金刚经的现代意义

    1994年春，应厦门大学青年禅学社邀请，开设《金刚经》系列讲座，在讲授的过程中，参考了几家古德权威注疏，玩味之余，颇有一些心得。当时列了一个提纲，拟撰写一篇有关《金刚经》的文章，因忙于其他事，未能写下去。一晃就到了年底，课程讲座都已结束，闲居无事，于是又打起《金刚经》的妄想，再次提笔，促成撰写此文的因缘。

一部家喻户晓的经典

    佛教的经典，在中国翻译流传的有数千卷之多，而流通最广、注疏最丰者，要算《金刚经》了。《金刚经》是般若系经典。般若经在东汉时期就已传到中国。魏晋南北朝盛行于教界，当时的中国文化界流行玄学，推崇老庄，崇尚虚无，与般若经典所说的空，表面上看上去颇为相似。于是那些玄学者，也就研究起般若经典来了。僧人为了弘法的需要，也以般若经教去迎合玄学，用老庄概念阐释般若思想，形成了般若学研究浪潮，出现般若学弘扬史上的辉煌时期，即六家七宗1。但因为般若经的翻译问题，当时人们对般若思想却不能正确理解。后来罗什弟子僧肇，就曾撰论对此作了批评2。
    罗什西来大量地翻译般若经论，在译出《摩诃般若》的同时，也译了与《般若经》相应的一些重要论典，如龙树的《大智度论》、《中论》、《十二门论》及提婆的《百论》等，对隋唐时期相继成立的各个宗派，都产生了巨大影响。吉藏创立的三论宗，就是直接依据《般若经》及龙树、提婆的《中论》、《百论》、《十二门论》为命名；天台智者创立天台宗，除了依《法华经》，许多重要思想也都来自《般若经》、《大智度论》。禅宗更不用说，下面专门介绍。
    《金刚经》在中国虽有多种译本，但最早的本子是罗什翻译的，而现在佛教界流行的也正是此本。大概是因为无论在语言的简练、流畅，或内容的忠实程度，其他本子都不能与之媲美，这才使它独行于教界。有的文人爱其文字之优美，而去读诵；有的文人喜其哲理丰富，而进行研讨；至于那些禅修者，更视《金刚经》为修心的指南，开悟的钥匙；而民间一般信徒也不甘落后，他们也以读诵《金刚经》为日常功课，并从中得到灵感。《金刚经灵感记》一书就是收集了从古以来读诵《金刚经》得到感应的例子。的确，这部经典太殊胜了，才使得人们乐于接受它，弘扬它。

http://www.jiqun.com


《金刚经》与禅宗

    达摩西来弘扬禅宗，在传授心地法门、顿悟禅法的同时，并推荐《楞伽经》作为禅修者的印心典籍。因此经名相丰富，说理繁多，译文生涩，对于修学顿悟的禅者来说，要去研讨它无疑是一大难题。因而到四祖之后，《金刚经》就逐渐取代了《楞伽经》的地位，四祖道信就曾劝人念“摩诃般若波罗蜜”3。五祖弘忍创东山法门，普劝僧俗读诵《金刚般若波罗蜜经》4。到了六祖惠能，与《金刚经》的因缘就更为密切了。

    一、《金刚经》与六祖惠能
    六祖惠能原是岭南一个樵夫，因为卖柴，路过街道，听到一户人家念《金刚经》，在心灵上产生了极大震动。从他后来见五祖时，与五祖两人的对话看来，惠能此时显然已开了智慧，只是没有大彻大悟而已，实在是宿慧深厚，来历不凡。
    随后，惠能取得那个诵经员外的资助，拜辞老母，便千里迢迢地来到靳州黄梅县东禅寺，参见五祖。经过一番往返考核，五祖对这位边远山区的年轻人，不得不另眼相看。于是就安排他到槽厂劈柴、踏碓。过了八个月多，五祖要传法退居了，就让门人各做一偈，以表自己在修证上的见地。惠能的偈子获得五祖的印可，并传其衣钵。在传法时，五祖又为惠能说《金刚经》，至“应无所住，而生其心”大彻大悟。惠能发心求法到得法，都没有离开过《金刚经》。
    惠能的悟道偈充分了体现般若性空的思想。般若讲性空无所得。《般若心经》曰：“无智亦无得，以无所得故，菩提萨埵，依般若波罗蜜多故，心无挂碍。”《金刚经》说：阿耨多罗三藐三菩提实无所得。六祖的悟道偈是：“菩提本无树，明镜亦非台，本来无一物，何处惹尘埃。”阐明的都是同一实质。
    六祖在弘扬佛法时，总极力称赞般若法门。《坛经》说：“师升座，告大众曰：总净心念摩诃般若波罗蜜。”又曰：“善知识，若欲入甚深法界，得般若三昧者，须修般若行，持诵《金刚经》，即得见性，当知此经功德无量无边，经中分明赞叹，莫能具说，此法门是最上乘，为大智人说。5”是说持诵《金刚经》功德无量无边，持诵《金刚经》能入甚深法界，见性成佛。

    二、《金刚经》对《坛经》的影响
    读过《金刚经》的人，再去接触《坛经》一定会有一种似曾相识的感觉。打开《坛经》的第二品，便是《般若品》。此品以解释“摩诃般若波罗蜜”为开头，展开了说法，接着显示般若的功用。祖曰：“凡夫即佛，烦恼即菩提，前念迷即凡夫，后念悟即佛，前念着境即烦恼，后念离境即菩提。6”从第一义上来看，凡夫与佛，烦恼与菩提，的确没有什么差别。可凡夫与佛存在迷与悟的不同：凡夫迷故，处处着境，没有智慧，因而便有烦恼；而圣贤以般若智慧通达诸法实相，不住于相，烦恼了不可得，当下就是菩提了。
    进入《定慧品》，六祖又依般若法门，提出禅门修行的三大纲领。祖曰：“善知识，我此法门，从上以来先立无念为宗，无相为体，无住为本。7”何为无念？《坛经》解释道：“于诸境上心不染着曰无念。于自念上，常离诸境，不于境上生心，若只百物不思，念尽除却，一念绝即死。”无念并非什么境界都不接触，或者什么都不想，而是在接触外境的时候，心不染着境界，如同明镜，境来则现，境去则无。显然，这与《金刚经》所说的“人住色声香味触法生心”，“应无所住而生其心”是一样的。何为无相？《坛经》告诉我们说：“外离一切相名为无相，能离于相则法体清净，此是以无相为体。”实相无相，但实相也并非离开万物，别有所指，这就需要有般若，以般若故不住于相，透过诸相，始能通达法性。《金刚经》也认为“实相者，即是非相”，“若见诸相非相，即见如来”。何为无住？《坛经》释曰：“念念之中不思前念，若前念今念后念，念念相续不断，名为系缚于诸法上，若前念不住即无缚，此是以无住为本。”心住于境，则是心为境所缚，倘不住于境，则解脱也。所以般若思想以无住生心，为修行的要领。
    对于坐禅，六祖从对般若法门的体验中，提出了禅家特有的方式。比如以往坐禅，禅者注重坐相，并对坐姿式及用心都有一定之规，而《坛经》中却呵斥坐相。经中记载：“有神秀弟子参访六祖，祖问：“汝师何为开示？对曰：常教诲大众住心观静，长坐不卧。祖曰：住心观静，是病非禅，常坐拘身，于理何益。听吾偈曰：生来坐不卧，死去卧不坐，一具臭骨头，何为立功过8。”从般若法门的无住前提看，禅者如拘泥坐相上的修行，本身就是住相，因为道乃无相，道遍一切处，应该从行住坐卧的一切举动中去体验。
    又在坐禅用心方面，小乘禅观讲究从六根门头摄一而入，系心一境。而《坛经》却叫我们坐禅，要心无所住。祖曰：“此门坐禅，元不执心，亦不执净，亦不是不动。若言着心，心原是妄，知心如幻，故无所着；若言着净，人性本净，由妄心故覆障真如，但无妄想，性自清净，起心着净，却生净妄，妄无处所，着即是妄，净无形相，却立净相，言是工夫，作此见者，障自本性。９”这是从见性、观实相入手，以无住为方便。定即是慧，定慧一体，同小乘禅观，由定而慧，显然不同。
    以上仅举几个比较明显的例子，其实《金刚经》对《坛经》的影响是全面的，而非部分，这有待于今后专门研究。


成佛是智慧的成就

    《金刚经》全称《金刚般若波罗蜜经》。般若是梵语的音译，之所以不译成华言，是因为中国词语中难以找到相应的概念。倘若一定要把它译出，那就勉强称曰“智慧”。
    梵语波罗蜜，译成中文包括两个意思。一是过程义，是指我们在完成一件事的过程，称曰波罗蜜，从这个意义上，古人译曰“度”，六波罗蜜又曰六度。一是究竟圆满义，是指一件事情彻底成就了，称曰波罗蜜，从这个角度，古人译曰“到彼岸”。
    六波罗蜜即布施、持戒、忍辱、精进、禅定、般若。六波罗蜜中的前五种，并非佛教所特有，比如布施，佛教固然倡导布施，其他宗教乃至社会也提倡布施；持戒、忍辱、精进、禅定，无不如此。那么，世间的布施与佛教的布施有何区别呢？世间的布施总是住相的，而佛法则要我们“不住色布施，不住声香味触法布施”。又世间布施有相则有限，佛法布施要不住相，无相则无限也。
    那么，造成两种布施差别原因在哪里呢？简单地说是般若。凡人般若未能开发，以妄心住相布施，将来只能招感人天果报；菩萨以般若引导布施，三轮体空，不住境相，布施就成为成佛的资粮。所以世间的布施等行不能称曰波罗蜜，惟有在般若引导下的布施、持戒、忍辱、精进、禅定等，才是成佛资粮，始可称波罗蜜。
    般若，经中说有三种：一、文字般若，即三藏十二部典籍，或者可以说，能够开发般若的一切文字，我们不妨称它为文字般若；二、观照般若，是依文字般若所显示的义理，以此思想观念去观察人生的一切现象，如实地透视一切，由正确的认识能通达实相，能生般若而称般若。三、实相般若，即般若的体相。三种般若实质上只是一实相般若，文字般若、观照般若都从能出生般若意义上，方便称为般若，实非真正般若也。
    般若又分实智与权智。实智是亲证宇宙人生真相的智慧，是般若之体。它无智无得、智境一如，没有差别，菩萨在修行过程中，经过了资粮位、加行位、通达位始证得。权智又称方便智或后得智，是了解现象差别，引导六度万行的智慧，是般若之用。权智是在证得实智后生起的，故曰后得智。在修学佛道上，实权二智缺一不可。
    般若波罗蜜就是说明般若在成佛中的重要性。众生在生死此岸，要到达成佛的彼岸，惟有依般若。《心经》曰：“三世诸佛，依般若波罗蜜多故，得阿耨多罗三藐三菩提。”三世诸佛都是依般若而成就无上菩提。《维摩诘经》曰：“智度菩萨母，方便以为父，一切众导师，无不由是生。10”一切诸佛都是以般若与方便二智为父母，由有般若，始能产生一切诸佛。又梵语佛陀，中文译为：智者、觉者。因此，成佛是乃智慧的成就。


日常生活中的修行

    东晋道安大师把佛经科为三分：即序分、正宗分、流通分。序分通常又有证信序、发起序两个部分。证信序是记述佛陀当时讲这部经典时的法会条件，各个经典在模式上基本相同，因而又称通序；发起序是佛陀讲这部经发起的因缘，经中或有或无，千差万别，故又称别序。
    发起序与经的内容往往关系非常密切。而不同的经典，发起因缘也各异，像《华严经》、《法华经》等，都是以放光动地，恒沙菩萨，百万天人云集为发起因缘。反过来看看《金刚经》，那就平常多了。经中记载：“尔时，世尊食时着衣持钵，入舍卫大城乞食，于其城中次第乞已，还至本处，饭食讫，收衣钵，洗足已，敷座而坐。”《金刚经》以日常生活作为发起因缘，它正体现了般若法门的修行风格。
    说到修行，通常很容易让人想到诵经、坐禅、礼拜等，总有一定的固定形式。诚然，我们不能否定这是修行，但如果从“修行”二字的意义去看，修行不只是局限在这上面。行是指身、口、意三业之行，我们的意业因为有贪嗔痴的关系，使得我们不断地造作杀盗淫妄等业。修行就是修正行为，在日常生活中表现为修正错误的思想、语言、行为，使之符合道德规范，使之与道相应。
    《金刚经》以显实相为宗。实相即诸法真实相。证得实相要离相，不住相。所以《金刚经》以无住生心为要领，表现在修行上也没有一定的固定形式，即就是要在日常生活的四威仪中修行。因为实相是无相的，是无所不在的，要通达实相自然不能住于某种相，而是要在日常生活处处离相无住，才能与实相相应。
    这就是后来禅家讲的道在日常生活中。那么，如何从生活中去体会道呢？禅家告诉我们，要有平常心，所谓平常心是道。何为平常心？马祖道一说：“道不用修，但莫染污，但有生死心造作趣向，皆是染污，若欲直会其道，平常心是道。何谓平常心：无造作、无是非、无取舍、无凡圣。11”道是现成的东西，只是因为被妄想执著所覆障，而不得显现。现在倘能去除染污之妄心，道就能自然显现。
    南泉禅师也有类似的开示。赵州问南泉：“如何是道？”泉曰：“平常心是道。”州曰：“还可趣向也无？”泉曰：“拟向即乖。”州曰：“拟向怎知是道？”泉曰：“道不属知不知，知是妄觉，不知是无记。12”道从平常心中证得，不可起心求道，起心者，如马祖所说的造作之心，是非之心，取舍之心，凡圣之心。凡人有了这许多心，早就与道相违了。所以南泉说：拟向即乖。另外道也不属于知与不知，凡人的知是妄觉，不知又处无记状态。总之与道都是不相应的。


《金刚经》解决什么

    学习佛法，首先应该知道佛法能解决什么问题。假如对此没有明确的认识，那我敢断定他一定还没能够树立正信。因为一个不清楚佛法能够解决什么问题的人，对于学佛是为什么这个问题一样也是搞不明白的。
    从《金刚经》来看，佛法是解决心的问题。当机者须菩提就向佛陀提出：“善男子、善女人，发阿耨多罗三藐三菩提心者，云何应住，云何降伏其心？”发阿耨多罗三藐三菩提者，是发菩提心，为修习菩萨道的根本；降伏其心则又是发菩提心所要达以的目的。《金刚经》就是围绕着这样一个前提而展开的。降伏其心，是《金刚经》所要解决的问题，也是整个佛法要解决的。从这个意义上看，佛法也不妨称为心性之学了。
    生活在这个世间的人，对自己的生存十分重视。为了人生的幸福，我们上学、寻求谋生的知识；工作，获得生存的财富；成家，建立情感的依赖；锻炼，造就健康的身体。这些虽与我们人生关系确实都很密切，但还有更重要而又最不为我们所注意的东西，那就是我们的心。在日常生活中，当我们遇到烦恼时，首先总会责怪环境，很少有人懂得去反省内心。其实，心才是根源。世界的差别是由于人类心的差别，因为心的不同，这个世界才有文明与野蛮、道德与罪恶、痛苦与快乐、善良与丑陋、清净与染污、光明与黑暗。
    我们要改造世界，获得人生幸福，无疑先要从心下手。大家知道，人类现代的物质文明，给人类生存带来了许许多多方便，今天我们所享受的物质条件，古代帝王做梦都不曾想过。但科技给我们带来便利的同时，也带给我们恐怖、不安。人类为满足自己的贪心，利用科技成果，制造那些杀伤性极强的武器，以此毁灭他人。广岛原子弹的爆炸，一座完整的城市，几百万人的生命在一刹那间就灰飞烟灭，多么可怕！科技本身没有善恶可言，它可以为人类造福，也可以用来毁灭世界，问题在于是谁来掌握它，拥有它的人有着一颗什么样的心灵。
    假如我们的心充满着贪婪、嗔恨、愚痴、我慢、嫉妒，那这个世界一定到处是战争、谋杀、偷盗、抢劫、强暴、欺骗。你想这将是一个多么险恶的世界；相反的，我们如果拥有惭愧、慈悲、道德、智慧，世界就会出现光明、和谐、安定的局面。一切惟心造，人们拥有什么样的心态，就会出现什么样的世界。
    心的健康与否，又直接关系到人生的苦乐。古人云：风月无今古，情怀各相异。便是说明这个道理。风与月永远是那样，但人们心境不同，所产生的感觉往往大异其趣。原因是什么呢？因为我们所谓的快乐，除了外在顺境这个因素，还需有主体的心灵去感受。当你感受时觉得快乐，那才是快乐；假如觉得痛苦，那就是痛苦。正像用同样的饭菜，健康时享用它，觉得可口香甜；病弱时食用，毫无味道。同样坐在椅子上，一个远行者坐下来休息，感到快乐无比；而看书写作者，因为坐的时间长了，觉得厌倦。看来一个人的快乐与否，实在不能从表面看，只有当事人才是最清楚的。
    拥有健康心境，是建立快乐幸福的根本。一个人倘若心境不好，有钱痛苦，没钱也痛苦；有地位痛苦，没有地位也痛苦；有爱情痛苦，没有爱情也痛苦；有事业痛苦，没有事业也痛苦。拥有良好心境，与上面所说的情况就截然相反了。那么，我们为什么不能有良好的心境呢？因为我们有烦恼，烦恼是扰乱内心宁静的因素。我们有烦恼，所以我们才活得不自在。
    《金刚经》提出降伏其心，就是要降伏我们内心中的不安定的烦恼因素。如何降伏烦恼呢？般若法门告诉我们，从通达空、无住入手。我们之所以产生烦恼，是因为六根缘六尘境界时，执我又执法，由我执法起贪嗔痴烦恼。如果能以般若智，通达我法空，不住我相、人相、众生相、寿者相；不住色声香味触相，那烦恼自然不生，其心自然降伏。


四相与人生

    读诵《金刚经》，经常会见到我相、人相、众生相、寿者相。这四种相简称曰四相。四相都是我相的不同表现形式，其实是一我相，或称我执。它与法执构成了世间的执著，是般若法门所扫荡的对象。
    我相，是四相的总称。众生在五蕴和合的生命体上，执有一个常恒不变的自我，以此因缘，在日常生活中，总有一种强烈的自我感，来支配着我们的思维和行动。平常我们总是特别爱自己的生命体，一个人忙于吃、忙于穿、忙于住、忙于成家、忙于事业，人生的一切努力，似乎都在为了生命体的延续。青年男女的恋爱，说我爱你，实质上也是基于爱自己，这是我爱。人都喜欢自以为是，总是觉得自己的看法是正确的，因而固执己见，这是我见。以为自己高人一等，摆出架子，要别人尊重他，即使不如人家，也不肯承认，这是我慢。众生由我痴，非我执我，起我见、我爱、我慢。
    人相，我们的生命体以人的形式出现，称曰人相。人有黑种人、黄种人、白种人；汉族人、满族人、傣族人；中国人、日本人、美国人。因为有了我，这就出现了人与人的界限、种族与种族的界限、国家与国家的界限。因为有了我，大家又都以自己为最优越，因而出现人与人之间的歧视，种族与种族之间的歧视，国家与国家之间的歧视。这就造成了人类社会不能和谐，不断引发战争。人又以万物之灵自居，觉得自己高于其他一切动物，以人为中心，觉得其他一切动物，都是为了人类生存方便而生存的，因而就不能平等地对待一切，任意宰杀众生，造下许多杀业，同时也破坏了自然界的生态平衡。
    众生相，生命体的构成，是由五蕴的假合。依此众缘聚成生命体，称曰众生。众生随着业力的不同，众生相也可谓千差万别。胎生、卵生、湿生、化生，是说生命体的四种不同受生形式；天道、人道、鬼道、地狱道、畜生道，是告诉我们生命形式的五大种类。就人道而言：有男的、女的；富贵的、贫穷的；健康的、病弱的；劳心的、劳力的；庄严的、丑陋的；善良的、邪恶的；胖的、瘦的等各种不同相。因为有了我相，众生之间才出现对立矛盾现象。
    寿者相，有情随着业力所招感的一期生命，从生到死这个过程，称曰寿者。人既然生到这个世界，他就希望永恒，永远都不死，尤其是功成名就的人，当他钱财地位都有了，他们简直不愿意死去，像古代帝王委托道士寻求长生不死之术，以求得长寿。希望我的生命体得以无穷尽的延续下去，这是寿者相；传统儒家有”不孝有三，无后为大“的观念，认为人必须生儿育女，传宗接代，继往开来，惟恐绝后，这是寿者相，因为这是通过子孙来延续自己的生命；有的人在社会上建立了一番功业，就希望他的事业能千秋万代地传下去，这也是寿者相。
    四相同是一我相。我相是一切烦恼生起的根本，如由我爱我的身体，我爱我的种族，我爱我的国家，我爱我的地位，我爱我的事业，我爱我的服装，我爱我的居住环境，我爱我的妻子儿女等，使我们的内心时时都处于牵挂状态，患得患失，终日不得自在，这是由我贪带来的烦恼；对于逆境产生厌离的心境，倘若不能离去，内心则出现不安、烦躁、愤怒、恼害等心理现象，这是因为我嗔而带来的烦恼；别人得到荣誉，尽管于我并无利害，但我却觉得难受，这是因为我的嫉妒而起的烦恼；有人侮辱我，伤害了我的自尊，使我很气愤，这是因为我慢造成的烦恼。
    五蕴假合的身体，不外乎物质与精神的两个方面。从物质看，由四大的假合，聚积为身体，离开四大，身体是什么呢？从精神看，心是经验的积集，由经验的延续，导致思维的延续。离开经验，思维又是什么呢？又五蕴生命体有我，那我与五蕴为一为异，假如是一，五蕴生灭，我也随之生灭；假如是异，五蕴与我就没有关系，那何以从五蕴中建立我呢？如此推求，五蕴之实质是无我的。
    五蕴无我，众生却偏偏执有我。由有我故，产生种种烦恼。为了我故，造种种业。佛经中讲无我相，就是要彻底打破我执，切断痛苦根源；又凡夫执我故，惟能自利，甚至损他利己。所以《金刚经》曰：“若有我相、人相、众生相、寿者相，即非菩萨。”


发菩提心与行菩萨道

    《金刚经》听众虽然是以须菩提为首的千二百五十声闻众，但佛陀在讲经时，却似乎是对着菩萨说的，所以《金刚经》体现的是菩萨道精神。
    说到菩萨，通常人们最容易想到的，不是供在佛寺大殿中的泥塑木雕的偶像，就是那些会呼风唤雨的神灵。仿佛菩萨都是来无影去无踪的，其实这是误会。梵语菩提萨埵，简称菩萨，汉译觉有情，是指已经觉悟而又能让人觉悟的有情，菩萨，是很现实中的人。在近代佛教史上，太虚大师就不称自己为比丘而称菩萨。台湾慈航法师人们也称他为菩萨。我们不妨这么认为，在现实社会中，能够无私地奉献到大众事业中者都具有菩萨精神。
    菩萨，在佛教中是大乘行者的称呼，以发菩提心为首要条件。何为菩提心呢？《金刚经》正宗分开头，是以此问题的提出作为发起，佛陀的回答是：“所有一切众生之类，若卵生、若胎生、若湿生、若化生、若有色、若无色、若有想、若无想、若非有想非无想，我皆令入无余涅槃而灭度之，如是灭度无量无数无边众生，实无众生得灭度者，何以故，若菩萨有我相、人相、众生相、寿者相，即非菩萨。”又曰：“菩萨应离一切相，发阿耨多罗三藐三菩提心。”
    从这段经文，可以看出发菩提心的内容，菩提心是发心形式之一，学佛首先要发心。世人根基不同，在学佛的发心上也往往各异，有以追求人天福报为目的，他们遵循着人天乘的思想，深信因果，止恶行善；有以解脱生死痛苦为目的，他们依照解脱的原理，发出离心，观察人世间的苦空无常，勤修三学，断除烦恼，证得涅槃；有以成就无上佛道为目的，他们发菩提心，修学菩萨道，不为自己求安乐，但愿众生得离苦，广行六度四摄，圆成无上佛果。
    大乘佛教鼓励我们发菩提心，因为一个人追求人天福报，不必学佛也能得到。像中国传统儒家提倡人伦道德。讲仁义礼智信之五种常德，如能严格遵守，也会不失人身；世间宗教如基督教、伊斯兰教等，都劝人行善止恶，博爱大众，能遵守这种教义也不失人天果报；不过人天福报再大，难免掺杂烦恼痛苦，何况福报享尽必然要坠落呢？而出世二乘虽然解脱了个人的烦恼痛苦，但仅能自利。惟有发菩提心才是最究竟而崇高的。
    发菩提心就是发广度众生之心，诚如经中所言：“所有一切众生之类，若卵生、若胎生、若湿生、若化生、若有色、若无色、若有想、若无想、若非有想非无想……”这是显示菩萨胸怀之博大，菩萨度生不是度一两个，而是以一切众生都作为自己救度的对象。
    这种胸怀的建立，当然要有大慈大悲的基础。何为慈悲呢？悲能拔苦，是将众生从痛苦中解脱出来；慈能与乐，给予众生快乐。以一切众生作为救拔对象，拔苦与乐，是为大慈大悲。又菩萨的慈悲称曰“无缘大慈，同体大悲”，无缘是说菩萨对众生的帮助，不存在任何条件与关系，不像世间的凡夫，当他帮助别人的时候，总会考虑到对方和我有无关系，我帮助了他，对我有哪些好处；同体是把自己与众生看为一体，众生的困难就是我的困难，众生的需要就是我的需要。如《维摩诘经》所说的：“以众生病，故我有病。”又如母亲看到爱子生病一样，菩萨对众生也是这样。
    从慈悲心出发，菩萨对众生的救度，大有救人救到底的味道。众生的苦痛无量无边，冷了给他衣穿，饿了给他饭吃，病了给医药，都可以解除众生的痛苦；政治的英明，经济的繁荣，学术的进步，也能减轻众生的痛苦。但如果没有拔除痛苦的根源，一切的帮助都只能是暂时的、局部的，终非彻底的救济。所以，菩萨的发菩提心，除了这些暂时的局部的帮助以外，还要以根本解脱的无余涅槃去救拔众生。
    涅槃，许多人可能会理解为是死亡的另一种说法，实际上并不如此。梵语涅槃，华言具有消除烦恼、解脱痛苦而得自在的意思。涅槃一词在印度，并非佛家所专有。俗人可以拍着吃饱的肚子说这是涅槃；有些外道，以四禅八定为涅槃，不知这是定境的自我陶醉，暂时安宁，不是彻底的。佛法说涅槃有二：一是有余依涅槃。通达一切法的寂灭性，离烦恼而得到内心的解脱。但由前生惑业所感的果报身还在，从身体而来的痛苦还未能解除，所以，即使是阿罗汉，饥寒老病的身苦，还是一样的。二是无余依涅槃。无学舍身而入无量无数的法性，不再有物我、自他、身心的拘碍，名为无余。无余涅槃是究竟解脱人生的一切烦恼痛苦。
    本经又告诉我们，菩萨的发心度生要建立在无我上。从有我与无我的区别上，也说明凡人与菩萨的不同。凡人有我，处处为我着想，即使发心利他。也不亡我相，总是带着功利色彩。因为有我，在利他时，首先就会考虑到自己的利益，这样就不能无限地利他，就不能无私地利他。所以经曰：”若菩萨有我相、人相、众生相、寿者相，即非菩萨。“
    菩萨发菩提心已，就是行菩萨道。菩萨道不同于声闻乘的解脱道。解脱道着重于自身的解脱，菩萨道则着重于利他。又解脱道是菩萨道的基础。由修习解脱道，解脱烦恼，身心自在，然后始能行菩萨道，广利人天。所以在《法华经》中，以三乘为皆一佛乘。现在汉传佛教的教义，忽略了人天乘及解脱道的理念及行持，结果造成了许多人学大乘经教，发小乘心。而在行为上，人天乘的德行也难以做到。
    菩萨道是从利他中完善自己。菩萨道的德行主要是六度四摄。由布施度悭贪，持戒度毁禁，忍辱度嗔恚，精进度懈怠，禅定度散乱，般若度愚痴。《金刚经》中关于六度的内容，主要在般若度的前提下，谈了布施与忍辱。
    经中佛陀对须菩提说：“菩萨于法应无所住行于布施，所谓不住色布施，不住声香味触法布施。须菩提，菩萨应如是布施，不住于相，何以故？若菩萨不住相布施，其福德不可思量。”布施这一法门，在《摄大乘论》中给它下了这么一个定义：“能克服悭贪，及能引得广大财富。13”布施与悭贪是对立的，有悭贪就不会有布施，修布施就能对治悭贪。布施又称为舍，不但要舍去外在的财富，更重要的是舍去生命内在的贪嗔痴烦恼及执著，放下一切，无牵无挂，这才是真正的布施。布施作为善因，又能引发广大财富。培植人间福德，要修布施；积集出世资粮，要修布施；成就佛道，利乐有情，更要修布施。
    布施有财施与法施。《金刚经》中曰：“三千大千世界七宝，以用布施”是财施；“恒河沙等身命布施”也是财施；“若复有人，于此经中受持乃至四句偈等，为他人说，其福胜彼”是法施。不论财施与法施都应无所住，即不住我相、人相、众生相、寿者相，不住色声香味触法，三轮体空。这样的布施，始可称曰菩萨道的布施。
    无住相布施的功德是不可限量的，经曰：“若菩萨无住相布施，其福德不可思量。须菩提，东方虚空可思量不？不也，世尊！须菩提！南西北方四维，上下虚空，可思量不？不也，世尊！须菩提，菩萨无住相布施，福德亦复如是不可思量。”
    布施有有相布施与无相而施，有相布施是有能施的我相、受施的他相及所施的物相。表现在行动上，比如有人出钱做点善事，惟恐他人不知道，在本院的一些法物器皿上，往往都有捐赠者的大名，他们希望他的大名，随着法物而留芳千古。住相布施者，总存有这方面或那方面的想法，发心不能很纯正，这样将来招感的果报，也必然是有限的，或是有缺陷的。而无相布施，泯除自他之相，三轮体空，以无限之心施舍他物，其功德自然也如同虚空，不可限量。


如何得见如来

    学佛的人可能都会关心这样的一个问题，佛陀是什么样子？如何才能见到佛陀？针对世间人的疑问，《金刚经》对这个问题，也作了阐述。
    在世间人的观念中，有以泥塑木雕的佛像为如来，见到偶像便谓见到如来。因此，一些人便认为佛教徒崇拜偶像，其实这是误解。须知佛教在初期并没有佛像，因为佛陀上兜率天为母说法，弟子们非常想念，当时弟子们为了慰藉对佛陀的思念之情，才有了雕像。现在佛教寺庙中，供奉佛像，主要是一种象征，表达佛弟子对佛陀的崇敬。同时也藉此见贤思齐。透过佛像的壮严；想念佛陀的伟大；通过有相的本像，而证悟法身的无相。
    可是，假如有的人把偶像当成如来真身，那就大错特错了。从前有丹霞禅师到一个寺院里挂单，因为夜里住在大殿中觉得很冷，就随手从佛座上请下几尊木像烧了烤火。这事被寺院中住持发现，惊讶不已，责问丹霞为何烧佛，丹霞禅师说：我在烧舍利？住持问：木佛焉有舍利？丹霞禅师说：没有舍利那就多烧几尊看。丹霞禅师的烧佛，除了说明佛教徒不崇拜偶像，不以偶像为真佛。当然，更重要的还在于破执，因为我们如果只知道大殿中的有相佛，执著于偶像，心外求佛，势必无法认识心中的无相佛。所以禅师说：“佛在灵山莫远求，灵山只在汝心头，人人有个灵山塔，好向灵山塔下修。14”
    佛陀三十二相，八十种好的庄严色身，也非如来真身。经曰：“可以身相见如来不？不也，世尊！不可以身相得见如来。何以故？如来所说身相，即非身相。”又曰：“可以三十二相见如来不？不也，世尊！何以故？如来说三十二相，即是非相，是名三十二相。”又曰：“佛可以具足色身见不？不也，世尊！如来不应以具足色身见。”又曰：“若以三十二相见如来者，转轮圣王即是如来。”不可以如来的庄严色身为如来，也不可以为见到如来色身，便是见到如来。原因是什么呢？如来身相虽无比庄严，却是缘生幻化之物，虚妄不实，终归败坏，在实相中一样是无少许法可取可得的。
    在佛经中记载：佛陀从忉利天下来到人间，弟子们云集到一起，大家都希望能够最先看到佛陀。依次序，比丘应在比丘尼之先，但莲花色比丘尼为了先见佛，即化作转轮王，走在最前面，她认为最先见佛了。但佛陀对她说：先见到我的不是你，是须菩提。原来，那次须菩提没有参加迎佛的盛会，当大家去见佛时，他想，佛陀曾说过，见法即见佛，于是在林中宴坐，观察实相之理，彻见了如来法身。
    不可以身相见如来。佛陀有三身：曰法身、报身、应身，法身才是真佛，报应身皆幻化。经曰：“如来者，即诸法如义。”诸法如义，如，是如实，本来面目的意思，这是说如来以诸法真实相为身。又曰：”如来者，无所从来，亦无所去，故名如来。“报应之身有来有去，如释迦的八相成道：降兜率、托胎、降生、出家、降魔、成道、说法、涅槃，都是化现。而在如来法身上，则无来去生灭。又曰：“离一切诸相，即名诸佛”，“若见诸相非相，即见如来。”都是说明了如来要离相，要透过相去认识，不可以住着于身相。
    明白了如来色身非真身已，进一步认识法身不是离开色身，不可以如来色声为如来；但也不可离开色身，另外去寻求如来。如来者，即诸法如义，就已经告诉我们了，如来真身是遍一切处的，只是我们是否具有认识的智慧。苏东坡的悟道诗：溪声便是广长舌，山色无非清净身。禅者曰：青青翠竹，无非般若，郁郁黄花，尽是法身。《肇论》曰：圣远乎哉，体之即神，道远乎哉，触事即真。15《维摩诘经》曰：“一切众生皆如也，一切法亦如也，众圣贤亦如也，至于弥勒亦如也。16”都是体现这个道理。一切都是般若，一切都是法身，一切都是实相。我们凡夫之所以不能认识，是因为执相，是因为没有能够认识的智慧。我们倘若不执相，不被世间的尘劳幻相所迷惑，远离虚妄分别，不起爱恶取舍，以平常心去对待一切，那么，我们就能与三世诸佛在一起。


《金刚经》的信仰

    佛法以信为能入，智为能度。整个佛法大纲不外乎信解行证四个部分。《大智度论》曰：“信如手，如人有手，入宝山中，自在能取；若无手，不能有所取。有信人亦如是，入佛法无漏根力觉道禅定宝山中，自在所取。17”信在学佛中的重要性可想而知。
    本经自称为难信之法，经中须菩提请问佛陀曰：“颇有众生得闻如是言说章句，生实信不？佛告须菩提：莫作是说！如来灭后后五百岁，有持戒修福者，于此章句能生信心，以此为实，当知是人，不于一佛二佛三四五佛而种善根，已于无量千万佛所种诸善根，闻是章句乃至一念生净信者，须菩提，如来悉知悉见，是诸众生得如是无量福德。”
    这段经文提出了《金刚经》的信仰基础。从修学佛法的过程来看，学佛首先要积聚资粮。资粮有二：一曰福德资粮，一曰智慧资粮。持戒修福是培植福德资粮；于千万佛所种诸善根则属智慧资粮。有了这些资粮，才有可能对般若法门产生信仰。
    又持戒修福乃至闻思经教，都可以摄入善根的范畴。善根是接受佛法的基础，从佛法看世间，万法各有因缘：所谓搞文学者要有文学的根基，搞哲学者要有哲学的根基，搞音乐者要有音乐的根基，搞书法者要有书法的根基。根基可以现生培养，也可以是过去生长期以来的积累。一个人倘若过去生中曾当过文学家，此生对文字就会产生偏爱；过去生是搞音乐的，此生对音乐则一学便知。所以在这个世界上有许多神童，苏东坡也说过：书到今生读已迟，也是这个道理。
    同样的，修学佛法也存在根基问题。有些人你磨破嘴皮去同他谈佛法，他总是不感兴趣，这是因为没有善根；有些人一闻佛法，便欢喜顶受，相见恨晚，这种人一定有善根；有些人接受了佛法，但日后遇到逆缘又退失信仰，这是因为根浅的关系；有些人信心道念坚固，无论在什么环境下，都很难使他改变信仰，这是根基深厚。那么，修学佛法者，惟有培植深厚的善根，才能在漫长的成佛之道中，勇往直前地走下去。
    本经直显诸法实相，产生信仰尤为不易。何况经中所说的信仰，又不是一般的信仰，是指净信。净信的含义，如经曰：“若复有人得闻是经，信心清净，则生实相，当知是人成就第一希有功德。”又曰：“其有众生得闻是经，信解受持，是人则为第一希有，何以故？此人无我相，无人相，无众生相，无寿者相。”破除我相，通达无我，妙契实相，方能于般若法门生起净信。难怪般若法门深信功德如此之希有，信仰如此之不易。


如何奉持般若法门

    对于甚深的般若法门，人们听闻受持之后，很容易产生执著，那么这种对经教的执著正确吗？
    须菩提尊者针对凡人疑虑，在经中向佛陀提出了这个问题。经曰：“世尊！当何名此经，我等云何奉持？佛告须菩提，是经名为金刚般若波罗蜜，以是名字，汝当奉持！所以者何？须菩提，佛说般若波罗蜜，即非般若波罗蜜。”这部经能洗破一切如金刚的戏论妄执，而使我们安住于清净所缘的实相中。然世间法有名义二者，名是能诠，义是所诠。但名能诠义，而名并不能亲证得义的自性，不过是世俗共许的符号。义是随名而转的，似乎可指可说，而义实不一定由某名诠表的。名不离义不即是义，义不离名而非即是名。有名有义的法，然法之实相，实不在名中，不在义中，不在名义之间，也不离名义。如此对于般若法门，如取相为如何，早就不是了。所以，佛说般若波罗蜜，即非般若波罗蜜。
    又曰：“若心取相，则为着我、人、众生、寿者。若取法相，即着我、人、众生、寿者。何以故？若取非法相，即着我、人、众生、寿者。是故不应取法，不应取非法。以是义故，如来常说：汝等比丘，知我说法如筏喻者，法尚应舍，何况非法。”我们修学般若法门，成就般若，通达实相，是不能着相的。
    如果我们取著我相，则起我执；取著法相，则起法执；取著非法相，则起空执。然而实相是离一切相，非有非空，非动非静，非生非灭，非善非恶。我们住着于奇相，那是有相，而非实相；住着于空相，那是空相，而非实相；住于动相，那是动相，而非实相；住于静相，那是静相，而非实相。般若实相离我、我所、有无等一切戏论妄执。《大般若经》曰：“菩萨不住法，住般若波罗蜜。”又曰：“一切法不信则信般若，一切法不生则般若生。”
    经中又喻经教如筏喻者，筏是竹筏，交通不便或水浅的地方，竹筏可用作交通工具。利用竹筏，就能由此岸渡到彼岸，到了彼岸，竹筏当然要舍去了，谁还能把它带着走呢？佛陀为济度众生，说种种法门，以法有除我执，以空相破法执，使众生得脱生死而到达无余涅槃的彼岸。当横渡生死苦海时，需要种种法门。但渡过中流，必须不执法、非法相，才能出离生死，到达彼岸。
    在这里使我想起了三论家的四重二谛：第一重，是以有为入谛，空为真谛；第二重，有空皆为俗谛，非有非空为真谛；第三重，以有空为二，非有非空为不二，二与不二皆是俗谛，非二非不二才是真谛；第四重，一切语言皆为世俗谛，言语道断，心行处灭方为真谛18。这四重二谛是层层深入，第二重是在推翻第一重，第三重又为推翻第二重，第四重又在推翻第三重。作者建立四种层次的二谛，其用意何在呢？主要还是为了破执。凡人闻有执有，闻空执空，闻亦有亦空则执亦有亦空，闻非有非空则执非有非空，四重二谛层层扫荡，亦可见作者用心之良苦也。


如何理解如来实无说法

    佛法僧三宝构成了佛教的全体。三宝中的法宝，是指三藏十二部经教。由法的久住，以法为核心，才能造成三宝在世间延续。
    法的存在是不容怀疑的事实，而佛陀说法四十九年更不容否认。然而我们打开《金刚经》，却多处说到如来无有说法。如经曰：“如来得阿耨多罗三藐三菩提耶？如来有所说法耶？须菩提言：如我解佛所说义，无有定法名阿耨多罗三藐三菩提，亦无有定法如来可说。”又曰：“须菩提！于意云何？如来有所说法不？须菩提白佛言：世尊，如来无所说。”又曰：“须菩提！汝勿谓如来作是念：我当有所说法，莫作是念，何以故？若人言如来有所说法，即为谤佛，不能解我所说故。须菩提，说法者，无法可说，是名说法。”
    对于《金刚经》的这种言教，我们应该作何理解呢？一、须知诸法真实相不可言说，《大毗婆沙论》曰：“若可说者，说火应烧舌，说食应除饥。19”说火不能烧舌，说食不能除饥，这是以名言离损益，曰不可说。《理门论》曰：“一切诸法皆有二相，一者自相，现量所得，不可言说；二者共相，比量所得，即可言说。”但言说并非表诠自体，只是遮诠止滥，如言青是遮非青等。这是以现量境不可说。《摄大乘论》曰：“复次云何得知如依他起自性，遍计所执自性显现而非称体？由名前觉无，称体相违故：由名有众多，多体相违故；由名不决定，杂体相违故。20”这是以名义相对假立，故不可言说。
    经中对于如来实无说法的解释曰：“如来所说法，皆不可取，不可说，非法非非法，所以者何？一切贤圣皆以无为法而有差别。”这是以真实法不可说。《维摩诘经》说到不二法门：前诸菩萨依自所解，各各大谈不二法门；文殊师利则曰：如我意者，于一切法无言无说，无示无识，离诸问答，是为入不二法门。于是文殊师利问维摩诘，我等各自说已，仁者当说，何等是菩萨入不二法门。时维摩诘默然无言。文殊师利叹曰：善哉，乃至无有文字语言，是真入不二法门21。《瑜伽师地论》中以不二为真实义22，入不二法门，即通达诸法真实相也。
    写到这里，不禁使人生起了这样一个疑问：一切法既然不可言说，世尊如何为他宣说呢？《瑜伽师地论》曰：“若不起言说，则不能为他说一切法离言法性，他亦不闻，若无有闻，却不能知此一切法离言法性，为欲令他知诸法离言法性，是故于此离言自性，而起言说。23”诸法实性是不可言说的，但不说，众生又焉知离言法性的存在。为令众生通达离言法性，不得已于无言中而起言说。
    如来无心说法，不说而说。这从《解深密经》中以得到答案。该经在《如来成所作事品》中说：“夫如来者，非心意识生起所显，然诸如来有无加行，心法生起，当知此事，犹如变化。曼殊室利菩萨复白佛言：世尊！若诸如来远离一切加行，即无加行，云何有心法生起？佛告曼殊室利：善男子，先所修习言便般若，加行力故，有心生起。善男子！譬正入睡眠，非于觉悟而作加行，由先所作加行势力，而后觉悟。又如正在灭尽定中，非于起定而作加行，由先所作加行势力，还从定起。如从睡眠及灭尽定心更生起，如是如来，由先修习方便般若加行力故，当知复有心法生起。24”
    凡人说法，都依心意识寻思而起，分别抉择而说。有说法的我相、听法的他相、及法相；地上菩萨虽通达实相，但说法时我相、法相犹未能泯；七地菩萨虽能无相说法，但尤有功用行。八地以后始达到无相，无功用行。其说法也，远离心意识寻思，譬如天鼓不敲自鸣，水月无心而现，无说而说。我们倘依凡人见地，去理解如来说法，觉得如来有法可说，有心说法，那岂非谤佛。所以经曰：如来无有说法。


从无所得中求证佛法

    佛法的体险应该从何处得入呢？这是每一个学佛的人都关心的问题。
    世间上的人，总是带着有所得的心在人生的舞台上生活着，他们不停地追求，希望得到知识，得到文凭，得到工作，得到财富，得到爱情，得到家庭，得到朋友，得到地位，得到态名誉，得到健康，得到长寿，得到成就等等。然而，接触了佛教，他们又带着同样的心态进入佛教，那些一般的信众，当他们在菩萨面前点上一炉香，摆上几个水果时，就向菩萨提出无穷无尽的要求，仿佛是在与菩萨做贸易似的。
    我经常在想着：世人不停地追求，无止境地占有，可是世间上到底有哪些东西能够究竟属于我们永远拥有呢？你看那些财富终归会消散，地位要失去，家庭会分离，情感会变化，朋友全反目，知识会落伍，乃至我们最亲爱的身体，并不会因为我们一直在忙于为它吃，为它穿，为它住，种种爱护，种种调理，它就永远地跟随着我们，而在几年或几十年之后，它必然也要离我们而去。
    《金刚经》说：“凡所有相，皆是虚妄。”凡所有相，是说世间的任何现象包括壮严的、丑陋的、染污的、清净的、平常的、神圣的、善良的、罪恶的等其实质都是一样的，那就是虚妄不实。因而，我们在修学佛法中，不能以有所得的心，去取著任何一种相。我们起心着相，这个心必然是妄心，那个相也必然是妄相，似有得，实乃无得。
    菩提涅槃是从无得中证得的。读过《心经》的人，我想一定都会熟悉这一句话：“无智亦无得，以无所得故，菩提萨埵，依般若波罗蜜多故，心无矨碍。”无智亦无得，是心空境寂，以无所得故，妄心妄境皆不显现，能所双亡，此时般若智始得现前。故《大般若经》曰：“一切法不生则般若生，一切法不现则般若现。”由般若现前通达诸法实相，消除二障，引导万行，自然成就阿耨多罗三藐三菩提。
    《金刚经》与《心经》在思想上同一体系。经曰：“世尊！佛得阿耨多罗三藐三菩提，为无所得耶？佛言：如是！如是！须菩提！我于阿耨多罗三藐三菩提，乃至无有少法可得，是名阿耨多罗三藐三菩提。”又曰：“须菩提！于意云何？如来于燃灯佛所，有法得阿耨多罗三藐三菩萨提不？不也，世尊！如我解佛所说义，佛于燃灯佛所，无有法得阿耨多罗三藐三菩提。佛言：如是！如是！须菩提，实无有法如来得阿耨多罗三藐三菩提。须菩提若有法如来得阿耨多罗三藐三菩提者，燃灯佛则不与我授记：汝于来世当得阿耨多罗三藐三菩提，是故燃灯佛与我授记。”
    在常人的观念里，以为成佛一定也是成就个什么东西，或者觉得得到什么。其实。这是错误的。佛陀在这里以自己的成就阿耨多罗三藐三菩提为例，说阿耨多罗三藐三菩提的成就，确实不是得到什么。如有某种真实有自性法，为如来能证得阿耨多罗三藐三菩提，那我就有我我所执了，燃灯佛也就不会给我授记。说我在未来世中作佛，号释迦牟尼。因为当时现觉我法性空，不见有能得所得，离一切相，燃灯佛这才为我授记。
    本经又举声闻四果为例。经曰：“须菩提！于意云何！须陀洹能作是念：我得须陀洹果不？须菩提言：不也，世尊！何以故？须陀洹名为入流，而实无所入，不入色声香味触法，是名须陀洹。须菩提，于意云何？斯陀含能作是念，我得斯陀含果不？须菩提言：不也，世尊！何以故？斯陀含名一往来，而实无往来，是故名斯陀含。须菩提！于意云何？阿那含能作是念：我得阿含果不？须菩提言：不也，世尊！何以故？阿那含名为不来而实无不来，是故名阿那含。须菩提！于意云何？阿罗汉能作是念：我得阿罗汉道不？须菩提言：不也，世尊！何以故，实无有法名阿罗汉。世尊！若阿罗汉作是念：我得阿罗汉道，即为着我人众生寿者。”
    从世俗世间来看，有果位高低之分，有断惑多少之分，有来去生灭之分。然而在平等的法性上，却无这许多差别。须陀洹，汉译入流；斯陀含，汉译一来；阿那含，汉译不还；阿罗汉，汉译无生。这些所谓的入流、一来、不还、无生，都是从世俗谛来说的。在法性中，岂有入与不入、来与不来、还与不还、生与不生的现象呢？诚如经中所言：我得阿罗汉者，即有我为能证，无生法为所证。倘若我法、能所的二见不除，就是执著我等四相的生死人，哪里还是真阿罗汉？
    最后我想用两个公案作为这段的结束。
    一、有学者参访禅者。问：道在何处？师曰：道在目前。问：我为何不见？禅师曰：有我故不见。问：禅师见否？禅师曰：有你有我辗转不见。问：那无我无你呢？禅师曰：无我无你又当谁见。从这段公案中可以得到两条启示：一、我相不除，不能见道。二、道不可以以我们世间的见与所见而论。
    二、达摩见梁武帝。帝问：云何是胜义第一义？达摩答曰：廓然无圣。帝问：对朕者谁？达摩曰：不识。禅者总是以本分事相见。在法性上，既不存在圣凡的区别，更没有识与所识的区别。这正体现了般若无所得的境界。


般若正观

    《金刚经》称曰《金刚般若波罗密经》，旨在反映般若在成佛中的功用，以般若而正观诸法实相，以般若引导万行。
    《金刚经》作为般若体系的经典之一，处处都表现出般若正观的作用。如经中所言：“如来说微尘，即非微尘，是名微尘。”“如来说世界，即非世界，是名世界。”“如来说三十二相，即非三十二相，是名三十二相。”“所言一切法者，即非一切法，是名一切法。”“如来说第一波罗蜜，即非第一波罗蜜，是名第一波罗蜜。”“所言善法者，即非善法，即名善法。”“如来说一合相，即非一合相，是名一合相。”“佛说般若波罗蜜，即非般若波罗蜜，是名般若波罗蜜”等等。这种三句的公式，几乎遍布全经。
    那么，这种三句的公式究竟蕴含着什么内容呢？在理解这个公式之前，首先要知道般若经教的核心思想－－缘起性空。佛法以为世间万物都是缘起。《阿含经》曰：“有因有缘世间集，有因有缘世间灭。”又曰：“诸法因缘生，诸法因缘灭，我佛大沙门，常作如来说。”又曰：“此有故彼有，此无故彼无，此生故彼生，此灭故彼灭。”缘起是因缘和合而起，因是亲的条件，缘为疏的条件，不论小如微尘，还是大如宇宙，无不是因缘的假合。缘起，说明了万物都是相互依赖的存在。
    诸法缘起的思想，佛陀在般若经教中，又作了进一步说明，即就是缘起性空。缘起已如上说的性空，是相对自性有而言。声闻乘中的有部，就是主张自性有。如《大毗婆沙论》曰：“我有二种：一者法我，二者补特伽罗我。善说法者，唯说实有法我，法性实有，如实见故。25”又曰：“诸法实体恒无转变，非因果故。26”又曰：“未来诸法集现在时，如何聚物非本无今有？现在诸法集散往过去时，如何聚物非有已还无？答：三世诸法，因性果性，随其所应，次第排立，体实恒有，无增无减，约依作用，说有说无。27”有部在分析世间诸法时，发现了事物只有单一不变的实质曰自性。此自性恒常不变，因而提出三世实有、法体恒有的自性有思想。
    可是依般若智来观察缘起现象，都无自性。如《摩诃般若波罗蜜经》曰：“舍利弗！一切法非常非无常。……色非常非灭，何以故？性自尔。受、想、行、识非常非灭，何以故？性自尔。乃至意触因缘生受，非常非灭，何以故？性自尔，以是因缘故，舍利弗！诸法和合生，无自性。28”又曰：“但有假名，都无自性。29”又曰：“诸法都无和合自性，何以故？和合有法自性空故。30”诸法由缘起故无自性，从缘起性空观察一切法，非常非灭。
    《大智度论》曰：“性名自有，不待因缘，若待因缘，则是作法，不名为性。诸法中皆无性，何以故？一切有为法皆从因缘生，因缘生则是作法；若不从因缘和合则是无法。如是一切诸法性不可得故，名为性空。31”自性是自有的，不待因缘而存在，倘若依因缘和合存在，那必然是没有自性。
    《迥诤论》说：“若法依缘起，即说彼为空，若法依缘起，即说无自性。诸缘起法，即是性空，何以故？是无自性故。32”《中论》曰：“如诸法自性，不在于缘中，以无自性故，他性亦复无。”又曰：“众缘中有性，是事则不然。”又曰：“若汝见诸法，决定有性者，则为诸法，无因亦无缘；未曾有一法，不从因缘生，是故一切法无不是空者。33”世间万事万物无不缘起，那么也无不性空，缘起与自性是对立的，不可相信缘起有，又承认自性有。
    明白了缘起性空的道理，从认识上就能建立中道的正观。在《中论》中有一首著名的偈子：“因缘所生法，我说即是空，亦为是假名，亦是中道义。34”这是从缘起法显示中道正观。缘起法是无自性的，所以但有假名；缘起法是无自性的，所以即是空。空，所以无自性，是假名的缘起。从缘起有、无自性空、幻化有中，建立中道的认识。
    中道是远离二边的。《中论》曰：“不生亦不灭，不常亦不断，不一亦不异，不来亦不去，能说是因缘，善灭诸戏论，我稽首礼佛，诸说中第一。”从缘起的中道正观，照见诸法，不落自性的生灭、断常、一异、来去的边见戏论。《大智度论》曰：“菩萨住二谛中，为众生说法，不但说空，不但说有；为着有众生故说空，为取着空众生故说是有，有无中二处下染。35”说空是为了扫除有见，说有是为了对治空见，远离二边之见，方能妙契中道实相。
    现在，我们再来回顾《金刚经》的三句公式。如“所谓世界”者，是说缘起的世界；“即非世界”者，是说世界的无自性的，空的；“是名世界”，世界虽然是无自性的，空的，但假相宛然。认识缘起而自性空，自性空而又然假有，这就是中道正观。《金刚经》告诉我们：对待一切的一切，乃至无比尊贵的般若经教，我们都应作如是观。


无住生心

    禅宗的六祖惠能，从听闻《金刚经》的“应无所住，而生其心”而悟道。无住生心，是般若法门修行的精要。
    无住是相对住着而言。世间的人有一个最大的特点，就是执著。他们总是处在不断执著状态中，如执著身体、执著服装、执著家庭、执著名誉、执著饮食、执著用具、执著财富、执著地位、执著友谊等等。由于对六尘境界的执著，使六根在缘六尘境界时，六识蒙尘劳的染污，以至我们原本清净的自心，失去清净。
    执使我们内心失去独立。生活在这个社会上的人们，为了生存的快乐，就要不停地去接独外境。这里我们不妨对一个世俗人，关于他的一天生活来个透视：他从早上起床开始锻炼，吃饭，上班，下班，吃饭，教育孩子，看电视，聊天，玩电子游戏，搓麻将，睡眠等等。可以这么说吧，一般的世间人，只要他还有感觉，身体或者精神总难平息下来。由于长期以来对外境的攀缘，使得渐渐对外境产生依赖，而内心不知不觉中就失去了独立。惟有在外境的刺激下，内心才会平衡，才能充实。
    执著于外境使我们迷失了自已。世间上的人，一天到晚关心的是什么？关心的都是生命以外的东西，那就是怎么样追名逐利，改善吃的、穿的、住的、用的。眼睛不停地追逐色相，耳根不停地追逐音乐，鼻子不停地追逐香味，舌头不停地追逐美味，身体不停地追逐好触。他们很少能够去考察生命的内在，只知道随着欲望而奔忙。由于一味执著外境，结果迷失了自己。因此现代人尽管生活在丰富多彩的物质环境中，依然感到空虚、失落、无聊、孤独。这都是因为迷失了自己的缘故。
    执著使我们产生内心的不安。经常听到许多人说：活得很累。又说这种累不是身体上的累，而是精神的负担。是啊！平常人只知道身体不能负担太重的劳动，却不知道无形的精神，也不能负担太重。那精神的负担是来自于什么呢？是执著。我看镜子，它之所以能够清晰地照一切影像而不留痕迹，为什么？因为它不执著。我们的内心具有镜子的功用，但又不像镜子。当我们的心在缘境界时，总喜欢对顺境进行执著，因为执著的关系，在思维上就留下负担，执著越强，负担就越重。这就使得我们产生很累的感觉；又因为执著的关系，外境的变化，随时都会引起我们内心的不安。所以，你别看许多人表面很神气，但内心里总有许多东西在困扰着他，始终活得不安宁。
    《金刚经》的修行，就是叫我们不执著。当然要做到不住，先要有般若正观的基础，认识到世间的缘起、无自性、空、幻化有。因为我们对诸法有了如实的观察，自然就不容易被世间的假相所迷惑。因而本经告诉我们：在度生时，不住我相、人相、众生相、寿者相，就能广度无量众生；布施时，要不住色生心，不住声、香、味、触、法生心，才能成就无限布施；发阿耨多罗三藐三菩提心，不住色身相，才能成就胜义发心；见如来时，不可以身相见如来，不住色身相，才能见如来真身；修福德时，明了福德者，即非福德，不住福德相，方能成就无量福德；菩萨壮严国土，不住壮严国土相等。经曰：“若菩萨心住于法而行布施，如人入暗则无所见，若菩萨心不住法而布施，如人有目，日光明照见种种色。”又曰：“若心有住，即为非住。”
    不住相的修行，能够消除我们心灵上的负担，能够使我们拥有一颗独立的心，能够使我们减少无谓的妄念，能够使我们解脱烦恼，能够使我们通达宇宙人生的真实。


《金刚经》的受持功德

    《金刚经》称：“当知是经不可思议，果报亦不可思义。”可见受持本经功德之殊胜。下面分别说明。

    一、增长福德：人生的幸福是基于福德。由有福德才能处处须遂，心想事成。受持《金刚经》能增长我们的福德。经中前后以三千大千世界七宝布施校量，恒河沙等七宝布施校量，恒河沙等身命布施校量，每日三时以恒河沙等身布施校量，又以佛陀曾经得值八百四千万亿那由他诸佛，悉皆供养承事的功德校量，都不及受持《金刚经》四句偈功德之大。因为财富的布施，身命的奉献，那都只能给人以短暂的帮助。而受持或为他人讲说本经，却能令正法久住，启发人们的正知正见，健全人的品德，引导他人向上增进以至解脱成佛，由此而得彻底的安乐，所以非财施所能及。

    二、消除业障：我们这个世界是业的世界，由于过去生中所造善恶业的不同，构成了世界的千差万别。因为我们无始贪嗔痴，造下过许多不善业，所以现实的生命总有许多缺陷及困扰，诸如天灾人祸，身体病弱，诸事不顺等等。受持《金刚经》却能消除业障。经曰：“善男子，善女人，受持读诵此经，若为人轻贱，是人先世罪业，应随恶道；以今世人轻贱故，先世罪业则为消灭，当得阿耨多罗三藐三菩提。”有些人没有受持《金刚经》本来平安无事，可受持本经之后，反而遭到他人的轻视，没有关系，这正是在业障。受持本经三途恶业都能消除，其它小业障就不必论了。

    三、开发智慧，通达实相：《金刚经》称曰般若波罗蜜，首要在于开智慧，《般若经》曰：“菩萨不住法，住般若波罗蜜。”本经处处教我们无住，无住是为了成就般若。经曰：“随说是经乃至四句偈等……何况有人尽能受持读诵，须菩提，当知是人，成就最上第一希有之法。”又曰：“若复有人，得闻是经，信心清净，则生实相，当知是人，成就第一希有功德。”成就第一希有之法，是乃成就智慧，通达实相。

    四、消除烦恼：《金刚经》中虽然不曾出现“烦恼”二字，但般若法门处处都在解脱烦恼。经曰：“无我相、无人相、无众生相、无寿者相。”四相乃烦恼生起的根本，消除四相，自然解脱烦恼。本经旨在成就智慧，智慧就是断除烦恼。住相能引起烦恼，本经要我们不住一切相，烦恼自然不生。

    五、成无上道：学佛是为了成佛，佛陀汉译曰觉者、智者，是智慧的成就。《心经》曰：“三世诸佛依般若波罗蜜多故，得阿耨多罗三藐三菩提。”本经曰：“一切诸佛及诸佛阿耨多罗三藐三菩提法，皆多此经出。”成就般若，方能成就无上佛道。


    注释：
    01、见汤用彤《汉魏两晋南北朝佛教史》第九章《释道安时代般若学》
    02、见僧肇《肇论》之《不真空论》
    03、见《指月录》卷四”道信传“
    04、见《六祖坛经·自序品》
    05、见《六祖坛经·般若品》
    06、见《六祖坛经·般若品》
    07、见《六祖坛经·定慧品》
    08、见《六祖坛经·顿渐品》
    09、见《六祖坛经·妙行品》
    10、见《维摩诘经·佛道品》卷七
    11、见《指月录》卷五”马道祖一传“
    12、见《指月录》卷十一”南泉普愿传“
    13、见《摄大乘论·彼入因果分》卷二
    14、见《指月录》卷九”丹霞天然传“
    15、见《肇论》之《不真空论》
    16、见《维摩诘经·菩萨品》卷四
    17、见《大智度论》卷一
    18、见吉藏《大乘玄论·二谛义》卷一
    19、见《大幽婆沙论》卷十五
    20、见《摄大乘论·所知相分
    21、见《维摩诘经·入不二法门》卷八。
    22、见《瑜伽师地论·真实义品》卷三十六
    23、见《瑜伽师地率·真实义品》卷三十六
    24、见《解深密经·成所作事品》卷五
    25、见《大毗婆沙论》卷九
    26、见《大毗婆沙论》卷二十一
    27、见《大毗婆沙论》卷七十六
    28、见唐译《摩诃般若波罗密经》卷七
    29、见唐译《摩诃般若波罗密经》卷四二二
    30、见唐译《摩般若波罗密经》卷四二二
    31、见《大智度论》卷三十一
    32、见旧译《迥诤论》（大正三二、一八上）
    33、见《中论》卷一、卷二、卷四
    34、见《中论》卷四
    35、见《大智度论》卷九十一


一部家喻户晓的经典
《金刚经》与禅宗
    一、《金刚经》与六祖惠能
    二、《金刚经》对《坛经》的影响
成佛是智慧的成就
日常生活中的修行
《金刚经》解决什么
四相与人生
发菩提心与行菩萨道
如何得见如来
《金刚经》的信仰
如何奉持般若法门
如何理解如来实无说法
从无所得中求证佛法
般若正观
无住生心
《金刚经》的受持功德
注释