封面

“中华佛典宝库”网站制作电子书
http://www.fodian.net


目录

下一页

《禅宗宗派源流》目录

第一章　禅宗之源——从达摩到弘忍
    一　诸说纷纭
    二　达摩前中土禅法
    三　从达摩到弘忍
第二章　曹溪一脉
    一、慧能求法
    二、六祖法乳
第三章　北宗正义
    一、神秀门庭
    二、秀门弟子
    三、法统之争
    四、南北分宗
第四章　南宗分灯
    一、荷泽神会
    二、马祖道一
    三、石头希迁
第五章　沩仰法脉
    一、怀海及《古清规》
    二、灵祐方圆默契
    三、慧寂默照为宗
    四、沩仰宗传承
第六章　临济法门（一）——临济宗的创立
    一、黄檗希运
    二、义玄禅风
    三、延沼传承
    四、省念承风接响
    五、汾阳善昭
    六、石霜楚圆
第七章　临济法门（二）——黄龙宗派
    一、慧南思想
    二、渊源和背景
    三、慧南禅风
    四、心理基础和师承
    五、传承与发展
    六、惠洪禅学
第八章　临济法门（三）——杨歧宗的建立
    一、杨歧宗的创立
    二、“三佛”禅法
    三、宗杲及“看话禅”
第九章　云门家风
    一、文偃机用
    二、雪窦中兴
    三、义怀宗乘
    四、宗本禅理
    五、契嵩新流
    六、灯灯续焰
第十章　法眼宗风
    一、文益创法眼
    二、法眼宗传承
    三、延寿振宗风
第十一章　曹洞法系（上）——唐宋时期
    一、三代催生
    二、曹洞开宗
    三、宋代曹洞宗
第十二章　曹洞法系（下）——元明清时期
    一、福裕少林系传承
    二、寿昌法系
    三、常润法嗣
第十三章　临济法门（四）——临济宗再次分流
    一、印简与“临济正宗”
    二、祖先与南方临济
    三、原妙及其禅法
    四、明本与看话禅
    五、元长与禅密一致
    六、圆悟复兴宗风
    七、法藏对看话禅的总结
    八、雍正与禅宗
第十四章　近代传承
    一、圆瑛禅净兼弘
    二、太虚融汇教宗
    三、虚云身承五宗
    四、来果传高旻禅风
    五、正果与禅悟体证
    六、明真心禅宗济世
    七、印顺禅史研究
附录
    附录I、中国禅宗宗派法脉传承图
    附录Ⅱ 近百年中国禅宗大事记
    附录Ⅲ 本书主要参考书目

《禅宗宗派源流》书后

下一页


一、诸说纷纭

第一章

    本世纪初，随着敦煌禅籍的发现和研究，禅宗及其宗派源流问题，日益引起世人的关注，尤其是中日佛教学者的高度重视。有关禅、禅学、禅宗的研究著作不断涌现，这就为深入研究禅宗宗派源流奠定了坚实的基础。

    一、诸说纷纭
    禅、禅学、禅宗是相互关联而又各不相同的一系列概念。禅是古印度宗教通过打坐使心念安定下来的实践。在释迦牟尼以前，印度即是以生天为坐禅目的的思想；至释迦牟尼时，始展开远能苦乐两边，以达中道涅槃为目的之禅。此后，印度佛教的禅观思想日趋发达，无数禅经应运而生。汉末传入中国的禅经，多系传承小乘承统的禅观思想，刘宋求那跋陀罗译出四卷《楞伽经》，即列愚夫所行禅、观察义禅、攀缘禅、如来禅四种禅。菩提达摩（即达摩多罗）所传（东晋佛陀跋陀罗所译）《禅经》所说自性清净禅。禅学是关于修禅定的学说，而禅宗则是以达摩为初祖、以直探以源、见性成佛为宗旨的大乘佛教宗派。中国禅宗的创立，有佛陀扇多说、达摩说、道信弘忍说、六祖惠能说、马祖道一说等。
    第一、佛陀扇多说。太虚大师持此说。太虚《与胡适之论菩提达摩书》说：“禅宗所奉为初祖的事实上人物，应是先在嵩山少林寺为魏君臣道俗举奉为大禅师的佛陀扇多。”其证据为：（一）奇异的禅风，为佛陀扇多后渐昌；（二）传达摩与流支不合，然此实为扇多与流支议《地论》不合之故事；（三）三祖神光——慧可，即传扇多禅的慧光律师，一名拆成二名。
    第二、达摩说。唐道宣最早持此说。他在《大通禅师碑铭》中列出达摩——慧可——僧璨的传法谱系；神秀则以僧璨——道信——弘忍——神秀上承于达摩；玄赜《弘忍传》载：忍临终（６７４，高宗咸亨五年）时说，弘忍的弟子，有十人可传其教法：（一）神秀；（二）资州智诜；（三）白松山刘主簿；（四）莘州惠藏；（五）随州惠约；（六）嵩山老安；（七）潞州法如；（八）韶州惠能；（九）扬州高丽僧智德；（十）越州义方；而玄赜自己受弘忍的托付，自然也应跻身十一位高足之列了。中国近代佛学专家汤用彤先生亦主张：“菩提达摩于梁武帝时来华，是为中国禅宗初祖。”近代日本学者忽滑谷快天即主张“菩提达摩以前印度非有禅宗，”“达摩之教旨有二入四行，其中理入思想之发达，六代相传，成泛神论之精髓，所谓纯禅时代是也。”他把菩提达摩看做中国禅宗的创始者，以其“二入四行”作为纯禅时代的标志。
    第三、道信、弘忍说。今人杜继文先生等持此说。他说：“从菩提达摩来华至隋朝的僧璨，可看作是禅宗的醖釀期；至唐朝的道信、弘忍、是禅宗的正式形成期；到慧能、神秀分立南宗、北宗及以后南宗独盛天下，都可以看作是禅宗的发展期，”认为“禅宗的真正发端者”是道信，使禅宗成为全国最大宗派的是弘忍，他论定禅宗的正式形成在道信、弘忍时期。
    第四、六祖慧能说。中国佛教界印顺、东初法师和日本禅师铃木大拙等均持此说。印顺法师说：“浑朴忠诚”、“简陋贫乏”，“确能树一代之风者，岭南虑慧能也。”东初法师说：“有六祖惠能大师，始有中国之禅宗也。”日本禅师铃木大拙说：“慧能是禅学史中的一位先驱，从某些方面来说，我们不妨将他视作中国禅的初祖。”一些日本学者亦认为中国禅的展开始于慧能门下乃为历史的事实，中国禅的真正展开，为青原行思与南岳怀让二法系。
    第五、马祖道一说。胡适之先生及令人潘桂明先生主此说。胡适先生本世纪以来对禅宗的史料的考证以及对达摩、惠能、神会的研究作了大量工作，在中外学术界有很大的影响。他在《论禅宗史的纲领》中说：“达摩一宗亦是一种过渡时期的禅。此项半中半印的禅，盛行于陈、隋之间，隋时尤盛行，到唐之慧能、道一，纔可说是中国禅。中国禅之中，道家自然主义的成分最多。道一门下不久成为正统。‘中国禅’至此始完全成立。”潘桂明亦认为：“马祖道一可以说是中国禅宗的真正代表之一，他的禅学在中国禅宗史上具有十分重要的意义，占有不可忽视的地位。”
    以上诸说纷纭，莫衷一是。尽管各有其侧重点，有其内在的立论根据，但都可作为研究的参考。我们认为，判断一个佛教宗派是否形成，主要看：（一）立宗者的宗旨，是否有比较系统的纲领、著作，是否有比较明确、一贯的宗旨；（二）该宗派是否有比较固定的、有组织的、有经常性活动的道场；（三）是否有比较独特的道风，开风气之先；（四）是否有系统的传承者。据此，我们认为：达摩为中士禅宗的开拓者，道信、弘忍对中国禅宗的建立有卓越的贡献；慧能为中国禅宗的实际创立者，而对于达摩以前之禅学也应给予足够的重视。茲先述达摩以前中土禅学之传承。


二　达摩前中土禅法

二　达摩前中土禅法

    中国禅宗之兴起，在达摩东渡以后；而达摩以前，中土就有禅学流行，这是学术、佛教界比较一致的看法。至于这一时期禅学的传承，太虚大师主张此期禅学为“依教修心禅”，将早期禅学分为安般、五门、念佛、实相禅四类；东初法师着重以安士高、鸠摩罗什、佛陀跋陀罗（觉贤）为代表；忽滑谷快天则以“祖师禅勃兴之准备时代”进行概括，分十二章进行论述。茲参照太虚四分法进行论述。
    （一）安般禅：依据安清（安士高）译《安般守意经》、《阴持入经》等经典，数息修禅，称安般禅。为汉、魏、晋初修习之禅法。
    安清，字世高（又作士高），安息国人（印度西北波斯，今伊朗土古国之王子），幼以孝行著称，父殁后，将王位让其叔，皈依佛门。后汉桓帝建和二年（１４８）经西域至洛阳，为佛教传入中国初期杰出的翻译家、禅学者。至灵帝建宁三年（１７０），共二十多年，译出经典三十四部四十卷，其有关于禅学者，如《大安般守意经》（二卷）、《禅行法想经》（一卷）、《大十二门经》（一卷）、《小十二门经》（一卷）、《禅定方便次第法经》（一卷）、《禅行三十七品经》（一卷）。世高“博晓经藏，尤精阿毗昙学，讽持《禅经》，略尽其妙。既而游方弘化，偏历诸国，以汉桓之初始至中夏，才悟机敏，一闻能达……于是宣译众经，改梵为汉，出《安般守意》、《阴持入经》、大小《十二门》及百六十品，初外国三藏众护选述经要为二十七章，高乃部析护所集七章，译为汉文，即《道地经》也。其也后所出经论，凡三十凡部，义理明析，文字公正，辩而不华，质而不野，凡在读者，皆亹亹而不倦焉。高穷理尽性，自识缘业，多有神迹，世莫能量。”世高译经，“为群译之首，安公以为：若及面禀，不异见圣！”可是对他译经、禅学评价之高。安世高精于阿毗昙学，主要传播小乘佛教说一切有部之毗昙学和禅定理论，为我国早期佛教的传播奠定基础，亦为将禅观带入中国之第一人。他专讲禅法的佛典《安般守意经》，是专门介绍安那般那禅（“安那”为出息，“般那”为入息，安那般那，简称安般，即呼吸，也就是“数息观”）；大小《十二门论》则介绍“四静虑”、“四无量”和“四无色定”三类禅法，重点在数息修禅，克服“贪、嗔、痴”三毒，超脱生死。弘扬这些禅法的，有汉末、三国南阳（今河南）韩林、颖川（今河南）皮业、会稽（今绍兴）陈慧、东吴（今江苏）康僧会，西晋竺法护，支愍度，东恶谢敷、道安等。
    安世高之禅法，是依禅师僧伽罗刹的传承，以四念住贯穿五门（即五停心）而修习。他从罗刹大本《修行道地经》抄译３７条，着重在身念住，破除人我执，另译大小《安般经》（经书将十六特胜和四念住相联击）。其所传禅法符合上座部佛教（特别是化地一派）用念住统摄道支的精神。晋道安见僧伽罗刹《修行道地经》（竺法护译）的全译本，又从六部《阿含经》的翻译上理会声闻乘的体系，对于安世高所译禅法有了更深刻的了解。他注解了这些译本，并一一作序，主要有《大道地经注》等七种。《大安般守意经》最重要，由康僧会注解、道安注释而行于世。
    （二）五门禅：依佛陀密译《五门禅法要略》而修五停观之禅法，叫五门禅。五停心，即对治多贪的不净观、多嗔的慈悲观、多痴的因缘观、散乱的数息观、多慢的五阴、十二入、十八界分析无我观。其中第五门，当时已改为大乘念佛观。此观论之甚详，有观顶上（或脐间）出一佛、二佛乃至五方五佛之别。念佛观，已成为后来求密法之基础。同时，鸠摩罗什译有僧护著《坐禅三昧经》，并自集《禅法要略》；觉贤译有达摩多罗《禅经》，安阳侯沮渠京声（居士）译有佛大先《禅秘要治病法》。玄高从佛陀受学，禅功甚高，深得时主敬信。魏孝文帝崇敬佛陀扇多，造少林寺授徒修禅。昙摩耶舍在江陵大弘禅业。僧稠从佛陀弟子道房修习禅法，佛陀赞为“葱岭以东修禅第一”。当时帝王欲专弘禅法，尽废经律，僧稠以“禅律相通”相谏，乃得免。可见，当时禅法已有相当的发展。
    觉贤译达摩多罗《禅经》，其内容，先列数息之法，次举种种过失，名方便道退；次列举昏沉、散乱等等障碍，名胜道退。于数息行进步为方便住，心得少分寂止而住，名胜道住。数息功夫熟而成就六妙门，为方便升进，暖、顶、忍、世第一法成，见道、修道、无学道，无色定、得八背舍、十一切入，光明充四体，从四体放光明，有入息三摩根，充满下方，出息三摩提，充满上方等功德，为胜道升进。数息从一至十，心定不乱；或舍二出息，数次入息，如是次第，数十之入息，心意不乱，或越十之出息，数次之入息，至十不失至念，于数息得自在，觉知其长短，全十六特胜为方便道决定。观察四大之损坏有情无情，知三界诸法皆苦，证四谛理，不失清净心，为胜道决定。次说不净观之退、住、升进、决定，详说四禅、五神通、四无量三昧，观五阴，观六入，观十二因缘。其思想中核为小乘，而兼带大乘之风。
    沮渠安阳侯，是河西王蒙逊之从弟。少时尝流流沙到于阗国，于衢摩帝大寺，过天竺法师佛陀斯那，谘问道义，佛陀斯那本学大乘，天才秀出，能诵半亿偈，明了禅法，西方诸国称他为“人中师子”。安阳侯从其学《禅要秘密治病经》胡本，口诵通利，东归河西后，译出汉文《禅要》。数年后，魏拓跋步伐凉州，安阳宗国殄灭，遂南奔于宋，游上塔寺，以居士自毕。
    玄高（４０２－４４４），生于后秦弘始四年（４０２），十二岁出家，十五岁为山僧说法，受戒后专精禅律，后往石羊寺拜佛陀跋陀罗为师，旬日而入其堂奥。乃杖策游西秦，隐居麦积山，从昙无毗禅师受学，得其真传。后无毗西返舍夷，有二恶比丘诬玄高“蓄聚徒众，将为国灾。”玄高被摈，往河北林阳堂山。高徒众三百，禅慧弥新，入堂者十二人，后河南王及太子采纳昙弘法师之言，赫然悔愧，即遣使迎高迁还邑，尊为国师，河南化毕，进游凉士，沮渠蒙逊深相敬事。时西海有攀会僧印六，从高受学，志狭量褊，得少为足，便谓已得罗汉，顿尽禅门。高乃密以神力，令印六于定中，备见十方无极世界诸佛所说法门不同，印六于一夏寻其法门，永不能尽，方知定水无底，大生惭愧。后随魏拓跋寿舅阳平生杜超达平城，大流法化。太子拓跋晃事高为师，见一时被纔，为父所疑；崔皓、寇谦之先得宠于寿，恐晃篡承之日，夺其威柄，乃谮云：“太子实有谋心，故勾结玄高；若不诛除，必为所害。”寿大怒，收高。高密与弟子云：“佛法应衰，吾与崇公首当其祸乎！”遂与凉州沙门慧崇于太平五年（４４４）九月同被害，时高年仅四十三岁。太平七年（４４６年）寿毁灭佛法。
    禅法传入中土初期，一方面凭借其究竟解脱法门，吸引徒众，另方面间或也借助其神秘的定力、奇异神通，增加其吸引力。这样一来，与道家蜕化、服食、以呪术摄众难免发生冲突，乃至引起道士妒忌，引发教权之争，导致统治者的偏听信而毁佛。僧稠修定，略显其神通，亦是一例。
    僧稠（４８０－５６０）俗姓孙，原出昌黎，后居巨鹿之瘿陶，性度纯懿，孝信知名，而勤学世典，备通经史，征为大学博士，讲解墳索，声盖朝廷。后一览佛经，涣然神解。年二十八，投巨鹿景明寺僧是法师出家落发。初从跋陀之神足道房禅师受行止观。既受禅法，北游定州嘉鱼山，旬日摄心，果然入定，常依涅槃圣行念处法，乃至眠梦觉见，都无欲望。居五夏，又诣赵州漳洪山道明禅师，受十六特胜法，钻仰积年，节食鞭心，九旬一食，米惟四斗。或煮食未熟，摄心入定，动移晷漏，前食并为禽兽所忠敢，又常修死想，遭贼怖之，了无畏色，受戒而返，尝于鹊山静处，感神来烧，抱肩筑腰，气嘘顶上，稠以死要心，因证深定，九日不起，后从定觉，情想澄然，究略世间，全无乐者，便往少林寺参谒跋陀禅师，呈已所证。跋陀曰：“自葱岭以东，禅学之最，汝其人矣。”乃更授深要，即住嵩岳寺，僧有百人。后诣悟州西王屋山修习前法，肯青罗山，屡入定，每以七日为期。又移怀州马头山，魏孝明帝夙承令德，前后三召，乃辞；魏孝武帝永熙元年（５３２）既召不出，亦于尚书谷为立禅室，集徒供养。又北转常山定州，燕赵之境，道味通被，齐文宣天保二年（５５１），诏令师赴邺教化，逐拂衣出山。稠年过七十，神宇清旷，帝扶接入内，为论正理，因说三界本空，国土亦尔，荣华世相，不可常保，广说四念处法，帝闻之，即受禅道，不久便证深定，停止禁中四十余日。天保三年（５５２），又勅于邺城西南八十里龙山之阳为构云门寺以居之，兼为石窟大寺主，两任纲位，练众将千，供事繁委，充诸山谷。又令国内诸州别置禅肆，令达禅念慧者，就为教授，时扬讲诵。帝以国储三分之一供奉三宝，常率其羽卫，故幸参观，稠处小房宴坐，都不迎、送。黄门侍郎李奘与诸大德请示禅要，因为撰《止观法》（二卷）。齐乾明元年（５６０）四月无疾卒于山寺，春秋八十一。初勅造寺，面方十里，令息心之士问道经行，稠曰：“十里太广，损妨居民，恐非远济，请半减之。”勅乃以方五里为定。暇日，帝谓：“弟子未见佛之灵异，颇得睹不？”稠曰：“灵异之事非沙门所宜。”帝强之，乃反袈裟于地，帝使数十人举之不能动，稠命沙弥取之，初无重焉，因弥笃信。
    （三）念佛禅：指为修习禅定而念佛的法门。后汉末，与安世高同时，支娄迦译《首楞严三昧经》，亦是弘扬念佛三昧法门的，道安以前，有僧显禅师在禅定亲见弥陀，住生净土。道安法师修安般禅，后又称弥勒名，誓生兜率，所以念佛禅在慧远前已有萌芽。
    庐山慧远专主念佛禅。慧远（３３４－４１６），山西雁门楼烦人。年十三，随舅令孤氏游学河南许洛，专通六经，尤善老莊，二十一岁入山西太行、恒山，听释道安讲《般若》，豁然有悟，乃叹曰：“儒道九流，皆粃糠耳！“与弟慧持落发为弟子。后与同学四百多人，随道安往襄阳。前秦建元十五年（３７９），苻坚军陷襄阳，偕道安返长安。慧远别师，弟子数十人往荆州，住上明寺。东晋太元六年（３８１）始入庐山，驻足西林寺，江州剌史桓伊于太元十一年（３８６）在庐山东建东林寺，充慧远息心之所。太元十六年（３９１）请僧伽提婆至庐山译经，翌年遣弟子支法领等往西域求经。慧远声望远闻，四方僧俗不期而集。初经流江东，多有未备，禅法无闻，律藏残缺，远乃令弟子法净、法领等远寻众经，逾越沙雪，旷岁方反，皆获梵本，得以传译。昔安法师在关，请昙摩难提出《阿毗昙心》，其人未善晋言，颇多疑滞。后有罽宾沙门僧伽提婆博识众典，远请重译《阿毗昙心》及《三法度论》，于是二学乃兴，并制序标宗，贻于学者，孜孜为道，务在弘法。每逢西域一宾，则恳恻谘访。闻罗什入关，即遣书通好。外国众僧咸称汉地有大乘道士，每至烧香礼拜，辄东南稽首，向心庐岳。东晋元兴元年（４０２）七月，以刘遣民等十八贤为上首，同志一百二十三人，在般若台精舍弥陀佛像前，立誓共期生西方而修念佛三昧，即庐山白莲社，为结社念佛的首创。翌年，桓玄于江东称王，令沙门跪拜王者，慧远撰《沙王不拜王者论》以驳之。又著有《大乘大义章》、《大智度论要略》、《法性论》，对于般若的流通亦甚致力，效师道安弘宣般若，又与鸠摩罗什及佛陀跋陀罗唱和。对禅法颇有影响。慧远卜居庐山三十年，未尝下山，送客亦足不过虎溪，东晋义熙十二年（４１６）八十三岁入灭。其参禅念佛，不是口唱念佛，而是一心专念，止寂他想，则鑑照之智自发，而得观见佛之境界，他弘通念佛禅而开禅净一致之端，为后世念佛禅之祖。
    而鸠摩罗什（３４４－４１３）则译出《大品般若》、《法华》、《中论》、《百论》、《十二门论》、《禅经》等，门徒八百余人，盛唱空宗，什之父鸠摩炎从天竺来居龟茲，被尊为国师，娶龟茲王妹而生罗什。什七岁随母出家，诵习毗昙，九岁随母至罽宾，遇盘头达多受《阿含》，以后才为国土所重。十二岁母携归龟茲。至沙勒国停一年，学《毗昙论》，受《六足论》。时有须利耶苏摩深通大乘，罗什师之而究明摩诃衍，受诵《中论》、《百论》等。既而被龟茲王迎归，弘演空宗。其母独往天竺，而什留龟茲诵大乘经论，升座说法，道誉远闻。前秦建元十八年（３８２），苻竖遣吕光大破龟茲，获罗什。弘始三年（４０１），秦王姚兴遣使迎什，同年十二月二十日入长安，以国师礼什，于西明阁及逍遥园从事译经，释睿、僧肇等八百余人咨受其旨，笃信之士请于长安译出众经。于是义学沙门云集，受业者三千余人。弘始十五年（４１３）入寂于长安大寺。所译经主要有：《摩诃般若波罗蜜经》（四十卷）、《小品般若波罗蜜经》（十卷）、《金刚般若波罗蜜经》（一卷）、《摩诃般若波罗蜜大明呪经》（一卷）、《妙法莲华经》（八卷）、《维摩诘所说经》（三卷）、《梵纲经》（二卷）、《大智度论》（一百卷）、《中论》（四卷）、《百论》（二卷）、《禅法要解》（二卷），《禅经》（与《坐禅三昧经》同，（三卷），《禅法要》（一卷）、《禅秘要经》（三卷）、《思维要略法经》（一卷）等。
    僧肇，道生是罗什门下最有力的两大弟子，僧肇（３８４－４１４），京兆人，家贫，以备书为业。遂因缮写，乃历观历史，备尽墳籍，志好玄微，每以老莊为心要。尝赞《老子》“美则美矣……猶未尽善”，后见旧《维摩经》，“始知所归”。其著《涅槃无名论》曰：“会万物为已者，其惟圣人。”又说：“净名曰：不离烦恼而得涅槃；天女曰：不出魔界而入佛界。然则玄道在于妙悟，即真则有无齐观，齐观则彼已莫二，所以天地与我同根，万物与我一体。”其《物不迁论》，倡动静一如，事理不二妙谛，与禅定“现实即实在”同一旨趣。其《宝藏论》妙悟于言外，古今独步。其《维摩经注》说：“终日说而未尝说也，终日闻而未尝闻也，”即禅家“不以一法示人”；“诸有所作，举足下足，当知皆从道场来”，是“佛法即世间法”的妙谛；其言“行净则从生净，众生净则佛土净”，为禅家“惟心净土”之极则。这些，都说明僧肇之学对后世影响甚大。
    道生（３５５－４３４）为罗什另一大弟子。本姓魏，钜鹿（河北平乡）人，寓居彭城（江苏铜山），家世仕族。幼而颖悟，后归依沙门竺法汰，年在志学，便登讲座。年至具戒，初入庐山七年，钻研群经，万里随法不惮疲劳。后与慧睿、慧严同游长安，从什公受业，还都止青园寺，校阅真俗，研思因果，乃立善不受报、顿悟成佛之旨。又著《二谛论》、《佛性当有论》、《法身无色论》、《佛无净土论》、《应有缘论》等，笼罩旧说，妙有渊旨，时六卷《涅槃经》先到京都，道生剖析经理，洞入幽微，乃倡“一阐提人皆得成佛”，孤明先发，独见忤众，被摈而遣之，自认所说与实相不相违，遂拂衣而去。初投虎丘山，销影岩岫，山中僧众咸共敬服。后大本《涅槃经》至南京，果称“阐提悉有佛性”，与前所说合若符契，乃升座讲说，听众莫不悟悦，宋元嘉十一年（４３４）逝于庐山精舍法座，京邑诸僧内惭自疚，追而信服。
    庐山慧远之后，专主念佛禅者，后有昙鸾、道绰、善导承其绪。昙鸾法师（４７６－？）因讲《大集经》而致病，乃欲修得长生，再弘大集。他本为北魏人，因求长生术，故至南朝梁地，时南朝人以为他是奸细，乃报于梁武帝。帝因请其说法，并问南来之意，鸾谓南方有为练气修仙所宗之陶隐居（陶弘景），欲从之而修长生。武帝乃吸其往访陶隐居，得长生术，又返北方。在洛阳遇菩提流支，流支菲薄中国仙术而授《观无量寿经》，并谓依此必得长寿。鸾法师遂焚仙术，回河西专修《无量寿佛》法，广弘传之。隋进道绰法师原修习禅定，因读鸾法师遣著，遂决定专修净土，持久念佛。此念佛法门唐朝时则善导法师弘扬最盛，后为日本净土宗所继承。
    （四）实相禅：即依《般若》、《法华》修空观（实相观）之禅法。名出罗什《禅法要略》。罗什传述禅之观法，用为实地修行的，则为慧文、慧思、智头诸师相承，立中道实相禅。
    北齐慧文（约在５３５－５５７前后）禅师，学徒数百，众法清肃，道术高尚。慧思（５１４－５７７）乃往依止。慧文依《中论》、《智论》而修禅，《中论》从空、假、中的理境上修观；《智论》倡“三智一心”，即以一心的三观一境的三谛，一境三谛即诸法实相，一心三观即是实相禅。慧思从慧文修学，发八触而得初禅，后放身倚壁未至壁顷，忽然悟入法华三昧，深达实相，遂弘法于南朝。陈光大元年（５６７年）至南岳，称前生曾居此处，于故地建“三生塔”，当岳心建般若寺。后帝迎之至栖玄寺，问辩佛理，师示众曰：“道源不远，性海非遥，但向已求，莫从他觅，觅即不得，得亦不真。”陈大建九年（５７７）六月唱佛坐逝南岳，寿六十上岁。为法华三祖。
    智头禅师（５３８－５９７）字德安，生荆州华容陈氏家，十八岁出家，初谒大苏山慧思禅师，即示普贤道场，为说四安乐行。诵《法华经》，见灵山一会，俨然未散，乃辞思游化。陈大建七年（５７５）抵建康瓦棺寺，创弘禅法，集一切禅法之大成。仆射徐陵、尚书毛喜等贵望并禀禅旨。陈宣帝诏师居光宅寺；隋开皇九年（５８９），憩庐山。后过衡峰，届荆部留玉泉寺。开皇十七年（５９７）归寂于台又石城寺。大师造大寺三十六所，命写经十五藏，著经疏百余卷，造佛像八十余万躯，度僧一万五千人，五十余州道俗受菩萨戒者不可胜纪。在陈隋有很大影响。
    以上四种禅法，大体上都是依佛教经典而修之禅法，故名“依教修心禅”，这些禅法都离不开如来佛典，故可称为如来禅，不同于师徒授受、以心传心、不立文字的“祖师禅”。这些禅法与有一定宗旨、道场、道风、传承的禅宗，更有很大的距离，但它又为禅宗的创立奠定了基础。第一、它们都有一套特定的修禅定的方法和观想方法，如安般禅、五停心观等，为后来的禅宗所继承。第二、其渐悟、顿悟之说，为后来禅宗的建立做了理论的准备，乃至后来随着禅宗的发展，南北分宗，南北顿渐之争，都与此有密切的关系。第三、以般若智慧（“慧”）与禅定（“定”）的密切结合，为禅宗的建立和发展从教理上打下基础。禅宗主定慧双修。定而无慧，则易走火入魔，陷入邪定：慧而无定，则不能成就功德，无法真正得到解脱。依《中论》、《智论》、《法华》、《维摩》而修实相禅，为二者的结合提供了现实的可能。这些，对于从宗旨、道风、道场、传承上创立禅宗都是必不可少的准备条件。


三　从达摩到弘忍

三　从达摩到弘忍

    达摩南来，以《楞伽》传宗，倡教外别传之心宗，并传法慧可，为禅宗的初创时期。慧可后传僧璨，于道信、弘忍，禅宗始略具规模。
    在禅宗创始人诸说中，一个重要问题是：究竟达摩是否实在其人？他是否中土禅宗的初祖？
    我们认为，从历史资料考察，历史上确有达摩其人，他是中国禅宗之源头。
    （一）达摩其人：
    菩提达摩，最早见于史传的，当推后魏杨衒之撰《洛阳伽篮记》（成书于５４７年）。《记》云：“修梵寺，有金刚，鸠鸽不入，鸟雀不栖。菩提达摩云：得其真相也。”其真相，当指佛土清净庄严，一尘不染。又说：“永宁寺，熙平元年（５１６）太后胡氏所立也。……殚土木之功，穷造形之巧。佛事精妙，不可思议。时有西域沙门菩提达摩者，波斯国胡人也，起自荒裔，来游中土；见金盘炫日，光照云表，宝铎含风，响出天外，歌咏赞叹，实是神功。自云年一百五十岁，历涉诸国，靡不周徧，而此寺精丽，阎浮所无也。极佛境界，并未有此。”达摩“口唱南无，合掌运日”。作者杨衒之反对佛法（唐初传奕引之入《高识传》，见《广弘明集》卷六），但与达摩同时，且当时无禅宗之传说。这样一个并不太信佛教的人，记叙达摩赞叹水平寺，可见其说当比较客观，达摩确有其人。
    唐道宣（５９６－６６７）《续高僧传》说：“菩提达摩，南天竺婆罗门种……通微彻数，定学高之，……初达宋境南越，末又北度至魏，随其所止，诲以禅教。……自言年一百五十余岁，游化为务，不测于终。”道宣虽晚于达摩、杨衒之一百多年，但其时尚无禅宗派系之争，且其治史“仰托周访，务尽搜扬”，史料比较可信。
    据有关比较可信的资料，达摩的生平和学说当如下：菩提达摩，南天竺人（或波斯人）。历游诸国，南朝宋末达南越，初在江南，后游嵩洛。在洛阳见永宁寺之壮丽，叹为各国所无，口唱南无，合掌连日。一生随处诲人禅法。北地道育、慧可从之受学，达摩为之说二入四行。谓入道多途，要惟二种：一是理入，二是行入。借教悟宗，深信含生同一真性，客尘障故，令舍妄归真，凝住壁观，无自无他，凡圣第一。坚信不移，不随他教，与道冥符，寂然无为，名理入也。行入四行，万行同摄，初报怨行，或遇爱憎，甘心受之，是我宿作，都无怨怼。二随缘行者，谓于一切境，无喜无怒也。此二入四行，后人录之行世。又尝以《楞伽》授学者。自云一百五十岁。天平年（５３４－５３７）前灭化洛滨，或云遇毒卒。其著作传有《少室六门集》上下卷（包括《心经颂》、《破相论》、《二种入》、《安心法门》、《悟心论》、《血脉论》）；另有敦煌出土的《达摩和尚绝观论》、《释菩提达摩和尚无心论》、《南天竺菩提达摩禅师观门》等。当系后人伪托之作。
    达摩对禅宗初创的贡献在于：第一、以《楞伽经》和“二入四行”的理论中“诸佛心为宗”作为立宗的宗旨和经典依据。不同于“依教悟心禅”时期以某些经典修习禅法、禅观的作法、禅观的作法，具有划时代的开拓意义。第二、以面壁修禅的“壁观”为独特的修持法门。第三、以不立文字，教外别传，师徒授受的形式传法于慧可。这三点是其主要贡献。正因为如此，菩提达摩作为禅宗之源、禅宗的初创者，于禅宗历史上有崇高的地位，是毋容置疑的。当然，由于他还没有建立自己的固定道场，而是隐居深山，行头陀游方的苦修生活，所以当时还不具备完整形态的禅宗。而他作为建立禅宗的开拓者、先驱者、开山祖师，是当之无愧的。
    至于禅门广泛流传的释尊在灵山会上拈花、迦叶微笑的典故，以为禅宗的滥觞，此虽未见史实根据，但北本《涅槃经》卷二说：“佛告诸比丘，有无上正法传嘱摩诃迦叶，迦叶当为诸比丘之大依止，犹如如来为众生之依止处。”或即释尊拈花、传法迦叶说之所本；从迦叶传至达摩，西天二十八祖之说，亦颇具传奇色彩。从佛教信仰角度说，这都是确信无疑的，详情待考。
    （二）《楞伽》传宗
    达摩来华，以四卷《楞伽经》传宗。玄匮一系的净觉作《楞伽师资记》，列楞伽师的传法系统是：慧可——僧璨——道信。《续高僧传》卷十九说：“初达摩师以四卷《楞伽》授慧可（４８７－５９３），曰：‘我观叹地惟有此经，仁者依行，自得度世。’”《景德传灯录》卷三也指出，慧也可以《楞伽》四卷，作为传授僧那、慧满的“如来心地法门”，认为“惟有此经可以印心”度世，《续高僧传.法冲传》说：“可师后，璨师等八人皆说玄理（指《楞伽》），不出文记。”可见，慧可、僧璨（？－６０６）均以《楞伽》大义相传承。僧璨虽然“萧然静坐，不出文记，”但他们师弟都称为楞伽师，都用《楞伽》经文印证。道信（５８０－６５１）、弘忍（６０２－６７５）受《大乘起信论》的影响，提出“一行三昧”之说，似乎更接近《般若》思想。他的著作中引用了许多般若类经典，如《大品》、《文殊般若》、《金刚经》等。比如“我应灭度一切众生……而无有一众生实灭度者”等，即引自《金刚经》。可见道信的禅法，正由《楞伽》逐渐地向《金刚经》、《般若》过渡，但《起信论》的最后根据，仍在魏译《楞伽》的异义上面，弘忍于五祖寺壁间画《楞伽》变相，同时使门人诵《金刚经》，到了得弘忍真传的慧能（６３８－７１３）那里，纔改以《金刚经》为传法的正宗。因此，大体上说，从达摩到弘忍，均以《楞伽》传宗，是有根据的。
    《楞伽》初译于昙无识。其四卷本，今已不传。南朝宋元嘉二十年（４４３），求那跋陀罗、慧观在道场寺译出四卷本。菩提流支于北魏延昌二年（５１３）由僧朗、道湛笔受译出十卷本。宋、魏二译均在达摩东渡以前出。唐久视（７００）于中阗三藏实叉难陀于嵩岳天中寺译成七卷，则是达摩逝世以后译出的。
    达摩之所以用四卷《楞伽》传宗，是因为此经为佛说第一真实了义。苏轼《楞伽经后记》说：“《楞伽阿跋多罗宾经》，先佛所说微妙第一真实了义。故谓之佛语心品。祖师达摩以付二祖曰：‘吾观震旦所有经教，惟《楞伽》四卷可以印心，祖祖相授，以为心法。’”
    达摩思想的特质，在于认为一切众生同一真性，为客尘烦恼所障，不能显了。这也是《楞伽经》所反复阐明的主旨。《入楞伽经》说：“如来藏是清净相，客尘烦恼垢染不净。”“如来藏自性清净，具三十二相，在于一切众生身中，为贪、嗔、痴不实垢染、阴界入衣之所缠裹。如无价宝，垢衣所缠。”一切众生自性，本来具足，这就是《楞伽经.佛语心品》的主旨。杨彦国说：“不灭真相，即达摩所传之一心也。明灵虚彻，亘古亘今，究竟本源，无有间杂。……是道也，非从他得，祗是家珍，目前历历狐明，认著依前埋没，不须取舍，本自圆成，但离妄缘，即是实际。佛语心品明此而已。”《楞伽》关于本性本自圆成之义与达摩理入思想完全一致。
    道宣记达摩“二入四行”教旨，对理入与行入的前三行较为详细。对第四行甚简称，祗说：“四、名称法行，即性净之理也。”《楞伽师资记》则补充称法行说：“性净之理，因之为法。此理众相斯空，无染无著，无此无彼。……智者能信解此理，应当称法而行。法体无悭于身命，则行檀舍施，行无希惜。……檀度既尔，余五亦然。为除妄想，修行六度，而无所行，是为称法行。”他主张通过理入以安心，行入以践履。践履则对从前所作恶业及其苦恼果报，受之不疑；对现在的苦乐遭遇得失，不予计较，对未来也不贪着，无所求；能这样行事，以至行无所行，即是“称法行”，前三行为对治“怨憎会”、“爱别离”、“求不得苦”、后者是以“无所得行”为方便，行菩萨行（六度）而无所行，从利他中消融自己的妄想习气。这既是对《楞伽经》所说众生都是“如来藏”之义的阐发，也与当时涅槃师“一切众生皆有佛性”之说同调。
    《楞伽经》将禅分为四等，即凡夫所行禅、观察义禅、念真如禅、诸佛如来禅。遇痴凡夫、外道及声闻、缘觉所行之禅，属凡夫所行禅；观察人法无我，诸相无实，名观察义禅；观察一切诸法无实体相，不起分别，得寂静境界，契合如来藏心之禅，名念真如禅；如实入如来地，入内身圣智，到不可思议境界，叫诸佛如来禅（或如来禅）。凡夫所行禅为小乘禅，其余为大乘禅。以具奋自觉圣智为内容的诸佛如来禅，是诸禅的最高境界。《楞伽经》如此直截指示佛家实的究竟和源头，对于当时讲究禅法的人是很大的启发。达摩的“安心无为，形随运转”的壁观法门，“上乘一心之法”（马祖道一语）实导源于《楞伽》。
    《楞伽经》有宋译四卷本、魏译十卷本、唐译七卷本之别。十卷本与四卷本虽分卷不同，内容相同，其中前有请佛品，末有陀罗尼品，还有一篇总品，是四卷本所无。十卷本与四卷本最根本的区别，在卷四依《胜鬘经》说佛性一段。经曰：“此如来藏识藏，一切声闻缘觉，心想所见，虽自性清净，客尘所覆故，犹见不净，非诸如来。……是故，汝及余菩萨摩诃萨于如来藏识藏，当勤修学，莫但闻觉，作知足想。”四卷本这一段明确把“如来藏”（佛性）、“识藏”（人心）结合成为“如来藏识藏”，十卷本则把二者截然分开，并明确说：“如来藏识不在阿赖耶识（即识藏）中。”由此出发，四卷本祗说有一心，即自性清净心；十卷本则说成有净染二心，从而其他理论也随之起变化。慧可所继承的达摩禅是以四卷本为依归的。从道信到弘忍的东山法门，则以“一行三昧”为中心，以守自心为方法，这是导人《大乘起信论》，把“一行三昧”提到止观的很高地位的反映。得弘忍再传衣钵的净觉，在《楞伽师资记》自序中即提出以《起信论.心真如门》的一番解说作为禅法的最高原则。神秀五方便门也依《起信论》建立其第一总彰佛体的离念法门。《起信论》完全用染净二心之说组织其理论体系，其根据实际上是《楞伽经》的十卷本，非四卷本。可见，此时“东山法门”，依据的《楞伽经》已经是四卷本与十卷本合流了。
    （三）慧可禅理
    菩提达摩的弟子，有道育、慧可。道育事迹不可考。慧可（４８７－５９３）俗姓姬，虎牢（今河南成皋县西北）人。对于儒家“墳索”、佛家典籍俱通。后到洛阳香山，跟随宝静禅师出家，不为世所知。年四十左右，在嵩洛遇菩提达摩禅师，一见大悦，遂拜达摩为师。历六个寒暑，尽得师传。达摩迁化后，化导道俗有年。东魏教静帝天平元年（５３４）于邺都（今河南临漳县西）盛唱玄风。慧可奇辩纵横，从者风靡，滞名相之辈或以为“魔说”，是非纷起，受到寺院义学显贵（如禅师道恒）的压制和刁难，不得已流离邺卫。慧可从容顺俗，创作新的禅理歌谣，使禅法更接近民众。后来，他度僧璨，北齐天保元年（５５０）教化向居士，缁素从者接踵而来。周武帝建德六年（５７７）毁释、道教时，韬光晦迹，于相州教化僧那，僧那又度慧满，以《楞伽》为心要。慧可远与昙林法师“共护经像”，隋文帝开皇十三年（５９３）圆寂，年一零七岁。
    慧可之师兄弟僧副禅师（？－５２４），太原祈县人，从达摩禅师出家，被称为“偏头副”。齐建武年间（４９４－４９８）南游扬辇（南京），止于钟山定林寺，梁武帝时住开善寺，后入蜀传禅，禅法大行。曾用《慧印三昧经》为南平五观齐祀治病。不久回金陵，于普通五年（５２４）逝世，其师妹尼总持不详。
    关于慧可师兄妹对达摩学说悟入的境界，有关资料记载：“偏头副”不执不离文字，为道所用，达摩称“得吾皮”；尼总持“断烦恼，得菩提”，称为“得肉”，道育“迷即烦恼，悟即菩提”，称为“得骨”；慧可则“本无烦恼，元是菩提”，称为“得髓”。达摩遂净如来付嘱迦叶之正法眼展转传至慧可。虽然这些记载带有传说性质，甚至有点离奇，但对于理解达摩门下的思想还是有一定参考作用的。
    慧可是一个意志坚定的禅师，无论人家对其禅法如何不理解，甚至视为“魔法”，还是遭到菩提流支、光统律师徒党的毒害，或被辩和律师勾结悬令“非理损害”，或者他断臂求法，与昙林共护经像，乞食供养“无臂林”，都可见他历尽磨难，志求佛法根本解脱真理的坚定行持和高尚节操。
    慧可之禅法，从他给向居士的回信，可见一斑。“向居士幽栖林野，木食涧钦。北齐天保初（５５１），闻二祖盛化，乃致书通好曰：‘影随形起，响逐声来。弄影劳形，不识形为影本；扬声止响，不知声是响根。除烦恼而趋涅槃，喻去形而觅影；离众生而求佛果，喻默声而寻响。故知迷悟一途，愚智非别。无名作名，因其名而是非生矣。无理作理，因其理则争论起矣。幻化非真，谁是谁非？虚妄无实，何空何有？将知得无所得，失无所失。未及造谒，聊申此意，伏望答之。’二祖大师命笔回示曰：‘备观来意皆如实，真幽之理竟不殊。本迷摩尼谓瓦砾，豁然自觉是真珠。无明智慧等无异，当知万法即皆如。愍此二见之徒辈，申辩措笔作斯书。观身与佛不差别，何须更觅彼无余？’居士捧披祖偈，乃伸礼观，密承印记。“可见慧可之教旨，在体认万法一如，众生与佛不二。达摩谓一切众生同一真性，客尘所覆，犹见不净，但离妄缘，即是实际。悟入即此一心，本来具足，即“理入”也。慧可承达摩“理入”之旨，悟此身与佛并无差别，即身是佛。可谓得达摩之真传。
    （四）传翕禅法
    传翕（４９７－５６９）是梁武帝时代二大士之一。齐明帝建武四年（４９７）生，婺州义乌县（今浙江义乌县）人。天质淳和，与乡亲一起捕鱼，常怀慈悲之心，把鱼具沉入水中，说：“鱼啊，鱼啊，愿走便走，愿留就留！”人们认为他这样做蠢得很。梁天监十一年（５１３），十六岁，与畱氏成婚，生下普建、普成二子。染普通元年（５２０）二十四岁时，遇梵僧嵩头陀，有所感悟，于是在松山下双寿树间结庵而居，自号双林当来下生善慧大士。与其妻一起，白天出去替人做事，晚上归庵弘扬佛法，苦行７年，多次得到感应，呈现瑞相。四众纷纷前来礼佛。郡太守王杰以其为“妖妄”，捕之入狱，大士十多天绝食，后太守深感愧疚，释放了他。这样一来，师事他的人更多了。他宣称“我从兜率天宫来到人间，为众生说无上菩提，以前秘而不宣，现在不再隐瞒此事了。”大通二年（５２８）把妻、子卖给人家，得钱五万，设大法会救济信众。中大通六年（５３４）十二月，遵梁武帝旨意，到建康钟山，次年入禁内拜见皇帝，后退居钟山定林寺，受官府的供养。大同元年（５３５）出席染武帝在重云殿讲《三慧般若经》，四月归山，大同五年（５３９）再拜见梁武帝，说：“一切色像莫不归空，无量妙法不出真如。天下非道不安，非理不乐。”梁武帝默然认同。大同十年（５４４），又将房产、田园、杂宝都捐给寺院做大法会。太清二年（５４８）告诉四众：“我将不再钦食作为齐供，烧身作大明灯，供养三宝、普度一切，”以此祈祷，普度梁末受兵火之祸的冤魂。弟子深受感动，请求以自己性命代替的有十九人，烧臂、燃指、馘耳、劓鼻的有二十八人，三天不食上齐的十五人，卖身供奉的二十多人。梁末大饥荒，大士日日与其徒拾野果野菜充饥，救度饥民。陈太建元年（５６９）卒，年七十三岁，其长子普建亦于陈后主祯明元年（５８７）焚身供佛。
    传大士的禅学，大抵归于般若空宗，深受僧肇的影响。其《行路难》等二十篇，立非断非常、真照无照，心相实相，般若无净，本际不可得，三空无性等，与《肇论》之旨相符。他曾上书梁武帝说：“双林树下当来解脱善慧大士白国王：救世菩萨今欲条上中下善，希能受持。其上善，以虚怀为本，不著为宗，亡相为因，涅槃为果；其中善，略以治身为本，治国为宗，天上人间果报安乐；其下善，略以护养众生，胜残去杀，普令百姓，俱禀六齐。”其所谓上善，就是以不执着于相为根本，以般若智慧达到涅槃境界为目的，这是出世间的大德们所追求的崇高境界，中善就是指按照儒家治身、治国、平天下之道努力修养道德之人，也能得好的果报。下善指能遵守某些禁戒，持齐利生之人。为善虽有上、中、下之差别，各人尽其所能，努力去做，却是共同的。
    传大士还作偈曰：“空手把锄头，步行骑水牛。牛从桥上过，桥流水不流。”全偈各句皆前后矛盾，把锄头则非空手，骑牛即非步行，能从木桥上过的，就不会是牛；把流水看作不动，本来不动的桥就成为流动的了。星云大师对此解释道：这首诗告诉我们一个道理：矛盾的调和。每句诗的前后虽有矛盾，“其实，这是禅师们从差别中来认识平等，从动乱中来认识寂静。只要我们心中廓然寂静，热关场中也可以做道场，这就是陶渊明所谓
‘结庐在人境，而无车马喧’的境界，”从有中把握空，从动中把握静，从矛盾中求得调和与统一，从差异中看到平等，这正是传大士禅语、禅时中所体现的辩证思维精神，很有可取之处。
    传大士虽然学无师承，但其禅法与达摩“理入”及六祖惠能之说却是相通的。他作《还源偈》说：“还源去，何须更追寻。欲求真解脱，端正自观心，还源去，心性不沉浮，安住王三昧，万行悉圆收。”把“观心”作为解脱的根本。他还倡导即心即佛，认为：“夜夜抱佛眠，朝朝还共起。起坐镇相随，语默同居止。纤毫不相离，如身影相似。欲知佛去处，只这语声是。”明确身与佛纤毫不离，众生佛性本来具足，不需向外驰求。
    传大士还作《心王铭》，盛倡“般若法藏，并在身心”之旨。他说：“观心空王，玄妙难测。无形无相，有大神力。能灭千灾，成就万德。体性虽空，能施法则。观之无形，呼之有声。为大法将，心戒传经。水中盐味，色裹胶青，决定是有，不见其形，心王亦尔，身内居停，面门出入，应物随情，自在无碍，所作皆成，了本识心，识心见佛。是心是佛，是佛是心，念念佛心，佛心念佛，欲得早成，戒书自律，净律净心，心即是佛，除此心王，更无别佛。……清净心智，如世黄金。般若法藏，并在身心，无为法宝，非浅非深。诸佛菩萨，了此本心。有缘遇者，非去来今。”反复阐明即心即佛的玄理。
    总之，传大士关于佛在心内、即心即佛的思想，虽然不是直接承达摩、慧可而来，但与达摩安心，理入思想是相一致的，反映了南朝佛教界的禅学思潮。日本学者忽滑谷快天说：“宝志先创唱即心即佛，传翕见而禀受之。志、翕均传显现神异，其非凡庸之材可以测知。即心即佛之语，非始于达摩，实梁代之一思想耳。”这种禅学思潮，与社会思潮紧密呼应，反映了南朝社会苦难深重和人们渴求迅速得到解脱的现实要求。传大士虽然对于中国禅宗的建立未提供更多的贡献，但其禅学思想，对于了解达摩禅学的影响以及南朝禅学思潮和社会思潮，仍有重要的意义，值得重视。
    （五）僧璨之禅：
    僧璨（约４９５－６０６）生平事迹，传录记载不详。《景详传灯录》说：僧璨，不申其乡贯姓氏，于东魏天平二年（５３５）年逾４０，见慧可得道，隐居舒州皖公山，遇后周武帝破毁佛法，往来大湖县司空山，居处无常，积十余载，于隋开皇十二年（５９２）度沙弥道信。后游罗浮山，又还皖公山，为众说法，俨立而逝，塔于山谷寺，时大业二年（６０６）。
    僧璨为居士时，设礼问师说：“弟子身缠风羔，请和尚忏罪。”慧可曰：“将罪来，与汝忏！”居士良久云：“觅罪不可得，”师曰：“我与汝忏罪竟！宜依佛法僧住。”曰：“今见和尚，已知是僧，未申何名佛、法？”师曰：“是心是佛，是心是法，法佛无二，僧宝亦然。”曰：“今日始知罪性不在内，不在外，不在中间，如其心然，佛法不二也。”大师深器之，乃为之削发，取名僧璨。
    关于僧璨的禅法，《舒州剌史独孤及赐谥碑》文记载：“禅师号僧璨，不知何许人，出见于周隋间，传教于慧可大师，抠衣邺中，得道于司空山。谓身相非真，故示有疮疾；谓法无我，故居不择地；以众生病为病，故所至必说法度人；以一相不在内、外、中间，故必言不以文字。其教大略以寂照妙用摄群品，流注生灭，观四维上下，不见法，不见身，不见心，乃至心离名字，身等空界，法同幻梦，无得无证，然后谓之解脱。禅师率是道也，上膺付嘱，下拯昏疑，大云垂荫，国土皆化，请南方教所未至，我是以有罗浮之行。其来不来也，其去无去也。既而以袈裟与法俱付悟者，道存影谢，遗骨此山，今二百岁矣。……当时闻道于禅师者。其浅者，知有为无非妄想，深者见佛性，于言下如灯照物。朝为凡夫，夕为圣贤，双峰大师道信其人也。其后信公以传弘忍，忍传慧能、神秀，秀传普寂。寂公之门徒万人，升堂者六十有三，得自在慧者，一曰弘正。正公之廊庑，龙象又倍焉。或化嵩洛，或化荆吴。自是心教之被于世也，与六籍侔盛。……其铭曰：人之静性，与生偕植。智诱于外，染为妄识。……如来悯之，为辟度门，即妄了真，以证觉源。启迪心印，贻我后昆。……凡今后学，入佛境界，于取非取。谁缚谁解。万能有千岁，此法不坏。”此碑文简要介绍其行实和法脉传承，重在概括其禅法，指出其以般若空观无得无证、即妄了真，以证觉源为特色。这和僧璨《信心铭》中所说：“不用求真，惟须息见”（即息除真妄二见），“心若不异，万法一如”的精神完全吻合。
    忽滑谷快天说：南岳慧思与传大士同时出世。其“顿悟心源程序开宝藏”、“但向已求，莫从他觅”等偈与《心王铭》异音同调，知顿悟心源乃一般大乘行者所主。僧璨、慧思、传翕同时出世。其思想之相类固当然耳。
    僧璨《信心铭》说：“至道无难，惟嫌拣择。但莫憎爱，洞然明白。毫厘有差，天地悬隔。……圆同太虚，无欠无余。良由取舍，所以不如。……一切二边，良由斟酌。……心若不异，万法一如。……真如法界……惟言不二。不二皆同，无不包容。……一即一切，一切即一。……言语道断，非去来今。”其玄旨，正如忽滑谷快天所说：“归于深信不二之句，为敷演达摩之理入者，华严圆融之旨，灼热如见。”他把《信心铭》概括为：“夫道之为物，洞然明白，一言不容拟议。在佛而无余，在众生而无缺。一切二见，总荡尽了，则万法一如，真妄无别。欲与此道相见，无如作不二观。不二之真宗，包容一切。一即一切，一切即一。大小圆融，古今泯绝，这个妙镜，岂言语思量之所及耶？”
    僧璨以“即妄了真，以证觉源”的《信心铭》，上承达摩、慧可，下传道信、弘忍、旁与慧思、傅翕相同调，对于禅宗的建立起了承前启后的重要作用。当然，他“居处无常”，往来江南，江北，无比较固定的道场，说明此时离禅宗的建立仍然有一定距离。这种状况在道信、弘忍以后，纔开始有新的改变。
    （六）东山法门——从道信到弘忍
    道信（５７９－６５１），姓司马氏，靳州广济县（一说河南沁阳县）人，少出家，隋开皇十二年（５９１）入舒州皖公山，谒僧璨曰：“愿和尚慈悲，乞与解脱法门。”璨曰：“谁缚汝？”曰：“无人缚。”璨曰：“何更求解脱乎？”道信言下立解。依学十载，得衣法。隋大业中领徒众抵吉州（今江西吉安）。住衡岳，欲次江州（今九江），因道俗之请，留庐山大林寺十年，爱江北黄梅县双峰山（旧名破头山）之泉石，乃入住。在山三十余年，荆州四层寺法显、神山寺立爽等，诸州来学甚众。有神足弘忍继承其衣钵。唐高宗永徽二年（６５１）寂，年七十二，著有《菩萨戒法》、《入道安心要方便法门》，今不存。据印顺法师考证，后书的主要资料存《楞伽师资记》，是可信的。
    这信继承其师僧璨“即妄了真，以证觉源”，真妄不二之大道，以一心灵源为不二之真宗，任意纵横，随处安心为解脱。这信对牛头法融融说：“夫百千法门同归方寸，河沙妙德总在心源。一切戒门、定门、慧门，神通变化，悉自具足，不离汝心。一切烦恼业障，本来空寂。一切因果皆如梦幻，无三界可出，无菩提可求。人与非人，性相平等。大道虚旷，绝思绝虑，如是之法，汝今已得，更无关少。与佛何殊，更无别法。汝但任心自在莫作观行，亦莫澄心，莫起贪嗔，莫怀愁虑，荡荡无碍，任意纵横，不作诸善，不作诸恶。行住坐卧，触目遇缘，总是佛之妙用，快乐无忧，故名佛师，”佛性对于人人来说，都是一切具足，在佛不多，在俗不缺，这正是从达摩到僧璨禅师以来的“顿悟法门”。他认为客体的“境像”无所谓好醜，好醜决定于主体的“心”，主要通过调整主体之“心”来获得自在解脱。他说：“境像无好醜，好恶起于心。心若不缰名，妄情从何起？妄情既不起，真心任编知。汝但随心自在，无复对治，即名常住法身，无有变易。”（同上）
    《楞伽经后记》载：“三祖《信心铭》，四祖之《禅宗论》，六祖《坛经》”，似乎仍把上述三种著作列入楞伽宗系统，但道信已开始重视《般若》的传承。在《入道安心要方便法门》中，道信几次引用般若经典，甚至以《金刚经》所说“我应灭度一切众生，灭度一切众生已，而无有一众生实灭度者”等语来说明般若实相原理。《续高僧传》载：道信“住吉州寺，被贼转城七十余日，城中乏水，人皆困弊，信从外入，井水还复。剌史叩问：‘贼何时散？’信曰：‘但念《般若》，’乃令合城，同时合声。须臾外贼见城四角大人力士威猛绝伦……群贼即散。”可见道信对《般若》崇信的程度以及《般若经》在禅宗创建过程中所起的重要作用。
    道信的禅法，据印顺法师考证，当以《楞伽师资记》所传的《入道安心要方便法门》（下称《方便法门》）为依据。《方便法门》从“文殊说《般若经》云”开始，至“略举安心，不可具尽，其中巧妙，出自方寸”，这是《方便法门》的主体部分。从“略为后生疑者假为一问”，至“了知一切未曾取舍，未曾分身，而身偏于法界之界。”是《方便法门》的问答部分。从“古时智敏禅师训曰”起，至末尾，是杂录部分。第一部分为主要内容，道信一开头就揭示了“安心方便”的根本意旨：举动施为，一切都不离方寸之“心”，“道场”是成佛的依处，“菩提”是佛之所以为佛的“觉”，一切语默动静，见闻觉知、资生事业，即是菩提，即是道场。这正显示道信禅法作为大乘佛教自度、度他的安心法门的特色，印顺法师还把道信禅法归纳为三点：
    １、戒禅合一。道信《菩萨戒法》虽未传下来，但其门风有戒有禅，弘忍门下禅与菩萨戒相合，正是禀承道信门风。
    ２、《楞伽》与《般若》合一。道信游学南方，深受南方般若学的影响，双峰开法时，更将《楞伽》“诸佛心第一”与《文殊说般若经》“一行三昧”融合起来，作《方便法门》；
    ３、念佛与成佛合一。一行三昧即是念佛三昧之一，息一切妄念而专于念佛，心心相续，念佛心就是佛。把属于念佛法门的，“一行三昧”引入“楞伽禅”，就成为双峰法门“入道安心要方便门”的显著特色。
    印公道几点概括，十分简明扼要，值得参考。
    道信三十四岁时，在庐山大林寺住，靳州黄梅人（今湖北黄梅县人，先世为浔阳人）弘忍（６０２－６７５）从道信出家，从道信出家，弘忍这时十二岁。道信之后，弘忍到双峰山以东十里的冯墓山（又称东山）创建寺院，接纳信众。他们前后经过半个世纪的努力，在黄梅开创的法门，后世称“东山法门”。“东山法门”继承达摩以《楞伽经》传宗的传统，又以《般若》相融通，并从理论到实践，从道场、道风、传承等方面有所建树，为建立中国禅宗作出了卓越的贡献。
    关于“东山法门”，萧萐父教授说：“在《大乘起信论》思想的影响下，北禅、南义进一步汇合，促使达摩以来以《般若》融通《楞伽》，来对旧禅学加以改造，并使之与儒、道修养论互相涵化，导致‘东山法门’的创建及一批早期禅宗文献（如《最上乘论》……《坛经》等）的产生，可以视作佛教禅学中国化的标志。”并且认为“东山法门”具有破旧立新的改革精神、取精用宏的创造精神、广开法门的宽容精神，这是很有见地的。
    “东山法门”的改革，主要表现在改单纯依赖布施的头陀生活为劳作自给的丛林生活。在道信、弘忍之前，禅僧们多孤游乞食。如与慧可同时之僧那禅师。“自出俗，手不执笔及俗书，惟服一衣一钵，一坐一食，以为常行，兼奉头陀，故其所往，不参邑落。”晋末之释僧显，“诵经业禅为务，常独处山林，头陀人外。或时数日入禅，亦无饥色。”当时的禅林，有些已有相当规模，如荆州长沙大寺，天下称最。《释法京传》说，法京十三岁出家，与同学智渊感升高座，说法无滞，凡所投造福门，大弘殿宇，小大千五百间，併京修造，僧众凑集，千有余人，“长沙大寺，圣像所居，天下称最，东华第一。”而弘忍“役力以申供养，法侣资其足焉，”把行、住、坐、卧四仪都作为修行的道场，身、口、意、“三业”都当作佛事。“四方请益，九众师横，虚往实归，月俞千计”（同上）。这就是把单纯靠乞食、孤游的头陀苦行改造成自食其力，把利已与利他、自觉与觉他、世法与出世法融通起来的大乘禅法，在修行方式上作了革命性的变革。
    “东山法门”对禅宗的贡献，在于发扬达摩以《楞伽经》“诸佛心第一”的传统，把“东山法门”的顿渐相融通，以顿悟为高，以顿悟名宗，其主旨是继承《楞伽》之渐悟又突出顿悟，这是他们对当时佛教界顿悟思潮的继承，又是在创立禅宗“顿教”法门中的创造。
    “东山法门”顿渐融通之说，是有其历史必然性的。关于中国佛教界的顿、渐之争，学者多有论述。在南朝宋梁二代，研习《涅槃经》及其所述“佛性”思想，蔚然成风。《续高僧传》僧旻传说：“宋世贵道生顿悟以通经。”竺道生主张“善不受报、顿悟成佛”，并著《二谛论》、《佛性当有论》、《法身无色论》、《佛无净土论》、《应有缘论》等。谢灵运追随道生，著《辩宗论》加以补充。对于道生顿悟说，宋教武帝十分欣赏，道生弟子道猷、法瑗、宝林等亦持此观点。而与谢灵运共同整理南本《涅槃经》的慧观则认为定慧需要阶级相乘，主渐悟，反对顿悟。慧琳、法助等亦持慧观渐悟说。南岳慧思“顿悟以源开宝藏”之偈以人人具足的本心与佛相印契，心佛不二，得一切处安乐。这不但体现在上述戒禅一致、《楞伽》与《般若》、念佛与成佛合一三个方面，在道信传法给他的弟子（包括道融、弘忍等）时也有精彩的论述。《景德传灯录》卷四载：“夫百千法门，同归方寸，河沙妙德，总在心源”，一切法门悉自具足，不离汝心；一切烦恼业障本来空寂；一切因果皆如梦幻。这三个“一切”，即是《楞伽经》“惟心证了知”与《般若经》“一行三昧”（即视法界皆一相，无有差别，惟有一心念佛，结合实相念佛）的体现，弘忍则在《最上乘论》中说：“但于行住坐卧中，常瞭然守本真心，令是妄念不生，我所心灭，一切万法不出自心。”把“四仪”与“守心”相融通出来。因此，道信、弘忍把当时渐修、顿悟的思维成果加以继承、光大，完全是顺应了历史的必然的。
    至于道信与弘忍关于顿悟问题的讨论，虽然资料不多，但我们透过一些零碎的论述，还是可以理出一些头绪来的。道信在对斗头法融传法时说：“吾受璨大师顿教法门，今付于汝。”明确指示：东山法门即承继僧璨的“顿教法门”。道信《入道安心要方便法门》，把学者分为四种：有行有解有证，上上人；无行有解有证，中上人；有行有解无证，中下人；有行无解无证，下下人。又引《维摩经》说：“豁然得本心”，信其言也。可见，道信与弘忍“每以顿渐之旨日省月试之，”已是探讨如何以渐修、顿悟来接引不同根机的学禅人。法融承继道信的，亦是此“顿教法门”。法融《心铭》说：“菩提本有，不须用守，烦恼本无，不须用除。灵知自照，万法归如。无归无受，绝观忘守。……不用证空，自然明彻。……诸缘顿息，一切不忆，”传翕《心王铭》与此亦异音同调。忽滑谷快天说：“知‘顿悟心源’，乃一般大乘行者所主”，“至梁时，高才卓识之间，主见性成佛，顿悟心源、即心是佛之谈者，自然之势也。”可见，关于顿、渐之争，由来已久。这既是对佛经关于修证成佛的关论述的不同理解，也是禅僧接引不同根机的人学佛中的亲身体会。“东山法门”的融通顿渐，既是对前贤，尤其是道生、僧璨“顿教法门”的继承，也是他们在创立禅宗过种中的创新。
    “东山法门”广开法门，弘扬禅宗，不但表现在道信门下，“缁门后秀，归者如云”，弘忍门下“四方请益，九众师横，虚往实归，月俞千计”，崇拜者众多，而且龙象辈出。其中“堪为人师”、影响一方的著名弟子有：神秀、智诜、刘主簿、惠藏、玄约、老安（即慧安）、法如、惠能、智德（高丽僧）、义方及玄赜。神秀为“两京法主，三帝国师”，势焰熏天。惠能则弘扬南宗顿教，独树一帜。嵩山老安，深有道行，宜身安乐，反经合权，出于山门，偏于天下。法如在弘忍处咨受三昧，经十六载，从于少林精舍，大开禅法，再振玄纲，成为少林法主。玄赜则与神秀受弘忍之嘱，于东都大开禅法，虽然其貌不扬，“形类凡僧”，却“证同佛地，帝师国宝，宇内归依”；与其弟子净觉，为楞伽师说作最后总结。资州智诜四川净众保唐禅系；宣什则创“南山念佛门禅宗”，果州未和上、阆州蕴玉、相如尼一乘皆弘之。智德有扬州，惠藏在华州、义方在越州、刘主簿在白松山皆弘化一方。
    由上可知，由达摩以《楞伽经》“二入四行”理论奠定基础，经慧可把般若性空之“理”与本体论意义的如来藏体系加以调和、融合，和僧璨的发挥，到道僧、弘忍，更从禅理（《楞伽》与《般若》结合、顿渐圆融）、禅风（禅修与劳作结合）、教转组织（广开法门、不择根机）上，为建立以自信自立、自求解脱为中心教义、以五祖寺为相对稳定的修禅据点，以劳作与参禅相结合的禅宗群体奠定了基础，至此，中国禅宗到道信、弘忍已略具规模。
    至于弘忍的《最上乘论》之真伪，学术界至今仍有争论。忽滑谷快天《中国禅学思想史》举五条理由论证《最上乘论》非弘忍真说：第一，“光元不坏。只为云雾所覆。一切众生清净之心亦复如是”，这是神秀之见，比慧能之见“劣而不胜”，不应当是弘忍之说；第二、使初学依《观无量寿经》非祖门正传；第三、“端心正念，善调气息”乃寂然教家之婆说，非禅将直指之狮子吼；第四、说自己的论说“实非了了证知，若乖圣理者，愿忏悔除灭”，是学道未熟之言，无权威，无力量，非弘忍一代宗匠之言。第五、说“若不信我，世世被虎狼所食”，上卑鄙之见地，更非出自弘忍。这些看法，自有一定道理，还可以讨论，但这并不影响道信、弘忍为中国禅宗“一代宗匠”，“东山法门”为开创中国禅宗奠定基础的结论。至于忽滑谷快天说“弘忍化盛东山”，又“无语录传世，所说法门，不知其要旨”，似乎对“东山法门”贬得过低，可以继续斟酌。
    总之，道信、弘忍创立“东山法门”，以《楞伽》、《般若》传宗，以双峰山、东山为比较固定的道场，以坐禅与劳作相结合，渐修与顿悟相结合、世间与出世间相融通，广开法门，不择根机，在以长江北为中心的广大地区产生了广泛的影响，为中国禅宗的创立作出了卓越的贡献。后来六祖慧能把南宗顿教法门的理论更加系统化，在历史上首次把中国僧人的著作《法宝坛经》列入“经”经至尊地位，从而为禅宗的真正建立作出了杰出的贡献。至于神秀使禅宗由民间走上朝廷，以及道信门下旁出的牛头法融以般若智慧指导修持，都为禅宗的建立与弘扬有独特的建树，这是不容忽视的。
    （七）牛头法融：
    法融（５９４－６５７），俗姓韦，润州延陵（今江苏丹阳）人，十九岁从茅山（今江苏句容）三论学者炅法师出家。十二年后移住牛头山佛窟寺。寺中有内外经书七藏，包括佛经、佛经史、道书、俗经史、医方图符等。融内外寻阅，前后八年，素养大大提高。贞观年间，道信入山见融，融端坐自若，曾无一顾，道信问：“在此作什么？”融曰：“观心”。道信说：“观是何人，心是何物？”现无对。便起身作礼，说：“大德高栖何所？”道信说：“贫道不决所止，或东或西。”融问：“还识道信禅师否？”曰：“道信禅师，贫道是也。”融稽首请说心要。信曰：“百千法门，同归方寸，河妙妙德，总在心源。”并将：“受璨大师顿教法门”授于法融。融返双峰山，后法席大盛。永徵三年（６５２）应邑宰之请于建初寺讲《大品般若经》，僧众千人。永徽中又出《大品般若》，僧众三千余人，称一时荣观。融在山溪，徒众乏粮，乃自往丹阳化缘，负米一石八斗，朝往暮还，供众百余日，唐高宗显庆二年（６５７）寂于建初寺。春秋六十四。相传著有《绝观论》（敦煌本）、《心铭》等。
    关于牛头法融的传承，最早的文献记载是唐李华（７１５－７６６）撰《润州鹤林寺故径山大师碑铭》。《铭》曰：“初，达摩祖师传法，三世至信大师。信门人达者曰融大师，居牛头山，得自然知慧。信大师就而证之……由此无上觉路，分为此宗。”与其相隔半个世纪左右的宗密（７８０－８４１）《圆觉经大疏钞》卷三和刘禹锡公元８２９年撰《牛头山第一祖啧大师新塔记》以及一百六十多年后（９８８）赞宁撰《宋高僧传》均以法融为道信之支脉，并说道信传法融时间在贞观年间（６２７－６４９），其传法系统为：法融——智岩——慧方——法持——智威——玄素（或为融、岩、持、威、玄、素、法钦）。印顺法师考证认为，真正明确牛头六祖师孙关系，当从慧方传法持开始。
    宗密认为，北宗神秀以朝暮分别动作，一切皆妄；南宗洪州则朝暮分别动作，一切皆真；而牛头法融的禅法，则“以本无事为悟，忘情为修。”宗密还进一步把三家归纳为：北宗一切皆妄，南宗一切皆真，牛头则一切皆无；并对三宗加以调和，认为：“诸宗所说，皆是诸佛之教也”；“若就行说者，初伏以灭妄，次信任情性，后休心不起”（同上），认为灭妄、任性、休心，都是修行的必经阶段（或者某一个侧面），都有其合理性，宗密指出：“就法有不变随缘二义，就人有顿悟渐修两门”。“牛头以达空故，于顿悟门而半了；以忘情故，于渐修门而无虚亏。”认为法融介于顿悟与渐修之间。这还可以通过《绝观论》进一步得到印证。
    《绝观论》“以虚空为道本，森罗为法用”，也就是以空寂之精神性的“道”为本体，以森罗万象之万法为功用。“道”这种空寂之本体，本身也是假名，而它又有其功用。因此：“假名毕竟空，亦无毕竟空，若身心本无，佛道亦本无，一切法亦本无，本无亦本无。若知本无亦假名，假名佛道。佛道非天生，亦不从地生，但是空心性，照世间如日。”这种“本无”本身也是假名的道，如红日普照世间，本体虽无，但有照耀大地之功用。本无是空、假、中的统一。这种中道观，就是法融所主张的般若空观思想，是他们一切禅法之理论基础。前面说过，牛头禅以无事为悟，忘情为修，是“无修不修，无佛不佛”这种禅行正是建立在般若空观基础上的。
    《心铭》对《绝观论》进一步加以发挥，提出：“菩提本有，不须用守；烦恼本无，不须用除，灵知自照，万法归如。无归无受，绝观忘守。”他把本有与无觉、空与不空在中道观的基础上统一起来，强调“正觉无觉，真空不空，三世诸佛，皆乘此宗”。正如宗密所说的，法融“道性高简，神慧聪利”，对般若性空思想有很高的悟性，“后遇四祖，印其所解空理，然于空虚显示不空妙性故，不俟久学，悟解洞明。”他之所以能在四祖门下别开一宗，实非偶然，一由本性颖悟，二由四祖的启迪，以“观是何人，心是何物”来启发他不起“知见”、“明寂自现”，三由当时渐修、顿悟之争的影响，促进他从佛法的根本上进行思考、体悟，从而在以般若为指导的中道观的辩证思想上达到相当高的造诣，独树一帜，这对于禅宗的建立亦是重要的贡献。
    总之，牛头法融承道之旨，在以般若智慧为指导的中道观理论的修持上，把禅宗的辩证思维素养进一步提高，其对于建立禅宗的贡献，是不可抹煞的。
    从禅学发展成为东山法门为禅学建立奠定基础的历史可以看出，一部禅宗创立史，是中国禅僧通过内省自觉悟的修悟而寻求解脱（即自觉圣智）的历史，是由中国禅僧与西域佛教徒，经过二三个世纪（公元５－７世纪）共同努力而逐步走向成熟的历史。从早期禅僧对“依教修心禅”的摸索，到达摩、惠可、僧璨以《楞伽》开宗，至道信、弘忍以《楞伽》融通《般若》，从“二入四行”的注重理论与宗教践履的结合，到道信、弘忍的“安心”、“自求本心”；从面壁凝思、观想，到禅修、劳作结合；从游化乞食到有比较稳定的道场，标志着中国禅宗已略具规模。真正建立中国禅宗的历史任务，是由“东山法门”的继承人慧能（包括神秀）来完成的。


一、慧能求法

第二章

    一、慧能求法

    慧能，一作惠能，原籍范阳（今北京大兴、宛平一带）人，俗姓庐。父名行瑶，早年做官，后来遭贬，于唐武德三年（６２０）被流放至岭南新州（今广东新兴）娶当地李氏女为妻，唐贞观十二年（６３８）二月初八日生下慧能。慧能三岁时，父亲不幸亡故，母守志鞠养，孤儿寡母，穷苦无依，生活极为艰辛，在如此境遇中长成的慧能，聪颖早慧，事母至孝，日日砍卖柴，奉母度日。不觉光阴荏苒，慧能已长大成人。
    慧能二十四岁那年，一日去市上卖柴，忽闻有人诵读佛经，据说慧能“一闻经语，心即开悟”，便问客人读的是什么经？客人告诉他，读的是《金刚经》。又问客人从何处来？如何得到此经？客人云：我从蕲州黄梅县（今湖北黄梅县西北）东山寺来，那里有禅宗五祖弘忍大师在主持传法，门徒有一千多人，我前往礼拜，总得以听受此经。慧能一听。心生羡慕，萌发了去黄梅跟从弘忍大师学习佛法的念头。客人本是一位热心的信徒，见慧能对佛法如此虔诚，便赠送他十两纹银，让他回去安置好老母的衣食生活，再到黄梅去参见五祖弘忍大师。
    慧能辞别母亲后，便来到黄梅求见弘忍。据说，慧能一见弘忍，弘忍便问他：“汝何方人，来此山礼拜吾，汝今向吾边，复求何物？”慧能回答说：“弟子是岭南人，新州百姓，今故远来礼拜和尚，惟求作佛，不求余物。”弘忍说：“汝是岭南人，又是葛獠身与和尚不同，佛性有何差别？”此语一出，使弘忍大为震惊，方知慧能是大根器之人，先令慧能在寺内随众作劳役，于碓房踏碓舂米。从此，慧能将劳作与修持相结合，虽然天天干活，可是时时刻刻在静虑修禅，用功修行，所谓“愿竭其力，即安于井臼；素刳其心，获悟于梯稗。”慧能忘身为道，不避艰苦，供养众人，尽心竭力。
    慧能就这样在寺中度过了八个月，一天，弘忍想物色继承人，就把众学徒召集起来，让每人写一首偈、写得最好的就被定为继承人。当时弘忍的门徒中，学业最佳、声望最高的是神秀上座，神秀恐负众望，就作了一首偈写在墙上，偈曰：
      身是菩提树，心如明镜台；
      时时勤拂拭，莫使惹尘埃。
这首偈显然表达了神秀渐修成佛的见解。弘忍认为此偈未能见性，只到门外。慧能得知神秀所作偈后，就知其对佛法的理解并不到家，于是也作了一偈，因为不识字。就请别人代写在神秀那首偈的旁边。偈曰：
      菩提本无树，明镜说非台；
      佛性常清净，何处有尘埃！
这首偈表明了慧能顿悟成佛的见解。从神秀与慧能的两首偈来看，神秀的四句偈是抓住了人的身心两个要素，将它们比喻为“菩提树”、“明镜台”、要求人们“时时勤拂拭，莫使惹尘埃”。这里的“尘埃”、是指“六尘”，即色、声、香、味、触、法六境，一般认为此“六尘”与眼、耳、鼻、舌、身、意六根接触，由于“六识”的贪着取舍，会造成人心的染污，所以教人要“时时勤拂拭”。此偈给人留下一个精进不懈的修行者的形象。对于引偈，对于此偈，弘忍尽管认为“只到门前，尚未得入”，但又告诉门人“凡夫依上偈修行，即不堕落”。正是有了神秀偈语的未见本性，总引出慧能的得法偈，也就是说慧能的得法偈是有针对性的，四句偈语完全是针对神秀的偈语而发的。因为神秀仍然执着于身心色相，所以慧能说：“菩提本无树，明镜亦非台。”这主要在于打破修持中对身心的执著。由于神秀将染净、圣凡绝对地对立起来，把污染看作是外在的因素，因而要求人们“时时勤拂拭，莫使惹尘埃”。但在慧能看来，凡生种种法生，心灭种种法灭，染净圣凡关键在于自心一念，心生善端即为善，心生恶念即为恶，心性自然，本来清净。所以，慧能说：“佛性常清净，何处有尘埃。”可以看出，慧能主要是从本然的心体上来批评神秀的，慧能这短短的四句偈，不仅概括了以后南宗禅对神秀禅法种种批评的精神要旨，而且也确立了慧能在禅门中的地位。
    果然五祖弘忍一见此偈，便知慧能已悟彻佛法大意。只是碍于当时众门徒在旁，未作认可，于夜半三更时唤慧能至方丈室，以袈裟遮住灯光，为慧能开示说法，讲解《金刚经》。慧能一闻，言下便悟。弘忍又将衣法传与他，并告诉他“为六代祖。将衣为信禀，代代相传，法即以心传心，当令自悟。”弘忍恐有人知传法事后加害慧能，便连夜亲自送他渡江南下。
    慧能走后，弘忍众门徒得知衣法已南下，结夥数百人追来，有一僧名惠明，于大庾岭上追及慧能，慧能把法衣置石头上，惠明不肯取衣，对慧能说非争法衣，只愿求闻佛法。慧能即于岭于为其讲说禅法，令其得悟。慧能为了躲避争夺衣体的追杀，曾一度在岭南一带“杂居止于编人”，“混农商于劳侣”，约在弘忍逝世之后两年，即唐仪凤元年（６７６），慧能觉得夺衣钵的风波渐渐平息，便来到广州法性寺（今光孝寺），当时正值印宗法师在讲《涅槃经》，慧能听到二僧在辩论关于风吹幡动的问题，一个说是风动，一个说是幡动，争认不下，慧能来到二僧面前说：“不是风动，不是幡动，仁者心动。”一语惊四座，也引起印宗法师的注意。印宗久闻黄梅衣法南来，今看到慧能谈吐不凡，便猜想是禀受衣法者，一问果真如此。遂请慧能拿出衣钵，众人礼拜。印宗向慧能请教弘忍禅法，慧能引《涅槃经》讲了一番“佛性是不二之法”的道理。印宗法师闻之，欢喜合掌，自叹弗如，称自己的讲经“犹如瓦砾”，而慧能的说法“犹如真金”，愿拜慧能为师，遂邀佛门大德和德高望重的信众来参加慧能的剃发受戒仪式。印宗自己亲自为慧能落发，并请智光律师为之授戒。这样，慧能总算正式出家为僧。从此，他的嫡传身份也就公之于天下。光孝寺中至今仍有瘗发塔、风幡堂等遗迹。慧能受戒后，在法性寺菩提树下弘扬东山法门，收徒传法，逐渐名振岭南，前来求法学禅的人日益增多，法性寺难以容纳诸多僧众。次年春，慧能辞别印宗法师，离开法性寺，率领弟了来到韶州曹溪宝林寺，僧俗相送者有三千余人。
    慧能早年在赴黄梅求法途中，便路经曹溪，并与当地村民刘志略结为兄弟，受到村民的礼遇，此次重返故地，在当地官民的支持下，大建寺院，广收门徒，使曹溪法门名播天下，从此，南宗便从岭南兴起，曹溪宝林寺成为岭南禅学中心。时任韶州剌史的韦琚慕慧能之名，特邀慧能下山至韶州城里的大梵寺为众说法，僧尼道俗参加听讲者有上千人，门人法海记录整理当时的开法情况编成了《六祖施法坛经》，此为中国禅宗的主要经典，也是我们今日研究慧能及南宗思想的重要参考资料。
    慧能在曹溪弘化数十年，门徒众多，被人称为岭南活佛，影响越来越大，引起唐王朝的关注。王维在《六祖能禅师碑铭》中记载说：“九重延想，万里驰诚，思布发以奉迎，愿叉手而作礼。则天太后、孝和皇帝，并敕书劝谕，征赴京城。”慧能面对王室的征诏，均托病力辞，保持了弘忍以来山林佛教的特色。
    唐玄宗先天二年（７１３），慧能回到新州，圆寂于国恩寺，世寿七十四岁，其肉身由新州迁回曹溪宝林寺供养，唐宪宗追赠“大鑑禅师”谥号，塔曰：“元和灵照。”宋太宗加谥“大鑑真空禅师”，诏新师塔曰“太平兴国之塔”。宋仁宗迎慧能真身入大内供养。加谥“大鑑真空普觉禅师”。宋神宗加谥“大鑑真空普觉圆明禅师”。此外，许多历史名人如王维、柳宗元、刘禹锡等都为慧能撰写过《碑铭》。
    以上我们根据历史文献中有关慧能生平事迹的记载，大致勾画出其生平的轮廓，尽管这一描述是粗线条的，但至少我们知道，慧能出身贫寒、没有文化，只是凭着对佛法的天才悟性，总赢得五祖弘忍大师的赏识，将衣法传授给他。慧能经过三十多年的辛苦经营，终于确立了他的曹溪法门，奠定了他在中国禅宗史上的地位。
    据《坛经》载，慧能门徒很多，弟子“三五千人，说不可尽”，直接受法者有“十弟子”。《景德传灯录》录其有名的法嗣四十三人，立传者十九人。实际后来最为知名的是青原行思、南岳怀让、荷泽神会、南阳慧忠、永嘉玄觉、曹溪法海等。他们得法后，大多各化一方，其中以青原行思、南岳怀让二家弘传最盛。南岳一系衍化出临济、沩仰二家。青原一系发展为曹洞、云门、法眼三家，即禅宗五家法流。禅宗法脉不仅在中国得到迅速发展，而且流传海外，远播欧美。直至今天会世界对禅宗的信仰和研究仍风靡一时，形成了一股“禅宗热”。


二、六祖法乳

二、六祖法乳

    在中国禅学思想史上，慧能禅法的确承先训后，继往开来，使禅宗一脉别开生面。他不仅融会发展了涅盘佛性学说和般若空观理论，而且海内百川，吸收融摄了中国传统的儒、道思想，形成一个比较完整的思想体系，这一思想体系由于是在般若非有非无的空之基础上构筑起来的，因此，其禅学理论表现为一种“不道之道”，落实于禅行生活中，则成为一种任运自在的“无修之修”。由此，南宗禅不著万法、顿悟菩提的宗旨，所引发出的便是它特有的不假修习、直了心性的禅风。
    （一）佛心不二
    佛教的理论轴心是寻求人生乃生至宇宙万象的真实本质，为求得解脱作论证。它从人生现实问题入手，随之探索人与宇宙交涉的问题，最后则扩展和深入到全体人生、整个宇宙，着力探索人生真义、宇宙的实相，这是佛教哲学发展的基本脉络和主要线索。慧能禅学作为一种直接为解脱实践服务的宗教哲学，完全继承了这一基本路数。表面看来，它宣传外在的现象世界虚空而内在的精神本原真实，实际上它关心的并不是物质与精神究竟何为本原的问题，而是一种人的自我解脱以及这种解脱的心理体验，是这种心理状态下所感受的人生、宇宙的终极真理。
    慧能从宇宙的高度阐发了人解脱成佛的根据问题，认为永恒绝对、灵明不昧的“真如本性”是宇宙的实体，是世界的本源，是永恒不朽的宇宙终极存在。慧能说：
    一切万法，尽在自心中，何不从于自心顿现真如本性！
    世人性本自净，万法在自性。
    如是一切法，尽在自性。自性常清净，日月常明，只为云覆盖，上明下暗，不能了见日月星辰。忽遇惠风吹散，卷尽云雾，万像森罗，一时皆现。世人性净，犹如清天，慧如日，智如月，智慧常明，于外著境，妄念浮云盖覆，自性不能明。故遇善知识，开真正法，吹却迷妄，内外明彻，于自性中，万法皆见，一切法在自性，名为清净法身。
宇宙万物都是由自性派生的，都包含在自性之中，外部客观世界是由于“妄念浮云”覆盖本心而不能显现，如果去掉妄念，就能显现山森罗万象，这是明确以自心为宇宙的实体、世界的本原。慧能认为自性即佛，自心的显现，也就是真如本性的显现。这是对“真如缘起论”的肯定。从佛教思想源流上说，慧能禅学属于如来藏思想系统，真如缘起论，也称如来藏缘起论，是佛典《大乘起信论》提出的缘起理论。所谓如来藏，是说真如产生一切染净、善恶之法，虽然自性清净，但由于客尘的障蔽而生烦恼不净，如来藏入于一切众生心中，因此人人皆有真如佛性，去除客尘的障蔽，显现出清净的自性，便可得到解脱。《大乘起信论》这一思想对当时佛教各派的思想有很大的影响。尤其在修为方面，当时许多人都循着它的路子去把握真心，把真心作为总源头，将修为方法看作是可以取之于已、不待外求的。慧能也接受了这一思想，认为真如佛性是自性意念的本体，“真如是念之体，念是真如之用。自性起念，虽即见闻觉知，不染万境而常自在。”在东方文化中，人之于宇宙并不是外在的、独立的，人是宇宙运动变迁、运作不息的生命之流的一部分。慧能继承了这一精神，把人投放于宇宙大屏幕，以真如统摄人性。当然，“真如佛性”说并不是慧能禅宗所独有，而是除三论宗、惟识宗之外其它各宗所共有的。但慧能的高明之处在于将这一观念强调到更加突出的地步，并把它同解脱论和修行观密切联系起来。我们知道，慧能禅宗的理论核心是解脱论，它一般并不去涉及宇宙的生成或构成等问题，其本体论和认识论也只是在解脱论中有所体现。在那个佛教盛行的年代，生活贫苦、不识文字的慧能对于佛教的皈依和信仰，并不是基于对艰深佛教义理的钻研和对构筑佛教思想体系的使命感，而是现实生活中，每个人所追求的自我解脱，所以，我们可以看到，慧能这一本体论的构筑，并不是去探求宇宙的本源秩序和自然的客观法则，而是极力论证人的本性与这一永恒不朽的“真如佛性”的冥然契合，“真如本性”的内蕴也并非是对宇宙自然的解脱，而主要是在探索和建立某种理想人格，给信徒指示出一个与人生密切结合的理想境界。在这一点上，可以说慧能禅学正充分体现了佛陀时代原始佛教的人生哲学的基本精神。因为佛陀在创立佛教之始，就曾把本体论等问题悬置起来，避而不谈。从这个意义上说，慧能禅宗确实要比佛教其它宗派更接近于释迦时代佛教的精神。但即使如此，也不能否认慧能思想中所显露出的本体论思想。慧能禅学作为直观地探索自性解脱的心性之学，它在形而上领域里的独特成就就在于对绝对自由和无限超越的人格本体的建构。
    慧能心性论的起点，即是将自心与本性联系起来，即自心与体性一不二。早在达摩初祖那里，就要求人们“深信含生同一真性”，体悟“无自无他，凡圣等一”的性净之理，慧可也说：“无明智慧等无异，当知万法即皆如，……观身与佛不差别。”后来，弘忍又依据《楞伽经》提出“境界法身。”慧能以《大乘起信论》的“一心二门”说为根据，进一步发挥了这一思想，“性”是《坛经》中讲得最多的一个词，有时单称“性”，有时称为“佛性”、“自性”、“本性”、“法性”、“真如”等，在慧能禅学中这些词基本上是相通的，也就是说“真如佛性”与人的“自性”是同质的。“自性能含万法是大，万法在诸人性中”，“本性是佛，离性无别佛”，“识自本心，是见本性”，在这里，佛心不二，自性即佛。而所谓自性，慧能更以人性说之，也就是说，自性即在人性中。这样，佛性就成为人心中的一种本性，人心即佛心，心性相同。人只要能识心见性，也就体现了真如佛性，慧能说：“佛是自性作，莫向身外求，”“我心自有佛，自佛是真佛”。真如佛性既内在地与自性合一，又超越于自性之上，它是修行解脱的终极理想。人只要明心见性，就与此理想相契。当其相契之时，自性与真如合一，这就是“自性即佛”。慧能后学进一步发挥了这一思想，希运就说：“祖师直指一切众生本来是佛，”，“即心即佛，上至诸佛，下至蠢动含灵，皆有佛性，同一心体。”在慧能禅学中，自性有时又与“心”相通用。《坛经》中，“心”大致有二层含义：第一是通常所说的人心，它既可以指人们的精神、意识活动，也可以指人的具有意识功能的生理器官。第二层含义是所谓“本心”、“真心”，它是对第一层含义的进一步抽象，是与“性”的意思相同的。可见，慧能对人心作了表象和本质、作用与本体、形而下与形而上的区别。但总的说来，在《坛经》中，“心”，“性”是相通用的，区分并不严格。慧能经常混同使用这两个概念，慧能以后的禅宗，常常干脆用“心”来代替“自性”，从以上分析来看，所谓“自性”有两个方面的含义：一是指众生先天具有的能够成佛的本性，故又称“佛性”；二是指能够包含或变现宇宙间一切万有的精神实体，它普遍在存在于每个人的心中，在这个意义上，“自性”又被称为“真如本性”。所以，这里的“自性”，既是宇宙的实体、世界的本源，又是众生的本性、人性的实质。它一方面是众生对自我先天具有的清净本性的体证，一方面也是显现本性，以包容万物，成就清净法身，即对宇宙万物的最高精神实体的契证，正如《永嘉证道歌》说的“一切圆通一切性，一法遍含一切法，一月普现一切水，一切水月一月摄。诸佛法身入我性，我性同共如来合。”这样，二位一体的“佛性”将现实的人与理想的“佛”统一起来，进而把“佛国”与“尘世”统一起来。
    神性和人性本来是不相容的，但慧能融汇了中国传统的“天人合一”的思维格式，把二者统一起来，自性即佛，崇高的佛性就在人的自性之中，这里并不把人生看作虚幻，把个体本性看成荒诞，反而肯定了它们的存在，只是要求一种“我与万物合而为一”的人格观念。所以，“佛性”既是人心的本性，又是宇宙的最高本体。慧能把个体的内在本性与外在的宇宙实体合而为一，贯通内外，主宰一切，从而使其解脱论得以实现，修行实践成为可能。
    （二）心性本觉
    “真如缘起”的思想并非是慧能禅宗所独有。它在本体论方面并没有多大的建树。应当承认，在对本体和现象的抽象思辩分析上，“不立文字”的慧能一派远不如惟识宗、华严宗。慧能禅宗真正着力的是心性修养。事实上，隋唐佛家多讲心性之学，只是禅宗更突出地发展了这一方面。冯友兰先生曾针对此指出：“中国所谓禅宗，对于佛教哲学中之宇宙论，并无若何贡献，惟对于佛教中之修行方法，则辩论甚多。”
    自晋末宋初以来，思想界把本体论和心性论的研究统一起来，并由探讨宇宙的本体转为着重研究人的本体，即人的真实本体。南北朝时因神灭神不灭的大论战，更刺激了这一课题的研究；隋唐时，佛教各宗竞相辩论，教相判释，更推动了这一问题的探讨，慧能正是在这种思想背景下，重点阐发了心性理论。
    关于慧能的心性修养理论，我们可以从三个方面来加以认识：
    １、人人皆有佛性
    佛性，亦意译如来性、觉性、如来藏，原指佛陀本性，后来发展为众生觉悟之因，众生成佛的可能性，这是中国佛教界对佛性的最一般的理解。印度佛教中讲的“佛性”，一是指心，二是指境。在它看来，众生若具有“性净之心”，便具有成佛的可能，但仅有“性净之心”还不能起作用，心要“待缘而起”，待得与“境界缘”结合，总能构成“佛性”。不过，在印度佛教经典中，对佛性没有一个统一的解说，这就给后人带来许多歧义，佛教传入中国以后，特别是南北朝时，佛学从对般若的探讨转到了佛性论，形成了巨大的佛性思潮。佛性是否为一切人都具有？它是“本有”还是“始有”？有许多高僧参加了争论。其中有一关键人物就是晋宋之际的竺道生，他孤明先发，首倡一切众生皆有佛性，指出“一切众生，皆当作佛。”但由于他的理论当时没有译出的经典作根据，所以一问世便受到很多非难，被作为邪说异端，不久，《大般涅盘经》译出，证明“一切众生，悉有佛性”，承认“一阐提人”也具有佛性，也可以成佛，情况总有所改变。一直到隋唐时代，佛性论仍然是一个悬而未决的问题。隋吉藏在谈到“佛性”时，总结过去各家说法共有十二家之多。唐玄奘和尚西行求法，从一定意义上说也是为了解决佛性问题。
    慧能继承发扬了竺道生“一阐提人皆得成佛”的佛性理论，旗帜鲜明地宣扬“人人皆有佛性”的思想。这一思想在慧能第一次参见弘忍法师时，就明确地表白出来。他在回答弘忍的责问时说：“人即有南北，佛性即无南北，葛獠身与和尚不同，佛性有何差别。”这就是说，人可分南北，而佛性无南北之分，人可以有葛獠与和尚的不同，而佛性无有差别。这一番不同凡响的回答，强调了佛性人人禀有，在成佛面前众生平等。在一部《坛经》中，表达这一思想的论述俯拾皆是：“但识众生，即能见佛，若不识众生，觅佛万劫不可得也。……后代世人，若欲觅佛，但识众生，即能识佛。即缘有众生，离众生无佛心。”反复强调了佛与众生本无差别的思想。在禅宗的发展过种中，这一思想是始终如一的。慧能的弟子神会曾以金器关系说佛性与众生是体一无殊，并说：“一切众生，本来涅槃，无漏智性，本自具足。”净觉则以冰水释众生与佛：“众生与佛性，本来共同，以水况冰，体何有异？冰有质碍，喻众生之击缚；水性灵通，等佛性之圆净。”宋代克文更说：“人人有个真天佛”，“僧俗男女平等心，一一皆同证法界”。既然佛性为人人所共有，那么若要成佛，只须直指本心，即可见性成佛。“经中只言自归依佛，不言归依他佛，自性不归，无所依处。”慧能禅宗直控心源，把生佛归诸一心，为缩小佛与众生的距离，打通迷凡悟圣的通道奠定了基础。
    ２、性体清净
    慧能认为人人皆有佛性，那么这个内在于人的佛性是怎样的呢？他对“自性”、“佛性”作了一个根本的规定，即“性体清净”。他说：“世人性本自净，万法在自性。”“世人性净，犹如清天，慧如日，智如月，智慧常明。”这些都是说明自性是清净的。佛教所谓清净，本是相对于染污而言的，它具体指那种去除了烦恼、迷惑、污染而达到的纯真、清净的状态。现实的世界和人们的尘俗之见、感情欲望是染污的，而佛的神圣境界却是清净的，从这个意义上说，清净就代表了佛，它是最高人生境界的体现。佛性是清净的，人性即是佛性，因而人性本净，因此，性体清净只不过是人生即佛性的另一种提法，它实际上是一种人性本善的观点。
    慧能这一“性善论”的意义至少有二：首先为其心性修养指明了归宿。禅宗的修养就在于破除无明，复归于清净佛性。本来一切众生，皆具清净佛性，可是为什么人们会堕入恶道而不能成佛呢？慧能认为：“人性本净，为妄念故，盖覆真如。”因为众生“于外著境，妄念浮云盖覆，自性不能明。”清净的本性被妄念遮盖了，就像“日月常明，只为云覆盖，上明下暗，不能了见日月星辰”。因而，一切众生，虽有佛性，皆不能见。慧能的这一认识，表现了所有宗教所共有的禁欲特色。要想成佛，就要息除尘世的一切妄念，摆脱外在客体的束缚，不受现实中五光十色生活的诱惑，“于一切法上，无有执着”。“自心归依觉，邪迷不生，少欲知足，离财离色，名两足尊。“只要对外界的声色财物视而不见，充耳不闻，就能得到至纯至善的真如本性的认识，就能复归于清净的本性。
    其次，这种先验的性善论直接为简化宗教修行的程序提供了理论基础。“性体清净”是禅宗一系所共同奉行的思想，但从达摩到神秀所理解的佛性都是真心、清净心。他们认为心性本净，但为客尘所染，“如镜昏尘，须勤拂拭，尘尽明现，无所不照。”前面提到神秀的求法偈“时时勤拂拭，莫使惹尘埃”就是其代表说，慧能南宗尽管也曾有心性本净，“为浮云盖覆”的说法，但他的“心性本净”与神秀所说的是有所区别的。神秀所说的本净心性与客尘烦恼，有自体与外铄、本体与客体之分。认为烦恼是外铄的、附属的。只有除去尘垢烦恼，本体还自清净，而慧能在对待二者的关系上，并不主张有主客之分，而更趋于二者一元。也就是说，所谓客尘烦恼，并不是独立于心性之外的东西，他的得法偈“菩提本无树，明镜说非台。佛性常清净，何处有尘埃！”所表明的就是在佛性之外并不另有尘埃存在，所谓“烦恼是菩提”，无二无别，相待立名，只是心的两种情况，而心只是那一个心，它在任何情况下也就那么一个样子，这就是“如如”。宗密曾说：“迷起一切烦恼，烦恼亦不离此心；悟起无边妙用，妙用亦不离此心。妙用烦恼，功用虽殊，在悟在迷，此心不异，欲求佛道，须悟此心。”自性与佛性原本体一不二，所以修行只在于“一切尘劳妄念，虽在自性，自性不染著”。做到这一点，就是清净本性，无须住心观净，坐禅苦修。而神秀对这“本自清净”、“本自具足”的佛性，还要“时时勤拂拭，莫使有尘埃”，就显得画蛇添足了。难怪慧能说：“不识本心，学法无益。”只要自识本心，直见本性，即可见性成佛。慧能得法，南宗兴盛，实质上正表明“自性清净”这一先验的性善论所要求的是简捷明快的顿悟功夫，即“放下屠刀，立地成佛”，而不是繁琐缓慢的渐修过程。当然，这是对于利根之人而言的。对于大多数钝根之人，顿悟仍不离渐修。
    ３、心性本觉
    慧能不仅以“人人皆有佛性”、“性本清净”为其心性修养指明了出发点和归宿，而且进一步以“自性本觉”，设立了修养的主体和动力。
    关于心性，中国佛教和印度佛教的说法是不同的。印度佛教主张“心性本净”，中国佛教尽管也承认“心性本净”，但它更具有自己的特色，　中印佛学很大的一个区别就是中国佛学用“心性本觉”来解释“心性本净”，实际上用“心性本觉”来代替“心性本净”。“心性本净”是说众生之心来清净，如同白纸一张，“心性本觉”是说众生的心本来觉悟，昭昭不昧，了了常知，具足无量功德。“心性本觉”说是我国南北朝时期假托印度人马鸣之名而伪造的《大乘起信论》首先提出的。它反对印度佛学“心性本净”、“客尘所染”的传统论断，提出了“心性本觉、妄念所蔽”的新命题，从而构成一种“真心本觉说”，为建立中国式的佛学提供了理论基础。
    慧能接受了这一理论，高扬“真心本觉说”。《坛经》云：“菩提般若之智，世人本自有之”，“自色其中，……自有本觉性。”本觉，就是本来觉悟。佛性，原意指成佛的可能性，然而在慧能这里，它已成了佛的同义语。它要求人们“识自本心，是见本性”，“佛是自性作，莫向身外求。”佛只是这个字的本义——觉悟。“佛者，觉也”，“自性觉，即是佛”。佛在心里头，只须自我觉悟，就可在自心中体认佛性，这就指明了修养的主体和方法。“但用此心，直了成佛，”如果想见佛，就应当向自己的内心去寻找，“心中众生，各于自身。自性自度，”只要本觉的自心，求得主观上的彻悟，便可达到理想境界，成就理想人格，慧能在这里肯定了通过自身努力可以达到理想的境界，突出强调了个体修养的自觉性，“自归依”而不“归依他”，要求修养主体认识到：佛就在自心中。
    我们只要将“心性本觉”和“心性本净”进行一番比较，就不能看到，慧能强调自力、突出自我在修养过程中拥有的主动性和自觉性，在禅学发展史上所引起的重大变革。“心性本净，客尘所染”这一命题意义在于，心性本来是清净的，但被客尘所染污，因此是凡夫。在“心性”和“客尘”的关系上，客尘处于主动地位，而“心性”处于被动地位，而“心性”处于被动地位。“客尘”可以改变“心性”的性质，使之由“净”变为“不净”。由此，必然导出这样两个结论：一是既然客尘能够染污心性，从逻辑上说，当然也可以完全泯心灭心性中的“善根”。因此，“一阐提人”没有佛性之说，便有了理论依据。二是既然心性处于被动地位，已被染污了的心怎么能自己去掉客尘呢？这就导致了成佛的困难。凡人的“心性”已是经过污染的，这就意味着，凡人的成佛需要依靠外在的资助，经过累世渐修总能达到。这样，印度除了释迦牟尼外，别人都不是佛，而慧能尽管也承认“心性本净”，但他突出了“心性本觉”的意义。心性不仅是清净的，更根本的是本觉的，或者说，本觉的“心性”是清净的。这一命题的改革意义在于：一方面本觉的清净本性，为自身中产生的邪见妄念所蒙蔽，因此是凡人，但这里的“心性”只是为“妄念所蔽”，其本性并没有丝毫的改变，也就像人在梦中一样，只要一醒，便能顿证佛地。这既肯定了人们本性中所存在的先验佛性，确立了心性修养的内在根据，又简化了成佛的程序，另一方面，“心性本觉”更具有主动、能动的意思，其意义在于肯定了个体精神的解脱和程升华要经过自身的努力，肯定了内因在修养过程中的作用。“心性本觉”就是说众生本来是佛，本来觉悟。现时的众生就是佛，只是他们现在尚未认识到自身就是佛，一旦觉醒，“一悟即至佛地。”所以在中国，众生即佛，自心即佛。慧能把“本觉”的心性运用到成佛的理论上，使他的心性修养论别开生面，按照“心性本觉”说，修养的内容和方法，就都要以促使内心觉悟为依归，成佛的途径更是自我觉悟的途径，这样一来，解脱论也就成了内在心性的修养论。
    （三）定慧等学
    禅，本是梵文“禅那”（Dhyana)的简称，鸠摩罗什意译作“思维修”，即运用思维活动的修持；玄奘意译为“静虑”，即止息妄念，安详地深思，是佛教各宗派所共同奉行的修行方式。宗密曾说：“禅是天竺之语，具云禅那，中华翻为思维修，亦名静虑，皆定慧之通称也。……悟之名慧，修之名定，定慧通称为禅那。”可见禅的本来意义是禅定和智慧两方面的结合。一方面是“止”或“定”，就是端身正坐，排除一切思虑和烦恼；别一方面是“观”或“慧”，就是直接的观照、证悟和感受。禅定就是先静坐敛心，集中精神，然后达到一种神秘的观悟和感受。“定”侧重于实践，行的方面；“慧”侧重于认识，知的方面。这就是当时禅法的基本程式。在古代印度，不论大小乘各派佛教，甚至佛教以外的其他宗教，都很注重禅定的宗教修养方法。在禅宗成立之前，中国佛教同样十分重视禅定修习。但所有禅法都没有脱离传统意义的禅，没有摆脱印度冥想实践的影响，在实践修行中只是一味坚持净心、念佛、坐禅。这种禅法的特点：一是把定慧分割为两上方面或步骤，并且“发慧”是在“趋定”的基础上，所谓“从定发慧”，二是由于把定慧割裂，往往导致在实际修行中对禅法作偏狭的理解，造成偏重“定”而忽略“慧”，把手段反而当成了目的，只要外在打坐，不要内心的觉悟。这就使得当时的佛教修持方式死板烦恼而又不得要领。慧能作为一代宗师，则从原则上对这种割裂定慧的旧禅法予以否定。他认为，旧禅法将定慧分为两个步骤，其结果必然导致知行不一的伪善，他批评说：“学道之人作意，莫言先定发慧，先慧发定，定慧各别。作此见者，法有二相，口说善，心不善，定慧不等。”也就是说，旧禅法割裂定慧，造成只注重外在的行为仪范，道德表象，而忽视了更为重要的方面，即内在的宗教认识和觉悟，这样就导致那种说得好听、做得好看而内心邪恶的虚伪表现。嘴上表白得好听，内心却没有达到相应的境界，甚至与口中讲的、表面做的截然相反，实际是“心行谄，口说法直。”所以，慧能提出了“定慧等学”的主张，他说：“善知识，我此法门，以定慧为本。第一勿迷言定慧别。定慧体一不二，即定是慧体，即慧是定用，即慧之时定在慧，即定之时慧在定。善知识，此义即是定慧等。”定慧体用一如，二者是即体即用的关系。《坛经》说：“定慧犹如何等？如灯光，有灯即有光，无灯即无光，灯是光之体，光是灯之用。名即有二，体无两般。此定慧法，亦复如是。”这就是说，定慧一体，二者并没有先后步骤之分。所以，慧能的新禅法就是“定慧一体，平等双修”避免那种只重外在形式，而忽视内心觉悟的偏颇，防止形成“假善人”、“伪道德”的人格形态，要求修持者表里如一，使内在的道德信念与外在的具体行为相一致，把意识和行为统一于个体完善的具体活动中，所谓“心口俱善，内外一种，定慧即等”，从而保持了宗教信念的庄严性和崇高性，从宗教道德的意识讲，慧能这一思想反对把道德行为和道德认识相分离，认为灯体光用，定慧一如，道德意识就贯穿于道德行为的始终，并诱发道德行为的产生。道德行为需要道德认识的指导，而道德认识又在道德行为中不断升华和强化，同时，道德意识并不单纯是人们的一种内在意向，其本身就有一定的外驱力，在具体操作过程中，要求人们作出相应的道德选择，而道德行为也并非是盲目的无意识的举动，往往有道德动机的支配影响。
    慧能反对传统的禅法，使禅法发生了根本的改变，他的“定慧等学”的真实本意在于突出心的觉悟，意念的发扬。他认为“道由心悟，岂在坐也”，所以把住心观静、长坐不卧的旧禅法称作“住心观静，是病非禅；长坐拘身，于理何益！”并说偈讥讽为：“生来坐不卧，死去坐不卧。一具臭骨头，何为立功课。”在他看来，心性本来清净。“本性自净自定，”“心地无非自性戒，心地没有坐禅入定的必要。他说：”此法门中，坐禅元不著心，亦不著净。亦不言不动。“这里慧能否定了静坐不动、摄心求净的必要性。传统禅法认为要达到“离念”“不动”的入定，必须凭藉一定观心杂念，仍然是有心可观、有定可修、有慧可发，亦即是有所执著的。慧能以般若无所得作为禅的指导思想，以不修为修，无证为证，对禅定作了新的解释：“此法门中，何名坐禅？此法门中，一切无碍，外于一切境界上，念不起为坐，见本性不乱为禅。何名为禅定？外离相曰禅，内不乱曰定，”慧能扩大了坐禅的范围，而不仅仅限于打坐，这是对达摩以来所持传统禅法的反动。禅林中广传的“磨砖岂能成镜”的故事就是这一思想的最好注脚。唐代著名禅师马祖道一青年时，曾在衡山结庵而住，整日坐禅，一天被慧能门人南岳怀让所见，怀让见他如此虔诚专注，便问道：你为什么要坐禅呢？马祖回答说：为了成佛。于是怀让便拿了一块砖在庵前石头上摩。马祖大惑不解地问：师父你磨砖做什么？怀让告诉他：想磨成镜。马祖说：磨砖怎么能成镜呢？怀让说：磨砖既不能成镜，坐禅岂能成佛呢？马祖经怀让这一指点，放弃坐禅，认识到求道不拘形式，心悟即可成佛。
    慧能否定、排斥坐禅意义的另一方面，则是对“慧”的强调和突出，从慧能起，禅宗教人不要打坐念经，不要累世修行，只要自识本性，内心觉悟，所谓“菩提只向心觅，何劳向外求玄？听说依此修行，西方只在目前。”在修养方法上，提倡一种“智慧观照”的新禅法：“令学道者，顿悟菩提，各自观心，自见本性。……智慧观照，内外明彻。若识本心，即本解脱。”慧能所谓新禅法，尽管表面讲“定慧双修”，实质上是以慧代定，或者说是抬高慧而大贬低定。一部《坛经》，并没有讲如何坐禅入定的言论，相反倒是大讲“般若波罗蜜”，修习“般若波罗蜜”就是最好的成佛方法。修习这一方法，并不靠外在的言行，而是在内心的觉悟与认识上用功，以企达到这一神秘的智慧。可见慧能所谓“定慧等学”，实际上是与传统禅定无关的，胡适先生曾指出：“慧能、神会虽口说定慧合一，其实他们只认得慧，不认得定。”慧能就是用宗教的悟解来取代外在的行为。在他看来，佛法功夫，全在于觉与不觉，悟与不悟，悟在于心，非关坐卧，慧能对禅法所作的全新的解释，从宗教道德的角度讲是有其新义的。新禅法所表现出的伦理意义是特虽注重个体的道德意念，突出了道德认识在修行过程中的作用，强调动机纯正的行为总是道德的行为。慧能禅法的善恶判断只存在于人的意念之中，“思量一切恶事，即行于恶；思量一切善事，便修于善行。”有善思便有善行，有邪念即有恶行。正如《佛名经》所说：“罪从心生还从心灭，故知善恶一切，皆由自心，所以心为根本也。”慧能禅宗强调意念的善恶，注重道德行为的主观动机，善行要发自良心，出于自觉，从乎自律，在道德践履上要心口如一，表里一致，真正体现行为主体的道德觉悟。
    据说，慧能初返曹溪宝林寺，天下学徒，不远千里，慕名前来依止，大家都觉得跟上鼎鼎大名的六祖大师，一定能聆听到深奥的教诲，在修行上获得长足的进步。但时间一长，他们觉得实际情形与自己内心的企盼完全不同，以前，他们在师父的训识下每天都要做功课，除了干一些杂务，大部分时间是在打坐入定。现在倒好，慧能大师干脆什么也不管，只是吩咐大家每天干些琐碎的杂活，众人议论越来越多，风声传到慧能的耳中后，他认为正是方便说法之时，便召集众人在大讲堂，开门见山地说：“今天将大家召集在一起，准备专门讲讲坐禅的问题。”众人一听，顿时群情振奋。慧能告诉大家说：“近日来，我听到大家的许多议论，抱怨我们这里不注重坐禅。现在我可以告诉大家，其实我们每天都在坐禅，只不过我们的坐禅不是让人静坐不动，而是从心所欲，不须拘泥，举手投足，皆在道场。只要保持心性的纯洁，不受善恶是非观念的影响，那么就是‘坐’；心灵净化自识本性，就进入‘禅’的境界，外动而内静，比起那些终日静坐、内心却心猿意马的僧人来，当然是好的。”
    众人听了慧能大师的一牛番话，觉得既新奇，又中肯。慧能大师接着告诉大家说：“其实大家都已明白了这个道理。不过，你们肯定还有一个疑问，那就是说，既然顿教法门无须打坐，日常起居都可以叫做坐禅，那还是宝林寺干吗？依照道理，自性自度，自识本心，是无须远道前来的，但你们不来，再简单的法门你们也不知道如何去领悟。我不能明明知道打坐于成道无助，还要让你们去苦修。我吩咐你们做一些有益身心的话计，目的在于先使你们从以往静坐不动的禅修程式中解脱出来，然后再传授你们顿悟法门。明心见性说来简单，可是真要掌握这一顿悟方法，却是要花很大功夫的。我当初在弘忍大师那里，并不曾整日打坐入定，而且整整舂了八个月米，于日常生活中体悟佛法，所以大师将衣钵传给我。今天我给大家说法，希望各人下去，用心体会。”慧能的弟子正是在这种日常耳濡目染的影响下，形成其不拘坐立、处处用心的曹溪门风。慧能道由心悟的思想否定了修身成佛的一切中间环节，而突出了明心见性的“心行”，从而建立了顿悟成佛的基础。　　（四）无相戒法
    慧能禅法中不仅主张定慧不二，而且提倡戒禅一致。他把二者融会贯通，使原始佛教以来戒、定、慧三学分离的理论和实践得到统一。在此基础上，他提出了“无相戒”的思想，无相戒思想从根本上改变了传统佛教戒律的意义，同时对后来禅门弟子破除束缚、任运自在的禅风在巨大的影响。
    据《坛经》记载：“慧能大师于大梵寺讲堂中，升高座，说摩诃般若波罗密法，授无相戒。”无相戒，就是无相之戒。所谓“无相者，于相而离相。”无相戒，也就是教人们要离相，而不要执著于具体戒相。按照佛教的传统教义，戒的基本含义有两个方面：一为止恶，叫做“止持”，即诸恶莫作；二为行善，叫做“作持”，即众善奉行。有“恶”可止，有“善”可作，表明都是有相的。慧能打破戒的传统意义，对一切修行，统冠以“无相”的限定词，如“无相戒”、“无相忏悔”、“无相三归依戒”等。自隋唐以来，对“戒体”是什么，在律学界曾有激烈的争论，并分为南山、相部、东塔诸家之说，将戒体或定为“心”，或为“色”，或为“不相应行。”慧能摈弃了以往律学的各种主张，将“戒体”统一于“修体”，并定“修体”为“无相”，致使戒律的意义完全变了。因为戒律是一种外在的行为规范，需要以其特殊的仪表相状贯穿于衣食住行各种宗教和非宗教生活之中，假若取消了这种仪表相状，使戒律仪轨皆置于“不著诸相”的原则下，就等于消解了它们应有的规范、制约的功能，所谓“受戒、忏悔、三归”等，都失去了原本的意义。因此，慧能所提倡的受戒等，实际是弘扬“自净其意”的内省，即所谓“自性自净”的扩展，没有一般正宗戒律的内容，不具有任何强制性质，他在《坛经》中十分透彻地阐发了自己的这一思想：
    善知识，总须自体，与授无相戒。一时逐慧能口道，令善知识见自三身佛，于自色归依清净法身佛，于自色身归依千百亿化身佛，于自色身归依当圆满报身佛。
慧能指出，自在法性，世人尽有，故应于自性中见三身佛。他对归依的解释是：”自归依者，除不善心及不善行，是名归依。“持戒与否，只在自性的迷悟染净，并不是在外在的善恶分别，慧能遵循”一切万法尽在自身中“的原理，认为善恶的起源与客观环境无关，而全在于个人的一念之间。他说：”思量一切恶行即行于恶，思量一切善事便修于善行。如是一切法，尽在自性。”这样“一念恶，报却千年善亡；一念善，报却千年恶灭。”在其《无相颂》中说：“愚人修福不修道，谓言修福便是道，布施供养福无边，心中三恶元来造。若将修福欲灭罪，后世得福罪元在。若解向心除罪缘，各自性中真忏悔，若悟大乘真忏悔，除邪行正即无罪。”这样一来，禅就变成了一种却恶向善、除邪行正的法门。只要自心清净，即是清净戒法，所谓“戒本源自性清净。”《坛经》中讲：“思量恶法化为地狱，思量善法化为天堂；毒害化为畜生，慈悲化为菩萨，”“慈悲即是观音，喜舍名为势至，能净是释迦，平直是弥勒。”把佛教的戒行律仪完全归结为修行者个体的清净心性。
    其实慧能这一不拘于外在律行、但求自心清净的新型戒法，亦自有源头活水。从初祖达摩时起，便有轻戒慢戒的倾向，道宣在《续高僧传》中批评达摩门下“相命禅宗，未闲禅字”。具体批评他们不遵守僧伽律仪而行同世俗的作为：“世有定学，妄传风教，同缠俗染，混轻仪迹。”“复有相述同好，聚结山门，持犯蒙然，动挂刑纲，运斤挥刃，无避种生。炊焚饮敢，宁惭宿触”。道宣是个持戒严谨的律师，“妄传风教”之语，反映了他对当时禅门不遵守戒律的不满，达摩及其弟子慧可等在当时即受到律学大师慧光的非议和指责，到了道信时代，持戒禅合一法门，开始为在教理上轻戒、慢戒打开了大门。因为相对而言，戒是外在的，禅是内在的，戒是手段，禅是目的，一旦戒禅合一，手段就可能为目的所吞没。慧能时继承东山门下轻戒的传统，大唱“受无相戒”，虽然还保存着拜佛、忏悔、发愿、归戒的形式，但全都销归自性，归结于“戒本源自性清净”，此时的戒已是有名无实，没有区别于禅的具体内容了。所以慧能虽然保留了说戒、说定、说慧的形式，其实是“得悟自性，亦不立戒定慧。……自性无非、无乳、无碍、念念般若观照，常离法相，有何可立？”十分有趣的是，在契嵩本和宗宝本《坛经》中，记载说慧能得五祖弘忍的衣法之后，离开黄梅，为争夺衣体之徒所追逐，受尽苦辛，“慧能后至曹溪，又被恶人寻逐，乃于四会，避难猎人队中，凡经一十五载，时与猎人随宣说法。猎人常令守纲，每见生命，尽放之。每至饭时，以菜寄煮肉锅。或问，则对曰：‘但吃肉边菜’”。慧能“但吃肉边菜”，表现了他对戒律的全新态度。慧能的三传弟子与惟宽在回答著名诗人白居易的提问时，对禅戒合一有过一个非常精彩的比喻。白居易问：“既曰禅师，何以说法？”惟宽回答说：“无上菩提者，被于身为律，说于口为法，行于心为禅。应用者三，其致一也。譬如江湖淮汉，在处立名，名虽不一，水性无二。律即是法，法不离禅，云何于中妄起分别？”慧能的这一态度，后被一些禅门弟子曲解为不重律仪的教理依据，结果一发不可收拾，以致律仪法制于禅门存实亡，及至百丈怀海，创丛林清规，总使道风得以整肃。
    （五）顿悟见性
    据《坛经》记载，一天，韶州韦刺史为慧能大师举行法会，请慧能大师千座说法，然后自己同其他官司吏、学士和百姓向慧能大师行礼致敬，向大师请教说：弟子听和尚宣讲佛法，觉得实在精深奥妙，不可思议。现在我还有一点疑问，希望大师慈悲为怀，专门为我们讲解一下，慧能大师告诉他：有疑难就提出，我为你们讲解。
    韦刺史说，和尚所讲的教法，是达摩大师的宗旨吗？
    六祖大师说，正是。
    韦刺史说：弟子听说达摩大师最初从广州到南京，教化梁武帝时，梁武帝问：我一生兴建寺院，剃度许多人出家为僧，施舍钱物，救济穷人，为僧人提供钦食，这有什么功德？达摩大师说：没有功德，弟子不明白达摩的答话有什么道理，希望和尚为我解说。
    慧能大师说：确实没有功德，千万不要怀疑前代祖师的话，梁武帝的见解不正确，不懂得真正的佛法。建造寺院，剃度僧人，布施钱物，举办齐会，这些活动叫做求福报，不能把求福误认为即是功德。功德存在于自我的本性中，并不拘泥于行善求福报的种种活动中。正确认识自我的本性是功，平等无区别地看待一切是德。思想时时刻刻不为尘世间的事物和现象所束缚，自我本性能够常常发挥妙用，这就叫功德。内心谦逊是功，对外以礼待人是德。从自己的本性中创立一切万法是功，自心本体不起尘俗妄念是德。不离开自己的本性是功，不受尘世的污染是德。如果想要寻求功德法身，只要根据这个原则来作，这不是真正的功德。那些真正修功德的人，心里是很谦虚的，常常对他人他事十分尊敬。如果轻视他人，遇事先考虑自己，但没有功。如果自己的本性虚妄不实，便没有德，这是因为惟我独尊、蔑视一切的缘故，时时保持正确的心念是功，公平正直的本性之中寻找，自己修心性是功，自己修身行是德。功德必须在自己的本性之中寻找，不仅仅是通过布施钱物，供养礼敬就能获得的。因此，福德与功德是有差别的。梁武帝不仅得这个道理，并非是达摩祜师说错了。
    韦刺史又问道：弟子常常看到一些人，口中念诵阿弥陀佛名号，希望能在下一世转生到西方极乐世界。请和尚说一说，这些人能转生到西方极乐世界去吗？
    慧能大师回答说：释迦牟尼佛当年曾在舍卫城中，宣讲有关引度众生到达西方净土世界的经文，明确指出西方极乐世界离此地并不遥远，如果从具体形象的方面讲，按一般的道路里数来计算，大约有十万八千里，但是如果从自己的本性上来讲，那就是有十恶八邪，十恶八邪与本性迥然有别，这就表明西方极乐世界离我们多么遥远，就西方世界十分遥远，是针对那些悟性差的人而言的，说它很近，是相对于那些具有超常智慧的人而说的。人有明白、糊涂两种，佛法并无两样。由于明白人和糊涂人有差别，对佛法的接受也就有快有慢。糊涂人整日口诵佛号，希望转生西方极乐世界，明白人至力于使自己的心灵纯净无瑕。所以佛说，如要人的内心清净了，那么佛土也就清净了。韦剌史你是东方人，只要保持自心的清净就没有任何罪业，尽管是生长在西方的人，其内心不纯净，那也是有罪业的。东方人有了罪业，想通过念佛来转生到西方极乐世界，那么西方人有了罪业，想通过念佛来转生到什么地方呢？愚蠢的凡夫俗子不认识自己的本性，不知道净土极乐世界即在自身中，只是想求生西方，明白的人无论在哪里都是一样的。所以佛说，随你所在永远安乐，只要韦使君你的内心没有邪念之念，西方极乐世界就离此不远，如果内心存在着邪恶之念，就是再念佛求法也难转生到西方极乐世界，现在打个比方规劝大家，先消除自己的十恶，就如同走了十万里路，再消除自己的八邪，就如同走了八千里路。只要时时体认本性，处处平等待人，那么，往生西方极乐世界，亲见阿弥陀佛，只是弹指间的事，只要能奉行十善，何必发愿转生西方极乐世界？如果自己不斩断十恶之心，又有哪位佛肯来接引你到西方极乐世界呢？“若悟无生顿法，见西方只有刹那；不悟念佛求生，路遥如何得达？”如果懂得无生无灭的顿教道理，瞬间就能见到西方极乐世界；不懂得顿教法门，只是希求通过念佛转生西方极乐世界，怎能走完漫漫长途而达到目的地呢？
    慧能大师接着告诉大家：我现在就可为大家将西方极乐世界移到这里，使大家瞬间就能见到，各位愿意不愿意看呢？
    听众都有兴奋，向慧能大师行礼说：如果在这里就能看到西方极乐世界，何必再发愿求往生呢？希望和尚慈悲，显示西方极乐世界，让我们大家都能看到。
    慧能告诉大家：世人自己的血肉之身就如同一座城池，眼睛、耳朵、鼻子、舌头等就好像是城门。外面有五个门，里面有一个意门。人的心如同土地，人的本性如同国土。国王居住在土地上，本性存在就如同国王存在，本性失去就如同没有了国王。如果本性存在，身心亦存在，若本性失去，身心也就毁灭了。佛是从本性中产生的，千万不要在身外去寻求。不认识自我的本性就是沉沦生死苦海中的众生，正确认识了自我本性就是脱离生死苦海的佛。拯救众生就是观音菩萨，布施一切人就是大势至菩萨，净化自心就是释迦牟尼佛，公平正直就是阿弥陀佛。以自我为实有的错误思想如同须弥山一样巨大，贪婪的欲望像大海之水一样无边无际，迷恋尘世的各种错误思想和情绪如同大海中的波浪一样起伏不息，伤害他人的想法犹如毒笼一样凶恶，各种不正确的心念像鬼神一样有碍于解脱，迷恋尘世的种种念头如水中鱼鳖一样来去不停。人的贪婪就是地狱，人的愚昧无知如同畜生。诸位有智慧的人们，常行十善，天常便在眼前，消除惟我至上的观念就如同推倒须弥山；没有对尘世的迷恋就如同平息了波涛；消除贪欲就如同使大海之水枯竭；消除害人之心就如同川流不息的鱼龙绝迹。从自己的心地上体验本性佛，使发自本性的智慧之光照亮人的六种感官，让眼耳鼻舌身意都清净而不受尘俗的污染。消除六欲诸天所作的业。自我本性返观内照，就可以消除贪欲、愤怒和愚昧，坠入地狱受苦的罪业也就顷刻消除净尽。这样的内外明白透彻。不受尘俗污染，与西方极乐世界又有什么差异，所以，慧能说：“不作此修，如何到彼？”
    众人听了六祖大师的这番话，全都恭敬行礼，称赞叫好，高声说：希望所有听到慧能大师讲法的人，都能立刻领悟理解。
    慧能以上的开示所表述的正是他即心即佛的主张，他认为“心外无法”、“心外无佛”，每个人的心性即佛心，所以成佛只在自悟本性，“故知一切万法，尽在自身心中，何不从于自心，顿现真如本性。”慧能把自心之迷悟看作是愚智凡圣的分野所在，自性迷则愚则凡则是众生，自性悟则智则圣则是佛。他将成佛与否归于一心之迷悟，从其认为心外无法，其心性是真的；就其认为心性是佛性，其心性是善的；从其认为心体是一种理想境界，它又是完美的。所以慧能这一真善美相统一的真如佛性，是“理之全”，是一种极高度的抽象。《坛经》称为“觉体圆明”，体性不二，是一个包罗万有不可分割的整体。这也就是禅宗的“理不可分”说。正如日人铃木大拙所说的：“禅是心整体，因此尽管可以说禅之中有知的要素，但心并非是可分割的多种机能，在经过解析后什么也不剩的合成物。”至理不可分，用智慧观照成佛，得即全体，所以利根之人对于这一纯全之理的体悟，只能顿了，不容阶次。“夫称顿者，明理不可分，悟语照极，以不二之语，符不分之理，理智慧释，谓之顿悟。”所谓顿悟，即指突然理解、体认、领悟佛理，而无需长期的修习。这种顿悟是通过直觉的主观体验，产生内心的神秘启示，达到精神状态的突变。后世禅师们常用“如桶底子脱”的比喻来形容顿悟。桶底一脱，桶中之物，顿时一览无遗。同样，一个人顿悟，就可当下直了本性，这种境界，不可言传，只能意会，所谓“如人钦水，冷暖自知”，所以佛与众生的差别，只在一悟，而迷与悟的不同，只在一念之间。“故知不悟，即佛是众生，一念若悟，即众生是佛。”“若悟无生顿法，见西方只在刹那，不悟顿教大乘，念佛往生路远。”慧能将自心顿悟作为成佛的一途径，作为修禅的惟一法门：“我于忍和尚处，一闻言下大悟，顿见真如本性。是故将此教法，流行后代，令学道者顿悟菩提，各自观心。令自本性顿悟”，不假修习的顿悟思想自慧能首倡之后，就成为禅宗修行的主要理论，所谓“自性自悟，顿悟顿修，亦无渐次，所以不立一切法。”吕澂先生指出：“《坛经》的中心思想，是单刀直入的顿教。”慧能的弟子神会就曾用“利剑斩否丝”的比喻来说“一念相应，便成正觉”的顿悟思想。慧能再传弟子慧海在《顿悟入道要门论》中对“顿悟”作了更为明确的解说：“求解脱惟有顿悟一门，顿者顿除妄念，悟者悟无所得”。这里讲的“除妄念”、就是要“除却自性中不善心、嫉妒心、谄曲心、吾曲心、吾我心、诳妄心、轻人心、慢人心、邪见心、贡高心及一切时中不善之行”。“无所得”，则是对外在世界无所执著，不染一切，这也就是禅宗所追求的“无念”境界。
    禅宗在修行上有“南顿北渐”之说，与慧能南宗不假修习的顿悟法门相对的是北宗神秀的渐修学说。神秀的禅法，以“住心观静”、“拂尘看净”为标识，其具体做法是“凝心入定，住心看净，起心外照，摄心内证”，这无疑是渐修法门。但神秀亦非全然不讲顿悟，在《观心论》中说：“超凡证圣，目击非遥，悟在须臾，何须皓首？”在《大乘无生方便门》中也说：“一念净心，顿悟佛地，”其实神秀的顿悟与南宗单刀直入、直了见性不同。它的悟只是通过种种方便以后的恍然大悟。从总体上说，神秀禅法是以“时时勤拂拭”为特点的渐修法门。如宗密说的“犹如伐木，片片渐破，一日顿倒，”而慧能南宗也并非全然摒弃渐修，一部《坛经》多处指出，尽管佛性世人本有，但缘心迷，不能自悟，须得到“善知识”的示道见性，方可“遇悟即成智”。这在一定程度上是承认引导、启发等教育作用和意义的。即使后期禅宗，也还要施以“机锋”、“棒喝”的手段。另外，慧能也是承认渐悟的，“法无顿渐，人有利钝。迷即渐劝，悟人顿修。”对于个人的修持来说，这样来区分和说明修持方法，应该说是实在的、积极的，又是有针对性的。自我修养对于每个人来说都是需要的，但对于不同的人又有不同的要求。顿渐的区分，既指出了修养境界的结构层次和修养过程的阶段性，也指出了修养主体各自具有的内在素质的程度性。
    （六）无念为宗
    慧能反对于外著境，心有所染，认为凡夫所以不能成佛，就是因为心有执著，而不能自见本性。要由凡转圣，首先要破除妄执，无心无物，无意于事。一切修行，自在无为。据此他提出“无念”作为其修行实践的总原则。他说：“我此法门，从上已来，顿渐皆立无念为宗，无相为体，无住为本。”“念”，就是指人的意念。无念即是说在意识活动中不起任何念头。“于自念上离境，不于法上生念。”如《坛经》云：“何名无念？无念法者，见一切法，不著一切法；偏一切处，不著一切处，常净自性，使六贼（指眼耳鼻舌身意六识）从门门中走出，于六尘（指色声香味触法）中不离不染，来去自由，即是般若三昧，自在解脱，名无念行。”这是就意识自身而言。“相”，指形状相貌；无相就是说意识不要执著于我睚的事物现象，这是从意念的对象来说。“住”，即著，无住即自然无碍，随心任运，是说意念不能定住或停留在某种具体的确良物象上，而使其自然流逝，这是从意识作为一个过程而言。可见，无相、无住，只是无念的不同提法，意思基本上是相同的，都是说明怎样使意识活动不被阻滞、隔绝、不生执著。慧能为什么要以“无念”为宗呢？这就是“即缘迷人于境上有念，念上便起邪见，一切尘劳妄念，从此而生。”“世人外迷著相，内迷著空。若能于相离相，于空离空，即是不迷。若悟此法一念心开，是为开佛知见。”所以慧能坚持要人们在日常修行中，以“无念”为指导原则，对外在一切事物不起心，不动念，如禅门弟子希运所说：“如今但学无心，顿息诸缘，莫生妄想分别，无人无我，无食嗔，无憎爱，无胜负。但除却如许多种妄想，性自本来清净，即是修行菩提法佛等，若不会此意，纵你广学，勤苦修行，木食草衣，不识自心，皆名邪行。”修行只在于息除诸缘，莫生妄想，一切放下，于相而离相，于念而无念，这就是“无修之修”，也就是“无念法”或“无念行”，慧能并不要求人们苦心灭智，拂拭修持，只要在伦常日用中无所执著即可。像后世禅宗语录中说的：“有源律师来问：和尚修道，还用功否？师曰：用功。曰：如何用功？师曰：饥来吃饭，困来即眠，曰：一切总如是，同师用功否？师曰：不同。问：何故不同？师曰：他吃饭时不肯吃饭，百种须索，睡时不肯睡，千般计较，所以不同也。”禅门中人的修行生活，无异于平常人的生活，只是“终日不离一切事，不被诸境惑，方名自在人。”既反对于境上生心，执著于外物，又强调安时而处顺，保持意识的“通用无滞”，自由自在，做事而不沾带于事，这就是过水而脚而不湿的修行原则。对慧能禅宗的无念说，宗密概括得最好：“觉诸相空，心自无念，念起即觉，觉之即在，修行妙门，惟在此也。故虽备修万行，惟以无念为宗。但得无念知见，则爱恶自然淡泊，悲智自然增明，罪业自然断除，功行自然增进。即了诸相非相，自修无修之修。烦恼尽时，生死即绝，生灭灭已，寂照现前。应用无穷，名之为佛。”在宗密这段话中既包含了作为无修之修的无念原则，也论及了作为修养境界的无念境界。在修行之时，虽身处尘世，意触万法，但要处处无意，时时放心，不著一切，无染无杂，于现实生活中，但不生贪着，不被五光十色的尘世现象引诱迷惑，经常保持清净的心性，无羁无缚的处身于人世，这总是真正的解脱，至于成就这一境界，自会通用无碍，应用无穷，所谓“悟无念法者，万法尽通；悟无念法者，见诸佛境界；悟无念顿法者，至佛位地。”这里，慧能将“无念”作为其心性修养的境界，把无念抬至佛的地位，抑或直接等。日后慧能的弟子对这一境界大力弘扬。神会就说：“无念者，是圣人法，凡夫若修无念者，即非凡夫。”拥有这一境界的人，尽管在表面与平常人并无两样，但他在与外界接触时，不受外物的迷惑，不受外界虚幻影响所扰乱，身处污浊尘世而心却一尘不染，悟得无念，即成金刚不坏身。如神会所说：“决心证者，临三军际，白刃相向下，风刀解身日，见无念，坚如金刚，毫微不动，纵见悟沙佛来，亦无一念喜心；纵见悟沙众生一时俱灭，亦不起一念悲文，此是大丈夫，得空平等心。”这里尽管也折射出“无念”境界所拥有的气势和豪迈，但更多的是指一种“念不起”或“不动心”的超然意境，所以在慧能这里，尽管“无念”同一概念，但应用却不同，正如冯友兰先生说：“于修时，也是要念念不著于相，于相而无相。于成就时，也是念念不著于相，于相而无相。不过于修行时如此，是出于努力；于成就时如此，则是不用努力，自能如此，这不是说，因为修行的人养成了一种习惯，所以不必努力，自能如此，而是因为修行的人于成就时，顿悟同无，所以不必努力，自能如此。”慧能既把“无念”作为其心性修养的理想境界，又把“无念”作为其宗教修行实践中的总原则，其实这是一个问题的两个方面；前者是从“已有”的胸襟出发，如高屋建瓴，无念“君临”于万事，不予染著，这是一种抽象境界；后者从“未有”的行迹讲说，如行云流水，无念“混染”于万事以防非止恶，这是一种具体的行为操作过程。如果说作为理想境界的“无念”主要在于成就一种“不除妄想不求真，绝学无为闲道人”的自在人格，那么，作为修行指导原则的“无念”，则更多地是指“见一切法，心不染著”的实践方法。当然，由于我们分析论证的需要，在特定的意义上把无念作了二重含义的论述，其实在慧能那里,它是作为一个总的指导思想而存在，所以无论是作为修养的无念境界，还是作为无修之念的无念原则，在整个修行实践过程中，像一条防腐带，保证了精神不作意追求，不执著外物，而处于自在解脱、来去自由的状态。
    慧能的“无念”说，并非是让人“百物不思，念尽除却”，因为那样无异于死人，所谓“一念断即死，别处受生”，即使从佛法的体悟来说，“若百物不思，常令念绝，即是法缚，即名边见。”慧能要的是“于自念上离境，不于法上念生”，也就是说指念念不断的“自念”于一切法上无住，所谓无念，是无妄念，并不是无“自念”，正是在这个意义上，慧能说：“无者无何事？念者念何物？无者离二相诸尘劳，念者念真如本性。真如是念之体，念是真如之用。自怀起念，虽即见闻觉知，不染万境，而常自在。”这里的真如本性与自念是不异不二的，它不是离念之外的存在，无念也等同于“自性起念”即真如佛性的运用，这就是说，无念它无意于抑制自发的意识活动，而是强调真如性的自然发挥和心灵的当下感受。这也是慧能系的“无念”与神秀系“离念”的根本区别所在。所以，心体离念的无念，被斥为“法缚”。后来《大珠禅师语录》明确发挥这一思想说：“无念者，无邪念”。也就是说，无念者，虽是无邪念，并非无正念。所谓邪念，不仅含有著相为邪念，念无著空也是邪念，只有不念有无，既不著相，也不执空，方为正念。神会说：“无念法，不言有，不言无。……若言其有者，即不同世有；若言其无者，不同世无。”因此，无念并不单纯谈空说有，而是不著空有，不执有无，出没尽离二道，究竟二法尽除，在思维方法上表现是不落有无，空有相即的中道思想。《坛经.咐嘱品》说：“若有人问义，问有将无对，问无将有对，问凡以圣对，问圣以凡对，二法相因生中道义。”人的意义不要执著于事物的差别，并由此而产生“边见”，而是使意识处于不落一边、不执一端的状态，内外明彻，通达无碍。慧能就特别注重这一方法，他曾对“十弟子”说：“吾教汝说法，不失本宗。举三科法门，动用三十六对，出没即离两边，说一切法，莫离于性相。若有人问法，出语尽双，皆取法对，来去相因，究竟二法尽除，更无去处。”这就是说，慧能所说的“无念”，即是离二相，破除将事物的两个方面绝对对立的见解，法门不二，念念真如，避免了对真如本性形而上学的割裂。慧能弟子神会日事对此作了进一点的发挥，他说：“云何不取于相？所谓如如。云何如如？所谓无念。”“起心既灭，觉照自亡，即是无念。是无念者，即无一境界。如有一境界者，即与无念不相应”，可见，慧能的无念为宗，实际上就是以自己当下之心念为宗，自性是佛，所谓“悟无念法者，万法尽通，悟无念法者，见诸佛境界，悟无念顿法者，至佛位地。”见无念即是见佛，无念即是涅盘。神会曾有一段话说见无念的功用：“能见无念者，六根无染；见无念者，得向佛智；见无念者，名为实相；见无念者，中道第一义谛；见无念者，恒沙功德一时筹备；见无念者，能生一切法；见无念者，即摄一切法。”无念不仅是修行的指导原则，也是修养的理想境界。
    （七）无修之修
    尽管慧能讲“顿悟”，但他的“悟道”并非是一种思辩的推理认识，而是个体的直觉体验。这份个体的直觉体验，也只能在现实生活中获得，即于日常经验中获“悟”。所以是在感性自身中获得超越，既超越又不离感性生活。慧能即心即佛的理论，必然导致其解脱不离世间，而提倡人间佛教的结局。他一面强调直了本心，即可成佛，而无须坐禅诵经，他反对传统佛教徒将坐禅诵经作为修行成佛的主要途径，认为坐禅不但不能使人成佛，反而会离佛更远。他见人结跏趺坐，“曾自将杖打起。”他引用《维摩经》的说法说：“于一切时中，行住坐卧，常行直心是。《净名经》去：‘直心是道场，直心是净土’”。只要能直了本心，即使行住坐卧也是修行。慧能的这一禅法思想，王维在《能禅师碑铭》中概括为：“定无所入，慧无所依；举手举足，常在道场。”慧能把佛移入自心，从而否定了外在的修行形式，肯定了只要自识本心，在行住坐卧世间日用中亦能成佛。他说：“法元在世间，于世出世间，勿离世间上，外求出世间。”慧能的这一思想在禅宗弟子那里得到了更大的张扬，神会就说：“若在世间即有佛，若无世间即无佛。”慧海也一再强调解脱不离世间：“非离世间而求解脱”。这里破除了世间与出世间的界限，把二者打成一片，肯定了在现实人世便可以成就无上佛道，成佛悟道就在日常行为用事当中，后期慧能弟子更是否定了传统的修行方式，而提倡实践中的禅宗。希运说：“语默动静，一切声色，尽是佛事。何处觅佛？不可更头上安头，嘴上安嘴。”慧海称参禅学道“只是逐声色走。”他在回答门人问“和尚修道，还用功否”时说：“饥来吃饭，困来即眠。”修道生活就是百姓日用的平常事，除此之外另觅修行之道，皆是死路。临济义玄说：“看经看教，皆是改业。”后期禅宗弟子尽管把心还原为真如真心，认为真如偏在，但同样否定了传统的修行，而肯定了“饥来吃饭困来眠”的修行方法，他们认为佛性偏一切处，所谓“青青翠竹，尽是法身；郁郁黄花，无非般若。”“运水搬柴无非佛事。”把本体之“佛性”放回到万物之中，一切都是佛性的表现，这就是“触类是道。”所以，禅宗追求一种本自天然、自由自在的修行生活。“道流，佛法无用功处，只是平常无事、屙屎送尿，著衣吃饭，困来即卧。”不必于日用平常行事外，别有用功，别有修行。正如《文益禅师语录》所说的：“举昔有老僧住庵，于门上书心字，于窗上书心字，于壁上书心字。师云：门上但书门字，窗上但书窗字，壁上但书壁字。”禅宗所追求的就是一个“本源自性天真佛”追求的是一个“父母未生时”的本来面目，也就是生活和生命的原色，“要行即行，要坐即坐”，只要随顺自然，依心而行，就可以使“此本来面目现，本地风光露。一道清虚，便是自己放身舍命，安闲无为，快乐之地。”
    慧能提倡的这种纯任自然、不加造作的修行生活，无异于世俗平凡生活，他甚至提出了“若欲修行，在家亦行，不由在寺。”把修行活动深入到世俗生活的每个角落，而不仅仅限于僧侣生活。慧能把“佛性”移植到人们的内心，直接投入人们的生活，强调“平常心”，注重在日常的言行中见性成佛，“佛法在日用处，行住坐卧处，吃饭吃茶处，语言相问处，所作所为处。”使“佛性”人性化、世俗化，把庄严的成佛境界的绝对超越性还原为“运水搬柴”的生活琐事，从入世中见到出世，在现实人世成就佛门正觉。这种不执着于戒律教条，摒弃传统修习，率性而行，任意而作，在人的平凡生活中成佛转圣的修行方式，是合乎人性的。日后禅门弟子百丈怀海“一日不作，一日不食”的农禅，可看作是这一进步思想的合理发展，从中也可以看出当时佛教由于实践的要求对传统修习的改革趋势。


一、神秀门庭

第三章

    一、神秀门庭

    弘忍之后，神秀一系成为北方势力最大、范围最广的一宗，是当时中国禅门之中心，迨至唐中期以后，慧能一系方反攻北方，取代了北宗的地位，从此改写了中国禅宗史。宋代以来的禅史灯录，基本以南宗谱系来写。推崇慧能一系，尤其对日后兴起的五家七宗之禅的弘传，更是铺天盖地，使曾经盛行一时的神秀一系几近湮没，弘忍门下的传禅之史亦被修正。长期以来，人们只能从南宗所传典籍中了解北宗禅法，这不免产生许多不符史实之处，而曲解神秀一系。
    神秀（６０５－７０６）生于隋大业元年（６０５），俗姓李，陈留尉氏（河南尉氏县）人，年十三，“属隋季王世充扰乱，河南山东饥疫，因至荧阳义仓请粮，遇善知识出家。便游东吴，转至闽，游罗浮、东、蒙、台、庐诸名山，嘉遁无不毕造。学究精博，采《易》道，味黄老及诸经传。自三古微赜，靡不洞习。”他在游历期间，内外兼修，博综多闻，受老庄玄学、《书》、《易》大义、三乘经论和《四分》律仪等儒释道的全面熏陶，使他“说通训诂，音参晋吴，”具备了日后成为一代教主的才学。神秀二十岁时，在东都天宫寺受戒，四十六岁至蕲州黄梅双峰东山寺（湖北黄梅县）参礼弘忍大师，见弘忍以坐禅为务，乃叹服曰：“此真吾师也。”遂誓心苦节，以樵汲自役，而求其道。他在五祖处“服勤六年，不舍画夜。大师叹曰：‘东山之法，尽在秀矣。’命这洗足，引之并坐。”神秀在弘忍处深受器重，在数百门徒中位至上座。《宋高僧传》载：“秀既事忍，忍默识之，深加器重，谓入曰：‘吾度人多矣，至于悬解圆照，无先汝者’。”
    弘忍殁后，神秀乃迁移江陵当阳山（今湖北当阳县东南）玉泉寺，住在寺东七里的山上，荫松藉草，修兰若行，影响日渐广大，学人纷纷来投，成为当时禅学重镇。《宋高僧传》说：“四海缁徒，向风而靡，道誉声香，普门熏灼。”宋之问《为洛下诸僧请法事迎秀禅师表》说：“契无生之理，传东山妙法。开室岩居，年过九十；形彩日茂，弘益愈深。两京学徒，群方信士，不远千里，同赴五门。衣钹鱼颉于草堂，庵庐雁行于邱埠，云集务委，虚往实归。……九江之道俗恋之如父母，三河之士女仰之犹山岳。”神秀的声势如此浩大，自然会引起当政者的关注。
    久视元年（７００），武则天遣使迎神秀入京。据张说《大通禅师碑》说，武则天竟不计君臣之别，亲加跪礼：“诏请而来，趺坐观见，肩舆上殿，屈万乘而稽首，洒九重而宴居。”每当说法，“帝王分座，后妃临席。”并敕在神秀住持过的当阳山建度门寺，以表彰神秀之懿德。神秀被安置于内道场中供养，则天帝时时向他问道。当时王公以下及京邑士庶竟相至谒，望尘拜伏，日有万计。中宗即位，对他更加礼敬，圣敬日崇，朝恩代积，被“推为两京法主，三帝国师。”但神秀毕竟是“迹远俗尘”的一代禅师，所以他曾“屡乞还山”，诏不许。长安四年（７０４），神秀再次要求还乡，新复位的中宗敕曰：“禅师迹远俗尘，神游物外，契无相之妙理，化有结之迷途。……弟子归心释教，载儜津梁，冀启法门，思逢道首。禅师作欲归本州者不须，幸副翘仰之怀，勿滞分榆之恋。”这反映了唐王室对神秀的基本态度。在武则天改号称帝的进程中，沙门薛怀义等人是出了大力的，武氏新政权要想维系稳定，收络人心，取得全国佛教徒的拥护和支持，就要拉拢扶持各宗代表人物，所以神秀的被诏入宫，的确含有深意。神秀所受的礼遇，确实半是羁縻，半是利用。
    神秀住东京洛阳六年，于神龙二年（７０６）在天宫寺示寂，中宗亲自送葬至洛阳午桥，并下诏于嵩阳之辅山顶为其造十三阶浮图，赐谥大通禅师，京洛士庶皆来送葬，“服师丧者，名士达官不可胜纪。”有皇室参与其事，丧礼办得极其豪华荣耀。其弘忍师门，立即声价百倍。在中宗、睿宗朝，弘忍的弟子老安、玄赜相继被诏入京，神秀的弟子辈，诸如普寂、义福等，也受到朝廷权贵的支持和崇信。一变而成国师，神秀所传禅法，所为统治层承认和肯定的官禅，达摩法系亦在诸禅系中被公推为正宗所在。
    神秀的禅法思想，史传上虽略有记载，却未言有著作存世，净觉所作《楞伽师资记》则明确说神秀奉行“不出文记”的原则，不会有著作留世。晚近在敦煌卷子中发现了几个本子，如《大乘无生方便门》、《大乘北宗论》等以及一向在日本流传的神秀《观心论》可以看作是神秀北宗禅法的记录。
    神秀一生内外兼修，所学驳杂，但其基本思想正脉仍是继承了达摩以来依持《楞伽经》的传统。张说《大通禅师碑》说神秀“持奉《楞伽》， 遞为心要。”李邕的《大照禅师塔铭》中也记述说：普寂诣神秀，神秀“令看《思益》，次《楞伽》，因而告曰：此两部经，禅学所宗要者。”《楞伽师资记》载弘忍的话说：“我与神秀论《楞伽经》，玄理通快，必多利益。”这里突出神秀在弘忍门下擅长《楞伽》玄理，表明神秀禅法与《楞伽》的关系。关于神秀的禅法，可以从两个方面来认识：一是他的禅法的理论基础，二是其禅法的方便法门，运用“体用”范畴，来发挥《楞伽》经义，并用以教授门徒。可以说，他的“体用”说是他全部禅法的纲领，贯穿其禅理禅行中。
    据《楞伽师资记》说，神秀在弘忍门下“受得禅法，禅灯默照，言语道断，心行处灭，不出文记。”他保持了道信、弘忍的朴素禅风，继承了自达摩以来历代相承的“观心”禅法。他明白无误地向则天皇帝表现自己所承继的即是东山法门：“则天大皇后问神秀禅师曰：所传之法，谁家宗旨？答曰：禀蕲州东山法门。问：依何典诰？答曰：依《文殊说般若经》一行三昧。则天曰：若论修道，更不过东山法门。以秀是忍门人，便成口实也。”神秀弘扬的禅修内容，据《大通禅师碑》概括为：“总四大者，成乎身矣；立万法者，主乎心矣。身是虚哉，即身见空，始同妙用；心非实也，观心若幻，乃等真如。”这里观身是空、观心若幻，将“心”作为立“万法”之主，确属《楞伽》惟识一流。神秀还有《观心论》中说：“心者，万法之根本也，一切诸法，惟心所生；若能了心，万行具备。”此心不但是“众善之源”，也是“万恶之主”，因此，修心解脱或永堕三界，无不依此一心。故曰：“以为出世之门户，心是解脱之关津。”神秀继承《大乘起信论》的真妄二心说，以妄心不起，真心不失为解脱，从而强调息妄修真的“观心”修行法门。他说：
    菩萨摩诃萨行深般若波罗蜜多时，了四大五蕴本空无我，了见自心起用有二种差别。云何为二？一者净心，二者染心，其净心者即是无漏真如之心，其染心者即是有漏无明之心。此二种心，自然本来俱有，虽假缘和合，互不相生，净心恒乐善因，染心常思恶业。若真如自觉，觉不受所染，则称之为圣，遂能远离诸苦，证涅盘乐。若随染造恶。受其缠覆，则名之为凡，于是沉沦三界，受种种苦。何以故？由彼染心障真如故。
    净染二心，皆本一心，人自有之。通过观心的修行，息妄显真，除染还净，了悟本觉真心，即可解脱。所以他说：“故知所修戒行，不离于心。若自心清净，一切众生皆悉清净。”这一“自心清净”之心，即是“真如之心”、真如佛心。世人三界轮回，受种种苦，即是由于无明染心障覆了真如之心，使自性不能明。只有去除妄念浮云，显示真实不虚、灵明不昧的真如之心，总有觉悟成佛。神秀这种佛性人人皆有，而为客尘所染的思想与达摩以来楞伽师遞相传承的如来藏佛性思想是一脉相通的。
    既然众生受苦，不得解脱，全在于无明染心障覆了真如之心，那么，要求得解脱，须破除无明之心，而显露真如佛性的本地风光。如何总能破除无明，显发真心呢？神秀认为，无明之心虽有八万四千烦恼欲及恒沙众恶，但其根源不出贪、嗔、痴三毒，此三毒”若应现六根，亦名六贼，其六贼者，则名六识。出入诸根，贪著万境，能成恶业，损真如体，故名六贼。”贪嗔痴三毒与眼耳鼻舌身意识六贼则是众生不得解脱的无明之心。《观心论》说：“一切众生，由此三毒，以及六贼，惑乱身心，沉沦生死，轮回六趣，受诸苦恼。犹如江河，因水泉源，涓流不绝，乃能弥漫，波涛万里。若复有人，断其根源，则众流皆息。求解脱者，能转三毒为三聚净戒，能转六贼为六波罗蜜，自然永离一切诸苦。”“求解脱者，除其三毒以及六贼，自能除一切诸苦”。这样，除三毒、净六根也就成为观心禅法的主要修习内容以及所要达到的目的：“知一切恶业由自心生，但能摄心离诸邪恶，三界六趣论回之业自然消灭，能灭诸苦，即名解脱。”摄心就是身心不起，常守真心，离恶就是心体离念，六根清净。为此，宗密在列举“禅之三宗”时将神秀一派的禅归之于“息妄修心宗”，并在《禅门师资承袭图》中概括为：“北宗意者，众生本有觉性，如镜有明性；烦恼覆之不见，如镜有尘闇。若依师言教，息灭妄念。念尽则心性觉悟，无所不知，如磨拂昏尘，尘尽则镜明净，无所不照。”神秀在《观心论》中认为，通过摄心、观心，可以“绝三毒心，永使消亡；闭六贼门，不令侵扰”，最后达到解脱。息妄修心，可以说是捉住了神秀禅法思想的要点。张说在《大通禅师碑》中概括神秀的“开法大略”为：“专念以息想，极力以摄心。其入也，品均凡圣；其到也，行无前后。趣定之前，万缘尽闭，发慧之后，一切皆如。”神秀在观心法门，就是要“摄心”“专念”，通过禅定修行实践，息灭妄念，拂拭客尘，发明本有佛性，进入与真如相应的境界，神秀所观之心，重在“心”的观幻，即能立万法的妄心方面。《大通禅师碑》的铭文中说：“额珠内隐，匪指莫效，心境外尘，匪磨莫照。”神秀的观心法门，不外是静坐观心。但他不是直探心源而安心，而是观妄心为幻，以磨垢而去妄，最终达到心地明净，直证心源。后来的神会将此禅法归纳为：“凝心入定，住心看净，起心外照，摄心内证。”这种“住心看净”、“摄心内证”的功夫，可看作是神秀禅学的主要特徵。净觉记神秀的遗嘱只有三个字：“屈曲直”。“屈曲直”出自《大智度论》：“蛇行性曲，入筒即直；三昧制心，亦复如是。”慧命的《详玄赋》中也引用过：“蛇入筒而改曲”，注曰：“喻定息乱”。这也说明神秀终生禅业，集中在“制心”、“息乱”，即“入定”、“安心”上，其它念佛、净心，观身看心，五事见性等，全是为这一中心任务服务的。
    此外，神秀在《观心论》中认为：“惟观心一法，总摄诸行，最为省要。”由此便将“念佛”法门亦统摄于观心法门之中，他说：“夫念佛者，当须正念，了义为正，不了义即为邪。正念必得往生净国，邪念云何达彼？佛者，觉也，所谓觉察心源，勿念起恶。念者，忆也，谓坚持戒行，不忘精勤。了如此义，名为正念。故知念在于心，不在于言，因筌求鱼，得鱼忘筌。因言求意，得意忘言。既称念佛之名，须行念佛之体。若心无实，口诵空言，徒念虚功，有何成益？具如诵之与念，名义悬殊，在口曰诵，在心曰念。故知念从心起，名为觉行之门；诵在口中，即是音声之相。执相求福，终无是处。”在这一段话中，神秀把念佛与观心联系起来，把向外求佛转为反观自心，他将口诵与心念相区别，认为念佛当须正念，而正念则是“坚持戒行”、“觉察心源”，了知清净自然为正念，执著于音声之相则为邪念，这种念佛实际就是观心看净，把念佛完全纳入“观心”法门之中，其实，统观神秀禅法不难看出，他是将“观心”这一纯粹的反身内省的精神体验来统摄佛教的一切修行活动的。
    神秀以“体用”范畴来组织自己的禅法体系，据《楞伽师资记》载，神秀曾把自己的禅法归结为“体用”二字：“我之道法，总会归体用两字，亦曰重玄门，亦曰转法轮，亦曰道果。”“体”，就是“知心体，体性清净，体与佛同”，一心本觉，亦即诸佛法身；“用”，就是“知心用，用生法宝，起作恒寂，是众生能够接受佛教、自觉修习的内在依据。因此，体用就是一心的本体和作用两个方面，神秀《观心论》中的思想即是对《大乘起信论》“一心二门”说是具体运用，摄心内证的体验，实际上便是神秀体用思想的反映。神秀首先将体用关系直接与《起信论》的一心二门说相结合，通过“观心”这一要门，扫除烦恼障盖，回归于清净朗明的心体，这里本源的清净即是体，而把尘垢拭去即是用。全面拂拭尘垢，由用而体，归于原初清净之性，便是体用关系，其次，他由体用入手，创立了他的“五方便门”：一、总彰佛体门，亦称离念门，依《起信论》说心体离念。它所要求的是通过“看净”的坐禅方便而离念了心，反归本觉。二、开智慧门，亦称不动门，依《法华经》说开示悟入佛之知见。它是从心体本具智慧出发，以智慧为体，以知见为用，要求通过身心不动的禅定而证得佛之知见。三、显不思议解脱门，依《维摩经》说无思无想为解脱，它是要求六根不起，身心离念，不思不议，诸法如如，现一切法正性，四、明诸法正性门，依《思益经》说心不起离自性为正性。要求由明诸法正性而心识不起，心识不起而得智慧之用，即成佛道。五、见不异门，依《华严经》说见诸法无异，自然无碍解脱，以“法界缘起”的圆融无碍思想，将种种禅修方便与所证之境皆融摄于“自心”之中，心无分别起见，法法相即相入，从而自然得无碍解脱。神秀的五方便门，其内容不外是“观心”禅法的展开，其理论依据仍是一心二门的体用说。宗密在论及神秀禅法这一特点时概括为：“拂尘看净，方便通经。”这是符合实际情况的。拂尘看净，即“时时勤拂拭，莫使惹尘埃，”指的是渐修。方便通经，即是禅法的五方便门与经教的会通，指的是借助于经典。拂尘看净需要以静坐禅定为条件，从拂拭尘垢，息妄止念，到证悟佛性，必然是一个渐修的过程。方便通经，以经教为依据而展开禅法，包括《起信论》、《法华经》、《维摩经》、《思益梵天经》、《华严经》等，依然是“藉教悟宗”。对禅定修习的重视和对经典的依持，必然使神秀禅法较多地保持着传统禅法的特色，成为达摩一系真正意义上的继承人。
    考神秀的渐修禅法，实承接楞伽师的余绪。楞伽师从达摩始，就倡舍伪归真，凝住壁观。《续高僧传.达摩传》曰：“入道多途，要惟二种，谓理入行入也。藉教悟宗，深信含生同一真性；客尘障故，令舍伪归真，凝住壁观，无自无他，凡圣第一，坚住不称，不随他教，与道冥符，寂然无为，名理入也。”所谓“理入”的内容是“藉教悟宗”、“舍伪归真”，具体的做法是“凝住壁观”、“壁观者”、实乃“安心”之术。宗密在《禅源诸诠集都序》中说：“达摩以壁观教人安心，外止诸缘，内心无喘，心如墙壁，可以入道。”如果把神秀的思想拿来与达摩所说相比较，可以发现，神秀的“住以观静”与达摩的“凝住壁观”实在没有多大区别。
    神秀的老师弘忍也是主渐修的。在《修心要论》中弘忍说：“既体知众生佛性本来清净，如云底日，但了然守真心，妄念除尽，慧日即现，……譬如磨镜，尘尽自然见性，”此磨镜说很容易使人想起神秀“时时勤拂拭”的偈句，二种说法有小鬼，思想无大殊，均有拂尘看净之义。
    如果按思想渊源说，神秀及其北宗的渐修法门，实更近于“正统”，但佛教思想的发展，除了其自身逻辑思想的推演，更要受时代的制约，因此，神会总有把神秀及其渐修法门推至“师承是傍”境地的历史可能。


二、秀门弟子

二、秀门弟子

    神秀门下人才济济，所谓“升堂七十，味道三千。”《景德传灯录》记神秀法嗣十九人，其中以义福、普寂、景贤、惠福四大弟子为首。《楞伽师资记》曰：
    洛州嵩山普寂禅师，嵩山敬贤禅师，长安兰山义福禅师，蓝田玉山惠福禅师，并同一师学法侣应行，俱承大通和上后。少小出家，清净戒行，寻师问道，远访禅门。……诸师等奉大师十有余年，豁然自证，禅珠独照。大师付嘱普寂、景贤、义福、惠福等，照世炬灯，传颇梨大镜。
    自神秀死后，这些弟子均受到帝室官僚的优礼，声名显赫，成禅宗一时之盛，当时天下坐禅人对这四大禅师评价曰：“法山净，法海清，法镜朗，法灯明。宴坐名山，澄神邃谷；德冥性海，行茂禅枝；清净无为，萧然独步；禅灯默照，学者皆证佛心也。”四人中真正以弘扬东山法门而影响巨大的，是义福和普寂。
    （一）义福禅要
    义福（６５８－７３６），俗姓姜，上党铜鞮（山西沁县）人，幼慕空门，遵母遗训出家，年甫十五，游历于卫、邺地区，好《老》、《庄》、《书》、《易》之说，后于汝南中流出灵泉寺读《法华》、《维摩》等经，又至东都福先寺，师事杜聉法师，广习大乘经论。后听说嵩岳大师法如开演不思议法门，“特生信重，夕惕不遑，既至，而如公迁谢，怅然悲愤，追践经行者久之。”三十二岁时始落发具戒，遂辗转到荆州玉泉道场拜谒神秀大师，居约十年。乃至神秀死于东都，惟有义福“亲在左右，密有传付，人莫能知。”即于此年，自嵩岳寺应邀至长安，于终南山化感寺栖置法堂，宴居廖廓。外示离俗，内得安神。二十余年不出寺门，尽心开演神秀禅慧之业。开元十年（７２２），应长安道俗之请，住京城慈恩寺。十三年（７２５），玄宗东巡河洛，特令赴都，居东都福先寺。十五年（７２７）放还京师。二十二年（７３４），复令入东都，居南龙兴寺。开元二十四年（７３６）卒，年七十九。葬于龙门奉先寺北冈，赐谥曰“大智禅师”，中书侍郎严挺之躬行丧服，撰《大智禅师碑铭》。
    义福当时在两京之地影响甚大，一则他是国师神秀的门人，另外他也得到了唐玄宗的优待，以及当朝官吏如兵部侍郎张均、太尉房官、礼部侍郎韦陟的信服敬重。据载，义福在终南山化感寺时，不远千里来求道者“腾凑物心，延袤山谷”，其中不乏“负才藉贯，鸿名硕德”的“息心贞信之士，抗迹隐沦之辈。”义福在当时，号称“道望高峙，倾动蒲、虢二州，刺史及官吏士女，比卖幡花迎之，所在途路充塞。”后住南龙兴寺，“靡然向风者，日有千数。”义福卒后，其葬礼也十分隆重。“灭仪法事，尽令官给。缙绅缟素者数百人，士庶丧服者有万计。自鼎门至于塔所，云集雷动，信宿不绝。”可见义福当时之威望和影响，严挺之总结说：“禅师法轮，始自天竺达摩，大教东流，三百余年，独称东山学门也。自可、璨、信、忍至大通， 遞相印属，大通之传付者，河东普寂与禅师（义福）二人，即东山继德七代于茲矣。”义福既是一代名僧，又是禅法正宗传人。
    义福在当时是以禅慧名世，开演颇多，但记载他本人思想及言论的文献甚少。据载，他在神有门下所行是“摄念虑，栖榛林，练五门，入七净，毁誉不关于视听，荣辱岂系于人我？或处雪霜，衣食罄匮，未赏见于颜色有厌苦之容。”从此记载中可看出，义福仍保持了苦乐随缘、任运自在、无所怨行的禅者风范。其禅修内容大致不出“练五门、入七净”。所谓“练五门”即是宗密于《圆觉经大疏钞》中所述北宗的“五方便门”，前已叙述。所谓“入七净”，出自《维摩诘经.佛道品》鸠摩罗什对于“七净华”的注。鸠摩罗什谓“七净”为：（１）戒净，即身口所作，无有微恶；意不起垢，亦不取相，亦不愿受生。（２）心净，三乘制服烦恼心、断结心，乃至三乘漏尽羽。（３）见净，即见法真性，不起妄想。（４）度疑净，即见解深透而断除疑惑。（５）分别道净，即善能分别是非，合道宜行，非道宜舍。（６）行断知见净，证得无学尽智、无生智者，能知见所行、所断，，而通达分明。（７）涅盘净。从义福所修“五门”“七净”来看，他仍未旁然无顾，率性直性，直探心源，依然继承了乃师神秀“拂尘看净”、去妄存真的禅法，显得过于拘谨、小心。《碑铭》说他“苦身励节”、“律行贞苦”，或许这是由他王家禅师的身份所限定，无法像山林禅者那样任他风清月白地洒脱自在。再看看他最后的教诫是：“道在心不在事，法由已非由人，当自勤力，以济神用。”这完全是神秀“时时勤拂拭，莫使惹尘埃”的翻版，汲汲于摄心息妄，刻意去炼法修心。严挺之总评说：“苦已任真，旷心济物；居道训俗，不忘于忠孝。”这全然是皇家和尚的口吻。
    （二）普寂心宝
    普寂（６５１－７３９），俗姓冯，蒲州河东（今山西永济县）人，一说长乐信都（今河北冀县）人。原游学于儒典，后弃俗求道，依大梁壁上人、东都端和尚、南泉弘景和尚等处听经受戒学律，深觉为文字所缚，隐居嵩山半岩。“布褐一衣，麻麦一食”，曾欲投少林法如禅师，未至而禅师已卒，“追攀不及”，转谒荆州神秀禅师。师事六年（一说七年），“神秀奇之，尽以其道授焉。”久视中（７００），武则天召神秀赴东都，神秀因荐普寂，乃度为僧。后中宗闻神秀年高，特下诏令普寂继神秀“心宝”，代神秀统其法众。及神秀卒，天下好释氏者的咸师事之。开元十三年（７２５），诏令住都城敬爱寺。十五年（７２７），玄宗将幸东都，诏义福从驾，普寂留都兴唐寺安置。“由是法云偏雨，……闻者斯来，得者斯止，自南自北，若天若人，或宿将重臣，或贤王爱主，或地连金屋，或家蓄铜山，皆毂击肩摩，陆聚水咽，花尽拂日，玉帛盈庭。”开元二十七年（７３９），普寂终于洛阳兴唐寺，寿八十九。诏曰：普寂“资于粹灵，是为法器，心源久寂，戒行弥高。……宜稽其净行，锡以嘉名，示夫净来，使高山仰止，可号大照禅师。”出丧之日，盛况空前，《大照禅师塔铭》载：“金棺发轫，卤簿启行。或两都倾城，或四方布路。持花者林指，执绋者景移。三条之中，泣泪如雨；重城之外，号叩若雷。彩云二时，自都达岳；白露数里，弥川偏空。”《宋高僧传》卷九也说：士庶“倾城哭送，闾里为之空焉。”普寂在中宗以后，一直是两京禅系领袖，同时也是全国禅众的一面旗帜。
    自武后则天迎弘忍门徒入京，中宗、睿宗独尊神秀一支，北宗一直是钦定的禅宗正统，神秀死后，义福控制两京，而以居于洛阳的普寂势力最盛。开元以来，普寂被视作北宗嫡传，号称七祖，直至刘禹锡时还承认，中夏之中“言禅寂者宗嵩山。”在唐宋的佛典中，嵩山即是指由普寂继承的神秀禅系。唐中宗诏于嵩岳寺为神秀追造十三级浮图，敕令普寂统帅僧众，都表明了普寂的帝师身份。李邕撰《嵩岳寺碑》，列达摩以来的传承，以“忍遗于秀，秀钟于今和尚寂”，正反映了当时的社会舆论。
    普寂的禅法基本与义福一致，共同承继了神秀的禅学思想。普寂在神秀处时，曾充僧使，其所作为为他人所不能为。因而深得神秀器重，尽其道授之。神秀所授心宝，即是：“良马易进，良田易平。加之思修，重之勤至。宝镜磨拂，万象乃呈。玉水澄清，百丈皆见。衡山之石，更悟前身，新丰之家，自然本处。”心法相传，普寂由此所修得的则是“心无所存，背无所倚；都忘禅睡，了悟佛知。”普寂以此为准，深悟禅理，“如此者复地年，大通和尚深赏重之。”开元十五年，唐玄宗在诏书中赞颂普寂的禅法说：
    其始也，摄心一处，息虑万缘，或刹那便通，或岁月渐证。总明佛体，曾是闻传；直指法身，自然获念。滴水满器，履霜坚冰。故能开方便门，示真宝相；入深固藏，了清净因；耳目无根，声色亡境，三空圆启，二深洞明。
  这说明普寂的禅法仍然是神秀思想的延续。摄心于一处，息虑万缘，对境不起，经此“磨拂”、“看净”的功夫，自然便可“刹那便通”，或者“岁月渐证”，即可以先渐修而后顿悟，也可以先顿悟后渐修，所谓“开顿渐者，欲依其根。”证悟者的顿渐之别，只是全凭众生不同的要根机，这是一种较有新意的说法。经过学习经论，总明佛体之所在，便可直指法身，自然获念。即自识本性，六根不为诸境惑，了知佛体在心中，这一修习过程，便也如“滴水满器，履霜坚冰”，这一思想所显示的是地道的北宗禅系风格。
    此外，普寂与义福同样注重戒律在禅众修行中的作用，据说他在决心转入禅门时，已经认识到“文字是缚，有无是边，盍不以正戒为墙，智常为座？”他的最后遗训中有“尸（戒）波罗蜜是汝之师，奢摩地（定）门不汝依处。”坚持传统佛教中的戒禅并行，强调了戒律对于当时禅众僧团的重要性。《宋高僧传》说他“严重少言”，其性凝重，持戒清慎，从不张伐其德，“远近尤以此重之”，显示了他作为一代国师、禅学领袖的职责所在。
    史载，神秀虽受帝王推重，然未曾大规模地聚众开堂演法，所谓“云从龙，风从虎，大道出，贤人睹，岐阳之地，就者成都；华阴之山，学来如市，未云多也”！亦只是就其影响而言。而普寂自中宗时代其师统摄禅门，于京城广行弘化，三十余年间使禅门大盛。他的门徒较义福更多，所谓“摄之孔多，学者弥广”，在当时全国禅门派系中，他的宗系势力最强。李邕所撰《大照禅师塔铭》说：“四海大君者，我开元圣文神武皇帝之谓也；入佛之智，赫然为万法之宗主者，我禅门七叶大照和尚之谓也。”在开元盛世，唐代第一大手笔的李邕将禅师普寂与皇帝玄宗相比附，足见普寂其时之声望。时人誇曰：“普寂禅师，名字盖国，天下知闻，众口共传，不可思议。”相比之下，当时慧能一系尚局限于岭南一隅一地传教活动，其禅门远默默无闻。故宗密说：
    能大师灭后二十年中，曹溪顿旨，沉废于荆吴；嵩岳渐门，炽盛于秦洛。普寂禅师，秀弟子也，谬称七祖，二京法主，三帝门师；朝臣归崇，敕使监卫。雄雄若是，谁敢当冲。
    尽管此段话中语气不无夸张成份，但北宗一系在当时的确是声势浩大。所谓“两京之间，皆宗神秀，”“北宗门下，势力连天。”于半个世界内成为禅界分认的正统禅学所在。
    然而谁也不曾想到，曾几何时，显赫一时的北宗基业竟会在不太长的时间内灰飞烟灭。到一百年后，柳宗元在撰写《赐谥大鑑禅师碑铭》时，竟然会高唱“今布天下，凡言禅皆本曹溪”，这是禅宗史上的一次巨变，而这一扭转乾坤者，便是慧能的弟子荷泽神会。


三、法统之争

三、法统之争

    神会（６８４－７５８），襄阳人，俗姓高。据《宋高僧传》记载，神会“年方幼学，厥性惇明，从师传授《五经》，克通幽赜。次寻《庄》《老》，灵府廓然。览《后汉书》，知浮图之说。由是于释教留神，乃无仕进之意，辞亲投本府国昌寺颢元法师下出家。”这说明神会自小就普接受过良好的传统文化教育。及至学佛，“讽诵群经，易同反掌，全大律仪，匪贪讲贯。”这为他日后成为慧能门下辩才无碍的鼓吹者打下了良好的基础。
    据载，神会出家后，在投奔慧能之前，曾师事神秀三年，“先事北宗神秀三年。秀奉敕追入。和上遂往岭南。”神会“闻岭表曹侯溪慧能禅师盛扬法道，学者骏奔，乃效善财南方参问，裂掌裹足，以千里为跬步之间耳。”神会在曹溪慧能处修学四年，在寺中辛勤执事，效慧能当年“腰石碓米”的精神，“苦行供养，密添众瓶，研冰济众，负薪担水，神转巨石等。”又“策身礼称，燃灯殿光，诵经神卫，律穷五部，神感紫云。”深受慧能器重，其间，他曾一度外出游历，偏寻名迹，广其见闻，并至西京受戒。景龙年中，又重回曹溪。慧能“大师知其纯熟，遂默授密语。”此后，神会常在慧能左右，成为慧能晚年的得意弟子。王维《六祖能禅师碑铭》中说他：“过师于晚景，闻道于中年。广量出于凡心，利智逾于宿学。虽末后供，乐最上乘。”慧能死扌，他又云游四方，四处参访，到了玄宗开元八年（７２０），敕配住南阳龙兴寺，故有“南阳和上”之称。他在南阳传布禅学，名声渐起。南阳太守王弼、内乡县令张万顷都向他问法。他还见到侍御史王维，王维称赞说：“南阳郡有好大德，有佛法，甚不可思议”。由于他答王琚（王赵公）所问“三车”义，更使他“名渐闻于名贤。”
    神会北归之后，神秀已卒十余年，其弟子普寂等正享盛誉，所谓“两京之间皆宗神秀”，“曹溪顿旨沉废于荆吴，嵩岳渐门炽盛于秦洛。”神会有感于此，遂于开元二十二年（７３４）在滑台（今河南滑县）大云寺开“无遮大会”，公开抨击普寂一系，正式向神秀北宗发起进攻，这是禅宗史上的重要事件，也是关于慧能六祖地位的关键之处。
    神会是挑起南北禅宗之争的第一人，其原因虽有教理、教义方面的是非判断，但更集中地是表现于宗统的争夺。
    宗统之争，由普寂妄立神秀为六祖而引起，神秀以后，普寂继承了北宗法师，统领天下禅众，他想借立神秀为六祖之名，行自己欲为七祖之实。当然，神秀一系当时以两京为基地，在中原以及整个北方地区拥有强大的势力，半个世纪里确实是禅界公认的达摩一系正统禅学所在。从传统的佛教师徒授受角度看，普寂确立法统亦不为过，普寂尚未去世时，李邕即在《嵩岳寺碑》中叙说了北宗法统，碑云：“达摩菩萨传法于可，可付于璨，璨授于信，信咨于忍，忍遗于秀，秀钟于今和尚寂，皆宴坐林间，福润宇内。”该碑立于公元７３９年，正是神会滑台大会之后，“大行禅法，声彩发挥”时，北宗抢先将未亡人普寂列入传承，可看作是南北宗争夺正统门争激化的表现。也是对神会抨击的一种反映。《大照禅师塔铭》又载普寂临终付嘱云：“吾受托先师，传茲密印，远自达摩菩萨导于可，可进于璨，璨钟于信，信傅于忍，忍授于大通（神秀），大通贻于吾，今七叶矣。”这表明普寂确有建立宗统之事，故引发了“法统之战”。
    神会与当时“两京名播，海外知闻”的神秀系山东崇远法师公开展开关于南北禅宗是非邪正的辩论，神会以菩提达摩“南天竺一乘宗”正传自诩，认定普寂所立的法统是伪造的，弘忍并不曾传法给神秀。他提出一个修正的传法系统：达摩“传一领袈裟以为法信授与慧可，慧可传僧璨，僧璨传道信，道信传弘忍，弘忍传慧能，六祖相承，连绵不绝。”并说：“秀禅师在日，指第六代传法袈裟在韶州，口不自称第六代，今普寂禅师自称第七代，妄竖和尚为第六代，所以不许，”这样看来，法统之争，主要集中于“六祖”桂冠的归属。因普寂是神秀公认的大弟子，而神会又以慧能的嫡传而自居，所以，只要“六祖”确定，那“七祖”自然不必言说。
    其实，据史载，“六祖”法统之争在弘忍之后并非显明，即使神秀、慧能二位“六祖”当事人亦未十分在意。五祖弘忍“法门大启，根机不择”，广接天下学人，受其教诲者无数。据净觉《楞伽师资记》所载，弘忍在临终前曾说：“传吾道者，只可十耳，”这些弟子“并堪为人师，化一方人物。”其中并未特别举某弟子为第六代传法人。弘忍去世后的一段时间里，上首弟子之一的法如（６３８－６８９）曾享有极高的声誉。据《唐中岳沙门释法如禅师行状》记载，法如在弘忍处奉待，前后十六载，“祖师默辩先机，即授其道，开佛密意，顿入一乘，”弘忍死后，“居少林寺，处众三年，人不知其高，所以守本全朴，弃世浮荣。廉让之德，贤士之灵也。”垂拱二年（６８６），“四海标领僧众，集少林精舍，请开禅法。”时“学侣日广，千里向会”。于永昌元年（６８９）寂然卒世，春秋五十有二。
    法如作为五祖上首弟子之一，其禅法受到僧众普遍推崇，在生前及死后享有很高的声誉。神秀的弟子义福和普寂都是先寻法如，因法如迁谢总改投神秀门下的。开元十三年智俨撰《大唐中岳东闲居寺故大德珪和尚纪德幢》中说：“（法如）大师，即黄梅忍大师之上足也。故知迷为幻海，悟即妙门。”将法如称为弘忍大师之上足弟子，开元十六年裴漼撰《皇唐嵩岳少林寺碑》说：“皇唐贞观之后，……复有大师讳法如，为定门之首，传灯妙理。”可见时人已称法如为“定门上首”，最早对法如作出法统定位的要数立于法如逝世当年的《唐中岳沙门释法如禅师行状碑》。关于禅宗法统继承，碑中说：“南天竺三藏法师菩提达摩，绍隆此宗，武步东邻之国，传曰神化幽迹。入魏传可，可传璨，璨传信，信传忍，忍传如，当传之不可言者，非曰其人，孰能传哉！”这是关于禅宗法系最早的一个传承表，这里尽管没有明言法如即是“六祖”，但其中所透出的信息却是明了的。此碑立于永昌元年（６８９），上距五祖弘忍之死只有十五年。当时，神秀、道安、玄赜、慧能等均在世。神秀还在湖北的玉泉寺，尚未入京，而慧能远在岭南，初为曹溪信众说法。此时，客观上并未形成法统之争。
    从现有史料来看，法如本人也没有争法的意图。《法如碑》中说他：“守本全朴，弃世浮荣。廉让之德，贤士之灵也，外藏名器，内洽玄功，庶几之道，高遁之风也。”可见他是一个操作严谨、不尚浮华的禅师，他所注重的只是自心的证悟，所谓“子勤行之，道在其中矣”，日后他的开堂演法，完全是屡辞不获的结果。“垂拱二年，四海标领僧众，集少林精舍，请开禅法。”众人说：“始自后魏，爰降于唐，帝代有五，年将二百。而命世之德，时时间出，咸以无上大宝，贻诸后昆。今若再振玄纲，使斯闻者，光复正化。师闻请已，辞对之曰：言寂则意不亡，以智则虑未灭。若顺诸贤之命，用隆先圣之道，如何敢矣！犹是谦退，三让之乃许焉。”《大唐中岳东闲居寺故大德珪和尚德幢》也说，法如开演禅法，是因珪和尚“与都城大德，同造少林，请开禅要”所致。即使法如在诸贤名德的再三请求下开法，亦未特意注重延续法统。《法如碑》记载，法如公开承认自己没有合达的法嗣，说：“当传之不可言者，非曰其人，孰能传哉。”所以，法如临终前曾留下遗训，要他的弟子“而今已后，当往荆州玉泉寺秀禅师下咨禀。”但这也确实反映了一个历史事实，即在弘忍逝世后，而神秀未发达前，法如确曾是这一时期北方禅法的主要代表人物。
    我们再来看神秀。神秀是众所公认的五祖弘忍的大弟子，他在弘忍门下时“决心苦节，以樵汲自役而求其道”，尽管“服勤六年，不舍画夜。（弘忍）大师叹曰：东山之法，尽在秀矣，”并曾预言神秀与玄赜日后“当以佛日再晖，心灯重照。”但神秀并未有贪“六祖”圣位之心。弘忍一日让门人各呈一偈，若有悟佛法大意者，即可付衣法，禀为六代。众门人因神秀上座乃教授师，故尽息心，不曾作偈。《坛经》记曰：“上座神秀思惟诸人不呈心偈，缘我为教授师，我若不呈心偈，五祖如何得见我心中见解深浅？我将心偈上五祖呈意，求法即善；觅祖不善，却同凡心夺其圣位。若不呈心偈，终不得法，良久思惟，甚难甚难。”从中可看出，神秀顾虑重重，踌躇良久的困惑，恰恰在于怕别人误解自己是为了祖位，而非为禅法。及至弘忍卒后，神秀“涕辞而去，退藏于密。”《传法宝记》更具体地说神秀“后随迁适，潜为白衣，或在荆州天居寺，十余年，时人不能测。”直至仪凤中（６７６－６７８），“荆楚大德数十人，共举度住当阳玉泉寺，”始取得“名在僧录”的合法地位。这时他已是古稀之年了。实际上，他本人也并未住于玉泉寺内，而是在寺东七里的“地坦山雄”处，他曾说：“此正楞伽孤峰，度门兰若，荫松藉草，吾净老焉。”有终老于此之意。《传法宝记》说：“然十余年间，尚未传法，”直至法如去世，学徒纷纷来归，所谓“自如禅师灭后，学徒不远万里，归我法坛，”总不得已而开法，“遂开善诱，随机弘济，”可见神秀亦无争法统的意图。及至后来影响日重，“天下志学，莫不望会，”，“学来如市”，为武则天、中宗所崇敬，被推为“两京法主，三帝国师”，但此并非完全出于神秀本意。《大通神秀和尚塔文》云：“师常晦迹栖真，久乎松壑。诏自江国，只命上京。而云林之情，肯忘山水。”他“屡乞还山”，诏不许。说明神秀并未凭借自己的政治特权来确立自己的法统地位。如作于开元十三年（７２５）的《珪和尚幢》在述李元珪之师承时说：“自达摩入魏，首传惠可，可传璨，璨传信，信传忍，忍传如，到和尚（即李元珪）凡历七代，皆为法主，累世一时，”李元珪卒于公元７１６年，其时神秀的地位及名声均远超过法如，李元珪尽管在法如殁后曾“暂之荆府，寻及嵩山，”在神秀门下呆过，但碑中仍明言其为法如门下。这说明当时“六祖”法统之争并不明显，北宗神秀一系亦没有在这个问题上采用政治权威来施加任何压力。即使在神秀为朝野所重、声望如日中天之时，也没有排斥打击南方的慧能一系，反倒介绍自己的门徒去慧能处参学，并多次向武则天和唐中宗举荐或亲自邀请慧能。《坛经》载，神秀对其门人说，慧能“得无师之智，深悟上乘，吾不如也，且吾师五祖亲传法衣，岂徒然哉？吾恨不能远去亲近，虚受国恩，汝等毋滞于此，可往曹溪参法”。可见当时门户之见并不深。《宋高僧传》亦载云：“初秀同学能禅师与之德行相埒，互得发扬无私于道也。赏奏天后请追能赴都，能恳而固辞。秀又自作尺牍，序帝意徵之，终不能起，谓使者曰：‘吾形不扬，北士之扬，北土之人见斯短陋，或不重法。又先师记吾以岭南有缘，且不可远也。’了不度大庾岭而终。”唐中宗《召曹溪慧能入京御札》云：“朕请安、秀禅师宫中供养，万机之暇，每究一乘。二师并推让云：南方有能禅师，密受忍大师衣法，可就彼问。”这反映了弘忍诸弟子最初相互之间的并存关系。直到神秀去世，法统问题仍未突出出来。
    确实，迄今为止的全部初期禅宗史资料表明，弘忍究竟传法于谁，并无一致的确切记载，所谓弘忍传法于神秀或慧能之说皆出自开元八年（７２０）神会入洛之后，实际上，弘忍时代，弟子众多，人才辈出，十大弟子各具千秋，均可为一方化主，所以《传法宝记》说：“及忍、如、大通之世，则法门大启，根机不择，齐速念佛名，令净心，密来自呈，当理与法，犹遞为秘重，曾不昌言。”这就是说，弘忍时代由于门下僧才济济，得法者众多，实行的是一种“密来自呈，当理与法”的传法方式，也正因为如此，弘忍门下各传法弟子总各排传承法系，以传东山法门的正宗自居，这样就先后出现了许多不同的传承说法。法如系说：达摩“入魏传可，可传璨，璨传信，信传忍，忍传如。”玄赜系将玄赜与神秀并列为传东山之法的第七代楞枷师。记弘忍临终嘱玄赜说：“吾涅盘后，汝与神秀，当以佛日再晖，心灯重照。”老安系记弘忍嘱咐说：“学人多矣，惟秀与安。”“今法当付，付此两子。”这样，老安与神秀又成为弘忍的嫡传。神秀系说：“东山之法，尽在秀矣。”“达摩菩萨传法于可，可付于璨，璨授于信，信咨于忍，忍遗秀，秀钟于今和尚寂。”神秀的弟子“普寂禅师为秀和尚竖碑铭，立秀和尚为第六代，”并“修《法宝记》，又立如禅师为第六代”，随后神秀门下又立普寂、义福为第七代。义福碑铭说：“禅师法轮，始自天竺达摩。大教东流，三百余年，独称东山学门也。自可、璨、信、忍至大通，遞相印司，大通之传付者河东普寂与禅师二人，即东山继德，七代于茲矣。”此后独狐及（７２５－７７７）有《舒州山谷寺觉寂塔隋故镜智禅师碑铭》，追述禅宗的传承云：“菩提达摩大师始示人以诸佛心要，人疑而未思，惠可大师传而持之，人思而未修。迨禅师三叶（僧璨），其风浸广，真如法昧，日渐月渍。……其后，信公以教传弘忍，忍公传慧能、神秀。能公通而老曹溪，其嗣无闻焉。秀公传普寂。”从中可以看到弘忍门下闇自排列传承法系中隐约可见的门户之见，也可看到当时诸派出于同门间的相互容忍认可。即使神秀和慧能两系亦未至水火不容的地步。
    正是面对当时禅宗内部法系混乱，莫衷一是的局面，神会携慧能禅法北上，“直入东都，面抗北祖，龙鳞虎尾，殉命忘躯。”，“为天下学道者辨其是非，为天下学道者定其旨见。”他有滑台大云寺无遮大会上公开指责当时势力极大的神秀一系是“传承是傍，法门是渐”，非弘忍所传之正宗，在辩论中，他提出了一个与北宗相对立的南宗传法系统：“达摩……授与慧可，慧可传僧璨，璨传道信，道信传弘忍，弘忍传慧能；六代相承，连绵不绝。”滑台大会之后，南北二系“相见如仇雠”的序幕渐渐拉开，争夺嫡系的门争也愈演愈烈。双方不但立碑作记，论定祖师，而且都借助于政治势力来抬高自己，甚至不惜将对方置于死地。《圆觉经大疏钞》卷三记载，神会有滑台演两宗之真伪后，“便有难起，开法不得”，甚至“三度几死。商旅缞服，曾易服执秤负归，百种艰难。”后来，神会还是得到兵部侍郎宋鼎的支持而得以入洛：“天宝四载（７４５），兵部侍郎宋鼎，请入东都，然正道易申，谬理难固。于是曹溪了义，大播于洛阳；荷泽顿门，派流于天下。”此时普寂和义福都已先后去世，神会抓住这一有利时机，积极鼓吹曹溪宗旨，不久又“于洛阳荷泽寺，崇树能之真堂，兵部侍郎宋鼎为碑焉。会序宗脉，从如来下西域诸祖外，震旦凡六祖，尽图绘其影，太尉房琯作《六叶图序》。”神会在荷泽寺为慧能建堂立碑。又依照南宗宗统画了《六叶图》。神会借助宋鼎、房琯的政治势力而声名大振。《宋高僧传》说：神会“于洛阳大行禅法，声彩发挥。先是，两京之间皆宗神秀，若不淰之鱼鲔附沼龙也。从见会明心六祖之风，荡其渐修之道矣。南北二宗时始判焉。”由此可见，神会确是分判南北禅宗之别、造成南北禅宗对抗的关键人物。宗密在《禅门师资承袭图》中也佐证说：“天宝初，荷泽入洛，大播斯门，方显秀门下师承是傍，法门是渐。既二宗双行，时人欲拣其异，故标南北之名，自此而始。”《祖堂集》卷三《荷泽和尚传》中也说：“荷泽和尚嗣六祖，……自传心印，演化东都，定其宗旨。南能北秀，自神会现扬，曹溪一枝，始芳宇宙。”神会在洛阳的活动，尽管使“普寂之门盈而后虚。”但普寂一系毕竟在洛阳苦心经营数十年，他们并不会是善罢甘休，洛阳是北秀的势力中心，他们在扩大自身法统传承、宣扬神秀禅法的同时，也同样借助和动用了政治手段来维护自己的法统地位，神会的成功马上受到北宗信徒严励的反击。“天宝中，御史虑奕阿比于寂，诬奏会聚徒，疑萌不利。玄宗召赴京，时驾昭应，汤池得对，言理允惬，敕移往均部。二年，敕徒荆州开元寺般若院住焉。”神会被排挤出洛阳，远徒湖北。据《圆觉经大疏钞》记，神会在不到二年的时间里，被迫四迁住地：“天宝十二年，被谮聚众，敕黜弋阳郡，又移武当郡。至十三载，恩命量移襄州。至七月，又敕移荆州开元寺。皆北宗门下之所毁也。”神会被贬的第三年，时局突变，“安史之乱”的爆发给了神会一个时来运转的机会。《宋高僧传》记载说：
    十四年，范阳安禄山举兵内向，两京版荡，驾幸巴蜀，副元帅郭子仪率兵平殄，然于飞挽索然。用右仆射裴冕权计，大府各置戒坛度僧，僧税缗谓之香水钱，聚是以助军须。初洛都先陷，会越在草莽，时虑奕为贼所戮，群议乃请会主其坛度。于时寺宇宫观，鞠为灰烬，乃权创一院，悉资苫盖，而中筑方坛，所获财帛顿支军费。代宗、郭子仪收复两京，会之济用颇有力焉。
    就这样，神会为唐王朝立了一大功，因而受到了帝室的重视，“肃宗皇帝诏入内供养，敕将作大匠，并功齐力，为造禅宇于荷泽寺中。”不久，神会病逝，皇室给予极高礼遇。《圆觉经大疏钞》卷三记载说：“宝应二年，敕于塔所置宝应寺。大历五年，敕赐祖堂额，号真宗般若传法之堂。七年敕赐塔额，号般若大师之塔。贞元十二年，敕皇太子集诸禅师，楷定禅门宗旨，遂立神会禅师为第七祖。”并“御制七祖赞文，见行于世。”神会受皇帝之敕，被立为禅宗七祖，有了政治上的保障，从而慧能作为禅宗的六祖也就有了依据。如《宋高僧传》所云：“会之敷演，显发能祖之宗风，使秀之门寂寞矣。”尽管日后禅宗的发展几乎湮没了这位“七祖”，但慧能“六祖”的地位却从此无法动摇。刘禹锡在《大唐曹溪第六祖大鑑禅师第二碑》中记载说：“元和十一年某月日，诏书追褒曹溪第六祖能公，谥曰大鑑。”柳宗元《曹溪大鑑禅师碑》中则有“其说具在，今布天下，凡言禅，皆本曹溪”的说法，自此，“六祖”之位，有了定说，南北之争亦就告一段落。


四、南北分宗

四、南北分宗

    神会为了使慧能曹溪顿旨取得正统地位，不避艰危，挺身与北宗抗争，指斥当时势力连天的普寂一系“师承是傍”，确实具有大无畏的精神和勇气，《南宗定是非论》中记载，崇远法师威胁神会说：“普寂禅师名字盖国，天下知闻，众口共传，不可思议。如此相非斥，岂不与身命有雠？”神会回答说：“普寂禅师与南宗有别，我自料简是非，定其宗旨，我今谓弘扬大乘，建立正法，令一切众生知闻，岂惜身命？”崇远法师又问神会；如此行事，难道“不为求名利乎？”神会说：“生命尚不惜，岂以名利关心？”足见神会为法忘身的精神。神会对禅宗的贡献也就具体体现在这次定夺祖位的门争中。他大力宣扬慧能顿悟禅法，使这一禅法由偏于一隅的岭南山区而广播京洛中原之地，他提出了与北宗相对立的南宗宗法，最终代替北宗，而成为禅门中的正统所在，确实为南宗禅立下了汗马功劳。胡适先生评价神会是“南宗的急先锋，北宗的毁灭者，新禅学的建立者。”“在中国佛教史上，没有第二人有这样伟大的功勋，永久的影响。”直至晚年，他仍坚持此观点，认为神会是“中国神宗佛教的开山宗师”，说禅宗南宗是神会一个人单刀匹马打出来的。
    我们说，慧能禅能够北上，取代神秀系而盛行，打破了东山门下北宗独盛的局面，造成了“南顿北渐”两宗对峙的历史态势，神会固然在中间起了巨大的推动作用，但这种作用并不是惟一的或决定性的，而主要的原因是在于神秀系禅法和慧能系禅法各自的特点以及当时的社会历史状况。我们根据《南宗定是非论》中神会的记述来看看南北宗的相异之处：
    首先是传承的傍正：即认为历你祖师相承，以传衣为信，令弘法者得有禀承，学道者得知宗旨，“达摩遂开佛知见，以为密契，便传一领袈裟，以为法信，授与慧可。慧可传僧璨，璨传道信，道信传弘忍，弘忍传慧能。六代相承，连绵不绝，”在唐中宗的诏书《召曹溪慧能入京御札》中也说：“朕每究一乘，安、秀二师并推让云，南方有能禅师，密受忍大师衣法，可就彼问，”神会还现身说法，说自己原属神秀门下，正是听了神秀所说“韶州有大善知识，元是东山忍大师付嘱，佛法尽在彼处”的话，总离开神秀而改投慧能。神秀本人也承认衣法在慧能处：“秀禅师在日，指第六代传法袈裟在韶州，口不自称为第六代。”所以神会特别指出：“衣为法信，法是衣宗。衣法相传，更无别付。非衣不弘于法，非法不受于衣。衣是法信之衣，法是无生之法。”这明确说，法衣所在之处，便是禅宗正统之所在。神秀一系只是傍出而非正宗。
    其次，法脉单传还是多传并弘的不同：南宗认为，“自达摩大师之后，一代只计一人。中间尚有二三，即是谬行佛法”。而普寂一系却并立法如和神秀为第六祖，这样，东山法门“一代一人”的承传法统就乱了纲常，神会将此斥为“饰鱼目以充珍，将夜光而为宝。”
    第三，法门的顿渐：南宗禅强调顿悟禅法，以顿悟为惟一方式，取代了传统的修行积累。但北宗的立足点是渐修。神会为宣传南宗一系的顿悟法门，突出攻击北宗“法门是渐”，着意把南北禅宗的差别判为顿、渐的原则分歧，南北之异“皆为顿渐不同”，所以“我六代大师一一皆言单刀直入，直了见性，不言阶渐。”
    第四，禅修方法不同：“今言不同者，为秀禅师教人凝心入定，住心看净，起心外照，摄心内证。”这种方法以坐为禅，摄取心念，息妄除染，是妄心法缚，有所执著，“皆是障菩提道。”神会认为：“从上六代以来，无有一人凝心入定，住心看净，起心外照，摄心内证”，皆以念不起为坐，以见本性为禅。“所以不教人坐身住心入定。”
    第五，与帝室的关系不同：“崇远法师问：秀禅师为两京法主，三帝门师，何故不许充为六代？（神会）和上答：从达摩已下，至能和上、六代大师，无有一人为帝师者。”四祖道信，居黄梅三十年，唐太宗数遗使徵召不赴，后虽加严命，仍不为之屈。五祖弘忍追随四祖，后唐帝室召之入京，亦不从命。慧能亦两次为唐王朝所召请，均予拒绝，确实继承了东山法门与王朝政治不相牵涉的传统，而北宗门下却皆依傍王室，被尊为“法主”、“国师”，受禁中供养。
    第六，弘忍地域的不同，慧能禅主要流传于中国南方，神会便假借菩提达摩“南天竺一乘宗”一名而以正统自居，而不许神秀弟子普寂禅师妄称南宗：“秀和尚在日，天下学道者号此二大师为‘南能北秀’，天下知闻。因此号，遂有南北两宗，普寂禅师实是玉泉学徒，实不到韶州，今口妄称南宗，所以不许。”这样，“南天竺一乘宗”演变成为中国的南宗。
    综合以上神会对北宗的种种抨击，不外是两条：“师承是傍”、“法门是渐”，所谓“师承是傍，”是说弘忍传法于慧能，故南宗是正统，北宗为傍门。正宗与否的根据，则是以袈裟为证：“从上相传，一一皆与达摩袈裟为信。”所以袈裟成了正法宗旨所在，嫡传的信物。其实，这类袈裟的故事，仍有待考证，除各类禅宗史传上这一记载大多隐约含糊外，在历史上就有人发出疑问，认为这是神会争夺正统的手段之一。刘禹锡曾作《佛衣铭》说：“民不知官，望车而畏；俗不知佛，得衣为贵。”又说：“六祖未彰，其出也微，既还狼荒，憬俗蚩蚩。不有信物，众生曷归？”所谓“法门是渐”，则是指南北两宗对参悟途径方式见地上的差别。南宗主顿悟，而北宗主渐修。其实，神秀一系也不是完全否定“顿悟”的，神秀认为：“一切善业自由心生，但能摄心，离诸邪念，……即为解脱。”所以他在注重“时时勤拂拭”的同时，反复强调了“顿悟”，他在《大乘无生方便门》中说：“诸佛如来，有入道大方便，一念净心，顿超佛地。”“起心思议是缚，不得解脱，不起心思议则离击缚，即得解脱。”解脱与否，只在一念之间。《大乘五方便》中也说：“悟则朝凡暮圣，不悟永劫常迷。”《观心论》更说：“但能摄心内照，觉观常明，绝三毒心，永使消亡，闭六贼门，不令侵扰，自然恒沙功德，种种庄严，无数法门，悉皆成就。超凡证圣，目击非遥。悟有须臾，何烦皓首？”这说明，顿悟也是神秀的主张。张说在《大通禅师碑》中就点明这一点：“一念而顿悟佛身。谁其宏之？实大通禅师其人也。”普寂也说过：“或刹那便通，或岁月渐证。总明佛体，曾是传闻，直指法身，自然获念。”所以，如果说“北宗但是渐修，全无顿悟，”是不符合史实的。但若从南北禅宗的立足点看，则“南顿北渐”确实标志着南北禅宗禅法上的差异。“南顿”指的是南宗重顿悟。“北渐”是说北宗重渐修，二者的重要区别就在于：北宗禅法始终着眼于“息妄”的渐修，它的“顿悟”只是建立在渐修种种“观心”的禅定方便法门基础之上，而不像南宗教那样，始终着眼于直了心性的“顿悟”。
    综上所述，北宗禅师具有禅法守旧、依附帝室的共同性，而南宗禅师具有创新立异、不依王权、独处山林的属性，这样的结果必然是禅法守旧、终敌不过改革了顿悟新论；依附帝室，终免不了改朝换代的遗弃。
    事实也说明，南北禅宗的兴衰，是历史的必然。安史之乱打击了数百年之久的门阀士族经济，从而也改成依附于这一经济基础的佛教宗派的衰退，而与此基础没有联击或联击较少的佛教宗派得以免遭厄难。“会昌法难”后，其表现更为明显，以寺院为主要依据的北宗禅完全衰败，而最终走上了依附帝室道路的神会系也一蹶不振，历史没有选择神秀一系，同样也没有选择神会一系，唐末五代兴盛起来的恰恰是保持了山林佛教特色的江西马祖与湖南石头门下的南宗禅。所以，神会在中国禅宗史上的地位问题仍应给予正确的看待。
    对于这一问题，目前已有许多学者论及，他们认为，中国佛教的一线生机，就是仗着禅宗这一宗承续连绵以至于今日，我们在推崇禅宗这一大功德时，却不可忘记当年拼命弘扬这一派禅宗的神会和尚。所以中国佛教的幸存，是存在这个神会手里，但中国佛教的衰亡，也就亡在这位神会和尚手里，北宗是渐修，南宗是顿悟；北宗重在行，南宗重在知，北宗主由定生慧，南宗主以慧摄定，这是两宗最大的差异，现在推翻北宗而专弘南宗，便是不尚渐修，而惟尚顿悟，不重行而惟重知，不主由定生慧，而主以慧摄定，这是神会和尚所造成的一种风气。由此主张导向，致使当时的僧人，以不立文字而轻弃一切经卷，以无念为宗而指斥修习有为，以定慧齐等而反对坐禅入定，以立地成佛而破除三劫五乘，以机锋肆应而驰鹜空谈玄辩，莫不舍难趋易，弃实崇虚，积习相承，每况愈下，甚至不知圣教究何所说，不知修行应何所依，正信还未生根，便说已经“开悟”，菩提尚未发心，侈谈已经“见性”，于是满街圣人，遍地野狐，这主要的根源之一，便是专弘南宗的流弊，而这位神会和尚，不能不负这个责任，本来南宗之高于北宗，如人立于塔顶，如果将塔基拆除，自己便无从依傍，上焉者悬空过活，下焉者堕落深坑，这便是推翻北宗而偏弘南宗之弊，北宗实为初首之方便，南宗实为向上功夫。南宗高于北宋，不离北宗；顿悟高于渐修，不离渐修，一念相应，便成正觉，这于大根器人，自可不假修持，但于一般障深业重的凡夫，仍须由修而悟，由行而知，由定而慧。宗密在《禅源诸诠集都序》中说：“原夫佛说顿教渐教，禅开顿门渐门，二教二门，各相符契。”顿渐之门犹如车之两轮，鸟之双翼，缺一不可，如古德云：理虽顿悟，事须渐除，若隔绝二门，则会造成顿渐的对立，无所凭乘，绝却初学入道的坦途。所以宗密主张顿悟资于渐修，以佛法般若为依据来会通诸宗，克服偏执一边的局限性。《宋高僧传》卷八《神秀传》中“系”曰：
    夫甘苦相倾，气味殊致，甘不胜苦则纯苦乘时，苦不胜甘则纯甘用事，如是则为药治病，偏重必离也。昔者达摩没而微言绝，五祖丧而大义师，秀也拂拭以明心，能也俱非而唱道。及乎流化北方，尚修练之勤；从是分歧南服，兴顿门之说。由茲荷泽行于中土。以顿门隔修练之烦，未般磐石；将絃促象韦之者，空费躁心，致令各亲其亲，同党其党，故有虑奕之弹奏，神会之徒迁，伊盖施疗专其一味之咎也，遂见甘苦相倾之验矣。理病未效，乖竞先成。只宜为法重人，何至因人损法。二弟子濯击师足，洗垢未遑，折胫斯见，其是之喻欤。
    这可看作是对“南能北秀”相对立这一历史悲剧的最好总结，这也是今后禅学复兴的最好借鉴。对于秀、能二师，特别是神秀的渐修法门，要重新有一个客观公允的评价和认识，清人梅雨田曾有诗云：“菩提非树镜非台，一物都无识本来。信说南能修苦行，应知北秀亦多才。”
    尽管神会北上之后，使“曹溪了义大播于洛阳，荷泽顿门派流于天下。”而神秀门下寂寞，但神秀北宗一系并未从此销声匿迹。其法脉传系几乎延续至唐末，在传承上甚至比神会系更为久远。
    史实表明，安史之乱以后，北秀仍然绵延发展了百年之久。北宗门人独孤及于大历七年（７７２）所作的《舒州山谷寺觉寂塔隋故镜智禅师碑铭并序》中说：“忍公传慧能、神秀，能公退而老曹溪，其嗣无闻焉。秀公传普寂，寂公之门徒万人，升堂者六十有三，得自在慧者一，曰弘正。正公之廊庑，龙象又倍焉，或化嵩洛，或之荆吴。”这说明在大历初期，北宗普寂门下的弘正一支势力仍很大，几乎又将以往南北分宗时各自的弘法地盘重新统一起来。直到唐文宗开成年间（８３６－８４０），仍有北宗僧人活跃于嵩洛地区。据《宋高僧传》卷九《崇珪传》载：“开成元年（８３６），赞皇公摄冢宰，宗秀之提唱，获益明心者多矣。”这也说明了宗密在《禅门师资承袭图》中所说的“秀及老安、智诜、道德最著，……子孙承嗣，至今不绝”是符合历史事实的。
    神秀法嗣，《景德传灯录》卷四记有十九人，实际著名者仅有普寂、敬贤、义福、惠福、大福、小福、五台巨玄、降魔藏、河中府智封、寿州道树、准南全植、郢州香育等，与神会在“滑台大会”上辩论的崇远法师即是降魔藏的弟子。义福的弟子很多，《景德传灯录》卷四列名为八人，见于碑塔铭记的有三人：智通禅师、比丘尼惠源、优婆夷未曾有。普寂的门徒比义福更多，所谓“摄之孔多，学者弥广”，但“所付诸法，不指一人，”李邕记有大弟子慧空、胜缘等。《景德传灯录》卷四记有普寂法嗣二十四人，此外，王缙撰《东京大敬爱寺大证禅师碑》记载北宗神秀系传承说：“忍传大通，大通传大照，大照传广德，广德传大师（即大证昙真）。一一授手，一一摩拜，相传如嫡，密付法印。”昙真上承北宗禅法，历唐玄宗、肃宗、代宗三朝，皆礼为“国师”，故称“三朝国师”。于代宗大历二年谥曰“大证禅师”，昙真门下有所谓“十哲”。密宗大师惠果，幼年曾从昙真习经。据《宋高僧传》载，从普寂学禅者还有：陕州回銮寺慧空、京师大安国寺楞伽院灵著、定陶丁居士、洛京广爱寺真亮、襄州夹石山思公、定州大象定真院石藏。此外，还有少林寺同光、敬爱寺法玩禅师。普寂的弟子中，最著名的是一行（６８３－７２７），俗名张遂，魏州昌乐人，少聪明，博览经史，尤精历象、阴阳、五行之学，是历史上有名的天文学家，曾奉敕助善无畏译出《大毗虑遮那成佛神变加持经》（《大日经》）并为之疏解，撰《大日经疏》，成为中国密宗理论的真正奠基者，但一行出家剃染，是以普寂为师，临终之前又来嵩山谒礼本师，当受普寂影响不小，普寂的禅法，最后能传到朝鲜、日本、可见其宗系之大。在朝鲜传布北宗禅法的代表人物的是神行禅师（７０４－７７９），他曾师事长安唐兴寺和尚志空，而志空正是普寂禅师的入室弟了，日本奈良朝（７１０－７９４）由中国传入的所谓“古京六宗”中，并无禅宗。北宗禅法是由洛阳大福先寺沙门道璿（７０２－７６０）传入日本的。道璿是大福先寺定宾律师的弟子，又是普寂禅师的弟子。开元廿四年（７３６），他应日本荣睿、普照之请入日，兼弘华严、禅、律。景贤，一称敬贤，是神秀的另一弟了，门下有法宣、慧囐、敬言、慧林等。
    总之，神秀一系作为北宗的主脉，徒众繁衍，与唐室相始终，于安史之乱后，其法脉确实还延续了百年之久（见北宗神秀法脉传承图），大中五年（８５１），唐宣宗召荐福寺僧弘辩禅师入殿，问“禅宗何以有南北之名”及“顿渐之别”，反映北宗在当时仍有相当影响。


一、荷泽神会

第四章

    一、荷泽神会

    作为本世纪二十年代以来中国佛教史的一个研究“热点”，荷法神会及其思想和作用一真是备受瞩目的“热门”话题。自１９３０年胡适发表《神会和尚遗集》以来，学术界关于这一课题的考辨可谓不遗余力，直至１９９６年７月中华书局还出版有中国社会科学院世界宗教研究所佛教研究室杨曾文研究员所编校的《神会和尚禅话录》一书。是书取材宏富，整理精致，既全面介绍了国内外学者关于神会著述的校勘和研究成果，又收有著者深入精湛的研究考证，在大陆的该课题研究领域内颇具有代表性，当然，这并不意味着对于神会的研究就可以到此止步，相反，这一研究应当而且事实上也正在进入更为具体和细致的境地。但是，正如同史料的过于粗疏容易妨碍我们对于历史真相的了解一样，对于史料的尽可能细致的梳篦辨析，固属必要，但未赏没有遮蔽历史真义真精神的危险。从这一意义而言，荷泽神会的独特价值是否会淹没在越来越多的历史细节之发现与阐释之中——就格外需要佛教学者警醒了。
    事实上，在南宗“分灯”的壮丽行列中，作为擎灯者的祖师级人物，其生平经历与劳绩之中，最重要的未必就是体系完整的思想阐述、法度森然的宗风示范，恰恰相反，比起禅宗史上那些成熟从容、自成体系的后来大家，在早期禅宗史的分灯之祖师上，别无长物，往往只有两样最简单的武器：胆与识。作为“分灯”第一人的神会，就是胆识俱足的第一大家。
    关于这一点，且让我们把视线跳出禅宗史以外——总是证之以禅宗本身的历史，未免会给人以自说自话的印象，转而从更宽阔的视野看去：
    唐玄宗开元中期（约７２７年前后），时任朝廷侍御史的中国文学史一等名人王维（字摩诘），通过神会的门人刘相倩，请神会和尚及其同道到南阳郡临湍驿，专事谈论佛法，达数日之久。王维请问，怎样修道总能达到解脱？神会和尚回答：“众生本自心净，若更欲起心有修，即是妄心，不可得解脱，”王维对于这个问答，十分惊奇，直呼“大奇！曾闻大德，皆未有作如此说！”转头就向在场的太守、别驾和司马等众多官场同仁，动情赞叹道：“（你们）这个南阳郡，有好大德。有佛法这样不可思议！”
    文学家的强烈的情绪化反应，可能比禅宗宗门内的对话，更为逼真地记录了六祖慧能之后第一支分出的慧炬所照耀之处，以及人们惊喜莫名的激动时刻，中国禅宗借助于僻处南天的相对封闭宁静的地理环境，通过慧能祖师巨手，完成了它的实际创立使命，而越山岭南，来至当时中国政治经济文化中心地区，一灯开处，照耀社会大舞台的中心——这个激动人心的年代，就是从神会开始的。
    荷泽神会，据《宋高僧传》卷八载，从幼年起从师得授《五经》，自学《庄子》、《老子》，均能“通幽赜”。“灵府廓然”。后来从《后汉书》中知道佛教的线索，便留意佛教，渐无仕进之心，终于本府国昌寺出家，“讽诵群经”，至于“易如反掌”。据《圆觉经大疏钞》说，神会曾师北宗神秀三年，后来神秀奉诏入洛阳（时在７００年或７０１年间），他又慕名南下曹溪，往依慧能，其间除曾到西京长安受具足戒之外，多从慧能学法，直到慧能入灭，仍在曹溪住了几年，至开元八年（７２０），“敕配住南阳龙兴寺”，为其立足中原腹地开辟传灯事业之始，经过长期弘法经营，他在当地已获得一定声望，人称“南阳和尚”，开元二十二年（７３４）正月十五日，神会在滑台（今河南滑县）大云寺开“无遮大会”，与山东崇远法师展开辩论，提出要为天下学道者“辨其是非”、“定其旨见”，为此正式向北宗系发起挑战，然当时北宗基础深厚，影响为最，而南宗禅法在社会上层多闻所未闻，神会敢于明确标举南宗旗帜，挑战北宗，则不仅需要见识，更需要胆魄勇气，他自己对此有着充足的思想准备：“我自料简是非，定其宗旨……令一切众生闻知，岂惜身命！”神会如此胆识，实为南宗第一灯所必须之“膏油”，其精神不死，则灯焰不灭。社会上层亦渐有理解接受南宗禅法者，至天宝四年（７４５），兵部侍部宋鼎请神会入住东都洛阳荷泽寺。神会继续传播曹溪法义，并在荷泽寺中为慧能祖师开堂塑像，且将东上达摩以下诸祖，尽数绘影供奉，一时达官如房琯、宋鼎者，分别为其作序志碑。随着南宗禅法日渐行世，北宗必然大举反击，至天宝十二年（７５３），神会“被谮聚众，”由此开始，两年之内，四度敕移住所。此时，神会已是年届古稀的老人了。幸而历史为其提供了一个新的机遇：安史之乱中，政府军费匮乏，用右仆射裴冕权计，多所置戒坛度僧，聚“香火钱”以助军需。天宝十四年（７５５），神会时返洛阳，于草莽之中被公举出来主持开坛度僧。所得财帛，顿支军费。这对于政府军收复两京，做出了有益的贡献，不久，受唐肃宗诏，入内受帝供养，并由朝廷动用官方力量为他在荷泽寺中大造禅宇，即便是大师之塔额号。直至近三十年后，唐德宗贞元二年（７８６），有诏“敕皇太子集诸禅德，楷定禅门宗旨，遂立神会禅师为第七祖。”这恰逢神会诞辰逾百年之际，是否有特为其百年纪念之意，现在当然不便遽定，但是即以世法眼光观之，人生百年，事业成功，壮志得酬，莫过于此。
    不过，以千载之下的后人来看，又与百年的眼不有所不同，这种不同并不在于神会的事业——其奠定南宗正统不朽的意义是永远无可怀疑的——而仅仅在于：神会个人的历史地位悄悄发生了位移，“七祖”之冠旁落当时僻居南国了无声名、但终以弟子而显的南岳怀让和青原行思二祖。南岳门下出马祖道一，青原门下出石头希迁，南宗之灯传此二大士而终于光耀天下，成大气候，由此而开“一花五叶”的后期禅宗全盛之世。相形之下，神会的弟子无一堪比马祖石头，勉强可从《宋高僧传》中寻觅者有：灵坦、进平、志满、无名、广敷、神英、行觉、皓玉、无行、慧空和法璘等一二十人。当然，缺乏名声显赫的传承者，仍然不是导致神会在“二世而亡”丧失七祖地位的深层原因。他何以缺乏强有力的传承者？这本身就是一个复杂的问题，留待下文在展开述评神会的思想与实践中叙述。
    神会的思想及生平资料大多保存于其弟子听法记录之中，主要有以下几种：《南阳和尚顿教解脱禅门直了性坛语》、《菩提达摩南宗定是非论》、《顿悟无生般若颂》、《南阳和尚问答杂徵义》以及神会自撰“五更转”两首及五言律诗一首。这些著述资料大都从宋以后逐渐佚失，直到本世纪二十年代总开始从敦煌文献中陆续发现，每一种著述又经过多次发现、整理、有多种底本存世，故情形较为复杂。杨曾文教授编校的《神会和尚禅话录》，是至１９９６年大陆有关这一题材的最为完备的文献果集，可资借鉴，在对于神会禅法的梳理研究方面，近人远出古人之上。事实上，由于神会“七祖”地位的迅速旁落，更由于其思想资料的长久湮没，古人在真正接近和了解神会禅法方面，是乏善可陈的，除了自许神会第四世法嗣主圭峰宗密有过昙花一现的激情描述之外，世人对于神会禅法的真正了解，完全可以说，是到了晚近总开始的。其中，胡适先生对其文献的发现和整理，尤其是对其历史地位的阐发，无疑是始作俑者，但是，在逐渐认识了解荷泽神会那久已模糊的历史面貌的同时，近人也许又陷入一种渐行渐深的误区——这就是对于所谓禅宗史“南顿北渐”之争的过份执著乃至入为设置，并由此出发替争执双方构造各自的“思想体系”。平心而论，任何一个一流的佛教史人物都自有其理论和思想的光芒，何况像神会这样一个禅宗史上的“革命家”，无论其思想理论是否自成一体，成为“体系”，都应当得到充分的重视和研究。宗密在《圆觉经大疏钞》卷三所谓：“‘寂知指体，无念为宗’者……是南宗第七祖荷泽大师所传”，此语实乃神会禅法最为精炼的概括。近人依据文献材料所在的一切有关禅会禅法的解说，都是对于这一概括的具体疏证。何谓“寂知指体？”宗密在下文中指出：“万法既空，心体本寂，寂即法身，即寂而知，知即真智。”何谓“无念为宗？”宗密续曰：“既悟此法本寂本知，理须称本用心，不可遂起妄念，但无妄念，即是修行。”
    除了上述宗密的概括之语，在有关荷泽神会本人言行的前引著述之中，更是充满了对此一宗旨的应接阐发之语，问题是：神会的这一禅法理论处于一个什么样的范围之中？也就是说，其源流何在？这又用得着宗密的一句斩钉截铁之断语了。他在其著名的《中华传心地禅门师资承袭图？中，特意强调说明：“荷泽宗者，全是曹溪之法，无别教旨，”既如此，那么，人们不禁又要问：既然别无教旨，又有什么必要称宗立派呢？宗密的解释是：“为对洪州傍出故，复称其宗号。”原来如此！
    博闻圆融如圭峰宗密者，于禅宗之中既能独钟，并私淑荷泽（其时神会身后萧条，早已无复“天宝当年”盛名盛况）——必有其特别会心之处，上述断语，可谓得荷泽之髓！
    今人之所以大有必要重温宗密的上述评语，是因为他的这些话可能会成为警醒我们的一剂最好良药；对于神会这样的革命者来说，最需要的并不是思想理论的何种创新发展——在这一方面，“无别教旨”式的忠实继承，甚至比发明突破要现实与合理得多，最重要的是舍身忘死的胆略，是举世独醉我独醒的见识！
    对于这一点历史真精神的最好记录，仍见之于宗密（这位神会百年孤独当口上的私淑者）的记录，他所作的那篇《神会七祖传》，无论在当时，还是在今天，似乎都不曾引起人们格外的垂青，然而，举神会精神映照而观，这篇简短的传记却不啻是一篇激情澎湃的美文，其文繁简布局分明：在描述神会一生行迹时，对于后人絮絮不休的“开坛度僧”历史戏剧一无置评，甚至像最富戏剧性的所谓“滑台大会”也一笔带过；他对有关神会的任何演义不感兴趣，甚至对神会的禅法理论也无一语正面叙述，而充溢全文的，却是一泻到底的英雄颂——对于一个孤独英雄“殉命忘躯”历程的赞颂。这个英雄的大背景，在文中被反复强调指出，这就是“能大师灭后二十年中，曹溪顿旨沉废于荆吴，嵩岳渐门焯盛于嵩岳。”北宗一系“势力连天”，“雄雄若是，谁敢当冲？”而南宗门下又如何呢？那里的局面沉重而惨烈：“岭南宗徒，甘从毁灭，法信衣服，数被潜谋。……传授碑文，两遇磨换！”荷泽神会正是在这种沉痛时刻踏上历史舞台中心的：他“亲承付吃，岂敢因循？直入东都，面抗北祖。”对于神会从此开始所经历的“百种艰难”，宗密甚至坚信达摩“（命如）悬丝”之记，并不是应验于五祖密授六祖的那个时代，而是“验于此矣！”
    用“感情冲动”形容这篇《七祖传》，显然是不足以解释宗密这位宗师级的人物何以将一篇传记写得如此具有强烈感情色彩——同样，也远不足以解释千载之下另一位大学者在神会面前的又一次“感情冲动”。这就是胡适先生在他那本《神会和尚遗集》的总结之语：
    “南宗的急先锋，北宗的毁灭者，新禅宗的建立者，《坛经》的作者——这是我们的神会，在中国佛教史上，没有第二个人有这样伟大的功勋，永久的影响。”
    三十年后，晚年的胡适先生，在利用新发现的敦煌文献并作过大量的新校重校工作之后，对自己的上述结论有所修改，但是其鲜明的“感情色彩”仍未能像通常习见的那样，因其暮气与研究的成熟而消遁：
    “中国佛教史上最成功的革命者，印度禅的毁灭者，中国禅的建立者，袈裟传法的伪史的制造者，西天二十八祖伪史的最早制造者，六祖坛经的最早原料的作者，用假造历史来做革命武器而有最大成功者——这是我们的神会。”
    虽然后一结论更为老到而略显拖沓，但我们仍应当承认，在本世纪中国佛教史的研究领域中，胡适先生评品神会的总结性文字仍然是最有神采的。如同“片面的深刻”现今已被人们所正视和印可一样，宗密与胡适相隔千载立场迥异，而同样富于激情的上述文字，也属于“片面的激情”，对此，学者可以根据重重史料指出其中一百个不足，但那都只是“形”甚至于形而下的事情，惟宗密、胡适得其神得其髓，他们为神会所作的“传语”，也许形尚未足，而神宗气足，将永远铭刻于神会研究的金字塔尖上。
    无论古人宗密，还是近人胡适之，他们不期而遇的历史激情，都来源于神会自己所创造的历史。“龙鳞虎尾，殉命忘躯”（宗密语）也好，“急先锋”、“毁灭者”、“建立者”、“制造者”、“革命者”、“最大成功者”（胡适语）也好，无一不描摹着神会为建立南宗正统地位夺门一生的真精神。然而，正如成也萧何、败也萧何一样，神会因这种真精神而终于达成为南宗争正宗的目标，成为“最大成功者，”同样，又因此而成为最大的悲剧角色——对于中国人包括中国佛教宗师来说，还有什么比二世而亡、香火断绝而更悲惨的呢？
    现在的问题是：造成这一悲剧的最主要的原因是什么？仅仅是神会在禅法理论上缺少创造性（甚至连六祖已有的革新成果都未消化完全，致有“知解宗徒”之纰漏把柄），因而注定缺乏思想的可继承性，无法造就杰出弟了吗？
    这当然是一个显而易见的直接原因：对于一个革命性的历史人物来说，兼顾“革命”和“建设”（建立自己的“选佛场”）当然是再完美不过的事，晚出一代的石头希迁，尤其是马祖道一，就是这样的两个幸运者，然而，神会所面临的历史责任远比他们要尖锐、现实和紧张得多。他必须在“岭南宗徒甘从毁灭”和“北宗门下势力连天”的对比局面下，为马祖、石头这样的后辈开出一条血路来——历史没有给他留下可供悉心琢磨自己“思想体系”的时间，甚至连为后来者指示一个新方向也来不及，遑论从思想血缘上培养接法传人！
    然而，这远远不是全部原因，事实上，中国佛教史造成了“这一个”革命者神会——溯而言之，这一对革命的师徒慧能与神会，却拒绝了第二对“革命者”师徒、特别是第二个神会式“亲承付嘱”为自己的宗派而“殉命忘躯”的徒弟产生的可能。在这一意义上，胡适之感慨“在中国佛教史上，没有第二个人有这样伟大的功勋，永久的影响”，实属有感而发之语。之所以在神会以后，再未曾出现这等个性强烈、为师命和宗派的地位而一往无前毕生赴之的人物，当然有着比上述个人意义要宽广和深刻得多的原因。其中，禅宗史继神会之后，以建设而不再见革命为中心的大局面之来临（以五家七宗的相继建立发展为标志），是“小气候”层面上的转变；佛教各宗各派在中唐以后逐渐走向总体上和谐并存乃至圆融的趋势，是中观层面的原因，至于儒释道三家在总体上亦走向所谓“三教合一”，以及理学复兴、革新乃至革命的人材逐渐集中于儒门（以理学和心学的产生为标志），则更是宏观层面上的原因。但是，在所有这些重要的原因背后，还有一个无法令人回避的属于佛教史自身的原因。这就是：唐宋以下，佛教史逐渐失却了再造慧能与神会式的革命者之内在驱动力。换句话说，在一片“圆融”“融合”声中，作为佛教这样的宗教的立足之本，其宗派各自的存在必要性与特点逐渐被消解，以至于为宗派的生存、发展和尽可能合法、崇高的地位而奋门——也成了羞于提起的事情。这当然只能算是神会不再来这一现象留给我们的一种思考，不属确定不易之论，只是，作为一种反证，中国佛教史发展到晚清以后，宗派林立的局面确实归于消解了。这当然饱含诸多因缘，但是否与佛教内部缺乏神会式的卫道士兼卫派（宗派）式人物确有关系呢？良足深思。
    神会已矣，法灯则从此长明，流布天下，并将在南宗的故乡——南中国腹地形成燎原烛天之势，照耀人间。


二、马祖道一

二、马祖道一

    公元八世纪的中国文化，与中国社会发展同臻历史的巍峨高峰。在这个不同寻常的世纪，中国文化诸多领域几乎均出现了成就卓著、继往开来的英才。就中国禅宗而言，在活动于这个世纪的一系列著名禅僧之间，在成就、风格和身世诸方面，独可拈出石头希迁、马祖道一两大家，与文学领域同一时代的李、杜二公相媲美。简略说来，马祖倣佛李白，乃天纵英才，其机锋峻烈、大机大用、大开大合之处，非常人可及。而石头则近似杜甫，其深邃绵密、沉郁孤高，亦并世无二。
    （一）马祖生平
    马祖道一（７－９－７６８），俗姓马，后世尊称为“马祖”。现存有关马祖的文献资料十分零散，而弄清其生平履历，对于了解马祖及深入了解唐中期禅宗的发展线索，具有重要的意义。马祖道一一生蹤迹，依其活动地域和思想发展线索，可以明显分为三个时期：
    １、剑南时期（７０９－７３３）中唐时代，剑南为一方镇，是玄宗时十节度使之一，约当今四川省中部地区，下辖益、彭、蜀、汉、资、渝等州。这一生于汉州什邡县（今四川什邡县）。幼年在本邑罗汉寺依唐和尚（即处寂６６５－７３６）削发出家。二十岁前后在渝州（治今重庆）圆律师处受具足戒，取得正式僧人资格。与此同时，著名僧人，新罗国王子无相（６８３－７６２）入蜀谒处寂，青年这一并曾师从无相。这一还曾广为游学，到过乾州等地。他在故乡剑南各地飘泊游历，受到这一地区蓬勃发展的佛教充分的熏陶，尤其是发源于五祖弘忍门下的智侁——处寂——无相这一系的影响，为他以后思想的转变发展奠定了基础。
    ２、衡岳时期（７３３－７４２）慧能的弟子怀让，闭门幽居南岳衡山之上，他“本不开法，但居山修道”，只因为来了一个“剑南沙门道一”（以上宗密语），于是便有了一个“磨砖岂能成镜，坐禅焉得成佛”的千古名训。道一最初到南岳衡山时，心性孤傲，不大理会旁人，只顾结庵而住，整日坐禅，怀让见他很不凡，便拿块砖到他庵前的石上磨来磨去，这一睁开眼睛问道：“师作什么？”怀让答“磨作镜”，道一惊奇地问“磨砖岂得成镜？”于是，怀让便趁势说法，开示道一。这一言下顿悟，从此不离怀让左右。这样他又在衡岳受到了六祖慧能——衡岳系的南禅宗教育。史称“同参九人，惟师密受心印，”前后共达九年，在这里他度过了青年时代，也是他的学生时代。三十三岁时前往福建和江西，开始了他以后大半生开堂说法，蔚为大宗的“祖师”生涯。
    ３、江西时期（７４２－７８８）天宝元年，道一在建州建阳（今福建建阳）的佛迹岭收了志贤、慧海等信徒，这是他开堂说法之始，当时条件艰苦，道一筚路褴褛，自创法堂，他在佛迹岭为时很短。不过一两年，旋于天宝三年左右迁往江西临川（唐时属抚州）西里山，又曾在宜黄石巩结庵，其遗迹到明代尚为人怀念。此后，道一在南康（今江西南康县）龚公山居住时间更久，约二十余年，该处在明代也有以他命名的遗迹“马祖石”，以上两地——抚州与南康，马祖道一共居三十余年（７４２－７３３），他是个活动能力很强的人物，每到一地总是开创禅林，聚徒说法，广泛交纳，逐渐形成势力，影响越来越大。
    唐代宗大历八年（７７３），道一移居钟陵（今江西省进贤县）开元寺，地近洪州（今南昌），此后即以洪州为中心广泛开展活动，直至去世，所谓“洪州宗”即正式成立于这一时期，德宗贞元四年正月，马祖道一年届八十高龄，行将去世。弟子问“和尚近日尊候如何？”，他答道：“日面佛，月面佛。”他终于开元寺，弟子遵其遗嘱将遗体火化，并建舍利石塔于建昌石门山（在今江西靖安县），此后该山因之禅院栉比，梵宫盛极一时。时隔六十余年，宪宗元和中谥“大寂禅师”。
    道一门下弟子众多，在世之时洪州即有“选佛场”之称。《景德传灯录》谓“师入室弟子一百三十九人，各为一方宗主，转化无穷。”《祖堂集》又说“大师下亲承弟子八十八人，出现于世及隐遁者，莫知其数，”合《景德传灯录》与《宋高僧传》，得有记载的弟子近八十人。
    今存《马祖道一禅师语录》、《广录》各一卷，分别收在《古尊宿语录》和《四家语录》中。
    （二）马祖道一的思想与实践
    １、概述　马祖道一上承慧能革新成果，下启后期禅宗临济沩仰诸派之先河，是中期禅宗最主要宗派洪州一宗的祖师，其思想简洁敏锐而自成体系，其实践个性鲜明而内涵深长，值得深入探讨，“即心是佛——非心非佛——平常心是道”是道一的佛性思想体系，这个体系简炼有力，内在逻辑演绎十分严密，成为道一思想与实践的总纲领；在修行实践方面，道一主张“道不用修”，或者说“任心为修”；大量的日常生活场景中随时随地而发的“接机”，取代了看经坐禅的传统。形成充满怀疑否定倾向和泛神意味的时代氛围。
    ２、道一的佛性思想体系　　佛性论向来是禅宗的立论基础、思想总纲，是禅宗思想与实践这一整套体系中的主轴。这在马祖道一也不例外，这里结合道一的生平与思想渊源，具体地剖析他的佛性思想体系。
    首先从思想渊源看，作为南岳怀让的嫡传弟子，马祖道一在思想上最重要的基础乃是六祖慧能一脉相传的学说，但是，他最初出家并游学于剑南，四川地区的禅宗流派如净众宗已给他的思想打上了烙印。中晚年定居洪洲，又与近邻的牛头宗来往密切，自然受其影响。他的经历决定了他是一个奇特的人物，自四川历湖南、福建而后定居江西，中唐时代南方禅宗几个主要地域，除岭南而外，他都涉历到了，这也就使他的学说和他的宗派必然具有融会贯通之妙。以下结合其生平具体而论。
    最初，道一在剑南故乡出家、受戒和游学。适逢该地区禅宗隆盛，由五祖弘忍著名的弟子智侁（６０８－７０２）发韧，经处寂（６６５－７３６）再传至无相（６８３－７６２），形成净众一宗，影响最著。据《历代法宝记》记载：“金和尚（无相）每年十二月、正月，与四众百千万人受缘，严设道场，处高座说法。先教引声念佛，尽一气，念绝声停。念讫云：‘无忆，无念、莫妄。’无忆是戒，无念是定，莫妄是慧。此三句语，即是总持门。”宗密《圆觉经大疏钞》卷三更有详细记述，说明净众集合大众进行传授与短期的学习情况。其大致情形是，先修方等忏法，然后分三步传授禅法：一念佛；二念讫开示，不离“无忆无念莫妄”宗旨；三是“授法了，便令言下息念坐禅。”这种传授与当时的禅宗其它宗派一样，多是集合大众而进行的，没有单独传授，因此青年道一当时仅为一普通学佛者，文献记载看不出与处寂和无相有何直接的思想交流，然而他由此接受了净众禅法却是毫无疑问的。他离开成都净众寺，游学于处州等地，无疑对其它禅宗宗派也有相当了解，如果州（今四川苍溪县）、阆州（今四川阆中县）一带流行的传香念佛一宗，也源于五祖弘忍门下，其传授方式和宗旨与净众颇有相似之处：“正授法时，先说法门道理、修行意趣，然后令一字念佛，初引声由念，后渐渐没声、微声乃至无声，送佛至意，意念犹粗，又送至心，念念存想，有佛恒在心中，乃至无想尽得道。”对照道一以后的思想历程，可知剑南时期他在如下两方面直接师承了四川地区禅宗主要特色：一是作为净众宗主旨的“无相无念莫妄”思想；二是坐禅。关于前一方面，近人印顺指出：“这与慧能所传得的，是同源而别流的禅法。”事实确乎如此，《坛经》不是明白宣称“悟此法者，即是无念、无忆，无著、莫起诳妄”么？道一以后膺服南岳怀让，从而由智侁一系一变而为慧能再传弟子，其来有自。如果说上述思想乃是道一顺利沟通净众宗与南禅宗的大前提的话，那么，他得自于净众宗的息念坐禅之禅法，即上述第二方面，便是他一变而为南宗信徒，开始走上推进后期禅宗进一步发展道路的决定性的契机，需要指出的是，道一思想发展转变的契机都是在貌似修行实践而实则归于佛性问题这样一种形式中实现的，这可能取决于禅宗历来不重言说而重日常修行实践这一传统吧！
    具体地说，玄宗开元二十年（７３３），道一二十四岁，受具足戒不久，东山剑南，来投南岳怀让（６７７－７４４），最初的交锋便始自“坐禅”问题，前已提及。对于“磨砖既不成佛，坐禅岂得成佛”，怀让给他作了一个比喻：“如牛驾车，车不行，打车即是？打牛即是？”道一无对，怀让进而咄咄逼人地发问：汝为学坐禅？为学坐佛？”如此尖锐，对于僻处一隅又初出茅庐的这位年轻人来说，实在是警醒人心、开发性灵之语！在这场交谈中，道一提出了三个问题：１、“如何用心，即合无相？”２、“道非色相，云何能见？”３、“道有成否？”这一系列问答，表明道一在基本思想上的重新建构，以般若之智说佛性，以中道说佛性，都是从这时期开始的。最后，怀让为道一作一偈云：
    心地含诸种，遇泽悉皆萌。
    三味华无相，何坏复何成。
    怀让这偈重在开示初学，并非全面阐述，然其来自慧能则无疑。如《坛经》记慧能语云：“心是地，性是王……”（故谓“心地”），又说“心量广大，犹如虚空。……性含万法是大，自性含万法，名为含藏识。”这里有两个问题很有意思：一是南宗所本“如本藏”思想，在这里未曾阐扬，向道一这位新的传人灌输的却是有惟识宗意味的思想（非但此，怀让开示道一的整篇记录也只是讲“心”，讲“道”，无一字说“性”）。第二，联系全篇看此一“心”、“心地”，貌似惟识之“心识”，其实又颇有差别，令人难以捉摸，似说如来清净禅，而亦有差别在其间，那么，这些意味的背后究竟隐藏着什么？对于马祖道一究竟有何意义？
    应该说，这些并非怀让的偈疏忽所致。实际上，慧能以下，禅宗思想的重心正在发生十分微妙而又自然的变化，南宗正在展开其合乎逻辑的思想历程。简单地说，就是：六祖慧能既已在“心”与“性”、“明心”与“见性”之间更强调“心”，强调“明心”，并且使这一“心”、“自心”更少出世色彩，而逼近当前现实人心，那么，他们的门下更将这种革新推向极致，并由此建构完善成一整套“心”的宗教，南岳怀让传世言论资料极少，幸存的上述他对道一的那一篇开示，即鲜明的提示了南宗的这一发展方向。
    道一直承慧能、怀让、经过长期思考和实践，终于在晚年提出了“平常心是道”这一彻底中国化的佛性学说，这一学说是禅宗思想发展的必然结果，是禅宗由前期向后期，由“如来禅”、“祖师禅”向“分灯禅”转变的一个关节点。
    道一的佛性思想，实际上，可以概括为“即心是佛——非心非佛——平常心是道”，这是一个内涵丰富、逻辑严整的思想体系。
    如上述、道一得怀让开示，毅然放弃净众息念坐禅的禅法，去积极信奉“即心是佛”。
    关于“即心是佛”或“即心即佛”，此说早已有之。号称禅宗二祖的慧可即云“是心是佛，是心是法，”道信更引经据典：“《无量寿经》云：‘诸佛法身入一切众生心想，是心是佛，’‘当知佛即是心，心外别无佛’”。这种如来藏思想一直是禅宗一个主要的思想渊源，而从五祖弘忍开始又渐持《金刚经》为主，“是心是佛”、“即心即佛”之说愈演愈烈。到六祖慧能，不单纯以“本心”“自心”说佛，而是直指“自心”，明确指示众生即心便是佛，如《坛经》说：“吾今教汝，识自心众生，见自心佛法。”“听吾说法，汝等诸人，自心是佛，更莫狐疑，外无一物而能建立，皆是本心生万种法……我心自有伸缩，问若无佛心，何处求真佛？菩提只向心说，何劳向外求玄？”，反覆强调心外更无别佛。道一从受法于怀让，直到他离开南岳而独立开宗收徒之初，他的有关佛性的主张自然不外直承以上传统，宣扬“即心是佛”，越州大珠慧海是他们下参学最早的一人。《景德传灯录》记载慧海初至建阳佛迹岭向马祖参学时的情形说：
    祖问曰：“从何处来？”曰：“越州大云寺来。”祖曰：“来此拟须何事？”曰：“来求佛法，”祖曰：“自家宝藏不顾，抛家散走什么。我遮里一物也无，求什么佛法。”师遂礼拜问曰：“阿那个是慧海自家宝藏？”祖曰：“即今问我者，是汝宝藏。一切具足，更无欠少，使用自在，何假向外求觅，”这段文字不如“即心是佛”之简括，然而却是“即心即佛”很好的一种解说。
    《马祖语录》开示众人，劈头即是：“汝等诸人，各信各心是佛，此心即佛……心外无别佛，佛外别无心。”
    可见，马祖道一最初是完全继承了慧能以来的思想。然而，这里存在着两个问题。第一，传统的所谓“即心是佛”之说，乃是一种简单的肯定，粗糙的肯定。其中并不包含任何辩证逻辑的内容，因而显得单调、贫乏和虚浅粗俗。第二，尤其是慧能自大力提倡“明心见性”以来，“即心是佛”的思想逐渐深入人心，几十年间竟又成一窠臼，使人执著旦“即心有佛，”颇有“异化”的危险，道一后期的许多弟子就慎重其事地指出过这一问题，如伏牛在说：“即心是佛是无病求病句”；东寺如会也说这就好像“剑去远矣，尔方刻舟，”南泉普愿批评“如今多有人唤心作佛，……将头觅头，设使认得，亦不得汝本来佛。若言即心即佛，如兔马有角。”
    毫不夸张地说，“即心是佛”成为僵化的教休——这是禅宗佛性理论在慧能以后所遇到的一个严重危机。禅宗要向前发展，就必须提出新的理论取而代之，总能克服这一内在的危机。
    道一针对这种情形，首倡“非心非佛”说。所谓“非心非佛”，是相对于“即心是佛”而言的一种否定之词。意即截断主体认知活动，主体所认识的对象不是心，也不是佛，心与佛俱不存在，道一有时也称为“不是心，不是佛”。
    这是对于禅宗佛性思想的一次大胆创新，它明确否定了以往佛性思想发展的传统，否定了似乎正成为不移之论的慧能革新的等同“真理”的成果。在以往禅宗发展史上，还从来没有过对于佛性如此横空出世般的否定的表达，它大大地解放了禅宗信徒的思想，一方面成为在日常生活中接应群机的一个理论诱因；另一方面作为“即心是佛”的具有辩证意味的否定面、对立面，丰富了禅宗佛性思想，在慧能以来禅宗思想的逻辑演绎过程中，大大地前进了一步。可以举一个例子，说明道一由“即心是佛”向“非心非佛”转变的心迹：
    有小师行脚回，于师前画个圆相，就上礼拜了立。师云：“汝莫欲作佛否？”云：“某甲不解捏目”，师云：“吾不如汝。”小师无对。
    道一惯为人师，当这个弟子前来参学时，本欲依老套子启发“即心是佛”之类，旋即在弟子面前醒悟自己几乎也执著心、执著佛，于是当即承认自己不如这个弟子——道一生性孤傲，如此坦率认输，是绝无仅有的一例。
    “非心非佛”当然并非从根本上抛弃佛教的宗教本质，通过这种方式否定，使信徒跳出具有危险倾向的思维定式（执著心与执著佛），发扬个人的主观能动精神，从更宽阔的视野、更高的层次上真正体会慧能高倡的南宗基调——心即是佛，从心明性。道一的这种宗旨，颇为其高徒们所心知，如：
    一日有大德，问师（南泉普愿）曰：“即心是佛又不得，非心非佛又不得，师意如何？”师云：“大德！且信即心是佛便了，更说什么得与不得。”
    另外，道一派人去试探大梅法常，说祖师近来另外又倡“非心非佛”，大梅法常断然回答：“这老汉惑乱人，未有了也，任汝非心非佛，我只管即心是佛，”道一闻言，赞叹“梅子熟也”（法常居大梅山上），这同道一自动认错一样，公开赞扬一个弟子，在道一也是十分难得。理论思想的成熟，也就这样表现在原有理论的更高阶段上得到复归、肯定。
    这种复归和肯定，是以“平常心是道”表现的。这是道一佛性思想的逻辑的终点，也是道一晚年之定论。所谓“平常心是道”，道一自己有详细解释：
    若欲直会其道，平常心是道。何谓平常心？无造作、无是非、无取舍、无断常、无凡圣……只如今行住坐卧，应机接物，尽是道，道即是法界，乃至河沙妙用，不出法界。
    用现在的话来讲，就是主体的一切认知和行为，都体现佛性或者佛教的教义，或者说应该将“道”贯彻到日常的一切认知和行为中去，其中具体意味下面再交代，大体上讲，这也就是宗密所谓“触类是道”，也就是道一后人所谓“性在自然”的意思。
    作为道一佛性思想发展的结晶，“平常心是道”颇值玩味，就以下两点而言：其一、关于“平常心”，道一及其洪州宗，颇受《楞枷经》影响，这是与荷泽等慧能余绪所不同的。道一宣言：“达摩大师从南天竺国来，躬至中华，传上承一心之法，令汝等开悟。又引《楞枷经》文以印众生心地，恐汝颠倒，不自信此心之法各各有之，故《楞伽经》云，佛语心为宗，无门为法门，”至若宗密干脆以《楞伽经》印证和概括洪州一宗之特色。事实上，道一及洪州宗上承如来藏禅，没有什么形而上学本体论的束缚，将如来藏理论以及达摩直至弘忍，慧能以来泛“心”论、泛神论特色大加发挥，力主“非心非佛”的怀疑论与否定论，终于导致“平常心是道”。此一“平常心”，固然不脱离其“无造作，无是非，无取舍”，等等说教本色，但是这在具体实践中无论如何是大大减少了诸般束缚，活泼泼地接触生活，与一般世俗所谓意志、情绪、感受大大贴近了。至此，禅宗无数的“接机”、“公案”出现在行坐住卧等等日常生活场景之中，总成为可能，慧能革新所指示的禅宗诸多特徽总得以淋漓尽致的发挥！顺便一提，与此相比较，荷泽神会一系命运短促，虽有各种原因，然而该宗专持《金刚经》，轻视《楞伽经》，致使默守成规，缺乏新陈代谢的内在活力、对于理论思想上的危机举措无力，最终难以为纪，应该说，这是一个重要因素。
    其二，关于“道”，如果说“平常心”是道一佛性思想世俗化倾向的体现，那么以“道”取代“佛性”，则是他的佛性思想玄学化、中国化的标志。可以说，在一定程度上这主要是道一及洪州宗与以牛头禅为代表的江东佛学关系密切的产物。江东佛学因地域关系，受魏晋玄学传统的熏陶，牛头禅成为禅宗之中老庄化、玄学化的一派，从八世纪前半期即与南宗来往密切，相互影响很深。牛头禅主张“道本虚空”、“无心会道”、“丧已忘情”。洪州宗与牛头宗毗邻，两宗门下往来甚多，道一与牛头名僧慧忠、道钦频通音问，因此在思想发展过程中势必吸收牛头禅与老庄玄学的营养，甚至名词术语也多采用玄学和老庄固有语言，也就不足为怪了。在有关佛性的问题上，前文提及，南岳怀让已不言“佛性”二字，而直称“道”或“无相”；到了道一这里，更时时面向实践，不尚“佛性”空谈，直称“修道”、“达道”，所谓“道不用修，但莫污染”，与其说近于牛头禅宗旨，毋宁说已超越牛头禅，而更具玄学口吻了！这样，一句“平常心是道”，使佛性思想在世俗化和玄学化两条道路上，大为逼近中国社会上上下下各个阶层的人心氛围，在中国人普遍的接受心理上显得格外熟悉和恳切。如此通俗易懂的白话，没有丝毫经院气味，却产生了足够的号召力，这难道不是彻底的中国化么？
    总之，道一关于“即心是佛——非心非佛——平常心是道”的佛性思想体系，是一个完整的逻辑程式，颇有“正——反——合”的严密性质，就这一体系本身而论，它的逻辑推演十分完整，它是道一毕生思想发展的结晶。从道一一生活动的特点看，它又具有浓厚的实践色彩。道一毕生创业艰难，他完全是一个实践家而不是一个学者。他只是在继承前人的思想基础上，解决新的危机，提出新的具有重大变革意义的佛性论口号，而几乎没有任何繁琐的范畴、概念的堆砌罗列，言简意赅，准确有力。从整个禅宗史的发展角度来看，道一的佛性思想体系，在禅宗发展史上具有两方面的意义，其重要性不可低估。第一，它大大丰富并完善了慧能革新的思想成果，慧能革新，大力提倡“明心见性”、“顿悟成佛”，从信仰和修行方式上扬弃了禅宗住心看净的旧传统，为禅宗的发展规定了直指人心，即心是佛的方向，他的弟子神会、怀让、行思等人都是这一个共同的方向上作出了自己的努力。但是，存能在以佛性论为主轴的宗教哲学上尚未来得及充分建构经营，一旦按照其内在的逻辑向纵深发展，这一宗教哲学体系（“即心是佛”）便很快日见其拙，不过半世纪间就发生了危机（如前所述）。道一大胆否定这种简单粗糙的心佛论，在更高的阶段上以完全中国化的形式对禅宗即心是佛的根本思想予以新的确认。因而，禅宗的佛性论的宗教哲学得到了丰富和完善。第二，它为后期禅宗确立了思想基础，因而克服了自身的危机。其外在特徵如超佛越祖、呵佛骂祖等等发挥无遗也就成为可能。“非心非佛”、“平常心是道”直接点燃了后期禅宗狂放恣肆的激情。
    ３、道一的修行论　这一以其“即心是佛——非心是佛——平常心是道”的佛性思想体系为总纲，在这个基础上建立起他的修行理论。
    在修行论上，道一坚持南宗“顿悟”本色。六祖慧能倡言“行住坐卧都是禅”，道一对此更有所发展。他强调“道不用修”、“道不属修”，也就是宗密概括的所谓“任心为修”、“任用自在。”
    道一早年经南岳怀让启发，毅然抛弃息念坐禅之禅法，晚年更由于对佛性的认识臻于成熟之境而充分发挥“顿悟”理论以指导修行。他首先从“自性本来具足”出发，反对“取善会恶观空入定，”认苦“不知圣心本无地位、因果、阶级”而还“妄想修因证果，住于空定，”那么这种修行方法的结果乃是“虽即已悟，悟已却迷。”他说：“若欲真会其道，平常心是道”，只有充分认识到“只如今行住坐卧应机接物尽是道”，总能“一悟永悟，不复更迷”。
    他说“自性本来具足，但于善恶事中不滞，唤作修道人。”马祖道一晚年所谓修道，已经完全不执看着经、坐禅。他认为只要懂得“平常心是道”，乃可随时著衣吃饭，长养圣胎，任运过时，更有何事，这便是他所谓“道不用修”、“道不属修”的含义。
    必须指出，唐中期禅宗在其“顿悟”的修行实践中，是特别讲究“上根上智”与“根微智劣”的差别的。道一及洪州即是这方面的典型。道一讲顿悟，只对“上根众生”而言。至于“根微智劣”者，免不得还是有禅定修习这一关（不一定是坐禅）。道一早期弟子慧海即明确宣称，对根微智劣者来说，“若不安禅静虑，到遮里总须茫然。”在修行实践中，具体来说，也就是要求学者从眼前随意拈来的日常事物之中迅速领会禅的精神。道一会多次毫无客气地将那些反应迟钝、未能言下顿悟的参学之人斥为“个阿钝根。”在这样的风气之下，学者竞相举扬主观能动性，力求积极主动，表达简炼而含蓄，历来坐禅入定、举止凝重、反应迟滞的出家人面貌为之一新。
    总起来说，道一的修行理论贯穿着他的“平常心是道”的佛性思想，对于坐禅、看经、戒律，虽然很少正面批判和否定，但总的倾向是非常淡漠的，他最热衷的乃是在“平常心是道”的旗帜下的“顿悟”，正是在这样的修行实践之中，道一倡导冷峻刚烈的“接机”风格，此风所及，大量的隐语、动作、手势、符号，乃至拳打脚踢，完全革新了以往受戒、看经、坐禅的传统，禅宗的面貌自慧能以来，到道一这里又一次发生奇异的变化！
    ４、接机——一种强烈的时代氛围　　“接机”是禅宗所特有的一个术语，指禅宗师徒之间或同学朋辈之间，通过隐喻暗示等曲折方法，对有关佛教某一问题的交流、讨论，这些讨论保存下来、记录成文，就形成所谓“公案”。
    接机，在六祖慧能即已有所运用，其后与马祖道一同时代的石头希迁、牛头慧忠与道钦等人也均有运用，并非道一首倡。那么，在道一这里，接机有何独特的重要意义？这要从唐中期禅宗整个广阔视野去看。
    微妙，这是唐中期禅宗的总的特徵。在这一时期，既没有发生六祖革命时代惊心动魄、“命如悬丝”的历史事件，也似乎不具备后期禅宗呵佛骂祖、大机大用、大开大合的澎湃激情，它仅在思想（宗教哲学）上发生一系列重心推移，在时候氛围上醖釀煽动普遍的怀疑、否定、泛神和自由化的情绪，这种情形犹如奔腾咆哮、闯关夺隘的长江，忽然来到了坦坦荡荡、湖泊星罗棋布的中游平原，一时间呈现出“星垂平野阔，月涌大江流”的局势。
    在当时的所有的宗派之中，道一以冷峻刚烈、直捷迅猛的机锋区别于他人，为世所瞩目。如果说，到唐代中后期，神宗已成为中国佛教的主流，那么，这时道一与洪州宗就是这主流之中的主流。
    道一在接机上运用的具体方法很多，归纳起来，主要有六种：一是语言（反问、比喻、暗示），这是最常用的；二是打和喝；三是身体动作；四是符号；五是用常随身携带的用品，如所谓“竖拂”；六是有具体的日常生活场景中随时随地发挥。
    道一特色的所有“接机”，其成就不在于思想上有何发展，而在于造就了一种强烈的时代氛围。这个氛围，概略说来，就是对于佛祖乃至一切精神束缚的普遍怀疑、否定倾向，就是个体精神对于自由的强烈追求意愿，最终完成中国思想史上一次局部的思想解放运动。这就是道一特色的机峰具有的独特的历史意义。
    当然，这样一场思想运动并非道一一人所能促成，严格地说，它始自六祖慧能革新禅宗，之后又有洪州宗众多弟子以及中唐其它禅宗派别（牛头、保唐、荷泽、石头等等）的参与努力。但是，慧能以下，道一在理论与实践两方面个性突出，富有力量，在中期禅宗中最有贡献，以上所说并不过份。
    就“接机”来说，这实际上就是——“任心为修”的修行实践活动，每一次接机，每一公案，都贯穿着他的佛性思想和修行理论，都强烈地体现着共同的时代氛围。
    “西来意”是道一机锋中最频繁地遇到的第一个问题，这关涉到一个根本问题：佛法或祖师从天竺来到汉地，究竟传授什么旨趣？或者说，究竟意义何在？几乎凡来马祖道一门下参学者开口必问这个“西来意”，例如：
    １）僧问祖云：“请和尚离四句绝百非，直指某甲西来意。”祖云：“我今日无心情，汝去问取智藏。”其僧乃问藏。……藏以手摩头顶云：“今日头痛，汝去问海师兄。”其僧又去问海，海云：“我这里却不会。”僧乃举似祖，祖云：“藏头白，海头黑。”
    ２）泐潭法会禅师问祖云：“如何是西来祖师意。”祖曰：“低声，近前来。”会便近前，祖打一掴……。
    ３）问：“如何是西来意？”祖曰：“即今是什么意？”
    ４）僧问“如何得合道？”祖曰：“我早不合道”。问“如何是西来意？”祖便打曰：“　我若不打汝诸方笑我也。”
    ５）洪州水老和尚初参马祖，问“如何是西来意？”祖云“礼拜著”。老总礼拜，祖便与一踏。
    在这里，究竟什么是佛法根本大意并不重要，重要的是懂得自性具足，不假外求。应该能随时果断地截断传统的求佛觅祖的思维定式，树立学者自身高度的主体能动意识，这真是一种何其胆大、何等崭新的精神面貌！不但不执着看经、坐禅、说法，而且从精神主体上也明确宣告脱离于佛祖的执著；六祖慧能以来，道一是第一人，慧能还只止于指出“禅非坐卧”这一步而已！
    又有一个有趣的“机锋”故事：祖令僧驰书与径山钦和尚，书中画一圆相。径山总开见，索笔于中著一点。后有僧举似忠国师，国师云：“钦师犹被马师惑。”
    前文提及，道一正是在这一“圆相”上输给一个聪慧过人的小徒弟，这一回，倒是大名鼎鼎的牛头宗径山法钦输给了他，慧忠的评语是正确的。所谓“圆相”，乃是暗喻自性圆满具足，径山往中间中一点，就如同道一开口发问“汝莫欲作佛否”一样画蛇添足，显得未领会透彻。道一创造的许多接机运用方法，很快在禅宗门徒中间广为流传，衍生出越来越繁多的意味，圆相符号在道一门下那里所运用的范围、意义比道一要广泛，复杂多了。
    在“平常心是道”的总的纲领下，道一修行实践活动集中体现在两个层次：一是对于求佛求祖的怀疑与否定，因为既然自性具足，那么不求佛祖便是理所当然的了：
    西堂、百丈、南泉侍祖玩月次，祖曰：“正凭么时如何？”西堂云：“正好供养。”百丈云：“正好修行。”南泉拂袖便去。祖云：“经入藏，禅归海，惟有南泉独超物外。”不看经，不坐禅，拂袖便一去，掉头不顾，可谓潇洒之极，这总是成熟的禅宗风格，难怪道一如此欣赏了！
    这第二个层次，既然不求佛祖，性在自然，“一切施为尽是法性，”“触类是道，任心为修，”那么，一切活动便都是合理的，就当肯定的了，包括冒犯传统的清规戒律，冒犯祖师尊长，都无可指摘。洪州廉使问曰：“吃酒肉即是？不吃即是？”祖回：“若吃是中丞禄，不吃是中丞福。”邓隐峰一日推土车次，祖展脚在路上坐。峰云：“请师收足。”祖云：“已展不收。”峰云：“已进不退，”乃推车碾过。祖脚损，归法堂，妨斧子云：“适来碾老僧脚底，出来！”峰便出于祖前引颈，祖乃置斧。
    所有道一特色的接机，不但直接作用于他的弟子和其它宗派（除牛头宗外，道一又曾以“石头路滑”的机锋开示前往石头希迁门下参学的邓隐峰），而且，几乎他的每一种接机故事，均可在其弟子以至后期禅宗那里找到大量的翻版，他的众多弟子离开洪州这个盛极一时的“选佛道场”之后，各为一方宗主，遍布全国各地，接机广为运用，不断在形式上翻新，学者竞相运用接机开示信徒、辩论诘难，以为炫耀学识身份之资，以至到后期随着时间推移，所谓“接机”在思想内容上无所创新，多在形式上玩弄花样，逐渐流于空洞无聊、神秘主义一途。然而，无数条“接机”，无数次巧妙的、精美的答辩，无数次直指性灵警醒人心的当头棒喝、劈头踢打，无数个意味深长的符号、动作，无数次各宗各派之间的往返诘难，却无可置辩地汇聚成为一个时代的强大机锋，创新最多、打、画、地、竖拂、喝、踏这些常用接机方式都始自他的发明，而他刚峻冷列的机锋风格，又最富有力量，自佛教东来，从来没有这么多普通僧众超载文字乃至语言的一切樊篱，企望心灵的直接对话，自由地参究心性的奥秘，在“平常心是道”的旗帜下，形成个性解放的大趋势。
    道一在世最后几年，其思想行为已显示出接近后期禅宗“呵佛骂祖”的迹象来：丹霞天然禅师再能祖，未参礼，便入僧堂内，骑圣像颈而坐。时大众惊愕，遽报祖，祖躬入堂，视之，曰：“我子天然。”后期禅宗呵佛骂祖的急先锋丹霞天然，即由此得名“天然，”马祖称他为“我子”，心灵是何等的契合！
    最后必须交代道一思想产生的历史背景问题，由于他以及洪州宗僻处一隅的特点，这方面的历史资料完全阙如，本文不可能对此详加论列，然而，有一最基本的线索我们是完全可以把握的，此即“官禅”与“民禅”的矛盾，对于道一思想的产生发展有重要意义。禅宗最初完全来自民间，仔细考较其真正起始，甚至与北魏流民乃至隋末流民问题大有关系，隋唐两代早期的几个皇帝都曾积极招集动乱中逃亡外流的民众，其中包括禅僧，到武周时代，禅宗首领“埋形河埃”的时代结束，五祖弘忍已在今湖北山区一带露头，禅宗与王室往来愈密，逐渐分化出受到统治阶级扶持的派系，如神秀和后来的神会，他们依靠政治势力积极发展壮大，这是所谓“官禅”，道一则是“民禅”的代表人物，他的思想产生，与官方意志有一定的对抗性，倡“非心非佛”，“平常心是道”，他的思想又主要影响最普通的下层人民群众，信徒大都来自于像石巩、慧藏这样的劳动阶层，他对于当时南北禅宗争夺正统这样的激烈事件十分冷淡。从他的思想发展来看，由于远离社会政治中心，思想较自由，不易受到人为的外在干涉，比较符合佛教思想自身相对独立发展的内在规律，因而最终形成一个逻辑严密的思想体系。又因为他毕生接近民间最下层的民众，接近社会实际生活，因而他的思想又具备简捷明了、通俗易晓的鲜明特点。虽然他毕生与地方官吏不乏往来，但看不出这对他的思想感有何明显影响。他创立的僧团——洪州宗，完全继承了他的“民禅”特点，到百丈怀海那里，“一日不作一日不食”、劳动自养成为制度，更成为与“官禅”截然相对的“农禅”了！


三、石头希迁

三、石头希迁

    （一）石头生平
    石头希迁（７００－７０９），俗姓陈，端州高要（今广东省高要县）人。其生平，可从以下几个时期申述之：
    １、少年时代。这位后来惯于静坐沉思的一代哲人，当其年少之时却是性格刚强好动，重然诺，特自信，敢做敢为。史载：其乡邑有畏鬼神，多淫祀之风，杀牛祭酒以祀神灵，每当此时，陈氏少年即挺身而出，毁祠夺牛。一年之中，这种情况屡次发生，乡老不能禁之。由坚决反对本土固有的原始自然神灵崇拜开始，而后踏上毕生追求佛陀智慧、长于精巧思维的道路，这实际上是在两种不同的文化之间进行选择的结果，从一个侧面可以具体而微地昭示后人以八世纪的南中国社会所发生的某种文化迁移之轨迹，故堪可注意。当然，天时地利均不可或缺，陈氏少年故乡地近新州和曹溪，而时值六祖惠能在此安渡其辉煌的晚年：他思想成熟、皇帝问法、举世风从。值此因缘际会，陈氏少年投身惠能门下，得度为沙弥。可惜不久六祖告别人世。史载六祖入灭前夕，有一小沙弥忧伤地近前问讯：“和尚百年后，当依附何人？”六祖微微一笑，答以三个最简洁的字：“寻思去！”此即希迁，时年十四，少年时代至此便落下了帷幕。在失去了指引灵魂的导师后，他一度经历了痛苦地傍徨求索时期：或“上下罗浮，往来三峡。”或“每于静处端坐，寂若忘生，”可想见其精神渴求之迫切。
    ２、青年和中年时代，在经历以上一个短暂的时期后，石头因得长老指点，言下醒悟，遂前往吉州庐陵（今江西吉安）青原山静居寺，真的寻找到了“思”即他的师兄行思。青原行思作为六祖门下年长弟子，本是石头大师兄而已，至此便义不容辞地担起了师父的责任。石头受六祖熏陶而来，兼之极具慧根，故与行思见面后，问答之间，机辨敏捷，直下承当，以至于是行思不禁欣然称道：“众角虽多，一麟足矣。”后遣石头持书往参南岳怀让，使之又经受了一番锤炼，圆满而归。因此，希迁少年时代受六祖薰陶后，青年乃至中年又得到了以上两位“大师兄”的及时促进，可以说占尽天时地利，后来他便得行思付法，终成师徒之名。
    ３、晚年时期。八世纪的南岳衡山是一个巨大的历史文化之迹；在整整一个世纪之间，这座僻处潇湘蛮荒之地的灵山，对于那些即将在中国禅宗史上开宗立派的禅僧巨匠们，几乎具有一种不可思议的强烈魅力，使他们一代接一代地竞相奔赴这座南国灵山，在镌刻于其上的那一连串流光溢彩的著名名字中间，石头希迁当属最为璀璨夺目的人物之一。天宝初年，他辞别青原行思，来到南岳，在南寺前的巨石上结庵而居。自此，亦即公元八世纪四十年代，迄于九十年代初，近五十年间，他都活动于南岳及其邻近地区，直至荼毗于斯。门下弟子有惟俨、大颠、慧朗、道悟等。
    史称湖南石头、江西马祖为“并世二大士”，那主要是就其身后影响而言。至于生前，则显然与一生“踏杀天下人”、开辟“选佛场”的马祖不同，石头过的是另一种回异于此的沉思默想的哲人生活。这从他的遗著中可以清楚地体现出来。其遗著有两种：一名《参同契》，一名《草庵歌》，均十分简洁，然而风格各异。前者深奥玄难，是智慧结晶（下文另析），而后者则形象生动，轻松明快，以近乎纯然的文学笔调描绘了这位大智者后半生将近半个世纪的草庵生活；他悟后任运，一切怡然自得：“吾结草庐无宝贝，饭了从容图睡快。成时初见茅草新，破后还将茅草盖。”他是何等的孤高自信：“世人住处我不住，世人爱处我不处……庵虽小，含法界，方丈老人相体解。上乘菩萨信无疑，中下闻之必生怪。”他对于眼前的智者生活心怀无限的欣喜：“青松下，明窗内，玉殿朱楼未为对。”对于逝去多年的师长，他一往情深：“遇祖师，亲训诲，结草为庵莫生退。”大智慧者具有真正潇洒胸襟：“百年抛却任纵横，摆手便行且无罪，”留存后人有无限的丛容，有不尽的深长回味：“欲识庵中不死人，岂离而今遮皮袋。”
    （二）石头的思想与修行
    １、石头思想的三个递进层次
    石头思想理论的特色表现为处于曹溪、牛头、华严乃至传统佛学与道家道教多种不同文化系统的边际地带，以曹溪宗旨为核心和基础，而对其它诸种系统加以利用吸收、调和融会，最终提出独树一帜的“回互”理论，开辟了一条具有一定自觉性的禅文化整合之路。这种融会、整合决非大杂烩，而是经过漫长的哲学沉思生涯的精心铸炼，按照一定的内在逻辑，次延展开，具有比较鲜明的递进转接的层次性。
    （１）直承曹溪宗旨，以“明心见性”为思想基础。石头立宗的宣言是：
    吾之法门，先佛传受，不论禅定精进，惟达佛之知见。即心即佛，心佛众生，菩提烦恼，名异体一。汝等当知，自己心灵，体离断常，性非垢净，湛然圆满，凡圣齐同，应用无方，离心意识，三界六道，惟自心现；水月镜像，岂有生灭，汝能知之，无所不备。
    六祖慧能直指人心，见性成佛，为中国禅宗开辟了一片空前广阔的新天新地，而石头独拈出这一种大革新赖以发端的理论渊源——慧能心性理论作为自己的思想基础，实是意味深长之笔。慧能深受涅盘佛性论与般若性空观影响，认为自心与本性体一不二，迷起一切烦恼，烦恼亦不离此心，故“何不从于自心，顿现真如本性？”（《坛经》语），他强调自心，主张任运自然，不应该对万法有所执着，而应于当下现实人心之中顿现真如本性。石头上根智慧，很早便领会得此旨，这一点在初次谒见青原行思时即表现出来：师（行思）问曰：“子何方而来？”迁曰：“曹溪。”师曰：“将得什么来？”迁答：“未到曹溪亦不失。”师曰：“凭么用去曹溪作什么？”迁答：“若不到曹溪，怎知不失。”如此真谓能“知自己心灵”，这是石头平生思想历程的最根本起点，是其全部思想的基础存在。事实上，他毕生亦以此旨指引学人，形成特色，如马祖点拔招提慧朗，使慧朗终于得见石头心地的故事：
    慧朗……往虔州龚公山谒大寂（马祖）。大寂问曰：“汝来何求？”师曰：“求佛知见。”曰：“佛无知见，知见乃魔界。汝从南岳来，似未见石头曹溪心要尔，汝应却归。”师承命回岳造于石头，问：“如何是佛？”石头曰：“汝无佛性。”曰：“蠢动含灵又作么生？”石头曰：“蠢动含灵却有佛性，”曰：“慧朗为什么却无？”石头曰：“为汝不肯承当。”师于言下信入。
    所谓不肯承当者，即未能明心，未能知自心，故未能自信尔。相比之下，潮州大颠对于石头思想的领悟力似在慧朗之上。他初参石头，便被劈头问道：“那个是汝心？”他答：“言语者是，”乃被石头喝出。经旬日，他又去问：“前者既不是，除此外何者是心？”石头喝出。经旬日，他又去问：“前者既不是，除此外何者是心？”石头答：“除却扬眉动目，将心来。”大颠说：“无心可将来？”石头就势提示道：“元来有心，何言无心？无心尽同谤。”颠于言下大悟。这种心性论，正是对慧能心性论的直接继承。
    （２）、调和融会其它诸家思想。慧能以下，所谓南岳、青原二系之分别，实则是以马祖和石头明确奠定其思想理论为分水岭的。吕澄先生以“触目是道”和“即事而真”来概括此二者之区别，认为一重主观，着眼体用，一重客观，着眼未来，这一概括无疑是一种精当的宏观把握，同时也还可以进一步明确两个界定：第一，两家同为“心宗”，以明心见性为第一要义，这一共同的特色是主要的、根本的、以上所谓“分水岭”不是思想理论的根本差异，而毋宁说是侧重点不同，方法有共，区别是相对的。第二，尤其重要的是，这种区别和对立是经历了长达几个世纪的思想运动之事纔逐渐得以明确的。
    具体来说，这种差异，最初即是由石头和马祖分别肇始的，前文曾分析马祖继六祖以后自觉地进行了一套“心”的宗教的建构，其方法是单刀直入，少有旁顾，毕生注重参究“自心”，最终发挥出一个“即心即佛——非心非佛——平常心是道”这样一个漂亮的富于实践色彩的哲学体系来，石头走的又是另一条道路，从明心见性这一共同起点出发，他注意旁搛杂取，广泛吸收利用来自各个不同文化系统的思想理论，以充实和丰富自己对于禅的形而上的哲学思考。撮其要者，有如下几端。
    一、亲近牛头禅。宗密在《禅源诸诠集都序》中说“泯绝无寄宗”时即以石头、牛头并举，认为二者：“说凡圣等法，皆如梦幻，都无所有，本来空寂，非今始无……凡有所作，皆是迷妄。如此了达本来无事，心无所寄，方免颠倒，始名解脱……”这是宗密大概而言，未曾对二者主要是石头系真正宗旨加以深究，但是他觉察到般若性空之学对二者的共同影响，这是不错的。石头之世，牛头禅亦值活跃期，门下颇通往来，牛头禅佛学思想中十分浓厚的玄学化因子和般若学功底，无疑对石头有相当影响，这正是石头与曹溪下神会及马祖诸宗所不同的特点之一。牛头禅大倡“无情有性”、“无情成佛”，被大珠慧海斥为“如此之言，宁堪齿录！”神会也明确予以否定，独石头对此意有所得，借闲悟慧朗之机申明“蠢动含灵却有佛性”，这无疑是在其宗门的发展道路上留下了超出曹溪、善于吸收利用它宗思想的方便之门，他的三传弟子洞山良价直接拈起“无情说法”的公案而得以悟入。
    二、再往上溯源可至僧肇等人的传统佛学，据《祖堂集》载，石头因读《肇论》，至“会万物以成已者，其惟圣人乎？”之句，受到启发，感叹道：“圣人无已，靡所不已。法身无相，谁云自他？圆鉴虚照于其间，万象体玄而自观。境智真一，孰为去来？”乃有《参同契》之作。《肇论》中所载《涅盘无名论》，是否确为僧肇作近人有异议，但石头注意从中国传统佛学思想之中吸取营养，这又是曹溪后人之中所独树一帜的。
    三，融入法华思想。其毕生结晶“回互不回互”之说，可以说直受华严宗十玄缘起以及六相圆融思想的启迪。华严宗的实际创立者法藏，当七、八世纪之交，以宏富的著译事业与备受帝后推崇的地位而名满天下，稍晚出的石头对其思想勤加研习，心有所得，自是意料中事。
    四，以上诸点表明，石头与慧能及马祖等一个显著的不同之处是，他无疑注意了广泛的阅读、接受前贤今人的思想资料，本来悟性极高，眼界胸襟也十分开阔，虽然僻处南方一个，但对于江东和中原流行的牛头、华严诸家，对于佛教前贤著述甚至外典之学（道家和道教）都颇有研究，而长期如此研究的结果，自然涵泳出别一种“学者型”的气质，这在当时禅界是别开生面的。
    在此，除了上述各点之外，他是否还接受和利用了更多的思想资料？比如其注意知见之处，与荷泽神会之重知解就似有某种呼应。那么与北宗神秀一系呢？对此石头本人并无可靠的证明资料，然而在他所倡导的“回互”理论发展道路上，以曹洞宗“默照禅”为极致，却一再令人感受到其与神秀禅“息妄修心”、“北境观心，息灭妄念”，在理论气质乃至实践方式上的某种相通和呼应契合之处，这种由石头肇其端的色连、呼应传统佛教的内在理论线索，实际上在后期禅宗如火如茶、洪水泛滥般的文化氛围之中，始终起着一种内在约束、整合和自我规范的可贵作用。由此往下一路，石头子孙们与唐代特别是宋代儒学复兴运动的某种亲切的理论互补（曹洞宗甚至以君臣、忠孝、主辅等等纯属封建儒教伦理概念充满其体系，与石头用道家、玄学词汇做《参同契》有异曲同工之妙）。这种超越佛教之外与中国传统文化勾连、呼应，是在更宏观更宽阔的高层次上禅宗与中国传统文化整体所进行的内在自觉整合。石头对此具有开创之功；曹洞穷究偏正回互、法眼之重理事圆融、云门宗风之玄奥孤高——实际上都是石头理论和气质的不断演绎和铺展，即总的思想上都是不但自信，而且亦注重在不同系统的思想理论之间调和融会整合，始终涵养一种善于吸收利用、长于理论整合而稍拙实践和宣传的整体气质，这与马祖一系的发展相映成趣、相得益彰。
    （３）、“回互”理论是石头思想的特色所在。在直承曹溪心要的思想基础上，经过融会诸家调和经营，石头终于达到了其思想制高点——“回互”理论。这一理论集中反映在《参同契》之中。
    所谓“回互”，与“不回互”相待而言。在前者谓事物间相互融会涉入，无所分别，后者则指一切事物各有分位，各住自性，不相杂乱。这一理论的核心是要让修禅者深刻领会万事万物之间互不相犯又相入相涉、理事圆融不二的关系，以此旨于日用行事上发挥证验。石头在《参同契》中紧紧把握此一宗旨：“门门一切境，回互不回互。回而更相涉，不尔依位住，”以此旨着眼，强调“人根有利钝，道无南北祖”和“承言须会宗，勿自立规矩。”这似可理解为具体针对当世南宗之争，还可以理解为石头对于以马祖系为代表的禅宗“过激派”的某种忧虑；他本人当然是禅宗这场局部思想解放运动中的积极参与者，但对于“自立规矩”、向超佛越祖乃至呵佛骂祖的方向急剧发展这一潮流（洪州宗此种声势喧天），对于当时正在普遍发展起来的完全不看经、不坐禅、严重忽视文化传承和整合机制的炽热倾向，这位时代的主要精神导师之一，感到深为不安。所以，就这一意义而言，与其说“回互”理论仅仅只是一种理论，不如说同时更是一位大智者向那个充满骚动不安、急欲冲决樊篱纲罗的大时代所发出的信号与警告：世界是“回互”的，思想与文化同样是“回互”的——它向人们提示着一种重视不同系统、不同层面的文化的相互内在联系亦即文化传承和整合、注意内在的自我规范和约束的文化方向。这在那样一个山雨欲来风满楼的时代，肯定是一个不太和谐的声音，因而几乎沉响绝，所谓“至如石头、药山，其名寝顿是也，然而历史终究不可能不予以正视之，洞山一出，石头精神便又水生风起，流芳百世，影响至于千载。
    话说回来，“回互”理论毕竟首先是一种思想产物，《参同契》主要还是以教导学人的口吻宣说此旨——“触目不会道，运足焉知路。进步非近远，迷隔山河固，”这是从反面警戒学人。为了使学人会得“回互”深意，石头在此文中运用了子母、根叶、本末、尊卑、明暗、明与处等比喻，反复说明理事之关系，互相倚待往来如化，如“明暗各相对，比如前后步”——正是马祖所谓“石头路滑”之禅风的思想渊源所在。前文已指出，石头这一思想直接得之于华严缘起思想启迪，这是就其内容而言，实际上，在形式上，其与道家、玄学的融通色彩还要突出得多，篇名直接取之于道教奉为“丹经王”的《周易参同契》，通篇不说佛，不说话，其至也不说禅，而只说道说玄，劈头便称“竺土大仙心”，结语以“谨自参玄人，”全然似道家风貌，印顺法师以为直截了当地“把禅学看作玄学，称参禅为‘参玄’，似乎石头是第一人，”
    作为石头思想历程的全部结晶，这一“回五”理论在形式和内容上都直接取材于别家，故平心而论，其本身理论创新的程度有限，新意无多，然而意义殊为重大，这就是以上所指出的提示着重视文化的传承与整合这一重要方向，正是沿着这一道路，纔有了曹洞宗在历史与逻辑一致的高层面上对“回互”理论尽兴尽意的发挥。显然，在石头这里，这一理论仅初具规模，结构还是很简单粗略，到了洞山良价以后，纔转趋精致，杂取诸家，尤其是儒道，精巧构架，费尽心思，发挥到无所不用其极，从客观而言，这也正是禅宗所必经的文化整合之路，是石头毕生苦心孤诣所得到的最为圆满的合乎逻辑的结果。
    ２、石头的修行实践特色
    石头的修行禅行实践与其思想理论是密切一致的，前者深受后者的规范和制约，从总体上说显示一种“学者禅”、“文化禅”的面貌，态度温和雅致，思辨色彩突出，融和会通诸家的痕迹宛然，关于后一点，可特别拈出如下一段机缘予以分析：
    问：如何是禅？师（石头）曰：碌砖。又问：“如何是道？”师曰：“木头。”
    这里似有两点堪可注意，即在石头接引学入时，禅与道是完全同样看待的，并且指示道无所不在，学人要从自家身心去体会，更要“触事而真”，也即“触目会道”，此其一。印顺法师对此分析说：“这一接引悟入的态度，是僧肇的、牛头的，不是曹溪的”，这应属确当之论。但是，第二点也应予以考虑，即如前文指出，此种融会别家的作风在石头这里属于第二层次，其根基仍有于直于曹溪心要，要求直指人心，明心见性。对此，石头在初谒青原行思以及后来他开示诸弟子时是均奉为人门第一要义的。融会运用别家之法。与此并无矛盾，只不过是用以帮助学人来更好地领会曹溪宗旨而已。因为处于曹溪南宗由慧能创立、向五家七宗继续发展这样一个斩折时期，更因为调和融通的哲学气质内在影响，对于戒定慧三学，对于看经说法坐禅，石头总体上来说都是采取者式的豁达态度。所谓“不论禅定精进，惟达佛之知见，”不是全然否定说不要禅定精进，而是强调“达佛之知见”为要，这样一来，就需要视学人根器之利钝来决定是否运用说法说戒、看经坐禅了——一般说来，石头对此是不大予以明确反对的。这正是石头在修持问题上与其传人其至同辈的马祖一个区别。一个著名例子就是关于丹霞与石头、马祖三人之间所发生的故事：
    忽一日，石头告众曰：“来日铲殿前草，”至来日，大众诸童行各备锹鑺铲草。独师（丹霞）以盆盛水净头，于和尚前胡跪……石头见而笑之，便与剃发。又为说戒法，师乃掩耳而出，便往江西再谒马祖……马师曰：“石头路滑，还躂倒汝么？“师曰：”若躂倒，即不来。”
    看来，在八世纪中叶南中国僧界充满了对某种思想解放、精神自由的渴求与骚动的那样一个时代，石头与其同时代人相比较，在实践上似乎显现出一定程度的“滞后”，以至于丹霞马祖相视一笑，为未曾“躂倒”于石头而颇为得意。这应属历史斩折关头一种常见的现象——理论上的完满、超前与实践中的某种滞后保守，往往是学者型的历史人物矛盾之个性特点。当然，石头学者气质之下生发的内在思想魅力，无疑具有掩饰不住的光芒风采。同样属于那个感受到时代强烈召唤因而躁动不安的世纪之人，药山惟俨也曾拍案而起：“大丈夫当离法自净，岂能屑屑事细行于布巾耶！”结果他选择了石头为师，即谒之而“密领玄旨”，此系明证，说明石头在思想正是站在那个时代的前列的。即如丹霞天然，这位个性鲜明呼之欲出、一生行迹如妙语连珠，精彩纷呈，占据着僧传之中精彩华章的杰出禅师，晚年在其“林泉终老之所，”上堂为大众说法，回顾平生经历之时，独举出石头希迁来，款款而谈：“吾往日见石头和尚，亦只教切须自保护……”丹霞一生标新的立异，最终却由绚烂之极复归平淡，删繁就简，于平生所学所遇之中独独怀念石头——哲人精神的内在魅力竟辉煌不朽若是！
    “石头路滑”，是马祖对于石头禅风的精当概括，路滑者，喻“回五”理论所描绘的世界往来转化，圆融无住，喻导此思想入禅观，使禅法运用妙处，圆转无碍，如环无端，令学人得悟之时，见一切差别对待处皆现即事而真、平等一如的境界。石头亦有自喻，谓“遮里针刺不入”，药山惟俨更应声曰：“遮里如石上栽花，”则惟俨更近马祖所谓“石头路滑”的感觉，药山惟俨可谓石头诸弟子中与石头最亲近和最忠实地传扬其家风者，茲引其机缘数则以见石头要旨：
    （１）一日师（惟俨）坐次，石头睹之问曰：“汝在这里坐么？”曰：“一切不为。”石头问曰：“凭应即闲坐也，”曰：“若闲坐即为也。”石头曰：“汝道不为，且不为个什么？”曰：“千圣亦不识。”
    此则深得石头之心，石头特为作偈赞之。
    （２）一日院主请师（惟俨）上堂，大众纔集，师良久便归方丈闭门，院主逐后曰：“和尚许某甲上堂，为什么却归方丈？”师曰：“院主，经有经师，论有论师，律有律师，又争怪得老僧。”
    （３）师坐次，有僧问：“兀兀地思量什么？”师曰：“思量个不思量底。”曰：“不思量底如何思量？”师曰：“非思量。”
    （４）师看经，有僧问：“和尚寻常不许人看经，为什么却自看？”师曰：“我只图遮眼，”曰：“某甲学和尚还得也无？”师曰：“若是汝，牛皮也须看透。”
    （５）（李）翱又问：“如何是戒定慧？”师曰：“贫道遮里无此闲空具。”
    由此看来，石头禅法在其后来的发展中，仍与看经尤其是坐禅有一定的关系。在这里，尚未得悟者是没有资格看经坐禅的（故谓“无此闲家具”，“牛皮也须看透”），悟后任运者，则尽可以看经、坐禅、“思量”，这正缘于石头所开创的富于形而上思考哲学气质的学者禅之本色一路。
    石头学者气质体现在接引学人的风格上，平实稳健，灵活细腻，为世所称道。例如，在潮州大颠悟后，石头继续向上引导之：
    ……师（大颠）言下大悟。异日侍立次，石头问曰：“汝是参禅僧，是州县白蹋僧？”师曰：“是参禅僧”，石头曰：“何者是禅？”师曰：“扬眉动目外”，石头曰：“除却扬眉动目外，将尔本来面目呈看。”师曰：“请和尚除扬眉动目外鉴某甲”，石头曰：“我除竟。”师曰：“将呈和尚了也！”石头曰：“汝既将呈，我心如何？”师曰：“不异和尚，”石头曰：“不关汝事，”师曰：“本无物，”石头曰：“真物不可得，汝心见量意旨如此也，大须护持。”
    大颠后来在潮州就“大须护持”之意深入探究，终于得以透彻。同为师徒授受参究，石头显然不似马祖风格，而毋宁说是近似于儒家传统：正襟危坐、循循善诱、反复叮嘱、从容平实、亲切绵密，在他那里见不到言语以外的动作手段，这一教学风格与其思想理论是完全一致的，对石头一系后来的发展影响至深。
    ３、石头与马祖的一种文化比较
    历来学界治禅宗史重考证诠释，爬抉梳理，这无疑是最必要最根本的方法。此种考证信美精当者，读之令人不忍释卷。然则除此之外是否可以考虑为那些别具现代意趣的审美观照和文化解读方法给予一席之地？一部中国禅宗史，本身即是一座无比丰富的文化宝藏，如何在它与现代读者之间架构起一道最有效的心灵桥梁（不限于信仰意义的）？似值得认真考虑。在此仅就石头与马祖现象，略陈数言。
    第一，关于禅宗历史发展中的文化选择。禅宗本身就是中国文化在与外来文化的矛盾与融会之中逐渐抉择变易的结果。
    当以慧能革新为标志的文化突变发生，宣告这一新的文化模式终于确立之后，这一文化选择机制很快即由宏观的表象层面转入中观、微观和核心等深层之中发生作用——在前述马祖一节中曾以“星垂平野阔，月涌大江流”形容当时的局面。当此之际，石头与马祖并世而出，实际上是为禅宗的发展在中观、微观的层面上提供了两种模式。简略来说，“马祖模式”乃是从充分举扬“人心”主观作用入手，以纯乎实践的方式将慧能革新开创的道场“局部的思想解放运动”推向极致，其“非心非佛”、“平常心是道”直接点燃了后期禅宗超佛超祖、呵佛骂祖的狂放恣肆的激情：“石头模式”则从“回互”思想着眼，强调“客观”，以学者化的思想家的角色，在这场思想运动中扮演着某种“保守”的角色，实际上是引入了一种自觉进行文化整合、融会和思想深层次的自我约束机制。事实上，在马祖与石头身后，禅宗历史发展所进行的文化抉择表明，“马祖模式”一直成为禅宗主流之中的主流，备受青睐，而“石头模式”虽然一直在发生作用，但相对黯然失色，是主流中的非主流。透过诸多中间环节的历史迷雾，这一差异最终发展到“看话禅”与“默暗禅”在文化气质上显著的强弱这分，发展到“临天下，曹一角”这种势力范围的悬殊，乃至曹洞宗派最后跨海东去，在异国文化之中存身立足，重图发展。作者以为，这中间包含了关于中国人和中国宗教精神之特徵的一系列的问题，发人深思。
    第二，关于禅宗之中的文化层面问题。简略说来有上层文化与下层文化之别。同属禅宗，前者注重经典文化的移译、著述与阅读，社会地位显赫，是所谓“官禅”代表人物，后者则接近中国社会占大多数的文化程度低下民众，理论上注重简捷明了、通俗易晓，实践色彩浓厚，可操作性很强，是“民禅”代表人物（其渊源可直溯南北朝时期）。就公元八世纪的禅宗而言，牛头禅是前者典型，而曹溪南宗是后者的当然代表。但在各自内部，在微观的层次上，又有层次之分。在曹溪南宗之中，“马祖模式”属于下层文化中的基层，思想的可操作性空前特出，故极合于中国宗教信仰文化的口味，在当世即火爆到“踏杀天下人”，开辟“选佛场”；而“石头模式”则属于下层文化中的上层，理论上融会兼通，明显地拙于实践，可操作性较差，流传有限，险些弄个“二世而亡”。所以，即从可操作化角色来看，处于不同文化层面和同一层面不同层次的地位，禅宗各家也各有不同的命运演化。限于篇幅，在此难以展开叙述。
    以上两点结合起来，可观石头与马祖在中国禅宗乃至中国宗教文化史上的各自作用，这种历史作用的不同，可以概括为：如果没有六祖慧能，可能就不成其为中国禅宗，在慧能以下，没有马祖，禅宗就会燃烧成为灰烬，什么也不剩下。双璧辉映。一张一地，一卷一舒，遂有尔后千秋万代完整和谐的禅史旋律奏出。


一、怀海及《古清规》

第五章

    一、怀海及《古清规》

    中唐时期，安史知乱，藩镇割据日益加强，江西地区的地方官僚又对佛教采取扶植政策，并且使之保持了相当的连续性，这就为道一禅系成为中唐最大的禅系创造了良好的外部条件。道一门人“亲承弟了八十八人。”其徒以江西南昌为中心，分布于潭州（长沙）、朗州（常德）、沣州（沣县东）、池州（安徽贵池）、杨州、常州、越州（绍兴）、泉州（福建）、杭州、处州（江西赣州），韶州（广东韶关）、鄂州（武汉）、随州（湖北隋县）、荆州（沙市）、襄阳（襄樊）、唐州（河南泌阳）、两京等地。
    道一（７０９——７８８）俗姓马，汉州什邡（今四川什坊）人。于资州唐和尚处寂门下削发，受俱于渝州圆律师。曾师事金和尚无相，后入衡岳怀让的“顿门”，禅诵于抚州西里处州龚公山，悍戾之徒，无不受感化。又得刺史裴公的信奉，闻名于世；大历中路嗣恭连帅请其至“里所”，贞元四年（７８８）坐化，春秋八十，长元元年（８２１）谥大觉。权德舆碑文载，道一最后之说曰：“大抵去三就一，舍权以趋实，示不迁不染之性，无差别次第之门。”常曰：佛不远人，即心而证；法无所著，触境皆如，岂在多歧以泥学者？故夸父吃垢，求之愈疏，而金刚醍醐，正在方寸。将佛教的诸多法门归结于一心之证悟。
    道一的禅学思想，主要有两个问题，第一、他常教诲众人：“汝人各信自心是佛，此心即是佛心”，“心外无别佛，佛外无别心。”第二、“见色即是见心，”“知色空故生即不生”（同上），他把心与佛、色与空统一起来，提出“触景皆如”的主张。
    道一最主要的弟子怀海（７４９－８１４），主张农禅并举，制订丛林制度的规范，在中国禅宗史上具有划时代的意义。怀海俗姓王，福州长乐县人，原藉太原。早年落发于西山慧照，进俱于衡山法朗，赴安徽庐山阅经藏，“不窥庭者积年，”后至洪州师事道一，“尽得心印”。道一寂后，依其塔所，居止石门，重宣上法。不久，移江西新吴（今新奉）大雄山人烟四绝、水清山灵、兀立千心尺之处，号百丈，庵庐环境，供施仍积，徒众愈多。宪宗元和九年（８１４）卒，时年六十六岁，僧腊四十七，弟子三十七，以灵祐、希运最有名。
    怀海“常以三身无住，万行皆空、邪正并捐、源流齐泯”之旨作人，又以“行同于众，故门人力役必等其艰劳”等精神教人，有“一日不作，一日不食”之言流播，“由是，齐鲁燕代荆吴闽蜀，望影星奔，聆声飙至。”
    怀海主张“歇诸缘，舍身心，心如木石”的顿悟法门。有僧问如何是大乘顿悟法门？他说：“汝等先歇诸缘，休息万事，善与不善，世出世间，一切诸法，莫记忆，莫缘念；放舍身心，令其自在；心如木石，无所辨别。”“若能一生心如木石相似，不为阴、界、五欲、八风之所漂溺，即生死因断，去住自由。”这种“一生心如木石”，即是渐修；“生死因断，去住自由”，即是顿悟后举动施为，与佛无二，自由纵横的解脱境界。能够做到“心如木石，”则“个个透过三句外，但是一切照用，任听纵横，但是一切举动施为，语默啼笑，皆是佛慧。”“是非好醜、是理非理，诸智解情尽，不能繋缚，处处自在，名为初发心菩萨，便登佛地。”百丈以简明扼要之语，表述了他以不著、无求为宗的思想。他还在《广录》中，引用初祖、三祖、曹溪惠能、道一、宝志、传大士之语，阐述“只如今心虚空相似，学始有所成”之义。虽然仰山慧寂称“马祖门下出八十四人善知识，……百丈得大机，黄檗得大用，”但其主要贡献则在农禅并举之思想及创立丛林《清规》。《广录》说：“师凡作务，执劳必先于众。众皆不忍。早收其作具而息之。师云：‘吾无德，争合劳于人。’师既偏求作具不获，而亦忘食。”这种禅僧带头，上下平等参与，不劳动者不得食的风气，在道信、弘忍时已有萌芽，而历一百五十多年，至怀海时始从制度上加以规范化。这在禅宗史上确实是有深造意义的大事。它对于印度佛教以乞食、布施为生的精神是一大改革，是佛教适应于以自给自足的自然经济为基础的国情，使自身中国化的一个重大步骤。
    《百丈清规》在景德改元甲辰（１００４）杨亿《古清规序》中有详细的引录。茲据《景德伟灯录》及诸本，校录如下：
    百丈大智禅师，以禅宗肇自少室，至曹溪以来，多居律寺；虽列别院，然于说法住持，未合规度，故常尔介怀。乃曰“佛祖之道，欲诞布化元，冀来际不泯者，岂当与诸部阿笈摩教为随行耶？”或曰：《瑜伽论》、《璎珞经》是大乘戒律，胡不依随哉？师曰：“吾所宗，非局大小乘，非异大小乘，当博约折中，设于制范，务其宜也。”于是创意，别立禅居。凡具道眼，有可尊之德者，号曰长老，如西域道高腊长，号阿阇黎等之谓也。既为化主，即处于方丈，同净名之室，非私寝之室也。不立佛殿，惟树法堂者，表佛祖亲嘱受，当代为尊也。所裒学众，无多少，无高下，尽入僧堂，依夏次安排，设长连林，施椸架，挂搭道具。卧必斜枕林唇，右胁吉祥睡者，以其坐禅既久，略偃息而已，具四威仪也。除入室请益，任学者勤怠，或上或下，不拘常准。其阖院大众，朝参夕聚。长老上常升堂，主事、徒众雁立侧聆，宾主问酬，激扬宗要者，示依法而住也。齐粥随宜，二时均偏者，务于节俭，表法食双运也。行普请法，上下均力也。置十务谓之寮舍，每用首领一人，管多人营事，令各司其局也。或有假号窃形，混于清众，并别致喧挠之事，即堂维那检举，抽下本位挂搭，摈令出院者，贵安清众也。或彼有所犯，集众公议行责，即以拄杖杖之，遣逐从偏门而出者，示耻辱也。详此一条，制有四益；一、不污清众，生恭信故。二、不毁僧形，循佛制故。三、不扰公门，省狱讼故；四、不泄于外，护宗纲故。四来同居，圣凡孰辨，且好来应世，尚有六群坏法，其损甚大，今禅门若稍无妨害者，宜依百丈丛林规式，量事区分。且立法防奸，不为贤士，然宁可有格无犯，不可有犯无教。惟大智禅师，护法之益，其大矣哉！禅门独行，自此老起。清规大要，偏示后学，令不忘本也。
    这个《古清规序》，把百丈立清规之宗旨，作了较扼要的说明：第一、尊卑有序，德高为尊；以具道行，有高尚道德之人为尊，同时僧众按僧腊排列有序；第二、立法防奸，慎护讥嫌，集体住宿，自觉遵守，互相督促，维那监督；第三、勤劳节俭，上下均力，既保持了中华民族勤劳、节俭的传统美德，又在禅众中加以具体化，使之光大发扬，第四、禅教结合，便于长期坚持；平时注重德育、有违必究，决不姑息纵容，百丈既主张不著为宗，无求为要，又从制度上为僧众们清修打下基础。现存《敕修百丈清规》虽已不复《古清规》的旧貌，是元至元二年（１３３６）增订本，有后人大量的删添，但大体上仍保存了《古清规》的精华。
    此外，怀海行持尚有二点可注意者。第一、《清规》是否规定诵咒问题。１３３６年《敕修百丈清规》载，诵经以《楞严咒》、《大悲咒》、《十佛名》为最。《开元释教录》卷九、卷八，《宋高僧传》卷二载：唐神龙元年（７０５），广州制止寺已出《大佛顶如来密因修证了义诸菩萨万行者楞严经》一部十卷；永徽、显庆年间（６５０－６６１），西印度沙门伽梵达摩亦出《千手千眼观世音菩萨广大圆满无碍大悲心陀罗尼经》一卷，可见此二经怀海时已行世。在禅院中诵此咒是有可能的。忽滑谷快天认为：《首楞严咒》不外多神的祈祷，《大悲心陀罗尼》为观音崇拜之堕落者，“与吾禅道有何交涉，”对此持否定态度。实则禅密诸宗互相吸收，彼此借鉴，实无可非议，何必纯之又纯，无半点圆融可言呢？
    第二、关于百丈野孤之话问题。怀海《语录》载：师每日上堂，常有一老人听法，随众散去。一天，这位老人问百丈：“大修行底人还落因果也无？”师云：“不昧因果。”老人言下大悟。因为老人原来听说“大修行人不落因果”，致使他五百年修行，仍为老孤身，现在师说“不昧因果”，意谓修行能契合禅的真义，即身成佛。后辞师去。师令维那告众，齐后普请送亡僧。领众至后山岩下，以杖挑出一死孤，依法火葬。这是悟道之人还受报应与否的一则著名公案。别据怀海同学大珠慧海《语录》说：“人问：一心修道，过去丛障得消灭否？师曰：不见性人，未得消灭；若见性人，如日照霜雪。又见性人，犹如积草等须弥山，只用一星之火，业障如草，智慧似火。”意思是说，不见性的人。终受业障的报应，见性之人，则业障之报自然消除。写前面百丈与野孤所化的老人对话所说大修行人“不昧因果”是一致的。不落因果，即不堕于因果报应之中，这是否定了因果报应，不昧因果，则明于因果之报，丝毫不差，同时努力修行，种善因果善果。但也有人认为此对话为伪作，待考。
    怀海于８１４年圆寂，后会昌五年月日 （８４５）发生毁佛的法难，宣宗即位（８４７），始再兴佛教，禅林大德如林，人材辈出，沩山灵祐即是其中佼佼者，灵祐与其徒慧寂，更创沩仰宗，成为禅宗的一花五叶中最早伸展出的一个叶片。


二、灵祐方圆默契

二、灵祐方圆默契

    唐武帝时迷信道教，打着“惩千古之蠹源，成百王之典法，驱游惰不业之民，废丹癯无用之室”的幌子，废寺院四万余所，令僧尼还俗二十六万余人。由于这种强行废佛的行政手段不得人心，不到两年，宣宗即位，即一改废佛的政策，重兴佛法。当然，宣宗复兴佛法的一个重要原因是与百丈山有特殊的因缘。宣宗本宪宗第四子。为穆宗异母弟，武宗惮忌之，乃沉之于宫厕，宦官仇公武暗中救护，使其免遭毒手，遂削发为僧，周游天下，备赏险阻，武帝一死，左神策军中尉杨公等即迎宣帝而立之。宣宗初与香岩智闲在百丈山看瀑布，智闲吟诗二句：“穿云透石不辞劳，地远方知出处高。”借穿云透石的瀑布，比喻宣宗出处高贵，不同凡响。宣宗当即续吟二句：“溪涧岂能留得住，终归大海作波涛。”以此寄寓自己的志气高远。宣宗由于有这一段学佛因缘，其后复兴佛教也就不奇怪了。此时，禅林中大德辈出。其一即沩山灵祐。
    灵祐（７７１－８５３）俗姓赵，福州长溪（今福建霞浦）人。十五岁依同郡法悟律师，执劳每倍于役，冠年剃发，三年具戒。后入浙江天台山，遇寒山子，造国清寺，又遇异人舍得，遵寒山、舍得之嘱，遂诣泐潭，谒大智怀海师，顿了祖意。元和末（８２０左右）随缘长沙，过大沩山（今长沙市宁乡县境），遂欲栖止，山峰峭绝，荒无为烟。以橡粟为食，猿猴为伍，经五七载，山民知之，建梵宇曰同庆寺。如此十数年，徒众五百余人，“言佛者天下以为称首。”会昌法难后，祐“裹首为民”，裴休访祐，因迎请之，与谈玄旨，亲为徒列，徒众复聚如初，相国崔公慎由崇重加礼，由是沩山名高天下。宣宗大中七年（８５３）迁化，年八十三。
    关于灵祐的禅学思想，忽滑谷快天说：“灵祐根本思想与百丈所见不异，作为沩仰门风者，宾主对扬之手段而已，而其手段多出自慧寂。”似认为灵祐根本同百丈，手段多出自慧寂，灵祐本人之贡献甚少，实则作为沩仰宗之开创者，其禅学思想自有其独到之处。灵祐以“镜智”为宗要，疾“三种生”（想生、相生、流注生）为虚妄，其宗风方圆默契，体用圆融。
    以“镜智”为宗要，疾“三种生”为虚妄。《人天眼目》载：“师（沩山）谓仰山曰：吾以‘镜智’为宗要，出三种生，所谓想生、相生、流注生。《楞严经》云：‘想相为尘，识情为垢，二俱远离，则汝法眼应时清明。’云何不成无上知觉？”“镜智”即“大圆镜智”。法相宗认为成佛以后，阿赖耶识转为清净智，如同大圆镜可以如实映现一切影像一样。这种可以如实映现一切法的佛智。即大圆镜智。以“镜智”为宗要，即以无为无事为道人之活计，他说：“道人之心，质直无伪，无背无面，无诈妄心。一切时中，视听寻常，更无委曲，亦不闭眼塞耳，但情不附物即得。……譬如秋水澄清，清净无为，澹泞无碍，唤他作道人，亦名无事人，”修从顿悟与渐修相圆融来说明“心自圆明”，有僧问他顿悟之人是否还要继续修行，灵祐回答说：
    若真悟得本，他自知时，修与不修，是两头语。如今初心虽自缘得，一念顿悟自理，犹有无始旷劫习气未能顿净，须教渠净除现业流识，即是修也。不可别有法，教渠修行趋向，从闻入理，闻理深妙，心自圆明，不居惑地。”
    一念顿悟是对生死解脱大事的根本觉悟，顿悟之后，仍有许多旧习气要逐步克服，方能有全面、彻底的觉悟。这种所悟与修圆融起来的观点是正确的。因此，以“镜智”为宗，即是在认识人人本自圆满俱足的本性的基础上，把修与无修、顿悟与渐修有机结合起来。这不仅继承了禅宗明心见性、顿悟成佛的优良传统，也是对禅宗南北顿渐之争的正确总结，对于克服中唐时期南宗偏于顿悟、轻于渐修之弊，是有益的，也是颇有创见的。
    以“镜智”为宗，认识人人本自俱足的佛性，也就是悟道。关于“道”，有治国的根本道理、根本学说、伦理道德原则、万物的本体等不同涵义。灵祐从佛教的立场出发，吸取道家清净无为的思想，以“无心”为“道”。他的《语录》说：“僧问如何是道？师云：无心是道，僧云：某甲不会，师云：会取不会底好。僧云：如何是不会底？师云：只汝是，不是别人。复云：今时人，但直下证取不会底，正是汝心，正是汝佛。若向外得一知一解，将为禅道，且没交涉，名运粪入，不名运粪入，污汝心田。所以道不是道。”这一段对话，鲜明地体现了灵祐以“无心”为“道”，即是从自家体认自己的本来面目，不是从经解、名言上得一知半解，染污清静本性。这种以下会“道”为真正体道之人，从自心中认取圆满俱足的思想，正是以“镜智”为宗的根本精神的体现。
    以“镜智”为宗，是与疾“三种生”密切相联的。《人天眼目》说：“想生，即能思之心杂乱；相生，即所思之境历然；微细流注，俱为尘垢。若能净尽，方得自在。”想生，即心作天堂，心作地狱，一切善恶，皆由一念，即主体的思维、思量分别而生，相生即执着一切虚幻境相为真，不悟五蕴皆空。流注生即堕于生死轮回，无有止息、解脱之日。灵祐认为这“三种生”皆属净尽，不破除这些虚妄，则不能悟圆满俱足的本来面目。“若能净尽，方得自在。”何国铨先生说：“仰山认为三种生（想生、相生、流注生）皆属虚妄，盖念念不断，心即生凿缚而不自在矣。惟不于念上起心，心随境转，则触目遇缘，亦无非道矣，”这种理解是得灵祐之旨的，是中肯的。
    方圆默契，似关合符，这是沩仰宗风的一个鲜明特点。《法眼禅师十规论》说：“沩仰则方圆默契，如谷应韶，似关合符。”《人天眼目》对此评论说：“沩仰宗者，父慈子孝，上令下从。尔欲捧饭，我便与羹。尔欲渡江，我便撑船；隔山见烟，便知是火；隔墙见角，便知是牛。……大约沩仰宗风，举缘即用，忘机得体，不过此也。”这一段话对沩仰宗风作了概括的评价，说明灵祐接引从众，有三人特点：
    （一）方圆默契，谈笑风生
    这与他宗门庭严峻，形成鲜明对比。“石霜抵沩山为米头，一日筛米次，师云：‘施主物，莫抛散’。石霜生：‘不抛散。’师于地上拾得一粒云：‘汝道不抛散，这个是什么？’石霜无对。师又云：‘莫轻这一粒，万千粒尽从这一粒生，’石霜云：‘百千粒从这一粒生，未审这一粒从什么处生？’师呵呵在笑，归方丈，”从百千粒从一粒生，未知一粒从何而生的公案中，不仅可以看出沩仰宗对一多圆融的辩证思维，也可以从中领略，他们师徒之间充满智慧与默契的禅趣。
    （二）意气相合，机锋互换
    《景德传灯录》载：“普请摘茶，师谓仰山曰：‘终日摘茶，只闻子声，不见子形。请现本形相见。’仰山撼茶树，师云：‘子只得其用，不得其体，’仰山云：‘未审和尚如何？’师良久。仰山云：‘和尚只得其体，不得其用。’师云：‘放子三十捧。’”这个体用双全的公案，典型反映了禅宗寓禅修于生产劳动之中的农禅作风，也反映了沩仰宗接引徒从的和平、意气相合。对此，白云守端禅师评价道：“父子相投，意气相合，机锋互换，啐啄同时。虽然如是，毕竟如何道得体用双全去？沩去放子三十棒，也是养子之缘。”这个评价是恰当的。
    （三）体用双全，理事不二
    至于体用，灵祐虽然讨论不多，但从几则公案中，也可略窥其宗旨。《景德传灯录》卷九载：“师一日唤院主，院主来，师云：我唤院主，汝来作什么？院主无对，又令侍者唤第一坐，第一坐来。师云：我唤第一坐，汝来作什么？亦无对。”这里牵涉到个别与一般、名与实、有与体的关系问题。虽然院主，第一座是抽象名词，与具体的“那一位院主”、“那一位第一座”是不同的；但是，二者又是密切联系的。灵祐虽然强调二者的区别，甚至把二者对立起来，认为“那一位院主”不等于“院主”，但实质上是要禅僧去掉名与实、个别与一般、用与体的分别心，坚持二者的统一、圆融，主有成佛的可能。他在上堂法语中就点明了这个主旨。他说：“纵有百千妙义，抑扬当时，此乃得坐披衣，自解作活计始得。以要言之，则实际理地，不受一尘，万行门中，不舍一法，若也单刀直入，则凡圣情尽，体露真常，理事不二，即如如佛。”“实际理地”即指与心性、宇宙贯通的本体；“万行”指人生的行为心理与道德哲学。本体“不受一尘”，即与现象是有区别的，同时，人的行为心理与道德践履又离不开世界诸缘。换言之，体不同于脾，又不离于用；理不同于事，又不离于事，这就是灵祐体用一如、理事不二的辩证法，也是沩仰宗接引徒众的显著宗风。
    可见，沩山灵祐在创立沩仰宗时，不仅师承百丈，而且有自己的突出贡献，故“言佛者天下以为称首”。至于他的弟子仰山的贡献，当然也不可抹煞的。


三、慧寂默照为宗

三、慧寂默照为宗

    慧寂（８１５－８９１），韶州怀化人，俗姓叶，年十五欲出家，父母不许，后二载，断手二指，跪父母前誓求出家，遂依南华寺通禅师落发。初谒耽源，已悟玄旨，后参沩山，遂升堂奥。耽源将六代祖师所传九十七圆相传慧寂，寂一览便付之一炬，后重录一册，竟无遗失。师灵祐时，问如何是真佛住处，沩山云：“以思无思之妙，返思灵焰之无穷，思尽还源，性相常住，事理不二，真佛如如。”于言下顿悟。自此执侍，前后十五载，寻往江陵受戒、住夏、探律藏，后参岩头，问石室，终传灵祐心印。“年三十五，领众出世住，前后诸州、府、节、察、刺使相续十一礼为师。”曾住五莽山。僖宗帝乾符六年（８７９），还袁州大仰山张化门，故以仰山之名为世知。“接机利物，为禅宗标准。”晚年迁韶州东平山，唐昭宗大顺二年（８９１）卒，年七十七。
    仰山继其师沩山之旨，师徒共创沩仰宗，二者亦有细微区别，沩山以“镜智”为宗，出想生、相生、流注生；仰山则以“默照”为宗，而出九十七圆相，兹述仰山之旨如下。
    （一）“默照”为宗，如实而修
    慧寂承沩山以“思无思之妙”，思尽还源，体用一如，事理不二的思路，倡“默照”为宗，如实修行，默照，即沉默专心坐禅，以慧来鉴照原本清净之灵知心性。“默照”不是默默面壁，放弃参悟，而是以无心之心，以无所得、无所悟而悟本来清净俱足之性。《五灯会元》载仰山与其弟子刘侍御、陆希声的对话说：“刘侍御问：了心之旨，可得闻乎？师曰：若要了心，无心可了。无了之心，是名真心。……陆希声相公欲谒师……公纔入门，便问：三门俱开，从何而入？师曰：从信门入。公至法堂，又问：不出魔界，便入佛界时如何？师以拂子倒贴三下，公便设礼。又问：和尚还持戒否？师曰：不持戒，曰：还坐禅否？师曰：不坐禅。公良久，师曰：会么？曰：不会。师曰：听老僧一颂：滔滔不持戒，兀兀不坐禅，酽茶三两碗，意在鑺头边。量却问：承闻相公看经得悟是否？曰：弟子因看《涅盘经》有云，不断烦，而入涅盘，得个安乐处。师竖起拂子，曰：只如这个作么生入？曰：入之一字，也不消得。师曰：入之一字，不为相公。公便起去。”这里的“无心可了”、“不出魔界，便入佛界”，“不持戒”、“不坐禅”，“不断烦恼而入涅盘，”表面上是否认诵经、持戒、坐禅，实际上是以无心之心来诵经、持戒、参禅，随时观照自己的清净本心。仰山与僧思益的对话也可说明这一点，思益问：“禅宗顿悟，毕竟入门的意如何？”师曰：“此意极难，若是祖宗门下，上根上智，一闻千悟，得大总持，其有根微智劣，若不安禅静虑，到这里总须位然。”慧寂认为，上根利器可以一闻千悟，即顿悟，而根微智劣之人，则必须安禅静虑，方可渐悟。可见，他并不是一律排斥经教、坐禅、而是根据不同人的根机，当机施设，方便接引学人。
    以“默照”为宗，实质上就是如实而修，他反对那些追求“三明六通”，弃本逐末，不如实而修的人，他开法王莽山时，上堂说：
    汝等诸人，各自回光返照，莫记吾言。汝无始劫来，背明投暗，妄想根深，卒难顿拔，所以假设方便夺汝粗识。如将黄叶止啼，有什么是处？亦如人将百种货物，与金宝作一铺货买，只拟轻重来机，所以道石头是真金铺，我这里是杂货铺，有人来觅鼠粪，我亦拈与他，来觅真金，我亦拈与他。”时有僧问：“鼠粪即不要，请和尚真金。”师曰：“啮镞拟开口，驴年亦不会。”僧无对。师曰：“索唤则有交易，不过唤则无我。若说禅宗，身边要一人相伴也无。岂况有五百七百众邪？我若东说西说，则争头向前采拾。如将空拳诳小儿，都无实处。我今分明向汝说圣边事，且莫将心凑泊。但向自己性海，如实而修，不要三明六通。何以故？此是圣末边事。如今且要识心达本，但得其本，不愁其末。他时后日，自具去在，若末得本，纵饶将情学他亦不得，汝岂不见沩山和尚云：“凡圣情尽，体露真常，事理不二，即如如佛。”
    慧寂主张各自回光返照，向自己性海，如实而修，不要追求什么“三明六通”之类的“特异功能”。“特异功能”是现代科学至今尚未认识的领域，古德认为，“特异功能”是修炼到一定程度自然出现的现象，如果放弃根本，舍本逐末，那是一事无成的。仰山和尚坚持禅门注重炼“内功”，认取自家圆满俱足的本性，反对单纯追求“神通”的迷信，这是继承了达摩、慧能以来“明心见性，顿悟成佛”的正信佛教的优良传统，体现了禅学发展的主流。
    （二）九十七圆相，用而不执
    慧寂接引徒众，重视不执着于相，又不离于相。他初谒耽源，把耽源传给他的九十七圆相用火烧了。说：“慧寂一览，已知其意，但用得不可执本也，”“耽源上师，师（慧寂）出众作此〇相以手拓呈了，却叉手立，源以两手相交，作拳示之。师进前三步，作女人拜，源点头，师便礼拜。”慧寂烧掉列代祖师所传圆相，并非弃而不用，而是不用而用，用而不执着。也就是说，圆相之作用，在于方便学人契入真好理境，由此而入。则圆相之存废就无关紧要了。他在惊人的记忆力与理解力，一览便知，烧掉后重录一本，竟无遗失，确实身手不凡。
    九十七圆相，有六重意义，即：圆相、暗机、义海、字海、意语、默论等。
    圆相：即表示远离语言文字的境地。“陆希声相公欲谒师，先作此〇相对呈。师开封，于相下面书云：‘不思而知，落第二头；思而知之，落第三者。’遂封回。”也就是说，不思而知为第二义，思而知之更次一等；只有远离语言文字，总能证悟涅盘真理。一僧问沩山：“和尚还识字否？”师曰：“随分”。僧以手画此〇相拓呈，师以衣袖拂之，僧又作此〇相拓呈，师以两手作背抛势，僧以目视之，师低头，僧绕师一匝，师便打。僧遂出去。有一僧右旋一匝，问师什么字，师于地上书十字酬之。僧又左旋一匝，问什么字，师改十字作卍字，僧画此〇相，以两手拓，如修罗掌日月势，问是什么字，师仍画此卍相对之。僧作娄至德势，师曰：“如是！如是！此是诸佛之所护念，汝亦如是，吾亦如是，善自护持。”其僧礼谢，腾空而去。这是说，〇形表无相三昧，如满月之状，也可象征佛性廓然虚明，有不可思议的大妙用，只有远离名言，总能证悟这玄妙的境地。
    暗机：即以特定圆形符号表示诸佛密意，以示宾主、纵夺、机关、眼目、隐显、权实。《人天眼目》卷四说：仰山于耽源处受此圆相，“后于沩山处得印证。说：‘诸佛密印，岂容言乎？’又曰：我于耽源处得体，沩山处得用，谓之父子投机，故有此圆相。”
    义海：即以义解释禅悟之理，将觉海变为义海。仰山在洪州观音寺时，一天饭后，有僧来礼拜，仰山看都没看一眼，僧问：和尚识字吗？山答：随分识几个。僧围绕着他绕了一圈，说：“是什么？”仰山在地上画十字、卍相对之。僧又作数至势，仰山肯定地说：“如是如是，此是诸佛之所护念，汝既如是，吾亦如是，善自请教仰山，仰山礼谢，腾空而去，后经五日，一道者以不辩此中三昧，请教仰山，仰山解释道：”吾以义为汝解释。此是八种三昧，觉海变为义海，体同名异。然此义合有因有果，即时异时，总别不离隐身三昧也，”仰山此解释，仍令人十分费解，大体上从体用、因果、时空、总别来阐释证悟之境界，即以“义海”证“觉海”。
    字海：即以文字名言显示机法。仰山有问三圣的著名公案。“仰山问三圣：汝名什么？圣云：惠寂。仰山云：惠寂是我。圣云：我名惠然。仰山呵呵大笑。”此公案在常人看来，也许并无新奇之处。仰山本名惠寂，三圣本名惠然。三圣有意以问者之作已名，以示人境自他俱夺之机；而仰山以“惠寂是我”，还其人境俱不夺之意。这就是通过名言、文字，把人境、自他俱夺、俱不夺之禅机显露出来了。
    意语：即不落言诠，以意显示真义。仰山有推枕子公案。《景德传灯录》卷十一载：“一僧问仰山，法身说法否？仰山答：我说不得，别有一人说得。僧又问：说得底人在什么处？仰山用推出枕子示之。”也就是说，真实法身非由言诠显示，用刷自体显现；　法身遍于世界，无所不及，万物皆有自性，到一定时节因缘，自然显现。沩山称赞仰山“为用剑刃上事”，即不落言诠，以示真义。
    默论：即以动静、语默显示禅机之法。仰山一日前往参访沩山。沩山问仰山自何处来，仰山答：田中来。沩山问：田中多少人？仰山插下锹子，叉手而立。沩山问：南山大有人割茅？仰山拈锹子便行。这则公案，通过沩仰师徒之间一语一默、一动一静之间显示佛道真义，反映他放去收来迅速自在，无所滞碍的禅风。
    总之，不论是圆相、暗机、义海、字海，还是意语、默论，都反映了仰山以不同方式接引学人的活泼禅风。
    （三）十九种法门　任运无所
    仰山慧寂教导学人之法门，有十九种；（１）垂示三昧门。即教示学人修习禅定。（２）问答互换门，教示学人问答、应对的方法。（３）性起无作门。即明真如本性人人本具，无待造作。（４）缘起无碍门。示学人缘起之理法乃自在无碍。（５）明机普互门。即明了学人不同根机而接化。（６）暗合宾主门。即学人与师家相互契机，冥合不二。（７）三生不隔门。即示学人泯绝过去、现在、未来三世之区别，示任何机宜皆可成佛之理。（８）即幻明真门。藉现象界之变异虚幻，向学人明示如如常住之法性真理即幻。（９）用了生缘门。针对修行者所遇合之众缘，一一辨析机理，抉隐明微，契当真理。（１０）就生显法门。示学人明了“自身即法”之理。（１１）冥符生缘门。令修行者自觉其机缘处境巧妙允当，冥符真理。（１２）三境顺真门。示学人随顺性境、独影境、带质境即真理。（１３）随机识生门。根据学人不同根机而识究之。（１４）海印收生门。以如大海一样甚深广大之殊胜法义，比喻不可思议的佛智。（１５）密用灵机门。即密用修行者灵利之根机。（１６）啐啄同时门。即因势利导，帮助学人开悟之助缘。（１７）随收随放门。即随缘接化，或以严峻手法否定学人心中妄见，或以宽容肯定学人之见解，放任其自由发展，收发自如。（１８）卷舒无任门。应机教导学人，擒纵、与夺，卷舒无碍。（１９）一多自在门。即师徒关系融通微妙，泯绝任何一多、大小、尊卑、妙粗之对待而任运无作，这些法门，通过垂示、问答、随机、密用、啐啄、卷舒等方式，以性起、缘起之理，从宾主、真幻、一多、放收等的辩证关系中，启发学人把握真如法性。


四、沩仰宗传承

四、沩仰宗传承

    关于禅宗五宗的传承，北宋明教契嵩大师说：“正宗至鉴（慧能），传既广，学者遂各务其师之说，天下于是异焉，竟自为家。故有沩仰云者，有曹洞云者，有临济云者，有临济云者，有云门云者，有法眼云者，若此不可悉数。而云门、临济，法眼三家之徒至今犹盛。沩仰之息，而曹洞者仅存，绵绵然若干旱这引孤泉，”今人陈荣波先生说：“在这五宗中，沩仰宗成立最早，临济及曹洞次之，云门及法眼较后。沩仰一宗在唐末时，后继无力，就绝传了。法眼宗也在宋初随之灭亡。至于云门一宗，发展到北宋就中断。目前尚存者，只有曹洞与临济二宗。”这是符合历史事实的，已成定论。
    （一）传承概况
    沩仰宗的传承，据《传法正宗记》等资料，有传记、语录、事迹可考者约九十九人。其中沩山灵祐之得法弟子四十四人，仰山慧寂传十人，香严智闲传十二人，西塔光穆传一人，资福如宝传四人，南塔光涌传五人，报慈德韶传二人，芭蕉慧清传十一人，双峰传一人，径山洪湮传六人，慧林究传一人。报慈德韶传三角志谦、兴阳词铎后，即沩仰宗六世后，不见传承。
    其主要传承者有：香严智闲、径山洪湮、西塔光穆、南塔光涌、霍山景通、无著文喜、资福如宝、芭蕉慧清、清化全怤、黄连义初、资福贞邃、芭蕉继彻、潭州鹿苑、承天辞确等。
    （二）香严智闲与祖师禅
    智闲（？－８９８）是慧寂的师弟，在百丈怀海时，性识聪敏，问一答十，问十答百，但参禅不得；怀海迁化，后能沩山，灵祐问他：“父母未生时，试道一句看！”他茫然无所措，回去遍翻经书，终无答案。自叹道：“画饼不可充饥。”屡求沩山说破，沩山以“我说底是我底，终不干汝事，”未为说破。智闲回去，将平时看文字通通烧掉，说：“此生不学佛法也，且作个长行粥饭僧，免役心神！”遂告辞沩山，过南阳，参忠国师遗迹，遂憩止焉。后来有一天，在普请下地除草时，因捡起一片瓦砾，随手一扔，碰到竹子上，“当”的一声，忽然省悟，马上回房净手焚香，遥礼沩山，说：“和尚大慈，恩逾父母，当时若为我说破，何有今日之事！”遂把自己的证悟写一偈寄给沩山，沩山和尚说：“此子彻也，”称赞他开悟了。仰山要香严智闲作一句偈颂，严脱口而出，说：“去年贫，锥也是贫，今年贫，始是贫，去年贫，犹有卓锥之地，今年贫，锥也无。”反映了自己认识境界的提高，仰山说他只会如来禅，祖师禅犹未会，他说：“我有一机，瞬目视伊，若人不会，别唤沙弥。”仰山这时总首肯他：“且喜闲师弟会祖师禅也。”如来禅即经教所说禅法。祖师禅即祖师口耳相传，以心传心所传禅法，如来禅有阶梯之渐，有迹相可寻，而祖师禅则言语道断，刹那之间，当下契入，迹相俱泯。故祖师禅要高于如来禅。但从根本上说，语静动默。一切声色，无非佛事，所以二者又是一致的，智闲始从经教悟入，不得证悟，对于父母未生之前禅人的本来面目是什么的问题茫无所知。后来抛开经教，在行住坐卧中真参实证，始悟“处处无蹤迹。”不须修持，即体悟到自己成佛的本性俱足，至于悟的境界高低，由“贫无立锥之地，”到“连锥也无，”，确是一个境界的升华，但仍落阶级，有迹相可寻；至“若人不会，别唤沙弥”，连小沙弥也会体悟自己的本来面目。则说明确是彻悟了，所以得到仰山的印可。
    香严接引学人，亦主张离开名言而证悟，他上堂说：“道由悟达，不在语言，况是密密堂堂，曾无间隔，不劳心意，暂借回光。日用全功，迷徒自背。”问他什么是香严境，他说：“华木不滋，”问他如何是佛法大意，答道：“今年霜降早，荞麦总不收”。问：如何是西来意？他在上堂中说：“若论此事，如人上树，口衔树枝，脚不蹋枝，手不攀枝，树下忽有人问：如何是祖师西来意？不对他，又违他所问；若对他，又丧失失命。当凭么时作么生即得？”虎头抬上座回答：“树上即不问，未上树时请和尚道。”师哈哈大笑。其实，在智闲看来，祖师西来大意，即在于了脱生死大事，而这不是口问心维所解悟的，只能在动静语默中去证悟，开口即错，动念即乖，故不论问树上人，还是树下问，都是不行的，当然，智闲也以语言为接引方便，故《五灯会元》说：“师凡示学徒，语多简直。有偈颂二百余篇，随缘对机，不拘声律，诸方盛行。”
    要之，智闲亦继随沩仰以“镜智”为宗，方圆默契之宗风。嗣法弟子有吉州止观、寿州绍宗、延庆法端、南禅无染、大安清干、长平山和尚、崇福演教、终南丰德、佛岩晖、双溪田道者、益州昭觉、睦州东禅等。
    （三）洪湮“道中一也无”
    灵祐之弟子杭州径山洪湮（？－９０１），吴兴人。十九岁礼开元寺无上大师落发。后入嵩山受具戒，谒云岩不契，再参沩山始悟。沩山寂，即继师席。他在接引学人时，运用大量比喻，说禅宗之修行，离四句，绝百非，不假文字，好比“耕人田不种”、“禾熟不临场。”佛日长老访他，说：“一言定天下，四句为谁宣？”洪湮曰：“汝言有三四，我道其中一也无。”并有偈云：“东西不相顾，南北与谁留。汝言有四句，我道一也无。”光化四年（９０１）卒，他主张“我家道处无可道，”显然是融合了道家老子与佛教空观思想的结果。
    洪湮的嗣法弟子有洪洲米岭、庐州寂、临川义直、栖贤寂、杭州功臣会道等六人。后不见传承。
    （四）南塔光涌“真佛无所似”的思想
    袁州仰山南塔光涌禅师（８５０－９３８），豫章丰城章氏子。少时依仰山剃度。北游参谒临济，后归侍仰山。仰山问他：“来作什么？”他说：“礼观和尚”／问他：“还见和尚么？”答：“见”。仰山问：“和尚怎么像驴？”回答说：“我看和尚您怎么也不像佛？”仰山说：“不像佛，那像什么？”光涌说：“若有所似，与驴何别？”仰山对此大为震惊。说：“凡圣两忘，情尽体露。吾以此验人，二十年无决了者，子保任之。”认为光涌证悟十分透彻，为其门下二十年来第一个证悟之人，嘱他好好保任，还称他为“肉身菩萨，”僧问：“文殊是七佛之师，文殊还有师否？”答：“遇缘即有。”问：“如何是文殊师？”光涌竖起拂子。僧问：“莫只这便是么？”师放下拂子，叉手问：“如何是妙用一句？”师曰：“水到渠成。”问：“真佛住在何处？”答：“言下无相，也不在别处。”他认为真佛无所似，也无形相，无一定处所。只要向内证悟，水到渠成，自见本心即是真佛。这个见解体现了禅宗的根本精神。
    光涌的弟了有五人，即越州清化全怤、芭蕉慧清、黄连义初、慧林鸿究、洪州黄龙，其中慧清传法弟子最多，达十一人，仅次于智闲，为沩仰宗传法弟子中最多的一个。
    （五）文喜“心尽即涅盘”
    杭州无著文喜禅师（８２０－８９９），嘉禾（湖州）语溪人，俗姓朱。七岁依本邑常乐寺国清出家弟染，后习律听教，会昌法难时，被澄汰，反服韬晦。大中初（８４７左右）按律例于盐官齐峰寺重新忏度，后谒大慈山性空禅师，往参五台山华严寺，遇文殊乘金毛狮子往来，其侍童赐偈曰：“面上无嗔供养具，口里无嗔吐妙香，心里无嗔是珍宝，无垢无染是真常。”因驻锡五台。咸通三年（８６２）至洪州观音参仰山，顿了心契，令充典座。又遇文殊现于粥镀之上。有异僧来求斋食，师减已份馈之，受到仰山的称赞，说：“汝得大利益”，后回浙江住龙泉寺，僧问：“如何是涅盘相？”答曰：“香烟尽处验。”将顺寂，于子夜告众曰：“三界心尽，即是涅盘。”言讫，跏趺而终。塔于灵隐山之西坞。钱王赐紫衣，署无著禅师。
    文喜以“香烟尽处”、“三界心尽”作为涅盘，以无垢无净为“真常，”即以主体、客体上的“空”为涅盘实相。其弟子未见传承。
    （六）五冠顺支续圆相
    新罗国五冠山顺支了悟禅师，为继续仰山九十七圆相的突出代表。
    师讳顺之，又作顺支，俗姓朴氏，新罗（今朝鲜）浿江（大同江）人，家世雄豪，以守边忠勤将领闻名乡里，母昭氏，少年精勤好学，有凌云之志。弱冠之年出家，投五冠山剃发，于俗离山受具，大中十二年（８５８）随入朝使，迳到仰山慧寂处，虔诚礼足。师曰：“来何迟，缘何晚！既有所至，任汝住留。”自此不离师，随侍左右，问道不懈，同门叹服。唐代懿宗乾符元年（８７４）回国，住五冠山龙严寺，寺为松岳郡女檀越元昌王后及子威武大王所施，后改瑞云寺，寂于此，时年六十五岁，故又称瑞云和尚。僧问如何是西来之意？师竖起拂子，问：莫这个便是？师放下拂子。问：以字不成，八字不是，是什么字？师作圆相示之，有僧于师前作五花圆相，师画破作一圆相。了悟禅师还有《五冠了悟和尚与仰山之玄问玄答》。其圆相之义，在前人的基础上有所发展，甚至可说至于极点。此后虽有用此圆相者，但已不多，运用也不广。《玄问玄答》说：”三祖（僧璨）云：‘毫厘有差，天地悬隔，’若不具正眼，焉能辨此，似子胡听伯牙之琴，如提婆晓龙树之相。喻鸡抱卵，啐啄同时，迟钝浅流，卒难顿晓，如盲视色而转错也。”他所说的“正眼”，即三祖僧璨《信心铭》所阐明的即妄了真、洞彻真源的不二法门。真义虽然浅钝之人难以顿晓，但也可以通过长期的渐修而得到证悟，顺支承仰山九十七圆相之旨，以此接引徒众。
    顺支撰《三篇》说，示三种悟道成佛法，第一、顿证实际篇，即顿悟成佛；第二、回渐证实篇，即先修三乘渐教，后入顿门以成佛；第三、渐证实际篇，即渐修渐悟法门。针对徒众不同根据以接引成佛。
    顺支还以圆相表示证理迟疾，分为“四对八相”、“两对四相”和“四对五相”，大体上说，“四对八相”示学人离声色，从本心顿悟，见性成佛；会三乘为一乘，契果修因，经三大僧只，坏四魔贼，证无漏性智。“两对四相”，则侧重摈除情解，体证自心圣智；摈弃对外企求，了知自心即佛、即净土；“四对五相”则循序渐进，明示自心佛，自心净土。
    此外，顺支还撰有《三遍成佛》一文，论证理成佛、行满成佛、示显成佛，揭示“一切诸佛，出现于世，撮化群生，相传授记，分毫不错……前佛后佛，皆同此路，如人行路，新旧同辙。”以遮那佛为本体，以文殊为见性智功，以普贤为万行福力，以实智与万行而证菩提。
    由上可知，顺支承仰山圆相之旨，对于见性成佛确有精到见解，在沩仰宗的海外弟子中为佼佼者，惜乎其传承不详。
    （七）慧清“娘肚出作狮子吼”
    仰山的再传弟子南塔光涌之徒郢州芭蕉山慧清，是另一位新罗国禅僧，也是８５８年入华，慧清上堂说：“你有拄杖子，我与你拄杖子，你无拄杖子，我夺却你拄杖子，”靠拄杖下座，还巧设譬喻，要学人在言语道断、心行处绝时证悟。他上堂说：“如人行次，忽遇前面万丈深坑，背后野火来逼，两畔是荆棘丛林，若也向前，则堕在坑堑，若也退后，则野火烧身，若也转侧，则披荆棘林碍。当与么时，作么生免得？若也免得，合有出身之路，若免不得，堕身死汉。”僧问：“不问二头三首，请师直指本来面目。”师默然正坐，问：“北斗藏身，意旨如何？”师曰：“九九八十一。”乃曰：“会么？”曰：“不会，”师曰：“一二三四五，”师谓众曰：我年二十八，至仰山参见南塔，见上堂曰：‘汝等诸人，若是个汉，从娘肚子出来便作狮子吼，好么？’我于言下歇得身心，便住五载。”问：如何是祖师意？师曰：汝问那个祖师意？曰：达摩西来意。师曰：“独自栖栖暗渡江。”问：什么物无两头，什么物无背面？师答：我身无两头，我语无背面。问：如何是透法身句？师曰：一不得问，二不得休。曰：学人不会。师曰：“第三度，与汝相见。”不问二头三首，娘肚子出来便作狮子吼，都是要学人悟自己本来面目，佛性本自圆成，不必向外驰求。
    慧清的传承很盛，其法嗣有：芭蕉继彻、兴阳清让、幽谷法满、芭蕉山遇、芭蕉山圆、承天辞确、牛头山精、觉城院信、芭蕉山闲、芭蕉令遵、兴阳义深、洪州贵龙等十二人。
    （八）继彻之旨不挂齿
    慧清法嗣有芭蕉继彻较为著名，继彻初参风穴，后谒芭蕉，以仰山“两口一无舌，此是吾宗旨，”而豁然有悟。后上堂曰：“眼中无医，空里无花。水长船高，泥多佛大。莫将问来，我也无答。会么？问在答处，答在问处。”以言语道断为教。问：“三乘十二分教即不问，如何是宗门一句？”答曰：“七纵八横。”问：“如何领会？”答：“泥里倒，泥里倒。”又问：“如何是衲僧分上事？”曰：“要行即行，要坐即坐，”师有偈曰：“芭蕉的旨，不挂唇齿。木童唱和，石人侧耳。”认为至道不在言说，动静语默，当下即是，悟则木童也能唱和，石人也侧耳静听，点头在意，教学人自家去语悟。其法嗣不详。
    仰山法嗣西塔光穆禅师，亦长于以圆相指引学人。问：“如何是西来意？”师曰：“汝无佛性，”问：“如何是顿？”师作圆相示之，问：“如何是渐？”师以手空中拔三下。其弟子即吉州资福如宝一人。如宝法嗣资福贞遽、吉州福寿、潭州鹿苑、报慈德韶四人。资福贞遽继承仰山之旨以圆相接引学人。僧问：“和尚见古人，得何意旨便歇去？”师作此后鱼相示之。问：“如何是古人歌？”师作此〇相示之。僧问潭州鹿苑和尚：“余国作佛，还有异名也无？”鹿区降尚作此〇相示之。问：“如何是鹿苑一路？”师曰：“石獠舌头问将来。”这些圆相，只可意会，难以言传，在今人看来，简直莫明其妙，然而当时禅师以此“不可思议”接引学人苦参实证，其用心亦良苦。
    沩仰宗在禅宗之五叶中成立最早，但到唐末后就绝传了。虽然到了现代，虚云承兴阳词铎为沩仰八世，韩国有信仰圆相（〇）所示法身佛的圆佛教，但也是一息尚存，微乎其微了。《人天眼目.五家要括》说：“百丈派出大沩祐，香岩仰山亲得绍，南塔芭蕉清续传，儿孙未见续其后。”为什么沩仰宗成立最早，数传后却儿孙绝续？这是值得人们思考问题，北宋契嵩说：“然其盛衰者，岂法有强弱也？盖后世相承，得人与不得入耳，”这是一条重要的经验教训，人能弘道，非道弘人，佛法之兴盛在人，传承在人，其盛衰决定于法门僧才的素质（当然还有社会政治、经济、文化、习俗、外交等各种机缘，而人的因素是第一位的。）人身难得，人才难得，其言诚不诬也。


一、黄檗希运

第六章

    禅宗自从南北分宗，就开始走上多头发展的道路，安史之乱以后，唐朝国势由盛趋衰，而禅宗则名家辈出，山头林立，呈现出繁荣景象，宗密所撰《禅源诸诠集都序》，谓其所述禅门诸宗“殆且百家”，南侁、北秀、牛头、石头、荷泽、保唐、赵州，诸宗大师龙吟虎啸、各擅胜场，禅宗由此走向鼎盛。由于社会历史和文化传统等多方面的原因，中晚唐以后，禅宗态势发生了很大的变化，神秀的北宗禅，再也不见有名僧闻世，而慧能的南宗在南方得到迅猛发展、广东、江西、湖南、浙江、福建、成为南宗禅的策源地。其中又以江西禅风最盛，百丈怀海，南泉普愿、黄檗希运等等，皆不世出的大禅师，他们的门下遍布大江南北，使慧能顿悟以新的风格播扬天下。
    在后期禅宗“五家禅”中，临济宗风最为强劲，无论是接化学人，还是阐释祖意，均新意迭出，不拘成规，其禅法特色，影响久远，成为中国禅宗中波及面最大、渗透最强的宗派。临济禅法思想的直接原因，可追溯至黄檗希运。

    一、黄檗希运
    希运，福州人，生卒年不详，约活动于八、九世纪间，自幼于江西高安的黄檗山出家。及长，身长七尺，额间隆起如圆珠，倜傥不羁，人莫能测。先游天台，后至上都（西安），行乞时，遇一老妪，问答之间，希运“玄门顿而荡豁。”老妪介绍他至江西参马祖道一，至南昌道一已逝，瞻礼祖塔时，遇百丈怀海，乃参之。从此，投于怀海门下。
    据《古尊宿语录》卷二载，希运曾向怀海请问道一平日的机缘。怀海向他说起“竖拂”被喝、三日耳聋的一段公案：
    我再参马大师侍立次，大师顾绳林角拂子。我问即此用，离此用？大师云：“汝他后开片皮，将何为人？”我取拂子竖起。大师云：“即此用，离此用。”我挂拂子旧处，被大师震威一喝，我直得三日耳聋。
其时，希运闻是语不觉吐舌，怀海说：
    “子已后莫承嗣马大师去否？”运云：“不然，今日因师法，得见马祖大机大用，且不识马祖，若嗣马祖已后丧我儿孙，”海云：“见与师齐，减师半德，子甚有超师之作。”
希运见地离拔时辈，颇受百丈怀海的赏识。《景德传灯灵》载有师徒二人初次见面的一段对话：
    问曰：“从上宗乘如何指示？”百丈良久。师云：“不可教后人断约去也。”百丈云：“将谓汝是个人。”乃起入方丈。师随后入云：“某甲特来。”百丈云：“若尔，则他后不得孤负吾。”
  可以看出，怀海起初对希运不甚了解，持保留态度，后见希运见解超迈，便寄予厚望，从日后百丈怀海对希运的评价便可看出这一点：
    百丈一日问师：“什么处去来？”曰：“大雄山下采菌子来。”百丈曰：“还见大虫么？”师便作处声。百丈拈斧作势，师即打百丈一掴。百丈吟吟大笑便归。上堂谓众曰：“大雄山上有一大虫，汝等诸人也须好看，百丈老汉今日亲遭一口。”
    希运于怀海处悟得道一大机大用，并得印可。后来希运回到黄檗山，“四方学徒，望山而趣，睹相而悟，往来海众常千余人。”会昌二年（８４２）希运被当时任钟陵（今江西进贤县）廉镇的裴休迎请至钟陵龙兴寺，躲过了会昌法难。大中二年（８４８），裴休移镇宛陵（今安徽宣城县），又迎请希运至开元寺，朝夕参扣，并记录其开示法语，辑为《黄檗希运禅师传心法要》和《宛陵录》。这是我们今天研究黄檗希运及早期临济思想的重要史料，裴休曾有诗赠希运：
    自从大师传心印，额有圆珠七尺身，挂锡十年栖蜀水，浮杯今日渡漳滨。一千龙象随高步，万里香华结胜因。拟欲师事为弟子，不知将法付何人。
    希运云：
    心如大海无边际，口吐红莲养病身，自有一双无事手，不曾只揖等闲人。
    于此可见希运见地风骨。希运在黄檗山开张门户，说法接人，四方学徒，海众奔凑，“自尔黄檗门风盛于江表，”大中年间，希运示化，谥号“断际禅师。”
    希运的禅学思想主要是继承马祖道一“即心即佛”的思想，而力倡“心即是佛”他说。
    诸佛与众生，惟是一心，更无别法。此心无始已来，不曾生，不曾灭。不青不黄，无形无相。不属有无，不计新旧，非长非短，非大非小，超过一切限量、名言、蹤迹。对待。当体便是，动念即乖。犹如虚空，无有边际，不可测度。惟此一心即是佛，佛与众生更无别异。
    自慧能起，“即心即佛”说便为天下学禅者普遍接受，成为人所共知的事实，从达摩来东土传法，即倡导直指人心，见性成佛。将心等同于佛，这是禅宗的一贯主张，希运说：“达摩大师到中国，惟说一心，惟传一法，以佛传佛，不说余佛，以法传法，不说余法。”但许多学禅者，舍本逐末，妄求佛法，希运批评说：“如今学道人，不悟此心体，便于心上生心，向外求佛，”众生著相外求，“求之转失，使佛觅佛，将心捉心，穷劫尽形，终不可得，不知息念忘虑，佛自现前，此心即是佛，佛即是众生。为众生时，此心不灭，为诸佛时，此心不添，乃至六度万行，河沙功德，本自具足，不假修添，遇缘即施，缘息即寂。”即心是佛，心外无佛。希运极力反对“向外求佛”，力戒对佛法的见闻知解，他说：“古人心利，总闻一言，便乃绝学，所以唤作绝色无为道人，今时人只欲得多知多解，广求文义，唤作修行，不知多知多解，翻成雍塞。”追求知解，不仅不能悟彻佛法，反而成为悟道之障缘。因为“此本源清净心，常自圆明遍照。世人不悟，只认见闻觉知为心。为见闻觉知所覆。所以不睹精明本体。”如此，则导致“求知见者如毛，悟道者如角。”希运认为，求知解是使人与道相隔绝的主要原因，所谓“只怕一念有，即与道隔矣。”世人妄以世智辩聪来知解佛理，不曾想，佛之真谛恰恰被淹没于知解见闻之中。所以希运说：“我此禅宗，从上相承以来，不曾教人求知求解。”即使有时教人“学道”，也只是一种“接引之词”。道不属修，佛不可觅，情存学解，便成迷道。希运继承道一、怀海之说，视一切语言文字、分辩知解为障道之缘。“所以佛出世来，执除粪器，蠲除戏论之粪，只教你除却从来学心见心。”并告诫随其学法的裴休说：“若形纸墨，何有吾宗！”
    既然“即心是佛”，那么应如何来体认这颗心呢？如何来见道呢？希运提出了“无心是道”的主张，他认为“即心是佛，无心是道，但无生心动念，有无、长短、彼我、能所等心，心本是佛，佛本是心。”心体净明，犹如虚空，具足一切功德，不假修添，所以，“举心动念，即乖法体”，在此意义上，马祖道一从否定角度提出了
“非心非佛”说，而希运在这里则以”无心“来取代。道一在否定之后提出了”平常心是道“说，而希运则不再另立“平常心”，直接指出“无心是道”，这就指出了修行实践中的途径和方法，希运说：“但直下无心，本体自现，如大日轮升于虚空，遍照十方更无障碍。”希运以“无心”为纲要，反复强调“无念”、“无求”，以证佛果，这又回归于《坛经》扬倡的“以无念为宗”的法门。“万法惟心，心亦不可得，”因此，不可将心更求于心。若以心求心，以佛求佛，无异于头上安头，角上安角，所以希运认为“不如当下无心，便是本法，”“惟直下顿了自心本来是佛，无一法可得，无一行可修，此是无上道，此是真如佛。”无心可用，无道可修，学道者“但能无心，便是究竟，学道人若不直下无心，累劫修行终不成道，被三乘功行拘凿，不得解脱。”希运认为，悟道无须通过外在的修习工夫，而只是人与道之间的“默契”，他说：“学道人直下无心，默契而已。”这便是无为法门，能悟得此法门者，被称为“无心道人”、“无为道人”。希道十分推崇达到这一境界的“自在人”，他说：
    供养十方诸佛，不如供养一个无心道人。何故？无心者，无一切心也。如如之体，内如木石，不动不摇，外如虚空，不塞不碍。
    希运特别强调在实际生活中“无心”的运用，他说：“终日吃饭，未曾咬著一粒米；终日行，未曾踏着一片地。与么时，无人我等相，终日不离一切事，不被诸境惑，方名自在人。”认为只要在一切时中行住坐卧，但学无心，不起分别，不著一相一物，亦无依倚，亦无住著，方名解脱。他说：“学道人，若欲得成佛，一切佛法总不用学。惟学无求无著，无求即心不生，无著即心不灭，不生不灭即是佛。”
    希运将“即心是佛”与“无心是道”结合起来构成其完整的禅学思想，这一思想直接贯彻了早期禅学《楞伽经》中的如来藏思想，即认为佛性“人皆有之，蠢动含灵与诸佛菩萨，一体不异。”圆满具足，更无所欠。大道平等，含生同一真性，但要识此本性，还须直下无心，如来藏思想与无心学说的结合，便是希运的“空如来藏”说。他说：“从前所有一切解处，尽须并却令空，更无分别，即是空如来藏。”“道场者，只是不起诸见，悟法本空，唤作空如来藏，”希运这一“空如来藏”说的提出，不仅使他的禅不致落于虚空，而保持自然直下任用的风格，也避免堕入“断灭空”的境地。他主张“心境双忘”，而以“忘心”为根本。“忘境犹易，忘心至难。”而“愚人除事不除心，智者除心不除事，”这是希运“空如来藏”的核心内容，在这一思想中，希运特别发挥了“灵性不灭”和“本无所有”的观念。他曾指导凡人临终前的观法：
    但观五蕴空，四大无我，真心无相，不去不来。生时性亦不来，死时性亦不去，湛然圆寂，心境一如，但能如是直下顿了，不为三世所拘凿，便是出世人也。
    心之本体，觉性灵明，是永恒的本真，其余四大、五蕴、三界六道，皆为其起心动念之产物，故虚幻不实。正是在强调空无一切的情况下，希运讲了只有在惠昕以后听《坛经》中总出现的一些言论。如慧能在大庾岭上对追赶他的惠明说：“不思善，不思恶，正当与么时，还我明上座父母未生时面目来！”惠明于言下顿悟，礼拜云：“如人钦水，冷暖自知，”又如将慧能之得法偈记为“本来无一物，何处有尘埃？”这都表明希运禅学思想的创新和发展，并未一味地去简单承袭道一、怀海的禅法。《宛陵录》中记载了希运关于禅的意境的描述：
    语默动静，一切声色尽是佛事，何处觅佛？不可更头上安头，嘴上加嘴。但莫生异也，山是山，水是水，僧是僧，俗是俗；山河大地，日月星辰，总不出汝心。三千世界，都是汝自己，何处有许多般，心外无法，满目青山，虚空世界，皎皎地无丝发计与汝作见解。
    一切声色尽是佛事，若学道者不即不离，不住不著，纵横自在，那么，行住坐卧，语默动静，皆为道场。
    临济示风峻烈，希运于此亦开启良多。他见地高拔时辈，自恃甚高，傲岸独立，雄视天下禅师，曾言：“大唐国内无禅师，”语烁四海。仰山慧寂曾评其禅法为“黄檗有陷虎之机”，因为希运之禅特别强调上乘根基的顿悟，他的禅门并不向中下根机者开启。他常对门下说：“若会即便会，若不会即散去。”有人问：“如何是西来意，”“师便打，自余施设，皆被上机，中下之流莫窥涯涘。”在接化学人方面，他完全承接由马祖发端的喝、打等手段。上堂示众云：“汝等诸人，……尽是吃酒精汉，凭么行脚，取笑于人。但见八百一千人处便去，不可只图热闹也。”临济禅创立者义玄当年更衣游方，首参希运。《景传传灯录》中记载义玄在希运处得法的经过：
    初在黄檗，随众参侍。时堂中第一座勉令问话，师乃问：如何是祖师西来意？黄檗便打。如是三问，三遭打。在此机锋棒喝间，希运已将心法传与义玄，并预示义玄将来必为禅门领袖，云：”吾宗到汝，大兴于世。”又云：“子将但去，已后坐断天下人舌头在。”日后的义玄开创临济禅完全继承了希运的门风。《临济录》载：
    僧问：“如何是佛法大意？”师竖起拂子，僧便喝，师便打。又僧问：“如何是佛法大意？”师亦竖起拂子，僧便喝，师亦喝。僧拟议，师便打。
    真正是棒喝交施，义玄自述地说：“我在黄檗处，三度发问，三度被打。”临济宗卷舒擒纵、杀活自在的宗风是与希运分不开的。
    希运是由洪州禅向临济禅发展过度的关键人物，他承接了马祖道一的法统，据《仰山慧寂禅师语录》载，沩山曾问仰山云：“马祖出八十四人善知识，几人得大机，几人得大用？”仰山答曰：“百丈得大机，黄檗得大用，余者尽是唱导之师。”希运在中国禅宗史上的地位不仅在于他是洪州禅的继承者，更重要的是他的禅法直接影响了临济禅的形成，是临济法门的先驱者。《人天眼目》卷一载，日后义玄初至河北住院，便公开宣称：“我欲于此建立黄檗宗旨。”希运这一承前启后的历史影响奠定了他在禅学史上的地位，这也是我们将他放入临济宗体系中分析的原因。
    裴休曾师事希运多年，他在《传心法要》序中，曾对希运的禅法作过总结性的评价：
    独佩最上乘，离文字之印，惟传一心，更无别法，心体亦空，万缘俱寂。如大日轮升虚空中，光明照耀，净无纤埃。证之者无新旧、无浅深；说之者不立义解，不立宗主，不开户牖。直下便是，运念即乖，然后为本佛。故其言简，其理真，其道峻，其行孤。
    此可谓相濡以沫之论断。


二、义玄禅风

二、义玄禅风

    习禅于江南、弘法于河北、开一代禅风的义玄禅师，是众禅师中的翘楚。义玄（７８７－８６６）俗姓邢，曹州（今山东菏泽）的华人。约生于唐贞元三年）７８７），卒于唐咸通七年（８６６），谥称慧照禅师。《临济录》及《临济慧照禅师塔记》等记载，义玄落发受具后，曾无居讲肆，“精究毗尼，博赜经论”，对大小乘教法，均下过一番功夫，晚年，义玄曾向弟子讲述自己的证悟经验：“道流！出家而且要学道，只如山僧往日曾向毗尼中留心数十年，亦曾于经论寻讨后，方知是济世药表显之说。遂乃一时抛却，即访道参禅，后遇大善知识，方乃道眼分明，始识得天下老和尚，知其邪正，”由此可以看出，义玄确曾深入藏海，并于教门有深厚根基，所以他由教入禅、开悟证道以后，能够机辨纵横、拈来即是，博采众家之长，而长临济一家之风范。
    义玄上面所说的“大善知识”，首先是其开悟师黄檗希运和高安大愚禅师。
    希运远绍六祖“即心即佛”之旨，认为众生心体本寂，只因人们“举心动念，”乖离法体，而与道隔。若能够“息念忘虑，佛自现前，”由此，希运认为悟道实则为悟心，而悟心是一个直下顿了、不假修为的过程。故希运反对“向外求佛”，尤其是反对“广求知见”、“惟认见闻觉知”的主张和修持方法，在他看来，“今时人只欲得多知多解，广求文义，唤作修行。不知多知多解，翻成壅塞。”希运的这些思想，对义玄禅师产生了直接的影响。
      《禅济录》对义玄在黄檗处的开悟因缘有生动的描述，义玄在黄檗处三年，随众修习，行业统一，深得首座师的赞赏。首座一次问他：“曾参问也无？”义玄回答：“不曾参问，不知问个什么？”首座：“汝何不去问堂头和尚，如何是佛法大意？”义玄便去问，问声未绝，黄檗便打。义玄不明其意，回告首座，首座告之：“但更去问！”义玄又去问，黄檗又打。如此三度发问，三度被打，黄檗的施为，与其思想风格倒是一致的，他的棒打可称“断”棒，即通过这种看似没来由的棒击，截断义玄对“佛法大意”的思虑和追究，把他从向意识卜度处求佛的歧路上拉回。可惜，义玄根机未熟，未能当下醒悟，反自恨业障深重，欲辞别黄檗而远去。黄檗未挽留他，在他辞行时，嘱咐他到高安大愚禅师处。
    到大愚处，大愚知道他从黄檗处来，即问：“黄檗有何言句？”义玄：“我三度问佛法大意，三度被打，不知我有没有过错？”大愚云：“黄檗老婆心切，只为你能够大疑大悟，你反倒来问自己有过无过！”义玄言下大悟，云：“原来黄檗佛法无多子，”意谓黄檗禅师的教法并不玄奥。不料大愚并不首肯，拽住他问：“这尿床鬼子！适来道：‘有过无过？’如今却道：‘黄檗佛法无多子’，你见个什么道理？速道！速道！”义玄朝着大愚胁下不是三拳，大愚急忙推开他：“汝师黄檗，非干我事！”
    义玄初见大愚，还在经验思维里打转，并因三度被打，不解黄檗深旨，凭空增添一份烦恼，多生一重障碍。待大愚禅师明白指出，他纔醒悟到，黄檗禅师的棒打，并不是说他开问的问题本身有错，而是他问询本身就错了。问“如何是佛法大意”，说明他还没有走上“悟心”的正路，还期望在思维意识的层面，解决佛教的根本问题，大愚指点玄义，被打的理由不在“所问”，而在“问”本身。义玄这纔悟出，悟不在言，不在见闻知解。“佛法大意”是问不出，也答不出的。大愚为进一步勘验义玄，逼他讲出所悟的道理，义玄以胁下三拳，示意大愚，无道可思，无理可道。
    关于高安大愚禅师的资料很少，根据这则公案可推知，他是一位有道高僧，并很受当时禅林推重，其境界不在黄檗之下，但其禅风不似黄檗峻急猛烈，表现出循循善诱、超然大度的长者风范。义玄也在两位前辈的接引下，终于走出了知解葛藤，领略到禅的大机大用。后来沩山灵祐曾问仰山慧寂：“临济当时得大愚力？得黄檗力？”仰山云：“非但骑虎头，亦能把虎尾。”举要言之，黄檗当头三棒，断其妄执妄想，婆心急切；大愚胁受三拳，开其灵窍本心，诲导恩深。当初南泉普愿为首座时，曾私下告黄檗云：“此后生以后必成参天大树，为天下人作荫凉。”依义玄的资禀根机，如果他一直追随黄檗，亦可为一方化主，假以时日，日后成为江南禅林领袖亦未可知。但义玄没有留在南方，而是决意北上，在南禅传统薄弱之地弘化。临行，黄檗问：“什么处去？”义玄答云：“不是河南，便是河北，”黄檗唤侍者：“将百丈先师禅板、几案来！”义玄则云：“侍者将火来！”其实，以衣钵相传承的传法旧习到慧能已告中止，慧能南禅讲求以心传心，以心印心，既是以心印心，衣钵何用？衣钵既废，禅板、几案何用？何如付之一炬来得干净痛快。义玄此举，大有丹霞烧佛、南示杀猫之气魄。后来沩山问仰山：临济是否辜负了黄檗，仰山断然云：“不然”。黄檗于义玄有亲传亲授之恩，然知恩报恩，非泥著师法，以傅衣体为能事，而是要使众生开示悟入佛之知见。《楞伽经》云：“将此深心奉尘刹，是则名为报佛恩。”
    （一）无位真人
    义玄上堂云：“赤肉团上有一无位真人，常从汝等诸人面门出入，未证据者看看！”时有僧出问：“如何是无位真人？”师下禅床把住云：“道！道！”其僧拟议，师拖开云：“无位真人是什么？乾屎橛。”便归方丈。
    “真人”本是道家的称谓，指存养本性修成正果的人。这里义玄所讲的真人则是佛家的称谓，指与人的肉身相对称的人的法身和报化身。此无位真人就果位而言，指超越凡圣、迷悟、上下、贵贱等分别，而无所窒碍、自在解脱者，达此境界，即不堕于菩萨四十二位、五十二位等品位，故称无位真人，此真人就因位而言，则指人的“本心”，此本心湛然常寂，应变无方。义玄把它形容为心光：
    你一念心上清净光，是你屋里：“法身佛”；你一念心上无差别光，是你屋里“报身佛”；你一念心上无差别光，是你屋子里“化身佛，”
    此清净、无分别、无差别之心光，亦即清净法身，此法身佛性是诸佛之母、万法之本源，证得此清净法身，即与诸佛无别。
    义玄又云：
    道流！心法无形，通贯十方。在眼曰“见”，在耳曰“闻”，在鼻曰“嗅香”，在口“谈论”，在用“执捉”，在足“运奔。”
    也就是说此本心或法身并不离人的肉身、色身，而是与人的报身相即不离。在这个意义上无位真人又可理解为此“真人”无时不在、无处不在，没有固定方所和位置。
    因位的无位真人与果位的无位真人，在义玄看来是一体无别的，它们分别代表“本心”的体和作。用义玄的话说：“你一念心上清净光是你屋里‘法身佛’……”。众生若反观自照，明心见性，即有般若放光，修成法性身、果报身与应化身。
    此无位于真人常从人面门出入，但众生只为情生智隔，想变体殊，故日用而不知。如果能息心止念，此本心自然显露，无位真人自然作主。只是未有修行功夫和斩断一切烦恼魔障的定力，未足以扫除妄念浮云，正如那位学僧骤闻无位真人之名，即疑惑顿生，并欲从思维理路上去寻个究竟，其遭义玄一声断喝，亦是自然的了。
    （二）无依道人
    那种与“本心”佛性相冥符的境界是什么样的境界呢？义玄继承了黄檗希运之说，标出“无心”二字，无心在义玄这里意味着破除一切执著，随缘任运，不受任何外境的束缚与阻碍。义玄云：
    “夫如佛六通者不然。入色界不被色惑。入声界不被声惑，入香界不被香惑，入味界不被味惑，入触界不被触惑，入法界不被法惑。所以达六种色、声、香、味、触、法、皆是空相，不能凿缚。此无依道人，虽是五蕴漏质，便是地行神通。”
    三界惟心，万法惟识，一切违逆境界皆梦幻空华，无由把捉。如果能够观照五蕴皆空，诸法无相，即能以无分别心入一切境，应物现象，如水中月、不沾不滞，这种境界就是无依道人的境界。
    无依道人，本是道家推崇的得道者，这样的得道者，能够摆脱一切外在的束缚，任运消遥，甚至能够入火不烧、入水不溺，迥然独脱，不受物拘。义玄借用这一称谓来指称达到无心境界的禅者。进入这一境界。则能转得四大色身而不受色身质碍。不仅能够“入火不烧，入水不溺，”而且能够“入三途地狱如游园观，入饿鬼畜生而不受报。”如果能够做到随处作主，则一切凡圣境界皆是清净无染，参禅打坐亦得，着衣吃饭亦得，所以说：“夫如真实道人，并不取佛，不取菩萨罗汉，不取三界殊腾。”
    （三）辨佛辨魔
    真正的无依道人或无位真人，是见地、修行和行愿皆臻圆满之境者，惟佛总堪称真正道人，众生业障深重，忘失本性，故烦恼无尽，常沦六趣苦海。要从苦海脱身，必须走修证之途，从见地、修行和行愿三方面，精进不息。
    义玄特别强调有“真正见解”，所谓真正见解，即见诸法空相，皆无实法。义玄指出，要超脱生死，获自在解脱，必须识得本无一物，四大皆空，如此总能不被地、水、火、风所转，不被生、住、异、灭所逼。要证得世间法空，首先要破无明贪爱，而破无明贪爱，又要识取四种无相境。
    你一念心疑，被地来碍；你一念心爱，被水来溺；你一念心嗔，被火来烧；你一念心喜，被风来飘。
    如果辨得贪嗔痴爱，皆无明造作，地水火风，如梦幻泡影，即不被境转而能转境。
    修道人将财色名利等世间法看空较易，而要打破出世间法的罣碍则较难。许多人将佛、道、法视为心外人物，将凡圣判为二途，驰心妄求，以求成就。岂不知离心而求，愈求愈远。因为，“佛者，心清净是；法者，心光明是；道者，处处无碍净光是；三即一，皆是空名，而无实有。”
    为彻底破除学人对世出世法的执著，义玄在拈出毁佛毁祖的手段。
    道流！你若道佛是究竟，缘什么八十年后，向拘尸罗城双林树间侧卧而死去。佛今何在？明知与我生死不别。
    道流！莫将佛为究竟，我见犹如厕孔。菩萨、罗汉，尽是枷锁，缚人的物。
    十地诸心，犹如客作儿；等妙二觉，担枷锁汉；罗汉、辟支，犹如厕秽；菩提涅盘，如凿驴橛。
    不过义玄毁佛毁祖，只是破除学人对佛祖的妄认执著而施的方便，并非让人否认凡圣、佛魔的差别。“夫出家者，须辨得平常真正见解，辨佛、辨魔，辨真、辨伪、辨凡，辨圣。若如是解，得名真出家。”义玄的教法，决不同于后世禅宗末流的乱骂一气。
    （四）无修而修
    论及修行，义玄强调不修而修，所谓“不修”，是相对于传统的修习途径和修行方法而言的，因为心外无法，只须于心上认明即可，勿须向外驰求，而通常意义上的修证，则舍本逐末，于虚幻影子中误却一生，义玄云：
    你诸方齐道“有修有证”，莫错！设有修得者，皆是生死业。你言“万度万行齐修，”我见皆是造业。求佛求法，即是造地狱业。求菩萨亦是造业，看经看教亦是造业。
    慧能于《坛经》中云：“不识本心，求学无益。”将心识为用功的根本处。义玄进一步发挥了这一观点。通常人有修有证，皆为舍无明妄念，出离三界苦海。义玄直接指出，三界并不离众生心念。“你一念心贪着欲界，你一念心嗔是色界，你一念心痴是无色界。”所以出离三界并不是离心念而求诸法，而是息心歇会，回归本心，“你一念心歇得处，唤作‘菩提树’；你一念心不能歇得处，唤作‘无明树’。”“你若歇得，便是清净身界。”
    修行的起点是持戒，由戒生定，由定发慧，是佛教通常的修行次第，而戒分止持和作持，止持戒，　即诸晋莫作，佛教所禁绝的诸种恶行中，最不可宽宥的是五逆罪：杀父、杀母、出佛身血、破和合僧，焚烧经像。犯此五罪，下世要堕五间地狱而受业报，故此五逆罪又称五无间业。
    义玄为标明禅宗修行的特异处，出语惊人：“大德！造五无间业，方得解脱！”不过他对此五无间业做了新的解释。“无明是父，贪爱是母。”所谓杀父、杀母，即惟见诸法空相，处处无著，灭无明贪爱。所谓出佛身血，则指于清净法界不生染著。破和合僧，指破烦恼结使。而“焚烧经像”，则指证见因缘空、心空、法空，断除一切凿缚依傍。《维摩经》云：“若菩萨行于非道，是谓通达佛道。”所谓“非道，”指背离戒律。其实证道菩萨违背正道只是表相，其内在精神仍然与佛法相应。
    （五）四宾主
    义玄一向认为禅人的开悟，非由师悟，而是自性自度，自悟本心，所以当有人问：“师唱谁家曲，宗风嗣阿谁？”义玄只答：“我在黄檗处，三度发问，三度被打。”因为人人本心具足一切智慧功德，只为妄念遮蔽而沉沦无明。故禅师的作用，只在为众人解沾去缚，扫除一切精神的依傍和影像。“莫错！我且不取你解经解论，我亦不取你国王大臣，我亦不取你辨似悬沙，我亦不取你聪明智慧，惟要你真正见解。”在禅师面前。一切与本心无交涉的物象都是障道的根本，禅师的一切作略，都只是帮学人徒内外迷执中解脱出来，作一真正自由人。
    禅师范接引学人，最讲求心心相印、因缘相契。但常常是高明的禅师未必就一定碰上高明的学僧，反之亦是，根机好的学僧也未必能遇到道行高深的禅师。义玄具体分析了参禅得（宾）与接引者（主）之间复杂的情况：（１）宾看主，比如来参者随手拿起一个石子，大喝一声，意思是我有许多缚累，请师为我解脱。而居上座者不明其意，装模作样，解说一番，此是宾的见地胜过主，称为客看主。（２）主看宾，仍如上例，如果是有道禅师，并不主动置一辞，而是随学人问处即夺却。学人若被夺，若抓住不放，则称主看客。（３）主看主，指师生相互激发，相互解脱。如学人举出一清净境，善知识识得此境不可守，（４）宾看宾，同上例，如果学人着相着境而来，所谓的善知识不识其病，再用一番玄言玄语来搪塞支应，学人亦不能辨，带着虚幻的满足而去，称为宾看宾，义玄形容为一“披枷带锁”人来，禅师再中一重枷锁。
    义玄立四宾主，同样是警策深不可执守师法言教，他最鄙视于古人言句下求解脱，或于禅师机境下寻活路的学人。他苦口婆心开示众生，就是为了让众生回光返照，认取自家本来面目，不为一切外镜所转移，无奈众生总爱从宾处着眼，而难得于虚处踏脚，岂不知外境皆幻，内境亦不可守，若无观一切法空的见地在，则修静静不静，观空空亦不空。
    （六）四料简
    四料简，亦作“四料拣”，是临济又一重要门庭施设。“料”，谓度量；“简”简别。四料简，就是四种简别的方法，即按照学人不同“根器”和接受佛教教义的不同程度，所采取的不同教授方法。意在破除我、法二执。义玄禅师说：“我有时夺人不夺境，有时夺境不夺人，有时人境俱夺，有时人境俱不夺。”“夺人”指破除、摈弃“我执”。所谓“我执”，即是对“我”的执著。佛教以为，“我”只是因缘和合的假象，并无真性实体；世人执着于“我”，以为是有主宰的、实在的自体，便产生种种谬误和烦恼。“夺境”，指摈弃，剥夺“法执”。“法执”即对“法”的执著，“法”即一切事物和现象，佛教以为，“法”无自性，处于刹那生灭变化之中；世人执着于“法”，予以虚妄分别，从而妨碍真如的悟解和体验。“夺人不夺镜”，是针对我见重的人，破除对人我见的执着；“夺境不夺人”，是针对法执重的人，破除以法为实有的观点；“人镜俱夺”，是针对我执和法执都重的人，二者都须破；“人境俱不夺”，对于人我、法我均无执着的人，二者都不须破。
    （七）四照用
    义玄禅师示众云：“我有时先照后用，有时先用后照，有时照用同时，有时照用不同时，先照后用有人在；先用后照有法在；照用同时，驱耕夫之牛，夺饥人之食，敲骨取髓，痛下针锥；照用不同时，有问有答，立宾立主，合水和泥，应机接物。”所谓“照”，观照，指对客体的认识；“用”，功用，指对主体的认识，根据参禅者对主、客体的不同认识所采取的不同教授方法，总的在“破除”那种视主体和客体均为实在的世俗观点。“先照后用”，针对“法执”重者，先破除以客体为实有的观点；“先用后照”针对“我执”重者，先破除以主体为实有的观点，“照用同时”，针对我、法二执均重者，同时都破除；“照用不同时，”对于我法二执均已破除者，即可运用自若，应机接物。
    义玄禅师一整套接化学人的手段，因人而异，分别对待，这种“兵来将挡，水来土掩”的灵活方法，的确体现了“临济将军”的风度。此宗日后的法运流长，是与义玄禅师倡导的这一随缘自在、天机活泼的禅风分不开的。


三、延沼传承

三、延沼传承

    风穴延沼（８９６－９７３），俗姓刘，浙江余杭人。少年即怀出世之志，剃发受具膈，“游讲肆，玩《法华玄义》，修止观定慧，”可见面礼于教门义学下壹番功夫，但自觉大事未了，未能发明心地，遂各处参学，先谒越州镜清怤禅师，但机缘不契，复北游襄州至华严禅师处，结识南院慧颙的弟子守廓，于临济三玄三要之旨，有所契悟。在守廓鼓励下，又亲去参访南院，一见之下，机缘颇契。
    （延沼）问曰：“入门须辨主，端的请师分。”南院左拊其膝，风穴便喝；南院右拊其膝，风穴亦喝。南院曰：“左边一拍且止，右边一拍作么生？”风穴曰：“瞎。”南院反取拄杖，风穴笑曰：“盲枷瞎棒，倒夺打和尚去，”南院倚拄杖曰：“今日被黄面浙子纯置。”
    这段公案是南院勘验风穴对临济宗风的体认。风穴不管南院如何举措，总应之以喝，说明他识得“临济喝”的宗风。但临济喝，意在喝断学人的虚思妄想，截断学人的日常理路，从而反求诸事，于自家命根处去认取，故“喝”是手段，而非标的。南院的发问，实际上是一“陷井”，这一问题不是没答案，而是不能答，因为一涉理路去寻求答案，即辜负临济一喝的用心，走向临济禅的反面。故风穴答以“瞎”，意为未看到南院的举止，从而根本否定了南院的问题本身，南院作装发怒，欲再勘验其定力，岂料风穴不为所瞒，一番笑谈，使南院领略了其机辨纵横之风采。
    从此，风穴执弟子礼，“从容承禀，日闻智证”，依止六年，尽得临济玄要。后唐长兴二年（９３１）辞南院至汝州，复兴风穴旧寺，由于风穴道望隆盛，故“法席冠天下，学者自远而至。”宋开宝六年（９７３）八月圆寂，临终有偈曰：“首在乘时须济物，远方来慕自腾腾；他年有叟情相似，日日香烟夜夜灯。”表现出慈悲济世、化导天下的禅者情怀。
    临济义玄的嫡传弟子三圣、大觉未留下著述，传法弟子兴化存奖及再传弟子南院慧颙也少有语句传世，这使我们难见临济宗初传期思想嬗变的轨迹。但从南院传法风穴的机缘语句看，最初几世的传人是竭力维护临济宗风之纯正的。
    南院问风穴：“汝道四种料简语，料简何法？”风穴对曰：“凡语不滞凡情即堕圣解，学者大病，先圣哀之，为施方便，如楔出楔。”
    禅者忌讳以言谈禅，因为禅原本是超言绝相，需要行者亲自去体证的。但临济义玄确实又有“三句”、“三玄”、“三要”、“四宝主”、“四料简”的说法，该如何看待言词语句与禅的关系，如何看待临济祖师的“四料简”等语呢？这实际上还是南院对风穴禅学见地的勘验。风穴以“如楔出楔”来形容禅师的方便说法，十分恰当。因为一切机缘语句本身都无实义，如指月之指，惟藉言而明心，缘语而入道，言语总显出其真实的意义，恰如指非月，但可顺指而见月，待有所悟入之后，就不可耽著这些言词语句，贻误向上一途的精进。以风穴的说法。“设使言前荐得，犹为滞殼迷封；句下精通，未免触途狂见。”即使不落于凡情，也会堕入圣解，误入歧途，忘却本份。
  （南院）曰：“如何是夺人不夺境？”（风穴）曰：“新出红炉金弹子，床破阇梨铁面门。“又问：“如何是夺境不夺人？”曰：“蒭草乍分头脑裂，乱云初绽影犹存”又问：“如何是人境俱夺？”曰：“蹑足进前须急急，促鞭当鞅莫迟迟。”又问：“如何是人境俱不夺？”曰：“常忆江南三月里，鹧鸪啼处百花香。”
    临济四料简，前面我们已提到，它是临刘勘验接引学人的手段。要勘验学人，首先要求禅师别具只眼，明了学人修学所达到的境界。实际上四料简亦可以作境界会。“夺人不夺境”指已破本参，有所入处，悟得身心无非四大和合而成，无有实体，此即无我的境界；“夺境不夺人”，指踏初关后，不住光明澄彻境界，不于死水中做活计，力求百尺竿头，更进一步，再求个出处，此时须否定已证之境而存精进之意志——我；“人境俱夺”，此时禅功证德俱臻上乘，可以狮子举步；无所畏惧，龙象出没，天下横行，火里红莲，汤镬中行，色空无碍，得大自在，此种境界或称透重关，或称得个用处；“人境俱不夺”则功夫入于化境，无明执著自然消落，一切修为自然了办，家即途，照即用，体斯用斯，主斯宾斯，无一物非我身，无一物是我已，此即了处。
    风穴以诗作答，对四种境界的体证和描述颇中肯綮，的确非深入正定、大死大活之过来人不能言。“造破阇梨铁面门“所示破“我执”之艰难，“乱云初绽影犹存”所标光明境界中自主“我”这依稀，“促鞭当鞅莫迟迟”所指由体达用之急切，“鹧鸪啼处百花香”所显了无罣碍、自然透脱之平淡，皆大有过人处。南院感叹，“汝乘愿力，来荷大法，非偶然也。”
    为进一步勘验风穴，南院又举出临济祖师临终时的公案，据《临济录》载，临济临迁化，上堂云：“吾灭后，不得灭却吾正法眼藏！”三圣出云：“争敢灭却和尚正法眼藏！”临济云：“以后有人问你，问他道什么？”三圣便喝，临济云：“谁知吾正法眼藏，向这瞎驴边灭却！”禅是活法而死法，若泥守师法，于末端皮相处会取，甚或拿着鸡毛当令箭，虚张声势，欺瞒天下，只会灭却师法，败坏宗风，与宗门的旨全不相干。三圣之遭痛斥，在临济门下实属自然。南院举此公案问风穴：“渠（指临济）平生如狮子，见即杀人，及其将师，何故屈膝妥尾如此？”风穴对曰：“密付将终，全主即灭。”意即靠秘密付嘱来传禅法，预示着禅法将终止，而泥守师法不知机变，则意味着禅法的灭亡，风穴由此主张参学之人，直须临机大用，境遇现前，不必自拘于小节，扫却一切凡圣见解，只依自家本分纵言便可，如狮子一吼，壁立千仞，谁敢正眼觑见！
    从以上风穴的机缘语句看，其禅风直追临济义玄，全体大用，机辨无方，气势雄迈，独步一时。
    禅师接人讲究以心传心，师徒啐啄同时、灵犀相通，总得称因缘相契。故禅林访得具眼禅师不易，而禅师得一真正学人更难，黄檗感叹“有禅无师”，而更多的禅师则感叹求法者多如牛毛，而得道者稀如麟角，风穴上堂曰：“阇梨与老僧亦能悟却天弄虚作假，亦能瞎却天下人。欲识阇梨么？拊其左膝，曰这里是，欲识老僧么？拊其右膝，曰这里是。”亦是告诫徒众莫依他作解，妄生分别执著。只可惜“于时莫有善其机者，”圣贤寂寞，自古已然，只是奈临济宗风何？仰山慧寂说：“临济一宗，至风而止。”而止时首山省念禅师出，继宗传法，承风接响，临济气运，非大仰五言能定也。


四、省念承风接响

四、省念承风接响

    首山省念（９２６－９９３），俗姓狄，山东莱州人，少即出家，“为人简重，有情识，专修头陀行，诵《法华经》，丛林畏敬之，自以为念法华。”头陀，梵语dhuta之音译，去除尘垢烦恼意。头陀行，指为修炼身心，消除对世间的执著而自苦身心的种种艰苦之行。如避世独居、常行乞食、著弊衲衣、常坐不卧等等。欲得禅功证量，首先培养出离心，从凡尘俗爱纲中解脱出来。头陀行不特使省念道心坚固，而且一番磨练，培基固本，使其悟入宗乘、承绍宗统成为可能。而能古来流传最广的《法华经》的研习，更使其深入佛陀一乘法海，获得开悟所不可或缺的真实见地。不过六祖慧能曾云：“心迷《法华》转，心悟转《法华》，”，单纯诵《法华》，并不决定一个人必然有所悟入，心地未明，为《法华》所迷却也未可知，故省念之证量还有待勘验。
    《古尊宿语录》对风穴勘辨首山事记载颇详：
    一日风穴见师侍立次，乃垂涕告之曰：“不幸临济之道，互吾将坠于地矣！”师（首山）云：“观此一众，岂无人邪？”穴云：“虽敏者多，见性者少，”师云：“如某者如何？”穴云：“吾望子之久，犹恐耽著此经，不能放下，”师云：“此亦可事，愿闻其要。”
    于是风穴上堂时，拈举释尊灵山会上拈花微笑一案让首山参，“世尊以青莲目顾视大众，迦叶正当与么时，且道说个什么？”结果首山一言未发，拂袖退堂而去。风穴赞叹道：“念法华（首山）会也！”
    当时有可能传风穴法者还有真上座，在勘验首山次日，风穴又向真上座举同一公案，并问：“作么生是世尊不说说？”即如何理解世尊不说而说呢，真上座答：“鹁鸠树头鸣。”风穴又问首山：“汝作么生？”首山答：“动容扬古路，不堕悄然机。”结果首山得风们印可。真上座的回答看似对题，实则仍于音声处荐取，未若首山于“动容”处着眼，于唇吻处会，可能只闻声而忘心，于形色处会，总有迦叶会心一笑。
    省念得风穴印可后，泯迹韬光，起初并不为人所知，后与游方僧楚和尚一声机辨，始名振四方。“远近学者承风而凑”，省念初住首山，后住宝安山广教禅院，晚年终老于宝应禅院。据载禅师能预知来事，于一年前即说出自己迁化时日。临终有偈曰：“白银世界金色身，情与无情共一真。明暗尽时俱不照，日轮午后是全身。”
    首山是临济嫡传，护持临济家法无疑是其分内之事。但临济家风亦有其精髓、骨胳、皮相、只有传其精髓，总能使临济正宗发扬光大。如果只是袭得其皮相，正不知误却天下多少人，遑论续法传灯。有僧问：“师唱谁家曲？宗风嗣阿谁？”师云：“少到崖前亲掌示。”我传的是祖祖相传的心法！若识得此心，则可与迦叶师兄分座，灵山一会，俨然未散；若不识此心，纵重生佛前，一样堕坑落堑。
    德山棒、临济喝、丛林皆知临济于黄檗会下三顿棒打而开悟，因动辄断喝而驰名天下。但如何理解临济棒喝的真实意旨呢？棒、喝本身并不是禅，它们只是外在的形式，只有当真实的禅的精神意蕴“灌注”其间，它们总不是僵硬的形式，而成为活泼的禅的精神的表现形式，这时候“喝”总不是盲乱喝，而是有明确的指向怀，如临济所说：“有时一喝如金刚王宝剑，有时一喝如踞地金毛狮子，有时一喝如探竿影草，有时一喝不作一喝用。”如果不明就里，而去盲目模仿，把师家接引学人的方便，视作禅的精髓，则狮子啸天，翻成野犬吠影矣。
    僧云：“忽遇狮子吼时如何？”师云：“一任野干鸣。”僧便喝，师云：“果然”，僧又喝，师云：“放你三十棒，”僧礼拜，师云：“这瞎汉。”
    （首山）复云：“诸上座，不得妄喝乱喝，这里寻常问你道，宾则始终宾，主则始终主，宾无二宾，主无二主，若有二宾二主，即是两个瞎汉。”
是说居于主位的师家与居于宾位的学人，都要时刻意识到自己的定位，主就是主，宾就是宾，主说主话，宾说宾话，不可淆乱。若主宾位颠倒错乱，就说明瞎徒碰上盲师，永无开悟之日。这是针对当时丛林流弊有感而发的。许多学人拾得先师唾涕，就以具眼禅师自居，行棒行喝，时出惊人之言，看似通透，实则全无真实的意蕴。
    首山复云：“诸上座，佛法无多子，只是你诸人自信不及。若也自信得去，千圣出头，来你面前，亦无下口处。”自信，即深信我心即佛，本自具足，无有欠缺，深信自性自度，不假外求。如果自信得及，不向外驰求，而惟以了办本分事为务，则即使释迦现前，也可与他三十棒！
    首山奉劝学人切实用功，真参实悟，不可于机缘语句中炫奇门胜。其《送某化主颂》云：“廓然无事少人闻，任意纵横勿计程。步步登高看前路，莫教失脚堕深坑。”让人于向上一途勇猛精进，莫错用功。其《偶作三颂》也表达出同样的旨趣：
    我有一机，不假修持。若人问著，便唤沙弥。
    我有一著，不自栖泊。若人更问，劈口便著。
    我有一宗，勿示西东，若人拟议，别唤王公。
    其第一机，相当于临济的“第一句”，超言绝相，不假修持，实际上指真如之体用。此真如之体，惟证乃知，不容拟议，不涉言句。真若有人问起，正说明其功行未充，所以唤作沙弥可也。僧问：“如何是真如体？”师云：“遍乾坤”，即此真如是无限的、绝对的、超时空的存在，而人类的思维则是有限的、相对的。以有限逐无限，自有根本障碍。其第二著，相当于临济“第二句”，物外纵横，不自栖泊，相当于真如之相，此亦不可落唇吻，开口便错，有言即易著相，失其本来。其第三宗，相当于临济“第三句”，方便善巧，随机说法，以有言示无言，相当于真如之用。此用是全体大用，非识得心体，洞明心地者不能发。故此宗之种种言句、种种作为，皆师法而非禅法，于此得启悟可，视其为根本则不可。故首山宁愿将禅师的机锋作略，皆视为一声败关、一堆无义味语。问：“德山棒、临济喝，未审明得什么边事？”师云：“你试道看”，僧便喝。师云：“瞎”，僧又喝。师云：“这瞎汉，只管乱喝作什么！”对临济喝，首山让学人多于“一喝不作一喝用”处会取，莫辜负临济一片苦心。还有僧问：“灵丹一粒。点铁成金。至理一言，转凡成圣，如何是至理一言？”师云：“更举一遍。”僧云：“当么则退身三步。”师云：“笑破大众口。”首山是不承认有这样的“至理一言”的。
    值得注意的是，首山以代别的形式来表达自己的禅学见地，开临济宗新的接人风格。其实这种就同一问题，在前人已有回答之后，再虽出心裁的人出新的回答的方式。在首山之前已很流行。如“如何是佛？”、“如何是祖师西来意？”、“万法归一、一归何处？”等等，都是学人屡屡问起的问题。而“庭前柏树子”（赵州），“佛是幻化身，祖是老比丘”（临济）等回答更是人皆共知。首山的代别，是就前人的公案，再加引申发挥，以发明公案未尽之意。“代别”是“代语”和“别语”的合称。所谓代语，指前人所答不合意旨，代答一语；而别语，是指公案中原有答语，作者另加一句别有含义的话。如对临济四宾主句，风穴皆有回答。而首山则再出别语。
    僧云：“如何是宾中宾？”穴云：“攒眉看白云。”师别云：“去来长自在，不与白云齐。”问：“如何是宾中主？”穴云：“入市双瞳瞽，”师别云：“高声唱绕街行。”问：“如何是主中宾？”穴云：“回銮两耀断。”师别云：“定国安邦贺太平。”问：“如何是主中主？”穴云：“磨砻三尺剑，待斩不平人。”师别云：“收番猛将，雨草不留。”
    另外，对临济“四用”、“四料简”及“云门三句”也各有别语。这些别语的出现是必然的，主要原因不在于前人的回答尚有发挥的确良余地，而在于禅师接引学人的问答，其生命力就在于回答的新奇独特。学人所问不外乎那么几类，如果重复前人的回答，不能给学人以新的刺激，就难以起到机锋转语惊醒学人的功用。至于这些代别是否比原有的答话更为对题，要具体分析，发明心地，示露本分者固然有之，而炫奇门胜，口头滑利者亦不在少数。如上引首山对四宾主的回答，据临济的回答观之，皆不高明，其“去来长自在，不与白云齐”对“主中主”似更恰当，而“收番猛将，寸草不留”又似乎是描摹“宾中主”的情景。
    便无论如何，“代别”之作为一种文体，对后世有不小的影响，在临刘宗内部，首山开风气之先，后世临济宗人纷纷起而效尤。其弟子汾阳善昭更是将“代别”作为阐发其禅思、禅风的主要方式，从而使这种文体更趋成熟和完备。而在文苑，明清特别盛行的批点，一经批点，让古人著作代自己立言，即变“我注六经”为“六经注我”，实际上就是这种代别的发展。


五、汾阳善昭

五、汾阳善昭

    汾阳善昭（９４７－１０２４），山西太原人，俗姓俞，史载“剃发受具，杖策游方，所至少留，随机叩发，历参知识七十一员。”古来大德为求开悟，不惮艰辛、剋期求证的精神，适足为学人典范，后到首山道场，参“百丈卷席”案而开悟。
    问：“百丈卷席”意旨如何？山曰：“长袖拂开全体现。”曰：“师意如何？”山曰：“象王行处绝狐踪。”师（汾阳）言下丈悟。拜起而曰：“万古碧潭空界月，再三捞洒始应知。”
    “百丈卷席”分案是讲，百丈禅师在马祖会下为侍者时的一则公案。一日马祖升堂纔坐，百丈出来卷却席，马祖便下座。百丈随马祖回方丈，马祖问：“适来要举转因缘，你为什么卷却簟（竹席）？”师曰：“为某甲鼻头痛。”百丈末后一句又牵涉百丈“野鸭子”公案，在百丈卷席的前一日，百丈随马祖行走，见一野鸭子飞过，马祖问鸭子的声音哪儿去了，百丈回答飞过去了，马祖回头就拧百丈的鼻头。“野鸭子”公案，可以理解为不可随声逐响，于色声处荐取。而百丈卷席，说明他已悟此理，以“卷席”这一看似唐突无礼之举，告诉马祖不必多言。再引申一步，则“法无有比、无可喻，故法身无为，不堕诸数，故云圣体无名，不可说，如实理空门难凑喻。”（百丈语）
    对百丈与马祖的一则公案，首山以“长袖拂开全体现”来喻示百丈对真如法身的理解；以“象王行处绝狐踪”表达自己对百丈祖师境界超迈的赞叹，实在是很恰当的，善昭言下大悟，悟不在言，不过是他经艰苦修证，机缘成熟，经首山点化而心地洞明而已。正如古潭明月，虽人皆知其是空华幻影，但只有去再三捞摝而不可把捉，纔确知为空一样，学人也惟有真参实证，于行履处亲证，纔能达至空体，善昭“万古碧潭空界月，再三捞摝始应知，”是从实际理地中发出的真正禅语，当时会下有僧问：“昭兄你适来见个什么道理，便与么道？”善昭云：“正是我放身舍命处。”即在空门中找到安身立命处。
    善昭于首山会下开悟后，继续在湖南、湖北、河南等地行脚参学。随着其道望愈来愈高，各地郡守竞相邀其住持名刹大寺。善昭皆坚辞不就。首山迁化。其弟子契聪受众人之托。前来迎请善昭。史载，契聪到善昭住处，善昭正在闭门大睡，契聪破门而入，曰：“佛法大事，靖退小节。风穴惧应谦，忧宗旨坠天。幸而有先师，先师已弃世。汝有力荷担如来大法者，今何时？而欲安眠哉？”契聪一翻慷慨激昂的话，使善昭意识到自己担荷如来大法的责任，放弃了隐遁山林、惟求自了的心态，前往主持汾州太平寺法席，善昭高超出世，三十年迹不涉俗，足不越阃，道俗皆尊称“汾阳禅师。”
    善昭的禅学见地及接人的风格，集中体现在以下上堂证录中：
    夫参学者，须具本分眼目，临机别取邪正，不受人谩，不被佛祖所滞，不随言语所转，不被诸法所惑，不依一切神妙解会，凡有来者，尽皆勘破。何故？伊倚会解，展弄机锋，求觅知见，问佛问祖，向上向下，自意祖意，皆可打伊，直饶一切不依。恰好点罚；万水千山，恰好吃棒，到凭么时，是个汉始得。
    汾阳上述见解，是与临济、首山强调“自信”、不依他解的主张一派相承的。有僧问：“心地未安时如何？”师曰：“谁乱尔？”僧曰：“争奈这个何？”师云：“自作自受”！参禅修道是大丈夫事，明心见性，须有大担当，躬行实践，以悟为期，蓦直参去，纔会有自己做得主之时。至于具体的参学步骤和手段。也须通过游方遍参，从万千法门中，找到适合自己根机的修学之路。有问：“如何是学人著力处？”师云：“嘉州打大象。”问：“如何是学人转身处？”师云：“陕府灌铁牛。”问：“如何是学人亲切处？”师云：“河西弄狮子。”汾阳的回答皆属义味语，或者说它们都只具有否定的意义。因为学人参学之入处出处，皆在行处而不在拟经转语处，即使为他解释得头头是道，学人功力未充，仍不能真正找到著力处、转身处、亲切处。如果接引不得法，还会使学人依藤附木，转求转迷。
    汾阳还拈出临济“三玄三要”句要大众来参。“先圣云一句语须具三玄门，一玄门须具三要，阿那个是三玄三要底句？”对此汾阳为学人分别作颂偈：
    第一玄，法界广无边，森罗及万象，总在镜中圆；第二玄，释尊问阿难，多闻随事答，应器量方圆；第三玄，直出古皇前，四句百非外，闾氏问丰干。
    “闾氏问丰干”是一禅林典故。丰干，唐代国清寺与寒山、拾得齐名的奇僧，前行化于京兆（长安），为太守闾丘胤治病。闾氏受丰干指引，前往天台山访求寒山、拾得。其时寒山、拾得正围炉谈笑，闾氏处诚致拜，二人连声咄叱，寒山复执闾氏手笑而言曰：“丰干饶舌！”从此丛林遂有“丰干饶舌”之趣谈。汾阳的偈颂表述了他对三玄的理解，第一玄指法界之本质、万物之同根处；第二玄指应机之问答；第三玄指无明确指向之无义味语。一句具三玄，即禅师一言，可以同时有三重信息，或直指心体，让人命根立断，悟却万法一如之理；或就近取譬，随机化导，以有言悟无言；或一言不作一言用，虽有言而实无言，不入四句不涉百非，只为截断众流，逆行反本，让学人于“不历僧只劫，直出古皇前”会取。
    一句具三玄，是说这三重信息涵摄于同一句话中，学人根机不同，主酬机对答的时节因缘不同，同一句话呈现出不同的意义，师举三玄语曰：“汝还会三玄应时节么？直须会取古人意旨，然后自心明去，更得通变自在，受用无穷，唤作自受用身佛。不从他教，便识得自家活计。”三玄可以做话头参，不可做道理会，它只是接引学人入门之具，而非禅机悟境本身，要得禅功证量，须透过三玄三要，“自心明去”，也就是说，明心见性的功夫，还得从实际行履中出，而不能从玄妙语句中求。故汾阳有颂曰：
    三玄三要事难分，得意忘言道易亲；一切明明该万象，重阳九日菊花新。
    自临济首举三玄三要，人们百般索解，聚讼纷纭。汾阳此颂可以说是结论性断语。汾阳的意思是说，三玄三要具体指谓的是什么，难以清楚地判定，关键是悟解它们蕴含的意旨，其意旨随时节因缘之不同而各异，所以说：“一句明明该万象，”“重阳九日菊花新，”则喻指时节因缘成熟，自有证量，自有境界。
    汾阳又举风穴“老僧与阇黎”公案，“且问诸上座，老僧与阇黎是同是别？若道是同去，上座自上座，老僧自老僧；若道是别去，又道老僧即是阇黎若能于此明得去，一句中有三玄三要，宾主历然，平生事办，参寻事毕。”老僧与阇黎同处，在于心体，此心在凡不灭，在圣不僧，一切众生圆满具足，无有欠缺，老僧与阇黎异处，在于根机与修行，从生虽同具本心，但因业障烦恼而黯昧不明，正如“明月当空，只为浮云遮障，不得显现。”老僧之卓异处，在于愿力宏大、见地超逸、如法修行，故其心如朗月当空，辉耀乾坤；万具缚凡夫则不能拨云见月，洞明心体。如明乎此，则能于禅师一句悟得三玄，亦能理解主之所以为主，宾之所以为宾。永嘉禅师云：“粉身碎骨未足酬，一句了然超百亿。”真正透得一句三玄，自然佛法现前，擒纵自在，自利利他。
    那么除了发挥临济三玄三要旨趣外，汾阳有没有他自己独特的禅法呢？汾阳上堂语有云：“汾阳门下有西河狮子，当门踞坐，但有来者，即便咬杀。有何方便入得汾阳门，见得汾阳人？若见汾阳人者，堪与祖佛为师，不见汾阳人，尽是立地死汉。”意思是说，汾阳继承禅风，行棒行喝，凌厉峻烈，如踞门狮子，见即扑杀。如果不是禅门老参，是难入汾阳门，窥见汾阳禅法的。
    汾阳也曾从正面表达自己接引学人的风格。
    僧问：“如何是接初机的句？”师曰：“汝是行脚僧。”曰：“如何是辨衲僧的句？”师曰：“西方日出卯，”曰：“如何是正令行的句？”师曰：“千里持来呈旧面。”曰：“如何是立乾坤的句？”师曰：“北俱卢州长粳米，食者无贪亦无嗔。”乃曰：“将此四转语验天下衲僧，纔见你出来验得了也。”
    以上称“汾阳四句”，在丛林中十分著名。其接引初机句，皆平淡无奇，并不拨弄特殊之机法，如赵州之“吃茶去”一般，让人于日常行止中起修，亦以此勘验学人是否得个入处。“勘验衲僧句”，则是出人意表、不落俗套之机锋转语，如“西方日出”、“掘地觅青天”等，汾阳以这些超出常见之语句，辨别衲僧之证量与境界，亦以此勘验学人是否从思量分别的日常思维理路中解脱出来，即是否得个出处。正令行句，正令，指佛法，于禅林特指不立文字、教外别传之禅门宗旨；行，指通行无碍。有大根器，悟得祖师大机大用之人，当能行化四方，将此佛法要旨传布天下，禅师以此勘验学人是否得个用处。立乾坤句，是勘验学人是否得个了处。习禅不是为逃世，也不是为自了，自己得受用，还应让天下人皆得受用；自己了脱生死，也应让众生皆从生死苦海中解脱出来，只有如此，纔能清除世间的贪嗔痴等烦恼，众生的朗朗心月，纔能禅耀乾坤。
    禅师的功行，不仅在于勘辨学人的根机与境界，还在于随机施教，方便接引。不立一切法，一切法皆可为接引学人之道具。汾阳亦有接引学人所设立之三种机法，此即“汾阳三诀”：
    上堂：汾阳有三诀，衲僧难辨别，更拟问如何，拄杖蓦头楔。有僧问：“如何是三法？”师便打，僧礼拜。师曰：“为汝一时领出，第一诀，接引无时节，巧语不能诠，云绽青天月；第二诀，舒光辨贤哲，问答利生心，拔却眼中楔；第三诀，西国胡人说，济水过新罗，北地用邠铁。”
    三诀不是固定的三句话，而是指接引学人的三种方式和风格。第一诀是就近取譬，不计时节，是当下之境物来指示一片新天地。正如赵州之“庭前柏树子”，“云绽青天月”也只是以境示人，不加别语。初学者闻此类禅语，能断其言下荐取之歧路，而有入处的禅客，亦能不住悟境，向上进取，以达万物一体，天地一如之至境，第二诀则是根据学人之根机，有问有答，为学人解粘去缚，抽钉拨楔，这是禅林中最流行的形式；第三诀是对已悟之禅客，不拘常则，不守死法，杀活自在，不离本分。不这种情境下，或有言或无言，或直语或韵语，或竖拂或棒喝，语默动静莫不是禅，其说也，如滔滔大江，一泻千里，其默也，如邠铁制刀，自在而方便。
    三诀不过是汾阳对自己接引学人诸种方式的概括，其间也并无深奥秘义可言，所以他不让学人于此思维辨别，以免再生出一番葛藤来。后世慈明，法昌遇、东山简等，对汾阳三诀皆有偈颂，但皆不出“六月满天雪”、“万里一条铁”等似通非通落草之淡的窠臼。
    汾阳三诀主要是从禅师勘辨接引学人的角度而立的，禅机体现在师徒主客的问答之间，作为师家的主方有“三诀”，作为学人的客方又有什么问禅习禅的“客诀”呢？汾阳总结了前代祖师与学人弟子请问酬答的方式，归结出学人通常向师家提出问题的十八种方式，此即“汾阳十八问”：请益、呈解、察辨、投机、偏僻、心行、控拔、不会、擎担、置、故问、借、实、假、审、徵、明、默。请益，指学人向师家直接请求指导之问法，如“如何是祖师西来意？”等；呈解，指学人呈示自己之见解而请求师家，但在禅宗语录中，我们见得更多的是一些提撕之问法，如“天下能盖、地不能载时如何？”等；察辨，指学人直接提出自己的疑问而请师家勘辨，如“学人有一问在和尚处时如何？”等。这些问法在禅林中最常见，也是初入禅门的学人最爱采用的提问方式。
    但一些有证量的学人则不满足于这些平淡的问法，总要炫奇门胜，以种种不寻常的设问来显示自己的悟境，并勘验师家见地之浅深。如投机，即学人将自己的悟境照实提出请师提示；偏僻，则指学人以偏于一端之见解呈示师家，如有僧问芭蕉：“尽大地是个眼睛，乞师指示”等。又如徵问，即学人以诘难态度提出问题，明问，即学人已明了一事，复举问他事。最后还有默问，学人默不作声，惟以举止动作表达自己的疑问。所有这些“不合常规”之问，具眼禅师皆能一眼觑破，不为所瞒。而未达本分理地者则可能如坠毁五里雾中，不得头绪，这在禅林看“主中宾”。
    依临济四宾主的分析，师家与学人的机缘问答，有着复杂的背景。而因缘契合、心心相印则是宗门中入向往和追求的境界。当然，要达到这种境界，师家与学人皆须作出努力，宗门比喻为啐啄同时，像雏鸡要破壳而出，母鸡与壳内雏鸡在蛋壳上同时用力一样。汾阳从说法者的角度，提出师家要勘辨接引学人所应具备的十种智慧，其间也包含了对学人各方面素质的要求，此即“十智同真。”
    对“十智同真”，汾阳和后世禅师皆有评唱，但多属断语、无义味语，不过细加索解，亦可窥见其真实意蕴。一、同一质，指师家用与学人融为一体，且各尽本分。“桑树猪揩背，长江鸭洗背。”即喻指此意；二、同大事，指师家与学人皆对佛法大事、宗门的旨有深切体认，惟如此，纔能“一身坚密现诸尘，寂灭光中无渐次。”三、总同参，指师家有纳须弥于芥子的道力，能够驱使万物，拈来即是，令森罗万象皆归依佛法。汾阳云：“万象森罗齐稽首”即此意。四、同真智，即师家具有出世间之真实智慧。古德云：“何人同此一真智，见得分明还不是”，即出世真智不同于俗世的见识和智慧，而是圆融无碍的大智慧。汾阳云：“毛吞遍变，即师家识得佛性与华严宗“巨细互容无碍门”相通。五、同遍普，即师家识得佛性无处不在，翠竹法身黄花般若，禾山解打鼓，无情可说法。古德云：“是什么物同遍普，旷大劫来今日睹。一波纔动万波随，何异婴儿得慈母。”六，同具足，指师家体得人人本具之佛性，古德云：“阿那个是同具足，细草含烟满山绿，它乡看似故乡看，添得篱根花绕屋。”七、同得失，师家为学人解粘去缚而皆得解脱，丢弃无明烦恼，证得清净本性。八、同生杀，禅门常讲杀活自在，但这要求师家有与学人同生死的悲愿，有拯人沦溺、出度苦海的无上道力，古德云：“作么生兮同生杀，桃花红兮李花白。今年吞却大还丹，到处相逢李八伯。”先有起死回生的“大还丹”，纔可放言同生死。九、同音吼，师家与学人皆有证量，开口即为狮子吼，横说坚说，不离本分。十、同得入，经住复问答，师家与学人同入胜境，泯除一切分别对待，悉皆成佛。
    古德对“十智同真”有颂曰：“由来十智本同真，语直心精妙入神。长忆江南三月里，春风微动水生鳞。”师家与学人同具如来德相，本来就应该十智同具，相师相长，惟有先入后入之别，纔有一请益、一接引，纔有主宾之分，双方右能精神气息，潜通一脉，则灵犀一点，疑结全消，恰如“春风微动水生鳞”的境界，此时皆做得自家主宰，已没有主宾之分。
    汾阳在禅宗史的贡献，还在于首创“诘问”和“颂古”的方式，来解说公案，接引学人。
    如前所述，首山以“代别”方式，来阐发前人公案的未尽之意，“代别”遂在禅林流行开来。汾阳曾作《公案代别百则》和《诘问百则》，对他选取的古人公案。给出自己的解说。关于公案代别，汾阳指出：
    室中请益，古人公案未尽善者，请以代之；语不格者，请以别之，故目之为代别。
    “未尽善者”和“语不格者”的意思相同，都是指公案的语意未尽，需要给以“代语”或“别语”，作进一步的阐发和引申，也可以说是对公案的修自性解释，而“诘问”，则是对历史上一些著名禅语提出问题，并代以作答，实际也是“代别”的一种形式，如其《诘问百则》中有一则为“四弘誓愿”：
    众生无边誓愿度，谁是度者？代云：车轮往灵山。法门法边誓愿学，作么生学？代云：朝参暮请，烦恼无边誓愿断，将什么断？代云：有么？无上菩提誓愿成，作么生成？代云：天子不刘草。
    “四弘誓愿”是一切佛教徒所应发之“通愿”，其意义明明白白，无须百般索解，汾阳的诘问，其实是自问自答，借题发挥，把佛教中最常见的语句作禅宗的改造，以阐述自己的思想观念。其第一番问答，不过是讲除修者自己以外没有度者，自性自度，自家事自己了。第二番问答，则平白直叙，别无他解，第三番问答，则以反问的口气表达对问题本身的否定。修禅达到极境。则无烦恼可断，亦无菩提可成，修而不修，不修而修。第四番问答，听来玄妙，实则暗喻“无上菩提”无须劳作生成。原本浅显的道理，经过这番玄化处理，反让人摸不着头绪，尤其是初学者，更会如堕雾中，汾阳本人似乎也不把此看得很重，他曾说：“诘问一百则，从头道理全。古今如目睹，有口不能适。”禅宗讲求观根逗机，应病予药，经过适用一切时一切人的禅话。汾阳对古来公案的解析，不说是游戏文字，也只代表一家之言。
    汾阳又作《颂古百则》，选择百则公案，分别以韵文加以阐释，他在其后作《都颂》曰：“先贤一百则，天下录来传。难知与易会，汾阳颂皎然。空花结空果，非后亦非先。普告诸大士，同明第一玄。”意思是说，这百则公案皆古德先贤传下来的典型范例，在各家语录中屡屡出现，代表了各家宗风。这些公案有的晦涩难懂，有的易于理解，而这些颂古之作，则是为了使其清楚明白，使天下学人皆能从中悟得禅理。如“三玄三要”颂曰：
    第一玄，照用一时全，七星光灿烂，万里绝尘烟。第二玄，钩锥利便尖，拟议穿腮过，裂面倚双肩。第三玄，妙用具方圆，随机明事理，万法体中全。第一要，根境俱忘绝朕兆，山崩海竭洒飘尘，荡尽寒灰始得妙。第二要，钩锥察辨呈巧妙，纵去夺来掣电机，透匣七星光晃耀。第三要，不用垂钩并不钓，临机一曲楚歌声，闻者尽然来反照。
    与善昭“颂古”文体同时，还有一种“拈古”流行，不过与“颂古”之采用韵文体不同，“拈古”采用散文体。圆悟所著《碧岩录》则认为：“大凡颂古，只是绕路说禅；拈古大纲，据款结案而已。”据此，颂古与拈古相比，前者不是把前圣的意旨直接叙述出来，而是用隐喻的手法曲折地表达出来。汾阳对“三玄三要”的“颂古”很符合圆悟的界实。其实三玄说直白些，分别指师家对空、有、真空妙有的体证，而三要分别指师家的证境及对学人的勘辨、接引。但这些含义都隐含在具体的形象和美妙的语句中，从字面上去理解，是把握不住其意旨的。
    由于颂古的形式在语言风格上追求缥渺玄远、意蕴含蓄，与士大夫阶层作诗为文时的追求契合，所以这种评禅方式得到士大夫的特别喜爱，在宋以后的禅林内外变得非常流行。


六、石霜楚圆

六、石霜楚圆

    石霜楚圆（９８７－１０４０），法号慈明，全州（今属广西）人。俗姓李，年二十二于湘山隐静寺出家。后四处参访，慕汾阳道望，前往参谒。据说汾阳一见之下，即识其大器利根，但并没有当下与其开示，相反有二年时间都冷淡待之。史载“每见必骂垢，或诋毁诸方，及有所训，皆流俗鄙事。”一日慈明又见汾阳，很委曲地说：“自至法席，已再夏，不蒙指示，但增世俗尘劳念。岁月飘忽，已事不明，失出家之利。……”话未说完，即遭汾阳喝骂。汾阳且“怒举杖逐之。”慈明欲开口呼救，汾阳急掩其口，慈明豁然开悟，叹曰：“是知临济道出常情。”汾阳巧妙利用“不愤不启”的接引原则，磨炼其性情，考验器量，待机缘成熟，痛下针锥，使其憣然而悟。对非常人，施以非常手段，这正是汾阳的高明之处。
    慈明到底在汾阳处悟个什么呢？不过是“依法不依人，依义不依语”而已！但在义理上明白这一道理，与通过实际的修证及禅师的点化而得到的深切感悟是不同的。而且一悟之后并非一了百了，而是悟后起修，再加砥砺，功夫总会纯熟，故慈明又在汾阳会下苦修七年，之后又参唐明智嵩禅师、神鼎洪湮禅师、谷隐蕴聪禅师，晚年先后住持袁州南源山广利禅院、潭州道吾山、石霜山崇胜禅院、南岳福严禅院、潭州光化禅院。康定庚辰（１０４０）示寂，葬于石霜山。
    （一）如来禅，祖师禅
    习禅者最忌对义理名相、机缘语句的泥著沾缚。慈明开示学人，不落窠臼，别开生面，颇有临济大机大用之风范，如临济有“三句”说：“第一句荐得，堪与祖佛为师；第二句荐得，堪与人天为师；第三句荐得，自救不了。”这三句在丛林十分流行，且诸方尊宿多有拈颂，各有发明，慈明在上堂法语中则别出机杼，反其意而用之。“第一句荐得，和泥合水；第二句荐得，无绳自缚；第三句荐得，四棱着地。”临济三句之说，是指引学人于无言句处荐取，以反本返源、顿悟自心。如果不明的旨，而到第一句、第二句中去百般索解，则必然是和泥合水、无绳自缚。
    不过，慈明的“反案”文章最引人注目的是对“香严击竹”公案的评点。
    香严智闲为沩山灵祐弟子，在沩山会上勤学苦修，一日灵祐谓之曰：“吾不问汝平生学解及经卷册子上记得者，汝未出胞胎未辨东西时，本分事试道一句来！吾要记汝。”香严进数语，皆未蒙许可，复归禅堂遍检所集诸方语句，然无一言可将酬对，于是尽焚所存，泣辞沩山而去。在南阳已故慧忠国师处，一日于山中芟除草木，以瓦砾击竹作声，廓然省悟，香严到底悟到了什么呢？他本人没有说。但联系灵祐所问，他无疑于“本分事”有所悟入。而识得本分，证得本心，正是慧能以来祖师相传之心印，丛林也一向视香严为得法禅师，故香严所证祖师禅当无疑问。
    但慈明则别有说法：
    示众，以拄杖击禅林一下云：大众还会么？不见道，一击忘所知，更不假修持。诸方达道者，咸言上上机，香严凭么悟去，分明悟得如来禅，祖师禅未梦见在。
    如来禅与祖师禅的区分，或始于仰山慧寂。《景德传灯录》载仰山开示语有，“师曰：‘汝只有如来禅，未得祖师禅。’”其实宗密在《禅源诸诠集都序》中，已有如来禅和祖师禅的思想。宗密将禅由浅至深，分为五等，即外道禅、凡夫禅、小乘禅、大乘禅、最上乘禅等。其中最上乘禅则为神会所承之慧能禅，即如来禅（此名似初见《楞伽经》，如曰此经所谓最上乘禅）。宗密对此宗概括曰：
    知之一字，众妙之门，由无始迷之，故忘执身心为我，起贪嗔等念。若得善友开示，顿悟空寂之知。知且无念无形，谁为我相人相？觉诸相空，心自无念。念起即觉，觉之即无，修行妙门，惟在此也。
此处之“知”是空寂之知，宗密在说荷泽神会之禅时称为“寂知指体，无念为宗”。“寂知指体”，是说此能照之知，即空寂之体之妙用，此灵知之用仅照其自己，非别有能照之知也，“无念为宗”，则指于境现前而不染不著，《坛经.定慧品》云：“善知识！于诸境上心不染，曰无念。”“于诸境上心不染”，即“不于境上生心”，亦即“无所住而生其心”。
    心上思想正是“达摩西来意”，也是祖祖相传之根本心印。那么仰山、慈明等为什么在如来禅之外，又特别拈出祖师禅相标榜呢？
    其实后来意义上的如来禅与祖师禅，在慧能禅出现时即已见分野。自初祖达摩至四祖道信，皆崇奉《楞伽经》，以楞伽传心，自五祖六祖以下则重般若类之《金刚经》。《楞枷经》属“如来藏自性清净心”体系，围绕圆证圆悟自性清净心立论。《金刚经》则偏重般若之妙用，即不舍不著之妙用，慧能当初偶闻“应无所住而生其心”而有所悟，直到立“以无念为宗，无住为本，无相为体”之宗旨，皆能见出慧能禅重般若妙用之精神。
    而宗密所言与最上乘禅相当之“直显灵知真性宗”则重在明心见体，亦即所谓“立知见”、“说无念法，立见性”。强调以无住心之照用，反照无住心，顿悟如来藏性，证如来法身，故“如来禅”重起心修道，断妄证真，而“祖师禅”则重在不断不修，任运自在。一言达体，一言妙用，这即是后世禅师在如来禅外别立祖师禅的主要原因。
    回头再看时严击竹公案，香严闻声而生欢喜心，说明他除灭分别法执，于色声影响间，豁然亲见少分真理，依惟识宗的说法，其第六识转成下品妙观察智，进入通达位，而登初地，即欢喜地。在禅宗修证次第中称破初关、破本参。然祖师禅的精髓在于不仅对本分有所悟入，而且不住境界，不舍世间，在烦恼境中、平凡事中磨炼砥砺，最终达到生灭灭已，寂照现前，应用无穷，谓之为佛的最高境界，故只有个入处，还不是真正意义上的祖师禅，必待有个出处，用处和了处，总体得祖师禅之三昧。
    慈明于“香严击竹”公案评点后又云：
    且道祖师禅有甚长处？若问言中取利，误赚后只，直饶棒下承当，辜负先圣。万法本闲，惟人自闹，所以山僧居福严，只见福严境界，晏起早眠，有时云生碧嶂，月落寒潭，音声鸟飞，鸣般若台前；娑罗花香，散祝融峰畔。把瘦节，坐磐石，与五湖衲子时话玄微。灰头土面住兴化。只见兴化家风，迎来送去，门达城市，车马骈阗，渔唱潇湘，猿啼岳麓，丝竹歌谣，时时入耳，复兴四海高人日谈玄道，岁月都忘。且道居深山、住城郭，还有优劣也无？试道看！”
    古德云：“若非妙解，焉知心是？若非妙行，焉证心是？”祖师禅之要旨，就在于悟后起修，所谓百尺竿头更进一步，圆悟之后再求圆证，而这需要生活的历练，实际的践行，自然这种“行”非空头冥行，而是由体显用，顺道而行，正如修学、开悟有其次第和阶级，立身度世亦有与证量相对应的方式。古德云：“不破初关不闭关，不破重关不居山。”居山清修，尚且不易，而况和光同尘，与世俯仰？平常心是道作为禅宗极则，是在大事了办，功夫臻于化境之后事，非小根器者初悟便可奉行。至于居深山还是住城郭，对圆证圆悟者皆是方便自在。慧能赏言，在家亦得，不必居寺，更何况禅者还有方便化导众生之责任，故只要有超尘脱俗之心，则居深山亦得，处城廓亦得。终日谈玄论道，不离宗门的旨；随处吟风弄月，终是禅家本色。万法本闲，惟人自闹，一朝放下，当下海阔天空。
    （二）无明实性即佛性，幻化空身即法身
    禅宗标榜“不立文字、教外别传”，实则是不执著于文字，不离教而传。因为禅宗亦不出《法华经》所言“惟有一乘，无二无三”之规范，虽偏重行证之自得，然究竟是释迦所立、祖师所传，非离佛乘，别有一乘也。
    禅宗的实际创始人慧能亦尊经重教，虽简而不繁，略而不详，但在许多地方皆见出他对经教的造诣，如《机缘品》中法达问《法华》、智通问三身四智、志道问涅盘，慧能皆能扼要讲述，警策切当。
    慧能的弟子永嘉玄觉禅师，曾研读《维摩经》，修天台止观，后在慧能座下机缘相投，一宿而觉。永嘉禅师从自身开悟经验中领悟到禅不离教，教不离禅，遂作《证道歌》，阐释自己对禅和教的证悟和见地。其开篇即曰：“君不见！绝学无为闲道人，不除妄想不求真。无明实性即佛性，幻化空身即法身。”佛性、法身都是讲的禅体或道体。一从因地说，一从果地说，永嘉又进一步阐发道：“法身觉了无一物，本来自性天真佛，五阴浮云空来去。三毒水泡虚出没。”
    永嘉禅师的《证道歌》对后世影响很大，在思想内容上，它开启了禅教合一的思想先河，后来的圭峰宗密禅师，永明延寿禅师等都是遵循这一路数而展开其思想体系的。它以韵文词赞的形式表达其思想，给人耳目一新之感，对后世禅师以偈颂解禅，也有影响。
    慈明禅师在其示众法语中，曾专门论及佛性，法身，从中可以看出永嘉《证道歌》的思想痕迹：
    示众云：无明实性即佛性，幻化空身即法身，诸仁者若也信得去，不妨省力。可谓善财入弥勒楼阁，无边法门悉皆周遍。得大无碍，悟法无生，是谓无生法忍。无边刹镜，自他不隔于毫端，十世古今，始终不离于当念。且问诸人，阿那个是当念？只如诸人无明之性，即汝本觉妙之性。盖为不了生死根源，执妄为实，随妄所转，致堕轮回，受种种苦。若能回光反照，自悟本来真性不生不灭，故“无明实性即佛性，幻化空身即法身。”
    作为众生生死根本的无明，其本性空寂，无有自性，故无明实性即是佛；至于因无明辗转而有的众生的血肉身，本来如幻如化，空而不实，所以叫它幻空身，但它的体性，恰就是诸佛的法身。这是从究竟意义上对道体、佛性的界定，那么众生受生之后，佛性又如何显现呢？
    只如四大五蕴不净之身，即无实义，如梦如幻，如影如响，从无量劫来，流浪生死，贪爱所使，无暂休歇。出此入彼，积骨如毗富罗山，饮乳如四大海水。何故？为无智慧，不能了知五蕴本空，都无所实。逐妄所生贪欲所拘，不能自在，所以释尊云：“诸苦所因，贪欲为本，若灭贪欲，无所依止。”汝等若能了知幻身虚假，本来空寂。诸见不生，无我、人、众生、寿者，法皆如故，幻化空身即法身，法身觉了无一物，惟有听法说法，虚玄大道，无着真宗，故云：“本源自性天真佛。”又云：“五阴浮云空去来，三毒水泡虚出没。”若如是者，为度一切苦厄，乃至无量无边烦恼知解，悉皆清净，是谓清净法身。若到这步天地，便能出此入彼，舍身受身，地狱天堂，此界他方，纵横自在，任意浮沉，应物舒光，随机逗教，唤作千百亿化身。
    众生皆有佛性，是就因地说的，由众生之无明和随之而来的贪欲，众生受生五界，迷没“自性天真佛”，构成人的肉质身的五蕴如浮云般遮蔽了法身。正像毒物可以杀死众生的肉身一样，由无明而起的贪、嗔、痴，亦能残害众生的法身慧命，使众生升沉于生死苦海。但正像浮云自去自来，无碍于天空的空净，而泡沫自生自灭，无碍于大海的深广一样，五蕴身无碍于法身，烦恼亦无碍于菩提。自然这是果地的证境，没有实际的修行，不可能达到这样的境界。通过修行，消除无明痴爱，证无生法忍，即得般若妙智，无我相、人相、众生相、寿者相、体得大道，证得法身，反本还源，与“自性佛”不一不异。到此境界，即有各种神通，以种种方便，接引众生，此即千百亿化身的真实含义。
    我们通常印象中的禅师，专在“言语道断，心行路绝”处施展手段，如门机锋、打手势、拈佛竖杖，乃至拳打棒喝等等。这原来是不错的。但所有这些都是勘验警策学人的方便施设，本身并非究竟了义。而且禅师也并不拒绝引用经文来接引学人，如慈明上述所为便是。真正的具眼禅师，于经教言说，是出入自在的，因为他们大都浸润其间，探骊得珠，而后总完成对教相的超越，后世学人之所以习禅者众而开悟者寡，与其缺乏经教研读薰习的功夫不无关系。
    （三）最后的公案
    慈明道行高邈，迥绝根尘，然又不出世间，不舍众生，世间闻道之士亦闻风趋向，竞相造访。师迹不涉俗，深山隐遁，与之交往最多的是人翰杨大年兴都尉李遵勖。
    其时，慈明在唐明智嵩师会下，智嵩对他说：“杨大年内翰知见高，入道稳实，子不可不见。”于是前去参访。杨大年知道他从唐明处来，问：“记得唐明当时悟的因缘么？”慈明道：“唐明问首山，‘如何是佛法的大意？’山曰：‘楚王城畔，汝水东流，’”杨问：“只如此语，意旨如何？”慈明道：“水上挂灯球，”首山对唐明的回答是截流语，意在断其理路，杨的发问，是勘验禅师的见地与证境，慈明以　无义味语作答，并不中其圈套，适可见出其禅家手眼。
    慈明与李遵勖的相识，是杨大年引见的结果。相见时，李问：“我闻西河有金毛狮子，是否？”慈明反问：“什么处得此消息？”李便喝。慈明曰：“野干鸣。”李又喝，慈明曰：“恰是。”李大笑。就禅机而言，慈明对李所问不置可否，并以反问形式反客为主，此所谓把得乾坤，不落坑堑。不过，给人印象更深刻的是，慈明与李遵勖，一方外一方内，一山僧一大吏，竟能以道相交，不落俗情。慈明以“野干鸣”之语对李痛下针锥，不留情面，更见其涉俗而不染之禅者襟怀。此与后世禅者末流，攀缘权势，媚俗混世之举相较，何啻天壤！
    史载，慈明住室中插剑一口，以草鞋一对，水一盆，置在剑边。每有学人入室，即道：“看！看！”其实慈明这种布置大有深意，剑象征师家的机锋，真具手眼的禅师。其接引学人或有言或无言，其言或有义或无义，皆从本分流出，如刀剑在手，其锋芒所至，可杀可活。但学人却不可以日常的思维习惯去忖度禅师的禅机。若于此起心动念，不仅劳而无功，而且还会转求转迷，故慈明见有学人至剑边拟议者，即曰：“险丧身失命也。”草鞋一对象征禅客之行履，开悟从修行中来，“岂有天然释迦，自然弥勒哉？”古来禅师皆以剋苦修行开示学人，禅法非由师徒口传而得，“不历一番风雪苦，怎么梅花扑鼻香？”慈明之师汾阳即以天下行脚、偏参四方激励学人，慈明将草鞋一对置学人前，其用意一也，清水一盆则象徵清净圆明、圆融无碍，主客一体、自在解脱的境界。至此境界则不须言说、不求修证，无烦恼可灭，亦无菩提可求，惟任运腾腾，自然触目是道。只可惜利根大器太少，会得禅师用心者不多。
    都尉李遵勖临终修书相约一见，禅师接书恻然，即与侍者取水道进京，在船上作偈曰：“长江行不尽，帝里到何时？既得凉风便，休将橹棹施。”了生死的最后时机莫过生死之际，以李的悟性和修养，洒然西归当无问题，果然李临终作偈献师曰：“世界无依，山河非碍，大海微尘，须弥纳芥。拈起幞头，解下腰带，若觅死生，问取皮袋。”亲肉向为皮囊，视生死为幻化，很是超脱。一番问答后，李都慰曰：“晚来困倦。”再不笑话，似有惟求自了之意，故禅师又道：“无佛处作佛”，祈愿此护法菩萨不舍众生，乘愿再来。禅师大心菩萨的情怀在可见。
    李公殁，禅师悲伤难抑，恸哭久之。在归途中对侍者云：“我忽得风痹疾，“侍者一香果真口斜，侍者捶首顿足，着急地说：”当奈何！平生呵佛骂祖，今乃尔。“不料禅师平静地说：”无忧，为汝下之。“说着又把歪斜的嘴正了过来。“呵佛骂祖”是已到了处的禅师为破除学人对凡圣的分别执著，而方便说示，是师法而非禅法。这种激烈的方式只有在这种意义上总是可以理解的。若不明就里，视方便为究竟，视师法为禅法，而自身又未到悬崖撒手的境界，则必造大口业，受来世轮落恶报，受无边苦，口歪脸斜犹是其次。慈明禅师巧施方便，警策学人于本分事下功夫，莫于枝节处生染著，本分既明，则起心动念、言谈行止皆不违道，横说竖说，不造恶业。


一、慧南思想

第七章

    一、慧南思想

    慧南（１００２－１０６９），一作惠南，信州玉山（今江西玉山县）人。他十一岁出家于本州定水庵智銮。十九岁落发受具足戒，后到各地参访游学，先后师事于庐山归宗自宝、栖贤澄湜、泐潭怀澄、福岩审承等人，又与丛林奇士云峰文悦、芭蕉谷泉相友善。景佑三年（１０３６年），坚请入石霜慈明室，蒙其印可。又作短期游学之后，开法于同安寺（在今江西永修县艾城乡凤栖山），后移住归宗寺（在庐山），因归宗寺失火遭罪入狱，出狱后主临济祖庭黄檗寺，于溪旁结积翠庵居住。治平二年（１０６２），应洪州太守程师孟等人请，入主黄龙寺（在江西修水县黄龙山），直到圆寂并瘗于黄龙山。
    慧南是临济宗自五代以来，第一位影响巨大、法席鼎盛的弘法大师。早在他参学的时候，即在泐潭怀澄门下为书记，分席接纳，远近知名。他开法同安，刚一到座开堂，即有传云“石霜一派迸入江西也”，当时在泐潭寺的僧徒即纷纷投到他的门下。住归宗寺时，他的佛法机锋已为时所重，远近参学日增。原石霜门下的僧人也往往随其倡法（翠岩可真即为其首座），当时名士如程师孟、潘延之、王安石，以及南昌九江的诸多官员（如太守、判官、殿丞、提刑）都入寺听法，或请他到州、府开堂说法，住黄檗后，他开始用三关语接引学者，引起丛林极大轰动，江淮一带远来参法。到他居黄龙寺后，更是“天下有志学道者皆集南公”，“法席之盛，堪比泐潭马祖，百丈大智。”黄龙寺被称为“无生狮子之窟，不二旃檀之林，”由此，慧南法系形成派别，经二三传后，便形成“黄龙一派，横被天下”的局势。
    对于这样一位禅门宗师，把握其佛学思想和宗法特色，对于理解他所开创的黄龙派，探索其发生、发展的规律，是十分重要的。
    正好历来禅师从般若性空思想上把握佛教一样，黄龙慧南的思想也以性空缘起说为基础，所以他认为“道不假修，但莫污染；禅不假学，贵在息心。心息，故心心无虑；无修，故步步道场；无虑则无三界可出；不修则无菩提可求。”他强调参禅者，要“一念常寂”，这样便可使“三际杳忘”，凡心不动，随处作主，他说：
    拟心即差，动念即乖，不拟不动，土木无殊。
    心王不妄动，六国一时通，罢拈三尺剑，休弄一张弓。
    智海无风，因觉妄以成凡；觉妄元虚，即凡心而见佛。
    这里的“智海”指自心、自性，即般若之智，“智海无风”即本心清净，人性本来具足菩提般若之智，如来藏自性本来清净，但因客尘所染，便有凡心执着妄念，有世间万法种种殊异，故修道别无它法，只需息灭妄念执着，使凡心不动，心常寂寞，便于当下凡心之中体悟自性，见其清净，成佛作祖，很明显，这些思想与惠能以来禅家所说的“菩提只向心觅，何劳向外求玄”，“迷凡悟圣”等等是一致的。
    慧南关于法身、法性，佛法的体用及理事关系的一些观点，颇见新意，他说：
    法身无相，依智海以为源，含源之流，总法身而为体，只为情生智隔，于日用而不知，想变体殊，趣业缘而莫返。
    法身无相，就物现形，般若无知，随缘即照。
    不过，慧南思想的真正特色，不在体道见性成佛的理论上，而在所见之“性”，所体之“道”，所成之“佛”的具体内容上，亦即在“佛”之性格上。
    慧南之所谓“道”，有这样几层意义。首先，“道”是一种恒常不变的存在。他说：
    古之天地日月，犹今之天地日月，古之万物性情，犹今之万物性情，天地日月固无易也，万物性情，固无变也。道何为而独变乎？
    其次，“道无疑滞”，无始无终，无前无后，无形无记，虽不假言说，但为使人体悟此“道”，不得已而说之：
    大道无中，谁复前后？长空绝迹，何用量之！空即如是，道岂言哉？虽然如是，上根辈不假言诠，中下之流，又争免得。
    第三，道虽不假修持，但有志之士，犹可得其高远：
    道如山，愈升而愈高；如地，愈行而愈远。学者卑浅，尽其力而止身，惟有志于道者，乃能穷其高远，其它执与焉？
    很明显，慧南所言之道，即佛性，它与天地万物之本体，与老庄之“道可道，非常道”，恍恍惚惚，存在于万物之中的自然本体和本原，十分接近，虽不可言诠，但可以体究。这就是说，慧南思想中佛性是近于道家自然本体，本性的。这一点，更明确地表现在他关于体道的方法论上，慧南认为，体道第一在有志于道，须禀丈夫决烈之志，他说：
    夫出家者，须禀丈夫决烈之志，截断两头，归家稳坐，然后大开门户，运出自己家财。
    所谓“截断两头”，即不落两边，杜绝分别心，灭去万法差别相。“归家稳坐”，指返本见性。“运出自己家财”指按照清净自性弘法利生。这里已强调学道的第二个要点在息妄心，去污染，所谓“道不假修，但莫污染，禅不假学，贵在息心，”他认为“心息，故心心无虚，不修，故步步道场；无虚则无三界可出，不修则无菩提可求，”所以说“且能一念常寂，自然三际杳忘，”若不然，“拟心即差（差错），动念即乖（谬误），不拟不动，土木无殊。”就禅家修行理论而言，慧南所说的息心、忘念即禅定的功夫，与老子的“心齐”、“坐忘”，虚静无为，“损之又损”的道家修行方式，是相通的。由此，我们看到佛道二家的融合，在慧南思想中已经到了契合无间的成熟时期，这是慧南思想的第一个特点。
    慧南又特别重视息心、忘念的功夫过程，强调要专、勤，不断积累，他说：
    夫圣贤之学，非造次可成，须在积累。积累之要，惟专与勤。屏绝嗜好，行之勿倦，然后扩而充之，可尽天下之妙。
    所谓“扩而充之”是两个功夫过程：“扩”是广泛涉腊，即“博”；“充”指深入参究，攻破消化，把握本质，即“约”；“扩而充之”，即由博返约。慧南把参禅学道看成一种学问功夫和人生修养功夫，这一方面也是对老庄“为道日损，损之又损，以至于无为”的修养方法的吸收，具有相当浓郁的文人士大夫气息。同时，他所成的“圣贤之学”，其目的又在“尽天下之妙”，即世间万法的真谛，可见慧南之佛法，既出世间，又不离世间，即在现实世界之中。他又说：
    夫人语默举措，自为上不欺天，外不欺人，内不欺心，诚可谓之得矣。然犹戒谨乎独居，隐微之间，果无纤毫所欺，斯可谓之得矣。
    对天、对人、对心“果无纤毫所欺”方可谓之得，这在禅宗内是前所未有的理论。禅宗自六祖以来，凡言作佛，皆言自见本心，自性即佛。这里不仅把自见本心心转换为“不欺自心”，还在此之前，外加了“不欺天、不欺人”。佛家的自性皈依转变为对天、人、自我三者的皈依。上文中“天”的内涵究指什么，慧南未直说，但不可欺的天，大体上离不开儒家天理、天道、天命等等神圣尊的意义。“不欺天”，即是息自心以合天理、天道，这与后来理学家的“存天理，灭人欲”的旨颐曾自道“吾此妙心实启于黄龙”，此中渊源契合，已经十分清楚了。“人”指人情、社会道德伦理等。慧南《致黄檗惟胜书》在谈到住持要得众、见性时说：
    人情者，为世之福田，盖理道所由生也。故时之否泰，事之损益，必因人情。情有通塞，则否泰生；事有厚薄，则损益至，惟圣人通天下之情。
    很明显，这里的“通天下之情”，与“尽天下之妙”与儒家“克已复礼”、“舍身成仁”、“经世致用”的思想趋于合流。他还有这样一段话：
    夫长老之职，乃道德之器。先圣建丛林，陈纲纪，立名位，选择有道德衲子，命之曰长老者，非苟窍是名也。慈明先师当曰：“与其守道老死丘壑，不若行道领众于丛林。”岂非善守长老之职者？则佛祖之道德存欤？
    慧南认为佛教具有道德人伦教化的职能，所以“领众丛林”，是为了行其道德，长老住持，便可住持，便可谓教化之主。儒家积极入世的思想溢于言表，佛教的“出世”与儒家“入世”在佛教“世出世”理论的框架之下被统一起来了，以出世之精神，导入世之事业，成为慧南思想的落脚点，这是其社会责任感之所在，也是其思想特色所在。他甚至把现实社会的王臣政治与佛教比作同样有头于生灵的春风丽日。说“欲使慧风与尧风并扇，佛日与舜日同明，苟非存意于生灵，何以尽心之如此。”
    也许正是这个原因，慧南对佛法始终持一种精勤执着的态度，他以荷担佛法，拯救佛法末运为已任。当受请住持黄龙寺时，他说“黄龙出世，时当末运，击将颓之法鼓，整已坠之玄纲”。见到参学者很少自性觉性时，他嗟叹“头角住多无獬豸，羽毛虽众少鸳鸯。”目睹四方禅法衰微，宗纲不振，他深感“酸酒冷茶愁煞人。”，当公卿士大夫拥戴他领众说法时，他“翻思有负公侯命，旦夕彷徨益厚颜。”这哪里是一个逃尘出世的衲僧形象？分明是胸怀报国大志的忠臣义士。
    《黄龙崇恩禅院传灯谱》卷上有这样一则记载，大意说祖心（慧南上首弟子）一次见慧南不高兴，问他什么原因，他说为寺院监收（僧职的一种）无合适人选而苦恼，于是祖心先后向他推荐了几个人，但慧南以人选道品行、根机灵性各种原因予以否定，认真执着之极。后灵源（祖心之徒）问祖心“黄龙用一监收何过虑如此？”祖心说：“有国有家者，未赏不本此，岂特黄龙为然？”祖心对慧南的评价，肯定了慧南佛法从理论到实践都“有国有家”这一积极入世的鲜明特徵。
    综观慧南的佛学思想，很明显是一个儒、佛、道“三合一”的体系。“三家”在这一体系中的地位、作用是否不相同的，禅家一脉承传的理论框架，仍然被继承下来，在语言的表层上，慧南与他的前代祖师没有多大的差别，但在其所之道和所见之性的具体内容及途径上，则已发生深刻的变化。带有本质意义的“道”，已经老庄自然本性、儒家天性与佛性的集合体。所以，慧南佛学思想是一个以佛为体、以道为质、以儒为用、带有很多文人气息的混合体。


二、渊源和背景

二、渊源和背景

    慧南禅学思想的形成，是有其深刻的历史渊源和社会文化背景的，它既是自六祖以来禅宗发展变化的合理延伸，更是慧南所处时代政治思想的文化大环境促成的结果。
    佛教自传入中国以来，便沿着与中国传统思想文化既相互冲突、相互竞争、又互相渗透、互相融合的路线而发展，且佛教与儒、佛、道三家融汇后的产物，只是早期禅宗这种融汇不够明显罢了。北宋结束五代十国的分裂混乱局面之后，实行中央集权的君主专制制度，国家利益、君主权威，至高无上，压倒一切，这是宋朝社会的政治、经济、文化的观念前提和思想基础。赵宋王朝实行科举考试制度，儒家依然是治世的正统思想，与此同时，佛、道二教被视为“有裨政治”而得到保护，与儒家思想共同生存于社会。正是这种特殊的生存环境，使三教融合成为当时思想政治领域的一种不可逆转的时代潮流。
    当然，由于儒、佛、道三家不同的本位立场，三教融汇的具体方式和内容是不尽相同的。儒家是科举考试的主要内容，始终不失其支撑朝政的正统地位（太祖之时崇尚法治，儒学正统不甚巩固。随着科举的推进，这种正统地位便很快确立），所以儒家往往凌驾于诸子百家之上，对佛、道二家，表面上采取一种不甚热情的态度——真宗对二家的倡导算是最得力者，也不过认为“释道二门，有补世教”，“二门”依然处于世教的“补充”地位，多数情况下，儒家对佛道采取排斥的态度。其中如孙复著《儒辱》、石介作《怪说》、李靓作《潜书》、欧阳修著《本论》都是代表。南宋理学家，表面上无不诋毁佛教。然而，不管儒家对佛、道二氏的表面态度如何，其融摄二氏思想的实质却是明显的，太宗时的邢昺是儒家大家，他曾说：“人若不学正经善道，而治乎异端之书，斯则为害之深也。“然而，他所著的《五经正义》不仅接受了汉代经学家玄学化的成果，而且在思想方式、心性学说等方面进一步靠拢佛道，又如张载曾说“吾道自足，何事旁求？”表示要“尽弃异学”，而张载的思想却依然是兼融三家的，所以冯兰先生评论他是欲使人“于人伦日用之中修成儒家的佛。”其他理学家如周敦颐，二程、朱熹等人，无论学风和思想体系，莫不如此。
    在这样一种思想潮流之下，佛教当然不可能如汉魏时候那样与儒、道公然对立，展开争辩，它也不能对中央集权下的国家至上、君主至尊无动于衷，所以靠拢正统儒家思想，竭力发挥其道德人伦教化的作用，便是佛教惟一可取的生存、发展模式。正因为如此，宋初，永明延寿（９０４－９７５）引儒家伦理道德入佛教规范，并著《万善同归集》等，开宋代禅学靠拢儒学之先河，稍后，天台宗山外派僧人智圆（９７６－１０２２）自号“中庸子”，后中庸学说入手、融通二家，倡“以儒修身，　以释治心”，与慧南同时代的云门僧人契嵩（１００７－１０７２），更是致力于三教融合学说，主张“儒者，圣人之治民者也；佛者，圣人之治出世者也，”他的《辅教编》得到仁宗的赞许，准入大藏，广为流传，他本人也因此而受对为“明教大师。”
    慧南的思想，很明显是宋代禅宗思想发展总趋势下的一个代表。他对佛法的精勤执着，表明他对现实社会是取诚恳、信任与协调态度的。他那以佛为体、以道为质、以儒为用的思想体系，不仅是佛教自晋宋以来庄学化倾向的合理延伸，更是佛教臣服于君主专制制度的必然产物，他的二风并扇、二日同明思想，与智圆的修身、治心说，契嵩的治世、治出世观点，是同一时代背景下的不同学说，其本质意义是相同的。
    最后，必须说明的是，慧南的禅学最终所要追求的成佛境界，是亦庄亦儒亦佛，非庄非儒非佛，圆融无碍，通达自由的。这即是他所说的于天、天人、于我都“无纤毫所欺”，“通天下之情”，“尽天下之妙”的境界。它给于禅者的最高人生旨趣，是无可无不可，纵横驰骋，任运随缘，放旷消遥，既不执着，也不逃避的自在人生，不管这种境界在现实人生可能存在多大的矛盾，它始终是慧南禅学追求的目标，也是他教化学人的理想模型，正因为如此，他不大厌其烦地反复强调：
    道无疑滞，法本随缘，事岂强为，盖不尔而尔。
    禅者非内非外，非有非无，非实非虚。
    五六七八九，面南看北斗，此中若得玄，纵横任哮吼。
    同安无折合，随汝颠倒所欲，南斗七，北斗八。
    流水下山非有意，片云归洞本无心，竹屋茅堂谁是主，月明中夜老猿声。
    数声清罄是非外，一个闲人天地间。
    由此，我们进一步看出慧南禅学的丰富性和深刻性。


三、慧南禅风

三、慧南禅风

    慧南禅学思想，散见于各处的言论（书信、语录、偈颂、笔记等）中。虽然具有他所处时代的鲜明特色，而且对后世禅宗的发展产生深刻影响，但由于他没有系统的禅学著作（他恪守了不立文字的禅规），未作深入论述，难免比较单薄而未易显示重要意义，甚至许多有价值的观点尚鲜为人知。
    然而，慧南却是一位卓绝的宗教实践家。他的禅学思想，是直接通过自己的实践，对禅宗、对社会发生影响的，必须深入到他的禅法实践之中，总能真正把握其禅学思想的实质和重要意义。下面，我们从四个方面加以考察。
    １、“壁立千仞，鍜尽凡圣”——黄龙三关及慧南的谨严禅风。
    最能代表慧南禅法典型风格的，当然是名重丛林的黄龙三关——即慧南所设，用以接化学者的“生缘”、“佛手”、“驴脚”三问。
    《建中靖国续灯录》卷七慧南章下是这样记载三关的：
    师室中常问僧出家所以、乡关来历，复扣云：“人人尽有生缘处，那个是座生缘？”又复当机问答，正驰锋辩，却复仲手云：“我手何似佛手？”又问诸方参请宗师所得，却复垂脚云：“我脚何似驴脚？”三十余年示此三问，往往学者多不凑机。丛林共目为三关。
    所谓生缘是人的姓氏、籍贯等，大凡僧人游访参学，到一寺院，首先必须通报生缘籍贯和参学来历，慧南的第一问，即从此最平常的事情中发出。话分两截，“人人尽有生缘”，意在将答问者的思维加以牵制，使其就擒，不能作主。同时，语中也含有无中生有，故意发问的玄机——既然人人尽有生缘，前已问过乡关来历，何必郑重其事地发问？所以“上座生缘在何处”已是所谓“无事起事，好肉上割疮”（慧南语），对于这样一个问题，如果还如常人以公辨知解的事实作答，表明答问者凡心未除，根机浅劣，随语生解。这是第一关，难度并不大。
    慧南的第二问是从“当机问答，正驰锋辩”的关键时刻，冷不防提出来的，问话的语言环境刚好与第一问相反——第一问是“顺风使船”，就当下所常问、所必问的内容顺势托出；而这里却是“逆水行舟”，当你思维正沿着前面的问答机锋在驰骋的时候，来一个一百八十度的大逆转，通常情况下，人们很难适应这种问话，此其一；其二，“佛手”、“我手”之问，贯穿佛家根本思想——众生与佛的关系；“佛手”代表佛性、佛法，“我手”则代表众生、自性，众生与佛的关系在佛教是一而二，二而一，既不可言同，又不可言异的。若言“我手”与“佛手”不相似，则与“真如偏在”、“万法一如”等思想相矛盾，何况禅家主张“青青翠竹，尽是法身，”岂有不相似之理？若言“我手”与“佛手”相似，但众生是因，佛性是果，因不即是果；且当下答问者所求无非成佛之道，分明众生与佛有别，俗界与佛界悬隔，何以淹灭和沟通？故无相似之理。所以“我手何似佛手”本身就是一个进退维谷、二律背反的两难境地，难度显然比第一问更大，这是第二关。
    不管前面两关是否通过，答话人的思维已经被调弄得很紧张了。可是慧南的第三关却跟紧着卡了上来。先是拉你一把，问你近来到各处参学有什么收获，紧接着把你一脚踢向门外：“我脚何似驴脚？”这第三问比第二问本身难度更大，第二问从生（我手）佛（佛手）关系发问，此处从众生（我脚）与众生（驴脚）之间发问，有情众生的千差万别，在任何一个未彻悟佛法的人心中，都是绝对的，只有深悟涅盘寂静境界者方能凑机，故此问可验学者对佛法是否了悟。加上此问紧逼前面一问，正是“雪上加霜，火里添油”，“钟楼上念赞，床脚下种菜”好比挥舞着杀人之刀，把人逼到一个死胡同里来了——看你如何死里逃生？这就是慧南的第三关。
    关于三关的禅法旨要，慧南自己曾以偈颂作过解释。如云：
    生缘有语人皆识，水母何曾离得蝦。
    但见日头东畔上，谁人更吃赵州茶。
    这是颂第一问。意即用平常之问，试探学者有没有更吃赵州茶的本领，即体究佛法的根机。又云：
    我手佛手齐举，禅流直下荐取。
    不动干戈道处，自然超佛越祖。
    这是颂第二问，意即此问把众生与佛齐举，从“理”上设问，试探学者对法的敏感，去其法执，充满机锋激流。这样的问题，只有凡心不动，不落生死，不动思虑干戈作答，成佛作祖。又云：
    我脚驴脚并行，步步踏着无生。
    会得云开日见，方知此道纵横。
    这是颂第三问，意即紧扣涅盘无生境界的第三问。只有了悟佛性，脱尽生死牢关，却除了我执，无纤芥凝滞，得自在三昧者总能纵横自在，不为所绊。
    黄龙三关就是这样一个步步为营，环环紧扣、机锋四伏的“连环雷”，真可谓用心良苦，三关当时在丛林反响异常强烈，天下衲子纷纷来朝，而又往往望风而倒，死于向下，所以惠洪说慧的“门风壁立，虽佛祖亦将丧气，故能起临济于已坠之道”。“观黄龙以三关，鍜尽凡圣。”黄庭坚则把三关比作大熔炉，说“自为炉而熔凡圣之铜。”
    黄龙三关的对答是不能固定格式的，否则便成知见执解，不能过关。丛林对三关有很多评唱，旨要大抵不出慧南自颂三偈。但这些偈颂，对深入理解“三关”是在帮助的，不妨摘录数则。如真净克文颂云：
    人人有个生缘处，认着依然还失路。
    长空云破月华明，东西南北从君去。

    我手何似佛手，翻覆谁辨好醜。
    若是狮子之儿，野干谩为开口。

    我脚何似驴脚，隐显千差万错。
    豁然金刚眼睛，看取目前善恶。

圆悟克勤颂云：
      人人有个生缘，蹲身无地钻研。
      若也眼皮进绽，累他桶底踢穿。

      我手何似佛手，随分拈花折柳。
      忽然撞着蛇头，未免遭他一口。

      我脚何似驴脚，赵州石桥略彴。
      忽然筑起皮球，崩倒三山五岳。
    此外，云盖守智曾批语丛林不解黄龙三关宗旨，以死语作答的现象，他说：“吾昔再入黄檗，至坊塘，见一僧自山中来，因问三关语，近日如何商量？僧曰：有语甚妙，可以见意。我手何似佛手，曰月下弄琵琶，或曰远道擎空钵；我脚何似驴脚，曰鹭鸶立雪非同色，或曰空山踏落花；如何是汝生缘处，曰某甲某处人。时戏之曰：前途有人问上座，如何是佛手驴脚生缘意旨，汝将远道擎钵对之耶？鹭鸶立雪非同色对之耶？若俱将对，则佛法混滥，若拣将对，则几事偏枯。其僧直视无所言。”
    正因为三关不能以执解作答，慧南在使用三关验人时，对学者所答皆不置可否。“敛目危坐，人莫涯其意。”当有人问他何以加此，他说：“已过关者，掉臂而去，安知有关吏在？从吏问可否，此未透关者也。”
    黄龙三关的深刻用意如此，它代表了慧南禅法的典型风格——险绝凌厉，同时，它也反映了慧南对佛法精勤执着，富于社会责任感的思想基础。这正如他自己在另一首《总同颂》中所自由，是“为报五湖参学者，三关一一透将来。”慧南是以佛教为“行道”手段，寄寓生灵、国家以深刻爱意的，三关的设立是一个具体表现。所谓“运出自己家财，赈济孤露，方有少分报佛深恩。”可见，慧南禅法的基本特色是执着、谨严的，与这一基本特色相适应，慧南还非常重视丛林清规，他“坐必跏趺，行必直视”，“进止严重，见者敬畏”，同时要求学人严守戒律，循规蹈矩，他把儒家纲常伦理道德纳入戒律范围，把不违规矩视为“头头圆觉，步步道场”，认为“规矩既乱，诸事参差，一人失事，众人不安”，居士潘延之曾问及他法道谨严的原委，他说：
    父严则子敬，今日之规训，日后之模范也，譬治诸地，隆者之下，洼者平之，彼将登于千仞之山，吾亦与之俱；因而极于九渊之下，吾以与之俱。伎之穷，妄之尽，彼则自休也。
    要为丛林建立规训的模范，这绝非等闲之辈所能为，慧南以振兴佛法为已任，所以有这样的志向与气魄，他能“起临济于已坠之道。”开创一个“横被天下”的宗派，绝非偶然。如此严格地把戏持“行道”之方，应该是黄龙派得势的主要原因。惠洪说得好：
    南禅师，风度凝远，人莫涯其量，故门下客多光明伟杰。名重丛林。有终身未尝见其破颜者，予闻之，厚于义者，薄于仁，师道也，师尊而不亲，厚于仁者薄于义，亲道也，亲亲而不尊。南公之意岂不以是哉。
    的确，慧南之禅法既有师道的尊严，也有儒者的仁爱，谨严执着的风格下透露的是禅家为体、老庄为质、儒家为用的禅学思想。
    ２、“坐断千差，密开要路”——慧南禅法的诸宗融摄现象。
    慧南禅法对唐末以来五家宗风的融摄现象是相当明显的，这一点可以从三个方面加以考察：
    一是慧南兼容并蓄，为我所用的宗法思想，在此之前，很少有人把五家宗风这样纠在一块来综合评述的：
    无中亦有，德山棒似撒星；有中亦无，临济喝如雷震，如聋如哑，逼塞乾坤。
    大觉禅师惟得偏行一着，临济德山只是互用二机。法道周流，大似拗曲作直，所谓棒喝截断，犹若以金博鍮；直饶东注西流，南唱北各，亘古亘今，且未有当头道着。
    三玄三要，五位君臣，四种藏锋，八方珠玉，三十年前，争头竞买，各逞机锋。而今道泰升平，返机朴还淳，人人自有山青水绿，白云深处，三衣并为一衲。
    以上语录中，德山指德山宣鉴，云门文偃之祖，雪峰义存师，他的禅风代表云门一派的绝险，大觉禅师指章敬怀晖，他是马祖门下高僧，属洪州宗，继承马祖全机大用之风，并喜以动作、圆相为机语，故慧南说他得“偏行一着。”三玄三要是临济宗旨，五位君臣是曹洞法要，四种藏锋是云门设施，很明显悲南对各家宗法虽有偏爱和侧重（临济、云门），但并不偏废其它各宗。如果说“道泰升平，返朴还淳，人人自有山青水绿”表明他具有关注时代学风的思想自觉，那么“三衣并一衲”则是他自定宗法的基本原则——“并”——兼摄、融通。所谓“东注西流，南唱北和，亘古亘今未有当头道着，”不仅是他对前代宗师禅法境界的认识，也是他自己对宗法风格的追求——左右逢源，纵横无碍，融摄诸家，为我所用，扶起放倒，随分施设，开遮自在，收放裕如，这正如他在《送周禅者　》偈中所叙述的那样式——
    扶起放倒，翻来覆去。随假随真，还伊价数，狮子频呻，象王回顾。赤日光中，腾云起雾，坐断千差，密开要路。大丈夫汉，莫打死兔。
    “坐断千差”本意为消除世间万法的种种差别相，达到万法一如的平等境地，这里被慧南理解为对诸家宗法的融汇，成为“密开要路”的准备和手段。
    与兼融并蓄，为我所用的思想相适应，慧南形成了一套灵活机巧，诸家并重的禅法实践。法眼神师清凉文益《宗门十规论》归纳五家特色时说：“曹洞则敲唱为用，临济则互换为机，诏阳（指云门宗）则函盖截流，沩仰则方圆默契，”法眼本宗的特色则在“理事相资还同目足，”而元中峰明本则把五家宗风归纳为“沩仰之谨严，曹洞之细密，临济之痛快，云门之高古，法眼之简明。”以此考察惠南禅法，可谓诸法具备，灵活机巧，例如他行棒行喝：“尽大地被同安一喝，瓦解冰消。汝等诸人，向什么处著衣吃饭？”隆庆庆闲来参，问何处来，答百丈来，问几时离那里，答正月十三，慧南说“脚跟下好痛与三十棒”。又一日问僧“百千三味，无量妙门，作一句说与汝，汝还信否？”对曰：“和尚诚言，安敢不信？”南指左边曰：“过这边来，”僧将趋，忽咄之曰：“随声逐色，有甚了期，出去！”另一僧知道又趋入，慧南以原话问，亦对曰“安敢不信。”指曰“过这边来”，僧坚不往，又咄之曰“汝来亲近我，返不听我言，出去！”德山、临济一路棒喝之风，慧南已运用自如，不露声色。又如：
    僧问：“大用现前，请师辩白，”师云“摘却你眉毛，倾出你脑髓，脚跟下道将一句来，”云：“镆耶举起，蛟龙失色。”师云：“作么生？”僧以手面前一画云“争奈这个何？”师云：“三十年后，讨个师僧也难得，”僧便喝，师云：“如一喝，未有主在，”僧作礼，师云“当断不断，反招其乱。”
这里，师徒对答问痛快淋漓，一唱一和，语机相投；宾主互换，禅流直下如泉涌注，既得临济法奥旨，又不失法眼之简明，沩仰之谨严和曹洞之细密，沩仰宗有９７种圆相，慧南即常用动作、圆相为对机语。如他曾访问云门派僧人法昌倚遇，方圆默契，尽得沩山风流。
    此外，慧南还有“一足令”在当时禅林也很有影响，《黄龙四家语录》卷一载：
    僧问：“作家不啐啄，啐啄不作家，大众临筵，请师作家相见。”师垂下一足，进云：“焰里寻飞雪，水下火烧天。”师乃收足。
    这里的垂足行令一具脂一指有异曲同工之妙，唐青原行思曾行此令，后则一直无人采用。慧南把它光大发扬，并成为自己禅法的特色之一，颇具云门高在古神秘之旨，故当时丛林评价很高，宾峰真净克文曾说：
    黄龙行此令，十方诸佛，无敢违者；诸代祖师，一切圣贤，无敢越者；无量法门，一切妙义，天下老和尚舌头，始终一印，无敢异者。
    一连用“无敢违者，无敢越者，无敢异者”三语，把慧南“一足令”推许到无以复加的地步，虽然难免有一些师徒之间自我吹嘘之嫌，但至少说明“一足令”在当时丛林是具有很大影响的。
    ３、“遇方即方，遇圆即圆”——慧南不拘一格的教化手段。
    正因为慧南禅法兼具众家之长，所以他在接引学者的方法上是灵活巧妙，随机应变，不拘一格格不的。慧南居黄檗寺时有这样一则上堂法语：
    黄檗有时正路行，有时草里走。汝等诸人且莫见锥头利，失却凿头方。不见古人道：“开不能遮，勾贼破家，当断不断，反遭其乱。
这既是慧南对自己灵活多变禅法的提示，也表明他的禅法思想——当机立断，开遮自在，这一点，在他接引学者，特别是对学者的培养提携方法上是有充分体现的。试看他对泐潭善清的教训：
    （善清）谒黄龙，龙示以风幡话，久而不契。一日龙问：”风幡子，作么生会？“师（指善清）曰：“迥无入处，乞师方便。”龙曰：“子见猫儿捕鼠乎？目睛不瞬，四足踞地，诸根顺向，首尾一直，拟无不中。子诚能如是，心无异缘，六根自静，默然而究，万无一失也。”师从是屏去闲缘，岁余豁然契悟。
    慧南论学道，在贵在积累、要专与勤的话，这里即以之启发善清，使他契悟，又如祖心是慧南门下最负盛名的上首弟子，契悟广大，时人尊为“衲僧之命脉，人天之正眼”（山谷语），慧南对祖心的提携教育，可谓费尽心机。当初，祖心因不堪云峰文悦的“孤硬”而投奔他的门下，机锋接引之后，他深祖心是难得的法器，于是“命其入众，”让他披阅经卷，参究《灯录》公案，“看话下语，百计搜寻，”历时四年，“有机而不发，”终于让祖心因耐不住凡心困扰而辞别。后祖心往来咨诀于文悦、石霜等人之间，仍不得悟。在无所用心之下，偶读《传灯录》“多福一丛竹”公案，猛然省悟，“顿觉亲见二师”（指文悦与慧南），于是重入慧南之门，当祖心问慧南为什么这样委曲对他，慧南说“若不令汝究寻到无用心处，自见自肯，吾即埋没汝也。”在慧南的教育之下，祖心“以无学之学朝宗百川”，直一“七纵八横，天回地转”无纤疑在，慧南总让他分座接纳。
    真净克文本以辩才负时名，入慧南门，慧南无所示教，克文说“我有好处，这老汉不识我”，后于香城禅师言下悟得黄龙用意，服膺于黄龙家法。泐潭洪英被惠洪称为“从上宗门之爪牙”，“精于内外典籍”，诣黄檗南禅师席，檗与语达旦，曰：“荷担大法尽在尔躬，厚自爱。”
    慧南对法门伟器珍重如此，其接纳人才则兼收并蓄，方法则灵活多变，各尽其才，各得其长。他特别重视自证自悟，培养门人的独立思维，如其回答祖心言，要“自见自肯”，关于这一点，慧南还有很多论述，例如他对石头禅师“乍可永劫受轮回，不从诸圣求解脱”一语极为推重，常引以教育学人要“自种祖父田园”，他喜举前人公案加以“逆解”来提倡宗由，以此启发学者独立思维，自证自悟。他批评那些随语生解，不能自悟的人“只能顺风使帆。不能逆风把舵”，他说：“时人住处我不住，时人行处我不行，于此了然明的旨，须会全身入火坑。”可见，他把“时人住处我不住，时人行处我不行，”这种带叛逆性的独立思维当作其体悟宗由，建立宗法的理论构架。
    《五灯会元》卷十七和《僧宝传》卷二十五隆庆庆闲章下均有这样一段记载：
    （庆闲与黄龙）同看僧堂，（黄龙）曰：“好僧堂”，师（庆闲）曰：“极好工夫。”曰“好在甚处？”曰：“一梁拄一柱。”曰：“此未是好处，”师曰：“和尚又作么生”？龙以手指曰：“这柱得与么圆，那枋得与么匾。”师曰：“人天大善知识，须是和尚始得。”即趋去。明日侍立次，龙问：“得坐披衣，向后如何施设？”师曰：“遇方即方，遇圆即圆。”
    十分清楚，这里是就黄龙寺僧堂之用材论黄龙门下的人才。“一梁拄一柱”意谓黄龙门下弟子一个个是荷担佛法的顶梁之柱。“这柱得与么圆，那枋得与么匾”意谓黄龙弟子各有特色，“一个个硬剥剥地”而非常闲之辈，所以庆闲称道乃师“人天大善知识，须是和尚始得”，并进一步领悟到黄龙人才荟萃的原因在慧南不拘一格，灵活多变，开遮自在的教化手段。
    为什么“天下有志学道者皆集南公”（惠洪语），在短短几十年间，黄龙一派横被天下的原因何在？十分重要的一条，即是“黄龙得势，首在得人”，而“遇方即方，遇圆即圆”则是黄龙所以得人的成功经验所在。
    ４、“不有提唱，孰辨宗由”——慧南禅法与语言文字。
    一向为教外别传，不立文字的禅宗，到晚唐五代之后不自觉地走上崇高文字功用的轨道上来了。汾阳善昭对语言文字的偏爱，开启宋代以后籍语言文字以参禅的新风，而这一风气的正式兴起者，则是黄龙派高僧慧南。在这里，他起到一个承先启后的作用。慧南关于语言文字的观点，概括起来说有这样几方面，例如他说：
    诸佛出世，假设言诠。祖师西来，不挂唇吻。
    大道无中，谁复前后。长空绝迹，何有量之。空即如是，道岂言哉。
    菩提离言说，从来无得人。
    这里，一方面承认佛祖凭籍文字语言以显示、传达、保存佛法的事实，同时又强调佛法不在言句本身。所谓“不挂唇吻”，即终日言而未尝言的意思。撩开来说，是承认语言文字的作用，在不立文字的宗旨下，给文字开一方便之门。所以他在说明道岂言哉之后，话锋一转说：“虽然如是，若是上根辈，不假言诠，中下之流，又争免得？”所以“晚学初机，须得明明说破。”如果注意到“黄龙出世，时当末运”和慧南认为末法时代罕遇上根之人的观点，实际上慧南已为自己设计了一个大施语言文字之禅的“小环境”，所以他敢于理直气壮地说：
    不有提唱，孰辨宗由？不有问答，孰明邪正？
    正是在这种思想的认识下，慧南相当重视解释、提唱公案古则即所谓拈古，重视师徒间的对机问答（三关之设即是一个典型的例子），慧南语录中，有很多拈提公案的实例，大都十分精彩，如他拈解“药山浴佛”这则公案时列举种种随语生解的错误说法，指出：“古人随时一言半句，亦无巧妙，今人用尽心力安排，终不到他境界，用此思维辨于佛境，如取萤火烧须弥山，纵经尘劫，终不能著。”从这一切公案的拈提可看出，慧南主张出语随缘，不假思索，不事雕琢。所以他批评“后来儿孙不肖……但逞华丽言句而已”。他又引孔子“目击道存”来论证佛家的“无示无得，”认为“夫说法者，无说无示，其听法者，无闻无得，”所以语言文字以随机接物，语中无语为活句，费心安排，语中有语为死回。在慧南看来，语言文字“千般说，万般喻，只要教君早回去。”即返观自心，返见自性，屏除思虑执着，回归自我，任性消遥，得自在法门，游戏三昧，“随汝颠倒所欲，南斗七，北斗八。”慧南对自己这种开遮自在、灵活机巧的禅风是颇为自负的，他有一首《送禅者》的诗，隐约道出此中端倪：
    拔草占风辨正邪，先须拈却眼中沙。
    举头若味天皇饼，虚心更吃赵州茶。
    南泉无语归方丈，灵云有颂悟桃花。
    从头为我雌方丈，要见丛林正作家。
“从头为我雌黄山，要见丛林正作家”显然是自况之词。这种自负的心理，一方面来自对佛法的执着和自信，一方面来自宗派势力在当时的影响。
    慧南对语言文字的重视，使他的禅法更具文人化的气息，加上他融儒、道为一体的思想体系和对社会、对人类富于责任感与爱心的特色，其禅法不仅在丛林享有崇高威望，也引起文人士大夫的广泛兴趣，当时士人往往与他或他的传人结交，谈禅论道，相契无间。中国文化史上的一个重要现象——士大夫禅悦之风，也在这个时代趋于热烈，慧南的禅法便通过这些渠道而对社会政治、思想文化产生影响，完成其“行道而领众丛林”，并以出世之功，行入世之道的禅学思想。为了适应这种“行道”的需要，慧南竭力使佛学俗学化。他自己亦能诗善画，诗风一如其禅风，深入老庄，开合自在，如行云流水，其书法则“笔法深稳，庄重而瘦，有颜平原用笔意。”这些修学都成为他禅法的有机组成部分，为其“行道”服务。所以慧南之禅，在很大程度上，已经是文人之禅，士大夫之禅。


四、心理基础和师承

四、心理基础和师承

    前面已经说过，慧南的禅法实践是为其禅学思想服务的，更确切地说，慧南的禅学思想，通过其禅法实践总得以体现，并产生实际的影响。所以我们考察了慧南宗法特色之后，对其三合一的文人化禅学思想有了进一步的理解。不过，慧南禅法特色的形成，还有两个方面的重要原因；性格特徵和师承渊源。下面，我们以他的生活经历为基本线索，对此加以考察。
    据《禅林僧宝传》卷二十二载，慧南小时候性格沉静，“深沉有大人相，不茹荤，不嬉戏，”看来天资已具佛家种性。从心理学角度来看，性格沉静内向的人，从事活动比较严肃、缜密，富于责任感和独创性。这在很大程度上确实与慧南禅法的谨严特色相吻合。元人中峰明本在分析五家宗法渊源时说：“五家宗派者，五家其人，非五其道，”从慧南性格及其宗法特色来看，的确如此，所以蒋维乔先生也说：“性质温者其言和，性质烈者其言峻；因其发言之和峻，禅风因之而变，其禅风之相违，即禅之派别相违；同为禅也，发挥之时，因受人格之影响，禅门宗趣遂致各异，”这是有一定道理的，大抵高僧名宿，在广为参学之后，便会形成对宗教思想、宗法特色的主观好恶和取舍，形成与自己性格相适应的传法风格、并以此接引机智相契的学者，同时也教育、转化一些性格不尽相同的学者，由此形成一门一派内相对稳定的特色。这是禅门宗派现象的实质所在。慧南禅法谨严、执着，富有社会责任感，其门风壁立，鍜尽凡圣，手法多端，圆融无碍，首先是受其性格制约的结果，这是慧南思想和禅法的心理基础。
    按照慧南思想和禅法特色形成的过程，其一生的活动大致可分为三个时期：（１）从他十一岁出家到得慈明印可并开法同安寺之前，为参学悟教期。这一时期主要是博览同外经典，广参四方尊宿，吸收各家思想，学习各家禅法。（２）从开法同安寺，后又转住归宗、黄檗积翠，为禅法醖釀定型期。（３）治平二年（１０６２）入主黄龙寺后听八年，为禅法成熟期。此时四众归趋，法席隆盛，黄龙一派显于天下。显然，影响其思想和禅法特色的关键，是第一个时期。
    慧南初师的怀玉（山名，即今怀玉山，在江西玉山县北）定水庵智銮禅师，事迹已不可考，不能确知他在那里受到怎样的教育和影响。不过据载，慧南出家后，不仅广读佛教经论，而且“并习儒典，博通经史”，由此可见，慧南“三合一”禅学思想的基础是在青年时代即打好了，其内外兼修的学习风气也与他所处的时代风气相吻合。
    天禧四年（１０２０），慧南落发受具足戒，随后即开始游学参访，他首先来到庐山，接触到的第一位高僧是归宗自宝。据载，他来到归宗寺，正遇上“老宿自宝集众坐”，于是他依止自宝，且“时时询之”。
    归宗自宝事迹不详，从其“集众坐”来看，禅风颇近青原一系，有石霜庆诸“枯木禅”特色。慧南对自宝的禅法颇感兴趣，所以用心参究，“时时询之”。结果，他受到了很大的影响，从此“坐必跏趺，行必直视。”
    第二位对慧南禅风构成重要影响的禅师是庐山栖贤寺的澄湜。慧南辞自宝以后，即投其门下，“规模之三年。”
    栖贤澄湜是法眼宗僧人，百丈道常之徒，清凉文益之孙。法眼宗是入宋以来，先于黄龙宗而兴起的一个宗派，真宗以前特别兴盛，当时江西道场多有法眼僧人活动，法眼宗思想对外的倡儒佛融合（如永明延寿著《万善同归集》），对内讲禅净合修，百家并重（如文益《宗门十规论》第一次综合评述沩仰、临济、曹洞、云门四家宗风，论其短长），在禅法上，随机变化，恳切提撕，既不乏云门的箭锋相拄，也具有曹洞的谨严执着，同时法眼宗人的文化气息也很浓，特别喜欢拈提古则公案，澄湜即是一位以禅法精严，“进止有律度”而著称的僧人，他“性高简，律身精严，动不违法度。暮年三冬，藏经以坐阅为未敬，则立诵，”他也喜拈提公案，曾点校《赵州从谂禅师语录》，慧南对澄湜极为推重，曾评价说：“栖贤和尚，定从天人中来，丛林标表也。”当时慧南年方弱冠，又刚为“大僧”不久，正是精力旺盛，求学心切的时候，所以，他在栖贤之年，对法眼宗旨有深入的参究，并深受其影响，纵观慧南禅法，有很多方面与法眼宗相类似（谨严俊利、恳切提断、诸家融合、拈提公案等等），法眼宗接机应化有“箭锋相拄、泯绝有无、就身拈出、随流得妙”的“四机”，慧南宗法也是如此，法眼之祖玄沙师备有《宗纲三句》，总结接化学人经验，慧南三关即深受其影响（后面将详加论述），所以，惠洪说慧南“平生所为，多取法焉，”这是符合事实的。
    慧南离开栖贤澄湜之后，继续到南方各地参访，当他来到湖北蕲水，与当时住三角寺的云门僧怀澄相契合，怀澄认为他已经悟解，“一见器许之”，故慧南从此追随怀澄，并随其移住与祖道场泐潭寺，掌书记之职，代怀澄分座接纳，由于当时怀澄在丛林中很有些影响，慧南受此器重，故“南书记之名，一时籍甚”。
    不过，慧南在禅法上，没有继承怀澄，却改弦易辙，促成他改弦易辙的重要原因则是在泐潭期间，他结识了云峰之悦，文悦（９９７－１０６２）是临济宗大愚守之的徒弟，偏参四方尊宿，深得临济、云门爽快凌厉宗风，当时号为“佛法龙象”，文悦认为泐潭怀澄虽是云门之后，但已失去云门宗应有的险绝、凌厉之风，流于故弄虚玄，徒可把玩的文字游戏。所谓“云门如九转丹沙，点铁成金，澄公药汞银，徒可玩，入鍜则流去，”慧南对此论表示不以为然，文悦反诘他说：“云门气宇如王，甘死语下乎？澄公有法授人，死语其能活人乎？”在这样的情况下，慧南将信将疑地接受了文悦建议，准备去见“手段出诸方”的临济名僧石霜慈明。由于对文悦的意见一时未能重视，在前往石霜山的中途，听说慈明“不事事，慢诲丛林”，又改变主意，结伴随来到南岳，投于福岩审承门下做书记。
    福岩审承，号“贤叉手，”是曹洞宗人，当时名气相当大，有“老宿”之誉。慧南投奔福岩，很明显是为曹洞宗法而来，审承是明安大师大阳警玄的著名弟子，警玄善解经律和公案，有“十八般妙语”传世，对曹山“三种堕”（类堕、宝贵堕、随处堕）和偏正五位皆有心得，审承得其家传，宗法以谨严，细密著称，慧南佛法谂熟于曹洞宗旨，应与这段参学经历有很大的关系。
    如果说慧南未采纳文悦的建议从师慈明，使他丧失了一次接受临济正宗佛法鍜炼的机遇，那么审承圆寂，慈明继主福岩，又恰恰顷给慧南挽回了这个机遇。从此，慧南拜倒于慈明门下，皈依于临济佛法，并以振兴临济宗为已任。
    石霜慈明（９８７－１０４０）是汾阳善昭的上首弟子，临济七世，俗姓李，号楚圆。他的佛法是经汾阳融汇云门、沩仰特色而传承下来的，以机锋险绝，不容知解分辩，断尽偷情著称于时。当时丛林流行便软之风，慈明禅法可谓独树一帜，领袖禅林，慧南虽参法眼、云门、曹洞，禅风偏于缜密、执着、知解一路，并未断尽生死之根。所以他得慈明为师，是其佛法脱胎换骨的一个契机，由此，他彻悟圆融佛法，洞见五家宗趣，对后来的禅风形成意义深造。
    且看他初步接触慈明佛法时的那种感受：
    慈明既至，公望见之，心容俱肃。闻其论，多贬剥诸方。而件件数为邪解者，皆泐潭密付旨诀，气索而归。
    见称于泐潭怀澄，又以“书记之名籍甚”的慧南，对自己的禅法无疑自以为是，正是这个原因，他未重视文悦的意见而师事慈明，现在，他抱着验证文悦所言的态度，侧面观察慈明所为，不料，自己抱为秘诀的佛法，被慈明“件件数为邪解”，这岂不让他倒吸冷气，惊讶不已？翻思文悦之论，知自己错失良机，故当即痛下决心，“坚请入慈明室。”
    慧南在慈明处获得的最大悟解是断尽知见，消除妄念执着，反省泐潭怀澄玄妙有所寄寓的解说为死语，真正把握临济、云门宗旨和不落生死、鍜尽凡圣的险绝门风，他的解悟经历是这样的：
    慈明曰：“脱如汝会云门意旨，则赵州尝言：‘台山婆子被我勘破’，试指其可勘处。”公面热汗下，不知答，趋出。明日诣之，又遭诟骂，公惭见左右，即曰“政以未解求诀耳，骂岂慈悲法施之式？”慈明笑曰：“是骂耶？”公于是默悟其旨，失声曰：“泐潭果是死语。”厌偈曰：“杰出丛林是赵州，老婆勘破没来由。而今四海清如镜，行人莫以路为雠。”慈明以手点“没”字顾公。公即易之，而心服其妙。”
    按照慧南对佛法的体究，他本来可以就赵州勘婆子大讲一番“来由”，解释其“精义玄旨”，但知必定被慈明“数为邪解，”故有话不敢说，窘迫而汗下，第二天，他恭恭敬敬地向慈明讨教，却又遭其辱骂：说也不是，问也不是，慧南陷入无以自适的境地。正怨恨处，慈明给他轻轻的一点：骂果真是骂么？骂亦不是骂，乃是老婆心切，着意提撕。赵州勘婆，本无所谓勘破处。一切只是人情执解知见，何必强为之说，强为之问？这正是慧南当下所领悟，也是他认为“老婆勘破没来由”的根源，慧南一向是以有所得为悟禅的，这里已说“没来由”，是思想上由“有”至“无”的第一次大突破、大飞跃，是脱去凡情俗解有表现，但是，“没来由”也不可执着，否则与“有来由”一样成为执碍。可有可无，非有非无，非非有非非无，不落两边，纵夺自在，随心任性，方是真佛田地。所以慈明指点一个“没”字而注视慧南，意谓不可死执此字，慧南随即改“没”为“有”，并心服慈明之妙。这个“妙”不是执有执无之妙，而是解空落空之妙，是入道的真实境界，慧南境界实现第二次飞跃而回归自性本来南目——这里的“有”是“本有”，“本来具足”的意思，慧南已得石霜禅法之旨。
    至此，我们可以理解慧南以临济、云门为基调，兼融法眼、曹洞、沩仰之长的禅风，乃是其广为参学，会通各家的结果。
    下面再以黄龙三关为例作进一步的分析。
    三关是慧南在黄龙寺期间藉以支撑门户，建立宗派的重要设施，前面已论述其宗法旨要和所代表的特殊门风。三关是慧南在黄檗时创立的，《林间录》卷上对此有明确记载：
    南禅师居积翠时，以佛手、驴脚、生缘语问学者，答者甚众，南人瞑目如入定，未尝可否之，学者趋出，竟莫知其是非，故天下谓之三关语。
    这说明三关在黄檗时已有一些影响，所以慧南到黄龙寺便把它发挥为主要的门庭设施。这时，湖南、湖北、安徽等地僧人前来参学的很多，“出长沙百里，无托宿所”，参学僧人之多，影响之大，于此可见一斑。
    慧南何以能设立一个鍜尽凡圣，令丛林望而却步的三关？这是一个值得深入研究的禅学课题。我们认为，黄龙三关既有充分的禅学思想依据，也明显受其时代学风的影响，虽然独特不二，却也渊源有自。
    首先，三关所采用的三句格式，为佛教教义所常用，是佛家宗师说法的习惯模式。如诸行无常、诸法无我，涅盘寂静三法印，戒定慧三学，空假中三谛皆可称为“三句”，《大日经》更有“菩提心为因，大悲为根，方便为究竟”三句，且“十方三世一切如来，种种因缘，随宜演说，无非为此三句法门，”唐代僧无相联系（６８０－７５６）说法也有“无意、无念、莫妄”三句宗纲。所以，参三句、透三句、悟三句、超三句，在很早以前即是佛家的流行说法。百丈怀海禅师就曾将“不取于法，不取非法，不取非非法”三句作为参禅的要旨，认为“若透得三句过，不被三段管教家举，喻如鹿三跳出纲，唤作缠外佛。”正是这个原因，惠洪曾引百丈怀海的话来论述慧南三关与古德法式的渊源，他写道：
    大智禅师曰：“夫教语皆是三句相连，初、中、后善；初直须教染发善心；中破善；后始明善，菩萨即非菩萨，是名菩萨法，非法非非法，”……古大宗师说法，皆依佛祖法式，不知者谓苟然语。
    很清楚，慧南三关在基本形式上，是依“佛祖法式”的，其次第相开，环环紧扣的风格，与大智禅师（即百丈怀海）所说初、中、后三层次的菩萨法相一致。
    不过，黄龙三关又与三法印、三学、三谛及无相三句、百丈之句都有着本质的区别。前者是用以勘验学者而用心设计的“牢关”，而后者只是解释、体究佛法的三种境界划分，在这一点上，三关风格与禅家重视的所谓“向上一路”“末后一句”紧密相联，三关一过，即透得向上一路。所以洛浦元安所说的“末后一句，始到牢关，把断要津，不通凡圣”与慧南的“已过关者，掉臂而去，安知有关吏在”应是同一境界。
    此外，黄龙三关又与当时禅门风紧密相关。当时丛林，普遍关注接化方式，重视宗门旨要，著名禅师往往在接化手段，教育方法上各创新说，各立门户，历考晚唐五代及宋代禅师，当时以三句格式创设宗纲的人很多，较著名的则有临济义玄三句（三要印开朱点侧，未容拟议久宾分；妙解岂容无著问，沤和争负截流机；看取棚头弄傀儡，抽牵都来里有人）；岩头全豁三句（咬去啼住；欲去不去，欲住不住；或时一向不去，或时一向不住）；云门文偃三句（函盖乾坤，目机铢两，不涉万缘）；玄沙师备三句（开方便句，转位投机句，慈定问句）；德山缘密三句（函盖乾坤，截断众流，随波逐浪）；巴陵颢鉴三句（佛祖之师句，人天之师句，不可自救句）；汾阳善昭三句（着力句，转身句，亲切句）等等。其中全豁、文偃、师备、缘密、颢鉴五人，是德山宣鉴下三代以内的云门、法眼宗师，前后生活年代相去仅百余年（全豁死于公元８８７年，缘密约死于公元９８７年左右），可见立三句以显宗旨确是一种风气。
    细考这些宗师的“三句”语，可以分为三类；一类是对“如何是佛”等禅门问话的机锋就答，即所谓转语（如巴陵三句）；一类是对自己接化学人方法的归纳和总结、如临济、岩头、玄沙、首山、汾阳之三句；惟有云门、德山师徒的三句，是直接用于勘验学人的活语，相当于看话禅中的“话头”，而恰恰在当时丛林中最有影响的，便是这云门三句。代表云门险绝之风的所谓“云门剑”、“吹云剑”即由此三句而名重天下。
    慧南三关，正是在这种“立三句”的时代风气之下，吸收众家之长而独创出来的，直接的经验，取自云门三句的显然较多，不过，将三句改为三问，使它更具有针对性和威慑性，剑锋直指来参学者，这都是慧南的发展。当然，这种发展出很大程度上可视为汾阳善昭机语设问的延续（善昭有《诘问一百则》），但直接的影响，还可能与沩仰宗仰山慧寂的接引方式有关。《五灯会元》卷九南塔光涌章记载了慧寂二十余年以“和尚何似驴”一问接引学者，“二十年无决了者，”最后遇到南塔光涌，纔应机的事情：
    山曰：“和尚何似驴？”师（指光涌）曰：“某甲见和尚亦不似佛。”山曰：“若不似佛，似个什么？”师曰：“若有所似，与驴何别？”
无论设问的形式和内容，慧南三关都与仰山做法类似，很清楚地看出慧南三关在形式上受其启迪的迹象。
    临济五世首山省念禅师有著名的“竹蓖子”话，那是一个典型的二律背反问题，慧南三关的后面两关也都是矛盾的背反，由此我们又进一步见出其深层逻辑与思想内容之间的某种联系。黄龙三关对当时禅法的影响是积极的，当时丛林风靡古则公案拈提颂唱，参禅不离灯录典籍，不逾尊宿言句，囿于文字，死于句下，在所难免，慧南三问从参学衲子最常见、最普通的事情（生缘、手、脚）而设立，不关任何经典，却又深含禅机，所以它对于纠正时弊，促进禅家的活参妙解，是有重要意义的，三关一出，丛林顿觉耳目一新，立即引起各方关注和重视，这决不是偶然现象。
    有趣的是，文偃禅师就曾把自己的三句称三关。《五家宗旨纂要》卷下：“云门示众云：‘函盖乾坤、目机铢两、不涉万缘，作么生承当’？无无语。自代云：‘一镞破三关’”。此外，天台宗慈云遵式以三问考察学者对于《楞严经》的理解，也叫楞严三关，这些例子似与黄龙三关名称的来历不无关系。
    法眼禅师文偃之祖玄沙师备有“宗纲三句”，总结宗师接引学人、教化来参的三种句子，慧南三关在思想方法和相互关系的设计上，都深受其影响，接照玄沙的思想，“第一句，且自承当，现成自足，”“唤作开方便门。”它的用意是使来参学者“信有一分真常流注，亘古亘今，未有不是，未有不非者，”即去除学者凡心妄念，染发菩提善心，成就正见。它的特点则“只成平等法”，“以言遣言，以理逐理，平常性相，接物利生，”慧南第一关“人人尽有生缘，上座生缘在何处？”正是为了勘验学者有无出格之量，能否“更吃赵州茶”的“开方便门”句，其特色也是以言遣言，以理逐理，随缘设问，就当下实际，平常性相生发开来的“平等法”，没有半点故作玄奥，但实实在在勘验来机。按照玄沙的观点，对于这个第一句，“若如出格之量，不被心魔所使，入到手中便转换，落落地言通大道，不堕平怀之见。”也就是说，不以俗见知解作答，方能自然纵夺，这也如慧南之所言“但见日头东畔上，”便能“更吃赵州茶。”
    玄沙的第二句叫做“转位投机”，其特徵则在“回因就果，不著平常一如之理，”它是“二理双明，二义兼照，不被二边所动”的，所以第二句的用意在使人（或验人）断灭万法差别相，达于生佛不二、万法一如的境界，慧南第二关，“我手何似佛手”将我手（找指众生）与佛手（代指佛）互举，恰好是“回因就果”、“二理双明，二义并照”的。它要求人溟绝生佛差别，在生杀自在、纵夺随宜的解悟之境下，“迥脱色欲爱见之境。”
    玄沙第三句叫“慈定之门”，这里是禅悟最高境界，到此便可“明阴洞阳，廊周沙界，一真体性，大用现前，应化无方，全用全不用，全生全不生，”即达到纵任自由，无可无不可，超四句，绝百非的涅盘境地，慧南第三关“我脚何似驴脚”所要求于学者的也正是这样一个境界，所谓“妙用现前，应化无方，”所谓“通天下之情，尽天下之妙”，都是这一境界的不同表达。
    “三关”与法眼宗旨的密切联系，说明慧南早年在栖贤澄湜处的参学影响之深刻。当然，全面地看待三关，它与慈明的不容分解，甚至泐潭怀澄的某些影响也不可分。所以慧南弟子潜庵清源（１０３２－１１２９）说：“先师初事栖贤是（即澄湜）、泐潭澄历二十年，宗门奇奥，经论要妙，莫不贯穿，及因文悦见慈明，则一字无用，遂设三关语，以验天下禅者。”潜庵的这个评价是比较符合三关的实际情况的。


五、传承与发展

五、传承与发展

    慧南嗣法弟子８３人，再传弟子满天下，充分显示其宗法的旺盛生命力，对慧南宗法的倡导与发展影响较大的黄龙传人有祖心晦堂、宝峰克文、东林常总、云居元祐、隆庆庆闲、泐潭洪英（以上皆一传）；死心悟新、灵源惟清、草堂善清、兜率从悦、泐潭文准，寂音惠洪、荐福道英（以上为二传）；九顶慧泉、禾山慧方、长灵守卓、圆通道旻、拙庵佛照、山堂道震、典牛天游（以上为三传）；经山智策、万寿善信、育王介谌（以上四传）；丹丘道融、灵隐道枢、万年昙贲（以上五传）；以及天童从瑾、虚庵怀敞、明庵荣西等（见附录：黄龙宗传承图）。
    纵观黄龙诸传人，他们在思想观念、弘法实践上，大都具有自已的特色，这显然是受乃师强调独立思维，要求弟子“他人行处我不行”的教育思想的结果，正好慧南自己所说，是“这柱得与么圆，那枋得与么匾”。黄龙僧人的个性，构成其宗派的共性，这不仅是其势力强大的一个重要原因，也是其宗风不断发展变化的内在动力。
    １、黄龙三关的流变。
    三关给禅宗带来的影响是巨大而深造的，慧南以后，倣效或套用三关的人连续不断。慧南传人中，如祖心常举拳头问“唤作拳头则触，不唤作拳头则背，汝唤作什么？”开元子琦问“一人有口道不得姓字为谁？”死心问：“月晦之阴，以五色彩著于暝中，令百千万人夜视其色，宁有辨其青黄赤白者么？”隆庆庆闲更是不时变换问语，如：“祖师心印，篆作何文？”“诸佛本源，深之多少？”“十二时中上来下去，开单展缽，此是五蕴败坏之身。那个是清净法身？”等等，不一而足，慧南传人以外，如大慧宗杲即沿用首山省念方法，以竹篦子设问：”唤作竹篦则触，不唤作竹篦则背，不得下语，不得无语，速道！速道！”天童昙华则以柱杖子设问，如突然拈起拄杖子曰：“唤作柱杖，玉石不分。不唤作柱杖，金石混杂。”这些问话的共同特征即在摆脱任何经典和古则公案的束缚，从日常生活司空见惯的事情发问，且问话不故作深奥，表面答案则非此即彼，与禅家一向以来，喜从佛法奥义设问（如：“如何是祖师西来意，”“如何是佛”，“如何是和尚家风”，“如何是云门剑”之类）有着很大的区别。但是，这些问话又无不深含禅机，让一般人无法回答。很明显，是慧南三关促进了丛林对“活语”的运用，此一影响的深刻变化则是促成了“看话禅”的产生。
    我们知道，看话禅的特色是公案中的一个“话头”进行“活参”，活参的实质，即是围绕“话头”作穷根究底的体究，说穿了，还是围绕话头，自己设问，自己解问，最后将所有的问题化解在虚幻空寂之中，达到了悟的境界，如高峰原妙的著名话头“万法归一，一归何处？”即是一个典型的例子。很清楚，这是慧南活语设问运用于古则公案的结果。
    相对联于活语问话的流变来说，一些套用黄龙三关的作法，显然少了一些开创一，但它足以说明黄龙三关在丛林中的影响。例如宝峰真净克文时以三关接人，他的著名弟子泐潭文准即死于“我手何似佛手”一问之下。他的再传弟子兜率惠照（１０４９－１１１９）则创立兜率三关。一曰：“拨草瞻风，只图见性，即今上人性在什么处？”二曰：“识得自性，方脱生死，眼光落地时，作么生脱？”三曰：“脱得生死，便知去处，四大分离向什么处去？”元初，杨歧派僧人高峰原妙也立三关。一曰：“大彻的人，本脱生死，因甚命根不断？”二曰：“佛祖公案，只是一个道理，因甚有明与不明？”三曰：“大修行人，当尊修行，因甚不守毗尼？”明朝僧恕中无愠设瑞岩三关，还在当时很有影响。
    ２、由领众行道到韬光晦迹
    慧南佛法本来即有以世为入世的特征，且其思想基础落到老庄一路。这一特色经祖心、灵源而后，其老庄色彩更为浓厚，并形成颇为独特的韬光晦迹之风。
    祖心（１０２５－１１００）在慧南门下是最具影响，也最能传其家法的上首弟子。他俗姓邬，广东人，少年读书即闻名乡里，二十岁参加剃度试经，他别出心裁以诗作答，故一出家就受人器重。受具足戒之后，偏参四方尊宿，经慧南着意提携，了悟大旨，祖心禅学，追求一种虚静淡泊、圆融无碍，任性逍遥的人生情趣，黄庭坚说“黄龙心老，盖庄子所谓伯昏瞀人之流。”慧南死后，他接掌黄龙寺住持十二年，但他“不乐从事于务，五求解去”，最终得闲居“晦堂”，他乐守空寂，厌于俗务的思想甚于乃师，如曾有一段评议住持的话：
    马祖百丈已前无住持事，进入相寻于空闲寂寞之滨而已。其后虽有住持，王臣尊礼谓人天师，今则不然，挂名官府，如有户籍之民，直遣五百追呼之耳，此岂不复为哉。
    祖心的这种思想与其乃师领众丛林行道的思想，区别是明显的，这对当时禅宗构成影响，一大批僧人接受了他的禅学精神和人生态度。他的上首弟子来源则进一步把这种思想纳入禅学理论。
    灵源惟清（？－１１１７）江西武宁县人，俗姓陈。延恩法安称他是“苦海法船”，黄庭坚则有“灵源禅师人天眼”的诗句，灵源禅法极重实践功夫，力主学人要守空知寂，心如死灰，形如槁木。他也不喜出世做住持，多次拒绝当时达官士人名山大刹之请，称疾居“昭默堂”中，“颓然坐一室”。他针对当时丛林热衷于俗务，执着于功利的现象，进行批评，认为这是禅门宗师教法不严所致，他说：
    今日学者，未脱生死，病在什么处？在偷心未死耳。然非其罪，为师者之罪也。……古之学者言下脱生死，效在什么处？在偷心已死。然非学者自能尔，实为师者钳
鎚妙密也。
    灵源对遁迹守寂的提倡是不遗余力的。他临死前自作《无生常住真归告铭》一篇，即是显明的例子。中云：“吾委息（即圆寂）后，……慎勿随末法所尚，乞空文于有位，求为铭志，张饰说以浼吾。至嘱！至嘱！！”
    以祖心、灵源为先导，黄龙高僧韬光晦迹，退隐山林之风一时相当普通，例如东林常总（又作常聪，１０２５－１０９１）禅法称雄一时，住泐潭寺，人称“马祖再世”，朝廷诏他“革东林律寺为禅”。他听到消息，连夜“遁去千余里，南昌太守王韵不得不下檄文寻找，总把他从新淦（今江西新平县）的大山沟请来应命。此后，他的东林寺名重朝野，“僧徒万指”，神宗又诏他进京住大相国寺（当时京城开封最重要的皇家寺院），“州郡敦遣急于星火”，可是他丝毫不为所动，“固称山野老病不能奉召，”朝廷对他无可奈何，益加钦重，特赐封他为“广惠”禅师。此外，如真净克文（１０２５－１１０２）不肯住金陵而住洞山，云居元祐（１０３０－１０９５）不受朝廷紫衣。黄龙德逢（１０７３－１１３０）是灵源的弟子，“英声藉藉著丛林间，”他先后两次固辞洛阳天宁寺和杭州天竺寺，安居云岩、黄龙、开福这些山间丛林。
    远离都市，退隐山林，本是自达摩以来的禅门风气。但这种风气自晚唐以后渐渐消失；五代宋初，汾阳善昭创内护外护之说，丛林遂以构附权贵为能事（慧南之师石霜慈明就曾颇费苦心地结交杨大年、李助等朝廷显贵），退隐之风已荡然无存。到慧南黄龙宗后，此风为之一变，他们也结交权贵（也有少数僧人如兜主从悦依然苦心交结权贵），但他们更“不肯低头拾卿相”（黄山谷评惠洪语汇　　），他们与士大夫交往的原则是“意合则千里应之，不合则数舍亦不往，”保持禅家应有的虚静和自尊。
    黄龙宗的此一风气，对当时禅宗有很大触动，对宋以后禅风的发展产生深刻的影响，元明以后，禅宗逐渐向功利禅和山林禅两路分化，其根源则直接来自黄龙僧人的隐晦之风。此外，隐晦之风也给黄龙宗法的传承与扩展带来重大的影响。
    黄龙宗自慧南以下三代，的确高僧辈出，人才济济。但由于韬光晦迹的风气，很多真悟妙解的宗门法器隐于山林小刹，事迹不为人知，这是黄龙派法席自第四传以下即迅速减弱的一个重要原因。以当时黄龙僧人的修行，如果愿意到大都市倡法，追随者必致繁盛，法席何愁不传（如上引克文、德洪、还有慧照、道震等都是）？但黄龙僧人只重佛法本身，厌根未执着于宗派法系的传承。相形之下，与黄龙派对峙的杨歧派作风就大不一样，所以明人净柱说：“临济宗自宋季稍盛于江南。阅元明，人宗大匠都有，而韬光敛瑞，民莫得传，”这正是黄龙派的实际情况。
    顺便一提，黄龙宗的法绪自宋迄元明而清，并未断绝，死心下灵源一系，经长灵守卓、育王介谌、万年昙贲、天童从瑾、虚庵怀敞而由明庵荣西传往日本、建立日本最早的一个禅宗宗派，对日本禅宗的发展影响深远，至今拥有众多的传人。此外，黄龙宗祖庭黄龙寺，历代香火不绝，法脉传承有序，至明万历间，住持已传四十七人。清康熙中，冰鉴禅师为住持，创佛印、教海、南禅三院，门徒多至五百众。元明以后，赣西北以及湘、鄂、闽累邻地区的一些山林道场多有黄龙派僧人活动。康熙时，黄龙寺所属庵刹达四十八所。乾隆二十七年（１７６２）黄龙寺僧修撰《黄龙崇恩禅院传灯宗谱》（上、下两大卷），收录许多关于黄龙宗的资料，为我们重新研究黄龙宗史提供了十分宝贵的资料。
    ３、无学之学与士大夫禅悦之风。
    在提倡韬光晦迹、退隐山林的同时，黄龙宗人对佛法本身的精勤执着之风不灭。他们发展了慧南禅法文人化倾向，关注经论教义，提倡语言文字，又融通内外经典，使禅进一步圆融恢谐、辩驳无碍。
    祖心仍然是一个突出的代表。他首先是重视能禅要亲身体验，强调自性自悟，反对故弄玄虚，流于口舌，他说：“三乘十二分教，还同说食，示人食味，既因他说其食，要在自己亲尝，使能了知其味是咸是淡是甘是辛。”在这个前提下，他主张广参百家，偏揽俗学，涉猎诸艺，提倡禅学的文人化，他自己“虽在僧次，常勤俗学，”博通内外典籍，“众中号为多能。”他把这种修行工夫称之为“无学之学”，并说“但有纤疑在，不到无学，安能七纵八横，天回地转，”即无学之学的境界在内外贯通、纵横无碍，更无半点疑滞。这是一个很特殊的要求。但黄龙高僧，却有很多人是这样说和这样做的。
    黄龙传人中，有一大批人深究佛典，精通教义。其中如死心、克文、庆闲、常总、元祐、文准、进英、道旻、惠洪等人，早年多从律师出家，都有雄厚的义学功底，但他们后来都有一致地放弃义学，在南方丛林广参尊宿，最后达于无纤芥疑滞的无学境地，形成纵横开合，机锋俊利的禅风。
    真净克文（１０２５－１１０２），河南陕县人，俗姓郑。他早年即以经论玄义负盛名于北方。“经论无不臻妙，夺京洛讲席，自为主客而发奥义者数矣，”在慧南门下，号“伟异博大者。”但他后来广涉儒道之书，反而“沮坏义学，剖发幽医，以乐说辩，洗光佛日。”克文弟子泐潭文准（１０６１－１１１５），四川人，八岁即出家习《法华经》，少年时已经对经义“伸辨详明，”后又“遍游成都讲肆，介诸部纲目。”但他后放弃义学，潜心修行，终于豁然贯通，开堂说法，“词辩注射，迅机雷扫，衲子畏而慕之，”门下常“数千指”。他常说：“我只畜一条拄杖，佛来也打，祖来也打，不将元字脚涴汝枯肠。如此，临济一宗不致冷落也。”看来他还是以荷担佛法，振兴临济为已任的。
    死心悟新（１０４４－１１１５）是祖心晦堂弟子，韶州（今广东曲江）人，俗姓黄。于经论玄义。“谈辩无所牴牾，”后祖心教育他“直须死却无量劫来偷心乃可耳”，所以他自号“死心”以申其志。他通会超脱之后，“迅机逸辩，雷轰电扫，学者莫敢婴其锋，”黄庭坚所他与灵源称为“衲僧之命脉，今江湖准浙莫居二禅之右者，”“脊骨硬如铁，去住自由，今天下道人中，一人而已”。此外，如“智辩自恽，气出诸流”的云居元祐，号称“铁嘴”的花药进英等人，参学方法与禅风都略相似。
    放弃义学，贯通佛法的一个重要内容是引俗学入佛学，以儒、道思想糅佛说，这正是黄龙僧人“无学之学”中所作的一项“实际的修行工夫”。所以“虽以见性为宗，而随方启迪，故摭内外收之要，指微诘妙开示，使人因所服习，克山自观。”当时丛林有对他们以外书糅佛说提出非义者，祖心驳之说：“若不见性，则佛祖密语尽成外书；若见性，则魔说狐禅皆是妙语。”这就是说：在贯通俗学、融摄儒道中，佛家只要留下“见性明心”这块最后的领土，便可以在天地万物之间拥有纵横驰骋的广阔原野。
    这是禅宗变化的重要消息所在。由此，禅便完全与俗人打成一片，出世与入工怕界限被彻底摧毁，修禅学道反变得简单易行而又充满人生乐趣，的确，站在佛家的立场来看，这种变化似乎有违佛法教义的“纯洁性”，但是我们已经说过，三教融合是宋朝社会制度下思想发展的潮流，佛家吸取、融汇儒道，是惟一可取的生存、发展模式、从这一点上说，黄龙僧人可谓识时务者。
    正是这个原因，黄龙僧人的禅法受到文人士大夫的激赏，以此为契机，宋代文人士大夫的禅悦之风随之而起。
    且先看看这样的变化：“熙宁以前（即１０６８年前），洛中士大夫未有谈禅者，”可见这时尚未形成禅悦之风。大约过了四五十年月日，这样的情况出现了：
    妇人孺子，抵掌嬉戏，争谈禅悦，高者为名，下者为利，余波末流，无所不至。
    短短几十年间，何以产生这样巨大的变化？我们不能不对禅悦之风陡然兴起的原因产生极大的兴趣。诚然，一个席卷全国的文化现象的出现，原因应该是多方面的、复杂的，但在这众多的原因中，我们不难看到一个相对清晰，且完全可能是最重要的原因——这便是上面所述黄龙宗的崛起和黄龙僧人对世俗化禅学的提倡。
    神宗熙宁以后到哲宗、徽宗的几十年内，正是慧南禅法鼎盛，黄龙一派呈波涛涌沸之势的关键时期，由于黄龙僧人对儒、道思想的融汇，为文人士大夫了解、掌握佛教，参禅学道，打开了一条便捷之路。加上简便的禅法和富有神秘色彩的机锋，给文人士大夫以强烈的吸引。所以，当时最著名的文人士大夫如王安石、周敦颐、潘兴嗣、程师孟、吴恂、王韶、苏轼、苏辙、黄庭坚、戴道纯、蔡京、范致虚、吴居厚、彭汝霖、徐府、张商英、胡安国一大批人，纷纷与黄龙僧人结交，他们或推举相资，往来寻访，或恭迎宅下，谈玄论道；或寄意林间，诗书相酬。黄庭坚、戴道纯、张商英等人，甚至累月累年静居寺内，日夕与僧人相随。所以如祖心，本不热衷于结交仕人，但“四十年间，士大夫闻其风而开发者众矣，”灵源虽晦迹，临川太守朱世英特为他造昭默堂，迎居以度晚年；二人相与论禅。苏东坡、黄庭坚等人与黄龙僧人的放地多交往，在当时都作为文坛佳话广为流传。总之，北宋中后期文人士大夫与黄龙僧人交往人数之多，关系之密，相契之深，在禅宗史上是从未有过的，这是黄龙宗与禅悦之风的重要关系所在。
    禅悦之风在中国思想，文化史上的意义不可抵估。概括而论，它至少在三个方面产生重要的影响，第一，圆融无碍的思维方式，强烈吸引着人们的思想，整个民族思维方式在不自觉中接受了禅家的影响；由此，人们的价值观念、人生理想、生活情趣都发生一些微妙的变化；至少，以禅为体，以道为质，以儒为用的思想体系和处世哲学，在宋以后中国文人士大夫中有广泛的影响。第二，禅悦之风，使三教合一得以圆融自足，它直接促成了宋明理学的产生；理学奠基人周敦颐与慧南、祖心、常总等人都有交往。周敦颐的思想，与东林常总的实相圆融理论密切的相关。第三，禅悦之风使禅家于生活日用中修行的思想，迅速扩散到各种文化领域，影响宋以后的文化精神、艺术观念。中国文化史近千年以来，始终贯穿一条追求禅境、禅味的发展线索，即是这种影响的结果。


六、惠洪禅学

六、惠洪禅学

    在黄龙诸徒中，惠洪是一位最值得重视的人物，他的禅学思想和禅史研究，对后呓影响很大。
    惠洪（１０７１－１１２８），一作慧洪，后改德洪，字觉范，赐号宝觉圆明禅师，自称寂音尊者，明白庵人。筠州新昌（今江西宜丰县）人，俗姓喻。惠洪一生颇为坎坷曲折，十四岁父母双亡，因失恃而到三峰寺作童僧。他天资颖悟，每天能记下数千字的文章，三峰寺藏经为遍览。十九岁试经得度后，修《惟识论》，”臻其奥“，同时博观了史，外习诗收，并有诗名。后入黄龙二世真净克文堂室，彻悟于汾阳公案之下，二十九岁后到南方各地参访游学，住持过北禅寺（江西临川）、清凉寺（南京）。惠洪一生执着于佛教，始终以弘扬佛法为已任，不忘“以法惠人。”他又“好论古今治乱，是非成败，”常“野服萧散，以文章自娱，”所以往往与世俗不相容合。由此，他先后三次蒙冤入狱。又被流放海外（今海南一带），备尝人生颠沛之苦，“出九死而仅生。”
    惠洪以博极群书，了无滞碍之长，“发挥经论，光辅丛林”，故其著作丰富而“言满天下，”有“今世融肇”的美誉。丞相张商英称他是“天下之英物，圣宋之异人”。据南宋乾道年间（１１６５－１１７３）云门僧人石室祖琇《僧宝正续传》卷二记载，惠洪著作有《林间录》二卷、《僧宝传》三十卷、《高僧传》十二卷、《智证传》十卷、《志林》十卷、《冷齐夜话》十卷、《天厨禁脔》一卷、《石门文字禅》三十卷、《语录偈颂》一编、《法华合论》七卷、《楞严尊顶义》十卷、《圆觉皆证义》二卷、《金刚法源论》一卷，《起信论解义》二卷，凡十四种，一百二十七卷又一编，另外尚可见录的有《临济宗旨》一卷、《合古辙》二卷、《易注》三卷、《甘露集》三卷共计约一百六十卷，这样多的著述，在宋以前不立文字的中国禅宗史上是绝无仅有的，可惜这些著作大多已不传，目前可见比较完整的。仅《林间录》、《禅林僧宝传》（即《僧宝传》，其后附有《临济宗旨》一文），《冷齐夜话》和《石门文字禅》、《天厨禁脔》、《智证传》几种。
    《林间录》二卷，大观二年（１１０７）成书，是一部以丛林见闻为内容的杂录，虽不限一人一事一地一科，也无年代先后编次，但所记“莫非尊宿之高行，丛林之遗训，诸佛菩萨之微旨，贤士大夫之余论”。所以书中大量保存了当时禅宗人物的趣闻轶事和传记、行状、文集、语录、灯录以及惠洪本人言行的原始资料，对研究宋代佛教，具有重要参考意义，《僧宝传》三十卷，成书于宣和六年（１１２４），可说是惠洪禅学的代表之作，书中辑录唐末以来禅门各家宗师“斩然绝出者”八十一人，记录其平生简历，参学行事始末，机缘语句和思想言论，各为一转，传末附以简短的评论，“行其褒贬”。《冷齐夜话》十卷，形式略似《林间录》，但内容以论诗书等艺术居多，其中也有不少僧人事迹和言论，可与《林间录》互参。《石门文字禅》三十卷，又称《筠溪集》，是转录诗词偈颂、墓志碑铭、信札题跋等的合集，有《自序》述生平事迹较详。
    惠洪于著述，颇具深刻意旨，尝自云：“余涉世多艰，盖其夙障。闻曼殊舍利言：以法惠人则罪自灭，故有撰述佛祖旨诀之意，欲以惠人而自灭夙障耳，非有他求也。”特别是《僧宝传》，从形式到内容都反映了他的禅学精神。长沙侯延庆《僧宝传引》中说“其识达，其学诣，其言恢而正，其事简而完，其词精微而华畅，其旨广大空寂，窘然而深矣。”广大深寂之旨究竟是什么，这里未明说，但引中介绍说，《僧宝传》是在达观昙颖（临济七世）一部记录五家宗师机缘语句的脚本上发展而成的，可见其基本的用意有五家宗风，所以明僧达观（紫柏老人）说：“五家宗派，各有宗纲，宗纲一得，则杀活在已，凡圣莫测。至于家里人，虽数千里外，一言相闻，便能鉴定是某家儿孙，宁令野狐外道群起为妖祥哉。此觉范著书意也。”惠洪为僧人立传的标准极高，与当时灯录的广揽博收恰成对比，《僧宝传》与《高僧传》习禅篇形式上略似，但内容、风格明显不同；作为一个虔诚的禅师，他只为禅门宗师之传，此其一；《高僧传》言辞质而艰涩，惠洪之言则如行云流水，了畅无碍，入情入理，此其二；《高僧传》多记事迹功过，价值取向侧重于世俗，惠洪则集中记载观点、言论，“入道之缘，临终之效”，用意在为禅门树立典型，拯治末法之弊，价值取向完全在僧人对佛法的契悟，此其三；《高僧传》有“系或论”，惠洪用“赞”，形式上是借鉴前者，但评述的内容各有测重，此其四；宋戴良《重刊〈禅林僧宝传〉》说：“觉范尝读唐、宋《高僧传》，以道宣精于律而文非所长，赞宁博于学而识几于圆，其于为书，往往如户昏按检，不可属读，乃慨然有志于论述”。可见，惠洪为僧人立传，意不仅在史，更重在“识”、“见”的“论述”，通过这种以史实为基础的论述，使“祖师大统大易之道”，“诸纲目无有弗备”，达到其“以法惠人”的目的。所以惠洪之作是取精用宏，以少胜多的，这是他的高明之处，也是他的著作历来受到重视的原因所在，《僧宝传》和《林间录》间世以后，在丛要中引起巨大反响，倣效、接续之作不断产生，其中如《林间录》一类的宗杲《宗门武库》、晓莹《罗湖野录》、《云卧纪谈》，道融《丛林盛事》、圆悟《枯崖漫录》、无愠《山庵杂录》等。如《僧宝传》一类的则有祖琇的《僧宝正续传》、宗杲的《正法眼藏》、自融、性磊《南宋元明禅林僧宝传》等等。惠洪的禅宗史学评论，在这些后续之作中都是具有权成性的。自融盛称《僧宝录》与《五灯会元》二书“同为禅林之龟鉴”，推崇备至，无以复加。由此我们看到惠洪作为禅宗史学家所占有的重要历史地位。
这里，有一段历史公案，即禅宗史上两个道悟之争的问题，涉及惠洪治学态度和历史形象，必须加以说明。
  据说，惠洪曾提出青原行思下的天皇道悟禅师（云门、法眼二宗出其下），本为马祖下天王道悟，所以五家传承世系中，云门、法眼二宗应归于南岳之下，由此，引起数百年禅宗史学界“行思——天皇”与“马祖——天王”二说的长期纷争，直到清康熙六年（１６６７），杭州白岩寺净符者《法门锄宄》，始以详尽的史料和严密的论证，得出“马祖——天王”说是门户之见下凭空捏造的一种伪说，天王道悟子虚乌有。此后，禅宗史学界便有人认为惠洪是天王伪说的捏造者，并由此而怀疑惠洪的治学态度，颇多微词。
    然而，这对惠洪却是一个莫大的机会，因为事实上，捏造天王道悟的人不是惠洪，而是与惠洪同时代的另一禅师达观昙颖，况且，惠洪当时对昙颖之说，也明显持怀疑态度，他自己著述五家宗派源流时，仍然坚持天皇道悟出自青原法系的正确主张，并未受到昙颖伪说的影响。后来一些怀着某种私心的人，强把惠洪的推作伪说的代表，使这位具有真知灼见的禅宗史家蒙受不必要的冤枉。
    两个道悟之说出自达观昙颖，惠洪当时记载得相当清楚。《林间录》卷上云：
    荆州天皇道悟禅师，如《传灯录》所载，则曰道悟得法于石头，所居寺曰天皇，……及观达观禅师所集《五家宗派》，则曰道悟嗣马祖，引唐丘玄素所撰碑文几千言，其略曰……。考其传，正如两人，然玄素所载，曰有传法一人，“崇信住沣州龙潭。”南岳让禅师碑，唐闻人归登撰，列法孙数人于后，有道悟名。圭峰《答裴相国宗趣状》，列马祖之嗣六人，首曰“江陵道悟”，其下注曰：“兼禀径山，”今妄以云门、临济二宗竞者，可发一笑。
显然，惠洪这里是就亲眼所见关于道悟的两种说法提出自己的疑问，有存疑备考的意思。“马祖——天王”说的提出者（按，亦即伪造者）明明白白是达观昙颖，惠洪并未提出天皇（或天王）出自马祖的主张。惠洪之后，《联灯会要》、《嘉泰普灯录》、《五灯会元》几种重要的禅宗著作相继问世，也不取天王道悟一说，更没有人认为“马祖——天王”说是惠洪主张。
    事实上，惠洪在两个道悟说上，是主张“行思——天皇”说的，这可以从他的代表作《禅林僧宝传》看得相当清楚。宣和六年（１１２４）《僧宝传》成书之初，惠洪请他的友人长沙侯延庆为之作序，序言开头便说：
    觉范谓余曰：“自达摩之来，六传至大鉴，鉴之后析为二宗；其一为石头，云门、曹洞、法眼宗之；其一为马祖，临济、沩仰宗之。是为五家宗派。”
这难道不足以代表惠洪的观点吗？
    再从《僧宝传》所记内容来看，卷四法眼系“福州玄沙备禅师”传末记载玄沙法系盛况后说：“石头之宗”，则道悟嗣法沙师备是天皇道悟不正传，称玄沙中兴“石头之宗”，则道悟嗣法石头已在不言之中。所以，惠洪对云门、法眼与青原的渊源关系是完全肯定，不曾怀疑的。他在《林间录》记载两个道悟之说，是“每得一事，随即录之”的结果，只具有资料性，而不是史学结论。作为一个忠于佛法，并欲“以法惠人”的禅师，他这样做，是出于对宗法的负责，正是严于治学，慎于治学的表现。可惜的是，这个资料，被后来一些主张“马祖——天王”说的人所利用。南宋智昭《人天眼目》载有署名为“觉梦堂”的《重校五家宗派序》一篇，倡“马祖——天王”说，并以“寂音尊者亦尝疑之”作为立论依据之一。此后，元、明以降，凡主张天王说者，往往就惠洪所记添油四醋，为已所用，以至人们误以为惠洪就是“马祖）天王”说的炮制者，如今人有的著作即认为明代汉月法藏倡“马祖——天王”说，是“弘扬慧洪重新厘定的禅宗的五家系谱”，把“马祖——天王”伪说归于惠洪。还有的将《人天眼目》所载《重校五家宗派序》的“著作权”由“觉梦堂”转到惠洪。让惠洪来承担“马祖——天王”伪说的全部责任，实是冤枉，日本学者忽滑欲快天说很好：“五家系派之争，……占妄论之首位者，达观昙颖也。”
    惠洪对禅宗理论的研究和整理也是具有重要意义的，他关于文字禅的理论和宗法要旨的思想，都对后世产生深刻影响。
    （一）“文字禅”理论。
    禅宗史上，一般把惠洪的禅学称之为“文字禅”，而且颇遭非议，有“葛藤”之讥评。诚然，按照禅家自性自悟的主旨，束缚于文字言句，是不利于佛法体悟的。但是客观地、历史地审视惠洪的文字禅思想，可以发现很大程度上，人们曲解了惠洪的本意，文字禅的存在，不仅是必然的，而且是必要的，它对宋以后禅宗的发展，影响是极为深刻的。
    中国早期禅学，并无排斥文字的理论，达摩时期，推重《楞伽经》，此经中即有“宗通”和“说通”之论，把语言文字视为人度脱的方便取巧之什（工具）：
    大慧宗通者，谓缘自得胜进相，远离言说文字妄想，趣无漏界自觉的自相。
    说九部种种教法，离异不异、有无等相，以巧方便，随顺众生，令得度脱，是名说通相。
这可谓是禅宗对语言文字问题所持态度的原始依据。由此来看，禅家并不否定文字在佛法中的作用，它强调的只是要人不执着于文字言句表面，直接解悟佛理，“自得胜进。”
    但禅宗发展到成熟时期，越来越强调远离文字，所以形成教外别传，不立文字的宗旨，禅宗的实际创始人六祖慧能对语言文字问题的基本观点是：
    一切经书，及诸文字，大小二乘，十二部经，皆因人置，因智慧性故，方能建立，若无世人，一切万法，本无不有，故知万法本自人兴。……三世诸佛，十二部经，在人性中，本自具有。在这样的观点前提下，人们对待语言文字问题，便采取不置可否、若即若离的态度。然而，自晚唐五代以来，随着僧人的士大夫化，禅宗事实上越来越重视语言文字的运用，禅门宗师，往往就自己对宗法的理解和接引学者的经验，创设一些宗法的理论（如五位、四句、料简、照用之类），就其实质而言，这些理论很大程度上，是关于语言运用的一些法则、技巧，只是囿于成见，一般都不从正面论述语言文字罢了。这样，语言文字对于禅宗便处于实际上不可离之须臾，而理论上却没有正常“名份”的尴尬境地。随着时间的推移，前代宗师的宗法理论，渐渐被人们曲解或遗忘，生般硬套，以致丧失宗纲的现象在所难免，加上宋朝实行试经度僧制度，一些僧人囿于经论言句，不能自我解脱的现象也很多。以此为契机，禅宗内出现了一股重口传心授，执空传空，故作神秘而反对语言文字，谤经毁教的激进思潮。流风所及，大有抛弃经论，辗轧文字的势头，走向另一个极端。
    惠洪文字禅的理论建设。就是在这样一个背景下完成的。所以，他有这样的言论：
    禅宗学者自元丰（１０７８－１０８５）以来，师法大坏，诸方以拨去文字为禅，以口耳受授为妙。
    枝词蔓说似辩博，钩章摘句似迅机，苟认意识似至要，懒惰自放似了达，始于二浙，炽于江淮，而余波末流，滔滔汩汩于京洛荆楚之间。
    惠洪文字禅理论首先是正面论述了语言文字与佛法的关系，他说：
    大法非拘于语言，而借言以显发者也。
    心之妙不可以语言传，而可以语言见，盖语言者，心之缘，道之标帜也，标帜审则心契，故学者每以语言为得道浅深之候。
    这里，首先否定了佛法“拘于语言”的观点，还语言文字以“工具”之本源，没有半点含糊，然后谈语言与佛法的关系：语言文字是心性佛法的“标帜”，是心之“所缘”，这是第一层；审察语言文字这个“标帜”、“所缘”，便可契悟心性、佛法这个“缘”，所以通过经论典籍，文字言句，是可以体究清净佛法的，这是第二层；人的得道深浅，表达在语言文字之中，成为发言者心性的一种“标靶”——“候”，即符号，从这个“候”中，又可了解发言者是否已经彻悟本性，这是第三层。
    在禅宗思想史上，对语言文字作用问题作如此全面，深刻的论述，还不多见，它直接揭示了宗教与语言文字，在作为人类语言符号时的本质一致性——惠洪所说的“显发者”、“见”、“标帜”、“候”，都是从符号意义上使用的。事实上，宗教与语言也只有在“符号”的深层上纔具有相通性，这是现代人文科学揭示的基本原理。惠洪在九百年前能有如此见解，是难能可贵的。他实际上解决了语言文字在禅学中的作用和地位这个理应解决但又一直没有解决好的问题。从此，语言文字结束长期以来没有正当“名份”的状况，堂而皇之，取得了与佛法互为表里，同生死、共存亡的地位。
    考察惠洪关于语言文字思想的渊源，很明显受到早期禅宗楞伽思想的影响，与如前所述“说通”观一派相承。事实上，他的“标帜”说也与楞伽思想密切相关，《楞伽经》早就有以指示物来比譬文字、佛法关系的先例。如：
    大慧，譬如有人为示人物，以指指示，而彼愚人即执著指，不取因指所示之物。大慧，愚痴凡夫亦复如是，闻声执着名字指故，乃至设命终不能舍文字之指，取第一义。
    如痴见指月，观指不观月。计著名字者，不见我真实。
这显然是惠洪“标帜”理论形成的基础。
    当然，“标帜”之说也与惠洪所处时代的禅学思想有关，当时不少禅师即以珠光、月影、目击道存等例子来形容佛法不即言句，不离言句，青原五世僧九峰道虔并说：“借一句子是指月，于中事是话月。”这与惠洪思想完全吻合。
    至于肯定语言文字作用的思想，则更多地来自对唐末五代以来禅门倡法实践的总结。其中，与黄龙僧人对语言文字的重视尤为相关。黄龙慧南已有末法时代不免言说，“晚学初机，需得明明说破”的观点，黄龙祖心则从佛法必须亲身体验的角度，肯定了文人士大夫从文字言句中体悟佛法的作法。同时，他也强调了佛法因文字而显的观点。他说：
    佛法因文字而显，要在自己亲见，若能亲见，便能了知目前是真是妄，是生是死。既能了知生死真妄，反观一切语言文字，皆是表显之说，都无关义。
这里，可以清楚地看到惠洪思想与黄龙宗的关系。
    惠洪关于语言文字是佛法“标帜”的思想，是他的“文字禅”理论的重要基础。对于唐宋以来很多宗师的宗法理论，他往往用这一思想去理解，如他曾这样解释临济宗的“三玄三要”宗旨：
    所言一句中具三玄，一玄中具三要，有玄有要者，一切众生热恼海中清凉寂灭法幢也，此幢之建，如涂毒之鼓，挝之则闻者皆死。
    这里所谓“热恼海中清凉寂灭法幢”，显然即清净法性，佛性、如来藏。涂毒之鼓是一种涂有毒的鼓，闻鼓声者致死，惠洪把以语言文字所显示的清净佛性比作涂抹在鼓上的毒药，毒药虽不是鼓的本身，但却依附在鼓上，将鼓一击，闻者遭毒——这与语言文字的标帜，符号思想完全一致，与此一思想相适应，惠洪进一步整理，完善了禅家运用语言文字的方法论，其中之一即是“死句”、“活句”观点，认为“语中有语名为死句，语中无语名为活句”，禅家发言应是活语，后学参禅也应参活句。
    活句之说，或始自青原五世夹山善会（８０６－８８１），他评石霜、岩头禅风云：“石霜虽有杀人刀，且无活人剑；岩头亦有杀人刀，亦有活人剑。”临济六世的叶悬归省也曾说：“此宗门中，亦能杀人，亦能活人。杀人须得杀人刀，活人须得活人句。”此后云门宗人发展了这个观点，惠洪的死句、活句观，即直接来自云门二世洞山守初。此外，慧南参石霜慈明，也是悟得“泐潭果死语，”可见死句活句论是一种流行观点。
    与活句论密切相关，惠洪又指出禅僧参学，“不可句中驰求，”以防“死于句下”，既然佛法是言语的标帜，不是言语本身，当然不能采取通常那种训诂、解析法，从言句之中寻求佛法。所以，“若是学语之流，不自省已知非，直欲向空里采花，波中取月，”“若向句中作意，则没溺汝学人，”由此可见，惠洪文字禅理论，作为其融汇百家而又自我发展的产物，是独立完整、自成体系的。
    （二）宗法要旨研究
惠洪对五家以来各派宗法旨要的关注也是很有价值的。首先，他对五代以来各宗师对宗未能的发展进行了系统的整理，如《僧宝传》对曹洞、云门、法眼、临济、沩仰各派宗法均有总结，特别是对临刘、曹洞二派，内容涉及临济三句、四句、料简、照用、宾主及五位君臣、三种渗透、宝镜三昧、三种堕等，这些内容成为后世研究五家宗旨的最好资料。
其次，他批评当时丛林错解宗门法要，不识宗眼的现象，并在此基础上，汇通各家宗旨。如他批评了荐福承古（云门四世）等人，按平实商量去解释“三玄三要”的错误，承古认为，“三玄三要”是古德法门，汾阳善照颂“三玄三要事难分，得意忘言道易亲，一句明明该万象，重阳九月菊花红”是就其中“三玄”先总后分依次颂唱的，所以立“三玄”名为玄中玄、体中玄、句中玄，并认为此“三玄”即亦沙师备的《宗纲三句》中的“三句”——第一句即句中玄，第二句即意中玄，第三句即玄中玄。惠洪认为，“三玄三要”玄、要互举，不可强分，是临济宗所立宗纲，与黄檗（希运）大机大用、岩头（全豁）雪峰（义存）的陷虎却物用意相同。此外，荐福承古对临济、云门的棒喝机锋颇有微词，认为一切言句棒喝，以悟为则，学者下劣不悟道，但得知见，知见是学，成非悟也。所以“认言句作无事、作点语、作纵语、作夺语、作照、作用、作同时不同时语，皆邪师过谬”，并讥笑马祖、赵州等门人一些对机应答是“合头语”，是“无出身之路”的“泼恶水”，他批评巴陵颢鉴自夸三转语（银碗盛雪、珊瑚枝枝撑着月、鸡寒上树月寒下水），是“死在言句之中”。承古又建立“两种自己”（“空劫时自己是根蒂，今时日用自己是枝叶”）的观点，用以解释人生要脱去知见，悟道要“明得空劫以前自己”。惠洪对此都抱不同意见，认为巴陵三转语是勘验来机的活语。“两种自己”割断了佛性与自性的关系，是“间隔之说”，“不知圣人立言之难。”
    为了批评荐福承古的禅法，惠洪特于《僧宝传》用一卷的篇幅，全面介绍承古观点，并在《后赞》中对其一一加以批评。又特撰《临济宗旨》一文，进一步阐述自己的宗法观点。他认为临济宗的“三玄三要”，“十智同真”同出一关捩，其中“玄”、“要”、“智”、“真”，皆谓众生本具的清净种智，即佛性。三玄三要，十智同真都是运用机锋语句来勘验学者的方法，反映了祖宗不究知解分辩、壁立万仞的险绝门风。“诸方但爱平实见解，执之不移，惟欲传授，不信有悟”，可见，惠洪在宗法思想上，是主张一心自见自悟，豁然通贯，无所滞碍的，这与他的文字禅理论相吻合，也与其师真净克文的禅法主张一脉相承，所以，惠洪的禅宗实际上是黄龙宗法文人化特色的发展，是“无学之学”豁然融通的结果。
    惠洪非常推重曹洞宗旨，他不仅对洞山以下历代曹洞宗师的法门作了全面研究，还大大发展了曹洞宗法理论。如他曾注释洞山门下作为密法相传的《宝镜三昧歌》，又对洞山五位、三堕、渗漏等宗旨一一作出解释，著成《合古辙》二卷。曹洞宗自良价以来，相传有用周易卦象来解释偏正五位的方法，《宝境三昧歌》中即说到“重离六爻，偏正回互，叠而为三，变尽为五。”但自北宋以来，此法已失传。惠洪以博洽内外之资，重新考证五位宗旨，提出自己的解释如下图：
    此外，惠洪禅学思想广泛渗入文学、美术、书法、茶道等多种文化领域、特别是他的《石门文字禅》，不仅具有佛学价值，更具有深刻的文化、艺术学价值，他对当时文化领域诸人物、事件的评论，是研究宋代文化思想的极好资料，惠洪在文学艺术方面的实践与理论对宋以后文化艺术均有影响。
    惠洪禅学对后世禅宗发展意义重大。南宋以下，深受其影响的著名禅师代不乏人。其中如大慧宗杲这样的大师，也对惠洪极为崇敬。惠洪在世时，宗杲曾多次向他请益求教，尊为师叔。宗杲的看话禅也明显受到惠洪禅学思想的影响。宗杲推重南阳慧忠教禅合一思想，把慧忠法语编入《正法眼藏》，不废经卷义理，惟与惠洪同一迹辙，当有人批评人他不该宣扬慧忠的“义理禅”、“老婆禅”，认为这样有违禅家不立文字之旨“教坏儿孙”时，他非常坦率地反驳道：“左右以自得瞥脱处为极则，纔见涉理路，入泥入水为人底，便欲扫除，使灭踪迹。见某所集《正法眼藏》，便云‘临济下有数个庵主好机锋，何不收入？如忠国师说义理禅教坏人家男女，决定可删’。左右见道如此谛当，而不喜忠国师说老婆禅。坐在净净洁洁处，只爱击石火闪电光一箸子，此外不容一星儿别道理，真可惜耳。”惠洪禅学在大慧思想中的影子相当明显。
    此外，如元朝高峰原妙，平生惟好黄龙宗法，对惠洪更是推崇备至。明末一代禅学师达观真可（人称紫柏老人）一生以弘扬宗教为已任，他在感于《大藏经》卷帙浩繁，不利于普及，便精选部分重点著作，予以印行，其中，他特别关注黄龙惠洪的著作，“凡古名尊宿语录，若寂音尊者所著，诸经论、文集，世所不闻者，尽搜出刻行于世。”又如明代汉月法藏更是公开说“得心于高峰，印法于寂音”，不肯做当时名高一世的密云圆悟的法嗣，而远师惠洪与原妙。甚至雍正年间，朝庭禁止法藏一系禅法流传，导致禅宗的最后衰绝，其中亦不无惠洪禅学影响的境界。


一、杨歧宗的创立

第八章

    一、杨歧宗的创立

    杨歧方会（９９２－１０４９），袁州宜春（江西宜春）人，俗姓冷。二十岁在筠州（江西高安）九峰山出家，曾到潭州（湖南长沙）随石霜楚圆习禅，后到袁州杨歧山和潭州云盖山开辟道场，禅林称为杨歧方会禅师。古德评之曰：“杨歧天纵神悟，善入游戏三昧，喜勘验衲子，有古尊宿之风。”方会本人也以担荷如来大法，赓续临济正脉自任。楚圆迁化，方会将先师遗像挂在禅堂，集众举哀。方会指着遗像谓众曰：“我昔日行脚时，被这老和尚将一百二十斤担子放在我身上，如今且得天下太平。”是说临济宗风到他这里，纔传扬开来，取得一统天下的态势，从禅宗整个发展史看，正是从杨歧方会开始，临济宗的影响和地位超过云门、曹洞，成为禅宗主流。
    （一）心法双忘性即真
    方会上堂法语有云：“百千诸佛，天下老和尚出世，皆以直指人心，见性成佛。若向这里明得去，尽与百千诸佛同参；若向这里未能明得，杨歧未免惹带口业。”是说方会也别无伎俩，只是如历代祖师一般让人明心见性。真正的大禅师必然是对“心”、“性”深有体悟，纔会以种种方便指导学人有个入处，从而形成独具特色的禅风。其或棒或喝，皆是其禅风的表相，其底流是心性观。
    有僧问：“如何是佛？”方会答：“贼是人做。”又云：“万法是心光，诸缘惟性晓。本无迷悟人，只要今日了。山河大地，有什么过？山河大地，目前诸法，总在诸人脚跟下，自是诸人不信，可谓古释迦不前，今弥勒不后，杨歧与么，可谓买帽相头。”
    “贼是人做”实际是说佛是人做，凡人悟则是佛，不悟即为凡人。“万法是心光”之“心”非肉团心，也非灵知之心，而是指人与山河大地的同根处，是生命的本源、万物的本质。此心非实体性存在，而是一种绝对的、统一的，光明的如如状态，一切万法皆是这种如如状态的不同表现形式，故曰“万法是心光。”此心超越时空，无时不在，无处不有，故山河大地总在诸人脚跟下，古释迦不前，今弥勒不后。
    这种意义上的“心”又称本心、佛心，以其真实不虚又称真如，以其为成佛的根据称为佛性，众生修行修此，禅师证悟证此，佛祖相传传此，悟得此心，即说明学人破除了我执与法执，达到万物一体、物我一如的光明境界，即能理解“无边刹境”无边杀境，自他不隔于毫端；十世古今，始终不离于当念，”因为此“心”是万法统一的基础，证得此心，即一通百通，一了百了。
    此“心”不同于人的思维感知，后一种意义上的“心”与外境相对，是缘生的、暂住的、方生方灭的。这种思维意识不仅不能引对人们去体证本体之心，相反会成为人们修行的障碍，所以禅宗开始即标榜以无念为宗，对本心的体证是一种直观性的（非无理性）、带有强烈个人色彩的活动。在这一带有神秘色彩的体验中，理性思维是被暂时悬置的，正像在人的审美活动中，形象思维占主导，而抽象思维隐而不显一样。方会上堂法语云：“心是根，法是尘，两种犹如镜上痕。痕垢尽时光始现，心法双忘性即真。”
    “心法双忘”之“忘”，非心理学意义上的遗忘，而是指心无分别、心无对待、心无执著，亦即《金刚经》所云“以无所住而生其心，”心无所住是一种状态，更是一种境界，这种境界不只体现在禅者顿然省悟的一刹那，更体现在日常的生活现实中。不住心，非对一切不动心，如死灰枯木般了无生气，而是以一种超功利的、近乎审美的心态和眼光去观照世界和人生。只有这样，纔能开阔其胸襟，澡雪其情操，从一已之悲欢苦乐中超脱出来，获得自在三昧，其上堂法语引古德之言曰：“心随万境转，转处实能幽。随流认得性，无喜复无忧。”禅悟的最高境界不在耽空落寂、只求无忧，而是于十字街头知转身处，在荆棘丛中进退自如。
    （二）繁兴大用，举步全真
    有僧问：“如何是杨歧境？”方会云：“独松岩畔秀，猿向下山啼。”又问：“如何是境中人？”方会答：“贫家女子携篮去，牧童横笛望源归。”又曰：“雾锁长空，风生大野，百草树木作大狮子吼，演说摩诃大般若，三世诸佛在你诸人脚跟下转大法轮。若也会得，功不浪施；若也不会，莫道杨歧山势险，前头更有最高峰。”
    在丛林，学人问禅师的境界如何，实际是探问禅师对外境的看法，下面往往接着问禅师对修行主体即对境之人的看法，方会的回答，前一句“独松岩畔秀，猿向山下啼”，以诗情画意的语言，展示出悟道后所见之光明境界；后一句“贫家女子携篮去，牧童横笛望源归，”则喻示悟道者洒脱自在、安然自适的存在方式和生活样态。
      这种生活样态的核心还是“心”的觉悟。用方会上堂法语说则是：“举步也千身弥勒，动用也随处释迦。”“繁兴大用，举步全真。即立名真，非离名而立，立处即真。这里须会，当处发生，随处解脱，此唤作闹市里上下班竿子，是人总见，”但是，“是人总见”的道理，并不是人人能够理解并得受用的。有一位名叫杨畈的提刑入院烧香，见方会禅师。禅师献茶招待，杨畈云：“这个却不消得，有什乾嚗嚗底禅，希见示些子，”师指茶信云：“这个尚自不要，岂况乾嚗嚗的禅？”禅不是某种具体的物品，但也不是如虚空影响般不可把捉的一类东西。禅就在钦茶吃饭、接人待物等伦常日用中，当杨提刑问禅师从慈明处有何所得时，禅师曰：“共钵盂吃饭。”这与赵州禅师见学人即请其“吃茶去”，是同一旨趣。
    （三）“四一”法门
    有僧见方会，问：“先圣有八万四千法门，门门见谛，学人为什么触途成滞？”古德云：“成佛惟一路，方便有多门，”佛祖观根逗机，应病与药，以种种方便善巧度化众生，或空或有，或实或幻，或教或宗，法门无量，一切法皆是佛法。然种种法门皆是度人边事，本身并不具有终极意义。有外道问佛：“不问有言，不问无言。”世尊良久，外道赞叹：“世尊大慈大悲，开我迷云，令我得入。”外道去后，阿难问世尊云：“外道见个什么，便道令我得入？”世尊云：“如世良马，见鞭影而行。”大根器的学人，本于有言无言处索解，而于未有言、未无言处体悟。亦即于师家本心处会取。此心以其空明澄彻，可谓无言；以其昭昭灵灵，可谓有言。超越言与无言，直追师家之本心，即以心会心，心心相印。故此，方会对僧人所问，未做正面回答，而答以“何得自家退屈？”警策学人莫于师家方便处著力，而于自家本份处用心。
    但“学者劳形，如猿捉影，”学人多于纸墨文字、机锋转语处枉费心思，辜负从上祖师一片婆心，方会上堂语云：“山僧一语，凡圣同举。罢钓收纶，不如归去。”这是方会的落寞之谈，说教说禅，难见一真正学人，不如缄口不言，又云：“云盖是事不如，说禅似吞栗蒲，若向此处会得，佛法天地悬殊。”即便说禅头头是道，祖师真意未梦见在。故云：“只个心心心是佛，十方世界最灵物。释迦老子说梦，三世诸佛说梦，天下老和尚说梦，且问诸人还曾作梦么？若也作梦，向半夜里道将一句来。”佛祖说禅是醒人说梦，而学人若鹦鹉学舌，则落入痴人说梦、梦人说梦。
    方会对自己接引学人之法门，概括为“一要”、“一言”、“一语”、“一句”，此即“四一”法门：
    上堂：“杨歧一要，千圣同妙。布施大众，果然失照。”
    上堂：“杨歧一言，随方就圆。若也拟设，十万八千。”
    上堂：“杨歧一语，呵佛叱祖。明眼人前，不得错举。”
    上堂：“杨歧一句，急著眼觑。长连床上，拈匙把筯。”
    “四一”其实是从不同方面，对言词语句在习禅参禅过程中的功用所做的说明。“杨歧一要”切不可作实解，以为杨歧真有玄妙的禅法传授学人。其上堂语云：“杨歧无旨的，栽田博饭吃。说梦老瞿昙，何处觅踪迹？”就连祖师说法亦是梦语，更何况我方会？我不过是靠种田讨口饭吃的一种僧而已，在这看似自谦的话语中蕴含着大禅师深切的体悟，也蕴含着禅师对后来学人的慈悲情怀。佛教讲诸供养中，法供养最胜，诸布施中，法布施第一。故古来大德不畏眉头堕地，横说竖说，为学人解粘去缚。但禅师禅语，只对有上上根器之灵利汉子说，若是凡俗之辈，不仅不能会其妙处，而且会更增障碍，重添枷锁。这就是：“路逢剑客须呈剑，不是诗人不献诗。”若对小根器者说大法，反倒易使其退失信心。
    故此，禅师说法无有定则，往往是拈来即是，随口对答，兴之所至，山河大地，草木鱼虫，人情物事，历史掌故皆为道具；直语、韵语、譃语、诞语，皆成禅语，问：“如何是佛？”答：“三脚驴子弄蹄行。”问：“如何是祖师西来意？”答：“担头不负书。”问：“雪路漫漫，如何化导？”答：“雾锁千山秀，迤逦问行人。”其它如“衲僧得一钵盂口向天”、“太平本是将军致，不许将军见太平”等等。这些机缘语句，有些与所问有关，有些则风马牛不相及，但无论如何，不可依据常人的思维习惯去猜底禅师的语口之意。因为禅师们经常把佛教的经典文字或象徵标志仅仅当做一种物化形式，根本不考虑人们按照佛教的观念约定俗成地赋予它们的意义。如方会上堂引契此和尚临终偈：“弥勒真弥勒，分身千百亿。时时示时人，时人皆不识。”遂拈起拄杖云：“拄杖子岂不是弥勒？诸人还见么？拄杖子横也，是弥勒放光动地；拄杖子竖也，是弥勒放光照耀三十三天，拄杖子不横不竖，弥勒向诸人脚跟下，助你诸人说般若。若也知得，去拈鼻孔，向钵盂里，道将一句来。如无，山僧失利。”常人一定会反问“拄杖子如何是弥勒？”拄杖子不过是一截木头而已，而弥勒则是尊贵的菩萨和未来佛，按常规逻辑，这是一虚假陈述，当然如果我们强以为解，认为法身偏在，佛性同具也未尝不可，但这已落第二机、第三机，而非常一机的禅悟本身了。故语言之于禅师禅客，具有不同寻常的意义和功用。实际上，禅师们正是借助种种不规范的“语言”（如自相矛盾、同义反复、答非所问、随意乱说等），来表达自己所达到的那种随心回转、圆融无碍的精神境界，从心理学层面上讲，这样的精神境界实际上不过是一种无意识兴奋的心理状态，禅师们种种不规范的语言也可以说是他们无意识活动的一种表现形式。人们在无意识兴奋状态下的行为（包括语言活动）往往显得紊乱无序、不合常规乃至似疯似颠。此时任何规则都不能限制心灵的自由，语言的逻辑规则也被置之度外。而如果一种语言的使用规则发生了变化，那么这种语言就会失去其原有的意义。因此，禅师的语言究竟表示什么，往往使人费尽心思而不得其解。
    不过，禅师所运用的“语言”，与其说是语言，不如说是一种声音和活动。因为禅师使用这种语言本来就不是要表达某种思想或指称某个对象，而又是以这种无拘无碍的言说活动本身，本传达一种无所执著、无所凿缚的精神境界。方会的弟子五祖法演以两句艳诗，将方会“杨歧一言”的妙旨传达了出来：“有两句颇相近，‘类呼小玉元无事，只要檀郎认得声。’”禅师的语言本身并不不指示某种意义，而只是传达其内心体验的活动方式，故习禅者也不能按照逻辑规则去理解和解释这些语言，这就是“若也拟议，十万八千”之的旨。
    至于“呵佛叱祖”之语，我们在方会的语录中未见到、倒是在《临济录》中时时出现，如“佛是幻化身，祖是老比丘”。“罗汉、辟古犹如厕秽，菩萨、涅盘如凿驴橛”等等。佛祖就世间法论，如宗祖父母，岂可任意诃骂？就出世间法论，佛无处不在，而又不可拟议把捉，如此则能诃者谁？所诃者谁？其实，禅师用诃佛骂祖或毁佛毁的激烈方式说禅，不过是一种方便施设，目的在于破除学人对凡圣的分别执着，确立“自性是佛”、“即心即佛”的信念。可以说。“呵佛叱祖”之语皆为师法而非禅法，临济说得很清楚，“夫大善知识，始敢毁佛毁祖，是非天下，排斥三藏教，辱骂诸小儿，向逆顺中觅人。”只有真正证得空有一如，适机透教，总可“逢佛杀佛，逢祖杀祖，”不与物拘，透脱自在。不然，未达究竟，即胡呵乱骂，只会招致口业，难逃恶报。而且“呵佛叱祖”只是勘验接引初机的手段，以这种迥异常情的言词产生发人深省的效果，警策学人体认本心，莫向外求。而对那些已有悟境，凡圣情见已除者，则无须以此标榜，因为“呵佛叱祖”不是究竟，成佛作祖，总是修行的最终目标，宗门中人亦不例外。
    总之，对接引学人的禅师而言，禅语无定则，只要达到实际理地，不怕你不会说法，而只恐言语情思忘不掉。而对从师习禅之学人而言，则不可泥著文字语言，要将禅师之言视作“无意味语，”去会取其“言外之意”，“言前之旨”。如其不然，为禅师之言所在，而去“急着眼觑”，起心动念，识浪翻腾，则会离题愈来愈远，忘却明心见性之宗旨，此即“在句下”。用方会之言则是，“长连床上，拈匙把筯，”在长连床上本应安心打座习定，却去拿身旁什物寻开心，这是信心不足的表现。那些玩弄玄妙、言句的禅师及为这些玄言玄杀的学人，则是学力未充、见地未到的结果。
    方会的“四一法门”，其实是无有法门，因为他并不像同出慈明的黄龙慧南那样，用“三关”这类固定问话格式来勘验接引学人，便这种无有法门本身也可称为法门。方会不拘成规，挥洒自如，杀活自在的风格，在当时即得到很高评价，在《禅林僧宝传》中，惠洪说：“杨歧天纵神悟，善入游戏三昧，喜勘验衲子，有古尊宿之风。”文政于《杨歧方会和尚语录序》中称：“当时谓海得其大机，运得其大用。兼而得者，独会师欤！”其灵活多变的宗风也是杨歧法系能够流传久远的重要原因。后世临济宗的正脉，实际上主要由杨歧系来传承延续。


二、“三佛”禅法

二、“三佛”禅法

    宋道融在《丛林盛事》中评价杨歧与黄龙派的势力与地位时说：
    黄龙、杨歧二宗，皆出于石霜慈明。初、黄龙之道大振，子孙世之，皆般般不减马大师之数，自真净四传而至涂毒，杨歧再世而得老演，演居海会，乃得南堂三佛以大的其门户，故今天下多杨歧之派。
    这大体上说明了临济宗在北宋时期的态势。杨歧方会的法嗣有白云守端等，白云守端（１０２４－１０７２）法嗣有五祖法演等。杨歧宗的兴盛正是在五祖法演及其法嗣“三佛”禅师之时。所谓“三佛”，指佛鉴慧懃（１０５９－１１１７）、佛眼清远（１０６７－１１２０）、佛果克勤（即圆悟克勤）（１０６３－１１３５）。他们同时活跃于北宋末年，皆为一方化主，举扬杨歧宗风，且各有发明。在“三佛”周围还有一个习禅弘禅之士大夫群体。这一群体的禅行使杨歧宗由山林扩展到庙堂及市民社会各个阶层。
    （一）白云守端与五祖法演
    杨歧方会之法嗣，以白云守端成就最大，声望最高。守端，俗姓葛，湖南衡阳人，一生历主承天寺、圆通寺、法华寺、龙门寺、兴化寺、海会寺，最后于海会寺圆寂。海会寺建于白云山上，故史家以白云守端称之。《白云守端禅师语录》载其中开悟因缘：
      ……往参杨歧，歧一日忽问：“受业师为谁？”师曰：“茶陵郁和尚，”歧曰：“吾闻伊过桥遭颠有省，作偈甚奇，能记否？”师诵曰：“我有明珠一颗，久被尘劳关锁。今朝尘尽光生，照破山河万朵。”歧笑而趋起，师愕然，通夕不寐。黎明咨询之，适岁暮，歧曰：“汝见昨日打敲傩者么？”曰：“见”。歧曰：“汝一筹不及渠。”师复骇曰：“意旨如何？”歧曰；“渠爱人笑，汝怕人笑。”师大悟。
      这是一则值得玩味的公案。茶陵郁禅师之开悟，是籍过桥遭颠这一因缘。白云守端没有在此纠缠，而是随口吟出其开悟偈文，说明他已有相当多的参禅经验和禅学素养，但面对杨歧神秘的笑，白云守端马上现出境界上的差距，所谓“明珠一颗”，仍是郁禅师所有；所谓“尘尽光生，”仍是郁禅师所证。而白云守端所习所得仍是“乾慧”，与法身慧命无涉，故一遇外境之侵扰，即心旌动摇，不能立定脚跟，其实杨歧禅师未发一言，而白云守端即陷入苦思冥想，通夕不寐之困境，可见有无入处、有无证境，不在记取多少则公案，诵出多少则偈文，而在平日于心性有无体认。此事惟证乃知，便亦有诸外在表徵，瞒人不得，杨歧作为具眼禅师，于白云守端之证境自然是一见便知的，但他未明白点出，而是举街头艺人的例子，让白云守端自己去体悟，那么白云守端到底悟到了什么呢？其上堂法语有云：
    古者道：动则起生死之本，静则沈昏醉之乡，动静双泯，则落空亡，动静双收，则颟顸佛性，到这里，直得穷天玄辨，竭世枢机，用一点不著，独有山僧，今日幸遇太平世界，得路便行，不惧他人笑恠。
    能到“不惧他人笑恠”境界，庶几可谓“随流认得性。”
    白云守端大器利根，在杨歧人下多有悟入，其示众法语，皆高邈超绝，于习禅之入处、出处、用处、了处，皆有阐发。
    示众云：佛身充满于法界，普现一切群生前，随缘赴感靡不周，而常处此菩萨座。大众，作么生说个随缘赴感底道理？只于一弹指间，尽大地众生根机，一时应得周足，而未尝动著一毫头，便且唤作随缘赴感，而常处此座。
    “常处此座”与“随缘赴感”，就实相论而言，相当于真空与妙有的关系。真空不碍妙有，故常处此座而随缘赴感；妙有本于真空，故随缘赴感而常处此座，就修行论而言，又相当于不变与随缘的关系。常处此座，即证得如如不动之理体，随缘赴感，则是悟后起修，事境上磨炼，就境界论而言，则常处此座又为体得空性，入得如来藏海；而随缘赴感，则是不落空无，不堕死海，而得着出处。若无随缘一着而耽空滞寂，则是鬼窟活计。故白云守端又云：
    到这里直须悟始得，悟后更须遇人始得，你道既悟了便休，又何必更须遇人？若悟了遇人底，当垂手方便之时，著著自有出身之路，不瞎却学者眼，若只悟得乾罗蔔头底，不惟瞎却学者眼，兼自己动，便先自犯锋伤手。
    习禅须有居山、闭关的功夫，否则难有悟处。但禅悟的境界不是头脑中玄想之事，亦非炫奇门胜之具，而是与法身慧命息息相关的性命之学，故任何境界都必得到伦常日用中去体现、去印证。若自以为有所悟入而在现实生活中又步步泥著、触途成碍，则悟非真悟。惟百尺竿头，更进一步，在生活中了却大事，总是真有入处，出处。白云守端又云：
    大众须知，悟了遇人者，向十字街头与人相逢，都在千峰顶上握手，向千峰顶上相逢，却在十字街头握手，所以山僧尝有颂云：他人住处我不住，他人行处我不行，不是为人难共聚，大都缁素要分明。
    “十字街头与人相逢，”喻示与世俯仰，和光同尘；“千峰顶上握手，”喻示超尘脱俗，遗世孤立，虽身在尘世，而意气干云。没有十字街头的历练，功夫难有进境，而没有千峰顶上的境界，又易埋没已灵，丧身失命。此处白云守端为学人指示了个用处。
    而禅悟的最高境界即了处，非透过三关，功夫纯熟，则难得消息。其上堂法语有云：“入林不动草，入水不动波，入鸟不乱行，”又引《法华》四弘誓愿曰：“饥来要吃饭，寒到即添衣，困时伸脚睡，热处爱风吹。”这正是禅师所追求的自由境界。不过这样的境界，非“无心是道”所能涵括。必得一番勤苦修行，总有望在大死之后获得生命的新生。“忌口自然诸病减，多情未免有时劳，贫居动便成违顺，落得清闲一味高。虽然如是，莫谓无心云是道，无心犹隔一重关。”无心非无所用心，或无情无识，完全纵情放任，而是指不刻意施为而自然合道。要达此境界，必须经过有所施为的阶段，正如必待破初关、重关，总有可能踏末后一关一样。“若端的得一回汗出，便向一茎草上现琼楼玉殿；若未端的得一回汗出，纵有琼楼玉殿，却被一茎草盖却。
    白云守端在僧安居日（依印度佛教规制，每到雨季，出家人即不再出游，而于林中坐禅习定，称为安居），上堂示众曰：“安居之首，禁足为名。禁足之意，意在进道而护生。衲僧家更有何生而可护？何道而可进？唾一唾，唾破释迦老子面门。踏一步，踏断释迦老子背脊骨。犹是随群逐队汉，未是本份衲僧。”安居禁足，本意是为不伤草木鱼虫，积聚功德，求得道行的进步。白云守端的诘问透出禅家的机锋，显示出不同凡响的作略，但白云守端的见地超绝处又不在此呵佛骂祖处，而在于对呵佛骂祖的否定。而经过这两重否定回归本份的衲僧，总真正是见道者，由此可以看出白云守端接引学人风格平易简捷，实有乃师杨歧之风。
    嗣法白云守端禅师者，有五祖法演、云盖智本、琅琊永起、保福殊、崇胜珙等禅师，及提刑郭祥正居士等，其中五祖法深门庭最盛、影响最大，其发挥马祖道一“一口吸尽西江水”公案云：“一口吸盖尽西江水，万丈深潭穷到底，掠彴不是赵州桥，明月清风安可比？”为后人广泛传唱。
    （１）一朝风月，万古长空
    五祖法演（１０２４－１１０４），俗姓邓，绵州人，三十五岁始出家，受具，曾往成都习惟识宗，于《百法论》下过一番功夫。《百法论》全称《大乘百法明门论》，天亲菩萨造，唐玄奘译，为法相宗的重要论书之一，主旨在于阐发实我本空、万法惟识之理。此书有一段说法比丘与外道辩难的故事，说的是依惟识理，菩萨入见道时，智与理冥，境与神会，不分能证所证，当时有外道诘难持此论之比丘曰：“既不分能证所证，却以何为证？”诸比丘皆被问倒。依当时辩论的规矩，失利的一方必须放弃自己的信仰或不能再宣传自己的观点。因为诸比丘不能驳倒外道，被迫撤掉钟鼓，反披袈裟，以示屈服。待三藏法师玄奘到此，对众曰：“如人饮水，冷暖自知。”众比丘总找到反驳外道的依据。因为“不分能证所证”是实有证境时候的事情，是不能思虑言说的，所以若真实悟入、明心见道，则自然会“智与理冥，境与神会，”若未到那种境界，则横说竖说皆不关旨。
    法演其时还未入宗门，于富有禅意之“冷暖自知”句还不明其深旨，乃问其师：“不知自知之理如何？”其师或许见其缘在宗门，乃指示他到南方丛林参访禅林大善知识，法演于是负笈出关，在南方每见尊宿，即以此咨决所疑，但一直未得到令其满意的答案，后谒照本禅师、浮山远禅师，举兴化存奖禅师“四方八面来时，打中间”句请益，未得究竟。浮山远禅师指示他往依白云守端。
    见白云守端禅师后，举僧问南泉摩尼珠话请问。守端叱责之，法演当下有所悟。白云之喝，是喝断其寻思猜度之寻常理路，而法演之悟处，正在于领悟到应于本心处着力，不可于枝节上生枝节，葛藤上绕葛腾。白云一喝之下，法演即有所悟，可见师徒间机缘颇契。法演向白云献偈曰：“山前一片闲田地，叉手叮咛问祖翁。几度卖来还自买，为怜松竹引清风。”卖来买去，最终目的还是为了享受一片诗情画意的好风光。
    不过法演此时只是踏破初关，总有悟处，还未到打成一片、通体无碍的境地，其再悟因缘缘于庐山禅客：
    未几，云至，语师曰：有数禅客自庐山来，皆有悟入处。教伊说，亦说得有来由，举因缘，问伊亦明得，教伊下语亦下得。只是未在。师于是大疑，私自计曰：既悟了，说亦说得，明亦明得，如何却未在？遂参究累日，忽然省悟，从前宝惜，一时放下，走见白云，云为手舞足蹈，师亦一笑而已。师后曰：吾因兹出一身白汗，便明得千载清风。
    白云所以评庐山禅客“只是未在”，是说他们虽有悟处，但未到了处，所习所学放不下犹有障在。法演于此顿起疑情，累日参究，总打破漆桶，豁然贯通，只有到此境地，总既不辜负一朝风月，又不忘却万古长空，彻天彻地，亘古亘今，一无挂碍，洒脱自在。不过“不经一番寒彻骨，怎得梅花扑鼻香？”此事惟证乃知，非得少为足、徒呈口利辈所能企及。
    （２）说佛说法，拈槌竖佛
    有僧问：“如何是佛？”法演答：“口是祸门”，意谓此问题问不得也答不得，但这一问题在禅林中屡屡被学人所提请，师家对此问题可以作正面回答，但多数情境下不做正面回答，因为学人设此问，不过是勘验师家的证境及接人的风格，以确定自己与师家是否有缘，法演的回答看似不对题，实则透着禅机，因为它否定了问题本身，截断了学人于言下荐取的思维取向，实属作家手段。
    不过“如何是佛”这一问题本身终归是不能回避，在禅林中，对佛祖的认识是涉及禅机的常见话头。法演也常拈槌竖佛，说佛说法，其示众法语云：
    十方诸佛，六代祖师，天下善知识，皆同这个舌头，若识得这个舌头，始解大脱空，便道山河大地是佛，草木丛林是佛，若也未识得这个舌头，只成小脱空，自谩去，明朝后日，大有事在。
    这里所说的“舌头”喻指佛言祖语及天下善知识之说禅说法。“识得这个舌头”，实际上不为这个舌头所瞒，于唇舌动前会取。因为真正的禅非口头禅，直正的空，一落言诠即变为“有”，所以只有突破语言的局囿和障碍，总有望体得真空，证得般若，此即“大脱空”境界，到这一境界，即会得惟识无境，万法惟心，空不虚悬，遍一切处，苏东坡居士“溪声便是广长舌，山色岂非般若身”。山河大地，草木丛林，心识到处，莫不空寂，皆是法性佛性的当体显现。应该注意的是，这里法演所说“山河大地是佛，草木丛林是佛，”并非泛神论命题，不是说山河大地，草木丛林是佛菩萨所变现，或它们都是佛的化身，而是指世间万物包括众生体性皆空，皆是真如本体的显现。佛不过是在最高层次上实现万物这一体性的修行者。所以从万法皆空的角度看，世间一切皆是统一的，有情无情，凡夫圣众，皆不一不异。说山河大地是佛，是说山河大地当体是空，佛当体亦空，同样地草木丛林是佛，亦作是解。
    如果不丛根本处着眼，从空性的角度看待世间一切，就必然熄灭执著、堕烦恼窟中。“未识得这个舌头”，喻指不能会得佛祖善知识之言的真实意旨，只于文字言句中去寻思忖度空、有的含义。这样即便对空理解得再“准确”，再“全面”，也是“小脱空”，不仅不能了办自身生死大事，还会徒增贡高我慢，阻碍向上的进路。
    为使学人更准确地理解佛与众生、佛与万法的关系，法演又举陆亘问南泉公案让弟子参：
    陆亘大夫问南泉的弟子：家有一片石，也曾坐，也曾卧，拟镌作佛，得么？云：得。陆曰：莫不得么？云：不得。大众，夫为善知识，须明决择，为什么他人道得也道得，他人道不得也道不得？还知南泉落处么？
    这里南泉之所以随声附和，不置可否，非故弄玄虚，作弄学人，而是另有意旨，且看法演的解释：
    白云不惜眉头，与汝注破。得又是谁道来，不得又是谁道来？汝若不会，老僧今夜为汝作个样子，乃举手云：将三界二十八天作个佛头，金轮水际作个佛脚，四大洲作个佛身。虽然作此佛儿子了，汝诸人又却在哪里安身立命？大众还会也未？老僧作第二个样子去也。将东弗于逮作一个佛，南瞻部洲作一个佛，西瞿耶尼作一个佛，北郁单越作一个佛。草木丛林也是佛，蠢动含灵是佛。既凭么，又唤什么作众生？还会也未？不如东弗于逮，还他东弗于逮，向瞻部洲还他南瞻部洲，西瞿耶尼还他西瞿耶尼，北郁单越还他北郁单越，草木丛林还他草木丛林，蠢动含灵还他蠢动含灵。所以道：是法住法位，世间相常住，既凭么，汝又唤什么作佛？还会么？忽有个汉出来道：白云休寐语。大众记取这一转。
    起塔造像，在佛教中是有大功德之善举，陆亘欲镌石造像，其愿心是值得赞赏的，但南泉作为宗门巨著匠，无时不在藉各种因缘点化众生，他对陆亘所问无可无不可的态度，恰说明他所关注的决不是用一片石做佛像合适不合适这一具体问题，而是如何是关注众生自己的生命、为自身找到安身立命之所的问题，所以法演提醒众弟子不要在“得”与“不得”间费思量，而要在道“得”与道“不得”者是谁问题上起疑情。只有彻底究明道者是谁，生命总有个安顿处，总不会为点滴的世俗烦恼所固执，如若不然，即便像法演所言拿三千大千世界来做佛像，于自家身命安顿又有何干？与其如此，还不如山河大地还它山河大地，丛林草木还它丛林草木，反求诸已，认取已灵，于是心是佛、是心作佛处痛下功夫，庶几有个悟处，得个受用。法演此番苦口婆心，皆是为破除弟子对一切境相的执著，并没有实际立什么妙法，所以最后他又举“白云林寤语”将自己的一番话彻底否定，不留泥痕，实乃大家手眼。
    （３）发上上机，开正法眼
    有僧问：“如何是和尚家风？”师曰：“铁旗铁鼓。”曰：“只有这个，为复别有？”师曰：“采石渡头看！”和尚家风是问不出来的，因为它根本是不可回答，任何所谓对题的回答都违背“和尚家风”，所以法演只能自说自话，所谓“铁旗铁鼓”、“采石渡头看”，根本是无实意的搪塞语，与拈杖竖拂、拍床踩地，同一伎俩。
    法演上堂：“千峰列翠，岸柳垂金，樵父讴歌，渔人鼓舞。笙簧聒地，鸟语呢喃，红粉佳人，风流公子，一一为汝诸人发上上机，开正法眼，若向这里荐得，金色头陀无容身处。若也不会，吃粥吃饭，许你七穿八穴。”这是说世间森罗万象、林林总总，人间芸芸众生、世事人情，皆是大道所在处，无时不在为众生说禅说法，若能于寻常的景物平凡的生活会得妙处，即是于“第一句荐得，可与佛祖为师。”
    因此，法演劝诫学人莫于师家唇舌动处生解，以免误累终生，“白云不会说禅，三门开向两边，有人动著关捩，两片东扇西扇。”又云：“汝等诸人，见老和尚鼓动唇吻，竖起拂子，便作胜解。及乎山禽聚集，牛动尾巴，却将作等闲，殊不知檐声不断前旬雨，电影还连后夜雷，谢监收。”法演对自然万象之诗情画意极为敏感，总是以禅者的情怀与诗家的心境，来表达自己的感悟与体验，引导学人扫除心中的医雾，时时处处发现生活中的美，禅本来就不是虚玄的、神秘的，而是平易的、生动的。参禅有所悟入，不是一头钻进魔窟中玄来玄去，而是打破物我质碍，以清澈洞明的心境与外境相接，去触摸大自然的形体，感受生命的律动。“悟了同未悟，归家寻旧路。一字是一字，一句是一句。自小不脱空，两岁学移步。湛水生莲花，一年生一度，”“湛水生莲花”清兮洁兮；“一年生一度”，本然当然。开悟者不是与世人完全不同、思想行为怪异的人，而是在世间又超出世间，不离俗而又不染俗的人。开悟者比世人不过更超脱，从而也更自在更洒脱而已。
    （４）白云万里，一切寻常
    法演上堂：
    山僧昨日入城，见一棚傀儡，不免近前看。或见端严奇特，或见醜陋不堪。动转行坐，青黄赤白，一一见了。子细看时，元来青布幔里有人。山僧忍俊不禁。乃问：长史高姓？他道：老和尚看便了，问什么姓？大众，山僧被他一问，直得无言可对，无理可伸。还有人为山僧道得么？昨日那里落节，今日这里拔本。
    法演举进城看傀儡戏一事，启发众弟子：禅师的种种施为如扬眉瞬目、举手投足，乃至拈槌竖拂，棒打断喝，皆与傀儡戏相似。有人在操纵指挥。同样地，禅师的种种接人手段本身也无实意，其真正的意义只在否定学人向外执求的思维习惯，截断学人思维分别之日常思路。法演在观戏时受好奇心驱使多说一句话，即遭演戏人呵责，这与学人于禅师面前遭棒喝相似。法演遭呵，“无言可对，无理可伸”，而学人被禅师棒喝，通常也是当下起疑情，断虚妄分别，开口不得。法演向弟子讲述这一故事，还是训诫学人不可执著禅师种种接人的方便施设，以方便为究竟，以师道为禅道。
    法演还举雪峰在德山和尚处开悟因缘说明这一道理：
    德山和尚因僧问：从上诸圣，以何法示人？山云：我宗无语句，亦无一法与人。雪峰从此有省，后有僧问雪峰云：和尚见德山，得个什么便休去？峰云：“我当时空手去、空手归。”
    禅师接引学人，不过是解粘去缚，为学人去除业惑烦恼，并没有实法相授受，其示众语云：
    祖师道：吾本来兹土，传法救迷情。一花开五叶，结果自然成，达摩大师信脚来，信口道。后代儿孙，多成计较。要会开花结果处么？郑州枣，万物无过出处好。
    又云：
      真如凡圣，皆是梦言。佛及众生，并为增添。
    如此说来，则不仅禅师的禅语皆无实意，而且从上佛祖大善知识之言语文字皆成游戏文字。后代子孙根机浅钝，执虚为实，将梦言增语翻成则则公案，又于公案横生计较，结果离佛祖本旨愈来愈远。法演以“郑州梨，青州枣”将一切玄言玄语尽情扫荡尽净，还本份事平易质朴的本来面目，可谓透机之见。
    法演总以本份事度人，将学人引入自性自度一途。有僧问：“百尺竿头，如何进步？”法演答以“快走始得”。问“如何是临济下事？”法演答：“五逆闻雷”。“五逆”指犯下出佛身血、破和合僧等大逆不道的罪行。犯下五逆之罪者闻雷声自然胆战心惊（因为中国民间有雷劈那些做下伤天害理之事者的说法），法演以此形容临济宗宗风峻烈，学人每每闻禅师断喝而胆丧。其间并没有故弄玄虚。其它如以“红旗闪烁”喻云门宗风。以“驰书不到家”喻曹洞宗风。以“断碑横古路”喻沩仰宗风，以“巡人犯夜”喻法眼宗风，皆从平易处着眼、质朴无华，一无虚套。
    法演上堂：“人之性命事，第一须是〇。欲得成此〇，先须防于〇。若是真〇人，〇〇。”法演此段法语，初看确实有点玄妙，其实如果知道〇或“圆相”的来历及其含义，则并无玄妙可言。唐代慧忠国师常举〇相示众，耽源谓师（仰山）曰：“国师（慧忠）当时传得六代祖师圆相，共九十七个，授与老僧。”此〇相意义有多种，主要代表万法之体性，万物之本源，是万物存在的根据，也是世间万物相统一的基础。就修行论或解脱而言，此圆相代表佛性或空性，它是众生成佛的根据，也是众生走向解脱的必由之路。所以法演总说“人之性命事，第一须是〇”，只有证得此空性，体得万法本空，总会无执无碍，获得解脱，找到安身立命之地。了办生死大事，但人们常常误解“空”义，将空论解为“没有”、“不存在”、“消亡”等等，从而陷入拔无因果，不信正法的空无外道。要想真正体证此“空”义，必须首先破除恶取空的观念，从万物本体的层面去趋近此“空”之真实蕴含。即便有所悟入，证得此空，亦不可泥著，坐此妙境而不肯出。如果以证空体空为满足，即重生障碍，再添烦恼，本身即背离空义，故古来大德每论及空，皆强调空“空”，即把“空”境、“空”界本身也空掉，只有连“空”本身都不加执著，虚破放下，总是彻底空、毕竟空，真实空。此即法演所说：“若是真〇人，〇〇。”“〇〇”，代表空“空”，前一空是动词，后一空为代词，指称众生所证悟到的万法本空的境界，或万法的真实体性。
    法演宗风平易而又机辨无方，其法语皆为解粘去缚而方便出之，究极言之，并无实义可寻。即便上述〇句，也非以实法予人，不过将古德剩语，随手拈来，翻成一则公案而已。若于此寻思索解，只能是枉费心机，徒增痴病，其示众语云：“每日起来，拄却临济棒，吹云门曲，应赵州拍（柏），瞻仰山锹，驱沩山牛，耕白云田。七八年来，渐成家活。”法演禅无有定法，虽为临济正脉，但并不囿于宗派之见，于其它宗派以开放的心态，含纳包容，且能拈放自如，不粘不滞。法演每每以“白云万里”抒发自己对禅的理解。不论德山棒也罢，临济喝也罢，我自“白云万里！”其宗风绵延，法嗣昌盛，其宜乎哉！
    （二）“三佛”的禅法
    宋朝至神宗、哲宗年间，国家进入多事之秋。辽国、西夏环伺，软弱的南宋朝廷一直为求得边境的安宁而向辽、夏进献大量财宝。而朝廷内部新党与旧党之争也纷纷攘攘，无有终局。就佛教界而言，此时在江西、湖南一带黄龙宗独盛，住持名山大寺、开堂说法者，多黄龙系禅师。但自白云守端以下，杨歧宗传法中心西移，中经五祖法演等敷演弘扬，在以蕲州为中心的长江西岸，杨歧宗逐渐得势，并呈现超出黄龙宗的趋向，这其间法演门下三位弟子佛果克勤、佛鉴慧懃、佛眼清远禅师居功实伟。《佛祖历代通载》卷三十：“演门二勤一远，声价藉甚，丛林谓之三杰。”
    １、佛果克勤与《碧岩录》
    佛果克勤，四川彭州人，出身于世代业儒之家，少时偶游妙寂寺，见佛书如睹旧物，心念前世为僧，因缘未尽，慨然出家。先习《楞严》等，未能了彻，乃遍参耆宿，最后于五祖法演处得悟。
    《五灯会元》记其开悟因缘云，有学人向五祖法演问道，法演答以“频呼小玉元无事，只要檀郎认得声。”克勤不解其意，法演曰：“如何是祖师西来意、庭前柏树子？参！”克勤忽自有省。出门见鸡飞上栏杆，振翅而鸣，顿悟法演小艳诗之意，返回方丈室，呈偈曰：“金鸭香销锦繡幃，笙歌丛里醉扶归，少年一段风流事，只许佳人独自知，”法演见偈，深表嘉许：“佛祖大事，非小根劣器所能造诣，吾助汝喜。”法演、克勤皆以艳诗谈禅，看似俗鄙，实则有严肃的内涵，是警策学人不可着相，应于生死命根处着实参究。有觉庵道人祖氏、据说于圆悟示众语下了然明白，圆悟却劝她：“更须飏却所见，始得自由。”此意与其在法演处所悟者同。
    佛祖所传到底传哪个，善知识所证到底证哪个，一直是学人十分感兴趣的问题。但佛祖所传，善知识所证又恰恰是超言绝相、惟证乃知之事，是见闻所不及，言语非能传的，克勤上堂云：“通身是眼见不及，通身是耳闻不彻，通身是口说不著，通身是心鉴不出，直饶尽大地明得，无丝毫透漏，犹在半途。”如果强以为言，也只能指个不着烟尘处认人去会意。“据令全提，且道如何展演？域中日月纵横挂，一亘晴空万古春。”
    此虚空影响般的本体，用拟人化的说法，即临济所说的“赤内团上的无位真人”，对超凡人圣的修行者，则指法身佛。此法身凡圣同具，但惟进圣位之菩萨总能随缘显现，此即克勤所说：“三百六十骨节，一一现无边妙身；八万四千毛端，头头彰宝王刹海。”不过此法身非有形质的存在，只能寓存在于报化身，亦即人的肉身中，总能显发其妙用。克勤上堂语云：“本来无形段，那复有唇嘴，特地广称场，替他说道理，且道他是阿谁？”
    克勤虽然屡屡设问，但这一问题没有答案，或说根本不能回答，因为一涉思虑，即落分别，一涉言诠，即生障碍。其上堂语云：“庞居士舌拄梵天，口包四海，有时将一茎草作丈六金身，有时将丈六金身作一茎草，甚是奇特。虽然如此，要且不曾动著向上关。且如何是向上关？铸印筑高坛。”“向上关”或称“向上一著”，指禅者所要体证的终极实在，此终极实在即是万法的空性。对此空性，只能以遮诠而不能用表诠法来说明，即只能说“它”不是什么，而不能说“它”　是什么，因为“它”是超验的存在，是超时空，绝对待的存在，而任何肯定判断除了同义反复（“它”是“它”）之外，都是分析比较的基础上作出的。所以是即非是，“说似一物即不中”，克勤就“临济三句”而别出新意：“第一句荐得，祖师乞命；第二句荐得，人天胆落；第三句荐得，虎口横身，不是循途守辙，亦非革辙移途。透得则六臂三头，未透亦人间天上。且三句外一句作么生道？生涯只在丝纶上，明月扁舟泛五湖。”
    即是说，于言句上著得，无论是利根大器，还是小器钝根，都有丧身失命的危险。只有透得言句，不为言句所瞒，追求向上一著，直趋本地风光，证得自性法身，总能以无量化身化度众生。如若不然，于言句上生执著，则南辕北辙，不着边际。“有句无句，超宗越格，如藤倚树，银山铁壁。乃至树倒藤枯，多少人失却鼻孔。直饶收拾得来，已是千里万里。”
    “一言截断，千圣声消。一剑当头，横尸万里。”禅师接人的言句似乎全在其否定的意义，即否定学人之寻常思维习惯，截断其向外执取之思维趋向。但就在这否定之中有肯定在，此即警策学人反躬内省，去认取自身内在的宝藏。不过此“截断众流语”能否开出活人之生命的源头活水，要看学人之根机，及学人与禅师是否投缘。克勤示众云：“万仞崖头撒手，要须其人，千钧之弩发机，岂为鼷鼠？”怎奈求法者多，而具眼者少，学人每每为言句葛藤缠绕，至死不悟。对此等众生，一切施设，皆成窠臼。一切言句，皆为增语，反不如闭口无言，或直言一句“吃茶去”。“云门睦州，当面蹉过，德山临济，诳謼闾阎。自余立境立机，作窠作窟，故是灭胡种族。且独脱一句作么生道？万缘迁变浑闲事，五月山房冷似冰。”
    ２、《碧岩录》及宋代禅风
    （１）《碧岩录》缘起：
    《碧岩录》全称《佛果圆悟禅师碧岩录》，又名《碧岩集》。这是一部在中国禅宗史上占重要地位、有巨大影响的著作，此书不仅内容丰瞻、风格独特，而且其流通传布也极具传奇色彩、被后人誉为“宗门第一书。”
    《碧岩录》是以雪宝禅师所著《百则颂古》为底本，故论《碧岩录》就不能不先谈《百则颂古》。雪窦重显，宋代初年云门宗禅师，其著作除《百则颂古》外，还有《洞庭录》、《后录》、《瀑泉集》、《拈古》、《祖英集》、《开堂录》《雪窦拾遗》等，后世誉之为云门宗中兴祖师。《颂古百则》是雪窦从古圣先贤机缘语录中选出一百则公案，分别附加颂古，以阐扬其意旨，由于雪窦禅师见地纯正，境界高邈，且其偈颂文字雅正，寓意深刻，故自问世以来，禅林中竞相传颂。
    圆悟克勤在开堂说法时，为方便后学，使学人更易理解《百则颂古》的妙旨、又作《碧岩录》。具体地说，此书是圆悟禅师住成都昭觉寺、夹山灵泉院、湘西道林寺等三处，前后二十年间为门人所讲，由众弟子记录整理而成，其弟子无觉所写的后序说，此书全由门人记录而成，其师圆悟未尝过问。由些推知，圆悟克勤似乎是在开示学人时随意拈出，并非刻意为之，也无意编辑成册，所以未尝过问其内容。
    圆悟克勤提唱《碧岩录》还得两位大护法的助缘，宋徽宗崇宁年间（１１０２－１１０６），圆悟辞别法演，回四川省亲。成都府知府郭知章慕其道望，迎请其在六祖山开法，继则迁到昭觉寺，时在崇宁五年（１１０６），在昭觉寺住持八年间，圆悟始对《百则颂古》加以评唱。后慕张商英。张商英是一代硕儒。号无尽居士，研究《华严经》颇有心得。两人一见如故，对华严教理畅谈通宵。商英对圆悟的道德文章极为推重，以师礼款待之，并聘请他住于湖南沣州夹山灵泉院。在夹山圆悟所居之方丈室，自善会禅师开山以来挂有匾额一块，到圆悟来此时，已有二百余年，题为“碧岩”。圆悟在此继续提唱评说《百则颂古》，《碧岩录》的题名即采此二字。
    （２）《碧岩录》的内容：
    作为《碧岩录》底本的《百则颂古》，内容仅有“本则”和“颂古”两部份。“本则”是雪窦所选一百则公案，在每则公案后面缀有颂古。圆悟克勤《碧岩录》的体系，是在每则公案的前面，讲一段“垂示”。在每则“本则”及“颂古”句下，注“著语”，又在“本则”及“颂古”后面作一段评唱，所以《碧岩录》的内容是由一百则公案及相应的“垂示”、“本则”、“颂古”、“著语”、“评唱”五部份组成。“垂示”又称“示众”，是圆悟将该则公案的要旨为弟子点出，学人若能于此“垂示”会得，即易把握该则公案的关捩子。“本则”又称“话头”，是雪窦从一千七百则公案中选出最典型、寓意最深刻的一百则，供学人参究。每则前面皆有一“举”字，意为特意举出评唱，“颂古”是雪窦所作阐释公案妙旨的偈颂。因禅理至平易而又至幽玄，非日常语言所能表诠，故雪窦以偈颂的形式来曲达其意。“著语”又称“下语”，是在本则及“颂古”各句下所标注的细字。有时候数字，有时候仅一字。虽然字数不多，但皆显出圆悟透机之见，给人以痛下针锥之感。“评唱”是在“颂古”之后圆悟所作的解释发挥。有的字数还很多，虽不免架屋叠床之讥，但亦见圆悟老婆心切，不舍众生之悲愿。其内容或叙公案之因缘故事，或阐述“颂古”未尽之意，或对公案“颂古”进行总括性评论，意在以楔出楔，以有言而使学人悟无言。
    且看圆悟所选第二则公案：
    垂示云：乾坤窄，日月星辰一时黑。直饶棒如雨点。喝似雷奔，也未当得向上宗乘中事。设使三世诸佛，只可自知。历代祖师，全提不起。一大藏教，诠注不及。明眼衲僧，自救不了，到这里，作么生请益？这个佛字，拖泥带水。这个禅字，满面惭愧。久参上士，不待言之。后学初机，直须究取。
    举：赵州示众云：（这老汉作什么？莫打这葛藤）至道无难，（非难非易）惟嫌拣择。（眼前是什么？三祖犹在）总有语言，是拣择是明白？（两头三面，少卖弄）鱼行水浊，鸟飞落毛，老僧不在明白里，（贼身已露，这老汉向什么处去？）是汝还护惜也无？（败也，也有一个半个）时有僧问：既不在明白里，护惜个什么？（也好与一拶，舌拄上齶）州云：我亦不知。（拶杀这老汉，倒退三千）僧云：和尚既不知，为什么却道不在明白里？（看走向什么处去，逐教上树去）州云：问事即得，礼拜了退！（赖有这一着，这老贼。）
    上面括号中的语句是圆悟所下“著语”，原文是小号字，是圆悟为各句所作夹注。
    雪窦的“颂古”曰：
    至道无难，（三重公案，满口含霜，道什么？）言端语端，（鱼行水浊，七在八裂，杂胡也）一有多种，（分开好，只一般，有什么了期？）二无两般。（何堪？四五六七，打葛藤作什么？）天际日上月下，（觌面相呈，头上漫漫，脚下漫漫，切忌昂头低头）槛前山深水寒。（一死更不再活，还觉寒毛卓竖么？）骷髅识尽喜付立？（棺木里瞠眼，虑行者是它同参）枯木龙吟销未乾。（咄，枯木再生死，达摩游东土）难！难！（邪法难扶。倒一说，这里是什么所在，说难说易。）拣择明白君自看。（瞎，将谓由别人，赖值自看，不干山僧事。）
    圆悟的垂示很长，前一部份就赵州公案阐扬发挥，后一部份就雪窦古再加讲评。
    “至道无难，惟嫌拣择”出自三祖道信《信心铭》：“至道无难，惟嫌拣择。但莫憎爱，洞然明白。”“拣择”即分别义，意谓本份心地超言绝相，无可思虑分别，只要远离烦恼，不凿俗情，当下即体得真常本心。对这层道理，赵州并未谈玄谈妙，论机论境，引导学人向道理处会，如果这样，恰恰是误导学人去拣择，去生憎爱。赵州以作家手眼，巧与回旋，在不动声色中，施以针锥，虽无棒喝之迅励，但亦有截断众流，发人深省之功效，圆悟特别指出，学人切莫于赵州“我亦不知”错会，以为赵州真的无知无识，禅师不过以本份事接人，“所以道相骂饶尔接嘴，相唾饶尔泼水，”其不争不辩，不过是以这种答话方式本身，警策学人莫落拣择，亦莫坐在明白里，一切放下，莫生执著。禅师是心地洞明而自在说法，非如后世禅和子懵懂无知，学人问着，也答以“我亦不知不会”，以示高深莫测，欺瞒学人。圆悟评道：“盖为他平生无许多计较，所以横拈倒用，逆行顺行，得大自在。如今人不理会得，只管道赵州不答话，不为人说。殊不知，当面蹉过。”颇有惺惺相惜之慨。
    （３）《碧岩录》与宋代禅风
    禅宗五家七派的祖师们本来各有机用，不易“凑泊”，自《碧岩录》出而有“敲门砖”可寻，禅风也为之一变。在唐代，禅师接人度众，皆直指心性，语句都很质朴平实。只要机缘相契，村姑野老也可因而悟道。如马祖会下的凌行婆和与南州等大禅师相交接的台山婆、烧庵婆等，皆见地透彻，机锋灵活，并不让得道的大禅师。禅宗发展到后来，士大夫阶层逐渐被吸引到禅宗方面来。到北宋时期，禅师与大士夫交游往来已成风习。如雪窦重显禅师与学士曾公会、附马都尉李文和、于秘丞、沈祠部等等。圆悟禅师与士大夫的交往更密切，他经常为运判、侍御、待制、朝散、安抚、少保、典御以及贵妃、郓国大王、莘王、济王等达官贵人上堂说法，历任名刹住持，也都出于士大夫们的推举，这些士大夫大都工于翰墨，爱好“斯文”，禅师为“应”当世之机，也就吟诗作赋，舞文弄墨，以诗偈赋颂谈禅论道。禅风也就由质朴而变为讲求藻饰，影响所及，极为深远。《禅林宝训》卷下引以闻昙贲禅师之说云：
    天禧间，雪窦以辩博之才，美意变弄，求新琢巧，继汾阳为颂古，笼络当世学者，宗风由此一变矣。逮宣政间，圆悟又出已意，离之为《碧岩集》，彼时迈古淳全之士，如宁道者、死心、灵源、佛鉴诸老，皆莫能回其说，于是新进后生，珍重其语，朝诵暮习，谓之至学，莫有悟其非者，诵哉，学者之心术坏矣。
    雪窦、圆悟辈的本意无疑是以文字般若开实相般若，由语言文字而达心性根本。但利根人少而钝根人多，那些才质根器不如师者只能袭其皮毛而遗其精髓，因而总有“不明根本，专尚语言，以图口舌”的禅病，据延祐年间径山住持（上面一个文字，下面一个巾）　陵的《碧岩录后序》云：“大慧禅师因学人入室下语颇异，疑之，总勘而邪锋自挫，再鞠而纳款自降，曰：我从《碧岩集》中记来，实非有悟。”大慧宗杲为圆悟弟子，见《碧岩录》竟使学人背本逐末，乃将《碧岩录》的刻版毁掉，以警策学人，但风气已成，改变亦难，即便在大慧自己的语录里，宾主问答亦大有讲究。如他在临安明庆院开堂说法，僧问：“人天普集，选佛场开，祖令当机，如何举唱？”师云：“人间无水不朝东。”进云：“可谓三春果满菩提树，一夜华开世界香。”宾主问答，都是选词造句上费心机，很难称得上“老实商量”，或“以本份事接人”了。
    有宋一代，禅林中颂古评唱的著作在《碧岩集》之后还有很多，如投子义青禅师颂古、天童正觉禅师颂古。而宋法应的《颂古联珠通集》四十卷，更累集了古今四百二十六位禅师的三千多首偈颂，几乎对禅宗门下流行的公案都有了解说。禅师们一篇在手，就能登堂升座，拈柱竖拂，头头是道，至于真参实悟，则无从谈起。
    ３、佛眼清远与《示禅人心要》
    与注重评说参究公案的克勤不同，同为法演高足的清远禅师特重真参实悟。他“不以见闻言辞辩博为事，使人洞真源，履实际。”他主张“就已知归”，“履践修行”，“须是当人自作活计，莫听他人说，”“意在自明”，“只要诸人自契，”这些思想在当时即已受到丛林的重视，对后世禅风亦有深远影响。
    《古尊宿语录》收录清远语录达八卷之多，而其禅学思想集中体现在《示禅人心要》一篇，此篇开首即云：“不应于无际空中立分限，若立分限是无际空，乃自负堕，所以解空者无空想。”所谓无际空无分限，是说众生心性圆满具足，无少欠缺。所谓解空者即证得此心性者，因为空性本身是“无际”，无分限，所以不能由日常的思维语言去分别把握，而只能是整体性的契合，这种心与心的契合即是一种体验和亲证。“近世皆曰：无不是道，譬如饭箩边坐说食，终不能饱，为不亲下口也。证者绝能所也，非别有玄论在寻常日用处，如见色时是证时，闻声时是证时，饮水食粥时是证时，一一绝能所，此非久习、不假薰炼。”日常的思维都是由特定的思维主体（能知）去把握特定的思维对象（所知），在具体的认识思维过程中，由对部份的认识逐渐达到对全体的认识，而参禅悟道的过程则不同，参禅重在“悟”而不在“知”，而悟则是以心契心，以心证心的过程，是不分能作，不涉阶级的“顿悟”和默契。“二乘断烦恼得证，名为偏修，不若应念化成无上知觉之速也。”清远在某种意义上又复归到六祖慧能“不识玄旨，徒劳念静”，“一念迷，佛即众生；一念悟，众生即佛”的理路上来。
    基于这一理路，清远将入道法门概括为两种方便，即真实方便和善巧方便：
    后上来有二种方便，有真实方便，所谓说无有间；有善巧方便，所谓妙尖群机。若从真实方便得入，不假思量，性自神解，永无有退，妙用河沙也，若从善巧方便得入，得坐披衣，向后自看始得，未足将为究竟，此二种方便皆一法也，不可须臾有失，学者思之。
    清远所说真实方便，即悟心见性、履实践真。若能悟见本心，则在一切境界中皆能随心转变，自在无碍。悟见本心的内涵即悟得万法本空之理，同时又识得万法之妙用，此即空不空。证得此理，即入不二法门，动静不二，真妄不二，烦恼菩提不二，佛众生不二。即能不为逆缘所阻，不为烦恼所困，故此，证得空性是根本，本立而道生，不假修学而与道冥合。
    “道不用苦求，求之即道失；事不在苦融，融之即事有。不求不融，道与事合也，则何事而非道耶？”
    清远又说：
      修道人若遇烦恼起时如何？古人云：但以正知见治之。余则不然，只以烦恼治之。如此看来，即不见有烦恼也。何故？烦恼不可更治烦恼，如火不更烧火，水更不湿水，体性一同，无可得露。现此，了烦恼本空，不着除遣。若起智断治奈伏，却成别用心，有对待，被他二境回换，纵得，亦迂曲有分限，须行径直路为上。古人云：劫火曾将无气吹，不劳动力当时萎，此之谓也。
    所谓“以烦恼对治烦恼”，实际上是就烦恼而当下虚破，证得其因缘和合，体性本空，使身心枷锁一时脱落，烦恼当下转为菩提，不过清远也意识到，欲获得一味平等正知见，必“夙生曾种善根，素有根本”，烦恼障薄，根机纯厚者。若未薰得此心，正信不生，纵闻之亦不生疑，但如风过耳，劝之又生嗔加诽谤，此又何缘得显露？所以千万人中，但一二人而已。
    大多数修道者，须从善巧方便得入，但在清远看来，不可将善知识接引众生的方便说法视为究竟理则，而应该闻法起修，与师同参，自己亦去亲证一番始得。“烦恼即菩提，众生成正觉”皆悟后心语，若于此执持不放，认为一切无事，不修不证，则即使真的解会其意，逆顺境界现前，仍然把持不住，则瞒不了别人，更欺瞒不了自己。故此。“若不就已知归，所作皆成造伪，纵记得河沙，会尽尘墨，于已何益？”眼见学人从师家言句中寻活计，清远痛心疾首：
    近世多以问答为禅家家风，不明古人事，一向逐末不反，可怪，可怪！昔人因迷而问，故问处求证，入得一言半句，将为事究明令彻去，不似如今人胡乱问，趁口答，取笑达者。
    清远甚至说：如说依言起见，不求返照已心，则不特辜负先圣苦口垂慈，而且是断佛种子的罪人。清远屡屡告诫别学人，参禅学道是大丈夫事，就如雪峰、玄沙、南泉、赵州等先圣古德，不惮劳苦，履实践真，以悟为期，莫尚空谈，清远举雪峰语说：莫教才僧有一句子到你分上，若有一句子到人分上，堪作什么也？不只古德无所说，佛祖虽指示言教，流布世间，但亦无所说，“若言有所说，即是谤佛，”其反对“口头禅”的立场是十分鲜明的。


三、宗杲及“看话禅”

三、宗杲及“看话禅”

    （一）大慧宗杲爱国兴教的一生
    大慧宗杲（１０８９－１１６４３），俗姓奚，宣州宁国（今安徽宁国）人，依张浚所撰《大慧普觉禅师塔铭》的记载，十七岁出家受具足戒，离乡出游：先后曹洞宗尊宿洞山微禅师学禅，因缘不契。依宝峰山湛堂文准禅师。湛堂文准（１０６１－１１１５），是黄龙派真净克文的弟子，大慧前后依止六年，思想上深受乃师影响，特别是文准将禅学与儒家伦理学说的结合，重视禅的现世性品格的理路，对大慧后来提出“忠义之说”有直接影响，宗杲在宝峰锤炼六载，禅路上大有进境，但文准以为他“欠这一解在”。因为欠此一着。“我在方丈里与你说时便有禅，总出方丈便无了；惺惺思量时便有禅，总睡着时便无了。”故对宗杲放心不下，临终嘱其参访圆悟克勤。十年之后，圆悟克勤受诏主持京都天宁寺，宗杲觉缘分已到，遂急切往依。据《年谱》记载，他当时下了必悟的决心：“乃自惟曰：“当以九夏为期，其禅若不异诸方，妄以余为是，我则造《无禅论》去也。谩自枉费精神，蹉跎岁月，不若弘一经一论，把本修行，庶他生后也不失为佛法中人也。”《塔铭》谓之个性鲜明、意气极盛，“怒骂嬉笑，得之天真”，于此亦可见一斑。
    在天宁寺，宗杲亦随众上堂，听圆悟说法。一日圆悟升座，举僧问“如何是诸佛出身处？”答曰：“薰风自南来，殿阁生微凉。”宗杲有省，而圆悟则曰：“也不易，你得到这个田地，可惜死了不能得活。不疑语句，是为大病。不见道‘悬崖撒手，自肯承当；绝后再苏，期君不得’。须信有这个道理。”圆悟一则批评宗杲还存在对语言文字的执着，一则鼓励他参活句，莫参死句，应于无所攀附、无所支撑（即“悬崖撒手”）处去参悟，体认。半年后，圆悟为宗杲举白云守端“有句无句”公案：“僧问：‘有句无句，如藤倚树时如何？’”祖曰：‘描也描不成，画也画不就。’又问：‘忽遇树倒藤枯时如何？’祖曰：‘相随来也。’”此公案是五祖法演开示学人不可依藤附木，应于自己本分事上剋实参究。宗杲凭籍多年参学功底，当下彻悟，从前疑结，豁然冰释，文准座下未了之事，也一时洞明，圆悟认为终于觅到可以振兴临济正宗的人，遂将自己所著《临济正宗说》付嘱宗杲，令掌记室，并让宗杲分座训徒。二年后，宗杲离开天宁寺，受请历主虎丘等道场，在丛林中渐渐有了声望。
    如果宗杲生逢太平盛世，他也许会说法度众，终老山林，平静地度过自己的一生，但个人不能选择自己生活的时代，宗杲生活的年代正是金兵南侵，赵宋朝廷风雨飘摇的多事之秋。朝廷内部主战派与主和派门争甚为激烈。宗杲虽身在佛门，但不曾忘却世事，从建炎元年（１１２６）至绍兴十年（１１４０），前后十三年间，宗杲先是在京城险为金人所摅，后随宋室南下，于江苏、浙江、江西、福建、广东等地颠沛流离，找不到一处清净修法之地。正是在这民族危亡关头，宗杲表现出崇高的民族气节和爱国热忱。其《示成机宜》云：“予虽学佛者，但爱君报国之心，与忠义士大夫等，但力所不能，而年运往矣，喜正恶邪之志，与生俱生。”他与当时朝中的主战派来往密切，如当朝右相张浚、刑部侍郎张九成等。宗杲并且因为与张九成的交往而招致流放之灾。
    根据《大慧年谱》，禅师罹祸发生于绍兴十一年（１１４１）。源于著名的“神臂弓”事件。
    是年四月，侍郎张公九成以父卒哭泣，登山修崇，师升座，因说：圆悟谓张徽猷昭远为铁划禅，山僧却以无垢禅如神臂弓。遂说偈曰：神臂弓一发，透过千重甲；仔细拈来看，当甚臭皮袜！次日，侍郎请说法，如州了因禅客致问，有“神臂弓一发，千重关锁一时开，吹毛剑一挥，万劫疑情悉皆破”之语。未几遭论列，以张坐议朝延除三大帅事，因及径山主僧应而和之。五月二十五日准敕，九成居家持服，服满别听指挥。径山主僧宗杲，追牒责衡州。
    所谓“神臂弓”是当时宋军一种颇具威力的弓箭，曾在抗金战场上发挥很大作用，宗杲以神臂弓作喻说偈说颂，反映出其强烈的抗金卫国意识，如果引申开来，它也确实传达出一股刚毅豪迈之气，一种对金兵的蔑视和对投降派的憎恶之情。但这首偈子再招猜疑，也不过是一首论佛谈禅的偈子而已，远够不上以此定罪。实际上，张九成、宗杲因其鲜明的主战立场，早已引起以秦桧为代表的主降派的嫉恨，他们被迫害乃是意料之中的事。无论是“神臂弓”事件，还是“妄议朝政”皆是“莫须有”的罪名，宗杲已看得很清楚，故他劝止友人为他疏通说项的好意。
    宗杲先被流放衡州（今湖南衡阳），后迁梅州（今广东梅县）。梅州在当时是偏远蛮荒之地，但僧俗追随如初。“梅州瘴疠寂寞之地，内衲子里粮从之，虽死不悔。”由此可见卷其道望之高。待离开梅州时，当时居民扶老携幼，夹道礼送，情景十分感人。宗杲在流放地前后十年，及离梅州取道永嘉北上，适逢当初同罹灾祸的张九成。张当时为永嘉太守，分别十七载，一见之下，不胜唏嘘。分别之际，张九成赠诗曰：“相别十七年，其间无不有。今朝忽相见，对面成老醜。人生大梦耳，是非安足究。欲叙惓惓怀，老大慷开口。公作湖南行，我赴永嘉守。重别是今日，南北又奔走，已歃相过盟，长沙不宜久。”其拳拳深情，感人至深。
    宗杲晚年先后请住明州阿育王寺、径山灵隐寺等，并不顾年高体弱，到江南诸名刹说法。在住持育王寺时，“里粮向道者万二千指。”可见道望之高。宗杲禅师抗金热情并未因罹祸受难而稍减。在圆寂的那年三月，闻宋兵得胜还朝，作偈曰：“氛埃一扫荡然空，百二山河在掌中。世出世间俱了了，当阳不昧主人公。”
    （二）狗子还有佛性也无
    宗杲在临济宗思想发展史上的贡献，在于创立了独具特色的参悟方式——看话禅。所谓“看话”，指的是参究“话头”，而所谓“话头”，指禅宗公案中禅师的答话。在宗杲的看话禅中，此话头特指“狗子无佛性话”和“竹篦子话”等。其中“狗子无佛性话”在《大慧语录》中出现得最多，也最能反映其禅法的风格。
    “狗子无佛性”出自赵州从谂语录：“僧问赵州；狗子还有佛性也无？州云：无。僧云。一切众生皆有佛性，狗子为什么却无？州云：为伊有业识在。”对这则公案，如果从寻常理路去看，实令人费解。禅宗普遍承认“一切众生皆有佛性”，狗子是众生，所以狗子也应该有佛性。赵州却偏说狗子无佛性。这无疑是与经教的说法相矛盾，即便赵州又给出一个解释，所谓狗子有业识在，也未能消解这一矛盾。因为按照佛教教义，凡属世间众生，无不有业识在，如果狗子因有业识在而无佛性，则一切众生俱无佛性，同样与经教相矛盾。
    不过赵州禅师与学人的问答，不是在探讨教义，而是在展示禅道。问者并不是不知一切众生皆有佛性，答者也不是不知道“正确答案”，但双方并不是在经教的范围内去疑解惑，而是要在特定的情境下露出禅机、觅得禅机。而禅的第一步是起疑，疑问、疑惑又来自不解，即日常的思维解释不通或陷入思维矛盾，赵州的回答从经教的意义上看是矛盾的或不对题的，但从禅悟的意义上看，它是充满禅机的，意在截断学人思维理路，放弃向外驰求的习惯，反求诸已，著力参究。因此赵州“狗子无佛性话”与“庭前柏树子”，以及洞山和尚的“麻三斤”，云门文偃的“乾屎橛”等等一样，皆是信手拈来的道具，只为让人起疑，让人老实参究，并没有特别的意味，即是说，在赵州这里，“狗子无佛性话”仅只有否定的意味，否定人的思维情识，否定人的机言权辨，只此而已。
  最早将赵州这一公案拈出并做了发挥的是五祖法演禅师。《法演禅师语录》载：
  举：僧问赵州：狗子还有佛性也无？州云：无。僧云：一切众生皆有佛性。狗子为什么却无？州云；为伊有业识在。师云：大众，你诸人寻常作么生会？老僧寻常只举无字人便休，你若透得这一个字，天下人不奈何你。你诸人作么生透？还有透得彻底么？有则出来道看。我也不要你道有，也不要你道无，也不要你道不有不无，你作么生道？
    为什么只不过透得一个无字，天下就奈何你不得，法演没有进一步说。但引入注目的是法演不是举赵州整则公案让人参，而是单提一个“无”字，认为参透这一“无”字，就一了百了，参学事毕，这与后来“看话禅”就很近似了。另外，法演向学人特别拈出的“无”，也不是我们日常言谈中的“有无”之“无”，即不存在、没有，而是具有形而上意义的普遍性存在，它实际上指称一种状态，一种境界，这种境界惟证乃知，不可以理会，也不可以言谈。这种对“无”的外化与提炼，是“看话禅”的另一基本特徵。
    （三）一刀两段（断），直下休歇
    要参话头，必须将心中一切知识成见，通通放下，以至连能思能想之心亦一并休歇，以虚豁空寂之心去参究活头。
    决欲究竟此事，应是从前作聪明、诵道理，文字语言上记持于心意识内，计较搏量得底，飏在他方世界，都不得有丝毫头许顿在胸中，扫除得净尽也。然后向心思意想不及处，试进一步看。……
    宗杲曾以此物吕居仁居士，吕却怕参无所得，落空亡外道。宗杲认为他这种患得患失的心态本身就是见道的障碍：
    此盖以求悟证之心在前顿放，自作障碍，非干别事。……若欲将心待悟，将心待休歇，从脚下参到弥勒下生，亦不能得悟，亦不能得休歇，转加迷闷耳。
    之所以要截断心的思维卜度，知解成见，是因为用日常的对象性思维，即以主体（能知）客体（所知）相分离为前提，由主体认识把握客体的思维方式，虽然可能接近，却永远不能达到真理性认识，相反，只会陷入思维矛盾。《大慧语录》卷十六载：
    妙喜室中常问禅和子，唤作竹篦则触，不唤作竹篦则背。不得下语，不得无话，不得思量，不得卜度，不得拂袖便行，一切总不得。你便夺却竹篦，我且许你会却，我唤作拳头作触，不唤作拳头则背，你却如何夺？更绕你道个“请和尚放下著”，我且放不着。我唤作露柱则触，不唤作露柱则背，你又如何夺？我唤作山河大地则触，不唤作山河大地则背，你又如何夺？
    宗杲举手头竹篦为例，说明学人若以对象性思维去认识把握某个客体所遇到的困惑；若你肯定判断，就是“世谛流布”，即与佛教圣义谛相抵触的世俗化认识；若作否定判断，即作“佛法理论”又与人们的生活经验相违背。对人类思维中出现的二律背反现象，佛教常以真俗二谛来解释，即把世俗谛解释不了的归于圣义谛，把圣谛不能涵盖的归于世俗谛。宗杲则认为，这样看只是对矛盾的退让和逃避，即没有从根本上解决矛盾，宗杲从手中的竹篦说到拳头、露柱，又推及整个山河大地，指出这种矛盾是无处不在的，如果不改变思维理路，即便暂时能回避，最终还是陷于困惑和矛盾。
    为警策学人不可依持自己的理性思维，宗杲甚至提出，那些在世俗世界里聪明灵利的人，在参禅方面，往往反不如那些愚钝的人更容易找到入手处。因为这些人往往纔闻师家举出公案，就将心意识来领会，并依寻常理路去寻思猜度，更兼伶牙俐齿，将思量得到的，认作实法，形之词色，以逞口利。岂不知这是错用心识，枉费心机，于生死大事，无半分交涉，宗杲说：
    永嘉有言：损法财，减功德，莫不由兹心意识。以是观之，心意识之障道，甚于毒蛇猛虎，何以故？毒蛇猛虎尚可回避，聪明利智之士以心意识为窟宅，行住坐卧，未尝顷刻不与之相酬酢，日久月深，不知不觉与之打作一块。亦不是要作一块，为无始时来，行得这一路子熟，虽乍识得破，欲相远离，亦不可得，故曰毒蛇猛虎尚可回避，而心意识真是无你回避处。
    关于人类理性思维对参禅悟道的负面影响问题，前代禅师亦各有论及，如南泉普愿即称“近日禅师太多，觅个痴钝人不可得”。德山见面施棒，临济动辄大喝，皆有否定人的思维知解的意味，但对人的心意识深恶痛绝，以至喻之为毒蛇猛虎，则仅见于宗杲禅师。禅师这样做自然有不得已的苦衷，面对公案禅、文字禅流弊日识，临济正宗宗风不绝如缕的局面，宗杲不能不以激烈的言词来针砭时风，以期矫枉过正，挽回丛林颓靡之势。
    （四）看个“无”字
    那么，如何摆脱日常理性思维的束缚和控制呢？宗杲认为，“方寸若闹，但只举狗子无佛性话……若透得个“无”字，一时透得。”所谓方寸之闹，包括消极的和积极的两方面的意念活动。消极的方面即人的妄想颠倒，诸种烦恼。也包括人的思维意识；而积极的方面，指人汲汲求悟而又不摸门径、寻不到入处的心理状态。依宗杲的看法，看“无”字话头，不特止妄想颠倒，亦且破疑情，明根本，洞见自家本地风光。
    疑情未破，但只看个古人入道底话头，移诸日许多作妄想底心来话头上，则一切不行矣。僧问赵州‘狗子还有佛性也无？’州云‘无’，只这一字，便是断生死路头底刀子也。妄念起时，但举个‘无’字，举来举去，蓦地绝消息，便是归家稳坐处也。此外别无奇特。
    宗杲还认为，“千疑万疑，只是一疑。话头上疑破，则千疑万疑一时破。话头不破，则且就上面与之厮崖。”参“无”字话头，为什么会有如此效力呢？宗杲认为，关键在于参透‘无’字即意味着破生死心，断生死命根，即了辨生死大事。
    人们在生活中之所以百般算计，千般计较，皆源于执妄为实，认假为真。而这种颠倒妄想又源于将心识与万法截然分离，执持万法为实有。从而未得患得，已得患失，终日在名利场上、是非窝中备受煎熬。看“无”字话头，就可以斩断分别性思维、对象性思维的自然趋向，在迷闷痛绝处，豁然悟到万法惟识，一切皆空，空亦不立的空明境界，断分别心，灭生死心，从有分别、有对待的差别境界，进入无生玩灭、无分别无对待的涅盘境界。其《示妙净居士》云：
    苟能直下信得及，不向外驰求，亦不于心内取证，则二六时中，随处解脱。何以故？既不向外驰求，则内心寂静；既不于心内取证，则外境幽闲，故祖师云：境缘无好醜，好醜起于心。心若不强名，妄情从何起？妄情既不起，真心任遍知。知内心外境，只是一事，切忌作两般看。
    宗杲还举沩山问仰山：“妙净明心，子作么生会？”仰山云：“山河大地，日月星辰”，妙净明心即是山河大地，山河大地亦即是妙净明心。修行功夫，即在于时时保任此妙净明心，不受染污。“若妄念起时，不必用力排遣，只举僧问赵州‘狗子还有佛性也无’，州云‘无’。举来举去，和这举话底亦不见有，不觉失声大笑一巡时，便是归家稳坐处也。”显然，看“无”字话头，同时具有“止”和“作”两方面的功用。“止”即止息妄念思虑，达到言语道断、心行处灭的确良境界；“作”即明心见性，达到不生不灭、湛然常寂的空明境界，而且“止”和“作”的过程是一体的，止息妄念的过程同时也就是证悟清净心地的过程。
    （五）不得作有无会
    在《大慧语录》中，宗杲除举赵州狗子无佛性的话头外，常举的话头还有云门的“乾屎橛”和“露”字话头，在古德千百则公案中，宗杲为什么单提这几则话头让学人去参呢？这与宗杲“看话禅”对“悟”的理解直接相关。具体言之，在看话头过程中，“疑”、“断”和“悟”是密不可分，或者说是一体的。古德有言，“小疑小悟，大疑大悟，不疑不悟。”疑是悟的前提，也是走向悟的门径。那么如何生疑呢？宗杲看来就是把自己的日常思维推向绝处，如老鼠钻入牛角尖相似。直到思无可思，想无可想之时，漆桶打破，命根立断，世谛流布，佛法理论，一齐抛却，纔悟见光明澄彻的新天地。在这一过程中，话头如一把利刃，参话头即以此利刃将种种虚妄，种种思量一齐斩断，如斩一团乱丝相似，一斩一齐斩，一断一齐断。那么什以样的话头纔有这样的效用呢》必然是易使人起疑情者。“无”、“乾屎橛”、“露”等在禅机问答中，没由头地被禅师指出，学人必有被兜头泼下一身冷水相似。因为这些词语或物事，与学人所问或南辕北辙，或毫不相干，乍听之下，必生错谔和惊讶，与遭师家棒喝相似。寻常习惯的思维路数至此不再起作用，问来问去，未得明白，反倒更加“迷惑”。而这种迷惑正是参禅所需要的，应该注意的是，对赵州“无”字话头，不得从“有无”的角度去寻思索解，即不能去“思想”，而必须进入特定的禅的氛围中去“体证”。他说：
    但将妄想颠倒底心，思量分别底心，好生恶死底心，知见解会底心。欣静厌闹底心，一时按下，只就按下处，看个话头，僧问赵州‘狗子还有佛性也无？’州云‘无’。此一字子，乃是摧许多恶知恶觉底器杖也。不得作有无会，不得作道理会，不得向意根下思量卜度，不得向扬眉瞬目处朵根，不得向语路上作活计，不得飏在无事甲里，不得向举起处承当，不得向文字中引证。但向十二时中、四威仪内，时时提断，时时举觉‘狗子还有佛性也无’之‘无’。不离日用，试如此做工夫，看月十日，便自见得也。
    这里提出参“无”字话头所应注意的两个方面：其一是正确理解“无”　的意义和功用。“无”在参话头的过程中，不能做实词解，即不能认为它有世俗所谓实在的意义，也不能认为它有圣义谛所谓实在的意义。简单地说，当赵州回答学人“无”时，他既不是在“有无”的意义上讲狗子无佛性，也不是指引学人去认取“无心”、“无事”或“无念、无相、无住”等等佛教第一义谛的道理。它只具有否定的意义，警示参禅者“不得作有无会，不得……”。如果它有什么实在的意义，其意义就在于这八个“不得”。参禅者以“无”字，将一切世间法、出世间法扫荡尽净，为下一步的开悟留下一空旷虚豁的心灵空间。其二是在日常生活中参话头，这是针对当时的文字禅、默照禅而发的。参话头不必拼绝一切世缘，专在语言文字上下功夫，谈玄谈妙或做出一篇词句美妙的偈颂，也不得专在静默处去苦思冥想。只须在行住坐卧中时时照顾“无”字话头即可。“古人云：‘我这里是活的祖师意，有什么物能拘执他，’若离日用，别有趣向，则是离波求水，离器求金。求之愈远矣。”在参禅者现实的生命活动中，开悟有重要意义，因为禅是活生生、活泼泼的，是打通了个别和一般、短暂与永恒、个体与宇宙的分别和对待之后获致的境界，而一般只能在个别中体现、永恒寓于每一个瞬间，宇宙全体也只能在有情识的生命个体中得到全息表达。所以禅的境界只能在个体现实的生命实践中得以实现。
    （六）随缘放旷，任性消遥
    参“无”字公案得悟，还可以从惟识学的角度得到说明。依惟识学的观点，心识分为八识，其中前五识眼耳鼻舌身相当于感性认识，第六识意识相当于理性认识，第七识末那识相当于悟性认识，第八识种子识属于本性或自性认识。八识之中，第七末那识常执第八识的相分为自内我，这就是俱生我执，由此我执，众生的意念行为，都是有分别、有对待，从而招致种种无明烦恼。所谓开悟，就是在第七识上完成彻底的转向，破除我执，这样第八识中的一切种子就变得清净无染。按惟识学的说法，即转第七识为平等性智。第七识既转，第八识亦转为大圆镜智，第六识转为无分别智。第六识既转，即破除分别性、对象性思维障碍，以清明澄彻、整体圆融的意识去支配前五识，就能五圆六通，所作著办，此即成所作习，宗杲说：
    只觉得肚里闷，心头烦恼时，正是好底时节，第八识相次不行矣。觉得如此时，莫要放却，只就这无字上提撕。
    第八识既除，则生死魔无处栖柏，生死魔无栖泊处，则思量分别底，浑是般若妙智，更无毫发许为我作障。
“第八识相次不行，”即通常所说的“言语道断，心行处灭，”意味着平素人们习以为常的分别性思维暂时休歇。宗杲认为此时正是着力处，须着实参究。所谓除却第八识，是指将业识染污种子拔除。需要指出的是，这里所谓烦恼种子只是比喻性说法，并不是实体性、物质性存在，它只是一种习气，一种原始的带倾向性力量。所谓拔除，是指上述所说的由识到智转变，完成这一转识成智的过程，般若之体当下即显发无上妙用。此时已消除了我障和法障，无分别心和生死心，从而进入一种自由的天地。
    宗杲还对这种境界描述说：
    若得地一下了，儒即释，释即儒，僧即俗，俗即僧，凡即圣，圣即凡，我即你，你即我，天即地，地即天，波即水，水即波，酥酪醍醐搅成一味，瓶盘钗钏熔成一金，在我不在人，得到这一田地，由我指挥，所谓我为法王，于法自在，得失是非，焉有罣碍？
    这也就是禅师常讲的自己做得主宰，心能转物而不为物所转的境界。有了这样的境界，“种种胜妙境界现前，心不惊异；种种恶业境界现前，心不怕怖”。不以物喜，不以已悲，不为情困，“随缘放旷，任性消遥。”这实在是人类共有的对人生自由的向往和追求。
    （七）看话禅与默照禅
    宗杲在创立看话禅的同时，对当时僧界和士大夫阶层流行的默照禅，进行了激烈的抨击。默照禅的代表人物，是活跃在北宋末年到南宋初年的曹洞宗禅师宏智正觉。宏智正觉是汝州（河南临汝）香山寺枯木法成的弟子，受丹霞子淳影响很大。法成与子淳都提倡坐禅，子淳常教导僧众“把今时事放尽去，向枯木堂中冷坐去”。正觉承续了二人重视坐禅的传统，同时充实独具特色的观法，形成与宗杲看话禅相对峙的默照禅，宗杲在其与当时的士大夫的通信中，多次批驳默照禅，透过这种批驳，我们可以更清楚地看出看话禅的特质。
    默照禅有两方面基本内涵，一方面是通过坐禅，休歇众缘，体得清净本性，亦即“明空劫前事”；另一方面是观照法界虚空，即体证万法之空性。此“默”与“照”的关系是一体无二的，前者是心之体，后者是其神照功能，以正觉的话说，则是“一切法到底其性如虚空，正恁么时却空它不得。虽空而妙，虽虚而灵，虽静而神，虽默而照。”正觉认为，静坐守寂是获得开悟的惟一方式。
    宗杲的批评也集中于这两个方面，首先是坐禅求静问题，宗杲并不一概反对参禅打坐。有位叫刘彦修的居士来信云：“夜梦画思，十年之间，未能全克，或端坐静默，一空其心，使虑无所缘，事无所托，颇觉轻安。”宗杲在回信中指出这位居士的修法属于初祖达摩的“壁观法门”。所谓“虑无所缘”即达摩所说的“内心无喘”；所谓“事无所托”也即摩所说的“外息诸缘”。确实，正觉的默照禅与达么的壁观法门，都要求外不被因缘流转，内无攀缘之思，而且都必须在静坐默究中完成，它们之间有着渊源关系。但宗杲却认为，达摩禅只是开悟的方便法门，而不是究极真实。“外息诸缘，内心无喘，可以入道，是方便门；借方便门入道则可，守方便而不舍则为病。”默照禅恰恰是认方便为究竟，将手段当成了目的。
    坐禅默究是为了求静，但单纯默坐真能达到心静、心寂吗？宗杲认为若要心地清净，必先究明生死大事，生死心不灭，只是枯坐求静，反倒会愈求愈迷。他说：
    今时有一种剃头外道，自眼不明，只管教人死獦狙地休去歇去。若如此休歇，到千佛出世也休歇不得，转使心头迷闷耳，又教人随缘管带，忘情默照，照来照去，带来带去，转加迷闷，无有了期。
    宗杲还认为，于静处做工夫，只是祖师应病与药的方便，是针对那些心性浮躁、无明烦恼炽盛者所开出的对治法门，而且只是入道初门。真正有一定进境后，还必须于闹处保任静境，虽在繁杂世缘中，而心不忘却竹椅蒲团上事，若一处闹处就把持不住，正说明在静中做工夫不到家。他说：
    若以静处为足，闹处为非，则是坏世间相而求实相，离生灭而求寂灭，好静恶闹时，正好著力，蓦然闹里撞翻静时消息，其力能胜竹椅蒲团上千万亿倍。
    宗杲还常举南岳怀让磨砖作镜的公案来开示学人，单纯地坐禅求悟，而不在明心地上下功夫，则如同磨砖而欲成镜一样荒唐可笑。显然，宗杲对坐禅的看法，是直接承续六祖慧能的观点的，他也屡屡引用永嘉玄觉的名言“行亦禅，坐亦禅，语默动静体安然”，力图将学人引导到现实生活中去修行，将禅行与平凡的生活打成一片。
    关于默照禅的第二个方面，宗杲也认为对自我心性的体证不同于对象性认识，因为此心性无方所、无名相，不能做为通常的认识对像去把握。而这一点也正是宠智正觉的“默照禅”所反复强调的，正觉认为“默照”工夫是“不触事而知，不对缘而照”，不是在静寂状态中起心动念，去观照某一特定对像，而是即默而照，即照而默。实际宗杲和正觉所说的这种特殊形式的体证和观照，是在人的第八识发生的心体的自认识，认识者和认识对象是一体的，而不是像前五识和第六识那样，有能知所知、能证所证的区分。而且这种本心的自认识，只有在第七识都暂时停歇的情境下总能实现。这也就是正觉所说的：“照与照者二相寂灭，于寂灭中能证寂灭者是你自己。”
    对摒息人们惯常的情识见解，宗杲与正觉相同。不同之处在于，宗杲认为，只是情念不生、冥然无知，并不必然就会明心见性，彻悟本来面目或本地风光。在一念不生之后，还必须把住一个话头，或“乾屎橛”，或“露”，或“东山水上行”，当然最便捷的是把住一个“无”字去参究。由参话头功夫不仅可以彻底止息妄念情识，而且也是通向开悟的必由门径。默照禅所追求的一念不生而又灵光历历的境界是开悟的必要条件，但不是充分条件。欲得心地洞明，必有“枯歇身心”的功夫，但身心枯歇，并不一定意味着大事了毕。宗杲常以“百尽竿头，更进一步”来说明，“顿舍外尘，时时向自己脚跟下推究，推来推去，内不见有能推之心，外不见有所推之境。净倮倮、赤洒洒，没可把……当人知是般事，便好猛著精彩，向百尺竿头，快进一步，”如果于空无所有之境止步不前，则是坐于魔窟鬼穴中，永无悟期。
    另外，对心体之妙用，宗杲与正觉也有不同的说法。证得心体亦即证得般若之体，般若之体发为妙用，应该是遇缘接物、自然合道。所谓“如实而见，如实而行，如实而用”，即是这种意思。正觉虽然也讲“般若故兴大用，涅盘故寂灭无余，无余故烦恼永尽，大用故圣化无穷，”但他的“默照禅”因为是在静坐守寂中完成的，所以有排斥实际的生活和日常的认识的倾向。“隐几虚心还自照，炷香孤坐绝它思”，显示出其禅行强烈的内敛性格，而“形仪谈如，陶腹空虚；懒不学佛，纯不知书”，“梦蝶境中闲有趣，露蝉胸次净无尘，”则反映出回避现实、于物我相忘中求得逍遥和解脱的修行取向。
    宗杲则将空观贯彻到世间事物，认为若证得般若，世间一切无不是方便，无不是妙用，就人的认识活动而言，在未证未悟时，众生随识而行，在烦恼生死海中头出头没。若证得般若心体，则转识成智，随智而行，随智而行并不是断灭一切心行，而是即心行而显智慧。“教中所谓随识而行不随智，以故昧却本地风光、本来面目。若或一时放得下，百不思量计较，忽然失脚蹋著鼻孔，即此识情。便是真空妙智，更无别智可得。若别有所得、别有所证，则又却不是也。”而且更重要的是“空”不虚悬，必藉“有”而显，第八识转为大圆镜寂，还必须通过前六识转为无分别智和成所作智来得到表达。“从上大智慧之士，莫不皆以知解为俦侣，以知解为方便。于智解上行平等慈，于知解上作诸佛事。如龙得水，似虎靠山，终不以此为恼，只为他识得知解起处。既识得起处，即此知解便是解脱之场，便是出生死处。”
    再就遇缘应物而言，默照禅主张于静处求静，正觉本人“画夜不眠，与众危坐，三轮俱寂，六用不痕”，他教导学人也是“结屋安禅，兀如枯株”“惟廊照本真，遗外境界”。对芜杂喧闹的现实，采取“坐忘”“无心”的态度。宗杲批评道：
    今时人不悟个中道理，妄自涉事涉尘，处处染著，头头凿绊。纵悟则尘境纷纭、名相不实，便拟凝心敛念、摄事归空、闭目藏睛。随有念起，旋旋破除，细想纔生，即便遏捺。如此见解，即是落空亡外道，魂不散底死人，溟溟漠漠，无觉无知，塞耳偷铃，徒自欺诳。
    这种批评是相当激烈的。宗杲认为佛法不离日常生活，如果能于平常生活中“觉得省力时，便是得力处”。所谓“省力”不过是随缘酬酢，自然合适，不须着意而已。古德云：“但于事上通无事，见色闻声不用聋”，又云：“愚人除境不忘心，智者亡心不除境。”能够于一切处皆无心，则一切差别境界自然化为平等境界。
    禅是讲人生解脱的理论和实践的，这种解脱不是对现世矛盾的回避，无论是思想上的“枯歇身心”，还是行动上的“枯坐守寂”都是如此，因为这种回避并不能最终解决矛盾，而最多是暂时忘却这些矛盾。待回到现实生活，人还是不能摆脱这些矛盾的困扰和压迫，不能获得人生真正的自由和逍遥。无论是“看话禅”还是“默照禅”，都是心地法门，皆属于出世间解脱法的范畴。但出世间解脱并不能摒弃世间法而实现，只有正确处理和解决了出世间与世间的矛盾，纔能于世间、出世间出入自在，此即在世间而出世间，出世间而不离世间。在这方面，宗杲确实比正觉高出一筹。这并不是说宗杲解决了禅师们都要遇到的这一基本矛盾，而是说，他更自觉地意识到这一矛盾对人生解脱的重要意义，他的禅法因而也更具有圆融世间和出世间的品格。在宗杲看来，所谓出世间解脱法，不过是在世间“识得破，作得主，不被他牵引”。于逆顺境界方寸不乱、脚跟立定。宗杲云：“逆境界易打，顺境界难打。逆我意者，只消一个忍字定省，少时便过了。顺境界直是无你回避处，如磁石与铁相偶，彼此不觉合作一处。”所以于现实生活中把得住并不容易，许多人于做工夫时能守得静寂，一涉世缘即方寸大乱，这就不能说功夫到家。
    宗杲与正觉禅师观点上的差异，与他们的宗派传承和个人的开悟经验有关。宗杲虽曾从曹洞宗僧人学禅，但因缘不契，后蒙湛堂文准、佛果克勤接引而开悟，故其后来的禅风，既见出杨歧派机辨无方、灵活多变的风格，也能见出黄龙派大开大合、圆融自在的宗风。尤其是湛堂文准强调在生活中了生死、在了生死中生活，成为宗杲终生奉持的禅行准则。另外，宗杲虽身处方外，而不能忘情世事，“爱君忧国之心与忠义士大夫等”。故广泛结交当朝官僚士大夫，力主抗金收复失地，这都使其禅法具有强烈的入世品格。宏智正觉师从枯木法成，而枯木法成之师则是北宋末年高僧芙蓉道楷。芙蓉道楷戒行谨严，不染世俗，宋徽宗曾赐紫衣和师号，道楷拒不接受。和同时期临济宗禅师不同，道楷与官僚和士大夫的关系相当疏远。对正觉禅学思想影响最大的丹霞子淳继承道楷的传统，极重坐禅，常让学人“把今时事放尽去，向枯木堂中冷坐去”。正觉的开悟，据说也是在“宴坐入道”后，听子淳讲到“空劫前自已”一语而豁然有省，正觉个人的禅悟体验对其谨严冷峭禅风的形成，有着直接影响。
    有意思的是，虽然宗杲力辟默照禅，但他与宠智正觉的个人关系却很好，正觉临终曾致书宗杲，请他主持自己的后事。宗杲在正觉圆寂后，为其遗像作赞云：“烹佛烹祖大炉鞴，锻凡锻圣恶钳锤。起曹洞于已坠之际，针膏肓于必死之时。善说法要，罔涉离微。……个是天童老古锥，妙喜知音更有谁。”不仅对正觉一生作了很高评价，而且把正觉引为知音。这说明宗杲和正觉所争者是禅法正道，不关个人恩怨。
    （八）看话禅与公案禅
    看话禅是从公案禅中脱胎出来的，看话的“话头”、诸如“无”字、“庭前柏树子”、“东山水上行”、“乾屎橛”、“露”、“麻三斤”等等，都是宗杲从古德公案中拈提出来以供学人参究的。在宗杲应请所作的大量“普说”和“法语”中，宗杲多就前代祖师大德的悟道因缘开示学人。虽然宗杲对待这些公案的着眼点不同，但他的看话禅与公案禅千丝万缕的联凿是显而易见的。他说：“凡看经教及古德入道因缘，心未明了，觉得迷闷、没滋味，如咬铁橛相似时，正好著力。第一不得放舍，乃是意识不行、思想不到，绝分别，灭理路处，寻常可以说得道理、分别得行处，尽是情识边事，往往多认贼为子，不可不知也。”可见宗杲并不一般反对静坐，也并不一概反对参究公案，参公案作为接引初机的方便，自有其价值和意义。
    但宗杲所创立的看话禅又与传统的公案禅不同，单从形式上看，看话的“话头”，指的是公案的答话，并非公案全部。如赵州“狗子无佛性”公案，宗杲让学人拈提参究的仅只是其间赵州的回答“无”字，并不让学人就整个公案去参究，而且宗杲还屡屡提到思量卜度整则公案，在公案的文句意旨上下功夫的徒劳无益，“千疑万疑，只是一疑。话头上疑破，则千疑万疑一时破；话头不破，则且就上面与之厮崖。若弃了话头，却去别文字上起疑，经教上起疑，古人公案上起疑，日用尘劳中起疑，皆是邪魔眷属。”
    从内容上看，参话头与参公案也有明显的区别。学人参究话头与参究公案的出发点、目的和“方法”各不相同（如果说真有方法的话）。
    １、有心参与无心参
    这里的有心、无心，非世俗意义上的有意无意，而是指对心识知见在参禅悟道中的作用的不同看法。宗杲特别强调在参话头之前休歇一切心识活动。他说：“但将妄想颠倒底心，思量分别底心，好生恶死底心，知见解会底心，欣静解会底心，欣静压闹底心，一时按下，只就按下看个话头。”宗杲还认为参话头应于日用应缘处时时用力，待机缘成熟，自然贯通，不可克意用强。求悟之心过重，反倒成悟道的障碍。“赵州狗子无佛性话，喜怒静闹处，亦须提撕，第一不得用意等悟，若用意等悟，则自谓我即今迷、执迷待悟，纵经尘劫，亦不能得悟。但举话头时，略抖擞精神，看是个什么道理。”宗杲由此而肯定静坐习定的价值，认为修道参禅者首先应使心不放逸，十二时中意识保持寂静，如赵州禅师所云“老僧十二时中除二时粥饭是杂用心，余无杂用心处，”能如此真实行履，久之身心自然常寂。
    而参公案者则不然，一些知解之徒，不于本分事上著力，专以拈提古人公案为日课，“将古德入道因缘，各分门类，云这几则是道眼因缘，这几则是透声色因缘，这几则是亡情因缘，从头依次第，逐则搏量卜度，下语商量”。知见纷纭，呈偈呈颂，但因缘真实悟处，脚跟未着她，所以“若不以古人公案举觉担撕，便如盲人放却手中杖子，一步也行不得。”宗杲认为这些禅和子病在知见太盛，不明禅不在古人、不在公案，而就在当下自己的本心。所以错用心识，忘已逐物，转求转迷。有人举祖师语云“正说知见时，知见即是心。当心即知见，知见即如今”来为自己辩解，宗杲则明白指出：祖师所说是开悟后的境界，而非未证未悟之前的事。对初机浅学，还是应该于自己本分事上着力，而不可乱逞知解，宗杲甚至认为，“纔涉秋毫知见，即蹉过脚跟下消息。脚跟下消息通了，种种知见，无非尽是脚跟下事故。”明心与知见，是本和末的关系，本立而道生，本心既明，不愁无知见。但如果本末颠倒，先后知见入手，则明心见性，遥遥无期。
    ２、参活句与参死句
    宗杲曾提出参究话头的一个总的原则，即参活句，莫参死句。他强调：“夫参学者，须参活句，莫参死句。活句不荐得，永劫不忘；死句不荐得，自救不了。”“死句”、“活句”的说法在宋代禅林并不少见。与宗杲同时代且私交甚笃之慧洪，认为“夫语中有语，名为活句；语中无语，名为死句。”是说在禅机对答中，若能不受语言文字的限制，在看似答非所问中体现出玄旨来，则称活句，否则随问作答，堕在言句，则称“死句”。另一宋代禅师祖琇则认为，“活句”不应仅限于玄言妙语，万千世象中，凡能启人开悟者，都可称为“活句”。所谓“棒喝讥诃，戏笑怒骂，以致风声雨滴，朝明夕昏，无非活句”，祖琇的说法已经超出了参究公案或话头的范围，是在更广泛的意义上说明“死句”、“活句”问题，即凡能使人开悟的因缘，皆可称“活句”，它们可以是公案，可以是话头，也可以是形体语言（禅势）或大自然的“语言”，总之，并不限于语言文字一途。
    宗杲所说活句、死句，也具有宽泛的意义。他甚至还在活句、死句外，另增加一“不死不活句”。在他看来，看禅师或学人的问答是死句还是活句，不应只就问答本身看，而主要看问答者是否有真实悟处。若真实证得本分，则出语皆为“活句”，若并无悟处，单以聪明知见示人，则言词再妙也仍属“死句”，宗杲据此对当时禅林的公案禅进行了激烈抨击，如他讽刺当时说法的禅师道：
    如今人不曾亲证亲悟，只管百般计较，明日要升座，一夜睡不著，这个册子上记得两句，那个册子上记得两句。拼拼凑凑，说得一片如华似绵，被明眼人冷地觑见，只成一场笑具。
    如此说法，如此评公案，不知让多少人死在句下。所以宗杲感叹道：“法本无曲，只为学者将曲心学，纵学得玄中又玄，妙中又妙，终不能敌它生死，只成学语之流，本是个无事人，却被这些恶毒在心识中作障作碍，不得自在。”赚煞学人慧命的“死句”，这种妄称禅师的语句为害最烈，因为学人自己不明，所误者自己，而师家不明，则一盲引众盲，从学者皆入荆棘丛中而不得出。
    师家如此，学人中不明进路嗜好也比比皆是。如有一些人以“谈”禅和“解”禅为能事，走向口头禅、文字禅的歧路，宗杲举例抨击这种倾向说：
    僧问云门：“如何是透法身句？”门云：“北斗里藏身”你作么生会？学者即大瞠却眼云：“北斗里藏身”。师家或权为沮抑，学者又连叫数声云：“北斗里藏身，北斗里藏身。”以谓把得定、作得主、不受转唤。……
    宗杲又举一例：有一位居士爱说道理，宗杲即举云门“乾屎橛”话头让他参，并言明不得说“道在屎溺，道在稊稗，道在瓦砾，”不得说：“即色明心，附物显理，”也不得说：“处处真，尘尘尽，是本来人”之类。多日以后，此居士自称有个悟处，呈数首偈子，其一曰：“太虚寥廊强为名，任是僧繇画不成。何用寻源问端的，都无一法可当情。”宗杲向这位居士道：“作得颂也好，说得道理也是，只是去道转远。”此居士还未觉悟，又作一颂曰：“切忌谈玄说妙，那堪随声逐色。和这一橛扫除，大家都无见识”。这位居士虽然文字功夫了得，数首偈子也表现出一定见地，但终究是在文字知见上绕圈子。这样的偈子同样也可以用于其他的公案，丝毫显示不出其间的差异，这位居士虽然比上例中的师徒来得聪明伶俐，但所出言句皆非从胸襟中流出，是靠思索“构想”出来的，属于比量的东西，而不是由修证而得的现量，所以从根本上说这些都是死句而非活句。
    ３、亲证亲悟与多知多解
    宗杲出道弘法不久，曾有一警世骇俗之举，即公开烧毁圆悟克勤所著《碧岩录》，在当时禅林影响很大。宗杲对自己师长的著作采取这种极端的态度，虽在不重权威的丛林也是罕见的。其缘由，据陵禅师在《碧岩录后序》中说：
    ……后大慧禅师，因学人入室，下语颇异，疑之，纔勘而邪锋自挫，再鞠而纳款自降，曰：我《碧岩集》中记来，实非由悟。因虑其后不明根本，专尚语言，以图口捷，由是火之，以救斯弊也。
可见宗杲毁《碧岩录》版，非否定其师的禅学观点，而是为抑制当时禅林由此书引发的种种流弊。无论是雪宝的《百则颂古》，还是克勤的《碧岩录》，都是禅宗典籍中的上乘之作，不仅见地纯正，而且文词优美，深入般若三昧，这些颂古或评唱皆从现量中来，非有修有证而不能出，孰料后来人不明就里，本末倒置，欲图快捷，径直从研习公案入手，以为通晓百则公案，作得数首偈子，也便与祖师把手同行，学人既有此病，又乏明眼禅师指正，遂相沿成习。师徒问答日益形式化，研穷公案成为禅僧生活主要内容，忘却了开发自己内在的生命之源，禅徒有形式躯壳，而失去了根本的精神内涵，宗杲的激烈行为，不过是对当时禅僧的头棒喝。
    宗杲反对“说”禅、“解”禅，是与其亲证亲悟主张相一致。他认为当时禅林的颓风，皆因学人不曾亲证亲悟，而只在语言文字上思量计较，岂不知“此事决定不在言语上，若在言语上，一大藏教、诸子百家，遍天遍地，岂是无方，更要达摩西来直指作么？”禅是了辨生死大事的生命的学问，非亲去参证一番，不能有个悟处。古德常言“悬崖撒手，自肯承当，绝后再苏，期君不得”。没有经历过大疑、大死、大迷的历练，也就不会有真实的大悟。禅林常有某某大德在祖师会下“言下大悟”，其实悟不在言，祖师之言不过是偶然的契机，并不是学人开悟的关键，听禅师说法，契与不契，不在意会，不在言词，也不在能否呈偈呈颂，而在于是否则真实悟处，清凉禅师云：“放旷任其去住，静鉴觉其源流。语证则不可示人，说理则非证不了。”宗杲遂感慨道：
    而今人纔闻恁么说话，将为实有恁么事，便道我证我悟，……殊不知，亲证亲悟底，惟亲证亲悟底人不假言词，自然与之默默相契矣。
    但禅林许多学人，自恃聪明灵利，纔闻善知识说法，便将心意识来解会，未有悟处，心中先有一重障碍，更有参禅士大夫，平日博览群书，记持许多古人言句以资谈柄，亦是依语生解，见指亡月。所以宗杲提出，对参禅来说，利根人往往还不如愚钝人容易有个悟处，只因为聪明所被聪明误，不摸进路，转求转迷。
    宗杲奉劝天下学人“无常迅速，生死事大”，于“生从何来，死向何去”起疑情，把得话头，蓦直参去，以悟为期，不稍懈怠。总有直下顿了的那一刻，且不可从语言知解处入手，贻误一生。至于种种知见、种种语言、种种智慧，皆是末端，得本不愁末。若真正空却本心，亲证亲悟到本地风光，于现实生活中应物随缘，七颠八倒，皆可放旷自在，不为外境所滞碍。
    （九）看话禅与士大夫佛教
      大慧宗杲所著《宗门武库》载有王安石一段佚事：
    王荆公一日问张文定公，曰：孔子去世百年生孟子，亚圣后绝无人，何也？文定公曰：岂无人？亦有过孔孟者。公曰：谁？文定曰：江西马大师、坦然禅师、汾阳无业禅师、雪峰、岩头、丹霞、云门。荆公闻举，意不甚解，乃问曰：何谓也？文定曰：儒门淡薄。收拾不住，皆归释氏矣。
    王安石与张方平的问答，反映出唐宋时期一个重要史实，即一此优秀的知识分子跻身佛门，使儒家失落的道统，在佛门得到赓续，张方平的说法也许有些言过其实。因为当时的儒门也并非无人，只是思想上没有根本性突破和发展而已。但当时的释门确实大德辈出，如张方平所列举诸禅师，皆以独特的禅风、鲜明的个性扬名禅林，并且在整个社会也极著声名。王、张的问答，尤其是张方平的见解，从一个侧面，透露出士大夫阶层对禅门大德的服膺，也折射出禅宗在士大夫圈中影响之大。
    有宋一代，与禅门耆宿交往之官僚士大夫，多不胜数，如苏东坡之与佛印禅师，黄庭坚之与灵源惟清，张商英之与兜率从悦、圆悟克勤等等。而大慧宗杲与当朝官僚、士大夫的交往，无论是范围还是密切程度，都是超过前代禅师的。经常与宗杲交往的有侍郎张九成、丞相李邴、学士吕本中等，他们皆登堂入室，称为方外道友。宗杲也在和他们的激扬酬唱中，阐发了对居士佛教的看法，使看法禅的影响扩大到社会士大夫阶层。
    宗杲首先指出，在家参禅悟道是可能的，因为佛法即世间法，世间法即佛法，佛法通则世间法亦通，即可随缘自在。其《示曾机宜（叔迟）》云：
    如何是不坏世间相而谈实相？妙喜为尔说破：奉侍尊长承顺颜色，子弟之职当做者不得避忌，然后随缘放旷、任性逍遥。日用四威仪内，常自检察，更以无常迅速生死事大时时提撕；无事亦须读圣人之书，资益性识，苟能如是、世、出世间俱无过患矣。
这是就一般的佛法与世间法关系而言的。修佛法并不一定隐遁山林、与世隔绝，抛弃世俗的生活，躲避社会的责任和义务。恰恰相反，对士大夫来说，只有在恪尽本分同时去参究，纔可能获得觉悟并得到受用。对参话头来说亦是如此。“赵州狗子无佛性话，左右如人捕贼，已知窝盘，但未捉著耳。请快著精彩，不得有少间断。时时向行往坐卧处，看读书史处，修行义礼智信处，侍奉尊长处，提诲学者处，吃粥吃饭处，与之斯崖，忽然打失布袋，夫复何言？”参话头与日常生活能够协调一致，不相矛盾，根本在于佛性与万法本性相通，明佛怀只能在应物随缘中实现。这也就是百丈禅师所谓“欲识佛性义，当观时节因缘，时节若至，其理自彰。”
    宗杲五十二岁那年，张九成登径山问道，谈及儒家“格物”之旨，宗杲曰：“公只知有格物，而不知有物格”。张不解，求问意旨，宗杲为他讲了唐代小说中的一个故事：安禄山叛乱时，有一附逆者曾为阆州太守，唐玄宗避乱到蜀地，见到此人画像，令人用刀砍画像上的头，此人在陕西果真人头落地。张听了“顿领厥旨”，并作偈曰：“子韶格物，昙晦物格，欲成一贯，两个五百”。宗杲与张九成，都是有真实悟处之辈，所以对以上问答，若非出常情之流莫如其落处。其实，格物、物格、故事、偈颂，皆是小说家言，不可作实意会。宗杲见张九成请问“格物”义，就知道他还落在知解窠臼，于是将错就错，和他虚以周旋，张多亏也具作家手眼，不为所瞒，以并无意味的偈子，道出自己的见地，并得宗杲首肯，这可以称为“主看主”的境界。
    宗杲生活的年代，正是朱熹理学流播天下的时代。格物明理，几成为士大夫的“口头禅”，宗杲并不反对士大夫照理学家的一套理论做工夫，但认为要解决生死大事，除生死命根，则必须参禅，具体地说即参狗子无佛性话头。他说：
    今学者往往以仁义礼智信为学，以“格物”、“忠恕”、“一以贯之”之类为道，只管如搏谜子相似，又如泉盲摸象，各说异端。释不云乎：“以思惟心测度如来圆觉境界，如取莹火烧弥山。”临生死祸福之际，都不得力，盖由此也。
    当然，儒家“存诚”、“主敬”的功夫也包含着于性地用功的内容，并不全是知解工夫，但从格物入手，总有向外驰求的倾向，其后“空说性论”等等流弊也与其用功趋向有直接关系。所以宗杲告诫学人应于性地著力，此性人人本具，区别只在人心是惺悟还是狂乱。只有休歇一切狂乱情识，把得话头，自会有契合处。“若识得仁义礼智之性起处，则‘格物’‘忠恕’、‘一心贯之’在其中矣。”
    宗杲还指出士大夫参禅易出现的两种偏差，其一是单纯求静，落于默照禅窠臼。士大夫多为尘劳所障，喜静压闹，只求能够迅速从参禅中得到受用，结果往往为邪师引诱“寒灰枯木”去。岂不知禅“不在静处，不在闹处，”既不离静坐，又非静坐可了。
    其二是“今士大夫多是性急，便要会禅，于经教上及祖师语句中卜量，要说得分晓。”因为只求速效，宗师未开口时，早将心意识来领解，岂不知禅决定不在言语文字上，决不是口传心受而可得。宗杲提出：“要参妙喜禅，须是辨得一生不会始得。若要求远效，则定是相误。何以故？只为从来无法与人。”士大夫聪明知见太多，造成各种恶知恶解，妨碍般若智慧的发挥，所以士大夫参禅，不患不聪明，患太聪明，不患无知见，而患知见太多。士大夫应该对参禅悟道有坚定的信心，常将“生死两字贴在鼻尖儿上作对治”，念念在道，心心相向，久久纯熟，则能达到触目是道，立处即真的境界，到此时，纔可以说一生参学事毕。
    禅宗的兴起和流传，吸引了社会上士大夫阶层，而士大夫广泛涉足禅门，也极大地推动了禅宗思想的丰富和发展，扩大了禅宗的社会影响。在宋代，宗杲一生倡导的看话禅及士大夫禅学，成为丛林禅学与士大夫禅学相结合的典范。经过宗杲与其周转士大夫的努力，禅学渗透到社会生活各个领域，而士大夫禅学也成为禅宗不可或缺的重要组成部分。宗杲对士大夫禅学的倡导也成为后世居士佛教的思想先导，明清禅学除了增加净土思想及更具入世色彩外，基本上是沿袭宗杲看话禅传统。从这个意义上说，宗杲的禅学居为最后一个有创造性的禅学体系。


一、文偃机用

第九章

    一、文偃机用

    云门宗，亦称云宗，以云门文偃为宗祖，因文偃住韶州云门山光泰禅院，举扬一家宗风，后世取其的居山名而命宗。
    文偃（８６４－９４９），俗姓张，苏州嘉兴人，幼年依本地空王寺志澄律师出家。敏质生知，慧辩天纵。及长，至常州毘陵坛受具足戒。侍奉志澄数年，偏览诸经，深究律部。虽持戒清业，而心事未了，乃辞志澄往睦州参学，经数载，尽得睦州和尚之法。又谒雪峰义存，据《云门匡真禅师录》载：他至雪峰庄，见一僧乃问：“上座今日上山去耶？”僧曰：“是”，师曰：“寄一则因缘，问堂头和尚，只是不得道是别人语。”僧曰：“得”。师曰：“上座到山中见和尚上堂，众纔集便出，据腕立地曰：‘这老汉项上铁枷，何不脱却？’”其僧一依师教。果然，雪峰一闻此僧语，便下座拦胸把住曰：“速道！速道！”僧无对。峰拓开曰：“不是汝语。”僧曰：“是某甲语。”峰曰：“侍者将绳棒来。”僧曰：“不是某甲语，是庄上一浙中上座教某甲来道。”峰曰：“大众去庄上迎取五百人善知识来。”次日文偃上雪峰，峰纔见便曰：“因甚么得到与么地！”师乃低头，从兹契合。温研积稔，密以宗印授马。可见，文偃初次出道，见地即不同凡响，深受义存之器重。后历叩洞岩、疏山、曹山、天童、归宗、灌溪等地，参究玄要，锋辩险绝，声名渐著。自云：“困风霜十七年间，涉南北数千里外。”后梁乾化元年（９１１），至曹溪礼六祖塔，后投于灵树如敏会下。如敏为百丈弟子大安的门徒，曾在岭南行化四十年，以“道行孤峻”著称，甚得当地僧俗敬重，南汉小朝廷曾赐号“知圣”。据《五灯会元》载，如敏在灵树二十年，不曾请首座，常云：“我首座生也，我首座牧牛也，我曾座行脚也。”一日，令击钟三门外接首座，众出迎，恰好文偃至，被请入首座寮，推为首座。这也说明文偃当时在南方已有一定影响。文偃追随如敏八年，以“识心相，见静本”相契。贞明四年（９１８），如敏示寂，遗言：“天人眼目，堂中首座。”文偃嗣其法席，主持灵树寺。同光元年（９２３），领众开云门山，构创梵宫，数载而毕，雕楹珠纲，庄严实相，赠额“光泰禅院”。自此，“抠衣者岁溢千人，拥锡者云来四表，”道风愈显，海众云集，法化四播。受南汉王礼遇，初诏入关，赐号匡真，汉隐帝乾祐二年四月十日上表辞王，垂诫徒众，端坐示寂，世寿八十六，僧腊六十六。据《云门匡真禅师广录》载，《遗诫》嘱其徒：“吾灭后，置吾于方丈中，上或赐塔额，只悬于方丈。”迨北宋乾德元年（９６３），雄武军节度推官阮绍庄，奏报文偃托萝要求为其开塔，遂诏往云门修齐迎请真身入于内宫供养，启塔颜貌如昔，须发犹生。“群僚士庶，四海蕃商，俱入内庭各得瞻礼。”留京师月余，仍送还山。改寺为大觉，谥“大慈云匡真弘明禅师。”有《云门匡真禅师广录》存世。
    文偃的禅法，最著名的是其“云门三句”。即如《五家宗旨纂要》卷下载：“云门示众云：‘函盖乾坤、目机铢两、不涉万缘，作么生承当？’众无语。自代云：‘一镞破三关。’后德山圆明密禅师遂离其语为三句：函盖乾坤句、截断众流句、随波逐浪句。”下面试详析之：
    所谓“函盖乾坤”，即是说绝对之真理充斥天地之间，至大无外，无所不包。这一无所不包的绝对真理，即是灵敏不昧的宇宙之心，就其随缘现为万相说，它是法相；从其为成佛的根据，即是佛性。也就是六祖慧能那里所说的一切万法从此出的真如佛心。其弟子缘密曾用颂体来解释说：“乾坤并万象，地狱及天堂，物物皆真现。头头总不伤。”世间万象，惟真显现，上至天堂，下至地狱，真如遍在，充满法界。故山河大地、天地万物均为真如之变现。于此，自然了解一切有情法性平等，一切众生皆具佛性，只要识得本心，自会自他不二，物我同心，这样纔会深切感悟到宇宙间青青翠竹总是法身，郁郁黄花无非般若的禅机妙谛。这一思想在文偃的语录开示中随处可见。“有僧问：如何是西来意？师曰：山河大地。曰：向上更有事也无？师曰：有。曰：如何是向上事？师曰：释迦老子在西天，文殊菩萨居东土。”告诉参学者，佛法偏在，不分西方东土。“只如雪峰道，尽大地是汝自己。夹山道，百草头上荐取老僧，闹市里识取天子。洛浦云：一尘纔起，大地全收，一毛头现师子全身。”说明万法一如，自性平等。“师以拄杖指前面云：乾坤大地，微尘诸佛总在里许。”又说：“微尘刹土，三世诸佛，西天二十八祖，唐土六祖，尽在拄杖头上说法，神通变现，声应十方，一任纵横。”强调法身偏在，万物一体，事事无碍，处处是道。当文偃搬柴时拈起一片柴火抛下说：“一大藏教，只说这个”时，当他“见僧量米次，问：米箩里有多少达摩眼睛”时，当他“一日以手入木狮子口，叫曰：咬杀我也。相救”时，当他“以拄杖示众云：拄杖化为龙，吞却乾坤了也，山河大地甚处得来”时，当他回答僧问：“如何是清净法身，门云：花药栏”时……，文偃无不在向学人昭示一个真理：万法一如，清净法身偏及一切处；法性平等，山河大地与自身本无差别，所谓“本真本空，一色一味，凡有语句，无不包罗，不待踌躇，全该妙体。”
    既然文偃认为真法一如等无异，自他不二法性同，世界即我，我即佛，那么其禅法自然过渡于“云门三句”中的第二句“截断众流”。所谓“截断众流”，就是要破除学人的烦恼妄执，反对执著于语言名相，从而达到“函盖乾坤”的境界，文偃正是由此而悟道的。《云门匡真禅师广录》载，文偃去见睦州：
    州纔见来，便闭却站，……师曰：“已事未明，乞师指示。”州开门一见便闭却。师如是连三日叩门。至第三日，州开门，师乃拶入，州便擒住曰：“道！道！”师拟议，州便推出曰：“秦时辘轹钻。”遂掩门，损师一足。师从此悟。
    这就是“云门脚跛”的禅门公案，文偃本心来参学，初见睦州，必会问一些“西来意”之类的话头，睦州突如其来地当胸抓住，令他快道，目的就在于截断问者的思路，使其当下无所用心、无从开口，立悟世谛门中一法不立。
    文偃开示门人，若欲得自在之境，须除去法我二执。他认为，修道人在修行中最易犯三种病，即“去门三病”。其一指修行未到悟境，仍停滞於相对分别之迷妄中。其二是已达悟境，然因执著悟境，以致无法自由自在，其三自以为已至司境，而得不依於一物之自由。其实，天地与我同根，万物与我一体，自心与外物是不可隔绝的。文偃开示说：“闻声悟道，见色明心。观世音菩萨将钱来买糊饼，放下手却是馒头。”文偃的“闻声悟道”是指香岩智闲由耳闻击竹之声而悟道，“见色明心”，指灵云志勤从乍见桃花而悟道的因缘，说明的是一色一味，无非妙体，即“即事而真”的思想。观世音菩萨买得糊饼，一放手却变成馒头，这是就我们以思量作用而认识的现象界的差别相，馒头是馒头，糊饼是糊饼，而对悟道者来说，全然了悟，早已断除了对立的判别见解，馒头与糊饼不一不异，无有差别，这说的是“法界一如”的道理。这一思想在文偃的开示中随处可见，僧举世尊初生时，言天上地下，惟我独尊文偃云：“我当时若见，一棒打杀与狗子吃，去图个天下太平。”法性平等，众生即佛，如有佛的偶像在，学人多被迷惑，迷失了自己回家的路即不知“金佛不度炉，木佛不度火，泥佛不度水，真佛内里坐”。人人自有佛性，只因无始劫来，被无明覆盖，被尘劳牵转，故堕入对立界中去，於无限中抉取有限，於平等中妄立差别，不能见出本来的光明与清净，本来的无限与平等。“僧问：如何是佛？门云：干屎橛。”干屎橛为污秽之物，而佛为清净身，云门以不净答清净之问，乃示人当离净、不净二见、应以纯一无染之心来参究，方能悟入佛道。“问：‘如何是超佛越祖之谈？’师曰：‘糊饼’”文偃的“云门饼”与从谂的“赵州茶”在禅林中是十分流行的，它的意义不过在于以一糊饼堵却你的是非分辨之嘴，无可言语，而反观心源，因为但有言说都无实议，起心即妄，动念即乖。如：“僧问云门：不起一念，还有过也无？门云：须弥山。”起念即妄，固然是过，若不起一念，还有过否？若执於此，又落於妄心分别之中，所以云门告诉他其过大於须弥山。这也是慧能六祖出语尽双，不落雨边的思想，禅宗的“无念”只是无妄念，而非断念，这里真正的意旨是指不容分别智的“无心妙用”，即不动智。既不执著於理，也不执著於事，真正禅的认识是不容许生分别心的。所以僧问：“如何是佛法大意？”云门说：“面南看北斗。”表明文偃截断差别妄想之禅法精髓的莫过於云门“日日是好日”的公案：云门垂语云：十五日已前不问汝，十五日已后道将一句来！自代云：日日是好日。”这里“十五日”并非一个特定的日子，实系借此截断学人差别妄想的分别智，日日好日，无须拣别，禅是直截了当的，不容槿衡，不容拟议，不容算计。古德说：即心即佛，惟证乃知，“成佛乃是以根本无分别智来亲证实相，实相乃是无相之相，亲证无相，杀那间就会智境冥合，能所双忘，虚空粉碎，大地平沉。这样的境界，绝非有分别心者能通能证的。
    《人天眼目》中解释“截断众流”句说：“堆山积岳，一尽尘埃；拟论玄妙，冰消瓦解”。“本非解会，排叠将来；不消一字，万机顿息。”意思是说，堆山积岳的宇宙万有，都不是真正的认识对象；只要一论及玄妙的真如本体，这些“排叠将来”的世音众法，就立即“万机顿息”、“冰消瓦解”。因为它们并不是真正的本体，在一定意义上说，禅是不可说的，是所谓“向上一路千圣不传”的自证自语的法门，对禅的体验和领悟亦不能像知识那样传授，“说似一物即不中”。为师者，哑巴得梦，只许自知；为弟子者，惟“如人饮水，冷暖自知”，不能受之他人，诸佛法印，非众人得。商量问答，已落剩语，讲学议解，更缠葛藤。文偃说“此事无汝替代处，莫非各在当人分上。老和尚出世，只为汝证明。”所以，文偃也反对执著语言文字，认为真如佛性不可言说，只应於内心证语。拭慧洪《林间录》卷上载：“云门和尚说法如云，绝不喜人记录其语，见必骂逐，曰：”汝口不用，反记我语，他时定贩卖我去’。”后世学者渔猎文字语言，正如吹纲求满，非愚即狂，《云门匡真禅师广录》中具体记载有他的言论：
    问：“如何是诸佛出身处？”师曰：“东山水上行。”
    借问：“如何是超佛越祖之谈？”师曰：“糊饼。”
    问：“如何是祖师西来意？”师云：“青天白日呓语作么？”
    问：“如何是佛法大意？”师云：“面南看北斗。”
答非所问，莫知所云。云门说：“大用现前，不存规则。”文不对题，旨在使问者打住话头，截断葛藤，无须在此打转转。因为言不展事，语不投机，承言者丧，滞句者迷。言语不能表达事实，不会成为启悟的契机，滞于言句之意者，会失却真实，越走越迷。“若约衲僧门下，句里呈机，徒劳伫思，直饶一句下孙当得，犹是瞌睡汉。”文偃告诫门人说：
    汝若不是个手脚，纔闻人举，便承当得，早落第二机也。汝不看他德山和尚纔见僧入门，拽杖便趁，睦州和尚纔见僧入门来，便云见成公案，放汝三十棒，自余之辈，合作么生？若是一般掠虚汉，食人涎唾，记得一堆一担骨董，到处驰骋，驴唇马嘴，夸我解问十转五转活。饶你从朝问到夜，论劫恁么还曾萝见么？甚么处是与人著力处？
    此外，云门为截断葛藤、破除执著，接引学人常用一字来说破禅之要旨，简捷明快，快刀斩麻，如电光石火，而每有千钧之重，即所谓一字禅，禅林称之为“云门一字关”。如：
    如何是云门剑——祖。
    如何是玄中的——祝。
    如何是吹毛剑——骼。
    如何是正法眼——普。
    如何是啐啄机——响。
    如何是云门一路——亲。
    杀父杀母向佛前忏悔，杀佛杀祖，向甚么处忏悔——露。
    凿壁偷光时如何——恰。
    会佛法如河沙，百草头上道将一句来——俱。
    这确实是“云门天子”的金口风范，一言既出，万法顺从，不容拟议。清僧三山来颂曰：“截断众流意若何，算来一字已成多，推排解会徒劳力，肯把要津放得过。”
    既明宇宙万象，平等一如，又破妄执情识，不取对待，那学人应于何处用功呢？这就是云门三句的第三句“随波逐浪。”文偃示众说：“乾坤之内，宇宙之间，中有一宝，秘在形山。拈灯笼向佛殿里，将三门来灯笼上。”这一“云门一宝”，即是变现万法的真如本心，亦即无位真人，修禅只要能随顺自然，任运自在，自识本性，别无用心，便为解脱。《五家宗旨纂要》概括为：“顺机接引，应物无心，因语识人，从苗辨地，不须拣择，方便随宜。”云门对门人说：
    且问你诸人从上来有甚事？欠少什么？向你道无事，已是相埋没也，虽然如是，也须到这田地始得。亦莫趁口快乱问，自己心里黑漫漫地。明朝后日，大有事在，你若根思迟回，且向古人建化门庭东觑西觑，看是个什么道理？你欲得会吗？都缘是你自家无量劫来妄想浓厚，一期闻人说着，便生疑心。问佛问法，问向上向下，求觅解会，转没交涉，拟心即差，况复有言有句，莫是不拟心是么？莫错会好。更有什么事？
    我向汝道，直下有什以事？早上相埋没了也。汝若实未有入头处，且独自参详，除却著衣吃饭，屙屎送尿，更有什么事？无端起得许多般妄想作什么？
    只有无心于事，无意于物，主客双泯，物我两忘，自能得大自在，得一个本然天真的本来面目。《云门广录》中多有此论述：
    僧问：“如何是佛法大意？”师曰：“春来草自青。”
    问：“如何是西来意？”师曰：“久雨不晴。”
    这是一种随顺自然的修行原则，同样的表达有：“东家点灯，西家暗坐”、“河里失钱河里摝”、“日出东方夜落西。”文偃告诉门人：“诸和尚子莫妄想，天是天、地是地，山是山，水是水，僧是僧，俗是俗。”到得这步田地，“大用现前，更不烦汝一毫头气力，便与祖佛无别。”悟得这一境界，自会“终日说事，未尝挂著唇齿，未尝道著一字。终日著衣吃饭，未尝触著一粒米，挂著一缕丝。”三山来颂曰：“随波逐浪过前川，绿笠青蓑把钓闲。一曲渔歌江际晚，高低棹破水中天。”
    云门文偃接引学人，主要运用“三句”、“一字禅”，云门宗接化学人的机用手段，被概括为“云门八要”，即：玄、从、真要、夺、或、过、丧、出。一玄者，凡有用处，玄妙难思，不在寻常语句内，不容测度，不可思量，故名为玄。三山来颂曰：“几度乘风泛小舟，彩云影里漫撑篙。举纲撒破虚空面，又向山头钓巨龟。”二从者，凡有指点，皆随机拈弄，或因其见解而接引之，不另标持解，故名为从。三山来颂曰：“万顷清风雨山，暖莺莺语巧喧喧。溪花野水不知数，总在春风和煦间。”三真要，真要者，就其本体，真实切要而言，不属玄微奥妙，支离蔓衍，故名真要，所谓“看尽云山雨翠深，秋霜助日萝魂清。有人问道无余事，云在青天水在瓶。”四夺，夺者，随所拈弄都是刀枪，就机夺机不容拟疑，任彼千般知解一味抢挽，故名为夺。即：“一阵白苹一叶风，满地零落玉芙蓉，巨鳞吸尽沧溟水，留得珊瑚照日红。”五或，或者，疑而未定之辞，或隐或显，或东或西，用无一定，语绝方所，此机窃之，不容捉摸者，故名为或。三山来颂曰：“习习香风过树头，去来何处觅踪由，行人无数空惆怅，几度寻思恨未休。”六过，过者，用到极头，十分孤峻，无你挨拶处，无你转身处，回避不及，忒煞无情，故名过。三山来颂曰：“狠毒心肠何太孤，提刀仗剑忍于屠。命根断处难思算，几个男儿是丈夫。”七丧，丧者，随人上下，丧失天真，不见本来，痴迷狂走，又或执著已见，丧却目前。如此之类，皆谓之丧。三山来颂云：“弱丧穷儿实可哀，家珍抛却自何来。自从别去娘生面，落落长途唤不回。”八出，出者，脱体转身，不拘一处，不守一隅，随机应用，八面四方，都有出身之路，故名出。所谓“南辰北斗只西宫，火里生莲夺目红。野色更无山隔断，月光直与水光通。”三山来颂云：“鸟道羊肠路太多，脚头脚底任蹉跎，随他曲折芒鞋滑，步步如龙畴奈何。”宋苏澥在序《云门语录》时说：“祖灯相继，数百年间，出类迈伦，超今越古，尽妙尽神，道盛行于天下者，数人而已，云门大宗师特为之最。擒纵舒卷，纵横变化。放开江海，鱼龙得游泳之方；把断乾坤，鬼神无行走之路，草木亦当稽首，土石为放光明。本分钳锤，金声玉振；峥嵘世界，瓦解冰销。”总之，文偃机用，孤危险峻，简洁明快，其接化学人，言中有响，句里藏峰，不有多语饶舌，只在片言只语之间，《五家宗旨纂要》言：“云门宗风，出语高古，迥异寻常，北斗藏身。金风露体，三句可辨。一镞辽空，超脱意言，不留情见，以无伴为宗，或一字或多语，随机拈示明之。”《慧南语录》云：“云门一曲二十五，不属宫商角徵羽，若人问我曲因由，南山起云北山雨。”
    文偃的知名门徒很多，《景德传灯录》记有六十一人，五十余人有机缘语，主要分布在岭南、湖南、江西、江苏等地。其中以白云子祥、德山缘密、香林澄远最为著名。日后文偃云门系僧人中，尤以雪窦重显和明教契嵩最为知名，对禅理和禅风的发展产生了深远的影响。


二、雪窦中兴

二、雪窦中兴

    文偃门下有白云子祥、德山缘密、香林澄远等，而以澄远为上首。他住益州青城山香林院，接人语句完全继承文偃的风格。澄远下有智门光祚，门风险峻，有《智门光祚禅师语要》一卷。光祚的法嗣有雪窦重显、延庆子荣、南华宝缘等二十人。到重显而云门的宗风大振，号称中与。
    重显（９８０－１０５２），俗姓李，字隐之，遂川（今四川遂宁）人。家世豪富，以儒业传世，幼受家学，而志存出世，乃以妙龄离俗入道，投益州（成都）普安院依仁诜上人出家。初习经律，兼涉世法。受戒之后，历游讲肆，究理穷玄，诘问锋驰，机辩无敌，咸知法器，佥指南游，遂离川东行，长期游学于湖北、江苏、安徽、浙江等地。以风月为友，登山涉水，间赋诗歌，以寄情怀，曾于襄阳谒石门聪，居三年无所契，后得法于智门祚禅师，依止五年，勤事磨练，长养圣胎，尽得其道。后辞智门，沿江东下，行脚偏参，历访当时宗门大善知识，到池州的景德寺做首座，为大众讲解僧肇的《般若无知论》。又隐于钱塘灵隐寺三年，乃出住苏州翠峰山。未几，明州知州曾公手书请师住持雪窦资圣寺，苏人固留不可，重显曰：“出家人止如孤鹤翘松，去若片云过顶，何彼此之有。”遂转徒明州（浙江宁波）雪窦山资圣寺，于此居住三十一年，《佛祖历代通载》谓其“迁明之雪窦，宗风大振，天下龙蟠风逸，衲子争集，号集门中兴。”雪窦于此寺大弘云门宗风，故有云门宗“中与之祖”之称。又以其久住雪窦山，后世禅林多以“雪窦禅师”称之，重显于皇祐四年（１０５２）入寂，世寿七十三，僧腊五十夏，谥号“明觉大师”。
    重显曾有一首偈颂，讲述了自己参禅究道的感受。偈颂云：“二十年来曾苦辛，为君几下苍龙窟。”为求佛法真髓，二十多年来不知吃了多少苦，这肺腑之声道出祖师求法究道的辛苦。据《五灯会元》卷十五载，重显初访光祚，问曰：“不起一念，云何有过？”光祚示意重显近前，刚一上前，即遭一拂子打，重显刚要开口，光祚又打，“师豁然开悟”。其实，真正的禅师，没有一个不是经受过这种电击石火的磨砺的。道不能说，只在自心自悟，开口即错，他在日后的传法生涯中，随处都贯彻了这一精神。《明觉禅师语录》卷一《住明州雪窦禅寺语》载：
    师开堂日，于法座前顾视大众曰：“若论本分相见，不必高长法座。”遂以手画一画曰：“诸人随山僧手着，无量诸佛国土，一时现前，各各仔细观瞻，其或涯际未知，不免拖泥带水。”
    首次开堂示众，就言不必升座说法，旨在说明实在无法可说，纵然说得天花乱坠，亦“于曹溪路上，一点使用不着。”所以，重显告诉学人，佛在目前，当下即是，“诸人随山僧手看，无量诸佛国土，一时现前，”否定来世成佛，否定西方净土。其实，重显的这一思想，亦是禅宗一向的风格。如惠昕本《坛经》所说：“东方人造罪，念佛求生西方，当年六祖禅师不正是为听法信众于当下现西方极乐净土吗？世界、佛、我三位一体，不可于我外求佛，这里没有追求目标和追求主体的分野，没有虚幻和实在的对立，自性即佛，佛心不二，关键在自我的直下承当。所以重显说：“如来正法眼藏，委在今日。放行则瓦砾生光，把住则真金失色。权柄在手，杀活临时，其有作者，相共证据。”自性一悟，道在瓦砾，桃竹说法；自性沉迷，佛在眼前，对面不识。权柄在手，既可为杀人剑，又可为活人刀，关键在于一念迷悟，这恰似青源惟信对其悟道境界的描述；三十年前未参禅时，见山是山，见水是水，及至后来亲见知识，有个入处，见山不是山，见水不是水，今日有个休歇处，依然见山只是山，见水只是水，山水依然，迷悟在已，若能打破对立，统一我佛，则一切都在佛光的普照里。而自心不识，反而“抛家散走”的外求体悟，岂非“不顾自家宝藏”，真可谓“放行则瓦砾生光，把住则真金失色。”
    自识本心，自性自度，关键在于自我的体验，而这种体验只能是个体的独自承当，旁人是无法代替的，重显概括为“如人上山，各自努力”。因为佛性偏在，各人自有本觉性，所谓“明眼衲僧，应须自看”。所以自识本心的悟境，只能自心自悟，无法传递。禅师们努力唤起他人相同的体验，但他们绝不给予，绝不注入。因为说出的体验，已非体悟本身，所以，禅师只让你默默地去参。《五灯会元》记载：
    有僧出，礼拜起曰：“请师答话。”师便棒。僧曰：“岂无方便？”师曰：“罪不重科。”复有一僧出，礼拜起曰：“请师答话。”师曰：“两重公案。”曰：“请师不答话。”师亦棒。问：“古人道，北斗里面藏身，意旨如何？”师曰：“千闻不如一见。”
    禅悟不可说，请答话挨棒，请不答话亦挨棒，正与赵州禅师的曾来过去吃茶，未来过亦去吃茶的意旨相同。那么重显到底要告诉门人什么意旨呢？即“千闻不如一见”，自悟本心，自性自度，禅师说得再好亦是禅师的体验，无法替代学人自身的体悟，禅理的获得，贵在自证自悟，所谓不识本心，学法无益，所以学人只须自识本心，自见本性，即可即心即佛，妙契祖心。所谓“未来翠峰多人疑著，及乎亲到一境萧然。”禅门中对云门评价云：“大智修行始是禅，禅门宜默不宜喧。万般巧说争如实，轮却云门总不言。”禅的体验要求达到永恒、整体和无限、具体，而言说却总是阶段、部分、有限和抽象的，所以任何语言文字都不免将整体、具体之的分割和抽象化，所以最高的境界是“沉默是金”、“一默如雷”。若至非说不可处，亦以否定的方式来避免和弥补语言的不足，如问什么是西来意，告之说：麻三斤。在接化学人的方法机用上，重显也继承了云门一派“截断众流”的手法：
    问：“德山临济棒喝已彰，和尚如何为人？”师曰：“放过一著。”僧拟议，师便喝。僧曰：“未审只恁么，别有在？”师曰：“射虎不真，从劳没羽。”
    禅悟是超言绝虑的，它须直觉的感受和心灵的体验，禅不可说，拟议即错，若强以言语，也是徒劳无益。所以他说：“不有低头，思量难得。”重显提撕云门宗风，每每以一言半语蓦地斩断学人葛藤，使问者当下截住，无可用心。
    问：“如何是佛法大意？”师曰：“祥云五色。”曰：“学人不会。”师曰：“头上漫漫”。问：“达摩未来时如何？”师曰：“猿啼古木。”曰：“来后如何？”师曰：“鹤唳青霄。”
    佛法如见，自然是道，“猿啼古木”、“鹤唳青霄”，无关乎达摩祖师来前来后，一朝风月，万古长空，本来如此，何须拟议。再如：
    问：“如何是把定乾坤眼？”师曰：“拈起鼻孔。”曰：“学人不会，”师曰：“一喜一悲。”僧拟议，师曰：“苦”。
    执著言辞，必死句下，正如“拈起鼻孔”，无法透气，必窒息而死无疑，所以学道者万不可执于名相，为文字所缚。重显临终，侍者哀乞遗偈，师曰：“平生惟患语之多矣。”千说万说，不如自见，若得自见分明，当下超凡入圣。
    禅法自然，无作无为，便是禅之精髓，便是生命之道，重显开示大众说：
    人天普集，合发明个什么事？焉可互分宾主，驰骋问答，便当宗乘去。广大门风，威德自在，辉腾今古，把定乾坤，千圣只言自知，五乘莫能建立。所以声前悟旨，犹迷顾鉴之端。言下知宗，尚昧识情之表。诸人要知真实相为么？但以上无攀仰，下绝已躬，自然常光现前，个个壁立千仞。还辨明得也无？未辨辨取，未明明取。既辨明得，能截生死流，同据佛祖位，妙圆超悟，正在此时。
    纸上得来总觉浅，须知此事应躬亲。但这里不仅排除言语间的悟道，亦不要行事中的着意作为，只求自然然，“上不攀仰，下绝已躬”，自可风吹草动，大路朝天。重显在回答“如何则入不二法门”时说：“维摩大士去何从，千古令人望莫穷。不二法门休更问，夜来明日上孤峰。”
    在禅宗史上，使重显彪炳史册的是他受汾阳善昭的影响所作的《颂古百则》，举古代的公案一百则，歌颂出玄旨，也就是有名的《雪窦颂古》一卷。所谓“颂古”，是以韵文对公案进行赞誉性解释的语录体载，它不仅是研究公案的方法，而且是教禅学禅、表达明心见性的手段。颂古首创于汾阳善昭的禅师，是对宋代禅学发展的一大推进，在北宋以后的禅史上，颂古比代别和拈古具有更大的影响。重显受汾阳之影响。作《颂古百则》，更把宋初的颂古之风推向高潮，风靡整个禅林，几至于凡舞文弄墨之禅师均有的颂古之作，而参禅悟道者亦多去钻研颂古，导致所有的禅林高手于颂古均有评说。这样，颂古之作如汗牛充栋，构成了禅宗典籍的重要组成部分。
    至南宋中期，许多禅师开始整理颂古，把它们从众多的单行语录本中抽取出来，加上零散的颂古之作，分门别类，另行累集成册。如池州（今安徽贵池）报恩光教禅寺僧人法应，花了三十年时间收集颂古，于淳熙（１１７５）编成《禅宗颂古联珠集》，采集公案三百二十五则，颂古二千一百首，作者一百二十二位禅师，元初钱塘沙门普会，接续法应的工作，从元代元贞乙未年（１２９５）开始，用了二十三年，编成《联珠通集》，在法应《禅宗颂古联珠集》所收颂古及作者的基础上，又增加公案四百九十三则，颂古三千零五十首，作者四百二十六人，从此颂古似星、著者如云的典籍资料中不难看出，自重显之后，颂古之风席卷禅林之规模。善昭颂古创立对于日后禅风影响很大，重显的《颂古百则》将此形式推至一个新的水平，其后，圆悟克勤又以重显《颂古百则》所选公案为框架而编成“宗门第一书”——《碧岩集》，开创了解释公案和颂古的完备形式，标志着宋代文字禅发展到了顶峰，完成了中国禅风的一大转变。
    善昭之后，颂古也经历了一个演变过程。影响最大的作者有四个：即云门宗的雪窦重显和曹洞宗的投子义青、丹霞子淳以及宏智正觉。其中以重显的《颂古百则》尤具创新意义。可以说善昭制作了颂古的雏形，重显则使之成熟，他们代表了宋代颂古的两种基本类型。在重显的《颂古百则》中，除《楞严经》二则，《维摩经》一则、《金刚经》一则外，其余九十六则中，较多地选择了云门宗僧人的公案，其中有云门文偃的公案十三个，涉及云门公案三个，为云门中僧不无关系，本来颂古就是将古来祖师公案拈出来以优美之韵文给予评唱解释的，圆悟克勤曾指出：“大凡颂古，只是绕路说禅，拈古大纲，据款结案而已。“这是对颂古的一个经典定义。克勤在这里讲明了对颂古要“绕路说”，切忌与重显风格相异，善昭的颂文用语较为平和直朴，并不完全符合“颂古”之要求。与此形成鲜明对比的重显颂古，却追求华丽奇异，文字含蓄。常蕴言外之旨。所以，在禅林中，善昭颂古反倒不怎么流行，而重显之颂古却铺天盖地，备受推崇，我们试举一例来看：善昭和重显都曾作过《俱胝一指》公案的颂文，这则公案很简单，说的是唐代俱胝和尚，每遇有人向他请教禅旨，他都不多言说，只竖一指表示回答，以此启悟能禅者，此即著名的“一指禅”。善昭的颂文是：“天龙一指悟俱胝，当下无私物匪齐。万互千差宁别说，直教今古勿针锥。”善昭首先交待了此公案的来历，俱胝即是从天龙和尚竖指示之而悟大道，尽管森罗万象，各各有别，但万物一体，法性平等，勿须思辨拟议，一指定乾坤，千古更不疑，读来平铺直叙，直露本意。而重显的颂则不同：“对物深爱老俱胝，宇宙空来更有谁？曾下沧溟下浮木，夜涛相共接盲龟。”重显的意思是说：本来万法一如，物我不二，但众生愚昧，对境起念，妄执分别，如猿猴捉月，病眼看花，自生颠倒，如今苍茫一脉，孤峰山头，有谁来殷勤开示，慈悲度人？追忆俱胝和尚以一指示人，如同在夜幕茏罩下波涛汹涌的大海中投下浮木，来拯救深沦于茫茫业海中的众生，那是怎样的一份救世情怀、似海悲心。颂文中饱含钦佩仰慕之意。颂文中后两句引用《法华经》中关于“如一眼之龟值浮木孔，无没溺之患”的寓言。仅此一例即可看出重显的颂文迥然有别于善昭颂文的特色，其一就是大量用典，时人指出：“雪窦《颂古百则》，丛林学道诠要也，其间取譬经论或儒家文史，以发明此事。”重显好骨典故，使其颂文更为含蓄耐读。其二，文辞典雅，又善于融入情感，使其颂古之作更显富赡华丽，情趣盎然，这与善昭颂文之“殊不以攒华叠锦为贵”更不相同，重显素以“工翰墨”见称，他在未悟道时追慕诗僧禅月贯休，有诗云：“红芍药边方舞蝶，碧梧桐里正啼莺，离亭不折依依柳，况有青山送又迎。”造句清新，意境深远，确是诗中上品，他得法于云门宗的智门光祚禅师之后，意境更高，造句更奇，如他在就任雪窦寺住持时上堂云：“春山叠乱青，春水漾虚碧，寥寥天地间，独立望何极。”还有“秋风生群林，野水资寒色”等，皆是传诵一时的名句。他一生中所作诗词歌赋，上堂小参，举古勘辩，均独具匠心，留意词藻，门人集其著作有《洞庭语录》、《雪窦开堂录》、《瀑泉集》、《祖英集》、《颂古集》、《拈古集》、《雪窦后录》七种，均辞句古雅，文采斐然。圆悟克勤说：“雪窦会四六文章，七通八达，凡是淆讹奇特公案，偏爱去颂。”元代名僧万松么秀则评论说：“吾宗有雪窦、天童，犹孔门之有游夏；二师之颂古，犹诗坛之李杜。”这个评价确实反映了后人对他文才的一种肯定和赞誉。由此，后世禅人纷纷倣，推动禅宗走上舞言语弄墨、着意于文字华丽一途。心闻昙贲说：“天禧间，雪窦以辩博之才，美意变弄，求新琢巧，继汾阳为《颂古》，笼络当世学者，宗风由此一变矣。”可见雪窦对当时禅风影响之大。
    雪窦重显之后，颂古之风愈盛，后解释公案内涵而一滑至于专求辞句华丽，渐渐文辞越作越华丽，而公案内容却越作越少，后来颂古之作反而无法让人理解，连历来受到推崇的重显颂古亦因典故叠出，辞意新异渐渐为日后文化素养不高者难以接受。普照禅师曾指出：“雪窦禅师，具超宗越格正眼，提掇正令，不露风规。秉烹佛锻祖钳锤，颂出衲僧向上巴鼻。银山银壁，孰敢钻研；蛟蛟铁牛，难为下口。不逢大匠，焉悉玄微。”重显颂古，一至如此，禅门需要对颂古进行再革新，对机说教，应病施药，这样，北宋末年，新的颂古总集，圆悟克勤的《碧岩集》应运而生，标志着禅学又一时代的到来。


三、义怀宗乘

三、义怀宗乘

    云门一宗，　至雪窦而宗风大振，号称中兴。其法嗣有八十四人，而以天衣义怀为上首。义怀承继雪窦家风。曾以“骊龙颔下夺明珠，一言勘破维摩诘。”的偈语为重显称善印可，并为后世禅林广泛传唱。其一生凡五迁法席，所到皆兴其荒废，大振云门法道，在云门禅发展史上，占有极为重要的地位。
    义怀（９９３－１０６４），俗姓陈，永嘉乐清（今属浙江）人，自幼即天资聪慧，秉具善根。家族世代以渔为业，儿时常随父出海，父得鱼令其串之，心怀不忍，乃私投江中，父怒笞之，而其不以介意，恬然如故。及长，入京师景德寺为童行，天圣（１０２３－１０３１）年中，试经得度。于众中清癯缓步，如鹤立鸡群，有一诵《法华经》的神异高僧，于市井中遇义怀，拊其背说：“云门临济去。”义怀不喻其意，请教耆宿，告曰：“汝其当宏禅宗乎？行矣，勿滞于此。”从此立志偏参，初谒荆州金銮善禅师，又参叶县归省禅师，皆不契，遂东游至姑苏，上翠峰参雪窦重显，即明觉禅师。据《五灯会元》卷十六载，义怀初见重显：
    觉问：“汝名什么？”曰：“义怀。”觉曰：“何不名怀义？”曰：“当时致得，”觉曰：“谁为汝立名？”曰：“受戒来十年矣。”觉曰：“汝行脚费却多少草鞋？”曰：“和尚草瞒人好！”觉曰：“我也没量罪过，汝也没量罪过，你作什么生？”师无语。觉打曰：“脱空漫语汉，出去！”：入室次，觉曰：“恁么也不得，不恁么也不得，恁么不凭么总不得。”师拟议，觉又打出。
    可见，义怀初参重显，即受到重显机锋棒喝的考验，可怜义怀未悟本心，无语作答。如此这般四次，仍未能悟，被派为负责供水的水头，一日，因汲水担折，忽然开悟。呈偈云：“一二三四五六七，万仞峰头独足立。骊龙颔下夺明珠，一言勘破维摩诘。”重显闻后拊案称善印可，遂嗣其法，为云门宗传人。
    不久，义怀即辞去，出住无为军（在今安徽无为县）铁佛寺，大倡法要，义怀去后，雪窦久未闻义怀消息，一日，有僧自淮上来，对重显说，义怀已于铁佛寺出世，化行道场，嗣法者众，重显令其述义怀提唱之语，曰：“譬如雁过长空，影沉寒水，雁无遗踪之意，水无留影之心。”重显以此语如同已出，十分赞赏，并专门遣使慰抚义怀。义怀后由铁佛寺迁至越州（今浙江绍兴）天衣山，再后五迁法席，所到皆为荒凉之地，义怀至必建立楼观，化行海内，振兴云门法道。晚年以疾，居池州（安徽池州府）杉山庵，于宋治平元年（１０６４）卒，寿七十二，世称天衣义怀，谥号“振宗禅师”。有《天衣义怀禅师语要》一卷存在。
    义怀有禅法，在基本思想脉络上继承了乃师重显的遗风，主张禅道自然，贵在悟心。据《五灯会元》卷十六载：
    僧问：“如何是佛？”师曰：“布发掩泥，横身卧地。”曰：“意旨如何？”师曰：“任是波旬也皱眉。”曰：“恁么则谢师指示？”师曰：“西方此土。”问：“学人上来，请现说法。”师曰：“林间鸟噪，水底鱼行。”
    这里的意旨最为明白不守，佛法是原初的生命本色，它所显现与表露的就是再平凡不过的自然之道，“林间鸟噪，水底鱼行”。自然即是佛法，佛法即是自然，修禅者应于本色上作功夫，不可于身心之外另求佛法意旨，所以当僧问：“如何是顶门上眼？”义怀告诉他：“衲僧横说竖说，未知有顶门上眼。”而只知“衣穿瘦骨露，屋破看星眼。”义怀反对于外著境，向外用力，提倡任心自在，随顺自然，他告诫学人：“要会灵山亲授记，画见日，夜见星。”意思是说，佛祖在灵山会上告诉你的不过也是画见日头夜观星的道理，各于自性本分事上用力。他举例开示学人说：“芭蕉闻雷开，葵花随日转。诸仁者，芭蕉闻雷开，还有耳么？葵花随日转，还有眼么？若也会得，西天即是此土。”芭蕉无耳能闻雷而开，葵花无眼能随日旋转，并非其有意作为，而是天性使然。自自然然，率性而行，这就是佛理，这就是禅法。
    义怀将此禅法自然作为其思想基础，极力反对妄起分别之心，徒使背离之功，在其语录中有一段较著名的话集中反映了他的这一思想：
    上堂：“夫为宗师，须是驱耕夫之牛，夺饥人之食，过贱即贵，遇贵即贱。驱耕夫之牛，令他苗稼丰登。夺饥人之食，令他永绝饥渴。遇贱即贵，握土成金。遇贵即贱，变金成土。老僧亦不驱耕夫之牛，亦不夺饥人之食。何谓耕夫之牛，我复何用？饥人之食，我复何餐？我也不握土成金，也不变金作土。何也？金是金，土时土，玉是玉，石是石，僧是僧，俗是俗。古今天地，古今日月，古今山河，古今人伦，虽然如此，打破大散关，几个迷逢达摩？”上堂：“雁过长空，影沉寒水。雁无遗踪之意，水无留影之心。若能如是，方解向异类中行。不用续凫截鹤，夷岳盈壑。”
    义怀一反往常许多禅师所用激将之法，“驱耕夫牛，夺饥人食。”将学人逼至无可用心处，言语道断，心行处灭，令他们疑情奋起，绝路逢生。义怀在这里既不点石成金，亦不变金成土。他告诉学人，千古一月，万年山河，金是金，土是土，不可截鹤续凫，头上安头，嘴上安嘴，所以他说：“虚明自照，不劳心力。”
    禅门主张，迷悟只在一心，顿悟只是一念，所谓前念迷即众生，后念悟即佛。古德云：“一念之喜，景星庆云；一念之怒，震雷暴雨；一念之慈，和风甘露；一念之严，烈日秋霜。”所以后世禅门弟子多于此一念上着力用功。义怀完全禀承了这一禅法，他说：“无边刹境，自他不隔于毫端，且道妙喜世界，不动如来，说什么法？十世古今，始终不离于当念。”这样，学人于自心自念上下功夫，便可自悟本心，自怀自度，他说：“行路难，行路难，万仞峰头君自看。”这番前程之路，别人是无法代你行走的。只有自性自度，自觉本心，方可佛即众生，众生即佛，西方与此土相同。义怀云：
    大道无偏，复谁迷悟？诸二者，迷则迷于悟，悟则悟于迷。迷时力士失额上之珠，悟则贫子获衣中之宝。谁人不有，故圣人云：如我现身实相，观佛亦然，前际不来，后来不去，今则无住，无住之本，流出万端。森罗眩目，全彰古佛家风，音声聒耳，尽是普贤境界。虽然如是，笑杀衲僧。
    佛性本自具有，不假外求，只于一念开悟，不可于外妄求。所以义怀对于禅宗一贯主张的鄙弃于言语名相中求解，于概念玄论中妄生分别情识的作法深表赞同。如有僧问：“天不能盖，地不能载，未审是什么人？”师曰：“掘地深埋。”曰：“此人还受安排也无？”师曰：“土上更加泥。”所谓“天不能盖，地不能载”的人是无法言说的，所以只好“掘地深埋”、“土上更加泥”。此说与问“不与万法为侣者为谁？”答曰：“侍汝一口吸尽西江水，再与你说”的公案同出一辙，反映的是禅不可言说，也不须于名相概念上妄生分别，更造戏论的宗旨。可以说，义怀在禅学基本思想上，仍是承袭了其师雪窦云门一系的禅法，所以，慧洪评价说：“予观雪窦天衣父子提倡之悟，其指示心法广大分晓如雪廓天布。而后之学者失其旨的，争以识情数量义学品目缁秽之。
    义怀作为一代宗师，其禅法尽管未脱云门一系之窠臼，但亦并非一味承袭，而在继承融会的基础上别有创意，提倡净禅兼修，将云门禅法向前大大地推进了一步。
    据《禅林僧宝传》卷十一载，义怀晚年以疾居池州杉山庵，示寂之夕，其徒智才问卵塔已事，如何是毕竟事，义怀竖拳示之，推枕而逝。后世学者认为其曾化人念佛，有劝修净土之说。明代道衍在《诸上善人咏》中即颂义怀禅师为：“五迁名刹萃英贤，净土兼修不碍禅。竖起拳头推枕化，宝花池上绽青莲。”宋宗晓《乐邦文类》卷四《惟心净土文》、明大佑《净土指归集》卷上均记载：
    天衣怀禅师一生回向净土，问学者曰：“若言舍秽取净，厌此欣彼，则取舍之情，乃是众生妄想。若言无净土，则达佛语。夫修净土者，当如何修？”复自答曰：“生则决定生，去则实不去。若明此旨，则惟心净土，昭然无疑。”
《惟心净土文》更直截明确地指出：“先自天衣怀禅师以下，专用净土法，递相传授，皆遂往生，各有明验，具载《宝珠集》。”可见在这些典籍中，义怀已被推为净禅兼之始作俑者。
    其实，从整个中国传教文化的大流程来看，净禅兼修的渊源，可追溯至东晋慧远以前，如后汉末的安世高及娄迦识都以不坐不卧之长行而念佛；道安法师亦是初修安般禅，后又持弥勒名，誓生兜率；慧远法师结社念佛，其念佛即是禅之念佛，可见，当时的许多法师都是注重禅定而念佛，即将念佛看作是修习禅定的法门，所以禅净兼修于慧远前已萌其端。后至达摩、慧能提倡“自心即佛”、心净则佛土净，可说是“惟心净土说”的确立，致使禅净隔绝，如《坛经》云：“若悟无生顿法，见西方只在刹那，不悟顿教大乘，念佛住生路远，如何得达？”当然这里不排除禅门旁系如法持、智诜、宣什等修持念佛禅。至宋时，中国佛教内部提倡诸宗融合，于外则倡导三教合一，成为一时之潮流，法眼宗永明延寿著《万善同归集》呼吁“净禅一致”，其说风磨天下。义怀作为一方宗主，敏锐地把握时代之脉博，大倡禅净兼修，其门下弟子慧林宗本、杨杰等皆追随师说，主张禅净兼修。后来再传弟子即宗本之嗣法云善本、守讷等所倡禅净兼修，其渊源亦出亦怀之倡导。云门师徒，前呼后应，法旨相承，遂使调和融合思潮成为云门一系一时之主流，这一思想影响甚远。此后，继起禅净双修者甚多，长芦宗赜、真歇清了、中峰明本、天如惟则、北礀居简、楚石梵琦皆为一时倡导禅净兼修的领袖。特别至明末有云楼祩宏、紫柏真可、憨山德清、蕅益智旭等四大高僧的合力提倡，使净禅兼修之风几乎席卷整个禅门丛林。此风一直延续至今。可见，义怀禅师对后世影响之深远。
    义怀一生七坐法席，大兴云门宗风，其门下弟子偏及江南江北、其中尤以慧林宗本、法云法秀、长芦应夫、天钵重元等为上首，使云门一脉，源远流长。


四、宗本禅理

四、宗本禅理

    唐末五代以来，藩镇割据，战乱不止，学术凋零。佛教在此动乱之际亦遭受深重打击，各宗派的鼎盛与兴旺随频仍的战火而灰飞烟灭。惟禅宗一派尚有气息延喘，及至五代末，亦举步惟艰，经营惨淡。至宋时，为了寻求出路，获得生存，佛教内部兴起一股调和融合的思潮，于外谋求“儒佛一致”、“三教合一”，对内则强调各宗之间的圆融统一，这种融通的思潮最终演变成为宋代佛教的主流。云门一系由文偃创立，经澄远、光祚、重显而至义怀。义怀顺应时代潮流，传法开示多有融合意旨，并极力倡导禅净兼修，门下弟子众多，其中尤以慧林宗本最为杰出。慧林宗本聪明颖悟，历驻名刹，曾应神宗之诏，为相国寺慧林禅刹第一祖，道场演法，大扬禅风，海会云集，弟子甚众。宗本继承义怀本怀，倡导禅教一致、净禅合修，所举华严禅，开演华严奥秘，臻于圆融玄妙，为禅门注入新鲜活力，独开一代新风，堪力云门门下之臣匠。
    宗本（１０２０－１０９９）常州无锡（今江苏无锡）人，俗姓管，字无吉，体貌丰硕，言无枝叶，所事淳厚。十九岁时，入苏州承天永安寺道升禅师门下。据《禅林僧宝传》卷十四载，当时，道升“价重丛林，师之者如云，本弊衣垢面，操井臼。典炊焚，以供给之，夜则入室参，道升曰：‘头陀荷众良苦，亦疲劳乎？’对曰：‘若舍一法，不名满足菩提，实欲此生身证，其敢言劳？’升阴奇之。”可见，宗本初次入道，便抱有心志求苦，为法忘身的志向和愿心。这样巾侍十载，方剃发受具足戒。后又服勤三年，乃拜辞道升游方偏差。
    宗本初谒池州（今安徽贵池）景德寺，师事天衣义怀。据《五灯会元》卷十六载，义怀问曰：
    天亲从弥勒内宫而下，无著问云：“人间四百年，彼天为一昼夜，弥勒于一时中，成就五百亿天子，证无生法忍，未审说什么法？”天亲曰：“只说这个法。”如何是这个法？
所谓“无生法忍”，又称“无生忍”，是指能体悟因缘生法的无生之本性，而安住于此种本性中，或者说是能观诸法无生无灭之理，并领悟之，安住且不动心，证无生法忍，就是证果之身，即与佛、真如、涅盘同义。此一境界无法言说，因为这就是“第一义”。所以天亲只能说：“只说这个法。”当义怀再问“如何是这个法”时，只是要告诉宗本，佛法真谛，只可自性自悟，开口不得，亦所谓“如人饮水，冷暖自知”。宗本于此言下开悟，后一日义怀又勘验他曰：“即心即佛时节如何？”宗本回答说：“杀人放火有什么难？”这里表露了宗本对佛法真谛的体验，将“即心即佛”与“杀人放火”相比拟，说明宗本已放弃世间的凡识妄辨，佛法一如，不起分别之心。“即心即佛”便是“非心非佛”，烦恼即菩提，于世间森罗万象、美善醜恶，均可以平常心待之。“平常心是道”，这便是佛法不二之法门。宗本由此而名播宁宇，深得义怀之器重，传说，宗本“尝为侍者，而好寝，鼻息齁齁，闻者厌之，言于怀。怀笑曰：‘此子吾家精进幢也。汝辈他日当依赖之，无多谈。
’众闻大惊。”从这一小事上，亦可看出义怀对宗本的偏爱之情。后来，义怀迁居越州天衣山、常州荐福寺，宗本皆追随身边，不离左右。
宋英宗治平初年，义怀退居吴江圣院。一日漕使李复圭来拜访义怀，夜话曰：“苏州瑞光寺法席虚，愿得有道衲子主之。”义怀即指宗本说：“无逾此道人者耳！”宗本遂至瑞光寺。既至，寺僧恭迎，集众鸣鼓，鼓坠地，滚动山响，寺众大惊，有一僧言曰：“此是和尚法雷震地之祥兆。”宗本于此开法，法席日盛，徒众达五百余人，影响甚大，遐迩闻名。其时，杭州太守陈襄闻师英名，请师前往住持承天、兴教二寺。苏州信众拥道挽留，陈襄又以净慈寺恳请，并对苏州信众说：“借师三年，为此邦植福，不敢外占。”道俗始从，宗本遂迁至杭州净慈寺开法。后来，苏州信众又以万寿、龙华二刹来请宗本，迎者上千人，众曰：“始借吾师约三年，今九载，义当见还。”并欲夺以归。杭州太守只得派兵卒护持，苏人不敢夺，此事遂罢。神宗元丰五年（１０８２），宗本将净慈道场付于门人善本，自居瑞峰庵，苏人闻之又欲夺之。此时恰好待制曾孝序来苏州，曾孝序曾经问道于宗本，得其心要，遂具舟往瑞峰庵拜谒宗本。既辞去，宗本登舟送之，言语谈笑间不觉已载至苏州，于是苏州信众欢喜跳跃，得以遂愿，乃请宗本居穹窿山福臻院。
    从以上宗本戏剧性的住持经历中，可以看出当时宗本在江南一带的影响之大，法缘之深，苏杭百姓对他的敬重和信奉。另一方面也反映了宗本的禅者风范，随缘而往，不恋不贪，特别是送客至舟，不经意间被载而去的趣事，犹如昔时庐山东林慧远大师的“虎溪三笑”的典故一般，禅味十足。
    宗本住穹窿山福臻院不久，汴京相国寺六十四院辟为八寺，二禅六律。以东西序建慧林、智海两大禅寺。元丰六年（１０８３）本受神宗之诏住持慧林禅院，为第一祖，既至京师，神宗遣使问劳，阅三日，传旨就寺之山门为士民演法，万众拜瞻，法会殊胜。开法次日，神宗召至延和殿问道，登殿赐坐，宗本就座般足跏趺，待卫惊慌相顾，而宗本却神情自若，又赐茶，宗本举盏长吸，又荡撼之。神宗问：“受业何寺？”对曰：“承天永安。”神宗曰：“禅宗方兴，宜善开道。”对曰：“陛下知有此道，如日照临，臣岂敢自怠。”即辞退，神宗目送之，请左右曰：“真福慧僧也。”上元日，圣驾幸相国寺，止禅众铁出迎。足见神宗对宗本之礼遇敬重。宗本奉旨宣扬佛法，影响远及四方。元丰八年（１０８５）神宗驾崩，哲宗即位，诏宗本入福宁殿说法，并赐“圆照禅师”，宗本以颂谢云：“乾坤之力莫能穷，政化无私孰有功。释子蒙恩何以报，白檀炉上祝尧风
  元祐元年（１０８６）三月，宗本以老乞归林泉，哲宗许之，便敕任意云游，所至州郡不得抑逼住持。可见当时宗本名望之重。临行击鼓辞众，说偈云：”本是无家客，那堪任意游？顺风加橹棹，船子下杨州。”既出都城，王公贵人送者车骑相属。宗本对他们说：“岁月不可把玩，老病不与人期，惟勤修勿怠，是真相为。”闻者无不感激涕零，其慈愍善导，感人如是。晚年居灵岩，闭门颓然，而四方从者相望于道。元符二年（１０９９）将入灭，沐浴而卧，门人环拥请云：“和尚道遍天下，今日不可无偈，幸强起安坐。”宗本熟视云：“痴子，我寻常尚懒作偈，今日特地图个什么？寻常要卧便卧，不可今日特地坐也。”过笔大书五字云：“后事付守荣。”掷笔而化，世寿八十。崇宁二年（１１０３）五月，宋徽宗敕谥“法空禅师”，塔赐“瑞光之塔”，宗本作为云门一代巨匠，一生举扬宗风，文偃家风、雪窦法道至其大盛，嗣法传道者百有余人，主要弟子有善本大通、金山善宁、守一法真、修颙真悟，功良佛慈、延泳正觉等。著有《归元直指集》二卷、《慧辨录》一卷。
    宗本禅法思想，直接继承了云门文偃及天衣义怀的宗风。禅宗史表明，迨达摩初祖东来，独标见性成佛的微妙法门，谓无上妙道，在于离言亲证，非语言文字所能及，于是便有一代藏教之外的单传心印的说法，以佛祖拈花、迦叶微笑来表明宗门不滞文字语言，直接洞见心地，了悟祖心。在《慧林宗本禅师别录》中，随处都可见宗本禅师对此宗风的举扬和展示。如载：
    上堂云：“洪音一剖，震动乾坤；法令施行，万机顿削；圣凡路绝，佛祖情忘。当此之时，东西不辨，南北不分，纵教千古万古黑漫漫，填沟塞壑无人会。”
    上得堂来，首先就是一通“杀威棒”，东西不辨，南北不分，令学人无所用心，言路断绝，诸见难存。其悲心切愿在于将学人逼至心行处灭，万机顿消时，也就是置于死地，处会绝处逢生，返观新源，一时本地风光原露，所以当学人向他请教：
  问：“如何是佛祖西来意？”曰：“韩信临朝。”云：“中下之流如何领会？”曰：“伏尸万里。”云：早知今日事，悔不忌当初。”曰：“三皇冢上草离离。”
  禅林中，“祖师西来意”可以说是最为常见的机锋之语，同时也是自古以来“千圣难傅”的意旨，故宗本只能告诉学人：“韩信临朝。”这里透露着两方面的意思：其一，韩信是臣子，臣子如君临朝，这是绝对不可能的，隐喻了“西来意”是不可能用言语表达的。其二，韩信若如君临朝，这是犯上谋反，必死无疑，如史载，韩信谋反为吕后所诛，。师家兴学人硬要於“西来意”下断语，亦绝无活路，必死句下，所以学学人再问中下根器如何领会时，宗本直言相告：“伏尸万里”。无上菩提之智，确非以世智辨聪能够领会，而应发上上机，开正法眼。若不於自心领语，即使敲骨取髓，刺血穷经，亦不能悟得，而像六祖慧能这样的大机利器，若不能自性自语，一味於言语问求解，只能“伏尸万里。”当学人产生畏难退转心，言悔不当初之语时，宗本告诉他：“三皇冢上草难难”，旨在说明一朝风月，万古长空，佛法一如，何须选择。
  禅悟不可言说，自运摩以来，即以著语言，不立文字，埋指本心，见性成佛为宗旨。禅法妙旨，一涉唇吻，便成死句，宗本在开示演法过程中，随处贯彻了这一原则，他上堂对众云：
    还更有问话底么？然问亦无穷，答亦无尽。何谓？宗乘浩渺，非妙智而莫测其涯，相道渊微，非上根而罕穷其处，诚谓昭昭法界，自他而境智全收，历历真源，彼此而圣凡俱寂，物我冥契，彼此会通，道本如然，目前可视。森罗万象，全彰古佛家风；大地乾坤，尽显毗庐顶相，六街钟鼓，观音入理之门，月殿琼楼，对扬斯事，若也于斯明得，念念释迦出世，步步弥勒下生，师乃顾示左右云，还会么？岂劳妙辨而敷物，何待神通而显示。
    神法宗乘，非思量可得，非言语可说，因为“举目则千山万水，思量则天地悬殊。”宗本向学人解释说：“若据祖宗门下，本分相见，不在高升法座，展露言锋。何也？所以道，言锋若差，乡关万里，”往古先圣，所传一言半句，只是权巧方便之门，旨在引导学人离言绝象，顿悟已心，学人万不可执言忘旨，执指忘月，忘却原初本心，所以宗人告诫学人说：“道由心悟，不在语言，”对于涅盘妙心，无上佛智，只可心悟，不可言传。宗本对此宗旨总结说：“祖师西来，直指人心，见性成佛。见即便见，不在思量，不历文字，不涉阶梯，若以世智辩聪解会，无有是处。”
    禅宗以为，佛由自心作，莫向身外求，自心即佛，即心即佛，所谓“菩提自性本来清净，但用此心，直了成佛。”世人本身佛性，但须自识本心，便可顿悟菩提，见性见佛。宗本以此开示学人说：“若据祖宗门下，本分相见，不在高升法座，展露言锋。”为什么呢？宗本告诉学人，这是因为“诸人各各有照天照地的威光，人人有把定乾坤、绵绵不漏的烁迦罗眼，笼今罩古，水泄不通，截生死流，踞祖佛位，妙圆超达。”佛法偏在，佛性偏在，人人拥有法眼，个个禀具慧心，这一本具自在天真佛卓然独立，烁古耀今，铺天盖地，可谓“天上地下，惟我独尊，”佛法的真谛，就在于让学人确认自性即佛，心外无佛，只要能明心见性，敢于直下承当，佛即众生，众生即佛，禅宗张扬自我，崇尚自性，就在使学人确立自信，崇拜自我，打破一切外在权威，敢于作祖成佛，宗本人堂开示说：
    “头圆像天，足方似地，古貌棱层，丈夫意气，趯倒须弥，踏翻海水，帝释与龙王，无著身处。”乃拈拄杖曰：“却来拄杖上回避。咄！任汝神通变化，究竟须归这里。”
    这里将自性本心所具有的“吞取宇宙”、“能含万法”的气度态势表露无边。宗本于此倾曰：“即心是佛祖师言，古圣从来不异传。一句了然超百亿，十方诸佛亦同缘。”
    学禅之人，只有自识本心，自见本性，“自肯承当”，自然会“咸均事理，顿见如来，拔生死之深根，得现前之三昧……便乃心心求寂，法法灵通，不劳求其半偈，用舍全躯。”世人佛性本具，为何不能顿见菩提？宗本说：“盖为生死为因；苦乐作本，不悟真常，宁通妙旨，浮世扰扰，竟日昏昏，业识相缠，未能顿觉。”所以世人“但能一心回光，便是出尘之事。”
    既然佛心不二，自心即佛，那学人应于何处用功呢？宗本说：“但知行好事，不用问前程。”修禅只要能随顺自然，任运自在，自识本性，别无用心，便为解脱。宗本开示学人说：“姑苏台畔，不话春秋；衲僧面前，岂论玄妙，只可著衣吃饭，玩水看山；夜见星画见日，两手扶犁水过膝。灵山授记只如斯，历劫何曾异今日。”宗本强调任心自在，随顺自然，于日常生活中体性大道，著衣吃饭，游山玩水，自然也是悟道之门，佛祖于灵山法会上传达给人的亦不过是“夜见星画见日”的自然之理。所以当学人请教他“上是天，下是地，未审中间是甚么物？”他回答说：“山河大地，”佛法自然，不可于心上另生葛藤枝节。僧问：“万里来朝即不问，扬帆回棹意如何？”师云：“洗脚上船。”禅法根本就在于随顺自然，贵在悟心，禅法精髓就是无作无为，别无用心，这是一种随顺自然的修行原则，亦是历代祖师传法心印的生命之道。宗本曾作颂表露了自己的这一修行总纲：“随缘任运不须忙，万事无心是妙方，闲坐寂寥人莫测，自然脑后放神光。”
    从上述宗本禅法思想中，可强烈感受到云门宗风在其思想王国里的浩荡气势，宗本禅法大致不出“云门三句”之纲，但宗本作为一代名师，自有其独特过人之处，他有禅学史上最为引人注目的，乃是他倡举华严玄旨，演达圆融奥妙，于圭峰宗密之后，再举“华严禅”之大旗。
    华严禅的首倡者，是唐代宗密禅师。裴休在《大方广圆觉经疏序》中曾介绍密说：“禅师既佩南宗密印，受《圆觉》悬记；于是阅大藏经律，通《惟识》、《起信》等论；然后顿辔于华严法界，冥坐于圆觉妙场；究一雨之所沾，穷五教之殊致。”宗密起初传承荷泽宗的禅法，精研《圆觉经》，后来又从澄观法师学《华严》，后而融会教禅，倡教禅一致论。在《禅源诸诠集都序》卷一中，他说：“经是佛语，禅是佛意，诸佛心口必不相违。”宗密于教最尊华严，于禅最重荷泽，他认为禅教合一的最高境界，应是华严与禅的圆融。“华严禅”的成立可以取代其他一切教家和禅门。宗密的“华严禅”是佛教中国化过程中一个重要环节，这一禅教合一的思想，代表了以后佛教发展的大趋势，入宋以后，这一思想被大力推广，成为当时佛教发展的一股潮流，宗本即是当时应用华严教法的代表之一。
    宗本继承发挥宗密思想，力倡禅教一致。他说：“先圣巧开方便，遂展多门，依无住本而建立。本既无住，能应多缘。譬如洪钟在虡，随扣击以呈音；浩月流辉，列千江而普应，此皆无缘之慈，随有机而感应，不二之旨，逐根性以互分。教虽多途，理归一拨。”佛法如如，教禅不二，真正的学佛者是不会执宗非教，或执教轻宗，各立门户，互相倾轧的。宗本称赞这种如法作为说：“好诸禅德，击三通之法鼓，演无尽之法门。侍者拈香，重重佛事。若据实际理地，三世诸佛不能自宣，六代祖师莫能建立，若据佛事门中，须恁指注，便有一尘一佛国，一叶一释迦，若帝纲之垂珠，法门无尽。”这完全是运用华严宗圆融无碍“四法界”学说来说明其理事无碍的最高境界。如他上堂开示说：
    烁烁瑞光，照大千界，百亿微尘国土，百亿大海水，百亿顷弥山，百亿日月，乃至微尘刹土，皆于光中，一时发现，诸仁者，还见么？若是见得，许汝亲在瑞光，若也不见，莫道瑞光不照。
    这实际就是华严“十玄门”的具体演说。一微尘中，同时具足一切诸法；一一法中有无量法，重重显映，无有穷尽，容摄无碍，不相隔历，诸法融通，相即自在，尘尘法法，事事无碍，随一事理，能显法界实相。所谓“于一毫端现实王刹，坐微尘里转大法轮。”
    宗本“华严禅”的思想还体现于他对高丽僧统义天的开示中。据《慧林宗本禅师别录》载，元丰八年（１０８５），高丽僧统义一在入宋，上表乞传华严教，义天至京，郎中苏轼陪同至慧林寺来拜谒宗本：
    师问僧统：“承闻久熟经论是否？”天云：“精于华严大教留心。”师曰：“好！《华严经》尽是诸圣发明称性极谈，若非亲证悟解，难明法界妙理，莫曾有悟入处否？”天曰：“昭昭于心目之间，而相不可睹。”师曰：“作么生是昭昭于心目之间？”天曰：“森罗及万象，一法之所印。”师曰：“犹是文字语言。如何是一法？”天曰：“无下口处。”师曰：“汝未曾悟在，诸佛意旨，密密堂堂，若非悟入，实难措口。祖师西来，直指人心，见性成佛，见即便见，不在思量，不历文字，不涉阶梯，若以世智辩聪解会，无有是处。所以《华严法界观序》云，昭昭于心目之间。”师顾视僧统云：“好！若也于斯会得，不妙奇特。”复云：“而相不可睹，晃晃于色尘之内，而理不可分，而彻法之慧目，离念之明智，不能见知心，如此之灵通，只如与么说，且那个是自心。”天曰：“知之一字，众妙之门。”师云：“知之一字，作么生会？”僧统曰：“义天未曾参禅。”师云：“不可到宝山空手而回。”天曰：“大善知识，历劫难逢。”师复云：“知之一字，众妙之门，到者众唤作禅得么？莫是举处便是处，一时拈却，且作么生会？”天无语。
    义天入宋，本意求华严教旨，宗本勘验其于法界妙理的悟入之处，义天认为“昭昭于心目之间。”宗本进一步逼问其意义，义天回答：事法虽别，理性同一，所以能一一称性融通，一多相即，即于一微尘中，同时具足一切诸法，如月印万川，而千江水月一月摄。只是相河睹，无下口处。宗本认为义天仍未彻底体悟，还是在名相之中兜圈子。所谓法界妙理，诸佛意旨，须亲证悟解，不在思量，不历文字，不涉阶梯，见即便见，直探心源，如以世智辩聪来解会，只能南辕北辙，错会祖意。所以所谓“昭昭于心目之间。”只是直指人心，见性成佛，因亲证悟入，开口不得，这完全是以禅来会解华严，宗本开示说：
    然华严大教，不可思议，称性极谈，惟对上机。如日独照于高山，尚不入二乘之手，如此戮力流通，岂为小缘。我佛世尊，初成正觉，为见一切众生，愚迷之甚，广大法界，而不能自证，广大威神，而不能得用，所以如来叹曰：奇哉！我今普见一切众生具有如来智慧相，但以执着妄想，而不证得。于是七处九会，称法界性而极谈。至于上品，有一十三千大千世界微尘数偈，中品有一四天下微尘数偈，下品犹有百千妙颂，是此阎浮提所得大教，欲令十方众生，得见自身具有如来广大智慧。于一尘而含法界，于诸刹而普见道场，一多无碍，大小圆融，掷大千于方外，纳须弥于芥中，皆众生之常分，但有心而皆尔，然既有心，何以不见，故知若非彻法之慧目，离念之明智，而不能自见。若也见得，所谓无有形貌，而森罗大千，无有边际，而含容万有，念念尔，尘尘尔，法法尔。古今去来，大小内外，不动纤毫，无参差相。重重涉入，帝纲交罗，虽然如是，犹是圆融法界。义目言诠，于其中间，且作么生会？一尘含法界，于此会得，可谓一口吞尽一代时教。
    诸佛世尊，惟以一大事因缘出现于世，所谓一大事因缘，即开示悟入佛之知见。只因世人外迷着相，内迷着空，不能证得本有如来智慧相，所以总有七处九会，称性极谈，广阐华严玄旨，欲使众生得见自身本具佛性。但因众生根机不同，故对机说法亦不同，所谓“一切法门无尽海，一言演出尽无余”然诸法平等，理性同一，于一尘而含法界，于诸刹而普见道场，尘尘法法，事事无碍，容摄圆通，不相隔历。如十佛摄化的境界，虽有莲花藏世界、十重世界、杂类世界之别，但诸种世界俱为一大法界，圆满自在。所以说，众生本具佛心。“既然有心，何以不见？”这就引入禅宗旨趣，“故知若非彻法之慧目，离念之明智，而不能自见。”最终归结至自识本心，见性明心。《坛经》云：“世人性本自净，万法在自性。”会得“掷大千于之外，纳须弥于芥中，”亦就明了“性含万法是大，万法尽是自性”这就是涅盘妙心，这就是圆融法界。宗本对义天云：“于此会得，可谓一口吞尽一代时教。”高丽僧统义天对宗本此一番“华严禅”的开示，衷心信服，礼拜而去。
    此外，宗本在倡导华严禅的同时，还留心净土法门。宋代佛教内部融合调和的呼声一流高似一浪，宗本作为天衣义怀之法嗣，继承乃师遗风，呼吁诸宗融合，禅教一致。尽管在现存诸种僧传中，未曾明言宗本密修净业，禅净兼修，但日后诸种净土典籍，于此均有记载。据明道衍《诸上善人咏》中说，宗本“老居灵岩，闭户密修净业，曦律师尝神游净土，见一莲座，问彼土之人曰：‘此何人之座？’曰：‘大宋国僧宗本之座。’元符二年十二月甲子沐浴告众，右胁若熟睡然，撼之已去。”宋僧志磐所撰《佛祖统纪》卷二十七亦载说，宗本“密修净土之业，临终安坐而逝，雷峰纔法师，神游净土，见一殿殊丽，人曰：‘以待净慈本禅师。’又资福义师，至慧林礼足施金而去，人诘之，答曰：‘吾定中见金莲华，人言以俟慧林本禅林。又小莲华无数，称是以待受度人。’”其它一些典籍则说照本禅师密修净业，……或问：‘神师云师乃别传之宗，何得标名净土？’师曰：‘虽迹在禅门，而留心净业故也。’”清彭希涑《净土贤圣录》卷三载云：宗本“出家后，参天衣怀禅师，念佛有省。”当然，宋明之后禅净合流已成一时之风尚，许多当时及前代的著名僧人均被说成是曾修净业，对于以上宗本之记载亦不无附会之嫌。但考诸宗本言论，还是能看出其思想中确有净土成分。在《慧林宗本禅师别录》中他曾有颂曰：“圆照十方无内外，灵光独耀莫能过，惟心净土非来往，念念相应是佛陀。”此外，在为驾崩的神宗皇帝举行法事时说：“大行皇帝恭愿净或超升，灵光不昧，金沙池畔，受生报化之身，宝阁门闭开，面睹弥陀之相，亲承佛记，决证菩提。”当有人间“大行皇帝仙驾什么处去？”宗本回答说：“此方向已谢，净国九莲开。”从中可知，宗本尽管仍受禅宗思想“惟心净土”说的影响。但“面睹弥陀之相”、“净域超生”，还是标明宗本确在净禅兼修的思想。“迹在禅门，而留心净业，”看来并非虚悟。其思想中存在着净土思想却是确凿无疑的。


五、契嵩新流

五、契嵩新流

    契嵩（１００７－１０７２），字仲灵，自号潜子，藤州镡津（今广西藤县）人，俗姓李，终钟氏。他７岁出家，十三岁得度落发，十四岁受具足戒，十九岁开始游方参学，下江湖，陟衡庐，十余年间来往于南方各地，“首常戴观音之像，而诵其号，日十万声。于是世间经书章句，不学而能。”后至瑞州（今江西高安）见到云门宗僧人晓聪禅师，成为其得法弟子。明道年间，（１０３２－１０３３），他以佛教五戒、十善比附人儒家五常，作《原教》一文，流传颇广，庆历年间（１０４１－１０４９），契嵩“入吴中，至钱塘，乐其湖山，始税驾焉。”从此，他结束了游方生活，“以文鸣道于天下，”所谓“至钱塘灵隐，闭户著书”。皇祐年间（１０４９－１０５３），曾“去居越之南衡山，未几罢归。”复著《禅宗定祖国》，《传法正宗记》。不久观察使李公谨得其书，且慕其高名，奏赐紫方袍。契嵩感念“幸生天子臣护道达法之年，”遂带着《辅教编》、《传法正宗记》、《传法正宗论》和《传法正宗定祖图》北上京城，能过开封府尹王素的推荐，将书上呈仁宗皇帝。仁宗看过后，后第二年“诏付传法院编次，”收入《大藏》，以示褒宠。并赐给他“明教大师”的称号，由此名灵海内。不久，契嵩谢绝朝廷士大夫的再三挽留，返回杭州，“晚居余杭之佛日山，退老于灵峰永安精舍。”故后人又称其为佛日禅师，亦以“永安”称之。
    从现在资料，已无法了解当年契嵩开堂演法时的情景，但从一些零星记载中，仍可嗅出他孤危险峻、人难凑泊的“云门突急”的遗风余韵。《镡津文集.怀悟序》记载说：“师自东来，始居处无常。……默视其迹，虽或出处不定，然其所履之道，高妙幽远。”可见，契嵩依然保持了云门一脉的高古家风，非上根器者不能领悟。这虽于中下根机者不宜，而契嵩又不肯以佛法作人情，削高就低，有唇门风。他“因而叹曰：吾安能圆凿以就方柄哉！闻圣贤所为得志则行其道，否则行其言而已，言之行犹足为万世法。使天下后世学者，识度修明，远邪见而游至途，则奚必目击而授之谓从已出耶？”契嵩机用，人难领用，所以他难以演法开堂行其道，只得以文字般若来接化学人，又何必去计较识度修明者是否为耳提面命。所以，契嵩的一生主要是“却关著书”。即使在著述中，他仍不脱云门高古之风。史载：“其文之高拨胜迈，绝出古今。……然求世之知言审音者，不亦难其人哉！”他勤于撰述，著作甚丰。据称“所著书自《定祖图》而下，谓之《嘉祐集》，又有《治平集》，凡百余卷，总六十余万言。”但是，他的著作并没有完整保留下来，到两宋之际，其著作已大部分散失，宋代禅僧怀悟从大观（１１０７－１１１０）初开始搜寻契嵩的著作，历时二十余年，至绍与四年（１１３４），仅收集到契嵩著作的一半，“其余则蔑然无闻矣。”怀悟将其所集文稿整理编次，成《镡津文集》二十卷。此外还有《传法正宗记》、《传法正宗论》和《传法正宗定祖图》。这些就是目前留存的契嵩著作。
    契嵩在禅宗史上的主要贡献，一是作《辅教编》等书，继承宗密思想，论述教禅一致，倡三教融合，特别强调儒释两教的一致性。二是作《传法正宗定祖图》、《传法正宗论》等书，厘定禅宗传法世系。
    当契嵩著书立说时，正值宋代思想家和朝野上下抑佛排佛的呼声不断高张。在思想界，一些儒士追随前代韩愈排传传统，纷纷著书反佛。“当时时，天下之士学为古文，慕韩退之排佛而尊孔子，东南有章表民、黄聱隅、李泰伯、尤为雄杰，学者宗之。”同时，朝中重臣中主张抑佛者亦很多，如范仲淹、富弱、文彦博、韩琦、欧阳修等，他们主要基于佛教的兴盛与封建统治经济利益的冲突。契嵩正是在这样一片排佛反佛声中，孤鸣独发，倡导佛儒一致，三教合一思想的。
    最能集中反映契嵩三教合一思想的是《辅教编》、《辅教编》的中心，即是要“广引经籍，以证三家一致，辅相其教。”契嵩认为，三教名目虽然不同，但目的是一致的：“圣人为教不同，而同于为善也。”它们的区别仅在功用之上：“诸教也，亦犹同水以涉，而历揭有深浅。儒者，圣人之治世者也；佛者，圣人之治出世者也。”它们的一致性就在于都能达到“同归于治”。他说：“儒、佛者，圣人之教也。其所出虽不同，而同归于治。儒者，圣人之大有为者也。佛者，圣人之大无为者也。有为者以治世，无为者以治心。”儒家治世，佛教治心，两者相辅相成，缺一不可。为了强调二者的一致性，他曾公然宣称：“不必僧，不必儒；不必彼，不必此。彼此者，情也；僧儒也，迹也。”从现象上看，儒佛是有别的，但从根本旨意上，二者却是相同的。契嵩融合三教的主张，在禅林中影响甚大，云门宗佛印了元曾写过一首诗：“道冠儒履佛袈裟，和会三家作一家；忘却率陀天上路，双林痴坐待龙华。”
    中国是一个宗法伦理国家，孝道是中国封建伦理思想的基本出发点，也是儒学的主要范畴，佛教在中国的推演过程，其实也就是对宗法制度下封建伦理纲常的适应过程。所以从佛教传入之时起，孝道就成为中国士人攻击，排斥佛教的主要武器。北周武帝在他的废佛诏书中指出：“父母恩重，沙门不敬，悖道之甚，国法不容，并退还家，用崇《孝经》。”唐初传奕反佛，其理由也是说佛教“不忠不孝”、“入家破家，入国破国”。韩愈作为儒门战将，亦指责佛教“弃而君臣，去而父子，禁而相生相养之道”。从佛教传入起，许多佛教学者为此而困惑，曾进行过长时间的调和融合，尽管契嵩亦十分清楚儒佛两种伦理体系间的差别，但他认为二者的教迹度不影响两教圣人心同的一致性，他在《上皇帝书》中说，他之所以作《辅教编》，其主旨就在于“推会二教圣人之道，同乎善世利人矣。”在方法上，契嵩侧重讲儒佛在伦理观上的相同之处。他说：“吾之喜儒也，盖取其于吾道有所合而为之耳。”他取佛教的五戒十善来坐同儒家的五常：“儒所谓仁义礼智信者，与吾佛曰慈悲、曰布施、曰恭敬、曰无我慢、曰智慧、曰不妄言绮语，其为目虽不同，而其所以立诚修行，善世救人，岂异乎哉。”“今儒之仁义礼智信者，岂非吾佛所施之万行乎？”把五常等同于佛教万能胶行，旨在说明佛家八万四千行，并未超出儒家五常的伦理规范。
    在儒家伦理规范中，契嵩特别推崇孝道。他特撰《孝论》说：“夫孝，诸教皆尊之，而佛教殊尊也。”说明“孝”不仅是儒家的伦理准则，更是佛教的伦理核心。他在论中多引《孝经》、《书经》、《礼经》等儒家经典来论述佛教“教”道，以至把孝说成是“天之经也，地之义也，民之行也。至哉大矣。”他说：“岂有为人弟者而不悌其兄，为人子者而不孝其亲，为人室者而不敬其夫，为人友者而不以善相致，为人臣者而不忠其君，为人君者而不仁其民。……佛之道岂一人之私为乎？抑亦有意于天下国家矣！何尝不存其君臣父子耶？岂妨人所生养之道耶？”本来在佛教中，“百行戒为先”，但契嵩以为，孝道比戒律更为重要，从而确立了其“孝在戒先”的命题：“子亦闻吾先圣人，其始振也，为大戒，即曰孝名为戒。盖以孝而为戒之端也。子与戒而欲之孝，非戒也。夫孝也者，大戒之所先也。戒也者，众善之所以生也。为善微戒，善何生耶？为戒微也。”契嵩所讲孝道，其核心是儒家的伦理思想，他所论述的戒孝关系，实际就是佛教和儒教的关系。他认为，戒律离不开孝道，孝是根本，戒只是从孝发“端”的，是孝的具体应用，戒律脱离了孝道，也就不成为戒。持戒修善所达到的解脱，实质上也是由“孝道”所致。这种孝在戒先的说法，实际是承认了儒家伦理在佛教伦理之上，是处于主导支配地位的。在宋代统治阶级加强封建纲常秩序的情况下，契嵩提出处理儒佛关系的新理论，适应了当时社会的政治需要。正因为如此，契嵩的著作受致函皇帝重臣的常识和重视。据说，韩琦曾把契嵩的文章给欧阳修看，欧阳修看后，对韩琦说：“不意僧中有此郎也，黎明当一识之。”第二天一大早，韩琦便偕同欧阳修一道往见契嵩，“文忠与语终日，遂大称赏其学瞻道明。”自韩承相以下，莫不延见尊重之，由是名震海内。仁宗见至其书，亦十分赞赏：“上读其书，至‘臣固为道不为名，为法不为身，’叹爱久之，旌以明教大师之号，赐其书入藏。”
    在倡导三教合一、儒佛一致的同时，契嵩为确定禅门传承世系亦殚精竭虑。其时，禅宗已流行了两三个世纪，关于菩提达摩到慧能的禅宗六祖之说已成公论，但对禅宗在西土的传承仍说法不一，天台宗僧人也攻击禅宗传承关系不清，菩提达摩不是正统。“谓所传列二十四祖，至师子祖而已矣，以达摩所承者，非出于师子尊者。”针对“虽一圆颅方服之属，而纷然相是非”的局面，契嵩决心“推一其宗祖，为天下学佛辈秘诤释疑，使百世而知其学有所统。”于是他“力探大藏，或经或论，校验其所谓禅宗者，推正法所谓佛祖者。……编成其书，垂十余万言。命曰《传法正宗记》；其排布状画佛祖相承之像。则曰《传法正宗定祖图》；其推会禅宗之本末者，则曰《传法正宗论》。”《明教大师行业记》中亦谈到：“仲灵（契嵩）之作是书，慨然悯禅门之凌迟，因大考经典，以佛后摩诃迦叶独得大法眼藏为初祖，推而下之，至于达摩，为二十八祖。”从此，禅宗“西天二十八祖”的传法系谱便成为定论，真正起到了“扶持正宗，排斥异说”的作用。
    此外，契嵩作为一禅门高僧，还进行了一项重要工作，即对《坛经》进行了校订。契嵩曾著有》
《坛经赞》一文，在当时很有影响，吏部侍郎郎简，亦颇喜《坛经》，但当时的流行本“为俗所增损，而文字鄙俚繁杂，殆不可考。”便请契嵩校订。契嵩用了近两年时间，于至和三年（１０５６）完成。据说“果得曹溪古本，校之勒成三卷，璨然皆六祖之言，不复谬妄。”这个编校本，今已不存，但后世流传的所谓曹溪原本及元代德异本、宗宝本，都是以此为底本，略作增减而成的。
    在《坛经赞》中，契嵩阐述了自己禅教一致的观点，他说：“以佛后摩诃迦叶独得大法眼藏为初祖，推而下之，至于达摩为二十八祖，皆密相付嘱，不立文字，谓之教外别传者。”尽管禅宗是教外别传，传佛心印，而不立文字，但并不能把禅与教割裂开来。他认为：“能仁氏之垂教，必以禅为其宗，而佛为其祖。祖者乃其教之大范，宗者乃其教之大统。”禅教的对立，乃至大小乘的相争，仅在于祖不正、宗不明，只要承认禅宗的正统地位，就可以息诤释疑，“后世之学佛者，不能尽考经论而校正之，乃有束教者，不信佛之微旨在乎言外；语禅者，不谅佛之能诠遗乎教内。”教是手段，禅是宗旨，参禅者应藉教以悟宗，习教者应明心而见性，经是佛语，禅是佛意，诸佛心口必不相违，因此，禅门与教门本来是一致无别的。
    总之，明教契嵩作为禅宗云门宗的传人，尽管在禅法风范上继承了云门一脉的家风，但他并没有特意去全力光大发扬云门禅法，而是为当时更为迫切的禅宗乃至佛教的生存发展的现实问题所牵制，他不得不用毕生的热诚和精力去著书立说，阐述儒佛不二、禅教一致的融合思想。所以，契嵩在云门宗史上之所以能占有此独特地位，并不在于对云门禅法本身的发展张扬，而在于他作为力倡儒释融合的著名禅僧，乃是云门的法流所出。


六、灯灯续焰

六、灯灯续焰

    云门文偃是禅宗六祖慧能门下第八代，其由雪峰存、德山鉴、龙潭信、天皇悟上承石头迁的法统。文偃于韶州云门山光泰禅院开法以来，门下颇盛，法席常逾千人。嗣法弟子有六十余人，主要有白云子祥、德山缘密、香林澄远、双泉师宽等。其中尤以澄远为上首。他住益州青城山香林院，接人语句完全继承文偃的风格。澄远门下有智门光祚，门风险峻，光祚法嗣有雪窦重显、延庆子荣、南华宝缘等三十人。
    云门宗至文偃门下第三、第四代弟子时，进入鼎盛时期，与临济宗并驾齐驱，成为禅宗中最活跃的两派，宋徽宗序《续灯录》曰：“自南岳青原而下，分为五宗，各擅家风，就机酬对，虽建立不同，而会归则一，莫不箭锋相拄，鞭影齐施，接物利生，启悟多矣，源派演迤，枝叶扶疏，而云门、临济二宗，遂独盛于天下。”北宋前中期，云门宗逐渐由岭南向北推移，出现了许多有影响的禅师，其中以圆通居讷和佛印了元、雪窦重显、大觉怀琏、慧林宗本及明教契嵩最为著名。
    圆通居讷（１０１０－１０９８），字敏中，樟州中江（四川中江人，俗姓蹇，十一岁出家，于汉州什邡（成都附近）竹林寺侍奉元昉，十七岁试经得度，后东行至庐山，成为光祚门下延庆子荣的弟子，先后住持归宗寺和圆通寺，在江州（江西九江）一带有不小的影响，特别是致力于儒佛融通，深得士大夫好评。
    佛印了元（１０３２－１０９８），字觉老，饶州（江西波阳）人，俗姓林，十五岁出家，十九岁去庐山参见开先善暹，成为其嗣法弟子，佛印的传承为文偃——双泉仁郁——开先善暹——佛印了元，据说居讷一见佛印即称赞他：“骨格已似雪窦，后来之后也。”了元曾住持庐山归宗寺、镇江金山寺，江西大仰寺和云居寺等，“凡四十年间，德化缁素，缙绅之贤者多与之游。”在江西和江苏等地建立了稳定的弘法基地。
    雪窦重显以明州（浙江宁波）雪窦山为中心，举扬宗风，影响甚大，其颂古之作不仅成为禅僧的必读书，而且受到参禅士大夫的欢迎，其嗣法弟子有八十余人之多，被称为“中兴云门。”
    大觉怀琏（１００９－１０９０），为文偃门下第四代，共传承法系为：文偃——双泉师宽——五祖师戒——泐潭怀澄——大觉怀莲。漳州龙溪（福建龙溪）人，幼年出家，曾师事怀澄十余年，后游庐山，常居讷禅师记室，皇祐元年（１０４９），朝廷命居讷住持左街十方净因禅院，居讷举怀琏以代。当时汴京两街诸寺的传承系统只有法相宗和南山律宗。自有净因院，禅宗始行于北宋京城。
    重显的知外弟子有义怀，曾住持安徽无为铁佛寺，后迁至越州（浙江绍兴）天衣寺行化，前后主持法席七次，大兴云门宗风，法嗣有八十三人，其中以慧林宗本，法云法秀、长芦应夫、天钵重元等为上首。
    宗本，十九岁入苏州承天永安寺道升禅师门下，若修十年方剃发受具足戒，又服勤三年，后拜辞道升参脚游方，至池州景德寺，参谒天衣义怀，有所契悟，义怀退居后，推举其在姑苏瑞光寺开法，元丰五年（１０８２），汴京相国寺六十四院开辟为八寺，二禅六律，以东西序为慧林、智海二禅寺，召宗本住持慧林禅刹，为第一祖，大扬禅风。宗本一系，僧才辈出，特别在北方势力更大，传承说较长。宗本下，有长芦崇信、法云善本等。崇信下，有慧林怀深，宣和三年（１１２１），国住持慧林寺。其后递传灵隐寂室、中竺痴禅、光孝已庵。善本（１０３５－１１０９），颖州（今安徽颖上县）人，出家后，到姑苏参宗本于光瑞寺，默契宗旨，服勤五年，尽得宗本之道。后来住持婺州双林寺，道俗推崇备至。继而移住杭州净慈寺，继承宗本的法席，和宗本并称“大小本”。不久又住持不京法云寺，继承法秀的法席，号大通禅师，住持八年，又归老于西湖之上。门上有雪峰思慧，天竺从谏等六十九人。思慧下有净慈道昌，道昌下有五云悟。
    义怀的另一知外弟子为法云法秀。法秀（１０２７－１０９０），秦州陇城（今甘肃秦安县）人，十九岁时试经得度，后来便从事讲经，既而至无为军铁佛寺参义怀，有所证悟，得到印可。初住持淮西四面山，既而又住持栖贤，蒋山、长芦，后来东京法云寺落成，他应如为开山第一祖，号圆通禅师。其下有佛国惟白，保宁了英等五十九人。惟白继法秀之后，住持白云寺，后移住明州天童寺，撰有《建中靖国续灯录》三十卷。其下有慧林慧海等十四人，慧海下有万杉寿坚。
    当然在云门法流所出中，以明教契嵩最为知名，其阐述儒佛一贯之理，对后世影响甚大，扩大了禅宗在社会上的影响。
    从上述看来，云门宗僧人奉诏住持京城寺院的人数众多。挟皇权之势，影响及于全国。如黄龙派创始人慧南，就借鉴了云门派的教禅特色，而设“黄龙三关”。杨歧派创始人方会，也在接化学人方面受到云门派的影响。北宋前中期，尽管云门派和临济派共同推进禅宗的发展，然而云门派禅人贡献尤为巨大。从北宋徽宗到南宋末年，云门派渡过了它的鼎盛期，逐渐走向衰微，尽管云门派传法世系未绝，但已不能代表禅宗发展方向，到了元初，其法系就无从考核，湮没无闻了。一宗之法脉仅延续了二百年，这大概是由于其宗风突急，机辨险绝，言语简洁高古，只言片语蕴无限旨趣，接化学人又常是截断众流，不容拟议，几乎无路可通，非上等根机不易悟入，与众多中下根机难以沟通，所谓“孤危耸峻，人难凑泊。”昔云峰悦禅师云：“云门虽有定乱之谋，要且无出身之路。”云门一脉的绝传，绝非偶然。


一、文益创法眼

第十章

    一、文益创法眼

    文益（８８５－９５８），俗姓鲁，余杭（杭州）人。年甫七岁，即投新定之智通院全伟落发，弱龄即受具戒于越州（绍兴）之开元寺。后于明州（宁波）育王寺希觉禅师门下习律，同时“傍探儒典，游文雅之场”，希觉称他为“我们之游、夏”。后到福州长庆寺谒长庆慧棱，未契玄旨，乃结伴从西湖出游，因大雨，停留在城西之地藏院，得参桂琛。桂琛问他：“行脚作么生？”文益曰：“不知。”琛曰：“不知最亲切。”文益豁然开悟。又指庭下片石问他：“寻常说三界惟心，万法惟识。且道此石在心内。在心外？”文益曰：“在心内，”琛云：“行脚人著甚么来由安片石在心头？”益窘无以对，遂放下包袱，依止月余。从“词穷理绝”处悟“一切见成”、言下大悟。至临川（江西抚州），州牧请住崇寿院。由此传法，四远参徒翕然而至，不下千人。南唐初（９３７后）受江南国主李氏之请，住金陵报恩院，号净慧禅师，再迁清凉寺，持续开堂。异域慕其法者，涉远而至。玄沙正宗，兴于江表。周显德五年（９５８）卒，谥大法眼禅师。著有偈颂、真赞、铭记、诠注等，共数万言，流布天下。现存《语录》、《宗门十规论》、《大法眼禅师颂十四首》首。
    关于文益法眼宗禅风的纲宗，有谓曰“三界惟心，万法惟识”，有谓曰“先利济”，有曰“消除情解”，有曰“一切见成”，当以“先利济”、“削除情解”为当。“先利济”为接引学人之手段，“削除情解”为解脱之目的。至于“三界惟心，万法惟识”则为佛教一切宗派，尤为法相宗之纲宗。“一切见成”亦禅宗各宗派，尤为杨歧派之纲宗，似不宜作为法眼宗之纲宗。
    （一）先利济，削情解
    《参禅要略门》把法眼宗“随对方人之机，接得自在”之宗风，称为“先利济”。济，即度人、济物。前面举桂琛接引文益之例；从“不知行脚作么生”，“不知最亲切”，再到“言下有省”；从“不知安片石在心内何故”，到“词穷理绝”，再到“悟一切见成”，都说明法眼宗接引学人之特殊宗风。
    先利济、削除情解，可以针对不同话头，也可以在不同场合、以不同情境题偈作赋启示学人。如文益从金陵报恩禅院迁清凉寺后，一日与南唐李主观赏牡丹花，李命作偈。益即赋云：“拥毳对芳丛，由来趣不同。发从今日白，花是去年红，艳冶随朝露，馨香逐晚风。何须待零落，然后始知空？”不仅诗趣高雅，而且寓意深刻，至今传诵不绝，脍炙人口。他之所以在金陵三坐大道场，朝夕演法，诸方禅林，皆靡然风化，是与这种“先利济”的禅风不一匠。
    （二）教禅融合，活用《华严》
    忽滑谷快天在评价法眼宗之禅风时说：“其宣扬法门，禅教融合，浑然无瑕（一个王字旁，一个此字）。语不险而理幽，机锋不露而用活。不隐当时之禅弊者，盖益一人耳。益法道之特色是发挥石头明暗理事回互之妙用，体现华严之圆理于禅，兼带三界惟心、万法惟识之真理者。”禅教融合，体华严圆理于禅，此确是法眼宗又一鲜明特点。
    文益在《宗门十规论》中，针对丛林的弊端，指出：“大凡祖佛之宗，具理具事，事衣理立，理假事明，理事相资，还同目足。若有事而无理，则滞泥不通，若有理而无事，则汗漫无归。欲其不二，贵有圆融。且如曹洞家风，则有偏有正，有明有暗，临济有主有宾，有体有用。然建化之不类，且血脉而相通，无一而不该，举动皆集。又如法界观，具谈理事，断自色空，海性无边，摄在一毫之上；须弥至大，归藏一芥之中，故非圣量使然，真猷合尔。又非神通变现。诞性推称，不著它求，尽由心造，佛及众生，具平等故……苟或不知其旨，妄有谈论，致令偏正滞于回互，体用混于自然，是其五。”“若欲举扬宗乘，须先明佛意，次契祖心。……傥或不议义理，只当专守门风，如辄妄有引证，自取讥诮，是其八。”文益批语专守门风不识义理，不明佛意之人，也批评对于偏正、体用的宗旨不明之人，主张禅与教，理与事融通。
    文益还要求其门下阅读法藏《华严奥旨》、《华严经义海百门》、《华严论》、《涅盘经》等经论，同时要活用，不要滞于教，滞于相，他批评有些门徒“只凭么念策（册）子，有什么用处。”他用华严六相义来接引学人。《华严六相颂》说：“华严六相义，同中还有异，异若异于同，全非诸佛意，诸佛意总别，何曾有同异，男子身中入定时，女子身中不留意，不留意，绝名字，万象明明无理事。”“华严六相”，是就所缘境界进行辩证思维，不偏执于某一点、某一方面，于有无、能所、动静、成坏圆融无碍，从而求得解脱。《宗镜录》说：“若究竟欲免断常边邪之风，须明华严六相义门，则能住法施为，自忘能所，随缘动静，不碍有无，具大总持，究竟无过矣。”六相的具体内容是：“六相者，一总、二别、三同、四异、五成、六坏。总相者，譬如一舍是总相，椽等是别相，椽等诸缘和合作舍，各不相违，非作余物，故名同相；椽等诸缘，递相互生，一一不同，名异相；椽等诸缘，一多相成名成相；椽等诸缘，各住自法不作，故名坏相。则知真如一心为总相，能摄世间出世间法故，约摄诸法得总名，能生诸缘成别号，法法皆齐为同相，随顺不同称异门，建立境界故称成，不动自位而为坏。”总相即对世间、出世间的总体把握；其本体即真如一心。别相是指世间、出世间一一具体现象、具体境界。诸相之相互关联同相。诸相不同特点称异相；一种境界产生、形成叫成相；这种境界停滞不前，固步自封，叫坏相。
    总、别、同、异、成、坏、是对世间、出世间一切境界及其关系的性质的总体把握。它们之间是相互对待的。而“空”作为一切有质碍之“色界”与无质碍的“无色界”的本质抽象，则是绝对的，无待的，因此，文益与永明道濳的机缘法语中就谈到“空还具六相也无”的问题。《文益禅师语录》说：“永明道濳禅师，河中府人。初参师，师问云：子于参请外，看什么经？道濳云：《华严经》。师云：总别同异成坏六相，是何门摄属？濳云：文在十地品中，据理，则世、出世间一切法，皆具六相也。师云：空还具六相也无？濳懵然无对。师云：汝问我，我向汝道。濳乃问：空还具六相也无？师云：空。濳于是开悟，踊跃礼谢。”道濳始认为世间、出世间一切法皆具六相，从经文益启发，认识到“空”是对诸法本质的概括，因而它不存在着总与别、同与异、成与坏问题。空本身就是不能有任何规定性的，是无待的，绝对的。所谓“何须待零落，然后始知空”，不管是零落还是不零落，都是“空”，这总是对一切色、法、一切色界、无色界的彻底的悟。由此看来，文益对于禅教之融合，对于华严理事圆融思想的证悟，是达到相当高的思辩水平的。
    （三）啐啄同时，针砭时弊
    法眼文益接引学人，啐啄同时，十分亲切。如鸡孵蛋，小鸡要出壳时，用嘴吮吸，叫啐；母鸡为了使小鸡出来，用嘴啄壳，叫啄。啐啄同时，即比喻禅林师徒之间机缘相契，毫无间隙。文益与门人德韶的悟道因缘即可说明这一点。“师一日上堂，僧问：如何是曹源一滴水？师云：是曹源一滴水。僧惘然而退。时韶国师于坐侧，豁然开悟，韶遂以所悟闻于师，师云：汝向后当为国王所师，致祖道光大，吾不如也。国师后有偈云：通玄峰顶，不是人间。心外无法，满目青山。师闻云：即此一偈，可起吾宗。”文益啐啄同时，大体上有两层意义：第一、在于根据徒众的不同根缘，予以及时肯定、引导、让他们受到启发，自己得到证悟。从问到答，虽然内容重复，但不是简单的重复，而是使徒众由不悟而生疑，激发他去努力参究、证悟；第二、实质上是“当下即是”的自我证悟。这样，徒众通过启发，更通过证悟，达到很高的境界，证悟虽然离不开师父的启发，却又不离自心（心外无法、法在心中），无怪乎文益因此一偈而肯定德韶“可起吾宗”，为法眼宗的光大找到一个得力传人。
    啐啄同时，从文益与玄则关于“丙丁童子求火”的公案也同样看得很清楚。“玄则禅师，滑州卫南人，初问青峰，如何是学人自已？青峰云：丙丁童子来求火。”后来，文益与之继续讨论，玄则以此反问文益，文益同样以此作答，“则于言下大悟。“前后答案虽然一致，但答案即包含在问题之中，而文益之所以先加以否定，后加以肯定，目的同样在于促进玄则因疑而努力参究，不满足于从文字、名言上的知解，玄则果然由此得到启悟，可见这种接引禅人的禅风确有独特效果。
    文益针对当时丛林的弊端，著《宗门十规论》。这对于加强禅宗的道风建设，有十分重要作用，至今仍有重要启示。其内容是：
    第一、批评懒于参求，徒具虚名的禅风。文益说：“近代之人，虽入丛林，懒于参求，纵或留心，不择宗匠，心地尚未明，急务住持，滥称知识，且贵虚名在，是其一。”
    第二、批评播弄是非，以争门为神通的宗派主义。文益说：“德山、临济、沩仰、曹洞、雪峰、云门、各有门庭施设。子孙护宗党祖，不展真际，意出多歧，矛盾相攻，以争门为神通，骋唇舌作三昧，是非锋起，人我山高，是其二。”
    第三、批评剽窃人言，真伪不分之弊。文益说：“今人多不量已力，剽窃人言，但知放，而不知收；虽有生而且无杀，如郎不辨、真伪不分。此其三。”
    第四、批评对于各宗派不辨纲宗，不知融通。文益说：“曹洞则敲唱为用，临济则互换为机，韶阳（云门）则函盖截流，沩仰则方圆默契，如谷应韵，似关合符。虽差别于规仪，且无碍于融会。近代宗师……对答既不辨纲宗作用，又焉知要眼，诳谑群小，欺昧圣贤。是其四。”
    第五、批语对于偏正、体用没有正确把握的人，不能知道理事相资的根本宗旨。文益说：“大凡祖佛之过，理事相资，还同具足。苟或不知其旨，妄有谈论，致令偏正滞于回互，体用混于自然，是其五。”
    第六、批语一些人缺乏先德那种为追求解脱真理而努力修持的求实、严谨精神，却臆断古今的弊病，文益说：“先德梯山航海，不避死生，为一两转之因缘，有纤瑕之疑事，须凭抉择，贵要分明，如不经淘汰，臆断古今，则何异未学剑而强舞太阿，是其六。”
    第七、批语一些学人滞于言句，自以为是，则处炫耀的弊病。文益说：“近代学人，专守师门，记持露布，切忌承言滞句，便鼓吻摇唇，以为妙解，是其七。”
    第八、批语一些人不识学理，却专守门风、自取讥诮的片面性。“若欲举扬宗乘，须先明佛意，以契祖心，傥或不识义理，只当专守门风，如辄妄有引证，自取讥诮，是其八。”
    第九、批语一些宗匠歌颂，制作的轻率，谬误流传，害人不浅。“诸方宗匠，以歌颂为等闲，将制作为末事，任情直吐，多类于野谈，率意便成。识者览之嗤笑，愚者信之流传。是其九。”
    第十、批语一些住持不守戒律，护已之短，攻人之长，不搞正信、搞迷信之弊病。文益说：“盖有望风承嗣、窃位住持，便谓我已得上乘，护已之短，毁人之长。以讦露为慈悲，以佚滥为德行，破佛禁戒，弃僧威仪，反凌铄于二乘，倒排斥于三学。口谈解脱之因，心弄鬼神之事，是其十。”
    文益对五代末丛林弊病痛下针砭，十分深刻，其批语之尖锐性，为历代所不多见，其中所阐明的道理对后来佛教的信仰，道风、人才、教制、组织建设，都有深远的指导意义，值得引为鉴戒。


二、法眼宗传承

二、法眼宗传承

    法眼宗的传承，在南唐、南越至五代间，据《五灯会元》、《传法正宗记》资料统计，其传承约一八三人，据本书末附录传承图统计，则有三百六十余人，法眼文益法嗣中，著名的有天台德韶、清凉泰钦、百丈道恒、净德智筠、永明道潜、永明延寿、灵隐清耸，报恩慧明、报慈行言、报恩法安、归宗策真等。
    （一）德韶得般若真宗
    天台山德韶国师（８９１－９７２），处州龙泉（今浙江龙泉）陈氏子。十七岁，依龙泉寺受业，十八岁纳戒于信州开元寺，后唐同光中游方，首诣投子见同禅师，次谒龙牙，屡问玄旨，竟不喻，再请垂诲，牙曰：“道者，汝以后自会去。”后于通玄峰澡浴次，忽省前语，遂具威仪，焚香遥望龙邪礼拜曰：“当时若向我说，今日决定骂也。”历参五十四位善知识，皆法缘未契，最后于临川谒法眼文益，文益一见，深器之。一日在回答“如何是曹源一滴水”的问题时，文益答“是曹源一滴水”，韶豁然开悟。文益称赞他“向后当为国王所师，至祖道光大，吾不如也。”寻回本道，游天台，参智顗禅师遗踪。后止白沙，时忠懿王为王子，刺台州，向师之名，延请问道。师谓曰：“他日为霸主，无忘佛恩。”后汉乾佑元年（９４８）王子嗣国位，遣使迎之，伸弟子之礼，并遵师之意，遣使住新罗国缮写该国流传的天台智者之教籍回国，盛行于世，开宝五年（９７２）六月，卒于天台般若寺。
    德韶主张超越见闻言句，从脚下亲参实悟。其上堂法语说：“大凡言句，应须绝渗漏始得。”批语在言语中转圈圈的人，“依草附木”，只能“与佛法天地悬隔”。“假若答话拣辨如悬河，只成得个颠倒知见，若只贵答话拣辨，有什么难，但恐无益于人，翻成慊语。”他指明学人为什么“说道理极多”，疑心不息，闻古圣方便，特地不会？“只为多虚少实。上座不如从脚跟下一时觐破，看是什么道理？……所以古人道：见闻不脱，如水里月，无事珍重！”他之所以强调超越见闻、言语，在于以般若智慧求得证悟。
    关于般若智慧，德韶在般若寺开堂说法有十分深刻的论述。有僧问：“承古有言：若人见般若，即被般若缚。若人不见般若，亦被般若缚。既见般若，为什么却被缚？”德韶曰：“若见般若，不名般若；不见般若，亦不名般若。且作么生说见与不见？所以古人道：若欠一法，不成法身；若剩一法，不成法身；若有一法，不成法身；若无一法，不成法身。此是般若之真宗也。”般若智慧是不立一法，又不破一法，有法皆立，无法不破。也就是说，般若与法身是不一不二，不离不成的。任何执着于名言法身都不能得其真谛。所以，德韶又说：“夫一切问答，如针锋相投，无纤毫参差。无事不通，理无不备。良由一切言语，一切三昧，横竖深浅，隐显去来，是诸佛实相门。只据如今一时验取。珍重！”这确是得般若真谛之论，亦是禅宗发展达到日益成熟的一个里程碑。自道信、弘忍以《般若》与《楞伽》融通以来，禅宗在以般若智慧指导禅修上，曾出现一些偏差。南北顿渐之争，一方面固然对禅学的发展有促进作用（以顿悟为究竟），另一方面，徒众之间，以门派之见，如山水火，则不能说是好事。偏执于一端，排斥异已，当属偏差，流弊甚多。德韶以不欠、不剩、不有、不无，辩证地处理法身与般若的关系。确实在理论上，实践上对于禅宗素质的提高，对于丛林的理论建设提供了比较正确的答案。这是应当予以重视的。
    德韶吸取了道家自然无为思想，继承了僧肇“般若无知”的思辨和慧能归依自身三宝的思想，对佛法一切现成，修行即无所造作，彻悟本有之性作了卓越的阐述和发挥。他上堂法语说：“佛法现成，一切具足。岂不见道圆同太虚，无欠无余。若如是也，且谁欠谁乘，谁是谁非，谁是会者，谁是不会者？……若会得，自然见闻觉知路绝，一切诸法现前。何故如此？为法身无相，触目皆形，般若无知，对缘而照。一时彻底会取好。诸上座，出家儿合作么生？此是本有之理，未为分外，识心达本源，故名为沙门。”他还对百千神通妙用，不出般若海中作了论述：
    “百千三昧门，百千神通门，百千妙用门，尽不出得般若海中。何以故？不于无住本建立诸法。所以道：生灭去来，邪正动静，千变万化，是诸佛大定门，无过于此。”
    德韶通过般若智慧，彻悟本源，即是在言语道断、心行处灭而证悟。他上堂说：“吾有一言，天上人间，若人不会，满目青山。且作么生是一言底道理？古人语须是晓达始得。若是将言而名。于言未有个会处，良由究尽诸法根蒂，始会一言，不是一言半句思量解会，唤作一言。若会言语道断。心行处灭，始到古人境界，亦不是闭目藏睛，暗中无所见，唤作言语道断，且莫赚会，佛法不是这个道理。要会么？假饶经尘沙劫说，亦未曾有半句到诸上座，经尘沙劫不说，亦不曾欠少半句。应须彻底会去始得。若如是斟酌名方，空劳心力，并无用处。与诸上座共相证明，后学初心，速须究取。”对于佛法道理，须通过证悟而通晓，不是一言半句去思维、审虑，了不是闭目藏睛无所见所能知晓的，这种境界十分玄妙，若能达到，就如同到了天上人间，若达不到，则依然满目青山。
    德韶作为一个深受国主敬重的禅师，既有宗教家循循善诱的品格，又有依附于当政的统治者、并与之协调的能力。他着力发挥佛教“报四恩”的思想，说：“灵山付嘱分明，诸上座一时验取。若验得更无别理，只是如今，譬如太虚，日明至暗，山河大地，一切有为世界，悉皆明现。乃至无为，亦复如是。世尊付嘱，迄至于今，并无丝毫差别，更付阿谁？所以祖师道：心自本来心，本心非有法，有法有本心，非心非本法。此是灵山付嘱榜样。诸上座彻底会取好，莫虚度时光。国王恩难报，诸佛恩难报，父母师长恩难报，十方施主恩难报。况建置如是次第，佛法兴隆，若非国王恩力，焉得如此，若要报恩，应须明彻道眼，入般若性海始得。”他上堂屡祝佛法久住，增益人天寿命，国王安乐，也确实反映了五代末社会动乱形势下人心思定，人心思治的要求与愿望。
    德韶之弟子甚众，达五十八人之多，其最著名者，有永明延寿、报恩绍安、普门希辩、五云志逢等。
    （二）清凉泰钦理事圆融
    清凉泰钦灯禅师（９１０－９７４），魏府（河北大名）人。生而知道，入法眼之室，海众归之。初住洪州双林院，开堂日，僧问：”如何是双林境？“师曰：“画也画不成。”又问：“一佛出世，震动乾坤。和尚出世，震动何方？”师曰：“什么处见震动？”次住上蓝护国院，后又住金陵龙光院清凉大道场。于清凉近一纪（十二年），上堂曰：“本欲居山藏拙，养病过时，奈缘先师有未了底公案，出来与他了却。”僧问：“如何是先师未了底公案？”师便打。僧曰：“祖祢未了，殃及儿孙。”曰：“过在什么处？”师曰：“过在我殃及你。”主张“不见一法即如来，方得名为观自在。”开宝七年（９７４）六月示疾。二十四日安坐而终。
    泰钦禅师继承法眼圆融教禅和活用《华严》的思想，主张：“百骸一的，一物百骸。”理事圆融；对于江南国主也相交甚深，时与相论玄旨，宣扬报四恩思想。
其传法弟子有云居道齐，道齐传云居契环，灵隐文胜、瑞岩义海、广慧志全、大梅居熙、南明惟宿等１１人，文胜、义海又传延珊等３人。
    （三）清耸以非取非舍释般若
    灵隐清耸（？－９４８），俗姓蔡，福州福清人。初参法眼，不喻旨。后因阅《华严》感悟，承眼印可，回止明州四明山卓庵。忠懿王命于临安两处开法。后居灵隐上寺，署了悟禅师。上堂法语主张“一切法不生，一切法不灭，若能如是解，诸佛常现前。……见如今直下承当，顿豁本心，皎然无一物可作见闻。若离心别求解脱者，古人唤作迷波讨源，卒难晓悟。”僧问：“如何是和尚家风？”师曰：“亘古亘今。”曰：“牛头未见四祖时如何？”师曰：“青山绿水。”曰：“见后如何？”师答：“绿水青山。”问：“如何是摩诃般若？”师问：“雪落茫茫……非取非舍。若人不会，风寒雪下。”他以“非取非舍”释般若大义，言简意赅，颇得要领，与德韶“不欠、不剩、不有、不无”的“般若真宗”的异曲同工之妙。
    清耸的传法弟子功臣道慈、罗汉愿昭、报恩师智，瀔宁可先、光寺道端、保清遇宁、支提辨隆、瑞龙希圆、国泰德文等９人。
    （四）道恒不离三句口诀
    百丈道恒（９１６－９９１）禅师，出家于洪州百丈夫智院，参清凉文益得法，留充侍者，复司函牍。僧问：“如何是百丈境？”师曰：“何似云居？”问：“如何是百丈为人一句？”师曰：“若到诸方，总须问过。”乃曰：“实是无事，诸人各各是佛，更有何疑，得到这里？古人道，十方同聚会，个个学无为。此是选佛场，心空及第归。且作么生是心空？不是那里闭目冷坐是心空，此正是意识想解。上座要会心空么，便且识心，便见心空。所以道，过去已过去，未来更莫笄兀然无事坐，何曾有人唤。……三世体空，且不是木头也。所以古人道，心空见法王。还见法王么？也只是老病僧，又莫道渠自伐好。珍重！”上堂法语说：“古人云：参他不如自参。所以道森罗万象，是善财之宗师；业惑尘劳，乃普贤之境界。若恁么参，得与善财同参。若不肯与么参，却归堂向火，参取胜热婆罗门。珍重！”他以“吃茶、珍重、歇”为三句口诀，要学人但且识心，但见心空，把“森罗万象”之“事”与善财宗师之“理”、业惑尘劳之“世间”与普贤境界之“出世间”圆融起来，发扬了文益禅教结合、活用《华严》之禅风。
    其传承弟子有栖贤澄湜、万寿德兴、云门永等３人。澄湜后传兴教惟等３人。
    （五）报恩慧明折群彦
    报恩慧明禅师（８９５－９７５）俗姓蒋，幼岁出家，三学精炼，南游于闽越，莫契本心。后至临川谒法眼，师资道合，寻回鄞水大梅山庵居。吴越郡内，禅学虽盛，而以玄沙正宗置之阃外，师欲整而导之。寻迁天台山白少卓庵，整导禅学。后汉乾祐中，忠懿王延入府中问法，王命翠岩令参诸禅匠及城下名公定其胜负，群彦弭伏。王甚赞赏，延居杭州报恩寺，阐扬宗道，其嗣为保明道诚。
    慧明之整导禅学及效果如何，不详，但他既以“玄沙正宗”为旗帜，当邓是针对禅林之种种弊端而弘扬正信禅宗者。惜乎法嗣仅道诚一人。
    （六）行言旨在旧处投师
    报慈行言玄觉导师，泉州人，上堂“古人有言，譬如披沙识宝，沙砾若除，真金自现，便唤作常住世间，具足僧宝。亦如一味之雨，一般之地，生长万物，大小不同。甘辛在异，不可道地与雨有大小之名也。所以道，方即现方，圆即现圆。何以故尔？法无偏正，随相应现，唤作对现色身，还见么？若不见也，莫闲坐地。”江南国主建报慈院，命师大阐宗猷。海会二千余众，别署玄觉导师之号。还说：“林罗万象，诸佛洪源，显明则海印光澄，冥味则情迷自惑。苟非通心上士，逸格高人，则何以于诸尘中发扬妙极，卷舒物象。纵夺森罗，示生非生，应灭非灭。生灭洞已，乃曰真常。言假则影散千途，论真别一空绝迹。岂可以有无生灭而计之哉！”僧问：“远远投师，请垂一接。”师曰：“却依旧处去。”他认为法无偏正，随相应现，方即现方，圆即现圆。是以森罗万像，尽诸佛洪源。主张于诸尘中发扬妙极，依旧处投师，不可以生灭计之。
    其法嗣有北禅清皎、云居义能。
    （七）契稠“佛法”即现成
    崇寿契稠（９５８－９９２），泉州人，嗣法眼文益禅师。住抚州崇寿院。上常曰：“大众欲知佛性义，当视时节因缘。……第一义现成，何劳更观？凭么显明得佛性常照，一切法常住。若见有法常住，犹未是法之真源，作么生是法之真源？上座不见古人道，一人发真归源，十方虚空悉皆消殒。还有一法为意解么？古人有如是大事因缘，依而行之即是，何劳长劳多说。”这种佛法一切现成，不劳把捉之义是深刻的。
    其法嗣有净土惟素、资国圆进、云台令岑、天童子凝。惟素传净土惟正。后不详。
    （八）法安旨曰“无法与人”
    报恩法安禅师（？－９６７）太和人，为清凉文益法嗣。初住曹山崇寿院。学人云集。上堂说：“夫佛性亘古亘今，未尝不现前。诸上座，一切时中，咸承此威光，须具大信根，荷担得起始得。不见佛赞猛利底人堪为器用，亦不他向善，久修净业者，要似他广额凶屠，抛下操刀，便证阿罗汉果，直须凭么始得。所以长者道，如将梵位直援凡庸。”江南国主请居报恩，署号摄众大师。上堂曰：“夫禅宗示要，法尔常规，圆明显露，亘古亘今。至于达摩西来，也只与诸人证明，亦无法可得与人。只道直下是，便教立地构取。古人虽则道立地构取，如今坐地还构得也无。有疑请问。”开宝中示灭于本院。他主张法尔如是，无法可入，直下便是，其法嗣有归宗慧诚、栖贤道坚。
    （九）道钦主“向衣钵下坐地”
    章义道钦禅师，太原人，清凉文益法嗣。初住庐山栖贤。上堂：“道远乎哉，触事而真。圣远乎哉，体之则神。我寻常示汝，何不向衣钵下坐地，直下参取。须要上来，讨个什么？既上来，我即事不获已，便举古德少许方便，抖擞些子龟毛兔角，解落向汝。诸上座欲得省要，僧堂里、三门下、寮舍里参取好。还有会处也未？若有会处，试说看。与上座证明。”后江南国主请居金陵钟山章义道场，上堂：“总来这里立，作什么？善知识如河沙数，常与汝为伴。行住坐卧，不相舍离。但长连床上稳坐地，十方善知识自来参，上座何不信取，作得如许多难易……诸上座但于佛法中留心，无不得者，无事体道去。”向衣钵下坐地，直下参取，亦是一切现成，顿悟之意。
    其法嗣不详。
    （十）匡逸“无失亦无得”
    报恩匡逸禅师（？－９５８），明州人，清凉文益法嗣。初住润州慈云院，后江南国主请居金陵报恩寺，署凝密禅师，上堂曰：“依而行之，即无累矣。还信么？如太阳赫奕皎然地，更莫思量，思量不及；设尔思得及，唤作分限智慧。不见先德云：人无心合道，道无心合人，人道既合，是名无事。人且自何而凡，自何而圣？于此若未会，可谓为迷情可覆，便去离不得。迷时即有窒碍，为对为待，种种不同，忽然惺去，亦无所得，譬如演若达多认影迷头，岂不担头觅头！然正迷之时，头且不失。乃乎悟去，亦不为得。何以故？人迷谓之失，人悟谓之得。得失在于人，何关于动静？”他主张莫思量，离动静，迷时人不失，悟时也无所得。演若达多以镜照面，见镜中影像眉目清秀而喜，想返观已头之眉目而不可得，遂大怒，以为是妖摩作怪而狂走。那种妄取幻境为真性却忘却真性的做法，正是认影迷头的迷悟的表现。
    （十一）金陵文遂离言句
    金陵文遂导师（９１５－９９０），杭州陆氏子，尝究《首楞严》，甄会真妄缘起，本末精博，并加注释，后谒法眼禅师，师令焚其注文，从此服膺法眼，始忘知解。初住吉州止观院，迁长庆、清凉、报慈诸寺，金陵国主署雷音觉海大导师。上堂曰：“天人群生类，皆承此恩力，对根设教，便有如此如彼，流出无穷。若能依而奉行，有何不可。所以清凉先师道：佛是无事人。且如今觅个无事人也不可得。”可知文遂服膺文益，主张离言句，作个无事人。而不少人随于是非之中，分彼此，究高低，如何能得清净自在！
    其法嗣有齐云慧、双岭祥、观音真、龙沙茂、大宁奖等。
    （十二）守仁“无汝着眼处”
    罗汉守仁禅师（？－９５８），泉州人。初住本郡东安兴教寺上方院，后迁漳州罗汉院。后迁漳州罗汉院。世称罗汉仁。上堂：“只据如今，谁欠谁剩？然虽如此，犹是第二义门。上座若明达得去也，且是一是二，更须子细看。”僧众晚参，师曰：“物物本来无处所，一轮明月印心池。”便归方丈。后住报恩，上堂，僧问：“如何是报恩家风？”师曰：“无汝着眼处。”问僧：“什么处来？”曰：“福州来。”师曰：“跋涉如许多山岭，阿那个是上座自己？”亦主张佛法一切现成，无余无欠，修行无着眼无，根本在认取自家本来面目。其徒有龙潭从晓。
    （十三）智筠“直下眼明始得”
    净德智筠达观禅师（９０６－９６９），河中府（山西水济）王氏子。初住庐山栖贤寺，上堂：“从上诸圣方便门不少，大抵只要诸仁者有个见处。然虽未见，且不参差一丝发许，诸仁者亦未尝违背一丝发许。何以故？炟赫地显露，如今便会取，更不费一毫气力。还省要么？设道毗户有师，法身有主，斯乃抑扬，对机施设，诸仁者作么生会对底道理？若也会，且莫嫌他佛语，莫重祖师，直下是自己眼明始得。”李后主于金陵北苑创净德道场，延师居之，署达观禅师。上堂，“夫欲慕道，也须上上机器始得。造次中下，不易承当。何以故？佛法非心意识境界。……所以诸佛赞叹，赞叹不及比喻，比喻不及道。上座威光赫变，亘古亘今，幸有如是家风，何不绍续取，为什么自生卑劣，枉受辛勤，不能晓悟？只为如此，所以诸佛出兴于世；只为如此，所以诸佛唱入涅盘；只为如此，所以祖师特地西来。”后屡辞归故山，国主赐以五峰栖玄蘭若。
    智筠似乎排斥“佛语”、“祖师”，强调自己眼明始得，其实是如同惠能“自归依三宝”一样，把佛、众生、自性统一在一起的。他虽然强调上根利器始能顿悟。“造次中下不易承当”，但“不易”，并不是不可能。因此既倡当下即是，又对机施设，方便接引众人。这是可取的。
    （十四）宝塔的绍岩重明心
    宝塔绍岩禅师（８９９－９７１），雍州刘氏子，吴越王命师开法，署了空大智常照禅师，常欲舍身弘法，每谋自焚，不许；投水又得救，不死。上堂：“山僧素寡知见，本期闲放，念经待死，岂谓今日大王勤重，苦勉公僧，效诸方宿德，施张法筵。然大王致请，也只图诸仁者明心，此外别无道理。诸仁者还明心也未？莫不是语言谭笑时，凝然杜默时，参寻知识时，道畔商略时，观山玩水时，耳目绝对时，是汝心否？如上所解，尽为魔魅所摄，岂曰明心？更有一类人，离身中妄想外，别认遍十方世界，含日月，包太虚，谓是本来真心，斯亦外道所计，非明心也。诸仁者要会么？心无是者，亦无不是者，汝拟执认，其可得乎？”开宝四年（９７１）七月示病，谓门弟子曰：“诸行无常，即常住相。”言讫跏趺而逝。
    绍岩对明心有深刻的论述，明心即心中不存妄想，亦不执偏十方世界为平等真心。心无是、无不是，不可执着，即谓明心。
    （十五）策真“觉知只一度”
    归宗策真禅师（９０５－９７９），曹州魏氏子也。初名慧真，谒法眼，言下悟入。住后，上堂：“诸上座，见闻觉知，只可一度，只如会了是见闻觉知，不是见闻觉知要会么。与诸上座说破了也，待汝悟始得。久立，珍重！”僧问：“承教有言，将此深心奉尘刹，是则名为报佛恩，尘刹则不问，如何是报佛恩？”师曰：“汝若是，则报佛恩。”
    策真之“见闻觉知，只可一度”，也许即灵云志勤禅师“一见桃花悟道”之旨吧！明末清初思想家王夫之曾批评释氏“见闻觉知只可一度”是认识一次完成论。然而，策真“会了”是“见闻觉知，”是说顿悟是一刹那间的事，但并不排斥平时通过多次是闻觉知而渐修，并没有把顿悟与渐修对立起来。


三、延寿振宗风

三、延寿振宗风

    永明延寿禅师（９０５－９７５），字仲玄，号抱一子，余杭王氏子。总角之岁，归心佛乘，既冠，不茹荤，日惟一食。持《法华经》，七行俱下，二十八岁为华亭镇将，一日乘舟归钱塘，见渔船之万尾戢戢，恻然以钱易之，放生入江中。吴越文穆王知师慕道，乃从其志，礼翠岩令岑为师，行清苦头陀。寻往天台山天柱峰，九旬习定，暨谒德韶国师，一见而深器之，密授玄旨。初开法雪窦，上堂，有偈曰：“孤猿叶落中岩月，野客吟残半夜灯。此境此时谁得意？白云深处坐禅僧。”宋太祖建隆元年（９６０）吴越忠懿王请开山灵隐新寺，为第一世，明年迁永明大道场（杭州净慈）为第二世，众盈二千人。僧问永明妙旨，答曰：“欲识永明旨，门前一湖水。日照光明生，风来波浪起。”居永明十五年，度弟子一千七百人。开宝七年（９７４）入天台山度戒约万余人。常为七众授菩萨戒，夜施食鬼神。六时散花行道，余力念《法华经》，计一万三千部，著《宗镜录》一百卷，诗偈赋咏凡千万言，播于海外。高丽国光宗大成王览师言教，遣使赍书，叙弟子之礼。该国僧三十六人，皆承印记，前后归本国，各化一方，于是，法眼一宗，行于海外。开宝八年（９７５）十二月卒，塔于大慈山。
    永明延寿，被清世宗《御前万善同归集》称为六祖心后“古今第一大善知识也。”忽滑谷快天说延寿为“禅道烂熟时代之代表者，”他们的评价确实很高，综观《宗镜录》、《万善同归集》，此说确有道理，延寿之禅风，不仅继承了六祖慧能、圭峰宗密、清凉文益、天台德韶之优良传统、而且有所发展，其突出特点是：会通禅教、融入净密，综合折衷，会相归性。
    （一）会通禅教
    延寿折衷法相、三论、华严、天台、净土、密宗，以融合于禅。慧日永明寺《智觉禅师自行录》载：延寿每日每夜作１０８件佛事，如受持神咒、念佛净业、礼佛、忏悔、行道、诵经、以及坐禅、说法等，其中坐禅、说法或被置于不太重要之地位，而对持咒、念佛尤为重视。《万善同归集》说明延寿一身而兼念佛、持咒、修禅等。他说：
    夫万善是菩萨入圣之资粮，众行乃诸佛助道之阶渐……《法华》会三归一。万善悉向菩提，大品一切无二，众行咸归种智。……《目莲所问经》云：我说无量寿佛国，易往易取，而人不能修行往生，反事九十六种邪道，我说是人名无眼人，名无耳人。《大集月藏经》云：……当今末法，现是五浊恶世，惟有净土一门，可通入路，当知自行难圆，他力易就。……兹旨叮咛，须铭肌骨。
    延寿集方等秘经六十部，西天东上圣贤语三百家，以佐贤首、慈恩三宗之义，成《宗镜录》一百卷，但禅教结合。其理论根据，即圆修十义：一、理事无阂；二、权实双行；三、二谛并陈；四、性相融即；五、体用自在；六、空有相成；七、正助兼修；八、同异一际；九、修性不二；十、因果无并。其根本乃在《大乘起信论》所倡之心法，他著《惟心诀》说：“千金异说，随顺机宜，无不指归一法而已。故《般若》惟言无二，《法华》但说一乘，《思益》平等如如，《华严》纯真法界，《圆觉》建立一切，《楞严》包里十方，《大集》染净融通。《宝积》根尘泯合，《涅盘》咸安秘藏，《净名》无非道场。……是以一法千名，应缘立足，”了此一心，即能知佛心，即能知祖意。延寿说：“此一心法，理事圆备，是大悲父、般若母、法宝藏、万行原。……是以若了自心，顿成佛慧，可谓汇百川为一湿，搏众尘为一丸，融钚钏为一金，变酥酪为一味，如《华严经》颂云：不能了自心，焉能知佛慧？”
    他还论大乘各主要经典，皆说一心，如释《妙法莲华经》经题曰：绝待真心称妙，莲华出水无著，心性随流，堕凡而不染垢，返流出尘为华而不著净；释《大方广华严经》：大方广是一心所证之法，佛华严是一心能证之人，摄所归能，人法冥合，皆是一心；释《维摩经》曰：净名，即是一切众生自性清净心，此心弗澄而自清，弗磨而自莹，处凡而不垢，在圣而不净，故云自性清净，云名，即心无形，但有名故；释《金刚般若波罗蜜经》者，即是本心不动，喻若金刚，般若真智乃灵台妙性，达此而即到涅盘彼岸，昧此则住生列迷津。这样，他就以一心而贯穿诸经，会通诸经。
    （二）会相归性
    《宗镜录》融会性相，会相归性。问：此《宗镜录》何教所摄？答：“真惟识性，理无偏圆，约见不同，略分五教。一、小乘教，惟说六识，不知第八赖耶。二、初教，说有赖耶生灭，亦不言有如来藏。三、终教，有如来教，生灭、不生灭和合为赖耶识。四、顿教，总无六、七、八识等，何以故？以一心真实，从本已来无有动念，体用无二，是故无有妄法可显。五、一乘圆教，说普贤圆明之智，不言惟识次第，又言佛学三界虚伪，惟一心作，亦摄入故。此宗则圆教所摄，乃是如来所说法门之根本，以如来依此心成佛故。”
    （三）针砭时弊
    针对禅宗纯熟时代的一些弊端，永明延寿对于教内之弊端力加抨击，他说：“近代或有滥参禅门不得旨者，相承不信即心即佛之方，判为是教乘所说，未得幽玄，我自有宗门向上事在，惟重非心非佛之说。并是指尘为马，期悟遭迷，执影是真，以病为法，只要门风紧峻，问答尖新，发狂慧而守痴禅，迷方便而违宗旨，立格量而据道理，犹入假之金，存现矩而定边隅，如添水之乳。”这与清凉文益《宗门十规》一样，是关系禅宗前途命运之重要著作。
    （四）语录之纂集
    延寿《宗镜录》录有禅宗四祖、五祖、青原行思等人之语录，为他书所不载，虽不可尽信，但可作参考。如记四祖语录曰：“第四祖道信大师云：夫欲识心定者，正坐者知坐，是心知有妄起，是心知无妄起，是心知无内外，是心理尽归心。心既清净，净即本性，内外惟一心，是智慧明了，无动心，名自性定，”又收弘忍之言曰：“第五祖弘忍大师云：欲知法要，心是十二部经之根本，惟有一乘法，一乘者一心是，但守一心，即心真如门。一切法门，不出自心，惟心自知，心无形色，诸祖只是以心传心，达者即可，更无别法。又云一切由心，邪正在已，不思一物，即是本心，惟智能知，更无别行。”大体均以不动心为清净本性，心真如门即守本心，忽滑谷快天认为此与六祖之旨符合。
    又记青原行思之法语说：“吉州思和尚云：即今语言，即是汝心，此心是佛，是实相法身佛。《经》云有三阿僧只百千名号，随世界应处立名。……若入三昧门，无不是三昧，若入无相门，总是无相。随立之处，尽得宗门，语言啼笑，屈伸俯仰，各从性海所发，故得宗名，相好之佛是因果佛，即实相佛。《家用经》云：三十二相八十种好，皆从心想出。亦元法性家焰。又云法性功勋，随其心净即佛士净，诸念若生，随念得果，应物而现，谓之如来。随应而去，故无所求，一切时中更无一法可行，自是得法，不以得更得，是以法不知法，法不闻法，平等即佛，佛即平等，不以平等更行平等，故云独一无伴，迷时迷于悟，悟时悟于迷，迷还自迷，悟还自性，无有一法不从心生，无有一法不坐心灭，是以迷悟总有一心。”
    这些法语亦他书所不载，可资参考。
    （五）延寿之失误
    延寿对于融通经教、调和折衰确实在禅宗史上立下不可磨灭的功勋。但其书间或亦有违背历史事实者，如说宝志识菩提达摩“是传佛心印观音圣人”。还引《起世界经》等伪经言说：“佛言我遣二圣者，往震旦行化，一者老子，是迦叶菩萨，二者孔子，是儒童菩萨。”这说明他在引证中亦有失考、违背事实之处，尽管如此，永明延寿在法眼宗、禅宗乃至中国佛教史上的重大贡献，仍是不可低估的。
    延寿的传法弟子有富阳子蒙、乾明院津，详情待考。
    法眼宗于宋初极盛，传至四五代后（前后不过百年），在中土即渐衰，然而在高丽却仍兴盛不衰，文益禅风兴于一时，以天台德韶门庭最荣，以永明延寿为首，有长寿明彦、五云志逢，报恩永安、光庆遇安、齐云遇臻等百余人，高丽王派来求法僧也很多，得法者有三十六人，此宗遂流布海东。文益、延寿、希辩门下都有高丽国弟子，他们是慧炬、灵鉴、智宗（圆空国师）、慧洪等，慧炬学成回国，被封为国师；智宗（９３０－１０８１）投永明延寿习禅，又拜天台宗净光大师义寂，受天台教旨，回国四十九年，历五期，均受殊礼，是高丽前期禅教双弘一高僧。《宗镜录》、《宗门十规论》均在朝鲜流传，可见法眼宗流传之盛。因此，法眼宗虽然与沩仰宗一样，流布时间短促，五世而斩，而法眼宗“墙内开花墙外红”，毕竟命运比沩仰宗好得多，法不孤起，随缘而生，信不虚也。


一、三代催生

第十一章

    一、三代催生

    从中国禅宗在精神文化领域举世公认的特行独立品格而言，可以把曹洞宗与其它几个宗派，称作“思想界的贵族”（真正的思想者）。这个“思想界的贵族”之所以能够成立，因缘当然不一而足，但其中最主要的原因是：以石头希迁、药山惟俨和云岩昙晟为代表的三代禅者，代代相续，直接地培育、养成了曹洞宗的思想来源和宗风底蕴，曹洞宗就是以上三代禅思想家一以贯之培养催生的结晶。
    在曹洞宗正式创立前夕，即公元九世纪下半叶（以良价和本寂二位创立者活动年代计）之前，中国佛教刚完成了一场前无古人的深刻革命——就是禅宗“南宗”的兴起和发展，这场革新运动，由慧能肇其端，当属确凿无疑，但是，严格地说来，“南宗”在历史上争取到其主流地位，特别是在思想义理上完善成熟、得以巩固其根基，却是在慧能之后，亦即由公元八世纪初叶开始的百余年间——这段艰苦卓绝又精彩纷呈的历程，为时一百五十年左右，胡适之曾这样描摹过这一段激动人心的历史：“从公元７００年至８５０年，在这一百多年中，包括盛唐和中唐、是禅宗极盛的时期，这在中国佛教中是一个大的运动，是佛教内部革新的运动。”他认为，这在于使佛教真正开始了中国化和简易化的历程。他在自己的论著中多次强调“公元７００－８５０年的佛教革命，”给予极高的评价。胡适之这一观点基本上是符合历史事实的，即以神会为杰出代表的南宗禅师，直接承继了慧能革新的成果，高举“顿门”嫡传的旗帜，为南宗成功地争取到了禅宗正统法系的地位，从而也就为佛教真正中国化开辟了广阔的前景。从此，由师说徒受，“言下悟道”，或者弟子将心得呈师印可从而悟得，便成了“顿悟”的主要形式，并沿袭下来。有的论者据此认为神会是南宗的实际创始者，帝一论点可以商榷，因为从思想渊源上看，神会之主张“顿悟”和“无念”，直接地源自慧能，上述推论显然与基本史实不符。
    公元７００年，神会前往岭南依慧能为师，恰巧也是这一年，石头希迁诞生了，这真是一种不可思议的奇特因缘：南宗禅的开路先峰神会接续慧能法脉在前，慧能法孙石头希迁诞生于后，前者即将在公元八世纪前半叶来上演为南宗摇旗呐喊、闯关夺隘、终成正果的雄壮活剧，而后者则注定会于世世纪后半叶，静处南国大荒山作世外凝思默想，为“五家七宗”中之三家南宗子孙开掘思想之正源，说公元７００年是南宗禅的一个逻辑和历史的起点，就没有什么过份之处了。如果我们再将视野扩大一点，就会发现禅宗群星灿烂照耀千秋的星座，正是以公元７００年为绝妙的坐标原点的，从慧能大师（６３８－７１３）始，有青原行思（？－７４０）、南岳怀让（６７７－７４４）、荷泽神会（６８６－７６０）、永嘉玄觉（６７５－７１３）、南阳慧忠（６９０－７７５）为第一代法子，更遑论马祖道一（７０９－７８８）、石头希迁（７００－７９０）以下了。中国禅宗第一度群星灿烂，神宗“五家七宗”莫不发源于此一奇特时空。
    对于曹洞宗，从整体上看，这一时期无疑是培元固本、先天养成的最佳年代，而在其中，石头希迁则是其思想的确凿源头所在。
    石头希迁，少年即在慧能大师门下得度为沙弥，按理本当成为直承大师的法子辈，惜年方十四岁，大师入灭，无所依傍。经历一番求索后，终于在青原行思处得到开悟，与行思遂由师兄弟一度而成师徒之辈，并得到另外一位“大师兄”南岳怀让的砥砺。石头希迁如此丰富而奇特的经历，可谓尽得慧能及行思、怀让两代南宗鼻祖之心要。事实上，石头本人就直截了当地宣称过这种再亲切不过的心灵意会关系，他初次谒见青原行思的机锋问答便是：
    师问曰：“子何方而来？”迁曰：“曹溪。”师曰：“将得什么来？”迁答：“未到曹溪亦不失。”师曰：“恁么用去曹溪作什么？”迁答：“若不到曹溪，怎知不失。”
    作为承上启下、继往开来的南宗禅思想大家，石头希迁的思想成熟、圆融，是在他中年以后由江西吉州青原山（在今江西吉安）迁往湖南南岳的时期，亦即公元八世纪的后期，他在南岳度过了后半生近半个世纪的时光。虽然僻处一隅，但是终其一生都保持了沉郁孤高、好学深思的隐者气蕴，十分注意广泛吸收前贤今人的思想资料，其中既有佛门别家非南宗、非禅宗的成份，如流行中原和江左的华严、牛头诸家，也包括道家和道教这样的外典之学。既有对当时思想界的积极回应，也显见追踪前贤、直溯历史深处的高古气质，以上诸多因缘造就了千古一石头，以致宗密在《禅源诸诠集都序》里半石头与牛头二宗并禅，同归于“泯绝无寄宗”；石头毕生结晶“回互不回互”之说，亦直接受华严宗十玄缘起以及六祖圆融思想的影响。至于说到追踪前贤，则石头读僧肇《肇论》而豁然受启发（事见《祖堂集》），就更是一个明证。应当强调的是：在公元八世纪后半期，亦即慧能以下第二代南宗禅师群体之中，石头希迁是独一无二的，这种独特性就在于：注重多方面的思想义理之间调和融会，始终涵养着一种善于兼收并蓄、长于理认整合，而稍拙于实践以及自我宣传的整体气质，而这一点，正是由马祖道一洪州宗所煽起的后期南宗禅中，所仅有的“孤例”，也就是说，在当时逐渐兴起的南宗禅那种如火如茶的呵佛骂祖氛围中，惟有石头希迁保持冷静超越的风度，对于南宗禅内外，佛门内外的各种思想养料进行着自觉的摄取，实际上恰好弥补了马祖一系单兵独进、孤军深入从而锐气有余、后劲不足之弊端，使南宗禅得以在宽阔和深刻的层面上进一步发展成为可能。
    作为石头希迁的思想的结晶，其《参同契》从形式到内容堪可注意，在形式上，此文充满与道家和玄学亲切融通的气息。题目直接采之于被道教奉为“丹经王”的《周易参同契》，综观全篇，完全不说佛，不言禅，通篇却参玄论道，以“竺土大仙心”起首，以“谨白参玄人”作结，这不止在当时，就是前后历史中也属罕见，乃至印顺法师也认为，直截了当地“把禅学看作玄学，称参禅为‘参玄’似乎石头是第一人。”这与其说是石头希迁对于道家的偏爱，勿宁说体现了他对于举世滔滔狂禅潮流所热衷的南北之争、只知谈禅而完全忽视文化传承和整合这一弊端的独特态度。“回互不回互”也好，“参同”也好，实际上都是一个中心思想：即要让修禅者深刻领会万事万物之间互不相犯、各住自性同时又相入相涉、无所分别的圆融不二关系，这当然也包括对于佛教不同宗派思想所应持的态度在内。在文中，他明确地说“人根有利钝，道无南北祖”，“承言须会宗，勿自立规矩”。这既可理解为具体针对当时南北宗之争，更可以理解为石头对于马祖一系“激进派”的深重忧虑；石头本人当然是禅宗南宗这场革命的积极参与者，但对于“自立规矩”、向超越佛祖乃至呵佛骂祖的方向急剧发展这一潮流，对于当时正在普遍蔓延起来的完全否定看经坐禅的炽热倾向，这位时代的主要精神导师，充满忧虑和不安。在这里，所谓“回互”学说不仅仅是一种理论，更是这位大智者“满天风雨下西栖”的俯首沉思，是他向那个到处充满骚动不安、急欲冲决一切罗纲樊篱的大时代所发出的警示：世界是“回互”的，思想与文化同样是“回互”的——他向禅门同修者门提示着一种重视不同系统、不同层面的文他相关联系，亦即注重思想文化的继承整合，注重内在的自我规约和必要秩序的大方向。
    曹洞宗恰恰是朝着这个方向产生和发展的。
    石头与马祖两位同时代的禅宗巨匠，便是在这个歧路上分别的。也许石头这位内向的、喜欢静默的思考者根本就不善于对别人品头评足。而机警俏皮的马祖，却留下了一句十分见才气因而也十分生动的评语：“石头路滑”。何谓“路滑？”路不滑人，人自滑。人何以会滑？石头《参同契》有言：“明暗各相对，比如前后步。”人之脚步前后如此“回互”，岂有不滑之理。当然，这只是马祖的批语。石头则完全是另一番道理：“触目不会道，运足马知路。进步非近远，迷隔山河固。”山川满目而不识前路，抬脚又能迈到哪里去？如此执迷不悟，又岂可以激进与否作标准来论是否真正有所进步？为令学人会得“回互”之深意，石头在《参同契》中运用子母、根叶、本末、尊卑、明暗、用处等比喻，反复说明事物互相关系、互相奇待，其苦口婆心，真似道家《老子》之“道”。
    石头的路，注定了悠远而绵长，端赖其“回互”理念无穷深厚内力之赐。这也就是曹洞宗虽然绝少临济宗之开大合、大红大紫，但却绵泽不尽、气力不竭的内因：“回互”者，生生不息，生机无限，这是与马祖一系截然别样的另一种生机。后者（从洪州宗始）入手于“即心是佛”，而历经“非心非佛”，最后拈出“平常心是道”，犹如提携利剑一柄，在一系列打、蹋、喝、骂的刀光剑影中，如迅雷不及掩耳，单刀直取人“心”。这是南宗禅在“顿悟”方向上的极致，如此活生生地逼人忽然省悟，释放出无限盎然生意来。而石头则在“回互”之中强调多方整合，三分迂回，一片蕴绵，如此一路的“生机”自然来得醇厚绵实。应该说，如此运作之分别，总是后世所谓“临济将军、曹洞士民”之喻的最初底蕴，是“临天下、曹一角”这一势力范围差别的内在由来。
    如果说，石头希迁因为开辟“回互”之路而为这一路上之肇始者，则药山惟俨因一肩担荷石头家业、在禅宗内部继续标举注重思想传承与文化整合之旗帜而成为第二代传人。
    药山惟俨（７５１－８３４）俗姓韩，绛州（今山西新峰）人。年１７依潮州西山慧照禅师出家，２３岁戒于衡岳希操（又作希琛）律师。值此少壮少年，因为痛感“大丈夫当离法自净，马能屑屑事细行于布巾耶？”而径直“谒石头，密领玄旨”，这是《宋高僧传》及《景德传灯录》、《祖堂集》一以贯之的说法，而另一份史料则明言其为马祖道一弟子。其实，当石头与马祖并立于世之际，天下禅僧往来二大师门下者，不知凡几。在这种情况下，所谓门徒与否，最重要的证据，还得审视其思想文化递嬗之迹。
    药山之直承石头，其最为亲切的会意，堪举其读经坐禅。贞元初（７８５）他离开石头，迁居汗阳（今湖南津市市）药山，居此近５０年，一如乃师石头之恒居衡岳，为世外高人隐士，惟看《法华》、《华严》、《涅盘》等经，昼夜如一。不但看经，而且在从石头门下时起就坚持坐禅：
    一日，师坐次，石头睹之，问曰：“汝在这里作么？”曰：“一切不为。”石头曰：“恁么即闲坐也。”曰：“若闲坐即为也。”石头曰：“汝道不为，且不为个什么？”曰：“千圣亦不识”。
    师坐次，有僧问：“兀兀地思量什么？”师曰：“思量个不思量底。”曰：“不思量底如何量？”师曰：“非思量。”
    如果我们环顾８世纪后半叶南宗禅的主流局面——马祖道一开创的洪州宗烽火几乎燃遍南国，其直指“平常心”，极力否认看经坐禅而代之以打、蹋、喝、骂、画的倾向已成为一时主流，流布天下，那么，药山惟俨如此坚持看经坐禅，相形之下，实别具深意，这并非刻意反潮流之为，而是石头系思想发展的必然结果。石头之注重“回互”传承整合的融会特色，在药山惟俨这里显然开始产生了实际效用。其直接的体证有二：从大处和远处说，重视读经意味着与佛言祖语传统经教时刻保持紧密联系，亦即坚持对于佛祖传了的承继一面；从小处和近处说，如此看经坐禅，完全不避堕入“知解之徒”的风险，则又直通荷泽神会的特色，亦即表现出与当代其它流派坦然整合的鲜明倾向。以上两者是相通的，既然坚持看经坐禅，那就是因为重视知见知解；既然要以知见为门径，那就必须看经，迁要坐禅，这也正是药山当初直诣石头，作大丈夫行的誓愿之成吧！
    当然，药山惟俨所谓“看经坐禅”，自是不可与凡等论。作为曹溪门下，从荷泽到洪州到石头，乃至石头门下，高标“行住坐卧皆是禅”，鄙视“以坐为坐禅”，这是并无二致的。甚至明确地指出看读经论为障道之因缘，还是药山惟俨首先发明的，《景德传灯录》记载：
    师看经，有僧问：“和尚寻常不许人看经，为什么都自看？”师云：“我只图遮眼。”云：“某甲学和尚得也无？”师云：“若是汝，牛皮也须看透。”
    师又云：“有一般底，只向纸背上，记持言语，多被经论惑，我不曾看经论策子。”
    （李）翱谢问曰：“何谓道耶？”俨以手指上下曰：“会么？”翱曰：“不会。”俨曰：“云在青天水在瓶。”
    “云在青天水在瓶”的见地境界当然只有极少数上根利器者能获致，对这类人来说，广学博闻悟后任运又何妨？而对“一般底”人而言，乃至根微智劣者，自然是不许被经论惑了。
    但是，在普遍地不看经、不坐禅风气蔓延开来的８世纪末叶，无论如何，坚持看经坐禅的人，不能免其孤独的心志和命运。药山在沉郁孤高的家风上，比之乃师石头更为浓重。
    僧问：“如何是道中至宝？”师云：“菲谄曲。”云：“不谄曲时如何？”师云：“倾国莫换。”
    师曰：“太守（指李翱——引者注）欲得保任此事，直须向高高山顶立、深深海底行……”他翱再赠诗曰：“选得幽居惬野情，终年无送亦迎。有时直上孤峰顶，月下披云笑一声。”
    “倾国莫换”，“高高山顶立，深深海底行”，都是药山惟俨孤高心志的“夫子自道”，孤峰顶上“月下披云笑一声”则更是其真实写照。
    事实上，石头宗系的命运在当世也远未达到后来人所称颂的显赫，虽然直到九世纪前期总有石头、马祖并称“二大士”之说，但是从总体上看，在７００－８５０年这个时期，亦即石头希迁诞生，直至唐武宗“会是法难”之前，石头宗系的影响是无法与马祖道一洪州宗比拟的，这与石头希迁、药山惟俨孤高出世的思想家品格无疑是大有关系的。
    这在石头系第三代传人那里体现尤为明显。
    当洪州一系作为禅宗主流蔚然成为“天下选佛场”而成为佛子往慕之门时，石头一系的地理透移也有悄然发生：从衡岳到药山，再到“沣泊深邃绝人烟处，”石头系前后三代局促湖南境内，由东而西再而西北，竟然次第移往深山更深处，越来越远离人世，这当然不是什么怯世避世，而是非高僧禅匠大思想家不能办之大业。这第三代即药山惟俨门下的华亭德诚、道悟圆智和云岩昙晟。药山入灭之后，师兄弟三人同议，打算持必要的种粮家什，下山溯沣水而上，直达湖南境内有名大河的源头，养道过生。（因为种种因缘，这个梦想想实际上是非曲直到了德诚弟子会善，总告完成。）
    云岩野晟（７８２－８４１）之所以在同门之中越越众人，成为药山惟俨法嗣之中声名独著者，就在于其浓厚的思想家色彩和独特思想成果。他本来在百丈怀海门下，为侍者长达二十年之久，守着这样一位洪州宗最为显要的大师，却认为自己仍未契入，于是就在侍奉百丈尽其天年之后，离开江西“选佛场”，从繁华极盛的南宗禅中心圈，径直来到冷落幽远的湖南药山“孤峰顶上”，投惟俨门下，顿告言下契会。此时已值九世纪初期（百丈怀海卒于８１４年），是一个禅宗南宗革命成功、需要自己的比较成熟的思想家的时代，江湖之间参禅路上不知多少行脚禅得往来憧憧，其中非有上乘法门、独到见地者不能言继往开来卓然成家。昙晟正是这样一位特出人俊。作为晚到却能成功地契入石头宗系的最有力印证，这位禅思想家举出自己的“宝镜三昧”法门——这就不但得到药山惟俨心印，而且竟直追乃祖石头希迁。石头希迁《参同契》道“即事而真”之理云：“事存函盖合，理应箭锋柱。”由洞山良价转述昙晟心义《宝镜三昧》词云：“羿以巧力，射中百步，箭锋相直，巧力何予？”均谓以事相上而显见理体，犹如盖与盒、箭与的、触目见道，自然契合，而昙晟理会石头希迁之亲切会意处，透过一派晦涩支离的名相，依然可观。此中若无药山惟俨之薰育，若无看经坐禅、对照经教，而假设依旧在洪州宗“选佛场”中一味否定看经师古，昙晟哪能举出此种法门来？如果说，药山惟俨是以其坚持看经坐禅的独到方式，为石头宗系保存了“回存”理论的星火，那么远来的和尚昙晟则拨亮和点燃了星星之火——他在《宝镜三昧》法门中明确首倡“偏正回互”说。由石头希迁而药山惟俨而云岩昙晟，三代禅师的思想历程，如同他们经历的湖南地理路线，青山隐隐，绿水迢迢，在一派禅语机锋的掩盖下，哲理时而晓畅明白，时而幽暗迷离，山重水复，但是至此，昙晟拈出“偏正回互”说，豁然之间，柳暗花明，瓜熟蒂落。
    “偏正回互”正是曹洞宗的根本宗旨。宗旨既立，宗派成立的年代也就到来了。


二、曹洞开宗

二、曹洞开宗

    公元九世纪随后的一两个世纪禅宗全面鼎盛，与西方“黑暗的神学中世纪”相比，中国的这个宗教鼎盛的中世纪，情况完全不一样，中国连续数世纪禅僧之中代代涌现的智慧群星却震烁今古。
    其原因固然很多，但若论从其代表性人物心态着眼，了解其最初动因，直叩心灵的源头，曹洞宗的正式创立者洞山良价，在这方面提供了一个绝佳的叩问门径。
    洞山良价（８０７－８６９），会稽诸暨（在今浙江）人，俗姓俞。先从马祖道一的弟子五泄灵默披剃，二十一岁时前往嵩山受戒。此后参学于多位著名禅师门下，例如南泉普愿、沩山灵祐等，最后在云岩昙晟门下悟入。“会昌法难”，他正值思想成熟的壮年，开山授徒。唐宣宗大中末（８５９），先居亲丰山，后转豫章高安（在今江西）洞山，聚众数百，遂为重镇，传法弟子有曹山本寂、云居道膺等二十六人。传世有《宝镜三昧歌》、《玄中铭》、《新丰吟》、《五位君臣颂》、《五位显诀》和《纲要偈》，并有语录二卷。后人所谓“曹洞宗”一名，即以洞山良价为轴心，上联曹溪，或下续其弟子曹山本寂，合称“曹洞”。
    洞山良价最初出家为僧时，写有一封《辞北堂书》给家中高堂，叙述其出家的思想动因。文字简练而饱含深情：
    “伏闻诸佛出世，皆从父母而受身，万汇兴生，尽假天地而覆载，故非父母而不生，无天地而不长，尽沾养痛之恩，俱受覆载之德。嗟夫！一切含识，万象形仪，皆属无常，未离生灭，虽则乳哺情至，养育恩深，若把世赂供资，终难报答，作血食侍养，安得久长。故《孝经》云：‘虽日用三牲之养，犹不孝也。’相牵沈滑，永不轮回。欲报罔极深恩，莫若出家功德，截生死之爱河，越烦恼之苦海，报千生之父母，答万劫之慈亲，三有四恩无不报也。故《经》云：‘一子出家，发族生天。’”
    以上这段话，既反映了良价在出家之前所接受的儒家教育素养，也体现了汉魏以来数百年间佛教对于中国人的潜移默化之功。即以孝亲为例，中世纪的中国人拥有如此多元的选择，如良价这样的人既承认和崇尚儒家“天覆地载”的一套教诲，又认识到存在着更高着眼的佛理——这种选择既是理性的、智慧的、又饱含着感性的、感情的因子，既是痛苦的，又充满着圆融的喜悦，全都是发自内心的，而无任何外在的强迫性，良价是这样表明他的选择的：
    “良价舍今世之身命，誓不还家，将永劫之根尘，顿明般若。伏惟父母心开喜舍，意莫攀缘，学净饭之国王，效摩耶之圣后，他时异日，佛会相逢，此日今时，且相离别，良非遽达甘旨，盖时不待之，故云：此身不向今生度，更向何时度此身，伏冀尊怀，莫相记忆！”
    书犹不足，作颂二首更以明志：
    “未了心源度数春，翻嗟浮世谩逡巡。几人得道空门里，独我淹留在世尘。谨具尺书辞眷爱，愿明大法报慈亲。不须洒泪频相忆，譬似当初无我身。”
    “岩下白云常作伴，峰前碧障以为邻。免干世上名与利，永别人间爱与憎。祖意直教言下晓，玄微须透句中真，合门亲戚要相见，直待当来证果因。”
    十年之后，良价已是一个参学四方，阅历甚广的得道高僧。回望来路，感慨良多，他再修书一封，告白母亲：
    “良价自离甘旨，杖锡南游，星霜已换于十秋，歧路俄经于万里。伏惟娘子收心慕道，摄意归空。休怀离别之情，莫作倚门之望。家中家事，但且随时，转有转多，日增烦恼，阿兄勤行教顺，须求冰里之鱼，小弟竭力奉承，亦泣霜中之笋，夫人居世上，修已行孝，以合天心，僧有空门，慕道参禅，而报慈德。今则千山万水，沓隔二途，一纸八行，聊伸寸意。”
    洞山良价母亲的回信，亦足以道明鼎盛年代母亲对于出家儿子的认识与心态：
    “吾与汝夙有因缘，始结母子恩爱情分，自从怀孕，祷神佛：愿生男儿，胞胎月满，性命丝悬。得遂愿心，如珠宝惜。粪秽不嫌于臭恶，乳哺不倦于辛勤，稍自成人，遂令习学。或暂逾时不归，便作倚门之望。来书坚要出家，父亡母老，兄薄弟寒，吾何依赖？子有抛娘之意，娘无舍子之心。一自汝住他方，日夜常洒悲泪。苦哉苦哉！今既誓不还乡，即得从汝志。不敢望汝如王祥卧冰、丁兰刻木，但如目莲尊者，度我下脱沉沦，上登佛果。如其不然，幽谴有在，切宜体悉。”
    一部中国佛教包括禅宗史，若将以上历史材料视之为题外赘余而弃之不顾，则不免面目苍白甚至可憎。比之以下要叙述到的抽象得多的洞山哲学思想，上述富含感性通俗易懂的文字，说明一个非常重要的事实，这就是：在整个佛教特别是禅宗鼎盛的年代，任何一宗一派之所以能够发达与鼎盛起来，其最初的动因，无不缘于社会与论的宽容、个体的理性自觉，选择是多元的——既可学王祥卧冰，更可效目莲救母，既可入世，更可出世。如此文化氛围与理性自觉选择之下成长发达起来的宗教，岂可与“愚昧和黑暗的守护神”同日而语！
    洞山良价如此智悲兼运的突出个性，不能不深刻地影响到他的云水生涯，他最初接触到乃师昙晟门下，就是从参“无情说法”一案而开始悟入的：
    “既到云岩，问：‘无情说法，什么人得闻？’云岩曰：‘无情说法，无情得闻。’师曰：‘和尚闻否？’云岩曰：”我若闻，汝即不得闻吾说法也，’曰：‘若恁么，即良价不闻和尚说法也。’
云岩曰：‘我说汝尚不闻，何况无情说法也。’”
    石头宗系长于吸收融会诸宗的特点，在这里又一次充分显露出来，其关注形而上的本体论思想家特质更为浓重，洞山良价在此即紧接着向云岩呈上一偈，表明自己的强烈兴味：
    “也大奇，也大奇，无情解说不思义。若将耳听声不现，眼处闻声方得知。”
    这与马祖一系强调直下顿悟，又成歧路。良价不是迳直由此全部领会，而是在经历了诸如此般“也大奇”的思想迂回曲折缠绕之后，总在昙晟《宝镜三昧》的法门之下终于悟入，因为他在辞别云岩山时，心中仍犹疑徘徊，反复思量，直到过一水，睹水中之影像，豁然悟彻，所悟的正是“宝镜三昧”精神。其得法偈云：
    切忌从他觅，迢迢与我疏。我今独自住。处处得逢渠。渠今正是我，我今不是渠，应须恁么会，方得契如如。
    过水即如临镜，形影相睹，当人即是影像，影像岂非斯人，形影宛转相照，水镜之妙一也。
    洞山良价之所以成为曹洞一宗的创立者，在于他直承石头承迁、药山惟俨与云岩昙晟，总结发明，提出了一整套包括功勋五位、正偏宛转、三渗漏和三路接人等方法、范畴在内的理论思想与修行实践体系。而这一套独特的体系，其展开运用与丰富完善又是由他弟子曹山本寂来完成的。其间之亲切紧密不可分割，故“曹洞”连称自为允当。《五灯会元》评价说：“洞山权山五位，善接三根，大阐一音，广弘万品。”而曹山则“妙唱嘉猷。道合君臣，偏正回互”，至此曹洞宗总蔚然成立，名播天下。
    曹山本寂（８４０－９０１），俗姓叶（一说黄姓），泉州莆田（在今福建莆田）人，唐代末年，泉州“多衣冠士子侨寓，儒风振起，号小稷下焉。”在此氛围之中薰陶过的经历，使本寂在儒家教育下颇具功底。《宋高僧传》作者赞宁就曾称赞他素修举业，文辞遒丽，富有法才，其实，这与乃师洞山良价以至乃祖石头宗系的特点颇有相通之处，对其个人的思想与修行实践也深具影响。他十九岁于福州出家，二十五岁受具戒，闻洞山良价禅师盛名，即往请益。良价闻其名。回曰：“本寂”。良价再问：“向上更道。”回云：“不道。”良价问：“为什么不道？”回云：“不名本寂”。良价由此器之，传其心要。悟入之后，随缘放旷，如愚若讷，后受请往抚州曹山，更迁荷玉山。两处均法席隆盛，学侣四集，他传授良价五位铨量，撰《解释洞山五位显诀》立为曹洞丛林标准，还留下语录三卷，并注《寒山子诗》，盛行当世。曹洞宗由石头系发源而出，洞山创立，至曹山大成。
    如果说在曹洞宗正式成立之前，石头宗系已经由石头，药山和云岩昙晟为其提供了丰富的思想来源，那么洞山良价和曹山本寂得以立宗的独特贡献就在于：在形而上的哲学思想层次，他们以与乃祖的君臣、偏正等范畴“回互”理论相结合，通过深入细致阐述，使这一传统理论变得完全成熟化，用以启示学人由事上见理、由现象见本体、由普通的世界观跃升而入“曹洞宗的世界观”；在具体的修行实践上，他们以三路接人、三渗漏、三种堕等手法，树立标准，具体展现曹洞宗应机接人的风格。
    将世俗之君臣理念直接引入自己的宗教哲学与实践体系，并且成为特色，这在古今中外的宗教历史上并不多见。在曹洞宗历史上，洞山良价的这一开创性尝试，其初因仍然可以直溯其《辞北堂书》，其浓厚的报恩思想动机，由报父母恩而延至报皇恩，并深入渗透到他的禅理论与实践中，由此而成“君臣五位”这一根本思想，用以阐明“回互”之理，并因之成为曹洞宗区别于其他宗门的主要特色。
    “君臣五位”重在阐释理与事、本体与现象、一般与个别之间存在的五种关系，其中有四种是片面的、失当的，只有一种是事理俱融、全面正确的。失当与否，可以用正、偏来表示，曹山本寂的概括简明扼要：
    “正位即空界，本来无的偏。位即色界，有万象形。正中偏者，背理就事。偏中正者，舍事入理，兼带者，冥应众缘。不堕诸有，非染非净，非正非偏，故曰虚玄大道，无着真宗。”
    用以上正偏五次来说明理事关系，犹嫌不足，以君臣二者来进一步明其大体，就是“君为正位，臣为偏位，君视臣是正中偏，臣向君是偏中正，君臣道合是兼带语。”显然，“兼带”也好。“君臣道合”也好，总是曹洞宗的理想哲学模式：克服各种片面的认识，达到由事见理，即事而真，事理圆融，混然内外，和融上下，方为至上境界。
    运用近代语汇来解释上述名相是一回事，真正贴近曹洞去理解其原初的“本来面目”又是另一回事，这种差别多少有点类似文物保护修复领域里的“整旧如新”和“整旧如旧”之异。从后者的角度来说，由石头宗系达至曹洞宗，其长于形而上思考这一思想家特质渐臻成熟完善，这是就内在之质而言，从外在形式看——当其开宗立派、丞需建构自己独特哲学体系时，困难便发生了：建筑这一新型大厦的砖瓦材料严重不足，只能从别处借取现成的名相范畴为我所用，曹洞借用“君臣”之说，即是最主要一例。后世论者往往指出其与世俗政治之关系（如中唐以后重振君权思潮之影响），并无不妥。但言谨及此是很不够的，更重要的问题在于：中世纪的禅思想家们，在努力建构自己的思想体系时，越来越面临着缺乏新的哲学语汇的严重困难，因此，这种努力就时常处在内在的思想张力与外在的语汇的贫乏矛盾之间，显得力不从心，以至于反复借喻，来回比说，本欲申明宗旨，反使宗旨本义为文辞所掩盖，变得迷离含混。例如在阐述“君臣五位”时，往往配以《周易》的一些卦象：将“正中来”配以“大过”；“偏中至”配以“中孚”；“正中偏”配以“巽卦”；“偏中正”配以“兑卦”；而“兼中到”（兼带），则相当“重离”。对此，后世学人当然只能取得鱼忘筌之法，来辨明领会其精神要旨了。至于对本宗如何朝新的方向发展，创新的突破口何在，则鲜见指导性意见，特别是有关本宗区别于其它宗派的特色，在重视知解、善于融会、坐禅看经，更未及作任何自觉系统的反思。如此，曹洞立宗之初，即埋伏下宗门内在的深刻危机。曹洞宗后世发展中，在大阳警玄和天童如净两度毅然自断法统，与此大有因缘，良足深悲！
    在修行实践上，曹洞宗立足于理事回互的基本理念，多方施设，接引学人。良价立“三种渗透漏”、“三路”、本寂立“三种堕”，均是。所谓“渗漏”，指错误见解，包括见渗漏、情渗漏、语渗漏、即指从见解、情志、语言文字等三个方面，背理执事，坠入世俗错误知见。作为对治“渗漏”之方，良价指出三种手段即“三路”，鸟道、玄路和展手。鸟道者无踪迹可行，示参学者需直下体悟；玄路者如“夜半正明，天晓不露”，说明明暗“回互”，学人要蹈此路。而展手者，示学人事理变明，体用无滞，尽展两手，直入般若门。
    曹洞宗门既立，继良价之后住持洞山的有道全、师虔、道延等（生卒年不详），曹山本寂门下参学的知外弟子亦有道延、从志、处真、慧霞、光慧、弘通、行传等。以上诸禅师亦多留传有机锋问答，但是法脉都传之不远。真正将曹洞法脉保存下来的是云居道膺一系。
    云居道膺（８４８－９０２）也是洞山良价的法嗣。俗姓王，玉田（在今河北）人。少年在范畴阳（治今河北涿县）延寿寺出家，初修小乘戒律，后往终南山之翠微寺参无学禅师（丹霞弟子），继往筠州（在今江西高安），参洞山良价，终于契悟，今会得洞山的宗旨。良价印可道：“此子以后千人万人把不住”许为门下弟子中的领袖。后至洪州（冶在今东西南昌）云居山创真如寺，讲法三十余年，大振曹洞宗风，风被海内外，徒众多至一千五百人。其海外传人中，著名的有新罗利严（８７０－９３６）、高丽庆甫（８６９－９４８）等，利严得法归国之后，创面弥山派，为海东禅门九山之殿。
    道丕（？－９０５），亦作僧丕，长安人，在家时以孝亲著名，亲殁出家，是云居道膺的法嗣。居洪州凤栖山同安院，学者云集，世称同安祖。其同门为道膺法嗣者，知名的还有怀晖、怀岳（？－９４５）、本空、道简（生卒年均不详）等人。
    僧志（生卒年不详），又作观志。嗣同安道丕，继其丈席，后世称为凤栖祖。
    缘观（生卒年不详），嗣同安僧志法席。住鼎州（今湖南常德）梁山，后世称梁山缘观。
    综观曹洞宗在唐五代的整体状况，可以分为三个截然有别的时期，即前曹洞宗时期，成立时期和第一个低潮时期。
    所谓前曹洞宗时期，即以石头希迁、药山惟俨和云岩昙晟为标志的酝酿准备年代，时间在７００－８４１年之间（以石头生年和昙晟卒年为始终）。这一长达百余年的准备年代，为曹洞宗的成立提供了充足的、直接的思想来源，就思想的成熟度来说，这种培元固本的工作使得曹洞一宗先天地具有了某种突出的早熟性。以至于当曹洞宗在九世纪（８０７－９１０，以良价生平和本寂卒年计）正式成立的年代，其创立了所做的工作主要就是将现成的思想资料（“偏正回互”）予以整理，使之向高度成熟和缜密的方向上进一步拓展（配以君臣五位乃至《周易》和道家思想资料），同时在接引学人的实践之中，将其尽可能地操作化（良价所谓鸟道、玄路和展手）。这样一来，一种看似矛盾的奇特现象就出现了：曹洞宗成立之时，其思想义理之基业已筑就，创立者们（洞、曹二师）努力建构适应成立需要的宗门哲学大厦，却发现缺乏足够的新鲜资料可以运用，于是大量的原非佛教的无关资料被借用进来，例如君臣、功勋、易卦等等名相被吸收进来作为主要的范畴，用以建构这座大厦。这与一般禅师随机应化、随缘施设是有着本质区别的：后者只是随手利用外缘开示学人而已，曹洞宗却不得不搬运外缘来作为基本材料，建构和发展自己的核心体系。这种思想的早熟性，使得曹洞宗具有某种悲剧意味，刚刚开始就告停滞，新的理论生长点无从寻觅。日本学者忽滑谷快天在论及曹洞宗第二代创立人本寂时，不无沉痛地说过：“使洞山宗旨明于世者本寂也，使洞山宗旨坠于死型者，亦本寂也。”这是迄今为止，就曹洞宗成立之悲喜剧所仅见的一则全面评价之语。明乎上述因缘，则知“坠于死型”，责任不在本寂，在乎时节因缘耳。当然，这也说明，所谓宗派成立年代，亦有人为划分之弊，“曹洞”因为约定俗成之一名相，宜明其亲密关系，但当初径直呼之“曹溪洞山”、或“石头曹山”以明乎其宗派的真正思想源流，亦未尝不可。
    历经八世纪准备，九世纪成立的曹洞宗，甫一成立，即进入相对沉寂低落的年代，终唐末五代之世，乃至于人宋之后，虽然在本寂特别是道膺下勉为传承，数代之间有迹可寻，但无复乃师乃祖光耀千古之旧观。这一局面横贯十至十一两个世纪，此中当然不是以名僧论世，最为致命的问题在于：新的义理的突破口，生长点未曾找到，故无新的气象可言。


三、宋代曹洞宗

三、宋代曹洞宗

    至少从公元１０世纪中叶起，曹洞宗进入了百年孤独的年代。
    臣主相忘古殿寒，万年槐树雪漫漫。
    千门坐掩静如水，只有垂杨舞翠烟。
    这首诗，本来是曹洞宗用以形容其臻于“偏正回互”、“君臣道合”、成佛作祖之至上境界的，但是从后世史家的眼光来看，却不免成为一种纤语：这个富于思想家特质的大宗派，在经历了８－９世纪的辉煌之后，失去了其强健的思想活力，在万看槐树、千门坐掩之中再也不见有“人天师”之主体出世，惟余“偏正回互”的余绪言，如垂杨在历史的风中漫舞，这真是一种刻骨铭心的百年孤独。
    这种孤独，当然不是表相的。从历史上看，几乎是在刚刚跨入十世纪的门栏之时，初期曹洞宗的最后一颗明星——云居道膺即告入灭（９０２），从此，在整个十世纪的上半叶，亦即所谓五代十国时期，相继有同安道丕、同安观志、梁山缘观在继嗣宗脉。虽然以上三师在历史上记载过简，传世机级语录寥寥无几（如同安志甚至缺语录传世），但曹洞宗谱不可言中断，甚至对同安丕、同安志、宗门尚有“同安祖”、“凤栖祖”之尊称，可以想见宗门香火绝如缕之亲切状。不过，在这个时期的最后一位嗣法者梁山缘观禅师那里，显然已经透露出某种令人不安的焦虑消息来了：
    （缘观）示众云：“停机罢赏，匿迹潜踪……谈玄唱道，莫非云水高人；鸟道无踪，乃是道人行履。谈玄则不挂唇吻，履践则鬼神难觅，悟之则刹那成佛，迷之则永劫生死。有疑即决，不可守株待兔，抱拙守愚，潦倒无成，空延岁月。”
    这与乃祖从容细密、回互绵延之风，相去何啻百千里！观此急切焦虑之状，实与禅师个人修行见地功夫无关，而事关曹洞禅之全局：云居道膺之后，数十年间，曹洞宗门参学者剧减，从当初动辄门下聚集千百徒众，演变而为门可罗雀，至于登堂入室窥其奥区者几稀，《景德传灯录》梁山观本传记曰：
    问：“如何是和尚家风？”（观）师曰：“资扬水急鱼行涩，白鹿松高鸟泊难。”
    梁山一曲歌，格外人难和。十载访知音，未尝逢一个（颂一），红焰藏吾身，何须塔用新。有人相肯重，灰里邈全真。（颂二）
    自石头希迁源、曹洞立宗以来，气象阔大浑厚的曹洞大宗，何以一变而为“鱼行涩”又“鸟泊难”？何以骤失吸引力？简略地说来，这与其立宗之初内在义理思想的早熟、外在名相语汇的贫弱匮乏大有关系，这在上文已作分析。是以，洞山开宗以后，经曹山本寂、云居道膺，不过二世，其内在与外在的旧有资源忽忽告罄，新的当时代之机的生长点尚未呈现，延至同安丕、同安志，竟无一新义可以语人。此门淡泊，收拾不住，天下参学者尽归当机之云门、临济二宗门下，面临此一光景，梁山观如何不深重忧虑自己门下“潦倒无成，空延岁月？”
    试进一步观察梁山观接引大阳警玄一案。大阳警玄（９４８－１０２７），江夏张氏子，少年在金陵崇孝寺依出家之仲父为师，年十九为大僧。其谒梁山而契悟事迹，在《禅林僧宝传》中记载如下：
    问：“如何是无相道场？”观指壁间观音像曰：“此是吴处士画。”延（即警玄，宋祥符中避国讳易名警延——引者注）拟进语，观急索曰：“这个是有相，如何是无相底？”于是延悟旨于言下，拜起而侍。观曰：“何不道取一句子？”延曰：“道即不辞，恐上纸墨。”观笑曰：“他日此语，上碑去在。”
    在梁山观“急索”之下，大阳警玄终于契悟，可以“上碑”传世，梁山观禅师悬悬之心，总算落一实处。
    很难说这种传承是否过于勉强，但是无论如何，到大阳警玄之世，曹洞宗竟至中断。这种暂时的中断，与其说是自然演化的结果，毋宁说是出于他的高度自觉、高度负责任的毅然抉择。
    史家往往因大阳警玄留皮履布直缀托付浮山法远代为觅传人的戏剧情节，而谓警玄门下乏嗣。然而，事实远非如此简单，据《天圣广灯录》、《建中靖国续灯录》等记载，警玄法嗣并不乏人，动以一二十人计，即使警玄入灭之后，亦有福严审承等人尚在世，不可谓无人承嗣。其中审承、清剖两人还号称奇杰，有语录传世，著名于时，所以历来所谓后继无人，不过是史家臆测之语。那么大阳警玄何以出此壮士断腕之举？
    上文言及，曹洞宗自十世纪初以来，传承脉息遽弱，自同安丕、同安志到梁山观，难以为继之窘迫状日甚。此并非外在压制使然，而系内在泉源枯竭，无从当机接人，至警玄之世，以玄之机警聪慧，仍无以改观。自同安丕三传以至警玄，百年有余，曹洞门下静如止水，新意生机丧事失殆尽。这种难乎为继的孤独之状，并不仅仅表现为门下冷清，更在于承其法统者精神深处的痛苦和无告。警玄传世语录甚简，但亦可透露其孤独心迹：
    问：“如何是平常无生句？”师曰：“白云复青山，青山顶不露。”云：“如何是妙玄无私句？”师云：“宝殿无人不侍立，不种梧桐免凤来。”“如何是体明无尽句？”师云：“手指空时天地转，回途石马出纱笼。”
    “自以先德付受之重，足不越限，胁不至席者五十年。年八十，坐六十一夏，叹无可以继其法者，以洞上旨诀寄叶县省公之子法远，使为求法器传续之。……以天圣五年（１０２７）七月十六日升座辞众。又三日，以偈寄王曙侍郎，其略云：‘吾年八十五，修因至于此。问我归何处，顶相终难睹。’停笔而化。”
    所谓“先德付受之重，”实乃曹洞禅法难乎为继、乃师梁山观勉以为继之危，警玄痛感乎此，足不越限，胁不至席五十年，而终于未能别开生面，此中悲苦，夫复何言！
    警玄最后不是从自己门下聊选一人，姑且付托——他从梁山观和自己身上已明察此路不通，而是明乎因缘未具，时节未至，毅然壮士断腕，断绝门下任何法嗣之念，将曹洞法统，以皮履直缀为记，庄重托付如日中天的临济高僧浮山法远，嘱其代觅天旋地转时节出世之曹洞真传。
    这是何等大智大勇之举！设若警玄此时一念苟且，草率付法，则其个人自不必冒断绝法嗣之风险，而曹洞宗门必步入陈陈相因、彻底枯竭之绝境！须知，为宗谱续法嗣极易，为精神择传人极难。由此反观佛教史、禅宗史上诸宗兴衰内在奥秘，可知苟且极易、不苟且极难，苟且必衰、不苟且必兴之至理！就这一意义而言，大阳警玄真为千古一高僧！
    大阳警玄这一千古绝唱，因其后投子义青的成功接续，而往往为论者忽略不识，史家常归功于浮山法远，殊不知阳警玄为其关键。大阳警玄以非凡气魄与手段，了断曹洞宗在公元十至十一世纪前期尴尬独的百年史，为曹洞宗的长远发展带来了真正的转机。
    选择浮山法远，来代觅曹洞真传之人，是大阳警玄高著眼的一个明证。浮山法远（９９０－１０６７）为临济名僧，在禅林中有“远公虎子”之名。欧阳修闻其说法之后，曾感叹：“修初疑禅语为虚诞。今日见此老机缘，所得所造，非悟明于心地。安能有此妙旨哉，”法远早岁游学时，曾参大阳警玄门下，得到警玄印可。是以警玄识人，托付传法大事于法远，　法远当此大任，未敢丝毫疏忽，历经二十余年，始得择中投子义青，嗣其嗣法警玄。
    投子义青（１０３２－１０８３），俗姓李，青社（今安徽舒州）人。十岁出家，数年间精通《法华》、《华严》和《百法论》等经论。后随法远数年，兼习临济与曹洞禅法。宋英宗治平元年（１０６４），受法远嘱，接续曹洞法统，其来历深厚，眼界开阔，又值盛年，上接曹洞中断二十余年法脉，有生机勃发，无陈腐逼仄，煞是清新可喜可观：
    圣节上堂：“天垂玉露，地涌祥云，千江澄万顷烟波，四塞贺尧风舜化。山连碧汉，树起清风。琼林华绽于瑶池，御柳莺啼于玉苑……诸仁者，正当恁么时，且道‘君臣道合’一句作么生道？”良久云：“道泰君臣清宇宙，时丰齐贺舜尧年。”
    谢化主上堂：“碧岫横空，白云自异。灵苗独秀，繁草何生。金鸡啼处，月落三更。玉兔眠时，日轮当午。琼林上苑，枯木逢春，宝殿苔生，歌谣万里。然虽如是，且道‘应时应节’一句作么生道？良久云：“夜来深雪里，天晓数枝开。”
    试比较投子义青与警玄门下审承诸人的机锋，则其高下，不啻天壤。由警玄而经法远，一只看不见的巨手，如是终于校正了曹洞禅法脉，此等大手笔，非玄、远等第一流禅者所不能梦见。
    义青嗣法弟子中，以芙蓉道楷最著名，芙蓉道楷（１０４２－１１１８），沂州（今山东临沂）人，俗姓崔，少辟谷学道，后游京师，试《法华》得度，具戒游淮西，时义青住白云山海会寺，道楷遇而言下悟入，先后住持安徽马鞍山、江西洞山和湖北大阳等地寺院。宋徽宗崇宁二年（１１０３），住持京城净因寺，后五年移住天宁寺。开封尹李孝寿以其道行卓冠丛林，请帝赐紫衣和师号。道楷谢恩爱拒受，被逐出京外遣放，次年敕放释，令自便，即仍庵于芙蓉湖上，学徒数百，环绕坐卧，楷虑祸，乃日各食粥一杯，不堪者稍稍减退，随侍者犹百余人。徽宗政和七年（１１１７），帝为所居庵赐额“华严禅寺”。明年入灭，遗偈云：“吾年七十六，世缘今已足。生不爱天堂，死不怕地狱。撒手横身三界外，腾腾任运何拘束。”
    曹洞宗历代传人中，超出江西湖南，长期住持帝京者，道楷为第一人，这本身就说明曹洞宗较之以往，活动范围大增，而眼界亦大，至于道楷的突出个性与节气，更令曹洞宗增色，设若当初曹洞宗无大阳警玄毅然“断腕”之举，依然苟且局促于区区同安道院，后来义青、道楷之崭新局面气象，岂可梦见？
    对于喜好以“君臣偏正”来说明自己哲学体系的曹洞宗来说，宋徽宗之于芙蓉道楷间的戏剧性情节，其实可以视作对曹洞宗风的一次检验，兹录道楷上表拒受帝赐之文如下：
    “……伏念臣行业迂疏，道力绵薄，常发誓愿不受名利，竖持此意，积有岁年，庶几如此传道后来，使人专意佛意，今虽蒙异恩，若遂忝冒，则臣自违素愿，何以教人。岂能仰称陛下所以命臣住持（指奉敕住京师两大寺——引者注）之意，所有前件恩牒，不敢只受。伏望圣慈察臣微悃，非敢饰词，特赐俞允。臣没齿行道，上报天恩。”
    帝闻，又令李孝寿亲往谕旨，而楷道心坚定，孝寿只得如实具闻。因此发生后来帝怒收楷，付有司逐京外之事。这是曹洞宗进入社会政治舞台中心之后的一次极精彩的亮相，是曹洞宗报恩思想由洞山良价报母恩而至道楷报皇恩的一次完整的宗教实践演绎，其结果赢得了上至天子下至士民的真正尊敬。宗门至此，焉得不光大。
    芙蓉道楷门下著名者有子淳、法成、惟照、元易、自觉、禧浦、齐琏、善秀、法灯等人。其中以丹霞子淳（１０５４－１１１９）和净因自觉（？－１１１９）著名于时，亦且传世久远。
    如果说，曹洞宗在立宗之后因时节因缘所限，其行不远，在十至十一世纪前半期一百五十余年的历史中尚未得到长足发展，那么，以１０６４年投子义青接续法脉的戏剧性情节作为分界线，此后就是曹洞宗真正展开生发的年代。芙蓉道楷便是“中兴”之祖，以他为新的历史起点，曹洞宗在此后几个世纪之中，呈现出一种饶有意趣的梯次发展局面（丹霞子淳和净因自觉在其间作了必要的铺垫和过渡）：
    第一梯次是北宋末到南宋前期的宠智正觉。
    第二梯次是贯穿南宋中后期的长芦清了一系。
    第三梯次则是直接发端于南宋，盛行于金元时代北方的净因自觉一系。
    具体地来说，从两宋之际兴盛起来，活跃于南宋的曹洞宗禅师，以丹霞子淳系为主。子淳门下发端出宠智正觉、长芦清了两支。
    宠智正觉之所以出类拔萃，超徒越众，蔚然成为道楷中兴曹洞宗之后的先锋人物，是有其深刻的历史因缘的。
    宠智正觉（１０９１－１１５７）是隰州（治今山西隰县）人，俗姓李。七岁能诵儒典，日诵数千言，其祖父与父亲两代都是深受禅宗薰陶的知识分子，参询禅师，诵习《般若》不辍。如此则使正觉少小与禅宗固结深缘，十一岁出家，十四岁受具足戒，十八岁开始游方参学。其先游踪北地中原，首参汝州（治今河南临汝）香山寺枯木法成禅师。此法成即芙蓉道楷弟子，亦曾受诏住持汴京名寺，名重当代。正觉二十三岁，得遇丹霞子淳，随侍五年，先掌记室，后升首座，并随子淳从中原南迁，此间得子淳传法。子淳入灭后，受清了之邀，曾往真州长芦（在今江苏仪徵县）为清了之首座。子淳门下两大弟子理共住一寺。宋室南渡之后，建炎三年（１１２９），正觉开始住持明州天童寺（在今浙江宁波），此后近三十年间，除曾应诏住持杭州灵隐寺数月之外，均住天童寺，其倡“默照禅”即在此期间，卒谥“宠智禅师”。有《宏智正觉禅量广录》传世。
    有宋禅宗史上，正觉的突出成就，在于其倡导“默照禅”，为南宗禅（主要是曹洞禅）的一种非主流传统——坐禅传统创造和阐明了充分的理论根据，具有强烈的指导修行实践意义。他的朋友兼论敌大慧宗杲禅师评其“烹佛烹祖大炉鞴，锻凡锻圣恶钳锤”，此言可谓知人，而评其“起曹洞于已坠之际，针膏肓于民死之时”则值得深思，深思宗自投子义青续法，至芙蓉道楷门下，已然中兴，楷入住帝京赐紫封号，其门徒如法成者亦享此殊荣，正可谓方与未艾之际，宗杲何以断言其“已坠”和“必死”只有首先弄清此一关键，然后总可言“默照禅”要旨。
    简略地来说，曹洞自洞山曹山开宗，九传至于宠智正觉，其间几三百年，曲折多舛，间有高僧如警玄、义青、道楷辈出，但是，一个带有根本性的问题始终未能解决，这就是适应立宗之后的需要、创建本宗独有的一整套思想理论体系，并使之在可操作层面完善成熟，对本宗修行实践具有根本的指导意义——惜乎从洞曹两代起，即一直未能彻底解决此一问题，前文已详细分析，曹洞立宗之前以“偏正回互”论成立为标志，即已具备思想的早熟性质，洞山曹山两大师使之更为丰富缜密有加，完成成熟，而在寻找新的理论生长点和依据上则未及开拓，特别是有关本宗在南宗禅法体系之内存在的合理性——其中最突出的是坐禅看经、融会别宗甚至外学（如儒道）这一系列迥异南宗禅主流（洪州、临济）的本宗特色，一直未能正面阐明，随着曹洞宗的次第传承，这个矛盾越来越突出；旧有的“偏正回互”、“君臣五位”的学说日益不能满足需要，尤乏可操作性（历代禅师渐次弃置不言及即是明证），而新的理论体系又未曾建立起来，其矛盾结果事关曹洞宗生死存亡。是以，先有大阳警玄途穷思变、壮士“断腕”于前，尔后即便在芙蓉道楷中兴繁华的表象之下，理论上无以立足的危机依然深重。反之，临济名僧宗杲以临济禅法蔚为南宗主流、体大思精、大机大用之显赫背景，冷眼观之，看破曹洞致命危机所在，自是意料中事，故云其时曹洞仍在“已坠之际”、“必死之时”！他猛烈抨击“默照禅”，却又高度赞扬“默照禅”起曹洞于必死绝境、使其起死回生之功，这一矛盾态度真可谓旁观者清，最得曹洞宗实际。
    明乎此，则知宠智正觉“默照禅”针砭之深切，注重坐禅，自石头、药山以来，至曹洞立宗以后，一直是石头宗系和曹洞宗的修行实践传统特色，如果说那些属于形而上的义理特色可以随时间推移而有所淡化、脱落，那么重坐禅这一传统则贯穿修行实践，未能回避，如何与北宗禅之坐禅观心、拂尘看净传统划清界限，与慧能南宗明心见性、直下顿悟之宗旨保持一致，进而言之，如何对曹洞宗修行实践提出根本性的指导方针，为其后发展开拓生存空间——以上正是正觉禅师入手处。
    “默照禅”者，合守默静坐与般若观照之谓也。正觉自作《默照铭》云：
    “默默忘言，昭昭现前。鉴时廓尔，体处灵然。灵然独照，照中还妙。露月星河，雪松云峤。晦而弥明，隐而愈显。鹤梦烟含，水含秋远，浩劫空空，相与雷同，妙存默处，功忘照中。……正偏宛转，明暗因依。……回互底时，杀活页纸我。……吾家底事，中规中矩。传法诸方，不要赚举。”
    正因为切中修行实践要害，找准了新的理论生长点，正觉认为“默照禅”能给曹洞学人以中规中矩、不被赚举之信心。这里，既包含和坚持了偏正回互、理事泯融的形而上理念，又更是一种切实便利的习禅方法，他明确否定北宗禅法，认为神秀所谓“身是菩提树，心如明镜台”是区分“雪里粉”、“墨中煤”的荒谬之举，指出默照者并非观心看净，没有一个身、心一类的特定观照对象，不仅要求习此禅法者去除一切观照对象之念，而且连坐禅者自身也要休歇、融入“空”中：“照与照者二俱寂灭，于寂灭中能证寂灭者是你自己。若恁么，桶底子脱去，地水火风，五蕴十八界，扫除无余。”
    通观“默照禅”之禅法，正觉既坚持和发展了石头希迁以来禅法宗旨，并将其推展到彻底空心之极致，使曹洞禅法落到实处、站稳脚跟，同时又大胆扬弃了洞、曹二宗师名相过于繁琐之弊，一改本宗素来不事张扬宣传传统，提出简便易行、富于吸引力的主张，所传心要，较之往圣，删繁就简，明白晓畅，号召力极强。其矛头所向，直指人心：“参禅一段事，其实要脱生死，脱生死不得，唤什么作禅？”如此直下了当，不能不令曹洞生命力全活，宗风大振！无怪乎正觉住天童，四方学者争相奔凑，逾千二百，其住天童垂三十年，寺屋几千间，无非新者，因缘时节至此而备，天童寺遂为一代习禅中心，此千百学人，得法之后大多“分化幽远，晦迹林泉”，如龙归沧海，虎放南山，虽山海之大不显其迹，而龙吟虎啸，其影响之大岂可蠡测。
    宠智正觉“默照禅”禅法馨香犹温，长芦清了一系又连绵继起，是为曹洞禅入南宋发展之第二梯次。
    长芦清了（１０９１－１１５２），法号真歇，左绵安昌（在今四川）人，俗姓雍。嗣法于丹霞子淳，然游历广泛，登峨嵋，朝五台，入京师，访禅讲名席，积磨炼之功，南游诣长芦，先为祖照禅师充作侍者，后一语投契，继其法席，有语录二卷行世，曹洞宗善于融会诸宗特色，至南宋之际，已然袒露于世，无所回避，其中最为传统者当属曹洞与华严相为表里，清了即著有《华严无尽灯记》，融华严入禅，其末有偈云：
    镜灯灯镜本无差，大地山河眼里花。
    黄叶飘飘满庭际，一声砧杵落谁家。
    又作《净土宗要》，提倡念佛，强调“信知乃佛乃祖，在教在禅，皆修净业，同归一愿。”表现强烈的融会禅、净、教思想。
    天童宗珏（１０９０－１１６０），一名大休，舒州人，俗姓郑。师事长芦清了禅师，嗣其法。住明州天童寺，学众恒逾３００，较之前辈，曹洞规模至此又见大增。
    雪窦智鉴（１１６２－１１９１），滁州人，俗姓吴。曾谒长芦清了禅师，时宗珏以首座示以方便，遂隐居苦参，久之得悟，乃嗣宗珏法绪。住明州雪窦（在今宁波），以本色接人，四方远来学法，门风大振。
    天童如净（１１６２－１１２８），明州苇江人，俗姓俞。初参雪窦智鉴，鉴问：“汝名什么？”净曰：“如净。”鉴曰：“不曾污染，净个什么？”净莫措。一日白鉴曰：“愿乞某充净头。”鉴曰：“不曾染污，净个什么？若道行，许汝净头。”净又莫措。阅数月，鉴召净室内曰：“前来一拶，道得也未？”净拟议，鉴大叱：“出！”如果激发数番。一日，忽上方丈，白鉴言：“某甲道得。”鉴曰：“纵脱臼窠，即落便宜，如何道得？”净拟进语，鉴便打，于是豁然有省，连声叫曰：“某甲道得，某甲道得。”鉴微笑，即请充净头，从受鉴会嘱大法，为曹洞法嗣。因其身长而豪爽，时人称为净长，后世号为“长翁”。相继住建康府清凉寺、台州净土禅寺、临安府南山净慈寺和明州天童寺等东南名刹。住天童四年，学者辐凑、门庭清严，海内以为法式。临终遗偈曰：“六十六年，罪犯弥天。打个跛跳，活陷黄泉。咦，从来生死不相干！“嗣其法者有鹿门觉、石林秀等人，日本京都僧人永平道元于宋理宗宝庆元年（１２２５）谒见如净。两年后，如净竟许为法嗣，传芙蓉楷祖法衣、《嗣法书》、《自赞顶相》和《宝镜三昧》、《五位显诀》等，与道元携返日本。
    天童如净在南宋曹洞宗史上有殿军之慨，这与其个人风格大有关系，其为人豪放，见处高迈，放言纵谈，痛斥时弊，则恶拳痛棒。史家往往以“只管打坐”一语概括其宗风，而言不及其内心沉痛激愤之深，实为皮相之言。　据永平道元所述，其示云：“参禅者身心脱落也，不用烧香、礼佛、念佛、修忏、看经，只管打坐而已，”则看似将“默照禅”推展为极致，即所谓“发展”，其实为匡救时弊痛下针砭之行也。禅宗发展至此，其僧界惑溺名利，风纪颓败之状亦臻于极致。观如净说法之语，不见乃祖从容绵密、回互亲切之风，而触目尽是愤嫉痛言，如指斥“僧堂里都不管，云水兄弟也都不管，只这与客官相见追寻而已，”又如常就天下僧家长发爪之辈警诫云“不会净发，不是俗人，不是僧家，便是蓄生。古来佛祖，谁是不净发者！如今不会净发，真个是蓄生！”其它如指斥在服装上“近来都著直缀，乃浇风也，你欲慕古风，则须著褊衫……近来参禅僧家，谓著褊衫是律家兄弟服者，乃非也，不知古法人也。”又如在经行步态上强调“僧家寓僧堂，功夫最要直须缓步，近代诸方长老不知人多也，知者极少……你试问诸方长老看，必竟他未曾知也。”他因而规定自己门下：“今日参内里之僧，必著褊衫，传衣时、受菩萨戒时亦著褊衫。”经行则“肩胸等不可动摇而振也。”以上通见其日本法嗣永平道元在《正法眼藏随闻记》所转述之语。以一代豪迈不羁之龙象，却似乎汲汲于发、爪、著衫、步态等琐细不堪处，其实睹落弃而知秋之沉痛，扶危局于欲倾之悲苦，堪向何处道得？最后，他竟将曹洞传法信物，悉数尽付随参不到三年的异域僧人道元，令其席卷而归海东，此似为色望之举，实乃拯救曹洞之一高着眼。回顾曹洞宗历史，壮士断腕。自行了断，以拯法脉，大阳警玄在前，天童如净殿　后，如是再者，其令人肃然深思。
    天童如净目送传法信物尽随道元挂帆远去，回过头来，他是如何看待自己置身其间的五家禅宗的格局的呢？他上堂示众云：“如今个个只管道云门、法眼、沩仰、临济、曹洞等家风有别者，不是佛法，也不是祖师道也。”“近年祖师道废，魔党畜生多频频举五家门风，苦哉！苦哉！”盖对五家儿孙落窠窟、竞势利、使正信佛法沦丧之危局痛入骨髓，故出此独断之语。道元回到日本，用旁观者口吻转述说：
    “大宋国一二百余年？……接引学人者，攀临济之四料简，四照有，云门之三句，洞山之三路、五位等，以为学道标准，先师天童和尚，常笑此曰：‘学佛岂如此也？’
    数百年来禅宗界惨淡经营之五家格局，竟被一句“学佛岂如此也？”轻轻问住，这便是曹洞宗在宋代操守清严见识高迈的法门龙象——天童如净所下的总结之语，令人不免有悲从中来之慨。在这里，简单地批评天童如净矫枉过王、偏激片面，或指认永平道元有某种贬家禅总格局也好，其成就是绝不容否定的，也无法否定，问题是，面对鲜花着锦、烈火烹油的佛教历史局面，人们都能回味这位高僧的轻轻一句笑语：“学佛岂如此也”么？
    在芙蓉道楷门下，曹洞宗中兴的第三梯次则是由净因自五传至万松秀一系所完成。其历时近一百五十年，与丹霞子淳至天童如净一系历时大体相当，但跨越南宋、金和元三代，中间数传法脉较为模糊不清。
    净因自觉（？－１１１７），青州人，俗姓王。少业儒，受知于司马光。宋绍圣（１０９４－１０９８）年间，从芙蓉道楷落发，数年从学，得楷印可。崇宁（１１０２－１１０６）间，奉诏住京师净因寺。政和元年（！！１５）迁鹿门寺（在今湖北襄阳）。政和七年（１１１７）二月示众而化。灰烬中有舍利如菽，还葬青州，入塔日，有雨华之感应，史家有将天童如净法嗣名鹿门觉者，与净因自觉混为一谈，缘于净因自觉后迁鹿门之故。实则二者相距百年有余。
    青州一辨，为净因自觉法嗣。宋宣和（１１１９－１１２５）年间，曾聚十方僧众，拈提宗纲，设百问示众，由慈云觉遂一作答。其后，由元代林泉从伦逐一附颂，集成《青州百问）一书，宣示曹洞宗风，流行后世。
    青州中以大明僧宝、王山僧体二代，传世雪岩如满禅师。雪岩如满（１１３６－１２０６），一作慧满。山西汾阳人，俗姓崔。在太原王山谒僧体禅师而得法，并承师丈席。晚迁大明寺（在今河北磁县），学人四集，盛极一时，有语录传世。
    万松行秀（１１６６－１２４６），河内之解（今河南洛阳一带）人，俗姓蔡。少年出家于邢州（今河北邢台）净土寺，辗转至磁州大明寺参雪岩如满，总二十七日便领旨，在满门下二年，尽得其底蕴，如满遂付以衣偈，令其嗣法，返回邢州净土寺后，在寺旁构“万松轩”以自适，因有万松之号，次迁中都（今北京）万寿寺，金章宗明昌四年（１１９３），行秀应诏赴内廷升座说法，帝躬迎礼，闻法感悟，赐锦绮大衣，建普度会，每岁设齐。后奉诏移住大都仰山栖隐寺，再迁报因寺，晚年退居报恩寺从容庵，秀天资英才，于百家之学无不淹通，曾三阅藏经。著述甚丰，有《祖灯录》、《释氏新闻》、《鸣道集》、《辨宗说》《心经凤鸣》、《禅悦法喜集》和《请益录》，并语录等若干卷，而以《从容庵录》最为著名，及门弟子众多，得法者一百二十人，影响最大者林泉从伦、华严至温、雪庭福裕等，以居士身份从学护法的还有耶律楚材等金元两朝官绅。
    《从容庵录》是万松行秀在耶律楚材敦请之下，将历年讲解公案和颂古的旧稿整理所在之书，集中体现了他所弘扬的曹洞禅风。耶律楚材为此书作序，该书全称《万松老人评唱天童和尚颂古从容庵录》，诠释正觉的《颂古百则》。其每则集公案与颂古为一。依《碧岩录》体例，每则之下例分示众、列举公案、列举公案、列举颂古、夹注和评唱五种内容。行秀自述其撰此书目的有三：“一则旌天童学海波澜。附会巧便；二则省学人检测讨之功；三则露万松述而不作，非臆断也。”行秀博学广闻，引领学人窥见宏智正觉心要，游刃有余，其兼通内外典功夫亦在“述而不作”之中毕现。
    曹洞宗发展至十三世纪上半期，其命运发生了根本性的改观。一方面，由丹霞子淳经清了四传至天童如净一系，几经周折，至如净竟告消歇。前文已分析如净身陷禅界弊端丛生之局，愤世嫉俗，无力回天，终将曹洞传法信物悉付日僧道元，任其跨海东去，道楷中兴之功，遂传东瀛。另一方面，净因自觉至万松行秀一系由南方渐移北地，入金元之庭，不意在如满至行秀一两代之间，不过三四十年光阴，竟然得到自由生发，倾倒朝野，生机勃勃，发扬光大中兴精神，又开辟了曹洞兴盛北地百余年的黄金时代。此中底蕴，实令人深思。从社会文化氛围看，南宋偏安，民族矛盾与社会矛盾交织，虽僧界亦不遑宁处，更兼文化腐朽习气深重，禅虽如净之操守清严亦回天乏力；而净因自觉一系，数代传承之间不知不觉脱离南宋，得遇北地金元政权，少数民族统治者入主北地不久，所染汉人习气不深，文化上多清新刚健之气，少滞着陈腐之习，故能为佛教生存与发展提供广大空间。万松行秀遇如此时节因缘，于心平气和之中从容伸展，其庵号“从容庵”，著《从容录》，力从容道业，此等境遇则为南方曹洞宗人所未敢梦见。


一、福裕少林系传承

第十二章

    一、福裕少林系传承

    在为时不满百年的元代，中国佛教禅宗在南方的传承多为临济宗等的法脉，而曹洞宗则多在北方弘扬，其中又以报恩行秀禅师（系雪岩如满师法嗣，为曹洞宗第十五世）的法嗣雪庭福裕、华严至温、林泉从伦诸禅师以及俗家弟子耶律楚材、李之能居士等为代表，尤以福裕在嵩山少林寺传承的一系为突出。
    （一）嵩山少林寺系
    福裕禅师（１２０３－１２７５），字好问，号雪庭，太原文水（今山西省文水县）张氏子。自幼陪颖，五岁解悟《论语》，日了千言。九岁入学，读书一目十行，于乡邻之中有“圣小儿”之佳誉，少时遭乱丧家，得道逢和尚劝导，于宋嘉定十七年（１２２５）至仙岩投古佛和尚薙发脱俗，次年受具足戒。在古佛和尚处从学七年后，转投燕京（今北京）行秀禅师，随侍十年，严受钳锤，精修猛进，久得印可，列为曹洞宗第十六世。此后，应请主法于燕京奉福寺，时值金元交战，嵩山（今属河南省登封市境）少林寺因战火波及，毁损严重，福裕禅师奉朝廷之命入主少林祖道庭，目睹殿堂荒芜破败之状，发心重振。数年后，少林寺面貌一新。福裕以其学识精邃，修持严谨，名闻远近。门徒甚众，也引起官方重视。忽必烈未登基时就曾潜至少林寺，命福裕为其举办资戒法会。宋淳祐八年（１２４８）奉诏入主和林兴国寺，月余后，即应召入内廷，奏对称旨，辩答无碍，深得厚赏。不久，获授都僧省之职，“总领释教”。宋景定元年（１２６０）奉即位不久的元世祖忽必烈之召，赴内廷和道士李志常等辩论，得胜后焚道门伪经四十五部，被赐为“光宗正法大禅师”。此后，复受请执掌燕京万寿寺法席，达十四年。还主持在和林、燕蓟、长安、太原、洛阳五处建少林寺下院，元至元十二年（１２７５）于嵩阳圆寂。元皇庆元年（１３１２），仁宗追封为“晋国公”，赠“大司空，开府仪同三司。”
    福裕一生致力弘扬曹洞法门，“通群书，善翰墨，吟咏、题唱、普说几十万言。”于禅法亦有独到之处。有僧问如何是向上尊贵一路，福裕答道：“渔歌惊起少汀鹭，飞出芦花不见纵。”以其建树卓著，后人称为“款龙庭而振举宗风，敞五林而宏阐家教，因缘会合，倾动一时，”尤其在主法少林寺期间，福裕不仅使祖庭恢复旧观，而且远承曹洞祖师本寂所倡嫡传方式，确定宗门师承关系，新立“七十字辈”，即
    福慧智子觉　了本圆可悟　周洪普广宗　道庆同玄清　净一真如海　湛寂淳贞素　德行永延恒　妙本常坚固　心朗照幽深　　性明鉴崇祚　衰正善喜禅　谨悫原济度　雪庭为导师　引汝归铉路
    从少林寺僧人的法辈排列都以此为序。“现在少林寺的弟子们，称其祖号时，时常冠以‘雪庭座下第几人传人’。”福裕一直被尊为少林寺的中兴之主，其法嗣甚众，其中影响较大的有少室文泰、中林智泰、足庵净肃以及五峰慧庆、藏云慧山等。
    至温禅师（１２１７－１２６７），字其玉，号全一，邢州（属河北省邢台市）郝氏子。六岁薙发，十五岁投行秀门下为侍者，道业日深，“凡秀偈颂法语，一闻辄了，遂得法焉。”后受请入燕京华严寺。数年后得往昔在家挚友刘秉忠推荐，获元世祖忽必烈召见，留住内庭三年，多有赞益，赐“佛国普安大禅师”号，不久又“总摄关西四五路、河南、南京等路，太原府路、邢洛磁怀孟等州僧尼之事。”
    从伦禅师（１２２３－１２８１），字林泉，承行秀禅师传法后，相继执常燕京成寿寺和报恩寺法席。元至元九年（１２７２），应元世祖之诏入内，从容答辨，大阐禅理。元至元十八年（１２８１），作为当时佛道门争中佛教代表人物，在燕京悯忠寺主持焚烧除《道德经》以外的道教书籍，长座后即以火炬打一圆相，再行说法点火。有上堂法语：“禅禅禅，非正非偏。无意路，有玄渊，超今返古，绝后光先，但能忘影迹，何必守蹄筌。直指人心见性，须凭祖意通玄。九年面壁真消息，端的其中有秘传。”从伦教育后学，风格独迥。“妙用纵横，智体不动，子虽依倚，父全不知。撒乾盖而本自无心，踞坤与而端然有力，此亦寂而不动，感而遂通之朕兆也。于此半遮半露，似晦似明。绿竹猗猗有裴君子，孰能于是了别心佛之根茎枝叶者耶！虽有倚蒲危坐，虚室生白心孤圆，秋天独迥，犹须转身不居一争，直得雁回北塞，声噎南楼。木女初闻，石人遥听，只知日午是三更，那信天明方半夜，何也？月满犹亏，半乌沉始是圆。”在致力弘扬曹洞法门的同时，他以数十年精力，先后诠释义青和子淳二位禅师各自的《颂古百则》，撰成《林泉老人评唱投子青和尚颂古空谷集》（简称《空谷集》）和《林泉老人评唱丹霞淳禅师颂古虚堂集》（简称《虚堂集》）。在此之前虽然其师行秀著有《从容庵录》，但此二集的面世，对于其后曹洞宗僧人诠释公案和颂古有着重要的影响。
    金末元初，投行秀门下的在家皈依弟子不少，其中得其真传列为法嗣者有耶律楚材、李之能等。
    耶律楚材（１１８９－１２４３），亦名刘楚材，字晋卿，法名从源，号湛然居士，系辽宗室后裔。宿负奇志，以天下为已任，曾仕金为小吏，久而厌之，转而学佛。初从圣安和尚习禅，后改投行秀甚契合，曾在杜绝人迹处苦修三年，获师印可，元世祖闻其名，聘之，太宗时拜中书令，军国大计，悉取决焉，多有建树。中晚年以后尤以推崇公案评唱而著称。
    李之能（生卒年代不详），字纯甫，号屏山居士。宏州（今河北省原县）人，承安进士。少年习儒，学业卓著，且好莱坞排释老。后在邢台偶遇行秀，转而虔心向佛。继则深入佛典，并至少林寺参学，撰成《〈金刚经〉注》、《〈楞严经〉注》、《少室面壁记》等，弘传达摩西来之旨。后半生致力于弘扬曹洞法门，“开发后学，大有功于宗乘”。
    在福裕禅师法嗣中，继其后执掌法席于豫、京一带的有少室文泰、中林智泰、足庵净肃、永平义云等数十人。
    文泰禅师（１２２９－１２８９），字灵隐，阳城（今山西省太原市汾州境）魏氏子，少时即以聪慧出众，礼本乡智禅师出家受具，恒心修持。后从学于三藏德律师，依雪峰恒和尚参请多年，蒙授记。复至太原深和尚座下参学，再蒙印证。再至燕京万寿寺，参学于福裕，侍随十年，饱承钳锤，道业深邃。至元十九年（１２８２），入主少林法席达八年。初入，有上堂法语曰“劫来事，只在于今。河沙妙德，总有心源。诚教伊觌面相呈，便不解当风拈出，且道过什么处。”卓柱杖曰：“只为分明极，翻令所得此。”住持少林期间，整肃风规，再振祖庭雄风。至元二十七年（１２９０）圆寂。门下法嗣有还源福遇、秋江洁禅师等。
    智泰禅师（生卒年失考），字中林，汾阳渔城（今属山西省汾阳县）温氏子。少修儒业，后投本邑华严寺薙发，数载专事经律，却厌于经教名相，感到大丈夫当体究大事，焉能区区于此耶，改修禅悟。至大都（今北京）参学于万寿福裕禅师，依住数载，尽得精髓。后奉诏入主太原报恩寺，弘扬曹洞宗风，别有见地，有僧问：“如何是万里无草处？”答曰：“不是阇黎践履之境。”又问：“如何出门便是草？”智泰应道：“总出力即乖。”僧又问：“如何是不出门，亦是草漫漫地。”答：“住著即错。”僧再问：“如何得不涉动静去？”智泰说：“偏界绝红尘，通身无影像。”
    净肃禅师（生卒年不详），字足庵，保定永平（今河北省完县）张氏子。少年出家后即习禅修，参悟究心二十余载，参请善知识十余辈，仍未明了。后至燕京万寿寺，投福裕禅师，淘汰有年，得付衣偈。继佐弼积年，德誉远溢。于福裕禅师圆寂后，继主法席。后迁锡少林寺，主席九载，多所建树，任“河南府僧尼都提领”之职。再移居泰安灵岩寺，八年后移锡燕京万善寺，他提携后学，惯使棒喝。有僧问：“胡来胡现，汉来汉现，胡汉不来时如何？”净肃答：“桃花岁岁皆相似，人貌年年大不同。”僧问：“此意如何？”答：“不因你来问，山中太寂寥，且喫一顿了去！”举棒便打。晚年退居香山寿圣寺，寂于此。法嗣有古岩普就，月岩永达等。
    福裕法嗣中，五峰慧庆，藏云慧山等人虽未执掌法席，但对少林祖庭的振兴及曹洞法门的弘扬，功不可没。
    慧庆（？－１２８８），自号“五峰”，河南许昌蒋氏子，全家皈依福裕禅师，慧庆礼福裕为师，剃度出家，后到嵩山少林寺。泰定二年（１２２５），在振兴寺门、抵御外寇的关键时刻，慧庆为副寺，率僧护寺，多的建树。七年后，改任监寺，继为提点。慧庆倡印《福裕禅师法语开示》，并赴京请朝廷为恩师赠谥，又礼请名家程巨夫和赵孟兆为福裕撰书碑文，慧庆虔心护持少林祖庭数十年，奋力光昭前人之业，得授“大名僧录，正宗宏法大师”之号。
    慧山（１２４３－１３０８），号藏云，七岁至少林寺即投福裕师，后随侍至京师，再返少林。于少林寺任职事五十余年，先后任监寺、都提点，统领武僧。曾主持兴建转轮于少林，在熊耳山空相寺、南阳维摩禅寺的振兴中也多有贡献。
    元代曹洞宗少林一系，继福裕、文泰、净肃等禅师之后，到元贞元年（１２９５）由曹洞宗十八世传人还源福遇禅师执掌少林寺法席。
    福遇（１２４５－１３１１），字还源，霍州灵石（今属山西省）王氏子，少年时投本邑兜率寺薙发出家受具后，偏参四方，历游讲肆，雄辩如流，对答无碍，后往少林祖庭礼文泰禅师，饱承法益，遂得印可，纳为法嗣。至元二十三年（１２８６），于永兴寺（在今湖北省黄岗县）大开法筵。有僧问：“如何是祖师西来的大意？”福遇答：“风送泉声来枕畔，月移花影到窗前。”僧曰：此犹是声色门头事。”福遇叹曰：“卖私盐汉。”三年后，住洛阳宝应寺掌法席，元贞元年（１２９５）入主少林寺法席，十六年中声名远扬，至大四年（１３１１）退居洛阳白马寺。皇庆二年（１３１３）圆寂，有《语录》行世。门下法嗣甚众，影响较大者当推淳拙文才、空相、龙潭深、龙潭端等。其中淳拙文才曾在少林寺院执掌法席数载。
    文才（１２７３－１３５２），字淳拙，山西临汾姚氏子。其父静妙居士，虔心向佛。文才少年时至绛州福严和尚座下剃度，受具后读《证道歌》“幻化空身即法身”之句，欣然契悟，后谒福遇和尚于少林，获印可而传衣偈，为首座。不久，住龙门寺闭关三载，深入经藏。继则隐居于终南山，泰定元年（１３２４），受请入主少林寺，严奉戒律，率众虔心事佛，声誉蔼然。五年后，辞法席，退隐香严寺，诠释《楞严法界则》及《般若心经》、《沩山警策》等，复校正《四家语录》，锓梓以传。至正五年（１３４５），应请再次执掌少林寺法席，直至至正十二年（１３５２）圆寂。两度主法少林祖刹，贡献卓著。尤其是后一次为时八载，主持新建钟楼，修葺储粟之庄，重立《大元重建河南嵩山少林寺萧梁达摩大师碑》，后人称之“以繁达之资，卓绝之行，遗外势利而任道自居，大振祖庭之席，使普遇之灯，烬而再焰，亦可谓克绍直接之传矣。”法嗣有松庭子岩和日僧邵元等影响较大。
    就在文才禅师两度执掌少林寺法席的前后，净肃禅师的高足菊庵法照与普就禅师的法嗣息庵义让相继执掌少林寺法席。
    法照（１２５６－１３２３），字菊庵，保定雄州（今属河北省），赵氏子，少时聪颖出众，十三岁至本邑云居寺，投义满和尚座下，披剃出家。十六岁受具足戒，后潜心精研《金刚经》、《圆觉经》，力究《玄赞》、《华严》秘奥，历数年未悟玄旨，于是决志参学，闻净肃和尚在燕京万寿寺高唱曹洞宗门，时称法窟，慕其风而奔之。“枢衣室中，寅夕参扣。一语契机，心地开通，足庵许可，乃付法衣。”至元二十九年（１２９２）春，住持林州黄华山（今属河南林县）觉仁禅寺，广置寺产，丰裕常住。延祐五年（１３１８），迁锡云居，鼎新寺宇，多有建树。至治二年（１２２２）入主少林寺，次年秋圆寂。虽主法少林仅年余，但“播扬大教，能为佛法作主。革新鼎力，亦能为修造竭力，可谓本色住持之榜样也。”法嗣有子珍、子胜等。
    息庵（１２７３－１３４０），字义让，真定（今河北省正定县）李氏子，二十岁至本邑华严寺，礼相和尚为师，受具后投于讲肆，听习《华严》数年，后游访燕赵，往封龙山普就禅师门下，修禅习定。后随侍前往泰山灵严寺。皇庆二年（１３１３），再随普就禅师改锡少林寺。巾侍数载，机缘相契，乃得印可，列为曹洞宗第十九世传人。后相继主持香严，香山、法王诸寺。至治二年（１３２２），开堂于洛阳天庆寺。继迁锡于熊耳空相寺，泰山灵严寺。至元二年（１３３６）秋，应请入主少林寺。五年中，鼎新殿宇，丰裕常住，寺风大振，门徒云集。至元六年（１３４０）圆寂，葬少林塔林。法嗣有松溪子定、舜都宗等十二人。
    如前所述，元代曹洞宗的传承在北方以少林寺一系为代表，但与之同时的行秀、福裕诸代禅师的法嗣也于长城内外、中原大地高唱曹洞法门，建树突出者不乏其人，其中还有日僧数人，限于资料，仅述其中较突出者。
    日僧彻通义介（１２２５－１２８０），简作“义介”，于宋开庆元年（１２５９）来华，先后参谒径山、天童等名刹，后得法于行秀禅师，列为曹洞宗第十六世，景定三年（１２６２）归国，主法永平寺，是为日本曹洞宗第二世。
    福裕禅师门下觉印禅师先后于和林北寺、京兆华严寺，仲庆禅师于四川成都昭觉寺，守护禅师于台州安平寺、久善禅师于弁州太子寺、法兴禅师于巩昌广严寺、妙乘禅师于顺德宝云寺，广弘曹洞法门，嗣徒课众，为世人所瞩目。
    福裕禅师门下的义云禅师（１２５３－１３３３），本为河南洛阳俞氏子，随父入日藉后，投义尹门下为僧、后，复奉师命入华求法，嗣法于福裕禅师，列为曹洞宗第十七世。回日本后住持吉祥山永平寺。
    文泰禅师的法嗣洁禅师弘法于济南灵岩秋江寺。洁禅师的法嗣雪轩道成（１３５２－１４３２），河北保定赵氏子。十五岁出家，次年受具后即与两同参苦修于青州（今属山东省）土窟中。后至山东灵岩投秋江洁禅师，为入室弟子，参悟年余，方得印可。获“他日能弘吾道者必汝也”之嘉许，明洪武十五年（１３８２），应选统领释教。洪武三十年（１３９７），奉勅入主金陵（今江苏南京）天界寺，建文四年（１４０２），奉诏出使日本，永乐二年（１４０４）归国。二年后却“以僚佐谮，凿囹圄百余日，”后得雪冤。永乐六年（１４０８）奉旨于钟山主持“普度大齐”，登坛开示，听者达数万人。宣德七年（１４３２）圆寂。一生说法无数，参悟灼见甚多。上堂有云：“密密宣扬，万象光中独露。利名场上，荐取无位真人。人我山中，显示本来面目，影含宗鉴，心生种种法生，身是道场，心灭则种种法灭，”有《道成语录》、《雪轩集》等传世。
    净肃禅师之法嗣永达禅师得印可后，主法于西京（今河南洛阳）宝应月岩寺。普就禅师承净肃禅师所传法脉后，先后于封龙古岩寺、杭州灵隐寺主法多年，圆寂后于大德六年（１３０２）获朝廷追谥“妙严弘法大禅师”之号。
    文才禅师法嗣古源邵元（１３０５－１３８５），日本国僧人。泰定四年（１３２７）受天皇委派华学佛，先后参学于华顶、天目、龙山、五台等名山。继投少林寺文才禅师座下，随侍多年方得印可，列为曹洞宗第二十世。至正七年（１３４７）回国，住大圣、等持、东福等名刹，精通佛学，长于汉文书法，曾在少林寺撰，书祖师塔名碑数方，至今尚存。
    由此看来，元代曹洞宗在北方的传承堪称是代代相承，名僧辈出。然而，就现有的资料看，同一时期曹洞宗在南方的传承，则比较衰微。祖庭洞山（在今江西省宜丰县）普利禅寺的法脉到宋代末年多已不详，寺内住持大多系临济法嗣。另一祖庭曹（在今江西省宜黄县）本寂禅师法系早已失传。从近年出土的文物来看，曹洞宗二世道膺禅师弘法道场云居山真如禅寺（今属江西省永修县）在元代所传的法脉也是其他宗派的（其间一度传承藏传佛教）。当然，元代曹洞宗在江西也还是有所传承，也出现若干名僧，大证禅师就是其中之一。
    大证禅师（１２９７－１３６１），字无印，鄱阳）今属江西省波阳县）史氏子。幼时聪颖，素有善愿。十四岁剃发出家，受具后奉师命外出参游。初至江西庐山圆通寺参学于石琬禅师，因机缘不契，后往浙江天童参云外岫禅师，随侍有时，获印可，列为曹洞宗第十六世，并请为典藏，至治年间（１３２１－１３２３），以金书藏经得赐织金屈眴之衣，后丞相脱劝以行政院檄请出世主衢州（今属浙江省）南禅寺，虔州光孝寺（属今江西省赣州市），洪都（今江西省南昌）翠岩寺等，皆以疾固辞。元至正十五年（１３５５）入主奉化（今属浙江省）雪窦山资圣禅寺。后退居定水圆明庵终老。有《五会录》等传世。
    元代末年，少林寺虽然屡历战乱，毁损严重，甚至有不少金佛像被刮皮破背，但寺中曹洞钟板悬挂不断。明代之初，即洪武二年（１３６９）曹洞宗第二十世传人松庭子岩禅师即奉勅入主少林寺。
    子严禅师（１３０９－１３８２），字松庭。河南缑氏（今属偃师县）樊氏子。九岁至少林寺礼霁云禅师出家，十八岁受具足戒后，参法照、息庵皆有省发。后投文才禅师，得契入。复以《参同契》、《宝镜三昧》反复徵辨，疑碍尽去，得文才禅师印可，付以衣法，为曹洞宗第二十二世，不久，入主南阳（今属河南省）万安寺，继主郑州普照寺、大都（今北京）天宁寺、西京（今洛阳）天庆寺等。明洪武二年（１３６９），奉勅执掌嵩山少林寺法席，晋院之后，大唱曹洞法门，力田给众，丰裕常住。曾有诗曰：“乱后归来自耕耘，生涯辛苦与谁论，画拈块石驱山鸟，夜坐巢庵逐野豚。肠断秋风频击柝，目窥夜月以消魂。近来始识农夫苦，一饭仍思施主恩。”洪武十三年（１３８０）冬，就诏为慈孝皇后悼资冥福法会说法，获赐紫衣。有《松庭集》《子岩和尚语录》等传世，法嗣有凝然了改等人。
    了改（１３３３－１４２０），字凝然，嵩阳（今属河南省登封市）金店任氏子。少年时至少林寺，礼提点训和尚为师，二十岁受具后，至香山参月印禅师，未契。后参西京（今洛阳）天庆寺子岩禅师，“洞彻玄微，直踏重关，相依数载，尽其底蕴”，得印可，列为曹洞宗第二十一世。此后，归住嵩山二祖庵，洪武二十三年（１３９０），应请入主少林寺。上堂法语云：“祖师心印，不是有言，不是无言，不是有知，不是无知。岂可向言句下研究，意识中揣度哉。”主寺期间，整肃寺规，再振家风。以其行止端庄，四众皈敬，周、伊、蜀、秦诸藩王皆登山供养，不敢轻言迎请，后，明成祖赐“大国师”号。永乐十八年（１４２０）圆寂，有《凝然集》《凝然了改国师广录》等传世，法嗣有俱空契斌等。
    契斌（１３８０－１４５２），字俱空，平阳垣曲（今属山西省）王氏子，少时从重兴禅院无相和尚薙染，受具后至少林寺投了改禅师，经数载获印可，列为曹洞宗第二十三世，正统六年（１４４１），执少林法席，为第二十六代住持。力弘曹洞法门，于五位君臣之说有新见。僧问“如何是君？”答曰：“谁能窥测九重深。”僧又问：“如何是臣？”答曰：“万里河山点墨痕。”僧又问：“如何是君向臣？”答曰：“宝殿光含万化新。”僧再问：“如何是臣奉君？”答曰：“玉阶仙杖龙颜近。”僧又问：“如何是君臣道合？”答曰：“端拱无为天下平。”景泰三年（！４５２）圆寂，葬少林塔林，有《语录》传世，法嗣甚众，以无方可从较突出。
    可从（１４２０－１４８３），字无方，雒阳（今属河南省）许氏子。少时礼福先芘峰和尚剃度，受具后参学于龙潭顺超化宗和尚，不契。后参少林契斌禅师。以绵密阃奥，重加锻炼，深契五位君臣奥旨，方得印可，列为曹洞宗二十三世。后潜修于郏鄏定国寺（今河南洛阳境），成化九年（１４７３），奉勅执掌少林寺法席。有法语云：“佛祖宗乘，本无言说，但此段家风，非从外得，须七处徵心，八还辨见，方得到家稳当，不涉程途，汝知九峰不肯首座，百丈堕在陶窝，足见得人为难，而得理尤为难。如上多方，切须珍重。”成化十九年（１４８３）圆寂，塔于少林塔林。有《可从集》、《无方语录》传世。法嗣有月舟文载等人。
    文载（１４５４－１５２３），字月舟，别号虚白。通州（今属江苏省）王氏子。十三岁在本邑广济寺，礼白庵禅师为师剃度出家，十九岁于杭州灵隐寺受具足戒，后至少林寺参可从禅师，历三载苦修，始蒙印可，承曹洞法脉为第二十三世传人。后入主北京白塔寺，达三十余载。于此，严守戒律。“袈裟恒不离身”，“蹈不越间，”提倡认真修持，“迷时须假三教，悟后方知一字无。”弘治九年（！４９６），入主少林寺，为第二十八代住持，主法十六年，期间“奉行禅苑清规，整顿丛林懿范，接纳方来，淳淳不倦，积岁弊风，翕然鲁变。”祖庭寺风大振，法筵常盛，有《洞山余绪》等传世，法嗣千余人，影响较大者当推小山宗书，光大曹洞法门，盛绝一时。
    宗书（１５００－１５６７），字小山，号大章，顺德府南和县（今河北省南和县境）李氏子。少时聪慧出众，十岁入学，即通大义，十五岁至本郡开元寺，投钿和尚座下薙发出家，二年后往太行山中闭关。二十岁时慕文载禅师道风，前往少林寺投其门下。随侍八载，尽得洞上宗风，得印可列为曹洞宗第二十四代传人。此后，相继驻锡于西京（今洛阳）天庆寺、北京积善庵、宗镜庵。嘉靖三十一年（１５５２），少林寺常住派人前来迎请回住，未允。六年后，少林耆宿秉诚复请，又得朝廷同意，方应允前往。晋院后，即大开法筵于少林，座下门徒逾百。上堂堂连环发问，紧扣禅关。“朔风凛凛，湖海冰坚，截然众流，是什么境界？到这里，个个寒毛卓坚，更须转身一路始得，为什么？渐不见道，太阳门下，日日本秋，明月堂前，时时九夏。山僧今日，炉头添炭，髩后增貂，使个个白汗滴滴，通身轻快，还知么？”求学者礼赞曰：“冻云开岭岫，梅蕊喷清香。”四方衲子慕名云集，后驻锡于均州（今属湖北省的均县境）广通寺、沁阳（今属山西省）宝光寺等处。嘉靖四十四年（１５６５），又回到少林寺，再次执掌法席，次年，奉旨入主北京宗镜庵，隆庆元年（１５６７），于北京西山三学洞圆寂，有《小山别集》、《宗书语录》传世，法嗣入室者达数百人，突出者有蕴空常忠、幻休常润、隐庵如进等人。
    常润（１５１４－１５８５），字大千，号幻休。进贤（今属江西省）王氏子。少时习儒，尝研读姚江良知学。稍长，入伏牛山礼坦然和尚为师出家，受具后，至少林寺。礼宗书禅师，随侍苦修三载，究宗乘向上事，针芥相投，方得传法。为曹洞宗第二十五世，万历二年（１５７４），奉勅主法少林寺。晋院之后，力弘曹洞宗风。有僧以“如何是洞上宗风”求教，答曰：“月下三花树，峰前双桂枝”，启发他追寻达摩祖师之意，后声名大振，时侍席者凡百余人，其中突出者有无言正道、洪断诸缘、慈舟方念、敬堂法忠等人。无言正道曾继其后执掌少林法席。
    正道（？－１６０９），字无言，号雪居，洪都新建（今江西省新建县）胡氏子。少时出家于本邑上蓝寺（今南昌市佑民寺），礼玲和尚为师。二十岁时，至南岳净瓶崖随知休禅师习修禅定，久而未契，继而谒逊庵禅师于树屏，听法于东岩大方，受戒于无尽，偏参诸名山世刹。后至少林寺，参学业于常润禅师座下，于“月下三花树，峰前双桂枝”语中大悟，即呈偈：“云攒峰顶，月锁幽岩。木人拊掌，石女舒颜，”得印可，为曹洞宗第二十六世，常润禅师圆寂后的第十四年，即万历十年（１５９２），应请入主少林寺，执掌法席十七年，整复寺院，清规肃然，雄风再振。圆寂后，塔葬少要塔林，被誉为“僧中之杰，传涅盘心，吐长广舌。双桂开敷，三花屹嵲，一代时教，永存珉碣，”其法嗣甚众，徒嗣慧喜、徒孙海宽等相继主法少林。
    慧喜（１５６３－１６３９），字心悦，号寒灰，满城（今属河北省）刘氏子。少时从普济和尚出家，十六岁至盘山习禅，后相继师从于慈云、松谷、净渊等大德。又至少林寺，得正道禅师教诲，于言下悟入，纳为法嗣，为曹洞宗第二十七世，掌少林寺法席，崇祯六年（１６３３），主法于开封相国寺。崇祯十二年（１６３９）冬，辞归少林，寂于寺内，法嗣有海宽等。
    海宽（？－１６６６），字涵宇，号彼岸，直隶内丘（今河北省内丘县）王氏子。　十六岁出家受具后，投少林寺慧喜禅师，饱得钳锤，三年后得印可，为曹洞宗第睦十八世，主法开封相国寺，明崇祯十二年（１６３９），为少林寺住持。清顺治三年（１６４６），获清廷勅为少林寺方丈，却因病未能晋京请换新札。顺治十四年（１６５７），再次获清廷所颂勅命主法少林寺，约集法侣，力谋复兴少林祖庭，积十二年苦心经营，始竟厥功。康熙五年（１６６６）圆寂，有《五灯会元赞续》等行世。
    （二）曹洞宗在燕赵，大江南北的弘传
    明代曹洞宗少林一系法嗣甚众，除在少林寺执掌法席者外，还有不少弘法于燕赵，足迹遍至大江南北。仅常润禅师门下就有慈舟方念、智空了睿、龟谷妙银、无疑真信及于钟英居士等，法门兴盛，在中国禅宗发展史上产生一定的影响。
    方念（１５１０－１５９４），字慈舟，别号清凉，唐县（今属河北省境）杨氏子。十岁时，投金台大慈出家，为明生死之大事，受具后即遍游燕赵及豫皖。抵少林祖庭，参常润和尚于立雪殿。后至达摩祖师面壁处参习而得悟。呈偈“五乳峰前，好个消息，大小石头，块块著地”而得常润禅师印可，为曹洞宗第二十六世。二十八岁，入五台山闭关潜修三载。出关后，先后主法于桂阳（今属湖南省）东塔寺、建昌（今江西省永修县）云居山真如禅寺、滇之圆通寺（今云南省昆明市境）等名刹，晚年迁锡京师大觉寺，圆寂后塔葬五台南山，有《慈舟禅师广录》等传世。法嗣有湛然圆澄，法孙瑞白明雪、石雨明方等。
    了睿（１５３９－１６２４），字智空，内丘（今属河北省）张氏子。弱冠出家，先从学于本邑觉和尚，继参天然禅师，后遍历燕鲁之地，广访名师，未契。后至少林寺，投常润禅师，服勤五载，方得印可，为曹洞宗第二十六世，主法京师广慈寺，上堂，有僧问：“怀才抱德来时，和尚如何相见？”了睿答曰：“看君好似南阳隐，不待茅庐三请来。”僧又问：“知音有几人？”了睿反问道：“还记得梁甫吟也？”僧无语，了睿又说“虾蟆打鼓蚓吹箫。”后名振长安，诸刹相请开堂说法。因目睹憨山、达观二大师皆为弘法而罹难，愤然南返内丘，结草庵潜修，二十余年足不踰山。有法嗣智融等数十人。
妙银（生卒年失考），字龟谷，邯郸（今属河北省）苗氏子，少年时在本邑杜家庵剃度出家，稍长即遵师命外出游访。至少林寺，投常润禅师，随侍有年，得印可。为曹洞宗第二十六世，后开法于上党（今属山西省）宗教寺。
    真信（生卒年不详），字无疑，别号西岩，蓬山（今属山东省）刘氏子。少时于本邑寿田庵出家受具，即喜书《华严疏》，后参少林寺常润禅师，深究“看父母未生前”话头。力参数载，方得有省，呈偈：“貍奴今日翻觔斗，报道娘生鼻孔真，”得常润禅师印可，为曹洞宗第二十六世，不久，主法于象城净业寺。
    于钟英居士（生卒年待考），字见明，河南邺下人。少时习儒典，举孝廉后，屡上公车不第，在感今既不能遂志龙门，则改向选佛场中心空及第。于是参访少林，继至京都大慧寺，投常润禅师门下，严受钳锤，凡三载，获授记为曹洞宗第二十六世，再入科考，得进士及第，初知南宫，旋弃之，回邺下南端创广济、宝莲禅院等，开堂说法。
    圆澄（１５６１－１６２６），字湛然，号散水道人。会稽（今浙江省绍兴）夏氏子。十多岁即充邮卒。二十岁出家为僧，受戒后往参隐峰禅师，以“谁”字为话头，连续三昼夜初有省。继而苦参三载，看乾峰和尚“举一不举二”话头，方得彻悟。万历十九年（１５９１）于风涂谒方念禅师，得印可，授曹洞宗第二十七世法券，并许之曰：“子日后截断天下人舌头。”后开法于会稽广孝寺、径山万寿禅寺、嘉兴福城东塔寺。自万历四十二年（１６１４）以后的三十余年，相继人驻于会稽云门显圣寺和天华寺，登坛说法，力弘曹洞宗风，大倡“一心法门”以，主张以心统摄融会禅教净律，认为念佛是念此心，看教系辨此心，持咒则护此心，参禅乃参此心。此心即定、慧，非心外别有定慧。以心即定、慧，非心外别有定慧。以其修持严谨，法门深邃，法筵盛开，听众常盈数千，得其精髓者有近百人，而后代相传承，自成云门一系。此系影响较大者当推瑞白明雪、佛日明方、化山明盂等。著述有《宗门或问》、《慨古录》、《法华意语》、《楞严臆说》各一卷，《金刚三昧经注解》四卷、《涅盘会疏》三卷和《湛然圆澄禅师语录》八卷等传世。以其业续卓著，至今仍被人们誉为与慧经禅师齐名的“明代曹洞宗中兴祖师。”
    明雪（１５８３－１６４１），字瑞白，相城（今福建泉州境）杨氏子。少时聪慧机敏，至安徽九华山聚龙庵出家，受具于云栖寺。十八岁时，登会稽云门山，于显圣寺内参圆澄禅师，屡经勘验，复于闻钟声中大悟，呈偈得印可，为曹洞宗第二十八世，圆澄禅师圆寂后，继主显圣寺法席。不久，改主湖州（今属浙江者）弁山寺。迁虔州（州治在今江西省赣州市）崆峒寺，后入主洪州百丈山百丈寺（今属江西省奉新县境）。晋院后，大唱曹洞宗门，整肃寺规，率众实践怀海禅师倡导的“一日不作，一日不食”家风，祖庭面貌为之一振。明雪以率众众农禅，建树卓著，获“大智（怀海）再来”　之誉。明崇祯十四年（１６４１）三月在百丈寺内圆寂，塔葬于此。
    明雪禅师门下法嗣甚众，影响较大者当推元洁净莹、百愚净斯、破暗净灯等人。净莹（！６１２－１６７２），在浙江一带住持过多处寺院，嗣法弟子四十三人，有《传灯世谱》传世。净斯（１６１０－１６６５），南阳（今属河南省）人。二十六岁出家，次年受具后即参百丈山明雪禅师，经三载苦修印可。后开法于庐山等处。“凡所至地，数千衲子，而糗粮自充，师名胜古迹振珠林。”法嗣有智操等二十四人。并有《百愚斯禅师语录》二十卷、诗集《蔓堂集》四卷等传世。净灯禅师行业失考，仅知其曾三次主法于镇江（今属江苏省）焦山定慧寺，并传法嗣智先等人。智先（１６３５－１７０５），字古樵，仪徵（今属江苏省）张氏子。少时时至焦山投元孚和尚门下出家，后参净灯禅师得法，为曹洞宗第三十世，继净灯之后执掌定慧寺法席，达十余载，期间，力主改革旧制，变子孙庙为十方丛林，寺宇得以振兴，法筵更为兴盛。法嗣有敏修福毅、月辉了禅、芥航大须、济舟沈洮等人，相继主法定慧寺，渐形成影响不小的曹洞宗焦山系，一直传到清代，法脉相续，连绵不断。
    佛日（１５９３－１６４８），字石雨，浙江嘉兴陈氏子，少时习读儒典，喜究参研。二十二岁，礼杭州西筑和尚为师，学修净土法门。后阅《楞严经》得感应而改习禅定，即转至会稽（今浙江绍兴）云门山显圣寺，投圆澄禅师，多受棒喝，方得印可，为曹洞宗第二十八世。后又得圆澄禅师所断佛一枝，故后人称之为“断佛禅师”。后主法于浙江省瑞安象田寺，继主会稽云门显圣寺、温州禹航寺、宝寿寺等处。有《石雨明方法檀》二十卷传世。法嗣净柱（１６０１－１６５４），曾主法杭州龙塘、保寿诸寺，有《五宗续略》二十二卷传世。
    化山明盂（１５９９－１６６５），字三宜，参圆澄禅师，印可后，继主法云门显圣寺等，有《明盂禅师语录》二卷传世，法嗣有数人，其中净挺，法号浪亭，受法后曾执掌云门山显圣寺法席。香雪明有，于明天启四年（１６２４）得圆寂禅师印可后，主法上虞香雪庵。


二、寿昌法系

二、寿昌法系

    （一）曹洞宗在江南的支派
    明中叶曹洞宗少林法系中高僧辈出。其中有小山禅师法嗣蕴空常忠、幻休常润等。后者继主少林法席，前者则将法脉延衍于长江以南，师徒相续，连绵兴盛，成为明中叶后曹洞宗的又一大法系。
    常忠（１５１４－１５８８），字蕴空，建昌府（今属江西省抚州地区）常氏子。少时习儒，稍长致力研究姚江良知之学。后出游于镇江鹤林得季善和尚劝引，膺服佛法，于高度寺剃度出家。一年后，转至少林寺参学。投小山禅师，久受钳锤。继随小山禅师改住北京宗镜寺，服勤三载，深得玄理，得印可。为曹洞宗第二十五世。其后南下，返回建昌，起初在一僻处静修，后至新城（今江西省黎川县）癝山结茅习禅，长达二十余年。期间，不与闲人接触，独与罗汝芳、邓元锡二人交谈性命之学。“间拈《金刚》、《圆觉》，发挥宗门大意，及举向上事，剖决良知，扫除知解，皆超出情见。”常忠有感于“当嘉隆间，宇内宗风，多以传习为究竟，”因而“疾时矫弊，志欲匡经投至门下，始说法传徒、倾心调教，尽囊而付，使无明慧经成为继其之后的一代宗师。
    慧经（１５４８－１６１８），字无明，崇仁（今属江西省）裴氏子。少时聪颖，九岁入乡校，即问浩然之气是什么。十七岁弃笔墨，二十一岁偶读《金刚经》，如获故物，由是断荤酒决志出家。不久，来到癝山礼常忠禅师，执侍三载，知有教外别传之旨。于是，转往峨峰（在今江西省黎川县）结庐潜修三年。一日，闻僧问：“如何是道？”答曰：“大好山”，因而疑情顿发。八月中的一天因掘石忽裂而大悟，作偈曰：“欲参无上菩提道，急急疏通大好山。知道始知山不好，翻身跳出祖师关。”数日后返回癝山，将此偈呈常忠，遂得薙发受具足戒，许入室。得印可，为曹洞宗第二十六世。万历二十二年（１５９４），得一同参相劝，“岂以一隅而小天下乎”，即外出参学，礼少林祖塔，登五台山得遇瑞峰禅师，获器重。又于京都访云栖、达观等老宿。南还，入宝方寺（今在江西省南城县，系曹山本寂禅师卓锡别院），数年之中，苦心经营，重建禅堂，天王殿等。继入住新城寿昌寺（在今江西省黎川县），驻锡十多年，百废俱兴，雄姿再现。又建别庵下院二十余所，法筵盛开，高唱曹洞五位君臣之义，坐下随喜者数百人。对习禅，慧经承师传，反对讲习评唱，对学人无须钻研公案、机语。主张“参禅者须得禅源底要妙，方有话头分。”认为机语“无来由，没格式，但应机便用，实无有铺排着量之言。”慧经还教诲学人：“参学之士，道眼未明，但当看个话头，要立个坚固志，如一人兴万人敌，安其放意，杀出方了。如是最是省力，不须念经。不须拜指，不须坐禅，不须学文字，不须求讲解，不须评公案，不须受皈戒，不须苦行，不须安闲，于一切处只见有话头明白，不见于一切处。”主法寿昌寺的数十年间，慧经潜心修寺，“足迹不履城隍，竿牍不近豪右，日惟随众作务，众未及田，师（指慧经）已荷钁先至，虽栉风沐雨，亦无倦意。”万历四十六年（１６１８）正月，圆寂于寿昌寺内，塔葬寺侧山旁。在住持寿昌寺的十余年中，法筵广开，法嗣有博山元来、晦台元镜、寿昌元谧、鼓山元贤等，皆成为明末著名的曹洞宗师，继而形成寿昌一系。慧经为其法嗣徒众制订二十八字派，即：
    慧圆道大兴慈济　　悟本传灯继祖光
    性海洞朗彰法忽　　广弘行愿证真常
其门徒代相传承，直至清代末年。对于慧经中兴曹洞伟绩世人评价甚高：“寿昌当宗风寥绝之时，触心荆棘，狐狸作崇，其建立宗旨也特难，乃参悟既与德山、临济同堂，　而操履又与百丈、赵州共路。”
    元来（１５７５－１６３０），字大舣，号无异，舒城（今属安徽省）沙氏子。少时习儒，十六岁于金陵（今江苏南京）瓦楞寺（一说瓦棺寺）听讲《法华经》而向佛。后到五台山，投静安通和尚出家，习修天台止观。五年后，慕名至峨峰（在今江西省黎川县）拟参慧经禅师，见其貌似农人，遂未停留便去福建白云峰诛茅潜修三年，初得证悟。返寿昌寺，受慧经之嘱，苦参深究“看藏身没纵迹”之话头，后见人上树而大悟，得印可，授以心法，为曹洞宗第二十七世。此后，受师命为首座。次年，至鹅湖寺（在今江西省铅山县）访祩宏和尚弟子超华心和尚，受“菩萨毗尼”。期间，三次请益于祩宏和尚，获赠“演畅真乘”之嘱。后，隐居于信州（今江西省上饶）西岩祖印院。万历三十年（１６０２），主博山能仁禅寺（今属江西省广丰县）法席。入院之初，见故德韶国师道场荒废日久，于是“诛茅为屋，仅足容膝，而禅律并行，蹶然兴起。”至寺宇大体恢复之时，又改往福建，先后住建州董岩、仰山。天启七年（１６２７），入主福州鼓山涌泉寺。此时的涌泉寺，自明嘉靖二十一年（１５４２）二月遭回禄之灾以来，仍破败不堪。元来率众奋力振兴，立规饬绳，四众翕然。苦心经营至初见规模时，元来将其交徒住持，自己改往金陵（今江苏省南京市）天界寺。不久返回再主博山法席。二度主法博山，力弘曹洞法门，禅律并行，禅教兼重，并有所创新。首先，元来主张“参禅须要立得心真，便头正尾正，其间亦不颠倒。禅人若能以此持之以恒，方可修成正果。”认为禅人参学，有三种歧路要防止误入。其一是：“担佛傍家走，乃至求佛、求法、求禅、求道、求玄、求妙等，随处担一担子，通身都是佛法，如龟负图，自取丧身之兆，凤萦金纲，趋霄汉以何期。”其二是：“自作主宰，谓有甚佛可求，甚禅可参，甚道可学，只剥得净洁无依，谓是自己受用。”其三则是：“起世间贪痴罪，虽重犹轻；若将半洁之处谓之参学极则，此为最重，世间无有与等者！”而要防止误入歧途，禅人则更要识得病根始得。“第一，不得讲时算日。第二、不得敲冰洗澡。第三，不得围炉向火。第四，不得暗里偷光。第五，不得开眼作梦。第六，不得触树迷封。第七，不得逆风把舵。第八，不得易短为长。第九，不得伤风露骨。第十，不得钉椿摇橹。第十一，不得步步登高。第十二，不得从空放下。”只有断此十二种病根，总能得悟；只有认真能究话头，总是正道。同时，元来也不以参究话头而排除其他，主张在参究话头的同时深入经藏，“夫为学者，凡经律论三藏大小偏圆，靡不遍涉。”其次，元来主张“禅教融通”。认为“宗、教殊途，皆归一致；都城趋入，迟速不同。”以宗抑教，或是以教抑宗，“即是魔人”！宗与教非水火不容，两者之间“宗乃教之纲，教乃宗之目，举一纲则众目张”。再次，元来在教诲学人认真参禅的同时，主张融会禅净。在他看来，“禅、净无二”。“禅、净二门，非别立标帜。”因为“说净土亦得，说禅亦得；说净土即禅，禅即净土亦得。”而初进者不可会通，“当求一门深入，”总不至于顾此失彼。这样，元来以其独到的禅修，奋力振兴祖庭，声名大振、“弟子益进，朔即燕都，南尽交趾，望风而至者岁以千计。”其门徒甚众，如长庆道独、雪磵道奉、古航道舟、瀛山智暗，皆成为明末至清代曹洞宗大师，弘法于赣、粤、浙、闽等处，后人称之为慧经禅师寿昌一支的博山法系。此系的法派辈份，乃循元来禅师亲自制订，即：
    元道弘传一　　（一面一个文字，下面一个心字）光照普通
    祖师隆法眼　　永播寿昌宗
    博山法系遵此立法号，代相延承，传至清末。元来禅师虽于明崇祯三年（１６３０）圆寂于博山能仁禅寺，其法脉兴盛，名声远播。有《无异元来禅师广录》三十五卷、《博山无异大师语录集要》六卷等流传。
    道独（１５９９－１６６０），字宗宝，号空隐，广东南海陆氏子。自幼显善慧，钟情于三宝之物。稍长得《六祖坛经》读颂而益加崇佛。十六岁结茅潜修于归龙山，一住近十载，二十九岁，游访至博山，礼元来禅师，获印可，传曹洞法脉为第二十八世。后，住长庆寺（在今江西庐山），二年后，往罗浮山华首台，继迁福建雁湖寺。明亡之后，返粤中，驻锡海幢寺，寂于寺内。有《空隐集》、《宗宝法语》等传世。法嗣有祖心函可、瞎堂函显、木人弘赞等人。
    函可（１６１１－１６５９），字祖心，号剩人，广东博罗韩氏子。本出身于官宦世家，父曰缵，官至礼部尚书。可自幼习儒，却无意功名。父殁后，即投庐山长庆寺道独和尚出家，久得印可，明崇祯年间＊！６２８－１６４４）末，入金陵（今江苏南京）迎请《藏经》，挂单于栖霞寺，时值清兵攻占金陵，洪承畴旨要函可前去面谈，可拒之并以诗相讽讥，畴怒请诛可。可虽未被诛，却在遭酷刑之后奉朝旨迁往辽阳千山朝阳寺。在千山，可力弘禅法，聚谴谪明臣结“冰天诗社。”出家众有五至七百紧随左右。尽管遭此处罚，可仍于艰难之中力建佛寺。世人誉之一生“七坐道场，全提直指，绝塞罕闻，称佛出世。”圆寂后，有《剩人禅师语录》传世。
    函昰（１６０８－１６８５），字丽中，法号天然。祖籍广东南雄，后迁至番禺。俗姓曾，谱名起莘，号瞎堂，少习儒典，明崇祯六年（１６３３）中举，后赴京应试路过庐山，偶参道独和尚，初闻佛法，颇契入。崇祯十二年（１６３９）冬，弃仕至庐山归宗寺投道独和尚。次年随道独和尚迁住广东罗浮山华首台，潜心禅修，努力精进，久得印可，传曹洞宗法券，为第二十九世，不久，俗世全家父母妻儿弟弟媳妇等俱入空门。崇祯十五年（１６４２），改锡海云寺，法筵盛开，弟子不下百人。清顺治十年（１６５３），入主庐山栖贤寺，鼎新寺宇，重肃寺规。五年后，古刹面貌一新，昰却功成而退，回住广东罗浮山华首台。后改住广州海幢寺、丹霞山别传寺等处。康熙二十年（１６８１）应南康府（今江西九江市境）知府廖文英之请，再主庐山归宗寺法席，道居后，迁住金陵（今江苏省南京）报恩寺，有《瞎堂诗集》、《楞严直指》等传世。其法嗣影响较大的有起芸今盌、乐说今辩等数十人。
    弘赞（１６１１－１６８５），字在惨，号木人，广东新会人，俗姓朱，相传为明藩王之后裔。少即习儒，稍长即在本郡法云寺剃度脱俗，后往庐山参道独和尚，三载后得印可，授曹洞宗第二十九世。后返粤入主鼎湖山寺。以其通儒精释工诗文，故有“南明诗僧”之誉。平日多与士人高贤唱和，有《木人剩稿》等传世。法嗣有圆捷一机等数十人。
    道独和尚所传此支，至清康熙年间（１６６２－１７２２）仍宗门常盛。其中建树卓著者当推函昰法嗣在南粤与赣北弘法的起芸今盌、乐说今解、仞今今璧、海云今湛、梵音今音、性因今释、石鉴今见、来机今冉、广慈今摄、记汝今帾、子昭今诏、诃衍今摩、虫木今无，以及继函昰之后主法庐山栖贤寺的顿修，弘赞的法嗣圆捷一机等。
    今盌（１６１２－１６９０），系函昰禅师俗家弟弟。全家遁入空门后，于广东罗浮山华首台得兄传法，为曹洞宗第三十世。后改往光孝寺（在今广州市）。为重兴寺宇，以已善绘画吟诗之长，用书画募款，建业卓著，清顺治六年（１６４９），掌光孝寺法席，直至圆寂，有《语录》和《诗集》传世。
    今辩（１６１２－１６９７），广州麦氏子，字乐说。自幼家贫，奋习儒学。稍长，潜心梵藉禅法。二十五岁前后，由一行脚僧伴陪，至江西庐山栖贤寺投函昰禅师，后获印可，为曹洞宗第三十世。后相继主法广东番禺海云、海幢、庐山长庆诸寺。有《四会语录》、《梵纲经注疏》等行世。
    今璧（１６１２－１６１７），字仞今，又作仞千，广东宝安温氏子。出身于官宦世家，明亡后入空门，投函昰禅师，得印可，为曹洞宗第三十世，后返粤住番禺海云寺。
    今湛（１６１３－１６７７），字海云，广东三水李氏子。少习惯于儒曲，中年出家，礼函昰禅师，获印可，为曹洞宗第三十世。后能与兴建番禺海云寺，建树卓著。
    今音（１６１４－１６６１），字梵音，系函昰禅师俗家堂弟。随全家入空门后，投函昰禅师为法，为曹洞宗第三十世。后长随函昰禅师左右，晚年住番禺海云寺。
  今释（１６１４－１６８０），字澹归，号性因、恬因、茅坪衲僧、借山野僧等，浙江杭州金氏子，自幼习儒，明崇祯年间（１６２８－１６４４）中进士。官至给事中。南明亡后出家，投函昰禅师得法，为曹洞宗第三十世。相继主法广州海幢寺、仁化丹霞禅院等处。后以请藏归吴。中晚年后，潜心修持，深入经藏，勤撰注疏，有《遍行堂正续集》与《梵纲戒疏随见录》等行世。
    今见（１６１１５－１６７８），字石峰，广东新会杨氏子。少时习儒，明亡后出家，投函昰禅师午法，为曹洞宗第三十世。后到端州（今广东肇庆）执掌栖贤寺（一说庐山栖贤寺）法席，率众实践“农禅并重”之家风，业林道风肃然，于僧俗两界有佳誉。有《惜峰诗稿》传世。
    今冉（１６１８－１６８８），字本机，系函昰禅师俗家小妹。随全家脱俗后，先参学于道独禅师，中年时，承兄传法，为曹洞宗第三十世。后随兄住随州，以十余载精力尼众道场——无着庵。有《本机法语》、《无着集》传世。法嗣有尚已等。
    今摄（１６１９－１６８５），字广慈，号巢云，广东番禺崔氏子。初以白衣礼函昰禅师。修习禅法，三十岁前后剃度出家。又依师苦参三十余载，直至六十二岁方获印可，列为曹洞宗第三十世。有《巢云遗稿》传世。
    今帾（１６２０－１６９０），字记汝，广东新会潘氏子。童贞入道，礼函昰禅师为师习禅，中年得印可，为曹洞宗第三十世，后随师入住番禺海云寺，晚年弘法于西樵山。
    今诏（１６２０－１６９６），字子沼，系函昰禅师俗家侄子。全家人空门后，传函昰禅师法脉，为曹洞宗第三十世，承家学，善丹青，工诗文。初住广州光孝寺，继至番禺与海云寺的兴建。后面函昰禅师执掌海云寺法席。
    今摩（１６２９－１７０２），字诃衍，系函昰禅师俗家幼子。少时聪颖，习读儒典，早有文名，十多岁即为诸生。后随全家入空门，得法于函昰禅师，为曹洞宗第三十世，其后随其祖父隐居于庐山鹤鸣峰，潜心编著《鹤鸣诃衍杂录》，晚年归住番禺海云寺。
    今无（１６３３－１６８１），字虫木，号阿字。广东番禺万氏子。少年出家，虔心向佛，喜研书画。崇祯十四年（１６４１）至广东罗浮山华首台，礼函昰禅师为师，后随师迁居广州，久参有悟，得印可，为曹洞宗第三十世，继则奉师命与今盌等多方筹款，鼎新广州光孝寺。二年后，往辽阳探望师叔函可，留住千山数载，共弘曹洞法门于朝阳寺。清顺治十六年（１６５９），受请执掌朝阳寺法席，数年后，南下返粤，助师扩建海幢寺，清康熙七年（１６６８）为海幢寺首座，继任方丈。参禅数十载，体验甚深。同时，善丹青，工诗文，有《光宣台集》传世。
    明末清初以来，元来禅师门道独一支一传再传，延衍兴盛，且多居赣北与南粤，其中今冉座下有尚已（１６３０－１７１１），字无我，参今冉得法，为曹洞宗第三十一世，主檀度庵，以工诗擅丹青而闻名，有《无我集》行世。尚已有法嗣了观（１６７３－１７５３），号实妙，越南扶安同春人。初侍大汕禅师，二十三岁后于尚已禅师坐下得法，为曹洞宗第三十二世。后，归越南弘扬曹洞宗法，圆寂后，获谥“正觉圆悟和尚”之号。
    与道独门下一支盛传的同时，其同门雪磵道奉禅师及瀛山智暗禅师等则仍以博山能仁禅寺为中心，力弘曹洞法门。
    道奉（１５９１－１６７０），字雪磵，建阳（今属福建）龚氏子。少时习儒，十七岁偶听《楞严经》面明省，投本邑闻谷和尚出家。后因参禅之中疑情增多，而改往博山能仁禅寺（在今江西省广丰县）参学于元来禅师，初入即遭喝斥回闽化缘。归途中见舟中缆绳忽断而有悟，返回博山呈偈：“只这缆断，可惜吃惊。船头倒转，打失眼睛。他时更有通宵路，不涉途程意自明。”得印可，为曹洞宗第二十八世。顺治二年（！６４６），开法于广信府瀛山（今属江西省玉山县）顺治十三年（１６５６），入主博山能仁禅寺法席，整肃寺规，建树卓著。退居后迁住高泉普宁寺。清康熙九年（１６７０）圆寂，法嗣有宏瀚、宏裕等人。
    智暗（１５８４－１６３７），字雪关，上饶（今属江西省）传氏子。八岁出家，聪颖出众。一日读《六祖坛经》，于“火烧海底”句有疑，久参不契，乃往博山参元来禅师，究参船子“藏身”公案。一日，偶入油槽，见牛磨鼻拽脱有省，呈偈博山，未得许可。复闭关六载，矢志苦参，终得彻悟，获印可，为曹洞宗第二十八世。后主法于广信府瀛山寺，兼任博山能仁禅寺首座。崇祯三年（１６３０），元来和尚圆寂后，受请入住博山执掌法席。二年后，应福州曹观察之请，入主鼓山涌泉寺，退居后，迁住杭州虎跑寺，晚年返住瀛山寺，崇祯十年（１６３７）圆寂，有《摘灯录》、《炊香堂诗文集》、《雪关和尚语录》等传世。法嗣有元锡等。无锡（生卒年失考），字弘恩，号祖昙，江西瑞昌刘氏子。继智暗之后主博山能仁禅寺法席。
    （二）鼓山系
    曹洞宗寿昌系慧经禅师门下另一高徒元贤，获印可后相续主法于文丰博山、福州鼓山等处，于鼓山时间尤长，其门下法嗣甚众，代相传承，史称之为“鼓山系。”
    元贤（１５７８－１６５７），字永觉。建阳（今属福建）蔡氏子。少时习儒，尤喜程朱之学。二十五岁借读于山寺，闻诵《法华经》而为之新奇，视为有别于程朱之说的一大事。于是进而从习《楞严》、《法华》、《圆觉》一经，明万历三十一年（１６０３），决意弃儒向佛，即至董岩报恩寺（在今福建省福清县）依慧经禅师习禅，万历四十五年（１６１７），由慧经剃度出家。次年，慧经圆寂后，元贤往博山依止元来禅师三年，受具足戒，四十六岁闭关三载，深入经藏，后应请入主鼓山涌泉寺，明崇祯八年（１６３５）开堂说法。继主泉州（今属福建）开元寺、杭州真寂院等处。一生“开堂三十载，未尝轻许学者。”盛名远扬，道席常盛，依止座下“率二百余人，问道，受戒，不啻数万人，得度若干人。”其中，影响较大者乃为霖道霈。元贤以儒入释，得法后，广弘曹洞宗法。互怀“刚强傲骨救禅”之愿，为后人留下了不少著述，其中较著名的有《继灯录》、《补灯录》、《建州弘释录》、《法华私记》、《楞严翼解》、《楞严略疏》、《金刚略疏》、《般若心经指掌》《洞上古辙》等。同时，整理和续编了《泉州开元寺志》与《鼓山志》。
    在上述著述之中，元贤阐述了自己的见解，认为临济与曹洞两宗禅学具有一致性，“予三十年前学临济，三十年后学曹洞。自胡乱后，始知法无异味。”在《洞上古辙》中对五位君臣、偏正回互等曹洞宗义作出新的解释，并将曹洞宗旨的源头归结于希迁的《参同契》，认为《参同契》乃“洞宗之源也”。同时，针对当时讲经注经中出现的“轻狂之士”任意发挥，以致“违经叛圣”的现象，元贤认为很不妥，主张讲经注经既不可全抄古注旧说，更不能曲解经义，而应当“俾以旧解为指南，间有未安者乃旁采众说，或出私意以翼之，”很注意发挥自己的禅观来弘法，对于禅、教、律三门，元贤认为“本是一源”，后世因智力弗能兼而分为三。但三者“如鼎三足，缺一不可，合之则俱成。”元贤见解深邃，至今仍被人们推崇为“是继元来之后曹洞宗最有影响的禅师。”
    道霈（１６１５－１７０２），字为霖，号旅泊、非字叟，建宁（今属福建省）丁氏子。自幼承家学习儒，少年时即为县诸生。十五岁弃儒至建州（今属福建省）白云寺出家，三年后受具足戒。后一对鼓山涌泉寺，投元贤禅师，经二十余载，终于四十二岁时蒙印可，为曹洞宗第二十八世。同年十月。元贤圆寂后，继主鼓山法席。数年后，相继主不支于崇福、白云、万福等处。清顺治十六年（１６５９），回博山能仁禅寺执掌法席。一生潜心经教，著述宏富，主要有《秉拂语录》、《还山录》、《云山法会录》、《旅泊庵稿》、《圣箭堂迷》、《禅海十珍》等，同时，数十年弘法生涯，严守戒律，认真修持，声名远播，闻法者数千人，常随弟了数百，但仅传衣钵于惟静道安一人。道安递传恒涛大心，圆玉兴五、象先法印、淡然法文等，直到近现代。
    （三）东苑系
    慧经禅师的另一个门徒——元镜禅师，弘法于建州（今属福建省）东苑，传觉浪道盛等法嗣，形成慧经寿昌系的一大支派——东苑系。
    元镜（１５７７－１６３０），字晦台，号镜如、湛灵、建阳（今属福建）冯氏子。少时性喜游侠，成年后折节向佛。明万历三十二年（１６０４）剃发脱俗后，潜心参究《楞严经》而有省。继至宝方寺（今属江西省南城县）参访慧经禅师，精研《维摩经》，再读《圆觉经》读至“急水滩头快打球，”疑窦释然，即呈偈曰：“识破不值半文钱，可怜摸索几多年。宗流尽是欺心汉，说甚祖师别有禅”，得印可，为曹洞法脉第二十七世。万历四十三年（１６１５），奉师命随师兄元来至福建大仰。三年后，改住建州东苑。泰昌元年（１６２０），择武夷山中石屏山肇建一枝庵，开坛说法，道筵极盛，后被尊为“武夷第一代禅祖”，法嗣甚众，影响较大者有觉浪道盛等，为清初曹洞宗一代宗师。有《晦台元镜禅师语录》传世。
    道盛（１５９２－１６５９），字觉浪，号杖人，柘浦（今属福建浦城）张氏子。少习举业，早有文名。十九岁弃儒入佛门，至鼓山涌泉寺投瑞岩和尚出家，明万历四十四年（１６１６），奉师命至董岩（今属福建）为慧经和尚祝寿，即在其门下受具。后参博山元来禅师，次年，至建州东苑，服膺元镜禅师。获元镜嘉许曰：“吾寿昌这支慧灯属子矣。”即获法衣，为曹洞宗第二十八世，万历四十七年（１６１９），始于江南设坛说法，崇祯八年（１６３５），入主新城县（今江西省黎川县）福船寺。数年后，移锡庐山圆通寺，主法三载。曾一度主法于洪都永宁寺（今南昌市佑民寺），清顺治二年（１６４５），至建昌云居山真如禅寺（在今江西省永修县）住静数载。后入主金陵天界寺。清顺治十二年（１６５５），执掌博山能仁禅寺法席，顺治十三年（１６５６）偕徒嗣药地等赴宜黄（今属江西省抚州地区）曹山，主持重建曹洞宗祖师本寂和尚墓塔。顺治十六年（１６５９），于回金陵天界寺休夏期间圆寂，塔葬栖霞山。
    道盛一生致力光大曹洞法门，自明万历四十七年（１６１９）出山弘法以来，偏与闽、赣、楚、吴、越及江淮，“展坐具阅历五十余年，声名洋溢，无间华夷。”门下徒嗣甚众，传法弟子二十七人，秉戒衲子不计其数。法嗣之中突出者当推竺庵大成、笑峰大然、药地大智等人。著有“佛祖儒老内外篇集百余种”，影响较大的有《会祖规》、《尊正规》以及《天界觉浪禅师全录》三十三卷等。其中《尊正规》的内容“以佛菩萨及诸宗祖出世为人，种种经律论藏，净土、止观、忏法等，门庭施设，堂奥深微，始终本末，折入禅宗，为集佛祖大成，已无余蕴矣。”《会祖规》则是“追孔子集大成之意，”集禅宗五家之大成，会“五家门庭堂奥之宗旨，不致流弊而无传也。”在些著作中，道盛以“一岁之统四时”为喻，把佛教尤其是禅宗五家进行排列：“沩仰则如春之生育，临济则如夏之明露，云门则如秋之严峭，法眼则如冬之精纯，曹洞则如四季之统化也。”以这样的观点为理论基础，提出以禅宗为核心概括佛教历史演化全过程的“六种纲宗”。“予昔阅《五灯》，见从上佛祖经络之事，乃作《法印记》，有六种纲宗：一参悟，二印证，三师承，四法嗣，五家风，六付嘱。始终虽分为六，实统于一参悟也。”这样的见解，虽有些牵强，但也自成一家，别具特色。
    大成（１６０９－１６６６），字竺庵，湖南长沙（一说江西瑞昌）龙氏子。少时聪颖，七岁即能作诗，及长，为明诸生。明亡后，至南岳剃发出家，受具后闭关十载，道业猛进。出关后，往博山能仁禅寺参智暗禅师，转至金陵天界寺投道盛和尚，三载后获印可。清顺治四年（１６４７），出主栖霞寺（在今南京）法席，期间，素以文字禅著称，金陵士大夫多重之。闻建昌祖庭毁于火，于清顺治十年（１６５３）率徒众草履跋涉回新城（在今江西黎川县），得邓来沙居士襄助，修复事宜顺利告竣，并于此执掌法席，至圆寂。著有《会圣堂集》、《指据录》、《摄山南岳诸汇》等传世。法嗣有楚云、兴沛等。
    大然（１５８９－１６６０），字笑峰，江宁（今江苏省南京）倪氏子，谱名嘉庆，字笃之。明天启二年（１６２２）进士，曾任给谏、户部和兵部正郎。后因遭诬党事而入刑部监狱七年，明亡后为僧，投道盛和尚、久参悟，得印可，为曹洞宗第二十九世。后入主青原山（今属江西省吉安市）净居禅寺。曾主持编纂《青原山志》刻印传世。
    大智（１６１１－１６７１），字无可、弘智、行远、墨历、木立、王老，号药地愚者、浮山愚者。桐城（今属安徽省）方氏，谱名以智，字密之。出身书香门第，少时习儒学，稍长即有文名，明崇祯十三年（１６４０）中进士，授翰林院检讨，明亡后，于梧州（今属广西）云盖寺出家，清顺治九年（１６５２）夏外出云游，行履遍及江西庐山开先、归宗、温州（今属浙江）黄岩、湖北玉泉诸名刹。次年（１６５３），至南京天界寺投道盛禅师，受具足戒，数载后获印可，为曹洞宗第二十九世。同年，于高座寺（在今江苏南京）看竹轩闭关。清顺治十二年（１６５５）秋，以父亡奔丧而破关。三年后，至庐山，再入赣中，先后执掌新城（今江西黎川县）天峰禅寺、癝山寺、寿昌寺、南谷寺、金溪（今江西省金溪县）疏山寺，南城县（今属江西）资圣寺等处法席。清顺治十六年（１６５９）主持兴建癝山塔院，清康熙三年（１６６４），入主青原山净居禅寺法席，鼎新寺宇，开堂说法，接引后学。大智虽中年出家，却由儒入释，别有见地。恒持“一心为道，放下世俗体面”之愿，深入经藏，潜心修竺。认为“世缘为分贫富生死所累，便于般若背驰。”对于禅修，主张“不二不一，犹不信乎？……一在二中，尚有疑耶？——三才之论，盛衰各变；经藏之节，缓急各变。”启迪学人“阐示宗教，释儒互济，中和为本。”门下法嗣甚众，影响较大的当推兴斧、兴贤、兴盅等。清康熙十年（１６７１），于万安（今属江西省）一舟上圆寂。有《药地炮庄》、《浮山后集》、《青原愚者智禅师语录》等数十种著述传世。世人称“先生合忠臣、孝子、才人而一人矣。性命之学，三才物理之学，声音文字之学，与夫一技一艺，莫不窃其源，造其极，记古今第一奇男子，名甲天下。”更有“四真子”（真孝子、真忠臣、真才子、真佛祖）之誉。
    大汕（１６２０－１６９８），字石濂、石湖、石头、号厂翁，吴江（今属江苏省）徐氏子（一说江西九江人）。少年出家，及长至金陵天界寺投道盛禅师座下，久参获印可，为曹洞宗第二十九世，清顺治年间（１６４４－１６６１）入主广州长寿寺，鼎新殿堂，多有建树。清康熙年间（１６６２－１７２２）之初，受越南国王阮福迎请赴越南弘法年余，纳越南弟子法嗣多人，归国后，著《海外纪事》三卷。一生于参禅之余，喜弄丹青，尤以山水、花卉见长、佳誉远播。另有《大汕语录》、《离六堂集》等传世。
    大权（生卒年失考），字叶妙，广昌（今唱江西）吴氏子。幼年聪颖多艺，九岁至广昌大觉寺剃度，后于本县白米岩结茅潜修，拜颂《华严经》，日夜不辍，三年不卧席。此后，至新城（今江西省黎川县）寿昌寺，参学于大成，于皋亭（在今浙江省杭州市东北）遇道盛禅师，从学左右，后研读《楞严经》有悟，得印可。为曹洞宗第二十九世。反返广昌，隐居于妙峰庵，闭关十余载，深入经藏。清康熙八年（１６６９），入住青原山净居寺为首座。次年冬，大智禅师因病退居后，掌净居寺法席，直至圆寂。有《青原语录》、《竹隐栖漱青堂诗集》等行世。
    大浩（?—１６６４），字其天，虔州（在今江西赣州）信丰杨氏子。早显善根，幼时即喜持素，弱冠出家，二十四岁得天界寺道盛禅师印可。返赣后，主法新城（今江西省黎川县）寿昌寺，率众劳作，鼎新殿堂，力弘曹洞法门，衲子闻风而至者常有千指。清康熙三年（１６６４）寂于寿昌寺。
    慧经禅师另一高足——元谧，驻锡新城（今江西黎川县）寿昌寺，弘扬曹洞法门，多有建树。元谧（１５７９－１６４９），字暗然，一说阒然，号见如，建昌府南城（今属江西省南城县）胡氏子，一说豫章（今江西省南昌）王氏子。二十岁断荤酒，至宝方寺（在今江西省临川县），礼明铠和尚为师，继受具足戒。一年后返宝方寺，先为火头，继充维那，一夜在金栖峰坐静，闻蛙声而有省，述偈：“虚空逼塞一蛙声，大地含灵共一家。十字街头新眼盾，自歌自唱哩莲花。”得印可，为曹洞宗第二十七世。后游五台，再回宝方寺，众请住持，辞之曰：“愿终身居学地，不欲出世。”因而潜往福建建宁。三年后，归住新城寿昌寺，执掌法席二十多年，力弘曹洞法门，修葺殿堂，丰裕常住。晚年获悉宝方寺毁于火，又前往主持重建。同时重振新城龙湖禅寺。有《见如元谧禅师语录》一卷传世。法嗣有道到此为璞等。
  慧经禅师门下，除元来，元贤、元镜、元谧等高徒外，还有其元禅师。真元（？—１６３８），号本寂，光泽（今属福建省）邓氏子。二十一岁投了空和尚出家，旋至云栖受具。不久，赴新城寿昌寺，礼慧经禅师，随侍三载，方获印可，得承曹洞法脉。明万历四十三年（１６１５），入主青原山净居禅寺。数年之内，苦心经营，祖庭面貌焕然一新，为“重兴青原中兴祖师。”


三、常润法嗣

三、常润法嗣

    明中叶以后，曹洞宗在江南呈中兴之势，常忠传慧经而后形成的“寿昌法系”是重要的一支。而常润高足敬堂法忠与洪断诸缘在赣域的弘法，也建树卓著。
    法忠（１５４１－１６２０），号敬堂，歙县（今属安徽省）曹氏子。十九岁于钱塘（今属浙江省）灵隐寺礼大机和尚出家，三年后于杭州灵隐寺受具足戒。后参学至嵩山少林寺，礼常润禅师，获印可，为曹洞宗第二十六寺，后走长安，谒偏融、月心等，获示心要。六年后，南下登庐山，先住讲经台、五老峰，再迁仰天坪，诛茅伐竹，肇建云中寺，四方衲子闻风而至者甚众，久之而成丛林，于率众弘法之同时，亲手植松十余万株，获世人嘉誉。泰昌元年（１６２０）寂于寺，塔葬庐山桃花峰下。一生严守戒律，“居恒坦夷，无缘饰，御众不立规矩，凡细务必以身先，至老不倦，随缘自守。”有法嗣能幻、能握、能撑等。
    诸缘（１５５０－１６２１），字洪断，其俗姓、籍贯与出身至今有二说。其一说为蒿城（今属河北省）张氏子。另一说称其为“明慈圣太后淑房国戚，俗姓陈。”幼时父母双亡，但早现善慧，十四岁即或荤腥，十七岁至崇效寺投兴阳禅师出家，二十一岁在京师宾湖和尚座下受具足戒。二年后游学南岳，遇少林常润禅师即往亲近，获印可，许为法器，为曹洞宗第二十六世。明万历七年（１５７９），入京掌西山古基万佛堂法席，得慈圣皇太后施厚金开建为十方海会丛林。经十三载苦心经营，万佛堂面貌一新，法筵大开。万历二十年（１５９２），获悉素有“曹洞宗祖庭之一”之誉的建昌云居山（今属江西省永修县）真如禅寺，由于地方豪强掠夺，破败不堪，以致“千尺盘桓到上方，云居萧索实堪伤。最怜清静金仙地，返作豪门放牧场。”发心重振之。入住后，闭关三载，跪诵《华严经》，整肃寺规，接着整修寺宇，再建法幢，得到朝廷支持。万历二十四年（１５９６），慈圣皇太后遣中贵至云居山贵至云居山挂旛，赐钱与紫衣、法器等，道风大振，原住持真绍主动退居，礼请诸缘和尚执掌法席，自己率寺僧真鍊、真锦、真潮、真泰等礼诸缘和尚为师，改法名为常鍊、常锦、常慧、常智等。明万历二十七年（１５９９），神宗御书匾额与柱联赐云居山真如禅寺。万历三十一年（１６０３），诸缘入京，慈圣皇太后施金铸造渗金千佛宝莲户舍那大佛像为镇寺之宝。次年，又获颁赐《大藏经》。因而，寺风大振，声名远扬，经诸缘历二十余年艰辛，率众惨淡经营，真如禅寺重视祖庭雄姿。与此同时，诸缘和尚还有江西许多地方传法讲经，其中有云居山只树堂禅寺、龙溪寺、瑶田寺、万载县杨山净觉禅院等数十处，使曹洞宗风，被及赣域大地。诸缘和尚将曹洞法脉数代祖师名号归纳，拟订本系六十四字辈份：
    善义德福　慧证海觉　真智圆明
    洪常祖道　法性清净　广启胜因
    志行维远　承悟元宗　宽裕平和
    坚持戒通　光续曹源　佛灯昌隆
    禅心朗彻　宝镜昭融　如珠照乘
    似日凌空
    万历四十年（１６１２），诸缘留嘱常慧等散居各庄庵静住，而将真如禅寺法席虚之以待高贤，以公法化，自己则返回京师静住。
    诸缘离赣后，其门徒遵其嘱散及江西各地，后多成一方宗师，形成与寿昌法系并列的诸缘法系，推进了明末清初曹洞宗的中兴，在中国禅宗发展史上有十分重要的地位。
    （一）云居山法系
    据新近发现清乾隆三年（１７３８）初刻、嘉庆三年（１７９８）增订重刻本《曹洞诸缘支宗传灯宗谱》（简称《诸缘公支派谱》）记载，继诸缘禅师之后，明末及清代在赣域承其法脉，建树卓著有秀峰常锦、味白常慧、云隐常月、首山常元、知悟常亨、丹田常鍊等人。
    常锦（生卒年待考），字秀峰，号蛇山。生平行业不详。于诸缘和尚鼎兴真如禅寺的万历二十六年至四十年＊！５９８－１６１２）期间，具体负责殿堂修复工程，多有建树。完工之后，遵师嘱隐居于云居山西北麓龙溪寺（遗迹至今犹存）。后诸缘和尚离山，真如禅寺一度主持乏人。应常住之请，常锦与常慧回真如禅寺代理寺务，凡四载。其后，仍回龙溪寺潜修，圆寂后，塔葬龙溪寺侧。
    常慧（１５５７－１６４３），字味白，号龟山。豫章胡家坊（今属江西省南昌市郊）胡氏子。幼时聪慧，早显善根。十五岁时，至本邑千佛寺剃度出家，受具后外出参访。明万历二十六年（１５９８），至云居山真如禅寺，参诸缘禅师为入室弟子。不久，得印可，为曹洞宗第二十七世。同时，　受请为常住之书记。而后，与师兄常锦等辅佐诸缘和尚重振真如禅寺。诸缘禅师离寺返京外出时，负责应对来往，广结外缘，联络檀越。万历四十年（１６１２），遵师嘱住守云居山只树堂禅寺。次年，就常住敦请再回真如寺，与师兄常锦共掌寺务。万历四十四年（１６１６），常锦回龙溪寺后，常慧乃支撑寺务，至崇祯十年（１６３７）观衡和尚晋院后，方履行交割。退守只树堂禅寺。崇祯十六年（１６４３）圆寂，塔葬云居山赵州关东侧龟山，其座下法嗣甚众，突出者有祖乐、祖辛等四人，代相传承，至清嘉庆三年（１７９８），已传及十三世，成为云居山曹洞宗的一大支系。
    常月（１５６８－１６２９），字云隐，吴江（今属江苏省）人。俗姓朱，为明宗室后裔。幼习儒业，少为诸生，名标虎榜。稍长弃儒向佛，至京师万佛堂投诸缘和尚出家，继则随侍左右，面命耳提，久得印可，为曹洞宗第二十七世。万历二十四年（１５９６），随诸缘禅师南下，重振云居山真如禅寺，四年后，携徒祖悟等开法于新吴（今江西省奉新县）富溪普安禅师。崇祯二年（１６２９）圆寂，塔葬寺侧。门徒甚众，代相传承，至清康熙十一年（１６２７），其第八世法孙我愿仍主法于普安禅院，其师兄长修诸人则在百丈山（在今江西省奉新县）等处弘法。
    常元（１５６７－１６３２），号首山，祁门（今属安徽省）于氏子。少习儒学，早有文名。弱冠时父母双亡，二十二岁弃儒而嘱意归隐，慕豫章（今江西省南昌）龙沙之识，往来于灵官坛、浮云观，研习老庄之学和许逊净明道教义。后偶读及《龙舒净土文》、《归元直指》等，心遂向佛，径往杭州云栖寺礼莲池大师，得净土要义，恒心念佛，著《长生元义》、《度世真诠》、《净土发蒙》等。明万历二十九（１６０１），至云居山真如禅寺，礼诸缘和尚出家，随侍数载，阅毕《大藏经》。继而外出参学，登匡庐（即庐山），南及楚地与岭南，东历江浙，遍访名师，道业日深，著成《初住境观》、《法海元津》、《五教别谈》，并以“十力同真没古今，由来观其异观心。欲圆种智亲知识，保任何如薝蔔林”偈呈古心和尚，而得受具足戒，返云居山得诸缘禅师印可，授曹洞宗法券，明万历四十一年（１６１３），率徒开法于敖阳（今属江西省上高县）芭蕉园普慧庵，广弘曹洞法门，并著有《禅净通别》、《怀净土诗》、《华严法界图》、《八识规矩补注》、《云居集》等。法嗣甚众，有祖施、祖靖、祖允、祖欣、祖慧等三十四人影响较大，继其后开法于普慧庵等处。祖欣（号斗山）所嗣一支由敖阳普慧庵迁居钤北夏塘乡（今属江西省高安市）另立普慧庵下院，至清嘉庆三年（１７９８），已有十三世传承了。另一法法孙移居宝云山（今属江西省上高到），肇基建普云寺，又衍法嗣数十人。于是，常元门下至清乾嘉年间（１７３６－１８２０）的法脉衍延兴盛，成为赣中佛门禅宗一大支派。
    常亨（１５７３－１６５０），字知悟，进贤（今属江西省）余氏子。少时习儒，稍长弃儒学佛，至北京万佛堂投诸缘禅师出家。数年后，礼古心和尚受具。复至北京，随侍诸缘禅师，许久得印可，为曹洞宗第二十七世，明万历二十四年（１５９６），跟诸缘禅师，重振真如禅寺，后奉师命卜静闽中，首住佛迹岭。明万历四十二年（１６１４），迁乐安（今属江西省）芙蓉山，重建芯蒭禅林，历四十年艰辛，躬自锄荒，奋力开辟，相继建成大雄宝殿、龙华殿等。清初戒显和尚来此造访，惊呼：“俨如至天上云居。”“堪与祖心并峙也。”常亨于清顺治七年（！６５０）圆寂，塔葬寺侧。法嗣有海云、慧云、志云、继云、祖满等，相继在此弘扬曹洞法门，至清乾嘉年间仍兴盛不衰。
    常鍊（生卒年失考），号丹田。行业不详，圆寂后塔葬云居山西塔，有法嗣祖星，祖明等数十人，一直在云居山法云寺、普慧寺等处弘法。
    （二）清代以来诸缘系的法脉：
    又据《曹洞宗诸缘支宗宗谱》载，诸缘禅师门下的法脉，入清以后极衍延不断。仅至清嘉庆三年（１７９８），云居山上常鍊、常慧法嗣已传十多代。常鍊门下有为慧、为智等第二十八代十余人。常慧门下有德衍、行衡等数十人，是为第二十七代。在敖阳（今属江西省上高县）、筠阳（今属江西省高安市）等处，则有常元、常月法嗣弘传曹洞宗法门，其中突出者为法祥、觉慧、觉峰、素怀、胜诚等人。
    法祥（１６６５－１７２７），字应瑞，分宜（今属江西省新余市）传代子，少有悟性，至本邑桐柏山薙发，受具后游访至钤阳（今属江西省高安）万寿庵，投道严和尚座下，二载后得印可，为曹洞宗第三十五世，后承师业，鼎新殿堂，增置田粮，丰裕常住，屡得县署褒扬。清康熙四十七年（１７０８），瑞州（府治在今江西省高安市）知府彭年赠匾“真见如来”。四年后，知县王松又赠额“慈光普照”清雍正五年（１７２７）圆寂，其法嗣至清嘉庆三年（１７９８）仍络绎不绝。
    觉慧（生卒年失考），号净行，上高县（今属江西省）墓田刘氏子，系清代名士朱轼的表弟。少时失怙恃，即投上高莲花庵性坚和尚出家，受具后外出参学三载，返莲花庵，即随师闭关阅藏。“举凡《法华》、《楞严》诸经及《传灯录》靡不毕览。”出关后，道业日深，得印可，为曹洞宗第三十八世。清康熙五十六年（１７１７），主席莲花庵，率众伐木运石，修葺殿堂，晚年更穷究佛典。至县城主坛盂蘭法会，空巷随喜，轰动城闾。其法嗣至清嘉庆三年（１７９８），仍有下传七世之法孙志明等数十人。
    素怀（１７１２－１７７４），字广安，高安（今属江西省）石桥况氏子。少习儒，二十七岁至本县环秀山投志隐和尚座下薙发脱俗。入佛门后严守寺规戒律，二年后礼净任和尚受具，复参志隐和尚得印可，为曹洞宗第三十九世。后继师之志，常莲花庵法席，数十年中，严奉戒律，鼎新殿堂，声名远播，法筵常盛。法嗣有百林、百城、百道等。至清嘉庆三年（１７９８），已下传五世。
    觉峰（１７４１－１７９３），字因悟，高安皇塘彭氏子。少时习儒，尤喜书法。十五岁时至本县东华寺礼胜云和尚为师，数年后至黄檗山（今属江西省宜丰且以）礼有庵得连和尚受具。复回东华寺，随侍胜云和尚，二年后得印可，为曹洞宗第四十二世。继则闭关近十载，博通儒释诸书，工诗古文辞，尤其是真草日臻炉火纯青之境。平日以画墨竹及枯松、怪石自娱。清乾隆三十六年（１７７１）始，杖锡远游，登匡庐，跻五老峰，望彭蠡，转新昌（今江西省宜丰县）石台寺，见此宋代名僧惠洪弘法道场，年久失修，荒芜蔓草，发心重振之。于是率众诛草建殿，历数年艰辛，复其旧貌。功成而退，仍一笠一杖飘然而去，至上高九峰崇福寺，又驻锡奋力振兴之。在此三次开坛授戒，戒子数百，声名远扬。法嗣有志蘭、志祥等数十人。清乾隆五十八年（１７９３）圆寂，肉身不坏。法徒志蘭等将其肉身供奉于高安东华寺。
    综上所述，元、明、清以来曹洞宗的衍延传承颇为昌盛，而且宗风大进，名僧辈出，建树突出。雪庭福裕一系传至小山宗书后，下分出常调、常忠两支、常忠两支，常忠传无明慧经，繁衍出寿昌系，下又分出博山系、鼓山系、东苑系；常润一支传至诸缘、方念，又形成西云居山系及赣中的支系。而且，福裕的法嗣义云、邵元还把曹洞宗继续传向日本；博山系下的尚已一支，则通过了观，传往越南。这在中国禅宗、中国佛教史及至中外佛教交流史上都有十分重要的影响。


一、印简与“临济正宗”

第十三章

    临济宗发展到元代，分为南北两大传承系统。北方以海云印简为代表，南方则以高峰原妙、中峰明本、天如惟则等为代表。印简一系与蒙古贵族关系密切，在元初被奉为“临济正宗”，势力很大，但在禅学思想上并没有多少创新和发展。南方临济宗不仅保持宋以来丛林禅学的特点，而且对宋代“看话禅”等传统禅法有所丰富和扩展，从而使临济宗风仍保持一定生机和活力。

      一、印简与“临济正宗”
    印简（１２０２－１２５７），字海云，俗姓宋，山西岚谷宁远（今山西岚县）人。自幼出家，从学中观沼禅师，十一岁受具足戒，中观沼圆寂后，印简到燕京大庆寿寺，从学于中和璋禅师，并接续其禅法。１２３５年，窝阔台差官选试天下僧道，印简被推为住持。１２４７年，贵由皇帝命他统领僧众，赐白金万两。１２５１年，蒙哥即位，命印简掌管全国佛教事务。印简死后，忽必烈命建塔于大庆寿寺之侧，谥“佛日圆明大师”，前此，成吉思汗曾赐号“寂照英悟大师”，成吉思汗的二皇后赐号“光天镇国大士”。印简历事成吉思汗、窝阔台、贵由和蒙哥四朝，所受朝廷重视和隆渥，无出其右者。
    印简是一位政治活动能力很强的禅师，他利用自己的道望和地位，做了许多保护佛教、卫护汉文化的善举。如忽必烈曾向他请问佛法大意，印简趁机进鍊，要忽必烈广求天下大贤硕儒，谘问古今治乱兴亡之道。忽必烈深为折服，不仅从之受菩萨大戒，而且赐以金缕袈裟，奉以师礼。临别，忽必烈问佛法如何受持，印简曰：
    信心难生，善根难发。今已发生，务须护持，专一不忘。不见三宝有过，恒念百姓不安，善抚绥，明赏罚，执政无私，任贤纳谏。一切时中尝行方便，皆佛法也。
禅宗讲求应机说法，对士大夫应士大夫之机，对宰官应宰官之机，禅宗一国权柄者，当然就该应帝王之机。印简对忽必烈，没有讲空讲有谈玄说妙，而是对治国方略坦呈已见，言言在理，句句当机，无怪乎朝廷内外皆以师礼待之。
    至大二年（１３０９），赵孟頫奉敕撰《临济正宗碑》，把印简一系奉为临济正宗，他的传统法系被追溯到北宋的五祖法演：法演传天目齐，齐传懒中和，和传竹林宝，宝传竹林安，安传容庵海，海传中和璋，璋传印简。自临济义玄下数，印简为第十六世。元武宗时代，印简的再传弟子西云安，受赐“临济正宗之印”，并对为荣禄大夫、大司空，“领临济一宗事”，印简一系在临济宗中的正统地位，得到朝廷的认可和维护。
    考诸史实，宋代五祖法演的法嗣，除著名的“三佛”外，还有开福道宁、大随元静、无为宗泰、五祖表自、龙华道初、九顶清素，以及元礼首座、普融藏主、法众上座等，其间并不见天目齐的名号。而且自天目齐以下以至中和璋，都是不见于僧传的无名禅师。
    印简一系禅师留下的文字资料极少，无从见其禅风全貌。《海云大士传》载，印简年轻时问道于中观沼，沼诲之曰：
    汝所欲文字语言耳，向去皆止之，惟身心若槁木死灰，今时及尽，功用纯熟，悟解真实。大死一场，休有余气，到那时节，瞥然自肯，方与吾相见。
    此处不见有特别之处。而“槁木死灰”的说法反倒与曹洞宗的“默照禅”相类。印简的悟道因缘，据说是在行脚途中，夜宿岩下。因击火而火星迸射，当下豁然大悟。在中和璋禅师处，中和举临济“两堂首座齐下喝”因缘，印简竖拳一拍，当时丈堂震动，遂受中和印可。印简常以“四无依”语勘学者，机缘不契即棒打出去。所有这些都并无独特之处。
    印简有两位知名弟子可庵朗和赜庵儇，可庵朗有俗弟子刘秉忠。刘秉忠原是僧人，得印简举荐，为忽必烈近侍，《元史》本传说他“久侍藩邸，积有岁年，参帷幄之密谋，定社稷之大计。”在元朝初年拜光禄大夫、太保、参领中书省事，是一位有相当影响力的人物。刘秉忠和前面提到的西云安禅师，对印简一系在禅宗中持续兴盛起了重要作用。
    由上述事实可以看出，海云印简一系能够争得“临济正宗”的地位，全赖印简等禅师世缘殊胜，得到元朝朝廷的隆遇和外谋，而与其禅学上的成就没有直接关系。


二、祖先与南方临济

二、祖先与南方临济

    南方禅宗是临济宗天下，有影响的禅师多出于大慧宗杲和虎丘绍隆两支。大慧的弟子以佛照德光（１１２２－１２０３）最为知名。他曾历主名刹，弟子众多，并入宫说法，得到孝宗皇帝的欣赏。德光之后，出现了灵隐之善和北磵居简两支。之善系的元叟行端（１２３５－１３４１）有“再世妙喜（宗杲）”之誉，在元代初年与元朝廷关系密切，十分活跃，居简系的笑隐大欣（１２８４－１３４４）亦历主名刹，元帝赐“广智全悟大禅师”，加赐“释教宗主兼领五山寺”号，荣宠一时。
    这一系禅师虽然是大慧宗杲的嫡传，但在禅风上却与宗杲不大相同，甚至截然相反。如行端一生，“以呵叱怒骂为门弟子慈切之诲，以不近人情行天下大公之道”，与宗杲教导弟子老实参话头不同，而笑隐大欣更是直斥参话头的虚妄，“每见近时宗师教人提个话头……使其朝参暮参，疑来疑去，谓之大疑必有大悟。虽是一期善巧方便，其奈愈添障碍。”虽然大欣所斥责的是禅僧中的“愚痴之辈”，但他显然对看话的功效是深表怀疑的。
    有意思的是，真正继承并发展宗杲看话禅的却是虎丘绍隆一系的禅师，具体地说，是绍隆系中破庵祖先一支。
    虎丘绍隆（１０７８－１１３６），与守杲同出圆悟克勤门下，晚年常住苏州虎丘，其《明教大师像赞》曰：“春至百花触处开，幽香旖旎袭人来。临风无限深深意，声色堆中绝尘埃。”可以看出是一位很有证量和学问的禅师，但在当时的声望远不能与宗杲相比。绍隆传应庵昙华，昙华传密庵咸杰，咸杰有弟子破庵祖先和松源崇岳。这两支皆有知名禅师出世，绍隆一系的影响超过宗杲一系，崇岳一支的禅师在思想上无甚创新，而祖先一支不仅法脉昌盛，思想上也很活跃，元朝南方最著名的禅师大都出自这一禅系，代表了元以后临济宗的传承。
    祖先（１１３６－１２１１），广安（四川宁西）人，俗姓王，字破庵。出家后往参密庵咸杰，修临济禅法。咸杰住持灵隐寺时，令他“分座”训徒。曾有僧问：“猢狲捉不住时奈何？”师曰：“用捉作么？”如风吹水，自然成纹。”是说心性本静，不必刻意求静，有专讲《楞严》的座主求开示，祖先说偈曰：“见犹离见非真见，还尽八还无可还。木落秋空山骨露，不知谁识老瞿昙。”祖先初住夔州卧龙寺，后又至江浙一带住持多处寺院。祖先有弟子无淮师范（１１７４－１２４９）等，师范年轻时在灵隐寺侍奉祖先，闻“木落秋空”偈而得悟，曾住持焦山、雪窦、阿育王、径山等名山大寺，受赐“佛鉴禅师”号。无准师范传法断矫妙伦。断桥，天台人，长期追随无准师范，参叩问疑，分座说法。据说初参师范，范问：“从何处来？”答曰：“天台。”范曰：“还见石桥么？”答曰：“我一脚踏断也。”从此丛林称之为断桥伦公。其示众法语云：“晓来一阵春风动，开遍园林一样花。”很能反映祖先系禅师长于诗文、以诗谈禅的风格。断桥妙伦的法嗣为高峰原妙，高峰原妙及其弟子中峰明本等，以创造性的禅学理论和实践，丰富发展了大慧宗杲的“看话禅”，使禅宗在宋末元初获得了新的生机。


三、原妙及其禅法

三、原妙及其禅法

    高峰原妙（１２３８－１２９５），吴江（江苏苏州）人，俗姓徐，十五岁出家，十七岁受具足戒，十八岁习天台教义两年，二十岁弃教从禅，至杭州净慈寺，就学于断桥妙伦，并立下三年死限，剋期求证。妙伦让他参“生从何来，死从何去”，原妙因只是从意识分别处理会，而妙伦亦未指示做工夫的入手处，故一年有余，仍只如迷路人相似。后参雪岩祖钦，祖钦令其参赵州“狗子无佛性”话头，有所省悟，知道了真正用功处。后又到径山参禅，经半月，于梦中忽然忆起断桥妙伦所举“万法归一，一归何处”话头，顿发疑情，直疑到“东西不辨，寝食俱忘”的程度。后见五祖法演和尚真像赞，其末后两句云：“百年三万六千朝，返覆元来是这汉。”豁然大悟，打破漆桶，绝后再生。其时恰好是二十四岁，距其发愿参禅也恰是三年。
    原妙这时的开悟只能算是破初关，所以他并没有就此止步，而是广泛参访叩问。１２６５年从法钦住天宁寺。法钦问：“日间浩浩时作得主么？”答曰：“作得主。”又问：“睡梦中作得主么？”答曰：“作得主。”又问：“正睡著时无梦无想无见无闻，主在什么处？”原妙当下被问住，只觉“无言可对，无理可伸。”法钦嘱咐他：“从今日去，也不要你学佛学法，也不要你穷古穷今，但只饥来吃饭，闲来打眠，纔眠觉来，却抖擞精神，我这一觉，主人公毕竟在什么处安身立命？”原妙自恨资质迟钝，不得要领，遂独自到临安龙须山，隐居苦修，自誓“拼一生做个痴犬汉，定要见这一著子明白。”苦修五年，某夜有同宿道友推枕头堕地作声，原妙蓦然打破疑团，从前一切疑问都涣然冰释，自此横行天下，机锋锐利，不让古人。
    原妙出道后，转入武康的双髻峰，适逢元兵南侵，宋恭宗德祐二年（１２７６），“学徒避兵回去，师独掩关，危坐自若。”南宋灭亡之年（１２７９），他隐遁天目山，于山中凿一石室如舟，号为“死关”，掩室独修十五载，直至逝世。临终遗偈曰：“来不入死关，去不出死关。铁蛇钻入海，撞倒须弥山。”其超尘出世的高邈道风，吸引了大批禅僧前来参问。１２９１年，提举鹤沙瞿为原妙建“大觉禅寺”，成为他的评价亦极高，《新续高僧传》评之“弘悟普度，名冠元世。”云栖祩宏则称其禅风“近有慈明妙喜之风，远之不下德山临济诸老，”将原妙列于一流禅师之列。
    （一）“入门三关”与“入室三关”
    原妙晚年所居“死关”，高居山崖，上溜下淖，惟惜梯纔能上达。禅师的门风亦如“死关”，高峻险绝，难可凑泊，非上根利器不能登堂入室，窥其堂奥。
    他有勘验学人的“三转语”，即：“大彻底人，本脱生死，因甚命根不断？佛祖公案，只是一个道理，因甚有明与不明？大修行人，当遵佛行，因甚不守毘尼？”若学人回答不契，原妙即拒而不纳，因此虽然到天目山参学者达数万，但得其接引印证者寥寥。此三转语从常情来看，都是相互矛盾的。“大彻底人”即拔却生死命根，超脱生机，不受后有的大彻大悟者，何来命根不断？佛祖公案皆引导初机、破妄显真的方便手段，不可以思维理性去分别猜度，本无所谓明与不明。而三皈五戒是对修行人的基本要求，大修行人焉有不守毗尼（戒律）的道理？
    对此三转语，若是中下根器，会以思维卜度求解会，结果只会转求转迷；若是根器稍利者，会依言起修，若真能严守毗尼，死参万千公案所含的“一个道理”，并于生死命根处著力，则参究日久，亦有进境；若是上根利器，则言下起疑情，并以大愤志于此疑团奋力参究，务期彻底究明此事。惟有后者总是原妙所能接受的真正修行人。
    原妙特别标出此三转语似乎另有深意在，因为当时丛林禅风凋零，禅僧不守戒律，不求正悟，只于古人公案妄加穿凿，盲传瞎授，徒呈口利，无真证量。原妙以此三转语勘验学人，确有警策学人真参实悟的用意。原妙说：
    往往学道之士，忘却出家本志，一向随邪逐恶，不求正悟，妄将佛祖机缘、古人公案，从头穿凿，递相传授，密密珍藏，以为极则，便乃不守毗尼，拨无因果，人我愈见峥嵘，三毒倍加炽盛。如斯之辈，不免堕于魔外，永作他家眷属。
    如果能透得此“入门三关语”，则说明学人已明了修禅的旨要，没有走向邪路，还可以予以接引，否则就说明学人根机未熟，还未入道。故“非具大根、负大志，鲜不望崖而退。”
    原妙又有“入室三关”，即：“杲日当空，无所不照，因甚被片云遮却？人人有个影子，寸步不离，因甚踏不著？尽大地是个火坑，得何三昧，不被火烧？”天日并不会被片云遮却，之所以会给人以暗无天日的假相，是因为人为乌云遮望眼。即不是日被片云遮却，而是人看不到。人踩不着自己的影子，是因为有我执，如果换个思维角度，不是从“我”出发，而是让他人也参与进来，让他人去踩，则踩着影子又有何难？“三界无安，犹如火宅”，欲出火宅，须修戒定慧，证得“无心三昧”，以般若智慧的清凉，消除烦恼欲火，而不被烦恼之火所烧。原妙此三转语同样是让学人脚踏实地，真参实悟，若根机未熟，而妄求顿悟，反不如勤修三学，熏习佛种，以待机缘。同样能反映原妙这种主张的是他对古人公案的看法。如“丹霞烧木佛”是椿流行很广的公案。一些禅师围绕这则公案聚讼纷纭，但大多认为这是启悟众生的方式，原妙则认为这根本是无稽之谈。他说：“丹霞烧木佛，为寒所逼，岂有他哉！若作佛法商量，管取地狱如箭。”参禅是大丈夫之事，非小根劣器而能为。对大多数学佛者来说，与其于古人公案盲提瞎颂，乱加穿凿，反不如严守毗尼，老实修学来得稳当。
    （二）万法归一，一归何处
    原妙的参禅的方式也是参话头，不过与宗杲所能赵州“无”字话头不同，原妙所参话头为“万法归一，一归何处？”这一话头与宗杲“无”字话头一样，也源自赵州从谂的公案。据《赵州禅师语录》载，有僧人问：“万法归一，一归何处？”从谂答：“我有青州作了一领布衫，重七斤。”可以看出原妙所参话头是截取公案的问话，而宗杲的话头则是截取公案的答话，当然他们所选择的公案也不同。这种不同并没有多少佛理依据，主要是源于他们各自不同的参禅经历和开悟因缘。原妙开始亦曾参“无”字话头，但用功三载，不曾有悟，心识非昏沉即散乱，用尽伎俩，也不能打消此昏散二魔。遂放弃这种修法。后来参究有得，原妙认为参“无”字话头的病根，在于不易使学人起疑情，即使能起疑情，也不容易把得住，常被昏散二魔所打散，而参原妙的话头则不同，“且是疑情易发，一举便有，不待反覆思维计较作意。”
    “万法归一，一归何处？”也是禅林中被广泛提唱颂的话头。“万法”，泛指世出世间一世事物和境相；“万法”所归之“一”，当指人的“一心”或“本心”。禅宗的重要理论依据是惟识宗的万法惟识思想，心生则种种法生，心灭则种种法灭，一心生万法，万法归一心。禅宗正是在此基础上建构即心即佛的修学体系的。但就这一话头而言，能生万法之“一心”是当体即空的。它本身就是绝对、一般、永恒，所以在它之上没有更高的存在，因此如果单就这一话头回答，则“一无归处”，如果一定要回答其归处，则一般寓于个别，永恒显于瞬间，绝对不离相对，此“一心”也恰恰存在于万法之中。
    不过在禅宗，解禅不等于参禅，禅师是很忌讳做以上思量解会、计较分别的。此一话头也只是逗发禅机的方便手段，对学人来说，拈提此问，等于为师家出难题，以此激发师家的灵感，以期在师家的答话中透见“真消息”。而对师家来说，则正好借题发挥，向学人展示其大机大用，使学人发疑情、断妄想、证真如。
    比较“无”字话头与“一归何处”话头，可以看出原妙选择问句而不选择答句，似乎还有其它原因。因为如果只就发疑情而言，“无”字话头并不比“一归何处”逊色，但“一归何处”确实更易下手，容易将学人导向参究一途，这实际上反映了当时丛林禅僧素质下降的现实。另外，参哪种话头更易发疑情，对具体修行者来说并无定准，全看各人的因缘，而将一已之开悟经验普遍化，认为自己藉以开悟的话头就是开悟的惟一话头，让四面学人人人参究，则将“活句”又变为死句。境界如宗杲、原妙者犹不免此病，解脱之难，于此可见。
    （三）疑以信为体，悟以疑为用
    原妙参话题，与宗杲一样强调发疑情，而且这种疑情必须是建立在对参话头的绝对信心和信念之上。
    须知：疑以信为体，悟以疑为用。信有十分，疑有十分；疑得十分，悟得十分。
    至于信的含义及在参究中的地位，下面再论。这里给人强烈印象的原妙对“疑”的强调。古德有言，大疑大悟，小疑小悟，不疑不悟，这与儒家所说不愤不启似有相近处，但都是泛泛而论，对由疑致悟的具体机制和过程并无详论，原妙则不然。原妙对如何起疑有详细说明：
    先将六情六识，四大五蕴，山河大地，万象森罗，总熔作一个疑团，顿在目前，……如是行也只是个疑团，坐也只是个疑团，著衣吃饭也只是个疑团，屙屎放尿也只是个疑团，以至见闻觉知总是个疑团，疑来疑去，疑省力处，便是得力处。
    当然“疑”本身不是目的，目的在于由起疑、决疑而开悟：
    西天此土，古今知识，发扬此段光明，莫不只是一个决疑而已，千疑万疑，只是一疑；决此疑者，更无余疑。既无余疑，即与禅迦、弥勒、净名、庞老不增不减，无二无别，同一眼见，同一耳闻，同一受用，同一出没，天堂地狱，任意逍遥。
    “一疑”即“一归何处”，为什么究明此疑即意味着大彻大悟了呢？原妙认为，所谓大彻大悟即洞彻“生死大事”，亦即明了生从何来，死往保去这一人生根本问题。而众生之所以不能了办生死大事，原因在于有“我执”，有人我的分别与执著。“须知人我即生死之根，生死即人我之弃。要去其叶，必先其叶，必先除根。根既除已，其叶何存？”要除生死之根，又从何处入手？原妙认为应参话头、起疑情。起疑情的功用，首先是可以空净其心。人在未觉悟之前，无明妄识、恶知恶觉充满人的心识，起疑情，并时时处处疑之，则一切妄情妄念悉皆扫荡干净，只有此时，“般若灵丹，方堪趣向”，再进一步，疑来疑去，疑到成为本能，则心识路绝，人法俱忘，用原妙的话说则是：
    直得胸次中空劳劳地、虚豁豁地，荡荡然，无丝毫许滞碍，更无一法可当情，与初生无异。……到这里蓦然脚蹉手跌，心华顿发，洞照十方，如杲日丽天，又如明镜当台。不越一念，顿成正觉。
    这种人法俱忘的境界，就是消除了人我障碍、我执法执的解脱境界。由此可见，“疑”在参禅过程中，与“信”一样是积极的，肯定的精神活动，是消除根本烦恼、体悟宇宙人生实相的重要途径。
    （四）无心三昧
    由疑到悟的具体表徵，原妙以“无心三昧”来概括。原妙自述昔年参“万法归一，一归何处”话头，疑情顿发。以至“废寝忘食，东西不辨，昼夜不分。……虽在稠人广众中，如无一人相似。从朝至暮，从暮至朝，澄澄湛湛，卓卓巍巍；纯清绝点，一念万年；境寂人忘，如痴如兀。”他又教导弟子发疑情要坚持不懈，直到：“吃茶不知吃茶，吃饭不知吃饭，行不知行，坐不知坐。情识顿净，计较都忘，恰如个有气底死人相似，又如泥塑木雕底相似。”这种“如痴如兀”、“计较都忘”的境界，即原妙所称的“无心三昧”。原妙将这种境界与达摩的“心如墙壁”、孔子的“三月忘味”，颜回的“终日如愚”、贾岛的“取舍推敲”相类比，由此可见，这种境界是一种精神高度专注，由此导致物我两忘、心波不兴，宁静安祥的状态。
    古来大德也多有“平常心是道”“无心是道”的说法，但原妙特别强调“无心”非无所用心，而是经过勤苦修行，久久纯熟后获得的自在境界，是大死一回后活转过来的超然境界“
    古云：”莫道无心云是道，无心犹隔一重关。”何止一重，更须知有百千万重在。苟不发愤志精进，下一段死工夫，岂于木石之有异乎？凡做工夫到极则处，必须自然入于无心三昧，却与前之无心天地相辽。
原妙为警策学人真实用功而不为“无心”之言所误，以古德苦修事迹激励学人。“世尊雪山六年，达摩少林九载，长庆坐破七个蒲团，香林四十年方成一片。”学人只要信得及、作得主、把得定、不计危亡得失，总有发现本地风光的时候。
    （五）参禅三要
    原妙在“示众法语”中提出参禅三要：
    若谓著实参禅，决须具足三要：第一要有大信根，明知此事如靠一座须弥山；第二要有大愤志，如遇杀父冤雠，直欲便与一刀两断；第三要有大疑情，如暗地做了一件极事，正在欲露未露之时。十二时中，果能具此三要，管取剋日功成。
    关于发疑情在参禅过程中的意义前已论及，那么“疑情”与此处的“信根”又是什么关系呢？从原妙对“信”字的多方说明看，信是参禅的根本，疑是方法手段，信是体，疑是用，信比疑对参禅开悟来讲更为重要。如原妙讲：“大抵参禅不分缁素，但只要一个决定信字，若能直下信得及、把得定、作得主、不被五欲所撼，如个铁橛子相似，管取剋日成功。”又说：“从上若佛若祖，超登彼岸，转大法轮，接物利生，莫不皆由此一个信字中流出。故云‘信是道元功德母，信是无上佛菩提，信能永断烦恼本，信能速证解脱门。’”这里的信，是指对人人皆有圆满如来德相的信念，指对参禅开悟的信念，因有此信念而痛念生死无常，生出离想，绝世忘缘，奋力参究。
    有了参禅悟道的信念，就会生发愿心，尽平生之力究明此事。原妙形容为蚊子咬失牛，一切不问，只管下嘴，又如急水滩头泊舟，丝毫不可放松：
    直须发大志，立大愿，杀却心猿意马，断除妄想尘劳，如在急水滩头泊舟相似，不顾危亡得失、人我是非，忘寝绝餐，绝思绝虑，昼三夜三，心心相次，念念相续，答定脚头、除你手足、剜你心肝，乃至命终诚不可舍，到这里方有少分做工夫气味。
这种拼却身家性命也要证得本地风光的精神意志，就是原妙所说的“大愤志”。原妙试图由此恢复古来大德古朴谨严的禅风，荡除当时丛林视参禅为游戏的轻浮飘荡的作风。
    当然只有大信根、大愤志还不够，还必须掌握正确的参禅方法，如果找不到真正的参悟门径，即便拼却性命，也难以开悟。原妙认为有两种参禅误入歧途者：
    嗟乎末法，去圣时遥，多有一等泛泛之流，竟不信有悟门，但只向这边穿凿、那边计较，直饶计较得成、穿凿得就，眼光落地时，还用得着也无？……更有一等汉子，成十年、二十年用功，不曾有个入处者，只为他宿无灵骨，志不坚固，半信半疑，或起或倒，弄来弄去，世情转转纯熟，道念渐渐生疏，十二时中，难有一个时辰把捉得定，打成一片。
    一种是只在公案文字上用功，不去实际参究，于生死大事无真实证量，虽百般计较，终不能得受用。另一种人虽讲求修行，但寻不到入手处，虽久久用功，但亦无效险。
    原妙虽然只讲参禅三要，实际上还有一要即“大根机”。有些人即便有大信根、大愤志、大疑情，仍无悟处，其原因就在于“宿无灵骨”，根器浅钝。若要了彻生死，大不容易，原妙称：
    若要点铁成金，与千圣同域，岂浅识小见者所能拟议？直须具举鼎拔山力，包天括地量，斩钉截铁机，打凤罗花手。果有如是操略，至丈助以发机。
    有此根据，即能“有意气时添意气、不风流处也风流”。若是“跛鳖盲龟”，只跳一两下，伎俩已尽，何谈参禅悟道。
    原妙禅师长年独居高山危崖之上，目瞪宵汉，孤峭严冷，不假人辞色，后人记载其严肃冷峻竟至“未尝一启齿而笑”。说明原妙门风甚严，决不轻评妄可，至天目山从原妙问禅者有数万众，但得其法者仅二人，即断崖义公和中峰本公。断崖义公寂然不闻于世，中峰本公即中峰明本禅师。


四、明本与看话禅

四、明本与看话禅

    明本（１２６３－１３２３），号中峰，杭州钱塘人，俗姓孙。少有异志，喜唱梵呗，十五岁立志出家，持戒甚严，夜读佛经犯困，以首触柱自警。后阅《传灯录》至“明知生是不生之理，为什么却被生死之所流转？”顿发疑情。闻高峰原妙居天目山狮子岩立死关以待参学，明本前往参叩。高峰一见即知为大器。二十四岁那年明本诵《金刚经》至“担荷如来阿耨多罗三藐三菩提。”恍然开解，内外典籍，皆通达其意趣。但高峰告诫他“识量依通，虽于义趣通经，终非悟也。”于是从原妙落发、受具足戒，并随侍十年，画则工役，夜则参禅，尽得原妙禅法旨要，原妙对明本亦深表推重，曾亲书真赞赠明本：“我相不思议，佛祖莫能视，独许不肖儿，见得半边鼻。”原妙逝世后，明本游方各地，先后经历皖山、庐山、金陵、镇江、少林寺等地，并于庐州弁山和平江雁荡山结庵传禅。至治二年（１３２２），宣政院请他主持径山，不应命，而结庵于中佳山，次年即圆寂，其临终书偈曰：“我有一句，分付大众。更问如何，无本可据”。明本以其禅行道望，羸得“江南古佛”的赞誉，元朝廷也屡加赐号褒扬，元统二年（！３３５）即明本寂后十二年，元帝敕封“普应国师”尊号。在当时只有藏族大喇嘛被尊为国师者，明本以汉族禅师身份受封，实属“旷世恩世。”
    （一）对当时丛刊林诸种弊端的批语
    明本虽学有师承，但又不囿师说，自在原妙座下开悟，一通百通，辨才无碍，学识渊博。其谈禅论道，皆发自胸襟，汪洋恣肆，雄论滔滔，不见崖
涘。
    明本首先探讨了禅到底是什么这一根本问题。明本分析了历史上诸种种的理论和实践“
    或有以枯形死态、冥心壁观之谓禅，或有以教外别传、不立文字之谓禅，或谓微尘法界、明暗色空、动植纤洪、飞摇蠢蠕，当机不昧、睹体全真之谓禅，或有拨开万象、透过色声、坐断有无、水立凡圣之为禅，或有向四大五蕴中认个昭昭灵灵、闻见觉知之谓禅，或有放下身心、休歇万事、一念不动、六情不摇之谓禅，或有以临济一喝、德山一棒、灵山拈花、少林得髓、繁兴大用、举必全真之谓禅，或有以德山托钵、云门话堕、赵州勘婆、洞山三顿棒等谓之“向上一关、末后一句”，扭转面皮、露出牙爪、活路生机、不容近傍者之谓禅。……略而言之，如上所见，并是情存取舍，意涉所依，有为机关，堕为窠臼。
    在明本看来，无论是唤作如来禅、祖师禅、平实禅、杜撰禅、文字禅、海蠡禅、外道禅、声闻禅、凡夫禅、五味禅、棒喝禅、道者禅、葛藤禅，还是所谓“胳略机境、不受差排”之向上禅，皆是闲名杂字，由知见解会中来，与了脱生死之本分事没有交涉，所以皆无真实的意蕴和实际的效用。
    那到底什么是禅，或者说什么是明本所理解的禅呢？
    禅为何物？乃吾心之名也。心何物也？即吾禅之体也。达摩西来，只说直指人心，初无所谓禅，盖于直指之下有所悟入，于即悟之间，主宾问答、得牛还马、遂目之为禅。然禅非学问而能也，非偶尔而会也，乃于自心悟处，凡语默动静，不期禅而禅矣。其不期禅而禅，正当禅时，明知自心不待显而显矣。是知禅不离心，心不离禅，惟禅与心异名同体。
    将禅与心的关系理解为体与用的关系，这是明本的独创。既然心为禅之体，所谓参禅悟禅，就只能是在心地下功夫。心地若明，则语默动静皆是禅，心地未明，没有切实的修行与真实的证量，则说祖师禅也不是，说如来禅也不是。明本正是基于对禅即心的理解，对当时禅林的诸种弊端进行了批驳。
    明本认为当时参禅者有两大误区。一是陷于知见窠臼，对古人悟道因缘百般索解，于言句上生解，于开口处承当。岂不知古人开口处如大火聚，是不可凑泊，不得思量卜度的；其二是错会古人“平常心是道”、“无心是道”的开示，或破律仪犯禁戒，任性而为，或钻古纸堆中不得出，或忘形死心，停机息念以资狂慧。总之，虽称参悟，但因不于心地下功夫，与生死根本无丝毫交涉，故非愚即狂。而那些领众修法的所谓师家，大多不具作家手眼，自身即不能穷本穷源，其教人自然也是以盲引盲，只欲学人速得知解，“暖热门庭”，即将古人剩语拿来讲解，全不顾学人脚跟未稳，心地未明，学人不识好恶，堕入窠臼，本欲觅师解沾去缚，不意重添一重枷锁。
    明本所指谪的上述弊端，在当时丛林对公案阐释方面表现得最明显。师徒不发真心，揣按不行处，唤作向上机，坐脱立亡，唤作末后句。”差牵排会，强以为解，并作为究竟极则，口传耳授。岂不知所有这些机缘语句，皆是古德悟后本份之谈，非有宝意，不可作禅道会，也不可作佛法会。学人若亲到那步天地，不待索解而自然会意，不到那分天地，虽曲说巧辨，毕竟与古德本意隔若天壤。
    以公案诠释作为助道因缘，始于雪窦的颂古，完成于圆悟的评唱。圆悟的代表性著作《碧岩录》曾影响一代禅风，直到金元之际的北方曹洞宗依然以公案诠释为参禅的主要方式。但此书对古德公案程式化、规范化的诠释，也带来很我弊端，使学人不思进取，只于书中寻言摘句呈口利，欺已欺人。故宗杲将其师的这部著作当众焚烧，留下一则可与“丹霞烧木佛”相对参的公案。
    明本虽对参公案的作法极为鄙视，但他对宗杲的惊世骇俗之举也不以为然。明本认为人人本具之如来智慧德相，即是一生参不尽之现成公案，这一公案既与语言文字无交涉，则万千公案、万千颂解出而不能加之，焚《碧岩集》、杜学人口，又焉能损之？
    无边众生，各各脚跟下有一则现成公案，灵山四十九年诠注不出，达摩万里西来，指点不破，至若德山、临济摸索不著，此又岂雪窦能颂而圆悟能判者哉？纵使《碧岩集》有百千万卷，于他现成公案上一何加损焉？昔妙喜不穷此理而碎其板、大似禁石女之勿生儿也。
    在明本看来，无论是古人公案还是近人颂解，都是顺应群机之方便施设，善用者为疗疾之药，不善用者则翻成毒药，关键是学人参究生死之心真切不真切，若真正有志于究明已事，则必不会依文解义，自能扣已而参。至于《碧岩集》之有无，则实不足论。
    明本反对死参公案，尤其反对从文字诠释的角度钻研公案，但并不一概并弃公案，而主张从发起疑情的角度利用公案，他要求学人：“但遇著古今因缘，都不要将心领会，只消举起一个，顿在面前，发起决要了生死之正志，壁立万仞，与之久远参去。”明本这里所说的“举起一个，顿在面前”，也就是参话头，不过他对参话头的看法与宗杲、原妙等皆有不同。
    （二）看话禅的地位
    明本将看话禅放入整个禅宗史中来考察，认为看话头也只是引人入道的方便，并没有绝对的意义，且不说灵山会上迦叶无言承旨，达摩东来无心可传，单就《传灯传》千百古德又有几个是靠做工夫、参禅头而得悟的呢？
    参禅悟道首先必须发疑情。往圣古德，直接就“生从何来，死往何去”而起疑，“疑之不已，自然心路绝、情妄消、知解泯、能所忘，不觉忽然相应，便是疑情破底时节也。”并不曾看公案、参话头、坐蒲团、做模样，只是于生死大事真切用功，以悟为期，无少懈怠。但后世学人参学不明门径，只将古人机缘语句认作佛法，认作禅道，误入知解罗纲，堕于识见窠臼，只求多知多闻，不知所知头撇在学人面前，认人放舍身心、不起一念，只向此话头上蓦直参去。些番参究，非为明佛法，也非为悟禅道，更不为增知见，只为生死大事未明、本分事未了。参来参去，参到话头破处，生死大事也一时俱了，所以参话头与了生死是互为表里的，非离生死之外别有话头可参。
    正因为参话头只是究明生死大事的方便手段，所以做工夫、参话头并不能代表六度万行一切善法。如坐禅，明本反对蒲团枯坐，但却主张与明心相结合的坐禅，甚至认为：“非禅不坐，非坐不禅；惟禅惟坐，而坐而禅。禅乃坐之异名，坐乃禅之别称。”这里的“坐”非兀兀枯坐，而是指“一念不动”；“禅”也不是二乘外道所说的四禅八定，而是指“万法归源”、明心见性。
    又如持戒，明本特别强调修心必先持戒。明本引古德语曰：“戒为基址，道为屋庐。二者若无，一身安寄？”明本还历数禅门大德重戒重律的嘉言懿行，特别为其师原妙令人燃指受戒之事辩护。当时有一类禅师标榜“一行三昧”、“一相平等”，不守戒律，放荡无羁，以致提什么“抱妻骂释迦，醉酒打弥勒，俱成一行三昧”的荒唐主张。明本指出，所谓“一行三昧”、“一相平等”皆是悟后境界，是有严肃的佛理内含的。如果没有切实的修行功夫和境界，没有证得平等性智，妄言“一行三昧”、“一相平等”，就是造大口业，若依此而胡作非为，则阎罗殿中钢钗铁棒正为此辈而设。
    （三）参哪种话头？
    明本对参话头的流传有一段说明：
    有一等初根愚钝，见说参禅须看话头、起大疑情，方顿悟入，于是硬剥剥地三十年、二十年，靠取个所参底话头，首尾一贯，不肯放舍。久之，情妄顿消，尽然开悟。后来凡遇学人请益，必欲令人看话头、起疑情、做工夫。似此等师家为人，虽曰难以进入，却始终不壤人根性。
    由此可见，话头是修行者偶然撞着，大多是学人的个体经验，并不具有普遍的意义。明本接着又说：
    自有宗门以来，虽曰直指人心，其涉入门户，千途万辙，各各不同。盖师家据一个直指之理，各人根性及自家悟入之由不同，所以诱引不同。原其至理究竟之处，一皆了脱死生大事为期，余无可为者。
    据此，似乎并不存在人人必须执持的话头。学人要哪种话题，要根据各人的根性及时节因缘。明本在说法开示中，时而举扬“万法归一，一归何处”请“单以生死无常为重，提起这僧问底话头道‘万法归一，一归何处’，行而参，坐而参，莫问闲忙静闹，拼得此一生与之抵捱，捱到不奈何处，和尚话头一时忘却，方知三世佛、历代祖、天下善知识，尽是认砖头作古镜。”时而举扬“四大分菜时，向何处安身立命？”谓：“但请发起一念决定信心，参个‘四大分散时，向何处安身立命’话，尽此余生，密密参究，久远不退，廓悟自心”。明本举扬“父母未生前，哪个是我本来面目，”劝一位信奉念佛法门的居士：“直以父母未生前，哪个是我本来面目话置之念佛心中，念念不得放舍，孜孜不可弃离。工夫纯密，识见愈精明道力愈坚密。一旦忘能所、绝气息处，豁然顿悟，始信予言之不尔欺矣。”但多数情况下，明本只是泛泛地讲参究“无义味话头”，并不特别强调哪一种话头，这与宗杲单提“赵州无字”，原妙特重“八字话头”不大相同。
    原妙强调无论参哪个话头，一定要把得定，发大愤志，一参到底，以悟为期，此生参不透则待来生，决不能半途而废，或换其它话头。但当时学人则不然，最初发心即立脚不稳，稍遇逆缘，即生退堕。明本将中途迁变者分为三类：其一是“惟尚言通，不自觉知，涉入知解，以相似般若沾缀识田，自谓了明，莫知虚妄”；其二是放弃参究做工夫，转而念佛习教苦行持咒，总之“皆是自违正信，远涉异端”；其三是：一个话头咬嚼未破，百般情妄起灭无时，不至三年五载，遽谓参禅不悟，竟向无事用中，念念循尘，心心流浪，日赴死门，未尝返省者。”有明本看来，只决志参究的愿心本身即有大功用，即能排除种种杂缘与妄念，故经中云“末世众生能发一念不退转心，即同正觉”。
    （四）如何参话头
    至于如何参话头，明本首先警策学人九个方面的注意事项：
    将个所参底无义味话，拍盲拈起，重整精神，默默自看。第一不得袂昏敌散，第二不得舍妄求真，第三不得爱圣憎凡，第四不得将心待悟，第五不得厌生离死，第六不得乐寂嫌喧，第七不得顺已达他，第八不得藏形避影，第九不得拣缘择境。
    明本在列举以上“九不得”个，还讲“更有十二个不得，未易与人说破”，因为待学人有所悟入，则自然明白，不用再说，言下之意，在学人未悟之前，另外“十二不得”说不得。先不论那不知所以的“十二不得”，单就以上“九不得”分析，实际上是讲在参话头时要虚廓胸襟，荡除一切情识知见，达到一种“虚豁豁，孤峭峭，净裸裸、赤条条
”的清寂圆明之境。明本引《华严经》偈曰：“若人欲识佛境界，当净其意如虚空，远离妄想及诸取，令心所向皆无碍。”明本上述“九不得”，即让学人“净其意如虚空”，然后参话头以悟佛境界。
    当然虚廓心怀，并不意味着可以放逸其情志。恰恰相反，心怀既净，正好集中心志起疑情，真切参究，在明本看来，生死大事不易了脱，因为人禀形质得肉身，是无量劫来流浪生死之根尘业习所成，欲不费气力，只求速成，只会转求转迷。所以明本又特别提出参话头“不要指立期限”、“不要住心待悟”、“不要计算功程”、“不要过难而忧”、“不要逢顺而喜。”
    参禅包括参话头，遇到的最大的问题是心境难以真正清净，往往是心猿意焉，识见纷飞，精神意识求寂静往往导致昏沉，求惺惺又常常偏向散乱。如何对治昏沉散乱，使精神收拾得住、把持得定，成为学人参究遇到的最大问题，明本认为昏沉散乱与人的诸种烦恼一样，是与生俱来的。“尔无量劫来，为客尘烦恼染习太重，是昏沉散乱之根本。”不只染污习气，而且爱憎取舍，乃至刻意参禅学道、成佛作祖，皆是昏沉散乱之根本，故此，昏沉散乱只是表相，其根本在于心地未明、生死未了，而能否明心见性、了生脱死的根本，又在于参禅的正念是否真切。昏沉散乱皆无自性，与涅盘寂静一样是当体即空的。所以“昏沉散乱当体是本地风光。”只要修行者念念真切，不染内外杂缘，则昏沉散乱无由得起：
    当知第一念不真切，（昏沉散乱）即从第一念入，第二念不真切，即从第二念入，乃至百千真切，意无所入，或最后一念稍不真切，则便从最后入矣。若使自最初一念真切，直至心花发明之际，其真切之心，了不间断，则所谓昏沉散乱，杳不知其迹矣。
正因为昏沉散乱是表相而非根本，所以对治昏散就不能只着眼于如何去宁神静虑、破除妄想情识，而应该从根本上入手，即以真切心去悟明心地。心地若明，则昏散当下即为寂静，正所谓不待活而自灭。若为道之心不切，而只于表相上纠缠，无异于“自处暗室而责已眼之不能洞视物象者，”这样不仅昏沉散乱不得对治，更会重增烦恼，更添一种障碍，明本警策学人：
    大凡做工夫，只要悟话头，不要你排遣昏散等。你但痛念生死无常大事，单单提个话头，起大疑情，以求正悟。惟是生死念切，自然话头绵密。于看话头绵密处，昏散等自然不现。凡是做工夫时见有昏散等，即是你念生死之心不切，看话头之念不密耳。
    可见明本并没有为学人提供如何对治昏散的具体方法，诸如禅定之类，但他又明确指出了从根本上消除昏散的途径，如果抓住了心地用功这一根本，参话头、起疑情，就不需要任何具体的对治方法，昏散当下即为寂静，而撇开根本，念念于昏散上著力，则横竖皆不是。
    与对治昏沉散乱相联系的是对治“偷心”“何谓偷心？乃识情之异名也。”参禅或参话头须荡除一切思惟情识，无思无想，无憎爱分别，甚至无求禅求道、求证求悟之心。当然要彻底遣除虚妄情识，也必得有真实参究之心，参究心切，把得话头，自然光明焕发，偷心不起。在这里，破偷心与证涅盘是一回事，偷心灭尽，不仅是究明心地的手段，而且是明心见性的表徵。明本还提出“偷心”与本心是不一不二的，学人参究之心不真切，则本心转为偷心，若道心坚定，求道之心真切，则偷心当下即转为本来清净圆明之心：
    偷心何物？即如来妙明元心之至体耳，以其求道之志不真不切，为诸妄所蔽，转为偷心也。犹虫生于禾，害禾者虫也；亦犹火生于木。烧木者火也。但求道之念真切，虽寝食于人不可一日无之之事尚能废忘，何偷心之不泯哉！
明本所说的“偷心”指人的见闻觉知、分别思维，以及人的喜怒哀乐，如恶憎爱等情感活动，这些精神活动与人的“妙明元心”，即作为人与宇宙统一基础的本心，虽有联系，但却是不同层次的范畴，明本将它们的关系比之虫与禾、火与木，不仅比喻本身不合科学，而且这种类比也是不恰当的。明本的用意，同样不在说明如何对治偷心，而在引导学人以真切之心，于生死大事上用功。
    “偷心”的异名又称“第二念”。参话头是“第一念”，相对于所参话头，其它一切杂念皆属第二念。制止第二念的过程，也就是参究开悟的过程：
    但除却一个所参究话头外，更有心念，不问是佛念、法念乃至善恶诸缘，皆是第二念。此第二念久久不起，惟于所参话上一坐坐断，和个所参话同时超越，便见十方世界皆是解脱游戏之场也。
    意思是说，要以“参话头”这一专念，却抑制其它一切思虑活动，及至其它思维情识完全断，说明一期参究事毕，所参话头也自然消失，这就是“同时超越”之意，既克服了其它杂心妄念，又超越了话头，则心地洞明，光明一片，自在解脱，一无挂碍。
    如此说来，明本所讲的做工夫、参话头，并没有特殊的具体要求，而且到头来参话头本身也要一并遣除，明本所指示学人的只是几条原则：
    第一须是放得从前知见解会底禅道佛法净尽；第二须把生死大事顿于胸中，念念如救头燃，若不顿悟，决定不休；第三须是作得主定，但是久远不悟，都不要起第二念，向外别求。
    其中的第二条是最根本的，明本引古德语曰：“但有路可上，更高人也行。”只要参究生死之心真切，不怕根机浅钝，不怕境缘不利，但坚持不懈，自有悟期，即便今生不悟，也可熏习佛种，于八识田中种下善因，来生定会速证正果。
    （五）大幻法门
    明本道眼高邈，不拘旧法师法，一生虽亦主参话头，但随机说法，各施方便，每每出惊人之论。在《幻住家训》一文中，特别拈出“大幻法门”，以为当世弟子之劝他，又为后世学人之训戒。
    明本认为一切皆切，幻有幻无，幻生幻灭。“一大藏教依幻而说，千七百则陈烂葛藤由幻而生，菩提涅盘根幻而成，真如般若侍幻而现，”乃至天地万物莫不禀幻而有，诸佛菩萨、古来大德，皆依此幻而具大神变而获大自在。而且此大幻法门就在众人脚跟下，与众生并无丝毫隔离。但众生之所以明知一切是幻，犹驰求不已，为幻所缚，就在于未尝真正参究一番，虽心存报知而仍被诸幻所牵，不得自在，如此则虽心知其幻，又与懵懂无知者何异？
    既然一切皆幻，所以泥著师说，或欲从古人言句中会取，就显得愚不可及。当时禅人评点古德禅法头头是道：“或以某师说禅简明，或以某师说禅圆活，或以执为高古，或以孰为峭峻、孰为细密、孰为文彩、孰为粗暴、孰为不工。”滋博是非，乖离正道，岂不知深达大幻之士，其言句文辞，皆从胸臆中流出，随机任器，杀活临时，随扣随应，了无拣择，决无分别取舍之情，更有拿个禅册子，广读博记，以图契入祖师西来意，结果徒增所知障，大我慢、与祖师之旨毫无相应。
    学人之病在于未悟一切皆幻，其对治法门，即在于向所参的无义味话头摹直参去，参究时不可问禅道佛法上别求解会，不可另生“第二念”，只孜孜兀兀如撞着银山铁壁相似，待情识消尽，达到光明境地，亦不可生欢喜心，只如无事人相似。只有经历这样一番历练，纔真正体证到一切皆幻，纔是悬崖撒手、桶底脱落，也纔是真正踏入大幻法门。
    入大幻法门亦如过生死门，实大不易，众生往往只见祖师悟后之放旷自在，而忽略祖师未悟时之千难万难。“只如二祖未悟之顷，立齐腰之雪，不知为寒，断娘生之臂，莫知为痛。只这一个样子，不惟今人之难，在二祖分上亦未尝不难。”并且一切有契有证之士，在未悟之前，未有一人未曾历经精神和肉体上的痛苦磨练。这些人之所以能万难不退，在于求证求道之心真切，以其心真切故忘其难。若为法之心不真不切不诚不若，纵使有百千方便，释迦达摩来至面前，亦无开悟之理。
    明本为学规模宏阔，不仅留下《山房夜话》、《拟寒山诗》、《楞严征心辨见或问》、《信心铭辟义解》和《幻住家训》等诗文，而且对儒家学说也深有研习，并有独到见地，曾为赵孟頫讲“防情复性之旨”，并将儒家修身养性学说比之佛教的渐教。其对当朝士大夫的说法也多结合儒家“涵养性情、变化气质”作称旨之谈，深得士大夫阶层的服膺和推崇。可以说他在禅学禅行上的造诣及在当时的广泛影响。是与他多方面的文化素养分不开的。
    在佛教内部诸宗关系上，明本虽以禅而自立门户，但并无门户之见，而是主张诸宗会通，而会通的基础则是众生之心。如关于禅与净土，明本谓：
    学者不识建立之旨，反相矛盾，谓禅自禅，净土自净土。殊不知参禅要了生死，而念佛亦要了生死。原夫生死无根，由迷本性而生焉。若洞见本性，则生死不待荡而遣矣。生死既遣，则禅云乎哉，净土云乎哉？
    禅与净土皆是为明心见性，心性既明，则禅亦得，净土亦得。禅不仅与净土，而且与密、教、律三宗在弘传“佛心”的基础上也是统一的。具体言之，“密宗乃宣一佛大悲拔济之心也，教宗乃阐一佛大智开示之心也，律宗乃持一佛大行庄严之心也，禅宗乃传一佛大觉圆满之心也。”既然四宗都是同宣一佛之心，所以四宗应该平等，不应有高下优劣之分。所有这些见解，非有真实悟入，探得诸宗堂奥者不能出。这些思想对后世禅宗思想发展趋向有深刻影响。


五、元长与禅密一致

五、元长与禅密一致

    明本的弟子中，以天如惟则与千岩元长最为知名。天如惟则在禅学上无甚创新，主要是传播明本的“看话禅”。千元长则不仅在当时影响更大，而且思想也有独到之处。当时有人将元长与同为祖先系的无见先睹、中峰明本并称。他们同时生活在元朝中期，无见先睹（１２６５－１３３４）居天台山华顶四十年，以善兴禅寺为基地，倡导看话禅。中峰明本居天目山，元长则在金龙府伏龙山圣寿禅寺，恰成三足鼎立。
    （一）元长倡看话禅
    元长（１２８４－１３５７），号千岩，萧山人。十七岁出家，十九岁受具足戒，在一次斋僧中，遇到中峰明本，明本让他参“无”字话头。于是往灵隐山修行，但或许因缘未熟，元长未能开悟，又到处参访。十年后再上灵隐山习禅，“胁不沾席者三年”，然后又去参见明本，明本告诫他：“汝宜善自护持，栖遁岩穴，时节若至，其理自彰。”于是，元长隐居天龙山东庵，“耽悦禅昧，不与外缘”。泰定四年（１３２７），元长开始在圣寿禅寺建立道场，弘禅授徒，声誉远播，曾受赐为“佛慧圆鉴大元普济大禅师”号。
    元长毕生提倡看话禅，自高峰原妙首倡“万法归一，一归何处？”之后，参话头似乎变成专参此话头。元长是原妙的再传弟子，曾说：“万法归一，一归何处，这八个字是天目高峰老祖自证自悟之后，又将这八个字教四海学者，各各令其自证自悟。”但元长并不传持此话头，认为关键是能否起疑情、断令根：
    果须到佛祖田地，须悟万法归一，一归何处话，与父母未生前话，狗子无佛性话，不是心，不是佛，不是物话，无丝毫疑滞，无些子差错，尽平生力量，一味捱将去。捱到露布极，伎俩尽，命根断，便是到佛祖田地也。
    以上列举的几则话头，都比较流行。选择哪种话头，并无定则，全规各人根机与因缘，但不管参何种话头，都须当人产证亲悟始得。元长在谈到后人对原妙八字话头多不肯信时说：“如今多有人不肯信他，只为不曾做这般真实工夫。虽曰参学，往往于万法上得些入头处，于一法上又打失了；于一法上得些入头处，于一法上又打失了；于一法上得些入头处，于万法上又打失了。所以不能如我祖师到证悟处，所谓毫厘有差，天地悬隔。”又引华严宗清凉澄观语云：“说悟则不可示人，说理则非证不了，且证悟之理，亦是对未悟者权立个方便。不作方便，亦无渐次，方得到事事无碍法界。”
    （二）涅盘心与差别智
    元长示悟侍者云：“先圣云‘悟是第二头’，又有云‘须妙悟始得’，又有云：‘悟后须遇人始得。’参禅参便了，又要遇人作什么？殊不知涅盘心易晓，差别智难明。”涅盘心在这里指妙明圆心，参禅人做工夫，首要的是明心见怀，亦即证得此涅盘妙心。此涅盘心是无生灭、无差别的，相对于此涅盘心，是有差别的成所作智。涅盘心代表真实悟入的境界，而差别智则代表悟后接人、悟后利人。禅宗虽然讲自性自度，但真正的大禅师必有慈救世的本性，求证求悟，不是为了自脱自了，而是为了随机化度，在这个意义上，自求开悟还只是第二步，悟后生妙和，度已度人，总称得上彻悟、妙悟。其《示瑛禅人》曰：
    参禅人做工夫无别事，只要知个本命元辰下落处。知得自己、辨得他人，山河大地，世出世间，一一尽知下落，瞒你一星子不得，唤作智眼洞明，心行处灭。然后回身轻步，建大法幢，现出三头六臂、七纵八横，拈一茎草作丈六金身，拈丈六金身作一茎草用，杀得人、活得人，金刚王宝刹寒凛凛地，唤作临济下儿孙，不为分外。
此即“参禅又要过人”，只有在应世接人的过程中，总能透得一切，用得一切，于法自在，转得万物而不为物所转。
    （三）禅教一致
    元长虽为宗门大禅门，但于教理尤其是华严教理很有研究，尝言：“教外无禅，禅外无教，非离言教而别有所传，谓迥异言教，传不可传之至妙耳。”临济三玄三要，四料简，一喝入五教之旨，与华严所谓三大四法界之旨，非同非异，亦同亦异。无论是宗门之旨还是教乘之旨，其至妙处，皆说不得、传不得，惟亲证亲悟始得。
    自然，在元长看来，禅教相统一的基础，是禅而非教，具体言之，即看话头。元长在《示春计景》中，教学人参赵州“无”字话头，认为任你讲得一大藏教，也出不得赵州一个无字。参无字话头，一直参到“一法无，万法皆无，和这无字亦无，正与么时，上至无量劫，下至未来际，总不出这个时节，自然活泼泼地、虚灵灵地，便是清净法身佛。不待静而自安，不待动而常用，便是千百亿化身佛。”若真能参到这一境界，则教、律、禅、皆备于我，皆为我道具。具体而言，说一切法，于法无碍，名为讲师；立一切法，于法无碍，名为律师；空一切法，于法无碍，名为禅师。教、律、禅，是在学人深入法界、真实悟入后，总体验到的境界。
    （四）禅密一致
    元代是我国历史上藏传佛教在内地传播最广、影响最深的时期。被封为帝师的藏僧主持宣政院，其它高级藏僧也往往在地方管理佛教事务。藏传佛教的大规模传入内地，制约着汉地佛教的演化，影响着各宗派的消长。藏传佛教以密教为主体，但藏密与唐代五代在内地传播的唐密体系有所不同。唐密传承未久，典籍虽存，未显行于世。随着元朝廷对藏密的推崇，藏密在内地的影响达到前所未有的程度。由于密教的广泛传播，引起了显教与密教间的争论，时人有云：“习显教者，且以空、有、禅、律而自违，不尽究竟之圆理；学密部者，但以坛、印、字、声而为法，未知秘奥之神宗，遂使显教密教矛盾而相攻，性宗相宗，凿枘而难入，互成非毁，谤议之心生焉。”
    显密之间的矛盾，与教禅的矛盾，皆是修行未臻圆满的表现，从彻证彻悟的角度看，它们都是融通一体的。元代有许多僧人致力于沟通显密关系。如五台山沙门道殴著《显密圆通成佛心要集》，谓：“显密之两途，皆证圣之要津，入真之妙道。”力图从究竟义上融通显密。元长在重视沟通禅与密教的关系，他用禅宗的观点解释密教教义，其《示首仁大师》曰：
    秘密一宗，显诸佛不传之旨，阐上上大乘之教，故能入凡入圣，入一切国土而无所入，于诸境界亦无所碍。
元长认为，无论修禅修密，皆以明心为要，而且一切修法皆方便法门，即打破漆桶，识得本命元长，则可随缘任运，随处做主，一切平常，是没有什么秘密可言的：
    你若理窟不破，事上便不明，事上既不明，诸法皆有滞。诸法既有滞，持咒观想皆是虚妄生死根本，唤作无等等咒得么？唤作大慈悲、大忿怒、大解脱、大自在得么？且道如今作么生，你但无事于心，无心于事，自然虚而灵、寂而妙。若有毫发许本末言之者，皆为自欺。随缘着衣吃饭，任运快乐无忧，不与凡圣同缠，超然名之曰祖，如上说底，即非密也。
禅宗是从扫荡一切法入手，直探万法之空际；密宗则是从建立一切法入手，由“有”达“空”，虽然其最后归趣一次，但各自的修行方式方法迥异，以密责禅不可，以禅责密亦非高明。元长虽有依禅解密的倾向，但同时肯定密宗亦佛说，其《示达儿嘛失唎大师》云：
    云门“普”、赵州“无”、德山棒、临济喝，与你寻常想底佛，持底咒。同耶，不同耶？同则禅分五宗，教分五教，不同则总是释迦老儿子孙，何有彼此之异？
    这与中峰明本禅师“四宗一旨”说有相通之处。四宗指元代盛行的密宗、教宗（包括天台、华严和惟识三宗），律宗、禅宗。明本认为四宗共传一佛之旨，弘扬的都是佛心，所谓：“密宗乃宣一佛大悲拔济之心也，教宗乃阐一佛大智开示之心也，律宗乃持一佛大行庄严之心也，禅宗乃传一佛大觉圆满之心也。”明末、元长的阐述，都反映出当时禅宗及其他各宗的特色，也反映出这些禅师对自己所尊奉教说的虔诚和自信。


六、圆悟复兴宗风

六、圆悟复兴宗风

    明朝末年，随着国家对宗教管制的削弱，佛教打破以往的沉寂，重新活跃起来，在中国佛教发展史上形成一个高潮，这一时期佛教的兴盛，在思想的表现，主要在于继承发扬宋以来教禅并重、禅净合一的思潮，同时还有一些高僧不满佛教内部诸多流弊，而走上复古，即直追古来大德，竭力维护传统佛教的路子。在禅宗临济宗中，明末最活跃的是笑岩德宝的弟子幻有正传一系，正传的著名弟子有密云圆悟、天隐圆修和雪峤圆信，都在江南一带传禅，其中密云圆悟影响最大。
    （一）密云圆悟
    圆悟（１５６６－１６４２），号密云，俗姓蒋，宜兴人。少家贫，从事各种劳动。待其成为大禅师后，曾回忆说：“悟上座出身本非他乡异士之人，即本邑南岳山中一个樵夫耳。”又曾答其弟子汉月法藏云：“老僧渔也渔过，樵也樵过，耕也耕过，牧也牧过。只为不知本命元辰立地处，故入佛门来。”初受流行的净土信仰影响而“一意念佛，”二十六岁时，阅六祖《坛经》，始知宗门向上事，二十九岁，自觉时节成熟，抛妻离子，出外游历，立志出家，翌年，即万历二十三年（１５９５）正月，圆悟到常州龙池山参见幻有正传。正传以师学道勇锐，志期彻悟，故授法号“圆悟”。
    本来幻有欲正式为圆悟薙染授戒，但圆悟自觉大事未明，立脚不稳而婉拒，情愿终身修苦行，服杂役。“身任众务，以至鬻薪陶器，负米百里之外”，不惮辛劳，刻苦任事，大有古德之风。乃至圆悟成一方化主，亦以此警策徒众，曾语众云：“老僧三十一上侍先师参禅学道，都在务作里办，汝辈要安坐修行耶？老僧不愿丛林遣此法式。”圆悟晚年先后住持常州龙池山禹门禅院、天台山通玄禅寺、福州黄檗山万福禅寺等六处寺院。每到一处，在领众修法之余，力倡百丈农禅之风，实行“作则均其劳，饭则同其食”，决不允许不劳而食有现象存在。在住持天童寺时，一次有十数僧不参加“普请”，他知道后立即将他们迁单，赶出山门。
    圆悟在正传门下服杂役三年妈落发受戒，三年间圆悟勤勉任事，刻苦参究，侍奉正传更是殷勤周到。“传上下舟车，师随行有类厮养。”正传也赞许圆悟具大根器，可担大纲。在受戒次年，遵从正传的教导。“掩关本山，以千日为期。”
    当时禅林存在“闭关”修行的风气。“闭关”又称“掩关”，指在一段时期内，足不出户，专事坐禅习定。其用意在抛却一切俗务，远离一切俗情，在一念不生处体认昭昭灵灵的心之本体，当然“闭关”也不是绝对不与外界通什么消息，只是不有攀援而已。一次正传到关房，与圆悟话及“有心无心之旨”。正传云：“你既有心，把将心来”。圆悟呈偈云：“自心本自心，自心非心，有无既非，无自非耶？”圆悟即呈偈云：“心心即自心，有无皆自心，有无皆自心，无心无自心。”正传云：“今日张渚买两把青菜来，无个大罗蔔头。”圆悟云：“某在关房不知。谢和尚三拜。”正传云：“终未大悟在。”
    正传与圆悟徒间的往得问答有如打哑谜，门外人听来只会一头雾水，不明就里。其实师徒二人是围绕“心”的不同含义及其相互关系而相互辨难。“心”在禅宗的义理层面上，有三种内涵：肉团心、灵知心、本体心。所谓本体心，即绝对待，无生灭，至精微而又至广大的宇宙之心，亦即众生参禅明心见性之“心”。此心相对于前两种“心”，即识见纷纭烦恼炽盛之灵知心、思维意识之心，则是“无心”。因为本体之心亘古亘今，不生不灭，相对于人生而始具之心，则是“自心”。明白了以上概念的含义，则正传、圆悟的对答就容易理解了。圆悟最后所说“有无皆自心，无心无自心。”是说修行达到明心见性的境界，则起心动念皆本心之妙用，但此心念皆清净无染，与未悟前的心念又不同，是自然任运、无造作、无染著的，故说：“无心无自心”，圆悟自以为已洞见本来，无执无碍，但正传认为说食不饱，见地是否纯正，还必须在应世接物的生活实践中印证，所以对圆悟并不首肯。
    圆悟三十八岁那年，一日自城归铜官山，到山顶，“忽觉情与无情焕然等现，觅纤毫过患不可得，”众生苦苦寻觅一生都难得证得的境界，在偶然一念间出现了。“尔时恍恍惚惚、昭昭灵灵底，要起起不来，欲觅觅不得，不知什么处去了。”圆悟意识到这就是古人所谓“大地平沉”境界。直到此时他总醒悟到正传当时在关房外不予首肯的良苦用心。他还说：“贫道若不得我幻有老人道‘未曾大悟在，’又争得到铜官山顶忽自觉情与无情焕然等现，又争忘得人我相、得失是非，又争敢道‘大地分明一个炉，看来浑是火柴头，老僧信手轻挑拨，便解翻身动地流’耶”。
    万历三十年，正传去燕京，圆悟受命监理龙池山的院务，万历三十九年（１６１１），正传欲传“衣拂”给圆悟，圆悟固辞不受。正传圆寂（１６１４），圆悟坚持“心丧伴柩”三年，其间作颂古二百首“以明佛祖大意”。其一曰：“月到中秋滴露浓，崖前石菊花正红。山僧尽日茆堂睡，长萝毘那多口翁。”其二曰：“相逢不必论高深，觌面何须更用寻。君有胜情并玄度，我无名理况支林。一盂香积维摩供，万法惟吾独露襟。自觉个中无一定，客来谈笑懒言心。”圆悟少贫，未曾广读外典，出家后又服杂役，亦未泛览内典，但上述诗句皆清新典雅，落落有高人韵致，这只能说其宿慧深厚，天性颖悟，再加闭关苦修，由定生慧，实相般若当下现为文字般若。
    圆悟一生历主名刹，在江苏、浙江、福建一带有很大影响，其弟子遍天下，剃度弟子二百余，嗣法弟子十二人，即五峰如学、汉月法藏、破山海明、费隐通容、石通秉公、朝宗通忍、万如通微、木陈道（一个文字头，一个心字）、海明，在明清之交，影响尤大。此外他与社会上倾慕佛教的名公巨儒，王臣国士亦多有交往。这些人或晨夕随侍，或尺素相通，或邂逅咨请，“得师激发，无不虚往而实归。”关于他的言行，有道（一个文字头，一个心字）编的《密云禅师语录》十二卷，有批语弟子法藏的《辟妄救略说》十卷，另有弟子通容所编《天童密云禅师年谱》，辑录其生平事迹。
    （二）参禅要诀
    圆悟禅风类德山，常举德山语云：“我宗无语句，亦无一法与人，”不让学人落入言语文字葛藤。不得已而为言，亦简明扼要，无论上堂法语抑或书信开示，常寥寥数言，点到为止，为学人自己留下自性自度的空间，“他人难用力，自度自家身”，圆悟常以此警策学人。
    圆悟对参禅开悟的看法，集中体现在《参禅偈九首》中，这九首偈为：
    参禅莫妄想，亦莫着除妄。一念未生前，试看底模样。
    参禅一着子，不假异方便。须着自回光，悟取本来面。
    参禅参直指，毋遭歧路使。竖起铁脊梁，直下超生死。
    参禅直参直，莫着心意识。千差万别来，直下当头截。
    参禅参自由，撒手复何求。赤身如白刃，谁取犯当头。
    参禅欲吐气，须参转身趣。转身吐气时，语语无剩句。
    参禅节要处，切莫顾危凶，当机擒虎兕，信手捉狞龙。
    参禅参真实，莫参口头弄。终不哄他人，到头终自哄。
    参禅贵正因，弗用记时辰，佛法无多子，久长难得人。
    这九首偈将学人参禅所应坚持与所应对治的方面都谈到了。第一首与第四首互映证，是讲参禅要停息一切思维情识，包括日常的起心动念千思万虑，也包括欲停息这些纷纭之念的想法本身。因为如果念念不忘自念停心，这本身又成执著、又成魔障。禅悟思维是心对心的观照，而日常思维都是心对外物的观照，即便是观心，也是把心视为客体，而禅悟则是心自体的内省、反照。所以欲明心见性，获得对宇宙、人生之根本——心的证悟，则必须消除日常思维的干扰，将向外驰求的心止息下来，在“一念未生”的状态，去认取自家本来面目。
    第二首、第三首是说惟有参禅开悟，总是超脱生死最殊胜的法门，而其它种种修行的方便法门，都不如禅这么直截了当。参禅是大丈夫事，须“竖起铁脊梁”，树立信心，勇于担当。只要竖定信念，回光返视，不假方便，不入歧路，就一定能够一超直入，顿超生死流，直入涅盘彼岸，第九首也包含类似的内涵，参禅修行，不性根机浅，而怕不摸进路，不明禅修的原则和方式方法，此即因地不明。因地不明，就可能种下邪因，而因地既邪，虽累劫苦修，亦难成正果。
    第六首是讲参禅的节要处在“参转身趣”，其实这里的“转身”实指“转心”，把“我执”之心，转为无我之心，即打破物我的质碍，在消除一切执著、一切染污习气之后，证得清净无染之本心。只有完成这一根本转变，总能转识成智，以无分别之心去成辨一切，无所挂碍自由自在，第五首所谓“自由”、“撒手”、“赤身”，都是对悟后洒脱自在境界的描述。
    第七首是策励学人心存无异，发大勇猛，誓破修行中一切魔障。无始以来习气熏染，众生于八识因中形成种种结使烦恼，这些烦恼对凡夫众生来说是流转生死的直接原因，而对参禅修行者来说，则成为修行的魔障。而且“道高一尺，魔高一丈。”修行越是有进境，魔障也越猖狂，用虎兕、狞龙形容决不过分。圆悟作为闭关修行三年、亲历险境的大禅师，对魔障的生起与对治之法，深有心得，所以此偈当是经验之谈。
    第八首是警策学人真实用功，不可卖弄口头禅，自误误人。圆悟常开示众人，禅悟决定不在文字中，亦不在唇舌拔动处，惟有亲证亲到，总转得身、吐得气。若舍本求末，在枝节上生枝节，葛藤中缠葛藤，则横生颠倒，丧身失命。有居士求脱离尘纲、免于沉沦之文字，圆悟复书道：“某秉教外别传、不立文字之旨，岂有尘纲沉沦、脱离开示之文字耶？惟请老居士不立文字时着眼，则无事不毕矣。”又有居士求开示法语，圆悟亦道：“来谕欲贫道法语于一言之下少有开发，不知贫道若有一方加于居士分上，即障居士，非开发也。居士但向不立一言时看觑，忽然觑透，本无一物一言遮障底，即自开发矣。”既然禅宗讲不立一言，则一切皆是剩语，虽有言语文字，皆无实义。但第六首为什么又说“转身吐气时，语语无剩句”呢？实际上不可泥著语言文字只是对初学者或未悟者而言的，对他们来说，一旦横生执著则永无出离之期，但对那些已证已悟者，则实相般若与文字般若不一不异，言言流露真性，句句通达佛心，一切语言文字皆成说法道具。圆悟曾云：“佛法二字虽不浊偶然，亦非特意。但有个悟入处，不妨信手拈来，自然贴体，随分道出，自然恰好。”
    （三）一条白棒
    圆悟曾花费许多时间致力于公案的研究。在他的《语录》中，有“举古”、“拈古”、“徵古”“别古”、“代古”和“颂古”达三卷之多。但圆悟并没有走上参究公案的路子，他曾总结自己数十年修行的经验为“直指人心，见性成佛，”
    山僧出家将四十载，别也无成得什么事，只明得祖师西来，直指人心，见性成佛一著子。
    “直指人心，见性成佛”是南宗禅的宗旨，圆悟重提这一宗旨，实际上是对后世林林总总的诸多方便法门的拒斥和否定。他自己开启学人“见性成佛”的手段很简单，只一味从头棒去：
    老僧生平不解打之绕，惟以条棒一味从头棒将去，直要人向棒头拂着处豁开正眼，彻见自家境界，不从他得。
时人评圆悟禅风曰：“大师为人，不惜身命，宁使丧身失命，终不为开第二门。此是彻骨精髓，独超千七百则宗门。”此独超千七百法门之殊胜法门，就是棒打。圆悟之所以独尊此法门，据他自己解释：“盖缘贫道无学识，兼之只讷，不善委曲接人，故以一条白棒当头直指耳。”然究其实，圆悟行棒行喝，另有深意在，此即匡正当时颓迷的禅风，重新张扬德山，临济等先代祖师大德的大机大用。
    棒打之风，肇始于马祖道一，马祖道一在接引弟子时，竭力否定语言文字的作用，，多采取隐语、动作等特殊的方式诱导其悟入，并且为使“钝根”之人当下转为“利根上智”之人，培养学人的大机大用，马祖还使用极端化的踏、打、喝等段，以令学生醒悟，这种以“粗打”来诱导学人方式经百丈怀海、黄檗希运、归宗禅师等传扬，很快在禅林中盛行，临济义玄据“黄檗宗旨”，广接徒众，独树一帜，形成临济禅宗。但棒打的意义到底何在，后人并非都能理解，故胡棒乱喝者有之，棒下懵懂者有之，“死”于棒下者亦不乏人。圆悟又是如何理解，行施棒打的呢？
    有位名叫王选的居士，因不知修行入门及下手处，欲求圆悟婆心开示，以终生奉而行之，圆悟复函曰：
    祖师西来，禀教外别传之旨，直指人自悟，乘悟力而行，是为修行。故临济三度问黄檗的大意，三度被打，而临济自悟棒头指处，便道：‘如蒿枝拂着相似’，此从上入门下手之法也。今选侍已奉毗尼，复能以生死因缘为念，但不知何以入门、何以下手，欲冀贫道婆心开示法语，将终身奉之出于火宅者，贫道但请选侍向拂著处自看，是生耶？死耶？苦耶？乐耶？行耶？坐耶？忽然觑破拂着处，则动静二相，了然不生，觅生死且了不可得，何苦乐之有哉？故大慧云‘未悟时心识纷飞，悟了时方怗怗地’。然则怗怗地便是拂着处，拂着处便是不从人得、超佛越祖之向上事也，又岂有旋起旋失之心、舍此取彼之念哉？惟愿选待自信自悟，决不相赚。
    禅宗修行虽不讲求礼诵、打坐、忏悔等传形式，但并不是一切根机的人皆可轻易有得。必须有宿慧利根，或者说要有悟性，即能够透过一切事相的质碍，去体悟事相背后的本质、本性。就禅师的棒打而言，禅师禅棒的起处、落处和批昨，非素具信心，禀性颖悟者不能知。
    首先，对棒打不能从痛痒处会，如果以为一棒打来头痛向痒，就以知痛痒者为本心，则大谬不然。因为知痛痒者只是人的灵知之心，即古人所说的“识神”。此识神也是本心的一种作用，全本身并非本心，此识神是一种分别意识、有生有灭，而本心则是无分别，无生灭，故古人云：“学道之人不识真，只为从前认识神。无量劫来生死本，痴人认作本来人。”如此则识神不仅非本心，而且是体证本心的障道因缘，也是众生烦恼炽盛、流转生死的根源，若于此错认，则是执妄为实、认贼作父。古人于棒头指处亦有说法，所谓“棒打石人头嚗嚗，“即受棒打，应该忘却痛痒，如同禅棒打在石人头上一样，临济义玄谈及自己于黄檗处三次被打而且开悟的因缘时说：“我被黄檗先师打六十棒，如蒿枝拂首相似。”这不是说临济禅师丧失知觉，不知痛痒，或者有什么硬气功之类，不觉痛痒，而是说对禅师之棒打，不可以心意识会，若一棒将来即识浪翻滚，疑惑纷呈，去追问禅师为何棒打，自己错在何处，以及执持知痛痒之神识为本命元辰，则不说六十棒，即使一百棒下去，亦会愈打愈迷，甚或丧身失命。
    其实不可生分别想。根机不利或因缘未熟的众生，一旦遭禅师棒打，或晕头转向，或识见纷纭，生空见、有见，生苦想，乐想，甚或生嗔念、恼念。其实禅师之棒打，正在于打碎无始以来的烦恼习气，让人返本还源，向不睹不闻，未有知觉意识之前，直下觑透。若于此见得分晓。“如黑漆桶处于黑夜，初无二色，即无二见。既无二见，则不见有男，有见有女，不见有缠缚，不解脱，不见有凡圣、有净秽，亦不见有玄有妙，有觉不觉，亦不见有道不道，不见有空不空，不见有真不真，不见有苦乐昏慧，火宅清凉。”二见既灭，则言思路绝（分别意识和分别思维即停息），言思路绝，自然一心不生。一心不生则妄情不起。妄情不起则无现业流识。无现业流识，则旷劫习气顿净，生死烦恼顿超矣。
    最后，一条白棒意味着当头直指，一超直入，深达源底。在当时的禅宗中，存在着对“悟”的不同理解，有所谓“大悟十八遍，小悟不计其数”之说，把“悟”看成是需要反复多次总能完成的过程。圆悟则不然，他强调“一悟不再悟，深达法源底，坠地便称尊。”对待学人，一棒打去，力求一切放下，一念不生，全体呈现，顿悟未来，这就简化了修行的层次，阶段，也是对当时禅林繁缛颓迷之风的一种纠正。
    圆悟把“棒打”视为自己的“家法”、“家风”，屡屡以“一条白棒”付嘱传法弟子。其《破山明请》云：“不识好恶，不分皂白，人若问着，当头便楔，无法与人，那来剩迹。”费隐容请》云：“描不成兮画不就，赞何益兮毁何及。从来千圣不能识，一切时人妄名测。一条白棒惟直指，所以千古为标格。”《牧云门请》云：“这老汉，只可看，不可判，拈条棒子当头打，一一鼻头穿一贯，正眼从来廓顶门，历历绵绵续不乱。”圆悟的棒打禅风确有德山临济之古风，但时移势异，此时的禅林已不复有盛唐时的气象，宗门廖落，龙象鲜出，圆悟虽愿力宏大，欲挥动禅棒，横扫宗门尘障，无奈势单力薄，难成气候，其后世弟子有不明就里者，专以打人为事，棒喝完全失去原来的严肃内容，成为学人逃避艰苦修行的招牌和借口，则非圆悟所能逆料者也。
    （四）禅宗五家与本分一着
    圆悟禅风痛快直捷，在其《语录》中虽不乏巧方善辩的机语酬对，但在总体上他倾向于运用棒打等手段启悟学人，不太看重语言文字的功用。这突出表现在他对五家宗旨的看法上。在圆悟看来，参禅要有大丈夫气概，只有不被世出世间一切境界语言所转，总能就是达到自由自在的境界，具体到五家宗旨，圆悟并不否认它们的存在，他为黎眉居士所刻《五家语录》所作的序云：“五家语者，自达摩西来，至六传再四世，法遍中华。禅备众体，机语不一，无心而分，自成五家，故谓沩仰、临济、曹洞、云门、法眼。”但他强调五家宗旨其实只是一旨，即佛祖所付嘱之单传直指、明心见性之旨。如此则五家不同的机用法式，都不过是彰显佛祖之心，众生之性的道具，“纵五宗差别之语言，亦无非明人人本分一着。若离人人本分一着，别有差别之智，则随名相展转。生差别之情识，依旧无自由分。”故圆悟奉劝学人研习五家语录，不可泥著语言名相，而应该“尽五家差别之元，以明自己差别之智，总归当人本地风光，全机大用，出于文字之表。”
    涅盘心与差别智的关系问题，一直是禅师门十分关注的问题。应当说二者有质的差别：涅盘心是宇宙人生的本相，无生无灭，亘古亘今，而差别智则是有形质（语言文字），有分别、有起灭的，当众生未证未悟涅盘心，则分别智与无分别根本智是相隔相碍的，众生只会随名相转换而生诸种差别情识。一旦证得涅盘妙心，则差别智与根本智融通一体，不一不异，差别智当下就是涅盘心，涅盘心当下亦即分别智，如果仍把二者判为两截，则说明未真正悟入实相。故圆悟云：“当知涅盘妙心是大海，差别智是雨滴。滴虽不同，总归大海，自无差别，所谓‘惟此一事实，余二则非真’是正宗正旨。若有差别之智胜过涅盘者，是为魔说。”
    由此可见，圆悟虽承认禅宗五家各有家风，但他实际上更重视“人人本分一着，”它们之间是本兴末的关系，即人人本具的妙明圆心是根本。而所谓五家差别之言，皆是妙明圆心的随缘呈现而已，启学人用功处，当在佛祖直指处，即真参实悟，证得本命元辰，而不在费尽神识去研辨五家宗旨，有居士吴道婆问五家宗旨之疑，圆悟复书曰：“细观来书，于本分一着，尚未亲证。当据实呈本分，然后所疑五家说话不妨开来，贫道方好点化，否则断不敢细解注也。”圆悟后来与其传法弟子汉月法藏及再传弟子潭吉弘忍之间的论争。也是围绕如何看待五家宗旨而展开的。在驳斥藏忍师徒的观点过程中，圆悟将自己的观点表述得更加明确。


七、法藏对看话禅的总结

七、法藏对看话禅的总结

    （一）与密云圆悟的因缘
    法藏（１５７３－１６３５），字汉月，俗姓苏，无锡人。十五岁于德庆院出家，二十九岁从云栖祩宏受弥戒，并从祩宏处得新刻《高峰语录》，读之甚感契心。自三十岁始，专参原妙“万法归一，一归何处”话头，用功数载，至四十三岁，自称“我以天目为印心，清凉为印法，真师则临济也。”自认为获得了义玄、慧洪和原妙的真传。
    但在当时的丛林，要开堂说法，主持道场、还必须获得正宗禅师的资格，即必须学有师承，得到传法宗师的印可。于是在五十三岁时，法藏到金栗山广慧禅寺拜密云圆悟为师。圆悟立即命法藏为“第一座”，并手书临济宗承嗣法源，连同信拂付嘱法处。法藏正式成为圆悟嗣法弟子，获得了临济宗传法宗师的资格。
密云圆悟（１５６６－１６４２）嗣法幻有正传，先后住持常州龙池山禹门禅院，天台山通玄禅寺，福州黄檗山万福禅寺等，在江南丛林有很高声望，其平生开导学人，只将一条白棒打将去，要学人于棒头豁开正眼，彻见自家境界，其宗风称得上痛快淋漓。圆悟之所以很快就接受法藏为嗣法弟子，一个原因是法藏此前就颇具声誉，从之问学和交游的禅僧和士大夫很多，在他周围已形成了有相当势力和影响的参学群体，圆悟接纳法藏，可以扩大本宗本支的影响。另一原因在于圆悟门户较宽，接纳传法弟子，少门户之见，传法弟子中既有长期追随他的“嫡系”，也有暂投门下，禅学见地不同的高僧，法藏就是其代表，后来圆悟还是因为禅学见地的不同，与法藏来回辩难，一直闹到势不两立的程度。
    （二）如来禅与祖师禅
    法藏于《圣恩寺普说》中曰：“参禅贵先决择祖师禅、如来禅。”祖师禅、如来禅的说法在宋以后的禅林流传极广，但诸禅师拈提使用时，似乎并没有对其内涵有过明晰的界定。如来禅之名似初见于《楞伽经》，经中有“此经所谓最上乘禅”之说。唐代宗密在《禅门师资承袭图》中，将所谓“直显心性宗”之第二种，即神会所承继之惠能禅，称为如来禅。但宗密并没有在如来禅之上，另置一祖师禅，以相对称。最早提出祖师禅，并以之与如来禅并举的，当是仰山慧寂。《景德传灯录》载，慧寂谓香来会得“去年贫，贫无立锥之地，今年贫，连锥也无”名如来禅，而以“我有一机，瞬目视伊，若人不会，别唤沙弥”为祖师禅。但二者涵义之分别，实不清楚，后世禅家大体上在“超佛越祖”的意义上使用祖师禅、在“四禅八定”意义使用如来禅，并把祖师禅与顿悟禅、如来禅与渐修禅并提。在法藏看来，当时丛林流行的诸多“禅病”，皆因不明祖师禅与如来禅的区别、不明祖师禅的根本特徵所致。所以法藏专门把它们提出来，做一番勘辨。
    法藏对祖师禅、如来禅的判析，与十法界说相联系，如来禅是十法界内极顶之见、而祖师禅则是直透十法界之出格之见：
    祖师禅者，透十法界之外，不堕如来之数，故曰出格。如来禅者，起于九种法界，堕在十法界之顶，犹是格内。欲知格内格外之分，须在一事一物上分清。十法界诸种之见，直到极顶，方是如来地位。祖师禅，又从佛顶上透出，出格之外，又越两种祖师外道。若是真正祖师禅，则末后一句始到牢关是已。
“十法界”是佛教对世间、出世间众生按境界高低所做的分类，由低到高依次为：地狱（众生）、饿鬼、畜生、阿修罗、人、天、声闻、缘觉、菩萨、如来。十法界，每一法界众生皆有其知见与境界，同样依次上次序可分别概括为我见、贪见、盗见、嗔见、仁见、施见、灭见、缘见、空见、即空即有见。前六种见为世间知见，后四种则为出世间见解。四种出世间见解，又各自与特定的观行与证量相联系，如声闻众观诸行无常，诸法无我，最终证明得有余涅盘；缘觉众观万法缘生，无明本无，而入性空大乘之初门；菩萨众观诸法之空相，一切万法性相平等，在凡不灭，在圣不增，缘生即是性空，性空即是缘生，证得中道实相；初地菩萨次第渐修，直至十地，观万法即假即空即中，达到空不碍有，有不碍空，空即是有，有即是空的自在境界。
    十法界中，六道众生皆被我执、法执所繋缚，流浪生死，无有出期。欲求解脱，须与闻释教，从头修起。出世间四种法界，因各有知见与证量，皆可纳入“正思维”或说禅的范畴。于是与四法界相对应的则是四种禅：声闻禅、缘觉禅、菩萨禅、如来禅。如来禅是出世间禅法的极致，但犹堕在十法界中，属格内之禅。祖师禅则反是，摧山碎岳，拔脱身心，一超宜入，迥出格外。“格内”、“格外”的内涵，法藏虽只笼统地概括为十法界之内外，但结合他在别处的阐发，它们实际上是指知见之内外、思量之内外。参学虽上抵如来境地，犹存知见，仍处于思量分别的窠臼，虽说空有双遣双照，融通无碍，但毕竟仍有空有的知见分别，由此分别而导致凡与圣、善与恶、生死与涅盘、世间与出世间的分别。而这些分别虽然只以残存习气的方式存在，但犹使人不得跳出生死羁绊，获得彻底解脱。祖师禅则离四句、绝百非，去有无，于言语道断、心行处灭时分翻转身来，当下洞彻本地风光，认取自家本来面目。故祖师禅比之如来禅，不特超尘拔俗，更以淋漓痛快之风，逸出青霄之外，非真正出格汉子，不能窥其涯涘也。
    法藏明言“欲知格内格外之分，须在一事一物上分清”，如果真能于一事一物上将十法界之歧见看得透彻，并进而讨个出格之路，于九种知见之外，再觅一分新天地，则称为看话头。
    法藏曾拿眼前一片瓦为例，来说明十法界之歧及如来禅祖师禅之分，眼前一片瓦，当人们未见之前，人人心空无事，不涉生死。即便见此瓦而思量不起、现量未分，亦无有烦恼歧见。待人问道“这是什么？”或“此瓦是谁的？”无量事端骤起，歧见烦恼纷来沓至。有一等人见瓦便曰：“此瓦我要，”便与人争，甚至不惜拔刀相见，打杀他人，夺瓦而去，此等即堕地狱众生；另一等人虽不至杀人，但贪心不足，重如饥渴，百计攘求，此等为堕饿鬼道众生。又一等见瓦而起盗心，堕畜生道，生生还债。又有一等嗔心炽盛，夺瓦而行布施，福大气大，堕修罗道。又一等知瓦有用，惠施于人，因仁义心而生人道。还有一等，以瓦盖佛殿供佛，感大福报，往生天界。
    以上六道众生见瓦而著相，或生贪嗔痴，或起人我见。但其见地归纳起来，皆不出四种见解：见瓦是有即有见，见瓦是无是无见。前明后无，前无后有，是即有即无见。知有是无，则无之亦无，即非有非无见。凡无众生对一具体事物的见解，总不出此四端。其中有见是肯定，无见是否定，即有即无见是矛盾，非有非无见是不定。众生识见纷飞，随事转换，不能执定，总不出此四句。
    同样是眼前一片瓦，出世间四法界之歧见，也判然有别。声闻众见此片瓦而谛观苦集灭道，以修小道而见得有余涅盘，此瓦上之声闻禅。又有一等见地一片瓦起于无明，众生不知，故有十二轮回。今见一切缘起性空，无明本无，故无老死忧悲苦恼，此瓦上之缘觉禅也，若见此瓦起于微尘，水调火锻，虚空与诸相因缘和合，假名为瓦，既为因缘和合，不坏此瓦而自性本无，则照见缘起即是空，空即是缘起，缘起即性空，性空即缘起，即是诸法之实相，此为地前菩萨之禅。于此更进一步，则因缘生而性空不得，因性空而缘生不得，两头俱断，此是八地禅。不坐八地死水，抖擞精神再上一层，则缘生与性空双照双遮、互生互碍，相互交织，“如织绵回文，并无罅缝，”此即如来禅结顶处。到此时面对眼前一片瓦，“没奈何地唤作瓦又触，不唤作瓦又背，如银山铁壁，千推不能，万动不得，”到此地步，正处于如来禅与祖师禅相抵相交之际。若有具眼禅师将瓦一脚踏碎，有见无见，一齐抛却，缘生性空，当下截断，凌跨十法界诸种之见，一超直入，与威音王佛把手共行，总算是入祖师格外禅之初门。
    真正祖师禅，除超十法界诸见之外，还须谨防落入邪魔外道及“出格声闻禅”。
    法藏所指的外道与具缚凡夫不同。“凡夫四句，随事转换，不能执定，不名外道。若外道之人，巧生知见，执一不变，心外有法，故名外道。”就是说，凡夫虽然著相而生我见，起心动念，不免堕于“凡夫四句，”但皆不执定，可以随时随处改变或转换，外道则不同，他们往往将某种知见固定下来，斥为不变的信仰，外道之见有四种：常见、断见、亦有亦无见、空见。还以看眼前之瓦为例子，若有，即是常见外道；若执万物无常，终归败坏，瓦终散灭，亦有亦无，即是矫乱外道；若执瓦是有无，其无亦无，即是说此瓦存在本身就是不存在，“不存在”也不存在，此即是空见外道。教典中还有其它形形色色的外道知见，其有九十六种之多，但大体上皆可归于以上四种如见之内。
    法藏所说的外道知见主要是由外境而生，偏执一端，不肯放舍，而堕佛法正道之外。邪魔则由修法众生之心而生，因见地不到，修有偏差，而生种种魔障，此魔广说千万，略说有五：若厌患身心世界，坐见身心世界与瓦齐空，了无一法，以此为得，便是色蕴魔，（若入禅定而见外部世界变化多端无所不至，谓之刹说、无情说，亦是色蕴魔，前者是色空为蕴，此是色有为蕴），若见前种种境界，便心生领纳，是受蕴魔。若因好境入心，不能忘置，而生邪想，是想蕴魔。因想著邪，无师救正，辗转迁流，是行蕴魔。若将以上种种尘识妄念认作佛法，即为识蕴魔。
    以上邪魔外道，皆属十法界，不可定指，六道众生难免堕入，修出世间法众生亦或不免。祖师禅超十法界外，自然也包括断灭种种外道知见及诸种修行魔障，若一念不慎，堕入外道，或被邪魔系缚，则如来禅犹不可求，而况格外之祖师禅耶？
    但即便跳出十法界，仍不能保证就能证得祖师禅，在真正跳出知见窠臼，坐断立亡之前，仍有两道关隘。首先虽忘知见。起疑情，但疑情未破。此时已至“言语道断、心行处灭”境地，无下语处，也无思维卜度的余地。但万境仍然是万境，虚空仍然是虚空，心识虽停息日常的思维活动，但并没有在八识田中完成根本的转变。整个身心处于蓄势待发的状态。此时若用心真切，一口咬定，剋期求证，则久久参之，机缘成熟，自然会体证到“虚空粉碎，大地平沉，光明匝地”的彻悟境界。但如果根性不利，机缘不熟，用心不切，就可能“堕在死水，全没用处”，虽有超十法界之趋向，而终堕格内。第二道关隘是已打破心物之间的隔碍，达到了心境互融的境地，便复堕死心空灭之见，耽空滞寂，一味清净，法藏称之为出格闻禅：
    你道毕竟如何？时鸿侍者将瓦一脚踏碎，师云：于此见得，即入祖师格外之初门矣。如更进之，则头尾并完，直至后句，方是了手。若不见得，则但入如来禅格外之一半，出言吐气，便要落声闻境界，未有出头要在。为何？渐，以其得体不得用，只为心小，要在极妙处躲根，不能出得妙处作用，问头答语，分不清楚，陷在坎中。好好将祖师禅，枉作出格声闻禅矣！
    法藏于此重拈仰山勘香严的公案，来进一步说明祖师禅与如来禅的法式，以及祖师禅的真正内涵，昔香严闻击竹声响而大悟，有偈曰：“一击忘所知”、“不堕悄然机”，似乎是既不堕有见，又不堕空见，又颇有一棒打杀，一超直入的大家作略，故沩山闻之大喜，以为香严已彻悟，仰山则认为香严虽已做到“扫荡一切，一法不立”，但是否做到“建立一切，一法不废”则还有待勘辨。于是从香严：“今年贫，锥也无”之颂，当下即知香严只到空空天地，未有出头，只达体而不知用，还未到不立一法而又无法不立，不废一法而又无法不废的自由境界，但香严毕竟超越了心物对立、能所分别，故仰山只许其得如来禅，而“祖师禅则未萝见在”。显示出古德不以佛法当人情，为学人负责的严肃态度，不似后世妄称禅师者拿东爪印子胡乱印证。香严毕竟是上上根机，一闻仰山点化，当下悟出机要，从空空天地转身，出得妙处，应机作用，所谓“我有一机，瞬目视伊”，即不存知见而又不废视听，应缘接物，一如无心道人。正所谓悟后非旧时人，而不异旧时行履处。
      （三）祖师禅与看话禅
    法藏继承了宗杲参话头的传统，但又有改造和发展。在他看来，古人本来没有现成话头，师徒在问答中间，师家说出“干屎橛”、“麻七斤”等无头语句，学人当下起疑情，尽力参究，即有个入处。后世具眼宗师少，师家不能随机接引，不得已举古德现成话头让人参去。但众人根性各不相同，机缘遭际也各异，让他们共持一个话头显然是不合理的，实际上，参话头不过是为断情识起疑情，如果能达到起疑情的目的，则不仅古人机缘语句可作话头，今人言句可作话头，而且面前任何事物皆可作话头去参。所以法藏称“所谓话头者，即目前一事一法也。”法藏又谓：“凡人平居无事，随心任运，千思百量，正是无生死处。只为将一件物事到前，便生九种见解，所以流浪生死，无有出期，故祖师家令人于一事一物上坐断九种知见，计个出格之路，谓之看话头。”这样法藏就剥去了有关参话头的种种神秘外装，使学人更易寻到入手处，而不必枯守“赵州无字”或“万法归一，一归何处”之类而不能自拔。
    参话头只贵用心真切，把得话头，去有无，离四句，绝百非，直到无出头处，昏天黑地，一点杂法不得入心，待疑到极处，迷闷到极处，忽然如太山崩虚空，碎得个前后际断，便透得一分真消息，做工夫、参话头，除向迷闷处著力处，别无容易方便。但学人常因见地不到，或根性不利，在参话头过程中知见纷飞，而又勘不破，结果不特祖师禅参不成，连如来禅的境界也达不到。
    法藏分析了看话头时容易失堕之处。有一等人看话头，坐到身心空处，见个历历分明，便言是我本来面目。念佛者主人公，其实不过落神我外道禅。又一等见得空空，本来无物，身心世界荡然不存，以此为是，又不过是落于空亡外道，又有一等人只管于“本来面目”、“念佛者是谁”等话头上，讨个本性妙心，于是用尽肚皮里知见，千思万想，而不能离心意识去事上参究，结果自认为勇猛精进，岂不知始终为五蕴盖覆，转求转迷，去道愈远。此类人用功既久，魔业已成，有人正言相劝，亦难省悟，甚至生大我慢，或骂或谤，反污他人未曾亲证一番，而不知生生世世堕魔业中而不得出离。又有一等于话头上参究日久，忽得前后际断，身心世界荡然一空，于是扫荡一切诸法，什么三玄三要，君臣宾主、棒喝语句，一齐抛向虚空外，只求一味清净，其出语则滚滚虚浮，全无意旨，此堕声闻禅也。或于话头见得无明本无，便陷溺“无”处，自求快话，此堕缘觉禅也。又有一等参话头至紧要处，猛地有个省发，见得一切法空，一无障碍，若身苦心，如空中声，如镜中影。在此空相中行履，如鸟飞空，然脚跟未点地，死水不藏龙，堕在家静理上，又有一等于话头上透过知见，不为法缚，得口头三昧，机锋转语，灵利快捷，但说得行不得，见地虽到而行履不到，故语时称法称旨，而事上常露罅漏，此即达体不达用之出格声闻禅。
    对于如何对治以上禅病，法藏亦有说法，那就是不于八识用功，而只在心地著力，以上种种禅病，或穿凿信第六识，放纵六根，尘识妄念不绝；或抱守养第七识，不知转著相之我见，结果不是悟些好光景堕五蕴魔，就是落分别知见窠臼；或静歇养第八识，终日坐在死光影中，自谓快活，不知没头死水，永无出期。而所谓心地上著力，指不涉杂修，绝情绝想，咬着话头，一味在心地上念兹在兹，茶里饭里，喧寂不分，净秽莫辨，一味奋力求出，直至有无双遣，是非全忘，人法双亡，一真不立，总是真正安身立命处。于此可见，若于八识用功，则处处用心，头头著意，识见纷飞，烦恼炽然，永无出期。如果于心地著力，则能转识成智，拔除烦恼情识之根，作大自在人。
    法藏虽然主张眼前一事一物皆可作话头参，并不执定某一持定话头，但他对宗杲日常所举“竹篦”话头似有偏爱，时时向人拈提，其典型说法是：
    拈起竹篦子云：唤著竹篦则触，不唤著竹篦则背。不得有语，不得无语。如将泥团塞却七窍，气息不过，自然愤之又愤，疑之又疑。疑得切，闷得深，于穿衣吃饭处，迎宾待客处，屙屎送尿、搬柴运米处，或堂里，或堂外，或出或入，目前山河大地，明暗色空，若本性，若妙心，总上个背触不得。到这里，若稍涉迟回，恐落冷窟，直须拼命，再添一愤，如太山崩虚空，碎得个前后际断。……真到恁么时，方与威音未名、父母未生以前一段大事相应。
法藏在此对如何参话头已讲得比较具体，总之是从分别思维中抽身，以一种由疑情而起的禅悟思维去把握本心与宇宙的实相。不过许多人虽知参话头、做工夫，而且看起来也讲求勇猛精进，但却不能悟道。法藏分析了几种原因，有的胁不着席，夜不倒单，结果精神渐疲，昏沉逼发，如高峰原妙三年不倒单，日夜打坐，终日凝滞沉相中，愈遣愈疲，话头转不亲切，虽参狗子无字，难起疑。对治方法是当睡则睡，当起则起，养足精神。“精神若旺，便得专志猛烈，话头便有精彩，便得跃然活泼参情，从此发而真疑起矣。”有的急于求悟，于意根下卜度，将教乘极则语，宗家玄妙句，置于八识田中，百般索解，但即便索解得出，亦与生死与交涉。对治之法是塞却智门，专意起疑。有的用功猛烈，忽得前后际断，见个光景，话头便不猛烈，自求安乐。到此田地，自己便无主宰，必得凭借一个话头从中抽身，又有一等，虽透得大法，而操养未深，亦不可得少为足，而应善加保任，直至无悟无法，无操履，无习气，无作佛，无利生，任运腾腾，腾腾任运，做工夫至此，总称见些气息。
    （四）如来禅与默照禅
    法藏在阐释自己的看话禅、祖师禅的同时，也对当时禅林流行的“枯木禅”、“墨照禅”进行了抨击。对两种邪禅的批驳，尤其是对曹洞宗的主要参禅方式默照禅的批驳，又与对如来禅缺陷的分析结合在一起。法藏示众云：
    单坐禅，不看话头，谓之枯木禅，又谓之忘怀禅。若坐中照得昭昭灵灵为自己者，谓之默照禅，以上皆邪禅也。坐中作止作观，惺寂相倾，观理观事，虽天台正脉及如来正禅，然犹假诸识神用事，所照即境。所以命根难断，不能透脱，多落四禅八定，及生五十种阴魔，以识神在故也。
关于枯木禅，法藏认为太过拘系，缺乏祖师禅随处是道场的自由精神。永嘉玄觉云“行亦禅，坐亦禅，语默动静体安然”，这虽然讲的是悟后的境界，但其洒脱的精神也应该贯注于修行的过程中，行注坐卧四威仪，大可不必偏执一端。并且长时间枯坐则精神疲弱，神弱则疑情必不猛烈，做功夫反倒难以有进展。高峰原妙枯坐三年而未悟，马祖坐禅谓之磨砖作镜，皆是前人之殷鉴。另外，法藏认为参禅又不专在静处，也不专在闹处，必须静中闹中，任缘任事，只要认定个话头不放舍即是。基于这种认识，法藏主张“看话头”与“参请”结合起来，即向内反省与向外参究并行不悖，只要宜于发明心地，则一切皆是方便。
    至于默照禅，与天台宗的止观法门一样，病在于“假借识神”用事，此“识神”即“人我见”或说一种分别思维和分别意义。按惟识学的观点，“人我见”，是“末那识”的现行，“末那识”为第六“意识”所依，故亦称“意根”，此意根决定前六识的取向。因众生在获得自我意识的同时，也就具有了分别意识，在生活中总是重复着“我的、我的、我的”，久染成习，在第七识“恒恒执认八识谓自内我”，在意识层面则分别人我是非，善恶性起，这是众生流浪生死，不得出头的根本缘由。看话禅的作用，就在于当下截断意根，在第七识完成由识到智的转变。法藏紧接上段引文云：
    大慧一出，扫空千古禅病，直以祖师禅一句话头，当下截断意根。任是疑情急切，千思万想，亦不能如此如彼，有何著落。既无著落，则识心何处繋泊？令人于无繋泊处一迸，则千了百当。可见总看话头，则五蕴魔便无路入矣。
所以，“当下截断意根”，就是将有分别之识心，转变为平等性智，“意识”转为妙观察智，则以平等性智、妙智察智为正因，第八识转为大圆镜智，而前五识则转为所作智。至此则大下了毕，千了百当。
    从惟识学角度看，枯木禅、默照禅之病在于只在“心”即第八识上用功，法藏在《离心意识辨示禅子》一文中说：
    夫心者，即第八识之一分有知，一分无知者是。有知者，灵灵不味，了了常知。以知为体而湛然者是。无知者，湛极无记，在三性则不涉善恶之昏沉者是。
枯木禅所执认即第八识之无知分，而默照禅所照得“昭昭灵灵”者，不过是第八识之无知分。因没有第七识上的根本转变，故第八识未离心体，未得清净，起心动念，仍落分别，故此“心”动则为生死，不动则为生死根本，求寂求静或认得灵灵，皆是大患，不能出离生死。联系超凡入圣之如来禅，法藏指出在“心、意、识”上参学的根本缺陷：
    心照生明，堕在明白里，正是无明生死根本也；意根把捉，堕在我相里，正是无明生死根苗也；五识起，明了外，揽生明，六识起，分别内，揽计著，同为无明生死枝叶也。“知”之一字，便落心意识，非缚即脱，非善即恶，非凡即圣。著相则结缚而凡，离相则解脱而圣。著相离相是对待法、两头语，全是生死，何由出离耶？
法藏由此主张“离心意识参，出凡圣路学”，而惟有参话头，总可望顿弃平生心意识，直超凡圣路。
    对看话头在转识成智方面的功用及次序，法藏亦有说明。如“竹篦子”话头，唤著则触，不唤著则背，两路去不得，两路罢不得，六识不能分别，七识不能执认。以不能分别故，得妙观察之质，心不能执认故，得平等性之质。因参话头，先得以上两种质地，然此时犹未悟，尚须尽力参究，愈求愈无路，转参转不得，到此时以自识杀自识，回光返照，六识绝而七识亦杀尽。到此即为前后际断，空空田地。不过此时尚不到家，不可坐空立亡，仍需把话头死参，忽然撞着，则桶底脱落，光明顿发，第七识转为平等性智，六识转为妙观察智，再不落凡圣差别境，永离心意识诸法。
    由以上分析可以看出，法藏把祖师禅看得高于如来禅，如来禅种种，有般若，有实相，有寂照，有定慧，有空智实智，有种种名相、种种修法、种种境界、其妙法妙道，亦非中根聪智所能臆测。真实修来，亦有诸多受用，三乘二乘菩萨以至如来，次第修而次第入，至极顶处，缘起性空，双照双遮，戳瞎有功用眼，谓之如来禅。然从此门入，由凡至凡，总不出凡圣差别境界。其根源在于第六识照了，第七识上指认，第八识上摹拟，以“心、意、识”不能一时截断，故心光尚在，不能从顶门无眼处以无光之光照彻天汉。故虽于生死大事有所了悟，但只能证得生死依稀本无，而不能拔除生死根本，故遇缘应物心平气和时，尚把持得住，“但决不能于睡中梦中，正睡无梦无想处，死来昏闷处，跌倒闷绝处与淫怒痴正发处，坦然一如，自在无碍，作快活人。”
    不过，法藏并没有并绝如来禅之意。如来禅，作为应病与药的一期方便，也有其不可替代的价值，法藏在答一位病中孝廉的书中说：
    病中工夫且歇却，看话头郁遏费力，难与病情支遣，不若明明白白，一看透底便自肯心休去。第一先看此身凝湿动暖，四大从来，无有实体。……其二看色身既不交涉，其身外骨肉恩怨，功名利养，一切我所，皆是虚妄。……其三看破内外色空，何处更有妄心领受？……到此则身心法界一法无可当情，当下脱然放舍，便与法界平等，无一尘一法不是我自心真心。真心者，无心也。无心便当下成佛。
法藏在这里介绍的禅法，属于定慧止观的传统禅法范畴圈。修此类禅法，虽不能证得究竟，但对于病魔缠身的人，犹不失为应病之药，从应缘当机的意义上看，此时参此三乘二乘禅，比参祖师禅（看话头）更易得受用。
    而且，若是真达不思议境界，则于出格处，脚下无私，深深海底行，高高山顶立，凡与圣俱断，空假中皆了，生死不二，生佛无间。此时再以顶门“摩醯眼”回观如来禅、祖师禅，皆是无梦说梦，但有假名，何有实义？若一味执持祖师禅，则不特祖师禅不可得，如来禅亦未梦见在。
    （五）圆悟与法藏的师徒的辩难
    前已述及，法藏虽然是圆悟的接法弟子，但并没有在圆悟座下修学开悟，其禅法见地，主要是自求自证而得。在投入圆悟门下之后，其禅思想并无改变。他曾致信圆悟，表明自己的修学志向：
    自谓得心于高峰，印法于寂者，乃复发愿弘两枝法脉，起临济正宗。凡遇埽宗旨者，力为诤之。不独负荷滹沱，将使云门、沩仰、曹洞四家，遥承近续，今五宗再烂，愿世世生生为接续断脉之种，……屈指诸家，知和尚（指圆悟）乃高峰嫡骨正传，敢不一探堂奥，向于金栗山前，叨承委付。
    法藏虽然口头上对圆悟及其禅法表示推崇。但在思想上却与圆悟大相径庭。他认为禅宗五家各有宗旨，都应该继承和弘扬，而不能像圆悟那样，“仅以”直指人心，见性成佛为惟一法门。天启五年（１６２５），法藏作《五家原》，对五家宗旨进行了系统的整理和研究，并基于对五家宗旨的分析概括，对那些抹煞“宗旨”，妄立门庭，强作机锋的种种邪禅、狂禅表示了极大的愤慨，进行了无情的抨击。
    崇祯三年（１６３０），圆悟得到法藏送去的《五家原》，未阅全文，束之高阁。不久，圆悟的同门圆修致书法藏，提出批评。法藏回书反驳。圆修把法藏的加信寄给圆悟，请其裁决。圆悟对法藏进行了规劝训诲，但似乎未见效果，于是在第二年，圆悟著《辟妄七书》，崇祯九年（１６３６），又著《辟妄三录》，对法藏的《五宗原》进行批判别。同时，当法弟子木陈道（一个文字头，一个心字）著《五宗辟》，呵骂汉月。此时法藏已死（１６３５），其弟子潭吉弘忍为维护师说，兼驳圆悟，著《五宗救》十卷。圆悟在读了此书后，于崇视十一年（１６３８），著《辟妄救略说》十卷，对法藏、弘忍师徒一起清算，将禅宗史上最后一次重大论争推向高潮。
    法藏的《五宗原》开篇即曰：“常见绘事家图七佛之始，始于威音王佛。惟大作一〇圆相之后，则七佛各有言诠，言诠虽异，而诸佛之偈旨，不出圆相也。”又曰：“圆相早具五家宗旨矣，五宗各出一面，然有正宗，第一先出临济宗旨，此相抛出，直下断人命根。于一〇中宾主辊辊，首入首罗眼中，所谓沿流不止问如何，真照无边说似他。离相离名人不禀，吹毛用了急须磨是也。”
    法藏还具体分析说明了如何从一圆相中分离出沩仰宗、法眼宗、曹洞宗、云门宗。一圆相成为法藏判析五家宗旨的根本出发点。其师圆悟对法藏师徒的驳斥，也集中于此一圆相。圆悟于《辟妄救略说》中说：“汉月妄捏一〇，为千佛万佛之祖，谓五宗各出〇之一面，则临济亦被粘缚于一〇矣。更将许多络索粘缚临济，以为宗旨，抹杀从上来正眼正宗，自成一家外道，不谓之怪诞而何？”圆悟认为五家宗旨，其实只是曹溪正脉的另一说法，而曹溪正脉即正法眼藏，不过是自性自度、认取本来一端，舍此别无他解。“今汉月不据曹溪正脉，一味假临济虚名，死配三玄三要，诳哧闾阎。甚至妄捏一〇为千佛万佛之祖，谓五宗各出〇之一面，虽云建立五宗，实乃抹杀五宗，自成汉月一种魔说。”
    圆相说可一直追溯到龙树，据说龙树于法座上现自在身，如满月轮〇，一切众生惟闻法音，不睹祖相。迦那提婆曰：“此是尊者现佛性体相，以示我等。何以知之？盖以无相三昧，形如满月，佛性之义，廓然虚明，”很显然，提婆在这里是以圆相形容本体佛性之圆满澄明、鉴照一切，并非实指佛性为一圆相。举圆相谈禅，始于唐代慧忠国师。慧忠以九十七圆相示耽源，耽源以示仰山，仰山一见即焚却。在曹洞宗中，圆相及其种种变体，更成为其宗风宗旨的形象显示。至此圆相脱离了其原始的象徵意义，以独特的内涵，成为禅师接人的又一方便法门。然圆相本身也是一种“语言”，以圆相示人，藉圆相悟入，即便洞达本来，也已落第二机，故仰山一见即焚却，历代大禅师亦不屑玩习此圆相。圆悟以扫除迷雾，重开临济宗风自许，自然对此深恶痛绝，还在龙池座下时，圆悟即有偈曰：“若据某甲扶佛法，任他〇〇〇〇〇。都来决与三十棒，莫道分明为赏罚。”圆悟只认一条白棒，对其它种种葛藤、种种施为，皆一棒打杀，毫不留情，临济家风，依稀可睹。
    圆悟与法藏之争，就禅法而论，圆悟执杀人刀活人剑，大破大立，杀活自在，更具作家手眼，而法藏泥著一大圆相，五家宗旨，似乎缺乏禅家扫荡一切、一法不立的气度。所以圆悟发挥禅宗以一心统万相之旨，来批驳法藏为虚妄，有一定道理。但法藏之所以强调五家宗旨，又有特殊的针对性，即对当时禅林以抹杀宗旨为真悟者的愤激与不满。法藏称此类人为无赖之徒。“比年以来，天下称善知识者，竟以抹杀宗旨为真悟，致令无赖之徒，无所关制，妄以鸡鸣狗盗为习，称王称霸，无从勘验，诚久假而不归矣。”由于当时禅林僧众素质普遍低下，缺乏具正知正见的大禅师，于是一些妄称善知识者拾得前人鸡毛当令箭，妄立门庭，入门便打，入门便骂，使具有严肃内容的接人手段庸俗化，以至成为粗俗不堪的道具，法藏对诸种禅病的痛恨是可以理解的。
    这场论争，除了禅法观点的差异和分歧，也参杂着个人恩怨，法藏难非从圆悟处开悟，但毕竟是圆悟印可的嫡传弟子，圆悟在开始还给法藏以极大的信任并寄以厚望，后来法藏独立主持道场，有人将春开堂法语送阅，圆悟即表示不满，“汉月每提唱时喜为穿凿，恐后学效尤，有伤宗旨，因其省问，乃为规诲。”但法藏并无“悔改”之意，仍一意孤行，这就触忤了圆悟师长的权威和尊严，故在《辟妄救略说》中，斥责法藏不敬师长，是无君无父，乱臣贼子：“古人道，威音王以后无师自悟，尽是天然外道，汉月抹杀老僧，便是外道种子，所以老僧竭力整顿他，亦为道也，非为名分也。”又说：“汉月攀高峰为得心之师，觉范为印法之师，真师则临济，正若世间无父之子，认三姓为父亲，遣臭万年，唾骂不尽。”这种批评虽有一定道理，后来也得到了雍正皇帝的肯定，但似也有点偏激。


八、雍正与禅宗

八、雍正与禅宗

    雍正皇帝胤祯（１６７８－１７３５）是清兵入关定鼎中原后的第三代皇帝。后世围绕其继位、暴死等事件传说甚多，多谬不实。其为政方略遭人物议处亦多，但他在位十三年（１７２２－１７３５），勤于政务，任用贤才，励精图治，在文治武功方面，都不愧一代英主之名。史称“康乾盛世”，实离不关雍正承前启后的功用。雍正还是一位很有学问的皇帝，曾从涟于著名学者阎若琚、张英、顾八代、徐元梦等人，不仅通晓《四书》、《五经》等儒家经典，而且诗词，善书画，有相当深厚的汉文化素养，特别值得注意的是，雍正喜读内典，深通佛理，尤其对中国佛教代表性宗派禅宗，更是深得法要，别有慧解。他曾师从高僧，直探心源，亦曾升堂说法，开导辟迷；并以帝王之尊，亲自编选《御选语录》，刊示天下。其禅论戛戛独造、在在中的，远非泛泛涉猎者所能企及。历代帝王中，信佛崇佛之“佛心天子”不在少数，但像雍正这样在佛理上卓然成家者实属罕见。
    （一）开悟因缘
    清朝皇室与佛教因缘颇深。清世祖顺治在他短暂的一生中，与佛教禅宗结下了不解之缘。他曾召禅僧憨璞性聪，玉琳通琇、木陈道（一个文字头，一个心字）等到内宫探讨佛法，谈论禅理。他自称“痴道人”、凡请禅师说戒之类的御札，都自称“弟子某某”，与宗门耆旧相见，不令称臣致拜，从容咨访，握手温颜，情逾师友。
    清圣祖康熙在位期间，曾多次巡游江南，几乎每次都参礼佛寺，延见禅僧，赐额题辞。《宗统编年》一书即受康熙之命而撰。康熙皇帝尤其尊奉藏传佛教，对达赖、班禅、章嘉等活佛多有敕封赏赐。二世章嘉阿旺洛桑却丹更是以国师之尊，出入皇宫，奔走边关，极得康熙宠幸。
    章嘉活佛转世系统，是清代四大尖佛转世系统之一，一世章嘉扎巴俄色，青海红崖子沟张家村人，所以由他开始的转世活佛系统称张家活佛，康熙帝时，以“张家”二字不雅，改为章嘉。二世章嘉曾从五世达赖喇嘛学习。１６９３年被康熙帝封为呼图克图。康熙帝击败准噶尔部噶尔丹之后，在多伦召集蒙古各族王公会盟，建汇宗寺，封他为“灌顶普善广慈大国师”，主持汇宗寺，掌管内蒙古地区佛教事务。
    因章嘉国师经常出入内廷，与诸王子关系亦密切，而与其最投缘的是四王子雍亲王，即后来的雍正皇帝。
    据雍正自述，他少年时即喜读内典，年轻时曾雇人代替自己出家，同时与僧侣来往密切，在读书时，将自己喜欢的文章编辑成《悦心集》，里面所面所选多看透世事，任情放达的文章。如《醒世歌》曰：“南来北往走西东，看得浮生总是空。天也空，地也空，人生杳杳在其中。日也空，月也空，来来往往有何功！田也空，地也空，换了多少主人翁。金也空，银也空，死后何曾在手中。妻也空，子也空，黄泉路上不相逢。”
    但早期雍正“惟慕有为佛事，”而对无迹可求的禅宗，因无实际体证，故未能窥其端绪，且每每非之。在结识章嘉活佛后，雍正与其“时接茶话者十余载，得其善巧方便，因知究竟此如。”消除了对禅宗的偏见。因藩邸与柏林寺相距不远，雍正与柏林寺禅僧亦有接触。康熙十一年（１７１２）春，雍正到柏林寺，遇妙智禅师，相谈甚洽，遂产生随僧众坐禅的想法。
    正月二十日，与数十僧一起打七，仅二枝香功夫。次日晚又随坐，至三枝香时，洞达本来。主持禅七的是当时名望很高的迦陵性音禅师。在打七之前，雍正与其问难甚久，但未能起一疑情，所以甚感失望。而此时迦陵性音踊跃赞叹，谓雍正已彻元微，笼统首肯。雍正自己当时自以为了歇，而数日后又觉不甚洒脱，又去叩问章嘉国师。章嘉回答：“若王所见，如针破纸窗，从隙窥天，虽云见天，然天体广大，针隙中之见，可谓偏见乎？佛法无边，当勉进步。”“针隙窥天”是形象说法，实指初步破参，即参禅者初登解脱之门，悟此七尽之躯，四大和合而成，无有实我。
    听了章嘉的开示，雍正复于是年二月十一日随众结七于集云堂。至十四日，正经行时，忽出一身透汗，命根立断，桶底脱落，自觉与佛祖众生同一鼻孔出气。乃复问证章嘉。章嘉云：“王今见处，虽进一步，譬犹出庭院中观天矣。然天体无尽，究未悉见，法体无量，当更加勇猛精进。”“庭院观天”指涉过重关。重关又称前后际断，指悟得山河大地，十方虚空，无非空华幻影。
    雍正亦曾垂询迦陵性音，并将章嘉的开示告之性音，岂料大禅师竟然不解其意，讪讪地说：“此不过喇嘛教回途工夫之论，更有何事？”雍正认为章嘉所说真实可信，而对性音之语不以为然。
    雍正谛信章嘉之垂示，为直达究竟而精进提撕，至次年（康熙五十二年）正月二十一日，复堂中静坐，无意中踏末后一关，“达三身四智合一之理，物我一如本空之道”。境智融通，色空无碍，获大自在。雍正再去叩问章嘉，国师望见即曰：“王得大自在矣。”雍正心生大欢喜，庆快平生。在《历代禅师后集后序》中，雍正追述了自己的参究因缘，对已故世的章嘉深怀感念，“章嘉呼图克图国师喇嘛，实为朕证明恩师也。”
    （二）圆明语录
    雍正自称破尘居士、圆明居士，以示寄情尘外，不受俗累之志。《悦心集》有一篇《布袋和尚哈哈笑》，将世上的英雄圣人，甚至皇帝都讽刺一番。“我笑那天上的玉皇，地下的阎王，与那古往今来的万万岁，你戴着平天冠，衣着衮龙袍，这俗套儿生出什么好意思，你自去想一想，苦也么苦，痴也么痴，著什么来由，乾碌碌大家喧喧嚷嚷的无休息。”文中还有“千载勋名身外影，百岁荣辱镜中花”、“悚问沉浮事，问娱花柳朝”、“漆园非所慕，适志即消遥”等诗句，透露出雍亲王学佛后虚豁旷达的胸襟和气度。
    康熙五十一年夏，雍亲王到热河避暑，白天闲来无事，乃将古德公案，一一研究。这时的雍亲王已是“透过重关”，习禅深有所得的居士了，在看过前人分案后，陡然自信起来。因为“今见昔人之语，与朕之所言，多不约而暗符，无心而自合。圆音如是，不禁哑然。”在窥知古人意旨之浅深、机用之妙密后，雍正随有拈提唱颂若干首。另有与诸禅侣及护卫待从之问答机缘，皆在茶饭后闲暇之时随感而发。这些禅话皆被侍从记录下来，编辑成帙，此即《圆明居士语录》。
    雍正的禅学见地，皆从实际修证中来，所以雍正最鄙薄“口头禅”、“文字禅”，而重视真实见地，在《语录》中言及见道行道难易时，雍正云：“从来言，见道易，修道难；修道易，守道难；守道易，行道难。圆明不然此论。若见假道场，修假道难；修假道易，守假道难；守假道易，行假道难。若真实言，则行真道易，守真道难；守真道易，修真道难；修真道易，见真道难。但得真见，修守行皆易于为力。若见处不真，修守修，不但难之一字，亦断不能成也。所以云，参须真参，悟须实悟，但得本、何愁末？”
    雍正所理解的真见是什么？实即空义。空包括境空、心空。雍正云：“学人初闻道，空境易，空心难。究竟则空心易，空境难。空境而不空心，到处为碍。空心而不空境，触途成滞。不见道心空及第？应知心外复有何物而可空？物外复有何心而可空？所以云，我自无心于万物，何妨万物常围绕？”雍正又云：“天无心覆而普盖，地无心载而普擎，三光无心明而普照，圣人无心用而普应。圣凡之殊、丝毫之隔，只在有心、无心之别耳。”有真实见地者，应则天象地法三光，勿起分别心。如此则终日吃饭，不曾嚼着一粒米，终日著衣，不曾挂著一条丝。
    雍正在《语录》中还就参禅的方式方法，根据自己的参悟经验，予以解说。如关于重关功夫，雍正指出，在初步破参后，虽说大事已明，但脚跟未稳，切忌得少为足，不肯精进。此时需要的是生疑。起疑情，总生大奋志，总有向上一路，而涉重关后，则要不疑而入真实。因此时已悟到万法本空，妄想执著全消，已露智慧德相，所以只管赤条条去即可。佛常将众生的无明妄想喻为迷头认影，而此时既已消除错认颠倒，识得本真，则头影之说可以不论矣。又如关于回途工夫，本来透重关后，已证得智慧德相，不必管回途不回途，但随遇而安，于一切处出入自在即得。如狮子之搏鹿，自在戏乐，透重关者亦得此三昧，回转往复，独步无畏。如果一年半载后仍觉不洒脱、不妥贴，就说明重关功夫未曾通彻。此时不妨重起妄情，再下一番功夫。古人云功不浪施，即便错用心，也只当写作几篇文字，辨理几件事件，无有大碍。关键是不可执著某一境界，因为著一境界，便是魔境，参禅最紧要的是目下功夫，至于更进一步处，待到功夫到时，自然了彻。这些言论，皆非亲历者不能言。
    在《语录》付梓刊刻之际，他再次表白，非慕作家居士之虚名，亦不敢与古来大善知识比肩，惟念佛祖开此无上法门教化众生之恩，欲使人信知妙性不远，明觉非遥，祖印遥传实有据，而言思绝处非虚说也。
    （三）宫廷法会
    据说，雍正曾从章嘉活佛受“深广教法”作为祈愿即位执政的因缘，并曾赐给章嘉一副珍奇座具，后来果然如愿以尝，登上王位，从此对章嘉活佛更加崇拜信服，无论这是否属实，雍正结交僧侣，忘情禅悦，而不像其它王子那样攀缘结党。投机钻营，确是他在康熙朝纷乱的皇储之争中脱颖而出的重要原因。雍正即位后，虽政务繁忙，仍留意佛法。大臣沈近思少年孤贫，曾在灵隐寺出家。雍正以佛理问之。沈对曰：“臣少年潦倒时，尝逃于此。幸得通籍，方留心经世事以报国家。亦如皇上圣明天纵，早悟大乘，然万几为重，臣愿皇上为尧舜，不愿皇上为释迦。即有所说，安敢妄言，以分圣虑！”雍正本欲觅一知音道友，不意碰了软钉子。雍正还曾问大学士张廷玉：“廷臣中有通禅悦者否？”张廷玉以张照对。雍正即召来问：“视朕何人？”对曰：“是佛”，“汝自视何人？”对曰：“乾屎橛”。言下大契，张照比之沈近思，“道行”的确高多了。
    据《诏录序稿》称：“逮次年（康熙五十二年）登清凉山回，宗门载籍，绝不流览。”又云，“登极以来，复十年于兹，除御园焚修文行禅师外，未见一僧，亦未曾齿及佛法一字。”雍正登极后，的确比较勤政，力图匡正康熙朝末年的颓靡之风，为此创设了军机处和密折制度。常常一天到晚接见军机大臣，批复密折，真可以说“朝乾夕惕”了，但如果说十年未曾言及佛法一字，则未免绝对了。雍正十一年春至夏，雍正在处理政务之暇，与内廷王公大臣多次探讨禅机、禅理。雍正共下一百则转语，让众人参对，此即《圆明百问》。交上“答卷
”的共六人，即张廷玉、鄂尔泰、福彭、允禄、圆寿、允礼。
    从《御选语录》所选张廷玉等所作诗文看，他们皆对禅对教有一定造诣，这也表现在他们各自的禅机奏对中，如雍正问：“历代佛祖中有一人超佛越祖，且道是那一人？”张廷玉答：“是佛”；鄂尔泰答：“无名氏，”福彭答：“土块”，允禄：“一手指天，一手指地，道不远人。”雍正所问的那一人并非实指哪一位佛无情共有的佛性或法性。称其为法身佛，是为了与报身佛、化身佛相对应的形象化说法。法身虽超色体而又不离色体，所谓“恒沙诸佛同一性，物我原来无异同。”能于诸色体识得法身，方显出禅者的机锋。张廷玉答以“佛”，表明他识得佛与佛性一如，鄂尔泰如允禄、答以“无名氏”、“人”，表明他不仅识得佛与佛性一如，而且识得一切凡夫众生具足同一佛性。以上三人的回答都显示出各自的佛学及禅学修养，但三人所指示法身之所在，都不出有情有识的范围，总有执虚为实的倾向，未到悬崖撒手的境界。福彭答以“土块”则不同凡响，不仅佛视众生与法身不一不二，而且一切山河大地也无一不是法身！所谓盈天地间，惟一真佛，百千万亿泥佛、木佛总是一佛是也。福彭所作《真如铭》曰：“即心即物，即物即佛，心佛物合，何异何同？”表达了同样的旨趣。
    经常与雍正帝探讨禅理者，除以上六大臣外，还有宝亲王长春居士（即后来的乾隆皇帝弘历），和亲王旭日居士弘画，以及左御史得无居士张照。在《御选语录》中，雍正对他们称许有加，谓古今禅侣，一生一世了无所得者大有人在，所谓谈空说妙者似粟如麻，而了悟自心者凤毛麟角，而今“王大臣于半载之间，略经朕之提示，遂得如许人一时大彻，岂非法会盛事？”雍正将这些内廷王大臣的禅诗、禅论合为一集，名《当今法会》，附于《御选语录》中。
    （四）御选语录
    禅宗本来标榜不立文字、教外别传，但到后世，禅宗的著蜍并不比其它宗派为少。除一些专题著述如四祖《信心铭》、永明智觉《宗镜录》、永嘉玄觉《证道歌》等等之外，就是林林总总的灯录和语录。灯录主要记述嗣法传灯的禅师门的行履和事迹，如《景德传灯录》；语录则是禅师法语偈颂的汇集，语录既包括单个禅师的语录，如《坛经》、《临济义玄语录》、《赵州禅师语录》等。也包括众多禅师语录汇编，如《古尊宿语录》、《指月录》、《正法眼藏》、《禅宗正脉》、《教外别传》、《五灯会元》等。要编辑大型的禅宗语录，不仅需要有相当的禅学造诣，而且需要编家的识见和慧眼。惟有别具只眼，总能从万千公案中辨分珠玑，披沙淘金，将真正有价值的公案存留下来。故此，禅宗史上那些著名编家如妙喜（《正法眼藏》编者）、幻寄（《指月录》编者）待，同样受到后的的敬重。时代推移到清代，从宫廷中走出一大编家，欲以自己所编语录传之久远， 以振禅宗于颓废，挽慧命于悬丝，这就是雍正皇帝和他的《御选语录》。
    雍正皇帝对自己的禅学见地有着惊人的自信，从《御选语录》及其它文字资料看，除了他的证明师章嘉国师之外，和他同时代的禅师以及许多前代大禅师，似乎全不放在眼里。大有笑傲天下丛林，扫尽古今英雄的气概。雍正所居至高无上的地位，再加之他确曾于参学下过一番切实的工夫，使得他黜陡古今，无所忌讳。
    当时，天下丛林最流行的语录就是《正法眼藏》和《指月录》。由于这两部语录的广泛流行，使最偏僻的山间小寺，也能见到释子研习拈唱古德公案。雍正在肯定这两部语录的优点的同时，又指出其所选非当，有严重纰瑕，这主要是因为编者见地未到，于古德语录，如对粉中之雪、煤中之墨，拣择不清。决定取舍，往往以语句是否尖断，机锋是否敏捷为标准，全不论其是否发明本心，有否真实见地。故而其所选就难免“掷黄金而取瓦砾，宝鱼目而弃摩尼。”雍正还分析了这些劣品公案得以流传的原因，在雍正看来，对这些不了言句，那些禅师并非不知其非常一义谛，只是为俗情所累，忘却续佛慧命的神圣职责。或以祖师所遗，视为家珍；或囿于门户之见，恐起争端，故明知其非，百般回避，其或附会拈提，曲作圣解，遮天下人眼目，如果不是生具慧命，见识独到，岂不为其所误。雍正自认非秉拂说法之人，自能超脱门户不见，以客观公允的立场，对古德公案或语录，加以抉择。
    雍正编辑《御选语录》的时间，在雍正十一年（１７３３）春至夏。在编辑过程中，雍正见到了当时迦陵性音禅师所编《宗统一丝》，翻阅之下，龙颜大怒。在雍正看来，此书所选“纷纷杂出，撩乱错出，”全不见编家的识见与禅德的慧眼。他甚至骂性音“昏愦卑鄙”，丝毫不留情面。他举例说，涌泉欣、天衣怀和韶国师等所出言句，皆从本分心地流出，如摩尼宝珠，如赤刀大贝，但此书弃之不顾，相反对德山宣鉴的诃佛骂祖之句，和南泉普愿水牯牛公案，却一概采用，简直如“鸱鼠嗜粪”般醜恶不堪。更难让人容忍的是，性音将当时开堂说法的禅师的法语，不管是否有见地，人人各编一则。雍正认为，如此取媚同参、自抬身价之举，与世间浇薄士子，彼此标榜选刻文字，无异同一伎俩。
    雍正以九五之尊，君临天下，以尧舜禹汤文武之道治天下，原本与方外之事无甚干系。但在雍正看来，自己既以特殊的因缘深入藏海，与本分处“少得相应”，则有责任为宗门整顿一番，以不负佛祖之深恩。
    《御选语录》包括《正集》、《前集》和《后集》，最后还有《御选当今法会》，带有附录性质。
    雍正在序言中提出了自己对禅师的确良选录原则，那就是不重虚名浪誉，惟看其是否达真实理地。如果其人有参实悟，则收录无遗；如其不然，则其人虽千百年来人人所共推崇，也置之不论，从《御选语录》的内容上，可明显看出与其它语录的不同，《正集》部分共收十五人，即僧肇、永嘉玄觉、寒山、拾得、沩山灵祐、仰山慧寂、赵州从谂、云门文偃、永明延寿、紫阳真人、雪窦重显、圆悟克勤，玉琳通琇、筇溪行森及雍正自己。
    《正集》收录的第一人不是历代推崇的大禅师，而是僧肇，确实出人意表。僧肇（３９４－４１４），东晋僧人，鸠摩罗什弟子，曾参加鸠摩罗什译场，评定经论。并著《般若无知论》等，在鸠摩罗什门下，被称为“解空第一”。但一般认为中土禅行始于达摩，达摩之前，中土未闻教外别传之旨，故僧肇虽道行超绝，见地逸偷，亦难列祖席。而雍正阅《肇论》诸篇，赞叹不已，认为非深明宗旨，了彻本源者，不能到此境界，遂追封僧肇“大智圆正圣僧”之号，并将《肇论》、《宝藏论》选入《御选语录》。僧肇所著《般若无知论》、《涅盘无名论》等，句句深达佛心，言言备通众教，虽无宗乘之名，而有直控心源之宝，达摩未来之时，中土无禅宗之名，但却不能说无禅，僧肇诸论即是明证。后世禅师常举“达摩见梁武帝时无所从来，遇宋云时亦无所去，”以明禅之无时不在。雍正则直接把僧肇编入大禅师之列，这确实是超人的识见和胆略。
    更引人注目的是，禅宗史上许多著名禅师未被选入《正集》，而道教史上的重要人物紫阳真人却赫然在列。紫阳真人（９８７－１０８２）即张伯端，又名用成，字平叔，号紫阳，北宋天台人。曾长期研习丹书，其所著《悟真篇》，与《道德经》、《阴符经》齐名。紫阳真人还同时结交禅僧，涉猎内典。其《读雪窦禅师〈祖英集〉》称当时禅宗云门宗巨擘雪窦重显（９８０－１０５２）为老师，赞曰：“吾师道高言顺畅。”似曾亲炙雪窦者。《悟真篇》外集为紫阳真人专论禅宗的诗文，称《禅宗诗偈》，被雍正选入《正集》。在雍正看来，紫阳真人是不世出的大禅师，虽以仙俊名世，但其言句真证了彻，直指妙圆，虽古今禅门大德，能如此深探究竟者亦不多见，从《禅宗诗偈》看，紫阳真人确有很高的禅学造诣，其高妙处在以道通禅。如以“道”释真如佛性，所谓“无体之体即真体，无相之相即实相。”以道家的自在消遥释禅悟解脱，所谓明心体道之士“物不能累其性，境不能乱其真”“随机应物，和而不唱”；以体道证真释明心见性，所谓“欲体夫至道，莫若明乎本心。故心者道之体，道者心之用也。人能察心观性，则圆明之体自现，无为之用自成，不假施功，顿超彼岸。”所有这些，非真通道通禅者不能道出。紫阳真人也颇自信，《〈悟真篇〉后序》谓若“见闻此篇，则知伯端得达摩、六祖最上一乘之妙旨，可因一言而悟万法也。”
    紫阳真人谈禅虽然借用道家的一些思想概念，但他并不是销道入禅，或以禅凌驾于道之上，春拳拳服膺的仍然是道家的思想体系和修行实践，故将《禅宗诗偈》列为《悟真篇》外集，以示大道一贯。以使观者睹此而明彼。但雍正则不这样看，他认为紫阳真人非以道教为内，禅宗为外，则是以此标明禅悟境界为超乎三界、真亦不立的无上境界。言外之意，紫阳真人是将禅作为自己精神归宿的。此虽不失为一种精致的解说，但却未必符合紫阳真人的原意。因为紫阳真人虽出入儒释，但毕竟以道为根本，其修学业要旨是性命双修，即从修命（精气）入手，先炼精化无，进而炼无化神、炼神还虚，虽然在紫阳真人看不起来，在最高境界上，禅道是相通的，明心见性即体道归真。但他以为在具体修持路径上，禅道各有长短。在养神修性方面，道教自逊禅教一筹，而在炼精修命方面，禅又不及道。《悟真篇》七绝第一首评禅家：“饶君了悟真如性，未免抽身却入身。何以更兼修大药（内丹命术》，顿超无漏作真人。”在紫阳真人看来，只有“性命双修”总是道。
    在《正集》所选十五位禅师之外，雍正又依《正法眼藏》和《指月录》二书，选录一百五十六位禅僧。除六祖外，还包括志公、马祖一、南岳思、石头迁、忠国师、长沙岑、观国师、临济玄、投子同、曹山寂、玄沙备、韶国师、以及药山俨、黄檗运、洞山价、罗汉琛、法眼益、天衣怀等等。在雍正看来，这些禅师与《正集》所选诸大善知识相比，在见证方面无甚差别，但细细评量，其言句犹有珠玑之分，所可采者无多，难以单独成卷，故合为一集。
    在上述一百五十六位禅师中，没有传大士、大珠海、丹霞天然、灵云勤、德山鉴、兴化奖、长庆棱、风穴沼、汾阳昭、端师子、大慧杲、弘觉范、高峰妙等。而这些禅师在宗门中历来被视为提携后学的宗匠。其机缘示语亦屡被后世禅师拈提唱颂，但在雍正看来，这些禅师都未达究竟理地，其垂示机缘，或大悖常理，支离谬误，或偶露见地而未到圆通处。与《正集》所选诸大善知识相较，不啻有天壤之别。雍正还特别拈提这些禅师的代表性公案，以认其非。如德山宣鉴以“德山棒”驰誉禅林，但雍正对其呵佛骂祖语极为反感，不仅一句不录，而且在《御选语录》的序言中大加诃斥。佛祖，以出世间法论则无生身之所，佛身遍满法界，一切有情无情及山河大地无不是佛，如此则能诃者谁？所诃者谁？众生不明此理，判生佛为两途，析圣凡为两端，对佛祖只知顶礼赞叹，忘却自家生命安顿，如此圣见不除，则触途成碍，古德老婆心切，以呵佛骂祖，除众生之见病，有意以这种激烈的方式，求得发人深省的效果。但必须明白，禅师的这种施为，只是接引初机的善巧方便，是师道而非禅道，即必得了辨自家本分事，方得依究竟而为方便，如若不然，望文生解，以为呵佛骂祖师为圣凡情尽，人物两忘，甚或学人饶舌，专以呵骂佛祖为能事，则不特有堕凡见，亦且造大诞语，生大口业，阎罗殿前刀山剑树，专为此辈而设，从世间法论，佛祖，先圣先师也，释子即以佛祖为祖父，岂能信口讥呵？基于同样理由，雍正对凡霞天然烧佛取火公这杂也嗤之以鼻，讥之为“狂参妄作”。雍正认为这些人犹如家之逆之，国之逆臣，适足堕畜生道。有人谓古德曾言：“六道轮回，一道齐平，方是透天透地，有何因果？”岂不知必先有通天透地的境界，总可言六道轮回任人出入。若未透三关，证得空有一如，即妄污因果，则因果之报不旋踵而至矣。基于此雍正把南泉普愿水牯牛公案（向异类中行）评为最下品，只因南泉颇有本分之语，总未加深斥。其它“三唤侍者”、“婆子烧庵”、“野狐听禅”、“南泉斩猫”、“台山婆子”等著名公案，雍正均有苛评，悉不选录。
    在评定前代禅师及其公案过程中，雍正特别强调，五家宗旨，同是曹溪一味，只不过接人的面目不同而已，若逐渐分宗，以情见分别之，甚或妄生争执，则大悖古圣“剿情绝见”之旨。雍正还对达摩传衣偈“一花开五叶，结果自然成”作了新的解释。他认为：“五叶”非喻“五宗”，而是指达摩之禅法“五传”而至慧能。五宗之说，不过是后世宗徒妄加附会而已！
    雍正时代，临济宗、曹洞宗最盛，二宗各有一些宗徒著书立说，争长论短，喋喋不休。雍正深感宗派之见繁盛，则正知正见不存，故对宗派之争恶痛绝。他不仅在编选语录时完全打破宗派界限，为天下宗徒作出典范，而且要求天下丛林古刹，无论何宗何派，在供养本支祖师外，应将从上古德一一设位于堂，以供朝夕礼拜供养，欲以此举，匡正禅林各守门庭的习气。
    （五）拣魔辨异
    雍正不仅自己参禅、谈禅，而且不惜帝王身份、直接出面干预当时禅宗内部的派系之争，亲自撰制《御制拣魔辨异录》，并下论，动用政治力量，打一派，扶一派，以期消除外魔知见，弘扬正法。
    禅宗内部的派系之争，系指明清之际，临济宗密云圆悟与汉月法藏一系的争论，汉月法藏（１５７３－１６３５）于海虞之三峰闻折竹声而开悟。后于天启四年（１６２４）至金粟寺，为密云圆悟之首座，然不满圆悟所提倡之“自怀自悟”说，于天启五年著《五宗原》，以纠正曹洞宗之误为由，强调禅宗五家其来有据，法藏将曹洞宗抹杀五家旨，仅单传释迦拈花一事，评之为　室中密授之死法，强调自威音王以来，无一言一法非五家宗旨之符印。法藏并依一大圆相探究佛祖之本源，密云圆悟不然法藏之论，于崇祯七年（１６３４），著《辟妄七书》，九年著《辟妄三录》，以驳法藏之说，并斥法藏为名利之徒，圆悟之弟子木陈道（一个文字头，一个心字）著《五家辟》，呵骂法藏。法藏之弟子潭吉弘忍则撰《五宗救》，非难道（一信文字头，一个心字），极力为师辨护，圆悟又于弘忍寂年（１６３８）撰《辟妄救略说》，驳斥法藏与弘忍。但法藏门人具德弘礼、继起弘储等，皆一时后秀，故法藏一系（因其开法于常州三峰，故称“三峰派”），在顺治、康熙朝，在江南地区很有影响。
    雍正对五家宗旨之说，历来嗤之以鼻，故他明确地站在圆悟一派立场上，对法藏一派严加鞑伐，反复辟驳，他认为，圆悟的《语岩》，“其言句机用，单提向上，直接人心，乃契西来的意，得曹溪正派。”而法藏之言，则“全迷本性，无知妄说。不但不知佛法宗旨，即其本师悟处，亦全未窥见。肆其臆诞，诳世惑人，此真外魔知见。”在《御制拣魔辨异录》中，雍正从《五宗原》、《五宗救》中，择出八十余条，逐条加以辨驳，痛斥其非。
    如在《五宗救》中，弘忍谈到禅宗的发展时云：“及其弊也，知解横生，故不得不变而为机锋、为棒喝；又其弊也，不得不变而定宗旨；宗旨定，若三代之礼乐备焉，虽千圣继出，不能易矣。”又分析五宗纲要云：“夫言论之弊也，弊于心性；而棒喝之弊也，弊于乱统。故从棒喝悟者，知乱统之病，而建同喝四喝、料简元要、函盖截流等纲宗、临济、云门是也；从机语悟者，知心性之病，而建四禁五位六相，种种三昧门等纲宗，曹洞、沩仰、法眼是也。”
    雍正认为，“若论五宗，俱是门庭边事。”各宗门庭施设虽不同，但若从施设处去求入处，无异夸父逐日、韩獹逐块。因为“禅宗无语句，亦无一法与人，”一切方便施设，俱非实法，不可妄加执著，更不可认指为月，以这些“纲宗”为究竟。“从上古德种种施设，有时行棒行喝，有时瞬目扬眉，或时架箭张弓，或时吹毛竖指，虽时节因缘不同，偏圆顿渐各异，折合归来，究是学人自了自心。何尝举起一丝毫与人，何尝于自性自度外，有甚奇特秘密？”在雍正看来，学人真实悟，大死大活，也不过与佛祖同一鼻孔，只为自己本分元辰，本来来是。或佛祖如是，我亦如是，岂得别有一法可宣可秘，可受可传。法藏、弘忍辈妄定五家宗旨，不特涂污古德，亦且贻误后学，因为它诱使学人依文生解，逐语分宗，只求高手阿师之口传面授，而不去反求已躬，真参实悟。
    在《五宗救》中，弘忍又曰：“凡先圣或此〇相，若伏义之卦画也，虽无文字，而天地万物之理备焉。而七佛列祖传法偈，若文王之系辞也。所云双头独结，无文密印等。其爻象乎？盖以此〇相统言诠，以言诠入此〇相，不相害也。”
    在禅宗里，常描画一圆形图以象徵真如、法性、实相，或众生本具之佛性能等。禅僧每以拂子、如意、拄杖或手指等，于大地画一圆相，有时亦以笔墨书写此类圆相，表示真理之绝对性，相传圆相始作于南阳慧忠。忠示耽源，源示仰山，仰山一见即焚却。沩山举圆相，内作一字，仰山就地画一圆相，内作一日字，以脚抹之，沩山大笑。
    雍正认为，圆相不在内，不在外，不在中间；圆相前无始，后无终，现在无现在；圆相不是心，不是佛，不是物。以此比拟真如实相，差可近之。但必须明白，此圆相，不过言思绝处，不得已而为之，究非真如实相本身。法藏等以此圆相为千佛万佛之祖，实为邀奇取胜，大乖教外别传之旨，若说九十七圆相奇特，任何人都可随意作八万四千圆相，此又何奇？雍正奉劝弘忍辈于沩山大笑处、仰山焚却及脚抹处荐取，莫以凡情测圣智，妄污古德。
    在对法藏和弘忍的思想逐条批驳后，雍正颁下谕旨：“著将藏内所有藏、忍语录，并《五宗原》、《五宗救》等书，尽行毁板，僧徒不许私自收藏，有违旨隐匿者，发觉以不敬律论。……法藏一法所有宗徒，著直省督抚详细查明，尽削去支派，永不许复入祖庭。”从此以后，三峰派在临济宗中衰落下去。
    有谓雍正以帝王身而行法王事，不畏眉毛堕地而为众生解粘去缚，真世间之金轮圣王，出世间之再来人也。然亦有不谓然者。千秋功过，见仁见智，只如留待后人各自评说。从览雍正一生的禅修行持及见地独到之禅论，可以看出雍正禅学思想的最大特点，即强调习禅者真参实悟。雍正从自身的禅悟经验中认识到没有实际的修持功夫。就永远不能断惑证真，即便讲得头头是道，天花乱坠，也不能于日常行止中得到真实受用。当年雍正有所悟入时，与之结交的迦陵性音劝他研辨五家宗旨，雍正问五家宗旨如何研辨？性音答：“宗旨须得口传。”雍正大不以为然。在他看来，释迦无言拈花，迦叶微笑承旨，何有言为？达摩东来，慧可断臂求法，亦非口传耳受。究极而言，禅家的一切言说皆是无义味语，堂堂丈夫，岂能拾人唾涕，于古人言下求活路？
    雍正恳切地奉劝天下宗徒以担荷如来家业、续佛慧命为已任，“参则实参，悟则实悟”，但求觉悟，莫计名利，尤其不可于公案上盲拈瞎颂，强作解事，此不但自绝圣路，而且贻误后人，徒僧罪业。雍正的警策当是有感而发的，当时禅林中，许多人不于契证处自了自心，但于公案上做功夫，采摭攘窃古人言句，差排牵合，“为可能不可能语，作若通若不通之文”，全无实际的底蕴和真实的见地，以此为拈代偈颂，适足涂污古人，误累已身，因为如果没有身心了证，即便所出言句，句句如佛所说，亦是从解路中来，与灵觉全无交涉。雍正劝告学人，与其轻言参透葛藤，转不如讲诵经典，熏习佛种，以待机缘。
    禅宗发展到清代，流弊日炽，实际上已很难见到早期禅宗那种大破大立的卓荦气象，一些无知钱徒，更是只得宗师之唾涕，甚或专以呵佛骂祖为能事，几与市井无赖无异，更有以教外别传而胡作非为者，一时狂禅流荡，野狐遍野，禅宗的真精神几乎荡然无存。雍正欲以帝王之尊，藉个人的影响力，振衰起颓，挽回宗风，其用以可谓良苦。


一、圆瑛禅净兼弘

第十四章

    进入近现代后，中国佛教神日渐衰微，但传承不断，法脉绵延、敬安、圆瑛、太虚、虚云、来果、明真、印顺等一批高僧、大德主持佛法，长者、居士大力扶持，光大宗门，颇有建树。

    一、圆瑛禅净兼弘
    圆瑛（１８７８－１９５３）为中国近代禅门高僧。他宗说兼通，台贤并弘，精研《楞严》，禅净双修，归宿“三求”，爱国爱教，弘法度生，为中国佛教事业作出卓越贡献。
    圆瑛，俗姓吴，法名宏悟，号韬光、一吼堂主人。福建古田县人。父名元云，母亲阙氏。因祷于观音菩萨有感，于清光绪四年（１８７８）生。幼失怙时，由叔父诗瑛扶养，五房一嗣，备受慈爱。年稍长，感身世孤零，人生如幻，欲出家，叔父不许。１８９３年投考本县秀才，次年中取，名列前茅。１８９５年秋（十九岁）大病一场，病愈投福州鼓山涌泉寺，礼莆田梅峰寺增西上人为师，剃度出家。次年，到涌泉寺依妙莲和尚受具足戒，后到大雪峰崇圣寺谒达本禅师，充当钣头菜头，茹苦含辛，清修梵行。
    二十一岁，圆瑛回到常州天宁寺，依治开老和尚参究禅宗心法，四年中获益良多，继往宁波天童寺依敬安禅师习禅定，前后六年，两次现悟境。其间还随道阶、谛闲、祖印、慧明诸师学天台教观。１９０６年拜宁波七塔寺慈运和尚，亲受法印，为临济寺四十世，法名宏悟；后又到福州雪峰达木老和尚处再受法印，传曹洞宗第四十六世，法名今悟。１９０７年（二十九岁）太虚法师在天童寺听道阶法师讲《法华经》，深受道阶法师重视，许为法器，圆瑛也与太虚在御书栖结为盟兄，还结交了会泉、转道法师，次年回闽，在涌泉寺开座讲经，声誉日隆，１９０９年主持宁波接待寺，创佛教讲习所，１９１１年参加敬安等联合十七省僧侣在上海成立的中国佛教总会，任总会参议长。１９１７年当选为宁波佛教会会长，创办僧民学校及宁波佛教孤儿院，１９２０年在北京讲《楞严经》、《法华经》，参与组织佛教赈灾会，救济灾民无数。１９２２年到南洋弘法，在新加坡、槟榔屿等处讲经，在转道法师兴建的普觉寺讲《大乘起信论》。１９２３年秋回泉州重修开元寺。１９２５年在寺中办开元慈儿院，任院长，收养孤儿二百多人。１９２６年重渡南洋募慈儿院基金。
    １９２８年至１９３０年，全国多次发生侵夺庙产“兴学”风潮，圆瑛、太虚、谛闲法师及王一亭、谢铸陈、黄忏华诸居士，发起成立中国佛教会（以圆瑛为会长），向政府请愿，全国佛教团体通电呼应，终使事端平息。“九一八”事变，东山省沦陷，他通告全国佛教徒启建护国道场，１９２３年冬，天童寺失火，圆瑛亲自募化，三年后得以重建，较前更加庄严。１９３５年在上海建圆明讲堂。同年辞天童寺方丈职，任鼓山涌泉寺住持。卢沟桥事变爆发，即投入抗战救亡行列，组织僧侣救护队。同年１１月率徒明旸法师赴新加坡、吉隆却、槟榔屿、怡保、马六甲募款。至１９３９年止，募到巨款，陆续汇去救难赈灾。九月初一在圆明讲堂突遭日本宪兵队拘捕，被关押南京，虽遭严刑审讯，仍义正词严据理申辩，开展绝食斗争，表现了高尚的民族气节，九月廿八日出狱，闭门谢客，从事著述。撰《劝修念佛法门》、《发菩提心文讲义》、《阿弥陀经要解讲义》、《佛说八大人觉经讲义》、《楞严纲要》等书。１９４３年，到北平、天津讲经。１９４５年，创新圆明楞严专宗学院，任院长，亲自主讲《楞严》经义。１９４９年后坚持留上海弘法。１９５３年代表中国佛教界出席在北京召开的“亚洲及太平洋区域和平会议”，并出席中国佛教协会寿备会议，被推为第一任会长。后南返天童寺疗养，不久即逝世，终年七十六岁僧借五十七年。一生著作甚多，有《大乘起信论讲义》、《楞严经讲义》、《圆觉经讲义》、《金刚经讲义》、《一吼堂诗集》、《一吼堂文集》等二十种，门人辑为《圆瑛法汇》行世。
    圆瑛禅学思想主要有三个特点：
    第一、精研《楞严》，修禅悟道。圆瑛于１９０５年（二十七岁）在天童寺禅悟后，继续修习佛法。他在通智处听讲《楞严》，至七十四岁《楞严讲义》告峻，可以说是以毕生精力精研《楞严》。《楞严经》是诸佛心宗、群经秘藏。圆瑛初听《楞严》，深感此经是“末世津梁，禅门关钥”，即作为参禅悟道的钥匙，指引众生解脱的南针。１９４１５年他在上海圆明讲堂开办楞严专宗学院时，更明确地说：
    “夫《楞严经》者，诸佛之心宗，群经之秘藏，众生之大本，万法之根源，……由是二番破识，撤去大定之障碍；十番显见，指明菩提之正因。会四科惟是本真，融七大无非藏性。……安住楞严大定，万行繁兴；趣向萨波若海，二严克备。原始要终，不离最初方便；从因尅果，疾成无上菩提。一大藏教，孰有过于此经者哉！”
他把《楞严经》看做开示修禅、耳根圆通、破除五蕴魔障等禅法的根本经典，四十余年精研不轰，虽然法务繁忙，仍时时参究，遇到经中不理解的问题，就写一张纸条，粘贴于座前的墙壁上，反覆琢磨，一旦领悟，再三定实，总把纸条撕下，墙上的纸条由少而多，又由多而少，直至“一房疑义，扯尽无余”，因用功过度，三次吐血，仍精进不止。研究此经竟达十载，讲此经达十三次，可见他用心之良苦。他讲说《楞严经》，被天台宗尊宿谛闲称为“海内独步”，被尊为“楞严座主”，从１９０９年在鼓山开讲《护法论》始，至１９５２年底（七十五岁）在玉佛寺讲《楞严经》止，讲经说法四十三年，所讲以《楞严经》为主的各种经论二十余种，直至六十三岁始出《楞严纲要》一卷，六十八岁始著《楞严纲要》二十四卷，七十五岁告峻，可见其著述之严谨。他所创办的楞严专宗学院，即以《楞严》为正课，以《圆觉经》、《大乘起信论》，台贤教义、惟识等为助课，听讲的除本院为僧外，四众弟子络绎不绝。
    禅宗之根本精髓，在于教人开佛知见，明心见性，顿悟心源。对此，圆瑛《首楞严经讲义》点明：
    佛之知见，乃众生本具六根之中不生不灭性。
    根性，即是佛性。此性常在六根门头，放光动地。在眼曰见，在耳曰闻，在鼻曰嗅，在舌曰尝，在身曰觉，在意曰知。
这种关于六根之性即佛性的“根性”说，是继北魏地论师佛性当果而现的“当常说”、佛性现成的“现常”说以及吉藏《三论玄义》论佛性十二家之说以来的新贡献。他论“参禅以修止观为下手，止观功深，而得定慧。”“参时，即用本觉理体，起一段始觉智光，照着那一个话头。”“教人看一句话头，截断意识不行，令见清净本然之心性。”可见，圆瑛的禅学思想既是继承宋大慧宗杲以来“看话禅”的传统，又有自己的独特见解和直接证悟。
    第二、禅净兼修，一吼三求。圆瑛自出家受具以来，学律、持戒、参禅、研究台、贤、法相、三论、密宗真言，无不涉及。１９１３年（三十六岁）阅永明延寿、莲池蕅益大师著作，又归心净土。他教宗兼弘，侧重禅净，归心土。１９５２年在回顾生平修禅历程时诵偈曰：
    禅净双修四十年，了知净土即深禅。
    有人问我其中意，云在青山月在天。
这是对永明延寿“会通禅教”传统的继承和发扬。１９３４年，他在上海圆明讲堂设“圆明莲池念佛会”，由其徒明旸助师弘法，常年组织四众念佛。圆瑛把自己驻锡的道场命名为“三求堂”，自号“三求堂主人”，即以“求福、求慧、求生净土”为宗旨，最后则“一心念佛，求生净土”，并嘱咐弟子们“以三求为正确修持方针”，为真正学佛宗旨。１９５３年农历八月十二日临终时，也在自己净念相续和大众念佛声中安祥往生。
    圆瑛融通禅净，对禅宗、净土法门都有深刻的解悟和实践。他认为禅净虽有二名，其实归元无二，都是针对不同根机而施设的不同法门，不可厚此薄彼。他说：
    禅宗是“接上根者流，是圆顿修持之法，称为最上一乘，中下根人，未足以语此。”
    净宗不论智愚老少，教人但持一句佛号，念念相续，无有间断，以念止念，心中惟有佛，佛外更无心，念到事一心不乱，即得往生。
他既肯定禅宗与净土的区别：有独被上根与适应中下根之分，有依仗自力、愿力、净行之力与依仗自力、他力（弥陀愿力）之别；有能否带业往生之异等，又认为禅净二者可以兼弘，念佛到达极致，则与禅悟无异，他说：
    若论高深，则禅宗单刀直入，固推圆顿，而净宗达理之士，未必或逊。古德云：“忽然起念念弥陀，平时无风自作波，有念消归无念处，岂知无念亦为多。”此则有无双遣，一性圆明，与禅宗圆照清净觉相，无以异也。
    圆瑛不仅圆融禅净，而且对“四种念佛”（实相念佛、观想念佛、观像念佛、持名念佛）的第一种——实相念佛尤为推崇。他说：
    实相念佛，依实相理，念法身佛。法身清净，犹若虚空，遍一切处，无相可得，本无能念之心相，亦无所念之佛相，能所双忘，心佛不二，即心是佛，即佛是心，若念实相佛，则无念而念，念即无念，一心不乱，湛然常住，是为理念。
    他的禅净双修，实际上是把禅修融进净土，也可以说是守定一句阿弥陀的话头来参禅，是禅师们修禅时繋心于佛的一种方法，这是继承四祖道信繋心一佛，专称名字的“一行三昧”的修持理论，并在近代中国人心根器日下的情况下的发明创造。
    第三、拔苦与乐，解行并重，禅宗发展到近代，禅僧的修行往往不单是参禅打坐，深究佛典，而是寓禅修于日常生活之中，圆瑛主张像印光大师一样，“从平常日用做起，家庭社会上做起。佛法世法，融成一气，诚为末世津梁，昏衢宝炬、立功，立德、立言，垂之不朽，”无论是非曲直雪峰寺当饭头、菜头，还是宁波办佛教工厂、农林场、普益学校、佛教孤儿院，泉州开元慈儿院，也不论是华北十六省救灾，还是与侵夺庙产“兴学”风潮抗争，他都以弘法利生作佛事，处处作道场。１９３０年他主持六朝古刹宁波天童寺，僧众逾千，冬参夏讲，冬季传授三坛大戒，定为常规；他还宣布“十二不”的规约，即不贪名、不图利、不营私、不舞弊、不苟安、不放逸、不畏强、不欺弱、不居功、不卸责、不徇情、不背理，　以此作为自己和大从修持的原则，重振古德道风，１９３１年日寇侵占东北三省，圆瑛立即通告全国佛教徒启建护国道场，反对日本帝国主义的侵略行为，并致书日本佛教界，共同谴责、制止日本军阀的侵略暴行。１９３７年“七.七事变”在上海组织一百多人的“僧侣救护队”，赴战地救护伤兵、难民。据上海慈善团体联合救灾会１９３８年报告记载：“淞沪一战共救护伤兵和灾民８２７３人。”为了配合救护队工作，中国佛教会和上海佛教界还在沪成立难民收容院和医院，收容难民三千多人，伤兵数百。为筹集救护、医疗、收容经费，１９３７年１１月圆瑛带弟子明旸赴南洋募款，宣传救国大义，回国后虽遭日本宪兵逮捕，但奋斗不止，１９５２年１０月出席亚洲及太平洋区域和平会议，号召世界佛教徒以同体大悲精神参加国际和平运动，把救苦救难、反抗侵略、维护世界和平作为佛事。以出世精神做入世事业，是圆瑛寓禅修于利生事业之中，解行相应精神的生动体现，也是他充分发扬禅宗济世利民之大乘佛教精神，赢得世人尊重和敬仰的缘因所在。
    圆瑛之徒甚多，有白圣、明旸、明瑞、明如、明哲、雪相、无碍、定持、密显等。明旸法师（现为中国佛教协会副会长、上海市佛协会长）亦传法多人，如开证、源灵、今聪、灵岩、心慈（尼师）等。


二、太虚融汇教宗

二、太虚融汇教宗

    太虚为近代中国佛教大师。印顺法师说：太虚“大师为中国佛学之大成者”。“为近代佛教惟一大师；早年献身革命，中年弘教利群，晚年复翊赞抗建，……融贯统摄，不拘于台贤禅净，卓然成家。”融汇台贤禅净，强调中国佛教“特质在禅”，注重弘教利群，实践“人生佛教”，为太虚佛学之明显特色。
    太虚（１８９０－１９４７），俗姓张，乳名淦森。浙江海宁（石门）人。幼年丧父，失母，五岁随外祖母寓长安镇大隐庵，七岁从舅氏读蒙学，后随外祖母赴九华，朝普陀，礼天童、育王、灵峰诸刹。十三岁当百货店学徒，十六岁志求神通，于苏州依士达监院出家，法名惟心，“惟”字为临济宗派偈“心源广续，本觉昌隆，能仁圣果，常演宽弘，惟传法印”之第十七字。后依奘严禅师往天童寺受戒，戒和尚为中兴天童寺之八指头陀寄禅。十七岁从歧昌禅师受《法华经》，以禅录中“话头”默自参究，后入天童习禅，赴西方寺阅《大藏》，接触革命僧栖云，广泛涉猎严译《天演论》，康有为《大同书》等进步著作。二十一岁就读于南京杨仁山创立的只洹精舍，与欧阳渐、梅光义同学。二十二岁始于广州狮子林之佛学精舍讲学，并任双溪寺住持。次年再次入西方阅藏。１９１２年与仁山法师开佛教协进会成立会于镇江金山寺，进京谒临时大总统孙中山先生，次年在南京创中华佛教总会。随后倡组织、教产、学理三大院，某夜闻前寺开大静，蓦然断息，复历悟境，两年半后出关，作《整理僧伽制度论》。１９１７年经日占台湾岛赴日本国访问，并在上海创觉社。１９１９年与胡适之论究禅学。次年作《太虚宣言》，创《海潮音》，倡《僧自治说》，为汉口佛教会院长，筹建武昌佛学院，主讲《佛教各宗派源流》、《印度哲学》。任佛化新青年会导师，于庐山讲《佛法略释》、《佛法与科学》等。佛化新青年会以狂热的佛教革新精神，引起长老安。１９２４年在庐山举行世界佛教联合会，次年，率团出席日本东亚佛教大会。１９２６年作《建设人间净土论》，进而倡佛僧、佛化、佛国的“三佛主义”。１９２７年任厦门南普陀寺住持，兼闽南佛学院院长。１９２８年创中国佛学会，并游化欧美七国，在巴黎大学讲《中国禅宗》，与德国学者论禅宗与神通。１９３１年在北平柏林寺教理院倡“八宗平等”之说。“九一八事变”后，起而号召“革日本军阀政客之命”。次年住持奉化雪窦寺，并于重庆创世界佛学苑汉茂教理院。１９３５年作《佛法一味论之十宗片面观》融通显密。后从班禅受金刚阿阇黎灌顶。１９３９年１１月１４日起，访问欧州、北美诸国，前后达五个月。１９４２年，组织中国宗教徒联贯谊会，次年，在流藏教理院讲《中国佛学》，强调“中国佛学之特质在禅”，１９４６年倡僧人“问政不干治”之说，任中国佛教整理委员会主任等职，受宗教领袖胜利勋章，１９４７年３月１７日寂于上海玉佛寺，世寿五十九，僧腊四十三，有《太虚大师全书》行世。
    太虚之佛学，有三大特点。
    （一）倡诸宗平等论，融汇台贤禅净
    太虚虽承临济法脉，但长于融贯统摄，不拘于某一宗。１９１５年，他作《整理僧伽制度论》，上承明代蕅益大师之说，别分大乘八宗，各有特胜而无不究竟，平等普应。次年作《首楞严经摄论》本《楞严经》以统摄大乘，以此为中国佛学之纲要。１９３１年大师在北平柏林教理院讲《大乘宗地图》，亦倡八宗平等各有殊胜之说，指出：
    今后之佛学，应趋于世界性，作最普遍之研究修证与发扬，……今后研究佛学，非复一宗一派之研究，当于经论中还取若干要中之要，作深切之研究，而后博通且融会一切经律论，成圆满精密之胜解。
    后来，他更明确地说：“法本一味，而方便门则无量无边。……所以本人…在教理解释上、教法弘扬上，随宜施设，不专承一宗以自拘碍。”他虽法号承临济，名义上在沩仰宗祖庭大沩山密印寺任住持十五年，便更从把握中国佛教各宗派根本精神，克服以往佛学研究之弊端，面向佛教的未来而立论。
    （二）以禅宗为中华佛法之特质
    太虚虽主八宗平等、各有特胜，但从总体而言，尤重禅密。早在１９２６年夏，太虚作《评宝明君中国佛教之现势》一文，即说：
    晚唐来禅讲律净——中华佛法，实以禅宗为骨子。禅衰而趋乎净，虽若有江河日下之慨，但中华之佛教，如能复兴也，必不在乎真言密咒或法相惟识，而仍在乎禅。
    后来，在１９２６年《中国佛学》中对此作进一步的论述，他在该书第二章“中国佛学之特质”标题下，分列五节：“（一）依教修心禅；（二）悟心成佛禅；（三）超佛祖师禅；（四）越祖分灯禅；（五）宋元明清禅。”第三章则列“禅观行演为台贤教”，第四章则列“禅台贤流归净土行，”最后列“中国佛学之重建”。可见他既重视禅宗之特胜，又着眼于中国佛教的重建与振兴，大力融会禅教。
    大虚不仅融会禅教，亦融通显密。１９３４年他在《佛法一味论之十宗片面观》一文中，除了重视禅宗外，也对于密宗之特胜加以赞叹。他说：然真空门妙极于禅宗，而假相门妙极于密宗。故行证之妙门，独以此二为崇。盖天台、华严、着重于玄妙的描写，致行证反成无力也。
虽然太虚赞即心是佛之禅宗与即身成佛之密宗为重工业行证之佛法中最殊胜的法门，并亲受班禅之金刚阿阇黎大灌顶法，但其重点仍在禅宗，他主张将“瑜珈之法”加入现时狭义的科学方法，即广义的科学方法，“盖瑜伽方法不先立何标的（禅宗），但先澄静其意觉而进为分析之观察，由是得到直接之感验，而构为善巧之说明，俾众同喻。他称赞禅宗有三方面的殊胜，正如印顺法师在论述太虚撰《唐代禅宗与社会思潮》一文时所说的：太虚“极力发扬禅者之风格，诱导僧众以趋向；务人工以安色身，则贵简朴；修佛学以严法身，则贵真至。”并说：大师以“反信教的学术精神”、“反玄学的实证精神”、“反因袭的创化精神”等说明禅宗学术思潮，以“虚无主义的精神”、“布尔什维克主义的精神”，“德谟克拉西主义的精神”，说明禅林与社会思潮。于唐代禅者之风格，颇多深入独到之见。
这里的“学术精神、”“实证精神”、“创化精神”，即说明禅宗不仅是入门信仰之需要，而且是“科学之哲学”、“科学之宗教”，具有注重内心体验、证悟的“实证精神”和生动活泼、富于禅意的“创化精神”，所以禅宗体现了中国佛教的根本特色。
    （三）倡“完成人格”之“人生佛教”
    太虚高瞻远瞩，从熔冶基督教（耶）、伊斯兰教（回）、佛教于一炉，建设全人类瑰玮烂灿的新文化出发，力倡“人生佛教”。１９２３年太虚在武昌佛学院讲学，即主张：
    学佛之道，即完成人格之道，第一须尽职业，以报他人资吾身命之恩；第二乃勤志业，以净自心进吾佛性之德。必如果，佛乃人人可学；必如是，人乃真真学佛！这是继承、发扬六祖慧能“佛法在世间，不离世间觉”精神的体现，在科学日益发达、物质日益丰裕而个人欲望日益炽盛的新时代，尤需这种体现佛教本怀的“人生佛教”，太虚说：
    以今日徵服天然，发达自我之科学的人世，已打破向神求人天福德，及向未有以前求外道解脱之印度群众心理；正须施行从佛本怀所流出之佛的人乘，以谋征服天然后欲望炽盛，及发达自我后情志冲突之救济，且可施行此佛乘，俾现时科学的人世，基之以进达人生究竟，以称佛教本怀，以显示佛教之真正面目！
    “人生佛教”以求人类生存发达、以大悲大智普为群众，以圆渐之大乘法为中心。弘传“人生佛教”以重整禅门宗风为根本，同时有赖于世学之融通和国际大环境之改善，所以印顺说：太虚１９２４年《大乘与人间两般文化》系“针对当时物质文明、精神文明之争而作。大意谓：两般文化，为东方西方所共有，特有所偏重，再则此两者各有利弊，应以大乘导化之使完善，此为大师融通世学之根本方式。”并说：“大师自谓，其时发生两种新觉悟”：
    一曰、中华佛化之特质在乎禅宗。欲构成持持佛法之新僧宝，当于律义教理之基础上，重整禅门宗风为根本。二曰、中国人心之转移系乎欧化：于正信佛法之新社会，当将佛法传播于国际文化，先从变易西洋学者之思想入手。
太虚反复主张从思想、制度、经济三方面革新佛教，以及赴东南亚欧美弘法，都是出于上述指导思想。虽然由于近代中国灾难深重，频经内乱、外患，当时之王张难以实现，但其悲心宏愿、高度的智慧及经验教训，为后人留下了宝贵的精神财富。
    太虚在１９４０年就访问东南亚佛教诸国发表观感，名为《复兴中国佛教应实践今菩萨行》，至今读来，倍感亲切。太虚说：
    革新中国佛教，要洗除教徒好尚空谈的习惯，使理论浸入实验的民众化。以现社会的情形和需要来说，今后我国的佛教徒，要从大乘佛教的理论上，向国家民族、世界人类，实际地去体验修学。这大乘理论的行动，即所谓新菩萨行，……也可名为今菩萨行。……我们想复兴中国的佛教，树立现人的中国佛教，就得实现整与僧寺、服务人群的今菩萨行。
    太虚大师慨今佛门付法，徒存形式，故不以法系为重。其剃徒有大安、传心、传佛、传众、传慧、传忠、传信、传震等，法孙有法宗、法旭、法光、法净、法如、法普、法轮、法雨、法喜、法常等。法普（密悟）法宗（恒演）二人均留学拉萨，得格西学位，其造就培养人材甚多，如法肪、法尊、芝峰、印顺、大醒、大勇（传众）等皆足为师门之光。


三、虚云身承五宗

三、虚云身承五宗

    虚云和尚（１８４０－１９５９），名古岩，又名演彻、性彻、法号德清。五十岁后自号虚云，改字幻游。湖南湘乡县肖氏子。父玉堂，曾为福建泉州府幕僚。生母颜氏，庶母王氏。颜氏平日虔诚奉佛。清道光二十年（１８４０），虚云和尚出生于其父在泉州府舍。自幼大厌荤喜心，忌用五辛，性喜恬淡，少年时于祖母的葬礼中见三宝法物生欢喜心，继而烦弃举子业，嗜读佛典。十五岁时随叔父到南岳进香，遍游诸刹，渐萌出家之愿。次年，择机离家，欲往南岳出家，半途被截回。后被父强徒居闽地，并配娶田、谭二氏、禁锢于一室而无染。咸丰八年（１８５８），赋《皮袋歌》，留别田、译二氏，与从弟潜至福州鼓山涌泉寺，礼常开法师披剃，翌年，于妙莲和尚座下受具足戒。此后，习苦行，住岩穴三载，方回涌泉寺，继奉师命外出参学，遍历大江南北，习禅研教，亲近善知识。曾自普陀起香三步一跪拜，朝五台；只身入藏地，远至缅甸、锡蘭（今斯里蘭卡）等地。归国后，清光绪二十一年（１８９５）在扬州高旻寺禅七中悟透禅关，疑根顿断，得偈云：“杯子扑落地，响音明沥沥。虚空粉碎也，狂心当不息。”又颂偈曰：“烫着手，打碎杯，家破人亡语难开，春到花香处处秀，山河大地是如来。”
    此后，虚老数十年如一日，恒守戒律，深入禅境，精进不解，同时，于极端艰难困苦之中，光大宗门，先后振兴云南鸡足山祝圣寺、昆明云栖寺、福建鼓山涌泉寺、广东韶关南华寺、乳源云门大觉禅寺等祖师道场，新中国成立后，１９５２年冬参与发起组织中国佛教协会。次年，当选为中国佛教名誉会长，１９５３年９月，迁锡于江西永修县云居山真如禅寺。以百岁高龄亲率众僧挖土抛砖，垦荒耕地。数年后，使这座因遭日寇战火毁坏殆尽的千年祖师道场雄姿再现。１９５９年农历９月１３日，虚老示寂于真如禅寺内云居茅蓬。荼毘后，获舍利数百粒，分别供奉云居山、香港等处塔中。
    虚老一生，志大气刚，悲深行苦，解行并进，严净毗尼，行头陀行。清光绪二十三年（１８９７），于宁波阿育王寺礼舍利，燃指供佛，超度慈亲。五年后，隐居终南山潜修，一日入定，半月方出。清光绪三十三年（１９０７），讲经于暹罗（今泰国）曼谷。一次趺坐入定，七日方出，轰动朝野。与此同时，虚老一生殚心竭力，光大宗门，续佛慧合，历坐十五座道场，中兴云居山真如寺等六大祖庭名刹，重建大小寺院庵堂八十余处，建树卓著，获誉甚高。清光绪三十二年（１９０６），曾获光绪帝所赐紫衣、钵盂、玉印、锡杖、如意、全副銮驾及“佛慈弘法大师”之号。民国三十二年（１９４３），受礼请为中国佛学会名举理事。到１９５３年中国佛教协会成立时，当选为名誉会长。
    在百余年的弘法生涯中，虚云和尚恒志禅法，见地深入，为禅门的光大作出贡献。为弘扬佛法，续佛慧命，在振兴鼓山、云居山等道场过程中，尽管条件艰难、虚云老和尚多次启坛传戒。同时，视因缘之殊异，分别创办戒律学院、佛学院、佛学研究苑等以培育僧材。而且，早在清光绪年间（！８７５－１９０８），虚老就在鼓山受妙莲和尚所传临济衣钵，为第四十三世传人；承耀成和尚所嗣曹洞宗法脉，列为第四十七世。此后，相继应湖南宝生和尚之请，续沩仰宗法系，远承兴阳词铎禅师之法脉，为沩仰宗第八世。中兴云门寺时，遥承传已庵深静禅师之法脉，为云门宗第十二世。又应福建八宝山青持法师之请，衍继法眼源流，踵良庆法师之后为法眼宗第八世，虚老和尚一身而参承五宗法脉，继则传嗣后代。
    仅据现有不完整的资料，虚老所传曹洞宗法嗣有宽贤复彻等人，再传法重孙有惟因今果等数十人，所传法眼宗法嗣有本智、本观等，再传法孙有灵意寂照等人，所传临济宗法嗣有海灯本明、观本明一等人，再传法孙有一诚常妙、瑞觉常亮等数十人。所传云门宗法嗣有妙道朗耀、妙定宽度、妙宗净慧、妙慈法云等人。所传沩仰宗法嗣有宣法自寿、宣化度轮、宣成达定、宣扬性福、宣玄圣一、宣云满觉、宣传月川、宣明心明等人，再传法孙有衍心一诚、衍妙戒全、衍悟悟圣等数十人。现在虚老所嗣诸宗法脉代相传承，已有三、四世之多。以上所述，仅为虚老所传法嗣的一小部分（因资料不全，其余待后补充）。据岑学吕居士整理编辑的《虚云和尚年谱》等资料不完全统计，虚老座下剃度、得法、受戒、受皈依弟子有数百万之众，至今分居于中华大地，远及东南亚、北美、东欧诸国，不少人成为当地乃至在全世界都有一定影响的禅门领袖人物。
    与此同时，虚老和尚一生尊师敬祖，地于历代佛教祖师尤其是禅宗宗派源流资料的整理、保存用心良苦。民国时期驻锡鼓山涌泉寺时，虚老就曾亲率弟子整理重刊《佛祖道影》，以清光绪苏州玛瑙经房刊本为蓝本。考正讹误，补缺拾遣，使之载列祖像赞达三百一十尊，为人们留下一份珍贵的历史资料。驻锡鼓山期间，虚老还曾多次搜集资料，整理、考订《法系考正》、《星灯集》等禅宗宗派源流史籍。为光大宗门，虚老分别为各宗继续演法派字号，为临济宗续演六十四字：
    慈悲喜舍　　大雄世尊　惠泽含识　誓愿弘深
苍生蒙润　　咸获超升　斯恩难报　克绍考勤　　导识义谛　　妙转嘉音　信解行慎　彻无边中　　回向诸有　完最上乘　　昭示来哲　冀永长崇
同时，虚老为临济宗外演号派八十字：
    古佛灵知见　星灯总一同　冥阳孰殊异　万化体皆容　镜鉴群情畅　碧潭皎月浓　随缘认得渠　　纵横任西东　显密三藏教　禅律阴（一个陟字头，一个鸟字）　修契幻华梦　应物悉玲珑　怍悛奋悠志　宝石珠自莹瑛　严奉善逝敕　杲日满天红
民国二十四年（１９３５），虚老在鼓山主持《增订鼓山列祖联芳集》的编辑刊印，于其中附载《禅宗五宗源流》，为沩仰宗法派号继演五十六字：
    词德宣衍道大兴　戒鼎馨遍五分新　慧焰弥布周沙界　香云普荫烂古今　慈悲济世愿无尽　光照日月朗太清　振启拈花宏沩上　圆相心灯永昌明
为法眼宗继演五十六字：
    良虚本寂体无量　法界通融广含藏　遍印森罗圆自在　塞空情器总真常　惟斯胜德昭日月　慧灯普照洞阴阳　传宗师眼大相义　　光辉地久固天长
虚老为诸宗继演的法派号，今天仍为禅宗丛林所奉行。
    在百余年的弘法生涯中，虚老和尚于潜心禅修之中。对佛法理论尤其是禅宗修持多有创发，先后完成《楞琚经玄要》、《法华经略疏》、《遗教经注释》、《图觉经玄义》、《心经解》等近十种著述。一生为四众弟子讲经说法开示次数难于统计。仅据香港岑学吕居士于五十年代所整理、编辑的《虚云和尚法汇》，六十年代与八十年代净慧法师整理编辑的《虚云和尚法汇续编》，《虚云和尚开示录》等，就有数百万字之多。综观这些论述以及虚老和尚近百年的修持实践，可以看到他对中国佛教特别是禅宗宗门的弘传所做出的巨大贡献，以及从中所体现的禅学思想特色。
    （一）佛教是使今日国际社会趋进大同的教派
    作为“当代禅宗泰斗”的虚老和尚，虔诚向佛，百余年如一日，对佛教的本质及社会功用有着极力深刻的认识。虚老认为宗教的实质，是引导人心趋于至善，因此可以产生移风易俗、辅政安民的效果。虚老曾指出：“世界无论何教，总是导入为善，为治心之法，如佛则济度众生，使众生脱苦。儒则重伦常，使人各尽本份，本无异致。所不同者，儒则著重世间法，佛则于世间法外，更有出世间法，深浅不同耳。”虚老赞同孙中山先生所强调的，“佛教乃救世之仁，佛学是哲学之母。宗教是造成民族和维持民族一种最雄大之自然力。人民不可无宗教之思想。研究佛学，可补科学之遍”的观点。虚老进而以详确事迹来佐证孙中山先生的观点，指出“佛教对于宇宙本体之研究”有其特色之处，仅其“对于世界之构造与成坏、人身器官之组织及其他种种问题，在《楞严经》及诸经论，多有详细论列与说明。”而且这些论列与说明，“大多与哲学科学发见者相合。”虚老认为：“佛学虽说惟心，然而哲学上之惟心论悬殊。”在虚老看来，“哲学上之惟心论，于心执有，于物执无。”而佛学的惟心，则是“释迦所谓以攀缘心为自性，执生死妄想，认为真实者。”也就是说，哲学上的惟心论否定认识过程中客观存在的第一性；佛教的“惟心”论，则反对向外驰求，主张自净其意，返闻自怀，净化人心，因此二者是有本质区别的。
    针对社会上有些人将佛教视为消极的、迷信的错误观点，虚老予以驳斥。指出这是“未明佛教者之言。”他认为从实际看“佛法不坏世间相。”怎么是消极？而且佛法“步步引人背迷合觉。”更进一步说，佛法要求广大弟子“一面自修，一面化他。”因此“其积极与正信，”在诸多宗教中“恐无有出其上”。所以，片面地将佛教指斥为消极的、迷信的是没有道理的。虚老认为，正如孙中山先生所指出的。佛教在中国的传播“有裨益于中国之学术思想”，“佛教为今日之周旋国际，趋进大同之惟一大教。”
    （二）以戒为修学之根本
    虚老在其一生中，戒行精严，定慧圆相，他中兴祖庭，屡次整肃僧纪，都是从严守戒律入手的。在鼓山创办佛学院，于南华创办戒律学院，设佛学研究苑于云居山，以培育僧材，庄严戒德。虚老一生于讲经说法之中，反复强调戒律是佛法的根本。“戒为德本，能生慧行，成就万行”。因此，“修学者，必须依佛戒，戒为无上菩提本。”“学佛不认修何等法门，总以持戒为本。”对于修行者说来，“持戒律如行路有资粮。”这是因为“因戒纔可以生定，因定纔可以发慧。”若不持戒而修行，则“无有则处，”而且“纵有多智，皆为魔事。”虚老是这样说的，也是这样严格要求自己及学人们徒的。他主持的寺院，坚持半月诵戒制度，即使是到了生命的最后时刻。虚老仍嘱咐身边侍者，要使佛教保持兴旺，保守这一领大衣，“只有一个字，曰‘戒’”。
    虚老和尚不仅严持戒律，而且十分重视如法传戒。早在三十年代，针对当时有的寺院戒律松驰，传戒不如法，甚至买卖戒师，将淫祠社宇、血食宰割之区乱为坛地，虚老斥之为“窃名纲利”，“翻为地狱深坑。”五十年代，虚老又多次告诫学人门徒，“佛法之败，败于传戒不如法。”强调“若传戒如法，僧尼又能严守严律”，则佛法将更加兴旺，在虚老的一生中，为四众弟子设坛传戒见诸文字的就有数十次，不管环境如何，都如法如律，严格要求，即便晚年在云居山遇到障碍因缘，而开自誓受戒方便法门，虚老仍是严格要求，真正做到一丝不苟，当时，虚老语重心长地告诫诸戒子，“毗尼威仪，规矩法则，切须自行学习。”若行戒牒，而“不能如戒持行，则盗佛形仪，妄称释子。”然而，从百余年弘法生涯来看，虚老和尚恒持戒律，严守毗尼，却不墨守成规，虚老认为佛法戒律是从印度等国传来的，但中国与印度的国情有相同之处，也有相异之点，所以我们持戒要明开遮。要懂得因时制宜，种种妙用。“当日在印度社会，以乞食乞衣，一心修道为出家人本分事。若自己营谋衣食，便招世议嫌，佛因之制此等戒。而在中国与印度环境不同，早在唐代百丈禅师“已有一日不作，一日不食之美举。佛如降生此时此地，决不会制掘地纺织等戒的。”所以虚老认为“我们耕田纺织，并不犯戒的事情。”虚老并且进一步希望佛门弟子“在修持中，切不可废劳动；劳动中，也不可忘修持”，要做到“两者兼行并进。”正是这样，在新中国成立后虚老和尚一再教育弟子们要根据国家社会环境的变化。出家人不能再像过去那样坐受供养，而是应当弘扬百丈家风，“农禅并重”，自力更生，自食其力。
    （三）提倡“楞严”思想
    《楞严经》是唐以后中国佛教各宗依之立说的一部重要经典。虚老对此经造诣很深。早在清光绪二十年（１８９７）就曾应道明和尚之请在焦山助讲《楞严经》，此后多次登坛宣讲此经，也曾为此经作汪写疏，而且在平常讲开示和答问中都以“楞严”思想为核心，勉励学佛者深入《楞严经》，“从闻思修，入三摩地。”民国三十二年（１９４３）在重庆讲开示时，虚老强调《楞严经》“几无法不备，无机不摄，究佛学哲学者均不可不参究。”解放后，虚老在云居山又多次要求学人弟子“最好能专读一部《楞严经》，”认为“此经由凡夫直到成佛，由无情到有情，山河大地，四圣六凡，修证迷悟，理事因果戒律，都详详细细的说尽了。”因此，虚老一再强调“熟读《楞严经》很有利益。”后来，虚老又多次强调现在正是末法时代，要寻访善知识很是困难。因此，“不如熟读一部《楞严经》，修行就的把握，就能保绥哀救，消息邪缘。令其身心，入佛知见，从此成就，不遭歧路，”虚老主张读《楞严经》，只要熟读正文，不必看注解，读到能背，便能以前文解后文，以后文解前文，这样纔能得到利益。
    虚老一贯坚持要求学人弟子深入《楞严经》，直至晚年仍无改变，就在生命的最后几年中，多次告诫他们“希望同参们，无论老小，常读《楞严》。此经是你们随身善知识，就和阿难同参。”
    （四）别具特色的禅学思想
    虚老在其一生中，百余年如一日，潜心于禅，行亦禅坐亦禅，自行化世，至老不移。虚老恒以《楞严经》为圭旨，在自己禅修的实践基础上，对参禅的目的、方法、禅病对治等方面形成了独具特色的理论观点。
    虚老认为，参禅目的在于明心见性，也就是要去掉自己的污染，显现自性的光明，彻见自己的本来面目。同时参禅是修学佛法的一种法门，也是办道的一种方法。诚如古德所教诲的，“佛法大海，信为能入”，“信为道源功德母。”虚老强调“无论什么人，尤其是用功办道的人，先要深信因果。”如果不信因果，就会“妄作胡为”，这样不要说办道不成功，“三涂少他不了。”有鉴于此，虚老教诲学人弟子，参禅办道就应该发长远心、坚固心、勇猛心、惭愧心。只有这样方能恒久如一，做到“万缘放下，一念不生。”也只有这样，纔能断除妄想，坚定信心，“不随妄想习气境界转，‘假使热铁轮于我头上旋，终不以此苦，退失菩提心。’”这样纔能悟道了生死。他认为，只有“放下一切，专心向道，这纔算是本色禅和。”与此同时，他反复教诫弟子“总要生死心切，是有长远坚固向道之心。”进而于修行要一门深入，以其为正行，诸门相助，恒常如一，专心致志，就有成功的一日。千万不能今日三明日四，朝秦暮楚，听人说学教好，又弃了参禅去学教；学教不成，又去持咒，这样下去是头头不了，赈赈不清，更不能采用功利近视“病来知念生死，病好道念就退了。”若是这样，那是无法悟道的。
    对于参禅，虚老和尚认为只要信心坚固，万缘放下，一门深入，则处处皆可修行，处处都是道场。“善用心者，心田不长无明草，处处常开智慧花。”因此，不以为一定要到禅堂打坐纔是参禅，“平常日用，皆在道中行，那里不是道场。在他看来禅常的设置，以及所谓参禅，“不过为我等末世障深慧浅的众生而设。”真正的禅者“行也禅，坐也禅，语默动静体安然。”“运水搬柴，锄田种地，乃至穿衣食饭，都是修行佛法。”晚年在云居山重振祖师道叫响，在蒲团坐下来，止了静就叫修行，”而“打坡板出坡，掘地种田，搬砖挑土，屙屎放尿，认为打闻岔，就忘记修行了。”虚老认为这样是无法悟道的。只有恒发长远心，脚踏实地，以戒定慧三学，除贪嗔痴三毒，收拾六根如牛一样，“不许它犯人苗稼”，这样久久用功夫自然纯熟，则任他天堂地狱，随缘不变，不变随缘，无挂无碍，灵明妙用，随处自在，识自本心，清清白白，明见无疑，就能见道，也可以在“忙碌中，是非中，动静中，十字街头，……都好参禅。”
    虚老和尚未披剃出家后即开始习禅。至一百二十岁圆寂，在一生的百余年里习禅不止，于参禅方法承历代祖师教诲，加上自己的体悟，因而有着深切而独特的创发。虚老和尚曾反复教诲门人参禅时，“把六根门头收摄起来，万念放下，”以此为先决条件。“单单的照顾话头。”照顾话头，也叫看话头，对话头，虚老释之为：话，就是说话；头，就是说话之前，“即是念头”，“念之前头就是心。直言之，一念未生以前就是话头。”究其实质，“看话头就是观心”。“父母未生以前的本来面目就是心，看父母未生以前的本来面目就是观心。”虚老和尚教导门人说，古代祖师传有许多话头，现在通常用的是“念佛是谁”这句话，所以，我们看话头就是要参这“谁”字，对“谁”这一问有疑，也即发疑情。疑情是看话头的拐杖，参禅要在这有疑难的地方去追究去，看这话到底由哪里而来，是什么样子，微微细细地去反照，去审察。简而言之，就是“以我们一向向外驰求的心回转来反照，”以达到反闻自性，以期开悟，他要求弟子门人，参禅要“生死心切，咬定一句话头。不分行住坐卧，一天到晚把‘谁’字照顾得如澄潭秋月一样，明明谛谛的，不落昏沉，不落掉举，”则开悟有期。对话头的咬紧，要紧到刹那不要放松，如老鼠啃棺材相似，咬定一处，不通不止。之所以要这样咬紧，其目的“在以一念抵制万念”，这是实在不得已的以毒攻毒的办法。
    至于具体参禅的方法，虚老和尚认为这也是十分重要的。首先，参禅要善于调和身心，务须心平气和，无挂无碍，无我无人，行住坐卧，妙合玄机。只有这样参禅方可入手，否则枉费时日，严重的还会导致“著魔发狂，吐血罹病，无明大火，人我见深。”他强调坐禅切不可用功太急。如感到心中烦躁，那就要放下休息一会儿，待自我感觉舒服后再起用功。他告诫四众弟子如果长期用功过急，则会造成性情急燥，易怒，严重的还会发狂着魔。另一方面，他一再提醒学人注意参禅姿势，以调身心。平日跏趺坐尤其是在禅堂坐香时，禅人“宜顺着自然正坐，不可将腰作意挺起，”“胸部不要太挺，气不要上提，也不要向下压”，而应“随其自然。”行香时，“颈靠衣领，脚步紧紧跟前面的人走，心里平平静静，”同时“不要东顾西盼”，而要“一心照顾话头”。这样，参禅纔能得到受用。否则，“虽说修行一世，终是劳而无功。”
    对于参禅初用如何下手，虚云和尚主张“楞严会上陈那尊者说‘客尘’二字，正是我们初心用功下手处。”他说客尘喻妄想，主空喻自性。因此，参禅初用功的人要先认清了“主”和“客”，纔能“自不为妄想迁流，”进一步明了“空”和“尘”，则妄想就不能成阻碍了。虚老和尚强调参禅用功知道了下手处，就要精进猛往，切不可松懈，要时时“痛念生死，如救头燃。”针对近代参禅的人不少，但悟道的人却没有几个的情况，虚老分析其原因是由于“现代的人根器的人及古人。”同时，“亦由学者对参禅看话头的理路，多是没有摸清的。”他曾多次痛心地指出有不少人一生总是执言句名相，在话尾上用心，误入生灭法，以致即使苦参终生，到头来总是空过一世，他一再告诫弟子要认真参学，“自古禅德，无不参学而入。”参学，即戒定慧。“因戒生定，因定发慧，定慧相资，其道乃成。”他要求学要弟子在参学时，要有三样好：第一要有一对好眼睛；第二要有一双好耳朵；第三要有一副好肚皮。虚老认为好眼睛就是金刚正见，凡一切事物能分是非，辩邪正，识好歹，别圣凡。好耳朵就是顺风耳，什么话一顺到都知道其中有否名堂。好肚皮就是要和弥勒菩萨的布袋一样，一切好好醜醜，所见所闻的全都装进袋里，遇缘应机，化生办事就把袋里所装拿出来加以比较分析，择其善者而从之，其不善者而改之。这样参学习禅，总能在成就。
    虚老和尚对参禅过程中种种毛病了如指掌，对后学弟子也一再告诫，多方提醒。在上海玉佛寺禅七开示中，他曾强调参禅时最要不得的禅病就是空亡无记，具体说来就是在坐着的静中把话头亡失了，空空洞洞的，糊糊涂涂的，什么也没有。之所以会坠入这种禅病状态，是因为“只贪清静界。”只要我们二六时中，“把一句话头，灵明不昧，了了常知的，行也如是，坐也如是。”那就可以对治此病了，不仅如此，他多次对学人参禅常易出现的四种禅病一一剖析，认为其一，是路头搞不清，话头看不上，弄得糊糊涂涂，随众打盹，以致妄想纷飞，或是昏昏沉摇。第二，则是话头看上了，也有了些把握，但把功用在话尾上，把看话头当成敲门瓦子，成了念话头，坠入生灭法的陷坑。第三，是有的会看话头，能照顾现前一念无生，或者知道念佛是心，并且逐渐过了寂静，粗妄既息，得到轻安，进一步有种种境界出现，而参禅者把握不当，产生贪恋甚至执著，以致着魔生病。第四、则业障较轻，理路明白，用功恰当，走上了正轨，但却于此停滞不前，或是昏沉停住，或是所得点滴慧解，醉心于作诗为文，起贡高我慢之心，对于这四种禅病，虚老和尚针锋相对地给学人授以对治之方。对第一种，虚老和尚教诚学人坚持恒看“念佛是谁”的“谁”字，看到妄想昏沉少，“谁”字不能忘了时，就看这一念起处，待一念不起时即是无生，也就是真正的看话头。对第二种，认为也只有照前述方法去对治。对第三种，他教诫学人不管遇到何种境界，千万不能执著与贪恋，只要一心照顾话头，一念不生，“佛来佛斩，魔来魔斩”，就可以继往前进。对第四种，他主张遵古德“万法归一，一归何处”的教导，“由一向至极处迈进，直至高山顶立，深海底行，再撒手纵横去。”对于参禅之中，因方法不当，以致色身着病吐红，虚老和尚认为这是“自不具眼耳，失于善调”之故。因此要如古德所说“入息不居阴界，出息不涉众缘”，而千万“不可寻语言随人舌根转，弄尽精魂，”也不要“坐上蒲团，瞌睡昏沉。放下腿来，闲谈杂话。遇着境界，毫无主宰。”至于有损色身，染疾吐红，虚老和尚认为，当时惯用的以生漆治之的方法欠当，因为“生漆不可多用，用多损多益少。”
    对于参禅，虚老和尚特别强调一定要以明心见性、了脱生死为目的，千万不能去追求神通。他认为“神通属用功之过程，岂可立心希求。”一旦用心追求神通，则与“无住真理”背道而驰，所以对这一类人“佛谓之可怜悯者”。他进一步批评说，若“专为求神通而修行，是魔见”。因为“神通一层，不但天魔外道有之，即在鬼畜俱有五通。”从根本上说，这是“性中本具”的，所以我们对其“不必注意”。
    在百余年中的参学习禅过程中，虚老和尚既注重于禅修理论与实践的探讨，又长期坚持率僧众弘扬百丈祖师所倡导的“农禅并重”家风。在主持福建鼓山涌泉寺、广东韶关南华寺、乳源云门寺及江西云居山真如禅寺等祖庭名刹时，亲率僧众参禅修性，严守禅堂规矩，坐长香，其余人每日有四至八支的养息香，每年于因缘具合时举行禅七，与此同时，率僧众出坡劳作，实践“一日不作，一日不食”之祖训，在恢复云门祖庭时，虚老和尚从对当时社会环境的观察分析出发，教导僧众“今后佛教要不被淘汰，僧伽经济必须在‘劳动生产’之条件下，自给自足，以谋解决，始克有济。”当时，他主持在云门开办“大觉农场”，制订《农场组织简章》，要求常住僧众除担任总管、副管理以及六十岁以上身体衰弱确实不能任劳者外，一律都要参加农事劳作。后来，看到因避日寇铁蹄而流落至广东韶关市四众弟子甚多，为谋生计，虚老和尚又因地制宜地主持在市内大鉴寺开办纺织厂，带领大家从事劳作。以自食其力度时过日。新中国成立后，他一再教导弟子时代变了，要“在现在基础上自力更生，以维佛门根本”。晚年驻锡云居山真如禅寺时，更以百十余岁的高龄，亲率僧众从事农禅，组建“僧伽农林场”，打地抛砖，重建梵刹，烟蓑雨笠，躬耕南亩，经数年艰辛，终于使这座千年祖师道场雄姿再现，青畴录亩，绕禅舍于烟霞；宝殿金身，树法幢于云端。
    （五）主张禅净不二
    虚老和尚是当代禅宗泰斗，以一身而承嗣五家宗派，深入禅境，久有体悟，但对其他宗派法门不分彼此，同样尊重，尤其是对净士宗，虚老和尚更是主张禅净不二，“参禅念佛等法门，本来都是释迦老子亲口所说。道本无二，不过以众生夙因和根器各各不同，为应病与药计，便方便说了许多法门来摄化群机。”他认为中国佛教到后来诸宗派的出现，乃是诸位祖师“不过按当世所趋来对机说法而已，”尽管各宗派修持方式或有不同。但“那一门都是入道妙门，”而且法法本来可以互通，圆融无碍的。虚老和尚指出从修行实践看，念佛念到一心不乱，何尝不是参禅；参禅参到能所双忘，何尝不是念实相伸缩。他一再强调禅乃净中之禅，净乃禅中之净。禅与净，可以相辅而行，并非水火不相容，对那些怀有门户之见，将禅净妄分高下的人感到深恶痛绝，并一针见血地指出，这“是佛门最堪悲叹的现象”。他严肃指出这些人实际上“违背了佛祖分宗别的深意，且无意中犯了毁谤佛法，危害佛门的重罪”，“是一件极可哀愍的事。”
    虚老和尚虽是坚守禅门，造诣精深，对于念佛法门不但毫无偏见，而且倍加赞扬，经常劝人老实念佛。１９５２年冬，他曾多次教导四众弟子“佛说种种法门皆能成佛。专持名号者，即得持名号而成佛。”虚老和尚认为，“参禅、念佛、持咒等一切法门，皆教众生破除妄念，显自本心。佛法无高下，根机有利钝。其中以念佛法门比较最为方便稳妥。”他反复强调学佛的人，对于禅净法门的选择，最好根据自己的具体情况来决定，“汝自审果能处烦恼而不乱，住禅定而不寂，则可以参禅。若未能做到，则当一心念佛。”不仅如此，他一贯主张学佛的人可以禅净双修，效果更佳。“于动散之时，则持名念佛。静坐之际，则一心参究‘念佛是谁’。如斯二者，岂不两全其美。”他对于念佛方法及其进行，也有很铠切的开导，曾经指出“念佛的人，从头到尾，要绵绵密密，一字一字、一句一句不乱的念去。”仅此还不够，虚老和尚强调念佛要坚固信念，贵在一心，不要受外境干扰，“佛来也是这样念，魔来也是这样念。念到风吹不入，雨打不湿，这样决有成功的日子，”他对于净土法门的弘扬不遗余力，在《虚云和尚法汇》中就有不少是劝导弟子勤修净土法门的开示语录，在数十年的说法生涯中，他对来参叩者，往往先是试以禅，若不契则示以念佛三昧，当年在广东昭关南华寺重建禅堂之后，又别立念佛堂，以方便学人习修净土。由此可见虚老和尚的“禅净不二”观点是得到了广泛的实践的，也是产生了深远的影响的。


四、来果传高旻禅风

四、来果传高旻禅风

    来果禅师（１８８１－１９５３），法名妙树，号净如，湖北黄冈刘氏子。幼时向善崇佛，自忌荤腥，苦行翘勤，二十四岁，投金陵宝华山出家，转至江苏镇江金山寺受具足戒后，留驻禅堂，习坐长香，自誓以悟为期，立行不倒单，不告病假、香假、缝补假、经行假、殿假，单参念佛是谁一法，至清光绪三十四年（１９０９）九月，坐晚香开静木鱼一下，猛然豁悟，如千斤担子顿下，此后，倍加精进。清宣统二年（１９１０），为避强任执事，改住扬州高旻寺，不久，受请为班首。民国三年（１９１４）夏，至终南山，隐居湘子洞潜修。次年九月，应高旻寺月祖老和尚之邀回寺，当月即承方丈明轩和尚传法。此后，云游至常州天宁寺等处。民国八年（１９１９），继明轩和尚之后执掌高旻寺法席，入住之后，决心重振道风，专修禅法，其他一切法门，概不准修，每年七月十三日为僧众讨单之时，入单者即进禅堂，每到十月二十九日开示考功，因而培养造就了不少僧材，同时，高旻寺也以道风正、规矩严而名闻海内外。
    来果禅师参禅数十年如一日，深入得悟。于禅法多有灼见真知，有《自行录》、《语录》、《开示录》等传世，从中反映出别具特色的禅学思想。
    （一）坚信因果，发宽大愿
    来果禅师认为，禅修是佛祖所示一种修行法门，坚信因果是参禅圆满的基础之一，禅人若“不审前因后果，虽努力精修，终难善后者。”来果禅师结合自己参禅的体验，强调参禅人最要放得下。否则，人在禅堂而心在世，继增陋劣，毫无进取。但要真正放下，认清“人被迷轮关注，心被识业关注，识被意惑开住，意被想尘关住，想被身体关住，身被家庭关住，家被山河关住，山河被大地关住，大地被虚空关住，虚空被无明关住，无明被不觉关住，不觉被众生关住”是关键。众生被迷轮关住，而要破迷轮，惟有“放得下”，禅人也如此。他反复告诫参禅人必立高上志，发宽大愿。于参禅之中千万不能发急，“要知发急二字，为催命鬼，为断佛因，”因此不可不慎。
    （二）严立清规，严格要求
    对于参禅学人，来果禅师有一套较为严格的要求。首先，要求参禅人一定要严守清规。来果禅师认为，清规者，公正清严为模范。公能除私曲猥弊，正能除邪谬垢染，清能除精浊秽污，严能除病惯懈习。所以丛林要严立清规。再者，来果禅师要求参禅人恒修戒定慧，灭贪嗔痴。“参禅人，先知世空则身空，身空则心空，心空则及第真空”。这就是来果禅师所主张的“参禅人正行正见”。因此
“身外废物，赶急舍去。”所以，“多一物多一心，少一物少一念，能少到一物不存，一心不生，是真法器。”而嗔怒“为身害命的渊府，是杀人利斧，”不除灭是无法入禅门的。要除灭贪嗔痴，在来果禅师看来参禅人先要知足，“知足者常乐，能忍者自安。”真正参禅人，只知有生死，只知想了生死，除了生死外，身心世界，荣枯得失，饥渴冷暖，非我正行。只有这样总能除染习，真参禅。这就要求参禅人坚定信念，发长远心，不被外境所转。而且能忍苦、耐烦、抱定一句忍中忍，耐中耐，坚守“先用耐地，后用心行，再用法行，到此一拳打破无明，一脚踢翻识臼。”就可以上路而入禅境，最后认识自己本来面目。
    （三）立志孤高，专门力守
    来果禅师经常教导参禅学人贵在一心一行，一心向道，坚持一法，专门力守，不容丝毫散漫，而且行得踏实，脚跟着地，方向正，步子关，这样“能知心行，敢保天下人，尽是诸佛。”与此同时，他要求参禅学人须“正要研究真实究”，即要参深禅，方可截断无始身习。另一方面，又要求参禅学人要守淡薄，“身心万不可浮华，不可骄泰，不可我慢。”这样总能恒心向前，不被外境所转，持名深入，工夫能做到不打失，不走作，不间断。来果禅师还强调“立志孤高，迥绝人世，以道为侣者，总是参禅人行履。”在他看来，古德所言“与人讲一句有益的话，尚与道违；无益之语，岂可得平”的遗训是很有见地的。参禅人若交游攀情之心一动，办道之身随之俱动，随之烦恼僧增，怎能参禅。因此。要真正断情爱，去染习，方可参禅有径。
    （四）真实参究，不求神通
    来果禅师曾反复告诫参禅学人须要真参，切忌专在工夫外逞强好胜，你高我低，你能我不能，这样下去时日虚度，招致烦恼，造下业障。而真参者则当以“人生最大莫过于生，生之最大莫过于死”为警策，惶惶不可终日，专办生死大事，方是正用。他还教导参禅学人力要用对，工夫要下得正，千万不能去追求神通。神通之术，“神鬼遍地尽有，一求可通，但终非已有”，而且易入盲修瞎练之歧途，最后难于自善其终，堕入鬼畜之道。
    （五）非疑不悟，孤疑难入
    对于具体参禅方法，来果禅师有自己独见。“疑”之一法，不少禅师都把它当成入禅之一途。来果禅师于此则有进一步的探讨，认为“疑之一字，众善之门，行人大需仔细。”来果禅师要求：参禅时要有疑，方可咬住“念佛是谁”的话头。也就是说对于生死，参禅法正疑是入门之法，非疑不得力，非疑不用功，非疑不开悟。而正是以疑为动力，小疑小悟，大疑大悟，不疑不悟。然而，对参禅之法却应绝对无碍。否则的话，稍有孤疑，即生轻谤。礼学投师即疑地道，受戒复疑哄人，住丛林更疑吃苦，当参学又疑吃苦，住禅堂也疑空混。这样孤疑一毫厘的人，其结果是堕恶道，“佛种斯断也。”于此对治，来果禅师强调参禅学人要树坚固心，发大宏愿，明因果，能吃苦，信念始终如一，方可去孤疑。
    对于参禅，来果禅师认为求静非真参禅。在他看来，工夫得力静不可得。而真正入禅境，疑情真参，外忘世界，内忘身心，身心两忘，孰有动静之别。他强调只要工夫得力，净戒严持，定力坚固，慧自然生，若是不下死心参禅，即使住在禅堂极静之中，妄想杂念纷起，专在见闻取舍上做生活又有何用，因此他要求参禅学人“把定一句念佛是谁，动如是参，静如是参，生如是参，死如是参，真参不舍，”定可得悟。
    （六）发明心地，坚持不懈
    来果禅师强调参禅人发明心地后，仍须继修，久久坚持，不稍松懈，习惯成熟，抢培法身之福，忙修慧命之慧，理事俱辞，自他两利。而其中自既能利，必设法利人，来果禅师认为“利人之法甚多，最大之利，莫如开丛林，建道场。”对此，既须因缘俱合，更要“必依古法”，先得其地，次得其人，有地与人，则成弘法基础。“一切人守规矩”，则是弘法道场之根本。他认为“规矩一法，乃出世之阶梯，为成佛之捷径，离规矩则坏丛林，坏自己；守规矩则修福慧，修身心。师傅在日用中，切不可随习气转，顺业识举。当知守得一分规矩，除得一分恶习；修得一分福慧，除得一分生死。所以生死不离习气，福慧不离规矩。”来果禅师在主持高旻寺时，自己带头严守规矩，坚持认理不认人，依法不依情。“那怕是我的生身父母和兄弟，一到高旻，就认不得了，父母兄弟犯了规矩，打香板比别人重，遣单比别人快。”也正是这样，来果禅师在高旻寺执掌法席中，依规矩办事，“铁打的常住，要靠铁打的规矩，有了铁打的规矩，总有铁打的常住，”上自堂头和尚，下至清众，在规矩面前一律平等。不时高旻寺规矩之严，是远近闻名的。仅其上早晚殿规矩，将早晚上殿定为恒课，任他山河有变，我行不移。宁可上殿而死，不可躲殿而生。上殿时要求大众一出禅堂，必须眼观鼻，鼻观心，后人看到人衣缝，一步套一步。到大殿走中门进去。进时，西单左脚先进，东单右脚先进。出时，西单右脚先出，东单左脚先出，在殿内不得告上厕所假，不得吐痰地上，不得倚靠壁上柱子。拜佛一阵风声，一起起倒，不得稍有前后。跟班站、排班站，皆要一条线，脚齐砖缝。拜佛要五体投地，问讯则背腰弯平，合掌则天立地。合十时，十指靠紧。手心靠手心。唱念众口齐声，梵音嘹亮，不得藉殿养神，偷安怕苦，由此可见高旻寺规矩严之一斑。来果禅师主持高旻寺的数十年中。率僧众虔心向佛，严守规矩，使之成为海内外闻名十方丛林，为中国禅宗的兴盛培养了一大批僧材，现今任福建厦门南普陀寺方丈妙湛法师等禅门大德，就是由高旻寺培养冶铸而成的。因此，一直到今天高旻寺的禅风与来果禅师为当代中国禅宗延衍所做的贡献，仍为人们称颂不已。


五、正果与禅悟体证

五、正果与禅悟体证

    正果法师（１９１３－１９８７）是中国现代佛教界众望所归、素享清誉的高僧。他一生研习三藏，学入性海，发明本心，启导迷悟，于蜀岭京华，遍设讲筵，宣说法音，绍隆佛种，培育僧才，毕生献身于佛教教育事业，担荷着传道、授业、解惑的重任。赵朴初先生曾评价说：“正果法师是一位道高德重、戒行精严、学识渊博、诲人不倦、爱国爱教的高僧。”
    正果，俗姓张，四川省自贡市人。生于１９１３年７月２４日，青少年时期，长期罹病，深感人生艰难，遂萌出家之念。１９３２年，他十九岁时出家于四川省中江县寿宁寺，礼广渠和尚为师。于此青灯古佛、礼诵黄卷，度过了两年时光。１９３４年冬，四川成都文殊院开坛授戒，二十一岁的正果于此受比丘戒，从此开始了他弘法利生的岁月。正果先去重庆市华严寺天台教理院学习。１９３６年，他考入当时佛教界的最高学府“——位于重庆市北碚缙云山的汉藏教理院本科学习，１９４０年毕业后，升入专修科（研究班）继续深造，师从佛学泰斗太虚大师（１８８９－１９４７）、译经大德法尊法师（１９００－１９８０）等人研究佛学。学习期间，他不尚时毛，不慕名利，潜心于佛门性海，每逢考试，总是名列前茅，因此，深得太虚大师和法尊法师的尝试。１９４２年研究班毕业，由于学德兼优，被留院任教，他对工作认真负责，一丝不苟，教学相长，解行并重，不久便担任汉藏教理院教务主任。
    １９４５年，抗日战争胜利结束，汉藏教理院原有教师大部分离院东下，加之１９４７年３月１７日太虚大师逝世，整个汉藏教理院的教学任务，主要依靠院长法尊和教务主任正果的大力护持，正果后此成为法尊法师在僧伽教育方面的得力助手，当时，局势混乱，物价飞涨，维护一个一百余人的学院，实非易事。重庆解放前夕，有些人主张把汉藏教理院迁往海外，法尊和正果力排众议，坚决留了下来。正果以喜悦的心情迎接新中国的成立，衷心拥护社会义义制度，积极参加各项爱国爱教工作，１９５０年冬天，正果与法尊一道，应邀纛北京，住在北海公园内的菩提学会，为中央人民政府主持藏文的翻译工作，并襄助法尊做了大师的弘法宣教工人。１９５４年正果应赵朴初之邀，到北京三时学会担任研究室主任，指导几位僧人和居士研究法相惟识。１９５６年９月，中国佛学院在北京法源寺成立，正果应聘主讲佛学，后担任教务主任。１９５７年，当选为中国佛教协会理事，１９６２年，任中国佛教协会副秘书长。十年动乱中，他受到不公正待遇，１９６９年至１９７３年，在斡校劳动四年，虽历尽磨难，仍以宽广的胸怀，忍辱负重，处之泰然，持戒不辍。曾有人劝他舍戒还俗，攀谈竟日，他不为所动，说：“戒是无上菩提本，佛弟子严持净戒必须做到”，并表示“有我在，便有佛法在！”１９７３年中国佛教协会恢复工作，正果即回京襄助会务。１９７８年起，他连任中国人民政治协商会议第五届、第六届全国委员会委员、常务委员，１９８０年，当选为中国佛教协会副会长、同年冬，任中国佛学院副院长、北京广济寺住持。１９８１年当选为北京市佛教协会首任会长。
    正果法师长期从事佛教界对外友好交往和海外联谊工作，在海外佛教人士中有广泛的联系和影响。１９６１年曾随中国佛牙护侍团前往斯里兰卡护侍佛牙并进行友好访问。１９６３年、１９６４年、１９７８年先后三次出访日本。１９８２年率领中国佛教协会迎奉佛像代表团访问泰国。
    １９８７年１１月２０日，正果病逝于北京广济寺，世寿七十五岁，僧腊五十四年，辞世前两日，曾向赵朴初会长念了四句偈语：“坚持无上锐提心，专修四宏誓愿行，弘扬佛法令久住，永作菩萨度众生。”此偈正是法师一生弘法利生的写照。赵朴初会长作《正果法师挽诗》曰：
    排众坚留迎解放，当风力破桃花浪。
    辞医不殊易箦贤，我在佛在气何壮。
    辩才无碍万人师，不倦津梁见大慈。
    忍泪听公本愿偈，预知海会再来时。
正果穷毕生之力，孜孜不倦，矢志不移地从事弘法利生、佛学研究和佛教教育事业，在佛教界造就了大批弘法人才，为中国佛教的振衰起弊作出了积极的贡献。他学识渊博，尤精惟识之学，曾费几年心力著成《辨了不了义论讲义》，洋洋数十万言，可惜在“文革”中毁失了。已印行的《佛教基本知识》一书，是他关于佛教法相惟识学方面的专著。他在修持上则以禅为依归，数十年如一日，坚持不懈。晚年在中国佛学院等处多次讲授禅学。正果对禅悟法门的体悟，对禅学理论的研究，集中体现在《禅宗大意》这部力作中。
    《禅宗大意》共分十五节，从佛学角度深刻地阐述了禅宗的历史起源、理论体系与修实践。
    （一）禅宗历史追溯
    正果法师认为：“禅宗，是中国佛教宗派中的特胜法门，教外别传的心宗，不落言诠，不立文字，重实修实证，真参实悟。”在达摩未至中土之前，中国已有禅学的滥触，对后世禅学的影响很大。安世高对禅经的翻译，支娄迦、支谦对大乘禅教的敷演，康僧会对禅教的解说，以及竺法护、道安、慧远、鸠摩罗什、佛驮跋陀罗对禅法的弘传、僧睿、僧肇、道生对禅门的影响，这些都说明了达摩没来中国以前，中国已有禅学在流传，从小乘禅到大乘禅以至祖师禅，其发展的轨迹隐然可寻。其实，禅宗的极则，实无一法相传，更无一法授之，只是以心心契合的证明来表示相传，称之为“千圣不传的传”，禅宗传授的基础，不在于经典，只在于大圆满的佛心。禅的起源，在于世尊的正觉。佛祖拈花，迦叶微笑，自此历代祖师传法传衣，成为大法传授、灯灯相续的真传，西天二十八祖、东土六祖相传。正果法师认为“禅宗的正式建立是从六祖慧能大师开始的。”从达摩至五祖弘忍皆主张“佛尘看净”、“静坐观心，”因而被称为“楞伽师”。从慧能始，并弃打坐，以慧摄定，直指心源，当下即是，创立了真正意义上的禅宗风范。这一论断是有其理论和史实依据的。
    （二）禅悟体证
  禅宗以“不立文字、教外别传、直指人心、见性成佛”为其立宗基础及体验的方法。所以历来祖师大德接化学人，都是用解粘去缚的手法，应病与药，使学人直悟，冷暖自知，以心传心，师资默契而已。正果说：“禅的主眼，是亲证真如法界，不是一种真理的概念，这必须如实体验，始得理会。”他对禅悟体证发明尤多，用墨最重，反对对禅的“考据”式研究，而主张真参实悟，要用心去体证。
    １、调和五事助参禅
    禅定一行，最为神秘，能发起自性的无漏智慧。一切妙用，万德万行，乃至神通光明，皆从禅定生。故三乘人欲求圣道，必须修禅，离此无门，离此无路。至于修禅之法以，正果认为，在形式上必须静坐，诸佛菩萨、三乘圣者没有不通过静坐修禅而悟道解脱的。在行住坐卧四威仪中，端身静坐，最易定身息心，有利于用心参究，故结跏趺坐是修禅之要道。
    坐禅首先要发心，百丈禅师《坐禅仪》说：“夫学般若菩萨，起大悲心，发弘誓愿。精修三昧，誓度众生，不为一身独求解脱。”常住大悲心以无量功德回向众生。誓断烦恼，誓证菩提，一切莫为，只管打坐，放舍诸缘，休息万事，身心一如，动静无间，一定能得到禅定而开悟。参禅，是以见性契悟涅盘妙心为主，除此皆是助道之法。静坐之先，须选择环境，远离喧杂，地处寂静。其次要调五事以助参禅，即调食、调睡眠、调身、调息、调心。禅之可尊贵者，以得法的要道，全在实修、真参、真究、因此称为“坐禅办道。”
    ２、参禅的入门方便
    大凡学佛者，都想通过参禅的方法冲破凡圣关，了脱生死累，转凡成圣，成为无挂无碍的见道人，证得自由自在的大解脱。但是对于参禅如何用心，如何体会，怎样实践，怎样参究，怎样受用，如此等等，想在佛经祖话中找现在答案是很难的。禅宗以“佛语心为宗，无门为法门，”既是无门，那怎么透去？祖师说：“从门入者，不是家珍，从缘得者，始终成坏。”这样说来，大似掉棒打月，隔靴抓痒，永处缠缚，无有出期。其实不然，禅虽深邃，还是有门可入的。正果认为，禅宗的本源，是佛的正觉，不在语言文字上，须领会正觉的意义。以心为宗，总能悟得即心即佛。古德说：“即心即佛，惟证乃知。”成佛实际上是以根本无分别智亲证实相。实相就是无相之相，亲证无明，刹那间是智境冥合，能所双忘，虚空粉碎，大地平沉，这样的境界，绝不是有分别心能通能证的。因此，“无心是道”是正确的方便法门。所谓无心者，并非无真心，而是没有一切杂念妄想，只有孤明历历的心。无心者，即是内照反省，一念触境生心，就是生死，离境无生灭，就是解脱，一念无心，凡夫等佛，烦恼即菩提。
    ３、参禅宜观心
    参禅贵实践，要真参实悟，总能得到受用。所谓真参，就是要在不落言诠、寻思、拟议处用功；所谓实悟，必须悟在无所得处。如沩山灵祐所说：“实际理地，不受一尘；佛事门中，不舍一法。”此一实证之境，只有当人一念观心之极，无念无相，归无所得，无所得亦不可得，这总成就了真参实悟的功夫。
    学禅者要真参实悟，须要“净念观心”。悟道之路，须以净念观心作起。观心反照，是为了以无念相之心亲证无相之实相。众生自性，本来清净，一切现成，不用求，不用学，无你用心处，一有用心，便远之又远矣。所以当下一念休歇便是，不向一切法求，一切心求，到心法双忘，自能独契。虽然如是，在此一刹那以前，还须时刻提撕，回观反照。《遗教经》说：“是故汝等，当好制心，制心一处，无事不办。”
    ４、见性成佛
    见性是禅宗的根本目的。参禅者必须透地宾关门，古今参禅人的第一要事，所谓“见性”，即开发自性，彻见自己本来心性，自觉到本来具有的佛性。参禅悟道，即是要识本心，见本性，所谓“不识本心，学法无益，若识自本心，见自本性，即名丈夫、天人师、佛。”大悟者，觉破了无始以来的迷妄，开显了真实的知见，身心廓然，没有一切尘垢习染。心的自性，不从外来，不自他得，性含万法，本自俱足。一个参禅办道人，如果能彻见自己的佛法，就能自由独立，成为解脱自在的无位真人。
    佛教诸宗中，禅宗不仅最能代表佛教的特质，总持佛法的心髓，而且最富应时契机改革自身原灵活性，最具即世间而出世间，切入生活而超越生活的传统。正果法师晚年致力于说禅解禅，紧扣现代禅学发展的命脉，立足文化重建而再树立禅学法幢，在禅法上多有创见，于体证上多有发明，对现代禅学思想的发展，对禅学在当代社会的复兴，贡献良多。


六、明真心禅宗济世

六、明真心禅宗济世

    明真法师（１９０２－１９８９）是中国现代佛学界一位大德。法号真慈，俗姓赵名哲，湖北荆门县人。曾于武昌就读于华严大学。１９２２年于武昌莲溪寺礼圆安上人出家，次年在南岳南台寺越尘法师座下受具。１９２６年肄业于南岳僧侣学校。１９２９年随灵涛法师创办南岳佛学讲习所，潜心惟识，参研禅那，教学相长，培养僧才，正论胜解，启沃读者。曾应邀到南岳国立师范学院讲授佛学。抗日战争中与巨赞法师结为莫逆之交，投身救亡运动。以民族团结为已任，促建“南岳佛道救难协会”，成为湖南佛教抗日旗帜，新中国成立后，历任长沙开福寺、北京法源寺、广济寺住持、长沙市佛教协会会长、湖南省佛教协会会长、中国佛教协会常务理事，、副会长、中国佛学院教务长、副院长等职。其论文《身非是我论》、《大乘百法明门论臆测》、《五蕴皆空的研究》等七十多万字，先后在《观宗弘法社刊》、《海潮音》、《人海灯》、《正信》、《现代佛学》、《法音》、《佛学研究》等杂志上发表。曾与戒圆法师等一起编纂《湖南省宗教志.佛教篇》。有《望云集》（长沙市佛教协会印）行世。赵朴初会长为明老撰塔铭曰：“弘教弘禅，高标一塔尊南岳；爱国爱民，丹心万古护中华”，对明真的行谊给予很高评价。
    明真法师潜研惟识，参究禅宗，融通禅净，解行并重。其剃度师为南台寺越尘上人。越尘时挂搭于湖北，但其祖庭却在耒阳县（今耒阳市）狮子岭紫霞禅寺，属曹洞法系。明真冶惟识、禅、净于一炉，讲经弘法不重在引经据典，而是致力于结合日常生活揭示佛教人生哲学的真谛，把佛教哲学与日常生活打成一片，随时随地利益人群。
    （一）弘扬在实际生活中有切实受用的经世佛学
    佛教本身就是“人间佛教”，佛学本身就是经世致用之学。但是，长期以来，人们往往以世俗的眼光看待佛教，或从儒家“入世”立场出发，认为佛教徒“遁入空门”，消极避世，似乎不食人间烟火，与世无缘，明老经世佛学思想有力地纠正了这种偏见。他精辟地论述佛学是人们在日常生活中受用不尽的般若智慧。
    １、从生、佛无二论述经世佛学。佛法的根本宗旨，在于普度众生，同登彼岸。作为诸经根本精神的集中体现的《心经》，阐述的就是这个道理。明老说：“《心经》在阐扬‘色即是空，空即是色’的不二法门，我们应从中学到烦恼与苦提无二，生死与涅盘无二，众生与诸佛无二的正知正见，亦即《妙法莲华经》所说的佛知佛见。”佛知佛见，是众生本来具有的。不是离众生别有什么佛知佛见。“大乘认为生灭者，当体即是不生不灭的寂灭，不须在浩浩的日常生活外而去别求涅盘。这一点我们学习《心经》时十分吃紧。”众生与佛、烦恼与菩提、生死与涅盘既相对待，又相统一。世间与出世间也是不二而一，不即不离的。《中论.涅盘品》说：“涅盘与世间，无有少分别，世间与涅盘，亦无少分别，涅盘之实际，及与世间际，如是二际者，无毫厘差别。”明老把佛菩萨喻为大树的花果，众生喻为树根，根深叶茂，总能花果飘香，没有众生，没有世间，也就没有佛菩萨。正是从众生与佛，世与出世相统一的观点出发，明老十分强调佛学的经世致用。
    ２、从福慧双修的菩萨道论述经世佛学。明老认为佛是有最高觉悟的智者。他说：“佛者，觉也。佛弟子假使不能自觉。虽佛在面前，亦是无可奈何的。”佛的可贵在于自觉觉他。学佛修行，不仅在个人解脱的慧业修持，而且在于人生道的福业经营。自觉觉他，福慧双修，自觉以后，仍然不出世，而是积极入世，甚至下地狱，为普度一切众生而奋门不息，这就是菩萨道。明老说：“色空无碍，悲智双运。以文殊普贤的榜样，庄严世界，利乐有情，精进勇猛，永不疲厌。这就是十方国土一切菩萨所行的正道，也就是今天我们中国佛教徒和全世界佛教徒的一个共同大方向。”正因为如此，他孜孜不倦地提倡“人间佛教”，弘扬经世佛学。
    ３、从日常生活中的修持与成佛的关系认经世佛学。挑水、搬柴，行住坐卧，在俗人看来是常事，谈不上什么修持。在佛家看来，“平常心是道”，日常生活中的精神，即是成佛的本分事。这从明老对精神的论述中可以看得很清楚。精神是什么？明老说：“精神是以我为中心，概括了思想、感情、意志和欲望的混合体。……能依据我法二空真如，把思想提炼为智慧，感情陶冶为大慈大悲，我也就塑造成佛了。人身难得，佛法难闻，我们日常生活中的精神，就是成佛的原材料。”思想本身无所谓善恶，却可以思善、思恶。感情即爱憎、同情心，人人皆有，但凡夫俗子囿于小“我”之爱憎，缺乏大慈大悲精神。意志是为达到一定目标的坚持之力，有的人十分脆弱，有的人却十分坚强；欲望既为人类的生存的本能冲动，亦是成就大事业的动力。因此，平常一举一动所体现的思想、感情、意志、欲望，都不是可有可无的，它们经过加工，可以成为般若智慧，成为大慈大悲，大雄大力，大愿大行这种高尚的、纯粹的、脱离低级趣味的佛菩萨精神。作为佛圆满自性的真如，就在日常生活之中，禅宗曹源寺滴水和尚一则公案说：曹源一滴水，七十余年受用不尽，明真法师也说：“不知什么时候起，真如竟然变成了一个名词，变成了一个神圣不可思议的实体，被讲得十分深奥，十分微妙，忘记了真如就在日常生活之中，……侈谈灵感，竞夸瑞应，使佛法蒙上了污垢，丧失了生命力。”他重视教育初机从日常生活中认取佛法，学习佛法，在日常的工作、生活中受作、他说：“务必使初机通过自觉，能在日常生活中认取佛法，享用佛法，心情更舒畅，生活愉快，工作和生活更能干劲僧增，对人民的贡献更大。不然，又何必学习佛法？使佛法不即是智慧，不即是安乐，在人类行将跨入二十一世纪的新时代，又何贵于这样的佛法？又何贵有这样的佛弟子？”
    正是基于众生与佛、福业与慧业，平常心与道、世间与出世间的不二而一，明老的经世佛学没有书斋气息，没有“本本”味道，而是富于“时代气息”、“生活气息”、他认为“本本”上的佛学，即使是佛祖亲授，亦毕竟竟只能是‘示月之指’，并非‘月’本身。如不能联系实际学习佛学，从有收获，也只能是不能充饥的画饼而已。他的佛学不是“画饼”，而是在二十一世纪的新时代在实际生活中受用不尽的禅悦和法乐。
    （二）经世佛学重在救治时代精神病
    明老佛学思想是在实际生活中享用的般若智慧，其最大受用，是在治疗“时代精神病”。
    “时代精神病”，是明老对当今精神失落、精神污染现象的形象概括。他说：“时代是不断前进的。在前进中还有不少的曲折和困难，还有不少的迷茫和痛苦，矛盾重重，指不胜屈：战火已在人类身上燃烧，核威胁、核毁灭的阴云笼罩着世界……当前人类在自己创造的险恶环境中，几乎束手地策，以至许许多多的人，形成消极悲观的情绪，无可奈何地过着醉生梦死的生活。裁军的声浪越高，扩军备战的势头愈加恶性膨胀，这是今天人类所面临的现实。我实无以名之，姑名之曰时代精神病”这种在科技高度发达、物质生活大为丰富条件下人类对自己所制造的险恶环境（生态失衡、战争核威胁）消极悲观，过着醉生梦死的生活，就叫做“时代精神病”。
    “时代精神病”的一个重要根源在于没有正确的思想作指导。本来，物质资料的生产是人类社会存在和发展的基础，科技发展，物质文明程度提高，应该是推动人类社会发展，大大造福人类的。其实二者并不完全同步。离开正确思想的指导，现代科技、物质文明不仅不能造福人类，反而可能给人类带来灾难。明老说：“人的精神，实实在在是不随形骸而俱朽的。……我们对这种微妙的精神研究跟不上去，没有正确的思想作指导，物质研究的成果，是将造福于人类，还是将成为人类的灾难？这就很难说了。”很显然，核反应可以发电，造福于人类，也可以用于发动战争，给人类带来灾难；治性病的特效药，可以使性病得到一定的控制，然而许多人却因为有恃无恐，使性病由过去的四种增加到世界卫生组织公布的二十多种。专家们甚至预测：一旦艾滋病特效药问世，艾滋病的流行必将加速。这不是典型的“时代精神病”吗？
    对治这种时代精神病，离开物质文明建设固然不行。明老说：“肉体与精神，关系密切，不可分别。”“物质之所在，亦即精神之所在。”但根本必须提高人类的精神生活。明老说：“在这种污染的国际气氛中，深信只有提高人类的精神生活，总是救治时代精神病的灵丹。”他对救治“时代精神病”开了几付处方：
    １、“五蕴皆空”——以缘生自性空对治我执、法执
    明老说：“‘五蕴皆空’这一句简单的佛语表达的人、我、世界，现象与本质的辩证统一，过去是真理，现在是真理，未来仍是真理。”他认为，“缘生自性空，这是佛学的一条重要原理。”“佛法用空否定了我与法，却又不愿人死在‘空’中……日常生活中的一一缘生事物上本自具有圆融无碍的空有两个侧面。……把这两个问题解决了，就把握了打开佛法宝藏的钥匙了。”这虽非独创，但他们剧“缘生自性空”的根本原理，密切结合世人的日常生活，对“法执”、“我执”、尤其是“我执”进行了透彻的剖析，认为：诸法都是相互依存的，不断运动变化的，执着诸法以为孤立存在、静止不变的实有自体，就是法执；以为“我”在日常生活中能主宰自己的生活、自己的环境，迷信主宰作用，迷信自由意志，就是我执：二者都是错误的。他对于明末清初思想家王船山（夫之）《相宗络索》中“一刀斩断末那为擒王破竹之元功”尤其作了深入的阐发。他指出：“缘生事物，当体即家，当体即无生，当体即无自体，是用不着什么神造的，也用不着什么本体演化的。”不仅把顿悟与渐悟，惟识宗与神宗、小乘与大乘融通起来，而且有利于纠正世俗对佛教“有神论”的偏见。
    ２、“以身非是我”——对治贪、嗔、痴
    人生活在世上，是不能没有个人利益的。但是，浸淫于个人利益之中，且恶性膨胀，却造成了世间多少悲惨、荒唐的恶果。所谓时代精神病，无非是在新时代条件下极度膨胀的贪、嗔、痴而已。明老说：“佛书上皆称财、色、名、食、睡为五欲。”认为“欲”与人生密切相联，在现实生活中是极其复杂，很有力量的。佛教强调无生、无我，也就是寡欲。欲与善恶密切的相联。“佛学视欲虽非善法，实亦非烦恼法，而认为它是中性的，可善可恶的。无欲，也许就没有崇高的愿望、伟大的理想了。古今中外的志士仁人，为了维护国人、天下人的生存，往往毫不踌躇，慷慨地献出自己的生命，求仁得仁，了无杂质，这是人类生活中的一种特异生活，是精神界的高度升华。”明老不主张对世人的欲望加以禁止，而是主张对欲望加以分析、调御、疏导。他说：“欲，希望为性，欲在人类生活中杂质最多，是很不容易对付的，特别是欲生。欲生，大概是生物共同的特徵，人亦不能独异。人之所以异于其他生物的，或许是能欲生的高尚情趣，欲生的尊严与价值，生在人身上，无时无地不在显示其威力。”他着重指出对欲加以引导的必要性：“在日常生活中，把思想认识摆在第一位，……对情、欲、意加以适当的调节和疏导，必须如此，总能心情舒畅，生活愉快。如果感到用事，欲望横出，丧失了理智，有如脱缰野马，小之必自寻苦恼，大之是会祸世害人的。”试看今日世界，什么“性解放”、“艾滋病”，用硫酸毁面容，用电脑盗窃巨款，杀人越货、吸毒、嫖、赌等，不正是人欲横流，如脱缰野马，祸及天下的“时代精神病”的写照吗？不正是贪、嗔、痴所致吗？
    贪、嗔、痴无非是把世界上的一切都看成是“我”的。对此，明老进一步剖析说：身既是“我”，又是你、他；既是我们，又是你们、他们。身既与“我”相联系，又非是我。身和世界万法一样，都是在过去、现在、未来中不断流动的，既不能执身为“我”，又不能把“我”看成是永恒不变的，。他说：“（王船山）先生在《相宗络索》中点出‘末那执八识一段灵光之体相为自内我’，是‘流转生死的祸根’，必须‘一刀斩断’。是意书中累见，实《相宗络索》内的关键问题。为什么？因为第六意识，是以末那为根而生起的，吸取了末那毒液，于是就固执身即是我，与我贪、我慢、我嗔、我痴相应，触处形矛盾，自苦苦人。不擒贼擒王，对末那迷执，斩草除根，是不能根本解决人生问题的。”般出把第七末那识作为污染真如自性、生起思想、感情、意志、欲望等“我执”的祸根，认为相宗显标渐教，密示顿宗，是惟识秘密法门，确在卓见，明老为独具慧眼，认为此是《相宗络索》的关键问题。的确，对于“我”的执着，污染真如本性，起种种贪、嗔、痴，造种种恶业，其根本即在第七末那识，也就是染污识。人们之所以把属于你、我、他之身执为“我”，把名相执为实相，惟一已之利益是图，陷溺其中而不能自拔，就在于末那识对真如本性的污染，执着。人们对世间万法采取形而上学的绝对化的思想方法，明明身非是我，却执为我；明明五蕴皆空，却执为实；明明名利、地位都是相对的，却以为是绝对的，死死抓住不放。欲海难填，最后在现实面前难免碰得头破血流，甚至自我毁灭，陷入生死轮回之中，永无了期。所以明老反复说：“第七末那识，执第八见分为自内我，则是迷，则将流转五趣生死。悟得此末那为第八流转根本，一刀斩断，即将证得菩提涅盘。”这就为后学的修证指点了迷津。
    ３、转识成智——以提高理智的质量，净化心灵
    明老对惟识宗很有研究，从１９２９年（二十三岁）起即究心惟识之学，十六年后，在南岳佛学研究社，先后讲过《成惟识论》１９４７年在《海潮音》发表过有关惟识学的学术讲演稿。他在《精神的试析之二》中说：“之所以独尊识为心王，是要人们把思想认识摆在日常生活中的第一位，通过对客观事物的不断观察研究，能够逐渐把认识磨冶成智慧，成为清醒明彻的认识。……佛教最终目的，就是要转识成智。不能转智，是无法转染成净、转凡成圣的。人类的精神生活既然有理智，也有感情、有欲望，如何不断提高理智的质量，使之对情欲具有调御、疏导的能力，发挥自他俱利的正常作用，不致泛滥成灾，自苦苦人，这应该是人类今后共同努力的一个方向。”明老认为识为心王，既尊识为“王”，就要把“理智”、般若智慧放在认识的主导地位，以此调御感情、欲望、意志，转染成净，转凡成圣。实际上这也是强调对人的自我认识能力的改造和主体精神的高扬。明老说：“般山先生所撰《相宗络索》，是在揭示人类的精神改造，不随时间以俱朽的。书中重点，在策励学者对自我进行彻底的改造。”明老以佛法作为铸造人们灵魂、净化心灵、拯救世道的灵丹来享用。他说：“今天人类存在的一切尖锐矛盾，莫不与彼制造者精神状态有关。治愈精神空虚、精神污染，建设精神文明，提高人类的精神生活——摆在人类面前的首要任务，就是：明白人类的精神是什么？”这就是说，心病靠心来治，治愈时代精神病，固态了不开物质文明建设，但根治之方，还在加强精神文明建设，还是靠提升人的精神。这是很有见地的，也有强烈的现实意义。
    （三）禅史研究别出新解
    明老对禅宗史的研究论文虽不多见，但从其晚年对《禅源诸诠集都序》研究的遗作看，其学风严谨，充满着禅者独抒性灵、别出新解的活泼精神，给后学留下一分禅史研究的宝贵遗产，虽然其研究结论不是人们都能接受的，但其精神确实令人钦佩。
    明老的遗作《〈禅源诸诠原都序〉是属于禅宗的书吗？》是应中华书局之约，在注释《都序》过程中写的一篇论文。其主旨是“《都序》以教证禅，是作者（宗密）想用此作为手段，把马祖、石头这两个禅宗流派纳入教的轨道，而思有以制约的。”“《都序》‘以教证禅’，想把禅宗纳入教的轨道，这是在扼杀禅宗，改变禅宗的性质。”这个观点不仅新颖，而且有点惊世骇俗，其根据是：１、真性是禅之本源，真性与禅的关系，是源与流的关系，宗密攻击“今时有但目真性为禅者，是不达理行之旨，”“批判的理由近于荒谬。”２、禅宗语录上的文字，与经论上的文字，风格迥异，是无法合，也不必合的，而宗密借助“以教证禅”，想把马祖、石头两个禅宗流派纳入教的轨道，或能有所制约。３、从历史背景看，宗密之时，禅门五家先后登上历史舞台，禅教矛盾十分尖锐，宗密已为朝野尊仰，对上述禅宗两大流派如不心悦诚服，必然会引起反感，欲有所摄服。４、宗密心胸狭隘，以自家宗习的荷泽禅作为分别得失的标准，“难得其旨”，且前后自相矛盾。
    明老对上述论点未及作深入的探讨和考证，但给人们提出了如何会通禅宗真性与教禅，如何全面评价密的功过、得失，如何评价道一、石头禅系及宗密的态度等重要的问题，是富于开拓性，启发性的。
    继明老之后，今人方广锠先生在８０年代末、９０年代初对《禅源绪诠集都序》及其它敦煌文献进行了深入的研究，赞同裴休关于宗密“以如来三种教义，印禅宗三种法门，融瓶、盘、钗、钏为一金，搅酥、酪、醍醐为一味，振纲领而举者皆顺，据会要而来者同趋，“本末相扶，远近相照，可谓毕一代时教之能事矣。”提出整理、恢复、研究宗密所编《禅藏》的重要课题，并指出宗密编辑《禅藏》的指导思想是“摆定各派的相互位置，调和它们的相互关系，”《禅藏》之所以亡佚，是亡佚于两宋战乱，也与它“不见容于传统的禅宗观点”有关。这最后一点与明真法师怀疑《都序》非禅宗之书的结论是相一致的，但比明老的研究更深入，涉及内容更广泛，引起国内外学者的注目。
    明老对宗密的研究别具新解，但并未全盘否定宗密的贡献。他“发现《都序》还有精华”，认为宗密所说“达摩所默传的，不是名，而是体”的结论值得肯定，达摩传的是什么。这“是中国佛学研究的新课题，值得珍视的。”认为宗密“从十个不同的侧面，辩析性宗、空宗的同异，这也是中国佛学界应该认真研究的一个课题。”肯定宗密的“高僧”形象至今并未泯灭，这都是实事求是的。
    明老在禅宗研究中，还阐述了“禅宗在生活中了生死”这一可贵精神，他认为禅宗并不否认次第禅（即外道禅、凡夫禅、小乘禅、大乘禅），“而是彻见绝对即在相对之中，无差别即在差别之中，最上乘禅即在次第禅之中，不于日常生活外别求佛法，此禅宗之可贵也，此禅宗之所以为禅宗也。”“离开日常生活，去别求佛法，即使求得了，也是医眼空也，也是不藏龙的死水。”他肯定中国禅宗“是从繁琐的佛教哲学，僵化的宗教仪式中冲杀出来的生力军，今天还有她的生命力。”这些论述，都体现了禅者不墨守成规，敢于冲破传统束缚，生动活泼的创新精神，充满着般若智慧。
    明真法师的弟子中，著名的有道安、道屏、暮茄、妙谈、灵根、戒圆（１９２６－１９９５）、惟正、李克等。


七、印顺禅史研究

七、印顺禅史研究

    印顺法师是我国现代佛教界一位高僧，也是对佛教教育、佛学研究，包括禅宗史研究卓有贡献的导师和学者，有论者说：“在当代的佛教学者中，能够像印公这样从历史发展的角度去探讨、研究佛教（无论是历史的还是思想的），并且建立起了自己的博大精深的思想体系者，并不多见。”
    印顺法师，号盛正。１９０６年诞生于浙江海宁一个半农半商家庭。俗姓张，名鹿芹。七岁进私塾，十三岁高小毕业，随即习中医，并研读道书及西方宗教之学。十六岁起在小学任教八年，二十岁始对佛学发生兴趣，二十三岁其母猝然病逝。不久，叔祖父、父亲亦相继病逝，深感人生无常，遂立志出家，二十五岁到普陀山福泉礼清念和尚披剃，受具足戒于天童寺，曾于闽南佛学院、武昌佛学院就学，参虚云、慈舟和尚，亲近太虚大师等，往来于普陀、厦门、武昌之间，授课讲经。二十六岁至三十岁曾在普陀佛顶山阅读《大藏经》，后到杭州、扬州参学，遇太虚大师，遵嘱往武昌佛学院、四川汉藏教理院讲学、研究，常与法尊法师讨论法义。１９４８年（四十二岁），在浙江雪宝寺主编《太虚大师全书》（共七百万字，历时一年）。１９４９年到香港，任香港佛教联合会会长及世界佛教友谊会港澳分会会长，并出版《佛学概论》。四十七岁，从台湾赴日本出席世界佛教友谊会第二届代表会议，后任台北善导寺导师。《海潮音》杂志社社长，在新竹建福严精舍，并赴菲律宾弘法。五十一岁任善导寺住持，在新竹设女众佛学院，创台北慧日讲堂，并多次出国弘法。１９６４年在嘉义建妙云兰若，同年在当地掩关静修。一年后，应中国文化学院之聘，任哲学系教授。１９７０－１９７４年出版佛教论文集《妙云集》，共二十四册，三百六十万字，１９７１年出版《中国禅宗史》，二年后，日本大正大学授予文学博士学位，为中国近代佛教史上获此学位的第一位中国僧人。１９８１年出版长达八十万字的《初期大乘佛教之起源与开展》，随后陆续出版了《如来藏之研究》、《空之探究》，《印度佛教思想史》、《中国古代民族神话与文化之研究》。前后出版的重要著作还有：《中观今论》、《惟识学探源》、《原始佛教圣典之集成》、《说一切有部为主的论书与论师之研究》、《杂阿含经论会编》等，共计著作约七百多万字。是近代继太虚大师之后著作最宏富的人，从其受学者有常觉、演培、续明、仁俊等多人。
    印顺法师的佛学研究，是客观地对全体佛教进行全面的厘清、阐释与批评、他从原始佛教经论《阿含》、《毗昙》及印度之空、有、真常三系诸经论，直探佛陀又后代祖师的经义，尤其对龙树中观学作深入之探讨，为自宋以来对中观研究最有贡献者，他对于原始佛教、部派佛教、中国禅宗史都有精深的研究。
    印顺法师重在学问、闻思，从经律论中探究佛法，他曾说：“在修行、学问、修福——三类出家人中，我是着重在学问，也就是重在闻思，从经律论中去探究佛法。”他对于禅宗的研究，即是从早期流传的经典，史料出发，以般若智慧进行剖析、探讨的。
    （一）以般若贯穿禅宗史研究
    印顺三十六岁时出版的第一部著作是重庆印行的《印度佛教》，他在对早期大乘经典的探究中，深刻认识到：印度佛教史上的第一个大乘教派——空宗，是龙树依据《般若》（还有《阿含》）思想而发展创立的。以《般若》——龙树思想为代表的初期大乘，是时代的产物，是“势所必至，理所当然”的。他站在时代的高度，从当时历史事件和发展趋势来把握般若思想，指出其历史必然性。他把大乘佛教分为三大系统：第一、性空惟名系，以龙树中观学为代表；第二、虚妄惟识生活费，以无著、世亲的惟识学为代表；第三，真常惟心系，宣扬实有的真如——如来藏之说，如中国佛教的天台、贤首、禅宗几个宗派都是。而且，“三系同源”，性空惟名系以现观法性为主要目的；虚妄惟识系，虽广说法相，在修证上先以识有遣境无，以境无识也不起，达到心境都无所得，也归入极无自性的现观；而真常惟心系，也是无由观察外境非实有的观察义禅，进到二无我而不生妄想的攀缘如禅，直到般若现前、于法无我、离一切妄想的如来禅。这与虚妄惟识者的现观次第是一样的。
    他还在《佛在人间》一书中，就世间法与出世间法进行对比，论定：“佛化道德的特质在般若。”他说：“佛化的道德，建立于般若——无我智的磐石，是破除私我、扫荡执见的特殊智慧。从这种智慧所摄提、所引导的，便与凡夫的德行截然不同。不再专为自我，我的家庭、我的庙子、我的故乡……而着想，能从整个人类、一切众生的立场去看一切。……体悟一切法无我，真慈悲即活跃于内心，私情和爱欲，能当下断尽。”
    这样，印顺法师从般若思想产生的历史必然性、“三系同源”论、佛化道德的特质在般若三个方面，为其研究佛教、尤其是中国禅宗史、中国佛教奠定了理论基础。
    （二）禅宗史研究的创见
    印顺法师对中国禅宗史的研究，虽然从内容而言，仅限于对中国早期禅宗史的研究（至五宗分灯止），未见贯通中国禅宗发展史的全部，但是，他的研究成果有令世人注目，在国际上享有盛誉。这是由于他的禅史研究颇多创见的缘故。
    关于禅宗史研究方法论问题。他明确指出：“禅史就包括两大部分：禅者的事迹与传承，禅法的方便施化与演变。”后者“该是禅史的重要部分。”重视禅宗思想发展演变的历史，从而避免禅史研究流于史料的堆积或烦琐考证的倾向。他也重视文化传统、社会风尚对于禅宗宗派、禅风形成的影响，对“南禅”、“北义”的差异及其原因作了深刻的探讨。他还认为，禅宗的传承法统既有史料的依据，又有禅者“充满热心的传说，”不是单纯的考据所能得出的结论，这些对于禅宗史研究都有方法论的指导意义。
    关于达摩其人。他肯定达摩在历史上确有其人，从海路来中国，其所传的“二入四行”理论为人所共知；所谓“理入”，即从“深信含生同一真性，但为客尘妄覆，不能显了”这一信念出发，经过“凝住壁观”等的修炼功夫，达到“舍妄归真”、“与真理冥符”的境界，即以后禅宗所谓“明心见性”之义。根据“深信念生同一真性”的观点，达摩显然也是一位“真常惟心论”（或“如来藏论”）者。达摩的传承，见“楞伽禅之传承，”从思想上说，求那跋陀罗与菩提达摩，属同一体系，达摩继承跋陀，“但在中国禅宗的传承中，跋陀的地位被遗忘了。”达摩传法给道育、慧可与昙林。印顺明确肯定达摩—慧可－僧璨－道信－弘忍的一脉相承之说：
    达摩禅“借教悟宗”。重教的，流衍为名相分别的楞伽师；重宗的，又形成不重律制，不重经教的禅者，护持达摩深旨的慧可下那禅师，璨禅师等，以《楞伽经》为心要，随说随行，而助以严格的、清苦的头陀行。道宣时，一颗光芒四射的慧星在黄梅升起，达摩禅开始了新的一页，使达摩禅终于一跃而成为中国禅法的主流的，是道信与弘忍。
关于双峰、东山法门。印顺法师论述了“道信禅法”的三大特色，即戒禅合一。《楞伽》与《般若》合一、念佛与成佛合一。尤其明确指出：
    达摩门下曾有“楞伽师”（胡适称之为楞伽宗）的系统，……到了道信，游学南方，更深受南方般若学的影响。……等到在双峰开法以，就……成为《楞伽》与《般若》统一了的禅门。
到了弘忍的时代，“五代相承”的法统说被确立下来了，“教外别传”、“不立文字的顿入法界的、以心传心的达摩禅，也被明确的提出来”了，肯定“不立文字”，“教外别传”、“顿悟”等一向被认为慧能禅宗特徵的教说，早在弘忍的“东山法门”时代已经有了。
    关于慧眼的《坛经》。印顺法师考定：慧能生于公元６３８年，二十四岁去黄梅礼五祖，公元６６２年起隐居五年（二十五－二十九岁），乾封元年（６６６）在广州出家（三十岁），先天二年（７１３）入灭（七十六岁），慧能虽“不识字”，由于有着更深的“宿慧”，而通晓佛法大意。慧能在韶州大慧寺开法，产生《坛经》，对后世产生深远的影响。慧能曹溪禅的传播，大体在岭南、江南、中原三区。《坛经》分为三部分：一部分是原始的《坛经》，为《坛经》的主体，是开法大梵寺的记录；另一部分是附录，是六祖平时与弟子的问答、临终付嘱以及临终及身后的情形，应与主体部分分别处理。中国禅宗的法统说，分三个时期：第一、弘忍门下的中期传说（有神秀或慧能为第六代两说）；第二、西天二十八祖，约公元７３０年始形成；第三、西天二十八祖的改定时期，约流行于八世纪慧矩《宝林传》之后，敦煌本《坛经》约成立于公元７８０－８００年间。
    关于神会。印顺考定神会年龄非九十三岁，而是七十五岁。神会十四岁谒慧能（“中年”应为“冲年”），“过师于晚景”，“不离曹溪山，常侍左右”，慧能入灭时，神会二十六岁，“神会为曹溪顿教而献身，不避任何艰险，坦然直进，终于达成。韶州慧能为禅宗六祖，永为后世定论。”
    关于慧能以后的禅宗。印顺认为，慧能在岭南的弟子如法海、志道等，“他们的贡献，是《坛经》的集成和传出，及有关慧能事迹的传说”；“发展曹溪顿教而成大宗的，属于中原及江南的弟子”，即中原的荷泽宗，江南的洪州宗与石头宗，剑南的保唐宗。
    （三）对禅宗的评价
    印顺法师认为，中国佛教流传至今一千九百多年，甚流行可分为二个时期：第一个时期，自汉魏至隋唐，“为承受思辨时期（约偏胜说），”“其特色为融贯该综，得则华贵、宏伟，失则繁文缛节，如世家子，确树比一代之风者，襄阳释道安也。”第二时期，自李唐至清季，“为延续笃行时期，即所知而行之证之。其特色为简易平实。得则浑朴忠诚，失则简陋贫乏，如田舍郎，确树比一代之风者，岭南虑慧能也。”对禅宗的得失，慧能之建树，作了客观的简略的评价。
    关于禅风，印顺法师说：
    禅宗之初，颇近两年于一分声闻行者，四事恬澹，有头陀之风；重实践，不以论说为重；有法堂而不立佛殿；经行、坐禅于山边林下，随适而安；解脱之心甚切，所谓“已事未明，如丧考妣”；随闻悟入；凡此莫非古代声闻佛教之遗风。然禅者衣食随缘，不拘于三衣、中食，多从事劳作，如百丈一日不作、一日不食，自始即别立禅院，与律寺异，迥异于古代……。至于禅者所悟，以达摩二入、四行观之，则藏心本净之见也。
印顺法师肯定“禅宗为千真万确之惟心论……而且是真常惟心论”；禅宗“为后期中国佛教之心髓
”，“唐、宋禅兴而义学衰。”
    印顺佛学思想根本在返求印度佛教本义。他在《印度之佛教》的自序中论：
    立本于根本（即初期）佛教之淳朴，宏阐中期佛教之行解（梵化之机应慎），摄取后期佛教之确当者，庶足以复兴佛教而畅佛之本怀欤！
    因此，他对于大乘佛教（属于后期佛教）虽有所肯定，亦有所批评。印顺《谈人世与佛学》一文，曾批评中国佛教理论的特色是“至圆”，修行方法是“至简”，修证特色是“至顿”，它的批评对象包括禅宗。台湾现代禅的创始人李元松居士认为“印顺法师间接影响禅的式微，”“印顺法师对禅（包括对密教、对净土）的批评并没有深及禅的内在生命。”“只停留在表面的层次。”台湾现代禅的理论骨干温金柯则说：印顺法师“继承太虚思想，提出契合时代理性，人文思潮的‘人间佛教’，当然是值得赞叹的。但他将重视佛法之契证的宗派，如禅宗，批判为‘小乘急证精神的复活。’对修证倾向的怀疑与贬抑，正是印顺‘人间佛教’所以为浅化，而不符大乘菩萨道真精神的根本原因。”不管人们对印顺的禅学、佛学思想如何评价，甚至有不同的意见，印顺的禅学研究，都有自己的独到见解，在国内外有深远的影响，这是肯定的。


附录I、中国禅宗宗派法脉传承图

    说明：
    1．本图系根据《五灯会元》、《祖堂集》、正续《高僧传》、《禅灯世谱》、《中国禅宗历史之演变》、《中国佛学人名辞典》附表、《巴蜀禅灯录》、海内孤本《黄龙崇恩禅院传灯谱》、《金山志》、《云居山志》、《重修曹溪通志》、《曹溪禅人物志》以及日本《佛心宗法脉图》和《禅宗法系谱》等资料汇编而成，力求比较全面、完整地反映禅宗在中土流传的概貌。本传承图共收入僧尼、居士人名七千七百四十六人，较《中国佛教人名辞典》附表增加了二千七百多人(其中据《巴蜀传灯录》补三百七十八人，据《曹溪禅人物志》补三百多人，据日本《佛心宗法脉图》、《禅宗法系谱》补九百五十多人)。其中重复错谬之处虽作了一些订正，但缺陷仍多，张冠李戴者当在所难免。全面增补、订正，尚期待后贤及来日机缘。
    2．各谱、志、传、表互有长短、详略，我们力求扬长避短，择善而从。如《禅灯世谱》有资料翔实之长，但其以唐肃宗、唐代宗隶属於南阳慧宗门下，唐宣宗嗣盐官齐安等，诸如此类，似不可取。其於沩仰、临济、云门诸宗法脉，列之甚详，而对曹洞寿昌慧经、云门澄法脉等因资料所限，亦付之阙如，我们参考他书补上。
    3．所列僧人、居士以中国僧人为主，亦少数收入新罗、日本入华僧(一般在括号内标明新罗、日本等)。下限最迟至本世纪九十年代。居士虽不是禅宗法脉之主要传人，但考虑到宋以后士大夫与禅宗关系甚为密切，故仍备录，以供参考。
    4．有些谱、志、传、表对同一禅师之法名或有异称，详略不一，对明显可以判断为一人者，因限於篇幅，仅采用一名，而舍弃其余；对不能判断是一人抑或是二人者，则仍两存，不贸然取舍。
    5．法脉传承，当列史乘确有记载者。对达摩以前之二十八祖等传说，本书不单独列表，读者可阅览有关资料而作判断。
    6．为了编排和阅读的方便，本图表采取化整为零的方式，按达摩到慧能，南北分宗，青原、南岳两系，沩仰、临济、黄龙、杨歧、云门、法眼、曹洞灯灯相续及近代传承的顺序，分别列出传承法脉，有一些还注上生卒年号；年代不可考，而其经历的年代尚有确实史料可证者，亦列出大体经历的年代，以供读者进一步考证时参考；年代不可考者则暂不列年代，拾遗补缺，尚俟之异日。一表列不下者，则分列几个表(凡用黑体字标出者，表明应参照前后几个表)。
    7．有关宗派传承人数众多，有一表列不下者，则分列数表，读者可参照阅读，以窥其全豹。


附录I-01

附录I、中国禅宗宗派法脉传承图-1


附录I-02

附录I、中国禅宗宗派法脉传承图-2


附录I-03

附录I、中国禅宗宗派法脉传承图-3


附录I-04

附录I、中国禅宗宗派法脉传承图-4


附录I-05

附录I、中国禅宗宗派法脉传承图-5


附录I-07

附录I、中国禅宗宗派法脉传承图-6


附录I-07

附录I、中国禅宗宗派法脉传承图-7


附录I-08

附录I、中国禅宗宗派法脉传承图-8


附录I-09

附录I、中国禅宗宗派法脉传承图-9


附录I-10

附录I、中国禅宗宗派法脉传承图-10


附录I-11

附录I、中国禅宗宗派法脉传承图-11


附录I-12

附录I、中国禅宗宗派法脉传承图-12


附录I-13

附录I、中国禅宗宗派法脉传承图-13


附录I-14

附录I、中国禅宗宗派法脉传承图-14


附录I-15

附录I、中国禅宗宗派法脉传承图-15


附录I-16

附录I、中国禅宗宗派法脉传承图-16


附录Ⅱ 近百年中国禅宗大事记

附录Ⅱ 近百年中国禅宗大事记
(1890～1990)

1890年
太虚(乳名淦森)生於浙江海宁州长安镇。虚云(1840～1959)五十岁，从拉萨经不丹到印度朝圣。
1897年
日人水野晓梅考察湖南佛教。
1902年
寄禅(八指头陀，1851～1913)辞上林寺主持职务，主天童寺丈席。
1907年
道阶(1866～1934)到星马、南洋槟榔屿、锡兰、缅甸、印度等国参访，后任金钱山、法源寺住持，倡修《新续高僧传》(六十卷)，在新加坡建中华寺。
1908年
寄禅被推举为宁波僧教育会会长。杨仁山在南京成立祗洹精舍。
1911年
辛亥革命。日本医生山崎将福建漳州无际大师(传为石头希迁)真身运往日本，存放警视厅。
1912年 2月8日，
中华佛教总会在上海静安寺成立，寄禅任会长，清海、道兴任副会长。
1913年 1月8口，
寄禅为维护教产遭辱，於北京法源寺圆寂。冶开(1852～1922)被推为中华佛教总会会长，清海为副会长。谛闲、应乾等发起成立世界宗教会。频伽《大藏经》编印完成。
1914年
欧阳竟无居士在金陵刻经处讲授佛典，《佛学丛报》第10期刊衡山南台寺(石头希迁祖庭)《日本僧赠藏经记》碑文，叙日僧水野梅晓、永平寺性海、本愿寺大谷赠铁眼本《大藏经》—部，刊石於藏经楼侧。口本大正博览会木乃伊展览场展出我国古代禅僧(传即希迁)肉身像。
1915年
太虚撰《整理僧伽制度论》、《佛法导沦》。来果接高旻寺月朗全法。虚云在鸡足山传春戒。日本於青岛开设曹洞宗布教所。
1916年
虚云赴缅甸迎请玉雕佛像。
1917年
太虚到台参访，赴日访问。月霞(1857～1917)圆寂。李叔同(1880～1942)归依太慈山虎跑寺了悟长老，法名弘—。
1918年
太虚发行《觉社全书》。丁福保撰《四十二章经笺注》等多种。《印光法师文钞》刊行。王与楫居士於沪创中国佛学会，讲授惟识经论。重庆佛源创佛学社於长安寺。
1919年
太虚於北平观音阁讲《维摩诘经》。虚云於昆明启建水陆道场。来果继主高旻寺丈席。日本曹洞宗在台湾嘉义创阿里山寺。
1920年
《海潮音月刊》创刊，由上海中华书局发行。太虚应湖南省省长林特生、总司令赵恒惕之请，赴长沙讲经，长沙成立佛教正信会。虚云受唐继尧等之请，主昆明华亭寺丈席。太虚撰《人工与佛学之新僧化》、《唐代禅宗与社会思潮》，以反信教的学术精神、反玄学的实证精种、反因袭的创化精神，说明禅宗与学术思潮，以虚无主义、布尔什维克主义、德谟克拉西主义之精神，说明禅林与社会思潮。觉力於台湾法云寺创立禅堂，率新戒参修。太虚发表《宣言》，述整理僧伽之志愿。丁福保《佛学大辞典》出版。佛源在四川重庆办佛学研究会。
1921年
宗仰法师(1865～1921)圆寂，寿五十七岁，曾建议罗迦陵印《频伽
藏》一部。
1922年
冶开法师圆寂，世寿七十—岁，僧腊五十九，有《冶开禅师语录》三卷行世。太虚在汉阳归元寺讲《圆觉经》；智德在安庆讲《地藏经》，道阶在北平西安门外讲《成惟识论》；空也在长沙开福寺讲《法华经》；德安庄长沙上林寺讲《大乘起信论》。虚云整修元代所建华亭寺为云栖寺。太虚任武昌佛学院院长。安庆佛教学校、衡阳佛学讲习所开学。太虚任宁乡沩山密印寺住持，并任佛教慈幼院院长。觉力任台北龙山寺住持，禅堂落成。上海佛教居士林林刊创刊。禅定法师在营口创建楞严寺。
1923年
上海世界佛教居士林成立。欧阳竞无在南京支那内学院创办《内学院院刊》和内学院刻经处。
1924年
太虚在庐山召开世界佛教联合会。胡适始撰《中国禅宗史》。会泉创办闽南佛学院，任院长。大勇在北平创立藏文学院。班禅喇嘛为达赖所驱，经甘肃到北京。佛源任成都文殊院院长。北京广济寺弘慈学院成立，杨棣美在檀香山印行《二十世纪文化以佛化为归》小册子。
1925年
孙中山逝世。中华佛教会筹备处成立。湖南佛教会成立，宝生为会长，欧阳竞无创法相大学，太虚即席讲演。日本召开东亚佛教大会。武汉佛化新青年会出《狮子吼刊》。湖南佛教宣传社出版佛学杂志。觉力於台湾法云寺开办女众研究院。台北万龙山寺创办《台湾佛教新报》(旬刊)。守培在镇江超岸寺创玉山佛学院。苏州创中华佛教大学。
1926年
太虚在上海筹组中华佛化教育社，发行《心灯》旬刊，撰《评宝明君中国佛教之现势》，谓中华佛教若能复兴，必不在真言密咒或法相惟识，而在於禅。世界佛教居士林新屋落成。世界佛教联合会在北京成立事务所。北京法源寺创办中华佛学院，空也任校长。虚云在云栖寺传春戒。胡适在巴黎、伦敦收藏之敦煌写经中发现神会《显宗记》及语录。李普现撰《寒山拾得非禅僧论》，刊於《中道》杂志。北京佛学研究会成立。唐生智电长沙省党部、省工会、农会等，对宗教残余之纪念品及寺产应予保护。岳峰法师圆寂。
1927年
两湖佛化联合会在汉口成立。唐生智改革僧制未成。前佛化青年会会长张宗载在汉口创办《无畏月刊》。冯玉祥於开封毁佛教寺院、道观。湖南佛化会推选程施愿居士任主席。虚云於云栖寺传戒、讲经、坐禅。太虚撰《僧制今论》，谓佛化重心已移置信众，时代趋势侧重生计，僧众不能不为生计分子，以谋自立於社会。胡适撰《菩提达摩考》，於上海讲演《中国禅宗史》。
1928年
胡适撰《白居易时代的禅宗世系》、《论禅宗史的纲领》、《禅宗古史考》等。南京居士林成立。湖南菩提寺育普法师开办平民工厂、平民小学、贫民医院。
1929年
道阶代表中国出席仰光世界佛教大会。四川佛教团体联合全省一万九千七百五十八寺，通电力诋国民政府《寺庙管理条例》有十种不合法，誓不承认。安徽容虚、寄尘创办九华佛学院。中华佛学会於南京万寿寺成立，太虚为会长。胡适撰《荷泽大师神会传》，称神会为“南宗的急先锋，北宗的毁灭者，新禅宗的建立者，坛经的作者。”日本台湾总督府公布台湾宗教情报，本岛信徒二十万零八千六百七十三人，寺庙斋堂神明会九千九百三十四所，耶教信徒四千五百—十二人，教堂二百一十六所。来果改革高旻寺早晚课诵仪程，送往生不念阿弥陀佛经往生咒。华阳县南华宫祀禅宗六祖大师。
1930年
世界佛学苑教理研究院成立，太虚任院长。虚云住持鼓山涌泉寺，至闽南佛学院邀大醒、心道开办僧学。来果於高旻寺建宝塔、禅堂等五大工程。虚云於鼓山传戒，归滇，以云栖寺丈席传安空法师。胡适整理《神会和尚遗集》出版。班禅於雍和宫建时轮金刚法会，虚云於鼓山筹办律学院。印顺在鼓山佛学院任教。
1932年
明教法师圆寂，世寿七十八岁，有《警世嘉言录》、《讲经记录)传世。重庆成立世界佛学苑汉藏教理院。太虚任雪窦寺住持，班禅任西陲宣化使职。章嘉呼图克图任蒙旗宣化使。圆瑛任中国佛教会理事长。来果删节《古百丈清规》印行。胡适撰英文《禅宗在中国的发展》。
1933年
达赖十三世在拉萨圆寂。虚云於鼓山扩建“异牛祠”为放生园。惠光返沩山佛学院讲课，秋入南京支那内学院讲《百法明门论》及《惟识三十颂》。班禅喇嘛於南京宝华山建药师法会，於北平太和殿建时轮金刚大法会。大醒撰《日本佛教视察记》。南京古林佛学院、金陵佛学院开办。
1934年
道阶法师於马来西亚逝世，世寿六十五岁，僧腊四十七、智光创办焦山佛学院。班禅任国民政府委员，并於杭州启键时轮金刚法会。黄忏华《佛教各宗大意》出版。中国佛教会在上海召开第六届全国代表大会。太虚电贺第一届欧州佛教大会在伦敦召开。南岳怀让、慧思塔院呈请省府保护。虚云整顿鼓山佛学院，延慈舟法师主持。印顺任教闽南佛学院。西藏三大寺代表请班禅回西藏。
1935年
《佛教日报》创刊，太虚任社长。班禅5月经南京返藏。太虚於南京中国佛学会讲《优婆塞戒经》，论其志趣为：“非研究佛书之学者，非专属一宗之徒裔，无求即时成佛之贪心，为学菩萨发心而修行者”；在厦门讲《佛学会与实现佛心》；於香港讲《优婆夷教育与佛化家庭》；於广州讲《禅宗六祖与国民党总理》，并撰《建设现代中国佛教谈》。胡适撰《楞伽宗考》。
1936年
宋碛砂藏经五百九十三册全部出版，国民党政府内政部统计：全国寺庙庵院共二百六十七万余所，僧尼计七十三万八千余人，在家信徒超过出家者五倍以上(不包括川、豫、湘、赣、皖五省)。
1937年
喜饶嘉措於国立中央、北平、武汉、中山、清华五大学讲学。太虚就抗日战争发表《告全国佛教徒书》。九世班禅寂於青海玉树。杨州高旻寺制订《高旻专门禅宗规约》，规定该寺永不出门做经忏、放焰口，不得开学堂、学密宗、示念佛。近代禅林有规约者，仅镇江金山寺、常州天宁寺及高旻寺几家而已。章嘉呼图克图任国民政府委员。熊希龄居士病逝，终年七十一岁。
1938年
南岳僧侣救护队成立，参加者有五大寺一百二十余人，道安任大队长，大定、智圆任分队长，经集中训练，每遇空袭，即赴战地救难。太虚膺任中国佛教会理事长。上海僧侣救护队解散。虚云赴广州讲经，後赴香港东莲觉社建大悲法会。惠光於浏阳兴华禅寺讲《法华经》，後转赴神鼎山讲《净土五经》。伪满佛教调查，现有佛教寺院庵堂二千余所，僧尼四千二百多人，信徒一百八十万人，有真言、天台、法相、三论、律、净、禅七宗。禅门又分临济、曹洞、毗卢、贾菩萨四派、日本曹洞宗於北平创设观音寺。
1939年
太虚赴滇弘法，虚云於南华寺传春戒。来果於高旻寺禁绝大小经忏佛事、闭关、般舟行，只坐香参禅。道安赴桂林讲经。日军进犯五台山，一千三百七十九名僧侣奔散。南岳巨赞、演文、慕茄组织佛教青年服务团，赴长沙一带工作。西藏第十四世达赖转生。章加呼图克图任成都蒙藏教理院院长。太虚任“国民精神总动员会”建设委员。日本曹洞宗於中国山西创平潭寺、阳泉布教所、榆次观音寺，潞安观音寺、北京别院观音寺，并於驹泽大学设立“大陆开教师养成机关”，於河南建金阁寺。台北圆山町临济寺开办“布教师养成讲习会”，训练台湾青年僧举办各种日本法式。
1940年
中国佛教国际访问团由缅甸抵印度、锡兰访问。衡阳罗汉寺举办佛学院，由灵涛、明真领导。黄忏华《中国佛教史》在长沙商务印书馆出版。来果以天灾人祸，目不忍睹，欲舍身蹈海，受累难行，是年六十岁。虚云修曲江大监寺作南华下院。日本东方文化研究所水野清一前往云冈石窟调查诸代造像记铭，前後四个多月，获多种珍贵古物。东初於焦山佛学院编《中流月刊》。
1941年
缅甸记者访缙云山太虚法师，考察中国各地佛教。唐大圆居士逝於宝庆。广州六榕寺住持铁禅法师创办国际佛教协会华南支会佛教图书馆落成。广东成立佛教居士林。印顺任四川合江法王学院院长，撰《行为的价值与生命》、《佛在人间》等文。赵恒惕於南岳设佛学院，请太虚为发起人。虚云於南华传春戒，以善信布施二十万元捐献广东省政府赈济粤北饥民，秋任广东省佛教会理事长。欧阳渐居士整理生平著作成《竞无内外学》二十六种，共三十余卷。惠光任道吾山孤儿院院长。
1942年
虚云於南华寺传春成；主持护国息灾大悲法会。弘一法师圆寂，世寿六十三岁。南京大报恩寺发现玄奘顶骨。
1943年
虚云於南华寺设戒律学院，於宝林门内兴办义务小学。欧阳渐居士去世，终年七十二岁。太虚连任中国佛学会理事长，陈铭枢、李基鸿、谢健、卢铸任常务理事。印顺《印度之佛教》5月出版。太虚应请主衡阳花药仁瑞寺。重庆举行释尊成佛纪念大会，虚云、太虚就席开示，列会者二万余人。
1944年
班禅十世於塔尔寺举行坐牀典礼。国立敦煌研究所成立。黄忏华《中国佛教简史》成。南京玄武山建宝塔，收纳玄奘顶骨。虚云辞南华丈席，赴云门振兴祖庭。印顺於法王学院为妙钦整编《中国佛教史略》。
1945年
印顺在北碚汉藏教理院讲《阿含讲要》。虚云於广东乳源云门山整修古大觉禅寺。8．15抗日战争胜利，日寇投降。各地日人寺庙无形瓦解。太虚发表《告世界佛教徒书》。法尊成立汉藏教理院译经场。中华佛教整理委会员成立。印顺撰《秦汉之佛教》，刊《文史杂志》。铁禅被日军拘捕，病死狱中，终年七十九岁。《东方杂志》刊钱穆《神会与坛经》，驳胡适关於神会伪造《坛经》之说。太虚《人生佛教》由海潮音出版社出版。
1946年
台湾佛教会成立，本圆任理事长。世界佛学苑沩山预习院开学，密印寺住持茗山兼任院长。天宁寺住持敏智办佛学院，力求禅教合一，并谋生产。太虚在杭州成立觉群社。虚云主持六榕寺追荏抗战殉难军民同胞诵经法会。东初任定慧寺住持、焦山佛学院院长，中流月刊发行人，复创工读社，勉僧侣从事生产，道安创办南华戒律学院。
1947年
震华法师於上海玉佛寺圆寂，年三十九岁，有《夹山变叶集》、《碧岩吟稿》等传世。太虚法师於上海玉佛寺圆寂，世寿五十九岁，一生倡导大乘佛教，实行人间净土之理想，四十余年，奔走於大江南北，及世界各国，致力革新运动，举凡创办佛学院、佛教刊物，筹设菩萨学处，乃至联系国际佛教运动等，均已初具成效，并为後世奠定良好典范宏规，其思想之渊博，卓识之高超以及各项建树，近代教界中实无出其右者。中国佛教会在抗日胜利後第一次会员代表大会在南京毘庐寺召开，章嘉为理事长，雪嵩、喜饶嘉措、苇一、亦幻、雪烦、李子宽、谢健、蒋士杰为常务理事，徧能、虚云、赵仆初、巨赞、东初、茗山等二十二人为理事。宝昙任湖南铜梁乡云溪寺住持。
1948年
惠光为南华戒律学院经学教授。虚云赴广州主持佛教志德医院开幕，後往香港慈航净苑讲经，结七念佛，又至东莲觉苑拜忏。印顺在厦门传戒，并赴同安、晋州诸山巡礼。
1949年
中华人民共和国成立。巨赞、赵朴初当选全国人民政协代表．赵朴初并当选为全国政协委员。法舫应请为大沩山密印寺住持。虚云赴香港般若精舍讲经一月，募集十万港币，归广东。倓虚创香港华南学佛院。章嘉呼图克图由成都抵台湾，在“中国佛教徒联谊会”上被选为常务理事。班禅十世於塔尔寺坐牀。
1950年
巨赞、李济琛、陈铭枢、赵朴初、喜饶嘉措、周叔迦等在京成立现代佛学社，出版《现代佛学》月刊，陈铭枢为社长，吕瀓为名誉社长，巨赞任主编。国家民政局统计，杭州现存寺庙五百五十九所，僧尼斋徒一千八百人。印顺编撰《太虚大师年谱》出版。道安任香港佛教联合会理事。律航於弥勒内院修般舟三昧，撰《百日念佛自知录》。日本铃本大拙在美国讲演禅学。
1951年
虚云在云门寺依例传春戒。因政治原因，僧众二十六人涉嫌被捕，虚云等受伤，经年方愈。惠光成《禅宗讲录》，约六万余字。达赖喇嘛与中央政府签订协约，西藏和平解放。
1952年
虚云、圆瑛法师飞锡北京。中国佛教协会筹备处成立，虚云任名誉会长，上书政府，停止撤寺及强迫僧尼还俗。虚云代表中国佛教协会接受锡兰赠送的佛陀舍利、贝叶经、菩提树。丁福保於上海逝世，终年七十九岁，著述颇丰，有《佛学大辞典》等。
1953年
《海潮音》复刊，印顺任社长，续明为主编。虚云在上海启建四十九天水陆道场，祝愿世界和平。中国佛教协会在北京广济寺成立，圆瑛为会长，赵朴初为秘书长。8月圆瑛寂後，由喜饶嘉措任会长，赵朴初为副会长。来果寂於高旻寺，终年七十三岁。灵源应南怀瑾之请，由香港赴台宏扬禅宗。
1954年
印顺《净土新论》，不为弘扬净土者所谅解。台湾当局以印顺《佛法概论》有歪曲佛教教义，隐含“宣传共产主义”之嫌，令各方“严加注意取缔”，经修改後，遂不再追究，而印顺深感自已缺乏“为法殉道”的精神，为“出家以来”“最可耻”、“最伤心”之事，深感内疚。虚云於武汉宝通寺主禅七，随即入江西云居山真如寺。融熙撰《佛教与禅宗》在《海潮音》月刊发表。
1955年
虚云在云居山传戒，限於条件，依《梵纲经》“自誓受戒方便”法、对丘百余众开“方便受戒”之例。高旻寺住持禅慧至香港募化道粮，僧众一百五十二人因寺田充公，日以薄粥维生。珍藏於中国的佛牙送缅甸供信众瞻礼，中国佛教协会在京举行法会，千人出席。
1956年
中国佛教协会对北京房山县云居寺公元七～十二世纪石经进行全面调查、挖掘和拓印。中国佛教代表团赴缅甸参加佛陀涅盘二千五百年纪念活动及第六次佛经结集大会。北京广济寺、雍和宫举行纪念佛陀湼盘诵经法会。缅甸一百多万人朝拜佛牙。印顺任台北善导寺住持。东初中华佛教文化馆落成。中国佛教院在北京广济寺开办，周叔迦为校长。虚云修云居寺殿、楼、房舍。香港宽慧、美国詹励吾、上海吴性栽等自动布施，常住二百多人，一年开垦水田一百八十余亩，收稻谷四万余斤。腊月初七打禅七两周。周祥光博士於印度新德里“佛教对艺术、文学、哲学之贡献讲演会”发表《禅学与理学之研究》一文，印顺《人间佛教》付印流通。中华书局《梁任公佛学研究十八篇》印行，十分畅销。
1957年
中国佛教协会第二届全国代表会在京召开，喜饶嘉措任会长，噶登赛特、应慈、静权、能海、赵朴初、巨赞、周叔迦等任副会长，赵朴初兼任秘书长。赵朴初副会长赴锡兰出席世界佛教徒联谊会理事会议。章嘉圆寂，终年六十九岁。印顺任台湾一同寺女众佛学院院长，後又为男众佛学院导师。中国佛教协会重修北京西郊辽代舍利塔。虚云在云居、云栖、云门、南华、鼓山等寺误遭批判。南京金陵刻经处归中国佛教协会管辖。日中佛教交流恳谈会送回中国殉难者遗骨。
1958年
慈舟法师在京逝世，终年八十岁。蒋维乔於上海病逝，终年八十六岁，著有《中国佛教史》、《佛学概论》等书。峨嵋山僧尼二百三十五人，积极参加植树、种茶等生产劳动。青松(张曼涛)发行《现代佛教文选》获社会好评。苏邦圃编《虚云和尚十难四十八奇》在台中瑞成书局出版。
1959年
中国佛教协会邀请班禅喇嘛在雍和宫主持转经法会，祈祷民族团结、西藏人民新生。虚云禅师圆寂，寿一百二十岁，僧腊一百零一岁。东初倡印《大藏经》功德圆满。胡适撰《记日本“入唐求法”诸僧的目录的南宗资料》、《北宋惟白和尚关於西天祖师偈颂来历及宝林传、圣胄集等书的记载》、《跋宝林传残本七卷》。
1960年
圣严(张本立)依东初法师剃度出家。白圣任台北圆山临济寺住持，及“中国佛教会”理事长。中国佛教研究院开学。台北松山寺佛学研究部针对胡适《中国的传统与未来》一文诋毁佛教进行驳斥。基隆虚云老和尚纪念堂落成，由惠光法师主持，中国和斯里兰卡联合举办中国著名高僧法显抵岛1500周年纪念活动。胡适撰《慧能禅师与诏州广果寺》、《所谓“六祖心偈”的演变》、《全唐文里的禅宗假史料》等论文发表；在“中日韩三国学者会议”开幕词中，希望三国合作研究中日佛教史；还著《续传灯录的作者居顶和尚》，《记宋宝祐刻本五灯会元的刻工》等。周祥光撰《胡适慎言》，批评胡氏“但知有疑，不知有信”，刊《海潮音》。
1961年
中国佛教协会赠款尼泊尔修建“马亨德拉大厦”和“科学大厦”。印顺主持慧日讲堂落成。惠光《禅学问答》、《佛教考证史》、《惠光禅师年谱》在基隆刊行．台湾师范大学举行禅学座谈会。印度政府拨款一百七十二万印币，在比哈省那兰陀建造玄奘大师纪念铜像。韩国曹溪宗大会主席金素文致函世界各国佛教徒，称日本帝国主义统治韩国时，以法会破坏佛制佛戒，使韩僧食肉带妻，现韩国光复，为正佛门，应本弘护本怀，对此类狮虫众以有效声讨，而彰显正义真理。印顺发表《玄奘大师年代之论定》、《佛陀跋陀罗传来的禅门》等论文。胡适撰《金石录里的禅宗传法史料》、《佛法金汤编记朱熹与开善道谦的关系》……《慧宗与灵坦都是神会的弟子吗?》、《跋裴休的唐故圭峰定慧禅师传法碑》、《宗密自记他的圆觉经及后来作疏的始末》、《嵩山会善寺故大德净藏禅师身塔记笔记》、《记李朝正的“重建禅门第一祖菩提达摩大师碑阴文”》、《七修类里的“六祖”》、《虞道园古录四九“晦机禅师塔铭”》等。
1962年
胡适逝世，终年七十二岁。中国佛教协会在广济寺召开第二届全国代表会议，班禅、应慈当选为名誉会长，喜饶嘉措为会长，赵朴初、周叔迦为副会长。台北十普寺三藏学院、临济寺中国佛教研究班举行结夏，师生於院内依律安居静修三个月。道安法师为《狮子吼月刊》复刊撰《上诸山长老书》。香港陆觉昱居士英译《六祖坛经》、《永嘉大师证道歌》及《圆觉经》，由伦敦赖德公司出版。
1963年
《虚云和尚年谱》的编者岑学吕居士病逝，终年八十二岁。英国纽约圣若望大学编制英译中国古典经籍丛书，《六祖坛经》、由陈荣捷教授翻译出版。台北临济护国禅寺为庆祝白圣法师六十寿诞启建千佛大戒。圣严在高雄闭关。中国佛教协会在北京广济寺举行监真法师逝世一千二百周年纪念法会，扬州法净寺建成监真纪念馆。贤顿法师在临济寺筹建戒光佛学院，道安於花莲佛教社讲“宗教与人生”，并解答“因果轮回与众生生死”等问题，於老人福利学会讲“老年人身心修养”，於南普陀佛学院讲“知艰难，守本分”。亚洲十一个国家和地区佛教徒会议在北京召开。弗洛姆(E·Fromm)与铃木大拙合著《禅与心理分析》，从心理学立场探究禅学，将禅学用於心理治疗。
1964年
《现代佛学》停刊，从1950年至今共出一百四十四期。“中国佛教会”第五届理监事会於善导寺召开，道源膺选为理事长。日本佛教界举行“玄奘三藏一千三百周年纪念会”。“中国宗教徒联谊会”在台北善导寺召开。佛教界二百多人在北京法源寺举行纪念玄奘大师逝世一千三百周年大会，台北各界亦举行唐三藏玄奘大师圆寂一千三百年纪念大会。北京全国政协礼堂举行玄奘大师逝世一千三百周年大会，郭沫若、茅盾前往讲演。西安大慈恩寺亦举行大型纪念活动。印度在奈伐奈郎达筹建玄奘大师纪念大厦，墨西哥探勘队於圣罗林校群岛发掘一尊九尺高之石雕佛陀顶像，经考证为二千年前布利土丁克文化遗物。
1965年
高雄寿山寺住持星云创办寿山佛学院开学。印顺法师於嘉羲妙云兰若闭关—年，出关任中国文化学院教授，讲授《佛学概论》，《般若学》。台北阳明山中国文化书院成立佛学研究所。中国佛教协会名誉会长应慈法师於常熟逝世，寿九十三岁。陈铭枢居士於北京病逝，享年七十七岁，著有《我的禅观》、《我的佛法观》等。
1966年 台北临济寺戒光佛学院学僧依制结夏。香港明常在荃湾栖霞新苑，设立“中囯佛教文化研究院”。“文革”浩劫开始，寺院、佛像、经书在“破四旧”声中多被毁坏，不少僧尼被迫还俗或遭迫害。港九“虚云老和尚舍利塔暨永久纪念室”建成。宝松法师偕徒自焚，代众生赎罪，祈祷世界和平，终年七十六岁。南怀瑾《楞伽大义今释》印行。道安於高雄佛教讲堂讲演，题：学佛与做人、佛教之根本思想、佛教之修持方法、中国禅学等。
1967年
台北善导寺举行佛教文化讲座，新加坡义安学院巴壶天讲《禅宗公案之透视》。大虚佛学院於台北慧日讲堂创办，演培任院长。惠光法师於台湾屏东铁炉寺圆寂，终年八十一岁。“中国佛教会”第六届理事会产生，白圣为理事长。白圣任槟城极乐寺住持。善信撰《中国禅宗祖师传》在花莲出版。琉璃经房印道阶法师、喻昧庵所编《新续高僧传》出版。
1968年
道安偕静海、传棨赴曼谷出席“国际佛教高级教育会议”，并访问新加坡、马来西亚、香港。《华冈佛学学报》第—期刊邢光祖《禅与诗画》、印顺《波罗提木叉经集成的研究》、张曼涛《中国佛教的思维发展》。韩国朴性焙《大慧之看话禅对韩国佛教的影响》、吴经熊《禅的起源》、晓云《般若禅》等论文在台北第一届国际华学会议发表。香港卢氏宗亲总会在轩尼诗道创建“六祖大师纪念堂”。熊十力於上海病逝，终年八十四岁，代表作有《新惟识论》。喜饶嘉措在“文革”中受折磨而死，终年八十六岁。
1969年
高雄佛光山东方学院落成，星云主持法会。台湾历史博物馆设中国佛教艺术研究委员会，其中佛教禅宗的绘画及书法，由南怀瑾负责。圣严赴东京大正大学进修硕士学位，善导寺举行佛教文化讲座，钱穆讲“六祖坛经大意”。
1970年
周叔迦在京逝世，终年七十一岁。道安至菲律宾弘法。世界佛教领袖会议在韩国召开，世界佛教徒联盟会成立。复仁编《来果禅师禅七开示录》。
1971年
中国佛教协会副秘书长石鸣坷(芝峰)逝世。日月潭玄奘寺慈恩塔落成。印顺撰《神会与坛经》，妙然撰《禅史、禅学与参禅》等发表。佛光山启建菩萨戒传授法会。赵恒惕居士病逝，年九十三岁，湖南衡山人，曾倡修《中华大藏经》。1972年 《内明》月刊在港由洗尘等共同创办。泰国副僧王颂禄拍江那叨访台北临济寺。高雄宏法寺举办大专佛学夏令营，讲授《般若心经》、《楞严大义》、《禅宗公案》等。圣严译野上俊静五人撰《中国佛教史概说》由台北商务印书馆出版，印海法师译日本曹洞宗禅僧孤峰智灿《中印禅宗史》，由福严精舍出版。
1973年
《海潮音》八月号刊仁化撰《评铃木大拙的禅与生活并论佛教》一文。惟觉於德源寺开办“德源禅学院”，招收男青年习禅。浩霖於纽约唐人街东禅寺举行佛像开光大典。印顺法师获日本大正大学博士学位。台湾慈济功德会募款五十万元赈济东部灾民。
1974年
慈明佛学院院长圣印主讲《禅与净土》。“中国佛教会”选出第八届理监事，星云等九人为常务理事(不选理事长)。心古任凤山禅寺住持。日本横滨鹤见区曹洞宗大本山总持寺以最高礼仪，恭迎“无际禅师”(传为唐代石头希迁)肉身遗体，在大祖堂内供养。第三届亚州佛教徒和平会在德里举行。蒋介石逝世。
1975年
丰子恺居士於上海病逝，终年七十八岁。星云举行佛学讲座，题：《从六祖坛经谈到禅宗教学的特质》、《从金刚经说到般若空性的研究》、《从阿弥陀经说到净土思想的建立》。缅甸菩提迦耶国际禅学中心举行十天的禅会。缅前任总理宇奴是四念处禅的代表人物，三十位从美国、英国、澳洲以及欧洲其他地方来的习禅者，都参加了由慕尼达拉主持的禅会。越南留学生德念在台北师大道学社讲演《中越禅宗史》，说：中国禅、越南禅具艺术性、融和性，印度禅则有神秘性。
1976年
道安在日月潭玄奘寺闭关。圆山临济寺创办临济托儿所。白圣、道安、圣印、心定赴曼谷参加世界佛教徒友谊会第二十五周年纪念会及第十一届大会。林语堂於香港病逝，仁俊应美国麻省工学院佛学社请讲说“佛教之静坐与修定”。毛泽东主席逝世，第四届亚洲佛教徒和平会在东京举行。
1977年
道安法师於台北圆寂，终年七十一岁，戒腊五十二。明乘於大香山观音禅寺闭关三年，燃指供佛，割舌写经。灵根任台北松山寺住持。星云於台北中山堂讲演，题：《从佛教各宗派说到各种修持方法》。东初法师於北投佛教文化馆圆寂，寿七十岁。高雄佛光山开山十周年举行传戒法会。《佛教大藏经》八十二册(包括大正、碛砂、嘉兴三部)出版。
1978年
中国佛教代表团访日。台北“国立历史博物馆”举办明四僧(渐江、八大、石溪、石涛)书画展，为期四十天，展品一百四十件。圣严在中国文化学院哲学所讲《隋唐佛教》，演培受请任美国中国佛学研究院院长。星云在台北国父纪念堂讲演《佛教与生活》，并获美国洛杉矶东方大学荣誉哲学博士学位。成一应罗光主教之请，为讲“禅法”。恒月法师圆寂，寿一百岁，自称为临济第四十二代传人。美国十四位宗教家到高雄寿山法兴禅寺讲习。
1979年
临济黄檗宗日中友好协会成立。星云率佛光山二百人经香港、泰国到印度朝圣。高观如在京逝世。王云五博士病逝。
1980年
日本监真和尚像回中国巡展。日本曹洞宗大本山永平寺副贯首丹羽廉芳一行四十人访台。日本道元禅师得法灵迹碑在宁波天童寺落成。法尊在京圆寂，终年七十九岁。星云任文化大学印度研究所所长。美国西来寺(佛光山别院)佛像开光。唐一玄出版《大佛顶首楞严经自课》、《改正版六组坛经》。《道安法师遗集》由刘国香居士编辑、灵根出版。
1981年
中国佛教协会主办《法音》杂志在京创刊。普雨当选福建省佛协会长。正果当选北京市佛协会长，并往鼓山涌泉寺主持传戒法会。张曼涛居士在日本逝世，曾任文化大学教授，编印《现代佛教学术丛书》百册。中国佛教会举行“佛教思想、三民主义、共产主义学术座谈会”。星云在东海大学讲授《佛教人生哲学》。德愿禅寺招收佛教青年学禅，每届三年。星云佛学讲座每年一度在国父纪念馆举行，题：《从人的过去、现在到未来》，《从心的动态到静态》，《从世界的起源到还灭》。第三届世界僧伽大会在阳明山举行，二十多个国家、地区的代表二千多人出席。《禅门逸书》、《中国佛寺史志汇刊》发行。慈济功德会於花莲建综合医院。
1982年
仁德任安徵省佛协会长。云峰任广东省佛协会长。虚云和尚舍利塔在江西云居山落成。悟明法师应美洛杉矶中美学佛会护国禅寺之请，教授习禅，宣讲《般若心经》。圣严在台北中华佛教居士会讲堂演讲《禅的修证与体验》。
1983年
新加坡佛教总会主席宏船法师一行十六人回大陆探亲。净严任河南省佛协会长。第十四届世界佛教徒联谊会大会在斯里兰卡科伦坡举行。传印、姚长寿从日本佛教大学进修回京。日本友好临黄协会首次遣友外之翼代表团访华。韩国石鼎禅师禅画展在台北新生画廊举行。慧矩杂志社举行虚云、太虚、印光三祖师纪念堂、佛菩萨开光典礼。傅伟勋《胡适、钤木大拙与禅宗真髓》於《中国时报》发表。程榕宁撰《禅的真谛，真空妙有》以记画家陈子斌谈习禅一得。
1984年
湖南省佛协成立，明真任会长。美负时誉的禅学大师卡普尔拜会南怀瑾教授，并发表演讲：《投笔从禅的历史》、《神秘的西方，现实的东方》，《佛学未来的展望》。圣严在哥伦比亚大学演讲《从静坐到禅》。台北普门寺举办星云佛学讲座，题：佛教的教育法、丛林的教育法、特殊的教育法；佛教的女性观、佛教的福寿观、佛教的政治观。圣印在台北中山堂宣讲《佛法与禅道》。韩朴宗哲教授、中研院瞿海源教授访圣严法师。圣严应邀访问美国罗杰斯持市卡氏禅中心，并在哥伦比亚大学讲演《禅佛教的基本理论及其实际修行》。星云主持佛光山十八年後退居，由心平继任住持。圣严在莲花岗“国立中大”礼堂讲演《禅与人生》。
1985年
第—次中日佛教学术会议在日本京都召开。亚洲佛教和平会第七届大会在万象召开。新加坡光明山普觉禅寺住持、新加坡佛教总会会长、世界僧伽联合会副主席宏船法师率观光团访华。
1986年
武汉归元禅寺传戒，三百多人受戒。广钦法师在高雄妙通寺圆寂，世寿九十五岁，僧腊七十五，戒腊五十三。圣印在台北觉明寺宣讲《禅与人生》。圣严在普林斯顿大学演讲《禅在日常生活中》。佛教慈济医院开业。净心在名古屋中国佛教文化交流会第九届大会上演讲《中国佛教的特质——禅》。圣印在屏东举行佛学讲座，题：禅与生活等。世界佛教徒友谊会第十五届大会暨世界佛教青年会第六次大会在尼泊尔召开。成一法师与赵朴初居士在会上相晤。赵朴初会长访问朝鲜。赵会长会见日本曹洞宗庆祝净慈寺大钟落成法会友好访华团。“世宗和”国际理事会议在北京召开，来自三十个国家和地区的一百二十名代表出席。第一届中日佛教学术交流会议在东京举行。
1987年
中国佛教协会第五届全国代表会议在京召开。近三百名代表出席。中国佛教文化研究所在京成立。陕西扶风县法门寺发现四枚佛指舍利和一批唐代珍贵文物。第二次中日佛教学术会议在北京举行。台湾“内政部”统计：台湾地区各宗教信徒五百九十八万，占总人口百分之三十一，佛教三百三十一万，其次为道教、基督教及天主教。寺庙教堂最多的是道教，其次为佛教、基督教、天主教等宗教。星云在高雄普贤寺开讲《六祖坛经》。美国加州万佛城举行水陆大法会，中国大陆僧伽法务团一行七十人和世界各地数百名高僧主持法事，“中国佛教会”理事长悟明任总坛主。圣严主持财团法人中华佛学研究所成立大会。明阳升座主北京广济寺丈席。圣印在台北佛教居士林作《佛法与人生》、《慈悲与忏悔》、《生活的禅味》的讲演。印顺《佛法概论》由中国佛协影印出版。中国佛协云南分会主持鸡足山祝圣寺传戒法会，一千零八人受戒。
1988年
普陀山佛学院在梅福禅院开学，妙善任院长，招收学员三十名。在国内已绝版的福州东禅等觉院《崇宁万寿大藏》、开元寺《毗庐大藏》在日本发现数部，成为国宝。武汉归元寺三百人受戒。浙江首次传戒法会在天台山高明寺举行，四百九十二人受戒。慧律在台湾师范大学作《话禅》的讲演。临济宗五十七代传人、基隆十方大觉禅寺开山灵源法师逝世，终年八十七岁，僧腊五十六，戒腊五十五。南华寺举行受戒仪式，八百多位来自二十三省市及香港、新加坡的僧尼出席。佛光山三万信众举行“回归佛陀的时代”弘法大会，由星云主持。日本首相访问中国，捐款十亿日元(近千万美元)修复敦煌古迹文物。曹洞宗法嗣第四十九世太平佛恩寺住持振贤法师圆寂，寿六十四岁，僧、戒腊三十四。第五届世界僧伽大会和第十六届世界佛教徒联谊会在美国西来寺举行。第三次中日佛教学术会议在东京举行。第二届中日佛教学术交流会议在北京举行。
1989年
闽南佛学院首届本科班四十五名学员毕业。“世宗和”第五届大会在澳大利亚曼纳大学召开。赵会长以“世宗和”十主席之一的名义，和中国宗教代表团一起出席。中国佛协副会长明真法师在北京圆寂，终年八十八岁。中国佛协副会长明阳赴美传戒，一百二十多人受戒。广东南华寺七百多人受戒。明阳任福州西禅寺方丈。“国际禅学会议”在佛光山召开，二百多位高僧、学者出席，主题：《六祖坛经之宗教与文化探讨》。海灯法师在成都华西医科大学逝世，寿八十七岁。大专佛学冬令营在台湾峨嵋道场举行。十世班禅在日喀则圆寂，世寿五十一岁。圣严在嘉义举行佛学讲座：《缘起与无我》，《禅定与般若》。应赵朴初之邀请，星云率中国大陆探亲弘法团七十二人进行为期一个月的弘法探亲活动。白圣法师在临济寺圆寂，世寿八十六岁，僧腊六十八，遗训：“世间名利谁不爱，过分贪求是祸根。举世尽从忙里老，谁人肯向死前修。”著有《学禅方便谭》等。普陀山普洛、法雨、慧济三禅寺礼请妙善为住持。佛教慈济功德会创办的慈济护专开学。圣印在台北中山堂举行讲座：《禅的因缘观》、《禅的生死观》、《禅的念佛观》。临济正宗第四十二世、北投曼陀寺住持德如尼师圆寂，寿六十一岁，僧腊三十八，戒腊三十六。星云赴香港主讲《禅师与禅诗》、《禅心与人心》、《禅道与禅法》。太虚大师百年诞辰国际会议在香港法住学会举行，数十位代表共发表六十篇论文。
1990年
重庆佛学院恢复招生，收学员四十人。甘孜四川藏语佛学院第二届七十多新生入学。洛阳白马寺近千人受戒。河北临济寺举行山门殿落成暨祖师像安座法会，日中友好临黄协会第十次文化团及香港、澳大利亚代表团出席。佛光山丛林学院学术会议讨论“人间佛教”。明阳主编《圆瑛大师年谱》在上海出版。圣严在台中市作“今日佛教”、“明日佛教”、“佛教的特色”、“净土的世界”讲演。山西发现明万历十七年至清顺治十四年(1657)私刻《大藏经》原刻雕板，共六百六十七
函，一千五百九十七种，六千四百三十一卷，残本三十九册，用宣纸折装，保存较为完整。圣严著第五种英文禅书《明镜》在纽约、伦敦出版，开现代中国法师将中国佛教在欧州弘播、落根的先河。圣严还在台北举行讲座：①善与恶——如何建立
正确的价值观念；②情与理——如何处理复杂的人际关系。金陵刻经处重新出版《玄奘大师译撰全集》，纪念奘师圆寂一千三百二十五周年。赵朴初主持镇江江
天禅寺、焦山定慧寺佛殿落成佛像开光庆典。赵县柏林禅寺举行汉白玉释迦佛、观音像安奉开光法会。虚云和尚纪念堂在江西云居山落成。第十七届世界佛教徒联谊会在汉城举行。日本佛教临济宗国泰派礼祖观会团到南岳、广州礼祖。四川宝光寺举行律戒法会，三百六十—人受戒。陕西香积寺举行传戒法会，五百二十八人受戒。第三次中日佛教学术交流会议在东京举行。新加坡普觉禅寺住持、宏船法师圆寂，享年八十四岁。
1991年
台湾中华佛学研究所所长圣严法师率佛教建筑考察团访问北京、山西、甘肃、四川。耕云(李挽)先生率台湾禅学参访团到北京、石家庄进行禅学交流，并向灾区捐赠一万美元，黄金一公斤。韩国佛教曹溪宗知元(辛贞美)法师率团到南华禅寺礼祖。虚云纪念堂在云居山真如寺落成，同时传戒，一千五百人受戒。奉化雪窦山资圣禅寺举行大殿佛像开光暨弥勒殿落成典礼。日本临济宗国泰派第三次友好访华团到南京、苏南、上海礼佛。印顺思想研讨会和思想讲座在台湾师范大学和台北侨光堂、高雄市立图书馆举行。第四届中日佛教学术会议在北京中国社会科学院举行，主题：《十至十四世纪的中国佛教》。

(参考《中国佛教协会成立四十周年纪念文集》、《民国佛教大事年纪》、《中囯近现代佛教人物志》等资料)


附录Ⅲ 本书主要参考书目

附录Ⅲ 本书主要参考书目

新修大正藏1932年版，
大正藏 高楠顺次郎主编 财团法人佛陀教育基金会1990年印本
续藏经 日本藏经院1912年刊行台湾影印本
卍续藏 新文丰编审部 新文丰出版公司1994年版
禅宗全书 蓝吉富主编 文殊文化有限公司1990年版
佛光大藏经·禅经 佛光大藏经编委会 佛光出版社1994年12月版
五灯会元 宋普济撰 中华书局1984年10月版
高僧传合集 梁慧皎、唐道宣、
宋赞宁等撰 上海古籍出版社1991年版
补续高僧传 明明河撰 卍续藏第—三四册
大明高僧传 明如惺撰 大正藏第五十卷
指月录 明瞿汝稷集 卍续藏第143册
续指月录 清聂先编集 台湾新文丰出版公司版
景德传灯录 宋道原撰 禅文化研究所1990年5月版
嘉泰普灯录 宋正受撰 续藏经第二编乙第十套
禅林僧宝传 宋慧洪撰 续藏经第二编乙第十套
联灯会要 宋悟明撰 卍续藏经第136册
禅宗颂古联珠通集 宋法应、元普会集 续藏经第二编第二十套
禅门师资承袭图 唐宗密撰 卍续藏第110册
禅源诸诠集都序 唐宗密撰 大正藏第四十八卷
禅林僧宝传 宋慧洪撰 卍续藏第137册
禅宗思想与历史 张曼涛主编 大乘文化出版社
现代佛教学术丛刊（52）
宗镜录 宋延寿撰 大正藏第四十八卷
历代法宝记 大正藏第五十一卷
佛祖历代通载 元念常撰 大正藏第四十九卷
传法正宗记 宋契嵩编 大正藏第五十一卷
佛祖统纪 宋志磐撰 大正藏第四十九卷
人天眼目 宋智昭撰 续藏经第二辑第十八套
祖堂集 南唐静、筠撰 上海古籍出版社1994年版
禅林宝训 宋宗杲、士珪编
净善重集 大正藏第四十八卷
碧岩录 宋重显、克勤著 大正藏第四十八卷
从容庵录 南宋行秀撰 大正藏第四十八卷
五宗原 明法藏撰 卍续藏第一一四册
五宗救 明潭吉弘忍撰
建中靖国续灯录 宋惟白撰 续藏经乙第二编第九套
文殊说般若经 梁曼陀罗仙译 大正藏第八卷
大盘涅盘经 北凉昙无谶译 大正藏第十二卷
楞伽阿跋多罗宝经 刘宋求那跋陀罗译 金陵刻经处重印同治九年本
楞伽师资记 唐净觉撰 大正藏第八十五卷
妙法莲华经疏 宋竺道生撰 卍续藏第一五O册
百丈清规 元德辉重编 大正藏第四十八卷
荷泽大师神会传 胡适撰
神会和尚遗集 胡适编校 上海亚东图书馆1930年版
神会和尚禅话录 杨曾文编 中华书局1996年版
宗门十规论 五代文益著 卍续藏第110册
古尊宿语录 宋颐藏主集 频伽藏云六
镡津明教大师文集 宋契嵩撰蕴闻编 大正藏第五十二卷
大慧普觉禅师语录 宋宗杲撰 频伽精舍大藏经腾八
五家宗旨纂要 清三山来撰性统编 续藏经第二编第十九套
南岳单传记 清弘储撰 续藏经第二编乙第二十二套
御选语录 清雍正帝编 续藏经第二编第二十四套
无异元来禅师广录 明无异元来撰 弘瀚编 续藏经第二编第三十套
永觉元贤禅师广录 明元贤撰 续藏经第二编第三十套
憨山老人梦游集 明德清憨山撰
清福善等编 江北刻经处本
笑隐䜣禅师语录 元笑隱大䜣撰
廷俊等编 续藏经第二编第二十六套
高峰和尚禅要 元原妙撰 续藏经第二编第二十七套
天目中峰和尚广录 元中峰明本撰
慈寂编 姑苏刻经处本
辟妄救略说 明圜悟著 真启编 续藏经第二编甲第十九套
正法眼藏 宋宗杲撰 卍续藏第118册
正法眼藏随闻记 日本道元撰 大正藏第八十二卷
千岩和尚语录 元元长撰嗣沼录编 明嘉兴大藏经第三十二册
密云禅师语录 明圆悟撰如莹等编 明嘉兴大藏第二十四册
三峰藏和尚语录 明法藏撰 明嘉兴大藏经第十三册
林间录 宋慧洪撰 卍续藏经第一四八册
天厨禁脔 释惠洪著 中华书局上海编辑所1958年影印本
拣磨辨异录 清雍正帝撰 续藏经第二编第十九套
中国哲学史 冯友兰 商务印书馆1936年版
中国通史 范文澜等 人民出版社
中国佛性论 赖永海著 上海人民出版社1988年版
中国哲学史论 山西人民出版社1981年版
胡适说禅 潘平、明立志编 东方出版社1993年版
胡适禅学集 东方出版社
禅学入门 铃木大拙著 三联书店1988年版
中国哲学史新编 冯友兰著
隋唐佛教史稿 汤用彤著 中华书局1982年版
中国禅学思想史 忽滑谷快天著朱謙之译 上海古籍1994年5月版
中国禅宗之历史演变 东初著 现代佛教学术丛刊第52册
佛教史 杜继文主编 中国社会科学出版社1991年版
中国禅宗史 释印顺著 上海书店1992年版
中国佛教史略 释印顺著 妙云集
中国禅宗思想历程 潘桂明著 今日中国出版社1992年版
中国佛学源流略讲 吕澂著 中华书局1979年版
禅师与禅诗 释星云 佛光出版社 1993年6月版
初期禅宗书的研究 日本柳田圣山著 法藏馆1967年版
首届禅宗与中国文化 禅宗与东山法门
国际学术讨论会开幕词 萧萐父 武汉出版社1996年6月
石头宗心性论思想述评 方立天 国学研究丛刊
中国禅宗通史 杜继文著 江苏古籍出版社 1993版
佛教文化百问 何云著 中国建设 1989年版
马祖道一评传 何云著 世界宗教研究 1989．1
敦煌新本六祖坛经 慧能著、杨曾文校 上海古籍出版社1993年版
坛经校释 郭朋编 中华书局 1983年版
冬灰录 释药地著方中通编 见《方以智年谱，安徽教育出版社1983年版
天一阁藏明嘉靖地方志
康熙青原山志略 释笑峰大然编纂 清康熙刊本
云居山志 释燕雷之鹏编纂 清光绪元年(1875)刊本
云居山志 释一诚主修 中国文史出版社1992版
吉安府志 清刘绎编纂 清光绪元年刊本
诸缘公支派谱 清超祥、本明等编纂 嘉庆三年(1798)增订重刻本
禅宗语录辑要 上海古籍出版社1992年版
中国禅学思想研究 何国铨著 文津出版社1987年版
道 张立文主编 中国人民大学1988年版
宋明理学与禅宗 南怀瑾 现代佛教学术丛刊(18)
禅海之筏 陈荣波著 志文出版社1989年版
中国佛学人名辞典 明复编 中华书局1981年版
中国禅宗大全 李淼编著 长春出版社1991年版
禅宗法系谱 樱井秀雄主编 见禅学大辞典1972年版
佛光大辞典 慈怡主编 书目文献出版社影印佛光山1989年版
少林寺与中国文化 徐长青著 中州古籍1993年版
曹溪禅人物志 易行广编 广东人民出版社l994年12月版
船山佛道思想研究 吴立民 徐孙铭著 湖南出版社1992年版
行愿无尽 荆门文史资料第八辑 荆门政协文史委1992年印行
关于禅藏与敦煌籍的若干问题 方广锠 藏外佛教文献第一辑宗教文化出版社1995年版。
黄龙宗史稿 黄君著 未刊稿
黄龙崇恩禅院传灯谱 乾隆刊本(修水县收藏)
山谷全集 黄庭坚撰 江西修水藏辑香堂刊本
黄龙慧南禅师语录 宋慧泉集 大正藏第四十八卷
杨歧方会禅师语录 宋仁勇编 大正藏第四十七卷
圆悟佛果禅师语录 宋绍隆等编 大正藏第四十七卷
佛典精解 陈士强编 上海古籍出版社1993年版
太虚法师年谱 印顺著 宗教文化出版社1995年版
虚云和尚年谱法汇 岑学吕编 台北大乘精舍印经会1986年版
船山全书 王夫之撰 岳麓书社1982～1997年版
游普陀志奇 孙中山 佛教文化1996年第三期
毛泽东与佛教 王兴国著 中国书籍出版社1996年1月版
石头希迁及曹洞禅 王兴国徐孙铭主编 岳麓书社1997年12月版
参禅要旨 释虚云著 香港宝连禅寺1994年重印本
玉佛丈室集 真禅 著 上海社科出版社1992年版
花都法雨 净慧 著 三联书店1994年版
禅门大德管窥记 陈樱宁者
来果禅师语录 上海佛学书局1992年印本
印顺佛学思想研究 郭朋著 中国社会科学出版社1991年版
禅灯世谱 （明）释道忞编 崇桢五年印本复印本吳侗集
巴蜀禅灯录 冯学成等编 巴蜀出版社 1992年版
中囯佛教协会成立40周年纪念文集 净慧主编 中国佛教协会编（1993年）
中朝佛教文化交流史 黄有福、陈景富著 中国社会科学出版社1993年版
当代佛教 杨曾文主编 东方出版社 1993年7月版
佛心宗法脉图(日本) 复印本
海潮音 1928年7月第7期
世界宗教研究 1989年第1期
法音杂志 净慧主编 1982——1990年
禅杂志(河北) 净慧主编 1995年
佛学研究创刊号、第三期 吴立民主编 中国佛教文化研究所编
闽南佛学院学报 1993年第一期
求索杂志(湖南) 1984年第3期
民国佛教大事年纪 台湾
中国近现代佛教人物志 於凌波等编撰 宗教文化出版社


《禅宗宗派源流》书后

  《禅宗宗派源流》书后
    李家振
    一九九六年四月

    《禅宗宗派源流》这篇大文章是中国佛教文化研究所承担的国家“八五”规划社会科学研究课题。一个佛教的团体所属的研究单位承担国家提出科研项目，这是几十年来第一次，这一点确实值得一记。
    作为佛教团体所属的研究所，对于禅的研究自然不是纯学术性的。不过既然是社会科学研究课题，那么也不能单纯强调宗教信仰，而是以学佛者的清净本心，去实事求是地作佛学文章。这种特色是我们定课题时认真思考过的原则，值得一提。
    根据经典所载，灵山会上佛祖拈花、迦叶微笑，从此有了“实相无相，微妙法门，不立文字，教外别传”的禅。达摩西来，在嵩山各二祖慧可传授心印，直到六祖慧能将“东山法门”发扬光大，从此“一花开五叶”，形成一个影响中华遍及世界的禅宗宗派。
    要道出禅宗的真谛，必须抓住“实相无相”这四个字。用般若作为红线贯穿全文，这是我们在确定如何对待这一课题时的设想。
    这里所说贯穿全文的般若，自然是实相般若。实相般若无相，它无所得，无所住，无所取，因而也就无所不得，无所不住，无所不取。
    参禅时常用“看父母未生之前真面目”为话头，这便参到了最清净、最根本的“种子识”上，这是必须体验亲证的。无此体证，所言之禅最多只是“口头禅”、“野狐禅”而已。
    这个要求是我们作为佛教团体所属的研究单位，有别于其它学术研究单位的特色。
    以般若为红线来处理这个题目很不容易，我们都有深重的语言障、文字障，一想到题目，脑海里不是清净的实相，很自然出现的却是一大堆名相！
    我们有语言、文字、真是不幸。可是，幸运的也是有语言文字，禅不可思议，并非不可领悟，只是不可用思考议论的方法去理解，而是要排除意识上的思考议论，还其本来面目，得到真切的体证。这种体证要参悟，但引导人们去体证还是可以用语言文字的，思考议论也是有用的。对我们来说要掌握实相般若，还需要花功夫“研究”。
    著相是我们无法回避的现实。语言文字既是我们的障碍，也是我们赖以生存的条件，我们要做的是破障。
    灵山会上迦叶所以是惟一的微笑者，正因为他是最少执著最重行为的修行者。自他之后禅形成偌大的禅宗宗派，其中传授心法的途径，也仍然有语言、文字，只不过那是破除一般常识，不受概念束缚，引导人在无法“正常”思议时，于“无路可走”中见到清净自性的。大量的禅宗公案，用那样多看似“不近情绪理”的语言，为的便是这个。如以为用常识可解，自然开口便错。
    老子说：“为学日益，为道日损”，这里有一个过程。为了知道禅宗是如何形成的，人们可以在知识上努力追求，在这方面“为学日益”，所得到的是知识。在这过程中去除名相知识的障碍，这是“为道日损”，悟出这里的实相般若，再写出文字来就是文字般若了。“看山是山，看水是水——看山不是山，看水不是水——看山还是山，看水还是水。”
    现出禅宗宗源源流的缘起，循前人参禅悟道之路，探其脉络，展其轨迹，通过缘起的显示去体悟，这对本文的作者与读者们都有用的。作者在思考、表达中悟，希望读者能在阅读与批判中悟。
    我说的这些，是我们的希望。结果如何？看看再说。