引言

    华严经要义
    释惟贤
    （2005年8月27—9月4日讲于上海沉香阁）

    引言

    讲经缘起

    各位师父们、居士们：
    今年适逢 “华严座主” 应慈老法师圆寂四十周年，上海佛教界进行纪念，特别举行纪念法会，包括一系列活动，讲经法会就是活动之一，我应上海佛教协会觉醒法师、观性法师、德育法师之邀有缘参加法会，讲《华严经》的要义，这个因缘很殊胜，非常难得，在此，我对上海佛教界的居士们，还有玉佛寺、沉香阁诸位师父的热情接待，表示衷心的感谢！
    在大乘经典中，《华严经》被称为经中之王，本来《法华经》是经中之王，《华严经》在历史上判为“一乘顿教”，所以一般称为“经王中之王”，由此可见《华严经》的重要性。《华严经》是唐朝实叉难陀尊者翻译过来的，一共八十卷、三十九品，有四万五千颂，过去我们的一些老师父们费了很多心，把《华严经》字数数出来，一共是十兆九万五千四百八十四字，卷帙很浩翰。

    武则天与《华严经》的因缘

    关于这部经，我们应该怀念唐代武则天，武则天曾经在尼庵住过一段时间，对佛教有深切的了解，也有深厚的感情，从入皇宫以后，没有忘记佛教，特别是大乘佛教经典里的《华严经》。
    《华严经》的翻译是在东晋时期，当时翻译的是佛陀跋陀罗，在建康（即今南京）翻译的，那个时候叫《六十华严》，其中的缺点是什么呢？就是卷帙不全，很多内容没有，所以武则天深感遗憾，希望得到全本，后来听说在于阗国，就是现在新疆的西边，叫和田的一个地方，那个地方盛行大乘佛教经典，同时有一个印度尊者实叉难陀，深习大小乘经典，学问很广博。武则天听到以后很高兴，就派人迎请他到当时的洛阳，同时把梵本《华严经》也带到洛阳，带到洛阳以后，就进行翻译，在宫廷中的皇家寺院遍空寺进行翻译，当时参加翻译的还有菩提流支等好几位梵僧。
    在翻译过程中，武则天很重视，翻译完后，武则天亲自题写书名，亲自作序，不久就请法藏法师进宫宣讲《华严经》，法藏法师即是贤首国师，是正式建立华严宗的祖师。
    在翻译和宣讲过程中有几个预兆，当实叉难陀要翻译《华严经》的时候，武则天有个晚上做梦，梦到天降甘露，她起来以后就感觉奇特殊胜；法藏法师开讲《华严经》的时候，讲到华藏世界品，大地六种震动，这种震动不是普通的地震，是吉祥的预兆，动而不受灾，是很好的预兆。这两件事情都是记载在历史里面的，说明这部《华严经》是很殊胜、很希有、很难遇的。
    实叉难陀在翻译完《华严经》以后，又回到和田，后来的唐中宗，就把他请到京都来，但是不幸的是，不久他遇到疫症，是不治之症，就圆寂了。圆寂以后，经过火烧，舌头不烂，有很多舍利子，他的弟子就把他没火化掉的舌头、舍利子，送回于阗建塔供养。所以《华严经》的流传，武则天出了很大力量，我们今天要怀念她。
    《华严经》的大乘境界实际是菩萨、佛的境界。佛当时成道以后，在第二七日为四十一位法身大士讲法，四十一位法身大士：即十住、十行、十回向、十地、等觉。佛就在菩提树下为法身大士讲，所以这是佛的自证境界，菩萨的最高境界，我们今天能够听到这部经，是很大的佛缘。

    听经要存三种心

    在这里我告诉大家，在听经的时候要存三种心，第一个寂灭心，第二个恭敬心，第三个广大心。在本经的《净行品》中，智首菩萨代表大众向文殊菩萨请教“如何发愿”，文殊菩萨的原话是什么呢？他告诉智首菩萨，“若诸菩萨善用其心，则获一切最上胜妙功德”。从这句话中我们就了解到，发菩萨大愿要像文殊菩萨发一百四十一愿一样，首先把心净化下来，要善用其心！不能善用其心，你就不会了解、不会悟入，不会深入法藏，更说不上结合修行！所以要注意这颗心！要善用这颗心！
    在经中注解有譬喻，就好像在大海中行船，行船要顺利，要找到方向，必须要靠舵手，舵手掌握得稳当，看得清方向，才能乘风破浪，达到彼岸。否则，如果舵手忽略了、马虎了，随随便便的，那就危险了，一是可能会触礁，二是可能会翻船，就有生命危险。
    善用其心，掌握其心，就好像大海中航船的舵手一样，一定要掌握稳啊。我们在座的都是学佛的、皈依三宝的，希望你们能够善用其心，保持心灵安静，使它能够安宁，使它能够发菩提心，向上追求，那么我们的人生就不辜负。

    应慈老法师的华严妙行

    沉香阁现在举行“华严法会”，来纪念应慈老法师。应慈老法师在他圆寂以前长期住在沉香阁，在沉香阁弘扬华严教义，讲《华严经》，同时和当时月霞法师办华严大学，培养研究华严的接班人。我在重庆开县的时候，有位慧西老法师，就是研究华严的，在华严大学毕业。重庆的遍空老法师、竺霞老法师，也是研究华严的，慧西老法师当年在重庆南岸大佛寺办华严学校时，他们在里面学《华严经》，遍空老法师现在已经一百多岁了，竺霞老法师已经圆寂了。我就是从那个时候，晓得上海的应慈老法师。
    应慈老法师功德很大，被海内外教徒赞奉为“华严座主”。玉佛寺已经圆寂的真禅老法师，他的亲教师就是应慈老法师。在一九九五年十一月，由真禅法师发起，当时佛教协会高振农居士还在主持会务，组织了一个研究会，就是“应慈老法师佛学思想研讨会”，我当时应邀参加，参加之前，我看了应慈老法师的有关传记和他的一些思想特点，就在会上提出了应慈老法师几点重要思想：一、教宗华严、行在禅那；二、般若不明、万行虚设；三、禅净同源；四、出世而入世的菩萨行。
    我在会上就提了这几点，这是对应慈老法师的华严思想和华严妙行，大概的一个总括，当然没有完全总括到，因为《华严经》精深博大，应慈老法师道高德重，这只是根据我的浅见提出的概括。现在我就把这四点简单解说一下。我们纪念应慈老法师，就要学习他的华严精神，并运用在实际行动上，这是很重要的。

    一、教宗华严，行在禅那

    这说明应慈老法师崇奉的大乘教就是华严教，以华严教为宗，为什么？因为华严教是一乘顿教，其中心内容就是显示如来的一真法界，一真法界就是众生的身心本体，所谓明心见性，性就是指这个，禅宗讲叫本来面目，讲真谛是它，讲法性也是它，讲诸法实相还是它。
    一真法界是直说明真心，我们学佛法，就是要恢复这个真心，明心见性，这中间性与心是有区别的，性就是本来不动的本性；心，即在起心动念的时候叫做心，经过修行去了无明障蔽之后才叫做真心，也就是真性。我们必须要恢复妙明真心，这叫一真法界，就是如来的法身，学佛就要达到这个目的。
    那么，什么叫法界观？就是菩萨的和谐宇宙观，包括一切色法、心法、善法、恶法、无记法，包括这个器世界、有情世界。这个器世界、有情世界能够以如来真心加以融通，就把世间所有矛盾、差别、对立、斗争就融化了，就象如来的心一样：广大、真实、平等、清净。
    这个法界观，也就是和谐宇宙观，就是被真心融通以后，成为菩萨的缘起观，对宇宙的观察，一切缘起法，互相依存，不再相对立，法法相资，法法平等，在众生间，就打成一片，我中有你，你中有我；众人中有我，我就有众人；国家有我，我就有国家；世界有我，我就有世界。这就成为很融洽、和谐、平等的这么一个世界。在这种情况之下，人人学佛法，人人学普贤菩萨，做到真俗圆融、悲智兼运，做到众生无尽，愿行无尽，一直与一真法界相应，完成佛果，这个境界好高大！这是我们学佛人，也希望一切众生应该走的共同道路，只有走这条道路，才能解脱，才能成佛，所以希望大家要了解这个道理。
    现在这个世界，人心混乱，灾难频繁，战争潜伏，充满恐惧，如何转变过来，必须希望人人学菩萨，弘扬《华严经》，现在中国讲建设和谐社会，只有“人人都学菩萨”，才是真正的和谐。达到这个和谐，社会就安宁，国家就繁荣，世界就和平，所以我们要认真学习华严，弘扬华严，在今天的意义很重要。
    “教宗华严、行在禅那”，这就说明，要了解华严，要与一真法界真心相应，要建立法界观，必须在行上用功夫，不能是专讲教义，不能夸夸其谈，谈而无用，说食数宝，必须在行动上，要修习禅观。
    禅那，是印度语，翻译到中国来，叫静虑，静中思维，静就是止，思维是观，修静必须要达到止观双运，关于止观的功用，前人有这么几句话：
    破执著之利斧，
    断情见之钢刀，
    趣菩提之阶梯，
    除烦恼之妙药。
    这四句很重要，为什么要修止观，其功用很大的，就好象利斧一样，很锋利的斧头，可以劈柴，可以砍树，我们是砍什么呢？要把无明执著砍掉，“我执”、“法执”，这个执著是生死根本啊！执著不断，生死就不能解脱。所以说是破执著之利斧，断情见之钢刀。
    什么叫情见？就是由世俗之情、物欲之情，生起来的邪见解，包括五种见：身见、边见、邪见、见取见、戒禁取见。身见，即是我见；边见就是执常、执断，认为世间上是常存的，或者生命消灭了就没有了，成为断灭见，叫做执常、执断；邪见就是诽谤因果，拨无因果，从而毁谤三宝，这是断人善根的；见取见就是执著以上的见解为正见叫见取见；戒禁取见就是一种邪法的修行，过去印度有滚粪坑的外道，现在美国的很多地方有外道集体自杀升天，搞这一套的，就叫戒禁取见。学佛要超尘出俗，超情离见，就要修止观，由止观修慧，证得般若就可以断除。
    “趣菩提之阶梯”，从初发心学佛之后，逐步走上菩提道路，但是难关很多，八风吹动，各种困难都要来，所谓“道高一尺，魔高一丈”，你必须具有定力，没有定力那就退了，堕落了。你能够走上菩提阶梯，一步一步走上去，要靠止观。
    “除烦恼之妙药”，止观是妙药，可以消灭心中烦恼，什么烦恼？贪、嗔、痴、慢、疑、恶见为六个根本烦恼，还有二十个随烦恼。《瑜伽师地论》讲了一百多种烦恼，细细地讲，有八万四千烦恼，形容大大小小的烦恼很多，如果修止观，就可治烦恼病，它就是妙药，有首偈子：
    若能静坐一须臾，
    胜造七宝微妙塔，
    宝塔顷刻化微尘，
    一念静心成正觉。
    这就说明止观很重要。能够静坐短时间哪，都胜过造七宝塔，因为有形的塔很容易破坏，就如我刚才说那个实叉难陀的家乡，后来经过一次灾难，先是经过回族侵入，后来经过天灾，落得城都没有了，什么大小寺院哪，什么塔呀，统统没有了，现在能保留下来的历史都是经过考古学家挖掘出来的一些文物。所以这个物质的东西是靠不住的，都有“成、住、坏、空”，但是我们内心的宝塔呀，你修好了，永远存在，火也烧不倒，水也淹不倒，风也刮不倒，人为也破坏不了，这很重要的，所以“宝塔顷刻化微尘，一念静心成正觉”。宝塔很快就化为微尘，没有了，但一念静心存在的话，相续下去，可以成菩提果，完成正觉。这是刚才我讲的静坐的重要。
    当然这个静坐，大家注意啊，不要学外道那些禅，那种静坐会走火入魔，为什么？我执没有断，烦恼没有除，是非得失的心没有去掉，执著各种相，贪心不除，你修静，一是静不下来，二是容易走火入魔，所以必须修出世禅。
    太虚法师讲到禅，有四个方面：一、安般禅；二、五门禅；三、念佛禅；四、实相禅。安般禅就是修数息观，以数息入静，它专门有套修法的。五门禅是针对你的病根来修，贪心重修不净观，瞋心重修慈悲观，痴心重修因缘观，慢心重修界差别观（观十八界），散乱心重修数息观，这是五门禅。第三是念佛禅，念佛是件好事情啊，念佛入定，就可以得念佛三昧，叫念佛禅。第四实相禅，那就是像须菩提一样，发大心，在修行中观三轮体空，超出一切相，叫实相禅。念佛禅也可以与实相禅相结合，念佛到念而不念，不念而念，离能所相，那叫实相禅。

    二、般若不明、万行虚设

    在六度万行中，般若度是第一，假若你修其他的善行，没有般若为指导就是人天善行，人天小果，还是在轮回中，所以般若很重要。《华严经》是智慧的经典，般若讲缘起性空、缘起性空之智，空就是根本智，缘起是后得智，空就是无漏无分别智，缘起就是无漏有分别智。这个分别不是一般的虚妄分别，而能够善查因果，善识善恶，分清邪正，走正大光明道路，这就是妙有，就是缘起，《华严经》所讲的根本也就是这些。
    由真心融通世出世间，一切万法，不管生物界、自然界、社会界、人类，以真心融通，彼此达到法法相通，法法平等，从真空见妙有，妙有见真空，这是般若的内容，假如不明白这一点，你在行动上没有指南，纵然有一点小善，功德也不大，如果以般若为指导，你能够做福德的事情，修善，那么功德就不可限量。这点《金刚经》已说得很清楚。

    三、禅净同源

    这是中国大乘宗派从唐以来的一个优良传统，中国的丛林、居士团体、佛学社、念佛社，一般都是讲禅净双修，这也是汉传佛教的特点。为什么叫禅净同源呢？尽管两者在修持方法上稍有差别，但是他悟入的大乘境界、达到的佛果是一样的，在修心方面是一样的。
    《楞严经大势至菩萨念佛圆通章》开首第一偈讲：
    都摄六根，
    净念相继，
    入三摩地，
    斯为第一。
    这就是禅净双修的功夫。念佛的人，要使六根不要乱动，先要守根，守根以后就护意。
    “净念相继”，念佛，保持正念，就能够护意，能够守根护意，就能进入禅那境界。
    “入三摩地”，三摩地就是三昧耶，是禅的功夫。什么叫三昧耶呢？三昧耶译为等持、等至，内心达到平等运持，进入轻安的境界，这就是禅宗的功夫。所以禅与净是一致的，历史上各宗各派的祖师，尽管他研究的教义各有发挥，但落实在实际行动上都是念佛参禅，所谓“教研本宗，行在净土”，或者是禅净双修，一直到印光法师，都是这种提法。

    四、出世而入世的菩萨行

    这种行就是大乘菩萨行。《大方广佛华严经》，这个“华”是什么呢？就是莲花，修六度万行的因花，以此因花而庄严佛果。出世而入世的精神，就好象莲花一样，莲花的功德微妙香洁，微妙就是智慧很高，处污泥而不染；香洁，就是品行高，处污泥而不染，但是也不舍污泥，不舍众生。所以华藏世界有净土也有染土，佛菩萨不舍众生，以大悲大愿、出世入世精神，广行六度万行，难行能行，难忍能忍。
    在抗战时期，日本的飞机从上海炸到重庆，在飞机轰炸之下，人民生命财产受到巨大损失，当时我在重庆，才十多岁，我亲眼看到，重庆几乎被炸成一片废墟。就在这种情况之下，佛教徒奋不顾身，组织僧侣救护队，从上海到武汉，武汉到重庆，都组织僧侣救护队，在日本飞机轰炸之下，救护伤亡的军民，死了的、牺牲了的，抬出去安埋；活了的，做医治。僧侣们背起药包，抬起担架，不怕牺牲，这说明佛教徒的无畏精神、慈悲精神。
    有一个乐观法师，他从上海到重庆，就住在慈云寺，发起组织僧侣救护队，抗战结束之后，他写了一本书，叫《奋迅集》来记述这些事情。我在《奋迅集》里看到应慈老法师的一篇序，他很赞扬这种精神，他说：僧侣在平常好好修持，念经拜佛，遇到国家有灾难的时候，应该奋勇站出来救国救民，这就是大无畏精神，这就是狮子奋迅精神！所以叫《奋迅集》嘛。
    应慈老法师在抗战时期，爱国爱教，他本人主讲《仁王护国经》，曾经修建护国息灾法会，这是爱国组织，也是爱护众生的悲心表现。同时在乐观法师的《奋迅集》里，他提出“狮子奋迅精神”，应慈老法师不单是讲经弘法，在实际行动中爱国爱教爱众生，这些都是具体表现。

    从以上这四段，我们就可以看出，应慈老法师研究华严，他的人生观，他的行动，是以华严为指导。以上这些内容作为我讲《华严经》要义的一个引言，也是众缘和合，在沉香阁开讲《华严经》的因缘。


封面

《华严要义》
（惟贤法师 著）
北京三学读书会 敬印
中华佛典宝库 制作
2006年2月20日


封面

    供奉于上海沉香阁的华严三圣，中为毗卢遮那佛，左文殊，右普贤，最前面一排是护法尊天，左大梵天，右帝释天。
    华严三圣即华严经所指华藏世界之三位圣者。(一)毗卢遮那佛，毗卢遮那意为遍一切处。即此自性，又称法身。理智完备，居中位。(二)普贤菩萨，以其居伏道之顶，体性周遍，故称普；断道之后，邻于极圣，故称贤。主理门，位于毗卢遮那佛之右。(三)文殊师利菩萨，文殊师利意为妙德。以其明见佛性，具足法身、般若、解脱三德，不可思议，故称妙德。主智门，立于毗卢遮那佛之左。

四川安岳石窟毗卢佛石刻像（宋代）

四川安岳石窟文殊石刻像（宋代）

法海寺普贤壁画像（明代）


目录

引言
正论
    第一章　华严经宗趣
    第二章　经题略释
    第三章 华严经之传译
    第四章 华严经印度、中国的传承
    第五章　华严经的内容
    第六章　华严经组织
    第七章 华严经精华举例
附录：惟贤法师小传


第一章　华严经宗趣

    正论

    第一章　华严经宗趣

    关于本经之宗趣，我是根据华严宗四祖澄观法师（又叫清凉国师）著的《华严疏钞》来讲的。清凉国师是华严宗的第四代祖师，法师崇拜文殊菩萨，常朝拜五台山，他对《华严经》研究很深。
    曾经有这么一段故事，当《华严经》翻译回来以后，华严宗三祖贤首国师宣讲过，后来澄观法师发心写疏钞，在没有写之前，他就拜佛，拜华严三圣，在拜的时候他就祝愿，希望能够合乎佛心，把这部书顺利完成，求佛加持。当天晚上他做个梦，梦中见到诸佛菩萨充满虚空，一片光明，他就在光明中礼拜诸佛菩萨，同时他捧起那片光呑下去，第二天他的境界就不同，深入悟境，智慧很高，写起来文笔流利，疏钞得以圆满完成。一般研究华严必须要读清凉国师的疏钞。
    华严宗二祖智严法师建立法界观，解释十玄门，清凉国师又建立了十玄门，出入不大，但秩序有点不同，所以智严法师的叫老十玄门，清凉国师的叫新十玄门，内容都差不多，我现在就是根据清凉国师《华严经疏钞》大义进行解释。《华严经》总共八十卷，加上般若三藏里的《普贤行愿品》，就是八十一卷，一共三十九品，文义浩瀚，现在这个法会开讲，只有短短的一个多星期，照文讲没有办法讲完，所以只有提纲来讲，能够顺利地讲完就好，这是我的愿望。

    第一节　宗趣

    澄观大师的注疏里的宗趣讲：“本经宗趣：以明法界缘起，理事因果，不思议为宗；以真俗圆融，悲智兼修，契入一真法界为趣”。

    什么叫法界
    什么叫法界？法界的界一种从性来讲，就是体性，理性；一种从差别事物来讲，就代表各种事相。理性代表真心之体，就是一真法界，如来法身；差别事物，就代表因缘生法。理与事是不能分开的，事是由理来成就的，理因事显，事由理成，所以理中有事，事中有理，这是圆融无碍的。佛教把这个没有分开，有心就有物，有物就有心，心物不二；不像一般的哲学讲心就是主观的心、第六意识的心，讲物，就是自然界的物、物质的物，把心物分开，就有偏见，难免就有矛盾，就有差别。佛法讲心物总合，理事圆融，理代表一真法界，如来真心，他的功德就是广大、真实、平等、清净。
    第一广大，就是不狭隘，佛心广大如虚空。
    第二真实，就是不虚假，没有半点虚假，是怎么样就怎么样，为诸法真实相。
    第三平等，没有差别，一切法平等平等，心性平等平等，因此没有矛盾。
    第四清净，清净就不染污。世间上的事情，随五浊恶世，难免染污。要符合心体就是清净的，纯洁的。所以说到理方面代表佛的心体；说到事方面就是因、缘、果，因缘生法的一切差别事相，这些事相在唯识学来讲是法相，包括色法、心法、善法、恶法、染法、净法，森罗万象。这些法在众生境界来讲，差别重重，矛盾重重，斗争重重，烦恼重重，不说做菩萨，做人都做不好！
    必须以真心融通，做好人，特别是做好菩萨，象佛心一样，都能够存广大心、真实心、平等心、清净心，以这种真心融通世间一切现象：自然现象、人生现象、宇宙现象，就达到消灭差别、平等圆融、和谐无障碍。这种“观”就是菩萨的宇宙观，有这个观，再结合行，什么行呢，普贤菩萨的十大愿行，其中包括六度万行，就可以救苦救难。
    普贤菩萨四无尽，即虚空有尽，众生有尽，众生业有尽，众生烦恼有尽，我的愿才有尽；但是虚空无尽，众生无尽，众生业无尽，众生烦恼无尽，我的愿就不尽！而且念念相续，无有间断；身语意业，无有疲厌！了不起啊！这种愿望，每一念一念，刹那刹那的，都没有间断，在行动上身业、语业，都不疲厌，都不感到疲厌，结合学普贤菩萨这种愿行，就是整个法界观，从理论到实践的内容。所以我说，法界观是什么？就是菩萨圆融的、和谐的宇宙观。能够以此观，就可以达到菩萨愿望，根据愿行，与一真法界相合，得到庄严佛果。

    什么叫做相
    什么叫做相呢？唯识学解释的法相，有三种：第一相貌，第二义相，第三体相。
    第一、相貌。相貌是什么？意识和前五识，同时显示的色尘，显色、形色、表色，是可以看得到的，叫相貌。
    第二、义相。就是第六意识根据印象了解的相，进行思维、分析、判断，引起的影相；同时第七末那识，缘根本识所生的我相，都包括在里面。
    第三、体相。就是一种最单纯实体之感觉，一般称为直觉。完全用于前五识，非第六意识。
    所以法相唯识，对相分析得很微细，比如说这个色，除五根、五尘外还有无表色、法处所摄色，其中又分五种：极略色、极迥色、受所引色、定自在所生色、遍计所生色，都是一般人眼看不到的。有些科学仪器可以验出来，如声波、光波、电波，但有些验不出来，如由定力所产生的色，由受戒产生的色，由执我产生的色，就验不出来。所以佛教讲的色，范围很宽，《心经》中“色即是空，空即是色，色不异空，空不异色”，体现妙有真空，而这个色范围非常广，说明佛教教义精深博大。

    第二节　一佛三菩萨

    你要认识《华严经》的内容，进一步了解《华严经》的宗趣，必须要认识一佛三菩萨，一佛是指毗卢遮那佛，三菩萨是文殊菩萨、普贤菩萨、弥勒菩萨。一般讲是华严三圣，中间是毗卢遮那佛，实际是报身卢舍那佛，左边文殊，右边普贤，这里还提到弥勒，因为在善财童子五十三参以后见弥勒菩萨，登弥勒楼阁，圆成佛果，弥勒菩萨起了关键作用，所以要提到弥勒菩萨。

    毗卢遮那佛
    毗卢遮那佛翻译过来就是光明遍照，这种光明遍照尘沙世界，在经上佛陀没说法而是放光，以放光而说法，不说而说。智慧光明，是如来的法身，以法身为体。

    文殊菩萨
    文殊师利翻译过来叫妙吉祥，以妙智为用，妙智就是普光明智，这种智慧就是根本智、空性智，发出来的就是差别智，只有这个智慧才能够了解、观照如来的心体，了解以后才能真正起信仰，建立正信，所以佛教的信不是一般讲的什么迷信、邪信，而是智慧之信。
    本经六位修行阶梯，第一位就是十信，这是由文殊菩萨的大智建立起来的，在建立正信发菩提心后，接着就要靠普贤万行引导，以普贤行磨炼其心，增进功德。普贤是等觉菩萨，等觉仅次于妙觉。

    普贤菩萨
    什么叫普贤呢？德无不周为普，至善调顺为贤。他的德普于三界九有，他的善是至善调顺，能够调伏一切众生的烦恼心，解决众生一切痛苦，顺成善法，所以叫普贤。
    在文殊的大智之后，结合实际行动，就必须要有普贤之行，普贤十大愿，普贤二千行。在行中，难行能行，难忍能忍，救苦救难，到了功行圆满，就能契入一真法界，圆证佛果，在这个时候，就可以见弥勒，登弥勒楼阁。《入法界品》中，善财童子五十三参以后，就到了弥勒楼阁，见到弥勒。弥勒菩萨是印度语，在中国叫慈氏，是因为他世世生生修慈心定。

    弥勒菩萨
    文殊、弥勒、普贤都是佛的大弟子，弥勒住在兜率陀天内院。兜率陀天内院不象外院，外院是天人境界，内院是菩萨境界，在若干万年之后，他下生在人间，那就是一个人间乐园，也就是人间佛教所讲的人间净土，过去形容什么花果满园、五谷满仓、牛羊遍野,都远远不及这个境界。所以弥勒菩萨，叫做一生补处，只得一生就登入佛果，若干万年之后生在人间，也是龙华三会，在龙华树下说法，广度众生。
    现在一般寺庙里供奉的弥勒菩萨，那是五代时候的化身，叫布袋和尚，大肚子，经常笑嘻嘻的，提着一个布袋募缘，别人骂他、讽刺他，他都不管。打他，他就跑得远远的，心胸广大，面带笑容，代表欢喜吉祥。善财童子经过五十参以后，最后遇到弥勒菩萨，进入楼阁以后见到殊胜境界，契入法界。然后，弥勒菩萨就叫他见文殊菩萨，文殊菩萨又叫他见普贤菩萨，来圆成这部《华严经》一真法界的内容，圆因圆果。

    华严经的精髓
    发心是很重要的，你能够发心而且坚定下去，必然完成正觉，打个譬喻来讲，由上海坐飞机到北京，飞机票买了，登上飞机了，必然要到北京，因果相应嘛。所以善财见文殊菩萨就表示，佛果与最初的信心是相应的，有信心，走上菩提道，必然会完成佛果。文殊菩萨又叫善财童子见普贤，是什么道理呢？必须要结合实际行动，修六度万行，在实际行动中逐步升华，才能证入一真法界，完成佛果。
    《华严经》的要义，讲体用因果，以毗卢法身为体，以文殊菩萨妙智为用，因智起行，普贤菩萨妙行为因，行竟则一生补处弥勒菩萨为果。《华严经》的内容，整个体系以一佛三菩萨就可以说明，这就是《华严经》的精髓，不单有理论，而且要结合行。信解行证是相应的，教理行果也是相应的。佛法在行方面讲信解行证，在理论方面讲教理行果，这是不能分开的。《华严经》八十一卷，不出信解行证，不出教理行果，都是有系统的，研究它必须从这方面着手。应慈老和尚讲的“教宗华严，行在禅那”，而且提出“出世而入世的菩萨行”，都是要注重行动，不注重行动，口说没有意义。

    一念不生全体现
    所谓“初发心时，便成正觉”，大家要好好体会这句话。学佛不要丧失信心，禅宗讲的“狂心顿歇，歇即菩提”，能把那个狂妄心停止下来，你当前就可以证入菩提境界，大地山河，无非菩提境界，有首偈云：
    一念不生全体现，
    六根浮动被云遮。
    什么一念呢？妄念不生，妄念没生起来的时候，万里无云万里天，虚空广大，法界无边。如何一念不生，那就好好持戒，修定。在唯识来讲，要断除遍计执、我执、法执，在《金刚经》来讲，要消除我相、人相、众生相、寿者相、法相、非法相。这个妄念要去掉的，不生这个妄念，就会“全体现”，什么全体现？一真法界的“全体”就现了，像太阳当空，慧日朗照，所以《华严经》有首偈：
    若人欲识佛境界，
    当净其意如虚空，
    远离妄想及诸取，
    令心所向皆无碍。
    这就是“一念不生全体现”，佛的境界。假如你眼耳鼻舌身意动了，随境所转，自己作了环境的奴隶，做不了主，天空就出现乌云，太阳光就不能显现，就受到无明我执障蔽，不能明见心性。所以学佛在念头，念头很要紧，这个念头在眼前来说是一念，时间很短，一念中有九十刹那，一刹那有九百生灭，很微细的呀，就在一念中就有过去现在未来，过去现在未来其中又分过去现在未来，这样一推下去，前前无始，后后无终，时间很长。
    《华严经》里面讲，长劫入短劫，短劫入长劫，一念之间通于过去和未来。我们要保持正念，一般凡夫就是一念之差，起恶因了，就造业，有因必然有果，那就是未来不好。所以一念之间很重要。我特别强调：要守根护意，六道大门守不好，强盗要进来偷，偷你的法身慧命。守根护意，不管禅宗、净土宗，还是其他宗派，都是行持的基本功夫，只有这样，才能解脱。


第二章　经题略释

    本经之经题略释，是根据《华严经》的离世间品提出来的，包括：《大方广佛华严经》的经题的定义、佛以德显示的十身、菩萨在修行中常见到的十佛身。有些人怀疑：为什么《华严经》常讲有恒河沙数的菩萨和佛，真有这么多的佛菩萨吗？殊不知华藏世界，重重无尽，境界不可思议，你能够把尘心转为真心，与一真法界相应，那就是在有形无形间，随时可以见到佛，这个道理，要好好思惟。能够与真心相应，无处不是佛地，无处不是佛身。

    第一节　大方广佛华严经的定义

    从题名就可以知道这部经典的重要意义。经名一是法喻因果并具，二是理智人法兼备，有法有喻，有因有果，有人有法，有理有智，结合起来的。
    什么叫大方广
    什么叫“大方广”？大代表真心之体，方代表真心之相，广代表真心之用。学习经典，如法修持，就可以恢复真心的体、相、用。学佛就是要达到这个目的，这是说明佛证的果。
    “大”，真心之体。佛的真心，就代表如来之性，这个体竖穷三际，横遍十方，光明遍照，无处不在，这是真如之性，无生无灭，超越空间和时间。
    “方”，真心之相。就是方圆正直、万德庄严，包括方正、慈悲、智慧、安隐、清净。庄严，是真心之相，得四无畏妙相庄严。
    “广”，真心之用。就是由真心发挥的妙用，由体显用，能生万法，世出世间一切善因善果，都有真心妙用。
    以如来三身来表示，真心的体就是如来的法身，真心的相就是如来的报身，真心的用就是如来的化身，这都是佛果啊，大方广就是代表佛所证的法。
    什么是佛
    “佛”，佛就是佛陀，佛者觉也，自觉觉他，觉行圆满，这是指的果位的佛。能够证得微妙的心体，微妙的心相，微妙的心用就是佛，由本觉到始觉，由始觉到妙觉，完成佛果，到这时的佛，三觉圆，万德具，具足三身四智、五眼六通。
    佛果的功德是难可思议的，我们要有深切的信仰，要以智慧眼来观察。“信为道源功德母，长养一切诸善根”，对于佛的三身四智，五眼六通，绝不能疑惑。
    “三身”是法、报、化三身。
    “四智”是成所作智、妙观察智、平等性智、大圆镜智。
    “五眼”是肉眼、天眼、法眼、慧眼、佛眼。
    “六通”是神足通、天眼通、天耳通、他心通、宿命通、漏尽通。
    这是佛的功德，佛的果位的不可思议的具足的福德智慧，应该深信不疑。
    什么叫华严
    什么叫“华严”，这是讲因位，指佛在因位之中修菩萨行，即六度万行之因花。
    “华”就是莲花，莲花的功德微妙香洁。微妙，就是甚深奥妙，形容其大智慧；香洁，形容其品德之高，处污泥而不染。所以菩萨行，就是莲花行，具足大悲大智。大智，不着污泥；大悲，处污泥而不染，而且能够喷洒芳香，净化国土。
    菩萨行，就是佛在因位上种的花，以此因花，庄严佛果。因花就是修德，果就是证德。这是个譬喻，指以六度之因花，庄严佛果，就是由修德庄严果德。
    心与性是一体的
    在这里要补充一个问题，讲到心、性，其实心与性是一体的，明心见性。其中又有些区别，一般讲的心是动的，是虚妄的，是有为的，至于讲性，就是真如性、真实性、不生灭性、常住性，是处于静态，而心是处于动态，就象水波一样，水被风吹动，波浪滔天，这是心的作用，妄心的作用。当风平浪静时，水天一色，可以显映森罗万象，智慧明朗，静照万物，这就是性。所以唯识法相讲五位百法，心法八个，心所法五十一个，都包括在这里面，在没成圣位以前，都是这个心，经过修行以后，真心显现，那就是性。
    一真法界，就代表性，这个性，即毗卢遮那佛的性，第一它是众德圆满，由修位到果位所证；第二常住不变，不象有为法，是无为法；第三能够融通身土，就是说佛身有佛土，比如毗卢遮那佛就有华藏世界，阿弥陀佛就有西方世界，药师琉璃光佛就有东方世界，佛身有佛土，既有正报，又有依报，这是毗卢遮那佛的功德显的妙用。在《入法界品》普贤菩萨赞扬佛的功德，有这么几句：
    虚空真如及实际，
    涅槃法性寂灭等，
    唯有如是真实法，
    可以显示于如来。
    这是佛果的功德。“虚空”言其广大；“真如”言其真实不变，如如不动；“实际”就是离相，无相而离相，遣除诸相，《金刚经》讲“离一切相即名诸佛”；“涅槃”就是佛的清净寂灭境界，消除烦恼，断除生死，清净寂灭；“法性”就是遍于一切有情无情，这个法性是普遍的，法性也是客观实际的；“寂灭”，这是涅槃之相。这几个功德，虚空、真如、实际、涅槃、法性等，这种真实法，才可以显示于如来的功德，这是普贤菩萨在《入法界品》赞扬如来的功德。
    另外提到法性，经上有这首偈说明法性的功德：
    法性本寂无诸相，
    犹如虚空不分别。
    超诸取著绝言道，
    真实平等常清净。
    “法性本寂无诸相”，法性本身就是一种寂灭的，远离诸相的，就好象虚空一样，没有虚妄分别，没有能所分别。
    “超诸取著绝言道”，不是象凡夫一样有能取所取——有能取的我、所取的法，这个境界是不可以思议的，是用语言描述不出来的。
    “真实平等常清净”，就是说这是真实不虚妄的，平等无差别的，清净无染污的，这就是法性，这就是如来的真实性。
    所以，“大方广”是所证的法，“佛”是能证的人，“华严”是佛在因位上修的万行因花，大悲大智大愿大行，代表悲智愿行，以这种因花而庄严佛果，有此能修的因才有所证的果。诸佛众生，佛性平等，此“大方广”系三世诸佛所同证，十方菩萨所同修，大千圣众所同尊，法界众生所同具！佛佛同体，佛佛道同！
    佛法讲众生平等，佛性平等，这与崇拜梵天，崇拜上帝，崇拜神我是完全不同的。佛说《华严经》是对菩萨讲的，即四十一位法身大士，但也是给佛灭度以后一切众生——能够发菩提心的、学菩萨的众生，对他们讲的，能够发菩提心、能够修菩萨行，就与佛同等，为什么？因为佛性平等，佛说法是为众生而说，能发心学佛，发了大心，佛是忆念到你的，佛是加持你的。《金刚经》里讲：如来善护念诸菩萨，如来善付嘱诸菩萨。你能发心，如来经常都在念你，在加持你，还要告诉你，如何登上菩萨阶梯，达到果位，佛真是大慈大悲啊！佛恩难报！
    所以，佛说《华严经》，虽然华严境界很广大、很深奥，但是也是为众生讲的，为接引众生而宣说的这部经。
    以上，就是“大、方、广、佛、华严”这几个字的意义。
    什么是经
    “经”，在印度语叫修多罗，翻译成华语是契经。契，就是上契诸佛理，下应众生机，根据众生的根机而说各种法门，佛以一音演说法，众生随类各得解。所以，经是依佛法修持的准则，依佛法修持的典范，依佛法修持的正道。经典就是佛的法身舍利，要尊重经典，供养经典，读诵行持经典，是不可轻慢的。能够如法行持，就是恭敬佛的法身舍利，功德是很大的。

    第二节　以德显示佛的十身

    上面讲了佛的功德大，具足三身四智，五眼六通。以德显示，佛具足十身：第一菩提身，第二愿身，第三化身，第四力持身，第五相好庄严身，第六威势身，第七意生身，第八福德身，第九法身，第十智身，这叫佛的十身，也包括了上面所讲的“法报化”三身。
    融三世显示佛的十身
    第一、菩提身。就是佛在菩提树下睹明星而成正觉，证得了佛果，禅宗神秀讲的“身是菩提树，心如明镜台”，这句话就代表佛果。
    当佛在菩提树下睹明星时，朗然大悟，叹息：“奇哉！大地众生无不具有如来智慧德相，但以妄想执著不能证得”。这时就证菩提身，也就是这时不久就讲《华严经》，发挥他这段话的妙义。
    第二、愿身。这就代表佛的悲愿。佛在三大阿僧祇劫，舍弃了国臣妻子宫舍，舍弃了财产享受，牺牲自己，难行能行，难忍能忍，就基于这个愿力。佛佛同等，十方诸佛都有愿，阿弥陀佛四十八愿，文殊菩萨一百四十一愿，普贤菩萨十大愿，观音菩萨十二大愿，地藏菩萨也发大愿。虚空有尽，我愿无穷，众生度尽，方证菩提。有愿必成。当然这个愿不同普通一般人的愿，普通的愿，为家庭，为名，为利，为金钱，为地位，因此尔诈我虞，你争我夺，这个不是那个愿，是基于大智慧、大悲心，超凡脱俗而发的这个愿。
    第三、化身。佛证了果以后，发挥真心的妙用，本着大悲心，以千百亿化身救苦救难，千江有水千江月，月亮映在各处，江河大海都有月亮，形容佛的化身，你只要静下心来，就可以得到佛的感应，见到如来佛的化身：
    诸佛清凉月，
    常游毕竟空。
    众生心垢尽，
    诸佛影现中。
    有些人说：我没有见到佛，我没有得到感应哪？！你内心的污浊除掉没有？你的邪恶思想除掉没有？你要自问一下，你如真正除掉了污浊，佛的化身可以感应你，加持你。
    第四、力持身。说明佛的力量象金刚一样坚固，住持正法，永久不坏。
    第五、相好庄严身。佛有三十二相八十种好，这只是个形容,其实无量无边地好，赞扬阿弥陀佛：
    阿弥陀佛身金色，相好光明无等伦。
    白毫宛转五须弥，绀目澄清四大海。
    光中化佛无数亿，化菩萨数亦无边。
    这都是佛的相。佛眉间放光，光明遍于整个三千大千世界，《华严经》中，佛一说法就放光，而这个放光代表佛说法，佛是无说而说。
    第六、威势身。代表佛的大雄大力，是有威有势，降伏众魔，而且这一种威势显出来就象天空的月亮，光明焕发，其他星宿的光都显不出来。
    第七、意生身。就是说你只要有诚心，佛就用意生身来加持你，意生身就是一种心意，心心相应，感而遂通，此感彼应。
    第八、福德身。就是说佛的福德很深厚，若大海之浩瀚，渊深无量，广大无量。
    第九、法身。法性微妙，湛然圆满，竖穷三际，横遍十方。
    第十、智身。形容佛的智慧广大，明朗决断，智觉圆满。
    以上就是以佛的德，显示佛的十身。其次从三世来看佛的十身，从佛修因到果位，这十身是：一众生身，二国土身，三业报身，四声闻身，五缘觉身，六菩萨身，七如来身，八智身，九法身，十虚空身。从过去到现在，佛三世所现的身，佛有业报身，但他的业报与众生不同，由悲愿所显，佛也现国土身，佛也现众生身、声闻身、缘觉身、菩萨身，到最后如来身，时间不同，但都是如来所现身。
    处处都是佛地
    为什么经上处处提到三千大千世界，恒河沙数世界，都有佛在说法，都有菩萨围绕？若是你的心坚定信仰三宝，坚定信仰因果，坚定信仰佛菩萨的净土世界，能够具足这种信仰，同时闻熏教法，那么你就在一真法界包摄中，就与佛的真心相应，你就不是一般的众生。尽管是凡夫，你已经在菩萨的因位上，等于受菩萨戒一样，你受了在家菩萨戒，就登入菩萨位，在《华严经》的菩萨阶梯中，就在信位，已经登入十信位！这是不简单的啊！对于这一点，大家一定要自信，要自尊，当你真正了解了这个道理以后，就能明白“处处都是佛地，处处都是佛菩萨”！
    关于放光
    《华严经》是佛成道后第二个七日讲的，共讲了三个七天，共二十一天，在七个地方讲，所以说七处九会，七个地方：菩提场、普光法堂、忉利天宫、夜摩天宫、兜率陀天、他化自在天、重阁讲堂，以后第七、第八会又重新回到普光法堂，一共是七处九会。而且在说法的时候，放光说法，不是他说，一般是菩萨来讲，特别是文殊菩萨、普贤菩萨。其间有两个方面是很殊胜的：一是放光，二是短短时间内以神通力量到天宫，这在普通人来看是不可思议的。
    《华严经》是释迦佛，现身卢舍那佛，对四十一位法身大士讲的，这个境界很高，不是一般凡愚所能了解、所可思议的。但是佛说的经典是为众生讲的，不是只为大菩萨讲，要普度众生、接引众生，不舍弃众生。你只要有信仰，有这个知见，佛不会舍弃你，希望你同大菩萨一样，同他一样，进入华藏世界，进入毗卢道场，佛菩萨就是这个心。
    至于放光，现代科学证明，这已经不是一个很神秘的事情，根据从上世纪五十年代到现代的科学证明：人体有光，地球有光，物体都有光环。我在上世纪五十年代，读苏联科学院院士华西列耶夫，他有一篇报道：说人体可以发光，发出电波，一秒钟之内可以发出一千五百周电波，他当时取了个名称叫“生命电流”。这是五十年代我看到的记载，当时苏联是很“左”的，但苏联科学家很客观。
    在八十年代，我看了一个英国科学院士的报告，提出人体随着生理和心理的不同，力量的强弱不同，光环就不同，有黄色的，有白色的，有红色的。有些静坐的、修气功的光环，都可以看得出来。这在佛家来讲，禅定境界越高，静力越强，光速就越大，而且随着内心的境界，光的颜色也不同。慈悲、和平、仁爱、善良的人，现黄光或白光；心术很坏的小人，他的光是黑漆一团，与妖魔鬼怪为伍，这是可怕的；所以人的心术要正。阿罗汉、菩萨、佛都有禅定的境界，力量强度还是有差别。佛在定中，他比菩萨的境界高，无量劫以前的事都知道，菩萨比罗汉知道得多，光都有所不同。所以说到放光，大家一定不要怀疑。
    神通很平常
    神通其实也是很平常的，中国历史上，晋朝的佛图澄，就有神通，他以神通将杀人不眨眼的暴君石勒降伏了。他念个咒，盆中就生青莲花；在地上画条龙，再念个咒，龙就飞走，把石勒弄得眼花缭乱，这在《晋书》上是有记载的。你说这些记历史的人都是封建迷信吗？他不顾事实吗？中国的史官宁愿不要脑袋，也要记实，秉笔直书！还有宋代的道济和尚，就是一般大家知道的济颠和尚，被叫做神僧。还有现代的虚云老和尚被称作东方神僧，都有些神异事情。所以，《华严经》七处九会，佛在说法时放光，在三个七天之内，走了七处，从人间到天上，天上转人间，这没有神通不行的，这并不为怪。

    第三节　菩萨常见之十佛身

    根据《华严经》的离世间品，是说明菩萨修行中常见的十佛身。能够修菩萨行，常行利益众生的事业，在十法中能够安住，就可以常见十佛，以十法见十佛。
    十法见十佛
    第一叫成正觉佛。修菩萨因，求菩提果，但是对于菩提果应无所住，因为其广大高深，若有所住，不成菩提，若能无所住，就叫做成正觉佛，无所住就与佛相应。
    第二、愿佛。你能够学菩萨，发悲愿，大慈大悲大愿，你就可以见到愿佛。正觉佛、愿佛，尽虚空遍法界，随时可以见到，就看你是不是住于正觉，是不是发悲愿。
    第三、业报佛。就说你能够信仰三世因果，相信业力不灭，造业有报，能够对此生起信仰就见到业报佛，实际上都在一真法界中，这是正念正信，这个力量很大，不要轻视。
    第四、住持佛。对佛法生起正念，希望佛法常住世间，随顺于佛法学习，希望正法久住，你就见到住持佛。
    第五、涅槃佛。对于涅槃，佛的果报，涅槃境界，清净平等这种境界，你能够深入深信，特别是佛菩萨的大涅槃，无住涅槃，你能深入深信就见到涅槃佛。
    第六、法界佛。你的真心像佛的真心一样，内心清净，对于事事物物都能以清净心对待，不染污，不执著，真心遍于法界，能如此就见到法界佛。
    第七、心佛。何为心佛，你内心安住，安住于什么？应无所住而生其心，对内不起妄念，对外不追求六尘境界，保持真心，内心就得到安住，这种叫心佛。禅宗二祖慧可求达摩祖师，求达摩赐法，什么法呢，他认为心没有安，安住不了，求达摩祖师给他安心，达摩祖师说“那你把心拿来我看看”。这是为何？二祖慧可心有执著，执著内、执著外、执著相，所以达摩祖师说“你把心拿来我看看”，他东找西找找不到这颗心，二祖说：师父啊！我觅心了不可得！达摩祖师说：好！我给你安上了！心是不容易安的，所以安住于心就叫心佛。
    第八、三昧佛。三昧就是定力，修定而不执著定，这个定很多的，而定力也是了不起的，能够八风吹不动，能够修定而不着定，定力深厚就可以见到三昧佛。
    第九、本性佛。就达到明心见性了，把内心尘埃消除，烦恼无明消尽，就象天空乌云除掉，明月显现，就见到本性，当你开悟时，根本智出现时，无能所，本智一如，这时就见本性。
    第十、随乐佛。能够普遍地随顺众生，随众生根基而感化之、教化之，就见到随乐佛。
    随时都可见到佛
    从以上内容可知，其实随时都可见到佛，在于心如何安法，起什么见，起什么信，起什么行，能够安往此十法，就可以见到十佛，而且无所处而非佛，安住十法，就常见十佛。《梵天思益经》有首偈子：
    诸法因缘生，故无有定性。
    若知是因缘，则达法实相。
    若知法实相，则能知空相。
    若知空相者，则为见导师。
    能够了解缘起性空，就可以见到佛，须菩提在深山修行，修空观，就见到如来法身。当佛在忉利天宫为母说完法，下来时，很多宰官、居士、比丘、比丘尼都去见他，有个莲花色比丘尼，现转轮王身去接佛，她先见到佛很高兴，佛就微笑说：不是你先见到我，是须菩提先见到我。《金刚经》上讲：若以色见我，以音声求我，是人行邪道，不能见如来。所以你能够修缘起，修空观，可以见到佛，就与佛的法身相应。宋代苏东坡，据说他是戒演禅师转世，他的诗文带禅意，有很多诗形容佛境，有一首：
    溪声尽是广长舌，
    山色无非清净身。
    夜来八万四千偈，
    他日如何举示人。
    溪沟里的水，潺潺地流，哗哗地响，就象佛的广长舌一样，在佛法来讲，显示了一切无常。一切无常是佛教的根本教义，无常故苦，苦故空，空故无我，流水之声，长江大河之声，都是广长舌之音。
    “山色无非清净身”，你能够具足真空见，具足般若慧，在山上反映的太阳光，光明遍照，就是如来的法身，可以当境见空。
    “夜来八万四千偈，他日如何举示人”，他晚上悟到这个境界，即是如来说的八万四千偈，内容多得很，但是我说不出来，别人又不懂，不可思议。他还有首诗：
    横看成岭侧成峰，
    远近高低各不同。
    不识庐山真面目，
    只缘身在此山中。
    你在庐山里面看庐山，你只看到高高低低的山峰，至于庐山整体的形式是怎样，就看不清楚。这就是说我们人啊，若有主观的执著，那么，事物的真理、法界的真理，你就悟不了，本来面目也认识不到，那的确就是“不识庐山真面目，只缘身在此山中”。
    苏东坡类似的诗比较多，他的诗与词，均带禅意。一般带哲理的文艺也有这种描写：从一朵花知春天，从一滴水知大海；一花一世界，一叶一如来。这个境界就是华严境界，一朵花就牵涉无尽缘起，他不是孤立的，成为一朵花，需要时间、水份、土壤、人工，要有各种缘，而这个缘又有各种缘，缘缘无尽。从一朵叶子了解其性空，就可以见如来。
    复次，从缘起，我们可以了解，器世界从微尘能见到三千大千世界，从有情世界就可以了解三界五趣、四生六道、胎卵湿化。从空性来讲，了解其性空的道理，就可以见到诸佛如来，见到佛国佛土，这是华严妙境，这必须要经过修行，修禅定，从实际行动中才能悟入。这就是《华严经》的境界。
    一心通十法界
    《华严经》讲十法界，中间一个心，在圈圈以内，就是四圣六凡，一心通十法界，就看你是什么心，假如合乎佛的心，觉悟的心，那就是佛界。假如是慈悲心就是菩萨界。假如能够了解四谛的道理，晓得世出世间的因果，就证入声闻界。能够了解十二缘起的生灭门和流转门，就可以证入缘觉界。这就是四圣。
    反之，你修普通善行，五戒十善，就是人界、天界。虽然修，有福而无德，嗔心重，那就是修罗界。行十恶业，杀、盗、淫、妄，说妄语、粗恶话、离间话、破坏话，内心贪嗔痴重，就是三恶道，上品地狱，中品饿鬼，下品畜生。就看你生什么心，而这个心就在一念之间就可以体现。
    天台宗智者大师讲“一念三千”，就从十法界分析出来，十法界每一界有十，成百法界，百法界每一界有十如，有其性，有其体，有其相，有其力，有其用，有其因缘果报，这几种都含有佛性，本末究竟，这叫做十如。百法界每一界有十如叫百界千如，百界千如再分析开，五蕴世界、众生世界、国土世界各一千，称一念三千。所以念头不要乱起，一个念头通过去，通现在，通未来，前前无始，后后无终，你现在起什么念头，由这个念表现于行动，将来就有什么结果，所以说要知你的过去就看你的现在，要知你的未来也看你的现在，当前一念相当重要，学佛的人要修禅定，修禅定就要保持正念，正念相续就是正定，有定力就不怕六尘境界、八风吹动。


第三章 华严经之传译

    经典结集

    佛在世时说经典，并没有文字记载，但是当时听经的，在声闻乘中，千二百五十人俱，其中有十大弟子：阿难、迦叶、目犍连、舍利佛、阿耨楼陀、难陀、富楼那等等。在菩萨众中有文殊、弥勒、普贤等等，有天龙八部、人非人等，佛说法的法会规模很大。尽管当时没有记载，但是在佛灭度后，大弟子们就将佛教经典的流传作为第一件大事。
    佛入涅槃，火化以后，八国国王将舍利子分开修塔供养，就在此时，迦叶、阿难就提出对佛说的经、律、论三藏要进行结集，最初结集就在王舍城外的七叶窟，以迦叶尊者为上首，由阿难诵经，优波离诵戒，富楼那诵论，这是窟内结集的经律论三藏，经典如《阿含经》等等，这是原始佛教经典也叫小乘经典。另外，还有窟外大众部的结集，系大乘经典，大众部结集的一般是大乘经典。大众部以外，根据历史的记载，还有文殊菩萨和阿难结集大乘经典。
    文殊菩萨是实有其人，据历史记载，佛入涅槃以后四百年间文殊菩萨都还在，这个时间不短哪。文殊菩萨和阿难结集大乘经典，其中包括《华严经》，是有事实的根据。结集不止一次，一共是四次结集，包括在斯里兰卡也有一次结集，所以藏经很多，有八千多卷，新编藏经二万三千多卷，当然新编的藏经把后来历史的著述都加进去了，这是基本的藏经内容，包括显教、密教、大乘教、小乘教等经律论三藏。经过多次结集，传到中国以后，又经过历代的祖师，特别是两晋到唐朝以后，不断的翻译，费了很多人力，好多心血，才有经典的存在。

    龙树菩萨取华严

    佛灭度后六百年间，龙树菩萨出世，专门弘扬般若，其实，他不单弘扬般若，其他宗派都弘扬，称为八宗祖师。根据《华严经传》的记载，龙树菩萨在大龙菩萨的指引下，到了娑伽罗龙宫，在龙宫中见到《华严经》，分为上、中、下三部，其中上部、中部特别多，卷轶浩繁，只有下部卷轶少一点，适于在人间流传，所以龙树菩萨就带出来，开始在印度流传，为解释《华严经》的十住品，还写了一部书，叫做《十住毗婆沙论》，一共十七卷。
    龙树菩萨又叫龙猛，为何姓龙，因为种族是龙族，为何叫树呢，是母亲在树下生出来的，生下来以后很不平凡，学问广博，特别不同的是他还学神仙术、具有神通。他的传记上记载：他有隐身法，隐身法一使，任何人看不见他。但那时他是外道，没学佛以前，就有些不正当，他伙同其他道徒混入国王宫中，对宫女进行淫乱，后来被发现，尽管他能隐身，但王宫宫门一关，御林军步步为营，抡刀乱砍，其他的道徒都被杀了，龙树虽然聪明，躲过了这场杀戮，但受到了很大的惊吓，此事让他铭记于心。
    他这时才开始有点觉悟，知欲为苦本。五欲境界是痛苦的根本，是流转生死的根本，乐是苦因，贪恋五欲就把自己送入苦海中，堕入深渊中，特别是流入生死苦海中，轮转不息。大家想想，现在社会上，就是这么一回事，唱歌跳舞，跳得妻离子散，赌博打牌吃吗啡，也是弄得家破人亡！乐为苦本啊！龙树菩萨因此生起出离心，皈依三宝，并经明师指点学习经论，弘扬大乘，后来还带了很多弟子。

    佛陀跋陀罗译六十华严

    第一位把《华严经》首先弘传在世间的是龙树菩萨；第二位就是东晋时候的西域僧人佛陀跋陀罗，翻译成华语叫觉贤，这个高僧博学群经，特别精专禅教、戒律，其他大乘论藏都懂。
    佛陀跋陀罗先到了长安，那时鸠摩罗什还在长安。鸠摩罗什也是一个译经家，但是佛陀跋陀罗在长安与鸠摩罗什一派的见解不合。鸠摩罗什讲般若，而佛陀跋陀罗偏于讲华严，讲法界观，这两种见解就有些差别，佛陀跋陀罗提出来“一微空故众微空，众微空故一微空”，此观点提出来以后，鸠摩罗什都弄不清楚，觉得很怪：中观讲一切皆空，诸法皆空，还分什么一微空，众微空？殊不知华严法界观就从“一个真心，涉诸事相，建立缘起”这方面来讲的，其义理是一致的，特别突出讲事事无碍法界，从事相方面来分析，从缘起法来分析，这就比较宽广。由于见解有点不合，佛陀跋陀罗受排斥，后来他就离开长安，到了江西庐山，在庐山住了一段时间，翻译了很多经典，当时被誉称为庐山十八高贤之一，现今庐山还存有他的译经台。
    晋朝义熙十一年，佛陀跋陀罗又到了建康，就是现在的南京，在南京道场寺，与法显法师（历史上出名的翻译家，到过斯里兰卡，写出《天竺求法记》），合译关于戒律方面的《摩诃僧祇律》，还有《大般涅槃经》，就在这期间，他翻译了《大方广佛华严经》六十卷。

    实叉难陀译八十华严

    在唐代，武则天海圣元年，由于武后的启请，为何当时武后还要启请呢？因为六十华严还不全，后面几卷没有，听说于阗有实叉难陀，他是研究华严的，很有学问，那里有《华严经》的全本，所以武则天就派人去迎请实叉难陀。实叉难陀翻译成中文叫学喜，他被请到当时的东都洛阳，在东都洛阳的皇家寺院遍空寺，同其他的高僧一起，译出《华严经》八十卷，比六十卷多，八十卷是三十九品，四万五千偈。在译的过程中，武则天亲自到译场关心，译成后，亲自题写书名，写序言，今天法会上唱的开经偈“无上甚深微妙法，百千万劫难遭遇，我今见闻得受持，愿解如来真实义”，据说就是武则天当时写的。《华严经》译成以后就在皇宫中弘讲。后来实叉难陀又回到于阗，唐中宗又把他迎请回来，不久他就得病圆寂了，火化后舌头火烧不烂，有很多舍利子，他的弟子又把舍利送回于阗修塔供养。

    般若三藏译普贤行愿品

    唐德宗贞元十二年，印度到中国来的高僧般若三藏，般若是智慧的意思，又在长安崇福寺翻译出《华严经》四十卷，这四十卷《华严经》是普贤行愿品的广本，又译成了《华严经入不思议解脱境界普贤行愿品》略本，将略本附在八十华严以后，是八十一卷，一般单行本是《普贤行愿品》。
    以上从龙树到佛陀跋陀罗、实叉难陀、般若三藏，就是《华严经》译传到中国的经过。


第四章 华严经印度、中国的传承

    马鸣菩萨的起信论

    《华严经》在印度、中国的传承，是指师资之传承，首先从印度来讲，印度有马鸣、龙树、世亲，是很著名的几个人。
    马鸣菩萨生于佛灭度后五百年，接近龙树菩萨的时间，为何说马鸣菩萨是传承《华严经》思想的？因为马鸣菩萨讲“唯心缘起”，他写了《起信论》，这个人很聪明，会写诗歌，当时在印度被称为诗人，他的诗歌是赞扬佛陀的功德，名《佛所行赞经》。他还写了很多著作，印度古代文学关于诗方面有他的记载。
    他为何叫马鸣呢？据说他在说法的时候，听众很多，他门前系的马，由于他辨才无碍，说法很感动人，不仅人听了感动，马听法以后也大声鸣叫，表示高兴，所以叫马鸣。当然，类似于这样的事情也不是很稀奇，比如明代莲池大师读《法华经》，连蜈蚣都听他读经。虚云法师说法，猴子老虎都听他说法，这些事情并不奇怪，因为生物都有灵性，只是嘴说不出来，佛法讲一切众生都有佛性，不过是受业力束缚，不自由而已。
    马鸣菩萨写了一个很著名的著作叫《起信论》，就是要启发大家对大乘经典的信仰，《起信论》中讲三心，学佛要有三心，学菩萨也要有三心：第一真实心，真实心就是佛心；第二深心，就是合乎一切善法的心；第三广大心，就是慈悲心。心能生万法，但众生境界由于被无明障蔽，就在生灭中流转，假如去掉无明，就可以证得真如，所以他的论分为二门，一是心生灭门，二是心真如门。
    心生灭门就是讲流转过程，内容就象十二因缘一样，它是讲三细六粗。三细六粗包括有烦恼，有行动，有苦果。
    心真如门讲如何转入心净的境界，建立信仰，与真如相应，一直成佛。《起信论》在民国以来有争论，有些日本人，和支那内学院，根据历史进化论来考古，说大乘经典非佛说，包括《起信论》不是马鸣写的，来提出论战。过去在武昌佛学院、内学院，还有很多居士也卷入这场论争中，搞得轰轰烈烈。论点是：马鸣菩萨在《起信论》中讲到：“真如熏无明，无明熏真如”，提出论难说：真如是常住不灭的，不生不灭的，如何熏？如何受熏呢，这句话在唯识学讲不通，所以绝对不是马鸣菩萨讲的，是假造的。
    后来太虚法师站出来，提出《起信论》是马鸣菩萨写的，起信论的论点还是合乎唯识法相的。太虚法师根据三自性来解释，唯识讲：五法三自性，八识二无我。三自性代表诸法现象，世出世间法都包括在其中，第一个遍计自性，那是一般众生因我、我所执，周遍计度而产生的，那是没有的，是虚妄的；第二依他起性，就是一切法待众缘生，因缘生法，这些事事物物，千差万别，是存在的，但是假名存在，如幻存在，不是实的；第三圆成实，就是真如境界，圆满成就真实，圆满说明他的法性周遍一切，成就说明法性常住不变，实就是真实，真实不虚的客观存在，所以叫圆成实。
    至于说“真如无明相熏”，那个真如就是唯识讲的如来藏，阿赖耶识是凡夫境界的，具染污性，但是阿赖耶识中藏有如来性叫如来藏，在众生境界名阿赖耶识，属于依他起，因缘生法，因缘生法有染有净，有染法熏习，有净法熏习，染法就是虚妄的，带我、我所执的，成为染污的阿赖耶。也有净法熏习，譬如你听闻经典，走入佛道，受戒，勤修戒定慧，这是净法熏习，这个净法就包含在真如里面，唯识法相讲十真如，其中就包括这些，受戒叫最胜真如，了解空性叫遍行真如，所以马鸣菩萨说的“真如受熏”是“在缠真如”，“无明熏真如”是“在缠真如”，是在烦恼掩盖之下的真如，也就是说的如来藏。
    至于说“真如熏无明”，那个真如就是净法的、善法的熏习，受戒、修定、了解空性，这也是真如。根据这个结论，太虚法师断定这是马鸣菩萨写的。太虚法师提出：对佛教研究，不能仅从世间上的眼光，凭进化论、考据论来认识佛法，这些看法是把佛菩萨的境界——禅定、神通什么的都否定了。
    我认为太虚法师是有正见的，可以说今天还有一部分人有这些观点，我在这里专门提一下。太虚法师讲：佛的大乘经境界，不管小乘大乘，都是佛的自证境界，这个自证境界超越空间时间，不是一般的意识想得到的，一般意识，一般言论根本就不能说出来，不能代表出来，也想不到。那样来研究佛法就说不出其特点，说不出其尊贵，今天应该坚持这点。
    九十年代复旦大学的教授王雷泉，他有一篇文章题目是《不愿成佛作祖的出家不是真正的出家》，教授对佛法是很有研究的，出家不想成佛做祖，出什么家？也可以说，你学佛就应该信仰三宝，你不信仰三宝，不想学菩萨成佛，你皈依什么？！这是个根本问题，希望大家能够引起注意。
    以上就是我介绍的马鸣菩萨，他是华严教法开始的传授者，他讲唯心缘起，这与《华严经》意趣相合。

    龙树写十住毗婆沙论

    第二讲龙树。龙树生于佛灭度后六百年间，被尊称为八宗祖师。他为解释《大般若经》写有《大智度论》一百卷，为解释《华严经》的十住品写有《十住毗婆沙论》，在《十住毗婆沙论》中，他宣扬“一切唯心造”的道理。尽管他弘扬空宗，关于“三界唯心，万法唯识”，他也提倡。在这部书中，他特别提出难行道、易行道，易行道就是往生西方，难行道就是根据菩萨阶梯，三大阿僧祇劫修行，这比较难，因此也推崇净土法门的易行道。

    世亲菩萨回小向大写十地经论

    第三个世亲。世亲菩萨又叫天亲菩萨，生于佛灭度后八百到九百年间，是无著菩萨的弟弟，两弟兄都出家。世亲菩萨先学小乘，弘扬小乘经典，为了解释《阿含经》写了一部最著名的《俱舍论》。他当时弘扬小乘，诽谤大乘，而他的哥哥无著菩萨与他相反，学的是大乘，无著菩萨为了把世亲菩萨感化过来，有一次故意装病，叫世亲菩萨来看他，由于兄弟之间的感情，世亲菩萨就赶来，到后，他问无著害什么病，无著说我为你害病，你诽谤大乘，罪过大，不要诽谤啊，诽谤堕地狱，而且堕无间地狱。这样世亲就开始警惕起来。
    章太炎去阴间判案
    “若人不造无间业，莫谤如来正法轮”，如果想不堕地狱，首先不要谤如来的正法。地狱是客观存在的。你以为没有地狱吗？过去有个国学大师叫章太炎，他有一段亲身经历地狱的故事。
    章太炎是很出名的啊，讲学、写文章，还有很多弟子，有一次晚上梦见一乘轿子来接他，接到哪里呢？接到阴间去，干什么呢？让他判案。因为章太炎很正直，他不怕权势，连袁世凯都不怕，袁世凯把他囚禁起来，他每天写字，写“袁贼袁贼”，骂袁世凯，不怕杀头，后来袁世凯很恭敬他，就把他放了，就是这么一个正直的人。
    每晚他到阴间地狱去判案，久而久之觉得疲倦，怎么得了：白天要写文章，要教弟子，晚上要到阴间！？这件事他就向印光法师汇报了，印光法师说可以解决，你多念金刚经，不要间断。他如法奉行，后来不久就没有了，杜绝了这件事。这件事情当时上海的《佛法日报》都登载了，你能说地狱没有吗？就看你造不造这个因，你若造了这个因，等于刑事犯罪分子一样，到时间就得被判刑。
    所以在这里，无著菩萨就警惕世亲菩萨不要再造这个因——诽谤大乘经典，否则会堕地狱。世亲菩萨就害怕起来，就想割舌头悔过，无著菩萨告诉他，你不要割舌头，你那个舌头弘扬小乘，可以转过来回小向大，专门弘扬大乘。在那个时候，无著菩萨叫世亲菩萨读诵《华严经十地品》，他觉得那个境界很高，很高兴，就坚决回转过来，弘扬大乘。他转学大乘后，写了《十地经论》十二卷，提出“三界皆虚妄，唯是一心作”，与《华严经》讲的“三界唯心，万法唯识”相合，从此就开始弘扬大乘，写了唯识方面的很多著作，小乘、大乘著作上千篇，所以被尊称为“千部论师”。
    以上所讲马鸣、龙树、世亲，他们都是传承《华严经》思想的。

    正法住世的标准

    太虚大师讲：佛法弘扬本在僧。在现代就需要大批弘扬佛法的人，要有一批杰出的、能够住持正法的僧人，既能管理寺庙，又能弘扬佛法，居士里面也需要培养接班人，都要提高素质，才能好好护持正法。尽管现在是末法时代，实际上这没有一定的标准。据历史的传说正法是五百年，像法一千年，末法一万年，但根据佛说的标准，只要是有教法、有证法住世，都算是正法。只要有人修行、有人讲经、有人学，正法就住世。
    华严宗的思想与传承，在中国是从东晋到唐代这段时间，为五祖相承，历史上最突出的是在唐代，以后虽然历代都有，但是讲教理的较少，禅宗、净土宗比较盛行，直到民国初年以后才逐渐复兴。华严宗在中国的五祖为：杜顺大师、智俨大师、法藏大师（贤首国师）、澄观大师（清凉国师）、圭峰大师（宗密大师）。

    杜顺大师

    第一位杜顺大师，杜顺的法名叫法顺，杜是他的姓，一般喊惯了，喊杜顺。他生在南朝的最后一代，陈武帝永定元年，出生在甘肃的永州。因为当时佛法很盛行，他小时候就受佛法的熏陶，礼佛啊，拜佛啊，象现在的一些小孩一样。最特异的是，他经常将一批小孩子聚集在坟山上，他就坐在中间讲法。稍大，他读书，博通儒家经论，很有才华，十八岁出家。出家以后，由于他历年的修行有一定的功夫，一般人叫他敦煌菩萨，就是因为他有些奇异的行迹，比如把疯子治愈了，把最凶恶的人调伏了，把聋哑盲人治愈转好，有个地方虫子为害，他把虫移走了，诸如此类的神奇事情。
    唐太宗有一次生病怎么也治不好，御医想尽了办法都治不好，就问他，请他治，他说：皇上啊，你最好是大赦天下！因为唐太宗南征北讨杀了很多人，这是冤业病。唐太宗就听他的话，大赦天下，并做了很多法事，超度亡灵，不久唐太宗的病就好了，对他很感谢，听他讲法也合他的心，就赐他法号“帝心”，即深合“皇帝”心之意。
    他一生志在读《华严经》，行在普贤行愿。根据他修学《华严经》的心得，建立了法界三观，又叫三门：真空门、理事无碍门、周遍含融门。这三门发展到后来，到四祖澄观法师成为四法界。
    真空门主要是扫荡妄情执着，消灭我、法二执，证悟我空、法空，也就是真心的境界，真如的境界。
    理事无碍门，就是说心与事物是融通的，不能分开的，理中有事，事中有理，宇宙事事物物，千差万别，都是通于理，都离不开心叫理事无碍。
    周遍含融门，就是说真心遍于法界，事事物物，大至山河，小至微尘，无不没有真心，了解这个道理，在事物中就可以破除差别，圆融无碍，行住坐卧，言谈举止都在道中，这个境界很广大的，所以叫周遍含融。
    华严的法界观就是杜顺法师开始发扬起来的，叫三门，后来又叫三观，发展到澄观大师，建立起四种法界观。而以周遍含融建立事事无碍法界观，六相、十玄都是解释事事无碍法界观。杜顺法师一共活了八十四岁。

    智俨大师

    第二是智俨大师，生于西元六零六年到六六八年，唐代初年。他生平读《华严》学《华严》，作《搜玄记》，发明十种玄门，另外以六相融释之。他有一次在梦中见到一个印度高僧（梵僧），对他说：你把《华严经十地品》好好读一下，其中有解释六相的，你将六相融通，对事事无碍法界就可以解释清楚了。他果然依高僧指点就学习十地品，建立六相，以六相配释十玄门，何为玄门？表示事事无碍法界，意义很高很深，所以叫玄门。他在六十七岁圆寂。

    法藏大师

    第三法藏大师，又叫贤首国师，贤首是当时唐代宗封他的，他生平读诵奉持华严，讲华严三十多遍，读《华严》，拜《华严》，也出现一些奇迹：天干缺雨，他拜《华严经》有雨；虫子为害，需要下雪，他拜《华严》就下雪；如有外敌侵略中国，要御敌，他就拜《华严》，帮助国家抵御敌人，击退敌人。
    他有很多奇异现象，一是由于他的诚心，二是说明《华严经》是不可思议的。他生平经历五个皇帝，活了七十岁，五个皇帝都拜他为师，他成为五帝的国师。他在讲《华严经》的时候（八十华严翻译过来后他讲华严），讲到华藏世界品，大地震动。他生平建立华严的三时五教，三时按一天来算，第一时：太阳初次出来照耀高山；第二时：再逐步上升到日中；第三时：下午太阳偏西以后返照大地。
    这个三时教，第一时就是佛说华严，佛在菩提树下成道后，经过三个七日说华严教。第二时就是太阳渐次上升，到中午对小乘人说缘觉十二因缘、声闻四谛；第三时是到了落土时，太阳回光返照，对大地众生说大乘教、圆教，不舍众生。这叫三时，称为三时教。
    五教就是小、始、终、顿、圆。小乘教最初讲阿含，讲四谛；始教包括法相和般若；终教讲心性，如楞严、起信讲心性；顿教不在言语上表示，言不尽意，如圆觉、楞伽经等；最后是圆教，就是华严。这三时五教，与天台判教五时八教相仿。这是法藏即贤首国师的具体情况。

    澄观大师

    第四澄观大师，又叫清凉国师，生于中唐时期，活了一百零二岁，在五个祖师中，澄观法师活的岁数是最大的，他经历的皇帝一共是七个，身为七个皇帝的国师，唐德宗封他为清凉国师，世寿一百零二岁。他高度地赞扬《华严》：“交映千门，融冶万有”、“广大悉备，尽法界之性”。他写《华严疏钞》，在没写之前，拜佛，希望佛加持，晚上在梦中见到虚空中充满佛菩萨，光明灿烂，他就捧起光喝下去，因此开悟发慧，写出《华严疏钞》，很合佛心。
    他在圆寂时，告诉弟子们：“你们当取信于佛，不要取信于人”！他的意思是说你们要信佛说的，不要取信人，要依佛不依人。在修持方面，他说：“对境无心，逢缘不动，对于一切外境不要起妄心，不要攀缘，不要心随境转；不管什么事情，好的、坏的、不好不坏的、恶的干扰，心都不要动，要八风吹不动。这样一来，保持真心，就可以与一真法界相应，这个意趣在禅宗六祖大师《六祖坛经》里讲得有，叫“一相三昧”。

    宗密大师

    第五圭峰宗密，是唐德宗建中元年生的，宗密大师住在圭峰，是四川西充人，平生专研华严，著书也很多，有二百多种，他的思想体系是继承了澄观大师，圭峰大师也是很有智慧的人，六十二岁圆寂。
    以上五位都是从南北朝到唐代，华严思想的传承者、发扬者。宋代、明代、清代也有弘扬的，不过不多，到民国以后，月霞老和尚、应慈老和尚，也都是弘扬华严的。

    第三节　明菩萨修学阶梯

    菩萨修学阶梯，是菩萨的路线图，《华严经》正宗分的各卷都说明此内容，分为七个阶段：十信、十住、十行、十回向、十地、等觉、妙觉。

    十信

    信，要凭理智对于佛的境界有所认识。《华严经菩萨问明品》是专门说明十种信心：一信心，二念心，三精进心，四慧心，五定心，六不退心，七护法心，八回向心，九戒心，十愿心等。
    第一、信心。是指听到大乘经典，大乘佛菩萨的境界，没有疑惑，坚定信念；
    第二、念心。经常忆念三宝的功德，念持不忘。
    第三、精进心。不要懈怠，要策励自己：身业、口业、意业，不能放松，身拜佛，口念佛，心想佛。
    第四、慧心。慧就是智慧，要善于观察，检查善恶邪正，不起恶心，不起邪心，而要起善心，正心，这要靠智慧的心灵。
    第五、定心。内心要随时保持定力，不要散乱，不要随随便便的，时高时低的。
    第六、不退心。遇到什么困难，不退，困难是各种的，有些朋友、儿女、亲戚，拉你的后腿，有些外人要讽刺你一下，或者有什么阻碍，遇难不退。
    第七、护法心。知道三宝的功德，佛法的伟大，就要护持正法，时时护念正法。
    第八、回向心。就是要随时把你的功德回向无上菩提，不是为了人天小果。
    第九、戒心。就是在信仰过程中，要严守三皈，奉行五戒，内心常常要提起警惕，保持三业清净。
    第十、愿心。要发大愿，要发四弘誓愿，学观音菩萨、地藏菩萨、普贤菩萨的大愿，不要失掉愿心。
    以上就是十信。这十种信仰，都属于资粮位，这个资粮位，学佛才走第一步，是最基本的。

    十住

    什么叫住，内心要安住，心猿意马，要开始收拾。安住于菩提境界，就必须要有般若正见，菩提是由般若而生的，般若首先要有正见。有正见就与般若相应，有般若就可发菩提之心，证菩提之果。十种就是：一发心住，二治地住，三修行住，四生贵住，五方便具足住，六正心住，七不退住，八童真住，九法王子住，十灌顶住。
    第一、发心住。发心就是以正见发菩提心，这是很重要的，学大乘经，学菩萨，菩提心不可缺少，“菩提心为因，大悲为根本，方便为究竟”、“一初发心即成正觉”，这叫发心住。受菩萨戒，必须发菩提心，菩萨戒又名金刚光明宝戒，价值非常高，与无漏真如相应。
    第二、治地住。治就是治理的治，地就是心地的地，为了度众生，要治理心地，开阔心地。因为地能生万物，心能够治理，就能生出种种功德，种种善法。
    第三、修行住。要安心住于修行，安心行持，勤修戒定慧，息灭贪嗔痴，为了度众生，要修六度万行，一心专注，不要二用。
    第四、生贵住。就是能坚持这种行动，就是出生佛菩萨的，就好象生在佛的种族家，很珍贵；世间上的人生在王宫，就很尊贵，能够学佛法，依法而行，就是生在法王家，法王比帝王更高贵。
    第五、方便具足住。就是世出世间，二谛圆融，弘法度生，既要有原则，又要有善巧，真就是真谛，真如、法界、真心，是真；俗就是世俗谛，一切缘生法，一切世间法，都在其中，真俗并用，方便善巧，接引众生。
    第六、正心住。就是心要正，光明正大，不忘佛法，不忘佛恩，虽然遇到恶境恶缘，其心不动。
    第七、不退住。就是走上正道，对于三宝、因果、三世、佛菩萨境界，坚定信心，修学不管什么恶缘现前，不恐惧，不后退，要有大无畏的精神。
    第八、童真住。童真是形容，象小孩子一样天真无邪，保持这种童真之心，不被淤泥所染。
    第九、法王子住。能够从真入俗，由俗入真，不失真谛，也能善于用俗谛，真俗圆融，与佛心相合，就可以绍隆佛种，就象法王子一样，成为佛的儿子。
    第十、灌顶住。成就了智慧，住于十地的十智，即将成佛，就象王子登位，首先举行灌顶之礼。
    以上十住说明学佛要把心意收拾起来，安住于十方面，就有正见，具足般若，就在菩萨道上走，故称为十住。

    十行

    上面讲了以智慧心，于佛的菩提道，安心而住，接着在行动上实践万行，做到自觉觉他，自利利人：一欢喜行，二饶益行，三无恚行，四无屈饶行，五离痴乱行，六善现行，七无住行，八难得行，九善法行，十真实行。
    第一、欢喜行。就是能够行布施，财施、法施、无畏施，解决别人的困苦问题，使别人从忧恼中感到欢喜，予乐拔苦，是最使人欢喜的事情，菩萨就要这样，不要烦恼别人，干扰别人。
    第二、饶益行。要严守菩萨的三聚净戒：摄律仪戒、摄善法戒、饶益有情戒。摄律仪戒指不要损害别人，要严守戒律；摄善法戒就是要广修善法，不管小善大善，世间善出世间善；饶益有情戒是以悲悯心修四摄六度饶益众生。
    第三、无恚行。恚就是嗔恚，人一定要消灭恨心，烦恼火一起来，那罪就大了，“嗔是心中火，能烧功德林，欲行菩萨道，忍辱护真心”，就要修忍辱。忍有耐怨害忍、安受苦忍、谛察法忍。耐怨害忍，就是对冤家仇敌要宽容忍耐，以德报怨，冤家宜解不宜结；安受苦忍，生活中有痛苦，遇天灾人祸，能够忍受；谛察法忍，对佛法深刻信仰，坚定不移。这三种又名：生忍、法忍、无生法忍。《金刚经》讲“佛说我得无诤三味，人中最为第一，是第一离欲阿罗汉”，佛是赞扬无嗔无恚的，修行办道，不修忍辱是办不到的。
    第四、无屈饶行。就是要精进于正道，坚持正法，不屈不饶，有威力加到你身上，不怕，不退，不屈服。
    第五、离痴乱行。心中随时要保持一颗定心慧心，铭念不忘，对一切外境无所惑乱，临境不迷，假如临境迷了，就会迷失正路。
    第六、善现行。就是经常要读经，要有正见，随时要与般若智慧相合，洞察一切，就象日光一样，朗照一切，这叫善现，这就必须要了解二空——人空、法空的道理。
    第七、无住行。一切遭遇，随缘不变，保持真心，真心就是随缘不变，有两句话：随缘不变，不变随缘。随缘不变就是在一切缘中保持真心，不变随缘就是在一切缘中发挥真心的妙用，真心不失，心无所住。
    第八、难得行。做到善根智慧都能坚持，达到自他二利，自利利他，自觉觉他，很难得。
    第九、善法行。以微妙的善法之力，有智慧，有辩才，说法利生，令他生解，这就有四无碍解“法无碍解，义无碍解、辞无碍解、辩无碍解”，到了善慧地就具足这四无碍解。法无碍解，谓能通达一切世出世间的法；义无碍解，对于文字的意义都能了解；辞无碍解，对一切名字辞章都要通达；辩无碍解，就是辩才无碍，能够四通八达，信手拈来，都成妙语。善法行就必须要以一种微妙善法之力，具足四无碍解，使他生解，说法度生。
    第十、真实行。就是根据佛的真实智慧，在心中，语言中、行动中，做到说真实话，但重点是在行上。要言行不二，理论与实践一致，不要诳惑别人。
    以上十信、十住、十行在菩萨的阶梯上都是属于资粮位，即准备成佛的资粮，这叫顺解脱分。什么叫顺解脱分？就是能够如此行持，就顺于涅槃菩提的道路，是在走解脱的道路，而不是世俗的道路。

    十回向

    回向最重要的是悲智兼修，心要广大，不能自私，不能处处为我。自己在修行中积累的功德、培养的善根要回向众生，回向菩提，回向真如境界。
    十项回向重点一是回自向他，把自己的功德不占为私有，布施给别人，这叫法布施，以法施人。二是回俗向真，就是修行的目的要达到真如境界，要象佛一样契证真如，达到一真法界，常住不变。三是回因向果，修习善法的因，目的是求得阿耨多罗三藐三菩提，要有这个远大的、崇高的志向，不是修来世，不是人天果报，而是无上菩提。
    回向共有十项，《华严经》十回向品是正说十相名的，一是救生离相回向，二是不坏回向，三是等一切佛回向，四至一切处回向，五无尽功德藏回向，六随顺坚固回向，七等顺众生回向，八真如相回向，九无著无缚解脱回向，十法界无量回向。
    第一、救生离相回向。救生就是我们的心，处处要想到众生，想到众生的苦难，不离众生，要救度众生，必须要以大悲为根本，广行济度，在广行济度中，有功而不自居为功，有德而不自居为德，心无所住，这是有大智慧，有大智慧必定同时有大悲心。悲智兼运，就包括四无量心，六度四摄，四无量心就是慈、悲、喜、舍，慈能予乐，悲能拔苦，见善随喜，布施平等，叫慈悲喜舍，这个心很广大，功德也是无量无边，所以叫无量心。我在读《大般若经》时候，经中佛就赞扬四无量心，心无量，行无量，功德无量，能够修四无量心，可以降天魔，伏妖怪，除灾害。所以四无量心，在修学菩萨行中第一第一，大悲广济，大智无住。
    第二、不坏回向。对于三宝功德应该扎根信仰，坚定不移，不要破坏，若失掉对三宝的信仰，断了善根只有下堕，要自己和他人都不断善根。
    第三、等一切佛回向。这就是《普贤行愿品》中的常随佛学，我虽然未成佛，但是我要向佛学习，我的行动，等同佛行，不管是过去佛、现在佛、未来佛，佛是怎样修的，我就怎样修，所以叫等于一切佛回向。
    第四、至一切处回向。就是心胸要广大，我的礼拜供养不是一个佛，而是十方诸佛、法界诸佛。至一切处，就是到一切十方世界三宝之前修供养，饶益众生，为众生谋利益，叫至一切处，这就是悲愿广大。
    第五、无尽功德藏回向。就是境界无量，功德无量，果报无量，不离众生，广修善根。“将此身心奉尘刹，是则名为报佛恩”，要把真心奉于尘尘刹刹的境界，尘尘刹刹的众生。这就有无尽的功德，我的身体存在，是为贡献三宝而存在，为救度众生而存在，不是为我自己，所以《法界观》的中心，要处处想到众生，众生中有我，我与众生打成一片，如此，无尽的地方，无尽的众生，无尽的功德，成了无尽的宝藏，这是我们最大的财富，而不是世间上金银财宝的财富。
    第六、随顺坚固回向。什么要坚固呢，善行要坚固，悲智要坚固，六度要坚固，不能有一点动摇，象金刚一样的不坏。
    第七、等顺众生回向。等顺就是以平等心随顺众生，破除一切执着，铲除一切障碍，消除一切相的分别，平等平等，随顺饶益。
    第八、真如相回向。就是说回向要顺于真如，修慈悲行，在修行中要无住生心，不要有所住相，就达到与真如境界相合。
    第九、无著无缚解脱回向。要修普贤菩萨的十大愿行，既不住，也没有缠缚，既不住于相，也不住于见。在修行中，不为名利，不为自己，专利他人，这样就住于无缚，有住就有缚，缚就是束缚你，无住就无缚。
    第十、法界无尽回向。定心纯净，远离垢秽，以法施，以清净心施于众生，心胸广大，等同虚空，周遍法界。总之，要心胸广大，修悲，修智，修行，其中真俗并融，悲智兼运，普周法界。
    十回向中，每一个回向分为入心、住心、满心。从你发起心以后，最初叫入心，进入心的境界了，入心以后就是住心，有个过程，就是安住于一段时间，功夫到了一定的程度，最后就是满心，就是说这心已经要圆满了，要进入另外一个阶段了。
    就在第十回向中，满心之后接着就是加行位。什么是加行位？即加功用行，勤修止观，要把内心知见纯正起来，由于错误的知见生起的人我执、法我执，要将其扫荡干净，就必须要加功用行，修止观，止观就是禅定，有四个阶段。《华严经》是属于修心的，要通过修心观阶段，其他各个宗派，不通过这个阶段也不行，什么原因？大家要知道，佛法讲修心，内心要净化，净化功夫就是要遣除我执、法执，建立我空、法空，否则，真空见就立不起来，般若慧无从发生，你则无从开悟，开悟就是破我执、法执，才能把生死根本拔掉，就如禅宗说的打破黑漆桶，因为我执、法执在，胸中是黑漆一团，见不到光明。所以这个静的功夫，相当重要。
    四加行
    加行位分四个阶段：暖、顶、忍、世第一。这里解释一下，暖就是暖和的暖，温暖的暖；顶就是山顶的顶，头顶的顶；忍就是忍辱的忍，忍可的忍；世第一就是世间上第一，数第一。小乘、大乘都是同样的称呼，但是境界不同，这叫四加行，由四加行才能入于见道，进入通达位，也就是一般说的开悟。
    有些人动不动就说我悟了，我开悟了，哪有那么简单！？有些居士好象很聪明的样子，说我悟了，悟个什么，悟的什么境界啊？！没有经过前面几个资粮位，十信、十住、十行、十回向，这些没有锻炼好，开什么悟？还没有修加行位，悟什么悟？!顿悟的功夫，是从渐修来的，由渐到顿，哪有一步登天梯的道理，所以学佛不能好高骛远，要脚踏实地。这里有几个定，在暖位修明得定，顶位修明增定，忍位修印顺定，世第一位修无间定。
    什么叫暖，就是说你最初有点智慧、智火了，智火显发，很温暖的，叫暖。顶呢？智火显发进一步提高了，增加了，就象爬山，登到山顶了，叫顶；忍就是继续忍可下去，又要加功用行，巩固已有的成绩，转入一个新的境界；世第一呢，到了这个时候，做到能取、所取俱空，达到二空境界，世间是第一的，修道是第一的，叫世第一。这就是暖、顶、忍、世第一。
    明得定，就是最初心里明白了，了解了，也就是智光出现。明增定，就是继续修，继续观，这种智光智火增加。印顺定，能够印证前面境界，又顺于后一步境界，前面证得所取空，后面就要进一步证能取空。所取就是境界，不执着境界叫所取空；能取，也不要执着内心，执着一个心，一个我，那都是错误的。所以印前顺后叫印顺定。无间定，就是很快。进入无间定以后，功夫就差不多圆成了，进一步证入见道位，那就是悟的境界了，证入见道位，就已经踏入第一地，十地中的欢喜地。
    以上道理再重复补充：
    第一位、暖位。由下品寻思观外境不实，不过是名义、自性、差别、假名安立，就印见所取空，一切境界是假的、空的。
    第二位、顶位。又继续深入寻思，细微地寻思，叫上品寻思，进入顶位，加深了对所取空的认识，经过寻思以后，明确了，决定了，没有疑惑了，经过反复拣择、分析、推论，到此时内心得到决定了，这叫做如实智。
    第三位、忍位。由下品如实智就进入忍位，不单是观所取空，进一步观能取空，能取的心、能取的我还是空，不要执著一个我，不要执著一个能取的心，讲唯识，识也是空的，等于般若一样，讲空，空还是空的，讲不可得，不可得还是空的，一切不可得，要把妄情杂念空得一干二净，才是真正的智慧，所以以下品如实智进入忍位，得了印顺定，既印证前面所取空，又顺于观察能取空。
    第四位、世第一位。由上品如实智进入第四位，世第一位，双证能取所取，所取的境界既空，能取的心识也空，不要执着心，心也是空的。这样才将妄情执著扫荡得很彻底。
    佛法讲神通，大家注意：真是到了这个境界，才有通，没到这个境界，内心有一点私心杂念，你通什么？!障碍多得很，你还证什么通!所以搞外道的，没有经过这些阶段，一上坐，就想神通，飞这里飞那里，想前知五百年后知五百年，结果走火入魔，我相、法相，种种魔相就生起来了，他得什么通？只能说邪通，所以学佛不要首先想得通，首先要想好好修习，象菩萨修行一样，经过十信、十住、十行、十回向，悲智兼修，积累福德智慧资粮，这样才踏实，再经过加行进入见道位，菩萨的悟道境界，这时就进入十地的第一地，住于欢喜地。

    十地

    何为欢喜？内心得了法喜、轻安，有这个基础，就可悲智兼运，饶益众生，所以叫欢喜。到了这时，断了由后天邪师、邪友、邪见熏习的三界见惑。就进入菩萨的修道位，继续修行，彻底断除烦恼障、所知障的现行和种子，经过十地。何为地？这是个譬比，到了这个阶段，福慧比较圆满，悲智也上升，就可生一切佛法，一切功德，就象大地能生万物一样，所以叫地。
    十地依次是欢喜地、离垢地、发光地、焰慧地、极难胜地、现前地、远行地、不动地、善慧地、法云地。真正到了初地，开了悟以后，才晓得三界唯心，万法唯识的真理。
    何为欢喜地？就是由见道进入初地，此时生起无漏无分别智，契证了真如，悟得了人、法二空，再由无漏的有分别智，断了分别的二障，即烦恼障、所知障，这二障属于邪分别生起来的，能够断掉分别二障，就能够自利利他，生大欢喜，广修布施，圆成布施，施而不执，三轮体空，圆成施度。
    二是离垢地，垢就是污垢，到这第二地，心性清净，具足清净见，在行动中远离烦恼污染，严持戒律，菩萨的三聚净戒，圆成戒度。
    三是发光地，成就胜定即殊胜的禅定，证得微妙的法乐，生起慧光，心胸广大，忍辱柔和。一个心胸广大的人，能忍辱、柔和的人，是能发光的。此地修行圆成忍辱度。
    四是焰慧地，由定光发出智慧的火焰，如火烧薪，慧焰增盛，在修行中精进努力，安住于菩提分法，即是三十七菩提分、四念处、四正勤、四如意足、五根、五力、七觉支、八正道等。把身见、边见、一切邪见能够除掉，慧焰增胜，圆成精进度。
    五是难胜地，就是难能可贵，很殊胜的，至此世俗谛与胜义谛，同时俱起，真俗互融，非常殊胜，修行禅定，圆成静虑度。
    六是现前地，般若智现前，了解缘起性空的道理，在此时，缘起性空之义了了分明，圆成般若度。
    七是远行地，何为远行？从初地到七地，观一切诸法无相，都是用力观察，加功用行，从时间上讲，即是第二阿僧祇劫，很长的阶段，加功用行，诸法无相的观察，已经到了最后的阶段，故叫远行地，这时修习方便般若，圆成方便度。
    八是不动地，观诸法无相，而是任运观察，由勉强到自然的阶段，任运自如，修无相观，观我、法二空，一切内境外境现前，做到如如不动，不为无明烦恼所障，叫不动。读《心经》第一句“观自在菩萨，行深般若波罗蜜多时，照见五蕴皆空，度一切苦厄”，观自在菩萨就是观世音菩萨，实际上是第八不动地的菩萨，这一地的菩萨悲心很深，智慧很高，观察诸法空相到了甚深微妙的境界，任运自如。这种智慧相续不断，一切内境外境都干扰不了，真是到了“八风吹不动”。这时完成愿度，真正才有大愿，普贤菩萨的大愿，文殊菩萨的大愿，观音菩萨的愿，到这时才能真正体现。
    九是善慧地，经过八地以后，就成就了殊胜微妙的智慧，叫善慧，有这个智慧，就具备四无碍解：法无碍解、义无碍解、辞无碍解、乐说无碍解。法无碍解就是通达一切世出世间法，就象现在说的知识广博，这是佛法的知识，不是世间上的知识，是智慧发出来的；辞无碍解就是通达一切名相、言辞，文字般若；义无碍解就是名相中的内容能够了解；乐说无碍解，就是能够善巧地左右逢源，因机说法，又叫辩无碍解。此时就能说法利生，这一度完成力度。何为力？智慧才是力量，所以说大势至菩萨有大智慧，不是说双手能举千钧，而是指大智慧的力量。
    十是法云地，就是十地圆满地，具足众妙功德，断除一切烦恼障碍，已经进入法身圆满的境界，法云是个譬喻：证得法身，智慧就象天空的云一样，满布天空，降大法雨，使众生得到滋润，大地得到清凉，到此时烦恼障所知障的现行和种子，彻底伏除，进入金刚道。

    等觉

    金刚道以后就是第六位叫等觉，此时就是成佛的预备阶段，即是一生补处，弥勒菩萨的地位，也是普贤菩萨、文殊菩萨、观音菩萨的地位，所谓等觉，就是等同于佛果，但是觉行还未圆。

    妙觉

    等觉以后是第七妙觉，就是佛位，此时圆证菩提，证得无漏的智果和涅槃果。智果就是菩提，涅槃就是真如，具足三身四智，五眼六通等无量功德。


第五章　华严经的内容

    第一节　明万法唯心

    佛教是修心法门，能够清净其心，则能明心，明心就能见性，性是什么？如来性！这个心，不是一般说的肉团心或者神经中枢，也不是一般人讲的第六意识，第六意识是虚妄分别，落于言诠，相对之中。而这一颗心，是广大、真实、平等、清净的真心。《楞严经》里第一大段，七处征心说得很清楚。学佛就是由妄归真，要恢复真心，山河大地，一切一切，都在真心包摄之中，不过众生境界，真心受了蒙蔽，因为众生背觉合尘。佛菩萨的境界是由真心显发出妙用，这是因为佛菩萨经过修行，背尘合觉，但都离不开心，“心佛众生，三无差别”，平等平等。
    华严讲“三界唯心，万法唯识”，《华严经十地品》在现前地里面讲了“三界虚妄，唯是一心作”、“十二缘分，皆属依心”，《菩萨明难品》里讲：“一切世间法，唯以心为主”，另外也有一段讲：
    心如工画师，
    能画诸世间，
    五蘊悉从生，
    无法而不造。
    这颗心象绘画的画师，能画这样也能画那样，不管色法、心法，森罗万象，心这个画师都能画出来，所以说心如工画师。
    三界：欲界、色界、无色界，是由于心的业力所感的总报或者依报，这就是“三界唯心，万法唯识”，是说宇宙的森罗万象，不管心理现象、物质现象、自然现象，都是唯识所变。
    《华严经》是唯识法相六经十一论之一，而且是主要经典。唯识所变，一是转变的变，二是变现的变。这个变不是变戏法，为什么能变？由于种子，种子就是潜在的心力，一切离不开能力，宇宙万法出不了能力，没有能力就没有万法，跟现代科学讲的“物质的推动完全由于力，没有力物质就无法转动”是一样的道理。
    种子就是力，就是能，一种是亲生诸法的种子，叫等流种子，又叫名言种子。另外还有两种，是构成生死、业果相续的种子，即我执种子、异熟种子，也叫业报种子。由我执种子、异熟种子，感生生死相续、生死轮转；由等流种子（或叫名言种）产生一切现象，都含藏在阿赖耶识中。其中属于染污的就构成染污的现象世界，属于清净的，就逐步使如来藏现行，恢复真心，经过一定的阶段，构成正觉世界。这些内容很深，很有条理的。
    “识”变一切，“识”又缘一切，以所变为所缘，《成唯识论》有一段：“阿赖耶识，因缘力故，自体生时，内变根身，外变器界，即以所变，为自所缘，行相仗之，而得起故。”这不是变戏法，也不是上帝来决定，因缘力故。一切讲因缘，有因有缘才有果，这不是一般宗教讲的，也不是一般的自然现象，当这个现象已经成功后，又以这个现象为所缘，内心变成四份：见分、相分、自证分、证自证分。
    “见分”是能缘，“相分”是所缘。这个相分，又有亲相分、疏相分。山河大地，是疏相分。眼中影像，是亲相分。清不清楚靠自证分，自证分清不清楚，靠证自证分，即心力的反射，分析得很详细的。所以关于讲识变，唯识法相详细解释了这个道理。佛法讲自净其心，有情世间，器世间都是由心所造，圣者世间是佛菩萨的真心体现，无不由心，《华严经》讲的“法界缘起”也叫“唯心缘起”，这听起来有点玄，但是没关系，听一下熏习一下，多思惟，多学习，慢慢就懂了，就怕不熏习，就没有办法。

    第二节　明法界缘起

    法界缘起，界者，一种是性，一切心物的体性，那就是真心，另一种代表事相，有分界，有很多差别，宇宙万法，森罗万象，事事物物，都有差别。法界一方面讲心，一方面讲事，体现了心与事物的总和，在真心融通之下，一切心理现象，事物现象，互为缘起。佛教的缘起一般讲，有业感缘起、阿赖耶缘起、性空缘起、真如缘起、六大缘起（六大缘起是密宗所讲的）。《华严经》讲法界缘起，是缘起教义的高峰，它不离开一切现象，不离开现实，讲真心在现实中找，讲道心也在现实中找，讲开悟也在现实中找，比较实际，世间哲学是讲不到的。

    四法界

    《华严经》所讲法界共有四种：事法界、理法界、理事无碍法界、事事无碍法界。
    第一事法界，事相差别，其中：宇宙森罗万象各有差别，地水火风，地是地，水是水，火是火，风是风，是不同的。
    第二理法界，这就是心、性，不管多少事法，森罗万象，都是同一心性所现。离不开心，这心就代表理。
    第三理事无碍法界，具“性”、“相”两义，性相代表本体与现象，虽然是两种，但是二而一，不能分开，现象由本体所成，本体由现象所显，事由理成，理由事显。可以理事融通无碍，叫理事无碍法界。
    第四就是事事无碍法界，专门讲事，事与事间都是通达无碍的，这一点世间哲学、自然科学在讲的时候，把它分得很严格，事物是独立的，各有差别，因此难免矛盾，难免是非，难免争斗，事与事间不能融合。华严讲事法界，事事无碍，一切都是因缘，此有故彼有，此生故彼生，此缘之有，离不开众缘，众缘之有，离不开此缘，缘缘无尽，这叫做无尽缘起，大家想想这个思想好伟大。这就是现代讲的辩证法，恩格斯在《自然辩证法》里讲：讲到辩证法，只有佛教徒的思想达到了最高的水平。
    但是佛教辩证法与自然辩证法、唯物辩证法又有差别的，不能混同一谈。同是讲矛盾，自然辩证法、唯物辩证法认为“矛盾是绝对的，统一是相对的，事物永远都在矛盾进化中”。佛法讲的就不同，佛法讲一切事物在真心融通之下，法法相资，法法平等；真俗圆融，二谛融通。真就是真谛、胜义谛，属于真心；俗就是世俗谛，属于缘生法；一个性空，一个妙有。二谛圆融，这是最高的智慧，由二谛圆融产生的行动是什么呢？由于真谛就有大智慧，不着一切，不染污泥，不贪恋世间；由于俗谛讲缘起，非断非常，住于中道，不否定因果，而且认识缘起法法法相资，法法平等，众生对我都有恩德，应该报众生恩，众生在苦难中，应该生起悲心，拔苦予乐。因此以真谛生起大智慧，以俗谛缘起不否定因果，生起大悲，救度众生，这就是事法界缘起的真谛义。
    发菩萨心，修菩萨行，就根据这个宇宙观，沿着菩萨的阶梯，学普贤菩萨修十大愿，结合六度万行。华严讲十度：布施、持戒、忍辱、精进、禅定、智慧、方便、愿、力、智，难行能行，难忍能忍，缘缘无尽，众生无尽，菩萨愿行也无尽。这个法界缘起观，内容很高的，这就是事事无碍法界的中心思想。
    根据上义再详细补充：在真心融通之下，一切分歧差别的事法，大如须弥，小如芥子，或如毫毛，得理法界之融通，皆具理性而普遍，彼此不相妨碍，如性融通而重重无尽，一摄一切，一切入一，一切是无量的诸法，无量的事相，入一呢，归于真心，为真心所融通，叫一切入一。一心摄万法，万法只一心。所以说：“无不从此法界流，无不还归此法界”，就是这个意思。
    一摄一切，就包括有数量、大小、长短，一切世法分不开这些。
    从事相来讲，有大有小，由小到大，小如微尘，大如须弥，在真心融通之下，大小相容，小不离大，大不离小，所以叫“须弥纳芥子，芥子纳须弥”。
    从数量来讲，一就可以摄一切，一切就包括在一中，就是一多相即，一与多是离不开的，多由一来，一离不开多，多离不开一，都是相即、相入的。
    从时间上来讲，长劫、短劫，一念之间，分为三世：过去、现在、未来，而过去里面又分三世，现在又分三世，未来又分三世，加上现在一念，叫十世；一念通十世，前前无始，后后无终，离不开一念间，所以说长劫入短劫，短劫入长劫；修行人在定力中，转瞬之间经历若干世，但一般人来看呢，不晓得有多长，很长很长的时间，修持禅定者的感觉却是非常短的时间。
    以上说明在真心融通之下，虽然有差别，差别而无差别，都是相应的，相通的，虽然讲真而不失俗，讲俗而不失真，二谛圆融。菩萨行就在中间，不舍真不离俗，修莲花行，具体讲修普贤行，不舍普贤大愿，不舍普贤苦行，这就是整个法界观的思想。
    所以法界观的中心还在事事无碍法界，能够了解这个道理，我们人与人相处，就应该舍小我顾大我，舍大我成无我。小我离不开大我，大我最终还要无我。我中有你，你中有我，我有国家，国家就有我，我有世界，世界就有我，我有众生，众生就有我，这就融合在一起了。还有什么不平等？还有什么差别？还有什么斗争？还有什么是非啊？！这就是华严的菩萨的和谐圆融的宇宙观。以此观来指导菩萨的行动，愿人人成菩萨，人人都是毗卢遮那佛，人人都是文殊菩萨，人人都成普贤菩萨，人人都成弥勒菩萨，就是这个中心思想，所以《华严经》岂止为菩萨讲，是为一切众生讲，希望众生都成菩萨，这是佛的大慈大悲。

    十玄门

    十玄门专门解释事事无碍法界，有智严大师的十玄门，澄观大师的十玄门，这里介绍的是智严大师的十玄门，老十玄门。
    为什么叫玄，就是说比较深，虽然深，若肯学肯修，还是能了解的。这十种是：同时具足相应门、因陀罗网境界门、秘密隐显俱成门、微细相容安立门、十世隔法异成门、诸藏纯杂具德门、一多相容不同门、诸法相即自在门、唯心回转善成门、托世显法生解门。一共十种，现在只简单地提一下。
    一、同时具足相应门
    这个相应，即前后相应，就是有始就有终，有因就有果，这中间包含很多内容，这里只举因果来讲。譬如毗卢遮那佛的果位的圆满，功德很多，以文殊菩萨的智慧为用，生起信心，“信为道源功德母，长养一切诸善根”，信心坚定，就在这个同时，发菩提心，经上讲“一初发心，即成正觉”。
    发心与成正觉是相应的，发心是因，成正觉是果，所以说学佛就看你发不发心，看你是否坚定信心。你若能够坚定信心，发菩提心，也就是求成菩提，只要有这个信心，就与菩提相应，与果报相应。就象禅宗讲的“狂心顿歇，歇即菩提”，普通讲“放下屠刀，立地成佛”。
    你能够放下屠刀，你就能成佛，就转过来了，因果相应。其实事物是联系的，不是单独的，此有故彼有，此无故彼无，缘缘相应，所以经上讲，“一初发心，即成正觉”，又说“悉成正等觉，不舍初发心”。虽然得了佛果，但是回转过来，不要把初发心割断了，就是由于初发心的关系，才能完成正觉，这就是“悉成正等觉，不舍初发心”，说明信心与发菩提心的重要。所以希望大家坚定信心，不舍菩提心。信解行证，有行最后必定有证，是有连带关系的，这是不能分开的。
    二、因陀罗境界门
    这是以譬喻来讲的，就是说缘与缘的关系是连带起来的，此缘离不开彼缘，彼缘离不开彼彼缘，推下去，等于象珠子一样是连串起来的。
    这里介绍的是帝释的因陀罗网，据说在帝释宫殿，罩有因陀罗网，网上有很多珠子，珠子灿烂光辉，明朗夺目，珠子与珠子相照，这个珠子里有那个珠子，那个珠子里有这个珠子，珠影重重相映。就象一室燃灯，中供佛像，四面悬镜：中间有个灯，周围上下也安起灯，佛像在中央，上下周围都有佛像的影子，影子里面又有影子，重重无尽。与因陀罗网的珠子是一样的，一珠为首，其余众珠的影像都影现其中，一切珠子都是这样的。
    一切事相由因缘所成，此缘由彼缘成，彼缘由彼彼缘成，一缘望多缘，多缘望一缘。一个事物的缘可以成功多缘，而多种事物的缘也可以成功这一缘，彼此相望，互为因缘，法法相资，以此相推，重重无尽，如《楞严经》讲的“于一毛端现宝王刹，坐微尘里转大法轮”。毛端很小，但是可以现出宝王刹，佛的法会，可以现其中，一个微尘虽小，可以转大法轮，佛说的八万四千法都在里面，小中有大，大中有小。
    “于一毛端现宝王刹”，就是说我们的正报可以摄持依报，正报小，依报大，与整个大千世界都有关系。
    “坐微尘里转大法轮”，就是说微尘虽小，微尘与各种微尘相接，就是无量无边的世界，就是无尽的缘起，也代表无边的空性，从一微尘中说明缘起性空，就代表佛说的三藏十二部教典、八万四千法门，所以说“坐微尘里转大法轮”。
    “于一毛端现宝王刹”，即“微尘剖出三千界”，微尘也可以显出八万四千法门，以小转大，以小摄大，我们这个心包括万有。古代圣人孟子讲到这一点“放之则弥六合，卷之则退藏于密”，心量放大，可以摄到十方世界，缩小呢，就是很微，很隐密。心包万有，万有归于一心。我们修道，与真如相契，则法界就广大，宇宙就广大，小中有大，大中有小。
    有篇《金狮子章》，是法藏法师为武则天写的，以金狮子作譬喻，狮子是金质的，本身是金的质量。因此狮子身上的毛也代表金狮子，狮子身上的眼耳鼻舌，各种肢节也代表金狮子，狮子整体也就是金狮子，而这一切，一根毫毛就可以代表，从小见大，小的可以包括大的，大中含小，就是这个意思。
    三、秘密隐显俱成门
    这是从缘起来讲，佛说法的缘起，因机制宜，因时制宜，不管说小乘教、大乘教、般若、唯识法相教、显教、密教、权教、实教，都是归于一乘，这是秘密的，目的就是要成佛。但是从明显来分，就有大有小，有显有密，有渐有顿，有权有实，这是根据众生的机缘来讲。说小乘教，大乘教就隐；说大乘教，小乘教就隐；说显教，密教就隐；说密教，显教就隐。象月亮一样，这边看是缺的，那边看是圆的，但是不管是大小，显密、顿渐、权实，终归一乘，意思就是大小显密等是圆融的，是无碍的，是相容的，最后都要达到佛乘。
    四、微细相容安立门
    这是从相方面来讲的，相，有小有大，由小到大，一微尘即成世界，所以大中有小，小中有大。《金刚经》讲“说微尘即非微尘，说世界即非世界”，这是胜义谛，讲空，微尘是各种分子合拢来的，本性是空，世界由微尘组成的，还是空。但从世俗谛来讲，有小有大，有细有粗。真心融通之下，大小相融，小中有大，大中有小，这不能分开，所以事相、小大、微细都是相容的，相即相入，如上面所讲的“芥子纳须弥，须弥纳芥子”，澄观大师譬喻的好象一个大琉璃瓶，里面装很多芥子，大小相容不能分开。佛法讲真心融通，大小相容。就是此理。
    五、十世隔法异成门
    隔法就是时间隔开了的，但是相通。就三世来讲：过去、现在、未来，三世中又各有三世，在现前一念中出现共为十世，看起来是隔了，是分开了的，实际是相通的，有短劫就有长劫，有长劫包括短劫，所以叫长劫入短劫，短劫入长劫，彼此相通，佛法讲空间无量无边，时间无始无终。佛教的世界观很宽，生命不断延续，虽然相即相入，而不失先后、长短。
    澄观大师有个譬喻，说有个人晚上作梦，梦是三更半夜，时间很短，但他在梦中的经历就长了，一百年的经历。你看中国小说《黄梁梦记》，人虽是在枕头上很短很短的时间，而在梦中就经过很多年，从生下来到作官，当宰相，生儿育女一大堆，醒来后老道的黄梁还没熟，叫黄梁梦，这是心力作用，时间长短相入，转瞬不过百年，“一夕之梦，翱翔百年”。
    六、诸藏纯杂具德门
    这是从修行十度来讲，布施、持戒、忍辱、精进、禅定、智慧到方便、愿、力、智。修布施度，财施、法施、无畏施，能够做到三轮体空，一切万法、一切善行都叫做施，具有空慧，不管哪方面行持，一切都叫施。但是在修行过程中分阶段，就具体行持各有不同特点。初地以布施为重，另外持戒等属于杂，纯施中附有杂行，是二而一，都是属于佛法修行之宝藏，所以叫诸藏纯杂俱德门。
    七、一多相容不同门
    这是从理方面来讲，从缘起的道理来讲，缘起法从一到多，多中包一，重重无尽，一切相即相入，彼此相容，有一就有多，有多就有一，一摄一切，一切摄一。
    从事相上讲，一多相即相入，虽然有一有多而相容，但数字不会混乱。澄观大师举了一个譬喻，譬如一个讲堂燃了千灯，不管一盏灯、十盏灯，或是千盏灯，数字不同，但是灯光互相交融，光光相网，而不相碍，所以叫一多相融，这个譬比很生动，一室千灯，光光相网而不相乱，从一到千是一体不会乱的，光光相网，互相容纳，是一体的，互摄互入。
    《华严经普贤行愿品》有这么一句话：一切众生身入一众生身，一众生身入一切众生身，而不相碍，不失一多之相。这个道理很明白，那就是我有众生，众生就有我，这里含着：我中有你，你就有我，我中有众人，众人就有我，相即相如，彼此无碍，这是大我，大我到无我。这叫一多相容不同。虽然不同而相容，即依缘起的道理来讲。
    八、诸法相即自在门
    这从作用来讲，你发了心就起很大作用。你不要以为只发了一点心，“一初发心，便成正觉”啊！经上又讲，“彼一念功德，无量无边际，如来分别说，穷劫不可尽”，你能发一念，这个善念，功德既深且广，没有边际，如来说，假如分开来讲的话，长劫都讲不完，这是心力的作用。
    心力不可思议，你发了愿心，就要坚持，有愿必成，发了信心，只要坚持，也必成菩提，力量很大的。移山倒海都做得到。你如不发心，哪怕一点小事也做不成功，就是这个道理，发心之用，不可思议，即始即终，一即一切，无有穷尽。虽然是相即，从初到终，不失菩萨行的阶段。
    九、唯心回转善成门
    这是从心方面讲，一切唯心造，心外无别物，善恶随心，顺转就成涅槃，逆转就成生死。顺于真性，就是顺于真心，众生是逆于真心，佛菩萨是顺于真心，这叫唯心回转。善成就是你能有真心，结果就好。这是以心来讲的，所以说“心佛众生，三无差别”、“生死即涅槃，烦恼即菩提”。尽管是生死，你转过来，消灭烦恼，消灭了妄心，就是涅槃；尽管是烦恼，你能转烦恼，消灭贪嗔痴，就成菩提。就在一心之间。
    十、托事显法生解门
    这是从智慧方面来讲，《华严经》世尊说法放光，从智慧来理解，放光就是佛说法，佛证了果位才放得出来，才有这么大的光，这种光周遍法界，无处不入，只有佛的神通才办得到，所以由放光就显示佛果的功德、佛果的伟大，就在说法，托事显法嘛，如禅宗祖师棒打拳打交加，“七尺竿头开正眼，一声吼下歇狂心”。临济祖师，你问他一下他就打你一下，托事显法，就是把你无明去掉，使你觉悟，又比如善财童子，登了弥勒楼阁，见到各种殊胜境界，重重楼阁，庄严美妙，这就是法界的境界，这都是托事显法。
    以上十门，说明一切事物，不管各种心法现象、事法现象，在真心容摄之下，都是相融通的，这就是事事无碍法界。

    六相

    六相，这是从形体相状来分析事物，说明缘起法在整体的各种相之内，互相依存，和合无间，圆融无碍，六相就代表事法界的内容，也是事法界的补充。
    六相成为专章，是因为华严宗第二祖智俨法师有一次在梦中，有位印度高僧指示他，你要阐扬法界缘起，必须在《华严经》的十地品中，其中的六相要加以阐述，智俨大师根据这一段梦中指示，就在十地品中的第一地“欢喜地”，找到这段原文，在“欢喜地”，佛告诉弟子们：你们要弘法利生，必须善于解释六相，而且指出了哪六相，缘起是什么样的。所以，六相是说明事物的整体关系，每一个事物都有六相，人有六相，一栋房子有六相，一部机器也有六相，每一相都相连，不能分离。
    下面，我就解释一下六相。哪六相呢？即总相、别相、同相、异相、成相、坏相，每一个缘起的事物都具足这六相，就成为一个整体。
    譬如总相，用人来举例：人体就是总相，这个五蕴身有六根，眼耳鼻舌身，内部有心肝脾肺肾，表面有皮肤、毫毛，这样子成为一个总体，现在生理学家分析得很详细：人脑有一百四十亿个神经细胞，人体有二百零六根骨骼，六百九十多块肌肉，一样都不能缺少，就成为人的总相，否则不能成为一个人体。
    第二别相。就是在各种根门中，各个有别相，体虽然是一种，但是根，五脏六腑不同，各有各的相，差别不同，这叫别相。
    第三同相。就是由于诸根和合而成一个整体，离不开和合，这中间就有心灵的支配，假如眼睛没有看，耳朵没有听，则眼见不到色，耳听不到声音，鼻没有嗅闻不到香，舌没有尝就不知味，没有这个根，就没有这个识，各有各的作用，由各种根门合成的法，互不相违，虽然各有特性，但同心协力，分工合作，而不相妨碍，成为一个整体，这是离不开的。同相，其实也就是和合相。
    第四异相。异就是不同，虽然分工合作，构成一体，但是各个部门，他的作用不同，他的形状不同，象眼睛不同，耳朵不同，鼻子也不同，嘴也不同，虽然不同，但是分工合作，成为一体，在一体之中，各自发挥各自的作用，各有其功能。
    第五成相。成功的成，不管你总相别相，最初要成才行，由不成到成的阶段，这也就是各个根门，各个部门互依互存，相互合作一法，到了成功的时候，就叫成相，成为一个总体。
    第六坏相。专门指自相自体讲的，在总相中，只就某一个部门来看，就不成为成相，也不成为总相，如单从眼睛来看，只能看，光凭眼睛不会成为总体，从这方面来讲，叫坏相，这个坏不是破坏的坏，是指不能成为一个整体。
    所以每一个事物：人、动物、生物、物质、有机的、无机的，都是有六相。总的说来，因缘生法，彼此相依相存，缺一不可。从人来说，这根毫毛很小，但你扯一根试试？拔一毛而动全身；牙齿也很小，你拔一颗看看？痛得不得了，而且缺了牙齿，吃饭、说话都不方便。所以，小中有大，大中有小，芥子纳须弥，须弥纳芥子，就是这个道理。小可以成大，大可以涵小，小大不相离，有和合性在其中，不是绝对分开的。
    另外从修房子来举例，一座房子是个总体，在总体之下有别相：柱子、横梁、桷子、天花板、地板，细到一块砖，一匹瓦都不能缺，缺一样都不行，就不能成为房子。譬如机器，大零件，小零件，缺一个镙丝都不行。譬如飞机、火车、汽车，镙丝钉出了故障就会发生危险。所以大小不相离，因为有个和合关系在其中，缘生法就是和合性，佛说缘生法是以慧眼观察一切，不象世间上差别相太大，界限森严，你我他分得那么严格，结果就斗争、造业。
    法界缘起的中心思想是和谐、和合，了解缘起，从缘起中了达性空，与真心相融，一切事物相依相存，应该互相尊重，互相爱护，因此菩萨就具足大智慧、大悲心，誓愿度众生，以此成佛道，这是佛说法界缘起的意思，《华严经》的重点就是法界缘起。

    海印三昧与大圆镜智

    《华严经》讲“三界唯心，万法唯识”，有些人半信半疑，世俗的人不相信。真正要彻底相信，要完全了解，必须是经过开悟以后的初地菩萨，开悟以后，回顾整个众生境界，大梦一场，就好象晚上睡觉一样，梦中有各种形象、各种经历，但是身在梦中不知梦，到了梦醒以后回想一下，才知刚才的境界是梦。法界观是佛说的，佛在什么境界中说的？是在海印三昧中，发了大圆镜智而说出来。
    何为海印三昧？三昧，就是定、禅定、止观，又叫奢摩他。大家设想一下，我们在大海边，当清风明月之夜，天上是月亮星星，或者有点云彩，那个时刻大海风平浪静，天上的月亮、星星、云彩清清楚楚地映在海中，海中就出现各种形象，这个大海，有影子映上去，它是这个样子，清清楚楚的，没有影子，它还是这个样子，清清楚楚的。他把天上的各种东西照得清清楚楚，就好象一面大圆镜一样，把森罗万象、事事物物照得清清楚楚的，这种定就叫海印三昧。
    “海印者，真如本觉也，妄灭心澄，万象齐现，犹如大海，因风起浪，若风止息，海水澄清，无相不现”，《起信论》云：“无量功德藏，法性真如海”，“今云森罗万象，一法所印，一法者，指心也，是心则摄一切世间、出世间法，即是法界大总相法门体，唯依妄念，而有差别，若离妄念，真如炳现，故云海印三昧”。以上引的是注释海印三昧的经文。众生平时的心是一种意识的妄心，属于染污的，有妄念，有我执，有烦恼，就象海水一样，起了大风浪，波浪掀天，在此情况之下，对万象森罗，对事相，对道理，如何能清楚？无明障蔽，心中黑漆一团，因此造业受苦，在生死中轮转不息。真心不显，妄心作怪。
    在唯识来讲，转八识成四智，到了成佛的境界，前五识转为成所作智。何为成所作智？在凡夫境界，我们的根门：手、脚、身体，不会正用，很多的人为了自己的利益，破坏他人的利益，眼耳鼻舌身乱动，就是这种情况。到了成佛的时候，叫成所作智，就是说那时我们的根门，我们的动作，一切为了成就众生，众生有所要求，就成就他们的各种愿望，这时的身体作用就不同了。
    转第六意识成妙观察智。意识在凡夫境界，虚妄重重，颠倒重重，看问题不清楚，戴有色眼镜，所以发生颠倒、造业的行为，到了佛的境界，就转成妙观察智。就是对于诸法，一切共相、自相、总体、别体都能够善于观察，哪怕是万象森罗，都能在观察中了解得清清楚楚的，因此对于众生，根据妙观察智而说佛法，给众生予智慧。
    转第七识成平等性智。第七识叫末那识，在众生境界，执我、执法，执生命的主体为我，执一切法为我所，贪心重重，这是生命的祸根，是痛苦的根本，因此有许多差别相，如《金刚经》里讲的人相、我相、众生相、寿者相、法相、非法相，各种差别相生起来。转成平等性智之后，就可以消灭差别相，把第七识转为平等性智，自他同体，心境一如，平等平等。
    转第八识成大圆镜智。第八是阿赖耶识，在众生境界是染污性，受熏习也是染污的，执持的种子亦是染污的，当然它也不只是受染污的，也有清净的受善法熏成的善种，但这种人还不多。若能修学正法，熏习善种、清净种子，从而克服、消灭了染污种子，到了佛地，转为大圆镜智，这时就象大圆镜一样，朗照虚空，无物不现，清清楚楚，这就是从海印三昧中才能产生出来，没有那种定力就没有那个智慧。
    要证得海印三昧，发大圆镜智，必须要注意几点：
    第一消灭第六意识的妄念。要根据文字般若，生起正见，能分别是非，分别善恶，分别邪正，相信因果，这离不开文字般若。
    第二破除我执，破除烦恼。我执是根本烦恼，必须要以观照般若，修定才能破除，没有定是不行的，百千三昧都是一个定。
    第三要达到海印三昧，生起大圆镜智，必须彻底拔除异熟果报的根根，离开生死。生死分为两种生死，一种叫分段生死，一种叫变异生死。分段生死在菩萨修行的第二个阿僧祇劫——七地位断除俱生烦恼障才能结束。分段是什么？就是一辈子一辈子的分段受生，离开这个分段生死，七地以后，因为还有微细的所知障，现行和种子还在，第八地一直到十地，现行时起时伏，就象生死一样，在变异中，叫变异生死。必须离开两种生死，圆证佛果，才能够证得海印三昧，发出大圆镜智。
    有些人会说：这么深、这么高，我们怎么办得到呢？你不要怕，只要你深信三宝，深信因果，就开始走这条道路，逐步就可以提高，这是有阶段性的，如不经过踏实的修学功夫，那是不行的，所以法界观是佛在海印三昧中发生大圆镜智而说出来。你要学佛，就在你的日常生活中，能够静下来，善于观察，逐步提高，一个阶段一个阶段的上升，就没有多困难，你如果怕难就没有办法。


第六章　华严经组织

    全经组织从内容说是七处九会，包括了三十九品的内容，七处就是菩提场、普光法堂、忉利天宫、夜摩天宫、兜率天宫、他化自在天宫、重阁讲堂。普光法堂讲了三次，第二会、第七会、第八会都在普光法堂，第九会是重阁讲堂。七处九会，每一会都有说法主，包括说法内容，这七处九会包括了八十卷三十九品的内容，是很有组织，很有秩序的。
    另外就是摄九会以为四分：第一会从世主妙严品至毗卢遮那品，有六品十一卷，为举果劝乐生信分；从第二会如来名号品至第七会如来出现品，有三十一品四十一卷，名修因契果生解分；第八会离世间品，有一品七卷，名托法进修成行分；第九会入法界品，二十一卷，名依人证入成德分。
    根据以上内容，有两个表，我现在综合讲一下。

    第一会:菩提场/诸佛和普贤/说如来依报因果

    第一会：世主妙严品以下，共六品，地点在菩提场，普贤菩萨为会主。
    所谓第一会，就是第一次集会，是释迦佛在菩提树下成道以后，现毗卢遮那的身，在印度摩揭陀国阿兰若菩提场中，放光，放眉间光、齿光。眉间光就是眉间放白毫光，齿光就是牙齿放光，入于毗卢遮那藏身三昧，此时是以普贤菩萨为会主，因为普贤菩萨具有大愿、大智慧，他就是毗卢遮那的代言人，为四十一位法身大士说法。
    是哪四十一位？十住、十行、十回向、十地，加上等觉菩萨，共四十一位。这个甚深之法，是为法身大士讲，说明是菩萨境界。讲佛果的正报庄严、依报庄严，显示佛果的功德。其中共有六品：世主妙严品、如来现相品、普贤三昧品、世界成就品、华藏世界品、毗卢遮那品。经文有十一卷，八十卷中的最初的十一卷，其中宣说演扬如来依报、正报，因位果报的境界。说法的目的是使众生兴起敬慕，而生起信心。这必须要有智慧的认识，以文殊菩萨的智慧生起大用，使众生对于佛果功德，由欢喜而敬仰，生起信心。在四分中属于举果劝乐生信分，在五宗中属于所信因果宗（澄观大师将其总括：全经分为四分，又分为五宗，四分是从信解行证来分的，五宗就是从教理行果来分的）。
    普贤菩萨入于三昧，知道佛的依、正二报，对这个依、正二报的由来加以解说，说明往昔毗卢如来，居于华藏世界，此世界系因缘果满所现的依、正二报，由于在因行中修因广大，所获的果报也是无量无边。三世诸佛都以利益众生的因果来严净刹海，庄严佛土，所以目的是劝请后世众生，就象诸佛菩萨那样如法精进修行。修因才有果，这个果从菩萨行中饶益众生、难行能行得来的。

    第二会：普光法堂/文殊与十首/说十信法门
    第二会：如来名号品以下，地方是在普光法堂，说法主就是文殊与十首菩萨，说法内容是十信法门，一共六品：有如来名号品、四圣谛品、光明觉品、菩萨问明品、净行品、贤首品。卷数是四卷，普光明殿，就在离菩提树三里的恒河湾处，离菩提树不远，这也表现了佛开始说法，说菩萨行，开始建立信仰是不离人间的，成佛就是由凡夫开始，不是离开凡夫来成佛，也说明佛法是不离人间的。这里说十信法门。
    此时世尊放两足轮光，两足轮光是表法的，说明我们由修行种因到果，证得正觉果海，就必须脚踏实地，不是光嘴说，关键要行，理论与实践一致，愿行结合，只要这样，就可以一步步登上去。
    此时是以文殊菩萨为会主，文殊菩萨在四大菩萨中，智慧第一，所以佛法的信仰不是叫人盲目的信仰，必须认识了解佛的果德，这种果德，显示如来境界是广大的、真实的、平等的、清净的、慈悲的，这就是在心灵方面得了解脱，发出光辉，要认识这一点，就要生起信仰，要净化心灵，走佛的道路。在这方面就要有认识、抉择，佛法的信仰不是勉强叫你信，佛教徒从历史到现在从不拉人勉强信，这是佛教的特点，这个信仰必须由理智认识而产生。这一品由文殊菩萨首先出来，文殊菩萨具有无量智慧，就说明佛教的经典，必须要有正知正见，要有智慧，来了解、认识、信仰。

    第三会:忉利天宫/法慧菩萨/说十住法门

    第三会：地点是忉利天宫，说法主是法慧菩萨，说法内容为十住法门。一共有六品：升须弥山品、须弥顶上偈赞品、十住品、梵行品、初发心功德品、明法品。卷数有三卷，这里就是释迦佛以两足趾发光，以法慧菩萨为会主，入无量方便三昧。
    在这个地方，你们要注意两点：
    第一：一会、二会都在人间，现在由人间引向忉利天宫，忉利天宫是在四天王天上面，四天王天又在须弥山顶，这说明什么含义呢？就是由人间上升天上，希望把人的一切行动从污浊罪恶的凡夫世界，引向高尚清净的境界。在天上看到人间，凡尘扰扰，波浪滚滚。由五浊恶世，引向佛果，必须境界高尚，超尘出俗，达到高尚清净的境界。
    这里说的十住法门，十住就是代表具备的般若正见，与佛心相应，此时已发了菩提心，《华严经》讲：“一初发心，即成正觉”，说明重在发心，发心是了不起的，要发菩提心，发了菩提心，有这个因，就与佛的果海相应，故“因该果海，果彻因源”。菩提心就是：上成佛道，下化众生。要成佛道，必须救度众生，不离众生，才是成佛的基础，离开众生去成佛，那是不可能的，所以心境要广大，要站得高，看得远。
    第二：佛不单此时讲《华严经》在忉利天宫，在此之前，佛成道以后，就到过忉利天宫为母说法。佛诞生以后不久，他的母亲摩耶夫人就升上忉利天宫，佛长大是靠他的姨妈波阇波提哺养的。学佛就要讲孝道，这是根本，佛在成道以后，不忘父母恩，在宫中父王有病，亲自侍奉汤药，父王死了，亲自抬棺材，同时想到母亲生在忉利天宫，就升到忉利天宫为母亲说法，讲了一部《地藏经》。
    《地藏经》的内容一是说明儿女要尽孝道，比如婆罗门女、光目女两次进地狱寻母亲，她们是地藏菩萨前身；二是要发大愿，光目女听母亲说地狱的痛苦，地藏菩萨想到地狱苦，由地狱苦想到众生苦，于是由报母恩发展到报众生恩，特别是地狱里最苦的众生；三是说明因果业报，《地藏经》讲业报，讲因果，为什么人要堕地狱？堕三恶道，是有原因在其中，不是无缘无故的，这一点《地藏经》的《业报品》说了很多，要人人相信因果，不要造业；另外就是广修供养，设坛广陈鲜花、水果、灯烛为现在母亲忏悔，消灾免难，为先亡母亲超度。《地藏经》的内容说明佛教首先以报恩为本，报答四恩：三宝恩、父母恩、国家恩、众生恩，《地藏经》就是一部报恩经，又称孝经。

    第四会:夜摩天宫/功德林菩萨/说十行法门

    第四会:升夜摩天宫以下，地点是夜摩天，说法主是功德林菩萨，说法内容为十行法门。一共四品：升夜摩天宫品、夜摩宫中偈赞品、十行品、十无尽藏品。经文一共三卷。
    夜摩天在忉利天宫之上，又升了一层，夜摩天有个特殊情况，它不象忉利天以下的娑婆世界，有太阳、月亮、星星，夜摩天没有这些，是以莲花的开敷而分白天晚上，这说明什么？说明佛说法，菩萨度众生，要因机施教，因时制宜，因地制宜，就是要顺于世俗谛，顺于机宜，用现在话说要与时俱进，方便善巧。
    此时的说法主是功德林菩萨，说十行法门。功德林菩萨乘佛威神之力，入于菩萨善思惟三昧，受到十方诸佛的加被、摩顶，从定起来以后，就代表佛宣讲利益众生的十行法，这个十行法也代表由根本智生起普贤行。普贤行是差别智，根本智是与真谛相合，差别智与世俗谛相合，要明因识果，明了缘起法，悲智双运广度众生，所以就在行上表现。这种行就是要根据众生的根机进行说法、救度，这就是普贤行。

    第五会:兜率陀天/金刚幢菩萨/说十回向法门

    第五会：升兜率天宫品以下，地点是兜率天，说法主是金刚幢菩萨，说法内容为十回向法门。共三品：升兜率天宫品、兜率宫中偈赞品、十回向品。经文的卷数有十二卷。
    这里要了解几点：
    第一，兜率陀天又叫知足天，兜率陀天内院就是弥勒菩萨住的地方，尽管在天上，实际上区别于其他的欲界天，叫知足天，作到少欲知足，体现了菩萨的悲智双运，常处中道之中。
    第二，佛放两膝轮光，膝就是膝盖骨，人要走路，离不开膝盖骨，这个膝盖骨可上可下。人在行动中，上与下由膝盖骨做主，可以轮转。在菩萨行中，菩萨的行为是上承佛道，下化众生，菩萨就必须要有这种精神，这种心胸和行为。菩萨修行，有功而不自居为功。经过上面的十信、十住、十行以后，所有功德以悲心摄持，进行回向，不据为己有。
    这个十回向，重点是：
    1、回自向他。自己的功德不据为己有，回向给别人，你们居士在皈依以后，每天早晚要行持，行持有三个环节：一忏悔、二发愿、三回向。
    首先要忏悔，不忏悔就没有把自己身上洗干净，清净三业达不到，就不能接受善法，所以第一忏悔很重要。《普贤行愿品》里有忏悔业障，众生从多生累劫以来，堆积的业障不少，必须要忏悔，不单是早晚忏悔，随时随地都要反省、忏悔，身心才清净。
    二要发愿，要有广大的愿望，愿度众生，愿断烦恼，愿学佛法，要广行善法，愿成佛道。要发四弘誓愿，受持菩萨的三聚净戒，将志向端正过来，不能象世俗人一样，专门为名、为利、为家庭，要有悲心、有智慧而发菩萨愿，具有远大的愿望、崇高的理想。
    三就是回向，不管是念经、念佛、拜忏，完了以后要回向，不要据为己有，以此功德，回向一切众生，包括六亲眷属、师长朋友、冤家仇敌、一切众生，使他们都得到好处，这就是法布施。
    2、回因向果。要将种功德的因，回向得到菩提果报，要求菩提，不是为其他。
    3、回事向理。以这种行动达到最后契证真如境界，恢复妙觉明心，亦就是一真法界。
    第五会是金刚幢菩萨说法，金刚幢菩萨入菩萨智光三昧，出定以后就说十回向法门，金刚幢喻悲愿如金刚坚定。

    第六会:他化自在天/金刚藏菩萨/说十地法门

    第六会：十地品，地方是他化自在天，说法主是金刚藏菩萨，说法内容为十地法门。十地法门只有一品：十地品，共六卷。
    这里要说明几点：
    1、到了十地，就是由贤位进入圣位，小乘是三贤四圣，大乘三贤十圣。以上十住十行十回向，菩萨叫三贤：下贤、中贤、上贤，三贤以后，进入十地，从初欢喜地到第十法云地，都是圣位，而十地菩萨的行动是纯为利他，修行十度万行，中心以智为主，实践的果就是亲证真如，断一分障，证一分真，分分断，分分证，逐步升华。
    2、佛在此时放白毫光，白毫光就是佛果之光。阿弥陀佛赞，“白毫宛转五须弥”，那个范围大得很哪，五须弥只能说是一个数字，还没把这个数字说完，而这个光明遍照整个法界，只有佛才能有这样周遍法界的光明。另外说明一个问题：凡是开悟后进入欢喜地的菩萨，从初地菩萨到十地以后都有光明，因为开悟以后结合修行，智慧光明就发出来了，这种光明比声闻、缘觉、罗汉高，而且在十地中，一地一地的逐步升高，力量强大。
    3、此时金刚藏菩萨说法。何为金刚藏？菩萨第一就是要有四无量心：慈、悲、喜、舍。慈能予乐，悲能拔苦，见善随喜，平等施舍，这叫四无量心，四无量心发了以后，就象金刚一样的坚固，不能破坏，而且可以摧毁魔军，扫除一切障碍，坚如金刚，所以菩萨戒又叫金刚光明宝戒。因此学佛后不要怕这怕那，就看你发不发心，意志是否坚定，是否照着佛教导的去行，如果你真是意志坚定，信仰坚定，就不用怕，所以菩萨既有悲心，又有智慧，悲智为体，而地上菩萨特别偏重于智，智如金刚，也代表这个意思。

    第七会:普光法堂/普贤菩萨/说因圆果满法门

    第七次集会：十定品以下，地点是普光法堂，又到了人间，说法主为普贤菩萨，说法内容共十一品：十定品、十通品、十忍品、阿僧祇品、如来寿量品、诸菩萨住处品、佛不思议品、如来十身相海品、如来随好光明功德品、普贤行品、如来出现品。一共十三卷。
    从四分说，从如来名号品、四圣谛品，到普贤行品、如来出现品，叫第二修因契果深解分，这一分，经文有四十一卷，品数有三十一品，加上第一分的六品，到这里就是三十七品了。
    从五宗差别来分，这一段里有二十九品是属于因果差别宗，因不同则果不同，而三十一品的最后两品：普贤行品和如来出现品，在五宗中叫平等因果宗，以上是关于四分和五宗的分法。
    这一段要注意的是：说明从初发心，经历了五位：十信、十住、十行、十回向、十地，到这里，就做到因圆果满，这中间既说了等觉，又说了妙觉。如来放光，放眉间光及口光，眉间光、口光解说等觉、妙觉法，赞叹佛陀果行及智德二位的功用，进而谈到庄严报身的广大自在。
    但是妙觉并不离开本觉，本觉、始觉、妙觉是三位一体，有本觉才有始觉，有始觉才有妙觉，所以本始不二，这是《华严经》的中心，一经发心，就一定成佛果，这是相应的，这就是刚才说的“因该果海，果彻因缘”。你发了心，就把佛果包容进去了，就走上佛道了，果是如何来的，离不开因，念阿弥陀佛，一句佛号就包括阿弥陀佛的果德，佛果就贯彻这个因，因果相应，所以圣号功德很大，不但是念了净心，还有力量得到佛的加持，自力、他力合成这个功德。

    第八会:普光法堂/普贤菩萨/说普贤二千行法门

    第八次集会：离世间品，地点在普光法堂，说法主是普贤菩萨，说法内容为普贤二千行法门，只有一品：离世间品，经文一共七卷。
    在四分中是说法进修成行分，就是进一步修行，普贤二千行；在五宗中，就是成行因果宗，在行中有因就有果。
    为什么叫离世间品？就是说虽处世间，而对于世间的六尘，五欲境界，无所染着。佛在这里，没有放光，为什么呢？就是要了解世间一切微妙难信之法，需要透过最高的智慧光明，就是要自己心灵发光，而且结合在实践的体验上，才能够直接觉悟，说明这个道理。在禅定中发出最高的智慧，了解世间森罗万象，一切事事物物，这就是普贤菩萨的差别智。学佛就要靠自己的心灵发光，自己的亲身体验。普贤菩萨说二千行门，是根据根本智发出的后得智，解释世间上一切根本哲学问题，什么本体论、现象论、行为论哪，都包括在其中，内容很宽广。

    第九会:逝多林重阁讲堂/如来示相百城善友/说入法界法门

    第九会：入法界品，地点是逝多林重阁讲堂，说法主：一是如来示相二是百城善友，说法内容：入法界法门。此处只有一品：入法界品，经文卷数较多，共二十一卷。
    在四分中是以人证入成德分，事事要靠人，人不动也是不行的，善财童子走了一百多个地方，参访一百多位善知识，才有所收获，有所契证，成就他的果德，所以称“以人证入成德分”。在五宗中就是证入因果宗，实际有所修证，证入法界。
    入法界品，最重要的是由文殊菩萨指引善财童子五十三参，在经过中最重要的含义是：修行由渐到顿，最后才有顿，没有渐就没有顿，从本到末，必须由渐到顿。说明华严的宗旨：始末不二，因果不二，渐顿不二，这是大乘境界。妙明真心，人人具足，如何证一真法界？必须由渐到顿，由因到果，不要怕路长，要发心，发心以后要实践，只要肯实践，还是很快的。
    譬如念佛来说，不念佛就没有办法，只要肯发心念佛，依佛修行，与佛相应，就快得很，就怕自己不发心，不行动。本品声云如来入于狮子频申三昧，也叫狮子奋迅三昧，狮子一吼，百兽震惊，狮子就代表智慧很高，振聋发聩，具足大雄大力。在此时，经过修行，到了最后入于狮子奋迅三昧，就说明佛果境界一时顿证，有无限的威力，所以叫狮子奋迅三昧。

    这九次集会，从始到终，从最初两次说法在人间，以后又回到了人间，就体现了学佛法重视人间，不离人间，善财童子最后见了弥勒菩萨，弥勒菩萨发愿将来下生，龙华三会，也在人间。
    佛法不离人间！大家应该深刻体会：能够生在人间，是最殊胜的，为何？三恶道最痛苦，天界最快乐，快乐极了就要堕下来，只有在人间是苦乐参半，有苦就有道心，不会只图快乐，不会乐以忘忧，所以古代的圣者、贤者都有这个感叹，曹操说：“譬如朝露，去日苦多”，苏东坡说“人有悲欢离合，月有阴晴圆缺”。
    不能专门耽恋快乐，知道乐极生悲，只有人才有这个觉悟，在三恶道即便知道了也来不及了。有这个觉悟就可以升华，发大悲愿，发菩提心，上求佛道，下化众生。象地藏菩萨一样，救度三涂特别是地狱苦难众生。
    但是救度三恶道众生，必须在人间做好，如何做？要宣传弘扬佛法的道理，明因识果，制止人们贪嗔痴的发展，贪嗔痴的发展就是堕三恶道的原因。治病要治未病，不治已病，病已经发生了就麻烦，疾病需要预防，所以菩萨发心在人间修行，就是杜绝三恶道众生的恶因。尽管三恶道在冥间，实际上三恶道也在人间，嗔心重、痴心重、贪心重就是人间的地狱、饿鬼、畜生。所以佛菩萨来净化人间，弥勒菩萨将来的志愿也是净化人间，太虚法师提倡的人生佛教，也是基于这一点。
    净化人间，在人间使人们明因识果，止恶修善，修大悲心，进一步发菩提心，目标是成佛，这就是人间的殊胜。《华严经》七处九会说法就含有此意，所以《华严经》是最现实的。
    以上就把《华严经》的组织，七处九会的内容、重要点提出来了。


第七章 华严经精华举例

    《华严经》卷帙很多，意义深远，现仅就精华举例：华藏世界、文殊一百四十一愿、普贤十大愿和二千行、善财童子五十三参、弥勒楼阁。

    华藏世界

    《华严经》的重点是无尽的法界缘起，法界缘起里面讲四法界、十玄门、六相，这是大纲，这是《华严经》的教义精华所在。法界观是事事无碍法界，从现象界、事物界方面加以分析、观察，不脱离现实，不离开森罗万象，这其中包括心理现象、物理现象、自然现象，而这个法界观就是根据华藏世界将其发扬出来的。华藏世界就是毗卢遮那佛在历劫修行中，由于修菩萨行，所感的正报和依报。此依报既庄严，又伟大、崇高。
    我们现在所讲仅是根据经文提一下纲要，但此可言说的经文境界没达到佛的果地，从文字上看还是有限量的，经文所讲，仍是有限度的可思议的范围，而佛的果地，是不可思议、不可言说的境界。
    《华严经》里处处讲十，十信、十住、十行、十回向、十地，十无尽藏等，一切离不开十。十，是个无尽的数，重重无尽，代表无尽数，所以光从经文来了解，只能说是意识上的一个比量，很有限，不过从这里面可以了解一个大概，根据《华严经》讲：
    华藏世界所有尘，
    一一尘中见法界，
    宝光现佛如云集，
    此是如来刹自在。
    这说得很清楚，华藏世界，一一微尘，都有无边的法界，都有无边的诸佛，都有无量的圣贤境界，所以“宝光现佛如云集”，其中就是如来妙用自在的境界，这种境界是如来在往昔因中，为了救度众生，舍弃头目脑髓，难行能行，难忍能忍，而感得的一种果报。
    经云：“世尊往昔于诸有微尘佛所，修功德净业，故现种种宝光明，华藏庄严世界海”，这也说明这个原因：世尊在往昔多生累劫以来，是在微尘，就是无量无边，象微尘数一样，修行功德积累净业，所以由此功德积累，最后感得华藏庄严世界海，现种种宝光明，非常殊胜。没有这个因就没有果。
    经上又讲“华藏世界海，法界无差别，庄严悉清净，安住于虚空”，这说明法界庄严世界海，彼此相望没有差别，都很清净，其境界象虚空一样广大，无量无边，无尽庄严，都是由无尽的万行之因所感得的。只要修万行之因，根据真俗圆融，悲智兼运，做到这一点，就同佛一样，可以感得华藏庄严海，进入华藏世界，所以众生心就是佛心，众生与佛平等，佛可证，众生可证，要有这种心。
    以上就是以经文解释因果关系，无因不成果，因果相应。如何净心？如何修行？主要靠自己，由本觉到始觉，始觉到妙觉。本觉就是自己如何启发，人人都有一颗明珠，只不过明珠上面蒙了灰尘，被无明烦恼所障蔽，学佛就是把明珠上的尘垢打扫干净，由本觉到始觉，明珠发出光辉，恢复明珠的本来面貌，就是成佛。
    所以华藏世界的成因，是毗卢佛在过去多生累劫以来修六度万行，纯粹利益众生，现身尘刹，证佛果后，成就华藏世界海这个庄严依报。这个华藏世界，庄严美妙，非常之圆融、和谐、清净，也就体现了佛果本身的功德。
    下面就是华藏世界的相状，根据文字记述，实际上我们凡夫的第六意识的境界是很有限度的，根据经文记载，我们所能想象的也与实际情况差得远，因为这是佛的境界，不是众生的境界。
    此华藏世界中央有二十重，从一重到第二重，其远近距离，第一重就是一个佛刹微尘数的世界，第二重至三重，二重为二佛刹微尘数的世界，三重为三佛刹微尘数的世界，乃至二十重，为二十个佛刹微尘数的世界。从低到高，从一重到二十重，逐步增加，渐渐上升，远近数等，毗卢遮那佛就住在十三重，娑婆世界也在十三重，当然还有其他世界。形状就象三角形，平的一面在上面，尖的一头在下面，又象一把大伞，大伞是撑开的，由小到大。
    我想到《楞严经》楞严咒的咒心，在我当小和尚的时候，师父教我们念“摩诃悉怛哆般怛那”，据说这个咒心威力很大，楞严咒本来是降天魔，而咒心的力量是相等的，这是师父教的。
    楞严咒心“摩诃悉怛哆波怛那”，翻译成汉字，“摩诃”就是大，“悉怛哆”就是白，“波怛那”就是伞盖，具体名称就是“大白伞盖”。这个大白伞盖是形容佛的法、报、化三身的功德。“大”形容佛体，法界、真如、法性，体很广大，竖穷三际，横遍十方；“白”形容佛在相方面的功德，相很清净、很庄严、很方正，一般白形容干净；“伞盖”形容佛心、佛体的妙用，可以广生善法，广度众生，所以大白伞盖就形容毗卢遮那佛的体、相、用。
    我读华藏世界，读到这一段，觉得很适合，就象一个伞盖，形容佛的体大、相大、用大，就以这个为核心，毗卢遮那佛就在中间。二十重从下到上，一重至二十重，重重相连，广博严净。
    此华藏世界是在十重风轮上。此风轮上，是普光摩尼香水海，海出莲花，名光明蕊香幢，莲花周围就是金刚轮山，里面就是平面大地，平面大地庄严妙好，七宝合成，宝光灿烂，在中间又围绕很多香水海，香水海之间又有香水河，都是在莲花包围中，所以叫华藏。在这个境界之内，佛刹重重相连，奇妙无比，广博严净。
    又从平面数量来说，距二十重中心的周围，有十世界，十世界之外，又有十世界，就是百世界。一百一十世界种，各有所表，在顶外，还有四重世界，重重无尽，一重世界就是一个佛刹，包括微尘数的世界。我想到现在天文科学讲，已经发现的世界有一百亿个银河系，一个银河系是一千二百颗恒星，一颗恒星就是一个太阳系，在这些世界上，有生物世界，当然没有发现的更多，现在仅就发现的就有这些数字。
    佛经上讲：释迦佛在娑婆世界成佛以后，一个佛所管理的范围，就是三千大千世界。一个世界就是一个星球的地方，一个太阳系；千个世界就是一个小千世界；千个小千世界就是一个中千世界；千个中千世界就是一个大千世界；称为三千大千世界。这个范围不小，也就是很多的银河系在其中，单是一个佛土就有若干银河系，依华藏世界的数字算，是若干亿银河系，说不清楚，如此庞大。
    再总结代表的法义：这里说的是十重风轮之上，有香水海，其中有大莲花，大莲花中间有二十重，二十重周围又有十重，十重周围每一重又有十重，在外还有四重，从数字来表的法义是：外十重代表菩萨的五位，因位、果位各五位叫十位，五位就是十住、十行、十回向、十地、等觉，修菩萨行要经过五位，从因到果，五位有其因有其果，故称十重，十重外面各有十重，代表菩萨从因位果位之中修十波罗蜜：布施、持戒、忍辱、精进、禅定、智慧、方便、愿、力、智，叫十度万行。
    外面还有四重代表四摄法：布施、爱语、利行、同事，以十度自利利他，以四摄法饶益有情，这就是普贤菩萨修的。普贤菩萨在无量劫中难行能行，难忍能忍，众生无尽，悲愿无尽，所以最初讲的一佛三菩萨就把《华严经》的中心体现出来了的。一佛就是毗卢遮那佛，三菩萨就是文殊菩萨、普贤菩萨、弥勒菩萨，实际上四位一体，毗卢遮那佛就代表佛的果体，万德庄严；文殊菩萨代表智慧的根本之体，法界智、根本智；普贤菩萨代表用差别智即无漏有分别智，以此为体发挥悲心的妙用；弥勒菩萨代表即将成佛的果体，这个思想组成了《华严经》的中心。
    尽管说《华严经》是给四十一位法身大士讲的，实际上是给后世发菩萨心的众生讲的，只要有这个心，修这个行，种这个因，就能得这个果。人人都可以入华藏世界海，人人都可以成毗卢佛，这个思想是很伟大的。所以华藏世界海不是我们所想象得到的，只能从文字上初步体会。这种胜妙庄严，都是佛在因行中修悲、修智，修十度万行所感的果报，在华藏世界中还有婆娑世界，婆娑世界是一种染污世界、五浊世界，这说明佛菩萨不舍众生，在污泥中还要度众生的悲愿。
    《华严经》的法界观就是据此发扬出来的，这就是事事无碍法界世界相连，大小相容，重重无尽，而且这些境界都是广博严净，庄严和谐。建立法界观就是要在毗卢遮那佛的那种广大、真实、平等、清净、慈悲的心体之下，把有情世界和器世界融通起来，把器世界和有情世界的差别相、矛盾相消灭，统一起来，融合起来，所以在器世界中一切事相大小相入，一多相融，长短相入，大不离小，小不离大，一不离多，多不离一，长不离短，短不离长，互不相离，这就是一个人生宇宙充满和谐的世界，应这样观察。
    在讲六相时，比喻人体是一个总体，外有四肢百骸，内有五脏六腑，大大小小的器官不少，缺一个也不行，别说脏器肢节，就是一根毫毛、一颗牙齿也不能缺，缺了就有问题，拔一毫毛而动全身。所以一个人体要正常，就要保持和谐。从人类来说，就要互相分工合作，彼此相对，平等尊重。
    现在我们中国讲究建设和谐社会，其实《华严经》讲的就是一个和谐的宇宙观、法界观，消灭差别相、对立相。世间的辩证法难免差别对立，佛法的辩证法是消灭差别对立的，这是不同的，所以大家了解华藏世界，再回想前面讲的法界观，就可体会。

    文殊菩萨一百四十一愿

    文殊菩萨在四大菩萨中是智慧第一，《华严经》净行品里面，提出一百四十一愿，就体现文殊菩萨从智海中，结合生活对众生的悲愿。
    文殊菩萨在第一品里面，从智慧中了解佛果的功德，坚定信仰，发菩提心，从信仰中结合行动，行动就是从身、口、意三业中来表达愿望，把自私心、无明烦恼心逐步对治扫除，就可以从净愿成为净行，则在生活中、尘劳中不受染污，当前一切行为：对人对事，都成为清净的修行。
    文殊菩萨指示：坚定信仰以后，发菩提心，从愿力和实践中，使行为清净，以事入理，以真向俗，达到真俗圆融，理事无碍。文殊菩萨的一百四十一愿，是针对在家菩萨、出家菩萨讲的，在家的菩萨共十一愿，出家较多，共一百三十愿，包括出家、受戒、披剃、坐禅、托钵乞食、经行、起居坐卧各方面。
    其中十善业道戒通于在家出家，作为菩萨应该以大悲心为首，根据十善业，不作罪，不思罪，同时不离世间，不舍世间，要把出世道运用在世间法中，禅宗六祖慧能大师讲过“佛法在世间，不离世间觉”，《法华经》讲：“一切世间经书、治世语言、资生事业皆顺正法”。所以说在家菩萨、出家菩萨并不是离开尘世生活，只不过身心不同，特别是心。身在尘世，心在山林，心要清净，以这种心处理各项工作，过生活，处理事物就属于正道，故文殊菩萨最初讲“要善用其心”。
    这个问题最初是由智首菩萨提出来，智首菩萨问如何修行，如何修心？文殊菩萨答复：“善哉佛子，汝今为善多所饶益，多所安隐，哀悯世间，利乐天人，问如是义，佛子，若诸菩萨善用其心，则获一切胜妙功德，于诸佛法心无所碍，住去来今诸佛之道，随众生住，恒不舍离，入诸法相，悉能通达，当如普贤，色相第一，一切行愿皆能具足，于一切法无不自在，而利众生，作第二导师”。
    这段《华严经》的原文中有最重要的四个字：善用其心。不善用其心，一切行为都是邪的、恶的，不是正的，不是善良的，善用其心在行动上是正的，就象大海航船的舵手一样，航船不翻船，必须靠舵手，能够掌握方向，才能顺顺利利地到达彼岸。假如舵手方向迷失，船就触礁，容易沉没，就有危险，所以文殊菩萨告诉智首菩萨首先要善用其心，这一百四十一愿都是在善用其心的前题之下发的愿望，下面再引几段《华严经》的原文：
    “菩萨在家，当愿众生，知家性空，免其逼迫。”是说在家菩萨，虽处家要有正确观念，处家不恋家，要认识家也是变化的，知家性空。为何是变化的呢？终究要分散，从几千年历史看，哪个家保下来了？不管家庭以及其他什么物质，都是空的，因此要看淡放下，应尽的责任尽了，尽到心力就算了，不要一天到晚都在想，有些人到了呼吸上不来的时候还在想，那不划算。想得开就逍遥自在，想不开就披枷戴锁，故说“知家性空，免其逼迫”。
    “孝事父母，当愿众生，善事于佛，护养一切”，鼓励儿女要孝养父母，以孝为第一，但是要发愿：还要恭敬佛宝，善事于佛宝，要供养、恭敬、承侍，父母是我的肉身父母，佛是我们的法身父母，不要忘记，而且要度我们的父母，还离不开佛法，离不开佛，因此要念念恭敬佛。
    “妻子集会，当愿众生，怨亲平等，永离贪着”，在家难免有妻子，妻子集会，说明有缘，缘有顺缘，有孽缘，顺缘还好一点，孽缘就会有生不完的气，此时你就要会想：这都是缘，随缘满了就行，要做到冤亲平等，不要再结冤，这样你就不受系缚，贪爱心也就可以淡薄下来，怨亲平等，永离贪着。
    “若得五欲，当愿众生，拔除欲箭，究竟安乐”，五欲：财、色、名、食、睡，佛家讲生活要少欲知足，穿得暖吃得饱就行了，用不着贪，贪起来，过于追求，欲为苦本，就象箭射到身上不得了，要拔出欲箭，就不要有贪心，这样才安稳。这个红尘世界，一般人追求五欲，就造成很多混乱，痛苦不堪，有些搞得家破人亡，都是因为欲造成的，在家人要知足常乐，生活能够维持就行了。
    上面几段都是针对在家菩萨的，下面还有几段：
    “脱去俗服，当愿众生，勤修善根，舍诸罪轭”，就是说出家人将世俗服脱了，就愿意众生，多修善法，才能脱离苦厄。
    “剃除须发，当愿众生，永离烦恼，究竟寂灭”，在剃度时，要发愿，愿一切众生都远离烦恼，达到究竟寂灭清净的境界，须发就象烦恼一样，出了世俗家，还要出烦恼家、生死家，不然就不是真正出家，只是形式上的出家。
    “正身端坐，当愿众生，坐菩提座，心无所著”，在端坐的时候就象坐菩提座，佛坐菩提座修道就成佛，也希望一切众生，都能坐菩提座，内心无所贪恋，无所执著，达到究竟解脱，完成佛道。
    “洗浴身体，当愿众生，身心无垢，内外光洁”，在洗澡时，要发愿，希望一切众生达到身心清净，不单是表面清净，内心也要清净，内外光洁，庄严首先要内心庄严，配合外表庄严，只讲外不讲内，不是彻底的庄严。

    普贤菩萨十大愿和二千行

    普贤菩萨十大行愿专门有一品，是般若三藏翻译的，后来加到八十华严里面，就成为八十一卷，在八十卷中，也有专门的一品，讲普贤二千行，所以结合起来讲。
    普贤菩萨是《华严经》的枢杻，为什么呢？有信仰、有了解以后必须要结合行，信解行证要相应，如果解与行不相应，就不能证佛果，有行才能证得法身，才能实现真如的理体，所以在普贤菩萨身上，既代表愿行，也代表佛的真如理体。文殊菩萨与普贤菩萨是相应的，文殊菩萨代表解，普贤菩萨代表行，文殊菩萨代表智，普贤菩萨代表理。所以华严三圣：中间是毗卢遮那佛，左边文殊菩萨，右边普贤菩萨，是配合起来的。
    根据十大愿来讲，早晚课诵都有十大愿，诸佛菩萨的愿，就在十大愿中，结合修行，饶益众生。同时最重要的是十大愿配合普贤菩萨的四无尽：虚空无尽，众生无尽，众生烦恼无尽，众生业无尽，普贤菩萨的愿也无尽，这很伟大。
    十大愿是一者礼敬诸佛，二者称赞如来，三者广修供养，四者忏悔业障，五者随喜功德，六者请转法轮，七者请佛住世，八者常随佛学，九者恒顺众生，十者普皆回向。这十大愿不单是愿，还结合行，愿行结合，从学佛来说，不管在家菩萨、出家菩萨，都应以十大愿作为自己的功课。除了功课以外，要结合行持。
    一者礼敬诸佛。代表礼拜恭敬，这是很重要的，要提到第一位来讲，所以大家不要忽略，要拜佛，礼敬要做到三业礼敬：身体礼，口念，心观。礼这尊佛同时要观想礼十方诸佛，从礼敬中消灭罪恶，消灭妄念，消灭散乱，这个功用很大的，大家不要小看礼敬。
    解放前，四川省成都市有个昌圆老和尚，没有文化，他从皈依以后到出家学佛，除了劳动以外就是礼佛，经过很长一段时间，就在礼佛过程中开悟，开悟之后，他虽然没有文化，但能讲法，当时那些省政府的官僚，从省长一直到各个厅长，都皈依他，他的弟子很多，象隆莲法师（生于1909年，现仍健在，为四川尼众佛学院院长）就是他的弟子。
    大家都认为磕头很简单，真是这样的吗？不是的！你若能坚持磕头，就在磕头中使你脱胎换骨，由五蕴身改变成为莲花身，它的功用就有这么大。中国古代传统文化很讲礼，礼仪三百，威仪三千，处处讲礼，对父母要有礼，对兄长要有礼，对长辈要有礼，对朋友要有礼，对师长要有礼，各方面都有礼，走路要讲礼，座位要讲礼，无礼不成章，以礼法治国，所以中国文化能够发展几千年，就是讲礼节，礼敬诸佛很重要。
    二者称赞如来。称扬赞叹，赞扬如来的功德，不能象俗人一样毁谤、讥笑，那样做是罪业，在语言中，说话，与人谈话，要称扬如来，平常做佛事，念经、赞呗，都是称赞如来，以如来之言行作为我之言行，这种语言就是最高的语言，最有功德的语言。
    三者广修供养。供养有：财供养、法供养。财供养就是十种资财：香、花、灯、水、果，茶、食、宝、珠、衣；法供养就是如说修行，佛如何说的，你就照着办。《华严经》里讲广修供养，法供养有七种：如说修行供养、发菩提心供养、不舍众生供养、不舍菩萨业供养、代众生受苦供养等等。许多人认为供养香花灯叫供养，却不知法供养。佛说：一切布施中，法布施第一，一切供养中，法供养第一。
    四者忏悔业障。每天要忏悔，学佛法，走正道，必须首先洗净自己身心的污垢，清净三业，才能接受善法。忏悔是根本，我们做佛事，在家、出家受戒，首先就要忏悔，洗净身心，才能接受善法，忏悔必须以四种心：真实心、惭愧心、畏惧心、勇猛心，要以这四心来忏悔。
    真实心就是不虚假，在佛菩萨面前不能掺假，要真实忏悔，痛哭流涕，洗心革面。
    惭愧心就是做错了事，再不忏悔，继续这样下去，就对不起自己、师长、父母，要自惭，要愧对别人。惭愧心是善根之一，唯识法相里讲善心所就包括惭心、愧心，发了惭愧心就增长了善法，而且也是彻底斩断罪恶根源的最好方法，他不会再犯了，因为有惭愧心。世间上犯罪的人，一进宫、二进宫、三进宫，哪怕最后枪毙都不害怕，原因就是因为没有惭愧心，没有把病根挖除。
    畏惧心，畏惧我再不改悔，前途不妙，死了堕地狱、饿鬼、畜生，应该悬崖勒马。
    勇猛心，勇猛就是勇气鼓起来，快刀斩乱麻，从现在开始，绝对不犯，放下屠刀，立地成佛。
    要用这四种心来忏悔，至于忏法有两种：事忏、理忏。事忏就是针对某种罪忏悔，理忏就是达到内心清净，消除烦恼，从根本消除罪恶。
    五者随喜功德。见善随喜，见别人学法、礼拜三宝、护持三宝、周济贫穷、戒杀放生，不管大善、小善，大功德、小功德，要生起欢喜心，敬仰别人，称赞别人，而且跟别人学。不要障碍别人、嫉恨别人、诽谤别人。
    六者请转法轮。请佛说法，请转法轮，就是使众生的法身慧命得以延续，佛不在，对大德高僧、大善知识，也要请求他说法。法是人天眼目，法是指路明灯，法是苦海中的航船，非常重要。
    七者请佛住世。要请佛常住世间，佛住世间就是众生的福报，众生法身慧命才能延续，世界才有光明。佛不在世，要请佛的经典住世间，佛的经典是法身舍利，也等于佛，所以要尊重经典、恭敬经典，要学法，要尊重法，弘扬佛法，流通佛法。
    八者常随佛学。佛就是佛陀、如来，如来在因位时是怎样行的，如来在果位怎样以悲心利益众生，说法度生，我们都要学。
    九者恒顺众生。在生活上、行动上各方面，要随顺众生，满足众生的各项要求，满足众生的愿望，解决众生的困难，在《华严经普贤行愿品》上有四种：于病苦者为作良医、于失道者示其正路、于暗夜中为作光明、于贫穷者令得伏藏。
    第一于病苦者为作良医。对于病苦的人，要使他得到医药，救治他的病苦，要施医施药，侍侯他，医治他。问候病苦是最大的福田，菩萨戒里有这条。
    第二于失道者示其正路。别人失路要为其指点路，或者别人迷失了正道，走入了邪道，要将其挽转过来，指点他。
    第三于暗夜中为作光明。是在暗夜中能够指导别人看到光明、不迷失路，别人不懂佛法，要能对他解释真理，使他能够觉悟。
    第四于贫穷者令得伏藏。别人贫穷，缺乏资产，衣食困难，要想法为他解决，挽救他，使他免于困难，作菩萨的心要处处想到这些。
    十者普皆回向。以你功德回向给众生，进行法施，回向有三种：回自向他、回事向理、回因向果。回自向他是将自己的功德布施给别人，不要占为已有；回事向理，就是将自己的修行，能够由此而悟入真理，悟入真道，由世俗谛入胜义谛；回因向果，把这种因行回向能够证得无上菩提，而且愿众生都能证得无上菩提，不管从利益方面、功德方面、说法方面，还是从成佛的愿望方面，都想到众生，都回向众生。
    普贤愿行在《华严经》中很关键，是修华严妙行的枢杻，因为尽管前面讲了建立信仰，发菩提心，具般若慧，但是佛法是讲信解行证，这四个字前后是贯通相应的，缺一不行。特别是在行上，学佛的人最重要的是行，所以说普贤愿行是关键，是枢杻。
    为什么呢？有这么几句话：修一切行，就是十波罗蜜的六度万行；除一切障，就能够除一切障碍；积一切德，可以培积一切功德；成一切功，功行就逐步成就；见一切性，从性中证得佛性，毗卢遮那佛的真如性；证一切果，从行到果，先后就有连带关系。从这几句话可知行的重要，不能行，就不能除一切障，就不能积一切德，成一切功，不能见一切性，最后就不能证一切果。
    这个行就是根据如来的真心，融通在行上，真俗圆融，悲智兼运，难行能行，难忍能忍，只有这样，才能够证佛果，才能够证入一真法界。所以普贤菩萨既代表行，又代表所证的一真法界的理体，有首赞扬普贤菩萨的法身的偈：
    普贤法身遍一切，
    能为世间万象主。
    无始无终无生灭，
    性相常住等虚空。
    普贤菩萨既代表行，从行中证得毗卢遮那的理体，也就代表毗卢遮那佛的法身。此法身广大无边，遍满虚空，充塞法界。由法身的妙用，可以生起诸法，生起妙用，生起善因善果，此法身不是有为法，是无漏法，时间无始无终，空间无生无灭，性相常住等虚空，其体性，其相状，常住在世，广大无边，等同虚空。
    四川的峨嵋山就是普贤菩萨的道场，峨嵋山在《华严经》中叫光明世界，五台山叫清凉世界，为什么叫光明世界呢？因为峨嵋山顶现佛光，这大家都知道，很多人朝峨嵋山就想看到佛光。佛光很奇特，一个人站在那里，就看见一个人，而且有些人在佛光里看到菩萨相，青狮白象等。还有万盏明灯朝普贤，也代表光明，这是峨嵋山的奇景，这说明普贤菩萨由于他的行，他的果，智光普照，万德庄严。
    在第三十八品离世间品，进一步提出了普贤菩萨的二千行，离世间品就是专门叙述二千行。离世就是虽然在世间，而不受世间的污泥所染，修菩萨行就必须有这个条件，就象莲花一样，不被污泥所染，但是不舍污泥。这就是莲花行。
    在这一品中，法会中有个普慧菩萨提了二百个修行问题来问普贤菩萨，哪二百个？就是根据十信行、十住行、十行行、十回向行、十地行、因圆果满行（即等觉和妙觉行）来提出的。在十信行中提出二十个，十住行提出二十个，十行行提出了三十个，十回向行提出了二十九个，十地行提出五十个，因圆果满行提出五十一个。因圆果满称为等觉和妙觉，等觉三十二个，妙觉十九个。普慧菩萨一共提出了以上二百个问题，来问普贤菩萨。
    普贤菩萨很慈悲，不厌其烦的根据二百个问题，每个问题发挥开来又答复了十个，这样一共答出了二千个关于修行的问题，从十愿到二千行，数字很大，当然这只是代表数字。佛法为了对治八万四千尘劳，修八万四千大行，那是最高的数字，普贤菩萨为何叫大行？即体现大悲大愿的精神。

    善财童子五十三参

    善财童子，可能家家都知道，善财、龙女，观音菩萨左边善财，右边龙女。《西游记》将善财说成红孩儿、哪吒太子，那是神话。实际上华严会上的善财童子是很有根器的，是菩萨现身。龙女出自于《法华经》，法华会上，龙女成佛。所以学佛人，不要轻视一切人，一切众生，平等平等，不分别男女、老幼、尊卑、贵贱、贫富等等，也不要分别畜生等各种动物，一切有灵知、有感情、有心识的众生都是佛性平等的。社会上从过去到现在，轻视女性，从佛法来讲是错误的。《法华经》特别提出龙女成佛，龙女曾经亲近、礼拜过观音菩萨，所以成为观音菩萨的侍者。
    五十三参，代表参访五十三位善知识，这里体现出的意义是：
    第一，学佛的人要依止善知识，要广学多闻。
    第二，一切世间、出世间的学问，都要学。善慧地菩萨得四无碍解，首先就是法无碍解，即是通达一切世间、出世间法。在《瑜珈师地论》里讲要遍学五明：声明、工巧明、医方明、因明、内明，这些都要通达。
    有些人不了解，认为学佛就是拜佛、念佛就行了，还念什么经哪？念佛不学经，学佛不学经，这是错误的理解。学佛就是要深入经藏，智慧如海。善财童子就是一个榜样。
    他生长在印度的福城，当他降生的时候，满室祥光，满室珠宝，有这个吉兆，这就代表他来历不凡，特别有福报和慧根。成人以后，皈依三宝学佛，遍礼明师。
    在福城，一次他谒见文殊菩萨，文殊菩萨首先叫他发菩提心，其次叫他从此南行，参访各种善知识，广学经教。善财童子根据文殊菩萨的指示，开始南行，最后一直到弥勒楼阁，经历一百一十个城，在参访的经历过程中，参访的善知识有菩萨、声闻、缘觉；比丘、比丘尼、优婆塞、优婆夷；童男、童女；仙人、婆罗门、梵行者等等。还有撑船的船师，看病的医师，可以说各行各业都有。
    遇到观音菩萨，菩萨教他修慈悲大行；遇到罗汉，教他清净行，解脱行；遇到船师，教他好好掌舵，看风向；遇到医师，教他辨药性，开药方。因机对治，类似于此的内容很多，不胜枚举。这里特别要指出的是：在修行五位之中，这些大德除了以言说开示以外，还有以行动表示五位之法：十住、十行、十回向、十地、等觉。
    譬如，德云比丘就是代表十住行的，怎样为住？就是说学佛人信仰佛以后，心要安住，安住于禅定境界，在禅定境界中观照不二，同时不单坐着才是禅，行也可以叫禅，坐好了，坐惯了，养成静的功夫，在日常生活中，语默动静无非是禅，处处都在禅中，行也禅，坐也禅，语默动静皆安然。德云比丘一时坐在树下，一时东南西北漫步经行，所以德云比丘是代表住的境界。
    十行，有个善见比丘，在行动中体现修行妙境，他也是在林中慢步经行，出于自然，表示妙行无住，行而住，住而行，无住而住。
    第三，十回向。有个药香长者，是位居士，等于我们现在做香烛的，和合诸香，香做成功以后，供养三宝，叫药香长者。他代表以悲智心，运用悲智双修，真俗圆融，以此回向一切众生，一切法界，具体讲就是回自向他、回真向俗、回事向理、回因向果，代表即是要有和合精神。
    第四，十地。有位春生夜神示现女身，十地菩萨从初地开始，菩萨的精神纯粹是利他，菩萨万行，纯为利他，这是菩萨的功德、菩萨的殊胜，所以十地菩萨以大悲为主。大悲能够长养诸善法，能够出生佛种，万行殊胜。《华严经》的“华”就是莲花，莲花就是庄严佛果的因花。
    “菩提心为因，大悲为根本，方便为究竟”，这几句话是密宗《大日如来灌顶经》所讲，尽管是密宗讲，实际贯通于显密，一切佛法都贯通。作为一个学佛的，学大乘佛法的人，这三句要贯通，其中大悲为根本，是很重要的。
    昨天所讲到的莲花藏世界，这个华藏世界是最形象的。以事物来表现，风轮之上，香水海就是大莲花，大莲花就把华藏世界包完了，中间是二十层，从一到上，象伞盖一样，毗卢佛就在中间，娑婆世界也在其中，围绕中间的二十层，边上又有十层，十层边上又有百层，百层边上又有四层，一重就代表一个佛刹、微尘数世界，在层层佛刹之中，有金色、银色的宝阶和大地，有香气充满大海，在边上还有象金刚一样的金刚山，保护起来，外魔不敢侵，灾害不能犯，就是这样一个境界，很形象。
    这个世界就在大莲花包围之中，这个大莲花就是普贤的万行因花，以大悲为主，故大悲为根本，很重要。学佛就要修大悲心，没有大悲，菩提心不能增长，没有大悲，就不能结合行，就不能成佛果。所以十地就是因为菩萨有大悲心，可以长养善根，长养佛法，菩萨万行，由此而生，就象大地能够生长万物一样，故称之为地。
    第五，等觉和妙觉。十一地，等觉在此处，以摩耶夫人为代表，善财童子参访到摩耶夫人处。摩耶夫人是佛母，她代表的是佛体、佛的智慧、佛的大悲，在这个位置上，真如理体，大智妙用，大悲殊胜，三法合为一体，有此三法，如来就诞生，生长于如来，所以摩耶称为佛母就是这个意思。
    善财经此以后，到了弥勒楼阁。以上五位是表法，善财参见佛菩萨，除了学知识以外，还表法。五十三参也是表法，要经历五十三个阶段，最后才见弥勒楼阁。

    弥勒楼阁

    下面向大家介绍一下弥勒菩萨。一般人只知道四大名山，不知道还有另外一个名山，宁波奉化，四明山雪窦寺，雪窦寺在唐代末年五代时候就是弥勒降生应化的地方。现在每个大庙，一进山门的天王殿，塑的就是弥勒像。这尊弥勒像，满面笑容，大肚子，提个布袋，所以叫布袋和尚。
    当时弥勒降生以后，就现此相，法名契此，经常手提布袋，笑嘻嘻的化钱，有一次他向一位高僧化钱，高僧就说：你要化钱，你站着我问问你。高僧问：什么是本来面目？！弥勒菩萨不开腔，把口袋放下来。又问：什么叫向上一着？弥勒菩萨还是不开腔，将布袋提起来就往前走了。高僧说：还可以，弥勒菩萨不是一般人。弥勒为什么不回答呢？他当然会答，但他那样做是表法。弥勒经常背个布袋要钱，要东西，但很满足，不多要，很知足。他有很多奇异事情，临终时坐在石头上说了一首偈：
    弥勒真弥勒，
    分身百千亿。
    时时示世人，
    世人自不识。
    他圆寂以后，大家才知道他是弥勒菩萨下生。雪窦寺供奉的弥勒相就是他下生时的相，至于在兜率内院的相是天人相，北京雍和宫有个很高的弥勒像，就是天人相，天人相的弥勒菩萨就与文殊菩萨、观音菩萨、普贤菩萨差不多，头戴天冠，身披璎珞。
    弥勒翻译成中文叫慈氏菩萨，因为他在修菩萨行的时候，发愿修慈心定，觉得世间众生太可哀悯，世世生生修慈心定。慈与悲是联合起来的，慈能予乐，悲能拔苦，解决众生的苦难，不厌其烦。他又叫阿逸多尊者，为何叫阿逸多？翻译成中文叫无伦胜，就是慈心定很殊胜，无可伦比，所以叫无伦胜。他在佛的法会中、大乘经典里面都出现。
    叙述弥勒菩萨的事迹，大乘经典一共有三十多种，就象观音菩萨的事迹一样多。佛在世的时候，弥勒菩萨也在世，他的具体称呼就是“一生补处弥勒菩萨”，住在欲界天的兜率内院。兜率天分内院和外院，外院是一般天子、天女住的，内院就是菩萨住的，这个内院很清净庄严，是一个佛土。
    据经上记载，世界经过成、住、坏、空，到了空劫，大地不存在，欲界天、色界天都难免遭灾。火烧初禅，水淹二禅，风刮三禅，天人都要受灾，只有兜率天内院像佛土一样还存在。据古佛给弥勒授记，将来在一生以后，就继承释迦佛的位置为佛，时间是八百八十五万年以后，这是根据人间时间来算的。
    他成佛以后，就成为贤劫中的第五尊佛。那时的人间就与现在不同，人民皈依三宝，奉行五戒十善，风调雨顺，五谷丰登，人人丰衣足食，互相尊敬，路不拾遗，夜不闭户，和谐相处，是人间的净土。将来弥勒下生就是这么一个净土，此时弥勒菩萨成佛，在龙华树下三次大法会，称为龙华三会，一共度二百八十二亿人，这就是佛经记载的弥勒菩萨的情况。
    善财童子最后到达了弥勒楼阁，弥勒菩萨赞扬他：经历了一百一十城，参访了一百一十位善知识，其中最重要的是五十三参，经过这些善知识的教导，不辞厌倦，不怕艰苦，发菩提心。《华严经》赞扬善财发菩提心的内容很多，以二百二十一条比喻，来赞扬菩提心的功德，这在《华严经》的最后一品，占了很大的篇幅，赞扬善财童子发大菩提心，成于大慧，住于大悲，救护众生，因此在一生内，能够以甚深智慧入于法界，成就十波罗蜜的万行。
    然后是善财赞扬弥勒的功德，篇幅也很长，赞扬弥勒以后，就恭敬顶礼、右绕弥勒菩萨，说：“唯愿大圣，开楼阁门，令我得入”。我现在诚恳地希望大圣（对弥勒菩萨的尊称）把楼阁门打开，我想进楼阁。
    经文上记载：“尔时弥勒，前诣楼阁，弹指出声，其门即开，令善财入，善财欢喜，入楼阁门已，门即还闭”。当善财提出请求以后，弥勒菩萨就到门前，弹指出声，随着指声，弥勒楼阁门就开了。门打开以后，善财欢喜，进入楼阁，进入后，门就闭了。
    当善财进入楼阁以后，所见境界很奇妙：“善财尔时顿见楼阁之内，重重楼台，庄严宏伟，种种妙宝，种种奇异，种种殊胜不思议境界”。在顷刻之间，他置身在众楼阁之上，也就是说到处都是楼阁，到处都是善财，分身各处，礼拜诸佛。其实这时他已进入禅定境界，在禅定中，分身各处，礼拜诸佛，这个境界是微妙不可思议的。
    不久，弥勒就又弹指，之后善财出三昧定，出定后，弥勒就告诉他：“此是法性真如所显诸幻相，种种幻相重重无尽，由幻入真，因真显幻，无相而相，相而无相，真俗圆融，不可思议”。这句话很重要的，学佛就是在禅定中，要修如幻三昧。
    《金刚经》最后有一首偈：“一切有为法，如梦幻泡影，如露亦如电，应作如是观”。众生迷，就是迷在境界中，执著我有，执著境界有，因此生起种种妄念，心随境转，自己不能做主，因此无明烦恼障蔽，造业不止，受苦不止，在生死中轮转。
    能够了达外境如幻，从中就可以见空，见如来的法性。故《圆觉经》说：“知幻即离，离幻即觉”。这个如幻三昧，相当重要！大家注意，如能真修如幻三昧，把一切看空，一切放下，慢慢就知道了，心就能作主，不会随境转，六根就会为自己所用，不会被境界所用，这点很重要的。
    一切法界，菩萨观之也是如幻，从幻中才能了解真如境界，才能证真，假如不知道如幻，执着真以为真，在空中执空，着诸空相，那又错了，知空而不执空，三空：我空、法空、空空。不要执空，达到究竟寂灭的境界，这才是真如即一真法界。
    要这样必须修如幻三昧、无相三昧，相而无相，无相而相，真俗圆融。所以最后这一段，弥勒告诉善财的话，对于学佛来说也是相当重要的，能够知幻就知空，故真空妙有，妙有真空，就是中道实相。
    当弥勒告诉善财以后，接着又叫回见文殊菩萨，文殊菩萨赞扬善财以后，又叫他回见普贤菩萨，这是什么意思？弥勒代表自性根本智果，文殊代表自性光明的智体，由智体发妙用，才可以见到智果！普贤代表自性差别的智用，以差别智用才能发出无尽的大悲大愿，以此为因，与真如相应。有因有果，有体有用，因果不二，体用不二，三位一体，佛与众生都是三位一体的。
    有智果，有智用，有差别智，有根本智，由根本智发生差别智的妙用就是悲愿，众生都有。但是众生为什么在生死中，就是被无明烦恼障蔽，不能恢复。诸佛是背尘合觉，众生是背觉合尘，假使能够背尘合觉，象《华严经》这种次序讲的：由智慧妙用深信佛的果德，信了以后发菩提心，安住于般若智慧，修福德智慧资粮，以后入见道，入见道以后入十地修行，分分断障，分分证真，一直到等觉进入妙觉，证得毗卢遮那的果体。
    了解这个道理后就知道《华严经》是佛悲悯众生讲的，留下了这部珍贵的法宝，使我们建立菩萨圆融和谐的宇宙观，以佛的广大、真实、平等、清净、慈悲的体，来融通我们的心，也象佛一样，在众生境界中，达到理事无碍，在生活中、工作中，一切行动中，以佛心为心，以佛行为行，指导自己的行动。能够如此，也就是修普贤行，最后才能入于一真法界，人人都能成佛，众生都能成佛，则我们这个世界就是人间净土，是圆融和谐的世界，这是佛的慈悲。
    所以文殊菩萨显般若是由用归体，普贤菩萨显大行能够由体显用，弥勒菩萨显佛果，入大圆镜，清净无碍，朗照法界。本经要点就是这几个意思。
    讲到这里，回顾从八月二十七日到今天一共是九天。《华严经》卷轶很多，八十卷，三十九品，四万五千颂，依照经文讲可能要一年二年乃至若干年，现在九天讲完了经文提纲，因缘很殊胜。这次沉香阁纪念应慈老法师圆寂四十周年，举行法会，讲经也是重要的活动。从开讲以来，诸位居士们很整齐，用心地听，师父们做佛事，也很严肃，念诵很整齐，法音嘹绕，很感动人。还有我们常住老和尚、监院师、知客师等各位师父都很辛苦，关怀大家的生活。对于我关怀很细致，很耐心，我在此表示感谢，同时祝愿大家在佛光加持下，身体健康，平安吉祥，同登法藏玄门，共入毗卢性海!
    (录音整理：正航、正圆;文字编辑：正根)

    若需此书或者助印请联系惟贤法师著作编辑室 正根居士
    电话：010-89812999，13910754666
    邮件：tengyu333@vip.sina.com QQ：99811713
    网站：http://www.fojiao.org


附录：惟贤法师小传

上一页 目录 全书完

附录：惟贤法师小传

    惟贤法师，俗名邱兆红，四川省蓬溪县文井镇新林黑堡堰村（徐家湾）人，生于1920年农历5月21日。两岁时母亲去世，父亲不久又亡，少小失恃，全仗四姐邱兆莲抚养成人。少年惟贤过早地品尝到了人间的苦辛。
    他七岁时开始读私塾，三年便读熟了《四书》、《五经》。十至十二岁在蓬溪县白塔寺出家，拜定光法师为师，深得定光师爱护。出家后仍背着书包念完了小学，写出了《小沙弥的新年》一文载于当时的蓬溪县报上。十三岁至十五岁时，到四川南充集凤王恩洋先生创办的龟山佛学院学习。王恩洋先生在“如何做人，如何完成做人的品格”方面，给了他很大的启发，奠定了他深厚的儒学基础。
    1936年，惟贤法师到重庆缙云山，考入太虚大师创办、法尊法师主持教务的世界佛学苑汉藏教理院，成为汉藏教理院最年轻的一名学生。在汉藏教理院，他由普通班升至专修班，循序渐进地进行了系统的学习，打下了坚实的佛学基础。此时的惟贤，学识精深，才华横溢，诗文并茂，并会藏语、英语，他频频在《海潮音》、《佛化》周刊上发表唯识、因明诸多论文，深得太虚大师、法尊法师的喜爱和器重。尤其是太虚大师对惟贤耳提面命，更是给予了他极大的教益。
    1938年，法尊法师为惟贤授沙弥戒。
    1941年于汉藏教理院毕业，同时依止雪松法师受比丘戒，开始弘法事业，随雪松法师在开县创办了大觉佛学院，先后任教授、教务主任、副院长等职。同时创办并主编《大雄》月刊，著有《心经讲录》、《唯识纲要》、《因明纲要》、《淡泊诗集》、《大觉诗稿》、《中国佛教青年之前途》等著作和刊于全国佛教报刊杂志上的若干佛教学术论文。
    建国初，法师任重庆能仁寺佛化学校教导主任兼重庆市佛教协会筹备工作组秘书长。1954年蒙冤受屈，在铁窗里度过了二十六年零十个月的漫长岁月，法师靠的是患难中的真情和坚定不移的信仰撑过劫难。
    1980年，法师回到重庆慈云寺，领时命、顾大局、理万机，投入到弘法利生的繁忙工作中，先后创办“佛教希望工程”，成立“佛教慈善功德会”，创办“母亲工程”，开办僧伽培训班等。
    近二十多年来，老法师曾先后参访过日本、泰国、新加坡、韩国和美国等国家，多次参加佛教学术、佛教文化方面的交流会议。在传戒、讲经说法等弘法事业方面，除了重庆、四川各地以外，他还多次应邀到深圳、上海等地，先后讲过《般若波罗蜜多心经》、《观世音菩萨普门品》、《楞严经》、《阿弥陀经》、《大般若经》、《法华经》、《十善业道经》、《普贤行愿品》、《华严经》等经典，著作有《惟贤法师诗文集（全三辑）》、《般若与人生》（已出版）、《法华经说什么》（已出版）、《唯识札记》（已出版）等。
    2000年，老法师参访尼泊尔，任中国佛协代表团副团长。
    2002年7月19日（农历六月初十），日理万机的惟老在接电话时，不慎摔断了左腿，左腿股骨骨折了，做手术换了人造骨头，8月20日即能下地行走，9月16日居然还能来京参加中国佛教协会第七次全国代表大会！
    2005年，为了响应“构建一个和谐的社会主义社会”的号召，85岁高龄的惟老，来到北京，走进人民大学、北京大学、北京佛教文化研究所，就“佛教哲学的现实意义、佛法的弘扬与构建和谐社会”发表专题演讲。他谈到“和谐本身就是传统文化——儒家、道家、佛家的重要内容，要实现和谐，就必须要继承和发扬传统文化！”
    老法师精通三藏，深研经论，博学多闻，他亲近一代佛门领袖太虚大师将近十年，除了“立品立德立行”外，还深得太虚大师“八宗平等、人生佛教、菩萨学处”思想心印真传，始终如一的以太虚大师思想为指导，按照太虚大师的志向在努力，践行人间佛教。他极力强调佛法弘扬一定要因时制宜、因地制宜、因机制宜，无论何时何地一定要契机契理，与所处的社会形态、社会环境、社会背景相适应，在“菩提心为因，大悲为根本，方便为究竟”（此三句话出自密宗经典《大日如来灌顶经》）的原则指导下，发扬“莲花精神”，积极参与社会主义社会各项事业建设，为当前社会服务，为现实人生服务，启迪人生智慧，为人们消除烦恼，解除身心病苦。
    他不辞辛劳，为法忘躯，四处应邀传戒、讲学、参访、弘法，足迹遍及祖国的大江南北，为佛教事业的发展呕心沥血，为佛教人才的培养竭尽全力，为佛教慈善工作的开展四处呼吁，为构建和谐社会尽心尽力！其所到之处，作狮子吼，宣妙法音，处处展示着敏捷的才思、严密的逻辑和健康、饱满、与时俱进的精神。其才华横溢不减当年！其广博的悲心可昭日月！
    老法师丰富的学识，广大的慈悲心，超凡的智慧，圆融的佛学思想，被佛教学术界尊称为“当今唯识学泰斗”，当代佛门高僧。现担任中国佛教协会咨议委员会副主席、重庆市政协委员、重庆市佛教协会会长、重庆市佛学院院长、重庆市反邪教协会副会长、重庆慈云寺方丈等职务。

     惟贤法师著作编辑室
     联系人：正根居士
     电话：010-89812999 13910754666
     网站：http://www.fojiao.org
          http://www.cqcs.org
     邮箱：tengyu333@vip.sina.com
     Q Q： 99811713

上一页 目录 全书完