庐山慧远法师文钞

［民国］沙健庵、项智源编 [image] 清凉书屋点校

·2006.06·


远公大师像赞

缅维远公，乘愿再来。创立莲宗，畅佛本怀。
俾诸凡夫，忆念佛名。仗佛慈力，带业往生。
已断惑者，即证无生。证无生者，速圆佛乘。
以果地觉，为因地心。感应道交，利益甚深。
未见《涅槃》，即宣常住。未见《行愿》，普导西去。
其所立法，暗与经合。护法菩萨，表自大觉。
罗什举经，深加赞叹。西僧景仰，心香辄献。
千余年来，不闻圆音。幸有遗教，尚可遵循。
伏愿我公，又复示生。普引群伦，同登五清。
印公遗文，模公道貌。庶几来哲，是则是效。

            常惭愧僧释印光和南敬撰

·清凉书屋标点本·
2006.06


排印流通序

《晋莲宗初祖庐山慧远法师文钞》排印流通序

    如来大法，弥纶法界，包括空有，示本具之真心，显随缘之妙用。其心体则生佛一如，圣凡不二，真常不变，寂照圆融。佛以究竟证故，故得五蕴皆空，诸苦悉度，一尘不立，万德圆彰。众生以彻底迷故，故致迷真逐妄，背觉合尘，轮回生死，了无出期。于是如来，随众生机，说种种法，令彼各各就路还家，亲见本生之父母，探衣出珠，即获无尽之家珍。上根固得解脱，中下仍在轮回。特开净土法门，令其横超三界，普使中下，追踪上根。其为利益，莫能名焉！此义虽出《方等》，其道实肇《华严》，但以凡小不能预会，莫由禀承。当《华严》未来之前，率目为方便小道，迨《行愿》既译之后，方知为成佛真诠。
    庐山远公，宿承佛嘱，乘愿再来。未睹《涅槃》，即著法性常住之论。未见《华严》，便阐导归极乐之宗。立法暗与经合，其道普被三根。契理契机，彻上彻下，畅如来出世之本怀，了含识生死之大事。若非大权示现，其孰能预于此！故罗什法师曰：“经言：‘末后东方，当有护法菩萨。’勖哉仁者，善弘其事！”西域僧众，咸称汉地有大乘开士，辄东向稽首，献心庐岳。其神理之迹，未可测也。
    按远公于东晋孝武帝太元九年甲申，始至庐山，住同门慧永法师之西林寺。后以来学者多，西林隘不能容，故复开东林寺。经始之时，山神效灵，材木自至。刺史桓伊，乃为建造，名其殿为“神运”，表灵异焉。由是缁素高贤，来者益众。至太元十五年庚寅，七月二十八日，与缁素一百二十三人，结社念佛，求生西方。此诸人等，于临终时，皆有瑞应，皆得往生。良由诸人均具出类拔萃之智，又蒙远公开导，及诸友切磋琢磨之力，故获此益。此系最初结社之人。若终公之世，三十余年之内，其蒙法化而修净业，得三昧而登莲邦者，何可胜数。溯远公于太元九年甲申至庐山，于义熙十二年丙辰，八月初六日西逝，凡三十二年，影不出山，迹不入俗。其弘扬法化，护持佛教之著述，备载《庐山集》。以屡经沧桑，佚失殆尽。幸《弘明集》、《广弘明集》，各有所录，犹令古德芳徽，永传于世。
    如皋沙健庵太史，晚年笃信佛法，专修净业，博览群书，凡远公著述，及后人所作传、赞、记、颂等，悉备录之，题曰《慧远法师文钞》，分正、附二编。其门人项智源，又为补录，委光校订而排印焉。窃以远公为莲宗初祖，其书广布，阅者必能兴起。但以资斧不给，先印万册以为之倡，则后之源源相继而印者，又何可计其数耶！后之学者，由此书故，悉知净土法门之所以然，必至当仁不让，追踪先觉，同出五浊，同登九莲也。故于付排之前，略叙来历。至于远公之道德、功业、文章、感通，备载《文钞》正、附二编，兹不繁述。
    世传远公与十八高贤、一百二十三人结社。十八人中，远公居首，余十五人，多系最初结社之人。若佛驮跋陀罗，系安帝义熙二年始入社，乃结社后第十七年。佛驮耶舍，系义熙十年入社，乃结社后第二十五年。飞锡法师《宝王论》，谓远公从佛驮跋陀罗受念佛三昧，与缁素高贤结社念佛。盖尊西僧，而未详考其入社之年时耳。
    民国二十四年，岁次乙亥，孟夏月佛诞日，古莘释印光谨撰。


重编序

重编《庐山慧远法师文钞》序

    庐山初祖慧远法师遗集，见于《隋书·经籍志》，有十二卷。焦竑《国史·经籍志》，所载相同。《崇文总目》，记《庐山集》为十卷。《遂初堂书目》，标集，无卷数。《菉竹堂书目》，载《庐山集》，则仅云二册而已。兵燹荐遭，遗文散佚。
    民国九年，海门周居士紫垣，多方搜罗，得二十六篇，汇为一卷，于北平付印流通。逾岁，至如皋，以一册赠先师沙健庵先生。先生宏览，兼修净业，得之喜，犹以周居士所搜辑为未备。乃就家藏《全晋文》、《庐山志》诸书，详加搜讨，于居士所辑一卷二十六篇之外，增为三十四篇。依旧传重定目次，将钞录付印，未及为而病作，丙寅冬逝世。临终，遗命付智源续成之。翌年，大兵过境，沙氏举宅迁徙，而此重订未完之本，因之散失。智源旋赴北平三年，归而求之，终不可得。
    去秋八月六日，恭逢远公忌辰，忽闻此册于败簏中发现，欣往奉归，未暇整理。今秋，乃就先师所定目次，手自誊写。适《重修庐山志》出版，乃寓书沪上“影印宋版藏经会”本邑范成法师，请甄录志中所载远公遗文，以备参考。法师北上，转请同门费慧茂居士钞录见贻。智源就编纂吴先生所刊定，得增多五言四篇，合之先师所定，得三十八篇，列为正编。又先师所定附录传、记、诗、文、杂事，区为附编。于是远公之文，及其生平轶事，大略可观矣。
    时当末季，修道綦难，当机法门，莫逾净土。而世智辩聪之徒，或疑为浅近，谓非高文绩学之士所乐为。今观远公之文，工妙若此，而提倡莲宗，精进无倦，同社往生净土者，至百二十三人之多。则今日此编之出，既于宏道有关，而净土法门之重要，将因远公之高文而益显。读者可不折除骄慢，益加精进也乎！
    佛历二千九百六十一年，岁次甲戌，十月朔日，优婆塞菩萨戒弟子项智源谨撰。


总目

庐山慧远法师文钞总目

卷首　序目

    远公法像并赞　　排印流通序　　重编序　　总目

正 编

      论
    沙门不敬王者论　　沙门袒服论　　三报论　　明报应论（附桓玄问）　　法性论（《高僧传》二句）

      序
    庐山出《修行方便禅统经》序　 《大智论钞》序　 《阿毗昙心》序　　《三法度论》序　 《念佛三昧诗集》序

      记
    庐山记（附二则）

      铭颂赞
    万佛影铭　　澡罐铭序（铭轶）　　襄阳丈六金像颂　　昙无竭菩萨赞

      诗偈
    五言游庐山诗（此下五首，皆名“庐山东林杂诗”）　　庐山诸道人游石门诗　　奉和刘遗民诗　　奉和王乔之诗　　五言和张野诗　　报罗什法师偈

      书
    与刘遗民书（附刘《发愿文》）　　答戴安公书二篇（原书三篇附）　　通好流支法师书　　通好罗什法师书二篇（答书附）　　答王谧书（原书附）　　答卢循书　　答姚兴书（原书附）　　答桓玄书（劝罢道原书附）　　与桓玄论料简沙门书（原文附）　　答桓玄书（论沙门不应敬王者，原书附前，再书附后）　　答何镇南书（难《袒服论》原书附）　　答晋安帝书（复书附）　　遗诫

附 编
（附录传记等文）

      传
    慧远法师传一（《高僧传》）　　慧远法师传二（《莲社高贤传》，《佛祖统纪》同）　　慧远法师传三（《净土圣贤录》）

      碑记
    慧远法师碑（谢灵运）　　远公影堂碑（李演）　　远法师铭（张野）　　远公影堂记一（元皓）　　远公影堂记二（明教大师）　　远祖师事实（《莲宗宝鉴》）　　远祖师谥号（同上）　　十八大贤名氏（同上）　　东林寺碑（李邕）

      杂文
    与慧远法师书（法远）　　慧远法师诔（谢灵运）　　远公赞（陈谦）　　辨远祖成道事（《莲宗宝鉴》）　　智者大师奉晋王述匡山寺书（附晋王二书）

      诗
    远公龛诗（刘长卿）　　远公墓诗（灵彻）　　远公影堂诗（李中）　　十八贤影堂诗（贯休）　　远公北阁诗（罗邺）　　远公讲经台诗（祖咏）　　远公讲经台诗（王守仁）　　讲经台诗（阎而梅）

      杂事
    《世说新语》（二则）　　《杜诗注》　　嵩仲灵《钞书记》　　《竺法汰传》语　　周景式《庐山记》（二则）　　《庐阜杂记》　　陈舜俞《庐山记》　　黎崱《纪游集》　　桑乔《庐山纪事》（二则）　　《庐山志》（四则）　　远公年谱（七则）


沙门不敬王者论

庐山慧远法师文钞正编
江苏如皋沙元炳健庵氏编辑　 门人项智源敬录

沙门不敬王者论（五篇，并序）

（《弘明集》卷五，又略见《高僧传》卷六）

    晋成、康之世，车骑将军庾冰，疑诸沙门抗礼万乘。所明理，何骠骑有答。至元兴中，太尉桓公，亦同此义，谓庾言之未尽。《与八座书》云：“佛之为化，虽诞以茫浩，推乎视听之外。以敬为本，此出处不异。盖所期者殊，非敬恭宜废也。《老子》同王侯于三大，原其所重，皆在于资生通运。岂独以圣人在位，而比称二仪哉？将以天地之大德曰生，通生理物，存乎王者，故尊其神器，而礼实唯隆。岂是虚相崇重，义存弘（《与八座书》中作“君”）御而已哉？沙门之所以生，生资国存（《与八座书》中作“所以生生资存”，无“国”字），亦日用于理命。岂有受其德而遗其礼，沾其惠而废其敬哉？”
    于时朝士名贤，答者甚众，虽言未悟时，并互有其美。徒（一作“但”）咸尽所怀，而理蕴于情。遂令无上道服，毁于尘俗；亮到之心，屈乎人事。悲夫！斯乃交丧之所由，千载之否运。深惧大法之将沦，感前事之不忘，故著论五篇，究叙微意。岂曰渊壑之待晨露，盖是伸其罔极。亦庶后之君子，崇敬佛教者，式详览焉。

在家一

    原夫佛教所明，大要以出家为异。出家之人，凡有四科。其弘教通物，则功侔帝王，化兼治道。至于感俗悟时，亦无世不有。但所遇有行藏，故以废兴为隐显耳。其中可得论者，请略而言之。
    在家奉法，则是顺化之民，情未变俗，迹同方内。故有天属之爱，奉主之礼，礼敬有本，遂因之而成教。本其所因，则功由在昔。是故因亲以教爱，使民知其有自然之恩；因严以教敬，使民知其有自然之重。二者之来，实由冥应。应不在今，则宜寻其本。故以罪对为刑罚，使惧而后慎；以天堂为爵赏，使悦而后动。此皆即其影响之报，而明于教，以因顺为通，而不革其自然也。
    何者？夫厚身存生，以有封为滞累，根深蒂固，存我（一作“我倒”）未忘。方将以情欲为苑囿，声色为游观，耽湎世乐，不能自勉而特出。是故教之所检，以此为涯，而不明其外耳。其外未明，则大同于顺化，故不可受其德而遗其礼，沾其惠而废其敬。是故悦释迦之风者，辄先奉亲而敬君。变俗投簪者，必待命而顺动。若君亲有疑，则退求其志，以俟同悟。斯乃佛教之所以重资生，助王化于治道者也。论者立言之旨，貌有所同，故位夫内外之分，以明在三之志。略叙经意，宣寄所怀。

出家二

    出家则是方外之宾，迹绝于物。其为教也，达患累缘于有身，不存身以息患；知生生由于禀化，不顺化以求宗。求宗不由于顺化，则不重运通之资。息患不由于存身，则不贵厚生之益。此理之与形乖，道之与俗反者也。
    若斯人者，自誓始于落簪，立志形乎变服。是故凡在出家，皆遁世以求其志，变俗以达其道。变俗，则服章不得与世典同礼；遁世，则宜高尚其迹。夫然者，故能拯溺俗于沉流，拔幽根于重劫，远通三乘之津，广（《僧传》作“近”）开人天之路。如令一夫全德，则道洽六亲，泽流天下。虽不处王侯之位，亦已协契皇极，在宥生民矣。是故内乖天属之重，而不违其孝；外阙奉主之恭，而不失其敬。
    从此而观，故知超化表以寻宗，则理深而义笃。昭（一作“照”）泰息以语仁，则功末而惠浅。若然者，虽将面冥山而旋步，犹或耻闻其风。岂况与夫顺化之民、尸禄之贤，同其孝敬者哉！

求宗不顺化三

    问曰：寻夫老氏之意，天地以得一为大，王侯以体顺为尊。得一，故为万化之本；体顺，故有运通之功。然则明宗必存乎体极，体极必由于顺化。是故先贤以为美谈，众论所不能异。异夫众论者，则义无所取，而云不顺化，何耶？
    答曰：凡在有方，同禀生于大化，虽群品万殊，精粗异贯，统极而言，唯有灵与无灵耳。有灵则有情于化，无灵则无情于化。无情于化，化毕而生尽，生不由情，故形朽而化灭。有情于化，感物而动，动必以情，故其生不绝。其生不绝，则其化弥广而形弥积，情弥滞而累弥深，其为患也，焉可胜言哉？
    是故经称：“泥洹不变，以化尽为宅。三界流动，以罪苦为场。化尽则因缘永息，流动则受苦无穷。”何以明其然？夫生以形为桎梏，而生由化有。化以情感，则神滞其本，而智昏其照，介然有封，则所存唯己，所涉唯动。于是灵辔失御，生途日开。方随贪爱于长流，岂一受而已哉！是故反本求宗者，不以生累其神。超落尘封者，不以情累其生。不以情累其生，则生可灭。不以生累其神，则神可冥。冥神绝境，故谓之泥洹。泥洹之名，岂虚称也哉！
    请推而实之。天地虽以生生为大，而未能令生者不死。王侯虽以存存为功，而未能令存者无患。是故前论云：“达患累缘于有身，不存身以息患。知生生由于禀化，不顺化以求宗。”义存于此。义存于此，斯沙门之所以抗礼万乘，高尚其事，不爵王侯，而沾其惠者也。

体极不兼应四

    问曰：历观前史，上皇已来，在位居宗者，未始异其原本。本不可二，是故百代同典，咸一其统，所谓“唯天为大，唯尧则之”。如此，则非智有所不照，自无外可照。非理有所不尽，自无理可尽。以此而推，视听之外，廓无所寄。理无所寄，则宗极可明。今诸沙门，不悟文表之意，而惑教表之文，其为谬也，固已甚矣。若复显然有验，此乃希世之闻。
    答曰：夫幽宗旷邈，神道精微，可以理寻，难以事诘。既涉乎教，则以因时为检。虽应世之具，优劣万差，至于曲成，在用感即民心而通其分。分至，则止其智之所不知，而不关其外者也。若然，则非体极者之所不兼，兼之者不可并御耳。是以古之语大道者，五变而形名可举，九变而赏罚可言。此但方内之阶差，而犹不可顿设，况其外者乎？
    请复推而广之，以远其旨（一作“以通其类”）。“六合之外，存而不论”者，非不可论，论之或乖。“六合之内，论而不辩”者，非不可辩，辩之或疑。“《春秋》经世，先王之志，辩而不议”者，非不可议，议之者或乱。此三者，皆即其身耳目之所不至以为关键，而不关视听之外者也。因此而求圣人之意，则内外之道，可合而明矣。
    常以为道法之与名教，如来之与尧、孔，发致虽殊，潜相影响；出处诚异，终期则同。详而辩之，指归可见。理或有先合而后乖，有先乖而后合。先合而后乖者，诸佛如来则其人也。先乖而后合者，历代君王未体极之主，斯其流也。何以明之？经云：“佛有自然神妙之法，化物以权，广随所入，或为灵仙、转轮圣帝，或为卿相、国师、道士。若此之伦，在所变现，诸王君子，莫知为谁。”此所谓合而后乖者也。或有始创大业，而功化未就，迹有参差，故所受不同。或期功于身后，或显应于当年，圣王则之而成教者，亦不可称算。虽抑引无方，必归途有会。此所谓乖而后合者也。
    若令乖而后合，则拟步通途者，必不自崖于一揆。若令先合而后乖，则释迦之与尧、孔，发致不殊，断可知矣。是故自乖而求其合，则知理会之必同。自合而求其乖，则悟体极之多方。但见形者之所不兼，故惑众途而骇其异耳。
    因兹而观，天地之道，功尽于运化。帝王之德，理极于顺通。故虽曰道殊，所归一也。不兼应者，物不能兼爱也。（以上四句，从《高僧传》补。）若以对夫独绝之教、不变之宗，故不得同年而语其优劣，亦已明矣。

形尽神不灭五

    问曰：论旨以化尽为至极，故造极者必违化而求宗，求宗不由于顺化。是以引历代君王，使同之佛教，令体极之至，以权居（一作“君”）统。此雅论之所托，自必于大通者也。求之实当，理则不然。何者？夫禀气极于一生，生尽则消液而同无。神虽妙物，故是阴阳之所化耳。既化而为生，又化而为死。既聚而为始，又散而为终。因此而推，故知神形俱化，原无异统；精粗一气，始终同宅。宅全则气聚而有灵，宅毁则气散而照灭。散则反所受于天本，灭则复归于无物。反覆终穷，皆自然之数耳，孰为之哉？若令本异，则异气数合，合则同化，亦为神之处形，犹火之在木，其生必存，其毁必灭。形离则神散而罔寄，木朽则火寂而靡托，理之然矣。假使同异之分，昧而难明。有无之说，必存乎聚散。聚散，气变之总名，万化之生灭。故庄子曰：“人之生，气之聚，聚则为生，散则为死。若死若生，为彼徒苦，吾又何患？”古之善言道者，必有以得之。若果然耶，至理极于一生，生尽不化，义可寻也。
    答曰：夫神者何耶？精极而为灵者也。精极则非卦象之所图，故圣人以妙物而为言，虽有上智，犹不能定其体状，穷其幽致。而谈者以常识生疑，多同自乱，其为诬也，亦已深矣！将欲言之，是乃言夫不可言。今于不可言之中，复相与而依稀。
    神也者，圆应无生，妙尽无名，感物而动，假数而行。感物而非物，故物化而不灭。假数而非数，故数尽而不穷。有情则可以物感，有识则可以数求。数有精粗，故其性各异。智有明暗，故其照不同。推此而论，则知化以情感，神以化传。情为化之母，神为情之根。情有会物之道，神有冥移之功。但悟彻者反本，惑理者逐物耳。
    古之论道者，亦未有所同，请引而明之。庄子发玄音于《大宗》曰：“大块劳我以生，息我以死。”又以生为“人羁”，死为“反真”。此所谓知生为大患，以无生为反本者也。文子称黄帝之言曰：“形有靡而神不化，以不化乘化，其变无穷。”庄子亦有云：“特犯人之形，而犹喜若人之形，万化而未始有极。”此所谓知生不尽于一化，方逐物而不反者也。二子之论，虽未究其实，亦尝傍宗而有闻焉。论者不寻无方生死（一作“方生方死”，无“无”字）之说，而惑聚散于一化；不思神道有妙物之灵，而谓精粗同尽，不亦悲乎！
    火木之喻，原自圣典，失其流统，故幽兴莫寻。微言遂沦于常教，令谈者资之以成疑。向使时无悟宗之匠，则不知有先觉之明，冥传之功，没世靡闻。何者？夫情数相感，其化无端，因缘密构，潜相传写。自非达观，孰识其变？自非达观，孰识其会？请为论者验之以实。火之传于薪，犹神之传于形。火之传异薪，犹神之传异形。前薪非后薪，则知指穷之术妙。前形非后形，则悟情数之感深。惑者见形朽于一生，便以谓神情俱丧，犹睹火穷于一木，谓终期都尽耳。此曲从《养生》之谈，非远寻其类者也。
    就如来论，假令神形俱化，始自天本；愚智资生，同禀所受。试问所受者，为受之于形耶？为受之于神耶？若受之于形，凡在有形，皆化而为神矣。若受之于神，是以神传神，则丹朱与帝尧齐圣，重华与瞽瞍等灵，其可然乎？其可然乎？如其不可，固知冥缘之构，著于在昔；明暗之分，定于形初。虽灵钧善运，犹不能变性之自然，况降兹已还乎？验之以理，则微言而有征。效之以事，可无惑于大道。（按《高僧传》作：“五曰形尽神不灭，谓识神驰骛，随行东西也。”）

    论成后，有退居之宾，步朗月而宵游，相与共集法堂。因而问曰：“敬寻雅论，大归可见，殆无所间。一日试重研究，盖所未尽，亦少许处耳。意以为沙门德式，是变俗之殊制，道家之名器。施于君亲，固宜略于形敬。今所疑者，谓甫创难就之业，远期化表之功，潜泽无现法之效，来报玄而未应。乃今王公献供，信士屈体。得无坐受其德，陷乎早计之累；虚沾其惠，贻夫素餐之讥耶？”
    主人良久乃应曰：“请为诸贤近取其类。有人于此，奉宣时命，远通殊方九译之俗。问王者以当资以糇粮，锡以舆服否？”
    答曰：“然。”
    主人曰：“类可寻矣。夫称沙门者何耶？谓其能发蒙俗之幽昏，启化表之玄路。方将以兼忘之道，与天下同往，使希高者挹其遗风，漱流者味其余津。若然，虽大业未就，观其超步之迹，所悟固已弘矣。然则运通之功、资存之益，尚未酬其始誓之心，况答三业之劳乎？又斯人者，形虽有待，情无近寄，视夫四事之供，若蟭蚊之过乎其前者耳。濡沫之惠，复焉足语哉？”
    众宾于是始悟冥途以开辙为功，息心以净毕为道。乃欣然怡襟，咏言而退。
    晋元兴三年，岁次阏逢，于时天子蒙尘，人百其忧。凡我同志，佥怀缀旒之叹，故因述斯论焉。


沙门袒服论

（《弘明集》卷五）

    或问曰：沙门袒服，出自佛教，是礼与？
    答曰：然。
    问曰：三代殊制，其礼不同，质文之变，备于前典。而佛教出乎其外，论者咸有疑焉。若有深致，幸诲其未闻。
    答曰：玄古之民，大朴未亏，其礼不文。三王应世，故与时而变。因兹以观，论者之所执，方内之格言耳。何以知其然？中国之所无，或得之于异俗，其民不移，故其道未亡。是以天竺国法，尽敬于所尊，表诚于神明，率皆袒服，所谓去饰之甚者也。虽记籍未流兹土，其始似有闻焉。佛出于世，因而为教，明所行不左，故应右袒。何者？将辨贵贱，必存乎位，位以进德，则尚贤之心生。是故沙门越名分以背时，不退己而求先。
    又人之所能，皆在于右，若动不以顺，则触事生累。过而能复，虽中贤犹未得，况有下于此者乎？请试言之。夫形以左右成体，理以邪正为用。二者之来，各乘其本。滞根不拔，则事求愈应。而形理相资，其道微明。世习未移，应微（一作“征”）难辨。袒服既彰，则形随事感，理悟其心。以御顺之气，表诚之体。而邪正两行，非其本也。
    是故世尊以袒服笃其诚而闲其邪，使名实有当，敬慢不杂。然后开出要之路，导真性于久迷。令淹世之贤，不自绝于无分；希进之流，不惑途而旋步。于是服膺圣门者，咸履正思顺，异迹同轨。缅素风而怀古，背华俗以洗心。寻本达变，即近悟远，形服相愧，理深其感。如此，则情化专向，修之弗倦，动必以顺，不觉形之自恭。斯乃如来劝诱之外因，敛粗之妙迹。而众谈未喻，或欲革之，反古之道，何其深哉！


三 报 论
（因俗人疑善恶无现验作）

（《弘明集》卷五）

    经说：“业有三报，一曰现报、二曰生报、三曰后报。”现报者，善恶始于此身，即此身受。生报者，来生便受。后报者，或经二生、三生、百生、千生，然后乃受。受之无主，必由于心。心无定司，感事而应。应有迟速，故报有先后。先后虽异，咸随所遇而为对。对有强弱，故轻重不同。斯乃自然之赏罚，三报之大略也。非夫通才达识，入要之明，罕得其门。降兹已还，或有始涉大方，以先悟为蓍龟；博综内籍，反三隅于未闻；师友仁匠，习以移性者，差可得而言。请试论之。
    夫善恶之兴，由其有渐，渐以之极，则有九品之论。凡在九品，非其现报之所摄，然则现报绝夫常类，可知。类非九品，则非三报之所摄。何者？若利害交于目前，而顿相倾夺，神机自运，不待虑而发。发不待虑，则报不旋踵而应。此现报之一隅，绝夫九品者也。
    又三业殊体，自同有定报。定则时来必受，非祈祷之所移，智力之所免也。将推而极之，则义深数广，不可详究。故略而言之，想参怀佛教者，有以得之。
    世或有积善而殃集，或有凶邪而致庆，此皆现业未就，而前行始应。故曰“贞祥遇祸，妖孽见福”，疑似之嫌，于是乎在。何以谓之然？或有欲匡主救时，道济生民，拟步高迹，志在立功，而大业中倾，天殃顿集。或有栖迟衡门，无闷于世，以安步为舆，优游卒岁，而时来无妄，运非所遇，世道交沦，乖其闲习。或有名冠四科，道在入室，全爱体仁，慕上善以进德，若斯人也，含冲和而纳疾，履信顺而夭年。此皆立功立德之舛变，疑嫌之所以生也。
    大义既明，宜寻其对。对各有本，待感而发。逆顺虽殊，其揆一耳。何者？倚伏之契（一作“势”），定于在昔，冥符告命，潜相回换。故令祸福之气，交谢于六府；善恶之报，舛互而两行。是使事应之际，愚智同惑，谓积善之无庆，积恶之无殃，感神明而悲所遇，慨天殃之于善人。咸谓名教之书，无宗于上，遂使大道翳于小成，以正言为善诱，应心求实，必至理之无此。原其所由，由世典以一生为限，不明其外。其外未明，故寻理者，自毕于视听之内。此先王即民心而通其分，以耳目为关键者也。如令合内外之道，以求弘教之情，则知理会之必同，不惑众途而骇其异。若能览三报以观穷通之分，则尼父之不答仲由，颜、冉对圣匠而如愚，皆可知矣。
    亦有缘起而缘生法，虽预入谛之明，而遗爱未忘，犹以三报为华苑，或跃而未离于渊者也。推此以观，则知有方外之宾，服膺妙法，洗心玄门，一诣之感，超登上位。如斯伦匹，宿殃虽积，功不在治，理自安消，非三报之所及。因兹而言，佛经所以越名教、绝九流者，岂不以疏神达要，陶铸灵府，穷源尽化，镜万象于无象者哉！


明报应论

明报应论二篇
（答桓南郡，来问二附）

（《弘明集》卷五）

    问曰：佛经以杀生罪重，地狱斯罚，冥科幽司，应若影响，余有疑焉。何者？夫四大之体，即地、水、火、风耳。结而成身，以为神宅，寄生栖照，津畅明识。虽托之以存，而其理天绝。岂唯精粗之间，固亦无受伤之地。灭之既无害于神，亦由灭天地间水火耳。
    又问：万物之心，爱欲森繁，但私我有己，情虑之深者耳。若因情致报，乘感生应，则自然之道，何所寄哉？
    答曰：意谓此二条，始是来问之关键，立言之津要。津要既明，则群疑同释。始涉之流，或因兹以悟。可谓朗滞情于常识之表，发奇唱于未闻之前。然佛教深玄，微言难辩，苟未统夫旨归，亦焉能畅其幽致？当为依傍大宗，试叙所怀。
    推夫四大之性，以明受形之本，则假于异物，托为同体，生若遗尘，起灭一化，此则慧观之所入，智刃之所游也。于是乘去来之自运，虽聚散而非我。寓群形于大梦，实处有而同无。岂复有封于所受，有系于所恋哉！若斯理自得于心，而外物未悟，则悲独善之无功，感先觉而兴怀。于是思弘道以明训，故仁恕之德存焉。若彼我同得，心无两对，游刃则泯一玄观，交兵则莫逆相遇。伤之岂唯无害于神，固亦无生可杀。此则文殊按剑，迹逆而道顺，虽复终日挥戈，措刃无地矣。若然者，方将托鼓舞以尽神，运干戚而成化。虽功被犹无赏，何罪罚之有耶？
    若反此而寻其源，则报应可得而明，推事而求其宗，则罪罚可得而论矣。尝试言之：夫因缘之所感，变化之所生，岂不由其道哉？无明为惑网之渊，贪爱为众累之府。二理俱游，冥为神用，吉凶悔吝，唯此之动。无明掩其照，故情想凝滞于外物。贪爱流其性，故四大结而成形。形结则彼我有封，情滞则善恶有主。有封于彼我，则私其身而身不忘。有主于善恶，则恋其生而生不绝。于是甘寝大梦，昏于同迷，抱疑长夜，所存唯著。是故失得相推，祸福相袭。恶积而天殃自至，罪成则地狱斯罚。此乃必然之数，无所容疑矣。何者？会之有本，则理自冥对。兆之虽微，势极则发。是故心以善恶为形声，报以罪福为影响。本以情感，而应自来。岂有幽司，由御失其道也。然则罪福之应，唯其所感，感之而然，故谓之自然。自然者，即我之影响耳。于夫主宰，复何功哉？
    请寻来问之要，而验之于实。难旨全许地、水、火、风结而成身，以为神宅，此即宅有主矣。问主之居宅，有情耶？无情耶？若云无情，则四大之结，非主宅之所感。若以感不由主，故处不以情，则神之居宅无情，无痛痒之知。神既无知，宅又无痛痒以接物，则是伐卉翦林之喻，无明于义。若果有情，四大之结，是主之所感也。若以感由于主，故处必以情，则神之居宅，不得无痛痒之知。神既有知，宅又受痛痒以接物，固不得同天地间水、火、风，明矣。
    因兹以谈，夫形神虽殊，相与而化；内外诚异，浑为一体。自非达观，孰得其际耶？苟未之得，则愈久愈迷耳。凡禀形受命，莫不尽然也。受之既然，各以私恋为滞。滞根不拔，则生理弥固。爱源不除，则保之亦深。设一理逆情，使方寸迷乱，而况举体都亡乎？是故同逆相乘，共生仇隙，祸心未冥，则构怨不息。纵复悦毕受恼，情无遗憾，形声既著，则影响自彰。理无先期，数合使然也，虽欲逃之，其可得乎？此则因情致报，乘感生应。但立言之旨本异，故其会不同耳。
    问曰：若以物情重生，不可致丧，则生情之由，私恋之惑耳。宜朗以达观，晓以大方。岂得就其迷滞，以为报应之对哉？
    答曰：夫事起必由于心，报应必由于事。是故自报以观事，而事可变。举事以责心，而心可反。推此而言，则知圣人因其迷滞以明报应之对，不就其迷滞以为报应之对也。何者？人之难悟，其日固久。是以佛教本其所由，而训必有渐。知久习不可顿废，故先示之以罪福。罪福不可都忘，故使权其轻重。轻重权于罪福，则验善恶以宅心。善恶滞于私恋，则推我以通物。二理兼弘，情无所系，故能尊贤容众，恕己施安。远寻影响之报，以释往复之迷。迷情既释，然后大方之言可晓，保生之累可绝。夫生累者，虽中贤犹未得，岂常智之所达哉！


法 性 论

（此二句，录《高僧传》 ○按《出三藏记集》第十二，载陆澄《法论目录》，
著录《法性论》上、下篇。今全文散佚，此二句特撮其要耳。）

至极以不变为性，得性以体极为宗。


庐山出《修行方便禅统经》序
（《频伽藏》题作“庐山出《修行方便禅经》统序”）

（“庾伽遮罗浮迷”，译言“修行道地” ○《出三
藏记集》第九，在明《南藏》“迹”字函卷九）

    夫三业之兴，以禅、智为宗。虽精粗异分，而阶藉有方。是故发轸分逵，途无乱辙。革俗成务，功不待积。静复所由，则幽绪告微，渊博难究。然理不云昧，庶旨统可寻。试略而言：禅非智无以穷其寂，智非禅无以深其照。然则禅、智之要，照、寂之谓。其相济也，照不离寂，寂不离照。感则俱游，应必同趣。功玄于在用，交养于万法。其妙物也，运群动以至一而不有，廓大象于未形而不无。无思无为，而无不为。是故洗心静乱者，以之研虑；悟彻入微者，以之穷神也。若乃将入其门，机在摄会。理玄数广，道隐于文。则是阿难曲承音诏，遇非其人，必藏之灵府。何者？心无常规，其变多方。数无定像，待感而应。是故化行天竺，缄之有匠。幽关莫开，罕窥其庭。从此而观，理有行藏，道不虚授，良有以矣。
    如来泥洹未久，阿难传其共行弟子末田地，末田地传舍那婆斯。此三应真，咸乘至愿，冥契于昔，功在言外，经所不辨。必暗轨元匠，孱焉无差。其后有优波崛，弱而超悟，智绝世表。才高应寡，触理从简。八万法藏，所存唯要。五部之分，始自于此。因斯而推，固知形运以废兴自兆，神用则幽步无迹，妙动难寻，涉粗生异，可不慎乎？可不察乎？
    自兹以来，感于事变，怀其旧典者，五部之学，并有其人。咸惧大法将颓，理深共（一作“其”）慨。遂各述赞禅经，以隆盛业。其为教也，无数方便，以求寂然。寂乎唯寂，其揆一耳。而寻条求根者众，统本运末者寡。或将暨而不至，或守方而未变。是故经称满愿之德，高普事之风。原夫圣旨，非徒全其长，亦所以救其短。若然，五部殊业，存乎其人，人不继世，道或隆替，废兴有时，则互相升降，小大之目，其可定乎？又达节善变，出处无际，晦名寄迹，无闻无示，若斯人者，复不可以名部分。既非名部之所分，亦不出乎其外别有宗，明矣。
    每慨大教东流，禅数尤寡，三业无统，斯道殆废。顷鸠摩耆婆，宣马鸣所述，乃有此业。虽其道未融，盖是为山于一篑。欣时来之有遇，感寄趣于若人。舍夫制胜之论，而顺不言之辩。遂誓被僧那，以至寂为己任，怀德未忘，故遗训在兹。其为要也，图大成于末象，开微言而崇体。悟惑色之悖德，杜六门以寝患。达忿竞之伤性，齐彼我以宅心。于是异族同气，幻形告疏，入深缘起，见生死际。尔乃辟九关于龙津，超三忍以登位。垢习凝于无生，形累毕于神化。故曰：无所从生，靡所不生，于诸所生，而无不生。
    今之所译，出自达摩多罗，与佛大先。其人西域之俊，禅训之宗，搜集经要，劝发大乘，弘教不同，故有详略之异。达摩多罗，阖众篇于同道，开一色为恒沙。其为观也，明起不以生，灭不以尽。虽往复无际，而未始出于如。故曰：“色不离如，如不离色。色不离如（一无此句），色则是如。如不离色（一无此句），如则是色。”佛大先，以为澄源引流，固宜有渐。是以始自二道，开甘露门。释四义以反迷，启归途以领会。分别阴界，导以正观。畅散缘起，使优劣自辨。然后令原始反终，妙寻其极。其极非尽，亦非所尽，乃曰无尽，入于如来无尽法门。非夫道冠三乘，智通十地，孰能洞玄根于法身，归宗一于无相，静无遗照，动不离寂者哉！
    （按此经，在明《南藏》“荣”字函卷七，题作“达摩多罗禅经序”，无作序人名。又单序，在明《南藏》“迹”字函卷九，标名远公作。）


《大智论钞》序

（《出三藏记集》第十，在明《南藏》“迹”字函卷十）

    夫宗极无为以设位，而圣人成其能。昏明代谢以开运，而盛衰合其变。是故知险易相推，理有行藏。屈伸相感，数有往复。由之以观，虽冥枢潜应，圆景无穷，不能均四象之推移，一其会通。况时命纷谬，世道交沦，而不深根固蒂，宁极以待哉？若达开塞之有运，时来非由遇，则正觉之道，不虚凝于物表，弘教之情，亦渐可识矣。
    有大乘高士，厥号龙树，生于天竺，出自梵种。积诚曩代，契心在兹。接九百之运，抚颓薄之会，悲蒙俗之茫昧，蹈险迹而弗吝。于是卷隐衡门，云翔赤泽。慨文明之未发，思或跃而勿用。乃喟然叹曰：“重夜方昏，非萤烛之能照。虽白日寝光，犹可继以朗月。”遂自誓落簪，表容玄服。隐居林泽，守闲行禅。靖虑研微，思通过半。因而悟曰：“闻之于前论，大方无垠，或有出乎其外者。”俄而回步雪山，启神明以诉（一作“讯”）志，将历古仙之所游。忽遇沙门于岩下，请质所疑，始知有《方等》之学。及至龙宫，要藏秘典，靡不管综。滞根既拔，则名冠道位，德备三忍。然后开九津于重渊，朋鳞族而俱游。学徒如林，英彦必集。由是外道高其风，名士服其致，大乘之业，于兹复隆矣。
    其人以《般若经》为灵府妙门、宗一之道，三乘十二部由之而出，故尤重焉。然斯经幽奥，厥趣难明。自非达学，鲜得其归。故叙夫体统，辨其深致。若意在文外，而理蕴于辞，辄寄之宾主，假自疑以起对，名曰“问论”。其为要也，发轸中衢，启惑智门。以无当为实，无照为宗。无当，则神凝于所趣；无照，则智寂于所行。寂以行智，则群邪革虑，是非息焉。神以凝趣，则二谛同轨，玄辙一焉。非夫正觉之灵，抚法轮而再转，孰能振大业于将颓，纽遗纲之落绪，令微言绝而复嗣，玄音辍而复咏哉！虽弗获与若人并世，叩津问道。至于研味之际，未尝不一章三复，欣于有遇。其中可以开蒙朗照，水镜万法，固非常智之所辨。
    请略而言：生途兆于无始之境，变化构于倚伏之场，咸生于未有而有，灭于既有而无。推而尽之，则知有无回谢于一法，相待而非原。生灭两行于一化，映空而无主。于是乃即之以成观，反鉴以求宗。鉴明，则尘累不止，而仪像可睹。观深，则悟彻入微，而名实俱玄。将寻其要，必先于此。然后非有非无之谈，方可得而言。
    尝试论之：有而在有者，有于有者也。无而在无者，无于无者也。有有则非有，无无则非无。何以知其然？无性之性，谓之法性。法性无性，因缘以之生。生缘无自相，虽有而常无，常无非绝有，犹火传而不息。夫然，则法无异趣，始末沦虚，毕竟同争（疑当作“途”），有无交归矣。故游其奥者，心不待虑，智无所缘。不灭相而寂，不修定而闲。非神遇以期通，焉识空空之为玄？斯其至也，斯其极也。过此以往，莫之或知。
    又论之为体，位始无方而不可诘，触类多变而不可穷。或开远理以发兴，或导近习以入深。或阖殊途于一法而弗杂，或辟百虑于同相而不分。此以绝夫垒瓦（一作“叠凡”）之谈，而无敌于天下者也。尔乃博引众经，以赡其辞。畅发义音，以弘其美。美尽则智无不周，辞博则广大悉备。是故登其涯而无津，挹其流而弗竭，汪汪焉莫测其量，洋洋焉莫比其盛。虽百川灌河，未足语其辩矣。虽涉海求源，未足穷其邃矣。若然者，非夫渊识旷度，孰能与之潜跃。非夫越名反数，孰能与之澹漠。非夫洞幽入冥，孰能与之冲泊哉！
    有高座沙门，字曰童寿，宏才博见，智周群籍，玩服斯论，佩之弥久。虽神悟发中，必待感而应。于时秦主姚王，敬乐大法，招集名学，以隆三宝，德洽殊俗，化流西域，是使其人闻风而至。既达关右，即劝令宣译。童寿以此论深广，难卒精究，因方言易省，故约本以为百卷。计所遗落，殆过三倍。而文藻之士，犹以为繁，咸累于博，罕既其实。譬太羹不和，虽味非珍；神珠内映，虽宝非用。信言不美，固有自来矣。若遂令正典隐于荣华，玄朴亏于小成，则百家竞辩，九流争川，方将幽沦长夜，背日月而昏逝，不亦悲乎？
    于是静寻所由，以求其本。则知圣人依方设训，文质殊体。若以文应质，则疑者众；以质应文，则悦者寡。是以化行天竺，辞朴而义微，言近而旨远。义微则隐昧无象，旨远则幽绪莫寻。故令玩常训者，牵于近习；束名教者，惑于未闻。若开易进之路，则阶藉有由。晓渐悟之方，则始涉有津。远于是简繁理秽，以详其中，令质文有体，义无所越。辄依经立本，系以问论，正其位分，使类各有属。谨与同止诸僧，共别撰以为集要，凡二十卷。虽不足增晖圣典，庶无大谬。如其未允，请俟来哲。


《阿毗昙心》序
（晋太元十六年出）

（《出三藏记集》第十，在明《南藏》“迹”
字函卷十 ○又略见《世说·文学篇》注）

    《阿毗昙心》者，三藏之要颂，咏歌之微言。管统众经，领其宗会，故作者以“心”为名焉。有出家开士，字曰法胜，渊识远览，探（一作“极”）深研机。龙潜赤泽，独有其明。其人以为《阿毗昙经》，源流广大，难卒寻究。非赡智宏才，莫能毕综。是以探其幽致，别撰斯部。始自“界品”，讫于“问论”，凡二百五十偈，以为要解，号之曰“心”。其颂声也，拟象天乐，若云籥自发，仪形群品，触物有寄。若乃一吟一咏，状鸟步兽行也。一弄一引，类乎物情也。情与类迁，则声随九变而成歌。气与数合，则音协律吕而俱作。拊之金石，则百兽率舞。奏之管弦，则人神同感。斯乃穷音声之妙会，极自然之众趣，不可胜言者矣。
    又其为经，标偈以立本，述本以广义，先弘内以明外，譬由根而寻条。可谓美发于中，畅于四肢者也。发中之道，要有三焉：一谓显法相以明本，二谓定己性于自然，三谓心法之生，必俱游而同感。俱游必同于感，则照数会之相因。己性定于自然，则达至当之有极。法相显于真境，则知迷情之可反。心本明于三观，则睹玄路之可游。然后练神达思，水镜六府，洗心净慧，拟迹圣门。寻相因之数，即有以悟无。推至当之极，每（别本无“每”字）动而入微矣。
    罽宾沙门僧伽提婆，少玩兹文，味之弥久。兼宗匠本，正关入神。要其人情悟所参，亦已涉其津矣。会遇来游，因请令译。提婆乃手执梵本，口宣晋言，临文诫惧，一章三复。远亦宝而重之，敬慎无违。然方言殊韵，难以曲尽。倘或失当，俟之来贤。幸诸明哲，正其大谬。


《三法度论》序
（《频伽藏》作“三法度经”，兹从《清藏》改正）

（《出三藏记集》第十，在明《南藏》“迹”字函卷十）

    《三法度论》者，盖出《四阿含》。《四阿含》，则三藏之契经，十二部之渊府也。以三法为统，以觉法为道。开而当名，变而弥广。法虽三焉，而类无不尽。觉虽一焉，而智无不周。观诸法而会其要，辩众流而同其源。斯乃始涉之鸿渐，旧学之华苑也。
    有应真大人，厥号山贤，恬思闲宇，智周变通。感达识之先觉，愍后蒙之未悟，故撰此三法，因而名云。自“德品”暨于“所依”，凡三章九真度，斯其所作也。其后有大乘居士，字僧伽，先以为山贤所集，虽辞旨高简，然其文犹隐，故仍前人章句，为之训传。演散本文，以广其义，显发事类，以弘其美，幽赞之功，于斯乃尽。自兹而后，道光于世，其教行焉。于是振锡趣足者，仰玄风而高蹈。禅思入微者，挹清流而洗心。高座谈对之士，拟之而后言。博识渊有之宾，由之而赡闻也。
    有游方沙门，出自罽宾，姓瞿昙氏，字僧伽提婆。昔在本国，豫闻斯道，雅玩神趣，怀佩以游。其人虽不亲承二贤之音旨，而讽味三藏之遗言，志在分德，诲人不倦。每至讲论，嗟咏有余。远与同集，劝令宣译。提婆于是自执梵本，转为晋言。虽音不曲尽，而文不害意。依实去华，务存其本。自昔汉兴，逮及有晋，道俗名贤，并参怀圣典。其中弘通佛教者，传译甚众。或文过其意，或理胜其辞。以此考彼，殆兼先典。后来贤哲，若能参通晋、梵，善译方言，幸复详其大归，以裁厥中焉。


《念佛三昧诗集》序

（《广弘明集》卷三十九）

    夫称三昧者何？专思寂想之谓也。思专，则志一不分；想寂，则气虚神朗。气虚，则智恬其照；神朗，则无幽不彻。斯二者，是自然之玄符，会一而致用也。是故靖恭闲宇，而感物通灵。御心唯正，动必入微。此假修以凝神，积习以移性，犹或若兹。况乎尸居坐忘，冥怀至极，智落宇宙，而暗蹈大方者哉！请言其始，菩萨初登道位，甫窥玄门，体寂无为，而无弗为。及其神变也，则令修短革常度，巨细互相违，三光回景以移照，天地卷舒而入怀矣。
    又诸三昧，其名甚众，功高易进，念佛为先。何者？穷玄极寂，尊号如来，体神合变，应不以方。故令入斯定者，昧然忘知，即所缘以成鉴。鉴明，则内照交映，而万像生焉。非耳目之所暨，而闻见行焉。于是睹夫渊凝虚镜之体，则悟灵根（一作“相”）湛一，清明自然。察夫玄音以叩心听，则尘累每消，滞情融朗。非天下之至妙，孰能与于此哉！以兹而观，一觌之感，乃发久习之流覆，豁昏俗之重迷。若以匹夫众定之所缘，固不得语其优劣，居可知也。
    是以奉法诸贤，咸思一揆之契，感寸阴之颓影，惧来储之未积。于是洗心法堂，整襟清向，夜分忘寝，夙兴唯勤。庶夫贞诣之功，以通三乘之志，临津济物，与九流而同往。仰援超步，拔茅之兴。俯引弱进，垂策其后。以此览众篇之挥翰，岂徒文咏而已哉！


庐 山 记

（陈舜俞《庐山记》题为“庐山略记” ○又见《全晋文》）

    山在江州浔阳南，南滨宫亭（“宫亭”者，即《安清传》之“共阝亭”，见《高僧传》卷一），北对九江。九江之南为小江，山去小江三十里余。左挟彭蠡，右傍通州，引三江之流，而据其会。《山海经》云：“庐江出三天子都，入江彭泽西，一曰天子鄣。”故旧语以所滨为彭蠡。有匡续（《水经·庐江水篇》注，作“匡俗”）先生者，出自殷、周之际，遁世隐时，潜居其下。或云：续受道于仙人，而适游其岩，遂托室岩岫，即岩成馆，故时人感（《水经注》作“谓”）其所止，为神仙之庐，而名焉。
    其山大岭，凡有七重，圆基周回，垂五百里。风雨之所摅，江山之所带，高岩仄宇，峭壁万寻，幽岫穷崖，人兽两绝。天将雨，则有白气先抟，而缨络于山岭下。及至，触石吐云，则倏忽而集。或大风振岩，逸响动谷，群籁竞奏，其声骇人，此其化不可测者矣。
    众岭中，第三岭极高峻，人之所罕经也。太史公东游，登其峰而遐观，南眺五湖，北望九江，东西肆目，若登天庭焉。其岭下半里许，有重岩，上有悬崖，古仙之所居也。其后有岩，汉董奉复馆于岩下，常为人治病，法多神验。病愈者，令栽杏五株，数年之间，蔚然成林。计奉在人间，近三百年，容状常如三十时。俄而升仙，绝迹于杏林。
    其北岭两岩之间，常悬流遥沾，激势相趣，百余仞中，云气映天，望之若山有云雾焉。其南岭临宫亭湖，下有神庙，即以宫（《高僧传》作“共阝”）亭为号。其神安侯也，亭有所谓感化。（此间有阙文。○按安侯，即《高僧传》卷一，安清，字世高。共阝亭庙神，即高前生出家同学，现蒙高度脱者。言“其神安侯也”，文有误。“所谓感化”者，系说该庙神灵感等事。《僧传》载：高于灵帝末，游化中国，云：“我当过庐山，度昔同学。”行达共阝亭湖庙，同旅三十余船，奉牲请福。神降祝曰：“舫有沙门，可呼上。”客咸惊愕，请高入庙。神告曰：“吾昔与子俱出家学道，好行布施，性多瞋怒，今为庙神。以布施故，珍玩甚丰。以瞋恚故，堕此神报。今见同学，悲欣可言。此身灭后，恐堕地狱。吾有绢物，请立法营斋，使生善处。”高曰：“故来相度，何不出形？”神从床后出头，乃是大蟒。高梵语数番，赞呗数契。蟒悲泪如雨，须臾隐去。高取绢物，达豫章，为造东寺。高去后，神即命过。暮，一少年上船，长跪高前，受咒愿，忽不见。高曰：“少年即共阝亭庙神，得离恶形。”自是庙神歇矣，无复灵验。）
    七岭同会于东，共成峰崿。其岩穷绝，莫有升之者。昔野夫见人着沙弥服，陵云直上，既至，则踞其峰，良久乃与云气俱灭，此似得道者。当时能文之士，咸为之异。又所止多奇，触象有异。北背重阜，前带双流。所背之山，左有龙形，而右塔基焉。下有甘泉涌出，冷暖与寒暑相变，盈减经水旱而不异，寻其源，出自于龙首也。南对高峰，上有奇木，独绝于林表数十丈，其下似一层浮图，白鸥之所翔，玄云之所入也。
    东南有香炉山，孤峰独秀起。游气笼其上，则氤氲若香烟。白云映其外，则炳然与众峰殊别。将雨，则其下水气涌出如马车（《庐山志》，“马车”作“车马”是），盖此龙井之所吐。其左则翠林，青雀、白猿之所憩，玄鸟之所蛰。西有石门，其前似双阙，壁立千余仞，而瀑布流焉。其中鸟兽草木之美，灵药万物之奇，略举其异而已耳。

    附：《游山记》（《御览》四十一）
    自托此山，二十二载，凡再诣石门，四游南岭。东望香炉，秀绝众形。北眺九流，凝神览视。四岩之内，犹观之掌焉。传闻有石井、方湖，足所未践。
    自托此山，二十三载，再践石门，四游南岭。东望香炉峰，北眺九江。传闻有石井、方湖，中有赤鳞涌出。野人不能叙，直叹其奇而已矣。（《世说》）


万佛影铭

万佛影铭（并序）

（佛影今在西那伽诃罗国南山，古仙石室中。度流沙，从径道，去此
一万五千八百五十里。感世之应，详于前记也。 ○记失载。）

（《广弘明集》卷十六 ○又《高僧传》卷六，有铭无序）

    夫滞于近习，不达希世之闻。抚常永日，罕怀事外之感。是使尘想制于玄襟，天罗网其神虑。若以之穷龄，则此生岂遇。以之希心，则开悟靡期。于是发愤忘食，情百其慨。静虑闲夜，理契其心。尔乃恩沾九泽之惠，三复无缘之慈。妙寻法身之应，以神不言之化。化不以方，唯其所感。慈不以缘，冥怀自得。譬日月丽天，光影弥晖，群品熙荣，有情同顺。咸欣悬映之在己，罔识曲成之攸寄。妙物之谈，功尽于此。将欲拟夫幽极，以言其道，仿佛存焉，而不可论。
    何以明之？法身之运物也，不物物而兆其端，不图终而会其成。理玄于万化之表，数绝乎无形无名者也。若乃语其筌寄，则道无不在。是故如来，或晦先迹以崇基，或显生途而定体。或独发于莫寻之境，或相待于既有之场。独发类乎形，相待类乎影。推夫冥寄，为有待耶？为无待耶？自我而观，则有间于无间矣。求之法身，原无二统。形、影之分，孰际之哉！而今之闻道者，咸摹圣体于旷代之外，不悟灵应之在兹。徒知圆化之非形，而动止方其迹，岂不诬哉！
    远昔寻先师，奉侍历载。虽启蒙慈训，托志玄籍，每想奇闻以笃其诚。遇西域沙门，辄餐游方之说，故知有佛影，而传者尚未晓然。及在此山，值罽宾禅师，南国律学道士，与昔闻既同，并是其人游历所经，因其详问，乃多有先征。然后验神道无方，触像而寄，百虑所会，非一时之感。于是悟彻其诚，应深其信。将援同契，发其真趣，故与夫随喜之贤，图而铭焉。

    廓矣大象，理玄无名。体神入化，落影离形。回晖层岩，凝映虚亭。在阴不昧，处暗愈明。婉步蝉蜕，朝宗百灵。应不同方，迹绝而（一作“两”）冥。（其一）

    茫茫荒宇，靡劝靡奖。谈虚（“谈”，《僧传》作“淡”。《莲社高贤传》有“淡彩图写”语，“淡彩”颇当）写容，拂空传像。相具体微，冲姿自朗。白毫吐曜，昏夜中爽。感彻乃应，扣诚发响。留音停岫，津悟冥赏。抚之有会，功弗由曩。（其二）

    旋踵忘敬，罔虑罔识。三光掩晖，万象一色。庭宇幽蔼，归途莫测。悟之以静（《僧传》作“靖”），震（《僧传》作“开”）之以力。慧风虽遐，维尘攸（《僧传》作“假”）息。匪伊（《僧传》作“圣”）玄览，孰扇其极？（其三）

    希音远流，乃眷东顾。欣风慕道，仰规玄度。妙尽毫端，运微轻素。托彩虚凝（《僧传》作“淡”），殆映霄雾。迹以（《僧传》作“似”）像真，理深其趣。奇兴开襟，祥风引路。清气回于轩宇，昏明交而未曙。仿佛镜神仪，依稀若真遇。（其四 ○末四句，《僧传》作：“清气回轩，昏交未曙。仿佛神容，依稀钦遇。”）

    铭之图之，曷营曷求？神之听之，鉴尔所修。庶兹尘轨，映彼玄流。漱情（《僧传》作“清”）灵沼，饮和至柔。照虚应简，智落乃周。深怀冥托，霄（《僧传》作“宵”）想神游。毕命一对，长谢百忧！（其五）

    晋义熙八年，岁在壬子，五月一日，共立此台，拟像本山，因即以寄诚。虽成由人匠，而功无所加。至于岁次星纪赤奋若贞于太阴之墟，九月三日，乃详检别记，铭之于石。爰自经始，人百其诚，道俗欣之，感遗迹以悦心。于是情以本应，事忘其劳。于时挥翰之宾，佥焉同咏。咸思存远猷，托相异闻，庶来贤之重轨故备。时人于影集大通之会，诚非理所期。至于伫襟遐慨，固已超夫神境矣！


澡罐铭序

（《北堂书钞》百三十五 ○铭轶）

得摩罗勒石澡罐一枚，故以此铭答之。


襄阳丈六金像颂

襄阳丈六金像颂（并序）

（《广弘明集》卷十六）

    昔众祐降灵，出自天竺。托化王宫，兴于上国。显迹重冥，开辟神路。明晖宇宙，光宅大千。万流澄源，圆映无主。觉道虚凝，湛焉遗照。于是乘变化以动物，而众邪革心。跬神步以感时，而群疑同释。法轮玄运，三乘并辙。道世交兴，天人攸梦（疑误）。净音既畅（疑有脱文），逸响远流，密风遐扇。
    远生善教末，年垂千祀。徒欣大化，而运乖其会，弗获叩津妙门，发明渊极。魍魉神影，餐服至言。虽欣味余尘，道风遂迈。拟足逸步，玄迹已邈。每希想光晷，仿佛容仪，寤寐兴怀，若形心目。冥应有期，幽情莫发，慨焉自悼，悲愤靡寄！乃远契百念慎敬慕之思，追述八王同志之感。魂交寝梦，而情悟于中，遂命门人铸而像焉。夫形理虽殊，阶途有渐；精粗诚异，悟亦有因。是故拟状灵范，启殊津之心。仪形神模，辟百虑之会。使怀远者，兆玄根于来叶；存近者，遘重劫之厚缘。乃道福兼宏，真迹可践。三源反流，九神同渊。
    于时四辈悦情，道俗齐趣，迹响和应者如林。铸均有虚室之供，而进助者不以纤毫为挫。劝佐有弥劫之勤，而操务者不以昏疲告劳。因物任能，不日而成，功自人事，犹天匠焉。夫明志莫如词，宣德莫如颂。故志以词显，而功业可存。德以颂宣，而形容可像。匪词匪颂，将何美焉！乃作颂曰：

堂堂天师，明明远度。陵迈群萃，超然先悟。
慧在恬虚，妙不以数。感时而兴，应世成务。
金颜映发，奇相晖布。肃肃灵仪，峨峨神步。
茫茫造物，玄运冥驰。伟哉释迦，与化推移！
静也渊默，动也天随。绵绵远御，亹亹长縻。
反宗无像，光潜影离。仰慕千载，是拟是仪。


昙无竭菩萨赞

（《初学记》二十三）

亹亹渊匠，道玄数尽。
譬彼大壑，百川俱引。
涯不俟津，途无旋轸。
三流开源，于焉同泯。


五言游庐山诗

（此下五首，皆名“庐山东林杂诗”）

崇岩吐气清，幽岫栖神迹。
希声奏群籁，响出山溜滴。
有客独冥游，径然忘所适。
挥手抚云门，灵关安足辟。
流心叩玄扃，感至理弗隔。
孰是腾九霄，不奋冲天翮。
妙同趣自均，一悟超三益。


庐山诸道人游石门诗

（《旧志》误为庐山诸道人诗，今《庐山新志》，据《方舆纪要》订为远公作）

超兴非有本，理感兴自生。
忽闻石门游，奇唱发幽情。
褰裳思云驾，望崖想曾城。
驰步乘长严①，不觉质自轻。
矫首登灵阙，眇若陵太清。
端坐运虚轮，转彼玄中经。
神仙同物化，未若两俱冥。

① 疑作“岩”。


五言奉和刘隐士遗民

（此下三首，均据《重修庐山志》，从“守山阁本”刊正，订为远公作）

理神固超绝，涉粗罕不群。
孰至消烟外，晓然与物分。
冥冥玄谷里，响集自可闻。
文峰无旷秀，交岭有通云。
悟深婉冲思，在要开冥欣。
中岩拥微兴，临岫想幽闻。
弱明反归鉴，暴怀傅①灵熏。
永陶津玄匠，落照俟虚昕。

①《新志》注：一作“博”。


五言奉和王临驾乔之

超游罕神遇，妙善自玄同。
彻彼虚明域，暧然尘有封。
众阜平寥廓，一岫独陵空。
霄景凭岩落，清气与时雍。
有标造神极，有客越其峰。
长河濯茂楚，险雨列秋松。
危步临绝冥，灵壑映万重。
风泉调远气，遥响多喈嗈。
遐丽既悠然，馀盼觌九江。
事属天人界，常闻清吹空。


五言和张常侍野

觌岭混太象，望崖莫由检。
器远蕴其天，超步不阶渐。
朅来越重垠，一举拔①尘染。
辽朗中天盼，回豁遐瞻慊。
乘此摅莹心，可以忘遗玷。
旷风被幽宅，妖途故死减。

①《新志》注：或作“披”。


报罗什法师偈

（《高僧传》卷六，《诗纪》三十七）

本端竟何从，起灭有无际。
一微涉动境，成此颓山势。
惑相更相乘，触理自生滞。
因缘虽无主，开途非一世。
时无悟宗匠，谁将握玄契。
末问尚悠悠，相与期暮岁。


与隐士刘遗民书
（附刘程之《发愿文》）

（愿文，《高僧传》卷六，及《乐邦文类》
卷二。远公书，《广弘明集》卷三十二。）

    《发愿文》曰：维岁在上章摄提格（即岁次庚寅，乃东晋孝武帝太元十五年），七月戊辰朔，二十八日乙未。法师释慧远，真（《僧传》作“贞”）感幽奥，霜怀特发。乃延命同志息心贞信之士，百有二十三人，集于庐山之阴，般若云（《文类》无“云”字）台精舍，阿弥陀像前，率以香花敬荐而誓焉，推（《文类》作“惟”）斯一会之众。
    夫缘化之理既明，则三世之传显矣。迁感之数既符，则善恶之报必矣。推交臂之潜沦，悟无常之期切。审三报之相催，知险趣之难拔。此其同志诸贤，所以夕惕宵勤，仰思攸济者也。盖神者可以感涉，而不可以迹求。必感之有物，则幽路咫尺。苟求之无主，则渺茫何津。今幸以不谋而佥心西境，叩篇开信，亮情天发。乃机象通于寝梦，欣欢百于子来。于是灵图表晖，影侔神造。功由理谐，事非人运。兹实天启其诚，冥运来萃者矣。可不克心（《文类》多“克念”二字）重（一作“专”）精叠思，以凝其虑哉！
    然其景绩参差，功福不一。虽晨祈云同，而夕归攸隔。即我师友之眷，良可悲矣。是以慨焉，胥命整襟法堂，等施一心，亭怀幽极。誓兹同人，俱游绝域。其有惊（《文类》作“警”）出绝伦，首登神界，则无独善于云峤，忘兼全于幽谷，先进之与后升，勉思汇征之道。然复（《文类》作“后”）妙观大仪，启心贞照，识以悟新，形由化革。藉芙蓉于中流，荫琼柯以咏言。飘云衣于八极，泛香风以穷年。体忘安而弥穆，心超乐以自怡。临三途而缅谢，傲天宫而长辞。绍众灵以继轨，指大息（他本皆作“大觉”）以为期。究兹道也，岂不弘哉！

    每寻畴昔游心世典，以为当年之华苑也。及见《老》、《庄》，便悟名教是应变之虚谈耳。以今而观，则知沉冥之趣，岂得不以佛理为先？苟会之有宗，则百家同致。君与诸人，并为如来贤弟子也，策名神府，为日已久。徒积怀远之兴，而乏因藉之资，以此永年，岂所以励其宿心哉？意谓六斋日，宜简绝常务，专心空门。然后津寄之情笃，来生之计深矣。若染翰缀文，可托兴于此。虽言生于不足，然非言无以畅一诣之感。因骥之喻，亦何必远寄古人欤！


答戴处士安公书二篇
（原书三篇附）

（《广弘明集》卷二十）

    安公和南：弟子常览经典，皆以祸福之来，由于积行。是以自少束脩，至于白首，行不负于所知，言不伤于物类。而一生艰楚，荼毒备经，顾影（一作“景”）块然，不尽唯己。夫冥理难推，近情易缠。每中宵幽念，悲慨盈怀，始知修短穷达，自有定分，积善积恶之谈，盖是劝教之言耳。近作此《释疑论》，今以相呈，想消息之余，脱能寻省。

    省君别示，以为慨然。先虽未善相悉，人物往来，亦未始暂忘。分命穷达，非常智所测。然依傍大宗，似有定检。去秋与诸人共读君论，并亦有同异。观周郎作答，意谓世典与佛教，粗是其中。今封相呈，想暇日能力寻省。释慧远顿首。

    安公和南：间作《释疑论》，以寄其怀，故呈之匠者，思闻启诲。既辱还告，开示宗辙，并送周郎难，甚有趣致。但理本不同，所见亦殊。今重申鄙意答周，复以相呈。旨诚可求，而辞不自畅，想脱览省。

    见君与周居士往复，足为宾主。然佛教精微，难以事诘。至于理玄数表，义隐于经者，不可胜言。但恨君作佛弟子，未能留心圣典耳。顷得书论，亦未始暂忘，年衰多疾，不暇有答。脱因讲集之余，粗缀所怀。今寄往，试与同疑者共寻，若见其族，则比干、商臣之流，可不思而得。释慧远顿首。

    安公和南：辱告，并见《三报论》，旨喻弘远，妙畅理宗。览省反复，欣悟兼怀。弟子虽伏（疑做“服”）膺法训，诚信弥至，而少游人林，遂不涉经学。往以艰毒交缠，聊寄之《释疑》以自摅散。此盖情发于中，而形于言耳。推其俗见之怀，诚为未尽。然三报旷远，难以辞究。弟子寻当索归，必觐展，冀亲承音旨，益祛其滞。诸怀寄之周居士。


遣书通好流支法师

（《高僧传》卷二）

    佛教之兴，先行上国，自分流已来，四百余年。至于沙门律戒，所阙尤多。顷有西域道士弗若多罗，是罽宾人，其讽《十诵》梵本，有罗什法师，通才博见，为之传译。《十诵》之中，文始过半，多罗早丧，中途而寝，不得究竟大业，慨恨良深。传闻仁者赍此经自随，甚欣所遇，冥运之来，岂人事而已耶！想弘道为物，感时而动，叩之有人，必情无所吝。若能为律学之徒，毕此经本，开示梵行，洗其耳目。使始涉之流，不失无上之津。澡怀胜业者，日月弥朗。此则惠深德厚，人神同感矣！幸愿垂怀，不乖往意。一二，悉诸道人所具。


遣书通好罗什法师二篇

遣书通好罗什法师二篇（答书附）

（《高僧传》卷六）

    释慧远顿首：去岁得姚左军书，具承德问。仁者曩绝殊域，越自外境。于时音驿未交，闻风而悦。但江湖难置，以形乖为叹耳。顷（《僧传》作“须”）知承否通之会，怀宝来游，至止有间，则一日九驰。徒情欣雅味，而无由造尽。寓目望途，固已增其劳伫。每欣大法宣流，三方同遇。虽运钟其末，而趣均在昔。诚未能叩津妙门，感彻遗灵。至于虚襟遣契，亦无日不怀。夫栴檀移植，则异物同熏。摩尼吐曜，则众珍自积。是惟教合之道，犹虚往实归。况宗一无像，而应不以情者乎？是故负荷大法者，必以无执为心。会友以仁者，使功不自己。若令法轮不停轸于八正之路，三宝不辍音于将尽之期，则满愿不专美于绝代，龙树岂独善于前踪。今往比量衣裁，愿登高座为着之。并天漉之器，此既法物，聊以示怀。释慧远顿首。

    鸠摩罗什和南：既未言面，又文辞殊隔。导心之路不通，得意之缘圮绝。传驿来贶，粗承风德，比知何如。备闻一途，可以蔽百。经言：“末后东方，当有护法菩萨。”勖哉仁者，善弘其事！夫财有五备：福、戒、博闻、辩才、深智。兼之者道隆，未具者疑滞。仁者备之矣。所以寄心通好，因译传意，岂其能尽，粗酬来意耳。损所致比量衣裁，欲令登法座时着，当如来意。但人不称物，以为愧耳。今往常所用鍮石双口澡罐，可备法物之数也。并遗偈一章曰：既已舍染乐，心得善摄否？若得不驰散，深入实相否？毕竟空相中，其心无所乐。若悦禅智慧，是法性无照。虚诳等无实，亦非停心处。仁者所得法，幸愿示其要。

    日有凉气，比复何如？去月法识道人至，闻君欲还本国，情以怅然。先闻君方当大出诸经，故未欲便相咨求。若此传不虚，众恨可言。今辄略问数十条事，冀有余暇，一一为释。此虽非经中之大难，要欲取决于君耳。（另偈一章入“诗”。）


答王谧书

答王谧书（原书附）

（《高僧传》卷六）

    司徒王谧修书曰：年始四十，而衰同耳顺。

    古人不爱尺璧，而重寸阴，观其所存，似不在长年耳。檀越既履顺而游性，乘佛理以御心，因此而推，复何羡于遐龄耶？聊想斯理，久已得之，为复酬来信耳。


答卢循书

（《艺文类聚》八十七，《御览》九百七十二）

    损饷六种，深抱情至。益智，乃是一方异味，即于僧中行之。


答秦主姚兴书

答秦主姚兴书（原书附）

（《高僧传》卷六）

    兴送论并遗书曰：《大智论》新译讫，此既龙树所作，又是《方等》旨归，宜为一序，以伸作者之意。然此诸道士，咸相推谢，无敢动手。法师可为作序，以贻后之学者。

    答曰：欲令作《大智论序》，以伸作者之意。贫道闻怀大非小褚所容，汲深非短绠所测，披省之日，有愧高命。又体羸多疾，触事有废，不复属意已来，其日亦久。缘告之重，辄粗缀所怀。至于研究之美，当复寄诸明德。


答桓玄劝罢道书

答桓玄劝罢道书（原书附）

（《弘明集》卷十一）

    桓玄书曰：夫至道缅邈，佛理幽深，岂是悠悠常徒，所能习求？沙门去弃六亲之情，毁其形骸，口绝滋味，被褐带索，山栖枕石，永乖世务。百代之中，庶或有一仿佛之间。今世道士，虽外毁仪容，而心过俗人。所谈道俗之际，可谓学步邯郸，匍匐而归。先圣有言：“未知生，焉知死？”而令一生之中，困苦形神，方求冥冥黄泉下福，皆是管见，未体大化。迷而知反，去道不远，可不三思？运不居人，忽焉将老，可复追哉！聊赠至言，幸能纳之。

    答曰：大道渊玄，其理幽深，衔此高旨，实如来谈。然贫道出家，便是方外之宾。虽未践古贤之德，取其一往之志，削除饰好，落名求实。若使幽冥有在，故当不谢于俗人。外似不尽，内若断金，可谓见形不及道，哀哉哀哉！
    带索枕石，华而不实，管见之人，不足羡矣，虽复养素山林，与树木何异。夫道在方寸，假炼形为真。卞和号恸于荆山，患人不别故也。昔闻其名，今见其人。故庄周悲慨：“人生天地之间，如白驹之过隙。”以此而寻，孰得久停，岂可不为将来作资？言学步邯郸者，新则无功，失其本质，故使邯人匍匐而归。百代之中，有此一也，岂浑同以通之？
    贫道已乖世务，形权于流俗，欲于其中化未化者，虽复沐浴踞傲，奈疑结何？一世之荣，剧若电光，聚则致离，何足贪哉？浅见之徒其惑哉！可谓“下士闻道大笑之”，真可谓迷而不反也。贫道形不出人，才不应世，是故毁其陋质，被其割截之服，理未能心冥玄化，远存大圣之制。岂舍其本怀，而酬高诲？
    贫道年与时颓，所患未痊，乃复曲垂光慰，感庆交至。檀越信心幽当，大法所寄，岂有一伤毁其本也，将非波旬试娆之言？辞拙寡闻，力酬高命，盖是不逆之怀耳。


与桓玄论料简沙门书

与桓玄论料简沙门书（原文附）

（《弘明集》卷十二，并节录《高僧传》卷六）

    桓玄辅政，欲沙汰众僧，与僚属教曰：夫神道茫昧，圣人之所不言。然惟其制作所弘，如将可见。佛所贵无为，殷勤在于绝欲。而比者陵迟，遂失斯道。京师竞其奢淫，荣观纷于朝市。天府以之倾匮，名器为之秽黩。避役钟于百里，逋逃盈于寺庙。乃至一县数千，猥成屯落邑聚，游食之群，境积不羁之众。其所以伤治害政，尘滓佛教，固已彼此俱弊，实污风轨矣。便可严下：在此诸沙门，有能申述经诰，畅说义理者；或禁行修整，奉戒无亏，恒为阿练若者；或山居养志，不营流俗者，皆足以宣寄大化，亦所以示物以道，弘训作范，幸兼内外。其有违于此者，皆悉罢道。所在领其户籍，严为之制，速申下之，并列上也。唯庐山道德所居，不在搜简之例。

    答曰：佛教陵迟，秽杂日久，每一寻思，愤慨盈怀。常恐运出非意，混然沦胥，此所以夙宵叹惧，忘寝与食者也。见檀越澄清诸道人教，实应其本心。夫泾以渭分，则清浊殊流；枉以直正，则不仁自远。推此而言，符命既行，必二理斯得。然后令饰伪取容者，自绝于假通之路；信道怀真者，无复有负俗之嫌。如此，则道世交兴，三宝复隆于兹矣！贫道所以寄命江南，欲托有道以存至业，业之隆替，实由乎人。值檀越当年，则是贫道中兴之运，幽情所托，已冥之在昔。是以前后书疏，辄以凭寄为先。每寻告慰，眷怀不忘。但恐年与时乖，不尽檀越盛隆之化耳。今故咨白数条，如别疏。
    经教所开，凡有三科：一者禅思入微，二者讽味遗典，三者兴建福业。三科诚异，皆以律行为本。檀越近制，似大同于此，是所不疑。或有兴福之人，内不毁禁，而迹非阿练若者。或多诵经，讽咏不绝，而不能畅说义理者。或年已宿长，虽无三科可记，而体性贞正，不犯人（《弘明集》作“大”）非者。凡如此辈，皆是所疑。今寻檀越所遣之例，不应问此。而外物惶惑，莫敢自宁，故以别白。
    夫形迹易察，而真伪难辨，自非远鉴，得之信难。若是都邑沙门，经檀越视听者，固无所疑。若边局远司，识不及远，则未达教旨，或因符命，滥及善人，此最其深忧。若所在执法之官，意所未详，又时无宿望沙门，可以求中。得令送至大府，以经高鉴者，则于理为弘。想檀越神虑，已得之于心，直是贫道常近之情，故不能不及耳。
    若有族姓子弟，本非役门，或世奉大法，或弱而天悟，欲弃俗入道，求作沙门，推例寻意，似不塞其清途。然要须咨定，使洗心向味者，无复自疑之情。
    昔外国诸王，多参怀圣典，亦有因时助弘大化，扶危救弊，信有自来矣。檀越每期情古人，故复略叙所闻。


答桓玄书
（论沙门不应敬王者 ○原书附前，再书附后）

（《弘明集》卷十二，及《高僧传》卷六）

    桓玄与远法师书曰：沙门不敬王者，既是情所不了，于理又是所未谕，一代大事，不可令其体不允。近与八座书，今以呈君，君可述所以不敬意也。此便当行之于事，一一令详遣，想君必有以释其所疑耳。王领军大有任此意，近亦同游谢中，面共咨之，所据理殊，未释所疑也。令郭江州取君答，可旨付之。

    答曰：详省别告，及《八座书》，问沙门所以不敬王者意，义在尊主崇上，远存名体。征引老氏，同王侯于三大，以资生运通之道，故宜重其神器。若推其本以寻其源，咸禀气于两仪，受形于父母，则以生生通运之道为弘，资存日用之理为大，故不宜受其德而遗其礼，沾其惠而废其敬。此檀越立意之所据，贫道亦不异于高怀。求之于佛教，以寻沙门之道，理则不然。
    何者？佛经所明，凡有二科：一者处俗弘教，二者出家修道。处俗，则奉上之礼，尊亲之敬，忠孝之义，表于经文；在三之训，彰于圣典。斯与王制同命，有若符契。此一条，全是檀越所明，理不容异也。出家，则是方外之宾，迹绝于物。其为教也，达患累缘于有身，不存身以息患；知生生由于禀化，不顺化以求宗。求宗不由于顺化，故不重运通之资。息患不由于存身，故不贵厚生之益。此理之与世乖，道之与俗反者也。
    是故凡在出家，皆隐居以求其志，变俗以达其道。变俗，则服章不得与世典同礼；隐居，则宜高尚其迹。夫然，故能拯溺俗于沉流，拔幽根于重劫。远通三乘之津，广开人天之路。是故内乖天属之重，而不违其孝。外阙奉主之恭，而不失其敬。若斯人者，自誓始于落簪，立志成于暮岁。如令一夫全德，则道洽六亲，泽流天下。虽不处王侯之位，固已协契皇极，大庇生民矣。如此，岂坐受其德，虚沾其惠，与夫尸禄之贤，同其素餐者哉？
    檀越顷者以有其服而无其人，故澄清简练，容而不杂。此命既宣，皆人百其诚，遂之弥深，非言所喻。若复开出处之迹，以弘方外之道，则虚襟者挹其遗风，漱流者味其余津矣。若澄简之后，犹不允情，其中或真伪相冒，泾渭未分，则可以道废人，固不应以人废道。以道废人，则宜去其服。以人废道，则宜存其礼。礼存则制教之旨可寻，迹废则遂志之欢莫由。
    何以明其然？夫沙门服章法用，虽非六代之典，自是道家之殊制，俗表之名器。名器相涉，则事乖其本。事乖其本，则礼失其用。是故爱夫礼者，必不亏其名器，得之不可亏，亦有自来矣。夫远遵古典者，犹存告朔之饩羊。饩羊犹可以存礼，岂况如来之法服耶？推此而言，虽无其道，必宜存其礼。礼存则法可弘，法可弘则道可寻，此古今所同，不易之大法也。又袈裟非朝宗之服，钵盂非廊庙之器。军、国异容，戎、华不杂。剃发毁形之人，忽厕诸夏之礼，则是异类相涉之象，亦窃所未安。檀越奇韵挺于弱年，风流迈于季俗，犹参究时贤，以求其中，此而推之，必不以人废言。
    贫道西垂之年，假日月以待尽，情之所惜，岂存一己苟吝所执？盖欲令三宝中兴于命世之运，明德流芳于百代之下耳。若一旦行此，佛教长沦，如来大法，于兹泯灭，天人感叹，道俗革心矣。贫道幽诚所期，复将安寄？缘眷遇之隆，故殚其所怀。执笔悲懑，不觉涕泗横流！（沙门不拜俗事一）
    （《高僧传》载答书曰：“夫称沙门者何耶？谓能发矇俗之幽昏，启化表之玄路。方将以兼忘之道，与天下同往，使希高者挹其遗风，漱流者味其余津。若然，虽大业未就，观其超步之迹，所悟固已宏矣。又袈裟非朝宗之服，钵盂非廊庙之器。沙门尘外之人，不应致敬王者。”按此即前篇，而文句多异。）

    桓玄重与书曰：知以方外遗形，故不贵为生之益。求宗不由顺化，故不重运通之资。又云：“内乖天属之重，而不违其孝。外阙奉主之恭，而不失其敬。”若如来言，理本无重，则无缘有致孝之情；事非资通，不应复有致恭之义。君、亲之情，许其未尽，则情之所寄，何为绝之？夫累著在于心滞，不由形敬，形敬盖是心之所用耳。若乃在其本，而纵以形敬，此复所未之谕。又云：“佛教两弘，亦有处俗之教，或泽流天下，道洽六亲，固已协赞皇极，而不虚沾其德矣。”夫佛教（《弘明集》作“敬”）存行，各以事应，因缘有本，必至无差者也。如此，则为道者，亦何能违之哉？是故释迦之道，不能超白净于津梁，虽未获须陀，故是同国人所蒙耳。就如来言，此自有道深德之功，固非今之所谓宣教者，所可拟议也。来示未能共求其理，便大致慨然，故是未之喻也。想不惑留常之滞，而谬情理之用耳。（又见《全晋文》一百十九，引沙门不拜俗事一。）


答何镇南书
（难《袒服论》原书附）

（《弘明集》卷五）

    难曰：见答问袒服，指训兼弘，标末文于玄古，资形理于近用。使敬慢殊流，诚服俱尽，殆无间然。至于所以明顺，犹有未同。何者？仪形之设，盖在时而用。是以事有内外，乃可以浅深应之。李、释之与周、孔，渐世之与遗俗，在于因循不同，必无逆顺之殊，明矣。故《老》明兵凶处右，《礼》以丧制不左。且四等穷奉亲之至，三驱显王迹之仁，在后而要，其旨可见。宁可寄至顺于凶事，表吉诚于丧容哉？郑伯所以肉袒，亦犹许男舆榇，皆自以所乘者逆，必受不测之罚。以斯而证，顺将何在？故率所怀，宜（一本作“想”）更详尽，令内外有归。

    答曰：敬寻问旨，盖是开其远途，照所未尽，令精粗并顺，内外有归。三复斯诲，所悟良多。常以为道训之与名教，释迦之与周、孔，发致虽殊，而潜相影响；出处诚异，终期则同。但妙迹隐于常用，指归昧而难寻，遂令至言隔于世典，谈士发殊途之论。
    何以知其然？圣人因弋钓以去其甚，顺四时以简其烦。三驱之礼，失前禽而弗吝。网罟之设，必待化而方用。上极行苇之仁，内匹释迦之慈，使天下齐己，物我同观。则是合抱之一毫，岂直有间于优劣，而非相与者哉？然自迹而寻，犹大同于兼爱。远求其实，则阶差有分。分外之所通，未可胜言，故渐兹以进德，令事显于君亲。从此而观，则内外之教可知，圣人之情可见。但归途未启，故物莫之识。若许其如此，则袒服之义，理不容疑。
    来告何谓宜更详尽，故复究叙本怀。原夫形之化也，阴阳陶铸，受左右之体。昏明代运，有死生之说。人情咸悦生而惧死，好进而恶退，是故先王即顺民性，抚其自然，令吉凶殊制，左右异位。由是吉事尚左，进爵以厚其生。凶事尚右，哀容以毁其性。斯皆本其所受，因顺以通教，感于事变，怀其先德者也。世之所贵者，不过生存，生存而屈伸进退，道尽于此，浅深之应，于是乎在。
    沙门则不然。后身退己，而不谦卑。时来非我，而不辞辱。卑以自牧谓之谦，居众人之所恶谓之顺。谦顺不失其本，则日损之功易积，出要之路可游。是故遁世遗荣，反俗而动。动而反俗者，与夫方内之贤，虽貌同而实异。何以明之？凡在出家者，达患累缘于有身，不存身以息患。知生生由于禀化，不顺化以求宗。推此而言，固知发轸归途者，不以生累其神。超落世务者，不以情累其生。不以情累其生，则生可绝。不以生累其神，则神可冥。
    然则向之所谓吉凶成礼、奉亲事君者，盖是一域之言耳，未始出于有封。有封未出，则是玩其文，而未达其变。若然，方将滞名教以徇生，乘万化而背宗。自至顺而观，得不曰逆乎？渐世之与遗俗，指存于此。


答晋安帝书
（安帝复书附）

（《高僧传》卷六）

    释慧远顿首：阳月和暖，愿御膳顺宜。贫道先婴重疾，年衰益甚。猥蒙慈诏，曲垂光慰，感惧之深，实百于怀。幸遇庆会，而形不自运，此情此慨，良无以喻。

    诏答：阳中感怀，知所患未佳，甚情耿。去月发江陵，在道多诸恶情，迟兼常，本冀经过相见。法师既养素山林，又所患未痊，邈无复因，增其叹恨。


遗 诫

（《莲宗宝鉴》）

    吾自知命之年，托业此山，自审有毕尽之期，乃绝迹外缘，以求其志。不觉形与运颓，已八十三矣。时至，欲厝骨于松林之下，即岭为坟，与草木同状。此古人之礼，汝等勿违。苟使神理不昧，庶达其诚，大哀世尊，亦当祐之以道。


慧远法师传一

庐山慧远法师文钞附编
（附录传记等文）
江苏如皋沙元炳健庵氏编辑　 门人项智源敬录

晋庐山东林寺慧远法师传一

（《高僧传》卷六）

    释慧远，本姓贾氏，雁门楼烦人也。弱而好书，圭璋秀发。年十三，随舅令狐氏，游学许、洛。故少为诸生，博综《六经》，尤善《庄》、《老》。性度弘伟，风鉴朗拔，虽宿儒英达，莫不服其深致。年二十一，欲度江东，就范宣子共契。值石虎已死，中原寇乱，南路阻塞，志不获从。
    时沙门释道安，立寺于太行恒山，弘赞像法，声甚著闻。远遂往归之，一面尽敬，以为真吾师也。后闻安讲《般若经》，豁然而悟，乃叹曰：“儒道九流，皆糠秕耳。”便与弟慧持，投簪落[髟/采]，委命受业。既入乎道，厉然不群。常欲总摄纲维，以大法为己任。精思讽持，以夜续昼。贫旅无资，缊纩常阙，而昆弟恪恭，终始不懈。有沙门昙翼，每给以灯烛之费。安公闻而喜曰：“道士诚知人矣！”远藉慧解于前因，发胜心于旷劫，故能神明英越，机鉴遐深。安公常叹曰：“使道流东国，其在远乎！”
    年二十四，便就讲说。尝有客听讲，难实相义，往复移时，弥增疑昧。远乃引《庄子》义为连类，于是惑者晓然。是后安公特听慧远不废俗书。安有弟子法遇、昙徽，皆风才照灼，志业清敏，并推服焉。
    后随安公南游樊沔。伪秦建元九年，秦将苻丕，寇并襄阳，道安为朱序所拘，不能得去。乃分张徒众，各随所之。临路，诸长德皆被诲约，远不蒙一言。远乃跪曰：“独无训勖，惧非人例。”安曰：“如汝者，岂复相忧！”
    远于是与弟子数十人，南适荆州，住上明寺。后欲往罗浮山，及届浔阳，见庐峰清静，足以息心，始住龙泉精舍。此处去水本远，远乃以杖扣地曰：“若此中可得栖止，当使朽壤抽泉。”言毕，清流涌出，浚矣成溪。其后少时，浔阳亢旱，远诣池侧读《海龙王经》，忽有巨蛇从池上空，须臾大雨，岁以有年，因号精舍为龙泉寺焉。
    时有沙门慧永，居在西林，与远同门旧好，遂要远同止。永谓刺史桓伊曰：“远公方当弘道，今徒属已广，而来者方多。贫道所栖褊狭，不足相处，如何？”桓乃为远复于山东更立房殿，即东林是也。远创造精舍，洞尽山美，却负香炉之峰，傍带瀑布之壑。仍石叠基，即松栽构。清泉环阶，白云满室。复于寺内别置禅林，森树烟凝，石径苔合，凡在瞻履，皆神清而气肃焉。
    远闻天竺有佛影，是佛昔化毒龙所留之影。在北天竺月氏国那竭呵城南，古仙人石室中，径道取流沙西一万五千八百五十里。每欣感交怀，志欲瞻睹。会有西域道士，叙其光相，远乃背山临流，营筑龛室。妙算画工，淡彩图写。色疑积空，望似烟雾。晖相炳暧，若隐而显。远乃著铭曰：

    廓矣大象，理玄无名。体神入化，落影离形。回晖层岩，凝映虚亭。在阴不昧，处暗愈明。婉步蝉蜕，朝宗百灵。应不同方，迹绝而冥。（其一）
    茫茫荒宇，靡劝靡奖。淡虚写容，拂空传像。相具体微，冲姿自朗。白毫吐曜，昏夜中爽。感彻乃应，扣诚发响。留音停岫，津悟冥赏。抚之有会，功弗由曩。（其二）
    旋踵忘敬，罔虑罔识。三光掩晖，万象一色。庭宇幽蔼，归途莫测。悟之以靖，开之以力。慧风虽遐，惟尘假息。匪圣玄览，孰扇其极。（其三）
    希音远流，乃眷东顾。欣风慕道，仰规玄度。妙尽毫端，运微轻素。托彩虚淡，殆映霄雾。迹似像真，理深其趣。奇兴开襟，祥风引路。清气回轩，昏交未曙。仿佛神容，依稀钦遇。（其四）
    铭之图之，曷营曷求。神之听之，鉴尔所修。庶兹尘轨，映彼玄流。漱清灵沼，饮和至柔。照虚应简，智落乃周。深怀冥托，宵想神游。毕命一对，长谢百忧。（其五）

    又昔浔阳陶侃，经镇广州。有渔人于海中见神光，每夕艳发，经旬弥盛，怪以白侃。侃往详视，乃是阿育王像，即接归，以送武昌寒溪寺。寺主僧珍，尝往夏口，夜梦寺遭火，而此像屋，独有龙神围绕。珍觉驰还寺，寺既焚尽，唯像屋存焉。侃后移镇，以像有威灵，遣使迎接。数十人舆之至水，及上船，船又覆没，使者惧而反之，竟不能获。侃幼出雄武，素薄信情。故荆楚之间，为之谣曰：“陶惟剑雄，像以神标。云翔沉（《佛祖统纪》作“泥”）宿，邈何遥遥。可以诚致，难以力招。”及远创寺既成，祈心奉请，乃飘然自轻，往还无梗。方知远之神感，证在风谣矣。
    于是率众行道，昏晓不绝，释迦余化，于斯复兴。既而谨律息心之士，绝尘清信之宾，并不期而至，望风遥集。彭城刘遗民、豫章雷次宗、雁门周续之、新蔡毕颖之、南阳宗炳、张莱民、张季硕等，并弃世遗荣，依远游止。远乃于精舍无量寿像前，建斋立誓，共期西方。乃令刘遗民著其文曰：

    “维岁在摄提格，七月戊辰朔，二十八日乙未。法师释慧远，贞感幽奥，霜怀特发。乃延命同志息心贞信之士，百有二十三人，集于庐山之阴，般若云台精舍，阿弥陀像前，率以香花敬荐而誓焉，推斯一会之众。夫缘化之理既明，则三世之传显矣。迁感之数既符，则善恶之报必矣。推交臂之潜沦，悟无常之期切。审三报之相催，知险趣之难拔。此其同志诸贤，所以夕惕宵勤，仰思攸济者也。盖神者可以感涉，而不可以迹求。必感之有物，则幽路咫尺。苟求之无主，则渺茫河津。今幸以不谋而佥心西境，叩篇开信，亮情天发。乃机象通于寝梦，欣欢百于子来。于是灵图表晖，影侔神造。功由理谐，事非人运。兹实天启其诚，冥运来萃者矣。可不克心专（一作“重”）精叠思，以凝其虑哉！然其景绩参差，功福不一。虽晨祈云同，夕归攸隔。即我师友之眷，良可悲矣。是以慨焉，胥命整襟法堂，等施一心，亭怀幽极，誓兹同人，俱游绝域。其有惊出绝伦，首登神界，则无独善于云峤，忘兼全于幽谷，先进之与后升，勉思汇征之道。然复（一作“后”）妙观大仪，启心贞照，识以悟新，形由化革。藉芙蓉于中流，荫琼柯以咏言。飘云衣于八极，泛香风以穷年。体忘安而弥穆，心超乐以自怡。临三途而缅谢，傲天宫而长辞。绍众灵以继轨，指大息（一作“觉”）以为期。究兹道也，岂不弘哉！”

    远神韵严肃，容止方棱，凡预瞻睹，莫不心形战栗。曾有一沙门，持竹如意，欲以奉献。入山信宿，竟不敢陈，窃留席隅，默然而去。有慧义法师，强正不惮，将欲造山，谓远弟子慧宝曰：“诸君庸才，望风推服，今试观我如何？”至山，值远讲《法华》，每欲难问，辄心悸流汗，竟不敢语。出谓慧宝曰：“此公定可讶。”其伏物盖众如此。
    殷仲堪之荆州，过山展敬，与远共临北涧，论《易》体要，移景不倦。既而叹曰：“识信深明，实难庶几。”司徒王谧、护军王默等，并钦慕风德，遥致师敬。谧修书曰：“年始四十，而衰同耳顺。”远答曰：“古人不爱尺璧，而重寸阴，观其所存，似不在长年耳。檀越既履顺而游性，乘佛理以御心，因此而推，复何羡于遐龄耶？聊想斯理，久已得之，为复酬来信耳。”
    卢循初下据江州城，入山诣远。远少与循父嘏同为书生，及见循，欢然道旧，因朝夕音介。僧有谏远者曰：“循为国寇，与之交厚，得不疑乎？”远曰：“我佛法中，情无取舍，岂不为识者所察？此不足惧。”及宋武追讨卢循，设帐桑尾，左右曰：“远公素主庐山，与循交厚。”宋武曰：“远公世表之人，必无彼此。”乃遣使赍书致敬，并遗钱米。于是远近方服其明见。
    初经流江东，多有未备，禅法无闻，律藏残阙。远慨其道缺，乃令弟子法净、法领等，远寻众经，逾越沙雪，旷岁方反，皆获梵本，得以传译。昔安法师在关，请昙摩难提，出《阿毗昙心》，其人未善晋言，颇多疑滞。后有罽宾沙门僧伽提婆，博识众典，以晋太元十六年来至浔阳。远请重译《阿毗昙心》，及《三法度论》，于是二学乃兴，并制序标宗，贻于学者。孜孜为道，务在弘法。每逢西域一宾，辄恳恻咨访。
    闻罗什入关，即遣书通好曰：“释慧远顿首：去岁得姚左军书，具承德问。仁者曩绝殊域，越自外境，于时音驿未交，闻风而悦。但江湖难置，以形乖为叹耳。顷知承否通之会，怀宝来游，至止有间，则一日九驰。徒情欣雅味，而无由造尽。寓目望途，固以增其劳伫。每欣大法宣流，三方同遇。虽运钟其末，而趣均在昔。诚未能叩津妙门，感彻遗灵。至于虚襟遣契，亦无日不怀。夫栴檀移植，则异物同熏。摩尼吐曜，则众珍自积。是惟教合之道，犹虚往实归。况宗一无像，而应不以情者乎！是故负荷大法者，必以无执为心。会友以仁者，使功不自己。若令法轮不停轸于八正之路，三宝不辍音于将尽之期，则满愿不专美于绝代，龙树岂独善于前踪。今往比量衣裁，愿登高座为着之。并天漉之器，此既法物，聊以示怀。”
    什答书曰：“鸠摩罗什和南：既未言面，又文辞殊隔，导心之路不通，得意之缘圮绝。传驿来贶，粗承风德，比知何如。备闻一途，可以蔽百。经言：‘末后东方，当有护法菩萨。’勖哉仁者，善弘其事！夫财有五备：福、戒、博闻、辩才、深智。兼之者道隆，未具者疑滞，仁者备之矣。所以寄心通好，因译（按前“音驿未交”、“传驿来贶”二句，此亦当作“驿”）传意，岂其能尽，粗酬来意耳。损所致比量衣裁，欲令登法座时着，当如来意。但人不称物，以为愧耳。今往常所用鍮石双口澡罐，可备法物之数也。并遗偈一章曰：既已舍染乐，心得善摄否？若得不驰散，深入实相否？毕竟空相中，其心无所乐。若悦禅智慧，是法性无照。虚诳等无实，亦非停心处。仁者所得法，幸愿示其要。”
    远重与什书曰：“日有凉气，比复何如？去月法识道人至，闻君欲还本国，情以怅然。先闻君方当大出诸经，故未欲便相咨求。若此传不虚，众恨可言。今辄略问数十条事，冀有余暇，一一为释。此虽非经中之大难，要欲取决于君耳。并报偈一章曰：本端竟何从，起灭有无际。一微涉动境，成此颓山势。惑相更相乘，触理自生滞。因缘虽无主，开途非一世。时无悟宗匠，谁将握玄契？末问尚悠悠，相与期暮岁。”
    后有弗若多罗，来适关中，诵出《十诵》梵本，罗什译为晋文，三分始二，而多罗弃世，远常慨其未备。及闻昙摩流支入秦，复善诵此部，乃遣弟子昙邕致书祈请，令于关中更出余分。故《十诵》一部，具足无阙，晋地获本，相传至今。葱外妙典，关中胜说，所以来集兹土者，远之力也。外国众僧，咸称汉地有大乘道士，每至烧香礼拜，辄东向稽首，献心庐岳。其神理之迹，故未可测也。
    先是中土未有“泥洹常住”之说，但言寿命长远而已。远乃叹曰：“佛是至极，至极则无变，无变之理，岂有穷耶？”因著《法性论》，曰：“至极以不变为性，得性以体极为宗。”罗什见论而叹曰：“边国人未有经，便暗与理合，岂不妙哉！”
    秦主姚兴，钦风名德，叹其才思，致书殷勤，信饷连接，赠以龟兹国细缕杂变像，以伸款心，又令姚嵩献其珠像。《释论》新出，兴送论，并遗书曰：“《大智论》新译讫，此既龙树所作，又是《方等》旨归，宜为一序，以伸作者之意。然此诸道士，咸相推谢，无敢动手。法师可为作序，以贻后之学者。”远答书云：“欲令作《大智论序》，以伸作者之意。贫道闻怀大非小褚所容，汲深非短绠所测。披省之日，有愧高命。又体羸多疾，触事有废，不复属意已来，其日亦久。缘告之重，辄粗缀所怀。至于研究之美，当复寄诸明德。”其名高远固如此。远常谓《大智论》，文句繁广，初学难寻。乃抄其要文，撰为二十卷，序致渊雅，使夫学者息过半之功矣。
    后桓玄征殷仲堪，军经庐山，要远出虎溪，远称疾不堪。玄自入山，左右谓玄曰：“昔殷仲堪入山礼远，愿公勿敬之。”玄答：“何有此理，仲堪本死人耳。”及至见远，不觉致敬。玄问：“不敢毁伤，何以翦削？”远答云：“立身行道。”玄称善。所怀问难，不敢复言。乃说征讨之意，远不答。玄又问：“何以见愿？”远云：“愿檀越安隐，使彼亦复无他。”玄出山，谓左右曰：“实乃生所未见。”
    玄后以震主之威，苦相延致，乃贻书骋说，劝令登仕。远答辞坚正，确乎不拔，志逾丹石，终莫能回。俄而玄欲沙汰众僧，教僚属曰：“沙门有能申述经诰，畅说义理，或禁行循整，足以宣寄大化。其有违于此者，悉皆罢遣（一作“道”）。唯庐山道德所居，不在搜简之例。”远与玄书曰：“佛教陵迟，秽杂日久。每一寻至，慨愤盈怀。常恐运出非意，沦胥将及。窃见清澄诸道人教，实应其本心。夫泾以渭分，则清浊殊势。枉以直正，则不仁自远。此命既行，必二理斯得。然后令饰伪者绝假通之路，怀真者无负俗之嫌。道世交兴，三宝复隆矣。”因广玄（《统纪》作“立”）条制，玄从之。
    昔成帝幼冲，庾冰辅政，以为沙门应敬王者。尚书令何充、仆射褚翌、诸葛恢等，奏不应敬礼。官议悉同充等，门下承冰旨为驳，同异纷然，竟莫能定。及玄在姑熟，欲令尽敬。乃与远书曰：“沙门不敬王者，既是情所不了，于理又是所未喻，一代大事，不可令其体不允。近与八座书，今以呈君，君可述所以不敬意也。此便当行之于事，一一令详遣，想必有以释其所疑耳。”远答书曰：“夫称沙门者何耶？谓能发矇俗之幽昏，启化表之玄路。方将以兼忘之道，与天下同往。使希高者挹其遗风，漱流者味其余津。若然，虽大业未就，观其超步之迹，所悟固已弘矣。又袈裟非朝宗之服，钵盂非廊庙之器。沙门尘外之人，不应致敬王者。”玄虽苟执先志，耻即外从，而睹远辞旨，趑趄未决。有顷，玄篡位，即下书曰：“佛法宏大，所不能测。推奉主之情，故兴其敬。今事既在己，宜尽谦光，诸道人勿复致礼也。”
    远乃著《沙门不敬王者论》，凡有五篇：一曰“在家”，谓在家奉法，则是顺化之民，情未变俗，迹同方内。故有天属之爱，奉主之礼。礼敬有本，遂因之以成教。二曰“出家”，谓出家者，能遁世以求其志，变俗以达其道。变俗，则服章不得与世典同礼。遁世，则宜高尚其迹。夫然故能拯溺俗于沉流，拔玄根于重劫。远通三乘之津，近开人天之路。如令一夫全德，则道洽六亲，泽流天下。虽不处王侯之位，固已协契皇极，在宥生民矣。是故内乖天属之重，而不违其孝。外阙奉主之恭，而不失其敬也。三曰“求宗不顺化”，谓反本求宗者，不以生累其神。超落尘封者，不以情累其生。不以情累其生，则其生可灭。不以生累其神，则其神可冥。冥神绝境，故谓之泥洹。故沙门虽抗礼万乘，高尚其事，不爵王侯，而沾其惠者也。四曰“体极不兼应”，谓如来之与周、孔，发致虽殊，潜相影响；出处成异，终期必同。故虽曰道殊，所归一也。不兼应者，物不能兼爱也。五曰“形尽神不灭”，谓识神驰骛，随行东西也。此是论之大意。自是沙门得全方外之迹矣。
    及桓玄西奔，晋安帝自江陵旋于京师。辅国何无忌，劝远候迎，远称疾不行。帝遣使劳问。远修书曰：“释慧远顿首：阳月和暖，愿御膳顺宜。贫道先婴重疾，年衰益甚。猥蒙慈诏，曲垂光慰，感惧之深，实百于怀。幸遇庆会，而形不自运，此情此慨，良无以喻。”诏答：“阳中感怀，知所患未佳，甚情耿。去月发江陵，在道多诸恶情，迟兼常，本冀经过相见。法师既养素山林，又所患未痊，邈无复因，增其叹恨。”
    陈郡谢灵运，负才傲俗，少所推崇，及一相见，肃然心服。远内通佛理，外善群书，夫预学徒，莫不依拟。时远讲《丧服经》，雷次宗、宗炳等，并执卷承旨。次宗后别著《义疏》，首称“雷氏”。宗炳因寄书嘲之曰：“昔与足下，共于释和尚间，面受此义，今便题卷首称雷氏乎？”其化兼道俗，斯类非一。
    自远卜居庐阜，三十余年，影不出山，迹不入俗。每送客游履，常以虎溪为界焉。以晋义熙十二年八月初动散，至六日困笃。大德耆年，皆稽颡请饮豉酒，不许。又请饮米汁，不许。又请以蜜和水为浆，乃命律师，令披卷寻文，得饮与否，卷未半而终。春秋八十三矣。门徒号恸，若丧考妣。道俗奔赴，踵继肩随。远以凡夫之情难割，乃制七日展哀。遗命使露骸松下。既而弟子收葬，浔阳太守阮侃，于山西岭凿圹开冢。谢灵运为造碑文，铭其遗德。南阳宗炳，又立碑寺门。
    初远善属文章，辞气清雅。席上谈吐，精义简要。加以容仪端整，风彩洒落。故图像于寺，遐迩式瞻。所著论、序、铭、赞、诗、书，集为十卷，五十余篇，见重于世焉。（前“灵图表晖”，及“独善于灵峤”，二“灵”字，别本又作“云”。）


慧远法师传二

（《莲社高贤传》，及《佛祖统纪》卷二十六）

    法师慧远，姓贾氏，雁门楼烦人。幼而好学，年十三，随舅令狐氏，游学许、洛。博综《六经》，尤善《庄》、《老》。宿儒先进，莫不服其深致。二十一，欲渡江从学范宁，适石虎暴死，南路梗塞，有志不遂。
    时沙门释道安，建刹于太行恒山。一面尽敬，以为真吾师也。初闻安师讲《般若经》，豁然开悟，叹曰：“九流异议，皆糠秕耳！”（“秕”音“比”，谷不成。）遂与母弟慧持，投簪受业。精思讽诵，以夜继昼，因求直道场。沙门昙翼（此自是北人，非庐山入社者），每给灯烛之费。安师闻之曰：“道士诚知人。”师神明英越，志与理冥。至二十四，大善讲贯。有客闻说实相义，往复问难，弥增疑昧。师为引《庄子》之说以相比类，惑者释然。安师因许令不废外典，常临众叹曰：“使道流东国者，其在远乎！”后随安师南游襄阳，值秦将苻丕为寇，乃分张徒属，各随所往。耆德临歧，皆蒙诲益。唯师不闻一言，即跪请曰：“独无训敕，惧非人类。”安师曰：“如汝者，复何所虑！”
    师乃与弟子数十人，南适荆州，居上明寺。念旧与同门慧永，约结屋于罗浮。太元六年（即晋孝武帝，《宝鉴》作九年）至浔阳，见庐山闲旷，可以息心，乃立精舍。以去水犹远，举杖扣地曰：“若此可居，当使朽壤抽泉。”言毕，清流涌出。浔阳亢旱，师诣池侧读《海龙王经》，忽有神蛇从池而出，须臾大雨，岁竟有秋，因名“龙泉精舍”。
    永师先居庐山西林，欲邀同止，而师学侣寖众。永乃谓刺史桓伊曰：“远公方当弘道，而贫道所栖，隘不可处。”时师梦山神告曰：“此山足可栖神，愿毋他往。”其夕大雨雷震。诘旦，林麓广辟，素沙布地，楩、楠、文梓，充布地上，不知所自至。伊大敬感，乃为建刹，名其殿曰“神运”。以在永师舍东，故号“东林”。时太元十一年也。此山仪形九叠，峻耸天绝。而所居尽林壑之美，背负炉峰，旁带瀑布，清流环阶，白云生栋。（《庐山记》：“匡俗先生，殷、周之际，受道于仙人，即岩成馆，人称神仙之庐，因名庐山。”《浔阳记》：“山高三千三百六十丈，周二百五十里。其山九叠，川亦九派。”《郡国志》：“叠障九层，包藏仙迹。”）别营禅室，最居静深，凡在瞻履，神清气肃。
    师闻天竺佛影，是佛昔化毒龙瑞迹，欣感于怀。后因耶舍律士，叙述光相，乃背山临流，营筑龛室，淡彩图写，望如烟雾。复制五铭，刻于石。江州太守孟怀玉、别驾王乔之、常侍张野、晋安太守殷隐、黄门毛修之、主簿殷蔚、参军王穆夜、孝廉范悦之、隐士宗炳等，咸赋铭赞（见《庐山集》）。
    先是浔阳陶侃刺广州，渔人见海中有神光，网之，得金文殊像，志云“阿育王所造”。后商人于海东获一圆光，持以就像，若弥缝然。侃以送武昌寒溪寺。寺主僧珍，尝往夏口，夜梦寺火，而此像室，独有神护。驰还，寺果焚，像室果存。及侃移督江州，迎像将还，至舟而溺。荆楚为之谣曰：“陶惟剑雄，像以神标。云翔泥（《僧传》作“沉”）宿，邈何遥遥。可以诚至，难以力招。”及寺成，师至江上虔祷之，像忽浮出，遂迎至神运殿，造重阁以奉之，因制《文殊瑞像赞》。
    尝谓诸教三昧，其名甚众，功高易进，念佛为先。既而谨律息心之士，绝尘清信之宾，不期而至者，慧永（同师安公，先居西林）、慧持（远师同母弟）、道生、昙顺（并罗什门弟）、僧睿、昙恒、道昞、昙诜、道敬（并远师门人）、佛驮耶舍（此云“觉明”，罽宾国人）、佛驮跋陀罗（此云“觉贤”，迦维卫国人）、名儒刘程之（号遗民）、张野、周续之、张诠、宗炳、雷次宗等，结社念佛，世号十八贤。复率众至百二十三人，同修净土之业。造西方三圣像，建斋立誓，令刘遗民著《发愿文》。而王乔之等，复为《念佛三昧诗》以见志。
    师神貌严肃，瞻仰者则心战。沙门有持如意致献者，不敢陈白，窃留座隅而去。法师慧义，强正少可，谓师弟子慧宝曰：“诸君肤浅，故于远公望风推服。”尝至山，值师讲《法华》，欲致难，辄内悸流汗。出谓慧宝曰：“此公言貌，诚可敬服。”
    殷仲堪任荆州，入山展敬，与师俱临北涧松下，共谈《易》道，终日忘倦。仲堪叹曰：“师智识深明，实难庶几。”师亦曰：“君之才辩，如此流泉。”（后人名其处曰“聪明泉”。）司徒王谧、护军王默，并钦慕风德，遥致敬礼（王谧有书往反）。
    卢循据江州，入山诣师。师少与循父嘏，同为书生，及见循，欢然道旧。其徒谏曰：“循为国寇，得不为人疑乎？”师曰：“我佛法中，情无取舍，识者自能察之，此何足惧。”及宋武进讨循，设帐桑尾，左右曰：“远公素住庐山，与循交厚。”宋武曰：“远公世表之人，何可疑也。”乃遣使驰书，遗以钱帛。
    有行者来侍师，善驱蛇，蛇为尽去，因号“辟蛇行者”。有一虎往来，时见行迹，未尝伤人，人号“游山虎”。师与社众，每游憩上方峰顶，患去水远。他日有虎跑其石，水为之出，因号“虎跑泉”。又于一峰，制《涅槃疏》，因名“掷笔峰”。
    初是大教流行江东，经卷未备，禅法无闻，律藏多阙。师乃令弟子法净、法领等，远越葱岭，旷岁来还，皆获梵本。昔安公在关中，请昙摩难提，出《阿毗昙心》，其人未善晋言，颇多疑滞。后僧伽提婆至，即请重译，及《三法度论》。于是二论乃兴，师即制序，以贻学者。闻鸠摩罗什入关，遣书通好。什答书曰：“传驿来贶，粗闻风德。经言：‘末代东方，有护法菩萨。’钦哉仁者，善弘其道！”昙摩流支入秦，师遣弟子昙邕，请于关中，出《十诵律》，流传晋国。西土诸僧，咸称汉地有大乘开士，每东向致礼，献心庐岳。及佛驮跋陀罗至，师即请出禅数诸经。于是禅、戒经典，出自庐山，几至百卷。先是此土未有“泥洹常住”之说，但言寿命长远。师曰：“佛是至极，至极则无变，无变之理，岂有穷耶？”乃著《法性论》十四篇〖清凉书屋校注：据陆澄《法论目录》，“十四篇”当为“上下篇”之误〗。罗什见而叹曰：“边方未见经，便暗与理合。”秦主钦风，以《大智度论》新译，致书求序。师以其文繁广，乃抄其要，为二十卷，而为之序。（罗什译《智论》凡百卷。）
    桓玄征殷仲堪，要师出虎溪，称疾不往。玄将入山，左右曰：“昔殷仲堪礼敬于远，请公勿屈。”玄曰：“仲堪死人耳。”及玄见师，不觉屈膝。所怀问难，不复敢发。及语至征讨，师即不答。玄后以震主之威，劝令登仕。师正辞以答，玄不能强。既而欲沙汰众僧，下教僚属曰：“沙门之徒，有能申述经诰、禁行修整者，始可以宣寄大化。其有违于此者，悉当罢黜。唯庐山道德所居，不在搜简之例。”师因致书，广立（《僧传》作“玄”）条制，玄悉从之。
    初庾冰辅政，以沙门应敬王者，何充奏不应礼。及玄在姑熟，复申冰议。师答书曰：“袈裟非朝宗之服，钵盂非廊庙之器，尘外之容，不应致敬王者。”乃著《沙门不敬王者论》五篇：一明在家者有天属之爱，奉主之礼。二明出家以求志，变俗以达道，岂得与世典同其礼敬。三明求宗不顺化，“宗”谓泥洹不变，以化尽为宅。（“泥洹”，即“涅槃”，翻“不生不灭”。）“不顺化”者，其生可灭，其神可冥，冥神绝境，谓之泥洹，而不随顺于生生化化、流动无穷之境。斯所以不事王侯，高尚其事，岂复有所礼敬者哉。四明体极不兼应，谓历代君王，体极之主，但务方内，而不可并御于方外，故曰“不兼应”。天地之道，功尽于运化；帝王之德，理极于顺通。与夫独绝之教、不变之宗，优劣明矣。若夫如来之道，则无所不应矣。五明形尽神不灭，谓火之传于薪，犹神之传于形。火之传异薪，犹神之传异形。方生方死，往来无穷。但悟彻者反本，惑理者逐物耳。有顷，玄纂位，即下书曰：“佛法宏诞，所未能了。初推奉主之情，故令兴敬。今事既在己，宜尽谦光，诸道人勿复致礼也。”桓玄西奔，安帝自江陵还京师。辅国何无忌，劝师候迎，师称疾不行。帝遣使劳问。师上书谢病，帝复下诏慰答。
    师尝讲《丧服经》（当是《礼记》“小记”、“大记”、“四制”等篇），雷次宗、宗炳等，并执卷承旨。次宗后著《义疏》，首称“雷氏”。宗炳寄书责之曰：“昔与足下，面受于释和上，今便称雷氏耶？”（陆德明《毛诗音义》云：“周续之，与雷次宗，同受《诗》义于远法师。”亦此类也。）
    释惠要，患山中无刻漏，乃于水上立十二叶芙蓉，因波随转，分定昼夜，以为行道之节，谓之“莲华漏”。僧澈善篇牍，尝至山南攀松而啸，和风远集，众鸟悲鸣，超然有自得之趣。退咨于师曰：“律禁管弦歌舞。若一吟一啸，可得为乎？”师曰：“苟以乱意，皆为非法。”澈唯而止。
    师居山三十年，迹不入俗，唯以净土克勤于念。初十一年，澄心系想，三睹圣相，沉厚不言。后十九年，七月晦夕，于般若台之东龛，方从定起，见阿弥陀佛，身满虚空，圆光之中，有诸化佛，观音、势至，左右侍立。又见水流光明，分十四支，流注上下，演说苦、空、无常、无我之音。佛告之曰：“我以本愿力故，来安慰汝。汝后七日，当生我国。”又见佛驮耶舍、慧持（义熙八年先逝）、慧永（义熙十年先逝）、刘遗民（义熙六年先逝），在佛之侧。前揖师曰：“师志在先，何来之晚！”师语法净、慧宝曰：“吾始居此，十一年中，三见佛相。今复见之，吾生净土必矣。”又曰：“七日之期，斯为渐矣。”即寝疾，制遗诫曰：“吾昔以知命之年，托业此山，自审有必尽之期，便欲绝迹外缘，以求其志。良由性弱于断，遂令同趣相引，时贤过眷，情以类感，不觉形与运颓，今年已八十三矣。仰寻远离之诲，俯慨自负之心，徒令此生虚谢，以悼往疾之深。于今时至，露骸松林之下，即岭为坟，与土木同状。此乃古人之礼，汝等勿违。苟神理不昧，庶达其诚，大哀世尊，亦当祐之以道。”门徒号恸，若丧父母。师以世情难割，乃制七日展哀，至期始顺寂，即义熙十二年八月六日也。弟子不忍露尸，与浔阳太守阮侃，奉全躯，举葬于西岭，累石为塔。谢灵运立碑，以铭遗德。张野作序，自称门人。宗炳复立碑于寺门，以表德业。
    师将终，耆德请以豉酒治病，师曰：“律无通文。”请饮米汁，师曰：“日过中矣。”又请饮蜜和水，乃令披律寻文，卷未半而终。所著经论诸序、铭、赞、诗、记，凡十卷，号《庐山集》（刻梓在绍兴府库）。自佛图澄、道安师、远法师、昙顺、僧睿，五世为国师云。唐宣宗大中二年，追谥“辩觉大师”。升元三年（南唐李先主年号，即晋高祖天福四年也），追谥“正觉”。大宋太宗太平兴国三年，追谥“圆悟大师凝寂之塔”。
    （前小注“匡俗”，“俗”字，《统纪》作“裕”，别又作“续”，不知孰是。因“续”、“俗”同音，故用“俗”，俟考。）


慧远法师传三

（《净土圣贤录》卷二）

    慧远，姓贾，雁门楼烦人。幼而好学，博综《六经》，尤善《庄》、《老》。时释道安，建刹于太行恒山，远往归之。闻安讲《般若经》，豁然开悟，因投簪受业。精思讽诵，以夜继昼。安叹曰：“使道流东国者，其在远乎！”
    晋太元六年过浔阳，见庐山闲旷，可以栖止，乃立精舍，号龙泉寺。时远同门慧永，先居庐山西林，欲邀同止。而远学侣寖众，西林隘不可处。刺史桓伊，为远更立寺于山东，遂号“东林”。远于是率众行道，凿池种莲，于水上立十二叶莲华，因波随转，分刻昼夜，以为行道之节。既而四方清信之士，闻风而至者，百二十三人。远曰：“诸君之来，能无意于净土乎？”乃造西方三圣像，建斋立社，令刘遗民著《发愿文》，勒之石。时王乔之等数人，复为《念佛三昧诗》以见志。远为作序曰：

    “夫称三昧者何？专思寂想之谓也。思专，则志一不分；想寂，则气虚神朗。气虚，则智恬其照；神朗，则无幽不彻。是二者，自然之玄符，会一而致用也。又诸三昧，其名甚众。功高易进，念佛为先。何者？穷玄极寂，尊号如来。体神合变，应不以方。故令入斯定者，昧然忘知，即所缘以成鉴。鉴明，则内照交映，而万象生焉。非耳目之所暨，而闻见行焉。于是灵相湛一，清明自然；玄音叩心，滞情融朗。非天下之至妙，孰能与于此哉！所以奉法诸贤，咸思一揆之契。感寸阴之将颓，惧来储之未积。洗心法堂，整襟清向。夜分忘寝，夙兴唯勤。庶夫贞诣之功，以通三乘之志。仰援超步，拔茅之兴。俯引弱进，垂策其后。以此览众篇之挥翰，岂徒文咏而已哉！”

    远以江东经藏多阙，遣弟子远越葱岭，购诸梵本，并传关中。所有经律，出诸庐山，几至百卷。尝造《法性论》，以明“泥洹常住”之旨。鸠摩罗什见而叹曰：“边方未见大经，便暗与理合。”
    居山三十年，迹不入俗。专志净土，澄心观想，三见圣相，而沉厚不言。义熙十二年七月晦夕，于般若台之东龛，方从定起，见阿弥陀佛，身满虚空，圆光之中，有诸化佛，观音、势至，左右侍立。又见水流光明，分十四支，回注上下，演说苦、空、无常、无我之音。佛告远曰：“我以本愿力故，来安慰汝。汝后七日，当生我国。”又见社中先化者，佛陀耶舍、慧持、慧永、刘遗民等，皆在侧。前揖曰：“师早发心，何来之晚！”远谓弟子法净、慧宝曰：“吾始居此，十一年中，三睹圣相。今复再见，吾生净土必矣。”即自制《遗诫》。至八月六日，端坐入寂，年八十三。
    慧持，远同母弟，与远同事安公。遍学众经，亦有高行。隆安中，辞兄入蜀，以西方为期。住郫县龙渊寺，大弘佛化。义熙八年入寂，年七十六。遗命诸弟子，务严律仪，专心净业云。


庐山慧远法师碑
谢灵运

    法师讳慧远，本姓贾，雁门楼烦人。弱而好学，年十三，随舅令狐氏，游学许、洛，故少为书生。二十一，欲渡江就范宣子。于时王路尚鲠，有志不遂。于关右遇释道安，一面定敬，以为真吾师也。遂抽簪落发，求直道场。沙门昙翼，每资以灯烛之费。安公曰：“道士诚知人。”法师藉旷劫之神明，表今生之灵智，道情深邃，识鉴渊微。般若无生之津，道行息心之观，妙理与高悟俱彻，冥宗与深心等至。安公叹曰：“使道流东国者，其在远乎！”
    太元初，襄阳既没，振锡南游，考室庐阜，结宇倾岩。同契不命，而景向闻道，誓期于霜雪。自以年至耳顺，足不越山。桓氏以震主之威，力为屈致。法师确然贞固，辞以老疾。俄而制使沙门尽敬王者，法师惧大法之将沦，抗言万乘。玄知不可强，俯而顺焉。既道渐中土，名流遐域，外国诸僧，咸来向礼。非夫道深德广，焉能使显默同归，异域致敬。且新经未表晋邦，律藏历年莫正。禅法甘露，国所未闻。实相宗本，人有异说。法师深存广图，大援群生，乃命弟子迎请禅师，究寻经本，逾历葱岭，跨越沙漠，弥旷年稔，并皆归还，既得传译，备尽法教。是故心禅诸经，出自庐山，几乎百卷。又以新本无二，即色三家之谈，不穷妙实，乃著《法性论》，理深辞婉，独拔怀抱。罗什见论而叹曰：“汉人未见新经，便暗与理会。”
    若夫温心善诱，发必远言。栖寄林岭，游兴能彻。虽复风云屡更，而无昭昧之情。俯仰尘化之域，游神无生之门。所谓言斯可发，行斯可乐矣。自枕石漱流，始终一概。恬智交养，三十余载。春秋八十三，命尽绝岭。遗言露骸松林，同之草木。达生神期，既于此矣。古人云：“道存人亡。”法师之谓。凡我门徒，感风徽之缅邈，伤语晤之永灭。敢以浅见，扬德金石。其辞曰：

九流乖真，三乘归佛。道往绝迹，慈还接物。
孰是发蒙，昭我慧日。摄乱以定，闲邪以律。
妙法常存，悠悠莫往。若人乘生，皎皎远赏。
鉴我鉴物，知狭知广。息生空谷，训徒幽壤。
秦皇雄惑，蔽理通情。王孙偏解，滞死达生。
夫子之悟，屡劫独明。仰高契峻，俯深怀清。
惟清惟峻，若隔近绝。惟高惟深，志崇智洁。
昔在香积，今也明哲。嗣之有人，实隆废歉。
揵度练数，甘露流津。律藏拂故，法性增新。
凡厥希道，日知好仁。景薄命尽，宗倾理湮。
寒暑递易，悲欣皋壤。秋蓬四转，春鸿五响。
孤松独秀，德音长往。节有推迁，情无遗想。

元熙二年春，二月朔，康乐公谢灵运撰。


远公影堂碑
李 演

    天之高哉，日星垂其曜。地之厚哉，山岳镇其维。禀两间之气，分五行之秀，而得预称于三才者，其为人道之最灵者乎！至若迈德宏域，融神慧境，焯迦维之绝照，挹甘露之玄津，并名岳而永崇，睎扶桑而不息，则慧远法师其人也。
    法师，雁门楼烦人，贾氏，释道安之门人。英姿雅韵，清行素节，详诸旧碑，及张氏传，固以杳映前秀，铺铄令闻者矣。灰心土骸，而神机天发。金口木舌，而法音雷震。无取无舍，而律仪冰彻。不生不灭，而禅性晖如。抱德阳和，而浩类洗心。潜灵渊照，而远方翘首。修不共法，而恒轸大悲。熏般若智，而富诸梵行。故能诱纳众善，泠汰群疑。万流仰海而同归，一雨施物而咸润。诚所谓阿摩勒果，实从中生；分陀利华，性非外染之为义也。自晋氏太元九年，法师始飞锡南岭，宅胜东林。世更七代，年垂四百，流风遗泽逮于今，而人知怀仰。故虎溪为释氏龙门，庐阜即搢绅阙里也。
    皇唐贞元十有一年，江州刺史冯翊严公士良，秉明德以分符，宣中和而述职。上赞缉熙之化，下临击壤之人。以无为为政，政克用乂。巡穑外野，指途中林，敷衽禅关，式瞻遗像。喟然叹曰：“斯名也，寒暑不能易其芳。斯德也，江海无以臻其极。彼琐行纤节，尚崇植楹庑，正位居室。岂尊美若兹，而寓形在壁！”乃与寺之上首熙怡律师，图建胜宇，用昭真相。旌美树若，二谋同心。说徒勒工，成之匪石。绣甍云耸，睟容景彰。观至道者，存妙像于境中。味微言者，得玄珠于意表。岂只慧义慑英姿而雨汗，仲堪仰素风而心醉哉！故非夫远公之至德，不能译圣文，服秀民。非夫严公之彻识，不能立清祀，扬妙范。篆芳金石，敬赞二美。乃为之铭曰：

粹灵纯纶，实惟至人。含德摛曜，升阳发春。
道光海域，幽遁岳滨。六髦弃黻，八士辞巾。
缘徂物谢，迹留事往。百亿神游，恒沙化广。
昭昭遐一，泠泠末响。慧日凝晖，白云翘想。
旷哉明牧，仰味芳风。思觌遗像，求之列墉。
爰建栋宇，式是道宗。旌休垂美，地广山崇。

唐大中八年七月望日，陇西李演撰，三纲徒众立。


远法师铭
张 野

（《世说新语》注）

    沙门释慧远，雁门楼烦人，本姓贾氏，世为冠族。年十三，随舅令狐氏，游学许、洛。年二十一，欲南渡，就范宣子学。道阻不通，遇释道安以为师，抽簪落发，研求法藏。释昙翼，每资以灯烛之费。诵鉴淹远，高悟冥赜。安尝叹曰：“道流东国，其在远乎！”襄阳既没，振锡南游，结宇灵岳。自年六十，不复出山。名被流沙，彼国僧众，皆称汉地有大乘沙门，每至燃香礼拜，辄东向致敬。年八十三而终。（录《世说新语》卷上之下）


远公影堂记一
元 皓

    一真绝迹，诸法本无。不凭有有之缘，孰究空空之理。慧远法师，外则诗书礼义，接引群机。内则戒定慧解，入真实际。在昔影堂，犹多毁圮。晋帝之龙舆虽在，石门之雁塔将隳。大吴大和一年，诏改封平原王为德化王，移镇九江。既求民瘼，仍奉佛乘。拥斾二林，栖神真境。复陈香炼，大会缁徒。回步师堂，俯仰良久。眷言重构，益展清规。辉华若天界飞来，严丽状龙宫涌出。鸳瓦丛翠，昼疑松桧之烟。宝铎叮当，夜泛莲华之漏。一千年之气貌，粉绘重新。七百载之车舆，安藏永固。


远公影堂记二
明教大师

（《镡津文集》）

    远公事迹，学者虽见，而鲜能尽之。使世不昭昭见先贤之德，亦后学之过也。予读《高僧传》、《莲社记》，及《九江新旧录》，最爱远公六事，谓可以劝也。乃引而释之，列之其影堂，以示来者。
    陆修静，异教学者，而送过虎溪，是不以人而弃言也。陶渊明，耽湎于酒，而与之交者，盖简小节，而取其达也。跋陀高僧，以显异被摈，而延且誉之，盖重有识，而矫嫉贤也。谢灵运，以心杂不取，而果殁于刑，盖识其器，而慎其终也。卢循欲叛，而执手求旧，盖自信道也。桓玄震威，而抗对不屈，盖有大节也。
    大凡古今人情，莫不畏威而苟免，忘义而避疑，好名而昧实，党势而忍孤，饰行而畏累，自是而非人。孰有道尊一代，为贤者师，肯以片言而从其人乎？孰有宿禀胜德，为行耿洁，肯交醉卿，而高其达乎？孰有屈人师之尊，礼斥逐之客，而伸其贤乎？孰有拒盛名之士，不与于教，而克全终乎？孰有义不避祸，敦睦故旧，而信道乎？孰有临将帅之威，在杀罚暴虐之际，守道不挠，而存其节乎？此故远公识量远大，独出于古今矣。若其荷负至教，广大圣道，垂祐于天人者，非蒙乃能尽之。其圣欤？贤耶？伟乎！
    大块噫气，六合清风，远公之名闻也。四海秋色，神山中耸，远公之清高也。人僧龙凤，高揖巢许，远公之风轨也。白云丹嶂，玉树瑶草，远公之栖处也。蒙后公而生，虽慕且恨也。瞻其遗像，稽首作礼，爰以弊文，书于屋壁。


远祖师事实

（《莲宗宝鉴》卷四）

    师讳慧远，雁门楼烦人，今河东代州，姓贾氏。生于石赵延熙甲午岁，为晋成帝咸和九年。师十二岁，从舅令狐氏，游学许、洛，博通《六经》，尤通《周易》、《庄》、《老》之书。二十一岁，欲渡江，与范宣子俱隐。值中原兵戈塞路，闻道安法师居太行山，遂与弟慧持俱投之。听讲《般若经》，豁然大悟，叹曰：“儒道九流，皆糠秕耳！”与弟投簪落发，常以大法为己任。安叹曰：“使道流中（别多作“东”）国，其在远乎！”
    孝武帝太元九年（《圣贤录》、《统纪》皆作六年），至庐山，以杖卓地曰：“有泉当住。”忽泉迸出，乃诛茅为庵。讲《涅槃经》，感得山神献灵，资助材木，雷雨辟地。江州太守惊其神异，奏立东林寺，名其殿曰“神运”。太元十一年，寺成。师以东南经律未备，禅法无闻，乃于寺内别置禅室，请一禅师率众习禅。令弟子逾越沙漠，求禅经，庶江表四辈，咸皆得以修习。愿使大乘之化，自北而南。
    每谓禅法深微，非才莫授。入道要门，功高易进者，念佛为先。师徒众往来三千，真信之士一百二十三人，乃与刘遗民等十八贤为上首，于无量寿佛像前，建斋立誓，同修西方净土，结白莲社。遗民著《发愿文》，师自制《念佛三昧序》。谢灵运恃才傲物，一见师，肃然心服，凿池种莲求入社，师以心杂止之。
    山多蛇，有行者，不知何许人，常侍于师，善驱蛇，至今号“辟蛇圣者”。师所居，流泉匝寺，下入虎溪，每送客，以溪为界。时陶渊明、陆修静，师尝送之，语道契合，不觉过溪，相与大笑，后世因传《三笑图》焉。
    时罗什法师，通书称师为东方护法菩萨。外国众僧，咸称汉地有大乘道士，每烧香礼拜，东向稽首，献心庐岳。姚主钦承道德，信饷连接。晋安帝隆安元年，桓玄劝帝沙汰僧尼，谓庐山为道德所居，不在搜简。师以书抵玄，得并免。元兴元年，玄又申庾冰之议，欲沙门尽敬王者。复以书辩论其事，遂免。安帝自江陵旋京，辅国何无忌，劝师候迎，称疾不起。帝遣使劳问，师表以闻，帝优诏答之。
    义熙乙卯十一月初一日，师入定，至十七日出定，见阿弥陀佛紫磨黄金身，遍满空界。《龙舒净土文》载：“远公三睹圣相，沉厚不言。”师三十年影不出山，足不入俗。丙辰八月初一日示疾，至六日困笃。大德耆旧，请饮豉酒，不许。又请以蜜水，乃命律师检藏，未见。而集诸徒遗诫曰：“吾自知命之年，托业此山，自审有毕尽之期，乃绝迹外缘，以求其志。不觉形与运颓，已八十三矣。时至，欲厝骨于松林之下，即岭为坟，与土木同状。此古人之礼，汝等勿违。苟使神理不昧，庶达其诚，大哀世尊，亦当祐之以道。”言讫而逝。门人与浔阳太守及官属，奉全躯葬于西岭，垒石而塔焉。安帝谥“庐山尊者、鸿胪大卿、白莲社主凝寂之塔”。谢灵运立碑，以铭其德。张野序之。有《匡山集》十卷行于世。


远祖师历朝谥号

（《莲宗宝鉴》卷四）

    晋安帝义熙年，谥“庐山尊者、鸿胪大卿、白莲社主”。
    唐大中戊辰年，谥“辩觉大师”。
    南唐升元三年，谥“正觉大师”。
    宋太平兴国三年，谥“圆悟大师”。
    宋乾道二年，谥“等遍正觉圆悟大法师”。


庐山十八大贤名氏

（《莲宗宝鉴》卷四）

    远公祖师 （讳慧远，姓贾氏，雁门楼烦人。）
    永法师 （讳慧永，姓繁，河内人。）
    持法师 （讳慧持，远公弟也，与兄俱事道安法师。）
    生法师 （讳道生，出魏氏，巨野人。）
    佛陀耶舍尊者 （此云“觉明”，罽宾国婆罗门种。）
    佛陀跋陀罗尊者 （此云“觉贤”，甘露饭王之裔。）
    睿法师 （讳慧睿，冀州人。）
    顺法师 （讳昙顺，黄龙人。）
    敬法师 （讳道敬，琅玡王氏，随祖凝之守江州。）
    恒法师 （讳昙恒，河东人，童子出家，不知姓氏。）
    昺法师 （讳道昺，颖川陈氏。）
    诜法师 （讳昙诜，广陵人，不知姓氏。）
    刘遗民 （讳程之，字仲思，彭城聚里人，汉楚元王之后。）
    散骑常侍雷公 （讳次宗，字仲伦，南昌人。）
    太子舍人宗公 （讳炳，字少文，南阳人。）
    治中张公 （讳野，字莱民。）
    散骑常侍张公（讳诠，字秀硕，莱民族也。）
    通隐处士周公 （讳续之，字道祖，雁门广武人。）


东林寺碑
李 邕

    古者将有圣贤，必应山岳。尼丘启于夫子，鹫岭保于释迦，衡阜之托思，天台之栖顗，岂徒然也！故知土不厚，则巨材不生；地不灵，则异人不降。阴骘潜运，玄符肇开，宿根果于福庭，大事萌于净土，其来尚矣。
    东林寺者，晋太元九年，慧远法师之所建也。世居雁门楼烦，俗姓贾氏。童妙神悟，壮力精博。初涉华学，不读非圣之书。中留梵经，尤邃是田之说。尝就恒岳，觏止道安，如火遇薪，玉成于器，虽根种诸佛，而果得一时。狮子吼言，载闻顺喻。维摩诘答，更了空门。安住四依，修舍二法。和尚叹曰：“吾道行者，唯此人焉！”属朱序寻戈，缁徒逃海，道由兹岭，冥契宿诚，谓其徒曰：“是处崇胜，有足底居。居地若无流泉，曷云法宇？”大雄神庙，特异莲峰。结跏一心，开宗五力。以杖刺地，应时涌泉。既荷殊祥，因立精舍。坚持禁戒，弘演妙乘。浮囊毒流，木铎正教。首唱南部，转觉后人。以智慧力，断烦恼锁。由是真僧益广，妙供日崇。隘其本图，弘其别业。乃进自香谷，集坂安栖。即昙现之门生，邻慧永之阿若。相与撰平圃，逾层岩，在山之阳，居水之右。经其始而未究其末，有其所而未虞其劳。
    当是时也，桓玄司人柄，干国钧，以福庄严，因憻檀施。书日力之费，尽土木之功。缭垣云连，厦屋天耸。如来之室，宛化出于林间。帝释之幢，忽飞来于空外。至若奥宇冬燠，高台夏凊。玉水文阶而碧沙，瑶林藻庭而朱实。琉璃之地，月照灼而徘徊。栴檀之龛，吹芳芬而馝馞。相事毕集，微妙绝时。罗什致其澡瓶，巧穷双口。姚兴奉其雕像，工极五年。殷堪抠衣而每谈，卢循避席而累赞。道弘三界，何止八部宅心。声闻十方，足使诸天回首。观其育王赎罪，文殊降形。蹈海不沉，验于陶侃。迫火不爇，梦于僧珍。愿苟存诚，祈心通感。既多雨以出日，乍积阳以作霖。则有影图西来，舍利东化。或塔涌于地，或光属于天。谢客欣味而成文，刘斐诋诃而覃思。所以山亚五岳，江比四溟。地凭法而自高，物因词而益重。
    洎梁有崇禅师者，传灯习明，安心乐行。指拳犹昔，薪尽如生。次有果、暀二法师，僧宝所钦，克和止观，法物为大，用继住持。上座昙杰、寺主道廉、都维那道真等，皆沐浴福河，栖止静业。诸结已尽，白黑双遣。众生可度，名色两忘。綦盛名于旧人，启新意于今作。重建雅颂，远托鄙夫。代斲有惭，岂云伤手。握笔余勇，曷议齐贤。但相如好仁，慕蔺名而激节。伯喈闻义，读曹碑而羡能。倘青色于蓝，冰寒于水，非曰能也，固请学焉。其词曰：

灵山兆发，真僧感通。刺泉有力，呵神致功。
法曹外演，禅心内融。性除偏执，门开太空。
瞻礼云集，底居峰薄。越岭图胜，降平规博。
信臣檀施，护供兴作。大起重阶，广延阿阁。
严幢涌出，宝塔飞来。尊客月满，法宇天开。
化城改筑，道树移栽。松清梵乐，石蔽华台。
金容海游，法宇山荐。毒龙业消，渔子心变。
万里西传，一时东现。华戎异闻，穹厚惊盼。
远实法主，谢惟文伯。光颂累彰，德名增益。
助起江山，声流金石。一言可追，千载相激。
了性了义，或古或今。止持绍律，定慧通心。
睹物情至，怀远道深。敢凭净业，永纪禅林。


与慧远法师书
释法远

（《全晋文》一百六十三，引明《南藏》“辇”字八卷《高僧传》）

    吾人微暗短，不能率众。和尚虽隔在异域，犹远垂忧念，吾罪深矣。


慧远法师诔
谢灵运

（《广弘明集》卷二十六）

    道存一致，故异化同晖。德合理妙，故殊方齐致。昔释安公振玄风于关右，法师嗣沫流于江左。闻风而悦，四海同归。尔乃怀仁山林，隐居求志。于是众僧云集，勤修净行。同法餐风，栖迟道门。可谓五百之季，仰绍舍卫之风。庐山之嵔，俯传灵鹫之旨。洋洋乎，未曾闻也！予志学之年，希门人之末。惜哉！诚愿弗遂，永违此世。春秋八十有四，义熙十三年秋八月六日薨。（按各传记，皆以义熙十二年丙辰，为公示寂之年，寿八十三。而此作十三年丁巳，寿八十四，已与各传记小异。至《稽古略》，又作十一年乙卯西逝，寿八十四，则生年当前二年，更为不合。第传写之讹，各书不免，阅者谅之。）年逾从心，功遂身亡。有始斯终，千载垂光。呜呼哀哉！乃为诔曰：

    于昔安公，道风允被。大法将尽，颓纲是寄。体静息动，怀真整伪。事师以孝，养徒以义。仰弘如来，宣扬法雨。俯授法师，威仪允举。学不窥牖，鉴不出户。粳粮虽御，独为苌楚。朗朗高堂，肃肃法庭。既严既静，愈高愈清。从容音旨，优游仪形。广演慈悲，饶益众生。堂堂其器，亹亹其资。总角味道，辞亲随师。供养三宝，析微辩疑。盛化济济，仁德怡怡。于焉问道，四海承风。有心载驰，戒德鞠躬。令声续振，五浊暂隆。弘道赞扬，弥虚弥冲。十六王子，孺童先觉。公之出家，年未志学。如彼邓林，甘露润泽。如彼琼瑶，既磨既琢。大宗戾止，座众龙集。聿来胥宇，灵寺奚立。旧望研几，新学时习。公之勖之，载和载辑。乃修什公，宗望交泰。乃延禅众，亲承三昧。众美合流，可久可大。穆穆道德，超于利害。六合俱否，山崩海竭。日月沉辉，三光寝晰。众麓摧柯，连波中结。鸿化垂绪，徽风永灭。呜呼哀哉！生尽冲素，死增伤凄。单蛰土椁，示同敛骸。人天感悴，帝释恸怀。习习遗风，依依余凄。悲夫法师，终然是栖。室无停响，途有广蹊。呜呼哀哉！端木丧尼，哀直六年。仰慕洙泗，俯惮蹄筌。今子门徒，实同斯艰。晨扫虚房，夕泣空山。呜呼法师，何时复还！风啸竹柏，云蔼岩峰。川壑如泣，山林改容。自昔闻风，志愿归依。山川路邈，心往形违。始终衔恨，宿缘轻微。安养有寄，阎浮无希。呜呼哀哉！

    （“可久可大”，《广弘明集》“久”字作“上”。“单蛰土椁”，《广弘明集》“蛰”字作“絷”。）


庐山远公赞
陈 谦

（《庐山志》）

楼烦擅博综，皈志恒山里。
一闻《般若经》，幡然弃经史。
至今白莲池，以比功德水。


辨远祖成道事

（《庐山莲宗宝鉴》）

    《礼记》曰：“先祖无美而称之者，是诬也。有善而弗知者，是不明也。知而不传者，是不仁也。此三者，君子之所耻也。”噫！在吾学佛之徒，岂不然耶？
    吾祖远公，行位昭昭，功德广大。愚忝与其教，为末流之裔，不肖孤陋，学浅才疏，未能绍袭先宗，实乃有孤慈荫。尝读明教《记》，不亦甚惭乎！又尝观石室琇禅师《通论》云：“去孔子百年，而有孟轲，是时孔子之道几衰焉，轲于是力行其道，而振起之。伏自佛教东流，凡三百年，而有远公，是时沙门寖盛，然未有特立独行，宪章懿范，为天下宗师如远公者，佛道由之始振。”盖尝谓远公有大功于释氏，犹孔门之孟子焉。与高僧、朝士，同修净社，道动帝王，法流天下。
    后之所习念佛者，不知吾祖之本末，失其源流。多见世之薄福阐提辈，伪撰《庐山成道记》，装饰虚辞，尽是无根之语，诳惑善信，遍传在人耳目，逮今不能改革。予乃参考大藏《弘明集》、《高僧传》，察其详要，略举七事，以破群惑，识者鉴之：远公礼太行山道安法师出家，妄传师栴檀尊者，一诳也。妄以道安为远公孙者，二诳也。远公三十年影不出山，足不入俗，妄谓白庄劫掳者，三诳也。晋帝三召，远公称疾不赴，妄谓卖身与崔相公为奴者，四诳也。道安臂有肉钏，妄谓远公者，五诳也。临终遗命，露骸松下，全身葬西岭，现在凝寂塔可证，妄谓远公乘彩船升兜率者，六诳也。道生法师，虎丘讲经，指石为誓，石乃点头，妄谓远公者，七诳也。
    悲夫！世之奸佞，不知祖师实德，道听途说，妄装点许多不逊之事。播丑于后世，取笑于四方，谤渎圣德。识者见之，不察其所由，得不轻侮于吾祖师耶？岂非出佛身血，五逆罪乎？尝观宋元嘉中，僧才观、惠严、谢灵运，翻《涅槃经》，增损其辞。因梦神人诃之曰：“敢以凡情，轻渎圣典？”观等惧而止。又惠琳，以才学幸帝，时号“黑衣宰相”，自著《白黑论》毁佛教，即感恶疾，肤肉糜烂而死。夫如是则妄造祖师传记，三途地狱，可不惧乎？凡吾同志，详审远公实迹，从本至末，痛告诸方，光扬祖道。庶先圣之屈，于斯雪矣。


奉晋王述匡山寺书
智者大师

    江州匡山东林寺者，东晋雁门慧远法师之所创也。远是弥天释道安之高足，安是大和尚佛图澄之弟子。三德相承，如日月星，真佛法梁栋，皆不可思议人也。而远内闲半满，外善三玄，德布遐方，声高霄汉。初诣山足，依止一林，共耶舍禅师头陀其下，若说若默，修西方观。末于林右建立伽蓝，因以为名东林之寺。远自创般若、佛影二台，谢灵运穿凿流池三所。梁孝元构造重阁，庄严寺宇，即日宛然。峰顶寺者，是齐慧景禅师，感山人延请，因住其峰。次梁慧归，在后登蹑，方建伽蓝。峰有水泉，忽然枯涸。归烧香咒愿，清流盈满，天降甘露于泥洹日。是以先德名踪，垂芳不断。松霞清旷，触处萧条。公私往还，莫不归向。
    自大化江左，贫道因至彼山，憩泊东林，时游峰顶，以岁为日，羡玩忘劳。然下山伽蓝，偏近驿道，行人去来，颇成混杂。今奉请为两寺檀越，庶藉影响，众得安心，礼诵虔诚，用酬洪泽。并乞勒彼所由，永禁公私停泊。沙门某敬白。

附：晋王广与禅阁寺书

    春序将谢，道体何如，僧众清善。匡山佛寺，兴自慧远法师。法师师于弥天道安，安师于佛图澄，妙德相承，莫之为最。江东龙藏，悉本雁门。上人创迹庐阜，自晋及梁，只有东林。陈晚浇漓，别生禅阁。僧徒好异，岂称至和？智者爰居，还须合一。想均愿海，更无异味。行人将送过，指此相闻。杨广和南。

附：晋王与匡山寺书

    极暄，法师道体何如，众内咸宜也。雁门远法师，四依菩萨，翻飞朔野，栖息南山。自斯以后，名德相继。智者见令为寺檀越，顾修寡薄，非敢克当。奖道既引，良深随喜。敬德指此承问。杨广和南。


远公龛诗
刘长卿

（《庐山志》）

松路向精舍，华龛归老僧。
闲云移锡杖，落日低金绳。
入夜翠微里，千峰明一灯。


远公墓诗
释灵彻

（《庐山志》）

古墓石棱棱，寒云晓景凝。
空悲虎溪月，不见雁门僧。


题庐山东林寺远公影堂诗
李 中

（《庐山志》）

远公遁迹在东林，往事名存动苦吟。
杉桧已依灵塔老，烟霞空锁影堂深。
入帘轻吹催香印，落石幽泉杂磬音。
十八贤人消息断，莲池千载月沉沉。


十八贤影堂诗
贯 休

（《莲宗宝鉴》）

白藕池边旧影堂，刘雷风骨尽龙章。
共轻天子诸侯贵，唯爱吾师一法长。
陶令醉多招不得，谢公心乱入无方。
何人到此思高躅，风点苔痕过短墙。


夏日题远公北阁诗
罗 邺

危阁压山冈，晴空疑鸟行。
胜搜花界尽，响益梵音长。
有月堪先到，无风亦自凉。
人烟纷绕绕，诸树共苍苍。
榻恋高楼语，瓯怜春茗香。
此身闲未得，驱马入残阳。


远公讲经台诗
祖 咏

（《庐山志》十三引）

兰若无人到，真僧出复稀。
苔侵行道席，云湿坐禅衣。
涧鼠缘香案，山蝉噪竹扉。
世间常不见，宁止暂忘归。


远公讲经台诗
王守仁

（《庐山志》十三引）

远公说法有高台，一朵青莲云外开。
台上久无狮子吼，野狐时复带经来。


讲经台诗
阎尔梅

（《庐山志》十三引）

蹒跚列坐讲经台，菜子花从乱水开。
水外有山山不尽，白云晴处大江来。


杂 事

    殷荆州曾问远公：“《易》以何为体？”答曰：“《易》以感为体。”殷曰：“铜山西崩，灵钟东应，便是《易》耶？”远公笑而不答。（《世说新语》卷上之下）
    远公在庐山中，虽老，讲论不辍。弟子中或有惰者，远公曰：“桑榆之光，理无远照，但愿朝阳之晖，与时并明耳。”执经登座，讽诵朗畅，词色甚苦。高足之徒，皆肃然增敬。（《世说新语》卷中之下）
    陶渊明闻远公议论，谓人曰：“令人颇发深省。”（《杜诗注》）
    灵运欲入社，远拒之曰：“子发鬒而须美，面与身戾，非令终之相。请多行阴德，戒饬三年而后可。”灵运怒曰：“学道在心，安以貌耶？”远笑而不答。（嵩仲灵《钞书记》）
    法汰与道安别，沿江东下，遇疾停阳口。安遣弟子慧远，下荆问疾。时沙门道恒，颇有才力，常执心无义，大行荆土。汰曰：“此是邪说，应须破之。”乃大集名僧，令弟子昙壹难之，据经引理，析驳纷纭。恒拔（疑作“仗”）其口辩，不肯受屈。日暮，明旦更集，慧远就席。攻难数番，关责锋起。恒自觉义途差异，神色微动，麈尾扣案，未即有答。远曰：“不疾而速，杼柚何为！”坐者皆笑。心无之义，于此遂息。（《竺法汰传》）
    远法师遣诸道人行卜地，息此而渴。法师以杖掘地，泉出。天旱，法师令道人读《龙王经》，泉中有物如蛇而角，腾去，须臾即雨。
    远法师居庐阜三十余年，影不出山，迹不入俗。送客过虎溪，虎輒鸣号。昔陶元亮，居栗里。山南陆修静，亦有道之士。远师尝送此二人，与语道合，不觉过之，因相与大笑。今世传《三笑图》。（周景式《庐山记》二则）
    远师结白莲社，以书招渊明。陶曰：“弟子嗜酒，若许饮，即往矣。”远许之，遂造焉。因勉令入社，陶攒眉而去。（《庐阜杂记》）
    远与殷仲堪论道，殷才辩纵横。远指流泉谓之曰：“君侯聪明，若斯泉矣。”（陈舜俞《庐山记》）
    初远公自楼烦至庐山，结庵于西林之东以居，曰龙泉精舍。其后刺史桓伊，为请立寺曰东林，而名殿曰神运殿。（元人黎崱《纪游集》）
    远公塔，相传其墓门在塔南阶下。永乐中，有人开之，见远公兀坐，其貌如生焉。
    讲经台，亦一峰也。峰顶有磐石，可坐百人，远公常据此讲《涅槃经》。又于台畔筑庵居之，制《涅槃经疏》。台下有二石室，风洞开门石。南上，即云顶石。（《庐山志》十三，引桑乔《庐山纪事》二则）
    崇福寺，慧远建。（《庐山志》十三，引《九江志》）
    大林寺，亦慧远建。（同上）
    化城寺，晋远公建。（同上）
    远建寺时，鬼夜为之叠墙。（《庐山志》十二上）


远公年谱七则

    殷仲堪出镇荆州，道经庐山，与远法师讲《易》。（《庐山志》一）
    范宁守豫章，远请入社，宁不从。（《庐山志》十二上）
    义熙四年，师与社贤游上方塔，患水远，有虎跑石出泉。（同上）
    岁庚寅，刘遗民著《发愿文》。辛丑，王羲之曾孙，道敬出家。庚戌，刘遗民端坐而逝。辛亥，道生始入社。壬子，佛陀耶舍始入社。（同上）
    太元十七年癸巳，谢灵运凿池种莲。（同上）
    安帝隆安二年，慧持入蜀。（同上）
    远弟子慧安，立木芙蓉十二叶于泉水中，因波转以定十二时。（同上 ○“慧安”，《统纪》作“惠要”。）


远公遗文轶事补录
清凉书屋辑

    ●庐山慧远法师，默问长安草堂摩诃乘法师鸠摩罗什，大乘经中深义，十有八途。什法师一一开答。分为上、中、下三卷。上卷有六事：《问答真法身》、《重问答法身》、《问答法身像类》、《问答法身寿量》、《问答三十二相》、《问答受决》；中卷有七事：《问答法身感应》、《问答法身尽本》、《问答造色法》、《问答罗汉受决》、《问答观佛三昧》、《问答四相》、《问答如法性真际》；下卷有五事：《问答实法有》、《问答分破空》、《问答后识追忆前识》、《问答遍学》、《问答住寿》。（《大乘大义章》）
    ●刘宋中书侍郎陆澄，撰《法论目录》，著录远公撰述四十一种。现存世者，见于《庐山慧远法师文钞》、《大乘大义章》。已佚失的则有：《法性论》上下、《妙法莲华经序》、《无三乘统略》、《法社节度序》、《外寺僧节度序》、《节度序》、《比丘尼节度序》、《与释慧远书论真人至极》（释慧远答）、《问法身非色》、《释神足》、《辩心意识》、《释神名》、《验寄名》、《问论神》，共十四种。（参见《出三藏记集》卷十二）
    ●慧远法师尝云：“释氏之化，无所不可，适道固自教源，济俗亦为要务。世主若能剪其讹伪，奖其验实，与皇之政并行四海，幽显协力，共敦黎庶。何成、康、文、景，独可奇哉？使周、汉之初，复兼此化，颂作刑清，倍当速耳。”（《弘明集·何令尚之答宋文皇帝赞扬佛教事》）
    ●庐山远大师释《涅槃经》：“问云：‘若无所得，云何作善？’佛答，明诸众生现有佛性，当必得果，如子在胎，定生不久，理须修善。又问：‘我今不知所趣入处，云何作善？’佛答，有如来藏，可以趣入，宜修善业。”（永明延寿《万善同归集》）
    ●庐山远大师云：“唯一知性，随用分多，非全心外别有诸数。譬如一金，作种种器，非是金外别有器体。随用别分受、想、行等，各守自相，得言有数，如金与器，非无差别。金、器虽别，时无前后，心法如是。若言定一金，时应当无其诸器。若言定别器，应非一金。心法一异，准此可知矣。”（永明延寿《宗镜录》）
    ●远法师云：“无明缘行者，有四无明：一、迷理无明，义通始终。二、发业无明，在于行前。三、覆业无明，此在行后识前。四、受生无明，与识同时，或在识后。”（永明延寿《宗镜录》）
    ●远大师云：“缘集义者，统唯一种，或分为二，约真妄开：一、妄缘集，三界虚妄，唯一心作，如梦所见，但是妄心解；二、真缘集，一切诸法，皆真心起，如梦所见，皆报心作。或约心识说三：一、就事缘集，从其事识，起一切法；二、妄缘集，从其妄缘，起一切法；三、真缘集，真识体中，具过一切恒沙性德，互相集成，故言缘集，又从真识，起一切法。故经说言：‘若无如来藏识，七识不住，不得厌苦，乐求涅槃。由如来藏，故起诸法。’又就有为无为说三，即：一有为缘集，二无为缘集，三具二缘集。”（永明延寿《宗镜录》）
    ●远大师云：“实相理穷，名为毕竟。体寂无为，名不生灭。此不生灭，是彼无常真实性故，名无常义。”（永明延寿《宗镜录》）
    ●庐山远法师本无义云：“因缘之所有者，本无之所无。本无之所无者，谓之本无。本无与法性，同实而异名也。性异于无者，察于性也。无异于性者，察于无也。察性者不知知无，察无者不知知性。知性无性者，其唯无察也。”（惠达《肇论疏》）
    ●远师云：“法身独还，不疾而速。”（惠达《肇论疏》）
    ●庐山中诸人问曰：“众经明空，其辞虽多方，不固各异，统归宜同，而独称法性何耶？”答：“明极之谓也，明极则神功周尽，圣智几乎息。”问：“然则体法性者将为哉？”答：“唯冥其极而已。”远师《法性论》成后二章，始得什师所译《大品经》，以为明验，证成前义。云法性者名涅槃，不可坏，不可戏论。性名本分种，如黄石中有金性，白石中有银性。譬如金刚在山顶，渐渐穿下，至金刚地际乃止。诸法亦如是，种种别异，到自性乃止。亦如众流会归于海，合为一味，是名法性也。（惠达《肇论疏》）
    ●远法师作《法性论》，自问云：“性空是法性乎？”答曰：“非。性空者即所空而为名。法性是法真性，非空名也。今何得会为一耶？”（元康《肇论疏》）
    ●远法师云：“眇莽无明，犹促夜之有旦，似寐而不觉。”（惠达《肇论疏》）
    ●“蔚登玄室”者，远师云：“名冠入室，迹并绝尘。”贤人为升堂，圣人为入室是也。（惠达《肇论疏》）
    ●远师云：“欲辟重冥于幽室，必开户牖以通其照。冥冥玄夜，幽寝无期，玄音发咏而大道宣流也。”（惠达《肇论疏》）
    ●远师云：“非夫圣近善诱，孰窥其畔。非夫穷神冥应，孰岸其极也。”（惠达《肇论疏》）
    ●般若之法，理性无差。比者学人释有差异，以其不能明般若之性，故异说不同。即如《远法师集》云：“闻壹公以等智为般若，情实不甘。”即其事也。何者？等智者是共有之智，上下是同。如《涅槃经》云：“一切众生，皆有三种等智，所谓淫欲、恐怖、饮食。”小乘依此，故立等智。此是粗近，未为深妙，岂以此智而为般若乎？道壹师不解，故云以此为般若耳。今肇法师亦弹此义。（元康《肇论疏》）
    ●安常注诸经，恐不合理，乃誓曰：“若所说不甚远理，愿见瑞相。”乃梦见胡道人，头白眉毛长，语安云：“君所注经，殊合道理。我不得入泥洹，住在西域，当相助弘通，可时时设食。”后《十诵律》至，远公乃知和上所梦，宾头卢也。于是立座饭之，处处成则。（《高僧传·道安传》）
    ●庐山远法师作《刘公传》云：“刘程之，字仲思，彭城人，汉楚元王裔也。承积庆之冲粹，体方外之虚心。百家渊谈，靡不游目。精研佛理，以期尽妙。陈郡殷仲文、谯国桓玄，诸有心之士，莫不崇拭。禄寻阳柴桑，以为入山之资。未旋几时，桓玄东下，格称永始。逆谋始，刘便命孥，考室林薮。义熙，公侯咸辟命，皆逊辞以免。九年，太尉刘公知其野志冲邈，乃以高尚人望相礼，遂其初心。居山十有二年卒。”（元康《肇论疏》、遵式《注肇论疏》）
    ●刘程之力辞举荐，乃之庐阜，以托于远公。远公曰：“官禄巍巍，欲何不为？”程之曰：“君臣相疑，疣赘相窥。晋室无磐石之固，物情有累卵之危。吾何为哉？”远闻其说，大相器厚。太尉刘公，亦以其志不可以力屈，与群公议“遗民”之号旌焉。及雷次宗、周续之、毕颖之、张秀实等，同来依远。远曰：“诸公之来，岂宜忘净土之游乎？如有心焉，当加勉励，无宜后也。”程之于诸公中，又最有文，得志其事，镵石以永之。（《净土往生传》、《新修往生传》）
    ●肇著《般若无知论》，凡二千余言，竟以呈什。什读之称善，乃谓肇曰：“吾解不谢子，辞当相挹。”时庐山隐士刘遗民，见肇此论，乃叹曰：“不意方袍，复有平叔。”因以呈远公。远乃抚机叹曰：“未常有也。”因共披寻玩味，更存往复。（《高僧传·僧肇传》）
    ●此山僧清常，道戒弥励。禅隐之余，则惟研惟讲。恂恂穆穆，故可乐矣。弟子既以遂宿心，而睹兹上轨，感寄之诚，日月铭至。远法师顷恒履宜，思业精诣，乾乾宵夕。自非道用潜流，理为神御，孰以过顺之年，湛气若兹之勤？所以凭慰既深，仰谢逾绝。去年夏末，始见生上人示《无知论》，才运清俊，旨中沉允。推涉圣文，婉而有归，披味殷勤，不能释手。直可谓浴心《方等》之渊，而悟怀绝冥之肆者矣。论至日，即与远法师详省之，法师亦好相领得意。但标位似各有本，或当不必理尽同矣。（《肇论·刘遗民书问》）
    ●君既遂嘉遁之志，标越俗之美，独恬事外，欢足方寸。每一言集，何尝不远，喻林下之雅咏，高致悠然。清散未期，厚自保爱。每因行李，数有承问。愿彼山僧无恙，道俗通佳。承远法师之胜常，以为欣慰。虽未清承，然服膺高轨，企伫之勤，为日久矣。公以过顺之年，湛气弥厉，养徒幽岩，抱一冲谷，遐迩仰咏，何美如之。每亦翘想一隅，悬庇霄岸，无由写敬，致慨良深！君清对终日，快有悟心之欢也。威道人至，得君《念佛三昧咏》，并得远法师《三昧咏》及序。此作兴寄既高，辞致清婉。能文之士，率称其美。可谓游涉圣门，扣玄关之唱也。君与法师当数有文集，因来何少？（《肇论·答刘遗民书》）
    ●远法师作《念佛三昧咏》及序，刘公等皆和。捡《远法师集》，此但有《三昧咏序》，无《三昧咏》及和，收集不谨也。（元康《肇论疏》）
    ●师有杂文二十卷，号《庐山集》。灵芝元照律师作序，板刊绍兴府库，识者敬焉。（宗晓《乐邦文类》）
    ●姚兴王秦，法事甚盛，于是法和入关，而提婆渡江。先是庐山慧远法师，翘勤妙典，广集经藏，虚心侧席，延望远宾。闻其至止，即请入庐岳，以晋太元中，请出《阿毗昙心》及《三法度》等。提婆乃于般若台，手执梵文，口宣晋语，去华存实，务尽义本。今之所传，盖其文也。（《高僧传·僧伽提婆传》）
    ●贤于是与弟子慧观等四十余人俱发，神志从容，初无异色。率侣宵征，南指庐岳。沙门释慧远久服风名，闻至，欣喜若旧。远以贤之被摈，过由门人。若悬记五舶，只说在同意，亦于律无犯。乃遣弟子昙邕，致书姚主，及关中众僧，解其摈事。远乃请出禅数诸经。贤志在游化，居无求安，停止岁许，复西适江陵。（《高僧传·佛驮跋陀罗传》）
    ●释慧持者，慧远之弟也，冲默有远量。年十四学读书，一日所得，当他一旬。善文史，巧才制。年十八出家，与兄共伏事道安法师，遍学众经，游刃三藏。及安在襄阳，遣远东下，持亦俱行。初憩荆州上明寺，后适庐山，皆随远共止。持形长八尺，风神俊爽，常蹑革屣，纳衣半胫。庐山徒属，莫匪英秀，往反三千，皆以持为称首。持有姑为尼，名道仪，住在江夏。仪闻京师盛于佛法，欲下观化。持乃送姑至都，止于东安寺。晋卫军琅琊王珣，深相器重。时有西域沙门僧伽罗叉，善诵《四含》，珣请出《中阿含经》。持乃校阅文言，搜括详定，后还山。少时，豫章太守范宁，请讲《法华》、《毗昙》，于是四方云聚，千里遥集。王珣与范宁书云：“远公、持公孰愈？”范答书云：“诚为贤兄弟也。”王重书曰：“但令如兄，诚未易有，况复弟贤耶！”兖州刺史琅琊王恭，致书于沙门僧检曰：“远、持兄弟，至德何如？”检答曰：“远、持兄弟也，绰绰焉信有道风矣。”罗什在关遥相钦敬，致书通好，结为善友。持后闻成都地沃民丰，志往传化，兼欲观瞩峨嵋，振锡岷岫。乃以晋隆安三年，辞远入蜀，远苦留不止。远叹曰：“人生爱聚，汝乃乐离，如何？”持亦悲曰：“若滞情爱聚者，本不应出家。今既割欲求道，正以西方为期耳。”于是兄弟收泪，悯默而别。遂乃到蜀，止龙渊精舍，大弘佛法。（《高僧传·慧持传》）
    ●释慧永，年十二出家，伏事沙门竺昙现为师，后又伏膺道安法师。素与远共期，欲结宇罗浮之岫。远既为道安所留，永乃欲先逾五岭。行经浔阳，郡人陶范，苦相要留，于是且停庐山之西林寺，既门徒稍盛，又慧远同筑，遂有意终焉。后镇南将军何无忌，作镇浔阳，陶爰集虎溪，请永及慧远。远既久持名望，亦雅足才力，从者百余，皆端整有风序，及高言华论，举动可观。永怗然独往，率尔后至，纳衣草屣，执杖提钵，而神气自若，清散无矜。众咸重其贞素，翻更多之。远少所推先，而挹永高行，身执卑恭，以希冥福。（《高僧传·慧永传》）
    ●释僧济，晋太元中来入庐山，从远公受学。远每谓曰：“共吾弘佛法者，尔其人乎！”后停山少时，忽感笃疾，于是要诚西国，想像弥陀。远遗济一烛曰：“汝可以建心安养，竞诸漏刻。”济执烛凭机，停想无乱。又请众僧夜集，为转《无量寿经》。至五更中，济以烛授同学，令于僧中行之。于是暂卧，因梦见自秉一烛，乘虚而行，睹无量寿佛，接置于掌，遍至十方。（《高僧传·僧济传》）
    ●释昙邕，少仕伪秦，至卫将军。形长八尺，雄武过人。太元八年，从符坚南征，为晋军所败，还至长安，因从安公出家。安公既往，乃南投庐山，事远公为师。内外经书，多所综涉，志尚弘法，不惮疲苦。后为远入关，致书罗什，凡为使命，十有余年。鼓击风流，摇动峰岫，强捍果敢，专对不辱。京师道场僧鉴，挹其德解，请还杨州。邕以远年高，遂不果行。然远神足高抗者其类不少，恐后不相推谢，因以小缘托摈邕出。邕奉命出山，容无怨忤，乃于山之西南营立茅宇，与弟子昙果，澄思禅门。至远临亡之日，奔赴号踊，痛深天属。后往荆州，卒于竹林寺。（《高僧传·昙邕传》）
    ●释道祖，少出家，后与同志僧迁、道流等，共入庐山七年，并山中受戒，各随所习，日有其新。远公每谓祖等易悟，尽如此辈，不复忧后生矣。迁、流等并年二十八而卒。远叹曰：“此子并才义英茂，清悟日新。怀此长往，一何痛哉！”道流撰诸经目未就，祖为成之，今行于世。祖后还京师瓦官寺讲说。桓玄每往观听，乃谓人曰：“道祖后发，愈于远公，但儒博不逮耳。”（《高僧传·道祖传》）
    ●彻年十六，入庐山造远公。远见而异之，问曰：“宁有出家意耶？”对曰：“远尘离俗，固其本心。绳墨镕钧，更唯匠者。”远曰：“君能入道，当得无畏法门。”于是投簪委质，从远受业，遍学众经，尤精般若。又以问道之暇，亦厝怀篇牍，至若一赋一咏，辄落笔成章。尝至山南，攀松而啸，于是清风远集，众鸟和鸣，超然有胜气。退还咨远：“律制管弦，戒绝歌舞。一吟一啸，可得为乎？”远曰：“以散乱言之，皆为违法。”由是乃止。至年二十四，远令讲《小品》，时辈未之许。及登座，词旨明析，听者无以折其锋。远谓之曰：“向者勍敌并无遗力，汝城隍严固，攻者丧师。反轸能尔，良为未易。”由是门人推服焉。（《高僧传·僧彻传》）
    ●宗炳著《明佛论》、颜延之析《达性论》、周颙驳《夷夏论》、郑道子著《神不灭论》，皆禀远是正焉。（《佛祖历代通载》）
    ●郑道子与远师书云：“夙兴之诚，日月而至。”（惠达《肇论疏》）
    ●陆澄《法论目录》，著录郑道子《与释慧远书论沙门袒服》。（《出三藏记集》）
    ●法显道人至自祇洹，具说佛影，偏为灵奇。幽岩嵌壁，若有存形，容仪端庄，相好具足，莫知始终，常自湛然。庐山法师闻风而悦，于是随喜幽室，即考空岩。北枕峻岭，南映滮涧，摹拟遗量，寄托青彩。岂唯像形也笃，故亦传心者极矣。道秉道人远宣意旨，命余制铭，以充刊刻。石铭所始，实由功被，未有道宗崇大，若此之比，岂浅思肤学所能宣述？事经徂谢，永眷罔已，辄磬竭劣薄，以诺心许。（谢灵运《佛影铭》）
    ●见重伸《释疑论》，辞理切验，善乎校实也。但仆意犹有不同，乃即欲更言所怀。一日侍法师坐，粗共求君意，云：“气力小佳，当自有酬。因君论旨，兼有所见也。”仆是以不复稍厝其爝火。须成，旨因上。（周续之《答戴安公书》）
    ●昔远和尚澄业庐山，余往憩五旬，高洁贞厉，理学精妙，固远流也。其师安法师，灵德自奇。微遇比丘，并含清真。皆其相与素洽乎道，而后孤立于山，是以神明之化，邃于岩林。骤与余言于崖树涧壑之间，暧然乎有自言表而肃人者。凡若斯论，亦和尚据经之旨云尔。（宗炳《明佛论》）
    ●吾少婴羸患，为性好闲，故虽在童稚之年，已怀远迹之意。暨于弱冠，遂托业庐山。逮事释和尚，于时师友渊源，务训弘道。外慕等夷，内怀悱发，于是洗气神明，玩心坟典，勉志勤躬，夜以继日。爰有山水之好，悟言之欢，实足以通理辅性，成夫亹亹之业，乐以忘忧，不知朝日之晏矣。（雷次宗《与子侄书》）
    ●卢循，司空从事中郎谌之曾孙也。双眸冏彻，瞳子四转，善草隶、弈棋之艺。沙门慧远有鉴裁，见而谓之曰：“君虽体涉风素，而志存不轨。”（《晋书·卢循传》）
    ●唱导者，盖以宣唱法理，开导众心也。昔佛法初传，于时齐集，只宣唱佛名，依文致礼。至中宵疲极，事资启悟，乃别请宿德，升座说法，或杂序因缘，或傍引譬喻。其后庐山释慧远，道业贞华，风才秀发。每至斋集，辄自升高座，躬为导首，先明三世因果，却辩一斋大意。后代传受，遂成永则。（《高僧传·唱导篇论》）
    ●晋、宋间有庐山慧远法师，化行浔阳。高士逸人，辐凑于东林，皆愿结香火。时雷次宗、宗炳、张诠、刘遗民、周续之等，共结白莲华社，立弥陀像，求愿往生安养国，谓之莲社。社之名始于此也。（赞宁《僧史略·结社法集》）
    ●弥陀教观，载于《大藏》，不为不多。然佛化东流，数百年间，世人殆无知者。晋慧远法师，居庐山之东林，神机独拔，为天下倡。凿池栽莲，建堂立誓，专崇净业，号为白莲社。当时名僧、巨儒，不期而自至。慧持、道生，释门之后彦。刘遗民、雷次宗，文士之豪杰。皆伏膺请教，而预其社焉。是故后世言净社者，必以东林为始。（元照《无量院造弥陀像记》）
    ●时教虽本佛说，然而弘时教者，必以天台为始祖。律藏虽本佛制，然而张律藏者，必以南山为始祖。禅宗虽本佛心，然而传佛心者，必以达磨为始祖。劝生净土，固出大觉慈尊，然而使此方之人知有念佛三昧者，应以远公法师为始祖焉。（宗晓《莲社始祖庐山远法师传》）
    ●晋以前，净土之旨，虽闻于震旦。而弘阐力行，俾家喻户晓，则自远师始。故万代而下，净业弟子推师为始祖，可谓释迦再说西方，弥陀现身东土者也。（莲池大师《往生集·远祖师传》）
    （因校《庐山慧远法师文钞》，见其附编“杂事”等，录远公事未尽。故摭拾所见，补录于此。2006年5月，清凉书屋谨记。）

·清凉书屋标点本·
2006.05


校勘表

    【校勘表】

篇 名 | 原 本 | 清凉书屋本 | 说 明
沙门不敬王者论 | 体（与八座书中作礼）实唯隆 | 礼实唯隆 | 《宋碛砂藏》、《永乐北藏》、《乾隆大藏经》、《大正藏》，均作“礼”。
 | （按高僧传，作五曰形尽神不灭，谓识神驰骛，随行东西也，此是论之大意。自是沙门得全方外之迹矣。今论无此数语，盖弘明集有删节也。） | （按《高僧传》作：“五曰形尽神不灭，谓识神驰骛，随行东西也。”） | “此是论之大意。自是沙门得全方外之迹矣。”乃《高僧传》就此论之影响所作评述。
明报应论 | 乘惑（疑当作感）生应 | 乘感生应 | 共二处，前据《乾隆大藏经》、《大正藏》改，后据《永乐北藏》、《乾隆大藏经》等改。
法性论 | 谨按莲社高贤传云，乃著法性论十四篇。 | 按《出三藏记集》第十二，载陆澄《法论目录》，著录《法性论》上、下篇。 | 据陆澄《法论目录》，《莲社高贤传》中“十四篇”，应为“上下篇”之误。
庐山出《修行方便禅统经》序 | （频伽藏作统序） | （《频伽藏》题作“庐山出《修行方便禅经》统序”） | 原注在标题中，现移其后。
庐山记 | （按本记三行，天子都，天子障，子字疑误。） | 删 | 考《庐山记》，引《山海经》无误，唯“障”应作“鄣”。
 | 山海经云，庐山出三天子都，入江彭泽西，一曰天子障彭泽也，山在其西故。旧语以所滨为彭蠡。 | 《山海经》云：“庐江出三天子都，入江彭泽西，一曰天子鄣。”故旧语以所滨为彭蠡。 | 据《山海经》、《大正藏·庐山记》改。
答桓玄劝罢道书 | 答桓玄（弘明集作南郡）书（劝罢道原书附） | 答桓玄劝罢道书（原书附） | 查四种藏经，均题作“庐山慧远法师答桓玄劝罢道书”。
 | 若使幽冥有枉 | 若使幽冥有在 | 查四种藏经，均作“在”。
答桓玄书（论沙门不应敬王者） | 夫称沙门者何耶…… | （《高僧传》载答书曰：“夫称沙门者何耶……） | 此段为《高僧传》所节引。
慧远法师传一 | 于惑者晓然 | 于是惑者晓然 | 据《大正藏》、中华书局本改。
 | 标云衣 | 飘云衣 | 见正编《与刘遗民书》
 | 具承德闻 | 具承德问 | 见正编《与罗什书》
 | 一曰，在家奉法 | 一曰“在家”，谓在家奉法 | 据《大正藏》、中华书局本《高僧传》改。
奉晋王述匡山寺书 | 般若、佛影二堂 | 般若、佛影二台 | 据《国清百录》（《永乐北藏》、《大正藏》）改
 | 在后登摄 | 在后登蹑 | 同上
 | 天降甘露于泥洹。自是以…… | 天降甘露于泥洹日。是以…… | 同上