首页

庐山净土集

[东晋]慧远法师等著 [image] 清凉书屋敬辑

·2003.10·


念佛三昧诗集序 (慧远法师)

念佛三昧诗集序

［东晋］慧远法师撰

    夫称三昧者何？专思寂想之谓也。思专则志一不分，想寂则气虚神朗。气虚则智恬其照，神朗则无幽不彻。斯二乃是自然之玄符，会一而致用也。是故靖恭闲宇，而感物通灵。御心唯正，动必入微。此假修以凝神，积习以移性，犹或若兹。况夫尸居坐忘，冥怀至极，智落宇宙，而闇蹈大方者哉！请言其始，菩萨初登道位，甫窥玄门，体寂无为而无弗为。及其神变也，则令修短革常度，巨细互相违，三光回景以移照，天地卷而入怀矣。
    又诸三昧，其名甚众。功高易进，念佛为先。何者？穷玄极寂，尊号如来。体神合变，应不以方。故令入斯定者，昧然忘知，即所缘以成鉴。鉴明则内照交映，而万像生焉。非耳目之所暨，而闻见行焉。于是睹夫渊凝虚镜之体，则悟灵相湛一，清明自然。察夫玄音之叩心听，则尘累每消，滞情融朗。非天下之至妙，孰能与于此哉！以兹而观，一觌之感，乃发久习之流覆，豁昏俗之重迷。若以匹夫众定之所缘，固不得语其优劣，居可知也。
    是以奉法诸贤，咸思一揆之契。感寸阴之颓影，惧来储之未积。于是洗心法堂，整襟清向。夜分忘寝，夙宵唯勤。庶夫贞诣之功，以通三乘之志。临津济物，与九流而同往。仰援超步，拔茅之兴。俯引弱进，垂策其后。以此览众篇之挥翰，岂徒文咏而已哉！

〖录自《广弘明集》卷第三十〗

清凉书屋点校·2003.10


问念佛三昧并答 (远公问 罗什答)

大乘大义章
问念佛三昧并答

慧远法师问　鸠摩罗什答

    远问曰：念佛三昧，《般舟经·念佛章》中说，多引梦为喻。梦是凡夫之境，惑之与解皆自厓，己还理了。而经说：“念佛三昧见佛，则问云，则答云，则决其疑网。”若佛同梦中之所见，则是我相之所瞩想，相专则成定，定则见佛。所见之佛，不自外来，我亦不往，直是想专理会，大闻于梦。了疑大我或或不出，境佛不来，而云何有解？解其安从乎？若真兹外应，则不得以梦为喻。神通之会，自非实相，则有往来。往则是经表之谈，非三昧意，后何以为通？又《般舟经》云：“有三事得定，一谓持戒无犯，二谓大功德，三谓佛威神。”为是定中之佛？外来之佛？若是定中之佛，则是我想之所立，还出于我了。若是定外之佛，则是梦表之圣人。然则成会之表，不专在内，不得令闻于梦，明矣。念佛三昧，法法为尔否？二三之说，竟何所从也？

    什答：见佛三昧有三种：一者菩萨或得天眼、天耳，或飞到十方佛所，见佛难问，断诸疑网；二者虽无神通，常修念阿弥陀等现在诸佛，心住一处，即得见佛，请问所疑；三者学习念佛，或以离欲，或未离欲，或见佛像，或见生身，或见过去、未来、现在诸佛。是三种定，皆名念佛三昧，其实不同者。得神通，见十方佛。余者最下。统名念佛三昧。
    复次，若人常观世间厌离相者，于众生中，行慈为难。是以为未离欲诸菩萨故，种种称赞般舟三昧。而是定力，虽未离，亦能摄心一处，能见诸佛，则是求佛道之根本也。
    又学般舟三昧者，离言忆想分别，而非虚妄。所以者何？释迦文佛所说众经，明阿弥陀佛身相具足，是如来之至言。又《般舟经》种种设教，当念分别阿弥陀佛，在于西方，过十万佛土。彼佛以无量光明，常照十方世界。若行如经所说，能见佛者，则有本末，非徒虚妄忆分别而已。以人不信、不知行禅定法，作是念：“未得神通，何能远见诸佛也？”是故佛以梦为喻耳。如人以梦力故，虽有远事，能到能见。行般舟三昧菩萨，亦复如是，以此定力故，远见诸佛，不以山林等为碍也。以人信梦故，以之为喻。又梦是不然之法，无所施作，尚能如是。何况施其功用，而不见也？
    又诸佛身有决定相者，忆想分别，当是虚妄。而经说诸佛身皆从众缘生，无有自性，毕竟空寂，如梦如化。若然者，如说行见诸佛身，不应独以虚妄也。若虚妄者，悉应虚妄。若不虚妄，皆不虚妄。所以者何？普令众生，各得其利，种诸善根故。如《般舟经》中见佛者，能生善根，成阿罗汉、阿惟越致。是故当知，如来之身，无非是实。
    又忆想分别，亦有时有。若当随经所说，常应忆想分别者，便能通达实事。譬如常习灯烛、日月之明，念复障物，便得天眼，通达实事。又下者持戒清净，信敬深重，兼彼佛神力，及三昧力，众缘和合，即得见佛，如人对见镜像。
    又一凡夫，无始以来曾见，皆应离欲得天眼、天耳，还复轮转五道。而般舟三昧，无始生死以来，二乘之人尚不能得，况于凡夫？是故不应以此三昧所见，谓为虚妄。
    又诸菩萨得此三昧，见佛则问，解释疑网。从三昧起，住粗心中，深乐斯定，生贪着意。是故佛教行者，应作是念：“我不到彼，彼佛不来，而得见佛闻法者，但心忆分别。了三界之物，皆从忆想分别而有，或是先世忆想果报，或是今世忆想所成。”闻是教已，心厌三界，倍增信敬。佛善说如是微妙理也。行者即时得离三界欲，深入于定，成般舟三昧。

〖录自《卍续藏经·第96册·大乘大义章》〗


万佛影铭 (慧远法师)

万佛影铭

［东晋］慧远法师撰

    夫滞于近习，不达希世之闻。抚常永日，罕怀事外之感。是使尘想制于玄襟，天罗网其神虑。若以之穷龄，则此生岂遇？以之希心，则开悟靡期。于是发愤忘食，情百其慨。静虑闲夜，理契其心。尔乃恩沾九泽之惠，三复无缘之慈，妙寻法身之应，以神不言之化。化不以方，唯其所感。慈不以缘，冥怀自得。譬日月丽天，光影弥晖，群品熙荣，有情同顺。咸欣悬映之在己，罔识曲成之攸寄。妙物之谈，功尽于此。将欲拟夫幽极，以言其道。仿佛存焉，而不可论。何以明之？法身之运物也，不物物而兆其端，不图终而会其成。理玄于万化之表，数绝乎无形无名者也。若乃语其筌寄，则道无不在。是故如来，或晦先迹以崇基，或显生途而定体；或独发于莫寻之境，或相待于既有之场。独发类乎形，相待类乎影。推夫冥寄，为有待耶？为无待耶？自我而观，则有间于无间矣。求之法身，原无二统。形、影之分，孰际之哉！而今之闻道者，咸摹圣体于旷代之外，不悟灵应之在兹，徒知圆化之非形，而动止方其迹，岂不诬哉！
    远昔寻先师，奉侍历载。虽启蒙慈训，托志玄籍。每想奇闻，以笃其诚。遇西域沙门，辄餐游方之说。故知有佛影，而传者尚未晓然。及在此山，值罽宾禅师，南国律学道士。与昔闻既同，并是其人游历所经，因其详问，乃多有先征。然后验神道无方，触像而寄，百虑所会，非一时之感。于是悟彻其诚，应深其信。将援同契，发其真趣，故与夫随喜之贤，图而铭焉。

    廓矣大像，理玄无名。体神入化，落影离形。回晖层岩，凝映虚亭。在阴不昧，处暗愈明。婉步蝉蜕，朝宗百灵。应不同方，迹绝而冥。（其一）

    茫茫荒宇，靡劝靡奖。淡虚写容，拂空传像。相具体微，冲姿自朗。白毫吐曜，昏夜中爽。感彻乃应，扣诚发响。留音停岫，津悟冥赏。抚之有会，功弗由曩。（其二）

    旋踵忘敬，罔虑罔识。三光掩晖，万象一色。庭宇幽蔼，归途莫测。悟之以静，震之以力。慧风虽遐，维尘攸息。匪伊玄览，孰扇其极？（其三）

    希音远流，乃眷东顾。欣风慕道，仰规玄度。妙尽毫端，运微轻素。托彩虚凝，殆映霄雾。迹以像真，理深其趣。奇兴开襟，祥风引路。清气回于轩宇，昏明交而未曙。仿佛镜神仪，依俙若真遇。（其四）

    铭之图之，曷营曷求？神之听之，鉴尔所修。庶兹尘轨，映彼玄流。漱情灵沼，饮和至柔。照虚应简，智落乃周。深怀冥托，霄想神游。毕命一对，长谢百忧！（其五）

    晋义熙八年，岁在壬子，五月一日，共立此台，拟像本山。因即以寄诚，虽成由人匠，而功无所加。至于岁次星纪，赤奋若贞于太阴之墟，九月三日，乃详捡别记，铭之于石。爰自经始，人百其诚，道俗欣之，感遗迹以悦心，于是情以本应，事忘其劳。于时挥翰之宾，佥焉同咏，咸思存远猷，托相异闻。庶来贤之重轨，故备时人于影集。大通之会，诚非理所期。至于伫襟遐慨，固已超夫神境矣！

〖录自《广弘明集》卷第十五〗


沙门不敬王者论 (慧远法师)

沙门不敬王者论

［东晋］慧远法师著

    晋成、康之世，车骑将军庾冰，疑诸沙门抗礼万乘。所明理，何骠骑有答。至元兴中，太尉桓公，亦同此义，谓庾言之未尽。与八座书云：“佛之为化，虽诞以茫浩，推乎视听之外。以敬为本，此出处不异。盖所期者，殊非敬恭宜废也。《老子》同王侯于三大，原其所重，皆在于资生通运，岂独以圣人在位，而比称二仪哉？将以天地之大德曰生，通生理物，存乎王者，故尊其神器，而礼寔唯隆。岂是虚相崇重，义存弘御而已？沙门之所以生生资国存，亦日用于理命。岂有受其德而遗其礼，沾其惠而废其敬哉？”
    于时朝士名贤，答者甚众。虽言未悟时，并互有其美。徒咸尽所怀，而理蕴于情。遂令无上道服，毁于尘俗；亮到之心，屈乎人事。悲夫！斯乃交丧之所由，千载之否运。深惧大法之将沦，感前事之不忘，故著论五篇，究叙微意。岂曰渊壑之待晨露，盖是伸其罔极，亦庶后之君子崇敬佛教者，式详览焉。

在家第一

    原夫佛教所明大要，以出家为异。出家之人，凡有四科。其弘教通物，则功侔帝王，化兼治道。至于感俗悟时，亦无世不有，但所遇有行藏，故以废兴为隐显耳。其中可得论者，请略而言之：
    在家奉法，则是顺化之民。情未变俗，迹同方内。故有天属之爱，奉主之礼。礼敬有本，遂因之而成教。本其所因，则功由在昔。是故因亲以教爱，使民知其有自然之恩；因严以教敬，使民知有自然之重。二者之来，实由冥应。应不在今，则宜寻其本。故以罪对为刑罚，使惧而后慎；以天堂为爵赏，使悦而后动。此皆即其影响之报，而明于教。以因顺为通，而不革其自然也。
    何者？夫厚身存生，以有封为滞，累根深固，存我未忘。方将以情欲为苑囿，声色为游观，耽湎世乐，不能自勉而特出。是故教之所检，以此为崖，而不明其外耳。其外未明，则大同于顺化。故不可受其德而遗其礼，沾其惠而废其敬。是故悦释迦之风者，辄先奉亲而敬君。变俗投簪者，必待命而顺动。若君亲有疑，则退求其志，以俟同悟。斯乃佛教之所以重资生、助王化于治道者也。
    论者立言之旨，貌有所同。故位夫内外之分，以明在三之志。略叙经意，宣寄所怀。

出家第二

    出家则是方外之宾，迹绝于物。其为教也，达患累缘于有身，不存身以息患；知生生由于禀化，不顺化以求宗。求宗不由于顺化，则不重运通之资。息患不由于存身，则不贵厚生之益。此理之与形乖，道之与俗反者也。
    若斯人者，自誓始于落簪，立志形乎变服。是故凡在出家，皆遁世以求其志，变俗以达其道。变俗则服章不得与世典同礼，遁世则宜高尚其迹。夫然者，故能拯溺俗于沉流，拔幽根于重劫；远通三乘之津，广开天人之路。如令一夫全德，则道洽六亲，泽流天下。虽不处王侯之位，亦已协契皇极，在宥生民矣。是故内乖天属之重，而不违其孝；外阙奉主之恭，而不失其敬。
    从此而观，故知超化表以寻宗，则理深而义笃。照泰息以语仁，则功末而惠浅。若然者，虽将面冥山而旋步，犹或耻闻其风。岂况与夫顺化之民、尸禄之贤，同其孝敬者哉？

求宗不顺化第三

    问曰：寻夫老氏之意，天地以得一为大，王侯以体顺为尊。得一故为万化之本，体顺故有运通之功。然则明宗必存乎体极，体极必由于顺化。是故先贤以为美谈，众论所不能异。异夫众论者，则义无所取。而云不顺化，何耶？
    答曰：凡在有方，同禀生于大化，虽群品万殊，精粗异贯，统极而言，唯有灵与无灵耳。有灵则有情于化，无灵则无情于化。无情于化，化毕而生尽，生不由情，故形朽而化灭。有情于化，感物而动，动必以情，故其生不绝。其生不绝，则其化弥广，而形弥积；情弥滞，而累弥深。其为患也，焉可胜言哉！是故经称：“泥洹不变，以化尽为宅。三界流动，以罪苦为场。”化尽则因缘永息，流动则受苦无穷。何以明其然？夫生以形为桎梏，而生由化有。化以情感，则神滞其本，而智昏其照，介然有封，则所存唯己，所涉唯动。于是灵辔失御，生途日开，方随贪爱于长流，岂一受而已哉！是故反本求宗者，不以生累其神；超落尘封者，不以情累其生。不以情累其生，则生可灭；不以生累其神，则神可冥。冥神绝境，故谓之泥洹。泥洹之名，岂虚称也哉！
    请推而实之：天地虽以生生为大，而未能令生者不死。王侯虽以存存为功，而未能令存者无患。是故前论云：“达患累缘于有身，不存身以息患。知生生由于禀化，不顺化以求宗。”义存于此。义存于此，斯沙门之所以抗礼万乘，高尚其事，不爵王侯，而沾其惠者也。

体极不兼应第四

    问曰：历观前史，上皇已来，在位居宗者，未始异其原本。本不可二，是故百代同典，咸一其统，所谓“唯天为大，唯尧则之”。如此则非智有所不照，自无外可照；非理有所不尽，自无理可尽。以此而推，视听之外，廓无所寄。理无所寄，则宗极可明。今诸沙门，不悟文表之意，而惑教表之文，其为谬也，固已甚矣。若复显然有验，此乃希世之闻。
    答曰：夫幽宗旷邈，神道精微，可以理寻，难以事诘。既涉乎教，则以因时为检。虽应世之见，优劣万差。至于曲成，在用感即民心，而通其分。分至，则止其智之所不知，而不关其外者也。若然，则非体极者之所不兼，兼之者不可并御耳。是以古之语大道者，五变而形名可举，九变而赏罚可言。此但方内之阶差，而犹不可顿设。况其外者乎？
    请复推而广之，以远其旨。“六合之外，存而不论”者，非不可论，论之或乖。“六合之内，论而不辩”者，非不可辩，辩之或疑。“《春秋》经世，先王之志，辩而不议”者，非不可议，议之者或乱。此三者，皆即其身耳目之所不至，以为关键，而不关视听之外者也。因此而求圣人之意，则内外之道，可合而明矣。
    常以为道法之与名教，如来之与尧、孔，发致虽殊，潜相影响；出处诚异，终期则同。详而辩之，指归可见。理或有先合而后乖，有先乖而后合。先合而后乖者，诸佛如来，则其人也。先乖而后合者，历代君王未体极之主，斯其流也。
    何以明之？经云：“佛有自然神妙之法，化物以权，广随所入。或为灵仙、转轮圣帝，或为卿相、国师、道士。”若此之伦，在所变现。诸王君子，莫知为谁。此所谓合而后乖者也。或有始创大业，而功化未就，迹有参差，故所受不同。或期功于身后，或显应于当年。圣王则之而成教者，亦不可称算。虽抑引无方，必归途有会。此所谓乖而后合者也。
    若令乖而后合，则拟步通途者，必不自崖于一揆。若令先合而后乖，则释迦之与尧、孔，发致不殊，断可知矣。是故自乖而求其合，则知理会之必同。自合而求其乖，则悟体极之多方。但见形者之所不兼，故惑众途而骇其异耳。
    因兹而观，天地之道，功尽于运化。帝王之德，理极于顺通。若以对夫独绝之教、不变之宗，故不得同年而语其优劣，亦已明矣。

形尽神不灭第五

    问曰：论旨以化尽为至极，故造极者必违化而求宗。求宗不由于顺化，是以引历代君王，使同之佛教，令体极之至，以权居统。此雅论之所托，自必于大通者也。求之实当，理则不然。何者？夫禀气极于一生，生尽则消液而同无。神虽妙物，故是阴阳之所化耳。既化而为生，又化而为死；既聚而为始，又散而为终。因此而推，故知神形俱化，原无异统；精粗一气，始终同宅。宅全则气聚而有灵，宅毁则气散而照灭。散则反所受于天本，灭则复归于无物。反覆终穷，皆自然之数耳，孰为之哉！若令本异，则异气数合，合则同化。亦为神之处形，犹火之在木，其生必存，其毁必灭。形离则神散而罔寄，木朽则火寂而靡托，理之然矣。假使同异之分，昧而难明。有无之说，必存乎聚散。聚散，气变之总名，万化之生灭。故庄子曰：“人之生，气之聚。聚则为生，散则为死。若死生为彼徒苦，吾又何患？”古之善言道者，必有以得之。若果然耶，至理极于一生，生尽不化，义可寻也。
    答曰：夫神者何耶？精极而为灵者也。精极则非卦象之所图，故圣人以妙物而为言。虽有上智，犹不能定其体状，穷其幽致。而谈者以常识生疑，多同自乱，其为诬也，亦已深矣。将欲言之，是乃言夫不可言。今于不可言之中，复相与而依俙。
    神也者，圆应无生，妙尽无名，感物而动，假数而行。感物而非物，故物化而不灭。假数而非数，故数尽而不穷。有情则可以物感，有识则可以数求。数有精粗，故其性各异。智有明暗，故其照不同。推此而论，则知化以情感，神以化传。情为化之母，神为情之根。情有会物之道，神有冥移之功。但悟彻者反本，惑理者逐物耳。
    古之论道者，亦未有所同，请引而明之。庄子发玄音于《大宗》曰：“大块劳我以生，息我以死。”又以生为人羁，死为反真。此所谓知生为大患，以无生为反本者也。文子称黄帝之言曰：“形有靡而神不化，以不化乘化，其变无穷。”庄子亦云：“特犯人之形，而犹喜之。若人之形，万化而未始有极。”此所谓知生不尽于一化，方逐物而不反者也。二子之论，虽未究其实，亦尝傍宗而有闻焉。论者不寻无方生死之说，而惑聚散于一化。不思神道有妙物之灵，而谓精粗同尽。不亦悲乎！
    火木之喻，原自圣典，失其流统，故幽兴莫寻，微言遂沦于常教，令谈者资之以成疑。向使时无悟宗之匠，则不知有先觉之明。冥传之功，没世靡闻。何者？夫情数相感，其化无端。因缘密构，潜相传写。自非达观，孰识其变？自非达观，孰识其会？请为论者验之以实：火之传于薪，犹神之传于形。火之传异薪，犹神之传异形。前薪非后薪，则知指穷之术妙。前形非后形，则悟情数之感深。惑者见形朽于一生，便以为神情俱丧，犹睹火穷于一木，谓终期都尽耳。此由从养生之谈，非远寻其类者也。
    就如来论：假令神形俱化，始自天本；愚智资生，同禀所受。问所受者，为受之于形耶？为受之于神耶？若受之于形，凡在有形，皆化而为神矣。若受之于神，是以神传神，则丹朱与帝尧齐圣，重华与瞽叟等灵，其可然乎？其可然乎？如其不可，固知冥缘之构，著于在昔；明暗之分，定于形初。虽灵钧善运，犹不能变性之自然，况降兹已还乎？验之以理，则微言而有征。效之以事，可无惑于大道。

    论成后，有退居之宾，步朗月而宵游，相与共集法堂，因而问曰：“敬寻雅论，大归可见，殆无所间。一日试重研究，盖所未尽，亦少许处耳。意以为沙门德式，是变俗之殊制，道家之名器。施于君亲，固宜略于形敬。今所疑者，谓甫创难就之业，远期化表之功，潜泽无现法之效，来报玄而未应。乃令王公献供，信士屈体。得无坐受其德，陷乎早计之累，虚沾其惠，贻夫素餐之讥耶？”
    主人良久乃应曰：“请为诸贤，近取其类。有人于此，奉宣时命，远通殊方九译之俗。问王者当资以糇粮，锡以舆服否？”
    答曰：“然。”
    主人曰：“类可寻矣。夫称沙门者，何耶？谓其发蒙俗之幽昏，启化表之玄路。方将以兼忘之道，与天下同往，使希高者挹其遗风，漱流者味其余津。若然，虽大业未就，观其超步之迹，所悟固已弘矣。然则运通之功，资存之益，尚未酬其始誓之心，况答三业之劳乎？又斯人者，形虽有待，情无近寄。视夫四事之供，若蟭蚊之过乎其前者耳。濡沫之惠，复焉足语哉？”
    众宾于是始悟冥途以开辙为功，息心以净毕为道。乃欣然怡襟，咏言而退。
    晋元兴三年，岁次阏逢。于时天子蒙尘，人百其忧。凡我同志，佥怀缀旒之叹。故因述斯论焉。

〖录自《弘明集》卷第五〗


答桓玄劝罢道书 (慧远法师)

庐山慧远法师答桓玄劝罢道书

桓玄书

    夫至道缅邈，佛理幽深，岂是悠悠常徒所能习求？沙门去弃六亲之情，毁其形骸，口绝滋味，被褐带索，山栖枕石，永乖世务。百代之中，庶或有一仿佛之间。今世道士，虽外毁仪容，而心过俗人，所谓道俗之际，可谓学步邯郸，匍匐而归。先圣有言：“未知生，焉知死。”而令一生之中，困苦形神，方求冥冥黄泉下福。皆是管见，未体大化。迷而知反，去道不远，可不三思？运不居人，忽焉将老，可复追哉？聊赠至言，幸能纳之！

远法师答

    大道渊玄，其理幽深，衔此高旨，实如来谈。然贫道出家，便是方外之宾。虽未践古贤之德，取其一往之志，削除饰好，落名求实。若使幽冥有在，故当不谢于俗人。外似不尽，内若断金，可谓见形不及道，哀哉哀哉！带索枕石，华而不实，管见之人，不足羡矣。虽复养素山林，与树木何异？夫道在方寸，假练形为真。卞和号恸于荆山，患人不别故也。昔闻其名，今见其人。故庄周悲慨：“人生天地之间，如白驹之过隙。”以此而寻，孰得久停？岂可不为将来作资？
    言学步邯郸者，新无功，失其本质，故使邯人匍匐而归。百代之中，有此一也，岂浑同以通之？贫道已乖世务，形权于流俗，欲于其中化未化者。虽复沐浴踞傲，奈疑结何？一世之荣，剧若电光，聚则致离，何足贪哉？浅见之徒其惑哉！可谓“下士闻道，大而笑之”，真可谓迷而不反也。贫道形不出人，才不应世，是故毁其陋质，被其割截之服，理未能心冥玄化，远存大圣之制。岂舍其本怀，而酬高诲？
    贫道年与时颓，所患未痊，乃复曲垂光慰，感庆交至。檀越信心幽当，大法所寄，岂有一伤毁其本也，将非波旬试娆之言？辞拙寡闻，力酬高命，盖是不逆之怀耳。

〖录自《弘明集》卷第十一〗


明报应论 (慧远法师)

明报应论

［东晋］慧远法师撰

    问曰：佛经以杀生罪重，地狱斯罚；冥科幽司，应若影响。余有疑焉。何者？夫四大之体，即地、水、火、风耳。结而成身，以为神宅。寄生栖照，津畅明识。虽托之以存，而其理天绝。岂唯精粗之间，固亦无受伤之地。灭之既无害于神，亦由灭天地间水、火耳。
    又问：万物之心，爱欲森繁，但私我有己，情虑之深者耳。若因情致报，乘感生应，则自然之迹，顺何所寄哉？
    答曰：意谓此二条，始是来问之关键，立言之津要。津要既明，则群疑同释。始涉之流，或因兹以悟。可谓朗滞情于常识之表，发奇唱于未闻。然佛教深玄，微言难辩。苟未统夫旨归，亦焉能畅其幽致？当为依傍大宗，试叙所怀：
    推夫四大之性，以明受形之本。则假于异物，托为同体。生若遗尘，起灭一化。此则慧观之所入，智忍之所游也。于是乘去来之自运，虽聚散而非我。寓群形于大梦，实处有而同无。岂复有封于所受，有系于所恋哉！若斯理自得于心，而外物未悟，则悲独善之无功，感先觉而兴怀，于是思弘道以明训，故仁恕之德存焉。若彼我同得，心无两对。游刃则泯一玄观，交兵则莫逆相遇。伤之岂唯无害于神，固亦无生可杀。此则文殊按剑，迹逆而道顺。虽复终日挥戈，措刃无地矣。若然者，方将托鼓舞以尽神，运干戚而成化。虽功被犹无赏，何罪罚之有耶！
    若反此而寻其原，则报应可得而明；推事而求其宗，则罪罚可得而论矣。尝试言之：夫因缘之所感，变化之所生，岂不由其道哉？无明为惑网之渊，贪爱为众累之府，二理俱游，冥为神用。吉凶悔吝，唯此之动。无明掩其照，故情想凝滞于外物。贪爱流其性，故四大结而成形。形结则彼我有封，情滞则善恶有主。有封于彼我，则私其身而身不忘。有主于善恶，则恋其生而生不绝。于是甘寝大梦，昏于同迷。抱疑长夜，所存唯著。是故失得相推，祸福相袭。恶积而天殃自至，罪成则地狱斯罚。此乃必然之数，无所容疑矣。何者？会之有本，则理自冥对。兆之虽微，势极则发。是故心以善恶为形声，报以罪福为影响。本以情感，而应自来。岂有幽司？由御失其道也。然则罪福之应，唯其所感。感之而然，故谓之自然。自然者，即我之影响耳。于夫玄宰复何功哉！
    请寻来问之要，而验之于实。难旨全许地、水、火、风结而成身，以为神宅，此则宅有主矣。问主之居宅，有情耶？无情耶？若云无情，则四大之结，非主宅之所感。若以感不由主，故处不以情，则神之居宅，无情、无痛痒之知。神既无知，宅又无痛痒以接物，则是伐卉剪林之喻，无明于义。若果有情，四大之结，是主之所感也。若以感由于主，故处必以情，则神之居宅，不得无痛痒之知。神既有知，宅又受痛痒以接物，固不得同天地间水、火、风，明矣。
    因兹以谈，夫神形虽殊，相与而化。内外诚异，浑为一体。自非达观，孰得其际耶？苟未之得，则愈久愈迷耳。凡禀形受命，莫不尽然也。受之既然，各以私恋为滞。滞根不拔，则生理弥固。爱源不除，则保之亦深。设一理逆情，使方寸迷乱，而况举体都亡乎？是故同逆相乘，共生雠隙。祸心未冥，则构怨不息。纵复悦毕受恼，情无遗憾。形声既著，则影响自彰。理无先期，数合使然也。虽欲逃之，其可得乎？此则因情致报，乘感生应。但立言之旨本异，故其会不同耳。
    问曰：若以物情重生，不可致丧。则生情之由，私恋之惑耳。宜朗以达观，晓以大方。岂得就其迷滞，以为报应之对哉？
    答曰：夫事起必由于心，报应必由于事。是故自报以观事，而事可变。举事以责心，而心可反。推此而言，则知圣人因其迷滞，以明报应之对。不就其迷滞，以为报应之对也。何者？人之难悟，其日固久。是以佛教本其所由，而训必有渐。知久习不可顿废，故先示之以罪福。罪福不可都忘，故使权其轻重。轻重权于罪福，则验善恶以宅心。善恶滞于私恋，则推我以通物。二理兼弘，情无所系。故能尊贤容众，恕己施安，远寻影响之报，以释往复之迷。迷情既释，然后大方之言可晓，保生之累可绝。夫生累者，虽中贤犹未得，岂常智之所达哉！

〖录自《弘明集》卷第五〗


三报论 (慧远法师)

三 报 论
（因俗人疑善恶无现验作）

［东晋］慧远法师撰

    经说业有三报：一曰现报，二曰生报，三曰后报。现报者，善恶始于此身，即此身受；生报者，来生便受；后报者，或经二生、三生、百生、千生，然后乃受。受之无主，必由于心。心无定司，感事而应。应有迟速，故报有先后。先后虽异，咸随所遇而为对。对有强弱，故轻重不同。斯乃自然之赏罚，三报之大略也。非夫通才达识，入要之明，罕得其门。降兹已还，或有始涉大方，以先悟为蓍龟；博综内籍，反三隅于未闻；师友仁匠，习以移性者，差可得而言。请试论之：
    夫善恶之兴，由其有渐。渐以之极，则有九品之论。凡在九品，非其现报之所摄，然则现报绝夫常类可知。类非九品，则非三报之所摄。何者？若利害交于目前，而顿相倾夺，神机自运，不待虑而发。发不待虑，则报不旋踵而应。此现报之一隅，绝夫九品者也。又三业殊体，自同有定报。定则时来必受，非祈祷之所移，智力之所免也。将推而极之，则义深数广，不可详究。故略而言之，相参怀佛教者，以有得之。
    世或有积善而殃集，或有凶邪而致庆。此皆现业未就，而前行始应，故曰：“贞祥遇祸，妖孽见福。”疑似之嫌，于是乎在。何以谓之然？或有欲匡主救时，道济生民，拟步高迹，志在立功；而大业中倾，天殃顿集。或有栖迟衡门，无闷于世，以安步为舆，优游卒岁；而时来无妄，运非所遇，世道交沦，于其闲习。或有名冠四科，道在入室，全爱体仁，慕上善以进德；若斯人也，含冲和而纳疾，履信顺而夭年。此皆立功立德之舛变，疑嫌之所以生也。
    大义既明，宜寻其对。对各有本，待感而发。逆顺虽殊，其揆一耳。何者？倚伏之契，定于在昔。冥符告命，潜相回换。故令祸福之气，交谢于六府。善恶之报，舛互而两行。是使事应之际，愚智同惑，谓积善之无庆，积恶之无殃。感神明而悲所遇，慨天殃之于善人。咸谓名教之书，无宗于上。遂使大道翳于小成，以正言为善诱。应心求实，必至理之无此。原其所由，由世典以一生为限，不明其外。其外未明，故寻理者自毕于视听之内。此先王即民心而通其分，以耳目为关键者也。如今合内外之道，以求弘教之情，则知理会之必同，不惑众途而骇其异。若能览三报以观穷通之分，则尼父之不答仲由，颜、冉对圣匠而如愚，皆可知矣。
    亦有缘起而缘生法，虽预入谛之明，而遗爱未忘，犹以三报为华苑，或跃而未离于渊者也。推此以观，则知有方外之宾，服膺妙法，洗心玄门，一诣之感，超登上位。如斯伦匹，宿殃虽积，功不在治，理自安消，非三报之所及。因兹而言，佛经所以越名教、绝九流者，岂不以疏神达要，陶铸灵府，穷原尽化，镜万象于无象者也！

〖录自《弘明集》卷第五〗


与隐士刘遗民等书 (慧远法师)

与隐士刘遗民等书

［东晋］慧远法师撰

    彭城刘遗民，以晋太元中，除宜昌、柴桑二县令。值庐山灵邃，足以往而不反，遇沙门释慧远，可以服膺。丁母忧，去职入山，遂有终焉之志。于西林涧北，别立禅坊，养志闲处，安贫不营货利。是时闲退之士轻举而集者，若宗炳、张野、周续之、雷次宗之徒，咸在会焉。遗民与群贤游处，研精玄理，以此永日。远乃遗其书曰：

    “每寻畴昔，游心世典，以为当年之华苑也。及见《老》、《庄》，便悟名教是应变之虚谈耳。以今而观，则知沉冥之趣，岂得不以佛理为先？苟会之有宗，则百家同致。君与诸人，并为如来贤弟子也。策名神府，为日已久。徒积怀远之兴，而乏因籍之资。以此永年，岂所以励其宿心哉？意谓六斋日，宜简绝常务，专心空门。然后津寄之情笃，来生之计深矣。若染翰缀文，可托兴于此。虽言生于不足，然非言无以畅一诣之感。因骥之喻，亦何必远寄古人。”

    于是山居道俗，日加策励。遗民精勤偏至，具持禁戒，宗、张等所不及。专念禅坐，始涉半年，定中见佛，行路遇像。佛于空现，光照天地，皆作金色。又披袈裟，在宝池浴。出定已，请僧读经，愿速舍命。在山一十五年，自知亡日，与众别已，都无疾苦。至期，西面端坐，敛手气绝，年五十有七。先作《笃终诫》曰：“皇甫谧《遗论》，佩《孝经》示不忘孝道。盖似有意小儿之行事。今即土为墓，勿用棺椁。”子雍从之。周续之等筑室相次，各有芳绩，如别所云。

〖录自《广弘明集》卷第二十七〗


庐山结社立誓文 (刘遗民)

庐山结社立誓文

［东晋］刘遗民撰

    既而谨律息心之士，绝尘清信之宾，并不期而至，望风遥集。彭城刘遗民、豫章雷次宗、雁门周续之、新蔡毕颖之、南阳宗炳、张莱民、张季硕等，并弃世遗荣，依远游止。远乃于精舍无量寿像前，建斋立誓，共期西方。乃令刘遗民著其文曰：

    惟岁在摄提格，七月戊辰朔，二十八日乙未。法师释慧远，贞感幽奥，霜怀特发。乃延命同志息心贞信之士，百有二十三人，集于庐山之阴，般若台精舍阿弥陀像前，率以香华敬荐而誓焉。
    惟斯一会之众，夫缘化之理既明，则三世之传显矣；迁感之数既符，则善恶之报必矣。推交臂之潜沦，悟无常之期切；审三报之相催，知险趣之难拔。此其同志诸贤，所以夕惕宵勤，仰思攸济者也。盖神者可以感涉，而不可以迹求。必感之有物，则幽路咫尺。苟求之无主，则眇茫河津。今幸以不谋而佥心西境，叩篇开信，亮情天发。乃机象通于寝梦，欣欢百于子来。于是云图表晖，影侔神造。功由理谐，事非人运。兹实天启其诚，冥运来萃者矣。可不克心，重精叠思，以凝其虑哉！
    然其景绩参差，功德不一。虽晨祈云同，夕归攸隔。即我师友之眷，良可悲矣！是以慨焉，胥命整襟法堂，等施一心，亭怀幽极。誓兹同人，俱游绝域。其有惊出绝伦，首登神界，则无独善于云峤，忘兼全于幽谷。先进之与后升，勉思策征之道。然复妙觐大仪，启心贞照。识以悟新，形由化革。藉芙蓉于中流，荫琼柯以咏言。飘云衣于八极，泛香风以穷年。体忘安而弥穆，心超乐以自怡。临三途而缅谢，傲天宫而长辞。绍众灵以继轨，指太息以为期。究兹道也，岂不弘哉！

〖录自《高僧传·卷六·慧远传》〗


念佛三昧诗 (王齐之)

念佛三昧诗

［东晋］琅琊王齐之

其一
妙用在兹，涉有览无。神由昧彻，识以照粗。
积微自引，因功本虚。泯彼三观，忘此毫余。

其二
寂漠何始，理玄通微。融然忘适，乃廓灵晖。
心悠缅域，得不践机。用之以冲，会之以希。

其三
神资天凝，圆映朝云。与化而感，与物斯群。
应不以方，受者自分。寂尔渊镜，金水尘纷。

其四
慨自一生，夙乏慧识。托崇渊人，庶藉冥力。
思转毫功，在深不测。至哉之念，注心西极！

（校注：王齐之，一作王乔之。彭绍升《居士传》云：“王乔之，琅琊人，官临贺太守。已而入白莲社事远公，与刘遗民诸贤作《念佛三昧诗》，而乔之诗独传于世。”）

〖录自《广弘明集》卷第三十〗


难《释疑论》(周续之)

难《释疑论》

［东晋］周续之撰

    近见君《释疑论》，盖即情之作，料检理要，殆乎有中。但审分命之守，似未照其本耳。福善莫验，亦仆所常惑。虽周览《六籍》，逾深其滞。及睹经教，始昭然有归。故请以先觉语当今之学者也。
    君以为审分命所钟，可无祈验于冥中；余庆之言，存于劝教。请审“分命”之旨，为当宅情于理，任而弗营耶？为忘怀暗昧，直置而已耶？若宅情于理，则理未可喻，善恶纷互，逆顺莫检，苟非冥废，岂得弗营？若直置而已，则自非坐忘，事至必感。感因于事，则情亦升降。履信获祐，何能不庆？为恶弗罚，焉得无怨？虽欲忘怀，其可得乎？靖求诸己，其效明矣。
    又劝教之设，必傍实而动直。为训之方，不可一途而尽。故或若反而后会，或晓昧于为言。是以途车刍灵，堂室异诏，或显其远，或微其近。令循教之徒，不苟求于分表；饮和之士，自足于仁义。故深浅并训，而民听不滥。而神明之赜，蕴于妙物，岂得显称积善，正位履霜，而事与教反，理与言违？夷、齐自得于安忍，颜、冉长悲于履和，恐有为之言，或异于此。若谓商臣之徒，教所不及。汲引之端，盖中智已还。而安于怀仁，不没其身；臧会以僭，有后鲁国。则分命所钟，于何而审？玄明之唱，更为疑府矣。
    是以古之君子，知通圮之来，其过非新。贤愚寿夭，兆明自昔。楚穆以福浓获没，蔡灵以善薄受祸。郄苑以衅深莫救，宋桓以愆微易唱。故洗心以怀宗，练形以闻道。拔无明之沉根，翳贪爱之滞网。不祈验于冥中，影响自征。不期存于应报，而庆罚以彰。故能反步八极，水镜万有。
    但微明之道，理隔常域。尧、孔拯其粗，宜有未尽。史迁造其门，而未践乎室。惜其在无闻之世，故永悲以穷年。君既涉其津，亦应不远而得。此乃幽明之所寄，岂唯言论而已！乖叙多年，聊以代勤。
    来论又以为天地旷远，人事细近，一善一恶，无关冥应。然则天网恢恢，疏而遂失耶？莫见乎隐，莫显乎微。但盈换藏于日用，交赊昧乎理缘，故或乖于视听耳。山崩钟应，不以路远丧感。火泽革性，不以同象成亲。详检数端，可以少悟矣。

（校注：本文是承庐山远公之意，对戴安公《释疑论》所作的答释。其后远公又作《三报论》，以进一步澄清疑惑。《广弘明集》同卷载《释疑论》全文及相关信件，阅者自可披览。）

〖录自《广弘明集》卷第十八〗


明佛论 (宗炳)

明 佛 论
（一名《神不灭论》）

［刘宋］宗炳 著

    夫道之至妙，固风化宜尊；而世多诞佛，咸以我躬不阅，遑恤于后。万里之事，百年以外，皆不以为然。况复须弥之大，佛国之伟，精神不灭，人可成佛，心作万有，诸法皆空，宿缘绵邈，亿劫乃报乎！此皆英奇超洞，理信事实。黄华之听，岂纳云门之调哉？世人又贵周、孔书典，自尧至汉，九州华夏，曾所弗暨，殊域何感？汉明何德，而独昭灵彩？凡若此情，又皆牵附先习，不能旷以玄览，故至理匪遐，而疑以自没。悲夫！中国君子明于礼义，而暗于知人心，宁知佛心乎？今世业近事，谋之不臧，犹兴丧及之。况精神作哉，得焉则清升无穷，失矣则永坠无极。可不临深而求，履薄而虑乎？夫一局之奕，形算之浅，而奕秋之心何尝有得？而乃欲率井蛙之见，妄抑大猷，至独陷神于天阱之下，不以甚乎！今以茫昧之识，烛幽冥之故，既不能自览鉴于所失，何能独明于所得？唯当明精暗向，推夫善道，居然宜修，以佛经为指南耳。彼佛经也，包《五典》之德，深加远大之实；含老、庄之虚，而重增皆空之尽。高言实理，肃焉感神，其映如日，其清如风，非圣谁说乎？谨推世之所见，而会佛之理，为明论曰：
    今会自抚踵至顶，以去凌虚，心往而勿已，则四方上下皆无穷也。生不独造，必传所资。仰追所传，则无始也。奕世相生而不已，则亦无竟也。是身也，既日用无垠之实，亲由无始而来，又将传于无竟而去矣。然则无量无边之旷，无始无终之久，人固相与凌之以自敷者也。是以居赤县，于八极曾不疑焉。今布三千日月，罗万二千天下，恒沙阅国界，飞尘纪积劫。普冥化之所容，俱眇末其未央，何独安我而疑彼哉？
    夫秋毫处沧海，其悬犹有极也。今缀彝伦于太虚，为藐胡可言哉？故世之所大，道之所小。人之所遐，天之所迩。所谓轩辕之前，遐哉邈矣者，体天道以高览，盖昨日之事耳。《书》称知远，不出唐、虞；《春秋》属辞，尽于王业；《礼》、《乐》之良敬，《诗》、《易》之温洁。今于无穷之中，焕三千日月以列照，丽万二千天下以贞观，乃知周、孔所述，盖于蛮触之域，应求治之粗感，且宁乏于一生之内耳。逸乎生表者，存而未论也。若不然也，何其笃于为始形，而略于为神哉？登蒙山而小鲁，登太山而小天下，是其际矣。且又《坟》、《典》已逸，俗儒所编，专在治迹。言有出于世表，或散没于史策，或绝灭于坑焚。若老子、庄周之道，松、乔列真之术，信可以洗心养身，而亦皆无取于《六经》。而学者唯守救粗之阙文，以《书》、《礼》为限断，闻穷神积劫之远化，炫目前而永忽，不亦悲夫？呜呼！有似行乎层云之下，而不信日月者也。
    今称“一阴一阳之谓道，阴阳不测之谓神”者。盖谓至无为道，阴阳两浑，故曰“一阴一阳”也。自道而降，便入精神，常有于阴阳之表，非二仪所究，故曰“阴阳不测”耳。君平之说“一生二”，谓“神明”是也。若此二句，皆以明无，则以何明精神乎？然群生之神，其极虽齐，而随缘迁流，成粗妙之识，而与本不灭矣。今虽舜生于瞽，舜之神也，必非瞽之所生。则商均之神，又非舜之所育。生育之前，素有粗妙矣。既本立于未生之先，则知不灭于既死之后矣。又不灭则不同，愚圣则异，知愚圣生死不革不灭之分矣。故云：精神受形，周遍五道，成坏天地，不可称数也。夫以累瞳之质，诞于顽瞽；嚚均之身，受体黄中。愚圣天绝，何数以合乎？岂非重华之灵，始粗于在昔。结因往劫之先，缘会万化之后哉？今则独绝其神，昔有接粗之累，则练之所尽矣。神之不灭，及缘会之理、积习而圣，三者鉴于此矣。
    若使形生则神生，形死则神死，则宜形残神毁，形病神困。据有腐则其身，或属纩临尽，而神意平全者；及自牖执手，病之极矣，而无变德行之主，斯殆不灭之验也。若必神生于形，本非缘合。今请远取诸物，然后近求诸身。夫五岳四渎谓无灵也，则未可断矣。若许其神，则岳唯积土之多，渎唯积水而已矣。得一之灵，何生水土之粗哉？而感托岩流，肃成一体，设使山崩川竭，必不与水土俱亡矣。神非形作，合而不灭，人亦然矣。神也者，妙万物而为言矣。若资形以造，随形以灭，则以形为本，何妙以言乎？夫精神四达，并流无极，上际于天，下盘于地。圣之穷机，贤之研微。逮于宰、赐、庄、嵇、吴札、子房之伦，精用所乏，皆不疾不行，坐彻宇宙。而形之臭腐，甘嗜所资，皆与下愚同矣，宁当复禀之以生，随之以灭耶？又宜思矣。周公郊祀后稷，宗祀文王，世或谓空以孝。即问谈者，何以了其必空？则必无以了矣。苟无以了，则文、稷之灵，不可谓之灭矣。斋三日，必见所为斋者。宁可以常人之不见，而断周公之必不见哉？嬴博之葬，曰：“骨肉归于土，魂气则无不之。”非灭之谓矣！
    夫至治则天，大乱滔天，其要心神之为也。尧无理不照，无欲不尽，其神精也。桀无恶不肆，其神悖也。桀非不知尧之善，知己之恶，恶己亡也。体之所欲，悖其神也。而知尧、恶亡之识，常含于神矣。若使不居君位，千岁勿死，行恶则楚毒交至，微善则少有所宽。宁当复不稍灭其恶，渐修其善乎？则向者神之所含知尧之识，必当少有所用矣。又加千岁而勿已，亦可以其欲都澄，遂精其神如尧者也。
    夫辰月变，则律吕动；晦望交，而蚌蛤应；分至启闭，而燕、鹰、龙、蛇飒焉出没者。皆先之以冥化，而后发于物类也。凡厥群有，同见陶于冥化矣，何数事之独然，而万化之不尽然哉？今所以杀人而死，伤人而刑，及为缧绁之罪者；及今则无罪，与今有罪而同然者。皆由冥缘前遘，而人理后发矣。夫幽显一也，衅遘于幽，而丑发于显，既无怪矣；行凶于显，而受毒于幽，又何怪乎？今以不灭之神，含知尧之识，幽显于万世之中，苦以创恶，乐以诱善，加有日月之宗，垂光助照，何缘不虚己钻仰，一变至道乎？自恐往劫之桀、纣，皆可徐成将来之汤、武。况今风情之伦，少而泛心于清流者乎？由此观之，人可作佛，其亦明矣。
    夫生之起也，皆由情兆。今男女构精，万物化生者，皆精由情构矣。情构于己，而则百众神受身大似，知情为生本矣。至若五帝三后，虽超情穷神，然无理不顺，苟昔缘所会，亦必循俯入精化，相与顺生，而敷万族矣。况今以情贯神，一身死坏，安得不复受一身，生死无量乎？识能澄不灭之本，禀日损之学，损之又损，必至无为无欲。欲情唯神独照，则无当于生矣。无生则无身，无身而有神，法身之谓也。
    今黄帝、虞舜、姬公、孔父，世之所仰而信者也。观其纵辔升天，龙潜鸟扬，反风起禾，绝粒弦歌，亦皆由穷神为体，故神功所应，倜傥无方也。今形理虽外，当其随感起灭，亦必有非人力所致而至者。河之出图，洛之出书；蓂荚无栽而敷，玄圭不琢而成；桑谷在庭，倏然大拱，忽尔以亡；火流王屋而为乌；鼎之轻重大小，皆翕欻变化，感灵而作；斯实不思议之明类也。夫以法身之极灵，感妙众而化见，照神功以朗物，复何奇不肆，何变可限。岂直仰凌九天，龙行九泉，吸风绝粒而已哉？凡厥光仪符瑞之伟，分身涌出，移转世界，巨海入毛之类。方之黄、虞、姬、孔，神化无方。向者众瑞之晻暧显没，既出形而入神，同惚恍而玄化。何独信此而抑彼哉？冥觉法王，清明卓朗，信而有征。不违颜咫尺，而昧者不知，哀矣哉！
    夫《洪范》庶征休咎之应，皆由心来。逮白虹贯日，太白入昴，寒谷生黍，崩城陨霜之类，皆发自人情，而远形天事，固相为形影矣。夫形无无影，声无无响，亦情无无报矣，岂直贯日陨霜之类哉？皆莫不随情曲应，物无遁形。但或结于身，或播于事，交赊纷纶，显昧眇漫，孰睹其际哉。众变盈世，群象满目，皆万世以来，精感之所集矣。故佛经云：“一切诸法，从意生形。”又云：“心为法本，心作天堂，心作地狱。”义由此也。是以清心洁情，必妙生于英丽之境。浊情滓行，永悖于三途之域。何斯唱之迢遰，微明有实理，而直疏魂沐想，飞诚悚志者哉？虽然，夫亿等之情，皆相缘成识，识感成形，其性实无也。自有津悟以来，孤声豁然，灭除心患，未有斯之至也。
    请又述而明之：夫圣神玄照，而无思营之识者，由心与物绝，唯神而已。故虚明之本，终始常住，不可凋矣。今心与物交，不一于神。虽以颜子之微微，而必乾乾钻仰，好仁乐山，庶乎屡空。皆心用乃识，必用用妙接，识识妙续，如火之炎炎相即而成焰耳。今以悟空息心，心用止而情识歇，则神明全矣。则情识之构，既新故妙续，则悉是不一之际，岂常有哉？使庖丁观之，必不见全牛者矣。佛经所谓变易离散之法，法识之性空，梦幻、影响、泡沫、水月，岂不然哉？颜子知其如此，故处有若无，抚实若虚，不见有犯而不校也。今观颜子之屡虚，则知其有之实无矣。况自兹以降，丧真弥远。虽复进趋大道，而与东走之疾，同名狂者。皆违理谬感，遁天妄行，弥非真有矣。况又质味声色，复是情伪之所影化乎？且舟壑潜谢，变速奔电，将来未至，过去已灭，见在不住。瞬息之顷，无一毫可据，将欲何守而以为有乎？甚矣！伪有之蔽神也。今有明镜于斯，纷秽集之微，则其照蔼然，积则其照朏然，弥厚则照而昧矣。质其本明，故加秽犹照，虽从蔼至昧，要随镜不灭。以之辩物，必随秽弥失，而过谬成焉。人之神理，有类于此。伪有累神，成精粗之识。识附于神，故虽死不灭。渐之以空，必将习渐至尽，而穷本神矣，泥洹之谓也。是以至言云富，从而豁以空焉。夫岩林希微，风水为虚。盈怀而往，犹有旷然。况圣穆乎空，以虚授人，而不清心乐尽哉！是以古之乘虚入道，一沙一佛，未讵多也。
    或问曰：神本至虚，何故沾受万有，而与之为缘乎？又本虚既均，何故分为愚圣乎？又既云“心作万有”，未有万有之时，复何以累心，使感而生万有乎？
    答曰：今神妙形粗，而相与为用。以妙缘粗，则知以虚缘有矣。今愚者虽鄙，要能处今识昔，在此忆彼。皆有神功，则练而可尽，知其本均虚矣。心作万有，备于前论。据见观实，三者固已信然矣。但所以然者，其来无始。无始之始，岂有始乎？亦玄之又玄矣。庄周称冉求问曰：“未有天地可知乎？”仲尼曰：“古犹今也。”盖谓虽在无始之前，仰寻先际，初自茫眇，犹今之冉求耳。今神明始创，及群生最先之祖，都自杳漠，非追想所及，岂复学者通塞所预乎？夫圣固凝废，感而后应耳。非想所及，即六合之外矣，无以为感，故存而不论。圣而弗论，民何由悟？今相与践地戴天而存，践戴之外，岂有纪极乎？禹之弼成五服，敷土不过九州者，盖道世路所及者耳。至于大荒之表，旸谷濛汜之际，非复人理所预，则神圣已所不明矣。况过此弥往，浑瀚冥茫，岂复议其边陲哉？今推所践戴，终至所不议，故一体耳。推今之神用，求昔之所始终，至于圣人之所存而不论者，亦一理相贯耳，岂独可议哉？皆由冥缘随宇宙而无穷，物情所感者有限故也。夫众心禀圣以成识，其犹众目会日以为见。离朱察秋毫于百寻，资其妙目，假日而睹耳。今布毫于千步之外，目力所匮，无假以见，而于察微避危，无所少矣。何为以千步所昧，还疑百寻之毫乎？今不达缘本，情感所匮，无以会圣，而知取至于致道之津，无所少矣。何为以缘始之昧，还疑既明之化矣哉？
    或问曰：今人云“不解缘始，故不得信佛”，此非感耶？圣人何以不为明之？
    答曰：所谓感者，抱升之分，而理有未至，要当资圣以通，此理之实感者也。是以乐身滞有，则朗以苦空之义；兼爱弗弘，则示以投身之慈；体非俱至，而三乘设；分业异修，而六度明。津梁之应，无一不足，可谓感而后应者也。是以闻道灵鹫，天人咸畅，造极者蔚如也。岂复远疑缘始，然后至哉？理明训足，如说修行，何所不备？而犹必不信，终怀过疑于想所不及者。与将陨之疾，馈药不服；流矢通中，忍痛不拔；要求矢、药造构之始，以致命绝，夫何异哉？皆由猜道自昔，故未会无言，致使今日在信妄疑耳，岂可以为实理之感哉？非理妄疑之惑，固无以感圣而克明矣。夫非我求蒙，蒙而求我。固宜虚己及身，随顺玄化，诚以信往，然后悟随应来。一悟所振，终可遂至冥极。守是妄疑，而不归纯敛衽者，方将长沦惑网之灾，岂有旦期？背向一差，升坠天绝，可不慎乎！
    或问曰：孔氏之训：“无求生以害仁，有杀身以成仁。”仁之至也，亦佛经说菩萨之行矣。老子明“无为”，无为之至也，即泥洹之极矣。而曾不称其神通成佛，岂孔、老有所不尽与？明道欲以扇物，而掩其致道之实乎？无实之疑，安得不生？
    答曰：教化之发，各指所应。世蕲乎乱，洙泗所弘，应治道也。纯风弥凋，二篇乃作，以息动也。若使颜、冉、宰、赐、尹喜、庄周，外赞儒玄之迹，以导世情所极，内禀无生之学，以精神理之求，世孰识哉？至若冉季、子游、子夏、子思、孟轲、林宗、康成、盖公、严平、班嗣、杨王之流，或分尽于礼教，或自毕于任逸，而无欣于佛法，皆其寡缘所穷，终无僭滥。故孔、老发音指导，自斯之伦感向所暨，故不复越叩过应。儒以弘仁，道在抑动，皆已抚教得崖，莫匪尔极矣。虽慈良、无为，与佛说通流，而法身、泥洹无与尽言，故弗明耳。且凡称“无为而无不为”者，与夫“法身无形，普入一切”者，岂不同致哉！是以孔、老、如来，虽三训殊路，而习善共辙也。
    或问曰：自三五以来，暨于孔、老。洗心佛法，要将有人。而献酬之迹，曾不乍闻者，何哉？
    答曰：余前论之旨已明，俗儒而编专在治迹。言有出于世表，或散没于史策，或绝灭于坑焚。今又重敷所怀。夫三皇之书，谓之《三坟》，言大道也。尔时也，孝慈天足，岂复训以仁义？纯朴弗离，若老、庄者复何所扇？若不明神本于无生，空众性以照极者，复以何为大道乎？斯文没矣，世孰识哉！史迁之述五帝也，皆云生而神灵，或弱而能言，或自言其名。懿渊疏通，其知如神。既以类夫大乘菩萨，化见而生者矣。居轩辕之丘，登崆峒，陟凡岱，幽陵蟠木之游，逸迹超浪，何以知其不由从如来之道哉？以五帝之长世，尧治百年，舜则七十。广成大隗鸿崖，巢、许、夸父、北人、姑射四子之流，玄风畜积，洋溢于时。而《五典》余类，唯唐、虞二篇，而至寡阙。子长之记，又谓：“百家之言黄帝，文不雅训，搢绅难言。唯采杀伐治迹，犹万不记一。”岂至道之盛，不见于残缺之篇，便当皆虚妄哉？今以神明之君，游浩然之世，携七圣于具茨，见神人于姑射，一化之生，复何足多谈。微言所精，安知非穷神亿劫之表哉？
    广成之言曰：“至道之精，窈窈冥冥。”即首楞严三昧矣。“得吾道者，上为皇，下为王。”即亦随化升降，为飞行皇帝、转轮圣王之类也。“失吾道者，上见光，下为土。”亦生死于天人之界者矣。“感大隗之风，称天师而退”者，亦十号之称矣。自恐无生之化，皆道深于若时，业流于玄胜。而事没振古，理随文翳，故百家所摭，若晓而昧，又搢绅之儒，不谓雅训。遂令殉世而不深于道者，仗史籍而抑至理，从近情而忽远化，困精神于永劫，岂不痛哉！
    伯益述《山海》：“天毒之国，偎人而爱人。”郭璞传：“古谓天毒，即天竺，浮屠所兴。偎爱之义，亦如来大慈之训矣。”固亦既闻于三五之世也。国典弗传，不足疑矣。凡三代之下，及孔、老之际，史策之外竟何可量？孔之问礼，老为言之；关尹之求，复为明道。设使二篇或没，其言独存于《礼记》，后世何得不谓柱下翁，直是知礼老儒？岂不体于玄风乎？今百代众书，飘荡于存亡之后，理无备在。岂可断以所见，绝献酬于孔、老哉！东方朔对汉武劫烧之说，刘向《列仙》叙“七十四人在佛经”，学者之管窥于斯，又非汉明而始也。但驰神越世者众而显，结诚幽微者寡而隐，故潜感之实，不扬于物耳。
    道人澄公，仁圣于石勒、虎之世，谓虎曰：“临淄城中，有古阿育王寺处，犹有形像、承露盘，在深林巨树之下，入地二十丈。”虎使者依图搜求，皆如言得。近姚略叔父为晋王，于河东蒲坂，古老所谓阿育王寺处，见有光明。凿求得佛遗骨，于石函银匣之中，光曜殊常，随略迎睹于霸上比丘，今见在辛寺。由此观之，有佛事于齐、晋之地久矣哉！所以不说于三传者，亦犹干宝、孙盛之史，无语称佛，而妙化实彰有晋，而盛于江左也。
    或问曰：若诸佛见存，一切洞彻，而威神之力，诸法自在。何为不曜光仪于当今，使精粗同其信悟；洒神功于穷迫，以拔冤枉之命？而令君子之流，于佛无睹，故同其不信，俱陷阐提之苦？秦、赵之众，一日之中，白起、项藉坑六十万。夫古今彝伦，及诸受坑者，诚不悉有宿缘大善；尽不睹无一缘，而悉积大恶。而不睹佛之悲一日俱坑之痛，慭然毕同，坐视穷酷而不应，何以为慈乎？缘不倾天，德不邈世，则不能济，何以为神力自在、不可思议乎？鲁阳回日，耿恭飞泉，宋九江虎远江而蝗避境，犹皆心横彻，能使非道玄通。况佛神力，融起之气，治籍之心，以活百万之命殊易。夫纳须弥于芥子，甚仁于毁身乎一虎一鸽矣！而今想焉而弗见，告焉而弗闻，请之而无救，寂寥然与大空无别。而于其中，有作沙门而烧身者，有绝人理而剪六情者，有苦力役、倾资宝而事庙像者，顿夺其当年，而不见其所得。吁！可惜矣。若谓应在将来者，则向六十万，命善恶不同，而枉灭同矣。命善恶虽异，身后所当，独何得异？见世殊品，既一不蒙甄别，将来浩荡，为欲何望？况复恐实无将来乎？经云：“足指按地，三千佛土皆见，及盲聋喑哑、牢狱毒痛，皆得安宁。”夫佛，远近存亡、有戒无戒，等以慈焉。此之有心宜见，苦痛宜宁，与彼一矣。而经则快多是语，实则竟无暂应。安知非异国有命世逸群者，构此空法，以胁异翼善。交言有微远之情事，有澄肃之美纯。而易信者一己输身，遂相承于不测，而势无止薄乎？
    答曰：今不睹其路，故于夷谓险。诚瞰其途，则不见所难矣。夫常无者，道也，唯佛则以神法道。故德与道为一，神与道为二。二故有照以通化，一故常因而无造。夫万化者，固各随因缘，自作于大道之中矣。今所以称佛，云“诸法自在，不可思议”者，非曰为可不由缘数，越宿命而横济也。盖众生无量，神功所导，皆依崖曲畅，其照不可思量耳。譬之洪水、四凶、瞽顽、象傲，皆化之固然，尧、舜弗能易矣。而必各依其崖，降水流凶，允若克谐，其德岂不大哉！夫佛也者，非他也，盖圣人之道不尽于济生之俗，敷化于外生之世者耳。至于因而不为，功自物成，直尧之殊应者耳。
    夫钟律感类，犹心玄会，况夫灵圣以神理为类乎？凡厥相与冥遘于佛国者，皆其烈志清神，积劫增明，故能感诣洞彻。致使释迦发晖，十方交映，多宝踊见，灯王入室。岂佛之独显乎哉？能见矣。至若今之君子，不生应供之运，而域乎禹绩之内。皆其诚背于昔，故会乖于今。虽复清若夷、齐，贞如柳、季，所志苟殊，复何由感而见佛乎？况今之所谓，或自斯以还。虽复礼义熏身，高名馥世，而情深于人，志不附道。虽人之君子，而实天之小人。灵极之容，复何由感映？岂佛之偏隐哉？我弗见矣。若或有随缘来生，而六度之诚发自宿业，感见独朗，亦当屡有其人。然虽道俗比肩，复何由相知乎？然则粗妙在我，故见否殊应。岂可以己之不曜于光仪，而疑佛不见存哉？
    夫天地有灵，精神不灭，明矣。今秦、赵之众，其神与宇宙俱来，成败天地而不灭。起、籍二将，岂得顿灭六十万神哉？神不可灭也，则所灭者身也。岂不皆如佛言：“常灭群生之身，故其身受灭。”而数会于起、籍乎？何以明之？夫乾道变化，各正性命，至于鸡、彘、犬、羊之命，皆乾坤六子之所一也。民之咀命充身，暴同蛛蟱为网矣。鹰、虎非搏噬不生；人可饭蔬而存，则虐已甚矣。天道至公，所布者命，宁当许其虐命，而抑其冥应哉！今六十万人，虽当美恶殊品，至于忍咀群生，恐不异也。美恶殊矣，故其生之所享，固可实殊。害生同矣，故受害之日，固亦可同。
    今道家之言，世之所述，无以云焉。至若于公、邴吉、虞怡，德应于后；严延年、田蚡、晋宣，杀报交验。皆书于魏、汉，世所信睹。夫活人而庆流子孙，况精神为杀活之主，无殃庆于后身乎？杀活彼身，必受报己身，况通塞彼神，而不荣悴于己神乎？延年所杀，皆凡等小人；窦婴、王陵，宰牧之豪。贤否殊，贵贱异，其致报一也。报之所加，不论豪贱，将相、晋王不二矣。岂非天道至平，才与不才，亦各其子。理存性命，不在贵贱故耶？然则肫鱼虽贱，性命各正于乾道矣。观大鸟之回翔，小鸟之啁噍，葛庐所听之牛，西巴所感之鹿，情爱各深于其类矣。今有孕妇稚子于斯，而有刳而剔之，燔而炙之者，则谓冤痛之殃，上天所感矣。今春猎胎孕，燔葅羔雏，亦天道之所一也，岂得独无报哉？但今相与理，缘于饮血之世，畋渔非可顿绝。是以圣王庖厨其化，盖顺民之杀以减其害，践庖闻声，则所不忍。因豺獭以为节，疾非时之伤孕。解罝而不网，明含气之命重矣。孟轲击赏于衅钟，知王德之去杀矣。先王抚粗救急，故虽深其仁，不得顿苦其禁。如来穷神明极，故均重五道之命，去杀为众戒之首。萍沙见报于白兔，释氏受灭于昔鱼，以示报应之势。皆其窈窕精深，迂而不昧矣。
    若在往生能闻于道，敬修法戒，则必不坠长平而受坑马服矣。及在既坠，信法能彻，必超今难。若缘衅先重，难有前报。及戒德后臻，必不复见坑来身矣。所谓洒神功于穷迫，以拔冤枉之命者，其道如斯，慈之至矣。今虽有世美，而无道心，犯害众命。以报就迫，理之当也。佛乘理居当，而救物以法，不蹈法则理无横济，岂佛无实乎？譬之扁鹊，救疾以药，而不信不服，疾之不瘳，岂鹊不妙乎？鲁阳、耿恭、远祖九江，所以能回日、飞泉、虫虎避德者，皆以烈诚动乎神道。神道之感，即佛之感也。若在秦、赵，必不陷于难矣。则夫陷者，皆己无诚，何由致感于佛，而融冶起、籍哉！
    夫以通神之众，萃穷化之堂，故须弥可见于芥子之内耳。又虽今则虎、鸽，昔或为人，尝有缘会。故值佛嘉运，投身济之，割股代之。苟无感可动，以命偿杀。融冶之奇，安得妄作？吹万之死，咸其自已，而疑佛哉？夫志之笃也，则想之而见，告之斯闻矣。推周孔交梦、傅说形求实至，古今攸隔，傅岩遐阻，而玄对无碍。则可以信夫洁想西感，睹无量寿佛，越境百亿，超至无功。何云大空无别哉！
    夫道在练神，不由存形。是以沙门祝形烧身，厉神绝往。神不可灭，而能奔其往，岂有负哉？契阔人理，崎岖六情，何获于我，而求累于神？诚自剪绝，则日损所情，实渐于道。苦力策观，倾资夐居，未几有之。俄然身灭，名实所收，不出盗跨。构馆栖神象，渊然幽穆，形从其微，神随之远。微则应清，远则福妙。盗跨与道，孰为优乎？顿夺其当年，所以超升。潜行协于神明，福德彰于后身，岂能见其所得哉？
    夫人事之动，必贯神道。物无妄然，要当有故而然矣。若使幽冥之报不如向论，则六十万命，何理以坑乎？既以报坑，必以报不坑矣。今战国之人，眇若安期，幽若四皓，龙颜而帝，列地而君，英声茂实，不可称数，同在羿之彀中，独何然乎？岂不各是前报之所应乎？既见福成于往行，则今行无负于后身，明矣。见世殊品，既宿命所甄。则身后所当，独何容滥？
    经之所奇，自谓当佛化见之时，皆由素有嘉会，故其遇若彼。今曾无暂应，皆咎在无缘，而反诬至法空构。呜呼！神鉴孔昭，侮圣人之殃，亦可畏也。敢问空构者将圣人与？贤人与？小人与？夫圣无常心，盖就物之性，化使遂耳。若身死神灭，但当一以儒训，尽其生极。复何事哉，而诳以不灭，欺以成佛？使烧祝发肤，绝其牉合，所遏苗裔，数不可量。且夫彦圣，育无常所，或潜有塞矣，空构何利，而其毒大苦，知非圣贤之为矣。若人哉，樊须之流也，则亦敛身周、孔，畏惧异端，敢妄作哉？若自兹以降，则不肖之伦也，又安能立家九流之外，增徽老、庄之表，而昭列于千载之后？
    龙树、提婆、马鸣、迦旃延、法胜、山贤、达摩多罗之伦，旷载五百，仰述道训，《大智》、《中》、《百论》、《阿毗昙》之类，皆神通之才也。近孙绰所颂耆域、健陀勒等八贤，支道林像而赞者竺法护、于法兰、道邃、阙公则，皆神映中华。中朝竺法行，时人比之乐令。江左尸梨蜜，群公高其卓朗。郭文举廓然邃允，而所奉唯佛。凡自龙树以达，宁皆失身于向所谓不肖者之诧乎？然则黄面夫子之事，岂不明明也哉！今影骨、齿发、遗器余武，犹光于本国，此亦道之证也。夫殊域之性，多有精察黠才，而嗜欲类深。皆以厥祖身立佛前，累叶亲传，世祗其实；影迹遗事，昭化融显。故其裔王，则倾国奉戒，四众苦彻，死而无悔。若理之诡暧，事不实奇，亦岂肯倾己破欲，以尊无形者乎？若影物无实，声出来往，则古今来者，何为苦身离欲，若是之至？往而反者，宜其沮懈，而类皆更笃乎？粗可察矣。
    论曰：夫自古所以丕显治道者，将存其生也。而苦由生来，昧者不知矣。故诸佛悟之以苦，导以无生。无生不可顿体，而引以生之善恶同。善报而弥升，则朗然之尽可阶焉。是以其道浩若沧海，小无不津，大无不通。虽邈与务治存生者反，而亦固陶潜《五典》，劝佐礼教焉。今世之所以慢祸福于天道者，类若史迁感伯夷而慨者也。夫孔圣岂妄说也哉？称“积善余庆，积恶余殃”，而颜、冉夭疾，厥胤蔑闻；商臣考终，而庄则贤霸。凡若此类，皆理不可通。然理岂有无通者乎？则纳庆后身，受殃三途之说，不得不信矣。虽形有存亡，而精神必应，与见世而报，夫何异哉？但因缘有先后，故对至有迟速，犹一生祸福之早晚者耳。然则孔氏之训，资释氏而通，可不曰玄极不易之道哉！
    夫人理飘纷，存没若幻，笼以百年命之，孩老无不尽矣。虽复黄发鲐背，犹自觉所经俄顷，况其短者乎？且时则无止，运则无穷，既往积劫无数无边，皆一瞬一阅以及今耳。今积瞬以至百年，曾何难及，而又鲜克半焉！夫物之媚于朝露之身者，类无清遐之实矣。何为甘臭腐于漏刻，以枉长存之神，而不自疏于遐远之风哉！虽复名法佐世之家，亦何独无分于大道？但宛转人域，嚣于世路，故唯觉人道为盛，而神想蔑如耳。若使回身中荒，升岳遐览，妙观天宇澄肃之旷，日月照洞之奇，宁无列圣威灵尊严乎其中，而唯离人群匆匆世务而已哉？固将怀远以开神道之想，感寂以昭明灵之应矣。
    昔仲尼修《五经》于鲁，以化天下，及其眇邈太、蒙之颠，而天下与鲁俱小。岂非神合于八遐，故超于一世哉？然则《五经》之作，盖于俄顷之间，应其所小者耳。世又何得以格佛法而不信哉？请问今之不信，为谓黔首之外，都无神明耶？为之亦谓有之，而直无佛乎？若都无神明，唯人而已，则谁命玄鸟，降而生商？孰遗巨迹，感而生弃哉？汉、魏、晋、宋，咸有瑞命。知视听之表，神道炳焉。有神理，必有妙极，得一以灵，非佛而何？夫神也者，依方玄应，应不预存，从实致化，何患不尽，岂须诡物而后训乎？然则其法之实，其教之信，不容疑矣。
    论曰：群生皆以精神为主，故于玄极之灵，咸有理以感。尧则远矣，而百兽舞德，岂非感哉？则佛为万感之宗焉。日月海岳，犹有朝夕之礼，秩望之义。况佛之道众，高者穷神于生表，中者受身于妙生，下则免夫三趣乎？今世教所弘，致治于一生之内，夫玄至者寡，顺世者众，何尝不相与唯习世情，而谓死则神灭乎？是以不务邈志清遐，而多循情寸阴，故君子之道鲜焉。若鉴以佛法，则厥身非我，盖一憩逆旅耳。精神乃我身也，廓长存而无已。上德者，其德之畅于己也无穷；中之为美，徐将清升以至尽；下而恶者，方有自新之回路，可补过而上迁。是以自古精粗之中，洁己怀远，祗行于今，以拟来业，而迈至德者，不可胜数，是佛法之效矣。此皆世之所壅，佛之所开，其于类岂不旷然融朗，妙有通途哉！若之何忽而不奉乎？
    夫风经炎则暄，吹林必凉。清水激浊，澄石必明。神用得丧，亦存所托。今不信佛法，非分之必然，盖处意则然。诚试避心世物，移映清微，则佛理可明，事皆信矣，可不妙处其意乎？资此明信已往，终将克王神道。百世先业，皆可幽明永济，孝之大矣。众生沾仁，慈之至矣。凝神独妙，道之极矣。洞朗无碍，明之尽矣。发轸常人之心，首路得辙，纵可多历劫数，终必径集玄极，若是之奇也。等是人也，背辙失路，蹭蹬长往，而永没九地，可不悲乎？若不然也，世何故忽生懿圣，复育愚鄙，上则诸佛，下则蜎飞蠕动乎？皆精神失得之势也。今人以血身七尺，死老数纪之内，既夜消其半矣。丧疾众故，又苦其半。生之美盛，荣乐得志，盖亦何几？而壮齿不居，荣必惧辱，乐实连忧，亦无全泰。而皆竞入流俗之险路，讳陟佛法之旷途，何如其智也！世之以不达缘本，而闷于佛理者，诚亦众矣！
    夫缘起浩汗，非复追想所及，失得所关。无理以感，即六合之外，故佛而不论，已具前论。请复循环而申之：夫圣人之作《易》，天之垂象，吉凶治乱，其占可知。然原其所以然之状，圣所弗明，则莫之能知。今以所莫知，废其可知，逆占违天而动，岂有不亡者乎？不可以缘始弗明，而背佛法，亦犹此也。又以不忆前身之意，谓神不素存。夫人在胎孕，至于孩龆，不得谓无精神矣。同一生之内耳，以今思之，犹冥然莫忆，况经生死、历异身，昔忆安得不亡乎？所忆亡矣，而无害神之常存。则不达缘始，何妨其理常明乎？子路问死，子曰：“未知生，安知死。”问事鬼神，则曰：“未知事人，焉知事鬼。”岂不以由也尽于好勇，笃于事君，固宜应以一生之内。至于生死、鬼神之本，虽曰有问，非其实理之感。故性与天道，不可得闻。佛家之说众生有边无边之类十四问，一切智者皆置而不答。诚以答之无利益，则堕恶耶。然则禀圣奉佛之道，固宜谢其所绝，餐其所应，如渴者饮河，挹洪流以盈己，岂须穷源于昆山哉？凡在佛法，若违天碍理，不可得然，则疑之可也。今无不可得然之碍，而有顺天清神之实，岂不诚然哉！
    夫人之生也，与忧俱生。患祸发于时事，灾沴奋于冥昧。虽复雅贵连云，拥徒百万，初自独以形神坐待无常。家人嗃嗃，妇子嘻嘻，俄复沦为惚恍。人理曾何足恃？是以过隙宜竞，赊谤冥化，纵欲侈害，神既无灭，求灭不得，复当乘罪受身。今之无赖群生，虫豸万等，皆殷鉴也。为之谋者，唯有委诚信佛，托心履戒，以援精神。生蒙灵援，死则清升。清升无已，径将作佛。佛固言尔，而人侮之。何以断人之胜佛乎？其不胜也，当不下坠彼恶，永受其剧乎？呜呼！六极苦毒，而生者所以世无已也。所闻所见，精进而死者，临尽类多神意安定。有危迫者，一心称观世音，略无不蒙济。皆向所谓生蒙灵援、死则清升之符也。
    夫万乘之主，千乘之君，日昃不遑食，兆民赖之于一化内耳。何以增茂其神，而王万化乎？今依周、孔以养民，味佛法以养神，则生为明后，殁为明神，而常王矣。如来岂欺我哉？非崇塔侈像，容养滥吹之僧，以伤财害民之谓也。物之不窥远实而睹近弊，将横以诟法矣。盖尊其道，信其教，悟无常，空色有，慈心整化，不以尊豪轻绝物命，不使不肖窃假非服。岂非导之以德，齐之以礼，天下归仁之盛乎！其在容与之位，及野泽之身，何所足惜，而不自济其精神哉！
    昔远和尚澄业庐山，余往憩五旬，高洁贞厉，理学精妙，固远流也。其师安法师，灵德自奇。微遇比丘，并含清真。皆其相与素洽乎道，而后孤立于山。是以神明之化，邃于岩林。骤与余言于崖树涧壑之间，暧然乎有自言表而肃人者。凡若斯论，亦和尚据经之旨云尔。夫善即者，因鸟迹以书契，穷神与人之颂。缇萦一言，而霸业用遂，肉刑永除。事固有俄尔微感，而终至冲天者。今芜陋鄙言，以警其所感，奄然身没，安知不以之超登哉！

〖录自《弘明集》卷第二〗


难《白黑论》(宗炳)

宗居士炳答何承天书
难《白黑论》

何与宗书

    近得贤从中郎书，说足下勤西方法事。贤者志其大，岂以万劫为奢？但恨短生，无以测冥灵耳。治城慧琳道人作《白黑论》，乃为众僧所排摈，赖蒙值明主善救，得免波罗夷耳。既作比丘，乃不应明此。白徒亦何为不言？足下试寻二家，谁为长者？吾甚昧然，望有以佳悟。何承天白。

宗答何书

    所送琳道人《白黑论》辞情致美，但吾暗于照理，犹未达其意。
    既云：“幽冥之理，不尽于人事。周、孔疑而不辨，释氏辨而不实。”然则人事之表、幽暗之理，为取廓然唯空，为犹有神明耶？若廓然唯空，众圣、庄、老，何故皆云有神？若有神明，复何以断其不实如佛言？今相与共在常人之域，料度近事，犹多差错，以陷患祸。及博弈粗艺，注意研之，或谓生更死，谓死实生。近事之中，都未见有常得而无丧者，何以决断天地之外，亿劫之表，冥冥之中，必谓所辨不实耶？若推据事不容得实，则疑之可也。今人形至粗，人神实妙。以形从神，岂得齐终？心之所感，崩城陨霜，白虹贯日，太白入昴。气禁之医，心作水火，冷暖辄应。况今以至明之智，至精之志，专诚妙彻，感以受身，更生于七宝之土，何为不可实哉？
    又云：“析毫空树，无伤垂荫之茂。离材虚室，无损轮奂之美。贝锦以繁彩发华，和羹以盐梅致旨。”以塞本无之教，又不然矣。佛经所谓“本无”者，非谓众缘和合者皆空也。垂荫、轮奂，处物自可有耳，故谓之“有谛”；性本无矣，故谓之“无谛”。吾虽不悉佛理，谓此唱居然甚安。自古千变万化之有，俄然皆已空矣。当其盛有之时，岂不常有也必空之实，故俄而得以空耶？亦如惠子所谓：“物方生方死，日方中方睨。”死、睨之实，恒预明于未生、未中之前矣。愚者不睹其理，唯见其有，故齐侯摄爽鸠之余伪，而泣恋其乐。贤者心与理一，故颜子庶乎屡空，有若无，实若虚也。自颜以下，则各随深浅，而味其虚矣。若又逾下，纵不能自清于至言，以倾爱竞之惑，亦何常无仿佛于一毫？岂当反以一火增寒，而更令恋嗜好之欲乎？乃云：“明无常，增渴癊之情；陈苦伪，笃竞辰之虑。”其言过矣。
    又以“舟壑、塘驷之论，已盈耳于中国，非理之奥，故不举为教本。”谓“剖析此理，更由指掌之民。”夫舟壑潜谢，佛经所谓“现在不住”矣，诚能明之，则物我常虚，岂非理之奥耶？盖悟之者寡，故不以为教本耳。支公所谓“未与佛同”也。何为以素闻于中国，而蔑其至言哉？
    又以“效神光，无径寸之明；验灵变，无纤介之实。徒称无量之寿，孰见期颐之叟？”诸若此类，皆谓“于事不符”。夫神光灵变，及无量之寿，皆由诚信幽奇，故将生乎佛土，亲映光明，其寿无量耳。今没于邪见，慢诞灵化，理固天隔，当何由睹其事之符乎？
    夫心不贪欲，为十善之本，故能俯绝地狱，仰生天堂，即亦服义蹈道、理端心者矣。今内怀虔仰，故礼拜悔罪；达夫无常，故情无所吝。委妻子而为施，岂有邀于百倍？复何得乃云“不由恭肃之意，不乘无吝之情”乎？泥洹以无乐为乐，法身以无身为身。若本不希拟，亦可为增耽逸之虑，肇好奇之心。若诚餐仰，则耽逸稍除，而获利于无利矣，又何关“利竞之俗”乎？
    又云：“道在无欲，而以有欲要之。俯仰之间，非利不动。”何诬佛之深哉！夫佛家大趣，自以八苦皆由欲来，明言十二因缘，使高妙之流，朗神明于无生耳。欲此道者，可谓有欲于无欲矣。至于启导粗近，天堂、地狱，皆有影响之实。亦由于公以仁活招封，严氏以好杀致诛。畏诛而欲封者，必舍杀而修仁矣。励妙行以希天堂，谨五戒以远地狱，虽有欲于可欲，实践日损之清途，此亦西行而求郢，何患其不至哉！
    又嫌“丹青眩媚彩之目，土木夸好壮之心；成私树之权，结师党之势；要厉精之誉，肆凌竞之志。”固黑蝗之丑，或可谓作法于凉，其弊犹贪耳。何得乃慢佛云“作法于贪”耶？王莽窃《六经》以篡帝位，秦皇因朝觐而构阿房，宁可复罪先王之礼教哉？
    又云：“宜废显晦之迹，存其所要之旨。示来生者，蔽亏于道，释不得已。请问其旨，为欲何要？必欲使修利迁善，以遂其性矣。”夫圣无常心，就万物以为心耳。若身死神灭，是物之真性，但当即其必灭之性，与周、孔并力致教，使物无禀，则迁善之实岂不纯乎？何诳以不灭，欺以佛理，使烧祝发肤，绝其牉合，所遏苗裔，数不可量。为害若是，以伤尽性之美，释氏何为其不得已乎！若不信之流，亦不肯修利而迁善矣。夫信者，则必耆域、揵陀勒、夷陀蜜、竺法乘、帛法祖、竺法护、于法兰、竺法行、于道邃、阙公则、佛图澄、尸梨蜜、郭文举、释道安、支道林、远和尚之伦矣，神理风操，似殊不在琳比丘之后。宁当妄有毁人理，落簪于不实人之化哉？皆灵奇之实，引绵邈之心，以成神通清真之业耳。
    足下藉其不信，远送此论，且世之疑者，咸亦妙之。故自力白，答以尘露众情。夫世之然否佛法，都是人兴丧所大，何得相与共处以可否之间？吾故罄其愚思，制《明佛论》，以自献所怀。始成，已令人书写，不及此信。晚更遣信，可闻当付往也。宗炳白。

释《均善》难

    何承天前送《均善论》〖即《白黑论》〗，并咨求雅旨。来答周至，及以为：“兹理兴丧宜明，不可但处以可否之间。”吾虽不能一切依附，亦不甚执偏见，但求夜光于巨海，正自未得耳。
    以为佛经者，善九流之别家，杂以道、墨，慈悲爱施，与中国不异，大人君子仁为己任，心无意必。且以形像彩饰，将谐常人耳目，其为糜损尚微，其所弘益或著。是以兼而存之。至于好事者，遂以为超孔越老，唯此为贵，斯未能求立言之本，而眩惑于末说者也。知其言者，当俟忘言之人。若唯取信天堂、地狱之应，因缘不灭之验，抑情菲食，尽勤礼拜。庶几荫宝积之盖，升弥灯之坐。淳于生所以大谑也。
    论云：众圣、老、庄皆云有神明，复何以断其不如佛言？
    答曰：明有礼乐，幽有鬼神，圣王所以为教，初不昧其有也。若果有来生报应，周、孔宁当缄默而无片言耶？若夫婴儿之临坑，凡人为之骇怛，圣者岂独不仁哉？
    又云：人形至粗，人神实妙。以形从神，岂得齐终？
    答曰：形神相资，古人譬以薪火，薪弊火微，薪尽火灭，虽有其妙，岂能独传？
    又云：心之所感，崩城陨霜，白虹贯日，太白入昴。气禁之医，冷暖辄应。专诚妙感以受身，更生七宝之土，何为不可哉？
    答曰：崩城陨霜，贯日入昴，不明来生之譬，非今论所宜引也。又见水火之禁，冀其能生七宝之乡，犹观大冶销金，冀其能自陶铸，终不能亦可知也。
    又曰：有谛、无谛，此唱居然甚安。自古千变万化之有，俄然皆已空矣。当其盛有之时，岂不常有必空之实？愚者不知其理，唯见其有。
    答曰：如论云：“当其盛有之时，已有必空之实。”然则即物常空，空、物为一矣。今空、有未殊，而贤、愚异称，何哉？昔之所谓道者，于形为无形，于事为无事，恬漠冲粹，养智怡神。岂独爱欲未除，宿缘是畏？唯见其有，岂复是过？以此嗤齐侯，犹五十步笑百步耳。
    又云：舟壑潜谢，佛经所谓“现在不住”。诚能明之，则物我常虚。
    答曰：潜谢不住，岂非自生入死、自有入无之谓乎？故其言曰：“有骇形而无损心，有旦宅而无愤死。”贾生亦云：“化为异物，又何足患。”此达乎死生之变者也。而区区去就，在生虑死，心系无量，志生天堂。吾党之常虚，异于是焉。
    又云：神光灵变，及无量之寿，皆由诚信幽奇，故映其明。今没于邪见，理固天隔。
    答曰：今亦不从慢化者求其光明，但求之于诚信者耳。寻释迦之教，以善权救物，若果应验若斯，何为不见其灵变，以晓邪见之徒？岂独不爱数十百万之说，而吝俄顷神光？徒为化声之辩，竟无明于真智，终年疲役，而不知所归，岂不哀哉！
    又云：内怀虔仰，故礼拜悔罪。达夫无常，故情无所吝。委妻子而为施，岂有邀于百倍？
    答曰：繁巧以兴事，未若除贪欲而息竞。遵戒以洗悔，未若剪荣冀以全朴。况乃诱所尚以祈利，忘天属以要誉。谓之无邀，吾不信也。
    又云：泥洹以无乐为乐，法身以无身为身。若诚能餐仰，则耽逸稍除，获利于无利矣。
    答曰：泥洹以离苦为乐，法身以接善为身，所以使餐仰之徒不能自绝耳。果归于无利，勤者何获？而云获于无利耶？此乃形神俱尽之证，恐非雅论所应明言也。
    又云：欲此道者，可谓有欲于无欲矣。至若启导粗近者，有影响之实。亦犹于公以仁活致封，严氏以好杀致诛。励妙行以希天堂，谨五戒以远地狱。虽有欲于可欲，实践日损之途，此亦西行而求郢，何患其不至。
    答曰：谓粗近为启导，比报应于影响，不亦善乎！但影、响所因，必称形、声。寻常之形，安得八万由旬之影乎？所滞若有欲于无欲，犹是常滞于所欲。夫耳目殊司，工艺异业。末伎所存，虑犹不并。是以金石克谐，泰山不能呈其高；鸿鹄方集，冥秋不能传其旨。而欲以有欲成无欲，希望就日损。虽云西行，去郢兹远，如之何？
    又云：若身死神灭，是物之真性，但当与周、孔并力致教。何为诳以不灭，欺以佛理，使烧祝发肤，绝其牉合，以伤尽性之美？
    答曰：华、戎自有不同。何者？中国之人，禀气清和，含仁抱义，故周、孔明性习之教。外国之徒，受性刚强，贪欲忿戾，故释氏严五戒之科。来论所谓圣无常心，就物之性者也。惩暴之戒，莫苦乎地狱。诱善之劝，莫美乎天堂。将尽残害之根，非中庸之谓。周、孔则不然，顺其天性，去其甚泰。淫盗著于五刑，酒辜明乎《周诰》；春田不围泽，见生不忍死；五犯三驱，钓而不纲；是以仁爱普洽，泽及豚鱼。嘉礼有常俎，老者得食肉；春耕秋收，蚕织以时；三灵格思，百神咸袟。方彼之所为者，岂不弘哉！又甄供灌之赏，严疑法之罚；述蒲宰之问，为劝化之本；演焄蒿之答，明来生之验。袨服盱衡而矜斯说者，其处心亦悍矣。
    论又称：“耆、陀、尸梨之属，神理风操，不在琳比丘后。”足下既明常人不能料度近事，今何以了其胜否于百年之前、数千里之外耶？若琳比丘者，僧貌而天虚，似夫深识真伪，殊不肯忌经护师，崇饰巧说。吾以是敬之。孙兴公论云：“竺法护之渊达，于法兰之纯博。”足下欲比中土何士也？及楚英之修仁寺，笮融之赒行馑，宁复有清真风操乎？
    昔在东邑，有道含沙门，自吴中来，深见劝譬，甚有恳诚。因留三宿，相为说练形澄神之缘，罪福起灭之验，皆有条贯。吾拱听谠言，申旦忘寝。退以为士所以立身扬名、著信行道者，实赖周、孔之教。子路称：“闻之而未之能行，唯恐有闻。”吾所行者多矣，何遽舍此而务彼？又寻“称情立文”之制，知来生之为奢。究终身不已之哀，悟受形之难再。圣人我师，周、孔岂欺我哉？
    缘足下情笃，故具陈始末。想耆旧大智，诲人不倦，于此未默耳。前已遣取《明佛论》，迟寻至，冀或朗然于心。何承天白。

答何衡阳难《释白黑论》

    敬览来论，抑裁佛化，毕志儒业。意义检著，才笔辩核。善可以警策世情，实中区之美谈也。
    观足下意，非谓制佛法者非圣也，但其法权而无实耳。未审竟何以了其无实？今相与断现事大计，失得略半也。灵化超于玄极之表，其故纠结于幽冥之中，曾无神人指掌相语，徒信史之阙文于焚烧之后，便欲以废顿神化，相助寒心也。
    夫圣人穷理尽性，以至于命；物有不得其所，若己纳之于隍。今诳以不灭，欺以成佛，使髡首赭衣，焚身燃指，不复用天分以养父母、夫妇、父子之道。从佛法已来，沙河以西三十六国，未暨中华，绝此绪者，亿兆人矣。东夷、西羌，或可圣贤，及由金日磾得来之类，将生而不得生者多矣。若使佛法无实，纳隍之酷，岂可胜言！及经之权为合何道，而云欲以矫诳过正，以治外国刚强忿戾之民乎？夫忿戾之类，约法三章，交赏见罚，尚不信惧。宁当复以即色本无、泥洹法身、十二因缘、微尘劫数之言以治之乎？禀此训者，皆足下所谓“禀气清和、怀仁抱义”之徒也。资清和以疏微言，励义性以习妙行，故遂能澄照观法，法照俱空，而至于道。皆佛经所载，而足下所信矣。
    至若近世通神令德，若孙兴公所赞“八贤”，支道林所颂“五哲”，皆时所共高，故二子得以缀笔。复何得其谓妄语乎？孙称：“竺法护之渊达，于法兰之淳博，吾不关雅俗，不知当比何士。”然法兰弟子道邃，未逮其师。孙论之：“时以对胜流，云谓庾文秉也。”是护、兰二公，当又出之。吾都不识琳比丘，又不悉世论。若足下谓与文秉等者，自可不后道邃，犹当后护、兰也。前评未为失言。诚能“僧貌天虚，深识真伪”，何必非天帝释化作，故激励以成佛耶？《白黑论》未可以为诚实也。
    来告所疑：“若实有来生报应，周、孔何故默无片言？”此固偏见之恒疑也，真宜所共明。夫圣神玄发，感而后应，非先物而唱者也。当商、周之季，民坠涂炭，杀逆横流，举世情而感圣者，乱也。故《六经》之应，治而已矣，是以无佛言焉。刘向称《禹贡》九州，盖述《山海》所记：“申毒之民，偎人而爱人。”郭璞谓之：“天竺，浮屠所兴。”虽此之所夷，然万土星陈于太虚，竟知孰为华哉？推其“偎爱”之感，故浮屠之化应焉。彼之粗者，杂有乱虐，君臣不治。此之精者，随时抱道，佛事亦存。虽可有禀法性于伊洛，餐真际于洙泗。苟史佚以非治道而不书，卜商以皆儒术而弗编。纵复或存于复壁之外典，复为秦王所烧。周、孔之无言，未必审也。夫玄虚之道，灵仙之事，世典未尝无之。而夫子道言远，见庄周之篇。瑶池之宴，乃从汲冢中出。然则治之《五经》，未可以塞天表之奇化也。
    难又曰：“若即物常空，空、物为一。空、有未殊，何得贤、愚异称？”夫佛经所称即色为空，无复异者，非谓无有，有而空耳。有也，则贤、愚异称；空也，则万异俱空。夫色不自色，虽色而空；缘合而有，本自无有。皆如幻之所作，梦之所见，虽有非有。将来未至，过去已灭，现在不住，又无定有。凡此数义，皆玄圣致极之理。以言斥之，诚难朗然。由此观物我，亦实觉其昭然，所以旷焉增洗汰之清也。足下当何能安之？
    又云：“形神相资，古人譬之薪火，薪弊火微，薪尽火灭，虽有其妙，岂能独存？”夫火者薪之所生，神非形之所作。意有精粗，感而得形随之。精神极则超形独存。无形而神存，法身常住之谓也。是以始自凡夫，终则如来，虽一生尚粗，苟有识向，万劫不没，必习以清升。螟蛉有子，蜾臝负之。况在神明理，荫宝积之盖，升灯王之座，何为无期？
    又疑：“释迦以善权救物，岂独不爱数十百万之说，而吝俄顷神光，不以晓邪见之徒？”夫虽云善权，感应显昧，各依罪福。昔佛为众说，又放光明，皆素积妙诚，故得神游。若时言成，已著之筌，故慢者可睹。光明发由观照，邪见无缘瞻洒。今睹经而不悛其慢，先洒夫复何益？若诚信之贤，独朗神照，足下复何由知之？而言者，会复谓是妄说耳。恒星不现夜明也，考其年月，即佛生放光之夜也。管幼安，风夜泛海，同侣皆没。安于暗中见光，投光赴岛，阖门独济。夫佛无适莫，唯善是应。而致应若王祥、郭巨之类，不可称说，即亦见光之符也。岂足下未见，便无佛哉？
    又陈周、孔之盛，唯方佛为弘。然此国治世君王之盛耳。但精神无灭，冥运而已，一生瞬息之中，八苦备有，虽克儒业，以整俄顷，而未几已灭。三监之难，父子相疑，兄弟相戮。七十二子，虽复升堂入室，年五十者曾无数人。颜夭冉疾，由醢予族，赐灭其须。匡、陈之苦，岂可胜言？忍饥弘道，诸国乱流，竟何所救！以佛法观之，唯见其哀。岂非世物宿缘所萃耶？若所被之实理，于斯犹未为深弘。若使外率礼乐，内修无生，澄神于泥洹之境，以亿劫为当年，岂不诚弘哉！事不传后，理未可知。幸勿据粗迹，而云“周、孔则不然”也。
    人皆谓佛妄语。《山海经》说死而更生者甚众。昆仑之山，广都之野，轩辕之丘，不死之国，气不寒暑，凤卵是食，甘露是饮，荫玕琪之树，歃朱泉之水，人皆数千岁不死。及化为黄能，入于羽渊，申生、伯有之类，丘明所说亦不少矣。皆可推此之粗，以信彼之精者也。
    承昔有道，闻佛法而敛衽者，必不啻作蒲城之死士可知矣。当由所闻者未高故耶？足下所闻者高，于今犹可豹变也。人是精神物，但使归信灵极，粗禀教戒。纵复微薄，亦足为感，感则弥升。岂非脱或不灭之良计耶？昔不灭之实，事如佛言。而神背心毁，自逆幽司，安知今生之苦毒者，非往生之故尔耶？轻以独见，傲尊神之训，恐或自贻伊阻也。佛经说释迦文昔为小乘比丘，而毁大乘，犹为此备苦地狱，经历劫数。况都不信者耶？复何以断此经必虚乎？
    足下所诘前书中语，为因琳道人章句耳。其意既已粗达，不能复一二辩答。所制《明佛论》，已事事有通，今付往。足下力为善寻，具告中否？老将死，以此续其尽耳。此书至，便倚索答，殊不密悉。宗炳白。

何重答宗

    重告并省大论，置阵如项籍，既足以贱汉祖，况弱士乎！证譬坚明，文词渊富，诚欲广其利释，施及凡民，深知君子之用心也。足下方欲影响，以神其教。故宜缄默，成人之美。但常谓外国之事，或非中华所务，是以有前言耳。果今中外宜同，余则陋矣，敢谢不敏。虽然，犹有所怀。夫明天地性者，不致惑于迂怪。识盛衰之径者，不役心于理表。傥令雅论不因善权笃诲，皆由情发，岂非通人之蔽哉？未缘言对，聊以代面。何承天白。

〖录自《弘明集》卷第三〗


与子侄书 (雷次宗)

与子侄书

［刘宋］雷次宗撰

    夫生之修短，咸有定分。定分之外，不可以智力求。但当于所禀之中，顺而勿害耳。
    吾少婴羸患，事钟养疾。为性好闲，志栖物表，故虽在童稚之年，已怀远迹之意。暨于弱冠，遂托业庐山，逮事释和尚，于时师友渊源，务训弘道。外慕等夷，内怀悱发，于是洗气神明，玩心坟典，勉志勤躬，夜以继日。爰有山水之好，悟言之欢，实足以通理辅性，成夫亹亹之业。乐以忘忧，不知朝日之晏矣。
    自游道餐风，二十余载。渊匠既倾，良朋凋索。续以衅逆违天，备尝荼蓼。畴昔诚愿，顿尽一朝。心虑荒散，情意衰损，故遂与汝曹归耕垄畔。山居谷饮，人理久绝。日月不处，忽复十年。犬马之齿，已逾知命。崦嵫将迫，前途几何？实远想尚子五岳之举，近谢居室琐琐之勤。及今耄未至昏，衰不及顿，尚可厉志于所期，纵心于所托。栖诚来生之津梁，专气暮年之摄养。玩岁日于良辰，偷余乐于将除。在心所期，尽于此矣。
    汝等年各成长，冠娶已毕，修惜衡泌，吾复何忧？但顾守全所志，以保令终耳。自今以往，家事大小，一勿见关。子平之言，可以为法。

〖录自《宋书·列传第五十三·隐逸传》〗


无量寿颂 (谢灵运)

无量寿颂

［刘宋］谢灵运撰

法藏长王宫，怀道出国城，
愿言四十八，弘誓拯群生。
净土一何妙，来者皆清英，
颓年欲安寄，乘化必晨征。

（校注：本诗见于唐飞锡《念佛三昧宝王论》，并收于
南宋宗晓《乐邦文类》卷五，均题名“净土咏”。）

〖录自《广弘明集》卷第十五〗


佛影铭 (谢灵运)

佛 影 铭

［刘宋］谢灵运撰

    夫大慈弘物，因感而接。接物之缘，端绪不一。难以形检，易以理测，故已备载经传，具著记论矣。虽舟壑缅谢，像法犹在，感运钦风，日月弥深。法显道人，至自祇洹，具说佛影偏为灵奇。幽岩嵌壁，若有存形。容仪端庄，相好具足。莫知始终，常自湛然。庐山法师，闻风而悦，于是随喜幽室，即考空岩，北枕峻岭，南映滮涧，摹拟遗量，寄托青彩。岂唯像形也笃故，亦传心者极矣。道秉道人，远宣意旨，命余制铭，以充刊刻。石铭所始，寔由功被。未有道宗崇大，若此之比。岂浅思肤学所能宣述？事经徂谢，永眷罔已，辄磬竭劣薄，以诺心许。徽猷秘奥，万不写一。庶推诚心，颇感群物。飞鸮有革音之期，阐提获自拔之路。当相寻于净土，解颜于道场。圣不我欺，致果必报。援笔兴言，情百其慨！

群生因染，六趣牵缠。七识迭用，九居屡迁。
剧哉五阴，倦矣四缘。遍使轮转，苦根迍邅。
迍邅未已，轮转在己。四缘云薄，五阴火起。
亹亹正觉，是极是理。动不伤寂，行不乖止。
晓尔长梦，贞尔沉诐。以我神明，成尔灵智。
我无自我，实承其义。尔无自尔，必祛其伪。
伪既殊途，义故多端。因声成韵，即色开颜。
望影知易，寻响非难。形声之外，复有可观。
观远表相，就近暧景。匪质匪空，莫测莫领。
倚岩辉林，傍潭鉴井。借空传翠，激光发冏。
金好冥漠，白毫幽暧。日月居诸，胡宁斯慨！
曾是望僧，拥诚俟对。承风遗则，旷若有概。
敬图遗踪，疏凿峻峰。周流步栏，窈窕房栊。
激波映墀，引月入窗。云往拂山，风来过松。
地势既美，像形亦笃。彩淡浮色，群视沉觉。
若灭若无，在摹在学。由其洁精，能感灵独。
诚之云孚，惠亦孔续。嗟尔怀道，慎勿中惕。
弱丧之推，阐提之役。反路今睹，发蒙兹觌。
式厉厥心，时逝流易。敢铭灵宇，敬告振锡！

〖录自《广弘明集》卷第十五〗


庐山慧远法师诔 (谢灵运)

庐山慧远法师诔

［刘宋］谢灵运撰

    道存一致，故异代同晖。德合理妙，故殊方齐致。昔释安公振玄风于关右，法师嗣沫流于江左，闻风而悦，四海同归。尔乃怀仁山林，隐居求志。于是众僧云集，勤修净行，同法餐风，栖迟道门。可谓五百之季，仰绍舍卫之风；庐山之嵔，俯传灵鹫之音，洋洋乎未曾闻也！予志学之年，希门人之末，惜哉诚愿弗遂，永违此世。春秋八十有四，义熙十三年秋八月六日薨。年逾纵心，功遂身亡。有始斯终，千载垂光。呜呼哀哉！乃为诔曰：

于昔安公，道风允被。大法将尽，颓纲是寄。
体静息动，怀真整伪。事师以孝，养徒以义。
仰弘如来，宣扬法雨。俯授法师，威仪允举。
学不窥牖，鉴不出户。粳粮虽御，独为苌楚。
朗朗高堂，肃肃法庭。既严既静，愈高愈清。
从容音旨，优游仪形。广演慈悲，饶益众生。
堂堂其器，亹亹其资。总角味道，辞亲随师。
供养三宝，析微辩疑。盛化济济，仁德怡怡。
于焉问道，四海承风。有心载驰，戒德鞠躬。
令声续振，五浊暂隆。弘道赞扬，弥虚弥冲。
十六王子，孺童先觉。公之出家，年未志学。
如彼邓林，甘露润泽。如彼琼瑶，既磨既琢。
大宗戾止，座众龙集。聿来胥宇，灵寺奚立。
旧望研机，新学时习。公之勖之，载和载辑。
乃修什公，宗望交泰。乃延禅众，亲承三昧。
众美合流，可久可大。穆穆道德，超于利害。
六合俱否，山崩海竭。日月沉辉，三光寝晰。
众麓摧柯，连波中结。鸿化垂绪，徽风永灭。
呜呼哀哉！
生尽冲素，死增伤凄。单絷土椁，示同敛骸。
人天感悴，帝释恸怀。习习遗风，依依余凄。
悲夫法师，终然是栖。室无停响，除有广蹊。
呜呼哀哉！
端木丧尼，哀直六年。仰慕洙泗，俯惮罤筌。
今子门徒，实同斯艰。晨扫虚房，夕泣空山。
呜呼法师，何时复还！
风啸竹柏，云蔼岩峰。川壑如泣，山林改容。
自昔闻风，志愿归依。山川路邈，心往形违。
始终衔恨，宿缘轻微。安养有寄，阎浮无希。
呜呼哀哉！

〖录自《广弘明集》卷第二十三〗


东林十八高贤传

［南宋］志磐法师增修

慧远法师

    法师慧远，姓贾氏，雁门楼烦人。幼而好学，年十三，随舅令狐氏，游学许、洛。博综《六经》，尤善《庄》《老》。宿儒先进，莫不服其深致。二十一，欲渡江从学范宁，适石虎暴死，南路梗塞，有志不遂。
    时沙门释道安，建刹于太行常山。一面尽敬，以为真吾师也。初闻安师讲《般若经》，豁然开悟，叹曰：“九流异议，皆糠秕耳！”遂与母弟慧持，投簪受业。精思讽诵，以夜继昼，因求直道场。沙门昙翼，每给灯烛之费。安师闻之曰：“道士诚知人。”师神明英越，志与理冥。至二十四，大善讲贯。有客闻说实相义，往复问难，弥增疑昧。师为引庄子之说以相比类，惑者释然。安师因许令不废外典，常临众叹曰：“使道流东国者，其在远乎！”后随安师南游襄阳，值秦将苻丕为寇。乃分张徒属，各随所往。耆德临岐，皆蒙诲益，唯师不闻一言，即跪请曰：“独无训敕，惧非人类。”安师曰：“如汝者，复何所虑！”
    师乃与弟子数十人，南适荆州，居上明寺。念旧与同门慧永，约结屋于罗浮。太元六年（晋孝武帝）至浔阳，见庐山闲旷，可以息心，乃立精舍。以去水犹远，举杖扣地曰：“若此可居，当使朽壤抽泉。”言毕，清流涌出。浔阳亢旱，师诣池侧，读《海龙王经》，忽见神蛇从池而出，须臾大雨，岁竟有秋，因名“龙泉精舍”。永师先居庐山西林，欲邀同止，而师学侣寖众。永乃谓刺史桓伊曰：“远公方当弘道，而贫道所栖，隘不可处。”时师梦山神告曰：“此山足可栖神，愿毋他往。”其夕大雨雷震。诘旦，林麓广辟，素沙布地，楩、楠、文梓充布地上，不知所自至。伊大敬感，乃为建刹，名其殿曰“神运”。以在永师舍东，故号“东林”，时太元十一年也。此山仪形九叠，峻耸天绝，而所居尽林壑之美。背负炉峰，旁带瀑布，清流环阶，白云生栋。（《庐山记》：“匡裕先生，殷周之际受道于仙人，即岩成馆，人称‘神仙之庐’，因名‘庐山’。”《浔阳记》：“山高三千三百六十丈，周二百五十里，其山九叠，水亦九派。”《郡国志》：“叠障九层，包藏仙迹。”）别营禅室，最居静深。凡在瞻履，神清气肃。
    师闻天竺佛影，是佛昔化毒龙瑞迹，欣感于怀。后因耶舍律士叙述光相，乃背山临流，营筑龛室，淡彩图写，望如烟雾。复制五铭，刻于石。江州太守孟怀玉、别驾王乔之、常侍张野、晋安太守殷隐、黄门毛修之、主簿殷蔚、参军王穆夜、孝廉范悦之、隐士宗炳等，咸赋铭赞（见《庐山集》）。
    先是浔阳陶侃刺广州，渔人见海中有神光，网之得金像文殊，志云“阿育王所造”。后商人于海东获一圆光，持以就像，若弥缝然。侃以送武昌寒溪。主僧僧珍，常往夏口，夜梦寺火，而此像室独有神护。驰还，寺果焚，像室果存。及侃督江州，迎像将还，至舟而溺。荆楚为之谣曰：“陶唯剑雄，像以神标。云翔泥宿，邈何遥遥。可以诚至，难以力招。”及寺成，师至江上，虔祷之，像忽浮出。遂迎至神运殿，造重阁以奉之，因制《文殊瑞像赞》。
    尝谓：“诸教三昧，其名甚众。功高易进，念佛为先。”既而谨律息心之士，绝尘清信之宾，不期而至者，慧永（同师安公，先居西林）、慧持（远师同母弟）、道生、昙顺（并罗什门弟）、僧睿〖校注：应为慧睿，见后注〗、昙恒、道昞、昙诜、道敬（并远师门人）、佛驮耶舍（此云“觉明”，罽宾国人）、佛驮跋陀罗（此云“觉贤”，迦维卫国人）、名儒刘程之（号遗民）、张野、周续之、张诠、宗炳、雷次宗等，结社念佛，世号十八贤。复率众至百二十三人，同修净土之业。造西方三圣像，建斋立誓，令刘遗民著《发愿文》。而王乔之等，复为《念佛三昧诗》以见志。
    师神貌严肃，瞻仰者则心战。沙门有持如意致献者，不敢陈白，窃留座隅而去。法师慧义，强正少可，谓师弟子慧宝曰：“诸君肤浅，故于远公望风推服。”尝至山，值师讲《法华》，欲致难，辄内悸流汗。出谓慧宝曰：“此公言貌，诚可敬服。”殷仲堪任荆州，入山展敬，与师俱临北涧松下，共谈《易》道，终日忘倦。仲堪叹曰：“师智识深明，实难庶几。”师亦曰：“君之才辩，如此流泉。”（后人名其处曰“聪明泉”。）司徒王谧、护军王默，并钦慕风德，遥致敬礼（王谧有书往反）。
    卢循据江州，入山诣师。师少与循父遐，同为书生，及见循，欢然道旧。其徒谏曰：“循为国寇，得不为人疑？”师曰：“我佛法中，情无取舍。识者自能察之，此何足惧。”及宋武进讨循，设帐桑尾，左右曰：“远公素王庐山，与循交厚。”宋武曰：“远公世表之人，何可疑也。”乃遣使驰书，遗以钱帛。
    有行者来侍师，善驱蛇，蛇为尽去，因号“辟蛇行者”。有一虎往来，时见行迹，未尝伤人，人号“游山虎”。师与社众，每游憩上方峰顶，患去水远。他日有虎跑其石，水为之出，因号“虎跑泉”。又于一峰制《涅槃疏》，因名“掷笔峰”。
    初是大教流行江东，经卷未备，禅法无闻，律藏多阙。师乃令弟子法净、法领等，远越葱岭，旷岁来还，皆获梵本。昔安公在关中，请昙摩难提，出《阿毗昙心论》。其人未善晋言，颇多疑滞。后僧伽提婆至，即请重译，及《三法度论》。于是二论乃兴，师即制序，以贻学者。闻鸠摩罗什入关，遣书通好。什答书曰：“传绎来贶，粗闻风德。经言：‘末代东方有护法菩萨。’钦哉仁者，善弘其道。”昙摩流支入秦，师遣弟子昙邕，请于关中出《十诵律》，流传晋国。西土诸僧，咸称汉地有大乘开士，每东向致礼，献心庐岳。及佛驮跋陀罗至，师即请出禅数诸经，于是禅戒典出自庐山，几至百卷。先是此土未有“泥洹常住”之说，但言寿命长远。师曰：“佛是至极，至极则无变。无变之理，岂有穷耶？”乃著《法性论》十四篇。罗什见而叹曰：“边方未见经，便暗与理合。”秦主钦风，以《大智度论》新译，致书求序。师以其文繁广，乃抄其要为二十卷，而为之序（罗什译《智论》凡百卷）。
    桓玄征殷仲堪，要师出虎溪，称疾不往。玄将入山，左右曰：“昔殷仲堪礼敬于远，请公勿屈。”玄曰：“仲堪死人耳。”及玄见师，不觉屈膝，所怀问难，不复敢发。及语至征讨，师即不答。玄后以震主之威，劝令登仕。师正辞以答，玄不能强。既而欲沙汰众僧，下教僚属曰：“沙门之徒，有能申述经诰、禁行修整者，始可以宣寄大化。其有违于此者，悉当罢黜。唯庐山道德所居，不在搜简之列。”师因致书，广立条制。玄悉从之。
    初庾冰辅政，以沙门应敬王者；何充奏不应礼。及玄在姑熟，复申冰议。师答书曰：“袈裟非朝宗之服，钵盂非廊庙之器，尘外之客，不应致敬王者。”乃著《沙门不敬王者论》五篇：一、明在家者有天属之爱，奉主之礼。二、明出家以求志，变俗以达道，岂得与世典同其礼敬。三、明求宗不顺化。“宗”谓泥洹不变，以化尽为宅（“泥洹”即“涅槃”，翻“不生不灭”）。“不顺化”者，其生可灭，其神可冥。冥神绝境，谓之泥洹。而不随顺于生生化化、流动无穷之境。斯所以不事王侯，高尚其事，岂复有所礼敬者哉。四、明体极不兼应。谓历代君王，体极之主，但务方内，而不可并御于方外，故曰“不兼应”。天地之道，功尽于运化。帝王之德，理极于顺通。与夫独绝之教，不变之宗，优劣明矣。若夫如来之道，则无所不应矣。五、明形尽神不灭。谓火之传于薪，犹神之传于形。火之传异薪，犹神之传异形。方生方死，往来无穷。但悟彻者反本，惑理者逐物耳。有顷，玄纂位，即下书曰：“佛法宏诞，所未能了。初推奉主之情，故令兴敬。今事既在己，宜尽谦光。诸道人勿复致礼也。”桓玄西奔，安帝自江陵还京师。辅国何无忌劝师候迎，师称疾不行。帝遣使劳问，师上书谢病，帝复下诏慰答。
    师尝讲《丧服经》（当是《礼记》“小记”、“大记”、“四制”等篇），雷次宗、宗炳等，并执卷承旨。次宗后著《义疏》，首称“雷氏”。宗炳寄书责之曰：“昔与足下，面受于释和尚，今便称雷氏耶？”（陆德明《毛诗音义》云：“周续之与雷次宗，同受《诗》义于远法师。”亦此类也。）
    释惠要，患山中无刻漏，乃于水上立十二叶芙蓉，因波随转，分定昼夜，以为行道之节，谓之“莲花漏”。僧澈善篇牍，尝至山南攀松而啸，和风远集，众鸟悲鸣，超然有自得之趣。退咨于师曰：“律禁管弦歌舞。若一吟一笑，可得为乎？”师曰：“苟以乱意，皆为非法。”澈唯而止。
    师居山三十年，迹不入俗，唯以净土克勤于念。初十一年，澄心系想，三睹圣相，沉厚不言。后十九年，七月晦夕，于般若台之东龛，方从定起。见阿弥陀佛，身满虚空，圆光之中，有诸化佛。观音、势至，左右侍立。又见水流光明，分十四支，流注上下，演说苦、空、无常、无我之音。佛告之曰：“我以本愿力故，来安慰汝。汝后七日，当生我国。”又见佛驮耶舍、慧持（义熙八年先逝）、慧永（义熙十年先逝）、刘遗民（义熙六年先逝），在佛之侧，前揖师曰：“师志在先，何来之晚！”师语法净、惠宝曰：“吾始居此，十一年中，三见佛相。今复见之，吾生净土必矣。”又曰：“七日之期，斯为渐矣。”即寝疾，制遗诫曰：“吾昔以知命之年，托业此山，自审有必尽之期，便欲绝迹外缘，以求其志。良由性弱于断，遂令同趣相引，时贤过眷，情以类感，不觉形与运颓，今年已八十三矣。仰寻远离之诲，俯慨自负之心，徒令此生虚谢，以悼往疾之深。今于至时，露骸松林之下，即岭为坟，与土木同状。此乃古人之礼，汝等勿违。苟神理不昧，庶达其诚。大哀世尊，亦当祐之以道。”门徒号恸，若丧父母。师以世情难割，乃制七日展哀。至期始顺寂，即义熙十二年八月六日也。弟子不忍露尸，与浔阳太守阮侃，奉全躯举葬于西岭，累石为塔。谢灵运立碑，以铭遗德。张野作序，自称门人。宗炳复立碑于寺门，以表德业。
    师将终，耆德请以豉酒治病，师曰：“律无通文。”请饮米汁，师曰：“日过中矣。”又请食蜜和水，乃令披律寻文，卷未半而终。所著经论诸序、铭、赞、诗、记凡十卷，号《庐山集》（刻梓在越府）。自佛图澄、道安师、远法师、昙顺、僧睿五世为国师云。唐宣宗大中二年，追谥“辩觉大师”。升元三年（南唐李先主年号，即晋高祖天福四年也），追谥“正觉”。大宋太宗太平兴国三年，追谥“圆悟大师凝寂之塔”。

慧永法师

    西林法师慧永，河内潘氏。年十二出家，事沙门竺昙现。初习禅于恒山，与远师同依安法师，期结宇罗浮。及远师为安公所留，师乃欲先度五岭。太元初，至浔阳。刺史陶范，素挹道风，乃留憩庐山，舍宅为西林，以奉师。布衣蔬食，精心克己。容常含笑，语不伤物。峰顶别立茅室，时往禅思。至其室者，常闻异香，因号“香谷”。一虎同居，人至，辄驱去。远师来之龙泉，桓伊为立东林，三十年影不出山。师居西林，亦如之。尝因法事至近邑，还山薄暮，乌桥营主醉，骑马当道，遮师不听去。师以杖指马，马惊走，荣主仆地。师捧慰之，遂还。营主病，往寺悔罪。师曰：“非贫道意。”为祷之，寻愈。镇南将军何无忌镇浔阳，至虎溪，请远公及师。远公持名望，从徒百余，高言华论，举止可观。师衲衣半胫，荷锡捉钵，松下飘然而至。无忌谓众曰：“永公清散之风，乃多于远师也。”师标诚植愿，动在安养。义熙十年在疾，忽敛衣求屣欲起。众惊问，师曰：“佛来也。”言终而化，异香七日方歇。葬于寺之西南。春秋八十三。唐玄宗朝，诏重建塔亭，追谥“觉寂大师实智之塔”。

慧持法师

    法师慧持，远公同母弟也。幼读书，一日所记，常敌十日。年十八，与兄同事安公，遍学众经，游刃三藏。及安公在襄阳，遣远公与师东下，遂止庐山。师形长八尺，衲衣垂膝。徒属三百，师为上首。豫章太守范宁，请师讲《法华经》、《阿毗昙论》，四方云聚。琅邪王珣，与范宁书，问远、持二公孰愈？宁曰：“诚谓贤兄贤弟。”珣复书曰：“但令如弟，诚未之有，况复贤耶。”罗什在关中，遥相钦敬，每致书通好。隆安三年，辞兄入蜀。远公留之曰：“人生爱聚，汝独乐离。”师曰：“滞情爱聚者，本不应出家。今既割欲求道，正以西方为期耳。”即怅然而别。至成都郫县，居龙渊寺，大弘佛法。升其堂者，号登龙门。义熙八年顺寂，春秋七十六。临终遗命，务严律仪，专心净业。以东间经籍付道泓，西间法典付昙兰。以泓行业清敏，兰神悟天发，并能系轨师踪焉。

道生法师

    法师道生，魏氏，钜鹿人。幼从竺法汰出家，披对经诰，一览能诵。年在志学，便登讲座，吐纳明辨，虽宿望莫敢酬抗。初依庐山。常以入道之要，慧解为本，乃与僧睿〖校注：应为慧睿，见《高僧传》〗、慧严、慧观等游学长安，从罗什受业。关中僧徒，咸仰神悟。尝喟然叹曰：“自经典东流，译人重阻，多滞权文，鲜通圆义。若忘筌得鱼，始可与言道矣。”于是校阅真俗，精练空有，研思因果，乃立“善不受报”及“顿悟成佛”义，又著《二谛论》、《佛性常有论》、《佛无净土论》、《应有缘论》，并笼罩旧说，妙有渊旨。守文之徒，嫌嫉竞起。师又以法显三藏所翻《泥洹经》本先至（六卷成文），经云：“除一阐提，皆有佛性。”师云：“夫禀质二仪，皆有涅槃正因。阐提含生之类，何得独无佛性？盖是经来未尽耳。”乃唱“阐提之人，皆得成佛”。时大本未传，孤明先发。旧学僧党，以为背经，遂显大众，摈而遣之。师正容誓之曰：“若我所说背经，当见身疠疾。若与实相不背，愿舍寿之日，踞狮子座。”遂拂衣而行。及后《大经》至，《圣行品》云：“一阐提人，虽复断善，犹有佛性。”于是诸师皆为愧服。师被摈南还，入虎丘山，聚石为徒，讲《涅槃经》。至阐提处，则说有佛性，且曰：“如我所说，契佛心否？”群石皆为点头。旬日学众云集。忽雷震青园佛殿，有龙升天，因改寺曰“龙光”。师于寺请罽宾律师译《弥沙塞律》，传于世。既而辞众，复投庐山，预莲社。久之还都，止青霞寺。宋文帝大会沙门，亲御地筵。食至良久，众疑过中。帝曰：“始可中耳。”生乃曰：“白日丽天，天言始中，何得非中？”遂举箸而食，一众从之，莫不叹其机辩。时王弘、范泰、颜延之，并挹敬风猷，相从问道。元嘉十一年十一月庚子，于庐山升座说法，将毕，众见麈尾纷然坠地，隐几而化，宛若入定。诸师闻之，益信前誓有证。翌日葬于庐山之西阜。初关中僧肇，始注《维摩诘经》，世咸玩味。师乃更发深旨，人服其妙。所述《维摩诘》、《法华》、《泥洹》、《小品》诸经，皆有义疏。时以师能推“阐提得佛”之义，于是显其“顿悟不受报”等论。

昙顺法师

    法师昙顺，黄龙人。幼出家，承训罗什。讲释群经，妙尽“色空无著”之旨。什叹曰：“此子奇器也。”后来庐山，同修净业。宁蛮校尉刘遵孝，于江陵立寺，要师经始，盛弘念佛三昧之道。宋元嘉二年，别众坐逝，异香满室。春秋七十九。

僧睿法师

    法师僧睿，冀州人。游学诸方，尝行经蜀西界，为人所掠，使牧羊。有商客异之，疑是沙门，及问以经义，无不综达，即出金赎之。后游历天竺诸国，还至关中，从罗什咨禀经义。罗什翻《法华经》，以竺法护本云：“天见人，人见天。”什曰：“此言过质耳。”睿曰：“将非‘人天交接，两得相见’？”什喜，遂用其文。久之来入庐山，依远公修净业。既而适京师，止乌衣寺。讲说众经，听者推服。宋彭城王义康，要入第受戒，师曰：“礼闻来学。”王乃入寺，祗奉戒法。王以貂裘奉师，常用敷坐。王密令以钱三万买之，师曰：“此虽非所宜服，然王之所施，不可弃也。”王闻益加敬。谢灵运笃好佛理，殊方俗音，多所通解。尝以经中字音，求证于师，因为著《十四音训》，梵、汉昭然。元嘉十六年，无疾，告众曰：“吾将行矣。”即面西合掌而亡。众见卧内一金莲华，倏尔而隐。春秋八十五。
    〖校注〗本传所载，除译《法华》及临终感应外，其余诸事及世寿等均为《高僧传》慧睿之事。又《高僧传》独记慧睿曾先入庐山，其后入关从什公咨禀，而无僧睿入庐山之记载；且《高僧传·竺道生传》中，同由庐山“游学长安，从罗什受业”者亦为慧睿。本文撰者乃将僧睿、慧睿误作一人。《净土圣贤录·僧睿传》言其：“入庐山，依远公修净业。后适京师，止乌衣寺。讲说众经，听者推服。”或即沿袭《佛祖统纪》中本传之讹。历考北宋熙宁五年（1072）陈舜俞所著《庐山记》，列名十八贤者为慧睿，而非僧睿；但称慧睿为晋时“四圣”之一，则已将二人混同。《卍续藏经》第135册《东林十八高贤传》后，载北宋元丰四年（1081）李冲元所作《莲社十八贤图记》，列名十八贤者为惠睿（即慧睿）。其后元代普度所撰《莲宗宝鉴》，卷四“庐山十八大贤名氏”中“睿法师”，亦注明为“慧睿”。因知列名庐山莲社十八贤者，仍以慧睿法师为确。但僧睿法师为罗什四大弟子之一，平生志愿求生西方，瑞迹尤为昭著。《高僧传·僧睿传》记其：“善摄威仪，弘赞经法，常回此诸业，愿生安养。每行住坐卧，不敢正背西方。”“后自知命尽，忽集众告别。”“于是入房洗浴，烧香礼拜，还床，向西方合掌而卒。是日，同寺咸见五色香烟，从睿房出。春秋六十七矣。”

昙恒法师

    法师昙恒，河东人。童孺依远公出家，年甫十三，便能讲说。内外典籍，无不通贯。德行清孤，物情推服。常有群鹿，驯绕座隅。自入庐山，专志净业。义熙十四年，端坐合掌，厉声念佛而化，春秋七十二。

道昞法师

    法师道昞，颖川人，陈氏。幼出家，为远公弟子。该通经律，兼明《庄》《老》。志节孤峻，言与行合。念佛三昧，究心无间。义熙十四年，豫章太守王虔，入山谒敬，请为山中主，用绍远公之席。众以道源法嗣，咸知宗仰。元嘉十二年，集众念佛，就座而化，春秋七十一。

昙诜法师

    法师昙诜，广陵人。幼从远公出家，勤修净业，兼善讲说。注《维摩经》，行于世。尝著《穷通论》，以明宿修。述《莲社录》，以记往生。又能别识鸟兽毛色俊钝之性，洞晓草木枝干甘苦之味，妙尽其理，人知其有密证云。元嘉十七年，集众谓曰：“自建寺以来，至此五十年。吾之西行，最在其后。”即跏趺念佛百声，闭息遂绝，春秋八十。

道敬法师

    法师道敬，琅邪王氏。祖凝之刺江州，遂从远公出家。年十七，博通经论，日记万言。每叹戒律终日难全，愿净六根，但禀一戒，以为得度之要。远公知其坚正，许之。笃志念佛，蚤夜弗替。远公归寂，乃入若耶山。宋永初元年，谓众曰：“先师见命，吾其行矣。”即端坐唱佛而化。众见光明满室，弥时方灭。春秋五十二。

佛驮耶舍尊者

    尊者佛驮耶舍（晋云“觉明”），罽宾国婆罗门种。有沙门至其家乞食，父本外道，怒殴之，遂手足挛躄。巫师谓曰：“坐犯贤圣。”即请此沙门悔过，旬日乃瘳。因令耶舍出家，时年十三。随师行旷野，与虎遇。耶舍曰：“虎已饱，必不伤人。”前行中道，果见余骸。年十五，诵经日至万言，以分卫废业为忧（梵语“分卫”，晋言“乞食”），一罗汉来代乞食。年十九，诵经满数百万言。性度简傲，不为诸人重，至三十犹为沙弥。复从舅氏学五明论、世间法术（内众、外道，皆有五明。内五明者：一声明、二医方明、三咒术明、四工巧明、五因明。外五明者：前四并同，后一是符印明）。至沙勒国，待遇隆厚。既而罗什至，乃从学《阿毗昙论》、《十诵律》。什随母反龟兹，师遂留止行化。符坚遣吕光伐龟兹，执罗什。师闻叹曰：“我与罗什未尽怀抱，今忽羁虏，相见何期？”后十年，师东至龟兹，盛弘法化。罗什在姑臧，遣信要之。师恐国人止其行，取清水，以药投之，咒数十言，与弟子洗足，即夜便发。比旦，行数百里，追之不及。问弟子：“何所觉耶？”答曰：“唯闻疾风流响，两目有泪。”师又咒水洗足，乃止。既达姑臧，什已入长安，闻姚主逼以妾媵，叹曰：“罗什如好绵纩，何可使入棘林！”罗什劝姚主遣使迎师，既至，别立省寺于逍遥园。四事供养，一无所受。时至分卫，一食而已。时罗什译出《十住经》，师更相征决，辞理方定。师髭赤，善解《毗婆沙论》，时人号“赤髭论主”。秦弘始中，译出《四分律》（四十四卷）、《长阿含经》（二十二卷）。义熙八年，来庐山入社。后辞还本国，自罽宾以《虚空藏经》一卷，寄商客至凉州。

佛驮跋陀罗尊者

    尊者佛驮跋陀罗（晋云“觉贤”），姓释迦，迦维罗卫国人，甘露饭王苗末也。幼亡父母，出家为沙弥。年十六，博学群经，深达禅、律。常与僧伽达多，共游罽宾。达多闭户禅坐，忽见师来云：“暂往兜率，致敬弥勒。”言讫便隐。后益见其神变，敬心祈问，方知得不还果。时姚秦沙门智严至罽宾，睹法众清净，慨然东顾曰：“我诸同辈，未遇真匠，将何发悟！”即咨询于众：“孰能遂我祈请，流化东土？”佥应之曰：“跋陀罗其人也。”严乃要师，裹粮而行。经历诸国，至交趾，附舶循海，达于青州东莱。闻鸠摩罗什在长安，即往从之。秦太子泓，请师于东宫，集众说法，与罗什论“色空”义。师曰：“汝只说得果中色空，不说得因中色空。”什问：“何谓？”师曰：“一微空故众微空，众微空故一微空。一微空中无众微，众微空中无一微。”往复数番，罗什罔测。秦主兴供僧三千，盛修人事，而师禅静自守。忽谓弟子曰：“吾见本国，五舶俱发。”众谓妄言，因共摈弃，乃与弟子慧严、慧观四十余人俱发，至庐山香谷，茇舍而居（茇，蒲曷切，草舍），时会莲社。远公谓师被摈，过由门人；悬记五舶，于律无犯。即遣弟子昙邕，致书秦主，为其解摈。乃请师东林译出禅数诸经，自是江东始耽禅悦。师志在游化，西适江陵。持钵分卫，果见天竺五舶至此。后还都，立道场寺。先是支法领于于阗得《华严》梵本三万六千偈，未经宣译。义熙十四年，吴郡内史孟顗、右卫将军褚叔度，请师为主译，与沙门法业、慧义、惠严、慧观等为笔授，译成六十卷。有二青衣，旦从池出，洒扫研墨。师先后译出《观佛三昧经》、《般泥洹经》、《修行方便论》，及法显所得《大僧祇律》，凡十五部。宋元嘉六年，念佛而化，塔于庐山北岭。

刘程之

    刘程之，字仲思，彭城人，汉楚元王之后。妙善《老》《庄》，旁通百氏。少孤，事母以孝闻。自负其才，不预时俗。初解褐为府参军。谢安、刘裕嘉其贤，相推荐，皆力辞。性好佛理，乃之庐山，倾心自托。远公曰：“官禄巍巍，欲何不为？”答曰：“君臣相疑，吾何为之！”刘裕以其不屈，乃旌其号曰“遗民”。及雷次宗、周续之、宗炳、张诠、毕颖之等同来庐山，远公谓曰：“诸君之来，岂宜忘净土之游乎！”程之乃镵石为誓文，以志其事（文见《庐山集》）。遂于西林涧北，别立禅坊，养志安贫。精研玄理，兼持禁戒。宗、张等咸叹仰之。尝贻书关中，与什、肇扬搉经义。著《念佛三昧诗》，以见专念坐禅之意。始涉半载，即于定中见佛光照地，皆作金色。居十五年，于正念佛中，见阿弥陀佛，玉豪光照，垂手慰接。程之曰：“安得如来为我摩顶，覆我以衣。”俄而佛为摩顶，引袈裟以披之。他日念佛，又见入七宝池，莲青白，其水湛湛。有人项有圆光，胸出卍字（“卍”字音“万”，是佛具万德之相），指池水曰：“八功德水，汝可饮之。”程之饮水甘美。及寤，犹觉异香发于毛孔。乃自慰曰：“吾净土之缘至矣。”复请僧转《法华经》近数百遍。后时庐阜诸僧毕集。程之对像焚香，再拜而祝曰：“我以释迦遗教，故知有阿弥陀佛，此香先当供养释迦牟尼如来，次供阿弥陀佛；复次供养《妙法华经》，所以得生净土，由此经功德。愿令一切有情，俱生净土。”即与众别，卧床上，面西合手气绝。敕子雍，积土为坟，勿用棺椁。时义熙六年也，春秋五十九。（《庐山集》载感应事迹甚详。）

张 野

    张野，字莱民，居浔阳柴桑，与渊明有婚姻契。野学兼华、梵，尤善属文。性孝友，田宅悉推与弟，一味之甘，与九族共。州举秀才、南中郎、府功曹、州治中，征拜散骑常侍，俱不就。入庐山依远公，与刘、雷同尚净业。及远公卒，谢灵运为铭，野为序，首称“门人”，世服其义。义熙十四年，与家人别，入室端坐而逝，春秋六十九。

周续之

    周续之，字道祖，雁门人。父殁过江，因居豫章。八岁丧母，哀戚过于成人。十二诣范宁受业，通《五经》、《五纬》，时号“十经童子”。养志闲居，穷研《老》、《易》。公卿交辟，无所就。入庐山事远公，预莲社。以为身不可遗，余累宜绝，遂终身不娶，布衣蔬食。刘毅镇姑熟，命为抚军，复辟太学博士，俱不就。以嵇康《高士传》得出处之正，为之注释。宋武帝北伐，太子居守，迎馆安乐寺，入讲礼月余，复还山。江州太守刘柳，荐于武帝，辟太尉掾，不就。武帝践祚，召至都，开馆东郭外。乘舆行幸，问《礼经》“傲不可长”、“与我九龄”、“射于矍圃”三义，辨析精异，上甚悦。或问：“身为处士，时践王廷何也？”答曰：“心驰魏阙者，以江湖为桎梏。情致两忘者，市朝亦岩穴耳。”时号“通隐先生”。续之素患风痹，不复堪讲，乃移病钟山。景平元年卒，春秋六十七。

张 诠

    张诠，字秀硕，野之族子也。尚情高逸，酷嗜坟典。虽耕锄，犹带经不释。朝廷征为散骑常侍，不起。庾悦以其贫，起为浔阳令。笑曰：“古人以容膝为安，若屈志就禄，何足为荣？”乃入庐山，依远公，研穷释典，深有悟入。宋景平元年，无疾，西向念佛，安卧而卒，春秋六十五。

宗 炳

    宗炳，字少文，南阳人。其母聪辨，富于学识，教授诸子，皆有成。炳妙善琴书，尤精玄理。殷仲堪、桓玄并以主簿辟，皆不就。刘裕领荆州，复辟为主簿，答曰：“栖丘饮谷，三十年矣。”乃入庐山筑室，依远公莲社。久之，兄臧为南平守，逼与俱还江陵，闲居绝俗。刘裕辟太尉掾，不就。二兄卒，累甚众，颇营稼穑。武帝敕南郡长，时致饩赉。衡阳王义季在荆州，亲至其室。炳角巾布衣，引见不拜。王曰：“处先生以重禄可乎？”对曰：“禄如秋草，时过即腐。”宋受禅，征为太子舍人；元嘉初，征为通直郎；太子建，征为中庶子，并不应。妻罗氏，亦有高志。罗氏殁，炳哀之过甚。既而悲情顿释，谓沙门慧坚曰：“死生之分，未易可达。三复至教，方能遣哀。”雅好山水，往必忘归。西陟荆巫，南登衡岳。因结宇山中，怀尚平之志。以疾还江陵，叹曰：“老病俱至，名山不可再登，唯澄怀观道，卧以游之。”凡所游履，悉图之于室，谓人曰：“抚琴动操，欲令众山皆响。”宋元嘉二十四年卒，春秋六十九。

雷次宗

    雷次宗，字仲伦，豫章南昌人。博学明《诗》《礼》，入庐山预莲社，立馆东林之东。元嘉十五年，召至京师，立学馆鸡笼山，置生徒百员。除给事中，不拜。久之还南昌，公卿徂道以送。与子侄书曰：“吾童稚之年，已怀远略。弱冠托庐山，事释和尚，游道餐风，二十余载。渊匠既倾，复与汝曹归耕先垄，山居谷饮，忽复十年。及今未老，尚可励志，成西归之津梁。自今以往，家务大小，一勿见关。”二十五年，召拜散骑常侍，不就。复征诣京师，筑室钟山，谓之“招隐馆”。每自华林园，入延贤堂，为太子、诸王讲《礼经》。是年无疾而卒，春秋六十三。子肃之，颇传素业，官至豫章郡丞。

    《十八贤传》，始不著作者名，疑自昔出于庐山耳。熙宁间，嘉禾贤良陈令举舜俞，粗加刊正。大观初，沙门怀悟，以事迹疏略，复为详补。今历考《庐山集》、《高僧传》，及晋、宋史，依悟本再为补治，一事不遗，自兹可为定本矣。

百二十三人传
（录其可见者三十七人）

    昙翼法师（以下五人有传）、昙邕法师、僧济法师、惠恭法师、法安法师；法净法师（以下五人见“远公传”）、法领法师、慧宝法师、慧要法师、僧澈法师；慧然法师（以下二人见《庐山集》）、昙威法师；道泓法师（以下二人见“持师传”）、昙兰法师；法业法师（以下四人见“跋陀罗传”）、慧义法师、惠严法师、慧观法师；昙果法师（见“邕师传”）、元弼法师（见“济师传”）；僧光法师（以下三人见“恭师传”）、慧堪法师、慧兰法师；阙公则（有传）、毕颖之（见“刘传”）；孟怀玉（江州刺史，以下十一人见《庐山集》）、王乔之（临贺太守）、殷隐（晋安太守）、毛修之（黄门侍郎）、殷蔚（主簿）、王穆夜（参军）、何孝之（参军）、范悦之（孝廉）、张文逸（处士）、孟常侍（以下二人失名）、孟司马；陆修静（简寂先生，有传）。

    昙翼，余杭人。初入庐山，依远公。后往关中见罗什。东还会稽，入秦望山，诵《法华经》十二年，感普贤大士化女子身，披彩服，携筠笼、一白豕、大蒜两根，至师前曰：“妾入山采薇，日已斜，豺狼纵横，归无生理，敢托一宿。”师却之力。女复哀鸣不已，遂令居草床上。夜半号呼腹疼，告师按摩。师辞以持戒，不应手触。女号呼愈甚，师乃以布裹锡杖，遥为按之。翌日，女以彩服化祥云，豕变白象，蒜化双莲，凌空而上，谓师曰：“我普贤菩萨，特来相试。”郡太守孟顗，闻于朝，敕建法华寺（今天衣寺）。初余杭山沙门法志，常诵《法华》。有雉巢于庵侧，翔集座隅，若听受状，如是七年。一日忽憔悴，志曰：“汝能听经，必生人道。”明旦雉殒，即为瘗之。夜梦童子拜曰：“因听经得脱羽类，今生山前王氏。”后其家设斋，志方踵门，儿曰：“我和尚来也。”志抚之曰：“汝我雉儿也。”解衣视掖下，有雉毳三茎。七岁令入山出家，十六落发。以掖有毳，因名以“翼”。

    昙邕，杨氏，关中人，形长八尺，雄武过人。南来庐山，依师远公。内外典籍，无不综习。立茅屋于山西，以自居止。有弟子昙果，澄思禅门，一夕梦山神求受戒法。果曰：“家师在此，可往求之。”邕忽见一人着袷衣，风神端雅，从者三十人，乞授戒。师以果先梦，知是山神，乃为说法、授五戒毕，神以外国二锄为嚫，礼谢而去。师后往荆州行化，卒于竹林寺。

    僧济，入庐山问道，精悟深要。远公叹曰：“绍隆大法，其在汝乎。”及在疾，远公以烛遗之曰：“汝可凭此，建心安养。”师执烛停想，延僧诵净土经。至五更，以烛授弟子元弼，随僧行道。顷之，觉自秉一烛，浮空而行，见阿弥陀佛接至于掌，遍事诸佛。须臾而觉，喜曰：“吾以一夕观念，便蒙接引。”明日，复于空中，见佛菩萨。谓弼曰：“佛来也。”即举首西顾，一息而终。时方炎歊，体三日不变，异香郁然。

    慧恭，豫章丰城人，与僧光、慧堪、慧兰，同志为学。光等学力不逮恭，而于净土系想则过之。兰谓恭曰：“君虽力学博闻，岂不知经云：‘如聋奏音乐，悦彼不自闻。’”恭曰：“学不可已，孰能未死，昧昧如痴哉！”后七年，兰等先逝，去时并有奇应。又五年，恭病且笃，曰：“大道沿洄，何时可止。死生去来，吾何归哉！”于是叩头雨泣，誓心安养，念不少间。忽见无量寿佛，以金台前迎。恭乘其上，见兰等于台上光明中而告之曰：“长老受生，已居上品，吾等不胜尉喜，但恨五浊淹延，相依之晚耳。”恭于是日告众，欣然奋迅而灭，时义熙十一年也。（《庐山集》有恭道人临终感应事。）

    法安，初依远公为弟子。妙善讲说，兼习禅业。律身持戒，为行尤精。义熙中，新阳邑社有暴虎，居神庙树下，前后害民以百数。安游其村，居民皆早闭门，乃之树下禅坐。须臾，虎负人至，见安惊喜跳伏。安乃为说法授戒，有顷而去。明旦，居民见安，谓是神人，相率礼敬。因改神庙，立寺宇，请安居之。左右田园，并舍为寺业。尝欲画像，须铜青，虑不可致。忽梦一人跪床前云：“此下有铜钟。”寤即掘之，果得二钟。取青成像，而以铜助远公铸佛。后不知所终。

    阙公则，入庐山白莲社。既逝，有同社人至洛阳白马寺，夜中为公则修忌祭。忽一时林木殿宇，皆作金色。空中有声曰：“我是阙公则，祈生极乐国，今已得生矣。”言讫无所见。
    〖校注〗据《法苑珠林》卷四十二，阙公则于晋武帝（265-290）时，往生西方安乐世界，为东土见于文献最早发愿生西者。东晋名僧支道林，曾为绘像制赞。据印光法师考证，远公结社为太元十五年（390），乃在此百年之后。飞锡《念佛宝王三昧论》误引为东林社中人，《佛祖统纪》中本传亦沿袭其误。彭际清《居士传·阙公则传》指出“他书误引公则为东林社中人”，而予改正。

    陆修静，吴兴人。蚤为道士，置馆庐山。时远法师居东林，其处流泉匝寺，下入于溪。每送客过此，辄有虎号鸣，因名“虎溪”。后送客，未尝过。独陶渊明与修静至，语道契合，不觉过溪，因相与大笑，世传为《三笑图》。宋泰始三年，羽化于京师，赐谥“简寂”，以故居为观。（《云笈七籤》本传，云元徽五年化。）

不入社诸贤传

    陶潜，字渊明（一字元亮），晋大司马侃之曾孙。少怀高尚，著《五柳先生传》以自况，时人以为实录。初为建威参军，谓亲朋曰：“聊欲弦歌，为三径之资。”执事者闻之，以为彭泽令。郡遣督邮至县，吏白：“应束带见之。”潜叹曰：“吾不能为五斗米折腰，拳拳事乡里小人耶！”解印去县，乃赋《归去来》。及宋受禅，自以晋世宰辅之后，耻复屈身异代，居浔阳柴桑，与周续之、刘遗民并不应辟命，世号“浔阳三隐”。尝言：“夏月虚闲，高卧北窗之下，清风飒至，自谓羲皇上人。”性不解音，畜素琴一张，弦徽不具。每朋酒之会，则抚而和之曰：“但识琴中趣，何劳弦上声。”尝往来庐山，使一门生、二儿，舁篮舆以行。时远法师与诸贤结莲社，以书招渊明，渊明曰：“若许饮则往。”许之，遂造焉，忽攒眉而去。宋元嘉四年卒，世号“靖节先生”。

    谢灵运，祖玄有功晋室，灵运为康乐公主孙，袭封康乐公，文章为江左第一（应为“江右”，指金陵也）。尝着木屐，上山则去前齿，下山则去后齿。寻山陟岭，必造幽峻。至庐山，一见远公，肃然心伏。乃即寺筑台，翻《涅槃经》，凿池植白莲。时远公、诸贤，同修净土之业，因号白莲社。灵运尝求入社，远公以其心杂而止之。

    范宁，字武子，笃学多所通览。时浮虚相扇，儒雅日替。宁以其源始于王弼、何晏，二人之罪，深于桀、纣，乃著论非之。累迁中书侍郎，朝廷疑议，辄咨访之。出补豫章太守，大设庠序，起学台，功用弥广。刺史王凝之上言，抵罪免官归家。远公招之入社，而宁竟不能往。

录自《佛祖统纪》卷二十六，以《卍续藏》所收本传参校


莲社十八贤图

    【说明】本图载《卍续藏经》第135册《东林十八高贤传》卷首。黄汝亨序，称为“龙眠《十八贤图》”。李冲元《莲社十八贤图记》，言为宋代著名画家李伯时（号“龙眠”）于元丰三年（1080）所作。此图原本分为三幅，现经对扫描文件的拼合、修整而为一整幅。
    考之《图记》，临溪而坐之跋陀罗、耶舍二梵僧后，尚有：“童子一，卷发胡面，持羽扇立其后。”本图无。因此《图记》言全图“凡为人三十有八”，而今为三十七位。又本图中幅，炉旁俯而烹茶者身后，兀然有一松枝伸出，原图似不应如此。类此差异，或乃屡经传写、刻版而有所变动所致。
    据《佛光大辞典》：李伯时，名公麟，号龙眠居士，宋代安徽舒州人。元祐（1086--1094）进士，元符年间（1098～1100）拜御史大夫。博学好古，尤善画山水、佛像。晚年归佛受戒，能通禅法，而雅好净土。隐居龙眠山庄，时与高僧谈论，并结社念佛。绍兴四年（1134）预知时至，施财，书偈，念佛而化。享年八十六。遗墨传世颇多，画家奉为典则。　（清凉书屋制作并记，2003.10.14）


莲社十八贤图记

［宋］李冲元撰

    龙眠李伯时，为余作《莲社十八贤图》，追写当时事。按十八贤行状，沙门慧远，初为儒，因听道安讲《般若经》，豁然大悟，乃与其弟慧持，俱弃儒落发。太元中，至庐山。时沙门慧永，先居香谷。远欲驻锡是山，一夕山神见梦，稽首留师，忽于后夜，雷电大震，平旦，地皆坦爽，材木委积。江州刺史桓伊，表奏其异，为师建寺，是为东林，因号其殿为“神运”。时有彭城遗民刘程之、豫章雷次宗、雁门周续之、南阳宗炳、张诠、张野，凡六人，皆名重一时，弃官舍缘，来依远师。复有沙门道昺、昙恒、慧睿、昙诜、道敬、道生、昙顺，凡七人，又有梵僧佛驮跋陀罗、佛驮耶舍二尊者，相结为社，号庐山十八贤。
    时陈郡谢灵运，以才自负，少所推与。及来社中，见远师，心悦诚服，乃为开池种白莲，求预净社。远师以其心乱，拒而不纳。陶潜时弃官居栗里，每来社中，或时才至，便攒眉回去。远师爱之，欲留不可得。道士陆修静，居简寂观，亦常来社中，与远相善。远自居东林，足不越虎溪，一日送陆道士，忽行过溪，相持而笑。又尝令人沽酒，引渊明来。故诗人有“爱陶长官醉兀兀，送陆道士行迟迟；沽酒过溪俱破戒，彼何人斯师如斯”，又云“陶令醉多招不得，谢公心乱去还来”者，皆其事也。
    此图初为人路，与清流激湍，萦带曲折。逾石桥，溪回路转，石岩一，又缭而上石岩一。二岩之间，有方石池，种白莲花。岩之傍，有石梯，度山迤俪而去，不知所穷。当图穷处，横为长云，蔽覆树腰、岩顶，其高深远近，盖莫得而见也。傍石池，有高崖悬泉，下潴为潭，支流贯池，下注大溪。激石而湍浪者，虎溪也。
    岩之外，游行而来者二人。一人登岭出半身者，宗炳也。一人蹑石磴而下者，昙顺也。
    岩中经筵会讲者四人。一人踞床凭几，挥麈而讲说者，道生也。一人持羽扇，目注悬猿，而意在深听者，雷次宗也。一人合掌坐于床下者，道敬也。一人相向而坐者，昙诜也。一人执经卷，跪听于其后。童子一，舒足搔首，有倦听之意。
    莲池之上，环石台坐而笺经校义者五人，石上列香炉、笔砚之具。一人凭石而坐者，刘程之也。一人手开经轴，倚石而回视者，张诠也。一人正坐俯而阅经者，慧睿也。一人回坐拱手傍视而沉思者，慧持也。一人持如意而指经者，慧永也。一人捧经笈，与童子持如意立其后。又童子跪而司火，持铗向炉而吹。一人俯炉而方烹，一人捧茶盘而立。傍有石置茶器。
    又一岩中有文殊金像，环坐其下为佛事者三人。一人执炉跪而歌呗者，昙恒也。一人坐而擎拳者，道昞也。一人执经卷而坐者，周续之也。
    临溪偶坐者二人，皆梵僧。一人袒肩持短锡者，跋陀罗也。一人举如意据膝而坐者，耶舍也。童子一，卷发胡面，持羽扇立其后。
    一人露顶坦腹，仰视悬泉，坐而濯足者，张野也。童子持巾立其侧。又蹲而汲者一人。
    石桥之傍，峭壁崛起，前有僧与道士相促而笑者，远公送陆道士过虎溪也。一人貌怪雄视，捉巾瓶而立者，捕蛇翁也。童子负杖却立而待。
    一人乘篮舆者，渊明之回去也。渊明有足疾，尝以竹篮为舆，其子与门生肩之。前者若欲憩而不得，后者若甘负而忘倦，盖门人与其子也。童子负酒瓢从之。
    一人持贝叶，骑而方来者，谢灵运也。傍一人持曲笠，童子负笈前骑而行。
    凡为人三十有八。马一、猿一、鹿一。器用、草木，不复以数计。人物洒落，泉石秀润。追千载于笔下，萃群贤于掌中。开图恍然，若与之接。挥麈而谈者，如欲悬河吐屑，肆辩而未停。默坐而听者，如欲屏息杜意，审谛而冥冥。沉思者，如欲钩深味远，叩玄关宅灵府，而游乎恍忽之庭。梵呗者，如欲转喉鼓舌，而有云雷之响，与海潮之声。行往来者，如御风而遐举。坐临水者，如骑鲸而将去。笑执手者，轩渠绝倒，达于衣冠。盖其心手相忘，笔与神会，而妙出意表，故能奴隶顾陆，童仆张吴，跨千载而独步。非十八人者，不足以发伯时之笔。非伯时者，不足以写十八人之趣。岂非泉石膏肓，烟霞锢疾，其臭相似。故形容之工，若同时而共处者也。
    伯时与余为从兄，实山林莫逆之友。为此图凡三十八日而成。余得之，游居寝饭其下。客来观者，或未知莲社事，因记其后，览者当自得之也。图成于元丰庚申（1080）十二月二十五日。越明年辛酉（1081）正月二十六日，龙眠李冲元元中记。

〖录自《续藏经·东林十八高贤传》〗


述匡山寺书 (智者大师)

述匡山寺书

［隋］智者大师撰

    江州匡山东林寺者，东晋雁门慧远法师之所创也。远是弥天释道安之高足，安是大和尚佛图澄之弟子。三德相承，如日月星，真佛法梁栋，皆不可思议人也。而远内闲半满，外善三玄，德布遐方，声高霄汉。初诣山足，依止一林，共耶舍禅师，头陀其下，若说若默，修西方观。末于林右建立伽蓝，因以为名东林之寺。远自创般若、佛影二台。谢灵运穿凿流池三所。梁孝元构造重阁，庄严寺宇，即日宛然。
    峰顶寺者，是齐慧景禅师，感山人延请，因栖其峰。次梁慧归，在后登蹑，方建伽蓝。峰有水泉，忽然枯涸。归烧香咒愿，清流盈满，天降甘露于泥洹日。是以先德名踪，垂芳不断。松霞清旷，触处萧条。公私往还，莫不归向。
    自大化江左，贫道因至彼山，憩泊东林，时游峰顶，以岁为日，羡玩忘劳。然山下伽蓝，偏近驿道，行人归去，颇成混杂。今奉请为两寺檀越，庶藉影响，众得安心，礼诵虔诚，用酬洪泽。并乞勒彼所由，永禁公私停泊。沙门某敬白。

附：王答匡山书
［隋］晋王杨广

    弟子总持和南。垂诲述江州浔阳庐山东林寺、峰顶寺，须令弟子并为檀越主。山岭盘秀，下属江湖。香罏层峰，上亏云日。仙人之所戾止，隐伦于焉不归。况乎慧远法师，胜依结构。谢客、梁元，穿池重阁。景师息心，神应峰顶。智者憩历，踵武前贤。师严道尊，实深随喜。所恨寡薄，无益将来，庶藉熏修，方证常乐。兼陈二寺偏近驿道，行人往来，颇成混杂。须勒彼州令去，公私使命，不得停止。即付所司，依事颁下。谨和南。三月一日。

附：与匡山寺书
［隋］晋王杨广

    极暄，法师道体何如，众内咸宜也。雁门远法师，四依菩萨，翻飞朔野，栖息南山。自斯以后，名德相继。智者见令为寺檀越，顾修寡薄，非敢克当。奖导既引，良深随喜。敬德指此承问。杨广和南。三月二十一日。

附：与禅阁寺书
［隋］晋王杨广

    春序将谢，道体何如，僧众清善。匡山佛寺，兴自慧远法师。法师师于弥天道安，安师于佛图澄。妙德相承，莫之为最。江东龙藏，悉本雁门。雁门上人，创迹庐阜。自梁及晋，止有东林。陈晚浇漓，别生禅阁。僧徒好异，岂称至和？智者爰居，还须合一。想均愿海，更无异味。行人将送过，指此相闻。杨广和南。三月二十一日。

〖录自《国清百录》卷第二〗

清凉书屋·2003.10


记刘遗民禅观事 (法琳法师)

《辩正论》记刘遗民禅观事

［唐］沙门释法琳撰

    晋彭城侯刘遗民，撰《五时教》，著《九想诗》；晋豫章太守雷次宗，精心慕法，造栖灵寺；晋临淮令周续之，服道日新；晋新蔡侯毕颖之，心期净域；晋南阳长宗炳之，如事恳苦。
    右五贤，谢职遗荣，策名神府，从远师游憩。意志隐沦，等布一心，俱履幽极。藉芙蓉于中流，荫琼柯以咏言。飘云气于八极，泛香风于百年。体忘安以弥穆，心超乐以自然。（《辩正论》卷第三）
    〖校注〗宗炳之，即宗炳。

    遗民精思勤笃，珠颜耀彩于眉间。
    刘遗民，彭城人，少为儒生，丧亲，至孝以闻。家贫，卜室庐山西林中，多病，不以妻子为心。绝迹往来，精思禅业。半年之中，见眉间相。渐见佛一眼，及发际二色，又见全身，谓是图画。见一道人奉明珠，因遂病瘥。出《宣验记》也。（《辩正论》卷第七）
    〖校注〗《宣验记》，刘宋临川王刘义庆著。

〖录自《辩正论》〗

清凉书屋·2003.10


往生集·远祖师传 (莲池大师)

往生集·远祖师传

［明］莲池大师撰

    晋慧远，雁门楼烦人，博综《六经》，尤善《庄》《老》。闻安法师讲《般若经》，豁然大悟，因剃染事之。太元六年过浔阳，见庐山闲旷，可以息心。遂感山神现梦，一夕雷雨，材木自至。刺史桓伊，乃为建殿，名曰“神运”。以慧永先住西林，故远所居号“东林”焉。
    远住东林三十年，迹不入俗，克志西方。高僧巨儒凡百四十人，共为净社。莲漏六时，禅诵不辍。澄心系想，三睹圣相，而沉厚不言。后十九年七月晦夕，于般若台，方从定起。见阿弥陀佛，身满虚空，圆光之中，无量化佛。观音、势至，左右侍立。又见水流光明，分十四支，洄注上下，演说妙法。佛言：“我以本愿力故，来安慰汝。汝七日后，当生我国。”又见佛陀耶舍、慧持、慧永、刘遗民，在佛之侧，揖曰：“师志在先，何来之晚耶！”既知时至，谓门人曰：“吾始居此，三睹圣相。今复再见，当生净土必矣。”至期，端坐入寂。时义熙十二年八月六日也。
    赞曰：晋以前，净土之旨，虽闻于震旦。而弘阐力行，俾家喻户晓，则自远师始。故万代而下，净业弟子推师为始祖。可谓释迦再说西方、弥陀现身东土者也，厥功顾不伟欤！予昔游庐山，酌虎溪之泉，瞻三笑之堂，徘徊十八贤之遗迹。见其规模弘远，足称万僧之居。而殿阁尘埃，钟鼓阒寂，寥寥然户异其扃，室殊其爨矣。哲人云亡，芳躅无继，嗟夫！

〖据《莲池大师全集》本点校〗

清凉书屋·2003.10


往生集·刘遗民传 (莲池大师)

往生集·刘遗民传

［明］莲池大师撰

    晋刘遗民，彭城人，汉楚元王之后。少孤，事母以孝闻。自负其才，不侣流俗。初为府参军，即隐去。谢安、刘裕，交荐不就，旌其号曰“遗民”。入庐山，预远公莲社，著《念佛三昧诗》，以表专志。尝于定中，见佛光照地，皆作金色。居十五年，又见阿弥陀佛玉毫光照，垂手慰接。遗民恳曰：“安得如来为我摩顶，覆我以衣。”俄而佛为摩顶，引袈裟被之。他日又见入七宝池，莲花青白，其水湛然。一人项有圆光，胸出卍字，指池水曰：“八功德水，汝可饮之。”遗民饮水甘美。及寤，犹觉异香发于毛孔。乃告众曰：“吾净土之缘至矣。”对像焚香再拜，祝曰：“我以释迦遗教故，知有阿弥陀佛。此香供养释迦如来，次供阿弥陀佛，及《妙法华经》。愿一切有情，俱生净土。”言讫，面西合掌而逝。时义熙六年也。
    赞曰：《观经》叙净业正因，以孝养父母为第一。故知不孝之人，终日念佛，佛亦不喜。今遗民少尽孝养，而复深入三昧，屡感瑞征，其往生品位高可知矣。在家修净业者，此其为万代师法。

〖据《莲池大师全集》本点校〗

清凉书屋·2003.10


莲社始祖慧远法师赞 (蕅益大师)

莲社始祖慧远法师赞

［明］蕅益大师撰

    莲社始祖慧远法师，俗姓贾，雁门楼烦人。幼好学，博综《六经》，尤善《庄》《老》。二十一岁，师事道安。二十四，大善讲贯。晋孝武太元六年，至庐山，梦神告以“毋他往”。夕大雷电，林壑洞开，素砂布地，楩、楠、文梓充布地上。九江刺史桓伊，为建东林寺，殿名“神运”。尝谓：“诸种三昧，其名甚众。功高易进，念佛为先。”结社者有十八高贤，及一百二十三众，皆登安养。时江东经卷未备，禅法无闻，律学多缺。师令弟子，越葱岭远求得之。著《法性论》，创明“涅槃常住”之理。什师叹其暗与理合。安帝时，桓玄令沙门拜王。师致书谏止，著《沙门不敬王者论》。师居山三十年，专修净业。三见佛，不言。义熙十二年七月晦日，佛来迎云：“七日后，当生我国。”至八月六日，耆宿请以豉酒治病。师曰：“律无通文。”又请饮米汁，师曰：“日过中矣。”又请饮蜜水，乃披律寻文，卷未半，坐逝。寿八十三。赞曰：

念佛三昧宝，圆顿法中王，
挺生神圣士，勇猛独承当。
香象截流度，捣丸集众香，
大德矜细行，禅律咸舒光。
法性悟常住，僧仪超帝皇，
才识迈前哲，密证不自彰。
文成印乃坏，怡然返故乡，
高风千古在，归命附慈航。

〖录自《灵峰宗论·卷九·十八祖像赞》〗


论三种念佛法门 (蕅益大师)

蕅益大师论三种念佛法门

    经云：“一称南无佛，皆已成佛道。”此言正因佛性，人人本具。故称性所起缘、了二因，必与正因同得究竟也。是以念佛三昧，名为三昧中王，普摄一切三昧。修此三昧，凡有三种：一者唯念他佛，二者唯念自佛，三者自他俱念。修虽有三，成功则一。
    一、念他佛者。托阿弥陀佛果德庄严，为我所念之境，专心注意而忆念之。或忆名号，或想相好，或缘四十八愿往昔洪因，或思力、无畏等现在胜德，或观正报，或观依报，总名为念他佛。贵在历历分明，一心不乱。则三昧功成，径登净域。如东林诸上善人，即其证也。
    二、念自佛者。观此现前一念介尔之心，无体无性，横遍竖穷，离过绝非，不可思议。具足百界千如，种种性相。与三世佛，平等无二。如此观察，功深力到，圆伏五住，净于六根，豁破无明，顿入秘藏。如西天四七、东土六祖，及南岳大师、天台智者，即其证也。
    三、自他俱念者。了知心、佛、众生，三无差别。众生是诸佛心内众生，诸佛是众生心内诸佛。托彼果上依正，显我自心理智。如《观经》云：“是心作佛，是心是佛。”由我心性本具功德不可思议，诸佛果中威力不可思议，故感应道交，自他不隔。极果圆因，称理映发。如永明寿、楚石琦所修法门，即其证也。
    方便多门，归元无二。随行一辙，俱得到家。切勿疑虑，自隔要津。

〖节自《灵峰宗论·卷七·净然沙弥化念佛疏》〗


初祖慧远大师赞 (印光法师)

晋初祖庐山东林慧远大师赞

［民国］印光法师撰

    以特别法，永为世范。意旨暗合于《行愿》，中外流通遍。普令庸彦，大事即生办。
    肇启莲宗福震旦，畅佛本怀垂方便。圆音一阐士归庐，大法将弘神运殿。一切法门从此流，一切行门从此办。致令各宗尽朝宗，万川赴海依《行愿》。

〖录自《文钞续编卷下·莲宗十二祖赞》〗


远公大师像赞 (印光法师)

远公大师像赞

［民国］印光法师撰

缅维远公，乘愿再来。创立莲宗，畅佛本怀。
俾诸凡夫，忆念佛名。仗佛慈力，带业往生。
已断惑者，即证无生。证无生者，速圆佛乘。
以果地觉，为因地心。感应道交，利益甚深。
未见《涅槃》，即宣常住。未见《行愿》，普导西去。
其所立法，暗与经合。护法菩萨，表自大觉。
罗什举经，深加赞叹。西僧景仰，心香辄献。
千余年来，不闻圆音。幸有遗教，尚可遵循。
伏愿我公，又复示生。普引群伦，同登五清。
印公遗文，模公道貌。庶几来哲，是则是效。

〖录自《文钞续编》卷下〗


《慧远法师文钞》序 (印光法师)

《晋莲宗初祖庐山慧远法师文钞》序

［民国］印光法师撰

    如来大法，弥纶法界，包括空有。示本具之真心，显随缘之妙用。其心体则生佛一如，圣凡不二，真常不变，寂照圆融。佛以究竟证故，故得五蕴皆空，诸苦悉度，一尘不立，万德圆彰。众生以彻底迷故，故致迷真逐妄，背觉合尘，轮回生死，了无出期。于是如来，随众生机，说种种法，令彼各各就路还家，亲见本生之父母。探衣出珠，即获无尽之家珍。上根固得解脱，中下仍在轮回。特开净土法门，令其横超三界。普使中下，追踪上根。其为利益，莫能名焉。此义虽出方等，其道实肇《华严》。但以凡小不能预会，莫由禀承。当《华严》未来之前，率目为方便小道。迨《行愿》既译之后，方知为成佛真诠。
    庐山远公，宿承佛嘱，乘愿再来。未睹《涅槃》，即著法性常住之论。未见《华严》，便阐导归极乐之宗。立法暗与经合，其道普被三根。契理契机，彻上彻下。畅如来出世之本怀，了含识生死之大事。若非大权示现，其孰能预于此！故罗什法师曰：“经言：‘末后东方，当有护法菩萨。'勖哉仁者，善弘其事。”西域僧众，咸称汉地有大乘开士，辄东向稽首，献心庐岳。其神理之迹，未可测也。
    按远公于东晋孝武帝太元九年甲申（384）始至庐山，住同门慧永法师之西林寺。后以来学者多，西林隘不能容，故复开东林寺。经始之时，山神效灵，材木自至。刺史桓伊，乃为建造，名其殿为“神运”，表灵异焉。由是缁素高贤，来者益众。至太元十五年庚寅（390）七月二十八日，与缁素一百二十三人，结社念佛，求生西方。此诸人等，于临终时，皆有瑞应，皆得往生。良由诸人，均具出类拔萃之智，又蒙远公开导，及诸友切磋琢磨之力，故获此益。此系最初结社之人。若终公之世，三十余年之内，其蒙法化而修净业，得三昧而登莲邦者，何可胜数。溯远公于太元九年甲申至庐山，于义熙十二年丙辰（416）八月初六日西逝，凡三十二年，影不出山，迹不入俗。其弘扬法化，护持佛教之著述，备载《庐山集》。以屡经沧桑，佚失殆尽。幸《弘明集》、《广弘明集》，各有所录，犹令古德芳徽，永传于世。
    如皋沙健庵太史，晚年笃信佛法，专修净业。博览群书，凡远公著述，及后人所作传赞记颂等，悉备录之，题曰《慧远法师文钞》。分正附二编。其门人项智源，又为补录，委光校订而排印焉。窃以远公为莲宗初祖，其书广布，阅者必能兴起。但以资斧不给，先印万册以为之倡，则后之源源相继而印者，又何可计其数耶。后之学者，由此书故，悉知净土法门之所以然，必至当仁不让，追踪先觉，同出五浊，同登九莲也。故于付排之前，略叙来历。至于远公之道德、功业、文章、感通，备载《文钞》正附二编，兹不繁述。
    （世传远公，与十八高贤，一百二十三人结社。十八人中，远公居首，余十五人，多系最初结社之人。若佛驮跋陀罗，系安帝义熙二年（406）始入社，乃结社后第十七年。佛驮耶舍，系义熙十年（414）入社，乃结社后第二十五年。飞锡法师《宝王论》谓远公从佛驮跋陀罗受念佛三昧，与缁素高贤结社念佛。盖尊西僧，而未详考其入社之年时耳。）

〖录自《文钞续编》卷下〗