楞严通议

下一页


目录


科号次第

科号次第

1、○
2、※
3、△
4、◎
5、□
6、≡
7、●
8、▲
9、◇
10、★
11、☆
12、⊙
13、∨
14、∧
15、⊥
16、∪
17、≠
18、∽
19、≌


通议卷第一

通议卷第一

大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第一

唐天竺沙门般刺密帝译
乌苌国沙门弥伽释迦译语
菩萨戒弟子清河房融笔受
明南岳沙门憨山释德清述

悬判

议曰。从前释经诸师凡解当经必先悬判十门。要令学者知我如来应世四十九年所说一大藏教。从始至终而有五时五教之别。谓小始终顿圆。而有浅深次第不同。刻指一经。定属何时何教。此乃注释之轨则。如贤首清凉已后皆祖述之。莫不皆然。独此一经。前后解者凡十余家。各据一见。所指之时。前后不同。多起争论。难决众疑。予尝见有本别题亦名灌顶部中录出别行。因谛观此经非一时顿说。向无的据。既见长水注疏经本别题一名中印度那兰陀大道场经于灌顶中录出别行。(王睿)师判云。佛说此经。非一时顿说。说必前后。是知集者约类纂为一部。以此为准。的信不疑。但详经中自名灌顶章句则集者约类可知矣。请试言之。然灌顶部乃我中央毗卢遮那佛所说之法也。以毗卢乃法身佛也。从法垂报名卢舍那。坐菩提场演大华严。谓之根本法轮。但被一类大根众生。而小根之人如盲如聋。故舍那世尊入刹那际三昧双垂两相。现应化身示生三界名释迦牟尼。始从兜率降王宫入胎出胎以至出家苦行八相成道。始于鹿苑说法。历方等般若法华等四十九年入大涅盘。始终不出刹那际三昧。所说一大藏教名为摄末归本法轮。亦名引摄教。为引五性三乘摄归一乘寂灭场地。即指华严为妙庄严海为所归之地。犹如穷子之家。而三观妙门乃归家之路。所谓一路涅盘门也。今观此经发起示堕淫室。此正阿含之时也。其征心以破执身常见。匿王以破断见乃阿含之教也。其辩妄见以显真见。破见精以显本觉。义与深密同时也。五蕴三科会归藏性。则同般若真空法华实相。又历两时之间也。七大遍周性真圆融。实与华严理事无碍法界相等也。及至四卷中云。一为无量无量为一。小中现大大中现小。于一毛端现宝王刹。坐微尘里转大法轮。此乃略显华严事事无碍法界。正是所归妙庄严海。是谓究竟归宁之地也。三身一体至是乃显。释迦出世之本怀教化众生必欲引摄至此而后已。是知此经无教不收无机不摄。岂可局定一时哉。盖释迦世尊所秉卢舍那佛一宝相印。是谓微密一心。而空假中三观法门乃破惑之利具。世尊出世即欲众生证此一心。奈何众生烦恼垢重不敢顿示此心。姑于阿含会上且说人天十善免堕三途。及说无常苦空无我苦集灭道四谛及十二因缘之法。令诸众生权出三界免离生死，所证涅盘谓之偏空。执空而不能有。以小乘不达唯识道理。乃说解深密经以立九识依之而起八识变起根身器界。要了妄相皆从唯识所变其相本空。次说般若以显真空幻有以破小乘偏空之执。此去阿含四十年矣。及至法华纯谈实相。直示一心以显中道。涅盘乃明平等佛性。三乘同归五性齐入。凡有心者皆得成佛。方尽世尊出世本怀。然涅盘尚未显有圆融之旨。今以此经所诠理趣通途按定一代时教。摄法无遗。况始从阿含终至涅盘尚系化佛所说之法。而圆融道理乃属华严为报佛所说。由是观之。岂可局定一时哉。若就法界海慧照之。则释迦说法四十九年始终不出刹那际三昧。此乃劫念齐收。无时之时实无先后。若就应化门头机有生熟。从浅至深不无次第。以一心法门佛佛同证，三观乃悟心之要。以历五时随机不同故散出一代时教。各对当机三根普收。行布亦异。故结集者虑恐末世修行之世智识狭劣。而教海汪洋难究指归。故推报化二佛所说从本垂末摄末归本二种法轮。总于一代教中拈出一心。特显众生从悟至迷以极七趣升沉之情状。会归三观按破二执以显从迷至悟所证浅深五十五位之阶差。通会长途始终一贯摄归一心。从凡至圣直入果海不涉枝歧。使修行之士一览无余。如悬镜智于目前。了归家之道路。所谓一路涅盘门。岂可局定一时哉。苟不以理融通印契佛心。即刻定一时于法奚益。故弘通者贵在得本而不贵乎泥迹也。

【大佛顶如来密因修证了义诸菩萨万行首楞严经】

议曰。此经题目。经中世尊自说有五种名。今此一题存隐可知。然此题虽一十九字。而独重在首楞严三字而已。其上一十六字皆约义也。释首楞严此云一切事究竟坚固。大定之总名也。乃一心之异称。有法有义。且此定体总之而为一心。别之而为三观。然此三观皆依一心而立。起信论云。心真如者即是一法界大总相法门体。所谓如来藏清净真心也。依此心体有三种名。一空如来藏。二不空如来藏。三空不空如来藏。谓此心体本来清净一法不立是故名空。具有洹沙称性功德故名不空。三空不空者即此二体但是一心。寂照同时。寂故名空照故不空。存泯无碍。名空不空。依此义故建立三观。由此三观还证一心。故云大定之总名也。是谓之法。上十六字乃其义者谓此一心具有体相用三大义故。一者体大。二者相大。三者用大。题称大佛顶等乃示三大义也。所言大者谓此心体广博包含极法界量大而无外体绝名言强名大也。佛顶者乃约喻以明相大也。谓佛乃至极之圣。顶乃最尊无上之顶。佛相好中名为无见顶相。故曰初生亲捧持谛观不见顶。以此至极无相之顶以喻广大无外之心。无相而不可以见见。故为相大也。如来密因等者以明用大。谓一切诸佛乘此一心以跻极果。究竟无余。故云了义。一切菩萨乘此一心到如来地。故云万行。以此一心具上三义。故为大定之总名。向下阿难约义而请三观。佛答直指一心。是知全经所演修证因果总之不出三观。究竟不离一心。若以此心而照万法则法法全真。故云一切事究竟坚固。若了一题则全经之旨思过半矣。

【一名中印度那兰陀大道场经於灌顶部录出别行。】

议曰。此别目也。印度具云印特伽。此云月邦。印度有五。此当其一。西域之大国也。那兰陀。此云施无厌。即龙名也。西域记云。〖艹奄〗没罗国有池池中有龙名施无厌。寺近彼池故以为名。大道场者西域诸寺独此最大。五天竺国王同共崇奉。集性相二宗大德沙门居之。佛法多积於此。昔玄奘初至西域先至此寺从戒贤论师习唯识宗即其处也。灌顶部者华严界中有五方佛所说之法各有一部。中央毗卢遮那佛为主所说之法名灌顶部。显此经通篇报佛所说故以此名。既标那兰陀大道场经则集者可知。按长水疏存此题亦云此经非一时说。

【中天竺沙门般剌密谛於广州制止道场译】

议曰。此译人名也。天竺亦名乾竺。亦名身毒。亦名印度。西域国名。梵音楚夏耳。般剌密谛此云极量。译师名也。此经西域国王最所宝重严禁不许出境。般剌三藏欲传震旦屡窃而来皆被获回。必不能得。后以微妙细毡书之。乃破臂藏於皮中。遂航海而达广州。唐神龙元年乙丑五月二十三日适遇宰相房融知南铨在广。安三藏於制止寺翻译而笔授之。此经来之难也。既而翻译才毕。以三藏潜来。彼国边境被责。三藏为解此难遂回。及房公入奏又遇中宗初嗣国方多事未暇宣布。时神秀禅师入内道场见而抄写遂流北地。大通在内亲遇奏经又写归荆州度门寺。有魏北馆陶沙门慧振常慕此经於度门寺得之。后悫师於故相房融家得其译本因而遂传此。经流通之难也。昔天台智者大师作止观成遇一梵师以止观示之。梵师曰。此与西域首楞严经三观大旨相同。大师日夜西望拜求愿见而未及见。是见此经之难也。今幸古今解者十余家义疏阐幽发明殆尽。方今缁白入此法门者不少。而学者概视为等闲。岂知佛法之难遇哉。

【乌苌国沙门弥伽释迦译语】

议曰。鸟苌此云苑。国名也。弥伽释迦此云能降伏。翻梵为华故云译语。

【菩萨戒弟子前正议大夫同中书门下平章事清河房融笔授】

议曰。菩萨戒弟子者乃宰官而受菩萨大乘戒者也。戒经云。欲受国王位时乃至百官受位时应先受菩萨戒。一切鬼神救护王身百官之身也。

此经十卷准常有三分

○谓一序分序说法之因由故

○二正宗分正示一经之宗体故

○三流通分冀流传於终古故

入经先列序分

※初通序

【如是我闻。一时佛在室罗筏城祗桓精舍。与大比丘众千二百五十人俱。皆是无漏大阿罗汉。佛子住持。善超诸有。能於国土成就威仪。从佛转轮妙堪遗嘱严净毗尼弘范三界。应身无量度脱众生。拔济未来越诸尘累。其名曰。大智舍利弗（此云鹫子）摩诃目犍连（此云采菽氏）摩诃拘〖纟希〗罗（此云大膝）富楼那弥多罗尼子（此云满慈子）须菩提（此云空生）优波尼沙陀（此云尘性空）等。而为上首。复有无量辟支无学。并其初心同来佛所。】

议曰。此通序法会之由也。世尊说法之常仪。乃佛遗制。诸经通有故为通序。所言六种成就及叹德列众弟子氏族准常多解此不重出。

※二别序

【属诸比丘休夏自恣。十方菩萨咨决心疑。钦奉慈严将求密义。即时如来敷座宴安。为诸会中宣示深奥。法筵清众得未曾有。迦陵仙音遍十方界。恒沙菩萨来聚道场。文殊师利而为上首。时波斯匿王为其父王讳日营斋。请佛宫掖。自迎如来。广设珍馐无上妙味。兼复亲延诸大菩萨。城中复有长者居士同时饭僧。伫佛来应。佛敕文殊分领菩萨及阿罗汉应诸斋主。唯有阿难先受别请。远游未还不遑僧次。既无上座及阿〖门者〗黎。途中独归。其日无供。即时阿难执持应器。於所游城次第循乞。心中初求最后檀越以为斋主。无问净秽刹利尊姓及旃陀罗。方行等慈不择微贱。发意圆成一切众生无量功德。阿难已知如来世尊诃须善提及大迦叶。为阿罗汉心不均平。钦仰如来开阐无遮度诸疑谤。经彼城隍。徐步郭门。严整威仪。肃恭斋法。尔时阿难因乞食次经历淫室。遭大幻术摩登伽女。以娑毗迦罗先梵天咒摄入淫席。淫躬抚摩将毁戒体。如来知彼淫术所加。斋毕旋归。王及大臣长者居士俱来随佛愿闻法要。於时世尊顶放百宝无畏光明。光中出生千叶宝莲。有佛化身结跏趺坐宣说神咒。敕文殊师利将咒往护。恶咒销灭。提奖阿难及摩登伽归来佛所。】

议曰。此别序发启此经之由致也。休夏自恣乃佛律制。比丘当初夏时即结制名为护生。亦名坐腊。九旬禁足。无由见佛。夏满之日同诣佛所。自有过失恣任僧举。佛为作法忏悔。名为羯摩。又云。於坐夏中各为腊人随身。若有何根犯戒即坏其根则不算腊。若全不犯者乃成一腊。如世俗之一岁。故出家以腊不以年。而此经以休夏自恣为开端者。以卢舍那佛说梵网经金刚宝戒命释迦化佛宣布十方。是知释迦四十九年单演戒法。意在出家修行出生死法以戒为基本也。问曰。此经理开藏性。行依大定。教属顿圆。而以阿难示堕淫室浅近之事发之者何耶。答曰。此如来说法有深意也。经云佛以一大事因缘故出现於世。所谓一大事乃一真法界如来藏清净真心。此心乃诸佛众生均赋而同禀者也。以众生迷之故如来特因此出世开示众生令其悟入。故此实最大一事也。然众生既禀此心所以常寝生死久溺轮回永劫不得出离者皆由爱欲牵缠故也。以其生死界中独与真为对者亦唯此一事为大耳。是为生死根本也。故曰赖有一矣。若使二同普天之人无能为道者。今欲返妄归真必须先拔生死根本。故梵网戒经以断杀为先。此经以断淫为首。以此患最深。非大定不足以破之。故阿难示堕淫室以发端。及归来见佛先以大定为请也。而开口便言欲气粗浊。向下世尊历历数其过患。至於三种相续则曰想爱同结爱不能离则诸世间父母子孙相生不断经百千劫长在缠缚。唯淫杀盗三为根本。又曰爱镜中头无故狂走。又曰称汝多闻何不能免摩登伽难。待神咒力淫火顿灭爱河干枯令汝解脱。又曰汝虽忆持如来秘密妙严不如一日修无漏业远离世间憎爱二苦。又曰摩伽耶轮同悟宿因贪爱为苦。及安立道场首即告曰六道众生其心不淫则不随其生死相续。淫心不除尘不可出。纵有禅定必落魔道。若不断淫修禅定者如蒸砂作饭百劫难成。淫身修行纵得妙悟皆归淫根。根本成淫。三途难出。必使淫机身心永断。至坐道场则曰心灭贪淫持佛净戒。至於证果之初则曰除其助用刳其正性违其现业。又曰当观淫欲犹如毒蛇。又曰永断淫心先则执身不行次则执心不起。又曰心无贪淫。於外六尘不多流逸。尘即不缘根无所偶。身心快然。是人即得无生法忍。从是渐修安立圣位欲习初干则与如来法流水接等。由是观之则世出世间生与无生尽在淫心断与不断耳。至若七趣由情想以取升沉。三途因淫习而招剧苦及夫修禅之士以性欲而坏定心破法王而成魔属。毒哉此欲生死牢关。长羁三界之囹圄永坏涅盘之安宅者无尚此矣。苟非密严利器付之勇猛丈夫又何以拔之哉。由此欲习最极幽深。故世尊先放顶光以照之。无为化佛秘密心咒以破之。文殊大智以拔之。斯则往救之由以示全经大定之体矣。由是观之。因受欲为生死之根。大定为成佛之本。意谓非大觉不足以破大梦。非大法不足以除大患。斯实真妄两途觌体无二者矣。故於正示观相文中偈云如世巧幻师幻作诸男女。虽见诸根动要以一机抽。息机归寂然诸幻成无性。又曰静极光通达寂照含虚空。却来观世间犹如梦中事。摩登伽在梦谁能留汝形。谛观全经的指唯此一事。故知发启之由则见吾佛说之本意也。

○二正宗分大科分二

※初大开修证之门（从此起至第八卷卷中问结经名止）

※二曲示迷悟差别（从精研七趣详辨魔阴终止）

初开修证门中通分四科

△初开三种如来藏以显三观之体（此处初卷起至四卷中尚留观听止）

△二示三观之相（从请入华屋起至第七卷中作如是愿止）

△三显三观之用（从问四十四心起至第八卷中名邪观止）

△四结三观之名（文殊问结名止）

已上四科通属大开修证之门

◎初开空如来藏示空观之体（文有三卷分为二科）

□初约生灭门中抉择真妄以显本觉真心（经至二卷半）

□二约不生不灭会妄归真以显真空藏性（从会五蕴起至三卷终）

初中二

≡初当机请行

【阿难见佛。顶礼悲泣。恨无始来一向多闻未全道力。殷勤启请十方如来得成菩提妙奢摩他三摩禅那最初方便。於时复有恒沙菩萨及诸十方大阿罗汉辟支佛等。俱愿乐闻。退坐默然承受圣旨。】

议曰。此阿难因误堕而请行也。意谓妙奢摩他三摩禅那乃十方如来得成菩提之妙门。阿难从佛以来一向闻之熟矣。但以非己智分故。一向徒益多闻。不肯依之造修。所以未全道力。今因魔力所摄。乃知多闻无功。且自知爱习深厚此非大法不足以断之。必仗三观之力庶可消其欲漏。今将发愤造修。但不知最初下手工夫从何而入。故问最初方便。向后佛示妙行借二十五圣发挥。意显门门皆可还源。处处尽成解脱。但初心入处只观解结当心便是下手之处。不必别指何者为最初方便。即观音耳根正应此方之机耳。

≡二世尊曲示分四

●初正破五蕴八识以明人空

●二例破二种世界以明法空

●三显本觉离缘以示真如出缠

●四拂迹入玄以显真如绝待

初明人空分四

▲先征心破色受二蕴明前五识无体分六

◇初审发心

【佛告阿难。汝我同气情均天伦。当初发心於我法中见何胜相顿舍世间深重恩爱。阿难白佛。我见如来三十二相胜妙殊绝。形体映彻犹如琉璃。常自思惟。此相非是欲爱所生。何以故欲气粗浊。腥臊交媾。脓血离(**1)乱。不能发生胜净妙明紫金光聚是以渴仰从佛剃落】

◇二斥妄本

【佛言。善哉阿难。汝等当知一切众生从无始来生死相续。皆由不知常住真心性净明体。用诸妄想。此想不真故有轮转。汝今欲研无上菩提真发明性。应当直心酬我所问。十方如来同一道故出离生死皆以直心。心言直故。如是乃至终始地位。中间永无诸委曲相。】

◇三诘妄元

【阿难。我今问汝。当汝发心。缘於如来三十二相。将何所见。谁为爱乐。阿难白佛言。世尊。如是爱乐用我心目。由目观见如来胜相心生爱乐。故我发心愿舍生死。】

◇四审妄处

【佛告阿难。如汝所说真所爱乐因於心目。若不识知心目所在则不能得降伏尘劳。譬如国王为贼所侵发兵讨除。是兵要当知贼所在。使汝流转心目为咎。吾今问汝。唯心与目今何所在。】

议曰。阿难见佛首以三观为请。佛即不答。且先诘问发心出家舍爱之由。此似神医治病先审病根所在而后方施药石也。阿难答以由见如来三十二相胜妙殊绝心生渴仰爱乐从佛剃落即此一语便见病根。何耶。以见色相而生爱慕者正是妄想之心也。故曰若以色见我以音声求我是人行邪道不能见如来。此阿难见佛但爱色相而未见法身。用妄想心以爱舍爱岂真出家耶。此其爱习种子潜发现行。既爱如来安得不爱摩登耶。此乃因地发心不真果招纡曲。所以今日遭此淫室之难耳。且此妄想之心不独阿难。即一切众生无始以来生死相续皆由不知常住真心性净明体用诸妄想。此想不真故有轮转。阿难以此生死之心从佛安得而不堕耶。汝今欲研无上菩提以求真发明性殆非妄想可入。应当直心酬我所问。维摩经云直心是道场。起信论云。信成就发心略有三种。一者直心正念真如法故。二者深心乐集一切善行故。三者大悲心欲拔一切众生苦故。今如来先教阿难直心酬问。以心直则不欺。不欺则可诣真矣。因而再审阿难当初发心缘见如来三十二相将何所见谁为爱乐。此似神医按定病根可施必疗之药耳。阿难直心以答。乃曰由目观见心生爱乐。此正出病原。故如来告曰。若果爱乐因於心目此正生死之本也。故曰使汝流转心目为咎。如国被贼侵发兵讨除必须知贼所在。今汝六为贼媒自劫家宝者皆依心目为主使也。所谓擒贼擒王。今知心目为法身之害。必须知其所依之处乃可扫除荡灭以绝害源。故曰唯心与目今何所在。在即处也。故经即言无有是处。问破妄明文世尊但标指心目而科云所破五蕴八识者何也。答成佛之要乃一心三观。所破之妄唯五蕴八识。一大藏中诸大乘教显此而已。以众生所迷但执妄心居在身内。然身即有执受身。乃五识所依之根。实六贼所依之处。为色受二蕴。心即妄想为六识想蕴。见乃八识之见分即七识行蕴。此指八识见精为根为识蕴。故心目二妄该尽五蕴八识。经文昭然。但义旨幽潜。一向解者发明未透。学者尘浮未易入耳。起信论宗百部大乘乃立真如生灭二门。且从生灭门入真如门。论云。推求五阴色之与心六尘境界毕竟无念。以心无形相十方求之终不可得。此大教之纲宗也。苟不知所宗但见文字缠绕义无归宿矣。以此印定经文理自昭著。

【阿难白佛言。世尊。一切世间十种异生同将识心居在身内。纵观如来青莲华眼亦在佛面。我今观此浮根四尘只在我面。如是识心实居身内。佛告阿难。汝今现坐如来讲堂。观祗陀林今何所在。世尊。此大重阁清净讲堂在给孤园。今祗陀林实在堂外。阿难。汝今堂中先何所见。世尊。我在堂中先见如来。次观大众。如是外望方瞩林园。阿难。汝瞩林园因何有见。世尊。此大讲堂户牖开豁。故我在堂得远瞻见。】

◇五正示定体

【尔时世尊在大众中。舒金色臂摩阿难顶。告示阿难及诸大众。有三摩提名大佛顶首楞严王。具足万行。十方如来一门超出妙庄严路。汝今谛听。阿难顶礼。伏受慈旨。】


通议卷第一

通议卷第一

◇六正破妄处无体

【佛告阿难。如汝所言。身在讲堂。户牖开豁。远瞩林园。亦有众生在此堂中不见如来见堂外者。阿难答言。世尊。在堂不见如来能见林泉无有是处。阿难。汝亦如是。汝之心灵一切明了。若汝现前所明了心实在身内。尔时先合了知内身。颇有众生先见身中后观外物。纵不能见心肝脾胃。爪生发长筋转脉摇诚合明了。如何不知。必不内知云何知外。是故应知汝言觉了能知之心住在身内无有是处。阿难稽首而白佛言。我闻如来如是法音。悟知我心实居身外。所以者何。譬如灯光然於室中。是灯必能先照室内。从其室门后及庭际。一切众生不见身中独见身外。亦如灯光居在室外不能照室。是义必明将无所惑。同佛了义得无妄耶。佛告阿难是诸比丘适来从我室罗筏城。循乞抟食。归祗陀林我已宿斋。汝观比丘一人食时诸人饱不。阿难答言。不也。世尊。何以故。是诸比丘虽阿罗汉躯命不同。云何一人能令众饱。佛告阿难。若汝觉了知见之心实在身外。身心相外自不相干。则心所知身不能觉。觉在身际心不能知。我今示汝兜罗绵手。汝眼见时心分别不。阿难答言。如是。世尊。佛告阿难。若相知者云何在外。是故应知汝言觉了能知之心住在身外。无有是处。阿难白佛言。世尊。如佛所言。不见内故不居身内。身心相知不相离故不在身外。我今思惟知在一处。佛言。处今何在。阿难言。此了知心既不知内而能见外。如我思忖潜伏根里。犹如有人取琉璃碗合其两眼。虽有物合而不留碍。彼根随见随即分别。然我觉了能知之心不见内者为在根故。分明瞩外无障碍者潜根内故。佛告阿难如汝所言。潜根内者犹如琉璃。彼人当以琉璃笼眼当见山河见琉璃不。如是。世尊。是人当以琉璃笼眼实见琉璃。佛告阿难。汝心若同琉璃合者当见山河何不见眼。若见眼者眼即同境不得成随。若不能见云何说言此知了心潜在根内如琉璃合。是故应知汝言觉了能知之心潜伏根里如琉璃合无有是处。阿难白佛言。世尊我今又作如是思惟。是众生身腑藏在中窍穴居外。有藏则暗。有窍则明。今我对佛。开眼见明名为见外闭眼见暗名为见内。是义云何。佛告阿难。汝当闭眼见暗之时。此暗境界为与眼对。为不对眼。若与眼对暗在眼前云何成内。若成内者居暗室中无日月灯。此室暗中皆汝焦腑。若不对者云何成见。若离外见内对所成。合眼见暗名为身中。开眼见明何不见面。若不见面内对不成。见面若成。此了知心及与眼根乃在虚空。何成在内。若在虚空自非汝体。即应如来今见汝面亦是汝身。汝眼已知身合非觉。必汝执言身眼两觉应有二知。即汝一身应成两佛。是故应知汝言见暗名见内者无有是处。阿难言。我常闻佛开示四众由心生故种种法生。由法生故种种心生。我今思惟即思惟体。实我心性随所合处心则随有。亦非内外中间三处。佛告阿难汝今说言。由法生故种种心生随所合处心随有者。是心无体则无所合。若无有体而能合者则十九界因七尘合。是义不然。若有体者如汝以手自〖扌至〗其体汝所知心为复内出。为从外入。若复内出还见身中。若从外来先合见面。阿难言。见是其眼。心知非眼。为见非义。佛言。若眼能见。汝在室中门能见不。则诸已死尚有眼者应皆见物。若见物者云何名死。阿难。又汝觉了能知之心。若必有体。为复一体。为有多体。今在汝身为复遍体。为不遍体。若一体者则汝以手〖 扌至〗一支时四支应觉。若咸觉者〖扌至〗应无在。若〖扌至〗有所则汝一体自不能成。若多体者则成多人。何体为汝。若遍体者同前所〖扌至〗。若不遍者当汝触头亦触其足。头有所觉。足应无知。今汝不然。是故应知随所合处心则随有无有是处。阿难白佛言。世尊。我亦闻佛与文殊等诸法王子谈实相时。世尊亦言心不在内。亦不在外。如我思惟内无所见外不相知。内无知故在内不成。身心相知在外非义。今相知故。复内无见。当在中间。佛言。汝言中间。中必不迷。非无所在。今汝推中中何为在。为复在处。为当在身。若在身者在边非中。在中同内。若在处者为有所表。为无所表。无表同无。表则无定。何以故。如人以表表为中时。东看则西。南观成北。表体既混心应杂乱。阿难言。我所说中非此二种。如世尊言眼色为缘生於眼识。眼有分别色尘无知。识生其中则为心在。佛言。汝心若在根尘之中。此之心体为复兼二。为不兼二。若兼二者物体杂乱。物非体知。成敌两立。云何为中。兼二不成。非知不知。即无体性。中何为相。是故应知当在中间无有是处。阿难白佛言。世尊。我昔见佛与大目连须菩提富楼那舍利弗四大弟子共转法轮。常言觉知分别心性既不在内。亦不在外。不在中间。俱无所在。一切无着名之为心。则我无着名为心不。佛告阿难。汝言觉知分别心性俱无在者。世间虚空水陆飞行诸所物象名为一切。汝不着者为在为无。无则同於龟毛兔角。云何不着。有不着者不可名无。无相则无。非无则相。相有则在。云何无着。是故应知一切无着名觉知心无有是处。】

议曰。佛问阿难心目所在。阿难先答心在身内。此乃一切众生寻常所执无一不在身内者。以妄心妄执色身为所依之处。此正贼之所在也。然阿难端请三观而如来先征心目者来意深长。从来解者漫云七处征心。殊不知佛意所主。但见佛许大定竟不识三观所归。此从来经旨所以通途难明也。请试言之。原夫一真法界不生不灭常住真心。诸佛众生同禀此心。本源无二者也。良以众生无始无明一念不觉而有生灭。即此生灭与不生灭和合变此真心成阿赖耶识而为众生生死之根本。此识具有三分。一者业相。乃根本无明。即识之自证分。二者转相。乃转根本智而为妄见即识之见分。此见乃前七识之根。三者现相。即识之相分。乃因无明不觉覆蔽真心遂将灵明无相寂灭之真空变为顽然无知之虚空。故下经云迷妄有虚空。此顽空体中无明凝结遂变而为四大之妄色以为空中之世界。故云依空立世界。由妄见而对四大之妄色相待既久遂抟取四大之外色少分执为己有。而妄见吸揽居中色心和合执受无知之色以为我遂成五蕴之众生。故云想澄成国土知觉乃众生。此正众生由之而起也。自此众生但执五蕴身心为我。岂更知广大真心哉。所谓一迷为心汝定惑为色身之内也。今此阿难执心在内正以色身之内妄想之心为真心。所以只见形貌可爱。而不达色心本空也。依此五蕴妄分六根。六根对境复取四大所造五尘为我所受用而起六识妄生分别。起惑造业。职此之由。生死轮回。实从妄认五蕴身心为我。妄执为常。今将返妄归真必先破其五蕴之我执也。以其此执历劫根深非大定不足以破之。故如来将宣大定先审心目所在。据阿难所执心在身内即贼所据之处便可进而击破之。以由阿难向执为我。今一旦打破恐其惊怖。故摩顶安慰而告之曰。有三摩提名大佛顶首楞严王。具足万行十方如来一门超出妙庄严路。是知从此征心辩见以去直至二种妄见通破众生我法二执以显本觉真心皆借大定之力也。以先破五蕴假我众生妄执为常者。今七处征心之文名虽征心其实潜破色受二蕴耳。以妄想一向执受四大为我以为心在身内。是执色身为心所依之处也。由执心在身内则内求之而不得。执心在外则外索之而不得。因而展转七处推求竟不可得。足知妄身不有而执受以为我者皆虚妄矣。由是观之。七处征心之文实破色蕴而受蕴亦随破之矣。从此渐进而破想行识三蕴明文具在后文。此实通途大旨。智者请深观之。不然。何以世尊征心之初先许大定。而后竟无结指之文。岂如来说法为漫谈耶。

▲二斥妄心破想蕴以明六识无体分四

◇初当机重请定门

【尔时阿难在大众中。即从座起。偏袒右肩。右膝著地。合掌恭敬。而白佛言。我是如来最小之弟。蒙佛慈爱。虽今出家犹恃娇怜。所以多闻未得无漏。不能折伏娑毗罗咒。为彼所转溺於淫舍。当由不知真际所诣。惟愿世尊大慈哀愍。开示我等奢摩他路。令诸阐提隳弥戾车。作是语已五体投地。及诸大众倾渴翘伫。钦闻示诲。】

◇二世尊光示定体

【尔时世尊从其面门放种种光。其光晃耀如百千日。普佛世界六种震动。如是十方微尘国土一时开现。佛之威神令诸世界合成一界。其世界中所有一切诸大菩萨皆住本国合掌承听。】

议曰。即此一光全示定体也。由前世尊征问阿难心目所在阿难妄指心在身内。此一切众生之通病也。已蒙如来追征。阿难执定此身是实。故谓心在身内。由是展转七处推穷。了不可得。此则明知所执色身本不有矣。阿难未悟。故此责躬重请开示奢摩他路。殊不知如来先许大定然后征心。意要阿难直下顿悟四大本空五蕴非有。即是大定全体现前矣。若阿难果是伶俐汉一状领过则可截断葛藤喝散大众而楞严一会从此散扬矣。由其懵懂不知故劳我世尊多方开示。然而阿难所以不悟者皆由执此生死妄想误为真实故也。故此以下示二根本名破想蕴。将破妄想而如来先从面放种种光者。古德所谓有一无位真人在汝等面门放光动地。奈何诸人自昧。所以日用但认妄想。六根隔越。六尘障碍。今佛放此一光照破根尘识界一一本真。故云普佛世界。光明顿现翻破无明故云六种震动。根尘门头了无障碍故云合成一界。如此照用现前则不劳动步即澄道场。故光中菩萨皆住本国合掌听法。且此一光佛即密示大定全体矣。向下破妄显真。而所显此一段光明境界而已。若人了此光相又何别求佛法哉。阿难不悟故须次第一一开示。由破妄之初阿难重请奢摩他路。如来先以光相密酬也。

◇三总示颠倒根本

【佛告阿难。一切众生从无始来。种种颠倒。业种自然。如恶叉聚。诸修行人不能得成无上菩提乃至别成声闻缘觉。及成外道诸天魔王及魔眷属。皆由不知二种根本错乱修习。犹如煮沙欲成嘉馔。纵经尘劫终不能得。云何二种。阿难。一者无始生死根本。则汝今者与诸众生用攀缘心为自性者。二者无始菩提涅盘元清净体。则汝今者识精元明能生诸缘缘所遗者。由诸众生遗此本明。虽终日行而不自觉枉入诸趣。】

议曰。如来将演大定必先示以生死之本。故曰一切众生无始以来。种种颠倒由惑业也。惑乃发业润生二种无明。因此无明造种种业。故名业种。既有此业而苦果随之。故惑业苦三必同条如恶叉聚。恶叉毒树名。生子必三同一蒂。故以喻之。此惑正是大定之所破者故先示之。由此惑故诸修行人不能得成无上善提。乃至别成二乘外道诸天魔王。正为惑之所使。由不知真妄二种根本故错乱修习耳。二根本者。一者众生所迷生死根本。即汝今者用攀缘妄想心为自性者是也。二者诸佛所说菩提涅盘元清净体。即汝今者识精元明能生诸缘以认诸缘而遗失者是也。由诸众生失此本明。故枉受生死。识精乃八识之体。元明乃本觉妙明真心。由诸众生迷此本妙明心。变为识精而起妄想。意将先破妄想。次破识精。而本觉真心乃显。皆仗大定之功。故破妄之初揭而示之。以下破妄显真正示奢摩他乃归真之路。其所破者二颠倒耳。

◇四正示颠倒分三

★初诘颠倒之心分五 ☆初验诘妄心

【阿难。汝今欲知奢摩他路愿出生死。今复问汝。即时如来举金色臂。屈五轮指。语阿难言。汝今见不。阿难言见。佛言。汝何所见。阿难言。我见如来举臂屈指。为光明拳。耀我心目。佛言。汝将谁见。阿难言。我与大众同将眼见。佛告阿难。汝今答我如来屈指为光明拳耀汝心目。汝目可见。以何为心当我拳耀。阿难言。如来现今征心所在。而我以心推穷寻逐。即能推者我将为心。】

☆二斥妄想非真

【佛言。咄。阿难。此非汝心。阿难矍然避座合掌起立白佛。此非我心当名何等。佛告阿难。此是前尘虚妄相想。惑汝真性。由汝无始至於今生。认贼为子。失汝元常。故受轮转。】

议曰。此正破妄心以明第一颠倒也。如来将破妄心先审欲知奢摩他路者。意显从此已去即显大定之体也。奢摩他乃空观之名。而如来藏清净真心本无一法此即空观之体也。且此观体更无别法。但以妄心妄见分别缘尘故隐而不现。今若心见既破缘尘本空真心乃显。若了缘生无性即是真心。故向下阿难执妄心妄见分别缘尘以问。如来但据空藏定体以答。故此以去皆奢摩他路。故先揭示以破妄心。如来初审阿难出家之因。而答以由目见如来心生爱乐遂从出家。如来明告之曰使汝流转心目为咎。是的示阿难妄心妄见也。及先征心而七处求之皆不可得。名虽征心实要知妄身非所依处足显身本空矣。阿难未悟重请定门。如来妙辩先破妄心次破妄见。故今举拳以问阿难。汝目可见。以何为心。要显妄心本空。故重诘之。阿难仍指能推穷者我将为心。是执妄想生死之心为真实也。如来因而大斥之曰咄此非汝心。如来说法四十九年。今唯向阿难施此一喝。如金刚王宝剑。实能剿绝命根。可惜阿难不悟。又费婆心。以阿难从来但认此为真心。故今被喝乃矍然向佛。若此非我心当名何等。如来明告之曰此心正是分别前尘虚妄浮想乃六识攀缘之心耳。所谓妄有缘气于中积聚假名为心迷惑汝真性者。岂可以为真心乎。由汝无始以来认此为心。如认贼为子。故失本元常住真心。所以轮转生死耳。

☆三 诘六识无体

【阿难白佛言。世尊。我佛宠弟。心爱佛故令我出家。我心何独供养如来。乃至遍历恒沙国土。承事诸佛及善知识发大勇猛。行诸一切难行法事皆用此心。纵令谤法永退善根亦因此心。若此发明不是心者。我乃无心同诸土木。离此觉知更无所有。云何如来说此非心。我实惊怖兼此大众无不疑惑。唯垂大悲开示未悟。尔时世尊开示阿难及诸大众。欲令心入无生法忍。于师子座摩阿难顶而告之言。如来常说诸法所生唯心所现。一切因果世界微尘因心成体。阿难。若诸世界一切所有。其中乃至草叶缕结。诘其根元咸有体性。纵令虚空亦有名貌。何况清净妙净明心性一切心而自无体。若汝执吝分别觉观。所了知性必为心者。此心即应离诸一切色香味触。诸尘事业别有全性。如汝今者承听我法。此则因声而有分别。】

☆四 带显七识非真

【纵灭一切见闻觉知。内守幽闲犹为法尘分别影事。我非敕汝执为非心。但汝于心。微细揣摩。若离前尘有分别性即真汝心。若分别性离尘无体。斯则前尘分别影事。尘非常住若变灭时。此心则同龟毛兔角。则汝法身同于断灭。其谁修证无生法忍。即时阿难与诸大众默然自失。】

☆五 总责颠倒

【佛告阿难世间一切诸修学人。现前虽成九次第定。不得漏尽成阿罗汉。皆由执此生死妄想误为真实。是故汝今虽得多闻不成圣果。】

议曰。阿难一向误执妄想六识攀缘之心为真心。今被佛呵遂惊怖自失。乃以无心同诸土木为问。世尊真慈欲令阿难大众心入无生。恐其失措。乃摩顶抚慰。略示其真而告之曰。汝何自疑无心同土木耶。如来常说诸法所生唯心所现。一切世间依正因果因心成体。此真心也汝何不悟。且世界所有至微之物皆有体性。纵令虚空亦有名貌。何况清净妙净明心为一切心之性而自无体耶。真心有体而汝不悟。但执分别妄想以为真心。岂不谬耶。若汝执吝此分别心为真心者。若果是真心即当离诸六尘别有全体乃是真心。今离尘无体。非妄而何。且如汝今承听我法此则因声而有分别。若我无声则汝心亦无。此正缘尘分别之心。乃第六识分别妄想之心。尘亡而心亦灭矣。此句正破想蕴无体以显六识。下句带显七识非真。意谓不但六识分别妄想非真。纵汝灭却一切见闻觉知六用不行内守幽闲犹为法尘分别影事。此正七识执自内我为意识之根。正是生死根本。又岂可以认为真乎。佛意将破行蕴灭第七识故。预以此句为张本。然我非斥汝所执者定非心也。但是妄想非真心耳。故令微细揣摩。离尘有体即刻许是汝真心。若离尘无体尘灭而心亦随灭同于龟毛兔角矣。如此则法身同于断灭。其谁修证无生耶。阿难被破妄想不真则失其固有而了无归宿故默然自失。世尊总斥其非。曰诸修行人虽成九次第定不得成阿罗汉者皆由执此妄想误为真实。是故汝虽多闻不成圣果者职此之由也。阿罗汉但灭六识得出三界。以此印定足知是破想蕴。前破妄心。后破妄见。

★二诘颠倒之见分三

☆初当机重请

【阿难闻已。重复悲泪。五体投地。长跪合掌而白佛言。自我从佛发心出家恃佛威神。常自思维无劳我修将谓如来惠我三昧。不知身心本不相代失我本心。虽身出家心不入道。譬如穷子舍父逃逝。今日乃知虽有多闻若不修行与不闻等。如人说食终不能饱。世尊。我等今者二障所缠。良由不知寂常心性。惟愿如来哀愍穷露。发妙明心开我道眼。】

☆二光示一真

【即时如来从胸〖〗字涌出宝光。其光晃昱有百千色。十方微尘普佛世界一时周遍。遍灌十方所有宝刹诸如来顶。旋至阿难及诸大众。告阿难言。吾今为汝建大法幢。亦令十方一切众生获妙微密性净明心得清净眼。】

议曰。下破妄见也。阿难蒙佛一往开示。已信缘尘分别之心离尘无体。足知一向所执之心非真心矣。以此而推则前见佛之见亦非真也。故请发妙明心开我道眼。然以道眼印证足知此下破妄见也。然此妄见乃意识执外根身为我名分别我法二执为分别见。意根执内八识见分为我为俱生我法二执为俱生见。以根识相依总属妄想故云二障所缠。如来破妄之初先从胸〖〗字涌百宝光者。表此妄想原是如来藏心大智慧光。今迷之而为妄想故转此智光而为妄见。今将破妄故先放此光照彻十方一时周遍以为前相。且此一段光明圣凡共有。故灌十方佛顶旋至阿难及诸大众。要悟真心真见了此一段光明便是。以迷此智光转成妄心妄见。今欲转心见成此光明本自具足。唯在转变之间耳。若悟此真光顿获妙净明心得清净眼。心是皆真。此实如来建大法幢也。下文会见归心者。以阿难一向执知是心见是眼。不知眼非是见。故佛会见归心。以破小乘执见是眼。为下辩见之本。

☆三会见归心

【阿难。汝先答我见光明拳。此拳光明因何所有。云何成拳。汝将谁见。阿难言。由佛全体阎浮檀金〖赤色〗如宝山清净所生故有光明。我实眼观。五轮指端屈握示人故有拳相。佛告阿难。如来今日实言告汝。诸有智者要以譬喻而得开悟。阿难。譬如我拳。若无我手不成我拳。若无汝眼不成汝见。以汝眼根例我拳理。其义均不。阿难言。唯然世尊。既无我眼不成我见。以我眼根例如来拳。事义相类。佛告阿难。汝言相类是义不然。何以故。如无手人拳毕竟灭。彼无眼者非见全无。所以者何。汝试於途询问盲人汝何所见。彼诸盲人必来答汝。我今眼前唯见黑暗更无他瞩。以是义观。前尘自暗见何亏损。阿难言。诸盲眼前唯睹黑暗。云何成见。佛告阿难。诸盲无眼唯观黑暗与有眼人处於暗室。二黑有别为无有别。如是世尊。此暗中人与彼群盲二黑较量曾无有异。阿难。若无眼人全见前黑。忽得眼光。还於前尘见种种色。名眼见者。彼暗中人全见前黑。忽获灯光。亦於前尘见种种色应名灯见。若灯见者灯能有见自不名灯。又则灯观何关汝事。是故当知灯能显色。如是见者是眼非灯。眼能显色如是见性是心非眼。】

议曰。将破妄见如来举拳验见者。以小乘不知八识三分。只知六识。一向但执根识相生。故以眼能见。而不如此见在心也。此所谓愚者难分识与根耳。如来将欲会见归心。故举金拳以验。问曰汝将谁见。阿难答言我将眼见。此正执见在眼也。如来就拳以例眼根。我若无手则不成拳。汝若无眼岂无见耶。故引盲人是无眼也所见黑暗岂非见耶。其盲人与暗室中人所见黑暗无二。则知见不在眼明矣。若盲人忽得眼光名眼见者。则暗室中人忽得灯光应名灯见矣。岂有是理哉。以灯但能显色而已。其见在人。是知眼根但能显色而已。而此见性是心非眼。此乃会见归心。下正明颠倒破生死心。验明六识妄执五蕴身心为我计常无常。起颠倒见。谓凡夫妄执五蕴身心为常。以无常计常。二乘不了身心本是真常。妄计为无常。故云颠倒。正属阿含教义。敢如此解者后结颠倒文云则知汝身与诸如来清净法身比类发明。如来之身名正遍知。汝等之身号性颠倒。故知前文乃约身见所起妄想分别心也。

★三示颠倒之人分二 ☆初请

【阿难虽复得闻是言。与诸大众口已默然心未开悟。犹冀如来慈音宣示。合掌清心伫佛悲诲。】

议曰。阿难所执妄心有依色受二蕴业已被破。今会见归心则茫无归宿。故不知所请。是以口已默然心未开悟。但伫佛悲诲。

☆次答分六 ⊙初示凡夫颠倒

【尔时世尊舒兜罗绵网相光手开五轮指。诲敕阿难及诸大众。我初成道。於鹿园中。为阿若多五比丘等及汝四众。言一切众生不成菩提及阿罗汉。皆由客尘烦恼所误。汝等当时因何开悟今成圣果。时侨陈那起立白佛。我今长老。於大众中独得解名。因悟客尘二字成果。世尊。譬如行客。投寄旅亭。或宿或食。宿食事毕。〖亻叔〗装前途。不遑安住。若实主人自无攸往。如是思惟不住名客。住名主人。以不住者名为客义。又如新霁。清阳升天。光入隙中。发明空中诸有尘相。尘质摇动。虚空寂然。如是思惟澄寂名空摇动名尘。以摇动者。名为尘义。佛言如是。】

议曰。此破凡夫颠倒见以示迷也。破见之初。陡以客尘问之者。由凡夫妄执五蕴身心为常故起常见。如来借客尘以破之。盖客投旅亭食宿便行。若真主人自无攸往。此譬众生旅泊三界生死无常也。安可计为常乎。清阳升天尘动而空体寂然。此譬生灭无常也。如此无常安可妄计为常乎。此正凡夫颠倒也。

⊙二示二乘颠倒分二 ∨初示迷

【即时如来於大众中屈五轮指。屈已复开。开已又屈。谓阿难言。汝今何见。阿难言。我见如来百宝轮掌众中开合。佛告阿难。汝见我手众中开合为是我手有开有合。为复汝见有开有合。阿难言。世尊宝手众中开合。我见如来手自开合。非我见性有开有合。佛言。谁动谁静。阿难言。佛手不住。而我见性。尚无有静谁为无住。佛言如是。如来于是从轮掌中。飞一宝光在阿难右。即时阿难回首右盼。又放一光在阿难左。阿难又则回首左盼。佛告阿难。汝头今日何因摇动。阿难言我见如来出妙宝光来我左右。故左右观头自摇动。阿难。汝盼佛光左右动头。为汝头动为复见动。世尊。我头自动。而我见性。尚无有止。谁为摇动。佛言如是。】

议曰。此破二乘颠倒见以示迷也。如来屈指飞光验见不动。以二乘妄计五蕴身心为无常故生厌离。以不了众生如故。故如来将破妄见先屈指飞光以验。阿难既知头动而见不动则知身境本不动矣。又何计为无常耶。此已密示真常矣。客尘飞光皆印如是者谓阿难所对不谬也。

∨次诘责

【于是如来普告大众。若复众生以摇动者名之为尘。以不住者名之为客。汝观阿难头自动摇。见无所动。又汝观我手自开合见无舒卷。云何汝今以动为身以动为境。从始洎终念念生灭。遗失真性。颠倒行事。性心失真。认物为己。轮回是中自取流转。】

议曰。此总责二妄以驱凡圣之计也。意谓众生既知摇动名尘则生灭不常明矣。可计此生灭为常乎。二乘若知头动而见性不动则本自真常明矣。奚可计为无常乎。既知常无常义云何汝等以动为身以动为境。此二句经言含两意真妄齐驱。意谓即此无常之身境凡夫岂可认以为常耶。此责凡夫也。即此幻妄身境本是真常幻化空身即法身。二乘岂可认为无常耶。意责二乘也。由此妄计所以从始洎终念念生灭遗失真性颠倒行事。本有心性而失之。尔乃认物为己。所以轮回颠倒之中自取流转。斯乃总责颠倒也。

  大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第一

**1别经作杂字


通议卷第二

通议卷第二

大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第二

唐天竺沙门般刺密帝译
乌苌国沙门弥伽释迦译语
菩萨戒弟子清河房融笔受
明南岳沙门憨山释德清述

⊙三示外道断见颠倒

【尔时阿难及诸大众。闻佛示诲。身心泰然。念无始来失却本心。妄认缘尘分别影事。今日开悟。如失乳儿忽遇慈母。合掌礼佛。愿闻如来显出身心真妄虚实。现前生灭与不生灭。二发明性。时波斯匿王起立白佛。我昔未承诸佛诲敕。见迦旃延毗罗胝子。咸言此身死后断灭名为涅盘。我虽值佛。今犹狐疑。云何发挥证知此心不生灭地。今此大众诸有漏者咸皆愿闻。】

议曰。此出断见之疑也。阿难闻前开示客尘飞光以示身境动有不动则知生灭有不生灭义。业已领悟。但一向妄认缘尘分别之心为心。未见不生灭性。故愿闻世尊即在现前的示何者是真实。何者为虚妄。如何是生灭。如何是不生灭。令真妄二体了然分明。方自信不疑。此乃阿难心愿而未决。故匿王因之以请也。匿王先事外道姓迦旃延名迦罗鸠驮。计一切法亦有亦无。又外道名删〖门者〗夜毗罗胝子。而毗罗胝乃母号也。故云子。此计诸法自然。其西域外道虽多。而所计者不出断常二见。此二计断见者匿王已奉此法。故虽见佛尚执旧习只知死后断灭。今闻此心不生灭性犹怀狐疑故请发挥。大众愿闻。若悟不生灭心则阿难妄执之情自谢真常之性自显矣。然死后断灭之见不独西域。而此方亦多。谓人死清气归天。浊气归地。一灵真性还于太虚。此断灭之见也。若果还太虚则因果绝矣。岂不幸哉。

【佛告大王。汝身现在。今复问汝。汝此肉身为同金刚常住不朽。为复变坏。世尊。我今此身终从变灭。佛言大王。汝未曾灭云何知灭。世尊。我此无常变坏之身虽未曾灭。我观现前念念迁谢新新不住。如火成灰渐渐销殒。殒亡不息。决知此身当从灭尽。佛言。如是大王。汝今生龄已从衰老。颜貌何如童子之时。世尊。我昔孩孺肤腠润泽。年至长成血气充满。而今颓龄迫于衰耄。形色枯悴。清神昏昧。发白面皱。逮将不久。如何见比充盛之时。佛言大王。汝之形容应不顿朽。王言世尊。变幻密移。我诚不觉。寒暑迁流。渐至于此。何以故。我年二十虽号年少。颜貌已老初十岁时。三十之年又衰二十。于今六十又过于二。观五十时宛然强壮。世尊。我见密移。虽此殂落。其间流易且限十年。若复令我微细思惟。其变宁唯一纪二纪。实为年变。岂唯年变。亦兼月化。何直月化。兼又日迁。沈思谛观。刹那刹那念念之间不得停住。故知我身终从变灭。佛告大王。汝见变化迁改不停。悟知汝灭。亦于灭时汝知身中有不灭耶。波斯匿王合掌白佛。我实不知。佛言。我今示汝不生灭性。大王。汝年几时见恒河水。王言。我生三岁。慈母携我谒耆婆天。经过此流。尔时即知是恒河水。佛言大王。如汝所说二十之时衰于十岁。乃至六十日月岁时念念迁变。则汝三岁见此河时至年十三其水云何。王言。如三岁时宛然无异。乃至于今年六十二亦无有异。佛言。汝今自伤发白面皱。其面必定皱于童年。则汝今时观此恒河与昔童时观河之见有童耄不。王言。不也世尊。佛言大王。汝面虽皱。而此见精性未曾皱。皱者为变。不皱非变。变者受灭。彼不变者元无生灭。云何于中受汝生死。而犹引彼末伽黎等都言此身死后全灭。王闻是言信知身后舍生趣生。与诸大众踊跃欢喜得未曾有。】

议曰。此破外道断见也。阿难愿佛就在现前身心拈出不生灭性。此理甚难发挥。故借匿王开示。然匿王不但不知生灭即常。而且执死后断灭者也苟知灭元不灭则知生本无生。真常之义显矣。不灭之性死后难明。只就现前身心以验则可知矣。故问匿王汝此肉身为同金刚常住不朽为复变坏。此问为引终从变灭之言也。若就形骸而观其实迁变不常。以从生至幼从幼至壮从壮至老渐渐不同。至老衰朽终归于死。若就岁月而观其实迁流不住。以纪变而年化。月变而日迁。细而察之不唯时迁而刹那刹那念念不住。此皆身心生灭无常也。即此生灭有不生灭真常之性。何从而见耶。故世尊乃诘观河之见以印证之。三岁观河以至于老。形骸虽变而见水之见性不变。即此不变之性乃真性也。以此足证变者受灭。而不变之性云何受汝生死耶。此身虽谢真性常存。如何引彼末伽黎等都言死后断灭耶。真常之性即就此身于是乎显矣。王闻此言信知身死不入断灭。已上破外道断见竟。

⊙四示颠倒之状

【阿难即从座起。礼佛合掌。长跪白佛。世尊。若此见闻必不生灭。云何世尊名我等辈遗失真性颠倒行事。愿兴慈悲洗我尘垢。即时如来垂金色臂。轮手下指。示阿难言。汝今见我母陀罗手为正为倒。阿难言。世间众生以此为倒。而我不知谁正谁倒。佛告阿难。若世间人以此为倒。即世间人将何为正。阿难言。如来竖臂兜罗绵手上指于空则名为正。佛即竖臂。告阿难言。若此颠倒首尾相换。诸世间人一倍瞻视。则知汝身与诸如来清净法身比类发明。如来之身名正遍知。汝等之身号性颠倒。随汝谛观。汝身佛身称颠倒者。名字何处号为颠倒。于时阿难与诸大众。瞪懵瞻佛目睛不瞬。不知身心颠倒所在。】

⊙五正责颠倒

【佛兴慈悲。哀愍阿难及诸大众。发海潮音。遍告同会诸善男子。我常说言色心诸缘。及心所使。诸所缘法。唯心所现。汝身汝心皆是妙明真精妙心中所现物。云何汝等遗失本妙圆妙明心宝明妙性。认悟中迷。】

议曰。阿难闻佛开示观河之见生灭中有不生灭。则前见拳之见即此见性。信知真性本不曾失。云何世尊独许匿王而说我等遗失真性。原不颠倒云何见责我等颠倒行事耶。此阿难其实未见真性。乃认妄为真。不知颠倒所在也。故世尊以垂手示之。且天然垂手而人以为倒。是犹身境本自真常而返生厌离。此二乘外道之颠倒也。竖臂是倒而返以为正。是认生灭无常而妄计为常。此凡夫之颠倒也。然唯我一臂耳。本无正倒。但以首尾相换妄生分别。世人一类如此瞻视。倍犹类也。如来法身与汝等色身皆一身也。若比类发明如来之身名正遍知汝等之身号性颠倒。以如来法身安然自在。汝等之身妄计断常。此所以为颠倒也。世尊意要阿难即色身以悟法身。故问阿难随汝谛观汝身佛身何处名为颠倒耶。阿难大众向以执迷故懵然不知颠倒所在。佛兴慈悲遍告同会曰。我常说言色心诸缘及心所使诸所缘法唯心所现。色十一色法也。心四蕴八识也。诸缘尘根也。心所使五十一心所也。诸所缘法根身器界一切万法也。皆唯心所现。以此而观足知汝身汝心皆是妙明真精妙心中所现物。如何但认幻妄身心而遗失本妙圆妙明心宝明妙性认悟中迷。以本来不迷。由汝认妄失真所谓悟中迷。此即颠倒所在也。

⊙六示迷悟同源

【晦昧为空。空晦暗中结暗为色。色杂妄想想相为身。聚缘内摇。趣外奔逸。昏扰扰相以为心性。一迷为心决定惑为色身之内。不知色身外洎山河虚空大地咸是妙明真心中物。譬如澄清百千大海弃之惟认一浮沤体。目为全潮。穷尽瀛渤。汝等即是迷中倍人。如我垂手等无差别。如来说为可怜愍者。】

议曰。由说一切诸法唯心所现恐当机难悟。故推原迷倒之由以示迷悟同源唯心之旨以破颠倒之妄心妄见也。意恐转计一切诸法及此身心既唯心所现然则何以迷之耶。故推迷妄之由以发之。原夫一真法界如来藏清净真心本无身心世界之相也。但由真净界中一念妄动而成不觉之无明。以此无明盖覆真心遂将灵明廊彻之真空变为顽然无知之虚空故云晦昧为空。依此顽空无明凝结变成四大之幻色故云结暗为色。真心既迷即转本有之智光变为妄见。以此妄见对彼幻色。相待既久即抟取四大之少分妄见和合而为五蕴之身心。故云色杂妄想想相为身。执此妄身遂失本有之真性。但认聚缘内摇昏扰扰相以为自己之心性。是所谓性心失真也。既一迷广大之真心而据蕞尔幻妄之身心决定惑为色身之内矣。曾不知此色身外洎山河虚空大地咸是妙明真心中所现物耳。譬如弃大海而认一沤此已迷矣。且以一沤目为全潮又更迷也。是故汝等为迷中倍人。此正颠倒之状。如我垂手无异。故如来说为可怜愍者耳。

上从前二种根本以来破想蕴灭前六识明第一颠倒竟

▲三辩妄见破行蕴明七识无体分二

◇初破妄分五

★先征破分别妄见无体分四

☆初呈妄见

【阿难承佛悲救深诲。垂泣叉手而白佛言。我虽承佛如是妙音悟妙明心元所圆满常住心地。而我悟佛现说法音现以缘心允所瞻仰。徒获此心。未敢认为本元心地。愿佛衰愍宣示圆音拔我疑根。归无上道。】

议曰。此下明第二颠倒也。阿难向认介尔妄想颠倒之心为心。今蒙佛开示妙明广大真心诚所未闻。故感激垂泣。但以承佛妙音悟此妙心元所圆满。此则因闻法音以缘心而悟。非亲证也。未敢认为自己本元心地。哉请拔疑根。古人彻信自心直到不疑之地方为实证。阿难所悟但因声分别乃缘尘之心生灭心也。故属意根。所云认缘失真者此也

☆二拣妄缘不实

【佛告阿难。汝等尚以缘心听法。此法亦缘非得法性。如人以手指月示人。彼人因指当应看月。若复观指以为月体。此人岂唯亡失月轮。亦亡其指。何以故。以所标指为明月故。岂唯亡指。亦复不识明之与暗。何以故。即以指体为月明性明暗二性无所了故。汝亦如是。若以分别我说法音为汝心者。此心自应离分别音有分别性。譬如有客寄宿旅亭暂止便去终不常住。而掌亭人都无所去名为亭主。此亦如是。】

☆三示根识俱妄

【若真汝心则无所去。云何离声无分别性（下映前六识无体）。斯则岂唯声分别心。分别我容离诸色相无分别性。（下带显八识非真）如是乃至分别都无非色非空拘舍离等味为冥谛。】

☆四示可还非真

【离诸法缘无分别性。则汝心性各有所还。云何为主。】

议曰。此明第二根本故借见精以破七识无体将显识精为涅盘体也。以七识乃意识之根为分别性。但托六识分别以显其用。通属八识之见分。以缘内外亦名缘心。今离前尘则无体矣。故约缘尘以破。世尊告曰。汝等若以缘心听法此法但属所缘生灭心耳。非得离言法体也。然我所说法如以指指月示人而指非月也。离指方能识月。若以指当月则月指二体皆失明暗二性无所了矣。若以分别法音为汝心者此心自当离声有体。如客宿旅亭客去而亭主常住。若此分别果是汝之真心则应常住。如何离声无体耶。如此不但此心无体。即分别我容离诸色相亦无体也。此则总显六识分别之心无体。以六识依此七识而有分别。今既分别无体即显此识虚妄矣。不但分别非真。纵使分别都无非色非空。七识内缘离外五尘故非色。执内为我故非空。此正八识昏昧之体犹非真心。而拘舍离等昧为冥谛。此尚非真。况分别缘尘者乎。缘尘分别者乃七识为意之根故有分别。若离外尘无缘即内缘八识为自内我。故外道计此为神我。立此为冥初主谛。计以为常。依此生二十五法。拘舍离外道名也。因破七识带显八识为所执之我亦非真也。若离法缘无分别性则汝之心性各有所还云何为主。此结前起后。意在不还者为主。乃显真心耳。

★二姑借见精以拣缘尘分二

☆初请

【阿难言。若我心性各有所还。则如来说妙明元心云何无还。惟垂衰愍为我宣说。】

☆次答分三

⊙初立见精

【佛告阿难。且汝见我见精明元。此见虽非妙精明心。如第二月非是月影。汝应谛听。今当示汝无所还地。】

⊙二拣缘尘

【阿难。此大讲堂洞开东方。日轮升天则有明耀。中夜黑月云雾晦暝则复昏暗。户牖之隙则复见通。墙宇之间则复观壅。分别之处则复见缘。顽虚之中遍是空性。郁〖土孛〗之象则纡昏尘。澄霁敛氛又观清净。阿难。汝咸看此诸变化相。吾今各还本所因处。云何本因。阿难。此诸变化。明还日轮。何以故。无日不明明因属日是故还日。暗还黑月。通还户牖壅还墙宇。缘还分别。顽虚还空。郁〖土孛〗还尘。清明还霁。则诸世间一切所有不出斯类。汝见八种见精明性当欲谁还。何以故。若还于明。则不明时无复见暗。虽明暗等种种差别见无差别。】

⊙三示见性

【诸可还者自然非汝。不汝还者非汝而谁。则知汝心本妙明净。汝自迷闷丧本受轮。于生死中常被漂溺。是故如来名可怜愍。】

议曰。阿难闻说可还者非主。故请不还之真心也。以真心难明姑借见精以破之。以见乃杂于缘尘之中。而八识精明之体不属缘尘。故曰见精明元。此虽非真以元系真如所变。已切近于真故如第二月不离月体。非是水中之影也。若悟此见精不还则可了悟真心矣。前云认缘失真故约缘尘拣示不还之地。若诸缘净尽则真性自显矣。且见所缘者不过明暗通壅缘空尘霁八缘而已。且此八缘皆有所还。汝见八种之见精明性当谁还耶。诸可还者自非汝之真心明矣。其不还者岂非汝之真性而谁耶。是则真性在汝本自妙明。今自迷闷不悟丧失本有而受生死。是故如来说为可怜愍者此耳。

★三示见性离缘以显见精分四

☆初请不还

【阿难言。我虽识此见性无还。云何得知是我真性。】

议曰。阿难意谓我已知此不还之性矣。但不知此性如何即是我之真性也。此非呈悟正陈不悟之心也。盖此见虽破。以是八识之精光应五根而了境者。故姑借见精以为主。外拣缘尘以破之。若尘亡而此见亦泯矣。故先揩定见量。拣缘尘而后破。

☆二定见量

【佛告阿难。吾今问汝。今汝未得无漏清净。承佛神力见于初禅得无障碍。而阿那律见阎浮提如观掌中庵摩罗果。诸菩萨等见百千界。十方如来穷尽微尘清净国土无所不瞩。众生洞视不过分寸。】

☆三拣缘尘

【阿难。且吾与汝观四天王所住宫殿。中间遍览水陆空行。虽有昏明种种形像。无非前尘分别留碍。汝应于此分别自他。今吾将汝择于见中。谁是我体谁为物象。阿难。极汝见源。从日月日宫。是物非汝。至七金山周遍谛观。虽种种光亦物非汝。渐渐更观云腾鸟飞风动尘起树木山川草芥人畜咸物非汝。】

☆四示见精

【阿难。是诸近远诸有物性虽复差殊。同汝见精清净所瞩。则诸物类自有差别。见性无殊。此精妙明诚汝见性。】

议曰。此正示见精明元也。以见乃八识之精光。映五尘而了境。故名缘尘之见。若就初照境时即名现量。正属八识精明之体。若第二念起心分别则名比量。乃属意识。前约八还以破。乃破缘尘分别之见。犹属比量。今约现量以显见精。故科云揩量以破也。且声闻菩萨与佛及众生虽圣凡各别。而照境之用广狭不同。都是八识现量见精所瞩。虽天地虚空万物杂陈，一见洞照。足知物异而见不异。此不异之见不杂于物者此精妙明诚汝之见性也。若知此性则可超悟真性矣。

★四破转计见精是物分一

☆初破转计

【若见是物则汝亦可见吾之见。若同见者名为见吾。吾不见时何不见吾不见之处。若见不见自然非彼不见之相。若不见吾不见之地自然非物。云何非汝。又则汝今见物之时。汝既见物。物亦见汝。体性纷杂。则汝与我并诸世间不成安立。】

☆二示真见

【阿难。若汝见时是汝非我。见性周遍非汝而谁。云何自疑汝之真性性汝不真取我求实。】

议曰。此破转计也。由前指万物以示见精。诚恐阿难认见是物。故特示之曰。万物乃所见之境也。而见物之见精岂是物耶。若见是一物则尔我之见皆是物也。而汝亦可见我之见矣。若谬执谓同见一物即是见我之见者。然我离物之时汝何不见我不见之处耶。纵许汝能见我不见之处此但是汝之妄见自然非彼不见之相也。彼字佛自指也。作我字看。若不见我不见之地足知尔我之见皆非物也。即此离物之见岂非汝之见性乎。若必执见是物则物皆有见。彼此互见人物不分不成安立矣。此离物之见乃会见分而归识精。知此则可渐见真性矣。故特指归见性曰。汝见物时是汝之见而不预我。即汝之见物圆满而周遍者。岂非汝之真性而谁耶。且汝之见性圆明了了。云何自疑而不悟。此性是汝本具而不以为真。返取我言以为实。岂不误哉。

★五正破见量以显真心分二

☆初立量

【阿难白佛言世尊。若此见性必我非余。我与如来观四天王胜藏宝殿。居日月宫。此见周圆遍娑婆国。退归精舍只见伽蓝。清心户堂。但瞻檐庑。世尊。此见如是。其体本来周遍一界。今在室中唯满一室。为复此见缩大为小。为当墙宇夹令断绝。我今不知斯义所在。愿垂弘慈为我敷演。】

☆次正破

【佛告阿难。一切世间大小内外诸所事业各属前尘。不应说言见有舒缩。譬如方器中见方空。吾复问汝。此方器中所见方空。为复定方。为不定方。若定方者别安圆器空应不圆。若不定者在方器中应无方空。汝言不知斯义所在。义性如是云何为在。阿难。若复欲令入无方圆。但除器方。空体无方。不应说言更除虚空方相所在。若如汝问。入室之时缩见令小。仰观日时汝岂挽见齐于日面。若筑墙宇能夹见断。穿为小窦宁无续迹。是义不然。】

◇二显真

【一切众生从无始来。迷己为物。失于本心。为物所转。故于是中观大观小。若能转物则同如来。身心圆明不动道场。于一毛端遍能含受十方国土。】

议曰。此正破除见量也。由迷真心而成阿赖耶识。此识具三分。一自证分。二见分。三相分。以无明力凝结既久遂成顽然无知之虚空而成四大之幻色。因此而有妄见。揽四大而成众生。故根身器界一切万物由之而起也。今将破妄显真故先拣去所缘之相分。姑显见性离缘令缘尘既消故能见亦泯。此所谓会妄见而归见精也。今见分既泯而见精独存。以八识未破此识现量虽能圆现根身器界。犹存限量。不能圆照法界。故有内外大小之隔。而疑夹绝之见也。若此量一破则根境两亡圆明普照十方矣。阿难问意经文可知。但破见量之说从前未发。苟不如此。何以此见一破即能一毛含受十方国土耶。世尊答意约器以破者。以此圆明妙心今在迷中而为根身器界之所局碍。若能内脱身心外遣世界则圆明妙体当下现前。故除器方而空体本无方圆也。不除虚空方相者此古德所谓不用求真唯须息见。若见量一泯则相分顿亡。此所谓若能转物即同如来。身心圆明不动道场。于一毛端遍能含受十方国土也。始因迷一心真如故转为妄相。今转妄相归一心故即同如来。如此深观方见如来说法之妙。以从悟至迷从细至粗法尔而有三细六粗之相。今破妄显真必须从粗至细渐诣真际也。论文昭然。以论勘经则一毛不爽。非是谬谈。智者请深观之。

从前阿难承佛悲救以来辩妄见破见分灭第七识行蕴以显分见真理明第二颠倒竟

▲四非见精破识蕴灭第八识的指正修行路分三

◇初破我执以显一真分三

★初当机出计

【阿难白佛言。世尊。若此见精必我妙性。今此妙性现在我前。（计即色是我）见必我真。我今身心复是何物。（计离色是我）而今身心分别有实。彼见无别分辩我身。（计我大色小色在我中）若实我心令我今见。见性实我而身非我。何殊如来先所难言物能见我。（计色大我小我在色中）唯垂大慈开发未悟。】

议曰。此下破八识自证分。潜破我执以显一真也。以一向七识执此识体为自内我。故二乘计此识为涅盘真我。外道执此为神我。故说我遍十方等。故曰。阿陀那识甚深细。习气种子成瀑流。我於凡愚不开演。恐彼分别执为我。此识世尊一向不轻谈者为是故也。阿难闻佛开示若能转物即同如来遂起执物是见之疑。就中潜计我见为请。意在破外道所执之我。以外道执此识为神我。而二乘执蕴即离我。故须代破。言虽不显。意实含之。乃曰若此见精必我妙性今此妙性现在我前者此字指前所转之物也。意谓若能转物即同如来。斯则现前一切万物皆是我之见精矣。此潜计即色是我也。见必我真我今身心复是何物者。意谓若此万物必是我之真见则彼物已是我矣。我今身心复是何物哉。此潜计离色是我也。而今身心分别有实彼见无别分辩我身者。意谓若物是我则身心非我矣。况今身心实有分别。彼物既是我何以不能分别我身耶。此潜计我大色小色在我中也。若实我心令我今见等者。意谓彼物若实是我心令我今见则彼之见性实是我而身心非我矣。如此则何殊如来先所难言物能见我。此潜计色大我小我在色中。总计外物是我也。此计从转物一语而起。故世尊向下就物择见。约即物以破之。前云若见是物盖彼认见作物也。今计认万物是见故不同耳。

★二世尊委破分二

☆初即物破是见

【佛告阿难。今汝所言见在汝前是义非实。若实汝前汝实见者。则此见精既有方所非无指示。且今与汝坐祗陀林。遍观林渠。及与殿堂。上至日月。前对恒河。汝今于我师子座前。举手指陈是种种相。阴者是林。明者是日。碍者是壁。通者是空。如是乃至草树纤毫。大小虽殊。但可有形。无不指着。若必其见现在汝前。汝应以手确实指陈。何者是见。阿难当知。若空是见既已成见何者是空。若物是见既已是见何者为物。汝可微细披剥万象。析出精明净妙见元。指陈示我。同彼诸物分明无惑。阿难言。我今于此重阁讲堂。远洎恒河。上观日月。举手所指。纵目所观。指皆是物。无是见者。世尊。如佛所说。况我有漏初学声闻。乃至菩萨。亦不能于万物象前剖出精见。离一切物别有自性。佛言。如是如是。】

议曰。世尊令阿难就物择见以显物非见精也。故先责所言见在汝前是义不然。若现前物实是汝之见精者则物物各有方所而汝见精必有方所可指陈矣。故令就此现坐祗林遍观种种诸物。但有形者一一指着。何者是见披剥万象析出精明指陈示我分明无惑。此令即物以辩我也。阿难领旨。答云不但声闻即菩萨大智亦不能于万物象前析出精见离一切物别有自性。佛言如是如是许其所对不妄也。

☆二即物破非见

【佛复告阿难。如汝所言无有见精离一切物别有自性。则汝所指是物之中无是见者。今复告汝。汝与如来坐祗陀林。更观林苑。乃至日月。种种象殊。必无见精受汝所指。汝又发明此诸物中何者非见。阿难言。我实遍见此祗陀林。不知是中何者非见。何以故。若树非见云何见树。若树即见复云何树。如是乃至若空非见云何见空。若空即见复云何空。我又思惟是万象中微细发明无非见者。佛言。如是如是。于是大众非无学者闻佛此言茫然不知是义终始。一时惶悚失其所守。如来知其魂虑变慑。心生怜愍。安慰阿难及诸大众。诸善男子。无上法王。是真实语。如所如说不诳不妄。非末伽黎四种不死矫乱论议。汝谛思惟。无忝衰慕。】

议曰。阿难认物为见精故世尊就物敕令指陈。今指择不出已知物不是见明矣。世尊仍令即物而指何者非见。阿难领旨。答云我又思惟是万象中微细发明无非见者。佛亦印许如是如是。问曰。阿难认物为见。世尊敕令就物指陈。而阿难已知物不是见。世尊已印许矣。又令阿难即物所指何者非见。阿难亦知即一切物无非见者。佛亦印许之。何耶。答曰。佛意端在直指一真了无是非之相。阿难大众不悟落在是非圈里。故茫然不知失其所守。至此则剿绝命根矣。如来知其魂虑变慑故怜愍安慰而暂纵之也。乃告之曰。法王所说是真实语。不同外道末伽黎等四种不死矫乱论议。谓矫智乱答无一定道理。世尊不然。以我法据真实义。不忝汝之衰慕也。以世尊自指非末伽黎四种不死矫乱论议。足知前破我执明矣。


通议卷第二

通议卷第二

★三文殊显真

【是时文殊师利法王子愍诸四众。在大众中即从座起。顶礼佛足。合掌恭敬而白佛言。世尊。此诸大众不悟如来发明二种精见色空是非是义。世尊。若此前缘色空等象。若是见者应有所指。若非见者应无所瞩。而今不知是义所归。故有惊怖。非是畴昔善根轻鲜。惟愿如来大慈发明此诸物象与此见精元是何物。于其中间无是非是。佛告文殊及诸大众。十方如来及大菩萨。于其自住三摩地中。见与见缘并所想相。如虚空华本无所有。此见及缘元是菩提妙净明体。云何于中有是非是。文殊。吾今问汝。如汝文殊。更有文殊。是文殊者。为无文殊。如是世尊。我真文殊。无是文殊。何以故。若有是者则二文殊。然我今日非无文殊。于中实无是非二相。佛言。此见妙明与诸空尘亦复如是。本是妙明无上菩提净圆真心。妄为色空及与闻见。如第二月。谁为是月。又谁非月。文殊。但一月真。中间自无是月非月。是以汝今观见与尘种种发明。名为妄想。不能于中出是非是。由是真精妙觉明性故能令汝出指非指。】

议曰。阿难大众不悟见精是非之义。故文殊特为启请也。以迷智而为识故妄见有根身器界一切万物种种差殊。是皆唯识所变现也。若转识成智则一切万物当下消亡。经云。得相是识。不得相是智。唯在转变之间耳。以一真之体全变而为阿赖耶识。故根身器界由之而起。若内脱身心外遣世界。即此识藏元是如来藏一真法界常住真心。又何有是非之相哉。以依识妄见故有是非。若以大智照之则了无彼此是非之相。此非大智不能洞然。故假文殊启请物与见精云何无是非是也。如来乃据大定而答曰。十方如来及大菩萨自住三摩地中以智而观则见与见缘并所想相如空中花本无所有。以此见及缘元是菩提妙净明体云何有是非是。此特示一真了无别法。可谓极尽开示矣。故文殊自谓但一真文殊。何有是非二相哉。佛言以此足知此见妙明与诸空尘本是妙明无上菩提净圆真心妄为色空及与闻见如第二月。若了知一月是真。自无是非之相矣。前破妄见乃约见精以破。故曰此见虽非妙精明心如第二月非是月影。今将破见精则曰唯一月真更无二月。此如来说法从粗至细渐引归真了然可见矣。若以妄想而观则不能出是非之外。若以妙觉明性而观故能令汝出指非指。至此一真之性于是乎显矣。

上破我执以显一真竟

◇二破自证以显一真分四

★初当机出计

【阿难白佛言。世尊。诚如法王所说觉缘遍十方界。湛然常住。性非生灭。与先梵志娑毗迦罗所谈冥谛。及投灰等诸外道种说有真我遍满十方。有何差别。世尊亦曾于楞伽山为大慧等敷演斯义。彼外道等常说自然。我说因缘非彼境界。我今观此觉性自然。非生非灭。远离一切虚妄颠倒。似非因缘与彼自然。云何开示不入群邪。获真实心妙觉明性。】

议曰。将破自证故阿难约自然以问也。自然者谓自体本然不假因缘。以真如在迷有自性可证。外道不知计为自然。故阿难假之以难请也。问有二义。一则承前世尊所示觉缘遍十方界。故疑与外道说有真我遍满十方相同。二则闻说觉性自然不属前尘。则妙性天然与彼外道所说自然何别

★二世尊委破分二

☆初破自然

【佛告阿难。我今如是开示方便。真实告汝。汝犹未悟。惑为自然。阿难。若必自然自须甄明有自然体。汝且观此妙明见中。以何为自。此见为复以明为自。以暗为自。以空为自。以塞为自。阿难。若明为自应不见暗。若复以空为自体者应不见塞。如是乃至诸暗等相以为自者。则于明时见性断灭。云何见明。阿难言。必此妙见性非自然。我今发明是因缘生。心犹未明。咨询如来。是义云何合因缘性。】

☆二破因缘

【佛言。汝言因缘。吾复问汝。汝今因见见性现前。此见为复因明有见。因暗有见。因空有见。因塞有见。阿难。若因明有应不见暗。如因暗有应不见明。如是乃至因空因塞同于明暗。复次阿难。此见又复缘明有见。缘暗有见。缘空有见。缘塞有见。阿难。若缘空有应不见塞。若缘塞有应不见空。如是乃至缘明缘暗同于空塞。】

★三的示精觉

【当知如是精觉妙明。非因非缘。亦非自然。非不自然。无非不非。无是非是。离一切相。即一切法。汝今云何于中措心。以诸世间戏论名相而得分别。如以手掌撮摩虚空只益自劳。虚空云何随汝执捉。。】

★四重拂妄计

【阿难白佛言。世尊。必妙觉性非因非缘。世尊云何常与比丘宣说见性具四种缘。所谓因空因明因心因眼。是义云何。佛言阿难。我说世间诸因缘相非第一义。】

议曰。阿难执谓觉性自然。世尊约境甄破。显自无体。则不属自然明矣。随复转计是因缘生。世尊即境按破不属因缘。盖此妙性不借缘生。不因境有。故直示精觉。乃曰当知如是精觉妙明不属一切因缘自然。超出是非之外。离一切相。即一切法。名言道断。心行处灭。云何于中措心以诸世间戏论名相而得分别耶。譬如以手撮摩虚空徒自劳耳。虚空云何随汝执捉耶。此直示一真觉性了无余蕴矣。如此开示阿难犹然不悟。仍执寻常所说因缘为疑。此正名言习气也。故世尊答曰非第一义。上破妄计以显一真竟

◇三破见精以示始觉分三

★初征破妄计

【阿难。吾复问汝。诸世间人说我能见。云何名见。云何不见。阿难言。世间人于日月灯光见种种相名之为见。若复无此三种光明则不能见。阿难。若无明时名不见者应不见暗。若必见暗此但无明云何无见。阿难。若在暗时不见明故名为不见。今在明时不见暗相还名不见。如是二相俱名不见。若复二相自相陵夺。非汝见性于中暂无。如是则知二俱名见。云何不见。】

★二的示始觉分二 ☆先拣缘

【是故阿难。汝今当知见明之时见非是明。见暗之时见非是暗。见空之时见非是空。见塞之时见非是塞。】

☆次的示

【四义成就。汝复应知见见之时见非是见。见犹离见。见不能及。云何复说因缘自然成和合相。】

★三结责劝修

【汝等声闻。狭劣无识。不能通达清净实相。吾今诲汝。当善思惟。无得疲怠妙菩提路。】

议曰。此破见精以显始觉也。一往辩见以来姑借见精先破缘尘分别之见。次破见分以显见精。以见相二分本同一体。元依识精所现。故物与见混而难分。故或认见是物。或执物是见。而起种种外道妄见。世尊即物以征其是非。今既蒙逐破见精。已显唯一真精更无别物超出是非之外。阿难一切自然因缘之疑已决矣。此乃泯见分而归识精也。但此见精犹属迷妄。正是无明。名为识蕴。故知第二月。若此不破难契本觉真心。故此一节乃破见精以示始觉之智也。且将破识精世尊犹以见与不见为审者。前乃对缘以辩。此乃离缘以辩。意显此见精不因境有。不借缘生。唯一精真切近真心。故此识一破则五蕴顿空。即名始觉之智矣。佛审阿难世人举皆说我能见。然云何名见。云何不见耶。阿难答以因明暗而有见。世尊破云。若见因明暗而有。且明去而见暗暗去而见明。是明暗自有去来。而汝见性非暂无也。是故明暗通塞自是前境。而此见精不因境有。不借缘生。唯一精见而已。此则前境既离而见精独显。犹属无明。故破之曰。汝复应知见见之时。见非是见。见犹离见见不能及。云何复说因缘自然及和合相耶。此乃正破识精也。见见之时见非是见者谓真见见于见精之时而真见非是见精也。且见精切近于真者尚犹离之。岂汝妄见而能及此真见乎。故曰见犹离见见不能及。是知此句乃的破见精明矣。此离妄之真见乃清净实相真心也。以汝等狭劣不能通达耳。此即是名始觉之智。以始觉有功本觉乃显。故此正示奢摩他路。吾今诲汝当善思惟。无得疲怠而不进修也。从初启请妙奢摩他以来至此。通破五蕴身心以显人空。故结指观名。以此正属我执。名为但空。以法执犹存。故下例破二种世界以破法执。

上破五蕴八识以明人空竟

●二例破二种世界本空以明法空分二

▲初当机呈请

【阿难白佛言。世尊。如佛世尊为我等辈宣说因缘及与自然诸和合相与不和合心犹未开。而今更闻见见非见重增迷闷。伏愿弘慈施大慧目。开示我等觉心明净。作是语已悲泪顶礼。承受圣旨。】

议曰。今破法执之初阿难且以闻前因缘自然然犹未明和合及不和合故云心犹未开。以前说五蕴不属因缘自然。但破假名而实法尚存。未达本空故心犹未开。今闻见五蕴之见亦非见故重增迷闷者正是二乘我执虽空法执未忘犹妄见有身心世界故觉心未净。所以重请开示也。

下答意总显五蕴不实例显世界本空

▲二世尊许说分二 ◇初许说诫听

【尔时世尊怜悯阿难及诸大众。将欲敷演大陀罗尼诸三摩提妙修行路。告阿难言。汝虽强记但益多闻。于奢摩他微密观照心犹未了。汝今谛听。吾当为汝分别开示。亦令将来诸有漏者获菩提果。】

◇二正示二妄分二 ★初总示

【阿难。一切众生轮回世间。由二颠倒分别见妄当处发生当业轮转。云何二见。一者众生别业妄见。二者众生同分妄见。】

★二别示分三 ☆初别业妄见

【云何名为别业妄见。阿难。如世间人目有赤眚。夜见灯光别有圆影五色重叠。于意云何。此夜灯明所现圆光为是灯色。为当见色。阿难。此若灯色。则非眚人何不同见而此圆影唯眚之观。若是见色。见已成色则彼眚人见圆影者名为何等。复次阿难。若此圆影离灯别有。则合傍观屏帐几筵有圆影出。离见别有应非眼瞩。云何眚人目见圆影。是故当知色实在灯。见病为影。影见俱眚。见眚非病。终不应言是灯是见。于是中有非灯非见。如第二月非体非影。何以故。第二之观捏所成故。诸有智者不应说言此捏根元是形非形离见非见。此亦如是目眚所成。今欲名谁是灯是见。何况分别非灯非见。】

☆二同分妄见

【云何名为同分妄见。阿难。此阎浮提除大海水中间平陆有三千洲。正中大洲东西括量大国凡有二千三百。其余小洲在诸海中。其间或有三两百国。或一或二至于三十四十五十。阿难。若复此中有一小洲只有两国。唯一国人同感恶缘。则彼小洲当土众生睹诸一切不祥境界。或见二日。或见两月。其中乃至晕适珊觖〖换王旁〗霓种种恶相。但此国见。彼国众生本所不见亦复不闻。】

☆三进退合明分三⊙初进别例同

【阿难。吾今为汝以此二事进退合明。阿难。如彼众生别业妄见瞩灯光中所现圆影。虽似前境。终彼见者目眚所成。眚即见劳非色所造。然见眚者终无见咎。例汝今日以目观见山河国土及诸众生。皆是无始见病所成。见与见缘似现前境元我觉明见所缘眚。觉见即眚。本觉明心觉缘非眚。觉所觉眚。觉非眚中。此实见见。云何复名觉闻知见。是故汝今见我及汝。并诸世间十类众生。皆即见眚非见眚者。彼见真精性非眚者故不名见。】

⊙二退同例别

【阿难。如彼众生同分妄见例彼妄见别业一人。】

⊙三进退合明

【一病目人同彼一国彼见圆影眚妄所生。此众同分所见不祥同见业中瘴恶所起。俱是无始见妄所生。例阎浮提三千洲中兼四大海娑婆世界并洎十方诸有漏国及诸众生。同是觉明无漏妙心见闻觉知虚妄病缘和合妄生和合妄死。】

上显法空竟

●三显本觉离缘以示真如出缠

【若能远离诸和合缘及不和合。则复灭除诸生死因。圆满菩提不生灭性。清净本心本觉常住。】

议曰。此以五蕴例破世界以破法执也。将破法执且云将演大陀罗尼诸三摩提妙修行路者。陀罗尼此云总持。盖前结劝无得疲怠妙菩提路者乃单示人空未显法空犹属但空。以法执未忘。今将示圆融空观之体。以举一即三言三即一。故云诸三摩提。今法执一破而空如来藏体顿显。且此空藏乃圆融之空体。总会万有。融归一心。故云总持三昧。此所以为诸三摩提妙修行路。义显真空乃即假之空非但空也。故佛责阿难强记多闻于奢摩他微密观照心犹未开。正指不悟本非因缘自然之旨。未达即假之空。故今重为开示也。然法执端是内之五蕴身心外及山河大地虚空世界二种实法而已。前云汝之身心外洎虚空山河大地皆是妙明真精妙心中所现物。譬弃百千大海认一浮沤目为全潮。是为颠倒。今将破二妄故先告阿难一切众生轮回世间由二颠倒分别见妄也。且此二妄从一真界中当处发生。既生此妄惑必有妄业。所谓动即有苦。故当业流转耳。云何二见。一者别业妄见。二者同分妄见。别业乃众生正报。各各五蕴之身心。是各人别业所感者。同分乃众生依报之世界。是大家同业所感者。以此二妄本来不有。良由真净妙明心中一念妄动而有无明。遂变真心而为阿赖耶识。故有见相二分。见为妄心。相为妄境。心境对待起惑造业。轮回生死实二妄之咎也。所谓见与见缘并所想相如空中华本无所有。故真心如好眼。妄心如眼眚。五蕴身心如灯上之圆影。四大山河如空中之狂华。若了目眚则二妄本空矣。故约目眚以破之。云何名为别业妄见。别业者乃众生正报各各五蕴之身心。要显五蕴本空元依见妄而有。故譬目有赤眚夜见灯光五色圆影。好眼灯光总喻真心。眚喻妄见。影喻五蕴。故即灯离灯以辩之。本无所有岂可以是非论之哉。色实在灯喻妄不离真也。见病为影喻因迷有妄也。影见俱眚喻心境俱迷也。觉迷迷灭故见眚非病。又喻如第二月足知了无是非之相矣。苟知二月是捏目所成则知影见乃目眚之咎。又何于灯起是非之妄计哉。了此足知五蕴本空。则因缘自然之疑可决矣。云何名为同分妄见。同分者乃十方众生同感依报之世界。欲显世界不有元依见妄所生。故以南阎浮提大小多国之灾祥不一明之。但一国人同感恶缘则一国人同见不祥。彼无恶者本不见闻。是知秽土众生乃恶业之所感。而净土中人本不见耳。所谓大火所烧时我此土安隐。以本不见有秽恶也。吾今以此二事进退合明。谓进别业以例同分。退同分以例别业。以五蕴本空易悟。世界不有难明。故假二事进退合而明之耳。即彼众生别业妄见五蕴身心如见灯光所现圆影。然影虽似有。毕竟是目眚所成。非灯本有也。若知是眚者则无见病矣。以此例汝观见山河国土及诸众生皆是无始无明见病之所成耳。见与见缘似现前境本非实有。元是我觉明之无明故妄见有所缘之眚耳。是则若觉若见皆即眚也。其本觉明心觉了诸缘者则非眚矣。然觉其所觉是眚此真觉也。真觉岂堕于妄觉之中哉。故曰觉非眚中。此实见见。因阿难前云今闻见见重增迷闷故佛以觉所觉眚觉非眚中以释见见之疑也。以此证成。则上见乃真觉。下见为目眚。眚乃妄见。正指无明识精也。此如来自释。明文昭然。不必异解。且识精乃见之精者。以真智而观犹是眚妄。云何觉闻知见而可及哉。是所谓见犹离见见不能及也。当知一真界中生佛本无。汝今见有佛有众生者皆是妄见之眚非见眚者也。彼妙见真精性非眚者远离诸妄故不名见耳。此上进别业以例同分。合而观之。则世界本空可知矣。故又退同分以例别业。即此众生同分妄见例彼别业妄见一人。以一病目人所见之圆影乃眚妄所成。例彼一国所见之不祥同是恶业之所起。而此国界俱是无始见妄之所生。以此一国例阎浮提并洎十方诸有漏国及诸众生。同是觉明无漏妙心见闻觉知。谓因无明迷此无漏妙心而妄为见闻觉知虚妄之病缘根境和合而妄生妄死耳。由是观之则五蕴身心外及虚空山河大地当下消亡了无寄矣。故知例破二种世界以显法空也。二执既破则始觉有功本觉乃显。总结本觉离缘以示真如出缠。故曰若能远离诸和合缘及不和合则复灭除诸生死因。圆满菩提不生灭性。清净本心本觉常住矣。从前征心辩见以来多方开示破妄显真。至此二执既破乃显本觉真心。然此犹是破和合识以显本觉。未极一心之源。向下更破始本和合之计方乃会归藏性耳。

上显本觉离缘以示真如出缠竟

●四拂迹入玄以显真如绝待分二

▲初世尊特示

【阿难。汝虽先悟本觉妙明性非因缘非自然性。而犹未明如是觉元非和合生及不和合。】

▲二重拂妄计分二 ◇初破和合

【阿难。吾今复以前尘问汝。汝今犹以一切世间妄想和合诸因缘性而自疑惑。证菩提心和合起者。则汝今者妙净见精为与明和。为与暗和。为与通和。为与塞和。若明和者。且汝观明。当明现前何处杂见。见相可辩杂何形像。若非见者云何见明。若即见者云何见见。必见圆满何处和明。若明圆满不合见和。见必异明。杂则失彼性明名字。杂失明性和明非义。彼暗与通及诸群塞亦复如是。复次阿难。又汝今者妙净见精为与明合。为与暗合。为与通合。为与塞合。若明合者。至于暗时明相已灭。此见即不与诸暗合云何见暗。若见暗时不与暗合。与明合者应非见明。既不见明。云何明合了明非暗。彼暗与通及诸群塞亦复如是。】

◇二破不和合

【阿难白佛言。世尊。如我思惟。此妙觉元与诸缘尘及心念虑非和合耶。佛言。汝今又言觉非和合。吾复问汝。此妙见精非和合者。为非明和。为非暗和。为非通和。为非塞和。若非明和。则见与明必有边畔。汝且谛观何处是明。何处是见。在见在明自何为畔。阿难。若明际中必无见者则不相及。自不知其明相所在畔云何成。彼暗与通及诸群塞亦复如是。又妙见精非和合者。为非明合。为非暗合。为非通合。为非塞合。若非明合。则见与明性相乖角。如耳与明了不相触。见且不知明相所在云何甄明合非合理。彼暗与通及诸群塞亦复如是。】

议曰。前已开示始觉有功本觉乃显。此所谓菩提心生生灭心灭犹属生灭。以有对待故也。阿难前间未明和合之义。向以始觉合乎本觉名究竟觉。将谓本觉真心亦因和合而起。故此重拂妄计。以显真心绝待观智俱泯。然后乃可妙契一心。故科名拂迹入玄。是知此中和合乃就真心以拣始觉。故不同前破和合识拣妄计也。此因阿难前云心犹未明故不待请问而告之曰。汝虽先悟本觉妙明性非因缘非自然性。而犹未明如是觉元非和合生及不和合。非和合生谓天然妙性不因修生不因和合而生也。及非不和合谓体绝妄缘。不与诸缘和合而未尝离缘也。然觉体明净难以措心。故借前尘妄想以发明之。乃曰吾今复以前尘问汝。汝今犹以一切世间妄想和合诸因缘性。指八识体名和合识。而自疑惑证菩提心和合起者。谓汝犹以夙习妄想妄谓菩提觉心亦从和合而起也。汝今即以妙净见精而推。为与前缘明暗通塞谁和合耶。所言和者如水乳和。合者如函盖合。所言和者杂而不分之义。且汝观明时何处杂见耶。下离即破。若明非见者则明既非见不当见明矣。此离不可也。若明即见者则明已成见不当更见矣。此即不可也。故曰云何见见。下一异破。若见是一则见已圆满又于何处和明耶。若明是一则明已圆满不应又与见和矣。意谓两物相杂乃可名和耳。此一不可也。若见必异明而言和者则杂而不分。若见若明两失之矣。岂可又言见明哉。此异不可也。既杂失明性而更言和明者此非义也。明既非和。则暗与通塞准可知矣。又汝今者妙净见精与明暗通塞如何而合耶。若与明合明灭则不当见暗以见随明灭故。若与暗合则暗谢自不当见明以见随暗谢故。了明若此。则暗与通塞准可知矣。阿难既蒙开示非和合义。故又转计云。如我思惟此妙觉元本非和合与诸缘尘及心念虑非和合耶。世尊破云。若非明和。则见与明各有边畔。若非明合。则见与明两相乖角。不相及矣。何以知其合不合耶。以此而推。足知妙净见精与诸缘尘若言和合及非和合皆不成矣。见精尚出是非之外。何况妙觉真心岂可以是非和合而计之哉。良以生灭与不生灭和合而成八识。故今破和合识则诸妄已尽。以始觉合乎本觉。观智俱泯。是非情忘。以显真如绝待。斯则寂灭一心于是乎见矣。

上约生灭门决择真妄以显本觉真心竟

□二约不生不灭会妄归真以显真空如来藏性分二

≡初直指一心

【阿难。汝犹未明一切浮尘诸幻化相当处出生随处灭尽。幻妄称相。其性真为妙觉明体。如是乃至五阴六入从十二处至十八界。因缘和合虚妄有生。因缘别离虚妄名灭。殊不能知生灭去来本如来藏常住妙明不动周圆妙真如性。性真常中。求于去来迷悟生死了无所得。】

议曰。此直指一心真源不生不灭如来藏性将以融会万法也。由迷此一心不生不灭与生灭和合成阿黎耶识。变起见相二分。为色心二法。内成五蕴之众生外及虚空之世界。诸所缘法悉现其中。良由众生不觉认缘失真故受轮转耳。阿难大悲示现假堕淫室之由全因妄认五蕴身心为误。故特请世尊开示十方如来得成菩提妙奢摩他三摩禅那最初方便。故世尊首破五蕴而指心目为咎。始从征心辩见以来总破妄心妄见而已。然则心见乃八识之见分。诸缘乃八识之相分。是为根本无明。由此无明不了诸相本空。故从前渐拣缘尘非有妄见本无。泯见相以归识精。破识精而归始觉。会始觉以归一心。而空如来藏体于是乎显矣。已前破妄所显之空名但空耳。以空而不能有故非真空。今将会五蕴根尘识界并及七大本如来藏妙真如性。是为即有之空名实相真空。方尽大乘圆融空藏之体。此非二乘所知。故世尊特告阿难曰。汝犹未明一切浮尘诸幻化相。当处出生随处灭尽。若了缘生如幻本自无生但幻妄称相而已。其性真为妙觉明体也。此则法法全真何有一法之妄相哉。如是则知五阴六入从十二处至十八界。此诸妄相。但是因缘和合虚妄有生。因缘别离虚妄名灭。汝等但见生灭之妄相。殊不能知生灭去来者本如来藏常住妙明不动周圆妙真如性也。了知藏性又何有生灭去来之幻妄哉。若以妄想而观则似有生死去来之相。若以正智而观性真常中求于去来迷悟生死了无所得矣。此特示一心真源而从前破妄所显者妙极于斯。向下五蕴三科七大一一会归藏性方尽真空之体也。

上直指一心竟

≡二顿融万法分三

●初会三科以显即事即理分四

▲初会五阴

◇一会色阴

【阿难。云何五阴本如来藏妙真如性。阿难。譬如有人以清净目观晴明空。唯一晴虚迥无所有。其人无故不动目睛瞪以发劳。则于虚空别见狂华。复有一切狂乱非相。色阴当知亦复如是。阿难。是诸狂华非从空来。非从目出。如是阿难。若空来者。既从空来还从空入。若有出入即非虚空。空若非空自不容其华相起灭。如阿难体不容阿难。若目出者。既从目出还从目入。即此华性从目出故当合有见。若有见者。去既华空旋合见眼。若无见者。出既翳空旋当翳眼。又见华时目应无翳云何晴空号清明眼。是故当知色阴虚妄本非因缘非自然性。】

议曰。此会色阴也。清净目喻真智。晴明空喻真理。瞪喻无明。劳喻妄见。狂华喻妄相。乃色阴也。约空目以辩无体。若了狂华不从空来。不从目出。则知色阴本无所有。全一虚妄也。

◇二会受阴

【阿难。譬如有人手足宴安百骸调适。忽如忘生性无违顺。其人无故以二手掌于空相摩。于二手中妄生涩滑冷热诸相。受阴当知亦复如是。阿难。是诸幻触不从空来。不从掌出。如是阿难。若空来者。既能触掌何不触身。不应虚空。选择来触。若从掌出应非待合。又掌出故合则掌知离则触入。臂腕骨髓应亦觉知入时踪迹。必有觉心知出知入。自有一物身中往来何待合知要名为触。是故当知受阴虚妄本非因缘非自然性。】

议曰。此会受阴也。宴安调适本无违顺诸受也。二手相摩则冷暖触现。约空掌以辩。不从空来不从掌出。足知触受无体。受阴本无所有。全一虚妄也

◇三会想阴

【阿难。譬如有人谈说酢梅口中水出。思蹋悬崖足心酸涩。想阴当知亦复如是。阿难。如是酢说不从梅生。非从口入。如是阿难。若梅生者。梅合自谈何待人说。若从口入。自合口闻何须待耳。若独耳闻。此水何不耳中而出。想蹋悬崖与说相类。是故当知想阴虚妄本非因缘非自然性。】

议曰。此会想阴也。谈说酢梅而口水出。思蹋悬崖而足酸涩。此陈妄想之状也。约梅口以辩想阴无体。如是酢说应云如是口水。然口水因谈梅而有。若此口水从梅而生则梅合自谈则水在梅不在口矣。若从口出且因闻谈梅而出则当是口闻不待耳矣。若独因耳闻谈梅而水出则此水当从耳出不从口矣。蹋崖相类。如是推穷则想无实体。足知想阴本无所有。全一虚妄也

◇四会行阴

【阿难。譬如暴流波浪相续。前际后际不相逾越。行阴当知亦复如是。阿难。如是流性不因空生。不因水有。亦非水性。非离空水。如是阿难。若因空生。则诸十方无尽虚空成无尽流世界自然俱受沦溺。若因水有。则此瀑流性应非水。有所有相今应现在。若即水性。则澄清时应非水体。若离空水。空非有外水外无流。是故当知行阴虚妄本非因缘非自然性。】

议曰。此会行阴也。瀑流相续以喻行阴之相也。此约四法以辩无体。谓因空因水即水性离空水。谓此流若因空而生则十方虚空成无尽流。是则空所遍处流亦遍满。一切世界皆沦溺矣。岂有是理哉。若因水有则此流性应在水外。以是水之所有故。若有所有相则今当止水。可指流性矣。若流是水性则流者是水而澄湛者应非水矣。若离空水且空不外于水水外则无流。如是推穷而此迁流之行阴竟何有耶。足知全一虚妄也

◇五会识阴

【阿难。譬如有人取频伽瓶塞其两孔满中擎空。千里远行用饷他国。识阴当知亦复如是。阿难。如是虚空非彼方来。非此方入。如是阿难。若彼方来。则本瓶中既贮空去。于本瓶地应少虚空。若此方入。开孔倒瓶应见空出。是故当知识阴虚妄本非因缘非自然性。】

议曰。此会识阴也。瓶喻中阴身。空喻识。两孔喻见闻。人死见闻闷绝故喻塞。识被业牵故喻往他国。若执有识体身往来者。此处识灭。往彼处生。如瓶盛此方虚空远饷他国。则本瓶地应少虚空。而彼处倒瓶应见空出。故知虚空不动。则识无去来。而以计识随生死去来者妄矣。由不达识体本空故。噫。如来妙辩推究曲尽其理。总显五阴本一虚妄了无实体。若知五蕴元无则真空藏性显矣。三科七大一一皆然。

大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第二


通议卷第三

通议卷第三

大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第三

唐天竺沙门般刺密帝译
乌苌国沙门弥伽释迦译语
菩萨戒弟子清河房融笔受
明南嶽沙门憨山释德清述

■二会六入 △初会眼入

复次阿难。云何六入本如来藏妙真如性。阿难。即彼目睛瞪发劳者。兼目与劳同是菩提瞪发劳相。因于明暗二种妄尘发见居中。吸此尘象。名为见性。此见离彼明暗二尘毕竟无体。如是阿难。当知是见非明暗来。非于根出。不于空生。何以故。若从明来暗即随灭。应非见暗。若从暗来明即随灭。应无见明。若从根生必无明暗。如是见精本无自性。若于空出前瞩尘象归当见根。又空自观何关汝人。是故当知眼入虚妄。本非因缘非自然性

议曰。此总征六入本如来藏也。说者暨以六入为六根。谓根乃六尘所入之处。谛观经义不然。以明言见精闻性等。岂浮尘根而可拟哉。经云。元以一精明分成六和合。此中特言见闻觉知盖推初分六湛之源也。意谓如来藏性唯一坚密身。了无能所。本不可入。良由一念妄动遂起无明。迷此真心而为八识。所谓识精元明也。以此识具有自证见相三分。由见相对等则吸习尘相中归藏识。以吸故名入。发起见闻觉知而为六用之元。湛渊之体因此而分。六受用根依之而立。以此遂为六尘所入耳。非谓浮尘根也。即彼目睛瞪发劳者兼目与劳同是菩提瞪发劳相。此言根识同源也。目根也。乃清净四大即无明壳属相分。为六根之元。劳指见分。为七识之元。菩提瞪发劳谓生相无明即自证分。意显相见同一自证。则根识同一识精元明之体。但因无明熏习而发见闻觉知以为六用之元耳。是知瞪喻无明。劳喻相见。同是菩提瞪发劳相。是则由无明力熏习真如故有八识三分耳。以此推之。若了三分无体元一真心。则根尘识三全无自性。故不属因缘自然。皆本如来藏妙真如性矣

△二会耳入

阿难。譬如有人以两手指急塞其耳。耳根劳故头中作声。兼耳与劳同是菩提瞪发劳相。因于动静二种妄尘。发闻居中。吸此尘象。名听闻性。此闻离彼动静二尘毕竟无体。如是阿难。当知是闻非动静来。非于根出。不于空生。何以故。若从静来动即随灭。应非闻动。若从动来。静即随灭。应无觉静。若从根生必无动静。如是闻体本无自性。若于空出有闻成性即非虚空。又空自闻何关汝入。是故当知耳入虚妄。本非因缘非目然性

议曰。此会耳入也。曰听闻性名闻性。拣鼻入也。辩无自性本如来藏矣

△三会鼻入

阿难。譬如有人急畜其鼻。畜久成劳。则于鼻中闻有冷触。因触分别通寨虚实。如是乃至诸香臭气。兼鼻与劳同是菩提瞪发劳相。因于通塞二种妄尘。发闻居中。吸此尘象。名臭闻性。此闻离彼通寨二尘毕竟无体。当知是闻。非通塞来。非于根出。不于空生。何以故。若从通来寨则闻灭。云何知塞。如因寨有通则无闻。云何发明香臭等触。若从根生必无通塞。如是闻机本无自性。若从空出是闻自当回臭汝鼻。空自有闻何关汝入。是故当知鼻入虚妄。本非因缘非自然性

议曰。此会鼻入也。亦曰闻性曰闻机义与耳同。在耳曰听闻。在鼻曰臭闻。体同而用异。所谓性中相知用中相背也

△四会舌入

阿难。譬如有人以舌舐吻。熟甜令劳。其人若病则有苦味。无病之人微有甜触。由甜与苦显此舌根不动之时淡性常在。兼舌与劳同是菩提瞪发劳相。因甜苦淡二种妄尘。发知居中。吸此尘象。名知味性。此知味性。离彼甜苦及淡二尘毕竟无体。如是阿难。当知如是尝苦淡知。非甜苦来。非因淡有。又非根出。不于空生。何以故。若甜苦来淡则知灭。云何知淡。若从淡出甜即知亡。复云何知甜苦二相。若从舌生必无甜淡及与苦尘。斯知味根本无自性。若于空出虚空自味非汝口知。又空自知何关汝入。是故当知舌入虚妄。本非因缘非自然性

议曰。此会舌入也。以舌抵物曰舐。吻唇吻也。曰知味性。又曰知味根。则根性一源也

△五会身入

阿难。譬如有人以一冷手触于热手。若冷势多热者从冷。若热功胜冷者成热。如是以此合觉之触显于离知。涉势若成因于劳触。兼身与劳同是菩提瞪发劳相。因于离合二种妄尘。发觉居中。吸此尘象。名知觉性。此知觉体。离彼离合违顺二尘毕竟无体。如是阿难。当知是觉。非离合来。非违顺有。不于根出。又非空生。何以故。若合时来离当已灭。云何觉离。违顺二相亦复如是。若从根出必无离合违顺四相。则汝身知元无自性。必于空出空自知觉何关汝入。是故当知身入虚妄。本非因缘非自然性

议曰。此会身入也。在身为觉名觉性也

△六会意入

阿难。譬如有人劳倦则眠。睡熟便寤。览尘斯忆。失忆为忘。是其颠倒生住异灭。吸习中归。不相逾越。称意知根。兼意与劳同是菩提瞪发劳相。因于生灭二种妄尘。集知居中。吸撮内尘。见闻逆流流不及地名觉知性。此觉知牲离彼寤寐生灭二尘毕竟无体。如是阿难。当知如是觉知之根。非寤寐来。非生灭有。不于根出。亦非空生。何以故。若从寤来寐即随灭。将何为寐。必（心？）生时有灭即同无。令谁受灭。若从灭有生即灭无。请知生者。若从根出寤寐二相随身开合。离斯二体此觉知者同於知华毕竟无性。若从空生自是空知何关汝入。是故当知意入虚妄。本非因缘非自然性

议曰。此会意入也。眠则为忘。寤则为忆。庄子其寐形交。其觉形开。故曰开合。忆则为生。忘则为灭。生法暂停曰住。住不久留曰异。谓吸撮此生住异灭为内法尘。较前指塞耳而有声。急畜鼻而有冷触。舌舐吻而有苦甜。手相摩而有冷暖。则知尘非外来。意显根尘识三唯识所变。且意吸生灭而为尘岂有实法哉。见闻逆流流不及地者。谓见闻等五根往外顺流缘五尘境。今不外缘但内缘五尘落谢影子生灭不停故云逆流。以生灭法尘但归意地。而八识本体非见闻所及故云流不及地名知觉性。以统收六根但云见闻觉知而已。一一辩妄无体皆本如来藏矣

■三会十二处

△初会色处

复次阿难。云何十二处本如来藏妙真如性。阿难。汝且观此祗陀树林及诸泉池。于意云何。此等为是色生眼见。眼生色相。阿难。若复眼根生色相者。见空非色色性应销。销则显发一切都无。色相既无谁明空质。空亦如是。若复色尘生眼见者。观空非色见即销亡。亡则都无谁明空色。是故当知见与色空俱无处所。即色与见二处虚妄。本非因缘非目然性

议曰。此总征十二处也。初约色尘以对眼根以显根尘十二处虚妄。说者谓十二处正破在色。经文明言即色与见二处虚妄。岂单在处耶。今皆无体则本如来藏矣

△二会声处

阿难。汝更听此祗陀园中。食办击鼓。众集撞钟。钟鼓音声前后相续。于意云何。此等为是声来耳边。耳往声处。阿难。若复此声来于耳边。如我乞食室罗筏城。在祗陀林则无有我。此声必来阿难耳处。目连迦叶应不俱闻。何况其中一千二百五十沙门。一闻钟声同来食处。若复汝耳往彼声边。如我归住祗陀林中。在室罗城则无有我。汝闻鼓声其耳已往擎鼓之处。钟声齐出应不俱闻。何况其中象马牛羊种种音响。若无来往亦复无闻。是故当知听与音声俱无处所。即听与声二处虚妄。本非因缘非自然性

议曰。此会声处也。声不来耳边耳不往声所。是则音声闻性两皆寂然。而妄生分别。二妄无体则本如来藏矣

△三会香处

阿难。汝又臭此炉中旃擅。此香若复然于一铢。室罗筏城四十里内同时闻气。于意云何。此香为复生旃檀木。生于汝鼻。为生于空。阿难。若复此香生于汝鼻。称鼻所生当从鼻出。鼻非旃檀云何鼻中有旃檀气称汝闻香。当于鼻入。鼻中出香说闻非义。若生於空空性常恒香应常在。何藉炉中惹此枯木。若生于木则此香质因爇成烟。若鼻得闻合蒙烟气。其烟腾空未及遥远。四十里内云何已闻。是故当知香鼻与闻俱无处所。即臭与香二处虚妄。本非因缘非自然性

议曰。此会香处也。香无定在。闻根本空。二皆无体则本如来藏矣

△四会味处

阿难。汝常二时众中持钵。其间或遇酥酪醍醐名为上味。于意云何此味为复生于空中。生於舌中。为生食中。阿难。若复此味住于汝舌。在汝口中只有一舌。其舌尔时已成酥味。遇黑石蜜应不推移。若不变移不名知味。若变移者舌非多体云何多味一舌之知。若生于食。食非有识。云何自知。又食自知即同他食。何预于汝名味之知。若生于空汝啖虚空当作何味。必其虚空若作卣味。既鹹汝舌亦鹹汝面。则此界人同于海鱼。既常受鹹了不知淡。若不识淡亦不觉鹹。必无所知云何名味。是故当知味舌与尝俱无处所。即尝与味二俱虚妄。本非因缘非自然性

议曰。此会味处也。约味以辩。味若生于舌则一舌而不能知多味。若生于食则食自知而无预于舌。若生于空则根尘无干何名知味。是知二皆无体则本如来藏矣

△五会触处

阿难。汝常晨朝以手摩头。于意云何。此摩所知谁为能触。能为在手。为复在头。若在于手头则无知。云何成触。若在于头手则无用。云何名触。若各各有则汝阿难应有二身。若头与手一触所生。则手与头当为一体。若一体者触则无成。若二体者触谁为在。在能非所。在所非能。不应虚空与汝成触。是故当知觉触与身俱无处所。即身与触二俱虚妄。本非因缘非自然性

议曰。此会触处也。约触以辩。以手摩头而为身之触也。若触在手头不应知。触若在头则不待手触。若头手皆有触则有二知应有二身。若头手是一则不成触。若头手二体则触无定在。是知觉触与身俱无处所二俱虚妄。此以自乎触身故一体二体以辩。毕竟无体则本如来藏矣

△六会法处

阿难。汝常意中所缘善恶无记三性生成法则。此法为复即心所生。为当离心别有方所。阿难。若即心者法则非尘。盖法已是心则非尘矣既非心所缘。云何成处。若离于心别在方所。则法自性为知非知。知则名心。异汝非尘同他心量。若有知而又异汝则非汝之法尘应同他心量矣即汝即心若有知而即汝之尘乃即汝之心矣云何汝心更二于汝。若异汝而非知者此尘即非色声香味。离合冷暖及虚空相当于何在。今于色空都无表示。不应人间更有空外纵计空外则心非所缘。处从谁立。是故当知法则与心俱无处所。则意与法二俱虚妄。本非因缘非自然性

议曰。此会法处也。约法尘以辩。以意中所缘善恶无记三性生成法则名为法尘。以此法尘唯意识所变。故即心离心推之。若此法尘即心而有法则是心而非尘矣。既非法尘则非汝心所缘之尘矣。云何成处耶。此言即心而有者妄矣。若此法尘离心而有必别有方所。若有方所则法自性为有知耶是无知耶。若知则非尘当名汝之心矣。若有知而又异于汝则非是汝之法尘应同他人之心量矣。且异汝而又有知而言即是汝之尘即是汝之心故云即汝即心。斯则云何汝心更二于汝耶。此则异汝而言有知者非也。若异汝而非知将为汝之法尘者此尘既非色声香味离合冷暖之实法又不同于虚空毕竟当何所在耶。此言离心而非知者妄矣。今于色空求之都无表示。不应人间更有空外而为汝之法尘也。此喻五尘之外别有法尘也。纵许法外有法则非汝心所缘之境矣。处从谁立耶。以此观之都无实体。一切总非。则空如来藏之义于是乎显矣

■四会十八界

△初会眼识界

复次阿难。云何十八界本如来藏妙真如性。阿难。如汝所明眼色为缘生于眼识。此识为复因眼所生以眼为界。因色所生以色为界。阿难。若因眼生既无色空无可分别纵有汝识欲将何用。汝见又非青黄赤白。无所表示。从何立界。若因色生空无色时汝识应灭云何识知是虚空性。若色变时汝亦识其色相迁变。汝识不迁界从何立。若从色变则识亦变界相自无。不变则恒。既从色生应不识知虚空所在。若兼二种眼色共生。合则中离。离则两合。体性杂乱云何成界。是故当知眼色为缘生眼识界三处都无。则眼与色及色界三。本非因缘非自然性

议曰。此征会十八界也。以根尘和合识生其中故就根尘以辩识无体。前后辩法要显无生之义。中论云。诸法不自生。亦不从他生。不共不无因。是故说无生。从根生自生也。从色生他生也。根尘合生共生也。虚空坐无因生也。此四生法前后间出。总显无生之义。所谓不生灭性即如来藏矣

△二会耳识界

阿难。又汝所明耳声为缘生于耳识。此识为复因耳所生以耳为界。因声所生以声为界。阿难。若因耳生。动静二相既不现前根不成知。必无所知。既无所知之境亦无能知之根知尚无成识何形貌。知根尚且无成所生之识作何形貌若取耳闻。无动静故闻无所成。闻性尚且无成云何耳形杂色触尘名为识界。即无动静又无耳根则耳识界复从谁立。若生于声。识因声有则不关闻。无闻则亡声相所在。识从声生若此识果从声生许声因闻而有声相是则识已被闻闻应间识不是闻声矣不闻非界。闻则同声。识已被闻谁知闻识。若无知者终如草木。不应声闻杂成中界。根尘既杂则中界不成界无中位则内外相复从何成。是故当知耳声为缘生耳识界三处都无。则耳与声又声界三。本非因缘非自然性

议曰。此会耳识界也。耳闻声尘故约动静以辩。若因耳生下约根以辩。若耳识但因耳生何假动静。若无动静则根不成知。必无所知之境。亦无能知之根。知根尚且无成而所生之识作何形貌。若取耳闻为根。无动静时则闻亦无成。闻性尚且无成岂有耳形杂色触尘便为耳识界耶。既无动静又无耳根则耳识界复从谁立。此计因耳生识者妄矣。若生于声下约境以辩。若耳识因声而生则此识因声而有。既因声有则不关汝闻性矣。若闻既是声则有闻便有声无闻则无声相所在矣。若果识从声生又许此声因闻而有声相。是则识已被闻。识既被闻则闻声应是闻识不是闻声矣。若不闻识又非声界。若是闻识则识已同声。识既同声已被闻矣。将谁又知闻识耶。若无知者则终如草木矣。此计因声生识者妄矣。不应声尘与闻根共处杂成中界。此破共生也。反覆推之根尘无体而识界竟从何立。识界既空则本如来藏矣

△三会鼻识界

阿难。又汝所明鼻香为缘生于鼻识。此识为复因鼻所坐以鼻为界。因香所生以香为界。阿难。若因鼻生则汝心中以何为鼻。为取肉形双爪之相。为取臭知动摇之性。若取肉形。肉质乃身身知即触。名身非鼻名触即尘。触即身尘不名鼻识鼻尚无名。云何立界。若取臭知。若以知性为鼻又汝心中以何为知。以肉为知。则肉之知元触非鼻。以空为知。空则自知肉应非觉。如是则应虚空是汝汝身非知。今日阿难应无所在。（知性尚无将何为鼻鼻根尚无又从何而生识耶）以香为知。知自属香何预于汝。若香臭气必生汝鼻。则彼香臭二种流气不生伊兰及旃檀木。二物不来汝自臭鼻为香为臭。臭则非香。香应非臭。若香臭二俱能闻者则汝一人应有两鼻。对我问道有二阿难。谁为汝体。若鼻是一香臭无二。臭既为香香复成臭。二性不有香尚无体界从谁立。若因香生。识因香有。香即是识如眼有见不能观眼。因香有故应不知香。知即非生。不知非识。若不知香即非鼻识。香非知有香界不成。识不知香因界则非从香建立。既无中间之识不成内外。根境彼诸闻性毕竟虚妄。是故当知鼻香为缘生鼻识界三处都无。则鼻与香及香界三。本非因缘非自然性

议曰。此会鼻识界也。辩识界文皆约根尘。独此一段有臭知之性。以从鼻形兼臭知性双辩无体也。谓若鼻识因鼻而生先审以何为鼻。是取肉形之相耶。为取臭知之性耶。若取肉形则肉质乃身也。若身知香名身则非鼻。名触即是身尘。而鼻尚无名云何立界。此计从肉鼻生者妄矣。若取臭知之性以为鼻者。则汝心中以何为知耶。若以肉为知则是肉之知元是身触非鼻识也。若以空为知则虚空是汝而汝身非知则阿难应无所在矣。此则知性尚无将何为鼻。此计以知为鼻者妄矣。若以香为知则知自属香何预于汝。若香臭气必生汝鼻则香臭不生伊兰及旃檀矣。二物不来汝自臭鼻为香为臭。若香臭齐闻则有两鼻。若鼻是一而香臭无二。臭既为香香复成臭。二性不有则香尚无体知从谁立。知尚无体识从何生。此计香为知者妄矣。若因香生下约境以辩。若鼻识因香而生。则此识亦因香有。香即是识。如眼不见眼。既因香有则识已是香应不更知香矣。若又知首即非从香生矣。若不知香则非鼻识矣。若香不待知而有则香界不成。若识不知香而因界则非从香建立矣。此计从香生识者妄矣。既无中间则内外不成。而闻香之识毕竟虚妄。三处都无而识自无体。无生之义于兹显矣

△四会舌识界

阿难。又汝所明舌味为缘生于舌识。此识为复因舌所生以舌为界。因味所生以味为界阿难若因舌生。则诸世间甘蔗乌梅黄莲石盐细辛姜桂都无有味。汝自尝舌为甜为苦。若舌性苦谁来尝舌。舌不自尝孰为知觉。舌性非苦。味自不生。云何立界。若因味生。识自为味。同于舌根应不自尝。云何识知是味非味。又一切味非一物生。味既多生识应多体。识体若一体必味生。鹹淡甘辛和合俱生诸变异相同为一味应无分别。分别既无则不名识。云何复名舌味识界。不应虚空生汝心识。舌味和合根尘共生即于是中元无自性云何界生。是故当知舌味为缘生舌识界三处都无。则舌与味及舌界三。本非因缘非自然性

议曰。此会舌识界也。若因舌生下。约根以辩。此识若因舌生何假众味而显也。若无众味当自尝舌为甜为苦。若舌成味谁来尝舌。舌不自尝谁为知觉。舌性非苦味自不生。此计从舌生识者妄矣。若同味生下约境以辩。此识若因味生则识自为味同于舌根。舌不自尝云何识知是味非味。又味非一物则识应多体。若识体是一而识从味生则识一而多味通成一味应无分别矣。既无分别何名舌识耶。此计从味生识者妄矣。根尘无体不应虚空生汝识也。若舌与味和合共生即于是中元无自性矣。从根生自生也。从味生他生也。和合共生也。从空生无因生也。前后皆据此义以显无生。独此段文最显。微细推穷三处都无。了无自体本如来藏矣

△五会身识界

阿难。又汝所明身触为缘生于身识。此识为复因身所生以身为界。因触所生以触为界。阿难。若因身生。必无合离二觉观缘身何所识。若因触生。必无汝身谁有非身和合离者。阿难。物不触知。（物不因触而有知）身知有触。（身因有知而即有触）知身即触（身知即因触而显）知触即身。（知触即因身而显是则身触不相离也）即触非身（若即触则非身矣）即身非触。（若即身则非触矣）身触二相元无处所。合身即为身自体性。（触若合身即为身自体而至触矣）离身即是虚空等相。（触若离身即是虚空）内外不成中云何立。中不复立内外性空。则汝识生从谁立界。是故当知身触为缘生身识界三处都无。则身与触及身界三。本非因缘非自然性

议曰。此会身识界也。若因身生下约根以辩。此识若从身生必无合离二缘则身何所识耶。是识不从身生也。若因触生下约境以辩。此识若因触尘而生是则但有触而无身矣。岂有非身而知合离者。且物不因触而有知。身因有知而即有触。知身则因触而显。知触即因身而显。是则身触不相离也。若即触则非身矣。若即身则非触矣。然则身触二相元无处所。若触合身即为身自体而非触矣。若触离身即是虚空相矣。内外性空则识从何以立界耶。一切无性而无生之义显矣


通议卷第三

通议卷第三

△六会意识界

阿难。又汝所明意法为缘生于意识。此识为复因意所生以意为界。因法所生以法为界。阿难。若因意生。于汝意中必有所思发明汝意。若无前法意无所生。离缘无形识将何用。又汝识心与诸思量兼了别性为同为异。同意即意云何所生。异意不同应无所识。若无所识云何意生。若有所识云何识意。唯同与异二性无成界云何立。若因法生。世间诸法不离五尘。汝观色法及诸声法香法味法及与触法。相状分明。以对五根。非意所摄。汝识决定依于法生。今汝谛观法法何状。若离色空动静通塞合离生灭。越此诸相终无所得。生则色空诸法等生。灭则色空诸法等灭。所因既无。因生有识作何形相。相状不有界云何生。是故当知意法为缘生意识界三处都无。则意与法及意界三。本非因缘非自然性

议曰。此会意识界也。意根约法尘以辩。意识无体。谓意识若从意根而生。然于根中必有所思之法尘方发明是汝之意根。若无法尘则意根尚无必无所生之识矣。若离所缘之法尘则根亦无形。纵有汝识将何所用。以无可分别故。此约根尘既无则识亦无体矣。下约同异以辩根识。又汝识心指意识也。与诸思量指七识意根也。此二兼有了别性。此识与根为同为异。同意即但是根。云何而为所生之识耶。若异意根则不同意应无所知之识。云何说名意根所生之识耶。若异意而又有知识。即名意根矣。云何意根而又识意根耶。且同异二妄尚无体性。而界云何立耶。此计从根生识者妄矣。下约尘辩。此识若因法尘而生。然世间诸法不离五尘。分明以对五根都有相状皆非意所摄。今汝谛观法尘之法作何相状。以法尘乃五尘谢落之影子。故约五尘对辩无体。五尘乃色空动静通塞合离生灭也。越此诸相终无所得。是则生但诸法等生。灭但诸法等灭。所因之法既无则因生之识作何形相耶。此计从尘生识者妄矣。根尘既空识界何有。则当下无生藏性显矣

从初卷阿难启请妙奢摩他以来至此。始则破妄显真。次则会汝归真。而所显之理从浅至深。总该四时所说之教。初征心辩见以破身见阿含教义也。破见分识精方等教义也。五蕴三科会归藏性根尘识界一一本空般若教义也。本如来藏妙真如性则法法全真通归实相法华终教义也。若下文七大遍周一一圆融周遍法界则引归华严理事无碍法界。总显三谛圆融空如来藏性以为空观之体。所谓融会入于如来妙庄严海。此通途之大旨也。按理而推是岂可局于时哉

上会三科以显即事即理竟

▲二会七大以显事理无碍分五

■初当机疑请

阿难白佛言。世尊。如来常说和合因缘。一切世间种种变化皆因四大和合发明。云何如来因缘自然二俱排摈。我今不知斯义所属。惟垂哀愍开示众生中道了义无戏论法

议曰。如来一往开示可谓理极情忘。而阿难犹执常谈因缘自然为疑者岂阿难颛愚至此耶。盖理有未尽故疑有未决。所以示同未悟耳。当机以中道之义为请。而此判属空藏者。所谓一空一切空无假无中无不空也

■二许说诫听

尔时世尊告阿难言。汝先厌离声闻缘觉诸小乘法。发心勤求无上菩提。故我今时为汝开示第一义谛。如何复将世间戏论妄想因缘而自缠绕。汝虽多闻。如说药人真药现前不能分别。如来说为真可怜悯。汝今谛听。吾当为汝分别开示。亦令当来修大乘者通达实相。阿难默然承佛圣旨

议曰。佛谓阿难厌离小乘勤求大法。已为开示第一义谛矣。而犹自妄想缠绕。良由一向多闻久执名言未有真修。如说药人真药现前不能分别也

■三总出妄计

阿难。如汝所言四大和合发明世间种种变化。阿难。若彼大性体非和合则不能与诸大杂和。犹如虚空不和诸色。若和合者同于变化。始终相成生灭相续。生死死生生生死死如旋火轮未有休息

■四特示一源

阿难。如水成冰冰还成水

议曰。此总答问义也。阿难执谓四大和合发明世间种种变化。以不达性真圆融周遍之理妄计和合。佛言大性若不和合则不能与诸大杂如。犹如虚空不和诸色。若和合者。则同于变化。生灭相续生生死死未有休息。是则不可言和合非和合也。若了真妄一体如水成冰冰还成水。则一切妄计当下情忘矣

■五遍示大性分七

△初示地大

汝观地性。粗为大地。细为微尘。至鄰虚尘析彼极微色边际相七分所成。更使鄰虚即实空性。阿难。若此鄰虚析成虚空。当知虚空出生色相。汝今问言由和合故出生世间诸变化相。汝且观此一鄰虚尘。用几虚空和合而有。不应鄰虚合成鄰虚。又鄰虚尘析入空者。用几色相合成虚空。若色合时合色非空。若空合时合空非色。色犹可析空云何合。汝元不知如来藏中性色真空性空真色。清净本然周遍法界。随众生心应所知量。循业发现。世间无知惑为因缘及自然性。皆是识心分别计度。但有言说都无实义

议曰。此示地大周遍也。意约体空以示性真。且此地大乃积微尘所成者。故析微尘以至鄰虚。析鄰虚以成虚空。由是而知虚空出生色相而地大之体本空也若言和合而成大地。此鄰虚尘用几虚空和合而有。以鄰虚极微乃地大之始也。若析鄰虚而为虚空当用几色相以合成虚空耶。若合色则非空。若合空则非色。色可析而空不可合。此计四大和合发明者妄矣。此地大体汝元不知如来藏中循业发现。本非和合而有也。若了循业发现则性真周遍之义显矣

△二示火大

阿难。火性无我寄于诸缘。汝观城中未食之家欲炊爨时。手执阳燧日前求火。阿难。名和合者如我与汝一千二百五十比丘今为一众。众谁为一。诘其根本各各有身。皆有所生氏族名字。如舍利弗婆罗门种。优楼频螺迦叶波种。乃至阿难矍昙种姓。阿难。若此火性因和合有。彼手执镜于日求火。此火为从镜中而出。为从艾出。为于日来。阿难。若日来者。自能烧汝手中之艾来处林木皆应受焚。若镜中出。自能于镜出然于艾镜何不熔。纡汝手执尚无热相。云何融泮。若生于艾。何藉日镜光明相接然后火生。汝又谛观镜因手执。日从天来。艾本地生。火从何方游历于此。日镣相远非和非合。不应火光无从自有。汝犹不知如来藏中性火真空性空真火。清净本然周遍法界。随众生心应所知量。阿难。当知世人一处执镜一处火生。遍法界执满世间起。起遍世间宁有方所。循业发现。世间无知惑为因缘及自然性。皆是识心分别计度。但有言说都无实义

议曰。此示火大周遍也。以手执镜于日求火。谛观此火不从日来。不从镜出。不从艾生。又非无从自有。则非和合明矣。汝犹不知如来藏中周遍法界。而性火真空本然周遍。故一处求火一处火生。若遍界求则满世间起。足知循业发现之义矣

△三示水大

阿难。水性不定流息无恒。如室罗城迦毗罗仙斫迦罗仙及钵头摩诃萨多等诸大幻师。求大阴精用和幻药。是诸师等于白月昼手执方诸承月中水。此水为复从珠中出。空中自有。为从月来。阿难。若从月来。尚能远方令珠出水所经林木皆应吐流。流则何待方珠所出。不流明水非从月降。若从珠出。则此珠中常应流水。何待中宵承白月昼。若从空生。空生无边水当无际。从人洎天皆同滔溺。云何复有水陆空行。汝更谛听月从天陟。珠因手持。承珠水盘本人敷设。水从何方流注于此。月珠相远非和非合。不应水精无从自有。汝尚不知如来藏中性水真空性空真水。清净本然周遍法界。随众生心应所知量。一处执珠一处水出。遍法界执满法界生。生满世间宁有方所。循业发现。世间无知惑为因缘及自然性。皆是识心分别计度。但有言说都无实义

议曰。此示水大周遍也。方诸水精珠者。但观其师以方诸求水。此水不从珠出。不从月来。不从空出。又非无从自有。汝尚不知如来藏中性水真空本然周遍元非和合。遍法界求满法界生。则循业发现可知矣

△四示风大

阿难。风性无体动静不当。汝常整衣入于大众。僧伽梨角动及傍人则有微风拂彼人面。此风为复出袈裟角。发于虚空。生彼人面。阿难。此风若复出袈裟角汝乃披风。其衣飞摇应离汝体。我今说法会中垂衣。汝看我衣风何所在。不应衣中有藏风地。若生虚空。汝衣不动何因无拂。空性常住风应常生。若无风时虚空当灭。灭风可见。灭空何状。若有生灭不名虚空。名为虚空云何风出。若风自生被拂之面。从彼面生当应拂汝。自汝整衣云何倒拂。汝审谛观整衣在汝。面属彼人。处空寂然不参流动。风自谁方鼓动来此。风空性隔非和非合。不应风性无从自有。汝宛不知如来藏中性风真空性空真风。清净本然周遍法界。随众生心应所知量。阿难。如汝一人微动服衣有微风出。遍法界拂满国土生。周遍世间宁有方所。循业发现。世间无知惑为因缘及自然性。皆是识心分别计度。但有言说都无实义

议曰。此示风大周遍也。风体难言故借整衣有风拂彼人面以辩性空。此如来妙辩最可思也。因整伽黎则有微风拂彼人面。此风为复出于袈裟。为发于空。为生彼人面。若出于袈裟则汝披风衣当飞摇而去矣。岂我衣中有藏风地耶。若生于空。空性常住而风亦常生。风灭而空亦当灭。若有生灭非虚空矣。若风自生被拂人面。既从彼面而生则当拂汝。云何彼人倒拂耶。三处无体岂成和合。汝宛不知如来藏中性风真空本然周遍。宁有方所。循业发现。非识心计度可知也

△五示空大

阿难。空性无形因色显发。如室罗城去河遥处。诸刹利种及婆罗门毗舍首陀兼颇罗堕旃陀罗等。新立安居凿井求水。出土一尺于中则有一尺虚空。如是乃至出土一丈中间还得一丈虚空。虚空浅深随出多少。此空为当因土所出。因凿所有。无因自生。阿难。若复此空无因自生。未凿土前何不无碍。唯见大地迥无通达。若因土出。则土出时应见空入。若土先出无空入者。云何虚空因土而出。若无出入。则应空土元无异因。无异则同。则土出时空何不出。若因凿出则凿出空应非出土。不因凿出凿自出土云何见空。汝更审谛谛审谛观。凿从人手随方运转。土因地移。如是虚空因何所出。凿空虚实不相为用。非和非合。不应虚空无从自出。若此虚空性圆周遍本不动摇。当知现前地水火风均名五大。性真圆融皆如来藏本无生灭。阿难。汝心昏迷不悟四大元如来藏。当观虚空为出为入为非出入。汝全不知如来藏中性觉真空性空真觉。清净本然周遍法界。随众生心应所如量。阿难。如一井空空生一井。十方虚空亦复如是。圆满十方宁有方所。循业发现。世间无知惑为因缘及自然性。皆是识心分别计度。但有言说都无实义

议曰。此示空大周遍也。虚空因色而显。以空是色之体。故假凿井以发明之。虚空融贯大地。但见色碍而不见空。因凿井出空则知虚空为处不遍矣。故曰喻如虚空遍至一切色非色处。今观凿井之空。不因土出。不因凿出。又非无因。若了此虚空性圆周遍则知现前地水火风均名五大。性真圆融本如来藏循业发现矣。岂以因缘自然而计度哉

此虚空并前四大皆八识之相分

△六示见大

阿难。见觉无知因色空有。如汝今者在祗陀林朝明夕昏。设居中宵白月则光黑月便暗。则明暗等因见分析。此见为复与明暗相并太虚空为同一体。为非一体。或同非同。或异非异。阿难。此见若复与明与暗及与虚空元一体者。则明与暗二体相亡。暗时无明明时无暗。若与暗一明则见亡。必一于明暗时当灭。灭则云何见明见暗。若明暗殊见无生灭一云何成。若此见精与暗与明非一体者。汝离明暗及与虚空。分析见元作何形相。离明离暗及离虚空。是见元同龟毛兔角。明暗虚空三事俱异从何立见。明暗相背云何或同。离三元无云何或异。分空分见本无是处云何非同。见暗见明性非迁改云何非异。汝更细审微细审详审谛审观明从太阳。暗随黑月。通属虚空。壅归大地。如是见精因何所出。见觉空顽非和非合。不应见精无从自出。若见闻知性圆周遍本不动摇。当知无边不动虚空并其动摇地水火风均名六大。性真圆融皆如来藏本无生灭。阿难。汝性沈沦不悟汝之见闻觉知本如来藏。汝当观此见闻觉知为生为灭。为同为异。为非生灭。为非同异。汝曾不知如来藏中性见觉明觉精明见。清净本然周遍法界。随众生心应所知量。如一见根见周法界。听臭尝触觉触觉知妙德莹然遍周法界。圆满十虚宁有方所。循业发现。世间无知惑为因缘及自然性。皆是识心分别计度。但有言说都无实义

议曰。此示见大周遍也。见大乃八识之见分。亦名见精。无知者以此见元是妙明之智光本无对待。今迷而为妄见。因对色空之妄境遂形了别。以本无所知故约明暗虚空一异以破。若一则既一于明而不到暗。必一于暗而不到明。两不相到则不能双见明暗矣。若异则离于虚空明暗之外别求此见形相而不可得。异此三处从何立见。且明暗相背难言或同。离三无体难言或异。空见不分难言非同。明暗迁而性不改难言非异。况见有知而空顽无知非和合矣。又非无从而有。毕竟无体。则见性本空。若见闻知性圆周遍本不动摇则知虚空并其四大性真圆融皆如来藏不生不灭性矣。汝曾不知如来藏中性见觉明本然周遍。但随众生心量循业发现耳。岂可以因缘自然计之哉

△七示识大

阿难。识性无源因于六种根尘妄出。汝今遍观此会圣众用目循历。其目周视但如镜中无别分析。汝识于中次第标指。此是文殊此富楼那此目犍连此须菩提此舍利弗。此识了知为生于见。为生于相。为生虚空。为无所因突然而出。阿难。若汝识性生于见中。如无明暗及与色空四种必无元无汝见。见性尚无从何发识。若汝识性生于相中不从见生。既不见明亦不见暗。明暗不瞩即无色空。彼相尚无识从何发。若生于空非相非见。非见无辩自不能知明暗色空。非相灭缘见闻觉知无处安立。处此二非。空则同无有非同物。纵发汝识欲何分别。若无所因突然而出。何不日中别识明月。汝更细详微细详审。见托汝睛。相推前境。可状成有。不相成无。如是识缘因何所出。识动见澄非和非合。闻听觉知亦复如是。不应识缘无从自出。若此识心本无所从。当知了别见闻觉知圆满湛然性非从所。兼彼虚空地水火风均名七大。性真圆融皆如来藏本无生灭。阿难。汝心粗浮不悟见闻发明了知本如来藏。汝应观此六处识心为同为异。为空为有。为非同异。为非空有。汝元不知如来藏中性识明知觉明真识。妙觉湛然遍周法界。含吐十虚宁有方所。循业发现。世间无知惑为因缘及自然性。皆是识心分别计度。但有言说者无实义

议曰。此示识大周遍也。识性无源因于六种根尘妄出。故约见相二分以破。八识假见分七识为根。以亲相分为境。离此二分别识牲本空。故曰识从何发。若生于空则非相非见。若非见则瞢然无辩。若非相则无前缘而见闻觉知无处安立矣。若言是空则同于无。若言是有又不同物。亦非无因突然而出。若此识心本无所从则知了别见闻觉知皆本无从。兼彼虚空地水火风均名七大性真圆融皆如来藏本无生灭矣。汝元不知如来藏中性识明知觉明真识。妙觉湛然遍周法界。含吐十虚循业发现。殊非妄心计度可知也

上约不生不灭会妄归真以显真空藏性竟

已上三科七大通云会妄归真以显真空藏性。而所显之理亦为门不同。按华严法界观门中有四句义。一会色归空。二明空即是色。三空色无碍。四泯绝无寄。今经三科会归藏性正当观中初句会色归空。当论中如实空义。今七大之文一一皆云性真圆融循业发现即当观中第二明空即是色第三空色无碍义。当论中如实不空义。论云。如实不空谓一切境界悉于中现。不出不入。不失不坏。今以论不空收入此经空藏体者以论宗楞伽等经理齐终教。此经引归性海带显圆融理该华严圆教。故以彼不空入此中空藏者义显妙有真空圆融无碍之空。非远离一切心境界相之空也。此空藏体即当华严理法界门。四句通收。十门齐会。若约七大色心周遍圆融则已带显观巾理事无碍十门中初二门义。以即真故相遍。由相遍故无碍。以此而观足见此经理收五教。是知向下显不空如来藏前当华严理事无碍法界后八门义若约毛端现刹尘里转轮则又带显事事无碍法界矣。义显此经为引摄教。以一切因果摄归果海故。请观法界观文决无疑矣

▲三当机领悟说偈陈情

尔时阿难及诸大众。蒙佛如来微妙开示。身心荡然得无挂碍。是诸大众。各各自知心遍十方。见十方空如观手中所持叶物。一切世间诸所有物。皆即菩提妙明元心。心精遍圆含裹十方。反观父母所生之身犹彼十方虚空之中吹一微尘若存若亡。如湛巨海流一浮沤起灭无从。了然自知获本妙心常住不灭。礼佛合掌得未曾有。于如来前说偈赞佛

议曰。此当机领悟也。阿难大众初但认蕞尔之身以为心在身内。今蒙如来微妙开示则各自知心遍十方矣。向以虚空为大。今悟妙心广大。故观十方空如手持叶物耳。向以目前诸物作障。不达唯心所出。今则了一切物皆即妙明真心。此心周遍含裹十方矣。向以只认父母所生之身为实而生爱恋。今则反观此身如十方空中之一尘。湛巨海浮一沤起灭无从了不可得矣。一向迷真但执妄想生灭为心。今则了悟自知获本妙心常住不灭矣。自非如来大悲开示何以一旦超悟至此哉。故说偈陈情赞佛

妙湛总持不动尊。首楞严王世希有

议曰。初句赞佛。此单赞佛法身。而三身具焉。不必别也。清净妙法身。湛然应一切。故曰妙湛。以此法身为诸法体。三德具足。故曰总持。佛身充满于法界。普现一切群生前。随缘赴感靡不周。而恒处此菩提座。故曰不动。举一体而具三身。故为圣中尊。所以单赞法身者。以阿难最初但见如来三十二相心托爱乐故从佛出家。以所见之佛不真而所发之心亦是妄想。今既蒙开示妙悟自心。乃见佛法身。故此特赞。此句有以三观配之者。若言法身则无不具矣。次句赞法。阿难初请妙奢摩他三摩禅那。佛许云有三摩提名大佛顶首楞严王。从前一往破妄显真以极一心之源。通显大定之空体。圆融三蹄总合真空。已悟此定体。故赞此法为世希有

销我亿劫颠倒想。不历僧祗获法身

议曰。此二句通陈获益也。从前所征破者而佛呵云皆由执此颠倒妄想误为真实。今皆了悟尽净消除。以前但认幻妄身心。今悟即此五蕴而顿获法身。不须更历僧祗。乃呈悟获益之速也。正所谓狂心不歇歇即菩提。胜净明心本周法界不从人得。何藉劬劳肯启修证也

愿今得果成宝王。还度如是恒沙众。将此深心奉尘刹。是则名为报佛恩

议曰。此陈愿也。初句已悟法身则成佛不远。依此修行则圣果可期。小乘一向未有成佛之心。今自信已心乃上求佛果也。次句谓下化众生也。小乘一向不肯利生。今悟无心外之众生。故愿度恒沙之众也。上求下化是谓深心将此深心以奉多佛。所感佛恩而无可报者唯此利生可报耳

伏请世尊为证明。五浊恶世誓先入。如一众生未成佛。终不于此取泥洹

议曰。此请佛加被以成大愿也。五浊恶世难入而今誓入。仗如来加被庶远魔事。故请证明。誓愿度尽众生方成佛道此大愿也。四十年来小乘一向未有发此愿也

大雄大力大慈悲。希更审除微细惑。令我早登无上觉。于十方界坐道场

议曰。此请益也。阿难虽悟法身。但初见道而已。犹有无明微细结惑深密难断。非已智可知。必仗雄猛慈悲之力方能破除。故请佛审谛一一破除。此惑一尽则成佛不远。故曰早登意欲速证菩提于十方现坐道声也

舜若多性可销亡。烁迦罗心无动转

议曰。此誓不退坚固心也。舜若多此云虚空。烁迦罗此云坚固。意谓虚空无形可使销亡。而我愿力坚固之心永无动转。此非大定之力何以有此愿力哉

前开空如来藏竟

大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第三


通议卷第四

通议卷第四

大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第四

唐天竺沙门般剌密帝译
乌苌国沙门弥迦释伽译语
菩萨戒弟子清河房融笔受
明南岳沙门憨山释德清述

●二开不空如来藏以示假观之体分三

■初当机疑请

尔时富楼那弥多罗尼子在大众中即从座起。偏袒右肩右膝著地。合掌恭敬而白佛言。大威德世尊。善为众生敷演如来第一义谛。世尊常推说法人中我为第一。今闻如来微妙法音。犹如聋人逾百步外聆于蚊蚋。本所不见何况得闻。佛虽宣明令我除惑。今犹未详斯义究竟无疑惑地。世尊。如阿难辈虽前开悟习漏未除。我等会中登无漏者虽尽诸漏。今闻如来所说法音尚纡疑悔

议曰。将显不空藏性。满慈示疑以请。深穷生起之由故有忽生之问。此先叙疑也。阿难以多闻无功故发启斯教。从前开示业已了悟法身自信成佛无疑矣。而满慈素推说法第一。既合闻开示尚未至无疑之地。足见此法非口耳所能入也

■二正述疑情分

○初疑真不容妄

世尊。若复世间一切根尘阴处界等皆如来藏清净本然。云何忽生山河大地诸有为相。次第迁流终而复始

○二疑四大相陵

又如来说地水火风本性圆融周遍法界湛然常住。世尊。若地性遍云何容水。水性周遍火则不生。复云何明水火二性俱遍虚空不相陵灭。世尊。地性障碍。空性虚通。云何二俱周遍法界。而我不知是义攸往。惟愿如来宣流大慈。开我迷云及诸大众。作是语已五体投地。钦渴如来无上慈诲

议曰。此呈疑致问也。满慈因前佛说根尘识界既皆如来藏性清净本然云何忽生山河大地诸有为相耶。是不知世界众生生起之由也。又闻七大遍周而地水火风齐遍法界。且水火相陵地空相夺。云何一一周遍耶。是不悟性真圆融之理也。此问彻底穷源。非如来一切种智何以能究本始之因哉

■三世尊（穴款）启分五

○初许说诫听

尔时世尊告富楼那及诸会中漏尽无学诸阿罗汉。如来今日普为此会宣胜义中真胜义性。今汝会中定性声闻及诸一切未得二空回向上乘阿罗汉等。皆获一乘寂灭场地真阿练若正修行处。汝今谛听当为汝说。富楼那等钦佛法音默然承听

议曰。此许说也。胜义中真胜义性。成识论胜义有四。一世间胜义谓蕴处界等。二道理胜义谓四谛法。三证得胜义谓二空真如。四胜义胜义谓一真法界此后正穷法界缘起。故说胜义中真胜义性也。阿练若此云寂灭处。华严说菩提场为阿兰若处。是所谓一乘寂灭场也。以法界性为本修因故是正修行处。下显不空空不空二种如来藏性。带显圆融法界。故佛许说意有所归也

○二示妄依真起分五

△初立一心为迷悟之本

佛言。富楼那。如汝所言清净本然云何忽生山河大地。汝当不闻如来宣说性觉妙明本觉明妙。富楼那言。唯然世尊。我当闻佛宣说斯义

△二双诘二门为生起之因

佛言。汝称觉明。为复性明称名为觉。（诘心真如门）为觉不明称为明觉（诘心生灭门）

议曰。此两诘妄源以示生起之由也。满慈问如来藏既清净本然则了无诸相矣。云何于清净界中忽生此物耶。忽生谓无故而起也。此推车拄壁之问最难措口。若在宗门只消一棒一喝便彻疑情。今教海穷源不得不逆推其始。故世尊婆心乃（穴款）启之。将明妄依真起。故先立一真法界之源以为迷悟之本。特拈常谈性觉妙明本觉明妙二语双启二门以诘满慈。谓汝称曰觉曰明。为是觉性本明不假明而明之称为觉耶。此诘真如门。为是觉性不明要将明以明之称为明觉耶。此诘生灭门。此世尊立定双关要引满慈所明一语以为造妄之端耳。佛性有三谓正因缘因了因。天然妙性本

自圆成。不借功勋故名正因。要假知识师缘开发 所谓佛种从缘起故名缘因。修而後悟故名了因。此中性觉妙明正因佛性也。本觉明妙了因佛性也。以借始觉之功而显本有。盖属修而後成者也。此二佛性总会一心故双举以立宗本

△三认妄失真

富楼那言。若此不明名为觉者。则无所明

议曰。佛意要引满慈所明一语以启迷妄之端。而满慈果认生灭之觉。谓若不假明以明此觉者则但有其明而无所明之觉矣。意要必有所明方为明觉也

△四生灭门中依无明不觉生三细

佛言。若无所明则无明觉。有所非觉。无所非明。无明又非觉湛明性（先纵夺遣妨）。性觉必明（觉义）妄为明觉（不觉义）量非所明（业相）因明立所（现相）所既安立生汝妄能（转相）

议曰。此示生妄之始也。若无所明则无明觉此纵辞也。意牒无所明一语。谓若果无所明则无明觉之妄矣。岂不幸哉。下夺之曰。争奈有所则非真觉。无所乃非妄明。若绝无本明又非觉湛明性之真体矣。性觉必明者谓性觉必定妙明不须更以明明之。此是本然佛性。当论觉义也。妄为明觉者谓才动所明之一念则将本然觉性妙明失之矣。当论不觉义也。觉非所明若有所明则属无明。此当论三细之业相也。以因此妄明之无明迷覆绝待之真心遂形对待之所相。此一所字则虚空世界众生之相已兆於此。故曰因明立所。当现相也。然 所相既已妄立则对待是形。故将本然寂照妙明

之智光转为能见之妄见。故曰所既妄立生汝妄能。当转相也。三细之相明见於此

△五境界为缘长六粗分三

初总显六粗

无同异中炽然成异。（明全真起妄）异彼所异因异立同。同异发明因此复立无同无异。（上总出妄相下正明六粗）如是扰乱相待生劳。（智相）劳久发尘（相续相）自相浑浊。（执取计名字相）由是引起尘劳烦恼。（起业系苦相下总结妄相）起为世界。静成虚空。虚空为同。世界为异。彼无同异真有为法

议曰。此原倒妄之由以显六粗相也。无同异中炽然成异者。谓一真法界常住真心本无同异之相。以一念妄动则真如随缘而有生灭遂为不觉成阿赖耶识。由此即有微细三相而六粗已兆。则世界众生种种差别之相炳然现於藏识之中。是则本无同异而今有之。法尔齐现故曰炽然。异彼所异下四句从一所字以拣迷中之同异将显六粗

之相也。所异即炽然成异。谓无明为能异世界等为所异。今就异中拣有一法不同所异之世界乃虚空也。所谓迷妄有虚空。因世界种种差别之异而立虚空为同以恒一故。以虚空静而世界动动静发明则又立一法为无同无异乃众生也。以众生有色相不同虚空。有知觉不同世界。此则迷中从三细现相而有虚空世界众生之异相。所谓依空立世界。知觉乃众生。此一念圆具故。下文佛自释之也。如是扰乱下明六粗相也。谓一真法界妙圆心中湛然常寂。今既迷妄而有世界众生。於虚空中动静相待扰乱生劳。劳则妄生分别当粗中智相也。劳久则发尘。劳久当相续相也。自相浑浊所谓自心取自心当执取计名字相也。由是引起尘劳烦恼业起而苦必随之当业系苦相也。盖因动念一所字故於本然清净界中。妄有山河大地有为迁流之相由是而生起也。起为世界下释上迷中同异之所以。谓上所言同异者。以起而动者为世界。一而静者为虚空。则彼无同异恐滥於真乃指之曰真有为法是众生也。此上总明由一迷妄遂有三细六粗以成世界众生业果之相。下示轮回不断之义。故别说三种相续之所因四大互生之所以也

二别示相续分三

初世界相续

觉明空昧相待成摇。故有风轮执持世界。因空生摇坚明立碍。彼金宝者明觉立坚故有金轮保持国土。坚觉宝成摇明风出。风金相摩故有火光为变化性。宝明生润火光上蒸故有水轮含十方界。火腾水降交发立坚。湿为巨海干为洲滩。以是义故。被大海中火光常起。彼洲滩中江河常注。水势劣火结为高山。是故山石击则成焰融则成水。土势劣水抽为草木。是故林薮遇烧成土因绞成水交妄发生递相为种。以是因缘世界相续

议曰。此明世界相续之因也。初言因明立所以所字当现相指世界众生等。今言世界乃唯识所变之相分。始因迷妄有虚空依空立世界。故推觉明之无明以对顽然之虚空而为世界生起之本。以空晦暗中结暗为色。此正结色之始也。以世界乃四大种正儒家所推先天之五行。谓由无明而成四大之世界。则天地以之而位。由四大而为五行。以生成故万物以之而育。然世界即吾人所居之天地非别有一世界也。说者但於经中约文字以作解从来未有发明於目前者。故因经文乃设问以明之。不但决二氏之疑。而吾徒亦知唯识之旨矣。幸无厌其烦。 问云何而有风轮执持世界耶。答经云觉明空味 等。谓由迷一真法界妙明真心而为觉明之无明。 遂变灵明寂灭之真空而为无知暗昧之顽空。能所相待明暗相倾既久而成妄想。此想鼓动心体积虚成气充满空中遂有风相。如虚室生风又如鼓扇生风也。积想不休而风力愈大。故曰一切世界风力所持。又一切世间境界皆依无明妄心而得住持。故有风轮执持世界。此风大种也。（老氏指觉明之老氏指觉明之无明为道体。故曰杳杳冥冥其中有精。又以空体为虚无大道指此风相为冲气。故专气致柔。又曰天地之间其犹橐龠乎。此老氏之道源也．儒氏以识神为天命之性、指空大为太极．指此风大为混元一气。由一气以生成万物。是皆不知唯识所变也。故太极图黑白相参。然白即觉性黑即无明。正不生灭与生灭和合成阿赖耶识为生万法之始。以此识有三分而虚空世界乃相分耳）

问云何世界而以金宝为体耶。答经云因空生摇等。谓由顽空体中而生摇动妄想之风。返吹藏识体中无知之明觉。一动一静生灭不停相摩相荡。摩荡既久而明体愈坚遂结为色。彼金宝者乃明觉所成之坚。故宝有光明以得坚觉之性也。由是故有金轮保持国土。此性色为地大种。指体而言故曰金宝。以须弥已下地底为金刚际。

（此儒家所言一阴一阳之谓道。以为生天地之本也。此中空静也。暗幽也。故为阴。摇动也。觉明也。故为阳。故曰动静有常、刚柔断矣。此由动静以成金轮为地大种。即天地初成之始也。以动为乾体静为坤体。故形而上者为天。形而下者为地。所谓乾坤成列而易摇乎其中矣。斯则阴阳未形而动静刚柔已具。所谓先天之易也。问云何而有火光为变化性耶。答经云坚觉宝成等谓由前坚觉之宝既成摇明之风既出。二者相对。一刚一柔相摩相荡故有火光为变化性。此火大种也。（此易所言刚柔相摩而成变化以形而上者在天成象。为日乃太阳之火精也。形而下者在地成形为木乃变化性。谓变生为熟化有为无。且後天五行异为风为木。故钻木取火。以得先天之性也。此四象中日也。）问云何而有水轮含十方界耶。答经云宝明生润等。此句文倒。应云火光上蒸宝明生润。谓由火光上焰而蒸坚觉之宝。宝被火气故生润而水出。故有水轮含十方界也。此句经义极难理会。且宝为地体何以火蒸而为空中雨露之水耶。以金宝为地体须弥山亦名金刚山。大论云。须弥山四宝所成山顶帝释

所居三十三天。是则上界宜乎金刚为地体也。况须弥山形如细腰鼓。是别上界地而覆於下者亦相若。日月行於山腰照临一四天下。足知仰视苍苍而碧色者皆上界宝地之体也。而为下方众生业火所蒸而生润。即空中雨露霜雪之类皆宝所生之水也。是则众生常居宝界之中。而宝中有水岂非水轮合十方界耶。（此即易所谓形而上者在

天成象月。太阴之精。为星辰。形而下者为江河湖海流注之状。此四象具矣）此前因觉明空昧相待而有风金二大。因风金相摩而有火大。因火蒸宝润而有水大。是则因四大而成天地阴阳日月星辰之四象。此正易经所说太极生两仪。两仪生四象。以为八卦之体。故曰。天尊地卑乾坤定矣。卑高以陈贵贱位矣。动静有常刚柔断矣。在天成象在地成形变化见矣。此上且说天地生成之相。後方说万物本末之由。以此而推世界从觉明唯识所变皎然不爽。予昔遇一梵宿谓予楞严经谈五行之妙极精。故刻意而推之。吾徒不可不知也。问云何而在江河湖海洲滩干湿流注之状耶。答经云

火腾水降等。前言乾坤已成阴阳既分而天地位矣。由四大种而为後天之五行以生成万物。此火金生水水火生土也。谓由火光上蒸宝明生润故火光上炎水势下降。交合於半空之中水火既济阴阳和而生子。故水火俱坚实而成形其本源湿性流为四大海水。其本源火性遂结成土。大者为洲。小者为滩。故有四大部洲诸小洲等。以是义故

水含父之性故海中火光常起。土得母之性故洲滩中江河常注也。以水火乃称性之水火。故在天成象有日月星辰。在地成形有江河湖海四大部洲之状。故云变化见矣。此交发立坚以水火相敌乃水火既济谓相生也。下水势劣火故有山石草木乃相克以成物也。问云何而有山川高下不平耶。答经云水势劣火等以前水火既济而势相敌故为洲为海。今水火未济水势劣火势不相敌而火上炎遂结为高山巨石。以其受父之性故山石击则成焰。得母之性故融则成水。即今石中有火山顶有水石根多润类可见矣。此犹属先天性火但全不相敌故成有形之山石耳。问云何而有草木之类耶。答经云土势劣水等。此五行水土生木也。以其受生之气分故林薮遇烧成土也。以其受母之气分故草木遇绞成水也。由觉明空昧二妄而为四大之种。遂成天地日月四大部洲江河湖海山川草木。而一气流行。阴阳错综。五行相生。八卦流变。至六十四故易卦始於乾坤而终於既济未济也。故曰交妄发生递相为种。以是因缘世界相续也。昔大慧禅师云。楞严世界相续说五行极详。举此示众。但未细分别耳

二明众生相续

复次富楼那。明妄非他觉明为咎。所妄既立明理不逾。以是因缘听不出声。见不超色。色香味触六妄成就。分开见觉闻知。同业相缠。合离成化。见明色发。明见想成。异见成憎。同想成爱。流爱为种。纳想为胎。交遘发生吸引同业。故有因缘生羯罗蓝遏蒲昙等。胎卵湿化随其所应。卵唯想生胎因情有。湿以合感。化以离应。情想合离更相变易。所有受业逐其飞沈。以是因缘众生相续

议曰。此明众生相续之因也。明妄非他乃至合离成化等者。盖言四生受形之因而身为苦本也。清净界中本无众生。但因无始一念妄动而有无明遂为众生之本。故曰明妄非他觉明为咎。觉明指无明也。因此无明遂形四大之所相。吸揽四大以为身。故使真明之理不能逾越於色身。复取外色所造之六尘而为受用之境。以是因缘故听不出声见不超色因色香味触六种妄尘既就则根尘和合而发六识。圆湛之体由是分为见闻觉知。根境识三和合造业为因。而四生之苦果随具。故同业相缠而有胎卵之形。合离成应而有湿化之类。此四生众生始因一念无明而有也。见明色发以至遏蒲昙等者此言投胎之状也。六道升沈不一此就人道而言。谓众生既造妄业死後得中阴身

所谓游魂也。鬼无色身而有五通。眼见最远。以爱染习气必寻所爱之境。极其见而求之。虽数千里外而可爱之境遂现。故曰见明色发。既见其境而识神必趋其所。以明见可爱而想形之。故曰明见想成。当其男女交遘之际而识神守之。若本是男则爱母而憎父。若本是女则爱父而僧母。故曰异见成憎同想成爱。乘其交遘而渴随随之。吸爱涎而流入母胎。而为受形之种子。故曰流爱为种。想揽父母一点精血纳想於中遂执为我。故曰纳想为胎。此入胎受形之始盖从交遘发生也。若其男女之辩又因憎爱吸引同业而有别也。由爱业为因。爱境为缘。而胎中一七日而为羯罗篮。（此云凝滑）遏蒲昙（此云〖皮色〗二七之状）。蔽尸（此云软肉 三七之状）健南。（此云坚肉四七之状）钵罗奢（此云形位谓六根方具五七之状也）上言投胎之所以也。至若胎卵湿化四生之不一者特随其所造之业而应 之。所谓当业流转也。卵唯想生胎因情有。湿以合感。化以离应。想轻举而情重浊。由想而爱随之故卵为首。附合湿气而生曰湿生。转脱易形曰化生。由情想合离敌更相变易。随因感果所有受业逐其飞沈耳。以是因缘众生相续也。

三明业果相续

富楼那。想爱同结爱不能离。即诸世间父母子孙相生不断。是等则以欲食为本。贪爱同滋贪不能止。则诸世间卵化湿胎随力强弱递相吞食。是等则以杀贪为本。以人食羊。羊死为人。人死为羊。如是乃至十生之类死死生生互来相啖。恶业俱生穷未来际。是等则以盗贪为本。汝负我命我还汝债。以是因缘经百千劫常在生死。汝爱我心我怜汝色。以是因缘经百千劫常在缠缚。唯杀盗淫三为根本。只是因缘业果相续

议曰。此明业果相续之因也。想爱同结爱不能离。父母子孙相生不断。此言众生所以不能出生死 而受轮回之苦果者欲贪为本也。贫爱同滋贪不 能止。谓贪众生身分血肉取以为食滋养己身故 曰同滋。以强陵弱取而食之故曰杀贪为本也。以人食羊等为盗贪者。以本不与而取之。强杀其命而食其肉。故为盗也。汝负我命杀贪也。我还汝债盗贪也。汝爱我心我怜汝色欲贪也。故此历劫牵缠三业为本。以是因缘业果相续也

三结显妄相

富楼那。如是三种颠倒相续。皆是觉明明了知性因了发相。从妄见生山河大地诸有为相次第迁流。因此虚妄终而复始

议曰。此结三种妄元也。谓三种颠倒之相本来不有。但因无始一念妄动而有无明。故曰觉明。由此无明而生妄见。故曰明了知性。因无明而发所相是从无明而生山河大地诸有为相也。是知初言因明立所。只一所字而三种之相巳具其中矣。以妄见不泯则轮回不息故终而复始也

上约迷以示妄依真起竟

三示本无灭分二 初执妄疑真

富楼那言。若此妙觉本妙觉明与如来心不增不减。无状忽生山河大地诸有为相。如来今得妙空明觉。山河大地有为习漏何当复生

议曰。满慈已蒙开示从悟至迷因依妙见明心迷 妄而生山河大地。遂疑如来已证妙空明觉而山河大地何当复生耶。要显觉不生迷本无生灭之义。故兴此问

二示本无生灭

佛告富楼那。譬加迷人於一聚落惑南为北。此迷为复因迷而有因悟而出。富楼那言。如是迷人亦不因迷又不因悟。何以故。迷本无根云何因迷。悟非生迷云何因悟。佛言。彼之迷人正在迷时。倏有悟人指示令悟。富楼那於意云何此人纵迷。於此聚落更生迷不。不也世尊。富楼那。十方如来亦复如是。此迷无本。性毕竟空。昔本无迷似有迷觉。觉迷迷灭觉不生迷。亦如翳人见空中华。翳痛苦除华於空灭。忽行愚人於彼空华所灭空地待华更生。汝观是人为愚为慧。富楼那言。空元无华。妄见生灭。见华灭空已是颠倒。敕令更出斯实狂痴。云何更名如是狂人为愚为慧。佛言。如汝所解。云何问言诸佛如来妙觉明空何当更出山河大地。又如金矿杂於精金。其金一纯更不成杂。如木成灰不重为木。诸佛如来菩提涅盘。亦复如是

议曰。满慈此问要显迷悟同源本无生灭。故如来连以四喻答之。迷方一喻使知昔本不迷今亦无悟。空华一喻使知真元无妄悟不生迷。金喻觉性不变。灰喻果德无生。

上答云何忽生。下答四大相陵。

四显理事无碍

富楼那。又汝问言地水火风本性圆融周遍法界疑水火性不相陵灭。又徵虚空及诸大地俱遍法界不合相容。富楼那。譬如虚空体非群相而不拒彼诸相发挥。所以者何。富楼那。彼太虚空日照则明。云屯则暗。风摇则动。霁澄则清。气凝则浊。土积成霾。水澄成映。於意云何。如是殊方诸有为相为因彼生为复空有。若彼所生。富楼那。且日照时既是日明。十方世界同为日色。云何空中更见圆日。若是空明空应自照。云何中宵云雾之时不生光耀。当知是明非日非空不异空日。观相元妄无可指陈。犹邀空华结为空果。云何诘其相陵灭义。观性元真唯妙觉明。妙觉明心先非水火云何复问不相容者。真妙觉明亦复如是。汝以空明则有空现。地水火风各各发明则各各现。若俱发明则有俱现。云何俱现。富楼那。如一水中现於日影。两人同观水中之日东西各行则各有日随二人去。一东一西先无准的。不应难言此日是一云何各行各日既双云何现一宛转虚妄无可凭据

议曰此下喻显事理无碍以示不空藏性也。满慈疑水火性不相陵灭。又疑虚空大地本不相容。如来举虚空之喻以显事理无碍。故曰譬如虚空体非群相而不拒彼诸相发挥。以除妙觉性空体绝诸妄而不妨随业发现也。且空中明暗等相本非虚空而不异虚空。是知妙见明心发现诸相本非妙明而不异妙明。此则不空之义显矣。观相元妄。

观性元真。唯一妙心。元非水火。云何复问不相容者。盖真妙觉心具有广大业用故循业发现而地水火风各各发明则各各现。若俱发明则一时俱现。然俱现者如水中日影随人东西各行不可作一异会也。知此四大各遍之疑泮然冰释矣。

上喻显理事无碍

五显迷悟同源以结事理无碍

富楼那。汝以色空相倾相夺於如来藏。而如来藏随为色空周遍法界。是故於中风动空澄日明云暗。众生迷闷背觉合尘故发尘劳有世间相。我以妙明不灭不生合如来藏。而如来藏唯妙觉明圆照法界。是故於中一为无量。无量为一。小中现大。大中现小。不动道场遍十方界。身合十方无尽虚空。於一毛端现宝王刹。坐微尘里转大法轮。灭尘合觉故发真如妙觉明性

议曰。此结显事理无碍带显事事无碍也。谓如来藏性本圆周遍。若以色空倾夺则随色空周遍法界。且事遍即理遍也。但众生迷闷不悟背觉合尘 故发尘劳有世间相。以显事理无碍也。我以妙明不生不灭会如来藏。而如来藏唯妙觉明圆照法界。故能一多相含。小大摄入。毛端现刹。尘里转轮。良以灭尘合觉故发真如妙觉明性。此带显事事无碍也。上示不空藏性竟

三开空不空如来藏示中道观体分四

初约遮照以显圆分四

初约双遮以显圆

而如来藏本妙圆心。非心非空非地非水非风非火非眼非耳鼻舌身意。非色非声香味触法。非眼识界如是乃至非意识界。非明无明明无明尽如是乃至非老非死非老死尽。非苦非集非灭非道非智非得。非檀那非尸罗非毗黎耶非羼提非禅那非般剌若。非波罗蜜多。如是乃至非怛达阿竭（此云如来）非阿罗诃（此云应供）三耶三菩（此云正遍知）非大涅盘。非常非乐非我非净

二约双照以显圆

以是俱非世出世故。即如来藏元明心妙。即心即空。即地即水即风即火。即眼即耳鼻舌身意。即色即声香味触法。即眼识界如是乃至即意识界。即明无明明无明尽如是乃至即老即死即老死尽。即苦即集即灭即道。即智即得。即檀那即尸罗即毗黎耶即羼提即禅那即般剌若。即波罗蜜多。如是乃至即怛达阿竭即阿罗诃三耶三苦。即大涅盘。即常即乐即我即净

三约同时以显妙

以是俱即世出世故。即如来藏妙明心元。离即离非。是即非即。

四结示离言

如何世间三有众生及出世间声闻缘觉以所知心测度如来无上菩提。用世语言入佛知见。譬如琴瑟箜篌琵琶虽有妙音若无妙指终不能发。汝与众生亦复如是。宝觉真心各各圆满。如我按指海印发光。汝暂举心尘劳先起。由不勤求无上觉道。爱念小乘

得少为足

议曰。此约遮照以显圆也。而如来藏清净本然纤尘不立离一切法十法界相了不可得。此约双遮 以显圆也。以是俱非世出世故。而如来藏即一切法。世出世间一法不舍。此约双照以显圆也。若言非言即犹是遮照未极一心必离即离非是即非

即。遮照同时心言路绝方显一心之妙耳。此则圆融果海妙绝言思。安可以所知妄心而能测度用世语言而入之哉。是须圆悟圆修方契一心之妙耳。故譬琴瑟虽具妙音若无妙指终不能发。妙指喻观行也。然汝与众生宝觉真心各各圆满与我无异。如我按指则海印发光。汝暂举心则尘劳先起者何也。良由爱念小乘不肯勤求得少为足耳。

上开空不空如来藏为中道观体竟

从初卷至此通开三种藏性三观体

即时阿难在大众中顶礼佛足起立白佛。世尊现说杀盗淫业。三缘断故三因不生。心中达多狂性自歇。歇即答提不从人得。斯则因缘皎然明白。云何如来顿弃因缘。我从因缘心得开悟。世尊此义何独我等年少有学声闻。其此会中大目犍连及舍利弗须菩提等。从老梵志闻佛因缘。发心开悟得成无漏。今说菩提不从因缘。则王舍城拘舍黎等所说自然成第一义。惟垂大悲开发迷闷。

议曰。阿难闻说妙心顿得不假修行。独蹑因缘之疑以启自然之问也。向以佛性借因缘而显。今则本有不修自得。是说佛性自然。则彼外道神我自然成第一义矣。此约佛性不假功勋为自然。非前妄见分别之自然也


通议卷第四

通议卷第四

二示一心以显顿悟顿得

富楼那言。我与如来宝觉圆明真妙净心无二圆满。而我昔遭无始妄想久在轮回今得圣乘犹未究竟。世尊诸妄一切圆灭独妙真常。敢问如来一切众生何因有妄。自覆妙明受此沦溺。佛告富楼那。汝虽除疑馀惑未尽。吾以世间现前诸事今复问汝。汝岂不闻室罗城中演若达多忽於晨朝以镜照面。爱镜中头眉目可见。嗔责己头不见面目。以为魑魅无状狂走。於意云何。此人何因无故狂走。富楼那言。是人心狂更无他故。佛言。妙觉明圆本圆明妙。既称为妄云何有因。若有所因云何名妄。自诸妄想展转相因从迷积迷以历尘劫。虽佛发明犹不能返。如是迷因因迷自有。识迷无因妄无所依。尚无有生欲何为灭。得菩提者如寤时人说梦中事。心纵精明。欲何因缘取

梦中物。况复无因本无所有。如彼城中演若达多岂有因缘自怖头走。忽然狂歇头非外得。纵未歇狂亦何遗失。富楼那。妄性如是因何为在。汝但不随分别世间业果众生三种相续。三缘断故三因不生。则汝心中演若达多狂性自歇。歇即菩提胜净明心本周法界不从人得。何藉劬劳肯綮修证。譬如有人於自衣中系如意珠。不自觉知。穷露他方。乞食驰走。虽实贫穷。珠不曾失。忽有智者指示其珠。所愿从心致大

饶富方悟神珠非从外得

议曰。前已开示三种藏性虽为三观之体。然且犹属修证不无渐次。故满慈复问何因有妄。要明妄元无因。以显顿悟顿得。方见天然妙性本自圆成。不借功勋非从外得耳。满慈何因有妄一问最为彻底穷源。学人日用但将此句时时参究。莫谓教

中无祖师意也。世尊难以措口聊借演若迷头之事发明以示妄元无因。亦见头非外得。以妙觉明心本来无妄既称为妄云何有因。有因则不名妄。但自诸妄想相因从迷积迷耳。如是迷因乃因迷自有。若知迷无因则妄无所依尚无有生云何有灭。如寤时人说梦中事耳。妄性如此因何为在。汝但不随分别三种相续。三缘断故则三因不生矣。三缘即杀盗淫。三因乃发业润生二种无明为三缘之因。谓若了三缘本空而根本无明当下不生则妙觉明心本来不迷。一旦顿得正若演若狂心若歇头非外得也。又何藉劬劳修证乎。故如贫子衣珠元不曾失非从外得也。顿悟之旨於兹见矣。

上直指一心以显顿得竟

三示真妄双绝以显妙分二

初当机执迷犹疑因缘自然

通议卷第四

二世尊曲借旁通即事以显真心绝待分六

初总显迷悟俱非

佛告阿难。即如城中演若达多狂性因缘若得得灭除则不狂性自然而出。因缘自然理穷於是

二显真妄双绝分二

初例真绝分二

初绝自然

阿难。演若达多头本自然。本自其然。无然非自。何因缘故怖头狂走

次绝因缘

若自然头因缘故狂。何不自然因缘故失。本头不失狂怖妄出。曾无变易何藉因缘

二例妄绝分二 初绝自然

本狂自然本有狂怖未狂之际狂河所潜

次绝因缘

不狂自然头本无妄何为狂走

三结妙绝言思

若悟本头识知狂走。因缘自然俱为戏论。

四遣妄缘

是故我言三缘断故即菩提心。菩提心生生灭心灭。此但生灭。

五观智双泯

灭生俱尽。无功用道若有自然。如是则明自然心生生灭心灭。此亦生灭无生灭者名为自然。犹如世间诸相难和成一体者名和合性。非和合者称本然性。本然非然。和合非合。合然俱离

六泯同果海

离合俱非。此句方名无戏论

四结责勤修以发行

菩提涅盘尚在遥远。非汝历劫辛勤修证。虽复忆持十方如来十二部经清净妙理如恒河沙只益戏论。法虽谈说因缘自然决定明了。人间称汝多闻第一。以此积劫多闻熏习不能免离摩登伽难。仍须待我佛顶神咒摩登伽。心淫火顿歇得阿那含。於我法中

成精进林。爱河乾枯令汝解脱。是故阿难。汝虽历劫忆持如来秘密妙严。不如一日修无漏业远离世间憎爱二苦。如摩登伽宿为淫女。由神咒力销其爱欲。法中今名性比丘尼。与罗候母耶输陀罗同悟宿因。知历世因贪爱为苦。一念熏修无漏善故或得出缠。或蒙授记。如何自欺尚留观听。

议曰。此即事例显真心绝待也。阿难向执因缘自然之见特常情耳。安可以入绝待真心哉。故世尊以演若迷头之事责之曰。即演苦迷头之事。若狂性因缘灭时则有自然头之见。但观未狂已前何有因缘自然哉。故曰理穷於是。下示本无因缘自然。故双辩其相。谓汝以离诸因缘便为自然者。且如演若头本自然则毕竟自然。又何因缘故怖头狂走。则非自然矣。此绝自然也。若自然头以因缘故狂何以不自然头假因缘而失耶。虽狂而头本不失乃狂怖妄出耳。纵狂而头无变改。何藉因缘耶。此绝因缘也。上辩头不因自然因缘而有得失。足知真性不属因缘自然也。下辩狂。谓不但头不属因缘自然。即狂亦无因缘自然。若狂是自然於未狂之先狂何所潜耶。此狂非自然也。若狂不自然而头本无妄何为狂走。此狂亦非因缘也。足知妄亦不属因缘自然矣。总而言之凡因缘自然之说皆妄计名言习气。但未一悟本头耳。若悟本头

识知狂走则因缘自然俱为戏论矣。以此而观。则知天然妙性不属因缘自然明矣。故下合显果海妙绝言思。是故我言三缘断故即菩提心者。此但妄缘断而觉性生但是生灭边事。若此灭生俱尽至於无功用道。此虽观智而对待未亡。若有自然则名自然心生生灭心灭。此犹属生灭边收。又指无生灭者名为自然。岂非妄见耶。智虽泯而理未忘。宗门到此但名法身边事。未是法身向上事。犹如世间调和成味而指非和合者称本然性耳。此非绝待真心也。必若本然非本然和合非和合。和合本然一切俱离。离合俱非至此则观智俱泯。心境两忘。圣凡情尽。迷悟双祛不堕法身。泯同果海。

向出言思。此句方名无戏论法也。前阿难陈悟谓不历僧祗获法身矣。至此又以因缘自然为疑。正是多闻名言习气未忘。岂可以戏论名言取菩提涅盘哉。故如来大慈结责劝修曰。菩提涅盘尚在遥远。非汝历劫勤修无以取证。纵汝忆持十二部经只益戏论耳。且汝多问乃积劫熏习。何以不免摩登伽难。只须待我神咒令汝解脱耶。是故汝虽 历劫忆持不如一日修无漏业。且摩登淫女也。耶轮妇人也。只一念熏修无漏善故。或得出缠。或蒙授记。而汝丈夫何不勇猛熏修而返留滞於见闻观听之迹耶

上开三种藏性以为三观之体。末後切劝修持。故下请行

二详陈众行以示三观之相分二

初特请行门

阿难及诸大众闻佛示诲。疑惑销除心悟实相。身意轻安得未曾有。重复悲泪顶礼佛足。长跪合掌而白佛言。无上大悲清净宝王善开我心。能以如是种种因缘方便提奖。引诸沈冥出於苦海。世尊我今虽承如是法音。知如来藏妙觉明心。遍十方界含有如来十方国土清净宝严妙觉王刹。如来复责多闻无功不逮修习。我今犹如旅泊之人忽蒙天王赐与华屋。虽获大宅要因门入。惟愿如来不舍大悲示我在会诸蒙暗者捐舍小乘毕获如来无馀涅盘本发心路。今有学者从何摄伏畴昔攀缘。得陀罗尼入佛知见。作是语已。五体投地。在会一心伫佛慈旨

议曰。此当机请行也。古德判为修道分。愚判此为示观相。以阿难初请三观。前但约所显理以为观体。今阿难发心修行。远取菩提。非观行不能入。以观妄相为行。故向下十方如来同声说偈正示观相而二十五圣圆通乃示各人随宜观相之方便耳。阿难蒙佛开示已悟法身真体。自信妙见明心本圆周遍。含育十方诸佛刹土矣。如来现今结责谓菩提涅盘尚在遥远。非历劫修行而不能证。殊非多闻可得。此则譬如天王赐与华屋要因门入。故此请行以三观乃入法界之门。今克约本经旨趣故为示观相

二世尊委示行相分二

初示自利妙圆理行分四

初通示迷悟之根分四 初总示发觉初心

尔时世尊衰愍会中缘觉声闻於善提心未自在者。及为当来佛灭度後未法众生发菩提心开无上乘妙修行路。宣示阿难及诸大众。汝等决定发菩提心於佛如来妙三摩提不生疲倦。应当先明发觉初心二决定义

二别示二决定义分二

初以不生灭心为本修因分三

初示能观之心

云何初心二义决定。阿难。第一义者。汝等若欲捐舍声闻修菩萨乘入佛知见。应当审观因地发心与果地觉为同为异。阿难。若於因地以生灭心为本修因而求佛乘不生不灭无有是处。以是义故汝当照明诸器世间可作之法皆从变灭。阿难。汝观世间可作之法谁为不坏。然终不闻烂坏虚空。何以故。空非可作。由是始终无坏灭故

二示所观之境分三

初示生灭源

则汝身中坚相为地。润湿为水。暖触为火。动摇为风。由此四缠分汝湛圆妙觉明心。为视为听为觉为察。从始入终五叠浑浊

二喻生灭相

云何为浊。阿难。譬如清水清洁本然。即彼尘土灰沙之伦本质留碍。二体法尔性不相循。有世间人取彼土尘投於净水。土失留碍水亡清洁。容貌汩然名之为浊。汝浊五重亦复如是

议曰。此下正示生灭之元。先立二决定义为发觉初心也。将示不生灭心为本修因。先示五浊生灭之相。意在即生灭以证无生。即五蕴以证法身也。众生所以迷倒者。良由迷一心而为业识。依见相而为色心。依色心而成五蕴。由是妄分根尘识界。 唯以五蕴为生死之本也。今将返妄归真若离此五蕴身心更无可修之地。故以观五蕴为入道之门。若因地倒还因地起也。则征心辩见以破者破此五蕴身心是妄耳。会归藏性必从五蕴为首也。众生相续则以五蕴为苦本也。故今修行必观五蕴妄相以发轫也。即末後开示阴魔盖由观五蕴不得其妙故堕魔属也。结会总示五蕴边际使知归宿也。此佛出世说法之本意专为打破众生五蕴身心耳。独於此经周备。故使观者必先得其要。则若理若观皆有所归矣。世尊许说之初乃曰於佛如来妙三摩提不生疲倦者以最初许曰有三摩提名大佛顶首楞严王。今先诫令於此大定勿生疲倦耳。以此证之则前显理为观体今说行门为观相无碍矣。二决定义谓决定而不可易者。一审因地发心。二审烦恼根本。意谓若生灭入照则当下真常。若烦恼知根则迎刃而解矣。修行之要莫切于此。故令审观因地发心与果地觉为同为异。意使以果地觉为本因心。殆非生灭心可契不生灭果也。故今照明世间诸生灭法皆可坏相。独虚空不坏者以无作故。此则的指无作妙行为根本也。且不生灭者即圆湛妙明清净真心也。只因最初一念妄动而为无明。遂形所相而成四大之妄色。因起妄见抟取四大而为身。因此四缠即将圆明妙心分为见闻觉知而成五蕴之众生。譬如清冷之水投之以灰沙尘土浑浊不分。此五蕴秽浊之因从此而有也

三别明生灭

阿难。汝见虚空遍十方界空见不分。有空无体。有见无觉。相织妄成。是第一重名为劫浊。汝身现抟四大为体。见闻觉知壅令留碍。水火风土旋令觉如。相织妄成。是第二重名为见浊。又汝心中忆识诵习性发知见。容现六尘。离尘无相。离觉无性。相织妄成。是第。三重名烦恼浊。又汝朝夕生灭不停知见每故留於世间。业运每常迁於国土。相织妄成。是第四重名众生浊。汝等见闻元无异性。众尘隔越无状异生。性中相知用中相背。同异失准相织妄成。是第五重名为命浊

议曰。上总显五浊生灭之元。下别示五浊生灭之相。然五浊依五蕴而立者。意谓清净界中本无众生。何有劫见烦恼众生命浊等事。只因迷本元明结为色心而为五蕴之众生即浑浊真心故有五种之妄相也。见空相织为劫浊者此约色蕴以明劫浊也。劫者梵语劫波此云时分。长时之称也。且此明依色蕴应云四大相缠。今以空见而言者以迷妄最初有虚空而为色体。乃妄见先所揽者。故因顿空以浑浊真心而成妄见。此见吸取空相久结为色而成色心。由此盖覆真心故约空以明色蕴也。此中相织约义而言但取绵密相缠不分。盖约生灭不停有织成义。非若世之经纬为织也。空

见不分者。谓迷妙空而为顽空则空本遍也。迷妙明而为妄见则见亦遍也。二妄混合而为一故云不分。且空本是真如之实体见本是圆明之妙觉。今既迷而混为一。正似投灰土於流水。则两失之矣。故但有空而无真体。但有见而无真觉。由此二妄生灭相缠乃有色心。故为色蕴之始也。名劫浊者。以清净界中本无有时。今由色心初集之时便为长时之本。故依色蕴名为劫浊。汝身现抟四大等为见浊者指受蕴为见浊也。此见乃五蕴执受之妄见也。指四大六根而为见浊者盖妄认四大为自身相为妄见也。意谓汝之色身本非有也。乃现抟取四大以为体。遂将圆明妙心壅令留碍分为见闻觉知隔越而不通。且彼四大本无知觉今壅识心於内。旋无知而令有知遂执受为我以无知投於知见之内知觉融贯於无知之中。自相浑浊生灭不停。妄见执此为受用根以於清净心中妄见有此执受之色根。故依受蕴名为见浊。又汝心中意识诵习等名烦恼浊者此依想蕴而立也。想乃六识之妄想。烦恼性空此妄想本非有也。由汝心中寻常诵习惯熟之往事习气内鼓忽然起念欲有所知所见之境。引起宿习故曰性发知见。

随其妄想而所念之尘境即分明形容於妄想心中。此所谓妄认六尘缘影为自心相故曰容现六尘。然此妄想缘尘而有。离尘则无实体。离觉则了无自性。以此妄想生灭不停。扰乱於清净心中。故依想蕴名烦恼浊。又汝心中朝夕不停等名众生浊者此依行蕴而立也。谓此众生本非有也。由汝妄想生灭不停知见每欲留於世间故念念造业。

而善恶业力念念流变於十二类生以去留生灭为众生本。浑浊真心。故依行蕴名众生浊。汝等见闻元无异性等名命浊者。此依识蕴而立也。然此命根本非有也。由汝元一妙圆真心本无同异之相。良由四大壅分识性而为见闻觉知。则众尘隔越故无状异生。性中本为一体故相知。用中六根割据故相背。故同无一定之同。异无各各之异。两失其准。此识连持色心而为命根。同异浑浊相织妄成。故依此识蕴名为命浊原此五浊於妙圆心中本无所有。但由五蕴生灭浑浊真心故为浊耳。是皆迷妄之源也。故此下约返妄归真以示观行

三示观行之因分三 初明因真果正

阿难。汝今欲令见闻觉知远契如来常乐我净应当先择死生根本。依不生灭圆湛性成。以湛旋其虚妄灭生伏还元觉。得元明觉无生灭性为因地心。然後圆成果地修证

二喻断惑浅深分二 初喻渐断

如澄浊水贮於净器。静深不动沙土自沈。清水现前。名为初伏客尘烦恼

二喻顿断

去泥纯水名为永断根本无明

三结真穷惑尽

明相精纯。一切变现不为烦恼。皆合涅盘清净妙德

议曰。此略示观行之相也。意谓欲令浑浊之觉远契涅盘清净之妙德。应先择死生之根本。择犹摘也。专依不生灭性以旋生灭。旋犹漩也。如水之漩复也。谓念念漩妄以归真也。伏还元觉得元明觉为因地心。如此方能圆成果地修证。故如澄浊水。清水现前名为初伏客尘烦恼。此渐断也。去泥纯水名为永断根本无明。此顿断也。当等觉後心将入妙矣。真穷惑尽则合涅盘清净妙德矣。斯由不生灭心观行之功也

二审烦恼根本意择圆根分六

初敕令详审

第二义者。汝等必欲发菩提心。於菩萨乘生大勇猛决定弃捐诸有为相。应当审详烦恼根本。此无始来发业润生谁作谁受。阿难汝修菩提若不审观烦恼根本则不能知虚妄根尘何处颠倒。处尚不知云何降伏取如来位

二正指结根

阿难。汝观世间解结之人不见所结云何知解。不闻虚空被汝隳裂。何以故。空无形相无结解故。则汝现前眼耳鼻舌及与身心六为贼媒自劫家宝。由此无始众生世界生缠缚故於器世间不能超越

议曰。此审烦恼根本也。发业是根本无明。润生是爱取二惑。生死实由此二而有通名烦恼。然此二 种依根而辩者。谓此二法元无实体。但依六识妄想为用。故於六根门头缘尘取境纯是无明用事以资爱取。故念念爱取处处贪着。生死结於根尘之中。故令审知虚妄根尘何处颠倒。以根尘相交结处即颠倒处。乃生死结根之所在也。若欲解结当就结根而解之。故审六根忧劣。意取圆根虚而易解。所以用其选择耳。将选圆根先示六根之优劣欲令知所选耳

三显根因妄织

阿难。云何名为众生世界。世为迁流。界为方位。汝今当知东西南北东南西南东北西北上下为界。过去未来现在为世。方位有十。流数有三。一切众生织妄相成。身中贸迁世界相涉。而此界性设虽十方。定位可明。世间只目东西南北。上下无位。中无定方。四数必明与世相涉。三四四三宛转十二。流变三叠一十百千总括始终六根之中各各功德有千二百

四显力用不齐分六

初眼根

阿难。汝复於中克定优劣。如眼观见後暗前明。前方全明。後方全暗。左右旁观三分之二。统论所作功德不全。三分言功一分无德。当知眼唯八百功德

二耳根

如耳周听十方无遗。动若迩遥。静无边际。当知耳根圆满一千二百功德

三鼻根

如鼻嗅闻通出入息。有出有入而阙中交。验於鼻根三分阙一。当知鼻唯八百功德

四舌根

如舌宣扬尽说世间出世间智。言有方分理无穷尽。当知舌根圆满一千二百功德

五身根

如身觉触识於违顺。合时能觉离中不知。离一合双验於身根三分阙一。当知身唯八百功德

六意根

如意默容十方三世一切世间出世间法。唯圣与凡无不包容尽其涯际。当知意根圆满一千二百功德

五诫选圆根

阿难汝今欲逆生死欲流。返穷流根至不生灭。当验此等六受用根谁合谁离。谁深谁浅。谁为圆通。谁不圆满。若能於此悟圆通根。逆彼无始织妄业流得循圆通。与不圆根日劫相倍。我今备显六湛圆明本所功德数量如是。随汝详审其可入者。吾当发明令汝增进

六使一门深人

十方如来於十八界一一修行皆得圆满无上菩提。於其中间亦无优劣。但汝下劣。未能於中圆自在慧。故我宣扬。令汝但於一门深入。入一无妄。彼六知根一时清净

议曰。此示六根优劣也。上云由此众生世界生缠缚故於器世间不能超越。故知众生世界但就正报之身而言。所云世界者世约妄念迁流。界约一而有左右前後故为界也。以一念才兴居然迁流便有三世。方虽有十只言四方。此三世四方只就一身而观。故曰身中贸迁以界与世互相交涉。所谓织妄相成也。三四四三宛转十二者。谓一念法尔具该三世全遍於一身。不出於左右前後之四方。则每方各有三世此三四以成十二也。其四方全被一念之所融贯则每世皆有四方此四三以成十二也。以此相织故曰宛转。初则一念为一叠但有十二耳。妄念重变前念已灭後念续生。最极微细。以初起一念无本。即此一念已包三世流於四方故成十二。此一叠也。第二叠者即於东方三世每世各有一根本共成三十。则四方合一百二十故曰百。第二叠也。第三叠者就百二十上各各有十则成千二百。此三叠也。此以世涉方。其界例此可知。最初一念不立本者以从无住本立一切法故。然生灭妄念微细流注谓一念中有九十

刹。那一刹那中有九百生灭。其实刹那刹那穷劫不尽。今但以三叠而言者。谓约生灭一念法尔迁流具该三世。虽穷劫亦只言三世耳。欲就生灭根身以明六根之业用。各各本该一千二百之功能。但约遍不遍处圆不圆根定其力用优劣耳。若眼根见前不能见後约功能不到处则三分阙一只具八百。耳则圆闻十方故全具千二。鼻则约出入

息阙於中交亦只八百。舌则宣扬妙理圆满千二。身以离合离则不知亦只八百。意则默容十方三世无不周遍故千二百。此全约功能以论也。六根优劣已示於此。众生颠倒於生死之中而不能超越者但依六根缘尘取境无明发业爱取润生起惑造业结成生死之根。故长劫沉沦。今若逆生死流返妄归真。只就此六根门头返穷流根至不生灭地耳。不必舍此别求也。以此六根本是妙明真心中所现之物故根根尘尘皆可还源。今但就圆根取其易入功用易成。故须选择令於一门深入。果能入一无妄则六知根一时清净矣

三略示妄尽还源分二

初当机疑请

阿难白佛言。世尊。云何逆流深入一门能令六根一时清净

二世尊的示分十

初总明机浅法深

佛告阿难。汝今已得须陀洹果。已灭三界众生世间见所断惑。然犹未知根中积生无始虚习。彼习要因修所断得。何况此中生住异灭分齐头数

二令观六一虚妄

今汝且观现前六根为一为六。阿难。若言一者。耳何不见。目何不闻。头奚不履。足奚无语。若此六根决定成六。如我今会与汝宣扬微妙法门。汝之六根谁来领受。阿难言。我用耳闻。佛言。汝耳自闻何关身口。口来问义身起钦承。是故应知非一终六。非六终一。终不汝根元一元六

三的示真妄两忘

阿难。当知是根非一非六。由无始来颠倒沦替故於圆湛一六义生

四责迷执一

汝须陀洹虽得六销犹未亡一

五喻出形名

如太虚空参合群器。由器形异名之异空。除器观空说空为一。彼太虚空云何为汝成同不同。何况更名是一非一。则汝了知六受用根亦复如是

六则示妄源分二

初别显妄源分六

初眼根

由明暗等二种相形。於妙圆中黏湛发见。见精映色结色成根。根元目为清净四大。因名眼体如蒲萄朵。浮根四尘流逸奔色

二耳根

由动静等二种相击。於妙圆中黏湛发听。听精映声卷声成根。根元目为清净四大。因名耳体如新卷叶。浮根四尘流逸奔声

三鼻根

由通塞等二种相发。於妙圆中黏湛发嗅。嗅精映香纳香成根。根元目为清净四大。因名鼻体如双垂爪。浮根四尘流逸奔香

四舌根

由恬变等二种相参。於妙圆中黏湛发尝。尝精映味绞味成根。根元目为清净四大。因名舌体如初偃月。浮根四尘流逸奔味

五身根

由离合等二种相摩。於妙圆中黏湛发觉。觉精映触抟触成根。根元目为清净四大。因名身体如腰鼓颡。浮根四尘流逸奔触

六意根

由生灭等二种相续。於妙圆中黏湛发知。知精映法揽法成根。根元目为清净四大。因名意思如幽室见。浮根四尘流逸奔法

二总结虚妄

阿难。如是六根由彼觉明有明明觉。失彼精了黏妄发光。是以汝今离暗离明无有见体。离动离静元无听质。无通无塞嗅性不生。非变非恬尝无所出。不离不合觉触本无。无灭无生了知安寄

七指归观心

汝但不循动静合离恬变通塞生灭明暗。如是十二诸有为相。随拔一根脱黏内伏

八智起惑忘

伏归元真发本明耀。耀性发明诸馀五黏应拔圆脱。不由前尘所起知见

九略显大用

明不循根寄根明发。由是六根互相为用。阿难。汝岂不知今此会中。阿那律陀无目而视。跋难陀龙无耳而听。兢伽神女非鼻闻香。骄梵钵提异舌知味。舜若多神无身受触。如来光中映令暂现。既为风质其体元无。诸灭尽定得寂声闻。如此会中摩诃迦叶久灭意根圆明了知不因心念

十显妄尽还源

阿难。今汝诸根若圆拔已。内莹发光如是浮尘及器世间诸变化相如汤消冰。应念化成无上知觉。阿难。如彼世人聚见於眼。若令急合暗相现前。六根黯然头足相类。彼人以手循体外绕。彼虽不见。头足一辩知觉是同。缘见因明暗成无见。不明自发则诸暗相永不能昏。根尘既销。云何觉明不成圆妙

议曰。此略示妄尽还源也。阿难闻入一无妄六根 一时清净之说未悟。教兴此问以启本无一六之谈。因示六妄本源以明所归之地耳。故世尊先审此根为一为六者意显此本元非一六义也。但由无始颠倒於圆湛体中一六义生。故譬虚空参合群器遂名为异。除器观空又说空为一。且虚空岂因器以成同异。同尚强名云何更说是一非一耶。了知此义则六受用根如此而已。不可作一六解也。问六根本是妙湛圆明之真心何以成此六根之妄想耶。答由明暗等下正示初成六根之妄相以示六妄之源也。由明暗等者意显六根本非有也。但由迷妙圆之真心妄成阿赖耶识谓之识精以因明立所遂有四大之妄尘。由明暗相形以击湛明之真体。因此黏湛而发妄见。见精映色久而取着。故结色成根而根初成之时乃四大之净色。以笼识精。及粗而为浮尘根於外故识精从此流进而奔於色等尘。此眼根之所以成也。由动静二尘以发耳根。由通寨二尘以发鼻根。由恬变二尘以发舌根。用离合二尘以发身根。由生灭二尘以发意根。皆例如眼根。此六根之所以成也。意根属心无形。而根元亦名清净四大者。谓初由妄见吸取父母之精血而识栖托於中。及五根既就而初结肉团居中名肉团心。故此属四大名浮尘根。而有一窍识精从此以奔法尘乃无明谷最初所结清净四大名胜义根以裹藏识。意根处此杳冥之中故如幽室见。圣人之心有七窍言其虚而明耳。已上通示六根生起之妄源。故总结之曰如是六根由彼觉明妄有明明之觉故失彼真精黏妄而发其精光耳。皆以缘尘而有离尘则无体矣。故曰无灭无生了知安寄。初以不知是妄故认无明为主宰爱取为受用。故依之而造业也。下示观心。故曰汝今若欲返妄归真但不循六尘随拔一根脱黏内伏伏归元真。则本有真心光明一旦发耀。若从一根耀性发明则五黏随脱不随前尘所起知见尽是真光独露耳。由此真明则不循六根之妄。但寄根以明疑。由是六根开通互相为用。此所以令汝速证安乐妙常亦汝六根更非他物也。下引不循六根之人岂不信哉。阿难下正示还源。谓今汝诸根若圆拔已则内莹发光如是浮尘根身及器世间如汤消冰应念化成无上知觉矣。如水成冰冰还成水。岂假於外哉。且岂知妄见皆借前尘。今不由前尘不因明而自然开发本有之真见则诸暗相永不能昏矣。所以障蔽妙明者根尘之过也。若根尘既消云何觉明之无明不成圆明之妙觉哉。是知真妄还源总不出六根之外也

上略显妄尽还源

四密示最初方便分二

初当机重疑断灭分二

初以真疑妄

阿难白佛言。世尊。如佛说言因地觉心欲求常住要与果位名目相应。世尊如果位中菩提涅盘真如佛性庵摩罗识空如来藏大圆镜智。是七种名称谓虽别。清净圆满体性坚凝。如金刚王常住不坏。若此见听离於明暗动静通塞毕竟无体。犹如念心离於前尘本无所有。云何将此毕竟断灭以为修因。欲获如来七常住果

二以妄疑真

世尊。若离明暗见毕竟空。如无前尘念自性灭。进退循环微细推求本无我心及我心所。将谁立因求无上觉。如来先说湛精圆常。违越诚言终成戏论。云何如来真实语者。惟垂大慈开我蒙吝

议曰。此将示闻性真常以密拣耳根为最初方便。故当机先设断灭之疑也。阿难问说六根离尘无体遂疑为断灭。故问佛果七种皆是常住。若果念心离於前尘本无所有则断灭矣。云何将此毕竟断灭以为修因欲获如来七常住果耶。故进退循环求而不知。遂起如来自语相违之疑

二巧示真常分五 初责许除疑

佛告阿难。汝学多闻未尽诸漏。心中徒知颠倒所因。真倒现前实未能识。恐汝诚心犹未信伏。吾今试将尘俗诸事当除汝疑

二击钟以验

即时如来敕罗候罗击钟一声。问阿难言汝今闻不。阿难大众俱言我闻。钟歇无声。佛又问言汝今闻不。阿难大众俱言不闻。时罗候罗又击一声。佛又问言汝今闻不。阿难大众又言俱闻。佛问阿难。汝云何闻云何不闻。阿难大众俱白佛言。钟声若击则我得闻。击久声销音响双绝则名无闻。如来又敕罗候击钟问阿难言尔今声不。阿难大众俱言有声。少选声销。佛又问言尔今声不。阿难大众答言无声。有顷罗候更来撞钟。佛又问言尔今声不。阿难大众俱言有声。佛问阿难汝云何声云何无声。阿难大众俱白佛言。钟声若击则名有声。击久声销音响双绝则名无声。

三正显真常分五 初拣定

佛语阿难及诸大众。汝今云何自语矫乱。大众阿难俱时问佛。我今云何名为矫乱。佛言。我问汝闻汝则言闻。又问汝声汝则言声。唯闻与声报答无定。如是云何不名矫乱。阿难。声销无响汝说无闻。若实无闻闻性已灭。同於枯木。钟声更击汝云何知。知有知无自是声尘或无或有。岂彼闻性为汝有无。闻实云无谁知无者

二正示

是故阿难。声於闻中自有生灭。非为汝闻声生声灭。令汝闻性为有为无。

责迷

汝尚颠倒惑声为闻。何怪昏迷以常为断。终不应言离诸动静闭塞开通说闻无性

四喻显

如重睡人眠熟床枕。其家有人於彼睡时捣练舂米。其人梦中闻舂捣声则作他物。或为击鼓。或为撞钟。却於梦时自怪其钟为木石响。於时忽寤遍知杵音。自告家人我正梦时惑此舂音将为鼓响。阿难是人梦中岂忆静摇开关通塞。其形虽寐闻性不昏

五显结

纵汝形销命光迁谢此性云何为汝销灭

四总结颠倒

以诸众生从无始来循诸色声逐念流转。曾不开悟性净妙常。不循所常逐诸生灭。由是生生杂染流转

五指归观心分三

初灭尘同觉

若弃生灭守於真常

二智起惑亡

常光现前根尘识心应时销落

三尘消觉净

想相为尘。识情为垢。二但远离。则汝法眼应时清明。云何不成无上知觉

议曰。此下世尊巧示真常也。阿难因疑此心离尘无体将为断灭。世尊试将俗事以验令其除疑。故令罗侯击钟以验。初击钟时问曰。闻否意在验闻性也。如来又敕罗侯击钟乃问声否是约声尘以验也。先已报言无闻矣。次又击时再问而报有声。若闻性果无则随时已灭不应又闻此声矣。故责之曰报答无定。以知有知无自是声尘或有或无耳。岂彼闻性为汝有无哉。若实无闻谁知无者。以此足征闻恒真常也。乃正示之曰声於闻中自有生灭非汝闻性为有为无。乃责之曰。汝尚惑声为闻。何怪以常为断。故不应言离彼动静前尘便说闻无性也。故说睡梦之人形寐而闻性不昏。以此足知纵汝形消命光迁谢。此性云何为汝消灭耶。此结显真常之义也。下示颠倒。以诸众生循诸色声逐念流转。不循所常逐诸生灭。故生生杂染流转。下指归观心。若弃生灭守於真常一旦常光现前则根尘识心应时消落矣。想相识情二俱远离。则根尘顿消而汝法眼应时清明。云何不成无上知觉耶。此已巧示真常。意显耳根可为最初方便。次下指结根元将明下手功夫耳

总示迷悟之根竟

大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第四


通议卷第五

通议卷第五

大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第五

唐天竺沙门般剌密帝译
乌苌国沙门弥伽释伽译语
菩萨戒弟子清河房融笔受
明南岳沙门憨山释德清述

二正示一心三观之相分二

初当机以真疑妄

阿难白佛言。世尊。如来虽说第二义门。今观世间解结之人若不知其所结之元。我信是人终不能解。世尊我及会中有学声闻亦复如是。从无始际与诸无明俱灭俱生。虽得如是多闻善根。名为出家。犹隔日虐。惟愿大慈哀愍沦溺。今日身心云何是结从何名解。亦令未来苦难众生得免轮回不落三有。作是语已。普及大众五体投地。雨泪翘诚伫佛如来无上开示

议曰。此下将示三观之相欲显即妄即真故约生灭以问也。阿难闻前第二义门已知生死结根。但不知今日身心云何是结从何名解。乃疑不知真妄之元。此特讲解结之方所谓下手之处。即是最初方便也。此大定法门非小因缘。故十方诸佛放光摄授同声说偈也

二佛示迷悟同源分四

初本尊安慰

尔时世尊怜愍阿难及诸会中诸有学者。亦为未来一切众生为出世因作将来眼。以阎浮檀紫金光手摩阿难顶

二诸佛证成分二

初光证道同

即时十方普佛世界六种震动。微尘如来住世界者各有宝光从其顶出。其光同时於彼世界来祗跎林灌如来顶。是诸大众得未会有

次言显一真

於是阿难及诸大众俱闻十方微尘如来异口同音告阿难言。善哉阿难。汝欲识知俱生无明使汝轮转生死结根。唯汝六根。更无他物。汝复欲知无上菩提令汝速证安乐解脱寂静妙常。亦汝六根更非他物

三当机重请

阿难虽闻如是法音心犹未明。稽首白佛。云何令我生死轮回安乐妙常同是六根更非他物

四世尊宣示分二

初长行分六

初指真源不二

佛告阿难根尘同源。缚脱无二

二示无明体空

识性虚妄犹如空花

三明根尘妄发

阿难。由尘发知因根有相

四明妄元无体

相见无性同於交芦

五示迷悟同源

是故汝今知见立知即无明本。知见无见斯即涅盘无漏真净

六指归真际

云何是中更容他物。尔时世尊欲重宣此义而说偈言。

议曰。诸佛先示迷悟同源然後乃示观相也。以阿难雨泪翘诚哀请之心极切。故世尊摩顶安慰而後告也。即时十方世界六种震动者表破根本无明则六根翻破故震动也。世界本唯一真故云普佛。微尘如来各有宝光同时来灌释迦顶者以表释迦所说顶法与诸佛道同也。诸佛异口同音告阿难者。以阿难初请十方如来得成菩提妙奢摩他三摩禅那最初方便。故今正示观相诸佛同告以表十方诸如来一道出生死。如所示者乃诸佛最初之方便也。使汝轮转生死结根唯汝六根更无他物。令汝速证安乐解脱亦汝六根更非他物以示诸佛修证皆同。欲令阿难谛信不疑也。此非阿难所知故致疑重请。本尊先指真源以示之曰根尘同一真源。缚脱本无二致。斯则直指一心更无剩法矣。谓既是一真无奈现有无明识性。故曰识性虚妄犹如空华本无所有。此言无明体空

也。疑是本空然则根尘从何而有。故曰由尘以发知。即所欲妄立生汝妄能也。因根有相谓无明虽空今既结成根则有妄相。此明根尘妄发也。即此见相二分原是无明所成。无明既是本空则此相见亦了无自性。故喻如交芦。盖芦体本空而交处亦空。此明妄元无体也。知见立知等者。谓无明根尘一一本空。空则一法不有。唯一真独存。但汝於所知所见性自天然不必更立知见。特强立一知见则是无明之本矣。是故即令返妄归真不必别修但於知见不起妄见。即是涅盘无漏真净矣。此示迷悟同源也。云何是中更容他物耶。此结指真际。而修行之要莫切於此矣。有未尽之义故重说偈言。

二偈颂正示观相分六

初依一心立三观之相

真性（本宗）有为空（空观） 缘生故如幻（假观）

无为无起灭。不实如空华（中观）

二即一心为所观之境

言妄显诸真 妄真同二妄（真妄双绝）

犹非真非真 云何见所见（根境两忘）

中间无实性 是故若交芦（无明体空）

结解同所因（迷悟同源） 圣凡无二路（归源无二）

汝观交中性 空有二俱非（直观中道）

迷晦即无明 发明便解脱（正出同源所以）

三依圆根为入理之门

解结因次第 六解一亦亡

根选择圆通 入流成正觉

四指生相无明为所断之惑

陀那微细识 习气成暴流

真非真恐迷 我常不开演

五顿证一心显三观之用

自心取自心 非幻成幻法（真妄互立）

不取无非幻妄灭真亡） 非幻尚不生

幻法云何立（真穷惑尽）

六诸佛同证结三观之名

是名妙莲花 金刚王宝觉

如幻三摩提 弹指超无学。

此阿毗达磨 十方薄伽梵

一路涅盘门。

议曰。此真性下至发明便解脱为应颂。正示三观之相义也。真性乃宗本也。谓真如妙性为万法之宗。故首标之。有为空此示空观也。谓诸有为法依真而立。虽有而性常自空。即此为空观。以空则唯一真如。了无一法。寂灭湛然故当奢摩他义也。缘

生故如幻此示假观也。谓真如体空以不变而随缘故成诸法。以诸法本无但以缘会而生。缘会而生（疑为灭字）。则未生无有。有而性常自空。故如幻耳。明照诸法当体如幻故当三摩义也。无为无起灭不实如空华此示中观也。谓真如无为本无起灭。今既随缘成事似有起灭。以幻体不实了然起处。故如空华。以空华本无起灭。而空体体一向寂然。谓真性寂然不碍随缘。虽任随缘而真源湛寂。斯则空有齐

彰中道颇显。故当禅那义。也然此三观总依一心以示其相。即首楞严大定。此定乃解结之秘诀破惑之神符也。佛佛成道皆以此为密因。而阿难最初便问此定。以迷妄根深故先破妄以显三观之体。及问行门乃审生死结根。今既知结根故请解结之方。至此诸佛方同声显示者足见此法甚深非谛信不疑者未可轻易拈出也。言妄显诸真一

偈半乃示即一心真源为所观之境。谓依一心建立三观。以此三观还照一心。故为观境。谓寂灭一心真妄双绝。且真之名但由妄显。若言妄言真总皆是妄。故曰妄真同二妄。且此心犹不说真与非真云何而有能见所见。是知能所皆因无明而立。若了无明体空则根尘自泯能所双忘。以根尘交处全体本空。空则不结。不结则根尘顿消。而解结之妙无尚此矣。结解同所因下为伽陀。乃出同源之所以也。谓迷一心而为无明妄立能所对待。根尘因此而结。今解亦因此而解。以圣凡同禀一心元无二路。今汝但观根尘相交之中本无实性从何而结耶。无明妄立故非空。虽有而无自性故非有。言空言有皆依无明。而湛寂一心空有两绝。故二俱非。汝但观此交中之性。迷晦即是无明。若发明即成解脱矣。何难之有哉。解结因次第下一偈意依圆根为入理之门。谓既有六结须次第解之。故曰因次第。若六结解而一亦不存。故曰六解一

亦亡。以此故须选择圆根。即可入流成正觉也。陀那下的指根本无明为所断之惑。谓能断者三观。此识甚深微细薰变难思。以习气内鼓使湛渊心体遂成瀑流。以真妄和合故曰真非真恐迷。谓恐外道二乘妄执为我起断常见。故寻常不敢开演也。今所断者正此识耳。自心取自心下五句示顿证一心以显三观之用。由迷真心而成业识变起根尘诸法。不达自心所现。故执取而起惑造业。岂非自心自心耶。因一取字故令非幻之真而成虚幻之妄法。今若返妄归真更无别法。只不取则根尘顿消。真且不立幻法从何而立耶。此真穷惑尽只在了此发业无明本空而润生之爱取则当下消亡。此所以不劳肯綮而顿证无生也。归真之要莫切於此。是名妙莲华下三句总结观名。谓此大定是名妙莲华。以本来无染故犹莲华。无坚不摧故名金刚王宝觉。即有以观空故曰如幻三摩提。弹指超无学者此显法利能取速效也。阿毗达摩此云无比法。显法胜也。十方薄伽梵一路湟盘门显佛佛同修同证也。一往开示妙义尽萃此章故判为正示观相。此外更无显了若此者。幸深观之。

上示三观之相竟

三略示解结方之分三 初经家叙致

於是阿难及诸大众。闻佛如来无上慈诲。只夜伽陀杂糅精莹。妙理清澈。心目开明叹未曾有。阿难合掌顶礼白佛。我今闻佛无遮大悲性净妙常真实法句

二当机启请分二 初问六解一亡

心犹未达六解一亡

二问舒结伦次

舒结伦次。惟垂大慈。再愍斯会及与将来。施以法音洗涤沈垢

议曰。此下略示解结之方也。阿难因闻解结次第。以未知六解一亡。舒结伦次。意请明下手之方也

三世尊巧示分二 初答六解一亡分三

初示根结所由分五

初借显妄迷一心而成五阴

即时如来於师子座。整涅盘僧敛僧伽梨。揽七宝几。引手於几取劫波罗天所奉华巾

二借显妄结五阴而成六根

於大众前绾成一结。示阿难言此名何等。阿难大众俱白佛言。此名为结。於是如来绾叠华巾又成一结。重问阿难此名何等。阿难大众又白佛言。此亦名结。

如是伦次绾叠华巾总成六结。一一结成。皆取手中所成之结。持问阿难此名何等。阿难大众亦复如是。次第酬佛此名为结

三借显一六义生

佛告阿难。我初绾巾汝名为结。此叠华巾先实一条。第二第三云何汝曹复名为结。阿难白佛言。世尊。宝叠华缉绩成巾虽本一体。如我思惟。如来一绾得一结名。若百绾成。终名百结。何况此巾只有六结。终不至七亦不停五。云何如来只许初时。第二第三不名为结

四借显六根同异

佛告阿难。此宝华巾。汝知此巾元止一条。我六绾时名有六结。汝审观察。巾体是同因结有异。於意云何。初绾结成名为第一。如是乃至第六结生。我今欲将第六结名成第一不。不也世尊。六结若存。斯第六名终非第一。纵我历生尽其明辩。如何令是六结乱名 。

五结合六根同异

佛言如是。六结不同。循顾本因一巾所造。令其杂乱终不得成。则汝六根亦复如是。毕竟同中生毕竟异

议曰。此巧示六结同异之元也。如来取劫波罗天所奉华巾将为结本者。以巾有五色。意表迷一真而为五蕴。将依此而妄分六根也。佛告阿难下征示一六义生也。以此华巾先实一条次第总成六结。正表元依一精明分成六和合也。此宝华巾下至生毕竟异借显六根同异也。上示巾结所由

二示六解一亡分二 初借显六解一亡

佛告阿难。汝必嫌此六结不成。愿乐一成复云何得。阿难言。此结若存是非蜂起。於中自生。此结非彼彼结非此。如来今日若总解除。结若不生则无彼此。尚不名一六云何成

二法合真妄不生

佛言。六解一亡亦复如是。由汝无始心性狂乱知见妄发。发妄不息劳见发尘。如劳目睛则有狂华於湛精明无因乱起。一切世间山河大地生死涅盘皆如狂劳颠倒华相

议曰。此示六解一亡。以显本无一六义也。佛问阿难汝必嫌此六结愿乐一成云何能得者意使阿难自悟六解一亡之义也。盖以一喻无明。六喻六根。阿难领知结若不生一尚无名云何成六。故佛印许亦复如是。此乃借事以明。故下正示之曰。由汝无始知见妄发发妄不息如目劳而见狂华。故於元湛精明一真体中无因乱起一切世间山河大地。而真净界中生死涅盘皆即狂劳颠倒华相。是所谓妄真同二妄。妄灭而真亦不存。六解一亡义见於此

三示解结之方分五 初借显二边无力

阿难言。此劳同结云何解除。如来以手将所结巾偏掣其左问阿难言。如是解不。不也世尊。旋复以手偏牵右边。又问阿难如是解不。不也世尊。佛告阿难。我今以手左右各牵竟不能解。汝设方便云何解成

二借显中道收功

阿难白佛言。世尊。当於结心解即分散

三借令直观中道

佛告阿难。如是如是。若欲除结当於结心

四正示成佛真因

阿难。我说佛法从因缘生。非取世间和合粗相。如来发明世出世法。知其本因随所缘出。如是乃至恒沙界外一滴之雨亦知头数。现前种种松直棘曲鹄白鸟玄皆了元由

五结示由根证入

是故阿难。随汝心中选择六根。根结若除尘相自灭。诸妄销亡不真何待

议曰。此正示解结之方也。阿难问云此劳同结云何解除。虽就巾结而问意在即请解根结之方。故以此劳同结为请。世尊巧示。乃以手左右偏掣而问阿难皆云不能解者。意显二边无力也。乃返令阿难汝设方便云何解成。阿难答曰当於结心解即分散。然如来岂不自知解结当心而返征阿难者正是欲令自知下手之处。故佛印许当於结心。意令直观中道也。下示成佛真因欲令当机谛信不疑。故佛自陈一切世出世法皆了元因。（矢引）此修行岂不知其节要耶。今则随汝心中选择六根。根结若除则尘相自灭。诸妄消亡不真何待。此的示由根证入也

上总答六解一亡


通议卷第五

通议卷第五

二答舒结伦次分四 初借显生因识有

阿难。吾今问汝此劫波罗巾六结现前。同时解萦得同除不。不也世尊。是结本以次第绾生

二借显灭从色除

今当须次第而解。六结同体结不同时。则结解时云何同除

三法合解结次第分三

初由中道断见思以证人空

佛言。六根解除亦复如是。此根初解先得人空

二由中道断尘沙以证法空

空性圆明成法解脱

三由中道断无明以证无生

解脱法已俱空不生

四结归观心

是名菩萨从三摩地得无生忍

议曰。此答舒结伦次也。结由次第而绾者借显生因识有。今亦次第而解者借显灭从色除也。上皆借事以显。下以法合解结次第。此根初解先得人空者。谓由奢摩中道观任运先断见思灭分段生死。故曰先得人空。此从观行以满十信也。空性圆明成法解脱者。谓由三摩中道观灭尘沙惑分破无明。乃从初住以去历三贤以至登地也。解脱法已俱空不生者。此由禅那中道观入初地。中中流入萨婆若海。此历十地以极等觉也。故结归观心乃曰是名菩萨从三摩地得无生忍解结之方无尚此矣。自非如来大慈何以曲尽如此哉

上示解结之方竟

议曰。按经通途。阿难最初启请十方如来得成菩提妙奢摩他三摩禅那最初方便。盖三观乃佛佛成道之本。所谓一道出生死。其最初方便乃各各发心悟道之本因。正如解结之功夫也。从前如来已为阿难巧示解结之方。审明下手之处。不啻三令五申矣。至此重假二十五圣旁通者正示各各最初悟道之方便也。如趋王城。家家有路透长安。 但出门一步。即在各人脚跟下随方取便耳。故圆觉修心而有二十五轮之观法。此经有二十五圣之妙门。即其人人悟处皆可还源。但取圆通本根处而易入。故选耳根为第一。此正除结当心敕二十五圣之意也

四广示最初方便分四 初当机特请当根

阿难及诸大众蒙佛开示慧觉圆通得无疑惑。一时合掌顶礼双足而白佛言。我等今日身心皎然快得无碍。虽复悟知一六亡义。然犹未达圆通本根。世尊。我辈飘零积劫孤露。何心何虑预佛天伦。如失乳儿。忽遇慈母。若复因此际会道成。所得密言还同本悟。则与未闻无有差别。惟垂大悲惠我秘严。成就如来最後开示。作是语已五体投地。退藏密机翼佛冥授。

二世尊借证密授分二 初世尊借问

尔时。世尊普告会中诸大菩萨及诸漏尽大阿罗汉。汝等菩萨及阿罗汉。生我法中得成无学。我今问汝。最初发心悟十八界谁为圆通。从何方便入三摩地。

议曰。此下广示最初方便也。阿难大众已悟一六亡义。但犹未达圆通本根。冀望开示。所得密言者已领六解一亡之义。谓诸如来所说之法也。还同本悟者谓先悟实相但於华屋未得门入犹与未闻等也。世尊不自开示乃问在会菩萨声闻者。意借各人所入之初心方便以显门门皆可证入也。冀佛冥授故如来默然假众以说

二诸圣证成分三 初诸圣宣示分二

初二十四圣别证分四 初六尘分六

一声尘

桥陈那五比丘即从座起。顶礼佛足而白佛言。我在鹿苑及於鸡园。观见如来最初成道。於佛音声悟明四谛。佛问比丘我初称解。如来印我名阿若多。妙音密圆。我於音声得阿罗汉。佛问圆通。如我所证。音声为上。

议曰。此下二十五圣由三科七大此从声尘而入者也。桥陈那此云火器。以先世为事火外道因以命族。五比丘乃佛最初得度者。佛出家时净梵乃命家族三人。一阿显婆。二跋提。三摩诃男拘利。舅氏二人。一桥陈那。二十力迦叶。敕此五人随卫。後舍佛各修异道。及如来成道思度五人。遂之鹿苑三转四谛法轮。问言解否。陈那答言巳解。佛印许。阿若多此云解。此由闻声得悟者

二色尘

优婆尼沙陀即从座起。顶礼佛足而白佛言。我亦观佛最初成道。观不净相生大厌离。悟诸色性以从不净白骨微尘归於虚空。空色二无成无学道。如来印我名尼沙陀。尘色既尽妙色密圆。我从色相得阿罗汉。佛问圆通。如我所证。色因为上

议曰。此由色尘而入者也。优波尼沙陀此云近少。亦云尘性空。由悟色性以得名。从不净观以至白骨微尘归於虚空

三香尘

香严童子即从座起。顶礼佛足而白佛言。我闻如来教我谛观诸有为相。我时辞佛宴晦清斋。见诸比丘烧沈水香。香气寂然来入鼻中。我观此气非木非空非烟非火。去无所著来无所从。由是意销发明无漏。如来印我得香严号。尘气倏灭妙香密圆。我从香严得阿罗汉。佛问圆通如我所证。香严为上

议曰。此由香尘而入者也。菩萨以童真入道故称童子。观香非木非空非烟非火则香严体空。去无所著来无所从。则尘境如如。由是意消。发明无漏

四味尘

药王药上二法王子并在会中五百梵天即从座起。顶礼佛足而白佛言。我无始劫为世良医。口中尝此娑婆世界草木金石。名数凡有十万八千。如是悉知若醋咸淡甘辛等味并诸和合。俱生变异。是冷是热有毒无毒悉能遍知。承事如来。了知味性非空非有。非即身心。非离身心。分别味因从是开悟。蒙佛如来印我昆季药王药上二菩萨名。今於会中为法王子。因味觉明位登菩萨。佛问圆通如我所证。味因为上

议曰。此由味尘而入者也。堪绍佛种故称法王子。药王多劫知味非一时也。了知味性本空约身心即根识与味尘对。观非即非离。则中道自显。分别味因则无明体空了证无生

五触尘

跋陀婆罗并其同伴十六开士即从座起。顶礼佛足而白佛言。我等先於威音王佛闻法出家。於浴僧时随例入室。忽欲悟水因。既不洗尘亦不洗体。中间安然。得无所有。宿习无忘。乃至今时从佛出家令得无学。彼佛名我跋跎婆罗。妙触宣明成佛子住。佛问圆通如我所证。触因为上

议曰。此由触尘而入者也。跋陀婆罗此云贤护。忽悟水因既不洗尘境空也。亦不洗体根空也。根尘既空而中间安然得无所有。此脱根尘而入空性

六法尘

摩诃迦叶及紫金光比丘尼等即从座起。顶礼佛足而白拂言。我於往劫於此界中有佛出世名日月灯。我得亲近闻法修学。佛灭度後供养舍利然灯续明。以紫光金涂佛形像。自尔以来世世生生身常圆满。紫金光聚。此紫金光比丘尼等即我眷属。同时发心。我观世间六尘变坏。唯以空寂修於灭尽。身心乃能度百千劫犹如弹指。我以空法成阿罗汉。世尊说我头陀为最。妙法开明销灭诸漏。佛问圆通。如我所证法因为上

议曰。此由法尘而入者也。摩诃迦叶此以大饮光氏。名毕钵罗。头陀第一。供佛舍利等。叙往因也。观六尘变坏生灭也。唯以空寂无生也。以观生灭得

证无生故曰空法

二五根分五 初眼根

阿那律陀即从座起。顶礼佛足而白佛言。我初出家常乐睡眠。如来诃我为畜生类。我闻佛诃啼泣自责。七日不眠失其双目。世尊示我乐见照明金刚三昧。我不因眼观见十方。精真洞然如观掌果。如来印我成阿罗汉。佛问圆通如我所证。旋见循元斯为第一

议曰。此下由五根而入者也。阿那律此云无贫。是佛堂弟。白饭玉之子。多乐睡眠。佛呵之曰。咄咄胡为寐。螺鲺蚌蛤类。一睡一千年。不闻佛名字。因此发愤不睡失明。依教修行遂得天眼通。不因眼观见十方者。所谓明不循根。不明自发。则诸暗相永不能昏

二鼻根

周利盘特迦即从座起。顶礼佛足而白佛言。我阙诵持无多闻性。最初值佛闻法出家。忆持如来一句伽陀於一百日得前遗後得後遗前。佛愍我愚教我安居。调出入息。我时观息微细穷尽。生住异灭诸行刹那。其心豁然得大无碍。乃至漏尽成阿罗汉。住佛座下印成无学。佛问圆通如我所证。反息循空。斯为第一

议曰。此由鼻根而入者也。周利盘特迦此云蛇奴。亦云继道。以生於路边故。性最愚钝。以前世为法师秘吝佛法故感愚报。五百比丘同教一偈。经九十日不能记忆。世尊教止散乱观出入息。遂得心开。返息循空离出入息也

三舌根

桥梵钵提即从座起顶礼佛足而白佛言。我有口业。於过去劫轻弄沙门。世世生生有牛（口司）病。如来示我一味清净心地法门。我得戒心入三摩地。观味之知非体非物。应念得超世间诸漏内脱身心外遣世界。远离三有如鸟出笼。离垢销尘法眼清净成阿罗汉。如来亲印登无学道。佛问圆通。如我所证还味旋知斯为第一。

议曰。此由舌根而入者也。桥梵钵提此云牛（口司）。牛事虚哨感报如之。非体非物则根尘两忘。故内脱身心外遣世界

四身根

毕陵伽婆蹉即从座起。顶礼佛足而白佛言。我初发心从佛入道。数闻如来说诸世间不可乐事。乞食城中心思法门不觉路中毒刺伤足举身疼痛。我念有知。知此深痛虽觉觉痛觉清净心无痛痛觉。我又思惟如是一身宁有双觉。摄念未久身心忽空。三七日中诸漏虚尽成阿罗汉。得亲印记发明无学。佛问圆通如我所证。纯觉还身斯为第一

议曰此由身根而入者也。毕陵伽婆蹉此云馀习。昔为婆罗门余习多慢如骂河神曰小婢之类。初入道时闻佛所说世间无常苦空之法故云不可乐事。心思法门而路中不觉毒刺伤足此苦事也。我念身有知而知此深痛。虽有知觉觉此深痛。返观觉心清净无有痛能痛。此觉心者是所谓纯觉遗身

五意根

须菩提即从座起。顶礼佛足而白佛言。我旷劫来心得无碍。自忆受生如恒河沙。初在母胎即知空寂。如是乃至十方成空。亦令众生证得空性。蒙如来发性觉真空。空性圆明得阿罗汉。顿入如来宝明空海。同佛知见印成无学。解脱性空我为无上。佛问圆通如我所证。诸相入非非所非尽旋法归无斯为第一

议曰。此由意根而入者也。须善提此云空生。又云善现。以生时库藏皆空解空为上。因久知空寂。故 从佛得闻性觉真空。遂得开悟。同佛知见者盖言分同佛所观空理。非全同也。非所非尽谓非所之非亦尽

三六识分六 初眼识

舍利弗即从座起。顶礼佛足而白佛言。我旷劫来心见清净。如是受生如恒河沙。世出世间种种变化一见则通。获无障碍。我於路中逢迦叶波兄弟相逐宣说因缘。悟心无际从佛出家。见觉明圆得大无畏成阿罗汉。为佛长子。从佛口生。从法化生。佛问圆通。如我所证心见发光光极知见。斯为第一

议曰。此用眼识而入者也。舍利弗此云鹫子。连母名也。旷劫以来心见清净则宿因已深。世出世间 种种变化谓四谛生灭法也。心见发光光极知见谓不由前尘所起知见

二耳识

普贤菩萨即从座起。顶礼佛足而白佛言。我已曾与恒沙如来为法王子。十方如来教其弟子菩萨根者修普贤行从我立名。世尊。我用心闻分别众生所有知见。若於他方恒沙界外有一众生心中发明普贤行者我於尔时乘六牙象分身百千皆至其处。纵彼障深未得见我。我与其人暗中摩顶。拥护安慰令其成就。佛问圆通。我说本因心闻发明分别自在。斯为第一

议曰。此由耳识而入者也。行秘法界曰普。位邻极圣曰贤。若耳识分别则有限量。今以心闻故心遍十方。而闻亦遍法界。众生所有知见不出此心之外。故能一一分别也。但有心契普贤行者即为摄受拥护。以心闻故分别自在

三鼻识

孙陀罗难陀即从座起。顶礼佛足而白佛言。我初出家从佛入道。虽具戒律於三摩地心常散动未获无漏。世尊教我及俱希罗观鼻端白。我朝谛观经三七日见鼻中气出入如烟。身心内明圆洞世界。遍成虚净犹如琉璃。烟相渐消鼻息成白。心开漏尽。诸出入息化为光明照十方界得阿罗汉。世尊记我当得菩提。佛问圆通我以消息息久发明明圆灭漏。斯为第一

议曰。此由鼻识而入者也。孙陀罗难陀此云艳喜。兼妻得名也。乃佛亲弟。出家之初因心散动故佛教令观鼻端白。所以注心不涉攀缘。故为依鼻识也。前数息但依根耳。诸出入息化为光明以离识故心光发越照十方界。

四舌识

富楼那弥多罗尼子即从座起。顶礼佛足而白佛言。我旷劫来辩才无碍。宣说苦空深达实相。如是乃至恒沙如来秘密法门。我於众中微妙开示得无所畏。世尊知我有大辩才以音声轮教我发扬。我於佛前助佛转轮。因师子吼成阿罗汉。世尊印我说法无上。 佛问圆通。我以法音降伏魔怨消灭诸漏斯为第一

议曰。此由舌识而入者也。富楼那此云满。弥多罗此云慈。尼女称乃其母也。从旷劫来辩才无碍。则宿因已深。宣说苦空四谛生灭之法。而能达於实相是谓微妙开示者也。以舌识宣扬妙法而得漏尽是所谓善解法义随说悟入

五身识

优波离即从座起顶礼佛足而白佛言。我亲随佛逾城出家。亲观如来六年勤苦亲见如来降伏诸魔制诸外道。解脱世间贪欲诸漏。承佛教戒。如是乃至三千威仪八万微细性业遮业悉皆清净。身心寂灭成阿罗汉。我是如来众中纲纪。亲印我心。持戒修身众推为上。佛问圆通我以执身身得自在。次第执心心得通达。然後身心一切通利。斯为第一

议曰。此由身识而入者也。优波离此云近执。如来为太子时亲近执事之臣也。谓杀盗淫妄性本是罪。不待制止。犯而成业。故云性业。其馀即因过始制。制前犯即无罪。故云遮业。以二业既空故身心寂灭。以身戒圆明故身自在。心戒圆明故心自在

六意识

大目犍连即从座起顶礼佛足而白佛言。我初於路乞食。逢遇优楼频螺伽耶那提三迦叶波。宣说如来因缘深义。我顿发心得大通达。如来惠我袈裟著身须发自落。我游十力得无挂碍。神通发明推为无上成阿罗汉。宁唯世尊。十方如来叹我神力圆明清净自在无畏。佛问圆通。我以旋湛心光发宣如澄浊流久成清莹。斯为第一

议曰。此由意识而入者也。目犍连此云采菽氏。名拘律陀此云无节树。优楼频螺此云木瓜癃。伽耶此云城。亦山名。那提此云河。三伽叶波所住之处也。因缘深义谓无生法也。以意识生灭。今悟无生故心得通达。旋湛谓不逐生灭前尘。故心光发宣。

上由十八界而悟入者。下由七大而悟入者

四七大分七 初火大

乌刍瑟摩於如来前。合掌顶礼佛之双足而白佛言。我常先忆久远劫前性多贪欲。有佛出世名曰空王。说多淫人成猛火聚。教我遍观百骸四肢诸冷暖气。神光内凝此多淫心成智慧火。从是请佛皆呼召我名为火头。我以火光三昧力故成阿罗汉。心发大愿诸佛成道我为力士亲伏魔怨。佛问圆通我以谛观身心暖触无碍流通。诸漏既销生大宝焰登无上觉。斯为第一

议曰。此由火大而入者也。乌刍瑟摩此云火头。此火大非外火也。乃就自心欲火而观。化多淫心成智慧火。所谓性火耳。因如来藏具有真空性火。凡淫机一动助发淫心。故生为欲火死为业火。然淫欲为生死根本由性火以成。今遍观百骸四肢诸冷暖触本自性空。故淫心灭而智光现前。所谓生大宝焰

二地大

持地菩萨即从座起。顶礼佛足而白佛言。我念往昔普光如来出现於世。我为比丘常於一切要路津口田地险隘有不如法妨损车马我皆平填。或作桥梁。或负沙土。如是勤苦经无量佛出现於世。或有众生於辕（门贵）处要人擎物我先为擎。至其所诣放物即行。不取其直。毗舍浮佛现在世时世多饥荒。我为负人。无问远近唯取一钱。或有车牛被於泥溺。我有神力为其推轮拔其苦恼。时国大王延佛设斋。我於尔时

平地待佛。毗舍如来摩顶谓我当平心地则世界地一切皆平。 我即心开。见身微尘与造世界所有微尘等无差别。微尘自性不相触摩。乃至刀兵亦无所触。我於法性悟无生忍成阿罗汉。回心今入菩萨位中。闻诸如来宣妙莲华佛知见地我先证明而为上首。佛问圆通。我以谛观身界二尘等无差别。本如来藏虚妄发尘。尘销智圆成无上道。斯为第一。

议曰。此由地大而入者也。持地菩萨先平世界地是未达尘性本空。故因毗舍浮佛教平心地即得心开以心地平等则一切平等。故见自身微尘与外微尘等无差别。是悟微尘性空本无内外也。性不相触者如以空合空故也。尘性既空则一切皆空。故刀兵亦无所触耳。 人将头临白刃犹似斩春风者以悟尘性空故。尘销智圆则本如来藏矣

三水大

月光童子即从座起顶礼佛足而白佛言。我忆往昔恒河沙劫有佛出世名为水天。教诸菩萨修习水观入三摩地。观於身中水性无夺。初从涕唾如是穷尽津液精血大小便利。身中旋复水性一同。见水身中与世界外浮幢王刹诸香水海等无差别。我於是时

初成此观。但见其水未得无身。当为比丘室中安禅。我有弟子窥窗观室唯见清水遍在室中了无所见。童稚无知。取一瓦砾投於水内激水作声顾盼而去。我出定後顿觉心痛。如舍利弗遭违害鬼。我自思惟。今我已得阿罗汉道久离病缘。云何今日忽生心痛。将无退失。尔时童子捷来我前说如上事。我则告言。汝更见水可即开门入此水中除去瓦砾。童子奉教。後人定时还复见水瓦砾宛然。开门除出我後出定。身质如初。逢无量佛如是至於山海自在通王如来方得亡身。与十方界诸香水海性合真空无二无别。今於如来得童真名预菩萨会。佛问圆通我以水性一味流通得无生忍圆满菩提。斯为第一

议曰。此由水大而入者也。当为比丘。当尔时也。定成水观。有弟子者即见水满一室是知唯识所变也。昔有僧居山入火观则远见遍山火光。故知性水性火圆满周遍。但循业发现耳。初未忘身以定有出入故。亡身之後对待情忘。故内会之水与香水海性合真空无二无别。方显性水真空本圆周遍一味流通性无二故。

四风大

琉璃光法王子即从座起顶礼佛足而白佛言。我忆往昔经恒沙劫有佛出世名无量声。开示菩萨本觉妙明。观此世界及众生身皆是妄缘风力所转。我於尔时观界安立。观世动时观身动止。观心动念。诸动无二等无差别。我时觉了此群动性。来无所从。去无所至。十方微尘颠倒众生同一虚妄。如是乃至三千大千一世界内所有众生。如一器中贮百蚊呐啾啾乱鸣。於分寸中鼓发狂闹。逢佛未几得无生忍。尔时心开。乃见东方不动佛国。为法王子事十方佛。身心发光洞彻无碍。佛问圆通。以观察风力无依悟菩提心入三摩地。合十方佛传一妙心。斯为第一

议曰。此由风大而入者也。此风大但观诸众生身皆是妄缘风力所转。故一切群动俱属妄缘。本性寂灭。曰诸动无二。则知动无去来之相。而众生颠倒但於寂灭性中鼓发狂闹耳。动本无动。故於东方不动佛国为法王子。身无动止心无生灭。故身心发光洞彻无碍也

五空大

虚空藏菩萨即从座起。顶礼佛足而白佛言。我与如来定光佛所得无边身。尔时手执四大宝珠。照明十方微尘佛刹化成虚空。又於自心现大圆镜。内放十种微妙宝光。流灌十方尽虚空际。诸幢王刹来入镜内。涉入我身。身同虚空不相妨碍。身能善入微尘国土。广行佛事得大随顺。此大神力。由我谛观四大无依妄想生灭虚空无二佛国本同。於同发明得无生忍。佛问圆通我以观察虚空无边入三摩地。妙力圆明。斯为第一

议曰。此由空大而入者也。虚空是色之体。因迷真空妄结四大故失空性。今以四大宝珠照十方微尘佛刹化成虚空者以观四大圆明体合真空是所谓得无边身也。自心现大圆镜放光照十方尽虚空际此心合真空也。以大圆镜智平等显现故也。诸刹来入镜内涉入我身身同虚空不相妨碍者。良以镜智圆照身心寂灭依正平等。所以善入国土广行佛事也。得大随顺者则一一皆入平等法界矣

六识大

弥勒菩萨即从座起。顶礼佛足而白佛言。我忆往昔经微尘劫有佛出世名日月灯明。我从彼佛而得出家。心重世名。好游族姓。尔时世尊教我修习唯心识定入三摩地。历劫已来以此三昧事恒沙佛。求世名心歇灭无有。至然灯佛出现於世我乃得成无上妙圆识心三昧。乃至尽空如来国土净秽有无皆是我心变化所现。世尊我了如是唯心识故识性流出无量如来。今得授记次补佛处。佛问圆通我以谛观十方唯识。识心圆明入圆成实远离依他及遍计执得无生忍斯为第一

议曰此由识大而入者也。弥勒久修唯识法门。往昔出家心重世名者以迷智成识坚执我爱故心重世名。以耽染六尘游戏诸根故好游族姓。以根尘识三和合为界。界者种族义。以久修唯心识定历事多佛。了悟万法唯识。故求世名心歇灭无有。至然灯佛方成妙圆识心三味乃了国土净秽皆是内心变现。无量如来皆从识性流出。故得授记次补佛处。由观唯识得圆成实。逆离依他及遍计执故得无生法忍也。

七见大

大势至法王子与其同伦五十二菩萨即从座起。顶礼佛足而白佛言。我忆往昔恒河沙劫有佛出世名无量光。十二如来相继一劫其最後佛名超日月光。彼佛教我念佛三昧。譬如行人一专为忆一人专忘。如是二人若逢不逢或见非见。二人相忆二忆念深。如是乃至从生至生同於形影不相乖异。十方如来怜念众生如母忆子。若子逃逝虽忆何为。子若忆母如母忆时。母子历生不相违远。若众生心忆佛念佛现前当来必定见佛。去佛不远不假方便自得心开。如染香人身有香气。此则名曰香光庄严。我本因地以念佛心入无生忍。今於此界摄念佛人归於净土。佛问圆通。我无选择。都摄六根。净念相继。得三摩地。斯为第一

议曰。此由见大而入者也。唯此见大乃八识之见分也。以迷大圆镜智而为无明成阿赖耶识发起妄见故为见分。以妄见根身器界一切众生执取染污故成秽士。今将返妄归真故以念佛摄归净土则妄见一破诸秽顿除故。以念佛为破妄见之要术也。以此妄见本是智光故大势所师之佛为无量光。此见由迷智变起故如母之於子也。妄见妄流随情造业故如子逃逝。诸佛智愿摄化众生故如母忆子。若有返妄归真之志则如子忆母也。予母相忆岂无见面之时。若众生念念回光返照无有不见自心之佛也。如染香人者以由熏变之力也。故大势依此见大摄念佛人皆归净土都摄六根等者。以立见根尘念念执取念念成染造种种业。故临终见地狱恶相堕落生死。今念佛人於六根门头一切见闻觉知纯一净心唯佛现前念念成净。故临将见佛。故云都摄六根净念相继。此正不思议熏变之力。净土唯心见於此矣。然见乃生死之本。若参禅则曰不用求真唯须息见。若念佛则转染见而成净见。唯一见分有用与不用。此禅净之分也。

大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第五


通议卷第六

通议卷第六

大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第六

唐天竺沙门般剌密帝译
乌苌国沙门弥伽释迦译语
菩萨戒弟子清河房融笔受
明南岳沙门憨山释德清述

二观音耳根圆证分三

初述观行所由

尔时观世音菩萨即从座起。顶礼佛足而白佛言。世尊。忆念我昔无数恒河沙劫。於时有佛出现於世名观世音。我於彼佛发菩提心。彼佛教我从闻思修入三摩地

二述根获圆通分三

初此根初解先证人空分二

初亡前尘

初於闻中入流亡所。所入既寂动静二相了然不生

二尽内根

如是渐增。闻所闻尽

二空性圆明以证法空分二

初遣观智

尽闻不住觉所觉空

次遣重空

空觉极圆空所空灭

三俱空不生顿证一心

生灭既灭寂灭现前

三述入流成正觉分二

初总显顿超十地

忽然超越世出世间。十方圆明获二殊胜。一者上合十方诸佛本妙觉心。与佛如来同一慈力。二者下合十方一切六道众生。与诸众生同一悲仰

议曰。此观音耳根圆证也。於音言观则已不用耳闻矣。所师之佛名观音者显法有所本也。从闻思修者谓从闻中思而修之也。初於闻中入流亡所等者即前云此根初解先得人空也。六根顺流奔境故随情造业。今於耳根思修则不缘外境矣。入流者返流也。谓逆彼业流返观闻性。则不由前尘所起知见而闻性现前。故曰亡所。且未

观闻性之前。以境有动静。则听不出声矣。今观闻性寂然则境无动静之相。故曰了然不生。是亡前尘也。如是渐增等者。由境寂灭。复增观行。以所闻声尘既无动静则此闻根亦泯。故曰闻所闻尽。此尽内根也。尽闻不住等者此空性圆明成法解脱

也。谓根尘双泯为尽闻处。而亦不住尽闻之觉更增观行。根尘既泯而此观智亦亡。故觉所之觉亦空。此空观智也。空觉极圆等者。谓空观智之空至於极圆之处则空所空之空亦任运而灭。故曰空所空灭。此泯谛理遣重空也。生灭既灭等者明俱空不生也。如此重重遮遣至於无遣。故曰生灭既灭寂灭现前。此妙行已圆。三谛一心平等显现。故能忽然超越也。一念顿证故曰忽然然。十界依正皆寂灭一心所现影像故曰超越。圆满十方洞然无碍故曰圆明。即前云明相精纯一切变现不为烦恼皆合涅盘清净妙德。故上合诸佛本妙觉心。圆照自心众生无不愿度。故曰同一慈力。下与六

道一切众生共一法身。以众生心中之悲仰即诸佛拔苦之觉地。故曰同一悲仰。此二最胜一时获得是所谓圆通超余者也

二别显妙用无方分五

初证同体慈能三十二应

世尊。由我供养观音如来。蒙彼如来授我如幻闻熏闻修金刚三昧。与佛如来同慈力故。令我身成三十二应入诸国土

议曰。此观音所证由无缘慈上等佛心。故能三十二应以显妙用无方也。楞伽说有三种意生身。谓三昧乐意生身此当八地。觉法自性性意生身此自九地至等觉。种类俱生无行作意生身此由等觉入妙觉位圣种类身一时俱现。观音以如幻闻熏闻修金刚三昧力故一念顿证妙觉。而三十二应正当种类俱生无行作意生身。所谓普门示现也

世尊。若诸菩萨入三摩地进修无漏胜解现圆。我现佛身而为说法令其解脱

议曰。十地菩萨坐宝华王座垂成正觉。亦须别佛说教闻熏。令断最後生相无明。故观音现佛身而说法也。胜解现圆此指最极根本无分别智将圆满时。此正等觉位观行所证之智也。以离因位故曰解脱

若诸有学寂静妙明胜妙现圆。我於彼前现独觉身而为说法令其解脱

议曰。此现独觉身说法也。独觉出无佛世观缘悟道。亦名麟喻。言其独也。中乘各有资加二行名为有学。此後断惑便证无学。约自乘理智将证未证 故曰寂静妙明。菩萨现同类身而为说法令其证入故曰解脱

若诸有学断十二缘缘断胜性胜妙现圆。我於彼前现缘觉身而为说法令其解脱

议曰。梵语辟支迦罗此云独觉亦云缘觉。独但自悟即前所现。缘觉依教观十二因缘作流转还灭 二种观门。未发真前名为有学。用七十七智推因审因理智将圆故曰胜妙现圆。菩萨现同类身而为说法令其解脱也

若诸有学得四谛空修道入灭胜性现圆。我於彼前现声闻身而为说法令其解脱

议曰。此现声闻乘人也。四果前三名有学。第四阿罗汉果名为无学。将证生空故曰胜性现圆。菩萨现身说法令其速证

上先三乘身也

若诸众生欲心明悟不犯欲尘欲身清净。我於彼前现梵王身而为说法令其解脱

议曰此现修梵天行也。厌欲界是苦是粗是障。欣禅天是静是妙是离。故曰欲身清净。故菩萨现身为说四禅出入定法令其离欲生於梵世。此现色界天身也

若诸众生欲为天主统领诸天。我於彼前现帝释身而为说法令其成就

议曰。此现修地居天行也。爱统诸天谓帝释居仞利天统三十三天也。为说上品十善法令其成就

若诸众生欲身自在游行十方。我於彼前现自在天身而为说法令其成就

议曰。此现欲界第三四天也。慈恩云得异熟果随意所念胜下二天。下二天果依树而得今随欲得故名自在

若诸众生欲身自在飞行虚空。我於彼前现大自在天身而为说法令其成就

议曰。此现大自在天也。乐变化天他化自在。乐自乐他变为乐具而受用之。名大自在。

若诸众生爱统鬼神救护国土。我於彼前现天大将军身而为说法令其成就。若诸众生爱统世界保护众生。我於彼前现四天王身而为说法令其成就。若诸众生爱生天宫驱使鬼神。我於彼前现四天王国太子身而为说法令其成就

议曰。天大将军即帝释所管将也。分住三十二天各领鬼神镇护四方。四天王者下界之初天。於须弥腰各居一垛。统领鬼神每王二部。共八部神救护国界。天王太子即那吒之类。辅政统摄护世益人。菩萨现同类身。先令成就后令出离

上现六欲天身也

若诸众生乐为人王。我于彼前现人王身而为说法。令其成就

议曰。此现人王身也。王者往也。人皆归往四轮粟 散皆人之主。以上化下物无不从

若诸众生爱主族姓世间推让。我於彼前现长者身而为说法令其成就

议曰。此现长者身也。长者具有十德。谓姓贵位高大富威猛智深年耆行净礼备上叹下归十德全备名大长者

若诸众生爱谈名言清净自居。我於彼前现居士身而为说法令其成就

议曰。此现居士身也。博闻强识不求仕宦隐居求志故名居土

若诸众生爱治国土剖断邦邑。我於彼前现宰官身而为说法令其成就

议曰。此现宰官身也。国域也。邦封也。有功者封於此也。邑县邑。各有所典。故曰宰官。此葺治邦家移训风俗剖判决断民之枉直也

若诸众生爱诸数术摄卫自居。我於彼前现婆罗门身而为说法令其成就

议曰。此现婆罗门身也。婆罗门此云净行。咒禁算艺调养方法皆为数术。菩萨乘机现相奖而成之。 亦何物而不化

若有男子好学出家持诸戒律。我于彼前现比丘身而为说法令其成就

议曰。此现比丘身也。尸罗此云戒。毗尼此云律。由依律法防非止恶故名为戒。二百五十戒也

若有女人好学出家持诸禁戒。我於彼前现比丘尼身而为说法令其成就

议曰。此现比丘尼身也。尼女声。即女比丘。持五百戒也。既戒德自严轨物成化。进行弥速远出三界

若有男子乐持五戒。我於彼前现优婆塞身而为说法。令其成就。若有女子五戒自居。我於彼前现优婆夷身而为说法令其成就

议曰。此现男女二身也。优婆塞此云近事男。优婆夷此云近事女。乐持五戒。志慕清净。菩萨现身说法令其成就。五戒者。一不杀二不盗三不邪淫四不妄语五不饮酒。众生持此则成佛。真因从是建 立。 若五戒不持人天路绝

若有女人内政立身以修家国。我於彼前现女主身及国夫人命妇大家而为说法令其成就。若有众生不坏男根。我於彼前现童男身而为说法令其成就。若有处女爱乐处身不求侵暴。我於被前现童女身而为说法令其成就

议曰。现女主等身所以修家国而益群生。此菩萨之能事。宜为说法令其成就也。若童男童女皆志慕贞洁者。上皆因所愿慕而令其成就者也

若有诸天乐出天伦。我现天身而为说法令其成就。若有诸龙乐出龙伦。我现龙身而为说法令其成就。若有药叉乐度本伦。我於彼前现药叉身而为说法令其成就。若乾达婆乐脱其伦。我於彼前现乾达婆身而为说法令其成就。若阿修罗乐脱其伦。我於彼前现阿修罗身而为说法令其成就。若紧那罗乐脱其伦。我于彼前现紧那罗身而为说法令其成就。若摩呼罗伽乐脱其伦。我於彼前现摩呼罗伽身而为说法令其成就

议曰。乾达婆帝释之乐神也。性荡逸。药叉勇健修罗似 天而无天德性多慢故。紧那罗云疑神。以人而头有角。摩呼罗蟒形而腹行。此虽在佛会为八部之 众。而宿因毁戒恶缘故堕斯类。今愿慕出伦。故菩萨现身一一说法令其成就也

若诸众生乐人修人。我现人身而为说法令其成就。若诸非人有形无形有想无想乐度其伦。我於彼前皆现其身而为说法令其成就

议曰。此现人非人身也。六道之中唯人身难得。故曰鬼神沈幽愁之苦。乌兽怀橘（换犭旁）钺（换犭旁）之悲。修罗方嗔。 诸天耽乐。可以整心虑趣菩提唯人道为能耳。故乐人修人。谓可以亲近三宝见佛闻法故也。有形无形等者有形谓有色蕴。如下休咎精明等。无形谓无色蕴。如空散消沈等。有想谓有四蕴。如鬼神精灵等。无想谓无四蕴。精神化为土木金石等。此非人类也

是名妙净三十二应入国土身。皆以三味闻熏闻修无作妙力自在成就

议曰。此结归显心也。尽法界身本无出没何有升沉。但以迷本圆明是生颠倒。则知九界众生皆妙净明心之影像。犹如空华乱起乱灭。故出世三乘依之而远离。三界异类以之而轮回。菩萨圆证此心故一切影现於寂灭心中随其所欲而一一成就。非唯成就彼众。实显自性圆明。以不外於一念特应视之速耳。故结名曰皆以三昧闻熏闻修无作妙力自在成就也

二证同体悲能十四无畏

世尊。我复以此闻熏闻修金刚三昧无作妙力。与诸十方三世六道一切众生同悲仰故。令诸众生於我身心获十四种无畏功德

议曰。此由与诸众生同一悲仰故令得十四无畏功德也。言以金刚三昧无作妙力等者。以菩萨身心与诸众生无有二相。故菩萨之三昧即众生之业用。众生之悲仰即菩萨之悲仰也。故於菩萨身心之中令诸众生获十四种无畏功德。殆非有彼此而加之使然也

一者由我不自观音以观观者。令彼十方苦恼众生观其音声即得解脱

议曰。由菩萨不自观音但观闻性。根尘顿脱。故令苦恼众生观自称菩萨之音声即脱其苦也。观菩萨音声者。如众苦逼急忽称菩萨名号一声。即此一声称性而发全体现前。则苦不期脱而自脱矣。如人疾苦必呼父母或呼天而苦即易忍。类此可

知

二者知见旋复。令诸众生设入大火火不能烧。三者观听旋复。令诸众生大水所漂水不能溺

议曰。知见耀而若火。闻听沸而若水。始由四大分湛。今自既旅复一元。则了无尘相。故令众生水火不能害也

四者断灭妄想心无杀害。令诸众生入诸鬼国鬼不能害

议曰。妄想如鬼物。所以戕害法身而伤慧命者。今自既断除。故令众生鬼不能害也

五者熏闻成闻六根销复同於声听。能令众生临当被害刀段段坏。使其兵戈犹如割水亦如吹光性无摇动

议曰。以三昧力熏妄闻以成真闻则六根销复无有形碍。杀害为其有身。今销形同声无尘可对。既无尘可对则了无可触。以心水湛渊慧光圆满。故能令刀兵如割水吹光性无动摇矣

六者闻熏精明明遍法界。则诸幽暗性不能全。能令众生药叉罗刹鸠盘茶鬼及毗舍遮富单那等虽近其傍目不能视

议曰。闻熏精明慧性发光。则诸暗相永不能昏。鬼魅生於幽暗今既圆明故令诸鬼咸受幽气。如罗刹不能见太阳故目不能视

七者音性圆销观听返入离诸尘妄。能令众生禁系枷锁所不能着

议曰。诸尘系累六根桎梏。今即观听返入离诸尘妄。故能令禁系枷锁所不能着。系缚生於贪着。今既离尘则自不着矣

八者灭音圆闻遍生慈力。能令众生经过险路贼不能劫

议曰。六为贼媒自劫家宝。劫夺生於敌对。今既灭音圆闻。则六尘顿空。平等一照了无自他。故虽涉险而贼不能劫

九者熏闻离尘色所不劫。能令一切多淫众生远离贪欲。十者纯音无尘根境圆融无对所对。能令一切忿恨众生离诸嗔恚

议曰。贪欲以缘尘爱取。嗔恚以逆境激心。今以闻熏离尘根境皆空。既无可取亦无可对。所以能令众生远离贪欲嗔恚也

十一者销尘旋明。法界身心犹如琉璃朗彻无碍。能令一切昏钝性障诸阿颠迦永离痴暗

议曰。阿颠迦一阐提也。此言无信根。良以痴暗覆心故不生实信。今以闻熏三昧销尘复明。身心洞然永破诸暗。故能令昏钝性障众生永离痴暗也。

十二者融形复闻。不动道场涉入世间不坏世界。能遍十方供养微尘诸佛如来。各各佛边为法王子。能令法界无子众生欲求男者诞生福德智慧之男

议曰。男子有干事之能。融形复闻故形随闻性周遍法界。由涉入世间则能一身为无量身。供佛则表其能事。为法王子则克绍家业。以供佛故福德具足。以三昧故智慧圆满。由此故令无子众生即得福德智慧之男也。宜矣

十三者六根圆通。明照无二。含十方界。立大圆镜。空如来藏。承顺十方微尘如来秘密法门受领无失。能令法界无子众生欲求女者诞生端正福德柔顺众人爱敬有相之女

议曰。女有柔顺之德。六根圆通性无违逆随顺之至也。立大圆镜空如来藏虚受之至也。故微尘如来秘密法门皆能受领女德之象也。故令求女众生诞生端正柔顺之女也

十四当此三千大千世界百亿日月。现住世间诸法王子有六十二恒河沙数。修法垂范教化众生。随顺众生方便智慧各各不同。由我所得圆通本根发妙耳门。然后身心微妙含容周遍法界。能令众生持我名号与彼共持六十二恒河沙诸法王子二人福德正等无异。世尊。我一名号与彼众多名号无异。由我修习得真圆通

议曰。六十二恒河沙数诸法王子以权实二智教化众生。虽各各不同。然皆不离法界海慧。今既得圆通本根。则身心微妙周遍法界。即可以一身为无量身。又岂可以名数限量哉。全盘既彰则一多互融。所以能令持一名号与彼众多无异。而所求福德亦无有异也。由我修习得真圆通结成所以也

是名十四施无畏力福备众生

议曰。此结名也

三妙契涅盘能四思议分二

初总示

世尊。我又获是圆通修证无上道故又能善获四不思议无作妙德。

议曰。由妙契涅盘故得四不思议此总标也。由前云一切变现不为烦恼皆合涅盘清净妙德。以佛神力不可思议。众生业力不可思议。皆一心变现之妙。言思路绝不能名状其相也。令观音圆证一心。故诸佛全体业用自在。随机适时不可以类推。心不可思。言不能议。是谓无作妙德也

二别示分四 初现众多妙容

一者由我初获妙妙闻心。心精遗闻。见闻觉知不能分隔。成一圆融清净宝觉。故我能现众生妙容。能说无边秘密神咒。其中或现一首三首五首七首九首十一首如是乃至一百八首千首万首八万四千烁迦罗首。二臂四臂六臂八臂十臂十二臂十四十六十八二十至二十四如是乃至一百八臂千臂万臂八万四千母跎罗臂。二目三目四目九目如是乃至一百八目千目万目八万四千清净宝目。或慈或威或定或慧救护众生得大自在

议曰。此别明现容说咒不可思议也。根境双融曰妙。体绝称谓曰妙妙。以脱粘遗闻故六用不隔。纯一圆明清净宝觉。此德本已立则大用无方。故能现众多妙容能说无边神咒也。首出於众物。手有提接之功。目有照明之德。以众生迷本妙明而为八万四千尘劳烦恼。故众生业力不可思议。今圆证一心。故转业力而为妙用。故首出於群相。手应接无方。目照明无碍。此所以一切变现不为烦恼。皆合涅盘清净妙德。故神力不可思也。通身手眼。毛孔光明。齐观并契。调伏众生。应摄应折。故曰或慈或威。或以定动。或以智拔。故曰或定或慧。所以得大自在也

二现众多妙形

二者由我闻思脱出六尘。如声度垣不能为碍。故我妙能现一一形诵一一咒。其形其咒能以无畏施诸众生。是故十方微尘国土皆名我为施无畏者

议曰。众生六尘隔碍动必有苦故多畏。菩萨以闻思三昧之力六尘既脱无复障碍。则身能妙现多形。心能妙诵多咒。以形摄受。以咒加持。故能令众生得离怖畏。以此身心妙应无方。故微尘国土皆以施无畏者称之也

三能过化存神

三者由我修习本妙圆通清净本根。所游世界皆令众生舍身珍宝求我哀愍

议曰。菩萨以三昧力永离诸爱。故能令众生舍身珍宝而求哀其也

四能感而遂通

四者我得佛心说於究竟。能以珍宝种种供养十方如来。傍及法界六道众生。求妻得妻。求子得子。求三昧得三昧。求长寿得长寿。如是乃至求大涅盘得大涅盘

议曰。由以三昧力已得佛心究竟平等。故能以无限法施回向。是以种种珍宝供十方佛傍及六道一切众生。而世出世间凡有所求无不获益也

四结指定名

佛问圆通。我从耳门圆照三昧。缘心自在。因入流相得三摩提成就菩提斯为第一。

议曰。此结属观门也。耳门圆根从闻思修故名圆照三昧。法界一缘故心自在。始从逆流终成大定。故因入流相得三摩提。此为第一也

五述名由实立

世尊。彼佛如来叹我善得圆通法门。於大会中授记我为观世音号。由我观听十方圆明。故观音名遍十方界

议曰。所师之佛名观世音。授以如幻闻熏闻修金刚三昧。故得如上无量功德。是以果觉为因心也。今蒙授记为观世音者谓因果一如始终无二也。观听圆明则微尘普照故心遍而名亦遍。如日月照临之地而人皆知为日月也。故名遍十方。良以清净圆明声觉真心众生本具。但由无明暗蔽根尘妄隔爱取牵缠所以常在生死而不能超出者。此自心取自心之过也。今依圆通本根闻熏闻修金刚三昧。则称性法界圆照十方根尘识心应时消落法界大用一念现前。故三十二应十四无畏四不思议等微妙功德犹是以限量心知其少分耳。其实全体显现安可以数量求之哉

已上从桥陈那至此各述初心方便竟

二主伴齐证

尔时世尊於师子座从其五体同放宝光。远灌十方微尘如来及法王子诸菩萨顶。彼诸如来亦於五体同放宝光。从微尘方来灌佛顶。并灌会中诸大菩萨及阿罗汉。林水池沼皆演法音。交光相罗如宝丝网。是诸大众得未曾有。一切普获金刚三昧。即时天雨百宝莲华。青黄赤白间错纷糅。十方虚空成七宝色。此娑婆界大地山河俱时不现。唯见十方微尘国土会成一界。梵呗咏歌自然敷奏

议曰。此如来圆证诸圣圆通也。二十五圣各证法门独耳根最胜。以性圆周遍体叶真心。根尘妄隔。性自圆通。四大壅淤一真无碍。为诸佛入理之门。实众生归源之路。所以观音自陈所证功德难思。堪任此界当机最初方便。故诸佛主伴齐证。依正

光网交罗。此极尽一心之源。普遍微尘世界通身吐露。彻底掀翻。故世尊五体同放宝光还灌十方微尘诸佛菩萨。而彼诸圣亦同放宝光来灌佛及诸大众顶也。且林木池沼皆演法音交光相罗如宝丝网者正表自他不二。依正互融有情无倩齐成佛道。所以是诸大众一切普获金刚三昧。此则消习漏於刹那。廓众尘於一念。万行备於性天。宝觉圆於实际。故天雨百宝莲华。虚空成七宝色。净秽情亡故娑婆隐而不现。根尘消复故十方合成一界。至此则林木池沼皆演圆音风动水流通成法喜。故梵呗咏歌自然敷奏同为证成共宣法利。真实圆通其验如此

三敕文殊拣选智证分二

初如来特命

及是如来告文殊师利法王子。汝今观此二十五无学诸大菩萨及阿罗汉。各说最初成道方便。皆言修习真实圆通。彼等修行实无优劣前後差别。我今欲令阿难开悟二十五行谁当其根。兼我灭後此界众生入菩萨乘求无上道。何方便门得易成就。

二文殊奉敕分二 初三业请加

文殊师利法王子奉佛慈旨。即从座起。顶礼佛足。承佛威神说偈对佛

议曰。此佛敕文殊拣选圆通也。言彼等修行实无优劣者以三乘等观性空而得道也。但心有大小为差耳。既云实无优劣则门门皆可还源矣。但克合此方之机令其顺而易入故须拣选。非大智不能具拣法眼故特敕文殊也

二正陈偈颂分十二

初半偈显一心真源

觉海性澄圆 圆澄觉元妙

二偈半显依真起妄

元明照生所 所立照性亡

迷妄有虚空 依空立世界

想澄成国土 知觉乃众生

三偈半显返妄归真

空生大觉中 如海一沤发

有漏微尘国 皆依空所生

沤灭空本无 况复诸三有

四半偈显归源无二

归元性无二 方便有多门

五一偈显拣选所因

圣性无不通 顺逆皆方便

初心入三昧 迟速不同伦

议曰。文殊奉命将择之初先立一真法界为迷悟之本也。法界一心广大悉备故譬如海普纳百川也。谓此觉性本来湛寂圆通故曰觉海性澄圆。圆湛之觉元来妙明绝诸对待不属悟迷故曰元妙。以元明体中本有大智慧光明遍照法界义故。唯是一真了无能所之相。忽尔妄动于圆明体中遂形所相故曰圆明照生所。所妄既立则生妄能而元明之性失之矣。故曰所立照性亡。由无明力覆蔽灵明之妙空变为顽然无知之虚空故曰迷妄有虚空。依此顽空结成四大之幻色故曰依空立世界。由妄澄结而为无情之国土。色杂妄想想相为身故成有情之众生。此虚空世界众生皆因迷妄而有。些言迷真起妄也。虚空虽是广大然於大觉心中如海中之一沤耳。况依空所生之世界岂不渺乎小哉。若沤灭刚虚空本无。何况空中之国土又何从而寄耶。故下经云。一人发真归元十方虚空悉皆消殒。何况空中所有国土而不振裂。故曰况复诸三有。今欲返妄归真固当作如是观也。是则顿悟一心本不假於方便。真实归元之性本无有二。但随根不一各从其便。故方便有多门耳。在於圣性无往不通何须拣择。若顺若逆皆为方便。但以初心方便若顺而易入则收功速。若逆而难入则取效迟。故须用拣选以便悟入也


通议卷第六

通议卷第六

六二十四偈显拣非当机分二

初拣三科分三

初六尘 一优波尼

色想结成尘 精了不能彻 如何不明彻 於是获圆通

二桥陈那

音声杂语言 但伊名句味 一非含一切 云何或圆通

三香严童子

香以合中知 离则元无有 不恒其所觉 云何获圆通

四药王药上

味性非本然 要以味时有 其觉不恒一 云何获圆通

五跋陀婆罗

触以所触明 无所不明触 合离性非定 云何获圆通

六摩诃迦叶

法称为内尘 凭尘必有所 能所非遍涉 云何获圆通

二五根 一阿那律陀

见性虽洞然 明前不明後 四维厥一半 云何获圆通

二周利盘特迦

鼻息出入通 现前无交气 支离匪涉入 云何获圆通

三桥梵钵提

舌非入无端 因味生觉了 味亡了无有 云何获圆通

四毕陵伽婆蹉

身与所触同 各非圆觉观 涯量不冥会 云何获圆通

五须菩提

如根杂乱思 湛了终无见 想念不可脱 云何获圆通

三六识 一舍利弗

识见杂三和 诘本称非相 自体先无定 云何获圆通

二普贤菩萨

心闻洞十方 生於大因力 初心不能入 云何获圆通

三孙陀罗难陀

鼻想本权机 只令摄心住 住成心所住 云何获圆通

四富楼那

说法弄音文 开悟先成者 名句非无漏 云何获圆通

五优波离

持犯但束身 非身无所束 元非遍一切 云何获圆通

六大目犍连

神通本宿因 何关法分别 念缘非离物 云何获圆通

次拣七大分七

初地大 持地菩萨

若以地性观 坚碍非通达 有为非圣性 云何获圆通

二水大 月光童子

若以水性观 想念非真实 如如非觉观 云何获圆通

三火大 鸟刍瑟摩

若以火性观 厌有非真离 非初心方便 云何获圆通

四风大 琉璃光法王子

若以风性观 动寂非无对 对非无上觉 云何获圆通

五空大 虚空藏菩萨

若以空性观 昏钝先非觉 无觉异菩提 云何获圆通

六识大 弥勒菩萨

若以识性观 观识非常住 存心乃虚妄 云何获圆通

七见大 大势至法王子

诸行是无常 念性元生灭 因果今殊感 云何获圆通

七十二偈半的指圆通要妙分二

初十偈半指法显胜分二

初偈半指法

我今白世尊 佛出娑婆界 此方真教体 清净在音闻

欲取三摩提 实以闻中入

议曰。此文殊拣选二十四圣皆不堪任此方之机。何耶。若於六尘而入六尘妄结而不一。若於五根而入五根隔越而不通。若於六识而入六识则生灭宛然。若於五大而入五大则无知昏钝。若於识大而入识性本非常住。若於见大而入念性元是无常。是皆不合此方之机。难入圆通根本。以此方真教体清净在音闻。若欲速取三摩提。实从闻中而入即时离苦得解脱也

次九偈显胜分二

初十句赞能修人胜

离苦得解脱 良哉观世音 於恒沙劫中 入微尘佛国

得大自在力 无畏施众生 妙音观世音 梵音海潮音

救世悉安宁 出世获常住

议曰。此总叹观音之德也。入微尘国得大自在此 叹三十二应也。无畏施众生此叹十四无畏也。从音入妙故曰妙音。圣人无己以物为己。故唯观世间音声以成己德故曰观世音。於音无着故曰梵音。应不失时故曰海潮音。以此故令世出世间皆获利益故安宁常住也

次二十六句赞所入根胜分二

初显独胜馀根分三 初六句圆胜

我今启如来 如观音所说 譬如人静居 十方俱击鼓

十处一时闻 此则圆真实

二八句通胜

目非观障外 口鼻亦复然 身以合方知 心念纷无绪

隔垣听音响 遐迩俱可闻 五根所不齐 是则通真实

三八句常胜

音声性动静 闻中为有无 无声号无闻 非实闻无性

声无既无灭 声有亦非生 生灭二圆离 是则常真实

次结馀根不及

纵令在梦想 不为不思无 觉观出思惟 身心不能及

次二偈显迷悟因依

今此娑婆国 声论得宣明 众生迷本闻 循声故流转

阿难纵强记 不免落邪思 岂非随所沦 旋流获无妄

议曰。我今下五偈半正叹圆通之妙也。十方击鼓十处齐闻了无分别彼此之相。此圆真实也。隔垣听音响此法性通遍远近皆闻。五根之所不齐。此则通真实也。音声虽有动静闻性不属有无。不因声生。不从声灭。远离有无生灭。此即常真实也。以此足证二十四圣之所不及也。纵令下一偈总叹超越身心。以身心有寤寐开合而闻性不为梦想所昏。至若梦中尚闻杵声虽作他物不是无闻。是所谓不为不思而无也。以五根发识皆有遍行之思不能圆照。独耳根虚融音声一到则无思无念寂然而照。特出思惟之表。此身心之所不能及也。今此下二偈正显克合此方之机。以诸佛国土说法不同。非独语言。以娑婆世界众生耳根最利。但以声论宣明道理。非耳不能了达。以闻性即本圆法性。由众生迷本有之闻性故流转於生死。纵阿难之强记多闻以不达闻性亦不免落於邪思。是知此界耳根关系甚重。岂不是随音声则沦生死旋闻机则获真常无妄哉。是以独选耳根为妙也。

八十七句结法劝修分三

初五句结指定门

阿难汝谛听 我承佛威力 宣说金刚王 如幻不思议

佛母真三昧

二四句责多闻无益

汝闻微尘佛 一切秘密门 欲漏不先除 畜闻成过误

三八句劝真修有功分四 初正劝修

将闻持佛佛 何不自闻闻

二闻非妙悟

闻非自然生 因声有名字

三妙悟绝言

旋闻与声脱 能脱欲谁名

四离言顿证

一根既返源 六根成解脱

议曰。此结法劝修以显法胜也。阿难下五句结法也。汝闻下一偈显多闻无益。将闻二句劝修也。诸佛由此三昧而出故曰佛母。诸佛言教文字般若即法身所在。法亦名佛故曰持佛佛。谓虽能持他佛之法如人数他宝自无半钱分。故不若返照自己闻性以成真实三昧即可顿证菩提也。闻非下六句显妄不是真。谓逐声尘之闻根非自然生要

因声显。特妄闻之名字耳。若旋其妄闻而脱声尘则能脱者当谁名耶。此所以一根既返源六尘成解脱也

九七偈半示观相分三

初正示三观涉入分三

初四句从假入空

见闻如幻翳 三界若空花 闻复翳根除 尘消觉圆净

二六句从空入假

净极光通达 寂照含虚空 却来观世间 犹如梦中事

摩登伽在梦 谁能留汝形

三十三句从空假入中分二 初喻明

如世巧幻师 幻作诸男女 虽见诸根动 要以一机抽

息机归寂然 诸幻成无性

二法合

六根亦如是 元依一精明 分成六和合 一处成休复

六用皆不成 尘垢应念消 成圆明净妙

二二句明观浅深

馀尘尚诸学 明极即如来

议曰。此二十五句依耳根圆示三观之相也。见闻下一偈显从假入空观。举见闻则该知觉。总示六根虚妄犹如幻翳。通观三界总若空华。但於闻性旋复则六根并除六尘亦消而本有觉性自然圆净矣。此由观假以入空也。净极下一偈半显从空入假观也。若诸尘净极。则心光独露。通达无碍。寂而常照。包含虚空自性圆明。回观世间如梦中事耳。若以此观安心则摩登伽亦在梦中谁能留汝形骸耶。此由空以涉假也。如世巧幻师下十五句显从先假次空以入中道观也。初一偈半设喻。机喻识性。若息机寂然则诸幻无性幻事亦不成矣。下七句法合。六根亦如幻事耳。元依一精明之识体分成六用之和合。若一处休复则六用不成。一破根本无明则根尘识三皆是真心之尘垢则应念消亡。而向之无明昏味之识体转成圆明净妙之德矣。是则不堕空假而顿证一心中道矣。耳根三昧妙绝於斯。岂可不亟圆修习哉。馀尘下二句明观浅深。若馀尘未净尚在学位。若妙心明极则成如来。是所谓去泥纯水名为永断根本无明故径登佛地也

三五句示解结之方

大众及阿难 旋汝倒闻机 反闻闻自性 性成无上道

圆通实如是

十两偈半例结同证

此是微尘佛 一路涅盘门 过去诸如来 斯门已成就

现在诸菩萨 今各入圆明 未来修学人 当依如是法

我亦从中证 非唯观世音

议曰。此十五句总结观行以显因果同证也。大众下五句正结观行。谓此耳根圆通并无别法。但旋汝等倒妄之闻机。返闻自己之闻性。若闻性圆明则顿成无上道矣。最为简要。又何别求佛法哉。圆通真实如是而已。此是下十句显同证。此是十方诸佛一路涅盘门也。过去已成之佛皆由斯门成就。即现在菩萨各入圆明。未来修行当依此法。文殊自谓我亦从中证。不但观世音以此亲证法门足证真实无妄也

十一四偈报命请加分二

初十一句报命

诚如佛世尊 询我诸方便 以救诸末劫 求出世间人

成就涅盘心 观世音为最 自馀诸方便 皆是佛威神

即事舍尘劳 非是长修学 浅深同说法

次五句请加

顶礼如来藏 无漏不思议 愿加被未来 於此门无惑

方便易成就

十二五句的授当机

堪以教阿难 及未劫沈沦 但以此根修 圆通超馀者

真实心如是

议曰。此报命请加以的授当机也。诚如佛世尊下十一句报命也。谓诚如世尊询问我择诸方便门若易成就涅盘心无过观音耳根为最也。其余诸方便门虽云实无优劣。於我揆之。皆是仗佛之威神令其即事以舍尘劳。非是可以通长修学浅深同说一贯之法也。顶礼下五句请加也。然请加宜独请佛。今顶礼如来藏乃指法也。以如来藏乃三德秘臧。三身圆证。三宝圆具。一体无碍。云不思议。故但礼其法而三身三宝具焉。所以愿被未来於此耳门分明无惑。唯此方便最易成就故末後的授当机。此可以教阿难及末劫众生但依此根修则圆通实超馀者。真实心要如此而已。是以自誓不妄也

上敕文殊拣选圆通竟

三当机领悟

於是阿难及诸大众身心了然得大开示。观佛菩提及大涅盘。犹如有人因事远游未得归还。明了其家所归道路。

四法会获益

普会大众天龙八部有学二乘及诸一切新发心菩萨。其数凡有十恒河沙。皆得本心还尘离垢获法眼净。性比丘尼闻说偈已成阿罗汉。无量众生皆发无等等阿耨多罗三藐三菩提心

议曰。此法会获益也。阿难所问诸佛成道最初方便。佛示之曰十方薄伽梵一路涅盘门。又曰菩提涅盘尚在遥远。故闻圆通本根身心了然。故於菩提涅盘。如人远游虽未归还。已知归家道路。则自信决定无疑矣。普会大众皆得本心获法眼净。性比丘尼得阿罗汉果。其馀众生皆发菩提心者。由闻说圆通本根之利益也。

从前请入华屋以来至此通示妙圆自利理行竟

二示利他妙圆事行分二

初当机陈请分三 初自利功圆

阿难整衣服於大众中合掌顶礼。心迹圆明。悲欣交集。欲益未来诸众生故。稽首白佛。大悲世尊。我今已悟成佛法门。是中修行得无疑惑

二陈利他愿度

常闻如来说如是言。自未得度先度人者菩萨发心。自觉已圆能觉他者如来应世。我虽未度愿度末劫一切众生

三陈利他所为分二 初为邪道乱真

世尊。此诸众生去佛渐远。邪师说法如恒河沙。

二为催邪显正分二 初问摄心轨则

欲摄其心入三摩地

二问安立道场

云何令其安立道场。远诸魔事。於菩提心得无退屈

二世尊许说分二 初赞许诫听

尔时世草於大众中称赞阿难。善哉善哉。如汝所问安立道场救护众生末劫沉溺。汝今谛听当为汝说。阿难大众唯然奉教

议曰。此问利他行也。心所乃心行处谓之心迹。向以无明暗覆故为所使。今闻开示生灭头数了然自见故曰圆明。已知众生同体故自未度先预度人故为利他行也。悬知末世邪师说法趣菩提者难以得正熏修。不知如何为摄心轨则如何安立道场远离魔事也。此先答摄心轨则以三无漏学为修行之本

次许说分际分二 初答摄心轨则分二

初总示三无漏学为修行之本

佛告阿难汝常闻我毗奈耶中宣说修行三决定义。所谓摄心为戒。因戒生定。因定发慧。是则名为三无漏学

议曰。此略标三决定义为修行之本也。毗奈耶云律。谓欲修定慧必以戒为基本故曰摄心为戒则定慧由之而生也。意以戒为重。故定已说。此特宣戒。故下令持四根本戒制断发业润生二种无明

二别示三聚戒为成佛之基分四

初略出戒体

阿难。云何摄心我名为戒

二正示修相分五

初令持四根本戒制断发业无明分四

一不淫戒分六 初通显能持利益

若诸世界六道众生其心不淫则不随其生死相续

二显不持过误

汝修三昧本出尘劳。淫心不除尘不可出。纵有多智禅定现前。如不断淫必落魔道。上品魔王中品魔民。下品魔女。彼等诸魔亦有徒众。各各自谓成无上道。我灭度後末法之中多此魔民炽盛世间。广行贪淫为善知识。令诸众生落爱见坑失菩提路。

三令依教当持

汝教世人修三摩地先断心淫。是名如来先佛世尊第一决定清净明诲

四显持犯得失

是故阿难。若不断淫修禅定者如蒸砂石欲其成饭。经百千劫只名热砂。何以故。此非饭本砂石成故。汝以淫身求佛妙果。纵得妙悟皆是淫根根本成淫。轮转三涂必不能出。如来涅盘何路修证

五以必断为真

必使淫机身心俱断。断性亦无。於佛菩提斯可希冀

六以实相印定

如我此说名为佛说。不如此说即波旬说

议曰。此示修三无漏学以戒为本而以淫戒为首也。戒有多品以四重为先。梵网诸本皆以不杀为首。此经独以断淫为首者。彼约利生以佛性种子而观众生故首断杀。此示真修以淫欲为生死根本故先断淫。故曰其心不淫则不随其生死相续。梵网经说卢舍那佛坐于华台。一叶一释迦奉舍那敕以心地法门金刚宝戒宣传於十方世界。若人受佛戒则登诸佛位。是知释迦出世说法四十九年但传舍那所说金刚宝戒而已。以此经统收一代时教修证理行因果。首楞严大定乃成佛真因。以戒为本。戒心清净即入佛位。故此经云其心不淫则不随其生死相续。前云众生相续欲贪为本。故今愿出生死必以断淫为第一也。修禅之人若不断淫。如以甘露灌溉毒树。灌溉益深而毒气愈盛。所以必落魔道也。蒸砂作饭终竟不成以非饭本也。以淫心而求佛妙果纵得妙悟皆滋淫根生死转剧何以得出三涂登涅盘之路哉。斯之一法先执身不行。次执心不起。故曰必使淫机身心永断。如此可以冀佛菩提。苟不痛心刻骨必成魔说矣

二不杀戒分六 初通显能持利益

阿难。又诸世界六道众生其心不杀则不随其生死相续

二显不持过误

汝修三昧本出尘劳。杀心不除尘不可出。纵有多智禅定现前。如不断杀必落神道。上品之人为大力鬼。中品则为飞行夜叉诸鬼帅等。下品当为地行罗刹。彼诸鬼神亦有徒众。各各自谓成无上道。我灭度後末法之中多此鬼神炽盛世间。自言食肉得菩提路。阿难。我令比丘食五净肉。此肉皆我神力化生本无命根。汝婆罗门地多蒸湿加以砂石草菜不生。我以大悲神力所加。因大慈悲及名为肉。汝得其味。奈何如来灭度之后食众生肉名为释子。汝等当知是食肉人纵得心开似三摩地皆大罗刹。报终必沈生死苦海非佛弟子。如是之人相杀相吞相爱未已。云何是人得出三界

三令依教当持

汝教世人修三摩地次断杀生。是名如来先佛世尊第二决定清净明诲

四显持犯得失

是故阿难。若不断杀修禅定者。譬如有人自塞其耳。高声大叫求人不闻。此等名为欲隐弥露。清净比丘及诸菩萨於岐路行不蹋生草况以手拔。云何大悲取诸众生血肉充食。若诸比丘不服东方丝线绢帛及是此土靴履裘毛乳酪醍醐。如是比丘於世真脱。酬还宿债不游三界。何以故。服其身分皆为彼缘。如人食其地中百谷足不离地

五以必断为真

必使身心於诸众生若身身分。身心二涂不服不食。我说是人真解脱者。

六以实相印定

如我此说名为佛说。不如此说即波旬说。

议曰。此第二诫决定不杀戒也。修禅若不断杀必堕鬼神罗刹之类。以此类专恣杀业。今以杀习感召故也。律部佛许比丘食五净肉。谓自死鸟残不见杀不因杀不为己杀皆得食之。嗣後比丘皆恣鲜美自杀而食。佛遂制止。况五净肉皆神力所化本无命根食之犹可。今则真食血肉岂慈悲者哉。罗刹飞行而食生物者言其杀心炽盛也。杀生冤债相牵云何欲出生死耶。是故修禅必以断杀为本也。服其身分恐为彼缘。况食肉乎。必使身心二涂不服不食。是人名为真解脱者。不如此说即波旬说也。

三不偷戒分六 初通显能持利益

阿难。又复世界六道众生其心不偷则不随其生死相续。

二显不持过误

汝修三昧本出尘劳。偷心不除尘不可出。纵有多智禅定现前。如不断偷心落邪道。上品精灵中品妖魅。下品邪人。诸魅所著。彼等群邪亦有徒众。各各自谓成无上道。我灭度後未法之中多此妖邪炽盛世间。潜匿奸欺（内心）称善知识（外貌诈现有德）各自谓已得上人法。玄惑无识恐令失心。所过之处其家耗散。我教比丘循方乞食。令其舍贪成菩提道。诸比丘等不自熟食。寄於残生旅泊三界。示一往还去已无返。云何贼人假我衣服。裨贩如来造种种业皆言佛法。却非出家具戒比丘为小乘道。由是疑误无量众生堕无间狱。若我灭後。其有比丘发心决定修三摩提。能於如来

形像之前身然一灯。烧一指节。及於身上（艹热）一香炷。我说是人无始宿债一时酬毕。长揖世间永脱诸漏。虽未即明无上觉路。是人於法已决定心。若不为此舍身微因。纵成无为。必还生人酬其宿债。如我马麦正等无异

三令依教当持

汝教世人修三摩地後断偷盗。是名如来先佛世尊第三决定清净明诲。

四显持犯得失

是故阿难。若不断偷修禅定者。譬如有人水灌漏卮欲求其满。纵经尘劫终无平复。若诸比丘衣钵之余分寸不蓄。乞食余分施饿众生。於大集会合掌礼众。有人捶詈同於称赞

五以必断为真

必使身心二俱捐舍。身肉骨血与众生共。不将如来不了义说迥为已解以误初学。佛印是人得真三昧。

六以实相印定

如我所说名为佛说。不如此说即波旬说

议曰。此第三诫决定不偷戒也。此偷非偷盗之偷乃偷心也。谓贪求施利潜匿奸欺诈现有德称善知识多取资具诳惑而取与盗窃等而酬偿并等。故教比丘循方如法乞食令舍贪也。盖以不达五蕴虚假故多取资财以养身命。本无道德假佛形服。所谓裨贩如来。信心难消必偿宿债。是故生死不能出离。佛教比丘然灯然指舍正报之身酬身外之之负盖以微因而偿多欠也。佛于毗兰邑王马厩食马麦三月。以先世诟骂比丘为食马麦者偿此报。以一恶言尚必酬之。况多贪乎。此必难逃其负也。前业果相续乃强取众生之血肉起於杀贪。此乃妄取众生之资财起於盗贪故通名偷盗。以滋生死之业果一也。若不断偷以定水而灌破戒漏卮终无益也。衣钵之馀分寸不蓄。乞食之馀施饿众生。不贪之至也。以捶詈而同称赞无我之至也。心不起嗔。身不加报。是为身心二俱捐舍。且观己身血肉与众生共平等无二。况身外之长物乎。非得真三味者不能也。反此即为波旬说矣

四不妄语戒分六 初通显能持利益

阿难。如是世界六道众生虽则身心无杀盗淫三行已圆

二显不持过误

若大妄语即三摩地不得清净。成爱见魔。失如来种。所谓未得谓得未证言证。或求世间尊胜第一谓前人言。我今已得须跎洹果斯陀含果阿那含果阿罗汉道辟支佛乘十地地前诸位菩萨。求彼礼忏贪其供养是一颠迦。销减佛种。如人以刀断多罗木。佛记是人永殒善很无复知见。沈三苦海不成三昧。我灭度後敕诸菩萨及阿罗汉应身生彼末法之中作种种形度诸轮转。或作沙门白衣居士人主宰官童男童女如是乃至淫女寡妇奸偷屠贩。与其同事称赞佛乘令其身心入三摩地。终不自言我真菩萨真阿罗汉泄佛密因轻言未学。唯除命终阴有遗付。云何是人惑乱众生成大妄语

三令依教当持

汝教世人修三摩地後复断除诸大妄语。是名如来先佛世尊第四决定清净明诲

四显持犯得失

是故阿难。若不断其大妄语者。如刻人粪为旃檀形欲求香气无有是处。我教比丘直心道场。於四威仪一切行中尚无虚假。云何自称得上人法。譬如穷人妄号帝王自取诛灭。况复法王如何妄窃。因地不真果招纡曲。求佛菩提如噬脐人。欲谁成就

五以必断为真

若诸比丘心如直弦一切真实。入三摩地永无魔事。我印是人成就菩萨无上知觉

六以实相印定

如我所说名为佛说。不如此说即波旬说

议曰。此第四诫决定不妄语戒也。此妄语业由贪痴慢起。以贪求世人名闻利养故造大妄语。谓未得谓得未证言证。自言得三乘圣果。此由愚痴起增上慢。故为爱见魔也。一颠迦即断善根者。此辈销灭佛种沈三苦海不成三昧。盖佛以四摄法现同类身教化众生非贪供养也。若是真圣亦不自泄违佛密因。除临终时阴有所付。云何是人以大妄语惑乱众生耶。故教世人修禅定者必断妄语乃可得入三摩地也。刻人粪为旃檀只增其臭秽耳。直心者心不欺也。目无实德妄称得上人法此欺心之至也。噬脐言终不相及也。心如弦直则永无诸委曲相是为入道之本也。故永无魔事。佛所印许。违越诚言则波旬说矣。梵网戒品十重四十八轻普摄一切名为性戒。是以佛性种子等观一 切。此经以真修务断生死根本。以淫杀盗是为性业。故首断此四为根本戒。若能持此四戒则一切枝末永不现行。是知此四已摄梵网诸品。而三聚五篇尽在是矣

前令持四根本戒制断发业润生二种无明竟

大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第六


通议卷第七

通议卷第七

大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第七

唐天竺沙门般剌密帝译
乌苌国沙门弥伽释迦译语
菩萨戒弟子清河房融笔受
明南岳沙门憨山释德清述

二令持秘密神咒熏断俱生习气分二

初明现行易制

阿难。汝问摄心。我今先说入三摩地修学妙门求菩萨道。要先持此四种律仪皎如冰霜。自不能生一切枝叶。心三口四生必无因。阿难。如是四事若不遗忘心尚不缘色香味触。一切魔事云何发生。

二明宿习难除分三 初教诵咒

若有宿习不能灭除。汝教是人一心诵我佛顶光明摩诃萨怛多般怛罗无上神咒。

二显咒妙

斯是如来无见顶相无为心佛从顶发辉坐宝莲华所说心咒。

三显咒力

且汝宿世与摩登伽历劫因缘恩爱习气。非是一生及与一劫。我一宣扬。爱心永脱成阿罗汉。彼尚淫女无心修行。神力冥资速证无学。云何汝等在会声闻求最上乘决定成佛。譬如以尘扬於顺风有何艰险。

三令依清净戒师深防邪误

若有末世欲坐道场。先持比丘清净禁戒。要当选择戒清净者第一沙门以为其师。若其不遇真清净僧。汝戒律仪必不成就。

四令择阿兰若处止绝外缘

戒成以后。著新净衣然香闲居。诵此心佛所说神咒一百八遍。然后结界建立道场。

五请佛冥加冀观行易就

求於十方现住国土无上如来放大悲光来灌其顶。

上示修相乃前四根本戒

三刻期修证

阿难。如是末世清净比丘若比丘尼白衣檀越。心灭贪淫持佛净戒。於道场中发菩萨愿。出入澡浴。六时行道。如是不寐经三七日。

四感应冥符

我自现身至其人前。摩顶安慰令其开悟。

议曰此明现行易制宿习难除将为建立坛场发启也。前说四重律仪乃制现行之轨则。以四重为根本戒。故能持此四种皎如冰霜则一切枝叶自然不生。即三业六根永绝发业之因矣。一切魔事由旧尘境而生。心尚不缘六尘则一切魔事何从而发耶。此现行犹易制也。唯有多生宿习最为难除。如器盛秽物虽去秽物而秽习尚存。必须洗涤之功。以无量劫来淫杀盗妄习气种子染於藏识之中极为深潜固密。如观照之力自不能攻。必假佛心印秘密神咒之力冀可熏断。如请上方之剑以讨贼耳。故曰若有宿习不能灭除。汝教是人一心诵我无上神咒。此咒乃无为心佛所说。所谓秘密心印非寻常比也。且摩登历劫恩爱习气一闻此咒爱心永脱成阿罗汉。彼尚淫女无心修行其效如此。况汝有决定成佛之志者乎。欲成就诵咒之功须坐道场。理宜提防邪误必须第一清净禁戒比丘以为其师。是为胜侣。先使戒根成就。然后然香闲居。诵此心咒。加持结界。乃可建立道场。更要请十方佛放光加被方使秘咒易成耳。故末世行人戒清净者坐道场中六时行道。经三七日我自现身摩顶令其开悟。是所谓摄心轨则也。

上答摄心轨则竟

二问安立道场分二

初当机重请道场轨则

阿难白佛言。世尊。我蒙如来无上悲诲心已开悟。自知修证无学道成。末法修行建立道场。云何结界。合佛世尊清净轨则。

议曰此问道场结界轨则也。入道第一要身心平等。次要心境一如。以造业因境为助缘。而真修亦然。故须问轨则也。

二世尊详示修治法式分二

初详答分十一涂地法式

佛告阿难。若末世人愿立道场。先取雪山大力白牛。食其山中肥腻香草。此牛唯饮雪山清水。其粪微细。可取其粪和合旃檀以泥其地。若非雪山其牛臭秽不堪涂地。别於平原穿去地皮五尺以下取其黄土。和上旃檀沈水苏合薰陆郁金白胶青木零陵甘松及鸡舌香。以此十种细罗为粉。合土成泥以涂场地。

议曰。此涂地法式也。雪山纯一无杂。白牛无染。香草纯味。清水纯洁。而茹退亦纯。旃檀其树无影。通表清净法身功德也。意显道场依法身建立也。去地五尺取其黄土。黄乃中色。和十种香谓由法身中道调和十波罗密而为行耳。故曰以涂场地。

二立坛法式

方圆丈六为八角坛。坛心置一金银铜木所造莲华。华中安钵。钵中先盛八月露水。水中随安所有华叶。取八圆镜各安其方围绕华钵。镜外建立十六莲华。十六香炉间华铺设。庄严香炉纯洁沈水无令见火。取白牛乳置十六器。乳为煎饼。并诸砂糖油饼乳糜苏合蜜姜纯酥纯蜜。於莲华外。各各十六。围绕华外。以奉诸佛及大菩萨。

议曰。此言立坛法式也。坛法旧解各有所表。大概以莲华表因心。镜表智体。香表观行等。其所用物 各有表显。非特言理也。

三供养法式

每以食时若在中夜。取蜜半升用酥三合。坛前别安一小火炉。以楼兜婆香煎取香水沐浴其炭。然令猛炽。投是酥蜜於炎炉内烧令烟尽享佛菩萨。

议曰。此供养法式也。诸佛菩萨本不受食。今修供养意表妙行熏修始觉以向本觉之意。必须缘影尽净方乃合一。故投酥蜜烧令烟尽也。

四设像法式

令其四外遍悬幡华。於坛室中四壁敷设十方如来及诸菩萨所有形像。应於当阳张卢舍那释迦弥勒阿（门众）弥陀。诸大变化观音形像兼金刚藏安其左右。帝释梵王乌刍瑟摩（火头金刚）并蓝地迦（清面金刚）诸军茶利（三目金刚）与毗俱胝（持幔髻金刚）四天王等频那（猪头）夜迦（象鼻）。张於门侧左右安置。

议曰。此设像法式也。卢舍那为法界主。馀十方佛及诸菩萨乃其伴也。意取主伴互融。其八部皆护法众。意取远诸魔事耳。

五观行法式

又取八镜覆悬虚空。与坛场中所安之镜方面相对。使其形影重重相涉。

议曰。此观行法式也。坛中先安八镜而坛内之镜已现影於镜中。今仍悬八镜相对则坛中之镜若影皆互相涉入重重无尽。是所谓诸佛法身入我性。我身还共如来合。此圆融自在观心若此。可与诸佛智体相应也。

六行道法式分三 初七礼拜称名

於初七中至诚顶礼十方如来诸大菩萨阿罗汉号。恒於六时诵咒围坛至心行道。一时常行一百八遍。

二七专心发愿

第二七中一向专心发菩萨愿心无间断。我毗奈取先有愿教

。

三七一向持咒

第三七中於十二时一向持佛般怛罗咒。

七感应道交

至第七日。十方如来一时出现。镜交光处承佛摩顶。

议曰。此行道法式也。行道若无次则心散而难摄功行难成。从初七以至三七日内各有所行故身心不倦。至於第三七日则感应道交十方如来一时出现也。镜交光处乃行人心契佛心之地故承佛摩顶以摄受也。

八结显功效

即於道场修三摩地。能令如是末世修学身心明净。犹如琉璃。

议曰。此显功效也。以表里俱净。故身心犹如琉璃。此所以不起道场而令成就也。

九使离过绝非

阿难。若此比丘本受戒师及同会中十比丘等其中有一不清净者。如是道场多不成就。

议曰。此言离过绝非也。坛中有一不清净者多不成就。意要永离诸过纯一无伪乃可克期成功耳。

十刻期取证

从三七后。端坐安居经一百日。有利根者不起于座得须陀洹。纵其身心圣果未成。决定自知成佛不谬。

二结示

汝问道场。建立如是。

议曰。此刻期取效也。由三七后即端坐安居。百日之内可证初果。当观行成就也。虽未登圣果。业已自知决定成佛不谬矣。道场之法建立如此。结答次问也。

前示利他妙净事行竟

二示俱利妙严密行分三

初当机三业显请

阿难顶礼佛足而白佛言。自我出家恃佛娇爱。求多闻故未证无为。遭彼梵天邪术所禁。心虽明了力不自由。赖遇文殊令我解脱。虽蒙如来佛顶神咒。冥获其力。尚未亲闻。惟愿大慈重为宣说。悲救此会诸修行辈。末及当来在轮回者承佛密音身意解脱。於时会中一切大众普皆作礼。伫闻如来秘密章句。

议曰。此请妙严密行也。显密双修自他俱利方尽真因。未说经先佛已放光说咒敕令文殊将咒往护。阿难尚未亲闻但冥获其力耳。故请重说神咒以益在会末及未来将为法利也。

二如来光相密酬分三 初现瑞

尔时世尊从肉髻中涌百宝光。光中涌出千叶宝莲有化如来坐宝华中。顶放十道百宝光明。一一光明皆遍示现十恒河沙金刚密迹擎山持杵遍虚空界。

二众仰

大众仰观畏爱兼抱。求佛哀佑。一心听佛无见顶相放光如来宣说神咒。

议曰。此光相密酬也。佛三十二相肉髻第一。从此放光表尊胜顶法由中道妙智所发也。光中涌莲表妙智胜因。莲中化佛表因果一契。化佛顶复放光光中示现金刚神众表从果体复起妙用殊非心识境界也。化佛说咒表此咒乃无为心佛所说。故功力愈见殊胜耳。

三说咒五会第一会

（楞严咒）

议曰。咒为秘密五不翻之一也。义说咒如军中之密号。但取办事。不许明言。又云。况*乃诸神王之名字。呼其主而众必随之。皆有摧邪之能。如所谓金刚力士随处护卫也。予昔居五台。遇一梵师。专持此咒其声极猛羁。如呵遣之状。因问之。曰。此鬼神王名也。今呼遣非猛力不能。就中嘱其所护之事。故极心力而驱遣之乃见其效。政取不思议力。非心识可到也。

三广显神咒利益分二初正行成益分二

初如来密因分二初能出生诸佛

阿难。是佛顶光聚悉怛多般怛罗秘密伽陀微妙章句。出生十方一切诸佛。

二能为密因

十方如来因此咒心得成无上正遍知觉。十方如来执此咒心降伏诸魔制诸外道。十方如来乘此咒心坐宝莲华应微尘国。十方如来含此咒心於微尘国转大法轮。十方如来持此咒心能於十方摩顶授记。自果未成亦於十方蒙佛授记。十方如来依此咒心能於十方拔济群苦。所谓地狱饿鬼畜生盲聋喑痖怨憎会苦爱别离苦求不得苦五阴炽盛大小诸横同时解脱。贼难兵难王难狱难风火水难饥渴贫穷应念消散。十方如来随此咒心能於十方事善知识。四威仪中供养如意。恒沙如来会中推为大法王子。十方如来行此咒心能於十方摄受亲因。令诸小乘闻秘密藏不生惊怖。十方如来诵比咒心成无上觉坐菩提树入大涅盘。十方如来传此咒心於灭度后付佛法事究竟住持。严净戒律悉得清净。

议曰。此下广显咒益也。向说般若为诸佛母。一切诸佛从般若生。今言诸佛从咒力出生。是知前说

三观乃佛佛成道之本为一路涅盘门。盖属显了般若。修行要假观智以断现行烦恼。烦恼净处佛果圆满名出生诸佛。今咒乃秘密般若。假此以断俱生习气。以习气深潜非观智可到。故须假诸佛秘密心印乃能断除。习气净处佛果圆成。故为出生十方如来也。观其十种大益。谓十方如来因此咒而成佛。执此咒以降魔。乘此咒以应尘国。含此咒以转法轮。持此咒以得摩顶授记。依此咒以济拔群苦。随此咒以供佛承法。行此咒以摄受小乘。诵此咒以成无上觉入大涅盘。传此咒以付佛法事究竟住持。是知十方诸佛出世始终事业皆依此咒心而得成就。非无上秘密心印何功力若此之殊胜哉。即此而观从上诸祖传佛心印者未有不由咒力而成功行者也。是所谓如来密因修证了义。的指此咒为行本也。即菩萨万行令二乘人远诸魔事无不资始乎此。今人修行舍此咒力又何以断习气收速效乎。妙在坛场胜友乃可克期成功。惜乎此土无结坛之具。故多因循漫视耳。虽无坛场而密咒断不可舍置也。

上显如来密因竟

二菩萨万行分二初能成万行分二

初自利行分十初能远魔事

若我说是佛顶光聚般怛罗咒从旦至暮音声相联。字句中间亦不重叠。经恒沙劫终不能尽。亦说此咒名如来顶。汝等有学未尽轮回。心至诚取阿罗汉。不持此咒而坐道场令其身心远诸魔事无有是处。

议曰。此通显咒心源远而益大也。以此咒从一真法界清净妙心所演。故无始无终穷劫不尽。而诸修行者不持此咒无以远诸魔事也。

此下通言有十种利益

二能远毒害

阿难。若诸世界随所国士所有众生随国所生桦皮贝叶纸素白（叠毛）书写此咒贮於香囊。是人心昏未能诵忆。或带身上。或书宅中。当知是人尽其生年一切诸毒所不能害。阿难我今为汝更说此咒救护世间得大无畏。成就众生出世间智。若我灭后末世众生有能自诵。若教他诵。当知如是持诵众生。火不能烧。水不能溺。大毒小毒所不能害。如是乃至天龙鬼神精祗魔魅所有恶咒皆不能著。心得正受。一切咒诅厌蛊毒药金毒银毒草木虫蛇万物毒气。入此人口成甘露味。

议曰。此能远毒害也。如不能诵若书写随带其利益亦等。咒乃佛心。持咒即持佛心。故能成出世间智而远世间毒害也。

三能令恶神守护

一切恶星并诸鬼神碜心毒人。於如是人不能起恶。频那夜迦诸恶鬼王并其眷属。皆领深恩常加守护。

议曰。此能令恶神守护也。持咒即呼召而嘱之。故能转恶心而为守护也。

四能知宿命

阿难当知是咒常有八万四千那由他恒河沙俱胝金刚藏王菩萨种族。一一皆有诸金刚众而为眷属昼夜随侍。设有众生於散乱心非三摩地心忆口持。是金刚王常随从彼诸善男子。何况决定菩提心者。此诸金刚菩萨藏王精心阴速发彼神识。是人应时心能记忆八万四千恒河沙劫。周遍了知得无疑惑。

议曰。此能知宿命也。以咒乃金刚心也。向未发悟但为八万四千尘沙烦恼。今执而用之。故有如是金刚藏王昼夜随侍。以此心无动转相故乱心忆

持而金刚王亦常随侍。能令行人顿破无明记忆八万四千恒沙劫也。

五能离恶道

从第一劫乃至后身。生生不生药又罗刹及富单那迦吒富单那鸠盘茶毗舍遮等并诸饿鬼有形无形有想无想如是恶处。

议曰。此能离恶道也。以咒纯无漏故永离恶趣生生不受生彼处也。

六能生善处

是善男子若读若诵若书若写若带若藏诸色供养。劫劫不生贫穷下贱不可乐处。

议曰。此能生善道也。咒力似如意珠故。劫劫不生贫穷下贱处也。

七能成善行

此诸众生纵其自身不作福业。十方如来所有功德悉与此人。由是得於恒河沙阿僧祗不可说不可说劫常与诸佛同生一处无量功德如恶叉聚。同处熏修永无分散。是故能令破戒之人戒根清净。未得戒者令其得戒。未精进者令得精进。无智慧者令得智慧。不清净者速得清净。不持斋戒自成斋戒。

议曰。此能成善行也。以持此咒即得佛心与佛同体。故自不作福而十方诸佛所有功德皆悉与之。以心心相印故同生一处熏修永无分散也。以如来果觉为我因心。故斋戒不持而自持。不精进而亦得精进智慧矣。

八能离染行

阿难。是善男子持此咒时。设犯禁戒於未受时。持咒之后众破戒罪无问轻重一时销灭。纵经饮酒食啖五辛种种不净。一切诸佛菩萨金刚天仙鬼神不将为过。设著不净破弊衣服。一行一往悉同清净。纵不作坛不入道场亦不行道。诵持此咒还同入坛行道功德无有异也。

议曰。此能离染行也。以法界性无染净。离止作。罪性本空。而动乱恒一。故能灭破戒之罪秽於未受时。亦同净故。虽不入坛而与入者等也。问曰。前言持咒必须结坛种种清洁。如一不净必不成就。今言破戒散心皆获成就。何相舛耶。答曰。前言真修必务严洁为主。今但言咒力殊胜。非言一概可成也。

九能灭众业

若造五逆无间重罪。及诸比丘比丘尼四弃八弃。诵此咒已。如是重业犹如猛风吹散沙聚。悉皆灭除更无毫发。

议曰。此能灭众业也。五逆无间罪业四弃八弃皆不通忏悔者今以咒力悉皆除灭也。四弃即四根本重业。梵语波罗夷此云弃。谓永弃佛法边外也。又如世之大辟曰弃市。谓永断慧命也。八弃者谓加比丘尼四弃共名八弃。尼四弃者谓触八覆随。触者不得与染心男身相触。八者谓不得与染心男捉手捉衣入屏处屏处共立共语共行身相倚相期等八事。覆者谓不得覆他重罪。随者谓不得随举大僧供给衣食。即为僧所举。未与作共住法者不得随彼也。通上共名八弃。僧所举即举诘之义。

十能消积障

阿难。若有众生从无量无数劫来所有一切轻重罪障从前世来未及忏悔。若能读诵。书写此咒身上带持。若安住处庄宅园馆。如是积业犹汤销雪。不久皆

得悟无生忍。

议曰。此能消积障也。无量劫来所积轻重诸罪。今以咒力而能消者。正如千年暗室一灯能破也。此上十种利益通显咒力不可思议也。


通议卷第七

通议卷第七

上约自利益下约利他益

次利他行分二 一能随所愿

复次阿难。若有女人未生男女欲求孕者。若能至心忆念斯咒。或能身上带此悉怛多般怛罗者。便生福德智慧男。女求长命者即得长命。欲求果报速圆满

者速得圆满。身命色力亦复如是。命终之后随愿往生十方国土。必定不生边地下贱何况杂形。

议曰。此约利他益能随所愿也。求男女即得男女。求果报即得果报。求往生即得往生。永离边地杂形之报者。盖称真法性心境一如永离邪曲故也。

二能灭灾难

阿难。若诸国士州县聚落饥荒疫疠。或复刀兵贼难斗诤。兼余一切厄难之地。写此神咒安城四门。并诸支提或脱[门者]上。令其国土所有众生。奉迎斯咒礼拜恭敬一心供养。令其人民各各身佩。或各各安所居宅地。一切灾厄悉皆消灭。阿难。在在处处国土众生随有此咒。天龙欢喜风雨顺时五谷丰殷兆庶安乐。亦复能镇一切恶星随方变怪。灾障不起。人无横夭。（木丑）械枷锁不著其身。昼夜安眠常无恶梦。阿难。是娑婆界有八万四千灾变恶星。二十八大恶星而为上首。复有八大恶星以为其主。作种种形出现世时能生众生种种灾异。有此咒地悉皆消灭。十二由旬成结界地。诸恶灾祥永不能入。

议曰此能消众生灾难也。种种诸难起於逆理故 致灾祥。今顺法性永离诸过故一切灾祥永不能 入也。支提此云可供养处。脱（门者）此云幢也。

二结成真行

是故如来宣示此咒。于未来世保护初学诸修行者入三摩提。身心泰然得大安隐。更无一切诸魔鬼神及无始来冤横宿殃旧业陈债来相恼害。汝及众中诸有学人及未来世诸修行者。依我坛场如法持戒。所受戒主逢清净僧於此咒心不生疑悔。是善男子於此父母所生之身不得心通。十方如来便为妄语。

议曰。此结成真行也。以印契佛心故永离魔冤一生取办也。前显说中性比丘尼得阿罗汉。今密咒 之功一生克果。足证二种般若其功等也。

上正行成益竟

二保护盛益分二一诸神守护

说是语已。会中无量百千金刚一时佛前合掌顶礼而白佛言。如佛所说。我当诚心保护如是修菩提者。尔时梵王并天帝释四天大王。亦於佛前同时顶礼而白佛言。审有如是修学善人。我当尽心至诚保护。令其一生所作如愿。复有无量药叉大将诸罗刹王富单那王鸠盘茶王毗舍遮王频那夜迦诸大鬼王及诸鬼帅。亦於佛前合掌顶礼。我亦誓愿护持是人。令菩提心速得圆满。复有无量日月天子风师雨师云师雷师并电伯等年岁巡官诸星眷属。亦於会中顶礼佛足而白佛言。我亦保护是修行人安立道场得无所畏。复有无量山神海神一切土地水陆空行万物精祗并风神王无色界天。于如来前同时稽首而白佛言。我亦保护是修行人得成菩提永无魔事。

议曰。此诸神守护也。华严说四十二位异生神众皆是毗卢遮那海印三昧威神所现。各得如来一种三昧。以为法界所统故。今此咒心乃法界心印。故凡所在处诸神守护。正如大将兵符符到令行。诸人皆得而左右之。况如来不思议力乎。

二菩萨守护

尔时八万四千那由他恒河沙俱胝金刚藏王菩萨。在大会中即从座起。顶礼佛足而白佛言。世尊。如我等辈所修功业。久成菩提不取涅盘。常随此咒救护

末世修三摩提正修行者。世尊。如是修心求正定人。若在道场及馀经行。乃至散心游戏聚落。我等徒众常当随从侍卫此人。纵令魔王大自在天求其方便

终不可得。诸小鬼神去此善人十由旬外。除彼发心乐修禅者。世尊。如是恶魔若魔眷属欲来侵扰是善人者。我以宝杵殒碎其首犹如微尘。恒令此人所作

如愿。

议曰。此菩萨守护也。首楞严定亦名如幻闻熏闻修金刚三昧。故五十五位最后等觉俱用金刚心断惑。以根本无明最极微细坚固非金刚心不能破。以一迷真心始起无明名为生相。由此无明发业润生则有生死故。变一心而为八万四千尘沙烦恼造生死业。今此咒乃金刚心中所流直断根本无明故变烦恼而为护法。以迷时纯为染业。今逆流纯成净用。故八万四千金刚藏王常随守护也。魔有侵者即碎其首犹如微尘。显此咒力一念能碎坚固无明不假馀力。故守护之功妙极於此。是所谓妙圆密行也。

从前四卷中请入华屋以来至此总显三观之相竟。

三显三观之用分二

初当机特请修证阶差

阿难即从座起。顶礼佛足而白佛言。我辈愚钝好为多闻。於诸漏心未求出离。蒙佛慈诲得正熏修。身心快然获大饶益。世尊。如是修证佛三摩提未到涅盘。云何名为乾慧之地。四十四心。至何渐次得修行目。诣何方所名入地中。云何名为等觉菩萨。作是语已五体投地。大众一心伫佛慈音瞪瞢瞻仰。

次世尊特示迷悟因果分二 初赞许

尔时世尊赞阿难言。善哉善哉。汝等乃能普为大众及诸末世一切众生修三摩提求大乘者。从於凡夫终大涅盘。悬示无上正修行路。汝今谛听当为汝说。

阿难大众合掌刳心默然受教。

议曰。此下问修证位次以显三观之用也。谓约位次以显三观具有能断能证之力用故。乾慧地者谓欲爱干枯根境不偶即天台信前五品观行位也。华严以信为行本。三贤已前总依信位更不别开。故通有四十二位。此经备开十信故有五十五位。以乾慧为最初之因。涅盘为至极之果。由初信至四加行故曰四十四心。并前乾慧十地故成五十五也。等觉乃因圆之果。刳者剜物见空曰刳。如所谓划〖？〗去知见也。

次正说分二 初立一真法界如来藏性为生死涅盘因分三 初直指一心

佛言。阿难当知。妙性圆明离诸名相。本来无有世界众生。

二真妄因依

因妄有生。因生有灭。生灭名妄。灭妄名真。是称如来无上菩提及大涅盘二转依号。

三即妄明真

阿难。汝今欲修真三摩地直诣如来大涅盘者。先当识此众生世界二颠倒因。颠倒不生斯则如来真三摩地。

议曰。因问修证位次先立一真法界为生死涅盘之因也。妙性圆明本无众生世界等者直指一心真源永离诸妄也。以最初一念妄动因而有生。因生遂有灭。因有生灭则名为妄。因灭生灭无生灭性则名为真。真妄因依故有转烦恼为菩提转生死为涅盘二转依号。此凡圣二路皆由迷悟而立。本非有也。今欲真修返妄归真不须别求。但能识破众生世界颠倒之因。便是真三摩地矣。岂更有别法哉。在即妄以明真。非舍妄以求真也。

二委示一心染净熏成迷悟因果差别之相分三

初约无明熏真如成染法为十二类生因分二

二约真如熏无明成净用为五十五位因分二

三结指观行圆证一心泯同果海成无上妙觉之果

议曰。此下十二类生约无明为染法之因也。问曰。阿难本问从乾慧地以至等觉五十六位修证次第。而如来先答十二类生者何也。答曰。此经专依一真法界如来藏心为迷悟圣凡之本。以其此心本无迷悟不属圣凡又何修证之有。但以最初一念妄动而有无明。不思议熏变。由此妄有颠倒之众生。若识颠倒之因则了生本无生。由是故有二转依号。是知迷悟不出一心。凡圣本乎一念。今既以一念妄动而为十二类生。岂不能以一念无生圆成五十七位。要显真妄因依迷悟一体。故先指十二类生为发心之地。舍此众生别无修证之果矣。故因问真修先示妄本元依一心转变也。此先约无明熏成染法故总标二种颠倒之因。

初中分二初总明众生世界之本

阿难。云何名为众生颠倒。阿难。由性明心性明圆故。因明发性。性妄见生。从毕竟无成究竟有。此有所有非因所因。住所住相了无根本。本此无住建立世界及诸众生。

议曰。此总标十二类生之因也。标中众生二字应云二种。以此八句总标故当双举，后有别列故知二字之误也。由性明心此特显一真法界妙圆真心以为迷悟因依之大本即前所云性觉妙明也。性明圆故即前所谓若此不明名为觉者则无所明。意有强明也。因明发性者性乃妄相即前因明立所。前之所字谓通含虚空世界众生业果等相。此乃单约众生正报以明无明熏变生死之状以为诸妄之本。故但言性而不言相。指体而言显此众生世界乃由无明熏变而起也。故曰因明发性。性妄见生者即前所妄既立生汝妄能。谓由所发之妄相遂起能见之妄见。此则众生世界宛然。而生死轮回因之而立。是从毕竟无而成究竟之有矣。此有所有下四句显妄无体也。此有者无明也。所有者众生世界也。非因所因谓无明与众生世界本无所因与之为因也。能住者众生。所住者世界。谓此众生世界全一虚妄了无根本。则显众生世界之本无也。谓一真法界本无所住之相。本此无住之真建立众生世界之妄法耳。是所谓从无住本立一切法也。前三种相续中世界的指外器世界。此世界端指正报色蕴之身。众生乃四蕴之心。所谓诸识合集名为众生。以前云使汝流转生死速证安乐妙常同是六根更无他物。故此二转依果皆依众生六根而立。经意隐然而示三细六粗之相。但就众生颠倒身心以明从真起妄。要显妄元无因。所谓达妄元虚即凡心而见佛。故五十六位依十二类而立也。

二别名二种颠倒之因分四 初众生颠倒

迷本圆明是生虚妄。妄性无体非有所依。将欲复真。欲真已非真真如性。非真求复宛成非相。非生非住非心非法。展转发生。生力发明。熏以成业。同业相感。因有感业相灭相生。由是故有众生颠倒。

议曰。此别示众生颠倒也。经文应有云何名为众生颠倒一句错简在前。迷本圆明下四句明妄依真起本无体也。由迷本圆明湛寂之真心是生虚妄之妄相。而此妄性无体非有所依。但了妄无依则真常顿复。不假更起修为也。以众生本空不容有心求复。将欲复真才有欲真之心则早堕生灭已非真真如性矣。以一真界中不容起见。举心即错。动念即乖。若以生灭心求复真常之性则真常之性亦成生灭。故曰宛成非相。所谓未出轮回而辩圆觉彼圆觉性即同流转矣。以众生本无何有生住。生住尚无何有心法。言生住该异灭。言心法

该身受。意谓本无生灭众生也。今於本无之中而妄见有生住心法之众生相故总言非。但以无明生相未泯耳。良由一念生相无明。不觉展转发生。积久而愈有力。由此生力发明。故六粗相显。以无明不思议熏以成业性。即因发业则有润生。故同业相感。因此所感之业相灭相生。由是故有众生颠倒也。生力发明即六粗中智相相续也。熏以成业即执取计名字也。同业相感则起业系苦也。若了无明本空则生死顿绝。故指妄元无因为观行之要耳。

二世界颠倒

阿难。云何名为世界颠倒。是有所有分段妄生因此界立。非因所因无住所住。迁流不住因此世成。三世四方和合相涉。变化众生成十二类。

三示熏变之相

是故世界。因动有声。因声有色。因色有香。因香有触。因触有味。因味知法。六乱妄想成业性故。十二区分由此轮转。是故世间声香味触。穷十二变为一旋复。

四示轮回之状分二

初总列十二类生之名

乘此轮转颠倒相故。是有世界卵生胎生湿生化生有色无色有想无想若非有色若非无色若非有想若非无想。

议曰。此别示世界颠倒也。是有者指无明妄心。所有者指妄身。以无明妄心依真而立本无分段。但由吸揽四大外色而成根身。则所妄既立明理不逾故分段妄生。因此而有左右前后一定之界限。故曰因此界立。以妄心无体非有因为之所因。妄身本空故无有住为所住之世界。於无住中妄执为住。故妄心生灭迁流不住。遂形三世之妄相。故曰因此世成。由方世和合不思议熏不思议变故变化众生成十二类。是知十二类生皆由一念无明妄心之所熏变也。是故世界下正示熏变之相。以妄心住於妄身之中无明内熏忆识诵习之习气猛发鼓动心体。则妄有缘气於中积聚。假名为心。故曰因动有声。然声乃妄想风耳。非外境也。因此动念则随其本习容现尘相。故因声有色。则习境妄现因此妄境返熏自心。故曰因色有香。香乃妄境之气分也。因此缘气返触其心而心亦趣境。故因香有触。心境相触则绵著其味爱而不吐。故曰因触有味。因此味著则知为法尘。此总显一念妄想由习气内发而为六尘非外尘境故不次耳。以此六乱之妄想熏成业性以为生因。所熏不出身心之外。故十二区分以为受生之果。故下结云由此六乱妄想生灭不停是故众生世界但以声香味触习染之六尘穷十二变为一旋复。是知一念妄想则为十二类生之因。所谓熏以成业不待更造而生死苦果念念随之矣。岂不痛哉。下正示轮回之状。以知见每欲留於世间。业运每常迁於国土。故曰乘此各具旋复轮转颠倒相故是有十二类生之苦果。此先列名也。旧解卵唯想生故卵居首。胎因情有故因次之。湿以气合而感。化以离形而应。其馀八类亦各以情想熏变而成。此指众生日用现前之情状。殆非约理而推也。

次别示十二类生之果分二

初示行分十二一卵生

阿难。由因世界虚妄轮回动颠倒故。和合气成八万四千飞沉乱想。如是故有卵羯逻蓝流转国土。鱼鸟龟蛇其类充塞。

议曰。此卵生类也。轮回言生灭妄想也。虽云四生受形之因各别。大概十二回类生皆云妄想之所熏成。何独卵唯想生故列首耶。细详经意。诸类通以

六乱妄想为因。始因一念妄动习气内鼓而为妄想之本。故曰因动有声。此召类之元也。故今卵生则曰虚妄轮回。乃初起一念生灭心也。认此动念为心故云动颠倒。然以生灭为心以动为境故心境和合习气内发妄有缘气故云气成。生灭不停。故云飞沉乱想。因此而有卵羯逻蓝。此云凝滑。以妄想吸此而成形。故有鱼鸟龟蛇之类。是推妄想初起因动有声约习气熏变之始故列卵生居首。非是众生之初先有此类也。第约情想偏重而言故以情属胎。其实卵生未尝无情也。皆有交遘岂非情耶。

二胎生

由因世界杂染轮回欲颠倒故。和合滋成八万四千横竖乱想。如是故有胎遏蒲？坛流转国土。人畜龙仙其类充塞。

议曰。此胎生类也。欲习熏起故曰杂染轮回欲颠倒。以染欲相交故曰和合滋成。情有偏正故曰横竖乱想。流爱为种纳想为胎故曰胎遏蒲坛。此云胞。乃胎中二七之相也。人畜龙仙胎生类也。龙亦有卵生。仙亦有化生。盖举其重者而言也。

三湿生

由因世界执著轮回趣颠倒故。和合暖成八万四千翻覆乱想。如是故有湿相蔽尸流转国土。含蠢蠕动其类充塞。

议曰。此湿生类也。附合习气熏起故曰执著轮回。执著者谓希求附合也。执取势利妄生苟合如世之逐气寻香趣势附利故曰趣颠倒。有气焰处即便合之故曰暖成。心无定向故曰翻覆乱想。如世之翻云覆雨之徒。蔽尸此云软肉。蠢蠕受形之始也。

四化生

由因世界变易轮回假颠倒故。和合触成八万四千新故乱想。如是故有化相羯南流转国土。转蜕飞行其类充塞。

议曰。此化生类也。诈习熏起故曰变易。谓附离而感。望势即变其所守。失势即易其本心。假权贵而变姓名。托势利以为己有。故曰假颠倒。触势而变故曰触成。弃旧迎新故曰新故乱想。羯南此云坚肉。乃化生受形之始。如鹰化为蛤蜣螂化蝉之类。故云转蜕飞行。

五有色

由因世界留碍轮回障颠倒故。和合著成八万四千精耀乱想。如是故有色相羯南流转国土。休咎精明其类充塞。

议曰。此有色类也。凝习熏起故曰留碍。此外道以日月星辰为父母。故吸日精月华餐霞饮露以为修真养性。心生固结而不化。障蔽妙明故曰障颠倒。凝想既久精光昭著故曰著成。大而为日月星辰。在物而为萤火蚌珠之类。故曰精耀。但以色相而显。故曰休咎精明之物类也。

六无色

由因世界销散轮回惑颠倒故。和分暗成八万四千阴隐乱想。如是故有无色羯南流转国土。空散销沉其类充塞。

议曰。此无色类也。惑习熏起销碍入空故曰销散。惑取虚无故曰惑颠倒。昏昧无知故曰暗成。幽潜神识暗昧心灵故曰阴隐。无色羯南是为空散销沉之类也。

七有想

由因世界罔象轮回影颠倒故。和合忆成八万四千潜结乱想。如是故有想相羯南流转国土。神鬼精灵其类充塞。

议曰。此有想类也。忆习熏起若有若无故曰罔象。奉事神明邪著影像故曰影颠倒。忆想神明潜结状貌故曰忆成。潜结乱想但由想成故为有想羯南。或幽而为鬼神。或昧而为精灵。即今樟柳耳报之类也。

八无想

由因世界愚钝轮回痴颠倒故。和合顽成八万四千枯槁乱想。如是故有无想羯南流转国土。精神化为土木金石其类充塞。

议曰。此无想类也。痴习熏起妄计无情有命。金石坚牢固守愚痴故曰愚钝痴颠倒。顽成无知精神枯槁故曰顽成枯槁乱想。如黄头化石华表生精。想至无情故曰无想。

九非有色

由因世界相待轮回伪颠倒故。和合染成八万四千因依乱想。如是故有非有色相成色羯南流转国土。诸水母等以虾为目其类充塞。

议曰。此非有色类也。伪习熏起递相假待造作诈伪故曰相待伪颠倒。习染成类因依求食故曰染成因依乱想。如世之假造伪印书画古器递相声势。或结连朋党起灭词讼骗财自活。如水母无眼求食赖虾原不露形故非有色相。待色成形故成色羯南。以妄想愈谬故生理愈乖。因果感召固其然也。

十非无色

由因世界相引轮回性颠倒故。和合咒成八万四千呼召乱想。如是故有非无色相无色羯南流转国土。咒诅厌生其类充塞。

议曰。此非无色类也。诱习熏起音声相诱故曰相引。习与性成故曰性颠倒。即世之淫词歌曲以声挑引意在顺情寄声成事。如相如琴心御沟红叶并邪术诅咒之类故曰咒成呼召乱想。假他色相故非无色。藉声诞形故曰无色。佛戒比丘歌唱之处不许故往观听。不许亲习外道邪术。正防微也。

十一非有想

由因世界合妄轮回罔颠倒故。和合异成八万四千回互乱想。如是故有非有想相成想羯南流转国土。彼蒲卢等异质相成其类充塞。

议曰。此非有想类也。欺习熏起非合而合罔冒？欺人以为不知故曰合妄罔颠倒。本非同体故曰异成。诚恐人知故曰回互乱想。此即世之托孤继嗣。忘本父母而托他人。或抱他子以为己子故感螟蛉之类。以异质故非有想以相成故成想羯南。

十二非无想

由因世界怨害轮回杀颠倒故。和合怪成八万四千食父母想。如是故有非无想相无想羯南流转国土。如土枭等附块为儿。及破镜鸟以毒树果抱为其子。子成父母皆遭其食。其类充塞。

议曰。此非无想类也。恨习熏起故曰怨害。由怨而害故曰杀颠倒。子成而食其父母最为怪事故曰怪成。鸱枭附块为儿。破镜抱毒树果为子。块果本无想而成想。故云非无想相无想羯南。破镜鸟未详。旧解引史记祀百祠用土枭破镜。按道安法师檄魔文云枭獍竞起。是则镜当作獍兽名。孤山谓如 〖豸区〗而虎眼。今经为鸟。又非獍也。俟再考之。

次结名

是名众生十二种类

议曰。妙净明心离诸名相。本来无有世界众生。是故世界众生但因妄想而有也。上约无明熏真如成其染法为十二类生之因竟。

大佛顶首楞严经通议卷第七

*（疑为咒字之误，原文如此）


通议卷第八

通议卷第八

大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第八

唐天竺沙门般剌密帝译
乌苌国沙门弥伽释迦译语
菩萨戒弟子清河房融笔受
明南岳沙门憨山释德清述

二约真如熏无明成其净用为五十五位因分三

初明染净同源

阿难。如是众生一一类中亦各各具十二颠倒。犹如捏目乱华发生。颠倒妙圆真净明心具足如斯虚妄乱想。

议曰。此通摄前以显染净同源也。十二类生皆依一念妄想而有。但随习气熏变。虽各类自有元熏本习以成当类。然此一心融通身心互涉世界则已遍具於诸类矣。故曰如是众生亦各各具十二颠倒。第约重轻而感。故本习感当类。余习带熏诸颠。又为彼各各因。此所谓不思议熏变而众生业力微矣。以此而观吾人日用未造真修举心动念无非妄想用事。念念皆为十二类生生死之因可不惧哉。以此颠倒尽是妙圆真净明心真足如斯虚妄乱想。是知全真起妄全妄却真。吾人苟能达妄原虚则了众生体空本来是佛。故五十五位之真修本於众生十二之颠倒也。故下文明真依妄立。

二明真依妄立分二 初正明

汝今修证佛三摩提。於是本因元所乱想立三渐次方得除灭。

次喻显

如净器中除去毒蜜。以诸汤水并杂灰香洗涤其器。后贮甘露。

议曰此明真依妄立也。以颠倒元是妙圆真心。故今修证佛三摩提不必别求。即就众生本因元所乱想立三渐次。若颠倒不生即是如来真三摩地。而十二类颠倒则当下除灭。故如净器先贮毒蜜。但除其毒洗涤其器。然后可贮甘露矣。

三正明因行阶差分二

初总明依三渐次顿悟一心为返妄归真之本分二 初微标

云何名为三种渐次。一者修习除其助因。二者真修刳其正性。三者增进违其现业。

议曰。此微列三渐次以明顿悟一心为返妄归真之本也。除助因者。以众生积劫习气念念熏变已是难断。若外加助发之因则愈益炽盛。故断习气之要先除助因为第一也。刳正性者。习有多种唯淫欲名生死之根。故曰一切众生皆以淫欲而正性命。知在众生中但以淫欲为正性也。刳者剜去之义。如人被毒箭所伤必剜去毒肉则可不伤 性命。故云刳者断其毒根也。违现业者。以旧熏种子习气内鼓发为现业。若现业不违而新熏益炽。何由能出生死哉。故真修必违现业。现业不行则正性自枯欲流可涸矣。所以依三渐次建立行本也。

次释分三 一除助因

云何助因。阿难。如是世界十二类生不能自全依四食住。所谓段食触食思食识食。是故佛说一切众生皆依食住。阿难。一切众生食甘故生食毒故死。是故众生求三摩提。当断世间五种辛菜。是五种辛熟食发淫生啖增恚。如是世界食辛之人纵能宣说十二部经。十方天仙嫌其臭秽咸皆远离。诸饿鬼等因彼食次舐其唇吻。常与鬼住。福德日销长无利益。是食辛人修三摩地。菩萨天仙十方善神不来守护。大力魔王得其方便。现作佛身来为说法。非毁禁戒赞淫怒痴。命终自为魔王眷属。受魔福尽堕无间狱。阿难。修菩提者永断五辛。是则名为第一增进修行渐次。

议曰。此别释三种渐次之初相也。大蒜（艹各）葱慈葱兰葱与兴渠是为五辛气味极浊。众生以此为食。而淫机元为命本。以无明内熏淫习鼓动。故妄有缘气依附肉团为妄想心。若食此五辛浊气返熏则淫机益炽。故能助发淫性。是须必断也。若不断辛。天仙嫌其臭秽。诸鬼时与周旋。善神不守。魔王得便。堕落邪途。为地狱种。故修菩提者永断五辛。则神清气爽观行易成。名为第一增进修行渐次也。

二刳正性

云何正性。阿难。如是众生入三摩地。要先严持清净戒律。永断淫心。不餐酒肉。以火净食无啖生气。阿难。是修行人若不断淫及与杀生出三界者无有是处。当观淫欲犹如毒蛇如见怨贼。先持声闻四弃八弃执身不动。后行菩萨清净律仪执心不起。禁戒成就。则於世间永无相生相杀之业。偷劫不行无相负累。亦于世间不还宿债。是清净人修三摩地。父母肉身不须天眼自然观见十方世界。睹佛闻法亲奉圣旨。

得大神通游十方界。宿命清净得无艰险。是则名为第二增进修行渐次。

议曰。此释第二渐次之相也。众生生死以淫欲为本。今愿出苦轮必永断淫心而生死可出也。饮酒则助发淫心而昏迷自性。食肉则恣杀业而增盗贪。冤债相牵无由得脱。是欲断淫必兼持四重以此为生死之本故也。且淫欲从渴爱生。若不大生恐怖则不生厌离。故视如毒蛇则自不敢狎也。如见怨贼则自知逃避也。四弃八弃虽严犹属小乘。但能执身不行而已。若修菩萨观智照破无明则执心不起。所谓摩登伽在梦。谁能留汝形。此观照之力也。不淫则不相生。不食肉则无杀业。不盗则免酬债。是以先持四重皎如冰霜。相生死根机永断身心清净。心见发光故得宿命清净也。宜矣。

三违现业

云何现业。阿难。如是清净持禁戒人心无贪淫。於外六尘不多流逸。因不流逸旋元自归。尘既不缘根无所偶。反流全一六用不行。十方国土皎然清净。譬如琉璃内悬明月。身心快然妙圆平等获大安隐。一切如来密圆净妙。皆现其中。是人即获无生法忍。从是渐修随所发行安立圣位。是则名为第三增进修行 渐次。

议曰。此释第三渐次之相也。前问行之初首示三决定义而以四重为妙行之本。今立圣位又从三种渐次为进趣之阶。正性之中虽兼杀盗而正意在淫。若淫心既断则杀盗何由而起耶。所谓皮既不存毛将安附。故今违现业专以断淫为第一义。何也。以广大无边清净法界如来藏心具有恒沙称性功德神通妙用孰能夺之。独淫欲一事则能

全举而覆夺之。金刚心地谁能坏之。唯淫机一动而尽坏之。是知破涅盘城荡法王家绝菩提种戕害法身而断慧命者无尚此矣。如来大慈出世专为此一大事因缘。故修断之功萃於此经。而始终以此再三致意焉。故首以此为发教之端。及问行门又以断淫为上。今跻圣位皆从断淫一行建立。淫心一断立登佛果岂不至重至要哉。故违现业

而为圣位之本也。以顺欲流故有生死。今则返流则旋元自归为复性之要。尘既不缘境空也。根无所偶心空也。心境皆空则返欲流而全一真。六根消复六用不行。尘境既空则身心内外一时清净。而十方皎然犹如琉璃内悬宝月。岂不快哉。斯乃顿破根本无明使八识种子一时迸裂。此通论全功。故下经云。识阴若尽则汝现前诸根互用。从互用中能入菩萨金刚乾慧。圆明精心于中发化。如净琉璃内含宝月。如是乃超十信十住十行十回向四加行心菩萨所行金刚十地。入于如来妙庄严海。圆满菩提归无所得。故曰一切如来密圆净妙皆现其中。是人即获无生法忍。诸说无生法忍八地乃得。今於三渐次中已证无生。而五十五位从此建立。则迥异余经。故后结云如是皆以三增进故善能成就五十五位真菩提路。所谓以果地觉为本因心。是为真修之要也。足知诸位如涉海履空无阶级中之阶级耳。岂可以渐次地位而拟之哉。

上总明依三渐次为返妄归真之本竟

次别明圆依一心三观之相渐断无明为转凡成圣之因分三 初世间差别因分三

初由中道妙观摄假入真证空如来藏分三

初干慧地

阿难。是善男子。欲爱干枯根境不偶。现前残质不复续生。执心虚明纯是智慧。慧性明圆鉴十方界。干有其慧（谓空有其慧无力断惑）名干慧地。欲习初干（但干欲流未干无明流）未与如来法流水接。

议曰。此下明进趣因位也。华严明因有二种。地前三贤名差别因。地上名平等因。天台判三贤为外凡。四加行为内凡。地上名圣位。信前为观行位。十信为相似位。十住已后为分真位。谛观此经总不如是。迥异诸说。以上文云违其现业即获无生法忍。又云从是渐修随所法行安立圣位。是则始从观行以干慧心即名圣位。又何外凡内凡之可分哉。此在圣心所属境界固非妄识可知。然就圣言比量明文自有昭著。以理为准庶可依通耳。是善男子即上修三渐次之行人也。由违现业尘既不缘根无所偶。故得欲爱干枯根境不偶。现前残质不复续生。此结上三渐次之功行也。前二决定义云欲取菩提应当审详烦恼根本。此无始来发业润生谁作谁受。以此经宗真修专断淫为本。故因地先审发业润生二种无明为所断之惑。故今证果之初约观行心先断此二种无明为发轫初步。其根境不偶则发业不生。不复续生则润生永绝。此二不生即真无生忍也。无生忍即不生灭心也。故此证果专以不生灭心断此二种无明。是以

果觉为我因心。故从乾慧即名圣位。不比他经分破分证之说也。执心虚明是伏二种无明不起也。 已离欲染无烦恼障故纯是智慧。以入流亡所一根返源六根解脱无复隔碍。故慧性圆明养十方界。此但观慧圆明未见真理。故干有其慧名干慧地。但干欲习。无明全在故未得与如来法流水接。此观行初心单约断欲故立此位。诸经所无

二十信。

即以此心中中流入圆妙开敷。从真妙圆重发真妙。妙信常住。一切妄想灭尽无余。中道纯真名信心住。

议曰。此约观行增进初心立十信位也。此十信位即在干慧观心中入。以中道直观八识渐渐研穷故曰即以此心中中流入。正如除结当心也。逆流而入入之既深则心精发化。故云圆妙开敷此乃自心发悟如莲华开真心忽现。大论云性戒清净。 犹如妙华开敷发生自他善因果故。即从所悟重发观慧故曰从真妙圆重发真妙。是则的信自心本无生灭故曰妙信常住。此则一切生灭妄想永不现行。如是渐增闻所闻尽故曰灭尽无馀。唯一精真湛不摇处故曰中道纯真名信心住。谓能安住信心也。

真信明了一切圆通。阴处界三不能为碍。如是乃至过去未来无数劫中舍身受身一切习气皆现在前。是善男子皆能忆念得无遗忘。名念心住。

议曰。此第二信由此妄想灭尽纯真信心圆明精了。故一切圆通阴处界三不能为碍。此以初信圆成七识不行。故舍身受身一切欲爱习气皆现在前。此见惑已尽思惑渐断故能忆念不忘名念心住。

妙圆纯真真精发化无始习气通一精明。唯以精明进趣真净名精进心。

议曰。此第三信进断思惑故妙圆纯真。由真精观智消熔爱习变习成智故曰通一精明。此正二乘涅盘。是则习消智明唯以精明进趣真净妙理。以尽闻不住故名消精进心。

心修现前纯以智境（分破无明）名慧心住。执持智明周遍寂湛。寂妙常凝名定心住。定光发明明性深入。（定慧并运）唯进无退名不退心。

议曰。此第四信以习气既消故心精现前。二惑已除故纯是智慧名慧心住。此已观智圆明故第五信即执持此智明遍照本体湛然。照寂双流则寂妙常凝名定心住。第六信位由智得定。定久发光则慧性圆明。定慧并运故明性深入智能会理故唯进无退名不退心。一向判位当七信为不退。断见思惑得六根清净。今於三信已断见思六根圆

通。而六信得不退者彼约先断见思以及尘沙后及无明。今经发觉初心三渐次中即以中道径破根本无明。任运粗垢先落。如澄浊水沙土自沉。清水现前。单约中道观智故回别诸位不可概论也。

心进安然保持不失十方如来气分交接名护法心。

议曰。此第七信。前虽有进无退尚有进趣猛利之相。至此七信进趣功纯定慧两全。故曰心进安然 保持不失。见思缘影已尽。仗中道观分破无明法身渐显。故与十方如来气分交接。名护法心也。

觉明保持能以妙力回佛慈光向佛安住犹如双镜光明相对。其中妙影重重相入名回向心。

议曰。此第八信。由前观智增明保持既久心光发晖妙契法身。故曰能以妙力回佛慈光向佛安住。理智融通故如镜交光重重相入。名回向心。

心光密回。获佛常凝无上妙净。安住无为得无遗失名戒心住。

议曰。此第九信以微密观照返照心源。顿契寂灭清净心体。故曰心光密回获佛常凝无上妙净。自然任运而入不假作为。故曰安住无为以凭观照之力一念失照即堕无明。故名戒心住。

住戒自在。能游十方所去随愿名愿心住。

议曰。此第十信。前虽不失犹未纯熟常防其失故 未自在。至此功用已纯故曰住戒自在游历性空。随愿断惑。明愿心住。按此信位虽列。名实是观行成就圆成一心。以中道纯真故非相似比也。向后三贤只以此一心研穷三观次第而入故为差别因也。十住乃以中道妙观摄假入真以显本觉出缠证空如来藏。

三十住

阿难。是善男子以真方便发此十心。心情发晖。十用涉入圆成一心名发心住。

议曰。此十住位谓以观行研穷开发本觉常住真心。所谓尽闻不住以无住为住故得住名。华严每位约观行有入住出三相。总摄前位以为胜进。然后进入后位。故此文云以真方便发此十心。是以三渐次及干慧地为真方便为入。发此十种信为住。但十种心历别未圆。至十信满心寂照双流融成一味。使十心摄入无次第相圆成一心。名发心住为出。是以十信观行胜进功圆总成初住一位也。始觉有功本觉乃显。故曰心精发晖。以此心初显故云发心住。其无始无明须渐次研穷深入。所谓理须顿悟乘悟并消。事非顿除因次第尽。故向后四十四心由是而立也。

心中发明。如净琉璃内现精金。以前妙心履以成地。名治地住。

议曰。此第二住以中道观圆照自心。故曰心中发明。所观理境了然现於观智心中。故如净琉璃内现精金。即以前微妙观智游履此心净治无明。故曰以前妙心履以成地名治地住（治字平声）。

心地涉知俱得明了。游履十方得无留碍名修行住。

议曰。此第三住由前治地以智照理理随智现。故曰心地涉知。境智历然故曰俱得明了。智照既明理境亦大。尽十方际成一真境。故曰游履十方。理智冥符不落空有。空不能留。有不能碍。故曰得无留碍。心心无间名修行住。

行与佛同受佛气分。如中阴身自求父母。阴信冥通入如来种名生贵住。

议曰。此第四位由修行位以中道妙智观中道妙理心境不异。故曰行与佛同。初以智熏真如而真如渐显亦返熏智智得所如。故曰受佛气分。念念证真故曰如中阴身自求父母。始本暗合故曰阴信冥通。融会藏性故曰入如来种。以本觉种子今彼观智新熏发生。名生贵住。以般若尊重特以贵名。以智摄理故如入胎。

既游道胎亲奉觉胤。如胎已成人相不缺名方便具足住。容貌如佛心相亦同名正心住。身心合成日益增长名不退住。十身灵相一时具足名童真住。

议曰。此五六七八四位通约住胎之相以明观智之功也。以始觉观照含育本觉故曰亲奉觉胤。观行已成故曰如胎已成名方便具足住。方便即观智也。谓非观智本觉不显。乃由方便而具足者。理智不二心境一如故曰容貌如佛心相亦同名正心住。理智冥会理随智增有进无退名不退住。本觉圆满一念顿证故曰十身灵相一时具足。具体

而微名童真住。

形成出胎亲为佛子名法王子住。表以成人。如国大王以诸国事分委太子。彼刹利王世子长成陈列灌顶名灌顶住。

议曰。此第九十二位约出胎之相以明观智也。始觉有功本觉乃显故曰行成出胎名法王子住。始本合一名究竟觉。由华严位位成佛。故如王子长成堪绍觉位名灌顶住。轮王授太子位取四大海水以灌其顶名为授职是为真子。觉位亦然故称灌顶。

上前十住位以中道妙观观三谛理任运先证空如来藏竟。

二由中道妙观带真涉假证不空如来藏（十行）

阿难。是善男子成佛子已。具足无量如来妙德。十方随顺名欢喜行。善能利益一切众生名饶益行。自觉觉他得无违拒名无嗔恨行。种类出生穷未来际三世平等十方通达名无尽行。一切合同。种种法门得无差误名离痴乱行。则於同中显现群异。一一异相各各见同名善现行。如是乃至十方虚空满足微尘一一尘中现十方界。现尘现界不相留碍名无著行。种种现前咸是第一波罗蜜多名尊重行。如是圆融能成十方诸佛轨则名善法行。一一皆是清净无漏一真无为性本然故名真实行。

议曰。此十行位乃出真入俗起假观用证不空藏也。以如来藏循业发现随染业用故起染行。随净业用故起净行。以此藏性具有恒沙称性功德。向被无明障蔽。今无明既破性德用显。故具足无量如来妙德。不住果觉故十方随顺。理满心足名欢喜行。此摄十住满心融成一味生大法乐故欢喜耳。自利功满能转己功以利众生名饶益行。以观众生随顺觉性永无违拒名无嗔恨行。以嗔恨起於违拒故。称法界性不休不息穷未来际。三世平等而无出没。十方通达而无往来。现无尽身度无尽生名无尽行。佛界众生界一界无二界故一切合同。鉴机说法故得无差误。不著法相名离痴乱行。我以妙明不生不灭合如来藏而如来藏唯妙觉明圆照法界故离痴乱。是故於中一为无量无量为一。同中现异异中现同。事理无碍名善现行。於一毛端现宝玉刹。坐微尘里转大法轮。现尘现界不相留碍名无著行。凡所示现无非大用现前全彰法界。故咸是第一波罗蜜多名尊重行。灭尘合觉故发真如妙觉明性。如是圆融妙行能成十方诸佛轨则名善法行。一切诸法会归藏性。以事得理融理能夺事。故一一皆是清净无漏妙行。无思成事称性而行。一真无为性本然故名真实行。此十行位依理发行从体起用涉俗利生。所谓觉所觉空故显证不空如来藏也。

三由中道妙观空假互入证空不空如来藏（十向）

阿难。善男子满足神通成佛事已。纯洁精真远诸留患。当度众生灭除度相。回无为心向涅盘路。名救护一切众生离众生相回向。坏其可坏。远离诸离。名不坏回向。本觉湛然觉齐佛觉。名等一切佛回向。精真发明地如佛地。名至一切处回向。世界如来互相涉入得无挂碍。名无尽功德藏回向。於同佛地地中各各生清净因。依因发挥取涅盘道。名随顺平等善根回向。真根既成十方众生皆我本性。性圆成就不失众生名随顺等观一切众生回向。即一切法。离一切相。唯即与离二无所著。名真如相回向。真得所如十方无碍。名无缚解脱回向。性德圆成法界量灭。名法界无量回向。

议曰。此回向位由前涉假以入中道也。菩萨修行回向三处。谓回向实际。回向菩提。回向众生。以本觉出缠远离空有。入空不留入有无患故曰远离留患。当度众生回向众生也。灭除度相以众生如故本来平等回向实际也。回无为心向涅盘路回向菩提也。以众生即已。终日度生不见有生可度。故名离众生相回向。可坏者无明烦恼乃杂染众生相也。故坏其可坏。离相亦无故曰远离诸离。名不坏回向。空有不住一心清净寂灭湛然故觉齐佛觉。名等一切佛回向。寂灭心地精真显现故如佛地无往不真。名至一切处回向。一真法界依正互融。世界依报也。如来正报也。互相涉入名无尽功德藏回向。既依正互入圆融交涉通为一真。则草芥尘毛皆是成佛真体。故云地中各各生清净因即此是为涅盘妙行。依佛真因故云依因发挥。名随顺平等善根回向。已证平等法界则真根既成而一切众生纯一真如故云皆我本性以成就性即是成就众生。故云不失众生。名随顺等观一切众生回向。全理成事事能夺理故即一切法。 全事即理理能夺事故离一切相。理事无碍故二无所著。名真如相回向。以真得所如则无不如者。 缚脱两亡名无缚解脱回向。法界性德中道圆成。唯一真心则法界量灭。所谓空觉极圆名法界无量回向。此十回向。依前十行念念证真心心寂灭妙契中道故云回向。然虽三观历然中道理显。犹存历别未极一心之源。故为差别因。必须泯前修相。妙证寂灭一心平等法界。方得圆满菩提。故须四种妙圆加行。融前四十一心以为一味。以平等难证必用四加行以为入地之功行。但泯前心。非离前位别有四行。故此四心为登地胜进。良有旨哉。

二出世间平等因分二

初遣差别因相四加行分四 初暖位

阿难。是善男子尽是清净四十一心。次成四种妙圆加行。即以佛觉用为己心。若出未出。犹如钻火欲然其木名为暖地。

二顶位

又以己心成佛所履。若依非依。如登高山身入虚空下有微碍名为顶地。

三忍位

心佛二同善得中道。如忍事人非怀非出名为忍地。

四世第一位

数量销灭。迷觉中道二无所目。名世第一地。

议曰。此四加行为入地之胜进也。总前四十一心通名清净则干慧已真而信非相似明矣。将证平等一心立四加行位者以融前历别修相。意在亡能所绝对待泯前观智方证一真。义当空所空灭。以其观智难亡故须展转四重离即离非名妙圆耳。前已觉齐佛觉即以所显之果觉为今入地之因心。因心已极故云若出。观智未忘故云未出。有

如钻火之暖相名为暖地。又以己因心成一真境界成佛所履。但观智似忘未忘故云若依其实将忘故云非依。以法界如空无所依故。故如登高山身虽在空足未离地有此微碍名为顶地。以心境一如故心佛二同。平等一心故善得中道。前虽以中中流入但任运次第见三谛理故未为善。今圆满一心不思而合故云善得。观智将泯故非怀。缘影未断故非出。名为忍地直至一往理行断证功夫一切俱泯故云数量消灭。十信尚迷为有。三贤属觉为空。至此中道泯绝无寄。故云二无所目。方有出世之分。名世第一地。由是而观。足见三贤位乃通以中道观智总照无明住地任运浅深而显。约此以明次第。殆非分断分证者比也。

上总明差别因下明平等因

然前差别因以属生灭门中对待之真如。今此十地唯依寂灭一心建立不属对待故为平等因也。

二正入平等因相分二

初有功用行分二 初列位次

阿难。是善男子於大菩提善得通达。觉通如来尽佛境界名欢喜地。异性入同同性亦灭名离垢地。净极明生名发光地。明极觉满名焰慧地。一切同异所不能至名难胜地。无为真如性净明露名现前地。尽真如际名远行地。一真如心名不动地。发真如用名善慧地。

次结因圆

阿难。是诸菩萨从此已往修习毕功功德圆满。亦目此地名修习位。

次无功用行

慈阴妙云覆涅盘海名法云地。

三结果满

如来逆流如是菩萨顺行而至。觉际入交名为等觉。

议曰。此入地位由四加行胜进功圆会入圆觉寂灭一心故善达菩提。觉通如来尽佛境界名欢喜地。差别事理因果同归一心。同亦不立名离垢地。法界一心有大智慧光明义。由净极而光通达故为明生名发光地。明至极处觉性圆满名焰慧地。从此差别理事同异所不能至名难胜地。无为真如全体显露故曰性净明露名现前地。俱生无明名为远行。今尽真如际已舍藏识名远行地。纯一真如不假功用永绝动摇湛寂一心名不动地。华严说此地菩萨堕寂灭真如不舍此定。故十方诸佛说三加七劝而拔起之。出真如定从体起用便能说法居法师位。故发真如用名善慧地。远从干慧以来通名修习因位。今修习功毕行极理圆。所谓生灭既灭。故此地收功名修习位（结前因圆）。若第十地於法性空布慈阴云覆涅盘海。融前九位通成—心法云地。正寂灭现前。如来圆证一心虽居果位不舍因门故逆流而出。菩萨修行逆生死流顺法性流而入果海。因果相接故曰觉际入交名为等觉。（结果满）则忽然超越世出世间入妙觉矣。

三结指观行圆证一心泯同果海成无上妙觉之果分二 初正结

阿难。从干慧心至等觉已。是觉始获金刚心中初干慧地。如是重重单复十二。方尽妙觉成无上道。是种种地。皆以金刚观察如幻十种深喻。奢摩他中用诸如来毗婆舍那。清净修证渐次深入。阿难。如是皆以三增进故。善能成就五十五位真菩提路。

次劝修

作是观者名为正观。若他观者名为邪观。

议曰。比结观行以明圆证一心泯同果海成无上妙觉之果也。始终干慧二地从古解者不一。学者难凭。但未观佛法源头耳。以九界众生因三种流名五住烦恼感二种生死。五住者欲爱住地。色爱 住地。无色爱住地。见一切住地。无明住地。三种流者谓欲流。有流。无明流。前四烦恼为欲流有流感。分段生死。此在初信已断。无明住地名无明流。感变易生死。至佛果乃断。今经约生死染缘重在流字。故六根则曰流逸奔境。返妄观行则曰返流全一入流亡所。专约三种流相以为真妄之本也。今首楞严大定总名金刚如幻三昧。故下文云。是种种地皆以金刚观察渐次深入。是知从初干慧即用金刚观照。发心之初志在直断生相无明。何待等觉后心耶。以此证之则初干慧地乃用金刚心任运先断欲有二流出分段生死。故曰欲爱干枯根境不偶。现前残质不复续生。如澄浊水沙土自沉。清水现前名为初伏客尘烦恼。此明文的证也。

其无明流从入信以来即志断之。但无明深厚故历五十四位直至等觉后心生相无明才干。以此无明在观心中断故曰是觉始获金刚心中初干慧地。五住究尽。二死永亡。无明流至此才干。乃入妙觉出变易生死。所谓去泥纯水名为永断根本无明。是则位有始终观无先后。以力行深浅为次耳。以此证明决无疑矣。又何牵强多说哉。如是重重者亦有多解。但约华严位位胜进自然明了。初以三种渐次为发觉初心。圆成一心为胜进。乃入信位位位历别。及至第十融成一心。入住行向位位皆然。其四加行又融前三贤观智乃入初地。前九犹是历别因。十地融前诸位为因穷。等觉为果满。会归寂灭一心乃入妙觉。故曰重重。以先历次为单。后融一心胜进为复。盖单十复十有二也。奢摩他止也。毗婆舍那观也。天台三止三观正符此义。初云从是渐修安立圣位。故此结云如是皆以三增进故善能成就五十五位真菩提路。观此结文则初干慧地通为基本为一位。十信至十地为五十五。是则以前为因。以等觉为果。华严不立信位唯云初发心时即得菩提。与今经从三渐次安立圣位义同。但彼圆宗以十二因缘原是如来普光明大智愿海。一念信心即得安住。因果同时。唯说称性法门横周法界。故曰即得菩提。不说断证。此经意在逆生死流竖尽一心故曰安立圣位。此为别耳。观者应知。从前请问位次至此通显三观之用。约真如熏无明以显净用。并圆证一心泯同果海竟。

四结三观之名分二 初文殊请问经名

尔时文殊师利法王子在大众中即从座起。顶礼佛足而白佛言。当何名是经。我及众生云何奉持。

次世尊具答五目

佛告文殊师利。是经名大佛顶悉怛多般怛罗无上宝印。十方如来清净海眼。亦名救护亲因度脱阿难及此会中性比丘尼得菩提心入遍知海。亦名如来密因修证了义。亦名大方广妙莲华王。十方佛母陀罗尼咒。亦名灌顶章句。诸菩萨万行首楞严。汝当奉持。

议曰。前七卷半经说理行因果已周修证义了。故文殊请问经名。此经以首楞严大定为宗。始终不离一心三观。故结经即结观名耳。如来具答五目一名大佛顶等者。表此藏性具体相用三大。如题中说。故云大佛顶。梵语悉怛多般怛罗此云白伞盖。喻显蔽性清净故曰白。覆庇众生故如伞盖。以实相印印定诸法故名宝印。大海不唯不受死尸而草叶亦不留也。眼里不容纤尘。如来藏清净真心纤尘不立故喻如海眼。此克体相立名也。亦名救护等者。约用立名也。亦名如来等者。三世果人资为密因。若修若证皆为究竟故云了义。乃合体用而名也。亦名大方广等者。谓体具三大。清净无染。出生诸佛为大总持。此约体用胜益而名也。亦名灌顶等者。谓是法身所演中道名言。一切因人资为万行。总称大定。此约观行以名。故判此章通为结观行之名也。佛说五名而结集题中巧含多义。存三隐二可知 上结三观之名竟

初卷阿难启请以来通科大开修证之门竟


通议卷第八

通议卷第八

二曲示迷悟差别分二

由前一往开示迷悟因果至此已周法会已圆。即可罢座。大众应散。今复重兴后问以启七趣升沉之说五十阴魔之谈者意明迷悟之差别耳。义谓元依一心妄想只合薰成一类众生何以备有七趣升沉之状。悟止一心一悟便了何有二乘魔外之差。此群疑所潜。故有后说。七趣乃示迷中之差别。阴魔乃示悟中之差别耳。

初精研七趣曲示迷中差别之相分三

初经家叙益

说是语已。即时阿难及诸大众得蒙如来开示密印般怛罗义。兼闻此经了义名目。顿悟禅那修进圣位增上妙理。心虑虚凝断除三界修心六品微细烦恼。

二当机启请分三 初陈自益

即从座起顶礼佛足合掌恭敬而白佛言。大威德世尊。慈音无遮。善开众生微细沉惑。令我今日身心快然得大饶益。

二正陈所疑分六

初疑真本无妄六道从何而有

世尊。若此妙明真净妙心本来遍圆。如是乃至大地草木蠕动含灵本元真如即是如来成佛真体。佛体真实。云何复有地狱饿鬼畜生修罗人天等道。

二疑六道为是本有为从妄习生

世尊。此道为复本来自有。为是众生妄习生起。

三疑妄性无体妄业如何受报

世尊。如宝莲香比丘尼持菩萨戒私行淫欲。妄言行淫非杀非偷无有业报。发是语已。先於女根生大猛火。后於节节猛火烧然。堕无间狱。

四疑众生既是无生如何生陷地狱

琉璃大王善星比丘。琉璃为诛瞿昙族姓。善星妄说一切法空。生身陷入阿鼻地狱。

五疑世界既无所住地狱可有定处

此诸地狱为有定处。为复自然。

六疑妄业是同受报何以各别

彼彼发业。各各私受。

三结请意

惟垂大慈发开童蒙。令诸一切持戒众生闻决定义。欢喜顶戴谨洁无犯。

议曰。此呈益赞谢复请后疑也。三界九地每地各具思惑九品。今闻开示实证二果实断下界一地前六品思惑故曰微细烦恼。约观行研穷俱生无明故曰善开微细沈惑。此赞谢也。若此妙明下总摄前义含有六疑。据答甚明。由问位之初乃曰妙性圆明离诸名相本来无有世界众生。又云清净本然周遍法界则一切皆是如来成佛真体。故此

疑云佛体真实既本无妄六道从何而有。此一疑也。故下答云因彼妄见有妄习生。二疑六道为是本来自有为是从妄习生起。故下答云此等皆是自妄想业之所招引。於中含有妄想是一何以六道不同。故下答云因有情想不同故有七趣升沉。三疑妄性既是无体妄业如何受报。如宝莲香淫业招报。故下答云自妄所招还自来受。四疑众生既是无生云何生陷地狱。如琉璃王杀业善星妄语堕无间狱。故下答云非从天降不从人兴自妄所招。五疑世界既本无住地狱可有住处。故下答云众私同分非无定处。六疑妄业既是一同受报如何各别。故下答云因各各私众私同分。以此六疑总显迷中差别之状。故世尊委答曲尽迷情。先举答意以质问端。

三世尊曲示分二 初赞许

佛告阿难。快哉此问。令诸众生不入邪见。汝今谛听。当为汝说。

议曰。此赞许也。惬佛本怀故称快哉。

次开示分五 初通示七趣根本分三

初约妄见妄习立内外分为三界之因

阿难。一切众生实本真净。因彼妄见有妄习生。因此分开内分外分。

二约内外情想为染净生死之因分二

初内分纯染

阿难。内分即是众生分内。因诸爱染发起妄情。情积不休能生爱水。是故众生心忆珍羞口中水出。心忆前人或怜或恨目中泪盈。贪求财宝心发爱涎举体光润。心著行淫男女二根自然流液。阿难。诸爱虽别流结是同。润湿不升自然从坠。此名内分。

次外分兼净

阿难。外分即是众生分外。因诸渴仰发明虚想。想积不休能生胜气。是故众生心持禁戒举身轻清。心持咒印顾盼雄毅。心欲生天梦想飞举。心存佛国圣境冥现。事善知识自轻身命。阿难。诸想虽别轻举是同。飞动不沉自然超越。此名外分。

议曰。此答七趣升沉之元也。实本清净本无妄也。妄见妄习迷轮始也。约内外分而分情想以定升沉。内分者由自心内爱习凝结而为情也。由内而发故云内分。外分者由虚想而发。自外而感故云外分。

三约情想多寡示七趣升沉之相分三

初总明生死交际之相

阿难。一切世间生死相续。生从顺习。死从变流。临命终时未舍暖触。一生善恶俱时顿现。死逆生顺二习相交。

二约情想多寡细示升沉之相分二

初列示其相分六 初天道

纯想即飞必生天上。若飞心中兼福兼慧及与净愿。自然心开见十方佛。一切净土随愿往生。

二天仙神道

情少想多轻举非远。即为飞仙大力鬼王飞行夜叉地行罗刹。游於四天所去无碍。其中若有善愿善心护持我法。或护禁戒随持戒人。或护神咒随持咒者。或护禅定保绥法忍。是等亲住如来座下。

三人道

情想均等不飞不坠生於人间。想明斯聪。情幽斯钝。

四畜道

情多想少流入横生。重为毛群。轻为羽族。

五鬼道

七情三想沉下水轮生於火际受气猛火。身为饿鬼常被焚烧。水能害己。无食无饮经百千劫。

六地狱道

九情一想下洞火轮。身入风火二交过地。轻生有间重生无间二种地狱。纯情即沉入阿鼻狱。若沉心中有谤大乘毁佛禁戒诳妄说法虚贪信施滥膺恭敬五逆十重。更生十方阿鼻地狱。

二略示报地

循造恶业虽则自招。众同分中兼有元地。

议曰。此备言七趣升沉之所以也。生为循情故云顺习。临终恶业果报现前故云变流。二习相交谓方生方死之际善恶殊途升沉遂别故纯想即飞必生天上。此纯想业也。若兼福慧净愿故生净土此纯净想也。若情少想多故升为神仙之类。有护法心者亲住佛座。此亦习使然也。若情想均等则为人类但约情想厚薄以分智愚。若六情四想则为毛羽群族。七情三想下沉水轮受气猛火。若八情二想则为饿鬼见水成火故能害己。若九情一想则入地狱。纯情即沉阿鼻。若加谤法五逆十重则永无出期。此三恶之状循造恶业自招。地狱则同受而各有元地非无因也。

三广示七趣轮回因果之相分二

初各示其相分七

初示地狱道因果之相分五

初总标十因六报

阿难。此等皆是比诸众生自业所感。造十习因。受六交报。

议曰。此结前起后十因六报详示地狱苦状以显情习之感也。造十习因委明地狱但约情习而言。谓习约一念妄心。而报则六根交受者以念念妄想融涉六根故报亦同受。如十二类则一 一类各具十二。今地狱苦报则一习为因六根同果足见众生业性不可思议。熏变之力昭然可睹矣。十习谓淫贪慢嗔诈诳怨见枉讼也。轮中根本烦恼六谓贪嗔痴慢疑邪见。此中具四。随烦恼十谓忿恨恼覆诳谄骄害嫉悭。此中诳即彼之诳。怨枉即该忿恨恼害四法。诈即是谄讼即是覆。其骄属慢。嫉属嗔。悭属贪。前四重律谓淫杀盗三总为贪。今则单以淫为首者是诸业之本故也。

二别择其相分二 羽征十习因相分十

初淫习分四 一因能感果

云问十因阿难。一者淫习交接发于相磨。研磨不休。如是故有大猛火光于中发动。如人以手自相摩触暖相现前。

二举果验因

二习相然故有铁床铜柱诸事。

三诸佛所呵

是故十方一切如来色目行淫同名欲火。

四行人当避

菩萨见欲如避火坑。

议曰。此征释淫习为生死根众罪之首也。男女交接二妄相磨故暖相现前此命终所现之境也。二习烧然故果感铁床等事。此所感地狱苦报也。下仿此。诸佛目淫为欲火。行人当避如火坑也。

二贪习分四 一因能感果

二者贪习交计。发于相吸。吸揽不止。如是故有积塞坚冰於中冻冽。如人以口吸缩风气有冷触生。

二举果验因

二习相陵故有吒吒波波罗罗青赤白莲寒冰等事。

三诸佛所呵

是故十方一切如来色目多求同名贪水。

四行人当避

菩萨见贪如避瘴海。

议曰。此贪通约贪著而言也。故曰於有有具染著为性。彼此妄计贪取故曰交计。贪取不止故如吸揽。吸生冷触故感寒冰等相。陵谓凭陵竞尚不休之意。吒波罗忍寒之声也。青赤白莲寒冻之色也。诸佛名贪为水以没溺故。行人当避如瘴海也。

三慢习分四 一因能感果

三者慢习交陵发於相恃。驰流不息。如是故有腾逸奔波积波为水。如人口舌自相绵味因而水发。

二举果验因

二习相鼓故有血河灰河热沙毒海融铜灌吞诸事。

三诸佛所呵

是故十方一切如来色目我慢名饮痴水。

四行人当避

菩萨见慢如避巨溺。

议曰。慢有多种。此指我慢而言也。谓恃己陵他高举为性。自他相慢故曰交陵。陵乃欺侮之意。恃谓恃己贡高慢之不已故曰驰流不息。故感奔波等相。彼此皆有傲慢之气故曰相鼓。故感灰河等事。诸佛名慢为饮痴水溺於不明。行人当避如巨溺也。

四嗔习分四 一因能感果

四者嗔习交冲发於相忤。忤结不息心热发火铸气为金。如是故有刀山铁橛剑树剑轮斧钺枪锯。如人衔冤杀气飞动。

二举果验因

二习相击故有宫割斩斫锉刺槌击诸事。

三诸佛所呵

是故十方一切如来色目嗔恚名利刃剑。

四行人当避

菩萨见嗔如避诛戮。

议曰。嗔习以怒气相加故曰交冲忤逆也。忤结不息。火盛而气益刚。铸气为金。故感刀山等相。而相伤刺故曰相击。故有宫割等事。诸佛目嗔名利刀剑。行人当避如诛戮也。

五诈习分四 一因能感果

五者诈习交诱发于相调。引起不住。如是故有绳木绞校。如水浸田草木生长。

二举果验因

二习相延故有〖木丑〗械枷锁鞭杖挝棒诸事。

三诸佛所呵

是故十方一切如来色目奸伪同名谗贼。

四行人当避

菩萨见诈如畏豺狼。

议曰。诈乃诳诈。为获利誉矫现有德。诡诈为性。邪命为业。诳惑於人故曰诱曰调。引谓缘引。故感绳绞校等相。校枷也。相延谓缠蔓不已。故有〖木丑〗械等事。如来目奸伪同名说贼。行人当畏如豺狼也。

六诳习分四 一因能感果

六者诳习交欺发於相罔。诬罔不止飞心造奸。如是故有尘土屎尿秽汗不净。如尘随风各无所见。

二举果验因

二习相加故有没溺腾掷飞坠漂沦诸事。

三诸佛所呵

是故十方一切如来色目欺诳同名劫杀。

四行人当避

菩萨见诳如践蛇虺。

议曰。此诳不同於诈乃欺罔之意。谓罔冒他人谄曲为性。矫设方便以取他意。故曰交欺相罔。以飞心造奸故感尘土屎尿等相。以心秽恶故感如此。相加诸交欺也。故有没溺腾掷等事。如来目欺名劫杀。行人当避如践蛇虺。

七怨习分四 一因能感果

七者怨习交嫌发於衔恨。如是故有飞石投砾匣贮车槛瓮盛囊扑。如阴毒人怀抱畜恶。

二举果验因

二习相吞故有投掷擒捉击射抛撮诸事。

三诸佛所呵

是故十方一切如来色目怨家名违害鬼。

四行人当避

菩萨见怨如饮鸩酒。

议曰。怨习谓彼此嫌。由衔恨而发。故感飞石投砾等相。递相吞食故有投掷等事。如来目怨名违害鬼。行人当避如饮鸩酒。

八见习分四 一因能感果

八者见习交明。如萨迦耶见戒禁取邪悟诸业。发於违拒出生相反。如是故有王使主吏证执文籍。如行路人来往相见。

二举果验因

二习相交故有勘问权诈考讯推鞫察访披究照明。善恶童子手执文簿辞辩诸事。

三诸佛所呵

是故十方一切如来色目恶见同名见坑.

四行人当避

菩萨见诸虚妄遍执如临毒壑。

议曰。此恶见也。谓于诸谛理颠倒推度。染慧为性。能障正见。招苦为业。彼此非其明而明之故曰交明。萨迦耶此云恶见。此见有五。谓一身见执我我所。二边见谓执断常二边。三邪见谓谤无因果。四见取非果计果。如以无想为涅盘之类。五戒禁取谓非因计因如外道持牛狗等戒卧棘投灰等。苦行为业。无益勤苦。故曰邪悟。以各执己见故有王使执证等相。相交谓交哄诤论。故感勘问考讯等事。如来目见为见坑。行人见遍执者如临毒壑。

九枉习分四 一因能感果

九者枉习交加发於诬谤。如是故有合山台石碾〖石岂〗耕磨。如谗贼人逼枉良善。

二举果验因

二习相排故有押捺槌按蹙洒衡度诸事。

三诸佛所呵

是故十方一切如来色目怨谤同名谗虎。

菩萨见枉如遭霹雳

议曰。枉谓诬枉。谗谤狠戾为性。即恼害也。能障不恼。蛆螫为性。乃追怀往恶多发嚣暴。兕鄙粗言。蛆螫他故。故曰交加。谓交相加害发於诬谤故有合山磕石等相。以二习相排。排谓挤陷。故感押捺诸事。如来色目怨谤名为谗虎。行人见枉如遭霹雳。

十讼习分四 一因能感果

十者讼习交宣发於藏覆。如是故有鉴见照烛。如於日中不能藏影。

二举果验因

二习相陈故有恶友业镜火珠披露宿业对验诸事。

二诸佛所呵

是故十方一切如来色目覆藏同名阴贼。

四行人当避

菩萨观覆如戴高山履於巨海。

议曰。此讼习讼其覆也。讼即是覆。谓於自作罪恐失利誉。隐藏为性。能障不覆。损恼为业。彼覆此讼故曰交宣。以其覆故故有鉴见照烛等相。陈谓陈列罪状。故感业镜对验等事。如来目覆名为阴贼。行人观覆如戴山履海。此上十习发业为因因必趣果故感地狱种种苦具。且十种习各由一念妄想而发。以此妄想融涉六根。故受苦报六根互变名为交报。

二释六交报相分二 初标六报总相

云何六报。阿难。一切众生六识造业。所招恶报从六根出。

议曰。此征标六交报相也。以六识总造恶业遍熏六根。故报从六根而出通受其苦。

次释六报别相分六 初见报分二

初当根招报分三 初现报

云何恶报。从六根出。一者见报招引恶果。此见业交。则临终时先见猛火满十方界。

二生报

亡者神识飞坠乘烟入无间狱。

三后报

发明二相。一者明见。则能遍见种种恶物生无量畏。二者暗见。寂然不见生无量恐。

次六根交报

如是见火。烧听能为镬汤洋铜。烧息能为黑烟紫焰。烧味能为焦丸铁糜。烧触能为热灰炉炭。烧心能生星火迸洒煽鼓空界。

议曰。此见业交乃眼识造业招引恶果也。易卦离为火为目。故见业交先见猛火。方生方死之际亡者神识将舍暖触故随见业所感之境识从习变乘之入无间狱。古释极善极恶皆无中阴。故如射箭顷径入地狱。以见不离明暗二尘故发明二相。一者明见。恶境遍现故生畏。二者暗见。寂无所见故生恐。此本识业因。下明六交报果。本识见火能烧当根经文缺也。闻根属水故为镬汤洋铜。鼻息为气故为烟焰。味触二尘以报舌身。心属火故星火煽空。此由见火交烧五根各随尘习而变诸苦具。此业为不可思议也。下仿此。

二闻报分二 初当根招报分三

初现报

二者闻报招引恶果。此闻业交则临终时先见波涛没溺天地。

二生报

亡者神识降注乘流入无间狱。

三后报

发明二相。一者闻听。听种种闹精神懋乱。二者闭听。寂无所闻幽魄沉没。

次六根交报

如是闻波。注闻则能为责为诘。注见则能为雷为吼。为恶毒气。注息则能为雨为雾洒诸毒虫周满身体。注味则能为脓为血种种杂秽。注触则能为畜为鬼为粪为尿。注意则能为电为雹摧碎心魄。

议曰。此闻业交耳识造业招引恶果也。易卦坎为水为耳。故闻业先见波涛神识乘流识从习变也。闻以开听为用。故闭则无闻闻注当根变为诘责之声。见火闻水相激若阴阳相激而为雷吼。水被火蒸故为恶毒气。水随气变故注息为雨雾毒虫脓血粪尿皆习所变也。水火相激故为电雹。

三嗅报分二 初当根招报分三

初现报

三者听报招引恶果。此嗅业交。则临终时先见毒气充塞远近。

二生报

亡者神识从地踊出入无间狱。

三后报

发明二相。一者通闻。被诸恶气熏极心扰。二者塞闻。气掩不通闷绝於地。

次六根交报

如是嗅气。冲息则能为质为履。冲见则能为火为炬。冲听则能为没为溺为洋为沸。冲味则能为馁为爽。冲触则能为绽为烂为大肉山有百千眼无量咂食。冲思则能为灰为瘴为飞沙砾击碎身体。

议曰。此嗅业交鼻识招引恶果也。鼻主出入息故先见毒气。鼻为土故识从地踊。鼻由通塞取境故通闻毒气塞则气掩。嗅冲当根则为质履。质碍塞也。履犹通也。气冲见火则为炬。气冲闻水则为没溺洋沸之声。气冲味则变败为馁为爽。为败曰馁。

爽失其味也。冲触则为绽烂肉山合触尘也。脾土主思故为飞沙等事。

四味报分二 初当根招报分三

初现报

四者味报招引恶果。此味业交则临终时先见铁网猛焰炽烈周覆世界。

二生报

亡者神识下透挂网倒悬其头入无间狱。

三后报

发明二相。一者吸气。结成寒冰冻冽身肉。二者吐气。飞为猛火焦烂骨髓。

次六根交报

如是尝味。历尝则能为承为忍。历见则能为然金石。历听则能为利兵刃。历息则能为大铁笼弥覆国土。历触则能为弓为箭为弩为射。历思则能为飞热铁从空雨下。

议曰。此味业交舌识招引恶果也。舌根不但取味而妄语绮语两舌恶口。或谤三宝毁汙贤善等。其业最广大。故感报亦甚。故临终先见铁网猛焰等相。神识乘之入无间狱。舌以吸吐二习。吸则取味。吐则发语。故吸则为寒冰等。吐则为猛火等。历当根为承为忍。以恶语伤人令他承忍故报亦如之。历见为然金石以见火铸气为金。金得水淬而更利故历闻为利刃。非语乘气笼络於人故历息为铁笼。利舌伤触於人故历触为弓箭等事。由意造奸而飞语横发故飞铁从空雨下。


通议卷第八

通议卷第八

五触报分二 初当根招报分三

初现报

五者触报招引恶果。此触业交则临终时先见大山四面来合无复出路。

二生报

亡者神识见大铁城火蛇火狗虎狼师子牛头狱卒马头罗刹手执枪〖矛肖〗驱入城门向无间狱。

三后报

发明二相。一者合触。合山逼体骨肉血溃。二者离触。刀剑触身心肝屠裂。

次六根交报

如是合触。历触则能为道为观为厅为案。历见则能为烧为热。历听则能为撞为击为〖事刂〗为射。历息则能为括为袋为考为缚。历尝则能为耕为钳为斩为截。历思则能为坠为飞为煎为炙。

议曰。此触业交身识招引恶果也。以众生妄识坚执四大为我依之造业故临终先见大山四面来合向未离身故死无出路。以身为众恶所归故神识乘铁城众多恶事入於地狱。触由离合二尘。故合则合山逼体。离则刀剑触身。历触当根为道观等者以生依此身如房舍故。历见则为火烧热见属火故。历听则撞击而有声。〖事刂〗以刀刺入肉也。以闻声即动触想故为〖事刂〗射。以息充一身故为括袋考缚等事。历尝能为耕钳斩截者以味充舌为滋触故。历思为飞坠煎炙者以妄想一动遍身火然。随因感果宜其然矣。

六思报分二 初当根招报分三

初现报

六者思报招引恶果。此思业交。则临终时先见恶风吹坏国土。

二生报

亡者神识被吹上空旅落乘风堕无间狱。

三后报

发明二相。一者不觉。迷极则荒奔走不息。二者不迷。觉知则苦无量煎烧痛深难忍。

次六根交报

如是邪思。结思则能为方为所。结见则能为鉴为证。结听则能为大合石为冰为霜为土为雾。结息则能为大火车火船火槛。结尝则能为大叫唤为悔为泣。结触则能为大为小为一日中万生万死为偃为仰。

议曰。此思业交意识招引恶果也。六识以缘气集聚妄想如风。故临终见风乘入地狱。思以生灭二尘。迷觉约根迷无所止故荒走不息。觉则明了故知苦痛思历当根生以妄想为心地故能为方所归向之地。思发知见故为鉴证。思土听水故为冰霜土雾。思以笼冒息气成火故结为火车等。思由舌发声故为叫唤等。思执根身故为生死偃仰等。是六交报皆以不思议业力之所熏变。唯佛眼能见非凡妄识情所知故唯心所变。地狱苦具不可解者甚多但约义据理而言非真知见力也。总属自心所现非心外法。故下文云若悟菩提则本无所有。凡在迷情可不畏哉。

三结示所由

阿难。是名地狱十因六果皆是众生迷妄所造。

议曰。此总结妄业由迷情有也。

四校量轻重分三 初六根同造

若诸众生恶业同造入阿鼻狱受无量苦经无量劫。

二六根各造

六根各造及彼所作兼境兼根。是人则入八无间狱。

三三业分造分三 初三业兼造

身口意三作杀盗淫是人则入十八地狱。

二三业不兼

三业不兼。中间或为一杀一盗。是人则入三十六地狱。

三六根独造

见见一根单犯一业。是人刚入一百八地狱。

五结答略问

由是众生别作别造。於世界中入同分地。妄想发生本非来有。

议曰。此示因果轻重之次也。同造谓十因六报具足也。六根各造谓先后不一。单兼一根一境则轻次前。若身口意三根唯造杀盗淫三业馀不兼涉则又轻次前。若於三业唯造二不兼馀则又轻次前。若一根独造单犯一业则又轻次前。见见（长水音现） 谓六根唯一造一业不兼馀也。以不相涉故云见见别作别造谓各各私造也。其业是同故感同分狱。由前问云。为是本有为是造成。故此结云皆是妄想发生非本来有。

上显十因六报之状 下示轮回之相

二示鬼道因果之相分三

初标示因果总相

复次阿难。是诸众生非破律仪犯菩萨戒毁佛涅盘。诸馀杂业。历劫烧然。后还罪毕受诸鬼形。

议曰。此从地狱出复受鬼形以显轮回之状也。前十习因所感地狱。若但由习则报尽可出。若非破律仪等则其苦更长故复受鬼形。非破律仪破比丘戒也。犯菩萨戒则破大乘性戒也。毁佛涅盘谓一阐提断佛种性也。此断善根受苦时长故复受鬼类。

上总标下别列

二别示因果别相分十 初贪习

若於本因贪物为罪。是人罪毕遇物成形名为怪鬼。

二淫习

贪色为罪。是人罪毕遇风成形名为魃鬼。

三诈习

贪惑为罪。是人罪毕遇畜成形名为魅鬼。

四怨习

贪恨为罪。是人罪毕遇虫成形名蛊毒鬼。

五嗔习

贪忆为罪。是人罪毕遇衰成形名为厉鬼。

六慢习

贪傲为罪。是人罪毕遇气成形名为饿鬼。

七诳习

贪罔为罪。是人罪毕遇幽为形名为魇鬼。

八见习

贪明为罪。是人罪毕遇精为形名魍魉鬼。

九枉习

贪成为罪。是人罪毕遇明为形名役使鬼。

十讼习

贪党为罪。是人罪毕遇人为形名传送鬼。

三结示因由分二 初结升坠因由

阿难。是人皆以纯情坠落业火烧干上出为鬼。

次结答有无所以

此等皆是自妄想业之所招引。若悟菩提则妙圆明本无所有。

议曰。此贪习也。所贪者物故附物成形。以巧计而取故为鬼犹怪。淫习贪色。以淫心欲火故遇风成形。名为魃鬼。旱鬼也。诈习惑人名为贪惑故遇畜成形即狐狸精魅现美色以惑人。故为魅鬼。怨习怀恨故为贪恨。恨积恶毒故遇虫成形如蛇虺蝮蝎以毒伤人。故为蛊毒鬼。嗔习怀恚不忘故为贪忆。乘虚而入故遇灾衰成形名为厉鬼。即瘟疫时病疟症皆此鬼作也。慢习陵人傲物欲为贪傲。骄矜恃气故运气成形。空腹高心故为饿鬼。诳习罔冒欺人故为贪罔。暗昧良心故遇幽成形。魇惑寐者故为魇鬼。见习妄执邪见以为明悟故为贪明。遇精明处即附成形。如山灵木石之精名魍魉鬼。以见逐光影故鬼亦似有若无。枉习构架无辜以成有罪故为贪成。以精思求过故遇明成形劳役心神故为役使鬼。即担沙负石之鬼。讼习党护己罪彼此相讼故为贪党。因人造奸故遇人成形发人隐恶。名传送鬼。即巫师之类。讦露阴事。以上十因所招地狱。纯情坠落业火烧尽。馀习未尽。故出而为鬼。皆是妄业招引。妙圆心中本无此事。盖由迷情所感之妄相耳。

三示畜生道因果之相分三

初标示因果总相

复次阿难。鬼业既尽则情与想二俱成空。方於世间与元负人怨对相值。身为畜生酬其宿债。

二列示因果别相分十 初贪习

物怪之鬼物销报尽。生於世间多为枭类。

二淫习

风魃之鬼风销报尽。生於世间多为咎征一切异类。

三诈习

畜魅之鬼畜死报尽。生於世间多为狐类。

四怨习

虫蛊之鬼蛊灭报尽。生於世间多为毒类。

五嗔习

衰疠之鬼衰穷报尽。生於世间多为蛔类。

六慢习

受气之鬼气销报尽。生於世间多为食类。

七诳习

魇昧之鬼幽销报尽。生于世间多为服类

八见习

和精之鬼和销报尽。生於世间多为应类。

九枉习

明灵之鬼明灭报尽。生於世间多为休征一切诸类。

十讼习

依人之鬼人亡报尽。生於世间多为循类。

三结示因由分三 初结示轮回因由

阿难。是等皆以业火干枯。酬其宿债傍为畜生。

二结答有无所以

此等亦皆自虚妄业之所招引。若悟菩提则此妄缘本无所有。

三牒示问意

如汝所言宝莲香等及璃璃王善星比丘。如是恶业本自发明。非从天降。亦非地出。亦非人与。自妄所招还自来受。菩提心中皆为浮虚妄想凝结。

议曰。此从鬼道出为畜生类也。以情多少之不一故沉地狱之不同。地狱罪毕复出为鬼。既经苦趣则情想之业二皆报尽故曰俱空。但怨债未忘以身酬值故为畜生。亦因本习各从其类。且如贪习为怪鬼畜为枭类。以贪他物而为己有故土枭附块为儿习使然也。物能容己故枭子食母业使然也。淫习为魃鬼淫为病征故馀习出为咎征。如商羊舞水江豚拜风之类。诈习魅鬼而为狐类。狐能魅人亦馀习也。怨习蛊鬼而为毒类。如蛇蝎等嗔习厉鬼乘衰入身而为蛲蛔。慢习饿鬼往受饥虚故为食类以充人腹。诳习为靥昧之鬼因诳罔冒於人虚饰外仪故为服类。凡畜物皮毛可为服饰或驴骡马等可乘服者皆其类也。见习魍魉名和精鬼和杂精明而为鬼也。畜为应类即应节序而先鸣者。预知先报盖见习也。枉习役使之鬼托明以生名明灵鬼。畜为休征之类。休美也。休征乃美事之先见者即麟凤之类。如吏励精图治穷诘民情而为明。所谓神明之宰皆其类也。讼习为传送故名依人之鬼。即世健讼能起灭讼事。一向因人故鬼为传送。畜为循类即人所畜养猫犬之类。专爱依人习使然也。此十畜类皆以业火干枯酬偿宿债而为畜生。皆妄业所招。若悟菩提则此三恶道本无所有。如汝所言宝莲琉璃善星等业皆自心发明。元非天降人与。乃自妄作其因自受苦果。於菩提心中皆妄想凝结耳。可不哀哉。

四示人道因果之相分三

初标示因果总相分二 初示因果酬偿

复次阿难。从是畜生酬偿先债。若彼酬者分越所酬。此等众生还复为人反征其剩。如彼有力兼有福德。则於人中不舍人身酬还彼力。若无福者还为畜生偿彼余直。

二示轮回不已

阿难当知。若用钱物或役其力偿足自停。如於中间杀彼身命或食其肉。如是乃至经微尘劫相食相诛。犹如转轮互为高下无有休息。除奢摩他及佛出世不可停寝。

议曰。此言畜生酬足复生人类。盖三恶报尽而幸生为人非善业所感也。故首论酬偿先债。然债非独杀盗而十习因中皆有负债之义。其贪诈等皆以邪命自活妄取他财岂非夙负。故畜生类中总言偿债偿足而止。言酬越过分者。谓或多售其价。过用其力。或过贪其味。挫糜其身。皆为过越。使彼含冤必返征其剩。此其所以轮回不已也。如彼有力即於人中酬偿者。如不孝败家之子弟。狐媚骗财之朋友。与夫劫贼官讼之类。令其破产荡财。皆往业所招。非无因也。又若负钱物而以身偿还如值而止。更杀其身而食其肉皆为过也。故相食相诛轮转不已。自非禅定之力及遇佛忏悔决无停寝之日也。

二列示因果别相分十 初贪习

汝今应知。彼枭伦者酬足复形。生人道中参合顽类。

二淫习

彼咎征者酬足复形。生人道中参合异类。

三诈习

彼狐伦者酬足复形。生人道中参於庸类。

四怨习

彼毒伦者酬足复形。生人道者参合狠类。

五嗔习

彼蛔伦者酬足复形。生人道中参台微类。

六慢习

彼食伦者酬足复形。生人道中多合柔类。

七诳习

彼服伦者酬足复形。生人道中参合劳类。

八见习

彼应伦者酬足复形。生人道中参於文类。

九枉习

彼休征者酬足复形。生人道中参合明类。

十讼习

彼诸循伦酬足复形。生人道中参於达类。

三结示轮回之相

阿难。是等皆以宿债毕酬复形人道。皆无始来业计颠倒相生相杀。不遇如来不问正法。於尘劳中法尔轮转。此辈名为可怜愍者。

议曰。此列十种酬偿人类也。枭本贪习从怪鬼出。今幸为人参合顽类。顽谓顽嚣无知也。以因地多贪而性愚痴故今为颛蒙无知之类。言参合者参预也。合混为一也。谓人中愚顽自有本因。今从鬼畜而来得参预混合而为人。意盖谓虽得人身而似非分也。咎征本淫习从魃鬼出。以多淫者邪心苟合故参异类。狐本诈习从畜魅鬼出参於庸类。谓庸鄙自用由诈习欺人故今返习庸鄙也。毒本怨习从虫毒鬼出故参合狠类。以怨天尤人而不揣己习使然也。蛔本嗔习从疠鬼出参合微类。微者眇贱不为人所齿录也。以嗔陵毒於人故感报微眇。食本慢习从饿鬼出。慢习贡高故感柔怯。以食类为强所陵故为人亦柔怯。服本诳习从魇鬼出。以因劳苦役力故人亦为劳形治生之类。应本见习从和精鬼出而人为文类。此文非大名家。盖小有才情动止可观者耳。休征本於枉习从明灵鬼出故人参明类。此世智聪明非明智也。讼习从传送鬼出而人为达类。此非达者之达乃通达世情。以讼习主刁词起灭鬼为传送发人祸福。故人

参达类习使然也。此上十类非正因为人故皆云参合。乃三途馀果酬毕复形各从习类。实业计颠倒耳。以未闻正法法尔轮转。此辈名为可怜愍者。

上人趣毕。

五示仙道因果之相分三

初标示因果总相

阿难。复有从人不依正觉修三摩地。别修妄念存想固形游於山林人不及处有十种仙。

议曰。此标仙趣也。仙道亦因修得。以不依正觉修三摩地。但依妄念存想固形。所谓修长生者。各从其术而有十种。

二列示因果别相分十 初地行仙

阿难。彼诸众生坚固服饵而不休息。食道圆成名地行仙。

议曰。此地行仙。因服饵所成。谓服药饵以此养形而得寿者。行不离地为地行仙。

二飞行仙

坚固草木而不休息。药道圆成名飞行仙。

议曰。此飞行仙。因餐松啖柏黄精芝术之类。服久身轻而得飞举非吸风露者比。

三游行仙

坚固金石而不休息。化道圆成名游行仙。

议曰。此游行仙。乃炼丹沙点化五金八石。游戏人间故曰化道名游行仙。

四空行仙

坚固动止而不休息。气精圆成名空行仙。

议曰。此空行仙。常消息阴阳之候。以子午卯酉为运气工夫。故云动止久而身轻蝉脱。名空行仙。

五天行仙

坚固津液而不休息。润德圆成名天行仙。

议曰。此天行仙。因鼓天池津液。吐故纳新。日久功成。如八洞神仙之类。能谒天帝。故曰天行仙。

六通行仙

坚固精色而不休息。吸粹圆成名通行仙。

议曰。此通行仙。乃吞日精月华。呼吸导引。久而寿永心通名通行仙。

七道行仙

坚固咒禁而不休息。术法圆成名道行仙。

议曰。此道行仙。因持咒禁术而得成功。如天师之类。名道行仙。此道乃禁术非大道也。

八照行仙

坚固思念而不休息。思忆圆成名照行仙。

议曰。此照行仙。以存想丹田泥丸为命元。如庄子曰泥垣之审为渊。名照行仙非慧照也。

九精行仙

坚固交媾而不休息。感应圆成名精行仙。

议曰。此精行仙。谓固守精气阴阳交媾如婴儿姹女之类。胎息存形名精行仙。

十绝行仙

坚固变化而不休息。觉悟圆成名绝行仙。

议曰。此绝行仙。乃习出阳神改形易质往来自由故曰变化。久而心通故曰觉悟。余仙之所不及故曰绝行仙。

三结示轮回之相分二 初拣不解真修

阿难。是等皆于人中炼心不修正觉。别得生理寿千万岁。休止深山或大海岛绝于人境。

次示轮回根本

斯亦轮回妄想流转。不修三昧。报尽还来散入诸趣。

议曰。此结仙趣也。以此仙趣乃人中炼心别得生理故胜于人。寿千万岁故不如天。不修正觉故曰妄想流转。报尽堕落故散入诸趣。以非天非人故别列此趣。

上仙趣毕

六示天道因果之相分二

初建示三界因果之相分三初欲界六天分二

初列示器界因果之相分六

初四天王

阿难。诸世间人不求常住。未能舍诸妻妾恩爱。于邪淫中心不流逸。澄莹生明。命终之后邻于日月。如是一类名四天王天。

议曰。此后言天趣也。三界中先从欲界。六欲天始于四王也。〖忄刃〗利已下名地居天。未离饮食男女之欲但因重轻为六天之次。皆不知修禅。正以十善之因所感耳。四王居须弥山。腰部日月宫。四面居之。为护世四王。此经论天下不说十善。单以淫欲一事为本。从经所宗也。四王有正妻妾。恩爱未舍。但不邪淫故感生此天。

二（忄刀）利天

于己妻房淫爱微薄。于净居时不得全味。命终之后超日月明。居人间顶。如是一类名（忄刀） 利天。

议曰。此（忄刀）利云三十三天。乃地居顶天。称帝释天。居须弥顶中。四方各统八天。故云三十三。以欲气粗浊故欲薄则上升。此天虽有妻房而淫爱微薄。即净居时不得全味。有微爱故。人中爱薄即感生此天。日月在下故超日月明。

三夜摩天

逢欲暂交。去无思忆。于人间世动少静多。命终之后于虚空中朗然安住。日月光明上照不及。是诸人等自有光明。如是一类名须焰摩天。

议曰。此欲界第三空居第一天。须焰摩此云时分。此天无日月光而有身光。以莲花开合为昼夜。由昔人中欲气渐薄故感生此天。逢欲暂交未离欲也。去无思忆无爱心也。不驰欲境故动少。欲淡心清故静多。身心不染而无秽浊。故朗然空居自有光明。

四兜率天

一切时静。有应触来未能违戾。命终之后上升精微不接下界诸人天境。乃至劫坏三灾不及如是一类名兜率陀天。

议曰。此欲界第四天也。兜率此云知足。有内院外院。外院乃实报天人所居。内院乃弥勒一生补处为主。其在释迦末法弘法菩萨及修行发愿待弥勒下生助扬法化者居之。以淫机不动故一切时静。未能息机故应触不违。以行胜前故云上升精微。然三灾坏至三禅而此云不坏者盖指内院而言也。

九五化乐天

我无欲心应汝行事於横陈时味如嚼腊。命终之后生越化地。如是一类名乐变化天。

议曰。此欲界第五天也。以乐变化五欲之境而自受用故得此名。我无欲心淫机巳息也。而欲境横陈在彼有心在我无味故如嚼腊则至淡也。越者超也。言在人中能有此行则径生此天不历下位故云越也。化地即此天。

六他化天

无世间心同世行事。於行事交了然超越。命终之后遍能出超化无化境。如是一类名他化自在天。

议曰。此欲界第六天也。无世间心同世行事故全无欲也。以未离世缘故云於行事交非言欲事。盖与妻妾相接而中心了无相干故云超越。若言犹与欲交则非此天之行也。俱舍云六受欲交抱。执手笑视淫。但目视而已。岂有交耶。化谓第五天。无化谓下四天。超者谓由人中径生此天也。此天受用乃他所变化故云他化自在。

二总结当界得名

阿难。如是六天形虽出动心迹尚交。自此已还名为欲界。

议曰。此结欲界天名也。人趣欲秽杂乱心多动摇。而天已离人故云出。言心迹尚交者盖约六天通相而言也。其实粗细不同非可例观也。以未出欲故通名欲界。

上欲界六天竟

大佛顶首楞严经通议卷第八


通议卷第九

通议卷第九

大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第九

唐天竺沙门般剌密帝译
乌苌国沙门弥伽释迦译语
菩萨戒弟子清河房融笔受
明南岳沙门憨山释德清述

二色界四禅天分二

初列示当界因果之相分四

初禅三天分二

初列示其相分三初梵众天

阿难。世间一切所修心人不假禅那无有智慧。但能执身不行淫欲。若行若坐想念俱无。爱染不生无留欲界。是人应念身为梵侣。如是一类名梵众天。

议曰。此下色界四禅十八梵天也。梵者净也。以此诸天不知真修无漏。但修欣厌禅。谓厌下苦粗障。欣上净妙离名欣厌定。以为正因。此经专依断淫而为次第。未得真修故云不假禅那无有智慧。但能执身不行淫欲而已。若淫心不动於一切时。想念俱无。爱染不生。谓不起爱心。已伏欲界惑故无留欲界。身为梵侣名梵众天。此梵民也

二梵辅天

欲习既除离欲心现。於诸律仪爱乐随顺。是人应时能行梵德。如是一类名梵辅天

议曰。此初禅第二天也。爱染已断故云欲习既除。初禅定心显现故云虽欲心现。此结上行也。於定共戒爱乐随顺防护不失净戒成就。能辅梵主名梵辅天。此梵臣也。此上二天修禅尚有寻伺

三大梵天

身心妙圆威仪不缺。清净禁戒加以明悟。是人应时能统梵众为大梵王。如是一类名大梵天

议曰。此初禅第三天也。禅观转胜受生微妙故云妙圆。戒德已成故云威仪不缺。结上行也。定能发慧故云加以明悟。此则慧解超胜。故能统众而为梵王。俱舍云。威德光明独一而住。无寻无伺定力所感。劫成先来。外道不知遂执为常。谓能生人为世间主

三结示当天得名

阿难。此三胜流一切苦恼所不能逼。虽非正修真三摩地。清净心中诸漏不动。名为初禅

议曰。此结德立初禅名也。已离欲界八苦故云苦不能逼。以欣厌伏惑故云非真三昧。已离欲染故心清净。已离欲散粗动故云诸漏不动。初禅论名离生喜乐地。初禅有五支谓觉观喜乐一心。以初心入禅名觉。细心分别禅味名观。欣庆心生名喜。忻悦心生名乐。心与定一名一心。已离欲界杂恶心得轻安。此初禅行相他

二二禅三天分二 初列示其相界三

初少光天

阿难。其次梵天统摄梵人圆满梵行。澄心不动寂湛生光。如是一类名少光天

议曰。此二禅初天也。此天主梵故云统摄。具戒定慧故云圆满梵行。结上行也。此天定心增明故云澄心不动。定光发越故云寂湛生光。此天已离觉观无有语言。但以定心发光以光胜劣分位次。喜相初生慧光初发放名少光

二无量光天

光光相然照耀无尽。映十方界遍成琉璃。如是一类名无量光天

议曰。此二禅第二天也。从前少光心光渐胜故云光光相然。以境随光净遍成琉璃。光随定遍名无量光

三光音天

吸持圆光明就教体。发化清净应用无尽。如是一类名光音天

议曰此二禅第三天也。此天已离语言。光能说法。故云吸持圆光以为教体。但见光明心即了悟宣流净行故云发化清净。随机开演故云应用无尽。以二禅无前五识。但用光明而为表诠。以光为音名光音天

二结示当天得名

阿难。此三胜流一切忧悬所不能遍。虽非正修真三摩地。清净心中粗漏已伏名为二禅

议曰。此结德二禅天名也。已超欲界故云胜流。极喜调适名定生喜乐地。故一切忧悬所不能逼。虽非真修离欲心中欲染粗漏至此已伏名为二禅。此天有四支。谓内净喜乐一心。以心无觉观之浑浊故云内净。忻心自庆名喜。恬然静虑名乐澄心。不动名一心

三三禅三天分二 初列示其相分三

初少净天

阿难。如是天人圆光成音披音露妙发成精行通寂灭乐。是一类名少净天

议曰。此三禅初天也。圆光成音乃前天行相也。以光为教体表诠妙理。今披光音显发微妙故云露妙。以所显理发为妙行故云发成精行。灭前喜相而生妙乐故云通寂灭乐。初入此定故名为通始。得此乐故名少净

二无量净天

净空现前引发无际。身心轻安成寂灭乐。如是一类名无量净天。

议曰。此三禅第二天也。离诸喜动不著乐相。故云净空现前。乐随定遍故云引发无际。彻意地乐故云成寂灭乐。名无量净天

三遍净天

世界身心一切圆净。净德成就。胜托现前归寂灭乐。如是一类名遍净天

议曰。此三禅第三天也。前虽彻意地乐止在身心。未名为遍。今则遍於依正世界身心无处不遍故云一切圆净。殊胜妙乐以成净德故云净德成就。即此妙乐是所托处已证此乐故云归寂灭乐。名遍净天。

二结示当天得名

阿难。此三胜流具大随顺。身心安隐得无量乐。虽非正得真三摩地。安隐心中欢喜毕具名为三禅。

议曰。此结德三禅名也。已离忧喜随顺胜定故云具大随顺得无量乐随顺自在。乐极於此纯一无杂故名毕具。故此三禅名离喜妙乐地。此有五支。谓舍念慧乐一心。舍二禅之喜名舍。爱念三禅名念。善巧解慧名慧。爱乐安快名乐。爱乐心息名一心。

四四禅九天分二

初列示当界因果之相分二

初当界凡夫四天分二 初列相分二

初凡夫天分三 初福生天

阿难。复次天人不逼身心苦因已尽。乐非常住久必坏生。苦乐二心俱时顿舍。粗重相灭净福性生。如是一类名福生天

议曰。此四禅共有九天。今初天也。然此地本唯三天。於广果中别开无想名外道天。其五不还天乃三果圣流所居又是一类。故有九天而分三种。其福生等三乃凡夫所感实报天也。复次下五句别前生后也。俱舍论说第四禅离八灾患者谓寻伺苦乐忧喜及出入息为八患也。又不为三灾所动故云不动地。今云不逼即离前位苦也。苦因下释不逼之所以。谓寻伺忧喜等是苦之因。今既离之故无逼迫。乐非常住者即明乐支。前第三禅虽得彻意地乐。乐必有坏故非常住。坏即成苦故云苦生。苦乐下正明此天苦乐俱舍以一一地皆云厌下苦粗障。欣上妙净离。厌下苦乐故云粗重相灭。欣上妙定故云净福性生。以离下染故云净福

二福爱天

舍心圆融。胜解清净。福无遮中得妙随顺穷未来际。如是一类名福爱天

议曰。此四禅第二天也。以舍诸苦乐等法唯一舍心与定心圆融。於舍心中决定忍可。不为异缘引转。故云胜解清净。由胜解力於圆融定中爱乐随顺得无留碍受用无穷。故云得妙随顺穷未来际。问此有漏禅寿命有限何得穷未来际耶。答此约得定寿报长远动经劫数言穷未来。非真无尽未来也。

三广果天

阿难。从是天中有二岐路。若於先心无量净光福德圆明修证而住。如是一类名广果天。

议曰。此四禅第三天也。於福爱天中分二岐路。一直往道即至广果。二迂曲道即至无想。此标也。若於下释相。若从发心以来不带异计。直修根本四禅。离前地染。故云无量净光。备历四位。至此福爱更增胜定。故云福德圆明广德所感名广果天。

次无想外道一天

若於先心双厌苦乐。精研舍心相续不断。圆穷舍道身心俱灭。心虑灰凝经五百劫。是人既以生灭为因不能发明不生灭性。初半劫灭后半劫生。如是一类名无想天。

议曰。此四禅第四无想天也。从福爱分出乃外道天。以修四禅带有异计故感报此天。由前欣厌不已故云精研舍心相续不断。至福爱天遍穷舍道故云圆穷。舍心即亡身心亦泯故云俱灭。计此无想为涅盘也。心虑下无想报也。无想天寿五百大劫。想心不行故云灰凝。是人下判成虚妄也。谓此天人初由不了不生灭心。唯以欣厌劳累是以生灭为因也。但见六识暂而不行如冰夹鱼。不知微细生灭妄谓涅盘。故云不能发明无生灭性。初半劫下释彼报行相。准俱舍引婆沙论释彼生死位中多劫有想。初生此天经於半劫始入无想异熟名初半劫灭。至无常时从异熟出最后半劫复有心生后始方死名後半劫生。中间一向无想名无想天。

次结名

阿难。此四胜流一切世间诸苦乐境所不能动。虽非无为真不动地。有所得心功用纯熟名为四禅

议曰。此结德四禅四天名也。此天离八灾患胜前地故名不动地。以有劫数寿尽还舍故云非真不动。俱舍云。然彼器非常。情俱生灭。凡夫修定味着受生名有所得。以定慧均等能舍苦乐名功用纯熟。前三乃实报凡夫。此名外道天。

次凡圣同居五天分三初总标因果总相

阿难。此中复有五不还天。於下界中九品习气俱时灭尽。苦乐双亡下无卜居。故於舍心众同分中安立居处。

议曰。此标五不还天也。此五天乃三果圣人所居不同凡外。故别列之。亦名五净居亦名五不还天。言下界等者二乘断三界九地思惑九九八十一品成阿罗汉。今那含乃三果人已断三禅已下四地各九品惑。种现俱无名为灭尽。离欲界系故亡苦。离下三禅故亡乐。已不续生故下无卜居。此地名舍念清净。故舍心同分中安立居处。

二列示因果别相分五 初无烦天

阿难。苦乐两灭斗心不交。如是一类名无烦天

二无热天

机括独行研交无地。如是一类名无热天

议曰。此不还五天中初二名也。前虽苦乐两亡而欣厌尚存待心未泯。今已对待故云斗心不交。以有对待觉识烦动。无对待则无烦矣。微烦曰热。唯一舍心故云独行。对境亦泯故云研交无地。定障既寂心得清凉故云无热。

三善见天

十方世界妙见圆澄。更无尘象一切沈垢。如是一类名善见天。

四善现天

清见现前陶铸无碍。如是一类名善现天。

议曰。此五不还天中三四天也。定慧圆明故云妙见圆澄。定慧障亡更无尘象沈垢。舍心圆明。故名善见。定慧功成故云精见现前。陶熔习气不为留碍故云陶铸无碍名善现天

五色究竟天

究竟群几穷色性性入无边际。如是一类名色究竟天。

议曰。此五不还天中第五天也。穷究至极故云究竟。色极微故云群几。色性性色之体也。色以空为体。穷至色边际即入虚空故云入无边际。以究尽色际名色究竟天。

三结叹胜能

阿难。此不还天。彼诸四禅四位天王独有钦闻不能知见。如今世间旷野深山圣道场地皆阿罗汉所住持故。世间粗人所不能见。

次总结当界得名

阿难。是十八天。独行无交。未尽形累。自此已还名为色界。

议曰。此结四禅天名也。梵语那含此云不还。以是圣人所居。无漏定力殊胜。故四禅天王有漏凡夫所不能见。此十八天超越欲染一味定心故云独行无交。尚有色碍故云未尽形累

三无色界四天分二

初总示当界圣凡因果之相分二

初列示分二 初寄显界外因果

复次阿难。从是有顶色边际中其间复有二种岐路。若於舍心发明智慧。慧光圆通便出尘界。成阿罗汉入菩萨乘。如是一类名为回心大阿罗汉。

议曰。此标无色界从色界顶色究竟中分二岐路也。一回心罗汉即出界外。二不回心者即入空处。以四禅通修舍定。若於舍心发无漏智顿断上地三十六品俱生烦恼便证无学。仍又回心向大乘道即不入空处名大阿罗汉。盖依色顶而修此定者也。

二正示界内因果分四初空处

若在舍心舍厌成就。觉身为碍销碍入空。如是一类名为空处。

议曰。此标无色初天也。此四天人无业果色有定果色依正皆然。此乃定性声闻与无想外道而来杂处。皆无色蕴故名无色界。皆依遍空修道。初厌色依空。二厌空依识。三色空识等都灭而依识性。四依识性以灭研穷而不得真灭。是皆未出轮回不成圣道者也。前依舍心舍已成就。但有色碍故消碍入空。此厌色依空故名空处。

二识处

诸碍既销无碍无灭。其中唯留阿赖耶识。全於末那半分微细。如是一类名为识处。

议曰。此四空第二天乃厌空依识者也。诸碍既销蹑前空处也。无碍下名破空入识也。销碍入无则不依色。无碍之无亦灭故不依空唯观於识。故唯留赖耶。以末那为意根依内外门转缘色空识三。今六识已灭故不缘色空。内缘八识见分为我故半分微细。舍空依识名为识处。

三无所有处

空色既亡识心都灭。十方寂然迥无攸往。如是一类名无所有处

议曰。此四空第三天也。前天虽亡空色而存识心尚为所有。今识心亦灭但依识性故十方寂然迥无所有。名无所有处。以识性幽绵。行人至此以为极则。非真究竟。实生死本也。

四非非想处

识性不动以灭穷研。於无尽中发宣尽性。如存不存。若尽非尽。如是一类名为非想非非想处。

议曰。此四空第四天也。前未见识性尚有研穷。今识性不动故灭研穷。依湛不摇处以为究竟。故云於无尽中发宣尽性。识性现前故如存。见相已泯故不存。前七已消故若尽。无明未破故非尽。以不存若尽故非想。以如存非尽故非非想也。

次结属分四 初结属界外圣人

此等穷空不尽空理。从不还天圣道穷者如是一类名不回心钝阿罗汉。

二结属界内外道

若从无想诸外道天穷空不归。迷漏无闻便入轮转。

议曰。此总结名四空非真修也。此等天人虽欲穷空但依欣厌未尽真空之理妄有取舍故非真修。以此四天行人皆从色界五不还天并无想天而来。若从不还不能顿断上惑未出三界。仍依无漏智断消碍入空而生此天者名不回心钝根那含。通称罗汉也。若无想外道与广果天人能穷空者则来生此天。若穷空不能销碍是迷於有漏无所见闻於彼不来便入轮转矣。不归不来也。旧引经论释无想外道业尽必堕是不来义也。

三结属实报凡夫

阿难。是诸天上各各天人则是凡夫业果酬答。答尽入轮。

四结属寄位菩萨

彼之天王即是菩萨游三摩提。渐次增进回向圣伦所修行路

议曰。此结显圣凡之别也。其诸天天人皆凡夫业果酬答。报尽必坠。若诸天之王皆菩萨寄位游戏。出入诸禅三昧。增进圣位。以入菩提路也。

二别结当界得名

阿难。是四空天身心灭尽。定性现前无业果色。从此逮终名无色界。

议曰。此结无色界也。此四空处色蕴既消妄想已灭故云身心灭尽。有定果色名定性现前。无业果色名无色界。

次总结三界之因

此皆不了妙觉明心。积妄发生妄有三界。中间妄随七趣沈溺。补特伽罗各从其类。

议曰。此略结三界虚妄也。谓欲界已上由昔人中修因感果。但不了妙觉明心。虽欲修因其实积妄发生妄有三界之相。未得真修。报尽入轮。故妄随七趣沈溺。永在生死。故云补特伽罗各从其类。梵语补特伽罗此云数取趣 上明天趣竟

七示阿修罗道因果之相分二 初标名

复次阿难。是三界中复有四种阿修罗类。

次辩相分四 初卵生鬼趣摄

若於鬼道以护法力乘通入空。此阿修罗从卵而生鬼趣所摄。

二胎生人趣摄

若於天中降德贬坠。其所卜居邻於日月。此阿修罗从胎而出人趣所摄。

三化生天趣摄

有修罗王执持世界。力洞无畏能与梵王及天帝释四天争权。此阿修罗因变化有天趣所摄。

四湿生畜趣摄

阿难。别有一分下劣修罗。生大海心沈水穴口。旦游虚空。暮归水宿。此阿修罗因湿气有畜生趣摄。

议曰。此阿修罗道也。旧说非天。谓有天名而无天德。嗔习然也。判属天趣。今经属於四生非独天也。此言鬼趣所摄云从卵生未详所以。其与天争权。华严云与帝释战。今云与梵王等。且上界无嗔。梵天无欲。何争之有。此亦未详。畜生趣摄者业报类也。

次总结虚妄

阿难。如是地狱饿鬼畜生人及神仙天洎修罗。精研七趣皆是昏沈诸有为相。妄想受生。妄想随业。于妙圆明无作本心皆如空华元无所着。但一虚妄更无根绪。

议曰。此总结七趣之状以答问义也。七趣皆从无明发业所感故云昏沈诸有为相。生因业果皆由妄想。於妙明中本无所有。如空中华更无根绪。

二结示迷悟因依分二 初迷时妄有

阿难。此等众生不识本心受此轮回经无量劫不得真净。皆由随顺杀盗淫故。反此三种又则生出无杀盗淫。有名鬼伦无名天趣。有无相倾超轮回性。

二悟后元空

若得妙发三摩提者则妙常寂。有无二无。无二亦灭。尚无不杀不偷不淫云何更随杀盗淫事。

议曰。此结三界转变之相。不识本心等妄想受生也。随顺杀盗淫等妄想随业也。业因苦果有无相倾起轮回性。所谓迷时三界有也。若得妙发三摩提等返妄归真也。以不识故沈生死。若妙发三昧妙悟一心顿证三德秘藏。妙常寂顺次配般若法身解脱三德一心之圆证也。有无二无则非生死。无二亦灭则非涅盘。此则妄因亦绝妄业顿空。非此不足以绝轮回也。

三结答问意

阿难。不断三业各各有私。因各各私。众私同分非无定处。自妄发生。生妄无因无可寻究。

议曰。此结答问意也。由前问云。为有定处。为复自然。彼彼发业各各私受。故此结云。以不断杀盗淫三业随人别造故云各各有私。别业同受故非无定处。妄元无因故无可寻究。

四识勖真修

汝勖修行欲得菩提要除三惑。不尽三惑纵得神通皆是世间有为功用。习气不灭落於魔道。虽欲除妄倍加虚伪。如来说为可哀怜者。汝妄自造非菩提咎。

五结指正说

作是说者名为正说。若他说者即魔王说。

议曰。此结劝修也。前云三缘断故三因不生。则汝心中狂性自歇。歇即菩提故云要除三惑等。言要必断乃为真修也。由前问云此道为复本来自有为是众生妄习生起。故此结云汝妄自造非菩提咎。

上精研七趣曲示迷中差别之相竟

二详辩阴魔曲示悟中差别之相分二

初示五阴魔事分十二 初世尊无问自说

即时如来将罢法座。於师子床揽七宝几。回紫金山再来凭倚。普告大众及阿难言。

议曰。此叙致下详辩阴魔以示悟中差别之相也。由初云诸修行人不能得成无上菩提乃至别成声闻缘觉及成外道诸天魔王及魔眷属。皆由不知二种根本错乱修习。故一往开示真修行法即以楞严大定通为五十五位真菩提路。乃显正悟。而定中邪习邪悟犹未发明。故判前七趣以明妄想是一而有七趣升沈之状者特显迷中差别之相也。今此定中而有五十重阴魔者正显悟中差别之相也。前说定用直示真修而三乘人未经邪悟故非所知。此是如来备历境界。且微细魔事非一切智不能明了。亦无能问者。故无问自说。已前开示迷悟因果已圆。故将罢法座。有此未尽之意。故再凭宝几普告大众。此最上深慈为最后教诲也。

二略示魔事因缘

汝等有学缘觉声闻。今日回心趣大菩提无上妙觉。我今已说真修行法。汝犹未识修奢摩他毗婆舍那微细魔事。魔境现前汝不能识。洗心非正落於邪见。或汝阴魔。或复天魔。或着鬼神。或遭魑魅。心中不明认贼为子。又复于中得少为足。如第四禅无闻比丘妄言证圣。天报已毕衰相现前。谤阿罗汉身遭后有。堕阿鼻狱。汝应谛听。吾今为汝子细分别。阿难起立。并其会中同有学者。欢喜顶礼伏听慈诲。

议曰。此略示魔事因缘也。诸三乘人回心趣菩提者如前已说真修行法矣。但禅定中微细魔事汝犹未识。故须详办以防邪悟也。若不说破恐魔境现前心中不明错认为真。如无闻比丘妄证谤法自取地狱。故不得不为子细分别耳。

三示迷悟之本

佛告阿难及诸大众。汝等当知有漏世界十二类生。本觉妙明觉圆心体。与十方佛无二无别。由汝妄想迷理为咎。痴爱发生。生发遍迷故有空性。化迷不息有世界生。则此十方微尘国土非无漏者。皆是迷顽妄想安立。当知虚空生汝心内犹如片云点太清里。况诸世界在虚空耶。汝等一人发真归元。此十方空皆悉销殒。云何空中所有国土而不振裂。

议曰。将明动魔之由先示一真为迷悟之本也。—真法界心佛众生三无差别。迷悟转变不出此心。虚空世界依之而立。心本妙明良由一念无明妄想迷真背理故痴爱发生。此言无明通为四惑之本也。生相既发则全体皆迷故云遍迷。空性依无明所变所谓迷妄有虚空也。妄迷转变而不已故云化迷不息有世界生。所谓结暗为色依空立世界。是则十方国土皆依妄想安立也。真心至大。故虚空生於妙心如片云点於太清眇乎小矣。况空中之世界岂不至微哉。今行人发真归元无明一破则虚空消殒而空中国土无不振裂。魔以暗昧为体世界为所依。今国土振裂而魔宫必隳。此实动魔之由也。

四示动魔之由

汝辈修禅饰三摩地。十方菩萨及诸无漏大阿罗汉心精通吻。当处湛然。一切魔王及与鬼神诸凡夫天见其官殿无故崩裂。大地振柝水陆飞腾无不惊摺（换忄旁）。凡夫昏暗不觉迁讹。彼等咸得五种神通唯除漏尽。恋此尘劳。如何令汝摧裂其处。是故鬼神及诸天魔魍魉妖精於三昧时咸来恼汝。

议曰。此言动魔致扰也。上云发真归元则虚空消殒。今修禅定乃归元之行也。菩萨罗汉与能修人心精通吻。谓妄想既破心境一如。无生体露故当处湛然。虚空消殒。而魔宫自振。此实动魔之由也。魔具五通有大神力。魔以害善得名恋此欲境岂肯甘心令汝破坏其处。是故於三昧中皆来恼汝。理必然也。

五示悟则胜邪

然彼诸魔虽有大怒彼尘劳内。汝妙觉中。如风吹光如刀断水。了不相触。汝如沸汤彼如坚冰暖气渐邻不日销殒。徒恃神力但为其客。成就破乱由汝心中五阴主人。主人若迷客得其便。当处禅那觉悟无惑。则彼魔事无奈汝何。阴销入明。则彼群邪咸受幽气。明能破暗近自销殒。如何敢留扰乱禅定。

六示迷则邪胜

若不明悟被阴所迷。则汝阿难必为魔子成就魔人。如摩登伽殊为眇劣。彼唯咒汝破佛律仪。八万行中只毁一戒。心清净故尚未沦溺。此乃隳汝宝觉全身。如宰臣家忽逢籍没。宛转零落无可哀救。

议曰。此言邪不胜正也。魔依幽暗。定心虚明。故如吹光割水。明暗二相了不相及故了不相触。明能破暗如汤消冰。是从外来故如客。邪不胜正故不能破坏。以汝心迷故彼得其便。但以禅那智照则魔自不容。定力愈坚则魔不能扰。以悟则胜邪。若汝阴自迷故成就魔事。以迷则邪胜。且如摩登绝为眇劣。彼假咒力犹但毁一戒。况魔有大神力断灭法身慧命破法王家。固宜深防无令得便也。

七正陈魔事分五 初色阴分三

初当阴未破

阿难当知。汝坐道场销落诸念。其念若尽则诸离念一切精明。动静不移。忆忘如一。当住此处入三摩提。如明目人处大幽暗。精性妙净心未发光。此则名为色阴区宇。若目明朗十方洞开无复幽黯名色阴尽。是人则能超越劫浊。观其所由坚固妄想以为其本。

议曰。此示五阴迷悟之相以辩魔境也。魔以幽暗为性。阴以覆蔽为义。由迷一真而成色心。五阴盖覆真心。是通以觉场而变为魔窟也。是故众生世界为魔所依。今若返妄归真必消此五阴身心以复一真之觉体。是由一心迷悟故魔佛於是乎辩。今以观照研穷五阴将破未破之间而阴境随心转变。以有积劫习气化为种种境界。所谓化迷不息也。以唯心所现故悟则无咎。以清净心中纤尘不立。一念才著便堕魔类矣。汝坐道场消落诸念等者。乃初入禅观照得力时也。当住此处入三摩地是直心正念为定本也。即於定中如明目人处暗正是色阴覆蔽之相。区局也。宇覆蔽也。若色阴尽则十方洞开无复幽暗矣。前劫浊依色阴而有。劫者时也。空为时初为色之体。色阴一破则三际顿空故能越劫浊。空晦暗中结暗为色。故坚固妄想以为色本。


通议卷第九

通议卷第九

二示定境差别向下十段

阿难。当在此中精研妙明四大不织。少选之间身能出碍。此名精明流溢前境。斯但功用暂得如是。非为圣证。不作圣心名善境界。若作圣解即受群邪。

议曰。此色阴将破而有十重境界也。即前离念精明之中以观精研妙明心体。所有妄想融涉四大故交织不散。今研心离色妄想不行。故四大不织。少选谓少时也。当此不织则四大各离故身不拘心即能出碍。但是精明流溢前境色阴实未破也。功用暂得如是耳。不作圣心则为功用善境。若作圣解即受魔气耳。

阿难。复以此心精研妙明其身内彻。是人忽然於其身内拾出蛲蛔。身相宛然亦无伤毁。此名精明流溢形体。斯但精行暂得如是。非为圣证。不作圣心名善境界。若作圣解即受群邪。

议曰。此色阴第二境界也。复以前观照精研心体。心光内彻四大虚融洞然不碍。故於身中拾出蛲蛔而身相不毁。色阴虽未及破而色质已虚。此特精明流溢形体。暂时功用非圣证也。

又以此心内外精研。其时魂魄意志精神除执受身馀皆涉入互为宾主。忽於空中闻说法声。或闻十方同敷密义。此名精魄递相离合成就善种。暂得如是非为圣证。不作圣心名善境界。若作圣解即受群邪。

议曰。此色阴第三境界也。阿赖耶识所执受四大之身。而在五脏各有所主。随得其名在肝曰魂在肺曰魄。在脾曰意。在肾曰志。在心曰精神。今以观照研穷四大虚融五脏亦化。魂魄无依故离身涉入互为宾主也。由夙闻熏种子因定激发遂托神魂现说法声也。此乃精魂递相离合非圣证也。

又以此心澄露皎彻。内光发明十方遍作阎浮檀色。一切种类化为如来。於时忽见毗卢遮那踞天光台千佛围绕百亿国土及与莲华俱时出现。此名心魂灵悟所染。心光研明照诸世界。暂得如是非为圣证。不作圣心名善境界。若作圣解即受群邪。

议曰。此色阴第四境界也。以前观心研穷身心皎彻色阴既融心光发明。故现境界。十方下所现之相。以多生闻薰圣教名言习气被定激发故。见世界金色化佛说法莲花等相以所染善种习气故云灵悟。以定力心光研穷明了照诸世界暂得如是非圣证也。

又以此心精研妙明观察不停。抑按降伏制止超越。於时忽然十方虚空成七宝色或百宝色。同时遍满不相留碍。青黄赤白各各纯现。此名抑按功力逾分。暂得如是非为圣证。不作圣心名善境界。若作圣解即受群邪。

议曰。此色阴第五境界也。又以前定心精研妙明心体观察不停。则忽然虚空成七宝色。色纯现者是谓宝觉明心。无明未尽被定激发故现斯相。此名功力逾分暂得如是。非圣证也。

又以此心研究澄彻精光不乱。忽於夜半在暗室内见种种物不殊白昼。而暗室物亦不除灭。此名心细密澄其见所视洞幽。暂得如是非为圣证。不作圣心名善境界。若作圣解即受群邪。

议曰。此色阴第六境界也。以前定心研究澄彻精心发光。从定中发故不动乱。於夜暗室见种种物。此非心光洞照。但是心细密澄其见故视能洞幽。非圣证也。

又以此心圆入虚融。四体忽然同於草木。火烧力斫曾无所觉。又则火光不能烧（热艹）。纵割其肉犹如削木。此名尘并排四大性一向入纯。暂得如是非为圣证。不作圣心名善境界。若作圣解即受群邪。

议曰。此色阴第七境界也。前以定心虚融四大。今以观心圆入虚融。又离於执受。故忽同草木无知。火烧刀割皆无所觉。此名排四大性纯入虚融。暂得如是非圣证也。

又以此心成就清净。净心功极。忽见大地十方山河皆成佛国。具足七宝光明遍满。又见恒沙诸佛如来遍满空界楼殿华丽。下见地狱上观天宫得无障碍。此名欣厌凝想日深想久化成。非为圣证。不作圣心名善境界。若作圣解即受群邪。

议曰。此色阴第八境界也。以前定心研穷欣厌习气内融故成就清净。内心既净。外器虚明成七宝色。诸佛遍满。地狱天宫一时俱见得无障碍。此名欣厌凝想日深随想化成。非圣证也。

又以此心研究深远。忽于中夜遥见远方市井街巷亲族眷属。或闻其语。此名迫心逼极飞出故多隔见。非为圣证。不作圣心名善境界。若作圣解即受群邪。

议曰。此色阴第九境界也。以前定心研为深远。以真心本遍向为色碍故不远见。今以定力精研。阴虽未破。而心能遥远见闻。亲戚眷属皆随习现。此名迫心逼极飞出故多隔见。非圣证也。

又以此心研究精极。见善知识形体变移。少选无端种种迁改。此名邪心含受魑魅。或遭天魔入其心腹无端说法通达妙义。非为圣证。不作圣心魔事销歇。苦作圣解即受群邪。

议曰。此色阴第十境界也。以前定心研究精极。由昔经邪师闻熏邪种。定研习变。故见善知识形体变幻。此由邪心含受邪魅。或天魔入心无端说法。非圣证也。以定力愈深故魔事益盛。故后四阴渐次深入理固然也。

三诫勖深防

阿难。如是十种禅那现境。皆是色阴用心交互故现斯事。众生顽迷不自忖量。逢此因缘迷不自识。谓言登圣。大妄语成堕无间狱。汝等当依如来灭后於末法中宣示斯义。无令天魔得其方便。保持覆护成无上道。

议曰。此结色阴将破十种禅那境界之相也。故总指云皆是色阴用心交互。若一念顿破根本无明五阴齐消则无此事。今次第研穷习气激发故云用心交互。若迷而不识便言证圣堕大妄语。今令宣示觉知魔事庶可保护成无上道也。

二受阴分三初当阴未破

阿难。彼善男子修三摩提。奢摩他中色阴尽者。见诸佛心如明镜中显现其像。若有所得而未能用。犹如魇人手足宛然见闻不惑。心触客邪而不能动。此则名为受阴区宇.

议曰。比示受阴未破之相也。色阴尽者四大已消无复留疑（疑可能为碍字之误－－录入者）。观心增明故诸佛心现于观照之中如镜现像。然佛心无相而见现像者乃观心所变缘影非真心也。此有所得而未能用者盖有含受之执故如魇人。是名受阴区宇也。

若魇咎歇其心离身返观其面。去住自由无复留碍名受阴尽。是人则能超越见浊。观其所由虚明妄想以为其本。

议曰。此预示受阴尽相也。受尽则无执受故心能离身。身在心中故退观己面。四大已消无可执受故无复留碍。见浊依受阴而有。以见有根身可爱领纳执取故为见浊。今受阴尽故能超之。以含受虚明之相故名虚明妄想。

二示定境差别向下十段

阿难彼善男子当在此中得大光耀其心发明。内抑过分忽於其处发无穷悲。如是乃至观见蚊虻犹如赤子。心生怜愍不觉流泪。此名功用抑摧过越。悟则无咎。非为圣证。见了不迷久自销歇。若作圣解则有悲魔入其心腑。见入则悲啼泣无限。失於正受当从伦坠。

议曰。此受阴第一境界也。以前观心研消色阴故其心发明。以见色消而用心太急内抑过分故发无穷悲。此乃宿有悲种。今被观力激发。故见蚊蚋。犹如赤子。此乃功用抑摧太过。非圣证也。不悟其非则有悲魔入心失正受矣。

阿难。又彼定中诸善男子见色阴销受阴明白。胜相现前感激过分忽於其中生无限勇。其心猛利志齐诸佛。谓三僧祗一念能越。此名功用陵率过越。悟则无咎非为圣证。觉了不迷久自销歇。若作圣解则有狂魔入其心腑。见人则夸我慢无比。其心乃至上不见佛下不见人。失於正受当从沦坠。

议曰。此受阴第二境界也。定中见色阴消则受阴明白。见此胜相遂感激心生。若感激过分则於定中生大勇猛志齐诸佛。自谓三祗一念能超此名功用陵率过越。陵谓陵蔑。率谓自强。非圣证也。不悟其非则狂魔入心生大我慢。

又彼定中诸善男子。见色阴销受阴明白。前无新证归失故居。智力衰微入中隳地回无所见。心中忽然生大枯渴。於一切时沈忆不散。将此以为勤精进相。此名修心无慧自失。悟则无咎。非为圣证。若作圣解则有忆魔入其心腑旦夕撮心悬在一处。失于正受当从伦坠。

议曰。此受阴第三境界也。受阴未尽故无新证。色阴已尽故归失故居。当进退两难之间智力衰微中道隳颓。心无所措故生大枯渴。则以沈忆为精进相。此名无慧自失非圣证也。不悟其非则忆魔入心心如悬撮失正受矣。

又彼定中诸善男子见色阴销受阴明白。慧力过定失於猛利。以诸胜性怀於心中。自心己疑是卢舍那。得少为足。此名用心忘失恒审溺於知见。悟则无咎非为圣证。若作圣解则有下劣易知足魔入其心腑。见人自言我得无上第一义谛。失於正受当从沦坠。

议曰。此受阴第四境界也。慧力过定失於猛利也。

以发胜性自心疑己是卢舍那。妄以为足更不前进。此名用心定少慧多故失恒审溺於知见。非圣证也。不悟其非则有下劣易知足魔入其心腑。自言已得第一义谛。故参禅须要定慧均等乃善用其心。

又彼定中诸善男子见色阴销受阴明白。新证未获。故心已亡。历览二际自生艰险。於心忽然生无尽忧。如坐铁床如饮毒药。心不欲活常求於人令害其命早取解脱。此名修行失於方便。悟则无咎。非为圣证。若作圣解则有一分常忧愁魔入其心腑。手执刀剑自割其肉欣其舍寿。或常忧愁。走入山林不耐见人。失於正受当从沦坠。

议曰。此受阴第五境界也。当色消受明二际之间已先前心未获新证。如履悬岩自生艰险。忧愁种子被定激发忽生忧恼欲早解脱。此名修行失於方便。非圣证也。不悟其非则有常忧愁魔入其心腑失正受矣。

又彼定中诸善男子。见色阴销受阴明白。处清净中心安隐后忽然自有无限喜生。心中欢悦不能自止。此名轻安无慧自禁。悟则无咎非为圣证。若作圣解则有一分好喜乐魔入其心腑。见人则笑。於衢路傍自歌自舞。自谓已得无碍解脱。失於正受当从沦坠。

议曰。此受阴第六境界也。定力研穷色消受明。故身心安隐忽生欢喜自不能止。此名轻安无慧自持。非圣证也。不悟其非则喜乐魔入其心腑。此慧少定多不均之过也。

又彼定中诸善男子。见色阴销受阴明白。自谓已足。忽有无端大我慢起。如是乃至慢与过慢及慢过慢或增上慢或卑劣慢一时俱发。心中尚轻十方如来何况下位声闻缘觉。此名见胜无慧自救。悟则无咎。非为圣证。若作圣解则有一分大我慢魔入其心腑。不礼塔庙。摧毁经像。谓檀越言此是金铜或是土木。经是树叶或是毡华。肉身真常不自恭敬却崇土木实为颠倒。其深信者从其毁碎埋弃地中。疑惑众生入无间狱。失於正受当从沦坠。

议曰。此受阴第七境界也。色消受明定力研穷激发慢习故起诸慢。谓恃己陵他高举为性通称我慢。其慢有七称量自他比校同德但称为慢。谓己独胜名过慢。於胜争胜名慢过慢。未得谓得名增上慢。虽知卑劣返顾自矜名卑劣慢。斥毁经像名邪慢。总由慢习而发也。故轻佛如来。此名见胜无慧自救。非圣证也。不悟其非则有大我慢魔入其又彼定中诸善男子。见色阴销受阴明白。于精明中圆悟清理。得大随顺。其心忽生无量轻安。己言成圣得大自在。此名因慧获诸轻清。悟则无咎。非为圣证。若作圣解则有一分好轻清魔入其心腑。自谓满足更不求进。此等多作无闻比丘。疑误众生堕阿鼻狱。失於正受当从沦坠。

议曰。此受阴第八境界也。以定研穷受阴虚薄定心精明。於此定中圆悟精理。理随观显受不能障故云得大随顺。身心调畅故忽生轻安。将谓成圣得大自在。此名因慧获诸轻清。非圣证也。不悟其非则有好轻清魔入其心腑。自谓满足更不求进。无闻比丘谓无多闻慧不达禅支妄生止足者也。

又彼定中诸善男子。见色阴销受阴明白。于明悟中得虚明性其中忽然归向永灭。拨无因果一向入空。空心现前乃至心生长断灭解。悟则无咎非为圣证。若作圣解则有空魔入其心腑。乃谤持戒名为小乘。菩萨悟空有何持犯。其人当于信心檀越饮酒啖肉广行淫秽。因魔力故摄其前人不生疑谤。鬼心久入或食屎尿与酒肉等一种俱空。破佛律仪误入人罪。失於正受当从沦坠。

议曰。此受阴第九境界也。因前定力空慧现前。受阴将尽。得大明悟。忽起空见故归向永灭。拨无因果。遂生长断灭见。非圣证也。不悟其非则有空魔入其心腑。遂谤持戒破佛律仪。以由定力内激邪见外引空魔失於正受。

又彼定中诸善男子。见色阴销受阴明白。味其虚明深入心骨。其心忽有无限爱生。爱极发狂便为贪欲。此名定境安顺入心。无慧自持误入诸欲。悟则无咎非为圣证。若作圣解则有欲魔入其心腑。一向说欲为菩提道。化诸白衣平等行欲。其行淫者名持法子。神鬼力故於末世中摄其凡愚其数至百。如是乃至一百二百或五六百多满千万。魔心生厌离其身体。威德既无陷於王难。疑误众生入无间狱。失於正受当从沦坠。

议曰此受阴第十境界也。受阴将尽内外虚明。以此虚明将为胜境。贪著生爱深入心骨。爱极发狂便为贪欲者以定力激发贪习种子因而发狂。此名定境安顺入心。以无慧照破遂误入诸欲非圣证也。不悟其非则有欲魔入心。欲鬼所摄广行淫欲。及魔厌遭难必从沦坠

三诫勖深防

阿难。如是十种禅那现境皆是受阴用心交互故现斯事。众生顽迷不自忖量。逢此因缘迷不自识谓言登圣。大妄语成堕无间狱。汝等亦当将如来语於我灭后传示末法。遍令众生开悟斯义。无令天魔得其方便。保持覆护成无上道。

议曰。此诫勖深防也。以定力精严无明未尽习随定现故变现斯事。理智未分故云用心交互。迷而不识则堕大妄语。诫令将如来语宣示末法诸修禅者早悟其相。勿令天魔得其便也。

三想阴分三 初当阴未破

阿难。彼善男子修三摩提受阴尽者。虽未漏尽心离其形如鸟出笼。已能成就。从是凡身上历菩萨六十圣位。得意生身随往无碍。譬如有人熟寐呓言。是人虽则无别所知其言已成音韵伦次。令不寐者咸悟其语。此则名为想阴区宇。

议曰。此言受尽想现之相也。色受二阴既破。则心无留碍。如鸟出笼。从是凡身上历菩萨六十圣位者。如乾慧地欲爱乾枯根境不偶则能从是安立圣位。虽后三阴未破而色受已尽离欲界系无明虽在圣位可历也。言六十者连三渐次至妙觉也。得意生身如罗汉山壁由之直度。如意速疾故云无碍。非地上三种意生身也。以想阴未破故如人熟寐呓语。以悟明圆理但未实证故如言已成音。今参禅少有开悟未得大彻。故但知解禅。闻者虽悟。而己实未了。以落忆想窠臼。乃想阴未破。正此类也。

若动念尽浮想销除。於觉明心如去尘垢。一伦生死首尾圆照名想阴尽。是人则能超烦恼浊。观其所由融通妄想以为其本。

议曰。此预示想阴尽相也。想相为尘识情为垢故 想消如去尘垢。想消行现故一伦生死首尾圆照。以烦恼浊依想阴而有。由妄想浊乱故想阴消则超烦恼浊。以想能融通心生形取故云融通妄想。

二示定境差别向下十段

阿难。彼善男子受阴虚妙不遭邪虑圆定发明。三摩地中心爱圆明。锐其精思贪求善巧。尔时天魔候得其便飞精附人口说经法。其人不觉是其魔著自言谓得无上涅盘。来彼求巧善男子处敷座说法。其形斯须或作比丘令彼人见。或为帝释或为妇女或比丘尼。或寝暗室身有光明。是人愚迷惑为菩萨信其教化摇荡其心。破佛律仪潜行贪欲。口中好言灾祥变异。或言如来某处出世。或言劫火或说刀兵恐怖於人。令其家资无故耗散。此名怪鬼年老成魔恼乱是人。厌足心生去彼人体。弟子与师俱陷王难。汝当先觉不入轮回。迷惑不知堕无间狱。

议曰。此想阴第一境界也。受阴已尽故不遭邪虑。谓已离前十种境界。故定力圆明激发贪习。心爱圆明故云求巧。乃精锐其思贪求善巧。内心既著故外魔得便而飞精先附他人来求巧人前说法现种种相。求巧之人信为菩萨。口中好言者乃所说之事也。此怪鬼本于贪习。因而附入去则留难。觉则无咎。

阿难。又善男子受阴虚妙不遭邪虑圆定发明。三摩地中心爱游荡。飞其精思贪术经历。尔时天魔候得其便飞精附人口说经法。其人亦不觉知魔著亦言自得无上涅盘。来彼求游善男子处敷座说法。目形无变。其听法者忽自见身坐宝莲华。全体化成紫金光聚。一众听人各各如是得未曾有。是人愚迷惑为菩萨。淫逸其心破佛律仪潜行贪欲。口中好言诸佛应世。某处某人当是某佛化身来此。某人即是某菩萨等来化人间。其人见故心生倾渴。邪见密兴种智消灭。此名魃鬼年老成魔恼乱是人。厌足心生去彼人体。弟子与师俱陷王难。汝当先觉不入轮回。迷惑不知堕无间狱.

议曰。此想阴第二境界也。定力研穷激发淫习。以淫心浩荡动乱身心故贪求经历好行游荡。故魃鬼本於淫习因而附人成就破坏也.

又善男子受阴虚妙不遭邪虑圆定发明。三摩地中心爱绵吻。澄其精思贪求契合。尔时天魔候得其便飞精附人口说经法。其人实不觉知魔著亦言自得无上涅盘。来彼求合善男子处敷座说法。其形及彼听法之人外无迁变。令其听者未闻法前心自开悟。念念移易或得宿命或有他心或见地狱或知人间好恶诸事。或口说偈或自诵经。各各欢娱得未曾有。是人愚迷。惑为菩萨。绵爱其心破佛律仪潜行贪欲。口中好言佛有大小。某佛先佛某佛后佛其中亦有真佛假佛男佛女佛。菩萨亦然。其人见故洗涤本心易入邪悟。此名魅鬼年老成魔恼乱是人。厌足心生

去彼人体。弟子与师俱陷王难。汝当先觉不入轮回。迷惑不知堕无间狱。

议曰。此想阴第三境界也。定力研穷激发诈习故心爱绵吻贪求契合。以诈伪欺人而欲求合。故魅鬼本於诈习。今年老成魔破坏定心。

又善男子受阴虚妙不遭邪虑圆定发明。三摩地中心爱根本穷览物化性之终始。精爽其心贪求辨析。尔时天魔候得其便飞精附人口说经法。其人先不觉知魔著亦言自得无上涅盘。来彼求元善男子处敷座说法。身有威神推伏求者。令其座下虽未闻法自然心伏。是诸人等将佛涅盘菩提法身即是现前我肉身上。父父子子递代相生即是法身常住不绝。都指现在即为佛国。无别净居及金色相。其人信受亡失先心身命归依得未曾有。是等患迷惑为菩萨。推究其心破佛律仪潜行贪欲。口中好言眼耳鼻舌皆为净土。男女二根即是菩提涅盘真处。彼无知者信是秽言。此名蛊毒魇胜恶鬼年老成魔恼乱是人。厌足心生去彼人体。弟子与师俱陷王难。汝当先觉不入轮回。迷惑不知堕无间狱。

议曰。此想阴第四境界也。定力研穷想阴渐消行阴将现。故定中爱穷根本物化始终贪求辨析。蛊毒恶鬼本乎怨习。以怨本深求。今附人坏定。盖有因也。

又善男子受阴虚妙不遭邪虑圆定发明。三摩地中心爱悬应。周流精研贪求冥感。尔时天魔候得其便飞精附人口说经法。其人元不觉知魔著亦言自得无上涅盘。来彼求应善男子处敷座说法。能令听众暂见其身如百千岁。心生爱染不能舍离。身为奴仆四事供养不觉疲劳。各各令其座下人心知是先师本善知识。别生法爱黏如胶漆得未曾有。是人愚迷惑为菩萨。亲近其心破佛律仪潜行贪欲。口中好言我于前世於某生中先度某人。当是我妻妾兄弟今来相度。与汝相随归某世界供养某佛。或言别有大光明天佛於中住。一切如来所休居地。彼无知者信是虚诳遗失本心。此名厉鬼年老成魔恼乱是人。厌足心生去彼人体。弟子与师俱陷王难。汝当先觉不入轮回。迷惑不知堕无间狱。

议曰。此想阴第五境界也。以圆定发明遂生悬应之心。故贪求冥感引魔入心。厉鬼本於嗔习。虽与定境不类附必有由。

又善男子受阴虚妙不遭邪虑圆定发明。三摩地中心爱深入。克己辛勤乐处阴寂贪求静谧。尔时天魔候得其便飞精附人口说经法。其人本不觉知魔著亦言自得无上涅盘。来彼求阴善男子处敷座说法。令其听人各知本业。或於其处语一人言汝今未死已作畜生。敕使一人於后蹋尾顿令其人起不能得。於是一众倾心钦伏。有人起心已知其肇。佛律仪外重加精苦。诽谤比丘骂詈徒众。讦露人事不避讥嫌。口中好言未然祸福。及至其时毫发无失。此大力鬼年老成魔恼乱是人。厌足心生去彼人体。弟子与师俱陷王难。汝当先觉不入轮回。迷惑不知堕无间狱

议曰。此想阴第六境界也。以定力渐深故心爱深入。想阴烦动。今想渐消故乐处阴寂贪求静谧。谧深静也。内兴邪念则外魔潜兴故乘便附人。言大力鬼即饿鬼也。本於慢习。

又善男子受阴虚妙不遭邪虑圆定发明。三摩地中心爱知见。勤苦研寻贪求宿命。尔时天魔候得其便飞精附人口说经法。其人殊不觉知魔著亦言自得无上涅盘。来彼求知善男子处敷座说法。是人无端于说法处得大宝珠。其魔或时化为畜生口衔其珠及杂珍宝简册符牍诸奇异物。先授彼人后著其体。或诱听人藏於地下有明月珠照耀其处。是诸听者得未曾有。多食药草不餐嘉馔。或时日餐一麻一麦。其形肥充魔力持故。诽谤比丘骂詈徒众不避讥嫌。口中好言他方宝藏十方圣贤潜匿之处。随其后者往往见有奇异之人。此名山林土地城隍川岳鬼神年老成魔。或有宣淫破佛戒律与承事者潜行五欲。或有精进纯食草木。无定行事恼乱是人。厌足心生去彼人体。弟子与师多陷王难。汝当先觉不入轮回。迷惑不知堕无间狱。

议曰。此想阴第七境界也。以定中忽起一念好知见心贪求宿命故魔得其便。是皆妄有希求忘失正行故招魔扰。所谓忘失菩提心而修诸善根是谓魔业皆此类也。山林等神本於诳习。继幽成形名为魇鬼。

又善男子受阴虚妙不遭邪虑圆定发明。三摩地中心爱神通种种变化。研究化元贪取神力。尔时天魔候得其便飞精附人口说经法。其人诚不觉知魔著亦言自得无上涅盘。来彼求通善男子处敷座说法。是人或复手执火光。手撮其光分于所听四众头上。是诸听人顶上火光皆长数尺。亦无热性曾不焚烧。或水上行如履平地。或於空中安坐不动。或入瓶内。或处囊中。越牖透垣曾无障碍。唯於刀兵不得自在。自言是佛。身著白衣受比丘礼。诽谤禅律。惊詈徒众。

讦露人事不避讥嫌。口中常说神通自在。或复令人旁见佛土。鬼力惑人非有真实。赞叹行淫不毁粗行。将诸猥亵以为传法。此名天地大力山精海精风精河精土精一切草木积劫精魅。或复龙魅。或寿终仙再活为魅。或仙期终计年应死其形不化他怪所附。年老成魔恼乱是人。厌足心生去彼人体。弟子与师多陷王难。汝当先觉不入轮回。迷惑不知堕无间狱。

议曰。此想阴第八境界也。以定中忽起爱神通心贪取神力故魔乘便附人以成破坏。因爱神通故现神通之事。山精等本於见习。乃遇精成形名魍魉鬼。

又善男子受阴虚妙不遭邪虑圆定发明。三摩地中心爱入灭。研究化生贪求深空。尔时天魔候得其便飞精附人口说经法。其人终不觉知魔著亦言自得无上涅盘。来彼求空善男子处敷座说法。於大众内其形忽空众无所见。还从虚空突然而出。存没自在。或现其身洞如琉璃。或垂手足作旃檀气。或大小便如厚石蜜。诽毁戒律轻贱出家。口中常说无因无果。一死永灭无复后身及诸凡圣。虽得空寂潜行贪欲。受其欲者亦得空心。拨无因果。此名日月薄蚀精气金玉芝草麟凤龟鹤经千万年不死为灵出生国土。年老成魔恼乱是人。厌足心生去彼人体。弟子与师多陷王难。汝当先觉不入轮回。迷惑不知堕无间狱。

议曰。此想阴第九境界也。以想阴渐破行阴将现。故定中心爱入灭。以行阴为生基。故研究化性以贪求深空。故魔现空事以破坏之。休征本於枉习贪明。今麟凤瑞征为灵习使然也。

又善男子受阴虚妙不遭邪虑圆定发明。三摩地中心爱长寿。辛苦研几贪求永岁。弃分段生顿希变易细想常住。尔时天魔候得其便飞精附人口说经法。其人竟不觉知魔著亦言自得无上涅盘。来彼求生善男子处敷座说法。好言他方往还无滞。或经万里瞬息再来。皆於彼方取得其物。或於一处在一宅中数步之间。令其从东诣至西壁是人急行累年不到。因此心信疑佛现前。口中常说十方众生皆是吾子。我生诸佛。我出世界。我是元佛。出世自然不因修得。此名住世自在天魔使其眷属如遮文茶及四天王毗舍童子未发心者。利其虚明食彼精气。或不因师

其修行人亲自观见弥执金刚与汝长命。现美女身盛行贪欲。未逾年岁肝脑枯竭。口兼独言听若妖魅。前人未详多陷王难。未及遇刑先已乾死。恼乱彼人以至俎（换歹旁）殒。汝当先觉不入轮回。迷惑不知堕无间狱。

议曰。此想阴第十境界也。定中忽起爱长寿心故贪求永岁。已离欲界分段而顿希变易此妄想也。细相常住以生灭细心为常住也。故魔得其便以破坏之。毗舍童子即毗舍遮食精气鬼。遮文亦其类也。听若妖魅。若彼也。前人所著之人也。

三诫勖深防

阿难当知。是十种魔於末世时在我法中出家修道。或附人体。或自现形。皆言已成正遍知觉。赞叹淫欲破佛律仪。先恶魔师与魔弟子淫淫相传。如是邪精魅其心腑。近则九生多逾百世令真修行总为魔眷。命终之后必为魔民。失正遍知堕无间狱。

议曰。此结想阴十种魔事也。昔佛住世诸魔坏法。佛神力故皆不能坏。魔作誓言。我於如来灭后依教出家破坏佛法。佛即堕泪曰。无奈汝何。譬如狮子身中虫自食狮子身中肉。是知末世坏法比丘皆魔属也。九生九百年。正法一千年。此将尽时也。一世三十年。百世三千年。末法之初。正魔强法弱之时也。

汝今未须先取寂灭。纵得无学。留愿入彼末法之中起大慈悲。救度正心深信众生。令不著魔得正知见。我今度汝已出生死。汝遵佛语名报佛恩。

议曰。此劝留愿弘宣以救未法也。佛恩难报。假使顶戴尘劫身为床座皆不能报。若不弘法毕竟无有可报恩者。故宣佛语名报佛恩。

阿难。如是十种禅那现境。皆是想阴用心交互故现斯事。众生顽迷不自忖量。逢此因缘迷不自识谓言登圣。大妄语成堕无间狱。汝等必须将如来语於我灭后传示末法。遍令众生开悟斯义。无令天魔得其方便。保持覆护成无上道。

议曰。此结魔由叮咛诫勖也。以遵奉佛言则不堕魔网。固宜弘宣以护行人也。

大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第九


通议卷第十

通议卷第十

大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第十

唐天竺沙门般剌密帝译
乌苌国沙门弥伽释迦译语
菩萨戒弟子清河房融笔受
明南岳沙门憨山释德清述

四行阴分三 初当阴未破

阿难。善男子修三摩提想阴尽者。是人平常梦想销灭寤寐恒一。觉明虚静犹如晴空。无复粗重前尘影事。观诸世间大地山河如镜鉴明。来无所黏。过无踪迹。虚受照应了罔陈习唯一精真。生灭根元从此披露。见诸十方十二众生毕殚其类。虽未通其各命由绪。见同生基犹如野马熠熠清扰。为浮根尘究竟枢穴。此则名为行阴区宇。

议曰。此示想尽行现之相。昼为想心。夜形诸梦。故想消则梦灭。是以寤寐恒一。心体本自圆明。向为浮想烦恼覆蔽。今想阴尽则圆明虚静犹如晴空。烦恼消则无粗重前尘影事。八识精明之体照诸世间山河大地但如镜中无别分析。只以六识妄想暗蔽故曰想相为尘识情为垢故不明了。今想阴既破六识已消故虚明之体如镜鉴照不黏踪迹。虽有行阴生灭根元则无前六浮想习气可入故云了罔陈习。了绝也。罔无也。陈犹列也。谓无习可陈。故八识唯一精真。而行阴微细生灭亦披露矣。生灭下行现之相也。行阴为同分生基。想灭行现故十二众生毕蝉其类。殚尽也。各命由绪乃异熟种子。其体深细故不能知。而同分生基正是行阴之相。今已披露故如野马熠熠清扰。野马泽中阳焰也。熠即闪烁之状。清扰行阴之相也。已离想阴粗重故云清扰。外浮根尘依为机纽故云枢穴。枢门转轴穴门臼也。下示行尽之相。

若此清扰熠熠元性性入元澄一澄元习。如波澜灭化为澄水名行阴尽。是人则能超众生浊。观其所由幽隐妄想以为其本。

议曰。此预示行尽之相也。以行阴乃八识体上生灭之相故云元性。八识为湛渊之体唯一精明故曰澄曰一。今行阴复归元性则八识了无生灭故性入元澄。如水无波澜唯一止水名行阴灭。以众生浊依行阴有。行阴既灭故能超之。此阴所以不尽者以幽隐妄想而为其本也。七识乃八识之见分。幽深难知故云罔隐

二示定境差别向下十段

阿难当知。是得正知奢摩他中诸善男子凝明正心。十类天魔不得其便。方得精妍穷生类本。於本类中生元露者。观彼幽清圆扰动元。於圆元中起计度者是人坠入二无因论。

议曰。此示行阴第一妄计二无因也。此先标其名。定慧坚住故云凝明正心。此想灭之相。天魔依想阴有。行阴乃见魔也。想阴既消便得精研行阴穷生类本矣。行阴已现则生元已露。然此生元通依七识故云圆元。以但见行阴就起妄计者则堕二无因论。是知西天外道皆有禅定工夫。但不知八识故起妄计耳。

一者是人见本无因。何以故。是人既得生机全破。乘於眼根八百功德见八万劫所有众生。业流湾环死此生彼。只见众生轮回其处。八万劫外冥无所观。便作是解。此等世间十方众生八万劫来无因自有。由此计度亡正遍知。堕落外道惑菩提性

议曰。此示本无因也。是人指修禅行人也。以行阴现前生元披露故云生机全破。乃乘眼根八百功德但见八万劫来其中众生业流湾环委曲轮回生死之状一一了知。而八万劫前冥然莫辩。故妄计众生从八万劫来无因自有。以未见藏识中异熟种子。故妄计众生本来无因。故堕外道惑菩提性。

二者是人见末无因。何以故。是人于生既见其根。知人生人悟鸟生鸟。乌从来黑鹄从来白。人天本竖畜生本横。白非洗成黑非染造。从八万幼无复改移。今尽此形亦复如是。而我本来不见菩提云何更有成菩提事。当知今日一切物象皆本无因。由此计度亡正遍知。堕落外道惑菩提性。是则名为第一外道立无因论。

议曰。此示末无因也。是人以定研穷既见生之根元。则见人物有生受形之始。八万劫来无复改易。妄谓前既不改而后亦不易。谓人定生人鸟定生鸟不改别类。以我本不见有菩提云何末后更有成菩提事。由执本无因故执末亦无因。故结云皆本无因。且以末因又为后因之本也。此第一计。

阿难。是三摩中诸善男子凝明正心魔不得便穷生类本。观彼幽清常扰动元。於圆常中起计度者是人坠入四遍常论。

议曰。此示行阴第二计四遍常也。以行阴乃八识体中微细生灭之相。今以定力研穷以见生灭相续不断。故於圆常中起四遍常论。实妄计也。

一者是人穷心境性二处无因。修习能知二万劫中十方众生所有生灭。咸皆循环不曾散失计以为常。

议曰。此示初遍常计也。以行人於禅定中穷心境二法。故能执至二万劫中众生生灭循环而体不散失。以不出生灭故计为常。

二者是人穷四大元四性常住。修习能知四万劫中十方众生所有生灭。咸皆体恒不曾散失计以为常。

议曰。此示二遍常计也。以行人定中但观四大性故能知四万劫中众生生灭体常。以四大乃八识相分。今八识未破故四大未消。众生皆以四大为体。四大常而众生亦常矣。

三者是人穷尽六根末那执受心意识中本元由处性常恒故。修习能知八万劫中一切众生循环不失本来常住。穷不失性计以为常。

议曰。此示三遍常计也。梵云讫栗瑟吒耶末那此云染污意乃七识也。执受者乃八识也。今行人以定力研穷六根以至末那执受者通言八识故云心意识中本元由处。至此行虽未尽而识性已显故云性恒常处。故能知八万劫中众生本来常住。以众生各各皆具八识。以八识体常而众生亦常矣。以穷不失性故。

四者是人既尽想元。生理更无流止运转。生灭想心今已永灭。理中自然成不生灭。因心所度计以为常。由此计常亡正遍知堕落外道惑菩提性。是则名为第二外道立圆常论。

议曰。此示四遍常计也。生理乃行阴也。行人定中一向但穷妄想只为流止生灭。今粗浮想阴已灭。而微细行阴一类相续不断。故妄谓生灭已灭则此行阴自然成不生灭矣。乃以生灭为不生灭故妄计为常。由此忘失菩提故堕外道四圆常论也。

又三摩中诸善男子坚凝正心魔不得便。穷生类本观彼幽清常扰动元。於自他中起计度者是人坠入四颠倒见一分无常一分常论。

议曰。此示行阴第三计四颠倒一分无常一分常论也。以七识执第八见分为我。故或执我能生他则我常他无常。或执我从他生则他常我无常。故云於自他中起计是一分常一分无常。

一者是人观妙明心遍十方界。湛然以为究竟神我。从是则计我遍十方凝明不动。一切众生於我心中自生自死。则我心性名之为常。彼生灭者真无常性。

议曰。此示四例见中第一计也。观智研穷妄想已消则八识精明遍十方界。以不知是识体精明遂执为神我。从此计为我遍十方。一切众上於我心中自生自死。则我心性为常。彼生灭者真无常性。此单观自也。

二者是人不观其心。遍观十方恒沙国土。见劫坏处名为究竟无常种性劫。不坏处名究竟常。

议曰。此示四倒见中第二计也。此人定中不观自心。但观十方国土。见劫坏处名究竟无常。劫不坏处名究竟常。此单观他也。

三者是人别观我心精细微密犹如微尘。流转十方性无移改。能令此身即生即灭。其不坏性名我性常。一切死生从我流出名无常性。

议曰。此示四倒见中第三计也。是人定中观自心微密流转十方性无改易故称为我。今在色蕴之中能令此身即生即灭。其不坏者是我心性名我性常。一切生死从我流出名无常性。此自他共观计自常他无常也。

四者是人知想阴尽见行阴流。行阴常流计为常住。色受想等。今已灭尽名为无常。由此计度一分无常一分常故。堕落外道惑菩提性。是则名为第三外道一分常论。

议曰。此示四倒见中第四计也。定中观四阴先后。今见行阴迁流相续不断计为常性。见色受想三阴已灭名无常性。此合观四阴起一分常一分无常计也。此皆不了妙明故云惑菩提性。

又三摩中诸善男子坚凝正心魔不得便。穷生类本。观彼幽清常扰动元。於分位中生计度者是人坠入四有边论。

议曰。此行阴第四计四有边论也。以定研穷想阴尽处行阴现前有四分位计为有边无边。

一者是人心计生元流用不息。计过未者名为有边。计相续心。名为无边。

议曰。此行阴四有边中初计也。定中研穷见行阴现今流注不息。过未不见名为有边。现相续心名为无边。此约三世分位也。

二者是人观八万劫则见众生八万劫前寂无闻见。无闻见处名为无边。有众生处名为有边。

议曰。此行阴四有边中二计也。定中观八万劫前无见闻处名为无边。见有众生处名为有边。此约见闻分位计也。

三者是人计我遍知得无边性。彼一切人现我知中我曾不知彼之知性。名彼不得无边之心但有边性。

议曰。此行阴四有边中三计也。定中见我之知遍一切处。一切众生现我知中。是我得无边性也。彼众生之知不见现我知中。以彼未得无边之心但有边性耳。此约彼此分位妄计也。

四者是人穷行阴空以其所见心路筹度。一切众生一身之中计其咸皆半生半灭。明其世界一切所有一半有边一半无边。由是计度有边无边。堕落外道惑菩提性。是则名为第四外道立有边论。

议曰。此行阴四有边中四计也。以观研穷取行阴空。以空处名灭见处名生。即计一切众生身中一半是生一半是灭。世界亦然。以现见处名为有边。以不见处名为无边。此约生灭分位计也。

又三摩中诸善男子坚凝正心魔不得便。穷生类本。观彼幽清常扰动元。於知见中生计度者是人坠入四种颠倒不死矫乱遍计虚论。

议曰。此示行阴第五计四种不死矫乱论也。长水引婆沙论说外道计天常住名为不死。计不乱答得生彼天。若实不知而辄答者恐成矫乱。故有问时答言秘密。不应皆说。或不定答。佛法呵云此真矫乱。以於知见中不能决择故有问者矫智乱答。故云不死矫乱。

一者是人观变化元。见迁流处名之为变。见相续处名之为恒。见所见处名之为生。不见见处名之为灭。相续之因性不断处名之为增。正相续中中所离处名之为减。各各生处名之为有。互互亡处名之为无。以理都观用心别见。有求法人来问其义。答言我今亦生亦灭亦有亦无亦增亦减於一切时皆乱其语。令彼前人遗失章句.

议曰。此行阴四矫乱中初计也。观照研穷生灭根元故云观变化元。於一行阴生灭中别见八义。谓常变生灭增减有无。不见见者谓见不见之处也。以理总观变化之心。用心别见生灭等八义。故计以为宗。有人来问则答云亦生亦灭等。并八义以答。以无定见故据两楹。令彼问人不得道理。无决定见。故云遗失章句。

二者是人谛观其心互互无处。因无得证。有人来问。唯笞一字但言其无。除无之馀无所言说。

议曰。此行阴四矫乱中第二单计无也。以观研穷行阴生灭。但见念念灭处名互互无。遂计为无。诸法皆然。故云因无得证。故有人来问但答云无之一字而已。

三者是人谛观其心各各有处。因有得证。有人来问。唯答一字但言其是。除是之馀无所言说。

议曰。此行阴四矫乱中第三单计有也。以观研穷行阴生灭。念念生处名各各有。因是得证一切皆有故有人来问但笞云是。以虽观生处名有。且又见灭。故不敢正言有。但答是之一字。拟防过也。

四者是人有无俱见。其境枝故其心亦乱。有人来问答言亦有即是亦无。亦无之中不是亦有。一切矫乱无容穷诘。由此计度矫乱虚无。堕落外道惑菩提性。是则名为第五外道四颠倒性不死矫乱遍计虚论

议曰。此行阴四矫乱中第四双计有无也。以观研穷行阴生灭二相故变计有无。以其境枝不一故其心亦乱。有人来问答云亦有即是亦无者。意许亦有之中即有於无。以见生即灭故。亦无之中不是亦有者。以见灭处不许有生。谓无中不敢言有。以此有无互相遮防。故云无容穷诘。总是妄计本无一定道理。故云矫乱遍计虚论。

又三摩中诸善男子坚凝正心魔不得便。穷生类本。观彼幽清常扰动元。於无尽流生计度者是人坠入死后有相发心颠倒。

议曰。此示行阴第六计死后有相起十六见也。无尽流行阴也。今见行迁不息。都执死后有相。以行为我故。

或自固身云色是我〖即色是我〗。或见我圆含遍国土云我有色〖我大色小色在我中〗。或彼前缘随我回复云色属我〖离色是我〗。或复我依行中相续云我在色〖色大我小我在色中〗。皆计度言死后有相。如是循环有十六相。

议曰。此见行阴无尽故执死后有相。初本计也。自坚固色为我等有四。而后三阴亦然。今观行阴为无尽流。例观前三亦皆无尽。故计死后有相。成十六相也。以色阴已破。亦同行阴无尽。故自固身。此计即色是我也。或计我圆遍云我有色。即我大色小色在我中也。前缘即目前之色也。色属我即我离色别有我也。行中相续云我在色。即色大我小我在色中。於色阴中作此四计。於受想行阴亦复如是。四阴共成十六相也。

从此或计毕竟烦恼。毕竟菩提。两性前驱各不相触。由此计度死后有故。堕落外道惑菩提性。是则名为第六外道立五阴中死后有相心颠倒论。

议曰。此因计四阴死后有相。故别计烦恼菩提不相陵夺。两性前驱。毕竟后有。例如四阴。盖颠倒论也。

又三摩中诸善男子坚凝正心魔不得遍。穷生类本。观彼幽清常扰动元。於先除灭色受想中生计度者是人坠入死后无相发心颠倒。

议曰。此行阴第七妄计死后无相也。以观研穷见前三阴已灭。即知行阴亦灭。故计死后无相。

见其色灭形无所因。观其相灭心无所系。知其受灭无复连缀阴性销散。纵有生理而无受想与草木同。此质现前犹不可得。死后云何更有诸相。因之勘校死后相无如是循环。有八无相（四阴因亡果丧）。从此或计涅盘因果一切皆空。徒有名字究竟断灭。由此计度死后无故。堕落外道惑菩提性。是则名为第七外道立五阴中死后无相心颠倒论。

议曰。此约四阴现在因亡未来果丧故成八无相。此便计涅盘因果一切皆空成断灭见颠倒论也。

又三摩中诸善男子。坚凝正心魔不得便。穷生类本。观彼幽清常扰动元。於行存中兼受想灭双计有无自体相破。是人坠入死后俱非起颠倒论。

议曰。此行阴第八妄计死后俱非相也。於行存中兼受想灭双计有无。谓将已灭三阴例现存行阴。作四个非有句。又将现存行阴例前已灭三阴作四个非无句。前后相望每阴皆有非有非无成四俱非。现在既尔。死后亦然。故成八俱非相。

色受想中见有非有。行迁流内观无不无。如是循环穷尽阴界八俱非相。随得一缘皆言死后有相无相。

议曰。此出八相俱非所以也。色等三阴先有今无。例行亦尔。此四非有也。行迁流内观无不无者。谓若将行阴例前为无。且今现见迁流不断。故又非无。行既非无。前三亦尔。此四非无也。如是循环穷尽阴界者。现将四阴循历相例一一皆见非有非无故云循环。惟至死后故云穷尽阴界八俱非相。随得一缘谓随举一阴死后皆悉非有非无也。有相即非无。无相如非有。

又计诸行性迁讹故心发通悟。有无俱非。虚实失措。由此计度死后俱非后际昏瞢无可道故。堕落外道惑菩提性。是则名为第八外道立五阴中死后俱非心颠倒论。

议曰。此四俱非中别计也。以观四阴有无俱非故计诸行性迁讹故通俗一切皆是非有非无以非 有无虚实不定故云失措。以现前有无不定。况死后昏瞢何可道耶。特颠倒见耳。

又三摩中诸善男子坚凝正心魔不得便。穷生类本。观彼幽清常扰动元。於后后无生计度者是人坠入七断灭论。或计身灭。或欲尽灭。或苦尽灭。或极乐灭。或极舍灭。如是循环穷尽七际现前销灭灭已无复。由此计度死后断灭。堕落外道惑菩提性。是则名为第九外道立五阴中后灭断灭心颠倒论。

议曰。此行阴第九妄计七断灭也。以观行阴念念生灭处名后后无。设生七处后皆断灭。七处者。身灭人天也。欲尽初禅也。苦尽二禅也。极乐三禅也。极舍四禅及无色也。是名七际。谓七处皆现断灭。死后不复生也。

又三摩中诸善男子坚凝正心魔不得便。穷生类本。观彼幽清常扰动元。於后后有生计度者是人坠入五涅盘论。

议曰。此行阴第十妄计五涅盘也。以观行阴灭而复生名后后有。妄计五处为涅盘果。

或以欲界为正转依观见圆明生爱慕故。或以初禅性无忧故。或以二禅心无苦故。或以三禅极悦随故。或以四禅苦乐二亡不受轮回生灭性故。迷有漏天作无为解。五虚安隐为胜净依。如是循环五处究竟。由此计度五现涅盘。堕落外道惑菩提性。是则名为第十外道立五阴中五现涅盘心颠倒论。

议曰。此计五涅盘相也。转依者转生死依涅盘也。未离欲界於观心中见圆明相即以欲界为转依处。或以初禅已离欲染无复忧心。二禅离苦。三禅极喜。四禅苦乐二亡名为极舍。以此五处即转依处。谓五现涅盘因修禅定得少轻安。不知现在有漏。便妄执为涅盘

三诫勖深防

阿难。如是十种禅那狂解。皆是行阴用心交互故现斯悟。众生顽迷不自忖量。逢此现前以迷为解。自言登圣。大妄语成堕无间狱。

议曰。此结行阴十种狂解也。以上十种皆是邪见。因修禅定而发邪见故云狂解。於生灭中妄起计度理观不明故云交互。

汝等必须将如来语於我灭后传示末法。遍令众生觉了斯义。无令心魔自起深孽。保持覆护销息邪见。教其身心开觉真义。於无上道不遭枝岐。匆令心祈得少为足。作大觉王清净标指

议曰。此劝弘宣也。前想阴中所引外魔故云天魔。

此行阴微细皆於定心自生邪见故云心魔。乃自作灾孽非外来也。故令弘宣保护预知觉察不堕邪见。故云不遭枝岐。枝非根本。歧非正路。离此可至究竟安隐之处也。

五识阴分三 初当阴未破

阿难。彼善男子修三摩提行阴尽者。诸世间性幽清扰动同分生机倏然隳裂沈细纲狃。补特伽罗酬业深脉感应悬绝。於涅盘天将大明悟。如鸡后鸣顾瞻东方已有精色。六根虚静无复驰逸。内外湛明入无所入。深达十方十二种类受命元由。观由执元诸类不召。於十方界已获其同。精色不沈发现幽秘。此则名为识阴区宇。

议曰。此明行尽识现之相也。世间性谓行阴为世间生死之体也。以众生生死皆依行阴生灭故为同分生机。前言基乃其本。今言机乃枢机也。谓此行阴最极深沈微细网罗诸趣结不可解故云纲纽。今以定力研穷顿破故云倏然隳裂。补特伽罗云数取趣。十二类生由行阴所取。今既隳裂则因亡果丧不受后有。故云酬业深脉感应悬绝。是知能灭行阴则永脱分段生死矣。此行阴尽也。五阴黑暗覆涅盘天为生死长夜。今四阴已破故如天将明。鸡后鸣则将明之时也。识阴精明故如东方精色。行阴既尽意根已销。则六识无体故六根虚静不驰。内照识体通一湛明。湛入合湛更无可入。故云内外湛明入无所人。识阴乃十二类受命元由。至此深达。但观识性执持根元。习气不行。新业不起。无受生分。故云诸类不召十方世界十二类生身心世界唯识变现。今观归识性故云已获其同。识精现前不昧故云精色不沈。识体幽秘今以观力研穷即入观境故云发现此则名为识阴区宇。以但识阴显现而未破故云区宇。

若於群召已获同中销磨六门合开成就。见闻通邻互用清净。十方世界及与身心如吠琉璃内外明澈。名识阴尽。是人则能超越命浊。观其所由罔象虚无颠倒妄想以为其本。

议曰。此明识阴尽相也。群召同中即识体之中。若於此中以观力研穷。向以六根隔碍。今则销磨六门合成一体开其留碍。使见闻觉知互相为用。则六根清净纯一圆明清净宝觉。故身心世界如吠琉璃内外明澈。名识阴尽。以命浊依识而立。今识阴一破故超命浊。罔象虚无谓似有若无。乃法身之影明。指最初生相无明以为识体也。


通议卷第十

通议卷第十

二示定境差别以下十段

阿难当知。是善男子穷诸行空。於识还元已灭生灭而於寂灭精妙未圆。能令己身根隔合开。亦与十方诸类通觉。觉知通吻能入圆元。若於所归立真常因生胜解者是人则堕因所因执。娑毗迦罗所归冥谛成其伴侣。迷佛菩提亡失知见。是名第一立所得心成所归果。违远圆通背涅盘城生外道种。

议曰。此识阴初妄计也。行阴已空故返识还元。无明未尽尚有微细流注故於寂灭精妙未圆。观照圆明能令己身六根向隔而今合开。但未全互用。观十方诸类唯识所现。故觉知通吻能入圆元觉性。此特观照之力未为究竟。若於所归之地便妄立为真常之因。於此生决定解者是人则堕因所因执。谓因识阴执为真常为万法之因。故云因所因。以世间万法因妄有生。妄本无因故说无生。今执定此识能生万法则与外道所执冥谛无异矣。以娑毗外道执冥初主谛从冥生觉等二十五法。故以冥谛为生法之因。非因计因谬起斯计故亡正知见。是皆计有所得心为所归地。故违背涅盘成外道种。故参禅人但存丝毫知见未亡便成外道邪见。况妄计乎。

阿难。又善男子穷诸行空。已灭生灭而于寂灭精妙未圆。若於所归览为自体。尽虚空界十二类内所有众生皆我身中一类流出生胜解者是人则堕能非能执。摩旒（换酉旁）首罗现无边身成其伴侣。迷佛菩提亡失知见。是名第二天能为心成能事果。违远圆通背涅盘城生大慢天我遍圆种。

议曰。此识阴第二妄计也。以观照研穷行阴虽空而於寂灭一心未能圆悟。若於所归识性览为自体。以见识性圆满遍虚空界则计十二类生从我身中一类流出以为决定。如此即堕能非能执。其实不能而妄计为能。故云能非能。摩旒（换酉旁）首罗大自在天也。外道计大自在天为常能生诸法。现无边身者执我身能现无量众生也。因既能为果成能事非正知见。故违背涅盘成我遍圆种。

又善男子穷诸行空。已灭生灭而於寂灭精妙未圆。若於所归有所归依自疑身心从彼流出。十方虚空咸其生起。即於都起所宣流地作真常身无生灭解。在生灭中早计常住。既惑不生亦迷生灭。安住沈迷生胜解者是人则堕常非常执。计自在天成其伴侣。迷佛菩提亡失知见。是名第三立因依心成妄计果。违远圆通背涅盘城生倒圆种。

议曰。此识阴第三妄计也。所归即识体也。前览所归为自体。今认所归为他体。故疑自身及一切法从彼生起。故以识为都宣流地计为真常无生灭解。尚在生灭便早计为真常。不达真无生意。且以生灭为不生故云既迷不生亦迷生灭。二俱不识坚执不舍故变住沈迷。以非常计常故云常非常执。既计彼能生我便与计自在天我能生彼者类也。因依识阴非果计果故云妄计果。计生灭为不生故云倒圆。

又善男子穷诸行空已灭生灭而於寂灭精妙未圆。若於所知知遍圆故因知立解。十方草木皆称有情与人无异。草木为人人死还成十方草树。无择遍如生胜解者是人则堕知无知执。婆吒霰尼执一切觉成其伴侣。迷佛菩提亡失知见。是名第四计圆知心成虚谬果。违远圆通背涅盘城生倒知种。

议曰。此识阴第四妄计也。所知乃所观识阴也。以观识体圆遍。其十方草木皆唯识所现。不达此义遂妄计草木有知与人同体。不拣有情无情故云无择遍知。以为决定。此人则堕知无知执。婆吒霰尼二外道名也。计一切觉。即草木有知。故成其类。妄计无情有知故成虚谬果为倒知种也。

又善男子穷诸行空已灭生灭而於寂灭精妙未圆。若於圆融根互用中已得随顺。便於圆化一切发生。求火光明。乐水清净。爱风周流。观尘成就。各各业事。以此群尘发作本因立常住解。是人则堕生无生执。诸迦叶波并婆罗门勤心役身事火崇木求出生死成其伴侣。迷佛菩提亡失知见。是名第五计著崇事迷心从物立妄求因求妄冀果。违远圆通背涅盘城生颠化种。

议曰。此识阴第五妄计也。以观照研穷六根虽未及互用已得随顺。四大渐融妄谓圆化一切发生。遂计四大为常能成圣果。故各各祟事。以四大为常住解能生胜果。其四大性实不能生妄计能生故云生无生轨。三迦叶波事火外道之俦也。既迷唯心妄从物立因果。颠倒化理故云颠化种。

又善男子穷诸行空已灭生灭而於寂灭精妙未圆。若於圆明计明中虚非灭群化。以永灭依为所归依生胜解者是人则堕归无归执。无想天中诸舜若多成其伴侣。迷佛菩提亡失知见。是名第六圆虚无心成空亡果。违远圆通背湟盘城生断灭种。

议曰。此识阴第六妄计也。以观照研穷观识性虚明。即於此中见前四阴已灭则一切永灭故云非灭群化非绝灭也。即计永灭为所归依。执决定见。此人则堕归无归执。断灭非所归地故云归无归执。此即无想外道与四空成其类也。舜若多空也。此执圆虚无心断灭为因故成空亡果为所灭种也。

又善男子穷诸行空。已灭生灭而於寂灭精妙未圆。若於圆常固身常住。同於精圆长不倾逝生胜解者是人则堕贪非贪执。诸阿斯陀求长命者成其伴侣。迷佛菩提亡失知见。是名第七执著命元立固妄因趣长劳果。违远圆通背涅盘城生妄延种。

议曰。此识阴第七妄计也。以观识阴圆常故欲固色身同於识阴妄求长生故云长不倾逝。以色身无常本不当贪而妄贪长生故云贪非贪执。谓贪其不当贪也。阿私陀云无比。乃长寿仙也。固执妄识为因趣长劳果。旧解劳作牢固之牢。妄执延年故云妄延种。

又善男子穷诸行空。已灭生灭而於寂灭精妙未圆。观命互通却留尘努恐其销尽。便於此际坐莲华宫广化七珍多增宝媛恣纵其心生胜解者是人则堕真无真执。吒枳迦罗成其伴侣。迷佛菩提亡失知见。是名第八发邪思因立炽尘果。违远圆通背涅盘城生天魔种。

议曰。此识阴第八妄计也。识阴为十二类生受命元由。今观此识故见十方众生之命彼此互通由此遂生妄计。谓我命若尽则众生之命亦尽即教谁证真常谁化众生。故留尘劳多增欲乐图命久住。以证真化物。故起感恣欲实非证真故云真非真执。吒枳迦罗旧未详释意必魔王天名也。以定中忽起邪思为因立炽尘果故生天魔种也。

又善男子穷诸行空。已灭生灭而於寂灭精妙未圆於命明中分别精粗粗决真伪。因果相酬唯术感应。背清净道。所谓见苦断集证灭修道。居灭已休更不前进生胜解者是人则堕定性声闻。诸无闻僧增上慢者成其伴侣。迷佛菩提亡失知见。是名第九圆精应心成趣寂果。违远圆通背涅盘城生缠空种。

议曰。此识阴第九妄计也。以观照研穷以识体为精真以惑业为粗伪。精粗二种因果相酬。故修精真之因求感精应之果。故见苦断集慕灭修道也。今既得灭便已为休。得少为足更不前进。此人则堕定性声闻。及四禅无闻之俦未得谓得为增上慢。此以圆精应心成趣寂之小果。沈空滞寂故云缠空种。

又善男子穷诸行空已灭生灭而於寂灭精妙未圆。若於圆融清净觉明发研深妙。即立涅盘而不前进生胜解者是人则堕定性辟支。诸缘独伦不回心者成其伴侣。迷佛菩提亡失知见。是名第十圆觉吻心成湛明果。违远圆通背涅盘城生觉圆明不能圆种

议曰。此识阴第十妄计也。觉明即识精圆明。而此识体四阴已消此亦将破无复粗垢故云圆融清净。於此研穷便为深妙立为涅盘此妄计也。是人则堕定性辟支。诸缘觉独觉之类。认识阴为圆觉合妄计为吻心。寂然不动未破无明故云湛明果。舍生自度故不化圆种。

三戒勖深防

阿难。如是十种禅那中涂成狂因依迷惑。於未足中生满足证。皆是识阴用心交互故生斯位。众生顽迷不自忖量。逢此现前各以所爱先习迷心而自休息。将为毕竟所归宁地。自言满足无上菩提。大妄语成外道邪魔所感业终堕无间狱。声闻缘觉不成增进。

议曰。此通斥妄计也。以将破识阴而未极妙圆似觉未觉便生邪计故云中途成狂。不了识阴妄生止足故云因依迷惑。浅者为外道邪魔种。深者堕二乘地。

八敕令弘宣

汝等存心秉如来道。将此法门於我灭后传示末世。普令众生觉了斯义。无令见魔自作沈孽。保绥哀救消息邪缘。令其身心入佛知见。从始成就不遭岐路。

议曰。此敕令弘宣也。以识阴中魔皆依妄见故云见魔。自心取著自坏真修故云自作沈孽。非此法门不能保绥哀救消息邪缘入佛知见也。心外取法故云岐路。

九诸佛同证

如是法门先过去世恒沙劫中微尘如来乘此心开得无上道。

议曰。此示诸佛同证也。谓无有一佛不破识阴而得菩提者。

十阴尽功圆

识阴若尽则法现前诸根互用。从互用中能入菩萨金刚乾慧。圆明精心於中发化。如净琉璃内含宝月。如是乃超十信十住十行十回向四加行心菩萨所行金刚十地等觉圆明。入於如来妙庄严海。圆满菩提归无所得。

议曰。此示阴尽圆证功用也。从互用中即入金刚乾慧者。此言识阴一破则不历诸位一超直入圆证佛果。所以然者。以如来藏清净真心本无迷悟。但因一念妄动是为生相无明。不生不灭与生灭和合成阿赖耶识。变起色心诸法而成五阴之众生。今返妄归真乃以金刚如幻三昧直观八识根本无明即转生死而为涅盘。故不历诸位一念顿证无上菩提。此乃上根利智。如观音耳根圆通生灭既灭寂灭现前忽然超越世出世间。故今识阴一破则六根互用。从互用中即入菩萨金刚乾慧。是则但破生相无明便成佛果。不必定历诸位也。是知五阴次第未必一一经历。但约观心通途故须一一开示耳。故识阴尽者。圆明精心於中发化。此即上同诸佛慈力。下合众生悲仰。普门示现利益众生。故云发化。以身心世界诸佛众生圆融交彻。故知净琉璃内含宝月。便能顿超诸位入於果海归无所得。如此方名究竟极则也。

十一先佛授受

此是过去先佛世尊奢摩他中毗婆舍那觉明分析微细魔事。魔境现前汝能谙识。心垢洗除不落邪见。阴魔销灭。天魔推碎。大力鬼神褫魄逃逝。螭魅魍魉无复出生。直至菩提无诸少乏。下劣增进。於大涅盘心不迷闷。

议曰。此言先佛授受心法以示行人也。以三观乃佛佛成道之本。定中魔事乃先佛所经。非今特说。故须谛信也。令预识魔事。则魔境现前则不落邪见。魔气销灭即可直至菩提。心不迷闷。有此大益。故须弘宣。

十二重示密修

若诸末世愚钝众生。未识禅那不知说法。乐修三昧。汝恐同邪。一心劝令持我佛顶陀罗尼咒。若未能诵。写於禅堂或带身上。一切诸魔所不能动。汝当恭钦十方如来究竟修进最后垂范

议曰。此再示密修功用也。愚钝众生不知说法。有修禅者恐遭魔扰。则教一心持我佛顶神咒。此是诸佛心印。仗斯咒力则魔不能动。此外无可降魔者。唯此法门乃十方如来究竟修证。出世密因。实如来最后之垂范。汝宜恭钦宣布。以利将来。作大法益也。

前明五阴魔竟

二示五阴妄想分二 初当机请问

阿难即从座起。闻佛示诲顶礼钦奉忆持无失。於大众中重复白佛。如佛所言五阴相中五种虚妄为本想心。我等平常未蒙如来微细开示。又此五阴为并销除为次第尽。如是五重诣何为界。惟愿如来发宣大慈。为此大众清明心目。以为末世一切众生作将来眼。

议曰。阿难因闻从前开示五阴。皆依妄想安立。未知妄想以何为本。上言破五阴相。且五阴相不知顿渐次第。亦不知五阴以何为界。总伸三问冀佛最后开示也。

二世尊委示分五 初总示妄元

佛告阿难。精真妙明本觉圆净。非留死生及诸尘垢。乃至虚空皆因妄想之所生起。斯元本觉妙明真精妄以发生诸器世间。如演若多迷头认影。妄元无因。於妄想中立因缘性。迷因缘者称为自然。彼虚空性犹实幻生。因缘自然皆是众生妄心计度。阿难。知妄所起说妄因缘。若妄元无。说妄因缘元无所有。何况不知推自然者。是故如来与汝发明五阴本因同是妄想。

议曰。此总示五阴皆以妄想为本也。将明妄想先立一真法界以为妄本故曰精真妙明本觉圆净。谓精真妙明本觉真心本来圆满清净。中不留他。故云非留死生及诸尘垢。言其本来一法不立。何有五阴差别之相。其虚空世界众生业果等事皆因妄想生起。元从本觉妙明真精妙心中妄以发生世间诸相。如演若迷头认影之事无状狂走故曰妄元无因。以自妄想发生递相为种。故於妄想中立因缘性已是迷矣。且迷因缘者又称为自然。岂非更迷哉。故云皆是众生妄心计度本非有也。若知妄有起处可说因缘。今妄元无则因缘无有。何况又推自然耶。迷之甚也。由是与汝发明五阴同是妄想。欲令了悟本非有耳。

别示五阴本因分二 初列分五

初色阴

汝体先因父母想生。汝心非想则不能来想中传命。如我先言心想醋味口中涎生。心想登高足心酸起。悬崖不有醋物未来。汝随必非虚妄通伦口水如何因谈醋出。是故当知汝现色身名为坚固第一妄想。

议曰。此示色阴妄本也。故身非有。初因父母妄想交媾。汝心乘此纳想为胎。乃为色身之始。汝心非想何来想中传此命根。是则汝身盖因父母与己三处妄想和合而成。然想虽虚妄而能成事。如我先说想梅思崖口水足酸因之而出。故妄想虽虚而实有酸水。因知汝身从妄想有亦犹是也。是故妄想凝结而成此身名为坚固第一妄想也。

二受阴

即此所说临高想心能令汝形真受酸涩。由因受生能动色体。汝今现前顺益违损二现驱驰名为虚明第二妄想。

议曰。此示受阴妄本也。汝受非有但由虚想临高而明受酸涩能动色体。则可验知违顺损益苦乐二受皆因虚明妄想而有也。

三想阴

由汝念虑使汝色身。身非念伦。汝身何因随念所使种种取像。心生形取与念相应。寤即想心。寐为诸梦。则汝想念摇动妄情名为融通第三妄想。

议曰。此示想阴妄本也。身为四大本属无知。但被妄想念虑所转故心生形取与念相应。如寤寐梦觉皆是妄想摇动妄情。是皆妄想融通一身。是故身以妄想为主也。

四行阴

化理不住运运密移。甲长发生气销容皱日夜相代曾无觉悟。阿难。此若非汝云何体迁。如必是真汝何无觉。则汝诸行念念不停名为幽隐第四妄想。

议曰。此示行阴妄本也。行阴本无但由汝心生灭不停故使汝身迁流不住。化理下六句通言行阴微细幽隐难知之相。此若非汝下四句辩妄无体也。行若非汝则何能迁体。若实是汝何以不觉求之不得。则知诸行念念生灭不停者名为幽隐妄想也。

五识阴

又汝精明湛不摇处名恒常者。於身不出见闻觉知。若实精真不容习妄。何因汝等曾於昔年睹一奇物。经历年岁忆忘俱无。於后忽然覆睹前异记忆宛然。曾不遗失。则此精了湛不摇中念念受熏有何筹算。阿难当知。此湛非真如急流水望如恬静。流急不见。非是无流。若非想元宁受妄习。非汝六根互用开合。此之妄想无时得灭。故汝现在见闻觉知中串习几则湛了内罔象虚无第五颠倒微细精想。

议曰。此示识阴妄本也。识阴本非有也。元是真精妙明心体。但受妄想熏习盖覆真性故名识耳。然此识体元是真精湛不摇处。在此身中不出见闻觉知皆识之用也。若此识体果实是真则不容习妄。以不受熏乃可名真。如何昔年曾视奇物久而不忘。岂非熏习使然耶。以此而推则汝所指精了湛不摇中念念受熏有何筹算。如此安得为恒常耶。故汝所执之湛非真湛寂。第以微细流注生灭汝不觉知。如急流水望之似恬以流急不见非是无流。则故识体若非想元宁受妄习。今既受妄熏则非真常恒一矣。若得此识纯真。非汝六根互用则此妄想无时得灭。岂可以妄想所熏之识便以为真。故汝现在见闻觉知粗现於外而其中有串习几微生灭之相。於湛了内似有若无不能穷诘者正是罔象虚无微细精想。以为识阴之体。由是观之五阴皆以妄想为体。妄想无体则阴非有也。

二结

阿难。是五受阴五妄想成。

议曰。此结示五阴皆妄想成也。此五即是众生受报之地。故通名五受阴。又名五取蕴。乃补特伽罗所数取故。

上答五阴本因

三示阴界边际

汝今欲知因界浅深。唯色与空是色边际。唯触及离是受边际。唯记与忘是想边际。唯灭与生是行边际。湛入合湛归识边际。

议曰。此答二问因界浅深也。因即界义。亦是分义。因依界分际分各别故云因界。色谓形色。空谓显色。俱色蕴摄。唯色与空乃色边际。触有违顺。离无违顺唯一舍受。三受乃受之边际。记忆与忘乃想边际。生灭四相乃行之边际。湛入合湛者湛乃八识之体。所谓湛兮似若存。以生灭乃从湛流出。今旋归妙湛。故云湛入合湛为识之边际也。

四示迷悟顿渐

此五阴元重叠生起。生因识有。灭从色除。理则顿悟乘悟并销。事非顿除因次第尽。我已示汝劫波巾结。何所不明再此询问。

议曰。此答三问顿渐也。以此五阴最初生起从阿赖耶识变起见相二分。以此色心二法和合而成五阴之众生。故云生因识有。今返妄归真先破色阴后破识阴故云灭从色除。若依圆理一念顿悟不历渐次顿登佛地。故云乘悟并销。但历劫无明习气须一一研穷。故云渐除须因次第而尽。如前所示巾结同异结解次第何所不明今再问耶。此结责也。

五结劝修持

汝应将此妄想根元心得开通传示将来末法之中诸修行者。令识虚妄深厌自生。知有涅盘不变三界。

议曰。此结劝也。一切世界妄想所持。今知五阴身心同一妄想则一切无非妄想建立。若了妄想无性则身心世界当下销亡。有何涅盘之难证。又何三界之可恋哉。是故将此妄想根元传示末法令知修行之要也。

前正宗分竟

三流通分分四 初较量功德

阿难。若复有人遍满十方所有虚空盈满七宝。持以

奉上微尘诸佛。承事供养心无虚度。於意云何。是人

以此施佛因缘得福多不。

议曰。此劝流通先较功德令生信重也。十方虚空

广大之处。充满七宝能施之多。微尘诸佛所奉之

众。心无虚度立心之坚。如此殊胜获福岂可思议哉。

二获福殊胜

阿难答言。虚空无尽。珍宝无边。昔有众生施佛七钱舍身犹获转轮王位。况复现前虚空既穷佛土充遍皆施珍宝。穷劫思议尚不能及。是福云何更有边际.

议曰。此答供佛获福殊胜也。施七钱而感轮王之报。所施者少所报者大。况以满空无尽之七宝以奉至极之如来。如此之福岂可得而思议耶。

三总显胜益

佛告阿难。诸佛如来语无虚妄。若复有人身具四重十波罗夷。瞬息即经此方他方阿鼻地狱。乃至穷尽十方无间靡不经历。能以一念将此法门於末劫中开示未学。是人罪障应念销灭。变其所受地狱苦因成安乐国。得福超越前之施人百倍千倍千万亿倍。如是乃至算数譬喻所不能及。阿难。若有众生能诵此经能持此咒。如我广说穷劫不尽。依我教言如教行道。直成菩提无复魔业。

议曰。此以厚施之福极重之罪总校不若弘法之胜益也。四重十重之罪。阿鼻极重之苦。穷尽十方之广。此罪此苦不可思议矣。若能以此法门一念开示末法。则令前重罪罪顿销。苦具变成乐国。足知此法之胜益也。不唯灭罪。又且获福。超前布施之人不可算数之倍者何其法之殊胜耶。良以圆顿法门一念熏修即得无上菩提之果。故此经说如来藏性功德无穷。咒乃诸佛心印。印持无尽。显密双修。成佛真要。故说不能尽。若依教修行。直成菩提。无复魔业。是谓最胜法门也。故弘宣之功不可思议矣。

四都结法会

佛说此经已。比丘比丘尼优婆塞优婆夷。一切世间天人阿修罗。及诸他方菩萨二乘圣仙童子。并初发心大力鬼神皆大欢喜作礼而去。

议曰。此结法会也。以如来最极之至圣。集凡圣同居之法会现无量光明之瑞相。演秘密难思之神咒。说微妙难解之法门。断历劫生死之爱根。销五阴邪思之魔业。得见所未见。幸闻所未闻。所以皆大欢喜也。

大佛顶如来密因修证了义诸菩萨万行首楞严经通议卷第十