《莲舟集》目录

目 录

    《莲舟集》序言
一、人生佛教
    1、理想与信念
    挽法云老法师
    纪念宁玛派圆觉宗阿奢黎慧华金刚上师
    韩老居士功在千秋
    送别金浩……
    2、观念与融通
    学佛入手在哪里？
    从自己现有的因缘条件上做起
    理想与信仰
    一定要抛弃自己是一个失败者的自我意象
    善知识的“显现”
    假装的平等也好，慢慢就弄假成真了
    关于福慧双修
    苦难可以使软弱者沉沦，苦难同样可使强者更加智慧
    新习惯代替旧习惯，只有不懈地坚持才能成功
    理想主义与浪漫情怀
    人各有志，求同存异
    磕头和烧香是人们表达对佛尊敬的传统方法
    礼佛随笔二则
    达则兼济天下之说的眼光尺度
    我们应该感谢众生，是众生给了我们积福的机会
    3、归依与学佛
    致文森善知识：关于皈依三宝。
    归依佛门不等于出家
    礼敬是皈依的基本含义之一
    关于鸡鸣寺的点滴回忆
    寻师且等慢慢自己稳定下来再说
    在美国中部想三皈依，当去何处？
    在新的环境如何学佛
    佛法的大门是向任何人敞开的
    大学生如何学佛？
    学佛从何处入手？
    分清个体的行为与团体意志
    4、迷信与正信
    云何使现世众生生起正信？
    善恶的标准：利人还是害人
    要改运不如积德
    这个地方有什么可糊涂的？
    附佛外道的命运如何？
    西瓜靠大边的自信
    点评某民间信仰的炒作
    5、佛法与世间
    追求真理需要跨越能所对立
    关于“困扰小弟很长时间的疑问”
    创世纪戏说
    异质相成与相似
    观念上的融通
    植物不属于有情
    无我、前世记忆
    融通与表述
    6、理性与逻辑
    别忽略了理性与逻辑
    关于菩萨的示现
    宿命论跟自由意志是一样的龟毛兔角
    关于现代逻辑与因明
    佛陀会不会上网？
    如果世人都出家该怎么办？
    老虎身上的慈悲也一样是崇高
    初级因明
    7、做老实人
    一些学佛之人次第不明的典型问题
    翻译佛经的事情谨慎量力而为
    有漏追求和尴尬的结果
    出不出家终要看缘，但生死总是要解决的
    新生活的起点
    你已经是个成人了，对自己负责任些
    因缘难测
    给自己心理上添加崇高油彩
    8、交流的风度
    理性交流佛法的风度
    论坛最吸引人的地方就是这里充满了民主的气氛
    有教无类与互相宽容
    愿诸众生，所行无逆，成一切智
    反省自己笑脸背后是否真的是“真诚”！
    网上掐架与宣传佛法
    京巴是生意人，就说点生意上的事儿
    让仇恨离我们远去
    9、善生常识
    吾人要转变人生境界，先要自心作大转变
    祈请大悲观世音
    要学会分辨正邪
    你的心病，唯佛法能医好
    人毕竟最爱自己
    一般的心理辅导对“幻听”不易见效
    “我破了我慢……”
    量力而为的事，别上纲上线
    解释什么梦呀
    每个地方卫生条件不同
二、学佛初机
    关于如何理解太虚大师的“人圆佛即成”思想
    1、离苦得乐
    出世、入世以及修行次第
    明信因果是学佛修行的基础
    第一位的是去体会苦，并决定离苦
    初学者怎样修习共同加行？
    以为有“我”的想法可以自然止息吗？
    控制“欲望”与“思维轮回过患”
    2、持戒
    依佛陀戒律是对佛陀真正的臣服
    持戒窍诀
    戒杀乃诸戒之首，应坚决奉行！
    杀戒不持，慈悲心如何能生起？
    关于对恶业的界定
    《大乘方广总持经》的教诲
    能损大利无过嗔
    所断不同，所断次第不同构成无为法差别
    看见美女，老是看个没完怎么办？
    出离心对于受持戒律的重要性
    谈谈对於同性恋和情欲的看法
    3、信和修
    正信生起的因缘
    信与圣言量
    信和修
    佛教中的信根、信力
    闻思修、信根的坚强基础
    胜鬘夫人开示的启示
    若无信心，难说修持。若无修持，难有体会
    越是圆顿的法门越需要信根
    佛法的力量！
    只要有如来的正法住世，佛法就不会末。
    4、佛子初修
    形象教育法——观想念佛
    初学者的实用学习方法
    从缘起性空说开去
    初机学佛讨论
    怎么说也得从现在做起
    不肯定自力修行会助长行人的偷心
    能觉察到“敌人”的存在是件好事
    如来住一切处
    妈妈会烦吗？
    自认佛子这一功德我们应该随喜
    为老人买张通往极乐世界的车票
    学佛就是学会引导自己的心
    动物保护：大学生活的一点启示
    探讨学佛人的婚姻与家庭问题
    5、善知识
    什么是善知识？
    关于上师与善知识
    依止善知识和积累福慧资粮
    亲近善知识非半梵行，乃全梵行
    谈谈我想出家的原因
    对于密教皈依上师的一些个人认识
    6、诵读与学习
    聊点“做功课”
    念诵与回向略谈
    关于念佛、诵经、忏悔灭罪
    年轻的佛弟子应该努力去背诵一两部佛经
    法华经怎么读？
    抄经“发家史”
    读经功德无量无边
    关于菩提道次第教授
    7、成长的烦恼
    莫等闲，白了少年头
    成长的烦恼
    致慧心通明兄
    自知之明就是勇气
    虽然无知最能被人原谅……
    其实真正的利他心不难判别
    烦恼障的根本是所知障
    度生
    身陷尘劳怎么办？
    关于前世今生
    8、择法与平等
    对于如何看待大乘佛法与大乘经典的一点粗浅认识
    佛教宗派建立的必要条件
    后学对于佛法各宗互不相违的粗浅认识
    禅法衰败的原因
    希望禅宗如同无尽灯
    “某事的末流与某事本身是两回事”
    树茂则根枝俱荣，诸枝俱荣则树盛
    有关修净土的一些话题
    历史上的多种说法
    佛法一多互摄，哪宗里没净土，净土里没哪宗？
    和风车兄聊一点净土
    力争上游与拔苗助长
    略谈因缘时节
    菩提道次第和修学净土法门
    众聚法与大小师
    是法平等，无有高下
    瑜伽士和般智达
    莫说密法，就是显乘也是非机不说
    学《最上乘论》之前要考虑的几个问题
    法无高下，挑自己能用得起来的方法实修就好
    怕的是永远等明天
    谈“空”
    谈谈“如实观”
    四念处观的深浅
    如何避免持诵为主修时乐着世俗的趋势
    学经论的闻思修
    学习随念和现观庄严论、华严
    管理自己的修行
    9、打坐中的误区
    打坐常识交流
    老生常谈积资粮
    仁兄为何而习定？
    静坐与“期望”
    不好意思，我看不出您这是什么行持来
    没什么特别殊胜，不过一场电影
    知觉问题辨析
三、发菩提心
    华严发菩提心文
    1、菩提心略说
    学佛的过程，几点体会
    菩萨道修行的总原则
    菩提心生起的因缘
    菩提心的根在哪儿？
    菩提心总摄空性慧与大悲心
    戒绝对五欲的贪著，同时发起无上菩提心
    不忍独自出离，则当发起无上菩提心
    发菩提心的行者不可退失大乘
    菩萨大悲心用的显现
    心量学“大”先“假装”
    越过发心和退心的循环
    从心底里发起无上菩提心
    成佛的可能性要变成现实性，关键步骤是发菩提心
    如来亲证十力、十八不共法
    仁兄，这三种人您想做哪一种？
    菩提心与体会空性
    2、行愿菩提心
    慈悲心的修学
    行愿菩提心应居于菩提心中的核心地位
    踏踏实实学习大悲心
    愿乃对目标的追求
    关于“爱见大悲”
    观世音菩萨的大悲绳索
    发菩提心持诵陀罗尼是秘密普贤行
    就在这里好好修菩提心教法吧！
    随喜四弘誓愿
    未来之弥陀见现在之弥陀，岂不理直气壮！
    菩提心、大悲、慈悲喜舍四无量心，这几者之间是什么关系？
    愿你我所愿早日圆满
    3、初发心功德品
    圆教的发心方法
    关于《初发心功德品》
    初发心功德品的见、修、行
    关于正遍知
    “贪”和“愿”等心行的差异
    发菩提心的所缘与实践
    发心清晰程度的确定
    初发心时，便成正觉
    安住实相，功德自显
    才发心时，即能熄灭一切世界诸恶道苦
    “华严发心门”和“普贤行愿门”
四、菩萨学处、禅坐略说
    1、菩萨学处
    菩萨道苦中有乐的一面
    菩萨勇气的来源
    关于懈怠与精进、多闻与实修
    为利生，无量的善巧方便正是菩萨当应学处
    真正认识到众生的可敬之处
    当嗔心的目标是菩萨时，此嗔心的恶果尤为严重
    网络学佛“讨论度”之浅见
    染净四料简
    菩萨摩诃萨的十种魔业和舍离之道
    降魔的无上妙诀
    “放下屠刀立地成佛”之因是放下
    知恩不报非君子也！
    2、禅坐略说
    打坐修持与实践中观
    鼓励把止修出来
    真的学静虑，建议从止开始
    打座程序的安排
    对念头做不了主一定没离昏沉散乱
    单凭慧力用心的人，容易不平衡
    生起大精进心对治昏沉
    打坐心中烦闷怎么办？
    近期好迷糊不知如何了！
    打坐时身体有动作的对治
    为何打坐到一定时候会灯光一闪
    方式有三，不劳不得
    禅坐略评
    修禅定省力气的办法：找具格的师父学
    真受持＝无疑＋专注
    昏沉谈不到是什么境界
    临终一念和平时用功都重要
    坐前和坐后的身体活动不要忽略
五、中观
    1、因果律与随机性
    因缘生的无自性
    龙树菩萨对轮回存在的说明
    关于“对因果与轮回的一些理解”
    有一条原则是不应动摇的，即坚信因果
    别连果树也一起刨了
    离“妄计因果”与“拨无因果”这两个边见
    观测与可能性
    因果律和随机性
    相对自由意志
    我理解它是“活”的就好了
    宿命并非真实
    自由意识与宿命论的对决
    2、缘起法与二谛
    关于缘起与空性关系的一点看法
    学人缘起正见的确立
    缘起一说为我佛教言之根本
    学佛的人常会遇到的问题
    阿罗汉入涅槃后，与他相关的因缘相续怎么说？
    因缘法涉及无量因缘
    俗谛与第一义谛的深浅
    “如幻”与“是幻无或是实有”
    细心防护自己别在不知中偷换立场
    慎对“虚妄”
    3、舍离观待与无自性
    观念上的割裂
    名言安立的界限
    所谓相互作用，也就是一种割不断的因缘
    观待等诸词集备忘录
    无自性、无自性性和缘起法
    法与法性
    因缘的不可分割、空性的不可分割
    缘起性空入于一切众生心想中
    应观导师体，即法界法性
    入中论之一颂
    关于在因缘当体体会性空
    “空性”与“慧”于行者心中只能同时生起
    4、能所与不二
    努力突破能所二执之障
    割裂与能所
    妄设能割所割，已是颠倒
    不二这个词很多人不小心就当一理解了
    验金石
    孔雀开屏的尴尬
    本来不二和后来合一
    “能转物”者其前提是转心
    悲智本来不二
    空性与因果之非一非异
    显空不二
    关于“随举一法皆未离心性的显现”
    5、中观类例
    从因果律看时空
    相似相续不需要载体
    盯住我执，创造修定的良好缘起
    在观待形成以前，根本无从谈起
    帮香严唱戏
    有些事不必过早担心，修来就知道
    契入第一念的前行和第一念的差别
    只不过是能所对立比一般情况细微了些
    广泛地去比较自己哪里错了
    小石头用文字精确描述出来，能吗？
    你偷的到底是什么？
    不汝还者，非“是”个东东吗
    梦里问梦从何始
    关于破四相
    苦受不等于烦恼
    我执──执无量因缘法里少分相续为我
    无我的一个重大意义就是说无主宰
    “封闭”的“自性有”能找着吗？
    自性是根本没有的东西
    无住与烦恼不生
    内外不可得
    无穷大与有限大
    大同与小异
    关于整体之类的概念
    分心外心内是凡夫二乘的错觉
    6、般若到彼岸
    谈谈对“般若波罗蜜多”的理解
    努力寻求般若波罗蜜多之真义
    自心是每个学佛人唯一真正能下手处，不是证处！
    二乘与大乘教法的区别，不在教法本身，而在于所利益的对象
    把握否定的界限
    应以般若智慧观照诸法的真实相──无相
    方便与般若之间的关系
    空性是活的
    本性的真实
    以缘起所显现的法性为所缘，其能缘之心即是实智
六、唯识
    1、瑜伽行
    智慧生佛
    唯识里借用禅定干什么？
    观察修与安住修
    诸蕴如幻与缘起法
    因缘法聚合的根本动力是行蕴
    五蕴是你的我的他的吗？
    如何破除对五蕴的实执呢？
    对识蕴的执著最为坚固难破
    识蕴与真心
    破的是执着与迷思，不破的是功能
    关于执着的迁转
    “无情有性”与“心中有色”
    2、功能主义
    唯识是从哪里说起的？
    唯识、中观与其他
    唯识与中观上的表达方法略谈
    阿赖耶与有情
    关于某个唯识讨论的个人看法
    种子、隐显、相似相续
    “名”说的是执受等事，而不仅仅是“名字”
    七识不需要“知道”第八识，就能执持为我
    眼不自见，手能自摸
    见的表述方式和抉择
    未现行的种子在其相续中同样与外缘相互作用
    有识间的同步性协调性这回事吗？
    3、知觉与观察
    如何理解“客观物质世界”？
    五蕴与遍计所执性
    一些唯识设问
    关于十二因缘的讨论
    “凡夫法”和“圣者法”的“交集”
    发愿与观察
    唯识中的“识”与圣者之“智”
    文句与正见
七、华严
    华严五教止观·第五华严三昧门
    1、中观、如来藏与华严
    中观、如来藏与华严
    《中观、如来藏和华严》续谈
    从“无性性”推导到“彼中有此，此中有彼”
    胜法身及胜色身
    缘起与遍知
    谈中观与如来藏
    如何理解众生本具如来智慧德相
    如来藏九喻
    正信的关键是要随顺缘起法之实相
    见真实相者即是智慧
    2、华严学
    关于华严的修证方法
    对华严法界信解而入的法理门和比喻门
    菩萨于佛十力中，虽未证得亦无疑
    李长者与众生眼中的佛
    杜顺大师教法的身影
    关于华严法门的权威注疏
    哪些华严宗著作较适合现代人初学阅读？
    现代语言逻辑与学华严
    实持与如幻
    《华严》、《般若理趣经》与大圆满
    3、显与隐
    显与隐
    显现与局部漫谈
    平等与显隐
    关于“有”和“无”，看看古德是如何解说的
    天台与华严遥相呼应
    根本的并起与显隐
    众生本具的如来智慧德相是隐藏的
    关于隐藏
    一个大家听后都会高兴的秘密
八、真言乘
    妙臂菩萨所问经分别数珠持心离障分
    1、真言持诵
    浅谈三摩钵提
    将心止于佛号或真言之上
    全心是咒，全咒是心
    全心是咒、全咒是心，不是三身圆满佛还能是什么？
    心若与陀罗尼相应，便是与般若相应
    佛力就是隐藏在我们心中的自力
    拿摩阿弥达布达呀
    一法摄一切法
    以深信心去修持真实念诵，如虎添翼也！
    持咒的信念
    以深信心持咒，必能与观世音的大悲心感应道交
    坚定对六字大明咒等正法的信心
    于咒生疑者，乃至小罪轻业亦不得灭
    六字大明咒所在之处，就是观世音菩萨现身之地
    将自己观想成观音菩萨之身的禅修
    观想一切众生与您一起持咒
    观想一切众生共同持咒等是密乘的重要修持方法
    一起持咒度过生命中不能承受之痛
    如何念大悲咒？
    关于准提咒
    楞严咒心的功德
    长咒与心咒
    推荐《显密圆通成佛心要集》
    将每日的呼吸转成六字大明咒的持诵
    只管耕耘，不问收获
    2、真言乘教理
    关于无表色等和实际修持的密切关系
    根本净光心是缘起还是非缘起？
    关于修念本尊
    “最细风身”与心同在
    真言起用原理之浅见
    一起踏踏实实学习这些如幻的功德吧！
    汉地古德指出的一条以华严法界观来修持密法的奇径
    对汉藏佛法谈点感想
    藏传有藏传的因缘与殊胜，汉传有汉传的因缘与殊胜
    阿达尔玛佛
    唐密中的“大圆满见”
    关于谈锡永上师谈大圆满
    介绍噶玛恰美关于行人根器的观点
    不要以为传法一定是念仪轨
    关于没有身边老师想学如法普传的密法的讨论
    过去诸佛全身舍利都在宝箧印陀罗尼中
    云何显现本有三种佛性
    一样不一样？
    关于破瓦法
    若如阿弥陀佛般忆想一切众生
    金刚手菩萨手中的金刚杵有多重？
    关于十三地之说
    3、真言的供奉和佩带
    宝箧印陀罗尼塔，末法之后佛法的保存形式之一
    装藏与开光
    关于如何佩带真言护身符
    关于打印佩带护身符
    关于佩带六字大明咒
    《大宝广博楼阁善住秘密陀罗尼轮》功德及佩带供奉方法
    4、真言译文
    《般若心经》的功德
    准提咒拼音
    阿弥陀佛心咒
    往生咒的注音
    楞严咒心注音
    楞严咒心和“五会心咒”
    大悲咒之注音
    关于大悲咒注音的问答
    一切如来心秘密全身舍利宝箧印陀罗尼
    关于宝箧印陀罗尼经
    关于灭定业真言
    谈真言新译整理的尝试
九、普贤行
    学习《普贤行愿品》来推动学华严
    关于学习《普贤行愿品》的几点建议
    学习《普贤行愿品》的推荐读本
    关于“广本普贤行愿品”
    关于令安住普贤行善知识
    关于普贤之含义
    因位普贤何时成正觉与行人根性直接相关
    凡夫应用有限的缘起知识要去实现的目标
    云何一念见三世，云何尽一切劫为一念？
    众生所以度不尽的数学解释
    我对“一切”的理解就是：一个都不能少！
    普贤菩萨对如来功德的赞颂
    对无上正等正觉的了解，可以归结为对佛功德的了解
    功德的积聚：七支行愿
    罪业忏悔清净了，本具的如来德相也就自然显发了
    关于一微尘中无量刹
    成就如来化身的因
    虚空界乃至众生烦恼不可尽故，我此忏悔无有穷尽
    随顺众生的目的
    天无绝人之路
    与普贤行愿相应
    学习《华严经入法界品》
    诵经与思维
    略谈普贤行愿品和大圆满的共和不共之处
    《行愿品》和《净行品》，《金刚经》
    若想潇洒解脱，修学普贤行愿
    关于《大方广佛华严经普贤行愿品别行疏钞》
    只要平时精进修行，心中便应无所畏惧
    将自己溶入普贤行愿中
    普贤行愿与净土法门
    关于华严法界观的学习体会
    理与行
十、译文、汇编
    吉祥狮子遗教·七钉镢
    大圆满椎击三要诀
    大手印愿文
    缘 起 赞
    汞处理的阶段总结
    英文佛教书籍选读书单
    佛教经典论著选读基础书目
    隆钦宁提见、行、果祈愿文
附：
    “中华佛典宝库”发起录入、校对《嘉兴续藏经》等佛经的活动！


《莲舟集》序言

    一、沿革

    伟大的导师释迦牟尼佛在《华严经》中反复宣说“一多互摄、重重无尽之因陀罗网”的比喻，后世无数追随者以各种视角做过解说。两千五百年后的今天，与此仿佛的互联网显现于世间。网络的出现与普及，如其他现代科学技术一样，正在改变着人类的生活习惯与社会文化。毫无疑问，网络也正为佛法的普及和资料的传播，提供了新的途径，这在历史上是前所未有的新时代。身处这样一个具有空前拓展潜力的大环境，如何利用网络的方便为佛法的传播服务，推动佛教的复兴，使佛陀的圆满教法在这个时代利益更多的众生，是作为我们佛弟子必须长期面对并参与实践的重大课题。
    大陆网络佛法传播的出现，如果以1996年佛教协会会刊《法音》杂志建立网络版为标志，到今天有八年的时间了。虽然在佛法东传中华大地两千年的历史中这一最新篇章才开始不久，但是随着整个互联网特别是大陆中文网的迅猛发展、网民人数的迅速增加，网络佛法传播从无到有，得到了长足的发展。
    1997年，湖北籍智光居士创办大陆第一个简体中文个人佛法网站“南无阿弥陀佛”。1997年底到1998年间，多个各具特色的个人佛法网站相继建立，如南普陀释本心法师创办第一个大陆出家法师的佛法网站“清净乐土”（现“法华论坛”的前身），浙江linden居士创办第一个禅宗和心密专题网站“菩提树”，留美成军居士创办第一个简体综合性佛教资料网站“网络中文佛法作品选录”（现“网海莲舟”网站的前身），四川毛堃居士创办“二十一世纪内部空间站”并开展海外英文佛教资料的翻译等。同年，由在日留学生租用服务器架设的“中华佛教论坛”开始了大陆佛教网综合讨论的最初尝试，金顶三世、越尘居士、版主智然和成军等佛教网站站长，以及其他诸多在后来对大陆佛教网产生重要影响的网人们都曾是论坛讨论的主要参与者。
    1998年底到1999年初，在取得一些编辑整理和合作校录佛教文献的最初经验以后，以上各个人佛教网站的创办人在释本心法师和成军居士的倡议下，决定联合当时网络现有的力量，共同建立“中华佛典宝库”网站，由linden居士担任第一任站长。“佛典宝库”发起后得到了广泛响应，在很短的时间里就有几十位志愿者报名校对和录入典籍。与此同期，“佛典宝库”的发起人还创办了“网海莲舟”网络杂志，这是一份综合性佛教文化半月刊物，由成军任主编，共发行二十七期，“网海莲舟”自2000年起转为以论坛和固定网站为主。
    97、98年间，中国佛教协会所属《法音》、《佛教文化》、《法源》、《禅》、《丛林》等全国及地方杂志社，中佛协综合研究室、佛教文化研究所、佛教文化信息中心、慧思德科技企业进行了“中国佛教信息网”的筹备工作，业务部分主要由智光居士和土登居士负责，筹备组于1999年1月24日（农历十二月初八佛成道日）正式发布了中国佛教信息网。作为中华佛教2000年的纪念品，慧思德公司还发行了大陆第一套正式版号的大藏经光盘，收录了七十八部重要佛教典籍的影印图片，便于读者阅读。1999年2月5日在北京举行了“中国佛教信息网研讨会”，在北京医院向赵朴初会长汇报的过程中，上海复旦大学王雷泉教授提出因特网可以佛教的因陀罗网譬喻时，赵朴初先生评价这种佛教网络化的新方向为：“千灯互照、光光交彻”。
    1999年初，由《法音》、《禅刊》等教内传统纸版刊物的电子版和“网海莲舟”、“莲池海会”（由当时网上众多净土宗网友联合编辑）等佛教网络杂志，联合组成的“佛法丛刊”以邮件列表方式在网络上每周发行，并在一年内订户过万。一年后因为邮件列表的发行方式随着电信资费的下降不再是主流传播方向，“佛法丛刊”停止邮件方式发行转为以固定网页为主，后并入“佛教在线”。考虑到可能有三分之一到十分之一的佛教网站读者订阅了“佛法丛刊”，“佛法丛刊”的一万多订户，反映了这一年里通过网络与佛教结缘网友的最初规模。
    同年，江苏szpure居士建立第一个净土宗专题网站“净土专页”，黑龙江csfx居士等建立“佛教导航”网站。1999年中，一个固定的佛教文字聊天室“新那烂陀”在刚开设不久的腾讯OICQ聊天室群组中建立，由祁家的、zs、悦华童子、古慈等网友相继担任管理员，经过近一年的实践，在网友交流氛围的建立和佛教聊天室管理方式等各方面均积累了一定的经验，对“佛教在线”在下一年里即时交流服务的建立和后来的长期运作有着有益的影响。
    1999年7月，慈氏学网站“弥勒道场”开通。在韩镜清老居士几十年来不懈努力下，作为我国历史上自玄奘大师以后最大规模的唯识学经论翻译工程，大量新译唯识学经论从藏文大藏中开始补充到汉译佛典的行列中来，并由韩老弟子陆续上网公布，2000年底由韩老弟子大千居士出任版主的慈氏学论坛开通。2003年1月韩镜清老居士以九十二岁高龄圆寂，他生前的翻译稿大部分还在由其生前所培养的翻译群体继续整理。
    1999年底，大陆佛教界门户站点──“中华佛教在线”，由土登居士在北京初步建立。其后（2000年），在与“佛典宝库”、“网海莲舟”、“佛教导航”等早期佛教网站诸多网人的协作下，“佛教在线”完成了向大型综合网站的过渡，并以佛教新闻信息和聊天室等即时交流平台服务为主要特色。至此，目前所为人熟悉的大陆佛教网基本模式均已成型，一些早期的佛教网站随即开始转型，向各具特色的综合或专题佛教网站发展。从1999－2000年开始，大量经由网上接触佛法的网友和上网的佛教信众，开始参加到录入校对佛教典籍和各佛教网站的建设管理工作中，作出许多基础性的持续贡献，渐渐形成了一支网络佛法弘扬的主力军。
    从早期的少量佛法资料收集录入和零星个人网站的建立，到“中华佛典宝库”大规模地组织录入校对和开展大藏经的全面简体电子化（《大正藏》在“台湾中华电子佛典协会”的繁体版基础上完成）和佛教类软件的开发（电子佛学词典和一些应用广泛的文字处理程序），再到“佛教在线”、“佛教导航”、“佛教天地”、“佛子在线”等佛教综合门户类站点的兴旺，以及近年来苏州西园寺、厦门南普陀寺等国内重要佛教道场网站的陆续建立，网络佛法渐渐走过了摸索和初创期而趋向成熟。目前“佛教在线”的社区注册用户已经超过10万，日访问量约8万人次，基本上可以代表当前网络佛法的规模。
    今年（2004年），在福建省厦门南普陀寺和广东省佛教协会的支持下，包括《大正藏》和部分藏外典籍在内的简体版佛典宝库光盘正式赠送发行，标志着佛法资料电子化在一定程度上已经进入了规模应用的阶段。网络佛法的长足发展，对佛教网站的功能提出了新的要求，即必须由静态的资料收集传播向动态的经验交流和指导实际修学方向转变。在这个方向的一类尝试，即是以早期“中华佛教论坛”（1998－1999年间）和后来的“网海莲舟论坛”、“法华论坛”、“佛教在线论坛”、“西方净土论坛”、“慈氏学论坛”、“南普陀论坛”、“西园论坛”、“般若论坛”、“心中心论坛”、“宁玛资讯社区”、“朗忍论坛”、“妙吉祥社区”、“科学与佛学论坛”等为代表的论坛佛法讨论。
    通过各佛法论坛以及一些附设的聊天室或其他聊天工具，网络上的佛弟子们以独立的个体参与讨论，交流思想和信息，建立联系，互相鼓励和促进，从而形成虚拟的社区甚至虚拟道场。很多实际修学乃至生活中的疑难问题可以通过论坛的交流得以解决，佛法的正知见也可以在善知识的指导和潜移默化的影响下建立。因此，从网络佛法传播出现至今，越来越多的网友喜欢上了论坛这种动态、活泼的交流方式，佛法论坛也如雨后春笋般相继建立。2002年，北美越尘居士网络言论集──《越尘集》整理出版，标志着佛法论坛这种生动活泼的佛法讨论形式从网上扩展到网下，由网络媒体返回传统媒体。今天《莲舟集》的汇集刊出，则是这方面努力的进一步尝试，也包含着编者们试图对网络佛法进行的一些总结与反思。

    二、反思和展望

    1998年，佛教网络发展之初，成军在“关于网络弘法之浅见”一文中，提出了当时佛教网站建设的以下五个主要问题：一、与附佛外道的区分；二、各网站的协作；三、佛法正知见文章的选取与甄别；四、多种汉字内码的并存与转换、五、网页的格式。时至今日，这些问题随着大陆佛教网和网络电脑技术自身的发展，已经基本得到解决。时代的进步，又对网络佛法传播的深入开展提出了更多的要求，在此我们尝试对部分相关问题作一些反思和展望。
    首先值得探讨的是网络佛法传播在整体佛教中的定位。网络作为电子时代兴起的新型信息载体，在社会精神文化的各领域有着越来越深远的影响，具有两千多年历史的佛教也不可避免地面对这一新生事物。已故赵朴初会长对於佛教网络化的重视以及在此精神指引下网络佛法传播的早期实践，代表了佛教内部分有识之士顺应时代潮流的开拓之举。网络佛法传播不但构成对传统传播方式的有力补充，而且借助网络的优势还可以发挥某些独特的作用。例如通过网络，远隔重洋的网友可以即时探讨佛法义理和修学经验，向善知识请益。佛典电子化的初见规模和佛教资料数据库的建立，极大方便了佛教典籍文献的流通和使用，只要拥有几张光盘，或具有方便的上网条件，就可以随时查询超过过去任何一个大型道场的藏书。随网络佛法传播的兴起，新一代佛教信众中相当的一部分人，恰恰是以网络的因缘，才得以接触、了解和信受佛法，这样的事例已经屡见不鲜。许多通过网络与佛法结缘并深入佛法的佛教行人，在实践佛法的同时，开始承担起网络佛法传播的建设和维护的志愿责任，可谓燃灯无尽，薪火相传。可以说，网络佛法传播正在和已经成为现代佛教的一个组成部分，并将伴随时代的发展起着越来越重要的作用。
    在不违背佛陀本怀的前提下，佛教要复兴，要在现代社会的大环境下得以生存和发展，就必须解决好两个核心问题，即契理和契机。所谓契理，是不管时代如何演变，传播载体如何变化，各宗派如何交互融合，我们所弘扬佛法的核心都不能违背佛法解脱道、菩萨道自觉觉人的本怀，也都不能有违三法印缘起无我的空性智慧。否则，牺牲法义原则所带来的任何暂时兴旺，都会给佛法的长期弘传带来极大危害。所谓契机，具体对网络佛法传播来说，表现在如何利用网络普及佛法、接引初机；如何在新时代以网络为交流平台促进传统佛教和现代社会的融合等。因为历史的因缘，社会大众的长期误解，以及佛教界自身的宣传不力，传统佛教长期被贴上迷信落后的标签，需要很好的澄清。佛教在网络上的出现，提供了一次让社会大众特别是具有较高知识背景的人士们重新认知佛法的良机。从这个角度出发，系统全面地向社会大众讲解佛法的常识，消除长期以来人们对於佛教的种种误解，并且不加回避地解答人们对於佛教的各类疑惑，是目前网络佛法传播所必须尽快予以解决的一大问题。在这个科学昌明，各种宗教、思想并存的时代，以网络为交流平台，团结教内外人士，开展佛法与科学，佛教与其他各宗教、各种哲学思想关系等问题的平等对话和深入思考，将促进佛教与现代文明各领域的融会贯通。以此因缘，必然会引导一些有缘人通过理性思考、比较与抉择，最终走上佛法的解脱之路。因此，契机契理地开展网络佛法传播，将有利于佛教获得现代社会各阶层广泛认可，特别是有利于佛教摄受更多较高知识背景的信众。从这个角度看，网络佛法传播对於佛教复兴和发展的正面意义，将和唐宋时代社会精英阶层大量入佛、民初部分进步知识分子对佛教的力图重振相媲美，从长远看，影响或许更为深远。
    在推动佛教自身义理探讨和修学实践的同时，网络佛教在与社会公益慈善事业的互动上，也将发挥一定正面作用。例如佛弟子组织和参与的网络助学和其它慈善活动，通过网络发起的护生与环保活动，网络协调助念与临终关怀，通过网络对志愿者人力资源的合理分配利用等等，现均已初见端倪。
    在肯定网络佛法传播诸多正面意义的同时，我们也必须正视网络的局限性和佛教网络化所可能带来的负面效应。佛教网络化最主要的局限性在于，网络道场不能取代现实道场，网上学佛不能取代网下学佛。随着网络佛法传播近年来的蓬勃发展，越来越多朋友习惯于上佛教网站检索阅读资料，上论坛、聊天室探讨佛法、与同修结缘。一些寺院道场和佛教界人士也纷纷建立网站，接引学人。但是，网络毕竟有其局限，不能取代现实生活。如果沉迷网络，即使是佛教网，忽视了网下现实生活中的正常工作、学习和佛法修学，那么网上翻阅和谈论再多佛法，也不能得真实利益。网络上的佛法讨论，有助于初学的佛教行人逐步深入了解佛法、树立正知见。在具备一定正见的同时，更重要的应是从三皈、五戒、十善、止观入手的实际修学。如果仅停留在网上，那么即使“见地”再高明，也都只是缺乏定水滋润的干慧，起不到应有的作用。因此，通过网络学佛，对于佛法已经具备一定了解，愿意信受实践佛法的朋友们，建议尽快在网下寻找合适的地方受持三皈、五戒，并且尽可能在现实中参访善知识修学。实际生活中善知识的言传身教，是网络对谈所无法代替的。通过现实生活中对治习气、增长智慧，在佛法上所取得的进步，也是网络上难以实现的。网络的特殊性，决定了网络上的一些言论可以快速广泛的传播。这样，如果不慎在网上造下诽谤佛法和他人的口业，恶业的增长也是自己所不乐见的，不可不慎。和网下的现实生活一样，网络佛法交流的前提，应是自身守持好三归五戒，进而深入学习菩萨戒中所蕴涵丰富的菩萨乘行人之间正面的、互助有益的修学关系。如此才能实现大众平和、积极的相处，使自他皆沐浴在和合无诤的佛陀教法中，真正得到佛法的利益。
    目前，汉地佛教的全面复兴已经略见气象，汉传佛教不仅在努力恢复历史上的已有成果，而且还发扬了历史上长于学习世界范围内各种优秀传统的开放胸怀，很多学佛行人博采众长，取得了很好的效果。历史的经验提醒我们，汉传佛法的复兴不会是孤立的，在互动中必然将会学习其他佛法体系的诸多优点，同时向其他语系提供经验与借鉴。例如，唐代在中国西藏地区的译传佛经中就有很多译自汉文经典，西藏旧译中的许多核心实修内容也是自汉族地区传入的。这种建设性的交流从来是相互的，象玄奘大师、宋惠寿大师的教学实践和回国以后的译传历程一样，通过交流努力将汉传佛教里历代祖师大德经过探索而发掘的特有深义完整而系统地发扬起来，借鉴其他传统中的有益经验，通过对佛陀教法的实践努力，将大有希望在这一时代把解脱之道更广泛深入地弘扬开来。现代多系统佛法之间双向乃至多向的交流在时间上必然是一个很长的过程，只有相互交流学习，才便于建立积极有建设性的各宗派交往和学习态势，建立积极进取平等互惠的宗教人格，促进佛教大众一起为弘扬佛陀全圆教法更好地努力。在莲舟集中，就此为主题做了一定的探讨，如中观应成和华严的交流问题，真言实修上一些运心方向等等。
    在莲舟集的第一部分所列出的四位已经逝去的大德（法云法师、慧华金刚上师、韩镜清居士、陈金浩居士），网络讣告均在莲舟首先贴出。我们纪念这些大德的逝去，同时也希望读者了解，这些在佛教内外都普遍受到尊敬、平凡而高尚的佛教行人是怎么书写他（她）们的一生的。这些逝去的大德是莲舟诸同人的师长和朋友，他们在佛教内部受到尊敬，恬淡平实地度过一生。作为主持佛教教务默默在异乡度过老年的僧侣，传承和弘扬佛教核心实修经验的金刚上师，焚膏继咎的翻译家，平凡度过一生帮助许多山村少年的佛教善知识，他们为我们佛教徒作出了榜样，使得我们对他们的纪念成为一种发自内心的声音，既是因为他们标炳的历史功绩，也因为他们没有利用在佛教中的优势地位来进行满足个人的世俗愿望的努力，一生都是一个平和恬淡的学佛人。在这里我们还想提起一位生前在莲舟论坛被质疑和相当程度的否定，在去世后则普遍得到纪念的台湾李元松先生，他临终前的公开反思和归入净土的英雄作略使我们看到另一种风景。以历史的经验看，佛教的衰落和兴起实际上还是取决与两个主要因素，即佛教行人的个人品质，和学佛人群体对佛法实践的不懈追求。通过这些，我们所想表达的是，对佛教的信仰和实践者，最重要的是准备做一个什么样的人：是为大众贡献力量并努力甘于平淡的修学过程呢，还是热衷于利用佛教来实现和满足世俗愿望？这一抉择不在于一时一地一处，而将作为内心深处质疑的声音伴随着所有佛教行人的终生，以后的路还很长，希望所有的人都能一路坦荡。
    回顾大陆网络佛教传播的建设与发展，网海莲舟的网友多是这一历史进程的参与者和见证者。在这种大环境下，莲舟论坛作为佛教网络中以教理讨论为主要特色的交流平台，开展过众多很有意义的讨论，这些资料的汇集在佛教思想发展史上将具有一定的文献价值。同时，因为网络交流与讨论所带来的在信仰实践上的动力，会形成一股合力，带动许多网友共同奋进，为佛教的复兴和发展贡献自己的力量。在新千年里，伴随着人类文明的发展和中华民族的全面复兴，相信佛教四众弟子将对社会精神文明的建设继续作出有益的贡献，祝愿中华佛教能在复兴和发展的过程中，利乐更多的有情众生。

    三、《莲舟集》提要

    “网海莲舟佛法论坛”（以下简称莲舟论坛），作为大陆佛教网较早建立的佛法论坛之一，始建于2000年初，其创始网友主要来自于各早期大陆中文佛教网站和“中华佛教论坛”、“新那烂陀”聊天室，参与讨论的既有中国大陆的佛教网友，也有相当一批海外华人留学生、学者和已在国外工作、定居的佛教网友，具有一定的代表性。他们既是佛教论坛的讨论者，也多是中文佛教网的具体建设者，在佛教网络建设的同时，也通过讨论交流厘清了一部分修学中所产生的认知。
    五年来，在莲舟论坛上开展了包括显密各宗佛法的诸多讨论，积累了很多精彩论辩和对答，对於佛法各宗知见的深入探讨和对於佛法实际修学的指导，乃至对於宗教学者从事网络佛教现象的研究，都是不可多得的宝贵资料。因此，我们从莲舟论坛大量的旧贴中汇集历次讨论的精华，特别是那些有代表性的问题与讨论，再加上本集主要作者在其他一些相关论坛（如“慈氏学论坛”、“佛法与科学论坛”、“佛教在线论坛”等）的部分发言，整理成现在的《莲舟集》。希望以此为中华佛教的复兴和汉传佛教与其他各佛教传统的交流尽一点微薄之力，同时为网络佛法的深入发展提供一些参考和借鉴。
    《莲舟集》的“人生佛教”部分，主要收集初了解佛教或者在佛门内外徘徊过一定时间的网友提出的问题和可能需要了解的参考建议。其中所选择的网友的问题，基本以正信佛弟子的人格养成为目的，做一些具体问题的解答，比如佛教行人的信念和理想到底是什么样子的，佛教行人的一生大致应该怎么走，如何在佛教氛围里与人交往，端正学佛的态度、理清思绪及如何力诫迷信等等。在这一部分的最后一节，提供了一些如果因为道听途说或想当然而产生纷扰时，如何排谴的例子。长久以来，很多不正常的说法被附会在佛教之上，加上流传中有意无意的夸大和扭曲，形成佛教的初学者在许多基础问题上会碰到的种种歧路，希望“人生佛教”部分能够以许多网人现身的经历作为借鉴，使读者少走弯路，放下学佛之初的许多思想包袱，并适当增加鉴别和抉择的能力。
    “学佛初机”部分，对于确认佛教可信、准备皈依或已经皈依、受持三皈五戒、在解脱之路已经迈出第一步的学佛行人具有一定的参考价值。比较正式的佛教修学路线，大多以树立正确的信心开始，然后如法受学和守持戒律，在从中确认了佛教的基本原则确实可以使行者获得有益的内心体验之后，调整信心，尝试一些修行的内容。向有实际经验的善知识学习、诵读和学习经典，排谴五欲诸盖、选择正式的禅修路线，开始一定的禅修体验。莲舟集的每一章中均不同程度谈到佛教的净土思想和修学体会，在此作为向初学佛的朋友们推荐的修学理路，有多处介绍，并在以后各章不断深入。本部分亦收集了许多网友在初机层面上所进行的讨论和情境交流，希望对初入佛门的同仁有所借鉴。
    文集的“发菩提心”部分汇集了在系统地学习关于发菩提心的各种教法时，所需要注意的多个要点，其中主要部分围绕着“大方广佛华严经初发心功德品”的讨论而展开。这一章节统摄以后各章及莲舟集的全部，在行进路线上居于核心地位。在文集中奉心居士做了如下表述：
    “目标的确立”相当于愿菩提心，即发起为利众生愿成佛的金刚誓愿；“学习的准备”相当于行菩提心，即发起为成正觉愿修无量难行苦行的金刚誓愿，正如《普贤行愿品》中所云“如来功德……不可穷尽，若欲成就此功德门，应修十种广大行愿”，此处“欲成就此功德门”便是愿菩提心，“修十种广大行愿”便是行菩提心，即应发起修学十种广大行的愿；学习的阶段便是在愿行菩提心摄持下，脚踏实地地修学普贤行。
    作为一个已经在修学大乘教法的行人，明显地涉及到两大问题，即在大乘佛法的环境之下受学时，面临各种互动关系和在这些情境时如何如法运心，以及在禅修上坐时如何对治烦恼等一些具体的问题，体会和解决这些问题对渐渐契入佛法的胜义是有相当意义的。“菩萨学处、禅坐略说”部分试图在一定范围内列举一些在公开范围内可讨论的内容，以便行人参考。需要提出的是，本部中的禅坐部分并非系统叙述，一些在《越尘集》中的相关章节中已经有过的叙述更为全面一些，建议读者同时进行参考。在次第禅修实践中最重要的经验，是要根据历史流传下来已经有成熟经验的学修传统来进行禅坐，在《莲舟集》中并未具体论述。建议读者同时参考佛教中相关典籍文献，并且依照一定的实修传承，在善知识指导下付诸实践，方有真正的进取之道，希望引起读者足够的重视。
    龙树菩萨所显发的中观学派作为大乘学者对佛陀著作的核心解释之一，其实践意义一直为后世所注重。《莲舟集》中观部分的编辑角度，即从因果律与随机性这一现代人较为容易把握的切入中观的视点出发，在对缘起法与二谛讨论的基础上，进一步探讨中观的学习如何与心地相应。本章从“舍离观待”与无自性教理相结合的角度出发，对中观如何用于修行实践做了一定程度的探讨，并进而拓展性地讨论超越能所与契入不二。本章的另一个特色是选编了一部分中观见在运用上的实例，并对通常的学佛实践中一系列涉及中观和无自性问题的样例做了分析，希望有助于读者在学习中观著作时引申思考，通过自己的努力于大乘般若学有所透入。
    自弥勒菩萨讲述瑜伽师地论和慈氏五颂，无著和世亲两位菩萨开展宏大深广的瑜伽行派的理论建设以来，中观与唯识就一直是与大乘瑜伽师的修学实际关系密切的学说。莲舟集的唯识章中的瑜伽行部分，主要就五蕴的辨别和认知，进行了讨论。唯识学作为大乘教法的重要组成部分，和内观有深刻和紧密的联系，“唯识里借用禅定干什么？”一文中，越尘居士指出：“如果只是看禅定境，照样是遍计执，不过外道而已。这就是大千兄所批评的。……但禅定提供了一个比平时外境能所弱，遍计轻，观察力更敏锐的状态。借这个状态与平时的差别，可以更容易看出我们的遍计是怎么积累的，怎么自己骗自己的。从而大大有助于我们找到正确方向，得到正确认识。这个过程显然与佛门的慧力有点关系。”
    “功能主义”这一词的用例来自于《越尘集》，在本集中讨论者对唯识的谈论角度进行了再次反思，提出“明确地以绝对别业作为说话的起始点，我们可以清楚地看到外境只是对一些识所变现的现象的推断，而凡夫对此推断执为真实。这就是所谓的遍计执。唯识破除这些凡夫错误见而说的唯识无境，完全不会导致断灭见。而对识所变现说为依他起则避免了常见。这种与中观从起始点就开始的不同观察角度与不同表述方式，使很多中观宗常用的概念完全不适合用到唯识的表述模式里来。而学人对这点的了解不足，是引发出若干中观唯识间无谓争议的原因之一”。在“知觉与观察”章，奉心居士和大千居士继续就这一主题的一些讨论实例，分别从中观和唯识的传统角度进行继续了具有实践意义的讨论。
    《莲舟集》华严部分的讨论得以进行到一定深度，需要感谢隋代杜顺大师。作为华严宗之祖，他深为网海莲舟诸人所景仰。众所周知，中观与如来藏系统的调和为佛教内部的遗留问题，争论历时千余年，所参与争论者根据各自的理解不同而有不同抉择，为佛教思想史留下极其丰富的一页，激起极其波澜壮阔的思想画面。轮涅一切诸法皆无自性之缘起是为中观不共之定见，但佛教中又多有宣说众生烦恼身心之中却具足如来智慧德相，从而造成许多学人在“缘起”和“本具”问题上的困惑。在这一问题上，杜顺大师以一句：“性即无为不可分别，随其大小性无不圆”料简之，奉心居士指出：“此一句乃关键中之关键。性者，即无自性性也。此无自性性乃不可分别、不可分割之无为法。一切缘起之法，无论其相有何差异，或大或小、或过去或未来、或色法或心法、或轮回或解脱，其无自性性不但全无丝毫差异，并且绝对不可割裂。”由法性的不可分别跨入法的不可分别，杜顺大师这一佛教史上飞越性的一步，将中观和如来藏会通，并顿入华严大法界中，对于一千四百年后的“网海莲舟”，产生了深刻的影响。“网海莲舟”的华严部分讨论，即以此为基点展开。
    对此，奉心居士指出：“杜顺大师以缘起正见为基石，以缘起法所显现之无自性性这一无为、不可分别、不可分割的法性为跳板，一步跨入此中有彼、彼中有此之事事无碍、重重无尽之法界。此时如以众生为此，如来为彼，则众生烦恼身心之中有如来智慧德相便为水到渠成的结论，以此中有彼故。杜顺大师上述见宗最为奇妙之处在于，如来藏不但与缘起正见无一丝相违气息，而恰恰是缘起法法性之所使然。未悟如来藏者，难说已全面、深刻地悟入缘起法之实相。由是方真知佛不妄语，对如来宣说之如来藏了义经典生起无疑定解。杜顺大师于本人的恩德大矣！”
    2001年9月，曾经在早期佛教网上发表过一些译述文献，并一直主要和莲舟网友以传统方式交流的奉心居士因为解答一个中观──如来藏问题，以华严为主要契入角度，而在莲舟论坛以“zf”的笔名开始了与许多网友的长期讨论交流，与越尘居士一起形成了莲舟论坛的一次以中观──华严的角度理摄学修的视点跨越，《莲舟集》的中观─华严─普贤行部分即选编自这些年来的相关讨论。
    本章中谈到众多以“中观──如来藏──华严”的协调系统出发，对于缘起深义、如来藏、一即一切、重重无尽、一解众解，如来遍智等概念提出讨论，并明确地论述了“见真实相者即是智慧”的概念，提出在见地基础上进一步展开实修的可行性和实践条件，即“入不思议解脱法界的窍要是了知缘起法无自性性的不可分别性”，“将对真如之理的体认由众生之举手投足、出辞吐气、起心动念扩充于如来身口意三密，其修行的核心都是对诸法不可分别性的体认和扩充”及安住实相、功德自显的反复提示。本章中所列出的有关学习的基本资料和体系之间的比较材料，在“隐与显”一节作为华严十玄门之一的部分论述，从如来藏的角度对诸法的平等性、如来与众生之间智慧与烦恼的互摄、大悲的核心主题等等，进行了广泛的论述，有利行人在扯脱于局部的缘起法时有所抉择。关于隐显问题的契入，奉心居士在一些个别进行的谈话中以“空性的无标度性”加以说明，这一以数学辅助的理解方法的若干比喻说明则可见于“现代语言逻辑与学华严”中关于中国画的谈话：
    “法是因缘和合的相”这一说法没错，但应进一步体察“相”的幻化性。“相”的基础是因缘，而因缘的本质是业力。我们认为坚固的法相，离开特定的业力就根本谈不上存在，如同梦境般虚幻。
    《莲舟集》的真言乘部分即是以华严学的讨论成果为应用范例，具体涉及了真言的修持经验，并希望以此作为直契普贤行之一例。2003年底到2004年初，在网海莲舟大众发起了关于普贤行愿品的具体讨论，论坛大众久虑华严宗之不振，能持诵者也鲜少，不忍见此无上大法留于尘封之中，于是发起了《普贤行愿品》的网络共修和讨论，《普贤行愿品》既为佛法大海一滴，即不离海水全圆之性，希望以此为门径，进而深入一解一切解之道，从此一滴深入佛法大海。普贤行一章即为学习《大方广佛华严经入不思议解脱境界普贤行愿品》资料的汇集。本集的第十部分为译文和汇编，收录了网友的一些有代表性的译文，和短篇简评。
    本书在2002年越尘集出版后即开始酝酿筹备，在2004年春起将汇集的稿件进行整理、组稿、编辑、校对历时逾六个月。在编辑过程中，对贴文进行了一定程度的节略、整理、重排、修订和核对，删去了脱离论坛环境后上下文中不必要出现的称呼和客套话等等，但对一些有助于理解对话内容的大段引文仍然保留，希望这些技术处理有助于使得全书脉络更为清晰。《莲舟集》的全书篇幅较大，《越尘集》应视为网海莲舟系列文集的第一部分，在这次的选编过程中有一部分善知识的著作因为筹备单独出版，相关的贴文未编入本版《莲舟集》，希望在网上提出要求并期待了很久的读者予以谅解，在适当时候编者会视情况继续系列文集的选编工作。如前面所提到的，网络佛法传播的深入发展，尚需要更全面的资料准备。在《莲舟集》的汇集完成的今天，系统的佛教初机知识和问答汇集、站在新时代立场对佛法与科学关系等问题探讨的专辑等，都将陆续进入编者们的日程。
    《莲舟集》在莲舟网友，莲舟历任当职版主和各友好论坛的不懈努力下，通过近二、三十位善知识的协同分工，终于完成了第一版的编校工作，其间花费了大家许多的学修及闲暇时间。编者们借此机会，向海内外、教内外众多关心和支持网络佛法传播的善知识们一并致谢，并希望能此书能够为读者在修学佛法的道路上提供一定的助力。
    普愿吉祥！贤善成就！

    网海莲舟论坛　http://www.whlz.net
    中华佛典宝库　http://www.fodian.net
    中华佛教在线　http://www.fjnet.com
      2004年9月


挽法云老法师

    挽法云老法师

    二麻子

    中国佛教界前辈法云老法师于2003年9月25日早6时在纽约某医院安祥示寂。愿法云老法师乘愿再来……
    法云法师早年追随虚云老和尚，是虚云老和尚晚年的随身侍者。老和尚示寂后，法云法师辗转多地，后到纽约。手创佛恩寺，在美国华人中弘扬佛陀教法，数十年艰苦如一日。老法师一生修学禅宗，于默照与参话头深得关要。晚年现病相，四大不调。乃断绝外缘，专心内证，豁破关垒。临行前数周，思维敏利，自知时至，更于行前三日，见弥勒菩萨亲来迎接。临行之时安祥无苦，数分钟里自在而去。火化得舍利子若干，四众惊讶。

    挽云:

    法从佛陀来,一生修习终成就
    云自慈悲起,半世辛勤为众生

    人天敬仰


纪念宁玛派圆觉宗阿奢黎慧华金刚上师

    纪念宁玛派圆觉宗阿奢黎慧华金刚上师

    佛教在线综合消息：据诺那华藏精舍相关人士发布的消息，世界佛教圆觉宗第七代阿奢黎　慧华金刚上师2004年1月26日上午8点在台湾圆寂，享年75岁。
    诺那华藏精舍发布的卟闻中说：“我们摰爱的慈母──慧华金刚上师，由于世间化缘已尽，已于二〇〇四年元月二十六日（佛历三〇三一年岁次甲申正月初五日）早上八点，收摄自心归于法界，入大圆寂。过程极为平静安详，无丝毫的痛苦或任何的障碍。示寂时，神色状貌犹如深入禅定一般。经众弟子陪伴持咒念佛十二小时圆满后，面露笑容。”
    慧华上师为江苏泰兴人，生于一九三〇年，当地一户朱姓人家。一九七三年皈依圆觉宗心印传承第六代金刚上师、莲华金刚藏吴润江上师，蒙授诸佛心印，并印证为明心见性，度母观音即身成就者，与智敏金刚上师同为圆觉宗第七代法嗣。慧华上师于一九八〇年开坛弘化，法雨遍洒，悲愿宏深，与智敏金刚上师共同建立诺那·华藏精舍，同为精舍住持，皈依弟子遍海内外。并创立“财团法人圆觉宗智敏·慧华金刚上师教育基金会”。
    一九七二年，慧华金刚上师成立“金刚赠经会”。三十余年来，所印赠之经书百余种，数量达数百万册；此外并曾印赠“佩带成佛”咒轮挂牌、各种咒轮、咒轮贴纸、佛像、陀罗尼经被、金刚明沙等法宝，完全免费普赠各界。所有经书、法宝，皆遍及国内外，利益众生，不可胜数。
    慧华金刚上师修持精湛，尤擅超度，度亡无数，凡经上师专坛超度之亡者，无论罪业深浅，多获五色舍利，此即往生之瑞相，故深获海内外显密大德之推崇。由于上师年岁渐增，众弟子为祈请上师早证无上菩提、示现虹光身，乃于一九九九年初恭请上师停止专坛超度。上师亦为能更广大利益无边有情，令得究竟安乐故，慈悲接受弟子之祈请，自一九九九年初起，不再专坛超度，而以闭关修持为主。
    一九八六年，慧华上师嘱弟子成立“诺那华藏精舍助念团”，至今在台湾已有助念团十八处，随时为亡者提供免费义务助念，多年来普受教界及各大医院极度肯定。一九九九年起，慧华上师更积极推动“一念莲华生命关怀”，由临终之前做起，尤其把握临终最后一念，为他助念，令其往生。且不自限于门下，而愿与教内、教外一切大德居士、医护天使、传播媒体等，共同来推广，愿此知见普及社会，深入人心，成为生活常识，则大众临终之时，便易于把握最后一念，念佛往生。此乃成就众生最快速简易之殊胜方便法门，推广普及，则人人都可以自度度他，同了生死，上师度生悲愿之深广，于此可见。此“一念莲华生命关怀”，乃上师无上悲愿之具体流露，亦是圆觉宗将持续推动、永不中止的度生智业。
    慧华金刚上师多年来积极拥护祖国的和平统一事业，广泛参与社会慈善事业，长期致力于佛法教学和修证，著有及与智敏金刚上师合著有《圆觉心法指归》，《返闻自性的途径》，《一念莲华生命关怀》，《圆觉宗浅述》，《大圆满修持心要》等书，为我国女性白衣瑜伽士之表率。上师于圆寂之前，犹谆谆以弟子团结和谐、共同为度生事业努力为念。
    为祈愿慧华金刚上师之悲愿智业，流通无尽如日常驻，圆觉宗将陆续开展相关的悼念活动。智敏金刚上师提示：若弟子要修法供养慧华金刚，以绿度母咒为主，阿弥陀佛圣号为辅。诺那华藏精舍台北总舍及各地分舍已设置灵堂，供瞻礼致祭，并于二月一日（星期日）下午三点整，全省各分舍连线共修度母荟供法回向。


韩老居士功在千秋

韩老居士功在千秋

    大千

    韩镜清老师于2003年1月17日下午3∶44分舍报往生，享年92岁。回顾韩老一生行愿，令人钦佩和感动。韩老是1912年生人，在北京四中读书时，就倾心佛法，皈依三宝，皈依师是常惺法师。20年代末，教界和学术界的研修唯识热潮方兴未艾，韩老醉心于佛法的广博精深，立志以此作为一生的追求。为此他决定报考北大哲学系，因为当时的北大与北京的三时学会、南京的支那内学院等，都是佛教研究重镇。1932年韩老考入北大之后，在汤用彤、周叔迦等佛学大家的指导和帮助下，学习了梵藏文等，存愿于将玄奘法师未能尽译的唯识经论继续翻译过来，完善汉典中的唯识理论体系。为此韩老精心准备，认真刻苦地学修佛法，尤其对于唯识经典，更是认真校勘，精研细究。可惜韩老实现宏愿的努力，正值壮年时被世事变迁中断了近30年，这期间虽然对于修学佛法来说，环境极为恶劣，但韩老仍然潜心琢磨，时有翻译。文化大革命结束后，韩老于1977年元月要求病退，在家闭门不出，专心继续青年时代就开始的对《成唯识论述记》校勘注释，用了十年时间积累资料对照研究，又用五年整理成文，于1992年完成了约380万字的《成唯识论疏翼》，对前人的唯识研究成果作了一次疏理和完善。此后便全力转入藏文大藏中《慈氏五颂》及其重要释论的汉译，不完全统计已翻译出60多部，约260多万字，配合玄奘法师所译的百卷《瑜伽师地论》等，基本上实现了把完整的慈氏学体系译成汉文的夙愿。
    韩老在翻译慈氏学经典的过程中，陆续提出了一些对我们修学佛法很有启发的新的思考，比如了别识和辨别识的区别，能相所相的强调，见分相分的含义等。由于韩老担心完不成翻译任务一直是在赶译，所以我们与韩老在一起时主要是协助他的翻译工作，没有多少请益的时间；又由于韩老也是处于思考过程之中，很多问题只是发现了，提出来了，有些问题也有了一些思考，但并未来得及全面细致地系统考察和深究，除了在摄论讲座上谈的一些，就是平时与人谈话时涉及到的一些，所以整理和理解韩老的思路实际上是一件需要时间和继续深入探索的事。
    从韩老总的思想发展趋势上看，他到晚年是在回归唯识古义。从佛说的唯识经典，到慈氏、无著、世亲及其学生的论典基本上属于唯识古义，陈那之后如护法等论师的论著被称为唯识新义，或称唯识今义，其主要差别是，唯识古义讲唯识无境，即世上只有心识，根本没有外境；唯识新义讲一切唯识所现，皆不离识。这是因为唯识理论在后来与小乘和外道的辩论中，被迫发展出越来越多的方便说法以接引更大范围的众生，所以唯识新义较唯识古义方便说的成分更多一些，而唯识古义则显得简洁彻底，直陈唯识本义的成分大些。开始接触唯识时，会觉得唯识新义更容易接受，但学到最后应该回归古义才更接近佛陀本怀，而实际上也只有最终通达古义，才能够融会贯通整个修行次第，看清楚各层次方便说法如何统一服务于实证空性的最终目标，并依之闻思修证，转识成智。
    韩老仿佛就是为了开发慈氏学而来，综观他的一生都是在为此准备、为此奋斗，接触过韩老的人都有一个强烈的印象，那就是他的言行都明确围绕着一个目标：开发慈氏学，其它什么都不顾，一直翻译到眼睛一点儿都看不见了，还每天坚持由助手读记的方式继续翻译。从1993年开始的《摄论》讲座一直讲到2000年底，也就是从81岁开始讲得过了88周岁，他的88岁生日就是中国佛学院的法师们陪他一起在讲座上度过的，直到他实在爬不动那短短的三层楼梯，最后一次讲座后回家时，我们连架带抱才把他送回到楼上，他自己更是气喘吁吁精疲力尽，就是在这种情况下韩老才极不情愿地默许了我们暂停讲座的请求。为了开发和弘扬慈氏学，韩老投入了他的全部精力和热忱，献出了他的眼睛以至整个身心，直到最后卧床不起时才被迫停止了翻译。在香山老年护理医院期间，直到临终前，也是处处体现着典型的韩老风格，每当有人问“你想谁呀”的时候，韩老回答的都是学生的名字，他所关心的就只有我们的校对进展、学修状况以及慈氏学研讨班的讨论情况等。别人与他说话时，说什么都是无所谓的态度，而学生们来看望他时，韩老就特别精神，一谈起佛法来，韩老总是声音洪亮有力，眼睛炯炯有神，非常令人感动。
    韩老的身体日渐衰老终至不能下床之后，各方面的功能好像较前还正常了些，原来韩老有时工作太累，会有恶心和便秘现象，卧床期间反而都消失了。韩老面色红润，神色庄严，皮肤细腻光洁，很少皱纹。去年三月份他的银白色须发开始变黑，很快大部分胡子就成黑色的了，眉毛全变黑了，头发也黑了不少。最后几天里韩老的身体相继出现发烧、心脏、肾和肺功能衰竭等症状，最终在平静如眠中安祥往生。当时韩老的呼吸越来越弱，平日韩老休息时也常有呼吸慢慢减弱到似乎听不见的现象，但后来发现韩老脸上的血色开始变淡，才知道是往生了。
    韩老出生时屋里有一股香气，母亲说他是和尚投胎。韩老平时常念慈氏菩萨，向往兜率，他给第一个孩子大女儿起的名字就叫做“念慈”。韩老曾表示，要为开发慈氏学“鞠躬尽瘁，死而不已”，生生世世弘扬下去。韩老行愿深切，以其一生历尽艰辛终于基本完成了继续开发慈氏学体系的主要工程——慈氏五颂及其重要释论的汉译工作，以此建功千秋永利众生的无量功德，我们相信韩老一定会往生兜率。我们一定遵照韩老的嘱咐，认真校对和出版全部译稿，把以慈氏六论为核心的慈氏学体系奉献给求法若渴的末法众生，并衷心祈愿韩老早日再来弘扬慈氏学，利乐众有情。


送别金浩……

    送别金浩……

    燃灯助学计划发起人和主要组织人，纽约佛教团体菩提心基金会元老陈金浩居士日前逝世。
    愿金浩先生往生西方净土，早日成就，发心再来。
    陈金浩先生生前组织的燃灯助学计划发动大量在海外的善心人士筹集款项，在国内云贵川的偏远地区积极帮助推行教育，资助了大量贫困小、中学生，使其免于失学，并在偏远地区建小学校等300余所，是一个低调而脚踏实地的助学组织。
    http://2ep.org/
    金浩先生用实际行动表现了菩萨精神菩萨行为，记挂助学计划到生命最后一刻，先生风范永垂不朽。

    2003年11月01日


学佛入手在哪里？

    学佛入手在哪里？

    成军

    佛陀的法本来是圆融一味不分大小的。大小乘只对于不同的阶段和根器，无论大小乘，根本都在解脱之道。学佛入手在哪里？在做老实人，做一个明信因果、知道自己深浅的人，愿意虚心学习，而不是到处找人印证自己从分别心出来的见解，如此堪为受法法器。然后才是归依三宝，依止善知识老实学佛。
    我们初机学人，重要的不是用自己的分别意识心强解佛果和空义，满足于自己很高明的感觉。而在认清人身难得，佛法难遇，生死无常，轮回善恶各趣种种苦难，明白唯有佛法僧三宝才能救度自己。因为明信业果怖畏生死轮回，而诚心忏悔自己过去无始以来的业障。在这些基础上发起出离心，强烈地希求修行解脱，出离轮回。如此，才是真正开始修学佛法。
    出离心是我们这些末法众生学佛的关键，千万不可以为是小乘法而忽视之！需知，菩提心是建立在出离心、解脱道基础上的。如果基于对轮回的染着所行的善法，不是真正的菩萨道，只是人天善法！
    再进一步，思维众生本来是我等的父母恩人，我们怎么能自己解脱而弃他们不顾，我们希望离苦得乐，众生也一样有这样的要求。以此基础，长养自己的慈悲心，慢慢发起菩提心。因为众生刚强难度，菩萨需要累积无量的智慧和方便，因此需要在空性智慧的基础上广行六度，方能圆满佛果。
    学佛自始至终，都是要归依三宝，依照佛陀祖师的言教，如法依止善知识，拿他们的教导用来对治烦恼，转化习气，忏悔业障。见解是用来指导修行的。而我们凡夫，没有断见惑、思惑烦恼，见解从分别思维而来，必然有种种问题。关键不在于继续用分别思维心去纠正这些问题，“寻找真理”。而在依教起修，一层层断烦恼，则智慧自现。
    说了很多，和善知识们共勉。


从自己现有的因缘条件上做起

    从自己现有的因缘条件上做起

    哈哈

    因缘果法，无常不定。学佛人视善知识为最殊胜外缘。但再殊胜，也没有自己自力自主努力学佛的心志重要。自己要学才是第一重要的。什么事都想靠别人护着，那是学佛吗？
    要效仿佛教记载中奉事大成就者的事情，在现实的条件中：
一、你能找到这样的大成就者，
    二、你得真有心去这样奉事上师，
    三、你的上师得愿意接受你的奉事，
    四、那你就努力奉事。
    这四条缺一，你就奉事不了。现在，你满足这四条吗？如果符合这四条，你不可能在这里大喊大叫。
    既然自己不是这个情况，以此为例有什么意义，需要什么样的理解？要等什么时候昏过去再醒来就获得大成就者的证量吗？可以的，等你有了上面四条的因缘以后再说吧。
    不肯从自己现有的因缘条件（实际情况）上做起，是我们凡夫修行的主要障碍之一。
    依赖心对学佛是没有什么大利益的。密教要学人依止上师，不是依赖上师。更别说对普通佛友的依赖了。你只管自己努力，这世界上善知识挺多的，多处参访请教，大概比你依赖别人要好。


理想与信仰

    yang：
    赵叔慢慢变成信仰主义者了。佛法讲正信，佛陀曾要他的弟子经过自己的验证再接受他的教法，如果没有验证就相信传播，只能算作信心增上，不是信心清净，赵叔论法，动辄大段经文，华丽磅礴，但可以实行的不知有多少？

    zf：
    一片真情，令人感动。多谢yang兄提醒，在下顶礼了。本人的确是个理想主义者──最高理想就是弘法利生，而且生生世世矢志不渝。但现在在论坛上实在是与诸兄交流学习心得，不敢作弘法利生想，原因是悲心智慧不够。
    本人的确是个信仰主义者──佛法大海唯信得入。未亲证一切种智之前，信心增上是重要动力。本人的信仰同善财童子、常啼菩萨等相比尚不够九牛一毛，今后还要努力加强。
    尽管在下目前还不能完全理解yang兄的指教，但yang兄的真心让在下感动不已，但愿yang兄早日成佛，利益我等有情。


一定要抛弃自己是一个失败者的自我意象

    dhira：
    以前虚度了人生，浪费了生命，我都30岁了，却是一事无成！！！……由于我不喜欢、更不擅长我的职业，再加上我做事不认真，没好好工作，结果事业一无所成，在单位是一个不受领导喜欢和重视的人。生活方面，我至今没找到一个对象，甚至没真正地谈过恋爱……结果不但烦恼习气一点没除，反而增加了很多新的妄想执着贪嗔痴。对一切都极其执着，看不开，放不下，生活得异常痛苦。

    zf：
    Dhira兄你现在的心情我可以理解。提几点建议供您参考。
    从上面你的自我评价看，您性格中有严重自卑的一面。在你自己的心目中，你是一个彻头彻尾的失败者。十多年前，我读过两本书──《你的误区》和《你的潜能》（作者是一位美国的心理学家，名字记不清了）。该书认为，每人的自我意象（自己对自己的评价）对自己的生活和工作起着重要作用。如果一个人的自我意象为成功者，则此人即使遇到困难，也会充分调动自己的潜能去克服，因为在他的心中失败不属于自己。反之如果一个人的自我意象为失败者，此人在困难的时候，常常自暴自弃，不思进取，从而一蹶不振。
    站在佛法的立场上看，虽然不能说“自我意象”的理论完全正确（因为一个人在世间的事业，除与自己的发心有关外，还与自己及有关人员宿世的因果有关），但自我意象理论强调的那种奋发向上（当然，他们的目标都是世间的而不是走向解脱的）的精神还是值得我们借鉴的。作为一个大乘学人，我们修学菩提心和菩萨行，要强化自己的自我意象──自己要成为一个菩萨，自己要作利益众生的事，作为佛子，所作所为不能给佛菩萨这一光荣的“家族”抹黑。密法中“本尊”修法的心理学基础恐怕和“自我意象”有关。（写到这里，感到有点偏离主题。）
    总之，建议您一定要抛弃自己是一个失败者的自我意象，而代之以：自己以往因为某些方面处理不当，事情的发展未能如意，但这不说明自己就是个失败者，只要努力，方法得当，自己一定能成功。不知那两本书现在还能否买到，你可以找来读一读。

    dhira：
    我学佛好几年了，自己读了一些佛经和佛理的书，我很茫然，很困惑，人到底应该为了什么而活着？现在遇到了一系列的各个方面的危机，不知道该如何应付，不知道自己今后的人生道路应该怎么走下去，到底应该如何去生活？

    zf：
    单从学佛这一点，将自己以前的生活说成是“虚度了人生，浪费了生命”就是很大的罪过！作为一个佛弟子，我们最大的成功就是有机缘闻修佛法。三界的本质就是苦，无论现在有多高的名望，有多么巨大的财富，这一切都不能给他们带来究竟的幸福，都不能使他们走向彻底的解脱。对于沉迷于轮回的有情，无论他在人们心中是多么成功，多么受人尊重，在佛弟子心中他都是值得怜悯的，因为等在他前面的是六道轮回无尽的苦海。只有佛法僧三宝才是我们出离轮回、走向究竟解脱的唯一依怙。“人身难得今已得，佛法难闻今已闻”，有机缘获得圆满的人身，并有机缘听闻佛法，在佛的眼中是百千万劫亦难遭遇的特大幸事，也是您宿世善根成熟的果报。万望您不要错过这稀有难得的机缘，脚踏实地，努力修学出离心、菩提心和正见，尽此一报身，往生极乐世界，方不辜负此生。
    作为佛弟子，首先就是一定要出离轮回，这是解决所有痛苦的一劳永逸的办法；在此基础上，见有无量众生，不知出离，沉迷苦海，而心生大悲，为利益一切众生发愿成佛，因为只有佛才能最有效地利益众生。这就是出离心和菩提心修法的轮廓，也就是佛弟子生活的根本目的。
    现在年轻人学佛，虽然有相当多的便利条件，如网上佛法资源的丰富，可通过网络交流心得等，但同时亦面临相当大压力。就业方面的问题恐怕是首要问题，若不认真对待，恐怕起码的生存条件都难以保证。因此建议你应对工作方面的事投入足够的精力。现在人们对所从事的工作能够真正喜欢的恐怕为数不多。我们工作的目的不是乐趣和追求名利，而是安身立命。当然在可能的条件下，选择一个不那么讨厌的工作最好。生活问题处理不好，会给学佛带来很大的麻烦，小心。
    知道怎样生活相对容易，真正困难的是要正视自己的问题，并咬牙改掉自己的弱点。
    哲学家蒙田说过（大意）：如果一件快乐的事，但将导致更大的苦果，我将抛弃；如果一件痛苦的事，但将带来更大的快乐，我将忍受。
    改正自己弱点的过程是痛苦的，这一点只能靠自己，别人帮不了忙。
    如果将来老兄发现了可以轻轻松松改掉自己弱点的方法，并切实行之有效，千万别忘了网上的各位兄弟，特别是──zf。

    dhira：
    多谢您的指点，感激不尽！ZF，您分析的非常透彻，我认识到了自己的自卑的个性。改变自己是艰难的，可是既然我想改变自己的人生，还有什么改变不了的呢？我要在漂泊流浪中改变自我，最终走向解脱。


善知识的“显现”

承勇：
    先挑一件做到，有了信心，渐及其余，赵叔觉得怎样？我也和你差不多。另外我觉得依止善知识很重要，只是一时也不知到哪里去找，苦！

    zf：
    好！另外，善知识不是没有，而要你准备好时才会“显现”。如果你是米拉日巴，你就一定会遇到玛尔巴。如果你是善财童子，你就一定会遇到文殊……观音……普贤。问题永远在我们自己一边。

    rj：
    问ZF叔一句，如果是观音菩萨，遇到的是……？

    zf：
    阿弥陀佛。

    rj：
    问ZF叔一句。如何相遇，从未分离？分离既非观世音？恭请赵叔细说。

    zf：
    我猜你说得对。

    哈哈：
    见老虎不吃自家崽，当知一切众生具慈悲，是观音菩萨显现于六道，当礼敬观音菩萨，祈请加被。见蚂蚁垒窝防雨，当知一切众生具智慧，是文殊菩萨显现于六道，当礼敬文殊菩萨，祈请加被。

    zf：
    哈哈兄，三缺一！见坛上诸兄，发大菩提心修普贤行愿，在下得知皆为金刚手菩萨显现人间！在下礼敬金刚手菩萨，祈请加被！


假装的平等也好，慢慢就弄假成真了

大海龟：
    板砖是平等的，抡谁都是包。有偈云：众生学平等，心随万境波，百骸俱舍尽，其如憎爱何？普贤菩萨云：以于众生心平等故，则能成就圆满大悲。小子近日反思，实在没学到什么平等，随造了几句平等歌，抛砖引玉吧。

    zf：
    真平等时恐怕已离佛不远了。假装的平等也好，慢慢就弄假成真了。“板砖是平等的，拍谁脸上都花……”因此，普贤菩萨只让我们“随喜功德”，乃至一念，而没教导我们往别人的脸上拍板砖。


关于福慧双修

妙语：
    认为无须修福，只注重修慧的一类人，因为有此偏执，修的慧往往不是真慧，见处不真，错了还不知错在哪里，又固执己见，又没有福缘遇到明师，难免走错路。其实修福、修慧，只是一种说法，本身不能割裂开来的。修福的同时，即是在修慧，修慧的同时亦是在修福。定慧亦同，即定即慧，即慧即定…
    如果偏执于修慧、或者修福之“见”，结果自然也会出现偏差。因为大部分人，偏于此“慧”，故在这里点出“福”的重要性而已。

    二麻子：
    麻子很是赞同这个看法。般若为其他五度之导向，但离开前五度也没法圆满第六度。排斥修福，是慧不透的一种表现。

    海印居士：
    再请教麻叔一个问题：修福修慧与因果问题。能否概说一下其次第？

    二麻子：
    麻子不觉得有铁定的次序，修福，其实更正确的说应该是修学菩提心慈悲行相一面；修慧，应该是修学菩提心智慧一面。这两面是互相促进的，哪一面暂时领先要看行人自己的具体因缘。应该都可以。但是，这两面的差距如果拉得太大，一定会减缓行人修学进度。极端者会停止不前。


苦难可以使软弱者沉沦，苦难同样可使强者更加智慧

    苦难可以使软弱者沉沦，苦难同样可使强者更加智慧

    zf

    妙音兄，麻兄和齐愍的建议都很好。下面是我的一点建议，供参考。
    一、齐愍推荐你的孩子佩带的那些真言（编按：六字大明咒，大宝广博楼阁善住秘密陀罗尼咒轮），建议您也佩带。要知道，佩带真言也是一种经典中广为推荐的有效修持方法。因此自己要在心里确定这样的观念：我是一个佛法的修行者，同时还是一位菩萨道的实践者，因为我按佛的教导佩带了真言，因此那些见我面者、和我交谈者都将因此种下解脱的种子。
    二、尝试着如是思维：
佛是真语者，佛在经典中开示的修行之道是不虚妄的。我自己现在的处境就是对佛法的见证。佛开示的因果之道表明，恶业在因缘成熟时将感得苦果，因此佛教诲我们诸恶莫作。自己前世一定做下了很大的恶业，这些恶业一定给其他众生带来了极大的苦难，使他们丧失了合法的财产、健康的身体、良好的声誉、和睦的家庭乃至宝贵的生命。如同我现在承受的苦难，我的恶业一定使别人承受至少同样的苦难。因此我不应当埋怨命运的不公，埋怨佛菩萨冷漠，而应以忏悔的心忍受今天的痛苦。
    如同恶业在因缘成熟时势不可当的苦果，我今天种下的菩提种子在因缘成熟时也将同样势不可当地感得果报──利益众生的智慧和方便。
    苦难可以使软弱者沉沦，苦难同样可使强者更加智慧。
    在负责任地忍受苦果的同时，对自己现在的思想和言行更加负责，这就是修行。
    除此之外，还可能有其他的办法吗？！


新习惯代替旧习惯，只有不懈地坚持才能成功

净心：
    磨练为何物？我觉得这个社会与我们所追求的合理性、道德性、佛法性是背道而驰的，有时候在对抗或者磨练中，个人的力量会显得有些单薄甚至受到屈辱。那，自净其意还有必要时时刻刻坚持下去吗？

    zf：
    在下浅见，人们生活的理想都是追求幸福，问题出在人们不知道只有善行才能产生乐果。现实社会中以恶行追求幸福的现象处处可见，我想这就是兄所谓“这个社会与我们所追求的合理性、道德性、佛法性是背道而驰”的原因。
    面对此现实，我们应如何自净其意？在下建议：
一、培养慈悲心
    果由因感，恶业待缘成熟时必感苦果。佛弟子见六道父母求乐反而增苦，心中不忍。故心中应时常祈愿：愿诸众生具足乐与乐因，脱离苦与苦因。
    二、向与自己投缘的人介绍佛法，最好以不发生对抗和冲突为限。
    三、在帮助别人学佛的同时，用心体会自己智慧、力量的不足。思维只有如来才能最契理契机地利益众生，因此发心成佛。
    四、要成就佛果，必积累福智资粮，我们就依据佛说，由易到难去实践吧。
    修行是以一种新习惯代替旧习惯，只有不懈地坚持才能成功。
    与兄共勉。


理想主义与浪漫情怀

    理想主义与浪漫情怀

    二麻子

    （编按：一位网友在论坛上受到网友们的批评，于是说了一些气话，本贴是越尘居士为双方写的回贴。）

    想说的正经话是，那些个别你认为可能犯小人的网友，麻子相当有信心地猜，那个什么疯子仅是您心目中的，其实绝无小人用心。相反，那个疯子说的其实是非常好的话。疯子这次的唯一不足是，这些好话不应该在这个时候对你说。而在将来，如果你学佛深入的话，终究有一天你会需要这样的经验之谈。麻子个人希望你能尽快（哪怕是慢慢地也好）学佛并深入，让你这次这里结的因缘终究都成为大家学佛的增上善缘。
    顺道也跟笑疯子兄打个招呼。嘻嘻。看到吾兄这些天的帖子，麻子很是从心底下高兴。这些帖子看上去似乎没什么，甚至还比过去似乎负面了点。但麻子在字缝里感到的是笑兄在学佛上似乎正在离开“理想主义与浪漫情怀”。麻子不敢有任何贬低学佛上理想主义与浪漫情怀的意思，但对于在离开这样的情怀后，仍然能保持学佛学菩萨道的佛友，麻子确实怀有更大的尊重。嘻嘻……也许是惺惺吧。不过这次笑兄是说错地方了，嘻嘻。这样的东西大概得对无畏惧学人才可讲，至少也得对畏惧比较小的学人才可讲呢。


人各有志，求同存异

   postman：
    一点佛学思考！学佛是为了增长福慧，福慧圆满就是成佛！福慧圆满就得大自在，大自由！！！学佛与现实生活中的追求是一样的都是为了自由！科学民主的目的就是自由嘛！！！

    智行：
    有的话有他的立场和道理，但不一定都适用，另外若误解了，则祸害无穷。菩萨很可能现科学家之身份，但那是引导世界走入佛门，并非一味引导人们去沉湎于科学发明创造。因为当今社会盲目崇拜以“科学”为名的东西，不知这些东西最多只解决此世界的一部分众生的一小部份问题，没法解决生死问题，更不知宇宙人生之大本源问题。吾辈凡夫当然应尊重科学（其实科学态度才是最值得尊重的），但不等于说学这样的科学就能成菩萨。将来再如何发展也难，因为方法错了，方向错了，用心错了，除非由科技走入佛门。要和佛法比，佛法才是真科学，适用于一切众生，相比之下现今的科学是幼儿园的水平。这就是为什么二十世纪来许多大科学家、心理学家研究佛法。另一方面，念佛简单，人人都会，看似无奇。但人人都能如法的念，人人都能出生死，作菩萨，乃至来生一生成佛，这是顶尖的科技啊！起码，愚致力科技二十多年，对此佩服得五体投地。

    postman：
    当然不应该迷信科学，而是应该具有科学精神！科学精神的精髓是探索精神、是不迷信权威、是怀疑精神、是大胆的推测严谨的验证……
    而对于许多宗教包括佛教来说，绝大多数的人都是迷信，臆测……
    利用人们的需要，迷信的人或者别有用心的人，他们有意或无意、善意或者是恶意地进行欺诈！！！

    智行：
    嘻嘻！您亲眼见过原子、电子吗？大家都相信有原子、电子，哪个不是相信权威的话？愚不相信您每件事都有用您说的科学精神！您吃饭穿衣、生病吃药、所学的科学知识不都在相信别人（权威）吗？您说科学精神是“探索”，那就先探索一下您那个能“探索”的心是什么样子，在哪里，无思无想时它藏到哪里去了？如果连这个能探索的心是什么样子都不认识，还能认识宇宙？您说科学精神是“怀疑精神”，那您为什么不先怀疑怀疑您自己这个论点？既然要怀疑就先从自身作起，看自己每一个身心所作是否有科学证据，包括您说别人是迷信，您怎么知道别人的心念？到底了解过几个人？您的抽样数量要大到什么程度才有统计上的价值？还有个问题可以想想：到底自己是谁？是身体还是那个心，若其中有一个不是自己时如何？若二者皆是，这两个“自己”是怎么粘合到一起，若此二皆不是，那么自己在哪里？这些您自己想想。别认为这些是古怪的问题，您想想若连自己都不认识自己，还能奢言探索什么？

    postman：
    心迷法华转，心悟转法华！
    佛陀号称两足尊，是福慧圆满的意思。所以他是佛。现代众生要成就。必须修福慧。对现代众生来讲，如何修证。后学认为非符合现代社会的潮流不可。
    以科学修慧，以民主修福。福慧圆满自然得大自由（大自在），大和平（大涅槃）！！！
    我不是佛门中人，作为关心佛学的门外人，我也在思考中国佛教该如何走。现在看起来佛教居士化是世界佛教发展的潮流。

    智行：
    您先把“福”和“慧”正确定义一下。

    林居士：
    postman，佛法的福与慧就只是这些？手拿一把沙而自称抓住了大地。不是也是，是也不是。

    postman：
    您可听说过六祖大师定慧一体的说法？
    福慧也是一体的哦。真正的大福报也就是大智慧啊。当然福和慧确有各自的解释，说福说慧总是方便的提法罢了……

    智行：
    您宜将佛说之福慧说一说，您我所说的福慧都不能算数，那是自己的意思，不是佛说的。既然学佛，就得依佛说。好比学相对论，就必须依爱因斯坦的说法，不然有不同就不是爱因斯坦的相对论。
    您说“定慧一体”，切莫含糊笼统。先要辨体是什么，再辨定慧，后再论定慧一体。观君之言，愚见您并未识此“体”，也未识什么是佛和六祖说的定慧。只照搬原话，并无益于解义。另外福慧和定慧并不完全一样，体虽同，概念不同，相不同，作用不同，不可牵强附会。

    postman：
    您知道你自己的目的么？
    现代社会赋予了我们不同与佛陀时代的条件，我们有理由赋予佛教相应的生命力，以适应现代社会的发展。譬如佛陀时代的出家人是不提倡劳动生产的，但到了中国。就有了农作与禅修结合的出家人。
    现代人学佛的目的是什么？是为了利乐有情，庄严国土！在这个基础上才好谈成正果、证涅槃……

    智行：
    诸变化中有不变的原则，佛法也如此，有一定的规范和不变的精神，只是用于不同的环境。中国出家人下田种地是条件所使，是生存的办法，并非这就是目的。不然农民个个都可说已经成佛。如今亦然，目前的“科学”是我们的生存手段，但不是学佛目的，不然佛一定只讲科学，不用讲戒定慧。
    在下学佛目的十分清楚简单可行：了脱生死轮回，或自行或教他行皆不离此。在下认为这才是真正的自利利他。生死问题是一切罪恶苦报的根源，不解决此问题，别的没什么好谈。看来我们目的太不同，人各有志，求同存异吧。


磕头和烧香是人们表达对佛尊敬的传统方法

HL：
    我真的很矛盾，基督教里不让磕头，不让烧香，可佛教里这是必不可少的。你说哪个正确。请指点。

    zf：
    磕头和烧香是人们表达对佛尊敬的传统方法。如果这些方法和你的生活环境有矛盾，你完全不必勉强自己去实施这些形式。表达我们敬意的方式可以是无形的。

    愿往西方莲花化生：
    下面是地藏十轮经中的一段：
假使有人于其弥勒及妙吉祥并观自在普贤之类而为上首殑伽沙等诸大菩萨摩诃萨所。于百劫中至心归依称名念诵礼拜供养求诸所愿。不如有人于一食顷至心归依称名念诵礼拜供养地藏菩萨求诸所愿速得满足。所以者何。地藏菩萨利益安乐一切有情。令诸有情所愿满足。如如意宝亦如伏藏。如是大士。为欲成熟诸有情故。久修坚固大愿大悲勇猛精进过诸菩萨。
    今天我遇见一位居士，问我这段作何解？

    zf：
    若有人闻上所说，对地藏菩萨生起无比信心，至心归依称名念诵礼拜供养，在下随喜。但在本人心中，文殊普贤观音地藏在功德上并无大小的差别，差别的是不同众生与他们之间的缘分。


礼佛随笔二则

    礼佛随笔二则
zf

    一

    网海莲舟向蓝毗尼圣地献花的照片

    前些天借工作之便，在下在尼泊尔朝礼了不少佛教圣地，并瞻仰了佛陀的出生地蓝毗尼和家乡迦毗罗卫城遗迹。
    在尼泊尔之行前，版主托在下将一袋干桂花带到蓝毗尼，以表达网海莲舟上所有佛子对佛陀的崇高敬意。在下圆满完成了版主的任务，有照片为证。照片中的雕像再现了佛陀降生时的情景，是蓝毗尼的标志之一。

    （2002年）

    二

    佛法利益众生的方便真是不可思议

    去巴基斯坦之前，没想到可以看到佛教遗迹。到那里以后，才从书中了解到许多非常著名的佛像都被妥善地保存着，如两尊著名的Fasting Buddha像（苦行中的佛陀），一尊保存在白沙瓦博物馆，另一尊保存在拉合尔博物馆。在白沙瓦的Fasting Buddha像前我献上了鲜花。在拉合尔，当我带着鲜花来到博物馆准备朝礼另一尊Fasting Buddha像时，当日博物馆不开放，遗憾。我便将博物馆观想为承含佛像的宝塔，将鲜花放在大门旁。
    “法王塔”Dharmarajika stupa，也称为“大塔”great stupa，是巴基斯坦境内一处极为重要的佛教遗迹，世界文化保护遗产。据一本书中记载（其可靠性无法断定），此塔当时是印度第二个最神圣的地方。下文中亦提及此塔。
    法王塔现在看起来真的象个大土堆，如宝箧印陀罗尼经所说，“如朽土聚”！我为此塔献花后，绕塔三周，心中诵念宝箧印陀罗尼作为供养。陪同的巴基斯坦同行瞪着大眼睛看着我这个异教徒的“偶像崇拜”举动。
    佛法利益众生的方便真是不可思议。当我看到那些在博物馆中参观佛像的巴基斯坦中小学生、在法王塔附近游览的穆斯林时，我真的为他们高兴，因为以此因缘，他们将来与佛法的因缘一定会逐渐成熟，并最终走向解脱！
    （2004年）

    附：
    【呾叉始罗】
    西北印度的古代都市。希腊语谓之为Taxila。汉译又有德叉始罗、竺刹尸罗、石室国等名。其范围横跨印度旁遮普省与西北边境地区。自古以学问、技艺发达而闻名。西元前326年，遭亚历山大帝入侵，其富裕景况因此为西方所知。又相传阿育王为太子时，曾任此地总督，故佛教在当时可能已经传入。西元前二世纪，大夏的希腊人入侵，建设新都市。复受塞（Saka）族、帕西亚（Parthia）族、贵霜族所支配。在此等外族统治时代，佛教文化兴盛，市内外皆有颇多佛教设施，与西邻的犍驮罗同属佛教美术盛行地区。
    西元230年左右，因伊朗的萨珊王朝占领此地一带，致使佛教文化一时中断，至四世纪末，始由贵霜族再兴。五世纪中叶，本市及附近的佛教伽蓝又遭咽哒族所破坏，自此未恢复旧观。
    此地有三个年代不同的都市遗迹，其时代约在西元前五世纪至西元五世纪之一千年间。这些遗迹所在目前都是村落。
    （1）位于比尔（Bhir）山丘的遗迹。由四个时代层（西元前五至二世纪）构成，系属自然形成的都市。
    （2）位于西尔卡普（Sirkap）的遗迹。由七个时代层（西元前三世纪至西元一世纪）构成。外有高峻、坚固的城墙围绕，内有王宫、佛塔等建筑。市民所使用的器具兼摄希腊及印度二种风格。系仿自希腊城市，具有高度生活文化的计划性都市。
    （3）位于西尔苏夫（Sirsukh）的遗迹。为有半圆形棱堡之城墙所围绕的大城市。在构造上，与贵霜族建于中亚的城市类似。然仅有部份被发掘。
    附近除了有绛迭尔的祅教寺院遗迹之外，亦有法王塔、卡拉旺、基利、摩拉摩、阇利昂等佛教伽蓝遗迹。
    依《大唐西域记》卷三所载，呾叉始罗是北印度古国。该书云（大正51·884b）︰
    ‘呾叉始罗国，周二千余里，国大都城周十余里。酋豪力竞，王族绝嗣，往者役属迦毕试国，近又附庸迦湿弥罗国。地称沃壤，稼穑殷盛，泉流多，花果茂。气序和畅，风俗轻勇，崇敬三宝。伽蓝虽多，荒芜已甚，僧徒寡少，并学大乘。’
    此地自古即以北印度之高等知识传播地而闻名。在巴利语《本生》及《真谛灯论》等书中，曾记述梵授（Brahmadatta）王子等人来此研学。相传文法家波你尼及大医耆婆亦曾于此地受业。此外，《大唐西域记》卷三云，大城西北七十余里存有医罗钵呾罗龙王池，池之东南三十余里有无忧王所建之窣堵波。城北十二、三里处有月光王舍头之胜地及经部拘摩罗逻多撰诸论之僧伽蓝。城外南山也有无忧王子拘那罗抉目之故地等历史名胜。
    ［参考资料］　《杂阿含经》卷二十三；《大庄严论经》卷八、卷十五；《捺女只域因缘经》；《蓱沙王五愿经》；《贤愚经》卷二〈降六师品〉；《大悲经》卷二〈持正法品〉。
    【中华佛教百科全书】


达则兼济天下之说的眼光尺度

    TZ：
    用佛教因缘观思考大乘佛教在中土光大，中国文化中本就有大乘之因？

    二麻子：
    抱歉，题目太大太大……大乘之因不仅仅中土有，各地都有。你看现在佛教全世界都有，主要也都是大乘教法。但中国从古就有达则兼济天下之说，所以眼光尺度在那个时代应该算是大的。


我们应该感谢众生，是众生给了我们积福的机会

    我们应该感谢众生，是众生给了我们积福的机会

    成军

    从世间法的角度，我们每个人如果都能做善事，帮助别人，世界就会祥和美好，这个道理三岁小孩都知道的。
    以佛法说，五戒十善是大小乘各宗佛法共同的基础，大乘菩萨道行者更是以种种的方便来利益他人。做善事利益他人，一方面是因为我们在生生世世以来，众生与我们互为父母亲眷，有无量的恩德；另外一方面，我们也可以通过善行的积累，改变我们的心行，使我们心中对自我的执着淡一些，对他人的关爱多一些，从而增长智慧，去除贪着，逐渐走向解脱。从这样的角度思维，做了善事，最理想的当然应该如金刚经里面说的，“菩萨不住相布施”，如果一时还做不到，那么就以这种“心头美美”的感觉，鼓励和促进自己的下一次善举吧。但是切记，我们做善事，万不可扬扬得意，不是众生应该感谢我们，而是我们应该感谢众生，是众生给了我们积福的机会。


致文森善知识：关于皈依三宝。

    文森:
我愿皈依三宝，弘四愿，修三福，以无退转，且望妻子亦都能皈依，惟尚须禀明二老乞请同意，亦须与妻商通。再者我并不知悉寺院内部事务，不知哪位大德能够慈悲介绍一二，我现在就近之寺院为厦门南普陀寺，哪个机构可接洽此事？

    成军:
皈依三宝不同于出家，不需要非得父母同意才可以。当然，父母和妻子都能支持您学佛，乃至全家共同修学佛法，成为佛化家庭是非常理想的修行助缘。
    据后学了解，一般来说，寺院的出家师父授三皈依不像授戒，不要求特别多的条件，如果当时不能给您立刻授三皈依，那么则是在一些固定的日子如佛菩萨圣诞，不需要等很久。
    后学所知的在网络上弘法的南普陀的出家师父有好几位，有时他们也会来这里或者法华论坛和中华佛教论坛法布施。因此，您可以在论坛上设法和他们取得联系，然后再在电话或E-mail里面详细谈皈依的事宜。
    南普陀据说是目前大陆出家师父最多的道场，很多人对那里的评价都很高。您如果有缘依止那里的出家法师学佛修行，相信一定能受益匪浅。

    法华论坛:
善知识好。归依三宝非常自由。
    归依三宝在古时是非常自由的，据经典介绍，很多善士遇到佛陀，立即被佛陀庄严圆满三十二相和无边慈悲智慧感摄，启发宿世善根而归依三宝，由此种下菩提之因，或者于菩提之路起程，必终至究竟安乐、圆满菩提。
    现代社会，因为大家对智慧修行和佛教缺乏了解，出于孝敬尊长和尊重师友的发心，很多善知识归依三宝预先征求父母师友等人的意见，这非常好。但如果父母师友反对，善知识不必放弃正确的道路，可放心归依，乃至受持五戒，并发愿成菩提时度化眷属及一切众生，这样必定利益无边众生。归依和五戒不会与普通的世法有大冲突。
    建议选择戒行严谨、道风纯正的寺院参加归依仪式，例如青岛湛山寺、浙江多宝讲寺。如果离这样的寺院比较远，只要归依仪式如法，可放心归依。归依三宝不是归依个人或寺院，是归依十方一切三宝、归依三宝殊胜功德、归依自性觉正净，归依师是归依的见证人。归依和五戒的详细介绍，请见圣严法师《戒律学纲要》（成军和文觉善知识主页有《戒律学纲要》），以及净空法师“三归依的意义”。

    拙:
阿弥陀佛！善哉！后学有幸得识南普陀寺的几位首座大德。文森善知识愿意归依三宝，后学愿为引路人。

    文森:
感谢各位大德慈悲照顾，我将有缘得“拙”善知识引荐拜见佛师，欢喜之余向论坛各位禀报，皈依仪式拟于春节过后携妻共同于师前完成。望此论坛越办越好，直至使众生广开所见。


归依佛门不等于出家

quote：
看过了太多的悲欢离合，看过了太多的虚伪.....如今，只想归依佛门清净地，修生养性。但却不知道应该怎么样出家，去哪里出家才会收留。怎么样才能表示出家的诚心呢？

    成军：
    归依佛门不等于出家。只要真心修学，在家修佛一样能够成就。
    无论是出家还是做在家佛弟子，您首先都要明白佛法的基本道理。为什么要学佛？为什么要出家？这个问题如果没有解决，盲目出家，结果只会适得其反。
    从您的情况看，也许还是应该先找到有出家人住持佛法的寺院，受三皈五戒。随着对佛法的深入了解，再决定是否出家。但是您必须清楚，在这个不圆满的娑婆世界，佛门不是避难所。如果只是对俗世失望，“看破红尘”而出家。未来面对寺院里面的一些不圆满，您该怎么样？出家的发心应该是为了摆脱世间的纠缠，勇猛精进地修学佛法，作为人天导师，以清净梵行，住持和弘扬本师释迦佛传下来的清净佛法。以如此发心出家修道，将来遇到种种障碍才不会轻易退转。


礼敬是皈依的基本含义之一

    zf:
“1、是不是以后我见了出家人就要礼拜？”
    ──在公开场合，表示应有的尊重就可以了。好像没有人要求在马路上见到出家人也要礼拜。

    “见了佛像就要顶礼？”
    ──在寺院里顶礼佛像是很正常的。开始时你如不习惯，在心里顶礼也可以。

    “2、我还可以读一些其他的书吗？”
    ──我们每天都在读其他的书。

    “是不是还可以接受一些新的其他的思想观点？是不是还能拥有开放的思想和心态？是不是其他的思想观点就是‘外道’？是不是不能认为佛法之外还有其他的真理？”
    ──佛法的真理观可以分两个层面；1、绝对的层面：这当然只有佛的教诲中才拥有。2、相对的层面：日心说比地心说好；民主比专制好。佛教不是要将人变得孤陋寡闻。

    “3、我读了网站上学佛行仪一章。感觉有一种身心被束缚的感觉。我害怕，我从此变得拘谨。那些规矩，实在是太规范人了。”
    ──如果你正确地理解了“规矩”，你会感到受到保护，而不是伤害。

    “4、我对佛法还可以有自己的理解吗？还可以独立思考吗？还可以质疑批判吗？”
    ──质疑批判的前提是充分的了解。没有充分了解基础上的批判，不要说对佛法，对任何事物都是不恰当的。

    ……向您推荐一本书：
“佛典宝库”网站之“藏传佛教典藉”中的《修行之道》【泰·锡度仁波切】。看看一位当代的大菩萨是怎样说的。

    落泪的雨：
    我认为三归依。其中的道理是需要很久才能真正可以完全地做到的，有谁能帮我做到呢？

    zf：
    佛子要在三皈依上用功的“期限”是：从现在起，直到成佛。能帮助你的，就是你要皈依的对象：三宝。否则，我们为什么要皈依呢？？

    净国：
    皈依的含义虽然不止于“礼敬”，但是礼敬却是皈依的基本含义之一。皈依佛，皈依法，亘古及今的佛弟子自然都没有什么异议。对于僧宝，则大大不同，“二宝居士”（皈依佛宝，皈依法宝）的说法，也由此而来。
    有帖子提到皈依僧伽，是皈依整个僧团，而不是皈依某个出家人。因为僧团代表的是佛、法常住，所以皈依僧也就是皈依佛，皈依法。
    我认为需要补充的一点是，僧团是佛、法的代表，所以我们皈依僧（团），但对于在家居士而言，每个出家人都是僧团的一员，所以我们应该礼敬。
    前几日小可有幸在纽约庄严寺盘桓几日，并有幸见到沈家桢老居士。对于皈依僧宝，沈老为我们上了生动的一课。当时我和同行的几位师兄正在斋堂用餐，才出关的庄严寺方丈首愚法师也在斋堂。沈老步入斋堂，见到首愚师，顶礼下拜，众人扶起。
    沈老居士是大家公认的德高望重的大善知识，如果论“辈分”，首愚法师比沈老居士还要低一辈。但首愚法师是出家人，代表的是僧伽。看到沈老居士在八十多岁行动不是很方便的情况下给首愚法师顶礼的场面，我的慢心也去了好多。


关于鸡鸣寺的点滴回忆

    关于鸡鸣寺的点滴回忆

    成军

    读书的时候常去鸡鸣寺，离学校走路不过20多分钟。去鸡鸣寺最好的时候是雨天，站在山上，看着烟雨蒙蒙，品味“南朝四百八十寺，多少楼台烟雨中”的诗句。如果是春天去，到鸡鸣寺的路上还有盛开的樱花。
    鸡鸣寺的十六尊者画像特别独特，一位位神态各异，乃是后学的皈依恩师上圆下霖老和尚所画，有传说他老是在定中一一观想诸尊者的形象，然后画出。
    鸡鸣寺的佛经流通处书非常多，当时所看的多数佛书是那里请来的。在没有网络佛法的当年，加上金陵刻经处，南京居士学佛的图书资料条件可谓得天独厚。
    南京寺佛协也在鸡鸣寺办公，有机缘的朋友可以去亲近对唯识学颇有研究的刘大任居士。
    每逢观音菩萨生日、出家日、成道日，鸡鸣寺就人山人海，从半夜到第二天下午。曾经在善知识带领下，帮忙卖过几次门票，感受到很多老人对佛菩萨那种质朴的情感。至今印象尤深的是一个老奶奶，天刚刚亮的一大早，牵着稚龄的小孙女，打开兰布手绢包的一叠零散角票，买门票的那一幕……
    据说鸡鸣寺的主持老师太修证很高，可惜当时不知道亲近，甚憾！听说老师太去世前，对人说她下一世还要来，要转到个穷人家做男孩子。火化时，舍利和瑞象很多，而且灵车返回寺院时候，还有人拍照到车前阿弥陀佛的显像。照片后来我也有缘见到。
    临毕业时，曾在大学里面募捐了几车衣服，托鸡鸣寺的当家师父拿去济贫。师父说，要设法送到甘肃最贫穷的定西县去。
    转眼八个春秋过去了，不知道现在是不是还有很多如我当年般的学佛青年，在烟雨中朝访鸡鸣寺，在观音菩萨的32应身前面一一顶礼？


寻师且等慢慢自己稳定下来再说

    白云深：
    看过诺那祖师的问答录，我真是对诺那祖师喜欢得一塌糊涂。感觉祖师真是知心人，句句都说出了我的心里话，请问哪里有诺那祖师的传承和像诺那祖师一样伟大和蔼知心的宁玛圆觉宗上师啊？请麻叔和林居士帮帮忙行吗？

    二麻子：
    有什么要帮忙的？诺那祖师传下的法脉，麻子当然知道些。麻子自己就是沐此传承法惠的。
    但就白兄现在而言，就是知道哪里有这传承的上师，又如何呢？兄现忙于搜集大德，心态看上去多少有点象集邮，虽也不坏，深究起来，大概尚偏浮躁了些。不妨等等，慢慢自己稳定下来再说。话有点重，包涵。
    说到和蔼，麻子有点想笑。祖师智慧、慈悲、威猛等尽有之。若讲和蔼，却要看对谁说。据俺耳闻，祖师对越是具根器的弟子，越不大和蔼呢。不知白兄寻择上师时，和蔼是重要条件吗？一笑。

    林居士：
    支持一下。大锣大鼓的倒像寻人追债多于在找真正上师。
    有一个方法是念四归依，十万十万的念。或者是祈请传承祖师，如宁玛的便祈祷莲师等。不过需要有很猛厉的信心和恭敬心。一般人的信心程度可能远不够。
    麻兄说的上师相我就见过一个实例：同一个仁波切，两次见面有不同的人在场，一次温和可亲，慈祥软语，第二天严肃的吓人，不怒自威，我几乎连大声呼吸也不敢。听知情者说，他是金刚手菩萨的化身，后者才是显露真本色。
    关于密乘上师的一些杂想：藏密传统上，拜师前通常要师徒互观，一些论著亦有解释如何选择上师。如法如理行之，当可无咎。观察以后便要有决定见，不再被任何人任何话动摇。纵天下满是伪师于己亦无碍。并无必要对各师多加评论，免有误犯自赞毁他之菩萨重戒之嫌。
    最终主导找到何种上师的主要是宿业和菩提心，不在乎你问了多少人，或查了多少书或网页。宿业既已过，故当常开展菩提心，并向传承的成就祖师（如宁玛的莲师、龙清巴，噶举的密勒、冈波巴、噶玛巴等）猛厉祈请，则纵一时找错，也绝不会走得太远。
    上为通途。
    现今密宗冒滥师多是事实，证量未到而传法者也必有之，未真获果证而以光影为号召亦有之，不然怎算末法？（不过证量与年龄却是两回事。）那就更显得拜师前如理观察的重要了。（大小活佛什么的就请别问我，反正活佛只是汉人作出來的名称，懂汉语的藏人用之也只是随顺汉习。难道还有“死佛”不成？）比例怎样就不得而知了，但其实不重要，因为拜师不是随机抽样，乱打乱撞的。
    除上述通途外，也有别格。有些与密法有深缘者实非始自今生，乃宿缘所追和往昔护持密乘三昧耶所致（如《胜利道歌。天鼓妙音》云：“吉祥普贤同缘分”），在缘熟时便会遇到宿生的上师，获传过去生已曾修学之法，以速得成就。此种情况通常在遇到上师前后会有特殊感应或梦兆，又或在初见师时有特别觉受。如古德传记中例可见：密勒日巴祖师之遇马尔巴，冈波巴祖师之遇密祖等。当然，纵有宿缘，亦得如法栽培开发才能成熟，方法亦不离上面通途所述者。
    常有一些想法就是上师必定要有极高证量，不然就只能修到上师的水平而止，不能得大成就。先不说此想法中的所含的我慢，有一大错误是不明白上师作为加持根本，所能赐予的是从法身佛以下不间断的传承祖师的加持。即使上师未成就，弟子也可成就，只要传承中没有被违犯三昧耶所污染，弟子以清净信心就能接受从法身佛开始的传承加持，像一条没有被堵塞的大河滔滔流下来。藏密常强调清净传承为成就的要素就是为此（可别看漏了弟子的清净信心是接受加持的重要条件）。
    藏密中有两著名的例子确保传承清净（只是举例，当然也有其他清净传承）和不间断的强大加持：
一、宁玛的伏藏传承。由莲师二十五大弟子受莲师命在千百年来的不同时空转生为伏藏师，因应众生业力和根器开启莲师亲传的教法，将该法传承缩至极短。例如晋美彭措法王亲自开启伏藏传出來的教法，计起来得法学人只是莲师再传。修不成就也不能怨人了。
    二、噶玛噶举的黄金念珠传承。由没有丝毫隔胎之迷、经释尊和莲师授记行诸佛事业的圣者噶玛巴，以自我认证转世的方式确保珍贵的传承清净如黄金念珠。每一世的大宝法王噶玛巴均具足最高证量与加持，与密勒日巴再传、冈波巴亲传的三世智杜松虔巴无别。
    结说一句，与其担忧世上没有好上师，不如担忧自己的业和菩提心未清净，接不上去。若条件够，佛菩萨一定会加持遇到真正上师的。


在美国中部想三皈依，当去何处？

    未曾有：
    北美三皈依，当去何处？我在美中，想尽快三皈依，作个正式的佛弟子……哪位大德善知识给在下指个去处？？

    成军：
    归依是归依三宝，在僧宝即清净的出家比丘前归依都可以，目的是请归依的师父为自己在三宝前做个证明。
    事实上，不是归依的某个人，而是归依的全体十方常住三宝。而这位替你归依的师父，则是你在三宝那里的证明人。
    美国中部的寺院不是很多，似乎比较知名的就是净空法师在德州达拉斯的道场。东部纽约有好几处道场（如美佛会的庄严寺），西部加州也有（如佛光山的西来寺）。
    以您所在的位置，就近找一处吧。事实上，三归依在任何一位比丘处都可以。因此即使在小型的精舍也可以归依。

    二麻子：
    到纽约去，那里寺庙很多……庄严寺，大觉寺都好。


在新的环境如何学佛

    在新的环境如何学佛

    林居士

    会修心的，什么地方都可以。不然，纵在佛的身边也是没有用。
    关键其实不是地方，而是外在环境的大转变会否影响学佛的心境。那是常有的事；我曾经试过在七、八年之间搬迁，多于平均每年一次，过半的距离超过一百公里。因这些事而退步已曾经历多次，多是因为劳累数周后提不起精神和体力；坦白点说就是“懒散”。其实目的地的环境怎样只是次要的，若能把无常、因果、菩提心等教授时刻放在心里，随力随缘不间断地做简单的定课，那就一定不会退步的。
    如果修行要依赖外面的人物环境（如某道场或同学）而维持的话，那就表示尚未能把佛法融进心里，作为自己思想行持的不可分割部分。不要太害怕，即使与善地善友分离，无常就是这样的了。只要用恰当的心态处理各种变化，那种种变化也就能成为修行上的历练。观照、忆念就是随传即到的修行良伴。而且在北美，清净的道场、良师、益友其实多着呢，自己若能努力于内心的清净就会有因缘碰到的了。
    起伏顺逆是人生难免的，这是佛法最基本讲的无常。只要深信因果就不会灰心，因为知道不好的境遇都是在还业债，还一分就轻松一分；只要坚持行善去恶，未来就只会改善而不会比原来的情况坏。坚信三宝为三界中之解脱依怙，那不论处于任何逆境都会祈请三宝加被而不觉孤立无援。再就是从自己受的苦难而想到其他众生也同在世间受苦，进而生救拔之念，这就是发菩提心。
    要在困难中维持这些正念并不容易，因此就有用定课来洗刷心地的必要。加以在任何时地尽量提起常念的佛号和咒语会更有效。
    最后提醒你一个宝贝：放生。放生是我们凡夫要改变宿业最快的方法。多看感应录就会知道古往今来很多例子。尽力多放、常放、劝放、共放；自然除了出世间的功德外，世间法也会慢慢顺境如意。
    祝吉祥！


佛法的大门是向任何人敞开的

    苦恼中：
    请问，同性恋者可以修习佛法吗？我是一个同性恋者，能否修习佛法呢？我的固定伴侣也有这个疑问。毕竟现在新制订的疾病诊断标准中也不把同性恋列为精神疾病了，可我们不知道，在佛制中，对同性恋有什么论述呢？像我们这样固定伴侣，类似夫妻的，可以以居士的身份修习佛法吗？

    zf：
    当然可以。从佛法利益众生的大原则上讲，佛法的大门是向任何人敞开的。因此任何人都可以修习佛法。
    由于寺庙通常将皈依和五戒一同办理，同性恋行为会被划入邪淫的范畴。因此建议你尝试以下两种途径：
一、皈依三宝，并接受除邪淫以外的四戒。（有见过皈依三宝和接受除酒戒以外四戒的情况。）
    二、或只皈依三宝，先不受戒。
    另外，如果当你把自己的情况讲明，在寺院办理皈依等手续遇到困难时，不妨先把“办理手续”的事情放一放，多读点介绍佛教的书，在心里多念“南摩观世音菩萨”（意为皈依观世音菩萨，祈请观世音菩萨拯救自己）。观世音菩萨曾发下大愿：众生当以何身而度，其即现何身而为救度。对同性恋者，观世音菩萨以其无碍的智慧和无缘的大悲，一定会有自己的善巧方便而为救度。因此要相信观世音菩萨，把自己交给观世音菩萨。
    学佛的根本目的是追求解脱，什么人能剥夺别人追求解脱的权利呢？！


大学生如何学佛？

    音耀：
    大学生如何学佛？作为一个医学生，专业课任务繁重，归依佛门机缘总是不巧，请各位善知识指条明路。

    成军：
    没有看明白您的意思。您皈依了吗？如果还没有皈依，可以在附近有如法的出家法师住持的寺院先行皈依三宝。
    如果您已经是佛门弟子，当然最理想的是按照师父的教导来学习。后学个人的建议则是：

教理方面，可以从一些浅显的入门读物和比较好懂的佛经开始，逐步树立正知见。后学网站的相关资料可供参考。
    实修方面，应该在条件可能的情况下，尽早受持五戒。如果一时没有能够指教指导您的善知识，不妨实践念佛法门，这方面，有净土五经和古今大德的很多论著可以学习。
    上大学功课可能比较紧，但是每天抽出一段时间来读经和念佛，应该还是做得到的，就看您如何合理安排时间了。

    tyro：
    大学生的闻思比较敏锐，所以应该先看一些佛经，了解一下佛法的基本名相和义理，利用自己比较敏捷的思维多多闻思。可以用质疑和辨析的方法去学习，佛法提倡质疑和辨析。
    如果心中装着很多的东西，既要实现这样、那样的目标，又要追求美好的理想，那么就会有很多的烦恼。当然一下子放弃这些也不可能。可以慢慢地将自己的心境放平和一些，对一些东西不要太执着了。


学佛从何处入手？

    风来疏竹：
    学佛以来颇为迷惑，不是对佛法有怀疑，而是实不知如何择法深入。有人告诫以戒律入手，有人告诫但持阿弥陀佛，有人告诫要以禅宗明心见性为要，当然还有人劝诫速速归依上师为要务。哎呀，这可是把我难住了。八万法门哪个适合我呢？我如何入门呢？

    二麻子：
    麻子的看法，仅供参考……
    佛法告诉我们，因缘所成法，无常不定……所以，学佛入手处人人不同，难说固定格式。不过，比入手处更入手处的是主观上开始有学佛的动机和动力，佛友看起来已经有了，这个麻子实在随喜。其次，是皈依受戒，不知道佛友有要做的动机吗？或者已经皈依受五戒了？
    这些有了，先找几本佛经，也别管哪本，看起来再说。看着看着，就开始入手了。

    断痴：
    各位师兄，我刚发心学佛，请问如何选择哪一宗啊？我老哥学的是心中心密法，我本人有点喜欢禅宗，但我妈妈又说只要至诚专修，净土是一定可以往生。请大家给我一点主意，或者我把各宗的修行旨要都看一遍，看看哪一个适合我可以吗？

    zf：
    真为您高兴，有个佛化家庭！上路之前，最好先看看地图，对几条路的大概情况有个宏观了解再走不迟。

    有网友问:
    对佛教了解不多，去藏区旅游时和一个藏族僧人认识了，后来旅行回去他还联系过我，来我这里的城市，后还有一些来往，是不是有特别的因缘？

    zf：
    关于您的际遇，在下没有了知过去世种种因缘的宿命通，因此无法对您的际遇给出具体细致的说明，请原谅。
    如果因为这件事使您增加了对佛教的了解和好感，您应该感谢这位藏族僧人。如果您要进一步发展和这位僧人在法上的关系，我建议您还是按照传统，花相当长的时间（数年）来观察他，向其他大家公认的佛教大德了解他的传承情况，同时他也需要观察您。长期的观察是必要的，如同婚姻一样，闪电般的结合常常不能持久，而且会留下很多烦恼。
    另外，您为了提高自己的观察力，应该多了解一些佛教的基础知识。这个论坛上的许多网友见多识广，您若有疑惑时可以到这里来交流。论坛的一个好处是公开，大家都犯同一个错误的概率毕竟要小一些。


分清个体的行为与团体意志

    分清个体的行为与团体意志

    二麻子

    “在佛门弘法利生当中，有价（钱）归依是否可取？除收取工本费外。若是可取，我宁可不归依！闻一位佛教前辈说，宁可捐一百万建庙，也不可坏了清净的三归依。”
    ──嘿嘿。我告诉你几句……
    如果你在律师事务所签署了法律文件，如果给你做证明的律师犯了罪，哪怕后来给开除出律师行业，你签署的文件仍然有效。因为，使你文件有效的基础是法律，不是律师。律师不过是见证。
    同样，你皈依的是佛法僧三宝。这里僧宝是僧团，不是个人。个人在这里起的作用是作证。
    所以，你最好想清楚这里的关系。个体行为，哪怕是很多个体的行为，与团体意志是两回事。虽然后者的形象受前者的影响。


云何使现世众生生起正信？

    云何使现世众生生起正信？

    成军

    后学个人以为，于佛法生真实无伪的信心，是需要很大的福德因缘的，以我们这些末法时代的凡夫初学，指望一步到位是很难的。但是，无论多难，路是人走出来的。正信，乃至实信，都需要逐步的培养。培养的方式，就是从三皈五戒十善入手的次等修学，随着您对佛法义理的深入了解、也随着您持戒念佛诵经得到的法喜和轻安，您的信心就会慢慢增长，您也会渐渐体会到和佛菩萨的相应。
    另外一个要点，是要积极争取和创造机缘，在实际佛法的修学中亲近善知识。因为佛经的文字是死的，人则是活的。善知识们以身作则，以言行为我们展示活生生的佛法，这种感召力是别的方式所无法取代的。亲近大德善知识们，可以帮助我们树立正知见，也可以培养对佛法的信心，达到见贤思齐的效果，因此经论中都非常强调修学佛法应当依止善知识。但是，末法时代，善知识也难得难遇。能够亲近善知识同样需要相当的福德因缘。
如果一时还无缘依止善知识，那么可以先尽快受持三皈五戒，依据佛经和祖师的教导，老实念佛。同时，在生活中勉力实践佛法，对治自己的习气，尽力帮助他人。最后，把自己一切的善法善行之功德，回向给自己未来的法缘，祈愿自己早日得遇明师。如果一心向道，法缘和求法的时间一定会有的，没有也可以设法创造。试问，有什么比解决自己的生死问题更大的事情吗？


善恶的标准：利人还是害人

    bffl：
    好人得好报这种说法完全是没有根据的。问题的关键在于什么是好人？雷锋是好人吗？学佛人是好人吗？不一定的，善恶没有一个绝对的标准。

    zf：
    依在下浅见，善恶标准很简单：

善──利人；
    恶──害人。
    “利”、“害”的标准随时代和文化而不同，但利人者为善、害人者为恶，恐怕具有普适性。至于菩萨将利人之心升华为利益一切众生之大悲，就另当别论了。善恶之心，骗得了别人，但最骗不了自己。


要改运不如积德

    真清：
    我家的房屋正对着几个大烟囱，一般人到我家都会觉得不舒服，说是风水不好。学佛之后倒也没把这种说法放在心上，但是家人身体真的是很不好，所以有了疑惑，请指点一二吧！

    二麻子：
    风水──是因还是果？
    风水问题对我们学佛的人来说，不是作用不作用的问题，而是分清因果的问题。
    许多人把风水不好看作是自己运气不好的因，用改风水来改“运”。这个做法实际就是企图用改变环境的方法来改变自己福报。凡是学过因缘果法的人，都能看出这个做法的不合理处。
    比较正确的看法是，风水反映了自己的福报，是果的现行，而不是因。不好的风水跟不好的运是同样福报在不同方向上的表现。就好像感冒会头痛发烧一样。头痛与发烧是同一病因在不同方向上的表现。
    王亭之先生的经验很有意思，强给人改风水以后，住户会搬走的……嘻嘻。
    所以，要改运不如积德……

    真清：
    完全赞同改运不如积德，可是……
    就像生病固然是果报，但是我们也不能因此不去积极治疗呀。
    也许我们努力改变为好的风水的现行正是原来善因现在成熟的果呢？嘻嘻。
    中医有一句话：急则治其标，缓则治其本。
    如果一方面改变风水，一方面积德修善，是不是更好呢？

    智行：
    风水大师倒是有。
    弥陀、观音是也！极乐净土风水多好啊！
    世间风水师则靠不住，他们都自身难保，不求也罢。

    二麻子：
    对极对极。不如发菩提心修诸善。


这个地方有什么可糊涂的？

    这个地方有什么可糊涂的？

    二麻子

    兄也是老佛友了，这个地方有什么可糊涂的？
    看事物何必硬追住个名字不放？若否定因果的，歪曲因缘法的，违背世尊一贯教法的，排斥它宗的，否定世尊其他教法的，强行割裂自他的，等等，叫什么名字我们佛弟子也不能同意。如果是真按照佛陀教法的，叫什么名字也应该赞叹。
    最麻烦的是些似是而非的，当没有批评声音时，说些什么好像某教“因信称义”这样的东西，遇到正派佛弟子批判时，又换个说法好像回到正路似的。等没人批评了，就又转回去了。象蝙蝠，飞走通行，兽鸟兼顾。
    所以，兄只管自己看明白就是了。类似“因信称义”的依法，麻子不敢支持。信须见于行，怎么行，佛陀说了49年。真信的，不至于偏成这样。


附佛外道的命运如何？

    Eagle：
    附佛外道的命运如何？这个世上附佛外道可真多。可是有的知道自己行的不是真正的佛法，不过是混口饭吃；有的还以为自己学的不错，颇有成就；还有的真是冤大头，啥也不知道就跟着拱。他们的命运如何呢？果报在哪里？
    甚至还有些附佛外道声称自己是密宗，传承清净等等，害得不少人就在后面跟着跑。那个骗人的师父没得说，地狱应该是等着他了；那些可怜的弟子呢（有些还学得很认真呢）？

    zf：
    谈点看法。因缘果报之理甚深，非我等凡夫所能完全测度。但依佛言教，有些规律还是可以了解的。
    我等众生渡过生死大海的唯一舟船便是三宝。如果某种邪说使信众丧失对三宝的信心，则便是将众生从船上推入苦海。这种恶业应是最重的恶业之一。
    决定来世投生何处，主要看今生所做善恶业谁者势力最为强大。势力最大者首先成熟，势力其次者将来成熟。如今生所做诸业势力较小，则前世所做诸业中余势较大者先成熟。如经中常有开示，某人因某恶业，将先入地狱多少劫，于地狱受报后将转生饿鬼、畜生道多少世，然后为人，盲聋喑哑，多诸疾病，贫贱无德，为人轻贱。若人做大善业，则天道之业首先成熟，天福享尽后，投生人间，福业余势，于人中有大势力。总之，所做业不失，成熟先后依业之大小。
    附佛外道的弟子来世的果报原则上也应遵循上述规律。附佛外道所持见地，必与佛法的根本意趣相违，应属烦恼中之邪见，在此邪见摄持下的身口意三业必是轮回之因。但是否一定落入恶道似乎并不一定。注意，附佛外道并不一定都是很恶的邪教，有些可能也要求弟子布施等，行诸人天有漏善行，只是他们错会空义，无法突破无明，超出轮回。这类外道既然附佛，同样可能要求弟子念佛菩萨名号。大家知道，念佛菩萨名号有极大功德。《法华经》中有：

若人于塔庙　宝像及画像
    以华香幡盖　敬心而供养
    若使人作乐　击鼓吹角贝
    箫笛琴箜篌　琵琶铙铜钹
    如是众妙音　尽持以供养
    或以欢喜心　歌呗颂佛德
    乃至一小音　皆已成佛道
    若人散乱心　乃至以一华
    供养于画像　渐见无数佛
    或有人礼拜　或复但合掌
    乃至举一手　或复小低头
    以此供养像　渐见无量佛
    自成无上道　广度无数众
    入无余涅槃　如薪尽火灭
    若人散乱心　入于塔庙中
    一称南无佛　皆已成佛道
    因此这类附佛外道的信众，藉念佛因缘在将来世中是会走上真正的学佛之路，成为真正的佛弟子。
    那些“附佛邪教”信众果报的轮廓可能如下：

这些邪教的邪见不只表现在对空性的错会上，还常常表现在错会因果之上，故不能正确领会“诸恶莫做，众善奉行”的原则。例如，有些邪教徒以杀害亲人的方式来救度亲人，不但亲人在极度恐惧、痛苦中死去，必堕恶道，而且自身亦造下杀人的大恶业。这些造了很大恶业的邪教信众来世首先到恶道受报恐怕是难免的。
    至于跟“伪上师”修密宗，古德开示，如一盲人向导，将带众人俱堕山崖（喻恶道），这似乎已有定论。
    值得深思的是，这些附佛邪教信众在受诸苦报后会怎样？通常，附佛邪教（注意，是附佛邪教，不是谤佛邪教）信众可能在心里深处对佛十分尊敬，只是他们不理解佛及佛法的正确含义。否则那些别有用心的“教主”也不会将其教义附会在佛法之上。如果这些邪教信众在行诸邪法的同时，心中曾真心向佛菩萨祈祷过，曾持诵过佛菩萨的名号，则这些善业终将不失，在久远的未来同样可能成为真正学佛的因缘。

    一点浅见，谨供参考，不当之处，敬请指正。


西瓜靠大边的自信

    西瓜靠大边的自信

    二麻子

    这位语虽惊人，别开一路说法，麻子看来，不失为一种相当不坏的解释。或说的再准一点点，一种不坏的描述。须知此类事，世间本无现成语言去描述它，兄这么讲，能使它人增加了解。
    若麻子来编话，就是“……”吧，虽不能准确表达，大致是这意思和味道。当事人以为真，必是学术法、不学正见、不学慈悲的人。其师难脱其咎。
    或者，干脆，其师亦同类。
    学密若找上这类人凶险是定了。但也要看看为什么会跟上这种人学？自己必有毛病在。但，嘻嘻，若是能反省的人，大概也不会去这样了。
    以菩提心教法为基础的学密，绝无此类凶险。
    这争论，基本没有什么意义。反映的大都是我们凡人的自信，与自信过份显现的狂妄。特别是自以为身后有力量可靠，自己就是真理了的那位。
    也难怪，西瓜靠大边，靠了大边的西瓜格外气壮。嘻嘻──此嘻嘻乃麻子的标签，切切不可忘了写上。
    顺道劝一句，搞五教合一的，有成功的吗？就算能自圆其说，别人买这帐吗？不如歇了。


点评某民间信仰的炒作

    点评某民间信仰的炒作

    二麻子

    嘿嘿，是也是也，如今世界真是令人开眼界。嘻嘻……你只说了“有关老人的”。嘻嘻。这个地方应该指出得更明确些。这位老太太在世时好像完全没听到风声，所以现在的事只是现在人的炒作。老人被人当大旗用而已。
    兄也有点不够仔细，麻子看了半天，怎么就没看到那位老人说过什么？只看到别人说老人说过什么，而且还能说出老人过世了以后还说了些什么。真厉害。嘻嘻。不过是借用旗号罢了，后面的这通喧嚣，其实与老人不一定有什么关系。
    似怪吗？根本不怪。认识问题需要个学习的过程。你老兄也不是生来就会的吧。特别你看那些个大师的手法，开始还说得有点相似，又有些个善良同修，只要一看见里面谈到佛号就自动拥戴。让很多人胆小不敢说话呀。你我自己也没早说话吗？及至手法逐步变味，或者说是逐步暴露，大家纷纷质疑，正说明这里多数人是有修学正法，远离非法之心。应该支持鼓励。
    你老兄该帮忙能帮忙的地方就该多做点正面说明，别整天冷冷地来两句，明明好意，弄得像跟人有仇似的。


追求真理需要跨越能所对立

    追求真理需要跨越能所对立

    二麻子

    一

    明兄问得锋利。但是说破了很多事真的就没意思了……嘻嘻。
    比如，“讲科学接近真理是在什么意义上讲的？”
    这问题，让麻子这就试试看能不能说破。但若是网友们看了觉得很没意思，嘻嘻，可以找明斋主算帐，别找麻子。嘻嘻。
    其实这问题里是有些不说的前提的。比如：
1、（客观）世界是有规律的。
    2、这些规律是能被认识而且能被使用的。
    就是必要前提。1里客观二字加了括号是因为这两字是隐含不明说，但实际上是主客对立的。
    这两个前提是我们一般认为的科学（精神？）所必须的。比如“科学可证伪”的说法，就要用到2。
    前提1其实是非常滑稽的。如果1完全成立，神学家就要出来说，“这怎么可能？那一定是上帝造的”。相反如果1完全不成立，科学就根本不能存在了。而半成立半不成立的状态，湍流就是例子，则是科学家极大的头痛。然而不管如何夹缠不清，这个根本不确定的前提还是非有不可的。想到这里的人大概都会对科学的可靠性有所怀疑了。
    那么人类科学发展到现在所具有的经验到底是什么呢？说起来，我们能肯定的只是，人类知道的范围越来越大，知道（能用）的知识越来越多了。
    看起来，这种越来越多的过程似乎没有止境。但这个没止境实际上已经是一种“美好的希望”而已。
    这种知识的增长，被很多人在稀里糊涂的负负得正逻辑下，被认做是“接近真理”：因为无知显然是背离真理的。
    就算这个美好希望不仅是希望而是真实的，科学的发展也不过有点像葫芦兄所举的例子，趋向全体正整数个数的那个无穷大而已。这并不保证科学能逼近真理，谁知道真理是不是“全体实数”那么大？
    要想真的确定“科学在接近真理”，人类显然需要同时把握科学，也把握真理。不幸的是，人类显然还不把握真理，似乎也没完全把握科学。所以，科学在接近真理或逼近真理的想法，真说起来，只不过是人类的一种正派、向上、积极的愿望或者说信仰罢了。其中甚至还包括了许多人类在达到地球生物界控制能力顶峰这段时间所积累的傲慢。

    二

    这地方需要说明白：
一个发展，并不断接近某个目标的过程，就一定会收敛在那个目标吗？完全不一定的。例子，数列9，9.9，9.99，……
    这个数列收敛于10，这都知道。换个角度看看，这个数列在不断地接近更接近20，但绝对不会收敛于20。
    科学在发展，也在不断地接近真理，这个趋势是应该看到并接受的。但，这并不能保证科学最终会无限接近真理！现在大家似乎把接近与无限逼近这两个有点搞混了吧？明兄看到了这一点。把这个不通厘清，似乎对搞明白科学与佛学的关系多少有点好处吧。

    三

    在逻辑上，麻子只要举出一个例子，比如就是我举过的例子，说明接近“不一定能”逼近，就证明了“一定能”是不对的，“不一定能”是对的。而“不一定能”并不意味着“一定不能”，所以您这里提出的问题在逻辑上并不相干。
    但您的问题可能在某些方面更像科学发展的表相一些。即是如您所说的情况，逻辑上仍然是“不一定”。
    无穷大也不一样。我们所谓的“无穷大”有多大？
    其实就是数轴上正整数的个数。这个数量要比（0,1）上的实数的个数要小得多，小到不能比。
    所以，趋向无穷大的过程，能趋向实数的个数吗？
    嘻嘻，完全不一定呀！

    四

    “如果按照二麻子兄的数列观，它们只能接近、而不能逼近真理，那为什么？”
    ──您这个说法是对麻子的误解。
    麻子贴子里表述的是“他们不一定能逼近真理”，或者说“未必能逼近真理”，而不是您这里说的“（一定）不能逼近真理”。这个差别非常大。
    麻子的确没有，也没法论证“科学一定不能接近真理”！要证明这个，与证明“科学一定能逼近真理”一样，都需要人类能同时把握真理与科学呢，嘻嘻。这地方不是麻子喜欢什么的问题，而是逻辑与现实都让麻子只能推论到这里。过了，逻辑上就留下错误了。
    科学与历史上的外道相比也还有个特别的长处：所谓科学精神声称科学是“开放的”。如果科学真能长久地保持这个精神，说不定哪一天，科学会放弃能所对立为唯一认识方法，进而接受佛法。嘻嘻。
    我想，你我都没法论证这个可能性绝对不存在。所以呢，麻子宁可保持这个希望/愿望，希望科学将来能走向这个方向。
    麻子跟明兄在这个问题上的认识其实没什么很大差别。麻子对这个逼近“不看好”，但麻子前面帖子里的推断，在逻辑上确实只走到“不一定能”，而不是“一定不能”。嘿嘿。也许麻子当年学数学留下的习惯有点过分拘泥严格了吧。不过，明兄如果不注意逻辑上的严格的话，随着讨论的深入，说不定哪天会碰到喜欢严格的对手在这些地方商榷你一通呢。嘿嘿。
    补一句：“不一定能”的杀伤力在麻子看来已经非常大了。

    五

    明斋主与大千这里都说到了科学佛法分野的要点，说得非常准确。
    科学：前提假设是，真理是可以被认识的。在这个前提下追求能被认识的真理。这里能所对立是隐含的必要前提。所以，这个方式很难真的靠到佛法上来。当然，因缘法的事很难测度，说不定什么时候人类的认识方法本身会有改进……
    “那么，科学还追不追求绝对真理了呢？”若不追求则违背大家期望的科学精神。若追求则将绝对真理又放到被认识对象上。
    通用的说法是，科学通过认识相对真理来逼近绝对真理。问题是，如同明斋主所指出，这个能所GAP跨越不了，没法逼近。

    六

    这论坛把科学跟佛法扯到一起，主要目的大概是为了让习惯科学的人能接近、亲近佛法，至少是希望能让他们少排斥佛法。如果让这些人觉得你很不科学从而排斥佛法了，大概有点违背这坛子的本意。
    搞科学的也是人，凡夫。如我等凡夫最排斥的大概就是在自己觉得自己比较熟悉的领域里大喊外行话的人/事。
    金兄这里的个别帖子确实有点这个味道。嘻嘻，看到搞科学的人排斥，似乎正是旁证麻子如上看法。
    麻子也是凡夫，当年看到过做不对高中数学的人强塞来的费马定理证明，神经兮兮的人送来的地震预报……那个感觉确实是……这个这个那个那个。麻子现在知道这是自己分别心没用对，不过也还不能完全改掉。嘻嘻。
    人文、科学与佛法侧重虽然不同，在现代，却是根本躲避不开也不应该躲开的。本师释迦如来在人世间示现成佛为众生说法，显然首先是为了人道说法。这人文主义也就首先在里面了。科学本身是现代人完全躲不开的。然而，要说过渡到佛法，谈何容易。不是一点都不能做，而是杯水车薪。嘿嘿。像海盗兄想通过实验手段检测禅修的想法很多人有，但多是想抓住高人做白老鼠。象海盗这样敢自己当白老鼠的不多，这点麻子随喜。
    实际上实验未必像一般想像的那么困难，很多地方实验是可行的，也其实做过点试验了。真正的问题有三处，一是这些试验结果往往不方便公开。二是样本难寻，很难在别人身上重复。在同一个人身上重复性其实不坏。三是，就是试验结果确定了，也不能提供一种让别人能做到类似事情的方法。所以，实际意义可能没海盗想的那么大。
    佛学对应的是科学理论，学佛对应的是做科学。佛学与科学理论都是表述了，都有限制。不过做科学与学佛差别就更明显了。
    好好。到此为止。


关于“困扰小弟很长时间的疑问”

    关于“困扰小弟很长时间的疑问”

    zf

    “下面几个问题是困扰小弟很长时间的疑问。曾多次在佛友会上拿出，可惜一直没有得到较为满意的答复。思索再三，还是决定放在这里向大家讨教。”(编按：引号中是聋猫网友提出的问题。)

    “佛在多部经书里讲到自己在多少劫前，是什么王，什么人，是什么动物，比如牛。那么也就是说至少在134400万年前就有“牛”这种高级哺乳动物了，这似乎很难让人相信。因为地球的年龄大约也就是几十亿年吧。（如果你硬说没有几十亿年，没证据。那我也没有办法）除非人类当时并不在地球上，在别的星球上后来转到地球来的。而那个地方的环境和地球很像。先不说怎么来的，光是这就很难让人相信。而且人类究竟是在什么时候来到地球的也是个谜。至少我们没有发现几亿年前的人类化石。但我们在地球上可以发现几亿年前别的生物的化石。”
    ──佛教对于‘时间’之观念，以劫为基础，来说明世界生成与毁灭之过程。因此，当讨论多劫前的事情时，世界已经生成和毁灭多次了。在前几个劫的某个时段存在牛这种动物应是完全可能的。

    “如果上面的问题并不算什么时，请看第三，当人寿到达8万4千岁时。可以说人类这时是最好的时期，文明应该是最发达的时期。但是那样的吗？在长达8万4千年里，人类似乎并没有什么值得骄傲的文明流传下来。（至少现在我们没有发现特别“牛”的文明）而现在平均寿命仅仅60多岁的人类都能做到。这又很难说的通。比如现代人在仅仅几千年的时间内，就发明了诸多工具，比如电脑，火药等。而且保存下来了。”
    ──依俱舍论卷十二载，劫初时，人皆如色界，肢体圆满，诸根具足无缺，形色端严，身带光明，能腾空自在，饮食享乐，得长寿久住。至地味渐生，其味甘美，诸人竞食，称初受段食。其后，身渐坚重，光明隐没，乃生日月众星。次有地饼、林藤出现。可见黄金时代的文明并不是我们现在这种类型的物质文明，即不需要我们现在的电脑，火药等粗重物质的工具。

    “但几个劫前的人类还是冷兵器时代？要用刀来肢解佛？还是农业时代？这很难说的通。又比如光目女的母亲爱吃鱼，几个劫前就有鱼了？又如前几个劫的文明都是什么样子的等等，由此延伸出来的问题真是太多了，就不一一列举了。”
    ──仁兄这里的问题可能是忽略了世界生成与毁灭的“周期”。

    “二、究竟什么是佛的问题。
    大家都在学习佛法，都想成佛。那么不知道大家心中的佛是什么样的。究竟什么是佛？也许很多人并没有认真的思考过，或许有些人还不是很清楚，或仅仅从偶像崇拜来考虑。”
    ──“究竟什么是佛？”　这“绝对”是个重要的问题，仁兄思考这样的根本问题，在下随喜！
    建议您读华严经。

    “1、首先什么众生能够成佛？佛说过“一切众生皆具如来智慧德相”那么也就是说所有的众生都能成佛。但是前提是必须能够思考。不能思考的众生就不能成佛。或者谨慎的说：不能思考的众生现世是无法成佛的。而不属于众生的物品则更无法成佛，比如石头，水。由此可见佛并不是万能的。”
    ──这里的逻辑在下看不清楚。

    “那么还有没有比佛更高的形态？”
    ──对于这个问题我们除了信仰佛所开示，即佛乃无上正觉外，恐怕没有进一步的判断能力了。

    “假如，我是说假如，大家承认佛法是规律，那么问题来了。这种规律是否存在不确定性？因为但凡规律就要受到外力的影响。”
    ──“因为但凡规律就要受到外力的影响。”这句话不好理解。

    “（比如，假设麻叔用棍子用力打我的屁股，我会觉的很痛，这就是一种规律。但是当我练成金钟罩时，麻叔再打我就不会感到痛了，那么上述的规律也就不适用了。）”
    ──那还会有更全面的规律。

    “如果存在不确定性，那么佛法这条规律就不能称之为终极的规律。因为他受到诸多限制，也就是说：有可能存在另一个比这条规律受限制更少的规律。”
    ──在下认为，佛法是否是终极的规律不是我们的智慧所能讨论清楚的，在这里起作用的是信仰而不是理智。

    “2、成佛的意义何在？有人说为了解脱，有人说为了普度众生。这些发心都很好，但是当所有的众生都成佛时，成佛的重要的发心缘由也随之消失了。通俗的说就是不用普度众生了，因为大家都解脱了，都是佛了。好，请问这时的大家是什么形态？没有了普度众生发心的形态，这个形态的意义何在？为不生不灭吗？还是尘归尘，土归土？（有点像断灭论，＾＿＾）。请各位给个准确的说法。”
    ──仁兄后面问题的来源是“当所有的众生都成佛时”这一假定，普贤行愿品中说得清楚：“众生界不可尽”。因此您后面的问题根本不是问题。

    “3、关于因果。
    因果循环，报应不爽。本不应该多谈。但有几个小疑问需要各位解惑。
    1。六道轮回是否有尽头？如果没有尽头，那么所有众生成佛岂非乌托邦式的空想？”
    ──这个问题前几天讨论过。

    “2、是一念恶的因果厉害，还是一念善的因果厉害。哪个更不可思议？”
    ──这要看什么样的“念”。

    “正因为爱佛教，爱佛法，爱佛。才会想那么多不着边际的东西。这里并没有谤佛的意思和念头，希望大家能理解，理解万岁。”
    ──解惑的过程就是学习的过程。
    “无惑”者有两类，一类是彻底的愚痴，一类是彻底的觉悟。这两类人论坛上恐怕一个都没有。

    吉祥如意！


创世纪戏说

    a：
    佛法说，人从光音天下来，那现在是进化还是退化？

    back：
    光音天这件事发生在什么时候？ｎ亿年以前了，你知道这种“人”和现在的人完全一样吗？拜托找经文来看看，那就是指的一种活物，要是属于我们现代的生物学范畴的东西，能是单细胞生物就不错了，至于他自己感觉是不是“人”，那是另一回事了。嘻嘻，大胆戏说一下创世纪，仅供大家批判。

    以下经文节选自《起世因本经》隋达摩笈多译

    诸比丘。云何世间坏已复成。诸比丘。彼三摩耶。无量久远。不可计时。起大重云。乃至遍覆梵天世界。如是覆已。注大洪雨。其雨渧粗。犹如车轴或有如杵。经历多年百千万年。而彼水聚渐渐增长。乃至梵天世界为畔。其水遍满。然彼水聚。有四风轮之所住持。何等为四。所谓一住。二者安住。三者不堕。四者牢主。时彼水聚。雨断已后。还自退下。无量百千万踰阇那。当于尔时。四方一时有大风起。其风名为阿那毗罗。吹彼水聚。波涛沸涌。搅乱不住。于中自然出生泡沫。然其泡沫。为彼阿那毗罗大风之所吹掷。从上安置作诸宫殿。微妙可爱。七宝间成。所谓金银琉璃颇梨赤真珠车磲马瑙等宝。诸比丘。此因缘故。梵身诸天。有斯宫殿诸墙壁等。世间出生诸比丘。如是作已。时彼水聚即便退下。无量百千万踰阇那。略说如前。四方风起。名曰阿那毗罗大风。吹掷沸沫。即成宫殿。名魔身天。垣墙住处。如梵身天。无有异也。唯有宝色。精妙差降。上下少殊。如是造作他化自在诸天宫殿化乐诸天宫殿墙壁。其次造作删兜率陀诸天宫殿。其次夜摩诸天宫殿。如是出生。具足悉如梵身诸天。次第而说
    ────
    这一段是说细身众生所住之处的建立因缘，这种情况下如果是我们肉眼所见的一个水泡里住的众生，有个宫殿什么的感觉，乃至身体比较大等等，乃至住在那里的众生这种自我感觉和佛眼所做的客观描述，是极有可能有许多差异的。引用这一段是让大家有一个大小上的距离概念，和下文的直接关系不大。

    复次诸比丘。彼三摩耶世间转已。如是成时。其众生辈。多得生于光音天上。彼等于彼天上生时。身心悦豫。欢喜为食。自然光明。又有神通。乘空而行。得最胜色。年寿长远。安乐而住。诸比丘。彼三摩耶世间转坏。其转坏时。虚空无物。于梵宫中。有一众生。光音天上福业命尽。从光音天下来。生彼梵宫殿中。不从胎生。忽然化有。是梵天名娑婆波帝（上两句梵本再称之）。为如是故。有此名生诸比丘。彼时复有自余众生。福业寿尽。从光音天。舍身命已。于此处生。身形端正。亦以欢喜持为饮食。自然光明有神通力。腾空而行。身色最胜。即于此间长远久住。彼等于此如是住时。无有男女。无有良贱。唯有众生众生名也。如是得名

    复次诸比丘。当于如是三摩耶时。此大地上。出生地肥凝然而住。譬如有人熟煎乳讫。其上便有薄膜而住。或复水上有薄膜住。如是如是。诸比丘。或复于三摩耶时。此大地上。生于地肥凝然而住。譬如攒酪成就生酥。有于如是形色相貌。其味有如无蜡之蜜。尔时彼处诸众生辈。其中有生贪性众生。作如是念。我于今者。亦可以指取味而尝。乃至我知此是何物。时彼众生。作是念已。即以其指齐一节间。取彼地味向口而尝。吮已意喜。如是一过再过三过。即生贪着。次以手抄渐渐手掬。后遂抟掬而恣食之。时彼众生。如是以手抟掬食时。于彼复有自余人辈。见彼众生如是啖已。即便相学竞取而食。诸比丘。彼等众生。以手如是抟掬他味。食啖之时。彼等身形自然涩恶。皮肤粗厚。躯体浊暗。色貌改变无复光明。亦更不能飞腾虚空。以地肥故神通灭没。诸比丘。如前所说。后亦如是。彼三摩耶世间之中。便成黑暗
    ────
    贪吃要不得，回不去了。俺不大好意思用发光的阿米巴这种比喻。这个大小的概念么，也许他觉得自己挺大，其实不太大，这里的翻译俺感觉挺准确，用的是众生这个词。如果不是因为光和作用而获取能量，那么这些原生动物能吃无机物或者简单的有机物，也不是没有生物学上的可能，海底岩浆附近现在好像也有类似的活物。

    诸比丘。劫初众生。食地味时。既资益已。久长住世。而彼等辈。若多食者。颜色即劣。若小食者。光相殊胜。当于彼时。形色现故。众各相欺。言争胜劣。胜者生慢。以我慢故。地味便没即生地皮。色味具足。譬如成就羯尼迦啰花。有如是色。又如淳蜜无蜡。有如是味。彼等众生。共聚集已。忧愁苦恼。椎胸叫唤。迷闷困乏。唱言呜呼我地味。呜呼我地味。譬如今者。所有胜味。既尝知已。唱言呜呼。此是我味。执着旧名。不知真义。彼等众生。亦复如是。时彼众生。食于地皮。久长住世。多食色粗少食形胜。以胜劣故。我慢相陵。地皮复没。便生林蔓。形色成就。香味具足。譬如成就迦蓝婆柯花。有如是色。割之汁流。犹无蜡之蜜。乃至如前。聚共愁恼。如是次第。林蔓没已。粳米出生。不曾耕种。自然显现。无芒无糩。清净米粒。香味具足。彼时众生。如是食已。其诸身分。即有脂髓皮肉筋骨脓血众脉。及有男女根相而彰。根相既生。染心即起。以有染故。数相视瞻。既数相看。便生爱欲。以欲爱故。便于屏处。行非梵行。不净欲法时。彼复有自余众生。未如此者。见已告言。谓汝众生。所作甚恶。云何如此。其彼众生。遂生惭愧。堕在不善诸恶法中。即得如是波帝波帝之名字也（梵语波帝隋言夫主）。时彼众生。以堕如是诸恶法故。共行欲者。将饭食来。言有堕也。言有堕也。如是立名。为婆梨耶婆梨耶也（梵语婆梨耶隋言妇）。诸比丘。此因缘故。旧时下来。诸胜人辈。见于世间夫妇出故。彼等众辈。以左手捉。用右手推。令离彼处。而彼众生。或复二月。三月去已。还复归来。时彼众辈。见彼还来。即以杖木土块瓦石。而用打掷。作如是言。汝善隐藏。汝善隐藏。譬如今者。诸女嫁时。或复掷花金银衣服及掷罗阇（梵称罗阇隋言热稻谷花）。复作如是咒愿言语。愿汝新妇。安隐快乐。诸比丘。如是次第。往昔众人。如是恶作。见今诸人。亦如是作。以是因缘。诸众生辈。于世法中。行于恶行。如是次第。起作舍屋。为彼恶业作覆藏。故偈言
    ──
    像不像从单细胞生物发展成为人的缩写进化史呀，这里的粳米应该不是实指，而是发光阿米巴开始有东西可吃，于是就越发发展起来了，从“单细胞生物”向复杂结构演变（其诸身分。即有脂髓皮肉筋骨脓血众脉。及有男女根相而彰。根相既生）。佛世时印度的种姓制度，说人因为从天神的不同部分出生／创造的，因而有高低贵践差异，贵者恒贵，贱者恒贱，有些世俗例子非常严酷，佛教否定这种说法，也否定神创论，当时已经引起印度一些坚持种姓制度者的相当反对，而佛陀他老人家则在这样的环境中把关键的事实部分这样表述出来。这部经典翻译了许多次，总之，这一段已经比说人是从猿猴进化的在时间尺度上还要远了。


异质相成与相似

    东郭：
    请教关于非想生的问题，《楞严经》卷七，讲十二类生时，有：“由因世界合妄轮回。罔颠倒故。和合异成八万四千回互乱想。如是故有非有想相。成想羯南。流转国土。彼蒲卢等异质相成。其类充塞。”这里以蒲卢为例，讲非有想生。查注解，蒲卢就是蜾蠃，小名土蜂、细腰蜂、泥壶蜂。能看到的注解都引《诗经》“螟蛉有子，蜾蠃负之”的旧典，采用汉代扬雄的说法：“螟蠕之子殪，而逢蜾蠃，祝之曰：‘类我！类我！’久则肖之矣。”更细致的则说蜾蠃不产卵，而且有雌无雄，所以取螟蛉子祝之云云，而事实上，“蜾蠃是抓鳞翅目昆虫的幼虫当作其后代幼虫的食物，并非把鳞翅目的昆虫教化成自己的后代”。我吃不准经中所说“异质相成”，是怎么个异质，怎么个相成法。所有能看到的注都是一个口径，偶尔看到近几年的注不是一样就是跳过不讲，愁。求请各位教俺个明白，多谢了！！！

    back：
    插一句，蒲卢在广东话（当时楞严翻译地）也可以解作葫芦，是植物……一个和葫芦有关的民俗学上说法是，说大水后人是从葫芦里出来的，印度和中国民间都有类似古代传说，似乎是闻一多先生进行的考证。经中的比喻可能就是引用类似的故事，来比喻生命出现某种类似化生的形式。

    二麻子：
    嘻嘻。这个具体的事……那个例子如果真是蜾蠃，是个不当例子。这个不当是从哪里来的似乎没法考证。但例子虽然不当，所说的事情却是非常相似的。
    有个例子现代看见的机会不多了：孩子长相像奶妈，特别是奶妈如果不仅喂奶，而且也带孩子的日常生活的话。而当孩子大了，离开奶妈跟自己父母生活相当久后，又会更像父母了。还有个例子是所谓夫妻相，共同生活多年的夫妻，会变得长相都相似。这个事西方有过相当正式的统计与分析，结论是相当肯定。
    生不生不知道了，像却是真会发生的。嘻嘻。


观念上的融通

    nkdj：
    天人、饿鬼、地狱道众生，我们凡夫往往是看不见的，龙虽然是旁生道众生，可我们也看不见，这是从佛经上了解的。承认这点比承认龙能兴云布雨难，那只是龙的本事。而科学只是我们人类的一种共识，我们这样看待下雨，蚂蚁却未必理解水蒸汽，而且对蚂蚁来说，掉下来含水的物品种类更丰富，比如吐口唾沫或者某种动物小便、路边喷泉之类的，它们的感受自然更不同。这样一来，各类众生对下雨这件事的见解就好比盲人摸象一般，科学只是人类的一种见解，需要明白其适用范围。问题是自己的，不是佛教和科学的。至于解决问题嘛，可以慢慢来，不必特别着急。
    以前我看《法华经》的时候，见经上说世尊放光，各类众生即均感光明，我也产生类似的疑问。因为按照物理学，我们见的光是指可见光，那只是电磁波的一个波段，描述电磁理论的是电动力学。如此一来，问题就产生了：

一、这些众生得有眼接收电磁波并感到光明，我们人类的眼就只能感受可见光，X射线之类的波段是不灵的；
    二、在深海里，有很多动物生活在黑暗中，且不说它们没有眼，海水对光线的吸收就是个问题，正因为对阳光的吸收，所以水越深就越黑，光强会越来越小的；
    三、按照狭义相对论，不同惯性参照系之间用洛仑兹变换来联系，那么光波在不同参照系里频率是不同的，会发生多普勒红移、紫移，那么多众生要是存在相互运动，并且运动速度比较可观的话，则我们这个参照系的可见光在另外一个参照系的众生看来可能已经是伽马射线了；
    四、就算大家都相互静止，总不能聚一块吧？相互之间的距离可能非常遥远，宇宙半径是一百多亿光年呢。那么按照相对论，真空中的光速不变，于是光不能同时到达各个众生，到达时间可能相差几十亿年；
    五、我们接受到光明，却未必分辨得出光源是谁，要是被反射的话，源头就不好找了。比如月亮，因为反射了太阳光，所以才亮。
    当时我是硬着头皮接受了，因为《金刚经》里世尊开示了：如来是真语者，实语者，如语者，不诳语者，不异语者。所以相信世尊有这本事，怎么回事咱不清楚。但是这个疑问还在心里，憋了好久，直到有一天突然想起做梦的时候也梦到光明，那感觉和醒来时没什么两样，但是梦里哪有电磁波这样的框框呢，何必要有光源呢？梦里也不需要用自己这双肉眼来帮忙呀，谁还非得睁开眼来配合做梦啊？于是感到豁然开朗，想起以前的问题，不禁觉得好笑，还觉得挺冤的。再后来吧，蒙善知识开示，知道时间也是妄相，于是和物理学的一些瓜葛就好掰开了，非常受益。
    对供佛，我是这样看的。有恭敬心，自然会恭敬承事。佛菩萨是我们的老师，恭敬是应该的。因为世间法里还非常讲究尊师重道，何况佛菩萨引领我们出离三界证无上涅槃。恭敬承事是弟子们天经地义的本分，供佛仅仅是其中之一。而我们凡夫毛病多，贡高我慢，真正生起恭敬心很难，时常供佛就慢慢熏习，时间久了习惯成自然，这种对天人师的恭敬心会培养出来。而且我们要积攒福慧资粮，供佛就会让我们培植福德，积攒菩提道的资粮。也许你听说过贫女供灯的故事，世尊为她授记成佛。你作的这些供养并不是因为佛菩萨需要你这些物品，而是调心的方便。对世尊最好的供养是如法修行。修行不仅会花一些你这里提到的金钱精力，更会花时间的，嘿嘿。再者，有正法住世是很难得的，有些事情也挺不容易的，我们花点钱去印经建庙等等，也算是佛子的一点点心意，为正法久住尽一点点力……

    zf：
    说的真好！在一类众生眼里成就的幻相，到了另一类众生的眼里就变成了其他的幻相。适用于描述各类众生幻相的“普适规律”恐怕难找！


植物不属于有情

    慧心通明：
    关于杀生的问题，我确有疑惑不解。
    1、最小的生命是什么？细菌？病毒？白细胞？蛋白质？
    2、绝对的不杀生几乎办不到。宏观的世界里或许能注意得到，但是微观的世界里，是很难注意到的。（比如，吃药治病实际上就是杀病毒的过程）？
    所以，持不杀生戒，我真的感觉几乎不可能。
    3、不杀生，是否意味着面对野兽的威胁（比如在丛林里）不可以自卫？再比如，面对行凶的歹徒，不可以正当防卫？
    如果遇到这样的两难：看到一只狼在吃小孩，要不要杀死狼，救小孩？如果见死不救算不算杀生？
    4、杀大生命（大动物）是不是比杀小生命（小动物）的罪过大？还是同等的罪过？
    以上问题，困惑我很久，让我不敢想持戒的问题。如何正确理解“不杀生”？

    二麻子：
    多嘴几句。
    “最小的生命是什么？……”
    ──佛门戒杀生说的是不可以杀有情。植物不属于有情。否则我们连饭都没得吃了。所以不必追究到单细胞生物去。而“有情”这个概念与其他一切法一样，是没有绝对精确定义的，但我们并不难掌握其一般意义。

    “绝对的不杀生几乎办不到……”
    ──见上。你这里举的例子是单细胞和病毒，连植物都不一定能算上。也不属于有情。

    “不杀生，是否意味着面对野兽的威胁（比如在丛林里）不可以自卫？再比如，面对行凶的歹徒，不可以正当防卫……”
    ──这个要取决于当事人修行的程度。禅宗记录过杀与被杀双方当场放下宿业的事。对一般人来说，有生命危险时的自卫并不一定杀死对方。

    “如果遇到这样的两难：看到一只狼在吃小孩，要不要杀死狼，救小孩？如果见死不救算不算杀生？”
    ──你能不能赶走狼？

    “杀大生命（大动物）是不是比杀小生命（小动物）的罪过大？还是同等的罪过？”
    ──比这个罪过大小并没很大意义。


无我、前世记忆

    (在新那烂陀聊天室的对话)

    某网友：请问善知识，我看书中讲“无我”，觉得逻辑上不能信服。但感觉自己是信无我的，只是这道理是不是真的能明白呢？
    某网友：是不是只有修证才知？
    二麻子：光凭道理是不够的。没有道理是不行的。
    某网友：善知识，现在总是信无我的道理，可总是觉得就是有我啊，这怎么回事呢？
    二麻子：若要这么容易就能解决，佛门这么多人都花那大力气干吗？嘻嘻。
    二麻子：哪个成就者不是千辛万苦的？
    某网友：是。
    某网友：善知识，我一直不懂，到底那个在轮回里的是谁呢？
    某网友：下一世那个人我总觉得我不认识呀。
    二麻子：“我”。就是这个虚幻的执着。
    二麻子：认识不认识并不关键，关键的是你造业他得承担。
    某网友：可是，从前想，他承担关我什么事呢？既然没有我，那他和我没关系呀。
    二麻子：能这样想也不错，你就不应该对你遇到的一切不顺利抱怨了……哈哈。
    二麻子：我说的是现在……哈哈。
    某网友：谢善知识开示！
    二麻子：嘻嘻，客气了……
    某网友：善知识，为什么人不记得上一世或前些世的事情呢？
    某网友：为什么入胎不迷住胎迷，住胎不迷出胎迷？
    二麻子：这没什么要说的道理，这世的事你全记住了？
    某网友：可是总有一些是可以想得起来的呀，这一世，为什么前些世的就没有一点能想起来呢？
    二麻子：不见的。有人就能想起来。
    二麻子：记住前世又怎么样呢？还有前前世，前前前世……
    二麻子：你想都记住？
    二麻子：都记住了，你还会喜欢生命而不厌烦吗？
    二麻子：那时可惨了，死又死不掉……
    二麻子：因为只要能记住，就相当于没死……
    二麻子：嘻嘻，你想过这些方面吗？
    某网友：没想过，善知识。我只想到要想起来从前世的事情多好啊！
    二麻子：只想好不想其不好，是不是愚蠢呀？
    某网友：您说得是。如果都想来的话，那么多记忆本来这一世都够烦了，那不就更烦得不得了了么？
    某网友：就有更多的放不下了。
    某网友：是，善知识您说得对。我是愚蠢呀。
    二麻子：不仅如此，受苦太大时往往导致不容易恢复的心理创伤。
    二麻子：若是忘不掉在地狱呆过的经历，嘻嘻，这心理大概怎么也是没法正常的吧？
    二麻子：所以，记不起来实际是对生命的保护。
    二麻子：除非你真有能力承受，你不可能记起来……
    二麻子：但你也没真忘掉。等你真有这能力时，会记起来的。
    二麻子：菩萨们不都这样？
    某网友：谢善知识！！！！


融通与表述

    融通与表述

    二麻子

    经云“一切治生产业等，皆与佛法不相违背”，科学当然也不违背。这地方应该没有什么异议。要求每个人都学会五明，那是难了点。但是已经学了科学的人可以利用其方便加深对佛法的理解，这也应该没什么异议。但说到实证就麻烦了。直接通过科学实证真如大概可能性不高。至少现在的科学还不行。那么还是要遵照佛法的基本路线，从三主要道学起，就是出离心，菩提心和空性正见。
    麻子基本赞同“融通”。虽然说若干细节上的看法未必完全一致，对于能“融通”到什么程度也还没有个大略的估计。但一定程度的融通对现代社会与佛法的持续传播显然是需要和有益的。
    佛法的真理/真如/空性虽然常用“不变”表述，实际却完全不排斥变化（缘起）。佛法在社会上的传播方式与表述形式却实际上没停止变化过，特别是佛法兴盛的早期，诸大菩萨/成就者/论师对佛法表述的形式做了大量工作。近代佛法在这些表述方式的调整已经非常少了，大家也就看到佛法表述与现代社会现代科学间的某些不协调。寻找能让现代社会更容易接受，与现代科学更协调的表述肯定是对佛法有益的。但这里需要有个极其强硬的前提，就是表述的方便与改进不可以扭曲佛法的核心。而这个核心，如众多佛友所知，在正见上是缘起性空，在实修上是自他解脱，在社会行为上是利益大众，在根本上是悲智不二菩提心。


别忽略了理性与逻辑

    别忽略了理性与逻辑

    二麻子

    说点看法吧，佛法里，理性是修学，崇拜也可以是修学。这两个若能结合得好，更是很好的修学。但如果结合不好，就比较麻烦。讨论法理的事，理性是极其重要的。
    行上的事，不懂但照做也算一种接受。但法理的事，自己不懂的，看不通的怎么接受，接受了些什么？这点请正视自己。不接受不等于说不好。您用“很好”来对比，是引申过度了。对能看通的人，那就很好。最怕的是自己看不通，还以为自己接受了，那可是自己骗了自己。所以，请不要看见“不接受”，就好像是对自己诽谤了。
    那些话是真正佛经里讲过的。您觉的表达得很好还是不很好？很好，怎么你也没全接受？你都可以，怎么麻子就不可以不接受呢？嘻嘻。举出这个地方，只是希望你量自己与量别人用同一尺度。看过这段，我想你第一段我就不用回了。俺可真看不明白你到底认为哪个是你的主题。

    “您说‘指月’我觉得很对，但您又说您不接受‘某种’表述方式，我就觉得您自相矛盾了”。
    ──麻子把这话标记为（A）。
    你这问题前后在逻辑上是没有联系的，虽然看上有种有逻辑联系的错觉。让我们再制造一句标记为（B）的话：

“您说‘指月’我觉得很对，但您又说您接受‘某种’表述方式，我就觉得您自相矛盾了”。
    （B）听上去跟（A）完全一样理直气壮。但（A）与（B）是截然对立的。这说明什么？接受不接受你都可以觉得自相矛盾，说明接受不接受与自相矛盾在逻辑上没关系。至于你只对不接受感到矛盾，应该自己仔细想想这个矛盾真正原因在哪里。
    我过去看过你的帖子，一直觉得你逻辑挺好的。这次前面的帖子，我一直认为你是投入了太多的个人感觉以至于忽略了理性与逻辑，所以反复问你主要问题到底是什么。


关于菩萨的示现

    莹心童子：
    我是初学，有人问我这样的问题，“佛肯定是正遍知，菩萨虽有疑惑，但肯定比凡夫对宇宙的了解懂得多得多。那为何佛菩萨不先示现为世界上最厉害的物理学家、哲学家、数学家、然后学佛，或出家呢？这样的话，照凡夫的揣测，应该能对佛法产生积极作用。”如何回答呢？

    二麻子：
    故事是这样的。

    A问菩萨，怎么不先当科学家，然后再出家，才有说服力呀？
    有个菩萨花了30年做到这点，刚要出家……
    B说，不行，你还没当过艺术家呢……菩萨又花了30年做得了。
    C又说，不行，你还没当国王呢……菩萨又花30年……
    ……
    菩萨花了3000年，还是没满足所有人的期望。
    ……
    在3050年的时候，终于有个人说，我对你满意了，菩萨。我决心向菩萨学习，从科学家当起，等我当完国王后，我也出家学佛……
    可是其他的人还不满意，继续向菩萨提出要求……
    故事作者写到这里，口吐白沫失去知觉……

    莹心童子：
    难道就无菩萨作某一方面的示现嘛？难道菩萨还要三十年嘛？毕竟现在崇尚科学啊！

    二麻子：
    然！在现代科学发展的情况下……
    做个科学家不要30年（岁），能很科学吗？那么多学问，这菩萨要多少时间学？莫非你要菩萨用神通去当科学家，这个科学界可不会承认你的呢。不承认的话，你当初期望的说服力就完全不存在呢。


宿命论跟自由意志是一样的龟毛兔角

    云飞月：
    自由意志是因缘法，唯名有，无自性。说“自由”、“不自由”、“自在”、“不自在”都是相待而言的。
    有一个我在选择吗？有一个所选择的自由意志吗？都没有，但也并非没有这样的作用，这就是因缘法。凡夫的自由意志是因无明而产生的。

    rj：
    如果你同意，“自由意志”是纯粹的龟毛兔角，那就意见一致了。

    云飞月：
    我不同意，可能其他许多人也不同意您的这个看法。说了半天，就怕掉在那坑里。

    rj：
    是吗？
    对于纯粹的无“自由意志”者来说，那个坑是根本不存在的。
    所有的坑都是自己挖的。不要畏惧那个坑而抱着“自由意志”的稻草——尽管披上了“缘起”的外衣。

    二麻子：
    应该同时补充一句，也不是宿命。宿命论跟自由意志是一样的龟毛兔角。

    rj：
    现在是认为有“自由意志”的多，所以其药性偏热。

    二麻子：
    其实所谓完全的自由意志……
    很容易被证明不存在。这个不用逻辑证明，现量一看就知道。比如我想无代价的发财发不了。哈哈。
    但所谓的宿命却有一套似是而非的说法，不大容易用逻辑证伪，而且不容易现量看清：所谓的（凡夫）不可预测的宿命。这个问题其实过去讨论过。
    佛法在这个问题上是非常不落两边的。


关于现代逻辑与因明

    月黑鬼车来：
    尊师兄的说法未免稍嫌偏激，眼光也嫌窄了些！因明虽然未必全同于逻辑学，但是可以视之为一种应用逻辑学，将之与西方逻辑作比较正是恰如其分，哪里谈得上“完全错了”！难道要人家学个佛教逻辑就一定要先皈依不成？还是生为因明人，死为因明鬼，别人家的玩意儿就瞧也不准瞧？透过不同系统逻辑的比较来认识各自的优劣，不是更好吗？外人在学习佛教因明时，一定会先被灌输一些佛教哲学的基础知识，那不就熏习了一颗出世种子吗？再者，如果一定要强调唯解脱是用，是不是学医的只能给修行人治病？学建筑的只能建寺盖庙？学法律的只能研读各部毗奈耶呢？
    至于说没有因明作为基础，“学佛就会变成戏论”，那可更玄了！光说佛陀在世的时候，圣弟子中能有几个懂得因明的？大成就者密勒日巴也因不善巧于因明，以致给弟子惹琼巴瞧不太起。咱们汉传佛教，更可以夸张地宣称是“得法眼者如毛，解因明者如角”了，不成这些人都是靠着戏论得道的？要真如此，那可是咱们成日价在网上戏论之人（或鬼）的一大福音呀！

    二麻子：
    支持一下，尽管您有点激烈……对比现代逻辑与因明，明确两者间关系是件很有意义的事。麻子一直是心有余而力不足。故，特别声明支持。
    过去佛教的辩论是用因明的，但现代一般人群对因明几乎无人了解，甚至多有对古德使用的因明是否严密、自洽有所怀疑者。这对现代学科技的人学佛是种阻碍。如果能把因明与逻辑的关系搞清，这部分问题就可以解决。

    zf：
    跟着麻兄举手！昨天晚上，遇到一位学佛的小姑娘，说，她的老师建议她学佛要先学因明。在下不以为然，建议她先从了解轮回的真相入手。

    二麻子：
    是也是也，有因明当然好。没因明的人，也能学佛。比较因明与逻辑，主要是接引现代学科学的人用的。


佛陀会不会上网？

    yang：
    佛陀会不会上网？我的意见是他不会，别的不多说了。

    zf：
    关键是对佛的理解。依大乘的说法，佛有三身，法报化。法身无相，不必多说。报身国土，根本用不着电脑网络这种粗糙的东西。化身当以何身而度即以何身而度。释迦牟尼应现之时，因众生不会上网，故佛无需会上网。现代社会，小学生都会上网，应现于此时的诸佛菩萨，如果需要，岂有不会之理！！！一些密乘弟子，通过网络接受上师开示。上师即佛。诸佛利用网络弘扬佛法已不知使多少学人受益，佛会不会上网的问题还要讨论吗？？？

    成军：
    “学南传”的朋友似乎很难认同佛的三身四智，根本立足点相差很远……

    zf：
    对原始佛法（或称南传），我等学大乘者将其视为佛法的基石，特别是依菩提道次第来看，出离心的培养、四圣谛的闻思都是生起菩提心的基础。南传圣者的著作对本人曾有莫大的帮助，因此本人对南传佛法心存感恩之情。对专心于原始佛法、对大乘敬而远之的行人，本人亦十分尊敬，毕竟同为佛子。讨论中，在下所不理解者主要有二：首先，将佛之一切种智局限于根本智，这对大乘行人危害极大。
    如兄所知，菩提心是佛法种子。但这颗种子能否结出佛果，不在“菩提心”之名，关键是菩提心的心行，其最重要者即是发心之所缘相是否准确或较准确。如果行人心中的“阿耨多罗三藐三菩提”与诸大乘经典中的“阿耨多罗三藐三菩提”明显背离，则行人即使虔发欲证取“阿耨多罗三藐三菩提”的心愿，此无上菩提心亦是有名无实。欲修大乘法者对此不可不十分小心。第二，一些人一方面赞叹大乘法，一方面要求初发心者即刻生起菩萨的广大愿行。对不能即刻修诸深行的初行者则冠以口是心非、空说大话，致使初发心者心生退却。比如一小学生发愿将来欲当医生，一人立即要此学生治疗一重病人。小学生自然无能为力，此人便对小学生横加指责。这种毁谤菩提道次第的言行实际上是在挖大乘的树根，过患巨大。
    至于对自己心行未详加观察，将“信”误认为“证”，而不自知，对此就不必多说了。用麻子的话说就是“观心不细”。
    “论战”至此，双方的见解基本表达清楚，再讨论下去恐怕弊多利少。能否请麻子对双方得失予以点评，以使我等后学均能从此次讨论中更多受益？

    yang：
    有请点评，不过赵叔的得失之心也不用那么重吧。

    zf：
    关于“得失”，在下“得失”之意，是双方各自的得失，即双方各自不应理之处，而不是谁胜谁负。

    二麻子：
    一点得失（应理与否），麻子的看法……
    有关佛陀是“全知”的吗，双方讨论都在知不知上。双方都同意，知不知是因缘所成法。然而，对知与不知，开始时双方都没考虑一种情况，就是，对于完全没有因缘显现的，我们用凡夫心强扯到佛陀头上的事，判断佛知不知都是没有意义的，应该是完全谈不到的。后来大千等注意到了，但还是没将之表述清楚。
    比如“上网”，佛陀时代完全没有这个因缘，这个问题会出现，根本是我们用妄想将之强扯到佛陀头上的。嘻嘻。而且所谓扯上，也不过是自己以为扯上，并不是真的：我们没法到佛陀面前去问他这个问题。此时，我们硬要去判断佛陀知道不知道，说实话，这种判断是十分“无记”的，没有意义，无论是判断为知或不知。
    佛陀示现我们世界，自其成道说法到现涅槃，对所有问难全都给予了完整的回答，其中不仅包括了解脱之道，也包括了很多治生产业方面问题。就是对所谓十四无记问题，佛陀也明确解释了为什么不答。
    所以，佛陀证明了他确实是正遍知：一切有缘于他面前提出的疑问都给予了圆满回答。这样的正遍知决不仅仅是根本智，也明显包括了后得智。
    所以，如果麻子也用点“无记”方式，就可以推断如下。
    如果有人能在佛陀面前问他上网问题，佛陀一定能给与完满回答。
    所以，就这个义理上来说，麻子对争论双方的说法都不完全赞同。然而，显然是离正方的说法近一点点。
    麻子一管之见，见笑方家。

    savelife：
    电脑应该属工巧明吧，若佛出生时有电脑，那佛陀出家之前肯定就精通了，哪里还用等成佛后才知道　＾＿＾

    二麻子：
    如果你的前提成立，这推论就是肯定的……

    savelife：
    换个角度推理，一样可以得出同样的怀疑，在对法界一切色法和心法的了解上，诸佛应该是平等无有差别的，如果他方世界现在正在说法的佛能够“知道”的事情，没有理由过去的释迦牟尼佛如果在世的话会不知道。
    因此还是回到那令人怀疑的前提：他方有佛的世界没有电脑。

    二麻子：
    诸佛在因缘法显现上是有差别的。不能由平等而否定这个因缘显现的差异。但凡夫只能根据显现来推断。有显现的推断还不一定对呢。没显现时的推断就纯是非量妄想。所以，麻子的意思是，我们推断不了。
    推断不了，不等于可以排除。
    随便说句怪话，它方世界有电脑也有佛出现的可能性很小。高的不用，比如，天人要电脑干什么用？废物嘛。低的做不出来。嘻嘻。
    正好跟我们这里众生这些年水平一致的，也就过分巧了吧……嘻嘻。

    savelife：
    会不会用电脑属“知”的范畴，不属于“因缘显现的差异”的范畴吧，所以又要绕回来了，承认佛陀是正遍知，就等于承认佛陀可以完全了解一切色法的任何组合而产生的任何物体的功能和结构，这个是属于“知”的范围，跟“因缘显现的差异”应该没有关系。
    不管任何佛陀再怎么因为因缘的关系而示现出什么不同来，在“知”的问题上，不可能有区别的，因为都是正遍知。
    麻叔，您认为呢。

    二麻子：
    这点正是我跟你认识不同处……
    麻子作为凡夫清楚地认识到，自己在这个点上不能做判断。而且，除非已证正遍知的佛陀，别人的判断也无道理可讲。
    完全没显现过的东西，你凭什么说有，说没有？
    再要说凭，只能凭信心──这也是没什么可说的。
    补一句……如果没有因缘显现，你连电脑的名字也听说不了，你就不会谈到会不会，知不知电脑的问题。从而，别人更没法知道你知不知，会不会。特别地，甚至也不能排除你会！
    你是凡夫，别人可以推断（未必对）你不会。但对佛陀，麻子只能推断他会，因为凡是问到他的问题他都会──这是正遍知！注意，麻子这里的是推断，不是证明。

    yang：
    既是无缘，即可排除，但又怎知“无缘”呢？知见作怪，没完没了。

    二麻子：
    这个无缘还有两层……你的意思是“他”无缘，但他没有缘不是你我能肯定的。我们讲的无缘实际上还包括了“我”无缘：我们没缘知道他有没有缘，这个你怎么排除？？！！我们能做到的，只是“我没看到他有缘”──这绝对不足以推断“他”有缘没缘。
    老兄的思维需要更细密点。“你不是我，怎么知道我不知？”


如果世人都出家该怎么办？

    喻明心：
    “如果世人都出家该怎么办？”
    有人常以此问来证明佛教的出家是不忠、不孝，且违背社会发展规律。因为他们认为：如果所有人都出家了，就没有人从事生产，社会就得不到发展。其实这个问题是有刁难成份的，谁都知道这是不可能的，但这不能成为我们拒绝回答的借口呀！

    静静的风：
    这问题简单。出家是为修解脱道的，忠孝是世间的善道。当大家要解脱的时候，世间善道的标准已经被超越而不适用了。不过这个自己明白就行了，对于一般的世间人怎么说就自己具体感觉了。

    林居士：
    还有简单的……把“出家”二字换了其他东西，比方说念书、当警察、当售货员、当网管、当教师、当解放军……难道又行了？因此根本就不成问题。


老虎身上的慈悲也一样是崇高

    老虎身上的慈悲也一样是崇高

    二麻子

    嘿嘿，如果能对人有利，就算是……称赞了自己或者骂了自己，也都不大要紧。嘻嘻。要紧的是对自他有利益。
    人类有两大恶习，对己欲伪装崇高而不能正视其恶，对人不能正视其善而仅视其恶。我们不必否认，都有这毛病。蝉姐在前一条上已经校正得很多，比别人轻了。但后一条反而比平均还重了。
    因为自己有阴暗所以不能接受崇高，就连别人的崇高也不能接受。这可能是你现在最致命的问题。
    老虎身上都有慈悲，老虎身上的慈悲也一样是崇高。慈悲不会因为在老虎身上而变成黑暗。老虎也不因为黑暗而完全不能慈悲。蝉姐久经风霜，难道连这点都不肯看明白吗？何苦自找麻烦。


初级因明

    初级因明

    二麻子

    佛法里讲地水火风的火，不仅是NKDJ兄所说的，我们一般意义上的燃烧之火.用现代更精确一点的说法，更象“热流”或温差。
    另外，“似烟”一句，隐含着只有火生的才是烟。这当然可推出有烟必是火了。那位贴主不明说，大概在考你们的逻辑功力，嘻嘻。
    顺便，把小学或初中的逻辑基本命题关系重抄这里一遍。嘻嘻。不是说二位，而是有好多朋友，包括要建立理论体系的朋友，都在这地方犯过错误。希望以后不再看到这类错误……
    设有命题1、“有A则有B”────为原命题。
    则
    命题2、“有B则有A”叫1的逆命题。
    命题3、“没A则没B”叫1的否命题。
    命题4、“没B则没A”叫1的逆否命题。
    这里的逻辑关系为： 1与4 等价， 2与3 等价。
    就是说，若1 对，则4必然对。反之，若4错就是1错。
    那个因明贴子上面讲的东西里，有一部分就是说这个。
    要注意的是，1/4与2/3这两组命题之间，没有什么必然逻辑关系。如果把对1/4命题的结论稀里糊涂地套到2/3这组上，就是犯了严重的逻辑错误。这种错误论坛上好多人犯过，希望不要再看到有人犯了。
    此外常要用到的是必要条件与充分条件的关系：若A是B的必要条件，则B是A的充分条件。反之亦然。
    当说“似烟”时，就是隐含了只有火生的才叫烟。这话的意思其实是将火定为烟的必要条件。当然，烟就成了火的充分条件了。
    嘻嘻。所以，见烟必有火在形式逻辑上就成立了。不过，这个“只有火生的才叫烟”是不是成立，能不能看到“似烟”两字后面藏了什么，嘻嘻，就看当事人了……


一些学佛之人次第不明的典型问题

    一些学佛之人次第不明的典型问题

    成军

    试总结一些学佛之人次第不明，不重基础，妄自喜简喜圆而出现的典型问题。
    一、三归依还不明就开始圆融外道，大喊一切法皆是佛法，失于解脱道。
    二、出离心尚无，就高喊行菩萨道度众生，貌似慈悲，实则背离佛法在世间而指向出世间的根本方向。
    三、世俗谛、胜义谛不分，两桶水倒来倒去，永立不败之地；实则限于口簧，不减烦恼，不益自他。
    四、不肯细细辨析名相，空有基本概念尚不能阐述，即开始谈空有不二、非空非有，唯恐自己不圆顿。还拿句“不起分别心”做盾牌。结果失于正法眼，不能分别邪正。
    五、喜玩弄意识，口角争先，拉禅为虎皮，行自我欣赏，自误误人。
    六、忽视善知识在学佛中的重要性，不勤求依止善知识，不肯真下大死的功夫，喜自许／窃许自己开悟。


翻译佛经的事情谨慎量力而为

    翻译佛经的事情谨慎量力而为

    二麻子

    翻译白话佛经，发心令人赞叹，但务必小心从事。
    佛经不是轻易可“翻译”的，若无诸佛菩萨加持，无证量为底子，翻必出错。这错会误导大量读者，却借了佛陀名义──这会有极不好的结果。
    所以，没把握不可轻易做此事，虽说佛友的发心大家都能理解，而且赞叹。若真有实证又能体现代人之急，翻出准确的白话佛经，那将是无上功德。
    麻子有友仅凭自己古文功底做过这类事──未听麻子劝阻，后果很不好。
    故麻子的建议是：谨慎，量力而为。


有漏追求和尴尬的结果

    落泪的雨：
    我知道自己是一个渴望寻找幸福的人，但是我明白我不适合去过两个人的生活，我不适应和一个人单独相处去过一辈子啊！

    二麻子：
    啊呀，那您得聚集足够的福德，要能当上天界的天王才行呀，那时候会有无数天女陪你。嘻嘻。然后，用完福报了再下来继续艰苦集聚呀。你过去无量劫里这样的事是不是已经做过无数次了？


出不出家终要看缘，但生死总是要解决的

    过客：
    我处在一个繁华的城市，工作接触这个城市的高学历、高收入、高社会地位的人们，同时就意味着高消费、各种流行的东西（从物质到思想意识）和这个时代的城市的浮躁与浮华。我也是他们的一员。我不想这样堕落。
    我相信因果。并希望，也有机会好好学修并进。但是，我的父母并不实信。他们仅仅希望我继续我的世俗的正常与灿烂。他们的想法也很好理解。但是，我根本没有力量引导他们。
    出世与入世其实没有两全。求世事的圆满是可笑的。但是，我又怎么可以抛下年迈的双亲？但如果反之，我没有任何力量可以控制业力的牵转。我每天都觉得会掉入深渊。这样的结果只会是堕落。而且，我曾经就掉入过，好不容易有这么好的因缘，爬了出来。我真的好怕。
    在夜深人静的时候，我都会害怕。没有人知道是否有明天。没有人知道明天会发生什么。
    我该怎么办？

    林居士：
    你若真看的透，就不会是他们的一员了。当你的看法、思想等等都与一般醉生梦死的人不同，生活圈子也自然会慢慢改变。
    在你自己修学未够时，要改变他人的顽固想法是很难的，也不必。反之，出不出家也好，先从自己的身心、行为做起，和做定课的修行（如念佛号），让身边所有人（不单是父母）慢慢亲自看到这个学佛的人真正是不同了、变好了，想法才会改变。真正学佛的人就好像在池塘中滴墨水，不知不觉地，身边的人自然会受到感染。不过在世俗中，学佛者也时刻受到四周的污染，因此日常的警觉与定课修持更加重要。哪边的力量大，另一边就会改变。
    放不放得下由你来决定，因为有很多客观因素需要考虑，外人很难完全了解。放得下是种福报，放不下的便不要放（有不同的做法，如有人带全家出家便是一例），省得牵挂，致成日后修途之障。你说的没有力量，是比较外面的染污缘而言。如出家缘未具，能不能在家修得好就要看自己修持的心力与外来的染污缘相较如何。
    “在夜深人静的时候，我都会害怕。”
    有怕的想法就对了，怕才有动力去改。怎样改？简单说就是加强向解脱之力，减弱染污之力。前半上面说了，只要脚踏实地修。后半就要检讨生活方式。例如八正道中便有正命。举个极端的例子，如果你是夜总会经理，又或者你因业务无法避免夜夜笙歌，那头一件事便应该要转工作，哪怕是收入或社会地位降低一点。另外，朋友和社交圈子也是大问题，没有益的应酬便干脆断了。开头会有点麻烦或纠缠，但久而久之别人都知道你是这种人便也省得烦你了。其他如此类推。如果这样一点一滴地改变也做不到，出家这样大的改变会更难，或者是维持不长，终要还俗。
    “是否有明天？”
    正要常怀着这种念头，不管出不出家，都应该有随时会死，不必定有明天的想法。日常照顾思想言行，谨慎因果，如果是念佛则随时提起佛号，终会做到虽然随时会死，但却因为于生死的归宿有决定信心而不再畏惧。出不出家终要看缘，但生死总是要解决的。


新生活的起点

    新生活的起点

    zf

    作为一个佛弟子，我本人欢迎这位老兄经常到佛教的论坛上与大家聊一聊，互相交流自己的思想。人的思想是在交流中变化的，思想封闭的人就没有希望了。在此，我给老兄提几条建议。
    一、正如悠游兄所说，老兄能否改个名？本论坛是佛弟子交流心得的地方，老兄名为“杀佛”，恐怕大家听起来别扭，这无形中为交流增加了障碍。虽然古代大德有“见魔杀魔，见佛杀佛”的说法，但那是圣人的说法，其中隐含着甚深的法义，绝非我等凡夫所堪为之。老兄能否听我相劝，将名字改为“敬佛”？兄以敬佛的名字在佛教论坛上与各位佛弟子交流思想，名正言顺，何乐而不为！
    二、退一步说，名字叫杀佛，或甚而有杀佛之心，从究竟的意义上说也是好事。原因简单，发此杀佛之心，便与诸佛结下了因缘，而此因缘便成为将来得度的契机。无论顺缘逆缘，诸佛平等普度。只怕无缘，若无因缘，佛亦无奈。但与佛结下逆缘的果报，是先到三恶道受苦，然后方有缘得度。恶道之苦，决非老兄今日之苦所能比拟（请详读《地藏经》）。
    三、老兄心里对自己的所为深怀愧疚，仅此一点便是新生活的起点。其实大家（当然包括本人）心里深处都有阴暗、肮脏的一面，这一点是相同的。所不同的是，对此阴暗面，不同人的态度明显不同。有恬不知耻者，有自暴自弃者，有洗心革面者。佛弟子的态度即为后者。佛弟子对心中阴暗面的第一个态度是承认，如《普贤行愿品》中说“菩萨自念我于过去无始劫中，由贪嗔痴，发身口意，作诸恶业无量无边，若此恶业有体相者，尽虚空界不能容受”；第二个态度是诚心忏悔，永不再造，如《普贤行愿品》中说“我今悉以清净三业，遍于法界极微尘刹，一切诸佛菩萨众前，诚心忏悔，后不复造。”现在为人身的大家，哪一位不是在六道中头出头没，因此，看我们的过去，大家都差不多，而对今后起决定作用的只是我们现在的态度和行动。
    四、感到苦者正好学佛。佛悟道后首先开示的就是四个方面的道理：苦、苦的原因、苦的可灭性、灭苦的方法。苦的深层原因是对宇宙人生真相的迷惑，表层原因就是贪欲。俗话说，急病治标，慢病治本。对老兄来说，当首先克制自己的贪欲。克制贪欲的方法分两步：第一深信因果，老兄可多读一些佛教方面的书，或常来论坛上向大家请教；第二思维贪欲的害处，从现世看，在贪欲驱使下的行为虽然可能带来暂时的满足，但更多的却是苦恼；而从佛法的观点看，贪欲给我们带来的伤害更是无量无边。趋利避害乃所有众生的天性，众生的可怜之处在于不知如何方能给自己带来长远究竟的快乐，常常反其道而行之。等到结果不可收拾时便想一死了之，殊不知，人死并非如灯灭，恶道之苦岂是老兄所能想像，到时悔之晚矣！！！
    五、老兄心中有苦，想到的是来佛教论坛上倾诉，仅此一点便可以断定老兄前世曾与佛法结下因缘，殷切希望老兄充分利用在网上与佛弟子交流的机会，洗心革面，不虚度此生，人身难得啊！！！
    罗嗦至此，望兄三思。


你已经是个成人了，对自己负责任些

    你已经是个成人了，对自己负责任些

    zf

    好好想想因果

    “我是湖南长沙一位患有心理障碍的小女孩，”
    ──不对，你已经是个成人了（18岁），应该对自己的思想和行为负责任了。

    “爷爷奶奶爸爸妈妈四个人照顾我一个人，衣来伸手，饭来张口，使我过着娇生惯养的日子，弱不禁风，不能自理，但是家里人从不告诉我怎样去适应社会生活。”
    ──既然你已经认识到自己的弱点，就应该下定决心改正。你如果不知自救，菩萨也救不了你。

    “现在的主要症状是想一个14岁的小男孩，我18岁，他14岁，我又不是喜欢他，是恨他，看不惯他，无缘无故想杀他”
    ──你既然开始学佛，除了向佛菩萨祈请之外，更重要的是要按佛的教导去做。在佛告诫我们最不应该做的事情中位列第一的就是不要杀生，更何况是杀人了！你知道杀生的后果吗？杀生的后果就是去地狱，地狱的情况《地藏经》里有介绍，你看一看。知道杀生这么严重的后果以后，你还敢不敢动杀心！

    “我真的是人间地狱啊”
    ──同真正的地狱比，你现在的生活是舒适无比！

    “我该怎么办，我很可怜，我父母为我急得也得了一身病”
    ──你已经成人了。现在应是你可怜你父母的时候了！


因缘难测

    因缘难测

    二麻子

    网友问：“念佛是否是被骗的原因？如何见得，如何不见得？如何因缘法不定、难测？”

    ──念佛与被骗没什么直接相关。可算上远因的是念佛可以忏罪。当罪忏得有效果了以后，过去的恶业会转向有利解脱的方向。
    要是知道了因缘法如何具体不定难测的，那不是就定了，测了吗？简单说，任何一事物在因缘关系上都是跟无穷其他因缘相关联的，变异不断。任何精确的了解都需要对缘起性空全局的完满证量。任何有限的了解都不能完全了解任一事物。所以，因缘难测。


给自己心理上添加崇高油彩

    给自己心理上添加崇高油彩

    二麻子

    那位说：“我今年30了，是一个苦命的人……8年牢狱；6年赌魔……我选择了走四方，向社会求助……我的目的就是早日还债，再创业起家。乞讨中受尽歧视和侮辱！我平常心对之！”
    一管之见，仅供参考……尽管当事人未必自己知道，这段有非常明显的掩饰自己动机，给自己心理上添加崇高油彩的现象。自己赌博出来的恶果，如果真改，比较好的方法是通过自己辛勤工作挣钱还债，而不是乞讨。平白跟人要钱，在世法上说，受到看不起是正常现象，看不出有什么特别“消业”的地方，不积累恶业就不容易了。


理性交流佛法的风度

    大千：
    玄奘法师取经回来按照师承传的是唯识新义，唯识古义虽说有佛说六经、慈氏六论和无著世亲安慧等大菩萨的书放着，但后人的释义大都是按唯识新义讲的，要挖掘古义必须得直接从根本经论中揣摩，经论就那几本，那是大纲和原则，没有祖师的接引方便理解起来受限制很大的。韩老闯出了开发慈氏学回归唯识古义的路子，可大量具体细致之处还未触及，佛教理论又不是闹着玩儿的，必须得有经论依据才敢说话，所以讨论起来实际上困难挺大的。我还欠着赵叔一个重要的贴子，因为涉及深广，不好好准备答不清楚，我都不知道哪天能写出来，但熟悉我的师兄们应该放心，我就是慢点儿，大千还是非常喜欢参加讨论的。

    zf：
    在下愿意奉陪。古人云，不以成败论英雄。单凭大千兄以回归唯识古义为己任的胸怀，无论千兄今生能将此事业推进到何种程度，您就是在下心目中的英雄！
    千兄在修炼过程的初期，在下愿意给兄当陪练。待兄一掌将在下击倒在地爬不起来时，高级陪练自会出现。不过请千兄留神，在下出手也不会留情的。

    大千：
    在下愿意生生世世与师兄交流佛法。师兄如此期予厚望，受宠若惊。末法修行，处境艰辛，得遇师兄，实乃大幸。我们互为道友，也是多劫缘分，过去定曾这样交锋，将来也必难解难分，所以在下也不客气，一切以佛法为重。

    二麻子：
    向大千致敬……
    是难，麻子绝对同意。对于韩老以及你们一组佛友能明确看到我们汉地的唯识学从来就不是非常完整的，而且能正面面对这些问题，麻子一向敬佩。
    千兄考虑，据说由于各种因缘，玄奘大师不是最注重修禅定的，所以他翻译瑜伽行的东西，完全有可能把某些非常实践性的东西没在文字里说明出来。


论坛最吸引人的地方就是这里充满了民主的气氛

    无不可：
    赵叔您是我的楷模，为什么，我自心里有数，不必多说。虽然赵叔以谦虚坦荡的胸怀面对我前期的言论，我仍感不安，担心误解，还想再说明一下。
    一、我自以为，赵叔对一些网友的心得，在探讨时，也许是对方表达的不清楚，使得赵叔没有抓住对方的思想，因为语言是一些因缘的合成物，同样的心得可能有不同的表达，或者看一件事有不同的角度，表达也不同。
    二、还是我自以为，赵叔对某位网友如生质疑，这位网友可能会遇到很大压力，我可能考虑不周。我希望此时赵叔能出面帮其解除压力。
    仅此两点，说出来，也解我的不安。衷心地向您祝福。

    zf：
    无兄，读了您的上文，我的心里倒是充满了压力。
    我毫不怀疑您的真诚和对在下的厚爱，但自己心中存在的阴暗面提醒自己，自己根本不配成为一个学佛人的楷模，更谈不上大德这一称呼。
    论坛最吸引在下的地方，就是这里充满了民主的气氛，大家在这里可以自由交流自己的学佛心得，发表自己的见解，互相取长补短，共同进步。前些天，空明兄以“巨脑”来形容网络对学人思想的整合作用，十分有启发性。我们每个人的思想都有自己的局限，生活中周围不可能有数十成百个志同道合的朋友经常与自己交流，但网络却给我们提供了这个便利，使几年前连想都不敢想的事变成了现实。
    本人知道网上有佛教论坛是在98年，迟迟没上网参加讨论的原因之一，是害怕耽误时间影响自己的修学。是几个朋友硬把自己拉到了论坛上的（就是最初称在下为“叔”的那几位，因年长他们十多岁，被他们称“叔”亦不觉为过。另外，我这个“叔”的得来还要得益于麻子，因他们称麻子为“麻叔”已成习惯，而我称麻子为老兄，故他们只好称我为叔了。后来许多人都随他们称“赵叔”，有人还以为我叫“赵书”呢！其实，我觉得论坛上大家互称“兄”最好，因为大家的父亲都是释迦牟尼佛）。在论坛上交流、讨论，大家的地位是完全平等的，彼此之间不是老师和学生之间的关系，而是同学之间的关系。同学之间交流的最大特点就是没有压力，许多不好意思跟老师谈的想法，都可以开诚布公地向同学敞开。我们每个人都有作学生的经历，对此一定深有体会。本人在论坛上的心态就是各位的同学，大家对在下的言论若觉有几分道理便可以体会一下，若觉得是瞎说，尽可一笑了之。但在下文中若引用了经论，希望各位对经论要用心思维，在下的解说则尽可以不管。在无兄指出在下的言论可能使“网友可能遇到很大压力”之前，在下根本没有意识到自己言论的这一后果。说句心里话，这种结果是在下十分不愿看到的。
    西方的现代教育是充分调动学生的积极性，这种教育的优点是大家有目共睹的。我们这些学生应该充分调动自己的能动性，不妨探索一下信息时代可能的新的学佛形式。


有教无类与互相宽容

    有教无类与互相宽容

    二麻子

    “因果的另类说法：种豆得豆、吃豆放屁是因果，种豆不得豆、吃豆不放屁也是因果；种豆得瓜、吃豆放豆不是因果。当然某些内道主张吃豆拉豆，那是豆吃多了。”
    哈哈……游客兄……这个拉字痞老这样用，其实是告诉人别被自己思维框架框住。同一句话可以有很多意思，未必自己望文生的义，就是别人的真意。这方法是禅宗古德很常用的技巧之一了。嘻嘻。不过，就是要用这法子让人把厕所联想到一起，那是痞老的个人爱好了。哈哈哈。
    这帖子基本意思其实就是说明，因果是错综复杂的。因缘法无处不是。不要把因果关系想成线性那么简单。因缘法不是定死的，当然违背因缘法的现象，比如种豆得瓜，是不可能出现的。
    但是，痞老偏要用这种让很大一部分人看了不爽的方式表达。你不爽了？好，不爽也是因果，你就在不爽里体会因缘法的复杂吧。这下子，痞老可爽了。哈哈。
    这种爽与不爽，嘻嘻，麻子很能体会，有时不免偷笑半天。说句闲扯的话，麻子这名字得自于别人偶然造成。但麻子长期坚持用这个名字，嘻嘻，本身就是某种痞气的表现。哈哈。
    金刚兄这个人，麻子说句难听话，是个痞子。但痞子也是人也是众生也可以学佛呀。而且，这个痞子是真在学佛并确有进展。你可能不喜欢，甚至不能理解这个痞气，但不是说别人也都不喜欢。这里明显有几位很与金刚兄脾气相投的弟兄。
    这种东西你可能没经历过，所以不知道。麻子是混过痞子的，至今也是痞气不净。嘻嘻，所以对这种风格，看了心里偷偷乐就是了。麻子既不能强迫金刚兄等硬去抹掉痞气，不能强迫不喜欢痞气的人硬去喜欢，还不能支持痞气朋友强要莲舟改变“正经”风格。
    所以，唯一的建议是，嘻嘻，大家包容些，看帖子看里面深点的东西。
    金刚兄的手法及其痞气方式，麻子相信对有些人有些时候是需要的，有益的。麻子也相信，很多人很多时候是不喜欢的。如何平衡二者，是金刚兄自己的事了。
    麻子的看法是，你这坛子如果接受这种风格，那就接受他。如果不接受这风格，就赶走他，反正他会找到别的地方，与风格相投的人继续交流。所谓此处不留爷……之类的。赶不赶纯是风格问题，与内外道没什么大关系。嘻嘻。
    似乎最没有成功可能性的目标是改造他，把金刚兄改造成道貌岸然言必子曰经言的“君子”或腐儒。哈哈。


愿诸众生，所行无逆，成一切智

    愿诸众生，所行无逆，成一切智

    zf

    陪人听海兄，以下供参考。

    “有的人，总是断章取义，道听途说，曲解佛意，甚至加以毁谤，恶语相讥。他们不信因果，不断地造地狱之因却不听劝告，不知悔改。”
    ──心中祈愿：愿此等人以曲解佛意、乃至毁谤佛法的因缘，将来得遇正法，恭敬修行，永出轮回。

    “有人似乎对佛法很有研究，说出的话也高深莫测，还打着修行密教的旗号，乍一看很是令人敬佩。殊不知他正是以这种手段骗取常人的供养，并妄称前世因缘欺骗天真无知的女孩与其行男女之欲，还称那是修行。”
    ──愿此等人，早解如来密义，得正法财，离世间欲，真行慈悲与空慧双运之道。

    “有邪教徒，以庸俗不堪的邪教谬论歪曲佛法，到处张扬，还妄想自己会“得到”比佛更高的“层次”和“法”。”
    ──愿此等人，以今世附佛之缘，将来生如来正法之家。

    “还有我的父亲，常不思正业，每晚与朋友醉酒寻欢，出入淫席，挥霍无度”
    ──父亲之过，不损养育之恩。汝当修持，六字大明，经云七代种族，皆得解脱。

    “蒙诸佛菩萨慈恩，弟子今生得到人身，得遇佛法，自当弃恶扬善，勇猛精进，上求佛道，下化众生。但对于上述几种人和自己的父亲，实在不愿眼睁睁地看着他们将来堕入恶道，奈何心中不忍却无能为力。想听听师兄们的意见，我该怎样做？”
    ──不忍是报恩心，无力是错误见。发菩提心，持六字明，腹中诸虫，皆成菩萨。何况汝父与有缘人！


反省自己笑脸背后是否真的是“真诚”！

    zf：
    扬子兄，你说的是一个相当沉重的话题。

    “我的看法是：或许源头在于国人多有这样的潜意识看法，因果轮回，报应不爽。”（编按，“”中是扬子网友的话）
    ──若真是这样，在下倒深感庆幸：国人有救。因为不信因果乃根本愚痴之一。

    “所以，一个妇女失去丈夫，大家不是同情，而是‘她克死了男人’”
    ──这是错解因果。丈夫短命，其因在其自身。将此因推给别人正是不懂因果的表现。

    “所以，一个家庭遭到天灾人祸陷入困境的时候，一个破落的家庭，感受到的或许有人间的真情，但更多的是白眼和欺凌：活该！”
    ──真相信因果者，即使出于自利的目的也不敢欺凌他人、恶语伤人。

    “当苦难被视为惩罚和报应的时候，当贫困被当成耻辱的时候，救助被视为施舍也就不奇怪了；”
    ──一、麻醉药并不真正治病；
    二、知耻者谓之勇；
    三、依佛教而行之施者，从来不将救助视为居高临下之恩赐，而视之为对往世父母的报恩。

    “于是，我们的真诚的笑脸所换来的却是孩子的漠然和敌意：我是在被人可怜！他们凭什么？！”
    ──若孩子的敌意不能被消除，“我们”应该做的是：反省自己笑脸背后是否真的是“真诚”！

    “能不能对这些‘好可怜’的孩子这样说：家庭贫困不是你的错！幼年失去父母也好，家有长期病人也好，父母善良而不善理财也好，这苦难不是报应，仅仅是对你的磨砺而已；哪怕是因为你父亲赌钱或入狱，哪怕是因为你母亲嫌家穷遗弃了你们，家穷不是你的错，或许他们有错，这也不是你的错；”
    ──有时将事实告诉孩子未免残酷，因此在下不反对您上面的说法。
    但，对苦难中的成年人您也这样说吗？

    “由此我想到的是：佛学里讲轮回，讲因果报应，固然有警示众生的意义，但另外一面也有歧视贫弱、视之为原罪的一面？”
    ──在这个世界上，您能找到一个不可能被别有用心者利用或被人错解的东西吗？

    “这样的解读下，苦难被视之为报应，带来的不是对贫弱的同情和救助，而是冷漠和势利的一面。”
    ──您能从观世音菩萨、地藏菩萨的心中发现冷漠和势利的一面吗？

    “人是不知其前世造了什么业的，他应该为之偿还什么？？”
    ──人的确不知道自己前世造了什么业，但佛告诉了我们，同时佛还告诉了我们永出苦海的方法。能否离苦得乐，还要看我们是否依教奉行。

    “比如，一个因为灾祸而失学的孩子，他该恨自己的‘前世’，还是挺起腰认为自己应该有不失学的权利？”
    ──当社会上公认孩子有不失学的权利时，佛教绝不会让孩子放弃这个权利——善的果报。

    智行：
    善说！善说！扬兄的那些问题不是因为人们信因果的问题，而是人们根本不了解因果才有的问题。至今大众都不了解因果，天下才有这么多问题。许多人嘴里说人家遇逆时是报应，实际上并不信因果，更不了解因果。当别人同样方式说他们是报应时，不知他们是何感受？


网上掐架与宣传佛法

    玄兹：
    玄兹在学习过程看到不少佛家弟子在不同论坛中的表现，心中自然会产生许多问题。
    请问诸佛友，佛陀在传法时是否喜欢骂人？若有，请给出处，玄兹愿学。若没有，再问诸佛友，佛教各宗师傅是否提倡骂人传法？若有，请给出处，玄兹愿学。若没有，为何有的佛家弟子出口脏字不断？出现这种现象，是佛法教义有问题，还是个人人品有问题？
    （编按：当时玄兹和某网友有一些就这类问题的争议。）

    zf：
    如果狮子王学佛，自心虽没有起好斗之心，但念及一掌下去会给“它们”带来苦痛，这一掌还是不忍拍下去的。心平气和地切磋“武功”，在下并不反对。但以争胜负为目的的“切磋”，害大于利。建议诸位不要凑这个热闹了。本是同根生，相煎何太急！
    依在下浅见，如果一个论坛能成为某些佛弟子寻求安慰的地方，这个论坛就是个相当成功的论坛。别忘了，佛菩萨是希望给予我等众生“暂时”与“究竟”的利益。关注“究竟”不错，忽略“暂时”不好！

    二麻子：
    给某兄和玄兹的劝解……
    某兄，麻子能劝你的唯一用词是“住嘴”。佛门行人学的是利益他人，行为当否，以此为抉择。利害交杂时，衡量能利大于害者。你遵师训了吗？
    玄兹兄，愿意与佛友交流，是为了大家取长补短吧。大家陷在黑漆桶里对骂，尊驾还记得本意吗？
    同对二位：俗云“死要面子活受罪”，这够难受的了。若还有没看到的反面，“活要面子死受罪”，更当如何？相骂无好口，若论是非过失，双方都有。对方前一个错误，并不能成为自己下一个错误的理由。就此停下来吧。
    两位都别跟贴。若要停，就这样停下。麻子这样希望。


京巴是生意人，就说点生意上的事儿

    京巴是生意人，就说点生意上的事儿

    京巴

    我所供职的公司不大，其中一项很重要的业务是将手里的几栋物业出租，赚取租金。最近发生这么件事儿，缘起是某一栋楼里的502室养了一只小狗，因为主人好像不大喜欢宠物在家里大小便，而使这只小狗固执的把整栋楼的公共部分认定为自己的厕所。于是，自从多了这么位新住户，从一楼到六楼，到哪儿都能见到和闻到它的排泄物。楼里其他住户们因为都是临时性寄居，虽住着不大痛快，开始也还都忍着，直到发现那只小狗不仅卫生习惯不好，而且缺少家教，经常选择在凌晨4、5点钟狂吠。使大家觉得身心备受摧残。忍无可忍的情况下，一再向业主(也就是我们)反映，然后公司出面，先请502加强对小狗的管教，效果不是很理想(期间该栋楼房住户流失，另觅新居的不在少数)。最终，这件事只好以我们客气地请502搬离而结束。一直坚挺着终于看到这一天的其他住户们，感激得差点给我们送来大红缎子镶金字儿的锦旗。
    结合最近在论坛上看到的，也合该这两件事挨得忒近，怎么都觉得像是一码事。在此，先声明一下，我没有把任何网友写的帖子比作狗屎的企图，但如果有人非做这样的联想，为了尊重他联想的权利，我也不会硬拦着。
    民主的精华在于保护少数人说话的权利，很高兴看到，虽然大家跟这个概念隔绝了不少年头，但却对此精华理解得如此深刻和坚固。但同样，我不得不小心翼翼指出，民主中，对个人意志的强调，实际上是对我执的一种肯定和激励。当然，您可以把尊重其他众生的个人意志和权利作为出发点，那又是另一回事。其实，关于扩大公民权利和担负必要的责任之间，该如何调配，永远是吃社会学这行饭那一撮人的衣食所在，我们不能期望靠网络上的某个论坛来完美这一管理理想。
    众所周知，网络除了充当资讯库，对很多人来说，一天比一天更像情感垃圾站和生活垃圾处理中心，基于心理上以及生理上的一些原因，大家对这块公共场所的利用率很高。来这里讨论，要在大多数共许前提下进行，我认为是十分必要的。好像有些宗教的教徒如果天天讨论真主和上帝谁本事大一样，到底对哪方有好处呢？在不共许前提下的讨论不是缺乏理智的纯感情宣泄，就是互相挖动机，进而人身攻击，使任何有意义的话题都难以深入。同时，对根本不相信因果的朋友指出地狱的前途，似乎作用也不大明显。所以，为了能有个交流清净正法的清净地盘，真诚地希望成军等大德绝不能手软，要不真就是对大伙不负责任了。


让仇恨离我们远去

    让仇恨离我们远去

    土登:

    让仇恨离我们远去
    仇恨的火焰使我们毫无理智
    我们的世界已有太多恐惧
    就象油不能扑灭大火
    仇恨也只能使仇恨延续
    让仇恨离我们远去
    我们需要和平的空气
    虽然东西南北隔离
    但养育我们的父母
    我们抚养的儿女
    一样的血液
    一样的情谊
    我们需要自由和平的空气

    让仇恨离我们远去
    我们本来都是兄弟
    虽然肤色言语各异
    可顶着同样的天
    踏着一样的地
    我们都是骨肉相连的好兄弟

    林居士：
    拿什么国籍与穿什么衣服相去几何？阿弥陀佛与观世音菩萨也不曾质问娑婆世界的众生“真的无辜吗？”事实上，我既生于此世而非净土，必为往昔作恶之果。幸好佛菩萨在救度我们时不会算我们“往昔所做诸恶业”的账，也不会在我们受苦难时讥讽说是我们罪有应得（虽然的确是）。法藏比丘在因地里就已经不管这些了，不然也不会发愿接引临终忏悔念佛的五逆十恶者，更不会认为他们得度相对于一生行善念佛者是“不劳而获的幸运”。

    2001年9月


吾人要转变人生境界，先要自心作大转变

    吾人要转变人生境界，先要自心作大转变

    智行

    明明玉山兄请进。
    来信奉悉。先讲个愚刚听来的事。一位刘师姐自小就有“富贵手”病，皮肤溃烂，不能触水，久医无效。其弟是皮肤专科医生，亦莫能治。一日其母闻台湾山地有种果子狸，吃了能治此病，就屡劝刘师姐去找山地人捕猎，此事并不难。但刘师姐当时刚受佛教影响，就是不肯去，最后说宁可让手烂掉，也不吃这动物。说也奇怪，这手病从此不治自愈，从那时起就真学佛了，到今已十五年。这是在本地佛学社上周六聚会刘师姐亲口说的。
    盖吾人要转变人生境界，先要自心作大转变，凡希望自己如何好，一定也要一切众生都得这些好处（把众生看成自己的一部份）。有些该求的我们不知求，所以要学佛。先从发菩提心下手，四弘誓愿，求生净土，上求佛道，下化众生。先从这些内容学起。发心不容易，但不能不勤勉。愚也是在慢慢学，做得很差，但感应却不少，故对三宝一点怀疑都没有。许多人都觉得付出得很少，却得到很多，十分感激三宝。
    人生中的不顺利都是从恼害众生的因缘来（其中有身口意三方面），我们要从这些方面去检查自己。看看是否恼害其他众生，有无妒忌别人，有无教别人做不良之事（或见作不善而生喜）。如果我们检查自己看不到这些错误，那一定是自己无正眼，看不到，应大忏悔。若看到自己通身是罪过，表示修行有进步了。接下来就是诚心诚意求三宝加持，少犯这些罪过。再思，若滞此界，罪根终在，萌而复生，岂不可惧。当力求往生净土，圆成佛道，普度众生，才是终极之安身立命之法。望多看《安士全书》。
    作善事需从心地，印经当然有功德，但发心却是主要。钱紧张时不必勉强出资，若生懊悔反而不好，可以见善随喜。您说的《观音经》不知是哪一部？普门品，耳根圆通章等是真经。《高王观世音经》是伪经，力量不够，要细鉴。心里要想把印经功德普施一切有情，早得佛道，得大自在，不要独据印经功德。常如是想，世间事不出因果，能饶益有情，则有情能回报以饶益，自他均利。能饶益无情（保护环境等），则无情亦能助我（保护环境能得生住佳境的果报）。
    另外，观世音菩萨感应甚多，多看看事迹。求生净土者，多念阿弥陀佛，多看念佛感应录，往生传等，观世音菩萨和其他众多菩萨自然在左右，可免种种意外不测。小灾小难，能忍则忍，灾难帮我们消业（只要不影响往生就不打紧），切莫怨菩萨不保祐。菩萨知道怎样对我们最好，不必挂心。
    广论是好书，下士道之前的部份可以多看。但若学净土，先要熟悉净土经论。中、上士道品先放一放。蕅益祖师的《阿弥陀经要解》要深入学，愚多少年来每次看都有新收获。《净土十要》，《西方公据》等都要看看。
    其余后谈。


祈请大悲观世音

    everflying：
    我的一位朋友的父母都身染重病，我告诉她到现在这个时候佛法才是唯一的依止处，依靠处，也许这也是机缘到了缘故，所以我告诉她劝她父母学佛。我学佛也不久，具体怎么做我也不知道。不知道她要发愿为父母做点什么？应该怎么办？

    zf：
    建议您朋友，诵念六字大明咒，祈请观世音菩萨来到其父母身边，放大悲光明照耀其父母，使其父母减轻病痛，命终随观世音菩萨往生极乐世界。
    om mani padme hum

    无明：
    世法近感越不相容，出家又有障碍当如何？末学学佛正好10年，十二分惭愧，念佛不很得力。最大一个变化是于世间法越来越不相应，单位开会宣传的那些越来越感到没兴趣，同事和朋友们比着买车买房，我对那些真的没兴趣了。这主要不是我修得如何好，是我有个特殊的儿子。他从小患孤独症（自闭症），至今不会讲话，不明世事，今已经十三岁连吃饭都还要喂，稍不如意就大闹一番。可他的意思却全要凭大人去猜的！可以说是一天天搞得筋疲力竭。我不忍心送他到其他地方，为此，他母亲离开了。我又要工作又要放主要心力在孩子身上，难极了。现在我有点熬不过去了。工作方面压力越来越大，越来越不适应，可孩子却要靠我，保姆随时可能会走掉，她如一走，我很难请来人，也没有人再愿意看这个孩子，太难了。我真是死路一条了！非常想出家，把孩子交给他母亲，可是偏偏她是个能力非常差的人，勉强顾到自已就不错了。真是上天无路入地无门了。

    zf：
    无兄，大事现前，躲不是个办法。躲得了今天，躲不了明天；躲得了今生，躲不了来世。大悲观世音，号称无畏藏，能施众生无畏，灭一切罪，堪为我等依止。以仁兄的精进，若用功方向对路，与大悲观音之本愿相应，离“恶道”之苦应不在话下。


要学会分辨正邪

    要学会分辨正邪

    zf

    “活在当下的意思是无论发生了什么、无论想到了什么、无论感觉到了什么，自己都保持清醒的觉知。”（编按：此篇为批驳一种所谓教人做事要“活在当下”，沉浸在嗔火中再“解脱”的外道言论。）
    如果“活在当下”是老兄所理解的这样，我看这种人才是真正的心理障碍，而且伤害巨大；如果病情严重而不自知的话，来生十有八九要堕入畜生道。当心，当心！因为认为杀生是件可以换取钞票的好事，因而其人就不会因杀生而下地狱了吗？
    觉知，最多可以和八正道中的正念沾点边；请问佛所说之正念？正见呢？正行呢？正命呢？……
    “保持清醒的觉知”下的杀生是正命吗？
    如果只是保持老兄所谓的“觉知”，而不进行善恶的“习惯性分别”，行人怎么会“发现仇恨的情绪不会带来任何有益的结果”？
    这里之“有益”是老兄之“觉知”能发现得了的吗？
    “诸恶莫作，众善奉行”是否是你所说的“习惯性观念和习惯性行为而下意识的产生情绪”？
    兄自认为是佛弟子吗？
    “我不是学禅宗的，但我也记得六祖说过的话，翻译成白话文就是：不思善，不思恶时，什么是你的本来面目。”
    ──你既然未入禅门，六祖开示的甚深奥义岂是门外人依文解义可以会得。
    我要反问的正是：你认为依靠你自己仅有的知识就可以分辨什么善和恶吗？
    以前为了赚钱杀生是恶，现在为了赚钱杀生是恶，将来为了赚钱杀生还是恶！你认为佛的这些戒律过时了吗？
    在下正是因为不敢相信自己的善恶判断，才以佛陀的戒律为判断的标准。请问，你的善恶标准比佛的戒律更可靠吗？
    为了挽救十个人的性命而将强盗制服乃至杀死（杀死强盗，同时亦是除去其造大恶业的机缘，强盗亦得大利益），此乃发心、行为、结果俱善的菩萨行，此为如来所开示。这与你之为了赚钱而心安理得的杀生可以相提并论吗？
    老兄心智糊涂到如此地步，还在论坛上为别人开药方治病，不是害人是什么？
    如果别人因为修学你这些与佛法相违的方法堕入地狱，受无量苦，这果报你怎么承担？你即使在地狱中呆上无量劫，他人的地狱之报可以因此而免除吗？
    最后问一句：兄自认为是佛弟子吗？


你的心病，唯佛法能医好

    身不由已:
大家好，我是名强迫症患者。
    各位好，第一次来，请各位善知识多多关照。
    不知各位听说过强迫症没有？可能大家听的最多的就是强迫洗手，心里知道没必要洗，可仍一遍遍不停的洗，其实强迫症的症状千变万化，举不胜举，可能大家乍一听洗手而已，实不知其中痛苦，有很多乍一听就觉得是很痛苦的症状，表相变化，内心痛苦却都是相同的，可强迫病人有个共同点，总觉得自己的症状是世界上最痛苦的，别的症状都没什么，其实痛苦是一样的。
    我今年25，已经被它折磨了10多年，其间痛苦无法言说，我有几个症状，简单说一下其中一个情况，我有余光恐惧，什么是余光恐惧呢，余光就是目光除了正视能看到的范围，害怕别人发现自己的余光，这种痛苦严重到什么程度呢？说出来各位实不相信，也无法理解。
    首先余光是客观存在的，余光恐惧的人却总想消除余光，这就注定无法解决，总是在注意别人有没有看自己，有没有发现自己有余光，特别害怕在两边的人，所以只要有人就一直处在恐惧中，各位可以想想坐在课堂上是个什么光景，这种恐惧无法形容，是实实在在的恐惧，却想不出恐惧的原因何在，一人独处时也是心存余悸，想着明日上学或外出该怎办，惶惶不可终日。
    我体验最严重的一次是在我上高中时，一早我骑车去上学，出门没多久就不行了，感觉所有人都在看我，其实街上没几个人，头痛欲裂，快要炸开似的，有种快死的感觉，无奈，只得停在路边歇息。
    目前国际尚无根治方法，国内用的最多的就是森田疗法，但效果并不理想。
    本人在10多年中一直处在头痛状态，头发紧的感觉，每时每刻都这样，尝试过种种疗法，进行过无穷思考，和父亲也互相探讨达几年之久，却是徒增迷惑，在百般无奈之际，因看过chaos的《我是怎样信佛的》，遂读南师的《金刚经说什么》，以此为契机接触佛法。
    因本人的特殊情况初学佛法所遇障碍实比一般人为多，经人介绍来此论坛，还望各位善知识多多开示。
    不知我这种情况可否学佛，我这样算不算因为痛苦逃避现实在佛法中寻求安慰？因症状确实让我逃离现实，因症状关系我早已退学，现一人在北京晚上上夜大，白天则呆家中。
    痛苦中人

    齐愍:
要给自己多点信心。
如果你是怕别人看你, 不论出于什么原因，要给自己多点信心。
    提出两个建议：
一、佩带一个真言护身符
    比如六字大明的，在易趣网上很多，或者自己缝制一个。更清晰的图可以自己去google找，要相信自己能找出帮助自己的办法。也可以找一本《新编佛教念诵集》。这个真言的功德，较完整的论述可见《大乘庄严宝王经》。
    二、学会念一个真言
    比如：一切如来心秘密全身舍利宝箧印陀罗尼，这个真言的全面介绍，也就是经文，是记载在《一切如来心秘密全身舍利宝箧印陀罗尼经》，此真言的功德，在其中广泛宣说的。
    佛在讲授这个真言的功德时，曾说：
若人往在高山峰上至心诵咒。眼根所及。远近世界。山谷林野江湖河海。其中所有毛羽鳞甲一切生类。碎破惑障觉悟无明。显现本有三种佛性。毕竟安处大涅槃中。若与此人往过道路。或触衣风或踏其迹。或唯见面或暂交语。如是等人重罪咸灭悉地圆满。
    所以，如果你学会念诵一个真言，那么看到你的人，你应该为他们感到喜悦，微笑的面对吧。
    佩带真言也是类似的。

    zf:
几点建议

    “在百般无奈之际　因看过chaos的《我是怎样信佛的》，遂读南师的《金刚经说什么》，以此为契机接触佛法　”
    ──每个人接触佛法的因缘都不相同，有顺缘也有逆缘，但无论顺逆，我们对此因缘都应心存感激，因为走上学佛之路是多么珍贵啊！与学佛将给我们带来的利益相比，任何代价都是微不足道的。
    建议仁兄放下心来，换个角度看待自己的病，首先学会与病共存──毕竟，此病对您有无比的恩德！
    在安下心后，尝试着按齐愍兄所说的去做，逐渐将精力转移到宝箧印陀罗尼经（或其他你有兴趣、有信心的佛经）上，从听、读开始，直到背诵。
    从佛法的观点看，给我们带来痛苦的根本原因是我们的恶业，而这些恶业又是由我们往世所做之恼害众生的恶行产生。因此心中应常常思维“我昔所造诸恶业，皆由无始贪嗔痴，从身语意之所生，一切我今皆忏悔。”之法义。以如是忏悔的心态去受持宝箧印陀罗尼或宝箧印陀罗尼经，我们的恶业就会如大火中的片片雪花，消失得无影无踪。
    另外，由于你心中“装”上了宝箧印陀罗尼，在佛菩萨和天人的眼中，你在不知不觉间就变成了一座“移动宝塔”！凡看见你或被你看见的人们都将与佛法结下因缘，将来都会从痛苦的轮回中解脱。当你了知这一切时，心底里一定充满了深深的喜悦吧！
    你可能会说，目前自己对这些还不十分相信。不要着急，首先去做──信心是伴随着成功的体验一点点积累起来的。

    “不知我这种情况可否学佛”
    ──没见佛经上说什么人不能学佛。

    “我这样算不算因为痛苦逃避现实在佛法中寻求安慰？”
    ──绝大部分人（当然包括我自己）都是从逃避痛苦到佛法中寻求安慰开始的。

    “因症状确实让我逃离现实，因症状关系我早已退学，现一人在北京晚上上夜大，白天则呆家中”
    ──正好有时间学佛。

    祝您早日康复，学佛精进。
    Om mani padme hum

    见证人:

    我曾为此受苦，我可以作为见证

    ，安心学佛吧，只要你肯真心学佛，用不了太长时间会基本治愈的。(森田也是学佛治愈自己强迫症的)
    我从上初中时有此毛病，高中辍学，其中之苦，自以为是人间地狱吧，以此机缘，后学气功，不治反重，后入佛，现已基本治愈。下面说说我对此病的总结及治愈的经验，希望对你有用：
    一、病因是前世恶业所感，今世缘熟现行。贪心重、淫心重、执着心重、自恋心重(爱面子)是心中的恶业，前世熏习而成，是此病的病根。
    二、强迫症的痛苦之事实际都是无所谓之事，但究因心中业障太重，现在回想当年，实际就是一个‘傻’字概括，过来后只觉可笑，当年脑筋何以至此呢？何等简单之事，竟然有如此笨的想法，真是可笑可怜啊。唉，真是业障啊，唉，真是往事如梦啊！！！(醒了只觉如此简单)
    三、学佛必可治愈，我可作见证，因我深知其苦，且先已脱苦，所以非常希望能帮助你。望建立信心，对佛法深信正信是第一要义。
    四、学佛须从基础学起，看书不要求热闹好看，要扎实学好皈依，树立正信，深信因果并修学出离心、菩提心等正见，且第一要义是依止善知识，依止善知识学习佛法正见，不可自己胡乱看书，那样会走很多弯路的。
    五、精勤忏悔业障，关键是发现自己的错误，并痛改前非。
    六、有能力多做善事，关键是发善心，比如孝敬父母等。有能力也可放生回向。
    七、可多礼佛拜忏。
    八、可每天出去经行，行时心空无住或念佛持咒，在大街上走，可活动气血，晒太阳，还有一个好处是人多的地方，看看那些真正苦难的人，你这病实在是微不足道，自己闹腾，到外面走走，开眼界，会开心不少。
    九、最重要一点，持咒修行，关键的关键。用信心和咒的力量消灭业障，自会渐渐执着心消去，渐渐好转乃至痊愈。用功的要点是：一发现烦恼起，恶念起，即专心持咒转化，但记住，不可硬压，而是转化之，方法要灵活，可出声，可礼拜等等方法与烦恼周旋，但绝不可姑息自己。平时持咒可用金刚持的方法，要摄心听咒，不可散心持。若在学理正见及修行方面有了一定基础，可打坐持咒则最好。
    推荐日常持六字大明咒，具足一切功德与效用，并同时每天持《宝箧咒》。
    以上句句肺腑之言，所列之事，都是经验之谈，望珍重并早日脱离苦海。

    zf:
多么宝贵的现身说法啊！
    建议您和身不由已二位建立email、电话联系，有条件时最好能当面交流。
    想起了那句老话：“榜样的力量是无穷的！”

    身不由已：
    谢谢各位善知识，得到如此多善知识关照，心中说不出的欢喜，自得病以来久已不知快乐为何物。确实，唯有信佛者心中有一片净土，试想其他人等，你死活与我何干？强迫症使我灵性丧失，思维机械，落入唯物深渊，也就是常言说转不过弯来，往后学佛还望善知识们多多开示。


人毕竟最爱自己

    qh：
    我学佛三年，近一年开始打坐，不知何故不到40岁，竟然不来月经了，有时我怀疑与打坐有关，或是别的什么。我不知道这是好事？还是不妥？

    hq：
    女漏已尽，应该是好事情，打坐可以使女漏闭，如果您认为是因为打坐而闭的，那么是很不错的事情，而不是障碍。

    xixi：
    以为打坐引起的变化那种掩盖不住、洋溢着一种沾沾自喜的情形来论，妖言惑众。
    你是坐佛而不知。佛本无住，或卧或坐。众生本心迷，不求心开，打坐打卧，呵呵，贪生惧死罢了。嘻嘻，贪图个证干吗呢，正所谓如人饮水，冷暖自受。打坐时能令身心安静。是思量佛事的机缘。但明明是打坐打出病态了，如何有充沛的精力思量？佛法是生机勃勃的人生，不是病态的腐朽。释迦当年还得益于牧羊女的一碗奶，才有精力的充沛。

    二麻子：
    麻子歪论，吃饭跟学佛毫无关系。不过饭还是要吃的。嘻嘻。想靠吃饭来长生不老的，或者因为吃饱一顿饭就觉得能长生不老的，嘻嘻，就纯属虚妄了。
    xixi整天胡说八道的。每每在关键地方说对几句，却又藏在个不大容易给人看见的地方。难怪EAGLE抱怨。嘻嘻。比如这次，这妖言惑众之说虽说重了点，点到的位置可没错呀。
    我们好像都是关心自己身体远远远远超过关心别人无量数倍呀，xixi看到这个了，你看到了没有？
    身体最重要……凡夫人人如此，本也普通。身体有些变化讨论一下也挺正常。但若这点事居然就能讨论到了什么“漏尽”，真是说明缺乏普通知识，不大懂佛法中打坐的道理。而且这事也实在能看出我们凡夫关心自己远远超过别人。
    到这个年龄，如果过去身体不很正常，则断续现象很容易发生，未必与打坐直接关联。这是最常见的原因。这个原因没排除，大家就认定是打坐造成的，是不是有点糊涂？


一般的心理辅导对“幻听”不易见效

    一般的心理辅导对“幻听”不易见效

    zf

    某兄的建议很好，特别是为您父亲佩带上六字大明咒很重要。

    “我父亲是重症晚期，他是从今年清明节去扫墓开始，5月份查出重症，而且他自己觉得好像去了一趟墓地不是很好，所以我想请问？”
    ──我猜“扫墓”和“重症”两个事件的关系，多半是时间序列上的先后关系，而不是“因”和“果”之间的关系。将先后关系误认为是因果关系是我们经常犯的毛病。

    “我父亲在晚上睡觉的时候总是说有个小孩不让他睡觉，在捣乱，弄得他现在每天晚上都睡不了觉，这样一直有几个月了……”
    ──这种“幻听”的表现，常常是某种严重精神疾病的症状。如果影响到正常生活，应该去看正规的精神病医生，进行相关的药物治疗，一般的心理辅导不易见效并可能耽误治疗的最好时期。


“我破了我慢……”

    “我破了我慢……”

    二麻子

    嘻嘻……通篇在说破我慢破我执破我相……但是总是反复“我破了我慢……”这样的口气。嘻嘻。仔细想这是有点滑稽的。
    只怕说大大放心的，心没果真放大。真若能广大无量，自是与诸佛把臂。
    另一篇的这某女士海外也颇有名声，早些年的学佛人大都知道。她的文章是有价值的，也如痴人说梦兄所说的。这些实际经历的确能给禅修的人提供些见识。但像某女士这样的人确实是少数，这点某先生说的没错，象任督脉动，甚至后来连带脉都动的人，实在不多。所以对多数人来讲，她的经历是不能重复的，故参考作用有限，倒是新鲜感、故事性比较吸引人。反正人都是喜欢猎奇的。
    从她文章里看，如正豪兄言，她还可以做得更好。不干净的地方自己不知道是件可惜的事。麻子提醒某兄也不过是不希望某兄忽略到这点。嘻嘻。因为某兄在禅修方面，是个容易产生类似气脉现象的人。


量力而为的事，别上纲上线

    真化:
如果连死后的尸体都不愿捐的话那还叫什么佛弟子呀！佛法讲六度万行，身命布施，活着时我们做不到，难道死后还要执着这尸体吗？

    二麻子:
量力而为的事，别上纲上线。什么是死亡，死亡的过程如何，医学上的脑死是不是完成了全部死亡过程，这都是些问题。建议你看看西藏生死书。麻子绝对随喜能布施身体的菩萨。但老实说，对我们这些初机行人，要量力而行。


解释什么梦呀

    善男子：
    昨日夜梦，见家父（96年已去世）突然返家，一惊之间觉得有说不出的力量压在身上，透不过气来。当时心中只有一念“阿弥陀佛”。就用力大喊“阿弥陀佛”但却很难张口，但心中还是想一定要念出声，努力之下终于念出声来。一切感觉渐渐就消失了，我也惊醒了……

    二麻子：
    嘻嘻，解释什么梦呀，不如去检查一下心脏……俺话里没玄机……这现象是心脏工作有弱点的极早期征兆之一。要等明显了再去检查出来，大概要等好几年。
    再一可能是睡眠呼吸中断，这也与心脏工作不正常有关。
    俺不喜欢将平常的梦做特异解释。对我们凡夫来讲，99.999％以上的梦，不过就是一堆胡思乱想，没别的大意义。
    心脏的问题还是应该找医生看；因缘法的问题一般原则是循因缘法解决。


每个地方卫生条件不同

    每个地方卫生条件不同

    二麻子

    在麻子看来，坛上讨论的那篇外国评论中国医院现状的文章写的不大公正……小麻子从两个月大就开始打预防针，平均三个月一次，一次两到三针，要打到一岁半才打完。这是在美国的标准做法。怎么不打预防针？
    此外，西方对小病不用大剂量抗生素是有道理的，但也是适合他们的国情而已。因为卫生条件好，一般病不凶，医疗技术又好，有情况也来得及治疗抢救。卫生条件有多好？胳膊划破口子缝8针，缝前创口是用自来水洗的，缝好后根本没吃消炎药，也没感染，当然破伤风预防针是打的。国内有这个条件吗？小孩病了一个不好，会送命的，医生也不愿意这样的事情发生。所以，国内容易多用抗生素的方法确实有它的缺点，但也是适合国情不得已罢了。


关于如何理解太虚大师的“人圆佛即成”思想

    关于如何理解太虚大师的“人圆佛即成”思想

    成军

    这些天网海莲舟佛法论坛上曾有同修提出如何理解“人圆佛即成”的问题，这句太虚大师的名言在今天已经成为许多佛弟子的座右铭。然而，也曾见有的佛弟子把这句话简单地理解成“学佛就是学做人，做好人，人做好了，学佛也就学成了”。因此，如何正确认识“人圆佛即成”，如何继承太虚大师“人生佛教”的遗教，实是个至关重要的问题。
    首先让我们看看太虚大师提出人生佛教和“人圆佛即成”主张的时代背景。清末民初，中土佛教经两千年流传，并遭受多次灭佛法难，已经日渐甚微。由于经典的散失与宗派法脉传承的断绝，许多佛教寺院呈现出义学不振和戒律废驰的局面，不少出家人整天忙于超度死人、赶经忏或经营庙产。在信众方面，佛教信仰被掺入民间鬼神迷信，一般民间信众佛道不辨、神佛不分，更不用说具备佛教的正知见。而知识分子和上层人士中的佛教徒虽然也常常组织各类讲经法会，其中的不少人却不过是把佛学当成生活中的一种调剂与点缀，而非真正以身心投入实践佛法。随着西方科学的传入，一般社会上的人对佛教的印象已是迷信落后、消极避世，只重死人、鬼神，不关心现实等等。在这样的历史条件下，面对西方现代文明与基督教的挑战，当时的中土佛教可以说是到了岌岌可危的生死关头。
    在这种情况下，为了中华大乘佛教的振兴，太虚大师一方面致力改革僧伽制度、培育僧才；一方面提出“仰止唯佛陀，完成在人格，人圆佛即成，是名真现实”的“人生佛教”主张，倡导学习佛陀的人格，“人圆佛即成”。太虚大师在《我怎样判摄一切佛法》一文中谈到：“现在正值佛灭后三千年的末法时期，如果依着声闻行果，是要被世人诟为消极逃世的，如果依着天乘行果是要被世人谤为迷信神权的。不惟不是方便反而成为障碍了。所以在现在的这个形势下，修行者所趋向的目标是应在进趣人乘行，而所依靠的既不是声闻行果，也不是天乘行果，而确定是在人乘行果，以实行人生佛教的原理，依着人乘的正法，先修成完善的人格，保持人乘的业果，方是时代之所需，尤为我国的情形所宜，由此向上增进，乃可进趣大乘行──即菩萨行大弘佛教……”
    由此我们看到，太虚大师“人圆佛即成”的主张并非是孤立的。对于佛教在现代社会如何契机契理地将佛弟子逐步引向究竟一乘的菩萨道，太虚大师有五乘佛法的整体思想。就是从五戒十善的五乘共法（人乘、天乘），到发出离心了脱生死的三乘共法（声闻乘、缘觉乘），最终至发菩提心、自利利他的不共菩萨乘。这五乘佛法也正和中兴西藏佛教的宗喀巴大师之三士道以及菩提道次第遥相呼应。而人生佛教最终的重点还在于在生活中发菩提心、实践菩萨道，即“菩萨学处”。太虚大师对所倡导的菩萨学处的解释是“重在启发初发菩提心愿的菩萨，旨在要人尽能成为大心凡夫的菩萨，不是顿期超过二乘的大菩萨。”
    针对当时乃至现今许多学佛人的通病，太虚大师指出：“向来对佛法有信心的人，便自称学佛；求其真能发菩提心愿做个大心凡夫的菩萨，却是凤毛麟角。有一种人学佛，却将佛推崇过于高远，自甘卑屈，既不能认识佛法全般的真相，固执着佛所权宜方便指示一点一滴的法门，如人间善行，天上福报着重个人福业方面极粗浅的说法，于是一生但求个己人天福报为足。这虽也可称为学佛，但去佛学的真精神远甚，真是方便中的方便，佛曾贬之为无性阐提。”“复有一种人学佛，觉得个己的生与死极苦痛，于是偏执着佛所指示的中道法空有两面的空一方面，以专求了脱个己的生死，精神上得寂灭无为为究极。这条路径虽可通至大乘，倘故步自封，不肯进探中道法的幻有妙有的一面，醉卧于空三昧中，自然未能贯彻佛学全般的精神，自堕于方便小乘，佛曾贬之为无性败种。”“我今倡导菩萨学处，绝不叫人迷着人天的福报，也不叫人愚耽小乘的寂灭，是指示人人可走之路，个个可修之道，是整个的全般的佛法的总纲，这便是菩萨之学。”
    对于修学次等，太虚大师明示为：“故菩萨学处，是从易学处说起，曰皈依三宝；恐人走入歧途，于皈依三宝时兼劝其发四弘誓愿……”在此基础上，此后则有“三乘共戒”、“在家众的五戒十善”、“在家出家的八关斋戒”、“发菩提心”、“学修六度”、“励行四摄”等依次增上。
    直到二十一世纪的今天，太虚大师这些主张仍然可以说是切中要害，发人深思。当今海内外佛教界的许多高僧大德沿着太虚大师指引的方向，倡导“人生佛教”、“人间佛教”、“生活禅”，教导在家弟子在生活中修行，取得了很好的效果。然而，在提倡人生佛教或人间佛教、“在生活中学佛”的同时，我们也应该全面理解大师“人圆佛即成”的教导，不能把“人圆”局限在“人乘”的五乘共法基础阶段，停留在“人乘”的阶段，而不发出离心、不修学菩提心，不向究竟一乘的大乘菩提道迈进。更不能把学佛简化成在生活中做个好人，人做好了，佛就学成了。
    佛陀之所以在人间示现成佛，是为了鼓励我们人道众生，以人身发心修行，一样可以成就圆满佛果。但同时佛陀也教导我们，人身不可迷恋，乃至三界亦如火宅。我们学佛目的是为了在无常的生死苦海中自渡渡人，而成就的关键是建立在出离心、慈悲心基础上的广大愿行菩提心。在初机阶段，学佛先从世间法的基本道德准则如五戒十善入手，把佛法融入生活之中，是非常契机契理的。然而，在人生佛教、人间佛教蓬勃发展的基础上，特别是在目前四众弟子素质普遍提高的形势下，我们更应该进一步宣传五乘佛法次第，鼓励佛弟子长养慈悲心，发出离心、菩提心，实践菩萨学处。这样才能最终将佛弟子导向究竟一乘佛法——大乘菩萨道，如此方不辜负太虚大师的苦心，不负佛菩萨、历代祖师大德的佛恩、师恩。


出世、入世以及修行次第

    问：
    人说“离世觅菩提，恰如求兔角”，南怀瑾的楞伽大意中也说学佛不一定要出世，我觉得只要心中有佛才是最重要的，但在世俗中做起真的很难，容忍别人自己会有很多痛苦，尽管用欢喜心去面对，但当别人把你的善良宽容当成无知时，又该如何呢？

    成军：
    首先，我们应该明了，佛法是建立在世间无常、轮回中无处不苦的基础上面的，我们修学佛法的根本目的是为了出离轮回，离苦得乐。通常我们也把这个修学佛法的根本心念叫作出离心。如果学佛不具备出离心，那么心怀善念或持戒修善，都还只是种人天乘的善因，并不能带来根本解脱。因此，从这个角度来说，学佛是必须出世的。这个世，不是我们通常认为的世俗，而是三界一切处（包括拥有相当福乐和清净的天道）。
    我们学佛修行，是在于时时刻刻（实修时就是包括座上和座下）调整自己的心念、觉照并对治自己的贪嗔痴习气，直到逐渐突破能所对立，最终实证众生本具的般若智慧。因此，学佛又并不是要另外去找一个什么能够让我们心清净的特殊地方，更不可能就能一下子逃避得了种种人事间的因缘纠葛。所谓菩提，就是我们众生本具的觉性。六祖大师的偈子“离世觅菩提，恰如求兔角”意在教导我们，学佛修行就在我们生活的每个当下。我们出离世间的方法，就是要在这因缘相续、本性空幻的世间逐步证悟“诸法无我”，而不是逃避到一个世间以外的地方。就好比佛法的空不是去追求空无，而是要认识到诸法都是因缘所成，并无恒常不变的自性，当体即空。
    这里还有一个误区，就是很多人以为学佛学禅就是当下“心中有佛”、“心怀善念”就可以了，还有人把“活在当下”误解成不必修学佛法，只管当下活好。事实上，我们无始以来的习气很重，因为无明的障蔽，心念中善法少而恶法多，只是平常心念不够细而往往不自知罢了。因此，时时刻刻对治习气烦恼、在生活中修行绝不是说不必皈依、不用亲近善知识、不要学教理也不需要打坐。因为没有这些作为助缘，我们是根本没有力量认知和对治自己的习气的。所以说，“活在当下”的生活禅，应该是让我们在生活中的每一刻努力培养心灵的敏锐与觉醒，尽可能对治习气，并和座上专心修持相辅相成，而不是象许多人误解的那样随着当下这一念被业力习气牵着鼻子走了，还反过来在佛法里面寻找心理平衡！
    具体做起来，因为我们的智慧毅力不足而业障习气却很重，因此会觉得很难。但是，我们不能因为怕难而畏缩不前。因为我们无始以来已经经受了无数轮回的痛苦，解脱的道路今生不走将来吃够了苦头也还得走。那么该怎么办呢？后学个人体会是学佛首先必须依止善知识，也就是说要经常向那些学修有成的过来人学习，因为只有他们才能发现你的毛病、问题，指出你前面该走的道路。另外一点，就是明了修行的次第。初入门时应该深信因果不虚，经常思维人身难得、佛法难闻，经常观察世间的无常与轮回的痛苦，并且要对佛法具足真实信心──唯有佛法僧三宝才能救度我们，从而发起真正的皈依心。这样才算是真正入了佛门。把这些心念归并到一起，就是发舍离世间的出离心。再进一步，思维一切众生都在轮回中间受苦也都希望离苦得乐，而在无始轮回里面，众生又都曾经做过我的父母，于我有无量的恩德。从而由培养自己的慈悲心开始逐渐引发利益一切如母有情的菩提心。由此方是修学大乘佛法之始。学佛修行中，正见是实修的明灯，诸法因缘假有而自性本空的正知见是我们修行不走错路的保证。以正见为基础，在善知识的教导下，我们应该实践止观，以禅定和智慧觉照的力量打破我们生死的根本──无始无明。故此宗喀巴大师把佛法的精要归结为三主要道：出离心、菩提心和空性慧。
    我们初学佛时，在生活中最主要的是受持五戒，先做到不损恼他人。面对人事的种种不圆满，我们必须明白这些是我们自己过去种下的因成熟的果报，没有什么可以抱怨的。达摩祖师有句话：“随缘消旧业，不再造新殃”，就是很圆满的概括。至于其他人因为我慢和我执，不能理解您的善良宽容，您也不必痛苦。要相信因果，如果您始终实践善法、利益他人，自然会渐渐为众人所理解接受，而自身的福报也会慢慢好起来，并且逐渐具备修学佛法的顺缘。从更深的层次看，担心别人的不理解，起因还是来源于对自我的执着，通过修学佛法，破除我执，这样的担心也就变得没有必要。
    今生能够信受佛法，是我们多生以来善根成熟的福德因缘。真心祝愿您珍惜这比如意宝珠还要珍贵的人身，归依三宝、亲近善知识，精进地学佛修行。


明信因果是学佛修行的基础

    明信因果是学佛修行的基础

    成军

    明信因果是学佛修行的基础。首先，佛法的义理和实证都是建立因果之上的，用较“学术气”的说法，是建立在缘起法则上面。也就是因缘法的不断相续，众生所作的业果不失。具体说，就是有情众生在生生世世的轮回中，所造的业作为因，随着外缘的变化，象种子那样生根发芽，最后显现出业果，又构成下面的因，循环往复。
    对於现代人学佛，明信因果却是最难过的一关。即使不信佛法的一般受过教育的人，对於作为东方圣哲--佛陀的智慧，往往是钦佩的。但是要他们相信因果，进而受持三皈五戒、学佛修行，却是很难的事情。
    因果之说并非佛法所特有，古印度和其他宗教的一些外道思想家也有说因果的。现代科学里面，因果律更是基础。但是佛法的因果与外道、科学又有不一样的地方。佛法的因果和诸外道不同的地方，在于佛法的因果是建立在缘起性空智慧之上，既承认因缘的相续不失，又认识世间法的如幻，并指出实证空性的解脱道路。而外道因为不具备缘起无我的智慧，往往把业果执实，背离中道。要么是一味追求生天享乐，要么就是背负原罪的包袱以苦行等方式折磨自己“赎罪”。值得注意的是，我们一些佛弟子，知见不够纯正，受气功和外道的影响，也会犯类似的错误，以为单纯地苛刻折磨自己就是修行。
    佛法的因果律和科学不同的地方是，科学的因果律局限于人类的感官和科学仪器所观察到的客体，而佛法侧重的是有情众生自身。当然佛法和科学的因果律有共通的地方(例如受了凉会感冒)，这一部分也是我们所容易接受的。我们难以接受的是我们所看不到、无法直接体验的那部分。那么我们该怎么办呢？
    在经典里面，佛陀教导我们，获得正确的知识有三种主要的方式：现量、比量、圣言量。现量是我们能够亲身体验到，认为它正确而获得的知识。比量，是当我们用现量的知识还没有办法得到结论时，我们通过推理的方式所得到的知识。圣言量，是指圣人(证悟空性的佛菩萨阿罗汉)所讲的道理。因为他们的能力智慧远远高于我们，我们相信他们所说的道理是可信的。
    对於因果的了知，我们也是通过现量、比量、圣言量而逐渐获得。首先，我们可以在现实生活中间细心体会因果和业报。现代社会的节奏比古代快，因缘果报来的也快，少年中年时候种的因，到了老年，果报往往就能显现。其次，可以根据佛法对於缘起法的阐述、心识的分析等方面，结合我们的现实生活，细心思维其中的道理。例如开始微细的习气是如何渐次增长，最后使我们造业，而作造的业又如何构成因缘法新的因。对於我们自身、对於他人，都可以依照佛法的道理来细心体察、思维，这样的体察思维本身也是佛法修学的一部分。随着智慧的不断增长，我们对於世间万象和自己身心背后的因果规律，往往会越来越看的清楚。这些主要是从现量和比量的角度。
    对於我们初修凡夫来说，更重要的是先接受圣言量，也就是相信佛菩萨说的因果。初看起来，这样的做法有“迷信”的地方。但是，仔细想想，我们对於科学的相信，又有多少是出於现量、比量？多数人不也是相信科学家们的“圣言量”？我们为什么相信佛菩萨呢？因为作为佛弟子，我们相信佛是觉悟真理的圣者，他的言教是真实不虚的。具体地，通过研读经论，我们可以感受到佛法的智慧。而在现实生活中，我们去参访那些教导我们佛法的善知识，可以直接感受到他们的慈悲和智慧。
    学佛修行是有次第的，作为初修凡夫，我们不可能一下子就“证得”因果。但是我们可以从通过现量、比量、圣言量，先相信因果的真实不虚。然后在此基础上，谨慎收摄自心，约束自己的言行，逐渐对治习气、增长智慧，最终能够亲证佛法，到那时候对於因果也就自然明了。如果因为无法接受因果的圣言量而始终在佛门外徘徊，便如入宝山而空回，实在是可惜了此大好的人身和听闻佛法的善缘。


第一位的是去体会苦，并决定离苦

    秀文：
    请教：我们应该希求多闻呢？还是悟空？谁是第一位的？

    zf：
    第一位的是去体会苦，并决定离苦。

    慧心通明：
    我热爱生命，当疾病死亡来临的时候，我虽感痛苦，但悦纳它，因为生老病死是生命的自然，正因如此，生命才显得曲折生动，弥足珍贵。朝闻道，夕死可乎，就是对生命的眷恋，对死亡的微笑。
    我热爱生活，爱幸福不幸顺境逆境交织在一起的生活，因为这才是原味儿的本真的生活，风雨之后的彩虹愈加美丽。欢乐的生命颂歌怎么能缺少魔鬼的敲门声？
    我热爱生活，在生命的痛苦中彼此扶助才显温暖善良仁爱慈悲的高尚。没有痛苦如何能品到如此高贵的人类精神？
    为什么要出离？如果要出离，接纳了就是出离了。共享了就是出离了。融合了就是出离了。
    承认生命的局限，接纳生命的本真，爱自己爱他人爱世界，彼此包容彼此关怀，体验生命共享生命。
    我想出离痛苦并不是不要痛苦，而是寻找接纳痛苦善待痛苦的方式。

    zf：
    如果“彼此扶助”和“温暖善良仁爱慈悲”不是指向离苦得乐，它们还是“高尚”的吗？

    “没有痛苦如何能品到如此高贵的人类精神？”
    ──如果没有疾病，我们无法了知医者的重要。但我们能因此得出“疾病是不需要离弃”的结论吗？

    “为什么要出离？如果要出离，接纳了就是出离了。共享了就是出离了。融合了就是出离了。”
    ──给我的感觉是，一个病人在质问和开导另一个病人:“为什么要去治病？如果要治病，接纳病了就是治好了。共享病了就是治好了。与病融合了就是治好了。”

    江边有鸟：
    笨鸟不知苦从何来？勇在何处？为我分解分解。

    zf：
    苦从三毒来，知苦之所来，而心生忏悔之意，发不再造之誓愿，此即为勇。
    在下觉得，若要修行得力，基本功是至关重要的。正因为如此，西藏的一些大德认为，“人身难得”、“生命无常”、“业与因果”、“轮回是苦”等共同加行是极为深奥和重要的修持。缺乏了这些基础的修行，就如同在沙滩上建高楼。
    在这些共同加行上下功夫后，自己是病人、如来为医王、佛法为妙药的感觉就会油然生起。
    洛本仁波切的《四共加行》（见“佛典宝库”网站）清晰明了，建议兄仔细研读。

    mfe6000：
    请问如何用佛法来加强个人意志力，决断力，行动力？

    zf：
    答非所问。我想，比加强这些能力更重要、更基本的问题是，将要利用这些能力去干什么！如果目标出了问题，能力强者闯下的祸可能更严重。

    智行：
    mfe6000，有办法！先以苦谛和集谛思维入手，先要认识现前的苦，美国人用“irritated”一字，很微妙。大凡人缺乏意志力是因为舒适惯了，所以老要呆在这舒适区里（comfort zone）。要振作起来，就要走出这个舒适区，先要让每个人都“got irritated”，也就是先要认识到问题，尝到苦味，并且感到问题非解决不可，这样就下决心走出来了。大凡要成就，不管是世间还是出世间，要诀都在以认识或感受“苦”为先。一般世间以没钱、没时间、没自由为苦，事业上成功的人一定在这方面有很强的离“苦”意识，这是他们成功的原动力，所以有经验的老板在雇人的时候特别注意其动机（motivation）。先深刻认识“苦”，生起离“苦”的愿望，然后寻找解决的途径、对途径生起信念、制定目标、实施计划、付诸行动（这些也可以归结成“信、愿、行”），最终结果。
    佛法也一样，以人生八苦、种种不自在为“苦”，也是先深刻认识“苦”，也是以信、愿、行来成就结果。佛法的教学是非常圆满，把它用于世间事业也一定能成功，只是我们大部份人，学得太多，用得太少。
    至于修定、修禅等等能否加强意志力，愚个人觉得纵使修定、修禅、修其他行，主要道理都来自“苦”这一字，印光大师说把“死”之一字挂在头上，更进一步了，因为“死”是“苦”之极。余此类推，纵使是到菩萨位次，还是以苦为师吧？只不过，那时是以众生苦、或以种智未圆为苦谛。“苦”字妙吧？

    zf：
    是啊，“至于修定、修禅等等能否加强意志力，愚个人觉得纵使修定、修禅、修其他行，主要道理都来自‘苦’这一字，……”“苦”如皮鞭，抽打在我们这些懒牛的屁股上，前行。

    mfe6000：
    具体如何操作呢？

    智行：
    思维观察。具体思维观察什么要结合各人自己的目标，有求财富，求健康，求名闻，求自在，求解脱，求一切众生俱得解脱。后后超前前，但是我们世间人做起来往往先从前头做起，得了前头的不忘后头的就不错了。前头没落实，直接求后头的对大部分人较难，也有大根器人能一口气全部放下身心世界，成就解脱道。只是许多人都半途而废，大凡也是有许多因缘事与愿违，仁者自当考量。
    求财富，求健康，求名闻，就要多思维“如果缺乏这些东西时会有哪些苦”，加上观察，体会，甚至可以去经历一下。愚个人不是大根器，不敢轻视这些世间福报，因为如果缺钱，叫我去讨饭吃，我会受不了。缺健康、名闻也差不多。
    求自在、求解脱，就要多思维缺乏这些东西时会有哪些苦，原则一样，思维六道轮回苦。佛祖都为我们说了，我们只要去观察、体会人生三苦、八苦等等。
    顺便一提，所谓的意志力就是愿力，愿力的核心就是求离苦得乐。佛愿力大，因为佛有个大“苦”，就是众生没成佛。只要有一个众生未成佛，十方佛都有这个苦，都不入涅槃，何况有无边众生。佛也有大乐，只要有一个众生得度，十方诸佛皆得大乐。众生往生净土，不但是度己苦，也是在度佛之苦。佛在度众生，众生也在度佛。这个我们要常常提醒自己，在求世间福报时，不要把它忘了。


初学者怎样修习共同加行？

    XLS：
    赵叔，初学者怎样能修习好共同加行？所谓“人身难得”“寿命无常”“轮回过患”“业之因果”。　怎样修行才能把他们融入自己的相续之中？　在开始这些最基础的修行前是不是需要先归依某个密宗的上师，或者不必一定是密宗，显宗的出家法师也可以呢？

    zf：
    X兄，“四共加行”所开示的四个方面的内容，如果有老师指导更好，若一时没有法师指导，通过阅读大德法师们的文章，加上自己的思维，在心中能够生起人生难得、轮回即苦的感受，觉得自己真的应该开始学佛了，并准备克服修行路上的一切障碍。到这个程度就可以继续往前走了。将来在修行路上遇到大的障碍时，难免会产生气馁或为难情绪。这时再回过头来复习四共加行的内容，发现除了努力修行，就得沉沦，从而进一步增加修行的动力。
    在四共加行有了一定基础后，该做的就是：礼敬三宝（其中的僧宝就是解脱路上的老师，通常此时需要跟随法师学习。因为没有老师自学，可能误解法义，走弯路或错路。），发出离心，修习戒定慧。若能发为利众生要成佛的心就更加殊胜。作为一个阶段性的目标，此生也可发愿往生极乐，待修至不退转时，再到十方世界利益众生，这与自己所发的菩提心也不违背。若不欲往生极乐，发愿在恶世修行，十方诸佛同样赞叹。
    至于跟显宗或密宗的法师学，要看个人的因缘。只要是“贤圣僧”都可以依止。


以为有“我”的想法可以自然止息吗？

    我：
    一个小小的观点。若真有苦，苦何能灭？
    若苦实在，如何能够止息？
    其实不用灭，苦生必灭，不灭的是对苦的不满。
    其实不用止息，生起的必然止息，不止息的是以为有一个“我”。

    zf：
    请问“我”兄，“若真有苦，苦何能灭？若苦实在，如何能够止息？”
    ──请问：除了“真有”和“实在”之外，是否还有其他能生起苦的方式？

    “其实不用灭，苦生必灭，不灭的是对苦的不满。”
    ──对苦不满有什么过错吗？

    “其实不用止息，生起的必然止息，不止息的是以为有一个‘我’。”
    ──请问，以为有“我”的想法可以自然止息吗？

    齐愍：
    “我”兄，想起两句佛经，拿出来大家参详参详。
    “世尊。若无如来藏者。应无厌苦乐求涅槃。何以故。于此六识及以所知如是七法。刹那不住不受众苦。不堪厌离愿求涅槃。如来藏者。无有前际无生无灭。法受诸苦。彼为厌苦愿求涅槃。（大宝积经卷胜鬘夫人会）”
    “世尊。断脱异外有为法依持建立者。是如来藏。世尊。若无如来藏者。不得厌苦乐求涅槃。何以故。于此六识及心法智。此七法刹那不住。不种众苦。不得厌苦乐求涅槃。世尊。如来藏者。无前际不起不灭法。种诸苦得厌苦乐求涅槃。（《胜鬘师子吼一乘大方便方广经自性清净章》）”


控制“欲望”与“思维轮回过患”

    苦恼中：
    奈何欲望起时，往往明知故犯，奈何？这才是我苦恼所在啊，请您慈悲。也可能是我对轮回没有证量的关系吧？于止观上下手，是不是个入处？若是，却怕缓了一些。

    静风:
依据菩提道次第谈谈个人的修学体会……
    思维修是修行中很重要的一部分。很多人仅仅把止观作为修，不怎么重视思维修。思维修是把所听到的佛法的含义反复地进行思考，从而对于这些道理生起很坚固的定解。这种定解也会引发比较坚固的记忆，或者叫忆持力。如果说仅仅是听闻到的，恐怕是很难久远。但经过反复思维过的道理，在人的印象里是很深的。小时候学习的时候都会有类似经验。如果一个物理定理，自己经过反复证明思考过，那持续的记忆就很深刻。反之那些仅仅是记住的，就会很快忘记。所以思维的力量可以使听闻的佛法道理深刻的印在识田里。学习佛法的目的就是修证我们的心，使我们按照佛法教导的正确的道理去思维。思维所产生的力量也会变成一种习气带到下一生去。有的人一生下来就会对某种东西有天赋，这都是上一生在那方面思考比较多的。同样如果佛法上思维的比较多，下一生也会对佛法很快相应。止观的修习需要以在思维修中所生起的定解和忆持力为基础。比如皈依三宝进行观修，皈依三宝依据道次第有两种因：一是怖畏三恶道苦，二是相信三宝的功德有能力救护我们。这时候，如果脑子里三宝的功德一点没记住，也没有定解，只有感性的认识感觉三宝好，那在观察修的时候观察什么呢？相反，如果闻思上下过功夫，对于三宝的功德，比如观察佛的功德时，知道佛有十力、四无碍智、四无畏、十八不共法等不共功德，这样具体的观察就能对于佛陀的功德生起信心，然后再说相信佛陀真的有能力救护我们，也就有了真正的理由。所以思维修生起的定解和忆持，可以进一步的帮助止观的修行。对于思维修的重要性，宗大师在《广论》里有一句很重要的话：“数数思维谓之修”，说明思维本身就是修行。另外思维最好和听闻同时进行，有很多人在开始听闻佛法的时候，比较重视文字的学习，喜欢作笔记等。效果更好的方式是如佛陀在每次讲经时所说的：谛听谛听，善思念之。就是听闻的同时一边进行深入的思维。这样听闻的第一遍就可以留下很深的印象，非常容易接受相应的含义。《菩提道次第广论》中教授了两种最普遍的思维修：思维功德胜利和思维过患。对于我们要修行生起的功德，开始就要思维它们的胜利，才能发起希求欲得的心。比如对大乘道的能入，是思维大乘道的广大自利利他功德；对于菩提心的生起，先思维菩提心的功德；对于六度法的修行，先思维修六度法的胜利和修行六度必成佛果。思维功德利益，可以引发强烈的善法欲，这是引发修行精进的动力。对于要断的，比如烦恼，要思维它们的过患。比如贪嗔痴三毒的过患是入三恶道，和别别思维十黑法的过患等。观察过患才能生起厌患心和远离心。思维修和观察修联系在一起，是以分别智修行的最重要的两个方法。道次第中很多教授都是靠思维修为主成办的……

    zf：
    关于“欲望”，我想，第一步是将其控制在一定程度上，不令其泛滥，不致于干扰每天的“修行功课”。在此基础上再从长计议。
    “思维轮回过患”这种思维修的方法看似缓慢，但效果稳定而有效，并直接触及问题的根本。静风兄在《佛教在线电子杂志》上发表之《依据菩提道次第谈谈个人的修学体会》是一篇值得认真研读的好文章，其中关于“思维修”的部分如上，希望能对您有帮助。


依佛陀戒律是对佛陀真正的臣服

    依佛陀戒律是对佛陀真正的臣服

    zf

    （下文双引号中是一位网友的原话。）

    “他以他当时的经验为这些弟子建立戒律，而这些戒律过了两千五百年，还是否实用，显然是个疑问。”
    对我们在家居士来说，五戒十善这些戒律的根本会随着时间的推移而不适用吗？
    另外，你的问题远远不止对戒律的怀疑。为赚钱心安理得地杀生不算恶法，这是何等严重的邪见！你不但自持此等邪见，而且在佛教论坛上传播此邪见，致使那些不明真相者以为此邪见是佛陀正见，这其中的因果我真不知你怎么承担得了！
    对善恶因果认识得如此错误，你自以为是的“空性慧”自然如同建在沙滩上的楼房。

    “最后我向那自觉、觉他、觉行圆满的佛陀祈祷，祈祷他能够以无边的智慧和力量，断除我心中的身见、疑见、戒取见。”
    ‘佛陀的觉行并不圆满，佛陀的智慧和力量是有限的，因为佛陀没有智慧指导两千五百年以后人的修行。他临终时虽告诉弟子要以戒为师，但他制定的戒律却过时了，因为以我自己直观的结果，即使杀生这一戒，只要我认识到，因为杀生可以赚钱，从而在杀生时心安理得没有罪恶感，杀生也不是恶业，不会受恶报。’
    以上话语是在你向佛陀祈祷的同时，你心中的另一个声音。

    “我已经养成了直观的习惯，而且我的思维也总是瞄准对象的前因后果。”
    如来所说之十二支因缘，你的直观亲证了吗？为赚钱心安理得杀生的因果也是你直观的吗？

    “抱歉了，也许对于你来说我不配称为一个佛教徒，但我想说，这世界上没有任何宗教有权力让人变成不能独立思考、麻木不仁的机器。”
    没有人强迫你变成什么机器，走什么路是你自己的选择。我所担心的只有一条，别让不明真相者因在佛教论坛上听了你的邪见导致堕入地狱，从而增加对佛法的误解！

    “我臣服于佛陀的无畏，能把自我的无明根除；我敬仰佛陀的精神，能为世上人造福”
    不错，但还远远不够。重要的是，你应该依止佛陀的教法──诸恶莫作，众善奉行，自净其意。
    而最根本的善恶标准应依佛陀戒律，而不是你自己的“经验”。如是方是对佛陀真正的臣服，否则，不过是自欺欺人！

    经论选录：
    大般涅槃经对戒律的开示

    长寿品第四

    佛复告诸比丘。汝于戒律有所疑者今恣汝问。我当解说令汝心喜。我已修学一切诸法本性空寂明了通达。汝等比丘。莫谓如来唯修诸法本性空寂。复告比丘。若于戒律有所疑者今悉可问。时诸比丘白佛言。世尊。我等无有智慧。能问如来应供正遍知。所以者何。如来境界不可思议。所有诸定不可思议。所演教诲不可思议。是故我等无有智慧。能问如来。世尊。譬如老人年百二十身婴长病。寝卧床席不能起居。气力虚劣余命无几。有一富人缘事欲行当至他方。以百斤金寄彼老人。而作是言。我今他行以是宝物持用相寄。或经十年或二十年。事毕当还还时归我。是老病人即便受之。而此老人复无继嗣。其后不久病笃命终。所寄之物悉皆散失。财主行还求索无所。如是痴人不知筹量所寄可否。是故行还求索无所。以是因缘丧失财宝。世尊。我等声闻亦复如是。虽闻如来殷勤教戒。不能受持令得久住。如彼老人受他寄付。我今无智于诸戒律当何所问。佛告比丘。汝等今者若问于我。则能利益一切众生。是故告汝。诸有疑网恣随所问。时诸比丘白佛言。世尊。譬如有人年二十五盛壮端正。多有财宝金银琉璃。父母妻子眷属宗亲悉皆具存。时有人来寄其宝物。语其人言。我有缘事欲至他处。事讫当还还时归我。是时壮夫守护是物如自己有。其人遇病即命家属。如是金宝是他所寄。彼若来索悉皆还之。智者如是善知筹量。行还索物皆悉得之无所亡失。世尊亦尔。若以法宝付嘱阿难及诸比丘。不得久住。何以故。一切声闻及大迦叶悉当无常。如彼老人受他寄物。是故应以无上佛法付诸菩萨。以诸菩萨善能问答。如是法宝则得久住。无量千世增益炽盛利安众生。如彼壮人受他寄物。以是义故。诸大菩萨乃能问耳。我等智慧犹如蚊蚋。何能咨请如来深法。时诸声闻默然而住。尔时佛赞诸比丘言。善哉善哉。汝等善得无漏之心。阿罗汉心。我亦曾念以此二缘。应以大乘付诸菩萨令是妙法久住于世。尔时佛告一切大众。善男子善女人。我之寿命不可称量。乐说之辩亦不可尽。汝等宜可随意咨问若戒若归。第二第三亦复如是。尔时众中有一童子菩萨摩诃萨。是多罗聚落婆罗门种姓大迦叶。以佛神力即从座起。偏袒右肩绕百千匝。右膝着地合掌向佛而白佛言。世尊。我于今者欲少咨问。若佛听者乃敢发言。佛告迦叶。如来应供正遍知。恣汝所问。当为汝说断汝所疑令汝欢喜

    尔时迦叶菩萨复白佛言。世尊。如来哀愍已垂听许今当问之。然我所有智慧微少犹如蚊蚋。如来世尊道德巍巍。纯以栴檀师子难伏不可坏众而为眷属。如来之身犹真金刚。色如琉璃真实难坏。复为如是大智慧海之所围绕。是众会中诸大菩萨摩诃萨等。皆悉成就无量无边深妙功德犹如香象。于如是等大众之前。岂敢发问为当承佛神通之力。及因大众善根威德。少发问耳。即于佛前以偈问曰

    云何得长寿　　金刚不坏身
    复以何因缘　　得大坚固力
    云何于此经　　究竟到彼岸
    愿佛开微密　　广为众生说
    云何得广大　　为众作依止
    实非阿罗汉　　量与罗汉等
    云何知天魔　　为众作留难
    如来波旬说　　云何分别知
    云何诸调御　　心喜说真谛
    正善具成就　　演说四颠倒
    云何作善业　　大仙今当说
    云何诸菩萨　　能见难见性
    云何解满字　　及与半字义
    云何共圣行　　如娑罗娑鸟
    迦邻提日月　　太白与岁星
    云何未发心　　而名为菩萨
    云何于大众　　而得无所畏
    犹如阎浮金　　无能说其过
    云何处浊世　　不污如莲华
    云何处烦恼　　烦恼不能染
    如医疗众病　　不为病所污
    生死大海中　　云何作船师
    云何舍生死　　如蛇脱故皮
    云何观三宝　　犹如天意树
    三乘若无性　　云何而得说
    犹如乐未生　　云何名受乐
    云何诸菩萨　　而得不坏众
    云何为生盲　　而作眼目导
    云何示多头　　唯愿大仙说
    云何说法者　　增长如月初
    云何复示现　　究竟于涅槃
    云何勇进者　　示人天魔道
    云何知法性　　而受于法乐
    云何诸菩萨　　远离一切病
    云何为众生　　演说于秘密
    云何说毕竟　　及与不毕竟
    如其断疑网　　云何不定说
    云何而得近　　最胜无上道
    我今请如来　　为诸菩萨故
    愿为说甚深　　微妙诸行等
    一切诸法中　　悉有安乐性
    唯愿大仙尊　　为我分别说
    众生大依止　　两足尊妙药
    今欲问诸阴　　而我无智慧
    精进诸菩萨　　亦复不能知
    如是等甚深　　诸佛之境界

    尔时佛赞迦叶菩萨。善哉善哉。善男子。汝今未得一切种智。我已得之。然汝所问甚深密藏。如一切智之所咨问等无有异。善男子。我坐道场菩提树下初成正觉。尔时无量阿僧祇恒河沙等诸佛世界有诸菩萨。亦曾问我是甚深义。然其所问句义功德。亦皆如是等无有异。如是问者则能利益无量众生。尔时迦叶菩萨复白佛言。世尊。我无智力能问如来如是深义。世尊。譬如蚊蚋不能飞过大海彼岸周遍虚空。我亦如是。不能咨问如来如是智慧大海法性虚空甚深之义。世尊。譬如国王髻中明珠。付典藏臣藏臣得已顶戴恭敬增加守护。我亦如是。顶戴恭敬增加守护如来所说方等深义。何以故。令我广得深智慧故。尔时佛告迦叶菩萨。善男子。谛听谛听。当为汝说。如来所得长寿之业。菩萨以是业因缘故而得长寿。是故应当至心听受。若业能为菩提因者。应当诚心听受是义。既听受已转为人说。善男子。我以修习如是业故。得阿耨多罗三藐三菩提。今复为人广说是义。善男子。譬如王子犯罪系狱。王甚怜愍爱念子故躬自回驾至其系所。菩萨亦尔。欲得长寿应当护念一切众生同于子想。生大慈大悲大喜大舍。授不杀戒教修善法。亦当安止一切众生于五戒十善。复入地狱饿鬼畜生阿修罗等一切诸趣。拔济是中苦恼众生。脱未脱者。度未度者。未涅槃者令得涅槃。安慰一切诸恐怖者。以如是等业因缘故。菩萨则得寿命长远于诸智慧而得自在。随所寿终生于天上。

    尔时迦叶菩萨复白佛言。世尊。菩萨摩诃萨等视众生同于子想。是义深隐我未能解。世尊。如来不应说言菩萨于诸众生修平等心同于子想。所以者何。于佛法中有破戒者作逆罪者毁正法者。云何当于如是等人同子想耶。佛告迦叶。如是如是。我于众生实作子想如罗睺罗。迦叶菩萨复白佛言。世尊。昔十五日僧布萨时。曾于具戒清净众中有一童子。不善修习身口意业。在隐屏处盗听说戒。密迹力士承佛神力。以金刚杵碎之如尘。世尊。是金刚神极成暴恶。乃能断是童子命根。云何如来视诸众生同于子想如罗睺罗。佛告迦叶。汝今不应作如是言。是童子者即是化人非真实也。为欲驱遣破戒毁法令出众故。金刚密迹示是化耳。迦叶。毁谤正法及一阐提。或有杀生乃至邪见及故犯禁。我于是等悉生悲心。同于子想如罗睺罗。善男子。譬如国王诸群臣等有犯王法随罪诛戮而不舍置。如来世尊不如是也。于毁法者。与驱遣羯磨。呵责羯磨。置羯磨。举罪羯磨。不可见羯磨。灭羯磨。未舍恶见羯磨。善男子。如来所以与谤法者作如是等降伏羯磨。为欲示诸行恶之人有果报故。善男子。汝今当知。如来即是施恶众生无恐畏者。若放一光若二若五或有遇者悉令远离一切诸恶。如来今者具有如是无量势力。善男子。未可见法汝欲见者。今当为汝说其相貌。我涅槃后随其方面。有持戒比丘威仪具足护持正法。见坏法者即能驱遣呵责纠治。当知是人得福无量不可称计。善男子。譬如有王专行暴恶会遇重病。有邻国王闻其名声兴兵而来将欲灭之。是时病王无力势故方乃恐怖改心修善。而是邻王得福无量。持法比丘亦复如是。驱遣呵责坏法之人令行善法。得福无量。善男子。譬如长者所居之处田宅屋舍生诸毒树。长者知已即便斫伐悉令永尽。又如少壮首生白发愧而剪拔不令生长。持法比丘亦复如是。见有破戒坏正法者。即应驱遣呵责举处。若善比丘见坏法者。置不驱遣呵责举处。当知是人佛法中怨。若能驱遣呵责举处。是我弟子真声闻也。迦叶菩萨复白佛言。世尊。如佛所言。则不等视一切众生同于子想如罗睺罗。世尊若有一人以刀害佛。复有一人栴檀涂佛。佛于二人若生等心。云何复言当治毁禁。若治毁禁。是言则失。佛告迦叶。善男子。譬如国王大臣。宰相产育诸子。颜貌端正聪明黠慧。若二三四将付严师。而作是言。君可为我教诏诸子。威仪礼节伎艺书数悉令成就。我今四子就君受学。假使三子由杖而死。余有一子必当苦治要令成就。虽丧三子我终不恨。迦叶。是父及师得杀罪不。不也世尊。何以故。以爱念故为欲成就无有恶心。如是教诲得福无量。善男子。如来亦尔。视坏法者等如一子。如来今以无上正法付嘱诸王大臣宰相比丘比丘尼优婆塞优婆夷。是诸国王及四部众。应当劝励诸学人等令得增上戒定智慧。若有不学是三品法懈怠破戒毁正法者。国王大臣四部之众应当苦治。善男子。是诸国王及四部众当有罪不。不也世尊。善男子。是诸国王及四部众尚无有罪。何况如来。善男子。如来善修如是平等。于诸众生同一子想。如是修者是名菩萨修平等心于诸众生同一子想。善男子。菩萨如是修习此业便得长寿。亦能善知宿世之事


持戒窍诀

    持戒窍诀

    zf

    噶玛恰美仁波切在《大手印与大圆满合修》中开示了如下之持戒窍诀。
    现由英译中如下，供养坛上诸兄：
    After having entered the gate of Dharma and received empowerment，
    reading transmission，and instruction，
    If you don’t observe your vows and samayas,
    It will ruin you just like medicine that has turned into poison。
    进入佛门、接受灌顶、阅读传授的教言之后，
    若不遵守戒律和三昧耶，
    你将因此堕落，如妙药变成毒药。

    If you don’t know the details of how to observe them and have
    difficulty keeping them，
    It will suffice to keep them condensed to their essence，in the
    following way：
如果你不知道持戒之详情而难以护持之，
    以下面的方式将戒律浓缩为其精髓而持之亦足够：
    To place your total confidence in the Three Jewels，
    Will suffice for keeping the refuge precepts.
    To refrain from ever causing harm to others，
    Will suffice for keeping the disciplines and precepts of
    Individual Liberation.
    全心相信三宝，对守护皈依戒来说已经足够。
    戒除任何对其他众生的恼害，对守护别解脱戒来说已经足够。

    Dedicate all your virtuous deeds to the universal benefit of all beings。
    To try to benefit others as much as you are able，
    Will suffice for keeping the bodhisattva precepts。
    将自己的所有善根全部回向于一切众生的广大利益，
    尽己所能去利益众生，对守护菩萨戒来说已经足够。

    Regard your root guru as being inseparable from the yidam。
    To refrain from entertaining any wrong views about him，
    Will suffice for keeping all the samayas of Secret Mantra。
    视根本上师与本尊无二。
    勿于上师起任何邪见，
    对守护一切密乘三昧耶来说已经足够。

    The masters will bestow blessings and the yidams will grant their siddhis,
    To the one who keeps the precepts and samayas in this way.
    It is certain that the dakinis and Dharma protectors will clear away the obstacles。
    对如是护持戒律和三昧耶者，
    上师将赐予加持、本尊将予以成就。
    空行和护法必将为其清除种种障碍。

    我手中此书是
    "The Union of Mahamudra and Dzogchen"

    在下认为，普贤行愿言，对业障的忏悔要念念相续，绝非虚言；行人若学如来藏见，对持视师为佛之密乘戒亦有极大帮助。


戒杀乃诸戒之首，应坚决奉行！

    gufeng:

    今有一友有一难题请教赵叔,有一对夫妻，妻子是学佛之人，不愿杀生。然不信佛的丈夫买菜时总要买些活的动物逼妻子宰杀，由此二人经常吵架。请问有何方法可以解决此矛盾呢？

    zf:

    解决问题的方法,这就要看“妻子”学佛的决心了。杀生乃佛门第一恶业，绝不能造！戒杀乃诸戒之首，应坚决奉行！
    “妻子”应当毫不含糊地给“丈夫”两种选择：

1、继续共同生活，但自己不再杀生；
    2、离婚。


杀戒不持，慈悲心如何能生起？

    初学老参：
    我有几位朋友学佛多年，经论上没少下功夫。就是有一点我很有想法，他们虽不犯国法，但是对佛的戒律不是很在意且有一番见解。如杀些个蚊子蟑螂小的众生，为人处事几乎与没有信仰人一样甚至还远远的不如！但问到这些时，却总是说我们还年青，在这样的社会里不可能做到如法。只能每天在做忏悔罢了。念一声佛可消八十亿劫的生死重罪，念四十万金刚萨垛心咒能消掉无始所有过失，我们只是些小过失而已。虽然他们知道无常迅速，但却还是信得过自己应该活得过这段青春。虽然信仰真实却是行持夹杂。所以我很想请教。谢谢！！

    zf：
    杀生乃五戒之首。杀戒不持，慈悲心如何能生起？
    慈悲乃大乘的根本，离了慈悲，大乘就成了空中楼阁。
    即使是常被人轻视的“小乘”，亦持不恼害众生之戒。可见不持杀戒者难算真正的佛弟子。
    是否肯为法牺牲某些眼前的利益，这就要看法在行人心中的重要性了。
    一、杀生可不是小过失！
    二、忏悔心的达成应包括两方面：1、对过失心生悔恨，2、永不再造恶的决心和行动。
    上述这种为了可以继续造恶而不受恶报进行的“忏悔”根本就不是真正的忏悔。以此心态受持佛号或真言难以与佛菩萨相应，因为这种企图在杀害其他众生的同时自己可以借助佛菩萨之力逃脱惩罚的心理极端自私。
    法藏大师言：“若令受苦而有利益则菩萨令受亦名为代”。这是说，如果菩萨认为某些众生应该遭受苦难才能从中受益的话，菩萨便会设法让他们遭受苦难，菩萨这样做也是代众生苦。我相信菩萨一定会施与那些认为杀生不是大过失者以苦难，令他们从中受益。


关于对恶业的界定

    笨鸟：
    还是有问题，看来还得劳赵叔的驾。
    那篇开示说了业障的起因与对治，
    但对于净业与恶业的界定却没说。
    对于贪嗔痴烦恼诸念的实际判读于笨鸟是不容易的。
    要是能够举些例子说明一下就好了。
    笨鸟这样理解不知对不对：

礼敬诸佛　──　修学的精神状态。
    赞叹如来　──　明确修学的目标。
    广修供养　──　明确应该做什么。
    忏悔业障　──　明确不该做什么。
    ………

    zf：
“但对于净业与恶业的界定却没说。”
    一、看看礼佛大忏悔文、法华忏、梁皇忏等“仪轨”，其中所忏悔的内容就是对恶业的界定。
    二、学习百法明门，里面有种种法的界定。


《大乘方广总持经》的教诲

    《大乘方广总持经》的教诲

    zf

    讨论学术时的世俗原则是否同样适用于随意对佛法发表见解，本人对此深表怀疑，因为事情的背后隐藏着深细的因果。
    《大乘方广总持经》中说：“若彼愚人于佛大乘。乃至诽谤一四句偈。当知是业定堕地狱。何以故。毁谤佛法及法师故。以是因缘常处恶道永不见佛。以曾诽谤佛法僧故。亦于初发菩提心者。能作障碍令退正道。当知是人以大罪业而自庄严。于无量劫身堕地狱受大苦报。以恶眼视发菩提心人故得无眼报。以恶口谤发菩提心人故得无舌报。阿逸多。我更不见有一恶法能过毁破发菩提心罪之重也。以此罪故堕于恶道。”
    我们希望见到讨论环境成为众生出离苦海的“莲舟”，绝不愿意见到论坛成为某些人“以大罪业而自庄严”之场所，不忍心见对佛教抱有偏见之人造大恶业。如普贤行愿品中云：愿令众生，欲行恶法，皆悉不成！


能损大利无过嗔

    能损大利无过嗔

    zf

    老兄将自己面对仇恨情绪的处理方法描述成：“继续感觉自己强烈的仇恨情绪，然后再次扩大它”
    在下提醒行人──当心，这里是陷阱！
    你可知道这种将仇恨强化的因果吗？这种强烈仇恨的影响，如果不立即以四力忏悔来对治的话，其异熟果报将在多生多世中持续地发挥极坏的作用！其因果作用岂是一阵发泄可对治的！
    这种违背佛法因果的“心理疗法”，还是不要在佛教论坛上推荐！与仇恨紧密相伴者必是嗔心，或者说仇恨就是嗔心。
    嗔心的大害老兄不知吗？！经论中常说“宁起百千贪心，不起一嗔恚，以违害大慈莫过此故。”“能损大利无过嗔，一念因缘悉焚灭俱胝广劫所修善。”请老兄说说，仇恨的情绪怎么可能不对行人造成巨大的伤害呢？


所断不同，所断次第不同构成无为法差别

    tyro：
    为什么《金刚经》上讲：“一切贤圣皆以无为法而有差别”？这句话用白话讲是不是：“一切圣贤都因为所证无为法的不同才有所差别”？还是：一切圣贤都因为众生的根基不同，才对无为法做了不同的解释，表现出差别？
    很是疑问：差别是有为事，有此有彼，才有差别，无为法中无因果，无彼此，如何有差别？

    二麻子：
    这是个过去回复过的问题……
    当年回复的老帖子麻子也背不过，大意如下。抽烟喝酒都是有为法，这个没有异议吧。
    那么戒烟，戒酒呢？是做了什么吗？不是，只不过是没做什么罢了。尽管如此，能说戒烟跟戒酒没差别吗？差别还是很明确的吧……
    圣人之不同于凡夫，断执而已。所以，所断不同，所断次第不同构成无为法差别。


看见美女，老是看个没完怎么办？

    门下：
    我在街上看见美女，老是看个没完（偷偷地），人都走过去了，我这边脑子里还在描摹形象。我知道这是贪着，我就想挖挖思想深处有什么根源，可是也想不出什么，有时我在贪看时观察自心，倒也没什么淫念，就是胡乱地想起一些前尘往事，是不是也没必要挖什么根子，只要猛厉遮止就好了？
    先谢了。

    zf：
    先挑重病治，你若觉得这是自己目前突出的问题，影响了生活和修行，必须立即加以强力对治的话，有效的修持方法就是如来开示的不净观。如果最重的病不是这个的话，建议先挑重病治。


出离心对于受持戒律的重要性

    出离心对于受持戒律的重要性

    京巴

   先贴一段一位老修行人对我的教诲：
“修行人应远离五家：所谓娼妓家，沽酒家，诽谤三宝家，国王家，邪见难回者家。因为，这是亏损戒律的。”
    “是佛教徒，应该按照戒律标准来衡量言行，而不是世间法的那一套。儒家尚且说，非礼勿视，非礼勿行。岂能佛教徒的言行倒够不上儒家圣人的标准么？”
    “要生起惭愧心。惭者，对已犯的过失生忏悔心，愧者，知是过失，而生羞耻心，坚决不为。”
    成军兄网站【戒律礼仪】部分，益西彭措堪布讲授的【走向解脱——三乘根本戒概述】里谈到，出离心对于受持戒律的重要性，其中有这么一段： 　　宗喀巴大师在《三主要道论》中确定出离心生起之量时说：
修已于轮回盛事，不生刹那之希望，
     昼夜唯求解脱心，起时是生出离心。
    也就是说，如果对轮回中的世间八法没有丝毫希求心，时时刻刻唯有追求解脱之念，这才是真正生起了出离心。
    现代众生的烦恼日益深重，贪欲在迅速增长，故法王如意宝的《胜利道歌》在提及出离心生起之量时说：于诸轮回盛世富，不起羡慕之心念。
    就是说对世间八法的贪求已经淡薄，而对解脱则产生了很强的希求心。因为宗喀巴大师针对的是当时弟子的根基意乐，故要求较高，而法王则针对的是现代众生的根基，故要求较低。
    反省自身，对这较低的要求，远未相应。于宗大师的高标准，距离更为遥远。京巴作为修行人，还奢谈什么持戒和实修。更不用说慈悲心了。连影儿都没摸着的事儿，还好意思鼓动大伙跟着受累费眼。回家先把做人的思路理顺再说！能善巧护持戒律，是最起码的。
    京巴记得，牛顿有句名言，如果说我看得远，那是因为我站在巨人的肩膀上。而今，京巴什么没见着，却已经被这么些巨人托着了，不向上走，还总往下出溜，实在说不过去了。
    再次忏悔！


谈谈对於同性恋和情欲的看法

    谈谈对於同性恋和情欲的看法

    成军

    首先必须明确，同性恋也好，异性恋也好，都是无明引起的贪爱，也都是我们生死轮回的根本。从这个角度看，同为凡夫，异性恋的"正常人"并没有更多的理由歧视同性恋者，五十步笑一百步而已。和其他情欲一样，同性恋的产生有生理和心理的原因，或兼而有之。作为一种畸形的情欲，同性恋者长期受到社会的歧视，自身也往往有沉重的心理包袱。他们比普通人的烦恼更深重，也更需要关怀。因此我们佛弟子首先应该同情他们，争取和他们平等交流，并且以佛法帮助他们。劝导他们学佛修行，从受持三皈五戒开始。
    依照佛陀的戒律，同性恋行为是违背五戒的。也就是说，如果同性恋者学佛，还保持原有的性爱方式，那么他/她就无法全部受持五戒。然而佛门广大，即使他/她一时还无法完全放弃同性恋的性取向，也还是可以学佛修行，例如先受持其他四戒。随着学佛的深入，烦恼习气的减轻，将来有条件再受持完整的五戒乃至八关斋戒等。当然，他/她们能够发心，一开始学佛就彻底中断同性恋行为，那是最理想不过。
    不管同性恋还是异性恋，情欲都是我们修行解脱的障碍。很多同修也都因为情欲的烦恼背负着思想包袱，使得学佛无法精进。八大人觉经云："觉知多欲为苦；生死疲劳，从贪欲起，少欲无为，身心自在"。后学个人的看法是，对於普通在家佛弟子，要求自己一步做到断情欲是很难的。只要能够在受持五戒的基础上，淡化情欲，不邪淫，同时常修忏悔，就可以使情欲不成为我们修道的障碍。同时，开阔自己的眼界和心胸，把精力多投入到修习佛法和利益他人的无尽事业中去。


正信生起的因缘

    正信生起的因缘

    zf

    “信为道元功德母”，那么信又是如何生起的呢？这是个很好的问题。
    在《大乘起信论中》，马鸣菩萨开示：

“分别修行正道相者。谓一切如来得道正因。一切菩萨发心修习。令现前故。略说发心有三种相。一信成就发心。二解行发心。三证发心。信成就发心者。依何位修何行。得信成就堪能发心。当知是人依不定聚。以法熏习善根力故。深信业果行十善道。厌生死苦求无上觉。值遇诸佛及诸菩萨。承事供养修行诸行。经十千劫信乃成就。从是已后。或以诸佛菩萨教力。或以大悲。或因正法将欲坏灭。以护法故而能发心。既发心已入正定聚毕竟不退。住佛种性胜因相应。或有众生。久远已来善根微少。烦恼深厚覆其心故。虽值诸佛及诸菩萨承事供养。唯种人天受生种子。或种二乘菩提种子。或有虽求大菩提道。然根不定或进或退。或有值佛及诸菩萨供养承事修行诸行。未得满足十千大劫。中间遇缘而发于心。遇何等缘。所谓或见佛形相。或供养众僧。或二乘所教。或见他发心。此等发心皆悉未定。若遇恶缘或时退堕二乘地故。”

    从菩萨的这一开示中我们得知，对佛法生起正信的因缘如下：

一、不定聚根性的众生；
    二、正法的熏习；
    三、值遇诸佛及诸菩萨等善知识；
    四、长时间的修行。

    这里有几个名词可能大家不太熟悉：正定聚，邪定聚和不定聚。
    正定聚者，指众生中必定证悟者。
    邪定聚者，指众生中不能证悟者。
    不定聚者，其性正邪未属，遇善缘则成正定聚，得恶缘则成邪定聚者，以其不定，故称不定聚。

    不定聚众生还被称为“毛道众生”，喻此类众生如空中之羽毛，随风而动，具有很强的可变性。菩萨以大悲心故，众生虽不请求，亦主动与其结缘，为其宣说正法，由是菩萨亦称“不请之友”。对不定聚众生来说，不请之友的弘法是至关重要的。


信与圣言量

    信与圣言量

    zf

    将圣言量独立，或是归入比量这种“纯学术”的问题，在下并不关心，但上文中最后一句话值得我们充分重视：“这是说对于超越根境之事，唯依可信解之圣言量，乃能了知。由信受彼言教，依之修行，即能得彼果，全无欺诳。”（编按：引文系一个关于圣言量的解释词条中的内容。）
    对于超越了我们感官（包括被科学仪器所延伸和加强了的感官）范围的知识，特别是那些冠以“一切”的全称判断，除依靠如来言教这唯一可信解的知识来源（圣言量）外，还能有什么呢？
    当然，接受了如来的圣言量只是开始，接下来的依之修行。当积累了足够的福智资粮时，我们也能获得如来的十力，从而现证如来境界。
    这里反复讲到“信”，但信的对象一定得是如来的圣言量，而不是外道邪说。
    下面是《华严经·贤首品》中贤首菩萨与“信”有关的开示，特恭录于后：

菩萨发意求菩提　　非是无因无有缘
    于佛法僧生净信　　以是而生广大心
    不求五欲及王位　　富饶自乐大名称
    但为永灭众生苦　　利益世间而发心
    常欲利乐诸众生　　庄严国土供养佛
    受持正法修诸智　　证菩提故而发心
    深心信解常清净　　恭敬尊重一切佛
    于法及僧亦如是　　至诚供养而发心
    深信于佛及佛法　　亦信佛子所行道
    及信无上大菩提　　菩萨以是初发心
    信为道元功德母　　长养一切诸善法
    断除疑网出爱流　　开示涅槃无上道
    信无垢浊心清净　　灭除憍慢恭敬本
    亦为法藏第一财　　为清净手受众行
    信能惠施心无吝　　信能欢喜入佛法
    信能增长智功德　　信能必到如来地
    信令诸根净明利　　信力坚固无能坏
    信能永灭烦恼本　　信能专向佛功德
    信于境界无所著　　远离诸难得无难
    信能超出众魔路　　示现无上解脱道
    信为功德不坏种　　信能生长菩提树
    信能增益最胜智　　信能示现一切佛
    是故依行说次第　　信乐最胜甚难得
    譬如一切世间中　　而有随意妙宝珠
    若常信奉于诸佛　　则能持戒修学处
    若常持戒修学处　　则能具足诸功德
    戒能开发菩提本　　学是勤修功德地
    于戒及学常顺行　　一切如来所称美
    若常信奉于诸佛　　则能兴集大供养
    若能兴集大供养　　彼人信佛不思议
    若常信奉于尊法　　则闻佛法无厌足
    若闻佛法无厌足　　彼人信法不思议
    若常信奉清净僧　　则得信心不退转
    若得信心不退转　　彼人信力无能动
    若得信力无能动　　则得诸根净明利
    若得诸根净明利　　则能远离恶知识
    若能远离恶知识　　则得亲近善知识
    若得亲近善知识　　则能修集广大善
    若能修集广大善　　彼人成就大因力
    若人成就大因力　　则得殊胜决定解
    若得殊胜决定解　　则为诸佛所护念
    若为诸佛所护念　　则能发起菩提心
    若能发起菩提心　　则能勤修佛功德
    若能勤修佛功德　　则得生在如来家
    ……


信和修

    zf：
    学习理论──通过地图了解目的地和达到的路径；
    实修──上路。
    真正的“信”就是“修”。如果行人能像因陀罗王（即下面的“印度王爷”）那样深信“汝是佛”之无上教授，“修”也就成为多余了。
    对不信者才需要修。
    诺那活佛的开示如下：
    问：佛有法身报身应化身，其差别之理何在？
    答：法身佛是一丝不挂，报身佛是下身有裙，上体肉袒，应化身佛是全身均有衣裙，观想虽有不同，而功德则无差别。合而言之，密宗根本道理，我就是佛，佛就是我。但此种道理一般人业障太重，不易相信，故有种种方便法门来启诱众生，令其慢慢成就究竟佛。

    例如阿达尔妈佛与五方佛均是自心明白而成佛，释迦佛传印度王爷立地成佛之法，亦是“汝是佛”一句话，王爷信得过，立时心地明白而成佛。当时释迦佛许多罗汉弟子，均非常惊异，甚至有闻此一句话惊骇而死者。往年莲花生大士之弟子中，闻此一语而自心明白，同时成佛者有一百余人，白教祖师之弟子中，因闻此一语而成佛者有二人，又有一尼姑之弟子，因闻此一语而成佛有一百余人。

    zw：
    赵叔，障重之众生如何突破此障，于此信入？

    zf：
    在善知识的帮助下，修习皈依、忏悔、发菩提心等显密诸行。
    而检验修行成效的重要标准就是看自己对“我就是佛”的信心是否加强了。

    刘华：
    一个人他总是在认为“我就是佛”，时间长了，他本还是一个凡夫，却总感觉我就是佛，并且自以为是。
    那这种做法是不是……我说不明白……

    zf：
    刘兄，关键的关键是，事实是：他本来是佛，却总感觉我就是凡夫！
    真认为“我就是佛”者，绝不会自以为是，而会自然行佛之事业──让凡夫都认识到自己本来是佛！

    asu：
    说本来是佛，这不是中观所批驳的因中有果论吗？
    最大的问题是，如果说众生本来是佛，如何又是众生？
    若说只因一念无明，那么，成佛以后，岂不还是会有一念无明？若说不会有，那我们的一念无明从哪里来？
    金刚经云，无有定法名阿耨多罗三藐三菩提。若说众生定是佛，这不成了定法？既然是定法，就违背了缘起正见。
    请您解惑，谢谢。

    zf：
    “最大的问题是，如果说众生本来是佛，如何又是众生？”
    ──在如来眼里，众生是佛；只因不知自己是佛，这就名众生。

    “若说只因一念无明，那么，成佛以后，岂不还是会有一念无明？若说不会有，那我们的一念无明从哪里来？”
    ──无明没有起始点，所以称为“无始无明”。
    众生不是由如来“退化”而来的，因此不必担心成佛后还会退失。

    众生法如梦如幻，佛法亦如梦如幻，众生法佛法不二不别。众生法是缘起法，不是定法；佛法亦是缘起法，同样不是定法。此与缘起正见全不相违。

    在华严的法界观中，法法无碍的同时，亦随业力而显隐自在。因此众生本来是佛（法法无碍）与因缘显现（中观之因果）无丝毫之矛盾。
    众生本来是佛，这是如来的法语；诸法缘起也是如来的言教。这“两种”见地都是正见，仁兄对哪个能信得及，依之修行就是了。

    asu：
    您说“如来眼里，众生是佛”，是否是说“众生定性当成佛”？还是说“众生无定性，所以有成佛之可能性”？

    zf：
    依华严古德的开示，不只是仅有成佛的可能性。若有一众生成佛，则一切众生已经成佛。
    当然这一见解并不为许多人接受，可以举出许多“证据”来反驳。
    （您就不必列举这些“证据”了，我知道许多。）

    asu：
    我还想加一句，在如来眼里，众生亦是众生！

    zf：
    同意您的理解。

    asu：
    众生之所以是众生，不是因为不知道自己是佛，而是因为没有佛的觉醒。

    zf：
    若基于华严的见，上述两种说法等价。

    asu：
    在下最后一问：正确对待义理矛盾的态度是什么？
    当面对义理上的冲突时：
态度之一：经过自己的观察抉择，选择自己认为最正确的。
    态度之二：不经过观察抉择，圆融地全盘接受。
    态度之三：对於自己有能力抉择的，选择自己认为最正确的；对於自己不能抉择的，圆融地全盘接受。
    可能还有第四种态度，就是存疑搁置。
    ZF兄，您显然接受了中观见，又接受了如来藏见。容在下无礼地逼问：您的态度是哪一种？
    惭愧请罪！

    zf：
    这是我的态度，不一定正确。

    我的过程是这样的：

  一、N年前首先接受的是如来藏见，当时对中观见没有深入。
    二、后来较仔细地学习中观见，发现自己的如来藏见沾常见，但不知如何善巧成立缘起与如来藏之无碍。
    这一阶段对中观见有信心，对如来藏见存疑。
    三、此时虽然不解如来藏，但亦坚信其了义，问题出在自己。
    此阶段若干年，甚苦！
    四、数年前接触杜顺大师的著作，解我疑惑。
    每当我读到宗大师对龙树、月称大师的赞叹，就想起杜顺大师对本人的恩德！

    （编按：以下数颂采自雪阳从英文版翻译的宗喀巴大师《缘起赞》。）

    我曾竭尽全力地修学，
    以反复寻求您教诲的真意。
    我也曾仔细地研习
    佛教各宗派的教义，
    却总是陷入疑惑，
    疑惑的困境是多么折磨人！

    我于是拜读了龙树菩萨的著作，
    犹如进入了佛法的夜百合园；
    他曾被您授记为善解无上乘佛法，
    缘起中道超越了有与无的陷阱。

    在那儿，由于上师的慈悲，
    我看见缘起的真意
    犹如吉祥的月光照亮一切，
    那圆满无染的智慧月轮
    自由地漫游在经典的天空；
    它驱散了一切边执的黑暗，
    使一切谬说的行星黯然失色；
    就这样我终于得到了无比的安宁！


佛教中的信根、信力

    妙音42：
    来了个基督徒保姆……看得出她很想请她的神治好我孩子的病，上来就问可否带孩子去她们的聚会？……为什么我这个佛教徒没有她这种劲儿了呢？如果有她这种劲求菩萨，孩子会怎样？这种信则灵的原理又是什么？能否说是迷信？要知道，这个基督徒只小学一年级文化，应该说是迷信吧。
    另外，说明一下，我没有真正求过菩萨治好孩子的病，只求过菩萨给我老师。消我业障，修道去障。因为承认了因果报应，接受现实。甚至认为这是我自己发愿（过激）感招而来的修行环境。这是否有误？因为有人说我自私，让别人（孩子母亲、保姆等）“跟着我受罪”。

    zf：

  “上来就问可否带孩子去她们的聚会？”
    ──我认为都可以答应。相信此人是出于善心，对此我们应当随喜。《普贤行愿品》中“……及彼十方一切世界。六趣四生一切种类。所有功德。乃至一尘。我皆随喜。”我们常常注意到随喜如来、菩萨的功德，却往往忽略了对众生功德（特别是“外道众生”）的随喜。
    这确是我们佛弟子应该反思的。难道我们佛弟子不需要对三宝──我们出离苦海的唯一依怙充满虔诚和信心吗？
    我相信“神”能办到的事，观世音菩萨一定能办到！在佛教中“信”是知于诸法之实相、三宝功德等的信乐。《唯识论》说：“云何为信？于实德能信忍乐欲心净为性，对治不信乐善为业。”这种信乃是入道的基础，五根或五力中亦分别以信根、信力为最初。
    佛教中肯定信心的作用，但并不将其绝对化。定业的成熟有时是不依我们的意志为转移的。例如佛陀在世时，释迦族的毁灭就连佛力亦不可转变。
    佛力不可思议，众生的业力同样不可思议。

    “能否说是迷信？要知道，这个基督徒只小学一年级文化，应该说是迷信吧。”
    ──是否迷信主要看信的内容。
    如果有人大字不识一个，但坚信诸行无常、诸法无我，此信亦是正信而非迷信。
    承认因果报应，同时祈请菩萨消业除障，这无疑是正确的。但在您心中，究竟如何才算除去了修行的障碍？对此还望仁兄仔细反思。
    如果仁兄能够以深深忏悔之心，面对今日给自己带来痛苦的孩子，思及往世因自己的贪嗔痴而给他造成的种种伤害，从而在承受苦报的同时真诚念佛、持咒，并发愿今后生生世世修习菩萨道，以此来弥补自己无始劫来给一切众生带来的无穷烦恼，依在下浅见，仁兄若能将心态调整到这样，不必遁世清修亦称得上善用此一人身。
    说句心里话，在下不相信您目前的逆境是此世发愿不当的结果。
    坚定的出离心是解脱的正因，善巧的修行同样重要。陪孩子玩时，念六字大明咒最好出声，让孩子也听到。真言一历孩子耳根，便会在其心中种下解脱种子，这就是听闻解脱。再加上你为孩子佩带的真言（佩带解脱），身根和耳根联合作用，效果会更加明显。
    只要你有信心，你和孩子尽此报身，定会往生极乐。


闻思修、信根的坚强基础

    智光：
    觉后空空无大千，请问还有因果否？
    末学一日入梦，人群中将老母走失了，深责不已，竟至梦醒。忽而觉醒：此梦境也，何过之有？何必深责不已？由此推知，吾人一生正如此梦，虽有功过因果，终究无实。进知六字大明咒正是教人出梦之法。
    近日升起疑问：如我佛释迦如来为大觉者，观法如化，正如大梦已醒之人。为何还要入梦中救度众生？既是梦境，又何必要入于其中？入得梦中又要受因果所缚？不懂不懂。请示请示。
.
    二麻子：
    您问的这个空空无大千的“觉后”有没有自我呢？
    如果还有自我，那么就有一定也有大千。如果没有，业果有受者吗？

    智光：
    “您问的这个空空无大千多“觉后”有没有自我呢？”
    ──有个觉性在，因一念动，则大千复又现前。
    “如果还有自我，那么就有一定也大千。如果没有，业果有受者吗？”
    ──如果没有，不是死寂了？

    二麻子：
    佛法说无我，你的理解就是死寂了？如果你真这样想，建议你系统学习佛法基本道理。

    智光：
    谢善知识，看来我不配问这类问题。

    二麻子：
    生死轮回前面，有什么闲气好争？
    智光兄若能信心不动摇，佛号念到底，本也能做到生死无碍，谁来跟你多话？你既然自己生疑，那就没别的办法，只有把这些宿世的疑根逐一打发。
    麻子的问题，不过让你回头去看看，你的问题从开始处就不自洽，由此再推论下去，越远就越没道理了。
    顺道告诉您一声，这里的人大概没一个天生会，都是后天学的。大家学得，偏你说学不得要退出，那也是没法子的事。毕竟街上看到的人里，学佛的是极少数。

    智光：
    多年无师，更无系统的学习。才找到这里。可自己水平太差听不懂，只不过生自己气罢了，还请善知识见谅。

    二麻子：
    人之常情，也没什么，以后尽量避免也就是了。
    既然已经生疑，对治的正路恰恰就是把佛法的基本道理比较完整地学一遍，即所谓闻思修。信根不是每个学佛人都很强大的，教下的正理正思维，三主要道的发出离心，菩提心，空性正见，其实恰是信根的坚强基础，应该努力学习。很多事情，真沉下心做起来，也未必就难得高不可攀。嘻嘻。


胜鬘夫人开示的启示

    胜鬘夫人开示的启示

    zf

    胜鬘夫人会云：

  尔时世尊叹胜鬘夫人言。善哉善哉。如汝所说。性清净心随烦恼染。难可了知。复次胜鬘。有二种法难可了知。何等为二。谓性清净心难可了知。彼心为烦恼染。亦难了知。如此二法。汝及成就大法菩萨。乃能听受。诸余声闻由信能解。胜鬘。若我弟子增上信者。随顺法智。于此法中而得究竟。顺法智者。观根识境。观察业报。观罗汉眠观心自在爱乐禅乐。观声闻独觉圣神变通。由成就此五善巧观。现在未来声闻弟子。因增上信随顺法智。善能解了性清净心。烦恼所染而得究竟。胜鬘。是究竟者为大乘因。汝今当知信如来者。于甚深法不生诽谤。
    尔时胜鬘夫人白佛言。世尊。复有余义能多利益。我当承佛威神之力。演说斯事。佛言善哉。今恣汝说。胜鬘夫人言。有三种善男子善女人。于甚深法离自毁伤。生多功德入大乘道。何等为三。若善男子善女人等。能自成就甚深法智。或有成就随顺法智。或有于此甚深法中不能解了。仰推如来。唯佛所知非我境界。除此三种善男子善女人已。
    诸余有情于甚深法。随己所取执着妄说。违背正法习诸外道。腐败种子。设在余方应往除灭。彼腐败者。一切天人应共摧伏。胜鬘夫人说是语已。与诸眷属顶礼佛足。
    时佛世尊赞言。善哉。胜鬘。于甚深法方便守护。降伏怨敌善能通达。汝已亲近百千俱胝诸佛如来。能说此义。

    胜鬘夫人开示的启示，其中第一段佛为说大菩萨的听受和大声闻的信入，胜鬘夫人余说三种善男子善女人入道之法，并遮一种妄说。

    一、对于如我等“于甚深法中不能解了”之凡夫初学，先修皈依、发心、忏悔、集资等加行，从而成就对如来教法的不共信心。若于深法不能解了，亦不生疑虑，唯仰推如来圣境，乃佛所知，非我境界。若能如是者，名为信心成就。
    二、以此信心成就为基础，再进一步使自心随顺如来圣法，以佛见为己见，由皮至肉，由肉至骨，由骨至髓。
    三、我等凡夫初学中之胆大包天者，若能如此行，纵使如来藏、华严、法华等大菩萨当机的教法，亦不妨一试。
    四、如是一跃，纵使不能一步登天，掉下来也不致跌得太惨。


若无信心，难说修持。若无修持，难有体会

    若无信心，难说修持。若无修持，难有体会

    zf

    密法各门修持的见宗与窍诀，若非实际用功修持者，恐难能体会其独到、殊胜之处。本人为宁玛弟子，故对大圆满见地方面稍微熟悉一点。我的一个深切体会是，不要说证入此见是何等困难，即使以思维心承认我等凡夫本具清净本觉智，对我来说都是那样困难。本人是多么羡慕那些上根者──直接对诸佛和上师的教言产生净信的行者。但对本人这样的根性，若不能在一定程度上借助经验和逻辑，而对某种见解──哪怕是佛和上师所说──生起不动的信心却几乎不可能。自己曾强迫自己去信，但对全然不理解者，这种信总是隔着一层。这应该是五毒中之“疑”的表现吧。对众生本具无自性之清净本觉，本人是借助华严宗杜顺大师的教诲方生起信心。可见对某一宗的见地真正生起信解绝非易事。若无信心，难说修持。若无修持，难有体会。


越是圆顿的法门越需要信根

    越是圆顿的法门越需要信根

    智行

    后学这些年来的体会是，越是圆顿的法门越需要信根，因为历超多位多劫，解、行、证三皆不能达。后学前不久听了一段梦参老和尚有关华严的讲话，听的十分有滋味，最引人入胜处就是讲信心。记得十年前听显明老和尚开示说，我们凡夫就是这一念转不过来，诚哉斯言。吾人修行净土，一般以念佛为其行，但此行的根底是如何见，但由于历超多位往往见不能及，所以必须以信为见。以圣言量为见，才能顿超，一切圆教顿超法大概都如此。不然，只凭借自己的解行所及来学，只能学渐法，当然渐法也是引导和利益众生的方便，但不是佛之本怀。
    依法华义，佛之本怀在给与“大白牛车”，其余皆是接引和结缘的方便，无此则对佛不能生信，无信不能授“大白牛车”，故最终唯凭“信”一字也。“信”者即“南无”义也，故说“一声南无佛，皆以成佛道”，法华之秘髓也。愚读地藏经时，这种感觉也非常强，地藏菩萨已位邻诸佛，开口都将一切归于佛的功德。
    能信圆顿法，大概是过去世很深的根基。“与佛无二”，或“今已在净土”等观，不但要信佛说，也的确要对自心不思议力用有很深的信心。
    知音难遇，不好开口。今认识您算是真正遇上知音，望将来多多开示。


佛法的力量！

    佛法的力量！

    zf

    您对“无限”的无奈和恐惧，
    就如同亲手绘画了一幅恶魔的肖像，
    然后被其吓得瑟瑟发抖，
    面色土灰。

    虽然如此，我对您仍然充满信心，
    因为我对佛法具有信心。
    您往日发愿、回向的修行终究会感得解脱之果，
    即使收获的季节我们无力确定。

    解脱之果的成熟是必然，
    您现在想逃都来不及！

    这，就是佛法的力量！

    （编按：本篇是奉心居士对一个对佛教中的“无限”概念产生困惑和畏惧的网友的回答，原贴即诗体。）


只要有如来的正法住世，佛法就不会末。

    只要有如来的正法住世，佛法就不会末。

    成军

    末法时代的说法，出于多部佛经，确为佛陀亲说，并非后人的杜撰。但在末法的时间解释上，不同的宗派传承略有差别。以事相而言，现代人因自身所感别业与众生共业，烦恼妄想日盛，确实修学佛法的根器不如佛陀出世的时代，这是我们众生的福报不够。但幸好尚存佛经、僧伽以及由诸佛菩萨师师相传的实修法门之教授。菩提道次第略论中有云：“佛为何时说佛无涅槃、时说佛世难遇，其中有甚深密义。前者恐众生畏其艰难丧失求法信心，后者恐众生以为佛法易得而不珍惜，此皆随听法众生根器而说也。”因此，依佛法之了义大乘，则无末法，故智者大师证法华三昧，亲见灵山一会，俨然未散。作为佛弟子，我们应该以末法为警戒，精进修行，护持正法，只要有如来的正法住世，佛法就不会末。


形象教育法——观想念佛

    形象教育法——观想念佛

    传明

    将观想念佛列为净土宗四种念佛方法之一的提法，乃出自圭峰宗密大师的《普贤行愿品疏钞》卷四，师把念佛分为称名念佛、观像念佛、观想念佛、实相念佛四种。念是系念，即心在所缘境上转，明记不忘，念佛就是以佛为所念境界，心在佛境上转，如依此得定，即名为念佛三昧。念佛分口念、心念。观想念佛属于心念，依佛的相好起念，念阿弥陀佛或其他的诸佛皆可。或先观佛像，把佛的相好庄严铭记在心，直至历历分明，然后静坐系念佛相。
    既然观想念佛是依阿弥陀佛的相好起念观想，那么行者则须先具体了解佛的三十二相、八十种随形好，否则无从观起。《观无量寿经》十六观里第八观中就提及了阿弥陀佛的像观。经曰：“次当想佛，所以者何？诸佛如来是法界身，入一切众生心想中。是故汝等，心想佛时。是心即是三十二相八十随形好。是心作佛，是心是佛，诸佛正遍知海，从心想生。是故应当一心系念，谛观彼佛多陀阿伽度阿罗诃三藐三佛陀。想彼佛者，先当想像，闭目开目，见一宝像，如阎浮檀金色，坐彼华上。像既坐已，心眼得开，了了分明。”
    这段引文是经中的心要，十六观都是“从心想生”的。经文告诉我们，行者只要观想诸佛如来的三十二相、八十种随形好，诸佛如来就会应念而显，此时行者的心就是佛心，与诸佛如来无别，甚至佛的正遍知也是由观想而引发的。究其理乃因诸佛如来的法身无相，但不离一切相，遍为一切法作相，遍一切众生心想中，只要“是心作佛，是心是佛”，那么你的心就是佛心。所以，佛陀劝凡夫众生应观想阿弥陀佛的报身。但阿弥陀佛的报身微妙难见，佛陀慈悲，知众生“心想羸劣”，“非是凡夫心力所及”，因此教众生“想彼佛者，先当想像”，“先观于一丈六像”的化身佛。

    下面根据《般若波罗密多教授现观庄严论名句颂解》卷四整理的三十二相、八十种随形好列下（因篇幅所限，八十种随形好从略）：
一、千辐轮相，如来恭敬迎送师长，感得手足掌心有千辐轮纹之相。
    二、足善住，足趺高好相，如来正受一切律仪净戒，感得两足平安如灵龟体之相。
    三、手足网缦相，如来行四摄事，感得手足指间薄膜相连之相。
    四、手足柔软相，如来广施美好衣服，感得手足温软细腻如细棉花絮兜罗棉相。
    五、七处充满相，如来广施饮食，感得手背，足背，两肩，后脑七处平满之相。
    六、手指纤长相，如来拯救将被杀害者，感得十指纤长之相。
    七、足跟圆长相，如来保护其他生命，感得足踵圆满无陷之相。
    八、身广洪直相，如来永断杀生之业，感得身形端正无佝偻之相。
    九、足踝端厚相，如来正受善法，感得踝骨不露之相。
    十、身毛上靡相，如来正受教诫，守护弘扬，感得身毛均向上旋之相。
    十一、繄尼耶腨，腨如鹿王相，如来于诸佛所说教言，恭行法施，感得股肉纤圆如鹿王者。
    十二、立手摩膝相，如来于其所有货财，凡有求者均不吝施舍，感得正身直立，双手过膝之相。
    十三、势峰藏密相，如来教导众生正受梵行守秘密语，感得男根密藏不露之相。
    十四、全身金色相，如来施舍美妙敷具，感得皮肤细薄紫磨金色之相。
    十五、皮肤细滑相，如来施舍良宅，感得身体皮肤细滑之相。
    十六、身毛右旋相，如来远离聩闹，感得汗毛一一右旋互不杂乱之相。
    十七、眉间白毫相，如来恭敬承事亲教轨范诸师暨父母长辈，感得眉间右旋白毫之相。
    十八、狮子上身相，如来全不强词逼凌他人，感得上身平正端严之相。
    十九、肩头圆型相，如来顺受爱语暨善言词，感得两肩圆满丰腴之相。
    二十、肩膊圆满相，如来广施药等，感得两腋丰腴圆满之相。
    二十一、得最上味相，如来侍奉病者，感得咽中常有津液，虽纳粗劣恶臭，仍得最上味之相。
    二十二、身分圆满相，如来劝造野苑禅林，感得身躯六合停匀，顶踵之高等于张臂之长之相。
    二十三、乌瑟腻沙相，无见顶相，顶成肉髻相，如来施精舍等殊胜净室，感得顶上有肉髻隆起如髻之相。
    二十四、广长舌相，如来出言温和，感得舌形广长，展则覆面，上至发际之相。
    二十五、得梵音声相，如来使三界众生解悟妙法，感得语音清净远闻之相。
    二十六、狮子颌轮相，如来永断杂秽语故，感得两颊丰满之相。
    二十七、齿鲜白相，如来殷勤侍奉诸众生故，感得牙齿白净之相。
    二十八、齿平整相，如来常以清净延命故，感得牙齿平整匀齐之相。
    二十九、齿齐密相，如来出言皆真实故，感得齿根齐密之相。
    三十、四十齿相，如来永断离间语故，感得齿数多达四十齿之相。
    三十一、目绀青相，如来看待众生皆如独子故，感得眼珠绀青色之相。
    三十二、牛王睫相。如来视不怒目故，感得睫毛如牛王睫之相。

    三十二相、八十种随形好通于诸佛如来。观想时，可于座上与礼拜中，兼以在座下日常生活中观修三十二相、八十种随形好。但无论在座上、礼拜、座下，都应该明记相好，了解相好是感何报而得，并发心愿常随佛学。
    在座上观想之方法，据《坐禅三昧经》中开示：
“及重罪人求索佛，如是人等，当教一心念佛三昧……将至佛像所。或教令自往谛观佛像相好，相相明了，一心取持还至静处，心眼观佛像，令意不转。系念在像，不令他念。他念摄之令常在像。”
    观想时先到有佛像的地方，细心观看佛像的相好。将一一相好观看清楚，谨记在心，然后回到静处独坐，在心里观想所忆持的佛像一一相好，令心不散乱他念，唯系念忆想佛像相好。如若方便，则可自请一尊庄严佛像，奉置静室，面对佛像观想而修。
    关于观想念佛，善导大师曾在《观经四贴疏》里开示：“此明标心想佛，但作佛解，从顶至足，心想不舍，一一观之，无暂休息。或想顶相，或想眉间白毫，及至足下，千轮之相。作此想者，佛像端严，相好具足，了然而现。乃由心缘一一相故，即一一相现。心若不缘，众相不可见。但自心想作，即应心而现。故言‘是心即是三十二相’也。”、“从上向下名顺观，从下千轮向上是逆观，如是逆顺住心，不久必得成也”。善导大师开示观想念佛，有顺观与逆观，顺观是从顶至足，逆观是从下千轮向上，无论顺逆观，心都应取一一相好而观之，这样观想，佛像则清净庄严，具足相好，了然明现于心，住心而观，不久将能成就念佛三昧。
    观想念佛还有一相观、全身观之别。谓观想佛之相好，即于三十二相中，随观一相，如《观无量寿经》中云：“观无量寿佛者，从一相入，但观眉间白毫，极令明了，见眉间白毫相者，八万四千相好，自然当现”。《观佛三昧海经》卷九、卷十也述及，佛为父王说白毫观，但观眉间的白毫相，婉转右旋犹如秋月，十棱成就，内外通明如白琉璃筒，亦如暗夜中的明星，不论观成或观不成，皆灭九十亿那由他恒河沙微尘数劫生死重罪，常蒙摄受。观想全身相，如《坐禅三昧经》所言，若行者求佛道，入禅先当系心念佛生身，莫念地水火风、山树草木、天地万类及诸余法，但念佛身处在虚空，如大海清时，有金山王相好圆满，出无量清净光明于虚空相青色中。常念佛身便得十方三世诸佛悉在目前，若心余处缘还摄令住，则可除无量劫罪。
    礼佛观想相好，《普贤行愿品》中普贤菩萨所发的十大愿王，其第一愿就是礼敬诸佛。依显教的头面承足礼，先观想阿弥陀佛与自己面对而立于莲花座上，具足相好，历历在目。观想时，一定要把阿弥陀佛观想成无质碍的光明体，放金色光，加被自己，千万不可观想成有质碍的实体。然后自己具足威仪，全身放松，虔诚恭敬，不急不缓，右掌向下，按于蒲团之中心，也是佛对站的双足中间；以左掌按于蒲团之前左边，佛之左脚背上；以右掌从中心移于蒲团之前右边，佛之右足趺上；以两手掌向外边翻转，手心向上，两手承佛足，佛立即站于两掌心上，头面刚好碰触在佛的两脚背上；以两手曲指反转内翻，仍按于佛的两脚背上，头离蒲团由伏而起；以右掌移于蒲团之中心，佛的两脚中间；以左掌离蒲团，置于胸前如合掌之状；以右掌用力撑起，合于左掌当胸，此为一拜，称为头面接足礼或头面承足礼。可以早晚观想阿弥陀佛，礼108拜，多少随行者自己适当安排。这种修法念念见佛，时时蒙佛放光加被，其本身就是与禅定密切结合不可分的修行。
    在座下日常生活中观修相好。诸佛如来具有三十二相，八十种好，上面所列举的三十二相，每一种相好都是佛陀往昔圆满每一种利益众生的功德而报得的，而这每一种利益众生的行为就是每一个佛教徒所要学要做的。《观无量寿经》中云：“以观佛身故亦见佛心，诸佛心者大慈悲是，以无缘慈摄诸众生”。佛弟子通过观想佛像，不但是为了礼拜、赞叹、供养，而且也是通过形象化的教育方法来让佛教徒铭记如来的大慈悲心和各种利益众生的行为。这不仅仅只是表达对佛体一一相好所代表的每一种圆满功德的敬仰。在敬仰的同时，净土行人，也应广修福德，积累助道因缘，在日常生活中，见贤思齐，以佛行为己行，学习诸佛如来过去因地修行相好、勤修六度四摄、利益众生的大行。这样行人当下就是阿弥陀佛的化身，同时也在圆满阿弥陀佛的报身，临终以此菩提道业，自然往生西方极乐世界。如《阿弥陀经》中所说∶“不可以少善根福德因缘得生彼国”；《观无量寿经》将过去未来现在三世诸佛净业正因归结为：“一者孝养父母，奉事师长，慈心不杀，修十善业；二者受持三归，具足众戒，不犯威仪；三者发菩提心，深信因果，读诵大乘”；大本《阿弥陀经》也说到布施、持戒等。这些善根福德，修净土的人，应该随分随力去做，使善根增长，福德增胜，以此功德回向净土。
    观想念佛的功德。在《观无量寿经》里说：“作是观者，除无量亿劫生死之罪，于现身中，得念佛三昧”。修观想念佛于现身可以得念佛三昧，灭除无量亿劫生死大罪；可以开天眼，粗见极乐世界，见佛闻法，往生极乐国土；随顺契入诸法实相的实相念佛，证得无生法忍。
    以上通过对观想念佛修学方法的论述，目的在于说明修学方式可以灵活多样，而突显观想念佛这一形象教育方法的殊胜。行人可以将座上发菩提心、观想念佛与座下持戒、积累福智资粮相结合，并将所修功德都回向往生净土，如是修行，决定往生净土无疑。

    （“佛教在线电子杂志”第一期）


初学者的实用学习方法

    诚明：
    赵叔问：“检讨是第一步。第二步是什么？”。想我等初学者，似这类懊悔是时常发起的，可是每次忏悔后，不出数天，会依然故我的老样子，长年仍停留在这个忏悔—复发—忏悔—复发的圈子里转，没什么突破。
    因此，赞叹赵叔善为引导我等初学。后学试答：
一、忏悔后关键是行
    二、无始烦恼习气业障深厚，在忏悔后虽欲重新做人，但往往忘失。反省到这里，忆起南师怀瑾常教诲的‘修行就是时时刻刻反省自己’，此言有深意。因此，在二六时中的种种苦乐对境，要随时检查自己的发心、动机，关键要做到是不忘失，恒念恒忆！得一善，拳拳服膺！
    三、对治，发现旧习，即刻忏悔，并要努力修习对治，以善业串习对治恶业的串习，日久可有力量。
    四、应有定力摄持，方得力用，注重修止。
    哎！有大德曰：在家学佛，如陆地行船，难！真赞叹羡慕出家人！末学惭愧，说食不饱，请赵叔指导。

    zf：
    说的好！总之要去做，调动身口意，开始时哪怕装模作样也好。无始劫来的习气，如果“顺其自然”，必然照旧流落生死。所以只有逆水行舟一条路。

    sati：
    修行“只有逆水行舟一条路”，在下同意但不完全同意。佛陀曾经开示说，修行就是在戒清净和正见的基础上勤修四念处。

    linden：
    “勤修四念处”与“调动身口意”是异曲同工的！你认为赵叔以上的贴子与你说的“勤修四念处”是同是别？无论大小乘或密乘，佛陀的教导在原则上都是一致的。“调动身口意”就是“勤修四念处”呀！在八风中修行正如逆水行舟，这才需要“勤修”，不勤则不进则退，怎么在你看来又不同了呢？

    诚明：
    请问赵叔，是否可以这样修为入手方便，末学发现，即使随时反省忏悔，但对境时的内心深处，依然是五欲、八风等染念。真是无可救药，忽然想起赵叔强调的‘装’的法门，恍然明白，赵叔回贴，正中要害，‘装模作样学菩萨’的修法实乃对治习气和修心的甚深窍诀。
    如何装呢？我想起密宗似乎有这样一个办法：把自己随时观想为本尊，外境皆观为本尊的清净显现。
    假如我是念佛的，逆顺对境时我就把自己观想为阿弥陀佛，使自己心与佛心相应，与四十八愿相应。甚至可以把众生观想为佛，把世间观想为净土。
    请教赵叔，以后末学是否可以这样训练自己，这个法门若不对路，应该如何具体来做呢？

    zf：
    诚明兄好悟性！
    “末学发现，即使随时反省忏悔，但对境时的内心深处，依然是五欲、八风等染念。”
    ──这是我等初学真实状况的写照。未认识到这一点者恐怕是在自欺欺人。
    “真是无可救药，”
    ──药是有的，就是有人不愿吃。
    肯吃药者必能得救。

    “‘装模作样学菩萨’的修法实乃对治习气和修心的甚深窍诀。”
    ──“装模作样”，“照猫画虎”这几乎是所有领域里初学者最实用的学习方法。

    “如何装呢？我想起密宗似乎有这样一个办法：把自己随时观想为本尊，外境皆观为本尊的清净显现。”
    ──这里的“观想”也是“假装”的方法之一。

    “假如我是念佛的，逆顺对境时我就把自己观想为阿弥陀佛，使自己心与佛心相应，与四十八愿相应。甚至可以把众生观想为佛，把世间观想为净土。”
    ──诚明兄真是好悟性！这是“装佛”的最好方法之一！

    这里有三点提醒师兄：

一、要想真正装得象，最好是从根本装起。
    阿弥陀佛的根本是什么？在下认为就是四十八愿。
    四十八愿生起时，法藏比丘就是因地的阿弥陀佛；四十八愿圆满时，法藏比丘就是果地的阿弥陀佛。如果有人现在就将阿弥陀佛的四十八愿确定为自己生生世世不可动摇的金刚誓愿（密乘称为金刚三昧耶），此人岂不立时成为因地的阿弥陀佛！
    因此在下建议诚明兄，首先将四十八愿一字不漏背诵下来，烂熟于心，未有一字不解其意。然后花相当时间（数年乃至数十年）以一切手段（包括坐上和坐下）将此誓愿“固化”在自己的心中，象金刚一样（金刚有两意：一是不能被破坏，二是能破坏一切），并将所修的一切功德皆悉回向此大愿令其圆满。
    是心作佛，是心是佛。从里到外都装象了，也就真正是了。

    二、关于佛号
    “南无阿弥陀佛”这六个字全部都是梵文的音译，包括“佛”字。
    “南无”读作“拿摩”，这两字通常不会错。
    “阿弥陀”应读作“阿弥达”。实际上，佛经中的“陀”字都应读作“达”。
    “佛”字应读作“布达”（此字英文的发音很准）。在“布达”后面加上一个“呀”字，表示此佛为礼敬的对象。
    如果我们设想当年释迦牟尼佛亲口所说的念佛方式应该是：拿摩阿弥达布达呀。
    本人的祖师莲花金刚藏上师对此开示曰：“‘拿摩阿弥达布达呀’是‘南无阿弥陀佛’的梵音，此是释迦牟尼佛金口所宣说之正确佛号，‘南无阿弥陀佛’则是中国人翻译的，故我们念佛当从佛所教授者。”
    若以“拿摩阿弥达布达呀”的方式念诵佛号，则此佛号便与密法中的真言完全没有差别。实际上，密乘中许多佛菩萨的心咒就是其梵文名号，种子字就是其名号中的第一个字母。例如，文殊菩萨有多个种子字，其中一个就是其梵文名字Manjusri的第一个字母Mam；药师佛的梵名为Bhaisajya guru vaidurya prabha rajaya，其种子字也是名字的第一个字母Bhai。
    若诚明兄能以四十八愿为己之金刚誓愿，以“拿摩阿弥达布达呀”的方式持诵佛号（亦可称为“八字真言”），再加上“把自己观想为阿弥陀佛，把众生观想为佛，把世间观想为净土”之类的观想，如是修行的净土法门便真正是“显说的密乘”！

    三、锦上添花
    如诚明兄有兴趣，可仔细研读《大方广如来藏经》（在大正藏“经集部”，可到“佛典宝库”网站下载）。该经以九个比喻宣说一切众生皆有如来智慧德相，如果能于该经信入，对本具如来德相深信不疑，在如来藏见的摄持下修持上述之“显说的密乘”，则此密乘就不再是一般的密乘了，而应属于密乘之顶——大圆满。
    请体会一下，（一）在知道自己本来是佛的情况下“装佛”，（二）在不知道自己本来是佛的情况下“装佛”，两者相比较，哪个更容易装得像？！

    sati：
    赵叔强调信心和愿力的作用俺还是非常赞同的。赵叔这里说的“装”似乎也是他的一贯见解的体现，但俺多少觉得有点别扭，可能是有点过吧。

    zf：
    在下在论坛上与诸兄交流学佛心得，言语之中定有许多不如法之处，不当之处还望兄不吝指出，以便在下改正，正所谓依法不依人。
    关于“装”字，记得一次曾与几位师兄交流，一位师兄刚开始修学，感到困难，在下便建议他采用“装”的方法。这时其中一人说，他曾在某位任波切处听开示，也是用“装”作为修学的入门方法。可见此“装”字诀不是在下的独创。记得当时zs师兄在场，可否为在下作个证明？

    sati：
    我的理解，这实际上涉及到大乘小乘的区别了，二者确实有区别，小乘冷静客观，大乘热情超越。二者最好能结合起来。

    zf：
    sati兄，这样的道路仁兄是否愿意去尝试——在冷静的般若智慧摄持下之火热的大悲行愿。


从缘起性空说开去

    从缘起性空说开去

    成军

    缘起性空，作为佛法义理的核心，其关键还在缘起法则上面，一切法，不出缘起。强调性空是为了佛陀对治我们执实的习气而专门说的。可是“空”是和“有”相对待的概念，如果单单说“空”，容易引起歧义，让人觉得是没有、虚无，也就是通常所说的恶取空。很多初学佛法的同修往往会在这里对佛法产生误会，以为佛法的空义是否定现实存在。因此，为了表述圆满，佛法往往同时说真空妙有，或如心经所说的，“色不异空，空不异色，色即是空，空即是色”。
    如果对於缘起明白清楚了，说性空也罢，说妙有也罢，都是自然而然的。缘起，或者说因缘的相续和作用，可以看成是一张无限大的动态高维网，有点象我们现在的internet，但是更复杂无数倍。在这么复杂的大网下面，因缘流转，相续不断，发生各种作用，显现各种现象（注意，因缘的流转相续是本来如是，并无推动力，如果有推动力，即成第一因，也就归到神创论）。
    我们众生因为无明，执取这无量因缘法中的少分为“我”，便生出我执、我见，同时也对一部分的因缘法产生常见，为此佛陀说“空”以对治之。而如果实证无我，不再执取少分因缘法为我，那时候就不需要再去抓住“空”不放。特别值得注意的是，虽然无“我”，但是因缘法的相续并没有断绝，也就是说，虽然无我，因缘法的作用即业果不失（为了表述我们所无法观察的和“我”所相关的因缘法之含藏，唯识宗在此安立阿赖耶识的假名）。具体的例子就是即使成道的圣者还会受报，如目键连尊者被裸行外道打死，虽然尊者早已经证“无我”，但是他此报的色身还是会被毁坏，此乃因缘法作用如此（即业果不失）。这也正是禅宗著名的“野狐禅”公案里面，不落因果和不昧因果的区别所在。另外一方面，证空性的圣者因为不执取少分因缘为我，反而可以借缘起而生起种种神通妙用。
    顺便也讨论我们学佛人很关心的消业问题。所谓消业，有几种可能的情况。由“我”来坦然受报当然是最直接的，也是最被动的。此外就是以善因缘（例如忏悔、念佛、持咒、诵经、放生等等）来抵消恶业，好像多个作用力的平衡。但是最有效的消业方法，却是实证空性。因为证了空性，业报的因缘虽然还在，受报的“我”却没有了，而因为“无我”，原先所谓的罪业，因为失去作用的对象也就不具有意义了，这才是最彻底的。正如忏罪偈所说的：“罪从心起将心忏，心若灭时罪亦亡，心亡罪灭两俱空，是则名为真忏悔”。
    如何将缘起性空用于日常的行住坐卧呢？我想，古德有句话，可以作为我们的座右铭：“高高山顶立，深深海底行”。也就是说，我们于义理上须明白缘起性空的道理，即在见地上要立于“高高山顶”上，不落空、有的边见，亦能够经常以此缘起无我的正思维熏习自心，消除我执我慢。另外一方面，在实际的行持上，我们应该真俗二缔圆融，不落狂慧狂禅，或者以得少为足。正因为缘起法的因果不虚，我们才应该以踏实的行持去消除业障、累积福德资粮，不忽视任何微细的善法，并尽量避免造任何的恶业。如此老老实实、踏踏实实地做人、持戒、念佛、修定，以点滴的积累转化自己的心念，对治自己的习气烦恼，逐渐使自己和佛菩萨相应。正是因为缘起法的真实不虚，才要一分耕耘一分收获，此即所谓“深深海底行”。
    因此，修净土者如何运用“缘起性空”来增加往生极乐之把握？后学的答案还是祖师们重复了无数遍的那句话：“老实持戒念佛！”。与论坛各位善知识共勉之。


初机学佛讨论

    xiaozeng：
    我粗浅的学佛方法，敬请您给予指正指教，我知道与困厄命运抗争是一个非常艰苦而长期的过程，病因业而起，只有治疗并念佛消业障才是正途。

    zf：
    一点参考建议。深信因果为修行的第一基础。古德曾言：不信因果，是名为痴。

    xiaozeng：
    多么幸运，我有机会听闻佛法，我现在粗浅的自修方法是这样的：一是生活中行善，为求存好心说好话做好事作好人，以一颗悲悯心感恩心看世界看他人，为自己每天每天所造的业忏悔。

    zf：
    听闻佛法的确是幸运中之最幸运事。是故有缘闻佛法者，无论现实在金钱方面遇到什么困难，都不应作“穷人”想。闻佛法者为世间最大的富豪，具法财故，而此法财能救我等最大的贫穷——轮回。
    行善同时还应看到众生之苦，富人、穷人、高官、百姓各有其苦，六道众生无一例外。轮回的本质就是苦，当思出离。
    每天忏悔还应忏悔无始来所造恶业，可参考《普贤行愿品》中关于“忏悔业障”部分。

    xiaozeng：
    我每天恭敬焚香三支合掌跪念念颂《白衣大士神咒》三遍，但我不知道是否需要在念咒后加念回向文，应该注意些什么；

    zf：
    回向非常重要。如果把诵咒比为“打工赚钱”的话，回向则是如何“花钱”。修行所得功德从根本上说是要用在解脱轮回之苦上面。如能由自己之苦想到众生之苦，而发为利众生愿成佛之心，则十方一切诸佛菩萨将同声赞叹！

    xiaozeng：
    经常念诵“南无观世音菩萨”与“南无阿弥陀佛”，休息时坐公车时只要脑子得空，就尽量将一句“南无阿弥陀佛”或“南无观世音菩萨”提起，有时出声有时不出声；四是用电脑时听孟庭苇佛教专集与郭富城的普善心经，睡觉时听圆通寺买的大悲咒与观音心曲，并从圆通寺请楞严神咒来佩戴。

    zf：
    好！忆佛念佛者，将来必定作佛。

    xiaozeng：
    平时在饮食时，我将肉食降到最低，可能一周只吃1－2两肉，尽量素食，但因为我有结核，母亲很担心焦虑我身体垮掉，所以我还必须吃一些蛋奶，让母放心。

    zf：
    从生活中培养自己的慈悲心，赞叹！

    xiaozeng：
    每年去1－2次圆通寺，尤其是大年三十或初一时必去忏悔，平时有时间就看一些高僧大德的文章。

    zf：
    坚持下去，定有收获。有问题也可来论坛上大家讨论，论坛是一个发挥集体力量的好地方。
    祝吉祥如意！


怎么说也得从现在做起

    妙音42：
    如果周围环境让人不安心，使离正念、分别心、计较心起，而且这些条件还都暂时无法脱离。由基本责任起（父子）一环一环全套住。“只能如此，别无选择”，这就是业力之狱吧。当如何？我心里明白，可以毅然脱梦而去，出家用功吗？“其力未充”，正是我目前状况。如身陷泥潭，上不去也使不上力。所以才着急。
    95年，孩子病情突然恶化，大闹不止，咬人，揪头发，不在家里面，非要在外面走，朝着某一方向上不停地走，似有某种外界灵力作用。周期性发作，约一月左右一周期，亢奋压抑循环。全家是人仰马翻。入深秋，症状才稍好一点，因为一位大夫自制了一种药。但从此留下了周期性发作的根。到现在也还是周期性亢奋压抑。亢奋时会一夜不睡，此时双足冰冷，双手汗出。肚中怪响不止。
    总是怀疑自己一声佛号一句咒语的力量达不到，总以为只有大德们、成就者们的持念才真正有效果，可达到经中所言的无边功德。而自己的半心持念哪有功德之力？事实上，生活之逆境是转不过来，孩子闹得人死的心都有、发疯的条件都具足。我的选择是往生极乐，此生无论如何要成办的大事。问题是目前这样念法，功夫不够，不能得力。出家又有家庭孩子束缚。该怎样办呢？

    二麻子：
    佛法确实不是无论什么地方都可以修学的……
    妙音兄这一问，甚是让人难说话。一般说来，大家都为了突出主观能动性的重要而说“只要你真想学，什么环境下都可以也应该修学佛法”。这话虽然不错却也并不全面。其实，要学佛需要很多条件。往极端里说，在地狱的众生是几乎不可能学佛的。即使在人世间，佛明说过暇满人身难得，而若无暇满人身，要学佛求解脱就十分十分地艰难。你现在的情况，近乎于没有暇满。怎么办？实话说，麻子看不出什么特效的办法。所以说菩萨畏因，凡夫畏果，当因缘法已经以果的形式出现的时候，没有什么简易办法可改变，甚至不一定有什么速效方法。
    怎么办，没办法也得有点对应办法吧？是。确实是。其一是忍。麻子对你的忍耐能力已经很佩服了，但显然对自己的具体情况你的忍耐能力也未必够用。所以，你仍需要继续忍。其二是设法改变目前状况，甚至不惜付出某些代价来换去一个自己可以修行的环境。
    这事有点像出家。出家本身对自己的父母家庭等等方面是很有亏欠的。但出家换来了一个自己修行较好环境。只要自己修上来了，这亏欠将来是可以弥补有余的。但如果没好好修，那后果就严重了。
    如果根本不能改变环境，那么说实话，麻子真想不出有什么很好的办法。
    所谓环境是已经显现的果。要改变它，也只有用因果的方法。请不要告诉我你一定要靠念佛号来改变环境。这事或许有些大德能做到，但绝对不是一般人能做到的。如果你能做到，大概也不会有现在这些问题了。为什么做不到？原因就是因缘法的规律。佛号是往生的正因缘，不是上大学的正因缘。如果有人要靠念佛号考大学，你觉得合理吗？
    麻子感到很抱歉，也很感到力不从心，对你的具体情况无法给出你希望的迅速见效的方法。麻子的基本看法是，如果不从改变这个现状开始下手，你不能解决问题。

    无名：
    这忍要忍到什么时候？没有更好的办法？

    二麻子：
    哦，无名兄，即使有更好的方法，忍耐力也是必须的。欲从根本上解决问题，需要勇于面对问题，需要承担自己的责任。这也是诸佛的加持力速显所需的个人素质吧。
    妙音兄的确很辛苦的，换了俺基本是挺不住的了。
    吾等还是依古慈兄的建议，为妙音兄及其病儿多多念佛回向吧。
    很多事情是没有速效解决方法的。
    在方法显效前的时候，只能忍。这个阶段有可能很长。然而，凡夫畏果，大都不能从因上慢慢解决，急求速效解决办法。虽然可以理解，但实在未必能满足。
    老兄多少有点误读了麻子的意思。

    无名：
    其实我想现在妙音兄的情况，出离心应该俱足了，如果能象地藏经上的婆罗门女和光目女一样，于佛前大兴供养。而后能发大愿，岂不是能得到佛菩萨的加持。但好象也不是速效方法，经上频频出现的“尽此一报身”就是说的这样一件事，呵呵。

    二麻子：
    您客气了……
    速效的办法不是真的没有，实在是因为我们凡夫心力不足，用不动。看华严经就知道。
    真若有大心力放得下的，所谓放下屠刀立地成佛。

    妙音42：
    末学正是沉不下来，有障碍。自觉是受破戒之报（ZF也这样说过）感觉诸事万难。上不去下不来，师傅不理，人不爱。孩子闹，老婆逃。定不生，慧不开。怕轮回，胡乱拜。
    像我这种人，今生还有救吗？今生。因我深知，此生不成，必入恶道。

    二麻子：
    嘻嘻……有那么吓人吗？
    嘿嘿，麻子跟你讲句难听话，地狱那些地方，我们都去过不知道多少次了，天道也如此。如今不还是在这里吗？所以，轮回的事，怕也没用。如果怕能成为你寻求解脱利益他人的动力，那就怕。如果不能，那么不如不怕。今生有救吗？这个麻子绝对不敢给人打包票。不过，如果不从今生，不从现在开始自救，下一生，下下……无数生，不还是不能自救吗？所以，怎么说也得从现在做起……结果如何？ZF兄说得好，只问耕耘不计收获好了。因果是不会错乱的，收获不用自己去计算。嘻嘻。


不肯定自力修行会助长行人的偷心

    得信欢喜心：
    《法华经》喻：
长者之子──自力心──自以为是心。无法摆脱“我”见心──学术心，研究心，不能自觉（绝对人人，无一免）心，不自量力心，蠢蠢欲动心，无耻心。
    离家浪子──自力迷心──不真信佛力心，迷信外道小乘心，好奇心，功利心，不肯乘佛悲愿，自力更生，不慌不忙，“脚踏实地，循序渐进”痴人说梦心。──最没良心，真真真切切切我等无一人逍遥。
    长者──本师释迦是！──南无阿弥陀佛慈悲愿海是──本愿早已成就是！──光明名号。遍照十方。十方众生。摄取不捨。若不生者。不取正觉。南无阿弥陀佛！

    成军：
    强调和阿弥陀佛的愿力相应，念佛求往生，这很好。但是由此否定一切其他自力法门，未免不合如来正法。须知，本师释迦牟尼佛就是累世行菩萨道自力成就的，难道也要归到你的“痴人说梦心。──最没良心”？
    自古以来，各宗依自力成就的祖师大德很多。片面强调他力贬低自力法门的行人，实在是有谤佛谤法谤僧的危险！
    您引用法华经，而法华经的唯一佛乘就是发菩提心、行菩萨道，自利利他而成佛，并非就是一个往生。往生净土当然好，但是到了那里，还是得凭自力，在阿弥陀佛和诸善知识的教导帮助下，发菩提心，修学三十七道品、四摄六度而渐次增上，直至成佛。
    难道学佛可以不必遵循佛法无常无我的规律？如果您学佛求的是这个，那么与基督教何异？更何况，只讲他力不肯定自力的作用，有可能会助长行人的偷心，不积极实践佛陀戒定慧三学与自利利人的教导。最后，“不可以少福德因缘得生彼国”，连往生也未必能做到。
    总之，您一心归命阿弥陀佛，以强信心与阿弥陀佛相应，是很好的事情。但是请不要曲解法华经，片面强调他力而否定自力的作用，诽谤他宗的教法和行人。切记，佛陀教法的精髓，在于菩提心和无我正见，永恒的不是生命，而是佛菩萨的悲心与愿行。
    以信力和阿弥陀佛愿力相应，不等于基督教上帝无所不能的拯救。因为佛陀也不能坏因果律。而上帝则是不在因果之内的，这应该就是佛法的他力和基督教的差别。真宗的说法，可以说更接近后者。
    “一念净信能生极乐”，说起来简单，但是没有依戒定慧三学对心念的熏习，又谈何容易！中国古代净土祖师，哪个不是严持戒律，精进念佛修行而成就的？难道人人都有那么大的善根，平时不持戒修行，临终就能一念往生吗？
    净土是大乘法门，往生的根本目的，是到彼土修学，直到最终成佛，利益众生。如果学佛把这个都忘了，至少已经不能算大乘了。如果没有菩提心，念佛求往生，求生命“永恒”，与基督教何异？
    现在还不是只存《无量寿经》的法灭尽时，《楞严》还在，释迦牟尼佛以来清净的法源传承也没有断绝。再说，念佛往生不等于真宗那样否定自力的作用。无量寿经里面，不也一样包涵五戒、十善、菩提心吗？后学反对片面强调他力，排斥自力他宗、教人不持戒不行六度的净土真宗，对于净土法门，赞叹还来不及呢。在历史上，联系近代日本佛教的变质，难道不值得我们深思吗？


能觉察到“敌人”的存在是件好事

    智诚：
    紧急求助！！！念佛时，脑海中总是有各种各样的杂念，有些甚至有亵渎之嫌。越是害怕，越是想要克制，却越是鬼使神差般地冒出来。请问如何克服？

    zf：
    别怕！别害怕，这是正常的。
    其实这样的杂念不是念佛时才有，我们实际上就生活在这些污秽的杂念中而不自知，这才是真正的可悲和危险。
    能觉察到“敌人”的存在是件好事，总比稀里糊涂地与敌人打得火热好得多。这时应在警觉的同时心中暗喜──毕竟发现了敌人；在暗喜的同时警觉──积累力量杀敌！


如来住一切处

    心如大海：
    请教，如来圣像的灵异是法身还是报身在显圣？

    zf：
    对我们凡夫来说，能够感受到的如来功德属于化身的范畴。

    心如大海：
    末学还有些疑惑，我相信佛菩萨是有的，还有佛菩萨显灵也是有的，但是否就住在佛像里面？既然住在佛像里面，为什么还会被人打碎？如果不住在佛像里面，那和佛像有什么关系？

    zf：
    如来住一切处。当然也包括佛像里。岂不闻：“一尘中有尘数刹，一一刹有难思佛。”
    佛像打碎有什么希奇？众生业障重到一定程度时，我们这个世界的整个佛法都会隐没。


妈妈会烦吗？

    芙蓉仙子：
    那大家都念阿弥陀佛，阿弥陀佛真的不烦吗？

    zf：
    设想：在您三岁时，不小心落入湍急的河流。此时你对岸上的母亲不断大声呼喊：“妈妈救我！”
    您妈妈会烦吗？

    至诚忏悔：
    妈妈救我！妈妈救我！三界如火宅，只有依佛菩萨的慈悲愿力来了脱生死。以后俺念佛时就想起zf老师的这句话：“妈妈救我！”

    zf：
    至诚兄，这三点也别忘了。念佛时，作“妈妈救我！”想，与下述法义并不矛盾：
一、“阿弥陀佛”──我们本具之大慈大悲大智及利生的无边行愿和神力，即如来智慧德相；
    二、“南无”──希冀如来藏速疾开显的深心切愿；
    三、“南无阿弥陀佛”──无上菩提心是也！！！


自认佛子这一功德我们应该随喜

    明心斋主人：
    某兄这种假冒佛子应该揭穿。他要是老实承认不是佛子，在不诽谤三宝的前提下，我们倒是可以和他聊聊。

    zf：
    “他要是老实承认不是佛子，在不诽谤三宝的前提下，我们倒是可以和他聊聊。”
    ──明心兄啊，自认为“佛子”，这是何等的功德呀！无论他的观点我们如何不同意，但自认佛子这一功德我们应该随喜啊！

    在下也给那位老兄提个建议，对于一些自己一时无法理解的东西，最好不要急于下个结论。南传和禅宗都是佛法正脉，您与这些法门有缘就脚踏实地地去修行。特别是禅宗，乃为大乘者“说”，为最上乘者“说”，祈愿仁兄能早得如来正法眼藏，利益我等有情！


为老人买张通往极乐世界的车票

    pm21：
    我女儿，被我去世的父亲压住了，是不是我父亲寻求帮助，应怎样帮助我父亲。

    zf：
    念六字大明咒，回向你父亲往生极乐世界。

    pm21：
    如何回向，我不懂啊。

    zf：
    这就是回向。

    念六字大明咒有无量无边的功德──好比您发了大财；
    您父亲现在缠着子孙，需要救度──如同老人缺钱，向您伸出求援之手；

    您将功德回向老父往生极乐世界──就是将自己赚来的钱为老人买了张通往极乐世界的车票，并将老人送上车。

    om mani padme hum


学佛就是学会引导自己的心

    云飞月：
    躺在繁星点点的夜空下、草坪上，内心一定充满了宁静、亲切、幸福的感觉，没有什么妄念，就是宁静和完全的信任、依止，就在那一瞬间上师真正传完了全部的佛法。

    zs：
    你要是觉得这个是大圆满见就错了……严重的粘所了:)

    云飞月：
    师兄说的是！这个不是，这只是后学根据书上的文字猜想当时索甲仁波切的一种心态，或者说他的上师为他指示前的一种状态。关于大圆满见，我没有什么闻思，只知道一切显现本来清净这样一种说法。关于这个思路，我没法体会得太多，只是加深了对《入行论》相关地方的理解。师兄有什么体会，可否说来分享？

    zs：
    学佛就是学会引导自己的心。心在那里，甭管你理不理他，他都会有各种作用。轮回的众生，对心的认识和控制，就像一个拧螺丝的小孩，一会儿松一扣一会儿紧一扣，对螺丝的功用和全面的属性，完全没有认识；学佛的众生，或许还没有全面掌握螺丝的全面属性和功用，但是有佛和大德们的指导书，只要按着做，肯定是环环松扣——所以，可以先不管真假问题，也不用管什么实不实相的问题……佛和祖师大德讲过遇到什么事情要有什么样的发心吧？！嘿嘿，照猫画虎这么做——这也就是赵叔说的装——反正每一步都是松扣，咬住牙做，就必然是解脱。

    云飞月：
    赞同师兄的说法，那就是回归到对上师三宝的信心与增上信心！从学佛历程来看，这种回归本身就是一种增上。可能我们都要经历这种过程，记得几年前，zs师兄在网上也谈到方向（见地）问题，您举的例子是到北京，不管走那条路，但得把方向找准。后学就是这样，还处在看地图的阶段。
    当然，如师兄所言，如果依止了具德上师（经过观察后的如法选择与依止），什么也甭管，老实跟着走就好，这也是身口意的依止与供养。我体会，上师在见地与修法上的传受，是依弟子的情况，逐步进行的，非常善巧！
    谢谢师兄为我指出了这点！顺便问一下，抄过经的纸怎么处理？烧了？

    zs：
    一、师兄能从我上贴想到依止上师的问题，真是欣喜，修佛的路数就是这个。
    二、抄经的纸我也不知道怎么处理，我攒了很厚一沓儿了。
    三、麻叔这贴，真别小看了，摘下存起来。你细看看，和〔XX和XX是互为因果〕等说法比较着看，只要能看的有点感觉，你的知见都有可能受到促进。

    “空性也不引生菩提心。为什么？不自生。”
    ──这话能这么说，我们真该觉出自己的福报大呀……

    齐愍：
    我觉得，抄的时候就抄工整比拇指还大一圈的大字，不同的经适度的装订成一本，前后加上归依和回向，订上封皮，累积起来平时留着和人结缘吧，我发现很多老太太念的经并不是印刷的而是自己抄写的，因为印得又好又大字的经她们反而不容易得到，一般的经字对她们来说都不够大的。


动物保护：大学生活的一点启示

    动物保护：大学生活的一点启示

    净国

    大学毕业五年了，期间很多事情也都逐渐淡忘了，放生的经历却还是历历在目的。通常是早上，在吴老师家汇合，然后和师母去山西北路的一个市场，买动物来放。我痛恨那个市场：一股杀气。记得有位阿姨，在那里剥泥鳅。活蹦乱跳的泥鳅啊。我们去买她会打折的，她总是说：我很难过我要杀他们，但是我的生意要做，你们买我按进价转给你们，不赚你们的钱。看到一个卖山货的汉子，师母一脸的阴沉：训斥他说，你不是说过要改行的吗？还是在干这行当（我想是猎取野生动物）。那人一脸的尴尬，赔笑说，明年就不干了（众生业力啊）。师母总会买些甲鱼，她说这些东西贵呀，很少有人买了去放，而且乌龟很多人买了是拿去玩的，甲鱼则人家买了都是去烧汤了。
    记得有一次有一位女居士和我们一同去，看到两条鳜鱼，非要买了去放。很多同去的人说鳜鱼很难放活的，而且其中一条已经受了伤。但这位居士说“我觉得这两条鱼特别亲。我从小没了父母，如果这两条鱼就是我的父母呢？”后来我们还是买了这两条鱼。但因为是放在了袋子里，到了灵古寺的时候受伤的那条已经不怎么会动了。在灵古寺受了三皈依，我们辗转到玄武湖公园里面去放水生动物。我在湖边放乌龟和鳗鱼，师母和同修们去了诺那精舍我都没在意。而等我回来的时候，在鸡鸣寺的门口碰上了一个同班同学，他告诉我他们去了精舍，他一边送我一个装有恒河金刚沙的小瓶子，一边对我说“还记得那两条鱼吗？”我当然记得，而且还在挂记那条伤的是否能够活命。他说可“可有意思了，那条伤的鱼没事啦，在水里还活蹦乱跳呢。而且，我们把他们放在水里以后，他们在那里游了好几个转，师母说去吧，不要再让人捉住了，他们才走了呢。”我心下很高兴。
    因为吴老师和师母都是素食的，很多同修在大学里就开始素食了。象后来在五台山出家的忠照法师、后来在多宝讲寺出家的宗根法师，现在还常来此论坛的利刃师兄等等。当时我因为一个很巧的因缘接触了佛教，并且皈依，也时不时亲近吴老师以及诸位学友，但是只是把佛教当作娱乐文化，并不是很认真的学，修则更谈不上。酒是穿肠而过，肉也是照吃不误的。有一天我在食堂，正好碰上利刃师兄。我们边吃饭边聊天。利刃师兄看看我的碗，问我，“你还吃肉？”我说是啊。他问我：“你想想这些动物都是你前世的父母，你还能吃的下吗？”
    我记得当时并没有回答这个问题，其实心里犯嘀咕：“这孩子怎么说话这么冲。”
    因为我在班上善辩是小有些名气的，竟然被利刃问了个语塞，（利刃和我不是同班），这个场面自然而然记了个清清楚楚。
    四年后，我开始了素食。因为我再受不了在心里嘀咕这个问题了。


探讨学佛人的婚姻与家庭问题

    探讨学佛人的婚姻与家庭问题

    成军

    菩萨的意思，是觉悟有情。菩萨的慈悲心，不是凭空而来的，是建立在我们凡夫的感情（如亲情、恻隐之心等）基础之上，因为菩萨的心量广大而遍及于一切众生。菩萨的慈悲虽然是我们凡夫感情的升华，却是需要了达以无我空性智慧。如果不明白这点，以佛法给爱情和婚姻另外再蒙一层美丽的纱，甚至打着佛法的旗号搞网恋、婚外恋等等，希望“不负如来不负卿”，只能是自欺欺人罢了。
    有一篇佛法开示提到，“佛法是教人如何享受美好的事物的，而不是要摧残它。要享受美好，先要了解一切事物都是无常的，好东西离去时勿悲伤，面对逆境困境时也不必徬徨”。如果处理的好，爱情、婚姻、家庭可以是人生里面很美好的东西。在家学佛，并不是说把自己变得和社会、家庭格格不入，特意逃避正常的家庭生活和感情，乃至故意以苦行折磨自己，把本来好好的生活弄得很糟糕甚至妻离子散。所谓“菩萨在家，不受缠缚”，应该是说体会其无常性，以此为基础再进而体会其性也空，在美满生活的同时，不要被其缚著。
    因此说，如果是在家学佛，就不必非要远离婚姻。单身和结婚，是各人的选择，每个人各有因缘。只要不是出家人，就没有必要非要以学佛为理由，向他人鼓吹结婚或单身。事实上，远离婚姻不等於远离淫欲。如果没有于禅定中获得现法乐住，实现身心的转化，强制断淫欲事实上是很难的。如果认为单身修行就可以不受淫欲的困扰，是不现实的。在家人学佛，重要的是先守好包括不邪淫戒在内的五戒，而不必一开始就以出家人的断淫来要求在家人。事实上，修行上了路，处理适当，已婚在家人的正淫并非修道的最大障碍。
    对於已婚佛弟子的感情问题和家庭生活，所谓“夫妻恩爱”，恩还在爱的前面，婚姻的幸福美满，重要的是来自互相关照对方，共同抚养子女、照顾老人的责任。有家室的佛弟子，如果能把对家庭（推而广之，对社会）的责任尽到，做一个好丈夫（好妻子）、好父亲（母亲）、好公民，就已经是在实践人天乘的佛法了。菩萨道行者要利益一切有情，如果连身边的人无法利益，又凭什么可以去利益陌生人呢？
    佛法的根本在于自他的解脱，在於出离三界火宅。美好的生活也是因缘和合的假有，过好家庭生活、尽好自己的义务，不等於被美满的婚姻家庭牢笼所困。菩萨道的行者，如果没有先升起强烈的出离心，那么菩提心也只是一句空话。如果具备了真实的出离心、菩提心，能够时刻以菩萨的智慧和心量观照生活中的一切，那么生活的一切都无不是修行，
    对於在家修行、佛化家庭、行菩萨道的问题，后学认为，具体对於我们这些在家学佛的佛弟子而言，最重要的是明白学佛修行次第，也清楚自己是处於什么阶段。对於初学佛法的同修而言，最重要的是皈依三宝，明信因果，受持五戒十善，实践人天善法，如此未来世则可以报人身。进一步，发出离心（请注意，出离心不等於出家），具备强烈的愿望，出离三界不再受生死轮回之苦。再进一步，不但希望自己能够了生脱死，也希望能够帮助其他一切的有情众生出生死海，发起大悲心。为了实现这个目的，希望自己能够具有和佛陀一样足够的智慧方便，这就是菩提心。发菩提心后，通过座上座下佛法的修学，使自己时刻都能保持此心行，并且不断增上。如此，放是大乘菩萨道的实践者，也才谈得上大乘菩萨的入世修行。因此，同样都是居家入世，我们往往容易把人天乘善法和大乘菩萨道混在一起，把前者当成了后者。结果，学佛一生，只得了人天果报。其中的关键，还是看自己的出离心和菩提心，是否真正升起？


什么是善知识？

    什么是善知识？

    zf

    善知识在我们修学佛法中的作用，的确值得深思。关于善知识的功德及如何承事善知识等的经文，“摘下来每天读一下”，的确应该这样。
    显乘行人对密乘常有不解之处，其中密乘的修持以上师为核心这一点就常常被误解为“依人不依法”。实际上一个具格的上师自然会具备大慈悲、大智慧、大善巧和清净的传乘。密乘弟子以这样的善知识为核心修持，这种宗风与《华严经》的思想是完全吻合的。因为“一切菩萨行、一切菩萨波罗蜜、一切菩萨地、一切菩萨忍、一切菩萨总持门、一切菩萨三昧门、一切菩萨神通智、一切菩萨回向、一切菩萨愿、一切菩萨成就佛法皆由善知识力，以善知识而为根本，依善知识生，依善知识出，依善知识长，依善知识住，善知识为因缘，善知识能发起。”
    当然，我等时处末法，假善知识恐怕比真善知识要多得多。提高我等自身的素质和分别真假善知识的能力是修行的重要内容。

    什么是善知识？善知识有哪些功德？如何承事善知识？这些的确是非常重要的问题。
    《华严经》对上述问题给出了非常丰富的解说，特别是在《入法界品》中，善财童子就是一位在善知识指导下修行成佛的典范。
    现从华严大海中取出几滴法水，供养诸位兄弟。

    一、对于修行大乘道者，具有哪些品质者方堪称为善知识？
    在《离世间品》中，普贤菩萨开示：
“佛子。菩萨摩诃萨。有十种善知识。何等为十。所谓令住菩提心善知识。令生善根善知识。令行诸波罗蜜善知识。令解说一切法善知识。令成熟一切众生善知识。令得决定辩才善知识。令不着一切世间善知识。令于一切劫。修行无厌倦善知识。令安住普贤行善知识。令入一切佛智所入善知识。是为十。”
    这就是说，那些能令行人安住菩提心者（未生令生，已生令坚）是善知识；
    那些能令行人生起戒定慧等诸善根者是善知识；
    那些能令行人修习布施、忍辱、般若等诸波罗蜜者是善知识；
    那些能为行人解说诸法实相及一切修持法门者是善知识；
    那些能令一切众生善根成熟者是善知识；
    那些能令行人以无碍辩才宣说正法者是善知识；
    那些能令行人不贪着世间名闻利养者是善知识；
    那些能令行人于一切劫修行无厌倦者是善知识；
    那些能令行人安住普贤行者是善知识；
    那些能令行人深入一切佛智大海者是善知识。

    二、行人应具有怎样的品质才能有机缘亲近善知识？

    《入法界品》中，
    “时有守护菩萨法堂罗刹鬼王。名曰善眼。与其眷属万罗刹俱。于虚空中。以众妙华。散善财上。作如是言。善男子。菩萨成就十法。则得亲近诸善知识。何等为十。所谓其心清净离诸谄诳。大悲平等普摄众生。知诸众生无有真实趣一切智心不退转。以信解力普入一切诸佛道场。得净慧眼了诸法性。大慈平等普覆众生。以智光明廓诸妄境。以甘露雨涤生死热。以广大眼彻鉴诸法。心常随顺诸善知识。是为十。”
    将我们充满烦恼的自心与以上十条标准对照一下，自己未能受到善知识的呵护，原因全在我们自己。

    三、善知识的功德及如何承事善知识等

    〈入法界品〉中，德生童子、有德童女对善财童子说道：
善男子。菩萨因善知识。听闻一切菩萨诸行。成就一切菩萨功德。出生一切菩萨大愿。引发一切菩萨善根。积集一切菩萨助道。开发一切菩萨法光明。显示一切菩萨出离门。修学一切菩萨清净戒。安住一切菩萨功德法。清净一切菩萨广大志。增长一切菩萨坚固心。具足一切菩萨陀罗尼辩才门。得一切菩萨清净藏。生一切菩萨定光明。得一切菩萨殊胜愿。与一切菩萨同一愿。闻一切菩萨殊胜法。得一切菩萨秘密处。至一切菩萨法宝洲。增一切菩萨善根芽。长一切菩萨智慧身。护一切菩萨深密藏。持一切菩萨福德聚。净一切菩萨受生道。受一切菩萨正法云。入一切菩萨大愿路。趣一切如来菩提果。摄取一切菩萨妙行。开示一切菩萨功德。往一切方听受妙法。赞一切菩萨广大威德。生一切菩萨大慈悲力。摄一切菩萨胜自在力。生一切菩萨菩提分。作一切菩萨利益事。
    善男子。菩萨由善知识任持不堕恶趣。由善知识摄受不退大乘。由善知识护念不毁犯菩萨戒。由善知识守护不随逐恶知识。由善知识养育不缺减菩萨法。由善知识摄取超越凡夫地。由善知识教诲超越二乘地。由善知识示导得出离世间。由善知识长养能不染世法。由承事善知识修一切菩萨行。由供养善知识具一切助道法。由亲近善知识不为业惑之所摧伏。由恃怙善知识势力坚固不怖诸魔。由依止善知识增长一切菩提分法。何以故。善男子。善知识者。能净诸障。能灭诸罪。能除诸难。能止诸恶。能破无明长夜黑暗。能坏诸见坚固牢狱。能出生死城。能舍世俗家。能截诸魔网。能拔众苦箭。能离无智险难处。能出邪见大旷野。能度诸有流。能离诸邪道。能示菩提路。能教菩萨法。能令安住菩萨行。能令趣向一切智。能净智慧眼。能长菩提心。能生大悲。能演妙行。能说波罗蜜。能摈恶知识。能令住诸地。能令获诸忍。能令修习一切善根。能令成办一切道具。能施与一切大功德。能令到一切种智位。能令欢喜集功德。能令踊跃修诸行。能令趣入甚深义。能令开示出离门。能令杜绝诸恶道。能令以法光照耀。能令以法雨润泽。能令消灭一切惑。能令舍离一切见。能令增长一切佛智慧。能令安住一切佛法门。
    善男子。善知识者如慈母。出生佛种故。如慈父。广大利益故。如乳母。守护不令作恶故。如教师。示其菩萨所学故。如善导。能示波罗蜜道故。如良医。能治烦恼诸病故。如雪山。增长一切智药故。如勇将。殄除一切怖畏故。如济客。令出生死暴流故。如船师。令到智慧宝洲故。善男子。常当如是正念思惟诸善知识。
    复次善男子。汝承事一切善知识。应发如大地心。荷负重任。无疲倦故。应发如金刚心。志愿坚固不可坏故。应发如铁围山心。一切诸苦无能动故。应发如给侍心。所有教令。皆随顺故。应发如弟子心。所有训诲。无违逆故。应发如僮仆心。不厌一切诸作务故。应发如养母心。受诸勤苦不告劳故。应发如佣作心。随所受教无违逆故。应发如除粪人心。离憍慢故。应发如已熟稼心。能低下故。应发如良马心。离恶性故。应发如大车心。能运重故。应发如调顺象心。恒伏从故。应发如须弥山心。不倾动故。应发如良犬心。不害主故。应发如旃荼罗心。离憍慢故。应发如犗牛心。无威怒故。应发如舟船心。往来不倦故。应发如桥梁心。济渡忘疲故。应发如孝子心。承顺颜色故。应发如王子心。遵行教命故。
    复次善男子。汝应于自身生病苦想。于善知识生医王想。于所说法生良药想。于所修行生除病想。又应于自身生远行想。于善知识生导师想。于所说法生正道想。于所修行生远达想。又应于自身生求度想。于善知识生船师想。于所说法生舟楫想。于所修行生到岸想。又应于自身生苗稼想。于善知识生龙王想。于所说法生时雨想。于所修行生成熟想。又应于自身生贫穷想。于善知识生毗沙门王想。于所说法生财宝想。于所修行生富饶想。又应于自身生弟子想。于善知识生良工想。于所说法生技艺想。于所修行生了知想。又应于自身生恐怖想。于善知识生勇健想。于所说法生器仗想。于所修行生破怨想。又应于自身生商人想。于善知识生导师想。于所说法生珍宝想。于所修行生捃拾想。又应于自身生儿子想。于善知识生父母想。于所说法生家业想。于所修行生绍继想。又应于自身生王子想。于善知识生大臣想。于所说法生王教想。于所修行生冠王冠想。服王服想。系王缯想。坐王殿想。善男子。汝应发如是心作如是意近善知识。何以故。以如是心近善知识。令其志愿永得清净。
    复次善男子。善知识者长诸善根。譬如雪山长诸药草。善知识者是佛法器。譬如大海吞纳众流。善知识者是功德处。譬如大海出生众宝。善知识者净菩提心。譬如猛火能炼真金。善知识者出过世法。如须弥山出于大海。善知识者不染世法。譬如莲华不着于水。善知识者不受诸恶。譬如大海不宿死尸。善知识者增长白法。譬如白月光色圆满。善知识者照明法界。譬如盛日照四天下。善知识者长菩萨身。譬如父母养育儿子。
    善男子。以要言之。菩萨摩诃萨。若能随顺善知识教。得十不可说百千亿那由他功德。净十不可说百千亿那由他深心。长十不可说百千亿那由他菩萨根。净十不可说百千亿那由他菩萨力。断十不可说百千亿阿僧祇障。超十不可说百千亿阿僧祇魔境。入十不可说百千亿阿僧祇法门。满十不可说百千亿阿僧祇助道。修十不可说百千亿阿僧祇妙行。发十不可说百千亿阿僧祇大愿。
    善男子。我复略说一切菩萨行。一切菩萨波罗蜜。一切菩萨地。一切菩萨忍。一切菩萨总持门。一切菩萨三昧门。一切菩萨神通智。一切菩萨回向。一切菩萨愿。一切菩萨成就佛法。皆由善知识力。以善知识而为根本。依善知识生。依善知识出。依善知识长。依善知识住。善知识为因缘。善知识能发起。


关于上师与善知识

    关于上师与善知识

    zf

    未兄，“上师”是密乘的称谓，大乘中与“上师”相近的一个称呼是“善知识”。
    关于善知识在大乘法中的作用，佛典中有丰富的论述。《华严经》，特别是《入法界品》中特别强调了善知识对行人趋向无上佛道的极端重要意义。
    现从这些珍贵言教大海中取出几滴，希望对您有所启发。
    佛子。菩萨摩诃萨。有十种成就佛法。何等为十。所谓不离善知识。成就佛法。深信佛语。成就佛法。不谤正法。成就佛法。以无量无尽善根回向。成就佛法。信解如来境界无边际。成就佛法。知一切世界境界。成就佛法。不舍法界境界。成就佛法。远离诸魔境界。成就佛法。正念一切诸佛境界。成就佛法。乐求如来十力境界。成就佛法。是为十。若诸菩萨。安住此法。则得成就如来无上大智慧。
    （zf评说：“不离善知识”位于“十种成就佛法”之首。）

    佛子。菩萨摩诃萨。有十种退失佛法。应当远离。何等为十。所谓轻慢善知识。退失佛法。畏生死苦。退失佛法。厌修菩萨行。退失佛法。不乐住世间。退失佛法。耽着三昧。退失佛法。执取善根。退失佛法。诽谤正法。退失佛法。断菩萨行。退失佛法。乐二乘道。退失佛法。嫌恨诸菩萨。退失佛法。是为十。若诸菩萨。远离此法。则入菩萨离生道。
    （zf评说：“轻慢善知识”位于“十种退失佛法”之首。）

    佛子。菩萨摩诃萨。有十种舍离魔业。何等为十。所谓近善知识。恭敬供养。舍离魔业。不自尊举。不自赞叹。舍离魔业。于佛深法。信解不谤。舍离魔业。未曾忘失一切智心。舍离魔业。勤修妙行。恒不放逸。舍离魔业。常求一切菩萨藏法。舍离魔业。恒演说法。心无疲倦。舍离魔业。归依十方一切诸佛。起救护想。舍离魔业。信受忆念。一切诸佛。神力加持。舍离魔业。与一切菩萨。同种善根。平等无二。舍离魔业。是为十。若诸菩萨。安住此法。则能出离一切魔道。
    （zf评说：“近善知识。恭敬供养。”位于“十种舍离魔业”之首。）

    尔时文殊师利菩萨。说此颂已。告善财童子言。善哉善哉。善男子。汝已发阿耨多罗三藐三菩提心。求菩萨行。善男子。若有众生。能发阿耨多罗三藐三菩提心。是事为难。能发心已。求菩萨行。倍更为难。善男子。若欲成就一切智智。应决定求真善知识。善男子。求善知识勿生疲懈。见善知识勿生厌足。于善知识所有教诲皆应随顺。于善知识善巧方便勿见过失。
    （zf评说：善财童子对众多善知识的参学正是在文殊菩萨这一总的原则下进行的：“善男子。求善知识勿生疲懈。见善知识勿生厌足。于善知识所有教诲皆应随顺。于善知识善巧方便勿见过失。”这一教诲与密乘中对弟子的要求如出一辙。）

    善知识者。则是趣向一切智乘。令我得至如来地故。善知识者。则是趣向一切智船。令我得至智宝洲故。善知识者。则是趣向一切智炬。令我得生十力光故。善知识者。则是趣向一切智道。令我得入涅槃城故。善知识者。则是趣向一切智灯。令我得见夷险道故。善知识者。则是趣向一切智桥。令我得度险恶处故。善知识者。则是趣向一切智盖。令我得生大慈凉故。善知识者。则是趣向一切智眼。令我得见法性门故。善知识者。则是趣向一切智潮。令我满足大悲水故。
    （zf评说：密乘中视上师为佛法的总持，与这里的开示何其相似！）

    观自在菩萨。于金刚宝石上。结跏趺坐。无量菩萨。皆坐宝石。恭敬围绕。而为宣说大慈悲法。令其摄受一切众生。善财见已。欢喜踊跃。合掌谛观。目不暂瞬。作如是念。善知识者则是如来。善知识者一切法云。善知识者诸功德藏。善知识者难可值遇。善知识者十力宝因。善知识者无尽智炬。善知识者福德根芽。善知识者一切智门。善知识者智海导师。善知识者至一切智助道之具。
    （zf评说：密乘中视上师为佛，与这里之“善知识者则是如来”含义完全相同。）

    时善财童子。遽发是念。由亲近善知识能勇猛勤修一切智道。由亲近善知识能速疾出生诸大愿海。由亲近善知识。能为一切众生。尽未来劫。受无边苦。由亲近善知识。能被大精进甲。于一微尘中。说法声遍法界。由亲近善知识。能速往诣一切方海。由亲近善知识。于一毛道。尽未来劫。修菩萨行。由亲近善知识。于念念中。行菩萨行。究竟安住一切智地。由亲近善知识。能入三世一切如来。自在神力诸庄严道。由亲近善知识。能常遍入诸法界门。由亲近善知识。常缘法界未曾动出。而能遍往十方国土。
    （zf评说：可见“亲近善知识”乃修持佛法的全部。）

    若有诸菩萨　　顺善知识教
    一切无疑惧　　安住心不动
    当知如是人　　必获广大利
    坐菩提树下　　成于无上觉
    （zf：华严经中的这一颂文也赠于未兄。）


依止善知识和积累福慧资粮

    成军：
    关于学佛依从明师谈点个人看法。
    学佛应该依止善知识，即明师（请注意，“名”师未必是明师），这是佛陀的教导，也是众多前人的经验。后学个人的体会，拜明师、依止善知识，有以下几点。
    第一是自己的福德资粮要具足，也就是说，今生得遇明师，很多时候看起来是巧合，其实背后的微细因缘却是非常难以思议的。比如说，为什么众多学人中，明师偏偏摄受了你而不是别人，你为什么又能对明师升起信心？
    第二是要有择法眼。末法时代，邪师说法如恒河沙，相似佛法、附佛外道盛行，很多也打着明师的旗号，典型的如青海无上师，她也标榜学佛要明师。反过来，没有眼光，明师在眼前也对面不识。那么我们怎么了知真伪明师呢？关键就需要自己对于佛法，具备起码的正见。
    第三是即使有缘得遇明师，自己要是能够受法的法器。有些人慢心重，所知障重，明师的话合自己意的就听，不合自己意的不听，甚至反生嗔恨。这样的人，即使有缘师从明师，最后也难有成就。
    一下子要做到以上几点并不容易，后学的建议是，如果一时还没有缘得遇明师的同修，可以一方面认真研读经论，增长自己的智慧，树立正知见。另外一方面，好好持戒、修定（如诵经、念佛）、在生活中尽所能利益他人，把这些所有的善根和修行，都回向给自己未来得遇明师的法缘，也可以为此多多祈请佛菩萨。等到福德资粮够了，自然能够得遇明师。
    祝愿您早日得遇与您有缘的明师，早日成就。

    jerry：
    多谢您的长帖！读了之后，觉得需要等缘分。自己现在只能多读经书和多积功德。不知可以打坐吗？
    您说的几条里，“择法眼”比较难。择法眼要有正见。只是正见从那里来？只读经能有正见吗？如果正见必须从拜明师来，那可成死循环了。请解释，多谢！

    成军：
    呵呵，起码现在有网络嘛，就不是死循环／不知道您怎么定义打坐，即使没有老师，坐着念佛总是可以的。研读经论可以是获得正见的一种渠道，不过很大程度也是因人而异。再多的我也说不好，您等论坛上诸位善知识的回答吧。

    二麻子：
    某种死循环的感觉是相当普遍的现象……
    甚至可以说是多数人的常态，差别仅在于“死”在什么程度而已。产生这个感觉／现象的原因是，我们凡夫看问题的时间尺度太小，而学佛直到解脱之间需要积累的福慧二资粮非常大，一般来说一生不够用。
    Jerry兄说的死循环，如果放在象滚雪球那样从小到大积累福慧的过程里，就不存在了。
    有的人福慧资粮比较多（过去俺觉得很不爽呀，嘻嘻），我们不多。麻子总算在学佛里知道，如果现在不去积累，那么下辈子一定还是不多。
    前面某个帖子里ZF兄说到，能生起对佛法的信心，是某种“果位”。俺很赞同，不是成就的那个果位，而是说，能生信心也是一种因果，而果必然是要有因缘在前面的。


亲近善知识非半梵行，乃全梵行

    zzzm：
    《入法界品》中，
    “时有守护菩萨法堂罗刹鬼王。名曰善眼。与其眷属万罗刹俱。于虚空中。以众妙华。散善财上。作如是言。善男子。菩萨成就十法。则得亲近诸善知识。何等为十。所谓其心清净离诸谄诳。大悲平等普摄众生。知诸众生无有真实趣一切智心不退转。以信解力普入一切诸佛道场。得净慧眼了诸法性。大慈平等普覆众生。以智光明廓诸妄境。以甘露雨涤生死热。以广大眼彻鉴诸法。心常随顺诸善知识。是为十。”

    ──若“成就”如上十法在后学看来已经是很“厉害”了，简直都快成佛了，若要成就此十法才能有机缘亲近善知识，那，没有善知识这十法如何成就呢？或者这里说的善知识已经不是普通意义上的善知识了。敬请赵叔释疑。

    zf：
    亲近善知识非半梵行，乃全梵行。首先需要说明的是，《华严经》教法的当机者乃是大菩萨，其中绝大部分开示的内容十分高深，这里所说成就善知识的十法亦复如是。
    要亲近十分完美的善知识，应该具备如上十法，但这并不是说在成就这十法的过程中可以离开不那么完美的善知识的指导。
    比如，小学生在小学老师的指导下，学完小学课程，便具备了“亲近”中学老师的条件，成为中学生；同样，中学生在中学老师的指导下，可以具备“亲近”大学老师的条件。学生每上一个台阶都离不开老师的帮助。
    当一个已经具有独立工作能力的人，陶醉于自己的能力，而忘记了其能力中所凝聚之师长的心血，这样的人并不是我们学习的榜样。
    印顺法师关于善知识的论述值得我们用心体会。

    ◎附：印顺法师《成佛之道》第二章（摘录）

    颂文：“趣入正法者，应亲近善士，证教达实性，悲愍巧为说。”
    解说：正法，虽可以从经典去了解，但主要还是要从说法师去听闻。法师的开导，比起自己阅诵，到底迅速而容易得多。所以为了要“趣入正法”，进求佛道，“应”该“亲近善士”──善知识，尤其是大乘善知识。佛曾以：“亲近善士，听闻正法，如理思惟，法随法行”，说为预入圣流所必备的四大条件，这可见亲近善知识的重要了。
    怎样才算是善知识呢？这不是因为他徒众多，寺院大，相貌好，或者是世法场中多知多识。因为他有：（1）“证”德，指三学修证：戒清净成就，定成就，观慧成就。（2）“教”德：深入经藏，成就多闻，能开示导引学众，进修大乘正道。（3）“达实性”：实性是正法的别名，这或者由现证慧通达，或是从闻思教理得通达。（4）“悲愍”：有慈悲心，不是为了名闻利养，而是能清净（为利益众生）说法。（5）“巧为说”：成就辩才，能善巧方便的为众说法，所以容易了解，容易得益。如成就这些功德，那就是了不得的大善知识了！可是末法时代，全德的善知识，是难得遭遇的；而修学佛法，却又不能没有师友，所以不能不退求其次。经上说：如有八分之一的功德，也可以亲近。《涅槃经》说“四依”──四种可以为人依止的师长：初依人，虽没有断烦恼，证实性，但已能通达佛性义十六分之一。总之，末世善知识难逢，如于佛法的行解，有一分长处，胜过自己，也就不妨如法亲近了。
    颂文：“观德莫观失，随顺莫违逆。佛说满梵行，学者应尊敬。”
    解说：无论是全德的善知识，少分功德的善知识，如不能如法亲近，都不能得应得的功德。所以对于善知识，要“观”察他的功“德”，“莫观”察他的过“失”。如听受善知识的教导，或从举止动静、待人接物处去学习，只要有一分长处，就注意他的长处而修学。这样，虽然是少分功德的知识，也可以得到法益。反之，如不观功德，专在善知识的缺点上着想，不是这样不对，就是那样不够，那虽然逢到全德的大善知识，也毫无利益。因为全德善知识，也不能一切圆满，没有一些缺点的。所以亲近善知识，应随时提醒自己：来这里做什么？不是为了寻求知识的过失，而是想学习师长的长处。能这样，就到处有师长可亲近，随处都能得益。孔子说：“三人行，必有我师焉”，也就是这个意思。
    亲近善知识，扼要的说，要“随顺”师长的意旨，使师长欢喜，切“莫违逆”师命。就是师长有所呵责，也应受责，不可生嫌恨心、恚恼心。怎么能使师长欢喜呢？（1）要随力供养种种财物；（2）为师长服劳务；（3）照着师长的开导教授去修行。佛法的恭敬亲近善知识，完满的表现“尊师重道”的精神。假使师长要你作种种非法呢？那是不应该随顺的，但应该婉转的说明不能奉行的意思。修学佛法，如不能如法尊敬师长，想得到佛法的功德，那是完全不可能的。如经上说：“若彼于师，住嫌恨心、坚恶心、或恚恼心，能得功德，无有是处。”
    某次，如来赞叹善知识的功德，阿难说：“半梵行者，所谓善知识。”“佛说”：“莫作是言。纯一“满”净“梵行”清白，所谓善知识。”阿难的意思，亲近善知识，那清净梵行，可说已完成一半了。可是佛的意思，亲近善知识，可说圆满清净梵行，已经完成。佛是怎样的重视善知识！所以“学者”，“应”该“尊敬”供养善知识。亲近善知识的功德，《华严经》等都说得非常详明。
    FROM：【中华佛教百科全书】

    注：有部毗奈耶杂事曰：“阿难陀言：诸修行者，由善友力，方能成办。得善友故，远离恶友，以是义故，方知善友是半梵行。佛言：阿难陀勿作是言，善知识者是半梵行。何以故？善知识者是全梵行，由此便能离恶知识，不造诸恶。常修众善，纯一清白，具足圆满梵行之相。由是因缘若得善伴与其同住乃至涅槃事无不办，故名全梵行。”


谈谈我想出家的原因

    谈谈我想出家的原因

    小夜叉

    不久前，我做出一个重大的决定：我要出家。作为大乘佛法的信仰者，我们都知道，学佛不一定要出家。那么，是什么原因促使我一定要选择出家呢？这里我谈谈最重要的理由：
我怕自己以后越来越堕落。
    中国有句古语：“人在江湖，身不由己。”是的，我知道对错，我也有强烈的道德感，甚至，我认为我有坚定的佛法正见。可是，这些都是脑子里想的和嘴巴上说的东西。我不敢保证自己能照着这些正见去做！
    在家的责任巨大，社会和家庭还会迫使你去做很多你可能不愿意做的事情： 　　当你长大了，你“必须”结婚。不结婚？父母辛辛苦苦把你养大，你怎么对得起他们？
    当你结婚了，你“必须”生子。不生？你妈妈等着抱孙子呢！你有毛病？还是你老婆有？
    当你生子了，你“必须”买房。房子都买不起？你真没用！瞧瞧你同学，你买的这还能叫房子吗？
    当你买房了，你“必须”升官。还是一小科员？嗨，你怎么混的！没出息！
    当你升官了，你“必须”发财。什么？全家都指望你了，还这么穷，你真没用！真没用！
    当你想钱了，就“必须”应酬。什么？不会喝酒？什么？小姐都没泡过？你真土！你是男人吗？
    当你都有了，你的子女呢？他们上哈佛了吗？啊？没有？嗨，家门不幸啊！
    这些东西，我就不一一列举了。
    我佩服南怀瑾先生的修养和大丈夫气派。他最穷的时候，拿着家里值钱的东西，冒着凛冽的寒风去当铺，当了钱去买米。回家的路上，看到邻居更加缺米，就把米全部送给了他们。南老师在贫困时，从来都是面无忧愁，从来都是谈笑风生！
    可惜，我不是南怀瑾。我是一个对别人眼色很敏感的读书人。我太在乎，所以，我“必须”做的事情，我大概都会去做的。我会慢慢地变成我不愿意做的人。在家的烦恼有极巨大的摧毁力，除非意志坚强的人，难免都会被卷进去，越陷越深。在家学佛，能出污泥而不染，太好了！可是很难。意志坚强的菩萨们，出家在家都可以。如果管不住自己，最好出家！
    大家都知道“三生石上旧精魂”的故事，主要是因为作家林清玄先生的关系。可是，您知道吗，据说林先生已经抛弃旧妻，另寻新爱了。人家的感情恩怨我们不好谈，可就学佛来讲，林先生是我们的警钟啊！不管你学识渊博、才华横溢，业力还是难逃，生死还是难以了却！林先生没有救度好妻子，又随着业力跑了。论佛学、修养、福报，我们谁比得上林先生？他都看不开、逃不过，难道我们有本事摆脱命运和业网的驱使吗？
    谁可以大声说：我就是要在家，而且我有百分之百的把握在今生解脱！
    恐怕没有人敢这么说。您有圆泽禅师的智慧和神通吗？连圆泽禅师都在劫难逃。更不用说我们了。
    就看看我们周围那些年纪大的居士吧，他们有几个人已经解脱了？嘿嘿，他们就是五十年后我们啊！你不感到恐惧吗？或许有人连活到他们的年纪还不一定呢！人命在呼吸间啦！
    我们有把握抵抗业力吗？您能保证五年后一定不会离婚？您能保证你明天不迷失在夜总会？您能保证后天不出车祸？就算都能保证，您能保证无常到来时往生乐土？圆泽禅师的神通都不能敌得过。林先生的才华修养也敌不过。那么，您凭什么？
    您能保证马上戒烟？
    您能保证五分钟后不去色情网站？
    嘻嘻，答案嘛，我们自己心里清楚。
    怎么办？我个人选择出家。我没有意志和魄力保证我不堕落。我却有信心和决心做一个好的比丘！因为出家人的障碍毕竟会少得多。学习经典的时间会多一些。练习禅定的机会会多一些。不需要去夜总会。不需要在酒席上豪饮应酬。不需要贷款买房子。您会有很多参访的机会。您会有机缘亲近更多的善知识。只要您有真才实学，您可以亲手传播佛陀的真理！
    出家不是逃避。是撤退。当恩怨、诱惑、烦恼的力量过于强大时，我们应该聪明地撤退，然后精进地用佛法训练自己，这样，以后就可以和业力过招，大战三百回合，粉碎魔军。
    出家甚至不是撤退，而是进攻！在僧团里，我们会时刻和恩怨、诱惑、烦恼作战！我们会面临很多问题：性的欲望，金钱和供养，徒众多少，建庙，名气，等等。对这些，我们将主动出击、奋勇作战！
    出家甚至不是进攻，而是成功！出家，就是跳出了一个大火宅，逃出了一个虎口，虽然我们赞叹火宅中处之泰然的菩萨。逃出火宅，就是巨大的成功！
    难道出家仅仅是自私的撤退、进攻和成功吗？不。还有更重要的：我们不忍众生继续苦难，我们不忍看到圣教继续衰亡！我们发大慈悲心、大菩提心，我们决心成就以后广度众生、击大法鼓、吹大法螺！在我们发心的那个时刻，我们就和佛陀没有差别！
    我们精进持戒。我们深入禅定。我们在甚深的禅定中观察、思考这个世界的真相。我们游戏于初禅、二禅、三禅、四禅、无色界禅。我们亲证初果、二果、三果、阿罗汉果、无生法忍、七地、八地、九地、十地！
    朋友，如果您有条件、有决心，那么，出家吧。
    在这个星球上，有一个相对比较安全的地方。
    那个地方就是佛陀亲手创建的比丘和比丘尼的僧团。


对于密教皈依上师的一些个人认识

    对于密教皈依上师的一些个人认识

    成军

    最近佛教论坛和法华论坛先后出现少数朋友对于四皈依中皈依上师的质疑，并逐渐演变到贬斥整个金刚乘。后学认为，只要合乎三法印的，传承清净无缺的各宗佛法，其实都是互不相违的，它们分别适合于不同根器的众生。在此佛法不兴的时代，佛教界内部显密互谤，实在是件很可悲的事情。
    首先，宗喀巴大师其实非常强调皈依上师的，他专门为印度马鸣菩萨著的《事师法五十颂》造释。在他的菩提道次第教授里面，也是教导学佛人应该视师如佛，如：“万善根本从师出”，“诸善知识真佛身”等。况且，宗大师于《菩提道次第广论》外，还造了《密宗道次第广论》，一向主张显密各宗互不相违。这位试图引宗大师的话来贬斥密宗的朋友，实在应该好好看些宗大师的著作。
    在大乘佛法中，我们知道，其实在此娑婆世界，现种种形象度化众生的诸佛菩萨是不可思议的，如法华经中那众多从地涌出的菩萨。
    佛陀本身，也是同时具足法报化三身，以各种因缘弘法利生。例如本师释迦牟尼佛时代的人们，因善根成熟，能够有缘跟从佛陀(属于化身佛)修行佛法。而后世的修行人中，已登地的菩萨，可以领受报身佛的教导，许多密宗经典，就是报身佛所传；显密各宗的大修行人，都常常在定中甚至平时感佛菩萨现身传法，这在历代高僧的事迹中多有记载，如智者大师证法华三昧后，亲见灵山一会俨然未散；又如宗大师造《菩提道次第广论》时，经常亲向本尊文殊菩萨请教疑难。而对于我们这些凡夫，则只能依从示现凡夫相而具备戒行实修的善知识修学佛法，其标准可以概括为善知识十德。这些善知识对于我们的恩德尤其巨大，没有他们，我们可能连佛的名字都没有听说过。同时他们虽然示现凡夫相，其内证也非我们所能知。
    因此，具足善知识十德的上师，其实是总摄佛法僧三宝的佛法的化身，视师如佛是完全合乎佛法的。须知，佛法的利益均来自恭敬心，否则我们为什么要拜泥塑木雕的佛像呢？
    显宗虽然不专门独立出皈依上师，但是我们看历代祖师的传记，他们大都是老老实实依止具德善知识老师的。历史上，大成就祖师的法脉往往由那些终身依止的侍者弟子接下来，例如禅宗六祖大师的大弟子，怀让祖师经六祖印证，“豁然契会”后，“遂执侍左右一十五载，日臻玄奥。”，“后往南岳，大阐禅宗”。大善知识潜移默化的言传身教是经论所无可替代的，佛法僧三宝其实正是在这些具德善知识身上得以具体体现。世间法的成就，尚且依靠老师，何况无上佛法？
    更进一步，在密宗里面，皈依上师，其实正是修行的入手处，对上师的真实无伪的信心也同时就是对佛法僧三宝的信心。而密宗入手的四加行修法中的上师相应法，在实际下手时相当系统可行。其所培养的相应，和显教净土宗里面通过念佛与阿弥陀佛的相应，以及根本乘原始佛法里面的十念法其实都有异曲同工之妙。以后学个人理解，本质上是通过此种种方便，转凡夫的身语意为佛的身语意。
    如果按照三十七道品，则应该对应于信力的培养。《华严经》云：“信为道源功德母，长养一切诸善根”。当代大德法尊的著作中说：“印度的僧伽，摄授弟子，初在熟识戒律之后，不要他学教参禅，先教以赞佛功德，如教之读一百五十赞和三百赞等，……，以此坚其信心，待信心坚固之后，始进学他种教理。”可见信力的培养和皈依的实修，是一个佛弟子必备的基础。印度大德阿底峡尊者入藏弘法，始终就是在强调皈依，这决不是多余的。在密宗行人后面实修的每一阶段，也都有赖于具证上师的教授，因此方能克期取证，金刚乘修法的独特殊胜之处也在于此。
    认为四皈依和三皈依矛盾，把上师和三宝故意对立起来，如果不是出于对佛法的误解，那么就不能不省查其用心了。当今佛弟子类似的错误还有只皈依佛和法，不肯皈依未成就的凡夫僧，俗称“二宝居士”；或是自认为心皈依，却不肯走皈依受戒的形式，自居“不着相”。这样的人，其实都还没有真正理解皈依的含义，没有明白上师、佛法僧三宝本质的无别与相互含摄。
    最后奉劝那些对佛法特别是密宗缺乏足够了解的朋友，切勿抓住一点佛法的皮毛而妄加评论。这样做，即使在世间法的层次也不是有修养的人所为，何况还有谤佛法、误导众生的业果在里面。对于佛法各宗的一些殊胜方便，如果所知不多，不妨暂时存疑，发愿将来有缘得遇真正的善知识而能够清楚地了解。
    上面所言，仅个人管见，特别是有关密宗的见解更是难免谬误，希望论坛上诸大德高贤指正。


聊点“做功课”

    聊点“做功课”

    智祥

    学佛稍有段时间的就会知道“做功课”，一般大概是这样开始的：听某法师说念阿弥陀佛名号或《金刚经》一遍有如何如何不可思议的功德，心生大欢喜然后就发心每天念多少遍。随着时间的推移，遇到能生大欢喜的法越来越多，如果再受了密乘的灌顶那每天的功课量就不断翻番上去了。我有段时间就这样，每天面对厚厚一叠法本这个也好那个也好都舍不得放弃，修行就变成每天花好几小时把各种法本仪轨过一遍了。

渐渐发现这样“做功课”并不得法，开始进行“治理整顿”。分析一下每天做的功课大约分这几类：一类是授灌顶的时候向上师本尊承诺的，这是绝对不能中断的，尤其是定为主修的法，更是要花大力气用最好的状态去修。另一类是自己发心修的法，这要根据情况，比如有段时间觉得念药师经很相应就天天念了，过了一段时间可能念地藏经感觉更好这可以调整的，但我在这种调整前会向三宝告白一下。这种调整是经常有的，比如感到自己近来慈悲心生起困难就在一段时间连续修观音法，世俗上不顺就早晚念颂度母赞，这样也可以让修行变得不那么枯燥。
善知识是成就之本，依师修法极其重要，但也不必机械地老是问上师自己修什么本尊好，或干脆让上师给安排功课，因身心状况随时变化自己最清楚。倒是有时候上师不经意提到细节需关注，上师有次听我说到修三皈依观就随口说了句：要坚持修。我就坚持每天早晨观修一遍，确实受益。
    “做功课”的时间安排个人体会最好相对固定，也就是先根据法和自己的情况定好在哪个时间段修什么法，随后遵照执行养成习惯。我早晨起来一般先清扫佛堂（也算功课吧，呵呵）然后念颂思维上师祈请文和三主要道颂，再修禅观和诵经，结束后开展一天的活动，这样坚持多年后早晨身心能比较快的调整好，对修行和生活都很有益。因为缘起关系，不同的法具体修法也会有讲究，比如有些密法适合白天修有些适合晚上修或者还有朝向等要求，这点在修法前最好先了解清楚再制订“功课表”。
    最后再聊点小体会：一个是套用现在的流行词“所见即所得”，叫“所修即所得”，就是说在座上修得的要能在生活中用上，不要把修行和生活打成两截，在修行之初就要注意用心，座上的点滴收获都让其融入生活中。另一个是要把自己在其他法门上得到的心要都摄入主修的根本法而修，在根本法上花最大的力气争取突破。

    2004/5/23


念诵与回向略谈

    成军：
    随喜各位师兄持诵地藏经的无量功德。后学的妻子大约是3、4年前，一次夜晚做梦，梦到一位远亲非常痛苦地来找她。事后打长途电话回家一问，这位远亲恰恰是差不多那个时候因为恶疾去世的，还不到40来岁。此后夜里偶然会有恶梦发生。事后，后学向恩师仁波切请教此事，恩师开示，后学的妻子应该持诵地藏经，为亲人回向。她持了若干部以后，再没有恶梦。
    想起来也奇怪，这个远亲我从来没有见过面，我的妻子也只见过两次而已。为什么找到她，大概是亲戚里面只有我们夫妇是三宝弟子吧。
    顺便提醒一点，持诵经典的关键，在于每个字从心田里清晰流淌过去，而不在快慢，因此不要一味求快比快（当然，念熟了速度肯定自然会加快些）。后学的恩师仁波切，曾经对於有人一小时念10000、5000遍的六字大明咒提出批评，指出生产100个次品不如生产一个正品。
    还有个建议。我们念佛、诵经等修法完毕，回向一定不可简略马虎（例如以一句回向一切众生带过）。除了常念的总回向四句或八句外，建议进行重重的个别回向，包括自己现世的父母亲人，过去世的亲属、冤亲债主，乃至生活中、网上结缘的同修及其亲属等等。虽然“回向一切众生”包括了所有这些人，但是因我们的心量不够广大，其实难以真正遍及他们，因此还是适宜补上这重重的个别回向，由近及远。

    初学者：
    我已经皈依了，但还没有受戒。先说说世间的事吧，我这个人如果整天按部就班或无所事事倒也过得平静，真有点享清福的味道，但只要想做点什么事，哪怕是只想约朋友到茶馆喝喝茶这样的小事，也会被这样那样的原因搞得没法办成！而且记性也特别差，读书或学过的佛学经论、文章等和没读差不多。至于修法也差不多，想抽点时间专门念经或打坐念佛也会被诸多原因搞得没时间，如果有时间而我家里那个不信佛的人就必然在家，你如那样他必目光异样，因怕他说些不该说的话造业，所以也就不敢当着他的面做，只能在心里默念了，但杂念又多，念佛心难以相续，书上说佛号置于乱心、心不得不佛，我真是一点这种感觉都没有，可谓山穷水尽了，现在是希望各位善知识给我指“杏花村”来了。

    成军：
    致“初学者”善知识：举世尽向忙中老，谁人肯在死前修？
    对于您说的修法障碍，后学也身有同感。试胡说几句，供仁者参考。从表面上看这是诸多外缘的障碍，但是究其根源，其实还是我们的生死心不切，念死无常的心不切，为自己的懈怠找理由以取得心理平衡而已。
    后学这几句说的尽管难听，但是却是因自身这方面的失败教训太多了而发。
    因此，我觉得您现在需要做的，不在于如何改变外缘，而是如何使自己修行的心念坚固，如何使自己念死无常的心念时时在心中发起。这方面如何思维观修，祖师大德的开示很多，您可以依从善知识如法起修。《大圆满前行引导文》。对这方面叙述非常详细圆满，可供我们参考学习。
    后学自己做的也很不好，很惭愧。谨与仁者共勉。

    小孩：
    我的办法：小孩就只会小孩的笨办法，小孩一直觉得我们这几代人基本素质特别差，想想原因大约是从来没有受过启蒙熏陶。就想出个笨办法：背。
    先背简单的好背的，心经什么的。再背长一点的，金刚经、普贤行愿品之类，另外附带着背一些论语唐诗之类感兴趣的。小孩比较笨，心经念了一百五十多遍才会背，小孩已经背了几年了，算补小时侯的课，自己的感受是临事临境基本上圣贤之言能从心底冲出来，挺实用的。而且发现自己背书也越来越快，心能静下来一点了。

    sunshiner：
    我现在有个习惯，早晨必须读经书。只要是跟佛教有关的就可以，读的话就一天精神愉快，对谁都很好。如果不读，就很烦，跟谁都没好脾气。这种反应很明显的。我自己都奇怪。晚上读不读经书都没关系，主要是早晨得看。即使我读了1个小时，一句话也没记住，也没关系。一天对谁的态度都很好。念佛号不管用。您有什么好办法吗？

    成军：
    一点建议：如果时间许可，把读佛经固定成为早晨必修的功课。一次读的也未必要那么多，有两种方案：1）阅读学习，系统选些古德的论来读，学习教理；2）持诵，可以用约20－30分钟时间持诵《金刚经》和《普贤行愿品》，持之以恒，既能摄心，又能累积很大的福德。


关于念佛、诵经、忏悔灭罪

    洪川：
    念佛一声，灭某某多重罪，是否可以理解成令许多重罪报应不起现行等成就后再来还债？还是这个灭重罪是因念佛的助缘灭了许多烦恼习气的业障？或是两者皆有？

    zf：
    请进，关于念佛、诵经、忏悔等灭罪的原理，我是这样理解的。
    我等凡夫，因贪嗔痴，发身口意，造诸恶业。所谓业，是感果的能力。业要感果则必须有具有适当的缘。贪嗔痴等诸毒，统称烦恼。以烦恼为因所造的恶业，只有在烦恼为缘的情况下才能结果。“已作业不失”，以往所造恶业感果的能力不会消失，对这一点我们似乎是无能为力。但我们可以努力消除自心中的烦恼，不为恶业感果提供外缘。有因无缘，苦果不生。这样我等既可以从往世无量的恶业中解脱，又不违背因果规律。
    念佛一声，灭某某多重罪的原因，可能就在于念佛能灭我等心中诸多烦恼，从而使许多重罪报应不起现行。这一点我同意洪兄的看法。
    关于前世所犯重罪是否成就后需要继续还债，我的理解是，原则上，似乎不存在着一对一还债的机制，因为成就后，烦恼已经灭尽，苦果无从生起。如果修行的过程到此结束，对心存良知的人来说，心中总会有过意不去的感觉。因为由于我们的过失，曾给其他众生带来极大的痛苦，欠了别人的债，在债主找我们讨债的时候，我们却跳出“圈外”，而债主因能力不够，只能留在圈内。如果是这样，“解脱者”颇有种逍遥法外的味道，为仁者所不愿。如来在很多经典中将二乘行人称为“漏器”或“焦芽败种”，不知是否与此有关。
    还债的心理，可以成为发起菩萨行愿的助缘。对于已发菩提心的菩萨，他们将自己的一切都交给了众生，今后生生世世唯一目的就是以最有效的方法利益一切众生，使众生不但从轮回中解脱，而且究竟成就无上正觉。因此菩萨的广大行愿是还债心理的最高升华。
    愿我等念念不忘欠下众生的债，念念不忘还债，早日真正生起菩提心，早日开始实践菩萨的广大行愿。


年轻的佛弟子应该努力去背诵一两部佛经

    慧心通明：
    请教，诵经的功德和阅读经的功德一样吗？

    zf：
    在佛教的传统中，“诵经”是指于经文能背诵而不须依靠文本者。显然能诵经者对经文的熟悉程度一定会超过自己当初阅读经文时的水平。从这个角度看，诵经的功德要大于读经的功德。
    本人一直主张年轻的佛弟子应该努力去背诵一两部佛经，如《金刚经》和《普贤行愿品》。将经文印在自己的心中与留在书本上，对我们的作用有很大的差别。那些能背诵下来的经文，其中的某些片段在不经意时就会自动地浮现在我们脑海中，原来不理解的经意这时可能便会豁然开朗。
    经文是显文字相的佛，虔敬地诵经即是念法，也是念佛和念僧。
    例如《金刚经》中所说：“若是经典所在之处则为有佛，若尊重弟子。”因此，《金刚经》就是佛和僧。又，《金刚经》即是法，因为“一切诸佛及诸佛阿耨多罗三藐三菩提法皆从此经出”，可见，显密一切诸法皆被此一经摄尽。若在诵经的基础上进一步与经意相应，则行人便与三宝水乳交融——这就是最圆满的皈依。
    皈依圆满之时，也就是无上菩提成就之日。

    一心:
    谁能告诉我，“我”究竟是“啥”，是谁在“轮回”，轮回的主体是啥？

    zf:

    罗睺罗尊者之《佛陀的教诲》对此有详细的说明。

    慧心通明：
    我已经读了一遍《金刚经》了啊。感觉太奥妙了。这部经简直就是谜语。有无限魅力。我在被吸引。
    我争取多抽时间。力求达到赵叔的要求，熟读成诵。另外我还有想法。我想不去看，或者少去看解读金刚经的文章。我想走一条，书读百遍其意自现的道路，不知道这算不算狂妄？

    zf：
    随喜！祝早日成功。

    一、这条路有人提倡、有人在走。历史上好像也有人成功。
    二、金刚经是值得千万遍诵读的。
    三、提醒仁兄一句：当您认为金刚经的真义已经在自己心中显现时，您如何验证这一“显现”是否符合佛意？


法华经怎么读？

    飞羽：
    请问妙法莲华经的中心思想是什么？
    今天终于把法华经读了第一遍了。可读到最后也不太明白佛祖在这部经里的中心要旨是什么。我一直就看到佛说这部经的价值宝贵，以及种种功德，护持等等。当然，经中讲述的各位菩萨的功德行止也是很重要的，可毕竟不是这部经的中心内容吧。我一直等啊，等啊，想等到佛祖告诉舍利弗这个第一希有难解的妙法是什么，可到最后到了普贤菩萨劝发品还是在讲述读颂受持的功德。
    是否法华经的中心思想就是那个三界火宅的比喻？说明佛法只有一乘，种种示现与说法都是应机方便。但总之那一乘的妙法终究还是没有说明啊。是否佛祖觉得只需要告诉我们有就是了，具体的东西只有成佛之后才能究竟吗？

    二麻子：
    您读到法华经了吗？
    就题材的习惯来讲，法华经本文好像没出现，通篇都是在介绍法华经如何好，更象法华经的Introduction。您注意到这点了吗？
    如果注意到了，您能告诉我，这是为什么，是什么意思吗？

    法华经的INTRODUCTION问题……
    对法华要义说得最简单明确的是六祖。他老人家一句话就说白了，此经是讲“依因缘成佛”。
    我们都知道，成佛也就是圆满实证空性。空性是所谓真谛，因缘是俗谛。真俗本来不二的。
    然而，法华经里，佛多说因缘，直说般若空性的地方不多，这真俗二谛是怎么不二的？佛把这个不二，巧妙地放在题材格式上。结果就是我们看不到“法华经”本身，只能读到法华经的“introduction”。
    整个一篇法华经文字，全是在介绍法华经如何好。请千万注意，这就是法华经，离了法华的introduction，不再别有法华经，就如同离了因缘法，不再别有空性！介绍就是本文，因缘就是性空。佛法也同样，我们看不到佛法本身，能看到的只是对佛法的介绍，包括一切经论。但佛法也就在这了，并非别有：佛无藏覆，人有未解。如此如此。
    南无释迦文佛。南无多宝如来。南无一切佛。


抄经“发家史”

    聋猫：
    大般涅槃经云：“受持读诵书写解说十二部经。见有受持读诵书写解说之者。心生恭敬兼以衣食房舍卧具病药花香。而供养之赞叹尊重。所至到处称说其善不说其短。供养三宝敬信方等大涅槃经。如来常恒无有变易。一切众生悉有佛性。是人能令地狱重报现世轻受。”
    只抄写一部如何？另请问zf或各位善知识一个问题。一、十二部是哪十二部？二、小弟正在抄写《地藏本愿经》，不过抄的很慢。抄经需要注意什么？

    zf：
    关于抄经。
    “十二部是哪十二部？”
    佛教词典的回答：
【十二部经】
    （术语）一切经分为十二种类之名。据智度论三十三之说，一、修多罗Sutra，此云契经。经典中直说法义之长行文也。契经者，犹言契于理契于机之经典。二、祇夜Geya，译作应颂，又作重颂。应于前长行之文重宣其义者，即颂也。凡定字句之文体，谓为颂。三、伽陀Gatha，译作讽颂又作孤起颂。不依长行，直作偈颂之句者。如法句经是也。四、尼陀那Nidana，此译因缘。经中说见佛闻法因缘，及佛说法教化因缘之处。如诸经之序品，即因缘经也。五、伊帝目多Itivrtaka，此译本事。佛说弟子过去世因缘之经文。如法华经中药王菩萨本事品是也。六、阇多伽Jataka，此译本生。佛说自身过去世因缘之经文也。七、阿浮达摩Adbhuta－dharma，新云阿毗达磨。此译未曾有。记佛现种种神力不思议事之经文也。八、阿波陀那Avadana，此译譬喻。经中说譬喻之处也。九、优婆提舍Upadesa，此译论义。以法理论义问答之经文也。十、优陀那Udana，此译自说。无问者，佛自说之经文。如阿弥陀经是也。十一、毗佛略Vaipulya，此译方广。说方正广大之真理之经文也。十二、和伽罗Vyakarana，译授记。于菩萨授成佛之记之经文也。此十二部中修多罗与祇夜及伽陀三者，为经文上之体裁。余九部从其经文所载之别事而立名。

    可见十二部经典是佛经的总称。
    如果将涅槃经上述之“受持读诵书写解说十二部经”理解为行人应一部接一部地受持读诵书写解说所有佛经，则这种修持方式对绝大多数修行者来说便几乎不可能。如来慈悲，不会给我们指一条根本行不通的路。因此在下猜测，上述经文的含义可能是“受持读诵书写解说十二部经中的某些经典”。

    另外，在《一切如来心秘密全身舍利宝箧印陀罗尼经》中，如来开示：
“佛言谛听汝金刚手。后世若有信男信女及复我等四部弟子。发心书写此一经典。即准书写九十九百千万俱胝如来所说一切经典……若人读诵此一卷经。即为读诵过去现在未来诸佛所说经典。”
    九年前，当本人首次读到上述开示时，便恭恭敬敬地将《宝箧印陀罗尼经》抄写了一遍，心中极为兴奋，因为自己已经获得了书写九十九百千万俱胝如来所说一切经典的功德！书写一部佛经的功德都无量无边，何况书写了全部，这其中自然包括《华严经》、《法华经》、《大般若经》、《大涅槃经》、《首楞严经》、《大日经》、《金刚顶经》……以及无上瑜伽部“大手印”“大圆满”的所有经典。仅凭书写《宝箧印陀罗尼经》此一事，在下便自认是“佛法巨富”，因已书写所有佛经故！若人不敢因此作“佛法巨富”想，实际上是不信如来所言！
    不知诸兄听了在下的“发家史”有动心的吗？

    “小弟正在抄写《地藏本愿经》，不过抄的很慢。抄经需要注意什么。”
    自然是应该认真了。
    佛法的修持不外是在身口意三方面用功。抄经时手书写佛经，而佛经是文字相的如来，身体方面自然积累了极大的功德；抄经时口中自然随文发音，积累了极大的口德；身口之行为无不以心为帅，同时心中思维经意，心意方面自然积累了极大的功德。正因为书写经典有上述功德，此修行方法才广为如来所提倡。
    当然，古时书写经典还有助于经典的保存和流通，不过这项功能在印刷技术发达的今天似乎被冲淡。

    木樨香：
    动心了！您举得一串经名，后学都没仔细读过，但很喜欢它们的名字。

    zf：
    木兄，动心以后应该……动手。听听如来怎么说，看你还敢不敢偷懒！
    众生佛性不名为佛。以诸功德因缘和合。得见佛性然后得佛。
    善男子。以是义故。我说二因。正因缘因。正因者名为佛性。缘因者发菩提心。以二因缘得阿耨多罗三藐三菩提。
    善男子。复有五法退菩提心。何等为五。一者乐在外道出家。二者不修大慈之心。三者好求法师过恶。四者常乐处在生死。五者不喜受持读诵书写解说十二部经。是名五法退菩提心。
    有那么多众生等着你去度，你竟忍心慢慢腾腾的！


读经功德无量无边

    Ed：
    看来，我们都是大富或即将是“暴发户”。
    赵叔：“若人不敢因此作‘佛法巨富’想，实际上是不信如来所言！”此话妙妙！根器如何，就看一信心！信心清净，则生实相。
    在下依此类推，读写《普贤行愿品》也一定和《宝箧印陀罗尼经》有同样的大功德。
    又《六字大明咒》总摄一切经的功德，故念此一咒功德等同念所有的经。一句佛号亦当如是。如此想来，吾人何等荣幸！四十八愿中第十八愿文：“闻我名号，至心信乐，乃至十念，即生我国”，同样可信！愚揣这种“至心信乐”和赵叔当时作“佛法巨富”的欢喜应该是一样的吧？是故，若我等念经咒佛号都有如此信心和庆幸、欢喜、感恩和报恩心，我等都是“佛法巨富”！
    若无此信，只好慢慢从经论一点一点积累信解或参究参究什么什么的。不知赵叔以为然否？

    zf：
    完全同意Ed兄所说。另外，我等暴发户在“偷着乐”的同时，也应注意检点自己的言行，尽量避免暴发户们常有的种种让人瞧不起的弱点。
    如来在提醒我们作巨富想的同时，告诫我们，应：
修习身戒心慧。亲近善友。修习正见。受持读诵书写解说十二部经。见有受持读诵书写解说之者。心生恭敬。兼以衣食房舍卧具病药花香。而供养之。赞叹尊重。所至到处称说其善不说其短。供养三宝敬信方等大涅槃经如来常恒无有变易一切众生悉有佛性。
    若能如是，则我等暴发户不但具有万贯家财，同时还兼有学者的知识、贵族的气质、绅士的风度和仁者的心肠。
    暴发户众兄弟们，一起努力吧！

    智诚：
    在下每天早上持诵无量寿经，晚上持诵金刚经。可否同时持诵两部经典？另外因时间关系，每次只能持诵几个小节，请问这样是否可以？

    zf：
    广读大乘经典是往生的助缘，这是佛说的。经中常说，读一四句偈功德都无量无边，更何况是几个小节了！

    慧心通明：
    《金刚经》适合初学吗？从《金刚经》入手修习佛法可行吗？
    另外，如何修习金刚经？仅仅是诵读吗？每日诵读？还是有其他的方法？
    在修习《金刚经》的过程中，能获得证悟吗？

    zf：
    适合。

    “从《金刚经》入手修习佛法可行吗？”
    ──可行。
    一切佛及佛法皆从此经出。

    “另外，如何修习金刚经？仅仅是诵读吗？每日诵读？还是有其他的方法？”
    ──入手的修习方法是诵读、书写。
    如染香人身有香气。

    “在修习《金刚经》的过程中，能获得证悟吗？”
    ──在读诵、书写的过程中，行人便积累了无量福智资粮（与密乘的加行相似）。将来机缘成熟，在善知识的指导下，智慧开显，证悟实相。
    若于金刚经法义完全相应，成佛足矣！


关于菩提道次第教授

    慧心通明：
    佛法最具代表性的经典是哪部？心经？金刚经？佛法经典都有哪些代表作？它们之间的关系是怎样的？读经应该按什么次第来读？

    zf：
    教材是现成的──菩提道次第教授。

    齐愍：
    冒昧向准备学广论的朋友做一些建议，广论系以普贤行愿（文中作七支行愿，内容是一致的）来总摄三士要道的修学。如果您打算开始菩提道次地广论这一系统的修学，那么在广泛的从三士道思维之前，建议您先学习华严经的普贤行愿品，将他熟读，了然于心，依此作愿；自己仅仅在思维诸苦无常时生起趋向安乐或者寂灭的态度，从广论的这一段看，应该并非正修习，当您如广论中所说的：“思惟……唯苦道理。”之时，就正应是修自他相换，如实学习发起菩提心的合适时机。如广论中云：
    “故于下士之时，思惟自于诸恶趣中，受苦道理，及于中士之时，思惟善趣，无寂静乐，唯苦道理。次于亲属诸有情所，比度自心，而善修习，即是发生慈悲之因，菩提之心从此发生。故修共同中下心者，即是生起真菩提心所有方便，非是引导令趣余途。
    多门励力，集福净罪，如其所应，即菩提心之前行，修治相续之方便，七支行愿及皈依等。故应了知此等即是发心方便。此中下中法类，即是发无上菩提心支分之道理，尊重亦当善为晓喻，弟子于此应获定解。每次修时当念此义，修菩提心发生支分，极应爱重，若不尔者，则此诸道与上士道别别无关。乃至未至实上士道，于菩提心未得定解，而成此心发生障碍，或于此间失大利义，故于此事应殷重修。
    如是修习中下之道及善修习，如士时所说道已，于相续中，随力令生真菩提心。次为此心极坚固故，应以不共皈依为先而受愿轨，由愿仪轨正受持已，于诸学处应励力学。次应多修欲学之心，谓欲学习六度四摄菩萨行等。若由至心起欲学已，定受行心清净律仪。次应舍命莫令根本罪犯染着，余中下缠及诸恶作，亦应励力莫令有染，设若有犯，亦应由于如所宣说，出犯门中，善为净治。次应总学六到彼岸，特为令心于善所缘，堪能随欲而安住故。应善学习止体静虑，道炬论说，为发通故，修奢摩他者，仅是一例，觉窝于余处亦说为发毗钵舍那，故为生观应修止。”


莫等闲，白了少年头

    无一：
    大家好：
我是一名很想了解佛经的无知人，但苦于佛学的博大精深，我不知道从何学起，从什么地方看起，以及在什么地方和大家讨论。希望大家帮帮我，还想请问一下，何为大慈大悲，为何大慈大悲？

    zf：
    无一兄请进

    “我是一名很想了解佛经的无知人，”
    ──“无知”如同干草，“很想了解”如同一把火。
    “但苦于佛学的博大精深，我不知道从何学起，从什么地方看起”
    ──你到这里看看：中华佛典宝库·藏外佛典·佛法入门

    “以及在什么地方和大家讨论。”
    ──这里就可以。

    “希望大家帮帮我，”
    ──帮助别人是这里的绝大多数人希望形成的新的本能。

    “还想请问一下，何为大慈大悲，”
    ──【大慈大悲】

    即佛菩萨济度一切众生的大慈悲心。又称大慈悲。慈者，与乐之义；悲者，拔苦之义。佛菩萨住于利他之心，拔除众生无边之苦而予以喜乐，尤以佛更以无缘之大悲心度化一切众生，故大慈大悲一般多用于称佛的慈悲。《观无量寿经》云（大正　12·343c）：“佛心者，大慈悲是。以无缘慈，摄诸众生。”

    《大智度论》卷二十七云（大正25·256b）：“大慈，与一切众生乐；大悲，拔一切众生苦。大慈，以喜乐因缘与众生；大悲，以离苦因缘与众生。（中略）复次诸佛心中慈悲名为大，余人心中名为小。问曰：若尔者，何以言菩萨行大慈大悲？答曰：菩萨大慈者，于佛为小，于二乘为大，此是假名为大，佛大慈大悲真实最大。”
    ［参考资料］　《佛地论》卷五；欧阳渐《支那内学院院训释》〈释悲训〉。
    FROM：【中华佛教百科全书】

    “为何大慈大悲？”
    ──如果你的家人掉到河里呼救，你该怎么办？

    顺便向您推荐使用“电子佛学辞典”。如果你会使用它，就如同有一位非常有学问的老师始终坐在你身旁。

    无一：
    谢谢你，有一些语言我还不能够很快的消化它。你讲的大慈大悲我能够明白一点了，不像开始就大慈大悲四个字。非常的感谢你，的确回头是岸。但是，回复上有讲：‘如是我的家人掉在河里了，我该怎么办？’，我想，又何谓家人，这里是否可讲色空为一？只要是生命，都该去救。

    zf：
    “但是，回复上有讲：如是我的家人掉在河里了，我该怎么办”我想，又何谓家人，这里是否可讲色空为一？只要是生命，都该去救。”
    ──菩萨视六道中轮回的众生就如我们视落入河中的亲人一样。
    “色空为一”是在说某种智慧。如果在利益众生的同时又不失智慧的心态，这当然最为理想。

    无一：
    无一想请教一下zf兄长：
刚在上面看见一位朋友讲：他求得大悲咒水，现在他病有好转。就这个问题，无一有一些想法，但又不知对与不对，故请教一下zf兄长。
    无一想，水就是水，不能治病。佛陀的无边佛法是让世人自救。其实，生老病死是自然的现象，又何必太执着，该生就生，该死就死。如果有了病，想求一碗大悲咒水，就好了，而不是自己注意自己的身体，自己修悟自己。我想，这样是不对的。无一这样理解，佛陀的无边智慧，是我们的一个榜样，是我们做人的准则，是我们的目标和方向。我们让佛陀的无边佛法，让我们心安，心平，心清，心静，心旷神怡。无一今年２３岁，以前一直以为拜佛是迷信，不以为然，直到前几天由朋友介绍一本心经与智慧一书，才恍然大悟，佛学之博大，之精深。
    又因自己年少，看法和想法尚未成熟。故特别想和zf兄长沟通，希望zf兄长指点对错。

    zf：
    无一兄请进
    “无一想，水就是水，不能治病。佛陀的无边佛法是让世人自救。其实，生老病死是自然的现象，又何必太执着，该生就生，该死就死。如果有了病，想求一碗大悲咒水，就好了，而不是自己注意自己的身体，自己修悟自己。我想，这样是不对的。”
    ──《大悲陀罗尼经》中言：
“若诸人天诵持此陀罗尼者。其人若在江河大海中沐浴。其中众生得此人浴身之水沾着其身。一切恶业重罪悉皆消灭。即得转生他方净土。莲华化生。不受胎身湿卵之身。何况受持读诵者。若诵持者行于道路。大风时来吹此人身毛发衣服。余风下过诸类众生。得其人飘身风吹着身者。一切重罪恶业并皆灭尽。更不受三恶道报。常生佛前。当知受持者福德果报不可思议。”
    佛力不可思议，大悲咒水的作用不应怀疑。
    另外，求佛力护持与我们自己努力并不矛盾。
    “无一这样理解，佛陀的无边智慧，是我们的一个榜样，是我们做人的准则，是我们的目标和方向。我们让佛陀的无边佛法，让我们心安，心平，心清，心静，心旷神怡。”
    ──同意您的看法。
    从根本上说，学佛是按照佛所说的去实践。但同时，我们也应清楚，我们是生活在如来的功德之中，即使我们不知不觉，如来的功德也在我们身心发挥着作用，护持着我们。如同瞎子虽然不知道有阳光，但他的食物、衣物等无一不是来自太阳的“恩赐”。
    “无一今年２３岁，……”
    ──年轻人，努力吧。
    莫等闲，白了少年头。

    mfe6000：
    请问ZF师兄，本尊是只能有一位，还是可以多位？

    zf：
    关于“本尊”，祈竹仁波切有如下开示：
“所谓‘本尊’，译自梵文Yidam这个名词，意思是我们终生专注修证的一位佛的化身。这尊佛的法门就是我们终生不辍，永不放弃的主修法门。‘本尊’并非西藏佛教独有的概念，你们汉人大多都以弥陀及观音为‘本尊’，只是你们通常并不以这个名词称之而已，其概念是一样的。修持某个本尊，不代表你不尊敬其他佛众。本尊就是你专修的法门，以他来代表一切三宝及佛众等。”
    由于本尊是一切三宝的代表，因此行人有一位本尊就足矣。
    至于行人要修本尊之外佛菩萨的法门时该如何观修，将来您的上师会告诉您。

    无一：
    谢谢zf兄长！
    （求佛力护持与我们自己努力并不矛盾，佛力不可思议，大悲咒水的作用不应怀疑）
    谢谢zf兄长，原来一直认为是自己努力，其实佛力的护持却是自己努力的动力，佛力不可思议，大悲咒水的确不应怀疑，怀疑大悲咒水的作用好比降低自己努力的动力。如同国家的政策，企业的文化。只是相比之下佛法已经超越了他们千倍万倍，而且完美无缺，而又因为他的绝对正确，成了真理，到达了一个颠峰，佛陀就是宇宙中最有智慧的人，成为万世楷模！无一这样理解，不知对与不对？请兄长教诲！
    （瞎子虽然不知道有阳光，但他的食物、衣物等无一不是来自太阳的“恩赐”）
    听兄长说到这里，无一的思绪比较乱，只感觉自己就像瞎子一样，不知所措！请兄长指点！

    zf：
    无兄请进
    “只是相比之下佛法已经超越了他们千倍万倍，而且完美无缺，而又因为他的绝对正确，成了真理，到达了一个颠峰，佛陀就是宇宙中最有智慧的人，成为万世楷模！无一这样理解，不知对与不对？请兄长教诲！”
    ──如来的觉悟是无上的，是究竟的，因此说其“绝对正确”也可理解（只是这种说法不太常见）。
    但有一点要注意：如来是应机说法，当以何身而度即以何身而度。因此如将某些应机说法绝对化便会出问题。例如，佛对适合以声闻乘而度者说声闻乘教法，但如果将声闻乘教法绝对化去否定大乘便是与如来本怀（如法华经所开示）相违背了。
    “（瞎子虽然不知道有阳光，但他的食物、衣物等无一不是来自太阳的“恩赐”）
    听兄长说到这里，无一的思绪比较乱，只感觉自己就像瞎子一样，不知所措！请兄长指点！”
    ──以下是华严经中对如来功德的宣说，不可思议，现在一时无法理解也不要紧（在下也不理解。），放在心上，相信待将来因缘成熟时自会明了。
    复次佛子。譬如日出。生盲众生。无眼根故。未曾得见。虽未曾见。然为日光之所饶益。何以故。因此得知昼夜时节。受用种种衣服饮食。令身调适。离众患故。如来智日。亦复如是。无信无解。毁戒毁见。邪命自活。生盲之类。无信眼故。不见诸佛。智慧日轮。虽不见佛智慧日轮。亦为智日之所饶益。何以故。以佛威力。令彼众生。所有身苦。及诸烦恼。未来苦因。皆消灭故。佛子。如来有光明。名积集一切功德。有光明名普照一切。有光明。名清净自在照。有光明。名出大妙音。有光明。名普解一切语言法令他欢喜。有光明。名示现永断一切疑自在境界。有光明。名无住智自在普照。有光明。名永断一切戏论自在智。有光明。名随所应出妙音声。有光明。名出清净自在音庄严国土成熟众生。佛子如来一一毛孔。放如是等千种光明。五百光明。普照下方。五百光明。普照上方种种刹中。种种佛所。诸菩萨众。其菩萨等。见此光明。一时皆得如来境界。十头十眼。十耳十鼻。十舌十身。十手十足。十地十智。皆悉清净。彼诸菩萨。先所成就。诸处诸地。见彼光明。转更清净。一切善根。皆悉成熟。趣一切智。住二乘者。灭一切垢。其余一分。生盲众生。身既快乐。心亦清净。柔软调伏。堪修念智。地狱饿鬼。畜生诸趣。所有众生。皆得快乐。解脱众苦。命终皆生天上人间。佛子。彼诸众生不觉不知。以何因缘。以何神力。而来生此。彼生盲者。作如是念。我是梵天。我是梵化。是时如来。住普自在三昧。出六十种妙音。而告之言。汝等。非是梵天。亦非梵化。亦非帝释护世所作。皆是如来。威神之力。彼诸众生。闻是语已。以佛神力。皆知宿命。生大欢喜。心欢喜故。自然而出优昙华云。香云音乐云。衣云盖云。幢云幡云。末香云宝云。师子幢半月楼阁云。歌咏赞叹云。种种庄严云。皆以尊重心。供养如来。何以故。此诸众生。得净眼故。如来与彼。授阿耨多罗三藐三菩提记。佛子。如来智日。如是利益生盲众生。令得善根。具足成熟。佛子。是为如来身第五相。


成长的烦恼

    慧心通明：
    我学佛的新困惑——越来越烦恼了：（（最初接触佛法，我在不信的基础上，吸收了一些佛的道理，感到受益很多。可是，最近随着学佛的深入，逐渐开始相信原来那些原来不信的果报之类的，反而越来越烦恼了。我感到现在心灵不自由了，有很明显的心灵枷锁的感觉。谨小慎微的，甚至有一种迷信的感觉。

    zf：
    成长的烦恼。
    不成熟的心灵＋过高的要求＝焦虑
    建议：
将要求放到自己不感到很为难的程度。
    琴弦过松过紧都发不出美妙的声音。

    透明娃娃：
    请问，佛是什么？他可以让我得到些什么？我要如何去降服自己的欲望之心？为什么我一闭上眼睛就会有很多事情出现在眼前，无法定下心来？我要如何做到心如明镜不染尘呢？

    zf：
    欢迎小娃娃！

    “佛是什么？”
    ──佛是一个完美的老师。

    “他可以让我得到些什么？”
    ──如果您愿意跟这个完美的老师学，将来您也可以成为一个完美的老师，去指导学生。
    （当然学生如果不想学，老师也无能为力。）

    “我要如何去降服自己的欲望之心？”
    ──先去了解“欲望之心”的害处。

    “为什么我一闭上眼睛就会有很多事情出现在眼前，无法定下心来？”
    ──我和您现在的状态差不多。
    “出现事情”不要紧，重要的是应争取出现对自己和别人都有利益的事情。

    “我要如何做到心如明镜不染尘呢？”
    ──这恐怕要慢慢来。（不好意思，我现在也做不到不染尘。）
    常到这里来与大家交流。
    多读点书。
    “佛典宝库”网站有很多好书。

    吉祥如意！


致慧心通明兄

    致慧心通明兄

    zf

    慧兄，见兄在下面的帖子中提到了在下，承蒙厚爱，受之有愧。
    以下是本人的一点看法，供参考。
    “我接触佛法仅仅一个月，……”（编按：本篇“”引号中为慧心通明网友的贴文内容。）
    ──我看不像。我猜您与佛法也是多生多世的因缘了。“慧心通明”这四个字，看了就让人欢喜！

    “我的学佛目的：寻求佛法的智慧，解我人生之烦恼，实现生命的圆满。”
    ──难得，难得！我来翻译一下上面这三句话：
寻求佛法的智慧──法门无量誓愿学
    解我人生之烦恼──烦恼无尽誓愿断
    实现生命的圆满──佛道无上誓愿成
    建议慧兄再加上一个：
愿作众生之牛马──众生无边誓愿度
    这就成了著名的“四弘誓愿”──所有菩萨学习佛法的根本目的和动力。
    不知仁兄是否接受在下的建议。

    “能够用佛法的智慧来指导我的人生，使我更加热爱生命和人生，活出生命的色彩，找到当下的幸福。爱自己，爱他人，爱这个世界。大家慈悲为怀，共享生命共享快乐共享这个美好的世界。”
    ──仁兄颇有当下转秽土成净土的豪情，赞叹！

    “我的学佛的思路或原则：
    一、我想了解把握佛学理论的基本的框架体系。与之对话，得出自己的结论。我的狮口计划（有些自不量力啊）是：读基础理论，了解佛学发展史，读大德传记，读核心经典，读今人的作品，追踪自己关心的专题。”
    ──好！以出离心、菩提心、清净见为核心的“道次第”一定可以满足慧兄的需要。

    “二、从基础、从精华、从疑问入手。逐渐深入拓展，因自己的时间精力能力所限，不求精深广博。但求对自己有用。基础即佛学的基础知识，精华即公认的佛学核心经典，疑问即指自己的个性化的需要和满足。”
    ──依在下之见，佛陀开示的教法全都是精华，只是有些更对我们的“症状”（我猜对症之药就是仁兄的“精华”意）。
    建议仁兄先在“三主要道”这一普遍适用的原则上下功夫。
    在普遍的基础上再来满足“个性化的需要”。

    “三、力求把握精神实质，写意般的理解佛法，保持灵动和不拘。不把自己淹没于浩瀚的经文里，不纠缠在细节里，不做无谓的输赢争论。只有从根本上把握了精神实质，才能超越于具体的实相，才能灵动不拘，才能不僵化和教条，才能感受佛法活的灵魂。”
    ──好。只不过“得意忘形”说来容易作来难。
    另外，“超越于具体的实相”一句有些费解。

    “四、采取面面观、平等的质疑对话和开放的态度。不放弃对世间其他学问的追求，在不断的知识游历中，在不同的观点中，从不同的角度认识佛法。不对自己不懂或者不了解的东西屈膝，在平等对话中、在质疑中、在批判中获得深思、智慧甚至是信仰。永远使自己保持一种开放的心态和开阔的视野。尊重自己尊重他人，尊重任何起点和水平、尊重任何人的话语权。”
    ──认识到自己的局限，保持开放的心态，这一点非常重要。
    从人格上，学生和老师是平等的，但从知识上，学生和老师却是有差距的。如何合理地把握这种平等和差距，是需要智慧的。

    “五、把佛法与自我的现代生活相融。把自己对佛法获得的有限的启悟应用到自己的生活中（也算作实修？），”
    ──能用佛法改变自己的心灵和生活，当然是实修！

    “对佛法进行生活化的理解、现代文的表述。佛法融入了生活方能显示其魅力，”
    ──是呀。如果修习佛法者都能在生活中真实流露出对贪嗔痴的远离，则便会有更多的人为佛法的魅力所吸引。

    “只有用自己的语言重新表述的理解才是自己真实的启悟。佛法总需要被理解的，而且是被现代的人、个体的人理解，佛法被理解是佛法的生命力所在。佛法也需要被践行的，而且，这种践行可以基于对佛法的各种水准的理解，如我一般的浅见基础上去践行依旧受益匪浅。”
    ──赞叹您的信念。
    佛法一定会被现代人理解的。因为从本质上说，现代人遇到的苦和过去人遇到的苦没什么两样，而佛法是驱苦的妙药。

    “我的学佛方法
    一、基于问题的学习。质疑批判的态度是我学习佛法的利器。在质疑中，在寻求解答的过程中，尤其要利用网络，利用搜索引擎，通过搜索和网页的阅读，寻找问题的答案。另外，要听取多方面的见解，尤其是对立的观点，在对立的观点中，更容易在面面观中认识真相。”
    ──给仁兄提个醒：在以质疑批判的态度对待别人的同时，别忘了以质疑批判的态度对待自己。

    “二、基于体验的学习。有时候自己的局限决定了自己确实有不知道的而他人知道的真相，因此有时候需要去体验。在体验中获取真知。在体验中验证一些道理。”
    ──最根本的一种体验仁兄一定不缺少，那就是──苦。
    因为苦，我们应寻找苦的原因和消灭苦的方法。

    “三、在对话中学习。这里我主要是指与善知识与佛友与佛外友的对话。对话是互动是激发，这里有无尽的教益。我亲近善知识，但是不迷信善知识。我相信所谓有知有证的人，但是不会把自己完全交托给他们。我相信网络时代与知识被少数人垄断的时代的学习方式有根本的不同，即使在佛法的学习和修行上，我不会屈膝于神秘主义或者玄学化的故弄玄虚的。我将依止于我的个性化的经历我的知识经历我的思悟和学习能力敲开佛学的大门。”
    ──对于真心学佛者，网络确实为我们提供了古人难以想象的方便。让我们善加利用吧。


自知之明就是勇气

    lele：
    我也曾努力刻苦的修行过，也曾发过大悲心，也曾在一周内把大悲咒倒背如流！

    zf：
    “已做业不失”，以往的修行、所发的悲心、诵咒等的功德都完好地保存在兄的心中，只要兄对三宝的信心不退，这些功德都会成为兄进一步修行的资量。依在下浅见，修行路上，兄不是个穷人。

    lele：
    我深知自己现在中毒很深，也明白我是自作自受，

    zf：
    知中毒乃自作自受，这就是勇气。骨子里兄是勇者。

    lele：
    这是一个大漩涡，可是我已经无力自拔了，我在一点点地烧毁我自己的功德，一步一步的后退，不，应该是直线下降！我不知道我在做些什么！

    zf： 　　暂时的消沉也是修行者常有的现象。（那位“笑傲江湖”的令狐大侠不也常借酒消愁吗！）

    lele：
    我知道前世曾做了不少孽，因为今生的坎坷就已经证明。记得曾暗自发誓努力修行，来抵消以前的过错，报答佛恩。我努力地做了，但做得不好，不过却有很大的感应，对于佛菩萨的怜悯，无数生生世世我都无法回报，

    zf：
    错误归自己，深信因果，不忘佛恩而思回报，深具仁、智二德，令人敬佩。

    lele：
    痛苦与矛盾萦绕着我，我看不透迷茫的世俗，走不出心中的阴影。曾经以为自己看破了红尘，现在想想我算个什么东西啊，离那境界还远着呢，当年的气魄都哪去了？我怎么找不到了？

    zf：
    世俗红尘，如梦幻泡影。金刚经之四句偈还望老兄常记心间。

    lele：
    谁能救我？

    zf：
    当然是兄自己救自己。但老师是佛，教材是法，助教是僧，还有论坛上的同学。

    lele：
    我不想听那些玄奥的禅机，因为我没心情去理解，也没那个悟性了！

    zf：
    我看兄悟性很好，深信因果一条就是大智慧。

    lele：
    期待弟兄们拉我一把，

    zf：
    兄弟们已经伸出了多只手。

    lele：
    我算完了。

    zf：
    酒后醉话。

    lele：
    我已经沉沦了，……，沉迷色情，……

    zf：
    先从这点改起。如来开示，对治贪欲（主要指淫欲）最有效的方法是修不净观。正好成军兄将有关的经典贴在那里（我看这是个很好的缘起）。只要兄有信心，加之正确的方法，将淫欲控制在正常程度，不致干扰通常的修行，应该不是难事。


虽然无知最能被人原谅……

    虽然无知最能被人原谅……

    二麻子

    因无知而犯错是最能被人原谅的，但也是最冤枉最没道理的，因为不是很难避免。
    当佛法说到我们这些凡夫耳朵里的时候，其义理、究竟见以及具体实修方法的表述是相当不同的。要看义理清楚，格鲁教法是极好的例子。要看见地高明，华严是例子了。虽然说义理与究竟见不二，毕竟也非一，所以，见与义理在表述上的区别是大家都看得见的。
    除了对上上根人以外，具体实修方法的表述与上述见、义理的差别就更大了。把一个东西看错了地方，不免出误差。上面古慈兄贴的，是祖师讲的实修方法。古兄虽然没说明白，某兄也是没仔细看就跟上胡说了。
    嘿嘿。发菩提心是各宗都提倡的，密教里七支修法与自他相换是大家都听说过的。除此外，某兄还有什么具体修法吗？或者说，世界上只有这两种修法了？
    嘿嘿，被珍宝绊到脚而不识也就罢了，这街骂的可是有点……嘿嘿，麻子也只能嘿嘿了。
    嘿嘿，您老兄还是多想想。您对挣钱吃饭也没疑义，但对量子力学就不一定没有疑义。你这里的有疑义没疑义能说明什么呢？
    说你句白话，我猜你也没机会听到前贤给你讲实修的要诀。你听到的还是思维法义。祖师不会在乎什么冒犯。担因果的是你自己。


其实真正的利他心不难判别

    其实真正的利他心不难判别

    二麻子

    “书里也多说某人是某菩萨再来，令人心向往之……我现在就是大菩萨再来，心理上该是多么的优越。”
    ──这刀尖锐而且深刻……
    对相当一部分人来说，蝉姐儿这刀实在有点深刻。看看有些邪师为什么越压越硬？就是为了心底下这点自我安慰。他们很多在世间法上混不顺利，就靠这点来安慰自己。连这个都放弃就什么也没了，怎么能放弃？
    另一方面看看成就禅师们“东家作牛西家作马”的勇气，看看声闻圣人长揖世间不受后有的彻底放下，我们真应该知道，没有点真的出离心利他心做底子，我们自称学大乘佛法，到底学的是什么还真需要检点检点呢。
    如果不是很高的标准，其实真正的利他心不难判别……只要看看对自己利益有所损害的利他行为，还肯不肯做，也就大概判断出来了。


烦恼障的根本是所知障

    wzl2001：
    坛经中六祖问：既然担心生死，为什么不去证取无生无灭的大法，去除烦恼呢？一位僧回答说：大道本来就是无生无灭的。万物也本是无迟速可言的。慧能赞扬了他的修学。我想请教的是，我有生死的烦恼障，看不破，请问该如何看破呢？真的有不生不灭的大法吗？是什么？经文的含义究竟是什么？谁能帮我透彻的解答呢？渡我脱离烦恼的海洋。不胜感激！！！

    zf：
    同辈的忠告

    “我想请教的是，我有生死的烦恼障，看不破，请问该如何看破呢？”
    ──烦恼障的根本是所知障──我、法二执。

    “真的有不生不灭的大法吗？”
    ──有。

    “是什么？”
    ──这个“大法”也叫无为法，空性或真如。

    “经文的含义究竟是什么？”
    ──“大道本来就是无生无灭的”──诸法从缘起，缘起无自性。生者是缘生，灭者是缘灭。缘生法无生，缘灭法无灭。

    “万物也本是无迟速可言的。”
    ──缘起法如幻，迟速亦如幻，诸法实相中，无速亦无缓。

    “谁能帮我透彻的解答呢？渡我脱离烦恼的海洋。”
    ──除佛三宝外，何者可皈依？


度生

    无名：
    在我的认识当中，超度好像是一种利他的好事情，可以使被超度者往生善处，但我头脑中还多多少少有点疑问。我想佛菩萨超度人不是要比教化人方便的多吗？应该是一种更好的度人方式啊？

    二麻子：
    嘻嘻。也容易理解……菩萨给人，天人说法，引导他们走向解脱，叫度生。给死人（中阴身），鬼说法，引导他们解脱，叫超（级）度（生）。除了说法对象不同以外，本质没有差别。

    无名：
    那么您这样说就很明白了，结论是：超度不是万能的。很多好的超度结果只能是一种比较巧的因缘和合。

    二麻子：
    XX决不是万能的……
    这话说到一切因缘法上都对。而且，一切因缘所成法都可以说是某种“巧合”。
    但得到成就者的超度是极其殊胜的。碰到真能跨（六）道度生的成就者本身就可以说是一种难得的“因缘巧合”，并不容易得到。
    现实的问题是，我们凡夫不容易判断哪些是真正的成就者，而江湖骗子又太多。所以，只说超度，在某些人时地也有副作用。不管多好的菩萨事，都有能给糟蹋了的人在。
    我们学佛人上则应该学应该做的是救度六道一切众生，次之应该学度自己。一味去等别人超度明显不应该是学佛人的目标。


身陷尘劳怎么办？

    慧悦：
    很久以前我曾经想在我们的网站建立起一个与宗教有关的频道，但是未能如愿。现在我在做时尚频道的版主。工作小有成绩。不过有得也必有失。由于工作过于繁忙我很少有时间来网站拜读经典，甚至连十念法那样简单的早晚功课也没有再做过。直到，最近在我得到公司嘉奖后，繁忙中我突然感到一种莫名的烦恼。也许工作和生活两方面的压力太大了，而我又已经一年没休假了。感觉快要崩溃了一般。
    所以，我想我需要的不仅仅是睡眠还需要更多的精神上的补给。世纪末的人们太容易被感染上浮躁，如何才能得一味良药医治呢？我相信我一定能在你的网站中获得我想要的东西。希望你还在精心的维护你的网站，希望你的网站越做越好。

    成军：
    这种感觉，相信每一个身陷尘劳的朋友都曾经有过。如果可能，您也许应该休息一段时间，能找个清净的道场专修就更理想啦。在现代社会，工作与修行的协调很难，也许您应该先尽力做到心中经常能思维苦、空、无常、无我，坚固出离心。这方面，后学本人做的也不好，不多说什么啦。这其实就是我们众生无始以来认假为真的攀缘心在做怪。因此若是没有佛法，众生何处得安乐呢？谢谢鼓励！成军一定尽力维护好这个网站。也请您继续支持。

    2000年1月


关于前世今生

    4570：
    我今年20岁，刚刚对佛教教义产生极大的兴趣，对于生命甚爱思考，如果说存在前世，那么肯定今生我不知道前世之事。那我存在的意义在哪里？按照我现有的理解，是为前世之恶而今生洗孽，还是为前世之苦而今世受善果呢？如果说三世因果，六道轮回，那么大家都善行，世界皆大同美好！皆佛！为什么还要结束生命，又要什么前世今生！？我现在只知道，为人要谨言善行，善待生命与万物！
    那其他的思考呢？还劳烦有缘人开悟！首先欢迎您今后常来和大家探讨佛法与人生的道理。

    成军：
    对於您的问题，说点个人看法。是否存在前世，我们先不谈。您现在还能回忆起2岁时候吗？能回忆起2个月大的时候吗？
    在这个物欲横流的时代，您能够冷静思考存在的意义这样非常根本的问题，赞叹您的慧根。不过，对於佛法您也许还需要再多一些了解。
    存在的意义，不是为了承受过去所造的苦果乐果，因为这些是因缘法自然而然的现象，本身并无意义可言。以佛法而言，我们存在的意义，或者说追求的目标，分两类，一是自解脱，也就是止息自身的烦恼痛苦，二是他解脱，也就是帮助一切的众生远离烦恼痛苦，常得安乐。两者又是不可完全分离的，在利他的过程中，自身的烦恼习气也会得以逐渐的减轻。而究竟意义上，佛法说“无我”，我与众生，本无差别，各自因为妄想执着而各执一部分因缘法，以为是“我”。
    “如果说三世因果，六道轮回，那么大家都善行，世界皆大同美好”。这样的想法是美好的，却有不现实，为什么呢？因为大家只要有我执、我见在，行为就不可能完全利他，就必然有人我的冲突和矛盾，世界也不可能大同美好。因此，佛法的基础是鼓励善行善法，但是却又不是停留在善行上，而是让大家破除我执，这样才能根本地使世界美好。
    “为什么还要结束生命，又要什么前世今生！？”。不知道您这话从何谈起？我们的身体，只要是因缘所成，就有老坏的一天，而这个对於我的执取，在此色身坏灭后，又会因为过去的业习因缘，执取新的身体，进入下一生。这个是自然规律，不是佛法让你结束生命，不信佛，生命就不会结束吗？
    “为人要谨言善行，善待生命与万物！”。能够做到这样已经很了不起，也祝愿您更深入的思考人生的道理，更多了解佛法的道理，看看佛法是否能够解决您的疑惑。


对于如何看待大乘佛法与大乘经典的一点粗浅认识

    对于如何看待大乘佛法与大乘经典的一点粗浅认识

    成军

    大乘佛经的来源，本来不是问题。其文笔的优美和义理的深广，更是世所公认。然而到了近代，学术界一些人从文献考据学出发，特别是以南传巴利文经典为唯一可靠的佛经，否定汉语系和藏语系从梵文译的经典，进而否定流传千年的整个大乘佛法体系。
    大乘佛法，经历了自佛陀初转法轮始的两千五百年，已经传入中国两千年，其修证方法为无数前贤所亲证，并且在事实上作为整个世界佛教的主干延续至今。到了近代，由于作为大乘佛法传承主体之一的汉地佛法的衰微，部分人将目光投向了传承了佛法中被汉地藏地祖师判教定为小乘佛法的一脉——南传上座部佛教。明清以来汉地部分寺院戒律的废弛、义理的荒疏和不重实修，使人们对于还比较完好保存原始佛教时期若干特征的上座部佛教寄予了较高的希望。一些有识之士开始尝试引进南传佛法以补汉地大乘佛法之偏差，于是出现了原始佛教热。然而一部分矫枉过正者，却打着复兴原始佛教的旗号，并以某些近现代佛学研究的观点为依据，对大乘佛法进行了根本否定性的“反思”。中华佛教论坛转贴的那个《历史人物回顾》系列文，正是这类思想的一个典型。这种思想目前在台湾一些学佛的同修中间已经相当流行，看来也正逐渐影响到了大陆佛教界。
    这类论点对佛法的危害是很大的，会戕害许多人的身心慧命，使末法时代本来就障碍很重的人们对佛法产生更多的疑惑，甚至丧失信心。其结果不仅将影响大乘佛法，也会加剧包括南传佛法本身在内整个佛教的衰微。佛陀在经典中关于谤法严重业果的叙述，绝非危言耸听。民国年间，印光祖师等曾经直斥某指认楞严经为伪经的佛学家为魔，这绝不是出于个人意气或学术之争，而是维护整个佛法兴衰的大事情。就连新近冒出来的宗教骗子李洪志都晓得利用他那一点有限而错误百出的佛教史知识，贬低现在的佛教非佛所说法，以达到他妄图成为现代佛的目的。因此，后学在此谈一点个人对大乘佛法与大乘佛经来源的认识，希望对于大家客观地看待这个问题有点帮助，更希望诸位学修有成的前辈大德能够予以指正。
    首先，现有的大小乘经典，都是由后世弟子多次集结而逐渐形成文字的。真正形成文字，大约是从佛后150年的阿育王时期开始的。古印度长期处于多国家和城邦的分裂状态，民族、语言种类很多。而佛陀的弟子为了弘法，游行各地，因此不同地区不同种姓民族的人，用于记录佛经的语言完全可能不同。据说巴利文是一种民间的土语，而梵文则是婆罗门学者惯用的语言，它们都有可能如实记载了佛陀经由后世弟子传播到各地的教法。欧美的现代佛学研究，是先从考证南传巴利文佛典开始的。因此，研究者始终对于经梵文流传并翻译成汉藏文字的大乘和密乘佛经抱有歧视态度。直到近年来学术交流和相互了解的增进才稍有改进，例如汉译阿含经与南传原始佛典存在大量对应。同时相当数量的汉文藏文的佛经和佛法著作也被翻译成英文为越来越多的西方人所了解并接受。令人遗憾的是，近当代日本和台湾的佛教界人士，也从学术考据的角度，附和这些西方学者的观点，把大乘经典说成是伪经，并认定凡与南传上座部教义不完全相合的大乘佛法皆不是佛说，不是佛法。
    历史学家对于大乘佛经的怀疑，除了因为采用的文字是梵文而非巴利文以外，主要是由于大乘佛法在印度的广泛传播与大乘佛教的广泛流通均晚于小乘佛教，因此认为可能是后世弘扬大乘的学者伪造。首先必须指出，对两千多年前发生的史实下结论，本身就是几乎不可能的，何况印度还是一个不重视历史记载的国度。如果根据大乘佛法的记载，所有以“如是我闻”开头的大小乘经典，都是佛说，由侍者阿难在第一次集结中背诵出来并经过以大迦叶为首的五百上座比丘的认可。但是，这些大乘教法在佛陀去世后的两百来年的原始佛教时期，却没有得到广泛传播。其原因主要是印地众生大乘根器未熟，当时传承佛法的佛弟子们大多只接受小乘教法。我们知道，佛陀最初度化的一批弟子，很多都是修习各外道法的出家沙门，他们原先虽然不具备缘起无我的正见，对于世间的厌离心是很强的，因此非常乐于信受佛初转法轮时说的四缔等以出离轮回为目标的小乘法，而对于圆融世间、出世间，发菩提心利益一切众生的大乘教法难以信解受持。佛陀涅槃后，佛法经由在全印度数百年的流传，特别是后世佛弟子的来源从出家沙门扩展到社会大众各阶层，弘法方式也随着各地区实际情况的差异而出现多样化，种种原因终于促成众生的大乘根器渐渐成熟。与此同时，传承小乘佛法的上座部僧团因见地与对戒律细相理解的分歧发生部派分裂。这时，便有马鸣、龙树等诸菩萨出世，从印度各地和龙宫、天界重新取出大乘佛经，并著述大乘论典阐扬大乘思想，弘传佛陀的大乘教法，直至今日而不绝。
    必须看到，完全站在考据学角度判定佛经的真伪，以佛法的立场而言是没有意义的。因为考据学对于佛法的基础如六道轮回等的存在与否都是无法证实。例如，佛成道后，先到天宫说华严经，后来也多次在天上宣说大乘法如地藏经，还在大光明定中为菩萨说诸甚深经典如圆觉经。这些都是无法考据的。学术界对于龙树菩萨在龙宫取出华严经的疑问其实正是学术研究与信仰实践的矛盾所在。然而，佛法包容三界，不可思议，实在非学术考据所能及。举个例子，藏地大修行人往往能够开启当年莲华生大士等祖师留下的伏藏法，直到现在，现代宁玛派大德还不断随因缘开启伏藏。这在考据的立场是完全无法理解的，但是这些伏藏却又是真实不虚的。
    最后再简单谈谈对大乘佛法与小乘佛法差别的看法。站在大乘佛法的角度看，南传小乘佛法其实一目了然，并不存在疑惑。小乘佛法是一切佛法的基础，称为根本乘更为合适。而大乘佛法的整个修法，其实在根本乘的三十七道品中都得以概括。没有对四缔法，对苦、空、无常、无我的认识，没有真实地生起出离心，大乘佛法不过是空中楼阁。然而，大乘佛法不仅停留在自身解脱这一阶段，更珍贵的是利益一切众生、使之离苦得乐的菩提心。佛陀成道后，并不直接入涅槃安享涅槃妙乐，而是毫无疲厌地善巧说法四十余年，足迹遍及于中印度；临近涅槃、年迈体弱之年尚且不忘度化有缘众生，这本身就是对于菩提心、菩萨道最好的身教。而南传的部分信徒片面强调苦空无常无我，否定大乘佛法最终达到常乐我净的可能性，其实已落入佛陀所说的法执。这样也就等于否认了佛陀所成就的究竟涅槃，因为我们知道已证无我的四果阿罗汉在很多方面都是远远无法与佛陀相比。南传佛法实修的基础是在以观照觉受为主的四念处法，如果真正修习成就，可以现证无我空性。但是某些极端的南传佛法实践者过于注重觉受，甚至恨不得把自己觉受尚不能证到的三世因果、六道轮回等大小乘共同的基础也一起否定掉，把佛法简单等同于一种缘起性空的哲学思想。另外，一些人曲解大乘，以为大乘佛法不遵守佛陀的戒律，不合乎三法印，不注重实修，其实是对大乘佛法的根本精神缺乏了解的结果。这一点，只要平心静气地翻阅记载古德事迹的高僧和研读大乘祖师撰述的论典，就不辩自明了。
    以上仅是后学个人的一点心得体会，论述这样的题目其实远超出后学之能力，因此不正确的地方一定很多，希望大家批评指正。另外，佛法的核心重在实证，三法印等佛法的基本原则是大小乘修证共通的结果，并不是生搬硬套拿来诽谤大乘佛法的工具。少数南传小乘佛法的信徒，在对大乘佛法缺乏足够了解与实证的情况下，肆意批评，就好象小学生拿自己的知识批判大学生，于人于己均无利益。
    【几点补充】
    上文完成后，根据在佛教论坛网友善知识们的回应，再补充几点如下。
    一、现代考据学其实并非一无是处。很多佛陀时代到后期阿育王时代等的历史遗迹都被考古证实，从而可以证实佛陀以及后世的历代传承佛弟子的真实性。另外，平心静气地比较巴利文、藏文、梵文、汉文经典，其实对研究佛法义理的演化与各宗义理的异同是有相当意义的。
    二、佛学不等同佛法，一个不相信佛法的三世因果、六道轮回，也不相信佛陀和诸菩萨圣者所达到证量的佛学家，无论他的立足点多么客观，都不可能完全符合佛法。因此，佛学家的著作对于了解佛学知识是有用的，佛学研究也有一定的意义，但是学佛求解脱还是得依止有实证的善知识，切不可本末倒置。
    三、第一义缔，离语言逻辑，本不可言说。祖师们为方便众生理解和入手实修，立各宗知见而强名之。各宗相辅相成而又相破，如唯识与中观互破，事实上只是从不同角度以语言逻辑诠释第一义缔，正说明各宗本不相违，只有了义和方便的差别。一个大乘行者，完全可能一生严持小乘别解脱戒，并分别就学于中观、唯识的大师。这样的例子很多，典型的如宋代时入藏中兴西藏佛教的印度大德阿底峡尊者。现代佛学家把实证的佛法当成空洞的哲学，以为各宗相互矛盾，或站在一宗立场贬低诽谤他宗，其实都是门外汉的作法，大家不必受其影响。
    四、学佛之初，于教理和事相等方面发生一些疑惑应该是正常现象，完全回避这些问题也未必可取。“疑”本是与贪嗔痴并列的五毒之一。真正能于生实信其实还是相当难的，一些证果罗汉尚且难以信受佛陀亲说的大乘教法，何况我等薄地凡夫。但是，我们初学者，切不可因为些许疑惑就此彻底退转，不再学佛，重新为业风所转，随业漂流。而是应该通过实修和教理的学习逐渐消除疑惑，坚固正信，趋向实信，方能有了脱生死、自觉觉他的希望。否则，在疑惑中人身空过，白白丧失此暇满人身，实在是最可悲可叹的事情。
    五、大小乘关系。有师兄指出，大乘才是佛法根本，根据应该出于《法华经》等大乘重要经典，即佛出生于世的因缘其实是令众生开佛知见。后学也赞同这样的说法，属于阐述的角度不同。后学上面提到的小乘为根本乘佛法，是根基的意思。具体说，小乘的发心出离心为修行下手最重要的发心，也是佛法与外道的不共差别。小乘的别解脱戒（五戒、比丘戒等）则是一切戒定慧修行的基础，也是受持大乘菩萨戒（菩提心）的必要条件。小乘的三十七道品，则是修持大小乘一切佛法共通的路径。


佛教宗派建立的必要条件

    佛教宗派建立的必要条件

    越尘

    中国，佛教在恢复。随之而来的不仅是寺庙的恢复，学佛人数增长，教法的复兴，而且还有新兴宗派的出现。而后者，引起了许多疑问。
    这许多自称佛法或佛教的新兴宗派里无疑是鱼龙杂混金沙俱下，有大量附佛外道存在，但断然否定一切新兴宗派，认为都是附佛外道，也是于理不合。特别是个别明显符合三法印等佛法教授，并在近年对佛法复兴起了有益作用的新宗派，由于种种因缘，依然受到了强烈的质疑。这使我们不得不仔细想想，怎样的佛教宗派才能建立牢固的基础，得到广泛的承认。
    对这个问题的第一直觉回答，特别对密教弟子，是“完整不间断的传承”。这个回答其实包含了两部分；a﹑自佛陀或法身佛以下不间断的教授相传，b﹑大量相续出现的以自宗教法修学的成就者。然而更仔细地分析会发现，a竟然不是必不可少的条件，b居然也不是充分条件。汉传佛法里净土、天台等宗派明显不具备条件a，然而无人对这些宗派的正派与有效怀疑。它们毫无疑义地是基础牢固广泛认可的宗派。而具备条件b的，却仍然可能是很小的不广为认知的秘密传承。当然，具备a﹑b﹑两条件无疑对一个宗派的巩固与广传具有极其有利的影响。
    那么一个巩固的，广为认可的佛门宗派还需要什么条件呢？笔者个人看法，还需要有c：合正理的自宗判教/道次第。具备a﹑b﹑c三条件的宗派固然是“名门正宗”。仅有b﹑c两条件的，也一样是正宗。
    所谓判教，就是按照佛陀教法，空性正理，将从凡夫开始学佛，直到成就佛果的各阶段所需要解决的问题，以及解决的方法给予说明，特别将自宗在各个阶段所用的方法给予明确讲述。最重点的，是要讲明自宗最核心修法──怎样成就完满佛果。对这个进行详细的讲解，依宗见加以抉择，引入实修，一般就叫道次第。一个宗派通过自宗的判教/道次第将自宗展示给大众，也经受佛门诸宗派修行者的质询与考察。如此经历过的宗派，就如大浪淘沙，剩者真金了。
    再看现有各宗。藏地宁玛，格鲁，嘎举，萨迦等派，无疑都同时具备a﹑b﹑c三条件。可以说没人再对这几个宗派的教法的纯正有疑问了。格鲁派形成最晚，而其道次第最为详尽，整个格鲁的教法，可以说是围绕着菩提道次第教法展开的。宁玛最早，情况也特殊。当初佛法进藏时需要的判教简单之极：自宗佛法是解脱法，其他的是外道不解脱。所以，宁玛的道次第反而是后来才详细展开的。
    汉传佛法的情况比较多样化一些，这与我汉人喜简捷（也就是易偷懒）的民族性格也有关。禅宗入中土时，具备了条件a﹑和b，达摩大师与禅宗诸祖的证量也是无可怀疑的，所以，禅宗的正统性与合法性受到的质疑不很大。相应地，根据中国人的“省事原则”，禅宗使用了最简单的判教：“教外别传，直指人心”，从此奠定了禅宗汉地第一宗派的位置。净土宗是汉地自己的宗派，没有条件a可直接使用。净土宗判教虽然不复杂：“横出三界”，其为此判教做的引证却绝对不是小量。加上净土宗往生的效验不断，也奠定下第一大宗的地位。汉传佛法里判教做得最典型的是天台宗，其判教之详细，当称为道次第，与藏传诸宗相比也不遑多让。很可能，这与天台宗不具备条件a有关。然而由于完整的判教/道次第具备了，也无人对天台宗的正法地位有任何怀疑。考虑到天台净土诸宗，当其起时，也是“新兴宗派”，故当今新兴的佛法正派应该接受历史的经验，建立自宗完整而合正理的判教/道次第会大大有利于自宗的稳定和发展。
    然而，建立自宗判教与道次第实在是个艰难任务，它需要有对佛法完整了解﹑同时实证极高的大师花费大量的时间才有可能完成。或者，它需要历代成就者持续不断的努力，而仅仅不断有成就者出现未必能保证这个使命迅速完成。愿汉地新兴的正派里能有这样的因缘，能建立完整合理的自宗道次第，能为广大佛门行人称赞认可，从而利益更多的有情。借用它宗的道次第终究是难以持久，难以建立稳固基础的。

    佛教在线电子杂志第一期


后学对于佛法各宗互不相违的粗浅认识

    后学对于佛法各宗互不相违的粗浅认识

    成军

    法华论坛上面法日菩萨提出各宗教义之别的问题，这是学习佛法容易遇到的一个问题，初学者往往迷失于各宗教理表面的不同而无所适从。过去在中华佛教论坛大家对此也有过讨论，这里谈一点个人理解，肯请大家指正。
    首先，我们知道，其实佛法的第一义实相其实是不可用语言逻辑述尽的，例如在《维摩诘经》中，维摩诘大士即以沉默回答了文殊菩萨关于第一义缔的提问。然而，我们这些钝根凡夫，根器有限，必须依赖思维逻辑下手了解学习佛法义理。因此后世祖师慈悲，根据自己对佛法的证量见地与所得传承立各宗知见，目的是为了给我们一个台阶，借助此方便逐渐契入真理的实相。却不是拿这个作为武器，攻击他宗。连佛陀自己尚且说自己说的法如渡河的船筏，过了河就当舍弃。
    中观应成见与他空见，以后学理解，其实是把真如实相的空有两边的毕竟空和胜义有，各自发挥到了极致，分别以否定和肯定的方式来阐述同样的第一义缔。对于我们凡夫学人，都是无比殊胜的佛法。无论哪宗，依之修学，最终都可以获得解脱成就。这点早有各宗的历代大成就祖师为证。同时，真正实证圆满后，对于这些知见，自然还会进行“修正”。例如藏地莲花生祖师传承的大圆满见和汉地禅宗证道大德“离四句、绝百非”的见地，其实就不属于是单纯义理上的中观应成或他空见。另外，我们必须认识到，中观应成见不立一法不等同于恶趣空；他空见立胜义缔，也绝不可与常我外道相提并论，两者都是基于缘起性空这一佛法根本的正知见，只是侧重不同而已。
    我们修学自宗，坚持和赞叹自宗见是对的。但是评价他宗则需要格外谨慎。因为就是证果已断烦恼的圣人尚且也可能还存在所知障，只有佛陀能够完全了知一切法门与方便。谤法的业报很重，因为它能够障闭我们自己和众生的正知见，使远离解脱。古代祖师空有之辩，可看作是演几出戏，示现给我们看，以帮助我们从不同方面更彻底地了解佛法的义理，并且应该避免犯那些知见错误。例如大乘破小乘，中观唯识互破，对于大乘佛法的发展，都有很重要的意义。然而，对于不同根器的众生，小乘、唯识、中观中的任一宗，都可能正好是对治烦恼、指导实修的良药，缺一不可。而且在修行的各阶段，可能还需要利用中观唯识等他宗的知见纠正自己的偏差。一个修行人，完全可能一生以小乘戒律为基础，同时依止中观、唯识大乘各宗的善知识修学，例如印度大德阿底峡尊者。就是佛陀一生说法，在不同时期，也是根据众生根器不同，偏说不同类别的法，从小乘到方等、般若、法华涅槃，逐步将众生导向圆满成佛。
    后学既无实修，又没有系统学习过教理，徒具一点书本知见，论述这样的问题实在非自己能力所及，甚感惭愧。


禅法衰败的原因

    禅法衰败的原因

    二麻子

    敬回金刚兄，麻子的一管之见……
    麻子同意，金刚兄所举（编按：指语录盛行及是否公开修行窍诀的问题）是宗门不振的原因之一。此事并非简单的保密问题，而是所谓众生密的解脱。因为凡夫中的大多数无有必要的基础，对于无上法要，即使有正确的讲解，也不能正确了解。若再辗转相传，积非日甚，行之当然无效。而且以讹传讹，积非成是，广大人群以错解为正解，既然行之无效，自然就以为是此法无效了。此为劣币驱逐良币，伪货击败正牌，悲夫。然而，保密不应该是宗门不振的主要原因，且看正法时期，声闻法基本有教无类，却无此等事情。
    麻子的看法依然是，宗门不振是因为禅宗失去了它发展的基础：大量具备慈悲、正见、禅定基础的佛门学人。唐宋之时，进入宗门的学人平均基础相当好，很多在教下修学有时的讲经师，禅定家等良材，纷纷入于宗下。故禅宗能以此为基础创立中华佛教前所未有的辉煌。然而，禅宗一向标榜门庭高峻，并未设立让学人从零开始的修学次第。宗下实际是以教下为前行基础的。待到今天，如此高质量的学佛人群不再存在，禅宗衰落就成必然。若要重振宗门，必须给禅宗准备必要的基础学人群，而这正是重振整个汉传佛教。故重振宗门实在与重振中华佛教指掌相联，不可分割。
    麻子一管之见，金刚兄指正。


希望禅宗如同无尽灯

    脏孩儿：
    我认为修行禅宗之人亦可顿入“识妄即止”阶段，不必依其大圆满之甚密修持，或者仅依“且却”之文字即可，请大德指教？

    二麻子：
    这“亦可”两字，您若是单指“可能性”，则麻子决不排除。实际上，中国唐宋时代禅宗兴盛时期，由禅而入的人相当多。时至今天，能依禅宗入的可能性依然存在。如果真有明眼人指导，自己也肯努力的话，依禅入是可行的。
    但是自己真有依禅宗修学成就的实力吗？这些，可就大大要掂量了。

    袋子：
    禅宗既然已经沦落到法卷传法，是否可以认为现在禅宗的传承已经断了？

    二麻子：
    对这些事麻子没有那么悲观。或许现时禅宗里有这样的个别现象，甚至就算是这样的个别现象不少，也不能说明所有的都是这样。你想说明禅宗的明眼人都死绝了吗？佛友，勿做此想。不管情况怎么样，我们希望禅宗如同无尽灯。
    六祖的时候，还没有五家七宗，五家七宗就是禅宗历代大手眼宗匠们为了接引学人后来发展出来的方便手段。所以，只要真有明眼人相续出现，就会有应机的手段相续出现。所以，能继承传承宗派的方便当然最好，如果不能，也可以发展出来。比这个更关键的是要有具手眼宗匠出现。
    现状似乎不很令人鼓舞，但也还不至于绝望。


“某事的末流与某事本身是两回事”

    “某事的末流与某事本身是两回事”

    二麻子

    翻看贴子，兄似乎有一点点以个别代替全局的倾向。比如禅宗，用某先生言论做代表来说明禅宗执我，就过分了。看过这个公案吧：
    问“大千坏时那个坏不坏？”
    （在西川的）师答“坏！”归根结蒂
    问者不服气，就去找另一位大大有名的禅师评判。大禅师合掌道“西川古佛出世”。

    可见禅宗不但说无常无我，而且还是共许的。
    至于当今的禅宗末流，嘻嘻，麻子赞同坛上已有的两句话：
    “某事的末流与某事本身是两回事”
    “现今学人也不尽是末流”。
    嘻嘻，有的人说汉地佛法没希望？嘻嘻。再说到汉地佛法，麻子看法现在是阴极阳生的情况。尽管看表面还不特别理想，一阳回复已经悄悄地暗暗的在动了。推动复兴同时尽量抑制相似法。归根结蒂，只要能让众生多往解脱方向靠近点，不就好点吗。
    基本上，麻子不觉得禅宗是什么系，或者说哪系都有点。原则是只要能导致开悟，有助开悟，哪个系的说法都可以用，也都不执为定说。后世的末流当然是另外一回事了。
    至于您说的宗派间比高低的事，确实有，大家都看见。但是还有两件事似乎也应该了解，一是，哪个宗都有（有过）弘扬自宗随喜它宗的大德。二是，哪个宗都不能自己说自己是“第二”的，否则一个学人也没有了。
    所以，如果要说自宗第一，又不很仔细地选择表达第一的文句的话，嘻嘻，似乎很容易就有了贬低它宗的效果。很多事情，似乎就是这样来的。


树茂则根枝俱荣，诸枝俱荣则树盛

    树茂则根枝俱荣，诸枝俱荣则树盛

    二麻子

    嘻嘻。净土学人们强调某些方面，其他学人强调另一些方面，如果都没离佛法要义，其实有什么架可吵的？
    这年头，看不起净土的人是有的，排斥其他宗的人也是有的。这是实际情况。为了反对上述一种而自觉不自觉地做了另一种，也是糊涂乃至愚蠢。
    有人说“弘扬净土会断灭佛种”。
    ──弘扬净土怎么会断灭佛种呢？会断灭佛种的是排斥它宗。佛法如多罗宝树，以菩提心为根，而各个宗派为枝叶。树茂则根枝俱荣。诸枝俱荣则树盛。
    若人称扬一枝而砍它枝，则是自断其手足，其蠢也莫过如此。岂有三肢俱断而一手独荣之人乎？岂不见经云，佛法若灭，净土教法不过多存百年，可知它宗若断，自宗亦难独存。
    多年相识而知，莲舟诸友几乎都是身体力行弘扬、支持净土，起码也是随喜净土教法的佛弟子。岂有反对净土者？相反，反对净土的人物在莲舟没有市场，这是历史证明的。同样，莲舟将坚决反对一切排斥其他佛门宗派的行为。
    麻子借此也呼吁一声，自断手足者，别继续自己的愚蠢了。


有关修净土的一些话题

    有关修净土的一些话题

    善惠

    在《大宝积经·无量寿如来会》中，世尊介绍无量寿佛土功德庄严，十方诸佛赞叹后，开示了众生往生无量寿佛土乃至成就无上正等菩提之道的一段话：
“他方佛国所有众生。闻无量寿如来名号。乃至能发一念净信欢喜爱乐。所有善根回向愿生无量寿国者。随愿皆生得不退转。乃至无上正等菩提。除五无间诽毁正法及谤圣者。阿难。若有众生。于他佛刹发菩提心。专念无量寿佛。及恒种殖众多善根。发心回向愿生彼国。是人临命终时。无量寿佛与比丘众。前后围绕现其人前。即随如来往生彼国得不退转。当证无上正等菩提。是故阿难。若有善男子善女人。愿生极乐世界欲见无量寿佛者。应发无上菩提心。复当专念极乐国土。积集善根应持回向。由此见佛生彼国中。得不退转乃至无上菩提。阿难。若他国众生发菩提心。虽不专念无量寿佛。亦非恒种众多善根。随己修行诸善功德。回向彼佛愿欲往生。此人临命终时。无量寿佛即遣化身。与比丘众前后围绕。其所化佛光明相好与真无异。现其人前摄受导引。即随化佛往生其国。得不退转无上菩提。阿难。若有众生住大乘者。以清净心向无量寿如来。乃至十念念无量寿佛愿生其国。闻甚深法即生信解。心无疑惑乃至获得一念净心。发一念心念无量寿佛。此人临命终时。如在梦中见无量寿佛。定生彼国得不退转无上菩提。”
    围绕世尊的这一段开示，可以发现在信心、欢喜心、菩提心、专念心、大悲心、回向心等等用心上，如何更好地与净土相应，净土行人应有一些相当的认识。保持正确良好的心态应该有助于我们对净土法门的修持：相应，相等和合之意。即指法与法相互间有和合不离之关系，特别指心与心的所缘之关系而言。即瑜伽，意译为“相应”，由此可见“相应”当然包括实修的意思；修相应，即从理上明确和行上现证这种和合不离，具体到净土修持，即指使心和净土融合不二，并将此贯穿到修持者所经验的所有相续中，时时刻刻不离净土，乃至临命终时即得往生得不退转。要做到这一点，明析发心和发心的所缘境──净土的丰富内涵，显然是体会和把握净土相应的重要命题。
    “信为道元功德母，增长一切诸善法”，这是《华严经》里讲明了的，这里讲的信字是总摄了归依和发心的，所以经中在这一句偈之前还谈到：“深心净信不可坏，恭敬供养一切佛，尊重正法及圣僧，信敬三宝故发心；深信诸佛及正法，亦信菩萨所行道，正心信向佛菩提，菩萨因是初发心。”对净土教法的最初净心的生起，各凭往昔福德因缘；随着对教法的深入学习，原先认识中模糊迷茫的地方变得逐渐明晰，不准确的变得准确，心中潜藏的惊疑变动逐渐消散，不易为各种顺逆因缘和不当的异说所倾动，则是走向正信乃至实信的标志。我们既不用相信空气是否存在，也不用去设想我们如何能够呼吸，若信力行到这一步，就算是对佛菩萨、对自己，多少有个交代了；所以佛世时有大声闻很明确的对某外道教主表示：“你问我是不是信释迦所说的法？释迦所说的法，我听闻，修习，日如是住，夜如是住，就是这样了！”
    增长对净土法门的信仰，从对经典的受学开始，是正确的方式，《大宝积经·无量寿如来会》里，有一节是专门讲这个问题的，世尊对弥勒菩萨谈到，“阿逸多。是故告汝及天人世间阿修罗等。今此法门付嘱于汝。应当爱乐修习。乃至经一昼夜。受持读诵生希望心。于大众中为他开示。当令书写执持经卷。于此经中生导师想。阿逸多。是故菩萨摩诃萨。欲令无量诸众生等。速疾安住不退转于阿耨多罗三藐三菩提。及欲见彼广大庄严。摄受殊胜佛刹圆满功德者。应当起精进力听此法门。假使经过大千世界满中猛火。为求法故不生退屈谄伪之心。读诵受持书写经卷。乃至于须臾顷为他开示。劝令听闻不生忧恼。设入大火不应疑悔。何以故。彼无量亿诸菩萨等。皆悉求此微妙法门。尊重听闻不生违背。”。
    世尊既然提出“于此经中做导师想”，其后自然也说明了这样考虑的原委所在，佛法难闻，人生难得，诸佛的教法又极深广，能说法人亦难开示，故而希望后来学者对记载如来说法的这些经典能认真修习，如是修，如是住，莫离莫弃。对经典有信心，自然能够对修持的所缘：比如佛号，生起极大的信心；“读诵受持书写经卷”这一行法，同样谈及过的《普贤行愿品》解作：“莫生疑念。应当谛受。受已能读。读已能诵。诵已能持。乃至书写。广为人说。”其中一个比较关键的转折点应该是背诵。背诵经典，现代不大有人提倡了，却是佛教早期传教中所用的主要方式，无论是大声闻的经典集结，乃至一些极早期传入中国的大部头经典，都是用背诵来解决持经这一问题的。笔者侥幸蒙一位大德明确提示，对这一要点才引起足够的认识，仔细体会起来，诵读佛教经典对于使心摆脱昧略粗疏的状态，全面精微的体认法义，乃至将来有可能的话依文起观，都有极大的帮助。值得注意的是，一部分净土宗修行者，在念持佛号之余，多有念持乃至背诵小本阿弥陀经以为助缘的习惯，可见世尊当年之累嘱，至今仍有依教奉行者在。
    学佛首先要信佛，对于佛弟子来说无疑是不须议论的话题，那么众生呢，我们对他们应该报以什么态度？其中最不恰当的态度，莫过于在心中常存这样的念头：“哈哈，我要去好地方了，你们继续蹲苦窑吧！”，这种窃笑若从口中发将出来，绝对容易引人侧目，自己也容易发现其中的毛病，所以当然不容易看到有人明说；但是不这么说，未必不这么想，仅仅是一闪而过，理论上对于修大乘者来说也是足够麻烦了。我们“信”的出发点，往往带有两种难以觉察的味道，即一：我们所信仰的“佛”，和我“人”，在我们看来是差别明显，少有共同之处的。其次的问题在于，不谈众生，即使是“别人”，在这个以自我为中心的环流里竟然是难以找到位置的，若勉强说有，能想上一句“我成佛以后再来度你们噢！”也是难能可贵的了。如何使我们的信心渐趋于如阿弥陀佛因地闻法所生起的信心一般无异无别？
    净土法门的大修行者曾这样建议持信：心佛众生三无差别！
    蕅益大师提出“由能深信心佛众生三无差别故，精修念佛三昧，不作无佛无众生想……了达心佛众生，三无差别，以心即佛故。上求无厌，与大智相应，以生同佛故。下化无疲，与大悲相应，念念悲智随四悉檀，善自护，亦善护他，是名真实中行。（《灵峰宗论》）”以持念佛号为例，常说一句佛号与阿弥陀佛无二别，即此能显能持万德洪名之心，当亦与阿弥陀佛无二别，以诸佛体性平等故，与法界诸佛无二别，以诸佛不舍一众生，此心含摄一切众生，以众生亦堪能持此一句佛号堪能成佛故，心佛众生三无差别，究竟不二。是以《观无量寿佛经》中世尊开示：“诸佛如来是法界身。遍入一切众生心想中。是故汝等心想佛时。是心即是三十二相八十随形好。是心作佛是心是佛。诸佛正遍知海从心想生。”
    正因为心佛众生三无差别，一切众生为烦恼无明覆着，诸佛的德相暂未自内显发，至心信乐专心修学，除灭烦恼便得解脱。《大方等如来藏经》云：“如是善男子。我以佛眼观一切众生。贪欲恚痴诸烦恼中。有如来智如来眼如来身。结跏趺坐俨然不动。善男子。一切众生。虽在诸趣烦恼身中。有如来藏常无染污。德相备足如我无异。又善男子。譬如天眼之人。观未敷花见诸花内有如来身结跏趺坐。除去萎花便得显现。如是善男子。佛见众生如来藏已。欲令开敷为说经法。除灭烦恼显现佛性。善男子。诸佛法尔。若佛出世若不出世。一切众生如来之藏常住不变。但彼众生烦恼覆故。如来出世广为说法。除灭尘劳净一切智。善男子。若有菩萨信乐此法。专心修学便得解脱。成等正觉普为世间施作佛事。”
    此信云何修习？《大宝积经·无量寿如来会》但诸菩萨众“能持一切如来法藏。安住不断一切佛种。哀愍有情能开法眼。闭诸恶趣开善趣门。普观有情能作父母兄弟之想。又观众生如己身想。”，有样学样，我们渐渐向菩萨去靠拢就是了。蕅益大师开示，由信自（心中本具极乐），信他（随顺诸佛真实教诲），信因（称名为成佛种子），信果（净土上善皆从念佛三昧得生），信事（实有极乐国土），信理（实不出我今现前一念心外）而即理入深信心：“我心遍故佛心亦遍。佛心遍故一切众生心性亦遍。譬一室千灯光光互遍。重重交摄不相妨碍。”其文俱在《佛说阿弥陀经要解》，有意修习者大可展而读之，则心自渐渐离秽趋净，乃至因大悲故，于世间恒无所取而普遍予以救度。
    人常言知之者不如好之者，好之者不如乐之者，这确也是颠扑不破的硬道理。基本人人都会写写字，知有此事；当然如今电脑发达，渐渐的都用电脑敲字，像我这般敲惯了的提笔倒还真往往有几个字得想一阵子；写得好的大致也就都该练过；这“好”字大致有两个含义，首先是肯定，其次是对之有一定的兴趣，这样就对写字下工夫去钻研；若到了以之为乐的程度，对写字的认识就肯定能逐渐深广起来，渐成一家，渐成一体，大多是这么来的，若当这个是苦差，则肯定不易成功。
    这里面就有两重问题，即知而信阿弥陀佛，乃至最初的欢喜，这是往昔生中非同一般的善业所显现的，所以《阿弥陀鼓音声王陀罗尼经》中云：“若有能信如是之事。当知是人不可思议。所得业报亦不可思议。”然而已知爱乐固然极善，若能爱乐于数数修习，自然更胜于仅乐于闻知，《大方广佛华严经菩萨问明品》中，文殊菩萨与法首菩萨的问答，即明确了实修对于菩萨行人之重要，其中曰：“如人善方药，自疾不能救，于法不修行，多闻亦如是；如人数他宝，自无半钱分，于法不修行，多闻亦如是”。所以，既已闻法，便当自修。
    其次的问题是，于自所爱乐行法，于数数修习时，有一个极重要的关系到修行成效的要点，就是止恶！心在初习的阶段，矛盾对立重重，有喜，自然有不喜，乃至有忿恨，甚至这一不欢喜的所缘，移至与自己所修所见不同的学佛同门身上。这种事情恒恒常常，可大可小，旋灭旋生，如烟雾缭绕不去。须知此乃恶分别，应及时改掉，否则于自他皆非善利，应善加随喜他人善业，忏悔往昔所起恶分别，则环绕自身之三毒等流障碍，必日见消散！对此梁皇忏中有几句话讲得很明白：
“若见人之善。莫论成与不成久与不久。但使一念一顷一时一刻一日一月半年一岁。已自胜于不作者矣。所以法华经言。若人散乱心。入于塔庙中。一称南无佛。皆已成佛道。而况有人能发如是大心勤于福善。不随喜者。圣所悲念。（某甲）等自惟。无始生死以来至于今日。已应有无量恶心阻人。胜善何以故然。若无是事。云何今日于诸善法多有留难。禅定不能习。智慧不能修。少时礼拜已言大苦。暂执经卷复生厌怠。终日劳扰起诸恶业。使此身形不得解脱。如蚕作茧自萦自缚。如蛾赴火长夜燋然。如是等障无量无边。障菩提心。障菩提愿。障菩提行。皆由恶心诽谤他善。今始觉悟生大惭愧。稽颡求哀忏悔此罪。唯愿诸佛请大菩萨。以慈悲心同加神力。令（某甲）等所忏除灭所悔清净。所有障碍无量罪业。因今忏悔净尽无余。相与人人等一痛切。五体投地归依世间大慈悲父。”
    忏悔归依之后，当发大心，为欲利益一切有情，愿当成佛，是谓发菩提心。极乐教主阿弥陀佛于因地发心时，且作种种殊胜之愿。与阿弥陀佛同心、同愿、无论是着眼于往生还是菩萨道，都广为大众所随喜，阿弥陀佛的金刚誓愿，亦尤为令人钦慕；故尔释尊在解说此愿时，亦对发愿受学此愿当来成佛的阿阇世王太子，及五百长者子，予以相当的鼓励：
“佛说阿弥陀佛为菩萨。求索得是二十四愿。时阿阇世王太子。与五百长者迦罗越子。各持一金华盖。俱到佛所。前为作礼佛。以头面着佛足。皆持金华盖。前上佛已。悉却坐一面听经。阿阇世王太子。及五百长者子。闻阿弥陀佛二十四愿。皆大欢喜踊跃。心中俱愿言。令我等后作佛时。皆如阿弥陀佛。佛即知之。告诸比丘僧。是阿阇世王太子。及五百长者子。却后无数劫。皆当作佛如阿弥陀佛。佛言。是阿阇世王太子。及五百长者子。住菩萨道已来。无央数劫。皆各供养四百亿佛已。今复来供养我。阿阇世王太子。及五百长者子。皆前世迦叶佛时。为我作弟子。今皆复会是共相值也。则诸比丘僧。闻佛言皆踊跃。莫不代之欢喜者。”（《佛说阿弥陀三耶三佛萨楼佛檀过度人道经》）
    随学大愿的同时，于阿弥陀佛发菩提心的所缘，亦当明析之，于此，可从净土之常随众菩萨的修习中有相当的了解，这些段落即悄然点出了于极乐国中修菩提心的所缘相。在《大宝积经·无量寿如来会》中，释尊开示：
“彼诸菩萨。于一切众生。有大慈悲利益心故。有柔软无障碍心……舍离一切执着心。断一切众生烦恼心。闭一切恶趣心故。行智慧行已成就无量功德。于禅定觉分善能演说。而常游戏无上菩提勤修敷演。肉眼发生能有简择。天眼出现鉴诸佛土。法眼清净能离诸着。慧眼通达到于彼岸。佛眼成就觉悟开示。生无碍慧为他广说。于三界中平等勤修。既自调伏亦能调伏一切有情。”
    这一段经文所指出的发菩提心的方向，与《大方广佛华严经·初发心功德品》中的表述相仿佛，其云：“为令如来种性不断故，为充遍一切世界故，为度脱一切世界众生故，为悉知一切世界成坏故，为悉知一切世界中众生垢净故，为悉知一切世界自性清净故，为悉知一切众生心乐烦恼习气故，为悉知一切众生死此生彼故，为悉知一切众生诸根方便故，为悉知一切众生心行故，为悉知一切众生三世智故，为悉知一切佛境界平等故，发于无上菩提之心。”可以想见，在极乐世界的条件之下，种种障碍俱已舍离，则不但具有这种全面发心且串习纯熟的行人之易于成就，而亦有种种便利引导行者自然生起此种发心，往生彼国得不退转，当证无上正等菩提，自是题中应有之义，如《大方广佛华严经·初发心功德品》中云“发是心已，能知前际一切诸佛始成正觉及般涅槃，能信后际一切诸佛所有善根，能知现在一切诸佛所有智慧。彼诸佛所有功德，此菩萨能信、能受、能修、能得、能知、能证、能成就，能与诸佛平等一性。”。
    值得一提的是，网上关于净土的讨论中，有一个经常出现的问题，即什么是往生净土的最低标准，必要条件。笔者觉得非常痛心的是，讨论者中的一方往往忽略了菩提心的重要意义，或者先将发菩提心排除在外，或者仅仅是为了将发菩提心排除在外，而提出这一话题。若是大乘佛弟子，这种舍菩提心的想法根本就不当有，若是为众生求方便计，应念及佛国净土，毕竟不离菩提心。弥陀大慈大悲，确为尚未明确显发菩提心的众生，予以持名接引的法门，乃至一个人即使这一世未尝受学佛法，乃至未曾听闻佛号，临终时中阴现起，诸尊救度时，仍有可能因为往昔业力的关系，当阿弥陀佛现起时认取而得救度。
    所有的类似说法中比较取中的是临终十念必生，这既是经中明言的，也是往生传中多有记载的，信得及，这样就能往生。大部分的净土修行者善根深厚，是在寿量未尽前很久就得闻净土法门的，这种情形的借鉴意义是在于，若心念用得紧，时时视当下如临终，持这种十念必生的见，就是极高明的实修。然而这其中没有菩提心的成分么？只怕未必。如果是想：反正十念必生，我到时候再念吧，然后就躲懒儿去了，且往往是在闻法时这样打断自他的因缘，请注意，这就是业障来了，或许应该加以特别的小心！一切相待而成，康健时尚如此，临终时会如何？若不抖擞精神，勉力修持，前途十分可虑是明显的。所以，在各种可能性和因缘变化万端的情况下，讨论最低标准并无太大的必要，且作为大乘佛弟子，随喜诸菩萨行将能极大的增上自他修持乃至成为往生的相当助力，所以与其讨论什么是往生净土的最低标准，在意识中作损减法，不如取法乎上，转变心念为随喜心，老老实实地念佛。
    《观无量寿佛经》里，世尊讲了：“欲生彼国者。当修三福。一者孝养父母。奉事师长。慈心不杀。修十善业。二者受持三归。具足众戒。不犯威仪。三者发菩提心。深信因果。读诵大乘。劝进行者。如此三事名为净业。佛告韦提希。汝今知不。此三种业乃是过去未来现在。三世诸佛净业正因”
    涉及净土的经典中大多都有相当的篇幅，世尊谈到了许多此土的情况，于观经中，更是以慈悲地为一个惨遭家庭破碎人伦惨变的韦提希夫人说法为缘起，介绍净土教法之中，先说净业三福。而魏译《佛说无量寿经》中，亦在在宣说了市民生活中的菩萨道，广泛地谈到人伦问题，对善恶大加剖白导引，是为人间净土思想之开端；既为前往净土修行前所应注意的事先准备，亦广为净土行人继承下来，而将敦伦尽分作为修菩萨行的主要切入角度，所以我们可以经常看到佛教的社会责任与社会价值观于斯之体现。释尊在《佛说阿弥陀经》对舍利弗谈到：“如我今者称赞诸佛不可思议功德。彼诸佛等。亦称说我不可思议功德。而作是言。释迦牟尼佛能为甚难希有之事。能于娑婆国土五浊恶世。劫浊。见浊。烦恼浊。众生浊。命浊中。得阿耨多罗三藐三菩提。为诸众生。说是一切世间难信之法。”行者的大悲心应不择净土秽土，普加护持观照，念念不离众生，如阿弥陀佛之于众生普加救度，如此则能顺逆皆得增上，念念与净土相应。
    最后，谈相应，谈修持，专念是不可少的，无论是持佛号，密咒，观想，都应专心于所缘，如此则成就可期。这其中有许多反复是正常的，有一个比喻给我以极大的信心：“譬如伊兰俱与栴檀。生末利山。牛头栴檀生伊兰丛中。未及长大。在地下时芽茎枝叶。如阎浮提竹笋。众人不知。言此山中纯是伊兰无有栴檀。而伊兰臭。臭若膖尸薰四十由旬。其华红色甚可爱乐。若有食者发狂而死。牛头栴檀虽生此林未成就故。不能发香。仲秋月满卒从地出成栴檀树。众人皆闻牛头栴檀上妙之香。永无伊兰臭恶之气。佛告父王。念佛之心亦复如是。以是心故能得三种菩提之根（《佛说观佛三昧海经·六譬品第一》）”。
    心犹如一片长满了腥臭芜杂植物的山，当念佛修持时，犹如播下了香树的种子，地下原有的旃檀树根亦因为合适的气候开始复苏，香木的根已经开始在地下滋长了，并逐渐占据主要地位，这时候山的表面虽然还是和原来差不多，但是实质已经发生了极大的变化，当香树开始纷纷抽芽生长的时候，一片旃檀香树林就自然取代了原来的环境。以一个具足功德的所缘——或持佛号，或持密咒，或观庄严宝像，或持经藏，专一贯穿所有的发心而修持，将心力用在与净土相应的方向上，以之念念回向净土，回向于大乘修法的核心：菩提心；由是次第修习，以归敬故得必生彼国，以赞叹修习故得欲见佛闻法，以一心专念故心得遍入极乐世界，以专念观察依正庄严故得恒受法乐，依这样的道路修持，净业必能有相当正面地展开，乃至自斯而后行化于诸刹土速成正觉，无量诸等功德，皆将由此而生矣！


历史上的多种说法

    仁心：
    今日在偶然机会里看到《无量寿如来观行供养仪轨》，其中有这样的开示《无量寿如来观行供养仪轨》（不空译）：“依此教法正念修行。决定生于极乐世界上品上生。获得初地。”。某位法师说极乐世界上品上生是八地菩萨，和上面的这个开示不太一样，为什么会这样？请诸位发慈悲尽快给予解答，不然会很影响后学的修行！

    zf：
    关于九品往生者的品位，历史上还有多种说法。仁兄要是知道了那些异说后，是否会更加不知所措？
    实际上，佛教中的“理论问题”有种种异说者是多见，只有一种说法者反倒少见。
    仁兄，您在这位法师，（“对净空法师也一直非常信任不动摇”）金刚手菩萨，或不空三藏（不空译“尔时金刚手菩萨。在毗卢遮那佛大集会中。从座而起合掌恭敬。白佛言。世尊。我为当来末法杂染世界恶业众生。说无量寿佛陀罗尼。修三密门证念佛三昧得生净土入菩萨正位。不以少福无慧方便得生彼刹。是故依此教法正念修行。决定生于极乐世界上品上生。获得初地。”）之间的这段“官司”，论坛上的“师兄大德”们恐怕不易断定。不过在下倒是想提醒您深思：
一、净土法门的根本原则“信愿行”之“信”所信的内容究竟是什么？
    二、在所信的内容中是否包括上品上生者为八地或初地？
    三、上品上生者为八地或初地之异说是否动摇了净土法门的根本？
    四、您是因为上品上生为八地才学净土法门的吗？
    五、您究竟为什么选择净土法门来学佛？


佛法一多互摄，哪宗里没净土，净土里没哪宗？

    zf：
    近些天来关于净土的讨论，焦点之一就是往生的“必要条件”，诸兄在理解上的差别是明显的。
    依在下浅见，与其要找到公认之往生的“充分必要条件”，还不如选定几条自己有信心并有条件依之而行的“充分条件”。“充分必要条件”的事不妨等到极乐后向阿弥陀佛或观世音菩萨咨询。
    诸兄关于“必要条件”讨论的“理论”色彩较浓，真正实践起来却并不会有太大的影响，因为绝大多数行人都不会忘记发愿往生极乐或本尊净土。即使那些目前对某个净土没有特殊兴趣，临终之时十方如来现身授手，宿世因缘显发或临时再作决定也未尝不可。
    或许有些大愿菩萨，对生死已得自在，命终之时十方如来虽然现身相邀，但却不欲往生，折身返回，而愿于轮回中“常时勤苦心无厌，乃至地狱亦安受”。这样的大菩萨值得我们顶礼赞叹。

    智行:
天台宗有个不成文的规矩：老实念佛，求生净土，天台的大祖师都带头作榜样。那首偈子是宗门大匠留下的，谛闲大师还专门讲过。
    在下遇到一精通天台宗的大德，他说念佛是最上乘人的作为，说得比在下这个主修净土的人还要“斩钉截铁”。盖智者大师说圆教止观时，用念佛法来入手。当然，持密宗的本尊真言，与念佛无二。念哪个本尊，就看各人之因缘了，道理是一样的吧。

    哈哈:
真说起来呢，哪宗也不会没净土。佛法一多互摄，哪宗里没净土，净土里没哪宗？空空兄引用的那话，对禅宗并不公正。说是要纠正别人偏见的，自己也不公正了，所以俺来添点笑料。


和风车兄聊一点净土

    风车：
    往生是如何，是不是不再堕轮回，就是往生？我们在临终前或者更早的时候就可以确定自己是否可以往生吗？
    上次看成兄的帖子，说只要用心诚心拜佛诵经，就可达到往生。这是不是就是不再堕入轮回？我认为这样是绝对不可能达到往生的，如果这样可以往生，那其它任何宗教的类似的虔诚宗教徒都可以达到往生。现在的佛教是不是就是这样宣扬的？我认为如果佛教徒一直只是诚心地盲目拜佛诵经，即使守戒而不能在认识上有所提高，是不可能达到往生的。这就是上面所说的是种善意的欺骗。但这样做有个好处，对某些人，就可以戒定生慧，真慧产生后会出现什么现象，我就想不到了。有可能可以由这种入世法而生出出世法（解脱法）。

    成军：
    您要是在论坛待久了，就会发现，论的最多的是“禅”，密宗上师弟子的对谈也不少，就是少有人谈净土，为何？一方面，修净土的同修可能以老实念佛为要，不喜流于戏论，故不常发言；另一方面，不少初入门的同修，特别是从佛学、禅学等文字义理因缘学佛的朋友们，在心底里还是有几分看不上净土法门，其想法多与兄上面所言相似。这多是对于净土法门了解不够，加之有的佛教徒也确实搀杂求世间欲乐的心在念佛，且不重视教理与正见，不但自己不能往生，亦难免为人非议。
    往生其实只是换个环境，除了西方阿弥陀佛极乐世界，投生其它诸佛菩萨的净土也是往生，比如弥勒菩萨的兜率内院、药师琉璃光净土等，往生的目的是换个好的环境，避免恶缘，便于亲近善知识，因而能不造恶业，修行逐渐进步不退。待时机成熟，再以愿力回入各方秽土，行菩萨道，累积福德资粮。那时不应算是堕入轮回，八地以下菩萨，未到不退，也有可能因习气尚存，会有隔阴之迷，但如果因地的菩提愿心发的纯正、猛烈，是不可能真正退转的。
    一般修净土的人，不一定都能做到生前就有十分把握往生，但修行精进的净宗大德，如近代的某老居士，就曾多次在念佛定中亲临圣境。但他们大多密而不宣，只在临终时现种种瑞相，以增长后辈学人的信心。其他一般的有真修行的莲友，也可以做到预知时至、身无病苦，蒙佛接引，从容往生。这类例子，古今记载的就多了，近年来也还一直可以见到。后学尝见一师兄在四川某县收集的念佛往生事迹，不但多现瑞相，且以一县的人口比例，数量也是相当可观的。我们知识分子最容易对此不服气，觉得老太太连菩提心都没听说过，盲目念佛，凭什么往生？后学当年看了这些材料，内心深处也是如此想法。
    其实念佛往生的道理，似浅实深，远非后学这样的人可以讲清楚。仅针对您的前贴谈一点自己的认识体会。佛法讲万法唯心造，我们对此娑婆世界世间欲乐起深执著，以此为实，故临命终时为此习气染着拖入六道轮回，不能出离。而一心念佛，以念佛之清净心代替染污心，久之，心净则国土净，大德念佛功夫纯熟，当下感净土现前，就是这个道理。另外，您说提高佛（学）认识，又如何提高呢？凭思维，不出能所对立，始终不可能跳出框框契入空性实相的。东晋远公大师创净土法门时，佛法义学不可谓不盛，大乘经典也已译出不少，但就是缺少能够入手实修的大乘法门。念佛一法，一方面，以至诚信力得佛力加持、道交感应；另一方面，一句佛号，“都摄六根、净念相续”（大势至菩萨语），即用佛号拴住平常四处奔驰的心念，正是得止的入手方便，和用参话头来堵塞妄想分别有异曲同工之妙。
    再者，那些只知念佛的“愚夫愚妇”真的就没有智慧吗？佛法上的认识真就不如我们这些读书人吗？这其实也难说的很。要知道，我们目前的“智慧”，更确切的说是对于佛法的知识，都还是建立在逻辑、分别心基础上的，而且说的到未必做的到，很多东西理上虽知，心念上并未真正生起。反过来，死下心念佛的人，业果、出离心等前行之心念多已相当坚固，而以念佛的入手方便，如果足够纯熟到契入实相，开启出我们自性中本有的根本智，那时其智慧就远胜于由书本、推敲而得来的。如果阅读古今大德的传记，就可以看到，许多高僧大德都是开始不识字，一心念佛或诵经持咒，功深开悟后，再由自性中开演佛法，辩才无碍，于经义通达无违。
    总之，我们这些读书人，凡事都好推敲一个理字，这也没什么不好，但如果学佛困在这个分别思维上，忽视实修法门，那就真是不如死心念佛的老太太了。


力争上游与拔苗助长

    力争上游与拔苗助长

    zf

    本人对您所问的某净土法门亦知之甚少。建议对此感兴趣者，最好下点功夫，深入了解此法门祖师在开创该门时的背景、该法门特别适于救度哪类根性的众生等。每一法门的提出，通常都有其特殊的背景，这一点其开山祖师心里最清楚。只要宗旨不违所依经典的根本意趣，都可成为适机学人的修持依据。问题往往出于后代门人，为使“本门”发扬光大，将适用于某一特定种姓众生的法门说成是“普适”的，更有甚者，将与此法门不一致的其他法门都贬为错误或无意义。这种态度最要不得。
    兄“力争上游”的精神本人赞叹，但若要求每一个求生净土的学人都如是力争上游，恐怕亦不现实。对那些以下品下生为此生目标的“不求上进”的学人亦不舍弃，恐怕正体现了阿弥陀佛的大慈大悲。回想自己学佛之初，亦曾将下品下生立为此生目标。“力争上游”者为“不求上进”者着急的心情是完全可以理解的，但切记不要拔苗助长。试想，即使下品下生者亦永出轮回，这同样是天大的喜事。


略谈因缘时节

    成军：
    大乘佛教的兴起，就是倡导利他行而不止于自修解脱。真修实证和利益众生矛盾吗？若离众生，有佛果可成吗？如果只是自修成就佛教就能发展，佛成道后为什么还要说法，而不直接入涅槃？
    佛法需要和众生结缘，需要普及和广泛传播。人间佛教所具备的贴近生活之特色，正提供了这样的方便。如果引导的好，完全可以成为接引众生学佛的方便。
    人间佛教存在的弊端，需要革除和引导。但是矫枉过正，全面否定人间佛教，试问你拿得出更好的在当代社会普及佛法的形式来？

    笨鸟：
    有一点不同意见。成军师兄好像都从佛教的需要这个角度考虑问题的。总感到佛法的发展应该是苦难众生们的需要。

    二麻子：
    鸟鸟小心些，这地方对错就差一点点……
    请注意。佛陀虽然大悲遍照，意欲救度一切众生，但佛陀说法却是对有缘众生说。也就是说，佛陀说法不是以众生苦的程度为说法不说法的唯一考量。
    佛陀到人道来说法而不是到地狱道就说明这点。
    鸟鸟小心你的悲情，那东西有时候很好，有时候会很危险，特别是它的危险被某些似乎伟大的色彩包裹着，不大容易看到。


菩提道次第和修学净土法门

    愿无畏：
    各位善知识：请教净土的问题。不肖在学习宗大师菩提道次第以前修学净土法门，现面临抉择：究竟应该在此土依止善知识生生增上，还是应该发愿往生极乐净土？净土最大吸引弟子之处为能疾得不退转，如龙树菩萨所说。但不肖愚痴，不明白若以教理抉择，何以往生净土会得不退转？修习大乘，最怕堕入小乘，不肖记得龙树菩萨所造某论指出，菩萨所惧非为堕落三恶道乃至地狱，而实恐堕入小乘，则佛果极为迂远，而生信发愿往生净土则可免此患，不知是否如此。不肖审查自身习气，自利作意是很重的，如此若在此土修学是不是容易堕入小乘，盖因境太苦故，若往生净土是不是对直入大乘更有利。另外，净土中有无声闻种姓的众生？若有，何以经中说净土众生皆不退转？
    恭请各位善知识慈悲开示，并请指点，除“极乐发愿文”之外，至尊宗喀巴大师另有哪些有关净土的著述？或其他历代格鲁巴传承祖师有何有关著作。

    念佛人：
    与师兄共同探讨：
一、不肖在学习宗大师菩提道次第以前修学净土法门，现面临抉择：究竟应该在此土依止善知识生生增上，还是应该发愿往生极乐净土？
    莲宗十三祖印光大师有言：“净土法门。乃十方三世一切诸佛。上成佛道。下化众生。成始成终之圆顿法门。以故等觉菩萨。已邻佛地。尚以十大愿王。回向往生。逆恶罪人。将堕阿鼻。若能称念洪名。即预末品。法门之妙。无以复加。”
    师兄此问，真是少有之问！
    等觉菩萨，尚且要求生西方。更何况我等？
    净土法门，无量法门。悉皆能入。此处不谈禅律台等宗。藏传佛教中有部分经典即是讲归极乐。如净土教言、阿弥陀佛修法极乐捷径等。据我所知，五明佛学院晋美彭措大法王发愿归极乐。藏地红白等教均是要归极乐世界的。师兄试想，大法王一定比我们更能深入宗大师的菩提道次第，亦要归极乐。我等初学末机呢？
    如果欲成就佛道。当效法文殊、观音、普贤等诸大菩萨。学祖师，亦求生极乐世界。

    二、净土众生皆不退转。
    天台智者大师《净土十疑论》中已将此问讲清楚，请师兄一阅：
    问：设令具缚凡夫得生彼国，邪见三毒等常起，云何得生彼国，即得不退，超过三界？
    答曰：得生彼国，有五因缘不退。云何为五？一者阿弥陀佛大悲愿力摄持，故得不退。二者佛光常照故，菩提心常增进不退。三者水鸟树林，风声乐响，皆说苦空。闻者常起念佛念法念僧之心，故不退。四者彼国纯诸菩萨以为良友，无恶缘境。外无神鬼魔邪，内无三毒等。烦恼毕竟不起，故不退。五者生彼国即寿命永劫，共菩萨佛齐等，故不退也。
    在此恶世日月短促。经阿僧祗劫复不起烦恼，长时修道，云何不得无生忍也？此理显然，不须疑也。

    三、愿与师兄共同深入教海。
    末学观师兄二问，均是对于净土一些基本的问题未能有所认识。称习净者多，实则深信切愿者少矣。
    小经中讲此法门莫非多善根福德因缘不能遇，师兄既有此善根福德因缘，何不珍惜此机会呢？可能是百劫、千劫、万劫难遇。黄念祖老居士对此曾讲到：
“这是百千万劫难遇。大家能够遇的就必须要把握这个机会，在今生解决问题。所以今天能遇到这个，过去多生多劫你都修了，修了半天你今生还只是这个样，你再这么转下去，转到哪天才能转出来啊？所以就下定决心，这一生解决问题啊。”
    依止祖师教法，老实念佛，莫换题目。以深信愿，师兄何愁不能带业往生。成就佛道。回入娑婆，度众生呢？
    南无阿弥陀佛。南无观世音菩萨，南无大势至菩萨。南无清净大海众菩萨。

    成军:
 愿无畏善知识这些问题很深，后学也不甚了知，以己浅见胡乱说几句。
    第一，您的道次第是依从哪位善知识学习？这类问题，最适合回答您的是您的根本上师，因为他最了解您的情况，也能观您的因缘。关于净土的问题，好像日常法师的讲广论的磁带里面也常提及，您可以找来学习。后学最近在网上也上传了rm文件。
    第二，后学以为，大乘和小乘，在道次上没有那么截然分明，也就是说，小乘是大乘的必要基础，如怖畏三涂苦与认知轮回是苦等，乃是大小乘共同的基础，非大乘行人就不需要或者不重视这些。
    第三，大小乘之差别，唯在菩提心。而凡夫发心，若尚未证空性，皆是世俗菩提心，尚非究竟，且烦恼不能调伏故，常有退转。若要真正不退，应该是证八地之后。因此，我们现在要做的，其实是如何迅速使世俗菩提心成就为胜义菩提心的问题。至于担心娑婆流转易堕小乘，后学觉得这没有必然联系，重要的是学佛的发心。
    第四，往生净土的道理其实很深，后学个人认为，大乘五道的资粮、加行、见道、修道都可以被涵盖在九品往生里面。而阿弥陀经里面，明白地写着：在极乐世界，阿弥陀佛和诸大菩萨在那里以殊胜的环境教导您修持三十七道品。
    因此，在净土所学其实和这里是一样的，因为诸佛的教法，本质无别。然而，娑婆人身因苦乐参半，容易发猛利心，故如果上根器人，可以迅速成就。极乐在积累资粮方面或许没有娑婆快，但因为远离三恶道因，不必害怕在轮回中退转迷失。
    个人情况不一，如何抉择当在您自己。藏地密宗行人，若不能即身成就，很多是发愿往生净土的。总之，业果不失，愿力不失，对于我们，现在最需要的是如何依止善知识，如何发起真实出离心，如何修习菩提心，如何修止观实证空性见。是否求往生，则看各人的愿力和因缘了。
    既然有人从娑婆往生，师兄焉知没有人从极乐回入娑婆度众生？何况净土行人，在此一生中，也可以以自己的愿行弘扬佛法啊。
    以上个人妄见，一定谬误很多，恳请各位善知识批评指正。
    另外请看徐进师兄的这篇文章：《发菩提心与五类往生》

    发菩提心与五类往生
徐进

    在格鲁派教授中，将往生净土分为五类∶
    一、以依止力往生。极度坚信三宝之威力，以赤诚至极故，心光互照，即凡心成佛心，故临终时诸圣现前，弹指即生。
    二、以厌离心往生。于此土浊恶心生厌离，无丝毫之留恋，但一心归投极乐导师，愿生安养。以愿心成熟故，与佛相应，故临终时净业现前，如蝉脱壳，自在往生。
    三、以现说菩提心往生。即历来大德所提倡的，为利众生愿成佛。而生净土，如进强化班培训，能迅速圆满我们的资粮，使我们的行愿不退。此“现说菩提心”，乃指发起愿菩提心。
    四、以证空性往生。如彼阿罗汉等，但欲回心，十方净土随愿即生。以不受三界缚故，心力自在故。（当然，除如来自证受用土，如密严等，非大菩萨不得与会）此证空性往生，非唯阿罗汉有分，诸证少分空性者，亦增往生之力也。因此可见，证空性之力量，亦是修行人生净土之正因。如来在余经中，亦说以禅定力助生净土，（如修安般法成就，亦可亲睹极乐界，往生自在）即此谓也。
    五、成就自证净土往生。如文殊、普贤，方便示现，往来无碍也。十方诸佛亦复如是，未曾离净土。又，修密乘之行人，得最极成就，往生自证净土也。如密勒尊者即是。
    据此，可知诸圣所言，皆无违也。汉地祖师大德，多强调欲生净土，则与此土不可生丝毫贪恋心，而于西方净土，生强烈之意乐心。藕益大师云∶“取舍若极，与不取舍，亦不二也”。此即欲使众生乘厌离心、信心往生也。又，净宗诸祖大多强调，从信他到信自，从事即达理即，此即“依止力”、“空性”之修证也。至于“往生安养，得诸忍已，即回娑婆”，宛然现说菩提心也。至于自成就净土往生，显然属于净土之果乘，不在我等初学者探讨范畴。我等只需信乐奉受而已，如宗大师所言，要“仰推圣境非我知”。窃以为，就大乘行者而言，因以菩提心和空性见为往生正因，但前二者是当然基础，又是接引众生之方便。故印光法师有言∶往生西方净土的妙处，有很多被不识字的愚夫愚妇得了去。这是指利用依止力和厌离心，方便摄受众生归入净土。

    在《大宝积经·发胜志会》（即《发起菩萨殊胜志乐经》）中，佛还说过，成就以下十种心中的任何一种，即可往生西方净土。哪十种呢？是∶

    一、于诸众生起大慈无损害心。
    二、于诸众生起大悲无逼恼心。
    三、于佛正法不惜生命乐守护心。
    四、于一切法发生胜忍无执著心。
    五、不贪利养恭敬尊重净意乐心。
    六、求佛种智于一切时无忘失心。
    七、于诸众生恭敬尊重无下劣心。
    八、不著世论于菩提分生决定心。
    九、种诸善根无有杂染清净之心。
    十、于诸如来舍离诸相起随念心。

    佛说，成就以上十种心中的任何一种，欲生极乐而不能者，无有是处。仔细思之，确实，这十种心任何一种，都不易成就，要成就，都少不了出离心、菩提心、空性见。而信心则是基础，不言而喻。因此，窃以为，我等初机学人，首先要从真正依止三宝做起，然后依三主要道努力修学。而要真正依止三宝，就必须从破我执、我慢入手，于凡夫习气做彻底决裂。要知道，带着我执我慢，是无法生起真正的出离心的，更何况是慈悲心、乃至菩提心。因为有我执，于众生则有亲疏，有爱见，不可能平等，经云∶“于诸众生生于爱见悲者，心则疲倦”。这是不可能发起净菩提心的，而且容易堕落。在《诸法无行经》中，释尊和文殊菩萨都谈了自己往昔世曾堕恶道的经历，而其根本原因，就是因我执、我慢障碍心故，不能见清净妙谛，于无倒宣说之佛法起于嫌恨、诽谤。
    其次，窃以为，往生净土需要“博闻专修”。博闻，则于诸佛理深广探求，不易偏颇；专修，则心力归一，见效甚大。现在不少宏扬净土者，悲心迫切，然方法似嫌不尽圆融；以贬斥他宗，专显己胜，来引发众生信心。故有提倡抛开一切经论、专提一句或一经之说。其实各派互不相违，但因众生根器、因缘不同而现差异。如来于各经中悉皆赞为第一，何以故？以诸佛妙理无边际故，缘起相应难思议故，平等法中离高下故。《四十二章经》云∶“汝等比丘知我说法，犹如食蜜，中边皆甜”。《楞严经》云∶“归元性无二，方便有多门”。李炳南老居士也提倡博闻，以圣言量为依，能远离凡夫见地，开真智慧。
    再者，何谓“专”？窃以为，并非寡闻、寡行为专；心无杂染为专。如果我们心中夹杂着太多的贪嗔痴慢疑，夹杂着太多的我执我慢，那么无论修什么胜法，欲求不退尚且难免，何况成就？嘉华仁波且曾开示说∶修密法之忿怒本尊者，如果背离了慈悲心、菩提心、为众生而求正觉的心，那么其所持诵的威猛密咒则会使其变为凶残的魔鬼。在藏地，有忘失菩提心，修大威德法，最终以本尊身相入于地狱者。我等宁不慎乎？
    最后，末学认为，净土能否往生，首先要看是否具有清净意乐；一者，无论修什么法，只要心中念念回向净土，则为专修、实修。二者，不破我执，心陷于污染，净业难成。其次，往生关键是心力是否具足。如果临终时往生净土之愿心所成就之善业，小于其余先成熟之恶业，恐难离开娑婆。这就要求我们从当下做起，不能有丝毫的忪懈，以期早日得到把握。
    以上片语，为末学臆想，请网上善知识多予指点，亦令我等后生能日有所进。


众聚法与大小师

    小千：
    净行品中有两句没读明白。
    一、“舍众聚法”是什么意思？舍离众会，聚入法会吗？
    二、“诣大小师”中的大小师，是不是指出家四众的沙弥（尼）和比丘（尼）？
    请诸位仁者赐教，谢谢大家。

    齐愍：
    大方广佛华严经疏　净行品（唐　澄观撰）：初睹众会。谓众聚多谈无义故。愿说深法众心易乖故令和合……
    大方广佛华严经初发心功德品：此初发心菩萨，不于三世少有所得，所谓若诸佛，若诸佛法，若菩萨，若菩萨法，若独觉，若独觉法，若声闻，若声闻法，若世间，若世间法，若出世间，若出世间法，若众生，若众生法，唯求一切智，于诸法界心无所著。
    华严五十要问答初卷　唐智俨集：十三大师小师义。二地摄生戒释……问。大师及小师差别云何。答。依小乘教和上为大师。阇梨为小师。佛非大师非小师。依三乘教佛为大师。余者并为小师。何以故。若小乘人别位制入无余涅槃果故。权于下位立大小师。一乘大小师。依理为正耳。非由相事也

    佛学常见辞汇（陈义孝编）：【和尚】吾师的意思，僧徒对其亲教师的尊称。
    佛学大辞典（丁福保编）：【阇梨】　（术语）阿阇梨之略。僧徒之师也。其义为正行。谓能纠正弟子品行。又谓之轨范师。以其能为弟子轨范也。梨亦作黎。寄归传曰：“梵语阿遮黎耶，唐言轨范，今称讹略。”

    zf：
    在下还要说几句。

    “一、“舍众聚法”是什么意思？舍离众会，聚入法会吗？”
    ──宣化上人讲述的《华严经净行品浅释》对此句的解释是：
众会聚集　当愿众生　舍众聚法　成一切智
    众会聚集：大家有的时候在一起聚会，或者有什么事情来开会，在这时候也应该发愿，发什么愿？就当愿众生，舍众聚法：把一切聚集这种法，也不执著了。不要执著这一切，你能舍众聚法，就能成一切智：佛法，你就因为有执著，才没有一切智慧；你要是没有执著了，一切智慧自然就现前了。
    可见这里的众聚法是“众因缘和合聚起之法”的意思，即我们通常所说之缘起法。“舍众聚法”的意思就是要我们去除对众聚法的执著、贪著，如《金刚经》云“一合相者即是不可说，但凡夫之人贪著其事。”

    “二、“诣大小师”中的大小师，是不是指出家四众的沙弥（尼）和比丘（尼）？”
    ──宣化上人的解释是：
诣大小师　当愿众生　巧事师长　习行善法
    诣大小师：诣，是到那个地方；造诣，就是往那个地方去。往什么地方去？大师，往大阿阇黎、大轨范师；小师，或者普通的法师，不够大阿阇黎这个资格，不是大和尚，是小师，就是普通的。当愿众生：这时候也要发愿了，要发什么愿？要巧事师长：巧事也就善事，善巧来侍奉师长。习行善法：要习学来修行一切的善法，不要修行一切的恶法。你修习一切的善法，这就是听善知识的教，不要听恶知识的教。

    我国唐代的智俨大师在《锲华严五十要问答》中对此的解释是：
问。大师及小师差别云何。
    答。依小乘教和上为大师。阇梨为小师。佛非大师非小师。依三乘教佛为大师。余者并为小师。何以故。若小乘人别位制入无余涅槃果故。权于下位立大小师。一乘大小师。依理为正耳。非由相事也。

    在下对大师这一开示大意的理解是：在小乘教中和尚为大师（和尚为受戒者之师表），阇梨为小师（矫正弟子们行为的比丘），而佛既不是此处的大师也不是小师。在三乘教中（一声闻乘，二缘觉乘，三大乘），佛为大师。二乘圣者为小师。因为小乘人的趋向是身智皆灰灭之涅槃，不及大乘之无住涅槃，故有大小师的差别。


是法平等，无有高下

    是法平等，无有高下

    zf

    向禅地衣挑战！
    在下有五位兄弟，其中四位名字分别叫“净地衣”、“密地衣”、“天台地衣”和“华严地衣”。
    这四兄弟虽然都叫“地衣”，但对谁是真正的“地衣”却争论有年，至今未有定论。
    今见禅兄亦名“地衣”，四兄弟决定联手向禅兄挑战——禅兄有何德能，胆敢与净、密、天台、华严四位英雄争“地衣”？
    禅地衣兄说：“禅宗是护持一切文化各正其用的非政府智囊僧团，禅者是没有是非心却协调一切的批判者……从前祖师感叹，大唐国里无禅师，不道无禅，只是无师。禅是佛心，佛法住世，必有禅法……遇到真禅师，言下能帮行人透过义理直觑修行面目”
    看到禅兄的“应战”，净、密、天台、华严四兄弟面面相觑，四兄弟停战，互相谓言：难道只有他自己是“非政府智囊僧团”，我们都是“政府智囊僧团”不成？不过禅兄所说之“遇到真禅师，言下能帮行人透过义理直觑修行面目”这却是我等不争的事实，但仅凭此点就自认为是真正的“地衣”，我等不服！
    于是，四兄弟各亮出自家的独门绝活。
    净地衣说：……以果地觉为因地心……；……为圆顿教法中的捷径……万修万人去……三根普被，利钝全收……末法时亿亿人修行罕一得度，唯此法门可靠……
    密地衣说：……龙树菩萨开南天竺铁塔……灌顶，……三密……即身成佛……气脉明点……大手印……大圆满……虹光身……
    天台地衣说：……智者大师……法华三昧……三谛圆融……一乘圆教……天台三大部……次第分明……
    华严地衣说：……华严为经中王……取自龙宫……杜顺大师……五教止观……六相十玄……理事无碍……事事无碍……一即一切，一切即一……
    就在四兄弟陶醉于自家绝技，都认为自己才是真正“地衣”的时候，在下的另一位兄弟终于开口说话。（别忘了，在下共有五位兄弟，净地衣、密地衣、天台地衣和华严地衣只是其中的四位。）这位兄弟名叫“法评等”。
    法评等说：你们几位兄弟的看家本领都很高强，并各有特点，但谁也替代不了别人，怎么可能分出个“地衣”“地二”来呢？这是明眼人公认的结论。我这里特别想提醒你们几位的是，应仔细反省一下自己争“地衣”背后的心理，是否有某种变形的“慢魔”在作怪！此魔法力甚强，稍不留神便被其缚，当心当心！！！
    净地衣、密地衣、天台地衣和华严地衣闻听法评等所言，沉默不语，若有所思。
    禅地衣兄，您意下如何？？？


瑜伽士和般智达

瑜伽士和班智达

    瑜伽士和班智达

    二麻子

    瑜伽士和班智达是藏地对两种佛门修士风格的说法，走瑜伽士还是班智达的道路，这里要点不在于是具体根据什么择定，而是对于我们福慧资粮不够用的学人来讲，没法兼顾时就不得不有所顾不上。这时候，其实择哪条都是正常的。
    瑜伽士的常识经验等也是不离正闻的。三宝子兄提出的期望／要求等都是好的方向，自己做的不够的尽量去补。一时补不上的，发愿慢慢补也就是了。
    “饱学”的目标甚不容易呢。嘻嘻。一般地来说，具有正确的常识性，经验性还具备“饱学之士”特点的人物，大概很有可能是菩萨化身。普通人要做到大概不容易。当然就是因为不容易，才应该是我们学习的目标呀。
    当然，就个人来说，如果不能同时具备上述三者的话，麻子宁可有常识，有经验，不愿意没常识没经验空读书。


莫说密法，就是显乘也是非机不说

    asu：
    所谓的双修，是否属於正宗藏密的范围？

    zf：
    插一嘴，听说

    一、听说，无上密部有佛父佛母双运的修法；
    二、听说，对成佛来讲这种修法不是必经之路；
    三、听说，对某些根性的行人，这种修法并不是最有效的。

    asu：
    我个人认为，佛教是宇宙、人间的真理，应该没有什么忌讳的。真理也一定不是模糊的，一定是“一就是一，二就是二”，“是就是是，不是就是不是”，本着这个态度，我希望能就这个机会来讨论一般佛教徒回避的这些问题。

    zf：
    asu兄，如来对于真理的态度并不是如兄所说毫无忌讳的，决定因素取决于对众生的利害。莫说密法，就是显乘也是非机不说。
    在法华经中，如来下面的开示值得仁兄深思：
    汝舍利弗　　我此法印
    为欲利益　　世间故说　　在所游方
    勿妄宣传　　若有闻者　　随喜顶受
    当知是人　　阿鞞跋致　　若有信受
    此经法者　　是人已曾　　见过去佛
    恭敬供养　　亦闻是法　　若人有能
    信汝所说　　则为见我　　亦见于汝
    及比丘僧　　并诸菩萨　　斯法华经
    为深智说　　浅识闻之　　迷惑不解
    一切声闻　　及辟支佛　　于此经中
    力所不及　　汝舍利弗　　尚于此经
    以信得入　　况余声闻　　其余声闻
    信佛语故　　随顺此经　　非己智分
    又舍利弗　　憍慢懈怠　　计我见者
    莫说此经　　凡夫浅识　　深着五欲
    闻不能解　　亦勿为说　　若人不信
    毁谤此经　　则断一切　　世间佛种
    或复颦蹙　　而怀疑惑　　汝当听说
    此人罪报　　若佛在世　　若灭度后
    其有诽谤　　如斯经典　　见有读诵
    书持经者　　轻贱憎嫉　　而怀结恨
    此人罪报　　汝今复听　　其人命终
    入阿鼻狱　　具足一劫　　劫尽更生
    如是展转　　至无数劫　　从地狱出
    当堕畜生　　若狗野干　　其影[乞*頁]瘦
    黧黮疥癞　　人所触娆　　又复为人
    之所恶贱　　常困饥渴　　骨肉枯竭
    生受楚毒　　死被瓦石　　断佛种故
    受斯罪报　　若作馲驼　　或生中驴
    身常负重　　加诸杖捶　　但念水草
    余无所知　　谤斯经故　　获罪如是
    有作野干　　来入聚落　　身体疥癞
    又无一目　　为诸童子　　之所打掷
    受诸苦痛　　或时致死　　于此死已
    更受蟒身　　其形长大　　五百由旬
    聋騃无足　　宛转腹行　　为诸小虫
    之所唼食　　昼夜受苦　　无有休息
    谤斯经故　　获罪如是　　若得为人
    诸根闇钝　　矬陋挛躄　　盲聋背伛
    有所言说　　人不信受　　口气常臭
    鬼魅所著　　贫穷下贱　　为人所使
    多病痟瘦　　无所依怙　　虽亲附人
    人不在意　　若有所得　　寻复忘失
    若修医道　　顺方治病　　更增他疾
    或复致死　　若自有病　　无人救疗
    设服良药　　而复增剧　　若他反逆
    抄劫窃盗　　如是等罪　　横罗其殃
    如斯罪人　　永不见佛　　众圣之王
    说法教化　　如斯罪人　　常生难处
    狂聋心乱　　永不闻法　　于无数劫
    如恒河沙　　生辄聋哑　　诸根不具
    常处地狱　　如游园观　　在余恶道
    如己舍宅　　驼驴猪狗　　是其行处
    谤斯经故　　获罪如是　　若得为人
    聋盲喑哑　　贫穷诸衰　　以自庄严
    水肿干痟　　疥癞痈疽　　如是等病
    以为衣服　　身常臭处　　垢秽不净
    深着我见　　增益嗔恚　　淫欲炽盛
    不择禽兽　　谤斯经故　　获罪如是
    告舍利弗　　谤斯经者　　若说其罪
    穷劫不尽　　以是因缘　　我故语汝
    无智人中　　莫说此经


学《最上乘论》之前要考虑的几个问题

    学《最上乘论》之前要考虑的几个问题

    智行

    在下钝根，不过有几个看法和问题说出来供参考。
    问题一、既然师兄想找“最上乘”，成串之贴中，为何所引之文没有一篇佛经？佛如何说“最上乘”，如何疾趣“最上乘”。若无佛言之“最上乘”，则恐怕会影响学人信心。
    问题二、怎样理解论中所言“自性圆满清净之心。此是本师。乃胜念十方诸佛”。为什么《文殊师利所说般若波罗蜜经》乃用念佛入“最上乘”，在许多其他经典里也是用念佛入“最上乘”，华严经有十地菩萨，始终不离念佛之说，难以枚举。净土的经典就更不用谈了，无量寿经说念佛是诸佛如来无上之法，大集经谓念弥陀是无上深妙禅。这些经文和这段论的文如何取舍，或作二头揉合？
    问题三、您如何理解“答曰：常念彼佛不免生死。守我本心则到彼岸”。有何为经文的佐证？古今念佛往生极乐者多多，是不是“免生死”？四十八愿度众生度到哪里去？
    问题四、您如何理解：“守我本心则到彼岸”。若真识“本心”，则法法皆禅，念佛（持咒义同）何异“守我本心”？若未识“本心”，守个什么心？
    问题五、“守心”之法中，此心与境界是相逢还是不相逢？若相逢，则佛乃诸境中之上上境，云何“守心”和“念佛”有异？若不相逢，则心境双隔，是死寂境界，是无想天人、断灭外道、或定性二乘所求，云何成“最上乘”？若再强论“心境非一非异”，则心佛亦非一非异，云何“守心”和“念佛”有异？
    提这些问题供思考，主要针对文字中“守心”和“念佛”背后的意义，通常我们很容易忽略背后的意义，故误用文字。师兄觉得如何？


法无高下，挑自己能用得起来的方法实修就好

    zwz0099：
    有一天看到临济涅槃偈觉得很似自己的心境：“沿流不止问如何，真照无边说似他，离相离名人不禀，吹毛用了急须磨。”如今我觉知妄想后便死死地看住，有时对大妄念则分析它的根源并起一意识对治，除此之外便是发宏愿、一心持四字宏名，再就是吃饭睡觉，如是而已。
    说白了我觉得学佛越学越简单了，主要是时时观心念佛。请给我指正一二、敲打一二。

    zf：
    指教的不敢，建议的几条。禅师们之证悟高深，师兄觉自己心境与之相近，这里马虎不得。建议师兄亲找公认之禅门大德印证，或广读经论印心。
    “如今我觉知妄想后便死死地看住，有时对大妄念则分析它的根源并起一意识对治，”
    这无疑是修行中某一阶段中的用心方法。但经中还有“知幻即离，……，离幻即觉，……”及观照妄念本身即是如来全体大用等用心方法。法无高下，挑自己能用得起来的方法实修就好。
    “除此之外便是发宏愿、一心持四字宏名，”
    虔发菩提大愿乃修行的根本，普贤行愿品能日日读诵最好。持名发愿往生极乐最为稳妥，到了极乐后没什么问题解决不了。
    “再就是吃饭睡觉，如是而已。”
    慢慢尝试着去体会吃饭睡觉与菩萨行愿之不二不别。
    几点建议，谨供参考。


怕的是永远等明天

    怕的是永远等明天

    二麻子

    谨复如下……

    “我想请问在家能否广学经论？”
    ──当然能，尽力学。法门无量誓愿学。

    “我是在家人，只皈依过。是否能有次第地学习经论？”
    ──随喜佛子发心，当然能而且也只能有次第的学经论。

    “另，如果可以，以什么次第学习，可否告知课程顺序？”
    ──这个比较复杂。汉藏各个宗派都有不同的次第设置。但大致上说，都是出离心，菩提心，空性正见为基础。具体怎么做，要看你自己慢慢发展，趣向与你因缘紧密、契机的方向。

    “二十多岁接触佛法，现今三十多了，今生看来要闲过了。”
    ──噢，还有好几十年吗。真要学是来得及的。怕的是永远要等到“明天再开始”。所以，不想闲过那就现在开始吧。

    “能否赐教？请示”
    ──不敢，佛友互相交流。


谈“空”

    悟空：
    有时候我想人生不过是一场空，然而如果真的是那样，人生究竟为何而存在？又该怎么样去度过呢？名为悟空，实难悟空。

    净安：
    悟空善知识这个问题其实非常好，在很多初机学佛的同修中都可能存在类似疑问。虽然迟了一些，后学还是想对此谈点自己的想法，也正好借此计划请论坛各位大德指正。
    佛法谈空，和普通人讲的空，并不完全相同。首先，佛法里面说的空并非没有，而是指“无自性”。简单说，就是事物都是因缘（其他条件）而生，并不存在任何恒常不变的体性。因此佛法用得更多的词，是“空性”、“空相”，以表达事物这种因缘而生、了无自性的体性。
    这个道理，就是佛法的根本道理——缘起性空。另一方面，佛法在空性的前提下也不否认因缘假有的存在，并且特别强调业果的真实不虚。因此，佛法对于空有关系的把握，是建立在缘起中道的基础上的，即不落我见和恶趣空两边。对自我的执取是我们众生长期的“习惯”性思维，固然积习难返；而片面说空，否定因果则是修行路上一个非常危险的陷阱。
    回过头来，谈谈佛法对于人生的态度。佛陀虽然实证了缘起性空，但是并没有因为诸法空性而立即入涅槃。而是辛辛苦苦为度众生劳碌说法了40多年，指引众生离苦得乐，这本身就是对于缘起中道的生命实践。
    因为虽然诸法无自性，但是对于无始以来一向认假为真的众生——我们，在空性之上所幻化出的缘起假有给我们带来执著与痛苦又是那么的真实！
    依照佛法的中道，人生的意义和解脱，在于实证诸法缘起性空的真相。一方面，因思维和实证无常无我的道理，生起出离心，了知轮回是苦，希求迅速出离轮回，以空性的智慧自己解脱。再进一步，由性空故，了知我与众生本来平等，众生的痛苦也就是我的痛苦；因缘起故，思维众生都曾经是我的父母亲眷。因此发愿令一切众生离苦得乐，成就佛陀的智慧功德，即发菩提心。同时，因空性故，于无尽的菩萨道度众生事业中不生厌倦，因为实无众生可度。
    出离心、菩提心，都是要建立诸法无我的空性见的基础之上。明代西藏宗喀巴大师把这三条概括为学佛的三主要道，其详细的解释可见于成军主页的道次第专辑。
    最后，概括成一句：因为缘起性空，我等当学佛修行，悲智双运，于自利利人中而得究竟解脱利乐。

    gentleLion：
    仁兄所言对小弟启发甚大，因此小弟借此和仁兄交流一下。

    仁兄说空是无自性，小弟同意，不过仁兄又言：“就是事物都是因缘（其他条件）而生，并不存在任何恒常不变的体性。”
    这个是小乘里说的无我空，空性的还有一个更为重要的意思是相对而存的无自性的空。比如能见与所见，能觉和所觉，其中见性与觉性均是如如不动，但亦无自性，何以故？能所相生，故具无自性，但有假名，亦是幻亦是空。不知仁兄如何看？
    仁兄言：“回过头来，谈谈佛法对于人生的态度。佛陀虽然实证了缘起性空，但是并没有因为诸法空性而立即入涅槃。而是辛辛苦苦为度众生劳碌说法了40多年，指引众生离苦得乐，这本身就是对于缘起中道的生命实践。”
    涅槃非涅槃相，故不存在有入涅槃之说，但有假名，实无出入，若言有出入，即还是持轮回心，不名涅槃。圆觉经中已经说了很多，佛提醒后世众生修大乘者多因著人我众生寿命相，因以有所得故，虽经累劫修行，不能成就究竟涅槃。消除无明，即［见］涅槃。
    “譬如病目，见空中华及第二月，善男子，空实无花病者妄执，由妄执故，非唯惑此虚空自性，亦复迷彼实华生处。由此妄有，轮转生死，故名无明。”
    “善男子，此无明者，非实有体，如梦中人，梦时非无，及至于醒，了无所得，如众空华灭于虚空，不可说言有定灭处。何以故？无生处故，一切众生于无生中，妄见生灭，是故说名流转生死。”……
    “善男子，此菩萨及末世众生，修习此心得成就者，于此无修亦无成就，圆觉普照，寂灭无二，于中百千万亿阿僧只，不可说，恒河沙诸佛世界，犹如空华，乱起乱灭，不即不离，无缚解脱，始知众生本来成佛，生死涅槃犹如昨梦。”
    “善男子，如昨梦故，当知生死及与涅槃，无起无灭，无来无去，其所证者，无得无失无取无舍，其能证者，无作无止，无任无灭，于此证中，无能无所，毕竟无证，亦无证者，一切法性平等不坏。”……
    “善男子，一切障碍即究竟觉，得念失念，无非解脱，成法破法，皆名涅槃，智慧愚疑，通为般若，菩萨外到所成就法，同是菩提，无明真如，无异境界，诸戒定慧及淫怒痴，俱是梵行，众生国土，同一法性，地狱天宫，皆为净土，有性无性，齐成佛道，一切烦恼，毕竟解脱，法界慧海，照了诸相犹如虚空，此名如来随顺觉性。”
    仁兄请看仔细这段，涅槃非有涅槃境可入。如来所说法无实无虚，非习惯思维所能亲证。这最后一段亦非像现代禅学人们所言，仅仅表现出大乘的“胸襟”是多么广阔。决非此义！而是其不解一切法性平等无差，生死涅槃尤如昨梦之义，佛法靠心印，以觉悟故成就佛心，不复以世俗心轮回心去修饰，揣度，妄有一涅槃境可入。欲离世觅佛法。

    法日：
    天堂地狱实非有，
    生死涅槃无二般。
    迷时八万四千法，
    觉后空空无大千。

    净安：
    后学觉得，大小乘在缘起无自性上，是一致的。即使小乘行人，欲证罗汉果位，也一样需要破能所。见楞严经中诸圣者的证道经历。大小乘各宗在人无我上，必然是一致的，否则就是外道啦。但是在界定胜义谛和世俗谛以及二谛关系上面，在对于外境和内识是否实有上，则有差别。
    师兄这个问题，似乎涉及到如何在诸法无我的基础上安立缘起假有。假名无自性，不难理解。但是对于能缘背后的内识和所缘的外境之间关系，如果讨论下去，牵扯极多，后学自己也没有完全搞清楚，就此打住。法尊法师有几篇文章论述此义，甚好，就是比较难读懂。
    四果罗汉，灰身灭智，确实可以入灭尽定而不在轮回流转。八地菩萨，如果非诸佛劝请，立刻也就会入于涅槃。此涅槃虽然在成佛究竟解脱道路上还是化城，但已经不在轮回之中了。后学上面说的，即是此义。


谈谈“如实观”

    谈谈“如实观”

    智行

    后学九年前曾涉猎兄所说的“如实观”，此如实观并非南传独有，在北传它是基础的一部份。如实观之四念处，核心是观心，观心有立旨与不立旨二种，各有妙用。立旨者（如观心无常）对治粗重邪见十分有力，重在慧门。不立旨即如实观，重在定门，禅宗观心法门与天台体真止即基于此，不同的是宗门教下都有入、住、出三阶段，“出”为向上处。后学所见某些“如实观”只有“入”与“住”，但没有“出”，兄是否注意过？楞严二十五圆通法中，如实观之四念处是其中四法，兄所言“安般法”亦其一也，望细研楞严。另外许多静坐法与此四念处同，汉地并不陌生，藏传佛教亦如是，但用法与语言彼此不同。禅宗观心法门古来常用，近代多用参话头，虚云老说观心法门于今人根器稍嫌不契。愚揣虚老指今人染重，观心多随境转或易入无记，故言稍嫌不契，当然也有很多例外。
    北传教法甚多，不似南传单纯。“如实观”几乎是南传禅修之主体，在汉地，楞严二十五圆通法中，“如实观”在数量上只占4／25，份量上又远不及耳根圆通及念佛圆通。所以在汉地单纯的“如实观”占的分量较轻。但是“如实观”精神处处可见，耳根圆通即是“如实”听，“听”即是用耳根观，用耳根观乃本于佛说此界众生耳根最利。又“如实”听世间音声又不如“如实”听念佛，即用利根，又用佛力加持，其妙无比，此为净宗所秉之“念佛圆通”也，密宗“如实”听咒又有何异？交光大师释楞严（编按：《大佛顶首楞严经正脉疏》）用“舍识用根”亦“如实”，正本“如实观”也。北传之“如实观”可说是精神不变。
    禅观中如有通教道品部份，本可通别圆，但若无人说，死执其境界为究竟，则不能入。兄疑大乘行人能否都能入不二法门，答案是只要肯学，最终都能达到，十方佛与大菩萨皆如是，但不定一生成就。兄为何以此自疑？难道个个修“如实观”者都能证果？不如是，难道兄就不修“如实观”了吗？三大阿僧祗成佛与即身成佛并无矛盾，只是“佛”字含义不同，请看天台六即佛义可知。净宗“一生补处”是经中明言。恕后学直言，师兄对净宗经论十分陌生，而净宗似浅而实深，切莫轻视。
    师兄想一想，您才学十个月，怎么能评断佛法？后学觉得您太轻易相信依赖几位现代人的知见，而久经历史考验的传承反而变成您评判的对象，您不觉此中有大问题吗？兄喜欢“如实观”，不妨先修修看，有成就后可来弘法，但不要轻视别宗。北传每一宗都够吾辈学一辈子（学也学不完）。另外，以不二法门判大小乘之来由，待师兄想真正了解时我们再继续讨论，不然浪费彼此时间。


四念处观的深浅

    四念处观的深浅

    智行

    天台宗三十七道品中，对一一道品都有藏、通、别、圆四种浅深释法。例如四念处，依意识“观身不净，观受是苦，观心无常，观法无我”，为生灭四念处，此为藏教道品“四念处”（此“藏”非西藏之“藏”）。此最浅四念处观者，初入手时起对治妙用。根性稍好者可直入通教道品之“四念处”，即随缘如实观身受心法，见身受心法本来无生。
    身受心法虽无生，不住无生，无生不妨无量种生，本无生今无灭，此别教“四念处”。身受心法本来无作，于生死中不见生死可得，修一切善法不见法有生灭去来，生灭去来本是真如妙用，不碍真如，但离一切幻执，即如诸佛，此为圆教道品之“四念处”。智者大师有著作专讲此四种四念处。
    天台讲四谛十二因缘即一切法门亦有藏、通、别、圆四种。后学觉得南传教义不出天台藏、通道品，后学尚未见南传诸师宣说对别、圆见地，兄见否？若见过，赶快告诉一下。兄言““大乘禅定”，其实都属“声闻乘禅定””，恐是照搬他人谬解。大小乘区别在“不二法”上。不论南传北传何宗何人，依不二法即大乘，依二法即非大乘。二法者，处生死中不得涅槃，处涅槃不能入生死，此入小涅槃，道力有限，称为小乘。不二法者，处生死中不碍涅槃，处涅槃不妨入生死，此入大涅槃，道力无限称为大乘。兄宜自省所学法中有此不二法否？


如何避免持诵为主修时乐着世俗的趋势

    如何避免持诵为主修时乐着世俗的趋势

    善惠

    在大方等大集经月藏分第十四月幢神咒品第一卷中，我们可以领略到世尊如是教诲：
    “惟依读诵欲求阿耨多罗三藐三菩提者。是人多歖着于世俗。
    以世俗故尚不得调己心烦恼。何能调伏他人烦恼。善男子善女人。乐着读诵求菩提者。便有嫉妒求名利。富贵高心自是轻慢毁他。以自高故。尚不能得欲界善根。何况能得色无色界一切善根。又不能得声闻菩提。何况能得辟支佛道及无上菩提。”

    确实，乐着于世俗是不能成就菩提的。在大方广菩萨藏文殊师利根本仪轨经一切法行义品第十五中，佛陀向文殊菩萨宣讲诸持诵人须修定业：
    “妙吉祥童子汝所求。我说彼世间善恶之事及诸法要。但为利益一切众生。过去诸佛亦同所说。可使未来佛种不断。若持诵者于此所说一切智力。深生信重精进无疑。所行之行同一切智智。
    若持诵人于过去世。曾作诸恶业障未尽。而于今生所作事业不成就者。当依诸佛所说悔法至心忏悔。必得业障除灭。复更依法修行速得成就。或是愚迷之人。轮回业重不能依法忏悔修行。
    所作所求不能成就。于诸有情无由利乐。又复诸持诵人须修定业。若不修定不能趣入解脱之门。若能修定与法为缘。决定解脱速证菩提。”

    如果我们回忆一下净宗的经典的话，我们会很容易想起大佛顶首楞严经大势至菩萨圆通章，大势至菩萨位居等觉，楞严会上佛陀邀请诸声闻菩萨众各陈悟入之门时，菩萨言道：
    “大势至法王子。与其同伦五十二菩萨即从座起。顶礼佛足而白佛言。我忆往昔恒河沙劫。有佛出世名无量光。十二如来相继一劫。其最后佛名超日月光。彼佛教我念佛三昧。譬如有人一专为忆一人专忘。如是二人若逢不逢或见非见。二人相忆二忆念深。如是乃至从生至生。同于形影不相乖异。十方如来怜念众生如母忆子。若子逃逝虽忆何为。子若忆母如母忆时。母子历生不相违远。若众生心忆佛念佛。现前当来必定见佛去佛不远。不假方便自得心开。如染香人身有香气。此则名曰香光庄严。我本因地以念佛心入无生忍。今于此界摄念佛人归于净土。佛问圆通。我无选择。都摄六根。净念相继。得三摩地。斯为第一。”

    都摄六根、净念相继、一直是净宗的念佛法门修持的核心，如佛所宣诚实之言，决定解脱速证菩提。持诵如此，观想亦然，佛法中教授念佛三昧之经甚多，贴也贴不过来，从略。


学经论的闻思修

    齐愍：
    专业的学习一些大论，如果是我自己从有限的一点经验出发来学，觉得应该选择先花一点时间观其大要，然后一样样试过来。举一个阿毗达摩中的例子，我没有能做过很深入的禅定，那么对于这里面的诸家里的精细分别，我就暂时不会去做看的仔细计划，而是尽量多为打坐多多的准备一些。
    个人看法，光是有常识上的正见或许是不够的，比较成功的论的写作大多是前贤为已经有一定的基础佛教修行经验的人，导入经的修习而做的，问题明显的是这一部分前期经验显然对于学习起到相当的作用，对于基本教法的所指应该有起码的明确认知。然后作为大乘学人，至少应该有一个天天修习的法，乃至最简便易行的是持个佛号或者真言，花一些时间把经论中所学到的在修念中发挥出来。

    幻来：
    末学关注的是闻思修的一体化问题。只有正闻熏习（闻）、如理作意（思）为先导，才有真实的法随法行（修）开展的可能。当然，这样的区分是逻辑性的，并没有时序或发生学上的意义。三者实际上相辅相成，在任何阶段三者缺一不可。因此，您说的修法在任何阶段都可以并行无妨，本人亦是这样做的。


学习随念和现观庄严论、华严

    静风：
    学习随念参考一下现观庄严论的六随念更好些，这个六随念是般若经上的，弥勒菩萨在现观总结出来的。是渐次加行（相当于道次第）的内容。
    我自己的理解是，菩萨正修的次第是六度法。平时随念的是六随念：随念佛，随念法，随念僧，随念戒，随念天，随念舍。这中间贯穿了最后一个次第：通达无自性。六度＋六随念＋通达无自性，这13法是弥勒菩萨对于菩萨修行的次第方面的总结。

    齐愍：
    令人欢喜，随念是佛教的基本教法，因为汉地有契经相当完整的方便，如增一阿含经的开头即讲了十随念及一部分实修，故颂文曰：“佛法圣众念，戒施及天念，休息安般念，身死念在后”。

    静风：
    是……这个随念的教授的确很多地方有，你说的阿含经上的我也见到过。道次第里也有六随念。另外每次受八关斋戒的时候，法师也经常会讲解六随念。不知道是出自哪里。法尊法师翻译过一个《随念三宝经》也很好，现在汉地有流通，并不很长。我个人觉得随念三宝是一定会有的，其他的还有多少随念在不同地方都稍微有些不同。弥勒菩萨把六随念和六度连起来讲，我个人理解可能稍微有点正行六度，平时六随念的感觉。这个味道比单独讲随念也许理解起来更完整些把。

    齐愍：
    哦，花了一点时间去看了一下颂文，个人看法，渐次现观品作为已有的通识，一样样体会作为学人要渐次熟悉把握的经历；弥勒菩萨所以略说的主旨是，要前面理解的分开来修习调整为整体性的修习，和华严的一摄多多摄一的道理大致相同，恒以一法观一切法，导入刹那证大菩提品的修学中。

    静风：
    是的。既是摄修在一起，又有一定的次第。还有，对凡夫来说次第显现重些，到佛陀则是完全摄持在一起。这中间次第显现会变少，摄持显现会越来越多。因为凡夫开始智慧资粮比较差，通常会仅仅把握住点，后来闻思修功夫好了，点和点就开始摄持成整体了。

    齐愍：
    所以这也是个从渐修次第入华严的方便，比如第九品法身品就是菩萨举了一个修佛随念的例子来讲解这件事情，所以大乘人学现观是一个很好的缘起。

    静风：
    华严其实是果地的描述。就是我们希望那样。因地上现观讲了两重方便。一是圆加行到顶加行。这是从法相讲的，把菩萨所修的法都总结起来，一共100多种，这个加圆加行。这些加行最后坚固起来，就是顶。二是渐次加行到刹那加行，这是偏重次第讲的。菩萨的法从次第摄为13次第，最后渐次圆满刹那证入佛果，就是刹那加行。因地上的这两重方便导入的都是华严果地上的究竟摄持。当然把果地进行经常串习，也可以算成因地。

    齐愍：
    现观庄严论虽是大论，却结构紧凑，文简义丰，看起来确实很适合花一定的时间去学习，也很希望看到你陆续将体会和大家分享，让我们这些没有怎么下过力气学这部论的注解的人，能够多少利益均沾，呵呵。


管理自己的修行

    小孩：
    请教各位一个问题，我们大概都没有那么多福报能只考虑修行的事的。工作生活等等事情，不仅占据我们的时间，还占据我们的精力，经常性地还影响我们的情绪。于是学佛就很容易变成两天打鱼三天晒网的。尤其是实际上需要认真地每天做的功课，如修止等。
    忽然有一天想到一个方法。好的管理都是标准少而低、但是要求严的，比如建筑条规有很多，但是很少有一个建筑是严格执行的，不遵守条规也不一定会有人来管的。再比如在规章制度很多的公司里执行得往往很差。井井有条的公司制度往往会很少。
    请问这个原则用在管理自己的修行上可以吗？就是说我们在管理自己的修行时间、修行内容的时候是不是也不要要求高？要求得太高做不到，各种后悔的心就都来了，容易退转什么的。而且现在越来越觉得，要求太高其实是自视太高。当然随喜赞叹那些对自己要求高又能做到的。但觉得自己可以做到的东西，实际上自己还做不到的。要求低一点的好处是，因为比较容易完成，就对自己充满信心。
    还有一个好处，去做所有额外的修行的时候，都觉得是做附加题，感觉特别好。杂念也少。不过这样对自己要求低总觉得不大好。我不是太有信心。

    二麻子：
    高低之间，其实有现成答案：“高高山顶立，深深海底行”。我们学佛如果丢了后半句就成自欺，丢了前半句则是被欺。科学界有句话好像是“一个好的问题是解决问题的一半”。小孩兄好问题。而且显然小孩兄对解决也有了一定的实践经验。

    小孩：
    高不成，总能低就的。相信自己，今天不行，明天总可以的。这是不是就是高高山顶了？还是更有高山？麻叔鼓励小孩，小孩继续露拙，小孩对自己的管理办法是：
一天24小时，有23小时该干什么干什么，唯一的标准是戒律，凡是没有在三宝面前答应过不做的事都可以做，不再有心理负担。还有1个小时要高质量地修行。因为不再“念念是佛”（做不到啊），修行的时候就容易心生欢喜，这是我愿意做的唯一的事啊。谋稻粮不得已，为世间八法所屈更是耻辱。再不利用这短暂的一小时做点高兴的事，岂不是太对不起自己了。

    二麻子：
    好。这样就很好。给自己一个可行的做法，把修行落实到行动上，远超过高喊而不实行。

    zf：
    关于修行的安排，在下的看法是：
一、终极目标要高，即在发无上菩提心这一点上绝不含糊。
    二、阶段目标适中，以行人不产生焦虑情绪为标准。
    如果焦虑占据了内心，一方面现时不得正受，另一方面也是对时间的浪费。因此，原则上在下是同意小孩兄看法的。

    小孩：
    菩提心小孩不敢忘。小孩一直没有机会聆听到赵叔开示如何从菩提心入手修行，羡慕那些师兄哦。感谢网络，能看见赵叔的“远程教育”的言语。真是幸福啊。

    zf：
    共勉，“如何从菩提心入手修行”──紧紧地盯着如来的十力、十八不共法，发愿欲成就之。
    这就是华严开示的菩提心修持之道：
“佛子。云何为菩萨发心住。此菩萨。见佛世尊。形貌端严。色相圆满。人所乐见。难可值遇。有大威力。或见神足。或闻记别。或听教诫。或见众生受诸剧苦。或闻如来广大佛法。发菩提心。求一切智。此菩萨。缘十种难得法。而发于心。何者为十。所谓。是处非处智。善恶业报智。诸根胜劣智。种种解差别智。种种界差别智。一切至处道智。诸禅解脱三昧智。宿命无碍智。天眼无碍智。三世漏普尽智。是为十。”


打坐常识交流

    打坐常识交流

    成军

    后学的恩师仁波切曾经开示，打坐时候到一定阶段，原来沉积的习气烦恼种子会翻上来，这时候就需要明师教导以正见对治之，问题解决了，修行才上正路子。
    那么如果一直不能得遇明师怎么办？数年前恩师仁波切亦曾经开示后学，如果这样的情况，就老实打坐念佛菩萨圣号，念到纯熟，诸佛菩萨自然会在定中加持的。此外，明师自然也会找上门。恩师仁波切还说了这样一个故事，过去西藏有个学密的修行人，他的老师只传了他基础的四加行法就去世了。於是此人就在一个山上认真地持续不断地修四加行。过了若干年，有一个大圆满的上师路过，看到此山放光，想在此殊胜处修行，於是找上山来，传了此人大圆满法。最近，奉心居士善知识还说过这样一句耐人寻味的话，大意如下：“不要抱怨现在这个时代没有玛尔巴，你自己要是米勒日巴，自然会有玛尔巴来教你。”
    这里顺便和初习打坐的同修交流点打坐的常识。一是要注意保暖，不要受寒。因为打坐时候浑身的关节都是打开的，寒气容易乘机进来。因此，盘腿打坐除了腿要用毯子或者布包好，肩部、背部、腰部的保暖也很要注意。特别是夏天，不要贪图凉快。
    二是比较散盘、单盘，双盘坐的好处很多，包括心容易安定、腰容易自然挺直、气脉更畅通等。因此，开始腿比较“硬”还无法直接采取双盘坐的同修，可以从单盘开始(单盘也做不到则先散盘)，逐渐训练到了一定的阶段，腿子慢慢坐软下来了，再尝试短时间的双盘。如果成功了，再慢慢延长双盘坐的时间。
    对於初学者打坐念佛，后学能够想到的其他细节还有：
一、在决心打坐(假定无师承情况下念佛)以前，宜及早皈依三宝、受持五戒，只有戒行(比较)清净了，打坐念佛才能有效果。戒定慧，是佛法一切法门宗派共同的次第。
    二、于现实生活中，不忘以正知正见调伏烦恼，累积福德资粮。不管是得遇明师的法缘、对佛法的信心、还是打坐的境界觉受，都和我们平日的心行，所累积的福报分不开。也就是说，学佛修行，不限於坐上的那半小时一(几)小时，而是尽量落实到生活中的时时刻刻。
    三、注意饮食，饭后不要立刻打坐，也不要吃过於刺激(如五荤)或者太难以消化的食物。
四、注意睡眠休息，不要在很困很累的时候打坐，甚至试图以打坐代替睡眠。如此，会养成打坐时堕入昏沉的条件反射。
    五、如果参加共修活动或发愿自修需要圆满一定数量的，计数只计座上不计座下。打坐念佛，如果计数，宜手持数珠。
    六、念佛时，最好在佛(坛、龛)前，或者在面前放置阿弥陀佛佛像，作为所缘境，也可以帮助摄心。


老生常谈积资粮

    俗人：
    “幻听就是白日做梦的一种，出了问题最好的办法是赶紧去看医生”。
    ──幻听那一类的神秘经验一般都是……独影＋非量，也还是随众生心、应所知量、当处发生、当处灭尽也。

    二麻子：
    哎呀，这次给俗人兄泼盆冷水……这个帖子上的没意思。这种分类学的知识，对前面的当事人真是一点用处都没有的。

    俗人：
    那么请教师兄，什么才是对前面的当事人有用的呢？

    二麻子：
    嘿嘿……
    俺就是找不出直接有用的，所以没说话。真说起来，俺在这些事上多少还是有点子经验。问题是对他们没用……所以就不说了。
    这地方的关键是当事人怎么能处理正确。
    问题是麻子想不出有什么直接的方法能让人学会正确处理。这个不是个理论怎么办的事，而是对境时他能不能办的事。
    当然，如果麻子说应该平时就慢慢积累福慧资粮那是绝对不错的。不过那些当事人大多不会听进去：不就是老生常谈吗。现积累见效不很快。嘿嘿。

    无名：
    积累福慧资粮包括哪些方面？

    二麻子：
    三主要道。


仁兄为何而习定？

    仁兄为何而习定？

    zf

（编按：以下“”中为“大秦武士”网友的贴文，该网友在此贴前自述他在自行无师自修禅坐的过程中发生恐惧和身体极度不适等情形。）

    “鄙人习定已有五年矣。定境由浅渐入深。”
    ──仁兄为何习定？

    “……人之心识无有所托，此时只得强行退出……”
    ──仁兄想过没有，您心识要托在何处才会感到安稳？

    “可能是我的薰习还未破到一定程度，所以遇到深定就耐受不住。也可能是我愿力不足，没有发修习菩提心的深心大愿，故一入深定就感到茫然不知所止所终，心有恐惧。不能完全忘身。”
    ──未有悲愿、菩提心者入定就一定感到恐惧吗？
    您的定力同阿罗汉比如何？

    “这个深定，我就慢慢习练着，两年之后，再考虑深入……”
    ──为定而定？

    “阿弥陀佛！今生所习，若有功德，全回向我的母亲！”
    ──若仅仅是为定而定的话，您修上述“大定”亿万劫也不及上面这一句话的功德大！

    “我是为转识成智而修定的。”
    成智又是为何？？

    “且我修定之前，根本无心要修那个定的。”
    ──看来您的“定”是看心不严，自己流浪的结果。

    “人通常时的心理状态是，心识总有所托，要么托在种种杂想念中，要么依于身转。这个习惯人们是安于接受的。但是我入那个定时，突然发现完全变了，一下子习惯不过来。所以就有不安感。”
    ──莫说忘身，就是安住非想非非想定者照样是六道凡夫，与解脱轮回不沾边。

    “您所说的，我一定好好思量。谢谢指教。”
    ──您既然对在下的闲话不反感，就再罗嗦几句：
一、恐怖的来源为何？挂碍也。若“心无挂碍，无挂碍故无有恐怖”。可见挂碍不除，恐怖难免。
    二、挂碍的来源为何？我法实执也。不证空性，挂碍难免。
    三、在佛陀开示的八正道中，居首位者为何？正见也。无正见指导下的修，歧路难免。
    四、跨越生死轮回之河的桥梁为何？善知识也。无善知识的护持，正见难立，轮回难逃。

    吉祥如意


静坐与“期望”

    朗然：
    去年体检透视曾说“颈椎生理曲度存在，左侧第四椎体稍变窄，无明显异常……”打坐时的动作也大多集中在左肩轴和颈椎一带，不清楚是否两者之间有何关联。

    二麻子：
    大概有点关联。
    颈椎生理曲度存在，
    ──这句的意思是正常。
    左侧第四椎体稍变窄，
    ──这句的意思是有点问题。
    无明显异常
    ──这句的意思是就是有问题也不明确。

    但片子的分辩能力是有限的，所以，你那里大概有点小毛病。但，“动”并不能治好这个毛病！这地方要治疗需要找到真正高明的脊柱专科医生。

    jialin618：
    有点不同意见，以我个人的体验，还是有关系的。一般气血不通就会造成相关部位的特殊感觉（比如沉重感）和活动。静坐的健身效果是大家公认的。一般慢慢你的病会好下去，然后活动会减少乃至消失。有很多人认为不需要去克制这些运动，当然也不要去鼓励这样的运动，不管它有没有。

    二麻子：
    你说的有你的道理……但你没注意到是器质性的变化。
    静坐的疗效，对我们这些人来讲几乎一定限制在非器质范围内。除非你真的能入三禅之类的定。
    就是入三禅，器质性的东西也不是都能治好。
    跟您说句个人的话，你可能需要些时间来慢慢打破某些由“期望”而产生的迷信。如果能自己早点看明白这地方，可能对提高比较有利。


不好意思，我看不出您这是什么行持来

    学生：
    学生经常关注论坛，看过老师的许多贴子，今天想请教几个问题。
    一、学生行持以念佛为主，现在打坐时，不用提起佛号，心中非常平静，很清楚，身体好似在动，不予理会，感觉身体不存在。请问这时继续下去，还是提起佛号。
    二、学生几年前一次骑车下班，对面过来一人，在下车躲人的刹那，初次体会这是自性妙用对否？
    三、学生现在常常都是在平静中生活，遇境可以不再用佛号对治妄念，对过去的事很少有记起的。学生这种行持是否有错？是否狂妄？应如何做？请指教！！！

    二麻子：
    敬复如下……

    “感觉身体不存在。请问这时继续下去……”
    ──情况您说的不是很明白。应该怎么做与您的当前具体目标有关。如果为了将来往生西土，那么要做意提起佛号，积累净业。如果不是特别修净土，提不提佛号要看你现在里面有没有夹杂昏沉掉举，如果夹杂了，仍然要做意提起佛号。如果果然没有沉掉，干吗不继续下去？

    “这是自性妙用对否？”
    ──大致是妄心的妙想。不过妄心也从来没离开性空过。

    “这种行持是否有错？”
    ──不好意思，我看不出您这是什么行持来。不记忆过去并不一定是什么好事，不说明什么。佛能回忆无量劫，无想天人不能明确知道”现在“的感觉。您说呢？


没什么特别殊胜，不过一场电影

    Eagle：
    一位网友说：就说那天晚上，我单独在看经书，有一句话使我猛然醒悟，突然间时空好像停止了，我有一种感觉，就是好比进入了时空遂道，觉得自己本来没有存在，也觉得未出生之前我已存在，又觉得整个宇宙本来就是我自己，一切外物，本来是自心所幻化，这样一来，整个身心就空荡荡了，接着，竟然不自觉地大笑起来，身心无比轻松和舒畅，从此，我好像换了人，总是笑意盈盈，源自于内心的快乐，急于要把我的快乐告诉别人，但是，没有人能理解，我于是有些不安了，……知道不对，可具体该怎么定性定位？下一步该如何继续？

    二麻子：
    没有什么可以定性定位的……
    不过就是个一般人比较少碰到的情况。
    跟有时候睡醒一刹那不知道自己在哪里也差不了很多。
    因为是瞎碰上的而不是修出来的，没法重复，故不属于禅定，没什么性，位要定。
    大概十年前麻子有个八竿子刚打到的朋友，白人小伙子也有个差不多的情况。然后就自己以为开悟了，至少是希望自己这是开悟了。四处找人印证。嘻嘻。在麻子这里听了点难听实话，还不欢而散。后来他花了五、六年时间，跑日本、台湾、中原、西藏，找禅师、法师、金刚上师四处印证，都是扫兴而归。后来再碰到麻子，就一句话“唉，当时若早听你的，可以少花很多钱”。如此而已。

    Eagle：
    刚睡醒或被吵醒不知身在何处有没有什么道用？会有一小段努力想“搞清楚处境”，这是不是“强能弱所”？还是谈不上？在坐或睡中有时这样呢？（结果当然都“找回来”了──在床上，＾＿＾）嘻嘻，这是我自己的问题。

    二麻子：
    在很长一段时期里，没什么用……因为自己力量不够，用不上。等到能用上时，却是很有用的……

    Eagle：
    他又有问题：“我认为大德的回答是对的，只是我还想问一下，我当时的那种体验，就是说，我觉得到世界观的不同，和自我的概念的不同，这种与原来对事物的认识或一般人对事物的认识的完全不同的体验，是不是正确的？因为我知道那种体验即使不合真如，至少我已完全改变了自己，我知道了先前做梦也不可能知道的事，体会了一种愉快的，和没有烦恼的特殊心态，使我确信成佛的可能。谢谢！”

    二麻子：
    没什么不好──比如我刚看过一场电影。也没什么特别殊胜──不过一场电影。


知觉问题辨析

    知觉问题辨析

    zf

    （编按：以上整个用引号扩起来的若干自然段为某网友文章中的摘录。）

    几个疑问：
“原来我们时时刻刻都在使用的知觉，竟然在我们不想使用时也仍然存在，而且根本不受我们自己的控制！”
    ──我们的知觉真的“根本”不受自己的控制吗？

    “我们的本元觉心是本来就存在的”
    ──“本元觉心”的确切含义是什么？如何由了知“知觉”的存在便可得知“本元觉心是本来就存在的”？
    如果不能搞清知觉与本元觉心的异同，则文中之“只有体悟到了这一点，你才会真正明白《心经》中所说的“不生不灭、不垢不净，不增不减”到底是什么意思”之说便大有疑问。
    “我们时时刻刻都在使用的知觉”为常恒不变？还是缘起缘灭？

    “众生的知觉，包括两方面，一是受意志力支配的意识──分别识，二是不生不灭的圆明觉性的用──大圆镜智”
    ──此大圆镜智乃如来果地时由第八识所转，众生因地时如何可以体验到此智之用？

    “意识灭度后的知觉就是正觉”
    ──这里的“意识”确切为何意？是唯识中的第六识吗？我们修行所应灭除的是无明还是意识？

    “如果执着于妄想的感觉，就是缘起缘灭的，如果是离于妄想的正觉，就是恒常不变的。”
    ──“正觉”既然是因离于妄想而起，如何理解其“恒常不变”性？

    “一旦证悟正觉，就会发现，正觉实际上也在妄想之中，妄想的体性亦是正觉。所以，虽然妄想以及产生的感受缘起缘灭，但其正觉体性却恒常不变。缘起缘灭的感受，实际上是由缘起缘灭的妄想所致。”
    ──“正觉实际上也在妄想之中”与“妄想的体性亦是正觉”这两个说法在语意上的差别是明显的。
    众生于轮回中妄想无始以来即有之，此妄想因存在于十二之因缘中，故虽有（作用）而非常。
    如正觉在妄想之中，此正觉是否为常？
    “正觉体性恒常不变”于“正觉恒常不变”有无差别？若有，差别在何处？

    “拿一个看不见摸不着的东西论差别，不会，不知仁兄会否？”
    ──看得见的东西是色法，眼根所对故；摸得着的东西无疑也是色法，身根所对故。五蕴之中除色法外，看不见摸不着的法占大多数，其差别兄都不论吗？？兄不妨看看自己写过的东西，有多少是在讨论那些看不见摸不着东西的差别。讨论就此打住，多说无益。


华严发菩提心文

    华严发菩提心文

    此发菩提心之妙法，乃由法慧菩萨于华严会上宣说。十方各万佛刹微尘数法慧如来亦说是法，一切诸佛悉如是说。我今随学此殊胜法宝，唯愿速证无上菩提，利益法界一切有情。

    南无本师释迦牟尼佛
    南无法慧菩萨摩诃萨

    我为令如来种性不断故愿成佛；为令如来种性充遍一切世界故愿成佛；为度脱一切世界众生故愿成佛；为悉知一切世界成坏故愿成佛；为悉知一切世界中众生垢净故愿成佛；为悉知一切世界自性清净故愿成佛；为悉知一切众生心乐烦恼习气故愿成佛；为悉知一切众生死此生彼故愿成佛；为悉知一切众生诸根方便故愿成佛；为悉知一切众生心行故愿成佛；为悉知一切众生三世智故愿成佛；为悉知一切佛境界平等故愿成佛。
    复次，我为了知十方一切世界故愿成佛。所谓为了知妙世界即是粗世界、粗世界即是妙世界故愿成佛；为了知仰世界即是覆世界、覆世界即是仰世界故愿成佛；为了知小世界即是大世界、大世界即是小世界故愿成佛；为了知广世界即是狭世界、狭世界即是广世界故愿成佛；为了知一世界即是不可说世界、不可说世界即是一世界故愿成佛；为了知不可说世界入一世界、一世界入不可说世界故愿成佛；为了知秽世界即是净世界、净世界即是秽世界故愿成佛；为知一毛端中一切世界差别性、一切世界中一毛端一体性故愿成佛；为知一世界中出生一切世界故愿成佛；为知一切世界无体性故愿成佛；为以一念心尽知一切广大世界而无障碍故愿成佛。
    复次，我为悉知一切世界成坏劫尽无余故愿成佛。所谓为悉知长劫与短劫平等、短劫与长劫平等故愿成佛；为悉知一劫与无数劫平等、无数劫与一劫平等故愿成佛；为悉知有佛劫与无佛劫平等、无佛劫与有佛劫平等故愿成佛；为悉知一佛劫中有不可说佛、不可说佛劫中有一佛故愿成佛；为悉知有量劫与无量劫平等、无量劫与有量劫平等故愿成佛；为悉知有尽劫与无尽劫平等、无尽劫与有尽劫平等故愿成佛；为悉知不可说劫与一念平等、一念与不可说劫平等故愿成佛；为悉知一切劫入非劫、非劫入一切劫故愿成佛；为于一念中尽知前际后际及现在一切世界成坏劫故愿成佛。
    复次，我为尽知一切世界所有众生种种差别解故愿成佛。所谓为知一切差别解无边故愿成佛；为知一众生解无数众生解平等故愿成佛；为得不可说差别解方便智光明故愿成佛；为悉知众生海各各差别解尽无余故愿成佛；为悉知过、现、未来、善不善、种种无量解故愿成佛；为悉知相似解、不相似解故愿成佛；为悉知一切解即是一解、一解即是一切解故愿成佛；为得如来解力故愿成佛；为悉知有上解、无上解、有余解、无余解、等解、不等解差别故愿成佛；为悉知有依解、无依解、共解、不共解、有边解、无边解、差别解、无差别解、善解、不善解、世间解、出世间解差别故愿成佛；为于一切妙解、大解、无量解、正位解中得如来解脱无障碍智故愿成佛；为以无量方便悉知十方一切众生界一一众生净解、染解、广解、略解、细解、粗解尽无余故愿成佛；为悉知深密解、方便解、分别解、自然解、随因所起解、随缘所起解、一切解网悉无余故愿成佛。
    复次，我为尽知一切世界中一切众生根种种差别，广说乃至欲尽知一切诸根网故愿成佛；为尽知一切世界所有众生种种欲乐，广说乃至欲尽知一切欲乐网故愿成佛；为尽知一切世界所有众生种种方便，广说乃至欲尽知一切方便网故愿成佛；为悉知尽法界虚空界无边众生种种心，乃至欲尽知一切心网故愿成佛；为悉知三世一切众生业，乃至欲悉知一切业网故愿成佛。
    复次，我为尽知一切世界所有众生烦恼差别故愿成佛。所谓为尽知轻烦恼、重烦恼、眠烦恼、起烦恼，一一众生无量烦恼，种种差别、种种觉观，净治一切诸杂染故愿成佛；为尽知依无明烦恼、爱相应烦恼，断一切诸有趣烦恼结故愿成佛；为尽知贪分烦恼、嗔分烦恼、痴分烦恼、等分烦恼，断一切烦恼根本故愿成佛；为悉知我烦恼、我所烦恼、我慢烦恼，觉悟一切烦恼尽无余故愿成佛；为悉知从颠倒分别生根本烦恼、随烦恼，因身见生六十二见，调伏一切烦恼故愿成佛；为悉知盖烦恼、障烦恼，发大悲救护心断一切烦恼网，令一切智性清净故愿成佛。
    复次，我为供养尽法界虚空界不可说不可说十方无量去来现在所有诸佛故愿成佛。
    总之，我为不断一切如来种性故愿成佛；为令如来种性充遍一切世界故愿成佛；为度脱一切世界众生故愿成佛；为悉知一切世界成坏故愿成佛；为悉知一切众生垢净故愿成佛；为悉知一切世界三有清净故愿成佛；为悉知一切众生心乐烦恼习气故愿成佛；为悉知一切众生死此生彼故愿成佛；为悉知一切众生诸根方便故愿成佛；为悉知一切众生心行故愿成佛；为悉知一切众生三世智故愿成佛；为悉知一切佛境界平等故愿成佛。

    法慧菩萨开示：菩萨以是发心故常为三世一切诸佛之所忆念，当得三世一切诸佛无上菩提，即为三世一切诸佛与其妙法，即与三世一切诸佛体性平等，已修三世一切诸佛助道之法，成就三世一切诸佛力、无所畏、庄严三世一切诸佛不共佛法，悉得法界一切诸佛说法智慧。何以故？以是发心当得佛故。应知此人即与三世诸佛同等，即与三世诸佛如来境界平等，即与三世诸佛如来功德平等，得如来一身无量身，究竟平等真实智慧。才发心时，即为十方一切诸佛所共称叹，即能说法教化调伏一切世界所有众生，即能震动一切世界，即能光照一切世界，即能熄灭一切世界诸恶道苦，即能严净一切国土，即能于一切世界中示现成佛，即能令一切众生皆得欢喜，即能入一切法界性，即能持一切佛种性，即能得一切佛智慧光明。
    十方世界诸如来　　悉共赞叹初发心
    此心无量德所严　　能到彼岸同于佛
    如众生数尔许劫　　说其功德不可尽
    以住如来广大家　　三界诸法无能喻
    欲知一切诸佛法　　宜应速发菩提心
    此心功德中最胜　　必得如来无碍智
    众生心行可数知　　国土微尘亦复然
    虚空边际乍可量　　发心功德无能测
    出生三世一切佛　　成就世间一切乐
    增长一切胜功德　　永断一切诸疑惑
    开示一切妙境界　　尽除一切诸障碍
    成就一切清净剎　　出生一切如来智
    欲见十方一切佛　　欲施无尽功德藏
    欲灭众生诸苦恼　　宜应速发菩提心

    南无本师释迦牟尼佛
    南无法慧菩萨摩诃萨

    （编按：此文系奉心居士根据《大方广佛华严经初发心功德品》整理。）


学佛的过程，几点体会

    学佛的过程，几点体会

    zf

    首先说明，自己在现实生活中并未能很好地处理各种矛盾与菩提心的关系，自己实实在在是个初学者。
    关于菩提心，先贤常将其分为世俗和胜义两种。胜义菩提心涉及甚深空性，这里暂且不谈。
    关于世俗菩提心，又常被分为愿、行两部分。两者之间的关系本人是这样理解的。
    我们先来看看一个孩子的成长过程。在孩子五、六岁时，负责任的家长就开始启发孩子的志向，向孩子介绍种种能给社会带来益处，同时又深受大众尊重的职业，例如教师、科学家、工程师、医生或总统、总理、将军、企业家等，帮助孩子选择一种自利利人的目标，这一阶段可称之为目标的确立。
    在孩子目标确立后，家长应告诉孩子：目标不能自动实现，需要上学，只有学到知识和技能，将来才能成为对社会有用的人，就如歌中唱到的“没有人能随随便便成功”。学习的过程虽也有乐趣，但毕竟是艰苦的，不如无忧无虑的玩耍开心。但不上学、不学知识便无成材之理，因此应帮助孩子作好上学的心理准备，即使遇到困难也不中途退学。这一阶段可称之为学习的准备。
    接下来就是学习的阶段。学习过程中遇到困难是难免的，克服困难最有力的武器就是牢记自己的目标，思考目标的实现能给自他带来的利益，思考不经学习便无成功之理，学习成功者的经验，从而盯着目标，脚踏实地。
    我们学佛的过程大体上与上面情况相似。“目标的确立”相当于愿菩提心，即发起为利众生愿成佛的金刚誓愿；“学习的准备”相当于行菩提心，即发起为成正觉愿修无量难行苦行的金刚誓愿，正如《普贤行愿品》中所云：“如来功德……不可穷尽，若欲成就此功德门，应修十种广大行愿”，此处“欲成就此功德门”便是愿菩提心，“修十种广大行愿”便是行菩提心，即应发起修学十种广大行的愿；学习的阶段便是在愿行菩提心摄持下，脚踏实地地修学普贤行。
    考察本人目前的修学程度，主要为修学愿行菩提心，并尝试在菩提心的护持下实践一点点菩萨行。遇到困难心生退却之意时，便反复祈请上师三宝、思维愿行二菩提心，为自己鼓劲。据古今大德开示，菩提心若坚如金刚，便可摧碎修行路上的一切障碍，密乘中的护法金刚实为行者坚定菩提心的化现，一切金刚的根本心咒皆为hum，而此咒正是菩提心义。
    修学菩萨行，既要有紧迫感，又不能拔苗助长。试想如果一个孩子立下了要当科学家的志愿，但一个愚蠢的人却要求孩子立即就去解决微积分或相对论中的问题，孩子自然无能为力。如果这个愚蠢的人因此便讽刺孩子、断言孩子根本不具备成为科学家的潜质，则此孩子的前途很可能被毁掉。


菩萨道修行的总原则

    菩萨道修行的总原则

    zf

    Bird、增兄：
修行之道，从根本上说是积累福智资粮。纵使如来德相我等本具，若无“二资粮”，本具的德相也无法显现。如在下之所为哪怕能为诸兄解惑如一微尘，在下便亦同时积累了成佛的资粮。因此，如法的交流是问者和答者的“双赢”之举（“双赢”二字很时髦吧！）。但此功德的起因是问者，因此，答者先给问者顶礼——感谢问者对答者的功德布施！
    言归正传。
    “哀愍众生广大智，普摄一切同于己，知空无相无真实，而行其心不懈退。”
    依在下浅见，这四句偈中包含了菩萨道修行的总原则——智悲双运。
    我们先看看佛驮跋陀罗译（晋译）《大方广佛华严经·初发心菩萨功德品》对此偈的表述：

“哀愍众生广大智，普摄一切同于己”在晋译中为“菩萨摩诃萨，大悲心无量，佛及己众生，等观无有异。”
    “知空无相无真实，而行其心不懈退”在晋译中为“乐观寂灭相，诸法如虚空，慧者如是观，一切真实性。”
    结合晋译，
    “哀愍众生广大智，普摄一切同于己”可理解为：菩萨以大智大悲的心怀，观察佛、众生与自心三无差别，并将一切众生之苦视为己苦，而为救度。
    “知空无相无真实，而行其心不懈退”可理解为：菩萨一方面以大智观察一切法空（即缘起）、无相（即无自性）、无真实（即如梦如幻），另一方面，亦不忍众生枉受虚妄之痛苦（如母视子在恶梦中呼救，母虽知儿梦中之苦不实，但亦不忍），如文殊、普贤、观音、地藏等，化身于六道利益众生，尽未来际。无有疲厌。

    不知以上解释是否有助解兄等疑惑？若尚有疑，别忘了再赐在下一个积累功德的机会。


菩提心生起的因缘

    静风：
    赵叔帖子说的菩萨勇气的来源如果是指行愿俗谛菩提心位的菩萨，那肯定没问题。但不知道小乘圣者是否可以见到六道非实有（个人认为可能还是会见到的）。不如法请指出来。
    我记起道次第里，宗大师宣说菩提心的四因四缘和四力的时候有说，如果拿出来仔细研究一下应该很有利益。四缘可以归为二缘：一是见到诸佛功德不可思议之威神力，然后希求成佛。二是见到末世众生苦恼所逼，末法衰微发愿住持正法而希求成佛。所以我认为：（一）希求诸佛功德和（二）希求住持正法、众生离苦的大悲心可以说是菩萨勇气来源的根本因，以别于小乘种性（当然我决不是说小乘怎么样，个人恐怕连小乘解脱种性都没有）。由于希求成佛和解救众生两点根本因上不断策发，在过程中以般若力观察减少实有的障碍，应该是一个比较完整的描述。（赵叔所说报恩可以摄于第二点上）。
    四因是：一、种性圆满。二、善友摄持。三、悲悯有情。四、不厌患生死难行。——个人觉得，这里面如上，悲悯有情的悲心和希求诸佛功德的希求心一直鼓励着菩萨，所以才不会厌患有情。另外善知识和善友的摄持和鼓励也是重要力量。我的善知识经常教导我说，大乘道的修行一定要有善知识。在我前一段专心研究空性的时候他老人家不断提醒我，要认识到苦是客观存在的，要发菩提心才能成佛。
    四力是：一、自力；二、他力；三、因力；四、加行力。自己希求成佛是自力。善知识善友的帮助可以说是他力。如果自己以前就熏习大乘，现在再听闻诸佛菩萨赞叹大乘而能发心，是往昔因力。现在亲近善知识，闻思修正法来增长发心，是加行力。
    心初发后，保持增长菩提心，也有几种力量。因为众生数量多，行为暴恶，如果心怯弱易退堕。这时候有两种方便来在现世增长菩提心，和后世再生菩提心。现世增长的主要方便是要数数发心，才能不退堕（每天至少六次发心）。还要保持两点来遮止发心现世退失：一、是不舍任何一个有情。二、是不可以说自己不能成佛。后世保持发心不退的方便是修四种善法，遮止四恶法。比如不能欺诳善知识等。内容较多就不说了。
    嘻嘻。本来想靠自己理解写一些。后来发现理解的实在有限，还是翻看了一些广论的内容，回来再写出来觉得策发保持发心的各种力量，基本上都是宗大师说的，不过变成我自己的话后不知道原味还剩下多少了。嘻嘻。
    发起菩提心后，主要保持增长的力量，概括起来说，就是广泛修学二种资粮（广论上说的）。感觉菩提心初发心，就象一个地基一样，刚有地基的时候，可能不大稳固。但随着上面福慧资粮的积累，大楼越来越高，地基相对的就越坚固了。比如菩萨布施，布施完了看到众生欢喜，自己也欢喜，这就增加了菩萨修学的力量，让菩萨感到修学大乘道确实比小乘道殊胜啊。其他的六度四摄也一样。当然这其中有主要因缘和次要因缘，不过这么说的话很多人是不是觉得是废话了。嘻嘻。

    zf：
    静风兄将菩提心生起的因缘讲说得十分清晰。
    兄文中认为：“（一）希求诸佛功德和（二）希求住持正法、众生离苦的大悲心可以说是菩萨勇气来源的根本因。”对此在下完全赞同。
    在下上文中所要表达的意思是，在上求下化（如兄以上之两点）根本动机的摄持下，菩萨发心修学菩萨道。此时菩萨心中两种力量共存，一、上求下化的愿力（即报恩心），二、畏难心理。在克服畏难心理方面，般若有着不可替代的作用。
    如果要进一步分析利生大愿和般若空慧两者谁更根本？在下完全同意兄之利生大愿为根本因的看法。因为，行人心中若有上求下化的菩提大愿，般若空慧一定会以不可思议的因缘生起；反之，对于证得空慧者，行愿菩提心却未必自然生起。这就是人们常说菩提心为佛父，而般若为三乘佛母的原因。
    另外，
    “在我前一段专心研究空性的时候……要认识到苦是客观存在的……”
    “苦是客观存在的”，这一说法兄要小心。我等初学的心行受语言的强烈影响，语言表述的差异可能导致不同结果。
    “本来想靠自己理解写一些。后来发现理解的实在有限，还是翻看了一些广论的内容，回来再写出来觉得策发保持发心的各种力量，现在圆满多了。基本上都是宗大师说的……”
    ──这难道不是修学上师瑜伽的过程吗？！

    TZ：
    能否请师兄或哪位谈谈菩提心含摄之要点。

    zf：
    T兄，《大正藏》中之“金刚顶瑜伽中发阿耨多罗三藐三菩提心论”对菩提心的含义有透彻的说明。
    《掌中解脱》中阿底峡尊者的传记里，有关菩提心的部分十分精彩。
    《华严经入法界品》中，弥勒菩萨对善财童子详述了菩提心的功德，不可不看。
    《华严经初发心功德品》中开示了一种随顺华严法界观的发菩提心方法，为十方各万佛刹微尘数如来所宣说并护持。


菩提心的根在哪儿？

    gentleLion：
    菩提心的根在哪儿？
    一、为什么有人能发真实菩提心，有人却不能？究竟是什么原因？发菩提心的根源在哪？
    二、如何让现在尚不能发菩提心的人发起菩提心，永离众苦，趣向菩提？
    三、如何让已发菩提心的，生生世世不忘失，永不退转？经云：忘失菩提心，所修一切善法皆为魔业。

    linden：
    ZF大德曾当我面背诵了以下一段经，印象之深，历历在目。正好回答这个问题。
    诸佛如来，以大悲心而为体故。因于众生，而起大悲。因于大悲，生菩提心。因菩提心，成等正觉。譬如旷野沙碛之中，有大树王，若根得水，枝叶华果悉皆繁茂。生死旷野，菩提树王，亦复如是。一切众生而为树根。诸佛菩萨而为华果。以大悲水，饶益众生，则能成就诸佛菩萨智慧华果。（注：这一经典段落出自《大方广佛华严经普贤行愿品》）


菩提心总摄空性慧与大悲心

    洛桑吉美：
    以前粗读过《入中论善显密意疏》对于月称师第一颂（“声闻”至“大悲心”，法尊法师译文，8句），读宗大师的解释，对于三因深意和关系，不甚明了。见赵叔论及菩提心因，故再次求教。能否请赵叔略讲？是不是三因（大悲心生余二因）中菩提心总摄悲慧呢？

    zf：
    《入中论善显密意疏》乃宗大师的重要著作，殊胜的格鲁教法在下没有系统学过，有机会您最好请教格鲁的大德。以下是自己的一点粗浅理解。论中说：
    ──────────────────────────
    丁三　明彼亦是菩萨余二因之根本
    三因中以大悲为主。由大悲心亦是菩提心与无二智之根本。为显此故，说【悲性】等一颂。大悲心于丰盛广大之佛果，为初生要因，如种子。中间令增长，如水润。后为众生常时受用之处，如果成熟。故我月称，于声闻独觉诸佛菩萨及余二因之先，或造论之首，先赞大悲心。此非入后文方赞，即此所说于生佛果初中后等即是赞叹也。性者，显佛果三位中之心要，唯一大悲。不如外谷初中后三位之要因别有三事，为最初宗要如种子者。谓具大悲心者，见有情受诸苦恼，为欲救一切苦有情故。便缘所为事而发心曰：【我当度此一切有情出生死苦，令成佛道】。又见要自成佛道，乃能满彼愿。故复缘菩提而发心言：【我为利益诸有情故，愿当证得无上菩提】。又见不修无二慧所摄施等诸行，则彼誓愿终不能成办。乃进修智慧等行。是故大悲心为一切佛法种子。《宝鬘论》依此义云：【若大乘经说大悲为前导，诸行无垢智，有智谁谤彼】。此说大悲为前导，菩提心所引诸行，与离二边无垢净智。此三行摄一切大乘义尽。
    为中间要因如水润者，谓大悲种子发生菩提心芽已，若不时以大悲水灌溉之，则必不能修习二种广大成佛资粮。定当现证声闻独觉涅槃。若以悲水时加灌溉，则必不尔。
    为末后重要如成熟者。谓成佛已，设离大悲心，则必不能尽未来际为诸有情作受用因。亦不能令声闻独觉菩萨圣众展转增上。若于果位有大悲相续者，则一切皆成。
    如是解释悲性等四句之义。应知即是显示，乐大乘者应先令心随大悲转。次依大悲，至诚引发众相圆满大菩提心，既发心已则学菩萨诸行，尤应彻了甚深正见。
    ──────────────────────────
    从大师的言教中我们可以得出：
一、菩萨因见众生苦，而起大悲，欲拔济众生出苦海，成就佛道。因此大悲是大乘道的基础。
    二、要完成救度众生的目标，就必须具有种种智慧、种种方便、种种神力，只有如来圆满了这一切功德，因此发心成佛。
    这里有一点必须注意，在本论疏中，如果是为了其他目的要成佛，则不入菩提心之列，因为没有大悲的基础。但在有的经典中，行人只要发心成佛就归为发菩提心，将来毕竟成佛。如《首楞严三昧经》中之魔王，发菩提心的目的竟是为了众魔女退失菩提心，但如来仍为魔王授记，以此因缘将来成佛。
    三、发菩提心后，菩萨发现若不修持般若摄持的诸行，便无法积累成佛的资粮，因而也就无法实现利益众生的理想，因此菩萨修学般若。

    回到仁兄的问题：是不是三因中菩提心总摄悲慧呢？
    在下认为，本论疏中的菩提心（我为利益诸有情故，愿当证得无上菩提）的本质是“愿”。在修空慧以前，此愿是与我、人、众生、寿者共存，这时菩提心中并不包括智慧；但当此心被般若净化后，虽无我、人、众生、寿者，利生之菩提愿照样坚固，此时也可以说菩提心中包含了空慧。
    至于悲，从来就没与本论中的菩提心分开过。

    洛桑吉美：
    拜谢赵叔讲解。
    中观论归敬颂，以说缘起赞佛，入中论归敬颂以大悲心赞佛因。想想，真是微妙。
    谢谢赵叔您慈悲开示！这些疑问积累很久了。主要是觉得如果没有一些基础性的空性见（无二慧，下文解说是因地的慧，不是能所无二等慧），好像发不了大悲心？经过您解说，看来还是可以的。也谢您顺带讲解了发菩提心不同的因相。

    zf：
    “这些疑问积累很久了。主要是觉得如果没有一些基础性的空性见（无二慧，下文解说是因地的慧，不是能所无二等慧），好像发不了大悲心？”
    ──从菩提心七支修法上看，大悲心可以从知恩、报恩心修起。空慧并不是生起悲心的不共因。
    《普贤行愿品》中“因于众生而起大悲，因于大悲生菩提心，因菩提心成等正觉”的开示也说明，生起大悲的原因是众生之苦。
    大悲心的生起虽然可以不靠空慧，但大悲心的实践（即菩萨行）若离开般若的护持却难以深入和持久。《摩诃般若经》对此有详细的开示。


戒绝对五欲的贪著，同时发起无上菩提心

    罪报所生：
    赵叔，“欲乐”这个词的意思是什么？“诸法即缘故，住于欲乐上”，请问欲乐是指好恶的意思吗？

    zf：
    “欲乐”也就是“乐欲”，《佛光大词典》的解释如下：
【乐欲】愿求欲望。又作欲乐。其义有二：（一）指闻法修行方面之乐欲，即于一切智及诸法藏，生志求不怠、欲乐无厌之心。法华经卷一序品（大九·四上）：“尔时，会中有二十亿菩萨，乐欲听法。”（二）指凡夫所求五欲之乐，此为一切烦恼之根源。最胜王经卷一（大一六·四○七上）：“一切烦恼，以乐欲为本，从乐欲生；诸佛世尊断乐欲故，名为涅槃。”［大宝积经卷四、盂兰盆经疏（宗密）］

    罪报所生：
    那么，对乐欲的态度是否是小大密乘的分水岭？对乐欲是戒还是转？“发菩提心的根本是转变乐欲”，转的轴心是空性正见。这样说对吗？

    zf：
    大小乘的根本区别在于是否有无上菩提心。（当然两者对“无上菩提”的认识有相当的差别。）

    “对乐欲是戒还是转？”
    ──依在下浅见，将乐欲由对五欲的贪著转成对无上菩提的追求，这一表述等价于“戒绝对五欲的贪著，同时发起无上菩提心。”

    “‘发菩提心的根本是转变乐欲’，转的轴心是空性正见。这样说对吗？”
    ──事实上，由于乐欲之自性空，因此对其之“转”或“戒”才具有可能性，从这一角度观察，说转或戒的轴心是“空”有其道理。
    但从修行的次第上说，转或戒并不是要在证得空性后才能开始，转或戒常常是证空性的基础。


不忍独自出离，则当发起无上菩提心

    一大全：
    诸法从缘生亦复从缘灭。什么叫生？又什么叫灭？什么叫非因缘非自然的妙真如性？怎么了生死？怎么才能做到不生不灭？怎么断烦恼习？

    zf：
    大家学佛，在论坛上交流心得，有先学有后学，无论先学后学，总之都是同学。下面谈谈对您所提问题的看法，供参考。
    “什么叫生？又什么叫灭？”
    ──谈到生灭，其前提是心中先有一法的概念（色法或心法），此法从无到有称之为生，从有到无称之为灭。这是通常人们的见解。如来开示缘起正见，认为诸法依因缘的具足而生起，依因缘的散坏而破灭。所谓的生，仅仅是缘起；所谓的灭，亦仅仅是缘散。实际上并没有一法真正地生起和破灭。所谓的法，仅仅是假名，是诸因缘的作用，并无任何不依赖于因缘的属性。缘起即是法的不起（即不生），缘灭即是法的不灭。

    “什么叫非因缘非自然的妙真如性？”
    ──先说真如，虽然真如本不可说。
    从辞典中可以查到：真者真实之义，如者如常之义，诸法之体性离虚妄而真实，故云真，常住而不变不改，故云如。唯识论二曰：‘真谓真实，显非虚妄。如谓如常，表无变易。谓此真实于一切法，常如其性，故曰真如。’真如是以肯定的方式表述法性，从否定方面对法性的表述是空性、无自性性等。需要注意的是，将“常住而不变不改，故云如”，理解为此真实之法性不随时间的改变而变化虽没有错，但应进一步去体会：时间的体性亦是妙真如性，此真如之中并无虚妄的时间相。“妙真如性非因缘”是说，此真如性不是依诸因缘而生起的有为法。以水波为喻，水之湿性（喻真如）并不是以水的流动性和风等为因缘而生起的波浪（喻缘起法）。一些学人错会水波之喻，将真如理解为某种常恒不变的本体，为常见、一见所缚，与外道同伍。须知，此真如性是彻底的空，是缘起法的无自性性，与外道见完全不同。一类无因外道，主张一切万物非依因缘，而是自然所生者。“妙真如性非自然”是开示，此妙真如性并不是与因缘法无关自然而然地存在。事实上，此真如性与因缘法乃非一非异。非一即妙真如性非因缘，已如上说；非异是说，此真如性依缘起法而开显。缘起法的无自性性就是真如。

    “怎么了生死？怎么才能做到不生不灭？怎么断烦恼习？”
    ──兄若急于自己了脱生死、断烦恼习，修习的总纲当是发出离心，修般若波罗密多。而般若波罗密即是开示妙真如性回向解脱的智慧。兄若念及尚有无量众生流落生死，不忍独自出离，则当发起无上菩提心──愿证取对救度众生有用之无量智慧、无量方便。以无上菩提心为父、以般若波罗密多为母，依菩提道次第的原则修行，而获自利利人的大益。上述两条路，兄愿选哪条？

    一大全：
    我愿意选择后者。因为后者不但自利，而且能利他！

    zf：
    至诚随喜大全兄自利利他的殊胜发心，发无上菩提心为入大乘的根本。据说，我等凡夫，身处五浊恶世，特别是以在家之身，为利众生，发心欲证无上菩提，如来都觉是难中甚难之事。是故若有一众生发心欲成佛道，诸佛菩萨皆欢欣异常，齐声赞叹。具体修行方式，虽总原则为菩提道次第，但因个人宿世因缘不同，今生修持的重点也会有差异。但一点可能是共同的──下功夫。
    我主张行人应该在年轻记忆力好时背诵一两部佛经，经的选取可因人而异，如《金刚经》和《普贤行愿品》。（在下正在背诵《华严经初发心功德品》，还没背下来，惭愧）。心中装有一两部佛经的好处是巨大的，在我们不经意时，一些经中的内容就会浮现出来，供我们反复体会，加深理解。这一点有点象骆驼等反刍动物，遇到食物时先囫囵吞枣地吃下去，待有时间时再细细咀嚼消化吸收。
    心中装有佛经的另一个好处是可以于自身生佛舍利塔想。经文即是佛之法身舍利，对佛弟子来说，其功德比佛之化身舍利（佛骨等）更为殊胜。如来开示：“诸法从缘起，如来说是因，彼法因缘尽，是大沙门说”四句偈即等同佛舍利，如塔中安放此偈，此塔即是佛舍利塔。《金刚经》中亦说“若是经典所在之处则为有佛”，可见佛经即是佛。如果自己心中装有佛经，自身四大之肉身立时变成相好庄严的舍利宝塔，能自然而然生起种种利益众生的事业。
    总之，背诵佛经的利益甚大，望我们共同下功夫。

    小赵：
    您讲：“兄若急于自己了脱生死、断烦恼习，修习的总纲当是发出离心，修般若波罗密多。而般若波罗密即是开示妙真如性回向解脱的智慧。”这种方式证得的是什么果位？是佛还是罗汉？

    zf：
    若真正与般若波罗密多相应，即修习妙真如性回向佛之一切种智，则所得果位应是如来，此点兄所理解无疑正确。
    若急于自己了脱生死、断烦恼习，在出离心的摄持下，修般若波罗密多，则所得果位应是阿罗汉。为何同修般若波罗密多，果位却不相同？原因在于发心，是二乘的发心阻碍了般若完全发挥其应有的作用。因此二乘所修般若实际上仅是菩萨所修般若之少分。但两者毕竟一味，如杯中水与大海水，故经中亦言般若波罗密多是诸佛母、菩萨母，也是声闻之母。


发菩提心的行者不可退失大乘

    发菩提心的行者不可退失大乘

    zf

    大乘法同二乘法相比难行，发心欲修大乘者心里应有充分准备，不应听有人言大乘难行而心生退却之意。《佛说首楞严三昧经》中，如来广说大乘菩萨修学首楞严三昧的殊胜功德，诸菩萨表示：“世尊。人宁作五逆重罪。得闻说是首楞严三昧。不入法位作漏尽阿罗汉。所以者何。五逆罪人闻是首楞严三昧。发阿耨多罗三藐三菩提心已。虽本罪缘堕在地狱。闻是三昧善根因缘还得作佛。世尊。漏尽阿罗汉犹如破器。永不堪任受是三昧。”是故闻大乘法、发菩提心的诸位行者，宁堕地狱，亦不可退失大乘。

    《佛说首楞严三昧经》中，世尊和文殊师利菩萨称赞大乘菩萨方为真正的福田第一和多闻第一，“说是法时二百菩萨生懈怠心。诸佛世尊其法甚深。阿耨多罗三藐三菩提如是难得。我等不能具足是事。不如但以辟支佛乘入于涅槃。所以者何。佛说菩萨若有退转。或作辟支佛或作声闻。”
    “尔时文殊师利法王子。知此二百菩萨有懈退心。欲还发起令得阿耨多罗三藐三菩提。亦欲教化会中天龙夜叉乾闼婆阿修罗迦楼罗紧那罗摩睺罗伽等故。白佛言。世尊。我念过去劫名照明。我于其中三百六十亿世。以辟支佛乘入于涅槃。尔时一切众会心皆生疑。若入涅槃不应复还生死相续。今文殊师利。何故作如是言。世尊。我念过世劫名照明。我于其中三百六十亿世。以辟支佛乘入于涅槃。是事云何。尔时舍利弗承佛神旨。白佛言。世尊。若人已得入于涅槃不应复有生死相续。云何文殊师利。入涅槃已还复出生。佛言。汝可问之文殊师利。自当答汝。时舍利弗。问文殊师利言。若人已得入于涅槃。于诸有中不复相续。汝今云何而作是说。世尊。我念过去照明劫中。三百六十亿世。以辟支佛乘入于涅槃。此义云何。文殊师利言。如来现在。是一切知者。一切见者。真实语者。不欺诳者。世间天人无能诳者。我所说者佛自证知。我若异说则为诳佛。舍利弗。彼时照明劫中。有佛出世号曰弗沙。利益世间诸天人已入于涅槃。是佛灭后法住十万岁。法灭之后其中众生。于辟支佛有度因缘。假使百千亿佛。为之说法不信不受。唯皆可以辟支佛身威仪法则而得度脱。是诸众生皆共志求辟支佛道。是时无有辟支佛出。是诸众生无处得种善根因缘。我于尔时为教化故自称我身是辟支佛。随诸国土城邑聚落。皆知我身是辟支佛。我时皆为现辟支佛形色威仪。是诸众生深心恭敬。皆以饮食供养于我。我受食已。观其本缘所应闻法。为解说已。身飞虚空犹如雁王。是时众生皆大欢喜。以恭敬心头面礼我。而作是言。愿使我等于未来世皆得法利如今是人。舍利弗。以是因缘成就无量无数众生令种善根。我时观察知诸人众供养我食生懈厌心。即时告言。我涅槃时至。百千众生闻是语已。各持华香杂香苏油。来至我所。我于尔时入灭尽定。以本愿故。不毕竟灭。是诸众生谓我命终。供养我故以香薪[卄/積]而烧我身。谓我实灭。我时复至异国大城。自称我是辟支佛身。其中众生亦以饮食来供养我。我于其中示入涅槃。亦谓我灭。皆来供养共烧我身。如是舍利弗。我于尔时满一小劫。三百六十亿世。作辟支佛身示入涅槃。于诸大城。一一皆以辟支佛乘。度脱三十六亿众生。舍利弗。菩萨如是。以辟支佛乘。入于涅槃而不永灭。文殊师利说是语时。三千大千世界六种震动。光明遍照。千亿诸天供养文殊师利法王子。雨诸天华。皆作是言。是实希有。我等今日得大善利。见佛世尊。及见文殊师利法王子。又闻说是首楞严三昧。世尊。文殊师利法王子。成就如是未曾有法。住何三昧能现如是未曾有法。佛告诸天。文殊师利法王子住首楞严三昧。能作如是希有难事。菩萨住此三昧。为作信行而不随他信。亦作法行。而于法相转于法轮不退不失。亦作八人。于诸无量阿僧祇劫。为八邪者而行于道作须陀洹。为生死水漂流众生。不入法位作斯陀含。遍现其身于诸世间。作阿那含。亦复来还教化众生作阿罗汉。亦常精进求学佛法亦作声闻。以无碍辩为人说法作辟支佛。为欲教化因缘众生示入涅槃。三昧力故还复出生。诸天子。菩萨住是首楞严三昧。皆能遍行诸贤圣行。亦随其地有所说法而不住中。诸天闻佛说如是义。悉皆涕泪而作是言。世尊。若人已入声闻辟支佛位。永失是首楞严三昧。世尊。人宁作五逆重罪。得闻说是首楞严三昧。不入法位作漏尽阿罗汉。所以者何。五逆罪人闻是首楞严三昧。发阿耨多罗三藐三菩提心已。虽本罪缘堕在地狱。闻是三昧善根因缘还得作佛。世尊。漏尽阿罗汉犹如破器。永不堪任受是三昧。世尊。譬如有人施苏油蜜。多有人众持种种器。中有一人用心不固破所持器。虽诣所施苏油蜜所无所能益。但得自饱不能持还施与余人。是中有人持器完坚。既得自饱亦持满器施与他人。苏油蜜者是佛正法。所持器破但得自足。不能持还施他人者。即是声闻及辟支佛。持完器者即是菩萨。身自得足亦能持与一切众生。是时二百天子。心欲退转于阿耨多罗三藐三菩提者。从诸天子闻是语已。及闻文殊师利法王子不可思议功德势力。更以深心发阿耨多罗三藐三菩提。不复随先退转之心。皆白佛言。我等乃至危害失命不舍是心。亦终不舍一切众生。世尊。唯愿我等闻是首楞严三昧善根因缘。当得菩萨十力。何等十。于菩提心得坚固力。于不可思议佛法得深信力。多闻得不忘力。往来生死得无疲力。于诸众生得坚大悲力。于布施中得坚舍力。于持戒中得不坏力。于忍辱中得坚受力。魔不能坏得智慧力。于诸深法得信乐力。尔时佛告坚意菩萨。若有众生于今现在若我灭后。闻是首楞严三昧能信乐者。当知是人悉皆得是菩萨十力。”


菩萨大悲心用的显现

    （编按：本文系关于“迷惑”网友自述某次感受到佛菩萨的影像出现的讨论，有删节。）

    笑疯子：
    即使是“真”光影也不是什么值得褒奖，况且只是一种觉受，是不是心性的光明，在下认为，如果真正明心见性，就知道那一切了！真正的明心见性，就是见到了观世音菩萨！

    zf：
    菩萨的大悲心用，在因缘和合时是可以被我等凡夫以光影和声音方式感知的。菩萨这种心用的显现与胜义谛并不矛盾。明心见性这个标准固然不错，但用它来要求初学者未免过高了。因此“迷惑”兄所感受的观世音菩萨，对我等来说都应是个鼓励。

    迷惑：
    我在呢，也准备走了。从那天后，我感触很深，心也特别清静。我在网络下载了一些佛经好好看看，也看了网上的一些学佛的事迹。
    但看到这儿的一些猜疑、嘲讽……我不想再说什么，谢谢这么多鼓励指导我的人！愿所有的人能够真正向观世音菩萨学习，有一颗救苦救难善良慈爱的心！

    zf：
    有兴趣的话建议看一点“菩提道次第”方面的著作。观世音是为你显现的，也是为我们大家显现的。从这个角度看，你是我们大家的善知识。这里的一些学人有意以坦然接受“嘻笑怒骂”的方式来使自己的脸皮变厚，实际上脸皮加厚的过程也是修习忍辱的过程（当然也存在着变无耻的危险），大家欢迎您回来。


心量学“大”先“假装”

    bird：
    各位师兄，心量的大小是不是很难改变的？要学“大”，从何学起？如何护持？后学颇有无从下手之感……

    zf：
    说难也难，说不难也不难。
    如果认为有变大的必要性，就只有知难而上一条路了！
    要学“大”，下手的方式很简单──先假装大，慢慢“装”成习惯了，就真的大起来了。
    具体方法：读《普贤行愿品》。普贤菩萨的心量够大的了，建议老兄花上几年或十几年或几十年的时间，学“装”普贤菩萨。没事时心里经常念叨着：“一切如来有长子，彼名号曰普贤尊，我今回向诸善根，愿诸智行悉同彼。愿身口意恒清净，诸行刹土亦复然，如是智慧号普贤，愿我与彼皆同等。”
    回想起来，在下自己近些年来心量比以前大些了，上述“假装”的方法功不可没。
    建议老兄试试，肯定很灵。


越过发心和退心的循环

    htc：
    我有时产生学佛的心思了，就看几页佛教书，在睡觉前打坐，日常生活中也保持一些有关修行的心念。经过两三天之后，连修行的念头都没法提起来了，精神状态变得非常无聊，什么都没意思，这时我多半就玩电子游戏，过一段时间，或长或短，又觉得总是做些浅薄的刺激感官的事情也没什么结果。于是修行成道对我又有吸引力了。至今皈依、学佛时间好几年了，一点进步也没有。不知别人有没有这种感受？能不能超越过这反复循环的状态？有没有比较有效的办法？

    zf：
    有一个办法可以试一试。抽空到附近一个大一点医院的急救室附近坐一坐，去看看那些进去时的活人，推出来的尸体。其中有老人，也有年轻人，去感受一下那种命在旦夕的气氛，进而仔细思考如来关于“无常”的教诲。这样或许对提高自己修行上的“精进”有些帮助。


从心底里发起无上菩提心

    涛声依旧：
    总想自己有更多的慈悲，却很难。悲难，慈更难。
    雪中送炭曰慈，予乐拔苦曰悲。
    予乐拔苦的前提是对苦与乐的透彻。
    雪中送炭的前提是对自与他的透彻。
    每当我自以为在予乐拔苦时，谁知是不是在流毒。
    每当我自以为在雪中送炭时，谁知是不是在下毒。
    慈悲很难，但在我努力与大家融到一起时，
    相信慈悲总是会增长的，只是还需要很长的努力。
    还请大家帮我。

    薄地凡夫的我难辩正邪，真怕有一天……
    自以为正直时却在邪行，
    惹得菩萨们失去了耐心，
    惹得菩萨们都厌弃了我。
    我真怕……。
    于是我开始告诫自己，
    若我是菩萨，尽量不放弃人群的每一份。
    动之以情，晓之以理，表之以行……。

    成佛前谁能说自己无邪？
    其实正邪只是自己的一种以为，
    实际上因缘错综复杂，哪是正邪所能了得。
    与其辩别正邪滋生亲疏远近，
    还不如去理解行为的理由与个体的需求，
    力求行一份离苦得乐的助缘与推动。
    以上是我不得其解之解，还望指点。

    zf：
    涛兄请进

    “总想自己有更多的慈悲，却很难。悲难，慈更难。
    雪中送炭曰慈，予乐拔苦曰悲。
    予乐拔苦的前提是对苦与乐的透彻。
    雪中送炭的前提是对自与他的透彻。”
    ──因此我要克守古训──—己所不欲，勿施于人。

    “每当我自以为在予乐拔苦时，谁知是不是在流毒。
    每当我自以为在雪中送炭时，谁知是不是在下毒。”
    ──因此我要从心底里发起无上菩提心。
    ──以使自己不但动机正确而且方法得当。

    “慈悲很难，但在我努力与大家融到一起时，
    相信慈悲总是会增长的，只是还需要很长的努力。”
    ──释迦牟尼佛尚要经历长时的苦行，
    ──再长的时间我也要忍受。

    “自以为正直时却在邪行，
    惹得菩萨们失去了耐心，
    惹得菩萨们都厌弃了我。”
    ──虽然真正的菩萨会视我为母，对我悉心呵护，
    ──但我要牢记佛陀的最后嘱托──以戒为师。

    “我真怕……。
    于是我开始告诫自己，
    若我是菩萨，尽量不放弃人群的每一份。”
    ──还有六道父母中的每一个。
    动之以情，晓之以理，表之以行……。

    “成佛前谁能说自己无邪？
    其实正邪只是自己的一种以为，
    实际上因缘错综复杂，哪是正邪所能了得。
    与其辩别正邪滋生亲疏远近，
    还不如去理解行为的理由与个体的需求，
    力求行一份离苦得乐的助缘与推动。　”
    ──只要助缘与推动的目标是指向轮回的解脱。


成佛的可能性要变成现实性，关键步骤是发菩提心

    zf：
    一切众生是否均为菩萨？
    某兄认为，如来说一切众生都能成佛，因此一切众生都是菩萨。此言本人不敢同意。原因是，本人理解，佛说一切众生都“能”成佛的“能”是“可能”义，而非现实义。此可能性要变成现实性，关键步骤是发菩提心。因此，未发菩提心的众生不能称其为菩萨。
    《首楞严三昧经》中，如来对未发心众生的授记如下：“云何名为有未发心而与授记。或有众生往来五道。若在地狱若在畜生若在饿鬼。若在天上若在人间。诸根猛利好乐大法。佛知是人过此若干百千万亿阿僧祇劫。当发阿耨多罗三藐三菩提心。又于若干百千万亿阿僧祇劫。行菩萨道。供养若干百千万亿那由他佛。教化若干百千万亿无量众生。令住菩提。又过若干百千万亿阿僧祇劫。当得阿耨多罗三藐三菩提。”显然，这一授记并非对所有众生的授记，而是佛以其无碍的智慧对那些“诸根猛利好乐大法”众生的授记。此中的恶魔虽以谄曲心而发心，但毕竟已发菩提心，其于行门功德虽然丝毫也未生起，但其功德亦如碎金刚宝，光明映蔽一切二乘之金。因此，此经中的恶魔，已非普通的恶魔，而是一位地地道道的初发心菩萨！

    xixi：
    从你这一贴看，离佛道远矣。一切众生皆佛，别以为这仅仅是方便说。绝无“众生仅仅是有成佛的可能而已”。

    zf：
    xixi兄不公平！于兄心中，一切众生皆佛，为何却将本人一脚踢得远离佛道！！！


如来亲证十力、十八不共法

    yang：
    赵叔学富五车，但于根本佛法始终不能入门的根本原因即在不能放弃自我……一大藏教在您那里变成了一个等级森严的理论体系，学修佛法这种以认证实相为目的的简单活动也变成了从小学中学到大学博士的繁杂学术体系……

    zf：
    yang兄好，Yang兄和在下都是十分“顽固”的主儿，在下的顽固劲儿在以前的讨论中想必yang兄已有所体会。但对在下这种顽固不化者yang兄还肯不弃，苦口婆心，在下心中由衷敬佩。
    Yang兄，我俩在修行道上见解有巨大差异的根本原因在于，我俩心中佛的含义是不同的。若如兄所说，佛就是一位自证的阿罗汉，则兄所说之“简单活动”“立杆见影”“立证”等等，在下全部同意。但如果如来并不是一位自证之阿罗汉，而是亲证十力、十八不共法，则yang兄所谓之“简单活动”便大可商榷。将本来简单的事情复杂化是愚蠢，将本来复杂的事情简单化是什么呢？毕竟，世界上并非只有简单的事情。
    Yang兄，只要在下心中之如来不是自证之阿罗汉，在下便绝不可能入兄之“根本佛法”门。Yang兄对在下不薄，在下无以回报，只是想给您提个醒儿：将来一旦发现自己心中的“根本佛法”并不究竟，原为如来所设之化城，万莫因今日之“亲证”，而碍于面子不肯出城继续赶路。

    yang：
    如果我发现是化城，一定会出来，我这里没有面子，只有实相，多谢赵叔；如果赵叔有一日发现那些才是化城，也请立即回归；同时我等二人不妨都在日常的修学中存着对方的“异见”，可能会有好处。

    zf：
    一言为定！甚好，这样才是“建设性”的交流！


仁兄，这三种人您想做哪一种？

    本春居士：
    我们都知道佛陀头痛三天的典故，对于一个俱解脱者，不会这样的，是否佛陀仅仅是为了告诉我们因果不虚的道理，才示现呢？
    真修行乃“一人与万人战”，是不是说除了我们自性五阴魔害怕没有依附物而捣乱，所有有因果联系的同样害怕其“联系”被剪断而来障碍？

    zf：
    关于“一人与万人战”
    “真修行乃‘一人与万人战’，是不是说除了我们自性五阴魔害怕没有依附物而捣乱，所有有因果联系的同样害怕其‘联系’被剪断而来障碍？”
    ──这主要看行人的发心和行持。
    村里的一人要进城永久居住，但与村民之间有很多债务问题没有了结。此人若欲强行离村，恐怕要“一人与万人战”了！
    村里的另一人同样要进城，但不是躲债，而是打工赚钱，并保证将来有钱时一定首先还钱。村民们还会阻拦此人吗？
    村里还有一人突发横财，不但如数还清债务，而且广兴布施，施予贫乏。万人会来与此人战吗？
    仁兄，这三种人您想做哪一种？


菩提心与体会空性

    菩提心与体会空性

    二麻子

    菩提心不引生空性的……
    空性也不引生菩提心。为什么？不自生。空性与菩提心根本是同一个东东，谁生谁？
    所以，修空性显发菩提心是很正常的，不需要更多的道理。反之亦然。
    不能显发菩提心，换种表达方式，也是空性没修透，不圆满。再换个说法，叫智慧不够。嘻嘻。
    一个细微的问题，你帖子里有句“或者说圣义菩提心只有证悟空性的登地菩萨才能生起”。类似的，很多人引用古德论述来说明，“XX只有到了YY地的才能知道”等等……这类东西看多了看久了，麻子不由得就多了点闲操心的担心。是不是有点推高圣境，让学人不敢企及了？但愿麻子是多余的担心。我们学佛过程里常常出两种不准确，过分大胆“承当”结果颟顸佛法是一种，过分推高圣境导致望而却步是另一种。两种偏差都不利我们修学，我们却也很难完全排除这些偏差。
    像上面那个论述，在麻子看来，其次第上的意思是登地菩萨都能证悟空性生起胜义菩提心，而不是排除说凡夫都不能体会空性。实际上，能体悟点空性味道的毛道凡夫其实（个数）不少，当然，比例还是很低的。这就是说，很多菩萨们做的事，我们凡夫也照样可以学着做起来。虽然还不能做得很好，也未必全然不能学着做。这地方随便一说只有“XX”才能做自己就此放弃努力，麻子觉得这绝不是学佛的增上因缘。
    麻子并无意说你老兄就犯了这个病，但对这类说法可能平常里潜移默化给人种下的种子，表示担心。


慈悲心的修学

    傻丫：
    请谈谈对众生生起慈悲心的经验体会，并提供修学的入门方便。

    zf：
    惭愧！“傻丫”兄重视慈悲心的修学，的确抓住了大乘的根本，因为菩萨修行，以大悲为首。修学慈悲心始终是本人修学重点中的重点、核心中的核心。为什么？《普贤行愿品》中说：“诸佛如来以大悲心而为体故”，所谓“体”者，乃本质、核心、精髓之义，我等既发愿学佛，自然应该特别重视此“如来体”。但若说到让在下谈谈“生起慈悲心的体会”，我只能非常惭愧地告诉您：自己慈悲心至今也没能真正生起。
    真正的菩萨，不但悲心广大，而且更为重要的是难行能行。《华严经》宣说：“佛子。菩萨摩诃萨。见有乞求其身髓肉。欢喜软语。谓乞者言。我身髓肉。随意取用。如饶益菩萨。一切施王菩萨。及余无量。诸菩萨等。于诸趣中。种种生处。以其髓肉。施乞者时。欢喜广大。施心增长。同诸菩萨。修习善根。离世尘垢。得深志乐。以身普施。心无有尽。具足无量广大善根。摄受一切妙功德宝。如菩萨法。受行无厌。心常爱乐布施功德。一切周给。心无有悔。审观诸法。从缘无体。不贪施业。及业果报。随所会遇。平等施与。”这是何等广大的悲愿！反观自己，不要说以身布施根本做不到，就是财布施也极少。现在有许多儿童因为家境贫穷上不起学、有许多人因为没钱重病得不到及时治疗，但本人并没有将积蓄布施给这些贫穷的儿童和病者，而是自己过着相对安逸的生活。因此，本人实际上没有资格介绍修学大悲的经验。但既蒙兄点名，只好打肿脸充胖子，谈谈自己的一点“理论心得”。
    《华严经·离世间品》中开示：“佛子。菩萨摩诃萨。以十种观众生。而起大悲。何等为十。所谓观察众生。无依无怙。而起大悲。观察众生。性不调顺。而起大悲。观察众生。贫无善根。而起大悲。观察众生。长夜睡眠。而起大悲。观察众生。行不善法。而起大悲。观察众生。欲缚所缚。而起大悲。观察众生。没生死海。而起大悲。观察众生。长婴疾苦。而起大悲。观察众生。无善法欲。而起大悲。观察众生。失诸佛法。而起大悲。是为十。菩萨恒以此心。观察众生。”“菩萨摩诃萨。知一切法本性清净。无染著。无热恼。以客尘烦恼故。而受众苦。如是知已。于诸众生。而起大悲。”
    六道众生于轮回中所受诸苦，经论中多有描述，无须在下重复。若我等众生命该如此，根本就没有解脱的可能，则我们只好认命、无可奈何、听之任之了。但据如来开示，我等众生本性清净、本具如来智慧德相，以客尘烦恼故而受众苦。只要我们依佛教诲如说修学，就可以彻底摆脱一切苦及苦因、获得一切乐及乐因。本人深自庆幸，有机缘得遇上师三宝，走上脱离轮回诸苦的解脱大道。但观察周围群人不信三宝、不植善根，虽有成佛的可能而不知修行，诸病缠身、诸苦攻心、为人轻贱，心中便生起难言的怜悯。至于畜生道的众生，受人鞭打、任人宰割，更是可怜。本人虽然立志以观音等大菩萨为榜样，决不舍弃众生而自求安乐，但在实际行动上却说得多做得少，实在惭愧！
    最后，在下愿以《华严经·入法界品》中世尊开示之“诸菩萨心之所念”与诸位共勉：愿我等尽未来际，以“大悲为身、大悲为门、大悲为首。以大悲法，而为方便，充遍虚空，一切世间，普皆严净。”

    yang：
    生起慈悲心的修法若连您都无法实行，她的意义何在？难道专度上上上上根人么？

    zf：
    本人正在修行，但不敢未证言证。如何能因此得出慈悲心修法无意义的结论？？？

    非多：
    请教如何作到大悲显现充遍虚空？所谓的“大悲周遍”、“同体大悲”与上文中“大悲法充遍虚空”，觉得挺难理解，因此特恭请善知识详加开示，启蒙初学。

    zf：
    一点体会，关于“大悲周遍”、“同体大悲”与“大悲法充遍虚空”，的确不易把握。菩萨乘与声闻乘的最大区别就在于是否有周遍的大悲。我等立志修学大乘者，皆不欲舍弃众生而求个人解脱，但如何将自己有限的悲心平等地扩大至一切有情，确实是大乘修学的基础和关键。因此在下非常愿意与兄等交流这方面的学习心得。
    走上解脱道路的行者，无一例外都对各自身心的苦深有体验。但要将为自己解脱而修行的心扩展到为利益一切有情而修行却并非易事。我等初学有时虽有此愿，但常感心力不够，有些人知难而退，退至二乘。有没有善巧方便可以帮助欲修学大乘者度过此难关？答案是肯定的。这一善巧方便就是般若波罗蜜多。
    《佛说佛母出生三法藏般若波罗蜜多经》中开示：“复次，须菩提！譬如有人乘船入海，船忽破坏，是人若不取彼浮囊，或木或板等，当知是人，即于中路没水而死，由此因缘不到彼岸。须菩提！菩萨摩诃萨亦复如是。于阿耨多罗三藐三菩提，有信有忍，有爱有欲，有解有行，有喜有乐，有舍有精进，有尊重，有深心，有净心，离放逸不散乱。虽具如是功德，若不得般若波罗蜜多善巧方便所护念者，是菩萨即不能成就一切智果，于其中路有所退失。须菩提！云何名为中路？又复退失何法？须菩提，中路者所谓声闻缘觉之地，所退失者谓一切智果。”
    这一开示告诉我们，若有人对无上菩提有信、有忍、有爱、有欲、有解、有行、有喜、有乐、有舍、有精进、有尊重、有深心、有净心、离放逸、不散乱，虽然如是，若不得般若波罗蜜多善巧方便所护念，还是不能成就佛果，而退失至声闻缘觉的二乘之地。
    该经中还说：“又如世间百二十岁老人，忽于一时为彼风癀痰癊诸病侵恼，以是因缘忍苦于床。须菩提！于意云何，是人若时无人扶侍，当能从床而自起不？须菩提言：不也，世尊。佛言：须菩提，是人设或能从床起，亦不能行一里二里乃至由旬。何以故？已为老病所侵恼故。须菩提！菩萨摩诃萨亦复如是，于阿耨多罗三藐三菩提有信有忍，乃至离放逸不散乱。虽具如是功德，若不得般若波罗蜜多善巧方便所护念者。当知是菩萨，于其中路有所退失，堕于声闻缘觉之地，不能成就一切智果。又须菩提，而彼百二十岁老人，虽复有疾忍苦于床。若时有二力士，来谓其言：我等二人各于左右扶侍于汝，汝速当起随有所往，令汝得至，勿忧中路有所退失。时老病人受其语故，能从床起随往得至。须菩提！菩萨摩诃萨亦复如是，于阿耨多罗三藐三菩提，有信有忍乃至离放逸不散乱。具足如是功德已，复得般若波罗蜜多善巧方便所护念者。当知是菩萨于其中路无所退失，不堕声闻缘觉之地，即能成就一切智果。”
    这一比喻说明，发菩提心而未得般若波罗蜜多护持的行者，如同有病卧床的一百二十岁老人，无法远行。而般若波罗蜜多犹如于左右扶侍老人的两位力士，可使老人顺利到达目的地——圆满佛果。由此可见般若波罗蜜多对发心修学大乘者的重要性。
    那么，般若波罗蜜多如何帮助我等初学克服菩萨道难行、大悲心难起的畏难心理？请看该经中的以下开示。
    “尔时，尊者舍利子白须菩提言：如我解尊者须菩提所说义，菩萨即是无生法。若如是者，云何菩萨为利众生故，有难行行及难行想？须菩提言：舍利子！我不欲令菩萨摩诃萨有难行行及难行想。何以故？若有难行想即不能利益无量无数众生。若于一切众生，生易想、乐想、父想、母想及彼子想，如是即能利益无量无数众生。菩萨摩诃萨于一切众生当生如是想，我于一切时、一切处，解脱一切苦，一切众生亦如是。于一切时、一切处，解脱一切苦，于一切处不舍众生，普令众生解脱苦蕴，于诸心意不生过失。菩萨摩诃萨于诸众生若生如是心，即无难行行无难行想。舍利子，菩萨摩诃萨应生如是心：如我于一切时、一切处、一切种，毕竟无所有不可得故。彼一切法于一切时、一切处、一切种，亦毕竟无所有不可得。如是即于内外一切法生无所有想。若菩萨摩诃萨以如是心行，即无难行行无难行想。”
    这一段开示的大意是，须菩提说，我不欲令菩萨对菩萨道有难行的想法。何以故？若有难行想即不能利益无量无数众生。若对菩萨道生容易想、生快乐想，对众生生父想、母想及自己的孩子想，如是即能利益无量无数众生。菩萨摩诃萨应于一切众生生如是想：我于一切时一切处解脱一切苦，一切众生亦于一切时一切处解脱一切苦。菩萨摩诃萨应于一切处不舍众生，普令众生解脱苦蕴。菩萨摩诃萨于诸众生若生如是心，即不会对菩萨行生起难行的想法。菩萨摩诃萨应生如是心：如自身心自性毕竟无所有不可得故，一切法之自性亦毕竟无所有不可得。如是即于内外一切法之自性生无所有想，若菩萨摩诃萨以如是心行，即无难行行无难行想。
    进一步分析，上述开示大概可分为两部分：
一、菩萨应对众生生父想、母想及自己的孩子想。
    如果我们知道在无穷的轮回中，一切众生都曾作过自己的父亲、母亲和孩子，这样我们利益无量无数众生实际上就是利益自己的父母和孩子。只要能做对父母孩子有利益的事，就是再苦心里也不会觉得苦。这是克服对菩萨道畏难心理的方便之一。金洲大师所传授的菩提心七支修法（知母、念恩、报恩等）便可视为对众生生母想的具体细化。
    二、自我的解脱就是一切众生的解脱。
    这听起来不可思议。但入此不可思议境界的门径就是般若波罗蜜多。
    经中宣说：“菩萨摩诃萨应生如是心，如我于一切时、一切处、一切种。毕竟无所有不可得故。彼一切法于一切时、一切处、一切种，亦毕竟无所有不可得。如是即于内外一切法生无所有想。”但为何菩萨于内外一切法生无所有想，便可契入“我于一切时、一切处、解脱一切苦，一切众生亦如是，于一切时、一切处、解脱一切苦”的奇妙境界？对此，本人是这样理解的。自我及一切众生皆为缘起法，缘起法之自性了不可得。故一切法之法性即是无为不可分别之真如。因为自我及一切众生的本性皆为不可分别之真如，所以自我及众生无二无别——我即众生，众生即我。如华严祖师杜顺大师所说：“性即无为不可分别，随其大小性无不圆，一切亦即全性为身，是故全彼为此。”《首楞严三昧经》中云：“魔界如即是佛界如，魔界如佛界如不二不别。我等不离是如，魔界相即是佛界相，魔界法佛界法不二不别。”此处“如”即为“真如”义。正因为法性真如的不可分别性，一切法皆无二无别，乃至魔界就是佛界。由此可知，自我的解脱就是一切众生的解脱，因为自我就是一切众生。
    菩萨于我即众生、众生即我获得定解，同时心中“于一切处不舍众生，普令众生解脱苦蕴”，则自我所修的功德自然回向一切众生，因众生即我故；同时众生所感之苦果自然愿为代受，因我即众生故。如是随着修行的深入，我人众生等相逐渐淡薄，平等大悲心逐渐浓烈。由此可见，般若波罗蜜多确实是将我等有限的悲心平等地扩大至一切有情的殊胜方便。
    寂天菩萨所传之自他互换的菩提心修法与上述修法有相同的意趣。
    如果有利益众生的愿望，再加上般若波罗蜜多的护持，生起大悲心、修行菩萨道并非高不可攀，这就是如来对我们的开示。愿我们一起努力吧。


行愿菩提心应居于菩提心中的核心地位

    酸菜粉条：
    我认为汉传佛教只是不太注重形式上的发心，也就是较不重视完整的发心仪轨而已。这固然可能和汉人较为轻视事相的习性有关，但是相信一部分也是因为汉传信徒对菩提心的认知，似乎比较接近于《大智度论》所说的那种：“菩萨摩诃萨非为道法故求阿耨多罗三藐三菩提心，为诸法实相性空故求阿耨多罗三藐三菩提。”所以若是过分强调愿菩提心的生起，就形同对道果的追求产生拘执，这对偏以般若空为主流思想的汉传大乘而言，多少是有些忌讳的。再说，在长期受到汉传佛教重视的《金刚经》《法华经》，乃至《地藏本愿经》中，都曾多次提及无上菩提心，所以至少对一名将诵经定为日课的信徒而言，可以说每天都在作愿菩提心的宣誓与熏习，除非他念经是属于顺口溜一族的。

    zf：
    在下浅见，行愿菩提心（对利生事业的追求）应居于菩提心中的核心地位。
    如《金刚经》中对菩提心的开示，首先即是发起欲灭度一切众生之愿，在此基础上，才以金刚般若净化、升华此大愿，成为胜义菩提心。
    又如《华严经初发心功德品》中，发心之所缘中包含了大量对诸法实相的追求，如“欲了知妙世界即是粗世界……一世界即是不可说世界……一念与不可说劫平等”等等。但所有这些对诸法实相的追求都是在行愿菩提心的摄持之下：为令如来种姓不断故、为充遍一切世界故、为度脱一切世界众生故而发菩提心。由此可知，菩萨欲了知众生烦恼的目的不是出于好奇，而是为了灭除众生的烦恼；菩萨欲了知诸法实相的目的也并不是简单地等同于对真理的追求，而是为了获得利生的手段。
    普贤菩萨之“诸佛如来以大悲心而为体故……”之宣说，我们应予以充分重视！


踏踏实实学习大悲心

    聊天：
    如何随顺众生真是个大技巧啊。
    我感觉，不恰当的办法可能适得其反。我曾经就这个问题请教过法师，法师说：首先自己要做好。
    这个回答没有能让我满意，对于习气很重的众生，有些办法很难奏效。当局者迷，你可以告诉他他自己的弊病，但他仍然不愿意改正。你也可以自己做出个好的样子来，但他根本就不愿意效仿。
    归根结底，他的性格是很久很久形成的，在潜意识里，就是生存的手段，你让他改，就象是要剥夺他生存的权利。
    换个角度，这样的众生不可怜吗？过去的伤害造成难以磨灭的印记，他们深在苦中而不自知。我们真要慈悲的话，我还是希望有个善巧的办法。

    zf：

    咱们一起学吧！

    【四摄法】
    菩萨摄受众生的四种方法，即布施、爱语、利行、同事。是大小乘的通用德目。出自小乘的《增一阿含经》卷二十二以下、《成实论》卷二等，广说于大乘的《大般若经》卷四三八、《大品般若经》卷二十四、《大集经》卷二十九、《大智度论》卷八十八、《瑜伽师地论》卷三十八、卷四十三、《大庄严论》卷八等。
    ［释名］　总名为摄，是因菩萨以此四法投众生之情，善巧摄引，以令度脱。或作四事摄法、四摄事、四摄初门、四摄行，简称四事、四法。
    （1）布施：详作布施摄。将财物分与他人曰布，辍己惠人曰施；由此布施摄引众生，令归正道，故名。
    （2）爱语：详作爱语摄。令他爱乐之言语谓爱语，以爱语摄引有情使之开悟，故名。
    （3）利行：详作利行摄。劝人修正行，或复自己三业所起之行善令一切沾利益，谓为利行。以此摄引众生令发心，故名。
    （4）同事：详作同事摄。谓普同众生之事业、利益等，共苦乐、分祸福，以此引摄令众生得道，故名。
    《瑜伽论》（别译《菩萨地持经》卷三）、《大庄严论》论四摄的相互关系，谓布施摄是随摄方便，先布施种种财物，饶益有情，令彼听受所说法，奉行教法，故为随摄方便行。爱语是能摄方便，以和言爱语述正教正理，以正法能摄受有情，故云。利行是令入方便，先授正法，由行利行，令彼有情出不善处而入善处，令过度生死入泥洹道，故云。同事是随转方便，相共修正事业，行正道，令随时转向正道，故云。
    ［种别］　四摄克实言之，虽以巧慧为体，但因相状有异，彼此互有差别。
    （1）布施分财施、法施两种。前者是施与财物，后者是说授正法；加上救人厄难的无畏施，即成三施。更加报他恩而行布施的报恩施，即成四施。另外尚有八施、九施、十施等。
    （2）爱语以离口之四过为体。就其所说，可分二种。一是随从世间语而慰问、咒愿、赞叹的世间爱语，一是宣说正法的出世间爱语。
    （3）利行大分为进退二门。又随人而分为四，即：1、方便随顺无德善人，2、称扬赞叹有德善人，3、呵责易调之恶人，令彼悔改，4、以神力降伏难调之恶人，令舍恶。其中，前二者是集善摄取，后二者是离恶摄取。
    （4）同事另有同行、同利二异名。若通释之，三者当具同一义，但《大乘义章》卷十一（末）加以分别。同事最下，因菩萨为化益，先俯同众生的苦乐之故；同行居中，与众生同修善根之故；同利最上，化物成德，令来同菩萨之故。又，依《地持论》等，同事有苦事同、乐事同二种，同行有集善行同、离恶行同二种，同利也有自分德同、胜进行同二种。
    ［对配］　《阿差末经》将四摄与六度对配如下︰
    （1）布施摄遍摄六度，其中的财施摄檀度；无畏施摄戒、忍；法施摄精进、禅定、智慧。
    （2）爱语摄涵摄戒、忍，因口离四过是摄属于戒之故。
    （3）利行摄涵摄精进度，劝化众生之故。
    （4）同事摄涵摄定、慧二度，俯同所成定、慧众生之故。
    《地持论》以四摄配十地，说四摄本遍通诸位，若随义而分，初地先行檀利他，能施财，故为施增上，又修法施，故爱语增上。第二地持戒坚固，口离四过，故爱语增上。第三地对众生修习十种救度行，故利行增上。第四地不舍众生而修道品，故为同利增上。
    ［次第］　《大乘义章》分三门论述四摄的次第。
    （1）就修入次第言：施除外悭，其行易修，故初举；爱语由戒分所摄，难作，故次举；爱语是离口之四过的离恶行，较属于集善之行的利行易成，故利行次举；依此利行，功德成就，与上地诸菩萨同德，故同事最后出。
    （2）就起用次第（起摄化众生之大用的次第）而言：菩萨须先俯同众生之卑下，故同事当为最初。其次若对贫人当布施救其贫苦，以爱语教化，遂授利行；若对恶人当行爱语令舍恶，布施资养令随顺，以令利行起修，故其次第并不一准。
    （3）就摄益次第（摄益一位众生的次第）而言：其次第同第一门，即先以布施摄取其身；次以爱语摄取其心，令生信解；次以利行令起行；依此令与菩萨同德，故第四出同利。

    ◎附：木村泰贤著·欧阳瀚存译《原始佛教思想论》第三篇（摘录）

    统摄一切团体之道德，佛陀所最重之德目，即所谓摄事是也。盖摄事为众生互相团结之条件之义，依据其名称，当已知为对于团体之物。摄事有四，名为四摄事，第一布施，第二爱语，第三利行，第四同事，乃前《六方礼经》朋友门之摘要。第一布施者，富者施贫者以财，贤者施愚者以法，由是团体之各员，互相扶助，有无相通，使团体生活，得向上圆满。第二爱语者，互以和悦之言，谈论慰藉，推而至于日常酬对之词亦属之。夫欲使团体融洽，固为不可缺之要素也。第三利行者，团体生活之利益。即顾全公益，以现今流行语言之，是为社会服务。第四同事者，自身同化于团体。即依从团体之规则及习惯而行动之义，盖团体德目中之最重要者，假使无此精神，则社会莫能成立为一团体矣。虽然，若团体之恶德，而自身亦同化之，则为佛陀所戒禁，故佛陀特谓此为‘于法同事’。即其规则与习惯，茍与法相契而毫不违背者，自身固当与同化，否则若为可以脱离之团体，则脱离之，不能脱离者，则宜极力提倡改革，斯乃佛陀之精神。由此以谭，道元禅师，谓此同事为‘初使自己同于他，后则使他同于自己’之义，实为饶有至味之解释也。
    要之，四摄法者，小而一家，大而至于全世界，茍组成为一团体，则为所不能缺之德目。此佛陀所以谓‘依此摄世界，如车之进行，而依于御者’是也。佛陀之僧伽，亦为此种精神所领导。又如在俗之佛陀信徒手长者，亦以此四摄事统摄五百大众，克举卓越之成绩，尝为佛陀所推奖，其事甚着。故吾人以为即在今兹，茍能应用此四摄法，则如各团体之纷扰，亦大可调和也。
    又四法之中，尚有属于利行者，佛陀曾就种种事项，片断述之。其最可注意者，厥为谋旅行者之便利。即于河置船，以利涉济；建宿舍，以利息止；掘井水，以解旅人之渴乏等之设备也。如《相应部》〈有偈篇〉诸天相应第四十七经〈Vana ropa〉说：“种植园果故，林树荫清凉。以桥船济渡（旅人），造作福德者，穿井供渴乏，客舍供行旅，如是之功德，日夜常增长，具足如法戒。缘斯得生天。”是为佛陀所谓生天之道。盖因佛陀自身长期旅行，爰于此有痛切必要之感，益以当时各国，交通频繁，其结果遂以此为一般的必要矣。综之，此可谓注意于文明之施设，乃极有兴趣之谭也。
    ［参考资料］　《法界次第》卷下；《大乘入道次第章》；《法华经玄赞》卷二；《平川彰著作集》第二册。
    FROM：【中华佛教百科全书】

    聊天：
    我需要的是这一种：以神力降伏难调之恶人，令舍恶。看来非常难，劝善是一件比自己成就还难的事情。这方面您能多说点吗？

    zf：
    “我需要的是这一种：以神力降伏难调之恶人，令舍恶。”
    ──还是踏踏实实学习大悲心吧，否则名为悲心实为嗔心，降伏恶人时就是自己著魔时！


愿乃对目标的追求

    末学：
    我常读普贤菩萨行愿品，而且也是读了普贤菩萨行愿品后，才真正了解菩萨的大悲大愿，可是有一些疑问请各位给予解答。恒顺众生，如何实行。怎么区别什么应该恒顺，什么不应该恒顺？

    zf：
    恒顺众生，具体说来，就是：“于诸病苦为作良医……于贫穷者令得伏藏。”
    利益众生之根本在于令其具足乐与乐因，脱离苦与苦因。所以若众生作恶时菩萨尽力制止，亦为对众生的随顺，如普皆回向中所说：愿众生“欲行恶法皆悉不成，所修善业皆速成就”。

    末学：
    十大愿中有代众生苦愿，可是为什么我们众生还有苦呢？

    zf：
    菩萨以大悲心为根本，愿代众生苦之心愿是真诚无伪的。但我等众生能在多大程度上接受诸佛菩萨的加持，则要看我们对诸佛菩萨的信心及行动，即菩萨利益众生、众生接受菩萨救度这件事本身亦是缘起法，是要依于条件才能圆满完成的。
    那些对诸佛菩萨完全没有了解、没有信心的众生是否也能在某种程度上得到诸佛菩萨的恩泽呢？回答是肯定的。《华严经·如来出现品》中普贤菩萨对此有如下开示：
“复次佛子。譬如日出。生盲众生。无眼根故。未曾得见。虽未曾见。然为日光之所饶益。何以故。因此得知昼夜时节。受用种种衣服饮食。令身调适。离众患故。如来智日。亦复如是。无信无解。毁戒毁见。邪命自活。生盲之类。无信眼故。不见诸佛。智慧日轮。虽不见佛智慧日轮。亦为智日之所饶益。何以故。以佛威力。令彼众生。所有身苦。及诸烦恼。未来苦因。皆消灭故。佛子。如来有光明。名积集一切功德。有光明名普照一切。有光明。名清净自在照。有光明。名出大妙音。有光明。名普解一切语言法令他欢喜。有光明。名示现永断一切疑自在境界。有光明。名无住智自在普照。有光明。名永断一切戏论自在智。有光明。名随所应出妙音声。有光明。名出清净自在音庄严国土成熟众生。佛子如来一一毛孔。放如是等千种光明。五百光明。普照下方。五百光明。普照上方种种刹中。种种佛所。诸菩萨众。其菩萨等。见此光明。一时皆得如来境界。十头十眼。十耳十鼻。十舌十身。十手十足。十地十智。皆悉清净。彼诸菩萨。先所成就。诸处诸地。见彼光明。转更清净。一切善根。皆悉成熟。趣一切智。住二乘者。灭一切垢。其余一分。生盲众生。身既快乐。心亦清净。柔软调伏。堪修念智。地狱饿鬼。畜生诸趣。所有众生。皆得快乐。解脱众苦。命终皆生天上人间。佛子。彼诸众生不觉不知。以何因缘。以何神力。而来生此。彼生盲者。作如是念。我是梵天。我是梵化。是时如来。住普自在三昧。出六十种妙音。而告之言。汝等。非是梵天。亦非梵化。亦非帝释护世所作。皆是如来。威神之力。彼诸众生。闻是语已。以佛神力。皆知宿命。生大欢喜。心欢喜故。自然而出优昙华云。香云音乐云。衣云盖云。幢云幡云。末香云宝云。师子幢半月楼阁云。歌咏赞叹云。种种庄严云。皆以尊重心。供养如来。何以故。此诸众生。得净眼故。如来与彼。授阿耨多罗三藐三菩提记。佛子。如来智日。如是利益生盲众生。令得善根。具足成熟。”
    由此可知，我等众生时时为如来光明照耀而获益反不自知矣！

    末学：
    十大愿是不是不适合我们凡夫。

    zf：
    没发此大愿，我等为凡夫；若能发起此大愿，我等就是菩萨。
    所谓愿，乃对目标的追求。要求发愿者立即达到目标是愚蠢的表现，好比一小孩发愿将来要当医生，便立即要求小孩为人看病。所以不要害怕发愿，先在心里将菩萨行愿强化，再尝试着逐步依愿起行。对大部分人来说，成佛不是一蹴而就的事，一步步向前走，只要目标正确。更何况普贤行愿品中还有往生极乐的愿，更加稳妥。

    末学：
    如何对治懈怠。而且我已经养成了懈怠的习惯。可以说无志者常立志。

    zf：
    南无阿弥陀佛
    习惯能养成，同样能被改掉。顶果仁波切曾说过：无明等恶行的最大好处就是可以被去除。努力吧，别人替代不了。


关于“爱见大悲”

    dawa：
    智慧一定不是去回避痛苦的。所以，如何看待众生的痛苦，不为“悲魔”所控？

    zf：
    关于“悲魔”和“爱见大悲”。
    对dawa兄关于如何以智慧看待众生的痛苦，而使自心不为“悲魔”所控的问题，谈点自己的看法。
    首先，关于“悲魔”，《楞严经》在谈到修行禅定可能遇到的种种障碍时有如下相关开示：“阿难！彼善男子，当在此中得大光耀，其心发明，内抑过分，忽于其处发无穷悲。如是乃至观见蚊虻犹如赤子，心生怜愍，不觉流泪。此名功用抑摧过越，悟则无咎，非为圣证。觉了不迷，久自销歇，若作圣解，则有悲魔入其心腑。见人则悲，啼泣无限，失于正受，当从沦坠。”
    上述经文中的“悲”，古德开示为“忧悲”之意。经文的大意是说：行者因于禅定中内抑过分，忧悲的种子忽然现起，见种种众生，皆如自己所生之子，因怜悯而流泪。若处理得当，这一现象会慢慢消失；若处理不当，则忧悲的情绪使行人不能自拔，无法解脱。可见，此“悲魔”之悲乃“忧悲”，而非欲拔众生苦之“悲”。
    与大悲有关的另一个可能引起疑惑的词是“爱见大悲”。
    《维摩诘所说经》中宣说：“彼有疾菩萨应复作是念：如我此病非真非有，众生病亦非真非有。作是观时，于诸众生若起爱见大悲，即应舍离。所以者何？菩萨断除客尘烦恼而起大悲。爱见悲者则于生死有疲厌心，若能离此无有疲厌，在在所生不为爱见之所覆也。”
    关于爱和见，《大智度论》中说：“烦恼有二种：一属爱，二属见。”古德开示，迷事之惑名爱，迷理之惑名见。如贪欲嗔恚等为迷事之惑，我见邪见等为迷理之惑。因此爱见大悲即是烦恼或迷惑摄持下的大悲。
    《维摩诘经》中开示：菩萨因观“如我此病非真非有，众生病亦非真非有”，因此应舍离于诸众生所起之爱见大悲。依本人浅见，此处所应舍离之爱见大悲，其主要所指是其中的爱见，而不是大悲。因为舍离爱见，即是断除客尘烦恼。该经紧接着就说：“菩萨断除客尘烦恼而起大悲。”无大悲心者根本不能称为菩萨。
    如何对待爱见大悲，对行人的修持关系极大。在本人接触的同修中，因听说应舍离爱见大悲，并未舍离爱见，而先舍离大悲者，不乏其人。本人认为，爱见大悲对大乘道的初学者来说至关重要，此爱见大悲，为多数大乘行人的入门之因。按“三主要道”次第修习由阿底峡尊者带入西藏的菩提心教授（知母、念恩……悲心……菩提心）时，生起菩提心的直接因就是爱见大悲。菩提心生起之后，在菩提心的摄持下，修行般若波罗蜜多，去除爱见，将爱见大悲转化成无缘大悲，这可能是多数大乘行人要走的路。
    回到dawa兄的问题：“如何看待众生的痛苦，不为‘悲魔’所控？”本人认为，欲利益众生的悲心，是最可宝贵的大乘之根。即使其上附会了爱见，此爱见大悲亦可成为发起殊胜菩提心的亲因。修习般若波罗蜜多要对治的是爱见，绝不是大悲。

    TZ：
    受启发而思之，大悲之心，通常从广度理解较多。读师兄贴想到：大悲心当——
    一、无限广，含摄十方三世一切众生。
    二、为菩提心摄，自度度他，究竟佛果。
    三、般若观照，不断修去爱见尘障。
    并请教：《维摩诘经》中有“菩萨之疾，大悲为源”句。能否再作阐发。

    zf：
    菩萨的病因
    TZ兄所问：“菩萨之疾，大悲为源”之意。在《维摩诘经》下列一段说明其意。
    “于是文殊师利与诸菩萨大弟子众及诸天人恭敬围绕，入毗耶离大城。
    尔时长者维摩诘心念，今文殊师利与大众俱来。即以神力空其室内，除去所有，及诸侍者，唯置一床以疾而卧。
    文殊师利既入其舍，见其室空无诸所有，独寝一床。
    时维摩诘言，善来，文殊师利，不来相而来，不见相而见。
    文殊师利言，如是居士，若来已更不来，若去已更不去。所以者何，来者无所从来，去者无所至。所可见者更不可见。
    且置是事。居士，是疾宁可忍不？疗治有损不至增乎？世尊殷勤致问无量。居士，是疾何所因起？其生久如？当云何灭？
    维摩诘言：从痴有爱则我病生，以一切众生病，是故我病。若一切众生病灭，则我病灭。所以者何？菩萨为众生故，入生死，有生死则有病。若众生得离病者，则菩萨无复病。譬如长者唯有一子，其子得病，父母亦病。若子病愈，父母亦愈。菩萨如是。于诸众生爱之若子，众生病则菩萨病，众生病愈菩萨亦愈。
    又言：是疾何所因起？菩萨病者以大悲起。”
    从维摩诘的开示中可以看出：众生因痴爱而有病（生死之大病），菩萨因大悲而入生死救度众生。即入生死，身体之病便难以避免。因此，从根本上说，菩萨之病，是因大悲而起。

    savelife：
    爱见乃是染污种子，为什么可以成为生起清净之果（殊胜菩提心）之因呢？不知道唯识宗之外的他宗对于转染成净的看法是如何？
    另外，您觉得在闻思修当中，您是如何处理不同宗派的观点上的不同的？（尤其是在指导修行上不会产生混乱）您是采取先学好其中一宗，然后再学其他宗吗？您在学习当中是否有阶梯次第？
    （因为之前有人说唯识乃是学中观的基础）

    zf：
    梦与醒。
    生起菩提心的因是大悲，而不是爱见。只不过我等众生在生起悲心的时候免不了要受到爱见的污染。但被污染了的悲心却不失可能生起菩提心的功能。试想，我等凡夫心中任何一念，都不可能不受到爱见（即无明）的污染，包括大悲心和行愿菩提心。如果凡被污染了的心念都不能成为解脱之因，则我等凡夫便永无解脱的可能。
    以莲花为例。莲种处于污泥之中，所生出的莲花却不受污泥所染。这里莲花的亲因是莲种，而不是污泥，但莲种不离污泥，莲种并不因其被污泥所染而失去生花的功能。
    《华严经》十地品中有如下比喻：“譬如有人。梦中见身。堕在大河。为欲渡故。发大勇猛。施大方便。以大勇猛。施方便故。即便觉寤。既觉寤已。所作皆息。菩萨亦尔。见众生身在四流中。为救度故。发大勇猛。起大精进。以勇猛精进故。至不动地。”这一开示中应引起我们注意的是，堕河、欲渡、发大勇猛等皆是梦中之事。而恰恰因为梦中有大勇猛心、施大方便，梦才可能被搅醒。如于梦中随遇而安，便只能随其流转。梦中的大勇猛心所喻者——大悲菩提心是也，所施之大方便者——般若波罗密多是也。梦醒之前的挣扎，皆是梦中之事，但若无此挣扎，绝无梦醒之理。此中深意，望兄深思。
    关于不同宗派，空慧方面，本人主要学习龙树、宗喀巴大师一系的中观和华严宗杜顺大师的著作。唯识方面本人涉及不深，感到那是一套与中观不同的“符号系统”。
    至于是否“唯识乃是学中观的基础”，本人相信两者应是平行的两条路，而不是“基础”与“提高”的关系。


观世音菩萨的大悲绳索

    云在天：
    可惜我命有桃花！！！
    但是我知道会有报应！！！
    所以我不敢变坏！！！
    可是，太难了！！！
    在诱惑面前，能够心不动，
    实在是圣人哪！！！

    zf：
    云在天兄

    自己感到无能为力时，
    就多念念大慈大悲观世音菩萨吧！
    对在苦海中每一个呼救之人，
    观世音都会向其抛出大悲之绳索。
    但是否肯沿索爬上，
    还要看我们自己！

    学佛之人就是不认命。
    若认命，前途只有一个──继续轮回！
    而轮回的本质就是──苦！

    行云在天之潇洒，
    缘于对贪嗔痴的抛弃。
    双手紧握火红的铁球而希望不被灼伤，
    那只是痴人的梦想！（铁球之喻乃顶果仁波切语）

    何去何从？
    三思！


发菩提心持诵陀罗尼是秘密普贤行

    祈福：
    我想专诵宝箧印心陀罗尼，可不可以在诵经的时候把咒文反复念诵，如果可以怎么回向呢？可以用普贤行愿品的前七愿代替吗？

    zf：
    可以。也可以先完整地诵一遍经，再专心诵咒。
    建议回向采用普贤行愿品中之第十愿“普皆回向”的经文。若能加上颂文中之“愿我临欲命终时，……乃至虚空世界尽，众生及业烦恼尽，如是一切无尽时，我愿究竟恒无尽”和“我此普贤殊胜行，无边胜福……速往无量光佛刹。”就更加圆满了。
    发菩提心持诵陀罗尼是秘密普贤行。别忘普贤行愿。


就在这里好好修菩提心教法吧！

    就在这里好好修菩提心教法吧！

    QZ

    想起了当年在国外刷盘子时的那段困苦时光。当时，我也是经常到网莲发帖子，找人问事儿，其实就是想找人倾诉，能找人倾听我的心声。得到安慰。
    刷盘子是很苦的事情，尤其是在大饭店。在婚礼宴席等大的宴席时，盘子多的像小山（相当大的盆景用假山）一样，而且这个山不是移完一堆儿就完事的。
    而是连续地堆积，连续地从清洗池入口向尽头移动，须分别经过洗污池，热水池，清水池，抵达最后装它们的塑料筐子……
    正式职员就两个人，我和另一个20岁的小伙子。不断地像人肉机器一样，把剩菜剩饭从水池子拨拉到下面的塑料袋里（污水池），再把它们扔进热水池里（去油污）用铁丝布擦洗，然后扔进（需要速度）清水池里。
    当然，这之前的前行——把装有剩菜的盘子里的剩菜分门别类地放进回收器皿里，并在最后，从清水池里把各式各样，形形色色大小不同的盘子，碗儿，碟子，分门别类地放进它们所属种类的塑料筐子里。
    有些碟子形状和大小相近，不容易区分。但我们必须准确地把他们按照各自的种类放到一起，不允许有错乱。然后，等着前台的服务员把它们一筐一筐地抬走。有时还得我们帮她们抬到清洗池的入口处，以便她们抬走。
    可以说整个饭店最重的活儿是我们两个在干，而薪水却不多。这个活儿，难就难在需要速度。上面我是把他们的程序一个一个地按次序说出来的，但在实际干活现场我得把这个程序在极快的时间内重复，并且是不断地重复，因为，一旦我们这边停下，清洗池的入口就会有成几何速度增长的装满盘子的托盘迅速堆积。这样，老板就会开始呼喊了。呵呵。
    在一开始不会干的时候，我不觉得累（因为主要由那个朋友挑大梁），觉得比以前在前台伺候人的工作容易，至少可以不挨很多人（老板和店工嫌我慢，毕竟我是外国人啊，有时听不懂他们说什么，不是我想慢。）的训斥了。但到了会干了，熟悉了的时候，才发现，这活儿真像是人肉机器干的活儿。怪不得这里的人手换了一个又一个，都干不出多少天。有几个人想成为人肉机器呢？当我想进来的时候，就有朋友劝我不要去，但是，我为了逃避别人的脸色，情愿选择肉体上的痛苦。
    每天从早上7点多起床，8点开始正式上班，到晚上11点饭店最后清扫结束打烊，我是全程参与者，因为待洗的盘子不能有一刻的堆积，除非在中午可以喘口气儿，但我们得比别人先吃完饭，有个提前量（先作好迎接下午刷碗大战的准备，还有很多盘子停在清洗台上呢！），并且没有其它员工的隔日一休。可以说从各方面条件而言，在饭店里是最辛苦的了。
    起早贪黑，唯一可以知道时间变化的，就是挂在墙上的时钟。混身是水我不在乎，一天，洗一百个铜制的2－3斤重铜碗，10几袋子40－60斤的湿辘辘的食物垃圾，当热水池子里的水烫伤了手臂，由于不能及时休息持续浸泡在水里而化脓，肩膀、手腕、腿在过度疲劳后已没有痛觉，像机器那样麻木，当太疲劳坚持不住而遭到同伴的责骂，当无数次地把碗/碟/盘们从热水池掏出擦净，扔到净水池子里并把它们捞出放到干净的塑料筐子里的过程中，我在想什么？
    我在一直想着赵叔对我说的发菩提心的教言！
    我自己想，就在这里好好修菩提心教法吧！
    把众生从热水中捞起，擦干他们的污垢，使他们进入清澈的水里。捞一个盘子就是从苦海里捞一个众生。
    就这样捞啊捞。也许您会问，那也许是劳动强度还不够吧？要不怎么还顾着想这个呢？当时情况是，如果我不这么想，以此为动力，我是根本干不下去那种活儿的！我在家里是从来不干活的人，都由母亲来做。我后来想这也是我的报应。
    就这样，我在这里干了70多天。直到开学的前一天。
    在我出离这个“人间地狱”的时候，我把如何干好这里工作的所有细节，都仔仔细细地讲给接替我工作的人（是两个刚毕业的厨师系的学生），使他们最大限度地进入角色，而不感困难。（不要跟我刚进去学的时候那样，到处碰壁，遭人白眼）。但愿他们也能像我一样值遇珍贵的菩提心教法而能于人生路上不气馁，直趣菩提！


随喜四弘誓愿

zf:
“四弘誓愿，众生无边誓愿度，烦恼无尽誓愿断，法门无量誓愿学，佛道无上誓愿成。”
    仁兄曾有这样的修持，在下随喜了。
    须知，成佛之弘愿，只要在心中生起过，便如金刚般不可毁坏。纵使一时烦恼现前，亦不会伤其毫毛。
    正如弥勒菩萨所开示：
“善男子。如琉璃宝于百千岁。处不净中。不为臭秽之所染着。性本净故。菩萨摩诃萨菩提心宝。亦复如是。于百千劫住欲界中。不为欲界过患所染。犹如法界性清净故。
    善男子。譬如金刚无能销灭。菩提心金刚亦复如是。一切诸法无能销灭。
    善男子。譬如金刚一切诸火不能烧然不能令热。菩提之心亦复如是。一切生死诸烦恼火。不能烧然不能令热。”

    tyro：
    私下理解持心如地、水、火、风，是不是这样：
持心如地：安忍不动，像大地，广博；
    持心如水：柔软流动，像海水，
    持心如火：炽热剧烈，像大火，
    持心如风：迅捷流动，像飓风。
    地是地相，水是水相，风是风相，火是火相，亦可理解为具有相同性质的物质为之，如车轮，风性。

    二麻子：
    据我的猜测……或者说据麻子的少分经验，这四持必须与持心如虚空并行，否则不得力。


未来之弥陀见现在之弥陀，岂不理直气壮！

    常如：
    我昔所造诸恶业，皆由无始贪嗔痴，
    从身语意之所生，一切我今皆忏悔；
    罪由心起将心忏，心若灭时罪亦亡，
    心灭罪亡两俱空，是则名为真忏悔。

    zf：
    请问如何灭心？兄所引的颂中有“心灭罪亡”之说，请问，此处“心”为何义？应如何“灭心”？？

    常如：
    敬答如下；此心义甚深妙，非言可解；若强言之，此心含摄万法，本无生灭，似华严一真法界所可比拟。只因众生颠倒，妄见心生心灭，见相而执，故生死流转，罪福相生。罪由相生，相由心起；心生则诸法生，心灭则诸法灭，所以可以说：心本无生灭，罪福亦空亡。
    虽然学人从经典的学习上可以知道这个道理，可是实际心地又能奈生死如何，若拿个“空”字，挡来挡去，恐怕只能挡住自己的眼睛，生死关头，徒唤奈何！
    学人若能从这个道理出发，进一步生起佛法真实不虚的信心，老实修行，一句弥陀，亦可受用不尽，时节到时，自然莲开见佛，岂不快哉。

    zf：
    常如兄；本人提问并无考兄之意，只想给兄提个醒，泼洗澡水莫连孩子一起泼了。其实答案就在兄所引的前一偈中。造诸恶业之心即是贪嗔痴，此三毒若灭则罪亦灭。而欲求无上菩提之心、缘诸法空性之心不但不能灭除，反应使其坚如金刚。
    兄于净土一门有大信心，令人敬佩。给兄提个建议供兄参考。
    兄以净土为归，执持名号固为正行，但同时若能以弥陀之本愿为自己之金刚誓愿，则更易与弥陀心心相印。试想，弥陀之所以成为今日之弥陀，原因即在于因地发起四十八愿，并依愿修行。兄若以弥陀之愿为己愿，则兄便是未来之弥陀，无量众生将因兄得度。临命终时，不待弥陀接引，此金刚誓愿之力和弥陀名号之功德力将兄引至极乐，易如反掌。试想，未来之弥陀见现在之弥陀，岂不理直气壮！届时兄若想不去恐怕还不容易呢！


菩提心、大悲、慈悲喜舍四无量心，这几者之间是什么关系？

    凡夫：
    菩提心、大悲、慈悲喜舍四无量心，这几者之间是什么关系？
    本人对于喜无量心，一直无法取得较好的定解。
    换一句话：心中无法安住在喜无量心增上。

    zf：
    浅见

    “菩提心、大悲、慈悲喜舍四无量心，这几者之间是什么关系？”
    ──对此道次第（如《略论释》）中有详细的论述。
    简单地说，四无量心不是菩提心，但可以成为菩提心修习的基础。
    “本人对于喜无量心，一直无法取得较好的定解。换一句话：心中无法安住在喜无量心增上。”
    ──所谓喜无量心者，见人离苦得乐生庆悦之心也。
    我们的“喜”心通常面对自己的孩子、父母、兄弟姐妹时容易生起，但由于爱憎分明，故为有限而非无量。
    仁兄不妨从修“知母、念恩”等入手试试──思维一切如母众生对我们的恩德，或许喜心会从有限渐渐扩充为无量。

    凡夫：
    理了一下思绪，进一步提问。
    因为本人阅读过的是广论，大概因为广论文繁而阅读时仓促冒进，并且阅读时，也因未有一导师可依，而未同时要求如量生起相应闻思功德，因此虽然前些月前，知道“四无量心不是菩提心”，但是仍然有些不解。
    菩提心四行相，不就是“慈悲喜舍”吗？
    赵叔是否可以略述一下，依［菩提心的四行相］来理解、行持菩提心，不够吗？
    我本人有一个粗浅的解释，就是声闻乘也修四无量，但是此四无量并不要求“度尽一切众生”的心量，因此，单论“四无量心”不能等于菩提心。这样理解正确吗？
    换一句话说，如果按照大乘教法，类似天台教法，对四无量心做出合乎无上大菩提心之量的适当解释，此四无量心可以同于菩提心？这样理解，可以吗？

    本人近期读一些经论时，注意到，四无量心比如喜无量心，其解释均散在经论各处，有些提到是悦乐佛法三宝、有些提到是法乐，对于喜无量心的诸方面含义，也渐渐有进步。不过也许是闻、思、修量均不具备的缘故，因此远未达到喜心扩充大至无量。还需要多方努力。惭愧！

    zf：
    请进

    “我本人有一个粗浅的解释，就是声闻乘也修四无量，但是此四无量并不要求“度尽一切众生”的心量，因此，单论“四无量心”不能等于菩提心。这样理解正确吗？”
    ──是的。
    四无量心的根本就是利益众生，但如何才是对众生的究竟利益，诸天、二乘和大乘却有不同的认识。
    大乘菩提心的根本是要成佛，而成佛的根本目的是利益众生。如何才是对众生的根本利益？大乘认为，只有将一切众生都度成佛，利益众生的目的才真正达到。如《初发心功德品》中言：“菩萨志愿等十方，慈心普洽诸群生，悉使修成佛功德，是故其力无边际。”又如《法华经》中言，如来出兴于世的目的就是开、示、悟、入佛之知见。（注意：是“佛”之知见，而不是阿罗汉或菩萨的知见）。只要还有一个众生未成佛，如来利益众生的事业就不会止息，如普贤菩萨所说：“乃至虚空世界尽，众生及业烦恼尽，如是一切无尽时，我愿究竟恒无尽。”
    总之，菩提心的根本所指是佛，而四无量心却并不一定如是。

    凡夫：
    明白了，菩提心是究竟利益一切众生，也就是令一切众生成佛。虽然零星地明白这个道理，此处赵叔专门指出后确实对此有清晰的理解了。谢谢赵叔。


愿你我所愿早日圆满

    仁良：
    “或许有些大愿菩萨，对生死已得自在，命终之时十方如来虽然现身相邀，但却不欲往生，折身返回，而愿于轮回中‘常时勤苦心无厌，乃至地狱亦安受’。”
    ──什么是大愿菩萨？对生死已得自在，这意思是说证到什么程度？

    zf：
    仁良兄请进，在下这里的“大愿菩萨”主要是指“不退转菩萨”，即在菩提道上已不可能退至二乘、凡夫的行人。关于此位菩萨的证量，仁兄可详见词典“阿鞞跋致”辞条。

    智光：
    末学问的是为什么要入“梦”度人？有何必要呢？末学可能正因此而发不出心来，故有此问。

    zf：
    看看有无必要？若您有孩子，正在作恶梦，大声呼救，您能否因为是梦而漠然处之？

    智行：
    设我成佛道，立名无量寿！众生闻此号，俱来我刹中。
    如佛金色身，妙相悉圆满。亦以大悲心，普利诸群品。

    zf：
    设汝成佛道，立名无量寿！我将劝众生，俱来尔刹中。
    如六道众生，我身相亦同。悉以众生语，劝彼往汝刹！
    智行兄，愿你我所愿早日圆满──乃至虚空世界尽，众生及业烦恼尽，如是一切无尽时，我愿究竟恒无尽。

    明心斋主人：
    如何发愿才是如法的？

    zf：
    随顺实相。


圆教的发心方法

    圆教的发心方法

    zf

    “初发心即成正觉”，乃《华严经》之极说，绝非三言两语所能说清。
    汉传佛教将大乘教法判为四教——始教、终教、顿教和圆教（还有其他的判法），通常将天台宗和华严宗判为一乘圆教，即圆满的教法。初发心即成佛之说，只有圆教中才有阐说，这种教法可能算得上难信之中最难信者了。
    需要指出的是，发心即成佛之中的发心，与通常所说之行愿菩提心、胜义菩提心和三摩地菩提心以及无上瑜伽部中的菩提心均不相同。这种圆教的发心方法，《华严经初发心功德品》中有详细开示，圆教之教理华严宗祖师多有论述。常常有人将华严宗的教理看成脱离实修的空谈，但个人认为华严教理实为教授学人生起对一乘圆教不共信心的方便，这种信心一旦生起，则发心即成正觉。因此本人认为，一乘圆教难在信而不难在行。
    《大正藏·诸宗部》中收录之青丘沙门见登所集《华严一乘成佛妙义》，对发心即成佛的原理有详细论述。见登大师乃高丽人，兄如有兴趣可以看看这位古代高丽圣僧的妙论。
    《华严经·初发心功德品》，实乃对发心即成佛之发心方法的殊胜教授，愿由此深入者，建议对此品经下大功夫。
    若将菩提心称为金刚种子，将除圆教发心之外的发心比为种子，种子种下后，尚需要浇水施肥等过程（喻显密修行方便）才能结果；但圆教之发心似乎是种子生成时同时结果，但切勿忘记，种子生成需要无量福智因缘。
    个人认为，发心即成佛与不修成佛（指佩带成佛或听闻成佛）并不是一回事，所谓发心就是修行。因为特殊的发心方法，使之可以速疾积累成佛资粮，故与阿底峡尊者之说不矛盾。
    从《华严经》中可以看出，似乎确有顿修顿证的法门，如“初发心功德品”所详述。只是这种发心的动机、发心的所缘相，对我等初学来说甚难把握。依个人之见，如果把这种顿修的法门视为正行的话，则进入正行的前行是必不可少的。
    众生虽三身本具，但要使本具之三身生起现行，没有足够的福智资粮万万办不到。而福智资粮的积累速度，应随众生心量和方便的不同而有差异。如卡卢仁波切开示：
“按照大乘的方式，我们应该将想念诵咒语的人聚集起来。由全体中的每个人念诵咒语，其效力将会加总。对于念诵一亿遍咒语来说，这是一种较快的方式，但仍需要很长的时间。不过，就金刚乘的观点来看，我们可以持静，将自己观想为观音菩萨的一万个或十万个化身，想着他们确实在场，并不断念诵咒语。假如怀着虔信来进行此项修行，整个过程将可在数小时或数天完成。多样的交通工具，具备这些在效率上有所差异的不同方式，以供人们选择。”
    一乘圆教教理的核心是事事无碍，依据这一教理“设计”出发心技巧，其积累资粮的速度要远远超过我们的想象，用《华严经》的话说就是：乃至才发心时即成正觉。
    发心即成佛之教授甚难起信。本人在论坛上所发第一帖，即是见人对此教授怀疑而出不敬语，深惧其人因此造大口业，而出言相劝：疑心可存，万勿诽谤。以此因缘参加论坛讨论至今，一发不可收拾。时至今日，本人对在论坛上讨论此话题还心有余悸，唯恐有人对此法义出不敬语而造恶业。汉地古德论著里面藏有珍贵之宝藏，如有兴趣不妨前往寻宝，相信您定不会空手而归。


关于《初发心功德品》

    关于《初发心功德品》

    zf

    《华严经初发心功德品》法义的确深奥难懂。对此品经有特殊兴趣者不妨尝试以下两门：
一、信门
    由于经中开示，此经为一切如来共同宣说，功德无量无边，乃至才发心时即成正觉。行者以深信心随顺经中开示的发心动机，努力作意思维。如经中所言：“三世疑网悉已除，于如来所起净信，以信得成不动智，智清净故解真实。”由此可见，不动的智慧可以依信而成就。本人对此品经的修习便是以深信心为向导而深入。
    二、解门
    此品经意若依汉地判教，应属一乘圆教，甚深甚深。杜顺大师《华严五教止观》为一条进入的门径。若行者已于中观正见有相当基础，可直接研习其中的华严三昧门。近日反省99兄推荐的智谕大师的《华严五教止观》讲解可以参考。不过即使有讲解参考，华严奥义亦甚难体会，这可能就是华严一宗不振的原因。
    本人现在每日读诵此品经，依经来思维菩提心的功德，校正自己的发心动机，体会法界之无碍本相，接受十方诸佛的加持（如经中所言：“三世一切诸如来。靡不护念初发心。悉以三昧陀罗尼。神通变化共庄严。”）。
    本人虽受此经恩惠颇多，但并不想劝其他佛弟子都要读诵此经。每人因缘不同，对不同经典感情也不一样，只要选择自己倍感亲切的佛经受持读诵就好。


初发心功德品的见、修、行

    gladness：
    请问发心也算是“见”是吗？看您的意思，好象发心与平等都是见。

    zf：
    发心是修，即去熟悉见，将心成为见。

    gladness：
    又一个问题请教，请问，佛无量的化身背后有没有一个像“幕后指使人”一样的佛？

    zf：
    有，如华严经中之毗卢遮那佛。

    gladness：
    佛有法身佛、报身佛、化身佛的说法，此毗卢遮那佛是其中的哪一种？

    zf：
    是这一种： 　　如来所得之十身，即华严宗所称之行境十佛：（一）菩提身，乃示现八相成道正觉之佛身。（二）愿身，乃愿生于兜率天之佛身。（三）化身，乃生于王宫之化身。（四）住持身，乃灭后止自身舍利而住持佛法之身。（五）相好庄严身，指无边相好庄严之佛身。（六）势力身，以慈心摄伏一切之佛身。（七）如意身，对于地前、地上菩萨而现生如意之佛身。（八）福德身，乃常住于三昧之佛身（三昧为福德之最极者，故称为福德身）。（九）智身，指大圆镜智等四智。（十）法身，即智身所了之本性。［旧华严经卷二十六］
    FROM：【佛光大词典】

    木樨香：
    谢谢Zf叔清晰的说教！
    还有一种身如何归类？即如来慈悲地融入每一位有情心中，安住在众生心识中的那个。
    这个问题解决后，湛然大师的无情成佛也就昭然了。

    zf：
    好问！

    所有这十种身都融于每一位有情的心中，乃至无情中。
    因为，此十种身性空，众生及无情性亦空。性空者必无碍，性空者必周遍涵容，性空之法必一即一切，性空之法必一切即一。

    梦中人：
    可不可以这样理解？石头草木等众生眼中的一切乃至众生举心动念皆是佛的慈悲示现？因其本性与佛无二无别。

    zf：
    可以，但同时您也要接受：“如来功德是石头草木及众生愚痴的显现”这样的说法。

    gladness：
    请问赵叔，您这句话如何理解？

    zf：
    平等

    gladness：
    是不是因为平等的缘故，“选择”的作用才会出奇的大。

    zf：
    是

    木樨香：
    三世诸佛，依般若波罗蜜多故，得阿耨多罗三藐三菩提。因此故，普贤菩萨在行愿品中再三强调：“是故菩提属于众生，若无众生，一切菩萨终不能成无上正觉。”从这样看，后学猜想普贤菩萨很是鼓励我们安住在裟婆世界，在这殊胜之土对如母众生生起坚固不退的菩提心。

    zf：
    ！！
“后学猜想普贤菩萨很是鼓励我们安住在裟婆世界，在这殊胜之土对如母众生生起坚固不退的菩提心。”
    ──看看普贤菩萨鼓励什么：
“于一毛端极微中，出现三世庄严刹，十方尘刹诸毛端，我皆深入而严净。”

    gladness：
    再请教，“利益众生”是“修”还是“见”呢。

    zf：
    是“行”。

    gladness：
    这样理解，按照初发心功德品去发心是修，发心发到位了，“见”也就圆满了。是这样吗？

    zf：
    见、修、行都圆满了。别忘了：“即能于一切世界中示现成佛”！

    rj：
    得见不易。见，修，行是一体的不同方面方向的表现，从几个方面方向来看一个东西，往往更真实，并且先后顺序也并不好说存在。可以说三个名词都是业力的不同方面方向的表现。
    佛菩萨的慈悲智慧其实在每个人的相续里存在，然而同时无明之流也在每个人的相续里存在，有句话好像是“众生决定成佛”，然而由上述的词句，可否说“众生决定轮回”。
    后学想知道这种推论有问题吗？

    zf：
    还是佛言最值得品味：
    “有句话好象是“众生决定成佛”，然而由上述的词句，可否说“众生决定轮回”。”
    ──众生本具如来德相；只因妄想不能证得。


关于正遍知

    zf：
    关于正遍知，如来之智慧在诸经典中最典型的概括就是十力和十八不共法。如来之正遍知不但了知诸法空相，同时了知一切因果。
    因果虽无始无穷，但依华严所开示境界，无始无穷的因果含摄于一法一念之中。如来证得妙观察智，故智慧知见过去世无阂无障。是故并不能因因果之无穷而否定能见过去世的智慧。
    十八不共法中第16为“智慧知见过去世无阂无障”。既然是“无阂无障”，可见我们不能设定过去某一劫，断言此劫之前的因果为如来所不知。

    yang：
    因果变化，“了知”者变不变？若变，怎谈了知“一切”？若不变，即同一神外道；若无“知”者，唯谈“了知”，问题同上。

    zf：
    “如来”为一假名，无“知者”，唯有智慧。智慧者相似相续，非常非断，与一神外道无关。

    yang：
    未来因果，如何了知？若“了知”未来因果，即成宿命。

    zf：
    十八不共法中第17为“智慧知见未来世无阂无障”。诸经中如来对未来授记之处随处可见，对如来之宿命通yang兄难道还要否定吗？
    兄言：“若“了知”未来因果，即成宿命”，此说不应理。既是因果，便非宿命。宿命论者非缘起论。兄以缘起论破如来了知未来因果之智，为在下闻所未闻。
    由此在下怀疑兄是否正确理解缘起法之真义。若兄所解之缘起法与如来之十八不共法相矛盾，yang兄要三思了。

    yang：
    诸行无常，“了知”是否诸行之一，无常法如何“一切”？说佛全知，即为谤佛！

    zf：
    如来之“了知”，即智慧是无常法。无常法者，非常亦非断。非常者，缘起无自性；非断者，了知一切因果。


“贪”和“愿”等心行的差异

    学佛者：
    学生现在已经没有体悟了，一切皆可破。

    zf：
    这本身就是一个很危险的“体悟”！一切皆可破吗？？？此生故彼生、此灭故彼灭的因果规律可破吗？？？因于无明而有轮回、因于般若而有解脱这些缘起法学兄能破得了吗？？？

    学佛者：
    不存在“佛性”，那只是能证而已。方法是一切如幻，无非本性清静而已。

    zf：
    大乘经中广宣佛性，若如学兄所断言：不存在“佛性”，如来岂不是大妄语者！我等初机学人，切不可因自己一时无法理解如来所说而妄下断言。如来经典中的“矛盾”是因我们自己心中的无明所致，克服这些“矛盾“的有效方法就是虔发无上菩提心，真诚忏悔自己的业障。业障减轻后，原来心中的“矛盾”会自然消失。
    缘起之法如同梦幻，虽无自性而能现起种种作用。轮回如幻，菩提亦如幻。但因如幻之菩提能利益如幻之众生，我等不应因其如幻而放弃追求。

    学佛者：
    学生只是意解到“脱离对立的……是对立后的能所不可能去认识的，而脱离对立的……也不脱离对立之后的能所”。其中“脱离对立的……”是不得已而强说。

    二麻子：
    “超越能所”是不能用对立中的能所二执去认识的。而超越能所也不需要离能所相。这段意思大致无误。

    学佛者：
    我的修行方向，“正定”时，不去寻求执守“空性”。一发现自己执守“念头”时，按如上的理解“体悟”之“如幻”，因为自己定力不够，“体悟”往往就是“观”了。

    zf：
    由观察修开始，自然过渡到安住修恐怕是实修的必经之路。

    学佛者：
    请评点及指引以后的修行方法。

    zf：
    只要将发菩提心和忏悔业障作为修行的重点就不会偏离正道。以上建议谨供参考。

    学佛者：
    后学初期不敢去想“追求”，“追求”要等后学证得“无思维而起念”时才行。这点后学特想听听诸位大德的教导。

    zf：
    在下猜测，学兄不敢“追求”的原因是因为没有搞清“贪”和“愿”等心行的差异。客观上一些人常常将“追求”统统斥为“贪”的指责可能也是造成我等学人不敢大胆地“追求”的原因之一。
    贪和愿俱为欲的范畴。欲又作乐欲，意谓希求、欲望，是希望所作事业之精神作用。欲有善、恶、无记等三性，善欲为引起精勤心之根据；恶欲则为引起烦恼的根据，包括贪等。
    先说贪。贪乃欲求五欲、名声、财物等而无厌足之精神作用。即于己所好之物，生起染污之爱着心，引生五取蕴而产生诸苦。
    再说愿。愿乃心中欲成就所期目的之决意，如心愿、志愿、意愿、念愿等。从本质上说，愿就是欲，但在佛经中，愿常指善欲。一切佛菩萨皆于修行之始，发为度众生愿成佛之心，如四弘誓愿等。同时，佛菩萨亦各有特殊之愿（别愿），如释迦牟尼佛之五百愿、阿弥陀佛之四十八愿、药师如来之十二愿、普贤菩萨的十大愿等。盖果虽直接由行所感，然若无愿，则其行亦无法到达所期之目的。密乘中，佛菩萨的誓愿常以宝幢来表示。大日经疏曰：“宝幢是发菩提心义也。譬如军将统御大众，要得幢旗，然后部分齐一，能破敌国，成大功名。如来万行亦复如是，以一切智愿为幢旗，于菩提树下降伏四魔军众，故以为名也。”由此可见，“追求”无上菩提的誓愿，乃为统帅诸菩萨万行大军之幢旗。军中无此幢旗，军众便没有了灵魂，学人心中如无对无上菩提的“追求”，便绝无成就无上菩提的可能。
    由此可见，菩萨的誓愿和众生对五欲等的贪著虽同为“追求”，但因动机和目标的差异，其果报全然不同。
    至于先证空性还是先发大愿的修学次第要因人而异。如来弟子中一些人是先部分证得空性，后在回小向大的劝导下发起无上菩提心；大乘的通途则是先发四弘誓愿后证空性。《华严经·初发心功德品》中之“诸佛色相庄严身，及以平等妙法身，智慧无著所应供，悉以发心而得有”。这一开示指出：不但如来的胜色身，其胜法身（即对空性的彻证）同样因于无上菩提心而证得。
    总之，欲成无上菩提，“追求”是不可少的，无论是早追求还是晚追求。


发菩提心的所缘与实践

    zzzm：
    后学也想请教一些问题，
    赵叔，您说：“所缘缘是指诸心、心所缘住的境界。如眼识及相应法，以一切色为所缘缘，耳识及相应法以一切声为所缘缘，意识相应以一切法为所缘缘等。对于一个修行者来说，修持的技巧或法门大部分属于对所缘缘的把握和使用。
    这里提醒仁兄注意者，正是菩提心之‘所缘缘’。”
    您说的菩提心之“所缘缘”是说要缘什么而发心，对吗？
    而所缘的对象越具体越准确越清晰，就越有利于引发菩提心的作用，即您后面说的“有利于对心力的引导。”是吧？
    而这个具体准确的所缘正是《初发心功德品》开示的那些，我们成佛必须要缘的诸佛的功德，是吗？
    那么，这个具体清晰的所缘相，与法界实相是怎么随顺的？
    另外，成佛的因是否也可以看成是我们法尔本具的“智慧德相”？而菩提心等可以看成是增上缘？
    宗大师说：一切经论皆教授。都是实实在在的具体修法。赵叔的行持，正是此言最好的诠释。真让人赞叹！只是赞叹之余也有些顾虑──像后学这等初级学人很有“临渊羡鱼”之感。笑嘻嘻。

    zf：
    “您说的菩提心之“所缘缘”是说要缘什么而发心，对吗？”
    ──对。
    因为“佛”或“无上正觉”在不同人的心中有不同的含义。

    “而所缘对象越具体越准确越清晰，就越有利于引发菩提心的作用，即您后面说的‘有利于对心力的引导。’是吧？”
    ──是。

    “而这个具体准确的所缘正是《初发心功德品》开示的那些，我们成佛必须要缘的诸佛的功德，是吗？”
    是。
    ──诸佛的功德，在不同经论中有不同侧面和不同深度的开显。《初发心功德品》中的如来十力，是在华严无碍法界见下的开显，有其不共之处。

    “那么，这个具体清晰的所缘相，与法界实相是怎么随顺的？”
    ──《初发心功德品》中的发心所缘相就是华严的法界实相和菩萨的大悲行愿。

    “另外，成佛的因是否也可以看成是我们法尔本具的“智慧德相”？而菩提心等可以看成是增上缘？”
    ──成佛之因是菩提心，是开显我们法尔本具“智慧德相”的“因缘”。六度万行等可视为增上缘。

    “……只是赞叹之余也有些顾虑──象后学这等初级学人很有“临渊羡鱼”之感。笑嘻嘻。”
    ──临渊羡鱼，不如退而结网。
    我自己是一面大喊这里有鱼，一面结网──修习皈依、菩提心、忏悔业障等。

    dawa：
    谢谢开示，如痛饮甘露……尚有一问：
【真下手修行时，还有一点常被忽略：佛的功德无量无边，但作为我们发心所缘之佛功德应该必须有哪些？
    此问题不解决，我们要成的“佛”便徒有虚名。】
    赵叔，这个地方是说行人应当发起具体的愿，如阿弥陀佛的48愿或者药师佛的12愿等等？

    俺的理解是：本具功德的显现是缘起，就表现为发起殊胜的愿力并使之实现。而将因果序列导入与愿力相符的轨道，即为因缘法之解脱。
    或缚或解，都不离法性，不离因缘。

    zf：
    “俺的理解是：本具功德的显现是缘起，就表现为发起殊胜的愿力并使之实现。而将因果序列导入与愿力相符的轨道，即为因缘法之解脱。或缚或解，都不离法性，不离因缘。”
    ──对！
    “这个地方是说行人应当发起具体的愿，如阿弥托佛的48愿或者药师佛的12愿等等？”
    ──目标准确、具体有利于对心力的引导。
    如人引弓欲射，但看不清靶子，结果会怎样？
    《初发心功德品》中之“发是心已能知前际一切诸佛始成正觉及般涅槃。能信后际一切诸佛所有善根。能知现在一切诸佛所有智慧。”这句话的分量，请仔细掂量！

    梦中人：
    欢喜赞叹。请问：“父母双运出生如来。”般若智为母，菩提心为父，以平等心行功德事，真的很具有操作性。这里的平等心与菩提心当指初发心吧？这里的发心当指愿众生成佛的心吧？具体在贪嗔痴的当下如何发心呢？还望赵叔明示！

    zf：
    “‘父母双运出生如来。’般若智为母，菩提心为父，以平等心行功德事，真的很具有操作性。这里的平等心与菩提心当指初发心吧？这里的发心当指愿众生成佛的心吧？”
    ──平等心指般若空慧；
    菩提心指为利众生愿成佛的金刚誓愿。
    “初发心”在不同教法中有不同含义（华严经中之“初发心”的标准就极高）。
    “具体在贪嗔痴的当下如何发心呢？”
    ──一、在贪心现前时，盯住它，体会其与对无上菩提追求的相同性，将“邪贪”转为对菩提之“正贪”；
    二、类似，将“邪嗔”转为对自心烦恼的“正嗔”；将“无明”转为无分别智。
    若行人力量充足，确实有直接转的可能，但多数人还是要依靠各种善巧方便。

    梦中人：
    “平等心指般若空慧；”
    心既平等，则贪嗔痴即是如来功德，如何还要力求如来功德呢？
    ──────────────────────
    “若行人力量充足，确实有直接转的可能，但多数人还是要依靠各种善巧方便。”

    在这里如何才能力量充足呢？
    ──────────────────────
    “在贪心现前时，盯住它，体会其与对无上菩提追求的相同性，将“邪贪”转为对菩提之“正贪”；”

    我的体会是当贪心升起，会有很大的习气，操纵你去造业，是不是先要降伏习气，伏归空性，体验空性，彻底斩断习气，菩提心才会升起并现行。我在这里的用心对不对？
    ──────────────────────
    最后还要问一个ZT兄曾经问过的问题，我空与法空究竟如何界定？为什么小乘圣者证空性却不能成佛？须菩提解空第一，是小乘阿罗汉，为什么金刚经是大乘经典？小乘与大乘究竟应如何界定？

    呵呵，善知识难得难遇，还望赵叔百忙中慈悲指授。

    zf：
    “心既平等，则贪嗔痴即是如来功德，如何还要力求如来功德呢？”
    ──心契平等，是如来功德显现的必要条件，但不是充分必要条件。

    ““若行人力量充足，确实有直接转的可能，但多数人还是要依靠各种善巧方便。”──在这里如何才能力量充足呢？”
    ──勤修皈依、忏悔、菩提心和显密方便。

    “我的体会是当贪心升起，会有很大的习气，操纵你去造业，是不是先要降伏习气，伏归空性，体验空性，彻底斩断习气，菩提心才会升起并现行。我在这里的用心对不对？”
    ──通过勤修皈依、忏悔、菩提心等，可以有效对制粗重的烦恼，在此基础上再修习空性会更易契入，这就是三主要道的次第。

    “最后还要问一个ZT兄曾经问过的问题，我空与法空究竟如何界定？”
    ──简单地说，我空的重点是说五蕴中无我；而法空则进一步破除对五蕴的自性执。

    “为什么小乘圣者证空性却不能成佛？”
    ──关于小乘所证空性的深度和广度，各家有不同的说法，这还不是最重要的。最重要的是──小乘没有无上菩提心。

    “须菩提解空第一，是小乘阿罗汉，为什么金刚经是大乘经典？”
    ──这可从两个方面理解： 　　一、大乘是如来本怀，为使小乘廻小向大，在时机成熟时，如来亦对小乘行人开显大乘法义。
    二、在《法华经》中，如来亦对须菩提等授记，将来成佛，因此也可以认为须菩提等圣者是辅助如来宣说小乘教法的菩萨。

    “小乘与大乘究竟应如何界定？”
    ──有无菩提心应是根本标准。

    F117：
    试答最后一问：所说功德，即非功德，是名功德，实无发心及所缘者，是为发心。

    zf：
    在下浅见，“无住”不是“无愿”。愿而无住，无住而愿，方合无住生心的妙旨。

    F117：
    是的，依信愿行入法性海，知见正了，行证要跟上
    但佛法的实践好难！尤其是大乘法，《普贤行愿品》是我的必读功课，早上读了，晚上都不敢想自己做了多少，“恒顺众生”，众生顺我还差不多！
    当然话说回来，人是社会的人，社会是人的社会，尽职尽责地扮演好自己的社会角色，应该是很好地行了吧？圆顿法门都讲世间、出世间不二，但烦恼和矛盾时时有处处有，就象下岗和生计问题罢，遇上了是真困扰人，这时空有不二的大法能当饭吃吗？还望老师拈提，用佛法的精神在世间为我等末学找个安身立命处！

    zf：
    “但佛法的实践好难！尤其是大乘法，”
    ──是啊！
    “《普贤行愿品》是我的必读功课，早上读了，晚上都不敢想自己做了多少，“恒顺众生”，众生顺我还差不多！”
    ──“普贤行愿”这种“终极大愿”要仗着胆子发，先别管现在能作到多少。一方面要用大愿来检查自己，但另一方面切记不要过于苛求，毕竟成佛以后所行的也不过是普贤行，特别是恒顺众生这一项。

    “当然话说回来，人是社会的人，社会是人的社会，尽职尽责地扮演好自己的社会角色，应该是很好地行了吧？”
    ──仁兄试想：如果佛弟子中有相当一部分是“尽职尽责地扮演好自己的社会角色”者，那么佛教徒在公众的心中形象恐非今日可比，这对引导大众（特别是青年人）学佛应该利大于弊。

    “圆顿法门都讲世间、出世间不二，但烦恼和矛盾时时有处处有，就象下岗和生计问题罢，遇上了是真困扰人，这时空有不二的大法能当饭吃吗？”
    ──虽不能当饭吃，但对调节自己的心态却大有益处，而心态对生计问题也关系重大。
    达摩祖师的“二入四行”中含有实际的用心法诀，可以用心参学。

    “还望老师拈提，用佛法的精神在世间为我等末学找个安身立命处！”
    ──对于那些没有立志“为利众生愿出家”者，我的建议是：一、好好学习和工作，起码作到衣食无忧；二、将主要的业余时间用来学佛。
    如果工作的目的是为学佛准备必要的条件，那么工作本身是否也成了学佛的一部分？

    F117：
    再答赵叔“发心所缘之佛功德应该必须有哪些？”我认为佛有法、报、化三身，相应地所缘之佛功德也应该各有侧重。佛的法身在于清净无染，报身在于福、智庄严，化身则象春雨，润物细无声。

    zf：
    您读过《华严经初发心功德品》吗？

    F117：
    发心广大等虚空　生诸功德同法界
    以前读过，现在又读了一遍，感觉真好。

    zf：
    随喜。


发心清晰程度的确定

    发心清晰程度的确定

    zf

    Q兄，齐兄下面这一句已经说得非常清楚了：“当行者在‘如’或者缘与‘诸法实相’相似的所缘时，心行上的开展与药师一致，虽未证得药师的全部功德，然对此法在深度和广度上皆无疑异，必然彻证佛果，可以称之为如实。”
    心之所缘的确定，是修行中极为重要的内容。菩提心的所缘，就是如来的所有悲心、智慧和功德。我等初学佛时，对如来的一切功德不可能有彻底清晰的了解，但有一点是确定的——这就是如来有圆满利益众生的能力，获得这种能力就是我们的目标。此时，我们心中的目标虽然有明确的方向性，但显然不够清晰，这时种种修行方便和助道之法便是不可缺少的。（上师瑜伽便是一种殊胜的修行方便，当行人对上师的信心圆满坚固时，自心与上师之心便完全融合，而这正是上师瑜伽的心要。）
    有一类众生，其根性喜欢在初发菩提心时就尽量将目标“清晰化”。但这种“清晰化”面临着一个困难，因为“如来功德，假使十方一切诸佛经不可说不可说佛刹极微尘数劫，相续演说不可穷尽”，对我等凡夫乃至大菩萨来说，绝对的“清晰化”是根本不可能的。那么，是否存在某种程度的相对“清晰化”？如来慈悲，在《华严经·初发心功德品》中给出了答案。在这里，发心的所缘比通常发心的所缘要“清晰”（同时也复杂）得多。发心清晰化虽然增加了发心这一环节的困难，但却减少了对发心后修持方便和种种助道法的依赖，对适宜根性者乃至仅依靠此发心一法，才发心时便可成等正觉。
    由此可以看出，发心的清晰程度与对修持方便的依赖似乎存在着“反比例”关系。


初发心时，便成正觉

    福严：
    菩提心乃大小乘根本区别。一发菩提心，就是大乘菩萨。经中有言：“初发心时，便成正觉。”

    终不说：
    初发心时，便成正觉。是方便，非究竟义！可能会退转也说不定。

    gladness：
    我记得华严经梵行品中有类似的话，好像是“才发心时即成阿耨多罗三藐三菩提”。之后初发心功德品中对此“初发心”所指的发心，详细说明了一下，并且说明如果按这种发心发起来的话，确实就成佛了。只是这里讲的发心和别处讲的发心有所不同，但是应该是究竟的发心，因为这样发心就成佛了。
    我也是听别人讲的，因为初发心功德品极殊胜，看到大家讨论才发心时便成正觉，就现炒现卖，但愿各位同修都与此品经有缘。嘻嘻。

    终不说：
    这是什么觉？只是因地而已！不要倒因为果，发了心就不用再修行了？

    zs：
    不是因地的。你最好先看看《华严经·初发心功德品》然后再说话。省得以后后悔。这是佛的发心。你能发出来，那就是佛。
    众生和佛的区别，某种程度上可以说是两种心态的区别。众生要依赖于把住一些东西来〔平衡〕心态，佛是看见凡所有相皆是虚妄，所以，不粘着的坦然而住。
    要想做到坦然而住，就要靠发大的菩提心了。每天勤发着，对修证是有极大极大的帮助。

    zf：
    佛不妄语
    《梵行品》中分明指出，若能如法修行，可以小方便，速疾成佛，乃至初发心时即成正觉。《初发心功德品》不但肯定了发心即成佛的可能，更进一步开示了此种发心的所缘相。众所周知，大乘佛法的通途是发菩提心、修普贤行直至成佛。而《初发心功德品》开示发心即成佛的方便，确是独辟蹊径！于此不解者实属正常。这里只是提醒诸位有疑虑者，《初发心功德品》中所示之发心即成佛的方便，乃十方各万佛刹微尘数佛（同名法慧）共同宣说，一切如来悉如是说。如来发愿：“我等悉当护持此法，令未来世一切菩萨未曾闻者皆悉得闻。”　是故诸位于此不解者，心中疑虑可存，但万万莫生毁谤而造恶业。
    《初发心功德品》中开示的教法与宁玛巴大圆满中“既无前行亦无需后修”的法门类似。这类法门若非特殊根性者、或有特殊机缘者极难相应信解。若无大善知识指导而错会圣义、未证言证，反耽误了自家的菩提慧命。慎之！
    zs说：“此种发心乃佛的发心”。此说稍欠准确。较准确的说法应是：此种发心乃直接随顺如来一切种智的发心。

    二麻子：
    原来是你！！！欢迎之极。ZS跟我说这篇写得好，作者厉害。我来一看，嘻嘻，原来同胞！欢迎欢迎，难得难得。希望以后常在这里见到你。嘻嘻。

    2001年9月04日


安住实相，功德自显

    gladness：
    关于初发心功德品的问题

    一、初发心功德品中有“妙世界即是粗世界。粗世界即是妙世界。”，那么套一下这句话，得出，娑婆世界即是极乐世界，娑婆世界即是莲师净土，应该是成立的。那么，如何让妙世界的妙用起用呢？
    二、“一念与不可说劫平等。不可说劫与一念平等。”，那么，如何让这一念的善愿、一声佛号、一个咒音，发挥出不可说劫的“念念相续。无有间断。”的作用呢？
    请善知识为末学解答。

    zf：
    安住实相，功德自显。
    别忘了，“见”是有业力的。

    rj：
    又，见是业力形成的，见有业力，业力形成见，看来真实细微见是什么样子，能说明业力的某些状态或者属性。

    赵叔就这点再详细展开谈谈吧。后学以为这里极其重要。尤其是在相续的状态的得知上。

    zf：
    “见有业力，业力形成见，看来真实细微见是什么样子，能说明业力的某些状态或者属性。”
    ──若说见之真实与细微，《初发心功德品》中开示之发心所缘对我们因位行人来说就是足够真实、足够深细之见。说其“足够”，是因为依之发心，“发是心已，能知前际一切诸佛始成正觉及般涅槃，能信后际一切诸佛所有善根，能知现在一切诸佛所有智慧。彼诸佛所有功德此菩萨能信、能受、能修、能得、能知、能证、能成就、能与诸佛平等一性。”
    “赵叔就这点再详细展开谈谈吧。后学以为这里极其重要。尤其是在相续的状态的得知上。”
    ──目标清楚了，就好比箭已上弓，能否中的，还要看硬弓是否拉满。
    见有业力，但此业力之大小、成熟的快慢，还要看此见是入行人之毛、之皮、之肉、之骨还是之髓。

    圣普：
    真信了真实，就到家了吧，因为真实是本具的。以于众生心平等故，则能成就圆满大悲，以大悲心随众生故，则能成就供养如来。

    zf：
    对实相的真信，也就是当下承当。能当下承当者，并无余事可做。
    而检验此承当是否有误的标准就是：普贤行愿是否成为内心自然的流露。


才发心时，即能熄灭一切世界诸恶道苦

    才发心时，即能熄灭一切世界诸恶道苦

    zf

    对“才发心时，即能熄灭一切世界诸恶道苦”这句经文，我的理解大概这样： 　　一、《初发心功德品》中的“初发心”，与通常发菩提心教授中的“初发心”并不相同。此处之“初发心”是直接缘重重无尽、事事无碍的华严法界和如来特有之十力而发心，故具有不共之功德。
    二、虽然如此，单从字面上理解“才发心时，即能熄灭一切世界诸恶道苦”还是有困难。
    佛经中常有如来放光救度恶道众生的记载。恶道众生蒙佛力加被，或有大苦减轻者，或有痛苦暂息者，或有出离恶道投生善道者，或有往生佛国者。如来于一切众生平等普度，并不存在种种分别，为何众生所获利益不同呢？根本原因在于众生的业力。因此，我们应该这样理解：如来具有圆满的利生能力，但这种能力的发挥程度则依赖于众生的业力。
    回过头来再看上述经文，可以理解为：按照此处教授发心的菩萨，便具有能力熄灭一切世界中与此菩萨因缘成熟的诸恶道众生的苦。
    《华严经》中普贤菩萨对如来功德的赞颂，可以提醒我们不要忘记——佛法是因缘法。
    佛智广大同虚空　　普遍一切众生心
    悉了世间诸妄想　　不起种种异分别
    一念悉知三世法　　亦了一切众生根
    譬如善巧大幻师　　念念示现无边事
    随众生心种种行　　往昔诸业誓愿力
    令其所见各不同　　而佛本来无动念
    或有处处见佛坐　　充满十方诸世界
    或有其心不清净　　无量劫中不见佛
    或有信解离憍慢　　发意即得见如来
    或有谄诳不净心　　亿劫寻求莫值遇
    或一切处闻佛音　　其音美妙令心悦
    或有百千万亿劫　　心不净故不闻者
    或见清净大菩萨　　充满三千大千界
    皆已具足普贤行　　如来于中俨然坐
    ……


“华严发心门”和“普贤行愿门”

    zf：
    “为什么佛可以不起种种异分别？为什么佛可以一念悉知三世法？亦了一切众生根？”
    ──您的问题是如何才能对如来的功德能起信并接受？
    我这里正好有付药，能治您的疑病。不过是否肯吃药还看您自己了。
   《华严经初发心功德品》中言：
“发是心已能知前际一切诸佛始成正觉及般涅槃。能信后际一切诸佛所有善根。能知现在一切诸佛所有智慧。彼诸佛所有功德此菩萨能信能受能修能得能知能证能成就能与诸佛平等一性。”
    可千万不要小看了这一开示：对如来所有善根、功德的信、受、修、得、知、证、成就都可以通过对华严菩提心的修持来完成。
    依在下的浅见，“华严发心门”和“普贤行愿门”都是即身成佛乃至当下成佛的总持大门。
    这不是在下的信口雌黄，而是十方诸佛所赞叹。

    静风：
    对您这篇（编按，指“圆教的发心方法”一文）所言俺有信心。众生根器不同，千差万别，即使是初发心，也有境界不同，何况再依诸佛的甚深法要，于极短时间即成果位应有可能。法华龙女和华严善财童子即是例子。

    zf：
    随喜。静风兄，法华龙女和华严善财童子是两个即身成佛的典型。
    龙女在文殊菩萨的指导下，于他方有缘国土成佛，但龙女修行的用心方法，法华中的说法方式是暗喻而不是显说。我等愚昧，不易随学。
    但善财童子的情况却不同。特别是普贤菩萨对善财童子的开示，对如何用心有详尽的解说，堪称一部观修仪轨，真心实修者完全可以依之而行。
    忍不住多说了几句。


菩萨道苦中有乐的一面

    1234322：
    我有一个问题，一想起种种菩萨行时，就觉得很难，心里确实有些畏惧甚至退缩，像师兄说的有点“发怵”的感受，但是不去行，又无法得到究竟解脱。请问有没有一种方法，可以不产生畏惧的感觉，或者更好一些，心里根本就想不起来这个难易的想法和感觉？不知道这算不算妄想或者“偷心取巧”？

    zf：
    对兄之“一想起种种菩萨行时，就觉得很难，心里确实有些畏惧甚至退缩，象师兄说的有点‘发怵’的感受，但是不去行，又无法得到究竟解脱。请问有没有一种方法，可以不产生畏惧的感觉，或者更好一些，心里根本就想不起来这个难易的想法和感觉？”的问题，静风兄回答得十分恳切。的确，菩萨道唯大丈夫（当然包括女中之丈夫）所能为，非心量小者所堪为之。下面补充一点自己的看法，供兄参考。
    一、菩萨之苦与众生之苦
    菩萨之苦乃医生之辛苦，众生之苦乃病人之痛苦。两者虽皆为苦，但本质有异。众生苦后还是苦，而菩萨苦中有乐。
    二、菩萨之乐
    因自身之辛苦，换取六道父母脱离苦海，乃菩萨大乐之源泉。此之大乐绝非世间任何欲乐所堪比拟。试想，当跳入急流中，奋力将亲子救出之父亲心中所体验之乐，岂是仅知于岸上流泪之母亲所能想象。是故若欲体验法界中之无上大乐，非以救度众生为道不可。如《般若理趣经》中所云：“拔有情界，利益安乐一切有情，毕竟大乐，最胜成就。所以者何？乃至生死流转处有胜慧者齐此，能以无等法饶益有情，不入寂灭。”从这一角度看，菩萨应是世间最“贪”之人。
    三、菩萨无畏之另一依据
    《华严经初发心功德品》指出：“一切世间唯想力，以智而入心无畏，思维诸法亦复然，三世推求不可得。能入过去毕前际，能入未来毕后际，能入现在一切处，常勤观察无所有。”由此可知，菩萨往复六道，出入一切世间拔济群苦而心无畏的另一依据在于般若妙智——即对一切法皆无自性之幻有的正观。若能真切了知“一切有为法，如梦幻泡影”则心自然不为幻象所迷，对一切世间幻象的恐惧便荡然无存。是故菩萨道以菩提心为因，般若为最重要之缘，故我等当勤修般若。
    四、分别智带给菩萨的快乐
    《华严经初发心功德品》中还开示：“菩萨于一毛孔中，普现十方无量刹，或有杂染或清净，种种业作皆能了。一微尘中无量刹，无量诸佛及佛子，诸刹各别无杂乱，如一一切悉明见。于一毛孔见十方，尽虚空界诸世间，无有一处空无佛，如是佛刹悉清净。于毛孔中见佛刹，复见一切诸众生，三世六趣各不同，昼夜月时有缚解。如是大智诸菩萨，专心趣向法王位，于佛所住顺思维，而或无边大欢喜。”菩萨经过修习，自然会感得了知种种因果的分别智，当此分别智现前时，菩萨心中会生起无边大欢喜。何以故，借此分别智之善巧方便，菩萨方能更契理契机地救度众生。
    静风兄宣说了菩萨道辛苦沉重的一面，我这里所补充的是苦中有乐的一面，两者结合，望1234322兄之菩提心早日坚如金刚，无坚不摧。


菩萨勇气的来源

    dawa：
    在报恩心上，一直做的不好……也很不喜欢像商品交换式的“报恩”。
    真正的报恩应该是学习佛陀。佛陀那种无计回报的施与精神，使其余一切所谓“恩德”变得极其的婆婆妈妈……
    如何报佛恩，如华严经所述：
如来兴出世　寂静大慈悲
    普转妙法轮　利益诸含识
    佛于无量劫　勤苦为众生
    云何诸众生　能报大师恩
    宁受三涂苦　备经无量劫
    终不舍如来　而求于出离
    宁代诸众生　永受轮回苦
    终不舍如来　而求于少乐
    宁恶道多劫　受苦闻佛名
    不愿生善道　暂时不闻佛
    宁地狱多劫　受苦常见佛
    不愿离三涂　生无佛法处
    何故于恶道　而无厌离心
    由见于法王　智慧常增长
    见佛自在力　能除一切苦
    得入诸如来　甚深智境界
    若得见佛时　灭除诸恶趣
    增长福智芽　必获菩提果
    众生若见佛　能破种种疑
    世出世间乐　所愿皆圆满

    二麻子：
    嘻嘻，文字与理解……
    嘻嘻。如你所说意思的报恩，有人相应，有人未必相应。而且，如你这样的不相应也未必就不好。相反，对你个人来讲，这似乎是“长大”过程的一环，应该不坏。不过呢，报恩两字也有别的理解法，比如
    “已将身心付尘刹，如是方名报佛恩”。
    嘻嘻。“身心付尘刹”是不是无我的“工具”？可这也是报恩呀。所以，同样文字还有个不同理解不同意义嘛……

    zf：
    菩萨勇气的来源。“深入红尘，担众生之苦，并不惧畏烦恼，能将烦恼转成菩提”这的确是我等有志于大乘道学人的理想，需要无畏的勇气。而培养勇气的根本，据佛经中的开示，是修学般若。
    仔细观察自心便可以发现，对菩萨道畏难心理产生的原因主要有两个：
一、“报恩”心理的薄弱；
    二、以六道为实有。
    有恩不报者难入大乘，这里暂且不谈。如果以六道为实有，而六道众生又无量无边，这时行人心理存有相当程度的畏惧是十分正常的。对治此畏惧的重要方便就是依照般若的法义，去理解、体验、实证诸法空义，《金刚经》中的“一切有为法，如梦幻泡影，如露亦如电，应作如是观”便是修行的殊胜窍诀。正如顶果仁波切所开示的那样：“幻师永远不会被自己的幻术蒙骗。当变现出牛、马、马车等幻相时，无论它们看起来多么逼真，他自己都知道这些东西并不真实存在。”正是由于大菩萨们具备了识破一切幻相的智慧，才能示现于六道，利益众生，永不疲厌，如《华严经初发心功德品》中所说：“观察众生如幻梦，以业力故常流转，大悲哀愍咸救拔，为说无为净法性……　一切世间唯想力，以智而入心无畏，思惟诸法亦复然，三世推求不可得。”
   关于般若对菩萨行愿的护持作用，《佛说佛母出生三法藏般若波罗蜜多经》中有一个非常形象的比喻：
复次须菩提。又如世间百二十岁老人。忽于一时为彼风癀痰［病－丙＋（企－止＋（套－大））］诸病侵恼。以是因缘忍苦于床。须菩提。于意云何。是人若时无人扶侍。当能从床而自起不。须菩提言。不也世尊。佛言。须菩提。是人设或能从床起。亦不能行一里二里乃至由旬。何以故。已为老病所侵恼故。须菩提。菩萨摩诃萨亦复如是。于阿耨多罗三藐三菩提有信有忍。乃至离放逸不散乱。虽具如是功德。若不得般若波罗蜜多善巧方便所护念者。当知是菩萨。于其中路有所退失。堕于声闻缘觉之地。不能成就一切智果。
    又须菩提。而彼百二十岁老人。虽复有疾忍苦于床。若时有二力士。来谓其言。我等二人各于左右扶侍于汝。汝速当起随有所往。令汝得至。勿忧中路有所退失。时老病人受其语故。能从床起随往得至。须菩提。菩萨摩诃萨亦复如是。于阿耨多罗三藐三菩提。有信有忍乃至离放逸不散乱。具足如是功德已。复得般若波罗蜜多善巧方便所护念者。当知是菩萨于其中路无所退失。不堕声闻缘觉之地。即能成就一切智果。何以故。法尔如是故。须菩提。若诸菩萨摩诃萨。于阿耨多罗三藐三菩提。有信有忍。乃至离放逸不散乱。具足如是功德已。复得般若波罗蜜多善巧方便所护念者。当知是菩萨决定不堕声闻缘觉之地。即能成就一切智果。皆悉以是功德。回向阿耨多罗三藐三菩提。
    我们这些菩提道上的初行者，虽然发起了行愿菩提心（“于阿耨多罗三藐三菩提有信有忍，乃至离放逸不散乱”），若无般若的护持，菩提道上的艰难便如同一百二十岁的病人欲行远路一般。但若得般若空慧，我等就如同老人被两个大力士左右扶侍一样，实现“深入红尘，担众生之苦”的行愿便一定不象原来想象的那样难了。
    般若对大乘道的重要由此可见一斑。


关于懈怠与精进、多闻与实修

    关于懈怠与精进、多闻与实修

    zf

    无常的教育：发生了认为不该发生的事情，在没有预料到的时间发生了认为可能发生的事情，这些都是无常的标志。
    生命存在于呼吸之间，其结束也是无常的。
    以此次“网络事故”为因缘，愿大家牢记普贤菩萨的醒世真言：
是日已过
    命亦随减
    如少水鱼
    斯有何乐
    当勤精进
    如救头燃
    但念无常
    慎勿放逸

    文殊菩萨与勤首、法首菩萨的问答——关于懈怠与精进、多闻与实修

    节录自《大方广佛华严经菩萨问明品》

    尔时文殊师利菩萨。问勤首菩萨言。佛子。佛教是一。众生得见。云何不即悉断一切诸烦恼缚。而得出离。然其色蕴。受蕴想蕴。行蕴识蕴。欲界色界。无色界。无明贪爱。无有差别。是则佛教。于诸众生。或有利益。或无利益。时勤首菩萨。以颂答曰
    佛子善谛听　　我今如实答
    或有速解脱　　或有难出离
    若欲求除灭　　无量诸过恶
    当于佛法中　　勇猛常精进
    譬如微少火　　樵湿速令灭
    于佛教法中　　懈怠者亦然
    如钻燧求火　　未出而数息
    火势随止灭　　懈怠者亦然
    如人持日珠　　不以物承影
    火终不可得　　懈怠者亦然
    譬如赫日照　　孩稚闭其目
    怪言何不睹　　懈怠者亦然
    如人无手足　　欲以芒草箭
    遍射破大地　　懈怠者亦然
    如以一毛端　　而取大海水
    欲令尽干竭　　懈怠者亦然
    又如劫火起　　欲以少水灭
    于佛教法中　　懈怠者亦然
    如有见虚空　　端居不摇动
    而言普腾蹑　　懈怠者亦然

    尔时文殊师利菩萨。问法首菩萨言。佛子。如佛所说。若有众生。受持正法。悉能除断一切烦恼。何故复有受持正法。而不断者。随贪嗔痴。随慢随覆。随忿随恨。随嫉随悭。随诳随谄。势力所转。无有离心。能受持法。何故复于心行之内。起诸烦恼。时法首菩萨。以颂答曰
    佛子善谛听　　所问如实义
    非但以多闻　　能入如来法
    如人水所漂　　惧溺而渴死
    于法不修行　　多闻亦如是
    如人设美膳　　自饿而不食
    于法不修行　　多闻亦如是
    如人善方药　　自疾不能救
    于法不修行　　多闻亦如是
    如人数他宝　　自无半钱分
    于法不修行　　多闻亦如是
    如有生王宫　　而受餧与寒
    于法不修行　　多闻亦如是
    如聋奏音乐　　悦彼不自闻
    于法不修行　　多闻亦如是
    如盲缋众像　　示彼不自见
    于法不修行　　多闻亦如是
    譬如海船师　　而于海中死
    于法不修行　　多闻亦如是
    如在四衢道　　广说众好事
    内自无实德　　不行亦如是


为利生，无量的善巧方便正是菩萨当应学处

    无言：
    “全心相信三宝”与“戒除任何对其他众生的恼害”该如何理解？
    做到什么样才能算全心相信呢？戒除任何对其他众生的恼害，可我们很难做到人人满意，总会有人不满，是不是可以理解为我们做事的发心不是为了恼害众生，至于别人是不是会烦恼或恼怒并不是关键？

    zf：
    “做到什么样才能算全心相信呢？戒除任何对其他众生的恼害，可我们很难做到人人满意，总会有人不满，是不是可以理解为我们做事的发心不是为了恼害众生，至于别人是不是会烦恼或恼怒并不是关键？”
    ──发心当然重要，但结果亦重要。
    好的发心导致差的结果，说明行事缺乏善巧。
    为利生，无量的善巧方便正是菩萨当应学处。
    学人常以“好心没办好事”为自己寻找借口，我等当慎之。

    无名：
    请教麻叔，关于“担众生之苦”一事。我想问这个担众生之苦是有意的还是无意的？以我想来，众生无始以来做种种恶业，自己的苦自己能对付了就不错了，再加上三五人的苦的话，怕是够消受的了，但还能不惧畏烦恼，甚至还能将烦恼转成菩提，千万人中何能见一个？试想一下文化大革命中的人，被斗倒斗臭者，我估计能转烦恼成菩提的不多。唯一的解释，那就是上根者，有根器，有福德。那么这种作略是不具有可推广性的。

    二麻子：
    嘻嘻。现在的因缘条件下推广确实难……但仍然是应该学习的目标。这个目标不应该放弃。如同我们学佛，并不是说人人现在都能做佛了，但这个目标不能放弃，向这个方向学习的努力不能放弃。能做多少，各自努力就是了。


真正认识到众生的可敬之处

    真正认识到众生的可敬之处

    zf

    玄兹兄，非常高兴能与兄继续交流学佛方面的心得，不当之处敬请指正。首先，在下不同意兄以外道自称。不错，三皈依的确是划分是否佛弟子的标准，但是否三皈依更重要者是看行者是否于心中真心皈依三宝，真心皈依三宝者便是佛弟子，不再是外道。
    兄最喜研读金刚经，并依经中开示修学，只此一点，在下认为，兄便是真心皈依三宝。首先，金刚经为法宝，此点无疑，因“一切诸佛及诸佛阿耨多罗三藐三菩提法皆从此经出”故；第二，金刚经亦为佛宝和僧宝，经中明示：“若是经典所在之处，则为有佛，若尊重弟子”。可见金刚经所在之处，即是诸佛和诸多可尊重之大弟子汇集之处。因此，依金刚经修学，便是依三宝修学。依三宝修学者自称外道，于己于人均有莫大过失，望兄三思。
    另外，依在下浅见，兄不但是三宝弟子，而且是大乘弟子。兄依六祖大师开示，发起四弘誓愿，同时在论坛上规劝其他学人依四弘誓愿发大菩提心，如此不但是自己发心，而且是实践着利益众生的菩萨行。经论中多有开示，即使行人仅发起成就无上菩提的愿菩提心，行门中的功德一丝亦未生起，仅凭此愿心，此行人亦可无愧安住菩萨位，为真佛子，其功德远非二乘阿罗汉可比。
    因此，兄于在下心中为一真正菩萨。
    关于“在后天的普通教育和修养仍不足以明显改变先天性格中的弱点时，如何做到普敬和不轻慢众生”这一问题，依在下浅见，要真正普敬众生，就必须真正认识到众生的可尊敬之处。而众生真正之可尊敬处，便是如来开示之“一切众生皆具如来智慧德相，只因妄想执着不能证得。”试想，因一切众生皆具如来智慧德相，则我等自然应如普贤行愿品中宣说之恒顺众生，种种承事、种种供养、如敬父母、如奉师长及阿罗汉，乃至如来等无有异。另一方面，众生虽本具如来智慧德相，但因妄想故不能证得，流落六道，枉受诸苦，乃天下第一冤枉之事。菩萨发愿利益众生，就是要帮助众生恢复本有功德。因此菩萨对众生的随顺不是无原则的，概括地说，菩萨随顺众生的原则就是：“欲行恶法皆悉不成，所修善业皆速成就，关闭一切诸恶趣门，开示人天涅槃正路。”因此一些菩萨现愤怒相，调伏众生烦恼，与普敬众生并不矛盾。
    如何克服先天性格中轻慢众生的弱点？对于欲修大乘的行者，若轻慢众生，则修行绝无成就之日，因大乘道的核心就是利益众生，关心众生胜过自己。普贤行愿品中开示：菩提树王以一切众生而为树根，诸佛菩萨而为花果。若轻慢一个众生，菩提树便有一根断掉；若轻慢一类众生，菩提树便有一族根断掉。树根若不发达，如何能开花结果？
    轻慢众生的危害如是，欲修大乘者不可不分外小心。


当嗔心的目标是菩萨时，此嗔心的恶果尤为严重

    当嗔心的目标是菩萨时，此嗔心的恶果尤为严重

    zf

    众位悉知，衡量是否为菩萨只有一个标准，既是否具有菩提心。生起菩提心的最正因是为利益一切众生，但这并不是说以其他因缘生起的菩提心就不算数，其人便不堪称为菩萨。在本人读过的经典中，此经中（注，指《佛说首楞严三昧经》，原贴中列出了《佛说首楞严三昧经》中，如来在宣说首楞严三昧诸功德后的一段经文。）恶魔之发心动机最为低劣，竟是为其他有情退失菩提心而发心，但如来仍为其受记，将来必定成佛。是故此之恶魔亦安住菩萨位，只是因地不正，果遭迂曲。
    本人这里给兄提的第一个问题是：根据你对某法师的了解，你是否有十足把握断定，某法师的发心动机要比上述恶魔的发心动机更低劣？？？即按照上述称恶魔为菩萨的标准来衡量，某师亦不配称其为菩萨？？？
    下面的经文引自《华严经普贤行品》。
    “尔时普贤菩萨摩诃萨。复告诸菩萨大众言。佛子。如向所演。此但随众生根器所宜。略说如来少分境界。何以故。诸佛世尊。为诸众生。无智作恶。计我我所。执着于身。颠倒疑惑。邪见分别。与诸结缚。恒共相应。随生死流。远如来道故。出兴于世。佛子。我不见一法为大过失。如诸菩萨。于他菩萨。起嗔心者。何以故。佛子。若诸菩萨。于余菩萨。起嗔恚心。即成就百万障门故。何等为百万障。所谓不见菩提障。不闻正法障。生不净世界障。生诸恶趣障。生诸难处障。多诸疾病障。多被谤毁障……（注：因为篇幅关系，节略数百字）……于菩萨无失坏道不能修习障。随顺二乘正位障。远离三世诸佛菩萨种性障。佛子。若菩萨。于诸菩萨。起一嗔心。则成就如是等百万障门。何以故。佛子。我不见有一法为大过恶。如诸菩萨。于余菩萨。起嗔心者。”
    本人当年读到此品经时，不觉吓出一身冷汗。试想，我们周围的同修以及网上的诸兄哪位不是已经发心的菩萨！彼此之间因为意见相左而生起嗔心是多么平常的事！但就是这样一件平常事，却正是普贤菩萨所说之“我不见有一法为大过恶，如诸菩萨于余菩萨起瞋心者”！
    某兄，本人所提的第二个问题是，在兄指出某法师种种不如法时，心中嗔心是否生起？？？
    本人毫不怀疑某兄参加讨论的动机──护持清净的佛法。但正如经中所言，“尔时长老摩诃伽叶。前白佛言。从今以后我等当于一切众生生世尊想。所以者何。我等无有如是智慧。何等众生有菩萨根何等众生无菩萨根。世尊。我等不知如是事故。或于众生生轻慢心。则为自伤。佛言。善哉善哉。伽叶。快说此言。以是事故我经中说。人则不应妄称量众生。所以者何。若妄称量于他众生。则为自伤。唯有如来。应量众生及与等者。以是因缘。若诸声闻及余菩萨。于诸众生应生佛想。”我们这些初入佛门者亦无有智慧断定菩萨的利生方便，若妄加评论，伤人自伤。对于某法师，能够带领如此众多的人念佛，而念一声佛号又能灭八十亿劫生死重罪，功德何其广大！对于法师的某些说法，本人亦多有不解之处，但本人因此发心，愿早得一切种智，早知利生之方便。
    以上两个问题仅供某兄深思，兄不必予以回答。文中佛经均引用“佛典宝库”电子版，在此致谢。
    如说：“不论广说不广说，都不违背菩萨戒。至于要不要广说，那就要看某种邪说的影响范围”。（至于某法师的言教是否邪说，本人无力断定，只认定一条：随喜功德，乃至一念）。
    “如果斤斤计较于个人的得失利害，不以圣教三宝为念，听任邪说横行，根基既毁，大厦何存！这样的人，说修大乘，其实比二乘不如。”这一说法，本人不解。对于初发心菩萨，虽欲护持三宝，然无智分辨邪说与大菩萨利生方便之间的极细差别，为免自伤及伤人而不支持某一方，这难道值得谴责吗？《圣弥勒解脱经》云：“善男子，譬如破碎金刚宝石，然能映蔽一切胜妙金庄严具。善男子，如是发起一切智心金刚宝石，纵离修习，然能映蔽声闻独觉一切功德金庄严具”（引自《菩提道次第广论》）。因此，将尚未修习、贪嗔痴具足（当然包括“斤斤计较于个人的得失利害”的我执）的初发心菩萨说成“其实比二乘不如”的依据何在？
    “如果真畏因果，大可不去论坛，老实自修自学，不要忙着做善知识。就算不说某本某人的是是非非，论坛上哪天又少了人我是非？谈玄说妙，解经释论，自己就能够保证没有错误？这里就不怕因果了吗？”，本人亦有不解之处。我等初发心菩萨，在论坛上交流自己对经论的理解难道是一种不畏因果的莽撞行为吗？论坛上大家取长补短，互相帮助，彼此互为善知识，正所谓三人行必有我师，这有何不妥吗？
    对“只论现象，不谈动机……。其实就事论事，一样能把问题谈清。”这一说法，本人深感怀疑。对于分辨是邪行还是利生方便，关键之处在于现象背后的动机，亦即所谓“居心”。若就事论事不谈动机，如何区别凡夫于嗔心摄持下的杀生与诸佛利生方便之降伏？
    “《菩萨善戒经》明确说：菩萨若有同师同学诽谤菩萨方等法藏，受学顶戴相似非法者，不应共住。若定知已，不得向人赞叹其德，是名菩萨第八重法。”所述为如来定制，我等当严格执行。但不得向人赞叹其德是否等于将该人的名字连同其非法之行向天下广而告之？？？？？？？？？？？？
    释迦狮子，曾将五种剧毒之物，示与我等，告戒我等，务必远离，万勿粘身，恐有性命之攸。傲慢，嗔心的过患想来兄并非不知。嗔心的对象无论是谁──菩萨、众生或魔，都应严厉遮止。只是当嗔心的目标是菩萨时，此嗔心的恶果尤为严重，广如普贤菩萨所说。
    本人前文的要点是提醒某兄仔细观察自己的起心动念（注意，只是提醒），若自己没有把握，莫以初行菩萨之身行深行菩萨之所堪为。
    若兄对自己之所为有十分把握，了知深细因果无碍，护持正法之事自己尽可以去做，因我亦无力测度兄之根基。本人要提醒的是那些与我自己一样，对自己没有把握的师兄，行事要慎重。把自己应该做、又有能力做而且肯定不会错的事搁置一边，去做那些自己力不胜任、稍不留心便可能铸成大错的险事，难说明智之举。
    法师能做的事，我等不一定能做；有些居士能做的事，我们自己不一定胜任！望兄好自为之。


网络学佛“讨论度”之浅见

    网络学佛“讨论度”之浅见

    zf

    古慈兄所提及之网络佛法中的负面现象（编按：古慈提的问题是，初学者应当如何看待和避免宗派主义），在下也略有所闻，心中虽亦担忧，但却每感无奈。
    在网络上交流学佛体会，对现今大陆学佛人来说，其作用不用在下多言，想必大家都有体会。从这个意义上说，我们都应感谢网络带来的方便。
    在网络上学习佛法与传统之以寺院为核心的学习相比，在形式上的一个鲜明特点就是开放、活泼，这一点与现代社会之学术研究的气氛有某种类似之处。我们可以设想，如果某个论坛聚集了一批在佛法正知见上有一定修养的学人，那么初学者在这个论坛上请教、讨论是相当安全的。其原因就在于讨论的公开性，这种公开性可以保证那些明显有悖于佛教经典的言论无立足之地。这比那些道听途说某种说法或习俗后就信以为真、依之而行要安全得多。
    网络佛法给我们带来了“民主”气氛，但我们大家是否为善用这一工具作好了准备？这是值得大家一起深思的问题。以世俗社会的民主制度为例，大家知道，民主制度尊重人的权利，但我们在行使自身权利的同时，一定要小心──不要侵犯了别人的权利；我们在追求自己自由的同时不要破坏了别人的自由。只有这些原则深入人心后，民主制度才能真正发挥其优越性，否则，“黑金政治”等社会丑恶现象同样会在“民主社会”中存在。
    网络佛法论坛上产生纷争的种类不一。将讨论局限于对教义理解上的交流，对讨论双方都非常有益，这种交流应予鼓励。各论坛斑竹开设论坛的初衷大都是为此类交流提供场所。但这种讨论稍不留神，就会对演变成对讨论者或讨论者尊重的某位大德乃至某一学派或宗派的攻击。只要一方有攻击性的言论，另一方为维护本派的声誉，势必奋起“护法”。依在下浅见，除极个别毁谤整个佛法者外，论战双方的初衷都是好的，都希望对方改邪归正（例如，前些天与yang兄讨论大小乘见地差异时，yang兄对在下的关怀之情溢于言表，令在下深为感动）。但讨论到什么程度应该立即停止，却不是个容易把握的度。超过这个度，对自他害大于利。在此，在下冒昧地提出一个可操作的“讨论度”的标准──以无嗔，即嗔心不生起为限。
    何为嗔心？从佛学辞典中可以查出以下解说：
嗔，又名嗔恚，三毒之一，系指对有情怨恨之精神作用。嗔，为修学佛道上最大之障害，经论中常诫之，如大智度论卷十四（大二五·一六七中）：“嗔恚其咎最深，三毒之中，无重此者；九十八使中，此为最坚；诸心病中，第一难治。”遗教经曰：“嗔心甚于猛火，常当防护，无令得入。劫功德贼，无过嗔恚。”决定毗尼经曰：“宁起百千贪心，不起一嗔恚，以违害大慈莫过此故。”往生要集中曰：“或处经云：能损大利无过嗔，一念因缘悉焚灭俱胝广劫所修善。”
    网络犹如一把双刃剑，在给我们提供交流便利的同时，也为我们嗔心的泛滥提供了便利。我们常常因为网上非面对面的讨论而放松了对自己的克制，在嗔心的驱动下，说嗔恚语，惹得对方亦嗔心大发，无始劫来辛辛苦苦积攒下来的善业被这一念嗔火烧得干干净净，命终之后，直奔地狱而去。因此，如果不能有效地对治自己的嗔心，可以毫不夸张地说，网络上的各个佛法论坛实际上就是一座座入地狱的预科学校！当然，从地狱出来后，今天在网上学到的佛法还会发挥作用，但这种地狱恶报我等何必非要不可呢？
    《华严经普贤行品》中详细开示了菩萨对其它菩萨起嗔心的巨大过患。以前在下曾引用此经，为加深印象，现再将此经引用如下：
尔时普贤菩萨摩诃萨。复告诸菩萨大众言。佛子。如向所演。此但随众生根器所宜。略说如来少分境界。何以故。诸佛世尊。为诸众生。无智作恶。计我我所。执着于身。颠倒疑惑。邪见分别。与诸结缚。恒共相应。随生死流。远如来道故。出兴于世。佛子。我不见一法为大过失。如诸菩萨。于他菩萨。起瞋心者。何以故。佛子。若诸菩萨。于余菩萨。起瞋恚心。即成就百万障门故。何等为百万障。所谓不见菩提障。不闻正法障。生不净世界障。生诸恶趣障。生诸难处障。多诸疾病障。多被谤毁障。生顽钝诸趣障。坏失正念障。阙少智能障。眼障耳障。鼻障舌障。身障意障。恶知识障。恶伴党障。乐习小乘障。乐近凡庸障。不信乐大威德人障。乐与离正见人同住障。生外道家障。住魔境界障。离佛正教障。不见善友障。善根留难障。增不善法障。得下劣处障。生边地障。生恶人家障。生恶神中障。生恶龙恶夜叉。恶乾闼婆。恶阿修罗。恶迦楼罗。恶紧那罗。恶摩睺罗伽。恶罗剎中障。不乐佛法障。习童蒙法障。乐着小乘障。不乐大乘障。性多惊怖障。心常忧恼障。爱着生死障。不专佛法障。不喜见闻佛自在神通障。不得菩萨诸根障。不行菩萨净行障。退怯菩萨深心障。不生菩萨大愿障。不发一切智心障。于菩萨行懈怠障。不能净治诸业障。不能摄取大福障。智力不能明利障。断于广大智能障。不护持菩萨诸行障。乐诽谤一切智语障。远离诸佛菩提障。乐住众魔境界障。不专修佛境界障。不决定发菩萨弘誓障。不乐与菩萨同住障。不求菩萨善根障。性多见疑障。心常愚闇障。不能行菩萨平等施故起不舍障。不能持如来戒故起破戒障。不能入堪忍门故起愚痴恼害瞋恚障。不能行菩萨大精进故起懈怠垢障。不能得诸三昧故起散乱障。不修治般若波罗蜜故起恶慧障。于处非处中无善巧障。于度众生中无方便障。于菩萨智能中不能观察障。于菩萨出离法中不能了知障。不成就菩萨十种广大眼故。眼如生盲障。耳不闻无碍法故口如哑羊障。不具相好故鼻根破坏障。不能辨了众生语言故成就舌根障。轻贱众生故成就身根障。心多狂乱故成就意根障。不持三种律仪故成就身业障。恒起四种过失故成就语业障。多生贪瞋邪见故成就意业障。贼心求法障。断绝菩萨境界障。于菩萨勇猛法中心生退怯障。于菩萨出离道中心生懒惰障。于菩萨智能光明门中心生止息障。于菩萨念力中心生劣弱障。于如来教法中不能住持障。于菩萨离生道不能亲近障。于菩萨无失坏道不能修习障。随顺二乘正位障。远离三世诸佛菩萨种性障。佛子。若菩萨。于诸菩萨。起一瞋心。则成就如是等百万障门。何以故。佛子。我不见有一法为大过恶。如诸菩萨。于余菩萨。起瞋心者。
    了知上述诸菩萨于余菩萨起瞋心的过患，真心修行佛道者必感惊心动魄。但我们也可能给自己寻找借口，即与我们讨论的对方不是菩萨，而是谤法者，甚至是魔。对此，《佛说首楞严三昧经》中有一相关开示。该经中，魔王以谄曲心而非真心发无上菩提心，如来亦为其授记，于将来世会出离魔道，成就菩提。对此授记，摩诃伽叶深有感触：
尔时长老摩诃伽叶。前白佛言。从今以后我等当于一切众生生世尊想。所以者何。我等无有如是智能。何等众生有菩萨根何等众生无菩萨根。世尊。我等不知如是事故。或于众生生轻慢心。则为自伤。佛言。善哉善哉。伽叶。快说此言。以是事故。我经中说。人则不应妄称量众生。所以者何。若妄称量于他众生。则为自伤。唯有如来。应量众生及与等者。以是因缘。若诸声闻及余菩萨。于诸众生应生佛想。
    伽叶长老与如来的上述对话告诫我们：只有如来才能真实了知众生是否为菩萨，我们没有如来智能，如果妄自称量众生根性，则为自伤。观察众生的原则只有一个──于诸众生应生佛想。
    嗔心的过患如此巨大，在下建议诸位网友在论坛上参加讨论时，时时不忘关照自心，这就是“正念”的修行。当观察到有嗔心生起的迹象时，立即思维诸佛菩萨对嗔心过患的开示，并祈请上师及诸佛菩萨加持自己战胜嗔魔，或关照此嗔心之虚妄及与诸佛慈悲心不二的平等体性，于此嗔心上现见如来之慈悲，则嗔心自息矣。
    嗔心是否生起，我们自己最清楚。那些大成就者，有时虽出语刚猛，其心不但不起嗔，而且充满慈悲。成就者所堪为者，我们这些初学者最好别贸然尝试。最稳妥的方法就是盯着自己的心，在无嗔的限度内参加讨论。
    如果大家都心平气和，则今日论坛上种种令人担心的现象就会自然平息。
    古慈兄，让我们先从自己做起吧。数年前，当我第一次读到《普贤行品》中的上述开示时，吓得出了一身冷汗。仔细想来，对一位菩萨生起嗔心是非常容易犯的过失。《宝积经》等经典中都清楚说明，只要生起愿菩提心者，纵使行门功德丝毫没有生起，此人亦是菩萨，其功德亦远超二乘圣者。今日论坛上的诸位网友大多知道菩提心的功德，生起愿菩提心者肯定不在少数，与我们讨论交流者十之八九皆为菩萨。如果我们不能克制自己的嗔心，则立时犯下大恶，百千万道障碍立刻在我们面前生起。纵使我们可以保证自己不起嗔心，亦应尽量用柔和语，以免惹得对方起嗔。对方起嗔造大恶业，一方面我们有连带因果，另一方面，为别人造恶业提供助缘，这与菩萨利益众生的根本愿望是背道而驰的，故我等不可不万分小心。
    据在下记忆，《普贤行品》中的开示以前在莲舟上曾出现过三次，但似乎并没有起到非常显著的作用。记得善慧曾有一贴，谈自己的体会，能否请善慧将此旧帖重新帖出，供诸兄参考。
    今后如果有必要，在下还将把《普贤行品》的内容一而再、再而三地引用，以提醒自己和诸位莫忘对菩萨生起嗔心的巨大过患。


染净四料简

    虚空友：
    对一些大成就者的示现，是否可以理解为，大成就者虽然实证染法净法皆无自性。但他们为了利益众生而行染法。
    因为无共业缘起，不能彼此显现，故为了不舍众生，行世间法，然证得业自性空，而广行如幻之度众等事，示现有共业众生前，为其应机说法，令其解脱，入得净土亦入得魔界，甚至五浊恶世，体现了佛经里的“无有一处空无佛”。

    智行：
    忙里偷闲说两句。圣者心净，则於一切境界中皆净，贪嗔痴诸染法他们可以用而无染，入生死亦是涅槃。可以这样来说：
    一、染、净一对：用于境界。
    二、有垢、无垢一对：用于心智

    此二搭配，可以分出四料简：
    一、有垢染：凡夫六道轮回。
    二、无垢染：圣人入种种染界（包括六道轮回）。
    三、无垢净：诸佛净土依正二报。
    四、有垢净：众生本具的如来智慧德相。“众生烦恼业海本是如来法身”一个意思。
    类似的说法愚初见於《大乘止观法门》，现将其归纳成以上四料简便於记忆。染、净、有垢、无垢只是名词，不一定要这样对应於心、境，只是为了便於理解，不妨这样安立，得义忘言可也！
    “有垢染”也可以扩大到二乘境界，因其法执之垢未尽，方便土也还不是究竟净故。“有垢净”是最难理解的部分，也是释迦告诉我们的最大的秘密，知道了就能知为何佛说“一切众生本来成佛”。有人闻后大哭，有人大笑，有人“悲欣交集”，总之佛恩难报特别在此体现。


菩萨摩诃萨的十种魔业和舍离之道

    菩萨摩诃萨的十种魔业和舍离之道

    zf

    《华严经》中之“忘失菩提心修诸善根是为魔业”广为古今大德所引用，各位想必耳熟能详。此一警戒乃《华严经离世间品》中普贤菩萨所开示之十种菩萨应防止的魔业之一。普贤菩萨同时还宣说了十种舍离魔业之道，特一并恭录于后，愿与诸兄常生警觉之心。
    普贤菩萨云：
    佛子。菩萨摩诃萨。有十种魔业。何等为十。
    所谓忘失菩提心。修诸善根是为魔业。
    恶心布施。嗔心持戒。舍恶性人。远懈怠者。轻慢乱意。讥嫌恶慧。是为魔业。
    于甚深法。心生悭吝。有堪化者。而不为说。若得财利。恭敬供养。虽非法器。而强为说。是为魔业。
    不乐听闻诸波罗蜜。假使闻说。而不修行。虽亦修行。多生懈怠。以懈怠故。志意狭劣。不求无上大菩提法。是为魔业。
    远善知识。近恶知识。乐求二乘。不乐受生。志尚涅槃离欲寂静。是为魔业。
    于菩萨所。起嗔恚心。恶眼视之。求其罪衅。说其过恶。断彼所有。财利供养。是为魔业。
    诽谤正法。不乐听闻。假使得闻。便生毁呰。见人说法。不生尊重。言自说是。余说悉非。是为魔业。
    乐学世论。巧术文词。开阐二乘。隐覆深法。或以妙义。授非其人。远离菩提。住于邪道。是为魔业。
    已得解脱。已安隐者。常乐亲近。而供养之。未得解脱。未安隐者。不肯亲近。亦不教化。是为魔业。
    增长我慢。无有恭敬。于诸众生。多行恼害。不求正法真实智慧。其心弊恶。难可开悟。是为魔业。
    是为十。菩萨摩诃萨。应速远离。勤求佛业。

    佛子。菩萨摩诃萨。有十种舍离魔业。何等为十。
    所谓近善知识。恭敬供养。舍离魔业。
    不自尊举。不自赞叹。舍离魔业。
    于佛深法。信解不谤。舍离魔业。
    未曾忘失一切智心。舍离魔业。
    勤修妙行。恒不放逸。舍离魔业。
    常求一切菩萨藏法。舍离魔业。
    恒演说法。心无疲倦。舍离魔业。
    归依十方一切诸佛。起救护想。舍离魔业。
    信受忆念。一切诸佛。神力加持。舍离魔业。
    与一切菩萨。同种善根。平等无二。舍离魔业。
    是为十。若诸菩萨。安住此法。则能出离一切魔道。

    （编按：这时有人问问题）：“未真实发起菩提心者，行此之十，是否是行魔业呢？”

    这要先说明“魔”义。
    《大智度论》中有：“问曰：何以名魔？答曰：夺慧命，坏道法功德善本，是故名为魔”。龙树菩萨又说：“除诸法实相，余残一切法，尽名为魔”。因此我们可以这样理解：从根本上讲，凡障碍我们成佛的一切都是魔。菩提心是成佛种子，只有在菩提心的摄持下，诸种修行才能成为无上菩提的助道因缘，因此若离菩提心便绝无成佛的可能，从这个角度说，“忘失菩提心修诸善根是为魔业”。
    未真实发起菩提心者，还未走上真正的解脱之路，还完全被“魔”掌所控制。
    如来为使众生逐步摆脱魔掌，设置了人天乘、声闻缘觉乘等化城，但如来利生的本怀是愿一切众生皆成佛道，是故若有众生贪着化城不肯出离，同样是为魔所制。
    《华严经出世间品》中，普贤菩萨告诫诸佛子，即使是已经发起了菩提心的菩萨，还时常会受到种种魔的障碍。普贤菩萨说：
    佛子。菩萨摩诃萨。有十种魔。何等为十。所谓蕴魔。生诸取故。烦恼魔。恒杂染故。业魔。能障碍故。心魔。起高慢故。死魔。舍生处故。天魔。自憍纵故。善根魔。恒执取故。三昧魔。久耽味故。善知识魔。起着心故。菩提法智魔。不愿舍离故。是为十。菩萨摩诃萨。应作方便。速求远离。
    其中这几种魔大家要格外小心：
    善根魔，恒执取故──以善根为实有而生执着之心，不能观照种种善根亦是缘起如幻。
    三昧魔，久耽味故──贪着禅定三昧之了，不思利生之广大悲愿，从而流入欲界。
    善知识魔，起着心故──不知善知识乃如来大智大悲的显现，以善知识为实有法而执着宛然。
    菩提法智魔，不愿舍离故──对种种修法方便心生贪着，不愿舍离。《金刚经》中之教诲不应忘记：如来说法如筏喻者，法尚应舍何况非法。
    对善知识魔，密乘弟子应特别留神。亲近上师（上师是善知识之一种）无疑是解脱的因缘，但如心生执着贪爱便成系缚。普贤菩萨的下列开示可视为对上师瑜伽真义的开显：
    佛子。菩萨摩诃萨。有十种善根回向。菩萨由此。能以一切善根。悉皆回向。何等为十。
    所谓以我善根。同善知识愿。如是成就。莫别成就。
    以我善根。同善知识心。如是成就。莫别成就。
    以我善根。同善知识行。如是成就。莫别成就。
    以我善根。同善知识善根。如是成就。莫别成就。
    以我善根。同善知识平等。如是成就。莫别成就。
    以我善根。同善知识念。如是成就。莫别成就。
    以我善根。同善知识清净。如是成就。莫别成就。
    以我善根。同善知识所住。如是成就。莫别成就。
    以我善根。同善知识成满。如是成就。莫别成就。（“成满”可能指善知识成满诸菩萨行愿之义。）
    以我善根。同善知识不坏。如是成就。莫别成就。（“不坏”可能指善知识之菩提心坚如金刚不可破坏之义。）
    是为十。若诸菩萨。安住此法。则得无上善根回向。

    （编按：这时网名“劣根”的网友问问题）：“转念又生一疑，祈善知识释之。《阿含经》里，佛陀示寂时，诸大弟子不堪忍受，有的甚至先于佛而入涅槃；阿难等弟子，惋转哀号，痛不欲生。难道这些已证果的罗汉也因对师父的贪执而悲伤？”

    莫疑，这里涉及到一个重要问题：是否悲伤只能由贪执所引起？断离贪执者是否就不会有悲伤了？答案恐怕是否定的。
    先看看佛典中“执着”一词的本意。
    执着，或简称“执”或“着”，是指由虚妄分别心认定实有我及法等，亦即将虚妄非实的人我及万法，执以为实有自性，执之着之，而起种种迷妄颠倒、虚伪不实之见解（详见佛学辞典）。
    可见执着的根本错误在于我法二执，对任何法，包括诸佛菩萨、上师和善知识的执着都是迷妄颠倒，与般若正见相违背，均须破除。
    破除对上师、善知识的执着，绝不是说我们对上师善知识不要恭敬供养皈依，何以故？缘起法无有自性，但有作用，善知识的作用就是引导我们走向解脱，我们只有尊重承事善知识才能真正获得法益。
    《华严经》中普贤菩萨开示了承事的十种心及其利益：
    佛子。若菩萨发无上菩提心。为悟入一切智智故。亲近供养善知识时。应起十种心。何等为十。所谓起给侍心。欢喜心。无违心。随顺心。无异求心。一向心。同善根心。同愿心。如来心。同圆满行心。是为十。佛子。若菩萨摩诃萨。起如是心。则得十种清净。何等为十。所谓深心清净。到于究竟无失坏故。色身清净。随其所宜。为示现故。音声清净。了达一切诸语言故。辩才清净。善说无边诸佛法故。智慧清净。舍离一切愚痴暗故。受生清净。具足菩萨。自在力故。眷属清净。成就过去同行众生。诸善根故。果报清净。除灭一切诸业障故。大愿清净。与诸菩萨。性无二故。诸行清净。以普贤乘。而出离故。是为十。
    另外关于悲伤，众生患得患失可能导致悲伤，诸佛菩萨出于大悲心，见众生执迷不悟同样会悲伤。
    《一切如来心秘密全身舍利宝箧印陀罗尼经》讲述了一段释迦牟尼佛与十方诸佛共同流泪悲戚的故事，十分感人。现将该经部分内容敬录如下：

    一切如来心秘密全身舍利宝箧印陀罗尼经

    特进试鸿胪卿大兴善寺三藏沙门大广智不空奉　诏译

    如是我闻。一时佛在摩伽陀国无垢园中宝光明池。与大菩萨及大声闻天龙药叉犍闼婆诃苏罗迦楼罗紧那罗摩睺罗伽人非人等无量百千。前后围绕。尔时众中有一大婆罗门名无垢妙光多闻聪慧人所乐见。常行十善归信三宝。善心殷重智慧微细。常恒欲令一切众生。圆满善利大富丰饶。时婆罗门无垢妙光从座而起。往诣佛所绕佛七匝。以众香华奉献世尊。无价妙衣璎珞珠鬘持覆佛上。顶礼双足却住一面作是请言。唯愿世尊与诸大众。明日晨朝至我宅中受我供养。尔时世尊默然许之。时婆罗门知佛受请。遽还所住。即于夜间广办肴膳百味饮食。洒扫殿宇张施幡盖。至明旦己与诸眷属。持众香华及诸伎乐。至如来所白言时至。愿垂降临。尔时世尊软语。安慰彼婆罗门无垢妙光。遍告大众宣言。汝等皆应往彼婆罗门家摄受供养。为欲令彼获大利故。于时世尊即从座起。才起座已。从佛身出种种光明。间错妙色照触十方。悉皆警觉然后趣道。时婆罗门以恭敬心持妙香华。与诸眷属及天龙八部释梵四王。先行治道奉引如来。尔时世尊前路不远。中至一园名曰丰财。于彼园中有古朽塔摧坏崩倒荆棘掩庭蔓草封户。瓦砾埋隐状若土堆。尔时世尊迳往塔所。于时塔上放大光明照耀炽盛。于土聚中出声赞言。善哉善哉释迦牟尼。今日所行极善境界。又婆罗门汝于今日获大善利。尔时世尊礼彼朽塔右绕三匝。脱身上衣用覆其上。泫然垂泪涕血交流。泣已微笑。当尔之时十方诸佛。皆同观视亦皆流泪。各所放光来照是塔。于时大众惊愕变色互欲决疑。尔时金刚手菩萨等亦皆流泪。威焰炽盛执杵旋转。往诣佛所白言世尊。此何因缘现是光相。何如来眼流泪如是。亦彼十方诸佛大瑞光相现前。唯愿如来于此大众解释我疑。时薄伽梵告金刚手。此大全身舍利积聚如来宝塔。一切如来无量俱胝心陀罗尼密印法要今在其中。金刚手有此法要在是中故。塔即变为重叠无隙如胡麻子。俱胝百千如来之身。当知亦是如胡麻子。百千俱胝如来全身舍利之聚。乃至八万四千法蕴亦在其中。九十九百千万俱胝如来顶相亦在其中。由是妙事是塔所在之处。有大神验殊胜威德。能满一切世间吉庆。尔时大众闻佛是说。远尘离垢断诸烦恼得法眼净。时众机异利益亦别须陀洹果斯陀含果阿那含果阿罗汉果辟支佛道。及菩萨道阿鞞跋致萨波若智。于如是事各得其一。或有证得初地二地乃至十地。或有满足六波罗蜜。其婆罗门远尘离垢得五神通。时金刚手见此奇特希有之事。白言世尊妙哉奇异。但闻此事尚获如是殊胜功德况闻深理至心起信得几功德。佛言谛听汝金刚手。后世若有信男信女及复我等四部弟子。发心书写此一经典。即准书写九十九百千万俱胝如来所说一切经典。即过于彼九十九百千万俱胝如来之前久植善根。即亦彼诸一切如来。加持护念犹如爱眼。亦如慈母爱护幼子。若人读诵此一卷经。即为读诵过去现在未来诸佛所说经典。由如是故。九十九百千万俱胝一切如来应正等觉。侧塞无隙犹如胡麻重叠赴来。昼夜现身加持其人。如是一切诸佛如来无数恒沙。前聚未去后群重来须臾推迁回转更赴。譬如细沙在水旋急。不得停滞回去复来。若有人以香华涂香华鬘衣服微妙严具供养此经。即成于彼十方九十九百千万俱胝如来之前。以天香华衣服严具七宝所成。积如须弥尽以供养。种植善根亦复如是。尔时天龙八部人非人等闻是说已。各怀希奇互相谓言。奇哉威德是朽土聚。如来神力所加持故有是神变。金刚手复白佛言。世尊何因缘故。是七宝塔现为土聚。佛告金刚手。此非土聚乃是殊妙大宝塔耳。由诸众生业果劣故隐蔽不现。由塔隐故如来全身非可毁坏。岂有如来金刚藏身而可坏哉。我若灭度后世末法逼迫之时。若有众生习行非法应堕地狱。不信三宝不植善根。为是因缘佛法当隐。然犹是塔坚固不灭。一切如来神力所持。无智众生惑障覆蔽。徒朽珍宝不知采用。以是事故我今流泪。彼诸如来亦皆流泪……


降魔的无上妙诀

    魔教教主：
    ……如果哪位博士生交出陈博士这种样的帖子当作业，立即罚抄《金刚经》一百遍，再革出师门，削去顶上方帽，打入大一好好补补基础课。（编按：系对一篇关于署名某博士的外道人士污蔑佛教的贴子的评论。）

    zf：
    “教主”真慈悲，对这样不争气且诽谤佛法的“博士”还要“罚”抄《金刚经》一百遍，用心良苦！
    抄此无上经典，名为惩罚，实乃喂药：为其将来走向解脱埋下种子。
    “教主”行于魔界，实为真实利益魔子魔女，想来一定与魔界行不污菩萨同门。

    聋猫：
    请各位帮忙。近来念佛总有魔障，不知道如何破解。

    zf：
    降魔的无上妙诀

    猫兄，这几句“口诀”被天台宗祖师视为降魔的无上妙诀：
    魔界如即是佛界如（zf注：“如”即真如。）
    魔界如佛界如不二不别
    我等不离是如
    魔界相即是佛界相
    魔界法佛界法不二不别
    我等于此法相不出不过（zf注：“此法相”指魔界法、魔界相。）
    魔界无有定法可示
    佛界亦无定法可示
    魔界佛界不二不别

    上述口诀亦是入“不二法门”之妙诀。只不过此口诀要用得起来，必须对“如”和“如的不二不别”有真切体验。
    无论如何，将此口诀放在心中，将来总会有大用。
    以此因缘，将此无上妙诀奉献坛上诸兄。

    口诀之出处──《佛说首楞严三昧经》

    海印：
    妙诀！另一个问题，修显教者，若持咒语、口诀或助念超度类事，是否应以心持为要，而依据具体情况不必过分执著形式呢？这样效果如何？比如上述口诀，若能明白其义，融于心念之中，在遇到魔相时，因明白道理而不动摇，是否可以算受持口诀呢？

    zf：
    形式是为目的服务的，执著形式，本末倒置。
    形式的起源可能是因为众人协作，若众人一起行事，没个规矩恐怕也不行。但根本上，修行之事在意不在形。

    将《首楞严经》中的开示冠以“降魔口诀”，乃在下哗众取宠之举。
    但实际上，佛经中的开示哪一句不是实修的“口诀”？《金刚经》《心经》是修持般若波罗密多的口诀，《普贤行愿品》是修习普贤行的口诀。
    若将上述口诀，明白其义、融于心中、遇魔相时、心不动摇，这样还不算受持口诀的话，我真想像不出真正受持口诀应该是什么样子！

    智行：
    在下手头有个共修课本就有这句话，麻烦的是，诵的人大多惊讶不知其中所云，解释起来很费力，呵呵。

    zf：
    天台智者大师的相关开示

    释禅波罗蜜次第法门

    隋天台智者大师说

    三明破魔法者。当用三法除却魔罪。一者了知所见闻觉知皆无所有。不受不着。亦不忧戚。亦不分别。彼即不现。二者但反观能见闻觉知之心。不见生处。何所恼乱。如是观时。不受不分别。便自谢灭。三者若作此观。不即去者。但当正念。勿生惧想。不着躯命。正心不动知魔界如即是佛界如。魔界如佛界如一如无二如。于魔界无所舍。于佛界无所取。即佛法现前。魔自退散。既不见去来。亦不忧喜。尔时岂为魔所恼。复次亦未曾见有人坐中。见魔作虎来剩食此人。骨肉狼藉。正是怖人。令心惊畏耳。都无实事。当知虚诳。如是知已。心不惊怖。复作是念。设令是实。我今身命为道故死。何足可惧。今我此身随汝分别。心如金刚。不可回转。如是或一月二月。乃至经年不去。亦当端心正念坚固莫怀忧惧。当诵大乘方等诸治魔咒。默念诵之。存心三宝。若出禅定。亦当诵咒自防忏悔惭悚。及诵波罗提木叉戒。邪不干正。久久自灭。事理除魔。其法众多。非可备说。行者善须识之。方便除灭故。初心行人。欲学坐时。必须亲近善知识者。为有如此等难。是魔入人心时。能令行人证诸禅定三昧智慧神通陀罗尼。何况不能作此小小境界。若欲知之。诸大乘经。及九十六种道经中。亦少分分别。今略说此。为令行者深知此意。则不妄受诸境。取要言之。若欲遣邪归正。当观诸法实相。是故摩诃衍论云。除诸法实相。其余一切皆是魔事。

    释摩诃般若波罗蜜经觉意三昧

    隋天台智者大师说

    首楞严经云。魔界如即是佛界如。魔界如佛界如。一如无二。如是故不出魔界而得佛界。当知观空即度他化天子魔。菩萨行三空正观。即时不复恐怖四魔。亦不得四魔而能度四魔。故释论云。除诸法实相。其余一切皆名魔事。若能善修实相即无魔事。是故行者善观此意修行三昧。终无魔事。若离此观分别忆想必定堕魔网中。故释论云。若分别忆想即是魔罗网。不动不分别是则名法印。复次行者能善修如上三观。破一切法心无所著。虽知众生空相而常念大悲。不舍一切众生。学诸波罗蜜起十力。观察法界种种法门。长养一切诸善功德。

    savelife：
    请教您是如何体会和实践“我等于此法相不出不过”的？并请您谈谈您引用的这个口诀和菩提心的关系。

    zf：
    琉璃兄、Save兄请进，“口诀”最初出自一群魔女之口，未读过《佛说首楞严三昧经》的同修闻此可能吓一跳。当然这些魔女已被佛菩萨度化，生起无上菩提心，虽现魔女身，实为菩萨。
    通常行人对魔界和佛界的态度是破除魔界去证取佛界。此时若无正见，容易堕在有魔界这一实法可破，有佛界这一实法可取的邪见之中。“口诀”之中明示：“魔界无有定法可示，佛界亦无定法可示”，由此去除行人的“得失”见。进一步，“魔界如即是佛界如，魔界如佛界如不二不别”，正因为真如的这种不可分别性，法界之实相恰恰是“魔界相即是佛界相，魔界法佛界法不二不别”。正因为魔界佛界不二不别这一属性，修行之时如果魔界现前，行者完全不须破除魔界之法相（“我等于此法相不出不过”之意），而应用心体会魔界佛界的不二性，于魔界上现见佛界。
    如何于魔界上现见佛界？修净土者当深信，弥陀之名号具足如来之万德，因此如来名号即是佛界；持咒者应知，如来真言即是如来即是佛界。法界实相之中，魔界必与佛界同在，因此见魔界的当下即是闻佛名号闻佛真言，即是亲见如来之三十二相。
    认识到魔界佛界之完全平等性后，菩萨唯愿心中佛界常显、魔界常隐。佛界常显方能利益无量众生故──这就是菩提心。
    在下上述见解多是纸上谈兵。点滴心得愿与诸兄分享，不当之处敬请指正。

    翁阿轰：
    用心体会魔界佛界的不二性，于魔界上现见佛界！学生对这句的理解是：佛、魔都是为度生而做的方便说，其实都是假名。有比量的方便是进入无比量的实相的阶梯，去除佛魔对立，认知不二才是驱除魔境的根本。所以，有佛有魔的时候就是魔境！而魔境即与佛境不二，那就没啥可驱除的。没啥屁事啦！……却不无。还要“菩萨唯愿心中佛界常显、魔界常隐。”是为慈悲。明了真如不二后，还要有所谓“慈眼视众生”，才不离慈悲本怀。

    zf：
    体性平等，利用不同。空慧若不为无上菩提而修，不名般若波罗密多。而菩萨成就菩提的目的是利益众生。莫忘普贤行愿品中之“诸佛如来以大悲心而为体故”。

    zf：
    翁兄，将“降魔口诀”改动一字，成为……

    三界如即是佛界如
    三界如佛界如不二不别
    我等不离是如
    三界相即是佛界相
    三界法佛界法不二不别
    我等于此法相不出不过
    三界无有定法可示
    佛界亦无定法可示
    三界佛界不二不别

    依在下浅见，维摩诘居士即是实践上述“口诀”的典范。

    古慈：
    因拜读谈先生文－后学近来也在再度读此经，后学感觉－问疾品──启发很大。

    zf：
    请进，《首楞严三昧经》中有一位菩萨叫“魔界行不污”，此菩萨的行相与维摩诘有类似之处。藏地宁玛派将维摩诘称为大圆满祖师，汉地禅宗把维摩诘视为禅师典范，可见禅宗与大圆满确有甚深因缘。

    附录一：
    《首楞严三昧经》相关章节选录

    后秦龟兹国三藏鸠摩罗什译

    尔时会中有一菩萨名魔界行不污。白佛言。唯然世尊。我今当现于魔界中。以自在神力令魔得住首楞严三昧。佛言随意。时魔界行不污菩萨。即于会中忽然不现。现于魔宫语恶魔言。汝宁不闻佛说首楞严三昧。无量众生皆发阿耨多罗三藐三菩提心出汝境界。亦皆当复度脱余人出汝境界。魔即报言。我闻佛说首楞严三昧名字。以被五缚不能得往。所谓两手两足及头。又问恶魔。谁系汝者。魔即答言。我适发心欲往坏乱听受首楞严三昧者。即被五缚。我适复念。诸佛菩萨有大威德难可坏乱。我若往者或当自坏。不如自住于此宫殿。作是念已。即于五缚而得解脱。菩萨答言。如是一切凡夫忆想分别。颠倒取相是故有缚。动念戏论是故有缚。见闻觉知是故有缚。此中实无缚者解者。所以者何。诸法无缚本解脱故。诸法无解本无缚故。常解脱相无有愚痴。如来以此法门说法。若有众生得知此义。欲求解脱勤心精进。则于诸缚而得解脱。时魔众中七百天女。以天香华末香涂香及诸璎珞。散魔界行不污菩萨。而作是言。我当何时于魔境界而得解脱。菩萨报言。汝等若能不坏魔缚。则得解脱。云何名为魔缚。谓六十二见。若人不坏此诸见者。即于魔缚而得解脱。天女复言。云何名为不坏诸见而得解脱。答言。诸见本无所从来去无所至。若知诸见无去来相。即于魔缚而得解脱。诸见非有非无。若不分别有无。即于魔缚而得解脱。若无所见是为正见。如是正见无正无邪。若法无正无邪。无作无受。即于魔缚而得解脱。是诸见者。非内非外亦非中间。如是诸见亦复不念则于魔缚而得解脱。七百天女。闻说此法即得顺忍。而作是言。我等亦当于魔界中行无所污。度脱一切魔所缚者。尔时魔界行不污菩萨。语恶魔言。汝诸眷属已发阿耨多罗三藐三菩提心。汝作何等。恶魔答言。我被五缚不知所作。菩萨答言。汝发阿耨多罗三藐三菩提心。当从此缚而得解脱。时诸天女慈愍魔故。皆作是言。可发阿耨多罗三藐三菩提心。勿于安隐生怖畏想。勿于乐中而生苦想。勿于解脱而生缚想。尔时恶魔生谄曲心。而作是言。若汝舍离菩提心者。我当发心。时诸天女以方便力。而谓魔言。我等皆已舍离此心。汝便可发阿耨多罗三藐三菩提心。若一菩萨发菩提心。一切菩萨亦同是心。所以者何。心无差别。于诸众生心皆平等。尔时恶魔。谓魔界行不污菩萨言。我今当发阿耨多罗三藐三菩提心。以是善根令我缚解。说此言已。即自见身从缚得解。时魔界行不污菩萨。以神通力放大光明。现净妙身照于魔宫。魔自见身无有威光犹如墨聚。时魔众中二百天女深着淫欲。见此菩萨身色端正起染爱心。各作是言。是人若能与我从事。我等皆当随顺其教。时此菩萨知诸天女宿缘应度即时化作二百天子。色貌端严如身无异。又作二百宝交露台胜魔宫观。是诸天女皆自见身在此宝台。各各自谓。与此菩萨共相娱乐。所愿得满淫欲意息。皆生深心爱敬菩萨。菩萨即时随其所应而为说法。皆发阿耨多罗三藐三菩提心。时魔界行不污菩萨。谓恶魔言。汝可诣佛。魔作是念。我缚已解。当诣佛所坏乱说法。尔时恶魔眷属围绕行诣佛所白言。世尊。勿复说是首楞严三昧。所以者何。说是三昧。我身即时被五系缚。唯愿如来更说余事。时坚意菩萨。谓恶魔言。谁解汝缚。答言。魔界行不污菩萨。解我系缚。汝许何事而得解缚。魔言。我许发阿耨多罗三藐三菩提心。
    尔时佛告坚意菩萨。今是恶魔。为解缚故发菩提心非清净意。如是坚意。我灭度后后五百岁多有比丘。为利养故发菩提心非清净意。坚意。汝观首楞严三昧势力佛法威神。是诸比丘比丘尼优婆塞优婆夷。以轻戏心贪利养心随逐他心。闻是三昧而发菩提心。我皆知此心与阿耨多罗三藐三菩提。得作因缘。何况闻是首楞严三昧。能以净心发阿耨多罗三藐三菩提。当知此人于佛法中已得毕定。坚意菩萨白佛言。世尊。今此恶魔闻说首楞严三昧。为解缚故发菩提心。亦得具足佛法因缘耶。佛言。如汝所说。恶魔以是三昧福德因缘及发菩提心因缘故。于未来世。得舍一切魔事魔行魔谄曲心魔衰恼事。从今已后。渐渐当得首楞严三昧力。成就佛道。坚意菩萨。谓恶魔言。如来今已与汝授记。魔言。善男子。我今不以清净心发阿耨多罗三藐三菩提。如来何故与我授记。如佛言曰。从心有业从业有报。我自无心求菩提道。如来何故与我授记。时佛欲断众会疑故。告坚意言。菩萨授记凡有四种。何谓为四。有未发心而与授记。有适发心而与授记。有密授记。有得无生法忍现前授记。是谓为四。唯有如来能知此事。一切声闻辟支佛所不能知。坚意。云何名为有未发心而与授记。或有众生往来五道。若在地狱若在畜生若在饿鬼。若在天上若在人间。诸根猛利好乐大法。佛知是人过此若干百千万亿阿僧祇劫。当发阿耨多罗三藐三菩提心。又于若干百千万亿阿僧祇劫。行菩萨道。供养若干百千万亿那由他佛。教化若干百千万亿无量众生。令住菩提。又过若干百千万亿阿僧祇劫。当得阿耨多罗三藐三菩提。号字如是。国土如是。声闻众数寿命如是。灭后法住岁数如是。佛告坚意。如来悉能了知此事复过于是。是名未发心而与授记。

    附录二：
    新角度看维摩诘

    无畏金刚（Dorje Jigdral，谈锡永）在《印度密乘源流考略》一文中认为，维摩诘乃大圆满法的人间祖师。现将该文中的部分内容摘录如下。

    印度密乘源流考略　节选

    谈锡永

    在密乘起源这问题上，格鲁派的说法有点含糊，宗喀巴大士的《密咒道次第广论》，其弟子克主杰的《密宗道次第论》都不对这问题有具体意见。
    至于《时轮续》，则谓系于释尊成道后第一年之三月十四日，释尊现比丘身说《般若十万颂》，又于南印现身说《时轮续》，其后，此续传于金刚手化身之月贤王（Suchandra），有一万二千颂。月贤是北印香拔拉的国王。
    但宁玛派的说法则与此不同。在此应知，宁玛派的说法，应该即是印度诸师的传统说法，如敦珠宁波车的《宁玛派教法史》说，密续的来源有三： 　　第一，为普贤王如来在色究竟天，示现为金刚持相，为五方佛及其眷属所说。
    第二，其后，文殊师利菩萨化身为金刚锐（Tiksnavajra），向天人说密法；观自在菩萨化现为甘露药王（Amrtabhaisajya），向龙王说密法；金刚手化现为愤怒尊身，向药叉众说密法。
    此外，关于大圆满法系，则以诸佛加持力，由金刚萨埵（即金刚心）传于帝释天王子最胜心。
    第三，佛灭度后二十八年，天、龙、药叉、罗刹、人等五大持明，将密法向人间传播。关于此五持明之名，汉文译文如下（《西藏古代佛教史》，刘锐之译）：天之持明渣鼎初忠、龙王持明王左波、药叉持明星箭面、罗刹持明罗爵他丁，与人之持明赖渣啤……。
    然而这五个名字的翻译，实际上有问题，近年来敦珠宁波车的《宁玛派教法史》已有英译本，对比英译，此五大持明实际该是：天人持明耶舍持护天（Yasvi Varapala）、龙族持明现毒龙王（Taksaka）、药叉持明焰口药叉（Ulkamukha）、罗刹持明黑齿罗刹母（Matyaupayika）、人持明离车族维摩诘（Vimalakirti，The Licchvi）。
    如此翻译这些名字，才能够跟佛经中原有的译名对得上，如若不然，便很容易认为这五大持明在佛经中不见经传。也许正因为这层关系，所以该书的汉译本出版已近二十年，却未见有学者提及宁玛派的说法，这也很难怪，名字太陌生，学者便不加重视，而且会认为无可稽考。
    说维摩诘是传播密法的人持明，除了敦珠宁波车之外，其他宁玛派学者的英文著述亦有提到（如《Buddha Mind》，Tulku Thondup Rinpoche著，Snowlion出版），因此这说法就特别值得注意。而且《维摩诘经》在西藏并不流行，因此提出维摩诘为密续持明，不应该是西藏诸师的创见，相信必为印度密乘的旧说，随密法一同进入西藏。宁玛派一向保存旧说，如今便成为独家的说法。

    至于维摩诘的行持，经说：
    ［虽为白衣］，奉持沙门清净律行。
    ［虽处家居］，不著三界。
    ［示有妻子］，常修梵行。
    ……
    ［入诸淫舍］，示欲之过。
    ［入诸酒肆］，能立其志。

    我们故意将部分经文用方括号括起来，如果将这些文字联系起来，那么，维摩诘所示现的行相，便是有妻子、服宝饰、好饮食、赌钱、入欢乐场所、研究外道学问、到处闲逛的白衣居士。
    如此行相，连一般学佛的人都不似，但他却是大成就者。这除了用密乘修持来解释之外，很难用别的修持法门来解释。因为密乘大圆满的修持，即是不离世俗生活，如实生活。对一切烦恼的境相，视之如同水面作画，随作随散，于是烦恼自然消融于法界本体，是亦不为烦恼所动。
    换言之，修持大圆满的特色，即是过着贪嗔痴的世俗生活，而从贪嗔痴修离贪、离嗔、离痴。这正如维摩诘在《弟子品》中教训须菩提：“不断淫怒痴，亦不与俱。”所谓“不断”，即是不逃避这种世俗生活；所谓“亦不与俱”，便是离贪嗔痴等。不断不俱，是即中道。能行中道，即是不动。
    一般人对这种修行的方式，未必了解。所以在《弟子品》中，当富楼那在树林中为诸新学比丘说法时，维摩诘便教训富楼那说：“欲行大道，莫示小径”，并不是世间一切根器都要由小径入道，除小径外，当有“大道”在。如果对适宜由“大道”入的人示之“小径”，那便是“以秽食置于宝器”，“彼自无疮，勿伤之也”。
    在这里维摩诘所说的“小径”，未必专指小乘，所谓“大道”，亦未必通指大乘。经文虽如是说，实则或意有别指。因为在《菩萨品》中，维摩诘亦一一指责大乘菩萨。
    他教训弥勒菩萨：“若弥勒得受记者，一切众生亦应受记；若弥勒得阿耨多罗三藐三菩提者，一切众生皆亦应得；若弥勒得灭度者，一切众生亦当灭度。”换言之，若弥勒应成佛，则一切众生亦应成佛。这便是如来藏思想。是故即知，维摩诘所说的“大道”即此，即大圆满道，非其余大乘法门。
    引用经文至此，笔者觉得，若说维摩诘是密乘大圆满的行者，已不算穿凿附会。宁玛派说他是“人持明”，为密乘祖师，所依当系印度密乘旧说，而旧说亦必有据。


“放下屠刀立地成佛”之因是放下

    凡夫：
    大心量人奋勇斗敌，以一当万，万念俱息。小心量人怎么办？不管，万般染污翻腾不管它，我自管发我的一念清净心。

    笨鸟：
    有没有这样一种可能，您说的嘎然而止是向清净的通途。
    还有没有其他的通途？
    比如把烦恼心推向极至，
    物极必反时立地成佛。

    zf：
    您这种成佛之道的设想，本人以前没听到过。
    把烦恼心推向极致的后果只能是无间地狱。
    而走向解脱乃至成佛的起点，只能是“烦恼无尽誓愿断”的愿力。
    在此大愿的摄持下，依般若之慧力可彻见烦恼即菩提。
    但此时烦恼与菩提之无二，绝非烦恼物极必反的自然结果。
    “放下屠刀立地成佛”之因是放下，而不是屠杀。

    月黑鬼车来：
    笨鸟的意思不妨理解为──贪至极处令明点不漏，嗔至极处令拙火升腾，痴至极处令睡光显现，慢至极处令佛慢坚固，疑至极处令虚空粉碎。

    二麻子：
    这是白月黑月？
    “贪至极处令明点不漏，嗔至极处令拙火升腾，痴至极处令睡光显现，慢至极处令佛慢坚固，疑至极处令虚空粉碎。”
    ──如此这般当然大好。这些行为过程里，毫无损恼众生行为，与笨鸟说的那些不大是一回事吧，黑月老兄是真没看出这个差别来？


知恩不报非君子也！

    知恩不报非君子也！

    zf

    在下完全支持各位对教理的平等讨论。交流心得对我等树立正见、少走弯路有大好处。但读了师兄上文后，心里有种沉重的感觉，不吐不快，供兄参考。
    “…某君知道我看《首楞严经》，可生气了，说我是“不求大法求小法”，而且心不诚，老是自作聪明……从此再也不对我说什么了。…”
    ──在兄清醒认识到“禅宗居士某”之见行中存在种种不如法的同时，兄是否同样清醒地认识到某居士对您的恩德？依在下浅见，某居士至少在下面几方面对您有大恩德：
    一、引导您进入佛门
    此乃诸恩之中恩德最大者。
    “…引导我走入佛门的是一位由练气功转入佛门的禅宗居士某。第一次正面接触，我就为其知识之渊博、言语之深刻所折服。他似乎什么都懂！……如此种种，使得我深为叹服！俯首帖耳，视之如师。…”
    ──我等众生无始以来流落六道。据顶果仁波切之开示（大意），我们仅投生为昆虫时留下的尸骨若堆积起来就要超过须弥山、投生为人道时因痛苦所流之泪水聚集起来要超过大海。而今以善知识引导为因缘，我等进入佛门，从此走向解脱，永不再受轮回之苦，引导我们进入佛门之人的恩德何其大也！

    二、劝君受持《六祖坛经》和《金刚经》
    “…我虔诚地向他请教佛法的修行次第和入手法门。得到一部《六祖坛经》，一部《金刚经》和一部……”
    ──受持金刚经等经功德无量无边，胜过以恒河沙等身布施，而引导您读经之人，是这一切功德的源泉。您今日明辨是非能力的提高，与受持金刚等经所集功德有甚深因缘。此某居士对您的大恩之二。

    三、为您开示大乘普度众生之法
    “…按大乘心法普度众生……自然地把对方导向正确的方向，这叫方便随顺众生。为此要做到“恒顺众生”，他喜欢什么你就跟他说什么…”
    ──某居士为君开示之“恒顺众生”乃普贤行及一切菩萨修行之总纲。大乘道乃自利利他的根本道，是成佛的根本。为我等开示大乘道者，哪怕只有一句，对我等的恩德都是无以报答的。
    《解脱掌中论》中，帕绷喀大师曾开示（大意）：在饥荒年间，当我们快饿死时，给我们一点发霉变质食物人的恩德远超过在丰收年月给我们精美大餐者。
    发菩提心的方便之一便是从知恩、念恩、报恩开始。愿我等念念不忘对自己有大恩德者，早日获得无量智慧、无量方便，以回报一切有恩之众生。未忘古训──知恩不报非君子也！


打坐修持与实践中观

    朗然：
    请教善知识：打坐可能引起……连续多日的头晕吗？　或者如果这种情况需要停止打坐么？

    zf：
    可能。在下就有过这方面的经历，原因多半是精神长时间过于集中于头部。如果确实是打坐引起的话，建议先停止打坐数日。待不适消除后，再调整用心。打坐最好有老师指导。

    小德：
    zf叔是否真的……俺只想问问，zf叔是否真能“精神长时间过于集中”，俺打坐时只有腰酸背痛，心可是天南海北，没法长时间集中，zf有何绝招？俺只是但求一痛呀。

    zf：
    德兄，在下所指“长时间注意力集中”是指：打坐时要观想某种形象或声音时。初学者当然不可能无杂念地进行这种观想，间杂着杂念的观想同样可能带来头昏的后果。
    如果不是有老师指点修持某种特殊的观想法，《楞严经》中“大势至念佛圆通章”中所开示的都摄六根、净念相续的念佛法门确是安全有效的修持法。
    这里要注意，“念佛法门”不仅仅是“念佛号法门”。念佛号是念佛，念佛真言是念佛，念如来及菩萨行愿是念佛，念经是念佛，修持般若同样是念佛。
    念佛时有杂念是正常的。能发现有杂念就是很大的进步(没修以前，杂念一点不少而不自知，如家中养贼而不识)，发现杂念后只要将其转为念佛之念就是了。禅宗中的“牧牛”说十分形象。
    将野牛驯服并不是件轻而易举的事，要讲究方法，还要耐心。

    小德：
    谢了再谢，但……叔的指导和鼓励晚辈定会常记在心。叔所说的观想需要主观去调度，这样是否偏离中观？

    zf：
    别担心，依在下的理解，简单地说，中观要求远离断常两边。诸法自性空而非毕竟无──是则远离断边；诸法缘起有而非自性有──是则远离常边。无上菩提依菩提心及菩萨行愿为因而生起，是故依菩提道去“主观调度”不但不堕断常两边，而恰恰在实践中观。
    关于前进的“方向”和“动力”，在下多说两句：
    方向──无上菩提；
    动力──为利有情誓证无上菩提之坚如金刚、无坚不摧的愿力──即菩提心。
    另，小草永远长不成大树。德兄当常思作大树。


鼓励把止修出来

    锦书：
    我个人的心得，减少食欲对知见的进步是有帮助的，所以虽然人在工作我仍然认为过午不食是一种生活方式，饮食习惯，不算什么苦行！但是很多人视其为苦行，而不愿去尝试，实在可惜！习惯饱食者，对身体会有粗重的感觉，对佛法之体会会有障碍！减少食欲者，较不受身体粗重的影响，有助于清明身心，体会佛法！各位可尝试看看！

    二麻子：
    有效果了。不过如果把止（奢摩它）修出来，基础效果比这要大得多。修到轻安的话，效果远非过午不食或其他节食能比。修到轻安并非什么大难事。

    台湾佛教网路论坛


真的学静虑，建议从止开始

    大千：
    真学佛的佛友中，很多人都在真修静虑吧，因为戒定慧是学佛的基本课程，只是水平高低不同罢了。开始修定之前应该先看有关经论，树立正见指导修定，比如《童蒙止观》、妙老讲解的《瑜伽师地论·修所成地》等都是很好的入门教材。依据经论修学深入之时，当然最好是有过来人可以请教咨询，唯识不是密法，大家肯定也欢迎修习止观方面的讨论。

    二麻子：
    发掘唯识宗正宗的禅修方法。这几乎就是发愿要恢复瑜伽行派的修持吗，麻子随喜不迭。其他的禅修方法当然从原则上都不会违背唯识，但瑜伽行派的修法说起来才真是唯识派的不共修法。可是，现在到哪里去找？其他的，若想要真的学静虑，建议从止开始。这个基础打好的话，修别的都容易见效。反之则很不容易见效。


打座程序的安排

    打座程序的安排

    二麻子

    一、临睡打坐可能影响睡眠。可以改为早上打。
    二、你打坐的程序大致合理，只在结束前缺一个回向。即，应将修行一切功德回向一切众生解脱。


对念头做不了主一定没离昏沉散乱

    zzzm：
    问一下，只要对念头做不了主：或提不起，或止不住，大致都算是没离昏沉和散乱。是吗？后学一定努力……

    二麻子：
    是，这个是一定没离昏沉散乱……即使能对粗妄想做主，也未必真的离开了细的昏沉跟散乱呢……


单凭慧力用心的人，容易不平衡

    xixi：
    嘻嘻，所以说灵魂出窍是不出意识的妄想。我还梦见过无腿的天女散花呢，能说明个啥？

    那不过是工作得太累，累得都自控不住，在神志不清下睡着，大脑突然得到休息的一种错觉。对这些幻觉的喜好，正是着魔。呵呵，问你一句，“人死如灯灭”是断灭见吗？六祖坛经对“诸行无常是生灭法，生灭灭以，寂灭为乐”的问答。若以为离生灭求寂灭而得乐，那才是痴人梦想。呵呵，百丈拨火炉问有火的公案如何？那就是轮回的公案。

    当时是累的一塌糊涂，想闭眼休息一下。然后就是一种很安逸的感觉，眼前出现许多漩涡，飞速的旋转，然后出现一片很灿烂很亮的青蓝像草地又像大海一样场面，接着感觉心口疼，但疼却是舒畅甘美的，那些所谓的天女就出现了。我当时并非睡着，有清醒的意识中觉得是心律不齐，有间歇性心跳停止的现象，这是心口疼痛的原因。但这是我第一次感到痛的同时是舒畅的不同感觉。完全清醒过来后虚汗淋漓，医生说是疲劳过渡。如果我当时是沉迷于那种感觉，必死无疑。呵呵，还是注意劳逸结合吧。这是我后来觉得金刚经：一切法如幻如电，说得对极。你所谓的记忆起前生的幻觉，一样是当前一念而已，并非你的真有个前生。至于天女的幻觉，正是我大学时对大足石刻画册很热衷的印象。

    二麻子：
    嘻嘻，臭xixi看进来……这是心轮被动到了，其他的脉轮没能相应发展，造成不平衡……单凭慧力用心的人，容易发生这现象。按次第修的人，就不大会这样。所以，还得注意些呢……


生起大精进心对治昏沉

    生起大精进心对治昏沉

    zf

    关于对治昏沉，“念咒时很昏沉，且想打哈欠，心很无力，怎么提都提不起，怎么办？”再说几句。
    能产生昏沉的原因很多。如果是因为工作导致身心疲惫，那么最好的方式就是先休息，待精力恢复后再打坐修持。对我们这样的“业余”修行者来说，并不是任何时候都可能在座上保持内心清明的。
    如果导致昏沉的原因不是由疲劳引起，那么对治的方法除了在技术上注意外（如将“心”放在身体胸部以上的部位，或观想光明等），更重要的是要生起大精进心。
    天台智者大师在《小止观》中简明扼要地开示了修习止观的种种注意事项。在“弃盖第三”部分中，下列开示与对治昏沉有关：
    三、弃说眠盖。内心昏暗为睡；五情暗蔽，放恣支节，委卧睡熟为眠。
    以是因缘，名为睡眠盖，能破今世后世实乐法心，
    及后世生天及涅槃乐。如是恶法，最为不善。
    何以故？诸余盖情，觉故可除；睡眠如死，无所觉识，
    以不觉故，难可除灭。
    如佛诸菩萨呵睡眠弟子偈曰∶
    “汝起勿抱臭尸卧，种种不净假名人，
    如得重病箭入体，诸苦痛集安可眠！
    如人被缚将去杀，灾害垂至安可眠！
    结贼不灭害未除，如其毒蛇同室居，
    亦如临阵两刃间，尔时云何安可眠！
    眠为大暗无所见，日日欺狂夺人明，
    以眠覆心无所见，如是大失安可眠！”
    如是等种种因缘，诃睡眠盖，警觉无常，减损睡眠，令无昏覆。
    若昏睡心重，当用禅镇杖却之。


打坐心中烦闷怎么办？

    F117：
    我早上起床打坐念弥陀心咒，很快能进入状态，但30分钟来往就觉得心中烦闷，难受至极，祈祷本尊加持也只能安定一小会，此时应该怎么办呢？

    zf：
    对待这种事，通常有两种方法：
    一、抱定拼死一搏的决心，作临终想，保持正念。一旦闯关过去，以后的路就好走了。
    二、每次在烦闷前就下坐，保持余兴。如果时间来得及，活动一下身体后再上座。通过这种方式逐渐加长每次座上的时间。
    另外，从根本上讲，任何障碍都是业障的显现，应真心忏悔。
    吉祥如意。


近期好迷糊不知如何了！

    安心：
    我一师兄近期好迷糊，有时走路都分不清东西南北（偶尔），有时前念还没提起，后念更不知如何了！

    二麻子：
    这是用功时，心没怎么用准，力气却花得过大点造成的一种现象。短时间如此没问题。长时间如此是领他修的人不得法。嘿嘿。关键时刻踢一脚就好了。


打坐时身体有动作的对治

    朗然：
    另：日前读讲打坐的事情，建议如果有身体动作就睁开眼睛，使之消失，以免养成习惯；后学有动作已经几个月了，不知是继续闭着眼睛坐下去，还是睁开眼睛让它消失……当初闭目打坐，主要是因为终日在电脑上工作，眼睛非常疲倦的缘故……

    二麻子：
    睁开让它消失……消失以后可以再闭。其实，不睁眼也能让它消失。你不让它动，心里对抗一下就消失了。


为何打坐到一定时候会灯光一闪

    世界法身中：
    为何晚上打坐到一定时候会觉得周围有灯光一闪，睁开眼，灯并未开，不知为何，昨天打坐，连闪了三次。

    二麻子：
    这也还要再分别一下……要看那“闪光”感觉上有多亮。象闪电，那是坐到心念将断，并且昏沉不很厉害时的标准现象。但这一闪常会把人心念又激励起来。如果昏沉再多点，就不知道这一闪了。
    像一般灯或天空那么亮，那是极其普通现象，只说明坐的心比较平静些了。

    keke：
    有时候精神好打坐的时候，有一种很清晰的感觉，但是又和一般的清楚不大一样，不过又时间一长，往往会被昏沉覆盖，是不是一种细昏沉？

    二麻子：
    是昏沉。而且……作为长远劫来的串习，我们凡夫的昏沉不控制是会增长的。


方式有三，不劳不得

    常如：
    请教一个难题，最近读百法门论，对种种心所纠缠交织，于五蕴中流转不息的情形，平日虽略能观之，使烦恼稍伏；遇事则抵不住，平日知见无用力处，人生之苦，何至于斯。读克勤参法演案，不禁长叹：确是非至究竟，则无以解脱。前些日，麻老有无所用心一句，我以为不是无心，不是无所，乃在无用。可是如何无用？心“用”无处不在，有心便有用在。对这个用字，真是无可奈何啊。这个问题若需自己想去，不劳跟帖；若有个下手处，还请给个指示，谢谢。

    二麻子：
    嘻嘻，方式有三，不劳不得……
    常兄善哉此问。麻子没有个简单的下手处。但大路数有三，都是依佛陀教导的方向走。
    一、就这样慢慢学慢慢磨，磨到习气全转了，自然没问题了。
    此法成就时就是彻底成就。只是慢点，得用些劫数时间。
    二、正见草成后，依见修定，定里磨见（剑？），如此可相当迅速地见到效果（自伏粗烦恼开始）。但这个要求下的力气比较大。
    行人要比较猛利才好。
    三、只在思维上做到。这个更快，也有效，但有限。可看到烦恼减少，却无力对治强烦恼。
    若依常兄贴里的问法，是应该学三主要道加禅定。


禅坐略评

    禅坐略评

    二麻子

    嘻嘻。麻子回你这几个问题，声明，麻子回答的只限于纯技术层面。

    “忌贪坐，一时高兴多坐，以后易退转，以每天一座，最多二座，每座一至二小时为宜。”
    ──这是对的。但不是绝对的。退转的确实有。但麻子的佛友里，有一天打七座，然后七天打一座的。这人好像修得也不坏。嘻嘻。更多的是坚持每天固定时间的。似乎也很好。

    “忌大声持诵，免伤气，要金刚持（唇动无声，自己听见）。”
    ──坐上如果大声持颂，能坚持多久？行不通的。是不是一定要金刚持，麻子看法是要看行人的具体情况。默持也是很好的。金刚持有方便处，也有不方便处。

    “忌身体多动，多动必致腰疼，伸腰要慢，身体不必过于正直。”
    ──确实忌多动，一般学人身动心也必随之散乱。但学人到某些程度后，就可以做到身动心不随之而散乱。坐上不散乱的人，不大会去动。身体不要过分［板直］。这里有一字之差。

    “心情不愉快、烦恼时，不要打坐，因为这样压制了肝气不通，会生病。所以心情不愉快时，可以出外散散心，把不愉快的心情化掉，再来打坐。”
    ──对大多数学人，这个态度也是可行的。除非学人有能力控制自己情绪，否则，坐也静不下来。对有这能力的，应该坐，正是看自己力量的时候。

    修法三要就不评论了，因为超过“纯技术”层面。


修禅定省力气的办法：找具格的师父学

    八喜：
    有点疑惑，是否修禅定“一定”是要有具备正见的过来人指导？若一时无缘，有没有其他途径，比如通过看书？能否再讲一下？

    二麻子：
    未必不能，要看是什么人了……
    嘻嘻，比如佛陀，六祖等，哪怕在成道前，其实在修禅定方面都不需要很多别人的指导。但这样的大福慧大根器人可能没有很多吧。
    至于八喜兄能不能，能到什么程度，似乎应该由自己判断。比方可以自己试验一辈子最后得到“我不能”的结论，然后，下辈子再重复这个试验。也可能试上多少年后在禅定上有所进展。当然，也有可能回心转意，想到省力气的办法：找具格的师父学。嘻嘻。人人因缘不同了。嘻嘻。


真受持＝无疑＋专注

    真受持＝无疑＋专注

    zf

    顶礼过去未来现在佛母，顶礼般若波罗密多！
    “若彼善男子于此总持章句。
    心无疑惑决定专注。
    是则名为真受持者。
    是则名为知过去未来及以见在说法师名。
    是则名为见过去未来及以见在说法师相。
    亦复得见过去未来及以见在正遍知者。”（《佛说如意宝总持王经》）
    真受持＝无疑＋专注


昏沉谈不到是什么境界

    spling：
    请教，清晨将醒未醒之际，忽起一念，此时正是判别醒、睡间的次第的时机（昨日看过相关书），于是将心一收，觉得进入一光圈，此时身心觉得有些木讷，杂念很少，想动一个念头都觉得沉重，身体四肢也像麻木了似的，但心意识却是清明的，勉强提念念佛，念了几声又念不动了，再提再念，还是一样。过了很久，要起床了的念头很强，于是起床了。这是什么境界？

    二麻子：
    昏沉。

    XLS：
    请教麻叔，俺碰到的情况是，也是在清晨快醒来时，意识突然一下子地醒起来，但是身体好像还没醒来，还没有动静，也没有想要动的念头。接着好像看电影一样看到一些事情的发生，似乎和我无关的，那是为什么？
    另外一种情况，此时会想起来佛，一直念下去，好像在宇宙飞行一样，最后很自然地醒来，发现躺在自家的床上。

    二麻子：
    这基本也谈不到什么……也不过是从睡到醒中的一个中间状态，你不过在这个状态停得稍微长点。说是无关还是有关，不信让人踢你一脚试试。嘻嘻。
    这个比上面那个状态好。但仍然是个可遇不可求的状态，你不能自主进入，对吗？

    nkdj：
    嘻嘻，想不昏沉难啊……

    二麻子：
    是难，所以昏沉在凡夫身上是极其普通的事……虽然修行时应该排遣，也不是一时能完成的。昏沉谈不到是什么境界。麻子想说的只是这句。

    袋子：
    袋子最近的一点感觉，昏沉和散乱虽然是两个极端，可实质上似乎是一个机制，但究竟怎样却说不上来。昏沉久了会转向散乱，散乱久了会转向昏沉，似乎是一个弹簧一样地往复，他们在本质上似乎是一个现象。

    二麻子：
    随喜随喜……随喜你对自心的观察。当看到昏沉与散乱交替的时候，你可以知道自己所观察的尚属相当粗的粗分。继续向前，以后你会观察到昏沉与散乱并起的现象。这时候就知道自己又前进一小步了。

    无言：
    麻叔，昏与散并起之后一般还会遇到什么问题呢？

    二麻子：
    嘿嘿，麻子要是回答了，你会不会还问“之后”？先问问你体会到了“并起”没有，如果没有，你的“之后”是怎么问出来的？

    无言：
    嘻嘻，想提前预防……不敢肯定自己是否体会到“并起”，不知是不是类似做梦的感觉，有时就像极快的进入了一个梦，又极快地醒了（意识到昏沉），不一会儿又进了一个梦（之所以说这种状态像梦，因为这时可能嘴里持着咒，脑子里在天马行空，眼睛在打架，有时还磕头，呵呵），这种情况总是交替着，如果精神用力些，醒的时候多，一分神，呵呵，就易发梦了。

    二麻子：
    昏倒……你自己明明在说交替吗。

    无言：
    嘻嘻，谢麻叔。


临终一念和平时用功都重要

    锦书：
    ……是不重视临终一念，而是重视日常生活，其实这很简单，譬如考试，平常努力念书，临考时自然应答自如，只有那些平常爱玩，考试一到，才用小聪明想要pass过关，任何小聪明都抵不上努力念书的实力！！！
    面对生死，靠的就是实力，而非临终一念，究竟实力是什么？你认为呢？话又说回来，生死又是什么呢？

    二麻子：
    锦书兄有趣。“临终一念重要”与“平时修习重要”，两者有矛盾吗？这如同争论是平时学习重要还是高考时重要。明摆着，都重要。强调临终一念的人没说平时不用努力呀。
    麻子同意锦书兄所强调的：意识力量不够大。但如果行人届时于心念意识全无控制力，就非随业流转不可。如何于这时能不随染业去？锦书兄所说的“平时生活中努力”无疑是极重要极重要方法。但，并不只此，还有很多方法可用。不过，不肯在平时生活中努力的人，别的方法也用不成。

    锦书：
    麻子兄，我本来就很有趣！谢谢你的夸奖！因为将注意力投注于“临终一念”的人们，有谁会认为随时的一念都可能是“临终一念”，还是认为我的“临终一念”，就是七老八十的时候？会在平日用功吗？又是用功什么？今日助念文化的产生，不能说和此没有关系！
    我是认为“擒贼先擒王”，“意识的控制力”是什么？掌握此，才有控制力可言，否则意念纷飞，无法对治，只能说说佛来佛斩，魔来魔斩，或是不作意，任其消散等话而已！
    所谓“随业流转”，“业”如流水，“识”如树叶，想要坚固树叶，不受水转，是不可能的！然而很多人都在尝试，好吧！就去尝试，别产生幻想症了！疑惑者，不要太相信意识所产生的境界，清醒和不清醒是龟笑鳖没尾！
    “水流”才是重点，如能控制它，才能有所帮助！印度思想的共同和分歧都在此，共同点在于同意“随业流转”（由吠陀来的观念），不同点在于“是什么在随业流转，业是什么，要转向那里……”
    悉达多的思想也是建立在此架构上，只是他有独特的见解，至少为我所赞叹，那就是“解脱知见”！

    二麻子：
    锦书兄，麻子相当赞同你的语后含意：时时要用功，懈怠是不成的。但“临终一念”一事未必仅属负面。若人能常知时刻都可能是临终，想必不敢太懈怠。助念一事，往者受多少利益非麻子所知，但对助念者本身却是极好修行机会。这也别一概否定了。收钱是另一件事。
    意识实在如幻。但“意识的控制力”在见上是偏常，然在实修上又是必经之路。谈到这就离不开实修了，且于阿牛前些天贴的题目“睡眠”有紧密关系，锦书兄有心思真聊这些内修的功夫吗？修到这的人，见修行非要至少有少份相应不可，否则铁定会错得离谱。

    锦书：
    认识无明是一段辛苦过程，因为它和行，识相关联，若离此二，则不见之，若辅以三十七道品和持八关斋，则有助于认识无明，行，识的关系！
    记得阿含曾记载佛说未见了知佛说之法而不生大恐怖者，惟除阿罗汉，我不知我曾经历的恐怖称不称得上大恐怖，但是足以让我记忆深刻，虽然已经七年，我却能知道所谓“佛说法，初中后善，善义善味，纯一满净”的意思！
    以前总认为了解无明后应是自由自在，经历大恐怖阶段才知道完全不是那么一回事！“明”不是我们所习惯的，也不是我们所喜欢的，但是却可以帮助建立解脱知见，佛法会灭是有原因的，因为人们要的是爱，是关怀，是稳定人类社会的力量，不是解脱知见！

    二麻子：
    锦书兄，有点想法，不便公开说，您在佛坛留我个EMAIL ADDRESS好不好？经历大恐怖是好事，但还再深点更好。经历过白红黑显吗？行人多在白显或红显之前经历恐怖，但并非人人经历。

    台湾佛教网路论坛


坐前和坐后的身体活动不要忽略

    everflying：
    末学请教静坐产生的问题，周六周日两天有很多活动，比较累。昨天晚上也就是周日晚上打坐了一段时间。可是今天早上起来的时候，发现左腿内侧脚踝以及其上面的一段特别麻木，可能是双盘的时候压迫所致。现在还是那种感觉，请问有什么改善的方法。谢谢！

    zf：
    坐前和坐后的身体活动不要忽略。

    且行且住：
    “周六日两天活动较多”这个恐怕是关键。如果平时锻炼得少，活动较多本身就容易使腿部麻痹，或者象是一条筋扯得痛一样。不一定就是盘腿坐的直接关系。过几天休息过来也就好了。
    平时还是要适当运动一下，保持腿部的柔韧度。另外，应该学习一下坐前运动的方法。金顶上师此前在这里发过一些相关的贴子，您可以找来看一下。


因缘生的无自性

    二麻子：
    自龙树菩萨以来中观对“生”“有”的讲解其实非常细密，难得有人真的深入到那么精细的地方去。故学人很容易混扰。比如这个“有”。再比如四生的否定，里面有非常多的精妙。麻子这两天忙，改天看看能不能用白话把这个问题表述一下。
    比如说“生”。一般凡夫名言共许下说的“生”，都是夹杂自性见的。而对这样的生，分为四类被全部破斥。所以，这样的生是被彻底否定的，故称“无生”。
    不被否定的“因缘生”，（注意这三字不能拆开）实际上是跟“生”完全不同的概念，或说实相现量。
    因缘生的意思是“无量缘起显现变化里，某个局部的显现明显改变了”。比如，“美人脸上生痘痘”，嘿嘿，有什么生出来？不就是一小块的颜色变红了点吗。所以，不否定的是缘起显现。这跟中观对“有”的肯定否定完全一致。
    第二，对生的破斥里，对四生的否定不是直接说“没有自性生出来”，而是在论述“生”这个过程是没有自性的，觅生不可得：抉择下无有勘忍。这点可以对比中论里对“有”的否定来看，是完全一样的。这样，“生”这个过程既然无自性，那么任何无自性的事物（法），不会因为生的过程而添加出自性来。
    如此，要确立一切一切情况下诸法永无自性，就用两步来说：1、一切法无自性，2、生的过程里也不会添上自性。所以，一切法永远无自性。
    初学中观时候麻子就想过，“一切法无自性”应该已经完备了的，为什么后面还要讲无生？
    后来明白，其实一切法无自性确实是个完备的表述。但凡夫会妄想纠缠能不能通过生的过程搞出自性来。所以龙数菩萨把这个明确破掉以断妄想。
    破四生里，自生它生都好理解，破共生就非常有趣了。共生跟因缘生的差别到底是什么，为什么要破？嘻嘻，这可以是个非常混扰人的地方。今天没时间，改天看看有没有空说个与此有关。

    dawa：
    相关的问题，其实以前莲舟小小地探讨过，俺印象深刻的是：无自性的集合中找不到有自性的子集。

    二麻子：
    嘻嘻。是。后面藏的东西就是这个……这个引理的另一个表述是“因缘无可分割”。嘻嘻。


龙树菩萨对轮回存在的说明

    龙树菩萨对轮回存在的说明

    zf

    真化兄，佛典中对轮回存在的说明，龙树菩萨在《大智度论》中论述应当算得上非常“权威”了。（编按：真化当时发贴问，如何证明三世因果。）但毕竟是“说明”而不是“证明”。要现量了知轮回的存在，只有通过禅定，开发天眼智。
    学佛大可不必等到自己得天眼后才开始。比如我们生病要吃药，药的有效性不需我们自己证明。只要有一个可靠的机制来保证药的有效性就可以了。我们学佛，只要可以肯定如来给我们的“药”有效就应该吃──去依法实践。难道如来会给我们“假药”吗？？？
    另外，对轮回的了知不是佛法的不共法，外道同样可以实证到轮回的存在。

    文摘：
    《大智度论》节选

    【经】舍利弗。汝所问菩萨摩诃萨与般若波罗蜜相应。从此间终当生何处者。舍利弗。此菩萨摩诃萨从一佛国至一佛国。常值诸佛终不离佛。舍利弗。有菩萨摩诃萨。不以方便入初禅乃至第四禅。亦行六波罗蜜。是菩萨摩诃萨得禅故生长寿天。随彼寿终来生是间。得人身值诸佛。是菩萨诸根不利。舍利弗。有菩萨摩诃萨。入初禅乃至第四禅。亦行般若波罗蜜。不以方便故舍诸禅生欲界。是菩萨诸根亦钝。舍利弗。有菩萨摩诃萨。入初禅乃至第四禅。入慈心乃至舍。入虚空处乃至非有想非无想处。修四念处乃至八圣道分。行十力乃至大慈大悲。是菩萨用方便力不随禅生。不随无量心生。不随四无色定生。在所有佛处于中生。常不离般若波罗蜜行。如是菩萨贤劫中当得阿耨多罗三藐三菩提。

    【论】问曰。舍利弗今问前世后世。佛何以故前世中三种答。后世中广分别。答曰。人以肉眼不见过去未来故。而生邪疑。虽疑二处而未来世当受故广分别。譬如已灭之火不复求救。但多方便防未来火。又如治病已灭之病不复加治。但治将生之病。复次佛无量辩才自恣。舍利弗所问虽少佛广为其说。如问与般若波罗蜜相应一事。而佛种种分别。如贫者从大富好施者乞。所乞虽少所与甚多。佛亦如是。有无量无漏佛法具足之富。以大慈悲好行施惠。因舍利弗少问故。佛为大众广分别说。复次是般若波罗蜜中种种因缘譬喻多说空法。有新发意者。取空相着是空法。于生死业因缘中生疑。若一切法毕竟空。无来无去无出无入相。云何死而有生。现在眼见法尚不应有。何况死后余处生。不可见而有。如是等种种邪疑颠倒心为断。是故佛种种因缘广说有死有生。问曰。无有死生因缘。何以故。人死归灭。灭有三种。一者火烧为灰。二者虫食为粪。三者终归于土。今但见其灭。不见更有出者受于后身。以不见故则知为无。答曰。若汝谓身灭便无者。云何有众生先世所习忧喜怖畏等。如小儿生时或啼或笑。先习忧喜故。今无人教而忧喜续生。又如犊子生知趣乳。猪羊之属其生未几。便知有牝牡之合。子同父母好丑贫富聪明闇钝各各不同。若无先世因缘者不应有异。如是等种种因缘知有后世。又汝先言不见别有去者。人身中非独眼根能见。身中六情各有所知。有法可闻可嗅可味可触可知者。可闻法尚不可见。何况可知者。有生有死法亦可见亦可知。汝肉眼故不见。天眼者了了能见。如是人从一房出入一房。舍此身至后身亦如是。若肉眼能见者。何用求天眼。若尔者天眼肉眼愚圣无异。汝以畜生同见。何能见后世可知者。如人死生。虽无来去者而烦恼不尽故。于身情意相续更生身情意。身情意造业亦不至后世。而从是因缘更生受后世果报。譬如乳中着毒。乳变为酪。酪变为酥。乳非酪酥。酪酥非乳。乳酪虽变而皆有毒。此身亦如是。今世五众因缘故更生后世。五众行业相续不异故而受果报。又如冬木。虽未有花叶果实。得时节会则次等而出。如是因缘故知有死生。复次现世有知宿命者。如人行疲极睡卧觉已忆所经由。又一切圣人内外经书皆说后世。复次现世不善法动发过重。生嗔恚嫉妒疑悔。内恼故身则枯悴颜色不悦。恶不善法受害如是。何况起身业口业。若生善法净信业因缘。心清净得如实智慧。心则欢悦身得轻软颜色和适。以有苦乐因缘故有善不善。今定有善不善故。当知必有后世。但众生肉眼不见。智慧薄故而生邪疑。虽修福事所作浅薄。譬如药师为王疗病。王密为起宅而药师不知。既归见之乃悔不加意尽力治王。复次圣人说今现在事实可信故。说后世事亦皆可信。如人夜行崄道导师授手。知可信故则便随逐。比智。及圣人语可知定有后世。汝以肉眼重罪比智薄故又无天眼。既自无智又不信圣人语。云何得知后世。复次佛法中诸法毕竟空。而亦不断灭。生死虽相续亦不是常。无量阿僧祇劫业因缘虽过去。亦能生果报而不灭。是为微妙难知。若诸法都空者。此品中不应说往生。何有智者前后相违。若死生相实有。云何言诸法毕竟空。但为除诸法中爱着邪见颠倒故。说毕竟空。不为破后世故说。汝无天眼明故疑后世。欲自陷罪恶。遮是罪业因缘故。说种种往生。佛法不着有不着无。有无亦不着。非有非无亦不着。不着亦不着。如是人则不容难。譬如以刀斫空终无所伤。为众生故。随缘说法自无所著。以是故中论中说
    一切诸法实　　一切法虚妄
    诸法实亦虚　　非实亦非虚
    涅槃际为真　　世间际亦真
    涅槃世无别　　小异不可得
    是为毕竟空相。毕竟空不遮生死业因缘。是故说往生。


关于“对因果与轮回的一些理解”

    关于“对因果与轮回的一些理解”

    zf

    “对因果与轮回的一些理解，请赵叔批改作业。”
    ──“批改作业”和“指点”的事，本人是没有能力做的，因为自己也不敢保证对佛法的理解是正确的。若自己的理解不正，却冒充善知识将别人引导到邪路，那因果可不是小事。但我等彼此交流学习的心得还是有意义的。对我的建议，若觉有理便可参考；若觉得没道理，左耳进右耳出就是了。

    “种子的伺机发芽生长便成为业。”
    ──关于“业”的较详细说明，可参阅罗侯罗尊者的著作《佛陀的教诲》。概括地说，业是指感果的能力，“发芽生长”时是成就业果。

    “精细地说起来，凡业难免有恶，至少是无常容易退转。”
    ──您上面所说的业，主要指轮回中以无明为缘的有漏业。有漏业中有善有恶，但均不能摆脱轮回。

    “轮回的解脱就是要挣脱因果这业力的驱使，不落在因果之中。”
    ──我理解您上面所说的意思是：轮回的解脱就是要挣脱“有漏因果”这业力的驱使，不落在“有漏因果”之中。
    有漏因果的根本是无明，要解脱轮回（有漏因果），就必须彻底去除无明。
    缘起（即因果）是此有故彼有，此无故彼无。有无明便有轮回，这是因果；无无明便无轮回，这同样是因果。

    “这需要一种心态与一种没有习气的习气。”
    ──“没有习气的习气”是指欲摆脱有漏业力的清净业力。

    “做到不落因果前，先以不昧因果为目标，多种善因，多结善缘，以为进步的基础。诸恶莫作，众善奉行，自净其意。”
    ──我理解，您此处“不落因果”是指脱离有漏因果，即脱离轮回。“不昧因果”之义是了知善恶因果之义后择善从之。

    “学佛的过程是上求下化的过程，上求是求自己的明白与解脱，下化是化解人们正在进行着的痛苦，为他们做一些力所能及的事。”
    ──关于“力所能及”，菩萨因欲最有效地利益一切众生，故感到智慧、力量、方便均有不足。为使“能及之力”成为无上，故发心成佛。

    “其实上求下化很难确切分开。上求心性的转变必然伴随着下化的行为，下化的过程包含着上求的进展。”
    ──据说，菩萨在证得根本智（无分别智）后，若不行“下化”的利生诸行，便不能证得后得智（分别智）。

    “我把六道理解成人的六种德性。因此，六道没有离开人群。善念发动时在善道，恶念发动时在恶道。”
    ──但这并不妨碍业果成熟时，感生六道。

    “我愿自己礼敬诸佛的那份恭敬普被有情与无情。”
    ──菩萨利益众生是因为有情有苦的感觉。“无情”因无苦的感觉，故并不是菩萨发心利益的对象。

    （编按：以上引号中是“涛声依旧”网友的话）


有一条原则是不应动摇的，即坚信因果

    zf：
    在下有几事不明：
    “至于现在当常观万法虚无，无一法为真实”
    ──万法虚无为何义？水还能解渴否？饭还能充饥否？

    “最后更当知：不但万法万物至究竟本性处空无所有，我之能觉之心至本性处亦是空无所有”
    ──行者之“究竟本性处空无所有之能觉之心”现在能看此贴吗？若能看，是否已离“究竟本性处”？

    “既然站在本性处，又何来万法与心识觉知之存在呢”
    ──本性处空无所有，行者如何“站”得住？

    “心若无者，谁去执著，谁人受苦，谁人造业！”
    ──无人，苦还有否？业还有否？

    “我性本空，心性本空乃佛法之无上要髓也！”
    ──何为“空”？与“无（nothing　）”义有别否？

    请问行者兄：“觉后空空无大千”，还有因果否？

    （编按：以上引号中为“大道行者”的话。）

    大道行者：
    说有因果，说无因果，皆是分别之念，梦里妄想所执，则因果历历。大觉后，不定要说因果是存在的，还是不存在，以此法非有非无也。

    zf：
    继续请教。
    “说有因果，说无因果，皆是分别之念”
    ──此“分别”是何义？昏迷是否无分别？妙观察智是否是分别？

    “大觉后，不定要说因果是存在的，还是不存在”
    请行者兄详细解释一下：
    一、大觉后，定说因果是存在的，有何过失？
    二、大觉后，定说因果是不存在的，有何过失？

    “以此法非有非无也”
    ──如何理解因果的非有非无？
    如何理解因果，对修学关系甚大，丝毫马虎不得，古时有人因误解其义堕为野狐。还望行者兄不吝赐教。

    gladness：
    因果之事，于在下确实非常重要，否则修行之时不知如何操作，尤其听到类似“无因无缘”之类的说法，又会以为因果似乎是阶段性起作用，到了某阶段大概会不起作用。但又不敢就下结论，因为一句“不落因果”就五百世野狐身，不是闹着玩的。
    此外，包括我自己在内的一些同修，在论坛时讨论往往都喜欢讨论高深的义理，但往往讨论之时不知把因果置于何处，无法把空性方面的见地与因果统一起来。搞不好在论坛上n多的五百世野狐身的业都造了。因此，请为我解惑。

    zf：
    对因果的一点体会。据佛经中记载，有人问佛：您悟得了什么而号称觉者？佛回答：我悟缘起。
    缘起者，此有故彼有，此无故彼无，此生故彼生，此灭故彼灭。这里“此”便可称为“因”，“彼”便可称为“果”。因此缘起与因果的含义十分接近。
    对因果的一个错误理解是：众生在轮回中受因果的制约，而圣者解脱了便不受因果制约了。事实上，众生因于无明而流转生死，受十二支因缘这一因果规律的制约。圣者解脱生死，从突破无明这一环节入手，无明灭则行灭……从而苦灭。这一还灭的过程又何尝不在十二支因缘的制约之下。别忘了，此有故彼有是因果，此无故彼无同样是因果。
    不只众生的流转和圣者的还灭在因果之中，菩萨发心成佛同样离不了因果。《普贤行愿品》中有“因于众生而起大悲，因于大悲生菩提心，因菩提心成等正觉”的开示，可见无上菩提的证成亦在因果之中。
    有人错会般若的空义，以为空就是否定一切，包括因果也要否定。这种断见非常可怕，所以如来曾说，宁愿人有见如须弥，不愿人断见如芥子。断见的最大害处在于否定因果，从而对如来“诸恶莫作，众善奉行”的教诲不能至心修学。但持断见者所造的恶业，却并不因为其“断见”而不感召苦果。世尊在《金刚经》中明确开示：“发阿耨多罗三藐三菩提心者，于法不说断灭相。”般若之空义是否定我们在缘起法上增益的自性执，并不否定缘起法（即因果）本身。这一点是我们必须用心体会的。
    在我们修学的过程中，对空义的准确把握并不容易，但有一条原则是不应动摇的，即坚信因果，“诸恶莫作，众善奉行”。

    无不可：
    我想：这里的“此无故彼无同样是因果”，如果此无为因，彼无为果可以成立的话，则“此无故彼无”应该是“此有故彼有”的果，没有“此有故彼有”为前提，“此无故彼无”如何说起呢？
    是不是说，我修了止观，发了菩提心，经过了什么什么“因”，最后证了佛这个“果”？

    zf：
    我对缘起法理解得十分肤浅，所说不一定正确。佛说缘起法甚深，因此这不是个小话题。以下是自己的理解，谨供参考。
    有和无是相待而生，没有“有”自然谈不上“无”，这一点我同意。但缘起法中“此无故彼无”的着眼点是“此”与“彼”之间的依赖性，即若“此”条件不具备，则“彼”便无法存在。至于“此”的有无又是由其他环节的因果来决定，因此果是以“因”为条件存在，而因又是以其他的“因”为条件存在。因此因果之链是没有头的。
    至于某一环节的“此无故彼无”是否一定要在先有的条件下才有意义，恐怕并不一定。以探讨月球上有无生命的问题为例。因为月球上没有空气、水等生命所必须的条件，因此月球上没有生命。这一结论并不需要假定月球上曾经有水、空气和生命等，后来水和空气没有了，因而生命也消失了。

    “是不是说，我修了止观，发了菩提心，经过了什么什么‘因’，最后证了佛这个‘果’？”
    ──是的。

    无不可：
    按我们正常的理解，这个因果关系的确有逻辑。但我认为这里的“因”是不对应那个“果”的。这里的“因”有“法”的痕迹。也就是无上正等正觉不是一个“法”的“果”。

    zf：
    无上正等正觉的确不是一个“法”的“果”，但确是众生修法的果。《普贤行愿品》中开示：“……以诸如来尊重法故，以如说修行出生诸佛故”。

    无不可：
    如果把因果的事用在成佛上，则“因于众生而起大悲，因于大悲生菩提心，因菩提心成等正觉”，反之：无大悲，无菩提心，则不成正等正觉，那么，正等正觉的空性，与“因缘所生法，我说即是空”，就是同样的逻辑了？我的想法是不能在这里以这种方式谈因果。

    zf：
    正等正觉的空性，与“因缘所生法，我说即是空”，完全是同样的逻辑。诸佛的智慧同样是缘起法，同样是无自性的空。诸佛智慧的空，与其利益众生的无边能力丝毫不矛盾。

    yang：
    正等正觉的空与因缘所生的空是否一样？如果一样，则为何要求正等正觉，还要没完没了地制造因缘；（别告诉我要普渡众生，告诉我为什么。）如果不一样，则正等正觉还是不是因缘所生法？

    zf：
    “无”一定是相对于“有”，这一点没有疑义。但结合您前一贴中的见解，是否这里的“有”是那里“无”的因，请三思。

    虚空友：
    三乘解脱果，不落因果乎？见修行为缘起因，何导不落因果之果？

    二麻子：
    有什么地方可落？因缘相续并没断绝，只是没有受者。
    所谓落因果，必须有个体作为受者。而我执断时，可以无主宰者，个体可以消失。这时候，受者在哪里？
    当然，个体也可以不消失，同样无我执，菩萨就是这样，将因果作为利益众生的机会。


别连果树也一起刨了

    荒山：
    荒山的草根在哪？除草我真是新手，所以想听听兄弟们的经验。如果不许说无明，也不许说这个识那个识，请问大家草的根在哪？

    zf：

    草深了果子虽不欠，我等也无法受用。除草的经验大家也很想听。这里的兄弟们也在除草，而且没一个人敢说草已除净。但看来你的兴趣并不在自己山上的草根！估计你的山还要荒下去。

    荒山：
    那我就先说说我的草根，请指正。这草都是从善恶的分别心里长出来的。要除草也只有除去分别心才能断根。

    zf：

    看来你不单除草，连果树也一起刨了。若说“你们的理解不对，荒山的理解才合祖师意”，荒山兄上述这种“对”与“不对”的区分，是不是你正在反对的“分别”？若是，你是否正在用“分别”反对“分别”？若不是，这种“对”与“不对”的区分，与你反对的“分别”有什么分别？当然也可能非是非不是，不过请说出个道理来。

    哈哈：
    荒山兄，所以，佛陀吃饭的时候都分不清米麦？别！


离“妄计因果”与“拨无因果”这两个边见

    二麻子：
    因与果的划分如同一切其他名相一样，是没法绝对精确定义的。比如吃饭是因吃饱是果，因前果后。但是如果你一定要说吃的时候还没饱，嘻嘻，就未必绝对成立了。
    如果我们遵从一般的因前果后因果不同时的区分方法，那么这个情况可以这样说，善因必有善果，是说善行终究会导致善果。并不是说，善行后的相续里就完全没有苦。实际上善行本身对凡夫感觉来说就未必是乐的，很可能是苦的。
    那么，这个善行及其后续里的苦是以善行为因吗？凡夫可能这样想。实际却不是。苦是集出来的，看看四圣谛的教法就清楚了。

    aruni：
    请教了：非因即不论。何谓因？

    二麻子：
    谨回……这因字一字，说起来也复杂的很，真说起来，佛法讲因缘时候，因与缘之间还真拿不出个绝对区分间隔来，无非比较紧密的缘就叫因吧。二，这个紧密与否的判断，还与我们讨论问题时候的观察角度有关，特别是看这个缘是否是我们曾经的主观作意。
    如此仔细下去对一部分人来说，没问题，恰恰是深入正见的过程。但对为数甚多的另一部分人来说，这实在有些复杂得超过需求与能力了。其实有很简单朴素的办法。
    比如，有人要通过练铁砂掌来提高高考成绩，哈哈，大概谁都会说他神经。这就是非因计因的极端了。
    但实际上，练铁砂掌锻炼了身体，对读书有利，从而对高考成绩或许也是有些个有利影响的。虽然如此，谁都知道，这个影响怎么也不能算成提高高考成绩的因吧。所以，如果练铁砂掌未能提高高考成绩，嘻嘻，不应该怀疑练铁砂掌的功效，功效根本就不在这个方向上嘛。
    持佛号可以是往生西方、忏悔业障、修持禅定等等的正因／亲因缘，具体当看行人的发心与做法。而不是防止刑事犯罪的亲因缘。如果有这方面的附带效果跟着赞叹就是，如果一时没显现这样的效果好像也实在没什么可抱怨的吧。嘻嘻。

    aruni：
    后学昔年听韩师教授时，常听师讲到有关劝诫学人勿将异熟果当成了亲因的教诫，似与大德非因计因贴中之意相通。野人献曝，不知然否？

    二麻子：
    客气客气，韩老所说麻子没在场听到，精确意思麻子不敢妄测。大致按照常理推断韩老所说应也是这个意思。因为离“妄计因果”与“拨无因果”这两个边见极端，是佛门大德很基本的素质，如韩老这般的素养对此不可能不懂。


观测与可能性

    观测与可能性

    二麻子

    某兄那贴子很怪，不能回，回贴的链接指向您另一篇大作。嘻嘻，只好另起。
    “两位成就者是否能在网上相印证？”
    ──佛法说，一切因缘法，无常不定。印证一事，亦属因缘法，故，不定，无常。三段式逻辑到此就了结了。
    当然，只看这段，闷气得很。那就具体看看，网上印证需要什么因缘。若因缘不具备，则无法印证。
    需要的条件很多，随便说说，比方，两人不同时上网，则印不了。上网不碰头，印不了。碰头若有一方不想印，印不了。若语言不通，则一般印不了。语言虽通，关键时停电，印不了……等等。这类外缘性的条件太多，不胜其举。有一条件不备，就印不了。故非绝对可行。
    但还有更困难的条件。两位开悟人士相印证，本身外人没法确定其“有，无”。除非其中一方是公认的成就者，当然，公认二字，又依赖无数因缘，暂放一边，而这公认成就者又正式对外宣布。或，二人相印证时，有第三位公认的开悟者在场，并将此事公布。否则，印证一事，就成为不可观测事件，对不可观测事件，说有说无全无意义，更别说绝对了。
    若改问，对印证双方中的人来讲如何呢？条件稍松一点。但，若此人想向外界说明此事时，就如上一样了。
    若反过来问，两位成就者有没有在网上相印证的可能性呢？麻子认为，完全可能。
    “绝对可以”与“绝对不可”的说法都不符合佛法。因缘所成佛法，即无常，不定。麻子原话是说，“绝对能”与“绝对不能”的说法，都不符合佛法。兄开始说这是文字游戏。此前“亦不能”一句，并非麻子说的。但“绝对能”一句却是阁下说的。
    兄一见无常不定即道“不能”，嘻嘻，戏论不自知？此是连外象亦看不清者。互相印证之事，有，无定法。
    执自心有者，能近道不能入道。兄若真能“不要也罢”，倒添一线希望。扔下你的“自心遍一切处”吧。先体会心如幻，不可得，也免得不知自己在说什么。


因果律和随机性

    明心斋主人：
    麻叔哪里走？留下买路钱！据说您曾和老儒兄（郑玄）就概率论、随机事件是否违背佛教因果论的问题进行过深入的探讨，能否告知旧贴在什么地方？如果找不到了，那是否可以简单介绍一下您对此问题的基本思路？谢谢，请不要再让我失望了。

    二麻子：
    那个讨论并不很长，在如意禅堂上进行的。
    就是酒老的坛子上。近年酒老可能酒喝多了，乘鹤而去，不知仙踪，那个坛子自然也就消失了。
    那个讨论的本质其实是“宿命”“不可知性”，真理（如）如何离此两端。不过跟老儒的讨论是用概率论的用语进行的。讨论时，老儒与麻子对这个表象后面所谈的本质──宿命，不可知论等，都心知肚明，而且双方看法相差不远。但因意外小故障打断，讨论没进行到底。
    后来，莲舟与慈氏论坛都讨论过佛陀是不是“全知”的问题。这个问题本质上是与老儒兄所讨论的问题一样。
    你说：“他的意思好像是认为概率论、随机事件构成了对因果的证伪，所以我本来估计是您和他激烈对辩啊。”──看来老儒的回忆有误，算了，估计的辩论痕迹也找不到了。
    嘿嘿，咱们佛门弟子，未必一定思维严谨，人家儒家高弟，未必思维都不严谨。老儒有他仔细的地方，嘿嘿，只是这郑老师在坛上混的年头多了，多少喜欢挖陷阱坑人寻开心。
    你仔细读读他的帖子，他暗示证伪的，是因果律还是宿命论？他否定过吃饭会饱吗？他强说为“常”的，变化中的不变，不是因果律吗？嘿嘿。他真正否定的是万事前定──这是因果律还是宿命论？
    明斋主对俺不满意的地方越来越多了，嘻嘻，毛病出哪里了？别看见人家那块牌子就简单否定人家，嘻嘻，仔细看清楚别人讲的到底是什么比较好些。这年头，不光有挂羊头卖狗肉的，也有挂狗头卖羊肉取乐的，特别是在网上玩家里。
    佛儒之争俺不会帮郑老师，这从概率论聊到因果律的事，还是把人家的意思看得更仔细点好。
    说句直率话，再联想到先前在讨论科学逼近真理与否问题时的印象，俺对明斋主做学问时够不够仔细，有点疑问。

    “老儒：‘如果理里面包含有果无因呢？’”
    ──那你掰掰看，这是说无有因果律了？
    他这里的因，与你说的泛指因缘的因是一个意思吗？比如，电信传输里，十万分之一的误率。每次误码都有明确原因？
    是谁想制造这次误码呀？这个误码可以说是大量影响不大的因素凑成的，不能说哪个因素是主因。但，用概率的术语说，这个解释，这个现象是古典概率的随机性。其大意是，因素太多了有限智力无法精确处理，显现随机表象。这种随机性完全没离开大家接受的因果律。法界里明显包含这种随机性，但很多人可能没注意到，如果说法界只包涵这种古典随机性将导致致命的宿命论：确定而不可测的宿命。
    现代概率论还说一种随机性，不是因为因素多，算不过来，而是说根本的，完全内在的自发的随机性。这种不确定性是根本的，无法排除的。这种随机性可能很多人就不能接受了，认为会违背因果律。实际上，这种随机性在现实中是相当明显的。而且，即使是这种随机性，也可以与因果律不相违背。关于这点更具体的例子与讨论是在大千的慈氏学论坛上，关于作意的自由与限制等。这里就不罗嗦了。
    千万注意，因果律主要是使违背因果的事不能发生，而不是精确确定唯一结果！结果被唯一确定仅仅发生在事件发生时。也就是说，还没发生的事都有某种（大小不等）的不确定性。完全确定了的，也就是过去了的。
    因果律是很要仔细的东西。嘿嘿。一个偏向将导致宿命论，另一个偏向将导致否定因果。
    嘻嘻。郑老师就是用这点细微的地方在搅和你。你如果不小心自己不知道隐含落入宿命论了，嘿嘿，就等他高兴了来折腾你，并顺道损两句佛教吧。

    “老儒：‘佛家最大毛病在于妄谈因果，排斥随机事件和自身知识局限。’”
    ──您是喜欢看老儒的口号呢，还是想真看明白他的陷阱？
    上面这些口号，麻子楼上帖子都有涉及，明斋主看看，老儒否定的到底是什么？
    是否定因果关系，还是说你不接受随机性？
    他没说不要因果，他说你“妄谈因果”。
    妄谈两字当然有技术性刺激对方的成分，不过，也是建立在你的确没讨论随机性这个现象上的。实际上，随机性是因果律里的重要成分。离开随机性，因果律就被阉割成宿命论了。
    你并不需要否定随机性，只要别人认为你否认，久了，就积非成是。你就变成否定随机性了。嘻嘻，别以为这是完全冤枉你。这里你不是你个人，人家说的是佛教徒。平心而论，我们佛弟子都搞清这个问题了？或者问，多数人，主流看法搞清这个问题了？似乎我们真不敢回答“是”。宿命论的影子或多或少总是存在，似乎有点挥之不去呀。
    买路钱不知道留了多少，但你还是失望呀。嘻嘻。


相对自由意志

    111111：
    佛教如何理解自由意志？多年的困惑。如果认为连学佛的意志，都是由先前的各种因缘决定的，则个人今天改变命运的“业因”其实也是“宿命”，则佛教归根结底也是宿命论；如果存在自由意志，则犯了无因过失，违背了因缘和合的基本观点。究竟应该如何理解？

    369：
    为什么说“如果存在自由意志，则犯了无因过失，违背了因缘合和的基本观点。”如果存在“自由意志”，也应是“有情”独具的吧？

    二麻子：
    绝对的自由意志……绝对违背因果律。绝无自由意志，绝对落入宿命论。两者都不对。六幺兄请看，顺答西藏老虎……嘻嘻。
    先让我们把问题说得清楚些。宿命论：认为现在及将来的一切都是早已确定不能有丝毫更改的。注意，这个宿命论不是说业力的惯性，而是说绝对不能更改。如果问起什么是“早已”，怎么“确定”，那就真的追到第一因去了。我们这里权且放过这个问题。
    自由意志：有两种。绝对自由意志，指人可以不受外界影响自由决定行为的能力。相对自由意志，指人决定行为时虽然受到各种因素的影响和制约，但这种制约并不能强使行为人只能做出唯一行为，从而行为人仍然有在一定范围内自由选择行为的能力。
    现在回到问题。说实在话，如果讨论宿命与自由意志问题也动用“不一不异”之类的空性见话，实在是把问题搞复杂了。对我们一般讨论来说，俗义就可以了。
    从简单的开始，先说绝对自由意志。很明显，对人类来讲，绝对自由意志明显地不存在。比如，人不会到火星上去比赛三级跳，没这个因缘。其他众生也各有其限制，同样不具备绝对自由意志。比如，想不死是做不到的。
    宿命论，特别是“不可测度的宿命”是个没法证伪的命题。这里所谓可测度是说，能对未来具备全面完整无所不知的预言。这种论法的基本方式是，对任何发生了的事，一律说是宿命。而对将来的事，则说“不可测”。然而这种说法，其实对人毫无意义，毫无利益。虽不能证伪，同样不能证实。从而成为“不完备性定理”的一个例子。
    相对自由意志，很明显是存在的。因缘业力虽然极大地限制了任何个人的行为范围，但在绝大多数情况，几乎所有情况下，并没约束到使人只能有唯一行为。这时候，当事人具有一定的自由来决定自己的行动。上面dawa的例子，受贿不能归咎于礼太厚，是个很好的例子。这里因缘法对行为范围的约束，正是所谓“业力”的反映。
    而个人这时候对行为的选择，正是新业的起始，或者说，将影响这些因缘演化的方向，从而影响将来的果。
    至于是染是净，就看具体心行了。
    至于因果是不是能改变的问题，其实根本不构成问题。
    因果就是因缘法，本身就在不断的演化中：因缘相续，当然是不断演化的。特别是演化中含有众生相对自由意志的加入的话，其变化就更是难以预测的。

    云飞月：
    正因为有这种相对自由意志，我们才有选择善与恶的能力？

    二麻子：
    是，但千万注意限度……老虎没有不杀生的自由。除非它肯自杀。

    savelife：
    意思是不是对于某些众生而言，自由意志是被限制在业力之内的？
    所以除非具有出世间的智慧，否则即使是比动物聪明的人，也会随业流转，难以自主，我们所谓的自主，也不过是业力习气的驱动下的“自主”，所以仍然还是受到业力的“影响”甚至“控制”。
    业力和宿命的不同之处，在于宿命是无可改变的，已经决定好了的，而业力则能影响一个众生思想和行动的方向，但业力不能决定一个人将来的一切命运。

    二麻子：
    如果麻子没理解错你的意思，大致差不多吧。麻子不太明白业力的内外是怎么个意思。除了“控制”有点偏向绝对化以外，别的说法麻子基本没异议。

    西藏大老虎：
    请问麻叔这个相对自由意志的“在一定范围内自由选择”之“自由”是否有前因后果，依缘而生？

    二麻子：
    这个明显是依因缘的。老虎能做的自由与人能做的自由明显不同。您这里似乎有个“一因一果”的机械论藏在里面，是吗？

    西藏大老虎：
    我的理解应该是有因而生的，因为我们每一个念头都是相续前一念，而且以前一念为因而生的这一念的果（嘻嘻，请不要笑话俺理解的粗浅）。那么，既然每一念意志抉择都未离因果，那“自由”该怎么理解？

    二麻子：
    这里你对自己心念的观察明显不仔细。不是每个念头都是像你说的这样相续。嘻嘻，若按你这说法，熟睡无梦（无心位）后，就再也起不了念，成“长眠”了。实际上，我们的心念很多是你这里说的这类。但有一类不是，所谓“孤起的”心念。比如，正讨论佛法时，突然起一念“隔壁王横抓了只蜻蜓给我”，“噢，这大概是15年前吧”……这里，后面的念是前面那个妄念的相续，就是你说的那类。但第一个不是！若问第一个从哪里起的？没寻处，叫“一念无明”。但即使这个“孤起的”的念，显然是与过去因缘有关的，一样是因缘法。并不是“法不孤起”里的孤起。

    西藏大老虎：
    不说因果能不能改变，而是“改变”是否皆依因果呢？相对自由意志的加入可以使“改变”不依因果吗？

    二麻子：
    怎么就不依因果了？绝对是在因果的约制下。你做不出违反因果的事来的。但，依因果的行为不是只有一种，还是有一定的自由。
    因此，尚未出现的事件（将来），不能说是完全确定的。佛在经里明明说过，将来法不定。还是那句话，因缘果法不是机械的，僵化的。

    西藏大老虎：
    还有一问：佛具宿命通是否可以准确预测未来？

    二麻子：
    嘻嘻，这个问题本坛上前不很久也相当详细讨论过，你翻翻老贴子吧。麻子这里只简单说一句，对我们凡夫来讲，佛有没有准确预测全部未来的能力，是不能证实也不能证伪的。似乎大老虎对这类不能判别命题有特别的亲和力，嘻嘻。哈哈。

    西藏大老虎：
    举个例子，北京的地铁是环行的，我家在积水潭，我要去雍和宫的话肯定得由西往东坐地铁，我每次也都是这么抉择的，可是我是有自由意志的啊，我可以反着坐地铁，反正绕一圈也能到雍和宫，我这么忽生一念我就往西直门反着坐了。请问这是“相对自由意志”吗？若是，那这个念头可是明显有前因后果的，前因是俺在论坛上正探讨这个“自由”，所以俺想实验一下，才生了反坐地铁的念头。若不是，请麻叔给俺举个是“自由意志”的例子。

    二麻子：
    这个是自由意志。你这个念当然是因缘所成。问题是，这个念并没确定你非反着坐这车，你甚至可以这样想半天以后，继续按原路坐。这个自由你有。直到你上了车。这里，你正坐反坐，都是有前因后果的，可依然有自由意志呀。你的问题是，你觉得凡是有因果的就不是（相对）自由意志了。这个不成立。
    其实你心里想的是绝对自由意志，自由于因果之外。麻子前面帖子里明说了，这样的自由意志，没有的。

    西藏大老虎：
    熟睡无梦是无念状态吗？难道意识相续流还有断的时候？
    难道自由意志就是没来由的生起一念“隔壁王横抓了只蜻蜓给我”？另外就是这个无哩头的念头也是有来头的啊，可以几乎肯定是当时“触景生情”（这里的“景”可以是环境、某句交谈的话语等等）。

    二麻子：
    读读唯识方面的书吧。熟睡无梦是几个无心位之一，其时，六识心暂停。你说意识相续这时候断不断？断后怎么再起？无哩头想法也是因缘法，你过去留下的因缘。但麻子没说这个孤起念头就一定是自由意志，你可别过度联想。麻子上贴说这类念头是提醒你，你观察自己心行并不很细致，别把自己观察到的那部分就当了全部了。这种无来头念头虽然是因缘法，却不是六识上相续的。

    西藏大老虎：
    麻叔，既然我两种决定都是有因果的，而前因已经不会变了，那么，您的意思是确定的因（包括缘）能导致不同的果？

    二麻子：
    对，就是。因为你在这些确定的前因后面，在果的前面，添的作意，行动不一样。这地方正是一切众生可以修行解脱的基础。否则成了宿命论，众生还能解脱吗？
    注意的要点是，你认为的“确定因缘”实际只是在果发生前的那部分。没包括在果发生之前你的作意和选择，你有一定的自由。直到你登上车，这些因缘才完全确定了。这时候，你再作意也改不了你登车这个果。

    西藏大老虎：
    佛教承认有“自由”吗？诸法无我，那“谁”自由呢？难道自由是有自性非缘起的？“此有故彼有，此生故彼生”，自由和缘起论是不是矛盾呢？

    二麻子：
    佛陀没用什么自由意志这个词。麻子前面说时，明确划分了相对自由与绝对自由。而相对自由，正说明了是缘起的。您别一边用着相对自由，一边脑子里偷偷换成绝对自由概念。至于诸法无我，嘻嘻，你想不再用俗义，改在空性见上讨论这个问题了？无我，就谈不到自由不自由。就像上面有问佛自由不自由，嘻嘻，那是凡夫强把自己的凡夫见扣到佛头上，然后产生出来的问题。“此有彼有”一句，是表述现前的显现与因缘的关系。你还没登车，怎么彼还没有发生，怎么个此有彼有？所谓相对的自由，就是因缘法的规律。佛陀没用这个词，但佛陀教导我们修行，而且再三说修行就在现在，就是用的这个自由。
    因缘法不是定死的，果没现前之前，都可能变化。当然能变化的范围可能大也可能很小，有的，小到看不出能变来，我们就说是定业了。其实，定业也未必定得那么死。例如，晚期爱滋病人，几乎一定会病死的，似乎不能改变。实际上呢？还是可以改，比如，病人决定马上跳楼，那就不是病死了。
    种豆不一定得豆，可能得的是豆苗菜。但种豆一定不会得瓜。这是因果不乱。别当成种豆一定就得豆。

    西藏大老虎：
    “熟睡无梦是几个无心位之一，其时，六识心暂停。你说意识相续这时候断不断？断后怎么再起？”意识相续这时候断不断？断后怎么再起？

    二麻子：
    无心位，意识当然断。断后再起的过程，就是十二支因缘说的，（一念）无明缘行，行缘识……越滚越粗。粗到一定程度，就是念了。

    西藏大老虎：
    既然凡夫的作意都是相对自由的，那为什么袁了凡在没修善法之前被算的那么准？而修善法之后又都改变了？这修行和未修行时的作意有哪些本质区别呢，以至于对未来的影响如此之不同？

    二麻子：
    这个原因跟前面说的情况几乎一样。影响限制我们的作意自由的，不仅仅是外部因缘，像我们上面帖子里讨论的那样。还有一类因缘，叫“串习”。串习说白了，就是在一类情况出现时，人习惯地就按某种方式去作意了，而没有充分使用自己具有的相对自由。了凡没修善法前，就是这样。
    “修善法”是什么意思，不就是使用了相对的自由，不再按照习惯去作意吗？这个新添的作意变了，其后果也就跟着变了。因缘法呀。
    作意这里是个中性词，包括了善的恶的。了凡改变的就是作意的方向，将恶作意停下，善作意动起来。用的还是这个相对自由。
    此外，回顾我们上面的讨论，麻子想提醒你注意的是，“相对自由意志”的运用一定是在“果”现起前。等果发生后，即对已经发生了的事件，就没有自由意志了。然而，因果相续是不断的，有时候分辨“前”很不容易。而只要前后一偷换，宿命论就可以振振有词。这常常是非常混绕人的地方。嘻嘻。

    zf：
    插几句，老虎兄：
    一、如果因缘中某一项占主导地位，其果的生成将具有某种“确定”的趋势，这一点恐怕大家没有疑义。
    二、对于远离平衡态的非线性系统，若影响因素极多，这些因素中又没有主导因素，则结果很可能不是平均结果，某一微小的扰动都可能对结果产生显著的影响。近些年发展起来的混沌理论具有启发意义。
    三、回到老虎兄的问题，当影响某一系统的因素接近无穷时，“确定的因缘”这一说法本身是否成立都值得深思。
    四、回到现实，不管“自由意志”的含义如何，老虎兄发心学佛的自由是确定无疑的。只要对“自由意志”的疑惑不至于动摇您学佛的意志，此问题一时搞不清也问题不大。最重要的是勤积福智资粮，等将来成佛时该清楚的都会清楚。
    五、以上“不求甚解”的建议供老虎兄参考。

    111111兄，仔细想一想，可能存在一种能解释一切的理论和学说吗？经验性理论的基础是经验和逻辑，至于经验所描述“事实”本身所成立的依据显然不是该理论本身所能解决的问题。若追究下去，结论只能以“事情就是这样的”来回答。例如如来开示了缘起之道，我们若问：“为什么会有缘起”，回答只能是：法就是这样的。
    关于“自由意志”，麻子所说之“缘起的相对自由”这一“事实”应该是我们大家都可以“实证”到的。依在下浅见，这样的“经验”应该有资格成为理论的基础。
    佛法本身对建立完备的理论似乎并不感兴趣。如来开示缘起的目的是为我们指明解脱之道，只要我们依之修学便可解脱。世尊对弟子们提出的一些与解脱不直接相关的问题默而不答，先贤们好像也无意去建立一种学说以回答所有人的所有问题。


我理解它是“活”的就好了

    二麻子：
    恒兄注意到没有，因果律并不是宿命论，因果律不等于确定性。因缘法并没绝对确定相续的发展，但是强烈地约制了相续的发展。
    例子。种豆不一定就是得豆。可以得豆苗炒菜，也可能得了豆虫生蝴蝶。这是不确定性。但种豆绝对不会得瓜。这是约制。
    在被约制的范围里，确实有个特别起不确定性作用的因素，就是作意。似乎不需要用什么“不思议变”这样的怪词吧。可思议又如何，一样可以不确定呀。

    恒河沙数：
    我突然明白了，我为什么一定要将自由意志再提纯呢，我理解它是“活”的就好了，它本来就是这样一个东西，再剖析它是“我见”在作怪。
    就是“作意”也可，其实很多心所法都有自由意志的特性在里头呀。
    呵呵，其实色法和不相应法也是“活”的呀，当然“活”得比较不自由而已。

    二麻子：
    嘻嘻，看得高兴就吆喝一声……这帖子比你前面的要好得多了。前面你想“提纯”出纯粹的自由意志，那是错的，不可能的。没有能离开因缘的自由意志。自由意志也是因缘法。嘻嘻。

    常如：
    多句嘴，所谓众生本“自由”，只是不知不见而被“缚”。若抓住自以为见到的“自由”的起处，狠狠“看回去”，或可明白那“自由”到底是个什么。

    二麻子：
    后半句对。前半句不怎么好。因为“自由”是对个体来说的，当然可能外延到群体。但是，只要是执于个体也就是说只要我执没破，就有自由与不自由。当我执破掉以后，这个概念根本谈不到了。所以，众生就是（自由）不自由，本来也是。除非你说，众生本来非众生，而且也不能再说是什么。嘻嘻……


宿命并非真实

    alphone：
    为何大家对宿命论如此惧怕，以现代数学物理的思维方式，我认为以过去／现在／时间作为参数，从而推导出未来是完全有可能的；当你超出第四维（时间）时就过去未来都能看到了。如果一切都是注定，其实也没什么可怕的，只不过有些郁闷罢了。

    dawa：
    嘿嘿，以现代数学物理的思维方式，以过去／现在／时间作为参数，从而推导出未来是完全【没有】可能。
    原因：
    一、除了物理学之外，更高层的运动，如化学，里面基本上没有数学推导。所以，您的设想的基础是彻底的还原论。
    二、即使是一个演绎体系，预测无限长的未来，需要对现况的无限精确的测量。这也是不可能的。

    alphone：
    你说的有一定道理，无限精确的测量之所以不可能，是因为观测者参与进其中了。但如果观测者可以做到“无我”（当然此状况下已不能再称之为观测者），做“不测之测”，那么预知未来就是可能的了。

    dawa：
    重申一下俺的意思，现代的科学常识不支持宿命论。至于无限精确的测量之所以不可能，物理学上有个“测不准”原理。测不准倒不是因为观测者的介入。呵呵，这儿请NKDJ兄说说吧……

    哈哈：
    这有原因。首先，宿命并非真实。这个每个人仔细观察都可以看出来。
    其次，如果宿命论通行，任何人都将不再对自己行为负责。杀人放火都不过是“命定的”，当然，枪毙也是命定的。后果如何您可以自行想象。

    月黑鬼车來：
    说不通！宿命论者可能比较没什么活力罢了！你说的那类人比较像是断灭论者，而且还得要具有犯罪倾向的断灭论者。

    哈哈：
    这种事情通不通取决于个人。人都想给自己的损人利己行为找点冠冕堂皇的理由。


自由意识与宿命论的对决

    二麻子：
    排斥与科学有关的猜想其实是不必要的。比如说，对基因的研究得出“基因的根本动力是维持自己的存在，方法是最大量地复制自己”。而基因是地球上生命的根本。好了，这话多好。正是从一个侧面说明俱生我执──生命就是执持自身呀。
    决定论（宿命）与非决定论的讨论挺有意思的。可预测，指准确预测，与决定论确实是可以分开的。比如，希特勒决定进攻苏联，斯大林未能预见。只要观察是有限的，可测不可测不能说明决定非决定。
    自由意志就使事情更复杂了。有自由意志使（假设）具有全局观测能力的人（神？），也失去准确预测能力，并使决定论（宿命论）失去立足之地。
    在讨论决定论问题时……讲的预测只讨论准确预计。因为能准确预计是决定论的充分条件。而概率预报不是这个充分条件。但反过来不成立。决定论不能保证准确预报。
    概率预报对是否决定论没有判断任何作用。只能概率预报的对象，有可能是决定的，也有可能不是。
    所谓“另一种决定论，不管您能不能准确预测，人类最终还是被某种神、超自然力量或规律决定的。”这就是所谓“不可测的绝对宿命”，非常糟糕的东西。这东西危害相当大。

    rj：
    嘻嘻，难道人自己有选择立场的自由吗？麻老，好像没有呀。

    二麻子：
    嘻嘻，你把什么叫自由？
    立正！稍息……立正！
    解散……
    问你现在有只许先迈左脚或右脚的限制吗？
    如果没有，你把这个叫什么？

    rj：
    嘻嘻！问题在于没有独立的一个“我”在作动作。所以说自由选择是不对的，因此说有选择立场的自由也是不成立的。

    二麻子：
    嘻嘻。我问的是：你把这个叫什么！真俗两义混着说的结果，对多数人来说，是一锅浆糊呢。

    rj：
    那就直接一点，那就叫“缘起在思维方面的作用”。您老看这里的区别是：把形容词给去掉了。事实上形容词是垃圾，比如“自由意志”里的自由。

    二麻子：
    成，你“缘起在思维方面的作用”了。口试完毕，你老师跟你说了上面那句话。哈哈。
    应成宗不许坏名言共许，看出道理了吧。你不能连俗有都不许说。嘻嘻。

    rj：
    俗有的界定──首先，后学认为是“缘起在思维方面的作用”，非是您老标题中的“你‘缘起在思维方面的作用’了”。
    自由意识在字面上的含义是“自在取向”，也就是有不受任何限制的选择自由。然而这是不存在的幻觉呀。“自由意识”这个词在佛经里没有，只是后来的哲学家们造出来的，所以共许要和哲学家们共许，佛弟子们好像没有“自由意识”的共许呀。
    既然是和哲学家们的共许，当然要按照哲学家们的本意来说呀，既然本来就是虚妄不实的一个兔子角，当然是要破掉并且也不坏世间法呀。
    “自由意识”这个名词可以有，但实际上除了满足自我的想象外实无所指。
    您老说是吗？

    二麻子：
    嘻嘻。你也跑题……
    我们开始讨论的是：“你把什么叫自由”。
    你添上意识两个字，再把它界定到哲学上的“绝对自由意识”上去。绝对自由意识当然是没有的。问题是，后两步你怎么偷跑的？
    你“缘起在思维方面的作用了”在我看来在今天对话里的意思，就是“你自由了”。嘿嘿。没什么别的。平常日子你不会听不懂这话的吧。哈哈。
    所以，语言这个东西，如果无限折腾下去最后就连话都不能说了。
    其实，事实很明确，回到解散那个例子，说明在任何事件发生前，
    1、因缘法给出一定的限制，比如，我们可以用左右脚但不能用第三只脚。狗就可以。嘻嘻。
    2、因缘法没限制到全无余地，比如先动左脚或右脚都是可以的。把这个叫限制叫自由都可以都有道理都不是绝对的。等到事件发生了，那就没有什么可以改变的了。

    上述顺序只要颠倒一下，比如说，
    a、事件发生前，说无法事前知道结果（这是有意忽视因缘法的限制）。
    b、发生后，说这个结果是发生前定的（这是有意颠倒因果关系）。

    就成了所谓“不可测的宿命”。

    我想，明白这些以后，关于宿命与自由的问题就不再有什么重大疑点了。


关于缘起与空性关系的一点看法

    关于缘起与空性关系的一点看法

    zf

    通过缘起而认识空性被龙树菩萨和宗喀巴大师等认为是灭诸戏论的最好途径。如《中论》开篇之“能说是因缘，善灭诸戏论，我稽首礼佛，诸说中第一。”及宗大师《缘起赞》中之“由彼彼依缘，说彼彼性空，离此更何有，希有善教诲。”这些开示都明确指出了缘起是通往性空的“第一门径”。
    一旦通过缘起了解了性空的真义，就会发现，若无性空，缘起根本不可能产生。在这个特定意义上将性空说成缘起的“因”，也可以理解。
    在上面的讨论中，“缘起”基本上还是“彼彼依缘”之义。如果将缘起的含义扩大为《华严经》之“重重无尽、事事无碍”的“法界缘起”，则对这种缘起的认识便一定以对空性的认识为前提。空性相对于上述法界缘起，一方面为其成立提供了可能性，另一方面还说明了其成立的必然性──即因为诸法性空，所以法界的真相一定是重重无尽、事事无碍。
    这里应特别指出的是，空性除具有通常所说的“无自性”义外，还具有另一个重要属性──“不可分别性”。正因为“性即无为，不可分别，……是故此中有彼，彼中有此。”
    空性的“不可分别性”似乎并未受到所有教派的关注，但我汉地华严宗古德却对此高度重视，并将其作为立宗之基石。
    由此可见，若依华严宗之见，缘起和空性的关系可以概括如下：
    由彼彼依缘之缘起，得入无自性、不可分别之空性；由此无自性、不可分别之空性，得入重重无尽、事事无碍之华严法界之缘起。
    在上述认识过程中，开始之“缘起”与结尾之“缘起”，虽名字相同，但意义上却有极大的差异。两个“缘起”中间“空性”所起的关键作用不言而喻。


学人缘起正见的确立

    学人缘起正见的确立

    zf

    关于学人缘起正见的确立，下面是自己的一点看法，供兄参考。

    从佛教辞典中可以了知“证”之主要字义：
    修习正法，如实体验而悟入真理，称为证；即以智慧契合于真理。
    证，有契会真理而悟入之意，故有契证、证契、证会、证悟、证入等语词。又证之境地，乃唯有自己体验之意，故有己证、内证、自内证之称。就能证而言，称为证智、证知。对修因而言，称为证得、证果。对教法或教道而言，则称证法或证道。

    关于“信”，佛教辞典中的解释是：
    指能令心澄净，对佛、菩萨、教法等不起疑心的精神作用。
    《大智度论》说，佛法大海，信为能入；又说，若人心中有信清净，其人则能入佛法，若无信则不能入。

    在下认为证或实证的重要特征就在于上面所说之“唯有自己体验之意”。本人在上文中所要强调的是，我们这些轮回中的众生，因自业力故，能亲自体验之五蕴诸法同如来相比是十分有限的。因此，即使我们能完全亲见到自己所体验到的一切法皆是缘起缘灭，我们所得到的结论也只能是：在我们感知范围内的一切法都是缘起的。只要我们不是坚持认为，在我们感知范围以外根本不再存在其他诸法，则由我们的体验到如来所说“一切有为法，如梦幻泡影……”这一全称结论之间仍有一个鸿沟。只有跨过这一鸿沟，我们才能真正接受“一切法皆是缘起”这一全称判断，而只有这一判断是全称时才能被称为是“正见”。跨过鸿沟的途径除了对如来的信心外，在下不知还会有别的什么可能。
    这一过程与对“不完全归纳结论”可靠性的讨论有些相似。例如，某地人所见的天鹅都是白色，因此得出“一切天鹅都是白色的”的全称判断。事实证明这一判断是错误的，因为在其他地方确有黑天鹅存在。
    因此，在下认为，学人缘起正见的确立是由两方面所构成：一是不完全的体验，二是对如来的信心。
    对那种认为正见的确立可以完全来自于自己的体验，或某人已完全实证缘起正见的说法，本人实在不敢苟同，除非其人已经获得无上正等正觉。


缘起一说为我佛教言之根本

    缘起一说为我佛教言之根本

    zf

    兄在文中曾引用《新旧译派的整合》一文中之“由于宁玛派所说的根本心不是依因缘而新起的，故名‘无生’”，因此断言，根本净光心不可能如某兄所说，是“缘起空性之至密、至深、至极的究竟体现”。本人欲就此谈点看法。
    关于“根本心不是依因缘而新起的”，其关键是此处的“因缘”之确切所指。狭义上，此处之因缘所指可为大乘行者从出离心、菩提心、清净见等到一切福慧资粮的积累；广义上，此处之因缘所指可为一切因缘。如果此处之因缘为狭义上的含义，则根本心即使不依福慧资粮的积累而新起，亦不能因此断定其为非缘起法，何以故？不依此因缘起还可依他因缘而起。这样众生本具与缘起法之间似乎便不存在不可调和的矛盾。如果此处的因缘为广义上的含义，则只能导致根本心为非缘起法这一结论，从而面对非缘起法而无自性的难题。因此，依本人的理解，此处因缘的含义应是狭义而非广义。
    《大方广如来藏经》以九喻说明众生本具如来功德。其中一喻如下：
    复次善男子。譬如以蜡作模。或作马形象形男形女形。泥裹其上而用火炙。销炼真金铸于模内。候其冷已。是其工匠将归舍宅。其模外为黑泥覆弊。形状燋恶内有金像。或工匠及工匠弟子。知其模冷。即坏其泥。既净持已。于须臾顷是金宝像则便清净。如是如是善男子。如来以如来眼观见一切有情。如金像模外为烦恼泥所覆裹。于内虚冲满有佛法无漏知宝。
    在如来此喻中，如果单独观察“或工匠及工匠弟子。知其模冷。即坏其泥。既净持已。于须臾顷是金宝像则便清净”这一过程，则可得出金像本具，非由清除覆弊黑泥之因缘而起的结论。但若仅仅据此便得出金像为非缘起法的断言则实为不妥，因金像实依以蜡作模、泥裹其上而用火炙、销炼真金铸于模内等缘而起。
    众生本具如来功德之缘起过程虽远较上喻深细，但如来此金像之比喻于我等确立对尽所有性的定解仍有巨大的启发意义。
    华严宗杜顺大师在缘起法的前提下，善巧安立众生本具如来德相，建议兄仔细研读大师的著作。
    缘起一说为我佛教言之根本，是佛教与其他宗教的根本不同之处。如来是真语者、实语者、如语者，如来亲口宣说：“见缘起即见法，见法即见佛”。我等佛弟子若对缘起一说稍有犹豫，则圣道之根基立时动摇。于此关系慧命之处，万望兄深思！
    缘起法甚深，在亲证一切种智之前，我等行人不可能遍知一切深细之因果，但对“诸法因缘起，如来说是因，彼法因缘尽，是大沙门说”的信念却不可动摇。某兄反复强调“果乘诸宗的……见，也不过是缘起空性之至密、至深、至极的究竟体现……大圆满见是缘起空性密义的终极体现”。其用意之一恐怕即是提醒我等切莫动摇对缘起正见的信念。不知本人是否错会了某兄的本意？


学佛的人常会遇到的问题

    学佛的人常会遇到的问题

    正见：
    本人是一佛学爱好者，只看书，无修行。本人一直以为学佛首重树立正确的见解，有四个问题一直困扰我：
    一、既然说诸行无常、诸法无我，一切都是缘起性空，一切必将流逝，那么我们还能追求什么，还能凭什么安身立命？
    二、既然说诸行无常、诸法无我，一切都是缘起性空，那么一切有生有灭，可为什么《心经》、《中论》皆说诸法不生不灭，岂非又落真常论？
    三、因果与自由的问题：成佛就是实现究竟的自由即解脱（极可能我理解错了），如存在因果，被因果之链锁着，如何能自由（成佛）；如不承认因果，又有悖于佛法。
    四、对佛教核心理论：缘起性空，本人觉得不难理解，就是万物皆由因缘和合而成，变动不居，究竟的说应是方生方灭。可本人身心依然不能有所证悟及受用，是否缘起性空还有更深更广的义理。

    dawa：
    一、既然“万物皆由因缘和合而成，变动不居，究竟的说应是方生方灭”，所以追求永恒的“身命”是不应该的。另一方面，变易的规律是善恶的因果报应。行善而得乐果，不知道算不算“安身立命”……
    二、这里面没问题啊……“诸法无我”、“缘起性空”是指，诸法因缘和合而成，无有“独立的自我存在”，即“性空”。“不生不灭”，俺真的不懂。但是说：无有“具自性的法”的生灭，总不会错。嘻嘻，这整个是“诸法无我”的翻版，哪儿又容得下真常论？
    三、成佛，就是摆脱了对“自我存在”的执著，能于因果流转中利益众生。佛陀不是“万能的”。所谓的“万能式的”绝对自由根本不存在。该话题，前一段有过讨论，可以看看旧贴。
    四、您的理解符合“诸行无常”，对“诸法无我”的理解可能还需要深化……还有一点，“有所证悟及受用”自实际修行得……仅仅是思辨，还不能“安身立命”。

    linden：
    这是学佛的人常会遇到的问题。
    一、“一切必将流逝，我们还能追求什么，还能凭什么安身立命？”
    ──世上不懂佛法真谛的人最怕空，听说什么都没了就容易发慌，这是普遍现象。其实学佛就是要学成得个无所得！我们的身、命只是补特迦罗相续中的一期，有什么好怕的？真要是一切无求，安心了，就走上正路了；就怕不能丢光，下世还得继续执着受苦。
    二、“诸行无常、诸法无我”指的是有为法，而“不生不灭”是指无为法，即有为法的法性，也即是空。色空两者相辅相成。这与常见无有丝毫关联。（另，你对“真常”二字的理解好像有误。）
    三、你对“究竟的自由即解脱”果然理解错了，自由是不昧因果的自由，是在戒定慧的行路上获得的解脱和自由，而绝不是超越因果的为所欲为。
    四、嘴说缘起性空易，事上承担难。你一天到晚起那么多念头，有多少符合缘起性空的法理呢？如果多数都符合了，又怎么会没有受用呢？

    智祥：
    凑个热闹，“诸行无常、诸法无我，一切都是缘起性空”，这是世界的真相，众生明不明白都这样。不碍着您追求的，求财的求官的不都求着嘛，求解脱求成佛也一样。诸法无自性，故能显现缘起作用。有生灭的是缘起作用，其自性无生灭。正是不落断常之中观正见！说落真常是自己不解。


阿罗汉入涅槃后，与他相关的因缘相续怎么说？

    大千：
    经中：“正如火苗被大风吹灭，已经消失，无以命名，牟尼摆脱了名和身，已经消失，无以命名……这样的人消失后，形量不存在，人们谈论他的依据不存在；当一切现象消失时，一切谈论方式也消失。”
    这都是指的有漏五蕴，必须对有疑惑的人说得很绝对才能彻底打消他的疑问。佛对小乘是不讲佛地境界的，这是对大乘弟子才说的。但是不对小乘讲，不等于不讲。

    二麻子：
    千兄，你这个回答里面，如果我们只在有漏五蕴里说话的话，是不是就默认什么也没剩下？老M说就是没剩这叫涅槃，当然我们不同意。但您这个答法至少有默认的嫌疑吧。
    佛说，阿罗汉涅槃非断灭。佛不会说错。就是在有漏五蕴上说话，也不是断灭。这是能说明白的。
    这问题不属于唯识专门，大千兄觉得需要不需要讨论下去一点？需要麻子就说两句一管之见。不需要就停下了。

    大千：
    我的基本意思是，有漏五蕴是断了，佛的报化身是无漏五蕴，当然这两者之间是有相续关系的，是在修行过程中慢慢地转染成净的。

    二麻子：
    不好意思……其实连有漏五蕴也没断，而且也不需要断。阿罗汉首先是断了我执，然后无余涅槃时，断的是补特伽罗我相续。但这个相续，只是与此原补特伽罗相关的相续中很小一部分。
    如烛火灭时，问“火哪里去了”当然是有问题。但说这火的影响（相续）就全没了，也是人对佛经的误解。请看，这烛火烤坏的油漆，会因为烛火灭而恢复原状吗？油漆坏了导致钢材锈蚀，最后塌了房子砸死人……这些后果，会因为烛火灭而消失吗？根本没这事的吧。嘻嘻。
    再如，假设你我跟一位阿罗汉学了解脱之法，后来，这位阿罗汉入无余涅槃，如烛火灭了。是不是你我所学的解脱法，从此就无效了？笑话嘛。你我还说不定常常要讨论这位阿罗汉师父的教法，怎么会谈不到？说不定将来还要把这些法教给别人。如此下去，相续不绝呢。
    嘻嘻，所以，就是在有漏五蕴里，阿罗汉入涅槃后，与他相关的因缘相续也没断的什么也不剩。不剩是不可能的，就如千兄所说，断灭那东西根本没有，证不到的。嘻嘻。
    至于涉及阿罗汉“涅槃后的”，这是非量了。“个体”不管假设净或不净的五蕴，都是生灭法。补特伽罗可灭。这点上南传说的并没错，具所有格的五蕴断了。麻子上面说的不涉及佛。


因缘法涉及无量因缘

    二麻子：
    因缘难测，但是毕竟善有善果，因果不爽。因缘法涉及无量因缘……而我们能主动干预的，在有限制的时间里是有限的，显然不可能绝对地确定结果。无量因缘的变化里包含太多的不确定性，所以，因缘法在任何一个果／事件现起前，都不能绝对保证一切细节都固定。所以说不定。
    任何一事物都与无量因缘相关，而无量因缘都在变化ing！也有是因缘法的特点。必然则成定法。

    为情所苦：
    宇宙中是否有不依因缘而生的东西？

    zf：
    有不依因缘而生的，但不是东西。

    nkdj：
    嘻嘻，请教赵叔，是什么不依因缘生？

    zf：
    看看这样说是否可以，有不是因缘生的，但不是东西。


俗谛与第一义谛的深浅

    QZ：
    想找无明，即在无明中。

    zf：
    在下浅见，想找无明，是破除无明的前奏。当学人只关注佛所开示之“成住坏空”“成住坏空”“成住坏空”……这一无始过程的一个环节“成”时，常误认为佛是在讲法界的起源。

    常如：
    我总以为真谛高，后来看到一句话，原来俗谛的道理比真谛更深。

    zs：
    这个……我是有点硬给拆开了……

    zf：
    拆开了说没什么不好，中观应成见对世俗谛和胜义谛的善巧安立非常殊胜，《中论·观四谛品》云：“诸佛依二谛，为众生说法，一以世俗谛，二第一义谛。若人不能知，分别于二谛，则于深佛法，不知真实义。若不依俗谛，不得第一义；不得第一义，则不得涅槃。”
    可见诸佛都是拆开了说。依龙树菩萨的开示，俗谛是入第一义谛之门，因此可知，俗谛浅第一义谛深。


“如幻”与“是幻无或是实有”

    iamfishers：
    给玄兹老兄，“如幻”与“是幻无或是实有”。
    我从这一阵子，玄兹兄的帖子中，得出一个推断：
  “玄兹老兄是这么理解‘如幻’的：如幻就是龟毛兔角。”
    不幸的是，大千兄的“……根本就没有”的说法，几乎就等于说是“一切世俗都是龟毛兔角”。有时候，我几乎认定：大千兄认为如幻就是龟毛兔角。
    按照我的理解，大千兄讲法中最主要的不足，就在于没有认真地在言语上安立世俗和世俗谛两者。
    我是从一个藏地修行者的传记中，对“如幻”有与原来不同的理解的。
    以前，我总认为，如幻就是一切都是幻觉。
    换一句话说，眼前一切都【是】不真实的；一切真实的，都【是】与我凡人现在所见毫无关系。
    这里面，我以前的理解中包含两个【是】。
    再换一种：凡俗一切【是】幻无，圣者一切【是】实有。
    这些个，是【我】以前的想法。
    然而，在传记中，我读到圣者不是这样表述的。
    首先，如幻就是无常、无我。
    其次，如幻不是凡俗幻无也不是圣者实有。
    再次，如幻就是实相在凡不减在圣不增。
    如幻同样可以表述有无，那么对如幻的有无的表述作用何在？
    其作用，不是确立凡夫没有而圣者实有。
    其作用，是修行路上一路到底的遮诠，换句话说，如幻，对六道凡夫和四圣道，平等成立。
    对于你我凡夫来说，我们都生活在【世俗】当中，一切都成住坏空、刹那生灭，这就是三法印中诸行无常的体现。这个无常，如果圣者生活在世俗当中，同样体会到，与凡夫平等无差。而大千兄通常回避这个问题，似乎释尊成道后从来没有到过世俗中间一样。我的意思是，圣者对世俗的体验，和凡夫对世俗的体验一样，都是无常、如幻。如果，大千要说圣者对世俗体验的是一颗颗心，实际上不需要这么安立圣者境界，如幻、无常就是这一颗颗心的真相，而且凡夫和圣者可以依据这个圣名言量来有效沟通，观如幻。
    因为大千兄没有意识到需要立一个世俗（而且这个无常的世俗本身已经直接体现了如幻），所以通常上来就把凡夫赖以支撑的经验世界，否定掉（归为龟毛兔角），而直接立起一个超验的圣者境界。这样，就掉入了凡夫不可知论。
    赵叔引圣教量说：如来开示，凡夫各各所知仅如大海之一滴。麻叔说：那不就是说凡夫可知嘛。
    或许有人没注意麻叔的意思：凡夫所知的真相也许很少，可是这大海之一滴，不是也有一点不可忽视的量吗？
    而这不可忽视的【量】确实由圣教量安立。凡夫并不是一无所知，比如可以感受到世俗的无常。
    正确地安立世俗，同样有助于三士道的学修次第的开展。凡夫是有具足的基础的。
    那么，世俗谛是什么？
    世俗谛就是基于凡夫对无常真相的那一点感受而契入圣教的教授。
    比如：有人[实执灵魂独立]，则告知生死轮回并没有死后安息不变的灵魂只有随业受报，有人[实执世界永久］则告知世界成住坏空并没有独立的外在世界永存只因众生法界各各业感如是。
    这种告诉，就是灵活地告诉什么是遍计执。
    并不是唯识学上那几句话才是遍计性的教授。
    凡夫也可以作[逝者如斯夫］的感慨，这种世事无常的感慨，引申起来，就是俺们凡夫实修无常的出离心修法。下士道的出离心，当然是对于我们凡夫而言。观无常这种观法本身就是世俗中的凡夫相应于真相的表现。
    世俗谛，就是告诉凡夫你的某某想法、态度，是错的。
    按照[如幻］这个立场，世俗谛就是对于观世俗无常的一个引导，也就是对于凡夫开始试图寻求解脱道的一个引导。再明确的说，对于你我凡夫来说，在初步寻求解脱道的时候，挖空心思揣测圣者的境界，并不是初学者应做的；告诉无知凡夫圣者甚深境界如何如何，也并不是一个教授者应该做的，即便你是圣者。按照严谨的教授次第，应该从给予求学者有关世俗和世俗谛的知识，开始做教授和学习。上来就说三界唯心万法唯识，实际上毫无实际的引导意义，除非特殊情况。对于你我初学者本身来说，探究字面上的句义，尤其是圣者究竟境界如何如何的字眼上作揣测，没有实际助益。
    如幻，作为一种实修方法，对于我等凡夫从世俗入道，是甚深的方便。
    般若经上讲，“须菩提知诸天子心中复作是念。语诸天子言。幻如人。人如幻乎。我呼须陀洹斯陀含阿那含阿罗汉辟支佛道悉如幻。正使佛道我呼亦如幻。诸天子语须菩提。乃至佛道亦复呼如幻。须菩提言乃至泥洹亦复如幻。诸天子问须菩提。乃至泥洹泥洹及泥洹亦复如幻。须菩提语诸天子。设复有法出于泥洹亦复如幻。何以故。幻人泥洹赐如空无所有。”
    因此说，如幻是甚深的教授，直至成佛，亦复如幻。如幻者，深矣，具足矣。
    我来把看似走题的帖子的线索，总结一下：
    麻叔静风那帖子，我问了麻叔，确实要安立世俗和世俗谛两者。所谓的安立，就是让前后讲法，不自语相违。也可以说，让世俗（凡夫）可以平滑进入（唯识的）世俗谛。
    为了表述这个平滑，我就把“[如幻］在世俗和世俗谛中都平等包容，且一直包含到成佛……”这样的情况，说清楚。
    很突兀地告诉你：[绝对别业］不是什么胜义谛的表述，而是在世俗（注意不是世俗谛）上取得凡夫共许的基础上，然后依据这种（世俗与世俗谛之间）内在的平滑，导入唯识无境的世俗谛。
    分析如下：
    “于是，唯识学没有明确说出来的起始点‘绝对别业’，就是对具体一个凡夫学人来说自己能追寻到的最基本的有情活动。”
    够凡夫吧。
    “所谓凡夫‘及识而还’，就是说到了这种地方就不再能深入了。由于未被否定的那些里面很大部分是指有情具备的分别能力，所以，说有能（力）无（推断出的）所（境），也是一种相当合理的，属于如幻有范畴的表述。”
    对于凡夫说的：有能无所＝唯识无境＝自心取自心。
    因此也可以看出，唯识无境，总是被拿作向凡夫做教授的。而且“带执着是凡夫的特征，凡夫在上述的推断过程里无一不加入大量的自性见执实有，所以一般也称为遍计执。但对于圣人，他们确实可以为了交流方便而做同样的推断却完全不落入执着。所以有时说遍计不说执也有其合理性。”圣人也可以用世俗方法，是吧。那么，从世俗到世俗谛，不是那么玄虚，是吧。完全基于凡人的经验，为什么要玄兹兄推出自相否定呢？原因估计：玄兹老兄把麻叔的帖子，当作一种[特殊的、对真实境界的揭示］来看了。

    二麻子：
    相当准确……渔夫说的唯一一点不同处，他是用中观的习惯用语说话的。俗、俗谛、圣谛的划分，在唯识里不像中观里那么界限清晰。原因是中观用的共许是凡夫的共，而这个共是不可能容纳圣人证量的。所以，圣者的证量要别立。唯识虽然有相似处，但唯识学人从完全凡夫开始修，在别业条件下说话，是渐渐趋向圣位的。这里没有截然界限。所以，这些谛界限就不那么明显了。
    虽然不那么明显了，必要的理清还是需要的。否则话就都说混了。


细心防护自己别在不知中偷换立场

    二麻子：
    给常青兄，不是回答的回答。你贴子我跟不上，只好回在这里。
    常兄问题一堆，其实是一个。根本来讲，你问的就是无明从哪里来的，不过换了个形式。嘻嘻。麻子没时间详细回答你。下面是个略答。
    你问题中有个重要现象：有些话是圣者说的，或说，站在圣者立场上说的；另一些话则典型是我们凡夫说的。你说的矛盾就出在你不知不觉中，在两个立场上转换。
    比如显现是无过的，这是站在圣人角度说。对圣人来说，凡夫们执法，也没什么是非可得。但对凡夫执着的人来说，这个执着是大问题。
    所以，你若细心防护自己别在不知中偷换立场，这些问题大多不存在。

    鸟巢：
    请问，跳出三界外，不在五行中，落在什么处？

    二麻子：
    嘿嘿……这是什么话！
    禅宗有句老话“菩萨子，警醒着，莫被别人瞒”，麻子这里还续个貂“也莫被自己瞒”。
    “落处”是三界内，“内外”都是三界内，问这话的哪跳出过？
    用密宗的习惯语，这叫自语相违。用圆觉经的话，这就是“彼圆觉性亦同轮转”。用禅家的话，那就都不好听了，就算了吧。

    鸟巢：
    境则心不显。涅槃是境吗？

    二麻子：
    不是！

    鸟巢：
    那是什么呢？不生不灭到底还是有个生灭在流动啊，解脱的实意在哪里呢？

    二麻子：
    想听难听话吗？

    鸟巢：
    可以。
￣￣￣￣
    二麻子：
    切勿……以一己一时之推断，强解圣意。
    你完全不解无生。要知道这个得花些基础功夫。
    南传的不受后有，是理解无生的一个方面，方法，学之有益。大乘的当体无生更高明，但也更难懂。
    画饼怎么了？从对饼一无所知开始，由画饼，看配方，造饼，到吃饼。你能跳过哪步去？切勿用六祖做比，六祖对没见过的经是一读就通的，你我大概差太远。
    你我跳过的结果，就可能是用沙子去做饼了……

    鸟巢：
    释迦佛今何在？念佛往生西方，不念佛往生什么处呢？

    二麻子：
    不在什么地方……你实在是离不了边见。在思维上都离不了。不念佛的人多了，受生无定处。

    鸟巢：
    那还解脱什么呢？解脱到什么地方去？心不能脱离境而有啊。

    二麻子：
    解脱执着，解脱自欺。

    鸟巢：
    我就试着说一句口头禅：“无用心处”。

    二麻子：
    嘻嘻……若说究竟，确无用心处。不过对我们来讲，现在说这个可真是画饼了，只是说说而已。不如把基础建牢点，将来学会如何不用心。
    这个吗……麻子也不是什么好听话……佛经里讲的见精，你肯定说，就是你闭眼时的能见？
    嘻嘻，那么熟睡无梦时，你的见精还有吗？没了？生灭法了？还是经里说的那个不是了？所以劝你别以自己一时推论去……顺道提句，你这个想法下去，很容易落在常见上的。
    “原来不是解决得了解决不了的问题，而是根本就没有问题。”
    嘿嘿，这话可唬人了。没问题佛陀出世干什么来了，闲腻了？
    看仔细：根本是没问题，但那是佛陀证的，不是我们。
    我们凡夫就是有一大堆没解决的问题，需要努力解决。不信就看你今天这顿折腾，怎么说没问题？你今日之折腾，不正说明你前面这帖子，不过又是“一时的推论”？

    鸟巢：
    “不用心”还用学吗？嘻嘻　￣￣￣￣

    二麻子：
    哈哈……真正外行话……让你学也不是你三年学得会的。除非你把街上行人的杂乱执着心，定义成不用心。哈哈。

    鸟巢：
    解脱又解脱到哪里去呢？……我家附近的街道有个屠宰厂，我有时常常从那里过，这几日就突然的想到“生死”两字，就被生死闷住了，佛是了脱生死的，不知这生死怎么了脱？涅槃，涅槃到什么地方去？如果说涅槃是无，那么就是子虚乌有还说什么解脱呢？如果说涅槃是有，那么释迦现在在哪里呢？解脱又解脱到哪里呢？我翻遍了书籍，也无法找到答案，已经几天了。请哪位师兄帮帮我？

    二麻子：
    好问好问……这一问比较实在。问题有两类答案，一类在南传教法里，一类在大乘教法。具体对你现在，麻子的建议却是先看南传教法里，阿罗汉不受后有是个什么意思。也省得继续为涅槃圣人找三找四。

    鸟巢：
    什么是阿罗汉不受后有？哪一类大乘教法？

    二麻子：
    请去读阿含经。

    鸟巢：
    此事还属修吗？

    二麻子：
    读经属于修的一种。

    鸟巢：
    读经属于修的一种。密意是什么？

    二麻子：
    麻子没密意……你的问题经里有现成答案。基础不做好，就会首鼠两端！嘻嘻，麻子歪用成语。不过，兄弟你实在是在两端跳来跳去。

    妙文：
    依鸟巢的缘起！和麻叔探讨个问题！我体会是真心恒在生死涅槃中，是十方诸佛真身，我们所见释尊是此真心慈悲愿力所现化身，阿弥陀佛也是如此，报化二身皆非真，接引众生妙用身。我们在依生死身修时，思想念头一断，明明朗朗是何者，他无能也无所，生死关头，识得此，常寂光中无所惧，他无生也无死也无涅槃之所得！此中当记唯一事，父母虽幻在苦中，恒现幻身孝父母，生死现身无尽期！

    二麻子：
    嘻嘻，探讨可以，只是麻子还没看明白……能先说明一下你熟睡无梦时，那个明朗在哪里？这里麻子只想说明，你说的那个明朗，还远没到。既有生灭，当然不度生死。若说是浪花当然也是，却与其他浪花同，没什么可特别的。禅宗有话“知之一字众妙之门”，后又有话“知之一字众惑之门”，为什么？就是这地方差之毫厘谬以千里，行人于此犯错的极多。
    其次，能不能告诉我，这个真身是一人一个还是大家公用一个？嘻嘻。说是有一就很容易落入细微常见。佛法不二，不说“有一”，为什么？有一就容易隐藏了二。妙文兄似乎应该把这个地方给自己清理得更明白些。


慎对“虚妄”

    小潘：
    佛经中说：“凡所有相，皆是虚妄”！可是为什么，佛弟子在拜佛之前，一定要右绕三匝或者多匝，而不是相反方向呢？另外，绕佛是表示什么意思呢？请诸位法师大德不吝赐教！末学先拜谢了！！！

    zf：
    小潘兄，问题的关键是把握“虚妄”的确切含义。
    水相是虚妄的，饭相也是虚妄的，可是我们一日不吃不喝便受不了。当然“受不了”相也是虚妄的。可是如来却并未让我们抛弃虚妄的水饭，去忍受虚妄的饥渴。就是如来在开示“凡所有相，皆是虚妄”这一法义之前，也要入城乞食的。可见对“虚妄”之事，绝不是采用一概抛弃这样简单的处理方法。
    龙树菩萨于《中论》中开示，如来为众生宣示解脱的方法，都是同时宣说“世俗谛”和“圣义谛”两种真理。我们在学习时，一方面要明白二谛的各自含义，另一方面要搞清这二谛之间相辅相成、互不矛盾的关系——这一关系被宗喀巴大师称为“诸佛究竟密义”，可见其重要性。
    关于二谛的含义，建议您多读些书，别指望别人三言两语就讲清楚。
    关于绕佛的方向和次数，我想形式是次要的，最重要的是所表达之对能引导我们解脱的导师的由衷敬意。
    当然，敬意也是“虚妄”的，但“虚妄”的敬意，能引导我们对“虚妄”痛苦的“虚妄”解脱，因为没有一个有情愿意忍受“虚妄”的痛苦，虽然有情和忍受也都是“虚妄”的。
    请小心谨慎地对待“虚妄”。


观念上的割裂

    观念上的割裂

    二麻子

    静风兄说：“观待缘起是应成所许的最深的缘起，其本质就是诸法不是从他那一方面而自有的，而是从我们意识方面观待他们，然后安立名言而有的。”
    这话什么意思，比如桌子，电视机是怎么安立名言而有的？静风兄这里把应成中观见里缘起安立的核心问题说出来了，这非常有价值。不过静风兄显然有些话说得比较“专业”，不熟悉背景的人不大容易看懂。
    为说明问题，麻子用黄海做例子，因为这个例子对“自有”“自性”等比较有破坏力。
    世上本来谈不到什么黄海，不过是大家同意从大洋里划分出一块水域，在观念上将这块水域与大洋其他部分割裂开来。然后，起个名字，就算有了黄海。这个过程里明显可以看出，黄海不是自己能有的，而是由意识割裂（观待）因缘法，当割裂到可以安立名言的程度时，可以说就“有”了，然后具体安立名称，说话就方便了。应成见说“名前绝无”的意思并不是说“不起名字就没有”，而是说当意识对因缘法的割裂到了可以命名的程度时，也就是观念上认为一法“有”了的时候。
    这种安立名言本没什么不好。问题是凡夫就此生自性见，觉得黄海似乎是独立于大洋之外的存在了。但是事实却是不管怎么以为黄海独立，黄海还是跟大洋紧密相连，割裂不开的。任何一法的安立实际上都是与上述类似的割裂过程，其差别仅在于割裂中造成“独立自有”错觉的难易程度有所不同。
    在麻子看来，静风兄那段话的意思大致就是这个例子说明的。此外，有几个推论值得继续说明一下。
    一、任何一法都是不可能与环境割裂的，要完整地全面地了解任何一法，都必须将周围的因缘作用一并考虑。这种关系在不论多大的尺度上都对，所以，对任一法的考察必然导致全局性的法界观。这可以简单地说成“因缘法不可割裂”成为导向法界缘起的过渡。因缘法不可割裂故，一粒沙子与法界平等不二。联想到ZF兄在莲舟讲述过他从“空性不可割裂”导向对华严法界观的过渡。两者是相似的过程。
    二、如上所述，名言的安立实际是与有情的作意割裂有关系的，这与一般人对应成中观见里俗有的认识有相当距离。一般认为，应成的俗有是有相当（相对）的客观性，而很少涉及俗有与作意的关系。但实际上，如前所说，应成见里最细微深入的缘起与有情作意关系紧密。所以，中观与唯识间的距离，未必有一般想象的那么大。实际上上述作意割裂安立名言并执自性见的过程，正是唯识学所说的遍计执过程。
    在赞同了静风兄那么多论点之后，麻子也指出一个自己不能完全赞同静风兄看法之处。由学习应成中观见而能得到对如上所述的缘起法深细认识，足见应成见的伟大。但如果说只有应成见才能达到这样的程度，麻子却只好说“＠＊＃＆＊＃＠（”了。嘻嘻。


名言安立的界限

    名言安立的界限

    zf

    门外汉的评说谨供参考。对唯名含义的界定，我想最权威者应该就是龙树那著名的四句偈了：“因缘所生法，我说即是空，亦为是假名，亦是中道义。”这里十分清楚地肯定了唯名而有的准确含义就是无自性的缘起法。假名者，否定的是法的自性，而不否定作用。我想这应该就是名言安立的界限。
    龙树菩萨的“三是偈”所开示的真义是：缘起即空、即假（名）、即中（道）。既然缘起就是性空就是假名就是中道，因此，缘起能破断常等戏论，性空、假名、中道必然同样也能破断常等戏论。那种认为缘起只能遮止断边不能遮止常边，或性空只能遮止常边不能遮止断边的见解，显然与缘起即空即假即中的正见相违。
    兄说的“世间共许，名言识可以堪忍，三是胜义识可以堪忍”，这是善巧安立世俗谛的条件。在下浅见，只有无明的所缘──“自性”为胜义识所不堪忍，而缘于“自性”而起的痴及贪、嗔等染法都是无自性但有作用的缘起法，均为胜义识所堪忍。苦谛是缘起法，安立苦谛之法与安立其他缘起法并无差别。
    胜义中不是不见一切法，而是不见一切法之自性。染法和净法在缘起无自性方面平等无差别，其差别体现在作用上，一者指向轮回，一者指向解脱。
    如宗大师所说：“故无尘许自性之自体，然能许可能生所生、破立等生死涅槃一切建立，是乃中观之胜法。”
    这里生死（染法）、涅槃（净法）的安立毫无问题，因为此染净诸法均空无自性。在下认为染净法的安立皆为胜义所堪忍，而染净的区分应视其作用而定。


所谓相互作用，也就是一种割不断的因缘

    zzzm：
    以应成见看，自识、他识也不过是方便安立而已，它们之间的相互作用、影响，是不是应该和缘起法之间的作用相同？而且也应该是不一不异、一多互摄的呢？
    还有“当割裂到可以安立名言的程度时，”这句话麻叔是否还可以再作一点解释？

    二麻子：
    是这样的……
    “以应成见看，自识、他识也不过是方便安立而已，它们之间的相互作用、影响，是不是应该和缘起法之间的作用相同？而且也应该是不一不异、一多互摄的呢？”
    ──当然如此。所谓相互作用，也就是一种割不断的因缘，识与法界也同沙子与法界，都是平等不二。

    “还有‘当割裂到可以安立名言的程度时，’这句话麻叔是否还可以再作一点解释？”
    ──比如黄海。如果你不在大洋里划分出一块水域来，就没法命名。再比如草原，随手一指，说“那片地方”，对自己可能是清楚地有所划分，但对别人就谈不到了，所以没法对众起名字。这就是割裂的程度不够。

    zzzm：
    多谢麻叔解答。既然一多互摄，那很自然就会得出一识中含摄所有有情的识。那为什么您觉得这个说法很勉强，后学觉得这种说法，应该比识外有识更圆融些，更接近实相。或许您的意思是说这种含摄方式不像我们通常想象的那么机械？
    由于诸识互相含摄，也是种子相互共有，而不是互相独立的。由此也可得出一切都是本具的，比如赵叔说的，众生含如来藏，如来含众生藏，只是显隐不同罢了。所以，一具一切，本来平等。那，这样认识您觉得有什么作用呢？笑嘻嘻。
    还有个问题，您别笑话俺。缘起性空是一也是异，在认识空性和法相（姑且这么称吧，但愿您知道后学要表达的意思）的不可分别性上，一般人是不是分开来认识的？是否存在难易的差别？这个差别与理无碍、事无碍的差别是类似的吗？不好意思，说的太乱了。

    二麻子：
    一多互摄是没错的……但这并不等价于沙子里面要有整个法界的复制件。

    常青：
    在唯识中，安立前七转识和藏识的名言，那个观待缘起的过程在唯识中似乎讲的更详细：第七识执第八识的结果，这在理解上似乎是更容易上手（麻老同意吗？）──但是却可能会造成：

    阿陀那识甚深细
    我于凡愚不开演
    一切种子如瀑流
    恐彼分别执为我

    我们一般都是见甚么，执甚么的。
    唯识和中论真是各有千秋。

    二麻子：
    这个麻子完全没异议……佛说一切法为治一切心。对不同病开不同药而已。哪个更方便实在要看具体个人情况，中观唯识实在是各有所长。

    zs：
    嘻嘻……其实心行上到这一步并不难──只是这是两步，一般人没注意罢了。第一步，确立分别，也就是十二缘支中[名色］这一步，这里的[名］是心法。
    第二步，为了认识方便或和他人沟通需要，起名字。很多人把这个起名字当成了[名言有］了。


观待等诸词集备忘录

    观待等诸词集备忘录

    【观待道理】【法相辞典】
    瑜伽二十五卷九页云：云何名为观待道理？谓略说有二种观待。一、生起观待，二、施设观待。生起观待者：谓由诸因诸缘势力，生起诸蕴。此蕴生起、要当观待诸因诸缘。施设观待者；谓由名身句身文身、施设诸蕴。此蕴施设、要当观待名句文身。是名于蕴生起观待施设观待。即此生起观待施设观待，生起诸蕴施设诸蕴，说名道理瑜伽方便。是故说为观待道理。
    二解　瑜伽七十八卷二十页云；观待道理者：谓若因、若缘、能生诸行；及起随说。如是名为观待道理。 　　三解　显扬二十卷十五页云：若由诸因诸缘故，诸行生起；及随显说；是名观待道理。
    四解　杂集论十一卷八页云：观待道理者：谓诸行生时，要待众缘。如芽生时，要待种子时节水田等缘；诸识生时，要待根境作意等缘；如是等。

    【分别】【法相辞典】
    瑜伽十三卷十八页云：云何分别？谓想蕴。
    二解　瑜伽七十二卷五页云：何等为分别？谓三界行中所有心心所。
    三解　瑜伽八十三卷十一页云：比量为依而起寻求，说名分别。
    四解　瑜伽八十三卷十二页云：分别者：谓略说已；分别开示，解其义趣。
    五解　显扬六卷一页云：分别者：谓三界所摄诸心心法。

    【增益见及损减见】【法相辞典】
    杂集论一卷十四页云：问：如是五见，几增益见？答：四、是增益见。于所知境，增益自性，及差别故。于诸见中，增益第一，及清净故。谓于五取蕴所知无我境，增益我我所自性；是萨迦耶见，增益我常无常差别；是边执见。于诸恶见，增益第一；是见取。即于此见，增益清净；是戒禁取。一、多分是损减见。一多分者：由邪分别，不必损减故。

    【安立思择】【法相辞典】
    无性释八卷二十一页云：安立思择者：谓从此出，如所通达，为他宣说。是故说名安立思择。

    【名言习气】【法相辞典】
    成唯识论八卷七页云：一名言习气。谓有为法各别亲种。名言有二。一、表义名言。即能诠义音声差别。二、显境名言。即能了境心心所法。随二名言所熏成种，作有为法各别因缘。

    【名言熏习差别】【法相辞典】
    世亲释三卷十九页云：名言熏习差别者：谓眼名言熏习，在异熟识中，为眼生因。异熟生眼，从彼生时，用彼为因，还说名眼。如是耳等、一切名言差别亦尔。无性释三卷二十页云：名言熏习差别者：谓我、法、用、名言多故；有人天等我，眼色等法，去来等用，熏习差别。由此我法用影显现，诸识生起功能差别。

    【安立真如作意】【法相辞典】
    显扬三卷九页云：四、安立真如作意。谓如前说，乃至于染污法体，思惟苦谛。既思惟已；欲令知故，为有情说。

    【如幻喻】【三藏法数】
    谓如幻师，幻作种种诸物及男女等相，体虽无实，然有幻色可见。一切诸法，亦复如是。无明幻作，迷心不了，妄执为实。修空观者，于诸幻法，心无所著，皆悉空寂，故说如幻。（空观者，谓观一切法皆空也。）

    【业力】【佛光大辞典】
    善恶之业有生起苦乐果之力用，称为业力。一切苦乐之果皆因业力所致，故通常有“业力不可思议”之语。有部毗奈耶卷四十六（大二三·八七九上）：“不思议业力，虽远必相牵。果报成熟时，求避终难脱。”（（参见：业）

    【显现变异分别】【法相辞典】
    世亲释四卷十七页云：显现变异分别者：谓眼识等、显现似彼所缘境相、所有变异。缘此显相变异分别。此亦如前所说老等种种变异。由此亦于老等位中变异起故。无性释四卷二十五页云：显现变异分别者：谓由眼等所依根故；令似色等影像显现。眼识等识、种种变异。即于此中，起诸分别。即如前说老等变异、随其所应而起变异。何以故？如说眼等、根有利钝，识明昧故。如无表色，所依变异、彼亦变异。由乐受等变异亦尔。如说乐者，心安定故。如说苦者，心散动故。贪等逼害时节代谢变异亦尔。捺落迦等及欲界等依身变异，识亦变异。如应当知。无色界中，亦有受等所作变异诸识分别。

    【显现甚深】【法相辞典】
    世亲释十卷五页云：颂曰：众生罪不现，如月于破器。遍满诸世间，由法光如日。此颂显示显现甚深。若诸世间、不见诸佛，而说诸佛、其身常住；佛身既常；何故不见？众生罪不现如月于破器者：如破器中，水不得住。水不住故；月则不现。如是有情身中，无有奢摩他水；佛月不现。水喻等持。体清润故。遍满诸世间由法光如日者：谓今世间佛虽不现；然遍一切施作佛事。由说契经应颂等法，譬如日光，遍满世间，作诸佛事，成熟有情。

    【舍离想受境界智明】【三藏法数】
    谓菩萨以善巧智明，于一切想念受用境界，悉能舍离，是名舍离想受境界智明。

    【微言大义极明灯·心要经密咒乘义释　摘要】
    师利星哈大师　造释　张志佛　由英译汉
    “复于尔时圣观世音自在菩提萨埵萨摩诃萨埵，行甚深般若波罗蜜多时，照见五蕴体性归空。”谓于时导师安住真实寂境，主众圣观自在自然安住。“菩提萨埵”者，外义谓依有学位；内义谓十地以上自在；密义谓甚深义自身。复次，菩提萨埵成就自利，摩诃萨埵成就利他。“圣”之共　义谓超越轮回苦趣；别义谓报身眷属；极不共　义乃谓觉性精义，即法身者。以自利故俯视内“观”，谓自明义；为利他故外“观”，谓善能教导诸般根性徒众；是故，彼等为自他轮涅之王，此其名义也。以经教之智，行者得以分别轮涅；以觉性之智，能了其义；以无观待智，诸法不二；故超越轮回，离诸苦恼而悲心显发。彼“甚深”以其体性不显为物故；彼甚深以其难言晓故；彼甚深以其超因果故，唯证方知。“行”之义乃涵泳此义，是故照见实性不假观待。照见之境乃诸蕴聚，五为其数。“五蕴”者，共五蕴乃色等五；别五蕴乃五部佛；五蕴自性乃五胜智，诸蕴体性清净。由观照而证具清净之行者，乃已入修道次第者，具信者。观诸法无有自性即为了义；极真实之义乃空性；“空”性之义乃观诸法空，非谓彼中无此；无生空性乃觉性本体义；物坏之空仍为微尘；诸法与境无有自性方为真实义；如是智慧不假观待方为“照见”义。

    【《宝聚续》摘录　转引自龙钦饶绛尊者实相宝藏论释　郭元兴译】
    呜呼！语金刚！自亦应听，观待法性空寂周遍智，无生本来俱安仁真希奇，士夫所诠极锐利而诸众生于一时得解脱，然彼补特伽罗之一续则无损益，哈哈！


无自性、无自性性和缘起法

    疑问1：
    请问无自性性是常还是非常，是有还是空？
    如果是常，有，那与外道所说的永恒不变的神我有何差异，如果是非常，空，那又与断灭论有何差别。

    zf：
    缘起法的法性从否定的侧面说可以用“无自性性”、“空性”等表述，即对凡夫自性执的否定；从肯定的方面说可以用“真如”、“圆成实性”、“实相”等。这里肯定和否定的角度虽然不同，但表达的意思不二。
    由于无自性性或真如不是有为法，因此常、断等对其根本不适用。
    外道的神我一方面具有创造者、决定者的含义，而缘起法性空，根本没有给神我留下任何余地；另外，在某些外道中，神我还有“不可思议的有”的含义，对此要特别留神，“无自性性”、“真如”等不但绝不含有类似的意思，而且是对此“不可思议的有”的彻底否定。
    断灭论是对缘起因果格格不入，而“无自性性”否定的是自性，与缘起无碍。

    疑问1：
    您提到在某些外道中，神我还有“不可思议的有”的含义。我记得好像有种外道说其真神遍一切处并出生一切法。不知这与六祖的“何期自性能生万法”的说法区别在哪里？虽然这是禅宗大德的说法，但我觉得华严宗的祖师们对这类问题应当也有相关的开示吧，不知他们是如何说的，您能给我们说说吗？
    另外，您说的“‘无自性性’否定的是自性”中的这个自性又是什么意思，是“无自性性”的自性还是其他什么东东？请开示。

    zf：
    我理解，“自性”就是诸法不依赖于因缘的自我决定性。
    如果“生”是指缘起，则法不是以真如为因生起的。
    另外，您的上述说法和我所要表达的意思有细微差别。
    如常随佛学兄所说，不同体系的“语言”并不相同，有时以一个体系的语言去理解另一个体系会出错。在下无意也无力去圆融各个体系。
    从缘起法的基本定义“此有故彼有，此无故彼无”来看，这里的“此”和“彼”都是法。
    因缘法当然还是从因缘法中生起的。真如是万法的法性。
    若任意一法不是性空的，不如梦幻空花，一法怎么可能具足一切法呢？？？！！！

    疑问1：
    关于不同体系之间的差异问题，我觉得只是对同一事物所用的名词不一样而已，实际上他们的观点应当是相同的吧，那么像六祖的这句话我们绝不能视其为错，但他所说到底是何意思，不知谁能解释一下。
    您说一法具足万法我相信，但您说无性性（真如）不具足万法，我就糊涂了，您能详细解释一下吗。如果说一法具足万法，能生万法，那么虚空如何生起受、想、行、识？

    zf：
    仁兄，论坛是交流心得的好地方，但这种交流代替不了系统的经论学习。如果对相关背景没有深入了解，讨论也很难有效。
    例如，如果说真如具足万法，这里的“具足”是何义？如何理解无为法具足有为法？？
    另外，仁兄真的理解“一法具足万法”之义吗？若如是，如何从此中推演出“一法能生万法”？这里的“生”是何义？（在下不是反对“一法能生万法”的表述，但采用此说时要特别注意“生”字的确切含义。）

    疑问1：
    因为您前面说过无性性（真如）不具足万法，而是一法具足万法，那么万法依何而生，以何为体性呢？若说以真如为体性，但真如不具足万法，既然是一法具足万法，那当然是一法生万法了，不知是否如此。
    还有，不是说一切唯心造吗，那么此“心”是什么，应当是指真如、无自性性、如来藏性清净真心吧，既然此“心”不具足万法，那它又是怎么造万法、凭何而造万法呢？

    zf：
    如果这样的猜测多了，问题就复杂了。
    不知您的这些猜测有何依据？
    在下理解“一切唯心造”是说：一切法都是心之业力所造。


法与法性

    gladness：
    麻叔，我对心经并不是太理解。您能给讲讲，“空中无色”和“空即是色”吗？我目前的理解是，空性不是法，但空性与法不离。法不是空性，但法与空性不离。一切法都具空性，但空性中没有法。

    二麻子：
    把法与法性绝对割裂是给自己找麻烦呢。说法，法性不一是方便，说法，法性不异也是方便。断然隔裂却大大不方便。
    对呀。色即是空，怎么还别有空？所以色中（别）无空！

    无畏持明：
    离开色去找空或寻找安立的空性即使找到天边也无此空。

    二麻子：
    是也是也。无畏兄说的是。
    就是这问题。很多人无意中就把空当了虚空，而色是虚空里的物质。嘻嘻。这样看就感觉空比色“大”。然后再认为色是幻相，只剩下没有物质的虚空，所以空中无色……
    这样的“空”离色别有，可惜，这个空不是空性而是彼彼空，为凡夫心的恶取（见楞伽经），当然找不到的。

    gladness：
    谢谢麻叔。我还是有点糊涂。这么说行不行，法性并不是一个存在哪里的“东西”。所以不能说法性中有法。

    二麻子：
    把法与法性绝对割裂是给自己找麻烦呢。嘻嘻。仔细体会一下，你们前面谈的有没有……是不是都在说“别有”及其反面呀？

    gladness：
    可是，咱还是没有转过弯来。末学的思路：一切法无自性，一切法都具有无自性性，即法性。此法与彼法的法性不可分别。法性是法的性质。所以没法说法性中有什么。问题在哪呢？

    二麻子：
    这是你对法性没看全……你说的都属于空性。但全面吗？空性仅仅是你说的这一点吗？空即是色在哪里？

    局部与全局……

    “法性是无自性性。‘空性不离一切，一切皆空性’，这里前面的‘一切’，应该是一切法。后面的‘一切’呢？如果也是一切法的话，就成了，一切法都是空性。那么，一切法皆是缘起的。是不是得出，空性也是缘起的？目前个人的理解，是把‘一切法皆空’理解成为，一切法皆是无自性的。是把这个‘空’当成形容词，而不是名词。”
    ──上面的“一切”不是全局概念，一切法皆空是说任意一个法都是性空，对吗。这里的一切法是局部概念外延。空就是一切法，这个一切是全部法，所以空是全局概念，两个范围不一样吧？

    有局部空性吗？不，空性不可分割。所以，当你从缘起推回空性的时候，偷偷地，你自己也不知道地，就将局部概念偷换成了全局概念。就出来空性也是缘起的这样的怪论。说他是怪论是因为这地方怎么说都不成立。说空性是缘起非缘起都有问题，空性根本不是这样的。因为连“全局”这个词都是我们凡夫胡来的妄想。法界有全局吗？这些地方说明，如果我们死抱住凡夫思维习惯去想，这种问题到处都是死胡同……

    局部与全局的讨论我从前有过帖子。一时找不到。


因缘的不可分割、空性的不可分割

    无言：
    时空与物质、与因果，皆是空性显现，凡显现必属因缘法范畴，而因缘显现不违自性空，由于空性的不可分割性，因缘法亦是不可割裂的。

    dawa：
    因缘的不可分割、空性的不可分割都是入法界的方便。其实俺觉得因缘的不可分割更直接些。

    二麻子：
    这真的要看你说的“直接”是怎么个定义了。空性不可割裂与因缘不可割裂，如同你说的一样，的确都是一种引导方便。其路线大致如下。
    一、因缘不可割裂。从我们凡夫思维开始分析因缘法，深入细微下去，直到思维极限，这大致是在名色支的地方。因为再往下的行支不是多数人能看到的。然后，指出不能停止在这个极限。用这个引导的好处是上手相对容易点。到达上述极限时候，虽然不能这就实证空性，更别说马上就入法界，但是根据从开始思维到抵达极限的这个方向，很多人可以对入法界有一个推断的间接的“味道”与“感觉”。虽然这个东西不一定准确，实际这个程度时候也不可能真的准确，但对大方向有判断了，也很殊胜了。
    二、从空性不可割裂开始，则没有很多话要说。就已经到达极限。所以这个其实更直接。但是，因为没有很多过程，除了已经对空性有所直接体会的人，多数人也不容易从这个引导里，对入法界产生直观感受，所以就更难点。
    三、对缘起性空如果有直接体会，那么这两个引导的后面是一样的。嘻嘻。

    无言：
    我想dawa师兄“直接”的意思更准确的说是不是指麻叔说的“上手容易”，还想请问麻叔，在这些个引导方便之后该如何做呢？因为毕竟这些时候没有准确的对法界有直观感受。

    二麻子：
    因为靠常规感觉不能体会／悟空性。所以，后面那个还是逃不掉要靠契入空性才行。


缘起性空入于一切众生心想中

    panzk：
    请问麻叔一个问题，这个问题困扰末学很久了，也不知道问得有没有意义！还请麻叔不吝赐教。问题是这样的：
众生的六根对应着外面的六尘，自心蒙尘而不能见。为何《观无量寿经》又云：“十方诸佛是法性身，入一切众生心想中”，末学对佛经所言，即当信受，不敢有疑，只是其中的妙理不明。诸佛法性身即应是清净身，云何入众生的妄心中的法尘中呢？如何理解呢？

    二麻子
 噢……小小误解而已。这经文的意思，不是有个清净身跑到众生妄心的法尘里来了。而是说，众生的妄想心处处也没离开过法性。如何法性？缘起性空是。众生妄想心难道不是缘起性空吗？所以如果改说成，“缘起性空入于一切众生心想中”，你是不是就不觉得别扭了？


应观导师体，即法界法性

    zf

    供参考：
    “应观导师体”——应观导师（即佛）的体性，
    “即法界法性”——即是法界的法性，
    “法性非所识”——法性并不是眼耳等诸识所缘之色声等法，
    “故彼不能了”——因此以色见佛、以音声求佛的方式是不能“见”真佛——佛之体性，即法身、法性。
    建议先学缘起正见，然后在正见的指导下正思维。


入中论之一颂

    齐愍：
    月称论师造《入中论自释》云：
如器有异空无别　诸法虽别性无差
    是故正知同一味　妙智刹那达所知
    如瓶盘等器虽有差别，然彼上之虚空毫无差别，同无碍故。如是色受等法虽有差别，然彼上之真实义，无生为相，亦无差别。是故当知此真实义唯是一味，此复唯以一刹那智周遍了知。故佛世尊，唯以一刹那智而得一切智智也。

    智祥：
    此偈原意还是描述见道时如水入水现证空性，一刹那间得一切智智。

    zf：
    智祥兄好眼力！兄所说之“此偈原意还是描述见道时如水入水现证空性，一刹那间得一切智智。”，在下完全同意。
    从“如”的无二无别上统合应成见和如来藏见正是在下上贴的本意。此点华严古德早已完成之。
    法之一味之说，确已不是应成所见。
    “利根者于一刹那间得一切种智的可能亦不可排除。”确实进得远了点……
    应成见和如来藏见表面看起来确有些地方难以沟通。华严古德在两者之间建立的桥梁就是“如的不可分别性”。
    藏传所重之《宝性论》中对此亦有相同的论述：“佛法身周遍，真如无分别，具佛性有情，说有如来藏。”在下理解，这里所说众生具有佛性、如来藏的依据就是“真如无分别”。但不知为何，藏地古德不似华严古德在此大作文章。

    智祥：
    谢谢您的回复，上贴是因为有师兄提示询问格鲁自宗的看法才在半夜匆忙写就的，早晨醒来觉得没有做好在此深入探讨的准备，所以删去了，没想到还是被您看到了。：）

    zf：
    智祥兄，格鲁一宗博大精深，在下虽然对格鲁教义知之甚少，但心中仍将宗喀巴大师视为自己未见面的上师，本人对空义的抉择主要依大师的论著为标准。在下曾对别人说过：莫将宗大师仅视为格鲁的宗大师，宗大师是所有佛子的宗大师。
    杜顺大师之《华严五教止观》，篇幅虽短，但具统摄如来全部教法之气势，用心研读，必有收获。
    我相信，主修藏传佛法者读一点汉地古德的论著会有好处；同样主修汉传佛法者读一点藏地古德的论著也会受到启发。


关于在因缘当体体会性空

    关于在因缘当体体会性空

    二麻子

    “我们大多将莫名其妙看成不可思议，对于凡夫来说，莫名其妙的是因缘的‘用’，这种莫名其妙是因为执著于因缘而导致糊涂。”
    ──这话说得很好。嘻嘻，就是这样。这正是不能在因缘当体体会性空的表现。

    “当亲证本体的时候，是无时空的，因为时空是‘用’的产物。”
    ──这个话不大好。没有离用别存的“体”。亲证时也不需要“无时空”。即性空不碍显现。

    “绝对的平等。本体在所有‘用’中。当说出什么或知道什么的时候，‘用’已经在因缘上显现了。”
    ──这句又很好。

    “‘知道’这个现象，只有能力的不同，而不是本质的不同。”
    ──我们的知道只是个现象。佛的正遍知未必是我们想象的知道。我们的知道确实只是能力差别，本质都是能所二执的产物。

    “没有‘用’的时候，如何看待‘体’。”
    ──没有“用”的时候，怎么能有看待？看待不是用吗。
    兄上一问（至少听上去）是站在“主”位问不用时怎么看。
    麻子所答是说，不用就谈不到看。兄此一问：“我是说：能用未用当下，离言不可思议的这个‘离言不可思议’比如：有无量数字，数字的背景是零。但有一个零。”
    听上去是站在“客”位上旁观。然而，此“体”不应有所离，故不能有客。此问也不成立了。这与数字里的零不一样。
    而无兄此问，恰恰是隐含了有什么东西可以离体。
    话说到这里其实已经相当清楚，无兄如果隐含着细微二元来问“体”，问题本身就一定有毛病。所以，问题的答案不在于回答问题，而在发现所问不当的不当处。嘻嘻。
    看见这种回答一定感到有点难过，嘻嘻，麻子当年也很难过的。
    嘻嘻，话说到这个程度……就要超过一般语言的分辩率了。所以，也可以停下了。
    无兄的话，自己记住。如果将来你通过实修达到今天讨论的地方，你一定会对今天的讨论有所感叹的。

    （编按：引号中的话为“无不可”网友的问题。）


“空性”与“慧”于行者心中只能同时生起

    “空性”与“慧”于行者心中只能同时生起

    zf

    “当知应成派所许执着境空后，所显之空性，以此为[境]，与显教相共，非别有[境]，而[有境]之大乐慧，则显教所无，圆次所修者即此。故先[境]（空性），已有决定，然后此间，再修[有境]（大乐慧），依方便以得空乐不二智慧。”
    ──依本人浅见，[境]与[有境]、[空性]与[慧]于行者心中只能同时生起，因其为相待的双方。说显教无[大乐慧]，恐怕不是事实。心经中第一句就是“观自在菩萨行深般若波罗蜜多时，照见五蕴皆空”。此处般若波罗蜜与大乐慧的差别恐怕只是名字。

    “如何认识到一切法无自性？即需要通达大经[般若等]大论[中论等]，依此修习得决定后，方才可认识到心之体性决定是空。”
    ──在认识到心之体性决定是空以前先认识到一切法无自性，这在逻辑上是否有问题？因为显然在“一切法”之外不可能有“心”。

    （编按：引号中为讨论中的一些引文，“──”后为zf的回复。）


努力突破能所二执之障

    努力突破能所二执之障

    二麻子

    烽火三天，麻子唯一感到抱歉的，是对你G兄。因为这场烽火骂战，耽误了你的主题。麻子深感抱歉。
    麻子本想说点话的，未料上来就卷入战场，这可是事先没想到的。
    G兄的状况，麻子看来，其实简明，问题的关节点只在一处上。当然，就是某兄与你的问答间，显出了你症结所在。麻子特别抱歉的是，麻子现在反而不能马上把答复直接写在这里了。这也得归功某兄。既然有人大话满满，又半阴不阳地贬低麻子，麻子也无法，只好看自觉是开悟而可用神通的人，是不是真能指点你症结了。
    不过，到现在事情已很明显，你的CASE，SO Far，离开悟有距离。您现在不可能得到“印证”，得到的将是否定。麻子所说的“不绝对”，已相当明显地显现了。
    如果，你的问题最后没得到真正解决，你又想听听麻子意见的话，麻子那时会说。
    症结在G兄未能超越能所对立的二执。此事分两面说。首先在知见上，G兄似乎还没注意到这个结。以能（我）对所（人，对象）的方式是不能契入法性的。见金刚经（我这无此字）。
    若以色见我，以音声求我，是人行邪道，不能见如来。
    当观法界性，为如来妙身，法性不可得，故彼不能了。
    可见，由见“得”的，无论内外，都非空性。当然，也都没离空性。但此时对兄症的，是“不可得”。
    知见上了解能所二执为障后，行人必然会努力去克服此障。
    然而长劫串习，使解此结不易。佛门在此点上留下一些下手之办法，但无有一种是对一切人“绝对”有效的。密教里有些“绝密”“极密”的法，属此类。禅宗里也留下一些法子，但真懂得的人不多了。限于因缘，麻子也不能在此直接讲这些（不）用心之法。
    至于G兄所见现象，几乎全是在努力抛开“所”过程里，抛开了一般的“粗”份之所，如一般的色相等，但串习同时就将自己的心黏到一些细的所上去，而尚未超越。你心里明白的那个“不生不灭”，恰是心所。你仔细体会一下看是不是。
    G兄继续往这方向努力，终会突破此障的。真临突破时，会有些伴生现象和必经过程，经过的人一说就知。麻子在网上碰到过熟知这些的高明人士，某网友的师父就是其一。若别人点到了还不知，就真不知麻子在笑什么了。那“＠＊＃＆＊＃＠（”八个字前后排法是有点问题，不过比起这些关键处，那八字还不值一提。
    顺便说句，这突破前关键处的难度，除与过去世积累的福慧有紧密关系外，与我们是否发菩提心，行利他事，是否修学佛法空性正见关系极大。与禅定的关系也大，但稍轻于前两者。


割裂与能所

    二麻子：
    割裂也分两个层次。最基本的是割裂能所。次生的是，比如，把黄海与大洋割裂开来。上面你们讨论的是割裂能所，举例杯子却是割裂器世间，所以不大顺畅。
    割裂能所的例子，比如，睡觉警醒睁眼，看到了……
    在还没有分别是天花板，床头灯之前，这时候甚至根本还没分别看到的是什么，但是绝不会觉得看到的是“自己”。这就是能所割裂的时候。嘻嘻。有人睡糊涂了，醒来时要晃晃脑袋搞清情况。不过他绝对不会为此去晃桌子。就是割裂能所的一个表现。

    zw：
    麻叔的例子是不是说，“能所割裂”从心行上说，远比“认识”，“分别”等微细，时间上早得多，以凡夫的乱心，可能割裂多时后尚未意识到？
    “睡觉警醒睁眼，看到了……在还没有分别是天花板，床头灯之前，这时候甚至根本还没分别看到的是什么，”是说认识、分别等尚未生起，“但是绝不会觉得看到的是‘自己’”是说已然割裂。
    不会术语，说错请大力捶。

    二麻子：
    是。没大的异议。

    无不可：
    您这里的所是什么所。当然一般都把不动的外境当作所，如果就用这个所，谈割裂能所，那岂不是把眼睛闭上，就是割裂能所了吗？如果就是这样，那这也没什么意思。
    能所本不割裂，本是一体，只是凡夫误分，谈割裂能所只能从凡夫妄想上谈。我这样看。
    补充一句，我说的“所”不在外边。

    二麻子：
    哎……真是有点累……
    你说所不在外边，倒也不错。问题是，你跟麻子争什么，麻子说所在外边了吗？这个想法，是你扣到麻子头上的吧？

    无不可：
    那好了，试试看看来。
    “睡觉警醒睁眼，看到了……”，这就是你说的能吧。
    “在还没有分别是天花板”“甚至根本还没分别看到的是什么”，这是你说的无所吧。
    无所，谁与谁分。（因为所是内部的）
    将来有所了，有分别，它本身还是（就是）能。按你说，这个时候能所就不割裂了？也可能这就是定义。这样我认输。
    睁开眼，不分别，这如果无所，瞎子的无所，与他一不一样？如果瞎子不算能所割裂，那只能说他原先无此所，故无所谓分裂。那么，能所分裂，就必须有一个前提，他原先有这个所，现在不起，叫能所割裂。
    有能何时无所？有能焉能无所？
    有能可以不执著所。但不能无所。
    分别它只能叫做“分别所”；不分别它，我也没法叫它，只能无言。但不能说它没有。

    二麻子：
    是我语文太差，还是你也太差？

    嘿嘿。

    “睡觉警醒睁眼，看到了……”
    ──这就是你说的能吧。

    “‘在还没有分别是天花板’‘甚至根本还没分别看到的是什么’，这是你说的无所吧。”
    ──继续往下读，我说的是“这就是能所割裂的时候”。是我说的无能所吗？

    “睁开眼，不分别，这如果无所，瞎子的无所，与他一不一样？如果瞎子不算能所割裂，那只能说他原先无此所，故无所谓分裂。那么，能所分裂，就必须有一个前提，他原先有这个所，现在不起，叫能所割裂。有能何时无所？有能焉能无所？”
    ──瞎扯。我需要把六根一一列举吗？或者你想举出个六根俱断的“人”？

    “有能何时无所？有能焉能无所？有能可以不执著所。但不能无所。分别它只能叫做‘分别所’；不分别它，我也没法叫它，只能无言。”
    ──嘿嘿。这些话是你自己编的，与麻子没关系。

    “但不能说它没有。”
    ──不知道你要说什么。

    ──总体来说，我正在非常头晕地思考，到底是中文出了毛病还是你我的语文出了毛病。


妄设能割所割，已是颠倒

    常如：
    变化是谁在看？能看的不变，对应有所看的变化。能看所看都不变化，那是什么？

    常青：
    “能看的不变”？当见物的时候，您这“能看的不变”和“所看的变化物象”是一体的？不是一体的？如果是一体的，当见物的时候，能不能把它们的分界区指陈出来？一、如果有分界区：那能看的，岂不也成了所看的物象？能看，所看岂不是混淆混乱了吗？二、如果根本找不到分界区，就不能说是一体的了。如果不是一体的，能看和所看，根本毫不相关，所谓风马牛不相及，又怎能所见到物象是变化的呢？由此可见，既不是一体，也不是二体。

    二麻子：
    这有点太绝对了吧……眼不自见，手能不能自摸？

    大千：
    自己认为有刀可割，首先妄设能割所割，已是颠倒，才会生出刀不自割的戏论。

    二麻子：
    嘻嘻，难得难得，千兄此论实在早就该说了……每每见人用刀不自割为例子，怎么不用手能自摸为例子。这两个例子都成立，说明那个推理逻辑上不成立。嘻嘻。为什么？如千兄所说，以凡心度圣罢了。

    1234：
    手非同质，连续体只是假象，恰证明赖意识＼虚空＼神经＼肌肉等[多元]因缘才能[异处相触]，如何喻无为不作的真如[一因自作]？什么[逻辑]？水还要分子间隙＼未结冰超凝固点＼风推等才能起波浪，如真如成了随缘的唯一质料依，一因论无质差＼势差＼如何凝然而能动？如此早为诸贤所破无余，您当真的有新发现？

    二麻子：
    “手非同质，连续体只是假象，恰证明赖意识＼虚空＼神经＼肌肉等[多元］因缘才能[异处相触］，”
    ──这几句没错呀，就是刀子，也不是什么一因！用大点力气扭扭让它回头自割也不是做不到的。

    “如何喻无为不作的真如[一因自作]？”
    ──这又是您老兄自己的推论吧，麻子说过真如一因自作吗？请不要想当然地将您的想法扣到麻子头上。

    “什么[逻辑]？”
    ──您老也定心下来想想，什么是逻辑。

    “水还要分子间隙＼未结冰超凝固点＼风推等才能起波浪，如真如成了随缘的唯一质料依，一因论无质差＼势差＼如何凝然而能动？如此早为诸贤所破无余，”
    ──这段与上面一样，您是继续在与风车战斗。

    老实说，凡夫问真如如何缘起的，就是问无明从哪里来的。
    不过又变了次样子而已。圆觉经里的论述继续有效。除此之外，说什么自摸不自割之类，无非是多绕自己几次罢了，因为这里都没离开自，隐含了它。对立二见早在里面了。
    自摸不是什么鸟真理，同样不自割也并不比自摸高明。
    真如不二，不是一。你老也仔细看看大乘教法。说一的是梵见外道。

    1234：
    但愿您的本意不是[风车]那类，但把[风车]当正法的不在少数。

    二麻子：
    是呀，把断灭当涅槃的也不少呀。


不二这个词很多人不小心就当一理解了

    hu－ou：
    从常识上，“我”不观待“他”的时候，在“我”这里没有了关于“他”的看法，但“他”并不因为“我”没看法而不存在。从法界上，“我”与“他”不处在一个法界里，那么照样“他”可以独立的存在！
    因为有一个法界，就有多个法界；有一个整体的法界，就有多个隔离的法界。理应如此！

    哈哈：
    “但他并不因为我没看法而不存在”这句还是你的看法，可见你仍然观待了。
    “因为有一个法界，就有多个法界”？多读点佛经吧。佛法不讲一，只讲不二。但不二这个词很多人不小心就当一理解了，这是误解。为什么佛法不讲一？有一就有二，就像你现在这样。

    hu－ou：
    不接受你的哈哈。

    哈哈：
    作为名字，只要我接受就可以了。你接受不接受都没关系。


验金石

    验金石

    zf

    请问，在“把能所二取消于法界”之后，是否还有因和果？？？

    提醒一下：
一、对“能所二取”的否定与对“能所”的否定，两者的含义差别。
    二、此处“法界”的确切含义为何？

    “能所的作用如幻，如众空华，灭与虚空。”
    ──此言不错，但要知道“空花”和“虚空”的所指。“幻想”不会自动落的。要杀敌，第一步是认准敌人（当然认识了敌人也不一定有力量杀）。


孔雀开屏的尴尬

    guokeytt：
    若于境不取不舍，心不染著，还剩下什么？观照！

    二麻子：
    打打打打打……打住，二位，特别是G兄。这是孔雀开屏，却让在背后的看到……

    guokeytt：
    真的这么严重吗？实际上是麻叔的话我有些不懂，嘻嘻。

    二麻子：
    嘻嘻……
    “若于境不取不舍，心不染著”
    ──很好，但这个是要做到而不能靠说到想到。
    如果真能做到一点，就不会再问下面的……

    “还剩下什么？”
    问了，说明没做到过！就算是引导别人，这一问也不对，说明问的人没到。所以要你打住。

    至于麻子上贴说的孔雀，解释起来挺难听的，俺就不解释了吧。嘻嘻……


本来不二和后来合一

    玄兹：
    不谈物我怎么就不能把物我两忘呐？在绘画史上有画家通过画画达到物我两忘的故事。这故事从正面说明不谈物我可以达到物我两忘。这个例子的关键点是不用谈物我也可以达到物我两忘。而不是像千兄原来说的那样：“必然是先谈物我，然后才可能达到物我两忘。”

    大千：
    谈是说出来吗？画家意识到“我在作画”就是谈到了物我，然后才能谈到两忘。

    玄兹：
    罢，罢，意识就是谈，呵呵。

    二麻子：
    嘻嘻，玄兹兄，这个不够仔细呀……如艺术家等进入“忘我”境界，不过是能所（我人）两相里，所相大能相小故对我相一时观察不到罢了。观察不到，自己一时所谓“忘掉”，其实没忘。画家用笔，没糊涂到用脚去拿吧？没能干到用别人的手画吧？可知能所未忘，只是细微。就是不谈，这个也破掉。
    不过麻子还是挺高兴你举这个例子。嘻嘻。所谓粗细差别，你举的例子细，限于粗心就很难破你这个例子。

    玄兹：
    嘻嘻，画家能达到的境界恐不限于此哩！以前曾读一画家的自我简介，其中说到“画四十年，终有一悟”。当然这个“悟”是否究竟外人不好从字面上判断，但可以看出这一悟并不是画画过程中的渐变，而是某种突变。
    我举这个例子意在说明不用（语言）谈也可以达到物我两忘，甚至达到这个例子中的悟。但千兄说意识就相当于“谈”，嘻嘻，玄兹也就没话可说了。按照千兄的这个等效说法，以后我们之间的谈可以用意识代替，比如“我么谈点什么”换成“我们意识点什么”，哈哈。

    二麻子：
    有意思……嘻嘻。你说的在你的意思下这地方自洽……麻子要提醒的是，佛门的悟，不是简单的物我两忘。

    玄兹：
    嘻嘻，同意老兄说佛门之悟不是简单的物我两忘。

    下面是一现代画家（张君）与其友人的对话：
发问张君：时下君已入何境界？
    答曰：时混时悟，混中有悟，彻中犹混。
    再问：君何时得入彻悟之境？
    又答：学画之道，心在悟中，悟在天外，无彻无悟，方为涅槃。

    又：玄兹个人并不赞同人们追求理论上的自洽。
    再给个例子：潘天寿大师认为“物境与心静合，便可实境而入化境，空灵奇变，无所挂碍，意参造化，左右逢源”。
    画史中物我两忘的出处：(【唐】张彦远 )遍观众画，唯顾生画古贤得其妙理，对之令人终日不倦。凝神遐想，妙悟自然，物我两忘，离形去智，身固可使如槁木，心固可使如死灰，不亦臻于妙理哉？所谓画之道也。
    麻兄似乎只是指出画家在绘画过程中的所相大能相小，而张彦远说的物我两忘则是画家绘画过程之外的功夫，如“凝神遐想，妙悟自然，物我两忘，离形去智”。
    在莲舟xixi默认文以载道，但不愿说明这里的文是否包括西文。实际上梵文、藏文、中文以及西文都能载道。更广义的，绘画乃至自然都能载道。

    二麻子：
    嘻嘻，这两段……
    当然，不仅文载道，画也可载，万物都可载。而且实际上确实也是万物都载道。所以禅德有云“无情说法，烁然说”。
    问题是谁能懂罢了。
    “张彦远说的物我两忘则是画家绘画过程之外的功夫”──此处不可考证！说的跟做到的可以相当不同，而当事人还可能完全看不出这个不同，一心以为相同。嘻嘻。这就是粗心看不到细心行的效果。所以这点上，是说是做，做到哪里，是真正的差别，而在语言里分别这个差别相当困难。

    玄兹：
    既然不可考证，我们就无法判断张彦远言行是否一致。

    二麻子：
    对，没法考证，麻子也就没去判断他是否一致了……不过麻子实在有几位艺术家朋友，包括搞雕塑，画山水等方面的。直觉是，这方向路数不容易到。当然，就是内道也不容易，嘻嘻。

    玄兹：
    俺以为要把艺术家和艺术大师区别开来……俺举的例子如潘天寿是大师级的，从大师们说的话可以看出其水平是不低的。似乎可以这样说：内道成功的几率大些，搞艺术的也有成功的可能，但几率要小些。

    二麻子：
    嘻嘻，你这个看法也没法考证。
    你看得懂毕加索那些变形得乱七八糟的画吗？麻子见识的艺术家们，依麻子看法，嘻嘻，也看不懂。不过麻子有个看法，说出来很吓他们一跳。当然，麻子并不能证明麻子说的就是对的。嘻嘻。
    那些局部相当准确，却构成乱七八糟全局的局部，是大脑在形成对外界全局形象前的零部件。把这些零部件拼对了的是常人，拼错了的是神经病，能在拼对拼错间转换的是天才。哈哈。
    想知道怎么知道是这样子的吗？禅定到某个深度，这些过程自己都能看见。

    玄兹：
    嘻嘻，潘天寿与毕加索相比如何？

    二麻子：
    没看过潘的东西，不知道了，东方有这个文化。西方没有。毕的东西我也不认为是什么悟。

    明心斋主人：
    我倒觉得，艺术水平如何与作者是否开悟等境界没什么关系，我恰恰觉得大师留下的文字不怎么样。

    二麻子：
    此言甚是击中要害。好！

    玄兹：
    嘻嘻，本来是谈潘大师说的“合”，再回顾一下……（编按，以下直到“现在的问题是‘合’，需不需要证？”，是玄兹整理的相关讨论的回顾）

    明心斋主人：
    潘老的画不敢乱议，但谁不是“心境与物境”合啊？连小偷、妓女、魔鬼、畜生都是心境与物境合，想不合能做得到吗？看来差别只在于合的是什么样的境界而已。

    玄兹：
    不乱议是比较可取的态度……在我们自己尚未证得物境与心静合时候更应该出言谨慎。在人类社会中，社会分工比起古代而言越来越细，菩萨化现成大科学家，大艺术家也是可能的。在我们凡夫识别不出来某大科学家、大艺术家是否菩萨化现时，决不能轻易将其贬之。比较可取的态度是不论。

    明心斋主人：
    您误解我的意思了。我认为任何人的心境在任何时候都是与物境合的，连我们愤怒、失望、沮丧、造恶业时都是如此。

    玄兹：
    没误会，关键是如何“合”。

    明心斋主人：
    对啊，所以说，心境与物境合是不需要证的，那是躲都躲不掉的。只是如何“合”高下有区分。这里面据说相差不少。

    玄兹：
    我们在此主要讨论大师留下的文字，属于修心方面的东西。

    明心斋主人：
    我恰恰觉得大师留下的文字不怎么样，但他的文字把心境与物境合抬得如此高，是不怎么样的，正如我多次强调的：物境必然与心境合，这是不需要证的吗？

    二麻子：
    玄兄所说之合，二而一之合也。由对立而不对立也。
    明兄所说之合，是本来没分，是本来合。这可是大差别。
    当然，俺麻子不敢保证明兄已经证了这地方。但至少思想上明兄在这点比你走得远。

    玄兹：
    明兄已经说过“心境与物境合是不需要证的”
    麻兄也说过“不敢保证明兄已经证了这地方”。
    现在的问题是“合”，需不需要证？

    二麻子：
    嘻嘻，有意思的问题……若是“本来合”，这个合本身，没什么证不证。然而，当人于尘劳里回头时，有个体会得到体会不到的问题。若说这个是证，则不无。
    若是后来合一，则一定需要证。结果必然证伪。
    因为后来合不是真实。但这个求证──证伪过程，非常有利于体会本来合。
    继续……当潘大师强调心与境合时，显然强调的是后来合。这说明他没体会到本来合。而后来合是达不到的。推论居然就是，他没达到合……！！！！所以我说，明兄这话，辣。嘻嘻。

    明心斋主人：
    未必他没体会到本来合。也许他只是强调的是后来合。也许他说的真正的意思是体会到本来合？大师的文字不怎么样，他的境界如何则不知道。

    二麻子：
    判决与推断……
    嘻嘻，明兄明白人。当我们讨论各种情况时，严格说来，只能是推断。差别只是正确的成分和概率有多大而已。判决某人某境界一定是什么的话，且不说准不准，本身就是一种自性见。因为我们的判断，无论如何都要通过主观感受，而对我们凡夫来讲，这个感受追到底，是不怎么可靠的。
    所以，上面的讨论其实都不言自明地隐含了“这是个推断”的前提。下面的以及以后的，当然也这样。
    为什么推断大喊“合”的人不是真证本来合？
    真证本来合的人，几乎一定会说出努力去合，或怎么去合之类，不过是引导方式。本来合不是因引导而来的。他可以没强调这点，但不应该没提这点。这是麻子推断的理由。当然，麻子这是推断不是判定。嘻嘻。
    都要判定的话，大家也就没什么能讨论了。

    明心斋主人：
    合的境界正如大千兄所说，不是真实，因为所谓合的境界本身恰恰是因为凡夫妄执能所二分才产生出来的。

    二麻子：
    若“合的境界”是说后来合，则麻子完全同意。

    明心斋主人：
    也许要证到能所俱冥，没有所谓“境界”的时候才是真实。可那是什么，现在在下纯属乱说，除了造业之外，恐无任何益处。

    二麻子：
    相对来说，这段是明兄说得最弱的一段了。这里粘了点断见。能所本来不二，真证到时，可以有境界也可以没境界，与境界不相妨碍。

    玄兹：
    嘻嘻，关于合二而一之合与本来合之合，合二而一之合是动词的“合”，本来合之合是名词的“合”，请问麻兄这动词之合与名词之合有什么可比性吗？
    普通画画者未合罢？潘大师告诉学生去合是为学生指出方向罢？

    二麻子：
    动词名词……连说它们不能比，都是一种比较！这个不同正反应出，嘻嘻，画家的不同。
    要加个注，我自己没看过潘的东西。说潘强力喊合一，实在是在这里看你们说的。也许是你没表达对潘的意思？“普通画画者未合罢？潘大师告诉学生去合是为学生指出方向罢？”这点麻子不能证伪。可以作为推断的理由。
    上几帖子里的“合”，正式来说，都应该用“不二”这个词代换掉。麻子只是顺着慈坛的原贴使用这个合字表义。再说得细点，本来合是说本来不二。后来合是说后来合一。这也是玄兹兄说本来合是名字，后来合是动词的原因吧。


“能转物”者其前提是转心

    yangzi：
    末学所理解的色是广指凡夫所见到的物质，或可指共业所成之器世间。色空不二，说明妄想坚固，造成真实的有（感受）。同样，受想行识，都是坚固妄想所成。与空不二。
    若能转物，是否指可转缘起的因果。
    圣者所现病痛，在某种层次以上，纯为示现，不转乃为度众生。

    zf：
    “末学所理解的色是广指凡夫所见到的物质，或可指共业所成之器世间。色空不二，说明妄想坚固，造成真实的有（感受）。”
    ──这个说法不能说错。
    但如何理解如来也有微妙的色身呢？

    “同样，受想行识，都是坚固妄想所成。与空不二。”
    ──受想行识与佛智亦有相通之处。

    “若能转物，是否指可转缘起的因果。”
    ──物为心所显，“能转物”者其前提是转心，即您所说之“转缘起的因果”。

    “圣者所现病痛，在某种层次以上，纯为示现，不转乃为度众生。”
    ──大乘经中确有这样的说法。


悲智本来不二

    笨鸟：
    麻叔，请教个问题。

    愿一切众生善业皆得成就——续一切善缘。
    愿一切众生恶业皆不得成就——断一切恶缘。
    这是大悲心。
    那么智是出现在悲的同时呢？
    还是出现在悲的过程中？
    以大悲水饶益众生，则能成就诸佛菩萨智慧华果。
    看这句智好象是在饶益的过程中出现的。
    但笨鸟又相信实证是开智慧的，
    这两者怎样统一呢？

    很有可能笨鸟问得无理。
    但对笨鸟来说却是个问题。

    二麻子：
    需要统一协调？嘻嘻。老弟，智慧跟慈悲什么时候被割裂开了的？你自己检点检点。

    笨鸟：
    凡夫的同情心与智力是分离的，菩萨的大悲大慧是一体的。

    二麻子：
    那么本来呢？它们是割裂的吗？不是吧。所以根本不要去想谁怎么增长了谁的事，根本是自己增长自己。悲智本来不二。所以，修慈悲长智慧，修智慧长慈悲都很正常。


空性与因果之非一非异

    小心：
    站在一个绝对的立场上，没有因果，也没有轮回。但是，这个绝对立场必须一个前提，就是放弃对自我实有的执著，以及放弃对法实有的执著。

    zf：
    小心兄，据在下理解小心兄之“站在一个绝对的立场上，没有因果，也没有轮回。但是，这个绝对立场必须一个前提，就是放弃对自我实有的执著，以及放弃对法实有的执著。”
    是在说，空性（即兄之绝对立场）与因果之非一非异。
    非一是说，空性不是因果，空性中无因果；
    非异是说，没有脱离于因果而单独存在的空性，见因果即见空性。
    华严祖师杜顺大师曾以水的“湿性”和“波浪”比喻空性与因果的关系。首先，湿性不是波浪，湿性中无波浪，此乃非一义；但同时，无离开波浪而单独存在的湿性，有波浪处即有湿性在，此非异义。
    心经中在说空中无色的同时，亦说空不异色、空即是色的用意亦是在开显这一非一非异的深意。插几句不相干的话，见谅。

    xixi：
    波浪性与湿性是两个不同的属性。与因果／空性的同性是不一样。如果用波浪代表因果轮回，用湿性代表空性，实际就是步入以色度空，以空显色的二法。佛法是不二之法。因果本空和波浪本湿是不能相比的。

    zf：
    仔细想想，任何比喻都是牵强的。但比喻的作用就是通过这种“牵强”让学人去体会其他。在这点上，比喻也是指月之指。
    因果于空性的另一个著名的比喻是“水”（喻空）与“波”（喻因果），但以水喻空，我等法执严重的众生便可能认为空是某种不变的本体。
    在下认为，只要一个比喻对学人有启发，就是“好”比喻。


显空不二

    显空不二

    二麻子

    用生灭同时来说不生灭，过去好用，现代用怕有点麻烦。运动物体的位置，可以说是生灭同时的一个例子。由此导出运动物体没位置, 子弹不会碰到靶子,恐怕大家不接受。生灭同时是说明因缘法不住的好例子，不是无生的好例子。
    佛法里讲的无生，其实是说无有自性生出来。比如椅子，从做起到塌坏，俗义上是有生有灭的。没坏前，似乎有个“椅子”，但如果仔细抉择一下，就发现没有一个什么独立的“椅子”能自己显现。所以，椅子虽然俗有，却无自性生出来。等到椅子坏了，也没个什么自性灭掉：根本没有的怎么灭？
    后面证空性后缘起显不显现了这样的问题，其实根本不存在。这问题要存在，就是心里先认定缘起与性空是两个，甚至要互斥才行。但佛法讲的是显空不二，所以根本没这样的问题。硬要举个例子，比如佛圆证空性，但照样回答弟子问题，后者显然是缘起显现。嘻嘻。


关于“随举一法皆未离心性的显现”

    关于“随举一法皆未离心性的显现”

    二麻子

    又激动了不是……不能删掉那几个字吗？
    兄弟，跟你说句真心话，我看到你跟某兄等的对谈，感觉非常奇怪。某兄的批判，在我看来，是对你在实修里提高极其有益的看法。同样，你对某兄的批评也是对他进入实修非常有益的。尽管你们两人目前在修学上的方向差别相当大。
    举个具体例子来说，“随举一法皆是心性的显现”这见，在初学用心时候是相当好的方便引导，但在实修用心到细处的时候，常常会有相当误导。如果改为“随举一法皆未离心性的显现”，这个误导一般来说就消失了。嘻嘻。麻子这是经验性的说法，但是在这些年的学习里麻子经常发现，这样的经验跟历史上的结论往往非常一致。您看看，麻子改过的这个说法，会让人批成数论或真常吗？我想不会吧。麻子的联想是，这类在见上看上去细微的差异，不仅仅是个理论思辨的问题，而是有非常重大的解脱实践背景的。
    我一直觉得某兄的看法极端了一点。但这些年在学佛圈子里的所见所闻，实在让麻子也有类似的担心，偏常的见地很容易给一些人带来“开悟”甚至“解脱”的错觉，而在应该真正走向解脱的方向差之毫厘。写到这里，麻子发觉俺似乎又在反复老生常谈了，所以要申明一声，这些话俺是从实践与操作的角度，而不仅仅是从思辨的角度，得来的。
    一个有关实际操作的因素……
    俱非肯定在理上是比较不容易偏的表达。但实用时有个问题，就是这个表达在思维上太复杂了，不够直接。所谓实用，就是借用毗婆舍那从分析进入现量。对多数人来说，这时候的分析不能太烦杂，否则容易破坏定心，就难以契入了。当然，例外的根器就是例外。
    其实除了在定心下用些思维性的毗婆舍那契入，还有别的方法，可能更直接。但对多数人，这种方法不容易用得动。

    至于“藏密诸师所授口诀是否有简化思路便於禅观的作用？”
    ──诸字俺没法回答，因为我知道的有限。口诀不仅是简化了思路，甚至是直接将思路转化为对应的心行。所以口诀本身不会跟你说什么“见”，而是跟你说怎么“做”（或者怎么“不作”）。历代大师对口诀的讲解往往是说明如何做是如何与某个见对应，是怎么对应的。

    “另外，禅宗早期多用观法，和台宗用功法大同小异。如观心法门，虚云老说此法于今人根器稍嫌不契，故宗门如今多用参法。在下不太清楚其中所以然。猜想是否在观心法中，能观所观都太难把握？”
    ──俺不知道虚老说话的根据与动机。在俺看来你说得很对，原因在很大程度上是由于能观所观都难把握。更准确定说是由于串习，能观所观都执得太紧。另外的原因是，具体做法（相当于密教里的口诀）近乎失传（会的人太少了）。


从因果律看时空

    二麻子：
明斋主要麻子在这边上帖已经邀请了很久，麻子口头答应过，但自己开贴似乎还真没有过，真不好意思。这帖算是还明斋主的文债吧。这东西在麻子脑子里若干年了，一直没写出来，主要是觉得对学佛修行等并无特别大的意义。这次在大千坛子上又应了YXY兄，所以，最后鼓劲草草写出来。希望对破除坚固的时空背景执着，多少有一点好处。
    从文体与叙述角度来说，这帖子在佛教类坛子里，最适合的也应该是贵坛。所以，贴在这里，也借此向各位老友致敬。（编按：这篇文章是在“科学与佛学论坛”发表的，在网海莲舟论坛继续了一部分讨论，本篇是两部分讨论的合集。）

    从因果律看时空

    时空也是因缘法，现代科学对这点看法与佛法一致。从相对论开始，时空不再被科学认为是事物演化的“刚性舞台”。质量／引力／时空弯曲／黑洞的关系也直接显示了物质与时空之间直接的相互作用。然而时空毕竟是因缘法里相当特别的一项，与其他的一般事物不同。一般事物任取一件都不难看到它是从别的事物演化来的，而时空却不大容易找到这样的来源。
    虽然物质与时空可以直接相互作用，毕竟象黑洞那样的环境是很少的。在时空的绝大部分范围里，物质与时空的直接相互作用太弱，不容易观察到。佛教也同样注意到时空的特别，在百法里将之列为“心不相应法”。
    尽管科学与佛法都告诉我们时空是与因缘法不能割裂的，我们却在绝大多数时间里仍然不自觉地把时空当作因缘法的背景舞台，甚至在我们讨论佛法因缘果法的时候都是这样。
    那么，在一般情况下（非黑洞等）时空真的就象我们一般认为的那样相对独立，类似于因缘法相似相续的背景舞台吗？不是的。下文麻子设法从因果律角度来看看，即使在最普通的情况下，时空是怎么与因缘法紧密不可分的。
    首先我们列出时间与空间的要素，后面会表述其意义。
    时间：
第一要素：有序性
    第二要素：顺序间的可测度性（即时间是有长短，并且其长短是可测度可比较的）。
    空间：
第一要素：广延性
    第二要素：广延的可测度性。
    假如我们接受最基本的单向因果律，即，因可导致果而果不可返回因（注意，麻子这里并不是说这样的单向因果演化律就是时空的来源。而是说，让我们从这个角度来看看，假如接受因果律会有什么发生）。最简单的因果例子是单链的因果序列：A－＞B－＞C－＞D……这里我们可以看到由于具有单向性，A、B、C、D等事件是有次序的。这个次序显然可以给出时间的一个基本要素：有序性。但是，仅仅这样的事件次序并不能给出时间的可测度性，因为现在A、B、C、D之间还根本谈不到怎么度量长度。
    同样，因果事件的关系可以是非常复杂的。上例中从因A演化到果D完全可能通过不止一条途径。比如，有并行的另一演化过程：A－＞E－＞D。这时问题就来了，事件E与事件B、C之间，怎么分别前后次序？实际上，它们之间不存在前后次序关系。由于E、C是一起作用于D的（到D就“同时”了，同一个事件就是同时，这是没有疑义的）但E与C并不是同一事件，那么，E于C必然“并存”。这样的并存只能是某种“广延”。类同的，我们可以说明E与B也必须并存过，同样显示了广延性。空间的第一基本要素就这样显现出来。注意，我们这里谈并存的时候，并不说E与C“同时”。到现在为止谈两个事件的同时是根本没有意义的。两个以上的事件同时的概念实际上包含了更多的假设。广延的必要不是从“同时”来的，而是从“无有确定的前后关系”而来。
    到这里我们看到，从简单的因果原则出发就可以给出时间与空间的第一要素，有序性与广延性。
    那么可测度性怎么来的？假如在复杂的因果显现（法界，嘻嘻）里，有些非常相似的因果关系反复出现，比如，A－＞B－A1－＞B1－＞A2－＞B2……这里A、A1、A2……是非常相似几乎一样的事件，而B、B1、B2……也是非常相似几乎一样的另一类事件，那么我们说，这样的A、B系列构成周期，而这种周期可以用来度量其他因果事件的演化过程（实际上，众生就是这样度量时间的）。那么，这样的度量有“可公度性”吗？不一定。比如用心跳周期来度量时间是古人使用的方法之一。但如果用的是在鸡足山里入定的大伽叶尊者的心跳周期的话，大家可能根本没法接受了。那么这种周期的稳定性与公度性的基础是什么呢？居然是所涉及的众生共业的范围大小！比如心跳，所涉相对小，稳定性也小，通用性也小。地球绕日所涉的众生范围就大多了，对应的稳定性通用性也大多了。现在我们用的时标准是激光频率，它是涉及基本粒子参数的，而这些粒子参数是我们这个物理宇宙的基本性质，涉及几乎全部这个物理世界的众生，所以稳定性通用性非常高。而且我们可以预期，因为我们这个物理宇宙是有限的，所以，时间的度量精度必然不能是无限的。这就是我们的时间，如此这般。那么，有了时间的测度以后，这个测度的意义是什么？时间测度的最基本意义是对直接因果关系里因缘法亲疏程度的一种量化。比如上述ABCD时间序列里，显然CD间最亲，而AD明显要比CD疏远，所以AD间测度出的时间要比CD间来得大。
    空间广延性的测度是类似的。如上述AED，ABCD两条因果链里，E与C并无直接因果关系，故而不可能确定相互间的顺序。但E，C都与D有直接因果，故EC间仍然有因缘的联系。如果广延性的测度也是反映出因缘关系的亲疏的话，那么这个测度应该与时间的测度是一样的。EC间的广延性测度似乎就应该是ED间的时间测度加上CD间的时间测度。在更复杂的情况下，E与C可能因缘和合出多个事件，而D只是其中之一。那么EC间广延性测度应该是这许多个时间测度里最小的一个。这个广延性的测度，对应我们一般的距离概念，所以这意味着距离应该是直接用时间的测度确定的。由于我们对时间与空间用的测度单位不同，这两个测度间还应该乘上一个常数因子。
    这恰恰是相对论的结果，在我们这个宇宙里，这个因子是光速。至于为什么是光速，麻子不知道。嘻嘻。我想也还没科学家知道。
    虽然还有很多可说麻子觉得这已经够多的了，先停止在这里吧。单单从一个因果律出发，我们已经得出某些与相对论同样的结论了，这看上去实在有点让人意外。
    回头总结一下，我们发现，只要有因果律，那么就一定有时空的第一要素。至于时空的第二要素，却与显现的样式关系很大。或许在它方世界（宇宙），时空的测度方式会与我们的宇宙差别很大。
    但只要因缘果法在显现，顺序与广延就是必然伴生的，这就是基本的时空。故，中观将时空表述为“观待缘起”非常合理而深刻。

转贴YXY兄文，供对比与麻子上贴的异同：
    YXY：

    破物理时间相物理时间是根据外部世界中的现象建立的，最形象的认识是物体运动一段距离，它逐一通过每个点的过程就揭示了时间的流逝，由此产生时间概念。钟表则把这一过程标准化，现代人在想到时间时总是和钟表联系起来，这种物体运动通过一段距离的意象仍然是时间概念的基础。更理论化的方式是用某种方法把不同时间发生的事件转化成空间中不同的点，这里的事件可以是任何事件，然后再通过理解和把握这张记录了不同时间点的图而理解和把握时间概念。当然为了计量的方便，人们一般总是选择周期性的事件，并在各种周期中选择相对其它各种周期最为稳定的一种作为标准时间。不过选择什么事件作为标准已经是计量问题，是时间概念形成以后的事了。从时间概念形成过程看，不管是最原始的办法还是最精致的办法，一个基本特征都是把时间区别转换成了空间区别，然后通过把握这种空间区别间接的把握时间。所以人们直接把握的其实只是空间，时间本身则从来没有接触过。这样间接把握的时间相当然只是一个时间模型的相，而不是时间本身的相。在《论佛教的认识路线》中我们讨论过，外部世界整体上是建立在假设检验基础上的，物体、事件、空间等等其实已经是一些用来解释感觉的模型了。在模型的基础上建立更复杂的模型，当然离真实更远。所以这种在外部世界模型基础上建立的时间模型不是时间的真实相。

    常如：
 嘻嘻，俺先看先发表读后感了。首先麻叔说的俺没全看懂。与杨兄文章主要不同的地方，个人的看法是：麻叔似乎先确立因果事件的概念。与时空相比，事件是更基本的，更直接点说，时空更应该看成是事件的“属性”，而不是事件的“背景”。
    将时空看成事件的“属性”，意味着时空的很多内涵可以从事件发展的逻辑中推导出来。相对论也就是用类似的方式来处理的。若将时空看成事件的“背景”，就是说时空和事件是可以割裂分离的了，经典牛顿物理就是这样的。嘻嘻，杨兄这里似也看出这个意思，只是表达上有些拖泥带水，不能“一以贯之”了……
    读《心经广义》中我觉得隐约就是有这样的意思，麻叔今天把它直接而清晰的表达出来了。嘻嘻，俺当初学相对论时留下的那一桶浆糊，现在终于可以清理清理啦，哈哈。

    hu－ou：
 不知麻叔的话还可引申不，我从麻叔的话似乎还可引申出别的意思。麻叔是说【假如我们先接受了最基本的单向因果律】，就可以导出时间与空间的第一要素，有序性与广延性。只要【因缘果法】【在显现】，顺序与广延就是必然伴生的。　【在一般情况下（非黑洞等）】，事件是更基本的，时空是事件的“属性”。也许隐含着【假如我们不接受最基本的单向因果律】？也许隐含着【在特殊情况下（黑洞等）】？麻叔也许承认黑洞的说法，物质与时空可以直接相互作用？

    二麻子：
“也许隐含着【假如我们不接受最基本的单向因果律】？”
    ──这个问题打破原贴的假设前提，明显是在原帖讨论范围之外的。或许有人有兴趣，或许可以另题讨论，但确实不应该在现在这个题目下讨论。
    “也许隐含着【在特殊情况下（黑洞等）】？”
    ──如果您想讨论黑洞里面的事情的话，这个根本不可讨论。因为按照现代物理学，黑洞里面的东西我们在黑洞外的人是“不可以观察”的，除了引力、电荷、角动量以外，即黑洞三毛定理。对于根本不可以观察的东西，谈有谈无都没意义，都谈不到。所以不讨论。
    “麻叔也许承认黑洞的说法，物质与时空可以直接相互作用？”
    ──广义相对论下的引力理论就说这个：物质引起时空弯曲，时空弯曲表现为万有引力。当时空弯曲到自封闭的程度时候，就是黑洞。所以，物质与时空的直接作用其实非常容易观测到。只是这个作用一般没强烈到让人知道是时空在参与相互作用。
    麻子曾经在大千坛子上贴过否定虚妄遍计执相的帖子，叙述过这些靠遍计执遍计出来的东西都是虚妄。麻子这个模型与表述也不过是表述而已，用来破执不是用来当真。

    YXY：
剥离掉外境的麻烦之后，麻叔的讨论可以在这个层次上重新进行一次，根据一大堆心念现象和现象间的因果关系建立内在时间的概念。这样我们就没有必要建立内在时间概念，只要有心念和心念之间的因果关系就够了。

    二麻子：
这段是真的有异议的了。在麻子看来，这行不大通。就是能通，要做的调整恐怕也远远超过YXY兄现在的估计。原因是在外境上的模型是建立在大量众生共业上的，而这里要建立在每个个体的别业上。这样的过渡，不那么容易。并不是粗粗一想，“唯”一下“识”，就简单成立的。

    YXY：
麻叔的讨论，背后的图景是ABCD等事件之间用因果关系的箭头联系起来。这个箭头本来是由一个时间指向下一个时间的，箭头两端不能同时经验到。但在这个图景中它们同时出现了。所以它是一个因果关系模型，而不是因果关系本身。是一种把时间关系转化为空间关系的模型。怎样才能不通过模型而直接触及时间或因果关系本身呢？

    二麻子：
这个当然。麻子用的当然是模型。怎么才能超越凡夫位而得一切智呢？时间或因果关系有本身吗？
    YXY兄是倾向用思维唯识理论来“追求真理”的，而且Y兄已经觉察到用这样的思维来追求真理，似乎是永远隔了一层。于是，Y兄希望找到一种用这样隔了一层的方式来不隔一层的结果。所以，Y兄的最后一句应该改成：
“怎样才能不通过模型而再次直接触及时间或因果过程本身呢？”。
    这是个有逻辑背反的问题！
    我们一切众生都直接现量触及了因缘法，我们的问题是不能当下脱离迷执。Y兄希望事后能再次直接触及，这是不可能的。
    其次，Y兄在努力地追求真理。麻子对这种的努力表示绝对的尊重。但是，麻子想说一句，如果这种追求还是在追求的阶段，那只能说这还是初级阶段。8－）。当然，这是个不可避免的必经阶段，必须阶段。而Y兄现在的努力，麻子希望，是这个阶段的末期。
    我们不讨论俗义理论的意义，这个意义是明显的，大家学习都要从俗义开始。
    俗义理论上，很多地方互补性是有的。不幸的是，如果想表述完备的俗义真理，就是要准确表述法界。儿由于法界的多样性，任何准确表述实际上只能是法界自身，也就是说，不表述。靠互补没法完备。
    这似乎导致了Y兄百尺竿头实难进行下一步，除非你悬崖撒手。撒到哪里去？触处皆真吗。嘻嘻……
    还得补一句。俺对Y兄的认真，真是佩服。
    希望Y兄考虑麻子的建议：
真理不是追求能得到的。破执则真理显。

    yxy：
赞同，靠互补没法完备，我是说，要想有用就已经需要互补了。所以，任何一个人们在使用的理论上都可发现互补性。

    二麻子：
y兄这个地方与中观宗很相似……中观说，“有”是观待出来到。也就是说，是比较，对比出来的。用Y兄的话，就是一定存在互补。这地方中观走得非常深入。

    明心斋主人：
我不明白的是：俗谛与世间理论的区别何在？另外，唯识是否将执着收归一点，我也表示怀疑。

    二麻子：
基本上是……而且执着基本都归到阿赖耶识上去了。不过要注意大是，在收归的过程里，这个“点”同时在失去它的边界，变得体积巨大而边界模糊不清。嘻嘻。

    dawa：
“从因A演化到果D完全可能通过不止一条途径”……
    ──给个例子，（理想）气体从状态1非等温地变化到状态2，其状态用P、V、T来表征。这一状态变化也可是通过一个等温可逆过程加上一个等压可逆过程来完成。热力学函数计算的简化就用到了这个途径等效性。嘻嘻，擅长打台球的或许可以给个更简单的例子。（嘻嘻，科哲论坛满了，所以发在莲舟这儿）

    二麻子：
嘻嘻，最明显的例子是近亲结婚生子。近亲是有共同来源，子是一个事件。父母是两条途径。小B考虑不周。嘻嘻。

    玄兹：
讨论时空离不开速度，在物理界，时间是用空间度量的，如钟表的指针，地球围绕太阳转动，等等。反过来，空间是用时间度量的，最典型的是在天文学上说某某星体具我们多少光年。而光年就隐含着光速。实际上用空间度量时间背后也隐含着速度，表针与地球的运动都有速度。所以时间、空间以及速度三者密不可分。

    二麻子：
“在物理界，时间是用空间度量的，如钟表的指针，地球围绕太阳转动，等等。”
    ──这个不重要，所举的例子多是为技术手段所限制而使用的方便。现在用数字显示，则可以完全不用这种度量。

    “反过来，空间是用时间度量的，最典型的是在天文学上说某某星体距我们多少光年。”
    ──这个非常正确，对我们日常生活里也对。只是光速太快了，日常中容易忽略这件事。关键的速度只有一个，就是光速。光速多大是人类选择单位造成的。如果适当选择单位，光速可以成为1。至于表针、地球的速度，都不重要。

    hu－ou：
为什么麻叔要提“物质与时空的直接作用”？我想了两天了，不敢说完全想通，这里，就说说一些读后理解。
    一般来说：事件是更基本的，时空是事件的“属性”。在这里，麻叔加了个前提，这个前提是这样说的：【在一般情况下（非黑洞等）】，这也许是用“黑洞”一词代表一般时空（单向因果）的天经地义意义消失，以此为界，一般的世界就是指“自然”世界，在“自然”世界里，事件是更基本的，时空是事件的“属性”。
    “有”并非就是“自然”世界，“有”应该是更广阔的“显现”世界，“自然”世界是“显现”世界一个子范围。所以，麻叔提到，在“自然”世界里应有“物质与时空的直接作用”现象，虽然不是容易观察到，应有“黑洞”现象，这才是比较完整的“自然”世界相。
    这里就“事件”一词，在唯识看来，也许并不仅仅指“自然世界”的“事件”现象，应是扩大到“显现世界”的“显现事件”，虽然“显现事件”是如幻性，但必定还是可说发生了具“体”的显现事件，没有具体的显现事件，显现现象不可能存在。由于可能词语的含义不同，所以，唯识还可以继续说：事件是更基本的，时空是事件的“属性”。
    显现的“体”，或说显现的“我”，不能说没有，是无常常；相续的“我”，是假，是没有的。这样理解符合麻叔的原意吗？

    二麻子：
时空那帖子没那么复杂。麻子说明时空与物质是直接相互作用的，意思是说明，这点dawa说的很对，时空与物质是纠缠在一起的，就是因缘法的无法割裂。从而说明时空没自体自相自性。黑洞事件地平另一边的事，根本不是我们这边能讨论的。
    当然，我们知道我们凡夫这个世界绝对不可能是法界全部，佛经里也提到过许多它方世界。但那些世界一般来说，也不是我们现在能讨论的。我们的讨论基本局限在我们现在这个物理世界里。我说明了这个局限，是限制麻子帖子的使用范围，因为我不知道出了这个范围这个帖子说的话还有没有意义。所以，麻子很多地方的限制，不是为了全局性，而是为了限制使用范围减少错误。

    云起：
所说的是事件的有序性和同时性，并非时间和空间本身，也不是时空的因缘。时空有不同于物质和事件的特点，并不能用物质和事件的因果说明，麻兄的观点暗含了ABCDEF几个事件就能产生一个时空小宇宙。
    （编按：该段作者认为节略不当，仅此说明。）

    二麻子：
是吗？帖子里俺否定同时性，您的理解比较特别。此外，俺根本不认为时空有什么“本身”，本身不可得。在事物的作用之外如果一定认为还有本身的话，那是自性见。

    “时空有不同于物质和事件的特点，”
    ──这个没错，但也不是绝对的。

    “并不能用物质和事件的因果说明”
    ──何以见得？我没见到您的论据。

    “麻兄的观点暗含了ABCDEF几个事件就能产生一个时空小宇宙”
    ──这是您的特别理解，俺没有这个暗含。俺是显说，只要分析ABCDE几个事件就能看出，有因果显现就一定会有顺序广延两个要素。建议，推论的时候，特别是判断别人的想法的时候，能不能更谨慎一点？

    云起：
时空没有因果，见《楞严经》，何以能用事件因果说明。如何没有暗含时空的话，ABCDEF事件存在于何处呢？从一事件如何过渡到另一时间呢？

    二麻子：
你是说时空不是缘起法不需要遵守因缘果法？嘻嘻。经的意思与你这里的意思一样吗？经中说的是虚空无主宰心，因果无受者。并不是说时空不是缘起法。嘻嘻。我们的时空在膨胀！怎么不变？
    “如何没有暗含时空的话，ABCDEF事件存在于何处呢？从一事件如何过渡到另一时间呢？”
    ──你果然是认定时空只能作为事件的背景舞台。嘻嘻。您尽可以保留你对时空的看法，但不能硬说我暗含了什么。嘻嘻。这是两会事。这地方，你我说话的整个体系都不一样。

    现代宇宙学，宇宙现在不是简单的物质四散，而是时空在膨胀。是有界无边的宇宙的界在涨。这些细节这里也不说了。回答原题，时空是跟物质直接作用的，是因缘法的一部分，而不仅仅是因缘法表演的惰性舞台。这是你我的看法不同处。地球是质量（物质），导致时空弯曲。时空弯曲的表现就是引力，又导致月亮不会跑掉。你说算不算因果？
    嘻嘻。事件必须有“处”，是将时空先设为比事件更基本。但这个先设并无证明。演化必要要“时”完全类同。麻子一直在说时空与物质不可分割，所以讲哪膨胀其实一样。因果是相似相续，彻底割裂开来是不可能。

    静风：
时间上，没意见。空间上，我认为表达的不够。如果把因缘法相续的复杂性，归结为空间。但因缘法不相续的地方呢？因缘法的相续，必定是有为法的范畴。但空间的确有“无为法”的范畴，不是有为法的相续复杂性就难解释。如电脑在运行，旁边有个VCD在放电影（我家目前情况，哈哈）。这是显示两个有为法同时在相续的复杂性。但在电脑和VCD之间，有一段“虚空”，这段虚空里并无任何有为因缘法在相续，是无为法所摄。因此空间的问题与时间很不相同，在时间安立上，有为因缘法的相续相对就能解释和度量，不涉及无位法。但空间上，必须安立另外的无为虚空这一法，通过观待才能完全破除。

    二麻子：
空间的问题多了……
    因为时间主要是顺序性，比较单线。空间反映的是并行的复杂性，细节上难说话得很。比如要问为什么空间是三维得话，就得用空间的自稳定性与因果间的关系来说，极其要命。
    好在麻子并不是要建立一个时空来源模型，而只是要从因果律出发试试看，看看能简单地推出什么。如果能推出不少东西，就侧面说明，时空与事件，空时空与物质，时空与相续，谁都不比另一个更“基本”。
    但是，你说的那段空间一定要安立为无为虚空，在过去可能是这样看。现代在我们这个物理世界其实是不必要的。因为时空里充满辐射，也就是物质，也就是事件，也就是相续。对大爆炸后不久的观测一直显示的是时空与物质辐射一块演化，无法分割开来。
    无为虚空也是一种表述方便。时代不同方便带来的利弊也都会变吧。

    静风：
问题多，多在以因缘法的相续规律，无法解释空间的一些性质，如三维。或者至少很难必然的推理出。另方面，麻叔却说，无为虚空的概念现在可以不必要应用了，因为空间和物质并行，按照现在的观察结果，至少有空间的地方就有物质。
    但这两方面的问题，只要如古论师那样安立无为虚空的概念，就可轻易都解决。无为虚空，无非是指色可以在内穿行无碍。现在的观察结果证明的有空间必然有色，也无非是前进了一步，但照样符合无为虚空的定义。况且，说色可以穿行无碍，亦无涉及到色与虚空哪个更基本的问题。同样可以符合我们的假设，认为同样基本或者至少空间不必比物质更基本。而三维等性质，无非都是虚空这一法的性质而已，如水是流动的，火是热的，空间是三维的。亦不必再费力的从物质的相续上去推理空间的性质了。我一向对我们古代的论师们很有信心，因为我们反复研究的东西，经常会发现也并未脱离他们的想法。古论师们也安立时间和空间。但只有空间被安立为无为法。时间却没有，只被安成了一个心不相应法。这说明古代论师们恐怕也是思考过这个类似的问题的巴。

    不动：
在这个层面里这样讲是不适用的，原因很简单，真正能在大乘里安立得起来的“虚空”是有其他含义的，不是在空间讨论里的虚空。你所立的有部的宗（古代的论师）正好是中观要破除的。大乘佛经里，如果要谈虚空的话，有做比喻的，但是也有很明确的说这个比喻是有限的，所以按照有部的传统把虚空定义为非缘起的“无为法”，不是在所有的佛教环境下都行得通的，在专门讨论这一问题时候尤其，这甚至在佛教辞典里都已经表述得非常明确了。

    二麻子：
嘻嘻，不动兄说了，此虚空非彼时空。确实与某段空间不是什么直接关系。而且从无为虚空也推不出空间的维数来。嘻嘻。注意，我们不是在建立什么时空理论，我们只是换个角度看问题，破一些常见的顽固的执着。

    静风：
空间，色可以在里面穿行，我这概念够共许了。中观其实根本没反对过。“维数”没必要推论出。只不过是虚空这个无为法的一个特性嘛。再说清楚一句：空间具有有为法相续不能完全缘起的特点，至少在有漏的凡夫看是这样，所以要成立他具有无为法的特性，以解决他那些有为法缘起相续不能完全成立的特点。这不就是麻叔提到的空间上面临的种种问题吗？

    不动：
“无为虚空”这个定义的弊端是可以把色的实有都定义出来的。当然，这是有部定义的简版。这么说甚至可以理解为有二法，一空间、二色，而且这个空间被定义为无为空间，那么你定意的色和空间是一是二？你那个定义的“空间”是非缘起的无为法的话──如果是一，色的“刚度”如果和空间一样，不是多少变成了无为法？如果是二，岂不是变成了实有法？这样的定义是从婆沙论里辗转来的，所以问题到推导的色法的定义上，就容易看出问题了。这和有部所以称之为说一切有部是紧密联系在一起的，“有为三世，无为离世。其体皆有，名一切有。”。比较精确的不涉及有无无为的定义成“不碍”就行了。我们对有部的伟大成果要尊重，但是在这上面观念就是不一样，这是要明确的。
    而且这样说的这个空界甚至不是有部关于“无为虚空”的定义，有部也根据根据把虚空分成了两类，有为和无为，你说的是属于有为虚空的，正式的有部论中定义为色法，他这样定义是概念性的，当年讨论的原文都还存在，见下面的引文，我看也没有什么一定的结论，有部的无为虚空的概念有一点是象从类似“绝对真空”走到心法的部分，具体怎么样我们不分析评论，看他的原文，实际已经是和用心联系在一起的范畴了。（编按：这里有一段略去的引文，见《阿毗达磨大毗婆沙论卷第七十五》“空界”一章）──在前面引文的基础上，也许比较容易理解中观为什么这么说。“如虚空种种求相不可得。余五种亦如是。问曰。虚空不在初不在后。何以先破。答曰。地水火风众缘和合故易破。识以苦乐因故知无常变异故易破。虚空无如是相。但凡夫悕望为有。是故先破。复次虚空能持四大。四大因缘有识。是故先破根本。余者自破。”（编按：这里有一段略去的引文，见鸠摩罗什译《中论·观六种品第五》）

    二麻子：
“空间，色可以在里面穿行”这个概念未必够共许。说鱼在水里穿行无碍，所以水是无为法吗？嘻嘻。1、这是用运动定义空间，而运动是空间定义的。2、物质（色）不是简单的对空间无影响的在空间里穿行。凡质量所在，时空就弯曲。厉害的时候成为黑洞。
    “维数”没必要推论出，那有没有无为虚空，在至少是时空问题上没显示出必要性来。现代时空理论说的跟你这个说法不符合，物质时空直接相互作用，不是什么无为法。

    yxy：
我认为虚空可能是个东西，时间不是东西，空间可能也不是。“时空和物质直接相互作用”，有把时空当作东西的意思。说说无妨，若当真就错了。这是现代物理的思想，中观不该这么看，唯识的安立也会与此不同。如果一切都不是东西，功能和显现又是什么东西？

    二麻子：
嘻嘻。连物质都不是东西。特别不是你现在说的这个东西，嘻嘻。因缘法里，讲相互作用，讲功能，讲显现，就是不认为这里面有个“东西”，包括物质。如果一定要把功能作用显现等说出个东西，那么它应该是我们执于自性的传习。

    yxy：
我们的串习又是什么呢？

    二麻子：
若答是A必问A又是什么，于是答B……继续可以问，乃至无穷。可见串习之力量。

    dgrldgrl：
 功能显现外的独特主体是什么？

    二麻子：
是自性，也就是凡夫虚妄执着。

    2004年七月

    科学与佛学论坛
    网海莲舟论坛


相似相续不需要载体

    林安和：
    刚买了电脑上网就发现了这个网站，感觉很幸运。末学很仰慕龙树的中论，反覆研读。却在四年前遇到疑难，未能与决。希望常上这个网站的诸大德们能帮助我。中论的业力观。有别于俱舍论中的三世实有，也不同于唯识的阿赖耶说，其它诸如“不失法如卷”等部派佛教论业之说，龙猛在中论业品中也呵其不备，那么不靠上述之说，中论究竟如何建立它的业观呢？造了业之后，在还未感果之前，不说种子，那业在中观又如何不落常见又能感当来果？是何面目呢？末学穷数年查阅中文有关经论（末学英文欠佳），教内以解了中观著称的大师们的大作，内中对此多是鲜少述入，末学也曾亲炙多位大德法师，也许福慧资粮不足，并未解悟，仅在月称论师的入中论中，如晨曦般的说了一句：由业非以自性灭，故无赖耶亦能生，有业虽灭经久时，当知犹能生自果……宗喀巴大师的著中亦未述及，仅表示此乃中论最不可思议，甚深之处，故请诸位网上善知识能有以教我，以去多年大疑，顶礼再三。（末学不太会用电脑，不知道信箱是这样留吗？）

    林广：
    林安和本家，您这问题其实很多人都有疑未解。其实这是个错误前提导致的问题：业并非需要载体才能（相似）相续。但这点与我们凡夫日常经验建立下的“直觉”相违，不容易被接受。相似的事科学界也出过，当初对光电磁波，大家都想找个介质，甚至起名叫“以太”。有很长时间，人们不能接受电磁波不需介质，在真空里就能传播。但事实上，电磁波就是能在真空里传！觉得业要有载体的本质，其实就是常见。中论当然破这个。

    林安和：
    真的十分感谢林广的回应，事实上就以载体为譬喻的量的话，末学也曾以之深思，所遇到的疑难是，若业生复灭后，不需载体就能引生当来果报，则一物灭后应生无量果，又灭已后生，无相应相续，如何感果无差，上述所说，恍如断见，若有载体，刹那迁灭，若能常住，违如常见，请再以教我。

    对于林广的譬喻，末学初闻，无比踊跃，但于讽颂中论时，忽生疑惑，以林广之喻，成立比量，电磁波不需载体，即能自在传播，则是电波，由此至彼，无诸更易，还是一法，则业由初生，至未来果，无诸更易，恍若常法，龙猛呵之，末学障重，复生忧愁，望再澍慈雨。

    leeyc2：
    安和兄：一、蛮钦佩你学习佛法的毅力，也希望你介绍一些中观论的参考书，让大家共同学习。二、我猜林广兄或是把阿赖耶比为以太，而用电磁波说明业力不失吧（如弄错，勿怪！）三、电磁波一样是因缘生法，如由加速粒子形成，电磁场不断振荡变化，也会受周遭环境影响，且有折射反射甚至转换成其他能量的可能。四、我对佛法虽有些兴趣，却老未下功夫学，看到有人如此认真，很惭愧！

    林广：
    本家当心！
    电磁波如何会是“一法无有变异”？有“由此至彼”即是变异，不同时是变异，场强改变是变异，更别说遇到物体的反射等等了──全是因缘和合，无常，自性空！
    物之（显）生灭，（相似）相续无住刹那不停，根本无有灭后再另显之事。作“灭以后另显”观者，凡夫断常揉合之见也。本家此处也大大需改进。仍依电磁波为例，绝非从甲处灭，停一段时间，再在乙处现。而是即甲处显生时，即甲处显灭。而渐传至乙处。业亦类此。业果也类似，只是其中有些过程，我等粗心不易观到而已。
    相似相续中，一物实缘无量果。如吃饭，吃已，其果非仅为“饱”，也长身体，也造肥料，也夺他众生食，也与他众生食……究其后效，竟不可尽！本家，因缘之法，复杂纠缠无有穷尽，决非一因一果之简单。以一因一果为说者，仅为简易说，非深说正解。
    LEEYC兄，麻子是说，电磁波根本不用要以太，就能传播。以喻业果不用“载体”就可（相似）相续。

    林安和：
    十分感谢诸位菩萨的慈悲，尤其是林广，末学对林广所示，内心深以为然，其实在末学读至入中论之“由业非以自性灭……”之语时，如受雷击，但疑心凡夫之资，或谬解之，末学窃以为，向来观因缘法，如此到彼，如一直线，但读斯句已，念因缘法如帝释珠网，非惟一点一线一面，实如立体世界，无量相应。但未决疑。闻林广菩萨教授，或能安心。又，或许末学障重，菩萨所言，一因多果，龙树大士，十二门论中，数数诃之。谨白菩萨，望鉴察之。为末学谬解大士旨意否？

    林广：
    林安和本家，一因不结相违背果。如种豆不结西瓜，但如说连豆叶也不可长，豆秆也不可获，笑谈也。此理明显，何必再论？本家读十二论及一切经书，万不可死于言句下。

    （编按：本篇转载自台湾佛教网路论坛所整理的贴文，越尘居士当时使用的笔名为林广，其他篇后署“台湾佛教网路论坛”的均亦为从台湾佛教网路论坛所整理的贴文中重新编辑，谨此说明。）


盯住我执，创造修定的良好缘起

    savelife：
    不知道为什么我打坐的时候觉得自己有一个很重的我执观念隐藏着，（或者说我感觉有一个很重的我执存在着）可是不知道该怎么驱除之。诸位善知识请指教。谢谢！

    林居士：
    曾从善知识处听过有关修定前次第的教授，依稀记得少许而已。既有所问，不敢自珍，谨就所记得的片段复述少分。我无修证，只为鹦鹉学语，或有错漏，当为本人之失，请明鉴之。
    其实不论六度、三学（戒定慧）、三慧（闻思修）、八正道、三十七菩提分等名相均有次第上的含义。没有一种是把禅定放在最前面的，足证佛教中真正修定不是一开始便跳进去的就一定能有好效果的。《天台小止观》把上坐前的前行次第说得较仔细，应该参考一下。
    持戒与闻思放在定之前是有其意义的。闻思为立正见，无正见而修定便与外道同，而此正见除了无我空性的道理，初修更主要的是无常、因果不虚、轮回苦等的要养成很深的习惯性思维，不然在定力深入后，无始以来三毒的习气随时爆发出来就连最基本的防线也没有了，到时有的连佛教徒也许也不愿意做。
    持戒是最简略的定前善行基础，通大小乘，摄归依戒与别解脱戒，大乘还有菩萨戒（未在仪式上受菩萨戒也应恒持菩提心）。若为较广义的善行基础便包括布施等（密法中则有不共加行的修法，显教则常用拜忏、培福等方便）。为什么有正见之外也要有善行基础？简单点来说就是我们的一身不知道从过去带来了多少业障和宿债，但平常粗心（不是大意那粗心，是粗细的粗）时多不会显出来，但习定心行较细便会转为明显，有时是身心的障碍，有时是境界的障碍，有时则为魔患（债主临门）。很多外道练气功深入的见到什么的若不是吹牛便往往是这种，不明白的便觉得很厉害，一起信了，反之则以为是精神病。戒等善行基础除可净除很多此等障碍外，守归依戒者有三宝所护（诺那祖师法语中好像有个念归依退鬼的典故），别解脱戒清净者有戒神所护，发大菩提心者更有天龙护法发心守护（金刚乘弟子若三昧耶与对上师信心清净也有传承护法守护），很多障碍在出现前便已被消除了。因此有的成就者的传记内便可见，严格依次第修的往往有很多年都没有什么特别境界。反而是一些什么功的常常修几个星期或更快便会见这见那的。
    再说六度也不是硬性的六件事，当中可以一度圆摄余五度，或说是每度都不舍余度，只是按修证的次第，有经和论的教证说明有各度增上的次第。个人在一生中也可按自己的宿习和根器把这些次第融会在修行中。例如布施：能施财或生命（放生）而不夺他者是戒，在施的过程中不为闲言讥讽所动是忍，在逆境困难中坚持是精进，施时心住于为一切众生证觉的菩提心而行是定，施的三轮体空是慧等，于初地现证空慧时方真正圆满。若从施、戒、忍、进的增上次第修起（依前义也可说为定前善行基础），到专修定时就更容易深入大乘不共的无我空慧。这才是佛教习定的真正目的。

    二麻子：
    savelife兄，不妨也从技术层面看看你这情况。
    依麻子一管之见，你这个情况不但不坏，作为“初级阶段”还相当好。首先，你看到了我执。同样这个我执在日常中处处都是，我等只因向外攀缘太重而没注意到。现在座上看到了，以后慢慢在座下也能看到。对认识自己是前进一步，有什么不好？
    第二，能看见感受到这个我执，说明你上座时是用功的，而且是有效果的。有什么不好？
    第三就更妙了。你想除去它吗？这个想法也是它。怎么能除去？反会增长他，这大概是你觉得不舒服的原因。但相反，若你不专想驱除他，而是用心死盯住这个我执，排除一切其他妄想地去体会感觉这个我执，就把这个感觉当作修止的所缘境，嘻嘻，效果就不大，甚至大不，一样了。嘻嘻。不妨试试呀。

    savelife：
    请教麻叔一个地理上的技术问题，麻叔所言的第三种大概就是我目前的状况，后学会依麻叔所言练习。另外请教您一个地理上的技术问题，让您见笑了：打坐时除了不能受凉、吹风、情绪过份激动、身体过于疲劳等等之外，在打坐的地方的地理位置上，应该怎么安排合适呢？房间的摆设有没有讲究？
    毕竟人还是会受周围的环境的影响的，尤其是藏传佛教中非常讲究缘起，不知道打坐所在房间的地理位置以及房间内的摆设的安排，对打坐有多大的影响？有没有需要注意的地方。
    另外有一点想请教的就是：藏传中对于缘起那么重视，我们这些后学应该如何做能够创造良好的缘起呢？什么是创造良好的缘起的最重要因素呢？
    除了这个重要因素之外，有没有什么技术细节需要了解呢？

    二麻子：
    创造良好缘起的关键是……修学菩提心。然后是祈请上师，诸佛加被。地理上的事，有作用，不是决定性的。打坐的姿势是需要调整的。这个网上说不明白，找个打过点坐的人都可以看出你坐正，坐直没有。


在观待形成以前，根本无从谈起

    在观待形成以前，根本无从谈起

    二麻子

    应成怎么悄悄变成唯识了？麻子偷笑了半天。嘻嘻，麻子绝对不是非议：在应成里论缘起，不知不觉地变成大千说得准确，正说明唯识的价值吗。
    大千说：“‘安名处’、‘缘起显现处’跟‘缘起和合的地方’都是离言境界，不是观待出来的，‘相’是名言境界，是安立出来的。”
    这个按唯识看很是自然，按中观看，应该不是这样说的吧。
    依照应成的缘起安立，根本没有什么“安名处”“显现处”。
    “和合的地方”——名前觉无吗。在观待形成以前，是根本不能说什么的，根本无从谈起，而不是有什么处。
    当我们说意识将法界因缘割裂观待而形成观念上的“有”，并不是说我们在割裂前，需要有个“有的素材”。“有前的原有”是根本不需要的，要这个反成累赘。
    “有”，包括素材以及我们的凡夫意识，都是在割裂观待过程里形成的，割裂观待并不需要更有个来处，也不必需作为对象的素材。相反，这些东西正是割裂观待过程的产物，是这个过程里凡夫生的自性见。当然，这个割裂观待的过程实际上如同滚雪球，割裂是反复滚大滚明显，而不是一步成功。
    下一步的割裂可能用了前一步已有的割裂做基础，但是这个过程并不需要个源头处。如同说无明无来源一样，割裂观待实际上就是在某个粗细程度上直接说无明，不需要再追究来处。否则也就等价于问无明哪里来的。
    仔细仔细……“万有引力在牛顿以前还作用不作用？”
    千万别被这话唬住。隔壁那小子用这话糊涂别人，我怀疑他自己也一样糊涂了。
    这样的话，牛顿以前的人能问出来吗？不能。能问的，200％是牛顿以后，明明观待了引力，偏要用个“以前”来糊涂别人。嘻嘻。不知道是不是连自己都唬了。不就是现在正在观待牛顿以前时候的引力吗。
    对任何一个个体，在割裂观待出某法之前，是谈不到该法的。是根本谈不到，谈有没有都嫌太多了。


帮香严唱戏

    二麻子
古慈兄看进来……嘻嘻……嘿嘿……
    （公案）“禅师云：如人上树，口衔树枝，手不攀枝，脚不踏树。树下有人，问西来意。不对即违他所问，若对又丧身失命。正与么时，作么生对？有虎头上座云：上树即不问，未上树，请和尚道。师呵呵大笑。雪窦云：树下道即易，树上道即难。老僧上树，致将一问来。”见传灯录十一，会元九。
    那个香严“上树”公案看几位已经炒作了好几天了，没见到个真看懂的。嘿嘿，所以麻子无事生非，倒要问问古兄一下：古兄看懂了吗？如果还没反应过来，麻子提供点……

    一、香严这是“夺饥人口中之食”，说来够狠。可惜呢当年在座的大都像虎口叼羊，夺不下来呀。这法子用得温和点，就是那（＠＊＃＆＊＃＠）七个怪字之类的。如果古兄自己先想到那七字与这公案相通，麻子就要为古兄高兴了。嘻嘻。

    二、那个上座答的意思，不过是说“就算没夺下来，他们就真吃得下去吗”。所以，这位是通人，知道夺下不夺下，都吃不下的。嘻嘻，相当厉害。香严笑笑是这原因吧。这点古兄看出没有？

    三、即使如此，上座的话仍然有失引导后学的方便，让一台好戏没唱下去。所以香严不答他。

    ──最后，如果有些弟兄们包括古兄联想到什么看明白点什么，嘿嘿，知道归元无多路，也就行了。不需要说太具体。

    zs：
    嘻嘻，麻叔，这一下进得去吗？最后还是“雪窦云：树下道即易，树上道即难。”吧？

    二麻子：
    嘻嘻，已进的早进了……没进的还是没进。所以这事不容易。古代禅师们隔三差五用机枪扫射，也不过打中几个。嘿嘿。
    嘻嘻……麻子扯点闲话……这公案有个非常好的转语，比那位上座的要好，比那位弹指头的长老也回答得好些：“树上先置，且问如何上得树的？”如果是在当时有人这样答，这就帮香严唱戏了。
    不过这放在坛子上是一点利益也没有的，只是闲话。当游戏可以玩。真上瘾是自己骗自己。


有些事不必过早担心，修来就知道

    abu：
    请教，佛陀涅槃后还有没有？或者还有作用？请师兄们正面回答！不要说非有非无，亦有亦无这样的话。也不要说这是戏论。众生是戏论，然而并非没有；涅槃是戏论，然而并非没有。有还是没有？！！！！！！！！！

    二麻子：
    嘻嘻。这问题，请您反面想想再侧面想想……想想你这个前后是就谁说话的？
    如果是就佛说，则涅槃即无三时，非有无，还谈什么涅槃“后”，谈什么有无？
    如果就众生说，那与佛涅槃有什么大关系？
    佛经你不是在读吗，这不是佛陀的作用吗？

    savelife：
    感谢您和诸位善知识的法施。学中观，我总是担心破到最后什么都没有了，会不会落入断见。学唯识，我总是担心自己在理解那个“清净识”（或者说转识成智的那个“智”）时落入常见。请您谈谈如何在学习中观和唯识时避免这两个问题？

    二麻子：
    嘻嘻，老弟一步一步来，干嘛发急？
    你也看见，为了掰明白点无境就是根本没有境同时根本不是断灭，那花了多少功夫。又有多少效果还不知道呢。
    所以，你也不能那么急呀。
    你说的那个常，纯粹是思维推断的常，这种常见其实没多大力量，因缘到时，说破就破了。比较难破的是修到某个程度人产生常的直接错觉。
    这个比较难破点，也有相当有效的方法破。
    所以，有些事不必过早担心，修来就知道。


契入第一念的前行和第一念的差别

    契入第一念的前行和第一念的差别

    二麻子

    兄小心了……
    “觉照第一念法，即为心中一起无明、烦恼时，立即觉照出，将其断除之法。”
    ──是个极殊胜的方法，但还不是第一念！若以此为第一念，会误导。
    第一念者，直契真如本来，无有能比者故，名第一（无上意也）。第一念无有先后相续，若还能有前后相比较，不是。
    然此法可为契入第一念的前行，迅速积累福慧二资粮，故实应赞叹。麻子随喜……
    兄可看看禅宗里，对第二头第三手是怎么说的。又，可参考参话头与赶话尾的差别。
    您若定要重新定义“第一念”也不是不能做，只是不免有人会因此疑惑。
    至于“第一念”与第N念在实修上力量的差别，参话头与赶话尾的差别，禅门也都有论述，兄只管看了与自己实修时心行比一下，就可大略知道其不同。
    个人建议，兄不妨多修点座上功夫，可能有利于您前进──一管之见，难免偏颇，兄斧正。


只不过是能所对立比一般情况细微了些

云飞月:
麻叔在《越尘集》中谈到切断妄念之流，一刹那进入的状态。后学没有修持，说说生活经验中的类似情况（或许人人都会有这样的体验），向麻叔请教。
    当我们沉浸在思念中的时候，随妄念之流冲浪，此时是观察不到妄念生灭的，专注在妄念（思想）中的时候，有时对其他的甚至浑然不觉，比如专心地想问题或与人交谈，别人来喊，有时也不知道。这就是无明，我们凡夫整天就在这种状态中（累世串习而成的凡夫定）。
    另一种情况是，回光返照观心，有一个能观的“我”好像坐在岸边看小溪的流水，所观的妄念像流水一样一波一波地流淌着。这时切断妄念，一刹那进入一种能所双忘的状态，一切历历清明的样子，没有身体及内外的感受，意识不思维作意，历历清楚的音声或眼睛看到的景象也不引起思维作意，就是那个样子！只是极其短暂，接下来自然感受到（应该是我执生起了）身心舒畅，紧接着妄念又起来了！如果观察呼吸，假如是在呼气的过程中切断妄念之流，一刹那进入那种状态中，在吸气的时候妄念跟着又来了。
    这种情况在我们的生活中，比如夏日躺着无所事事地仰望繁星点点的夜空，在思维停止后的那一刹那状态，又比如费尽辛苦地登山，到达山顶时一览众山小，而心情舒畅、思绪停止后的刹那状态。可能在每个人的生活中，都会有经验。
    请问麻叔这是不是一种正受？后学没有修持，没有定力来延长它、加深它，见道或说明心见性是否是从这里开始深入的？

    二麻子:
没法给你绝对的回答……过去有大德在类似的情况下契入了空性。
    但，一般说来，不是。就好像有古德打铁成就，但一般说，打铁的人都没成就一样。
    你上面说的情况，在绝大多数情况下，只不过是能所对立比一般情况细微了些，所以习惯了粗重能所的心不能识别这时的能所对立，而感觉似乎没对立了。同样，也不能就此超越能所对立的执着。所以，没什么可说的。


广泛地去比较自己哪里错了

    广泛地去比较自己哪里错了

    二麻子

    这里麻子重弹一下老调……
    如果你只是在思维逻辑范围里，那么逻辑可以说明，寻求第一念从哪里来的这个问题，本身是不符合逻辑的。方法如下。
    若第一念从A来，则A就成了新的第一念，又需要寻找从哪里来……如此下去永无完结。
    如果你学禅，参这个话头，真的得力参进去了。最后，你会现量体会妄想无根。
    千万别以为圣人们会像我们一样有这个问题，只是圣人们比我们强，知道这个问题的答案。嘻嘻。那就冤透了。圣人们确实知道的是，这个问题并不存在。

    “不过我觉得圆觉经有句话似乎对此解释的很好：‘未出轮回而辩圆觉，彼圆觉性即同流转，若免轮回，无有是处。’此句话我感觉是在说在我们还未开悟之前此问题是不可能完全理解的，就像是在梦中说醒时之事，或是像某一故事所说的某个人向一个生来就眼盲之人解释什么是白色的故事那样，认为‘嘎嘎’就是白色。不知是否如此？”
    ──这段理解大致差不多。麻子再举个老例子，也许有帮助。
    做梦的人在梦里，能找到怎么开始做梦的吗？不过就是“一念不觉”或“一念妄动”，就做起梦来了。想找到开始是不可能的。你还能怎么说？
    希望有个满意的“开始”，这本身是无明呀。
    嘻嘻，比喻就是说有些地方很像，有些地方不像。如果全都像就不是比喻而是精确描述了。所以，看比喻的时候要小心，不要引喻过量。
    用梦来比轮回，有很像的地方。但有一处很不像。梦醒了，还有个我在，这是个体，梦虽不执了，我执还在。轮回醒了却没有个我剩下。更精确点说，没有我执剩下。
    所以，用梦比轮回，可以的。用梦醒比成佛，要小心。
    特别是用梦醒后剩下的来比佛，非常容易出错误，要大大小心。
    麻子只写出校正错误。没具体写用什么方式校正。具体方式很多，向老参请教，同修讨论，学习经典等等都是。
    密教弟子，这不是很难，只要你的上师真有料，就问自己上师好了。
    不在密教有点麻烦。因为现在显宗下真有料的好像很少公开自己有料，能印证别人。公开喊能印证别人的那些，似乎又，嘻嘻，有点这个这个……
    但也有些办法，不过慢点。基本上，如果你不期望印证自己“对了”，而是反复地广泛地去比较自己哪里错了，并将错误校正。那么慢慢地，你终究会对了。
    真对了时候，还是会有能印证的人的。而且这时候，你也知道这样的人是真能印证的。
    现在时代，明师不容易找到。另一个是，现在学禅的人违背了学禅的“次第”。大概有人会用六祖做例子反驳麻子的“次第”说。嘻嘻。是有例外。但所谓例外，就是极少发生。学人不可以期望自己就是例外。那末违背了什么次第？没先学经教。禅宗兴旺时，经禅开悟的人大多在没入宗门前，先在教下修学很多，佛法的经论，基本原理都是通达的。只是没到现量上。现在的人这里可缺多了。同是汉地佛弟子，切肤之痛，更复何言？
    唯愿一切正信佛子，同心同德各自努力去改变这种状况。与兄共勉。


小石头用文字精确描述出来，能吗？

    bffl：
    不说清楚是一个很坏的习惯，确实有一些东西很难说清楚，但我们一定要努力说清楚，我们要一点一点地不断地战胜无明混沌。

    二麻子：
    嘻嘻，老兄，麻子给你出个小难题……去门外随手拣块小石头回来放到桌子上。这小石头可算实在了吧。请您把这小石头的形状，用文字精确描述出来。能吗？

    bffl：
    确实不好描述清楚，但是小石头是实实在在地存在着的，我可以看得见，摸得着，别人有疑问我可以让他也看一看摸一摸，如果硬要描述，我就采用最简单的描述方法：一块小石头，这样别人也可以有一个大致的了解，因为大家都见到过小石头。

    二麻子：
    嘻嘻，这个小难题只是为了说明……你说“不说清楚是一个很坏的习惯”是很有些过分了。如果我把小石头换成昨天你在某饭店吃过的某道菜，要你描述味道，嘻嘻，你的办法好像就又不管用了……

    bffl：
    有一些东西最好不要描述。比如吃了一道好菜，于是把这菜描述的天花乱坠，最后说：你们也去吃吧。我觉得这个人有病。各人的口味不同，你喜欢吃的别人不一定也喜欢。我同意有一些东西不好描述，不必描述，因为这是属于非常个人化的东西。

    二麻子：
    禅观内证正是如此……但还是要跟人说，说解脱道。怎么办，只好说了半天……


你偷的到底是什么？

    不懂了：
    依小乘、中观、唯识，“观”都是指观察思考空义；但，禅宗却是排斥思维的，这是为什么？
    依据一般的讲法，定只是强行压制烦恼，修观则能悟空性而得根本智慧。但是，大乘起信论却认为：止是止于空义而得根本智，观是观察因缘差别而得后得智（依慈航法师的起信论注解）。请问这些矛盾如何理解？

    二麻子：
    兄弟您不懂是书没看够，所闻不广造成的。

    “依小乘、中观、唯识，‘观’都是指观察思考空义；”
    ──是，但不全是。观察思考是观的一部分，叫毗婆舍那。还有三摩钵提呢。你好像不知道。找经论看看，就知道了。

    “但，禅宗却是排斥思维的，这是为什么？”
    ──不是。禅宗不排斥思维，只是明白指出，仅靠思维不够。注意，唐宋时代去学宗下的，多是在教下修学过很久，思维过很久，基础扎实。这时禅宗如画龙点睛，引导其超越思维的局限。并不是禅宗排斥思维。

    “依据一般的讲法，定只是强行压制烦恼，”
    ──这是一般讲法，并没能包括一切情况……

    “但是，大乘起信论却认为：止是止于空义而得根本智，观是观察因缘差别而得后得智”
    ──起信论这段没错。但这里的止与观不是一般意义上的，而是对已经契入空性的行人来说的。否则，若仅是思维空义，就根本没法止在思维空义上，心不是这个用法的。

    智行：
    不懂了兄，提供一点摸象之见。先举一例如下：设有哗众在，吵闹哄乱，某欲使其静，乃呼“安静！安静！”，众哗若歇，则无需再呼“安静！”，不然反被呼“安静！”声所闹。今思维空义亦好比呼“安静！”法。
    隋朝慧思禅师举大小乘人之执时指出：小乘人只知思维，不知一心，所证有限（愚按：如上，执呼“安静！”不舍）；学大乘人有执一心，而欲舍思维（六识）而得一心，不易得入（愚按：若离呼静之法，则众哗不歇）。宗门的手眼不落常套，该呼静时则呼静，该止呼静则止呼静，不能说禅宗排斥或不排斥思维。教家又何尝不如是？但天台教法有其系统，可次第可圆融。三止三观乃慧思禅师依《起信论》义所创，传于智者大师，由智者广传天下。若欲知其概，除《起信论》外，还可读慧思禅师的《大乘止观法门》，言简义丰，难得的佳作。修学的部份，智者大师说得详细。
    再者，大小乘虽都说空义，内涵非常不同，要留心。小乘说空只说到因缘法无自体，无自体故空。好似吾人分析万有，都由因缘而来，无常恒不变之主体，此是从相上分解，容易理解。但最后留个“尾巴”──空相、和思维空相的思维（此是法执的一种）。
    大乘的起点较高，观诸万有如梦幻境界，本来非真实有，亦无起灭，梦幻起灭时正是无起灭，因为梦幻起时实无所生，梦幻灭时实无所灭，本来就没生起，所以根本无所谓灭不灭。但梦幻起灭来去，其相宛然，而知觉之觉性不灭不动。知觉之觉性性本不可灭，亦无所生。凡有强压令己无觉，都未入真实大乘。
    由此可知，观梦幻境界有而全空，即体真止──止时有观，称作空观；幻境宛然，灵觉不灭，所以空而不无，即方便随缘止，止时有观，号为假观。其实一个观即是另一止门之开端，一个止又是另一观门之开端。知幻非实，故能止妄，能止故，进而能观诸法实谛，能观诸法实谛又增止力，互资互进。此二观实为一体两面看，觉性的两种用法，实际上只讲一件事，好像说镜中像，说有说空都是说镜中像的两种特点，有时非有，空时不空。水中月亦如是，万法皆然，觉性若水，万法似水中月，月依水现，水中月现，水月互为体相，不即不离。所以但能不执其空的一面，不执有的一面，就是“息二边分别止”，双泯双照（泯二边分别，而又空假二谛双照），称其为中观。三观说透了只为一心说三种用法，若解得空有义，则三观实为一观，中时即有空假，空时即有假中，假时即有空中，又叫一心三观。说法为三，只为易解，其旨是一，根本看不到矛盾。
    《摩诃止观》中，多用念佛法修习止观，所以也可从净土门入如来禅法。只要有净土所需之信愿，纵不破惑，亦必往生净土。所以天台列祖皆求生净土，甚是明智，学台宗者不可不察。

    不懂了：
    请帮忙。一般来讲，初学者学佛，总是以思维开始的。数数观察、思考缘起无自性。这是一个“动态”的过程。说白了，老是在想事儿。这个动态的思考总得有个结束的时候，从动态转为静态。而从动态转静态的转折点就是所谓的开悟吧？这样说对吗？

    圆觉经讲的三摩钵提等三个方法都是说的开悟后的事情。那么，开悟前是否只有思维空义一条路？
    如果说只有思维一条路，那么，禅宗只用疑情，并非思维，这是什么道理？
    如果说仅仅靠思维不能开悟，那么声闻是如何开悟的？
    如果说靠不靠思维都能开悟，那么禅宗的优势是什么？除思维以外，其他的方法是什么？
    最后，疑情导致开悟的原理是什么呢？有人把起疑情后善知识的提携比喻成“震荡疗法”……

    二麻子：
    思维思维……

    “一般来讲，初学者学佛，总是以思维开始的。数数观察、思考缘起无自性。这是一个‘动态’的过程。说白了，老是在想事儿。这个动态的思考总得有个结束的时候，从动态转为静态。而从动态转静态的转折点就是所谓的开悟吧？这样说对吗？”
    ──不是。开悟不是动态静态，不离动静。

    “圆觉经讲的三摩钵提等三个方法都是说的开悟后的事情。那么，开悟前是否只有思维空义一条路？”
    ──又不是。我上贴说的是，起信论里那一段讲的止观都是契入空性的行人用的。

    “如果说只有思维一条路，那么，禅宗只用疑情，并非思维，这是什么道理？如果说仅仅靠思维不能开悟，那么声闻是如何开悟的？”
    ──前面的不成立，这里的也不成立了。

    “如果说靠不靠思维都能开悟，那么禅宗的优势是什么？除思维以外，其他的方法是什么？”
    ──进死圈了吧？所以说，光靠思维对绝大多数人不行。

    “最后，疑情导致开悟的原理是什么呢？有人把起疑情后善知识的提携比喻成‘震荡疗法’……”
    ──谈不到原理，原理是思维心中的一个概念。

    ──思维是需要的。希望你思维得严格些，上面你的思维过程里，马虎搞错的地方太多。说明，您需要继续思维，把自己思维理得更条理些。

    不懂了：
    您说的“一昧”是否指悟得空性？您的意思似乎是说，只有悟了一昧后才谈得上祖师禅。如来禅也是要悟得一昧后才谈得上吗？
    如果已经悟得空性，有了落脚处，下面的事情好办一些。我的疑问一直是关于如何悟得空性。是当下体会？还是思维缘起？思维之外，别的方法是什么？
    疑情属于祖师禅。既然祖师禅是悟得一昧后才谈得上，那么悟得一昧前疑情有用吗？

    二麻子：
    仔细检点自己的思维……

    空性以及契入空性都不“是”什么。契入空性发生在行人得以（至少）调伏能所对立之幻象，不为此幻象所惑时。你一定要问“是”什么，也就是强要放在能所对立下去，嘻嘻，你说这算什么？比方现在问你“你偷的到底是什么？”，嘻嘻，什么先不论，偷字反正先栽上了。

    “疑情属于祖师禅。既然祖师禅是悟得一昧后才谈得上，那么悟得一昧前疑情有用吗？”
    ──断语下得很结实，凭据是什么？疑情是修学手段，谈不上什么禅！你是不是能在思维时更仔细些呢？

    “如果已经悟得空性，有了落脚处，下面的事情好办一些。我的疑问一直是关于如何悟得空性。是当下体会？还是思维缘起？思维之外，别的方法是什么？”
    ──是什么不是什么现在对您来讲没多大实用价值。建议是加强基础。

    见慧：
    学日益，道日损。

    二麻子：
    没粮食吃的时候，何不食肉糜？初生婴儿怎么损？为什么没成解脱反而都长成俱足烦恼的众生了？这个过程能用损停止不能？若不能，嘻嘻，还是得学。


不汝还者，非“是”个东东吗

    明心斋主人：
    楞严经中说“诸可还者，自然非汝。不汝还者，非汝而谁？”，“心性”为什么要到处“还”呢？就说因缘和合不就行了吗？古兄说：“还——为了体验缘起性空，而且是从明显的粗分缘深入到微妙的微细分缘”，“还”是有破的成分在，您说的不错。但是“还”完后，找到那个“还”不掉的东东，这个是否是中观宗不太爱做的事情啊？

    二麻子：
    这里有根稻草，能不能救命就不知道了……从“不汝还者”，明兄就想到不还者是个什么东东，这似乎添了点东西呢。不汝还者，非是个东东吗？这话里，麻子强调的不是“东东”一词，而是“是”字。

    明心斋主人：
    是不是和这段有关啊？“我真文殊，无是文殊。何以故？若有是者，则二文殊，然我今日，非无文殊，于中实无，是非二相。”

    二麻子：
    有点关系。就“是”字用法来说，非常像。但是这里的那个不还者，根本不需要“是”任何东东。它根本就不能是个什么东西。凡是“是”的，都在因缘法里，也都能被“还”掉。还不掉就非因缘，也就根本不能“是”。
    绕到这里，嘻嘻，明兄应该把“是”或“存在”或者“有”这个概念的建立条件仔细推敲一番了。嘻嘻。


梦里问梦从何始

    疑问：
    您能为我们解释一下吗。如果说法不是从无性性中生起，那么，法是从什么中生起呢，是从因缘法中生起吗，那因缘法又是从什么中生起呢。

    二麻子：
    您这里“法是从什么中生起呢”中的法字，意指一切法，任意法吧？那么我告诉你，你说的这些个法从无明中升起。
    你想接着问无明从哪里升起吗？

    疑问：
    是的，我是想继续这么问，估计您老会说无明是我们的妄心所生吧，那妄心从何而来，您会说妄本无因吧。那么，虚空会生妄心吗，会生无明、受、想、行、识吗？如果说是，那它是如何生起的？为什么会生起？我现在糊涂的是为什么说无性性（真如）不具足万法，如果如此，那一法如何具足万法，为什么具足万法，请您慈悲开示。

    二麻子：
    没全猜对……
    麻子绝对不会去解释无明从哪里来的。
    麻子建议你去读圆觉经。
    问无明是从哪里来，是凡夫最典型的妄想，是个没有答案的问题。这个圆觉经讲得非常清楚。大意是，这个问题就像一个在梦里的人问自己的梦是从哪里开始的。嘿嘿，这能找到吗？

    疑问：
    关于不同体系之间的差异问题，我觉得只是对同一事物所用的名词不一样而已，实际上他们的观点应当是相同的吧，那么像六祖的这句话我们绝不能视其为错，但他所说到底是何意思，不知谁能解释一下。您说一法具足万法我相信，但您说无性性（真如）不具足万法，我就糊涂了，您能详细解释一下吗。如果说一法具足万法，能生万法，那么虚空如何生起受、想、行、识？

    二麻子：
    嘻嘻，世界哪里会这样简单？比如，一个圆你分三份，我也分三份。你这份拼起来是一个圆，我这三份拼起来也是这个圆。尽管如此，我们的两个分法里，一份跟另一人分的一份，一定能相同吗？两种分法的各份间能一一对应吗？所以，绝对不仅仅是名词不同。但最后的圆一样。


关于破四相

    QZ：
    请问破四相──我相，人相，众生相，寿者相的必要，破的方法。这两个问题可以么？

    zf：
    “一、破四相──我相，人相，众生相，寿者相的必要？”
    若急欲破除无明，解脱轮回，破此四相便为必须；若以往生净土为此生首要追求，破四相便并非为必须。

    “二、破的方法。”
    思维修习缘起正见。正见立，邪见自破。
    某兄曾提到瞎子摸象的故事。的确，瞎子在别人的指导下可以了解大象的形状。但瞎子在正常人指导下能否对大象的颜色也有一定的了解？我看很难。与其在没有视力的情况下思维分辨各种颜色的差异和特点，不如集中精力先治好自己的眼病。若能获得视力，分辨颜色岂非易事？

提点建议：
    一、集中精力修学缘起正见。如来说，见缘起即见法，见法即见佛。
    二、在正见的修习有一定基础后，开始观心修行。仔细观察起心动念，此属于正念的修习。
    三、将心态与正见对比：去除与正见相违者，强化与正见一致者。这就是正思维。
    这种修行是个慢功夫，但效果稳定、有效。心中凡与正见相违者（无论其名字如何），由粗到细会逐渐被发现、去除。
    这种修法常称为观察修，有相当基础后自然转为安住修。其宗旨与原始佛法中的八正道一致。
    对于我们这些菩提路上的初行者来说，所谓“正见”、“正思维”中的“正”字恐怕只能是相对意义上的正确，不大可能是如同佛一样真正的正确。但这种相对意义上的正确也是十分有意义的。比如数学上的迭代法，如果是收敛的，每一步的解虽然都不正确，但毕竟逐渐逼近精确解。
    在我们修行这一迭代过程中，愿心决定了收敛的目标和收敛的速度。如果愿心为出离心，迭代过程将向解脱轮回这一目标收敛；如果愿心为菩提心，迭代将收敛于无上佛果。
    愿心越强，收敛的速度越快。
    如同有些方程可以直接求得精确解一样，某些特殊根性的人可以顿悟成佛，但估计你我均不是这样的根性，让我们耐心迭代吧，只要目标正确。

    二麻子：
    实在是不想答……
    破这四相的必要性与方法ZF兄答的很明白了。
    麻子不想答的真正原因是，其实问的人未必真知道自己问的是什么。比如，现在要您先说说如何是这四相，特别什么是众生相，寿命相，您能说出来吗？假如说不出来，那你问的是什么呢？所以问问题时，藏着未知问下一步会很麻烦的。
    简单说，四相通称我相，或我执，或执着。当分成四处说时，“我相”一词着重表达此执偏重于“能”，“人相”表达执着偏重于“所”。“众生相”表偏重于细微极细微“所”，“寿者相”表执偏于极细微“能”。而经中如此的顺序正是学人依佛法修学时，破执逐步深入的次序。也可说，这是种次第。
    佛法里面有些东西有偶然性。比如不吃蒜类，如果当时没有特别的因缘发生，也许佛就不设这个戒了。所谓不犯不制。还有些东西是必然性的。比如，无论如何，佛不会把无明说成有明确来源的。
    这个无明不说来源，有其内在的必然。
    回到这个帖子谈的众生相与寿者相，这两相一定是模糊的，不能是我们希望的那种清晰。您不妨翻遍佛经，看看哪里把这两相说到你希望的清晰上了。您还没体会到为什么不能清晰，就在说麻子圆滑，这也让麻子不甘呀。嘻嘻。
    建议，您若有兴趣，不妨找找为什么。为什么这两相不能清晰？
    “大象，可以描述他的体态长相，”
    ──这可用来描述我相人相，没法用来描述众生相寿者相。
    名相这东西，是跟人的心念认识紧密相关的。对大家都观察过的东西，一般都会有个大家都知道的名词。对只有相对少数人观察过的，虽然可以有名词，但对多数人这名字并不能给出意思。
    比如医学，核物理等专用名词，非这圈子的人不懂。对只有极少或个别人观察过的，那就几乎一定没有名词对应了。就是有名词，别人读到也很难知道说什么。众生寿命两相，虽然众生时刻没离开，但因其细微，很少人真能体会到。这就很难描述清楚了。大名在这里并不能解决问题。
    另一个重要方面是，我们习惯的所谓“清晰”描述，是建立在强烈的能所对立上的。清晰本身就暗示着“明显的不同，差别”。
    这只能是我人相范围里的事。对众生寿命两相，将他们清晰地表述出来的努力，只是将他们换成了对应的粗分相，就人我相了。所以，这里的不清晰，模糊是有其内在原因的。嘻嘻。若清晰了，就不是了。对细微心行的了解各人方法可能有所不同……这些东西真想知道，多数人要借禅定。在禅定下观察体会，有可能体会到。靠说希望不大。

    常如：
    请问，四相就是见我为常，见人，众生，寿者为常。破四相，即为破此四常见。这样理解行不行，还需要注意什么？

    zf：
    仔细体会四相，即有常也有断。以我见为例，对于此期生命，生时为常，死时为断。常断二见实际总是成对出现的。其实，四相中包含生灭、常断、一异、来出等诸种边见。


苦受不等于烦恼

    苦受不等于烦恼

    二麻子

    本来就不是立言只是对当时人的回答。原贴原问问题的意思是明本心后还受不受苦了。而且对苦受与烦恼也不加区别。所以麻子也没加简别。没差别明显在说苦受没差别。后面的意思，与您在这里的意思一样，只是没用非理作意这个比较专业的词，麻子只说续生的妄想烦恼。这段地方的差别实际只是个专业化程度的差别。严格地说，你说的对，苦受不等于烦恼。说真话，嘻嘻，当年上这帖子的时候，也没想到今天网上的佛法讨论能到现在这个深度。（编按：系关于《越尘集》中“已明自性与未明自性，烦恼有何不同”一文中“疼就是疼，不能说佛身上的疼不是疼吧。依佛法，受就是苦，就是烦恼，疼痛当然是。所以就烦恼说烦恼，就连佛陀他老人家示现在世，也不能不沾点边。”的讨论。）
    佛性与空性这个问题，麻子看见过你讨论这问题的帖子。这里麻子的看法与你稍稍有点不一致。但这地方很细微了，讨论起来也不是很有意思／意义／利益。各自保留吧。
    对还不能真了解意金刚密意的佛友，讲同体异名副作用最小。讲照见空，恐怕兄不大会接受。意金刚又不合适公开讲。


我执──执无量因缘法里少分相续为我

    我执──执无量因缘法里少分相续为我

    二麻子

    “人命终时往生净土，是什么在往生？”
    ──兄一句话，麻子挑两处毛病。
    一、除了证圣位的，往生净土的与无量劫轮回的，没有什么特别不同。尽管这可以说是轮回头出头没的最后一次，等下次再来就是乘愿了。所以专问往生净土，似乎问得太偏特殊了点。
    二、更要紧的，这问把“有什么东西”往生当了先决条件，问的只是“那是什么”。这个隐含先决条件是不符合佛法的。没什么东西，只是我执，执无量因缘法里少分相续为我。不过这次，相续续到净土去了。恭喜恭喜。

    “超度到底有多大的力量？”
    你到底要问的问题是什么？麻子陪你聊两句……
    佛法的基本见是，一切法依因缘而显现。因缘不同，显现就不会一样，所以无常。什么是无常？任何事物没有常一不变的格式。一个人能不能被超度到净土，依赖非常广泛的因缘，上师的超度可以是其中最宝贵的。但是，无论多么宝贵，单一或少数因缘是无法绝对保证结果的。上师不可能把所有的人都超度到净土，就像佛不能一下子把所有众生都引向解脱一样。
    所以，你的问题就很不清楚……若问有人被上师超度到净土过吗，回答肯定是有。若问每人都被超度到净土了吗，回答肯定是没有。具体某个人被超度到了没有的问题，则不是我们能泛泛回答的。虽然如此，这里面原则上也没什么不清楚的地方了。


无我的一个重大意义就是说无主宰

    维京传说：
    我想你会这么认为：佛教讲能、所，能所双亡。而别的宗教、哲学不讲这个，只知能或所，不讲能所的问题，所以佛教高明。我的评论是：绝对没这么简单的事情，别的宗教、哲学也讲能所，也明确提出了能所这个问题，只是用词不一样，解决方案不一样。

    二麻子：
    确实没那么简单的事……
    别的宗教哲学等，确实也有往这个方向思考，甚至趋近的。
    问题是没彻底。
    哲学不用说了，思考本身是能所对立的，所以光思考本身不足以超越这个能所对立。只能思维模拟，而这个模拟与实行间的差别之大，远超过宗下与教下。
    其他宗教也有走向能所合一的。比如印度教婆罗门。但这后面还是有细微差别。这东西真辨起来也十分复杂。要点是，婆罗门教终究没清理掉隐含的“主宰者”。而佛教说的是五蕴无我，这个无我的一个重大意义就是说无主宰。
    再聊了……


“封闭”的“自性有”能找着吗？

    nkdj：
    不变量是真不变，不是还有不确定因素的。比如欧氏空间的转动保持距离不变。或者物理理论里的能量、动量、角动量守恒定律等等。
    世间法里所说的不变量就是离开观察的自性有。所以那个【规律】也是自性有的了。所以和佛法矛盾了。其实那些【公理】就是自性有的东东，然后靠逻辑就结果了。量子力学是承认那些守恒定律的理论，甭管其概率的诠释，它要承认电荷守恒、重子数守恒、能量守恒等等，这些就是不变量。既然有不变量，就有自性。
    按照世俗的【规律】去认识时，就必然会导致不变量，因此有自性。这个有一半我是猜的，没完全捋顺，诸位肯破一破吗？

    二麻子：
    哈哈，先歪回一句，只有无条件的不变量才是自性有，有条件的就需要考察，看条件的条件的条件……等能不能找到在一个范围里封闭。能封闭的，这个范围作为整体是自性有，不能封闭的不是自性有。

    nkdj：
    嘻嘻，谢谢麻叔。小子有够呆，没明白什么是不封闭。您能大致举个例子来说明一下那个【条件不封闭的不变量】么？
    小子粗粗想来，佛法说的因缘法都是有条件的，可是小子没想出什么【不变量】来。好比【缘起性空】，【常乐我净】，小子觉得这是圣者对凡夫开示的对离戏境界的描述，是超越思维的，不是世法里名言逻辑上的【规律】。小子也没想出有关条件的事。
    在世法里，条件不能封闭的，有一种情况就是逻辑出了问题，于是自己把自己绊倒了。比如亚里士多德说重物比轻物落的快，逻辑上就死机了。
    那些试图把范围推广到一切的逻辑体系是否就必然蕴涵着不变量自性有？
    哥德尔好像是说公理逻辑体系不完备，是否又是给不变量的条件不封闭提供了出口？
    不封闭就不是自性有的意思是否就是逻辑上没法说它已经自性有了，因为不封闭，所以就说不着？
    嘻嘻，没法子，智商不够，只好有累高明了……

    Eagle:

    怎么觉得麻叔讲的简单明了，到你这里就变复杂了？麻叔没有说有一个“封闭”的“不变量”啊！相反，麻叔是在给出一个推导的方法：要想找出一个“自性有”的东西，可以去试，就是去找有没有“封闭”的东西。如果有“封闭”的东西，哪怕这里是个群体，是个组合体，也可以算这个整体是“自性有”……但是，能找着吗？


自性是根本没有的东西

    bffl：
    椅子明明在那儿你能说它没自性吗？
    一切都不要执着也就罢了，哪有什么空性可证。

    二麻子：
    嘻嘻，兄弟有些话先别说得太横，特别是不熟悉的地方……
    看了您的帖子俺知道你还不了解佛法里讲的“自性”是指什么。自性一词，除了辞典里，佛经里正式给定义的地方不多，那不是当年佛讲经的惯用形式。但格鲁表述应成见时，对这个词解释得比较仔细。大略说，自性就是“能不依赖一切其他因缘而独立显现的”。
    能这样显现才可以说是“自”性。否则就是依他起了。

    椅子能吗？明显不能。常用的一个破除性分析方法是说，椅子要由腿，面等合成……椅子要依赖这些。其实这个方法不是绝对必须的。还有更深刻细微的方法。
    比如，假设我们有个金刚石球，而且假设这个球是不可分裂的完全刚体。这个球有自性了吗？还是没有！
    因为，如果没有光线你就看不见它，放的远点你就摸不到它，没个桌子放它它就得掉地上，没大地它就得飞到宇宙里去远到没人能看见……等等。所以，就是这样一个完全假设的理想不可分割球，也非要依靠其他因缘来和合才能显现！这叫无自性。
    按照中观见，自性是根本没有的东西。根本没有的东西怎么定义？所以，也不过就是按名言共许先说着罢了。定义也不出名言共许。凡夫却有执自性实有的邪见，这个定义，也无非是对妄执里的自以为的定义吧。
    老兄肯思考，不大肯读书。嘻嘻，有长有短了。


无住与烦恼不生

    yang：
    问题,“万法俱生，就在当下，万法俱生而无住，无住而无我，无我而法空，也在当下。”
    ──好，那你为什么要吃饭？能不能“无住”一下，十天不吃。注意哦，不许说我吃也无住，那是骗鬼的。

    二麻子：
    嘿嘿，你是说当年佛陀吃饭的时候就是有住？别把话说极端了。

    yang：
    当然有住，有身体，饿了要吃，这是苦，身苦灭度了以后，才真的“无住”。

    二麻子：
    住改成苦了？住＝苦，苦＝住？怪事。

    yang：
    要是住不是苦，那你要无住作什么？

    二麻子：
    昏话。无住是能要的吗？你想住在无住上吗？嘿嘿。头脑清醒点。

    rj：
    看杨兄的意思好像是：由住而生苦。住是苦的必要条件，但未必是充分条件。当然这是我感觉他想这么说。

    二麻子：
    嘿嘿，你看，弄反了吧……
    “由住而生苦。住是苦的必要条件，但未必是充分条件。”
    ──苦受是住的必要条件。
    有苦受未必有住。

    逻辑上苦受甚至跟住没有绝对的关系。

    rj：
    啊
    住（感觉）　＝＝＝》苦（感觉）
    （可能衍生）
    您老说这样对吗？

    二麻子：
    嘻嘻……
    看佛经知道，佛陀当年有苦受，比如头痛三天，佛陀当年也肯定有感觉，否则没法回答弟子。
    但佛陀当然无住。
    在麻子个人看来，无住就是无执的意思。住是指某些比较精细不大容易断除的执着。

    rj：
    是吗？什么是“苦”呢。后学知道无常是苦，然而佛陀是离开了苦的，也就是离开了常的，同时也离开了无常的，自然苦灭。
    既然苦灭，如何能说佛陀有苦受呢？乐受和苦受应该是没有区别的，对于佛陀来说。何以故，无执无住达实相故。即使有微细的我执，必然感无常之“苦”。所以后学认为“执”是“苦”受的必要条件。

    二麻子：
    嘿嘿，你翻翻书吧，看看苦受与苦是不是等价的。

    rj：
    你老看，书上说“无常是苦”，佛菩萨观无常如幻，是故离苦，名为得乐。既然无苦受，当不名为苦。
    苦和苦受好像是分不开的。

    二麻子：
    是吗？
    “书上说‘无常是苦’。佛菩萨观无常如幻，是故离苦，名为得乐。”
    ──无常不仅仅是苦。

    “既然无苦受，当不名为苦。”
    ──这是哪里来的话？

    “苦和苦受好像是分不开的”。
    ──不是……很多我们不作为苦受的，也是苦。比如乐受，但无常，仍然是苦，却不是直接的苦受。苦受要窄得多。而且，苦受本身不一定就能造成烦恼。对圣人来说，苦受可以继续显现，烦恼却不生。

    yang：
    苦受可以继续显现，“显现”到什么时候呢？

    二麻子：
    对凡夫，苦受无穷，对圣人……对圣人，你用时间去测度纯系栽赃呢。

    二麻子：
    yang，你的很多看法对现在很多佛友的认识其实是有帮助的……
    问题是，你表述出来的看法本身也相当地倾向一边，或者说，有些片面。
    在某种程度上，麻子支持你对许多人隐含常见而不自知的状态进行的针砭。但麻子绝对不支持，而且提醒你注意，如果对广大无量慈悲心菩提心教法进行攻击，业果将是不好的。
    南传是佛说，大乘也是佛说，何必吵架？特别是，南传里面确实具备大乘的基础，可以说，只要有南传教法存在，大乘出现就是必然呢。你注意到过这点吗？麻子只是提醒一下，仔细考究一下就会发现这个道理。干嘛不先自己想想看？


内外不可得

    zf：
    “在我看来，我们恭敬佛像主要是见贤思齐，是为了让我们精进修行，向佛陀学习。我们恭敬佛像是因为我们对佛陀的景仰。”
    ──通过恭敬佛像来表达我们对佛陀的敬仰，这无疑是很好的心态。

    “但若说圣像有什么灵异，我看这好像不对。”
    ──仁兄对佛像的灵异有看法，那么请问，您对佛号的灵异有疑问吗？您对真言的灵异也有怀疑吗？若因为佛像是色相，因此怀疑，那么佛号和真言是声相，同样可以怀疑。

    “《金刚经》早说过‘若以色见我，以音声求我，是人行邪道，不能见如来。’”
    ──这里的“如来”是指法身呢，还是指报、化二身？

    “且此等事情，皆如传说故事，也没有人去调查过，依我看来，宣扬此等事情，乃是心外求法，……”
    ──请仁兄再仔细分析一下这些圣像的灵异故事，灵异的发生是否曾离开过“心”而单独发生？上述金刚经四句颂中之“如来”向心外求不可得，向心内就能求得吗？


无穷大与有限大

    凡夫:

    无穷大的子集仍然是无穷大.

    zf:

    无穷大的子集也可能是有限大。

    二麻子：
    推论过分造成的困扰……如，当你生病的时候，医生让你吃某种药，然后你病就好了。那么，是不是有种“抗病力”藏在药片里？嘿嘿，这东西是没有的。不过，药还是有效治病的。


大同与小异

    大同与小异

    二麻子

    “自性那个，主要是说，我们凡夫总是觉得诸法不待安立从他那一边自能成立过来的，这是一种错觉，需要破除，格鲁传统的说法好像就是这样的，这地方我理解的也不透，详细的用佛教名词专门地说还说不清楚，我回家查查书，看看能不能再说一遍。”
    ──嘿嘿，从认识兄以来看见兄用自己语言说的话里，说得最准确的也就是这段了。不容易，好呀。凡什么事一定要完全套到自己学的那个体系里去看，这对自己没什么，要求别人就过分了点。有很多情况，不同体系的东西在大处虽然一致，小处却套不起来。记得当年刚看到“乐明无念”三分与“明空觉”三分的时候，这两个三分说得是同一件事。于是，就想看明白这两个三分之间每分相互怎么对应的。结果看了很久也没法对应起来。嘻嘻。根本就不能这样对应嘛。


关于整体之类的概念

    不动：
    实际以前想过，对应与局部缘起法的困局，对应的一定是整体吗，用整体之类的概念合适吗？后来想了想，还是不大合适，针对与局部的缘起法而立起来的“整体”，往往在潜意识里是个“含糊而稍大的局部”，行者在这里往往难以发现其中的弊端，容易走向梵见。在这里，不异、不可得，在表述上往往更为有利于用心上清晰明确的走向。

    二麻子：
    严重同意。8-)。
    用超越局部，非局部等，不要用整体。法尔无体。


分心外心内是凡夫二乘的错觉

    净藏：
“自心求者是正道。心外求者即外道。”请发表看法，多谢！

    智行：
先分心外心内，这是凡夫二乘的错觉，以为心有内外。所以将第六识误以为是“心”，有外境与心相对，此已经是错见。第六识是心的一种用，以第八识为体。真心大而无外，小而无内，涵裹一切。是故一切佛，不论自佛他佛，都不在心外，凡以为有佛在心外，有法在心外，就是心外见法，即名外道。偏执自心者堕此错见者甚多，往往可能还会因此批判净土宗密宗等等，不知自己造谤法业矣！

    zf：
“自心求者是正道。心外求者即外道。”
    般若正见是五蕴皆空，心内心外诸法皆缘起无自性。于自心求法者，当清楚其心为何物。


谈谈对“般若波罗蜜多”的理解

    zf：
    某兄所提的多个问题（编按：当时问题是提议讨论心经），每一个都不是几句话可以说清楚的。《般若心经》乃《大般若经》的心髓，整部《大般若经》都可以说是对《心经》的注释和展开。
    在下抛砖引玉，先谈谈对“般若波罗蜜多”的理解。
    众所周知，般若波罗蜜多意译作慧到彼岸，即彻见诸法实相，度生死此岸至涅槃彼岸之菩萨妙慧。对于我等学人来说，“般若”妙慧，常常成为大家关注的焦点，对“波罗蜜多”即到彼岸，却没能充分重视。
    如来在《佛说佛母出生三法藏般若波罗蜜多经》中指出：
“佛告阿难言。如是如是。我于诸波罗蜜多中。唯说般若波罗蜜多最上称赞。何以故。阿难。汝今当知此般若波罗蜜多与五波罗蜜多为导首故。阿难。于汝意云何。若布施不回向一切智。得成波罗蜜多不。阿难白佛言。不也世尊。佛言阿难。若持戒忍辱精进禅定不回向一切智。得成波罗蜜多不。即此般若不回向一切智得成波罗蜜多不。阿难白佛言。不也世尊。佛言阿难。于汝意云何。所有不思议智慧善根。回向一切智不。阿难白佛言。世尊。如是如是。所有最上不思议智慧善根。而悉回向一切智。佛告阿难。是故当知。以诸善根回向一切智故。得诸波罗蜜多名。以第一义法回向一切智故。得般若波罗蜜多名。是故阿难。彼诸善根回向一切智故。般若波罗蜜多。与五波罗蜜多而为导首。彼五波罗蜜多。住般若波罗蜜多相应法中。由是般若波罗蜜多故。诸波罗蜜多皆悉圆满。阿难。是故我于般若波罗蜜多而最称赞。譬如大地散诸种子。如其时处随所和合各得生长。彼诸种子依地而住。若不依地不能生长。般若波罗蜜多亦复如是。而能摄彼五波罗蜜多。如是五法皆依般若波罗蜜多而住。由般若波罗蜜多而得增长。是故五法皆得名为波罗蜜多。阿难。是故当知般若波罗蜜多。与彼五法而为导首。”
    如来在上述开示中应特别引起我们重视的是：若布施、持戒、忍辱、精进、禅定和般若不回向一切智，便不能成为波罗蜜多。
    大家知道，许多外道亦修持布施、持戒、忍辱、精进和禅定，但因为他们未将修持的功德回向无上菩提，因此他们修持的布施等不是波罗蜜多，不能将其从生死的此岸带到一切智的彼岸；某些研究佛学的学者，他们可能非常准确地把握般若的含义（最起码是文字般若的含义），但因为他们未将般若作为解脱生死、利益众生的手段，般若对这些人来说与世间的学问没有什么差别，因此般若对他们来说也不是波罗蜜多。只有将修持般若的功德完全回向无上菩提，即将修持般若视为成佛的方便时，般若才能发挥其波罗蜜多的作用。
    仔细考察一下，若行者能与般若波罗蜜多真实相应，其前提条件一定是该人已经真实生起了无伪的无上菩提心。如来开示“彼一切种智，从大悲之根本生，从菩提心之因生，以方便而达究竟”。对于已经种下成佛种子——即菩提心的人来说，接下来应全力从事的工作——即方便，就是为种子施肥、浇水、除草等——即修行六波罗蜜多。若行者不是在无上菩提心的摄持下修行般若空性正见，便不能保证将修持般若正见的功德回向一切智。因此，若没有无上菩提心，般若便不是波罗蜜多，如理修持般若波罗蜜多就等于无上菩提心与空性正见的圆满双运。
    佛说般若波罗蜜多与五波罗蜜多为导首者，正是开示，只有在无上菩提心和空性正见的摄持下修持布施等五度，才能积集成佛的福智资粮，圆成佛道。
    如来的恩德大矣。

    智行：
    鸠摩罗什三藏所译《摩诃般若波罗蜜经》佐助品云：“偏在无常一边，故说相似，非真实。”
    般若离二边分别，不作“常”见，不作“无常”见。离一切见而用一切于众生有益之见。众生执常，故说“无常”以破执常之“执”，不破五蕴。即是，不坏五蕴说无常是也。

    zf：
    经中说：“不坏色故观色无常。不坏受想行识故观识无常。不作如是观者。是名行相似般若波罗蜜。”其含义是，如果因色、受、想、行、识会坏，才观其为无常，如是观者，是名行相似般若波罗蜜。所谓不坏色受想行识而观其无常者，据本人的理解，是指观五蕴之缘起性。缘起之法，其不待坏，自性亦空，即是无常，如是方名真实般若波罗密多。

    yang：
    您说“缘起之法，其不待坏，自性亦空，即是无常”，您能告诉我“不待坏”的“缘起之法”是什么吗？
    缘起之法，瞬息生灭，不住，不定，不独立存在，您的“不待坏”已落常见，又反过来说您认为“不待坏”的“法”“自性亦空”，不是戏论是什么？

    zf：
    您现在正在使用的电脑就是本人所指的“缘起之法”。此法依诸缘而起，具有上网等功能，假名电脑。不待丧失其功能，此法之自性亦了不可得。缘起之假名，远离生灭、常断等戏论。在下见地有何不妥，敬请指正。
    “缘起之法，瞬息生灭”与缘起之法，不生不灭，其义同否？异否？请兄三思。

    yang：
    1，假名之“法”，有什么坏不坏？
    2，“瞬息生灭”是实相，“不生不灭”是想像。

    zf：
    “假名之‘法’，有什么坏不坏？”
    ──他日yang兄的电脑出故障不能上网时，兄就知道什么叫“坏”。莫忘，如来开示之胜义谛与世俗谛毫不相违。
    “‘瞬息生灭’是实相，‘不生不灭’是想像。”
    ──般若心经中观世音菩萨金口宣说“是诸法空相，不生不灭”，释迦赞叹，一切如来亦如是说。yang兄如何断言“不生不灭”是想像？？？
    yang兄建议梵兄精读《定解宝灯论》，想必您本人亦曾精读此殊胜之大论。请问yang兄：《定解宝灯论》中可有“‘瞬息生灭’是实相，‘不生不灭’是想像”之类开示吗？？？在下亦曾拜读过此论，可能因为心粗，未发现其中有yang兄所说的意思，请yang兄指教。


努力寻求般若波罗蜜多之真义

    大道行者：
    若求佛法无上妙髓，当知佛法之超绝于世者，唯以“般若实相”也，此即圣谛第一义也，此即此世人所梦寐以求之真理者，此即法性实义也，此即真如也，此即涅槃也，此即菩提也，此即圆觉也，此即一真法界，此即妙明真心，此即不二法门，此即佛性觉海，无尽法义，重重无极，皆在此一真义之证悟也。

    zf：
    常啼菩萨摩诃萨为供养法上菩萨以求般若波罗蜜多之真义，不惜刺臂出血、破骨出髓。
    法上菩萨摩诃萨对常啼菩萨摩诃萨开示言：“善男子。如来者。无所从来亦无所去。何以故。真如无动。真如即是如来。不生法无来无去。不生法即是如来。实际无来无去。实际即是如来。空性无来无去。空性即是如来。无染法无来无去。无染法即是如来。寂灭无来无去。寂灭即是如来。虚空无来无去。虚空即是如来。善男子。离如是等法无别有法可名如来。此复云何。所谓如来真如。一切法真如。同是一真如。是如无分别无二亦无三。善男子。譬如春末夏初。于日中分阳焰动发。若时有人于中求水于汝意云何。彼水从何所来。为从东海来耶。南西北海来耶。其去亦然。常啼菩萨言。彼阳焰中无水可得。况复有来及有去耶。但是愚痴无智虚妄所见。法上菩萨言。善男子。一切如来亦复如是。若人着于色相及以音声。观诸如来若来若去起分别者。当知是人愚痴无智虚妄所见。何以故。如来者是即法身。非色身可见。善男子。法性无来无去。一切如来亦复如是无来无去。又如幻师幻化所作象兵马兵车兵步兵。如是四兵幻所作故无来无去。一切如来亦复如是无来无去。又如有人于其梦中。或见一佛二佛三四五佛乃至百千诸佛。善男子。而彼诸佛从何所来去至何所。常啼菩萨言。大士。梦所不实无决定法。于是法中何有去来。法上菩萨言。一切如来亦复如是。如佛所说。一切法如梦。有人不能如实了知一切法如梦故。即以色相音声语言名字。执着分别诸佛如来若来若去。善男子。若于是法中不如实知虚妄分别者。当知是等名愚异生。受生死身轮转诸趣。远离般若波罗蜜多。远离一切佛法。善男子。若人如实了知。如佛所说一切法如梦。于是法中即无有法若来若去。是故无所分别。如实了知一切如来无来无去不生不灭。如是知者。是为见法。是为知法。是人即近阿耨多罗三藐菩提。是行般若波罗蜜多。不虚受其国中信施。能与世间作大福田。”
    望我等今借行者兄法布施之因缘，均早证实相。


自心是每个学佛人唯一真正能下手处，不是证处！

    学功夫：
    “有很长时间，人们不能接受电磁波不需介质，在真空里就能传播。但事实上，电磁波就是能在真空里传！觉得业要有载体的本质，其实就是常见。中论当然破这个。”
    ──麻兄一文太精彩了，借用开题，万勿介意！
    如果业不须载体论成立的话，引伸到人们追寻开悟而‘反观自性’，是否也在找一个自性载体的第一因？
    小疑，请问有没有灵魂？

    二麻子：
    功夫兄，“反观自性”何为哉，希求找到自性乎？若而，其谬也大。
    实证者为真实体会“自性空”，非为自性有！性空即万法如是现。若真以为万法由自性生，自性为万法本，合该遭锦书，摩诃男等责。
    “相由心生”乎？未必，心亦由相生。麻子找篇老贴子附上您看（编按：其后的引文见《越尘集》“相由心生”一文，从略）。可能有点离题，包涵则个。

    学功夫：
    如来禅“反观自性”其一开始就找寻唯心的第一因，意下如何？

    二麻子：
    功夫兄，自心是每个学佛人唯一真正能下手处，不是证处！吾兄所引诸语录中，凡“自性”二字都不妨在其后添一“空”字，而与原语义无违。
    “所以，如来禅‘反观自性’其一开始就找寻唯心的第一因，意下如何？”一语，不佳。实际上，“反观自性”是要学人于“无有第一因”，“自心如幻不实”，“轮回无根”有个切身真实体会。千万别搞反了。

    学功夫：
    麻兄，您一直用“空宗思想”破“禅宗的自性有”思想而不自知？很多人也以为禅宗是说空的，但其反观自性实实在在是在说自性有、如来藏有、佛性有、一真法界有、返本还原有的！
    麻兄，自印度空有之争以还，今夕何夕，此时此刻，您得到了甚么？您掉弃了甚么？有幸与您交流！如有说错，见谅！

    二麻子：
    功夫兄，不是二麻子空宗有宗。是您有常见不净。
    功夫兄，请勿将名相硬套在禅宗头上，以凡夫心说禅空也罢有也罢，都不是。例：“大千坏时那个坏不坏？”答曰“坏”！而被尊为古佛出世。是空是有？
    兄弟，套名相而不自知，则还不能论空有。还望您真的反观自心妄相流转，勿为其惑。
    再比如修禅定。对半青不黄的人是要学会“如何用心”，对将入门径的人是要学会“如何不用心”。是空是有？
    真如不可得亦不能离，却无碍显现，是空是有？
    超越对立能所，方有契入之机。否则，终不得要领。

    学功夫：
    麻兄，是弘忍及慧能将名相套在禅宗上，不是我呀？又您说我常见，我也不是呀？常见的有名经论如下──
    楞严经：“本如来藏，常住妙明，不动周圆，妙真如性，性真常中”。大乘起信论：“自性清净心义故，常乐我净义故”。
    禅宗经常是借空反有，奈何！！！

    二麻子：
    功夫兄，要给古人栽赃呀。凡借语言说就不得不用名相。不用怎么说？佛陀再三说“我法如标月指”，就是要学人别执在名相上。
    您能引几句古人的话证明禅宗是有，二麻子就可引同样多的话来破有！如来藏同一合相，不能讲“有”的！
    “禅宗经常是借空反有，奈何！！！”，无可奈何。大祖师也奈何不得您。只是您没法解决您的根本问题：第一因在哪里。
    要找第一因，请读圆觉经金刚藏菩萨所问品。

    学功夫：
    麻兄，我习惯了看指就看指，看月就是看月，没有你指标月高明咧？
    《涅槃经》“我者，即是如来藏义。一切众生悉有佛性，即是我义”。这说明有常乐我净的如来藏我，不是第一因，是甚么？
    《坛经》“万法在自性”，“一切法尽在自性”。自性不是有第一因，怎说呢？如要怪栽赃，找这些经论算算吧！

    sam：
    两位大德，让我来评一评吧！你们所说的都错，各打三十板，满意了吧！其实禅宗与佛所说是完全不同的，禅是说“常有”，佛是说“断空”，两大阵形，各有所好。可是现在禅不认有常，佛不认空断。现在有一块透明的玻璃，在两位面前，一位用眼观，见是无碍，一位用手触，却生障碍，如你们争论玻璃的有碍，无碍，但玻璃自身是怎样的，它无碍就是无玻璃吗？有碍就有玻璃吗？如我说这碗饭没有人吃，于是有一人说：这个“没有人”不吃饭会饿死吗？另一人说：这个“没有人”当然是饱啦，不然怎会不吃饭。你们说“没有人”究竟是饱是饥呢？

    林安和：
    看了三位大德的教示，末学忽然想到了一个疑问：涅槃真心，法身真如，与“梵”的差异何在呢？末学在五十奥义书中曾看到“梵，无始之生，而生世界，无始之有，而有万物。不净不染，不生不灭，远离相对，绝诸语文，非修可修，非证可证……”末学所知障重，总觉得“我们佛教的”应该会和“别人的”有点不一样，故于此向二菩萨请益。

    二麻子：
    噢，SAM兄说的是“没有人”。嘻嘻。
    禅非常有佛非断空，与“没有人吃饭”还真有点像。第一因是个DEAD LOOP。如A为第一因，则必有人问“A由何起？”若答“由B起”，则又问B……无穷无尽。出此死循环有两路。一路道：“定义A为一切之始，接受，不可问！”如耶教等，用此法。另一路道：“无始，无有第一因”佛法如此说。
    然而，如“业不需载体”之说一样，无始之说，人在直觉上不易接受，总是放心不下。其实，“无始”也是种说法。如人做梦未醒时，要在梦中找出此梦之始，不可得也！故对梦中人，梦也是一种无始。而于对醒了的人（的座标系）梦是否有始，梦中人其实无法讨论。所以，梦中人欲询梦源，可以是一种搞醒自己（修行）的方法，但切勿以为真有个梦之始可寻。
    功夫兄若要继续讨论见宗，二麻子很高兴参与，但若判高判低，引入个人情绪，恕二麻子不陪。
    林安和本家提出的问题，深值深思！

    学功夫：
    麻兄，感觉您总答非所问，尽说甚么栽赃呀，个人情绪呀，梦中人其实无法讨论呀等等！我表明，一直尊重我们的讨论！
    请教禅宗说返本还原，到底“本”、“原”算不算有，如不算有，何用“返”？
    引一节“性在作用”语录大家参考参考──
    达摩的弟子波罗提为王说法，《传灯录》卷三：
    “问曰：何者是佛？答曰：见性是佛。……王曰：性在何处？答曰：性在作用。王曰：是何作用？……波罗提即说偈曰：在胎为身，处世为人，在眼曰见，在耳曰闻，在鼻辨香，在口谈论，在手执捉，在足运奔。遍现俱该沙界，收摄在一微尘，识者知是佛性，不识唤作精魂。”
    只再问麻兄，自性有或无？这次，请不要以修行方法来解说，谢谢！

    二麻子：
    真是没完没了……
    功夫兄，对于这事，您叫真如，自性，空性都无所谓，说有，说没有都不成。佛门老话，叫“离四句绝百非”。您那最后一问，正是四句中的前两句。只要您不能离开“是”“不是”之类的对立思维，无论如何谈都不得要领。如能离开，就如SAM大佬所言，变成傻佬。
    仿您最后一问，二麻子也出一问，功夫兄试答如何？有言在前，二麻子无有恶意，只望功夫兄看看，这问的毛病出在哪里。其问如下：
“你承不承认偷了别人东西，是承认还是不承认？”
    答呀！

    sam：
    任何人的东西也是从别人处取回来的。身心也是呀！一切与我无关呀！连我亦是呀。

    二麻子：
    这贼汉！

    sam：
    当你知道禅，你就会不负责任，胡说八道，无赖，懒到极，不愿思想，不会修行，成不成佛亦无关，生死亦懒理。有与无关我鬼事！

    二麻子：
    倒不见得。也许明天又变得勇担慧命，言不离法，勤行不懈，思想敏锐，不断修行，见性成佛，生死无畏，大悲普及。只是不知后天大后天又会如何……

    台湾佛教网路论坛


二乘与大乘教法的区别，不在教法本身，而在于所利益的对象

    zf：
    yang兄，别来无恙？蒙您推荐，在下学习了上文。文中对涅槃等的阐述透露着作者的真知灼见，令人钦佩。
    但文中对大乘的评说却多有误解之处。抛开原始佛教和大乘在修学目的上的差异不说，在对般若经和大乘空义的评论中便有可商榷之处。
    文中对《般若经》有如下评论：
“《般若经》是直接将色与空划上等号的，它的经文说‘色不异空、空不异色；色即是空、空即是色。受、想、行、识亦复如是。’换言之，般若经认为空和现象没有差异，五受阴的现象中不仅没有本体，甚至五受阴的现象压根儿就被般若空观给空掉了。现象中找不到本质并不代表现象本身也被空掉、不存在了。总不能仗着‘生病’只是一种生理现象而不是一种永恒的实在，所以光荣地向全世界的卫生医疗机构摇旗呐喊：‘病是不存在的，我们佛教徒已经彻底解决医疗问题了！’”
    我相信，许多大乘行人见到这一评价一定大喊冤枉！正如龙树菩萨所指出的那样：“因缘所生法，我说即是空。”因此，“空”不是“不存在”，法空也不是说法压根儿就没有了。藏地宗喀巴大师便大声疾呼：“性空之空义是缘起义，非作用空无事之义”。汉地古德杜顺大师亦曾开示：“法无自性。相由故生。生非实有。是则为空。空无毫末。故曰无生。经云。因缘故有。无性故空。解云。无性即因缘。因缘即无性。又中论云。以有空义故。一切法得成。”这些大乘行人的教法无一不是在宣说缘起与性空的无碍本质。
    关于心经的古今种种解说，无一不是直指缘起性空的法义。在下将当代济群法师对心经的开示附录于后，仁兄可以比较一下，上文中对般若经的评说与大乘行人的解说是否一致。
    至于上文中对大乘的其他误解，在下就不一一指出了。

    yang:
多谢厘清般若空观法义，您指出的方面确实是作者的明显错误，大家都是承认缘起有的。但在此前提下，似乎取向大不相同：杂含直指缘起有的无余灭尽，所谓此无故彼无，要由无明渴爱的灭而导致“有”的灭，而此“有”的灭即是涅槃，即是佛教修行的终极目标；而大乘则要在此缘起有上转染成净，开显如来功德至圆满以成佛，以觉行圆满的“缘起有”为终极目标，涅槃亦成自性清净的代名词。这样两种截然不同的取向恐怕是两种教法的根本分别。
    如果抛弃既往大小乘争执的不良说辞，就此根本的分别请赵叔不吝赐教，不仅可以解除我等疑惑，而且可以就此熄灭对佛教危害极大的所谓大小乘之争。

    若有比丘于老病死，生厌、离欲、灭尽、不起诸漏、心善解脱，是名比丘得见法般涅槃。【契经　杂因诵】”
    根据这段经文，“凡是亲证真理、涅槃的人，就是世间最快乐的人。”等，应该指的是“见法涅槃”，“见法涅槃”并不等同于涅槃，只是对涅槃的一种明确的预期，而涅槃则另有所指：
“彼色（受、想、行、识）是无常、苦、变易之法。若彼色受阴永断无余，究竟舍离、灭尽、离欲、寂没；余色受阴更不相续、不起、不出，是名为妙、是名寂静、是名舍离。一切有余爱尽、无欲、灭尽、涅槃。【契经　五阴诵】”
    ──文义明确，直截了当。

    二麻子：
    佛陀的这个教法当然是正确无误的。但请仔细想想，这个教法是从什么角度说的。
    说白了，这个教法是对尚未破除我执的学人，从随顺“有我”“有个体”的角度说起的。显然，当破除我执实证无我并顺断了过去“有我”妄执所积累的相续后，证得涅槃，即不再有什么过去妄执的“我”继续存在，自然对这个自我而言，五阴等自此都谈不到了，称为“离”“断”等等。
    但是，如果大乘菩萨已经破除我见我执，根本不被“（有）自我”的角度自限，则无我也不碍众生显现。佛陀已证涅槃，众生不还在这里活跃吗？既然不受此“个体”自限，则对五阴之类也谈不到什么离不离灭不灭，而是直接了当的“当体无生”。
    “自性本清净”也罢，“本来无一物”也罢，从祖师禅看都偏向点静态，“一昧”是没问题的。却有点不“知有”的味道。所以说这个偏点“无”也是有道理的。当然，这些说法都是现在我们在看。六祖当年真实情况不是我们现在能考证的。后来在五祖处袈裟围住说法后，明显有改变。这里说的无呀有呀的，不是很粗的常断见。
    所以，其实都对，并不需要矛盾。只是有时候要仔细考究一下佛说法面对的具体情况。嘻嘻，哈哈，一管之见，仅供参考。

    yang：
    谢谢麻叔，麻叔说的在理，不失为一种合乎逻辑的解释，但是否符合佛陀本意，还难以遽下定论。因此同样请麻叔拨冗通读一下《灭苦之道》，在下尚有问题请教。

    二麻子：
    客气客气……不过麻子有点不理解的地方。
    yong兄注意过没有，对那些特别喜欢用类似考证的方法表白自己是，而别人不是“佛陀本怀”的人，他们能考证出他们自己的看法就是“佛陀本怀”吗？
    嘻嘻。说真话，我不相信他们能也没看到他们能。却看到制造了佛门内斗。

    zf:
非常高兴与兄交流心得！

    四圣谛中“灭”谛所揭示的灭的“有”究竟是什么，这的确是值得大家思考的问题。
    南传圣僧罗侯罗.化普乐在其《佛陀的启示》一书中给出了如下非常具有启发意义的开示：
 “我们再看看巴利文原典里若干涅槃的定义及说明： 　　‘涅槃是彻底断绝贪爱：放弃它、摒斥它、远离它、从它得解脱。’
    ‘一切有为法的止息，放弃一切污染，断绝贪爱，离欲，寂灭，涅槃。’
    ‘比丘们啊！什么是绝对（无为）？它就是贪的熄灭、嗔的熄灭、痴的熄灭。这个，比丘们啊！就叫做绝对。’
    ‘罗陀啊！熄灭贪爱，就是涅槃。’
    ‘比丘们啊！一切有为无为法中，无贪最上。就是说：远离憍慢，断绝渴想，根除执著，续者令断，熄灭贪爱，离欲，寂灭，涅槃。’
    佛的大弟子舍利弗回答一个游行者‘什么是涅槃’的问题时，他的答覆与佛所作无为法的界说（见上）一般无二：‘贪的熄灭、嗔的熄灭、痴的熄灭。’
    ‘放弃、消灭爱欲与对此五蕴之身的贪求，就是苦的止息。’
    ‘生死相续的止息，就是涅槃。’
    因为涅槃是用反面文词所表达的，因此有许多人得到一种错误观念，以为它是消极的、表现自我毁灭的。但涅槃绝不是自我的销毁，因为根本无‘我’可毁。只能说它（涅槃）所销毁的是‘我’的幻觉、‘我’的错误意念。

    佛在经历一种愉快、不愉快，或既非愉快亦非不愉快的感觉的时候，他知道这种感觉是不久长的。它即没有缠缚他的力量。经历这些感觉，不能使他情感激动。不论是什么样的感受，他都能经历而不受它的拘缚。他知道一旦躯壳朽败，这些感觉终将归于平静，就像油尽灯枯一样。
    ‘因此，比丘们啊！有这样赋禀的人，才是赋有绝对的智慧。因为具有灭一切苦的智识，才是绝对的圣智。
    ‘他这筑在真理上的解脱，是不可动摇的。比丘啊！凡是虚妄不实的，都是假法。凡是真实的、涅槃的，才是真理。因此，比丘啊！有这种赋禀的人，才是赋有绝对的真理。因为绝对的圣谛就是涅槃，也是实相。’
    在另一部经里，佛毫不含糊地用真理一词代替涅槃：‘我将教你们真理，以及走向真理的道路。’在这里，真理的意义，很明确的就是代表涅槃。

    什么是绝对的真理？依佛教说，绝对的真理就是：世间没有绝对的事物。凡所有法都是相对的、缘起的、无常不永恒的；而没有恒常不变、亘古永存的绝对的实体，诸如‘自我’、‘灵魂’或‘神我’等，无论在身内或身外。这就是绝对的真理。虽然，在通俗言词里，也有‘反面的真理’一词，真理却决不是反面的。体证这真理，就是对事物的如实知见，无有无明妄想；也就是断绝贪爱、灭苦、涅槃。在此值得记住的，就是大乘佛教‘生死即涅槃’的见解。同一事物可以是生死，也可以是涅槃，全在你的看法如何──主观或客观。这种大乘观点，大抵是从上座部巴利文原典中的观念演变而来。这些观念在我们方才短短的讨论中已经提到过。”

    ──尊者在上面的开示中，有以下两点应特别注意：
一、涅槃是贪的熄灭、嗔的熄灭、痴的熄灭。
    二、体证真理，就是对事物的如实知见，无有无明妄想，这就是涅槃。
    由此可见，涅槃不是“生命”的结束，而是“错误生命”的结束。错误生命的结束，就是新生命的开始──对真理、对诸法实相的体证。
    那么这个新生命具有什么特征呢？尊者开示：
    “凡是亲证真理、涅槃的人，就是世间最快乐的人。他不受任何‘错综 （complex）’、迷执、忧、悲、苦恼等苛虐他人的心理状态所拘缚。他的心理健康是完美的。他不追悔过去，不冥索未来，只是扎扎实实地生活在现在里。因此，他能以最纯净的心情欣赏与享受一切，而不掺杂丝毫自我的成分在内。（译者按：即陶然与万物合一，浑然忘我之意。）他是喜悦的、雀跃的、享受着纯净的生活。他的感官愉悦，无所忧烦，心灵宁静而安详。他既无自私之欲求、憎恚、愚痴、憍慢、狂傲以及一切染著，就只有清净、温柔，充满了博爱、慈悲、和善、同情、了解与宽容。他的服务精神是最纯正的，因为他不为自己设想。他不求得、不积储、甚至不积贮精神的资粮；因为他没有‘我’的错觉，而不渴求重生。”

    概括地说，在尊者看来，亲证涅槃的人具有两个最重要的特征：1、智慧──对真理、实相的体证；2、慈悲──最纯正的服务精神。而智悲双运不正是大乘行人所追求的根本目标吗？！
    由此可见，贪嗔痴等缘起有的无余灭尽与智慧慈悲等功德的开显完全没有矛盾。
    二乘与大乘教法的区别，不在教法本身，而在于所利益的对象。对那些发心从轮回中解脱的学人，佛为其宣说二乘教法；对不满足于自我的解脱，而欲利益众生者，佛为其传授大乘教法。
    如同病人为治疗己病去看医生，医生自然悉心为其治疗；如果病人治好病后，或当初看病时，发愿要成为医生为别人治病，医生便会为其传授医疗理论和经验。

    yang:
站在《灭苦之道》的立场，与赵叔商榷

    【四圣谛中“灭”谛所揭示的灭的“有”究竟是什么，这的确是值得大家思考的问题。】
    ──同意，对于这个“有”的解释歧异很多，大体来说，好象“有即五蕴”与“有即我执”两种看法是比较关键的。

    【南传圣僧罗侯罗.化普乐在其《佛陀的启示》一书中给出了如下非常具有启发意义的开示：
“我们再看看巴利文原典里若干涅槃的定义及说明： 　　‘涅槃是彻底断绝贪爱：放弃它、摒斥它、远离它、从它得解脱。’
    ‘一切有为法的止息，放弃一切污染，断绝贪爱，离欲，寂灭，涅槃。’】
    ──这里明确提出“一切有为法的止息”，并未说“杂染的”有为法的止息。

    【‘比丘们啊！什么是绝对（无为）？它就是贪的熄灭、嗔的熄灭、痴的熄灭。这个，比丘们啊！就叫做绝对。’
    ‘罗陀啊！熄灭贪爱，就是涅槃。’
    ‘比丘们啊！一切有为无为法中，无贪最上。就是说：远离憍慢，断绝渴想，根除执著，续者令断，熄灭贪爱，离欲，寂灭，涅槃。’
    佛的大弟子舍利弗回答一个游行者‘什么是涅槃’的问题时，他的答覆与佛所作无为法的界说（见上）一般无二：‘贪的熄灭、嗔的熄灭、痴的熄灭。’
    ‘放弃、消灭爱欲与对此五蕴之身的贪求，就是苦的止息。’
    ‘生死相续的止息，就是涅槃。’】
    ──这段文字，似乎是将“见法涅槃”和涅槃统一来说了，但也有单纯描述涅槃的文字：‘生死相续的止息，就是涅槃。’

    【因为涅槃是用反面文词所表达的，因此有许多人得到一种错误观念，以为它是消极的、表现自我毁灭的。但涅槃绝不是自我的销毁，因为根本无‘我’可毁。只能说它（涅槃）所销毁的是‘我’的幻觉、‘我’的错误意念。】
    ──这段文字是针对认为涅槃是自我的毁灭的错见的，因为无我，所以没有一个自我被消灭，但这并没有妨碍涅槃是五蕴的灭尽这样一个命题。况且这个问题，早在佛世就有了：
尊者舍利弗就座，洗足已，语焰摩迦比丘：“汝实作是语：‘我解知佛所说法，漏尽阿罗汉身坏命终无所有。’耶？”
    焰摩迦比丘白舍利弗言：“实尔，尊者舍利弗！”
    舍利弗言：“我今问汝，随意答我。云何，焰摩迦！色为常耶？为非常耶？”
    答言：“尊者舍利弗！无常。”
    复问：“若无常者是苦不？”
    答言：“是苦。”
    复问：“若无常、苦，是变易法，多闻圣弟子宁于中见我、异我相在不？”
    答言：“不也，尊者舍利弗！”
    “受、想、行、识亦复如是。”复问：“云何，焰摩迦！色是如来耶？”
    答言：“不也，尊者舍利弗！”
    复问：“受、想、行、识是如来耶？”
    答言：“不也，尊者舍利弗！”
    复问：“云何，焰摩迦！异色有如来耶？异受、想、行、识有如来耶？”
    答言：“不也，尊者舍利弗！”
    复问：“色中有如来耶？受、想、行、识中有如来耶？”
    答言：“不也，尊者舍利弗！”
    复问：“如来中有色耶？如来中有受、想、行、识耶？”
    答言：“不也，尊者舍利弗！”
    复问：“非色、受、想、行、识有如来耶？”
    答言：“不也，尊者舍利弗！”
    “如是焰摩迦！如来见法真实，住无所得，无所施设，汝云何言：‘我解知佛所说法，漏尽阿罗汉身坏命终无所有。’为时说耶？”
    答言：“不也，尊者舍利弗！”
    复问焰摩迦：“先言：‘我解知佛所说法，漏尽阿罗汉身坏命终无所有。’云何今复言非耶？”
    焰摩迦比丘言：“尊者舍利弗！我先不解、无明故，作如是恶邪见说。闻尊者舍利弗说已，不解、无明一切悉断。”
    复问焰摩迦：“若（有人）复问：‘比丘！如先恶邪见所说，今何所知见，一切悉得远离？’汝当云何答？”
    焰摩迦答言：“尊者舍利弗！若有来问者，我当如是答：‘漏尽阿罗汉色无常，无常者则是苦，苦者寂静、清凉、永没。受、想、行、识亦复如是。’有来问者，作如是答。”
    舍利弗言：“善哉！善哉！焰摩迦比丘！汝应如是答，所以者何？漏尽阿罗汉色无常，无常者是苦，若无常、苦者是生灭法。受、想、行、识亦复如是。”
    尊者舍利弗说是法时，焰摩迦比丘远尘离垢，得法眼净。【契经　五阴诵】

    【佛在经历一种愉快、不愉快、或既非愉快亦非不愉快的感觉的时候，他知道这种感觉是不久长的。它即没有缠缚他的力量。经历这些感觉，不能使他情感激动。不论是什么样的感受，他都能经历而不受它的拘缚。他知道一旦躯壳朽败，这些感觉终将归于平静，就像油尽灯枯一样。】
    ──“他知道一旦躯壳朽败，这些感觉终将归于平静，就像油尽灯枯一样。”“他知道”，是见法涅槃；“油尽灯枯”是涅槃。

    【‘因此，比丘们啊！有这样赋禀的人，才是赋有绝对的智慧。因为具有灭一切苦的智识，才是绝对的圣智。
    ‘他这筑在真理上的解脱，是不可动摇的。比丘啊！凡是虚妄不实的，都是假法。凡是真实的、涅槃的，才是真理。因此，比丘啊！有这种赋禀的人，才是赋有绝对的真理。因为绝对的圣谛就是涅槃，也是实相。’
    在另一部经里，佛毫不含糊地用真理一词代替涅槃：‘我将教你们真理，以及走向真理的道路。’在这里，真理的意义，很明确的就是代表涅槃。】
    ──佛陀的四条神圣的真理，最终的绝对的就是灭的真理，即涅槃。

    【什么是绝对的真理？依佛教说，绝对的真理就是：世间没有绝对的事物。凡所有法都是相对的、缘起的、无常不永恒的；而没有恒常不变、亘古永存的绝对的实体，诸如‘自我’、‘灵魂’或‘神我’等，无论在身内或身外。这就是绝对的真理。虽然，在通俗言词里，也有‘反面的真理’一词，真理却决不是反面的。体证这真理，就是对事物的如实知见，无有无明妄想；也就是断绝贪爱、灭苦、涅槃。在此值得记住的，就是大乘佛教‘生死即涅槃’的见解。同一事物可以是生死，也可以是涅槃，全在你的看法如何──主观或客观。这种大乘观点，大抵是从上座部巴利文原典中的观念演变而来。这些观念在我们方才短短的讨论中已经提到过。”】
    ──这里涉及涅槃的转义问题，涅槃即是空性，还是空性所显，如果是空性所显，那么空性所显的又是什么？依大乘，空性所显乃诸佛无量功德，那是要先承认在十二缘起之外另有一套诸佛功德的缘起系统，以菩提心为因，成佛为极果。但在阿含系统中只有一个缘起系统，就是十二缘起，这个系统以无明起，以纯大苦聚集终，空性所显即为十二缘起的终止，再无其它。故此在十二缘起系统下说绝对的真理，说空性，都直接指向灭尽、涅槃。
    见此经：“此无故彼无，此灭故彼灭。谓无明无故行无，无明灭故行灭，行灭故识灭，识灭故名色灭，名色灭故六入处灭，六入处灭故触灭，触灭故受灭，受灭故爱灭，爱灭故取灭，取灭故有灭，有灭故生灭，生灭故老病死忧悲恼苦灭，如是如是纯大苦聚灭。【契经 杂因诵】”

    【尊者在上面的开示中，有以下两点应特别注意：
一、涅槃是贪的熄灭、嗔的熄灭、痴的熄灭。】
    ──上面已经说过，在十二缘起系统中，贪嗔痴（亦即无明）的熄灭即是灭尽、涅槃，并未指向任何一种哪怕是功德无量的缘起状态。

    【二、体证真理，就是对事物的如实知见，无有无明妄想，这就是涅槃。】
    ──还是请注意“见法涅槃”与“涅槃”的区别。

    【由此可见，涅槃不是“生命”的结束，而是“错误生命”的结束。错误生命的结束，就是新生命的开始──对真理、对诸法实相的体证。】
    ──我们现在谈到的“生命”，就是“错误生命”，这个错误的生命的结束，就是灭尽、涅槃。“错误生命的结束，就是新生命的开始──对真理、对诸法实相的体证。”这个说法阿含中是没有的。另外，这个“新生命”必定需要依托一个缘起系统，而且决定不是十二缘起，这就引出了大乘的菩提心为因的缘起系统，到了“唯信能入”了。

    【那么这个新生命具有什么特征呢？尊者开示：
“凡是亲证真理、涅槃的人，就是世间最快乐的人。他不受任何‘错综 （complex）’、迷执、忧、悲、苦恼等苛虐他人的心理状态所拘缚。他的心理健康是完美的。他不追悔过去，不冥索未来，只是扎扎实实地生活在现在里。因此，他能以最纯净的心情欣赏与享受一切，而不掺杂丝毫自我的成分在内。（译者按：即陶然与万物合一，浑然忘我之意。）他是喜悦的、雀跃的、享受着纯净的生活。他的感官愉悦，无所忧烦，心灵宁静而安详。他既无自私之欲求、憎恚、愚痴、憍慢、狂傲以及一切染著，就只有清净、温柔，充满了博爱、慈悲、和善、同情、了解与宽容。他的服务精神是最纯正的，因为他不为自己设想。他不求得、不积储、甚至不积贮精神的资粮；因为他没有‘我’的错觉，而不渴求重生。”】
    ──很对的，每一个见法涅槃的人都是这样，他在坚定地趣向涅槃。

    【概括地说，在尊者看来，亲证涅槃的人具有两个最重要的特征：1、智慧──对真理、实相的体证；2、慈悲──最纯正的服务精神。而智悲双运不正是大乘行人所追求的根本目标吗？！
    由此可见，贪嗔痴等缘起有的无余灭尽与智慧慈悲等功德的开显完全没有矛盾。】
    ──这是见法涅槃的人在趣向涅槃的过程中自然开显的特质，阿含中未有把这种状态定义为佛陀教法的根本目标。

    【二乘与大乘教法的区别，不在教法本身，而在于所利益的对象。对那些发心从轮回中解脱的学人，佛为其宣说二乘教法；对不满足于自我的解脱，而欲利益众生者，佛为其传授大乘教法。
    如同病人为治疗己病去看医生，医生自然悉心为其治疗；如果病人治好病后，或当初看病时，发愿要成为医生为别人治病，医生便会为其传授医疗理论和经验。】
    ──区别就在教法本身，包括对生命缘起系统以及涅槃的不同看法。反而在利益的对象方面，两种教法好象区别不大，阿含教法关注个人解脱，同时也鼓励有能力的人尽量帮助别人获得解脱知见，间接的帮助别人解脱；大乘教法的“为度众生愿成佛”更是包含了自他两方面的解脱。

    zf:
 心平气和的交流，多么令人愉快！

    “这里涉及涅槃的转义问题，涅槃即是空性，还是空性所显，如果是空性所显，那么空性所显的又是什么？依大乘，空性所显乃诸佛无量功德，那是要先承认在十二缘起之外另有一套诸佛功德的缘起系统，以菩提心为因，成佛为极果。但在阿含系统中只有一个缘起系统，就是十二缘起，这个系统以无明起，以纯大苦聚集终，空性所显即为十二缘起的终止，再无其它。故此在十二缘起系统下说绝对的真理，说空性，都直接指向灭尽、涅槃。”
    ──仁兄这里提及的两套缘起系统的问题，的确是大小乘的重要差别，是无法回避的。
    《阿含经》中涅槃的定义是：“涅槃者，贪欲永尽，瞋恚永尽，愚痴永尽，一切诸烦恼永尽，是名涅槃。” 因阿罗汉已经断尽一切烦恼，没有于三界中受生的因缘，所以不再三界受生，故说“不受后有”，这在原始佛教的系统中是自然的结果。原始佛法虽讲缘起，但讲“缘起”的目的是为了“缘灭”。
    而菩萨因大悲心切，不证二乘极果，以菩提心为因，遍法界利益众生。大乘缘起说，在缘灭（烦恼的灭）的同时，如来功德得以开显（缘起）。同原始佛法相比，大乘的确是另外一个缘起系统。

    “我们现在谈到的“生命”，就是“错误生命”，这个错误的生命的结束，就是灭尽、涅槃。“错误生命的结束，就是新生命的开始──对真理、对诸法实相的体证。”这个说法阿含中是没有的。”
    ──是的，这是站在大乘的立场上的说法。

    “另外，这个“新生命”必定需要依托一个缘起系统，而且决定不是十二缘起，这就引出了大乘的菩提心为因的缘起系统，到了“唯信能入”了。”
    ──说到“唯信能入”，在下认为，不但大乘的菩提心缘起系统要靠信入，四圣谛和十二缘起的入手处也是个信字。二乘行人在修行开始时如何能实证四圣谛和十二缘起？自己未实证十二缘起，而在佛陀的指导下修习八正道去“缘灭”烦恼，不正是靠“信入”吗！

文摘：

心经开示 （节录）

济群法师

    【有空不二──舍利子！色不异空，空不异色；

    色即是空，空即是色。受想行识，亦复如是。】

    有与空是哲学中的一对重要范畴，也是佛法中重点讨论的内容之一。《心经》中色受想行识的五蕴法门，是代表着有的存在。与有相对的是空，在一般人经验中，总以为有与空是对立的，他们认为有不是空，有在空外。本经阐述了有与空的关系，说明有空不二的道理。

    要认识有与空的不二，先得说明有。有，在我们常人观念中，它与“实在性”往往联系在一起，当我们说到有时，便会觉得自体有，实在有，人类对事物的实在感是根深蒂固的，它具有普遍和相通性。如原始野蛮人不知梦境是不实的，一旦做了一个恶梦就惊恐万状，以为灾难就要降临了，于是要祈祷三天。婴孩不知道镜里的影像是虚假的，他们见到镜里影像，就会乱抓乱笑。

    至于文明人虽然知道梦境的不实，但却以为认识的一切物件都是实在的；科学家虽然摆脱了常人的错觉，但他们在分析物质现象时，由于智慧不够，往往就会认为构成物质的元素是实在的，如原子说，极微说；哲学家的智慧，似乎又高一畴，他们已能透视到现象的虚假性，但他们却又执著隐藏在现象的背后，有个永恒不变的本体，如泰勒士的“水”，巴门尼德的“存在”，柏拉图的“理念”。从原始幼稚人到现代文明人，乃至科学、哲学家，他们对存在的认识虽有程度上的不同，但所产生的实在执却是一样的。

    人类的对“有”所产生的实在感，是“自性见”的表现。须知“自性”一词，或译自体，含有自己有，自己成，自己规定自己，本来如此，实在，恒常的意义。从自性见出发。我们对“有”的一切，必然会有实在感。然而，以般若中观的智慧来看。“有”是缘起有，世间一切有的现象，莫不是众缘所生。也就是说：任何一种有为现象的存在，都是由众多条件和合，由条件决定它的存在性。

    缘起与自性是势不两立的。世人无知，不了解“有”的缘起性，才会出现自性见，实在感，假如认识到“有”的缘起性，必然知道无自性。因为自性：是以“有”的一切现象，为自己有，自己成，自己规定自己；而缘起：是以“有”的一切，为条件有，条件成，条件规定。因此，缘起的“有”不是本来如此，更非恒常的，实在的。由此可知，对“有”的实在感，是错误的。

    《大智度论》卷十二说到有，从程度上分三种不同：一曰相待有，二曰假名有，三曰法有。

    相待有：是相待而有，离开相待的物件就无法说明。比如说我们认为这个花瓶很大，那是相对小的花瓶说的；说这个人胖，那是相对瘦人。高是相对低说的，长是相对短说的，美是相对丑说的，善是相对恶说的，离开大，小是什么？离开胖，瘦是什么？离开高，低是什么？因为大小、胖瘦、高低、长短、美丑、善恶都相待假立，是为相待有。

    假名有：事物的存在不过是一种假名安立，随着不同的因缘安立不同的名称。正如我们眼前的台子，人们称它曰桌子。桌子只不过是一大堆木料的组合，离开木料，请问桌子是什么？这一大堆木料古人将它叫桌子，它便是桌子；古人将它叫椅子，它便是椅子了。可见桌子或椅子不过是一个假名。同样的我们说人，也是一个假名。如果古人把我们这个有情生命叫做猪，把猪叫做人，那么现在要是不称你为猪，阁下听了，恐怕会生气，你竟然瞧不起我，不把我当猪看待，真是岂有此理。可见人、猪乃至世间一切都是假名安立，假名而有。

    法有：是指世间万物万事名称虽然假立，但也不是什么都没有，因为事物除了名称之外，尚有形成现象的种种因缘。这些因缘虽无自性，但假相宛然，这因缘法的有，便是法有。

    《金刚经》对有的实质也作了深刻的说明，认为有，只不过是假有。经中说：“一切有为法，如梦幻泡影，如露亦如电，应作如是观”。有为是具有生灭、造作的一切现象。如梦：梦境虚假，这是众所周知的，可是梦中人却执以为实，觉醒了才觉得可笑。诸法如梦，虚妄不实，但世间有情无明妄想故，执以为实，智者从无明梦中觉醒，乃知诸法无实。如幻：幻，是由幻师用幻术，幻现种种事物，如马、车、房舍、人物等，客观上虽然没有实物，但却宛然存在我们眼前，有色可见，有声可闻，“有”的存在也是这样，虽空无自性，而假相宛然。如泡：泡是水因气体出现了，华而不实，瞬间即逝，诸法如泡，刹那生灭。如影：影是阳光投射下显现的，太阳落山影也随之消失，诸法如影但随缘现，缘散即无。如露、电：喻诸法存在的短暂性。应作如是观，是要这样的去看待“有”的一切。

    与《金刚经》同一思想体系的《维摩诘经》维摩大士假示疾为大众说无常、空的道理：“是身如聚沫，不可撮摩；是身如泡，不得久立；是身如炎，从渴爱生；是身如芭蕉，中无有坚；是身如幻，从颠倒起；是身如梦，为虚妄见；是身如影，如业缘现；是身如响，属诸因缘；是身如浮云，须臾变灭；是身如电，念念不住”。这是从色身，说明有为法的无常、空，显示存在的虚假性。

    明白了有，再来说明空。通常我们以为：有是存在，有就不是空，空是不存在，空就不是有，因此有在空外，空有对立。可是以般若中观智慧来看，空有不但不对立，而且是一体的。所谓空，不必在有之外，也不必事物毁灭了始谈空；因为有是缘起有，有的当下就是自性空。因此佛法是依有明空，有空一体。

    《大智度论》卷十二提出三种认识空的方法：一曰分破空，二曰观空，三曰自性空。

    分破空：又称析空观，是通过对有的分析，由粗而细，由细而微。佛教中的有部学者，就是采用这种方法对五蕴色身进行分析，发现了五蕴色身中我了不可得，提出我空；但在分析色心现象时，一直分析到物质或精神不能再分析的部分时，便提出了极微说，认为此极微法实有，因而出现了我空法有的思想。其实，分破空的意义是在破除人我执；至于物质现象倘若加以分析，极微也是不能成立的。《唯识二十颂》就曾对极微说进行了破斥，你说有不可分的极微，请问极微有没有体积？假如有体积，就存在东西南北上下的六方，那还是可以分析，可见极微说是不能成立的。

    观空：是从观想的意义上认识空。如那些修瑜伽止观的人进入止观状态时，能随着他的观想显现种种境相。修火观，观想成就，见到处都是火；修水观，观想成就，见到处都是水。在现实生活中有“李广射虎”及“杯弓蛇影”的典故：李广认石头为虎，结果能将箭射入石头中；某先生误认弓为蛇，导致肚皮大痛三天。止观的水火及典故中的虎蛇，事实上都没有，然观想中的人却认为宛然存在。从随人观想而境像显现，唯识者悟到了外境无实，随心所现，因而提出万法唯识。观空者破除了外境实有的执著，却难免落入心有境空。那么，这种空还是不究竟的。

    自性空：自性，是自己有，自己成，本来如此的意思。世间外道不了解诸法的缘起性，他们在接触事物中，难免出现自性见；小乘有部虽然知道缘起，但同时也觉得诸法有自性。然以一般中观学者看，自性与缘起是不能并容的。《中论观有无品》说：“众缘中有法，是事则不然，性从众缘出，即名为作法。性若是作者，云何在此义，性名为无作，不待异法成。”缘起是作法，由众缘所作而成，自性乃无作，自己有，自己成，不待众缘。中观学者以为：缘起必然无自性，这就是自性空。

    《心经》中：“色不异空，空不异色，色即是空，空即是色”。是从自性空的立场来说明的，色，不是世间人所执的自性色，是因缘所生的色；空，也非世人所说一无所有的顽空；或者认为人死如灯灭，一个生命彻底消失了，那是断见。空，乃是自性空。《中论观四谛品》说：“未尝有一法，不从因缘生，是故一切法，无不是空者”《十二门论观因缘门》说：“因缘所生法，是即无自性”。色是缘起的，色必然是无自性、空。因此说：色不异空，色即是空。

    有人说：“色即是空”还好理解，“空即是色”这似乎就说不通了，造成这种看法的原因，还是因为把空理解为顽空，中观说空乃是自性空，自性空并不否定缘起的假相。《中论·观四谛品》说：“因缘所生法，我说即是空，亦说为假名，亦名中道义”。说缘起法是无自性、是空，并不坏缘起的假相，所谓缘起有而自性空，自性空而宛然有。因此，色不异空，自然空也不异色；色即是空，空自然即是色。原本在世人心目中一向对立的有空二法，在般若中观智慧的观照下，得到了统一。

    空有不二的思想，是为遣除世间的有见、空见，世人因为不了解有，对“有”的一切生起错误的认识和执著，导致了人生种种烦恼、痛苦。《经》曰：“色即是空”是要我们看破“有”的实质，是虚幻、是无常、是无自性、是空。一个人倘若真正的认识到“有”的实质，他还会因为有的问题而生烦恼吗？还会为物所累吗？世间还有一部分人，他们的智力更高一些，已能看破有的虚幻实质，但因为不了解缘起因果，认为世界一切既然都是虚幻的，人生的事业最终都要归于毁灭，那么生存还有什么价值意义可言呢？于是他们不顾社会道德，放纵自己的身心为所欲为，导致虚无主义。《心经》曰：“空即是色”便是对治这种邪见，说明万物虽空，但缘起因果还在不断延续中，人生的善恶行为都是有果报的。


把握否定的界限

    把握否定的界限

    zf

    般若正见的确立，关键是把握否定的界限，绝对不是否定的越彻底就越正确。过度否定的最大过失就是否定缘起的诸法。若诸法的缘起性被破坏，则因果规律便无从安立，从而佛陀教诲的根本“诸恶莫作，众善奉行”在邪见者心中亦成为一种“执着”的表现。须知，般若正见所破的对象是“法执”，而不是“法”本身。那种认为，必须连“法”本身都要彻底破除的见解是根本错误的。《金刚经》中著名的四句偈是说“一切有为法，如梦幻泡影，如露亦如电，应作如是观”，而不是说一切有为法根本就不存在，其中的奥义我等学人应当深思。
    宗喀巴大师于《菩提道次第广论》中特别明确地指出：“诸具慧者应知，性空之空义，是缘起义，非作用空无事之义”。大师的开示表明： 　　一、性空之空义是诸法之缘起无自性义；
    二、空义并不否定缘起法的作用（非作用空）；
    三、空义并不是说法根本不存在（无事）。大师对空义的开示实乃救治持邪见者的良药，至于病者是否肯服药就看其发心和善根了。
    《心经》中宣说：“色即是空，空即是色”，认为法根本就没有者不要忘记：空就是色，根本就没有可以离开色等五蕴的空！！！


应以般若智慧观照诸法的真实相──无相

    zf：
    何等人能转地狱报现世轻受？大般涅槃经中如来开示： 　　师子吼言。世尊。何等人能转地狱报现世轻受。善男子。若有修习身戒心慧。如先所说。能观诸法同如虚空。不见智慧不见智者。不见愚痴不见愚者。不见修习及修习者。是名智者。如是之人则能修习身戒心慧。是人能令地狱果报现世轻受。是人设作极重恶业。思惟观察能令轻微。作是念言。我业虽重不如善业。譬如叠花虽复百斤终不能敌真金一两。如恒河中投一升盐水无咸味饮者不觉。如巨富者虽多负人千万宝物无能系缚令其受苦。如大香象能坏铁锁自在而去。智慧之人亦复如是。常思惟言。我善力多恶业羸弱。我能发露忏悔除恶能修智慧。智慧力多无明力少。如是念已。亲近善友修习正见。受持读诵书写解说十二部经。见有受持读诵书写解说之者。心生恭敬兼以衣食房舍卧具病药花香。而供养之赞叹尊重。所至到处称说其善不说其短。供养三宝敬信方等大涅槃经如来常恒无有变易一切众生悉有佛性。是人能令地狱重报现世轻受。善男子。以是义故。非一切业悉有定果。亦非一切众生定受。

    小牛：
    请问善知识：如何是──“不见智慧不见智者。不见愚痴不见愚者。不见修习及修习者”？

    zf：
    请进，“不见智慧不见智者。不见愚痴不见愚者。不见修习及修习者”？
    我想如来这里提醒我们的是应以般若智慧观照诸法的真实相──无相，即无论“智慧”、“智者”、“愚痴”、“愚者”、“修习”、“修习者”都是无自性的缘起法。
    这里我们初学者应该注意的是，不见智慧、不见愚痴所否定的是这些法的自性，即这些法不可能脱离一定的条件（即因缘）而独立存在，但并不是说这些在一定条件下存在的法如龟毛兔角一样根本就不存在、没有丝毫作用。

    zs：
    “在圣者位，这个那个作用的主体〔因执少许因缘法而成的我〕不复存在了，所以，谈不上作用……”

    zf：
    我不存在了，就谈不上作用了？三思。
    “诸法从缘起，如来说是因。彼法因缘尽，是大沙门说。”对大沙门来说，自然无我，但缘起的作用却依然现前。见缘起即见法，见法即见佛。可见缘起法这一作用并不会在如来智慧中泯灭。


方便与般若之间的关系

    常如：
    请问关于菩提心与般若智两者的关系，哪本经书说得比较详细，谢谢！

    zf：
    在宗喀巴大师《菩提道次第广论》中，详细论述了方便与般若之间的关系。这里“方便”的含义为由行愿菩提心摄持的布施、忍辱……禅定等菩萨行。大师详尽讨论了欲成就佛果，方便与般若必须双运。正如华严经中弥勒菩萨的开示：方便为佛父、般若为佛母（大意，具体文字记不清）。兄如仔细研读《广论》，一定可以解惑。
    顺便提一句。“方便”一词在经论中含义不一。当“方便”与“般若”成对出现时，方便的含义便为行愿菩提心摄持的布施至禅定等五度；当论及菩提心为成佛种子之时，“方便”常表示除菩提心外由般若摄持之一切菩萨行。


空性是活的

    zf：
    当年在下确有以佛性为空性的误解。虽然佛性本性亦空，但将佛性等同空性却是错误的。多谢提醒。不过，依在下现在的见地，虽然器皿的空性不是佛性，但器皿同样具有佛性。

    二麻子：
    嘻嘻，给某兄回在这里。这个空性两字，某兄用的意思，与宁玛派用的意思不大一样呢。ZF兄也宝贝，他不说出这个不同，却用佛性两字随你推一步，可这一推，嘿嘿，茶杯有佛性呢，你看，又来麻烦了吧？
    嘻嘻。应成的习惯，空性是说自性纤毫无。那么死活的差别是什么？虽然这差别也没自性，但这个只是无违自性空，并不保证自性空就有死活差别。一个老例子是，唱歌无违走路。不过走路不保证有唱歌。
    那么，唱歌哪里来的？宁玛不是这样表达。在宁玛里，空性不是死的。嘻嘻。鸡同鸭讲的事，我们都常做的。


本性的真实

    求真：
    谁能帮忙？我们所知的一切存在皆因我们的思想而有，而我们的思想是虚幻不实的，因而一切皆属虚幻。真实在哪？

    zf：
    我等凡夫的思想皆以无明为根，此无明所缘起之色心诸法皆虚妄不实。但，即此虚妄法之不实之性（即空性）却是“圆满成就的真实性”。这可以称为“本性的真实”。
    又，因“圆满成就的真实性”无为不可分别，故一切法互摄互入，事事无碍，重重无尽，如因陀罗网。此境界为普眼智所缘，可以称为“现象的真实”。

    求真：
    谢谢各位，再问（非常重要）：各位所说，仍然是思维所得吧？若是，则我们的思想是虚幻不实的，因而众位所说皆属虚幻。真实在哪？

    zf：
    关于思维，思维本身并无过失。如来开示的八正道中就有“正思维”，可见依于正见的思维不但不是束缚，反而是解脱之正道。
    我等凡夫思想的虚妄主要因为其基础为无明，而正思维的基础是缘起正见，此正见正是对无明的否定。
    与实相观待而生的智慧，其体性虽同样为空，但其作用与“邪思维”却迥然不同。
    知幻即离，离幻即觉。

    QZ：
    如何将中观的“缘起性空”正见与“本觉智”的体验结合起来修行呢？

    zf：
    若能“体验”本觉智，必知“缘起性空”之正见真实不虚，老兄还要怎么“结合”？？？过关的妙诀：虔发菩提心。菩提心的修持是隆钦心髓前行的重要部分，Q兄辛辛苦苦求来的法！


以缘起所显现的法性为所缘，其能缘之心即是实智

    齐愍：
    近日读到大唐天竺三藏地婆诃罗的两个译本的《大乘离文字普光明藏经》，其经似乎和大圆满祖师的遗教有天生的相应处，请善知识指点。

    zf：
    一点体会，经中如来以“己所不欲勿劝他人”总持菩萨戒律，为后学所未闻。然此一原则为我等观察起心动念之所依，又是何等方便！
    经中之“善男子。如是所觉一切法性。是名遍照光明之藏。善男子。何故法性名之为藏。以诸众生世出世智。皆依此藏而得生故。如以实智观彼法性。智依彼生故名为藏”则实为实际修持的窍诀。以缘起所显现的法性（即空性、真如、无自性性）为所缘，其能缘之心即是实智（“以实智观彼法性。智依彼生故名为藏”）！此实智即名遍照光明！安住此明空双运即是大＊＊、大＊＊、大＊＊之修持。正所谓：唯如如及如如智，其智亦如也！


智慧生佛

    智慧生佛

    大千

    一、凡夫靠什么成佛

    《心经》说：“三世诸佛。依般若波罗蜜多故。得阿耨多罗三藐三菩提。”“般若波罗蜜多”，意译智慧到彼岸。“阿耨多罗三藐三菩提”，意译无上正等正觉。觉者知也，智也，是至高无上的诸佛平等的真正智慧。故成正觉即是成佛。过去、现在以及未来所有的佛，都是靠智慧成的佛。
    众生堕入轮回，皆因无明，也就是没有智慧，由无知故起惑造业，流转生死；智慧明灯能破无明昏暗，能除烦恼、所知二障，成就佛陀一切智智，遍知一切应知境界，觉悟圆满，得大自在。由此般若波罗蜜多能生诸佛，为一切善法之根本，故尊称为“诸佛之母”。

    二、智慧为何能除二障

    二障，由无始以来凡夫有情颠倒执着实有二我而生。凡夫执着实有人我（主观精神世界、能取），为我而生种种烦恼，能障众生不得涅槃解脱，称为烦恼障；凡夫执着实有法我（客观物质世界、所取），对境而生种种分别，能障众生亲证所应知境，称为所知障。
    二障存在何处？凡夫无始以来颠倒妄想执着二我的同时，就有印象习气留在潜意识里，也就是有二障的染污种子熏习在阿赖耶识之中。所以今天我们虽然已知实无二我，但由于颠倒妄想积习深厚，阿赖耶识中仍有以前所积累的执着二我的种子在不断生起执我的现行。因缘成熟生起现行的这部分种子，显现为现行后就不存在了，但我们在面对这些现行的时候，又习惯地带着我执去对待，从而又熏成了新的我执种子，所以我执种子就这样吐故纳新接续不断，我们的二障也就无有尽时。
    如何对治这些执我的染污种子？这就要靠闻思修佛法无我的道理，熏习成随顺佛陀最清净法界等流正法的清净种子。这样可以起到三个作用：一是明白了无我之理，就可以减轻我执的程度，逐渐改变我执的习气，以至于无我之理闻思修纯熟，达到如实知见无我的境界，从而断掉新熏我执种子的来路。二是在闻思修无我之理的时候，时时处处改造我执习气的时候，都同时会有清净种子熏习到阿赖耶识当中，对治我执的清净种子掺和进去，会妨碍我执种子顺利地聚合众缘生起现行。熏到阿赖耶识里的清净种子逐渐增多，所占比例越来越大，就会使一些染污业终于再也不能聚齐生起现行所需要的全部染污种子，众缘中只要差一缘尚未聚合，此项染污业的种子就不能生起现行。这样各种恶业生报因缘的聚合越来越困难，就会使许多恶业之报生起现行的可能性越来越小，以至最终达到完全没有可能聚齐因缘生起现行了。三是闻思修佛法所熏清净种子的势力越来越大，修行清净无漏善业生报的因缘就更容易成熟，由于日日反复精勤听闻、如理思维和依法修行清净法界等流正法，使自己的思想言行越来越接近佛菩萨的境界，就会与佛菩萨更容易相应，更易得到众佛菩萨大慈大悲的护念加持，以至常能见佛，得生净土。
    当清净种子在阿赖耶识中所占的比例越来越大，能够达到一小半时，由其障碍作用使染污种子互相聚齐生起现行已经没有可能，就是转染成净的过程要发生质变的时候到了，这就是见道。此时染污现行因无力生起而中断，凡夫见闻觉知的一切如梦幻象全部消失，这就是由圣者的根本无分别智证得了空性；而后由清净种子生起后得无分别智，世界本来面目自然现前，如实现量亲切证知一切境界，生死长梦中的凡夫终于觉醒，无始以来第一次见到何为真实，何为凡夫不可思议真如境界，如今亲自体证了了分明，心中涌出空前欢喜，这就叫做登极欢喜地，也就是初地菩萨了。此情景就如刚从梦中醒来，正醒之时，梦中幻事全都不见，醒来之后，才见梦幻真实面目，全不过是自己心中一堆妄想，终于明白佛言三界唯心、万法唯识非是虚言，哑然失笑，生大欢喜。如是已生如来家中，成真佛子，可入佛陀报身法会，依佛直指，十地之中，分分对治所余大半染污种子，待到全部转染成净，八识得转佛陀四智，圆满证得无上正觉，就完成了修行成佛的全部过程。
    转识成智的过程若细分起来，见道是转识成智的第一步，这时颠倒妄想的根源——“第六意识”转成妙观察智，我执的根源——“第七末那识”转成平等性智，此时便能降伏染污种子的现行。然后在修道位的菩萨十地中，再接着对治所余染污种子，达到圆满佛地时，就是转染成净修行的完成，也就是转识成智的第二步，阿赖耶识转成大圆镜智，前五识转成成所作智，至此凡夫八识就全部转成佛陀四智了。

    三、怎样才是无分别智

    圣者的智慧叫无分别智。方便说法，可分三种：加行无分别智，根本无分别智，后得无分别智。加行无分别智为地前加行位菩萨所修，根本无分别智和后得无分别智为见道时证得，若以根本无分别智为体，后得无分别智即为其用。无分别智，无的是凡夫的分别，生起来的是圣者的智慧，后得无分别智是有圣者的如实现量分别的，那与我们凡夫意识的分别完全不同，不可以我们凡夫的思维妄测类比，所以无分别智既不是不分别的智，也不是空无一切的智。此二种圣者之智只能证得，凡夫无法思议，所以我们讨论的重点应当是怎样证得二智，那就是要靠地前菩萨所修的加行无分别智，此智是由凡夫智慧到圣者智慧的过渡，是引导凡夫证得空性的智慧。
    为什么叫做加行无分别智？就是要把我们凡夫的分别心识加力修行成无分别的智慧，这是见道前的冲刺阶段，就像赛跑中撞线前的最后几米，前面的一切积累都是为了这最后的成功，也好像养兵千日用兵一时，今天终于上了战场要动真格的，看你平时的训练是否真的能用上一样。首先要明确，这种修行，就是要用我们凡夫的分别来修，就是得用凡夫的意识来修，凡夫除此之外没有其它可以用来修行的工具。因为凡夫的本钱也就只有心意识，离了心意识也就不是凡夫了。什么叫离凡夫的分别？有人提出可以修无想定。但四禅八定只是渐离了寻伺，仍未离微细意识的分别，三界之顶的非想非非想定，就是没有粗想而不是没有细想的意思。无想定其实也只是前六识暂时不起，第七第八识照常活动不停。准确地说，第八识叫心，第七识叫意，前六识叫识，真正离开第七染污意，是在证空性登初地的时候，第七识转为平等性智，才叫做离开了凡夫的第七末那识。与此同时，第六意识转为妙观察智。这叫做“六七因中转，五八果上圆”，第八识和前五识要到成佛的时候才转为大圆镜智和成所作智，所以真正要离了心意识，必须到佛地才行。
    而这暂时停止前六识活动的无想定却是外道的修法，因为他们认为，凡夫生死轮回的原因是意识的分别，有分别就会生烦恼，所以错误地认为断掉分别就可以证入涅槃获得解脱。而佛教认为生死轮回的原因是我执，必须断掉我执才能获得解脱，而断掉我执必须靠反复熏习无我的正见，而正见就是正确的分别，所以错误的分别必须靠正确的分别才能对治除断，而不是靠停止一切分别。如果不起分别，人就如同石头朽木一般，根本没有修行的能力了。
    凡夫转凡成圣而得见道，要靠闻思修佛法所得的智慧，而闻思修慧全都要靠第六意识来修，必须靠第六意识的无我正见才能对治执我的邪见，因为我执的邪见就是由第六意识执着来的，所以解铃还必需系铃人。什么叫智慧？就是能够正确简择诸法。八识中只有第六意识能够完成这个任务。无想定暂停了第六意识的活动，那就不能修慧了，所以就与佛教除遣我执的修行无关了，也就成了外道的修行了。修成无想定可得生无想天五百大劫的果报，五百大劫中前六识不起，由于不能闻思修佛法，佛把它与地狱、饿鬼、旁生、盲聋喑哑、北俱卢洲、世智辩聪、佛前佛后等并列为“八难”之一，也就是所谓长寿天难。这是佛教修行必须避免的陷阱和灾难。
    如果暂时停止意识活动就是修行的话，那我们睡得很死没有梦的时候，就应该是很好的修行了。或者把你一棒子打昏过去也是挺不错的修行。如果怕疼，也可以用适量的安眠药抑制成无梦睡眠来修行。其实这样修得更好的还是冬眠动物，可以几个月意识不起，春暖花开的时候还不都证了空性。还有更厉害的，植物人甚至可以几十年不起意识，应该成佛也没问题了吧。记得有报刊说，有冰冻上百年的人又活过来的，他要还不是佛的话，我看别人就别再指望这种馊主意了。
    所以，要把凡夫的有分别识，训练成圣者的无分别智，不能靠不分别，而是要靠正确的如佛法之理的分别。要通过反复闻思修佛法，把我们因无明所生的我执邪见都舍弃掉，把由凡夫颠倒错误造成的疑惑全解开了，心里没有疑惑和烦恼了，也就用不着再分别了，这才叫做加行无分别智。比如，我们原来都认为有我，现在学习佛法明白了根本无我的道理，把心里的疑惑搞清楚了，不再有丝毫的犹豫和动摇，时时处处在“有我没我”的问题上不用分别就能断定无我，所以根本不必再加分别，这就是达到了加行无分别智的状态。这种无分别，玄奘法师翻译成“喜足”无分别，就是对这个问题你心里明白了，没有疑惑和烦恼了，心里很高兴，很满足，不再受它扰乱了，所以也不用再去分别它了。韩老根据藏文翻译成“持断定”的无分别，就是说这个问题，你得到了一种可以断定的认识，问题解决了，再没有问题了，所以也不用再去分别它了。
    所以真正的修行，就是这样用佛法去解决自己的无明造成的疑惑和烦恼，比如世界究竟是无常、苦、染污的，还是常、乐、洁净的？一个个地搞明白了，没有疑惑了，以至最后能够明明白白地认识到，我们凡夫所有的见闻觉知都只不过是一种能分别，所以佛说万法唯识，而所有的所分别又都只不过是颠倒妄想，佛说全是遍计所执，也就是根本不存在的龟毛兔角。当然这不是说听懂了这个道理就算明白，得是心里真正清楚，彻底明白，明明朗朗，没有疑惑，任何外境不能扰乱，所有诸相不能迷惑，什么议论也不能动摇，这才叫做得了胜解，这才真正是到了不需要再分别的境界，当把这最后的胜解之念也舍弃时，就是根本无分别智现前的时刻了。所以要达到无分别智不能靠不分别，而是要靠正确如理的分别，才能接近和最终证得圣者的无分别智。

    四、怎样修行加行无分别智

    地前菩萨怎样把凡夫有分别的智慧修成圣者无分别的智慧？需要依次以三种方法修成三种智慧。根据修行阶段和方法的不同，地前智慧可分为三种：闻所成慧，思所成慧，修所成慧。
    闻所成慧，即是由听闻佛法所生成的智慧，其思维的对象是语言文字，目的是理解其中的含义，就是文字中所包含的道理，所表示的意义。这叫“缘文解义”。
    修所成慧，是在定中作观所成的智慧，作观的对象是离语言文字的道理意义，目的是将它们以无我空性为中心融会贯通，连成一片，集于一团，终于观到纯熟通达勿须分别的时候，就能以根本无分别智整体亲证空性之理，也就是实证真如的见道位。这叫“缘法义观”。
    思所成慧，是闻所成慧与修所成慧之间的过渡，是由思维正理所成的智慧。思维对象是文字和道理，目的是将闻所成慧所理解的道理，对照联系，相互贯通，再依表达更深道理的文字继续深入，或依原来听闻过的文字体会其中更深的含义，再将领会到的更深的道理相互联系，逐渐与佛理的核心无我空性贯通，如是反复思维，达到可以完全脱离语言文字的观法时，就属于修所成慧纯粹“缘义作观”的范畴了。

    五、怎样证得空性

    闻所成慧是靠听闻佛法所得，所以我们首先需要正确听闻和理解佛法。佛法的核心是“诸法无我”，真正通达了诸法无我的道理，也就是通达了二无我所显的空性的道理。空性就是空无自性，何为自性？就是二我，人我和法我，我就是自性，自性就是我，无我就是一切法皆无自性。什么是我或自性呢？就是我们所执着的一种“独立不变”的东西。世上本来根本不存在这种东西，可是我们凡夫无始以来就颠倒执着必定是有这样的东西。比如认为内有能取的人我，外有所取的法我，由此起惑造业，堕入轮回。如果把这种执着二我的妄想去掉，也就不会再去造业了，无我空性就会自然现前。空性只能证得，不可思议，可思议的就是无我的道理，所以只要空掉可思议的二我，去掉二障，不可思议的空性自然就显露出来了。因为空性法尔如是，从无生灭，亦无增减，只是我们凡夫自障其眼不能观见罢了，因此若尽其障，空性自然就会显现。
    反复闻思佛法可以熏习成清净种子，可以对治我执烦恼，伏断一部分烦恼现行。但是只靠闻所成慧还不能证得空性，为什么呢？因为闻所成慧思维的对象是语言文字，语言文字概括的范围较小，力量就弱，而文字所含之“义”概括的范围较大，你需要说很多句话才能说清楚一个道理，而这个道理在意识中只要一闪念就可以思维得到。比如有人在说笑话，说着说着大家突然都笑起来了，就说明听这个人说话必须要有一定长的时间，而明白这些话里所包含的道理（义）却不过是刹那间的事了。
    这样看来，用“义”思维，比用语言思维包括内容的范围要大得多，这样它的力量也就大得多，它所起的作用也就大得多。所以在懂得了佛法的道理之后，要练习把这些道理融会贯通起来，这就是用语言和“义”交叉思维，也就是修习思所成慧的阶段。把多次闻法所理解的各种道理，联系贯通，融会成一些更深更高层次的概括性更强的道理，这样的“义”概括的范围更大，代表的内容更多，使人的思维越来越精练简略，但是其力量却变得越来越大，这就是由多闻到精华的提炼过程，也仿佛平常所说的由博返约的总结概括性学习阶段。
    思所成慧对治烦恼现行和熏习清净种子的力量更大，作用也更强，但是在思所成慧阶段也还不易证得空性，为什么呢？因为思所成慧靠的是散心思维，散心的力量还比较弱，定心的力量就又强得多了，心力强作用就大，所以如果在定中观察思维佛法的道理，尤其是达到脱离文字概念的纯粹“义”观的时候，逐渐把所有的道理都与无我之义融会贯通起来，形成高度概括的简练的观法，那就可以进入加行位了。在加行位中，由高度概括的观法（唯识中就是由四寻思观证四如实智）把所有分别概括成“能与所”这种最基本的分别，然后把所取空掉，当这只有能取的最后一念也断掉时，就是空性现前的时刻了。
    慈氏菩萨曾在深密法会上请问释迦佛如何作缘总法观，佛回答说：“若诸菩萨即缘一切契经等法。集为一团一积一分一聚作意思惟，此一切法随顺真如。趣向真如临入真如。随顺菩提随顺涅槃。随顺转依及趣向彼。若临入彼此一切法。宣说无量无数善法。如是思惟修奢摩他毗钵舍那。是名缘总法奢摩他毗钵舍那。”这就是在讲临入真如的最后观法。

    六、三慧的修行方法

    我们一起来看弥勒菩萨在《辨中边颂》里是怎么说的，颂下的论是世亲菩萨的解释。
    “论曰。作意正行其相云何。颂曰
    菩萨以三慧　恒思惟大乘
    如所施设法　名作意正行
    论曰。若诸菩萨以闻思修所成妙慧。数数作意思惟大乘。依布施等如所施设契经等法。如是名为作意正行。此诸菩萨以三妙慧思惟大乘有何功德。颂曰
    此增长善界　入义及事成
    论曰。闻所成慧思惟大乘。能令善根界得增长。思所成慧思惟大乘。能正悟入所闻实义。修所成慧思惟大乘。能令所求事业成满。谓能趣入修治地故。作意正行有何助伴。颂曰
    此助伴应知　即十种法行
    论曰。应知如是作意正行。由十法行之所摄受。何等名为十种法行。颂曰
    谓书写供养　施他听披读
    受持正开演　讽诵及思修
    论曰。于此大乘有十法行。一书写。二供养。三施他。四若他诵读专心谛听。五自披读。六受持。七正为他开演文义。八讽诵。九思惟。十修习行。”
    作意正行是以三慧思维大乘法义，即能趣入修治地，也就是见道而悟入修道地。其中“闻所成慧思惟大乘。能令善根界得增长”的“界”是因义，指种子，就是说，多闻佛法能够增长善根种子，也就是前面提到的清净种子。
    修作意正行具体需要做什么呢？就是十法行。释迦佛在《胜天王般若波罗蜜经》中开演十法行时告诉阿难，此十种法能受持此般若波罗蜜修多罗，“阿难。譬如大地。一切树林花药皆依而生。一切善法皆依般若波罗蜜生。阿难。譬如转轮圣王若在世间七宝常现。般若波罗蜜亦复如是。此修多罗若在世间。则三宝种常不断绝”。
    十法行总结起来，一是要闻思佛法，二是要修习止观。闻思修经论是正行，而方法上必须辅以止观，其作用有三。一是在闻所成慧阶段，修定可以使身心顺畅，神志清明，于闻思经论助益广大。二是在思所成慧阶段，静坐思维时心力集中，很多散心时百思不得其解的问题很容易就心开意解了，或是平时想不到的地方，定中也就容易心领神会融会贯通了。三是修所成慧阶段，必须常在定中作法义观，才能最终习熟见道。十法行的第十项修习行，指的就是在定中观修法义。所以罗嗦了半天，修行方法概括起来其实很简单，也就是读经、止观两件事儿。


唯识里借用禅定干什么？

    玄兹：
    嘻嘻，麻兄，若唯识无境，那么水呀，太阳呀，还有它们的运动以及互相关系呀等等，都不存在，甚至网上的诸兄也都只是俺的某种识。这些识构成一个虚拟世界，而这个虚拟世界根本没有。这唯识最后唯到什么都没有了，嘻嘻。麻烦老兄把这串问题回答下来，好让俺目瞪口呆一把。

    二麻子：
    哈哈……老兹，别那么聪明……，那个不是你说的虚拟世界，相反，那个正是你误以为真实的世界。你倒是把它没有了试试。能做到我还真服你。嘻嘻。

    玄兹：
    嘻嘻，俺明明叫它虚拟世界（这是俺的识），麻兄却说俺（把它）误认为真实世界，嘿嘿。麻兄在莲舟说过这串问题回答下来能使俺目瞪口呆。俺这次绝不能放过这个好机会，敬请麻兄回答一下。若今天没空可以明天，明天没空可以后天……

    二麻子：
    哦。你老兄原来一直没有目瞪口呆呀……这个这个，看来麻子对您的勇气估计不准确，麻子很愿意校正自己这个错误，以后加十倍估计你的勇气。如果将来再发现估价过低，麻子可以继续提高对你勇气的估价。嘻嘻。容易改正呀。

    玄兹：
    嘻嘻，希望麻兄这次给个显式回答，看看俺能否目瞪口呆。像您老目前这样隐来隐去对俺不太起作用（实话实说）。

    二麻子：
    嘻嘻。这次确实低估了你的勇气……很多人看到说无境的无就是兔角的无，会相当吃惊。您老完全感觉不到，麻子佩服呀。
    再看看你跟常青常如兄弟的对答，麻子也就有点感觉到是怎么回事了。不好意思，对老兹了解不够呢。嘻嘻。
    嘻嘻，差别那么明显，你自己故意不看。在那个破法里，每一步破掉一种粗细程度的遍计的时候，都没破成对应的“彼彼空”断灭空，都留了点什么非断的。你不过是不看这个非断的，要让这个过程趋于断灭。
    一个递减数列，不一定趋于零的。
    借用禅定看什么……？如果只是看禅定境，照样是遍计执，不过外道而已。这就是大千兄所批评的。
    但禅定提供了一个比平时外境能所弱，遍计轻，观察力更敏锐的状态。借这个状态与平时的差别，可以更容易看出我们的遍计是怎么积累的，怎么自己骗自己的。从而大大有助于我们找到正确方向，得到正确认识。这个过程显然与佛门的慧力有点关系。
    所以，佛法里用禅定跟外道用禅定的路数是根本不一样的。嘻嘻。


观察修与安住修

    观察修与安住修

    zf

    所谓修法，就是指导用心的方法。人们通常把“见”和“修”分开，实际上当用“见”来观察自心、对心行进行取舍时，见和修就是密不可分的了。
    在这里，肯定和否定的界限就变得极为重要了。
    我们观察心中的诸法──可以有各种分类，如五蕴中的受想行识（当然，应该知道这些作用的内涵）。然后观察哪些心行是“分别心”所摄，哪些心行为“假名安立”所摄；这些心行都是“正当”的，不应否定的。再观察哪些心行是在假名所表示的缘起法上产生的实执；这些心行是要坚决去除的。这就是“观察修”的用心方法。
    在观察修的基础上，面对缘起法而心已不起执着时，心行便已契入了般若妙智。此时自然而然便可安住在般若智中，这就是“安住修”，但此时已是无修之修了。当然，这里的“无修”主要指智慧方面，在菩萨的行愿方面还要努力修行。

    我们的问题出在五蕴中的行蕴中。受、想、识都属安立的范畴。五蕴中能产生“业”的只有行蕴，当然是在受、想、识的帮助下。而只有业才对因果起作用。无明属行蕴，智慧也属行蕴。从本质上说，行蕴就是取舍、决定、意愿。如果把我们的心比作一个司令部，受、想、识是分管信息的获取、识别、整理、归纳、方案的制订等，而行蕴则好比司令，对方案进行取舍、决定。对全局取决定作用的是司令而不是参谋。
    无明是一种取舍──认为我和法都是实有的；
    智慧也是一种取舍──认为我、法都是无自性的；
    出离心是一种取舍──对出离轮回的决定；
    菩提心是一种取舍──对成佛的选择；
    信心也是一种取舍──认为某事为真。

    从根本上说，心行之感果是依据见地的。无论你以什么方式获得见地──较理性的或较多信仰的，见地都对因果起到决定的作用。　以我们以前的见地──“我执”来说，现在看来完全没有道理。但对此完全没道理的“我”“信”以为真，其因果就是我们流落六道。
    我们若能对“无我”“如来藏”信以为真，其结果会样？
    所以重要的是无我、如来藏是否真正成为了的见地！！！
    顶果仁波切说得好（大意）：修就是熟悉见地，行就是不离并熟练使用见地。

    实际上，“见”又何尝不是一种取舍和抉择呢──有我与无我的抉择、修生与本具的抉择！“见”也属行蕴。


诸蕴如幻与缘起法

    大千：
    谁见过“我”？谁找到过“我”存在的证据？可我们凡夫生来就认定非有我不行，这也算一个谎言吧，“我”也是龟毛兔角吧，可其作用之大……。这样说来，我们的有情界和器世间等一切存在，就是无始以来为了“我”这个龟毛兔角从而起惑造业生出来的。

    zf：
    产生作用的是龟毛兔角的“我”呢，还是以“我”为实有的心，即无明？
    在十二支因缘中，产生轮回因果的是无明，即以我、法为实有的错解，而不是“我”和“法”这些龟毛兔角。说根本不存在的龟毛兔角有作用，这是多数人难以理解的。

    大千：
    师兄说得对。这是我的表达问题，实际上是省略了“对（龟毛兔角）的执着”。准确地表达应该是：不光是执着实际存在的东西会起作用，即使执着并非实际存在的东西也可能会起作用。

    zf：
    好，这应算我俩讨论所得到的第一个成果──根本不存在的东西是不能产生作用的。
    （但这里还留下了不少问题，如，是否能产生作用的就是缘起法？应该怎样界定“作用”？这些问题以后再谈吧。）

    大千：
    观慧是缘起法，但指导修行观慧的佛法──佛说的一大套道理，只是一些概念、判断和推理等意识中的虚拟想象，不是实际存在。

    zf：
    这里涉及到一个重要问题：概念、判断、推理等等意识中想象的“虚拟程度”是否有区分的必要？
    例如，“龟毛兔角”和“羊毛鹿角”都是虚拟想像，但对我们凡夫来说，虚拟的程度却不相同。
    毕竟佛法不是为佛所说，而是为众生说。佛法言教要发挥应有的作用，与世俗共许的尺度恐怕是极难把握的。共许得太多，则可能堕于媚俗，起不到佛法的教化作用；共许得太少，又难免欺世之嫌。
    唯识从古义到新义的转变其本质恐怕就是这种与世俗共许尺度的调整结果。
    这里，弥勒菩萨开示：“了知诸蕴皆如幻故”。诸蕴者，即色受想行识是也；如幻者，依老兄前说，乃依他起也。因此，如果在下没有理解错的话，弥勒菩萨这一开示就是说：五蕴是依他起的缘起法！与老兄先前所说之五蕴是龟毛兔角相矛盾！

    大千：
    这个就得多说话才能说清楚了。这之前我们还是先统一一下概念：
依师兄看，世俗谛是有？是无？或其它？
    世俗谛是否包括凡夫所执的自性（二我），和缘起法两部分？
    世俗谛是否等于凡夫所见闻觉知的一切法？
    十八界中，是否六根、六识和前五尘都是缘起法？法尘是全部都是自性？还是里面也有一部分缘起法？

    zf：
    在下这里的“发难”，主要是针对老兄语言的表述上： 　　老兄说，大乘经中所说如幻者即是依他起。那么：
一、华严是大乘；
    二、华严中说五蕴如幻。因此逻辑上的结论只能有一个：五蕴是依他起。
    这显然不是老兄的本意。在下这里要提醒千兄的是，今后对于这类断言，要特别小心。
    宗大师的教派在安立世俗谛时，有三个要点：
一、名言识所共许。因此，世俗谛的法是有，这种有是在无错乱之名言识所共许下的有。安立假名需要有共许的安名处，龟毛兔角显然不在此有的行列。
    二、无余名言量妨难。即名字也是共许的，指鹿为马之举非世俗谛所许。
    三、无观真实量妨难。对上述共许法真实性的探讨，如无有、假有、真有以及凡夫所执的自性（二我）均不在世俗谛的范围。
    上述世俗谛的安立与唯识的安立肯定有所不同，这是正常的。只要世俗谛和胜义谛不相违背，则二谛就会成为众生解脱的舟船。

    大千：
    经论在谈到缘起法时有两种含义：一种是佛菩萨亲证的缘起法的本来面目──真正的缘起法本身，这是有的，但因缘起甚深，凡夫是无知无见不可思议的；一种是佛菩萨为度众生用凡夫名言假安立的方便说缘起法，这并非是实际存在的缘起法本身。
    所以经论在谈到缘起法时也相应有两种说法：说缘起法是依他起性时，一定是指前者，如师兄所举弥勒菩萨开示“了知诸蕴皆如幻故”；说缘起法无生，一定是指后者，如《中论》所说：“佛欲断如是等诸邪见令知佛法故。先于声闻法中说十二因缘。又为已习行有大心堪受深法者。以大乘法说因缘相。所谓一切法不生不灭不一不异等。毕竟空无所有。”因此《中论》才把四缘、因果、有为法及无为法破除尽净。


因缘法聚合的根本动力是行蕴

    zs：
    因缘法的聚合，是行蕴！
    学中观、唯识有个令人郁闷的点，就是因缘是怎么和合的。其实，这里面有两个槛。
    一、没有单纯的无情的因缘和合，所有的因缘和合都有有情参与。
    二、观察到的所有相，都是无意义的──也就是说，观察到白色演变成蓝色，并不意味着这两种颜色是个什么东东，这两种东东怎么和合。应该是观察决定相。──再细一点分，就是〔观察〕里面有行蕴，行蕴决定相！

    zf：
    因缘法聚合的根本动力是行蕴。
    正所谓：
“若人欲了知，三世一切佛，应观法界性，一切唯心造！”
    据在下的理解，这里的“唯心”主要指能产生业果之心用──行蕴。

    “〔观察〕里面有行蕴”是否是想表达如下的意思：
a、观察的生起离不开行蕴──作意；
    b、观察正在进行时亦常有行蕴的陪伴──意愿、取舍。

    “行蕴决定相！”
    ──某些“相”乃异熟果报，虽仍为行蕴之果，但其间的因果关系不是我等轻易可以见到，正所谓“缘起法甚深”！

    常随佛学：
    “因缘法聚合的根本动力是行蕴。”
    ──意思是不是：“……动力就是执取（？）”　？

    另外，三法印中“诸行无常”和这里的这个行蕴，有什么关系？

    zf：
    在下的理解是：因缘法聚合的根本动力是业力，而能产生业力的心法只有行蕴，因此可以等价地说“因缘法聚合的根本动力是行蕴”。仁兄之“执取”用于描述凡夫行蕴之根本，十分贴切。但同时我认为：出离心、菩提心、空性见统统都是行蕴，因为它们的业果是显然的──个人的解脱和无边的利生事业。
    通常的理解，“诸行无常”中之“行”是指三世迁流之有为法，其含义较五蕴中之“行”更为宽广。

    常随佛学：
    那么，这个“出离心、菩提心、空性见”的业果，算包含在五蕴中吗？
    唯心造──把此处［心］作［识蕴］，把此处［造］当作行蕴，不也可以吗？

    zf：
    我的理解
    “那么，这个“出离心、菩提心、空性见”的业果，算包含在五蕴中吗？”
    ──对此不同系统有不同的说法。
    《大般涅槃经》云“色是无常，因灭是色，获得解脱常住之色。受想行识亦是无常，因灭是识，获得解脱常住之识。”可见“出离心、菩提心、空性见”的业果──如来智慧和色身亦可划归五蕴的范畴。

    “唯心造──把此处［心］作［识蕴］，把此处［造］当作行蕴，不也可以吗？”
    ──但众生、菩萨（乃至如来）［识蕴］能力的展现，终究以业力作用（异熟果报）为根本。

    常随佛学：
    众生甚深烦恼业乃至如来甚深密藏，究竟会以诸种业相表现出来──是这意思吗？

    zf：
    正是。“如来不说断灭相”！

    古慈：
    向赵叔讨教，如何将ZS及您所说的跟修行联系起来，如何运用这个呢？

    zf：
    浅见，“修”与“见”不可分。
    一、中观见下的修，用心的步骤大概是：
1、观察自心（此时识蕴起主要作用）；
    2、区分正邪（想蕴起主要作用）；
    3、扶正去邪（行蕴起主要作用）。

    二、如来藏见下的修，用心的原则是：体会邪与正的不二性，于邪上见正（此时行蕴起主要作用）。
    可见“修”的核心是取舍（扶正去邪）和抉择（邪即是正），这都是行蕴在起决定作用，其业果就是烦恼的解脱和利生功德的显现。
    实际上，“见”又何尝不是一种取舍和抉择呢──有我与无我的抉择、修生与本具的抉择！
    “见”也属行蕴。

    常如：
    请问。在中观见修，想蕴和行蕴是一种互为因果的关系吧？
    在如来藏见修，想蕴在起什么作用？是不是在起如来藏见的准备过程中，想蕴的问题已经解决了，已经不用或不太用操心了？在其用心原则上即体会邪与正的不二性，于邪上见正，是不是有相当于转五毒为五智的意思？

    zf：
    “在中观见修，想蕴和行蕴是一种互为因果的关系吧？”
    ──在下上文中的所谓“步骤”只是为了叙述的方便所设置，实际上在心中起作用时可能在一刹那中几乎同时完成的。
    关于您所说之“想蕴和行蕴是一种互为因果的关系”，我的理解是：
1、区分正邪之想蕴的生起，一定是以欲进行此种区分的作意（行蕴）为前提；
    2、扶正去邪之取舍（行蕴），同样必须以邪正之区分（想蕴）为基础。
    从这个角度说，两者互为因果是可接受的。
    “在如来藏见修，想蕴在起什么作用？”
    以一个不太贴切的比喻来说明我们心中识蕴、想蕴和行蕴的关系。
    司令部由三部分人员组成：
一、情报收集人员；二、情报分析、作战方案制定的参谋人员；三、指挥官。
    工作的步骤应为：
一、在指挥官的指导下，情报人员首先收集相关信息；
    二、在指挥官的指导下，参谋人员制定不同的作战方案，并分析不同方案的利弊；
    三、最后由指挥官进行方案的选择并指挥行动的实施。
    在我们的心中，识蕴好比情报收集人员，想蕴好比参谋人员，行蕴好比指挥官。

    “是不是在起如来藏见的准备过程中，想蕴的问题已经解决了，已经不用或不太用操心了？”
    ──是。
    “在其用心原则上即体会邪与正的不二性，于邪上见正，是不是有相当于转五毒为五智的意思？”
    ──是。

    常如：
    哈哈，极高兴，谢谢赵叔！！

    幻海宏愿：
    “观察修与安住修”这一段有点不明白，“然后观察哪些心行是‘分别心'所摄，哪些心行为‘假名安立’所摄；这些心行都是‘正当’的，不应否定的。再观察哪些心行是在假名所表示的缘起法上产生的实执；这些心行是要坚决去除的。”
    是要选择“正当”，驱除“不正当”的么？

    zf：
    “正当”的包括：慈悲心，菩提心，空慧等；
    “不正当”的包括：贪、嗔、痴、慢、疑等。


五蕴是你的我的他的吗？

    佛弟子：
    活着的阿罗汉还可以修大乘吗？还能修菩提心吗？入无余涅槃的阿罗汉，听说还可以回小向大，但阿罗汉是“前五蕴灭，后蕴更不生”，如何还能回小向大？

    zf：
    若从法华经的观点看，二乘的涅槃显然是化城。如来即有能力设置化城，自然也有能力打破化城。

    古慈：
    抛砖引玉，谈谈自己的思考。
    一、肯定可以，很多经典上有，如佛陀之诸出家大弟子。
    二、我觉得应在因果上来思考，入无余依涅槃的阿罗汉，虽然“前五蕴灭，后蕴更不生”，而且“没有识生起了。也没有纳和取的作用”，但是并没有如佛陀一样完全断除无明，与众生之业缘也就没有断尽，由于因果不可断灭缘故，一定还能回小向大的。
    三、按照大乘修法来呀。

    二麻子：
    “前五蕴灭，后蕴更不生”
    ──假如你有幸跟从某阿罗汉修学佛法，而那位圣人教了你如何趋向解脱的方法之后入灭了。请问，他入灭后，他教你的方法还管用吗？说不管用是摆明了否认事实吧。说还管用，那么这是不是与这位阿罗汉有关的因缘没灭？灭的，不就只是执为做主的我吗？
    这问题上面古慈兄说的一点没错，只是你不同意而已。

    佛弟子：
    再请教。那样的因缘是没灭。但生起此身心五蕴的十二缘起则灭。如灭，则此阿罗汉不可能回小向大，是这样吗？

    二麻子：
    嘻嘻，能说仔细点吗？
    “那样的因缘是没灭。”
    ──这部分没异议了。
    “但生起此身心五蕴的十二缘起则灭。”
    ──您是说阿罗汉入灭后，你也看不见五蕴了？不是吧。所以，五蕴不是那么简单的就灭了的。十二因缘你没看见继续流转？这同样也不是那么简单就灭了的。灭的，只是原先的那个普特伽罗执我做主宰。

    佛弟子：
    此阿罗汉的十二缘起还在流转？（我当然能见五蕴，但我不见入灭后阿罗汉的五蕴）

    二麻子：
    这说明我们有错见，不说明别的……
    “我当然能见五蕴，但我不见入灭后阿罗汉的五蕴”
    ──这是我们习惯的错见，五蕴是你的我的他的吗？我们用我执心去想阿罗汉，想不对大概也正常吧。
    “此阿罗汉的十二缘起还在流转？”
    ──无余涅槃阿罗汉已经彻底破除执我，根本谈不到什么“阿罗汉的”。
    所以，只是无我，断灭是我们凡夫添上去的。

    rj：
    如果说凡夫能添上“断灭”，或者说能添上“断灭”的是凡夫。
    那么佛能添上“断灭”吗？　还有就是桌子能添上“断灭”吗？　难道凡夫作到的，佛不能吗？　然后是为什么呢？

    二麻子：
    嘿嘿，只要你用凡夫逻辑，找点佛做不到的事，有什么难的？凡夫能佛不能的，嘿嘿，顺手一件就是──无明。佛能有无明吗，凡夫呢？嘻嘻哈哈嘿嘿。


如何破除对五蕴的实执呢？

    QZ：
    请讲讲如何破五蕴可以么？
    一、应该如何理解色受想行识这五蕴的所指呢？
    二、如何破除对此五蕴的执着呢？
    三、破除五蕴对众生的解脱来说有什么利益呢？
    四、破除对五蕴的执着是不是三宝弟子最首先必要达成的目标之一呢？

    zf：
    抛砖引玉
    “一、应该如何理解色受想行识这五蕴的所指呢？”
    ──依诸经论观察外境内心恐怕是必经之路吧。
    色受想行识这五蕴一个比一个“细”，观察到行蕴和识蕴作用的起灭要费点功夫。

    “二、如何破除对此五蕴的执着呢？”
    ──若能观察到其缘起缘灭的真实相，对五蕴的实执就会破除。
    这里有一点要特别注意：我们的观察必定是有限的，要将有限的观察上升到对“一切法”普遍性的见地，即由对有限法的缘起性的观察过度到对一切法缘起性的认定并不是靠实证，所依靠的是对如来言教的信心。信心在这里所起的作用被许多修行者忽略，认为所持之“诸法从缘起”之正见为自己完全实证。因此在下认为，“信为道元功德母”之说不但适用于密乘和显教大乘，同样适用于声闻乘。

    “三、破除五蕴对众生的解脱来说有什么利益呢？”
    ──对五蕴的执着就是无明，破除无明的利益就是轮回的解脱。

    “四、破除对五蕴的执着是不是三宝弟子最首先必要达成的目标之一呢？”
    ──依在下浅见，对绝大多数学人来说，最首先必要达成的目标是确保此生往生极乐或本尊净土。


对识蕴的执著最为坚固难破

    对识蕴的执著最为坚固难破

    （编按：齐愍网友贴出《慈氏菩萨所说大乘缘生稻干喻经》，其中有云“从五种缘生眼识。云何五种眼缘色明虚空从彼生作意。眼识作依止色作所缘。光明以为照虚空作无碍从彼生作意以为审虑。若无众缘眼识不生。若阙内眼处如是色光明虚空作意。则眼识不生。如是五缘不阙则一切和合能生眼识。其眼不作是念我与眼识作所依。其色不作是念我与眼识为所缘。光明不作是念我与眼识作照缘。虚空不作是念我与眼识为无碍缘。所生意不作是念我与眼识作审虑。又眼识不作是念我为众多缘所生。然有众多缘而生眼识。”，以下是奉心居士的评论和一些鼓励网友学习经典的话。）

    zf：
    多谢推荐此殊胜开示！弥勒菩萨以此浅显比喻，将缘起正见开示得如此清晰，真希望坛上的诸位都能仔细研读此经。
    五蕴之中，我等凡夫对识蕴的执著最为坚固难破。多少行者将识蕴执为“胡来胡现、汉来汉现”不因诸缘而常存的“明镜”！弥勒菩萨的“若阙内眼处如是色光明虚空作意。则眼识不生。如是五缘不阙则一切和合能生眼识。”这一狮子吼当令迷者猛醒！
    诸法待缘而起，即此读经之事亦由缘起。还望老兄能经常推荐读过并有体会的经论，作为我等读经的助缘。


识蕴与真心

    1234：
    如果一味强调直觉，那么结果多半是痴呆的，即使感到头脑很清醒，但是似乎开动不起来，木在那里，失去敏捷反应。开始阶段会感觉如梦中行，烦恼不起，但时间一长问题就明显了。症状会是记忆力减退，中风，老年痴呆都来了，思维那半脑荒废了。我有一段时间就那样，上座后“任运起灭”，就像你说的放弃“主动思维”，不去干扰六尘，自己以为是正见，实际上这样坐下去的话，来生免不了入于驴胎马腹。

    zf：
    师兄能将自己走过的弯路，在论坛上公开示众，提醒同修，慈悲啊！
    不知有多少行人正以此弯路为无上道而努力修学，当心啊！
    这种在“任运起灭”时不失觉照的修持最多可以和正念沾点边，绝非解脱苦之正道。
    八正道中正见位列第一。以正见摄持下的正思维才是圣道之主。正念、正定乃辅主之仆也。

    1234：
    而上座部内观入门的指示却是明确的，了解了那个窍决，用心原则也很清楚，那并非是无为任运的模式，与我们过去遭遇的方法如此不同，而的确会导致见道和解脱。可以说在北传中已经没有这样的修学途径了，早期高僧传时代有否相近作略不得而知。上座部太伟大了，而这些单凭读书也不行的。

    二麻子：
    你没碰到就推断没有，似乎过了点吧。麻子看来，不可以这样说呢。北传也不是单读书的。麻子也知道，你所批评的弊病很多北传学人确实是有的，但就此否定了北传就不好了。麻子甚至可以明确地跟你说，非常可行的实修方法，北传无疑是有的。也是权当私房话吧。
    北传中的方法可能不完全跟你说的方法一样。也可能非常相似。嘻嘻……北传里方法很多，有相似的也不奇怪……以后有机会再聊……

    zf：
    如兄所言，南传北传各有各的妙处，修行得法，都是解脱之路。道理很简单，根子都在佛陀处。
    本人以前修学，由于走过以识蕴为观慧之弯路，故对此印象深刻。
    将在下从此弯路拉向正道者，宗喀巴大师是也。
    后来接触上座部佛法，了解其对此弯路有角度独特的提醒，深感其妙也。
    但见有人将见地沾常的北传行人斥为外道，在下不以为然。何以故？因为菩提心。
    有菩提心者，即是真佛子，既使全无智慧，亦非外道！
    北传佛法有众妙，而菩提心是妙中之妙！

    无畏持明：
    1234那“任运起灭”和“觉照”是不同大圆满的，“无念”并不是没有念头，只是“不粘”，妄念起即觉，此时已为妙用。

    老狗：
    “无畏持明”好心告诉说：那“任运起灭”和“觉照”是不同大圆满的。1234却说：那只是换个说法,我何曾不知你说的，但你做去。哎，自己掂量掂量吧。
    这是对大圆满还不明晰，大圆满窍诀部有外、内、秘密的加行，而秘密的加行在于“观察自心”，破除“自心领受自心”的流转见，大手印推心的颜色、体性、生灭等，皆为如此。
    上面多是窍诀部的指示：指心为空、指空为明、指明为大乐，这是止观双运的修法，在于破除种种错见。必须过了这个坎，也就是破除种种错见，才能直接接触“本面”，否则作那些任运之修，无非是将阿赖耶当成明觉，将无明当成智慧，将识当成觉量，这只是自己欺骗自己的把戏，如果还在这里诽谤大圆满，一看就是没有真实的传承。
    大师龙钦巴指示过很多窍决：如“国王登基大典群臣贺炮”等三个窍决，个个都是针对你那种所谓“不加简择”的“任运修”。所以，怪自己不多闻，且无实修吧。
    还有，大圆满观察一切显现而培养放下贪执之能力，是任何一个佛教传统都或明或显实行的，相信在南传更看的清晰。
    不要因自己一点过去的挫折就诽谤相似的教法，大圆满根本见地的大山安住，修道的大海安住，行为的解脱安住，和果的超越二元的安住，如此四个次第实际修过再发言也不迟。
    那个所谓的“任运”修行，其实只是依照葫芦画瓢，在纯与不纯阿赖耶分，未曾拔除二取，错误尽在你自己，怎么又能含沙射影大圆满呢？

    savelife：
    菩提心应是包含智慧的，为何赵叔说“有菩提心者，即是真佛子，既使全无智慧”呢？另外我一直以为除非发愿往生净土，否则做善事而不修禅定应该是无法出欲界的，不知道我这个看法是否正确？

    zf：
    s兄，别把目光局限在今生。
    在下这里的菩提心是指“众生无边誓愿度，佛道无上誓愿成”的愿菩提心。愿菩提心生起时，并不一定要以空慧为前提。
    “另外一个是我一直以为除非发愿往生净土，否则做善事而不修禅定应该是无法出欲界的，不知道我这个看法是否正确？”
    这要看是什么善事。
    不在菩提心摄持下善事的确只能成为往生欲界的资粮。
    但若有菩提心，则哪怕一点善事也是成就无上佛果的巨大助缘。
    只要有菩提心，纵使现在没有智慧，将来（可能是今生，也可能是来世）也一定会以不可思议的因缘开显出智慧。
    如果我们把目光放长远点看，现在发菩提心者，就是将来的佛。
    因此在下才敢说，有菩提心者，即是真佛子，既使（现在）全无智慧！
    Do your life have been saved？

    gentleLion：
    如是，正因＋正缘＝正果，一切法皆靠因缘成就，一切智慧功德非无因而来。菩萨智慧和功德也不是没有原由而来。ZF说得好

    zf：
    将识蕴误认为是般若观慧，这确实是佛弟子们应该予以足够重视的问题。罗侯罗·化普乐尊者所著之《佛陀的启示》对此有相当清晰的论述，建议对此问题感兴趣的诸兄能认真研读此书。
    事实上，此识蕴并不是常恒不变，而是缘起缘灭，只不过其起灭如瀑布之流，不仔细观察，难见“水花”罢了。另外，在想蕴不起之时，行蕴和识蕴仍然炽盛，此时炽盛的行蕴错认炽盛的识蕴为般若观慧，这是行人应十分小心的陷阱！
    引导后学在前念已灭、后念不生之际体验“真心”者不乏其人。这里已灭、不生之“念”究竟是什么？是无明吗？此念若非无明，则无明便仍然躲在此“修持”的背后嘲笑行人！

    幻来：
    汉传佛教常引导行者通过体验“前念不生、后念未起”之际而证入“真心”，确实是一大误区。此所谓“真心”，实际是“清明”的妄想境界，对应于色界定与无色界定所观境。于此二界境，行者最易堕入的是无想定以及非想非非想定，前者只是第六识暂不转（种子犹存），但仍有杂染性的第七与第八识现起，后者是微细的杂染心识现起状态。此二者由是微细的心识状态，在印度的外道中常被执为涅盘状态，而在汉地常被视为“真心”现前。
    赞同zf兄对此问题的看法。但兄说“在想蕴不起之时，行蕴和识蕴仍然炽盛，”是错误的。想蕴由想心所所摄，具有遍行性，只要有识蕴与行蕴生起，想蕴一定亦生起，不可能分开。

    zf：
    多谢师兄指正！文中“在想蕴不起之时，行蕴和识蕴仍然炽盛”一句，我想表达的意思是“在想蕴暂不生起之时……”
    在不同系统里，五蕴的含义可能并不完全相同。
    在《佛陀的启示》中，作者开示：
“识并不能辨认事物，这点必须明白了解。它只是一种知觉，对于某一事物的存在的察觉。眼睛接触一种颜色，比方说蓝色的时候，眼识即行生起。但它只是察觉到有一种颜色存在，并不认识它是蓝色。在这阶段，尚没有认识。认出它是蓝色的，是想蕴。”
    在这里识蕴的生起与想蕴的生起是可以有“时间差”的。而识蕴的生起是离不开“作意”的，此“作意”为行蕴所摄。因此，就某一个环节来说，在想蕴未生起之前，行蕴和识蕴单独生起是完全可能的。


破的是执着与迷思，不破的是功能

    云飞月：
    这里倒是有个问题的，也涉及到五蕴是否俱起的问题。那就是，一念无明或一个念头起来（种子），到生起现行的过程，似乎要依次经历识、行、想、受、色五蕴的过程。

    二麻子：
    嘻嘻。作为追寻的一个过程……你上贴的说法无可非议。作为阶段性的观察结果，你的描述也属于正确范围。你所做的事，确实是在逐渐将矛头指向无明。
    只是别那么简单就把什么当作“是”无明。没错，那些都是无明表现，无明就是那类玩艺，但简单的说个“是”，其实已经很粗了，不应该是你想表达的本意。

    泥象：
    那从眼识入道的，破眼根、眼识孰先孰后？

    二麻子：
    都破！！！！包括意识。也可说都不破。
    破的是执着与迷思，不破的是功能。
    1234兄指出，从根尘识破时一定也破到意识处，是对的。这是从实践方面来说的。

    离离：
    根尘识破，当然破到意识了。难道根尘识外还有个“意识”？嘻嘻，咋这么不小心。

    二麻子：
    嘻嘻，你也不很小心……根尘识等十八界，分做六类。若不是专门谈意根、法尘、意识，一般讲识，可以是眼识，耳识等，完全可以说的不是意识。但是，实修时，一定会牵到意。


关于执着的迁转

    关于执着的迁转

    二麻子

    从轮回的角度来说，其实没有什么死亡，只是执着换个地方。
    或者说粗点，换个身体。当然，这个换是自然规律强迫的，当事者未必喜欢。换的过程里跟一般人对死亡的想法最相似的地方是有一段“大昏迷”，在这段期间除了极其高明的修行人，其他人（或者说“主体”）都将失去对主客间的了知与分别，进入无记。这个大昏迷对不同的人到来与持续的时间非常不同，越是修行有底子的，来得越晚，持续越短。
    亡者身体什么时候才可以搬动？应该是进入大昏迷后。凡夫从这个大昏迷醒来时，已经不再执得住这个身体了，依俗话说，神识离体了。麻烦在于不同人进入大昏迷的时间差别很大。不修行的人有不少远在身体死亡前就昏了，也有些临终清醒到最后一口气的，让人不容易判断什么时候才昏迷的。
    好的修行人则完全可能在外呼吸停止后依然住于禅定里，这个禅定的时间非常不容易事先判定。
    上面文章里引用佛教的说法也只是个大略的说法。一般地说，宁可晚点搬动。精确的确定就得靠因缘，看现场有没有高人在了。


“无情有性”与“心中有色”

    玄兹：
    我们的心念是否有色？

    zf：
    心中当然有色。

    玄兹：
    在下开始问的是“心念”是否有色，zf兄回答“心中当然有色”。
    心念是心活动的产物，zf兄说“心中当然有色”。依据佛家词典“色”有坏的意思，请问zf兄：心中的什么“色”可坏？另外，心念与心中的色有什么关系？

    玄兹查佛家词典“色”有坏的意思，这样一来所有的“色”都有生灭，故曰其幻，本空。

    zf：
    “无情有性”与“心中有色”。

    “请问zf兄：心中的什么‘色’可坏？”
    ──心中那个您正讨论之“色”可坏。

    “另外，心念与心中的色有什么关系？”
    ──这个问题可就复杂了。
    仁兄可曾听说“无情有性”？即色法也有佛性（或觉性）。
    在下浅见，心念与心中的色的关系非常类似无情与其中的觉性之间的关系。
    仁兄若真对心念与心中的色的关系有兴趣，建议您下点功夫，首先真正了解无情有性。
    藏宝之地──汉传之天台、华严两宗。

    当然，“无情有性”之说，被许多教内人士视为奇谈怪论，“心中有色”之说恐怕也难逃类似命运。

    玄兹：
    忍不住还要续问，藏于八识中的该念如何灭？

    zf：
    老兄，别急，您还是先对心中是否有色的问题获得定解。

    净国：
    （编按：关于楞严经耳根圆通章）有人说观照那个能听的，小可觉得有问题——道理上讲没有所听的，就没有能听的。通议里面讲“音声虽有动静闻性不属有无”；　而且说“不因声生。不从声灭。远离有无生灭。此即常真实也。”既然是常真实，应是离“能”离“所”的。但是阿难离开色拣择不出见来，离开声焉能拣择出个闻来？

    zf：
    净国兄，这些地方真的很费解。兄看看在下这样理解是否沾边。将“闻性”理解为“闻的体性”，闻是缘起法，其体性为空。诸法之空性乃“圆满成就的真实性”，因此说闻性（即空性）“不因声生。不从声灭。远离有无生灭，此即常真实也。”并不违背缘起法义。


唯识是从哪里说起的？

    唯识是从哪里说起的？
    ──从观察自身看遍计执的积累

    二麻子　静风

    任何一个交谈的题目，理论的建立，都有个开始说话的基础。没有这个基础，话是说不起来的。对于一个理论体系来说，这个起始的点“STARTING POINT”未必就是整个理论的基石。相反，有的时候理论建立过程里甚至还需要否定／破斥这个起始点。但是，这个起始点的选择，对理论建立的方式却具有十分重大的影响，在很多情况下如果学习这个理论的人忘记了这个起始点是什么样子的，会对后来的学习添加巨大困难，甚至导致大量误解。
    那么唯识学的这个起始点是什么呢？为说明这点，我们先粗略看看中观的起始点如何。中观师对中观说话的起始点有明确说明，叫“名言共许”。其意义为接受大众通常的共业为说话的共同基础。恰巧，这个基础基本就是我们一般凡夫平常说话时的所谓理性的基础，既是不特别明确说明大家也会自动用它。但中观师们仍然严谨地将这个共许明确表达出来，说明是随顺世俗说有无，以防止凡夫由世俗谛而生实执。假如没这样一个基础，则语言交流将十分困难，是非判断也没有共同规则了，那是不行的。明显的是，中观并没将这个起始点“名言共许”当作真理，或者真理标准。而只是作为说话的基础。但这个起始点带给中观理论的影响十分明显，基本上整个中观宗对法理的抉择都没离开这个基础。
    那么，相对应的，唯识学的起始点是什么呢？非常有趣，唯识说话的起始点几乎与中观完全相反。我们知道唯识学最初是瑜伽行派的教科书，是指导佛弟子们借禅定破除各种执着的教法。所以如同禅定，这里说话的起始点，完全是从一个人为本位的感觉／觉受等说起的。即使所涉及的是共业，比如大家在开同一个会，唯识说话的方式也是从某个具体参加开会者的自身体会等说起，而在相当一个阶段里不涉及别人的感受，也不讨论相互作用。例如，唯识里最常见的例子之一，于人所见的水，天人见为甘露，而饿鬼见为脓血，就是分别从个别众生的本位感受来说明识与境界的关系的。由于没有现成词汇，对于这样一个个起始点，下文将暂时称之为“绝对别业”。绝对别业这里还有第二层含义：唯识说话实际上不仅仅是限制从某个人的本位开始，还要在这种个人的本位上究其最“基本”的开始说话，当然，这里面对的是凡夫，最基本也是相对凡夫所能做到的而言。那么，什么算更“基本”的呢，两类事务相比较，哪个算是更基本的？唯识这里使用了一个十分合理的判据：凡是推导／推断出来的东西，都没有这些推断所依赖的素材（东西）更基本。于是，唯识学没有明确说出来的起始点“绝对别业”，就是对具体一个凡夫学人来说自己能追寻到的最基本的有情活动。
    从这个“绝对别业”起始说话，唯识做的第一件事，显然是就让每个人都具体找出最基本的来看看。对于一个修习禅定观察自己内心活动细节的学人来说，不需要多少禅定功夫就可以看到，我们感受到的山河大地等外境，无非是前五根传来的感受，经意根意识加以分别联想，而得出的推断。凡夫并不能也未曾直接感受过外境。如果没有一堆感觉，或者不经我们推断，外境就根本无从谈起。所以，外境完全不是基本的，而且除了作为意识的推论和推断，外境根本不存在。从这个意义上说，唯识学说无境是绝对天经地义的，而且这个无，就是龟毛兔角的无！
    然而这样地否定外境，虽然无，却与断灭根本没关系，因为这里根本没否定推断外境所依赖的感觉。于是我们知道了与我们眼耳鼻舌身相对应的十八界里的五界，是没有的，有的只不过是意识的推断。同样方式再进一步追寻我们马上会发现，眼耳鼻舌身根也是推断出来的，同样属于无有，而其对应的识也是如此。这样十八界里已经有十五界属于无有，仅剩下意了。再看下去，就是意识本身也是也是推断的结果，所谓我思故我在，同样要归于无有。破到这里，似乎十八界都破光了。断灭了吗？没有。那一堆在凡夫身上引发出外境推断的觉受感觉还在。
    再继续仔细追究下去可以发现，既使是这些感觉，觉受一类的东西，其实也包含了某些细微的推断，仍然可以否定。实际上，当感觉／觉受的原材料被认识为感觉／觉受时，是已经使用了推断并且隐含（不明确地包括）了我与我所。但引发这些觉受／感觉的素材以及能将这些东西推断为“我的感觉／觉受”的能力，换句话说有情具备的分别的能力，却没被否定掉。到这个地方，大致就是凡夫能追究的极限，这些没否定掉的，唯识学称为识，或者识所变现。这两词在一般情况下含义并不相同，但在这个具体情况下没有本质差别，因为这时还没有明确推断分别出能与所。所谓凡夫“及识而还”，就是说到了这种地方就不再能深入了。由于未被否定的那些里面很大部分是指有情具备的分别能力，所以，说有能（力）无（推断出的）所（境），也是一种相当合理的，属于如幻有范畴的表述。
    那些还没做这种推断前的“原材料”，大略地说就是依他起，但并不纯粹。实际上，在凡夫地这些原材料也是含有极其细微的执着和扭曲的。反证如下：如果此处全无扭曲执着，那么这堆原材料就应该也能显现别人的乃至一起众生的觉受，事实却并非如此。说明此处也是污染的。由此可见唯识学说一切众生都是染识的结论，是基于对凡夫心广泛而深刻的了解，是非常真实的结论。了解了这个追究过程也可以明确看到，无论唯识怎么强调无境，唯识不会落于断灭见，无境否定的只是凡夫的想象与推断──更唯识专业化的词是否定“遍计所执”。很明显，从原材料到感觉／觉受再到外境山河大地的推断过程就是遍计的过程，而且是遍计层层相套越积越多的过程。然而，虽然遍计了，遍计未必一定要带有执着。带执着是凡夫的特征，凡夫在上述的推断过程里无一不加入大量的自性见执实有，所以一般也称为遍计执。但对于圣人，他们确实可以为了交流方便而做同样的推断却完全不落入执着。所以有时说遍计不说执也尤其合理性。
    那么，那些“原材料”是怎么来的？唯识一般说依它起，说种子／现行和合，这就出现了阿赖耶识的概念。从绝对别业的起始点加上唯识对遍计执的破斥来看，引入作为种子的集合的阿赖耶识是非常自然的发展。我们知道，业果不失的规律在中观等宗见来看，很容易用相续的因缘法来理解：因缘法的相续过程本身就是不错乱，这样的相续完全可以在相对独立于特定个体的情况下不断，从而保持因果不错乱。但从绝对别业角度来看，说外面存在相对独立的相续因缘实质是种推断或遍计，故而是没有的。所以，因果的不错乱只能是源于某种“一体的”而且观察不到的东西──对具体的现行是种子，对总体叫阿赖耶。不幸的是，直到现行前，种子与阿赖耶都是凡夫观察不到的，所以对凡夫依然是种推断或者遍计而已。
    由上述的讨论我们可以看到，如果明确知道唯识的说话起始点是绝对别业的话，我们可以非常容易了解唯识学里对外境否定的彻底程度及其意义，以及其条件限制。唯识无境在这个意义下完全不会落于断见上去。而且可以看出引入八识概念是非常自然的。然而，绝对别业并不是表述佛法唯一正确、唯一方便的起始点。实际上，它有所方便就有所不方便。当讨论到共业相关的问题时，上述结论成立的前提条件就有问题了，需要小心修正。绝对别业角度需要修正的最明确情况是其他众生也有识存在，这个既使是绝对别业角度也不能否定。因为否则这个，就是通过其他众生否定自己。所以，唯识从来承认识外有识。而这个承认，也实际上是默认了众生的识之间，一定存在着相互作用。那种说每人识里面有别的众生的识的复制件的说法，是过分生硬的包装，没法说通的。这种相互作用是明显的，共业是大家每个人都觉受得到观察得到的。那么识与识之间怎么作用是个需要解释的问题。因为所谓共业也可以说是多数别业相互作用相互纠缠相互叠加的结果。所以，绝对别业角度下的结论，在适当修正下是可以推广的。但这里有着非常多的陷阱，单纯用思维推断的遍计方式，几乎一定会执出问题来。这方面涉及太宽广，此贴中暂时搁置，不予深入了。
    由此联想到唯识与中观双方争论的很多问题，其实是源于对唯识这个起始点的不了解。特别是唯识学人对这点不了解造成的辩论无力，有时候让人哭笑不得。比如从中观立场看，兔子与兔角是相当不同的。兔子是俗有，有俗义上一定真实性，兔角根本是非量，完全没这个东西，没有任何真实性。然后问，唯识无境是说境如兔角吗？结果，不少唯识佛友回答时候，中气就显得弱了。其实唯识佛友大可回答得强硬些。理由有两个。一个从唯识的角度如上面所说，在绝对别业起始点下外境就是兔角，两者都是凡夫心遍计／推断出来的。另一个理由却是从中观的起始点分析一下建立俗有／俗义真实的基础是什么？这个基础是共业，或者说共因缘。我们接受为俗义真实的因缘一般至少要两条共性：一、这因缘要与意根以外至少一根相（共）关，否则不承认。二、要与多数人相（共）关，否则不承认。比如兔子，符合这两条：很多人都看见过，而且能看见摸到。兔角不同，虽然人人可以用意根想像兔角，没其他根能相关接触到所以不被承认。再比如，有人白天见鬼，因为多数人没有这样的共同经验，不被认为是真实。但是在唯识的绝对别业的角度来看，这两个判据都没有意义。既然是别业，谈不到大家共的。既然前五根也同外境一样根本没有，就根本不能用做独立判断。所以，在这个绝对别业的角度下，中观通用的那种相对真实与完全虚妄的差别并不存在。这地方用中观的角度套到唯识头上完全不能成立，是鸡同鸭讲。唯识无境，可以不排斥这个俗义真实与完全虚妄的差别，但这是要在对由“绝对别业”起始点导出的结论做出合理修正以后，而不是对“绝对别业”下的结论本身。“绝对别业”与“唯识无境”对于中观宗见里俗义真实与完全虚妄的差别，既不在逻辑上排斥，也未在逻辑上要求，实际是逻辑中立的。而在唯识对共业的推广，对这个问题将应该得出与中观类同的结果。
    推论与疑问：由上所述，假如“绝对别业”确实是唯识学当初开始建立时候说话的起始点，又假如学人对这个起始点有明确了解，那么唯识学现今一些深奥难解问题可以得到很大的简化，而且唯识学人与中观学人的很多争论就明确成为互不妨碍的多余。这看来颇为有益。然而包括作者本人由此却产生一个相当的疑问：既然如此有益，为什么作者等未曾见到中印藏祖师们说明这个问题？对此，作者谨列出数个可能性如下：一、古德曾经开示过此点，但作者等学浅，未曾读到或读到未能记得，或有大德曾经读过。这是作者最希望的情况，并且盼望饱学佛门大德能指点出处。二、古德曾有此类开示，但在漫长的时间里消失了。这是作者最不希望看到的，但是却实有可能性。理由与下条同。三、从上古德未开示此事，更未曾录入经纶。这点虽然看来突兀，实际却有相当的合理性。作为唯识发源的瑜伽行派，其主要成员应该都具备深厚的禅定知识与实践经验，对于他们来说，上述的起始点问题可能是太浅显太明显太初级了，实在是不言自明，不需要多说话的。既是不说话此派学人也都应该知道。问题是，当瑜伽行派慢慢演化到唯识宗的过程里，由于修行方式的改变这个问题不再是不说自明的了，于是对这个起始点的了解就湮没在历史中。如果是这样的，那也实在是没办法的事情。
    小结：明确地以绝对别业作为说话的起始点，我们可以清楚地看到外境只是对一些识所变现的现象的推断，而凡夫对此推断执为真实。这就是所谓的遍计执。唯识破除这些凡夫错误见而说的唯识无境，完全不会导致断灭见。而对识所变现说为依他起则避免了常见。这种与中观从起始点就开始的不同观察角度与不同表述方式，使很多中观宗常用的概念完全不适合用到唯识的表述模式里来。而学人对这点的了解不足，是引发出若干中观唯识间无谓争议的原因之一。此外，假设以绝对别业作为起始点可以很明确地看出，唯识宗引入阿赖耶识是非常自然合理的发展。当讨论的问题超越出绝对别业可用范围时，对唯识理论的拓广必须十分小心。

    静风：
    声明！这贴都是麻叔写的。只是一些细微处我提出了一些修改意见。有顶礼错的我一定double的顶回去。哈哈。不过我以为大家围绕这贴提出一些讨论到应该是非常有益的。

    zf：
    先鼓掌，后问难。
    “所以，唯识从来承认识外有识。而这个承认，也实际上是默认了众生的识之间，一定存在着相互作用。那种说每人识里面有别的众生的识的复制件的说法，是过分生硬的包装，没法说通的。”
    若依华严之法界观，“每人识里面有别的众生的识的复制件的说法”甚合法义。何以故：
“法同法性，入诸法故”，解云，法者即举缘起幻有法也，同性者，缘起即空而不碍彼相故，即全收彼为此，以彼即空而不碍彼相故，即此彼全收相皆不坏，是故此中有彼，彼中有此。
    麻兄、静风兄，如此精彩的文章，若有小疵，甚为遗憾。既然名“初稿”，便是准备修改的。对如在下这样的问难者，二位如何回答？

    二麻子：
    老兄客气。即如大海，水中有盐亦即盐中有水，彼此不相妨碍。
    而不象计算机备份，若A备份B则A里含有完整的B复制件。阿赖耶不能像计算机备份，因为这里众生平等，若A备份B，则B也需备份A，但A里有B，所以B要有两个B……如此下去无尽，BA内各需要有无穷自己与对方的备份……相当无法令人接受。嘻嘻。
    所以，讨论到这些问题时，应该脱离阿赖耶绝对独立的想法。正说明绝对别业这样的起始点，有其方便也有其不方便。

    zf：

    老兄，诸法实相，难以接受也得接受。看看古德怎样说：
大方广佛华严经金师子章
    贤首法师法藏述
    第四因陀罗网境界门者。谓师子眼耳支节一一毛处各有金师子。一一毛处师子同时顿入一茎毛中。各各显露皆有无边师子。一一毛头带此无边师子还入一茎毛中。如是重重无尽。若帝网之天珠。故名因陀罗网境界门。

    二麻子：
    嘻嘻。那就让能接受的人接受……，海水也不过如此是个比方。水里有盐，盐里有水，一滴水里之盐与大海之盐无别，一团盐（说做盐的话）里之水与大海之水无别。已经一多互摄了，用不到别有复制件。
    “第四因陀罗网境界门者。谓师子眼耳支节一一毛处各有金师子。一一毛处师子同时顿入一茎毛中。各各显露皆有无边师子。一一毛头带此无边师子还入一茎毛中。如是重重无尽。若帝网之天珠。故名因陀罗网境界门。”
    老兄引的，与阿赖耶识怎么个联系法，麻子没看明白呢。别用诸法实相吓唬俺呀。诸佛世界重叠就是每个阿赖耶得有无穷复制在内？

    zf：
    只要阿赖耶识是缘起法，就逃不出这个“相”。当然，不接受此“观点”的人多得是。

    二麻子：
    这可是个古怪地方……，没人敢说阿赖耶不是因缘法的。不过却又说阿赖耶不是凡夫能观察到的。这是耶识古怪的地方吧。这样严格来说，我们凡夫都应该闭嘴，咱们讨论就进行不下去了呢。嘻嘻。

    zf：
    不见得，缘起法中，我们凡夫所见不及大海之一滴。但如来还是为我们开示：诸法从缘起。

    二麻子：
    这不正是见得吗。我说凡夫闭嘴，你说如来开演。

    静风：
    鼓掌赵叔，复有问难：“法同法性，入诸法故”，解云，法者即举缘起幻有法也，同性者，缘起即空而不碍彼相故，即全收彼为此，以彼即空而不碍彼相故，即此彼全收相皆不坏，是故此中有彼，彼中有此。
    赵叔既说，诸法实相，此中有彼，彼中有此，为何诸人阿赖耶识却是不同？既然彼此互有，应仅为一共阿赖耶而已。请教赵叔如何答复？

    zf：
    答案是现成的。《大方广佛华严经金师子章》贤首法师法藏述：“第五诸藏纯杂具德门者。谓若以眼收师子尽。则一切纯是眼。若耳收师子尽。则一切纯是耳。若诸根同时相收悉皆具足。一一皆纯。一一皆杂。是圆满藏。故名诸藏纯杂具德门。”

    常随佛学：
    “有谁在不断进行复制这个动作吗”？

    zf：
    所谓的“复制”是不需要“谁”的。

    rj：
    本来一性，何来复制之说？因众生妄想而生分别，幻见人我法相。

    zf：
    众生妄想而生分别，幻见人我法相，为破此执，方说入我我入。

    rj：
    另外，唯识是瑜珈行的次第法门，何以能是议论话题？

    zf：
    上路之前，交流一下对地图的看法，也没什么不可以。

    hu－ou：
    “每个识都有别的识的复制品”不能按常识去理解，常识很容易理解为：“事先存在”一份“别识的复制品”。这只是一个方便的说法，其实是要否定有外存实存的“共同体”的存在，而又要表达“共业”的现象。唯识还有些方便的说法，比如“种子”，不能从常见到的种子即“所”即“存在对象”这个角度去理解。

    二麻子：
    嘻嘻，干嘛要尽……？
    那个复制件的问题，毛病就出在多一件复制上。佛法里确有一多互摄，不过法界这种互摄，不必在阿赖耶用这么笨的模型描述吧。嘻嘻。
    你这地方指的重点与我想指的重点不大一样。
    麻子想的重点是另一个。举例，当唯识说现行相续的时候，讲上一刹那的现行与种子结合构成下一刹那的现行。那么这是说了现行的机制，或者现行生起的规律。
    现在，当我们谈识与识的相互作用时，也得说出个机制来和规律。这个不说明白，那么相互的共业就不知道怎么安立。
    比如麻子踢你一脚，你怎么屁股会痛？嘿嘿。
    唯识无境，怎么痛到你那边去了的？就说你那边凑巧就这个时候有种子同时现行，说服力恐怕不够。这也是静风当初问的问题的要点。后来的圣普在莲舟上的帖子，还是问这个地方。麻子与静风的帖子，实际并没涉及这个问题的回答。对个地方，我非常希望看到唯识到底怎么说的。

    荒山：
    如果有人偷偷地在你手上扎一针，你会本能地把手缩回来。这种反应并没有意识的推论和推断，那这个外境是否存在？
    “但引发这些觉受／感觉的素材以及能将这些东西推断为“我的感觉／觉受”的能力，换句话说有情具备的分别的能力，却没被否定掉。到这个地方，大致就是凡夫能追究的极限，这些没否定掉的……。所以，说有能（力）无（推断出的）所（境）”
    ──你是怎么知道这个“能力”的？难道不是层层推断才知道的么？既然是推断出来的，那“能力”也是不在的了？（“能力”这两个字一出口，或在脑子里一出现，已经是经过意识的作用了）
    迎面而来的汽车可以撞伤／撞死人，而兔角最多只会给人一场虚惊，出出冷汗而已。说外境就是兔角好像有问题吧？
    我学佛时间短，中观的论还没看，对唯识更是一无所知，斗胆问几个问题，请师兄们多多指教。

    二麻子：
    “如果有人偷偷地在你手上扎一针，你会本能地把手缩回来。这种反应并没有意识的推论和推断，那这个外境是否存在？”
    ──这个怎么就没意识参与？有。意识包含了思想，以及一些比思想要细微的活动。你这里大概只是指思想了吧。手缩回来已经包括把痛感认为不是我，而是我的感觉这样的活动。当然，这里用话说出来就比较粗了。

    “你是怎么知道这个“能力”的？难道不是这样层层推断才知道的么？既然是推断出来的，那“能力”也是不在的了？（“能力”这两个字一出口，或在脑子里一出现，已经是经过意识的作用了）”
    ──这个误差来自做与说的差别。如果是做，这个地方不用我们这里的推断。能力是明摆着的。但要把这个事说出来表达出来，也只好借用语言，这就包含了推断。

    “从另外一个角度来说，我们的身体也是外境，按文中的推论，我们的身体也是不存在的了？身体不存在，还有“能”存在吗？”
    ──是。身体就是这样的。但能还在。如果真的没有能，你现就连假的也推断不出来。

    “迎面而来的汽车可以撞伤／撞死人，而兔角最多只会给人一场虚惊，出出冷汗而已。说外境就是兔角好象有问题吧？”
    ──你这是肯定外境在前吧？完全从个体来看，出冷汗跟死人的本质差别在哪里呢？

    “我学佛时间短，中观的论还没看，对唯识更是一无所知，斗胆问几个问题，请师兄们多多指教。”
    ──您客气了。但您确实对说这些话所用的前提条件不很了解。慢慢来。大家都是这样慢慢来的。
    单从观察角度来说，科学甚至发展出一套普遍做法。对于一个前提条件，先不考察这条件对不对，对不对以后再说。先在这个前提下看看都能发展出什么推论。再由推论看看与实际符合不符合，从而判断前提的适用范围。这类做法的典型例子是非欧几何。刚发展出来时，根本不知道符合什么实际，有什么实际用处。

    善德：
    到哪里去修学唯识？谁授课？
    “……修学唯识要费很长的时间，也要有好老师指导，而且经论相当深，一般程度恐怕很难理解……”
    若闻佛号。心中狐疑。于佛经语。都无所信。皆从恶道中来。宿殃未尽。未当度脱。故心狐疑。不信向耳。

    哈哈：
    正是正是，你也仔细再读几遍。“于佛经语。都无所信。皆从恶道中来。宿殃未尽。未当度脱。故心狐疑。不信向耳。”于佛说唯识等经都无所信者也是如此。

    玄兹：
    嘻嘻，这篇文章贴出来就给俺土八路看的机会。俺感觉用“相对别业”也比用“绝对别业”要好懂。俺土八路理解什么需借助字典的解释，而字典中关于绝对的解释套用在“别业”上使得“绝对别业”很不好理解。除非麻兄对“绝对”有自己的别样解释，即使那样也需把别样解释给出来。

    二麻子：
    这话有道理呢……，俺当时主要想表达的是：这个角度是只从自己这个角度看。不管问题多复杂，别人情况如何，先不管。只管从个体角度看感受。就是说，不管什么共业，只管拉着仅与自身相关的部分观察。
    这个意思其实比较绝对。嘻嘻。常如兄这里真看出麻子当时的用心来了。

    rj：
    嘿嘿！“只管拉着仅与自身相关的部分观察”难道谁能观察到和自身无关的部分？若有那真奇了。

    二麻子：
    你上面那话是个事实。但问题在于，我们凡夫老是不信／装没看见／忘了这个事实。所以才强调。
    嘻嘻。为什么倡导学雷锋？因为雷锋少。为什么反复讲唯识无境，因为大家都执境为实有。也就这么件事。

    玄兹：
    若把这个角度设为绝对是否有强加的味道。

    二麻子：
    这不是你说的那个绝对，这个绝对的意思是一切其他的都不管。跟绝对优先里的用法相似。是从中观的角度看唯识。或者说从共看别。这个ZF绝对知道。麻子也是知道的。对应地，从唯识角度应该怎么看？麻子一直在看。似乎到现在还没看到广泛同意而明确的看法。当然，可能是麻子孤陋寡闻。

    大千，玄兹兄请进。嘿嘿。千兄，你说俺是支持你还是搞痛你？俺这里其实几乎没使用什么禅定里的东西，唯一粘点边的大概是用了点自我观察的方法。所用到的东西也很普通，没修禅定的人也一样可以体会到的。唯一可能算差别的，不过是看问题的角度稍微不同。但是，麻子的结论似乎比千兄还强硬呢。嘻嘻。
    老兹，你自己看看，这里有什么别人做不到的禅定东东？嘿嘿……
    这回跟静风兄合作，双方互补，合作愉快。嘻嘻。哦，这合作愉快不仅是祝愿，也是结论。


唯识、中观与其他

    茶壶：
    既然中观和唯识各自有各自的方法论，有各自建立的前提，那么，把这两个体系放在一起比较，有没有可供比较的大前提或者说共同的基础？如果有是什么？

    二麻子：
    嘻嘻，茶壶兄可别期望太高。这个争论历史很久了，不是我们就能消除的。共同的底线肯定是有：都是缘起性空，都是佛说的，都是靠成就者的证量。所以，根本上原则上一定是能协调不矛盾的。但怎么能做到？问题很多。我们做我们能做的也就是了。
    比如有些唯识行人无条件的不许外境，不管什么结论，那在另一些人看来不成了定论常见了吗。又如唯识宗说过心是实有吗？也许有的行人有这个想法，那另一些人觉得就该批。但唯识整个理论体系不是这样说的吧，所以就很像唐吉柯德大战风车了。

    茶壶：
    既然如此，俺理解，这缘起性空应该是一样的。可是在这同一个基础上建立的两个体系的见地为什么有差别呢？是哪一个环节或者哪一个方面导致的？

    二麻子：
    这个问题比较难回答。历史上，到底是什么原因怎么导致的，可能很复杂，而且也未必都记录下来了。所以，现在只能说这个问题的原因有不同的判断，真要是去断言哪个判断是正确的，大概在技术上与因缘法上都不大容易做到了。这问题在麻子看来就是说话出发的角度不同。

    智行：
    好书太多了，看不过来。师兄能否简要介绍一下？不过，读来读去，本人还是觉得汉地的论在见地上说得凌厉，直接到位，给人痛快的感觉。藏地的在修行上说得细，见地上较迂回。如来藏是佛说的，怎么会有大乘人否定如来藏？这个在下实在不可理解。若有大德作否定说，愚也只能说那是方便遮止而已，岂是究竟说？愚读过一些藏地的论著，都没谈到这一步。所以，不太清楚古兄的说法来自何处？

    二麻子：
    嘻嘻。也许还可以有别的情况，未必一定是方便遮止，未必是绝对否定，也未必是肯定。不同体系的说法，其实很有变通的地方，但其本质可以一样。
    比如，格鲁应成中观见是不说七、八两识的。这个不说，被不少人说成是“中观不承认七、八识”，这就有点容易误导了。其实中观应成见不说七、八识，只是不说这个名相。七、八识所具备的功能等，一点都没不承认，同归到六识里说了。比如，因果的相续，若用八识种子固然可以说，但中观应成见直接用相似相续不断也是直接了当。
    同样，对“不承认如来藏”这事，也是需要仔细简别的。未必会成为象智行兄担心的这个样子。

    常青：
    如果“流注”之意，在中观里是用相似相续来说的。（说到这里，想起狮兄在楼上对于那“意识是持续不断”说法，颇感不好理解。其实如果把“持续不断”，换作这里的“相续不断”，他多半不会再有异议了。）
    那，“明流，暗流、等流串习”之意，不知在中观里是否也有对应的说法？麻老，您能不能只用几句话简单说一下？请您不要扔给我一本中观的经典应付……

    二麻子：
    对不起，您这个想法有点过分。你试图要求将唯识的一一名词都要中观里有对应，这不可能。如果可能，中观就变成唯识了。别说中观唯识这么大的两大体系。俺给你举个例子。
    在大手印等教法后面，都有对空性／本觉的某种表述／引导。一种说法是明空觉三分。另一种说法是乐明无念三分。这些词都需要仔细简别的，我们这里不谈。但这两个三分表述的完全是同一件事，于是，有人试图建立两种三分间的对应关系。嘻嘻。这是建立不起来的。
    举个更简单例子是：三分同一个圆，两种三分就能建立每份间的对应吗？没这事。
    所以，这次连中观的书都没开列。


唯识与中观上的表达方法略谈

    唯识与中观上的表达方法略谈

    二麻子

    A兄问：“‘瑜伽则真有俗无。以三性为本。中观乃真无俗有。是二谛为先。’何解？”
    大哉乎，此问也。麻子答不了，只能瞎侃几句……
    A兄此问总括唯识中观两大智慧解脱门，可谓大哉。麻子私下想，真能全面回答这个问题的人当代未必有，就是自有佛教以来，能回答的大概也没多少人吧。麻子当然没这个能力回答。嘻嘻。
    这话麻子什么地方见过，记不住了。虽然简练，其实很容易给人造成误解。首先，这并列的有无，仅仅是字面的排比，其内在的含义，在中观与唯识，其实有相当的不同。真解释这不同非常麻烦不容易，而这样简单并列实在容易误导。
    中观是从思辨心开始的。真无者，不过是说无有自性。依应成见的方法，是如法抉择下，无一丝堪忍。俗有者，就是因缘所成，显现无碍。此理虽然不难，行人要在心行上真的做到，却大大不容易。密教里很多修法，就是要引导行人与此中观正见相应。那就不是三言两语可说的了。
    而唯识方面，三性，依它起，遍计执，圆成实确实是基本。然而唯识内有很多家，诸家说法也有所不同。对这个三自性是否是“实有”的，有很多争论。麻子个人看法，这个有，与中观里用的“有”，意义根本不一样。有些佛友由此简单地判唯识是常见，有自性，麻子是不赞同的。而唯识之无，也不是说俗义诸法不显现，只是说此等显现之法，并无实质，如同幻相。所以，这地方，唯识中观虽然有无相对，其意趣却实在无二致。唯识之学，越展开越复杂，越说就越多，为什么呢？因为心相心行可以无限细分的，而语言总不能完全表述。故而在麻子看来，唯识学本意是给瑜伽行做教材用，而不是如后世人做学问用的。许多唯识学里的名相，如果不在禅修里体会大概永远也说不清。
    虽然方便表达都不同，唯识中观根本目的都一样，就是让学人经此逐步脱离二取见。真假有无，也都是一期方便引导。老兄如有兴趣专门讨论，唯识方面可以到慈氏学论坛上交流，中观应成见方面则可去朗忍等论坛切磋。
    麻子不敢自称中观或唯识，实际上，麻子也的确不是。老兄如果有更具体些的问题，坛上诸佛友想必很愿意与您进一步深入交流。
    继续侃几句……
    大千兄的意思，简单说就是声闻所修所断比较粗，不需要用到如阿赖耶识那么细微的东西。这个理由南传的人大概不会同意。但在唯识里，这样说可以。当然即使没必要说的东西，未必不可以说。
    麻子只在经里看到佛对此事说“我于凡愚不开演”，未见说“我于声闻不开演”。所以这个不说，只是并非必须，说不说应该都可以，不说阿赖耶应是当时历史因缘所成。
    中观也不说阿赖耶，但这个不说，不是不必要说此事，而是另有表达方法。中观体系与唯识不同，不用这个词完全可能，只要考究，唯识里要用阿赖耶所说明的事情，中观里能不能得到解释就行了。如果确实都解释了没问题，那不用这个词并无所谓。
    事实上中观并没少解释了什么，确实可以不用这词。
    这是中观不说阿赖耶的道理。此外中观不说阿赖耶恐怕还确实有防止初学人“执为我”的原因。
    麻子曾经在功能主义的几个相关帖子里讨论过使用名相的方便与不方便。但帖子不在手头。找找再说吧。
    问无性自己的意思到底是什么，似乎没人可代替他说呀。人能说的，只是自己对无性所说的理解吧？要麻子说，无性说三件事：一、为什么没对声闻说阿赖耶。二、为什么需要对大乘说阿赖耶。三、如何依之从凡夫走向佛。
    “尔时觉知无所取义，如是亦能知无能取，由此证得无分别智。”
    这段，是用语言对由二取到超越二取作了个表述。然而，由于语言本身是建立在二取上的，这表述在思维语言范围里就没法很清楚准确。如果让麻子用自己的话再表述一次，只会更糟，不会更清楚。
    在瑜伽／唯识／法相一系里，如果行人是依瑜伽行修到这个地方，那么他对上述那段话不会有什么疑惑。对这地方想表述的有了切身的实践与体会，对这段话里哪些地方是关键，哪些地方是语言的限制不得不用，都会很清楚。相反，如果学人是随法相学思维到这里，则一定没法超越这段话里表面上的自相矛盾，不能体会到这是说什么。
    这个地方，是思维的极限。

    编按：“瑜伽则真有俗无。以三性为本。中观乃真无俗有。寔二谛为先。”系唐代义净法师《略明般若末后一颂赞述》中的一颂。本文中的无性指印度瑜伽行派的无性菩萨,所提到的段落系无性菩萨造《摄大乘论释》(唐玄奘法师译)卷第一中的段落:

    释曰。由此深细境所摄故者。此显阿赖耶识亦是深细亦所知境。由深细故于诸声闻不为宣说。彼是粗浅所知境摄。所应化故深细境智。于彼无恩。由诸声闻不于一切境智处转者。此则显彼无有功能。悕愿处相。是故于彼虽离此说等者。谓于声闻虽离为说阿赖耶识。但由粗浅色等境界。苦集等性无常等行。正观察时。便能永断一切烦恼。彼为此义依世尊所。勤修梵行。言粗浅者。谓诸色法体相粗故。受等诸法所缘行相易可分别。行相粗故。与此相违如其所应阿赖耶识说名深细。如说我不说一法未达未遍知等者。此密意说。不断烦恼以别相声说总相处。非诸烦恼有各别断。或取共相无常等行故不为说。阿赖耶识亦无过失。若诸菩萨定于一切境智处转者。显菩萨有种姓势力。由与功能悕愿处相具相应故。一切智性为所期处异。此不能作他义利。所以者何。非一切智无有堪能随顺知他意乐。随眠界根胜劣有能无能。时分差别具作一切他之义利。如是等事菩萨所求。是故为说阿赖耶识。若离此智等者。若离阿赖耶识智不能永断。于义遍计彼不断故。无分别智则不得有执。有遍计所执义故。由此因缘不易证得一切智智。所以者何。能证一切所知共相。是分别智知遍计义自相分别。展转不同以无边故。决定无能具证一切。若知此唯阿赖耶识。能生习气转变力故。义有情我显现而转。尔时觉知无所取义。如是亦能知无能取。由此证得无分别智。次后得智如所串习通达法性。由一切法共相所显。真如一味知一切法。于一刹那亦易证得。一切境智非无边故。然复说言要经于三无数劫者。此显积习广大资粮方能证得广大殊胜。一切种相微妙果智。如是所说。妙智资粮不离能证法无我境。故说颂言
    非于一切所知境　　不断所执法分别
    而能证得一切智　　是故宣说法无我

    不善通达如是理教故有颂言

    由彼相续有堪能　　当知如火食一切
    如是应许一切智　　能作一切知一切

    是故于此阿赖耶识知不知者。易证难证一切智智。定依此宗作如是说。非知一切法无我者。名一切智彼虽一切智非一切种智


阿赖耶与有情

    阿赖耶与有情

    二麻子

    千，善，玄兄，把“什么有情”再聊一步吧……，大千说，有阿赖耶的是有情。玄兄说，有俺执的是有情。只要是“有”，就多少非有点俺执不可……，可以很细微，自己未必能体会到。
    麻子看来，这两个命题等价。都是几乎正确。只缺了说明“觉有情”的部分。
    其实这定义可以反推下再拓广。就从阿赖耶开始把。
    我们不管从哪来的，耶识要保持不散坏，就必须有新种子不停地进来。否则只出不进，一定会散了的。
    所以，有情是指能生产新种子的。生产新种子的必要条件是，能作意。所以，能作意的是有情。
    ──这个定义比俺执和阿赖耶定义广些。而且也挺符合直觉。当然，有些情况的作意非常细微，不是人人都能观察到的。
    麻子不知道唯识学里怎么讨论这个作意的。在麻子看来，这个是修行的很关键部分。凡夫非理作意，生污染种子，轮回果。圣人如理作意，就成清净种子解脱果。有趣的是，如理作意里有个特例是如理不作意，居然导致阿赖耶坏散──阿罗汉的不受后有！嘻嘻。有趣吧。

    “耶识是一种决定生命存在模式的基本结构（相宗的‘基因’？）”
    ──麻子个人态度是，对这些佛法力很根本的名相，不再去说它“是”什么。只依习惯说，种子集合“名”阿赖耶。

    “我认为，不作意并不导致耶识的‘坏’。当刹那契入真如时这种结构也未坏，何况不作意。”
    ──这个地方大千的解释不全是麻子本意。契入并不非要导致“坏”，更可以导致“转”。但不作意就有所不同。见下……

    “也许您的‘不作意’不是指‘刹那契入真如’，是指什么？是指‘任运’，由清净有为法自生自灭吗？愿闻其详！”
    ──麻子说的那个不作意，就是指南传法要里的如蜡烛灭，不受后有。则也不再有阿赖耶可谈，说名坏散。如理作意做深了，也一样契入真如。所以，如理作意（包括如理不作意）都能契入真如。其实大乘人用如理作意契入的更多，所谓因大悲故，深入实相而不自取证。至于立为什么名字的问题，麻子倒觉得不最要紧。意思搞对了就好。嘻嘻。

    “涅槃流不会‘坏’。”
    ──只怕多数南传学人不会接受“流”字。不受后有不能称流。对大乘的无住涅盘，勉强说流是可以的。但必须记得，说流是从凡夫角度说的。对圣者，涅盘谈不到三时，故也无流可说。而且，清净有为法的说法，不大全面。

    “还是由无数个契入真如的刹那组成？这也是验证涅槃流有没有缘起空隙的问题！”
    ──俗义显现之法总是刹那生灭的。

    “如果有，这种可让阿罗汉依之而出涅槃的空隙是什么？这个问题暂时未与南传人士交流过，怕引起他们的困扰。”
    ──这个大概有两类。一类就入南传说的不受后有。那就谈不到什么空隙。另一类是如大乘法说的回小向大的，这个恐怕不是我们现在的能力能说的。

    “耶识为什么会散坏，为什么要保持不散坏，为什么要保持不散坏就必须有新种子不停地进来，为什么说否则只出不进，一定会散了的。”
    ──为什么会坏？没有什么恒久不散坏的，这就是无常。阿赖耶识也同样。为什么要保持？不为什么，这就是无明执着。为什么有新种子不停进来？这是按照唯识的系统说的。请读唯识经论。为什么只出不进会散？其理自见。无源之水其能久乎？

    “阿赖耶识若坏散，那么所谓的转识成智岂不是空话？还是转识成智的意思就是阿赖耶识坏散？”
    ──转识成智本不是南传说法。依大乘，转识成智不是靠不作意完成的。“转”也可说为一种坏散，但跟你现在问的这个词意思不一样吧。

    “还有，阿赖耶识若坏散了，那么是否该阿赖耶识执藏之种子从此消失了？”
    ──这是你这帖子里最有意思的问题。麻子有些个人看法，未必合乎唯识主流。对这问题的深入讨论一定会涉及阿赖耶的共不共问题……你如果喜欢讨论这点，麻子愿意随喜旁观。嘻嘻。

    “还有，阿赖耶识可以坏散的话，那算不算因缘法？
    按照因缘法的理解，既然有坏散，就会有重新聚合，也就是说坏散的阿赖耶识有重新聚合的‘那一天’？”
    ──这段大概是S兄次贴里最“无记”的一段了。嘻嘻。什么是重新聚合？重新的意思是不是隐含还是原先那个“主体”？
    否则怎么能叫重新？如果是，你可大落外道见了。嘻嘻。这是一，其二，如果你说不谈原先那个主体，则你这里是在问阿赖耶是怎么起始的。嘻嘻。其实就是在问无明是怎么开始的。掉进坑里了吧……。嘻嘻。


关于某个唯识讨论的个人看法

    关于某个唯识讨论的个人看法

    二麻子

    虽然麻子不喜欢做总结，更不喜欢给别人做总结。
    下面是麻子个人看法，并尽量对此问题的讨论做了简化．希望麻子没过分误解双方，并希望这个简化没有过分扭曲了原讨论。
    慕藏兄对这问题的说法，简化了如下。
    一至七识都是依八识种子现起的。八识也有现分，必然也必须依某些种子才能现。这些种子必然不能属八识本身。如此，则须立九识。但九识依然如此，需要十识持种。这样的话，就成无穷尽了。所以，这地方必须有所截断。幕藏兄于此，选用“本有”种子一说，并将此“本有”作先天意会．如此，则唯识论就有常见。（希望如此简化没有将慕兄原意过分失真）
    大千兄的回答，比较限制在技术层面，更像技术性回答。未能直接回答到慕藏兄这个问题的关键或核心去．大概这是慕藏兄不大满意的地方了。嘻嘻。
    不究细节，单从形式逻辑讲话，到“截断”为止，幕藏兄所说并无不对处。但对此截断以后的推论，却不好。其实这样子的截断佛经里早有过，就是十二支因缘。于无明支，佛截断为无明无缘。但佛陀决不来说无明“先天”“本有”“法尔”。佛对无明只是说“如幻”。看看这个用词表述的不同，就知道我们又是落在凡夫思维限制里了。所以，在麻子看来，慕藏兄的问题，本质上与“无明之源”是等价的。
    任何一套逻辑体系都会有类似问题存在。唯识必须将这个地方给以截断。麻子对唯识不够熟悉，不知道这个地方唯识古德是怎么做的，也不知道新唯识派准备怎么做。但一定要跟佛对无明支的截断类似，才合佛理。
    然而就唯识本身来说，麻子觉得要截断并无原则性困难，故唯识决不会本身结构上就带常见。这点上是麻子不能赞同慕藏兄的。
    技术上困难比较大的，真还是慕兄的第一问，阿赖耶的别共问题。


种子、隐显、相似相续

    非文：
    和麻兄讨论一下种子的理解。
    您“学佛理时，中观与唯识能不能不打架？”文中说：
“明显可观察到的相续，起名“现行”，或按新唯识派的名称，叫“明流”；观察不到的相续，起名“种子”，或“暗流”。
    当观察不到的相续转成了能观察到的时候，就说“种子转现行”，或称“显”。每一时刻的现行，都有一部份其后（相）续是观察不到的，叫“现行生种子”，或称“隐”。嘻嘻，没什么不可以吧？”
    ——您这里“观察不到的相续”是一般情况下观察不到，还是绝对观察不到。您的理解是这样吗：世界实际上分为显世界和隐世界，显世界里是能观察到的现行，隐世界里是不能观察到的种子。当然，不管是显还是隐，都是功能的集团。
    但宿命通能直观地了解未来，不是推理。宿命通通的是现行还是种子？能知未来，未来必不是现行；但种子又是观察不到的。所以用显隐世界的模型似乎不太好解释宿命通。您的理解如何？

    二麻子：
    总算有时机回你了，非兄……，嘻嘻。
    佛法不接受“绝对”，绝对即非因缘所成法了。
    讲种子，隐显等名相的前提是“相似相续”。若破掉这相似，“现行”“种子”的存在与差别就都谈不到了。所谓观察得到，观察不到都是相对的。至于“显世界”“隐世界”那是非兄的引伸了。
    非兄，宿命通是通过去还是通未来？还是都通？
    佛云“未来法不定”，对未来的了解恐怕不是你隐含的那种“精确了解”吧。

    非文：
    麻兄似乎没有正面回答。宿命通是过去未来都通。并不违背“反绝对”的佛教精神，佛教是承认宿命通的。它和“相似相续”也不矛盾。您是否不承认宿命通现象。若是这样，自然不用往下说了。若承认有宿命通，就有“宿命通通的是现行还是种子”的问题。

    二麻子：
    宿命通……，麻子没宿命通，实在没法子说它到底是什么。但至少有几处我们可能要仔细考虑一下。
    一、“种子”一说，所说对象是什么人。而且麻子不信这名相是在所有场地对所有人都应说的。换句话说，种子只是个相对的表达。显隐也是对人说的。对佛大菩萨来说，没有什么显隐、种子现行问题。
    二、若对将来的“通”只是未尽细节的，则你我在一定程度上也会。如，推断出某些将发生的事。这在心行上是现行，没什么神秘处。差别只在能力大小而已。
    三、将来法不定，对将来的“通”不可能完全精确。否则是有宿命了。就连佛陀，在经上对人的授记，也是说个大略。
    所以，虽然麻子还没对非兄的问题思考到细节上去，直觉是非兄所引“宿命通”与“种子”的不自洽问题，实际包含有绝对的先设，即宿命通可对将来精确了知。麻子不同意这点，而不是不肯直接回答。嘻嘻。

    非文：
    您的第一点我同意，其实我的看法是：您所描述的显隐的现行种子的说法用来理解大部分精神修行现象都是可以的，就像牛顿力学，虽然有适用范围，但日常的大部分力学现象都可以解释。我的意思只是说，对于一个想进一步修行的人，只了解这一点是不够的。您的第二点，有一些疑问。您是认为宿命通是推理过程吧。六祖对怀让说：你足下出一马儿蹋杀天下人。五祖对六祖说：遇什么则藏，逢什么则止。这些具体的人名地名，恐怕不是推理能推出来的。您认为这是心行上的现行，又涉及到现行和种子的定义问题。因为您显然把现行分成了两种，一种是实际上马祖出世教化众生，另一种是六祖心里想的马祖出世教化众生。那么按照您对现行种子的描述，可以这样说吗：马祖的种子先在六祖的意识里现行了一下，然后过很多年后再在现实世界里现行。马祖的种子是六祖想出来的还是有其自身的发展规律。说到这里，可能各位观众会感到很混乱。这就是由于理论本身不完善造成的。
    您的第三点，将来的通不可能完全精确，我赞成。
    您下面的这句话不是我的意思，“直觉是非兄所引‘宿命通’与‘种子’的不自洽问题，实际包含有绝对的先设，即宿命通可对将来精确了知。”您发没发现，您描述的现行种子显隐说法，即使对过去的通也没法解释。过去的现行已经不存在，除了靠记忆外，按照那种说法，是没有“通”过去的可能的。尽管前面讲的六祖的了知可能也应该算精确了，但我并没有认为宿命通可对将来完全精确了知。实际上，未来是可以由自身努力得到一些改变的，对某一些人来说，改变还可以很大。这样修行才有可能，有必要。
    现行种子的显隐说法，理论上不是很完善，会造成思想上的一些问题，对于进一步修行可能会有障碍。

    二麻子：
    可以说，什么理论都有限制，不能说完善。
    但六祖，马祖的故事，权且不考虑考证，认为实有其事，也可如下解释。
    一般人观察不到的“种子”——隐的相续，有可能被特别人物，实证的高手，观察到。而六祖此观察及言论，确实也作用（影响）到了后来的马祖。所以，这段对六祖是明确的现行。并不奇怪。
    某些人的种子（不能观察到的相续），可能对另一些人是现行。这没什么特别的。
    把能所分别太清楚了，总有一天会碰的麻烦的。
    细分再细分，无有穷尽。理论永不能完备恐怕是通理呀……


“名”说的是执受等事，而不仅仅是“名字”

    常如：
    【唯名无色过及唯色无名过】
    分别缘起初胜法门经七页云：复言世尊！若唯名生，都无其色；斯有何过？世尊告曰：若一生中、唯有其名，不依色住；相续生起，不应道理。复言世尊！若唯色生，都无其名；斯有何过？世尊告曰：若唯有色，无名执受；即应散坏，不得增长。
    【《法相辞典》朱芾煌　编】

    二麻子：
    什么是“名”？这里说得很清楚呢。
    世尊告曰：若唯有色，无名执受；即应散坏，不得增长。
    佛经里“名”说的是执受等事，而不仅仅是“名字”。


七识不需要“知道”第八识，就能执持为我

    唯识新生：
    请问在第七识执着第八识时，第七识怎么知到有第八识的？

    大千：
    第六意识告诉它的，意识执着有我熏成我执种子，就生成了机制化的意根第七识。

    二麻子：
    嘻嘻，凡夫不能亲见八识。知道第八识是辗转听佛大菩萨等说的。七识不需要“知道”第八识，就能执持为我，好像婴儿不需要知道奶从那里来，就知道吃。

    xixi：
    嘻嘻，当初狮兄说学佛就是学婴儿的天真，我举的例子就是吃奶的例子说明欲是轮回的动力。

    二麻子：
    嘻嘻，中观不说八识，不是没道理的……，好好的东西，比如标月之指，被凡夫一顿分别计度手指长短，线条优美否……，也就糟蹋了。嘻嘻。

    wise：
    这样理解中观，似乎在说，中观才直指实际，唯识装饰豪华，没见过大世面就被豪华的路标迷惑，不知道找实际的目标了。
    八识虽假名安立，但不是没有来源和意义，若凡夫不是被业习熏染所种的种子幻现的诸法迷惑，就与诸佛无别。如今日林广，此心当下即是，此心具足无边智慧，可令此界现清净佛国本来面目，令一切众生共成佛道，可是因为林广仍是第七识执第八识为我，所以此心当下之理虽明，中观之义虽通，而起心则陷第八识种子大海所幻现的“自我国土”中，不能庄严国土。

    二麻子：
    麻子不过是接着原贴说话……，难道麻子每次说话还非得两边各说一句，您才觉得公平？“中观不说八识，不是没道理的。”“唯识说八识，也不是没道理的”这样您满意了吧？

    wise：
    如果林广善知识没有里面那段话，只标题那句话，不是很好么。

    二麻子：
    向你学习……，八识虽假名安立，但不是没有来源和意义，若凡夫不是被业习熏染所种的种子幻现的诸法迷惑，就与诸佛无别。如今日WISE，本心当下即是，本心具足无边智慧，可令此界现清净佛国本来面目，令一切众生共成佛道，可是因为WISE仍是第七识执第八识为我，不见本心，所以此心当下之理虽明，唯识之义虽通，而起心则陷第八识种子大海所幻现的“自我国土”中，不能庄严国土。

    唯识新生：
    七识执持为我，是执持哪个识为我？

    二麻子：
    按唯识说，是执八识……，不过鸟不需要知道空气，不需要知道空气动力学，照样飞。
    执持与认为不是一个意思……，七识执八为我，并不需要“认为”。认为身体为我的，是六识。婴儿不知道“我”，他的七识照样持八识。结果照样能知道，比如，“饿了”。

    唯识新生：
    如果“饿了”是七识执持八识，那菩萨“饿了”时是不是也可以理解为是七识执持八识。

    二麻子：
    哈哈。老兄……，凡夫不能见八识，欲说只能借比喻了。你若非要将比喻的当原来的，可就累了。


眼不自见，手能自摸

    古慈：
    记得有位大善知识说过，某种做法就是，用俱生我执破分别我执——结果呢，还守着哪个俱生我执不放……后学觉得我兄在敝帚自珍——不必理他。

    齐愍：
    所谓“第六识可以自为所缘”，中观就是用“那是个回忆”来解的，若住在中观谈，自语不便相违，若一定要就“同时”来掰，不用“回忆”解，那就可以用有部的时分缘起来说，即在有支上各建立五蕴，各看各的，互不相违。

    二麻子：
    识是一定可以认识自己的……，未必能全面认识，却一定能多少认识点。否则人根本就觉不到自己存在呢。眼不自见，作为论据其实没什么用，我们可以立即举出反例：手能自摸。嘿嘿，嘿嘿……

    齐愍：
    所以自摸正是时分缘起的例子，一刹那中十二支各带各的五蕴，析成六十支，当然就能看到部分了，如果带上时间段和回忆，活动的范围是非常大的了。

    常如：
    时分缘起是具体怎样。还有别的分吗。请给些参考。

    齐愍：
    这个分法还是比较多的，前者是约一刹那讲，引文如下:
    一、后来的小乘论书把十二因缘同轮回相配，众生由过去的业而受现世的果报，由现世的业而受未来的果报，就有说众生涉三世轮回的次第缘起。《俱舍论》把十二因缘分成四种：一、刹那缘起，于刹那间立十二支；二、连缚缘起，十二有支因果无间，连续而起；三、分位缘起，立三世两重的因果关系，从胎生学的角度来解释十二因缘；四、远续缘起，悬远相续无始，而立十二支。其中分位缘起说为有部所采用。（姚长寿）
    二、这一解说，毗婆沙师认为是可以这样说的，名为“刹那缘起”。但毗婆沙正宗，是“分位缘起”。尊者的“刹那缘起”，与世友Vasumitra“品类论”的“刹那”或“连缚缘起”，提婆设摩Devas／arman“识身论”的“远续缘起”，“发智论”的“分位缘起”，总称四种缘起　。（印顺法师）


见的表述方式和抉择

    见的表述方式和抉择

    二麻子

    不好意思，麻子不评论其对错，老实说麻子个人不接受“一切前后见此的众生每个阿赖耶识里种子都是如此配合好了的”这个表述方式。
    接受不接受是有条件的。俺接受不接受是看这个表述对俺方便不方便。换个条件，换个人，接受不接受会改变。俺的确没在乎是不是唯一正确推论方式得来的，俺在乎的是怎么能让人接受正确结论。在这个地方，麻子的确觉得“阿赖耶独立”“唯识无境”如果要“进行到底”的话，会对很多人大大地不方便。
    兄如果不相信“阿赖耶独立”这个不方便，麻子愿意陪兄讨论下去。只是有个先决条件，希望兄能用自己的话表述出来，别光是抄经论。麻子实在不愿意与贴着菩萨名号的风车战斗——这不是专门针对兄而说，实在是麻子经历过太多类似的事：先大段抄经论，然后，你不反驳就说你输了，你反驳就说这是某菩萨说的，你找菩萨争吧。嘻嘻。尽管抄的人未必就真知道菩萨说的是什么。这里还得加个注，麻子绝对不反对学习抄写经论，俺反对的是不知道菩萨说的是什么就拿来当武器。所以建议用自己的话说，以免此弊端。
    例如，有一定理，有三种证明方法。俺麻子只看明白一种，从而也达到了正确结论。其他两种俺没看通。即使是达到了正确定理以后，俺还是没看通那两种证明方法。所以，俺接受看懂的证法，让俺能看懂就是对俺方便。俺不接受俺没看懂的，因为不方便。注意，麻子话当初就说得非常留有余地，俺没说那两种证明方法对或者不对，只说了俺不接受。怎么样，你上面那些咄咄逼人的问题还成立吗？兄这些问题是不是以己度人了呢？
    单就这个逻辑本身来说，给你个例子，您再回头拿你这里的问题比比，就应该能知道自己错在哪里。
    《中论》里说：
诸法不自生
    亦不从他生
    不共不无因
    是故知无生
    先要看龙树菩萨的无生是在说什么。如果认为讨论的是诸法本身的生不生，则麻子也把这个逻辑放到不接受一类里去。但要注意的是，这里已经先在“诸法本身”上执实有了。
    如果看成是在讨论诸法之“生”这一法无自性，则龙树的逻辑明确得很呢。“生”既然无自性，则说“非生”“无生”也就无碍，如同对俗有执实者说非有，无有。但俗义的生／有是明摆着显现的。
    麻子没说“无有自性生起”，麻子说的是，“生”无有自性。那段地方明确地，而且依照中观论证方法是一贯地，论证了生无自性。如果同意这点，下面就简单些了。
    生无自性，也就是生不可得，再换句话说，就是事物的现起是相续变化的，期间没有个确定的“生”可以找到。所以事物是虽显现而无“生”的。
    实际上，那段逻辑就是在说“生”找不到，但那段逻辑没说显现也不变化了，没有了。所以，俗义的生在名言共许下还是可以用的。如果麻子来说会说成：破四种生不是破“生”，而是破生的“自性”。
    嘻嘻，若干年前麻子这地方看法跟某兄现在完全一样。后来觉得上述表达也许会再稍稍好一点。但同时也发现这个表述非常平淡无奇。嘻嘻。
    嘻嘻，更讨厌的是共生，仅仅用不自生不他生就推论不共生，很多人能接受，但实际上不严格，麻子当初就不能接受，也许是因为麻子受数学逻辑影响，比较挑剔吧。花点时间仔细想后发现如果插入个引理就明确了。这个引理比较明显，几乎不需要真的论证：“因缘法内不存在独立有自性的子集”。但想清楚这个引理也让麻子对因缘法的了解有所深入。
    龙树菩萨论里的有些推理方法，麻子也不认为是唯一正确推理方式。但菩萨们的结论是绝对没错的。所以麻子才会觉得，“不是不能说，只是很难令（现代）人信”。表述毕竟是表述，如标月指。无论怎么标月，指毕竟还不是月。对于佛法真如，麻子不认为存在一种“无条件绝对准确的表述方式”。否则指就可以代月了。
    这次俺宁可绕远点——远到如：“不可将革命进行到底”。为什么？到底的革命只能是无条件完美无缺的，这是自性见了，根本不可能做到。为这目标进行的“继续革命”“不断革命”实践、证明会在不知不觉间远远偏离真理。将革命两字换成别的词，比如“融通空有”，大概也是同样。再换成“配合好的”，只怕也是同样。那么这个“不可到底”论是不是可以到底的？也不是。比如，应成见里的抉择就是要进行到底，彻显无自性。那么什么样的要用“不可论”？大致上，肯定性的命题都是不可到底的。否定性的要看情况。这是俺对表述方式的态度。


未现行的种子在其相续中同样与外缘相互作用

    大千：
    时间上种子自类相生相续是在变迁，但种子本身的内涵属性没有变化。

    二麻子：
    等的就是这句话的意思……，“时间上种子自类相生相续是在变迁，但种子本身的内涵属性没有变化。”
    这个地方相当有问题，如果把这句话绝对化了的话……
    实际上，未现行的种子在其相续中同样与外缘相互作用，生灭并变化。只是不如现行时明显。麻子能举出在特定条件下，种子未经本人（种子主人）现行，却根本改变了属性的的例子！所以，韩老先生讲明流暗流，讲只有显隐，麻子是很赞成的。嘻嘻，只是显隐差别。就连显隐之别，也还是相对的。
    所以，上述说法可以对多数情况成立，却不能绝对成立。
    如果绝对成立，则潜伏的种子就居然是“自类相续”，而不是因缘相续的无常不定了。
    从更广的角度来看，我们很多问题就出在我们这些机械强硬绝对的分类上。然而实际的世界是从来没有个能用来分类的绝对界限的。一强分到底，就会出些不上不下的困难，麻烦得要命。嘻嘻。“种子”一事，也是如此。

    常青：
    比如某甲N世前相似相续的前生和某乙N世前的前身互相打杀，结下恶性种子。某甲虽潜藏了这个恶性种子，但是后来经过很多世的归依正法的修行，N世后，某甲和某乙因缘相遇（在此之前一直没有：即种子未显），但是某甲此时却修道有成，以大智慧力和慈悲忍辱力反而借此因缘度了某乙……，不就是很好的例子吗？

    大千：
    打杀业的恶性种子根本改变了属性，生起了大智慧力和慈悲忍辱力的现行？

    二麻子：
    常兄说的是甲的修行，在某种程度上改变了乙的种子……

    常青：
    那麻老举个例子嘛。

    二麻子：
    我要举的例子几乎就是你这个例子，若我来说，可能会说的更完整一点点……

    大千：
    甲的修行通过什么途径来改变乙的种子？

    二麻子：
    如果换个角度去想，就连机制也容易想到……，如果只是将种子看做是从个人特定角度看，一时不能观察到的，相续中的因缘法，则一切都容易解释。这个例子里具体怎么改变的机制，麻子不知道……，因缘法难测吧？但结果是明显改变了。麻子能另举个可以看到改变过程的例子。嘻嘻。

    善惠：
    换一个角度看问一下，当甲的修行通过什么途径来改变乙的种子时，乙是通过什么机制来作配合工作的？

    二麻子：
    若只是有所改变的话，可以完全不需要配合呢……。嘻嘻。

    善惠：
    如果不单是只要“有所改变”，嘻嘻？

    二麻子：
    麻子原来想用的例子，与常青兄举的几乎一样，如下。
    先定义善恶。世间恶为给自他带来苦受的行为。
    出世间恶为有碍自他解脱的行为。简单一点松一点，我们定义善为非恶。
    “比如某甲N世前相似相续的前生和某乙N世前的前身互相打杀，结下恶性种子。”此时，双方所结下的种子均为恶，无论世出世间。
    经长时间修行后，甲修到佛位。佛位有很多功德，其中一种是，佛已经将一切过去相续中积累的因缘，转为出世间善缘。
    甲修行到成佛，未与乙相逢过。（注，这是完全可能的，读过诸法无行经的可以在里面看到一个类似例子，文殊菩萨未成就前曾下地狱，此前与某菩萨结缘。到文殊菩萨成七佛之师后很久，才重逢那位菩萨）。
    与我们讨论有关的结果是，乙与甲相关的种子，已经转为出世间善的了：有利乙趋向解脱。
    例子：“看得见的种子相续”故事：
某日麻子在傻兄家作客。傻兄养了一只狗狗。某早上，傻兄急事出门，但狗狗缠住要玩。傻兄心急，踢它一脚，就出门办事去了（1）。
    狗狗气愤，乃叼来傻兄拖鞋猛啃，啃坏。仍然不解气，就跑到傻兄必经之处放下一堆，这个这个，臭臭。（2）
    两小时后傻兄回来，一脚正中，于是大叫……（3）
    这（2）过程对傻兄而言，是潜藏八识里的，傻兄自己绝对看不到，待到踏中目标，正是“种子生遇缘现行”了。嘻嘻。
    这种子是踢一脚时留下的。其实，这段傻兄看不见的过程里，这些相关的八识种子的“自类相续”也不过如此而已，并没什么太神秘的。看不到也是相对的。自己看不到，不等于别人也看不到。说来不过是一段自己没法看到的因缘法相似相续。
    当然，八识种子的一般情况比这个例子广泛复杂，但本质不应该有什么大不同。

    大千：
    这也是没办法的事，因为我们要见的是真实，所以就只能照着真实去说。只是因为我们起惑造业，才会有业种子生起我们的正报（根身）和依报（器世间），如果我们不造业，哪里会有宇宙呢？所以应该是并没有一个客观存在的宇宙让我们拷贝，宇宙实在是我们自己心生的妄想造出来的。

    二麻子：
    有点说过了。这样说话，连种子也是妄想。不造业哪里谈得到种子呢。每人一份宇宙种子也谈不到了。
    嘻嘻，两个案子分开来说吧，本来就是两个，狗狗案只是说明，种子暗流的看不见不是绝对的。并没涉及转性等问题。
    对第一个案子，麻子肯定持不同看法。任意一个众生，只要他与佛有缘，这缘就一定是有利他自己解脱的。文殊愿王也说明了这点。
    乙当初造的恶缘（种子）一定会给他带来苦受果，这个在此例里没转。但，就解脱来讲，是转成有利了。假若乙与佛只有此缘，他会比跟佛无缘的要好很多。连歌利王都因类似的缘得度。
    这正表现出佛的伟大，佛度生功德的不可思议。

    傻丫：
    既然用唯识解释问题不如因缘法来得简洁明快，照您这么说唯识理论好像没多大用了。那么，可否请您详细谈谈当初唯识是怎样产生？并是用来干什么的呢？

    二麻子：
    问题问得有些问题，这说没多大用了可是以偏盖全的推论方法了。中观与唯识各有其方便，各有其当用处。如鸟之两翼。各人看法可能有所不同。在麻子看来，唯识最大的方便处在于指导学人如何在禅定时用无我空性做方向，进而契入空性。

    傻丫：
    大家都知道唯识学以其体系完备博大、思辩严谨精细称著。您的观点不曾有闻。可否详细谈谈：“唯识最大的方便处在于指导学人如何在禅定时用无我空性做方向，进而契入空性。”的具体含义？也给学唯识的诸兄一个参考。谢谢。

    二麻子：
    佛法哪一支不是以博大精深闻名？麻子胡说点别人不大说的论调也不是一回了。但这次不是。唯识在印度时，原是瑜伽行派的教程，这不是什么奇闻。

    傻丫：
    依您的观点看唯识是指导人修禅定的“参考书”，如此说来不修禅定只把它当作佛法理论，并藉以生起正见的一种方法去学习研究，此并非是唯识当初的本意？是吗？

    二麻子：
    麻子看来至少不是全面的本意。当然麻子也是个人看法，不能当定论的。弥勒菩萨讲的慈氏学有个主题，叫“唯心识定”，您就顾名思义一下吧？唯识里讲寻伺等禅定中，心相法相等讲得仔细着呢——明摆着是“体（心）操动作要领说明书”。当然傻兄初学未久，没听说过是可能的。
    中观唯识都是圣教，但都不是“全能武器”。若是，就不需要别的了。都是对真理真如的引导与表述，也都还不是真如本身（当然也没离），如同标月之指。这指就各有所用，有方便的地方，就有不方便的地方，指望一项理论体系就包打天下其实挺给自己找麻烦的。嘻嘻。


有识间的同步性协调性这回事吗？

    静风：
    佛陀端坐水池边，旁有一人，因渴而饮他所见之池中之水；复有一饿鬼，因渴而饮他所见之池中之血，佛以神通力同时得见，复有一天人，来饮他所见之池中之甘露，佛陀以神通力亦同时见。
    请教大千兄，佛陀此时若同时见三者饮池中之物，应见所饮池中之物是水，是血，还是甘露？

    大千:
佛陀只见有三颗心，这个“颗”有多大呢？就有三界那么大，所以佛说“三界唯心”。这颗心也就是一个意识，存在两种状态：绝大部分处于潜伏的种子状态（但佛能看见无始以来积累的所有因缘种子），很小一部分因缘成熟的种子正在生起现行，生起现行意识活动的这部分在佛看来就是凡夫的一个梦境。有一颗心正梦到自己是个人，因渴而饮他所见之池中之水；复有一颗心梦到自己是个饿鬼，因渴而饮他所见之池中之血；复有一颗心梦到自己是个天人，来饮他所见之池中之甘露。佛陀看着这仨正在做梦的心意识想：如母众生啊，赶快学佛觉醒吧，醒来之后就明白了：三界所有唯是一心，万法都不过是个意识在那儿妄想，哪里有什么人鬼、水血甘露呀。

    老兹:
鬼见到的脓血，是不是人的那个脓血？

    二麻子
嘻嘻，老兹，你的问题一贯是把好几步混到一起。“鬼见到的脓血，是不是人的那个脓血？”
    你这问的是哪个点？如果指的是外境，那肯定不是，因为那些东西人看见是水。
    如果说的是主观感受，那么根本不能精确比较，只能说大致相似。就是张三李四看见同一堆脓血时，其感受也没法完全相等。比如，张三可能会晕了，李四可以没事。所以，佛讲那话的意思，只是说对被人看成是水的因缘法，鬼看见时候的感觉与人看见脓血时候的感觉相似！如此而已。
    哪有你们折腾得那么复杂。当然，凡是想法，没有绝对的对错，我们只是错得多点少点的差别。嘻嘻。

    savelife:
不理解为什么风兄问这个问题，不理解为什么风兄问大千兄这个问题。我记得大千兄在慈氏学论坛那里对这个问题有过多次阐述，观点是“唯识无境”。风兄此问的意思，似乎是先承认了识外有一个境界的存在，而此境界依众生的习气而产生不同的认识。若我理解有错误，请见谅。

    二麻子:
问得准确。嘻嘻，就是。我看静风兄也是这个意思，就是有点要栽赃的意思……嘻嘻。哈哈。但S兄也得仔细。虽说是唯识无境，但各识间的同步性协调性是唯识学需要仔细解释的问题。
    具体到这里，不论天，人，鬼到了这里都现行出看到堆东西的感觉，既然无境，那么天人鬼怎么会这样同步呢？这种协调性怎么来的？

    大千:
试着解释解释。唯识无境，但识外有识。相对于一有情识来说，其他有情识也可以说是客观外境，所有其他有情识对于他来说就是一个客观世界了。不过这样说，很容易与唯识中特指凡夫颠倒妄想所执着的人我法我的那个根本不存在的“外境”相混淆，所以一般不这样表达，只说识外有识要准确一些。
    各识起惑造业，皆是自作自受，因为自识起心动念留下的记忆（种子），只自己有，全部积累下来的种子就起个名儿叫阿赖耶识，自己阿赖耶识中因缘成熟的种子生起的现行，自然也与他识不同，因为各人经验不同嘛。但各识之间却也有很多相同的现行，比如人见都是水，鬼见都是血，自然就有个问题，各识间的同步性协调性是哪里来的？根源还是各识之间大量的协调活动造成的，大量到什么程度呢？从一个小孩子出生，他就开始学习与其他有情的协调（实际胎教也是），生他的那个人必须叫做妈妈，左教右教，日日教月月教，叫得不像不行，叫别人去了还得纠正。这是黄，那是红，这是A，那是B，也是要反复学习，必须得与别人一致了才罢休，幼儿园在协调，小中大学研究生都是在协调，工作了还得协调，上街玩儿，进厕所，吃喝拉撒睡不与别人协调就没法生活，所有协调都留下了记忆 ，也就是熏成了相似或相同的种子。协调必须养成习惯，习惯得成了自然，所有时间地点看到黄色的反应都是认为黄色，看石头都认得是石头，每时每刻全方位的，这些重复都同时熏习成了大量的同步种子，加强着各识之间的协调和同步的程度，这些种子生起的现行自然也就相当协调和同步了。
    实际上，刚生下来的小孩子，本身就是一个无始以来大量学习协调的产物，人道都是一个鼻子两只眼，个子也都差不多……。这是此生人道业报成熟的这些有情，前前世中相互协调造了许多相同的业（共业）的自然果报，共业是各识所造业行相似相同，而不是我造业熏成了你的种子，或者我们俩儿造业熏成了属于共同公有的种子，只是我们俩儿造了相似相同的业，果报自然也就相似相同而已。
    麻叔所说阿赖耶不可能完全独立互不相干，以至最终必须承认世界是无二的、分别即错等都是与前面这些说法不相矛盾的。说法都是为针对具体问题解决疑惑的，各个角度各个层次的说法各有其用，只要搞清了它要解决的问题，它的作用也就到此为止了。

    二麻子:
在谈最后那段共业不共种子前，千兄是不是能说明一下……识与识之间怎么能相互作用?
    对任一凡夫来说，唯识无境，这点麻子绝对支持你。嘻嘻，实际上麻子觉得甚至可以给出更清晰通俗的解释。但是，既然无境，识与他人之识怎么能相互作用？除非你确认识与识之间可以直接作用。否则就协调不出共业来。
    若识与识可以相互作用，则现行就不仅与自种子相关，还要与别人的种子相关呢。这恐怕也有些麻烦吧。不知唯识学对这些地方怎么解释的？

    孤山:
哈哈，他心通。转识成智。知性无遮蔽，自他不二，遍一切处。

    二麻子:
嘻嘻，那可是圣人的事，凡夫怎么协调的？凡夫们都协调得很好，这个都看得到呀。只问怎么协调的，不问说作意去协调。

    孤山:
哈哈，凡夫日用而不知。

    二麻子:
嘻嘻。那么，老兄你是知不知？

    孤山:
哈哈，有这样问的吗？此问非正问，不答。

    二麻子:
上贴是特别多给你一次机会。嘿嘿，麻子原贴的问题是教理的讨论，特别是问大千兄的。你若能依教理回答自然是好。如果不能，要用机锋式的回答，也由你，只要你能像模像样。可惜你接下来就不像了。上贴麻子再让你说一次，结果更不像。
    这个对答从机锋角度看颇似赵州和尚的一个公案，你自己答不出来，去公案里看看赵州和尚怎么答的！

    nkdj：
    对备份的疑问，若是备份，则【因为这里众生平等，若A备份B，则B也需备份A】推出，凡是能有条众生链和AB挂钩的众生，其备份也都在其中，大概已经是一切众生了，由平等性或互相包含性得知，这些众生的备份必然都相同，其中必然有和观世音菩萨结缘的，所以就和观世音菩萨的一模一样，所以是干净的备份，否则没法成佛了吧。既然一样，可以不去谈【A里有B，所以B要有两个B……如此下去无尽，BA内各需要有无穷自己与对方的备份……相当无法令人接受。嘻嘻】。但是谈起来也未必完全站不住脚，无穷求和可以收敛，如1＋1／2＋1／4＋1／8＋……＝2，若说如1＋1＋1＋……一般发散似乎也没什么太大关系，因为众生是无量无边的，因此总会遇到发散的问题，发散一次是发散，二次也是，发散下去也不是问题，只要承认心足够大，蕴藏得了各种无穷大。
    若是大海水，则因为互相结缘的众生是无量的，因此仅仅一二种盐是不够的，同样无量多种才恰当，于是也出现了无穷大。
    另外的疑问是【彼此不相妨碍】似乎没有明确说明相互作用，怎么体现观世音菩萨寻声救苦的功德呢？

    二麻子：
    请注意，即如不等于即是。即如就是说比喻。所谓比喻一定是有所像，有所不像。引喻过当，当了即是就没意思了。为什么用比喻？因为原题没法直接说明白。
    如果能即是的话，何必比喻。


如何理解“客观物质世界”？

    （编按：“知觉与观察”这一章节，在网海莲舟和慈氏学论坛作为讨论的主题，历时数年，参与的网友众多，主要以大千居士和奉心居士在网海莲舟（从第五十八批旧贴起）和大千居士和zs居士在慈氏学论坛的约五到六批的旧贴为主线。在《莲舟集》的编辑过程中，选择了大千居士和奉心居士在网海莲舟的贴文中代表双方主要观点的部分，以供读者大致了解其中的认知差异，并同时请作者作了一定的修订。有些长篇讨论及大千居士题为“凡圣所见世界究竟有何不同（凡夫的世界与圣者的世界）”长篇回复，《莲舟集》第一辑中未收入，谨此存目和说明。）

    大千：
    眼识的认识对象──颜色只是一种主观映象或感觉，并非客观存在。

    zf：
    这是大家容易接受的。当在下还是个中学生时，一次检查色盲，一位同学就是看不出卡片上的图形。那次经历使我了知视觉的主观性。

    大千：
    所以并不存在眼识所见的客观外境。

    zf：
    这个推论只是两个可能结果中的一个。
    另一个推论是，存在眼识所见的客观外境。
    而且仅凭颜色只是一种主观映象或感觉这一点，并不能断定上述两个推论的是与非。

    大千：
    由眼识的认识对象并非客观存在，应该推不出：存在眼识所见的客观外境。
    但可以证明；人类据以建立客观物质世界的原材料全部都只不过是一些主观感觉而已，并没有任何客观存在的证据，所以所谓客观存在的物质世界实际只不过是人们的一个妄想罢了。

    zf：
    某些人据以建立“客观物质世界根本不存在”这一推论的原材料同样全部都只不过是一些主观感觉而已，所以所谓“物质世界不客观存在”同样只不过是人们的一个妄想罢了！

    大千：
    承认是主观感觉，就等于承认不是客观存在。
    或者我这样说：所以并不存在眼识所见的客观外色。

    zf：
    “不存在眼识所见的客观外色”并不能作为否定外境存在的证据。

    大千：
    除了眼所见色、耳所闻声和鼻舌身所触觉外，还有什么能作为外境存在证据的吗？
    另外，我并非在建立“客观物质世界根本不存在”的立论，而是在证明“客观存在一个物质世界”的结论是不能成立的。

    zf：
    在下亦不是建立“客观物质世界存在”的推论，而只是说明“客观物质世界根本不存在”的论断是不能成立的。

    大千：
    眼识所见就只有色，现在证明此色不是客观外色，就等于说眼识没有见到客观外境，这就破了世人建立“存在一个客观物质世界”结论的依据。

    zf：
    “外境客观存在”与“外境可以被客观认识”是两回事。
    老兄的上述论述只能破“外境可以被客观认识”这一论断的依据，但并不能破“外境客观存在”的依据。
    如果有人建立“客观的外境存在但无法真正认识”的假说，该假说可以认为，此客观外境虽然存在，但人们只能通过眼等接触感知，因而感知的印象是主观的。
    以此假说为基础而建立的体系，同样可以在其体系内部无矛盾地解释色的主观性。
    要证实这样的“理论”困难，但要证伪它，同样困难。
    请大千兄反思，您在其他的讨论中，是否将色的主观性作为否定外境存在的证据？
    只要基于认识的主观性，无法唯一得出“客观物质世界根本不存在”的结论，则世人“客观物质世界存在”的立论您也破不了。

    古慈：
    后学认为“唯识无境”推广成宇宙论──而，不是限定在指导佛法实践范围内，有其不稳妥处。因为觉得您和大千兄的讨论中，大千兄有一点一直很坚决，按照他的意思，圣者和凡夫间根本不存在交集──这一点是后学觉得问题所在，也就是圣者与凡夫之间究竟有没有那么一丁点“绝对的共业”──如果没有，则众生皆可成佛似乎要打上问号了……
    感谢大千兄和赵叔，对于如来藏理论的优越性体会更坚定了──哈哈～

    zf：
    古兄，在《华严经》中，菩萨欲了知的世界是：
妙世界即是粗世界，粗世界即是妙世界；
    仰世界即是覆世界，覆世界即是仰世界；
    小世界即是大世界，大世界即是小世界；
    广世界即是狭世界，狭世界即是广世界；
    一世界即是不可说世界，不可说世界即是一世界；不可说世界入一世界，一世界入不可说世界；
    秽世界即是净世界，净世界即是秽世界；
    ……
    对于我们凡夫来说，
    妙世界即是妙世界，粗世界即是粗世界；
    仰世界即是仰世界，覆世界即是覆世界；
    小世界即是小世界，大世界即是大世界；
    广世界即是广世界，狭世界即是狭世界；
    一世界即是一世界，不可说世界即是不可说世界；不可说世界无法入一世界，一世界无法入不可说世界；
    秽世界即是秽世界，净世界即是净世界；
    ……
    比较凡夫和如来所见的世界，妙世界、粗世界、仰世界、覆世界、小世界、大世界、广世界、狭世界、一世界、不可说世界、秽世界、净世界等等正是圣者和凡夫所见的“交集”。同如来所见相比，凡夫之所见的确是歪曲和极端有限的，但并不是一点都沾不上边。
    我们的讨论若能增加老兄对如来藏的信心，则在下甚感欣慰。这正是在下明知“争论”不会有结果但还要争的原因。

    大千：
    无法立之处，不见得就无法破。就如梦里找不到真，但有可能知道梦是假的。
    “外境可以被客观认识”也可表述为“外境可以被如实认识”（当然前提一直是在凡夫范围内），只是由于我们凡夫的认识方法不正确，所以认识到的是幻象、假象而非真相、实相而已。

    zf：
    凡夫所认识的都非真相、实相，这一点在下没有疑义。
    但以此为基础推断色法（物质世界）根本没有，并不充分。

    大千：
    师兄称“客观的外境存在但无法真正认识”是假说是很准确的，假说仅是一种推测，并非是成立的结论，自己就未立为真，所以也无从证伪。
    您对外境的理解与唯识所说外境含义不同。唯识所说的外境，专指凡夫认为客观存在的物质世界和与之相对的精神世界，也就是凡夫所知的一切法，这些事物实际上都是不存在的，只是凡夫感觉和认为它们存在而已。唯识所说的外境，不是指圣者所证的实际存在的有情识，也就是唯识的“识”，这是见到世界真实情况的圣者见到的世上唯一的实际存在。
    相对于某一位有情识来说，如果把自己称为主观，其他有情识也相对可以称为客观，如果把自身称为内识，其他有情识也就可以称为被他所认识的外境，唯识并不否定这种“外境”，但为了与前面所说唯识要破的凡夫所执的外境不混淆一气，唯识就不把他识叫做外境，而叫做疏所缘缘。您所说的外境就类似后面这个意思，如果是这种“外境”，唯识是不破的。

    zf：
    我所说的外境中还包括色法（物质）。
    我不反对破外境，但认为破的方法应讲究。如果佛弟子使用的方法被世人中有科学、逻辑和哲学素养者挑出毛病，反而会动摇某些人对佛法的信心。

    大千：
    ……我们也只是因为从各方面考察，相信佛陀是实语者，所以相信他是依据自己实证而说万法唯识的。

    zf：
    同意。在以某种“理论”解释佛法时，解释者心里应该清楚“解释”的局限性。“信为道元功德母”，我们常常忘记作为自己思想最重要基石的实际上是信仰。

    大千：
    “客观物质世界根本不存在”不是立论，而是破，这里的前提是有人说“客观存在一个物质世界”，唯识无境的理论就是来破这个立论的，唯识的立论是唯识，无境是破世人的立论。对唯识理论来说，它根本不承认客观物质世界的存在，所以也不需要再对自己说“客观物质世界根本不存在”。

    zf：
    “唯识理论根本不承认客观物质世界的存在”，这只是事情的一个方面；
    您能否以自己的体系破除别人的体系，这是另一个问题。
    多种体系并存的事实说明，破除别人的体系比自己另立一个体系困难得多。

    大千：
    您说只要基于认识的主观性，则世人“客观物质世界存在”的立论您也破不了，我说破是可以破的。但实际上这个立论根本就不存在，谁证明过“客观物质世界存在”？这是说认真的科学意义上的证明。从古代哲学家直到现代的科学家，倒确实是想证明它，因为这是所谓真理和科学的命根子。要是连这个都证明不了，好不容易积累起来的人类知识的结晶──整个科学体系，都就成了没有客观基础的主观戏论，可有谁证明了？

    zf：
    没有证明“客观物质世界存在”，在逻辑上并不意味着“客观物质世界不存在”。
    老兄，说“整个科学体系都就成了没有客观基础的主观戏论”这种话时还是慎重点好。以相对论为基础，人们发现了原子能；以电子学为基础，我们现在可以通过网络交流佛法。如梦如幻与龟毛兔角是有本质区别的。
    大千兄，小弟建议我俩关于这个话题的讨论暂告一个段落。学唯识者和学中观者通过讨论只要能加深对各自所学的理解，讨论的目的就达到了。


五蕴与遍计所执性

    zf：
    大千兄，依兄所见，“辐射能量”、“声波”、“挥发性物质”、“可溶性物质”等法，应属于五蕴中的哪一种？

    大千：
    属于色法。对色法的理解可分出三个层次的说法。
    一、最普遍的理解，是世间共许的物质。
    二、实际上佛教所说的色法是指颜色。因为佛教认为色眼根所取之境。对于声、香等而言，色乃专指眼根所识别之对象。“凡色境有三，即显色、形色与表色。‘显色’，即一般所说的颜色，如青色、黄色等。‘形色’，系指物体之形状，如长短等。‘表色’，系指有情之动作，如取舍、屈伸、行住、坐卧。”（《中华佛教百科全书》）
    其中显色就是青黄赤白等颜色。形色，指长方形、圆形、长短、高低等人们从所见颜色交界对比中抽象出来的一些抽象图形概念，并不是一种实际存在。表色，指能被人理解的一些动作所表示的语言意义，也不是一种实际存在。实际上人所看到的就只有显色一种色，所以说佛教所说的色法，实际是指眼睛感受到的颜色。
    三、唯识的本义是否定色法的存在，所以在唯识中讲到最后，是要说明颜色只是一种主观感觉，只是意识中的一种主观映象，并非离识的实际存在。即：色法是根本不存在的遍计所执性。
    玄奘法师在十八国无遮大会上所立“真唯识量”（真故极成色，定不离于眼识）就是这个意思。

    zf：
    大千兄，任何以语言为载体的讨论，若能对双方都有益，其前提条件应是对用词含义的共许。希望大千兄不要嫌在下罗嗦，我们慢慢将一些名词的含义理清楚。
    您说：
“一、最普遍的理解，是世间共许的物质。
    二、实际上佛教所说的色法是指颜色……
    三、唯识的本义是否定色法的存在，所以在唯识中讲到最后，是要说明颜色只是一种主观感觉，只是意识中的一种主观映象，并非离识的实际存在。即：色法是根本不存在的遍计所执性。”
    ──请问：当您说“色法是根本不存在的遍计所执性”时，这里的“色法”是特指“颜色”呢还是包括“世间共许的物质”？

    大千：
    都包括。与师兄讨论历来的感觉是最简捷痛快的了。

    zf：
    多谢夸奖！那么，兄曾说过，光线、声波、挥发性物质等这些共许的物质都是现行识。那么，现行识也是根本不存在的遍计所执性吗？

    大千：
    简单讲，识之体为（本质）相分，识之用为见分，见分所见的影像相分是“如是显现不如是有”的遍计所执性。若讲彻底一些就又要分层次说了。
    从佛说三界唯心、万法唯识的境界开始，这是最反映唯识根本义的，到弥勒菩萨开示的六论，以及无著、世亲及其弟子们的阐释，基本上都是对唯识本义的理解和细化。在唯识理论的基本框架树立起来之后，在弘扬过程中，有学习者的提问，有与小乘、外道的辩论，所提问题的共许平台离唯识境界越来越远，逼迫唯识理论必须建立与各个层次、各种角度理论的接引方便，后来的这些理论就被称为唯识新义。在唯识新义中，先与它宗共许百法，以此为出发点讲起，这时的说法就是，万法唯识，所以这百法都是识或识变的，色法也是识变的，不离识。而再深入一个层次时，就要否定色法的存在了。再深入一个层次时，就要否定心法的存在了。再深入一个层次时，就要否定佛法的存在了，这就是渡过河时船也要舍弃了。也就是《心经》所说“无苦集灭道。无智亦无得。以无所得故”而证涅槃。也正如《解深密经》中说，从五蕴到三十七道品，全都是遍计所执性：“尔时胜义生菩萨复白佛言。世尊。诸佛如来密意语言甚奇希有。乃至微妙最微妙。甚深最甚深。难通达最难通达。如是我今领解世尊所说义者。若于分别所行遍计所执相。所依行相中假名安立以为色蕴。或自性相或差别相。假名安立为色蕴生为色蕴灭。及为色蕴永断遍知。或自性相或差别相。是名遍计所执相。世尊依此施设诸法相无自性性。……如于色蕴。如是于余蕴皆应广说。如于诸蕴如是于十二处。一一处中皆应广说。于十二有支一一支中皆应广说。于四种食一一食中皆应广说。于六界十八界。一一界中皆应广说。
    如是我今领解世尊所说义者。若于分别所行遍计所执相所依行相中。假名安立以为苦谛。苦谛遍知或自性相或差别相。是名遍计所执相。……如于苦谛如是于余谛皆应广说。如于圣谛如是于诸念住正断神足根力觉支道支中。一一皆应广说。如是我今领解世尊所说义者。若于分别所行遍计所执相所依行相中。假名安立以为正定及为正定能治所治。若正修未生令生生已坚住不忘倍修增长广大。或自性相或差别相。是名遍计所执相。”

    zf：
    大千兄闲不着，小弟又来了！

    “……所以这百法都是识或识变的，色法也是识变的，不离识。而再深入一个层次时，就要否定色法的存在了。再深入一个层次时，就要否定心法的存在了。再深入一个层次时，就要否定佛法的存在了，这就是渡过河时船也要舍弃了。”
    ──这里对色法、心法和佛法存在的否定，是在什么意义上否定？是对其作用的否定吗？
    另外，离开了色法、心法和佛法的作用，唯识的“识”能孤零零地存在吗？？？

    “渡过河时船也要舍弃”的意思是说：渡过河后就会发现船原来根本就不存在吗？
    “也就是《心经》所说“无苦集灭道。无智亦无得。以无所得故”而证涅槃。”
    ──观世音在开示“无苦集灭道。无智亦无得。以无所得故”后，紧接着就说：“菩提萨埵依般若波罗密多故，……远离颠倒，究竟涅槃。”　如果佛法是龟毛兔角，则般若波罗密多自然也在其列。请问，龟毛兔角有作用吗？菩萨证涅槃是依靠龟毛兔角的作用吗？

    “……如是我今领解世尊所说义者。若于分别所行遍计所执相。所依行相中假名安立以为色蕴。”
    ──对如来以上开示的理解涉及到“遍计所执相”一语的确切含义。
    从经文的文字中似乎看不出分别所行遍计所执的“对象”一定是龟毛兔角而不是依他起。

    大千：
    龟毛兔角是不存在的，但对龟毛兔角的执着（的心识活动）是存在的，起作用的不是龟毛兔角，而是执着有龟毛兔角的心。
    或者说心是能分别，是实际存在的；概念是所分别，不是实际存在。比如：我们的意识在思考，这是能分别，确实存在这回事儿。而意识想到一个“龟毛兔角”的概念，这是所分别的内容，这个概念就是只存在于意识中的一个想像，而并非实际存在了。
    同理，色法、心法和佛法都是我们意识所分别出来的概念，并非是实际存在，更不可能是我们能进行思维活动的心识本身，因为眼不能自见，识不能自识，用心只能够认识到心识所认识的对象，而不可能认识到能进行认识活动的心识自身，所以我们心识所认识到的一切都是心识所认识的概念，都是不是实际存在。但是我们思维这些并非实际存在的概念时的心识活动是存在的，起作用的就是这些心识活动，善恶业种就是这些心识活动造成的。因此说，色法、心法和佛法并非实际存在，而我们对色法、心法和佛法的思维心是存在的，这就是唯识的“识”。
    由此道理，般若船确实根本就不存在，般若波罗密多并非实际存在，佛法亦如龟毛兔角，《心经》说“无智亦无得。以无所得故……究竟涅槃”，就是说般若智慧并非实际存在，最终也必须舍弃对它的执着才能实证空性；《金刚经》说“法尚应舍，何况非法”，也是实无佛法，实无众生得灭度者之意。佛法如龟毛兔角并非实际存在所以不会有作用，菩萨证涅槃依靠的是自己心识对佛法进行思维的作用，能够思维的心识是存在的，当心识通过闻思修般若波罗密多的修行活动转变成智的时候，菩萨就证到涅槃──诸法实相了。
    “……如是我今领解世尊所说义者。若于分别所行遍计所执相所依行相中假名安立以为色蕴。……是名遍计所执相。世尊依此施设诸法相无自性性。”遍计所执相在三性理论中就是毕竟空无所有的意思，如《摄大乘论》说：“若圆成实自性。是遍计所执永无有相。”遍计所执完全彻底地永远断除，就是圆满成就了真实性。


一些唯识设问

    zf：
    大千兄，“色声香味触不是客观存在，而是主观映象和感觉。”这一点小弟完全同意。
    但如何理解产生这些主观感觉的“辐射能量作用”、“声波”、“挥发性物质”、“可溶性物质”、“机械刺激”？
    这些参与了“主观感觉”生起的“客观现象”与龟毛兔角是否有区别？
    如果行人对“辐射能量”、“声波”、“挥发性物质”、“可溶性物质”等假名安立的法：
一、不去推断存在着一个独立于人们认识感觉之外的客观物质世界；
    二、不否定其能引起感觉的作用；
    三、不用“识”来探讨此等作用的本源，而以业力来理解一切法产生的原因（如人见水，鬼见脓血，天人见甘露等）。

    上述之“见”依唯识体系的观点如何评价？
    换一个角度，能否说种子是为表述“已作业不失”作用的假名安立？
    “空中无色”之“无”是何意？是如龟毛兔角的无吗？若色为如龟毛兔角的无，则“色即是空，空即是色”中的“空”与断灭空有何区别？另外，与受想行识不二的空跟与色不二的空是否有区别？

    大千：
    可以说种子是为表诉“已作业不失”作用的假名安立，实际上凡夫所知一切法都是名言假立的，都不可能是实际存在的缘起法本身。
    “空中无色”之“无”是没有的意思，就是如龟毛兔角的无。“色即是空，空即是色”中的“空”与断灭空没有区别，与受想行识不二的空跟与色不二的空没有区别。关键是要知道，只有在凡夫的名言假立中才有五蕴的分别，因此《心经》所说的五蕴十八界十二因缘四圣谛等都是指凡夫所见闻觉知的一切法，这一切都是毕竟空无所有的，必须把它们完全彻底地断除无余，才能“以无所得故……究竟涅槃”，实证诸法空相。
    所以断灭凡夫的妄想，并不等于断灭了包括圣者所证真实境界的一切法，凡夫所知法与圣者所证法对比起来，小到少到不可思议的程度，我们修行的目的，就是要以彻底断除凡夫所知法来实证圣者境界。就如《华严经》所说：“无一众生而不具有如来智慧，但以妄想颠倒执著而不证得；若离妄想，一切智、自然智、无碍智则得现前。”


关于十二因缘的讨论

    zf：
    请问大千兄，兄多次引用《大般涅槃经》。请问，依兄所见，《涅槃经》所开示的法义（特别是下面的经文）是方便说，还是了义说？

    “我经中说十二因缘其义甚深。无知无见不可思惟。乃是诸佛菩萨境界。非诸声闻缘觉所及。以何义故甚深甚深。众生业行不常不断而得果报。虽念念灭而无所失。虽无作者而有作业。虽无受者而有果报。受者虽灭果不败亡。无有虑知和合而有。一切众生虽与十二因缘共行而不见知。不见知故无有终始。十住菩萨惟见其终不见其始。诸佛世尊见始见终。以是义故。诸佛了了得见佛性。善男子。一切众生不能见于十二因缘。是故轮转。善男子。如蚕作茧自生自死。一切众生亦复如是。不见佛性故自造结业流转生死犹如拍毬。善男子。是故我于诸经中说。若有人见十二缘者即是见法。见法者即是见佛。佛者即是佛性。何以故。一切诸佛以此为性。”

    大千：
    此为了义，但此缘起无法对凡夫讲，所以在凡夫所知法中假安立缘起法为方便。

    zf：
    请教大千兄，您是以何根据来断定作为此了义经典核心的十二因缘为方便说？
    如来于《大般涅槃经》中开示：
“善男子。又如医师有一秘方。悉摄一切所有医方。善男子。如来亦尔。所说种种妙法秘密深奥藏门。悉皆入于大般涅槃。是故名为大般涅槃。”
    此被如来称为普摄一切妙法秘密深奥藏门的《大般涅槃经》为了义之说，是毫无疑问的。
    经中特别重视十二因缘之说，例如：
“善男子。是故我于诸经中说。若有人见十二缘者即是见法。见法者即是见佛。佛者即是佛性。何以故。一切诸佛以此为性。善男子。观十二缘智凡有四种。一者下。二者中。三者上。四者上上。下智观者不见佛性。以不见故得声闻道。中智观者不见佛性。以不见故得缘觉道。上智观者见不了了。不了了故住十住地。上上智观者见了了故。得阿耨多罗三藐三菩提道。以是义故。十二因缘名为佛性。佛性者即第一义空。第一义空名为中道。中道者即名为佛。佛者名为涅槃。”
    如来说，若有人见十二缘者即是见法，见法者即是见佛，佛者即是佛性。又说，十二因缘名为佛性，佛性者即第一义空，第一义空名为中道，中道者即名为佛，佛者名为涅槃。大家知道，《大般涅槃经》的中心主题是宣说佛性，而十二因缘在此亦被称为佛性，可见在此经中十二因缘居于核心地位。
    请教大千兄，您是以何根据来断定作为此了义经典核心的十二因缘为方便说？
    如果一部经典的核心是方便说，这部经典能称为了义吗？

    大千：
    作为此了义经典核心的十二因缘不是方便说，正是了义说。
    十二因缘在佛经中有两种含义。
    一、了义：实际存在的十二因缘，是诸佛菩萨境界，是凡夫无知无见不可思惟的。如《大般涅槃经》所说“我经中说十二因缘其义甚深。无知无见不可思惟。乃是诸佛菩萨境界”中的“十二因缘”即是了义。
    二、不了义：佛为了接引众生，使我们也能够思惟和理解因缘法，有些经中是拿凡夫可知可见可思惟的法来讲十二因缘的，这些法不是实际存在的因缘法，而是凡夫颠倒妄见的梦中幻事，这样解释的十二因缘就是方便说法，不是真正的甚深义的十二因缘，这是不了义的说法。
    比如，讲老死，一般解释为你看，我们人都会老，都会死，这就是不了义的方便说法，因为这都是凡夫可知可见可思惟的法，而不是其义甚深的因缘法。在诸佛菩萨境界的甚深因缘法中，无我们，无人，无老死，是我们凡夫无知无见不可思惟的境界，那才是真正了义的因缘法。
    依此类推，佛说的所有的话，都有这样两种含义，一个是佛说此话时，他真正所指的是他亲证的真实境界，这个含义是凡夫无知无见不可思惟的，但唯有此义才是终极了义；一个是凡夫听佛说此话时，一定是按照自己可知可见可以思惟的那些法来理解佛说此话的意思，佛也随顺凡夫这样的理解，但这个理解就是不了义的方便含义了，因为这种理解绝非佛陀亲证境界本身。
    所以佛在《金刚经》里说：佛说世界，即非世界，是名世界。这就是在提醒我们：佛说的世界，是佛亲证的甚深境界，并不是凡夫听者所理解的那样的世界，只是为了让凡夫听得懂，佛暂时把它也叫做与凡夫所理解的世界一样的名字罢了。
    这是从佛说的角度来说的，如果从我们的角度出发，也可以倒过来说，我们在读佛经的时候，如果我们就按照自己可知可见可以思惟的法来理解佛说的话，这就是不了义的方便理解；如果我们知道，佛让我们这样理解只是个方便，目的是通过这种方便让我们理解到佛有真正甚深的含义，这才算是理解到了佛说的了义。
    若依此倒过来说的含义，佛说的每一句话，就既可以说是了义，也可以说是不了义，这取决于读经的人是能否理解得到了。
    当然，一般所说了义不了义，有大家共许的特定含义，不是最后这段话里说的这种意思。

    zf：
    关于十二因缘其义甚深，在下有如下理解：
一、既然如来分十二个环节开示缘起法，因此无明、行、识、名色、六入、触、受、爱、取、有、生、老死这十二类法都是缘起法。
    二、这些法中的大部分都是凡夫可以感知的。例如，六入（六根，属于色法）、触、受等。
    三、十二因缘甚深难见，不是说这十二类法难见，而是说这十二类法之间的因缘关系难见，唯佛能彻知。例如为什么无明是行生起的因缘，而行又是识生起的因缘等。能将这十二类法排成一个因果链（或环）者，除了佛，别人根本无法完成。
    四、如果“缘起法”一语是指十二类法之间的因缘关系，则毫无疑问，此“缘起法”唯佛能证知；另一方面，如果“缘起法”是指某一类法（这些法在圣人眼里处于因果关系之中），则这样的法凡夫也能见到，不过在见到这些法的同时增益了法执，因无法见缘起故。
    上述讨论附带回答了大千兄关于中观中凡夫是否能见缘起法的问题。当然，唯识旧说是不会同意在下这些看法的。

    二麻子：
    诸法实相，不接受也不行……，嘿嘿……这个地方，唯识新说也罢旧说也罢，麻子看法是都得接受。大概表达上差别一点点。
    凡夫以思维心认识缘起法虽然带有扭曲，但总也有少分真实，说见真实也没错。只是这个见真实确实不够深，不是诸佛菩萨所证的程度。
    而依唯识角度来看，上述凡夫思维心所见完全是带有遍计执的，这在唯识来说，就不能算是见依他起，所以唯识不许。由此来看，唯识这里说的“见”，语义上跟中观所用的有所不同，唯识的门槛设得高些。

    zf：
    关于中观和唯识之“争”，记得在下曾当面与大千兄说过：我不相信今人学中观者有超过月称者，也不相信今人学唯识者有超过月官者，二月相“争”七年没有公认的结果，今人即使争出个结果来，也不会是真正的“结果”。
    虽然不可能有结果，但还要继续争。
    一、将十二因缘界定为十二类法之间的因缘关系，众生虽不能见其中的因缘关系（即不能见缘起），但可见法（此法在圣者眼里是如梦如幻的缘起法，在凡夫眼里是实有法）。这种对十二因缘的理解，大千兄所引的经论并不能破除。
    二、在大千兄所引的如下经论中：
“复次云何应释彼相。谓遍计所执相。于依他起相中实无所有。圆成实相于中实有。”
    “依他所执无　　成实于中有
     故得及不得　　其中二平等”
    “谓于依他起中。由遍计所执无故。及由圆成实有故。”
    非常清楚地指出：遍计所执相是于依他起中生起的“执”。“依他所执无”并不等于凡夫根本无法见到法（这些法在圣人眼中是依他起的）。若根本见不到（依他起的）法，凡夫于何处起执？
    若凡夫所见全是遍计所执，那么“依他所执无，成实于中有”这一句是否应该改为“遍计所执所执无，成实于中有”？


“凡夫法”和“圣者法”的“交集”

    大千：
    发愿是能，没有所，比如我们发愿成佛，因为我们“能”发愿，愿确实是发了，但所发之愿──成佛的那个想像，实际上是不存在的，因为我们想像的一定不是我们最后实证的佛果，而是一个用我们凡夫遍计所执相组合成的佛果，这个佛果是不存在的，只是能起到帮助我们修行的作用罢了。

    zf:
请问大千兄，
    一、 我等凡夫现在发愿成佛，此愿之“能”边，在圣者看来是否是缘起法？
    二、 此愿之“能”边，我等凡夫是否可以觉知？
    三、 若不能觉知，我等凡夫当如何用心才能发起成佛之愿？初发心菩萨是如何得知自己已经发心？
    四、 若能觉知，“凡夫法”和“圣者法”是否有“交集”？

    先界定讨论中共用语言的含义,其中最重要者就是“缘起法”。

    一、 “缘起法”表真实义
    如兄所言：
“由于人类有限的认识范围，相对于无限的宇宙来说永远只是一个特例，所以人类永远不可能认识到宇宙的普遍规律──真理（也叫真实），……”
    如果仁兄在讨论中用“缘起法”表述如上“真实”义，那么毫无疑问，这种缘起法我等众生是根本沾不上边的。对此，学中观者恐怕不会有疑义。
    能如实见到这种“缘起法”（在时间上无限，在空间上无限……）者，只有证得一切种智的如来，十地菩萨也见不到这种真实。

    二、 “缘起法”表“缘起之法”义
    对于学中观者，“缘起法”通常是指缘起之法。
    论坛上学中观的诸兄与仁兄关于凡夫能否见缘起法争论的焦点不是指上述表“真实”义者，而是指这种“缘起之法”。
    这种“缘起之法”主要是指一条缘起链上的某一个环节，如无明──行──识──名色……，或众生──大悲心──菩提心──等正觉。
    以发愿成佛为例，我等众生确实没有智慧了知此一念愿心在成佛的因果路上所能起到的作用和这种作用发生的机制，但这并不是说我们根本就觉察不到自己心中这个“愿”的存在。

    请兄不妨做个实验：
    （1） 督摄六根，反观自心；
    （2） 发起“我要成佛”的愿；
    能够产生果报的不正是当下这个“愿”吗？
    仁兄难道不能做到在发愿的同时觉察到愿的存在吗？

    还有个苦招：
（1）饿上三天不吃饭，然后在面前放上一桌饭菜；保持内心的觉照，看看能否发现自己想吃之“愿”？
    （2）继续保持觉照；当忍耐不住的时候就去吃。
    这样，不但觉察到想吃之“愿”，还觉察到了此愿的果报──吃到了饭。
    这不是现见因果吗？虽然同如来了知一切因果相比过于粗糙、肤浅，但毕竟也算因果链上的一环。

    大千：
    完全同意信念几乎不可讨论，可讨论的只能是道理。
    我等凡夫现在发愿成佛，此愿之“能”边，在圣者看来是缘起法。此愿之“能”边，我等凡夫不能觉知。我等凡夫只要从能够觉知到的“所”边发愿，这个发愿活动本身就是“能”边。也就是说，有所必有能，不可能有无能之所出现。所以初发心菩萨只要在“所”边发愿，便知自己已经发心（当然这是从自己能否觉知的角度说，如果从是否真实发心角度说，则是另一个问题了）。
    “凡夫法”和“圣者法”当然有“交集”。凡夫可以通过修行转凡夫识成圣者智从而转凡成圣；实证真实的圣者，也可以如实证见有关凡夫的一切法：无论是凡夫心识活动本身的“能”边，还是凡夫心识活动所认识到的“所”边。
    佛说三界唯心，万法唯识，这是圣者以无分别智实证的世界真实面目，就是说这个世界上就只有心识，而没有其它。这心识就是真正的缘起法。比如我们发了一个愿，就是这心识的一个活动，这是实际存在的缘起法，意识的现行发愿活动会熏成种子，当这些种子与有关因缘的种子成熟时，就会显现果报的现行。这些都是实际存在的缘起法的相似相续的运行，这是真正的因果链。
    但意识的这个实际运行过程意识自己认识不到，因为眼不能自见，识也不能自识，必须由比意识更高层次的认识工具（圣者的无分别智）才能真正认识到意识的活动，这也就是佛说的缘起甚深，凡夫不能见知，是诸佛菩萨境界的意思。凡夫的意识在缘这个缘起法时，把它搜集到的信息又翻译成了它自己的那种分别出来的相对概念，所以实际存在的发愿的心识活动，在意识的认识里就被意识假立的名言描述成另一幅样子，这幅样子纯粹只是意识的主观感觉，并不是实际存在。意识如果不去感觉，停止活动，比如无梦睡眠的时候，由意识描绘出来的那幅样子的世界就消失得无影无踪了。因此，存在于意识想像中的这条因果链是用名言假安立的，而并非实际存在。
    当然，意识在想像中对那些并非实际存在的事物进行思维的时候，它本身的这个思维活动过程却是实际存在的。那些想像中的事物因为不是实际存在，所以它们不可能是真正的因果链，真正能够起作用的因果链，是实际存在的心识活动本身。


发愿与观察

    zf：
    大千兄，您对中观有自己独到的理解，论坛上的诸兄可能会有所评说。我还是将焦点集中在自己感兴趣的问题。以发愿成佛为例，我等众生确实没有智慧了知此一念愿心在成佛的因果路上所能起到的作用和这种作用发生的机制，但这并不是说我们根本就觉察不到自己心中这个“愿”的存在。
    请兄不妨做个实验：
（1）督摄六根，反观自心；
    （2）发起“我要成佛”的愿；
    能够产生果报的不正是当下这个“愿”吗？
    仁兄难道不能做到在发愿的同时觉察到愿的存在吗？

    大千：
    能觉察到的，都是名言境界中假安立的法，不是真正的缘起法，也就是说，不是实际存在的“愿”的本身，而是在意识中用名言假安立出来的一个模拟（实际存在的缘起法之愿）的愿，这种愿只存在于意识的思维想像之中，不是实际存在的缘起法，意识停止分别的时候这种愿就毫无所有了，它怎么还有可能产生果报呢？所以能够产生果报的是作为缘起法的“愿”，而不是只存在于凡夫意识分别中的那个“愿”。

    zf：
    请仁兄仔细剖析一下，当我等正在自心中在发愿时，我们是如何在发愿的同时又用意识想象出来一个“愿”？为何这个想象中的“愿”可以被观察，而原来用心发的愿却观察不到？
    关于我等不能直接观察到心中的愿，仁兄能否引用经论中的教证予以说明。否则给在下的感觉是，仁兄已经先有了不可动摇的信念。若此讨论涉及到信念的问题，在下便会犹豫是否有必要与仁兄进一步讨论下去。因为信念几乎是不可讨论的。

    大千：
    因为我们凡夫的意识只能用名言进行思维，所以我们必须用意识的语言想象出一个“愿”来，我们的意识才能完成自己（缘起法）的发愿活动；如果不让意识想象出一个认识对象来，意识就不会活动了。
    用名言在意识的想像中描绘、描述出来的任何事物都不是事物本身，而只是一些名言概念，并非实际存在的事物。比如我们用意识的语言想象出来的那个“愿”，那是意识的认识对象，而绝非是正在进行发愿活动的意识本身，意识只可能认识到它的认识对象——法尘，而不可能认识到意识自身。
    关于这个心识不能自见的道理，略引教证：
《中论》观三相品第七中说：“住若自相住。法亦应自相住。如眼不能自见。住亦如是。”
    《十二门论》观一异门第六中云：“凡物不能自知，如指不能自触，如眼不能自见。是故汝说识，即是相可相，是事不然。”又在观作者问第十中云：“若自作，即自作其体，不得以是事，即作是事。如识不能自识，指不能自触。是故不得言自作。”

    zf：
    通过近来的讨论，您看问题的角度我了解了一些。我想，讨论的主要目的不是获得一致的认识，只要能引导讨论者深入思考，作用也就起到了。
    仁兄文中有许多问题值得进一步讨论。这里先选出一个。
    “佛说三界唯心，万法唯识，这是圣者以无分别智实证的世界真实面目，就是说这个世界上就只有心识，而没有其它。”
    仁兄常以眼不能自见、手不能自摸来说明心识不能自见。
    请问：
1、唯识体系中的“识”是否包括圣者之“智”？
    2、仁兄常以眼不能自见、手不能自摸来说明心识不能自见。
    请问，在唯识体系中，圣者之智能否自见？

    大千：
    这要先分析为什么心识不能自见？这是由凡夫意识认识事物的方式决定的。意识不能直接亲证事物本质、真相，而只能认识事物的外在现象、表象；它不能完整地认识事物，而必须用意识自己的语言把认识对象分别成相对的概念才能认识到。如果不让意识用这种假安立的虚拟概念来认识事物，意识就无法活动了。而这种概念，包括具象思维概念（现量）和抽象思维概念（比量），完全是意识自己的语言，而不是事物本身，所以意识描述出来的世界，是对实际存在的世界的一个模拟地图或沙盘，不管它怎样描述，都与真实情况是两回事。世界本来是无二的整体，而意识必须把世界分别成相对的二、三、四以至无数的概念，这本身就是对真实情况的割裂、歪曲，绝非真实情况本身了，所以说一起分别就已经错了，意识是不能直接认识实际存在本身的。
    而佛陀实证的世界真实情况是三界唯心，万法唯识，这里的心识是实际存在的，所以说凡夫的意识认识不到实际存在的心识，心识不能自见。究其原因，还是因为意识只能见知用自己的语言建构起来的虚拟世界中的感觉和概念，而不能直接亲证实际存在的法。
    而圣者之智叫做无分别智，就是没有凡夫意识那种分别的智，因为圣者智已经不是凡夫之识了，自然也就没有识的分别了，也就没有识分别出来的虚拟世界里的一切概念了，也就没有由此虚妄障碍凡夫不能认识到实际存在的法的问题了，也就没有由此造成的凡夫意识不能自见那样的缺陷了。

    （编按：这一问题的其他讨论见本节中“唯识中的‘识’与圣者之‘智’”一文等。）


唯识中的“识”与圣者之“智”

    zf：
    唯识体系中的“识”是否包括圣者之“智”？

    大千：
    包括。所以如果在广义上说，也可以都称为识（或者也有把识称为智的），比如于佛位亦有无垢识、清净识、如来识、阿摩罗识等称呼。起个什么名字，只是为了说明一种道理，并不就决定了事物的本质，只要明白为什么要这样称呼，就不会影响对事物本身的正确理解。

    上一个问题涉及凡夫意识能够认识到的虚拟世界和圣者智实证的真实境界两方面，而现在这个问题就完全是不可思议、不可言说的圣者境界的事，应该是更不容易讨论了，所以先讨论上一个问题，可能会减少一点儿讨论现在这个问题的困难。
    识与智既有不同，也有联系，因为智是由识转变成的，所以既是不同的阶段，又有相续的关系。识是如何转变成智的呢？我们凡夫无始以来起惑造业，熏习了无量的染污种子，说其染污就是因为执着有我（略说有人我法我，也就是我和我所、能取和所取、精神和物质等等），由此产生贪嗔痴三毒和生死轮回的业报。佛菩萨为了度化众生消除三毒、出离生死，化身示现走向解脱的佛法，其核心就是告诉我们“诸法无我”，我们闻思修佛法熏习成的种子与无始以来所熏习的染污种子的性质就正成相反，由于明白无我了，就能逆贪嗔痴而修施忍慧，还债消业就能消除生死轮回的业报，获得解脱，证得与佛菩萨一样的清净境界，所以闻思修佛法的种子被称为清净种子。
    生死中每一刹那显现我们生死轮回的业报都要消耗掉大量的染污种子，如果我们面对业报继续起惑造业熏习补充染污种子，那这生死轮回就自然能平衡地延续下去，而如果我们面对业报却闻思修佛法熏习清净种子，就自然形成染污种子减少、清净种子增多的转染成净的修行过程，当这种清净种子的熏习达到一定比例（大约一少半）时，每一刹那生起现行业报所需要的所有染污种子之间的联系就会受到阻碍，本来需要执着有我和我所的染污种子来生起有“我”和有“器世间”的感觉，可在联络所需同伴的时候，却发现旁边有不少专门破除我和我所颠倒感觉的清净种子，后者自然是帮不上这个忙的，结果造成染污种子相互之间不能顺利地联络和聚合，万缘中只要差一缘尚未聚合，整个染污的现行业报就不可能生起，至此生死轮回就被中断了，生死长梦至此结束了，一位初地菩萨就此诞生了，生死长梦中的一切事物不再显现，如《摄大乘论》说“无分别智现在前时。一切诸义皆不显现”，这就是识转成了根本智从而实证了一切法毕竟空无所有的空性，后得智随即生起，世界本来面目自然现前，无始以来第一次实证甚深缘起法，如梦初醒第一次亲证真实，原来三界就只有心，其余一切都只不过是心中的妄想而已，现量亲证实际存在的心识刹那生灭、如幻如梦（而不是我们凡夫虽然比量知道一切有为法如梦幻泡影，而现量感觉却如真实一般），而心识所梦、也就是意识所见闻觉知的一切法都是根本不存在的梦想、妄想，无数众生因果业报所有因缘：每位众生现在正在做什么样的梦，过去曾经造下什么样的业种，将来成什么相应的果报了了分明刹那现前，心中生起极大欢喜，所以初地就叫做极欢喜地。
    染污和清净两种种子虽然染净性质相反，所指方向相背，所生结果殊异，但其熏成的形式和过程却是一样的，都是心识一切现量和比量思维活动熏成的种子（用现在的话也可以说，是一切起心动念在深层潜意识中留下的记忆），只是在两种种子之间的数量比例关系发生变化时，量变到一定程度就会引起质变，也就是说在转染成净的量变达到一定程度时会发生转识成智的质变，进入一种更高层次的状态，而实际上它们的生成方式仍是一样的，所以如果在广义上说，也可以都称为识（或者也有把识称为智的），比如于佛位亦有无垢识、清净识、如来识、阿摩罗识等称呼。称名，只是为了说明一种道理，并不就决定了事物的本质，只要明白为什么要这样称呼，就不会影响对事物本身的正确理解。
    如果在需要狭义使用识的时候，“识”字的实际所指又会发生变化，比如在上述广义之识中，要分析凡夫识与圣者智的差别的时候，就要使用狭义之识了，佛教经论中大量的论述都是使用的这种狭义之识，而在佛说三界唯心，万法唯识的时候，他是用“识”字表示三界所有实际存在之有为法，所以这时应该是指广义之识。

    zf：
    通过与千兄的讨论，在下了知，唯识这一大体系中包含了许多“子体系”，这些“子体系”之间的见解并不完全相同，这其中可能就包括对“识”含义的不同理解。
    在下想提醒千兄的是：在同一“子体系”内，同一概念应尽量具有相同的内含；若有“广义”、“狭义”之差时，应予以特别说明，这样才不致给后学带来不必要的困难。毫无疑问，教理本身不能替代对实相的证入，但教理如同指月之指，可将人之目光指向明月。若手指不停地变换着方位，欲见月之人便会有不知所措之感。
    由于千兄以恢复唯识古说为己任，在下这一提醒或许对千兄构造“理论体系”时有用。
    仁兄的这一解说大可商榷。
    一、“无数众生因果业报所有因缘：每位众生现在正在做什么样的梦，过去曾经造下什么样的业种，将来成什么相应的果报，了了分明刹那现前。”这绝不是初地菩萨所能如实见到的。在十二支因缘中，十地菩萨尚不能全见，更不要说初地菩萨了。
    二、如果说初地菩萨的生死长梦结束了，他在梦醒之时为什么不能全见十二支因缘？
    三、初地菩萨的所知障显然没有破净，而在没有破尽所知障的心中，“真实”和“梦幻”是如何显现的？

    如果仁兄觉得这些问题并非无稽之谈，可以慢慢思考，不必急于回答。


文句与正见

    文句与正见

    二麻子

    一行字的存在，虽然不能给出唯一意思，但对意思还是有很多约束的，这并没有说一行字的意思可以任意改变全无限制。但一行字也没有什么自性自义──所谓恒常不变不依因缘的意义。因缘法的事，前段时间坛子里关于“宿命论”与“自由意志”的讨论里说过点。实际上，因缘法对后果既不是完全决定性的宿命，也不是完全无约束的自由。
    难道真的有个什么文句是有其“自性”“自相”“自义”的吗？显现是依赖因缘的，不同因缘下同一行字的意义可以不一样，这有什么不对吗。麻子就是要尽可能地让每行字显发正解，你干吗不也这样做？嘻嘻。依麻子的个人看法，如果你只描述手掌，几乎不描述手背，错当然没有，但要有人喜欢来补充你，这人也不见得是错的吧。比如：
“转识成智后，各种心所怎么变？烦恼心所应该是断了。但其他心所是断了还是转了？还是没变？如果转了，转成什么样？”
    ───“涅槃以后再干什么呢”？这个问题往往是梵教的人用来动摇正见不够的佛门弟子的。虽然上贴贴主不是这种别有用心，但其问题的错误和扭曲是类似的。涅槃无三时，问涅槃以后干什么纯是栽赃。同样，转识成智的时候能所不二，并不是心与心所各转各的。要想成各转各的，才能有原贴的问题，然而，这纯系栽赃了。
    “‘无我之后，没有什么’，有人认为这样的观点就是断见”
    ──这本身当然不是断见，但是读这话的一般人却也挺容易产生断见联想的。如果在后面补一句“也不缺什么”，可能就好很多。
    又如：
“有为法、无为法都不是，那这个“真心”是个什么法？”
    ──既然不认为有，硬要谈“是”，不是栽赃吗？
栽赃的地方，是一定要说它“是”什么。“是”什么？是人的能所二执。就是说，人把能所对立强栽到它头上。虽然我们要用语言说话，而语言本身是能所对立的，所以说话里不免使用某些隐含对立的词汇。但这样明确地强调能所对立明显是栽赃给真心了。

    中观，特别是应成中观是非常准确精密的正见。唯一要小心的是，尽管中观非常准确精密，我们对中观的理解却未必准确。不少人对这个差别视而不见。麻子不认为空宗、唯识、真常圆觉这三宗有什么不了义。麻子只认为许多学人未达了义。比如你引用的一些想要冠以常见的“真常”语句，麻子告诉你这些话有正解，而且有的人就是这样正解的。但麻子并没说这样的话可以任意解释为，比如，“牛吃草”。麻子也没说“至尊主”这样的外道教义可以解释为无我！
    中观里“实有、实法、实事”这三个词，特别实有这词多是指自性有。而唯识里，这几个词似乎只是“遍计”“妄想”的否定。在唯识一边历代以来，各种宗派说法不一。麻子也觉得有若干学唯识的人未能准确，以至有粘常见的嫌疑。然而，唯识一说本身，麻子觉得不应有此弊病。唯识在依他与圆成上所用“自性有”一词是与中观的自性有同义吗？在麻子看来，决然不同。自性有在唯识里，绝无“能不依因缘而独立显现之恒常不变”的意思。（当然，不幸的是，若干人就是把阿赖耶识这样认识的──这是，至少暂时是，题外的话）。所以，即使是唯识用自性有来说三自性，麻子仍然不觉得这里有什么“常见”剩下。
    一般来说在唯识里说有没有（参见大千兄的贴子）用的意义就是一般通用意义，用中观的话说，是不违背名言共许。而名言共许意义上的有，其实都是观待唯名的有。也就是说，要说有，必然有对立对比。唯识一般情况下也是这样用的。但到了圆成实的“有”，这个“有”字改用了完全不同的含义。如果遵照上面的名言共许，这个有字是根本不能用的，只能说非断。现在用了有字，不免被很多人误解为俗义，把圆成实与别的什么对立了看，那就一定落到常断见里了。无兄特地申明了无对待，很好的。若是麻子，就再申明一下，这样的有，用中观的话来讲，就不能叫有了。
    “真心佛性不空”如果是“有”，就接近他空见。如果是“不断”，则同“妄念本空”。即使说“真心佛性不空”是有，他空见也不是轻易可以打倒的。如果是“不断”，则只不过是“妄念本空”的另一表述，完全符合中观正义。所以，真常唯心系完全可以是正见。但是，有不少人心底下是把“真心佛性不空”做实有的，这是事实。而这才是需要担心的吧。

    能所对立本身就是观待（缘起）。禅宗之参是要参到离心意识，说得更准确一点是要参到超越心意识的能所局限，而并非一开始参就离得开心意识。而其开始参处，很多都有无我的抉择思维。如果真能知道无位真人的意思，一定能契入。无位真人有个非常无我无常无自性的解。只是如今，把这四字能理解对的极少。当然，真知道解的人不会不喜欢不赞成苦空无常无我。这个妙明净体也有个非常符合龙树菩萨八不的现量与解释。如果对上两条有正见正解，那么绝对有可能修入圣道。
    在麻子看来，明体什么的绝对存在正解，可以正解。类似的可看一下大手印“明体”。但是我们得知道，大手印描述的明体是超越能所对立的。这个明体性净（不可污染）无我，不做主宰，而且这个明体非对待。所以，不能算是“有”。但也不能算是“无”。如果你死盯住问那“是”个什么法，对不起，你是把能所对立栽到它头上了。超越能所对立，连“有”都说不上谈什么“是”？有为法无为法，离二边你倒是张嘴看看？
    再一个问题是，有的描述里面举性空无生的例子都是外境。而实际在解脱道上最关键的几步是把对空性无生所做的分析，用在“自心”这个样本上，特别是自我主宰感，能所对立实有感等。你如果真的这样用一下，会发现有些你平时觉得已然看破的事情其实还在，所以当觉得理解已经相当透彻了的其实未必那么透彻，对别人是否“常”见的尺度把握，恐怕也会有相当大的修正。
    就算是行人见尚未准，也是不要紧，只要他们在向正见继续靠近就好。这似乎是正常的学习过程。嘻嘻，还是老话，常见是错的，但不要用个什么“真常唯心”一竿子打翻一船人。过分延伸对方的含义，从而给对方制造谬论，并不有益于我们学佛以至解脱。


华严五教止观·第五华严三昧门

    华严五教止观·第五华严三昧门

    京终南山文殊化身　杜顺　说

……
    但法界缘起惑者难阶。若先不濯垢心。无以登其正觉。故大智论云。如人鼻下有粪臭。沈麝等香亦为臭也。故维摩经云。无以生灭心行说实相法故。须先打计执。然后方入圆明。若有直见色等诸法从缘。即是法界缘起也。不必更须前方便也。如其不得直入此者。宜可从始至终一一徵问。致令断惑尽迷除法绝言见性生解方为得意耳。问曰。云何见色等诸法。即得入大缘起法界耶。答曰。以色等诸事本真实亡诠。即妄心不及也。故经云。言说别施行。真实离文字。是故见眼耳等事。即入法界缘起中也。何者。皆是无实体性也。即由无体幻相方成。以从缘生非自性有故。即由无性得成幻有。是故性相相浑融全收一际。所以见法即入大缘起法界中也。问既言空有无二即入融通者。如何复云见眼耳等即入法界中耶。答若能见空有如是者。即妄见心尽方得顺理入法界也。何以故。以缘起法界离见亡情繁兴万像故。问既知如是。以何方便令得入耶。答方便不同略有三种。一者徵令见尽。如指事问云何者是眼。如已前小乘中六种简之。若入一切诸法但名门中收。无有一法非名者。复须责其所以知眼等是名。如是展转责其所以。令其亡言绝解。二者示法令思。此复有二门。一剥颠倒心。既尽如指事。以色香味触等。夺其妄计。令知倒惑。所有执取不顺于法。即是意识无始妄见熏习所成。无始急曳续生三界。轮环不绝。若能觉知此执即是缘起。当处无生。二者示法断执。若先不识妄心示法。反成倒惑。若不示法令见。迷心还着于空。所以先剥妄心。后乃示法令见。三者显法离言绝解。就此门中亦为二。一遮情。二表德。言遮情者。问缘起是有耶。答不也。即(空故。缘起之法无性即空。问是无耶。答不也。即有故。以缘起之法即由无始得有故问也)亦有亦无耶。答不也。空有圆融一无二故。缘起之法空有一际无二相故也。如金与庄严具思之。问非有非无耶。答不也。不碍两存故。以缘起之法空有互夺同时成也。问定是无耶。答不也。空有互融两不存故。缘起之法空夺有尽唯空而非有。有夺空尽唯有而非空。相夺同时两相双泯。二表德者。问缘起是有耶。答是也。幻有不无故。问是无耶。答是也。无性即空故也。问亦有亦无耶。答是也。不碍两存故。问非有非无耶。答是也。互夺双泯故。又以缘起故是有。以缘起故是无。以缘起故是亦有亦无。以缘起故是非有非无。乃至一不一。亦一亦不一。非一非不一。多不多。亦多亦不多。非多非不多。如是是多。是一。亦是多亦是一。非是一非是多。即不即四句准之如是。遮表圆融无碍皆由缘起自在故也。若能如是者。方得见缘起法也。何以故。圆融一际称法见故。若不同前后见者。是颠倒见非正见也。何以故。前后别见不称法故。问如是见已。云何方便入法界耶。答言入方便者。即于缘起法上。消息取之。何者。即此缘起之法即空无性。由无性故幻有方成。然此法者即全以无性性为其法也。是故此法即无性而不碍相存也。若不无性。缘起不成。以自性不生皆从缘故。既全收性尽。性即无为不可分别。随其大小性无不圆。一切亦即全性为身。是故全彼为此。即性不碍幻相。所以一具众多。既彼此全体相收。不碍彼此差别也。是故彼中有此。此中有彼。故经云。法同法性。入诸法故。解云。法者即举缘起幻有法也。同性者。缘起即空而不碍此相故。全收彼为此。以彼即空而不碍彼相故。既此彼全收相皆不坏。是故此中有彼。彼中有此。非但彼此相收。一切亦复如是。故经云。一中解无量。无量中解一。展转生非实。智者无所畏。又云。于一法中解众多法。众多法中解了一法。如是相收彼此即入。同时顿现无前无后。随一圆融即全收彼此也。问法既如是。智复如何。答智顺于法。一际缘成。冥契无简。顿现不无先后。故经云。普眼境界清净身。我今演说人谛听。解云。普眼者。即是法智相应顿现多法也。即明法唯普眼智所知简非余智境界也。境界者。即法。明多法互入犹如帝网天珠重重无尽之境界也。清净身者。即明前诸法同时即入终始难原缘起集成见心无寄也。然帝释天珠网者。即号因陀罗网也。然此帝网皆以宝成。以宝明彻递相影现涉入重重。于一珠中同时顿现。随一即尔。竟无去来也。今且向西南边。取一颗珠验之。即此一珠能顿现一切珠影。此珠既尔。余一一亦然。既一一珠一时顿现一切珠既尔。余一一亦然。如是重重无有边际。有边即此重重无边际珠影皆在一珠中。炳然高现。余皆不妨此。若于一珠中坐时。即坐着十方重重一切珠也。何以故。一珠中有一切珠故。一切珠中有一珠时。亦即着一切珠也。一切反此。准以思之。既于一珠中入一切珠。而竟不出此一珠。于一切珠入一珠。而竟不起此一珠。问既言于一珠中入一切珠而竟不出此一珠者。云何得入一切珠耶。答只由不出此珠。是故得入一切珠。若出此一珠入一切珠者(即不得入一切珠也。何以故。离此珠内无别珠故。问若离此珠内无一切珠者。此网即但)。一珠所成。如何言结多珠成耶。答只由唯独一珠方始始结多为网。何以故。由此一珠独成网故。若去此珠。全无网故。问若唯独一珠者。云何言结成网耶。答结多珠成网者。即唯独一珠也。何以故。一是总相具多成故。若无一。一切无故。是故此网一珠成也。一切入一。准思可知。问虽西南边一珠总收十方一切珠尽无余。方各各有珠。云何言网唯一珠成耶。答十方一切珠者。总是西南方一颗珠也。何以故。西南边一珠即十方一切珠故。若不信西南边一珠即是十方一切珠者。但以墨点。点西南边一珠者。一珠着时即十方中皆有墨点。既十方一切珠上皆有墨点。故知十方一切珠即是一珠也。言十方一切珠不是西南边一珠者。岂可是人一时遍点十方一切珠耶。纵令遍点十方一切珠者。即是一珠也。此一为始既尔。余为初亦然。重重无际点点皆同。杳杳难原。一成咸毕。如斯妙喻类法思之。法不如然。喻同非喻。一分相似故以为言。何者。此珠但得影相摄入。其质各殊。法不如然。全体交彻故。华严经性起品云。为饶益众生令悉开解故。以非喻为显现真实义。如是微密法无量劫难闻。精进智慧者乃闻如来藏(云云)。经云以非喻为喻等也。诸有行者准喻思之
    卢遮那佛过去行　　令佛刹海皆清净
    无量无数无边际　　彼一切处自在遍
    如来法身不思议　　无色无相无伦匹
    示现色相为众生　　十方受化靡不现
    一切佛刹微尘中　　卢遮那现自在力
    弘誓佛海震音声　　调伏一切众生类


中观、如来藏与华严

    小夜叉：
    谈本体论和发生论。
    一、本体论和发生论
    大乘演化到真常，从哲学上讲，是从本体论演化到本体＋发生论。
    原始佛教的缘起性空和般若的无自性毕竟空，都是本体论。说白一点，就是：缘起的如梦如幻是现象，无自性毕竟空是本体、本质。趣向第一义的路径是：先谈现象——缘起，再谈本体——性空。即：从俗谛而入胜义。用一句话总结：缘起的本体是性空；并非性空“生出”缘起。
    真常的逻辑就大变了。真常空性和真常心合二为一，称为真常心，即如来藏或佛性。理论上，变成了先说第一谛，再谈世俗谛。先立真常心，再立森罗万象。这个方向的转变是重大的。一切“现象”都是从佛性（本体）发生出来的，都是妙有。所以，有“淫怒痴皆是梵行”的说法，不知跟这个有没有关系？一切都是由佛性产生出来的。这就从本体论演化到发生论。用一句话总结：佛性是来源、起源（甚至材料？），佛性“生出”大千世界的妙有。
    二、依因和生因
    本体论和发生论的差别可以用“依因”和“生因”来提炼。般若宗认为空只是“依因”，即“以有空义故，一切法得成”。而真常认为佛性是“生因”，佛性生出妙有，认为真常心有“能变”的功能！六祖云：“何期自性，能生万法！”麻叔曾帮我调和，很有道理。但限于篇幅，暂且不谈。
    三、理事和体用
    本体论和发生论的差别还可以用“理事”和“体用”来总结。儒家的体用思想被中国真常者所采用。般若宗认为：缘起是事，显寂灭之理。真常者则认为：真常心是体，妙有是用！这个在元音老人的著作里比比皆是。
    四、性寂和性觉
    以上是用本体论和发生论的思路总结。下面再用“性寂”和“性觉”来总结。
    这四个字的信息含量极大。般若宗的核心思想是“性寂”，即森罗万象的物理世界和精神世界本是寂灭性空的，也即自性涅槃——不生不灭。真常思想的核心是“性觉”，即众生本来就是佛，佛的功德在众生里面结跏趺坐，也即自性菩提——妙觉。
    五、新生和返本
    般若宗认为成佛是新生：本来迷，觉而后新生、成佛。真常：本来就是佛，成佛只是成本来之佛。
    六、正观和放下
    上面谈的全部是义理上的区别。现在谈修持上的差别。般若宗认为众生颠倒，从来没有觉悟过，要觉悟，就必须如理观察思考，即正思维、正念。真常者认为：众生本来是佛、本来就觉、本来功德圆满，所以，只需放下，不需要作意观空，放下就是，不执著就是。前念迷即凡夫，后念觉即佛。有重定不重慧的倾向。
    七、小结
    佛说一切法，为度一切众。因病施药，因材施教。凡药三分毒。般若是药，真常也是药。以上戏论，纯属世智辩聪，以萤火烧须弥而已。贾题韬居士言：“佛教非但不怕别人怀疑并且还提倡大胆地怀疑！”善哉斯言！我不相信学佛还有什么忌讳。以无忌讳故，远离颠倒梦想，究竟涅槃。所谓童言无忌，能婴儿乎？不过，我连怀疑都没有，只是想总结两个系统的不同。请大家仁者见仁，智者见智。
    有为、无为法是统一的一体。如果仅仅讨论如来藏的概念，倒也很容易，一切问题都可以很快解决。比如说，如来藏就是空性。但是，如来藏作为一个庞大复杂的理论体系，就很难分析了，至少大大超出了本人的水平。
    “如来藏。不同外道所说之我。大慧。有时说空无相无愿。如实际法性。法身。涅槃。”
    从佛的那句话看，如来藏＝空性。空性＝无自性。所以：如来藏＝＝无自性。既然如此，就不能说如来藏是有自性或是无自性。如来藏就是无自性的另一个名字。
    有为法和无为法两者是一体的。有为法依于无为法，无为法是有为法的本质，两者是同时的。

    成军：
    即是对应性空缘起的有边，从染边说，即阿赖耶，从净边说，即如来藏（佛性）。有边、空边，同为法性啊。
    佛法总分教证二门，但是教证是不可分的。
    无论中观、唯识、还是如来藏系，目的都是通过文字表述的方便，使众生通过相应法门的实修导向解脱。这个是基本认识，佛教不是哲学，没有“原教旨”主义，第一义谛本来是超越语言文字的。
    实证方面，三系其实也是互补而不排斥。比如说持中观见的人可能念佛，他空见和中观应成派都修时轮金刚。而将中观应成派传入藏地的祖师，阿底峡尊者，他最心要的菩提心修法则来自持唯识见的金洲大师。
    以实证方法来说，如同很多净宗祖师说的，净土属于果地修法，其实密宗也可以算，如来藏系很多修法都可以归这方面。
    而通常的法门属于因地。也就是说，如来藏系法门，可以通过相应，将佛的三身功德，智慧德相，转化成修学者的，从而融合无异，直到成佛。这其实正是如来藏系的殊胜，而这样的方法，显然并非什么权说。因为，其实众生本具如来智慧德相，如来藏系的各种方便，只是把这些显现开发出来。
    这里要说明，以上所说只是后学个人理解，仅供小夜叉参考。
    错谬处还望各方善知识指正。

    zf：
    致夜叉、成军等诸兄。夜叉兄对般若（中观）和如来藏两系的比较甚为精彩，想来一定是心存疑虑，并为此疑虑折磨多时。否则何以会从6个方面对此问题分析比较，并且有根有据？不要说我等凡夫闻思佛法时心中会常存疑虑，就是文殊化现之宗喀巴大师在研习中观正见时亦饱受疑虑的折磨。这可能是我等“知识分子”的特点：当我们欲生生世世全力实践一种理论时，总是难以忍受这种理论可能存在的内在矛盾。
    话归正题。在印度、汉地和西藏，教内关于中观和如来藏两系的争论恐怕已有千年历史。时至今日，争论还在继续，成为一大公案。这一争论有时甚至超出了教义论战的范围，而通过政治力量以强制手段解决分歧，可见这不是个轻松的话题。
    记得月称论师曾说过（大意）：最不可思议之事是诸法皆空无自性，而善恶因果却丝毫不爽。对本人来说，轮涅一切诸法皆无自性之缘起，而众生烦恼身心之中却具足如来智慧德相（广如《大方等如来藏经》所说），曾更加不可思议、更加无法理解！按照佛法的缘起论，众生因于无明，造诸恶业，流转六道，受诸苦恼；而如来以菩提心为父，以般若为母，修习六度万行，成就胜法身及胜色身。如宗喀巴大师所说：“此复观待至心定解世俗因果，从如此因生如此果，胜利过患信因系，即于尽所有性获得定解；及由至心定解诸法皆无自性如微尘许，即于如所有性获得定解。”本人虽于尽所有性和如所有性均获得定解，但对众生烦恼身心之中会有如来之净果——亦即众生即如来藏——却无论如何无法生起定解。此一疑虑折磨本人多年，其中之苦想来夜叉兄定能理解！
    在上师三宝的加持下，本人有幸得遇华严宗初祖杜顺大师的千古奇文——《华严五教止观》。杜顺大师在大藏中只留下此一篇署名短文，但依本人之见，仅凭此一短文，大师便足以独步中外古今！
    大师在“华严三昧门”中，首先抉择了缘起正见，其宗旨与龙树、月称和宗喀巴大师等全不相违。以缘起无自性之中观正见为始点，大师开示了进入事事无碍、周遍涵容法界之无上窍诀：“问如是见已，云何方便入法界耶？（zf注：如是见者，即缘起正见。法界者，即事事无碍之法界也。）答言入方便者，即于缘起法上，消息取之。（zf注：入事事无碍法界之方便，全在缘起法之法性之中，而非从缘起法以外之任何别处求得。）何者？即此缘起之法即空无性，由无性故幻有方成。然此法者即全以无性性为其法也，是故此法即无性而不碍相存也。若不无性，缘起不成，以自性不生皆从缘故。既全收性尽。（zf注：无性者，即无自性。无性性者，即无自性性。此无自性性，如来于《解深密经》中称之为真如、圆成实性，亦即只有缘起法之无自性性方为法尔圆满成就的真实性。）性即无为不可分别，随其大小性无不圆。（zf注：此一句乃关键中之关键。性者，即无自性性也。此无自性性乃不可分别、不可分割之无为法。一切缘起之法，无论其相有何差异，或大或小、或过去或未来、或色法或心法、或轮回或解脱，其无自性性不但全无丝毫差异，并且绝对不可割裂。）一切亦即全性为身。是故全彼为此。即性不碍幻相。所以一具众多。既彼此全体相收。不碍彼此差别也。是故彼中有此。此中有彼。（zf注：一切亦即全性为身者，无自性性正是法身也。彼中有此、此中有彼的原因正在于缘起法的无自性性。）”
    杜顺大师以缘起正见为基石，以缘起法所显现之无自性性这一无为、不可分别、不可分割的法性为跳板，一步跨入此中有彼、彼中有此之事事无碍、重重无尽之法界。此时如以众生为此，如来为彼，则众生烦恼身心之中有如来智慧德相便为水到渠成的结论，以此中有彼故。杜顺大师上述见宗最为奇妙之处在于，如来藏不但与缘起正见无一丝相违气息，而恰恰是缘起法法性之所使然。未悟如来藏者，难说已全面、深刻地悟入缘起法之实相。由是方真知佛不妄语，对如来宣说之如来藏了义经典生起无疑定解。杜顺大师于本人的恩德大矣！
    《华严五教止观》实为解决中观与如来藏两系千年之争、打开两者圆融之门的金钥匙！本人视之为如意宝，本不欲将其奥义轻示于人。然见夜叉等诸兄为疑虑所困，我与兄等同病相怜，故将杜顺大师的千金之方，连同自己的心得和盘托出。
    一千四百年前，文殊师利以杜顺大师之身，示现于我中华，为利益后学，留此宝典。然我等众生，由诸业果劣故，致使法义隐蔽不现已久矣。（事实上，从三祖法藏大师起，华严宗之法义便开始有了微妙变化。）今值佛法复兴之机，大师之法义重现于世，万望诸位努力修学，早日成就，利益一切。
    书写至此，泪如泉涌，不能自制。停笔。
    （此文完成于9月11日，但未能发表，拖至今日。）
    2001年9月15日

    智行：
    欢喜赞叹并随喜并求教；几天没上论坛，今读善知识之文，甚感踊跃欢喜。后学对华严宗了解不多，稍涉天台，常闻台宗大德赞叹杜顺大师乃文殊再来。今见其论及善知识的解说非常钦佩，望善知识常来此指导吾等后学。后学十分喜欢慧思禅师之《大乘止观法门》和楞严经，从中所学所见与善知识所言乃一同气氛，但在行门尚滞门外。请善知识指教入行门之方便。后学顶礼！

    zf：
    本人对天台了解不多，但天台止观的大名却如雷贯耳。
    其实止观两门乃佛法各宗的共道，无论显密。大止妙观实为佛法金翅鸟的两翼。
    广义的止，并不仅是去除妄念，而应理解为去除干扰正念的妄念，诸正念中以菩提心为最尊贵，故入行之门以修习菩提心为重。
    网上有寂天菩萨的《入行论》（索达吉堪布讲解）望仔细研读。

    问：
    凡夫能去除干扰正念的妄念吗？

    zf：
    能！靠出离心和菩提心！

    济法：
    同各位仁兄切磋；小弟见各位仁兄之研讨实在是深奥，若没有高深哲学等理论功底想修佛恐怕见之却步矣。然若不是研究，却想实修，我见如此就太苦了。我闻大道至简至易，修炼直指人心。我理解只要时时审视自心有何烦恼有何牵挂，统统放下，就是在修吧。明了四圣谛八正道就足以让人随遇而安，逆来顺受，灭因缘，心坦然。自自在在圆通无碍。
    修佛本是要解脱，自在。那样耗精费神地深纠在里边，不是解而是缚矣。都知佛说万法皆空自性圆满，何必在理论中困扰自己呢。心在修，诸恶莫作，诸善奉行，自心清净，不受外扰，慢慢磨炼，除心尘垢，持之以恒，自性终会显现，光芒四谢。
    我见“科学与佛学”网址上济空兄贴的“十度歌”就足以让实修者警以审心，据此精进实修了。
    当然闲暇之余多读理解佛经是好的，目的也仅在于有助解执，指导实修，否则就无意义了。
    我想如果把修佛搞的非常晦涩难懂那就会使很多众生受阻了，这恐怕不是佛的初衷了。
    小弟愚见，与各位商磋矣。

    zf：
    一个建议；济法兄的建议很好。在我等目前关于见地方面的讨论告一段落以后，能否将话题转为交流修学“诸恶莫作，众善奉行”等方面的体会上？
    古今大德们在见地上可能并不完全一致，但一共同之处是大慈大悲的心怀和为众生甘入地狱的行愿。与智慧相比，我等今人在这方面的缺陷尤为严重。真学佛者应切记：大悲之方便和无我正见两者缺一不可！！！

    1234：
    仔细重读；原来重点在通于因果的法尔法性，表达所见角度的确别致独特。
    法界法性，法住法位，佛以智诠，智之所成为“有习非无习”（阿含佛圣量语，见尽智经），非先天具有（种子可具非果实本具也，性不属修，道属修也／认识的有为改造），然而智证法尔，如来藏真义，为真理的本然（此“悟”则大家本无争），而认识真理的可能性（佛性）是无漏智种的隐含，皆非佛智慧功德身之先在本然（有谬）也。说到底还是智如的非一非异，不容偏执，如是而已。

    二麻子：
    嘻嘻，您还是有认真二字的。虽然开始时毛躁了一点点。佛法无多，嘻嘻，就这么些。但别出角度的能有多少人？

    1234：
    鄙人不只一贯“认真”，还一贯“执着”问题得很，发了不少帖子讨扁，麻兄都少开金口，大概嫌对牛弹琴白费劲吧？
    人最难自觉其非，前段我花了不少“油漆”探讨经验论、方法问题。就等各位挑刺，我可没有挑衅异见的动机，只想遵循思辩的理性原则：分歧第二，讲理第一，能说服我者，可以为我师也。
    在下烦恼，但非固陋宗派、面子之徒，因此认知立场每有开放的动变。麻兄授受一点骨髓如何？

    二麻子：
    嘻嘻，您可是知道的……若是对牛弹琴，不是牛的过失，是弹者的过失。嘻嘻……
    麻子没有什么，看到能插上话的地方就插句而已。你这样准备这样做法，总会得到正法的。剩下的就是在积累里等因缘现起。就这么简单。嘻嘻。

    savelife：
    感谢善知识的法施。
    后学有几个问题请善知识不吝赐教：
    一、解杜顺祖师意是否要像您一样以获得尽所有性和如所有性之定解为前提？
    二、此华严止观是否亦有次第禅的心系所缘、由止入观、止观双运的一系列传承次第可得？
    若不是，则既云止观，吾等凡夫当如何契入？
    若是，则能否请善知识开示其中次第并教授吾等凡夫？
    后学愚钝，请善知识指教！顶礼致谢！

    zf：
    S兄，如来藏一系的法义甚深，我等凡夫若不在缘起正见上狠下功夫，极易将法执搀杂进去。古德讲解中观者，多不讲如何从中观进入如来藏；讲如来藏者又多未讲如何与中观衔接。杜顺大师的独到之处是提供了一条贯通两者的途径。从这一点看，如未于中观正见生起定解，很难领悟杜顺大师密义。
    杜顺大师之后，华严宗其他祖师给出了有次第的止观修法（可参看大藏）。
    我本人的修习方法亦不外见修行三个方面：见：于正见生起定解；修：定中思维法义（观察修），进而安住法义（安住修）；行：四威仪中不离法义。我本人目前尚为初修，并无很多经验可供交流，更莫谈传授。

    常青：
    请教善知识兼请教麻叔，虽然大乘起信论中提到：“如来藏”那本具有不可思议妙用的功能，一念不觉而转“本有智光”成为晦暗的藏识（阿赖耶）因此便“无明不觉生三细，境界为缘长六粗”“构成”后来较粗的执：日月星辰和众生的妄见，这也许就是楞严经中所说的“于无同异中，炽然成异”……
    但是这些经句颇难理解，我想问的是：如果说，实际上所谓“众生”，包括“执”众生的那一念，本身也必然是依“圆成实”而现的一种遍计执的妄相（圆觉净性现于身心随类各应？），好象楞伽经中说的“识流住”而导致“相住”，因此而执持的三界妄相，恰恰并不能说是有个“执者“所执出来的……那是不可思议”胡来胡现“功能的“妙用”罢了。那么我的问题来了：
    一、如果仅从因“执”恰是妄，因此却非有个“执体”可得，自然也非有个“所执”的对象可得。好比两根共生的芦苇，一边不在，另一边自然也无从谈起。这点来说，是否就是一切诸法的确是“从本以来，常自寂灭”的意义？
    二、实际上在能所不立（也许是“本”不立）的情况下，在实际的修行过程中，当然并非是混混无知，但却也非“了了常明”（好像有个能明的明体隐含）所能形容，是不是就是在经中所说的“面对色而没有色的认识，面对受想行识而没有受想行识的认识（见摩诃般若波罗蜜经）”以及“住妄想境，不加了知，于无了知不辩真实”的含义相同？（这点不知当年禅宗的道信祖师和牛头山的法融大师关于“观是何人，心是何物”那段流传千古的精彩对白的意义相同否？）
    水平有限，我的问题可能太凌乱无章。

    zf：
    回常青兄，楞严、楞伽、起信等经论本人下的功夫不多。原因是文字艰辛，又无大善知识指点，恐错会圣义，耽误了慧命。佛法正见方面的修学本人集中于中观方面。
    对于“一切诸法‘从本以来，常自寂灭’的意义”从中观角度看应理解为：一切诸法，皆为缘起，缘起故无有自性。常自寂灭的含义是自性从未生过，故自性寂灭。
    对“面对色而没有色的认识，面对受想行识而没有受想行识的认识”，我的理解是：面对色而没有对色的自性执，面对受想行识而没有受想行识的自性执。诸法的显现并无过失，问题出在法执上。
    “住妄想境，不加了知，于无了知不辩真实”这句难解。能否勉强理解为：住境而不妄想；若不妄想，便是智慧到彼岸，莫于其上再起分别。
    我的上述解释与中观宗义不会有大的相违，但是否符合经意没有把握，毕竟文字上相差甚远。
    （这点不知当年禅宗的道信祖师和牛头山的法融大师关于”观是何人，心是何物“那段流传千古的精彩对白的意义相同否？）
    禅师们的语录离开当时的人物和背景，理解起来更加困难。
    知难而进并不总是勇敢之举，有时知难而退更加明智。

    1234：
    然则无自性性有自性乎？乃普遍相应之理耳。本意唯诸法皆无可得，无自性性即毕竟空性、无可得性，如何有一摄无穷之“无自性性自性”？名字骗死人乎？
    无自性性者，诠诸法之普遍皆无自性也，云何此普遍空寂为一自性（事）乎？印度诸贤，皆谓法性非“法”，与法非一非异，宗大师之中观讲二谛，云若法法性为异、为一，各有5种过失。ZF先生高论，并非某宗之定见也；而一般中观、唯识家恰以ZF此悟为真常系贤首等宗之最大误解，能有超越此者乎？

    linden：
    无自性性应该是“法性”而不是“法”吧？看不出把无自性作为一种实有的法啊。

    zf：
    1234兄，兄所提问题甚好，恐怕许多人有类似的疑问。现就自己的理解予以回答，不当之处敬请指正。
    一、无自性性为一法吗？
    回答：请兄仔细研读杜顺大师的著作，大师从未说过无自性性为一法。本人在注释中说：“此无自性性乃不可分别、不可分割之无为法。”此说不够准确。准确的说应为：“此无自性性乃无为、不可分别、不可分割。”因此无自性性乃法性而非法。1234兄所言极是。
    二、无自性性有自性吗？
    有无自性均相对法而言。无自性性乃法性而非法，故“无自性性是否有自性？”并非正问。
    三、是无自性性摄一切法吗？
    兄说：“如何有一摄无穷之‘无自性性自性’？名字骗死人乎？”还望兄仔细研读大师著作。大师的本意是：一切法因其法性为无自性性，而此法性无为、不可分割，是故一法摄一切法。注意！是一法摄一切法，而不是无自性性摄一切法。两者差异望兄用心体会！
    四、杜顺大师著作为真常系吗？
    兄说：“ZF先生高论，并非某宗之定见也；而一般中观、唯识家恰以ZF此悟为真常系贤首等宗之最大误解。”事实上，华严一宗，自三祖贤首大师后，法义发生了微妙变化。而华严宗常被称为贤首宗，可见贤首大师的影响之大。其他宗派对华严宗的评价多是针对贤首大师以后的法义。兄若有兴趣，请仔细比较杜顺大师与贤首大师教法的区别。万莫人云亦云。

    1234：
    我不曾详读杜顺著作，而……本人上帖所指乃针对一般匆草沦为世间一元论的性具之谈，本坛某些学长曾把无为法作为真实自性的事体来谈。把法性当作一形而上学的“法”，弄不好就成为不可思议我和宇宙梵本的翻版。
    也谈如来藏说的理解：
    一、有认为二期说法了义，三期说法不了义，有理；既然二期空性正见得到，就可把如来藏作为摄机之别谈故，于畏怯无我者巧施设故；如来藏是能诠，毕竟空、无所得、第一义为所诠故；
    二、认为空性、如来藏皆了义宗，有理；如宁玛派，其本于自空中观的应成见故，随顺不违离戏毕竟空故，即空性、如来藏皆诠空性故；
    三、认为毕竟空不了义、如来藏为了义的某些真常判教观点，错误；以其如来藏（内密）与性空（外门）非等义趣，即对于彻底的法无我性作了空过头的理解，反而在法空后面转出一不空的妙有性体来支撑这些空的法。一些祖师基本把佛学等同易学，易解禅佛，如来藏乃无极太极的玄体，得一漏万；明清以后更成为三教同源的滥觞；
    最后请教，如果因诸法具无自性性就能以一法摄无余他法尽的逻辑——铜、铁、瓦、石因皆无自性，如何推理出就能互具？一般法的显现有四缘具足等义，且因缘作用有程度差别，有些缘太远，根本不足以影响关乎您考察的某一具体的法之生灭。比如我现在种花的念头变为种豆，能影响孔子出生那天鸡下蛋的个数吗？超验的一具一切对普遍联系过于夸大，非缘起的先天性具对差别／影响事实的缘起说反而相违，成了空洞、无益解脱的玄学无疑。您如何看待这个问题？

    zf：
    1234兄，一法摄一切法这一结论实在惊人。但依《华严经》“一尘中有尘数刹，一一刹有难思佛”的开示，法界的现相确应如因陀罗网般重重无尽、事事无碍。试想，法界的实相若非周遍涵容，如来之“于一法中解无量法，无量法中解了一法”的一切种智便缺乏存在的依据。古德中以“诸法唯心，心本无碍，故法亦无碍”来理解华严境界者不乏其人。但此说中如何安置此心而不沾常见、一见便成为问题的关键。
    若以“诸法因缘起，诸缘亦依他缘而起，如是展转，以至无穷”来理解因陀罗网境界亦会遇到巨大障碍。以木、热、氧为缘生火为例，木等为火之最近缘，但此时若说木中有火、火中有木，便会为天下人所耻笑，为因中有果、果中有因的陷阱所缚。同样，“一切众生皆有如来智慧德相”等如来藏一系的法义为原始佛法或中观宗所不容的一个重要原因，便在于此说有“无因而有果”之嫌。再如兄所说，铜、铁、瓦、石何以互具等都不易通达。正因如此，中观与如来藏之间的鸿沟极难逾越。那些急于融通这两系者，多难逃脱为中观宗人所嘲笑，因其错会空义故。若依宗喀巴大师的说法，便是空的不够。
    杜顺大师从中观进入华严境界的唯一跳板便是缘起法的无自性性。何以我等虽知诸法皆无自性，但仍然无法通达诸法互具？其根本在于我等于无自性性这一法性起了分别！！！以甲乙两法为例。当我等谈及甲乙两法时，甲乙两法的法性——无自性性通常会以这样的方式在我们的心中出现：甲的无自性性与乙的无自性性两者完全相同。事实上，问题就出在将甲乙两法的法性亦分为二。杜顺大师发出的狮子吼：“性即无为，不可分别，随其大小性无不圆”当令我等猛醒！对此法性的任何分别都是无明。据本人陋见，释迦牟尼佛于般若经中反复强调“不分别”的对象，恰恰就是缘起法的法性，而不是缘起法本身。杜顺大师进一步指出：“一切亦即全性为身，是故全彼为此。即性不碍幻相，所以一具众多。即彼此全体相受，不碍彼此差别也，是故此中有彼，彼中有此。”
    古德中能贯通中观与如来藏而不沾一丝常见、一见者鲜有其人。因此。我于杜顺大师生起无伪真佛的信心。

    恭敬：
    如此而论只有无为的性，没有无为的法？对否？

    zf：
    同意。

    恭敬：
    那么为什么，《金刚经》云：“一切贤圣，皆以无为法，而有差别。”，此处是善巧方便吗？

    二麻子：
    嘻嘻，是您自己心里框住自己了……抽烟喝酒是有为法，这不应有问题吧。戒烟呢？戒酒呢？为了什么了？不过是没做什么罢了。嘻嘻，但你能说戒烟跟戒酒没差别吗？所断不同，所断次第不同，一样可成为差别的！嘻嘻。

    zf：
    回恭敬兄；“无为法”的含义，本人理解即为缘起法的法性——空性。空性本非法，假名安立为法。
    《金刚经》这句话的含义，本人理解为：一切贤圣的修证程度，借以对空性的证悟程度来区别。
    上述理解，谨供参考。

    1234：
    我是有针对的设问，因为中国话一词多意，性有多解，就让ZF先生多辅导一下不是大家更透彻吗？
    如果把法作A，自性为B，A无B（否定句），或A有“无B”性（肯定句），其实都一样说的是：A无B、或无B的A，经由语言的表述不可能多出一个事实具体意义的C法　——“无B性”来。
    另外关于普遍联系的一问见我另帖。而ZF高人是哪位大德，能否介绍一下喔？

    zf：
    zf绝非大德，1234兄对法义的把握，令本人佩服！
    的确，佛经是从国外翻译而来，表达上肯定存在诸多困难。如读过译成英文的佛经，就会发现不可避免的带有基督教的味道。研读佛经，对字义的准确把握极难，这是时常困惑我的地方。
    从兄的讨论中感到，兄在原始教法上颇有造诣。这是通常学大乘者所欠缺的。大乘的空性见应与原始教法一脉相承，若在学者心中有相违之处，学者应非常仔细的检讨。
    本人绝非大德，菩提道上刚刚上路，因与诸兄同病相怜而交流体会。蒙诸兄厚爱，在此一并顶礼。
    在未遇杜顺大师之前，本人固守缘起无自性的正见，对如来藏一系的法义敬而远之。
    但本人对见地沾常见、一见的大乘行者亦十分尊重，原因在于菩提心。行者虽在智慧上暂不究竟，但菩提心的力量终将使其破除无明。故依于因缘法则，本人重视菩提心胜于智慧。

    博为：
    自学佛以来总在为第一义的不同见解，烦恼思考。今日听善知识开示，豁然开朗，法喜不断。
    再提一问，请善知识不以佛法做人情，赐我正见。
    无自性和觉性的关系是什么？是否是一体两面的关系。或能否理解成无自性是理，觉性是事，原本就是一回事。既然法性不可以分割，觉性亦不可以分割，若执着觉性各有，即执着我相。对否？若执着觉性为一，则和大梵的见解有相似处，但毕竟有本质区别，本质区别在于觉性（或称无自性，或称法性）无一切相，远离一切妄想。它既不是实存的物质，也不是虚无的顽空。毕竟无有所得。

    zf：
    博为兄，兄和夜叉、成军等讨论的帖子，本人已经拜读。本来我那篇“致夜叉、成军等诸兄”帖子的名字应为“至夜叉、成军、博为等诸兄”，但当时忘记了“博为”是哪两个字。抱歉！
    在尝试回答兄所提问题之前，先请兄回答我两个问题。
    一、在兄心中，所谓“觉性”的确切含义是什么？
    二、佛法中对法有多种分类，最简单的分法是色法和心法两大类。心法又分成受、想、行、识。这就是所谓的五蕴。关于五蕴的定义，教内各派的理解无大的差异，这可以作为我们讨论的基础。请问：“觉性”与受想行识是何关系？
    若无共同基础，各说各的，结果不会好。

    博为：
    感激善知识，回答如下。我把觉性理解成佛经中的本觉妙明。此觉性和一切法之间是非即非离的关系，一切有为法因它而显现，如果把觉性比作镜子，一切有为法可以比作镜中的影子。
    （关于：“觉性”与受想行识是何关系？）
    答善知识，受想行识不是觉性，但受想行识从未离开过觉性，它们之间是非即非离的关系。
    我自学佛以来，深深有体会，单靠自己阅读书籍，时常理解有所偏差而不能自知。每每发现自己的观点中的漏洞，虽不肯轻易放过，但往往也无力通解，今日逢善知识亲自教诲，实在欣慰。希望善知识，能不留情面，指正我见地上的偏差。感激！顶礼！

    zf：
    不是回答的回答。博为兄；佛法大海，深广无边，非我一凡夫智力所可测度。
    本人学佛，常读的经典为阿含、般若、华严等经以及中论等，对楞严、楞伽等经鲜有涉及。这两系的经论对我等未悟之人来说，确有难以通融之处。
    困难之一来自语言，不知其精确含义。例如，如兄所引，“当知如是精觉妙明，非因非缘，亦非自然，非不自然，无非不非，无是非是，离一切相，即一切法。”此中“精觉妙明”是法还是法性？从字面上看，好象为法。但若是法，此法非因非缘，这便于佛法的基本原理——一切法皆因缘而生似有矛盾。
    关于觉性，兄说：“受想行识不是觉性，但受想行识从未离开过觉性，它们之间是非即非离的关系。”若依阿含、般若、中论等经论，所有法——从无明到一切种智——都为五蕴所包含，五蕴之外无别法。非五蕴所包含的法根本就不存在！《中阿含经》第201中，佛驳斥了人们经常对五蕴中识蕴的误解。佛说：“识有缘则生，无缘则灭，识随所缘生，即彼缘，说缘眼色生识，生识已说眼识。如是耳、鼻、舌、身、意法生识，生识已说意识。”兄可仔细研究识蕴与你所说觉性的异同。对识蕴的执着是很难破除的。
    似乎没有很好回答您的问题。但这一问题实在超出了我的能力。

    小夜叉：
    承蒙诸位大德的开示。我在近乎疯狂的阅读和思考中，居然遇到了原本不可想象的切入点，原有的疑虑似乎全部消失了。我深深感到萤火烧须弥的可笑，我意识到，中观和如来藏都是佛菩萨慈悲智慧的了义之说。特别是如来藏、佛性之说的善巧不可思议！佛性即是空性，是约众生之心性而说。有人说，这是真常空与真常心的结合，虽有他自己的用意，然诚非虚言。众生心性本空，即佛性之真空；而此佛性有“胡来胡现”之功能，则为真空之妙有也。这和中观又有什么不同！
    我试着如此理解您引用的杜顺大师的几句话：
    ……
    “性即无为不可分别，随其大小性无不圆。”性即空性。空性如虚空，在圆器则圆，在方器则方，然空性之体非方圆。如楞严云：“随众生心，应所知量，循业发现，宁有方所。”如来藏妙心，纵然天堂地狱，妙性随缘不变。

    zf：
    回夜叉兄。夜叉兄，以下是本人提醒兄宜深思熟虑的若干问题。不必急于给出结论。（茅台、白兰地要上年份才会有特殊的香气。）

    原帖：“我意识到，中观和如来藏都是佛菩萨慈悲智慧的了义之说，特别是如来藏、佛性之说的善巧不可思议！佛性即是空性，是约众生之心性而说。”
    ——何为佛性真义？何为空性真义？两者含义是否完全相同？

    “有人说，这是真常空与真常心的结合，虽有他自己的用意，然诚非虚言。”
    ——真常空与真常心的确切含义是什么？

    “众生心性本空，即佛性之真空；而此佛性有‘胡来胡现’之功能，则为真空之妙有也。”
    ——是佛性（或空性）有胡来胡现的功能，还是心法因空故而有此功能？真空之妙有与真空之幻有之间是何关系？

    “这和中观又有什么不同！”
    ——这和中观之间真的没有任何差异吗？

    ““性即无为不可分别，随其大小性无不圆。”性即空性。空性如虚空，在圆器则圆，在方器则方，然空性之体非方圆。”
    ——能以“方”“圆”来描述空性吗？？？？兄以方圆描述空性，只此一点，我便建议兄应在中观正见上狠下功夫，万莫浅尝辙止，错会空义！！！

    夜叉兄，空性、佛性、觉性的关系希望能深究。空性见说到底是用来去除无明的。依我等现在的程度来审视自心中的无明，应该说比较粗重者还是能够发现的。问题在于对这些可以发现的无明，我们是否花功夫予以去除了？？？这就涉及到实修的问题。我本人决不反对思辩，但反对离开实修太远的思辩。在修行中，通常思辩应该走在前面，但如果实修跟不上，没有足够的资粮作后盾，则思辩就容易出错。所以功夫常常出在戏外！
    许多大德谈起空性见来可能还不能尽如人意，但他们真正令人感动的常常不是智慧，而是高尚的人格和无尽的悲愿。我等当务之急不是加我所长，而应是补己所短。这些内容说起来不那么有趣，但确是命根！
    我与一位夜叉有缘，此夜叉因手持金刚杵故，号称金刚夜叉，亦即金刚手菩萨。愿兄早日亦持此金刚（五智菩提心为其体性），利益一切六道父母。

    二麻子：
    赞叹与感叹。ZF兄剖肝沥胆，字字心血，究其核心，不过佛法“不二”两字。
    这两字，坛上谁没听过？只是从初闻到深入体会，法尔定解，其间不知多少艰辛，不是糊里糊涂就一切“圆融”的人能体会到的。如此深入不舍而来的定解，其力巨大，决非口头圆融之能望项背。实在让麻子赞叹。同样由之而来的却是麻子的感叹，从一般角度来讲，ZF兄所引用的“法性不可割裂”，未必能让很多人真理解到ZF兄在说什么——心血在地，也很容易被当成红油漆的。唉，唉。麻子无话了。

    zf：
    老兄好！多谢老兄鼓励！本不欲将此体会轻示于人的原因，就在于不忍心看到自己的心血被视为红油漆。后见人与我同病，就忍不住了。小弟不敢奢望很多人能从中受益，若能对三五人有真实帮助，即使心血被余人视为粪土亦无憾矣！
    老兄多年于网海泛舟，其中辛劳恐外人难知。近日结识linden等兄，从其言语中可以闻到老兄特有的“血腥”之气，看来兄之心血没有白费，已溶入余人血中。

    二麻子：
    老兄今后常来……利一个算一个了。嘻嘻。麻子杀人杀己的，久了不免血腥四布，罪过罪过。文武之道一张一弛，还望老兄兑添些祥和。嘻嘻。

    zf：
    与诸兄道别！
    本人此次在论坛上与诸兄交流了修学的体会，承蒙各位厚爱，在此一并顶礼感谢！！！
    本人虽为菩提道上的初学者，但亦深知，大乘道的命根为菩提心。本人将暂时退出论坛，专心于菩提心的修学，待将来有体会时，再上论坛与诸兄交流。
    此次来论坛，起因为对《华严经初发心功德品》的讨论，这里将该品经中的最后一四句偈奉献诸兄，与诸兄共勉。
    欲见十方一切佛，欲施无尽功德藏，欲灭众生诸苦恼，宜应速发菩提心。

    2001年9月20日


《中观、如来藏和华严》续谈

    windmills：
    “如来，如来智慧德相，如来藏”是缘起无自性的和一般的定义有不同啊。

    zf：
    生起现行的如来智慧德相的确是缘起法（从大悲之根本生，从菩提心之因生）。
    而众生本有的如来智慧德相（如来藏），不因众生的烦恼为生因而生，但其与缘起法之法性并不矛盾。反而因为众生和如来皆是缘起法，众生才能本具如来智慧德相。

    windmills：
    （以上）而且还有“执彼此为实”的问题，如果这样的话，会出现很多问题，比如，“我中有电脑，电脑中有我”。

    zf：
    上面处处强调“彼”“此”为缘起法，如何能生起“执彼此为实”的问题？不解。
    若依华严境界，的确“我中有电脑，电脑中有我”。但只有在“我”和“电脑”非实的前提下才能成立。
    在《中观、如来藏和华严》一文介绍杜顺大师的教法时，前提只有一个——诸法的缘起性。众生即如来藏是此前提的结论，并未作为论证的理由（前提）。
    关于如来是否为缘起法，我们有不同的看法。
    我未说如来藏是缘起法，而认为其是缘起法之某种属性。缘起法的属性不一定是缘起法，例如，缘起法的法性便不是缘起法。

    windmills：
    我的理解，“以众生为此，如来为彼”，就是有“执彼此为实”的问题，原论中“彼此”是相对的抽象概念，不能拿来类比说此是具体什么，彼是具体什么。

    zf：
    本人认为这里的彼此就是指具体之缘起法。
    杜顺大师文中“彼此”处处所指皆为缘起法。何以兄认为应是相对抽象的概念，不能指具体法？？

    windmills：
    我的理解，“华严五教止观”是从真谛角度来说的。而见你用在俗谛方面，前提结论虽然正确，但对论证过程有些疑问。

    zf：
    如果以1、名言识共许，2、无余名言量妨难，3、无观真实量妨难（格鲁派）这三条作为世俗谛的标准，以诸法之空性为圣义谛标准的话，“彼中有此，此中有彼”的境界，对我们这些初学者来说，的确既不属圣义谛，也不属世俗谛。若一定要用“二谛”的角度观察，华严境界似乎可以理解为“如来的世俗谛”。因为重重无尽事事无碍的因陀罗网境界，非亲证大圆镜智者不能现量尽显。杜顺大师开示之殊胜之处在于，为我等指出一方便之门——以比量的方式对华严境界生起信解。以此信解为基础，积累资粮，以求圆证。
    “中观、如来藏和华严”一文是本人的一点体会，不一定准确把握了杜顺大师的真义。兄直接研读大师的著作最好。

    智行：
    A中有B，B中有A。华严直谈唯心无碍境界，非但吾辈凡夫难知，纵阿罗汉亦不易明了。通常华严之无碍境界可说理法界，事法界，理事无碍法界，和事事无碍法界。理者即真谛，事者即俗谛。理事无碍法界即真俗二谛圆融无碍之不二法界。事事无碍即俗不碍俗，法法互融，重重无尽，小能包大，一多互融。
    不二境界，没有外道和如来的障碍。不仅如此，华严境界连水火亦不相妨碍，不妨水中出火，火中出水。凡夫可以靠观想或作梦来现这个如幻相，独头意识也很不可思议啊！当然这还远不是华严境界，只是可以管见唯心一斑，华严要有断无明惑之功才能自在受用。我们未入不二境界，所以样样事皆不容，当然小不包大，水火不容，这是我们唯识所现境界。我们的意识里是小不包大，水火不容，境界也如此，障碍从这来。唯心境界里，没有这些意识，没这些成见和见执，所以一切运用无碍。
    所以师兄说“从俗谛上看，就会有很多奇怪的结论”，这主要问题在于以我们的唯识所现境去体味华严唯心境界。总之，不能说华严五教止观只说真谛。
    又忽有人问曰：水火相容，岂不水救不了火，华严岂不成火海或汪洋。此问又是以唯识所现境去体味华严唯心境界。唯心境界，水火皆随心应现，本自安立，没这些问题。若要火灭，不用一滴水，火亦得灭。说到底，只有唯心可说。
    注：华严里的这个“唯心”与一般所说“唯物”相对之“唯心”名同实异，不可不鉴。彼“唯心”者实是执幻识为本，正为大乘所破。

    维京传说：
    俺要仔细琢磨一下。对俺来说，最难以理解的是如何在无相中安立菩提心，如何在万法不染、无来无去、本无生灭中树立大悲心。
    悲智又如何双运？
    普贤行愿品说：生死旷野大树王，诸佛菩萨为智慧华果，众生为树根。如以大悲水饶益众生……这段话揭示了佛菩萨与众生的关系，大悲是沟通这种关系的方法。
    密宗也说，无大悲为根基，脉结难以打开，无上密修行不成就。就是在技术上，大悲之重要性也不可忽略。
    可是，此中如何与甚深中观义协调起来？
    所谓观众生为无始劫来父母，以此来修大悲，这是个方便入门法。但也可以观成众生无始劫来皆为仇敌啊，难道是为了因果而观前种，不观后一种？

    智行：
    会归到心性上来，中观从来就不碍大悲心，应该说大悲心本来就是中观的内容之一。只是中观被许多人说走样了，用一个“毕竟空”把中观给打发了。既然是“中”，则即空有、而不落空有，说它是“毕竟空”时应知其“毕竟不空”，所谓真空不空是也。若不能把握这“中”，则应宁可偏在“有”边，起出离心、大悲心、顺俗菩提心等。偏空则不是执断，就是落在空穴里，灰身灭智，造极不过是定性阿罗汉。
    诸佛所开显无非是唯心之大用，心本来就可用，众生天天在用，此心体从来与佛心无异。只是我们凡夫用时把如幻随心境执著成心外实有之法，起种种分别，生种种烦恼执著。执著故生与执著相应之境界，比如认定墙是实有，不能穿越，则不能穿越墙壁，自作自受，作茧自缚。今虽信墙是幻现，未必真信，执著习气还在，当然也不能超越。所以第一先明境界乃是唯心之幻境，无有实体，亦非是无（心不断灭故），故可任意起心之用。起心之正用曰“自利利他”，故不论悟否，先起出离心、大悲心、顺俗菩提心等都能自利利他，行者应先从此入。达空性者则知一切如梦幻，了不可得，虽了不可得，“不妨大作梦中佛事”，并且这才是空性之正用。一方面空性、如幻之理性并不妨碍“梦中佛事”（吾辈只有知幻、不知幻之别）。另一方面，吾辈无明习气非一日即断，福慧也难一日而圆，故应起如幻之薰修，大修特修，待习气断尽，一切见执皆舍尽，一切无执，一切无碍，则成大自在。然此心亦未变得一分，但吾辈已全能用心，无事不办，此即如来果德。回头再看众生，原来众生本来就是佛，带著如来法身在轮回。
    从此若解入，则中观，唯识，如来藏，法界唯心等体系之间无有一字在打架，信不信由您。

    zf：
    插几句，维兄的困惑，本人亦曾遇到过。不体验此种困惑，无法感受清净正见的重要性。
    而正见的关键，依宗喀巴大师的开示，是准确把握肯定和否定的界限。何者应予肯定——法的缘起性；何者应予否定——对法的自性执，即无明。在这里，肯定与否定之间不但不互相矛盾，反而相辅相成。一切法因依诸缘而生起，故绝无可以离开诸缘而独立存在的自身属性（自性）；而恰恰因为诸法皆无自性，则一切缘起才可能成立。
    对缘起之法，缘起缘灭，故如来说“一切有为法，如梦幻泡影，如露亦如电，应作如是观。”梦幻泡影者，是说缘起之法并非实有。但非实有之法并不是没有作用，不能因其无自性而忽视其作用。比如我们一天不吃饭便饿得慌，虽然心里明白，此饿是依缘而起，但能否因为认识到此饿的缘起空性，便不再找饭吃？如来在开示《金刚经》之般若妙义之前同样要进城乞食。又如，孩子在梦中遇险而呼救不止，旁边的母亲能否因为孩子的痛苦是梦中之事，而欣然视之不理？菩萨对众生之苦，即如慈母视孩子梦中之苦一样，绝不因其是梦中事而置之不理。
    如果菩萨对世尊开示之如来藏说，能生起信解，则悲心更易生起。此时菩萨视众生真真是捧着金饭碗要饭！本具如来智慧德相的众生，却因无明妄想而不能证得，于六道中枉受诸苦，这真正是世间第一冤枉事！菩萨遇此不平之事，绝不忍袖手旁观。
    依本人的一点粗浅体会，如果悲在智中无立足之地，一定是智方面出了问题——过度否定，即否定了缘起法的作用。故正见之确立，不可不十分小心。

    反省99：
    （编按：关于《中观、如来藏与华严》一文），不知ZF师兄文中所指的“无自性性”是否就是六祖惠能大师开悟时所说的“何其自性能生万法……”的“自性”？或是如来藏的体性？

    zf：
    此“无自性性”就是缘起性空之“空性”。至于六祖惠能大师开悟时所说的“何其自性能生万法……”的“自性”之确切所指，本人不知。
    在讨论“非缘起与无自性”时本人亦有一贴涉及如来藏与缘起互不相违，可参考：
    佛性一词多义，包含空性、法性、如来藏等义。对于空性、法性义来说，空性非法，谈不上是否缘起。
    对于如来藏义来说，依《如来藏经》，众生本具的如来功德非修因所生，但如来并未因此断言其为非缘起法。依华严宗古德开示，众生本具之如来藏与缘起法并不矛盾。

    本人猜测，如来开显如来藏一门，本为信根成就者修习，因《宝性论》中开示，十地菩萨亦难全解如来藏。
    但如学人能对众生本具空无自性之如来德相（即如来藏）　深心信入，则不动摇信心生起之时便是得大成就之日，其功德详如《如来藏经》所宣说。


从“无性性”推导到“彼中有此，此中有彼”

    asu：
    请问ZF兄，从“无性性”如何推导到“彼中有此，此中有彼”？
    ZF兄，您是“过来人”，是从对中观和如来藏的矛盾中走过来的，所以，代表网友们，请您谈谈。
    一、我反复思考“即于缘起法上。消息取之”这段，但不得要领。句句中间的跳跃性思维很多。能否请您简要地复述其关键性的逻辑？
    二、还有，“彼此相收”的“收”字，是什么意思？是否是“包含”，“摄受”的意思？
    三、通常所说的“如来智慧德相”，是常，还是无常？是真常，还是缘起？
    四、杜顺大师也说“性即无为。不可分别”，既然是无为法，如何又有“性具”和“性起”的理论？六祖更是说“能生万法”！
    罗里罗嗦，请您慈悲指教。

    zf：
    “一、我反复思考‘即于缘起法上。消息取之’这段，但不得要领。句句中间的跳跃性思维很多。能否请您简要地复述其关键性的逻辑？”
    ──“消息取之”，这里的“消息”二字，我理解为“总机关”、“总窍要”的意思。即入重重无尽法界的根本路径是缘起法，从此门得入者，后面的所有结论都不会与诸法缘起相矛盾。
    “逻辑”的关键是“性即无为，不可分别，随其大小，性无不圆”。因为法性的这种无为不可分别的属性与我们常见的五蕴等有为法的差别太大，接受起来确实困难。但这就是诸法的真实相，无奈，我们只有努力忏悔业障，尽力随顺。

    “二、还有，‘彼此相收’的‘收’字，是什么意思？是否是‘包含’，‘摄受’的意思？”
    ──是。
    另外，您可以参考“十玄门”中的“显”、“隐”。

    “三、通常所说的‘如来智慧德相’，是常，还是无常？是真常，还是缘起？”
    ──当然是缘起法。

    “四、杜顺大师也说‘性即无为。不可分别’，既然是无为法，如何又有‘性具’和‘性起’的理论？六祖更是说‘能生万法’！”
    ──这是个好问题。
    我对“性具”的理解是：因为一切法都是缘起法，而缘起法的法性无为不可分别，因此任一缘起法都同时具足一切法。特别注意，不是无自性性具足一切法。在人们常说的“一即一切、一切即一”中，“一”不是指“无自性性”或“真如”，而是任意“一”法。
    的确有人将这里的“一”理解为“无性性”或“真如”，在下认为这是误解。
    关于“性起”，我的理解是：不是说法是从无性性中生起，而是说因为无性性的无为不可分别性，重重无尽、事事无碍的华严法界才能生起。
    至于六祖之“何期自性能生万法”说，还是请熟悉禅宗的大德开显其真义吧。

    “罗里罗嗦，请您慈悲指教。”
    ──哪里谈得上指教！既然大家都思考相同的问题，彼此交流体会是理所应当的。

    吉祥如意！


胜法身及胜色身

    铁桥：
    请问什么是如来的智慧德相？是因缘成就的吗？

    zf：
    经中常以十力、四无畏、十八不共法来概括如来的智慧德相。《华严经初发心功德品》中说：“诸佛色相庄严身，及以平等妙法身，智慧无著所应供，悉以发心而得有。”可见，如来的智慧德相为因缘所成就，这一点是肯定的。

    铁桥：
    “而如来以菩提心为父，以般若为母，修习六度万行，成就胜法身及胜色身”，胜法身及胜色身也是因缘所成的，也会坏灭吗？

    zf：
    法身的本质是缘起法的法性——无自性性。此法性，如来若出世若不出世，无有丝毫变异。（注意，此处之法性与外道之不可思议、常恒不变的本体全然不同，当用心体会。）此法性非因缘法，但不离因缘法，须依因缘法而显。但对此法性的证入，亦即成就法身，确是因缘法。胜色身依大悲心（化身）和无量功德（报身）而成就，其缘起性不必多说。

    缘起的本意是说，诸法依因缘而生起、依因缘而存在、依因缘而坏灭。如来法身依智慧的因缘而生起，如来色身依大悲的因缘而存在。若如来智慧灭，则法身灭；若如来悲心行愿灭，则色身亦灭。如来绝无觉而再迷的可能，故如来法身不会灭。（但莫因法身不会灭而沾常见。）如来悲心和行愿亦为缘起法——依众生为缘而生起。若众生灭，则悲心行愿亦灭。但《普贤行愿品》中分明指出：虚空界尽、众生界尽、众生业尽、众生烦恼尽，我愿乃尽，而虚空界乃至众生烦恼无有尽故，我此行愿无有穷尽。可见，只要还有我等一个有情在，菩萨的色身便不会消失。菩萨的这种发心正应是我们的学处。

    铁桥：
    如来藏按字面去理解是什么意思？是指从中能生万法吗？所以和空性是一个意思吧。

    zf：
    “如来藏”中的“藏”字是胎藏、胚胎义。从字面理解即一切众生皆含藏如来智慧德相。欲理解其与空性的关系，还望仔细研习杜顺大师《华严五教止观》。

    铁桥：
    阿弥陀佛的西方极乐世界也是因缘所成的吧，也会坏灭吗？

    zf：
    如果众生灭尽，极乐世界亦无存在的意义了。请兄放心，只要我等一人还在，阿弥陀佛便不会扔下我们不管的。


缘起与遍知

    zzzm：
    佛能一念知无量劫，于一中解无量，那是因为佛是以“现量”智观察一切，“一念”与“无量劫”等，无有时空限制。
    而众生被时空所惑，所有因缘果法的演化总不自觉的打上时空烙印。
    所以当把佛的境界纳入自己所执的时空体系去考察时，自然就会有宿命不宿命之思考。
    所以，在后学看来，这类问题应属“非为正问之列”。虽然自己对此也有疑惑。

    二麻子：
    这个看法比较好。认识到自己的限制，认识到用自己有限制的立场去度量诸佛，怎么说都是没法全面的。

    chenge：
    华严经十通品第二十八中的第四知尽未来际劫智神通一段里，意思是菩萨能够知道未来的众生的一切变化，菩萨是全知的，似乎有点宿命论的味道，感觉有些讲不通。换句话说：人有自由意志吗？

    zf：
    我这里倒是有个一个看似矛盾“逻辑”：若如来有知尽未来际劫智神通，则诸法必定是缘起的；若诸法为非缘起，如来便不可能具有了知尽未来际的神通智。
    在下的理解如下，若一切法皆是缘起法，因缘起法空性的不可分别性，则一法必是一切法。此一属性便使如来“一中解无量，无量中解一”成为可能。这里的“无量”包括了三世一切法，因其自性无不为空故。若法非缘起，如来能否自知恐怕都成问题。因为进入圆顿大乘的门径恰恰就是缘起。因此，缘起与圆顿大乘无丝毫相违气息。


谈中观与如来藏

    谈中观与如来藏

    zf

    明兄，在下注意到您的“一直有个问题”一贴，觉得这的确是个很大的问题。本人对这样大的问题并没有有把握的见解，担心自己的胡说耽误别人，因此选择了沉默。现在既然被兄点了名，只好谈谈自己的一点看法，供兄参考。
    学完初等数学后，不想学高等数学的人犯的是什么毛病？他们在工作中可能面临什么困难？但如果有现成的软件，把输入文件准备好，结果便可以自动给出，困难是否能在一定程度上被克服？
    在初等数学基础没打好时，就学习了高等数学的人犯的是什么毛病？这种人与那些初等数学功底扎实同时又精通高等数学的人在解决实际问题时能力上是否有差异？但学过微积分者（不一定成绩突出）在求曲线下的面积等方面的能力（不借助现成软件）是否应该高过那些只学过初等数学者？兄注意了！在下这里还是只说高等数学，而未说高等佛法！
    比喻终究是比喻！佛法本质上更像是药。当然在医生眼里，先吃哪种药后吃哪种药是有讲究的。这也是比喻。我们之间的讨论绝对是同学之间的交流。我的那些比喻不一定恰当。任何比喻都有不恰当的地方。
    唯识的语言在下不很熟悉，但相信应该是与中观处于同一层面，因此下面主要谈中观与如来藏。
    中观的主要着眼点是开显缘起法与空性的互不相违性，从而破除行人的我法二执。在缘起正见和菩提心的摄持下，通过修持菩萨的广大行愿而积累二资粮，缘起出佛果。相对说来，这样的一条修行道路对大部分行人来说是容易理解和接受的。在二资粮的积累方法上，可分为显和密；对显宗有信心者可以修持六度万行，对密乘有信心者可以修持四部瑜伽，如法修持功德圆满时自然证得胜法身和胜色身，至于证果时间的长短与修持方法及行人的努力程度关系密切。因此中观见、菩提心和修持方便相结合是一条成佛的殊胜大道，这一点是毫无疑问的。
    从中观入手的行人往往有一个优点，在空性见上十分干净。因为缘起法便无自性，通常不会犯被宗大师所斥之“所破不够”的过失。破除自性执的方法不止一个，但龙树菩萨惟独称赞因缘法是如来所说破除诸戏论方法中第一殊胜（中论之开篇），这其中是有甚深含义的。就我个人的体会来说，其他破除自性执的方法都没有缘起正见来得猛烈和彻底。
    再说如来藏。一切众生本具如来智慧德相，不要说我们这些凡夫觉得不可思议，就是十地菩萨亦不能全证，全证如来藏时便是无上菩提成就之时，因此如来藏亦被称为果位见。因位的行人要持果位之见，除了“信”之外，我想不出还可能有别的什么方法。因位行人对如来藏虽不能全证，经过努力还是可以品尝到大海之一滴的。这种品尝对行人的信心无疑会有莫大的帮助。
    对信心有帮助者还有一个，这就是“解”──即理解。因为从某一角度或层面对其有一定的理解，从而不再感到如来藏是那么高不可攀和不可思议，这样在无形中就会减少对信的阻力。例如，佛说缘起法如幻，如幻之法便无实质，无实质之法便应无碍，无碍法之显现全在因缘，因此在我等凡夫心中所显之身心世界，在佛心中无碍地显现为智慧和净土，这是完全有可能的。由于法无实质，因此说凡夫法就是佛界法也合情合理。通过这样的思维，可以加强我们对如来藏的信心。信解相资，再加上修便可以积累开显本具功德的资粮。
    法界的实相是性空妙有，而如来藏就是无尽妙有之一种。如果没有中观的基础，直接持如来藏见（更准确地说是信如来藏见），这可以理解为从妙有一边随顺实相，此类行人可能存在的问题是细微的法执破除的不够，将如来藏视为一种不可思议、不可表述的实有。由于如来藏为本具，因此与缘起之间似乎有矛盾；在无法理解其缘起性时，直接断言其自性空，许多学人是难以真正空的，至少我本人就是这样。从彻底空的立场上看，宗大师对那些持如来藏见（即大圆满见）而未真正空者予以破斥是不无道理的。但另一方面，持中观见者在其体系中无法安立如来藏亦不能说尽善尽美。
    华严杜顺大师的体系借助于法性的不可分别性，将因位之中观见与果位之如来藏见予以贯通，对那些追求体系完美的学人来说实在具有巨大的价值。在这一体系中，“本具”的内在依据恰恰就在于缘起性，这是何等的奇妙！
    有些持中观见者将持如来藏见而未彻底空者斥为外道，这是十分不恰当的，因为只要有菩提心，无论是持“无法安立妙有的性空见”，还是持“并未真空的妙有见”，行人都不会偏离成佛的大道，殊途必然同归。
    信根成就者可以直接从如来藏入手。从如来藏入手者即使一时空得不够，也没什么大了不起的。菩提心的力量终会使其放弃法执。从中观入手者则需要考虑如何在心中无碍安立如来藏见。当然，只要菩提心炽然，这也终究会实现。但请注意，如来是在二转法轮时宣说般若空慧，而在三转法轮时才宣说如来藏。这种时间上的前后不应是没有意义的。因此从修学次第上说，先修般若空慧再学如来藏更通顺些。
    有一篇以九个比喻说明如来藏的佛经老兄读过吗？佛经是《大方等如来藏经》觉贤译，《大方广如来藏经》不空译是同一部经，两个版本，两部对照读最好。一些后人对如来藏系佛经的批评完全是无知和狂妄，如来的言教怎么可能有错呢！！即使在修学此系佛法的行人中出了问题，那也是“人”的问题，而不是“佛”的问题。作为佛弟子，我坚信如来是真语者，那些批评者不可能比佛陀更有智慧。所以老兄要小心，不要上别人的当啊！
    当然，“究竟”了什么都一样。但对我们这些不“究竟”者，从不同角度去理解它们也是必要的。说了上述这些和“见”有关的话题，最后还是归到了菩提心这一根本上来。在下文中所说的“见”，是指“空性见”。菩提心最根本的含义是成佛之“愿”，此愿的发起并不需要以空性见为基础。事实上，获得空性见还是菩提心所缘的目标之一。如《华严经初发心功德品》中之“为悉知一切世界自性清净故，发于无上菩提之心”。将主要精力放在菩提心的修持上才是最最关键。


如何理解众生本具如来智慧德相

    zf：
    关于如何理解“众生本来成佛”。虽然佛弟子们对此的理解角度也不尽相同，但认为成佛后又可堕落为众生，则显然不符合佛法教义。
    对“众生本来成佛”，《华严经》中的表述为“一切众生皆有如来智慧德相”。但众生在具有如来德相的同时，还具有妄想执着。这妄想执着的作用使得本具的如来德相不能现起大用而枉受轮回之苦。
    因此，众生并不是因佛堕落而成，无始以来如来的智慧德相便被无明所遮蔽。从这个意义上说，众生本来成佛并不能导致成佛后又可堕落的结论。

    向齐兄及诸位推荐一经，大藏确为宝藏，含藏世尊无量殊胜开示。《大方广如来藏经》便为其中之一。
    此经以九喻开示众生本具之如来智慧德相，是如来藏一系经典的鼻祖，同时为弥勒菩萨之《宝性论》所依据的经典之一。
    此经中亦有令我等目瞪口呆的授记。如“若有菩萨。得此如来藏法。书写经卷读诵受持。思惟其义为他广说。而彼菩萨应作是念。我今获得无上菩提。”
    以及：
  菩萨闻此修多罗　作是思惟获胜觉
    若有人手得此经　人天礼拜应恭敬
    诸佛世尊大导师　称赞彼人人中最
    亦名最胜之法王　若经入于彼人手
    是人照曜如满月　应受礼敬如世尊
    能持法炬为世雄　由入此经于彼手

    法王在我等心中地位之高不用我说，但如来却授记，受持此经者便名“最胜之法王”。想来此中之法王一定是与经意真实相应而生定解者。无论如何，这样殊胜的经典应该引起我等的足够重视。
    此经有两译分别为《大方等如来藏经》（觉贤译）和《大方广如来藏经》（不空译）。电子佛典中不空译本的标点有几处错误，读时应小心。

    明心斋主人：
    谈谈我的想法，如来藏的思路是否是这样的：
    1，我觉故我迷。
    2，我迷不碍觉。
    3，觉后不再迷。

    愚子：
    此三条不得独一条而说，不然会很容易使人误解。这三条能扩展到很多种说法，种种经论所说，会心而笑。最重要的是此觉对实修可有帮助？帮助实在太大了！一般人只敢承当迷（业），而不敢承当觉（德），而我们从今而后一定会很清楚承当迷的当下也不离觉，便顺理成章、自然而然也能承当觉，极助发心能广大、修行能迅速，莫停留于文字上、理论上，将之兑现于现实日常中……

    zf：
    师兄说的好！
    “最重要的是此觉对实修可有帮助？帮助实在太大了！”
    ──何以受持《如来藏经》的功德如此巨大？依在下浅见，其原因就在于对此“迷中有觉”的承担！能死心
    塌地承担就是“修”，而且是最顿的修！

    静风：
    请教赵叔，若是一法亦具一切法,
    一众生中是否具佛32相？
    一石头中是否具佛32相？
    若同具，是否石头也可成佛？
    此二具是否有区别？与一切众生皆具佛性之具又是否有区别？

    zf：
    回答

    “一众生中是否具佛32相？”
    ──是

    “一石头中是否具佛32相？”
    ──是

    “若同具，是否石头也可成佛？”
    ──是

    “此二具是否有区别？”
    ──否

    “与一切众生皆具佛性之具又是否有区别？”
    ──否

    喜饶嘉措：
    质疑
    “‘一众生中是否具佛32相？’──是”
    ──这是典型的“瓶中佛”的观点，是不符合龙树和无著的观点的。如果众生本具佛果位的32相，还用修持吗？缘起怎么解释呢？佛说万法从缘起，又怎么解释呢？那还用修持吗？这是否“自生”的观点呢？

    “‘一石头中是否具佛32相？’──是”
    ──如果石头具有佛的32相，那石头也可以成佛了？32相是佛特有的（转轮王的不清楚、明显）身相，那就说石头也是佛了？

    “‘若同具，是否石头也可成佛？’──是”
    ──石头也能成佛的说法，就更可笑了。石头也是有情？不是有情能成佛吗？有经典作依据吗？

    zf：
    “这是…………不符合龙树和无著的观点的。”
    ──是的。
    但是符合汉传天台宗和华严宗的法义。

    “如果众生本具佛果位的32相，还用修持吗？”
    ──用。

    “缘起怎么解释呢？佛说万法从缘起，又怎么解释呢？”
    ──因为是缘起的，所以是本具的。

    “这是否‘自生’的观点呢？”
    ──不是。

    “如果石头具有佛的32相，那石头也可以成佛了？”
    ──是。

    “32相是佛特有的（转轮王的不清楚、明显）身相，那就说石头也是佛了？”
    ──是

    “石头也能成佛的说法，就更可笑了。”
    ──我曾听到过很多不信佛的人说佛法可笑。您也听到过吧？

    “石头……不是有情能成佛吗？有经典作依据吗？”
    ──当然有。


如来藏九喻

    zf

    通过譬喻引导弟子理解甚深法义，是世尊常用的教学方法。例如，在《法华经》中就有火宅喻、穷子喻、药草喻、化城喻、衣珠喻、髻珠喻和医子喻这些著名的比喻。
    《大方广如来藏经》则以九个比喻，说明众生本具如来智慧德相，依在下理解，此九喻是以不同的比喻说同一件事。
    （1）譬如佛所化无数莲花，忽然萎变，无量化佛在莲花内，相好庄严，结跏趺坐。萎花比喻无明烦恼，佛身比喻如来藏。谓一切众生烦恼身中本有功德庄严之如来藏，然为无明贪惑所覆而不能见。
    （2）譬如醇蜜在岩树中，无数群蜂围绕守护，故欲取蜜，必先除彼蜂。群蜂比喻无明烦恼，蜜比喻如来藏。谓一切众生本具之如来藏原有功德法味，然为无明所缠绕，则不得其用。
    （3）譬如稻、麦、粟、豆等，所有精实为糠所裹，若不去糠，则不堪食用。稻、麦、粟、豆等比喻如来藏法身之体，糠比喻无明烦恼。谓如来藏法身之体深隐在无明烦恼中，不得受用。
    （4）譬如真金虽堕于粪秽中，然永不变质，若知其所在，则得觅取而用之。真金比喻如来藏性，粪秽比喻无明烦恼。谓如来藏性为无明烦恼所覆，然不失本净，一旦寻获，去其垢秽，则复现其明洁净性。
    （5）譬如贫穷家，其屋宅内地藏有珍宝，却了无所知，待发掘后始得用处。贫家比喻众生，珍宝比喻如来藏性，地比喻无明烦恼。谓众生虽具如来藏性，然为无明烦恼所覆，了不自知。
    （6）譬如庵摩罗果之种子深藏于果实之中，安住不动，未能萌芽生成，然亦含藏不朽，若遇地缘，种植其中，久后自成大树王。庵摩罗果之种子比喻如来藏，果实比喻无明烦恼。谓如来藏久藏于无明烦恼中，安住不动，然亦始终不朽，其后若遇佛法殊缘，则自然萌生，证成无上菩提。
    （7）譬如真金之像，披裹臭秽弊垢之衣，弃掷于地，流转旷野，见者不知，皆贱视之。真金之像比喻如来藏清净法身，臭秽弊衣比喻无明烦恼，旷野比喻三界之生死大海。谓众生虽有如来藏清净法身，然为无明烦恼所缠裹，故堕在生死大海之中。
    （8）譬如贫贱女，身怀贵胎（转轮圣王）而不自知，犹作贱子之想。贫贱女比喻无明烦恼，贵胎比喻如来藏清净法身之体。谓一切众生以无明烦恼之故，不知自身即有如来藏清净法身之体。
    （9）譬如铸造金像，真金在内，燋模在外，其模为黑泥覆蔽，形状燋恶，令人不能推知其内有真金。真金比喻如来藏性，燋模之黑泥比喻无明烦恼。谓如来藏性被无明烦恼所覆蔽，众生遂沉浮于闇昧迷惑中，全然不识自身中之如来藏性。
    （以上九喻之文字引自电子版《佛光大词典》）

    弥勒菩萨在《宝性论》中对《如来藏经》中的九个比喻进行了完整的概括。谈锡永上师《宝性论》的新译文通俗流畅，现将其中之如来藏九喻恭录如下：
    萎花中佛蜂腹蜜，皮壳中实粪中金，地中宝藏种中芽，破朽衣中圣者像。
    贫丑女怀轮王胎，泥模中藏真金像，有情所具如来藏，时为烦恼染成障。
    染如萎莲如蜂腹，如壳如粪如土地，如种如朽故败衣，如贫丑女如泥土。
    如来藏则如佛陀，如蜜如实如黄金，如宝藏如宝树芽，如转轮王如金像。

    譬如萎败莲花中，佛具千种庄严相，唯具天眼者得见，迎佛出此水中莲。
    是故善逝具佛眼，地狱亦见如来藏，能以无碍大悲悯，救渡有情离此障。
    萎莲中佛天眼见，萎败莲花瓣即开，譬如佛见如来藏，有情烦恼障即离。

    譬如蜜酿蜂腹内，具善巧者欲取蜜，乃以善巧方便法，使蜜能离蜜蜂腹。
    世尊具一切种智，见如来藏譬如蜜，使离如蜂根本障，由是取得蜂腹蜜。
    欲得百千万蜂蜜，蜜若有情无垢藏，烦恼藏则恰如蜂，世尊善巧取蜜者。

    果实为壳掩，无人能得食，凡欲食其实，先须去皮壳。
    譬如如来藏，为烦恼所杂，不离烦恼染，三界不成佛。
    米麦未去壳，食之无滋味，如来藏污障，有情无法味。

    如人有黄金，置于粪秽中，黄金性不改，千百年如是。
    天人具天眼，见而告人曰，此中有宝金，待还清净相。
    如佛见有情，烦恼如粪秽，为除贪欲染，降无上法雨。
    如天人见金，示其珍贵性，佛以法清净，著染如来藏。（zf注：“著染如来藏”中之“著”为开显义。）

    譬如贫家地深处，具有被掩无尽藏，贫人对此无所知，宝藏不能命彼掘。
    此则恰似如来藏，清净不增复不减，有情对此无所知，由是常受轮回苦。
    贫者不知具宝藏，宝藏不能告其在，有情如是具法身，佛以方便令出世。

    譬如菴摩罗果等，其种恒具发芽力，若予土壤及水等，即能渐长成为树。
    如是无上真如性，有情无明如种核，若以功德作诸缘，即能渐成胜利王。
    水土阳光时空等，芽具诸缘发成树，有情烦恼藏所掩，佛芽缘具即茁长。

    譬如宝石造佛像，为破臭衣所遮盖，天人见此在路旁，乃为凡夫作指引。
    佛亦如是见佛性，纵使畜生亦具足，无始以来烦恼掩，故说法义解脱彼。
    如宝石像朽衣掩，天眼见已示凡夫，如来藏为烦恼掩，佛说深法为显露。

    譬如贫丑无助妇，既无片瓦复无护，腹中虽怀王者胎，不知轮王在腹内。
    世法浑如无瓦屋，污染有情如孕妇，清净藏虽堪作护，却似轮王处腹内。
    臭衣丑妇屋无瓦，纵使轮王在胎住，有情恰似无助者，虽具护助亦苦恼。

    譬如大像真金铸，却为泥尘所掩盖，若有人能知见者，除去泥模金清净。
    佛亦如是见有情，自性光明偶污染，除诸障已得解脱，有情即如真金像。
    如纯金像泥模掩，知金像性除其泥，一切智智心寂静，演说深法除诸障。

    有些师兄可能要问：思维、理解上述九个比喻（以生起信心）有何功德？我们且看《如来藏经》中的开示：
    若有菩萨。得此如来藏法。书写经卷读诵受持。思惟其义为他广说。而彼菩萨应作是念。我今获得无上菩提。其人应受人天阿苏罗供养恭敬。
    佛说是已唯然欢喜。尔时世尊复说伽他曰：
    菩萨闻此修多罗　作是思惟获胜觉
    若有人手得此经　人天礼拜应恭敬
    诸佛世尊大导师　称赞彼人人中最
    亦名最胜之法王　若经入于彼人手
    是人照曜如满月　应受礼敬如世尊
    能持法炬为世雄　由入此经于彼手

    从这一开示中可以了知：若有行人发菩提心（即“菩萨”意），于此经典受已能读，读已能诵，诵已能持，乃至书写，思维其意，广为人说，是菩萨当作已成佛想！
    由此可见此经之殊胜！
    另外，对“法王”名号感兴趣的师兄瞪大眼睛看清楚了：“若有人手得此经，人天礼拜应恭敬，诸佛世尊大导师，称赞彼人人中最，亦名最胜之法王。若经入于彼人手，是人照曜如满月，应受礼敬如世尊，能持法炬为世雄，由入此经于彼手。”
    请注意，若人受持此经，释迦牟尼佛便金口授记此人为“最胜之法王”！

    此甚深如来藏乃诸佛的自证境界，因此我等行人感到不可思议是完全正常的。此境界虽然不可思议，但我等行人却并非没有直入的门径。在《宝性论》中，弥勒菩萨说：
    如来藏与证菩提，佛功德及佛事业，此唯佛自证境界，纵清净者不思议。
    智者深信佛境界，能得无量佛功德，证不思议无上乐，其善胜于诸有情。

    由此可知，门径便是“深信佛境界”！


正信的关键是要随顺缘起法之实相

    正信的关键是要随顺缘起法之实相

    zf

    如果仁兄自认为是初学者，则目前将主要精力化在金刚经和楞严经法理的学习上可能会有困难，这就好比让某一专业的初学者直接学习刚刚发表的前沿论文一样。仁兄学佛之初就得到一套《广论》，看来仁兄与菩提道次第有缘，建议在菩提道次第方面下点功夫。关于读经，还是先学“教材”，再读“论文”。另外，下载一部电子佛学词典，文字上的困难基本可以克服。
    初学者在没有明师讲解的情况下一上来就直接啃《广论》恐怕困难不小。《菩提道次第略论释》（昂旺朗吉堪布口授）由浅入深，值得推荐。该书网上有电子版，很方便阅读。
    不过在下要送你一份礼物──台湾方广文化事业有限公司出版的《略论释》（1994年，初版）。该书刚一出版，便有人赠送麻子一套，麻子读完后便送予在下。在下见你对麻子很有信心，便狠了狠心，决定将此书转赠给你。
    人不可能心中没有任何疑问才去修行的。请老兄整理一下思路：我们为什么学佛？因为有苦。而苦的存在完全是我们可以“实证”到的，以此对苦的“实证”和对佛陀“集”“灭”“道”的信心，我们便可以选择一个自己可以接受的方法脚踏实地的修行了。
    正信的关键是要随顺缘起法之实相，否则即是邪信。如果信的目标选择得准确，再加上法理上的理解，则仅依靠信解一法便可成就佛道。因此，随顺实相的信解本身同样是真正的修行。
    “是不是说一颗尘埃里，也有无数佛？只是我的肉眼看不见，甚至想象不出来，”
    是。
    从法理上讲：
    一、微尘本性为空，无数佛本性亦为空；空性无为不可分别，微尘即是佛，佛即是微尘。
    二、微尘为幻，佛亦是幻；两幻不当相碍，是故可于微尘中见佛。
    现量见此境界并不一定要等成佛时。善财童子所参访的许多善知识便可亲见此境界。真正的同体大悲，恐怕唯佛能圆满。
    虽是一体，其体性空；因体性空，所以一体。简单地说是：你中有我，我中有你。关于此问题的详细解说，天台宗和华严宗的古德有很多论著可供参考。
    “原本只有一尊佛（或者称别的什么）还是本来就是那么多呢？”
    一、诸佛的本性，不可以色见，不可以声闻（如金刚经之颂），自然也不能以个数。
    二、有形象之色身在华严法界中如因陀罗网，“一尘中有尘数刹，一一刹有难思佛”，无量无边。
    佛说一切众生皆有如来智慧德相，但并不是说众生是如来一时迷糊变成的。由于众生不是佛变的，因此你的问题（佛产生那么多的躯命？）并不存在。那么众生是怎么来的呢？你仔细想一想，这个问题是不可能有答案的。假如有人给了你一种解释，你只要再问一句：“为什么会是这样？”他总有答不上来的时候。
    但有人会疑问，这个世界的众生为什么会变多？实际上，法界的众生无量无边（我们可感知到者只是九牛一毛），所谓众生变多，只是我们忽然知道其存在罢了。
    对“一切众生都是佛”生起定解，这非常难得！随喜！但同时别忘了“一切众生又都不自知是佛”，因此我们才应世世常修菩萨道，以将众生从生死的大梦中唤醒。


见真实相者即是智慧

    CH：
    诺那祖师开示录中所说之法真是非常的殊胜和方便，但这里的关要是“发大菩提心”和“信得过自己就是本尊”。发大菩提心我可以如理的去发愿，但是，这不疑的深信就不好办了。我试过这个方法，可是境一来时我和本尊就分家了。所以我就想请教，能不能给个理论根据来坚固这个不疑的深信。谢谢！

    zf：
    CH兄所探讨者确实是修持中面临的实际问题。信心在圆顿教法中居于核心地位，正所谓“信为道元功德母”也。
    除极特殊根器者外，信心的确立并不是一蹴而就，而是是需要逐渐培养的。其中仁兄关注之“理论”对坚固信心具有十分重要的作用，在下非常高兴与兄交流“理论学习”方面的心得。

    诺那祖师曾开示：“若夫无上金刚乘之教义，俨同华严一乘实相，即‘心佛众生，三无差别，实相现前，如如不动’数语为本。”可见体证心佛众生无差别之实相，乃是无上密乘的根本。然而在我们心中，凡夫的贪、嗔、痴与如来之智、悲、力根本就不是一件事，对无差别之义甚难契入。
    此难关的突破点在哪里？其实经论中早有阐述，即法性（真如、空性、无性性）的无分别性。
    以下经论可供仁兄思维。

    一、杜顺大师在《华严五教止观》的“华严三昧门”中直截了当指出，入不思议解脱法界的窍要是了知缘起法无自性性的不可分别性，即“性即无为，不可分别，随其大小，性无不圆。一切亦即全性为身，是故全彼为此。”这就是说，大小、染净、众生如来等一切法，因其法性的不可分别，法亦不可分别，所以当下大即是小、小即是大，染即是净、净即是染，众生即是如来、如来即是众生。
    杜顺大师在《漩澓颂》中言：“若人欲识真空理，心内真如还遍外，情与非情共一体，处处皆同真法界。”
    诺那祖师言：“诸位修行，必以三密相应为本之要旨，即把自己真如自性平等扩充，差别流现；即是举手投足，皆手印之身密，出辞吐气，皆真言之口密，起心动念，皆观想之意密，法尔如是，不假思维。”
    比较以上两位祖师的开示，无论是将对真如之理的体认由内心遍及有情与无情之法界，还是将对真如之理的体认由众生之举手投足、出辞吐气、起心动念扩充于如来身口意三密，其修行的核心都是对诸法不可分别性的体认和扩充。

    二、《佛说首楞严三昧经》中亦有相关开示：“魔界如即是佛界如，魔界如佛界如不二不别。我等不离是如，魔界相即是佛界相，魔界法佛界法不二不别。我等于此法相不出不过，魔界无有定法可示，佛界亦无定法可示，魔界佛界不二不别。”此大法要的开示者，乃是一些发愿安住魔界而修菩萨行的“魔女”。若分“教”、“行”二分来看这一法要的话，一、其“教法”为：魔界佛界法性皆如（即真如），因为如的不可分别，所以魔界佛界亦不可分别，魔界相即是佛界相，当然佛界相也即是魔界相。二、其“行法”为：不必出离魔界（即是“不出不过”之义），于魔界显现之时，当下体会魔界佛界的如幻性和无分别性，从而于魔界上安立佛界之利生大用。

    三、华严经十回向品中有：
    了达诸法真实性　而于法性无分别
    知法无性无分别　此人善入诸佛智　（即，了知法性的无分别性是入诸佛智的善巧方便。）

    法性遍在一切处　一切众生及国土
    三世悉在无有余　亦无形相而可得　（即，法性真如遍及十方三世而无相。）

    一切诸佛所觉了　悉皆摄取无有余
    虽说三世一切法　如是等法悉非有　（即，诸佛的一切功德自己本来具足（因为不可分别），同时亦毫无自性可得。）

    如诸法性遍一切　菩萨回向亦复然
    如是回向诸众生　常于世间无退转　（即，菩萨不但了知自己与佛不二，同时了知众生与佛不二，并为使众生同证此不二而行菩萨行。）

    Ch兄，为解决“境一来时我和本尊就分家了”这样的问题，我们除了要让凡夫境界与如来功德无二无别之正见在心中扎根，还应通过修持而达到“如人问我贵姓，充口随应，绝不错乱，广东人说广东语，信口而谈，如是熟练，便得自在（诺那祖师语）。”

    CH：
    善知识所言我认真的拜读了数遍，得出两个结论，不知是否完全领会了善知识所说要意，请善知识指正。
    心佛众生的本性三无差别，这是信点之一。魔界相与佛界相无有差别，这是信点之二。同时在拜阅中也有几点不很明了还要善知识开显。
    引言：“入不思议解脱法界的窍要是了知缘起法无自性性的不可分别性，即‘性即无为，不可分别，随其大小，性无不圆。一切亦即全性为身，是故全彼为此。’”
    问题：
     一、“不可分别性”这个概念中的“不可分别”是什么意思？
    二、即是“全性为身”，那么“全彼为此”指的是什么？
    引言：诺那祖师言：“诸位修行，必以三密相应为本之要旨，即把自己真如自性平等扩充，差别流现；即是举手投足，皆手印之身密，出辞吐气，皆真言之口密，起心动念，皆观想之意密，法尔如是，不假思维。”
    问题：一、真如自性的扩充是不是就是说我们思维的扩充？
    二、如果“举手投足，皆手印之身密，出辞吐气，皆真言之口密，起心动念，皆观想之意密”那么是不是说我们的贪、嗔、痴当下就是如来的智、悲、力了？

    以上所问的中心就是要明了起修处这个关键点。如能看准这个点我想就进入这个法的大门了。

    zf：
    “善知识”的称呼在下不配，我等以师兄相称最好。

    “魔界相与佛界相无有差别”
    ──这是说魔界的作用与佛界的作用无差别。

    “入不思议解脱法界的窍要是了知缘起法无自性性的不可分别性，即：性即无为，不可分别，随其大小，性无不圆。一切亦即全性为身，是故全彼为此。问题：一、‘不可分别性’这个概念中的‘不可分别’是什么意思？”
    ──对此性不能作一和异、局部和整体等的分别。任何两法，无论染净、局部和整体、过去和未来，对其本性我们的任何分别、分割等概念完全不适用。

    “二、即是‘全性为身’，那么‘全彼为此’指的是什么？”
    ──一切法的本性都是真如空性，此性不碍幻相，即一切法都是以真如为“身”的如幻显现；由于法性的完全不可分别性，彼、此二法的显现也互不妨碍，因此彼中有此、此中有彼，彼即是此，此即是彼。
    我们接受此见的主要障碍源于对诸法实有的执着，这种执着是如此深细，乃至无法察觉其存在。
    《大方广如来不思议境界经》中言：“譬如有人。梦见种种变异事等。及其觉已。所见皆无。凡夫亦尔。无明梦故。妄于诸法生实体想。诸佛觉已。皆无所著故能十方一切世界。一念示现无量佛事自在无碍。利益成就一切众生。皆令悟入无量深妙解脱门故……如人梦中见于一处。有种种事。以非实故。而无所碍。是一切刹。靡不唯其心之所现。或见劫烧。或已烧尽。或风所成。或净或秽。或复无佛。皆由众生随自心业。见如是等种种不同。”
    法界实相，本来重重无尽、事事无碍，可是我们凡夫因自业力，只能见此圆融法界之某一侧面，并于此侧面生起实有的执着，将本来无碍之法界生生割裂为彼此妨碍之诸法。真是天下本无事，庸人自扰之！

    “l　引言：‘诺那祖师言：诸位修行，必以三密相应为本之要旨，即把自己真如自性平等扩充，差别流现；即是举手投足，皆手印之身密，出辞吐气，皆真言之口密，起心动念，皆观想之意密，法尔如是，不假思维。’”
    “问题：一、真如自性的扩充是不是就是说我们思维的扩充？”
    ──是。即将一切凡夫所现之差别相，恢复到平等无碍之圆融相──入不思议解脱境界。

    “二、如果‘举手投足，皆手印之身密，出辞吐气，皆真言之口密，起心动念，皆观想之意密’那么是不是说我们的贪、嗔、痴当下就是如来的智、悲、力了？”
    ──对！
    这就是《圆觉经》中之如来随顺觉性：
     “善男子。一切障碍即究竟觉。得念失念无非解脱。成法破法皆名涅槃。智慧愚痴通为般若。菩萨外道所成就法同是菩提。无明真如无异境界。诸戒定慧及淫怒痴俱是梵行。众生国土同一法性。地狱天宫皆为净土。有性无性齐成佛道。一切烦恼毕竟解脱。法界海慧照了诸相犹如虚空。此名如来随顺觉性。善男子。但诸菩萨及末世众生。居一切时。不起妄念。于诸妄心。亦不息灭。住妄想境。不加了知。于无了知。不辨真实。彼诸众生。闻是法门。信解受持。不生惊畏。是则名为随顺觉性。善男子。汝等当知。如是众生已曾供养百千万亿恒河沙诸佛及大菩萨。植众德本。佛说是人名为成就一切种智。”
    上述经文中之“居一切时。不起妄念。于诸妄心。亦不息灭。住妄想境。不加了知。于无了知。不辨真实。”
    不易理解，我们来看看宗密大师在《大方广圆觉修多罗了义经略疏》中对此的解释：
    居一切时不起妄念──妄念者。攀缘取着外法也。念则违觉。故令不起
    （zf的理解：这句是说应保持“觉”。何之为觉？即安住前面所说之“得念失念无非解脱。成法破法皆名涅槃……有性无性齐成佛道。一切烦恼毕竟解脱”之正见。）

    于诸妄心亦不息灭──若求真舍妄。犹弃影劳形。若灭妄存真。似扬声止响
    （zf的理解：这句是说，不必舍妄求真，妄就是真，烦恼就是菩提。）

    住妄想境不加了知──境从心现元是自心。若加了知即迷现量。故经说非幻成幻。论云。心不见心。但不生情自然如镜照物。且心体本自知觉。何必更加了知。知上起知名为加矣
    （zf的理解：这句的关键是，只要不生情执，妄境即是智慧。）

    于无了知不辨真实──能知既寂即真实知。真实即知。谁知真实。如眼不自见等。
    （zf的理解：见真实相者即是智慧，没有必要（实际上也不可能）再以智慧为所缘来评头品足。）

    CH：
    问题：赤橙黄绿青蓝紫等等差异的本性是因缘无实这易理解，但是万千众生于无始来对这些法的差异认知是一致的（共业范围内）。所以说本是差异的诸相＋本能分别差异的众生本性＝却是诸差异相的无别，这确实是难中难啊！（我以为不可能，佛也有一切种智啊，只是《佛说首楞严三昧经》中有“魔界相即是佛界相”就也只能生信而后解了）

    zf：
    说到底，问题出在我们对实有的执着上。要接受“法无分别”　这种见地，必须有对“缘起如幻”相当程度的认知。因此，《金刚经》中“一切有为法，如梦幻泡影，……”这四句偈应该常在心中体味。
    “信而后解”是一步险着。有善根者所信为如来正见，这是修持顿法的根性；无善根者所信为邪见，却顽固不化。由此可以看出无上菩提心的护持是何等重要！

    CH：
    法性这两个汉字连在一起是在表达一个完整的意思，那就是说法是因缘和合的相，而因缘的和合的这种规律就是所有法的本性。是啊！这是宇宙万有的真相啊，不过众生对法的执着就是认知了这个真理后也是无法去除。这应该是对破除我执尚存法执的具量大人能起到作用的了义真理。大多众生就好像是春天绿树上虫子，虽然知到树根已断但是还是能尽情地享受着尚好的生存环境。受着那个环境的种种牵引生贪嗔痴等。所以这个对绝大多众生来说属于思维范畴的了义最高知见下起手来不得其力呀。

    zf：
    “法是因缘和合的相”这一说法没错，但应进一步体察“相”的幻化性。“相”的基础是因缘，而因缘的本质是业力。我们认为坚固的法相，离开特定的业力就根本谈不上存在，如同梦境般虚幻。
    法性并不是什么深奥的东西，就是这种虚幻的无实性。
    最直的那条上山路，对很多人来说根本就不是路。

    CH：
    如果说我们的贪、嗔、痴当下就是如来的智、悲、力了，那么，就是说我们的这个世界当下就是佛国净土了，或者说根本就不用去分辨佛国人间净土秽地了，这样我们是不是就不用刻意去修学戒定慧，现前的贪嗔痴就是现成的戒定慧之果报了？我觉得真正的下手之处就是这里了！一旦通达，那么，真的可是度无量众而无一众可度者！！

    zf：
    一、当贪嗔痴现前时，您若能清晰照见其与如来智悲力的无二无别性，这种与如来功德无二的“贪嗔痴”还是那能将我们束缚于六道的贪嗔痴吗？
    二、贪嗔痴与佛功德无二无别，但随因缘有隐与显的差异（“隐显”的法义可参见华严宗古德的论著）。菩萨修学的唯一目的就是利益众生，即让本具之佛功德显，使本具之贪嗔痴隐（将贪嗔痴说成“本具”一定会召来批评）──这正是菩提心之所指。

    “我觉得真正的下手之处就是这里了！一但通达那么真的可是度无量众而无一众可度者！！”
    ──修持之道，实际是在平等中做选择。
    平等──照见贪嗔痴与佛功德之无二无别性，此乃般若佛母；
    选择──贪嗔痴与佛功德虽平等无别，仍力求佛功德现行，此乃菩提心佛父。
    父母双运，出生如来。
    真下手修行时，还有一点常被忽略：佛的功德无量无边，但作为我们发心所缘之佛功德应该必须有哪些？
    此问题不解决，我们要成的“佛”便徒有虚名。

    CH：
    “说到底，问题出在我们对实有的执着上。要接受‘法无分别’这种见地，必须有对‘缘起如幻’相当程度的认知。因此，《金刚经》中‘一切有为法，如梦幻泡影，……’这四句偈应该常在心中体味。”
    ──我对这段话有些不解：
     一、知诸法的本性是因缘和合就会从理上立即破除对法相的实有认识。
    二、如幻之意就是法相的无常性。就象天空上的云，从有相到无相，从无相又渐渐生成，每一刹那都会呈显出不同的相来一样的。但是这并不能说明那些不同的相是一样的，同时谁也不会认为那些相是一成不变的。

    zf：
    “有些不解，一、知诸法的本性是因缘和合就会从理上立即破除对法相的实有认识。”
    ──理上如是，但行上如幻观非常重要。
    在心行上，您可不要小看了我们无始串习的力量。
    您利剑（正见）在手，可以杀死那些被您发现了的敌人，但许多敌人躲在你身后，您尚未见到，更别提杀了。
    “二、如幻之意就是法相的无常性。就象天空上的云，从有相到无相，从无相又渐渐生成，每一刹那都会呈显出不同的相来一样的。但是这并不能说明那些不同的相是一样的，同时谁也不会认为那些相是一成不变的。”
    ──仁兄所言乃幻之浅意。
    而幻之深意，必通无碍。
    华严澄观祖师于《华严悬谈》中言：
     “……五、如幻梦者。犹如幻师能幻一物以为种种，幻种种物以为一物等。经云：或现须臾作百年等。一切诸法，业幻所作，故一异无碍。言如梦者，如梦中所见广大，未移枕上；历时久远，未经斯须。故论云：处梦谓经年，觉乃须臾倾。故时虽无量，摄在一刹那。”
    仁兄三思。

    CH：
    隐显的法义我这里无从寻得，请赵老慈悲摄要言之。因不知隐显法义这段我不能得出结论。

    zf：
    “隐显”之法义在华严古德所立之“十玄”中：
     “（5）隐密显了俱成门：是说一切诸法，互摄无碍。此全摄彼，就此显而彼隐；彼全摄此，就彼显而此隐。一法摄一切法，就一法显而一切法隐；一切法摄一法，就一切法显而一法隐。显与显不俱时，隐与隐不相并，然而隐显同时，并存无碍。”

    缘起法的现起离不开条件。佛教中把种种条件归纳为四类：因缘、等无间缘、所缘缘与增上缘。
    四缘中的因缘是指生起某法的主要的、不可缺少的条件。对于大乘行人来说，欲成就佛法，其因缘恐怕非无上菩提心莫属。
    所缘缘是指诸心、心所缘住的境界。如眼识及相应法，以一切色为所缘缘，耳识及相应法以一切声为所缘缘，意识相应以一切法为所缘缘等。对于一个修行者来说，修持的技巧或法门大部分属于对所缘缘的把握和使用。
    这里提醒仁兄注意者，正是菩提心之“所缘缘”。

    仁兄带着在下的提醒去研习经论吧，毕竟讨论不能替代系统的学习。
    关于“法不分别”，暂时放到一边也不要紧，如果通过我俩的讨论，仁兄能进一步重视对菩提心所缘缘的把握，也算没有浪费仁兄的时间。


关于华严的修证方法

    zf

    华严宗风不振不是今日的事，已有数百年历史了。个中原因在下不敢胡乱推测。
    讲解华严教理的论著并不缺乏，如有兴趣可到大正藏“诸宗部”中寻找。
    关于华严的修证方法，人们通常的看法是华严有教法少证法。事实上并非如此。
    据在下的一点粗浅体会：
    一、行人若能在中观见的基础上更进一步，学习华严之“周遍涵容”，于事事无碍之见生起定解是可能的。
    二、在此见的基础上，依《初发心功德品》中的发心教授实际修习菩提心，只要肯用功，应该是能修起来的。
    此品经对“华严见”下的菩提心之所缘有相当清晰的描述，绝不是仅有理没有行。
    在下将此中的教授视为菩提心的无上教授，因为发心即成佛的教授似乎只有这里明说。
    三、《普贤行愿品》（特别是其中的长行部分）就是一部修持普贤行愿的完整仪轨，绝对是“证法”。在华严见摄持下修持普贤行愿，更易与普贤菩萨相应。
    行人若能如是见、如是修，深入华严大海并非天方夜潭。


对华严法界信解而入的法理门和比喻门

    无言：

    请问赵叔并请诸位师兄不吝赐教,普贤十大愿中第一愿礼敬诸佛，该如何礼敬呢？
    经中云：“我以普贤行愿力故。起深信解。如对目前。悉以清净身语意业。常修礼敬。一一佛所。皆现不可说不可说佛刹极微尘数身。一一身遍礼不可说不可说佛刹极微尘数佛。”
    起深信解，如对目前。是否是要观想不可说不可说佛刹？如何做才能称得上是“深”信解？如何做才能是“如对目前”呢？我等凡夫，因无始业力薰习，难起信解，更不要提“深”了，而要如对目前，更是难上加难！当前还不能“现不可说不可说佛刹”，更不能“现极微尘数身”时，该如何礼敬呢？我目前的做法是这样的，不知可否：虽未“如对目前”但坚信一点：在我礼佛时，已同时于一一佛所以一一身礼敬诸佛。
    但，嘻嘻，念念相续无有间断，身语意业无有疲厌还差得远。

    zf：

    无言等诸兄，刚出差回来，就看到诸兄在交流关于修学普贤行愿的体会，非常兴奋，自然不甘落后了！
    在“礼敬诸佛”中，“我以普贤行愿力故。起深信解。如对目前”之前的经文是：“所有尽法界虚空界。十方三世一切佛刹极微尘数诸佛世尊。” 在下认为，这句经文应是“称赞如来”中之“所有尽法界虚空界。十方三世一切刹土所有极微一一尘中。皆有一切世界极微尘数佛。一一佛所。皆有菩萨海会围绕”之略说，两者的含义应该是一致的，即这“一尘中有尘数刹，一一刹有难思佛，一一佛处众会中”的重重无尽之法界是行人应起深信解和观修的目标。注意：这里普贤菩萨开示行人的用心方法有两层含义：
    一、对此目标的“信解”；
    二、在信解的基础上起观，如对目前。

    那么，对上述华严法界的信解应从何而入呢？本人认为，杜顺大师在《华严五教止观》中给出了两个门径：
    一、法理门
    以缘起法法性的无为、不可分别性为基础，进入事事无碍、重重无尽的法界，确立此华严法界乃法界实相的定解。
    关于上述见解，以前我们在论坛上曾进行过相关讨论，这里就不再重复。
    二、比喻门
    对华严法界最形象的比喻可能就要算“因陀罗网”了。

    杜顺大师言：
    然帝释天珠网者。即号因陀罗网也。然此帝网皆以宝成。以宝明彻递相影现涉入重重。于一珠中同时顿现。随一即尔。竟无去来也。今且向西南边。取一颗珠。验之。即此一珠能顿现一切珠影。此珠既尔。余一一亦然。既一一珠一时顿现一切珠既尔。余一一亦然。如是重重无有边际。即此重重无边际珠影皆在一珠中。炳然高现。余皆不妨此。若于一珠中坐时。即坐着十方重重一切珠也。何以故。一珠中有一切珠故。一切珠中有一珠时。亦即着一切珠也。一切反此。准以思之。既于一珠中入一切珠。而竟不出此一珠。于一切珠入一珠。而竟不起此一珠。问既言于一珠中入一切珠而竟不出此一珠者。云何得入一切珠耶。答只由不出此珠。是故得入一切珠。若出此一珠入一切珠者即不得入一切珠也。何以故。离此珠内无别珠故。问若离此珠内无一切珠者。此网即但一珠所成。如何言结多珠成耶。答只由唯独一珠方始结多为网。何以故。由此一珠独成网故。若去此珠。全无网故。问若唯独一珠者。云何言结成网耶。答结多珠成网者。即唯独一珠也。何以故。一是总相具多成故。若无一。一切无故。是故此网一珠成也。一切入一。准思可知。问虽西南边一珠总收十方一切珠尽无余。方各各有珠。云何言网唯一珠成耶。答十方一切珠者。总是西南方一颗珠也。何以故。西南边一珠即十方一切珠故。若不信西南边一珠即是十方一切珠者。但以墨点。点西南边一珠者。一珠着时即十方中皆有墨点。既十方一切珠上皆有墨点。故知十方一切珠即是一珠也。言十方一切珠不是西南边一珠者。岂可是人一时遍点十方一切珠耶。纵令遍点十方一切珠者。即是一珠也。此一为始既尔。余为初亦然。重重无际点点皆同。杳杳难原。一成咸毕。如斯妙喻类法思之。法不如然。喻同非喻。一分相似故以为言。何者。此珠但得影相摄入。其质各殊。法不如然。全体交彻故。华严经性起品云。为饶益众生令悉开解故。以非喻为谕显现真实义。如是微密法无量劫难闻。精进智能者乃闻如来藏（云云）。经云以非喻为喻等也。诸有行者准喻思之。

    行人当仔细体会大师以上比喻的用意，了知每一个珠都喻五蕴等诸法，法界中一切染净、色心等诸法都如因陀罗网般你中有我、我中有你，重重无尽。
    在对因陀罗网的形象有相当了解的基础上，尝试着思维和想象：
    一、正如“一珠中有一切珠，一切珠中有一珠”，任何一个微尘中也具有极微尘数佛，一一佛所，皆有无量无边的菩萨海围绕。
    二、 正如“若于一珠中坐时，即坐着十方重重一切珠也”，当你礼敬眼前的佛时，你便同时在一切微尘中礼敬佛；而你眼前的佛又同时存在于一切微尘，这样，一一佛所皆现极微尘数身，一一身皆礼极微尘数佛便自然而然地完成了！
    三、 正如“十方一切珠者。总是西南方一颗珠也。何以故。西南边一珠即十方一切珠故。若不信西南边一珠即是十方一切珠者。但以墨点。点西南边一珠者。一珠着时即十方中皆有墨点。既十方一切珠上皆有墨点。故知十方一切珠即是一珠也”，当一众生成佛时，我们也应该同时成佛！当观世音心中持诵六字大明咒时，我们的心中也应该同时受持六字大明咒！当你自己的心中念佛时，一切众生心中亦应同时在念佛！
    当普贤菩萨在实践其广大行愿时，我们亦同时实践着普贤行愿！普贤行愿在普贤菩萨的心中念念相续无有间断身语意业无有疲厌，此行愿同时在我们的心中也是念念相续无有间断身语意业无有疲厌！
    若有了上述信解的基础，“如对目前”的观想便不再像以前那样困难了，进而会觉得，若不如是，反而极不应理！

    说几句题外话。

    目前许多人（特别是密乘行人）认为“观想”是修行的“高级”技巧，而“信解”则是低级的、非善巧的方法。在下丝毫无意贬低“观想”的重要性，但同时认为，“信解”同样可以是修持的最高手段──关键是“信解”的目标为何。

    在《大方广入如来智德不思议经》中，灭诸盖菩萨在宣说“入如来智德不思议境界法门”后，言：
    “文殊师利。若有善男子善女人。于恒河沙劫。以天上味及天妙衣。施十方界微尘等一切诸佛及声闻众。彼佛灭后。为一一佛。遍满十方一一世界。造十方界微尘等塔。其塔皆是阎浮檀金。电光摩尼。互相间错。集众光宝。周围栏楯。宝幢遐建。宝铃流响。蛇卫栴檀。以为涂香。覆以自在摩尼王网。其上复有天宝盖云。宝幡幢云。妙花香云。摩尼王云。如意珠云。徘徊散空。满三千界。日日三时。如是供养。经恒沙劫。兼复教化无数众生。如是供养。不如有人闻此入如来智德不思议境界法门。心生信解。其福过彼。无量阿僧祇。文殊师利。若有菩萨。信解此法。则速成满菩萨摩诃萨无量亿那由他诸波罗蜜。证入无量亿那由他地。背舍无量亿那由他生死。了知无量亿那由他诸佛神通。破无量阿僧祇我慢山。倒无量阿僧祇悭嫉幢。竭无量阿僧祇爱河。渡无量阿僧祇生死海。断无量阿僧祇魔网。掩蔽一切日月释梵护世威光。从一佛刹。至一佛刹。能救地狱饿鬼畜生阎罗王界诸苦众生。常得亲近诸佛菩萨。具足成就海印三昧。持一切法三昧。法自在三昧。诸相庄严三昧。宝生三昧。安乐三昧。莲花庄严三昧。虚空藏三昧。随入世间三昧。妙法花三昧。境界自在三昧。大奋迅三昧。虚空心三昧。师子奋迅三昧。日灯三昧。无量旋三昧。澍甘露三昧。金刚幢三昧。如金刚三昧。金刚齐三昧。地持三昧。须弥灯三昧。须弥幢三昧。宝藏三昧。心自在三昧。一切众生心自在三昧。增长一切行三昧。深密方便三昧。种种辩才三昧。无能见三昧。了诸法三昧。游戏三昧。出生一切神通三昧。降魔三昧。现一切色相三昧。一切色最胜三昧。观身三昧。具一切行三昧。智灯三昧。菩提光三昧。乐说辩才三昧。入一切功德三昧。说诸法实相三昧。寂静神通三昧。首楞严三昧。海潮三昧。又得无量佛身相陀罗尼。大智陀罗尼。净音陀罗尼。无尽箧陀罗尼。无量旋陀罗尼。海印陀罗尼。入决定辩才陀罗尼。诸佛住持陀罗尼。又得随顺一切众生殊胜行一切法无师智。断一切法疑。得佛神通。具菩萨行善巧方便。文殊师利。譬如须弥山王。高显秀丽。映蔽余山。菩萨信解此法门者。功德严净。蔽诸众生一切善根。亦复如是。”
    “尔时文殊师利。告灭诸盖菩萨言。佛子。复更有余胜法。若诸菩萨。能信解者。便得成就余胜功德。灭诸盖菩萨。闻是说已。复白文殊师利言。若有菩萨。信解五法。则能除此胜法。得余无量殊胜功德。何等为五。一者信解一切诸法。不生不灭。不可称说。无比无对。二者信解如来无功用。无分别。入过阎浮提微尘等威仪行处。刹那刹那常起不绝。三者信解释迦如来。往昔教化苏陀婆王。但为成熟诸众生故。然实已于恒河沙劫。久成正觉。四者信解释迦如来。示然灯佛。授记已来。乃至成佛。于是中间。修菩萨行。而实已于无量劫来。成等正觉。住佛境界。五者信解释迦如来。现托王宫。释种被害。但为成熟诸众生故。而实已于无量劫来。成等正觉。文殊师利。菩萨若能于此五种。生信解者。则能除此胜法。更得成就余胜功德。”

    诸兄如果仔细体会上述经文，可知修持“入如来智德不思议境界法门”的用心方法只有一个，那就是“信解”二字，而信解此法门的功德则是成就首楞严三昧。在《首楞严三昧经》中，如来开示，菩萨若成就首楞严三昧，则已再无别法可修，因为如来的一切利生事业所依靠者就是首楞严三昧的功德本事。可见“信解同样可以是修持的最高手段”不是在下的胡说。
    关于“入如来智德不思议境界法门”的法义，有兴趣者可以研读《大方广入如来智德不思议经》。不过依在下之浅见，“入如来智德不思议境界法门”的要义全部蕴涵在“广本普贤行愿品”中之以如下偈语为起始的广大颂文之中。

    “佛智广大同虚空　　普遍一切众生心
    了世妄想皆非有　　不起种种异分别
    一念悉知三世法　　亦了一切众生根
    譬如善巧大幻师　　念念示现无边量
    随诸众生心行异　　往昔诸业愿乐力
    令其所见各不同　　而佛寂然无动念”
    因此，普贤菩萨对如来功德的赞颂，一方面是后面普贤行愿“欲成就如来功德”的目标，另一方面，其本身就是一个无上的修持法门！

    rj：
    om mani padme hum

    《华严五教止观》中之
    比喻门──化粗分＋细分，破粗实执
    法理门──化细分＋粗分，破细实执
    由此二门自然引出菩贤行愿品之行门。
    此行门为身口意之行门，趋向于实相，然而由无缘分大悲心故，如来显。
    这样理解如何？

    zf：
    “比喻门──化粗分＋细分，破粗实执
    法理门──化细分＋粗分，破细实执”
    ──在下浅见，此二门的重点是彻底的平等。

    “由此二门自然引出菩贤行愿品之行门。此行门为身口意之行门，趋向于实相，然而由无缘分大悲心故，如来显。”
    ──普贤行愿是在大平等基础上的选择──由无缘分大悲心故，如来显。
    选择是如来父，平等是如来母。


菩萨于佛十力中，虽未证得亦无疑

    zzzm：
    一相摄无量相尽之华严事事无碍法界，通常是很难理解的，后学看到一段开示很妙，与大家共享。同时也希望看到各位的高论。
    “今约事理融通。故得有斯无碍也。谓不异理之一事。全摄理性时。令彼不异理之多事。随所依理。皆于一中现也。若一事摄理不尽。则理有分限失。若一事摄理尽。而多事不随理现。则事在理外失。今既一事全摄理性。多事岂不于一中现。故经云。华藏世界所有尘。一一尘中见法界。（见四法界。）”
    摘录于《大方广佛华严经普贤行愿品别行疏钞》

    zf：
    菩萨于佛十力中，虽未证得亦无疑。

    “今约事理融通。故得有斯无碍也。”
    ──事：法。
    理：不是通常的“道理”，而是空性、真如、无自性性。
    事理融通：性空不碍缘起，缘起不碍性空。

    “谓不异理之一事。全摄理性时。令彼不异理之多事。随所依理。皆于一中现也。”
    ──不异理之一事：五蕴不异空，空不异五蕴。
    全摄理性：此乃关键。因理性无为不可分别，因此任何一法的体性必是“全空”，而绝无“部分空”的可能。

    “若一事摄理不尽。则理有分限失。”
    ──理之不可分别，不可分割，即此处之不可“分限”。

    “若一事摄理尽。而多事不随理现。则事在理外失。今既一事全摄理性。多事岂不于一中现。”
    ──任一事全摄理尽，而此理又不可分别、不可分割、不可分限，则结论只能是“华藏世界所有尘。 一一尘中见法界。”


李长者与众生眼中的佛

    李长者与众生眼中的佛

    zf

    李通玄长者在《新华严经论》中关于众生眼中的佛的论述亦十分精彩，建议“每日经论”刊出。
    其中论及众生因自心业力不同，而致使毗卢遮那佛在其眼中显现不同，长者开示：
    “第五明见佛差别者。夫佛身性相一体无差。器有万端依根各异。情存相隔见绝体齐。身立影生情留佛异。佛由情应以此乖真。心尽情亡智身自称。智缘无作动寂俱真。如是相应名毗卢遮那佛。毗卢遮那者。名种种光明遍照也。以法身悲智示相教光。用对诸根随情现色。为情乖相别见异佛殊。以体相混收本是毗卢遮那一智身也。只可归真去假。不可滞假亡真。略立十门见佛差别。使得留心创信者返末而还源也。
    一、人中见佛但有三十二相
    二、诸天见佛但有八十种好
    三、诸龙见佛。或同人所见。或见但为大龙王也。余畜例然
    四、诸仙人见佛但见仙人
    五、诸余外道还见佛与己同类
    六、八部神等见佛与己为王
    七、小乘人见佛为大声闻
    八、缘觉见佛还为缘觉
    九、权教中菩萨见佛。但为三千大千世界之主。福智充遍三千大千世界
    十、一乘教中菩萨见佛。为十佛刹微尘数莲华藏世界海。为法界主。且云十佛刹微尘数莲华藏世界。为明无尽。总摄一切刹故。福智充满一切诸刹。无尽相海重重故。
    如上十种见佛不同。皆由发心之时信乐差别。以信乐力故。见佛不同。是故当知。发心之者。发广大心。
    信广大教门。发广大愿。行广大行入广大智。利益成就无尽众生。即得速成菩提行愿福智悉皆圆满。若不如是。终非毕竟成大菩提。劳而功少。何如直往一切智之中也。”

    依本人猜测，上述“人中见佛但有三十二相”中之“人”，乃指生活于释迦牟尼佛应化之时代而能亲见佛陀者，并非指我等这些末法时代的众生。畜生见佛为畜生，那么，今天在我等众生眼里之佛应该是个什么模样？
    常常见到有人对禅宗之见性成佛和密宗之即身成佛不解甚至诽谤。在这些人看来，成佛者若不能显现为十佛刹微尘数莲华藏世界海之法界主，则成佛便是大妄语。他们在审视别人的时候却恰恰忽略了最重要的一条──审视自己，是否是一乘教中之菩萨！
    兄说“一个老人在八十六岁之后的十年就这么独自一人，在野外的一个土洞里写作，虽然他一定也受到善信的相当照顾了，但是肯定还是诸多不便，吃了很多苦。特意把这位长者的传找来看了，又想起了能读到经典，还是因为一代代的老百姓出了钱，帮助了佛教经典的保存，很感激。”
    是啊！汉地的文化传统不大喜欢谈神弄玄，但即使如此，李长者的“事迹”读起来还是颇有传奇色彩，
    真乃奇人也！此等奇人留下的奇论若不细细品味，憾事！


杜顺大师教法的身影

    杜顺大师教法的身影

    zf

    “我对杜顺大师绝对有信心”
    ──这就好办。建议仁兄先花一段时间，将主要精力用在对杜顺大师教法的体会上。

    “真如具足一切”或“理具一切”的说法，相信在祖师们的心里应该具有与杜顺大师言教一样的法义，但我等凡夫或某些“学者”听来，却很容易将其演绎成某种“本体论”
    ──即真如是出生一切法的本体。经过这一番糟蹋，开显如来心髓的华严竟变成了与外道眉来眼去的“真常唯心”！天大的冤枉！！！！！

    杜顺大师教法的特别殊胜就在于，其唯一的基石就是缘起性空。这一特点导致其推演出的所有结论都与彻底的空毫不相违。在大师的体系中，小乘、中观、如来藏、天台、华严等教法是如此和谐、美妙地组成由浅入深的次第！因此说大师是文殊示现，在下绝对相信！
    关于圆融，各派所说法义相同，是圆融；各派法义组成一个由浅入深的次第难道不也是一种圆融吗！
    华严宗本身虽然并不兴旺，但在各宗教法中却处处显露身影，在禅宗中这种影响更加明显，如宗密大师便将华严与禅宗有机结合。
    近代密宗高僧持松上师是将华严和密乘结合的另一位大德，比较起来，持松上师介绍的密法具有一种特殊的味道。按照藏传体系来看，持松上师所说的密法属于“下三部”，但由于其修法所持的是华严见，以在下之浅见，说上师的修持体系属于无上密大圆满毫不为过。但愿我没有错误理解杜顺大师的法义！
    华严宗的著作，大正藏“诸宗部”中有很多相关内容，可到“中华佛典宝库”网站中找。其实我比较熟悉的也不过是《华严五教止观》等少数的几部。仁兄还是先花功夫深入杜顺大师的教法后再自己比较吧！


关于华严法门的权威注疏

    化鹏：
    我想了解华严法门，请您为我推荐一些权威的注疏，越多越好，谢谢。

    zf：
    化鹏兄，仁兄好似一只展翅欲飞的大鹏，好大的气魄！随喜随喜！
    不过先说好，您将来有心得时别忘了教我。
    对《华严经》的注释，可分为两类：一者为画龙点睛者，二者为逐句逐段解释经文者。
    在第一类著作中，本人认为杜顺大师的《华严五教止观》最应受到重视。其原因是：
    一、大师为华严宗的奠基者。
    通常某一宗派奠基者的著作同后来之集大成者相比往往比较简练，不够全面和恢弘，但奠基者眼光的独到之处是我们应该特别关注的。（世间的学问也是如此，如果你想真正了解某一方向，该方向的第一篇论文 一定要特别认真地研读。）
    二、《华严五教止观》中的“华严三昧门”以简短的文字为行人指出了入不思议法界的妙门──缘起法的不可分别性。从此妙门得入者，既可以远离断常等诸边，又可成立如来功德之本具，空宗有宗之争可以休矣！
    今人对《华严五教止观》的注释可找到的是台湾智谕大师的作品，《中华佛典宝库》中收录。
    属于这一类的著作还包括：《华严一乘十玄门》（智俨撰承杜顺和尚说）、《大方广佛华严经金师子章》（法藏大师述）、《三圣圆融观门》（澄观大师述）（有兴趣者可将此中之普贤、文殊与藏传宁玛之普贤佛父、普贤佛母比较，将会发现两者之间具有惊人的相似性）。新罗青丘沙门见登所集之《华严一乘成佛妙义》也相当精彩，包括了一些实际用心的方法。
    关于杜顺大师的《华严法界观门》，《大正藏》没有单独收入此文。但《注华严法界观门》（　唐　宗密注）中包含了此文的内容，需要者可以小心地从释文中“剥离”出正文。
    给诸兄提个醒，法藏大师《大方广佛华严经金师子章》以“金”喻空性，其中“谓以金无自性，随巧匠之缘遂有师子相起，起但是缘故名缘起。谓以师子相虚，唯是真金，师子不有，金体不无，故云色空”等喻。
    对于未于中观下一番苦功而较彻底破除自性执者，常将此“金”错会为不可思议之妙有。学界多有将法藏大师判为真常见者，原因恐怕与此有关。多年前本人学习此论，亦曾错会大师之意。
    其他许多类似著作在大正藏的“诸宗部”中可以查到。
    在第二类著作中，最著名者应是华严宗大师们的一系列作品，例如法藏大师20卷之《华严经探玄记》、澄观大师60卷之《大方广佛华严经疏》和90卷之《大方广佛华严经随疏演义》、长者李通玄20卷之《新华严经论》。权威性超过以上者恐怕是没有了。
    另外，日本华严宗的古德也留下了相当数量的论著（大正藏“续诸宗部”收录），同样是心血的凝聚，您若有精力不妨参学。
    最后，给您提个建议──在研学华严经论注释的同时不要忽略了修学。杜顺大师曾言（大意），入华严之行门者有二：发菩提心，修普贤行。《华严经》中之“初发心功德品”和“普贤行愿品”正好包含了这两个方面。仁兄若能依此两品经，思维经意随文发愿修观，则不但可以成为华严的学者，同时还能成为华严的行者。解行相资，如虎添翼！
    祝仁兄早日腾飞，利益无边有情！


哪些华严宗著作较适合现代人初学阅读？

    玩主：
    杜顺大师《华严五教止观》，末学看了觉得非常好，多谢！！不过由于末学古文基础不是很好，看的有些似懂非懂，不知道其他佛友是否也有同感？能否翻译成白话？

    zf：
    将该文翻译成白话，恐非在下力所能及。另“佛典宝库”网站中收录了台湾智谕法师对《华严五教止观》的注释，兄可研学。

    老九：
    华严宗乃汉传之大宗，见解深邃，我打算印一些华严宗古德的疏或者讲解，用简体横排，不知道哪些比较适合现在人修学，且需求量比较大，请指点。非常感谢！

    zf：
    随喜发心
    “佛典宝库”网站收录的下列著作较适合现代人阅读。
    华严五教止观浅导【智谕老和尚著】
    华严一乘十玄门修学记【智谕老和尚著】
    华严一乘十玄门探玄【智谕老和尚著】
    华严经义海百门述义【智谕老和尚著】
    修大方广佛华严法界观门直解【智谕老和尚著】

    老九：
    我会考虑这些法宝的，但不知道现在对于这些华严宗方面的法宝需求量如何？因华严之境界乃大乘甚深境界，后学想陆续出版一些华严的法宝，但如果没有人学修、需要，则没有太大的意义。多谢各位大德支持！

    二麻子：
    随喜随喜，总会有人需要的……相信法界广大，无畏惧敢入娑婆修学佛法的菩萨多的是。一年十年百年千年，一定会有需要这些经典的菩萨学人出现。


现代语言逻辑与学华严

    现代语言逻辑与学华严

    zf

    一点体会，在下认为，方先生以现代语言和逻辑对杜顺大师的解读对那些欲理解华严宗思想的行人是有启发意义的。（编按：指方东美先生《以西方方法学的“关系逻辑”来透视杜顺大师的法界观》　一文）
    本人在刚开始研读杜顺大师论著时，遇到的困难之一就是“色不即空，以即空故”这样一些看似矛盾的表述。我们的习惯是同一句话中重复出现的同一个词应该具有相同的含义，但大师常常不按“规矩”办事。初学时摸不着头脑，后来也就慢慢习惯了。
    与此有些类似的是中国画的技法。我们观看一幅山水画时，常常有这样的感觉：一、当观看山的整体时，感觉我们离山的距离是1公里；二、当观看山上两位下棋的老人时，感觉离老人只有100米，因此同一幅画具有不同的视点。
    西方传统的油画，一幅画似乎只有一个视点，很逼真。但近代毕加索的画中，从人的侧面可以看到该人的另一个眼睛和耳朵，把人画得与比目鱼相似，在一幅画中存在多个视点。在这一点上，西方的现代反倒与中国的传统更接近。
    如果你能跟得上华严祖师们的这种“视点”变化，读他们的论著就相对容易了。
    方先生说：
     “所以我们要彻底了解华严宗的这一思想，我们必须要透过近代哲学的眼光，要深一层去认识，当杜顺大师在说这话的时候，他是处于那一种underlying logic　（基础的逻辑）应用，绝不能预先设立一种虚妄的假定，也绝不能误以为每一个term都只是能够有one and unique meaning　（唯一且独特的意义）而已，对于这一种说法，应该从根本来加以放弃，然后才有可能研读华严宗里面的大文章。”

    至于是否如方先生所说之“必须要透过近代哲学的眼光”才能理解祖师们的思想，我想恐怕并不一定（因为祖师们肯定没学过“近代哲学”）。在下也没有学过“近代哲学”，但简单的“视点变换”已经使本人受益匪浅！
    明兄说：“我觉得华严境界是超越逻辑的，要在逻辑层次上清楚、准确表达是不可能的。搞不好两头不落好”，在下同意。
    逻辑的本质是什么？在下不知道逻辑学家的答案。就本人理解，逻辑的本质是某种共许，即对共同性、一致性的认同。如果在下上述理解不错的话，那么这种共许便一定会因众生业力显现的不同，特别是共业显现的不同而有差异。因此六道中不同道的众生应有各自可接受的“逻辑”。例如，天道法界的许多显现对我们人来说很难理解（例如天眼的功能），那么天道众生之共许（对我们来说真正是天方夜谭）能成为我们逻辑的一部分吗？我想这不可能。
    六道众生之间都难有共同的逻辑，而我们的共许与佛界的共许之间的差别更加巨大。华严境界是如来的现量所显（实际上，以我们人道众生语言所表述之“华严境界”与佛之现量相比不知要漏掉多少“信息”），想通过我们的逻辑论证其真实性其难度可想而知！
    退一步，“色即是空，空即是色”这种表述是符合逻辑的吗？如果我们去问一位不信佛的逻辑学家，得到的答案多半是否定的。因为他根本不知这里的“空”为何物（或不接受正确的空义），他所能理解的“空”只能是“没有”、“虚无”、“空洞”、“空旷”、“空间”等。他的逻辑中肯定无法容纳“物质就是没有，没有就是物质”这样“荒唐”的论断。
    但同时在下也认为，尝试以现代语言对古德言教予以解释的努力对我等学人是有启发意义的，虽然这种努力并不能真正使佛法变得合乎一般人可接受的逻辑。


实持与如幻

    实持与如幻

    zf

    一

    “所谓法界缘起论，是华严宗中所主张的。不把实体定为惟一的真如，而说缘起的诸法全都是实体，在现象即实体的立场上进行说明的步骤……”
    ──该篇论文的用词不知是原文作者还是译者的原因，与通常经论不同。如“实体”一词多次采用,且“实体”所指似为华严古德之“无性性”或“理”，请诸兄体会，“实体”和“无性性”或“理”的差别，不是细微，而是巨大。佛弟子对“本体论”应特别小心，小心“本体”的确切含义。佛法是“缘起论”。恰因诸法从缘起，是故一切众生本具如来智慧德相。
    古德教诲，于己应生病人想，于佛应生医王想，于法应生药想。用药重在对症，佛法之药曾医好多少众生的生死大病，我等感恩尚来不及，佛弟子不应因学者们进行的“学术研究”而动摇自己对佛法的信心。

    二

    “有限的对着无限的，能说什么呢？凡夫兄教诲的对：一人不与万人斗。何苦对着无量较劲？”
    ──呵呵，原来仁兄是被“无边、无尽、无量”给吓住了！
    我若是让您一口吞下无量世界，您一定会想：zf肯定是疯了！
    可如来分明告诉我们，无量世界全部在您碗中的一粒米中。
    您能吃下一粒米，也能吞下无量世界！

    “有限的对着无限的，能说什么呢？”
    我的回答是：有限包含着无限，有限就是无限。
    别忘了，无限的烦恼终究是幻象。
    当无明这一基石被破除时，建立在其上的无限烦恼大厦，便会轰然坍塌。

    “没救了。：（）”
    ──有救！

    三

    一个和地狱有关的“幸运”错误。

    地狱中的景象实在可怕。因果不虚，“诸恶莫作，众善奉行”的真言我等一刻也不要忘记。
    同时也想起了一个和地狱有关故事，出自《三宝感应要略录》（大正藏No.2084）：
    空观寺沙弥定生见红莲地狱谬谓实华藏世界感应
    沙弥定生。师僧法不能诵经戒。闻陈说花藏世界相。情恒慕乐。恣误僧事。入红莲花地狱。谬谓花藏世界。欢喜称花藏妙土。其时地狱变为花藏。闻唱受苦之人。皆坐莲花。时狱官白阎魔大王。王言。此是花严大不思议经力。即说偈言
    归命花严　　不思议经　　若闻题名
    一四句偈　　能排地狱　　解脱业缚
    诸地狱器　　皆为花藏　　而皆自见
    坐宝莲花

    关于红莲地狱，“佛光大词典”中介绍如下：
     红莲地狱，亦称为钵头摩地狱，八寒地狱之一。据瑜伽师地论卷四载，受生此地狱者，严寒逼切，其身变成红赤之色，皮肤冻裂，故称红莲。另据立世阿毗昙论卷一地动品载，为十寒地狱中之第十，瞿伽离比丘以诽谤舍利弗及目犍连，堕此地狱。然长阿含经卷十九地狱品以之为热地狱之一种，其狱中皆呈赤色，如钵头摩华之色，故称钵头摩。又谓此地狱中火焰炽盛，罪人距火一百由旬，火已烧炙；距火六十由旬，两耳已聋；距火五十由旬，两目已盲，无所复见。

    这个故事告诉我们：沙弥定生因闻《华严经》中华藏世界的庄严法相而心生欢喜、羡慕。但因不通经戒，恣误僧事，造诸恶业，之后入红莲花地狱。但因其心中深深仰慕华藏世界，而错将可怕之红莲地狱认作华藏世界，欢呼自己终于往生到华藏妙土！沙弥定生这一“错误”的结果是：其时红莲地狱立即变为庄严的华藏世界。地狱中其他受苦之人，亦皆坐莲花，转生佛土！
    这是何等幸运的“错误”啊！
    但这幸运“错误”的发生却绝不是偶然的！
    以此因缘，愿大家皆诚心称念：
    南无大方广佛华严经！


《华严》、《般若理趣经》与大圆满

    常随佛学：
    请教赵叔及诸位善知识，读华严经时本人一个经久的疑惑
    华严经“‘菩提场出九逝多，三四忉利及夜摩，普光明殿二七八，他化兜率五六过。’佛最初在菩提场成道，就是坐在菩提树下宣说华严经六品十一卷；第二会在普光明殿，说经六品四卷；第三会在忉利天，说经六品三卷；第四会在夜摩天，说经四品三卷；第五会在兜率天，说经三品十二卷；第六会在他化天，说经一品六卷；第七会重在普光明殿，说经十一品十三卷；第八会也是在普光明殿，说经一品七卷；第九会在逝多林，说经一品二十一卷。何谓‘逝多林’？‘逝多林’是坟场。下本四万五千偈传到中国，还有五万五千偈九品尚在印度，而没有传到中国来。虽然不足，但是序分、正宗分，及流通分均已全备。所以中国唐朝清凉国师弘扬华严时，认为这部经可作为全经。”
    为何佛陀开演华严大经，均在欲界诸处？此中有何密意？

    zf：
    我的答案是
    “为何佛陀开演华严大经，均在欲界诸处？此中有何密意？”
    ──不知道。
    另外，您什么时候知道了，别忘了告诉我一声。

    nkdj：
    哈哈，赵叔善巧……看来这个问题不是很迫切喽。

    zf：
    这个问题当然很重要，但最重要的是如说修行。

    另外，仁兄读过《般若理趣经》吗？（在《中华佛教百科全书》“不空”“大圆满”词条中，郭元兴大德认为该经与大圆满同一理趣。）也是在欲界天所说。依郭大德的见解，般若理趣乃沟通藏密大圆满和汉地密乘的桥梁！

    天楼霜月:

    我目前知道的所谓华严法界观是珠珠相摄,无穷无尽的因陀罗网和密宗的坛城观或本尊观,是否有异同之处.请您一一说明.

    zf:

    华严的观行和密乘的观行都深广如大海，其间的异同远非在下所能说得清。特别是密乘观行，方便众多，各体系、各门派的成就法数不胜数，简单的概括难免挂一漏万。
    以仁兄提到的坛城观或本尊观为例，通常这种观行的重点并不要求行人一定作到陀罗网观。

    huyg：
    请教，密法里的普贤王如来与汉传佛教里的普贤菩萨是什么关系？此前有师兄回答过，后学还是不太明白，敬请指教。

    二麻子：
    敬回……普贤王如来在密法里的表意大致是法身佛的意思。当然，密法有它自己的表述体系，这个意思跟我们汉地说法身佛的含义还是有点差别。如果再加上如来藏本来清净本来圆成的含义就差别比较小了。

    zf:

    关于藏文《华严经》来历的一个惊人说法是:

    义成活佛（Tulku Thondup）在《大圆满修习》（The Practice of Dzogchen，Snow Lion Publications，1989）一书中论及大圆满与汉地和尚摩诃衍的关系时引用了龙青巴尊者《宗轮藏》（Theg-Pa Tham-Chad Kyi Don gSal-Bar Byed-Pa Grub-Pa’i mTha’Rin-Po-Ch’e’i mDzod(f.206)by Dri-Med A’od-Zer. Published by Dodrup Chen Rinpoche.）中的一段话：复须注意，或谓不少大乘经教之翻译为藏文，乃凭一名大乘和尚之记忆而成。究竟此是否与摩诃衍同属一人？龙青巴尊者于《宗轮藏》中云：“不少被日成焚毁于天竺那烂陀寺之经典，先已译成汉文，如《华严》、《大般涅槃》及《律藏》等，由遍照护及巴.尚喜二人据大乘和尚之记忆而译为藏文。”
    （以上由许锡恩所译，取自谈锡永主编之《九乘次第论集》）

    英文原文如下：
     It is also worth noting that some sources say that many Mahayana Buddhist scriptures were translated into Tibetan from the memory of a Ha-shang Mahayana。Who knows whether it is the same Ha-shang or another？Longchen Rabjam says：“Many sutras such as the Avatamsaka， Mahaparinirvana（sutra），and Vinayagama，which were translated into Chinese before they were burned（at Nalanda monastery in India）by Nyima Ngodrub，were translated into Tibetan by Vairocana and Ba Sangshi from the memory of Ha-shang Mahayana。 ”

    齐愍:

    是, 德格目录上确有毗卢遮那译师的名字,根据那本目录上的记载，西藏传本华严经(80华严)的翻译者是:
    印度班智达胜友译师(jinamatra)、印度班智达戒王菩提译师(Silendrabodhi) 和宁玛派祖师移喜德译师(Ye-ses-sde)。
    而这个版本的翻译校订者是：
    宁玛派祖师毗卢遮那译师(Vairocana，遍照护)
    宁玛佛教史著作也多有谈到，其中两位宁玛派早期藏地祖师毗卢遮那译师、移喜德译师与诗列僧哈（宁玛派早期祖师，汉人，又译作宋惠寿）颇有因缘，如《大圆满法门传承》中说：
    无垢友（Vimalamitra）祖师，定中见空行嘱附他去中国五台山向诗列僧哈求法，在五台山住了三年，得到教授，但未得到法本。无垢友祖师以近二百岁高龄，应藏王邀请，在西藏传授大圆满，和莲华生大士互为师徒。加那苏川（Jana Sutra，藏文Yeshe Do），亦受空行嘱附，去中国五台山向诗列僧哈求法，住了九年，得到法本。再传法本于无垢友、莲华生大士、毗卢遮那译师。后无垢友祖师集为“无垢友心髓”四卷。又称老派，长传（Karma）大圆满。
    莲师弟子毗卢遮那大译师，曾由加那苏川（Jana Sutra，即　Yeshe Do）、诗列僧哈、莲华生大士处受法，著有《心部（Semde）十八部》。


显与隐

    zf：
    关于四大和五蕴之间的关系，兄自己慢慢梳理吧。随着修学的进步，原来模糊的认识逐渐会变得清晰起来。华严所开示的法界，如因陀罗网，重重无尽，事事无碍。随举一法，无论色法心法，全收法界。法界粗分为十：四圣（佛、菩萨、缘觉、声闻）六凡（即六道众生）。因自心业力，当一界显时，余界即隐。例如六道众生，虽显现种种烦恼，但如来仍说我等烦恼身心之中具足如来智慧德相，此即烦恼显，如来功德隐。这里的差别是显和隐，而不是有和无。
    说众生是烦恼显、如来功德隐，诸位可能还觉得可以接受，毕竟佛说众生是如来藏。若说诸佛是如来功德显、众生烦恼隐，诸兄中可能会有人感到头皮发紧、背后发凉。因为我们多数人心中的如来是纯粹之功德聚，烦恼是彻底的无，绝不是显隐的隐。但实际上，只要从生死轮回到一切种智之一切法自性为空，则诸法必然你中有我，我中有你。正如杜顺大师所说：“性即无为，不可分别，随其大小，性无不圆，一切亦即全性为身，是故全彼为此。”
    这里需要指出的是，如来心中所隐之烦恼永无重新生起现行之可能，而众生心中所隐如来功德生起现行的可能却永远不会消失。
    天台宗祖师亦有如来只断相恶不断性恶之说，此说与华严异曲同工。感兴趣的师兄可以仔细研读天台祖师的论著。

    石头：
    什么是有？什么是无？
    用显与隐的说法既高明，又体现祖师用心良苦。“有”的本意应该是我们能够体会其存在。“无”当然是无法体会其存在。从本质上讲，有与无就是显与隐。然而，我们执著“有”为先验的有，“无”为先验的无。也就是把“有”定义为无条件的存在，把“无”定义为无条件的不存在。此时用有或无的概念来衡量色身，来衡量如来功德，就会存在问题。改用显与隐较为方便。
    在下如此理解，不只是否恰当？

    zf：
    石头兄，在下认为，我等学佛就是要舍弃自己的众生见，设法学习理解如来见。
    如来以佛眼观我等众生，本具如来智慧德相，但此德相，因我等烦恼障碍，无法现前发挥作用。我们因为感觉不到此德相的作用，故说“没有”，如来了知此不能发挥作用的德相，故说“隐”。
    这时就需要我们拿出勇气──舍众生见，学如来见。

    西澈：
    与您探讨，隐换为转是否更恰当？另外，请教您提的著作是哪几部呢？有劳，先谢谢了。

    zf：
    天台传灯大师的《性善恶论》对此有详细说明。

    Eagle：
    “如来心中所隐之烦恼”一句大有文章，还是再请ZF叔吧。

    zf：
    多说几句，显隐之说，亦是祖师不得已而言之。因我等众生由无明串习，无论谈显谈隐，心中总是隐含着一实有法的显和隐。而佛所开示的华严境界，是以诸法彻底的空为前提。正因为从生死轮回到如来德相一切的一切都依缘起而无丝毫自性，故此如梦如幻之一切法方能无碍地自在显现。杜顺大师在《华严五教止观》中详细解说了无尽法界之因陀罗网喻。诸兄借助此喻，仔细体会此中显隐的真义。“然帝释天珠网者。即号因陀罗网也。然此帝网皆以宝成。以宝明彻递相影现涉入重重。于一珠中同时顿现。随一即尔。竟无去来也。今且向西南边。取一颗珠。验之。即此一珠能顿现一切珠影。此珠既尔。余一一亦然。既一一珠一时顿现一切珠既尔。余一一亦然。如是重重无有边际。有边即此重重无边际珠影皆在一珠中。炳然高现。余皆不妨此。若于一珠中坐时。即坐着十方重重一切珠也。何以故。一珠中有一切珠故。一切珠中有一珠时。亦即着一切珠也。一切反此。准以思之。既于一珠中入一切珠。而竟不出此一珠。于一切珠入一珠。而竟不起此一珠。问既言于一珠中入一切珠而竟不出此一珠者。云何得入一切珠耶。答只由不出此珠。是故得入一切珠。若出此一珠入一切珠者（即不得入一切珠也。何以故。离此珠内无别珠故。问若离此珠内无一切珠者。此网即但）一珠所成。如何言结多珠成耶。答只由唯独一珠方始始结多为网。何以故。由此一珠独成网故。若去此珠。全无网故。问若唯独一珠者。云何言结成网耶。答结多珠成网者。即唯独一珠也。何以故。一是总相具多成故。若无一。一切无故。是故此网一珠成也。一切入一。准思可知。问虽西南边一珠总收十方一切珠尽无余。方各各有珠。云何言网唯一珠成耶。答十方一切珠者。总是西南方一颗珠也。何以故。西南边一珠即十方一切珠故。若不信西南边一珠即是十方一切珠者。但以墨点。点西南边一珠者。一珠着时即十方中皆有墨点。既十方一切珠上皆有墨点。故知十方一切珠即是一珠也。言十方一切珠不是西南边一珠者。岂可是人一时遍点十方一切珠耶。纵令遍点十方一切珠者。即是一珠也。此一为始既尔。余为初亦然。重重无际点点皆同。杳杳难原。一成咸毕。如斯妙喻类法思之。法不如然。喻同非喻。一分相似故以为言。何者。此珠但得影相摄入。其质各殊。法不如然。全体交彻故。”
    上面最后一句：“如斯妙喻类法思之。法不如然。喻同非喻。一分相似故以为言。何者。此珠但得影相摄入。其质各殊。法不如然。全体交彻故。”是说，以因陀罗网比喻无尽法界，只是少分相似。其原因在于，我等众生因无明执著，异熟果报之色身等境多为有碍，比喻中之珠“其质各殊，但得影相摄入”；若离无明执著，则诸法“全体交彻”。此全体交彻便是正确理解显隐的关键。
    虽然多说了几句，但还是觉得言不达意。诸位若觉在下前面“显隐”之说不如理，丢到一边就是了。多在菩提心和去除自性执上下功夫总是没错的。

    无不可：
    如来心中无有执著，哪里谈得上什么有烦恼无烦恼，烦恼显烦恼隐的问题。过去见您提到不坏色故自性空，是否这个不坏色，赵叔没有注意到并不是不坏执著。

    zf：
    请进，空之一字，有人理解为没有或虚无。但空之所指乃缘起如幻义，不是实有也不是完全的无。
    色不待坏,其性即空,是指:色正显现之时，因其为缘起法，故无自性，称之为空。

    无不可：
    同意您的说法，但分歧却不是在这。所以色不待坏，就是要承认因缘法，就是要承认色的正显现，正是因缘现起，不是完全的无，因无自性，称之为空。这个空性，在凡在圣都是空。
    但是在如来的心中，这种无分别智，是以灭坏掉执著为前提的。
    烦恼是执著的产物。虽然烦恼也是空性的，按理也可以说烦恼不待坏其性即空。但是在如来的境界中，是证得了这个空体，是无挂碍，故无有恐怖，远离颠倒梦想，究竟涅槃。无烦恼之隐显可言。在这个色既是空，空既是色的境界中，色不是烦恼色，只是缘起色。

    zf：
    “但是在如来的心中，这种无分别智，是以灭坏掉执著为前提的。烦恼是执著的产物。虽然烦恼也是空性的，按理也可以说烦恼不待坏其性即空。”
    ──同意
    “但是在如来的境界中，是证得了这个空体，是无挂碍，故无有恐怖，远离颠倒梦想，究竟涅磐。无烦恼之隐显可言”
    ──如来功德的证得是缘起法，众生烦恼的现前亦是缘起法。如来功德正现前时，众生之烦恼即隐于其中。法性如是。

    二麻子：
    嘻嘻，麻子多插一嘴？
    如果麻子不是误解双方的话，在麻子看来……
    无不可兄说的如来是“圣”如来，不包括凡夫。
    不能说无不可兄的说法是错的。
    ZF兄所说的如来是圣凡不二的如来：凡夫并不在如来心外，故凡夫心中之烦恼，嘻嘻，也没在外。但此烦恼，却也污染不了如来。故称隐。
    这个地方ZF兄的显隐之说，表面是来自天台宗，背后藏着华严的法界观。嘻嘻。可能无不可兄没注意到。
    不知道麻子说到二位讨论的关键点没有。
    其实说隐显有它更亲切的一些方面。麻子若说破这个方面，定招人心里骂，所以算了。嘻嘻。

    zf：
    老兄所说极是！


显现与局部漫谈

    无畏持明：
    外面的显现，既不是自己的心，也不是心以外的事物。

    海印：
    那么，“外面的显现”应是怎么显现的？？？

    二麻子：
    哈哈，我猜，无畏兄不过是在标题的最前头省略了“所谓”二字，您就看上了。嘻嘻。

    海印：
    我是联想后面“既不是自己的心……”如果不是……也不是……，那么，后学确实不知道是怎么显现的了！

    二麻子：
    嘻嘻，给你翻译翻译。虽然还可以有很多方法解释一下怎么显现什么现象之类的，但归根结底不如直接把你这一问翻译成一下：
    “如果不是……也不是……那么，后学确实不知道无明是从哪里来的了”。嘻嘻，这个熟悉吧。
    其实关键真的是删去的那两个字，否则一不小心随着妄想走了，就心内心外的，先二元对立上了，再“怎么”也“不是”。

    海印：
    继续请教麻叔，我在网上认识了您，别人也认识了您，您的显现，就我们的妄心来说，我对心中显现的您认识对吗？别人对您的认识对吗？您在后学这里与在别人那里，是一个不变的认识吗？另：后学打开电脑见到网络上您的名字，关掉电脑想着您的名字，与您人的存在有什么样的关系呢？

    二麻子：
    海印兄换题目了呢。如果你先确定在人我对立的范围里说话，那么俺先就字面回您：
    就我们的妄心来说，我对心中显现的您认识对吗？
    ──这个我不知道。

    别人对您的认识对吗？
    ──这个我一样不知道。

    您在后学这里与在别人那里，是一个不变的认识吗？
    ──这怎么要问麻子？您当然知道不是。

    另：后学打开电脑见到网络上您的名字，关掉电脑想着您的名字，与您人的存在有什么样的关系呢？
    ──妄想攀缘的关系吧。
    所以您这几问其实没大意思。但是，您偷偷换了题目自己知道吗？前面你问是“非局部”的显现怎么来的，如同圆觉经里问明妙真心如何出现山河大地。这帖里你问的是局部一法的显现。这个100％可以用因缘的聚合说明。但在这个地方讨论，我想100％不是无畏兄的本意。

    海印：
    如麻叔所说，“局部”与“非局部”有什么区别吗？
    后学感到在您这段文字里：
    “以您这几问其实没大意思。但是，您偷偷换了题目自己知道吗？前面你问是‘非局部’的显现怎么来的，如同圆觉经里问明妙真心如何出现山河大地。这帖里你问的是局部一法的显现。这个100％可以用因缘的聚合说明。但在这个地方讨论，我想100％不是无畏兄的本意。”
    难以接受“局部”与“非局部”的区分。就算有局部与非局部的区分，那么所显现的法，如何是局部呢？如何是非局部呢？
    如果认为局部的就是具体事相，比如我们吃饭拉撒以及所见山河大地具体事相等，若另有非局部的什么，或说整体的什么，那么100％则成为了一种抽象的东西。
    那么，无异承认这个抽象的（遍计所执）头脑中产生的“事物”实有性了。

    二麻子：
    嘻嘻，海印兄能不能再仔细点？
    实相上谈不到什么局部不局部，不过，这次讨论的一直都在俗义范围里。
    即使在俗义里，也未必有个什么“非局部”按俗义有的意义存在。不过，在我们凡夫的思维逻辑里，局部与非局部的差别是存在的，而且有时候差别严重。你的问题恰恰落在差别严重的范围里。
    不信？看个例子。“任何一法都是因缘所成”。这话正确没问题，注意这是局部表述。
    再看：“一切因缘法的全体，是不是因缘所成”？
    这是个非局部描述。你看看怎么回答才是？
    怎么回答都不对呢。你能说我们凡夫的逻辑在这没差别？
    回到这讨论的开始，无畏兄与你说的显现都是指一切显现吧？后来你具体到麻子头上时候，变成局部。你注意到这个差别了吗？现在注意到了吗？我们思维的时候在这样的地方很容易看不到的地方。仔细点看就是了，别发急。

    海印：
    感谢麻叔，但个别地方我只有暂时存疑，
    “不信？看个例子。‘任何一法都是因缘所成’。这话正确没问题，注意这是局部表述。
    再看：‘一切因缘法的全体，是不是因缘所成’？这是个非局部描述。你看看怎么回答才是？怎么回答都不对呢。你能说我们凡夫的逻辑在这没差别？”
    ＊我认为您上一帖中那种区分“局部表述”与“非局部描述”是无多大意义的，可能在哲学上有些意义。
    虽然您说“不过，在我们凡夫的思维逻辑里，局部与非局部的差别是存在的，而且有时候差别严重。你的问题恰恰落在差别严重的范围里。”我承认自己妄执，但是，佛法是不会顺从我们的错误而妄计遍执的，佛说法恰恰是要纠正我们的错误的。
    再，经中说“应观法界性，一切唯心造”，这是局部非局部描述？“一法入一切法中，一切法入一法中”一法、一切法圆摄无碍，虽然我未领悟，但引用经典该可以吧！这是局部非局部？若“诸法唯心造”是整体还是局部？不论整体或局部（尽管这种区分是妄执），并不能排除唯心造作。‘如果有区分局部与整体的必要，如果存在二者不同，那么，禅宗百千公案则无从成立！
    面对正常讨论，麻叔这样说“仔细点看就是了，别发急。”既然您这样认为，那后学只有暂时存疑了。

    dawa：
    插句嘴，俺也举个例子，或许能清楚表明局部、非局部的差异。
    海印兄可能没有意识到这区别是很简单的，应该算不上哲学吧。
    局部：1，3，5，7，9　都是奇数
    非局部：｛1，3，5，7，9｝谈不上奇偶性。

    海印：
    您举例说的这个概念我理解。但是，我指的问题是：
    从诸法唯心现角度讲，根本不存在局部与非局部的规定。
    假设存在二者区分，说“局部”是心现，“非局部”非心现，则应是大错特错。
    换句话说，难道，若具体某人妄心所现境是局部，此外，（因为众生无量，妄心亦无量）就可以说还存在“一切外境”所谓非局部吗？
    那么，我问，天有边吗？您怎么回答？这就是什么非局部？

    二麻子：
    有人说过非局部与心现不心现有关吗？

    海印：
    先说您提出概念划分之事实证据：无畏兄说外面的显现既不是自己的心……，我提问说，（基于无畏兄这些前提）那么外面的显现应是怎么显现的？经过系列讨论后，您说了这段话“但是，您偷偷换了题目自己知道吗？前面你问是‘非局部’的显现怎么来的，如同圆觉经里问明妙真心如何出现山河大地。这帖里你问的是局部一法的显现。这个100％可以用因缘的聚合说明。但在这个地方讨论，我想100％不是无畏兄的本意。”
    当然，紧接着，由于水平有限，凭我的接受能力，难以接受这种区分……我仔细想了一下，您是否基于这个原因而出现局部显现与非局部显现概念之分的？您从诸法即色即空的角度来了个“非局部”的说法？但是，我觉得哪怕具体微小（勉强形容）之法，因缘起性空故，而此性空含遍法界，没有大小内外的说法，故推论缘起显现，没有局部非局部的说法，正如经说“一微尘中有无量佛土”，再，诸法唯心现，本身不违缘起性空，故用不着区分所谓“非局部”显现，所以我前帖引用说“佛说诸法对治诸妄心，既无一切心，何用一切法”，所以，用不着担心大家陷入因“心”而执“我”的陷阱。相反，非局部说法倒成了一种遍计执着。
    请指正！

    zf：
    “……但是，我觉得哪怕具体微小（勉强形容）之法，因缘起性空故，而此性空含遍法界，没有大小内外的说法，故推论缘起显现，没有局部非局部的说法，正如经说‘一微尘中有无量佛土’，……”
    ──仁兄，法界本来一即一切，但这对我等行人来说，还只是一种“见”（当然，仅持此见就具无量功德）。要使此无碍法界在心中如实显现还要无量功德的相助方能“缘起”。因缘具足时，得入海印三昧（兄以“海印”为名，想来对此三昧“情有独钟”！），方亲证实相。因此仁兄之“缘起显现，没有局部非局部”的说法恐怕只对佛适用。
    对六道凡夫乃至菩萨来说，显现的只能是无碍法界中与自业力相应的某一局部。
    华严十玄中的隐、显之说正是针对此处。

    海印：
    在赵叔您所限定的这个环境中，后学理解并接受局部与非局部的区分，此差别相谁也不能否定。
    但针对“外界显现”是否“心现”“不心现”的话题，确实并没有因我们是凡夫而改变实相之理。人与人的差别相，凡夫乃至菩萨与佛存在差别相，但并不因为诸法所谓“局部或整体”的不同而存在“唯心所现”的不同说法。
    南无阿弥陀佛！

    二麻子：
    绕了半天，还是老话……无畏兄原贴子前面如果加上所谓二字，就避免了这些联想。

    二麻子：
    奥，前面说的很清楚……
    那些讨论是在俗义上说的，如果你不吱声又要跳到圣人立场上去，麻子祝愿你起跳成功。但不停变换立场却使讨论失去共许的基础。
    如果你没注意到自己又换成圣人立场，麻子这里算个提醒。额外的提醒是，即使思维上换到圣人立场，也不过是个思维假设的圣人立场。
    也许我的提醒对你没多大意义。佛法虽然不会随顺我们的妄执，我们对自己妄执不清楚，却是很能随顺的呢。把妄执换为轮回，同样成立吧。

    海印：
    这样说法：
    “那些讨论是在俗义上说的，如果你不吱声又要跳到圣人立场上去，麻子祝愿你起跳成功。”
    ──请教麻叔，如果我读诵经典，引用佛言祖语发帖，这是否意味着跳到圣人立场？且我们每个人能否保证自己不出错？
    前帖劝我别急，这里又说我跳到圣人立场上去，这令我想像不到。麻叔啊！您多悲悯点吧！
    阿弥陀佛！

    二麻子：
    您似乎只在看我呢……
    引用经论当然是好的，但不至于以为经论上的话我会念，就是我真懂吧。
    “前帖劝我别急，这里又说我跳到圣人立场上去，这令我想象不到。”
    ──对呀，麻子立场连贯，有什么想像不到的？
    嘻嘻，你要麻子怎么着呢？你自己是快是慢是跳是没跳，都在上面呢。你倒是悲悯大家呀。

    海印：
    感觉与您讨论问题，最好一个腔调。不然，帽子。

    二麻子：
    最好一个立场，这样大家比较容易说话，一定要改换立场说话也可以，但是希望自己清楚每个改换，别把话说混扰了。实在混扰了也没法子，但别发急。发急别生气，生气别扣帽子。扣了帽子也希望看看，这帽子是不是自己先扣出来的。嘻嘻。
    如果这些都没法子，歇几天再说也好。

    幻海宏愿：
    嘻嘻，能知道有“非局部”也不容易呢。
    我为什么会饱？因为吃饭了。这是局部吧？我执为什么产生？这个就非局部了。
    我们凡夫看问题时，基于所执能所相似能看清的算是局部。不破能所二执，就看不清的为非局部。
    就象所谓外境的显现，这个东西解释不清，因为一要想解释，早就落入能所而不自知了。凡夫离不开我执，若不除我执。自然对“非局部”的无能为力。
    意识到有非局部存在，也不容易呢。下一步说不定就能看到我执的升起之处了。

    yang：
    要产生“非局部”这样的戏论，确实不容易！

    【我为什么会饱？因为吃饭了。这是局部吧？我执为什么产生？这个就非局部了。】
    ──这个是戏论，要是大家都是，要不是大家都不是，凭什么吃饭会饱就是局部，我执产生就变成非局部了？

    【我们凡夫看问题时，基于所执能所相似能看清的算是局部。不破能所二执，就看不清的为非局部。】
    ──你这个“能所二执”和“所执能所”是不是一回事？如果是，破了能所，你拿什么看？如果不是，那么能所和“能所二执”又是什么关系？是不是破了“能所二执”后剩下的“能所”就能看清“非局部”，或者说“全部”了？

    【就象所谓外境的显现，这个东西解释不清，因为一要想解释，早就落入能所而不自知了。】
    ──是“解释不清”？还是不能解释，因为“一要想解释，早就落入能所而不自知了”。如果是“解释不清”，那是功夫未到。如果是不能解释，那就别解释了。

    【凡夫离不开我执，若不除我执。自然对“非局部”的无能为力。】
    ──听你这意思，若除了我执，就对“非局部”“有能为力”了？

    【意识到有非局部存在，也不容易呢。】
    ──“意识到有非局部存在”，我看也是个局部，而且是个离开实际比较远的“局部”，很容易啊，任何一个执着名相的人都很容易。

    【下一步说不定就能看到我执的升起之处了。】
    ──你“看到”“我执的升起之处”？乖乖！你整个就是一个我执的“升起之处”……别介意，我也是。

    二麻子：
    产生这样的戏论不很难，更难的是认识到这是戏论不要当了真。这些戏论没那么容易被认识清楚，科学界也不过到上世纪初才从集合论里著名的“理发匠悖论”里才认识到。要说我们这些佛弟子们都认识到了，嘿嘿，我看不见得呀。这不是随便说声“这是戏论”就真的认识到的，要么怎么老是看见有人犯这类戏论自己不知道呢？

    勇气是好事，颟顸不是好事。

    QZ：
    文摘：
    “理发匠悖论”
    ……
    “理发匠悖论”是罗素本人为使“罗素悖论”更易于理解提出的，可说是后者的通俗版。
    萨尔维村有这样一位理发匠，他是本村的男人，并且给且只给该村所有不给自己刮胡子的男人刮胡子。
    现在的问题是，这位理发匠是否给自己刮胡子？

    显然：
     如果他给自己刮胡子，他就不给自己刮胡子；
    如果他不给自己刮胡子，他就给自己刮胡子。

    “悖论”由是得以产生。……

    yang：
    这个悖论的成因很简单，直白说明就是了，不过是把应该在“整体”之外对它发生作用的某个个体再规定进“整体”里边去，所谓刀不自割，是个简单的思维游戏。

    二麻子：
    嘻嘻，他的那个例子改得不好。那个悖论本来是……一位给一切不给自己理发的人理发的理发师，该不该给自己理发。
    注意，是一切，不是一个村子。你那个整体之外就没法用了。所以也就没那么简单了。

    yang：
    问题出在哪里？觉悟不是理发。

    二麻子：
    嘻嘻。这个说得好。可惜不够详细……
    理发有能剃和所剃，佛门的觉悟不仅仅是能觉与所觉那样的。
    虽然说有不少随顺能觉所觉的说法，这无可厚非无非是因势引导。如果真把觉悟限制在能觉所觉里，嘻嘻，那就买椟还珠了。

    yang：
    您认识到这是戏论不要当了真，确实不很难，难的是很多人不如麻叔您老人家聪明，多半就绕进去了，而佛陀教法（包括龙树的阐释）重在破相显实，因为以相破相，终必自伤。

    二麻子：
    以相破相与破相显实，矛盾吗？佛经两木相因的说法，您一定见过吧。
    假装不看那个悖论不等于能不陷入，掉进去的人多了。你说这是聪明不聪明！

    yang：
    不矛盾，但是你破的人家更增疑惑了呢，不如明白讲吧。

    二麻子：
    嘻嘻。这个增疑恐怕比不知道疑要好。错的明白就有改正的机会，懵懂不知错的，还不知道什么地方有毛病呢。


平等与显隐

    rj：
    赵叔请进，既然有佛界，众生界，怎么说是平等呢？您是说在无自性性上平等还是别的意思。即使无自性性上平等，平等的是什么呢？无自性性？望确认一下，以免俺对您所说理解的不那么透彻。

    zf：
    平等与取舍：显的众生界＋隐的佛界＝显的佛界＋隐的众生界，我想这应该是真正的平等了吧。但显的不同，即缘起的作用不同，因此取舍还是必须的──诸恶莫作，众善奉行。可见，平等与取舍并不矛盾。

    rj：
    喜不自禁……佛界是靠缘起的吗？众生界是靠缘起的吗？
    什么是各自的缘起作用？缘起即有缘灭……众生界若灭，佛界若何？
    佛界若灭，众生界若何？众生界无尽，佛界无尽，缘起只是显或隐的缘起吧？
    另外，您说的平等是本始基平等吗？还是说体性平等？平等的意义是什么？法尔如是？

    望ZF叔教俺。

    zf：
    “佛界是靠缘起的吗？”
    ──是的。因于众生而起大悲，因于大悲生菩提心，因菩提心成等正觉。

    “众生界是靠缘起的吗？”
    ──是的。无明缘行，行缘识，识缘名色，……

    “什么是各自的缘起作用？”
    ──众生的缘起作用──烦恼；如来的缘起作用──大智大悲。

    “缘起即有缘灭……众生界若灭，佛界若何？”
    ──从本性上看：缘起即是不起，缘灭即是不灭；众生界本无起，众生界亦不灭。
    从作用上看：重重无尽的法界中，缘起即是显，缘灭即是隐。因此，若一切众生成佛，众生界（显众生界＋隐众生界）不减，佛界（显佛界＋隐佛界）不增。
    但莫忘：“虚空界尽，众生界尽，我愿乃尽，而虚空界及众生界不可尽故，我此行愿无有穷尽……”可见众生界不灭。

    “佛界若灭，众生界若何？”
    ──佛界不灭。

    “众生界无尽，佛界无尽，缘起只是显或隐的缘起吧？”
    ──是。

    “您说的平等是本始基平等吗？平等的意义是什么？”
    ──我所理解的“本始基”就是重重无尽的华严法界。一切法皆周遍涵容，你说这是什么意义上的平等?

    rj：
    佛界若是靠缘起的，何以不灭呢？或是隐而不灭。
    众生界亦复如是。隐而显，显而隐，如大海泡沫，一时生，一时灭.那么众生可成佛（佛界显），佛又可为众生？（佛界隐）请赵叔无遮细说。

    zf：
    “佛界若是靠缘起的，何以不灭呢？或是隐而不灭”
    ──此有两义：
    一、如来智慧德相虽依缘起，但一旦生起，便不会再灭，原因是，如来智慧之所缘乃法界之真实相，如来大悲事业之所缘乃整个众生界。法界之真实相不可灭，因此如来智慧不灭；整个众生界不可尽，因此如来之大悲事业不灭。这里的如来乃相待于法界实相和整个众生界，如华严经中之法身佛毗卢遮那。
    二、缘于部分众生的如来报身和化身在因缘尽后亦随之而灭。
    “众生界亦复如是。”
    轮回的根本是无明，无明的所缘为法执──对诸法自性的执著。众生轮回可灭的根据在于，诸法的自性如龟毛兔角，根本就不存在。当无明这一根本错误得到纠正后，缘于此错误的缘起法──轮回自然也就熄灭了。
    但有一点要注意，众生界不是因佛界隐而生起的，即众生不是佛一时糊涂变成的。众生界的存在是无始的，在这无始的存在中，佛界始终隐藏其中。

    rj：
    再请ZF叔。
    众生界无始无终，佛界无始无终。其实为一实相的不同面向。然如何选择面向决定在于无明。
    无明具有单向性──指向轮回界──众生
    明也具有单向性──指向佛界──持明者
    然佛魔不到处呢？是指什么？是无所住而生其心吗？
    又，佛界众生界同一法味，同为如如，如何相应及如何不起相应？

    zf：
    “无明具有单向性──指向轮回界──众生
    明也具有单向性──指向佛界──持明者”
    佛界的“单向性”与众生的“单向性”不同。
    十法界于佛心中可以同时显现，但在众生心中只能显现自己业力相应的部分。

    “然佛魔不到处呢？是指什么？是无所住而生其心吗？”
    概括地说，佛有两种智慧：
    一、如所有智──照见真如；
    二、尽所有智──照见诸法因果。
    这两种智慧对利益众生来说已经足够。
    我们可能会觉得佛还应该有其他“智慧”，如龟为什么没有毛？兔为什么没有角？若一定要说佛有不到处，这些可能算得上。
    至于魔不到的地方那多得是了。
    注意：“佛魔不到处”出于禅师之口。禅师所指与特定对象有关，离开特定环境，在下不知其义。

    “又，佛界众生界同一法味，同为如如，如何相应及如何不起相应。”整个显密佛教都在说这件事。


关于“有”和“无”，看看古德是如何解说的

    zf

    华严杜顺大师在《华严五教止观》中分“遮情”和“表德”两个方面阐述了“有”和“无”。所谓“遮情”者，乃遮止众生之无明也；所谓“表德”者，乃直显缘起法无自性之作用也。是故于遮情部分，有、无、亦有亦无、非有非无俱被否定。何以故？因为此时众生心中之“有”，乃自性有也；此时之“无”，乃断灭无也。
    在“表德”部分，由于圣者已证缘起法之实相，有、无、亦有亦无、非有非无皆与缘起法性无碍。因为此时之“有”，乃表无自性缘起法之作用，即幻有也；此时之“无”，乃表缘起法无尘许之自性也。
    “有”“无”二字虽然相同，但在不同人心中所表之“义”却有天壤之别。
    由此想到麻子在评述汉地禅宗和藏地大圆满时曾说（大意）：禅宗虽属显宗，但在法义的表述上常用否定的形式，并不明说，虽显却密；大圆满虽属密乘，但在法义的表述上却常用肯定的形式，直陈证量，虽密却显。若以杜顺大师上述立场来看这一差别，则虽显却密者，遮情也；虽密却显者，表德也。

    闲话少说，愿诸位仔细品味杜顺大师的殊胜开示：
    三者显法离言绝解。就此门中亦为二。一遮情。二表德。
    言遮情者。问缘起是有耶。答不也。即空故。缘起之法无性即空。
    问是无耶。答不也。即有故。以缘起之法即由无始得有故。
    问亦有亦无耶。答不也。空有圆融一无二故。缘起之法空有一际无二相故也。如金与庄严具。思之。
    问非有非无耶。答不也。不碍两存故。以缘起之法空有互夺同时成也。
    问定是无耶。答不也。空有互融两不存故。缘起之法空夺有尽唯空而非有。有夺空尽唯有而非空。相夺同时两相双泯。
    二表德者。问缘起是有耶。答是也。幻有不无故。
    问是无耶。答是也。无性即空故也。
    问亦有亦无耶。答是也。不碍两存故。
    问非有非无耶。答是也。互夺双泯故。
    又以缘起故是有。以缘起故是非有非无。以缘起故是亦有亦无。以缘起故是无。乃至一不一。亦一亦不一。非一非不一。多不多。亦多亦不多。非多非不多。如是是多。是一。亦是多亦是一。非是一非是多。即不即四句准之如是。遮表圆融无碍皆由缘起自在故也。若能如是者。方得见缘起法也。

    关于“非有非无”还要多说几句,在“遮情”部分，“问非有非无耶。答不也。不碍两存故。以缘起之法空有互夺同时成也。”这里“不碍两存”是指缘起之“有”和无自性之“无”是互不相碍同时成立的。既然如此，为什么还说“缘起之法空有互夺同时成也”呢？这里“互夺”是互相矛盾的意思。那么“空”与“有”在什么情况下才是互相矛盾的呢？显然无自性之空与自性之实有是矛盾的；断灭之空与缘起之幻有是矛盾的。当以无自性之空破除了自性之实有，以缘起之幻有破除了断灭之空时，无自性之空与缘起之幻有一定是同时成立的。此时如对缘起之幻有和无自性之空再予以否定（即此处之“非有非无”）便是不如法了。
    在“表德”部分，“问非有非无耶。答是也。互夺双泯故。”这里“非有”是否定自性之实有；“非无”是否定断灭之空。同样以无自性之空破除自性之实有，以缘起之幻有破除断灭之空，在这一互夺双泯的前提下，对自性之实有与断灭之空的双重否定是极为应理的。这便是此处“非有非无”的法义。
    杜顺大师在这里的行文中，“有”“无”二字有时在同一句话中亦具有不同的含义。若了解其义，便觉大师言教字字珠玑；若不解其义，会觉得文中充满矛盾，不知所云。
    就在下的理解，无自性空与缘起幻有是从两个方面对同一件“事”的描述。因此两者均可用来破除我、法二执。本质上，我、法二执是一回事，只是粗细上的差别。


天台与华严遥相呼应

    天台与华严遥相呼应

    智行

    杜公《华严五教止观》“遮情”和“表德”之说非常圆满，在下非常喜欢其中所用“遮情”和“表德”二词，可以显出通常所见之“泯谛”和“立谛”二词中的深义。
    “表德”表现出诸法之总特点，空，有，非有非空，亦有亦空，乃至种种特性，皆性德也！诸法皆有这些特性，众生以情执故只见部份，不见全体，故需遮情（破边执也），才能圆见性德全体。若执空或执有一边，即是天台所说之藏、通根机之众生。若离空有二边（也就是非空非有），则入别教之机，行于中道。但此时若不见“亦有亦空”（也就是“即有即空”），则是“但中”，虽已入不思议中道，较“圆中”则又稍逊一筹。若离空有二边（也就是非空非有），同时亦见“亦有亦空”（也就是“即有即空”）之二边，则入圆中道。若说圆中道之破（“遮情”也），则两边不立，中道不存（离非空非有、离亦空亦有），一切俱破；若说圆中道之立，一切皆立（“表德”也），则曰即空、即有、即非空非有、即亦空亦有。这就是通常天台所说的即空假中而非空假中，也可说即空假中而不住空假中，是义与华严如出一辙。故学般若人从天台或华严教门入，知见不易偏在一边。


根本的并起与显隐

    静风：
    昨天听人讲俱舍，说是对法藏。个人认为对法都是并起的。嘻嘻，好像不并起的法也找不到。昏沉和散乱是不是并起，我一点也没体会，不过我觉得研究一下，佛性的显现和昏沉散乱是不是并起似乎更有意义。当然，这里说并起好像不大合适。（编按：这个讨论是延续昏沉散乱并起的问题，见“昏沉谈不到是什么境界”一文。）

    zf：
    根本的并起，如来功德与众生烦恼并起。在众生，烦恼显，如来功德隐，这就是“如来藏”；在如来，功德显，众生烦恼隐，这就是“烦恼藏”。

    无不可：
    赵叔，您贴中的两个“藏”字各发什么音？

    zf：
    请进，文中“如来藏”和“烦恼藏”中的“藏”应读成zang（4声）。
    这里“藏”的意思应该是“隐藏”。

    无不可：
    麻叔，记得您上次也加入了这个话题，“在众生，烦恼显，如来功德隐，这就是‘如来藏’；在如来，功德显，众生烦恼隐，这就是‘烦恼藏’。”刚才想到，这里的主语是：功德，烦恼。这两个都是“用”。是从这个角度说的吗？

    二麻子：
    千万别忘了这些话都是说给凡夫听的……圣人们不需要这些话。这就决定了说话的出发点……

    无不可：
    那两个“藏”字如果发“cang2”音的话，上面这句话如果这么说我不会误会：
    在众生，烦恼显，如来功德隐，这就是“功德藏”；
    在如来，功德显，众生烦恼隐，这就是“烦恼藏”。
    赵叔是这个意思吧。如果不是这个意思的话，望赵叔告诉我这句话的出处，我查一下。

    zf：
    就是这个意思。


众生本具的如来智慧德相是隐藏的

    信愿行:
    本人因前世不修善业故，今生落在偏乡僻壤，独自一人，心向佛法而难值善知识教导，故于佛法尚属懵懂。近日听朋友介绍，入于宝地，听到各位善知识的开示，不胜欢喜。
    现在有一疑问：看书上说，“众生本具佛性，因一念无明而坠入轮回”，既然已具佛性，为什么会坠入轮回？

    zf:

    只要网络在，天涯若比邻。
    试答:
    众生本具佛性，并非指众生都曾是如来功德现前的佛。众生本具的如来智慧德相是隐藏的，而不是显现的。
    一念无明并不是在某一时间之前没有，突然生起的。无明是没有开始的，因此叫做“无始无明”。
    如果众生以前曾经是佛，突然之间产生了一念无明，就堕落成众生了，这种“轮回中的佛”是对佛性的误解。


关于隐藏

    关于隐藏

    zf

    《大方广入如来智德不思议经》中：“……复与十佛刹不可说百千亿那由他微尘等菩萨摩诃萨俱。皆是一生补处。从余方界。来集于此。尽能普入十方世界。得涅槃道善方便智。安住菩萨观察成就一切众生方便法门。摄诸众生。令断一切戏论执取……于一佛身现一切众生身。一切众生身现一佛身。于众生身现净法身。于净法身现众生身……”
    从上述经文中可以看出，在一生补处诸大菩萨所亲证的法界中，佛身中可以现众生身。此时佛身显，众生身隐，即如来功德显，众生烦恼隐。同时，众生身中亦可以现佛身。此时众生身显，佛身隐，即众生烦恼显，如来功德隐。实际上，《华严经初发心功德品》中“于一毛孔见十方，尽虚空界诸世间，无有一处空无佛，如是佛刹悉清净。于毛孔中见佛刹，复见一切诸众生，三世六趣各不同，昼夜月时有缚解”所表达的法义与《入如来智德不思议经》中这里的法义一致。
    一切众生皆如来藏，对此经论中多有论及，我等行人纵使信不及，也耳熟能详。但如来境界中亦有“烦恼隐藏”，这却是比如来藏更加难信。天台宗灌顶大师在其《观心论疏》中对此解释曰：
    “萨遮尼干子受记经云。一切众生烦恼身。即是如来藏。当知一切烦恼藏有如来法身。湛然满足。如麻中油。如木中火。如地中水。如乳中酪。如藏中宝。是故众生。即如来藏。此并是经明文也。问生死众生有佛法界十如。经论明证理应可信。但佛是出生死人。何得复有六道法界十如耶。答斯义微隐实难可取信。经云。五眼具足成菩提。又佛问须菩提。佛有肉眼不乃至问有佛眼不。答云有。然既有凡夫之肉眼。岂无凡夫之六根。是即肉眼天眼及六根。即是六道法界。慧眼即二乘法界。法眼即菩萨法界。佛眼即佛界。斯则佛既具五眼。则有十法界百如明矣。问众生六根法界十如。皆悉无常。佛既有者亦应无常耶。答经云。所谓彼眼根。于诸如来常具足无减修。了了分明见。乃至彼意根。于诸如来常具足无减修。了了分明知。经云彼者。彼指众生。是则众生六根于诸如来是常。况佛有肉眼等诸根而不是当耶。经云。凡人所知者。名为世谛。如来所知者。名为真谛。斯则虽同照一境。境随于照有真俗之殊。虽同有六根而有常无常之异也。问何以然。答中论云。因缘所生法我说即是空。亦名为假名亦名中道义。六道十如即是因缘生法。二乘十如即是空。菩萨十如即是假。佛十如即是中。是则十界百如。只是三观。佛有空假而常中。不为二边所染。所以佛有十界皆常。而众生虽有三观。不得空中二观用故。为六尘所染。而复无常虽不得用。不可言无空中二观也。贫女不知伏藏。不可言无财。如痴王不善取声。不可言无响也。二谕况之。可以意知。无劳疑也。如是圆信成就名初随喜品人。所以法华格量。此人功德不可思议。诸佛穷劫叹其功德不能令尽。”
    《首楞严三昧经》中开示：“魔界无有定法可示，佛界亦无定法可示，魔界佛界不二不别。”既然众生界与佛界不二不别，那么众生界中有佛界“隐藏”，佛界为什么不能有众生界“隐藏”呢？！若不存在这种互相隐藏的关系，众生界和佛界之间似乎便不够真正平等。
    这样想一想，问题好像并不难理解。
    对此一旦生起信解，便立时获得诸佛穷劫亦不能赞叹尽的不可思议功德。
    何以故？心随顺法界实相故！


一个大家听后都会高兴的秘密

    一个大家听后都会高兴的秘密

    zf

    一个大家听后都会高兴的秘密

    佛说如来不思议秘密大乘经
    称赞金刚手菩萨大秘密主功德品第十

    尔时尊者舍利子。前白佛言。世尊。所有十方世界。贤劫诸菩萨众。现于诸佛世尊所修梵行者。彼金刚手菩萨大秘密主。于是诸菩萨众中。常随何等菩萨之后。佛言。舍利子。止止此是不思议行。世间天人于菩萨行。不生信者返招迷乱。若有众生。为善知识所摄受者。即于是中闻已净信不生惊怖。舍利子白佛言。我于如来极生净信。惟愿世尊为我宣说。佛言舍利子。金刚手菩萨大秘密主常随我后。汝能见不。舍利子白佛言。我以世尊威神力故。今方得见。亦非宿昔自能知见。佛言舍利子。如是如是。汝今当知。彼贤劫中诸菩萨众。而金刚手菩萨大秘密主常随其后。于一切处。现金刚手菩萨形相。以宿愿力及神通力故能如是。舍利子。乃至三千大千世界。所有一切诸众生类。而是金刚手菩萨大秘密主。现本形相亦常随后。然于所现加持智力。亦未圆满。又舍利子。彼金刚手菩萨。常随慈氏菩萨之后。汝能见不。舍利子白佛言。世尊。我今初见非昔所见。佛言舍利子。彼常随后汝自不见。他方世界若诸菩萨。若梵王帝释护世天等。常来见彼金刚手菩萨。执金刚杵。随慈氏菩萨之后。又舍利子。或于一时。彼贤劫中诸菩萨众。为慈氏菩萨现俱胝那庾多百千种诸变化事。而是金刚手菩萨大秘密主。亦随彼诸菩萨之后助加持故。又舍利子。乃至如来作变化事时。彼金刚手菩萨大秘密主亦随佛后。以愿力故助扬圣化。舍利子。是故当知。此如是等。皆是金刚手菩萨大秘密主。不思议神通加持智力。悉具足故
    ──────
    诸位师兄，金刚手秘密主手持金刚杵，始终立于我等身后护持我等，知此事实，心中有何感受？
    不过有一件事，还望三思。经中云：
     “舍利子。乃至三千大千世界。所有一切诸众生类。而是金刚手菩萨大秘密主。现本形相亦常随后。然于所现加持智力。亦未圆满。”
    为何诸众生类虽有金刚手秘密主常随身后，但菩萨的加持却无法圆满？


妙臂菩萨所问经分别数珠持心离障分

    妙臂菩萨所问经分别数珠持心离障分

    西天译经三藏朝散大夫试鸿胪少卿传教大师臣法天奉　诏译

    复次欲等烦恼与心合故。说为轮回。根本烦恼若除。由如清净玻胝迦宝。若离轮回乃名解脱。又如水本清净。于一刹那间尘能浑浊。亦如有情心源本净。于刹那顷被诸烦恼而为染污。
    复次说于数珠。乃有多种。所谓菩提子金刚子。莲花子木槵子。及与砗璖诸宝锡镴铜等。随取一物为珠数一百八。如是得已。持诵行人常保重之。凡持诵时于本尊前。依法安坐调伏诸根。端身自在不得隈倚。系念本尊及真言印契。收摄其心勿令散乱。然取数珠右手执持左手仰承。每诵真言一遍乃掐一珠。所持遍数恒须克定.勿令少剩。持念之法令唇微动。勿使有声亦不露齿。一心专注勿令散动。有情之界居凡夫位。心如猿猴贪着诸境乐而不舍。又如大海被风所激。生起波涛不能自息。凡夫睹境亦复如是。常须收摄不令散动。勿令心源而有波浪。持诵行人若是疲倦。将欲昏睡恐其失念。即起经行。或观四方以适神思。或用冷水洗其面目。既得醒爽复座持诵。行人若是怖于劳苦。心有移动便作是念。此身无主因业所受。无依无定随业流转。轮回八苦何处得免。至于寒暑饥渴蚤虱蚊虻。如是苦恼处处皆有。又复贪欲若盛。作白骨及烂坏不净之观。瞋恚若盛作慈悲观。无明若盛作缘起观。又复若遇冤家观如亲友知识。或复亲友知识忽作冤家。行者若是遇此冤亲境时。莫起分别憎爱之心。当住平等无着正念。又出道场时。不得与婆罗门吠舍首陀等语。又复不应与不男之人女人等语。何以故。盖非乐法之侣。可与助伴同事等语。或是入触便利等事。便须入水澡浴使其洁净。或献香花灯涂赞叹供养。乃至持戒精进持诵修行。一切善法皆悉回向阿耨多罗三藐三菩提。譬如众流皆归于海。既入海已咸成一味。集诸善因总趣佛果。无量福聚自然相随。譬如有人耕田种谷。唯望子实不为藁干。既丰子实其于藁干自然而有。求趣佛果亦复如是。一切福乐不求自至。又持诵人不应为小而妨于大。或若有人来有来请。便应答言。待我自得长寿。及其一切乐具。此心满足。然后能满一切有情之愿
    又复行人当要远离世之八法。所谓善称恶称得利失利。赞叹毁谤苦乐等事。如是之法不得在心。还如大海不宿死尸。乃至刹那亦不同处。又如室中然灯。为防风故。飘鼓若免光明即盛。如持诵人持诵真言。亦须勤勇加行若立。善法增长亦复如是。又持诵人要在摄心。不得歌舞戏乐。我人憍慢邪见邪染。嫉妒懈怠懒惰睡眠。及入喜会迷醉邪论及无义论。以至瞋怒恶口两舌。如是等事皆须远离。又复不得吃供养残食及鬼神残食。行人唯得食三白。及树果菜根乳酪浆等。及大麦面饼油麻滓。及种种麋粥等。又持诵行人当须昼夜精勤如法持诵。常于诸佛法僧及遗身舍利。恭信珍重诚心忏悔。愿一切先罪悉皆消灭。每持诵时先依法请召。持诵了毕。依法回向发愿讫。然后发遣。或至夜分将欲眠睡。于本尊侧不近不远。地上敷吉祥草于草上坐卧。坐定后然。于一切有情起利乐心。作慈悲喜舍等观然后眠睡

    注：本品经从宋代法天三藏译《妙臂菩萨所问经》第一卷节录，主要讲解真言持诵的修行。此经唐代输波迦罗三藏亦进行过两次翻译，名为《苏婆呼童子请问经》，可以作为阅读时的参考，就本篇中的节选列出一些参考的段落：
     本经中“即起经行或观四方以适神思。……无明若盛作缘起观。”一段，输波迦罗译本中作：“应起经行。或观四方。或水洒面令得醒悟。或经行之次无故忆本师僧。或忆旧亡父母。或忆同学。或想淫心即动不定。念诵之人即责身心。是身无主。由业流转一切诸趣。无所依止。舍此身后复受余形。善恶业因由斯不绝。生老病死忧悲苦恼。爱别离苦求不得苦。怨憎会苦五盛阴苦。随所至方终不得免。蚊虻蚤虱蛇蝎辟宫。寒热饥渴。如是等苦处处皆有。诸天共同无逃避路。心欲退转拟向余方者。以斯观门将为对治。若贪恚盛者。修白骨观及膖胀烂坏诸不净观。若瞋火盛作慈悲观。若无明盛作缘生观。”
    本经中“譬如有人耕田种谷。……然后能满一切有情之愿”一段，输波迦罗译本中作：“譬如有人耕田种稻。唯求子实不望藁干。子实成熟收获子已。藁干不求而自然得。行者欲获菩提种子功德。不为世乐求无上菩提以喻其实。诸余世乐。况喻草干不求自获。世乐者。天上人中或二十八天王。或人间作转轮王王四天下。若复有人。为求小利请诈往彼。不应为前人一切退本愿。彼前人。宣如是语而答于彼。待我获果长寿之身。及获种种诸余资具。以无厌心。当利众生。满足所求种种愿已。然后往彼。不须珍重请我往彼。以我薄福而说谄辞。求他供养以为活命。违背真言密教。而受邪命。佛无此教我终不顺”
    本经中“乃至刹那亦不同处。又如室中然灯。……亦须勤勇加行若立。”一段，输波迦罗译本中作：“念诵人若起不善思惟。速应远离。乃至一念勿使在心。譬如室内然灯烛者。只为防风。以无风故灯焰转明。持诵真言。复加勤苦勇猛精进。令善法增长亦复如是。”


浅谈三摩钵提

    zf：
    浅谈三摩钵提

    经云：“若诸菩萨唯观如幻。以佛力故。变化世界种种作用。备行菩萨清净妙行。于陀罗尼不失寂念及诸静慧。此菩萨者名单修三摩钵提。”
    三摩钵提既可与奢摩他和禅那同修，也可单修。
    很多人一提禅修，便以为只有“以净觉心，取静为行”一条路，而忽略了“于陀罗尼不失寂念，及诸静慧”这条“动”的修持之道。
    实际上，“全心是咒，全咒是心”的修持密咒之道正是“单修三摩钵提”的妙方便。

    请看：
    “若诸菩萨唯观如幻，”
    ——“一切有为法，如梦幻泡影”。三界如幻，佛界亦如幻；众生如幻，如来亦如幻；众生业力如幻，如来佛力亦如幻。
    “以佛力故，变化世界种种作用，”
    ——密咒是如来心，总持如来一切功德，因此密咒之力就是佛力。受持密咒者，可以净化身心，可以利益众生，可以庄严世界。
    “备行菩萨清净妙行，”
    ——菩萨清净妙行可概括为六度，而受持密咒者，日日具足六度万行。
    “于陀罗尼不失寂念及诸静慧，”
    ——密咒总持一切佛法，故为陀罗尼；密咒于心中念念相续（即“不失寂念”）的同时，思维密咒之法义（如阿字所示之“诸法本无生”义），就是不失静慧。
    “此菩萨者名单修三摩钵提”
    ——如是修持就是单修三摩钵提。若行人于此方便信心具足，单修此法，成佛足矣。
    另外，若行人能以深信心念念相续地修持普贤行愿，又何尝不是修三摩钵提呢！

    无忧无碍：
    感谢慈悲开阐禅定妙法。想再请问：
    “‘于陀罗尼不失寂念及诸静慧’
    ——密咒总持一切佛法，故为陀罗尼；密咒于心中念念相续（即‘不失寂念’）的同时，思维密咒之法义（如阿字所示之诸法本无生义），就是不失静慧。”
    ——我现在的做法是：密咒一提起来，心就系咒上，心念耳闻。同时保持警觉，念头一出现，马上牵回咒上。
    有时念头是工作生活中的“大事”，刹那之间就有了好主意。此时存在高效的思维（有时知道这类念头起了，也就随它跑，但如果刹那间理不出清楚，就马上放下，回到咒上），但咒音却暂时被压住了。

    请问：在持咒的同时，如何思维密咒的法义？是否是禅定修持到一定的阶段，全咒是心，成为背景噪音，但不碍思维？

    zf：
    无忧兄请进。

    “我现在的做法是：密咒一提起来，心就系咒上，心念耳闻。同时保持警觉，念头一出现，马上牵回咒上。”
    ──这正是修定。

    “请问：在持咒的同时，如何思维密咒的法义？”
    ──咒的法义不外智、悲两个方面。
    一、咒之般若波罗蜜义，广说无量无边，但归纳起来，《心经》之“诸法空相，不生不灭，不垢不净，不增不减”亦足矣。
    二、咒之大悲利生义，无非欲令六道众生出轮回，成佛道。如华藏上师对六字大明咒的开示，念诵六字时分别观想关闭六道门，开菩提路等。

    无缘：
    修三摩钵提凸显大乘佛法的殊胜。无论是动是静，是密是净是禅，尽入如来清净圆觉。如来不住一法，不舍一法，行人若能一门深入，死心塌地，定可成就。
    普贤菩萨行愿，是无上密，是无上禅，是无上净。佛只说一法，一法而万法摄；佛也说万法，万法而一法归。

    zf：
    关于净土，若行人发菩提心，深信弥陀名号总持如来万德，则净念相续之净土法门即是三摩钵提。称其为无上甚深微妙禅，不虚言也！

    mfe6000：
    那么东方净土，药师琉璃光如来呢。

    zf：
    一样。


将心止于佛号或真言之上

    Harlem：
    在准备的过程中，如果想修止，加强定力，怎么办？后学想练习打坐，可是听好几位师兄说这个不能自己练，必须要有善知识指导。

    zf：
    关于修行止观的法要，天台智者大师的《修习止观坐禅法要》即通常所说的“童蒙止观”、“小止观”，由浅入深，自成系统，是非常难得的法宝，收入在大正藏的“诸宗部”里。
    另外一种修止方法就是将心止于佛号或真言（如六字大明咒）上。通过佛号或真言来督摄六根，达到净念相续。这种修法的纲要就是楞严经“大势至念佛圆通章”（可以找到很多此经的注释作为参考）。
    修止是通过将注意力集中在某一个特定的目标上，从而对治散乱。依在下浅见，将心止于佛号或真言之上是一种“自力”和“佛力”相结合的方法，一举多得，何乐而不为！
    若行人发菩提心，深信弥陀名号总持如来万德，则净念相续之净土法门即是三摩钵提。称其为无上甚深微妙禅，不虚言也！


全心是咒，全咒是心

    笨鸟：
    赵叔，闻思修的思与止观的止如何平衡？思的结果总是扯出团团乱麻，止不接受团团乱麻万念放下，止与思互为克星。

    zf：
    一点体会，供参考。
    具有较强的对思维对象的专注能力，显然有助于加深对内涵的理解及洞察。这显示了止的能力的重要性。
    修止有各种方法。在下采用的是通过将心专注于真言来培养自己的止力。我体会这种方法的优点如下：
    一、专心持咒时，发现自心游离了目标时，将心重新放在真言上。这就是通常所谓之止的修持。
    二、真言乃佛之心印、秘密菩提心，持之可以除障积德。修止的同时又积累了资粮。以此为基础修习正思维，定会有新的感受。
    三、随着业障的减轻，对真言具足如来法报化三身功德的信心不可动摇，此时若能做到全心是咒，全咒是心，则唯修此“止”法便可成佛无疑。

    MH：
    请问zf叔：对未得师门而入的人，可以持什么样的真言呢？曾听说可持六字大明咒的。但一直不知道该如何具体操作。能否请您给介绍一个比较详尽的持咒方法呢？将不胜感激。

    zf：
    哪些真言不经上师亲口传授便可受持，对此有不同的说法。
    据在下了解，在藏地，六字大明咒和绿度母心咒是人人可以受持的普传真言。
    在汉地，行人在参禅、念佛的同时兼持密咒已经成为较普遍的模式，其中楞严咒、大悲咒、准提咒、往生咒等千百年来为僧俗广为持诵，应可视为普传。

    MH：
    非常感谢。只是我对如何持咒的方法还是不知道。

    zf：
    最简单的持咒方法可参照净土宗念佛的方法。比较复杂的方法要配合观想或思维咒义。《显密圆通成佛心要》中介绍的一些方法可供参考。

    我：
    （编按：转引用某种南传念佛内观的方法，原文从略如下）：“当它开发了，心就明亮了，而“佛──陀”的字眼就消失了。当真言“佛──陀”已经从心意里消失了，不要认为你已经遗忘了你的禅思对象。当心意已经安住于祥和时，这只是心意的自然状态而已。我们以真言“佛──陀”修习，直到心意坠入一个轻安的状态而解除了真言。”

    zf：
    这两种修法中之“真言”名字虽同，但含义和作用却天壤之别。
    在您所介绍的上述禅修方法中，“佛──陀”这一真言仅仅是通向祥和心态的桥梁，当“心意坠入一个轻安的状态”时，此真言将会自然消失。是故真言是手段，而轻安的状态才是目的。
    在我所介绍的修法中，真言既是手段，同时真言也是目的。当行者之心与真言不二时，本具之三身功德便得到圆满的开显。因此在这种修法中并不要求随着“止”力的提高而放弃真言，而是始终“止于至善”──摄持如来三身之真言。依此真言行，菩萨的利生事业便可任运实现。
    大悲观世音便是此种真言行的典范，在《千手千眼观世音菩萨广大圆满无碍大悲心陀罗尼经》中：
    “佛告总持王菩萨言。善男子汝等当知。今此会中有一菩萨摩诃萨。名曰观世音自在。从无量劫来成就大慈大悲。善能修习无量陀罗尼门。为欲安乐诸众生故。密放如是大神通力。佛说是语已。尔时观世音菩萨从座而起整理衣服向佛合掌。白佛言世尊。我有大悲心陀罗尼咒今当欲说。为诸众生得安乐故。除一切病故。得寿命故得富饶故。灭除一切恶业重罪故。离障难故。增长一切白法诸功德故。成就一切诸善根故。远离一切诸怖畏故。速能满足一切诸希求故。惟愿世尊慈哀听许。佛言善男子。汝大慈悲安乐众生欲说神咒。今正是时宜应速说。如来随喜诸佛亦然。观世音菩萨重白佛言。世尊我念过去无量亿劫。有佛出世。名曰千光王静住如来。彼佛世尊怜念我故。及为一切诸众生故。说此广大圆满无碍大悲心陀罗尼。以金色手摩我顶上作如是言。善男子汝当持此心咒。普为未来恶世一切众生作大利乐。我于是时始住初地。一闻此咒故超第八地。我时心欢喜故即发誓言。若我当来堪能利益安乐一切众生者。令我即时身生千手千眼具足。发是愿已。应时身上千手千眼悉皆具足。十方大地六种震动。十方千佛悉放光明照触我身。及照十方无边世界。从是已后。复于无量佛所无量会中。重更得闻。亲承受持是陀罗尼。复生欢喜踊跃无量。便得超越无数亿劫微细生死。从是已来常所诵持未曾废忘。”
    这“从是已来常所诵持未曾废忘”一句，点出了真言行的眼目。


全心是咒、全咒是心，不是三身圆满佛还能是什么？

    abu：
    请教一个问题，“此时若能做到全心是咒，全咒是心，则唯修此‘止’法便可成佛无疑。”这种说法有无经论的依据？还有，您这里的“成佛”是什么意思？是指明心见性呢？还是成为三身圆满的佛？是从凡夫成佛呢？还是从登地的菩萨到圆满一切种智的佛？

    zf：
    在下岂敢胡说八道！
    这里的“成佛”是成为三身圆满的佛。
    经论的依据，在《一切如来心秘密全身舍利宝箧印陀罗尼经》中，有如下开示：“佛言谛听思念莫忘。现在未来一切如来分身光仪。过去诸佛全身舍利皆在宝箧印陀罗尼。是诸如来所有三身亦在是中。”
    因为如来三身皆在陀罗尼中，因此行人若能全心是咒、全咒是心，不是三身圆满佛还能是什么？


心若与陀罗尼相应，便是与般若相应

    我：
    ……观音耳根圆通得道，亦非咒力相合而证，此《楞严经》已有明示。不论中土西域南传北传，各派之中多少都有通过“真言”而得“止”力的方法，然从没有单凭“止”力即可现证般若的说法。
    师兄所举之《千手千眼观世音菩萨广大圆满无碍大悲心陀罗尼经》虽出密教，经中重点非是般若还在净土，此经曰“由持此咒故。所生之处恒在佛前。莲华化生不受胎藏之身。”“至心称念我之名字。亦应专念我本师阿弥陀如来。然后即当诵此陀罗尼神咒。一宿诵满五遍。除灭身中百千万亿劫生死重罪。观世音菩萨复白佛言。世尊若诸人天。诵持大悲章句者。临命终时十方诸佛皆来授手。欲生何等佛上。随愿皆得往生。”就是此说。
    师兄前说“随着业障的减轻，对真言具足如来法报化三身功德的信心不可动摇，此时若能做到全心是咒，全咒是心，则唯修此“止”法便可成佛无疑。”，弟以为此言不合经义，若非放弃“止”修而行“观”法则无法进步增益智慧，唯修此“止”往生西方也许可行，若想成佛没有般若为航，苦海无边定不能渡。……

    zf:
    观音普门示现，当以耳根圆通而度者即为其开示耳根圆通法门，当以密咒而度者即为其宣说密咒功德，这正是大悲观音的本愿。
    以深信心止于真言之“止”已不是通常止观之“止”。依靠真言之力可以现证般若，对此密乘经典中是充分肯定的。《佛说大乘圣无量寿决定光明王如来陀罗尼经》中言：
    修行智慧力成就　　智慧力故得成佛
    若入大悲精室中　　耳暂闻此陀罗尼
    设使智慧未圆满　　是人速证天人师
    从中可见，纵使行人智慧未能圆满，但只要心生大悲，即使暂闻此陀罗尼，亦能速证佛位，当然也就包含现证般若了。
    在《千手千眼观世音菩萨广大圆满无碍大悲心陀罗尼经》中，关于大悲陀罗尼形貌状相，观世音菩萨言：“……平等心是，无为心是，无染着心是，空观心是……”，上述这些“心”不正是般若吗？因此，行人心若与陀罗尼相应，便是与般若相应，现证般若不足为奇。
    该经中还开示，“此陀罗尼是过去九十九亿恒河沙诸佛所说。彼等诸佛为诸行人。修行六度未满足者速令满足故。”行人修持大悲咒能令六度未满足者速得满足，六度皆能满足，何况般若！
    在《佛说大乘庄严宝王经》亦有类似开示：
    “若有善男子善女人。而能依法念此六字大明陀罗尼。是人而得无尽辩才。得清净智聚。得大慈悲。如是之人日日得具六波罗蜜多圆满功德。”
    密乘经典中此类开示多不胜举，仁兄之修习真言不能现证般若之说与佛说相违。
    经中分明言：
    “诵持此陀罗尼者。当知其人即是佛身藏。九十九亿恒河沙诸佛所爱惜故。当知其人即是光明藏。一切如来光明照故。当知其人是慈悲藏。恒以陀罗尼救众生故。当知其人是妙法藏。普摄一切诸陀罗尼门故。当知其人是禅定藏。百千三昧常现前故。当知其人是虚空藏。常以空慧观众生故。当知其人是无畏藏。龙天善神常护持故。当知其人是妙语藏。口中陀罗尼音无断绝故。当知其人是常住藏。三灾恶劫不能坏故。当知其人是解脱藏。天魔外道不能稽留故。当知其人是药王藏。常以陀罗尼疗众生病故。当知其人是神通藏。游诸佛国得自在故。”仁兄将如来对此广大圆满无碍陀罗尼功德的开显说成“经中重点非是般若还在净土”，这恐怕是以偏盖全。
    “师兄前说‘随着业障的减轻，对真言具足如来法报化三身功德的信心不可动摇，此时若能做到全心是咒，全咒是心，则唯修此“止”法便可成佛无疑。’，弟以为此言不合经义，若非放弃“止”修而行“观”法则无法进步增益智慧，唯修此“止”往生西方也许可行，若想成佛没有般若为航，苦海无边定不能渡。”
    ——密乘修持可以于一念间圆具六度，自有其不可思议处。仁兄之修持若以三法印摄持，自然是如来正法，在下随喜。但如来有无量方便，以我等的慧力，还是不要妄评如来教法为妙。
    另外，在下上贴中“天壤之别”之说，只是说真言在两种修持方法中所起作用的差别之大，并无区分高下之意。对于如来的教法，行人能相应者就是妙法。

    （编按：本文为《全心是咒，全咒是心》一贴后所紧接着的讨论。）


佛力就是隐藏在我们心中的自力

    阿菜：
    我原修自力法门，近见持咒可得佛力加持，想持咒求佛护佑，又不想放弃过去系缘方法，可否每天做过去功夫之外，再持咒30分钟－1小时？一求佛力加被，二为众生回向，请问赵叔，这样做行吗？算不算杂修？

    zf：
    毫无疑问，当然可以。如果有人说不可以，可请他到“网海莲舟”来，在下愿与其“理论理论”。
    您如能坚持这样“杂修”，经过一段时间后会发现，原来所修的“自力法门”也会有意想不到的进步──因为“自力”更加充沛的缘故。
    记得憨山大师说过（大意，不记得出处了），历史上许多禅宗大师暗中都持诵楞严、大悲、准提等真言。老兄今日在修自力法门的同时念佛持咒，绝对算不上标新立异。
    话又说回来，如果某个法门一定要将“自力”和“佛力”截然分开，我倒劝您要小心了！
    因为佛力就是隐藏在我们心中的自力。


拿摩阿弥达布达呀

    拿摩阿弥达布达呀

    zf

    念诵“南无阿弥陀佛”，当行者的信心与如来的本愿力相应时，感应道交是确定无疑的。如同我们念诵“皈依无量寿佛”、“皈依观世音菩萨”“皈依药师佛”一样，虽然上述佛号完全是汉字，但只要有信心，便一定会有起作用的。
    但从密法的观点来看，“无量寿佛”、“观世音菩萨”这样的名号与真言有较大的差别。念诵真言时即使行者不知真言的含义，念诵照样可以起作用（事实上，真言的含义是无量无边的，翻译成汉语难免挂一漏万，这也是不翻的原因），这就是密乘所谓之“真言实相”。因此如以“拿摩阿弥达布达呀”的方式念佛，佛号便可以同时发挥真言的作用。
    依在下浅见，如果行人对密乘有兴趣，比较“信仰”“阿弥达布达呀”这一梵音的无穷内涵，念“拿摩阿弥达布达呀”会更容易感应。
    另一方面，如果行人对阿弥陀佛有无比的信心，了知佛是一切智者，我等起心动念，佛无不了如指掌，无论我等是念“阿弥陀佛”、“无量寿佛”、还是“无量光佛”，如来都会不违其本愿力，从生至生，同于形影，不相乖异，则此类行人无论念诵哪个名号都好。


一法摄一切法

    mfe6000：
    请问补阙真言的MP3，哪里可以下载。

    zf：
    在《中有教授听闻解脱密法》中，有如下补阙真言（mp3不知何处有）： 　　嗡，都噜都噜，渣鸦穆克，梭哈。

    另外，建议仁兄：密咒者，总持也，一法摄一切法。
    与一密咒相应就是与所有密咒相应也。

    （编按：根据奉心居士的说明，这篇中“一法摄一切法”的回答不是针对补缺真言，而是对于一些善友想同时持诵数量众多的各种真言的这种情形而作的一种建议。）


以深信心去修持真实念诵，如虎添翼也！

    成军：
    （真言）不翻不等於故意回避不去研究其实义。
    现代语文对一些外来词也不翻译，反而是时间久了，这些词汇融入汉语之中，典型的如坦克。事实上，“佛陀”在当年也是外来语，“阿弥陀”也是。现在不也成了汉语的一部分？
    陀罗尼，意为总持。陀罗尼本身来自梵语，一词可能表多义。古德不翻，既为保留读音，也是恐怕以偏概全，丧失其全部的意思。
    但是当代一些密宗大德，在讲解一些咒语（最典型的如六字大明咒）时，也有依字词逐字解释的。可见不翻和理解其梵语原义并不矛盾。毕竟佛法本质上不是咒术，是智慧。

    zf：
    同意仁兄的见解。关于真言，在下的理解是：
    一、如同佛的形象是佛的功德在我们眼根的示现一样，佛的真言是佛的功德在我们耳根的示现。
    因此听到真言就是现量地见佛。
    行人若了知如来的所有功德都含摄在真言中，纵使不再思维咒意，以深信心将自心与真言融合，仅此一法便是总持六度万行之法。

    二、正如佛像中每个部分、每种颜色、每个衣饰、每个手势、每个法器都有其特定表法之意一样，真言中的每一句，乃至每一个音节亦有其法意。密乘中诵咒时同时思维咒意的修法称为“真实念诵”，这种修持具有古老的传统，与著名的华严经字母修法和涅槃经字母修法如出一辙。

    以深信心去修持真实念诵，如虎添翼也！


持咒的信念

    gufeng：
    请问在家修行如何作到身心清净？谢谢！

    zf：
    Gufeng兄，在家人和出家人在修行上，各自面临着自己特有的困难。但从根本上说，两者的敌人都是一致的，那就是贪嗔痴，因此对治的原则大体上也相近。
    因为在家人和出家人生活环境的不同，戒律上的差别是明显的。
    在家修行而得大成就的典范要数维摩诘居士了，其“心净则国土净”的开示道出了佛法修行的真谛。
    具体修持上，在出离心、菩提心和清净见有一定基础时，受持密咒是有效的方法。其中六字大明咒最广泛地为古今大德所推荐。

    《大乘庄严宝王经》中开示：
    “若有善男子善女人。而能依法念此六字大明陀罗尼。是人而得无尽辩才。得清净智聚。得大慈悲。如是之人日日。得具六波罗蜜多圆满功德。是人得天转轮灌顶。是人于其口中所出之气触他人身。所触之人发起慈心离诸嗔毒。当得不退转菩萨。速疾证得阿耨多罗三藐三菩提。”
    Gufeng兄，依法念此六字大明陀罗尼之人，日日得具六波罗蜜多圆满功德，您所要求的“身心清净”自然可以满足。
    此法易行难信，若行人信心十足，则成佛在握。

    www：
    请问出离心如何在修行中体现，是不是在念佛或念咒时心中有个舍弃娑婆，求生极乐的意念。

    zf：
    正是。在念佛或念咒时心中想着一切众生都舍弃六道，求生极乐，并最终成佛，就与菩提心和菩萨行靠近了。仁兄觉得在下这个不费什么事儿，就可以和菩萨沾边的方法怎么样？

    无名：
    赵叔能否讲讲您自己念诵六字大明咒的感受与体会？

    zf：
    说说在下持咒的信念：
    一、咒就是佛本身──法、报、化三身。这是“见”。
    二、将心与咒溶合──如水乳交融。这是“修”。
    三、本具如来功德的显现。这是“果”。

    古慈：
    后学觉得持念佛号、菩萨名号、佛经是否也当如此见、如此修才能肯定亦得如此之果？？？

    zf：
    同意。


以深信心持咒，必能与观世音的大悲心感应道交

    独自醉倒：
    后学学会念大悲咒。

    zf：
    在持大悲咒的同时，别忘了常念大悲陀罗尼经中开示大悲咒功德的部分，以提高自己的信心。
    以深信心持咒，必能与观世音的大悲心感应道交。
    吉祥如意。

    独自醉倒：
    多谢ZF叔，对了，后学发愿终生持诵六字大明真言的，这段时间专念大悲咒可以么？还是都念呢？

    zf：
    当然可以，六字大明咒是大悲咒的浓缩；大悲咒是六字大明咒的展开。两者都是观世音的心。

    zzzm：
    后学看到某法会发起文中，六字大明咒为：嗡　玛呢贝美吽舍。这后面为什么比通常的读音多个“舍”？这个音不读可以吗？敬请释疑。

    zf：
    《大乘庄严宝王经》中之六字大明咒就是六个字，莲师传记中对此真言的开示也是六个字。因此不读“舍”字是可以的。
    此“舍”字是阿弥陀佛和观世音菩萨的种子字（古汉语译为“纥哩”，发音为“贺力”两字的连读，更接近梵音），因此在西藏，有些传承在六字后面加上此字，但只用六字者亦大有人在。
    与此有关的一个例子是，一些藏经中所载之文殊心咒是：“阿拉巴扎那”五字明（此五字为五方佛的心），但文殊心咒在西藏最常见的形式是：“唵阿拉巴扎那底”七个字（其中“底”字是文殊的种子字之一）。


坚定对六字大明咒等正法的信心

    坚定对六字大明咒等正法的信心

    zf

    六字大明咒可视为大悲咒的心咒。《千手千眼观世音菩萨广大圆满无碍大悲心陀罗尼经》开示：
     “今诵大悲陀罗尼时。十方师即来为作证明。一切罪障悉皆消灭。一切十恶五逆。谤人谤法破斋破戒。破塔坏寺偷僧祇物污净梵行。如是等一切恶业重罪悉皆灭尽。唯除一事于咒生疑者。乃至小罪轻业亦不得灭。何况重罪。”
    如来是真语者。只要我们于咒无疑，“一切罪障悉皆消灭”。特别提醒各位师兄留意，如来金口所说的是能消灭“一切罪障”！！！
    “一切”的含义是什么，我想不用我多说。


于咒生疑者，乃至小罪轻业亦不得灭

    于咒生疑者，乃至小罪轻业亦不得灭

    zf

    《千手千眼观世音菩萨广大圆满无碍大悲心陀罗尼经》中观世音菩萨自己开示：
     “尔时观世音菩萨从座而起整理衣服向佛合掌。白佛言世尊。我有大悲心陀罗尼咒今当欲说。为诸众生得安乐故。除一切病故。得寿命故得富饶故。灭除一切恶业重罪故。离障难故。增长一切白法诸功德故。成就一切诸善根故。远离一切诸怖畏故。速能满足一切诸希求故。惟愿世尊慈哀听许。”
    菩萨所特别指出的是，只有一种情况大悲咒将失效，那就是：“唯除一事，于咒生疑者，乃至小罪轻业亦不得灭，何况重罪。”这一点行人要特别小心！


六字大明咒所在之处，就是观世音菩萨现身之地

    chf：
    各位请帮帮我，我十岁女儿的离世让我痛不欲生，几个月来我生活在黑暗中，生不如死。我想为她超渡亡灵，而我这里没寺庙法师无法做。在此想请教各位仁师我该怎样才能完成我的心愿？顺便请问：没有骨灰能否超渡成？

    zf：
    Chf兄，特提以下建议：
    一、不知你是否有六字大明咒的梵文或藏文真言？若有，请将此真言贴在你女儿照片的背面，并想象你女儿正佩带着六字大明咒；若没有，麻烦哪位师兄将六字大明咒的梵文或藏文图象文件连在下面，您可打印下来或“画”下来。
    二、建议您开始念诵《地藏经》或任何您愿意念诵的佛经，以及六字大明咒（om、ma、ni、ba、mi、hum）、阿弥陀佛、观世音菩萨、地藏菩萨名号，并将功德回向您女儿，愿其往生极乐世界。因您与女儿之间有如此亲近的因缘，因此感应应是十分迅速的，对此您应有足够的信心。
    三、告诉大家您女儿的名字，请论坛上的各位师兄为其修法回向。
    四、是否有骨灰对其往生没有任何影响。
    om、ma、ni、ba、mi、hum
    愿您女儿立即往生极乐！
    om、ma、ni、ba、mi、hum
    om、ma、ni、ba、mi、hum
    om、ma、ni、ba、mi、hum
    ……
    观世音菩萨是一切如来大悲心的显现，而六字大明咒是观世音菩萨的微妙本心，是“声音化”的观世音。六字大明咒所在之处，就是观世音菩萨现身之地。
    六字大明咒中之六字分别具有关闭六道轮回之门（om—关闭天道门，ma—关闭修罗道门，ni—关闭人道门，ba—关闭畜生道门，mi—关闭饿鬼道门，hum—关闭地狱道门）独开往生净土乃至成佛门的功德。（六字大明咒的功德广如《大乘庄严宝王经》所述。）
    您诵咒时最好配合以下观想：
     一、您女儿与您一起诵咒。因诵咒之功德而关闭六道轮回之路，打开往生极乐世界之门；
    二、观世音菩萨手拉着您女儿一起乘莲花飞向极乐世界；
    三、您女儿在极乐世界向您招手微笑，并约您将来在极乐世界相会。
    华严经云：如是思维则如是显现。
    如来是真语者。
    Chf兄，若您能因此因缘走上解脱之路，则您女儿很有可能是一位与您宿世有缘的菩萨，今生以此方式让您及早认识人生之无常，从而发奋修行，永离苦海！

    劣根：
    chf朋友请一定振作起来！！按ZF善知识所说的去做，这是您女儿现在最最需要的！
    为响应ZF老师的建议，后学这两天读地藏经2遍并咒语圣号回向您的女儿及一切苦难众生。
    在读地藏经时后学感触很深。此经后学在四年前读过，是为因心脏病去世的父亲，记得当时并没有太多深刻的感受。但这次读来却与前次大感不同，数次被地藏王菩萨的悲愿、本师对众生的慈念感动的泪流满面。深深感到：这真是一部值得一读再读的希有殊胜经典！因缘法就是如此不可思议，正是您和您的女儿给了我这个与此经感应的机缘。所以后学在此想特别向您表示感谢！或许您现在还不能完全理解我的心情，但这真的是真心话。这正体现：利人方能真正自利。
    好！废话不多说。为了您的女儿和与您一样的众多苦难人当然也包括我自己，让咱们携手共驱苦难！！

    chf：
     衷心感谢各位，反复看了好心师兄们的回复，我感动不已，泪如泉涌——竟还有人能为我分担痛苦，原来我并不是孤立无援的，在此一同谢谢各位，我定会照做。

    文摘：六字大明咒的功德
    《大乘庄严宝王经》　节录
    中印度惹烂驮啰国密林寺三藏赐紫沙门臣天息灾奉　制译

    “……
    如是。善男子。彼观自在菩萨摩诃萨。有六字大明陀罗尼难得值遇。若有人能称念其名。当得生彼毛孔之中不受沉沦。出一毛孔而复往诣入一毛孔。于彼而住乃至当证圆寂之地。时除盖障菩萨白世尊言。世尊今此六字大明陀罗尼。为从何处而得耶
    佛告善男子。此六字大明陀罗尼难得值遇。至于如来而亦不知所得之处。因位菩萨云何而能知得处耶。除盖障菩萨白世尊言。如是陀罗尼。今佛如来应正等觉。云何而不知耶
    佛告善男子。此六字大明陀罗尼。是观自在菩萨摩诃萨微妙本心。若有知是微妙本心即知解脱。时除盖障菩萨白世尊言。世尊诸有情中。有能知是六字大明陀罗尼者不。佛言无有知者。善男子此六字大明陀罗尼。无量相应如来而尚难知。菩萨云何而得知此观自在菩萨微妙本心处耶。我往他方国土。无有知是六字大明陀罗尼处者。若有人能而常受持此六字大明陀罗尼者。于是持诵之时。有九十九殑伽河沙数如来集会。复有如微尘数菩萨集会。复有三十二天天子众亦皆集会。复有四大天王。而于四方为其卫护。复有娑誐啰龙王无热恼龙王。得叉迦龙王嚩苏枳龙王。如是无数百千万俱胝那庾多龙王而来卫护是人。复有地中药叉虚空神等而亦卫护是人。善男子观自在菩萨。身毛孔中俱胝数如来。止息已赞叹是人言。善哉善哉善男子。汝能得是如意摩尼之宝。汝七代种族皆当得其解脱。善男子彼持明人。于其腹中所有诸虫。当得不退转菩萨之位。若复有人以此六字大明陀罗尼。身中项上戴持者。善男子若有得见是戴持之人。则同见于金刚之身。又如见于舍利窣堵波。又如见于如来。又如见于具一俱胝智慧者。若有善男子善女人。而能依法念此六字大明陀罗尼。是人而得无尽辩才。得清净智聚。得大慈悲。如是之人日日。得具六波罗蜜多圆满功德。是人得天转轮灌顶。是人于其口中所出之气触他人身。所触之人发起慈心离诸嗔毒。当得不退转菩萨。速疾证得阿耨多罗三藐三菩提。若此戴持之人。以手触于余人之身。蒙所触者是人速得菩萨之位。若是戴持之人。见其男子女人童男童女。乃至异类诸有情身。如是得所见者。悉皆速得菩萨之位。如是之人。而永不受生老病死苦爱别离苦。而得不可思议相应念诵。今此六字大明陀罗尼。作如是说。
    ……”


将自己观想成观音菩萨之身的禅修

    非非：
    “就金刚乘的观点来看，我们可以持静，将自己观想为观音菩萨的一万个或十万个化身，想着他们确实在场，并不断念诵咒语。（卡卢仁波切开示）”。“持静”这词听起来挺新鲜的，可否解释一下？俺在持咒或者念佛时，曾出现持不起来的情况，此时一片空明，不知是任之呢？如果任之而安住，是否就是“持静？还是继续用力提起？

    zf：
    上文中卡卢仁波切的开示，乃从《卡卢仁波切——即身成就的活佛》（台湾中天出版社，慕容由英译汉）中引用，“持静”一词的确不是大家常用的词语。但从上下文来看，在下的理解就是：我们先将心保持在安静的状态，将自己观想为观音菩萨的一万个或十万个化身，……
    关于“空明”，首先非兄要确定，此“空”是否为诸法缘起无自性之空？此“明”是否为照见五蕴皆空之般若智慧光明？若是，则此修行乃功德，应回向无上菩提；若否，则此境界最好只算得上色界定，扰乱持咒念佛，与魔无二。
    须知，空者，五蕴当体即空，非蕴外有空。当用心体会“持”“咒”“念”“佛”当下即空，与空无碍。若兄之“空明”中容不下持咒念佛，则对此“空明”要倍加警惕。

    文摘：卡卢仁波切著作介绍

    卡卢仁波切一世（1904——1989）生前是香巴噶举的掌舵人。他出神入化的佛学知识，以及传法内容深入浅出之精湛，使得许多大成就者对其顶礼有加。在藏传佛教界，卡卢仁波切被誉为学问僧的至尊之一。愿诸位皆能从仁波切的开示中受益，生起殊胜菩提心，早得正觉，利益一切有情。

    卡卢仁波切法语

    六字大明咒的修行聚集了最多优点，也是最好的一种修行，就是观音禅修。有句从观音菩萨的教法而来的俗话是：禅修观音菩萨之人，或是仅让自己心存观音的人，即可净化无数的恶行。禅修观音或只让自己心存观音之人，就拥有净化多数恶行的力量，而且拥有立即的结果。这段话是由大悲者自己所传授的。禅修观音，念诵其咒语，并且在此修行之中禅修心性，即可净化累世的恶业。当你进行此种净化业障的禅修之际，一定会认清自己的心性。这是自然而然发生的。
    在观音禅修中，我们首先想着：“我们就是观音”，并继续念诵咒语。一开始禅修时，想让自己的所有本质均成为观音，那是很困难的。假如看不清楚自己，那并没什么关系。只要禅坐时，想着自己是真正的观音就够了……随着对此修行更加熟练，我们所观想的身形就会更加清晰。
    像这种将自己观想成观音菩萨之身的禅修，是一种如同彩虹的空相，此时的心即成为定止，不会有所分心。在此种情况之下，我们可以尽其所能，念诵多次摩尼宝咒。当我们禅修至这种境地，止的修行就会自然而然的发展，并有所精进。往后我们可以偶尔将心置在观音菩萨的存在中，保持放松、清澄、没有任何的狡诈，只是休息于观音菩萨的存在之中。我们可以任随心意，让自己身处于此种境地。这种禅修的概念，在修持大手印时非常有用。
    有时候，当我们不断念诵摩尼宝咒时，会将自己的心留在咒音中，没有特地加以思索，例如想着：“这是好的、坏的、强的、暖的、大的、小的，或其他。”这是发展止的极佳方法。这些不同的修行，不仅只能用来发展止的修行，因为当我们让自己的心维持观音的形象或咒音，同时就能进行止的修行，因为存在于心中的观音，拥有净化累世恶业的力量。
    我们是初学者，想在不刻意之下，一边简单的念诵六字大明咒，一边让心静持的能力或许有限。假如是这种情况，我们也可以不朗诵摩尼宝咒，只要让心在自然而然的状态下修持。我们偶尔也可以转而信任观音上师，并培养发展自己对众生的慈悲心。接着，我们可以祈求观音上师的出现，并祈请自己能完全了解大手印。以这种方式，不断祈请，是相当重要的。当禅修结束之后，我们即可了解到修行对众生的助益，并发正愿。每次佛法修行的最后都应该做到这一点。

    乘与道

    登入正觉之道的第一步，就是皈依佛、法、僧三宝。接着，我们思索业、行、因与果。道的积累，就是舍弃恶行，并根据自身的领悟行善。在这个基础之上，我们开始培养慈悲心、禅修、信仰，以及修本尊法等等。这些修行都是资粮道的首先步骤。此道具备低、中、高三种等级，根据功德积累与根本证悟的程度来区分。这种种正面的特质会持续精进，并让我们的知识增长。那时我们即可达到加行道。此道称为统合之道，是由于它发生在下一个阶段：证道之前，而证道可让我们沉思心性。在证道之前，我们都只有在知识上思考，并没有直接体会领悟。
    加行道也有三种等级。假如我们勤奋修行，即可通达这些等级。当我们真正了解心性之后，即是登入证道之时。
    透过证道的低、中、高三种等级，我们不断精进，直到达到最高的境界。这个时候，心性——也就是空性、明性，以及无碍证悟的结合，就如同我们的老友一般，已经能清楚认得他的面目。累积之道、统合之道，以及证道，各有低、中、高三种等级。它们对小乘、大乘及金刚乘，都同等的重要。这三乘是三种在同一条路上行走的不同的交通工具或方法。这些交通工具是佛陀教义的不同呈现，好帮助我们朝着相同的目标迈进。每一乘都有莫大的精神影响，以及绝佳慈悲心的来源。精神影响与慈悲心之间，并没有任何差别，因为这三乘在其中，是到达不同精神层次的方法。

    然而，在这些道的长度上，却有极大的差异。小乘是一条漫长之路，大乘则比较直接，金刚乘则是最短的一条。比方说，假如拥有了上等之资，金刚乘可以在此生，引导我们成就正觉；对于中等之资，则是在中阴之中成就正觉；要是资质颇差者，则需要三到七世的修行。因此，从金刚乘修行的观点来看，资粮之道、加行之道，以及证悟道都比较短。因为金刚乘拥有灵巧的方法，以及伟大的慈悲心，因此丰盈了其修行，我们今生能有机会修行此乘，真是莫大的福缘。

    不同之果

    为了证明这一点，佛陀表示再也没有比念诵六字大明咒利益更大的修法了。在小乘之法中，发愿念诵一亿遍这些咒语的人，只要单单朗诵咒语，就可以有所帮助。假如我们十分勤奋，只要三年的时间就可以念完这个次数。
    按照大乘的方式，我们应该将想念诵咒语的人聚集起来。由全体中的每个人念诵咒语，其效力将会加总。对于念诵一亿遍咒语来说，这是一种较快的方式，但仍需要很长的时间。不过，就金刚乘的观点来看，我们可以持静，将自己观想为观音菩萨的一万个或十万个化身，想着他们确实在场，并不断念诵咒语。假如怀着虔信来进行此项修行，整个过程将可在数小时或数天完成。多样的交通工具，具备这些在效率上有所差异的不同方式，以供人们选择。
    假如我们对某位喇嘛、本尊或是佛深具信心，而且我们发愿对他行十万遍顶礼，这需要一段相当长的时间。此种对某位成就者皈依的修行，将可消除恶业并积累功德。然而。在我们修行四加行时，应该观想眼前的空间，正充满着喇嘛、本尊、佛、菩萨、佛母、护法，并想着他们确实出现在我们面前。如果我们观想，自己送了数千个、数万个自己的化身，一同在他们的面前行顶礼，我们将会积累无尽的功德，消除无数的业障。这即是金刚乘的修行。
    同样，一位富人可能拥有金子或银子、珍贵的宝石、丝绸，或是有价值的所有品，他决定将这些物品供养给自己的喇嘛或佛，以求成就功德。当此人献给喇嘛或佛供养时，他说：“这对我弥足珍贵；我希望您能拥有它。”能贡献如此纯净的供养，是一件相当不错的事，而且亦是积累莫大功德的方法之一。
    然而，金刚乘中有一种供养的方法，称为供养曼荼罗。在此种禅修之中，我们不断供养自己的身语意，世俗的所有物，前世、今生或来世所累积的善德，天神或人类的喜乐——例如美丽的形体或声音、好的口感与香味，以及令人愉悦的感受——以奉献给十方诸佛与菩萨。我们怀着强烈的信仰，不断地供养，此种方法将比前面提到的其他供养，更能积累数千倍、数万倍，甚至数十万倍的功德，而且所净化的恶业，是与积累的功德成正比。

    喇嘛并非有形

    执念也存在于佛法修行之中。当我们怀着对喇嘛、本尊与佛陀的信仰，进行不同的修行时，佛陀是存在的，喇嘛是存在的，本尊也是存在的。因为他们存在，所以我们能领受到他们所施与的所有形式的加持与成就，并且领悟到心的真正本性。
    然而，我们所称为的佛陀或喇嘛，他们存在的方式，并不象水晶、黄金、钢铁或宝石一般。你们不该以此种唯物的态度来看待他们。喇嘛或佛陀的本质为空，他们的本性为明，他们的外貌则是无碍证悟的体现。他们无形、无色、无相——就像空明的天空一般。当我们领悟到他们是如此，就可培养出信仰，并将己心与其心融合，好让我们的心能够平静的休息。此种态度与修行方式是极为重要的。
    这是如此重要的一点！有些人可能对喇嘛或佛陀有着极深信仰，但是他们想着：“我的喇嘛是真实的，他确实存在。我对这位喇嘛深具信心。我如此敬仰自己的喇嘛，相信他是我目光的焦点。我会尽自己的一切力量，以求服侍这位喇嘛，并怀着信仰禅修。”
    那么，当喇嘛圆寂之后，他们会想：“多可怕！我的喇嘛去世了！”他们被悲伤与担忧所征服，心中想着：“我再也无法见到自己的喇嘛了！”因此变得非常沮丧与不安。这是由于他们认为喇嘛是有形的存在，因而产生的执念。

    弟子的执念

    我的根本上师之一，是博学且有成就的喇嘛甘炯仁波切，他是一位非常杰出的上师。他有位对其非常虔诚的法国弟子，这位弟子想着：“甘炯仁波切是我的根本喇嘛，我对他有着莫大的信任与信仰。”
    在禅修开示中，他教导她，应该让自己的心与他融合。因此她想着：“从现在起，我跟他的身将不分彼此，我们的语与意也不分彼此。”她依此修行了一段时日。
    这位弟子的信仰正如自己的禅修一般，非常强烈专注。然而她私底下的执念实在很深。过了一阵子后，仿佛她到任何地方，都将喇嘛扛在肩上似的：无论她前往何处，他亦跟随；她坐在那里，他也坐在同处。这位弟子无法将自己与喇嘛分离独自生活。她因此几乎快要疯狂了。
    我过去常见到她，但已经有好一阵子没看到了。我不知道这个故事后来的结果为何……因此，对喇嘛拥有如此的执着与执念，是相当危险的。
    正如所说：“假如我们对本尊有执念，这将转变为我们最大的束缚。我们如果对自己的成就有执念，它们将成为我们最大的障碍。”我们要是将自己附着于本尊之上，那会让自己成为囚犯受其束缚。假使我们亦执着于修行的成就，它们将变成莫大的业障。执念本身就是个错误。
    很多人会想：“我们的喇嘛渐渐老去，而且又住得很远。由于他的年老，以及彼此的距离，让我再也看不到他。我们之间的距离太远了，因此我接收不到他的影响。”另一个错误就是，我们不了解喇嘛的心就如同天空一般，而且一个人的心亦像天空。关于喇嘛很老或是住得很远之类的印象，都是由于缺乏了解，以及怀有错误的观念所造成的。

    修行的本质

    简而言之，别认为自己的肉身和血液真的存在，而想着它是崇高的观音菩萨之身。假如你可以清晰观想观音菩萨的法相，就这样做吧——最起码，只要想着自己拥有那种形体即可，即是空相。同样的方式，你应该认为所有的声音，都是声音与空性的结合，也就是大悲之咒语的自然回响。所有内心现象与活动，应该被视为观音之心，也就是觉性与空性的结合——大手印。心与其明性，都充满在整个广大的空间之中。
    无论我们白天做了什么，不管是念诵咒语或其他活动，假如我们知道如何保持此种对空性的认知，获得佛果就不会有任何困难了。
    在这个世界，每秒钟都有人死去与诞生。因此这个世界是不断在改变的。在这个世界，人类经历了万事万物，然而他们仍必须遭受生老病死。每件事物均为无常。永远将这一点谨记于心，这是相当重要的。


观想一切众生与您一起持咒

    zf：
    仁兄遇到事情想开点，不要独自醉倒，破了五戒。

    独自醉倒：
    多谢。末学醉倒不为酒，只因尘世皆惑。醉于世间啊。
    您能不能再给说说六字大明咒的妙用呢？大家看到的都是功德描述，没有一些具体运用。我先说一个，凡遇被宰杀过尚在挣扎的动物，可以念诵几遍，然后往其身上吹口气，可解其苦痛。
    您多给说说，让我们在持咒的时候也利益一下众生。

    zf：
    “末学醉倒不为酒，只因尘世皆惑。醉于世间啊”
    ──我看仁兄是装醉！

    “……没有一些具体运用。”
    ──仁兄若欲帮助某些众生，最简单而有效的方式就是观想这些众生与您一起持咒。

    “我先说一个，凡遇被宰杀过尚在挣扎的动物，可以念诵几遍，然后往其身上吹口气，可解其苦痛。”
    ──当然可以。您看上一眼也有用。

    “您多给说说，让我们在持咒的时候也利益一下众生。”
    ──观想一切众生与您一起持咒。

    XUEFO：
    以前看到某位大德对“观想众生与自己一起持咒”的开示。

    木樨香：
    南无诺那上师！感谢Zf叔宣说此无上窍诀！

    无名：
    “观想众生与自己一起持咒”真是大方便啊！

    zf：
    一起顶礼杜顺大师、诺那活佛！
    自己念经、念佛时观想一切众生都念经、念佛有极大的功德。实际上，这一修法恰恰是随顺趣入华严法界的方便──因为在您念佛念经时，一切众生确实在同时念诵。兄可参见杜顺大师对因陀罗网的开示。

    诺那活佛开示：
     问：持咒时，我一人持咒，观想为一切众生持咒，如此作想，功德大否？
    答：一人持咒，观想为一切众生持咒，功德甚大。此为密宗之理，因菩提心大故。

    问：修法超度亡人时，自己应作何观想？对于亡人，应作何观想之功德为最大？
    答：都观想为本尊。

    问：对于超度已死之畜类众生，应作何观想？
    答：一样都作本尊观想，不论何时何地，两眼所见与不见之一切众生，都观想为本尊，我是佛，一切众生都是佛。如此观想，功德甚大。

    问：对于亡人或死亡甚久，甚或已行转生之亡人，修法超度，能否受到利益？
    答：可以受到利益，不论已转生未转生之亡人，均能得到利益。


观想一切众生共同持咒等是密乘的重要修持方法

    xuefo：
    zf叔，昨天您提到的观想带一切众生念咒的问题，我记得以前看到某位大德（记不清是哪位了）的开示，称因传承方面的问题，不宜作此观想，请问是否存在此方面的问题？

    zf：
    我不太清楚您问题的确切所指。

    实际上，观想一切众生共同持咒等是密乘的重要修持方法。
    有经为证，《大乘本生心地观经》成佛品中，如来开示：
     “……尔时行者结此印已。即作此观。一切有情共结此印。持念真言。十方世界无三恶道八难苦果。同受第一清净法乐。我今首上有大宝冠。其天冠中五佛如来结跏趺坐。我是毘卢遮那如来。圆满具足三十二相八十种好。放大光明照十方界。利益安乐一切众生。如是观察名入毘卢遮那如来最胜三昧。”


一起持咒度过生命中不能承受之痛

    海行：
    有个病人快不行了，怎样助念才好？我助念的病人昨晚开始神志不清。今天一直在叫，在动。现在快不行了，带他念只念一两声就乱叫乱动了。有什么要注意的吗？请大德指教！！

    zf：
    请到“圆觉宗”的网站 http://www.nona.org.tw/，其中有临终助念和后事处理的详细开示。关键一点：在他的耳边念六字大明咒，只要他能听到就好。

    linuwa：
    现在有一位我最亲的亲人，姑妈，自小就劳累，家里上下老小由有她照顾，对我更是像亲生儿子。家里最勤劳的是她，生活得最苦的也是她。每每老人得病。总是守在病榻前，出钱出力；小的有个三长两短，也都照顾倍至。
    不想如此一个善良勤劳之人，才年过40，就被发现患上了重症。最可怜的是，在发现前几天，都还在捂着肚子忙上忙下。痛煞吾哉！！转瞬之间，恍若隔世，只恨自己无力相助，肯问各位大德有何治疗良方或中阴救度之法，弟子叩首谢恩！！

    zf：
    观想您姑妈与您一起持咒：
    一、六字分解修：
    om——诵此咒时观想：此字（或声音）消除姑妈无始劫来所积之与天道相应之业力，莲花承足，宝盖住顶，天道门闭，极乐门开，其莲如飞，至极乐界。
    ma——诵此咒时观想：此字（或声音）消除姑妈无始劫来所积之与修罗道相应之业力，莲花承足，宝盖住顶，修罗门闭，极乐门开，其莲如飞，至极乐界。
    ni——诵此咒时观想：此字（或声音）消除姑妈无始劫来所积之与人道相应之业力，莲花承足，宝盖住顶，人道门闭，极乐门开，其莲如飞，至极乐界。
    ba——诵此咒时观想：此字（或声音）消除姑妈无始劫来所积之与畜生道相应之业力，莲花承足，宝盖住顶，畜生门闭，极乐门开，其莲如飞，至极乐界。
    mi——诵此咒时观想：此字（或声音）消除姑妈无始劫来所积之与饿鬼道相应之业力，莲花承足，宝盖住顶，鬼道门闭，极乐门开，其莲如飞，至极乐界。
    hum——诵此咒时观想：此字（或声音）消除姑妈无始劫来所积之与地狱道相应之业力，莲花承足，宝盖住顶，地狱门闭，极乐门开，其莲如飞，至极乐界。

    二、六字合修：
     om ma ni ba mi hum——诵此六字大明咒时观想：此六字（或声音）消除姑妈无始劫来所积之与六道相应之业力，莲花承足，宝盖住顶，六道门闭，极乐门开，其莲如飞，至极乐界。
    分解修与合修的安排可以按照自己喜欢的模式进行。

    linuwa：
    一、弟子的姑妈现在还在治疗，准备手术，情况比较危急，现在用什么方法帮助好些？
    二、弟子现在一直在念南无阿弥陀佛可以吗？是结合阿弥陀佛与您教的方法还是坚持其中一种就可以还是改为您的方法，谢谢！！
    三、另外您教的方法弟子不知道具体明细，粗略的观想可以吗？特别是那个宝盖不知道如何想。同时六道门要想象颜色吗？最后是想象莲花承载姑妈去极乐世界吗？

    zf：
    念观世音菩萨名号或六字大明咒请菩萨加持您姑妈减少痛苦。
    一、可以一心念佛，祈请阿弥陀佛将您姑妈接至极乐。
    二、念佛和持咒两种方法也可并用。
    总之，选择你最有信心的方法。

    “粗略的观想可以吗？”
    ──可以。只要有那些思维和意念就有很大的作用。

    “特别是那个宝盖不知道如何想。”
    ──您可以自己想象一个庄严、漂亮的宝盖。
    某些佛像上有此宝盖。

    “同时六道门要想象颜色吗？”
    ──先不必想得那样仔细。
    最重要的是信心。

    “最后是想象莲花承载姑妈去极乐世界吗？”
    当然。
    见佛了生死，如佛度一切。

    jjerry：
    请教问题，我父亲90高龄，已卧床两年有余，最近情况不好，看来来日无多，我应该做些什么事来安慰他？

    zf：
    一、向老人介绍轮回的基本知识，破除现在常人“人死如灯灭”的断灭见。
    二、向老人介绍阿弥陀佛的慈悲大愿和极乐世界的殊胜，劝老人发愿往生。
    三、将《新编佛教念诵集·常用佩带供奉咒轮图·佩带解脱护身咒轮》处之咒轮打印或复印一份，以您认为合适的方式包好（如用绸布等），为老人佩带在胸前或放入衣袋中。
    四、将您念佛、诵经或持咒的功德回向老人，愿其临欲命终时，尽除一切诸障碍，面见彼佛阿弥陀，即得往生安乐刹。
    五、参阅《饬终须知》等著作中的临终注意事项。

    om mani padme hum　愿您的报恩之心得以圆满，并普及于一切众生！

    en：
    我来问些具体问题。
    一、如果家属及老者并不信佛，强行教佛／念佛可能适得其反，应如何处理？
    二、如何选超度的法师？
    三、家属不应该哭，以免影响往生。但家属多不信佛，所以必将哭，那么如何处理？
    四、法事应该做多久？

    zf：
    “强行”效果当然可能不好，应用柔和语，耐心开导。

    “如何选超度的…”
    ──“选”字不好，应用“请”。

    “但家属多不信佛，所以必将哭，那么如何处理？”
    ──从此您知道因果的重要性了吧！所以我们要用心发愿：“愿我临欲命终时，尽除一切诸障碍…”

    "法事应该做多久？"
    ──十小时左右。


如何念大悲咒？

    问：
    如何念大悲咒？
    “念诵大悲咒的时候，前面有一段文字
    “我若向……”
    这些文字是不是每遍都要念呢？还是念完第一遍以后就反复念诵咒语就可？”

    zf:

    一、真言的发音可参考“新编佛教念诵集”，在“佛教在线网站”。
    二、持咒心要：深信佛是不妄语者。

    大悲心陀罗尼经中的观世音菩萨的誓愿：
     “若有比丘比丘尼优婆塞优婆夷童男童女欲诵持者。于诸众生起慈悲心。先当从我发如是愿
    南无大悲观世音　　愿我速知一切法
    南无大悲观世音　　愿我早得智慧眼
    南无大悲观世音　　愿我速度一切众
    南无大悲观世音　　愿我早得善方便
    南无大悲观世音　　愿我速乘般若船
    南无大悲观世音　　愿我早得越苦海
    南无大悲观世音　　愿我速得戒定道
    南无大悲观世音　　愿我早登涅槃山
    南无大悲观世音　　愿我速会无为舍
    南无大悲观世音　　愿我早同法性身
    我若向刀山　　刀山自摧折
    我若向火汤　　火汤自消灭
    我若向地狱　　地狱自枯竭
    我若向饿鬼　　饿鬼自饱满
    我若向修罗　　恶心自调伏
    我若向畜生　　自得大智慧
    发是愿已。至心称念我之名字。亦应专念我本师阿弥陀如来。然后即当诵此陀罗尼神咒。一宿诵满五遍。除灭身中百千万亿劫生死重罪。”

    ──我自己的体会是，先将那些誓愿用心念诵几遍（三遍或七遍），然后再专心持咒，这样效果较好。


关于准提咒

    txwls：
    我还未到寺庙正式皈依，在家想修真言但障碍较多，特别是中午在食堂，晚上和岳父母同吃，我只吃其中素菜，或肉边菜，汤中蛋花或葱蒜难保能全免，怎办啊？我怕反而加大罪过！！！！！

    zf：
    向您推荐准提咒，在善无畏大师所译之《七佛俱胝佛母心大准提陀罗尼法》中，“佛言此咒印能灭十恶五逆一切重罪。成就一切白法。具戒清洁速得菩提。若在家人。纵不断酒肉妻子。但依我法无不成就。”可见修准提法对饮食上并无特殊要求。具体修法可参见《显密圆通成佛心要集》。


楞严咒心的功德

    阿菜：
    楞严咒心的注音有了，可以座上座下修吗？座上有没有手印要求？座上和座下修法的要点是什么？如能有比较详细的开示就更好。阿弥陀佛！

    zf：
    “可以座上座下修吗？”
    ──当然。只要诚心。
    此真言出自《楞严经》，经中未提手印等。只要诵咒便有无量功德。此真言乃一切如来之父母，秘密首楞严。修行要点中的要点是培养对法的信心。《大佛顶首楞严经》中广说此咒心的功德；《佛说首楞严三昧经》中广说首楞严三昧的功德，而首楞严三昧的功德全部为此楞严咒心所摄持，是故万万不能轻慢此真言，否则罪障极大。切记，切记！！！


长咒与心咒

    zf:

    诺那祖师对相关问题的开示如下：
     问：大悲咒与六字真言之功德有无差别？
    答：没有差别。“大悲咒”是观音菩萨之长咒。“六字真言”是观音菩萨之心咒，亦为“大悲咒”之心咒。长咒为多赞叹请求观音菩萨普度众生之意。譬如汝们向长官说话，多说恭维赞叹话，再说请求话，就成为长咒。开口即说请求话，就成为短咒。但目的所请求之事是一样。请求凡夫，要说得理由充足，方能得允许。至于观音菩萨是无差别心者，多说请求话与少说请求话，均一样感应。最要紧是自己要信得过，我就是观音菩萨，观音菩萨就是我，这才是真正修观音菩萨。

    问：持白伞盖长咒与持心咒，其功德有无差别？
    答：持长咒与持心咒，功德并无差别。长咒为多赞叹请求之意；持心咒，我就是本尊，本尊就是我，故功德相等。

    从祖师上述开示中可以体会到两点：
    一、如果有足够的信心：“我就是观音菩萨，观音菩萨就是我”，则受持长咒、短咒并无差别。
    二、如果认为长咒功德更大、对菩萨更加尊重者，便可选择长咒。

    另外，佛法的传播还有一个因缘问题。过去的千百年来，汉地的佛弟子受持大悲咒（长咒）的风气显然要超过受持六字大明咒者，大悲咒（还有金刚经）似乎已经进入了汉地佛子的“遗传基因”中；而在藏地很少普通的行人受持大悲咒，乃至一些活佛对汉地所流行之大悲咒的藏文版本都不熟悉。

    酸菜粉条:

    活佛说的这段不太能理解？
    【问：持白伞盖长咒与持心咒，其功德有无差别？
    答：持长咒与持心咒，功德并无差别。长咒为多赞叹请求之意；持心咒，我就是本尊，本尊就是我，故功德相等。】
    ~~苟其如此，则长咒犹自圣凡隔别，心咒已造生佛不二，两者高下宛然，焉得谓之功德相等？

    zf：
    长咒中并未说圣非凡心中之圣，凡非圣心中之凡。以圣心中之凡礼敬凡心中之圣，乃开显本具功德的胜方便。圣凡隔别乃行人自心之隔也，与法何关！
    随心咒也就是心中心咒，字面上的意思是“精要中的精要”。


推荐《显密圆通成佛心要集》

    qh：
    如何念咒？为什么念？怎么念？念的时候应该注意什么？

    zf：
    qh兄，您的问题可真够大的了！
    一、如果您有传法上师，则以上师的传授为准。
    二、如果您目前还没有上师，要了解密乘，我向您推荐《显密圆通成佛心要集》（大正藏“诸宗部”收录）。

    qh：
    我没有上师就不能念咒吗？首先我没有上师，我也不是修密的，但我是学佛的呀！我学佛有几年了，身心都有变化，烦恼越来越少了。由于习气缘故，有时对升起的烦恼明明知道但控制不住，所以我需要佛菩萨的加持。有人告诉我念咒不失为一好办法，试过几次觉得有效果（六字大明咒），故想将念咒纳入“正规化”。
    如您所说问题严重了，难道不该念？？？

    zf：
    我的意思是，您问的问题都是些大问题，不是一两句话可以说清楚的。六字大明咒和大悲咒没有上师也能念，别担心。


将每日的呼吸转成六字大明咒的持诵

    zf

    鉴于妙音兄的实际情况，在下特为仁兄介绍一个修行方便。

    姜贡康楚仁波切（西藏近代鼎鼎大名的大成就者）在《生起次第和圆满次第——密乘观行心要》（Creation and Completion——Essential Points of Tantric Meditation，WISDOM PUBLICATIOBS，1996）中开示：
    Additionally，in the morning as soon as you rise，
    Having cleared away the stale breath，apply HUNG AH OM to the exhaling，pausing and inhaling，
    Counting twenty－one or a hundred times。
    Imagine that all your breathing during the day is like that。
    When going to sleep，apply the three letter to exhaling，inhaling and pausing，
    And imagine that all your breathing during the night is like that。
    By doing this，your daily 21600 breaths become mantra and the deity’s recitation requirement is fulfilled without hardship。

    翻译成汉语就是：
    “另外，早晨在你刚起床时，呼净胸中的浊气，在呼气、暂停和吸气时默念　吽　阿　唵　三字二十一遍或一百遍。
    想象你整个白天的呼吸都如此。
    临睡觉前，在呼气、吸气和暂停时默念此三字，并想象你整个夜间的呼吸都如此。
    如是，你每日的21600次呼吸便都变成了对真言的持诵，这样对本尊真言持诵的要求便可以轻松完成。”

    妙音兄，如果行人在呼吸之间默念“三字明”，再加上那个特殊的“想象”，每日的呼吸便可以成为对此真言的持诵，那么你若在呼吸之间默念“六字大明”，再加上“想象”，每日的呼吸一定也是对六字大明咒的持诵！
    您若能对此方便生起信心，如说修行，既可以达到相当可观的诵咒遍数，又可以安下心来陪孩子，可为两全其美！
    道路在面前，是否肯上路就看仁兄自己了！

    《Creation and Completion——Essential Points of Tantric Meditation》一书的藏译英和公开出版是在Marpa Institute　的Khenpo Tsultrim Gyamtso　仁波切（仁波切于尼泊尔弘法）的建议和授权下进行的。仁波切在该书的英文版前言中写到：“二十世纪末，人们生活在极度繁忙之中。人们忙于工作、家庭或消化吸收源源不断的新信息。在此纷纭复杂和充满压力的世界，寻找一个地方去专修佛法并不总是很容易的，因此人们需要的是清晰、简洁的观修理论和实践。”（对此，论坛上的诸兄一定深有体会吧，特别是妙音兄！）该书介绍的姜贡康楚仁波切的教法便具有这个特点。在序言的最后，Khenpo Tsultrim Gyamtso　仁波切祝愿：“愿此教法为无量有情带来广大的利益。”
    我等今日有缘亲尝此殊胜法味，当至心感谢诸佛菩萨的慈悲。

    文中的真言是om ah hong。在该书前面部分此真言出现时是om ah hung　而不是　hung ah om。
    我认为，文中“在呼气、暂停和吸气时默念　吽　阿　唵　三字二十一遍或一百遍”等同于：在吸气、暂停和呼气时默念　唵　阿　吽　三字二十一遍或一百遍。（可能产生歧义的地方是以“呼气、暂停和吸气”还是“吸气、暂停和呼气”的方式呼吸，这两种呼吸方式密乘修习时都有采用，但后一种方式更常见。）
    该书中介绍的是对om ah hung的观修。但本人认为，om ah hung三字明具有的功德，六字大明咒亦应完全具足。通过对三字明的观修能将每天的呼吸变成对真言的持诵，通过对六字明的观修同样能将每天的呼吸变成对真言的持诵。建议可以尝试在吸气（om）、暂停（mani padme）和呼气（hung）时默念六字大明的方法。
    提醒仁兄一句，此修法的核心不在呼吸方式和具体哪一个真言，而在“想象”和信心。


只管耕耘，不问收获

    songyl:

    听某位仁波切的开示说：“佛经中载有修持六字大明咒之功德，念一万遍可出离堕落三恶道之苦；念十万遍可从六道轮回中解脱，念一亿遍则可往生西方极乐世界。这是佛经所言，真实不虚。念观世音菩萨心咒，修持、礼拜观世音菩萨的利益之所以这么大，其主要的加持力系来自于我们对佛的信仰，观世音菩萨在过去世已成佛是原因之一，今天我们能得以听闻观世音菩萨的心咒，也是由佛的功德加持而来。以后修持观音法门，在内心生起各种正念、悟道，乃至最后成佛的功德加持力也都是从佛而来。”
    一亿遍六字大明咒即可往生极乐？请问出处。末学粗算了一下，从今起念三十年，每天不断，每天念三小时，约可完成此一亿遍。试问这类修持中平日散念算不算？如要求专门修法，末学时间怕不能保证。不敢发愿行持。第二，念佛号求往生似没见到此类“定数”之说。是我寡闻还是根本没有？为何会有此差异。请示。

    zf：
    songyl兄，关于六字大明咒，汉语佛经中集中开示其功德者就是《大乘庄严宝王经》。此经中似乎未有关于“念一亿遍则可往生西方极乐世界”的记载。或许仁波切依据的是其他藏文经典。
    密典中不乏一些“定数”的开示，如：
    《大宝广博楼阁善住秘密陀罗尼经》
    成就心陀罗尼法品第四
    “凡成就心陀罗尼事业者诵十万遍即见一切如来。诵二十万遍得见一切佛土。若诵三十万遍得成入一切曼荼罗。一切真言法悉得成就。诵四十万遍得持明仙中转轮王。诵五十万遍一切阿苏啰。及诸仙窟龙宫窟门自开悉皆得入。若诵六十万遍得见一切伏藏。若诵七十万遍即忆知过去无量生宿命事。若诵八十万遍即得宝印三摩地。若诵九十万遍得一切菩萨游戏神通加持。若诵一百万遍得一切如来灌顶。与一切如来同会。福慧如是倍增而获无量殊胜功德。”

    依在下之见，行人若对某一真言深具信心，不妨依《普贤行愿品》中普贤菩萨之愿来发愿念咒：虚空界尽，我念乃尽，而虚空界不可尽故，我此念诵无有穷尽。如是乃至众生界尽，众生业尽，众生烦恼尽，我念乃尽，而众生界乃至烦恼无有尽故，我此念诵无有穷尽，念念相续，无有间断，身语意业无有疲厌。
    普贤菩萨如上之发愿，深契华严法界实相，实乃“一念中所有行愿皆得成就”之发愿妙法。
    行人若能如是发愿持咒，只管耕耘，不问收获，而结果自然是“一念一切悉皆圆，成就众生清净愿”。

    二麻子：
    正解正解……
    “行人若能如是发愿持咒，只管耕耘，不问收获，而结果自然是‘一念一切悉皆圆，成就众生清净愿’。”
    ——如是如是，如实如实。初心行人发愿修学菩提道，往往耽耽于所得胜果，虽也是入菩萨修学的方便，虽也是无论如何赞叹也不为过的，比上述发心终究还隔了相当距离。若能学普贤菩萨发广大无量心而只管耕耘不问收获，有什么障碍还能真的阻挡法尔圆成？

    阿弥陀佛，麻子随喜。


关于无表色等和实际修持的密切关系

    关于无表色等和实际修持的密切关系

    zf

    【辞典词条：法处所摄色】（术语）总括诸法为十二处，摄属于法处而为意处之所对者，有五种，一极略色，分析色声香味触，眼耳鼻舌身等有质之实色而令至极微者。二极迥色，分析虚空青黄等无质之显色而令至极少者，达见为难，故名极迥色。三受所引色，即无表色也，是为依受戒而引发于身中之色，故名受所引色。四遍计所起色，遍计一切法之意识前所显现之五根五境等影像是也。如空华水月等皆为此所摄。五定所生自在色，禅定所变之色声香味等境也。以胜定力之故，于一切之色变现自在，故名定所生自在色。

    常如兄，这里所列举的五种色法中，后三种与我们实际修持有密切关系。
    先说无表色。
    上面仅说到因受戒而得戒体，此戒体无形无相，无法表示，但有止恶扬善的殊胜功能。实际上，根据“心气不二”之说，任何一种心行，必有一种“最细风”与之共存。（金刚量兄说：“部派论说中还有将业力定义为‘无表色’的”。将业力说成色法，在下不敢苟同。但在下相信，必有与造业之心力相对应之无表色存在）。受戒是一种止恶扬善的心行，必有一种相应功能的最细风身存在。同样，发菩提心、读诵佛经、诵持真言者都会感得这种止恶扬善的风身。《普贤行愿品》中“此善男子，善得人身，圆满普贤所有功德。不久当如普贤菩萨，速得成就微妙色身，具三十二大丈夫相”。这里因受持普贤行愿而感得的具三十二大丈夫相的微妙色身（即菩萨的报身）也应属于无表色的范畴。
    在下认为，无表色之无形无相，是相对我们凡夫而言，并不是绝对之“无形”。无表色中亦应有“粗细”之分，粗分之无表色，天人可以看到；极细之无表色恐怕只有登地以上的菩萨才能见到。如来报身之色，应是最细之色。
    心中执著越重，与之相应之无表色越粗。若心彻证空性，与之相应之“色”便应最细。
    最后两种细色与密乘中的“幻身”修法也有密切联系。
    大乘修行的根本目的就是证得胜法身和胜色身。细色与心行的关系，密乘明说，显乘少说。显乘虽不明说，但并不是说显乘的心行没有生起胜色身的功能。未破无明时的菩萨行愿所感之细色身较粗，相当于密乘生起次第的“浊幻身”；待附会于菩萨行愿之上的无明被去除后，“纯净”之大悲行愿所感者为最细之色身，相当于密乘中圆满次第的“净幻身”。（法身非身，证得诸法空性，即是证得法身。）
    总之，离不开悲智双运。只要下面这四句偈牢记在心，行人应不会偏离修行之正道：
    文殊师利勇猛智，普贤慧行亦复然，我今回向诸善根，随彼一切常修学。
    与兄共勉。


根本净光心是缘起还是非缘起？

    空明无二智：
    虚心求教ZF兄，请您讲讲根本净光心究竟是缘起的，还是非缘起的，如果是缘起的，究竟是何缘所生起？如不是，为何无自性？

    zf：
    这岂是我所能讲清楚的，本人这样说，绝不是自谦。同时，这一问题完全有可能以我们的语言、思维根本无法彻底说清，正所谓唯证相应。试想，古人在智慧上并不比我们逊色，这样的问题一定同样被问过不知多少次，何以世尊和诸大菩萨均言此根本心无自性，但非修因所生，而不斩钉截铁地开示其根本上就是非缘起法？
    另一方面，有人认为，既然从根本上说本问题的解决要靠修证，因此对其探讨纯属多余，只需修去。对此本人亦不敢完全同意。对那些信根成就的行者，这种方式可行，但对和我类似的一些人来说，如果对目的地完全不了解，或根本无法理解其存在的道理，便无法全力以赴地赶路。因此我对这些问题探讨的原则是，即使不能完全理解，也希望对其存在的可能性有个大致了解。
    下面谈谈自己的一点体会。
    1．引起根本净光心是缘起还是非缘起这一问题的原因是其为众生本具，非因修而得。兄所熟知，空性亦具有上述特征，但空性非法（虽也有称其为无为法者），故其非缘起，合情合理。但此根本心却不能说为非法，若认定其为非缘起法，便与如来宣说之“诸法因缘起”的根本开示矛盾。另外，法无自性，起必依他，而同时承认非缘起和无自性，却非本人心量所堪容。是故此根本心只要有一丝缘起的可能，本人亦不愿接受其为非缘起法的结论。那么，此心是否有可能既是众生本具又因缘起呢？我觉得完全有可能。
    杜顺大师在《华严五教止观》中开示：“即此缘起之法即空无性，由无性故幻有方成。然此法者即全以无性性为其法也，是故此法即无性，而不碍相存也。若不无性缘起不成，以自性不生皆从缘故，即全收性尽。性即无为不可分别，随其大小性无不圆，一切亦即全性为身，是故全彼为此。即性不碍幻相，所以一具众多，即彼此全体相收，不碍彼此差别也，是故彼中有此，此中有彼。”
    大师上述开示的特点为：
    （1）立一切法为缘起；
    （2）缘起法以无性性（即空性）为其法（亦即法身）；
    （3）此无性性无为不可分别，无论何法其无性性无不圆满；
    （4）因一切缘起法皆以无性性（空性）为身，是故彼中有此，此中有彼。由此而成立事事无碍、重重无尽之因陀罗网境界。
    既然彼此全体相收，是故如来的智慧德相众生亦应全具，当然也包括此根本净光心了。
    应特别注意的是，此处众生本具如来德相不但不需借用“非缘起法”的概念，而且只能在一切法皆为缘起的前提下才能成立。
    另外，《宝性论》中一颂，亦说明了众生本具如来藏的原因。此颂谈锡永上师新译为：
    “佛法身周遍，真如无分别，具佛性有情，说有如来藏。”
    法身、真如、佛性虽含义丰富，但均有空性之意。此处如均作空性解，应无大误。此颂的大义为：佛、众生本性均为空性，而此空性无为不可分别，因此一切众生具有如来智慧德相。上述法义与杜顺大师的开示如出一辙。
    由此，本人认为，众生本具如来德相（当然包括根本心）不但不与缘起相违，而恰恰是缘起法的甚深法性。
    2．谈谈对无明的看法
    无明作为生死轮回的根本，生死因其而起，亦因其灭而灭。所以只要承认无明是可灭的，无论是否认为其为缘起，均对修行无大碍。但说句心里话，除非万般无奈，本人亦不愿意承认其为非缘起法。而尝试以缘起来理解。
    首先，无明以诸法之自性为所缘。诸法之自性如龟毛兔角，本来无有，故法之自性为非缘起法。但对此如龟毛兔角之自性（非缘起法）之执著却可以认为是缘起法。无明与“明”（即般若）的缘起性有点类似，所缘均非法。般若所缘为空性，此空性亦非缘起法，但般若却为缘起法。
    以无明为缘起法可能导致的一个困难，是无明缘起之前此心为何？若为明，则有由明而变无明之嫌。如是，成佛后还会迷失，此不应理。克服此困难的一个出路是认定此无明无始，故名无始无明。
    麻兄所“编”之无明的非缘起但无自性，必有其密义，本人不敢妄测。
    关于这样深广问题的讨论，不可能在短时间取得一致的意见，甚至今世或以后多世亦未必意见一致，当然有一致的时候——大家亲证无上菩提之时。为此，祈愿所有参加、关注此次讨论的坛上诸位兄弟均能虔发菩提心，勤积福智资粮，早成佛道，利益一切。
    罗嗦了这么多，都是自己的真实想法。难免犯以生灭心测涅槃界之错。不敢奢望解除兄的疑惑，若对兄有一点点启发，本人心愿足矣。
    祝新年新气象！


关于修念本尊

    关于修念本尊

    zf

    密乘修行应以上师的开示为准，我下面介绍者是若干一般原则，供参考。
    “请问如何找到自己的本尊？
    ──佛菩萨有不可数不可数那么多！本尊是不是就是自己最有信心的一位佛菩萨？比如观自在菩萨。”
    这应该听上师的，但通常上师会根据弟子的因缘来确定。

    “一经确定是否终身不变？”
    ──本尊一经确定，最好不变。
    对此问题，诺那祖师开示如下：
    问：有人今天修此本尊，明天修彼本尊，是否能多得诸尊佛菩萨之加被，有易于迅速成就之功德？
    答：学佛贵于一心，各人所修本尊，始终只有一尊，不宜随便变更，其他诸佛菩萨之法，亦可作为助修。如今日修此佛为本尊，明日修彼佛为本尊，恰如汝们公务人员，今日侍候此长官，明日又侍候那长官，反复无定，结果得不到一个有感情之长官，如能始终侍候一个长官，一定能得到长官之信用，只要对一长官有真感情，则其他诸长官对于汝亦自然有感情。密宗行人，如始终修一本尊，得到本尊之感应后，其他诸佛菩萨，亦对汝均有感应。所谓一法通万法均通也。二心就不能成佛，何况多心。不过人心很多，所以凡夫亦很多。

    “比如在修加行的时候，就想着也是观自在菩萨在修加行？拜佛的时候，其他的佛菩萨都看作是本尊的化身。　礼拜本尊就是礼拜其他所有的佛菩萨，反过来也是一样？　”
    ──“正规”密法的修持是有步骤的，自己与本尊不二不别的修持通常是在加行基础上进行的。在修加行时，行人尚未作自成本尊之修习，通常是以现在的凡夫形象礼敬诸佛、忏悔业障。

    “念六字大明咒就是念其他一切的咒语？口渴时喝的一口水，是观自在菩萨的甘露，黑弄堂里的一盏路灯是菩萨心化的明灯，出门碰到好天气也是佛菩萨的加持？　”
    ──对。
    “刚接触到密宗不久，有很多比较初级的问题”
    ──密宗的知识可以多了解些，但实际修行应在上师指导下进行。


“最细风身”与心同在

    “最细风身”与心同在

    zf

    常如兄，您前些天参加讨论时问及“无色界天人的‘载体’与‘思想’是怎样的？”。以下是在下的一点粗浅理解，供参考。
    思想是不能脱离载体而单独存在的，密乘无上部中的“风心不二”开示的就是这个道理，即“最细风身”与心同在。以这一观点来看欲界、色界众生乃至诸佛菩萨，都好理解。问题是如何理解无色界众生心与风的关系。
    关于无色的含义，经论中说法不一。有人认为，既言无色，即蕴含‘色已全无’之意。心识可以离开色法而单独存在。如《成实论》中说：
     “问曰。若意识更无根者。为依何处。答曰。依四大身。问曰。无色界复何所依。答曰。无色界识无所依。法应如是。无依而住。所以者何。相差别故。意识能知有无。若有色则依。无色亦能住。故无色界。亦无依而住。又众缘合故识生。”
    但亦有认为‘无色’应是无粗显之色，而非无细微之色者。在下更愿意接受这种见解。在下浅见，无色界众生色身不是没有，而是不显。我等众生如持“心可独存”之见，辅以“专心忘身”之甚深禅定，业力足够强大时，便可能感得无色界的异熟果报。与此相似的是，当我们专心思维时，可能忘记身境的存在，但此时心的活动并不因为我们的忘记而可离身（此身包括风身）独立存在。
    大乘诸经中多有描写无色界之“色相”者。
    如《佛说菩萨本行经》中：
     “于时如来观于三界诸天人民。心怀欢喜踊跃无量供养如来。世尊将欲说于前世本所修行菩萨道时。即便微笑。五色光明从口中出。光有五分。一一光头出无数明。一一光头有宝莲花。一一花上皆有化佛。一分光明上照欲界色界无色界。三界诸天见其光明。又睹化佛皆悉欢喜。各离欲乐来诣化佛所听说经法。”
    从上述开示中可知，无色界之天人亦可见佛光明，并睹化佛。
    《大乘悲分陀利经》中：
     “尔时我当从兜率天下。为度众生熟善根故。于最妙转轮王种第一夫人腹中受胎而住。我当尔时放净光明遍照娑诃佛土上至阿迦尼吒天下至金轮际妙光周遍。尔时众生生娑诃佛刹者。或在地狱或为畜生或为饿鬼或生天上或生人中。在色界无色界想无想非想非非想处。令彼一切见斯光明觉触其身。令彼一切厌生死苦乐求涅槃。”
    这里无色界众生不但能见佛光明，如来光明还可“觉触其身”。可见无色界众生亦应有“色身”。
    《大乘本生心地观经》中：
    “时薄伽梵。于师子座结跏趺坐。威仪殊特犹如四宝苏迷卢山处于大海自然迥出。如百千日照曜虚空。放无量光破诸昏暗。亦如俱胝圆满月轮独处众星。放清凉光明朗世界。是时如来入有顶天极善三昧。名心璎珞宝庄严王。住此定已。身心不动。时无色界一切天子。雨无量种微妙华香。于虚空中如云而下。色界诸天十八梵王。雨众杂色无数天华百千万种。”
    这里，无色界天子尚能雨无量种微妙华香供养如来，可见无色界不是绝对的无色。
    《华严经》中：
     “尔时善财童子。见普贤菩萨。如是自在神通境界。欢喜踊跃。普遍身心。重复观察。见普贤菩萨。一一身分。一一肢节。一一毛孔。悉有三千大千世界。其中一切地水火风。大海四洲。须弥铁围。及众宝山。国土城邑。宫殿园苑。乃至地狱。饿鬼畜生。阎罗王界。天龙八部。人与非人。欲界色界。无色界处。所有形色。日月星宿。风云雷电。昼夜月时。及以年劫。诸佛出世。菩萨众会。道场庄严。如是等事。悉皆明见。”
    这里，善财童子能于普贤菩萨身中，“见”到无色界处。既然能被见到，就意味着有某种细微的色。
    大乘经典中这样的例子很多，在下就不一一列举了。
    若依华严，这一问题更好理解。法界之存在，本来就是重重无尽、事事无碍、一即一切、一切即一。众生乃至菩萨皆因其业力（菩萨的智慧和悲愿也是一种广义的业）而显此无尽法界之一角或局部，唯如来之普眼境界可尽观法界矣。


真言起用原理之浅见

    真言起用原理之浅见

    zf

    简单说，如来的本质就是智悲不二的大菩提心。此心在“色”上的显现，就是如来的庄严法相；在“声”上的显现就是如来的真言密咒。
    观佛形象的功德较易理解，其实持咒的原理与观想一样，都是以如来果地的功德为我等行人因地之所缘。其目的只有一个，将我等充满贪嗔痴的心转化成智悲不二的大菩提心。


一起踏踏实实学习这些如幻的功德吧！

    喝茶：
    现在有人标榜无上瑜伽有“幻身”成就，殊不知难到一切本来不就是个幻吗？所以还是个见地的问题。

    zf：
    不同意您的看法。喝茶兄，请原谅在下的直言──您上面对藏传佛教的评论是典型的对自己心中藏传佛教的评论。
    是的，一切本来都是幻，但观世音菩萨于六道寻声救苦这种“幻的本事”老兄有没有？地藏菩萨地狱不空不入涅槃这种“幻的大愿”老兄有没有？若老兄有这些“幻的本事”和“幻的大愿”，在下真心顶礼老兄，若没有，我们还是一起踏踏实实学习这些如幻的功德吧！
    无上瑜伽的“幻身”修持是成就上述如幻功德的殊胜方便，老兄不知详情，万不可随意说三道四。当然，这不是唯一殊胜的方法。


汉地古德指出的一条以华严法界观来修持密法的奇径

    天楼霜月：
    密宗观行是否与华严的法界观一样。

    zf：
    不尽相同。但以《显密圆通成佛心要集》为代表的汉地古德指出了一条以华严法界观来修持密法的奇径。
    另外，《普贤行愿品》中多处提及：“我以清净身语意……”，初学行人诵经至此处时常常感到茫然：何谓清净身语意？当然对“清净”的理解可以有不同的层次。有密乘背景的行人此时莫忘：所谓清净身语意者即是本尊的三密。若以本尊三密去观修普贤行愿品，就是以华严法界观来修持密法，或以密法修华严法界观。
    没有密法背景的行人修普贤行愿品也同样殊胜。如果以密乘的语言来表述的话：普贤菩萨的微妙色身是本尊的身密，普贤行愿品是本尊的语密，而普贤行愿就是本尊的意密。
    另外
    “一切如来有长子，彼名号曰普贤尊，
    我今回向诸善根，愿诸智行悉同彼。
    愿身口意恒清净，诸行刹土亦复然，
    如是智慧号普贤，愿我与彼悉同等。”

    不正是自成本尊的誓愿吗？


对汉藏佛法谈点感想

    智行：
    很多人简单地将显宗（用逻辑推理）等同於汉地佛法，将密宗等同於藏地佛法，但实际并非如此简单。密宗在藏地最兴盛，有殊胜多门的方便，这是有目共睹的。但愚见藏地在显教方面下极多的苦功，故能培养出许多具金刚不动之信心者，成为密法之根器。汉地佛法禅宗的明心见性本身是密，天台贤首也绝不在下。净土法门被佛说成是“无上深妙禅”当然更没有不是密的道理，只是此门是密法显说，容易被人看浅。又圆觉经说“一切众生本来成佛”，当然包括了能转秽身成圣体之理。其实当下就是，唯人自迷不知。这正是大圆满境界。
    后学感觉汉藏悬殊较大之处不在於理，而在於入门的方便法门的多寡和承传上。藏地诸多真言，非常好用。汉地的真言和传承多隐没了，可惜。藏地传承的加持力当然更不可思议，对於信心坚定者有奇效。综合起来看，后学认为汉人最应学藏人那样老实修行，谦虚恭敬上师和三宝，在出离心、菩提心上多下些功夫，而不只是理解辄止，这样才有后劲。再加上真言的总持力，就有不思议效果。至於对理体的认识，似乎这并不是汉人的弱项。愚甚至认为大圆满、大手印应该和汉人挺有缘才对。而广大汉人在道前的资粮修集较少，故入道和修证都会有障碍或易生退惰。《大圆满前行引导文》是部好书，值得各宗学习。汉地也有类似的内容，但不知是门派有别或什么因缘，少见系统集中教学传承。不知是否汉人对道前资粮不够重视，或是一味求高见地忽略了基础而出问题。
    后学感觉到，汉人一方面要认识祖师留下的宝贝，另一方面要学藏人的朴实和谦虚，扎实修集道前资粮，才能在汉地复兴佛法。在此抛砖，供大家思考。

    zf：
    智行兄所说甚善。依在下浅见，一些现代西藏僧人或学者对汉传佛教的了解相对局限于禅宗（某些教派对禅宗的评价，实际上是对他们自己心中“禅宗”的评价，如同某些汉人学者对密法的评价一样。这种“堂吉诃德大战风车”式的论战，古今中外都不鲜见）和净土宗，而对天台和华严等于汉地开宗立派者了知甚少。
    汉地天台、华严和禅宗等宗派与藏传佛教系统的“显宗”在见、修、行上是否属于同一层次？对此仁者见仁，智者见智。某些深谙汉传佛教精髓，同时又为藏传金刚大阿闍梨的成就者们（如诺那活佛传承的上师）认为，如果以藏传系统的立场来看，汉地天台、禅宗等宗派毫无疑问应当属于“大密宗”的范畴。这里“大密宗”是指密乘中的无上瑜伽部，特别是大圆满。
    大圆满修行的要点：修行大圆满最当机的弟子是对上师三宝具有无比信心者。因此大圆满一切前行的目的都可以归结为对“信心”的培养。有信心者对本具之如来智慧德相当下承担，并不需要其他“方便”。毫无疑问，在修法的系统性和层次性上，藏传有突出的优点。但如果因此将汉传修法说得一无是处显然与事实不符。
    至于对汉传佛教没有系统方法的批评，这显然不是事实。禅宗对根机成熟者直指人心；对根机不足者亦有种种接引方便，例如参话头等。天台宗关于“止观”的教授由浅入深，自成系统，绝非是只靠因明和思维。
    关于“色身”相好的修持，常被认为是汉传佛教的弱点，事实上我们熟知的《普贤行愿品》中对此便有明确的开示：“此善男子，善得人身，圆满普贤所有功德。不久当如普贤菩萨，速得成就微妙色身，具三十二大丈夫相。”这里普贤菩萨非常确定地指出，修持普贤行愿者可以速疾成就具三十二大丈夫相之微妙色身。事实上，如果行人心契空性，并以普贤菩萨之行愿为己愿，行人之最细风身若不显现微妙之三十二大丈夫相反倒是真正的怪事。另外，《普贤行愿品》中之“一切如来有长子，彼名号曰普贤尊，我今回向诸善根，愿诸智行悉同彼。愿身口意恒清净，诸行刹土亦复然，如是智慧号普贤，愿我与彼皆同等。”这种欲成就普贤菩萨身口意和净土之修持与密乘中的“本尊法”用心完全一致。由此可见，汉传佛教绝非是某些人心中的“显宗”。
    若论将烦恼转为道用，维摩诘居士就是这方面的典范，汉地历史上秉承这类传统的大德并不少见。若论“诀窍”，《华严经》中有发心即成佛的诀窍。至于行人对此诀窍是否有信心，则另当别论。
    对待汉传佛教，我们这些汉地佛子既不要抱残守缺，也不应采取虚无主义的态度。无视两千年来汉地历史上的众多古德对适合于汉地众生根性修持之道的探索，从某种意义上说是一种忘恩负义的行为。这些古德之中肯定会有文殊、普贤、观音、地藏等的化现。
    今日汉地佛子在修行上的突出弱点是对以菩提心为核心的加行没有给予足够的重视。如果行人有了菩提心这一大乘道的坚实基础，“向上一路”之修法汉地并不缺乏。


藏传有藏传的因缘与殊胜，汉传有汉传的因缘与殊胜

    藏传有藏传的因缘与殊胜，汉传有汉传的因缘与殊胜

    二麻子

    致金刚兄……
    嘻嘻，回头一看，你老兄的帖子又被删了。说实在话，也是该删，老兄何必把话说得那么难听，简直是有意识招人来删吗。所以，麻子得说声，为了卫生起见，应该删。话说回来，麻子也得说声，金刚兄那帖子里表现出来的眼力，麻子是十分尊重的。嘻嘻。好眼力。在麻子看来，我汉地的禅也并不是所有学大圆满的藏人都懂的。方便后得智，不学也不会。汉传佛教里大有奇珍瑰宝，自满自封当然错误，唯藏为尊似乎也同样滑稽。莫非还真是只有远来的才会念经不成？嘻嘻。
    这事其实与崇洋媚外／贬洋排外之类的社会现象类似，都是极端倾向。不能在这些方面把持中庸之道，不能排除极端捧／摔，说明我们汉地佛弟子有些不够成熟。


阿达尔玛佛

    阿达尔玛佛

    二麻子

    阿达尔玛佛是指法身，这有什么疑？看看宁玛教法吧。不光宁玛，黄花白也一样，凡讲传承法脉之起始，都是由法身─>报身─>化身，再进入人间传承的。宁玛在此称法身佛为阿达尔玛佛，即普贤王如来。
    五方佛中，以毗卢遮那佛为蓝色，宁玛以普贤王如来为蓝色，您当是编的呀。看看古今成就者们的开示吧，“无云晴空”这话是怎么来的？
    至于如果有什么书说阿达尔玛佛是报身佛，请去问作者，麻子不知他为什么这样说。
    另外不可望文生义。“本初佛”不是“太初有佛”的意思。
    本初佛与“法性”同义。真如非因“妄想”生，在凡夫看上去，真如就在一切之前了。不记得禅宗说“威音王以前”了？？？？


唐密中的“大圆满见”

    每日经论：
    真言净菩提心私记　节录
    傅法院觉鍐撰

    夫。真言净菩提心。是自性法身心地法界大日如来心王具体。亦一切众生色心实相。普门海会平等种子。故大日经疏第二云。此心即是如来自然智。亦是毗卢遮那遍一切身。以心如是故诸法亦如是。根尘皆入阿字门又同疏第一云。一切众生色心实相从本际已来常为是毗卢遮那平等智身。非是得菩提时强空诸法使成法界也。佛从平等心地开发无尽庄严大曼荼罗。已还用开发众生平等心地无尽庄严大曼荼罗。妙感妙应缘不出阿字门。当如。感应因缘。所生谁亦复不出阿字门。
    又此净菩提心。是一切众生自然本有心地实际。即是一切智智。如实了知名为一切智者。故大日经第一云。云何菩提。谓如实知自心。十住心论第十云。经云。云何菩提。谓如实知自心。此是一句含无量义。竖显十重之浅深。横示尘数广多。又大日经疏第一云。此品统论经之大意所谓众生自心品。即是一切智智。如实了知名为一切智者。是故此教诸菩萨真语为门自心发菩提。即心具万行见心正等觉证心大涅槃。发心方便严净心佛国。从因至果皆以无所住而住其心故。曰入真言门住心品也复此净菩提心是真言行者入修秘要。悉地成就速疾成就。必依真言净菩提心一体速疾力三昧也。真言行者若以本尊三密方便。勇猛精进观之。行之。此生秘获除盖障三昧入诸佛境界。故大日经疏第一云。今真言行者。于初发心时。睦观自心实相了知本不生故。即时人法戏论净若虚空。成自然觉。不由他悟。当知。此观复名顿悟法门也经云。秘密主此菩萨净菩提心门名初法明道。菩萨住此不久勤苦。便得除一切盖障三昧者。入佛智慧有无量方便门。今此宗。直以净菩提心为门。若入此门即是初入一切如来境界。乃至云法明者。以觉心本不生际。其心净住生大惠光明。普照无量法性见诸佛所行之道故云法明道也。乃至行人因净菩提心。照明诸法故。少用功力得除盖障三昧。见八万四千烦恼实相成八万四千宝聚门故。经次云菩萨住此修学不久勤苦。便得除一切盖障三昧。若得此者即与诸佛菩萨同等住又同疏第二云。行者初入净菩提心。虽未于无数阿僧祇劫具备普贤众行满足大悲方便。然此等如来功德皆已成就。何以故。即是毗卢舍那具体法身又大日经第七云。若我势力万增益。住法但观菩提心。佛说此中具万行。满足净白纯净法又发菩提心论云。若人求佛惠。通达菩提心。父母所生身。速证大觉位。……(编按：系摘自《大正藏》)

    zf：
    大圆满见：
    “一切众生色心实相从本际已来常为是毗卢遮那平等智身。非是得菩提时强空诸法使成法界也。佛从平等心地开发无尽庄严大曼荼罗已。还用开发众生平等心地无尽庄严大曼荼罗。
    又此净菩提心。是一切众生自然本有心地实际。即是一切智智。如实了知名为一切智者。”
    对唐密、东密这体系切不可小看。


关于谈锡永上师谈大圆满

    zf：
    谈锡永上师的一些观点十分新颖，例如认为维摩诘居士是大圆满法的人间祖师等，对学人很有启发。遗憾的是，因为谈上师的著作都在海外出版，大陆对其了解十分有限。谈上师文中认为如来藏是法性之作用，而不是某种意义上的“本体”，这一点宁玛学人应给予足够重视。

    文摘：
    谈锡永上师，法号无畏金刚，以笔名王亭之驰誉于世。广东南海人，先世八旗士族。童年随长辈习东密，旋即对佛典产生浓厚兴趣，至二十八岁时皈依西藏密宗，于三十八岁时，得宁玛派金刚上师位，为敦珠法王的心子。1986年由香港移居夏威夷，修习大圆满四部加行法；1993年移居加拿大多伦多。
    本文下面的内容摘录自谈上师之《闲话密宗》一书（台北全佛文化出版社，1997）。谈上师在该书自序中写道：“笔者近年应《华侨日报》之邀，辟专栏谈佛谈密谈术，这里所收集的，即是其中的一组文字，采取闲谈的方式，讨论一些密宗的问题。因为是报纸副刊的小专栏，因此亦不可能用写学术论文的方式来写。但这样做却有好处，那就是真的能如闲话家常，娓娓而谈，谈时好像彼此捧着一盏茶，歪在沙发上，省掉正襟危坐的拘谨。对于初学密乘的人来说，这种方式或者反更容易接受。但形式虽然随便，内容却很严肃，里头说的，都是笔者近几年建立的观点。”

    “六年心血一席话”
    ──谈锡永上师谈大圆满、如来藏、中观和禅宗

    什么是“大圆满”

    “大圆满”的修习，目的在令行者能证空性，亦即如汉土的祖师禅“知本来面目”与“顿悟”。所以“大圆满”实在是不能修的，能修的，只是引导行者证悟的种种修持法门，实际上只是“大圆满”的前行。
    俱生喜金刚所传的“大圆满六百四十万颂”，一九八二年东京出版了一套“宁玛派密续编目”，已有记录，而且还作了提要。由提要可知，大部分所述都是前行，只可惜提要者语焉不详，以致难以知道，一千九百多年前的“大圆满”前行修习，到底跟今日所传的修习有什么不同。而全套密续，实在亦应该翻译出版，因为无论如何都是相当于我国东汉初年的印藏古籍。目前笔者编译的《宁玛派丛书》，即将此项计划考虑在内。
    如今所传的“大圆满”，最重要的是确立一种见地，称为“大圆满见”。也即是说，“大圆满”本身虽只能悟而不能修，但“大圆满见”却必须了解。
    然则，“大圆满见”又到底是什么呢？
    基本上，即是“众生皆能成佛”、“众生都具佛性”的“如来藏”思想。关于“如来藏”，佛家对之有许多争论，汉土藏土对之都有批评，因此非加以讨论不可。
    “如来藏”系列的经典，佛学家一向视之为晚出的大乘经典，比《般若》系列、《唯识》系列都要晚，充其量视之与《唯识》系列相先后。
    实际上，《维摩诘经》中已有“如来藏”的思想。经中维摩诘问文殊师利菩萨：“什么是如来种？”文殊师利于是答以一连串的烦恼：“有身为种、无明有爱为种、贪恚痴为种、四颠倒为种、五盖为种，以要言之，六十二见及一切烦恼，皆为佛种。”
    为什么烦恼即是佛种呢？
    文殊师利说；“比如高原陆地，不生莲花，卑湿于泥，乃生此花。”又说：“比如不下巨海，不能得无价宝珠，是不入烦恼大海，则不能得一切智宝。”
    既然烦恼即是“如来种”，是故密乘便可以在日常生活的烦恼大海中起修，而维摩诘本人亦恰恰是在烦恼大海中起修的成就者。
    再进一步来说，由于六十二种邪见以及烦恼皆是“如来种”，则可谓一切有情皆具佛性，都具有成佛的潜能。
    这种见地，不但小乘行人听见为之惊怖，即使一些大乘行人听见，心中亦有点不自在。是故后来当“中观宗”的学说发展至灿烂时，便有人用“中观”的理论来否定如来藏。

    格鲁派力排觉曩派

    其中用“中观”来否定“如来藏”思想的，是藏密格鲁派的祖师宗喀巴大士。所针对的对象，主要是当时的觉曩派。
    觉曩派修习，以《时轮金刚续》为主，恰巧宗喀巴亦弘《时轮》，然而两派的宗旨却不相同，由是彼此自然有所异议。宗喀巴称觉曩派为“他空派”，并且用中观应成派的理论来将之辩破。

    什么叫“他空”呢？

    举例来说，我们将抽屉里的东西统统拿掉，便说“抽屉空了”，这便是“他空”。因为所空的其实是抽屉以外的东西，而非抽屉本身的本体。
    觉曩派认为“如来藏”是众生成佛的种子，是故本体不空。然而众生不能成佛，却是因为将种种烦恼污染了“如来藏”，此等污染即是无明，是故应空，当无明空掉以后，“如来藏”的本体法尔显露，众生因而便可成佛。
    宗喀巴称之为“他空”，便是这个道理。空掉“如来藏”上的污染，既等于将抽屉中的东西空掉，但却未知“如来藏”本身的空性，此即是“他空”。
    格鲁派的说法是──自性清净心的法性，未离客垢位（未离无明污染），可以称为“如来藏”，但若已离客垢位，便只能称之为自性身，或称之为“究竟涅槃”，或称之为清净法身，再不能称之为“如来藏”了。因为“如来”称之为“藏”，便只是成“如来”之因，并非即是成佛之果。
    这个说法，虽然很合中观应成派的道理，但却与宁玛派的“大圆满见”相违。因此格鲁派便亦不承认有“大圆满”这个修习的次第，只承认有生起次第和圆满次第，不许更有向上的安立。
    宁玛派的说法，继承了印度晚期诸师的旧说，将“如来藏”思想称为“大中观”，亦即“大圆满见”，由是建立大圆满次第。格鲁派的新说，显然亦动摇了宁玛派的基础。

    宁玛派说“如来藏”

    格鲁派为什么不去破宁玛派的“如来藏”呢？原来宁玛派的“如来藏”学说，跟觉曩派有所不同。
    宁玛派并不认为“如来藏”是一件事物，亦不是一种精神本体。他只认为，人的心识有两种功能，当其起清净的功能时，便称其为“如来藏”；当其起无明的功能时，便称之为“藏识”（阿赖耶识）。人常受无明污染，故心识所显无非是那称之为“藏识”的功能。若能将无明烦恼转化为清净，心识的清净功能便起，是则称之为“如来藏”。
    这有如一个人，当他用心思去开保险箱偷东西时，名之为“贼”（起做贼的功能），但当他回到家中，所有的心思都变成对妻子儿女的体贴，这时便名之为“好丈夫”（起做好丈夫的功能）。所以这个人的本体虽空，但做贼与做好丈夫的功能却不空。
    众生亦一样，倘如能通过修习，顿时只起心识的清净功能，那便可以成佛；而一般人则重重作业，重重无明污染，是故心识所起的功能，便是轮回六道的阿赖耶识。
    宁玛派“如来藏”之说，原来如此，只可惜很少人理解，甚至许多宁玛派的人亦不解此，老是将“如来藏”当成本体，结果就得出错误的结论。

    六年心血一席话

    前所介绍的宁玛派说“如来藏”，看起来简单，可是这简单的理解，却花费了笔者近六年的心血。
    这六年。笔者住在夏威夷岛的山谷，读古代的佛家经论、读时贤的论述、读外文译著，一边读，一边修密法，并且用不同层次的密法，去配合不同层次的理论（见地），是故读过一堆书后便去闭关，然后才领悟到敦珠宁波车所传宁玛派的“如来藏”义理。同时悟到，一切宗见，实在是该宗派祖师实修时的体验，由于每位祖师的根器不同，是故所悟的境界便有差别。所以，我们不能说这宗对，那宗错，只能说，在层次上，这宗比较接近绝对的真理；那宗则比较远离。是即所谓“次第”。
    藏地宁玛派秉承印度诸师旧说，建立“九乘次第”，又建立“四宗五见”，并且将四部密续与之作配合，这样做，并非机械的建立，而是印藏诸师在修行道上确有所见，并依其所见的境界作配合。当然，凡配合必有点机械，但若违貌取神，便应该承认其配合合理。
    笔者过去不喜欢“唯识”，认为繁琐，自从悟出实修境界即是见地之后，对它便再也不敢轻视，于是从头再学。后来忽地将“如来藏”跟“唯识”融合起来思索，再看宁玛派“大圆满”系列中英文著作，然后始悟出其见地如是。
    世事往往很奇怪，当未得窍时，看一本书，处处都是疑问，一旦得窍，看同一本书，便觉句句可解。
    宁玛派说“如来藏”是用（功能）而非体（本质），只是一个很简单的概念。但未有这概念前，读一切有关“如来藏”的经论，都模模糊糊，总以为凡说“如来藏”，必指其为一事物，是故应追究其本体到底是空抑或非空，可是一旦得窍，则读经论时，每句话便都觉得它其实是说“如来藏”之用。
    在这里，笔者不想举例，一举例便要举出一大堆经论，殊非撰写本篇的意趣，但却想说明一下：为什么许多谈“如来藏”的祖师，不简简单单介绍这个概念呢？
    要回答这个问题，便要跟实修联系了。
    当我们心中存有一个见地，认为一切现象与境界都属实有，于修法观想时，便会出现一个“实有境界”；但当我们于修法时，心念一转，认为一切境界现象无非都是心识所变，这时，那个“实有境界”立刻便随心念之转而转，想恢复原来观成的样子，已经无法办到。
    所以，若心中持有见地，认为“如来藏”非本体而只是功能，对修“如来藏”前行的人来说，可谓了无益处，徒然影响其修习。密乘祖师之隐约其词，实有必要。
    读者或许会问：既然祖师不说，为什么你却又说呢？这就是时代所需了。
    藏传中观之学流入汉土，是由于译师接近格鲁派，因此便多将宗喀巴大士师弟的论著介绍，同时又译出格鲁派所推崇的印度论师论著，多为中观应成派之说，中观学由是便在汉土发扬，一时称为显学，故与唯识家争衡。
    格鲁派许应成派之说为了义（究竟的道理），“如来藏”说为不了义（不究竟，只是权宜建立的道理），这个说法，影响了汉土的学者。但假如这见地成立，则宁玛派视为至高无上的“大圆满”法门，便无建立的依据，甚至汉土的禅宗亦无证悟的依据。
    再加上如今又出现了一种情形：显乘学者，居然有认为印度佛学只有唯识及中观两派，“如来藏”的学说则不成体系。这种见地，便比说之为不了义更坏。
    密乘行人呢？即以“大圆满”法系标榜者，对此法门却说不出道理，只说什么光脱脱、赤裸裸、本来清净之类，这些话头，实无法抵抗中观应成派理论的评破。
    为此，如今已到了要说破“大圆满见”的机遇。至其影响，实在亦可以抵消，于修行前行时，仍然把他当成是“自明本体”就可以了。所谓“自明”即是“法尔”，不假观修而成。

    禅宗即是“大圆满”

    《维摩诘经》说“如来种”，但非专说，是故读经的人便容易将注意力转移，注意到他的“不可思议解脱法门”。
    其实，这个法门即是“无住为本”，无住者，不生分别想，能不生分别，则烦恼、非法、邪见等皆是“如来种”，因为此时心识已不为所染，亦即心识不起污染的功能，而清净的功能便自然显露。由烦恼离烦恼，即是如此。“大圆满”所修习的，即是如此。若解之为圆陀陀、光脱脱，是尤落在分别的层次，并非“无住”。
    禅宗在六祖以前，用《入楞伽经》印心。此经所说，便亦是“如来藏”的思想。禅宗的修习同“大圆满”，只无其前行，由是可见，一修到这个阶段，便非以“如来藏”作为见地不可。
    试举一宗禅宗公案为例──
    尼到赵州问密密意。赵州伸手便探其穴。尼曰：“和尚还有这个！”赵州曰：“某无这个，汝却有这个。”
    “有这个”，便非“无住”。故赵州禅师之言，等于说：“我无分别，你却有分别。”这便是禅家的“密密意”。赵州说有说无，非说本体有无，只是说心识说起的净染功能。

    婆子烧庵的故事

    禅宗还有一件故事──
    一个婆子建庵供养一个禅和，经二十年，令二八女子送饭给伺。一日，令女子抱著禅和问道：“正当恁么时，如何？”那禅和答道：“枯木倚寒岩，三春无暖气。”
    女子将禅和的话头说给婆子知，婆子怒道：“我二十年只养得个俗汉。”于是将禅和逐出，放火烧庵。
    看起来，这禅和精严戒律，似无不对，婆子却为什么发怒呢？原来禅和所修的只是枯禅。枯禅也者，即与日常生活严格脱离，自己的心识是与尘世漠不相关的境地，这样的禅，似乎清净，实际上却未经考验，有如小孩子一出生便用氧气罩罩起来，跟细菌绝，但我们却绝对不认为这孩子健康。
    开悟的心──或者说“大圆满”的心，是经过考验、百毒不侵的心，这样的清净，才是真正的清净。禅宗谓之“大死一场”。宁玛派祖师传下许多歌，称为“金刚歌”，其中所咏唱的，大抵类乎汉土禅宗的语录。印度的佛门之花，开在汉藏不同的土地上，用不同的养料滋养，结出来的果实却绝无分别。
    所以要了解“大圆满”的在烦恼中修离烦恼，应该先了解这个婆子烧庵的故事。“三春无暖气”，恰恰便是分别执著的烦恼。


介绍噶玛恰美关于行人根器的观点

    爱莲:
    出离心/往生心是一个问题的不同说法。可是有些人就想在这个世界快乐完，然后再去极乐世界，怎么办。

    zf:

    有资格选择这条路的前提是该人有十足把握去极乐。

    关于行人的根器，介绍一种观点。（请RJ帮忙翻译一下。）

    噶玛恰美Karma Chagmey在其著作《大手印和大圆满的融合》（The Union of Mahamudra and Dzongchen）有如下开示：
    Emaho！
    In these times，when there are many who teach the oral instructions，There are many people who have some partial knowledge。
    But the appearances of this life are beguiling and enticing，And，because of not taking the thought of impermanence and death to heart，There are many whose knowledge remains as mere theory。
    Although they receive many instructions，they are stubborn and insensitive。
    Without shying away from wrong-doing，their actions are like a mere commoner。

    Those who receive the teachings only criticize the faults of others。
    This is because they lack revulsion，the foot of meditation。
    If you know the path but do not traverse it，
    It is like having no chance to visit Jowo Temple。

    In this respect，people have higher，medium，and lower capacities。
    The person of the highest capacity does not need to renounce worldly actions，But can practice while mixing mundane actions with the practice。
    This partaking of sense pleasures as the path，without abandoning them，Is the example of King Indrabodhi。

    The person of medium capacity abandons most worldly actions。
    He practices while keeping the behavior of a monk。
    Trying to acquire food，drink， and clothing　Is the life-style of most learned and accomplished masters of India and Tibet。

    The person of lowest capacity cannot fulfill his aims while keeping two frames of mind。
    He is unable to engage in both Dharmic and mundane pursuits　And practices，having cast away concerns for the food and clothing of this life。
    This is the life-style of such masters as Milarepa and Gotsangpa。

    rj：
    噶玛恰美Karma Chagmey在其著作《大手印和大圆满的融合》（The Union of Mahamudra and Dzongchen）有如下开示：
    唉玛火！
    如今，当提起口耳相传的时候，很多学人其实对之仅仅具备片面的见解。
    由于生活的表现是欺诈和诱惑，并且也由于学人并没有把观死与无常时时放在心上，这样那些口耳相传在他们那里就变成了仅仅是理论上的东西。

    尽管他们接受了很多口耳相传，但他们还是很固执和愚钝。对所做的事一点不会感到羞愧，其行为和不修行的人没什么两样。
    那些接受了指导的人仅仅批评他人的错误，这是由于他们缺乏自我反思──入三摩地的工具。
    如果你知道方法但不实际去做，似乎并没有能进步的可能。

    基本上，人们可分为利根，中根，钝根三类。

    利根的人不需要断绝和世俗的瓜葛，相反他们能把世俗事务和修行很好地协调起来。
    这种参与的快乐感觉可以作为修行的道路，而非舍弃快乐。这样例子有Indrabodhi国王。

    中根的修行者舍弃世俗中的大部分活动，他的行为需要和出家人一样。
    不论是在西藏还是印度，（一边修行一边）努力去获得饮食、衣物是大多数学过并且熟练掌握修行原理的行者的生活方式。

    钝根的人若同时生活在两种人生框架下并不能实现其目标。以其能力，他不可能修行和世俗生活二者兼得。
    在其此生的实际生活中，他不关心饮食、衣物。此类生活方式的行者有密勒日巴（尊者）和 Gotsangpa。

    zf:
    上述观点与我们常见者迥然不同，特别是将米拉日巴归为“下等能力者”，恐难为众人理解。然而噶玛恰美祖师乃噶举传承之成就卓越者，他的这一划分绝对不会是哗众取宠之举。
    在下猜测，噶玛恰美祖师的用意可能是提醒众人，即使如米拉尊者这样“下等能力者”，只要时刻taking the thought of impermanence and death to heart，精进苦修，其成就照样可以超过“中等能力者”而独步古今。
    在下介绍此标准的用意是：从“理论”上说，并且历史上确有此种“上等能力者”，可以practicing while mixing mundane actions with the practice，partaking of sense pleasures as the path without abandoning them。只不过欲尝试此种修行者，应认真掂量一下自己的本事──孔雀吃剧毒而越发美丽，您敢与孔雀共餐吗？

    zf：
    记得因陀罗菩提王（King Indrabodhi）得道情形大概如下：
    王请释迦牟尼佛传授一个不需要放弃世间生活就可成佛的修行方法，如来说：你就是佛。王当下信受承当，大事了毕（颇有禅宗立地成佛的色彩）。

    另外，诺那祖师开示录中记载：
    问：现在一般人世务憧憧，修法之时甚少，不知有无最简单而且最大之修持法？
    答：密宗最简单最大之修持法，汝就是本尊，本尊就是汝。汝之身口意就是本尊之身口意；汝之居处或办公室，就是本尊之庄严佛殿；汝之父母妻子及一切所见之众生，均是本尊之身体；汝耳所闻一切声音，均是本尊之法语；汝心所想及一切众生之心念，均是本尊之心念；一切地水火风空，无一不是本尊之功德；汝所住之世界就是佛土。常如此想，就是无上密宗成佛之大法，久而久之，自能打成一片，到一心不乱境界。最要紧是汝自心信得过汝就是本尊，本尊就是汝，汝与本尊无二无别。
    问：如此简单修持，其功德是否与清净修持时之功德相等？
    答：功德一样，密宗行人，最要紧是发大菩提心，并且信得过我就是本尊，此为密宗根本之道理，如能深信不疑，我就是本尊，本尊就是我，则所说之话，所食之物，所穿之衣，甚或打人骂人都是功德，譬如蜜蜂采花成蜜，而不伤花之道理一样。

    可见，修持无上法的关键是信心。


不要以为传法一定是念仪轨

    白云深：
    请问一个问题，如果我去见了一个伟大的上师，请求上师收我做弟子，上师很高兴同意了，听旁边的师傅说上师让我去念一个咒子，这个咒子我以前就知道怎么念。今天又做了四皈依。
    问题是，这个咒子虽然以前我都会念，但是由于语言翻译问题，我都不知道师傅亲口对我念了这个咒没有。如果没有亲口念，而是让我去念，这算是传了法和得了传承吗？如果像上面所说那样，这个上师他应该算我哪种上师呢？我们之间有三昧耶戒关系吗？
    ──说明：由于现在我因某些原因不方便再去打搅上师（我已经去过3次了），所以特上来向大家请教。谢谢诸位善知识！更正一下，我打电话问上师旁边的师傅，师傅说在念四皈依时是念了咒的。

    林居士：
    起码是归依师……不论当时有没有口传那个咒，上师都是对你作了个别的修行指示（就你的描述，我理解是这样），那也算是传法了。不要以为传法一定要把一种密法仪轨法本念给你才算，通常是比较亲近的上师才会对个别弟子作出因应其情况的特别教示。有时候可能是叫你思维共加行或菩提心，也可能是专念某个经文或咒，或某一仪轨等。若对方为已成就的具德上师，全心全意依这样的特别教导是条最殊胜的路。看密勒日巴祖师初依马尔巴祖师时也不是在修仪轨或打坐的，只是长时间在建房子，吃苦头。可惜现世人多不重视这类最宝贵的教授，只最喜欢上师传仪轨法本，教打坐……
    从这角度看，当然是有师徒誓句的关系，而且还不浅。


关于没有身边老师想学如法普传的密法的讨论

    关于没有身边老师想学如法普传的密法的讨论

    zf

    “身边没有老师（老师远或者老师已往生，未传下上师位）。那如果打坐中有疑问，该如何？”
    ──向德高望重的同门金刚兄弟请教。
    “难道普传密法不能学么？”
    ──能。将密法如法普传者都是大成就者，而且只要行人发心正确，这些修法都不易出偏差。
    在藏地持颂六字大明咒和度母心咒，在汉地受持大悲、楞严、准提、往生等真言已成惯例，为历代大成就者所认可，仁兄不必多虑。


过去诸佛全身舍利都在宝箧印陀罗尼中

    志在解脱:
    我有一朋友供养一大德真身舍利一年，长大了近一倍。这颗舍利是蓝色的，我想请教大家舍利不同的颜色代表什么？有啥说法吗？我有一颗是黑色的，呵呵。有师兄解答一下吗？先谢了。

    zf:
    舍利可分为两种：
    一、法身舍利
    大智度论云：经卷是法身舍利。谓如来所说中道实相之理，不迁不变，无灭无生，亘古今而恒存，弥天地而普覆。人能至心如法受持，即是得见如来法身，其所获福无量无边。故法华经云：若经卷所住之处，皆应起塔供养，不须复安舍利，此中已有如来全身。
    马胜比丘对舍利弗所说之诸法缘起颂：“诸法从缘起，如来说是因；彼法因缘尽，是大沙门说。”乃说四谛中苦、集、灭三谛之偈颂，或称缘生偈、缘起偈。以阐明法身之不生不灭，故称法身偈，又称为法身舍利偈。
    《一切如来心秘密全身舍利宝箧印陀罗尼经》中说，过去诸佛全身舍利都在宝箧印陀罗尼中。若塔中供养宝箧印陀罗尼，就等于供养过去诸佛全身舍利。

    二、骨舍利、发舍利、肉舍利
    《法苑珠林》谓骨舍利为白色，发舍利为黑色，肉舍利是赤色。
    实际上，生身舍利的颜色不仅这三种。多年前，在下一位好友之老母去世，遗体烧出很多舍利。老人生前念经、念佛、持咒（密法之传承来自宁玛昂藏寺朱巴活佛），临终时又得儿女和善友助念。老人的舍利中除白黑红三色外，给在下印象最深的是，有数粒大米般大小的透明的金色舍利。

    至于舍利颜色与行人证量之间的关系怎样，在下不知。


云何显现本有三种佛性

    凡夫:
    请教，《 一切如来心秘密全身舍利宝箧印陀罗尼经》云：“显现本有三种佛性。毕竟安处大涅槃中。”此中，本有三种佛性，是指什么？
    印象中，是指大悲、自性和菩提心，──但，这三者到底为何被明确互相区别开？
    此贴打了一个哑谜，呵呵，请赵叔开解。:)

    zf:
    此经中“三种佛性”究竟何指，未见古德论及，在下也曾经疑惑过。
    与“三种佛性”相近的术语是“三因佛性”或“三佛性”，对此古德多有论述（可见下面的名词解释）。
    如果以“三因佛性”来理解“三种佛性”，则“显现本有三种佛性”便是显现本具之法身德、般若德和解脱德，即一切如来智慧德相。我感觉这样解释还算通顺。
    如果以“三因佛性”来解释自性、菩提心和大悲：
    自性──正因佛性；
    菩提心──了因佛性；
    大悲──缘因佛性。

    不知此一关联是否有助于仁兄理解这三者在作用上的差别。

    【三因佛性】
    （名数）涅槃经所说：一、正因佛性，离一切邪非之中正真如也。依之成就法身之果德，故名正因佛性。二、了因佛性，照了真如之理之智慧也，依之成就般若之果德，故名了因佛性。三、缘因佛性，缘助了因，开发正因之一切善根功德也。依之成就解脱之德，故名缘因佛性，金光明玄义曰：‘云何三佛性？佛名为觉，性名不改，不改即是非常非无常，如土内金藏，天魔外道不能坏，名正因佛性。了因佛性者，觉智非常非无常，智与理相应，如人能知金藏，此智不可破坏，名了因佛性。缘因佛性者，一切非常非无常功德善根资助觉智开显正性，如耘除草秽掘出金藏，名缘因佛性。’同记上曰：‘正谓中正，了谓照了，缘谓助缘。缘资了，了显正，正起胜缘。亦是正发于了，了导于缘，缘严于正。正起胜缘，相由既然非横义也，一心顿具非纵义也，此妙因能克妙果，俱名因者其义在玆。’此三佛性，又为空假中之三谛。因为空谛，缘因为假谛，正因为中谛也。辅行二曰：‘三千即空性了因也，三千即假性缘因也，三千即中性正因也。’
    FROM:【丁福保《佛学大辞典》】


一样不一样？

    我：
    言若是实相，一切言应皆为实相，何偏只咒为实相？如此念什么不都一样吗？末学以为关键在心，而非“念”也。心若诚，有应无应皆诚，心若疑，有应喜无应而疑，黏着取舍，何以诚心正意，止观中道？心若诚管用不管用又有什么关系，若不诚管用不管用都不会踏实的。呵呵──！

    哈哈：
    一样不一样……“何以故？言若是实相，一切言应皆为实相，何偏只咒为实相？如此念什么不都一样吗？”
    ──真的一样吗，念杀盗淫能与念戒定慧一样？天界与地狱一样？
    真能一样为什么佛不叫众生都去下面混混？修到维摩诘大菩萨的程度再说一样也不晚吗。
    咒音上有诸佛菩萨的愿力，与念别的在因缘法上就是有所不一样。


关于破瓦法

    关于破瓦法

    二麻子

    破瓦真说起来，有法身破瓦，报身破瓦和化身破瓦。
    中阴成就也有法身成就，报身成就与化身成就。挺复杂的。还是自己看吧。
    只一点要说清。不考究各种因缘影响，能不能用起来。如果能用的话，破瓦法是用在生理上尚未临终的，在时机上比中阴法早。高僧给人超度时，也有用破瓦法代替一般的中阴救度法的。用上了破瓦的人，不需要再用中阴救度。
    密法里这个死相问题是很要紧的事，有专门的讲述。从三年讲到数日。
    但是，用现在的技术程度来看，这些相未必很准确。不知道本家思考过这个问题没有。麻子也没什么成形的想法，只觉得这问题值得考虑。


若如阿弥陀佛般忆想一切众生

    nkdj：
    哎呀，好久没看见智行兄了……
    甚思念

    智行：
    他是个生死凡夫，想他就不免轮回。要想佛，呵呵。问师兄好。

    二麻子：
    哈哈。若如阿弥陀佛般忆想一切众生包括智行，则又如何？

    kzh：
    麻叔透露了点生起次第观修的消息嘛。嘻嘻。这需要依止真正的具德上师长时修学。


金刚手菩萨手中的金刚杵有多重？

    zf：
    金刚手菩萨，汉语系经典大多视其与普贤菩萨同体异名。藏传宁玛巴中亦有认为其与大势至同体者。

    佛说如来不思议秘密大乘经
    阿阇世王问答品

    尔时阿阇世王。即起是念。此金刚手菩萨大秘密主。右手所持大金刚杵几何轻重。而秘密主。有大力势能善执持。
    时金刚手菩萨大秘密主知其所念。即告阿阇世王言。大王。当知此金刚杵亦轻亦重。王言。以何缘故亦轻亦重。金刚手言。为欲调伏憍慢贡高诸众生故。此杵即重。为示无慢正直诸众生故。此杵即轻。
    时金刚手菩萨。即以所持大金刚杵置之于地。当置地时以神力故。三千大千世界六种振动。即告阿阇世王言。大王。汝今宜应以此地中大金刚杵而自举之。时阿阇世王。即时以自坚固勇力。欲举其杵竭其力势。不能动摇一毛端量。即生希有尊重之心。前诣佛所。合掌白佛言。世尊。我昔曾于战阵之所。取被甲大象。一手执持举掷于远。此金刚杵其量微小。我今竭自力势不能动摇。况复举邪。以何缘故其事如是。佛言大王。无自恼心。此金刚杵至极重故。
    时阿阇世王。即白帝释天主言。憍尸迦。今宜举此地中所置大金刚杵。时帝释天主。即时以自勇猛神力欲举其杵。尽竭其力不能动摇。即生希有尊重之心。前诣佛所而白佛言。世尊。我若与彼阿修罗王。斗战之时我力坚胜勇锐无敌。右手取彼毗摩质多罗阿修罗王所有大车。量广七百由旬。我时执持如迅风行。此金刚杵竭自势力不能动摇。岂非世尊广大威神所制止邪。佛言。憍尸迦。此亦非我神力所制。但为彼金刚杵至极重故。憍尸迦。于汝意云何。须弥山王至极重邪。天主白佛言。须弥山王至极重大喻所不及。佛言天主。此金刚杵金刚所成。重复过彼须弥山王。而金刚手菩萨。能以此杵掷碎轮围诸山。犹如糠秕。以其金刚大力势故。
    尔时帝释天主。即白尊者大目干连言。佛说尊者于声闻众中神通第一。愿今尊者。举此地中大金刚杵。尊者大目干连即自思念。我若于此人天大众之前。不能举动此金刚杵。岂非于我生慢心邪。作是念已运自神力。方欲前举彼金刚杵。即时三千大千世界六种振动。海水腾涌大地普皆怖畏振击。唯金刚杵不动不摇。是时尊者大目干连。前诣佛所顶礼佛足。作是白言。佛说我于声闻众中神通第一。具大威神名称力势。能以四大海水置于掌中。亦能转此三千大千世界。犹如有人以一金钱转于指端。又能空中止其日月。制彼威光不令转动。又能取彼须弥山王掷过梵世。又能调伏难陀乌波难陀二大龙王。又能于彼阳焰世界周行乞食。此金刚杵其量微小。然我亦复不能动摇。世尊。岂非我今神力减邪。佛言。大目干连。非汝神力有所减少。但为菩萨威力加持。一切声闻缘觉悉不能动。况余众生。又目干连。假使殑伽沙数诸佛刹中所有须弥山王悉能振动。唯金刚杵随置地方不能动摇。目干连白佛言。世尊。金刚手菩萨具大力势。而能戏掷此金刚杵。诚哉希有。佛言。大目干连。假使三千大千世界诸须弥山。尚能合入一须弥山悉能动摇。此金刚杵而不能动。
    尔时尊者大目干连生希有心。前白佛言。希有世尊。此金刚手菩萨大秘密主具大力势。善能持彼大金刚杵。此秘密主。为即父母所生力邪。为神力邪。佛言。大目干连。父母所生之力。随所入处皆有分量。而诸菩萨神通力者无尽无限。我若开示使天人世间咸生迷惑。
    尔时世尊。普遍观察诸众会已。告金刚手菩萨大秘密主言。汝今宜应自当举其地中所置大金刚杵。
    时金刚手菩萨大秘密主神力振动三千大千世界已。即以左手举取其杵。戏掷空中旋绕七匝。杵旋空已。即时接置安右手中。一切众会生希有心。合掌顶礼大秘密主。咸作是言。希有秘密主。能具如是广大力势。善持最胜大金刚杵。普愿一切众生皆悉获得如是胜力。
    时阿阇世王复白佛言。世尊。菩萨具修几法。即能获得如是胜力。佛言大王。菩萨若修十法获斯胜力。何等为十。一者。菩萨宁舍身命。终不弃舍无上正法。二者于一切众生。作谦下想不增慢心。三者于彼劣弱众生。起愍念心不生损害。四者见饥渴众生施妙饮食。五者见怖畏众生施其无畏。六者见疾病众生施药救疗。七者见贫乏众生惠令满足。八者见佛塔庙形像涂饰圆净。九者出欢喜言安慰众生。十者见彼负重疲困苦恼众生为除重担。菩萨若具如是十法。即能获得如是最胜之力。


关于十三地之说

    阿正：
    请问，后学读《智敏、慧华上师开示录》受益很多，但有一个问题不懂故想请教赵叔和麻叔，原文如下：第二篇“心法要义——修证位次”中的开示：问荼毗时出现彩虹，是何道理？师曰：乃是汇归法性之意义。舍报后往生有三种：最胜者可汇归法性常寂光土，为十一地至十三地之境界。
    一般佛经都说金刚十地、等觉(十一地)、妙觉(十地二)，不知智敏、慧华两位上师所指“十三地”是从教相上指什么？

    二麻子：
    不光有十三地之说呢，这里十三地指成佛正等正觉，密教里有些地方划分得更仔细些，如果有一天看到阿达而妈佛的地数，你可能还会这样问呢。到底为什么这样分，似乎实在不是我们现在的修行所能够知道，或需要知道的。

    zf：
    根据祖师开示，十三地为无上正觉。这种划分的依据何在，在下不知。
    另，在【中华佛教百科全书】的【大乘要道密集】条目中提到“十三地”：
    …金刚句偈注云︰外缘起为回风转气，及景象、梦等外在境相粗略所现，内缘起为心气集摄于脉字宫殿，密缘起为断世间道而现出世间身脉等四坛城，真如缘起为初地以上之外，内、真如验相生现明点、气、心，究竟缘起为融入四行于十三地证果。


宝箧印陀罗尼塔，末法之后佛法的保存形式之一

    rj：
    如何制作宝箧印陀罗尼梵字真言塔？

    zf：
    “如何制作宝箧印陀罗尼梵字真言塔？”
    ──将梵字真言折叠、包装后放入塔中即可。

    玄兹：
    俺土八路有个信念，无论我们这个世界发生什么情况，佛法总会以某种形式保存下来。

    zf：
    随喜玄兄信念──佛法不灭！
    “俺土八路有个信念，无论我们这个世界发生什么情况，佛法总会以某种形式保存下来。”
    随喜玄兄这一信念！
    关于佛法住世的时间，最常见的说法是，佛陀入灭后正法五百年，像法一千年，然后是末法时期，此时期历经一万年后，佛法则灭尽。对佛法灭尽和重生时的情形，《佛说法灭尽经》中有如下预言：人寿命五十二岁时，首楞严经、般舟三昧先化灭去，十二部经寻后复灭，尽不复现，不见文字。如是之后数千万岁，弥勒当下世间作佛。天下泰平，毒气消除，雨润和适，五谷滋茂，树木长大，人长八丈，皆寿八万四千岁。众生得度不可称计。
    诸佛如来不舍一切众生。佛法灭后，世间不见十二部经之文字，但如来大悲恒久住世，以不思议之善巧方便继续利益有情。《一切如来心秘密全身舍利宝箧印陀罗尼经》中宣说，若塔中供养一切如来心秘密全身舍利宝箧印陀罗尼，则等同供养一切如来之身和一切如来全身舍利乃至八万四千法藏。如来灭后末法之时，众生习行非法应堕地狱，不信三宝不植善根，为是因缘佛法当隐。但安放宝箧印陀罗尼之塔在一切如来神力所加持下，虽朽坏如土堆，但依然坚固不灭。“若有有情能于此塔，一香一华礼拜供养，八十亿劫生死重罪一时消灭，生免灾殃死生佛家。若有应堕阿鼻地狱，若于此塔或一礼拜或一右绕，塞地狱门开菩提路。塔及形像所在之处，一切如来神力所护。其处不为暴风雷电霹雳所害，不为毒蛇蚖蝮毒虫毒兽所伤，不为师子狂象虎狼野干蜂虿之所伤害，亦无药叉罗刹部多那毗舍遮魑魅魍魉癫痫之怖，亦复不为一切寒热诸病、疬瘘痈疽、疮疣疥癞所染。若人暂见是塔能除一切灾难。其处亦无人马六畜童子童女疫疠之患，不为横死非命所夭，不为刀杖水火所伤，不为盗贼怨仇所侵，亦无饥馑贫乏之忧，厌魅咒咀不能得便。四大天王与诸眷属昼夜卫护，二十八部大药叉将、日月五星幢云彗星昼夜护持，一切龙王加其精气顺时降雨，一切诸天与忉利天三时下来亦为供养，一切诸仙三时来集赞咏旋绕礼谢瞻仰，释提桓因与诸天女昼夜三时来下供养。其处即为一切如来护念加持，由纳经故塔即如是”。
    由此可见，末法之后，虽佛经文字相尽，但佛法仍然住世，宝箧印陀罗尼塔就是玄兄所说的佛法保存形式之一。
    修建安放宝箧印陀罗尼之塔对众生，特别是释迦牟尼佛法灭尽后、弥勒菩萨成佛前千万年间此世界的无量有情将具有巨大的利益。不知玄兄是否愿意在将来机缘成熟时一同修建宝箧印陀罗尼塔？


装藏与开光

    like：
    请教佛像装藏的问题，朋友请了一尊尼泊尔造的佛像，佛像站立在底座上。佛像的身体部分是实体（里面无法装东西），只有底座可以打开。请问是否可以把舍利装进底座？最好有经论或上师教言作为依据。

    林居士：
    平面佛像只有开光，没有装藏；立体佛像通常开光前要装藏，如佛像不是藏式的，本身没有预留空间（如部分汉式佛像或塑料的）就不能装藏，但也能开光。装藏有不同的方法，可能按修学传承、像体、和当时条件吧。有些比较讲究的做法需要像体中空至头部，以便放进代表中脉和刻有三金刚种子字的物件。一般常见是一些有特定表征的加持物。怎样装和装什么要由师傅按情况决定。
    开光必须由有证量的师傅来做，目的是迎请智慧尊与佛像融为一体而安住，真正开光后的佛像就应视为是佛的化身之一，当相应地看待处理。此中仪轨不一，若为大成就者在忙碌时甚至可以简至略为注意一下或吹口气或洒把米就可以了。
    其实法身遍一切处，化身随缘示现，只要有清净信心，纵未开光的佛像也可供奉，也会有加持。待将来有因缘时再请大德开光不迟。反之若供奉者心行不正、缺乏净信，纵开光后也难以感应道交，或同凡品；佛出世住世均依因缘法故。
    真能开光者要具证量，须能召请法界中的真正智慧尊之故，不过跟金刚上师的头衔却没有直接关系。


关于如何佩带真言护身符

    PAOMO:
    请问当如何佩带真言?我将从网络上下载的真言图片打印出,折叠放于一小布袋中挂在身上可否?

    齐愍:
    如果关于佩带的教示经典或者同一系列的经典没有具体开示，且有将此真言比喻成如来或者如来舍利者，我觉得可以参照佩带佛舍利的经文所指出的要点

    宝悉地成佛陀罗尼经(节录)
    特进试鸿胪卿大兴善寺沙门大广智不空奉　诏译
    “……
    善男子等汝等当知如来设利即是无上世间难有。诸菩萨等亦难值遇。何况世间诸凡夫类。此佛设利即是无相摩尼。即是真性如意宝珠。即是秘密大精进也。十方佛土所有庄严之宝。如意幢幡摩尼璎珞。珠帘玉床真珠天盖。七宝屏风众彩卧具。如是妙物等类。最胜珍宝不能为价。亦复无器得置。是故此经中说。用团圆之物。可置设利。如汝心形如佛心形。汝心佛心互相置故。汝体佛体相互融故。既相互融性即非二佛身。设利可如是持。亦可安置五轮塔中。亦可安置多宝塔中。亦可安置三股塔中。亦可安置五股塔中。亦可安置独股塔中。同前置物互融。不异证位平等若比丘比丘尼优婆塞优婆夷四部众等。得受持佛设利乃至一粒分散一分。常行恭敬常带者。此人所到之处。悉成金刚界大曼荼罗。所亲近一切之物。皆成四种法身之体。若近男近女若近牛若近马。若近狗若近猫。若近一切飞鸟禽走兽虫蛛畜生等有情类。悉令当生即入菩提初门。令得菩萨初位。
    ……
    若得佛设利者。不论净秽随身供养。不离臆胸诃栗多妙莲华间。常念佛德昼夜不息。现身证得佛清净身住金刚顶。是人名曰持佛身者持金刚者持宝法者。是大菩萨摩诃萨
    佛复告言。善男子等。假使世间若有愚童有情愚夫有情。愚惑有情老耄妇女愚痴僧尼。如是有情得佛设利乃至一粒分散一分。及与设利所置之物。带于身上不论昼夜。若净若不净。若触若不触。不离其身常可带之。所获功德无有所计比量。若顶上若颈上。若心前若背后。若两胁若腰闲带设利者。譬如世间犀牛之角。若人带之离水六尺。带设利者亦复如是。离一切罪业恶业恶趣不能染着。善根渐生恶障渐离。善人自遇恶人自去。所作事业皆同佛行。同释迦牟尼如来故。其身即是世间应化故。即是清净法身大毗卢遮那佛。其人必入大涅槃位。于现身中证得无相法身大精进峰。是故当知十二大天金刚天等。一切灵只常当守护。寿命延长见百秋已。命终决定上生都史多天宫闻法爱乐。更随志愿亦得往生十方净土。见佛闻法证不退地。
    ……”
    关于净秽问题, 此经中再三指出不论净污不则人等,我们通常所想的出于恭敬心的某些处理方式应该是合理的正常的, 但是就如法而言, 如来则即于行人如此佩带或教授佩带所基的根本见地, 提出了和想象中不同的要求。

    zf:

    为了防止纸张被雨水或汗水浸湿，可用薄塑料多层包裹，然后用塑料胶带密封，再放入小布袋中挂在胸前。
    我们的身体和外境为自心业力所感，而佩带真言就等于在自己的外境中引入如来的真身。
    外境的变化怎会不反过来改变我们的内心呢？！
    “如染香人身有香气。”


关于打印佩带护身符

    安虹：
    网上的电子版图片护身符，能不能打印出来，再放进包里佩带？

    zf：
    请进，如找经上师加持的佩解脱（上述式样）有困难，可以设法找到梵文或藏文的六字大明咒（网上好像就有，可以打印下来），作为佩解脱。六字大明咒人人都可以佩带，其佩带功德详如《大乘庄严宝王经》所述。


关于佩带六字大明咒

    关于佩带六字大明咒

    zf

    “一切”兄，“假如一个人生命垂危，求生净土也好，求学别法门也好，是求得来生学佛的尽可能更暇满，这时候该怎么办呢？”
    在下有个易行难信的方法。
    找到梵文、藏文或汉语的六字大明咒、六道金刚咒、大悲咒、楞严咒、佛顶尊胜陀罗尼、宝箧印陀罗尼、大宝楼阁陀罗尼等密咒，将其佩带在身上。
    佩带密咒有不可思议的解脱功德，这是一种省力而有效的修行方式，不幸的是常被人忽视。

    《大乘庄严宝王经》中开示：
     “若复有人以此六字大明陀罗尼。身中项上戴持者。善男子。若有得见是戴持之人。则同见于金刚之身。又如见于舍利窣堵波。又如见于如来。又如见于具一俱胝智慧者。”
    这分明是说，佩带六字大明咒者，其身即是金刚、即是舍利宝塔，其人即是如来。

    “若此戴持之人。以手触于余人之身。蒙所触者是人速得菩萨之位。若是戴持之人。见其男子女人童男童女。乃至异类诸有情身。如是得所见者。悉皆速得菩萨之位。如是之人。而永不受生老病死苦爱别离苦。而得不可思议相应念诵。”
    这说明，佩带六字大明咒，不但自利，而且可以于行住坐卧、言谈举止中利益众生。
    这种佩带密咒的修持方法在许多人看来近乎无稽，但在密典中却广为宣说。此方法在藏地得到了相当的重视，希望诸兄不要忽视。


《大宝广博楼阁善住秘密陀罗尼轮》功德及佩带供奉方法

    120ffhb：
    我有缘请到一些印有大宝广博楼阁善住秘密陀罗尼轮的黄布。请问这咒的作用及如何正确使用？？谢谢！

    齐愍：
    此咒功德及佩带供奉方法节略

    《大宝广博楼阁善住秘密陀罗尼经》唐　不空译
    “……
    彼一切有情类。由此陀罗尼威力。若读若诵受持。若佩身上若书衣中。若置幢上。若书经卷若书素叠及墙壁牌板。乃至闻声手触及影其身。及转触余人。决定当得不退转无上菩提。能于现世获无量百千功德。远离诸罪成就一切善根摧伏诸魔。于诸世间皆得敬爱。于一切处皆得供养。一切国王王子宰官后宫。并诸眷属皆得欢喜。一切沙门婆罗门亦皆欢喜。言音威肃人所乐闻。手脚柔软声相和雅。离于贫穷不受世间毒药刀杖水火等难。诸恶兽怖不能为害。无诸贼怖无劫盗怖。无旃陀罗怖无喃摩怖。行大小路悉皆无怖。无鬼神怖无罗刹比舍遮怖。无拏吉你怖无毒蛇怖。乃至一日二日三日四日。寒疟常疟一切疟病悉不著身。眼病耳病鼻病舌病。齿病唇病喉病项病。诸支分病手病背病腰病脐病痔病淋病。痢病瘘疮病髀病胫脚痛病。丁疮肿病瘰疬班病。肚痛疥病疱跛癞癣。无如是等病。无头痛不盲不瞎不伛。无横灾死。不聋不哑不被轻欺。如是等类现世不受。得无碍辩临命终时心不散动。一切诸佛现前安慰。亦不为厌祷蛊毒咒诅著。身卧安觉安。于其梦中见百千佛刹。及见诸佛并诸菩萨围绕。由此秘密陀罗尼威力故。获如是殊胜功德。”

    zf：
    120兄，真言的功德，齐兄已略说。
    关于如何使用：
    一、平时佩带。用塑料薄膜多层密封包好，以免雨水、汗水浸湿；然后装在小布袋中佩于胸前。
    二、临终使用。若有人在临终时才有缘得此法宝，也可为其佩带或放在衣服口袋里。过世后一直随身，并一同火化。另一种方式是，火化前将真言取出，待火化后将其和骨灰放在一起。
    三、若有人生前无缘见此法宝，其亲属和朋友可将法宝放入其骨灰盒中或上面。若采用土葬，也可将法宝包好后放在其坟上，并用土覆盖。
    与佛法无大因缘者，无缘遇此法宝。

    少言寡语：
    请问这是不是也叫配带解脱？

    zf：
    正是！


《般若心经》的功德

    《般若心经》的功德

    zf

    《般若心经》篇幅虽小，却浓缩了整个般若类经典的精华，受持读诵此经功德无量无边。《大唐大慈恩寺三藏法师传》中介绍：玄奘大师在四川时曾遇一病人，身疮臭秽衣服破污。大师怜悯此人，施与衣服饮食，病者乃授大师《般若心经》。大师取经途中，经过一八百余里之荒漠，逢诸恶鬼奇状异类绕人前后，虽念观音不能令去。大师便持诵《般若心经》，诸恶鬼等闻声皆散。护持大师完成取经伟业者实乃《般若心经》之威神力也。义净法师所译《般若心经》后附之持诵功德文云：“此经破十恶、五逆、九十五种邪道。若欲供养十方诸佛，报十方诸佛恩，当诵‘观世音’、‘般若’百遍千遍无间，昼夜常诵此经，无愿不果”。
    心经后面真言的发音为：
    om，噶滴，噶滴，巴拉噶滴，巴拉萨（母）噶滴，部滴，斯哇哈。（注：萨（母）两字连读。）


准提咒拼音

    准提咒拼音

    zf

    准提咒的汉语拼音及现代汉语注音

    现根据《中华佛教百科全书》（电子版）和《汉梵、梵汉陀罗尼用语用句辞典》（作者Robert Heineman(德国)，台湾华宇出版社，1985年）两部著作对准提咒分别以汉语拼音和现代汉语进行了注音，其中汉语拼音的音调均为一声，同时对真言的句义进行了简要的说明。

    (1)南无飒哆喃
    梵文：namo-saptanam
    汉语拼音注音：na-mo-sa-da-nan
    现代汉语注音：拿摩萨达南
    注释：‘南无’意为‘归命’，‘飒哆喃’意为数字‘七’。

    （2）三藐三菩驮
    梵文：Samyaksambuddha
    汉语拼音注音：san-mia-san-bu-da
    现代汉语注音：三（米阿）三布达
    注释：‘米阿’两字连读成一个音节。
    ‘三藐三菩驮’意为‘佛’、‘无上觉者’。

    （3）俱胝南
    梵文：kotinam
    汉语拼音注音：gou-di-nan
    现代汉语注音：勾地南
    注释：‘俱胝南’意为‘无上’。
    ‘南无飒哆喃三藐三菩驮俱胝南’句意为‘皈命七俱胝佛母’。

    （4）怛侄他
    梵文：tadyata
    汉语拼音注音：da-d-ya-ta
    现代汉语注音：达得压他
    注释：此句意译为‘即说咒曰’。
    发音时注意，第二个音节‘得’（d）应轻声，一带而过。

    （5）唵
    梵文：om（或aum）
    现代汉语注音：奥母
    注释：此字皈敬意。“母”为鼻音

    (6) 折隶
    梵文： cale
    汉语拼音注音：zha-li
    现代汉语注音：扎隶
    注释：‘折隶’意为‘女行动者’，指准提佛母。

    (7) 主隶
    梵文：cule
    汉语拼音注音：zhu-li
    现代汉语注音：主隶
    注释：此字字意未查到。

    (8)准提
    梵文：cundhe
    汉语拼音注音：zhuan-di
    现代汉语注音：专滴
    注释：‘准提’意为‘清净’。

    (9)娑婆诃
    梵文：svaha
    汉语拼音注音： si-wa-ha
    现代汉语注音：司哇哈
    注释：此句意译为‘成就圆满’。


阿弥陀佛心咒

    以德服人：
    请教赵叔。阿弥陀佛心咒Om Ami Deva Ayu Siddhi Hum Hrih 怎么念？
    阿弥陀佛！谢谢。

    zf：
    供参考
    Om　奥母（母字鼻音）
    Ami　阿弥
    Deva　爹瓦
    Ayu　阿右
    Siddhi　悉地
    Hum　虎母（母字鼻音）（常被念成“轰”）
    Hrih　你试着将“哈利”两个字当一个字来念。在藏地此字常被念成如英文之“she”。


往生咒的注音

    zf：
    往生咒的汉语拼音及现代汉语注音
    现根据《中华佛教百科全书》（电子版）和《汉梵、梵汉陀罗尼用语用句辞典》（作者Robert Heineman（德国），台湾华宇出版社，1985年）两部著作对往生咒分别以汉语拼音和现代汉语进行注音，其中汉语拼音的音调均为一声，同时对真言的句义进行了简要的说明。

    （1）南无阿弥多婆夜
    梵文：namo－amitabhaya
    汉语拼音注音：na－mo－a－mi－da－ba－ya
    现代汉语注音：拿摩阿眯搭巴呀
    注释：此句意译为‘归命无量光佛”。
    无量光佛，梵名Amitabha，音译阿弥多婆、阿弥亸皤。此佛即是阿弥陀佛，梵名Amita－buddha，又作阿弥多佛、阿弭跢佛、阿弭亸佛。另有梵名Amitayus，音译阿弥多廋，意译无量寿。其最后音节（ya）为感叹词，相当于‘啊”。

    （2）哆他伽哆夜
    梵文：tathagataya
    汉语拼音注音：da－ta－ga－da－ya
    现代汉语注音：达塔嘎达呀
    注释：此句意译为“如来”。
    tathagata的其他译法还有怛他伽哆、怛他揭多、怛哆伽哆、答塔葛达等多种。

    （3）哆地夜哆
    梵文：tad－yatha
    汉语拼音注音：da－d－ya－ta
    现代汉语注音：达得压他
    注释：此句意译为“即说咒曰”。
    tad－yatha在密典中最常见的译法为怛姪他，亦有译为怛你也他。发音时注意，第二个音节‘得”（d）应轻声，一带而过。

    （4）阿弥利都、婆毗
    梵文：amrtod－bhave
    汉语拼音注音：　a－mi－li－dou－ba－wei
    现代汉语注音：阿弥利兜、巴威
    注释：此句意译为‘甘露主”。
    阿弥利都婆毗意为甘露的源泉，亦有译为阿蜜栗妬婆吠。

    （5）阿弥利哆、悉眈婆毗
    梵文：amrta－siddhambhave
    汉语拼音注音：　a－mi－li－da－xi－dan－ba－wei
    现代汉语注音：阿弥利达、悉眈巴威
    注释：此句意译为‘甘露成就者”。
    Amrta意为甘露，亦有译为阿蜜多、阿蜜利多、阿蜜栗多。Siddham意为成就。

    （6）阿弥利哆毗迦兰谛
    梵文：amrta－vikrmte
    汉语拼音注音：　a－mi－li－da－wei－ge－lan－di
    现代汉语注音：阿弥利达、威哥兰谛
    注释：此句意译为‘甘露播洒者”。

    （7）阿弥利哆、毗迦兰哆、伽弥腻
    梵文：amrta－vikrmta－gamine
    汉语拼音注音：　a－mi－li－da－wei－ge－lan－da－ga－mi－ni
    现代汉语注音：阿弥利达、威哥兰达、嘎弥尼
    注释：此句意译为‘甘露遍洒者”。

    （8）伽伽那、枳多、迦棣
    梵文：gagana－kirti－kare
    汉语拼音注音：　ga－ga－na－gei－di－ga－li
    现代汉语注音：嘎嘎那、给地、嘎利
    注释：此句意译为‘遍虚空宣扬（甘露）者”。
    Gagana意为虚空，其他译法为哦哦曩、誐誐那。
    Kirti意为名闻、名称，其他译法为吉底、计哩底。Kare意为造作、造作者。

    （9）娑婆诃
    梵文：svaha
    汉语拼音注音：　si－wa－ha
    现代汉语注音：司哇哈
    注释：此句意译为‘成就圆满”。

    几点说明：
     将本来以梵文记录的真言以汉语注音，就如同以“三克油”来为Thank you注音一样，实属无奈。语音与文字相比要难以保存得多，即使口耳传承不断，历经千年，真言的发音亦难保不走样。藏文直接脱胎于梵文，师徒相传至今，但据一位被公认为“西藏梵文第一”的活佛亲口对我说，西藏僧众受持的某些真言发音与梵文相比已有变化，个别地方的变化还相当大。但真言的发音在藏传佛教内并不是什么问题，因为上师依此真言成就，弟子只要照单全收就是了，这就是有传承的利益。
    但在汉地，情况就不同了。汉地僧众念诵的《禅门日颂》中有许多真言，其发音大多是直接依据汉字。这些真言绝大部分译于唐代，当时的密乘因有传承，故行者依汉字标注应能念出较准确的梵音。但不幸的是，密乘在汉地失传。明清以来的僧俗依汉字发音念诵真言，某些发音失真严重。汉地修持禅宗和净土宗的僧俗多辅以《楞严咒》、《大悲咒》、和《往生咒》等真言，虽没有严格按照密宗的方式灌顶传授，发音也不够准确，但虔诚的受持者感应道交的事例屡见不鲜，可见持诵真言仍以虔敬心为第一要诀。
    对于汉地的修行者来说，在具备虔敬心的前提下，如果真言的发音较为准确，则效果应当更加明显。今日文化进步，学术发达，交流便利，使得以汉语拼音或现代汉语对教内常诵的真言重新注音成为可能。虽然按照现代汉语注音读出的真言与梵文专家念诵的真言相比仍有相当差距，但总要比我们直接念诵以古汉语注音的真言好很多。
    愿今日行者，既能利用现代学术成果，又能继承古人虔敬之心，精进修持，悉得往生。

    guokeytt：
    一个问题请教。我以前念的是汉语发音，小册子上标注的。与师兄注释的完全不同，但通过体会，好像也有功用。

    zf：
    G兄，您以前念诵往生咒，体会到功用是完全正常的。其原因一是虔敬心，二是发音虽差别较大，但总还是相似。
    试想念观世音菩萨名号完全是汉语意译，根本没有梵音，但其之灵验谁能否定！
    在我汉地佛弟子中，绝大部分没有密宗传承，或对密宗存有戒心而敬而远之。但相当一部分人并不排斥持咒，这就是往生咒、大悲咒等广为流通的原因。对于这部分持咒行者来说，真言发音若能准确些，实为锦上添花。但另一方面，对于普通行者来说，对真言发音准确性的追求亦应适可而止，原因是这个世界上可能根本就没有“准确”的标准，而且许多梵音我们汉人极难发出。梵文作为一种语言，今日世界上已无人在生活中继续使用，只有少数专家研究。

    智行：
    谢ZF善知识，此咒音与后学所念几乎全同，只有一处，Kirti Kare Svaha，后学所见是Kirta Kare Svaha，不知何者为正。

    zf：
    智行兄；关于Kirti－kare　和Kirta－kare，我手上两部独立著作中均为Kirti－kare，应该较为可靠。希望兄也能追究该种拼写的来源，以排除打印或印刷错误的可能。
    在《汉梵、梵汉陀罗尼用语用句辞典》中，Kirti－kare旧译为吉底迦隶、计哩底羯哩。该辞典中未有Kirta－kare。
    Kirti一词为梵文中较常用的词汇，意为‘名称”。维摩诘大士梵文名为Vimalakirti，其中vimala意为‘清净无垢”，所以大士的名字还被译为‘无垢称”，即‘清净无垢的名称”。法称大师（Dharmakirti）、月称大师（Chandrakirti）名字中的‘称”字都是因kirti而得。宗喀巴大师名为‘罗桑扎巴”意为‘善慧名称”，若译为梵文便是Sumatikirti。（‘善慧”二字的梵文是Sumati，发音为‘苏麻底”！））
    联系到该句真言的意思为“将佛法的名称传遍虚空一切处”，因此本人认为此处Kirti－kare应是正确的。

    cw：
    哪儿可买到此《汉梵、梵汉陀罗尼用语用句辞典》，请告知，非常感谢！

    zf：
    此书台湾出版，大陆恐怕买不到。北京图书馆旧馆（北海文津街）敦煌阅览室有此书。我于数年前将此书复印下来。


楞严咒心注音

    guokeytt:

    楞严咒心是那一段？您能注上梵音吗？还望师兄慈悲。

    zf:

    楞严咒心为：
    跢侄他　唵　阿那隶　毗舍提　鞞啰　跋阇啰　陀唎　槃陀槃陀你　跋阇啰谤尼泮　虎（合牛）　都嚧瓮泮　娑婆诃
    咒心的梵音及字意待我仔细整理后一并给出，请等一等。
    另，唐密、东密和藏密均有“大佛顶”修法，其真言俱为咒心。
    此真言为和我汉地佛子最有缘的几个真言之一，为一切如来之父母（“此……章句出生十方一切诸佛”）、一切如来之根本法轮（“十方如来含此咒心于微尘国转大法轮”），功德广大，无量无边。今人有幸遇此真言者，万望加倍珍惜，视为如意宝珠。
    本人上述建议所针对者，均为以禅、净修行为主兼持密咒者。而以密法修行为主者，则一切应听上师教诲。特此说明。

    楞严咒心注音

    现根据《汉梵、梵汉陀罗尼用语用句辞典》（作者Robert Heineman（德国），台湾华宇出版社，1985年）、不空三藏所译《楞严咒》及章嘉国师（清）《大藏全咒》等著作对楞严咒心分别以汉语拼音和现代汉语进行注音，其中汉语拼音的音调均为一声，同时对真言的字义进行简要说明。
    （1）跢侄他
    梵文：tad－yatha
    汉语拼音注音：da－d－ya－ta
    现代汉语注音：达得压他
    注释：此字意译为‘即说咒曰’。
    发音时注意，第二个音节‘得’（d）应轻声，一带而过。
    （2）唵
    梵文：om（或aum）
    现代汉语注音：奥母
    注释：此字皈敬意。“母”为鼻音。
    （3）阿那隶
    梵文：anale
    汉语拼音注音：a－na－li
    现代汉语注音：阿那隶
    注释：字意为“无上”，表竖高义。
    （4）毗舍提
    梵文：visada
    汉语拼音注音：wei－sa－da
    现代汉语注音：微萨达
    注释：字意为“遍一切自在”，表横遍义。
    （5）鞞啰
    梵文：vaira
    汉语拼音注音：wei－la
    现代汉语注音：微啦
    注释：字意为“遍一切处”，表毗卢佛部。
    （6）跋阇啰
    梵文：vajra
    汉语拼音注音：ba－zi－la
    现代汉语注音：巴资啦
    注释：字意为“金刚”，表金刚部。‘资啦’两音节应连读。Vajra一字由藏文译汉时常译为“别杂”或“班扎”。
    （7）陀唎
    梵文：dhare
    汉语拼音注音：da－li
    现代汉语注音：达唎
    注释：字意为“法、总持”，表密教法部。
    （8）槃陀、槃陀你
    梵文：bandha、bandhani
    汉语拼音注音：ban－da、ban－da－ni
    现代汉语注音：班达、班达你
    注释：字意为“结界”，表遮一切恶，显一切善。
    （9）跋阇啰谤尼
    梵文：vajra－pani
    汉语拼音注音：ba－zi－la－bo－ni
    现代汉语注音：巴资啦波尼
    注释：字意为“金刚手”，即金刚手菩萨。
    （10）泮
    梵文：phat
    汉语拼音注音：pa－te
    现代汉语注音：怕特
    注释：字意为开通义。“特”字发轻音，占半音节。由藏文译汉时，常译为“呸”。
    （11）虎（合牛）
    梵文：hum
    汉语拼音注音：hu－mu
    现代汉语注音：虎母
    注释：此字为菩提心义。“母”为鼻音。Hum最常见的译法为“吽”，发“轰”音。
    （12）都嚧瓮
    梵文：？？？
    汉语拼音注音：du－lu－mu
    现代汉语注音：都鲁母
    注释：此字梵文难以确定，估计可能为dhrum。章嘉国师之《大藏全咒》中，依藏文将此字译为“达噜乌嘛”四字之连读，其中“嘛”即为“母（鼻音）”。可以确定的是，原文“都嚧瓮”中之“瓮”一定读“母（鼻音）”，因此此处译为“都鲁母”三字连读。
    （13）泮
    见（10）。
    （14）娑婆诃
    梵文：svaha
    汉语拼音注音：　si－wa－ha
    现代汉语注音：司哇哈
    注释：此句意译为‘成就圆满’。

    综上所述，楞严咒心之现代汉语注音为：
     达得压他，奥母，阿那隶，微萨达，微啦、巴资啦、达唎，班达、班达你，巴资啦波尼、怕特，虎母、都鲁母、怕特，司哇哈。

    祈愿：所有见闻者，悉发菩提心，尽此一报身，同生极乐国，见佛了生死，如佛度一切。

    提几点建议，供参考。
    一、大藏经中关于楞严咒主要有三个版本：（1）汉译《楞严经》中的真言（未见相应之梵文本）；（2）不空大师所译的楞严咒（保留有梵文本）（即你新发现的版本）；（3）由梵文译藏，再由藏译汉的版本。三个版本的真言虽然名字相同，但内容却不尽相同，即使是咒心部分亦不一致。
    二、若按密法的规矩，受持上述三个版本中任一真言，具应由上师传授。但在汉地，汉译《楞严经》中的真言已由先贤公开传授数百年，因此今人欲受持楞严咒，以受持此一版本的真言最为稳妥。
    三、若欲将汉译《楞严经》中楞严全咒的发音重新注音困难很大，因为未见相对应的梵本。依本人之浅见，修行者与其受持发音不是很准的全咒，不如集中精力受持发音较准的咒心。既然与此咒有大因缘，建议尽量将发音读准，以收事半功倍之效。
    持诵楞严咒者可分为两种：一者通篇全诵，二者专诵咒心。古德开示，持诵咒心的功德与持诵全咒功德相同。另外，您所依据版本的咒音与梵音差别较大。以咒心为例，唵不应读成“安”，而应读成“奥母（aum）”，“毗舍提”应发音“威萨达”，“槃陀”应读成“班达”，“虎（合牛）”不应读成“虎信”，而应读成“虎母（hum）”，即通常的“吽”等等。


楞严咒心和“五会心咒”

    huyg：
    有关楞严心咒，印象中楞严心咒如下：“都鲁雍瓦达，达迪雅他，翁，阿奴哩，毗舍提，皮拉，吧舍拉，托哩，盘陀盘陀尼，吧舍拉，旁尼畔，虎衅，都鲁，音畔，梭哈。”
    昨天有同修来找楞严心咒，说有五个咒。五方佛各一，以上是中央佛心咒。本人不甚了解故，向各位请教。谢谢！

    zf：
    这一说法至少汉语系大藏经中没有记载。章嘉国师编辑的藏汉密咒集中也没有相关说明。
    关于楞严心咒的汉译，
    一、“达迪雅他，翁，阿奴哩，毗舍提，皮拉，吧舍拉，托哩，盘陀盘陀尼，吧舍拉，旁尼畔，”不同人在注音上有差别，可以理解。
    二、“虎衅”，就是“吽”hum。
    三、“都鲁，音畔”应是“都鲁音，畔”。其中“都鲁母”（即此处的“都鲁音”）是“光聚佛顶”的种子字。
    汉地传统上，将“楞严咒心”前面的部分分为五会：一、毗卢真法会，二、释尊应化会，三、观音合同会，四、刚藏折摄会，五、文殊宏传会。从这个角度看，整篇楞严咒也可以称为“五会心咒”。


大悲咒之注音

    大悲咒之注音

    zf

    Namah ratnatrayaya
    拿摩拉大那达拉呀呀
    namo aryavalokitesvaraya
    拿莫 阿利呀瓦楼（哥一）地思瓦拉呀
    [注：（哥一）连读为一个音节。下面（**）中均连读。]
    bodhi-satvaya
    播地萨（多阿）呀
    mahasatvaya
    马哈萨（多阿）呀
    maha karunikaya
    马哈 嘎鲁你嘎呀
    om sarva rabhaye
    （奥母） 萨瓦 拉巴夜
    sudhanadasya
    苏达拿达夏
    namo skrtva I mom
    拿莫 思哥拉（多阿） 衣蒙
    aryavalokitesvaraya
    阿利呀瓦楼（哥一）地思瓦拉呀
    ramdhava
    拉（母）达瓦
    [注：（母）为鼻音。]
    namo narakindhi
    拿莫 拿拉（哥因）地
    heri maha vadhasame
    （喝一）利 马哈 瓦达萨密
    sarva athadu subhum
    萨瓦 阿达度 苏布
    ajeyam
    阿接羊
    sarva sata
    萨瓦 萨达
    namo vasta
    拿莫 瓦萨达
    namo vaga mavadudhu
    拿莫 瓦嘎 马瓦度度
    tadyatha
    达呀他
    om avalikelokate karate
    （奥母） 阿瓦利（哥一）楼嘎地 嘎拉地
    ehre
    衣和利
    mahabodhisatva
    马哈播地萨（多阿）
    sarva sarva
    萨瓦 萨瓦
    mala mala
    马拉 马拉
    mahe mahredayam
    马（喝一） 马（喝一）利达因
    kuru kuru karmam
    古鲁 古鲁 嘎曼
    dhuru dhuru
    度鲁 度鲁
    vajayate
    瓦加呀地
    mahavajayate
    马哈瓦加呀地
    dhara dhara
    达拉 达拉
    dhirini
    地利尼
    svaraya
    思瓦拉呀
    cala cala
    杂拉 杂拉
    mama vamara
    马马 瓦马拉
    muktele
    目地利
    ehe ehe
    衣（喝一） 衣（喝一）
    cinda cinda
    今达 今达
    arsam pracali
    阿拉三 巴拉杂利
    vasa vasam
    瓦萨 瓦三
    prasaya
    巴拉萨呀
    huru huru
    户鲁 户鲁
    mara huru huru
    马拉 户鲁 户鲁
    hri sara sara
    （喝一）利 萨拉 萨拉
    siri siri
    悉利 悉利
    suru suru
    苏鲁 苏鲁
    bodhiya bodhiya
    播地呀 播地呀
    bodhaya bodhaya
    播达呀 播达呀
    maitriya narakindi
    买德利呀 拿拉（哥因）地
    dharsinina payamana svaha
    达拉悉尼那 巴呀马那 司哇哈
    siddhaya svaha
    悉达呀 司哇哈
    maha siddhaya svaha
    马哈 悉达呀 司哇哈
    siddhayoge svaraya svaha
    悉达右给 思瓦拉呀 司哇哈
    narakindi svaha
    那拉（哥因）地 司哇哈
    maranara svaha
    马拉那拉 司哇哈
    sirasam amukhaya svaha
    悉拉三 阿母嘎呀 司哇哈
    sarva maha asiddhaya svaha
    萨瓦 马哈 阿悉达呀 司哇哈
    cakra asiddhaya svaha
    杂嘎拉 阿悉达呀 司哇哈
    padmakastaya svaha
    巴得马嘎思达呀 司哇哈
    narakindi vagaraya svaha
    那拉（哥因）地 瓦嘎拉呀 司哇哈
    mavari sankraya svaha
    马瓦利 三哥拉呀 司哇哈
    namah ratna trayaya
    拿摩 拉大那 达拉呀呀
    namo aryavalokitesvaraya svaha
    拿莫 阿利呀瓦楼（哥一）地思瓦拉呀 司哇哈
    om siddhyantu mantra padaya svaha
    （奥母）悉旦度 满达拉 巴达呀 斯瓦哈

    愿：所有见闻者，悉发菩提心，尽此一报身，同生极乐国。


关于大悲咒注音的问答

    关于大悲咒注音的问答

    zf

    “按寺庙流通的碟片念诵音（与许多寺庙流通的大悲咒书本注音基本一致）那样念诵是否可以？”
    ──毫无疑问，通常的念诵是足够有效的。千百年来人们就这样念，感应道交层出不穷。若说无效，纯粹是瞪着眼睛说瞎话。但有些人喜欢较真儿，总希望找到一个标准的梵音版本。这样便有了不少“标准版本”，在下也跟着凑热闹。实际上，准确都是相对的。在持咒的修持上，比发音重要不知多少倍的是信心。因此，选择一个你最有信心的“版本”修持，这就是我的建议。

    “Svaha本来似乎应念S—Va—ha，可是在下听人念标准梵音时却像Sua-—ha（像“耍哈”）。”
    ──S——Va要联读。确实很像“耍哈”。

    “另外，梵音中，菩提萨埵（Bodhisattva）的tva该念t──va，还是tua（“徒啊”联读）。”
    ──应是“徒啊”联读。
    另外，“ra”的发音，在西藏通常发“日啊”联读，但在印度、尼泊尔有些人的发音接近“la”（拉）。
    “ri”或“re”的发音也在“日一”联读和“利”之间。

    “‘毕加雅代。玛哈，毕加雅代。’是‘毕加雅代’还是‘瓦加呀地’”
    ──vajayate mahavajayate
    “va”，在印度和尼泊尔，有人读“巴”，也有人读“瓦”。我国古代的译师们也有这两种不同译法。
    我在尼泊尔时，看见一家旅馆——“金刚旅馆”，本来应写成“Vajra Hotel”，但由于发音的关系，他们干脆写为“Bajra Hotel”。

    “是‘萨lr瓦萨特，那玛瓦萨特’
    还是‘sarva sata
    萨瓦　萨达
    namo vasta
    拿莫　瓦萨达’”
    ──关于“lr”音，有人发得清楚，有人一代而过。（美国英语和英国英语就有类似的差别）。

    “是‘玛玛彼玛啦’
    还是‘马马瓦马拉’”
    这还是“va”的发音问题。
    “是‘馥啦萨利。未sua未suang馥啦萨雅。’
    还是‘巴拉杂利
    vasa vasam
    瓦萨　瓦三
    prasaya
    巴拉萨呀’”
    ──“p”的发音可能在“p”和“b”之间。

    “我的疑问也是同那位同修一样，我找不出哪一个发音版本是可以一直恭诵下去，”
    ──一时没有十分满意的，就选一个相对满意的。
    只要一种发音方式有出处，不是全世界只有你一人这样读，你就应该安下心来。
    最重要的“如法”就是有信心。
    我想，无论你读的大悲咒怎样怪，观世音都能丝毫不差地听懂你心中的呼唤，否则就不是“观世音”了。你只要专心颂咒就是了，其他的事情全部都交给观世音菩萨就是了！！！！


一切如来心秘密全身舍利宝箧印陀罗尼

   一切如来心秘密全身舍利宝箧印陀罗尼

     不空三藏 原译
     zf现代汉语译音

    （古代汉语译音）那莫悉怛哩野地尾迦南
    （现代汉语译音）拿摩 悉地哩呀 地尾噶南

    （古代汉语译音）萨婆怛他蘖多喃
    （现代汉语译音）萨瓦 达他噶达南

    （古代汉语译音）唵
    （现代汉语译音）奥母

    （古代汉语译音）部尾婆嚩娜嚩唎
    （现代汉语译音）部尾吧瓦达瓦利

    （古代汉语译音）嚩者梨
    （现代汉语译音）瓦者利

    （古代汉语译音）嚩者[齿*来]
    （现代汉语译音）瓦者泰

    （古代汉语译音）祖噜祖噜驮啰驮啰
    （现代汉语译音）祖鲁 祖鲁 达拉 达拉

    （古代汉语译音）萨嚩怛他蘖多
    （现代汉语译音）萨瓦 达他噶达

    （古代汉语译音）驮睹驮梨钵娜[牟*含]婆嚩底
    （现代汉语译音）达睹 达利 巴得吗 巴瓦地

    （古代汉语译音）惹也嚩梨
    （现代汉语译音）者呀瓦利

    （古代汉语译音）亩怛梨萨磨啰
    （现代汉语译音）目得利 思吗拉

    （古代汉语译音）怛他檗多达磨斫迦啰
    （现代汉语译音）达他噶达 达吗 扎噶拉

    （古代汉语译音）钵罗靺栗多娜
    （现代汉语译音）波拉瓦达那

    （古代汉语译音）嚩曰罗冒地满拏
    （现代汉语译音）巴者利 包地 班那

    （古代汉语译音）楞迦啰
    （现代汉语译音）楞噶拉

    （古代汉语译音）楞讫哩谛
    （现代汉语译音）楞给哩地

    （古代汉语译音）萨嚩怛他檗多地瑟耻谛
    （现代汉语译音）萨瓦 达他噶达 地思提地

    （古代汉语译音）冒驮野冒驮野
    （现代汉语译音）包达呀 包达呀

    （古代汉语译音）冒地冒地
    （现代汉语译音）包地 包地

    （古代汉语译音）没[亭*夜]没[亭*夜]
    （现代汉语译音）布达呀 布达呀
    （说明：其中“达呀”两字连读。 如将汉字中“嗲”字发第一声，便很接近此音。）

    （古代汉语译音）参冒驮儞参冒驮野
    （现代汉语译音）三包达你 三包达呀

    （古代汉语译音）者攞者攞
    （现代汉语译音）者拉 者拉

    （古代汉语译音）者懒都
    （现代汉语译音）者懒都

    （古代汉语译音）萨嚩嚩啰拏儞
    （现代汉语译音）萨瓦 瓦拉那你

    （古代汉语译音）萨嚩播波尾檗谛
    （现代汉语译音）萨瓦 巴巴尾噶地

    （古代汉语译音）户噜户噜
    （现代汉语译音）户鲁 户鲁

    （古代汉语译音）萨嚩戍迦弭檗帝
    （现代汉语译音）萨瓦 戍噶尾噶地

    （古代汉语译音）萨嚩怛他檗多
    （现代汉语译音）萨瓦 达他噶达

    （古代汉语译音）讫哩娜野嚩日啰抳
    （现代汉语译音）和利达呀 巴者拉你

    （古代汉语译音）三婆啰三婆啰
    （现代汉语译音）三巴拉 三巴拉

    （古代汉语译音）萨嚩怛他檗多
    （现代汉语译音）萨瓦 达他噶达

    （古代汉语译音）虞[口*皿]野驮啰抳亩涅梨
    （现代汉语译音）苏哈呀 达拉你 母得利

    （古代汉语译音）没悌苏没悌
    （现代汉语译音）布地 苏布地

    （古代汉语译音）萨嚩怛他檗多地瑟耻多
    （现代汉语译音）萨瓦 达他噶达 地思提达

    （古代汉语译音）驮睹檗陛娑嚩贺
    （现代汉语译音）达睹 噶比 司哇哈

    （古代汉语译音）三摩耶地瑟耻帝娑嚩诃
    （现代汉语译音）三吗呀 地思提地 司哇哈

    （古代汉语译音）萨嚩怛他檗多讫哩娜野驮睹亩捺犁娑嚩诃
    （现代汉语译音）萨瓦 达他噶达 和利达呀 达睹 目得利 司哇哈

    （古代汉语译音）苏钵罗底瑟耻多萨睹闭怛他檗多地瑟耻帝户噜户噜吽吽娑嚩诃
    （现代汉语译音）苏布拉 地思提达 思度比 达他噶达 地思提地 户鲁 户鲁 轰轰 司哇哈

    （古代汉语译音）唵萨嚩怛他檗多
    （现代汉语译音）奥母 萨瓦 达他噶达

    （古代汉语译音）坞瑟抳沙驮睹亩捺啰尼萨嚩怛他檗单娑驮睹尾部使多地瑟耻帝
    （现代汉语译音）乌思你沙 达睹 母得拉你 萨瓦 达他噶单 萨达 睹尾部西达 地思提地

    （古代汉语译音）吽吽娑嚩诃
    （现代汉语译音）轰轰 司哇哈

    （编按：不空三藏所译《一切如来心秘密全身舍利宝箧印陀罗尼经》，传世有两个译本，奉心居士现代汉语新译的这一版本主要依两个版本“大正藏No.1022a，No.1022b”之一“No.1022b”中的“一切如来心秘密全身舍利宝箧印陀罗尼”译音；这两个版本《一切如来心秘密全身舍利宝箧印陀罗尼经》有少量差异，如本文选用版本中的“亩怛梨萨磨啰”，“大正藏No.1022a”版本做“亩祖犁萨么啰”。这两个版本的流通情况是，1022b版的经本正文内容较丰，其经本和经中的真言在现代流通本中收录和流通较多见，历史中的古代藏本中以单收录1022a版本经为多见，谨此说明以便读者参考。）


关于宝箧印陀罗尼经

    小鱼：
    您好：赵叔。我已经收到您所赠送的宝箧印陀罗尼经，非常的喜欢这本经，已经在专心修持！但是我有一个大问题：因为此经书上所有文字已经全部标上汉语拼音，我想问的是：是否可以照着汉语拼音照念？但是我下了您的宝箧印陀罗尼MP3，发现您读的和经书上标的咒语拼音好象有点区别哦。请问我应以什么读音为准？

    zf：
    经书中的注音是按台湾金刚赠经会的版本进行的，您按拼音念诵是可以的。不应回避的是，经文中对真言的汉语注音是在唐朝时进行的，经过千年的时间，以今人所认识的古汉字来诵咒，咒音有一定变化，这一点是学术界公认的。我所念诵的梵音真言，谈不上准确，但似乎应该比直接以汉字来诵咒稍微好一点。对诵咒来说，信心是第一位的。您选择一个自己有信心者念诵就可以了。


关于灭定业真言

    彩虹:

    后学对地藏菩萨有信心，看了弘一大师的《地藏菩萨圣德大观》后知弘一大师、蕅益大师等大德除了提倡念圣号外也提倡念灭定业真言，意即两个都念最好。所以烦请赵叔为后学给灭定业真言用汉语拼音注下音，谢谢。
    嗡 钵啰 末粼 陀宁 娑婆诃

    zf:

    地藏菩萨灭定业真言，在下未见过相应的梵文拼写。圆觉宗诺那华藏经舍金刚赠经会所印赠的经典中有此灭定业真言如下：
    om 不拉 吗呢 沓咧 梭哈

    （编按：新编佛教念诵集中收录了以下一些真言的新译，一并列入）

    绿度母（多罗菩萨）心咒

    唵，达丽，都、达丽，都丽，娑哈。

    金刚萨埵心咒

    唵 班（札尔）萨埵吽

    速疾满普贤行愿陀罗尼

    拿摩悉地哩呀、地尾噶南，达他噶达南，奥母、阿素瓦拉、尾给地，斯瓦哈。

    七佛灭罪真言

    离巴离巴帝，估哈估哈帝，达拉尼帝，尼嘎拉帝，微嘛离帝，马哈嘎帝，（加母）（拉母）（扎母）帝，司哇哈。

    药师咒

    拿摩把嘎瓦帝，贝萨加、古鲁、微督离呀，钵拉巴、拉加呀，达塔嘎达呀，阿拉哈帝，三（米阿）三布达呀，达得压他，奥母，贝萨借，贝萨借，贝萨加，萨穆嘎帝，司哇哈。


谈真言新译整理的尝试

    谈真言新译整理的尝试

    zf

    “虽然我不经常到网海莲舟论坛来，但我也发现有一位叫zf的善知识在密咒的整理和弘扬方面作出了很大的贡献，我在此随喜！”
    ──“很大的贡献”真的是愧不敢当。在下斗胆尝试的主要原因有二：
    一、新译的结果总的说来要比以现代汉语发音读诵古译来得好。
    二、真言本身具有极强的“纠错功能”，纵使个别处发音有误，也不会导致真言的功能向害多益少的反方向改变；诵宝箧印陀罗尼照样是无量无边的如来前来加持；诵大悲咒观世音一定会以千手呵护、千眼慈视。
    那种若真言中的某些字词发音有误，诵咒不但无益反而有害的说法，在下深不以为然！试想，行人若以真诚之心持诵大悲咒，观世音会因为行人发音不准而允许魔鬼前来扰乱！？持此见者未免过于低估观世音菩萨的智慧和慈悲了吧！

    “我也见过一种藏传的《宝箧印陀罗尼咒心》，是用兰扎体梵字写的，供参考：
    o3 sarva tath2gato＝51＝a dh2tu mudr25i
    sarva tath2gata dharma dh2tu vibh9＝ite
    adhi＝6hite huru huru h93 h93 sv2h2”
    ──多谢。关于宝箧印陀罗尼，汉语大藏经除不空的两个版本外，施护大师还有另外一个版本。宝箧印陀罗尼的“心咒”还在另外一部经中出现。另外，此真言的修持在藏传体系中尚有传承在。此真言的传承当年被诺那祖师带到了汉地。

    “我发现你有自己亲自念诵的正梵音大悲咒（就是你曾为它注过拼音的）资料，能否给我一张？”
    ──我原来确实为别人念诵过。前些天再次录了音，“佛典宝库”上有。录音文件都是其他师兄整理的，我手头没有保留。我对自己念诵真言的评价根本不敢用“准确”二字，“正梵音”谈不上，但感觉应该比直接读汉字好一点。

    注音和录音之事在下曾犹豫过，因为肯定不是绝对的“正梵音”，但有相对价值的事是否值得去做？
    犹豫的结果是，做。
    此事若有任何一点功德，全部回向一切六道父母；若因发音不准为行人带来的一切恶果，在下心甘情愿一人承担！


学习《普贤行愿品》来推动学华严

    智行：
    ZF善知识，在下一直觉得《普贤行愿品》非常殊胜，此论坛也不乏好学之人，好像此经十分契诸兄之喜好和心量。又有师兄提议以此共修，正是大好因缘。您能否出来给大家带个头，起此普贤共修会，随便指导一下大家修学华严，此事您最合适、法缘也很殊胜。
    久闻华严宗不振，猜测是否和华严部头太大有关，能持诵者甚是鲜少。今若以《普贤行愿品》来推动学华严，虽是大海一滴，也不失海水之性。进而大家了解了一即一切，那么从此一滴入大海也就有了门径。不忍见此无上大法留于尘封之中，肯请善知识给带个头，应该各宗都会有学人随喜或参与。这是法门的一个胜事啊！

    zf：
    在下虽然才疏学浅，但带头学普贤行愿品的事还是十分愿意去做的。感谢智行兄给本人这个机会！“共修会”应办成什么样子，希望所有愿意参加者都发表自己的意见。
    本人先提两个建议：
    一、提倡解行并重，以解助行，目的是使大家成为“华严行者”，而不是“华严学者”。
    二、《普贤行愿品》以“广本”为主。

    阿菜：
    为了预备先看点什么？后学已经找到《华严五教止观》，《初发心功德品》，《广本行愿品》（ZS师兄贴出的），求ZF叔指点，需要看哪些？　看书加强学习外，行是怎么个具体行法？求赵叔开示。

    zf：
    阿兄，
    一、建议您先熟悉“广本普贤行愿品”。
    二、关于“行是怎么个具体行法？”我想不外如普贤菩萨所说“受已能读、读已能诵、诵已能持，乃至书写，广为人说。”
    心与法相应，就是行。


关于学习《普贤行愿品》的几点建议

    zf：

    本人建议如下：
    一、建议修持禅、净、密的佛友在保持原有修法的同时，增加“普贤行愿”的修持。
    二、建议“普贤行愿”的修持首先从阅读80卷《华严经》的“入法界品”或40卷《华严经》入手（“佛典宝库”网站收录了上述经典）。从善财童子53参的故事中，一方面学习善财童子精进的求法精神，另一方面，着重体会普贤行愿的重要和殊胜。这些善知识中有修行显宗者、有修密乘者；有正行者、有逆行者；但善知识们开示，这些修法都是普贤行愿大海之一滴。我们应由此对普贤行愿之殊胜生起定解。
    这里，《入法界品》的阅读不定为“精读”要求，可以当故事读。
    （若有佛友欲对经意进行深入理解，可研读法藏大师、澄观大师、李长者等的经疏。）
    三、“文殊师利大胜尊，三世诸佛以为母，十方如来初发心，皆是文殊教化力。”诸位在阅读入法界品时要了知，善财童子从初发菩提心直至导入普贤行愿海所依靠者都是文殊菩萨的护持力。因此希望大家从心里祈请：“南无文殊师利大胜尊，愿我早入普贤行愿海。”
    四、在学习《入法界品》的同时，建议诸兄每天都能读诵一遍普贤行愿品。根据自己的时间，“广本”、“小本”或颂文都可以。
    五、在一定的基础上，将来我们再一起研讨普贤行愿的深意。
    关于是否大家要有共同的修持时间，是否要在某一时间内读诵经文达到一定的遍数，本人倾向于不做规定，诸位视自己的情况而定。学习《普贤行愿品》的网页，建议大家合力将它办好。我提几个建议：
    一、对“佛典宝库”中已有的对普贤行愿品讲解的资料进行链接，如
    《普贤行愿品讲记》【济群法师讲】
    《普贤行愿品略释愿海舟》【益西彭措堪布　著】
    二、佛友们一起努力，将目前尚未电子化的、大德们对普贤行愿品的讲解输入电脑。这样的著作还有一些。
    三、各位佛友一起努力，将自己以前读过的所有和普贤行愿品有关的内容整理汇集起来。例如《华严念佛三昧论讲记》【黄念祖居士讲】中的有关部分；弘一大师在普贤行愿中往生等等等等。
    这些工作怎样有效地开展，请大家多多指导。


学习《普贤行愿品》的推荐读本

    eeagle：
    提出一个建议：我们大家可否请赵叔为我们甄订一下学习《普贤行愿品》推荐念修的经本?

    zf：
    作为学习《普贤行愿品》的修持，在下向诸位推荐的是：
    一、四十卷华严（或八十卷本的入法界品）为泛读内容，参考书为《大方广佛华严经普贤行愿品别行疏钞》。
    二、精读内容为“广本普贤行愿品”。
    要求为：
    （1）、受──接受。通过入法界品的学习了解普贤行愿的殊胜和在大乘道中的地位和作用。
    （2）、读──依经本熟读。
    （3）、诵──脱本背诵。
    （4）、持──心与经文和经义融合。
    （5）、书写──对经文的书写（包括印刷流布）。
    （6）、广为人说──对普贤行愿的弘扬。

    毫无疑问，参加普贤行愿共修的同学可以根据自己的兴趣修习其他法。


关于“广本普贤行愿品”

    zf：

    关于“广本普贤行愿品”，以下内容是本人给一位网友的回信。
    ＊＊＊＊：
    你的记性好，又肯用功，应当趁着年轻时多背诵点重要的经文，好处是巨大的。
    我建议你从现在开始读诵“广本普贤行愿品”（这个名字是我起的）。
    在汉地，《华严经》共有三个版本，分别是60卷、80卷和40卷。这40卷本是最晚来到中国的，相当于80卷本中的最后一品《入法界品》，即关于善财童子53参的故事。40卷华严的特殊之处是增加了最后一部分──我们通常所说的“普贤行愿品”。实际上整个40卷华严的完整名字就是《大方广佛华严经入不思议解脱境界普贤行愿品》。
    我们现在读诵的“普贤行愿品”之前的一段，是普贤菩萨对如来功德的赞颂，这一部分经意十分重要。在“尔时普贤菩萨摩诃萨。称叹如来胜功德已。告诸菩萨及善财言。善男子。如来功德。假使十方一切诸佛经不可说不可说佛刹极微尘数劫。相续演说不可穷尽。若欲成就此功德门。应修十种广大行愿”中，“若欲成就此功德门”一句不但是讲发菩提心，而且还开示了发菩提心具体应该以怎样的功德为目标，这一点极为重要。因为如果我们希望成佛，可是心里却并不知道佛究竟具有哪些功德，这样的菩提心并不是真正的菩提心，如同我们引弓射箭，可是却看不清楚靶子，其结果是可想而知的。
    另外，在行愿品中“称赞如来”这一部分的修行中，要求“我当悉以甚深胜解。现前知见。各以出过辩才天女微妙舌根。一一舌根。出无尽音声海。一一音声。出一切言辞海。称扬赞叹一切如来诸功德海”，可是若有人问，如来究竟有哪些功德，估计我们绝大部分人说不出个一二三来。如果我们不了解如来的功德，我们如何去称赞呢？这样的行愿岂不成了空愿？
    “广本普贤行愿品”中既有普贤菩萨所总结的如来功德概要，同时还包含了为实现此目标的手段──十种广大行愿，浓缩了佛法修证的精髓。
    希望你能充分重视。


关于令安住普贤行善知识

    关于令安住普贤行善知识

    zf

    学佛的第一步就是寻找善知识（也就是你所谓的师傅），这一步若是出了问题，后面的苦头可就大了。密探兄，你善根深厚，第一步没走错。这一断言不是出自在下之口，而是普贤菩萨金口亲说，有经为证：
    华严经中普贤菩萨言：
    “佛子。菩萨摩诃萨。有十种善知识。何等为十。所谓令住菩提心善知识。令生善根善知识。令行诸波罗蜜善知识。令解说一切法善知识。令成熟一切众生善知识。令得决定辩才善知识。令不着一切世间善知识。令于一切劫。修行无厌倦善知识。令安住普贤行善知识。令入一切佛智所入善知识。是为十。”
    上面十种善知识中，清清楚楚标明“令安住普贤行善知识”，遮丑兄让你念三千遍普贤行愿品作为入门的基础，“令安住普贤行善知识”这一称号当之无愧！

    遮丑兄绝非只说不练之辈，自己就是一位普贤行者。此亦是菩萨亲说。有经为证：
    “佛子。菩萨摩诃萨。有十种普贤行法。何等为十。所谓愿住未来一切劫普贤行法。愿供养恭敬本来一切佛普贤行法。愿安置一切众生于普贤菩萨行普贤行法。愿积集一切善根普贤行法。愿入一切波罗蜜普贤行法。愿满足一切菩萨行普贤行法。愿庄严一切世界普贤行法。愿生一切佛刹普贤行法。愿善观察一切法普贤行法。愿于一切佛国土成无上菩提普贤行法。是为十。若诸菩萨。勤修此法。疾得满足普贤行愿。”

    遮丑兄让你念三千遍普贤行愿品不正是“愿安置一切众生于普贤菩萨行普贤行法”吗！

    密探兄，遮丑兄将你引入普贤行愿门，对你的恩德大得无量无边。何以故？“如四大河从无热池。既流出已。究竟无尽。入于大海。菩萨摩诃萨。亦复如是。以大愿力。修菩萨行。自在知见。无有穷尽。究竟入于一切智海。如四大河入于大海。无能为碍令不入者。菩萨摩诃萨。亦复如是。常勤修习普贤行愿。成就一切智慧光明。住于一切佛菩提法。入如来智。无有障碍。如四大河。奔流入海。经于累劫。亦无疲厌。菩萨摩诃萨。亦复如是。以普贤行愿。尽未来劫。修菩萨行。入如来海。不生疲厌。”因此，遮丑兄引你修学普贤行愿，就是将你直接带进佛法的大宝库！你可要知恩图报啊！！！

    最后在下再供养坛上诸兄一段经文，作为对遮丑兄普贤行的随喜。

    尔时普眼菩萨。白普贤菩萨言。佛子。此菩萨摩诃萨。得如是法。同诸如来。何故不名佛。何故不名十力。何故不名一切智。何故不名一切法中。得菩提者。何故不得名为普眼。何故不名一切境中无碍见者。何故不名觉一切法。何故不名与三世佛无二住者。何故不名住实际者。何故修行普贤行愿犹未休息。何故不能究竟法界舍菩萨道。尔时普贤菩萨。告普眼菩萨言。善哉佛子。如汝所言。若此菩萨摩诃萨。同一切佛。以何义故。不名为佛。乃至不能舍菩萨道。佛子。此菩萨摩诃萨。已能修习去来今世。一切菩萨种种行愿。入智境界。则名为佛。于如来所。修菩萨行。无有休息。说名菩萨。如来诸力。皆悉已入。则名十力。虽成十力。行普贤行。而无休息。说名菩萨。知一切法。而能演说。名一切智。虽能演说一切诸法。于一一法。善巧思惟。未尝止息。说名菩萨。知一切法。无有二相。是则说名悟一切法。于二不二一切诸法差别之道。善巧观察。展转增胜。无有休息。说名菩萨。已能明见普眼境界。说名普眼。虽能证得普眼境界。念念增长。未曾休息。说名菩萨。于一切法悉能明照。离诸闇障。名无碍见。常勤忆念无碍见者。说名菩萨。已得诸佛智慧之眼。是则说名觉一切法。观诸如来正觉智眼。而不放逸。说名菩萨。住佛所住。与佛无二。说名与佛无二住者。为佛摄受。修诸智慧。说名菩萨。常观一切。世间实际。是则说名住实际者。虽常观察诸法实际。而不证入。亦不舍离。说名菩萨。不来不去。无同无异。此等分别。悉皆永息。是则说名休息愿者。广大修习。圆满不退。则名未息普贤愿者。了知法界。无有边际。一切诸法。一相无相。是则说名。究竟法界舍菩萨道。虽知法界。无有边际。而知一切种种异相。起大悲心。度诸众生。尽未来际。无有疲厌。是则说名普贤菩萨。佛子。譬如伊罗钵那象王。住金胁山七宝窟中。其窟周围。悉以七宝。而为栏楯。宝多罗树。次第行列。真金罗网。弥覆其上。象身洁白。犹如珂雪。上立金幢。金为璎珞。宝网覆鼻。宝铃垂下。七肢成就。六牙具足。端正充满。见者欣乐。调良善顺。心无所逆。若天帝释。将欲游行。尔时象王。即知其意。便于宝窟。而没其形。至忉利天。释主之前。以神通力。种种变现。令其身有三十三头。于一一头。化作七牙。于一一牙。化作七池。一一池中。有七莲华。一一华中。有七采女。一时俱奏百千天乐。是时帝释。乘兹宝象。从难胜殿。往诣华园。芬陀利华。遍满其中。是时帝释。至华园已。从象而下。入于一切宝庄严殿。无量采女。以为侍从。歌咏妓乐。受诸快乐。尔时象王。复以神通。隐其象形。现作天身。与三十三天。及诸采女。于芬陀利华园之内。欢娱戏乐。所现身相。光明衣服。往来进止。语笑观瞻。皆如彼天。等无有异。无能分别。此象此天。象之与天。更互相似。佛子。彼伊罗钵那象王。于金胁山七宝窟中。无所变化。至于三十三天之上。为欲供养释提桓因。化作种种诸可乐物。受天快乐。与天无异。佛子。菩萨摩诃萨。亦复如是。修习普贤菩萨行愿。及诸三昧。以为众宝庄严之具。七菩提分。为菩萨身。所放光明。以之为网。建大法幢。鸣大法钟。大悲为窟。坚固大愿。以为其牙。智慧无畏。犹如师子。法缯系顶。开示秘密。到诸菩萨行愿彼岸。为欲安处菩提之座成一切智。得最正觉。增长普贤广大行愿。不退不息。不断不舍。大悲精进。尽未来际。度脱一切。苦恼众生。不舍普贤道。现成最正觉。现不可说不可说成正觉门。现不可说不可说转法轮门。现不可说不可说住深心门。于不可说不可说广大国土。现涅槃变化门。于不可说不可说差别世界。而现受生。修普贤行。现不可说不可说如来。于不可说不可说广大国土。菩提树下。成最正觉。不可说不可说菩萨众。亲近围绕。或于一念顷。修普贤行。而成正觉。或须臾顷。或于一时。或于一日。或于半月。或于一月。或于一年。或无数年。或于一劫。如是乃至不可说不可说劫。修普贤行。而成正觉。复于一切诸佛刹中。而为上首。亲近于佛。顶礼供养。请问观察。如幻境界。净修菩萨无量诸行。无量诸智。种种神变。种种威德。种种智慧。种种境界。种种神通。种种自在。种种解脱。种种法明。种种教化。调伏之法。佛子。菩萨摩诃萨。本身不灭。以行愿力。于一切处。如是变现。何以故。欲以普贤自在神力。调伏一切诸众生故。令不可说不可说众生。得清净故。令其永断生死轮故。严净广大诸世界故。常见一切诸如来故。深入一切佛法流故。忆念三世诸佛种故。忆念十方一切佛法。及法身故。普修一切菩萨诸行。使圆满故。入普贤流。自在能证一切智故。佛子。汝应观此菩萨摩诃萨。不舍普贤行。不断菩萨道。见一切佛。证一切智。自在受用一切智法。如伊罗钵那象王。不舍象身。往三十三天。为天所乘。受天快乐。作天游戏。承事天主。与天采女。而作欢娱。同于诸天。无有差别。佛子。菩萨摩诃萨。亦复如是。不舍普贤大乘诸行。不退诸愿。得佛自在。具一切智。证佛解脱。无障无碍。成就清净。于诸国土。无所染着。于佛法中。无所分别。虽知诸法普皆平等。无有二相。而恒明见一切佛土。虽已等同三世诸佛。而修菩萨行。相续不断。佛子。菩萨摩诃萨。安住如是普贤行愿。广大之法。当知是人。心得清净。佛子。此是菩萨摩诃萨。第十无碍轮大三昧殊胜心广大智。佛子。此是菩萨摩诃萨。所住普贤行十大三昧轮。


关于普贤之含义

    dawa：

    dawa作业之一

    一、关于普贤之含义：
    澄观《华严经疏钞》中约自体、诸位普贤、当位普贤、佛后普贤、融摄，而说五种普贤，这是最全的说法。如《华严经疏》卷五云（大正35·535b）所云：‘言普贤者，体性周遍曰普，随缘成德曰贤，此约自体；又曲济无遗曰普，邻极亚圣曰贤，此约诸位普贤；又德周法界曰普，至顺调善曰贤，此约当位普贤；又果无不穷曰普，不舍因门曰贤，此约佛后普贤；位中普贤悲智双运；佛后普贤智海已满，而运即智之悲，寂而常用穷未来际。又一即一切曰普，一切即一曰贤，此约融摄。’
    这儿感到难区别的是“诸位”和“当位”……
    下面的这段则容易些。
    《华严经疏》卷十一说普贤有三种（大正35·576a）：“（一）位前普贤，但发普贤心，即是非今所用。（二）位中普贤，即等觉位故，此居佛前。（三）位后普贤，谓得果不舍因行故。”此相当于上述所谓的诸位、当位、佛后。

    所以，菩萨从初发菩提心，六度万行，到德行圆满，证菩提华果，皆普贤也。通常所说的普贤菩萨，乃约等觉位而言；若约自体义和果位，即为普贤王如来。

    二、普贤的含义中既摄佛果，又摄成佛之因：普贤行愿。“修行之要，最重发心，发心方有趣向，趣向方达道果。发何等心，修何等行，至何道果也。”
    这儿提示了一个方便：把法身的“能生”义可以理解为对“因”的融摄。“自性能生万法”其实依然是对因缘法的描述，把法身理解为诸法之“第一因”显然是误解。

    三、普贤即“如来藏”，以广大而圆成。

    zs：

    嘻嘻……这帖子漂亮

    再加上〔俺觉得“普贤”谈不上变不变的……〕
    ＝＝》这正是佛出世、住世的因缘呀！！！嘻嘻，法华经是经王，这个见有很大原因吧？！

    〔3，普贤即“如来藏”，以广大而圆成。〕
    ＝＝》普贤是如来显吧？嘻嘻，可以问问麻叔、赵叔。

    dawa：

    补充：【普贤如来】释义

    【普贤如来】
    （佛名）在金刚界或以名果上之大日如来，或以名因位之普贤菩萨。名大日者，依于大日普贤证成善愿行之义。名为普贤如来又名普贤法身。若依主伴互具之义，则三十七尊总称为普贤如来也。日本安然之瑜只经疏，依于此义而总称三十七尊为普贤如来。瑜只经曰：‘金刚界普贤如来。’同疏曰：‘三十七尊，皆名普贤。’略出经四曰：‘普贤法身。遍一切无始无终无生灭。’菩提心论曰：‘其圆明则普贤身也，亦是普贤心也，与十方诸佛同之。亦乃三世修行，证有前后，及达悟已，无去来今。’同初心钞下曰：‘普贤身心者，约之可指大日身心，大日名大普贤故。’又名普贤者，为示大日如来久已成道，为诸众生今始成道，又因中有果，故因中说果，称普贤之身为如来。金刚顶经疏一曰：‘婆伽梵大菩提心，普贤大菩萨。’同疏三曰：‘婆伽梵者果号也。大菩提心大菩萨者是即因号，今以果号号因种者，为显毗卢遮那虽久成道为诸众生示适今证，故号因位，又云因必有果故以为名。’
    FROM：【丁福保《佛学大辞典》】


因位普贤何时成正觉与行人根性直接相关

    dawa：
    一、【菩萨之所以做此示现，目的在于引导众生随学，如根本没有于一念顷圆满普贤行的可能，则菩萨的示现便成为纯粹的卖弄。】
    请问，上文中的“做此示现”，其所指应该是“于一念顷。修普贤行。而成正觉”？
    二、俺理解“成正觉”，就是“随缘成德”，或者就是“安住于普贤行愿”。所以“一念顷”和“不可说不可说劫。修普贤行。而成正觉”，二者平等，皆普贤德之显。
    而所谓的“时间”观念，似乎在“安住”面前失效了……就如同“人我之别”无阻慷慨之心。

    zf：
    “请问，上文中的‘做此示现’，其所指应该是‘于一念顷。修普贤行。而成正觉’？”
    ──是

    “俺理解‘成正觉’，就是‘随缘成德’，或者就是‘安住于普贤行愿’。所以‘一念顷’和‘不可说不可说劫。修普贤行。而成正觉’，二者平等，皆普贤德之显。”
    ──因位普贤何时成正觉与行人根性直接相关。
    若说平等，如佛与众生之平等，一念与长劫自然也平等。

    “而所谓的‘时间’观念，似乎在‘安住’面前失效了……就如同‘人我之别’无阻慷慨之心。”
    ──这里讨论的着眼点是，行人从发心修学至安住的时间差别。

    dawa：
    【因位普贤何时成正觉与行人根性直接相关。】
    俺知道自己的问题了……喜欢耍小聪明，有偷懒的心思。
    猛利的行人是直接接受本具的功德，并以之endless利益终生了。

    zf：
    说得太好了！不过，“猛利的行人是直接接受本具的功德，并以之endless利益终生了。”
    ──是“众生”而不是“终生”！


凡夫应用有限的缘起知识要去实现的目标

    凡夫应用有限的缘起知识要去实现的目标

    zs

    嘿嘿……老兄，缘起法不是有钱了才能用没钱了就边都摸不到的东东。那是世间法的究竟──你懂什么意思吗？！就是〔造〕──注意，造 飞机轮船邮票牙签都是要遵循缘起法的。凡夫能把飞机送上天，能把潜艇送下水，这都是在掌握了一定的缘起法的知识的表现……你怎么能说什么〔缘起只有一类，凡夫无知无见不可思议；即凡夫可知可见可思议的都不是缘起。〕？！！！您老坐过汽车没有呀？！嘿嘿！
    这里有两点是要明确的：
    一、凡夫所认识的缘起法不全面──或者只强调心或者只强调物，而佛讲的缘起法，是把心心所的问题全部总结进去了。
    二、凡夫应用有限的缘起知识要去实现的目标，基本是非解脱的──而佛知道利用缘起法的作用，是能帮助自己及众生离苦得乐。所以，佛在讲解缘起法的时候，用缘起观引导众生解脱的方法，被佛讲解的淋漓尽致，但是造飞机的思路，佛是不甚提及……提及也是教个办法让你自己飞起来算了，比如去阿弥陀佛世界得神足通。


云何一念见三世，云何尽一切劫为一念？

    zzzm：
    也谈一点体会，前面蒙赵叔帝网珠喻的讲解，对“一身复现刹尘身，一一遍礼刹尘佛”的观想有了点影子。这个相似于空间上的境界，那么对时间上的，比如，如何一念见三世，如何尽一切劫为一念？后学觉得挺难的，就此请教赵叔，赵叔说：那些小珠子是可以代表任何一法的吆！奥，后学觉得有些明白了。层层无尽的小珠子可以看作内、外、有形、无形等一切法，自然可以代表过去、现在、未来一切法，自然可以代表一刹那，也可以代表无量劫。这样一念遍入三世，三世摄归一念，而竟不出此念；一念遍入一切劫，一念遍入一切念而不出此念，便显得十分自然；这样自然就可以做到──至少是观想到：
    三世一切人师子，一切遍礼尽无余；
    我能深入于未来，尽一切劫为一念；
    三世所有一切劫，为一念际我皆入……
    一念行普贤行即是念念行，一行即一切行，即无量劫行。
    所以自然是念念相续无有间断，身语意业，无有疲厌。
    后学觉得华严层层遍入，周遍涵容的法界大缘起观，是广大普贤行的“理论”基础，只有在此见地下的行，恐怕才能称得上真正的普贤行。后学非常希望看到众师兄在这方面的深入讨论和善知识的开示。

    后学在各方面都很浅陋，但有感于zs师兄“我想甭管见地高低只要放到网海里转起来，揉的时间长了，自然各自获益非浅。”的话，也为报答善知识教诲，写一点体会，就教于大家。

    所有与我同行者，于一切处同集会；身口意业皆同等，
    一切行愿同修学。所有益我善知识，为我显示普贤行；
    常愿与我同集会，于我常生欢喜心。

    zs：
    一、一念含摄无数劫……破的是时间相，时间是个对比的假象，其实心不住于一法的时候，这个不是问题吧？
    二、华严境界不是相的问题，是个用心的问题，说的明确点就是个发心的问题。
    三、〔后学觉得华严层层遍入，周遍涵容的法界大缘起观，是广大普贤行的“理论”基础，只有在此见地下的行，〕哈哈，这其实就是空性见。一切都是相对的，必然是层层叠叠……

    zzzm：
    有些地方没太明白。我觉得时间相是极难破的。您说的对，心不住于一法的时候，这个不是问题，那什么时候能心不住于一法，如何心不住于一法？我觉得这个观想正是一种很好的破时间相的方法。

    “华严境界不是相的问题，是个用心的问题，说的明确点就是个发心的问题。”
    ──没看太明白。您是说入华严境界是个用心、发心的问题？是吗？我说华严境界也不离相大概也不错，华严经上到处都是，以事显理，理事互彰。我上帖是说“华严层层遍入，周遍涵容的法界大缘起观，”即一含一切的这种见地，是普贤行愿的基础。
    华严的空性见──姑且这么说吧，或说缘起观是很有特色的……不好意思，当然我也说不好，总之觉得很殊胜，很不一般。正开始学。还请诸兄多指点。

    zs：
    嘻嘻。怎么知道心不住于一法，我说个怪答案──祈请上师加持去！嘿嘿，有个事情很怪，如果学佛的精进程度是没什么变化的，开始的时候学佛的进度自力的作用会表现得很明显，但是越往后越发现自己得靠上师的加持力牵着了……
    可以一含一切，也可以一不含一切吧？？普贤行愿的基础，是金刚经的那段话，不是什么一切不一切的。不过，相和心不二，从相上说也没问题吧。空性见不分华严还是什么其他的。

    zzzm：
    再说几句，多谢师兄提醒。我会于此努力的。若以华严缘起观说，一定是一含一切。您的意思是……？

    “普贤行愿的基础，是金刚经的那段话，不是什么一切不一切的。”
    ──这个不同意！！后学是这样想的：不管基础是什么，如果没有“一即一切”的见地为指导，普贤行愿永远不可能圆满。别说十大行愿，就单说礼敬诸佛，我们如何能做到一礼即遍礼对过去现在未来三世诸佛而无有一佛遗漏呢？就算不要求一礼即是遍礼，那过去佛，现在佛都无量无边，更何况还有无量无边众生将要成就的未来诸佛，这样的三世佛如何才能一一遍礼尽无余呢？所以如果不是“一具一切”的华严缘起观，经中那么多已经具足普贤行愿的大菩萨就无从谈起了。师兄以为如何？

    “不过，相和心不二，从相上说也没问题吧。”
    ──没看懂。这好像是我要说的话。

    zs：
    师兄要多想办法和上师亲近，时常能得到上师的指导，这是修行的根本。一即一切，这话是对心行上有细微心相割裂的一个引导。真要作为见，那个〔一即一切〕的第一个“一”，得抠掉。什么叫见呀？！是一种思维理解吗？不起观就不是这个样子了？就不是圆满了？！对这个〔一即一切〕的含义再想想。一个未曾修任何法的凡夫，极为随便的礼佛的那一刹那，就是遍礼一切佛──只是他没认识到这个罢了。起观的目的是带动心行……

    zf：
    插一句，依在下浅见，在“一即一切”中，无论是“一法”还是“一切法”都是世俗所共许之法。如同“中观”中世俗谛之法与胜义谛之空性不相违背一样，华严在成立“一即一切”时与世俗谛之法同样毫无相违。因此，在下认为，“一即一切”的第一个“一”，无须抠掉。

    nkdj：
    嘻嘻，小子觉得“一即一切”是在世俗谛对凡夫的见的引导。思量起来，一法和一切法也都是随顺世俗谛的说法，如何为一，如何一切，这是没法定住的。只是凡夫有一多之别，未明平等，故而障碍重重。还请诸位指教。

    zs：
    依赵叔的说法，是把这话等同于世俗谛的作用，世俗谛就是对凡夫的引导。依这个做法，对众生引导更有利吧……

    zf：
    “一即一切”即不是通常的世俗谛，也不是通常的胜义谛。

    nkdj：
    赵叔，这个问题您能多说几句吗？

    zf：
    我知道的也就这些了。


众生所以度不尽的数学解释

    大千：
    众生都有成佛的可能性，就必然包含有一部分众生事实上不能成佛的可能性，如果没有后边的这种可能性，就不应当说“众生都有成佛的可能性”，而应当改成说“众生都必定成佛”了。
    所有众生都有佛性，但并非所有众生必定都能实现这种可能性。一个是说可能性，一个是说这种可能性的实现。这是两回事。比如，每个公民都有当总统的可能性，这意思是说就可能有一部分公民当不上总统。

    二麻子：
    哎呀，大千真是吃亏……当年没专门学数学。嘻嘻……
    麻子帮你说清楚。
    1、给定任一众生A，必存在一个时间T，当T以后，A已成佛。由于是对任一众生都如此，1就是“一切众生究竟成佛”。
    2、给定任一时间T，必有（至少）一个众生还没成佛。这就是“佛度不尽众生”。
    所以，嘻嘻，讲能不能成佛，可能性什么的，就得讲明白，是指定众生还是指定时间？
    指定众生，则他将来一定成佛，多久就不管了。
    指定时间，就一定有众生没成佛。
    两个搅和在一块问，嘻嘻，就是搅和罢了。
    麻子那话，只是对大乘佛法的“一切众生究竟成佛”
    在俗义上的一个解释。如此而已。
    如果接受“一切众生终究解脱”这个看法的话，麻子那话里将成佛换为解脱，就也成了个解释。当然接不接受这个看法本身，是见的不同。
    千兄这里真是吃数学的亏……现代的无穷大思想对正确了解佛法这部分可以很有帮助的。度不尽与究竟成佛可以根本不矛盾。若在古代，这地方说不明白的情况想必要多得多。

    玄兹：
    是哩，不引起误解有个最好的办法，那就是不说：）俺当年当真抠过无穷大的定义，其中“任意给定一个大N”中的“任意给定”就是一个很有意思的说法。一般情况下“任意”就不能“给定”，“给定”就不能“任意”。结果号称严密的数学定义竟然把它们写在一起。

    二麻子：
    先任意后可以给定。先给定后不能再任意！！！！顺序在数学证明中极其重要。嘻嘻。
    数学用语有时候真的很特别很奇怪。比如生活里说，“桃子是甜的在一般情况下成立”，那意思是说有个别情况下可以不对，也有桃子可能苦。同一句话放到数学里，却是说绝无反例。若有一个桃子苦，就证明这话错了。
    如果从数学专业的角度来看。无穷大在数学上不做为“数”来看，只是一个极限过程。注意，是过程。描述趋向无穷大的过程的那套e－d语言的意思其实就是说，不管你给多大的数，只有你给定了，在过程里这个东西就会变得比你给的那个大。
    无穷大之间也可以比较，这里比的实际是两个趋向无穷的变量谁趋向得速度更快，而不是比两个“数”。数学家们用先任意后指定，任意性表现在指定前。指定后就不能变，否则不叫数。嘻嘻，所以有时候，这个任意指定数又叫任意指定的常数。在数学里，数就是个常数。能变的不叫数，叫变量。没有个等于无穷大的数，只有趋向无穷大极限的变量。


我对“一切”的理解就是：一个都不能少！

    不动：
    一个问题向大家请教，行愿品中有两个作为起点的概念，即“不可说”，“极微尘”。这两者在观修上如果依华严起修，有什么特别需要注意吗？对“不可说”的若以信入，比如一即一切，是否隐含着实修者本身概念中最大化的局限而需要加以认识呢？应如何观修？另外，华严中的微尘和极微尘，和我们一般概念中的物质组成微尘，除了一多互摄，另有什么原则性的概念需要注意的区别吗？

    zf：
    想参加讨论，但对问题把握不准。如“是否隐含着实修者本身概念中最大化的局限而需要加以认识呢？”具体所指是什么？

    不动：
    实际上我始终认为。不但想象力会有局限，连一切的概念也有局限。实际上运用名言的时候，比如一切，实际上还是有概念上的潜在比较的，我对信入的方法充分信任，但是还是忍不住希望能在名言上有所现前的突破，比如把这个一切的概念在潜在比较上就予以扩大，至少在认知上有将此一切上的局限趋势转成开放的意识，末学目前能想到的方式是用华严阿僧祇做观直至心不能容受，依华严世界成就品来认知尘点的相互依存方式，请您多加开导。

    zf：
    是的，不同众生的“一切”确实不同。我对“一切”的理解就是：一个都不能少！


普贤菩萨对如来功德的赞颂

    zf：

    赞颂佛的功德是普贤十大愿王之一。
    在赞颂佛功德的同时，起心向往并发愿成就之，这就是菩提心。
    赞佛功德并欲成就，还是念佛法门──念佛功德门。
    《普贤行愿品》的第一句为“尔时普贤菩萨摩诃萨叹如来胜功德已”，此一句乃承接前一品经文中普贤菩萨对如来功德的赞颂。今人读诵普贤行愿品，通常对这一段称赞如来功德没有足够重视。但如果缺乏了这一环节，则在与“若欲成就此功德门，应修十种广大行愿”的连接上便感唐突。
    实际上，从“若欲成就如上所赞扬之如来功德”和普贤行愿这两者的关系来看，若将普贤行愿比作一张千钧硬弓，则欲成就如来功德之菩提心便是一只金刚利箭。弓箭配合方能杀尽烦恼之敌。

    经文选录：普贤菩萨对如来功德的赞颂
    选自《大方广佛华严经》(唐般若译四十华严之第三十九卷节录)

    尔时普贤菩萨摩诃萨。观察一切菩萨众会。及善财童子。而说偈言

    汝等应离诸疑垢　　一心不乱而谛听
    我说如来满诸度　　一切解脱真实道
    出世调柔胜丈夫　　其心清净如虚空
    常放智日大光明　　普照世间除惑暗
    如来难可得见闻　　无量亿劫今乃遇
    如优昙华时一现　　是故应听佛功德
    随顺世间诸所作　　譬如幻士现众业
    但为悦可众生心　　未曾一念生分别

    尔时一切菩萨。闻此说已。一心渴仰。发大誓愿。欲闻如来真实义谛所有功德。咸作是念。普贤菩萨诸行已圆。体性清净。如说能行。如行而说。一切如来共所称赞。作是念已。深生渴仰。尔时普贤菩萨。圆满种种功德智慧。庄严身心。犹如莲华。不着三界一切尘垢。告诸菩萨言。汝等皆当一心谛听。我今欲说佛功德海一滴之相。即说偈言

    佛智广大同虚空　　普遍一切众生心
    了世妄想皆非有　　不起种种异分别
    一念悉知三世法　　亦了一切众生根
    譬如善巧大幻师　　念念示现无边量
    随诸众生心行异　　往昔诸业愿乐力
    令其所见各不同　　而佛寂然无动念
    或有处处见佛坐　　充满十方诸世界
    或有其心不清净　　无量劫中不见佛
    或有信解心无我　　一念发意见如来
    或有谄诳不净心　　亿劫专求莫能遇
    或一切处闻佛音　　其音美妙令心悦
    或有百千万亿劫　　心不净故不得闻
    或见清净大菩萨　　充满三千大千界
    皆已具足普贤行　　如来于中俨然坐
    或见此界妙无比　　佛无量劫所严净
    毗卢遮那最胜尊　　于中觉悟成菩提
    或见莲华胜妙刹　　贤首如来住在中
    无量菩萨众围绕　　皆悉勤修普贤行
    或有见佛无量寿　　观自在等共围绕
    悉已住于灌顶地　　遍满十方无量土
    或有见此三千界　　犹如妙喜具庄严
    阿閦如来住在中　　及如香象诸菩萨
    或见月觉大名称　　金刚幢等菩萨俱
    住如圆镜妙庄严　　普遍十方清净刹
    或见日藏世所尊　　住普光明清净土
    与得灌顶诸菩萨　　充满十方而说法
    或见金刚大焰佛　　与智幢等菩萨俱
    周行一切广大刹　　说法除灭众生闇
    一一毛端不可说　　诸佛具相三十二
    菩萨众会共围绕　　种种说法度众生
    或见一一佛毛孔　　具足庄严广大刹
    无量诸佛住其中　　清净佛子皆充满
    或见十方平等刹　　而全在一极微中
    无量菩萨悉充满　　不可说劫修诸行
    或有见一毛端处　　无量极微尘刹海
    种种业起各差别　　毗卢遮那转法轮
    或有世界不清净　　或清净刹众宝成
    如来住寿无量时　　乃至涅槃诸所现
    普尽十方诸世界　　种种示现不思议
    随诸众生心智殊　　靡不化度令清净
    如是无上大调御　　充满十方国土中
    示现种种神通力　　我说少分汝当听
    或见释迦成佛道　　已经不可思议劫
    或见今始为菩萨　　十方利益诸群生
    或有见此释师子　　供养诸佛修行道
    或见人中最胜尊　　显示种种神通事
    或见布施或持戒　　或忍或进或诸禅
    般若方便愿力智　　随众生心皆示现
    或见究竟波罗蜜　　或见安住于诸地
    总持三昧神通智　　如是悉现尽无余
    或现修行无量劫　　住于菩萨堪忍位
    或见住于不退地　　或现法水灌其顶
    或现梵释护世身　　或现刹利婆罗门
    种种色相所庄严　　犹如幻师现众像
    或现兜率始降神　　或见宫中受嫔御
    或见弃舍诸荣乐　　出离王宫行学道
    或见始生或见灭　　或示出家学异行
    或见坐于菩提树　　摧伏魔军成正觉
    或有见佛始涅槃　　或见起塔遍世间
    或见塔中立影像　　或随众生现身色
    或见如来无量寿　　与诸菩萨授尊记
    而成真实大导师　　次补住于安乐刹
    或见无量亿千劫　　作佛事已入涅槃
    或见今始成菩提　　或见正修诸妙行
    或见如来清净月　　在于梵世及魔宫
    自在天宫化乐宫　　示现种种诸神变
    或见在于兜率宫　　无量诸天共围绕
    为彼说法令欢喜　　一切净心供养佛
    或见住在夜摩天　　忉利护世龙神处
    如是一切诸宫殿　　莫不于中现其像
    或于然灯世尊所　　散华布发为供养
    从是了知深妙法　　恒以此道化群生
    或见久远已涅槃　　或见初始成菩提
    或见住于无量劫　　或见须臾即灭度
    身相光明与寿命　　智慧菩提及涅槃
    众会所化威仪声　　如是一一皆无量
    或现其身极广大　　譬如须弥大宝山
    或见跏趺不动摇　　充满无边诸世界
    或见圆光一寻量　　或见千万亿由旬
    或照无量国土中　　或见充满一切刹
    或见佛寿八十年　　或寿百千万亿岁
    或住不可思议劫　　如是展转倍过是
    佛智通达净无碍　　刹那普了三世法
    皆从心识因缘现　　生灭无常无自性
    于一刹中成正觉　　一切刹处悉亦然
    一切入一一亦尔　　随众生心而示现
    如来安住无上道　　成就十力四无畏
    圆满智慧无障碍　　转于十二行法轮
    普知苦集及灭道　　微细分别缘起法
    法义乐说辞无碍　　因此无畏广宣扬
    诸法无我无有相　　业性不起亦不失
    一切远离如虚空　　佛以方便能分别
    如来如是转法轮　　普震十方诸国土
    宫殿山河悉摇动　　不使众生有惊怖
    如来普演广大音　　随其根欲皆令解
    悉使发心除惑垢　　而佛未始生心念
    或闻施戒忍精进　　禅定般若方便智
    或闻慈悲及喜舍　　种种言辞差别声
    或闻四念四正勤　　神足根力觉支道
    诸念神通止观等　　无量方便诸法门
    龙神八部人非人　　梵释护世诸天众
    佛以一音为说法　　随其品类皆令解
    或有贪欲嗔恚痴　　忿覆悭嫉及憍谄
    八万四千烦恼异　　令其闻说对治门
    若白净法未修治　　令其闻说十学处
    已能布施调伏者　　令闻寂灭涅槃音
    若人志劣无慈愍　　厌恶生死自求离
    令其闻说三脱门　　使得出苦涅槃乐
    若有自性少诸欲　　厌背三有求寂静
    令其闻说诸缘起　　依独觉乘而出离
    若有清净广大心　　圆满施戒诸功德
    亲近如来具慈愍　　令其闻说大乘音
    或有国土闻一乘　　或二或三或四五
    如是乃至无有量　　悉是如来方便力
    涅槃寂静无差别　　智行胜劣有殊异
    譬如虚空体性一　　鸟飞远近各不同
    佛体音声亦如是　　普遍一切虚空界
    随诸众生心智殊　　所闻所见各差别
    佛以过去修诸行　　能随所乐演妙音
    无心计念此与彼　　我为谁说谁不说
    如来面门放大光　　具足八万四千数
    所说法门亦如是　　普照于世除烦恼
    圆满清净功德智　　而常随顺三世间
    犹如虚空无染着　　为众生故而显示
    示有生老病死苦　　亦示住寿处于世
    虽顺世间如是现　　体性清净如虚空
    一切国土无有边　　众生根乐亦无量
    如来智眼皆明见　　随所应化示佛道
    究竟十方虚空界　　所有人天大众中
    随其形相各不同　　佛现其身亦如是
    若在沙门大众会　　剃除须发服袈裟
    执持衣钵护诸根　　令其欢喜息烦恼
    若时亲近婆罗门　　则为示现羸瘦身
    执杖持瓶恒洁净　　具足智慧巧谈说
    吐故纳新自充饱　　吸风饮露无异食
    或坐或立不动摇　　现诸苦行摧异道
    或持彼戒为世师　　善达医方等诸论
    书数天文地众相　　及身休咎无不了
    深入诸禅及解脱　　三昧神通智慧行
    言谈讽咏共嬉戏　　方便皆令住佛道
    或现上服以严身　　首戴华冠荫高盖
    四兵前后共围绕　　誓众宣威伏小王
    或为听讼断狱官　　惩恶劝善多方便
    所有与夺皆明审　　令其欣敬尽钦承
    或作辅弼诸大臣　　善用诸王治政法
    十方利益皆周遍　　了达世间无有余
    或为粟散诸小王　　或作飞行转轮帝
    令诸王子采女众　　悉皆授化奉修行
    或作护世四天王　　或作夜叉龙等主
    各为其众而说法　　一切皆令大欣庆
    或作忉利大天王　　住善法堂欢喜园
    首戴华冠说妙法　　诸天觐仰无能测
    或住夜摩兜率天　　化乐自在魔王所
    居处摩尼宝宫殿　　说真实行令调伏
    或至梵天众会中　　说四无量诸禅道
    普令欢喜便舍去　　而莫知其往来相
    或至阿迦尼吒天　　为说觉分诸宝华
    及余无量圣功德　　然后舍去无知者
    如来无碍智所见　　其中一切诸众生
    悉以无边方便门　　种种教化令成熟
    譬如幻师善幻术　　现作种种诸幻事
    佛化众生亦如是　　为其示现种种身
    如净月轮在虚空　　令世众生见盈缺
    一切河池现影像　　所有星宿夺光色
    如来智月出世间　　亦以方便示增减
    菩萨心水现影像　　二乘星宿无光色
    譬如大海宝充满　　清净无浊无有边
    四洲所有诸众生　　一切于中现其像
    佛身功德海亦尔　　无垢无浊量无边
    乃至法界诸众生　　靡不于中现其像
    譬如净日放千光　　不动本处遍十方
    佛日光明亦如是　　无去无来除世闇
    譬如龙王降大雨　　不从身出及心出
    而能沾洽悉周遍　　涤除炎热使清凉
    如来法雨亦复然　　不从于佛身心出
    而能开悟诸含识　　尽能灭除三毒火
    如来清净妙法身　　一切三界无伦匹
    超出世间言语道　　本性非有亦非无
    虽无所依无不依　　如是无来亦无去
    如空如日亦如梦　　当于佛体如是观
    三界有无一切法　　不能与佛为譬谕
    譬如山林鸟兽等　　无有依空而住者
    大海摩尼无量色　　佛身差别亦复然
    如来非色非非色　　随应而现无所住
    虚空真如及实际　　涅槃法性寂灭等
    唯有如是真实法　　可以显示于如来
    刹尘心念可数知　　大海中水可饮尽
    虚空可量风可系　　无人能说佛功德
    若有闻斯功德海　　能生欢喜信乐心
    如所称扬悉当得　　慎勿于此生疑念


对无上正等正觉的了解，可以归结为对佛功德的了解

    圣普：
    看了zs发的贴子，有发心五相，虽然知道发正愿，行相，所缘，功德，最胜，但就好像知道山西而不知道怎么走一样，有点困惑。
    困惑一、行相中的“无上正等正觉”、佛智，应该如何确切的了解呢？
    困惑二、所缘中提到缘大菩提、缘一切有情义利。虽然知道，可大菩提是什么呢？在缘一切有情时，明显的感受到并不是缘一切有情，或许只缘了地球上的众生而已，其他我看不到的众生，似乎在缘的心力上并没有用上力，问题是在哪里呢？是因为对“一切”的理解不对么？

    zf：
    “在缘一切有情时，明显的感受到并不是缘一切有情，或许只缘了地球上的众生而已，其他我看不到的众生，似乎在缘的心力上并没有用上力，问题是在哪里呢？是因为对‘一切’的理解不对么？”
    ──这个好办。研读道次第中对众生苦的开示，熟悉六趣四生的特点，心量逐渐就会变大的。

    “行相中的‘无上正等正觉’、佛智，应该如何确切的了解呢？”
    ──对无上正等正觉的了解，可以归结为对佛功德的了解。
    这可以从两方面入手：
    一、从“果”的方面
    佛经中从不同方面对佛功德进行过种种归纳，如五智、十力、四无畏、十八不共法、身口意三密等。
    “广本普贤行愿品”中对如来功德进行了概括，应认真体会。
    二、从“因”的方面
    澄观大师在《三圣圆融观门》中言：
    “如来为果。果超言想。（zf注：大正藏电子版中，此处为“果起言想”，有误。）且说二因。若悟二因之玄微。则知果海之深妙。

    澄观大师所言是一个非常重要的开示，即如来果海深妙难思，但我们可以通过如来因地之所行来测度其果德的殊胜。因为相对于如来果地来说，其因地法行对我们凡夫来说毕竟不是那样不可思议。
    《华严初发心功德品》给出了从如来因地了解其果地功德的途径。
    《普贤行愿品》同样是这一路数──
    一、略说如来功德，因为对如来功德的详说几乎不可能（“经不可说不可说佛刹极微尘数劫相续演说不可穷尽”）；
    二、详说成就如来功德的法门──十种广大行愿。
    如果用心体会上述如来因地法行，对其果地之无功用妙德──众生当以何身而度即现何身而度，便也不再那么天方夜谭了。

    圣普:

    随喜，赞叹，谢谢赵叔
    再来一贴，看来愿要发的详细一些好，不能图偷懒

    【发心自性】
    瑜伽三十五卷九页云：复次菩萨最初发心、于诸菩萨所有正愿，是初正愿、普能摄受其余正愿。是故发心、以初正愿为其自性。
    FROM:【法相辞典】

    那什么是正愿呢？

    【正愿五种】
    瑜伽四十五卷十六页云：云何菩萨所修正愿？当知此愿、略有五种。一者、发心愿。二者、受生愿。三者、所行愿。四者、正愿。五者、大愿。若诸菩萨、于其无上正等菩提，最初发心；是名发心愿。若诸菩萨、愿于当来、往生随顺饶益有情诸善趣中；是名受生愿。若诸菩萨、愿能无倒思择诸法；愿于境界，修无量等殊胜善法；是名所行愿。若诸菩萨、愿于当来、摄受一切菩萨善法；摄受一切所有功德；若总、若别、所有正愿；是名正愿。菩萨大愿，当知即从正愿所出。此复十种。若诸菩萨、愿于当来、以一切种上妙供具，供养无量无边如来；当知是名第一大愿。若诸菩萨、愿于当来、摄受防护诸佛世尊所有正法；传持法眼，令无断坏。当知是名第二正愿。若诸菩萨、愿于当来、从睹史多天宫降下，如前乃至入大涅槃。当知是名第三大愿。若诸菩萨、愿于当来、行一切种菩萨正行；当知是名第四大愿。若诸菩萨、愿于当来，普能成熟一切有情；当知是名第五大愿。若诸菩萨、愿于当来、一切世界，皆能示现；当知是名第六大愿。若诸菩萨、愿于当来、普能净修一切佛土；当知是名第七大愿。若诸菩萨、愿于当来、一切菩萨，皆同一种意乐加行，趣入大乘；当知是名第八大愿。若诸菩萨、愿于当来、所有一切无倒加行，皆不唐捐；当知是名第九大愿。若诸菩萨、愿于当来、速证无上正等菩提；当知是名第十大愿。
    FROM:【法相辞典】


功德的积聚：七支行愿

    zf：
    数年前读此书时，蒋贡仁波切下面的开示给我留下极深印象，从此对《普贤行愿品》的信心更强了：
    功德的积聚：七支行愿
    不要认为，你因为没有财富就无法积二资粮。据说，一个人只要有一些信心和智慧，就有令人难以置信的能力可以积功德。你只要以菩提心供养七支行愿，你的一切障碍将可以消除，你所积的功德将如天空广大无际。
    噶胆巴派的大喇嘛，并不作其他修法，只是精进不懈地修持七支行愿。这是大噶举巴（包括冈波巴在内）的惯例。但今天似乎已消失殆尽了。
    在一切显经和密典之中，没有比七支行愿还能更深远地积聚二资粮的。七支行愿所能产生的功德，逐步增加，一支比一支多。献供品所积的功德大于行跪拜；忏悔恶业的功德又大于献供品；随喜善业的功德又大于忏悔恶业，……。
    不管你是选择“七支行愿”的长文或短文念，最重要的是你要思考其意义。光是念，即成笑柄。

    智行：
    一直很喜欢《行愿品》，并一直想以此为主修。但还有另外几部经（8－9部）愚也很喜欢，想立一部为主修，于是在佛前拈阄，三次都是拿到《无量寿经》。初莫明其妙，只是照作。后来发现这不是偶然，《无量寿经》是凡夫入华严的钥匙，包括普贤行愿。所以在下觉得《行愿品》和《无量寿经》一起看很有味道。


罪业忏悔清净了，本具的如来德相也就自然显发了

    妙音42：
    佛在世时，确有许多现因现果，因果关系易观察，成熟期短。而今天长的道理是什么呢？是否业因复杂，果报就复杂？
    末学此世之报就环环相套，一点也解不开，由此可推知当是久远劫前种下的恶因？如是，我心稍平。否则，每由对境想起自己前世曾如此之恶，难过之极也！

    zf：
    浅见

    “但马上见效的原理是什么呢？”
    ──原理就是“一切唯心造”。不过要转变异熟果，必须有极强的心力。

    “佛在世时，确有许多现因现果，因果关系易观察，成熟期短。而今天长的道理是什么呢？是否业因复杂，果报就复杂？”
    ──在下浅见，问题不在业因的复杂上，而在我等善根的浅薄上。

    “末学此世之报就环环相套，一点也解不开，由此可推知当是久远劫前种下的恶因？”
    ──还可能有其他的解释吗？

    “否则，每由对境想起自己前世曾如此之恶，难过之极也”
    ──大家彼此彼此！
    “若此恶业有体相者，尽虚空界不能容受。”普贤菩萨尚如是说，何况我等！
    从这个角度说，忏悔一法也可摄一切法──若罪业忏悔清净了，本具的如来德相也就自然显发了。
    让我们一起忏悔吧！念念相续无有间断，身语意业无有疲厌。


关于一微尘中无量刹

    gladness：
    请教善知识，关于一微尘中无量刹。

    一微尘中的“中”是否可以这样理解──不在内，不在外。
    “观察众生如幻梦。以业力故常流转。”有梦但没有做梦的人。此梦中的一微尘与彼梦中的刹土，难道有位置关系？或者说空间、时间关系？此梦在彼梦的上面？下面？里面？外面？
    不知道理解得对不对？

    zf：
    说点“梦”话。

    “一微尘中的“中”是否可以这样理解──不在内，不在外。”
    ──在下认为，这里的“中”是“内”的意思。而且一微尘内无量刹中的一微尘内还有无量刹。在华严中似乎没有某一个尺度的“微”是不能再小的了。

    ““观察众生如幻梦。以业力故常流转。”有梦但没有做梦的人。”
    ──是，即所谓“唯蕴自轮转”。

    “此梦中的一微尘与彼梦中的刹土，难道有位置关系？或者说空间、时间关系？此梦在彼梦的上面？下面？里面？外面？”
    ──这里对“梦”中物的探讨是站在“醒”者的角度。

    云飞月：
    请教《初发心功德品》中的一句话

    “一切世间唯是想，于中种种各差别，知想境界险且深，为现神通而救脱。”──这一句该怎么理解？尤其是“知想境界险且深”指的是什么？

    zf：
    在下的猜测，80卷华严的这四句颂
    一切世间唯是想，于中种种各差别，
    知想境界险且深，为现神通而救脱。
    在六十卷华严中是：
    一切群生类　种种诸希望　善恶无记法　寂灭如虚空
    随顺众庶类　种种欲乐相　无量自在力　悉能应化之
    综合两译可见，众生之种种希望、欲求乃流转六道之因，特别是恶念实为堕入恶道之门，是为“险”；众生的某些心念甚细，甚至自己都不易察觉，是为“深”。

    gladness：
    再请教，是不是有醒者的角度，但没有醒者。

    zf：
    因为有梦，所以有醒；无梦者，哪来的醒者！

    dawa：
    俺觉得一切都是无尽的……包含，是个时空关系，不离无明……

    zf：
    仁兄先别下结论，

    “包含，是个时空关系，不离无明……”
    ──离了无明就没有时空关系了吗？

    QZ：
    《离了无明就没有时空关系了吗？》──试答ZF叔此问。

    离了无明──这句动宾短语，可以有很多种理解。
    但，无明到底指的是什么呢？
    俺的理解：指的是一种心行运作方式。
    凡夫没观察到以下心行运作方式：无明缘行，行缘识。而在识缘名色之后，才开始发现心。举个例子就像：对于初学者，WINDOWS的显卡没插好的时候，将会出现黑屏。我们会以为电脑坏了，或者电脑不工作了。
    事实上，主板上的其他程序正在有序的运行。显卡并不是最基础的部件，最基础的部件是CPU和主板（当然还得有电）。他们在负责调度其他部件，其他部件的运行以二者的正常运行为基础而生起。比如，空间和时间的观念就是这样，他们在识缘名色的过程中及之后相续中出现。
    无明就像其它因缘法一样，不常不断，所以，说离无明：如果认为无明从此再也没有了，那是断见。所以，倒不如说是依无明显现一切法而于此无染。所以，时空尽管显现，于显现不染就是了。一管之见，请诸位善知识狠批。嘻嘻。

    zf：
    再问：
    “无明就像其它因缘法一样，不常不断，所以，说离无明：如果认为无明从此再也没有了，那是断见。”
    ──缘起者，此有故彼有，此无故彼无。
    无明者，我法之自性执也。众生因增益之自性见而起执，故曰无明；若依缘起正见，照见诸法本无自性，自性之执便无从生起，是为无明灭。
    QZ兄，如是说离无明，是断见吗？

    dawa：
    谢谢赵叔提醒

    话说出去了，自己也觉得不对劲……
    想起了楞严咒心，很惭愧：
    om
    anale anale
    visada visada
    bandha bandha
    bandhani bandhani
    vaira
    vajra pani phat
    hum bhrum phat
    svaha

    zs：
    嘻嘻，不会吧……

    一下就吓回去了？！
    说断绝时空关系，那是落了缘起无的断见，但是，
    可以没有时空感……

    zf：
    回答在下一个问题再笑。

    “说断绝时空关系，那是落了缘起无的断见，但是，可以没有时空感……”
    ──什么叫“无记”？

    zs：
    嘻嘻，答赵叔。

    【无记】
    （术语）三性之一。事物之性体中容，不可记为善，亦不可记为恶者。又感善果不可记，感恶果亦不可记者。俱舍论二曰：“无记者，不可记为善不善性，故名无记。有说，不能记异熟果，故名无记。”唯识论五曰：“于善不善损益义中，不可记别，故名无记。”大乘义章七曰：“解有二种：一对果分别，中容之业不能记得苦乐两报，故名无记。二就说分别，中容之业如来不记为善为恶，故名无记。”
    FROM：【《佛学大辞典》丁福保　编】

    zf：
    【空心静坐】
    （术语）昏住也。六祖坛经曰：“第一莫着空，若空心静坐，即着无记空。”永嘉禅师云：“无记者，虽不缘善恶等事，然俱非真心，但是昏住。”
    FROM：【丁福保《佛学大辞典》】


成就如来化身的因

    zzzm：
    我们学佛为度众生，但众生无尽，永远无尽……那我们不是在干一件永远都不可能完成的事吗？

    zf：
    闲着也是闲着，做点事有什么不好！

    佛智广大同虚空　　普遍一切众生心
    了世妄想皆非有　　不起种种异分别
    一念悉知三世法　　亦了一切众生根
    譬如善巧大幻师　　念念示现无边量
    随诸众生心行异　　往昔诸业愿乐力
    令其所见各不同　　而佛寂然无动念

    如来于无动念间游戏神通，利益无边有情的事业，何等令人羡慕，何来伤心之事？！

    zzzm：
    呵呵，后学不是伤心这个，而是，众生永远无尽，永远有沦落六道的六亲眷属！！

    zf：
    恭喜，您摸着门了！
    “永远有沦落六道的六亲眷属”
    ──这正是成就如来化身的因。


虚空界乃至众生烦恼不可尽故，我此忏悔无有穷尽

    至诚忏悔：
    请问，昨晚诵读《普贤行愿品》有一疑问向各位师兄请教。曾有佛经上说一切众生终将成佛，而《普贤行愿品》上说“如是虚空界尽，众生界尽，众生业尽，众生烦恼尽，我忏乃尽，而虚空界乃至众生烦恼不可尽故，我此忏悔无有穷尽。”既然一切众生终将成佛，为何众生烦恼又不可尽？请指教。

    zf：
    好问题！在下是这样理解的。

    如《大般涅槃经》所宣说，一切众生终将成佛。这一结论听起来好像确实与《普贤行愿品》中众生界不可尽的说法相矛盾。对此“矛盾”本人是这样理解的： 　　　一、一切众生终将成佛，是说众生都有成佛的可能性。
    二、但要将这个可能性变成现实性需要一个过程，包括诸佛菩萨的教诲和众生的发心和修行。
    三、佛经中说，众生是无量无边的，如果用数学的语言来说，众生是个“无穷集合”；同时佛菩萨也是无量无边的，即佛菩萨也是个“无穷集合”。
    四、但从佛经中的开示可以了解到，众生这个“无穷集合”要远远地“大于”　佛菩萨的“无穷集合”。
    五、这两个“无穷集合”相互作用的结果是佛菩萨集合的数量增加，而众生集合的数量减少。
    六、但这并不意味着两个集合的相互作用可以在有限的时间内结束。
    在下认为，“虚空界乃至众生烦恼不可尽故”正是说佛菩萨救度众生的事业在时间上不会于某个特定的时刻最终完成。但这并不意味着某些众生不可能成佛。

    玄兹：
    众生皆有成佛可能。在众生成佛的过程中，尽管所需时间长得不可思议，但由于这是单向性的（成佛后不退堕），所以应该有众生烦恼可尽的时候。

    zf：
    玄兄，我对待这个问题的思路是：
    一、相信众生皆有成佛可能（如《大般涅槃经》所宣说）；
    二、相信普贤菩萨所说“虚空界乃至众生烦恼不可尽”；
    三、在信的基础上去探讨两者之间的相容性。
    四、在您的推断中，因为结论与普贤菩萨所说相矛盾，因此，本人的结论只能是：您推理的前提是错误的。
    五、即使将您推理的前提孤立出来，在下没有足够的理由论证其为错误，本人的结论仍然是：您推理的前提是错误的。
    六、这就是信仰。

    玄兹：
    zf兄，在下的思路以及最后结论是，菩萨佛集合无穷大，众生集合无穷大，再加上无穷大的时间作用，其作用机制非凡夫如在下所能测度。

    zf：
    因此，信佛所说吧。

    空王之子：
    也问，好像经上有讲“众生界不增不减”，这是否意谓着尽管不断地有众生解脱成佛，但众生界在量上不变。

    zf：
    浅见，供参考。

    在下认为，“众生界不增不减”不是说“量”，而是说“质”──因为从胜义的角度，缘起即是无生；因无生故，缘起之法不增不减。

    二麻子：
    嘻嘻，数学来了……

    设有无穷数列　1,2,3，……

    现在我们把数列里面的数，一个一个地拿到　另一个集合｛F｝里去。这样，对任意一个数列里的数，比方10000，它早晚会被放到集合F里去──一切数字早晚成F成员。但是，数列并没减小！这个没减小的意思可以参考集合论。同样的可以说F集合没增。
    嘻嘻。数学都可以做到的事，佛与众生界一定更能做到。

    空王之子：
    确实，这段佛理可折伏数论专家，“对任意一个数列里的数”似应表述为“对数列里任意一个数”。

    二麻子：
    嘻嘻。是。你这个表达更严密。


随顺众生的目的

    信愿行：
    请问周围的人所做不合法律规定，侵害别人权益，这样的人又比较多，是恒顺众生，只管自己呢？还是公开反对这种做法呢？

    zf：
    一、换个单位；
    二、洁身自好。随顺众生的目的是利益众生，而不是任其作恶。当然这不是我等初学所能做到的。

    江边有鸟：
    可以这样理解吗？恒顺众生是以众生能接受的方式去利益众生。恒顺众生是以众生能接受的方式使众生离苦得乐。

    zf：
    顺的目的是转。“于失道者示其正路”。


天无绝人之路

    天无绝人之路

    zf

    如果说回向是以所修功德为前提，您自认为没有什么功德，是故不配用以庄严净土，这种心情在下可以理解。
    此路不同，还有他途。
    看看这个怎样。
    尝试着在心里发“烦恼无尽誓愿断”这一大愿。
    人们常常不敢发愿，特别是不敢发大愿，担心实践不了，成为空愿。这里面可能有误会。
    实际上，愿望的目标肯定是我们目前无法达到的。也只有因为现在无法实现，才要发愿将来通过努力来达到。例如通常每个家长都会用心照料孩子，因此家长们根本没有必要常发“悉心关照儿女愿”。
    类似“烦恼无尽誓愿断”这样的大愿，通常都不是即生或几生可以圆满的，可能要在无数劫后经过艰苦的努力才能实现。但从因果的角度看，今后历生的修行都是以当初一念发心为起点的。没有发心就不可能有今后的身体力行，而只要有了真切的发心，纵使现世在行动上没有任何起色，这一修行的种子在来世因缘合和时也会发芽，并最终结出果实。因此在发大愿这个问题上，我们应该把目光放的长远些，不必一定要计较现世的结果。因果不虚。
    发“烦恼无尽誓愿断”这愿者，目前心中肯定有或多或少的烦恼，并且无力斩断或断净。
    如果说回向您自己觉得不配，发“烦恼无尽誓愿断”这愿您还觉得不配吗？

    （编按：本篇是奉心居士对一个网友觉得自己在抄经等时，因为自己过去的不如法行为而“不配有功德”，所以不想进行功德回向的情形的一个答复。）


与普贤行愿相应

    云飞月：
    请问ZF叔，怎样成就普贤行愿？
    看ZF叔的贴，如果后学没有理解错的话，那就是：深心信解如己之愿，读诵受持见修即到。问题是，凡夫做到了这一点，还是不能像普贤菩萨一样深入法界、显现不可思议的行愿力，是否要等到往生西方极乐世界以后，才能圆满这样的行愿力，才能如《初发心功德品》所说一样，遍现微尘数世界，上供诸佛、下化众生？

    zf：
    “如果后学没有理解错的话，那就是：深心信解如己之愿，读诵受持见修即到。”
    ──是的。
    但能真正“受持”普贤行愿（用密乘的话说就是与普贤行愿相应），却也不是对任何人来说都能一蹴而就。依在下浅见，了解华严宗古德所开示的“周遍涵容”见，对受持普贤行愿有极大的帮助。

    “问题是，凡夫做到了这一点，”
    ──能做到这一点者还是凡夫吗？

    “还是不能象普贤菩萨一样深入法界、显现不可思议的行愿力，”
    ──若真能做到与普贤行愿相应，一定可以显现不可思议的行愿力。

    对于很多行人来说，佛法在悄悄地发挥着神奇的作用，乃至行人自己都无法察觉。
    如大悲陀罗尼经中言：“若诸人天诵持此陀罗尼者。其人若在江河大海中沐浴。其中众生得此人浴身之水沾着其身。一切恶业重罪悉皆消灭。即得转生他方净土。莲华化生。不受胎身湿卵之身。何况受持读诵者。若诵持者行于道路。大风时来吹此人身毛发衣服。余风下过诸类众生。得其人飃身风吹着身者。一切重罪恶业并皆灭尽。更不受三恶道报。常生佛前。当知受持者福德果报不可思议。诵持此陀罗尼者。口中所出言音若善若恶。一切天魔外道天龙鬼神闻者。皆是清净法音。皆于其人起恭敬心。尊重如佛。”
    又如宝箧印陀罗尼经言：“若人往在高山峰上至心诵咒。眼根所及。远近世界。山谷林野江湖河海。其中所有毛羽鳞甲一切生类。碎破惑障觉悟无明。显现本有三种佛性。毕竟安处大涅槃中。若与此人往过道路。或触衣风或踏其迹。或唯见面或暂交语。如是等人重罪咸灭悉地圆满。”
    密法如是，普贤行愿的威神力亦复如是。

    “是否要等到往生西方极乐世界以后，才能圆满这样的行愿力，”
    ──这要看行人与普贤行愿的相应程度了，按普贤行愿品的法义，“是诸人等于一念中所有行愿皆得成就”，这是说，普贤行愿有在一念间完成的可能。

    另，华严经中普贤菩萨言：
    “佛子。菩萨摩诃萨。亦复如是。修习普贤菩萨行愿。及诸三昧。以为众宝庄严之具。七菩提分。为菩萨身。所放光明。以之为网。建大法幢。鸣大法钟。大悲为窟。坚固大愿。以为其牙。智慧无畏。犹如师子。法缯系顶。开示秘密。到诸菩萨行愿彼岸。为欲安处菩提之座成一切智。得最正觉。增长普贤广大行愿。不退不息。不断不舍。大悲精进。尽未来际。度脱一切。苦恼众生。不舍普贤道。现成最正觉。现不可说不可说成正觉门。现不可说不可说转法轮门。现不可说不可说住深心门。于不可说不可说广大国土。现涅槃变化门。于不可说不可说差别世界。而现受生。修普贤行。现不可说不可说如来。于不可说不可说广大国土。菩提树下。成最正觉。不可说不可说菩萨众。亲近围绕。或于一念顷。修普贤行。而成正觉。或须臾顷。或于一时。或于一日。或于半月。或于一月。或于一年。或无数年。或于一劫。如是乃至不可说不可说劫。修普贤行。而成正觉。”
    从上面的经文中可以看到，菩萨“或于一念顷。修普贤行。而成正觉。或须臾顷。或于一时。或于一日。或于半月。或于一月。或于一年。或无数年。或于一劫。如是乃至不可说不可说劫。修普贤行。而成正觉。”可能有人会想，这些都是菩萨的示现。但在下认为，菩萨之所以做此示现，目的在于引导众生随学，如根本没有于一念顷圆满普贤行的可能，则菩萨的示现便成为纯粹的卖弄。

    诺瓦：
    请问阁下，如果有人曾经的确是证悟了那种智慧圆满之法，身心受控，并觉到达彼岸之乐，可是最终仍旧抵抗不住人性固有的本能，导致悟觉倒退，不能操控身心，懊悔不已，他能否还有机会回归乐土呢？
    我的感觉是：内心越是到达纯净的境界，身心越是健康，人性本能就越强烈……

    zf：
    “如果有人曾经的确是证悟了那种智慧圆满之法，身心受控，并觉到达彼岸之乐，可是最终仍旧抵抗不住人性固有的本能，导致悟觉倒退，不能操控身心，懊悔不已，”
    ──这是不可能的。
    最值得怀疑之处是“的确是证悟了那种智慧圆满之法”。

    “他能否还有机会回归乐土呢？”
    ──恐怕要重新做起。
    原来的那个“乐土”不可靠。

    “我的感觉是：内心越是到达纯净的境界，身心越是健康，人性本能就越强烈……”
    ──“纯净”的背后可能就是污垢，不过没发现而已。


学习《华严经入法界品》

    缁逊：
    《华严经入法界品》看不懂急得直出汗……

    zf：
    我等初学者今日学习《华严经入法界品》目的当集中于下面两点： 　　一、善财童子从发心始直至成佛，不断参访善知识的精神。（值得注意的一点是，新参访的每位善知识都由前面一位介绍，深思。）
    二、最后由普贤菩萨开示《普贤行愿品》应成为学习的重点。
    今人知道行愿品者不少，对此品亦有详细的注释，但不读入法界品（读全经更佳），则无法体会行愿品的极端殊胜！行愿品现常被视为入大乘的入门读物，实际上，华严经王的精髓皆浓缩在此品经中，万万不可轻视。
    入法界品中其他菩萨所开示的法门，许多没有传下来，理解起来自然十分困难。


诵经与思维

    鼓雷：
    思维是非常有力的工具，可能见效慢，但是后劲极大，拦都拦不住。
    思维时就可感受到一种力量，感觉上是信心的力量，随着时间的增长，这种力量会越来越大。信心会大长，专心程度也提高。逐渐逐渐地，会把原来不敢接受的佛经中的一些说法认为是当然如此的（虽然理解上可能还有相当的差距）。
    个人见解，见笑了

    rj：
    哈哈，好帖！进一步若能思维思维之缘起，力量更大！再进一步，莫把思维当思维看，登地近在咫尺！赞叹鼓兄！

    鼓雷：
    说到思维，您说的我还不太懂，但最近又看了一下《佛陀的启示》中讲五蕴的地方，很有启发。大概意思是这样的：
    思维以外没有思维者，思维者就是思维本身。说生命是运动的是不对的，因为生命就是运动本身。
    又想起善知识传授的窍诀：
    无有造作者。亦无受报人。
    唯蕴自轮转。此是正知见。

    而蕴也是缘起的，五蕴的缘起也不在五蕴之外，解脱的缘起也不在五蕴之外。

    rj：
    随喜赞叹！好！

    圣普：
    我也是用思维的，有点感悟时，我宁肯停下来思维……
    由于无明，众生总是局限于少许因缘法，而对广大境界有所疑惑，有感悟时，正是破疑惑时，思维通了，这对增长信心极为重要！以后再读时，就不用打磕巴了，一念带过，以深信心的行持，一念及获经中所述无量功德。
    若人于此普贤愿，读诵受持及演说，果报唯佛能证知，决定获胜菩提道。
    若人诵持普贤愿，我说少分之善根，一念一切悉皆圆，成就众生清净愿。
    以于众生心平等故，则能成就圆满大悲，以大悲心随众生故，则能成就供养如来

    鼓雷：
    “为了信心及功德增长”“要因诵经获得无量功德”与“无所得”“无所求”“无自性”“缘起”无碍。大大方方说“为让一切众生成佛而自己成佛”“为了成佛多捞功德，多攒资粮”，非此愿里有我执，实乃我等学人我执未破而处处皆沾我执也。有我执也不用怕，深切发大愿常发愿还怕破不了吗？

    zf：
    所说甚善！
    “有我执也不用怕，深切发大愿常发愿还怕破不了吗？”
    ──《初发心功德品》中言：
    “诸佛色相庄严身，及以平等妙法身，智慧无著所应供，悉以发心而得有。”
    可见即使对“平等妙法身”的证得，即对我法二执的破除，大愿──即菩提心也是根本因。

    鼓雷：
    惭愧惭愧。不敢当，佛敢当，但是您的夸奖可是不敢当。惭愧

    酸菜粉条：
    谬矣！谬矣！

    “‘为了信心及功德增长’‘要因诵经获得无量功德’与‘无所得’‘无所求’‘无自性’‘缘起’无碍。”
    ──“无自性”“缘起”可以毋论；若有求之心与无得之理，亦但许你理上无碍，事上依然相违分明。

    “……非此愿里有我执，实乃我等学人我执未破而处处皆沾我执也。”
    ──是呀！譬如说，不是暴力、色情片会让人犯罪，实乃受了彼等蛊惑的犯罪人血气不定之故！

    “有我执也不用怕，深切发大愿常发愿还怕破不了吗？”
    ──不是怕破不了，而是怕尔说得行不得也！

    zf：
    “理上无碍”已经是极高的夸奖了！雷兄还不赶快谢过！不过粉条兄，您已经自许事上无碍了吗？？？

    “不是怕破不了，而是怕尔说得行不得也！”
    ──若连说尚且不敢，如何行得！
    在下对“普贤行愿”的理解是“发起实践普贤行的愿”。愿在行前，应该合情合理吧！

    鼓雷：
    哪敢言谢呀，理上无碍也忒猛了。
    多谢赵叔出招。赵叔虽让言谢，可后学哪敢接呀。理上无碍实在是让人羡慕死了。
    咱现在可不是理上无碍，理上不解的地方多了，而且必定还有很多未发现之处。所以本人目前奉行“信上不管”政策，即百分之百相信，佛说的肯定无碍，不可能有碍，尘许有碍也绝对没有，如果觉得有碍，那一定是自己的问题。
    虽然未必解得了，这一剑我也未必挡得开，但有您让我披上的“信”铠甲在，倒也伤不得。


略谈普贤行愿品和大圆满的共和不共之处

    rj:
    真实平等和差别是学人的名相，实质是站在不同的角度看的，所谓佛父佛母而生佛子。普贤行愿品和大圆满的共和不共之处是什么呢？

    zf:
    这个问题恐怕只有同时精通华严和大圆满见、修、行者才能圆满地回答，在下实在是力不从心。
    本人下面的一点粗浅理解或许可供仁兄参考。
    一、两者的共同之处——同为即身成佛乃至当下成佛的殊胜法门。
    华严乃如来之真实法轮，其境界之深广已达极致，普贤行愿品又为华严见修窍诀之浓缩，怎样称赞都不为过。大圆满在宁玛巴心中为九乘佛法之顶，见修行体系完备，历代大成就者辈出，其殊胜可想而知。
    二、最大的不同之处
    大圆满为密乘法门，特别是其修法的实践必须有具格上师的灌顶和传授。
    普贤行愿品并不是通常所谓之密法，因此依之修学并不需要如密乘般的灌顶和传授（但这并不意味着善知识的指教是不重要的）。其实，与普贤行愿品中的法义真实相应并不容易，华严之见是必须的，而华严之见又以中观见为基础。因此除了个别特殊根器者，“顿”还是离不开脚踏实地的“渐”。
    顺便说一句，因为历史和文化方面的原因，殊胜的华严体系的修法（如普贤行愿品）由于它的“非密乘性”，可能对某些汉地佛子更具有亲和力。华严作为一个独立的宗派出现在汉地应该不是没有原因的。


《行愿品》和《净行品》，《金刚经》

    钱昭：
    关于“念颂普贤行愿品时，如果能认真思维，可以加大我们在日常生活中用上佛知见和佛所行的力度。所以，念颂时的思维极为重要。”
    我觉得《净行品》对日常生活的指导意义更强些，我喜欢把《行愿品》和《净行品》配合着一起念。

    nkdj：
    看到钱兄的话【我觉得《净行品》对日常生活的指导意义更强些】，感觉意犹未尽，何不多说几句？兄弟洗耳恭听。

    zs：
    嘻嘻……其实也应该配合《金刚经》
    《金刚经》启始有一段话，“须菩提，诸菩萨摩诃萨，应如是降服其心。所有一切众生之类，若卵生若胎生若湿生若化生若有色若无色若有想若无想若非有想非无想，我皆令入无余涅槃而灭度之。如是灭度无量无数无边众生，实无众生得灭度者。”这段话就是诸佛菩萨所持见以及所行。只是，金刚经更多的是从见的角度开显，而〔所有一切众生之类，若卵生若胎生若湿生若化生若有色若无色若有想若无想若非有想非无想，我皆令入无余涅槃而灭度之。〕应怎么做，没有明确展开，而普贤行愿品是恰恰是展开了这一部分。所以，我觉得，金刚经和普贤行愿品配合读颂思维，应该是相得益彰的事情。
    前天去居士林，巧得很，正好有一本由北京佛教居士林出的折子本，是金刚经和普贤行愿品合印的，印刷精美大小合适，十元一本。其实念颂的同修可以请一本，很方便。


若想潇洒解脱，修学普贤行愿

    若想潇洒解脱，修学普贤行愿

    zf

    关于自杀的巨大恶果，诸兄文中解说得十分清晰，在下读后深有收获。本人没有受过（自然也没有修过）颇瓦法，但据在下理解，对我们普通修行者来说，颇瓦法只能在临命终时使用。想用颇瓦法去“自杀”的人，若将此想法告诉其传法上师，得到的回答一定是一顿臭骂。
    至于大成就者，以无碍神通了知自己应化因缘已尽，最后应向众生示现解脱自在，如汉地隐峰禅师、庞居士等，于谈笑之间坐脱立亡，自当别论。成就者们的所为与“自杀”二字毫不相干。
    在下体会，龙猫兄最初所问的本意是想寻找一条“潇洒”的解脱之路。这到让在下想起了自己当年学佛的一段经历。
    十多年前刚开始学佛时，首先学习的就是净土诸经。当时没有师父，麻兄和我们几个好友就一起学习经论。经过仔细分析研究，结合自己的实际情况，我确定了“下品下生”的目标，因为下品下生也是彻底解脱轮回。自己修行的主要方法就是执持佛号，希望临命终时，心不颠倒，弥陀来接。由于感到命终之时心不颠倒甚为不易，是故一方面用力念佛，但在心里深处一直希望找到一种即使命终之时自心颠倒也能往生的方法（现在看来，这种想法纯属多虑，因为只要平时功夫到，命终之时内心自然不会颠倒）。
    一日，研读《普贤行愿品》，读到了下面这段文字：
    是故善男子！汝于此义，应如是知。若有善男子、善女子，以满十方无量无边不可说不可说佛刹极微尘数一切世界，上妙七宝，及诸人天最胜安乐，布施尔所一切世界所有众生，供养尔所一切世界诸佛菩萨，经尔所佛刹极微尘数劫，相续不断，所得功德；若复有人，闻此愿王，一经于耳，所有功德，比前功德，百分不及一，千分不及一，乃至优波泥沙陀分亦不及一。或复有人，以深信心，于此大愿，受持读诵，乃至书写一四句偈，速能除灭五无间业。所有世间身心等病，种种苦恼，乃至佛刹极微尘数一切恶业，皆得消除。一切魔军、夜叉、罗刹、若鸠槃茶、若毗舍阇、若部多等，饮血啖肉诸恶鬼神，皆悉远离。或时发心，亲近守护。是故若人诵此愿者，行于世间，无有障碍。如空中月，出于云翳。诸佛菩萨之所称赞，一切人天皆应礼敬，一切众生悉应供养。此善男子，善得人身，圆满普贤所有功德。不久当如普贤菩萨，速得成就微妙色身，具三十二大丈夫相。若生人天，所在之处，常居胜族，悉能破坏一切恶趣，悉能远离一切恶友，悉能制服一切外道，悉能解脱一切烦恼。如师子王摧伏群兽，堪受一切众生供养。又复是人临命终时，最后刹那，一切诸根悉皆散坏；一切亲属悉皆舍离；一切威势悉皆退失；辅相大臣、宫城内外、象马车乘、珍宝伏藏，如是一切无复相随。唯此愿王，不相舍离，于一切时，引导其前。一刹那中，即得往生极乐世界。到已即见阿弥陀佛、文殊师利菩萨、普贤菩萨、观自在菩萨、弥勒菩萨等。此诸菩萨，色相端严，功德具足，所共围绕。其人自见生莲华中，蒙佛授记。得授记已，经于无数百千万亿那由他劫，普于十方不可说不可说世界，以智慧力，随众生心而为利益。不久当坐菩提道场，降服魔军，成等正觉，转妙法轮。能令佛刹极微尘数世界众生，发菩提心，随其根性，教化成熟，乃至尽于未来劫海，广能利益一切众生。
    这段经文当时给了我巨大的震撼。以下三点特别吸引在下：
    一、强调平时用功，弱化命终时的要求。
    如经中所说，若人诵此愿者，临命终时，最后刹那，唯此愿王，不相舍离，于一切时，引导其前，一刹那中，即得往生极乐世界。这就是说，只要我们平时依经修学，命终之时，无论自心是否颠倒，此愿王都不相舍离，于一切时，在我们面前而为向导，将我们引入极乐。“于一切时，引导其前”是这一开示的关键。
    二、不用弥陀来接，依愿王力，一刹那中，自己投生极乐。这种往生方式，相对如来迎接，更加“潇洒”。
    三、到已即见佛，相当于上品上生。
    因为认识到普贤行愿品的这些殊胜之处，自己的修学重点就慢慢转到了普贤行愿的修持上来。开始时自己是把普贤行愿作为往生资粮来修，后来逐渐尝试着依其发心，不知不觉间竟走到了修学菩提心的路上。真是“如染香人，身有香气”。
    时至今日，普贤行愿品仍是在下最常读诵的佛经之一。
    罗嗦了这些话，只想对龙猫兄说一句话：若想潇洒解脱，修学普贤行愿。


关于《大方广佛华严经普贤行愿品别行疏钞》

    zf：

    多谢布施大法宝《大方广佛华严经普贤行愿品别行疏钞》，此疏钞中融入两位祖师的智慧，是我等研修普贤行愿品的最权威参考书！希望大家高度重视，赶快下载！

    （编按：《大方广佛华严经普贤行愿品别行疏钞》（书名）又云行愿品随疏义记。六卷，唐宗密大师著，解清凉大师澄观著行愿品疏者，以下为中华佛教百科全书所载澄观大师和宗密大师的词条）

    【澄观大师】
    华严宗第四祖。世称清凉国师、华严疏主。俗姓夏侯，越州山阴（今浙江绍兴）人，生于唐玄宗开元二十五年（737），十一岁时，从本州宝林寺霈禅师出家，肃宗至德二年（757），从妙善寺常照受具足戒。乾元年间（758～759）依润州栖霞寺醴律师，学相部律；后回本州，依开元寺昙一受南山律学；更往金陵依玄璧，受学关河的三论。代宗大历元年（766）在瓦官寺听受《大乘起信论》及《涅槃经》。又从淮南法藏学新罗·元晓的《大乘起信论疏》。随后又到钱塘（今杭州）天竺寺听华严宗法诜讲《华严经》。大历七年（772）又往剡溪从成都慧量重新研究三论。大历十年往苏州从天台宗学者荆溪湛然学天台止观及《法华》、《维摩》等经疏。又走谒牛头慧忠、径山道钦及洛阳无名，咨决南宗的禅法。更从禅僧慧云，探习北宗的禅理。他一方面广学律、禅、三论、天台、华严各宗的教义；一方面还研究佛教以外的各种学问。
    大历十一年历游五台、峨嵋诸山，后仍回五台，住大华严寺，行方等忏法。同时应寺主贤林之请，讲《华严经》，感觉《华严经》的旧疏文繁义约，发愿撰新《华严经疏》，从德宗兴元元年（784）正月开始，到贞元三年（787）十二月，历时四年，撰成《华严经疏》二十卷，即是现行的《大方广佛华严经疏》。然后在本寺及崇福寺一再讲演。又为弟子僧睿等作新疏的演义数十卷，即是现行的《大方广佛华严经随疏演义钞》（后世把疏、钞合刻，略称《华严经疏钞》）。故有华严疏主之称。
    贞元十二年朝廷召他到长安，协助罽宾沙门般若翻译南印度乌荼国送来的《华严经》后分梵本，由他加以审定，到十四年译成四十卷，也题名《大方广佛华严经》，世称《四十华严》。又诏令他作疏解释，于是在终南山草堂寺撰成《贞元新译华严经疏》（又作《华严经行愿品疏》或《普贤行愿品疏》）十卷。次年，为德宗皇帝讲《华严》，被授以‘清凉国师’的称号。不久又参与翻译《守护国界主陀罗尼经》，由他证义。以后顺宗、宪宗、穆宗、敬宗各朝，他都很受尊敬。文宗开成三年（838）三月圆寂，年一〇二岁。后世尊他为华严宗四祖。

    【宗密大师】
    唐代名僧。为佛教史上重要的佛教思想家。俗姓何，果州西充（今四川省西充县）人。少时，通儒书。宪宗元和二年（807）二十八岁，将参加贡举考试，偶然造谒荷泽神会系下的遂州大云寺道圆，言下相契，便从他出家，当年从拯律师受具足戒。有一天随众僧赴斋，受得《圆觉经》，读罢有悟，回去向道圆陈述。道圆即印可他当大弘圆顿之教，于是授与《华严法界观门》。元和五年（810），游方到襄汉，在恢觉寺遇澄观弟子灵峰，授与澄观所撰《华严经疏》及《随疏演义钞》，昼夜披寻，认为此疏辞源流畅，幽颐焕然。于是作书寄疏主澄观遥叙弟子之礼，并述所领解，遣弟子玄圭、智辉送往。澄观答书称赞，希望见一面印证所解。他就亲自到长安礼觐。这时宗密三十二岁，澄观已七十四岁。自后二年间，昼夜随侍。元和十一年（816）春，在终南山智炬寺，遍阅藏经三年，撰《圆觉经科文》、《圆觉经纂要》各一卷。后来入长安，住兴禅寺。穆宗长庆元年（821）正月，游清凉山，回到鄠县（属陜西省，在长安县西南），住终南山草堂寺，起草《圆觉经疏》。后到丰德寺，撰述《华严经纶贯》五卷，阐明《华严经》的关节次第。入草堂寺南的圭峰兰若，诵经修禅。太和年中，文宗邀入内殿，问佛法大意。赐紫方袍，敕号大德。以后又累次诏入内殿问法。朝臣及士庶归崇的也很多，特别是宰相裴休常受他的教旨，深入堂奥。武宗会昌元年（841）正月，在兴福塔院圆寂，年六十二岁。宣宗即位（847），追谥‘定慧禅师’，世称圭峰禅师，尊为华严五祖。他的著述现存的有《华严经行愿品疏钞》六卷、《华严经行愿品疏科》一卷、《注华严法界观门》一卷、《注华严法界观科文》一卷、《原人论》一卷、《华严心要法门注》一卷、《圆觉经大疏》十二卷、《圆觉经大疏释义钞》十三卷、《圆觉经大疏钞科》中下二卷、《圆觉经略疏》四卷、《圆觉经略疏科》一卷、《圆觉经略疏之钞》十二卷、《圆觉经道场修证仪》十八卷、《金刚经疏论纂要》二卷（会入《金刚经疏记科会》）、《佛说盂兰盆经疏》二卷、《起信论疏注》四卷（会入《起信论疏笔削记会阅》）、《禅源诸诠集都序》四卷、《中华传心地禅门师资承袭图》一卷（裴休问，宗密答）。


只要平时精进修行，心中便应无所畏惧

    oliver：
    龙树菩萨讲临终有一念嗔心，即下地狱。请问如果修学普贤行者，万一临终有恶念，怎么办？

    zf：
    心识如毛，业如风。修行之人应尽量增强往生极乐之“西风”──菩提业风，同时尽量减弱“东风”──轮回业风。两风相遇，心识之毛自然随强风而行。是故观察自己平时心中东西风的强弱，临终时的情形就应该知道个大概。
    如果行人平时大部分时间里，心中西风压倒东风，临终一念东风做主，情况会怎样？依龙树菩萨所说，此人应即下地狱。但此人下地狱后情况可能会怎样？对此，oliver兄一定很感兴趣。
    《佛顶放无垢光明入普门观察一切如来心陀罗尼经》中，如来宣说“佛顶放无垢光明入普门观察一切如来心三摩耶陀罗尼”后，有如下开示：
    若诵百千遍。命终之时被焰魔使以索系颈。牵入焰魔罗界。彼界之内一切地狱悉皆破坏。返生怖畏。寻令回还而得解脱。谓彼行人法王之使。住静虑道无有疑惑。欲生安乐世界随愿往生。
    仔细考察上述开示，耐人寻味。
    行人诵此神咒十万遍，命终之时还可能被焰魔使以索系颈，牵入地狱。经中未明说此行人被牵入地狱的原因，在下猜测，多半是临终恶念做主的缘故。但令我等意想不到的是，此人入地狱后，非但没有尝受地狱之苦，反将地狱之内一切悉皆破坏。将其牵入地狱的焰魔使者，反而心生恐怖，立即将此人放回，并说此人乃如来的使者。此人随即解脱，往生极乐。
    勤修佛顶放无垢光明入普门观察一切如来心三摩耶陀罗尼者有此功德，在下坚信，勤修普贤行愿、六字大明咒、大悲咒等真言者同样会有这样的功德。
    是故只要平时精进修行，心中便应无所畏惧


将自己溶入普贤行愿中

    笨鸟：
    座上的普贤行愿是用广大无碍的愿海浸泡自己吗？

    zf：
    也可以说，将自己溶入普贤行愿中。


普贤行愿与净土法门

    huyg：
    请教，
    愿我临欲命终时、尽除一切诸障碍。面见彼佛阿弥陀、即得往生安乐刹。
    我既往坐彼国已、现前成就此大愿。一切圆满尽无余、利乐一切众生界。
    “一切圆满尽无余”是不是成佛？

    zf：
    仁兄，除证得无上正等正觉之佛外，谁还堪称“一切圆满尽无余”？

    rj：
    huyg想说的可能是净土法门把普贤行愿包括了，就是说连普贤菩萨也要通过净土法门成佛。

    zf：
    说净土法门把普贤行愿包括了，没错。说普贤行愿把净土法门包括了，也没错。别忘了，普贤菩萨除发愿往生极乐外，还授记“是故汝等闻此愿王莫生疑念。应当谛受。受已能读。读已能诵。诵已能持。乃至书写。广为人说。是诸人等于一念中所有行愿皆得成就。”这分明是说，当机之行人可能于一念中成就所有普贤行愿。如是不必离此土即达极乐净土。
    阿弥陀佛以净土法门利生又何尝不是普贤行啊！

    木樨香：
    赵叔能不能趁热打铁，进一步阐述心、佛、众生三者的关系。广大无碍的空和细如粉尘的有之间的关系。极乐世界和娑婆世界的关系。

    zf：
    仁兄出的题目都是大题目，非在下轻易说得清楚。关于“广大无碍的空和细如粉尘的有之间的关系”，在下推荐济群法师的著作《心经的人生智慧》，说理透彻，深入浅出。至于“心、佛、众生三者的关系。极乐世界和裟婆世界的关系”，有志者若能深入华严宝山，定不会空手还。

    huyg：
    有位师兄说往生极乐后并不能在极乐世界成佛，在下想起行愿品这两句，不敢妄解，特来请教。

    zf：
    当行人之普贤行愿圆满时，便具有了众生当以何身而度即现何身而度的功德。那时，对于当以佛身而度者便可自然显现佛身以度之──哪里需要并因缘成熟，便在哪里显现。


关于华严法界观的学习体会

    gladness：
    提议再次发起有关普贤行愿品与初发心功德品修学的新一轮讨论，有不少师兄在五一期间又充了电了。希望大家把心得、体会、问题都摆上来。这样可能会有比较全面的相关文字保留下来。而且这种形式又比较轻松、有趣，容易吸引读者，引发兴趣。怎么样，弟兄们都同意吗？

    nkdj：
    谈点“一即一切”和通常的概念。
    ──【一即一切，一切即一】这样的华严法界观，对在下来说当然是高难的。想想通常的概念，我们说一个人、一件事、一样东西等等。虽然我们可以很清楚所指，但是仔细从概念上考究起来，我们却无法绝对严格的定义所说的人、事、物等。
    比如一个人来说，很清楚，不把他身上的衣服袜子算作是他的一部分，这个没问题。但是他呼吸的空气算不算呢？已经进到肺部和血液里的气体算他的一部分嘛？他的头发、头皮屑、指甲等等呢？经常更新的呀。。还有大小便，出来之前还在肚子里呢……就算我们不考虑他消化道里的东西，包括各种寄生虫等等，但是他必定和外界有交换，这是无可否认的。既然有交换，有更新，所以我们发现自己甚至根本不可能通过某种方式或定义，严格的将这个人的肉体同外界截然分开。但是我们仍然大体上可以分开，于是不妨碍我们进行各种判断。
    一件事也如此，这里我们就从时间的角度来看，不说空间上如何划分。首先我们得有钟表来标志发生和结束的时刻，那么再好的钟表都是有误差的，不可能绝对精确的，这是其一。其二，拿吃一顿午饭来说，从哪里算起又到哪里结束呢？如果从坐下到最后离坐算起，那么坐和起本身都是一个过程，嘿嘿，这又是另外一件事了。仔细想想，我们真的无法绝对精确的划分一件事情，在时间刻度上就作不到的。
    再说一件物品，比如是个桌子这样的，看起来不会和人那样与外界有交换了。但是仔细想想，还是一样有问题。按照现代科学，物质是由原子分子组成的，它们也没办法和外界截然分开，跑出一两个原子分子不奇怪，环境里的杂物尘埃落上去也正常得无法避免，就是放在高度真空环境里，这些还是无法避免。而且，无论如何，它避免不了辐射和吸收。因此，从我们通常的物质观点上，就可以确信，无法把它截然和外界分开。甚至于它的大小也是一个无法严格定义的概念，因为这依赖于你的尺子，而一方面我们是不可能用精确到纳米的尺度去度量一张桌子的长度；另一方面，如果到那个尺度，嘿嘿，我们就要面对原子集团的形状了。好比我们说海岸线有多少公里，这是用公里的尺度来说的，但是如果换成米的尺度，长度马上就陡增，再用毫米的尺子去量……最后，海岸线无限长了。
    既然前面的这些宏观尝试是失败的，那微观怎么样？电荷不是精确的嘛？静止质量不是精确的嘛？光速不是精确的嘛？问题没有那么简单。我们可以拿电子的电荷和光速等物理量作为我们的定义单位，同时我们真正在实验上可以了解到的量，都是有实验误差限制的，误差范围内是什么样子，我们不知道。也就是说，现实是我们不可能绝对精确的知道一个物理量。所以这里要小心，因为在通常的物理观念上，我们可能认为诸如此类的量，我们虽然在实验上受条件限制，但是我们相信它是一个独立存在的量，并且我们可以通过提高实验精度逐步来逼进它们。而在下要表达的是，根本没有这样独立存在的量。因为这样的独立存在，意味着它可以和外界截然分割开来，这些量成为它自己的特有属性，这就是说它有自性，这和佛法相违背。任何一法根本不可能不依赖于条件而成立。事实上，如果真可以独立存在，我们是无法观测到这个独立存在的，我们从来不可能将观测和客体截然分割。
    现在我们明确，我们上面基本都是从世俗所说的概念角度出发，而且已经得出结论，无法精确的给事物划分界线，使其同外部环境截然分开。我们还要明确，这些分析并不妨碍我们处理事物，为什么呢？因为我们从来没有这种需要，我们从来是身处其中的。但是我们往往以为可以精确的划分自、他，这是我们错误的自性见，是应该摒弃的。
    再说一切。通常我们面临的问题是某一些事物或者人的总体，这个集合就是我们所考虑问题的全集，我们往往称为【全部的XX】。这个全体，我们也可以把它看作一个个体，这就无外乎上面所说的了。但是当我们试图把所有的都考虑进来的时候，也就是无一例外的情形，麻烦出现了，这个情形实际上是我们难以想象的，和通常所谓的那个【全部】是不一样的，那个【全部】实际上是【无一例外】的局部，虽然按照上面所说，这个局部没有办法明确划分。这时候，对我们来说，似乎【无一例外】才是一个好概念，这个似乎好理解，而真正的无一例外的全体太难以想象了。那么，进一步，我们可以认为所谓的【无一例外】就是这个全体的定义。
    到这里，我们需要对习惯使用的数学语言说两句。在那里，比如一个三维的空间就是我们的全体，空间一个点是一个精确的点，可以用坐标来描述。但是，我们只是借助于数学工具来描述我们所生活的世界，而不要把这种所谓的【精确】当真。这种【精确】是龟毛兔角，纯粹源于我们的妄想。别为这个伤脑筋，如果自、他可以符合这种【精确】，就一定会有自性了，所以这当然是不可能的了。
    我们还需要说明，以上这些世俗的概念，本身就会有些问题。因为按照《华严经》的《普贤菩萨行愿品》里，【我于一念入三世】【三世所有一切劫】【为一念际我皆入】，普贤菩萨有这样的行愿力，这说明时间不是实有的，空间也不是实有的，都是我们的幻象。不会有独自成立的时空，一切现象本来就是如幻的，如《金刚经》云【一切有为法　如梦幻泡影　如露亦如电　应作如是观】。
    好了，终于可以说到篇题了。惭愧的是，【一即一切】这样的佛见，在下怎有能力讲呢？诸位不要怪我拉大旗就好，嘻嘻。在下想说的是，这里的【一切】，不要认为仅仅是空间上的，而是总括十方三世的一切，而时间空间这样的概念在这里不好使。这里的【一】，从前面的分析可以类比的得到结论，局部从来无法和全体截然分割开来，那么也就是说，任何的局部都和所谓的全体有着割不断的联系，这就是因缘法，而因缘法是重重无尽的，因此局部就很有些【全息】的味道了。虎头蛇尾，不好意思。

    圣普：
    好文，鼓掌。谈点体会。实相上并没有这个“一”，但“一”却起用。这就是没有我，却以“我见”入轮回。如果我们接受了佛见，那将会是怎样呢？
    在起用华严的修法的时候，所缘一切必不可少，然想观出一切的形象来，实在是—＊￥＃＠＃％（不可能），因为如果有个形象，大可问一句，这个形象以外呢？所以大而无外。观修时有两种方法，一种是反证法（不知道说的对不？）：即无一例外。没有一个不在，即是一切。没有一个不包括，即是一切。第二种扩展法：即一及一以外的一切。我及我以外的众生即是一切众生。
    时间不在一切之外，由此一念之间可圆成一切劫功德。重要的在信！受！奉行！

    法界实相，如何有效率的修行？
    众生感苦，是缘起法；众生感乐，亦缘起法。修行成佛更是缘起法。无论做什么，想达成什么目标，如何修行的有效率都要好好的了解一下缘起法的特点。
    缘起法的推动力在于五蕴中的行蕴。也可以理解为心行。例如见、抉择、判断。虽然一切法性空，但却能如如起用（好奇妙的事情），依赖于什么样的见，就起什么样的作用。例如在自性见的基础上，两物相击会有至碍。在我见的基础上，就有轮回，虽然并没有一个有自性的“我”。阿罗汉证得无我，则出离轮回。接受什么样的见，就起什么样的作用。值得注意的一点是我们在意的是作用、结果。就是只要我们接受了这样一个见，它就起作用！！！而与我们以何种方式获得这个见无关！！！
    如欲成佛，则要缘于佛的见地起修。对于佛的见地则直接接受。普贤行愿品上开示了很深广的的修法。基础就是华严法界观。即一即一切，一切即一。因为一切法皆性空，空性又不可分别，所以一法中摄一切法。
    摘普贤行愿品经文：
    “所有尽法界、虚空界，十方三世一切刹土，所有极微一一尘中，皆有一切世间极微尘数佛；一一佛所，皆有菩萨海会围绕。”
    “我当悉以甚深胜解，现前知见，各以出过辩才天女微妙舌根，一一舌根，出无尽音声海，一一音声，出一切言辞海，称扬赞叹一切如来诸功德海。”
    “所有尽法界、虚空界，十方三世一切佛刹极微尘中，一一各有一切世界极微尘数佛，一一佛所，种种菩萨海会围绕。”
    所有尽法界、虚空界，十方三世一切佛刹极微尘中，一一各有不可说不可说佛刹极微尘数广大佛刹。
    接受这样的见修行就有这样的作用。当我们心行上相信，一尘中有微尘佛，所有尽法界虚空界十方三世一切佛刹，一一佛前皆有我们礼敬时。就起到了礼敬一切如来的修法的效果。当在一念之间，起的是念念相续无有间断的念头，这一念之中，即圆满了一切劫的功德。即“一念一切悉皆圆，成就众生清净愿。”这里的重点就是在信上起修。
    并没有写的具体的观修方法，只能说写了一半。其实具体的观修方法就在行愿品中，相信行愿品中所说的是真实，一念中于行愿品中的十大行愿生起信解就是修行。就是相信念诵此经时，自己正在实实在在的做！！！
    我捧鲜花，欢迎大家拍砖，一起讨论修学。愿众生速速开显本来佛性功德。

    gladness：
    确实有效率，而且华严法界观实乃“易筋经”是也。“易筋经”乃传说中的无上武功，掌握之后，学其他任何武功，任何武功都成为无上武功。华严法界观也如此。
    比如观想，观想即是要把净相开显出来。并非是把本来没有的东西观想出来，不是把佛的功德修出来。而是把本自具足的如来功德开显出来，本来如是。本来是佛，本来清净。
    再比如祈请，祈请佛的加持。从“你中有我。我中有你。一切即一。一即一切。”来看，佛是无处、无时不在的。而佛的大悲、智慧是圆满的，遍知一切众生心，也不会因为众生不信佛、不祈请就不加持众生。那祈请是什么意思呢？是打开我们的心，受授本来遍满法界，过去、现在、未来从无间断的加持。
    再比如念佛、持咒。我持咒，即是莲师持咒，莲师持咒即是我持咒。我持咒即是一切众生持咒。我成佛即是一切众生成佛。一念持咒，即是念念持咒，即是过去、现在、未来念念相续持咒，无有间断。
    只是粗粗了解，错误之处，请批评。

    无言：
    大家可能正在细细回味吧，感觉回来后有不少收获，但要具体说出来，却还有些难度。这几日又看了坛子里以前的一些旧贴，有些地方对照一想，又有一番理解。普贤行愿与初发心功德品中的发心共同参学，真是相得益彰。
    行愿品中说：
    “普贤菩萨告善财言：‘善男子！言礼敬诸佛者，所有尽法界、虚空界，十方三世一切佛刹，极微尘数诸佛世尊，我以普贤行愿力故，深心信解，如对目前，悉以清净身语意业，常修礼敬。一一佛所，皆现不可说不可说佛刹极微尘数身。一一身，遍礼不可说不可说佛刹及微尘数佛。”
    其中“极微尘数佛世尊”、“一一佛所，皆现不可说不可说佛刹极微尘数身。一一身，遍礼不可说不可说佛刹及微尘数佛”不易理解，如何才能做到一一佛所皆现一一身，同时遍礼不可说佛刹呢？
    看看初发心功德品，便知如何理解了：
    “欲知一毛端中一切世界差别性，一切世界中一毛端一体性；欲知一世界中出生一切世界，欲知一切世界无体性；欲以一念心，尽知一切广大世界，而无障碍故，发阿耨多罗三藐三菩提心。”
    正因为一切世界无体性，一念可尽知一切广大世界。所以才能达到一一身遍礼一一佛而无有障碍。念亦无体性，嘻嘻，只有有体性，才能被“念知”吗？或者说只有有体性才能“念知”一切世界吗？我们所要破的是因缘法的自性有——龟毛兔角，不是因缘法的作用。

    圣普：
    加一句，空性不可分别，所以……

    rj：
    恩，不过。对于得道的人也许可以这样说，对于因位上的人来说总有些分别的吧？既然有分别，才有如理作意的说法，老兄说的也是如理作意的一种，但就到此为止了吗？


理与行

    理与行

    zf

    如来的圆满是智慧的圆满、慈悲的圆满和利生大愿的圆满，其结果是如来成佛后亦无时不刻地实践着“乃至虚空世界尽，众生及业烦恼尽，如是一切无尽时，我愿究竟恒无尽”的普贤愿行。不知在下理解的普贤行愿和仁兄所说的“普贤行愿”是否有异？
    澄观大师在《三圣圆融观门》中开显了诸法实相（即文中之“理”、“体”）与普贤行（即文中之“行”）的关系：
    “理若无行。理终不显。依体起行。行必称体。由行证理。理无行外之理。由理显行。无理外之行故。随所证理。无不具一证一切证故。”
    对祖师开示，本人理解的大意是：
    诸法实相必依普贤行愿而开显；
    普贤行从实相中来，其行必与实相不相违背；
    由普贤行而证实相，普贤行当下就不在实相之外；
    依于实相而显现之行方是真正的普贤行，离实相之普贤行了不可得；
    诸法实相，一即一切，若从此悟入，一证一切证矣！


吉祥狮子遗教·七钉镢

    吉祥狮子遗教·七钉镢

    吉祥狮子（师利辛哈）造
    老狗·嬉笑游舞 译
    礼敬大圆满人间三祖吉祥狮子！

    礼敬受持本法者智经尊者！
    吉祥妙善！（以上归敬译者加）

    正 文

    我指示本初心性的贤美圆成，
    正如明光与虚阔的无二合和；
    遍知所有一切，
    永远开放，没有边际。
    犀锐的彻穿不动的大地，
    用这七根钉镢，穿透习气轮回的狭路，
    从中得以自由解脱，
    法喜永远从你心中涌现。

    用心性的无碍空、明，将“有依”和“无依”一起钉住。

    用俱生光明，将“能观分别”与“所观对象”一起钉住。

    用自动显现的无染本质菁华，将“心”与“物”一起钉住。

    用定解之见，将“断边”与“常边”一起钉住。

    用超越形体的殊胜明觉，将“形象外表”与“内核本质”一起钉住。

    用一切感觉听其任运自解，将“欣”与“厌”一起钉住。

    用法身的本来完美，将“显现”和“无际”一起钉住。

    （完）

    七钉镢深意璎珞·译后记

    嗳吗好！

    吉祥狮子大师是大圆满人间传承第三位祖师，十五岁从汉地到印度求学佛法，遍学显密教法后，依止二祖妙吉祥友学大圆满持明指示传承二十五年，后隐居于吉祥旃檀林神变宝塔，最后返回中国五台山。他教导出智经(JanaSutar)、无垢友(Vimalamitra)、莲华生(Padmasambhava)、遍照（Vairochana）等大圆满祖师。吉祥狮子涅盘时，正值智经在其胁侍，大师的肉身融入圆相虹光之际，为智经唱出遗教朵哈——《七钉镢》。此朵哈正如其名，简洁却具有刺透力，将见、修、行、果圆成和合，概要托出。在此略采撷其深意精华之璎珞。
    文中“本初心性的贤美圆成”，也可浓缩翻译为“俱生普贤”。在声闻学地中，将烦恼取持为可畏怖者而断除；在显宗安立清净因、道、果，有所建立与破坏；在金刚乘里安立自在转化，仍有造作之功用；大圆满视一切乃意金刚之变化游舞，本来都是普遍贤善。本来、本俱、自显就是“俱生”，普遍贤善完满就是“普贤”，并非故意对立仇视一切显现，而陷入脱离之极端，反而不能去任运心性的游舞庄严。所以在光明心性的基础地上，不应一味仇视任何显现，而应任其自然解脱，空明观察之意是不依靠任何立足点的，说名为心性也毕竟没有自性可以得到，并且更能观察到戏论也是心的游舞作用，从而更尊重业果，总体来说，现量无勤任运的通达中观智慧。所以一开始大师就称赞：“我指示本初心性的贤美圆成，正如明光与虚阔的无二合和；”。
    文中“遍知所有一切，永远开放，没有边际。”，遮止了很多邪见和相似见，比如昏沉、无分别、没有定解而修无念定、意识上的认取自赞等等，具体的要门品类应该依靠上师传授来学习。文中“用这七根钉镢，穿透习气轮回的狭路”有两层甚深含义，最肤浅的是“解脱”，而深一层说明“穿入”。钉镢穿入同时，也就被包含进了所穿透物的内部，这就是说明了一切本俱解脱的内涵。

    文中第一钉，是将显现的条件分为“有依”、“无依”。审视其本质是可嬉笑而无绝对的，所以说用心性的无碍空、明将其钉住。这里可以看到心性不依两边且极其具有观察智，一下子说明了“空、明”的本质。
    文中第二钉，说明心性作用的方便，俱生之中最无勤、自显的法性光明，将一切能见和所见无二和合，在口诀部中有此深道的讲述，此不累絮。此处应说明其俱生之光明，从自性中任运，其不是从方便造作而来，是俱生之中大俱生。
    文中第三钉，将显现与分别打通，心不仅追逐外显现，更进一步追逐自造的内显现，产生建立和破斥，其实如同蛇自己打结，但本来还是一条“通”蛇。一切显现自动显为解脱，但心识使其不解脱，而本质是无迷更无悟，这里就是本质自显的含义。
    文中第四钉，定解之见很重要，不能将见、修、行、果割裂开来。单单靠一个口诀去自肯自己的修行是很危险的，很多人盲目否定业果是很荒唐的。所以有人将超越因果误认为拨无因果是不对的。昔日二祖妙吉祥友初为佛教五明大学者，尚不信服此法，以为超越二元之法破坏因果，乃是邪见，其不知此法澈察中道，反而更能尊重因果，巧用轮涅；后来与五百弟子僧众，同时归依胜喜金刚祖师。三祖之时，国王畏怖超越因果之法而遂禁流通，遍照大师也是白天佯学续部，晚上才能向吉祥狮子大师秘密学此法。超越因果之法不是滥杀无辜，反而更能运用因果的游舞庄严，所以说中观缘起见极为甚深这是不假的啊。
    文中第六钉，可以借用一句朵哈来说明：“将烦恼当作烦恼是错误，让烦恼成为烦恼是方法”。人们极端的排斥烦恼，却不看自己对烦恼的恐惧心，自己给自己打结多么可笑。烦恼真的是不好的，为什么不安住于烦恼中？当烦恼仅仅是它自己的时候，又有什么可以驱除的呢？那时烦恼还是烦恼吗？烦恼也不见了。所以说显现的一切当下解脱。
    文中第七钉，表现的俱生普贤——本来的完美，把有量的显现，和无碍的通达贯穿。普贤王如来代表无始的法身，其真正含义是本来自然的心地。
    这个心地既如同开放的天空，又充满了游云的活性，不故意排斥而广大包含。当然，也没有这样一个绝对的展现给你，那时是超越一切语言和上述譬喻的，如同惊愕的时候而没有任何立足点而已；但是要配合见、修、行，才能完全的认知，只是心意上度量也是不够的。如果跟从上师学习这些“活”的教法，一定很平常的会相应的。这里，吉祥狮子大师从其心中滴出此七滴精髓，对其心子智经作了最后的开示，其中深甚的含义和相应广大的修持要门是很难用几句话展开的，在此仅仅以只言片语勾缀其中光明璎珞，愿启发读者随其经线填充真实的感悟。

    老狗 2000年9月11日译记于北京

    二麻子：
    顶礼大圆满早期唯一汉人传承持有者，大成就者宋慧寿大师。绝妙教法，无上法宝。

    林居士：

    吉祥狮子(诗利辛哈)略传

    吉祥狮子(诗利辛哈)尊者诞生于中国汉地秀夏洲(Sosha Island)，父为具善，母为光明慧，十五岁于阿阇黎哈德白拉处学习五明三年后通达无碍。尊者稍后往西游时，空中现出观世音菩萨的净相，并对他说：“幸运的善男子，你如想得到成就之果，应前往印度索萨维拔城的尸陀林。”。尊者虽对授记感到高兴，但自想：“我仍应先学习所有其他的内外密续，以利于掌握不共的教法。”。他因此往文殊圣地五台山，于七年间从贝拉科提上师学习全部内外密续，其后受具足戒严持毗尼、精研三藏三十年。其时观世音菩萨再次重复之前的授记。于是尊者想：“为免途中受阻，我应用神通前去索萨维拔较佳。”。尊者修持有关仪轨三年后，便得到所需之神力。于是尊者便如风般离地两尺许飞行，抵达索萨维拔并见到文殊友(Manjushrimitra)尊者，并从之受教修行达二十五年。
    根据空行心髓(Khandro Nyingthig)和其他资料，吉祥狮子尊者也曾去了释他哇那尸林，亲见极喜金刚(Garab Dorje)并获授心髓教法，尊者后来将之传予莲花生大士与毗卢遮那。
    此后文殊友大师示入涅盘，其肉身在索萨维拔城中尸林的塔顶消失。当时空中充满了音乐和虹光。吉祥狮子尊者悲哀地祈请：
    “呜呼哉！广大虚空！
    金刚上师光被障，
    谁将能除世间暗？！”
    此时文殊友大师忽然现于空中，伸出右手将一指甲大小之宝盒置于吉祥狮子尊者掌中。尊者在盒中找到用百种宝物之墨写于五宝金属的叶子上的文殊友遗教《修定六受》(Six Experiences of Meditation)。
    吉祥狮子尊者对自己的证量再没有疑惑，并能完全无误明了不共密续的句与义。他将文殊友秘藏于菩提伽亚金刚座下的典籍取出后返回汉地。
    在汉地，他把大圆满口诀部(Me-Ngande)的教法分为四部：外、内、密、极密。他称此中前三部为“广教法”并将之秘藏于汉地近菩提树寺的阳台里。尊者将极密部(也就是宁体)随身收藏。然后，依于空行之指示，他将该部典籍秘藏于吉祥万门寺的一条柱子内，并付托于护法独发母。尊者此后自受密行之乐(enjoying esoteric exercises)，并住于汉地的展寒尸林，为所在之空行勇父之师。
    尊者将大圆满口诀部的外、内、密部口传授予无垢友(Vimalamitra)。他将口诀部的四部口授和典籍全部授予迦纳思扎(Jnanasutra,智经)，并给他大圆满口诀部的教法与灌顶，包括广灌顶、略灌顶、甚略灌顶、和最略灌顶。

    随后尊者的肉身化成虹光，其遗教《七根钉》则下降之迦纳思扎掌中。内写了：
    (逐句翻译连英译原文)
    Homage to the perfection of primordial wisdom, [the union of] clarity and emptiness.
    敬礼明空之不二之圆满本初智慧。
    The awareness wisdom, which pervades all and appears in all,
    遍及一切亦显于一切之觉性智，
    Is open and impartial.
    乃开放与无偏。
    For nailing [the awareness] on the changeless ground,
    为把[觉性]钉于不变之地
    By putting the seven great nails on the narrow paths of samsara and nirvana.
    将七根大钉钉于轮回与涅盘之狭路上，
    Changless great bliss arises in my mind……
    我心生起不变之大乐……

    [a]Strike the nail of unhindered wisdom of clarity at the juncture of samsara and nirvana [in order to unite them as oneness].
    将清明无碍智之钉击于轮回与涅盘之际[以令二者无二双运]。
    [b]Strike the nail of self-appearing light at the juncture of mind and objects.
    将俱生光明之钉击于能观与所观之际。
    [c]Strike the nail of natural-pure essence at the juncture of mind and matter.
    将自然无染菁华之钉击于心与物之际。
    [d]Strike the nail of freedom from views at the juncture of nil and eternity.
    将离见之钉击于断与常之际。
    [e]Strike the nail of awareness, which is beyond phenomena, at the juncture of phenomena and the nature of phenomena.
    将超越诸法的觉性之钉击于法与法性之际。
    [f]Strike the nail of totally liberated five-doors [sense faculties] at the juncture of excitement and torpor.
    将完全解脱之五门[根]之钉击于欣与厌之际。
    [g]Strike the nail of primordially perfect Dharmakaya at the junction of appearance and emptiness.
    将本自圆满的法身之钉击于显现与空性之际。

    (按：与老狗·嬉笑游舞之译有少异处。)

    本文意译自东杜祖古之《龙钦宁体传承祖师传记》吉祥狮子章
    (Masters of Meditations and Miracles: The Longchen Nyingthig Lineage of Tibetan Buddhism, Tulku Thondup. Shambala:Boston, 1996.)
    并参考敦珠法王之《宁玛佛教史》
    (The Nyingma School of Tibetan Buddhism, Dudjom Rinpoche. Wisdom Publications:Boston, 1991.)

    以水平所限，谬误恐难免，谨此先向诸大圆满祖师忏悔。——林居士

    智行:

    这么大的成就者为什么在汉地罕闻？

    林居士：
    缘。
    大圆满当时在印度也是秘密传授的，若非现在大圆满法大盛，可能藏地也是罕闻。
    汉土禅宗之法缘也要到盛唐才成熟，而初期还被一些“保守派”当作魔子。吉祥狮子的年代要早得多，那时候的汉地应该当经师会吃香得多，若传大圆满恐怕被当外道的机会不少。《宁玛佛教史》称当时在五台山传授尊者密续的贝拉科提(Bhelakirti)上师为Outcaste，可见当时不单大圆满，连其他密法也是在建制以外秘密传承的。

    智行:

    可能这个世纪汉人和大圆满的缘该成熟了吧？

    tempuser:

    可能渠道不同，还有就是当时在汉地类似的大成就者很多。
    1、渠道不同，印度的修行人知晓更多些，都千里迢迢去五台山。后来几百年后，也一直如此。看“西藏佛教史”中说，“秘密藏经”的梵本就是后来几个路过西藏去五台山的印度僧人发现的。
    2、在汉地类似的大成就者很多。中国佛教当时处于鼎盛时期，应该是有很多。
    3、在汉地有秘密传承存在，外人不知。
    “当今红教法王贝玛诺布更明确说：“大家不要以为大圆满法在汉地没有传，历代以来中原依大圆满修至佛位者，有数千人之多”


大圆满椎击三要诀

    大圆满椎击三要诀

    巴祖仁波切造
    止贡·敬安仁波切释语
    释修圣集

    顶礼上师

    见即深广无有量（1），修即悲智之光明（2）
    行即如来之芽苗（3），如是受持修学者，
    此生证觉无坎坷，否亦心安阿拉拉（4）。

    见为深广无量者，三要义诀之椎击，
    最初自心安然放，不散不摄无分别。
    与中松坦安闲住，突然作意呼一呸，
    威猛短促真希奇。一切皆无唯惊愕，
    愕然当下皆洞达，明澈通达无言说，
    法身本觉当认之，直指本性自见第一要。

    复次散住皆适可，嗔恨贪欲及苦乐，
    恒常及暂一切时，本性自见法身当认知。
    今昔母子光明会，住于无言本觉中，
    所现乐明数数除，突施方便般若字（5），
    入定出定无差别，座上座下亦无别，
    恒常住于无别境，然若未得坚固时，
    须舍聩闹勤修持，入定闭关专行之，
    恒常及暂一切时，法身唯一得任持，
    决定即此无其他，确定唯一决定第二要。

    此时贪嗔及喜忧，分别客尘皆无余，
    认知彼中无相续，知是解脱之法身，
    譬如水中之图画，自显自解续不断，
    所显明空赤裸食（6），诸般变现法身王，
    自净无迹阿拉拉，显现如昔同旧样，
    解脱分别之大要，离此之修迷误道，
    具足无修法身中，决定当下解脱第三要。

    具足三要之见者，智悲双运之修习，
    随友佛友一切行，三世如来虽聚议，
    无较此胜之口诀，觉力法身掘藏者，
    智慧界中取此出，不同土石之伏藏，
    胜喜金刚之遗嘱，三种传承之精华，
    付之心子之心印，是甚深义与心声，
    是心声语是要义，切勿舍弃心要义，
    慎勿漏失此口诀。

    注：
    （1）双关语，既指见地亦为龙钦巴祖师名号。
    （2）双关语，亦为智悲光尊者名号。
    （3）双关语，亦为佛芽尊者名号。
    （4）阿拉拉──赞美义。
    （5）表方便字音为帕，表般若之音为扎，合为一字音呸。旧译为音泼吒。
    （6）食，比喻受用义。

    仰地三虚空相应口诀摘录：
    修自性定与光明，到此非得究竟证，
    不修更不能得证，即修即是细分别，
    不修分别更粗劣，无有微尘量修因，
    心应刹那离散乱。

    此为吾友新译校之椎击三要。日前有古慈兄等佛友问及三要要义，恰此新译刚成未印。麻子将之键入贴出，供佛友对比参考。


大手印愿文

    大手印愿文

    自生金刚·让蒋多杰 造
    止贡·敬安 云波且 译语
    释修圣 集

    1.
    上师本尊坛城诸圣众
    十方三世诸佛及佛子
    悲念于我及所发净愿
    祈请加持如意得成就.

    2.
    清净意乐加行雪山生
    三轮无著善业恒流注
    我及无边一切有情众
    愿皆汇入四身佛海中.

    3.
    乃至未得如此果位时
    所有一切生生世世里
    不闻罪业苦恼之名字
    愿常受用善乐福德海.

    4.
    具信智慧精进及暇满
    能事善师得授极心要
    如法行持无诸中断障
    愿修胜法生生世世中.

    5.
    闻思正理远离无知障
    口传抉择灭诸疑惑闇
    修生光明霍然现实相
    愿得三种智慧光遍照.

    6.
    二谛本义远离断与常
    要道资粮远离增与损
    胜果自在超越轮与涅
    愿得值遇无错无谬法.

    7.
    本净心性不二明空运
    能净离染金刚大瑜伽
    所净忽而垢染幻无明
    愿得净果无染法身现.

    8.
    断诸增损于法决定见
    持此正见为修定要门
    修定自在即为最胜行
    愿于三要得获无动摇.

    9.
    一切现象皆心所幻显
    心亦无实心之体性空
    空而无碍一切皆显现
    愿善观察总断迷执根.

    10.
    自显无实迷执为外境
    自明非我无明执为我(对称性提高,但准确性不如原文,但也未离原意)
    二执驱我流转于诸有
    愿破无明总断幻惑源.

    11.
    非有乃至诸佛亦未见
    非无乃至轮涅无碍现
    此乃无悖不二大中道
    愿能领悟离边心法性.

    12.
    无有任何可指为是此
    亦无任何可指为非此
    真如(无伪)法性远离于思量
    愿得决定圆满真实际.

    13.
    于此不悟流转轮回海
    于此契入证觉非他处
    遍处一切无彼此对立
    愿现无遮法性一切基.

    14.
    显现在心坏空也在心
    了悟在心幻惑亦在心
    升起在心消失也在心
    愿断自心一切增损执.

    15.
    不由造作禅修所伪饰
    不为俗世事务所动摇
    了知安住本然而无作
    愿能精熟修持心要义.

    16.
    粗细妄想起伏自消歇
    舒缓心流调柔渐休息
    离却昏沉掉举浑浊处
    愿得安宁坚固寂止海.

    17.
    数数观察心本无可见
    本然非见霍然赤裸现
    永断是非首鼠疑惑根
    愿此无谬法性自显现.

    18.
    观境之时无境唯现心
    观心无心心亦不可得
    同观二者能所自消融
    愿悟光明本来心实相.

    19.
    此离作意即是大手印
    此离边见即是大中观
    此摄一切即是大圆满
    愿由知一而得证一切.

    20.
    大乐无贪持续无中断
    大明无执遍彻无遮蔽
    离念超思任运自显现
    愿得无作正修无间断.

    21.
    觉受贪着当下获解脱
    妄念迷幻现法自清净
    平常心无取舍无增损
    愿悟离戏法性真实谛.

    22.
    众生从来未离究竟觉
    未悟徒受无边轮回迷
    于诸痛苦无边有情众
    愿我心生猛利难忍悲.

    23.
    猛利悲心生起难忍时
    空性赤裸当体而显现
    于此最胜不二胜要道
    愿我昼夜修习永不离.

    24.
    修力所生眼等诸神通
    成熟有情清净诸佛刹
    实践佛法大愿得完备
    愿得圆满清净成正觉.

    25.
    十方诸佛佛子大悲力
    所有一切清净善业力
    愿我以及一切诸有情
    所有净愿如意皆成就.

    附言：
     真如（无伪）法性远离于思量，无伪不大合乎中文习惯，故翻为真如法性。


缘 起 赞

    缘起赞

    ──对释迦牟尼佛教义精髓的赞颂

    宗喀巴 大师造

    伟大的妙音上师呵，我向您致敬！
    我向完美的佛陀顶礼，啊至高无上的哲人！
    是您教导我们缘起，超越生与灭的幻象，
    越过断与常的陷阱，战胜来与去的戏论，
    澄清一与众的纷争。
    您的宁静越过了一切人为的造作，
    啊那极乐的巅峰！

    我向您致敬！您的洞察和教诲
    使您成为无与伦比的导师和圣人；
    真正的大雄，您认清了最终的真理，
    然后向我们开示，那就是缘起正见的吼声！

    在这无常的世间，错误的知见
    它自身就是所有痛苦的根；
    您洞察了痛苦的根源，然后将它灭除，
    以普遍适用的缘起引导众生。

    怎么可能有这样的事情？
    智者们会不懂得缘起──这真实的途径
    正是您教导的核心？
    如果是这样，谁还能找出更妙的言辞
    来赞颂您，拯救者啊，
    还能有什么比您缘起的教导更高明？

    “凡依存于条件者都无自性！”
    难道还能有什么杰出的教导，
    比您这一发现更为神圣？

    虽然无知的人也会采用它，
    那不过是边见者的曲解；
    有智慧的人们却同样以缘起，
    切开那虚假造作的网。

    这伟大的教导别处没有，
    所以只有您才是真正的导师啊！
    对外道称导师那不过是阿谀，
    好比把狐狸说成是狮子王！

    不可思议的导师！不可思议的皈依处！
    不可思议的无上法王！
    不可思议的世界的拯救者啊！
    我向您献出全部的敬仰，
    是您将普遍适用的缘起传扬！

    啊，大恩世尊！您演说深奥的缘起
    以治愈一切众生的痛苦；
    是这无双的教理显明了空性，
    而空性正是你教诲的根本。

    谁若以为缘起的过程
    与空性矛盾或自身不能成立，
    那他对您的教法真是一窍不通！

    这才是您的本意：当我们理解
    空性作为缘起的真相，
    这一空性并不否定作用。

    然而当谁从反面去理解：
     有作用的过程不可能空，
    空性在作用的过程中会丧失；
    他就要掉进焦虑的深渊。

    所以对缘起的体验
    在您的教法中最受推崇，
    它既不是完全的虚无
    也不是本质的实有。

    非缘起好比空花，
    没有任何法是非缘起的。
    认为事物若存有其固有状态，
    将会排除其依赖于因缘而存在的正见。

    因此您才这样教导我们──
    因为什么也不能超越缘起，
    也就没有什么能超越自性空。

    您才这样教导我们──
    如果事物有任何自性，
    因为自性不能被灭除，
    虚假造作也就不能被灭除，
    涅槃就没有可能。

    在智者的集会中无所畏惧，
    您清楚地发出雄狮的吼声，
    “破除自性去获取解脱吧！”
    这庄严的吼声谁敢不服从？

    所有的法能存在，
    就在于没有固有的自性，
    这与缘起并不矛盾，
    反而它们相互补充。

    “因为缘起的缘故，
    一切边执邪见就没有根据”
    因为这杰出的论断，救世者啊，
    您是哲人中无与伦比的至尊！

    “一切法都自性空！”
    且“有如是因就有如是果！”
    这些事实不但不相互抵触，
    可以肯定它们还能相互加强。

    还能有什么比这更不可思议？
    还能有什么奇迹比这更让人敬畏？
    以此赞颂您才算是真正的赞颂，
    以其它来赞颂您都是不得要领。

    那些幻象的奴隶们，
    愤怒地向您挑衅；不足为奇
    他们将发现无法忍受
    您那无自性的声明！

    但是那些表面接受缘起的人，
    好像懂得您教诲的宝藏，
    当他们承担不了空性的吼声时，
    那才真地让我吃惊！

    无与伦比的缘起，
    通往无自性之门。
    若既承认缘起，名义上又主张有自性，
    他们怎能这样欺骗自己！

    他们应该由您所喜悦的缘起中道，
    引导进入善的幽径，
    那无比的安乐之地，
    与所有的众圣同行。

    自性，无作和绝对，
    缘起，有作和相对；
    这样的两个方面岂能共存，
    而不矛盾？

    是故缘起诸法虽无自性，
    看起来却似乎有自性显现，
    因此您才宣说：一切法如同幻影。

    从这一点出发，将能明白
    您教诲的中心；
    而那些向您的教法挑衅的人
    却不可能找出任何把柄。

    为什么呵？因为您对缘起的阐明，
    使我们彻底地远离增益与减损。
    （超越教条与经验的束缚，
    远离取与舍的困境！）

    这恰到好处的缘起中道，
    证明您的教诲无与伦比；
    它使我们对您其它的教诲，
    也产生了完全的信心。

    您以缘起之理教导我们，
    所有跟您学习的善人，
    必定能远离一切世间的不幸，
    断除恶习邪见的根本。

    可是那些违背了您教诲的人，
    虽然他们长期苦行，
    过失总是纷纷围绕着他们，
    因为他们坚固的我执在作祟

    奇妙呵！智者们能明达
    违背与顺从您的教诲是如此不同，
    他怎能不对至尊的导师您
    和您的教诲发出深深的敬信？

    难道还必须将您的许多教导一一言明？
    谁若能大概地理解您教诲的深意，
    哪怕不过是几句偈语，
    最胜的安乐必定充满他的身心！

    啊呀！我的心曾充满困惑，
    我虽然长期地皈依您，
    对于您这无尽的功德海，
    却一点都没有能受用。

    现在我虽面对着死神，
    我的生命还并没有耗尽，
    我是多么幸运啊，
    能对您缘起的教诲产生信心！

    教诲中，是缘起的教诲，
    智慧中，是缘起的智慧，
    如同世间的王统领群臣，
    它正是您智慧的顶峰！

    您所开示的一切教导，
    皆以缘起为总的纲领；
    您以缘起所贯穿的一切法门，
    无不指向涅槃的胜境。

    正是呵！谁听从您的教诲，
    他就能从万法中证得究竟的安宁；
    谁能不对这无上佛法的宏扬者，
    生出无边无际的恭敬？

    缘起的正法折伏一切论敌，
    并且远离种种内在矛盾
    它使众生得到现前及究竟的利益，
    我对这妙法的喜悦与日俱增！

    为了这无上的妙法，
    您一次又一次布施亲眷和财产，
    甚至头目手足以至生命。

    当我看到您这如此的大功德，
    看到您大觉的心中涌现的无上正法，
    就像铁钩钓鱼一样，
    那是多么遗憾呵未能从您亲闻！

    虽然怀着深深的悲伤，
    我的内心从未舍弃对您缘起中道的追求，
    如同慈母之心
    总是随子同行！

    甚至当我想象您说法的情景，
    “伟大的导师，佛身相好，
    光网围绕，光明晃耀，
    以清雅的梵音宣说缘起中道！”

    伟大的释迦牟尼佛的尊贵妙容
    就会在我的心中显现，
    治愈我的痛苦，如清凉的月光
    照破热恼。

    虽然您缘起的教诲是如此美妙，
    智慧不足的人们却为之所困，
    如同盘根错节的杂草，
    他们的见解总是纠缠不清。

    面临这一难题，
    我在诸智者的经典中潜心探寻；
    我曾竭尽全力地修学，
    以反复寻求您教诲的真意。

    我也曾仔细地研习
    佛教各宗派的教义，
    却总是陷入疑惑，
    疑惑的困境是多么折磨人！

    我于是拜读了龙树菩萨的著作，
    犹如进入了佛法的夜百合园；
    他曾被您授记为善解无上乘佛法，
    缘起中道超越了有与无的陷阱。

    在那儿，由于上师的慈悲，
    我看见缘起的真意
    犹如吉祥的月光照亮一切，
    那圆满无染的智慧月轮
    自由地漫游在经典的天空；
    它驱散了一切边执的黑暗，
    使一切谬说的行星黯然失色；
    就这样我终于得到了无比的安宁！

    佛的一切事业中，以佛的教诲最胜！
    佛的一切教诲中，以缘起的教诲最尊！
    真正有智慧的人呵，忆念完美的导师，
    怎能不忆念他缘起中道的丰功！

    我以佛陀为榜样出家修行，
    我学习大师的教诲以求深入，
    我是一个勤修瑜加的僧人，
    这就是我对伟大觉者的尊敬！

    我能值遇无上导师的缘起正法，
    那是由于上师的宏恩；
    现在我将造赞之功德回向一切众生，
    愿众生都有得遇明师的福分！

    愿佛陀利益众生的正法，
    尽未来际不被恶见之风所动；
    愿众生能正确领会佛教诲的缘起性空，
    愿正信的行者时时增进！

    愿我能弘扬释迦牟尼佛的教法
    所光显的缘起中道；
    愿我生生世世宁舍身命，
    也念念不忘佛的教诲！

    为获得这无垢的教法，
    伟大的佛陀无量劫难行苦行；
    愿我念念不忘寻求各种方便，
    以弘扬缘起正法！

    当我净心勤修此无上法门，
    愿大黑天，梵王，帝释，护世天神，
    和所有的护法圣众，
    都一心护持我永不离分！

    雪白·雪阳 戊寅年十月敬译于白象斋

    愿以此功德上供下施川流不息
    六凡四圣同证缘起性空不二法门


汞处理的阶段总结

    汞处理的阶段总结

    赵振茂　原著
    dawa　　编注

    引言

    汞是常温状态下唯一能呈液态的金属，呈银白色，其在常温下即能蒸发，不溶于水，能溶于类脂质，易溶于硝酸及硫酸，但不与碱液反应。汞和汞的化合物都具有毒性。目前环境中的汞污染，主要是因为工业上的汞流失造成的，例如氯碱工业用汞作阴极电解食盐，除汞蒸气的挥发外，大量的汞和氯化汞将从废水中排出。
    此外，汞在微生物作用会转化为毒性更强的有机金属化合物（如－甲基汞），可被生物富集，通过食物链进入人体。食物中汞主要就是以甲基汞的形式存在，其对人体的危害更大。著名的水俟病就是由于食用含有甲基汞的海产品而引起的。
    除了通过饮食之外，金属汞和化合物主要以蒸气或粉尘形态经呼吸道进入人体。汞进入血液后，将与血浆蛋白或血红细胞结合，以后主要分布到脑和肾脏，其次为肝、肠壁、心、肺等处。汞的危害突出表现在其神经毒性之上，对呼吸道、消化道也有影响。
    急性的汞中毒多因短期内吸入高浓度汞蒸气所致。由于汞蒸气无色、无味、无刺激性，故最初吸入后，除仅感口中有金属味外，一般无甚不适。在连续吸入数小时后，即可出现症状，主要是头晕、乏力以及呼吸道刺激症状，严重者可致化学性肺炎。发现急性中毒病人，应立即脱离染毒环境，并换去污染的衣物，及时就医。
    慢性中毒系长期接触一定浓度汞蒸气所引起，受损器官主要是中枢神经系统，亦常伴有植物神经功能紊乱，主要有三大症状：即兴奋性增高，震颤和口腔－牙龈炎。病人平时表现为情绪易激动、烦躁、胆怯、注意力不集中、记忆力减退及失眠；有的病人有鼻炎、上呼吸道炎表现，少数病人眼晶状体出现“汞性”晶体炎。
    佛教是现代社会中鎏金这一传统工艺的大用户，佛像和法器法物很多都进行鎏金。佛教建筑中，主要是大殿的屋顶、塔的构件等处常需要鎏金处理。在大型项目中，用金数量一般以公斤甚至吨计。鎏金的原理系先将黄金溶解在汞水中，称之为杀金，然后涂抹在器物表面上，加热烘烤去汞而在器物表面留下黄金的薄层。但是从一些相关的资料看，佛教目前大量鎏金屋顶和其附属部件的施工，尚处于比较原始的状态下，一般系直接将汞金部件就地露天烘烤，防护设备仅为口罩、厚纱布等。这必然直接对施工人员和在场的指导僧员造成中毒的危害，导致大量的汞蒸气沉降在当地的土壤和水源中，可能在寺院周围形成长期的汞污染，造成健康问题，影响相关寺院的常住僧众。
    原国家文物鉴定委员会委员、著名青铜器修复专家赵振茂先生所著《金银铜器的传统修复技术》一文中对鎏金工艺和汞处理有所总结，原文刊载于《故宫博物院院刊》1994年第三期，该文是目前看到的资料中对鎏金工艺最详细具体论述的文章，文中具体谈到在鎏金过程中有效的进行劳动保护，及汞蒸气的净化措施。因为宫廷建筑和佛教寺院建筑是同一类，本文鎏金所采取的一些工艺流程和技术细节也是和佛教中常用的鎏金工艺相一致的，可以相互参照。2003年佛教在线电子杂志刊发含《汞中毒及防护措施》的这篇文章后，四川各莫寺根据这篇文章建造了有关的设备，用于大塔鎏金部件的除汞，用少量的资金就取得了很好的效果，顺利完成了有关工程，人员也得到了必要的防护。现根据一些实际情况，为了有利于这种环保技术在佛教界中的应用，将这篇文章的有关部分再介绍一下，并将原来的图示进行重绘，加了一些编注，希望有助于读者的阅读。

    汞中毒及防护措施
    赵振茂

    1．汞中毒
    为了叙述方便简明，前面在向读者介绍传统鎏金工艺时未谈及汞中毒和防护问题，但这是一个不容忽视的问题。因为在鎏金过程中有大量汞蒸气远散，不但污染周围环境，而且危害人体健康，特别是操作人员身体的健康。
    汞，化学符号Hg，俗称水银，为易流动的银白色液态金属，内聚力很强，熔点一38．87℃，沸点356．589℃，因汞离子是一种强烈的细胞原浆毒，能使细胞中蛋白质沉淀，故汞蒸气和汞的大多数化合物都有剧毒。在鎏金过程中，特别是在“杀金”、“烤黄”工序中，因在火上进行，会产生大量汞蒸气．通过呼吸道、食道、皮肤侵入人体引起汞中毒。慢性者口腔发炎或精神失常：急性者有腹泻腹痛血尿等症。闻名于世的日本“水俟”病，就是因日本氮肥公司在水俟镇设厂，向海水中排放大量含有甲基汞的废水，使鱼类中毒，人吃了毒鱼痴呆麻木，精神失常，甚至死亡。所以，我们在鎏金过程中必须要有效的治理防护措施．而不是采取原始的“站上风”、“含口酒”的方法和把祸害转嫁给别人的“以邻为堑”的方法。我们一要防止汞中毒保护人身健康，二要避免毒气逸散保护周围环境。
    2．防护措施
    （1）汞废气净化的系统设备及其工艺流程
    1981年故宫经东南角楼上宝顶时所使用的汞废气净化系统设备就是在北京市劳动保护科学研究所和北京市环境保护监测站支持帮助下安装起来的。其设备主要由喷淋塔、贮液池、“烤黄”罩、“杀金”炉、通风机、耐酸泵、管道等部件组成。采用酸性饱和高锰酸钾（饱和高锰酸钾KMnO4水溶液，5％硫酸H2SO4）作为吸收剂，净化废气中的汞。属于化学吸收。见汞废气净化装宜示意图。

    汞净化工艺流程简述如次：
     ①开动耐酸泵，使贮液他中的净化液经过水泵──塑料管──喷头，呈雾状在塔内喷淋。
    ②开动通风机，使“杀金”、“烤黄”时产生的汞蒸气经过（编注：吸风罩吸入）进风管道──通风机进入喷淋塔底部（编注：流经通风机进入喷淋塔底部。喷淋塔是净化的核心装置），含汞气体由塔底上升与净化液──酸性饱和高锰酸钾水溶液接触，进行化学吸收。
    ③净化后的气体经塔顶的排气管道进入贮液池，再次与净化液作用达到二级净化，经二级净化的气体从贮液池盖上诽气管道自然排出。在塔中与汞蒸气接触后的净化液从塔底流回贮液池循环使用。贮液池中含汞废气净化液经处理达标后方可徘放。
    （2）鎏金操作规程
    在鎏金实践中我们总结了七条操作规程，供读者参考：
     ①鎏金前要检查净化系统设备是否完善。
    ②操作人员必须身着长袖工作服、工作裤，戴工作帽和防毒口罩。
    ③因汞的比重大，易流动，落地不易收净，故鎏金时在器物下应铺上高丽纸或放置大的器皿。
    ④不要在鎏金车间就餐、吸烟、饮水。工作完毕要洗净手脸，嗽口。有条件最好洗热水澡。
    ⑤鎏金时用过的纸、棉花等物，应在吸罩下烧毁。
    ⑥在鎏金过程中如发现有汞中毒症状立即就医治疗。
    ⑦在鎏金过程中，操作人员要注意饮食以辅助排汞解毒。多饮浓茶水，适量饮酒，多食牛奶、鸡蛋、豆类，多吃利尿水果蔬菜。
    采用以上净化设备和防护措施对汞废气进行治理效果如何呢？经过测试表明，基本达到了预期效果。
    以上介绍的是十年以前我们鎏金时所采用的净化设备和防护措施。目前已是九十年代了，科学技术不断进步，设备不断更新，进行鎏金时，一定会有更好的净化系统设施和更科学的防护措施，从而达到更好的防护效果。我们之所以向读者介绍这些情况，一是引起警觉，二是可以借鉴。

    编注：
    传统鎏金工艺中，“杀金”、“烤黄”过程中都会产生大量的汞蒸汽。废气净化设备主要由喷淋塔、贮液池、“烤黄”罩、“杀金”炉、通风机、耐酸泵、管道等部件组成。采用酸性饱和高锰酸钾作为吸收剂，净化废气中的汞。汞废气净化装置的核心部分为耐酸泵和鼓风机，应根据操作需求具体选。中小型的耐酸泵的价格在二千元左右，而鼓风机只需要几百元。另外，管材规格主要有两个参数，外径和壁厚，如果不加标注则数值的单位是毫米（mm）。壁厚越大则管材的耐压能力越大，可以根据喷淋塔的高度选择管材规格，但实际上一般管材都能满足该废气净化设备的要求。塑料管材可以考虑选用PPR管材或UPVC管材。厂家一般按吨为单位进行销售，当前价格如下：PPR管材约2万元／吨，UPVC管材约1.1万元／吨。PPR管基材的密度为0.9g／cm3，常见的外径（壁厚）为：40（3.7），50（4.6），63（5.8），75（6.8），90（8.2），110（10），计算可知其中63规格管材的价格约为（18－19）元／米。对于UPVC管材，其基材密度为（1.4－1.5）g／cm3，常见的规格有50（2.5），75（3.0），110（3.3），160（4.0），其中75规格管材的计算价格（11－12）元／米。以上的价格会随市场情况有所变化，仅供参考。四川各莫寺环保工程中，采用不锈钢为主体材料制造的净化设备总体造价约为4万元，可重复使用。

    对工业过程中汞中毒和汞污染的防治，一般可以从以下三个方面入手：
    ① 对汞蒸汽的处理：密闭操作系统，加强通风排气，操作台应设置吸风装置，并经净化装置吸附后排出。这也是本文介绍的废气处理设备的作用所在。
    ② 对二次污染的防治：工作时遗落的液体汞，会形成小汞珠，分散分布而形成二次污染。作业场所墙、地和一切用物表面均应尽量光滑、平整、地板、台面应不留缝隙，并保持一定斜度。表面可涂以过氯乙烯，以防汞珠附着或渗入，便于冲洗擦净。空气可于每天下班后用碘自然蒸发（需碘0.2g/m3）或加热熏蒸（需碘0.5g/m3），以使汞、碘蒸气结合成不易挥发的碘化汞，次日上班时用水冲净即可。还可以漂白粉液或5%～10%三氯化铁溶液定期喷洒、冲洗地面，同样有效。
    ③ 对含汞废液的处理，基本原理是把汞以沉淀的形式或金属汞的形式分离出来。
    此外，含汞的废物应密封埋藏，或交汞矿场处理。

    废气净化设备的安装过程中应注意以下几点：
     ① 耐酸泵的高度不要于与贮液池的液面相差太大。同时，喷淋塔顶部的高度应高于贮液池的液面，以满足自然回流的要求。
    ② 从装置的示意图上看，设置有分流管路。这种设计的目的一般是用于往复式水泵的流量调节。但通常的耐腐蚀泵大多是离心式水泵，其流量是通过水泵出口管路上阀门来调节的。所以若选用离心泵，该分流管路的作用不大。
    ③ 注意泵的吸入管路不应与液体回流管连接在一起。
    ④ 由于汞蒸汽的比重远远大于空气，所以进风口可以酌情安置一个分入风口于工作位置的侧方或下方。

    含汞净化液中的最后处理，应该去除其中的汞、锰金属元素，并中合其酸性。初步处理方法，可以考虑使用熟石灰调节净化液为弱碱性，此时会使大部分汞、锰等形成不溶的沉淀物。更进一步的处理可以采用硫化钠，将净化液中的汞彻底去除，但这一步处理中将生成金属汞，需富集处理，并有可能产生少量有毒的琉化氢气体，需要专业化工场所和人员操作。最后，所收集的含汞、锰沉淀物应该密封保持，或联系回送矿场处理。

    （注：根据最新资料，以上方法仍有汞中毒的可能，目前的最佳方法是在有环保设备的工厂里进行镀金。）


英文佛教书籍选读书单

    南竹:
    我也希望看到介绍好的英文佛教书籍。

    林居士:

    一张比较随意的书单，可作开始,下面的书在国外的网上书店可以找到。

    (几乎是)必读：
    Words of my Perfect Teacher
    (即《大圆满前行引导文-普贤上师言教》)

    Way of the Bodhisattva
    (即《入菩萨行》，约有四五种英译本，此译文笔较优美。有一译还载有创古仁波切的注释，不过忘了书名，可以试搜:Bodhicharyavattra)

    极力推荐：
    Repeating the Words of the Buddha
    Rainbow Painting
    (上二书都是祖古乌金仁波切的开示汇集，乌金仁波切是宁玛的大成就者，十六世噶玛巴的根本上师之一，顶果钦哲仁波切、敦珠仁波切等当代大德也曾从之受法并尊为顶严。书中由最基本的归依要义到最深入的大圆满窍诀都有触及，深入浅出，不可错过。)

    Luminous Mind
    (卡卢仁波切开示汇集之一)

    Dakini Teachings
    (中译为《空行教授》，为莲师伏藏开示)

    The Lotus Born: The Life Story of Padmasambhava
    (一本详略适中的莲师传，乃直接翻译自一种版本的伏藏莲师传记)

    Masters of Meditation and Miracles
    (龙钦宁体祖师传记)

    The Great Kagyu Masters
    (噶举派前期几位祖师的传记，其中谛洛巴、那洛巴、马尔巴、密勒日巴、冈波巴祖师均有英译独立传记出版，也可参看)

    较系统性的：
    Instructions of Gampopa: A Precious Garland of the Supreme Truth
    (堪布卡塔仁波切讲授《解脱庄严宝》)

    The Path of Awakening
    (蒋贡康楚罗卓泰耶注释七义修菩提心法)

    Liberation in the Palm of Your Hand
    (《掌中解脱》其中一种英译)

    The Great Treatise on the Stages of the Path of Enlightenment:
    The Lamrim Chenmo
    (《菩提道次第广论》英译第一册，尚有二三册未出)

    上面的书目并不很全面，但可以作为不错的开始。


佛教经典论著选读基础书目

    佛教经典论著选读基础书目

    网海莲舟佛法网站

    许多同修在阅读了一定的初机入门读物，对佛法生起信心后，往往就会有下面这些困惑。佛法的经论那么多，古今大德的开示亦不计其数，虽然我们研读了都有一定的受用，但是往往还是不能十分清楚了解修学佛法的实际次第应该如何？又应该以怎样的思维来引导自己，加强修学佛法的信心与决心，直至发起真实无伪之菩提心？
    《佛说大般泥洹经》中记载，世尊对迦叶说。“善哉善哉。善男子。渐阶如来一切种智。乃能问斯甚深经义。一一方面阿僧只恒沙诸佛。从本已来自于世界坐道树下成等正觉其数无量。本为菩萨得菩提道次第开觉。皆悉因问如来深法藏故。”
    根据往昔的意乐、愿望、因缘和现世基础不同，学人在人天乘、小乘、大乘与金刚乘的相互关系与次序如何？如何在菩提道上渐此而行，从初发心直到最终圆成佛果？不同阶段的重点又都有哪些？对此，本师释迦牟尼佛和菩萨，祖师大德们都进行了许多重要的开示，在佛教中的各个学派都对此有精彩的表述。在中国佛教两千年的译传史中，佛教经典论著和历代译传大德为每一代的学佛人所做的努力，令人由衷的生起敬意。
    为此，我们汇辑了佛教经典和菩萨论著中对此的若干叙述，及各学派传统中祖师大德关于菩提道修学次第这一专题，进行全局或局部讨论的论著和近当代大德的讲解及修持略示中的一部分。并推荐有意对此加以了解的行人首先背颂《大方广佛华严经·净行品》、《大方广佛华严经·贤首品》、《大方广佛华严经·普贤行愿品》（广本），阿底峡尊者造《菩提道灯论》等经论的其中一篇并熟读其余，阅读和念颂隋代杜顺大师所著之《华严五教止观》，印度寂天菩萨所著的《入菩萨行论》；并阅读思维依佛经中汇集句文而成的、印度寂天菩萨所著的《大乘宝要义论》和《大乘集菩萨学论》，并根据《佛说除盖障菩萨所问经》所示的修学次第或自己所依学派的修学次地的实际修学引导，深入体会《妙法莲华经》、《大方广佛华严经》和《摩诃般若波罗蜜经》所示深义。
    在学习佛教各学派的次地之前，建议先对基础经论，人生佛教，律仪守持与忏悔业障，三十七道品修学，发菩提心与六度四摄中的内容加以了解，精读其中一部分，然后根据自己的因缘情况，选择一个具体的佛教学派的论述进行专题学习，先阅读其中所依经典，然后阅读论著，以便有大致的了解，然后根据自己的情况选择其中一本著作进行详细阅读，并以此为主线阅读其他经典和论著，及论著中所涉及引文的经论原文，查阅佛教辞典并向善知识请教，以便更实际的掌握佛法的真实内容，书目中藏传佛教部分，我们主要的选目主要使用汉译中的与之对应的经典译本，以菩萨藏的教法为主，密乘教法的深入学习，有待读者自行依师进行。一些初学中具体修学中的讨论，建议也可以参阅网海莲舟系列文集。
    我辈学人研习于自己所学密切相关的菩提道修学次第思想，将获得巨大的法益，不仅可以树立从初入道依止善知识起直至最终成佛有关整个菩提道的正知正见，为今后的实修打好基础；亦可将我辈平日零散所学所得之佛法心要相贯穿，并触类旁通，对其他学派的思想精华多加掌握和学习，通达一切圣教无违殊胜之道理。需要提醒的，本篇目录中所涉及经典中的密乘观修，在善知识的指导下进行方为妥当之举。望各位同修，无论修学显密、禅净，都能从佛陀的圆满教法中获得真正的进益

    目　录

    █　基础经论选读
    妙法莲华经【姚秦 鸠摩罗什译】
    大方广佛华严经【唐 实叉难陀译】
    摩诃般若波罗蜜经【姚秦 鸠摩罗什译】
    佛说除盖障菩萨所问经【宋 法护等译】
    大方广佛华严经·净行品【唐 实叉难陀译】
    大方广佛华严经·贤首品【唐 实叉难陀译】
    大方广佛华严经·普贤行愿品（广本）【唐　般若译】
    华严五教止观【隋 杜顺说】
    入菩萨行论【寂天菩萨造论　如石编译】
    大乘宝要义论【寂天菩萨造　宋 法护等译】
    大乘集菩萨学论【寂天菩萨造　宋 法护等译】
    菩提道灯论【阿底峡尊者造】

    █　人生佛教
    皈依发心偈
    三皈五戒次第开示【大方便佛报恩经】
    佛说信佛功德经【宋 法贤译】
    随念三宝经【现代 法尊法师译】
    佛说三归五戒慈心厌离功德经【 失译人名】
    阿毗达磨法蕴足论·学处品【尊者大目干连造　唐 玄奘译】
    佛说耶只经【南北朝 沮渠京声译】
    佛说戒消灾经【三国 支谦译】
    八大人觉经【后汉 安世高译】
    佛说父母恩难报经【后汉 安世高译】
    佛说盂兰盆经【西晋 竺法护译】
    佛说善生经【后秦 佛陀耶舍共竺佛念译】
    佛说孛经抄【吴 支谦译】
    佛为优填王说王法政论经【唐 不空译】
    般若波罗蜜多心经【唐 玄奘译】
    妙法莲华经观世音菩萨普门品【姚秦 鸠摩罗什译】
    大悲心陀罗尼经【唐 伽梵达摩译】
    伽蓝经【中阿含经 及 南传大藏经·增支部·三集·大品·六十五】
    佛说七处三观经【后汉安息国三藏安世高译】
    优婆塞戒经【北凉 昙无谶译】
    大宝积经·无量寿如来会【唐　菩提流志译】
    大宝积经·不动如来会【唐　菩提流志译】
    佛说弥勒下生成佛经【后秦 鸠摩罗什译】
    药师琉璃光如来本愿功德经【唐 玄奘 义净 译】
    地藏菩萨本愿经【唐 实叉难陀译】
    初中后善愿【宗喀巴大师造】
    随念三宝经浅说【现代 法尊法师著】
    随念三宝经注疏——吉祥妙音【当代 益西彭措堪布著】

    █　律仪守持与忏悔业障
    大方广佛华严经·净行品【唐 实叉难陀译】
    佛说优婆塞五戒相经【宋 求那跋摩译】
    大宝积经·三律仪会【唐　菩提流志译】
    大宝积经·郁伽长者会【曹魏 康僧铠译】
    佛说决定毗尼经【西晋 炖煌三藏译】
    大乘方广总持经【隋 毗尼多流支译】
    虚空藏菩萨经【姚秦 佛陀耶舍译】
    佛说观普贤菩萨行法经【刘宋 昙无蜜多译】
    大通方广忏悔灭罪庄严成佛经【又名《大通方广经》,《圣大解脱经》】
    瑜伽师地论持瑜伽处戒品【弥勒菩萨说 唐 玄奘译】
    礼佛大忏悔仪文(八十八佛大忏悔文)
    慈悲道场忏法【梁 诸大法师集撰】
    慈悲三昧水忏【唐 悟达国师撰】
    千手眼大悲心咒行法【宋 知礼集】
    优婆塞五戒相经笺要【明 智旭述】
    慈悲三昧水忏讲记【现代 演培法师述】
    走向解脱·在家篇【当代 益西彭措堪布著】

    █　三十七道品修学
    大方广佛华严经·四圣谛品【唐 实叉难陀译】
    正法念处经【元魏 瞿昙般若流支译】
    阿毗达磨法蕴足论【尊者大目干连造　唐 玄奘译】
    杂阿含经论会编【汇编自　杂阿含经　瑜伽师地论摄事分　现代 印顺法师汇编】
    大乘阿毗达磨集论【无著菩萨造 玄奘 译】
    清净道论【觉音尊者造　现代 叶均译】
    七净门与禅观诸境【马哈希法师著　智如译】
    南传菩萨道【现代 明昆三藏著】
    如实知见【当代 帕奥禅师讲】
    正念之道【当代 帕奥禅师讲】
    大正藏阿含部
    大正藏毗昙部

    █　发菩提心与六度四摄
    大方广佛华严经初发心功德品【唐 实叉难陀译】
    大方广佛华严经·普贤行愿品（广本）【唐　般若译】
    大方广如来藏经【唐 不空译】
    佛说无上依经【梁 真谛译】
    大宝积经·胜鬘夫人会【唐 菩提流志译】
    佛说施灯功德经【高齐 那连提耶舍译】
    六度集经【吴 康僧会译】
    悲华经【北凉 昙无谶译】
    禅秘要法经【姚秦 鸠摩罗什等译】
    达摩多罗禅经【东晋 佛陀跋陀罗译】
    定学经论选·九住心资料集【汇编】
    大乘本生心地观经【唐 般若译】
    佛说观佛三昧海经【东晋 佛陀跋陀罗译】
    佛说观无量寿佛经【刘宋 鍄良耶舍译】
    菩萨从兜术天降神母胎说广普经【刘宋 鍄良耶舍译】
    最胜问菩萨十住除垢断结经【姚秦 竺佛念译】
    不思议光菩萨所说经【后秦 鸠摩罗什译】
    维摩诘所说经【姚秦 鸠摩罗什译】
    思益梵天所问经【姚秦 鸠摩罗什译】
    金刚般若波罗蜜经【姚秦 鸠摩罗什译】
    佛说开觉自性般若波罗蜜多经【宋 惟净等译】
    佛顶尊胜陀罗尼经【唐 佛陀波利译】佛顶尊胜陀罗尼注义【唐 不空译】
    千手千眼观世音菩萨广大圆满无碍大悲心陀罗尼经【唐 伽梵达摩译】 现代汉语注音
    一切如来心秘密全身舍利宝箧印陀罗尼经【唐 不空译】 现代汉语注音
    佛说大方广善巧方便经【宋 施护译】
    佛说入无分别法门经【宋 施护译】
    佛说甚深大回向经
    释迦牟尼佛广传·白莲花论【麦彭仁波切 著 索达吉堪布 译】
    莲花生大师传

    █　中观
    摩诃般若波罗蜜经【姚秦 鸠摩罗什译】
    大方广佛华严经·十地品【于阗国三藏实叉难陀奉制译】
    大智度论【龙树菩萨 造 姚秦 鸠摩罗什译】
    十住毗婆沙论【龙树菩萨 造 后秦 鸠摩罗什译】
    中论【龙树菩萨 造 姚秦 鸠摩罗什译】
    十二门论【姚秦 鸠摩罗什译】
    百论【姚秦 鸠摩罗什译】
    广百论本【圣天菩萨造 唐 玄奘译】
    大丈夫论【提婆罗菩萨造 北凉道泰译】
    鸠摩罗什法师大义【东晋 慧远问．罗什答】
    三论玄义【隋 吉藏撰】
    大乘玄论【隋 吉藏撰】
    二谛义【隋 吉藏撰】
    广释菩提心论【莲花戒论师造 宋 施护译】
    古印度中观九种论著【任杰居士译】
    入中论自释【月称论师造 法尊法师译】
    入二谛【阿底峡尊者造 释如石译】
    中论略义【宗喀巴大师造疏·观空法师译】
    入中论善显密意疏【宗喀巴大师造疏·法尊法师译汉】
    中观宝鬘论颂显明要义释【龙树菩萨造颂、甲操杰大师释】
    大正藏中观部

    █　瑜伽行派（唯识）
    阿毗达磨大乘经【仅译传一颂】
    解深密经【唐 玄奘译】
    大乘密严经【唐 不空译】
    大方广佛华严经·十地品【于阗国三藏实叉难陀奉制译】
    入楞伽经【元魏 菩提留支译】
    慈氏五颂【辨法法性颂。辩中边论颂。现观庄严颂。究竟一乘宝性颂。大乘庄严经藏颂】
    瑜伽师地论【弥勒菩萨说 唐 玄奘译】
    摄大乘论本【无著菩萨造 唐 玄奘译】
    显扬圣教论【无著菩萨造 唐 玄奘译】
    金刚般若波罗蜜经论【无著菩萨造 隋 达磨笈多译】
    顺中论义入大般若波罗蜜经初品法门【无著菩萨造 元魏 瞿昙般若流支译】
    唯识三十颂【四种汉译本对照】
    唯识二十论【无著菩萨造 两种汉译本对照】
    六门教授习定论【世亲菩萨造 唐 义净译】
    佛性论【世亲菩萨造 陈 真谛译】
    十地经论【世亲菩萨造 唐 玄奘译】
    佛地经论【世亲菩萨造 唐 玄奘译】
    大乘广百论释论【护法菩萨造 唐 玄奘译】
    大乘阿毗达磨杂集论【安慧菩萨造 唐 玄奘译】
    金刚般若经赞述【唐 窥基撰】
    妙法莲华经玄赞【唐 窥基撰】
    大正藏瑜伽部

    █　净土
    佛说阿弥陀经【姚秦 鸠摩罗什译】
    佛说观无量寿佛经【刘宋 畺良耶舍译】
    拔一切业障根本得生净土神咒【刘宋 求那跋陀罗】
    佛说无量寿经【曹魏 康僧铠译】
    大佛顶首楞严经大势至菩萨念佛圆通章【唐 般刺密谛译】
    大方广佛华严经普贤行愿品【唐 般若奉诏译】
    大方等大集经贤护分【隋 阇那崛多译】
    阿弥陀鼓音声王陀罗尼经
    悲华经·西方三圣发心因缘
    观世音菩萨授记经【刘宋 昙无竭译】
    大乘瑜伽金刚性海曼殊室利千臂千钵大教王经·西方无量寿世界无边音声吼手菩萨所说分【唐 不空译】
    大方广佛华严经净行品【唐 实叉难陀译】
    大佛顶首楞严经大势至菩萨念佛圆通章【唐 般刺密谛译】
    大佛顶首楞严经卷第六四种决定清净明诲【唐 般刺密谛译】
    十住毗婆沙论·易行品【龙树菩萨 造 姚秦鸠摩罗什 译】
    十二礼偈【龙树菩萨造　禅那啒多译】
    无量寿经优波提舍【世亲菩萨造 元魏菩提流支译】
    庐山净土集【东晋 慧远】
    鸠摩罗什法师大义【东晋 慧远问．罗什答】
    昙鸾法师文集
    安乐集【唐 道绰撰】
    观念阿弥陀佛相海三昧功德法门【唐 善导集记】
    观无量寿佛经疏【唐 善导集记】
    转经行道愿往生净土法事赞【唐 善导集记】
    念佛三昧宝王论【唐 飞锡撰】
    龙舒增广净土文【宋 王日休撰】
    庐山莲宗宝鉴【元 普度编】
    莲池大师全集
    佛说阿弥陀经要解【明 智旭解】
    佛说阿弥陀经要解便蒙钞【清 达默钞】
    一函遍复【印光法师著】

    █　天台
    摩诃般若波罗蜜经·三慧品【姚秦鸠摩罗什译】
    妙法莲华经【姚秦鸠摩罗什译】
    佛说观普贤菩萨行法经【刘宋 昙无蜜多译】
    金光明经【北凉 昙无谶译】
    大智度论·释初品中四缘义【龙树菩萨造 姚秦鸠摩罗什译】
    诸法无诤三昧法门【陈 慧思说】
    金光明经玄义【隋 智顗说．灌顶录】
    法界次第初门【隋 智顗撰】
    释禅波罗蜜次第法门【隋 智顗撰】
    摩诃止观【隋 智顗撰】
    六妙法门【隋 智顗撰】
    天台智者大师禅门口诀【隋 智顗撰】
    五方便念佛门【隋 智顗撰】
    方等三昧行法【隋 智顗说】
    法华三昧忏仪【隋 智顗撰】
    法华三昧行事运想补助仪【唐 湛然撰】
    观无量寿佛经疏妙宗钞【宋 知礼述】
    金光明经玄义拾遗记【宋 知礼述】
    金光明最胜忏仪【宋 知礼集】
    金光明忏法补助仪【宋 遵式集】
    千手眼大悲心咒行法【宋 知礼集】
    法华会义【明 智旭述】

    █　华严
    大方广佛华严经(60卷)【东晋 佛驮跋陀罗译】
    最胜问菩萨十住除垢断结经【姚秦 竺佛念译】
    大方广佛华严经(80卷)【唐 实叉难陀译】
    大方广佛华严经(40卷)【唐 般若译】
    大方广圆觉修多罗了义经【唐 佛陀多罗译】
    华严五教止观【隋 杜顺说】
    华严五十要问答【唐 智俨撰 承杜顺和尚说】
    华严经旨归【唐 智俨集】
    修华严奥旨妄尽还源观【唐 法藏述】
    华严发菩提心章【唐 法藏述】
    大方广佛华严经金师子章【唐 法藏述】
    三圣圆融观门【唐 法藏述　承迁注】
    华严经传记【唐 法藏集】
    大方广佛华严经感应传【唐 惠英撰．胡幽贞纂】
    大方广佛华严经随疏演义钞【唐 澄观述】
    华严法界玄镜【唐 澄观述】
    注华严法界观门【唐 澄观述】
    新华严经论【唐 李通玄撰】
    大方广佛华严经中卷卷大意略叙【唐 李通玄造】
    略释新华严经修行次第决疑论【唐 李通玄撰】
    大方广佛华严经愿行观门骨目【唐 湛然撰】
    华严一乘成佛妙义【新罗 见登之集】
    大方广圆觉修多罗了义经略疏【唐 宗密述】
    大方广佛华严经普贤行愿品别行疏钞【唐　宗密疏】
    华严念佛三昧论讲记【黄念祖居士讲】

    █　密乘经论略集
    大方广佛华严经·世界成就品【唐 实叉难陀译】
    大方广佛华严经·如来出现品【唐 实叉难陀译】
    大宝积经·无边庄严会【唐 菩提流志译】
    大宝积经·密迹金刚力士会【西晋 竺法护译】
    大法炬陀罗尼经【隋 阇那崛多译】
    大毗卢遮那成佛神变加持经【唐 善无畏、一行译】
    陀罗尼集经【唐 阿地瞿多译】
    苏悉地羯啰经【唐 输波迦罗译】
    妙臂菩萨所问经(【宋 法天译】
    佛顶尊胜陀罗尼经【唐 佛陀波利译】佛顶尊胜陀罗尼注义【唐 不空译】
    金刚顶瑜伽金刚萨埵五秘密修行念诵仪轨【唐 不空译】
    金刚顶经瑜伽十八会指归【唐 不空译】
    佛心经品亦通大随求陀罗尼【唐 菩提流志译】
    大佛顶如来密因修证了义诸菩萨万行首楞严经【唐 般刺蜜帝译】
    大乘瑜伽金刚性海曼殊室利千臂千钵大教王经(【唐 不空译】
    佛说大乘庄严宝王经【宋 天息灾译】
    最上大乘金刚大教宝王经【宋 法天译】
    佛说大白伞盖总持陀罗尼经【元 真智等译】
    药师琉璃光王七佛本愿功德经念诵仪轨【元 沙啰巴译】药师琉璃光七佛本愿功德经【唐 义净译】
    救度佛母二十一种礼赞经
    圣妙吉祥真实名经【元 释智译】
    大毗卢遮那成佛经疏【唐 一行记】
    无畏三藏禅要【唐 善无畏】
    总释陀罗尼义赞【唐 不空译】
    金刚顶经大瑜伽秘密心地法门义诀【不空撰】
    金刚顶瑜伽中发阿耨多罗三藐三菩提心论【不空撰】

    █　禅宗
    楞伽阿跋多罗宝经【刘宋 求那跋陀罗译】
    文殊师利所说摩诃般若波罗蜜经【梁 曼陀罗仙译】
    金刚般若波罗蜜经【姚秦 鸠摩罗什译】
    维摩诘所说经【姚秦 鸠摩罗什译】
    佛说首楞严三昧经【姚秦 鸠摩罗什译】
    大方广圆觉修多罗了义经【唐 佛陀多罗译】
    大佛顶如来密因修证了义诸菩萨万行首楞严经【唐 般刺蜜帝译】
    信心铭【隋 僧璨作】
    少室六门
    信心铭【隋 僧璨作】
    最上乘论【唐 弘忍述】
    南宗顿教最上大乘摩诃般若波罗蜜经六祖惠能大师于韶州大梵寺施法坛经【唐 法海集】
    黄檗山断际禅师传心法要【唐 裴休集】
    禅宗永嘉集【唐 玄觉撰】
    永嘉证道歌【唐 玄觉撰】
    五灯会元【宋 普济集】
    景德传灯录【宋 道原纂】
    大慧普觉禅师宗门武库【 宋 蕴闻编】
    宏智禅师广录【宋 侍者等编】
    勅修百丈清规【元 德煇重编】
    观楞伽阿跋多罗宝经记【憨山大师笔记】
    禅关策进【明 袾宏辑】
    宗门无尽灯论【 东岭圆慈撰】

    █　宁玛
    大方广佛华严经(80卷)【唐 实叉难陀译】注：西藏译本华严经(80卷本)由印度班智达和宁玛派祖师毗卢遮那和移喜德参与翻译，藏传佛教部分的经典在本页中为使用内容与之对应的汉译目录。
    大乘密严经【唐 不空译】
    普贤王如来祈祷能显自然智根本愿文【根松成林曲杰嘉才仁波且译】
    旧译宁玛派密续的主要来源和目录略举【义成宁波车　著】
    莲师教言集【莲花生大师等著】
    直指觉性赤见自解【莲花生大师著】
    莲华生大士应化因缘经【诺那呼图克图口授】
    西藏度亡经（正文部分）【达瓦桑杜 英译藏，徐进夫 藏译汉】
    大乘宝要义论【寂天菩萨造　宋 法护等译】
    大乘集菩萨学论【寂天菩萨造　宋 法护等译】
    实相宝藏论【龙钦巴尊者造 贝玛多吉译】
    实相宝藏论释【龙钦巴尊者造 郭元兴译】
    四法宝鬘【龙钦巴尊者著, 谈锡永等译】
    大圆满前行引导文【华智仁波且】
    《定解宝灯论》讲义【麦彭仁波切造颂，法王晋美彭措传授，堪布索达吉译讲】
    金刚上师诺那呼图克图法语【诺那呼图克图】
    西藏古代佛教史【敦珠金刚上师造】
    大圆满的加行见地【敦珠法王开示】
    成就山法精华--大圆满修持精要【敦珠宁波车开示】
    九乘次第论集【敦珠法王等著, 许锡恩译】
    窍诀宝藏海【晋美彭措法王著】
    胜利道歌【晋美彭措法王著】
    《金刚萨埵修法如意宝珠》讲记【法王如意宝晋美彭措　造颂 索达吉堪布 译颂 益西彭措堪布 讲解】
    圆觉心法指归【智敏·慧华上师】
    窍诀宝藏海【晋美彭措法王著】
    西藏生死书【索甲仁波切著】
    大圆满之门——秋吉林巴新岩藏法【秋吉林巴掘藏，祖古乌金仁波切等讲述】
    密宗断惑论【堪布索达吉著】
    略说佛教各派互不相违【堪布索达吉著】

    █　噶举
    月灯三昧经【高齐 那连提耶舍译】
    成就胜道宝蔓集【冈波巴大师造】
    解脱庄严宝－大乘菩提道次第论【冈波巴大师造】
    密勒日巴尊者传【冈波巴大师造】
    大手印系列【沙门慧贤传】
    大手印教言──催动空行心弦【第十六世噶玛巴著，黄英杰译】
    了义炬【姜贡康著仁波切著述 郑振煌译】
    唤醒沉睡的佛【泰锡度仁波且 著】
    修行之道【泰锡度仁波切】
    解脱庄严宝论概说【堪布卡塔仁波切讲，含“大手印无上心要”“死亡无惧”“转识成智”“谈发菩提心”等四篇】
    卡塔仁波切文集【含“冈波巴四法”、“入悲智之门”、“证悟的女性”】
    创古仁波切文集【含“三乘佛法心要”“转心四思惟”“止观禅修”“月灯”“佛性《究竟一乘宝性论》十讲”】
    蒋贡康楚文集【含“修心七要”“无云晴空 ”“无死之歌”】
    空，大自在的微笑──空性禅修次第【堪布竹清嘉措仁波切 著】
    圣妙吉祥真实名经讲述【直贡法王澈赞仁波切 讲述】

    █　觉囊派所引用经论及注疏传记
    摩诃般若波罗蜜经【后秦 鸠摩罗什译】
    解深密经【唐 玄奘译】
    大乘密严经【唐 不空译】
    大方广佛华严经【唐 实叉难陀奉译】
    入楞伽经【元魏 菩提留支译】
    大方广如来藏经【唐 不空译】大方等如来藏经【东晋 佛陀跋陀罗译】
    佛说入无分别法门经【宋 施护译】入无分别总持经【（敦煌本） 失译】
    胜鬘夫人狮子吼经【唐 菩提流志译】
    大法鼓经【刘宋 求那跋陀罗译】
    央掘魔罗经【刘宋 求那跋陀罗译】
    大空经【东晋 瞿昙僧伽提婆译】空大经【现代 元亨寺译】
    大方等大集经陀罗尼自在王菩萨品【东晋 瞿昙僧伽提婆译】
    大方广入如来智德不思议经【唐 实叉难陀译】佛华严入如来德智不思议境界经【隋 阇那崛多译】
    大方等无想经【北凉 昙无谶译】大云无想经【姚秦 竺佛念译】
    大般涅槃经【北凉 昙无谶译】
    佛说不增不减经【元魏 菩提流支译】
    慈氏五颂【弥勒菩萨造】
    中观他空思想要论【多罗那他 著】
    金刚乘密法概论【多罗那他 著】
    七系付法传【多罗那他著，郭元兴译】
    印度佛教史【多罗那他 著 张建木 译】
    觉囊派教法史【阿旺·洛追扎巴 著 许得存译】

    █　噶当派所引用经论及后世各派注疏
    大方广佛华严经(80卷)【唐 实叉难陀译】
    法句经【吴 维祇难等译】
    菩萨本生鬘论【宋 绍德慧询等译】
    瑜伽师地论·菩萨地【弥勒菩萨说　唐玄奘 译】
    入菩萨行论【寂天菩萨造论　如石法师编译】
    大乘集菩萨学论【寂天菩萨造　宋 法护等译】
    集量论略解【陈那菩萨造，沙门法尊译编】
    大乘庄严经论【唐 波罗颇蜜多罗译】
    剑轮修心法【印度·法护大师著】
    入菩萨行讲记【印度·法护大师著，嗄汪达耶格西注释】
    菩提道灯论【阿底峡尊者造】
    入二谛【阿底峡尊者著】
    菩提道灯释【阿底峡尊者著】
    入菩萨行讲记【寂天菩萨造论　堪布索达吉传讲】

    █　格鲁
    现观庄严论【弥勒菩萨 造】
    俱舍论【世亲菩萨 造】
    入中论【月称菩萨 造】
    释量论【法称菩萨 造】
    戒经本论
    菩提道次第广论【宗喀巴大师造 法尊法师译】
    菩提道次第略论【宗喀巴大师造】
    菩提道次第略论科判表【宗喀巴大师造】
    菩提道次第摄颂【宗喀巴大师造】（广译本）
    菩提道次第心论【宗喀巴大师造·能海上师集】
    证道歌【宗喀巴大师造】
    修“菩提道次第”初修法门【慧幢法师著】
    三主要道【宗喀巴大师造颂·帕绷喀讲授】
    缘起赞【宗喀巴大师造·昂旺朗吉堪布讲授】
    最胜耳传修心七义论讲记【昂旺朗吉堪布讲授】
    修定修观法要【昂旺朗吉堪布口授,郭和卿译】
    甘露心华--菩提道次第论《道之三主要》释义【祈竹仁宝哲开示】
    菩提道次第略论释【宗喀巴大师造·昂旺朗吉堪布释】
    大乘菩提心法【无著贤论师造】
    菩提道次第简述【法尊法师著】
    略说三主要道心要【昂旺敦振居士讲】
    甘露心华--菩提道次第论《道之三主要》释义【祈竹仁宝哲开示】
    兜率天上师瑜伽法导论【夏坝仁波切】

    █　萨迦
    量理宝藏论【萨班·庆喜幢 编著，明性法师　中译】
    大乘要道密集【八思巴大师 著】
    《萨迦派上师开示录)【含“远离四种执着修心法集解”等四种著作】
    《萨迦世系史》【阿旺贡噶索南 著】
    《萨迦世系史续编》【衮噶罗追 著】


隆钦宁提见、行、果祈愿文

    隆钦宁提见、行、果祈愿文

    自生金刚 仁波且 掘藏
    昂藏珠巴 仁波且 传授
    法 嗣 慈诚嘉成 汉译

    顶礼法身普贤尊!

    原始本性自性离戏论，非有未见佛陀法身面，非无生死涅盘收摄处，
    不相矛盾超越所诠境，大圆满见本性愿通达！
    体性本空常边得解脱，自性明现断边而脱离，大悲无碍种种变化基，
    三者差别意义无差别，大圆满见本性愿通达！
    不可思议远离诸增益，有无偏执行相胜断灭，此义言说穷尽佛陀舌，
    无初中后深明大法界，大圆满见本性愿通达！
    自性清净无生本无垢，任运无为虹霓彩现起，不执一边明空大双运，
    思维见之密意量行持，行之根本要点勿迷失！
    本来清净见之名亦无，自性认知修行因外立，不定星曜运行离系缚，
    自性胎住离戏赤裸境，行之根本要点勿迷失！
    好坏寻思无偏执刹土，平等行舍无记遍无边，生散无痕放任极广刹，
    取舍本尽自性遍智境，行之根本要点勿迷失！
    原始本见如同虚空境，初显明识如云入虚空，后现智识向内而返归，
    具六特征童子瓶身中，果位王之胜要地速持！
    原始自明法身普贤尊，所得欲意边净法界散，离精勤意大圆满体性，
    界明普贤王母空界中，果位王之胜要地速持！
    极无所住大中观胜义，法性广大大手印自性，边际解脱广大圆满要，
    地道功德基智天成中，果位王之胜要地速持！
    心要广大深密意，尽摄甚深此愿文，守誓护法垃呼拉，僧相敦促而告示，
    密意散布有利益，缘起圆满愿文故，虚空藏尊所加持，贡娘隐藏之持明，
    深密解说嘱神护，利益量等虚空众。
    吉祥！
    自生金刚心藏密伏藏，见修果之甚深此愿文，
    应当清净信解虔诚诵，诸众悉皆安立原始地。
    此偈为古夏巴所说

    吉 祥 圆 满


“中华佛典宝库”发起录入、校对《嘉兴续藏经》的行动！

“中华佛典宝库”发起录校《嘉兴续藏经》的行动！

    “中华佛典宝库”上转码成大陆版的《大正藏》为大陆四众弟子带来了修学佛法上的巨大利益，这是受惠于“中华电子佛典协会（CBETA）”等机构数年努力录入《大正藏》的结果。2002年起CBETA发起录入《卍续藏》的计划，宝库积极支持并呼吁大陆的四众弟子和愿意弘扬佛教文化的善友们共同参攘盛举，每人随缘校对若干页，以便大家一起完成《卍续藏》的电子版。 目前宝库所分配到的录入的若干个分卷录入接近完成，有待进一步的校对。
    在以上两个藏本的基础上，要构建中国佛教古籍部分的全集，仍有一些大篇幅的文献总集需要录入，其中居于优先地位的应该是《嘉兴续藏经》和《敦煌藏》中尚未录入的佛教文献，宝库 拟先从刻本比较清晰的《嘉兴续藏经》开始。《嘉兴藏》，又名《径山藏》，发起于明嘉靖末隆庆初年，到清康熙十五年完工，全藏分“正藏”、“续藏”和“又续藏”三个部分。《嘉兴藏》的“续藏”“又续藏”收录了大量以往从未入藏的佛教文献，到今天为止，《嘉兴藏》中还有288种典籍未曾被包括《卍续藏》、《大正藏》在内的任何新编大藏经收录过。这是中国佛教界佛教典籍的一笔丰厚的积累。
    宝库预备提供扫描图象，首先征集志愿者网友OCR藏经文本，宝库负责统一整理，提供下载并集中管理录入文本，然后再征集志愿者网友进行录入、校对。报名参加的人请发信给宝库，信的标题为“参加校对《嘉兴续藏经》计划”，信中报名愿意先行OCR或校对多少页，宝库收信后即分配任务。志愿者可分批次校对，例如首次10页，如果校对顺利，也可续报。
    宝库拟继续发行《中华佛典宝库》光盘，包括中华佛典宝库网站的藏经、藏外佛教文献的主要内容和电子佛学辞典。对每一位志愿参与《嘉兴续藏经》校对者，将赠与一张《中华佛典宝库》光盘。愿意受赠者请在信中附上邮寄地址。
    中华佛典宝库亦致力于其它藏经、佛经、藏外佛教典籍文献和现代佛教著作的校对录入，非常欢迎有相关志愿的善友以个人或团体身份共预其事，其基本的工作流程和上述续藏经的过程相类似。志愿加入请写信到：
    fo-dian@163.com, shilingfeng@sohu.com