目录


内容提要

  唐玄奘一生修行历程
    俞佩明 著
    河北少年儿童出版社
    明天出版社
    河南教育出版社

    内容提要

    本书是河北少年儿童出版社、明天出版社、河南教育出版社协作编辑出版的《历史人物小故事丛书》中的一种。
    唐僧，法名玄奘，是中国古代杰出的旅行家、探险家、翻译家和佛教的宗教哲学理论家。唐朝初年，他冒险西出玉门关，孤身越过大沙漠，历尽千难万险，终于到达印度。他在印度游学十几年，虚心学习佛法，刻苦研读佛经，在全印度大法会上获得了至高无上的荣誉。归国后，他尽心著述，努力翻译，为祖国的文化事业，为中国和印度人民的友谊做出了非凡的贡献。本书以故事的形式，生动、形象地介绍了唐僧玄奘的一生。


一、佛教的影响

    隋朝末年，在洛州缑（gōu勾）氏县（今河南偃师县西南），有一个依山临水的小村落，叫陈堡谷。村子西头相传就是唐僧玄奘诞生的地方。玄奘本来姓陈，名叫陈祎（huī灰），玄奘是他出家以后的法名。
    陈祎的曾祖和祖父都做过官。父亲陈惠曾经当过隋朝的江陵（在今湖北省）县令。由于隋朝末年政治腐败。陈惠就辞官回乡，过起了隐居生活。
    大约在隋开皇二十年（公元600年），陈家出生了第四个儿子，陈惠给他取名陈祎。
    陈惠常常把几个孩子叫到一起，对他们讲解学问。陈祎五岁时有一次和哥哥一起，听父亲讲《孝经》。
    “今天我讲的是曾子避席。”陈惠一边说，一边把“曾子避席”四个字写在纸上，给识字还不多的小儿子看。然后慢慢说了起来：
    “古人没有椅子，都是席地而坐的。孔子向他的学生讲书，学生们也就坐在席子上。他的学生很多，曾子就是其中的一个。
    “那天，孔子和学生们一起谈论天下大事，说着说着，他忽然提了个问题，叫曾子回答。
    “曾子本来聚精会神地坐着，听着，见老师要他回答问题，赶紧站起来，往边上一站，并且垂下双手，毕恭毕敬地回答了孔子的提问。
    “这就是’曾子避席’的故事。以后‘曾子避席’就成了尊敬师长的典故。你们明白了吗？……”
    说到这里，陈惠突然不讲了。原来，陈祎霍然站了起来，并且整理好衣襟，恭恭敬敬地站在父亲面前，回答说：“孩儿明白了。”
    陈惠心里一动，问他：“你明白就是了，干吗站起来呢？”
    “父亲不是问我们明白了没有吗？这就像孔子问他的学生曾子。曾子回答老师的问题要避席，我回答，明白了，当然也要避席。”
    “哦，原来你的理解力这样强！”陈惠心上高兴，摸着胡子笑了起来：
    打那以后，陈惠更喜欢小儿子了。
    陈惠给儿子们讲解学问，主要讲的是儒家的经书，有时也讲一点佛经。
    为什么他讲佛经呢？原来，信佛教是当时的一种社会风气。
    佛教和基督教、伊斯兰教，并称为世界三大宗教。它的创始人释迦牟尼，是和中国孔子差不多同时代的人。佛教最初起源于尼泊尔、北印度一带，被定为印度的国教，汉朝时传入中国。
    按照佛教的教义，人的肉体是要死亡的，但是人的灵魂却会永远存在，并且转生来世。不论什么人，只要活着能忍受一切苦难，诚心诚意地修行，来世就可以脱离苦海，如果他几辈子做人都能这么忍受苦难，一心修行，那么，最后就可以到达“无烦恼、无痛苦、无罪恶”的“极乐世界”。这个佛教教义对于受剥削和奴役的劳动人民来说、是很有吸引力的。许多人这辈子受苦受难、就把希望寄托在下一辈子、于是，他们信了佛教。
    封建统治者也很愿意老百姓信佛教。因为佛教劝人安分守己，忍受剥削和压迫，为“来世”创造幸福。这对于封建统治阶级当然是有利的。假如人们都能够在被压迫、被剥削的苦难生活里安分守己，那就不会有人造反，也就不会有农民起义了。所以，当时的统治阶级就大力提倡佛教，利用它来作为麻醉和统治人民的工具。
    也有一部分人，不仅信佛教，而且索性出家为僧，男的当和尚，女的做尼姑。他们一辈子不吃肉、不结婚。这些人中间入固然有虔（qian钱）诚的佛教徒善男信女；但也有不少人，只是为了逃避繁重的赋税和谣役负担，才出家进寺院的，因为当了和尚、尼姑就可以不交赋税，不服徭役。
    中国从东晋以后、佛教的兴盛，僧尼的激增，使佛教寺院遍及全国。唐朝时有个诗人写过一首《江南春绝句》的诗，说：“千里莺啼绿映红，水村山郭酒旗风。南朝四百八十寺，多少楼台烟雨中！”光是从四百八十所寺院这个数字，就可以想像当时佛教的兴旺。
    信佛教既然是当时的社会风气，陈惠自己信佛，并向儿子们讲讲佛经，也就没什么奇怪的了。不仅如此，陈惠的第二个儿子，也即陈祎的二哥陈素，还在洛阳净土寺出家当了和尚，法名长捷。
    少年时代的陈祎，就生活在这样一个佛教气氛很浓的家庭里。


二、破格出家

    陈祎从小聪明，理解力强，记忆力也好。他八九岁时开始诵读经书，在父亲指点下，养成了广泛研究学问的兴趣，尤其爱好佛学。可惜，陈祎十岁那年，“父亲不幸去世了。
    二哥陈素很关心小兄弟的学业，问他愿意不愿意随自己到洛阳去，继续学习佛经。陈祎听了这话，马上点头说好。第二年，他真的跟着二哥来到了洛阳。
    洛阳是隋朝的都城，也是当时佛教的中心，寺院遍布，香火旺盛。有四个寺院是经常讲经的场所。陈素每次到那些寺院听高僧讲经，都要把小兄弟陈祎带去，让他学习、熏陶。慢慢地，小陈祎就产生了想当和尚的念头。 　　当时，要做和尚可不是那么随便、那么容易的，必须经过政府有关机构的考选，获得准许，然后进行剃度（剃发出家），发给度牒（和尚的证书）。
    陈祎对二哥说了自己的想法，二哥非常支持，叫他多念佛经，同时等待剃度的机会。到了他十三岁那年，机会可真的来了：
    隋大业八年（公年612年），隋炀帝派大理寺卿（中央政府中掌管司法、刑狱的大官）、郑善果到洛阳，考选人才，预备剃度一批和尚。陈祎听到消息，马上兴冲冲地赶去报了名。
    这一次郑善果到洛阳，剃度的名额只有二十七个，可是报名的却有好几百人。他于是邀请在洛阳的几位高僧一起主持考试，从中挑选出合格的人来，考试这天，陈祎的情绪分外紧张，心头像小鹿儿似的撞个不停。他眼看着应试的人一个一个地被叫进去，过一会儿又一个一个地走出来，有的脸孔发红，有的唉声叹气，只偶尔有个把人出来时嘴角挂着一丝笑容。轮到陈祎了，他整整衣冠，克制着内心的激动，尽量镇静地走了进去。
    没多久，陈祎出来了，他的嘴唇闭得紧紧的，眉头挤得拢拢的，低着头，只管朝外跑。等在门外的二哥赶忙迎上去，间道：“怎么样？行吧？”
    “唉！”陈祎叹了一口气，摇了摇头。“考得不好？”
    “我已经尽了最大的努力了，可是，大理寺卿说我年岁大小，他边上两名法师（对有学问的和尚的称呼）问我读过哪些佛经，我照实回答了。他们说我经读得还不多。”
    “这也难怪。”二哥安慰他说，“你既然尽了努力，也就不要再难过了。”
    “可是，那两位法师提出的关于佛经的解释的问题，我本来是可以答好的，谁知心里一紧张，说得结结巴巴，而且漏掉了不少。我真懊恼！”
    二哥只好劝他：“俗话说：‘过了初一，还有十五。’你今年虚岁才十三，就是这回没考上，以后还会有机会的。”
    话是这么说，可陈祎的心里却总不是滋味儿，无奈，他只得快快地跟着二哥回净土寺去了。
    那天考试的结果很快揭晓，陈祎果然榜上无名。
    要说陈祎经读得还不多，他是承认的。可是，他又想，我也可以当了和尚再继续读，读上一辈子嘛！至于说陈祎年龄小，他根本就不服气，有志不在年高，无志空活百岁。佛经上也从来没规定，要多大岁数才可以当和尚。而他最懊恼的，是因为心里慌张，没能把两名法师出的关于佛经解释的问题回答好。这么想着，想着，他就信步跑到了大理寺卿办公事的衙门口。
    陈祎在衙门走过来走过去，指望能碰到郑善果本人，然后，要是可能的话，请他给自已一次补考的机会。假如再考得不好，就没话说，下回再努力。
    他入神地想着该怎么跟郑善果提出请求，有个轿子回衙门里来他也没注意到。
    轿子上的人正是郑善果，他老远就瞧见了衙门口有一个走来走去的少年。
    郑善果的轿子到衙门口停下了，他觉得这个少年有点面熟，可一时间怎么也想不起来，就叫他走近些，往往笑眯眯地问道：“娃娃，你是谁家的孩子？”“启禀大人，”陈祎见大理寺不像上回考试老板着脸，就行礼回答道：“我姓陈名祎。先父叫陈惠，当过本朝江陵县令，二哥出家在净土寺，法名长捷。”
    郑善果想起来了，点点头，和善地问陈祎：“你要出家，是吗？”“是的。我有志于剃度出家，但因为根基浅薄，没有达到愿望。”
    郑善果心里一动，对了，那天我也说过他年龄似乎小了一点的话，看来小家伙不死心哩！
    “你这么小一个孩子，为什么一定要出家呢？”
    “我出家只是希望继承佛祖如来（即释迦牟尼）的事业，使佛教教义发扬光大。”
    大理寺卿听他小小年纪这么有抱负，有志向，不由得点头夸奖了几句。他问陈祎读过什么经书。陈祎像考试那天回答的那样说了一遍，并且说：“那天我回答关于佛经解释的问题，由于一时紧张，没有答好，大人如果允许，是不是可以让我再考一回？”
    郑善果想了想，答应了这个请求，当时就叫手下人去把两位协助考试的法师请到衙门来，面试陈祎。
    这次考试，考场既不像上回那么威严，主考官的脸色也比较和气。陈祎一点不慌张，从容不迫地回答了法师提出的考题。
    郑善果见他对答如流，好不高兴，和两名法师商量了一下，决定破格录取这位有志于佛学的少年。
    陈祎高兴极了，立即跪下，向主考官们磕了个响头。
    第二天，他接受剃度，把头发剃了个精光，身上也披上了袈裟。
    陈祎本来长得唇红齿白、相貌堂堂，剃光了头发，披上了袈裟，更显得干净利落，一表人才，郑善果满心欢喜，感慨地对同僚们说：“这个孩子风骨难得，将来必能成为佛门栋梁。可惜我年岁已大，恐怕等不到他成才的那一天了。”
    郑善果说的话，后来果然都成了事实。
    从这天起，陈祎就有了一个法名——玄奘。


三、佛门“千里驹”

    唐僧玄奘原来是因二哥长捷和尚的关系，借住在净土寺的，如今他自己当了和尚，就名正言顺地在净土寺住下学习了。
    净土寺里有两名和尚：佛学造诣很深，一个叫景法师，一个叫严法师。他俩分别给和尚们讲解《涅 （pdn盘）经》和《摄大乘论》，这两种佛教经文都不大好懂。可是，玄奘专心致志地听讲，废寝忘食地钻研，并且时常拿着经卷向两位法师请教，终于弄懂了经文的内容。
    有一次，唐僧玄奘把严法师讲的《摄大乘论》，有条有理，完完整整地复述了一遍。这使寺里的和尚们非常惊讶，都说郑善果有眼力，发现了一个难得的人才；对于玄奘的刻苦努力和迅速进步，更是感到十分佩服。
    但是，唐僧并没有能在洛阳长久地学习下去，这是为什么呢？
    原来，隋大业十三年，隋朝的封建统治已经被农民起义军打得摇摇欲坠。这时，隋朝的太原留守、贵族李渊，在他的儿子李世民的怂恿下，利用这一有利情势，起兵夺取长安（今陕西西安市），占领了今陕西省一带。第二年春天，昏庸荒唐的隋炀帝在扬州被他的臣子杀掉。李渊就自己做了皇帝，建国号叫做唐。
    隋炀帝是被杀死了，李渊也正式宣告自己做了皇帝，可是，洛阳却仍旧处在隋朝残余势力王世充的黑暗统治下。连年的战争把洛阳搞得凋零破败，到处断墙残垣，路有饿尸。和尚们连肚子都吃不饱，也就不大顾得上讲经说法，谈学论佛了。好在出家人四海为家，不少和尚也就纷纷离开洛阳，云游四方。
    唐僧瞧这情形，呆在洛阳实在不是长久之计。他便对长捷说：
    “二哥，眼下局势这么混乱，隋朝的天下眼看着完了，咱们何必在这里干坐着等死呢！”
    长捷点点头：“是啊，连咱寺的景法师都走了，咱们也跑吧。”
    “听说唐皇已经占了长安，天下归依，咱们何不投奔到长安去？”
    “好，我也正这么想呢。”长捷说着，就叫兄弟赶紧收拾行装。
    出家人的行装再简单不过，一件袈裟，一个钵盂，一份度牒，外加几卷经书，打在青布包袱里，背上就可以走。兄弟二人第二天一早就离开了洛阳。
    从洛阳到长安，路不算远，可长安已是唐王朝的范围。玄奘和长捷到了长安，就在庄严寺里住下了。
    但是，没多久，唐僧就发觉这里的佛教事业并不兴旺。因为这时唐王朝刚刚建立起来，正处于百废待兴的状况；而且，李渊、李世民父子，还没把整个中国统一起来，更没有工夫关心到佛学。长安这么大一座古城，居然没有一处开讲佛经的场所！
    既然寺庙不讲经，那就找几个佛学学问好的和尚请教请教吧。唐僧打听了一下，想不到，原来在长安的高僧学者，也都离开长安，到四川去了。因为在隋末唐初这段时期，中国的四川受战争的影响比较小，所以当时许多名僧和研究佛学的学者，大都集中到了四川。
    唐僧求学不成，只得和二哥一起离开长安，经子午谷前往四川。
    他们走到汉川（今陕西南郑县）、遇见了两个也准备去四川的和尚，一个叫空法师，一个就是洛阳净土寺的景法师。玄奘很高兴，一路走，一路向两位法师请教学习。四个人边走边讨论着佛学，一个多月后，结伴儿来到了锦城成都。
    四川号称“天府之国”，加上近年来战火没有波及，所以呈现出一派太平景象。从各地游移来的佛学大师，到处大开讲席，传授佛经，有的和尚还与道教展开辩论，很有生气。唐僧看到这番情景，非常高兴。
    唐僧跟从道基等法师学习。他专心致志地潜修学问，珍惜每一寸光阴，在短短两三年内，就精心研究了佛教的重要经典。
    唐武德五年（公元622年），二十三岁的唐僧在成都受了“具足戒”。这个“具足戒”又称为“大戒”，是佛教僧尼的最高戒律。佛教徒们认为，要成为一个合格的僧侣，必须经过长期的修行，而一旦被授予“具足戒”，就说明这个人在佛学上已经具有了很高的、精湛的造诣。
    唐僧尽管已经成为一个公认的有学问的人，但他仍然不满足，希望能够继续得到深造。他在成都学习了几年，差不多已把四川所有的佛经都研究遍了，感到再留在这里进步不会太大，于是向二哥提议，到各地去访求名师，结识学友。
    长捷听了兄弟的提议，却不像当初离开洛阳那会儿，说：“兄弟，你我二人在四川，都已有了不小的声望，再说，这里衣食住行样样不愁，于吗还要日晒雨淋地，东跑西走呢！”
    “原来是这样！”唐僧明白了二哥的心思——他满足于已经掌握的佛学知识，贪恋着成都宁静安逸的生活啊——既然这样，人各有志不能勉强，那就分手好了。他想到这里，就说：
    “那也好，我一个人走。”
    “什么，你一个人走，不行，我不同意。”长捷连连摇头。
    “二哥，这就是你的不是了。我请你一起走，你不愿意走；我自己一个人走，你又不肯放我走。”唐僧说到这里，见长捷板着脸，改换了口气，“兄弟我无论走到哪里，永远也忘不了二哥您对我的关怀和教诲！”
    长捷知道理亏，把眼睛闭上了。
    唐僧明白，要二哥同意他走，实在很困难：“好吧，那就瞅个机会溜走得了。”
    没几天，唐僧打听到有个商人将要乘船出四川做生意，就决定和他结伴同行。他留下一封信给二哥，独自走了。
    从此，唐僧和长捷天各一方，彼此再也没有见过面。
    商船离成都，入长江，过三峡，很快到了荆州（治所在今湖北江陵县）。唐僧告别商人上了岸，在天皇寺住下。
    他在天皇寺，和那里的法师等人一起研究、讨论了不少佛学问题。当地的和尚和佛教徒知道唐僧对佛学很有研究，也经常请他开席讲解佛经。
    半年以后，唐僧离开了天皇寺，到河南、河北等地，一面讲解佛经，一面虚心向有学问的人请教。在这个过程中，他不仅读了很多佛教经典，而且研究了佛教各家各派的学说。
    唐僧常想，当初他和二哥到长安时，佛教事业固然很不景气；可是如今，好几年时间过去了，长安毕竟是唐朝的首都，不会再像当初那样的。于是，他又到了长安。
    果然不出所料，这时的长安，佛事已经兴盛起来，讲经说教的活动也很频繁。唐僧就经常在长安大觉寺听法常、僧辨两位佛学大师讲解佛经。
    由于在许许多多听讲的和尚中，唐僧学习和理解得最好，因而不时得到两位法师的称赞。法常和僧辨两人还感慨他说：
    “我们都已老朽，恐怕不能看到玄奘日后的伟绩了。他真是佛门的‘千里驹’啊！”
    两位佛学大师对唐僧的赞扬传出后，“佛门千里驹“的名声立时传遍了长安城内外。


四、立志西行

    唐僧出家十多年来，在国内到处寻访有名的佛学大师，请问求教，弄通了不少重要的经典。但是，他的学问愈广博，疑问也就愈多。尤其是他发现佛教的宗派林立，教义各不相同，很难说哪个才是正确的，极有必要对于各种宗派及其理论作进一步的探讨。
    同时，他也感到，佛教经典的译本太少了；有些译本不但文笔拙劣，晦涩难懂，而且错误的地方很多。唐僧着重研究的是大乘佛教的“瑜伽（yú qié余茄）法门”，而这方面的系统经典的译本，更加残缺不全。
    为了解决疑义，深入研究，弄清佛教的根本，传授较好的佛经译本，他认为非亲自到天竺（今印度）去留学不可。
    恰巧在唐僧二十七岁（公元626年，唐武德九年）那年冬天，中印度（印度有东、南、西、北、中五部分）学者波颇密多罗从海路航行到中国，住在长安。这位波颇密多罗是印度权威学者那烂陀寺戒贤法师的学生，据说能记诵大小乘经典各十万颂①。唐僧遇到这么有学问的老师高兴极了，他诚恳地向其请教，求问多年来积下的疑难问题。他从这位老师那儿，不仅在佛学上得到了很大的收获，而且知道，中印度有个全印度最宏大、最壮丽的佛教寺院那烂陀寺，寺里有位全印度人人景仰的佛教权威戒贤法师，这位法师非但深通“瑜伽”，对于佛教其他宗派也都精熟，
    从这以后，唐僧更加向往印度，尤其向往中印度的那烂陀寺。他到印度去留学的志愿愈加坚定了。
    但是，中国和印度之间，有险峻的喜马拉雅山阻隔，在交通还不发达的一千三百多年前，人们如果走陆路到印度去，只好绕一个大圈子：从长安出发，经过今甘肃、新疆，向西越过葱岭（帕米尔），进入中亚细亚，再由兴都库什山脉的缺口，到达北印度的旁遮普。这条道路是漫长而危险的，特别是要通过茫茫千里的大沙漠，险阻万重，随时随地都可能把性命送掉！
    困难虽大，却挡不住唐僧的决心。他并且以前人作为楷模，用事实激励自己。这楷模就是：公元5世纪初，佛教徒法显和智严经历千辛万苦，终于到达印度，取得了佛经。唐僧说：“要想有所作为，就应该拿这两位前辈作榜样！”
    可是，他的决心一开始就受到了挫折。挫折首先来自朝廷方面。因为这时唐王朝还没有
    实现全国的统一；北方及河西(今甘肃省境内黄河以西地区）一带，存在少数民族突厥侵扰的威胁。所以国家对老百姓出境的限制极其严厉。法律规定，凡是出国的人，必须得到国家的批准，并且领得“过所”才能出发。他约好几个同伴，正式向朝廷提出申请。可是，他们的申请迟迟没有得到批准。
    他们等待了好久，始终杳无音讯。别人都退缩了，只有唐僧毫不灰心。他一边等待出境的机会，一边专心致志地学习印度和西域各国产语言文子，偷偷打听从陆路去印度的路线，为出国西行进行各种准备。
    唐僧在长安隹 得久了，渐渐明白，唐王朝政府之以不像隋朝推崇佛教，还有一个皇帝本人信仰的问题。
    唐朝的皇帝姓李，道教的祖师老子李耳，也姓李。
    唐高祖为了表示自已的祖父先多么了得，就自称是李耳的后代，并且此而抬高道教的地位，把佛教放在道教之下。
    唐武德九年，李渊的儿子李世民即位做了皇帝，就是唐太宗。唐太宗对于佛教的看法与他父亲相同，因而，唐僧提出的关于出境请求还没有得到批准确，
    安一带遭到严重的自然灾害，庄稼大多给霜、雹毁损，收成极坏。老百姓都饿着肚子，成了统治者头痛的“饥民”。
    唐太宗李世民拿不出许多米面填饱“饥民”的肚子，又怕他们铤而走险造成麻烦，于是下了一道命令：所有缺粮的人都可以逃荒到丰收的地方去要饭吃。
    趁着这个机会，唐僧提了个简单的行李包，混在外出逃荒的人群中，离开长安，踏上了西行的道路。
    他走出长安没有多久，碰到了一个法名叫孝达的和尚。这和尚是从秦州（今甘肃天水）来到长安学习佛经的，眼下正准备返回秦州去。唐僧听说他正好也往西走，就和他结伴同行，到了秦州。
    在秦州，他遇到了一些从凉州（今甘肃武威县）到秦州送官马来的人。这批人正要口凉州去，于是，他就随他们到了凉州。
    凉州是河西的大都市，唐朝西境的国防重镇；奉命镇守这一地区的凉州都督李大亮，严禁人民私自出境。唐僧没有“过所”只好在这个人生地不熟的城市暂且住下来，慢慢想办法。
    这时的唐僧，已经在佛学界颇有名声，他到达凉州的消息，很快在各个寺院和佛教徒中传了开来。人们请求这位高僧为大家讲讲经。他就在一个寺院里，为当地人士讲了一个多月的经。
    唐僧讲经条理清晰，深入浅出，不仅获得了凉州官绅百姓的崇敬，也使参加听讲的西域各国商人感到钦佩。原来，唐朝政府虽然禁止百姓西行，但却不禁止西域人特别是西域商人东行到凉州等地做生意。所以，往来于凉州的很多西域商人，每逢唐僧开席讲解佛经时，都跑去听讲。他们回去后，纷纷在本国君王面前称赞唐僧博学多才、满腹经文，说得西域各国的君王和僧人们，都望眼欲穿地盼着唐僧能到他们那里去讲经。
    唐僧在凉州的名声大振。有人向都督李大亮报告了这一消息，并且说，这个从长安来的和尚可不是只在凉州讲讲经就算了，他要到天竺去取经呢！
    李大亮听说他想要西行，这件事关系到自己的职责，就派人把唐僧找来，问：“法师到凉州一个多月了。不知法师究竟为了什么从京都长安来到这边防僻地？”
    唐僧毫不隐瞒地口答：“贫僧想要西行，求法取经，学习佛教真义，所以从长安来到凉州。”
    李大亮听说他果然打算西行，面孔一板：“朝廷明令，无论什么人都禁止西行。法师又没有出国的‘过所’，怎么可以出境！你还是快快口长安去，否则，别怪我无礼！”
    唐僧听李大亮的口气这么硬，料定即使说破嘴皮也别想得到他的同意，于是只得默默地退下。
    他闷闷不乐地口到借住的寺院。寺院的当家和尚慧威法师见他愁眉不展，就间他为什么事担忧。唐僧如实地把自己的志愿和今天见李大亮的情况说了一遍。
    慧威法师十分同情唐僧，他想了大半夜，决定派手下两个小和尚惠琳和道整，、带引唐僧偷偷溜出凉州。
    第二天夜里，唐僧怀着感激的心情，由惠琳、道整两个小和尚护送，悄悄离开了凉州城。
    私自出境，当然是一件严重犯法的事情）唐僧早已把生死置之度外，可是，万一叫官兵发觉了，不仅西行求经学佛无法继续，还会连累慧威法师和两个小和尚。他们三人只好白天休息，晚上赶路，一步一步地走过张掖（业），出嘉峪关，几天后赶到了瓜州（今甘肃安西）。
    途中，道整先去了敦煌；到瓜州后，唐僧看慧琳年纪既小，身体又不好，估计他也行不得远路，就打发他回凉州去了。


五、滞留瓜州

    瓜州刺史复姓独孤，单名一个达，他和凉州都督李大亮有很大的不同：李大亮不信佛，对出家人一点不客气；独孤达却是个虔诚的佛教徒，对唐僧这位高僧极其恭敬有礼。
    独孤达把唐僧接到他那里住下，了解了他西行的原由，然后问：
    “法师既然立志西行，我决不留难。但是，法师对于西行的路线，是不是打听清楚了？”
    “实不相瞒，我只想着去天竺取经学佛，对于西行的路线却还不大清楚。”
    “那我倒可以贡献一点意见。”独孤达说着、把西行的路线向唐僧作了一番介绍。
    从瓜州西行，有两条道路可走。一条是北道，一条是南道。南道由瓜州到敦煌，从敦煌过去，沿着今天的阿尔金山脉，经鄯（shan善）善（今新疆若羌县）、于阗和田，今新新疆和田县），折向西北到莎车，然后从那里越过葱岭，进入今中亚细亚地区，再向西南行，可以到印度。这条路线比较艰险，不大好走。
    北道比南道安全些：由瓜州向北到伊吾（今新疆哈密）、高昌（今新疆吐鲁番），然后沿天山南麓西行，经屈支（今新疆库东县）到疏勒，由疏勒越过葱岭，进入今中亚细亚地区，再向西南，到罽（计）宾（今克什米尔一带），它的南面，就是北印度了，当时商人的旅行队伍大多走北道。
    唐僧听独孤达说明了路线，心想自己路既不熟，又是单身西行，当即决定走北道。
    “可是，走北道也困难重重哪！”独孤达说，“从瓜州向北行五十多里，就有一条葫芦河（今疏勒河）。葫芦河河身上游狭窄而下游宽阔，水深流急，很难渡过。河面上虽说有一座桥，但是河对岸桥头的玉门关上，有军队把守，没有‘过所’，决不会放你过去！”
    唐僧皱了皱眉头，沉思起来。
    独孤达想，唐僧单身一人，往西行去多半会死在半路上，还是劝他打消这念头。留在瓜州为大家讲讲经吧。
    他接着就说：“玉门关是西行的必经之路。就算你出得了玉门关、）前面还有八百里莫贺延碛（泣，莫贺延碛又名沙河，即今大戈壁沙漠）。那里有五座烽火台，每座相距一百多里，上面都有军队把守，专门拦阻私自出关往西行的人。因为沿路只有烽火台下才有水草，所以，它们也等于是必经之路。法师没有‘过所’，当然也是通不过的。”
    “要是玉门关和五座烽火台都通过了呢？”唐僧他自己也不知道这一关和五台到底通得过通不过，但是把路上的困难了解得详细一点，总是有好处的。
    “那还有八百里大沙漠呀！这是一大片一眼望不到边的不毛之地，上无飞乌，下无走兽，没水没草，人马难行。大风一起，沙尘会把天空全都遮住；风过后，沙石如雨，旅行队伍往往不幸被活埋在沙石下面。沙漠里的天气又变化莫测，白天烈日当空，热风似火，弄得旅行的人气都透不过来；夜里磷火闪闪。寒风如刀，可以活活把人冻死。途中常可见到堆堆尸骨，他们都是因企图穿过戈壁沙漠而丧生的人，令人看了毛滑惊然，就算这大沙漠也被你闯了过去，也只到了伊吾。再往前去，我就不清楚了，听人说，后半程的危险还有许多呢！”
    唐僧听到这儿，不仅大体上了解了沿途的艰辛，也明白了独孤达劝阻自己西行的意思。但他早已下定决心，哪管生死安危，不达到目的誓不罢休。于是，他向独孤达合掌致谢，并重申了自己的志向。
    独孤达见他如此坚定不移；只好恳切他说：“法师既然执意西行取经，我也不敢拦阻。但是这条道路上实在充满着危险，还望法师三思而行！”
    唐僧笑了笑，说：“多谢你的关照。但我宁死也要去天竺，不取到真经决不回长安！”
    独孤达听了这话，也就不再说什么，请他先去歇息。
    就在唐僧与独孤达谈论西行路线的时候，有一名军士骑着快马驰进了瓜州城。他是凉州都督李大亮派来送一份公文的。
    瓜州一个名叫李昌的州吏接过公文，打开一看，不由得吃了一惊。
    公文上赫然写着：“有一名从长安出发已过凉州的僧人玄奘，要去天竺取经，各州县应严密捉拿，不得私藏……”
    可是，李昌对于佛教比独孤达还虔诚。他虽说从没见过唐僧，但就凭公文上说的“从长安出发”，“要去天竺取经”两句，便对这位意志坚强的和尚肃然起敬了。
    他叫送公文的军士回去复命，自己则向手下人悄悄打听，有没有外地和尚到了瓜州。
    一问，果然有一个从东边来的和尚，眼下正在本州刺史独孤达那里。
    李昌了解到这一情况，不由得犹豫了。他想把凉州都督发来公文这件事报告给独孤达，又怕独孤达胆子小，见到公文反而不敢保护唐僧，那就坏了大事了。但是，不报告独孤达，自己就要担当隐匿公文、包庇人犯的罪责。他左思右想，反复考虑了很久，最后决定，还是不报告，出了事由自己一人承担，就是被杀了头，也是为佛门做了件好事。
    当天夜里，李昌来到唐僧的住处，见左右没人，压低声音问：
    “法师大名可叫玄奘？”
    “这个，嗯，这个……”唐僧不知李昌的来意，支支吾吾，不敢明说。
    “法师不必多疑，尽管实说，如果真是玄类法师，弟子一定为您想办法。”
    唐僧见他说得挺诚恳的，点了点头：“实不相瞒，我是玄奘。”
    李昌于是从怀里取出那份公文，递将过去。唐僧大略一看，就像那份公文烫手一样，赶紧还给他，接着，坦率地告诉了他自己西行的志向。
    “我也是个佛教徒，所以一接到这东西，就藏起来了，没有给别人瞧见过。”李昌说着，当唐僧的面把公文撕碎，在烛火上点燃烧了。
    唐僧十分感动。他明白，要是没有拼着一死的决心，是绝对不敢销毁公文的。
    “法师西行，心诚意真，难能可贵啊！”李昌赞叹地说，“不过，既然凉州都督已发了这样的公文，您在此地就不能久留了。还是请法师尽快西行吧！”
    唐僧双手合十，向李昌深深地行了一礼，表示感谢，一直把他送到门口，才回屋来。
    他应该尽快走，这是毫无疑问的；但是，真的要走，却又很不容易。一路上的困难艰险，独孤达已经告诉他了，这条路孤身一人可怎么走啊！
    他又愁又急，想了好久也没想出办法，终于迷迷懵懵地睡着了。


六、玉门关下

    第二天早晨，唐僧念了一会儿佛经，然后慢吞吞地踱到寺院门口，徘徊思索）“有什么法子可以找到同伴或是向导呢？”
    他低着头，走过来，走过去，又走过来，又走过去。这个举动引起了一个当地人的注意，这人是来寺院拜佛的，名叫石磐陀。他一见到唐僧，就认定这和尚准是一位有学问的高僧。
    石磐陀与唐借交谈了几句）诚恳他说：“法师佛学精深，弟子愿敬拜您为师父。求师父收下我这个弟子吧！”
    唐僧见他言辞真诚，就为他授了五戒。五戒是不出家但信奉佛教的教徒必须终身遵守的五项戒条：不杀生，不偷盗，不邪淫，不说谎，不饮酒。
    石磐陀满心欢喜，当他知道师父还没有吃早饭，就马上跑到街上，买来了素面、水果和糕饼，请师父吃。
    唐僧见石磐陀身体强壮，容貌端庄，又是西域人，不会不熟悉西行的道路；要是这个新收的徒弟能伴送自己前往，可就太好了。于是，他把西行去天竺取经的志向和计划，告诉了石磐陀 ，并问他是不是愿意与自己同行，至少护送出玉门关，通过五座烽火台。
    石磐陀听了这话，立即满口答应：“我家中有老有小，到天竺恐怕不行，但我可以作向导，护送师父一程。”
    唐僧顿时转忧为喜，笑吟吟地叫石磐陀等一等，自己转身回寺院去取了一点银子，请他买点御寒衣服和旅途用品，并买两匹马当坐骑，中午一过就出发。
    石磐陀点点头，拿着银子去了。
    不多一会儿，他牵着一青一黑两匹马回来了，马挺健壮，看样子还真能跑远路，其中一匹大青马的背上还驮着个包袱，里面是衣服、干粮和皮水袋等东西。
    石磐陀把马和包袱交给师父，就回家去和家里人告辞。
    中午时候，他回来了，还带来了一个白发苍苍的老人。老人的模样和衣着都像是中亚地方人，手里牵着一匹又老又瘦的枣红马。
    “这位是——”唐僧皱了皱眉头，问石磐陀。他不希望让别人知道自己西行的踪迹，要是走漏了风声，弄不好会把李昌都连累上的。
    “他是我在马市边上碰到的，说是愿意把这匹马便宜一点卖给我们。”石磐陀赶紧解释。
    老人抚摸着马鬃，对唐僧说：“听说您要向西边去。可是，那条路的险恶，不知您了解不了解。我劝您还是改变主意，别轻易把性命送掉了！”
    唐僧听了老人的话，躬身行了个合掌礼，说：“老人家的好意我心领了。但我为求佛经，立志西行，不到天竺，决不东退一步。即使因此而死在半路上，也心甘情愿，毫不后悔！”
    “啊，既然您下了这么大的决心，我就不再劝阻了。”老人感动他说，并且把手中的马缓绳交给唐僧，“我把这匹马送给您吧！”
    “这，老人家，我怎么可以白受您的马呢！”唐僧连连摆手推辞。
    “没什么。这不过表示我一点钦佩的心意。”老人瞥了一眼唐僧的两匹马，指指自己的马说，“您不要小看这匹枣红马。它虽说又老又瘦，可是，已经十五次走过沙漠，到达伊吾城了。俗话说，”老马识途。’它比您这两匹马更有用处呢！…
    唐僧想，这老人说的话确实合情合理；再瞧瞧他那匹枣红马，老归老，筋骨却还可以，于是说：“这么吧，老人家，我收下您的马，也把上午买的马送一匹给您，咱俩就算交换好了！”
    老人起先不肯，说自己这匹马值不了几个钱，换马太不好意思了，但经不住唐僧坚持要这么做，也就答应了。
    他们说话间，日头已渐渐偏西。唐僧和石磐陀向老人道过别，匆匆上了路。
    当天夜里三更时分，师徒俩走到了葫芦河边，远远地已经看得见玉门关的黑影了。
    葫芦河河水又深又急，河上唯一的桥梁就在玉门关的前面。唐僧没有“过所”，当然不敢大摇大摆地从桥上过去。
    他们沿着河岸，悄悄地往上游走去；走到离玉门关口十多里的地方，发现了一处狭口。这里的河面不宽，只有一丈多点，而岸边却有一。片梧桐树林，可以利用树干搭一座便桥。
    石磐陀跳下马背，拔出腰刀，砍下了几棵梧桐树。他和唐僧一”起，把树拾到河边，“架到了对岸，然后，他们用布带将几棵树横扎住，上面铺一层草”，垫些沙子，成为一座便桥，师徒俩…·前一后，把两匹马牵到了对岸。
    月亮高高地挂在空中，地面上凝了一层银白色的霜。他们找到一小块草地，从马背上解下行李，准备在这里过夜，天亮再继续赶路。
    唐僧心里一时高兴，一边打开行李，一边对石磐陀说：“这下可好了，过了玉门关，那凉州都督就不大容易发现我了！
    “什么？”石磐陀一惊，“师父，您是说”凉州都督要抓您吗？”
    “就是嘛！凉州都督李大亮……”唐僧没注意到石磐陀神色有变，把李大亮怎么不许他西行，又怎么发公文到瓜州等等，说了一遍。
    石磐陀听完后，显得很慌张，哆哆嗦嗦他说：“师父，您咋不早说呢！违反禁令偷偷出关，这罪可不小哇！”
    唐僧安详地回答：“我西行的志向既然坚定不移，还怕什么禁令呢！这件事对你早说晚说还不都一样吗？”
    石磐陀听唐僧这么说，只好闷声不响。在褥子上躺了下来。
    唐僧发觉石磐陀有点异样，尽管自己身子很累，也不敢躺下安睡。好在他出家人会打坐（盘腿坐在地上闭目养神，代替睡觉）。于是，就在离开石磐陀五十多步的地方，打坐休息起来。
    玉门关下的深夜，气候比白天要冷得多，唐僧打坐了一会儿，那刺骨的寒气冻得他怎么也安不下神来。他微微睁开眼皮，忽然看到，月光下有一点什么东西闪闪一亮。亮光渐渐近前来了，已经看得清楚：是石磐陀手中提着的腰刀，在月亮下闪出寒光。
    唐僧的心怦怦直跳。他十分清楚：周围十多里路没有人影，喊叫不仅得不到帮助，反而会促使石磐陀遽起杀心；要是向石磐陀恳求，恐怕也难逃一死；最好的办法是祈求菩萨保佑，对了，石磐陀也是信佛教的，白天又刚刚受了五戒，就用念经来提醒他吧！
    于是，唐僧哺哺出声地念起了佛经。
    石磐陀提着腰刀逼近唐僧，当真是企图杀师父的。他想得很简单：师父是犯了禁令私自出境的，前面大沙漠只有烽火台下才有水草，取水喂马不可能不被守台军士发现；一发现，就得被杀头。如果我不杀师父，一个人溜回去，师父把我招供出来，也还是一个死。只有杀了他再跑掉，才可以没事。他这么想，也就打算这么做了。
    可是，唐僧念经的声音提醒了他：违反禁令私自出境是有罪）但是杀人同样犯了重法呀！万一事情败露、仍旧逃脱不了死罪。而且，石磐陀白天刚受过五戒。五戒的头一条就是不杀生。生指一切有生命的动物。连动物都不好杀，何况杀人！更何况杀的是一位有学问的立志到天竺取经的高僧！要真杀了他，死后……
    想到这里，石磐陀转了念头:师父这会儿正闭着眼睛念经,看来没发现我,他马上转过身子蹑手蹑地走回原处,把刀插进刀 鞘。
    唐僧眼睁开一条缝，把一切瞧得明明白白，终于吁了一口气。
    天亮时，唐僧叫醒了石磐陀。两人了脸，漱了口，吃了一点东西。唐僧想，等上路，我只当知道昨晚上的事，慢慢地开导他，让他树立信心．
    可是，他才跨上马，石磐陀就说话了：“师父,弟子想来想去,前实在太艰险了,大沙漠风沙连天,无水无草,人难行.只有烽火台下有水，可是，万一取水时被守军发现，就会送命。我劝师父还是趁早回去，求个太平吧。”
    唐僧骑在马背上，眼神镇定地望着石粱陀，简短地说:
    “上马！”
    石磐陀因为昨晚上的举动，到底有点心虚、唐僧说的“上马”两个字，竟像一道威严的命令，他立刻翻身上了大青马的马背。
    走了几十里路，唐僧正寻思着怎么同石磐陀讲明白道理。石磐陀却跳下马，拦住了枣红马的马头，说：“师父，弟子实在不敢再往前走了。我家里有老有小，触犯了王法，连累一家老小，可怎么办？师父还是同我一起回去吧。”
    唐僧瞧了瞧石磐陀的眼睛、那眼睛里流露出深深的惊恐，料定他确实不可能再往前走了，就说：“我知道你有难处，不勉强留你了。你自己回去吧。”
    但是，石磐陀听了这话；却摇了摇头，表示不肯走。
    “这就怪了。你怕出事，怕连累一家老小，不愿意再往前走，这好理解，所以我让你回去。可是你又不愿意走，是什么原因呢？嗅，我明白了，你是要报酬，是不？好吧，我身边带的银子不多，路上还要用的，就把这匹马送给你好了。”唐僧说着，指了指石磐陀手里牵着的那匹大青马。
    “不是这个意思。”石磐陀终于说了实话，“师父，西行路上关卡大多，我看师父是到不了天竺的。万一师父被烽火台守军捉住，供出我的名字，说我为你带过路，那我一家老小还是活不成啊！”
    “原来是这样！”唐僧翻身下马，安详他说，“这个你尽可以放心。西行取经求佛是我的意愿，私自出关与别人没有关系。假如我被捉住，就是刀架在脖子上，也不会说出你的名字来。出家人不打妄语（不说谎），你相信我好了！”
    石磐陀不说什么，只是感激地点点头。
    “去吧。你把马骑回去，．我还要继续赶路呢！”唐憎反倒催他走了。
    “师父，”石磐陀被唐僧的宽宏大量感动了，轻轻说，“您还要走远路，就把这匹老马给我，您骑大青马好了。”
    “不，枣红马识路，我要骑。你快走吧。”
    石梁陀于是把行李包袱换驮到枣红马背上。他自己觉得太惭愧了。趴在地下给师父磕了一个头、起来后喊了声：“师父保重！”头不回地翻身上马飞驰而去。
    唐僧望着石磐陀逝去的身影，嘴角露出一丝苦笑；他想起了昨天夜里的一幕险剧，摇摇头自语道：“走了也好，不然晚上睡觉都得提心吊胆的。”


七 过沙漠

    石磐陀走了。现在，陪着唐僧西行的，只有那匹又者又瘦的枣红马了。
    唐僧单人匹马，费力地在沙漠中一步一步前进。
    沙漠一望无际，就像被暗灰色的煤碴覆盖着。稍一疏忽，就会迷失方向，结果往往就因为饥渴而倒毙在沙漠里。
    这里也有一些商队经过的踪迹：马和骆驼的粪便，以及散乱的自骨。它们就是路标。
    唐僧就沿着这些干硬的粪便和令人恐怖的白骨朝前走去。幸好那匹者马认识路径，这使唐僧省心不少。
    沙漠的白天，热风似火，他走不多久就汗流泱背，活像呆在蒸笼里一般。
    到了夜里，寒风如刀，冻得他籁籁发抖，睡不到三更就被冻醒了。
    有时狂风卷起沙子，搅得天昏地暗，他得赶紧下马，用袈裟把自己和马头罩在一起。
    即使在风和日丽的好天气，眼前极其单调、无边无际的景色，也叫人感到孤寂和恐怖。
    但是，环境越是险恶，唐僧的意志就越是坚定。他心里想：“我连死都不怕，还怕什么！”
    他先是艰难地走了八十几里地，远远望见了一座烽火台。
    烽火台是中国古代用于军事监察和联络的哨所，同时也监视有没有人偷越国境。所以，唐僧必须避开这地方。
    但是，他装在皮口袋里的水快喝光了，马也需要饮水吃草。沙漠中只有烽火台下才有水草。
    唐僧打量了一下地形，觉得白天去打水取草，一定会被烽火台上的军士发现，危险性太大，为了不暴露自己，只有夜里偷偷接近水塘。
    于是，他牵着枣红马，躲在离烽火台不远的地方，静静地等待着夜幕的降临。
    天黑以后，唐僧让枣红马留在隐蔽的沙沟里，自己提着皮袋和一根绳子，悄悄地往水塘走去。皮口袋是盛水用的，绳子打算拔点草用它捆住背回来。
    他到了水塘边上，先俯身喝了几大口冰凉的清水，然后拔起草来，可当他把皮口袋浸入水塘灌水时，被烽火台上的军士看到了。
    唐僧明白自己被烽火台上的军士发现，索性站起来，大声喊：。
    “请不要射箭）不要射箭：我是长安来的和尚，要去天竺拜佛取经，请你们行个方便！”
    夜深原野静）他的喊声烽火台上听得清清楚楚。
    一会儿，烽火台下的门打开了，两名士兵走过来，”叫他去见校尉。唐僧点点头，指指不远处，说是还有马匹行李在那边）他们于是一起去掂起行李卷、牵着那匹枣红马，进了烽火台。
    烽火台内这时已打起了好几支火把。校尉王祥合掌问唐僧：
    “法师为何来到此地？”
    唐僧见他行着合掌礼，。知道这位校尉是信佛教的，心中就产生了一线希望、只是不知凉州都督追缉自己的公文）是不是发到了这个烽火台，要是没有发到这里来，那希望就更大了。想到这里，唐僧问道：
    “校尉可曾听说，长安有个僧人玄类，已经过了凉州，要去天竺取经？”
    “没有哇。玄类法师的大名我早已拜闻，可就不知他过了凉州的事。”王祥反倒觉得奇怪。
    “唐僧想，准是李大亮估计我出不了瓜州，所以没把公文发到这儿釉不由得心中暗喜，当下从行李包里取出自己的度牒，递给王祥。
    王祥一看度牒，原来自己面前站着的就是玄奘法师，顿时肃然起敬，要行大礼。唐僧连忙拦阻，并且说：
    “贫僧远道而来，立志西行，还望校尉大力帮助！”
    “这个——”王祥沉吟了一会儿，回答说，“弟子崇仰佛门，决不会跟法师为难。不过，法师走了多日，已经知道了路途的艰难。像这样困苦危险，您怎么到得了天竺呢？请法师不必再西行冒险了！”
    唐僧听了王祥的话，坚定地回答说：
    “我从少年时起就投身佛门，学习佛法，但是有许多疑难问题一直得不到解决，因此立志西行，拜佛求取真经。校尉既然也是佛门弟子，怎么能不激励我奋发向前，反而劝我退身呢？”
    王祥又感动又惭愧，忙说：“弟子能见到法师已是大幸，岂能阻拦法师？法师多日来劳累了，先请休息。
    说罢，王祥叫军士烧了点热水，让唐僧洗了个澡；又摆下一席素斋，陪着唐僧吃了饭。
    第二天清早，王祥包了一点银钱，又因为听说唐僧的皮口袋掉在水塘里了，一时间不容易找到，就把自己的皮口袋和银钱一起送给唐僧，另外还赠给他一些干粮和马草。唐僧见他十分诚心，也就一一收下了。
    王祥亲自送唐僧走了十多里路，最后指点说：
    “法师如果一个一个烽火台走过去，那些校尉就是肯放行，恐怕也要费不少周折。您从这条路向前，可以绕过第二个和第三个烽火台，直达第四个烽火台；那里的校尉名叫王伯陇，是我的本家。他心地善良，法师只要对他说是我送您出来的，他一定会帮助您的。”
    “单凭我口说不知他信不信。”唐僧很高兴，但他想尽量把事情弄妥帖些，“您是不是给个什么字条？”
    “不用了，”王祥指指挂在马鞍前的皮口袋，笑了笑说，“您只要把这给他看看就行了。”
    唐僧再一次向王祥道了谢后按照他指点的方向上了路。
    他走了好长一程，看到了第四座烽火台。这时，唐僧心里还不踏实，恐怕王伯陇也要自己折回去，反而多一层麻烦，于是，仍旧像上次一样，打算躲在一条沙沟里，等天黑了再去烽火台下的水塘取水。
    不料，唐僧刚刚下马，就从烽火台上飞来一支箭，射中了他的肩肿。这支箭跟普通的箭不一样，发出一种口哨那样的尖啸声，而箭头却是钝的，所以虽使唐僧吃了一惊，却并没有受伤。
    原来，这叫响箭，是用响声来发出信号的。它从烽火台上射下来，显然是起着警告的作用，意思等于说：“不许动！你是什么人？要是不回答，下一支可就不是响箭了！”
    “唐僧尽管不太清楚响箭代表着什么意思，可也当然明白自己被烽火台上的军士发现了，于是只好大喊，说自己是长安来的和尚，请台上不要放箭。
    军士听到喊声，下来把唐僧带进烽火台，去见王伯陇。
    唐僧见了王伯陇，恳切他说：“贫僧自长安而来，去天竺取经，”曾从第一座烽火台经过，王祥校尉要我向您求助。这是他送我的皮口袋，可以以此为凭证。
    王伯陇果然深信不疑，安排唐僧用过素斋，让他舒舒服服地睡了一夜。
    第二天，王伯陇给唐僧的皮袋里灌满水，送他走了一程路，指着一个方向说：“法师可照我所指的路走，这样可以避开第五座烽火台。那第五座烽火台的校尉生性暴躁多疑，他要是碰上了您，会为难您甚至伤害您的。”。
    唐僧表示了感谢，问：“我不定那烽火台下，但是，这袋水够不够走出大沙漠用的呢？”
    “当然不够。不过，法师由这里向前行一百多里路，有一个野马泉，可以取水，过了野马泉，还要走几百里路的大沙漠，方可到达伊吾城。我不远送了，法师路上多加小心！”
    “唐僧辞别了王伯陇，继续在沙漠中行进。一路上沙海浩浩，有时刮起大风，飞沙打得他晕头转向；有时风停沙落，环顾四周，一片荒凉。他骑在马背上，向前走啊，走啊，自以为始终是沿着王伯陇指点的路在走，其实早已偏了方向，所以怎么也找不到野马泉。
    皮口袋里的水只剩下不到一半了。唐僧因为不熟悉道路，一直节制着饮水，这时实在精疲力竭、口渴难熬，只好下马，打算解开皮袋喝上一口水再走。
    谁知道，唐僧已经累得头晕眼花，浑身发软、解下皮口袋时，一个失手，皮口袋落到了地上！
    半口袋沙漠中最最宝贵的活命的水，“嗤溜”一下子，全被吸进了沙子里。
    唐僧无力地拾起那只剩下夹缝里几滴水的皮口袋，心中懊恼极了！
    “怎么办？”他无声地问自己。
    前途遥远，野马泉连影子都看不见，能走出大沙漠吗？
    还是退回第四座烽火台，取了水再走吧。但他才走了两步，就斥责起自己来：“不，不能这么办！这是违背誓言的！”
    当初，唐僧曾经许过愿，发过誓——不到天竺，决不东归一步！尽管暂时回去是为了继续前进，但回到第四座烽火台，毕竟是“东归”啊！再说，能不能找到那烽火台，一点没把握。
    “宁愿往西而死，决不归东而生！”唐僧把马头拉了回来，决心不顾一切地朝西方走。
    沙漠中没有水的旅程，其艰难的程度是难以想像的。
    白天，旋风裹挟着黄沙，好像夏天的暴雨；唐僧多么渴望那是暴雨啊，可是，老天爷吝啬得一滴水都不肯降下来：
    黑夜，沙漠里闪烁着点点磷火，好像水珠的反光，唐僧暗暗祝愿那是露水，可是，他走近了一摸，干巴巴的，连潮气都没有。
    一天上午，唐僧忽然发现，前面有一大片水丰草盛的绿洲，还有牧人在放羊牧牛，那里有水“，水！他拼命踢马肚子，催枣红马快跑。跑近了，又远了，再跑近点，干脆不见了！
    原来他看到的是“地镜”，也即海市蜃（慎）楼，它是由于光线折射造成的幻象。
    一连五天四夜，他喉咙口没有沾到一滴水，嘴唇开裂，口舌冒烟，肚子里就像火烧一样难受。
    他软乎乎地从马背上滑到地下，趴在沙丘上，大口大口地喘着气，接着便昏了过去。
    那匹枣红马也显然不能动弹了，老马恋主，它乖乖地在唐僧身边躺了下来。
    半夜过后，不知从什么地方刮来一阵阵凉风。唐僧醒过来了。
    他支起身子，吸进几口新鲜空气，顿时仿佛洗了个冷水浴，只觉得浑身凉爽。
    枣红马也站了起来。它对着风的方向，鼻翼一扇一扇，好像在嗅什么味道。唐僧打起精神，骑到马背上，握住缰绳，催枣红马朝西前进。可是，这匹老马第一次表现出反抗，它不听使唤，偏朝横里，也就是风吹来的方向走。
    “怎么啦？为什么不一直往前走呀？”唐僧拼命地想把它拉转过来，可是枣红马根本不听。而且，它一边煽动着鼻翼，一边加快了步伐。
    唐僧只好放松了缰绳，随着它跑去。
    猛然间，远处出现了一片青草地。
    “绿洲！”唐僧大喊一声，他并且看到了一汪像镜面似的碧清的湖水。
    “老马果然识途！好马，好马！真是天无绝人之路啊！”
    他下马俯身在湖水边上，痛痛快快饮了一阵；枣红马也咕嘟咕嘟地喝了个饱，肚子晃得吮吮响。在这块草地上，唐僧和枣红马美美地休息了一天。
    第二天，他在皮口袋里装满了水，又拔了许多青草，继续前进。
    走了两天，他终于走出了大沙漠，到达了伊吾城。
    伊吾城东有个佛寺，这时天早已黑了，唐僧敲了下门，报了自己的法名和来由。佛寺内一个汉族老和尚听说由东土大唐来了个玄奘法师，衣服鞋袜都来不及穿好，光着脚板就跑出门迎接。
    汉族老和尚搂着唐僧，泪流满面他说：“真想不到，在这里还能遇到故乡来的亲人啊！”
    唐僧也激动得流下了眼泪。


八、高昌留难

    伊吾城不大，伊吾国也只是西域的一个小国。
    国家虽小，伊吾王对唐僧却挺客气。他热情地款待了这位大唐来的高僧。
    伊吾国是高昌的属国。唐僧到达伊吾时，正好高昌国的使节也在伊吾城里。不久，使节回高昌，把唐僧的事向国工作了报告。
    高昌国的国王叫鞠（曲）文泰，是一个虔诚的佛教徒，也是一个中国文明的崇拜者。
    鞠文泰早就从去过凉州的商人那里，听说了唐僧的大名，现在知道唐僧已到了伊吾，顿时颇为激动。他派了一位使者带上一支马队，前往伊吾迎接唐僧；并写信给伊吾王，让他派人护送.。
    唐僧本来想从伊吾出发，经过可汗浮图I（今新疆吉木萨尔北）前往天竺的，也就是说，打算出天山之北，沿北麓西行。而高昌却是天山南麓的一块绿洲，并不在预定的路线内。但是，高昌使者再三陈述高昌王要见他的迫切心情，使唐僧感到不去高昌国实在过意不去。于是，他把预定向西北走的路线改为向正西，由伊吾王派人护送，跟着高昌王的使者出发了。
    他们在沙漠中走了六天，第六天傍晚，到达了高昌国的自力城。
    这时，人也困了，马也乏了，唐僧想叫大家休息一宿再走。但高昌使者和白力城中的官吏说，王城就在附近，还是赶快前进，以慰国王盼念。唐僧和迎接、护送的人们，只得换了马再走。
    唐僧到达高昌的王城时，已经夜半了。可是，他又仿佛看到，城的中心处有一片亮光。这是怎么一回事呢？
    走近了王宫，唐僧看清楚了，那是高昌王率领着大臣们，举着火把灯烛，正在宫门外迎候呢！
    鞠文泰亲自举着蜡烛，和侍从们一起把唐僧引人王宫后院，请进一座重阁宝帐，然后恭敬他说：
    “弟子久闻法师大名，天天都想见到法师尊容。我派使者前往伊吾城去迎接法师后，一直在计算路程，认走法师今夜必到。因此，弟子与王妃都不敢人睡，一边读着佛经，一边静心等候。现在终于把法师盼来了！”
    唐僧听了这话，心中叫声“惭愧”，要是今天傍晚在自力城住下，那高昌王竟要一夜不睡，等我到天亮哩！
    不一会儿，王妃带着几十个宫女来到，向唐僧拜见行礼。高昌王与唐僧促膝相谈，直到深夜。
    第二天清早，唐僧还没起身，高昌王就同王妃一起来到重阁宝帐前行礼问安。一国之主这么恭敬，唐僧心中很觉不安，他连忙起身还礼，请高，昌王坐下。
    寒暄一番后，高昌王设下丰盛的素席，为唐僧洗尘。
    由于鞠文泰本人崇信佛教，所以佛教在高昌国十分盛行，全国有僧人好几千名。与唐僧作伴谈论佛法的，有一个彖（tuan）法师，一个统法师。彖法师曾经到长安留学二十年，很有学问，高昌王把他当做国宝看，常引他与唐僧见面。
    但是，无论是象法师，还是统法师，在高昌王看来，都及不上唐僧，要是能把唐僧留在高昌，那就太好了。高昌王不好意思直接开口，就托统法师向唐僧提出。但唐僧立即婉言谢绝了。
    唐僧为避免高昌王留客的盛情引起麻烦，过了几天，就向高昌王辞行。但高昌王自从统法师转告了唐僧的谢绝后，越想越不是滋味，这时就亲自出马说：
    “弟子曾请统法师代为恳留法师，法师是不是可以再考虑一下？”
    “君王的恩典贫僧心领了。”唐僧合掌说，“但是，我曾向佛祖发誓，往天竺求取真经，如果半途而废，有头无尾，不仅于心不安，更于佛法所不容。”
    高昌王仍不死心，恳请说：“弟子平生见过许多高僧学者，但并不十分动心。如今见到法师尊容，实在是三生有幸。弟子发下心愿，请法师长留高昌，一是希望法师终身受弟子供养，以满足弟子一片尊师的诚心；二是高昌百姓都是法师的弟子，还都期待法师教化，为他们开席讲经，传授佛法。请法师接受弟子这一片诚意，不要再西行了吧！…
    尽管高昌王如此盛情，唐僧还是不肯答应：“贫僧西行数千里到达这里，决不是为受供养而来的。因为本国佛经奇缺、法义不全，彼此争论不休，至今无法统一，所以我立志西行；到佛国取经，希望君王体察我的苦衷。”
    也不知是高昌王本来就性子急躁，还是故意发脾气，听了唐僧的话，他脸孔一，板，大声说：
    “我仰慕法师，一定要把您留下供养。即使高山崩裂，我这意愿也坚定不移！”
    “不行。”唐僧也坚决他说，“去天竺是我平生的志愿，山崩地裂，海枯石烂，也动摇不了我的决心。
    高昌王这下真的动了肝火，愤愤他说：“如果法师坚决不肯留下，弟子自有办法。试问，法师如果不得到弟子准许，能离开高昌国吗？法师前面只有两条路：一条是弟子派人送法师回东土；一条是长留高昌受弟子供养。究竟走哪条路，法师自己选择。不过，弟子认为还是选择后一条路好。”
    唐僧心里一怔：得不到鞠文泰的准许，确实离不开高昌国。早知今日会受到如此留难，当初在伊吾满可直接往可汗浮图，不该到高昌打这个弯的。后悔是来不及了。高昌王提出的两条路一条也不能走。想到这里，他也索性把话说绝：
    “贫僧西行远游，为的是取经求法。虽说现在被阻难于高昌，但君王留下的只能是贫僧的尸骨，绝对留不住贫僧的一颗心！”
    高昌王无可奈何，只得向手下人下令。不准唐僧随意行动，并打算以盛情款待和恭敬态度感动唐僧，劝他回心转意。
    从那以后，高昌王每天都备置丰盛的素席，唐僧用餐时，他都站在旁边，恭恭敬敬地献上杯盘，要等唐僧吃过了，他才去吃饭。每天晚上，也要唐僧安睡了，他才去睡觉。
    三天过去了，唐僧又请求了好几回，但高昌王总是不答应。唐僧终于明白了：鞠文泰是想软化我呀！于是，他决心绝食，以死来表明自己的心愿。
    他白天黑夜地合掌端坐，不吃一口饭，不饮一滴水。
    一天过去了，两天过去了，第三天，唐僧的身体越来越衰弱。这下可急坏了高昌王，他请王妃和大臣、彖法师和统法师，一起来到唐僧这里，好言相劝，但是，一切都无济干事，唐僧仍是不吃。
    到了第四天。唐僧仍然不肯进食。高昌王见他的意志如此坚定，深受感动，不由得对自己的行为感到了惭愧和内疚。
    高昌王走到唐僧面前，边作揖边恳求说：“请法师赶快进食，饶恕弟子的无理吧。法师可以遵照自己的意思继续西行，弟子不再阻拦了。”
    唐僧微微睁开眼睛，见高昌王不像说假话，但又怕他事后反悔，要他对天发誓，才能相信。
    高昌王对天发了誓，唐僧这才捧起杯子，喝了口水。
    “但是，法师要走，还得答应弟子三个请求。”高昌王毕竟舍不得。
    “什么，还有条件？”唐僧放下了水杯，“你说说看。”
    “不是条件，是请求。法师如果信得过弟子的诚意，就请答应弟子：一是与弟子结为异姓兄弟；二是法师取经成功从天竺回来时，要在这里住上三年；三是高昌僧人、百姓都想见一见法师，请法师在这里开席讲经一个月，在这一个月中，弟子也好为法师准备各种物品，表表心意。这三个请求，望法师一定答应。”
    唐僧原来就完全明白高昌王敬僧的真心，也十分感激他款待的盛情。既然现在高昌王答应自己西行，唐僧也就满口答应了他的请求。
    高昌王好不高兴，第二天，他与唐憎对着佛像结拜为兄弟。高昌王大一岁，就成了唐僧的义兄。
    几天后，唐僧身体复原了，就坐在高昌王为他设置的宝帐中开讲佛经。他讲授了一个月《般若经》。每次开讲前，高昌王都双膝下跪，伏在地上，用自己的身体作台阶，让唐僧踩过去登上讲台；唐僧讲经时，王妃、大臣和三百多名僧人都席地而坐，静心听讲。
    一个月后，唐僧准备出发了。高昌王派了二十五个人护送，并备了三十匹马，三十套面罩、手套、鞋子和御寒的衣服，黄金一百两、银钱三万，绞、绢各五十匹和其他许许多多足够旅行二十年所需的用品，全都赠送给唐僧。另外，他还给自己的亲戚、统治西。突厥的叶护可汗写了一封信，说明唐僧玄奘是自己的义弟，情谊很厚，请可汗多多帮助和照顾。对于唐僧一路上所要经过的西域二十四个国家的君王，高昌王也都写了信，请他们迎送从大唐来的高僧。
    唐僧得到了高昌王的赠礼和帮助，非常激动，当场写了一篇《谢高昌王启》的文章，表达了自己感激的心情。
    唐僧出发的这一天，高昌王和王妃、大臣们，高昌佛寺的法师、僧人等，以及城里许多百姓，都为他送行。队伍到了城西，高昌王抱着唐僧痛哭流涕，大家也都为离别而难过得流下了眼泪。最后，高昌王又骑着马送了十几里路，这才依依不舍地与唐僧挥泪告别。


九、翻越雪山

    唐僧一行离开高昌国后，经过阿耆（ql其）尼国（今新疆焉耆），到了银山。
    银山今天的名字叫库莫什山，山中多银矿，据说当时西域国家铸银市的银子，大多产自这座山。
    过了银山，又跨过一条大河，他们来到了屈支国（今新疆库车）。
    屈支国的国王得到消息，恭敬地把唐僧迎进一座大帐篷，并且由一名和尚向他献上了一束鲜花。然后，屈支王命人摆开丰盛的素席，为唐僧洗尘。
    第二天，屈支王把唐僧等人接到王宫，盛情款待。唐僧本来想立即翻过葱岭继续前进的。可是正逢大雪封住了山路，只得在屈支城住了下来。
    唐僧在屈支城逗留时，观赏了当地精美的佛教美术，如壁画、雕塑等等，还特地到城西北的阿奢理儿寺，拜访了屈支国的高僧木叉毱（拘）多。木叉毱多曾经到印度游学二十多年，但他信奉的却是小乘佛教。唐僧多次与他讨论佛学教义，有时还进行辩论。本叉毱多虽说不同意唐僧信奉的大乘佛教，可是对唐僧的学识渊博、态度严谨却十分敬佩。他对自己的弟子
    们说：“这位大唐高僧很不容”易对付。哪天他到了天竺，只怕天竺的壮年学者都不及他哩！”
    两个月以后，唐僧等人重新上路。他们向西走了六七百里，到了跋禄迹国（又名姑墨国，今新疆拜城、阿克苏一带），在那里住了一夜；又折向西北行二三百里，到了葱岭北部的凌山（又名冰达坂，今新疆鸟什别迭里山口）。
    凌山终年积雪不化，一眼望去，只见白皑皑的冰天雪地。山上到处都是悬崖峭壁，经常有巨大的冰雪块下坠，能把行人砸死或活埋；风雪交加，使崎岖山路更加难行。唐僧等人艰难地攀登，一步一步地前进。休息时，他们找不到一点干燥的地方，甚至晚上都只好睡在冰上过夜。
    在翻越凌山的短短几天中，有的人遭遇到雪崩压死了，有的人被狂风刮下的大冰块砸死了，有的人失足落进了万丈深渊，还有的人陷进深不见底的冰洞，再也没有爬上来。七天后，唐僧和同伴们终于越过令人心寒的凌山，随行的人死了三分之一多，驮运物品的牛马也损失了许多。
    他们出了凌山，走到一个大湖旁边。这湖在唐代时称为咸海，因为湖水是咸的，面积又很大；它还有两个名字：一是因为它终年不冻而得的名，叫热海；一是因为它水质清澈，人们又叫它大清池（今前苏联的吉尔吉斯伊塞克湖）。
    大清池周围一千多里，东西长，南北狭，一望无际，无风就有三尺高的浪头。唐僧等人沿着大清池向西北走了五百多里路，到了素叶城（即碎叶城，今吉尔吉斯托克马克）。
    当时的素叶城是东西交通的要道，也是唐僧西行的必经之路。说也巧，就在这里，他遇上了一支打猎队伍，一间，为首的正是高昌王的亲戚、西突厥全盛时代的统治者叶护可汗！
    唐僧把高昌王写给叶护可汗的信呈上，并转送了高昌王托他带来的礼品。叶护可汗虽然不信佛教，但因为他当时很想同唐朝联络关系，加上又有高昌王的介绍，所以对唐僧很客气： 叶护可汗把唐僧等人请进了大帐篷。突厥人的习俗是席地而坐的，至多在地上铺…块垫子、褥子或毯子。但可汗为了表示对唐僧的尊重，特地支了一张铁床，铺上褥子，”请他坐上。唐僧坐上去时，感到奇怪：这床为什么不用木头做，要用铁呢？他正想着，侍从们端出葡萄美酒和丰盛的素菜，乐伎（技）们奏起优美动听的音乐，于是他也和大家一起吃了起来。
    散席后，叶护可汗为了表示礼貌，请唐僧讲说佛法。唐僧也不推辞，从容讲了起来。想不到，由于唐僧讲得精彩生动，叶护可汗居然对佛教产生了兴趣，对唐僧说：
    “我看法师还是留在这里吧，不必到天竺去了。天竺很多地方天气实在热得难熬，当地入的皮肤都晒得红通通黑黝黝的。像法师这样的身体容貌，只怕要给太阳晒融了呢！”
    不信佛教的叶护可汗也要留难，这倒是唐僧没有估计到的，他于是回答说：
    “贫僧西行，志在求取佛经，无论是严寒，是酷暑，都不能阻挡我。可汗深明大义，想来是一定会支持我帮助我的。”
    果然，叶护可汗并不像高昌王那样死心眼儿。他知道留不住客人，也就点点头表示同意。
    唐僧临行那天，叶护可汗赠给他红绫袈裟一领、绢丝五十匹；还派一个曾经到过长安、既通晓汉语又懂得西域各国语言的“官员，给他当翻译和向导，官员随身带上了给沿途各国君王的信，叶护可汗亲自和大臣们一起，把唐僧送出素叶城外十多里。
    走在路上，唐僧问向导，突厥人的床为什么用铁而不用木头做？向导告诉他，突厥部族信奉拜火教，认为木头里有火（所谓“木生火”），坐在木制品上，就是对火不敬。唐僧点点头，算是弄明白了一个西域国家的习俗。
    由于当时西域各国都受西突厥控制，所以叶护可汗写给各国君王的信，使唐僧等人一路上得到了不少帮助。他们先是走了一千多里，通过了几个西域国家；义渡过妫（guī龟）水（也叫乌浒水，即今俄罗斯和阿富汗之间的阿姆河），逐渐折向东南，走了五百多里山路，到达了西突厥的要塞铁门。
    铁门位于当时中亚南北交通要道上，地势非常险要。它左右尽是高山绝壁，危崖的颜色和铁相似，中间有一条狭窄的山径，只可容一人通过；因此，也有人把铁门称做铁门关。铁门关关口还装着两扇大铁门，门上悬挂铁铃，门开动时铃声大响，行人无法偷越。
    出了铁门，唐僧等人继续向南走，来到了缚喝国（在今阿富汗境内）的国都王舍城。这里有一一百多所佛寺，还有几处佛教圣迹。唐僧礼拜了佛澡罐、佛牙和佛扫帚。然后他们从缚喝国再向南走了六百多里，来到了大雪山（今阿富汗和巴基斯但之间的兴都库什山）。
    大雪山长达两千多里，满山都是冰雪，夏季都不融化。山上常常寒风凛冽，雪片飞舞；在陡峭的山路上行走，比翻越凌山更加艰难。幸好，叶护可汗派来的向导路径既熟，办法也多。唐僧身上穿着好几件皮衣，脚上的袜子也是好几层，还是冷得上下牙齿直打架。他跟着向导，有时躲开雪崩坍下的积雪，有时绕过挡住去路的冰凌，有时边走边用铁锹从冰坡上挖出踏脚的坑洞，有时抓着绳索荡过稍不留心就会掉下去的峡谷……
    他们足足走了十多天，才走出大雪山，来到了迦（加）毕试国（今阿富汗喀布尔）。
    过了迦毕试国，就不属于西突厥势力范围了。叶护可汗派来的向导告辞回去了。唐僧在迦毕试国休息并巡礼佛教圣迹，停留了两个多月，然后向东走了六百多里，越过黑岭（兴都库什山南面的山岭），于唐贞观二年（公元628年）的夏未秋初，到达了北印度。


十、遇盗

    印度与中国、埃及、巴比伦，并称为世界四大文明古国。早在汉武帝时，中国人就知道西南方有个大国叫身毒（yudn“园睹）、也就是今天的印度。除了身毒外，它还有个名字，叫贤豆：东汉以后的史书，一直到唐僧西行的唐代，则都称“天竺”。
    唐僧到了印度，反复比较了这几个名称，觉得都不怎么符合当时的印度语音，认为音译成“印度”比较合适，于是就用了印度，，他是第一个不用身毒或贤豆或天竺而称印度的人。从唐僧回国后起，印度这个名称就通行起来。一直沿用到今天。
    印度当时分为东，南、西、北、中五个部分。唐僧先到北印度的滥波国，停留了三天，接着又南行、到了那揭罗喝国（滥波国和那揭罗喝国都在今巴基斯坦西北边省北部）。
    在那揭罗喝国的灯光城，唐僧听说城西南有个名叫龙窟的山洞，洞内有释迦牟尼佛的影像，就要前去礼拜。随行同伴们知道这一带道路荒险，又多强盗，劝他不要去了，可是他一定要去，随行同伴不肯带路，他就自己边间边走。途中遇到一个小孩，也只把路指给他看，不敢陪他前往。唐僧不顾一切，单身摸索前进，将近龙窟时，突然跳出五个强盗，横刀拦路问他：“什么人，到哪里去？”
    唐僧一惊，回答说：）贫僧是东土大唐来的，要到龙窟礼拜佛影。”
    强盗觉得奇怪，说：“你难道没听说这里有强盗吗？”
    唐僧笑了笑回答：“强盗也是人，是人总有人性。我为了礼拜佛影，即使猛兽挡路，也不会害怕，何况你们是有人性的人呢！”
    强盗们听了这话，很受感动，不但不伤害他，反而领他进龙窟，礼拜了佛影再送他走上来时的路。
    离开那揭罗喝国后，唐僧又向东南行，走了五百多里地的山路，到达犍（iI0n肩）陀罗国（今巴基斯但白沙瓦及阿富汗东部一带）。
    犍陀罗国有不少庄严华丽的寺院、佛塔，以及许多雄祎肃穆的佛像。这里的雕刻精美绝伦，别具一格，誉满天下，被称为“犍陀罗艺术”。
    唐僧参观了佛教艺术珍品，礼拜了佛教圣迹，并把高昌王送给他的金银、绫绢、衣服等分送给各个寺院。接着，他从犍陀罗国东南渡过一条河，经过几个小国，到达迦湿弥罗国。
    迦湿弥罗国位于喜马拉雅山西麓，也就是今天克什米尔地方。这里是小乘佛教的发源地之一。唐僧一到这个国的国境，国王就派他的舅舅前来迎接。几天后，唐僧到达王城，国王亲自率领官员、僧人一千多人出城，向他献上鲜花，并请他乘着大象进城，住在一个佛寺里。
    唐僧虽说信奉大乘佛教，但他认为，小乘佛教也很有熟悉的必要，因为他的志向是要把中国的佛教各派统一起来，不全面了解就达不到这个目的。
    迦湿弥罗国有一位年近古稀的称法师，学问很好。他见唐僧是国王的客人，又谦虚好学，就十分尽心地为他讲授了小乘佛教的主要经典和“声明学”（语言文字学）、“因明学”（逻辑学）。他在这里刻苦学习了两年，把三十万颂九十六万字的佛经，全部读通了。称法师钦佩地向大家宣示：这位大唐和尚的学识，在我们国家里实在还不出第二个人！
    在读经期间，唐僧也听寺院里的和尚讲了这里供养的一枚佛牙的传说：
    “大约六百年前，有一个和尚经过一片森林旁边，忽然看到一大群象疾驰而来，吼声震天动地。和尚慌了，赶紧爬上一棵大树。象群来到树下，伸出长鼻于卷树，树大干粗，象鼻子卷不住。它们轮流跑到河边，用鼻子汲足水，回来喷浇在树根处。”象多水多，大树下的土地吸饱了水，渐渐变得松软了。这时，好几头大象用身子合力挤大树，大树挤倒，吓得面如上色的和尚掉到了地下。可是，大象并不害他，却用长鼻子把和尚卷起轻轻放到背上，然后走进森林深处，到了一头躺着的大象面前。和尚一看，明白了：原来这头大象脚上扎进了一根竹刺，伤口已经化脓，那群大象是把和尚请来治病的！于是他帮病象拔去竹刺，敷上草药，还撕破了自己的衣服，为它包扎了伤口。病象解除了痛苦，非常感激，将一个金盒子送给和尚，和尚打开一着，原来是一枚一寸半长的洁净发亮的佛牙，顿时喜出望外。象群围着和尚跳了一会儿舞，又献上许多精美的果子，和尚吃了，它们才把他放到背上，送出森林……
    唐僧和随行同伴们离开迦湿弥罗国后，向西南走了七百多里，然后折向东南前进四百多里，渡过一条河，到了波罗奢原始大森林。
    原始森林里大树参天，葛藤蔓绕，抬头望不见青天，低头看不清道路。他们由向导带引，艰难地沿着弯弯曲曲的林中小径前进。
    一天中午，他们正赶着路，突然从密林深处跳出一群强盗，大喝：
    “站住！留下买路钱来！”
    强盗有好几十人，都是又高又大的汉子，手中还拿着刀棍；唐憎一行手无寸铁，而且都没武艺，只好听天由命。强盗把他们全部金银财物搜个精光，还剥下了他们身上的衣服。
    那会儿是大热天，身上没有衣服倒也不怎么觉得冷。可是强盗得了衣服财物，恐怕放走他们会叫了人来捕捉，竟要把唐僧等人全部杀死。
    唐僧一听强盗要的不单是买路钱，不禁急得额头冒汗：出家人钱财本是身外之物，可是自己要是真的死在强盗手中，那又怎么取到佛经送回大唐呢？强盗面目狰狞，刀光闪闪，对他们讲道理是讲不通的，只得先来个缓兵之计，再想办法脱身。想到这里，他就对强盗头领说：
    “好汉，我自从出家那一天起，就决心献身佛学，把生死置之度外。今天既然难免一死，那就让我先念上一卷佛经，也好超度亡灵。请好汉高抬贵手！”
    强盗头领想，反正这些人逃不走，迟点杀早点杀无关紧要，也就点点头，把他们统统赶到一个已经干涸了的池塘里，自己同手下喽罗们坐地分赃开了。
    池塘里虽说没什么水，可是淤泥没过膝盖，好些地方还长满了荆棘萝蔓，稍动一动，脚上的皮肤就给拉出了血印子。原始大森林里本来就极少见到人，这会儿，除了在池塘里受难而且将要送命的唐僧一行，只有岸边的强盗在为分赃吵吵嚷嚷。即使有人路过这里，也会赶快溜走，更不敢上前搭救。唐僧他们想到这一层，差不多只好闭着眼睛等死了。
    趁着大伙儿乱哄哄的当儿，唐僧把几个比较机灵的随行同伴叫到一起，吩咐他们，分头到池塘的各个方面，看看有没有出路可以逃走。
    池塘不太大，寻路的人没多久就陆续回到唐僧身边，垂头丧气地报告说，到处找不到路。
    唐僧不灰心；自己去找。他顾不得脚上拉开的口子鲜血淋漓，也不怕淤泥可能使他遭到灭顶之灾，只管往池塘里面走。忽然，他看到一个小和尚正朝自己这边来。这小和尚刚才是同大家一起去寻路的，由于他个子瘦小，腿步灵活，所以跑得最远。唐僧见了小和尚，赶紧上前问道：
    “怎么佯，有路没有？”
    “法师，”小和尚指指池塘南边，“那里有一个水洞，算不得路，我没敢往里头钻，不过，那水洞也许是一条出路，因为我在洞口边看到了人脚印的痕迹。
    “啊！”唐僧眼睛一亮，“有希望，咱们快点把大伙儿招拢来，打洞里钻过去，就算那水洞是一条死路，大不了也是一个死！”
    “法师，我看就咱们俩走吧。这么多人全去钻洞，强盗能不发现吗？一发现就全得完。”
    唐僧看看池塘里另外一些伙伴，瞧瞧正在岸上为分赃大吵大闹的强盗，确实，想一块儿走的话，一个也走不成。
    “可是，我又怎么可以撂下大家不管，自顾自去逃命呢？”
    小和尚拖住唐僧的袖子，恳切他说：“我并不是要法师撂下大家，您和我走出水洞后，可以叫人来救。要是再迟疑，全都得作强盗的刀下鬼！”
    唐僧想想有理，就趁着我们纷乱嘈杂的机会，和小和尚两个跋涉到池塘南面，钻进了那个水洞。
    水洞里黑古隆冬的，伸手不见五指，水差不多有齐腰深。前面究竟有没有出口毫无把握，掉进深水坑淹死倒非常可能。唐僧横下一条心，一边摸索一边前进，脚高脚低地拉着小和尚只管朝前钻。
    约摸走了二三里路光景，前面忽然出现了光亮。他们栅快步子，跌跌冲冲地奔出了水洞。
    太阳光亮得刺眼，唐僧定了定神，才看清东面不远的地方有个村庄。他连忙飞快地朝那村庄跑去。在村口边上，他们遇到了一位正在耕地的老人。
    老人见两个光头赤脚、满身泥浆、只穿着一件单衣和一条裤权的和尚奔来，先是吃了一惊。唐僧立即说明遭遇，并请求援救。老人明白了情况，二话没说，赶紧跑进村子，拿下挂在一棵大树上的牛角号，“呜——”吹了起来。
    牛角号声是本村约定的求救信号。听到号声，村子里的青壮年等，立刻拿着棍、棒、锄、耙、菜刀、门闩，纷纷赶来。唐僧顾不得身上稀湿、脚底疼痛，奋勇地在前引路，直奔池塘而去。
    这时，强盗们还在为分赃不均而吵得不可开交，所以没顾得上对池塘里的人下毒手。唐僧带着村民赶到，强盗见来的有好几百人，抱起抢到的衣服、财物，四散逃窜。村民们抄起手中的家伙，打得强盗嗷嗷乱叫，一会儿就窜进森林不见了影子。
    池塘里的人得救了，都激动地向唐僧道谢。唐僧却指着那吹牛角号的老人和一起赶来搭救的青壮年村民，对大家说：“要不是他们见义勇为，拔刀相助，我和大家要下一辈子才能见面呢！”
    “再说，”唐僧指着那个发现水洞的小和尚说，“我们之所以能去报信求救，也亏他发现了水洞。”大伙儿于是一边向村民等人道谢，一边就随他们回到那个村庄里。这时太阳已经渐渐西沉，唐僧等人就求宿在这村庄里，并向村民们讨了一些衣服鞋子凑合穿上。
    由于遭到了抢劫，又受到一场大惊吓，唐僧的随行同伴们，大多怨天尤人，长吁短叹，有的甚至失声哭泣起来。只有唐僧，好像啥事儿都没发生过一样，洗去腿上泥巴时，还嘻嘻哈哈地开玩笑说：“这泥巴盖在腿上，可以防蚊叮虫咬，我还真有点舍不得洗掉哩！”
    “法师，”一个同伴忍不往问，“咱们这回遭遇到强盗，差点儿成了刀下鬼，现在想起来还感到后怕。如今虽说脱险了，但是衣服财物已一无所有，越想越心痛，越难过。可是法师却是那样无优无愁，请问您怎么想的呢？”
    “这个嘛，”唐僧笑呵呵地反问，“你们想过没有，
    人最宝贵的是什么？”
    “当然是生命罗。”
    “对呀！既然生命还在，不过丢失了一些金银、衣服，出家人本来就不计较身外之物，还有什么值得忧愁的呢！”
    大家听他这么一说，都感到他的胸怀宽阔，目光深远，佩服得不得了。那些原先忧心忡忡或樱樱哭泣的人，也惭愧地低下了头，终于不再难过了。
    第二天，他们告辞村民们，来到了磔（哲）迦国（在今印度旁遮普邦境内）东部的一个大城镇。这个城镇的北面，住着一位学识渊博的老学者。唐僧高兴极了，急忙赶到那里拜访。
    那老学者看起来不过五六十岁，其实已经活了一百七十岁，他的一个徒弟也有一百三十多岁了。他见唐僧是从遥远的大唐来的，昨天不幸遭到了强盗的抢劫，就叫自己刀”位高足传讯给城镇里信奉佛教的居民，让他们为大唐高僧等人筹集点衣服物品；一边就同唐僧谈经论佛。
    那位一百三十多岁的和尚奉了师父的命令，胸前挂个大木鱼，边走边敲边喊：“大唐的玄类法师已来到这里，不幸遇到了强盗抢劫，衣服鞋沫随身钱财全都没啦！请大家施舍，帮助玄奘法师……”
    人们听到喊声，都很同情，即使不是佛教徒，也送来了许多衣服、布匹和素食。在当地百姓帮助下，唐僧向者学者学习了一个多月，然后才和随行同伴们继续前行。
    他们先是向东，再转向东北，又折向西南，旅行
    了三千二百多里，经过了好几个国家。唐僧每到一地，不仅十分虚心地向有学问的人请教学习，并且都要把印度的风土人情考察一番。
    后来，他就把自己学习考察到的知识，记在《大唐西域记》这本书中。


十一、中印度见闻

    唐僧在从北印度到中印度的历程中，对印度的风土人情、地理物候等等，做了详尽周密的考察。
    印度北靠雪山，东、南、西三面临海，东部土地肥沃，南部草木茂盛，全国百姓大多信奉佛教，尤以中印度为最盛，是全国佛教中心。
    这里的房屋，门大多朝东开。墙壁刷石灰，洁白明亮；地上涂牛粪，有一股特别的气味。原来，这是印度人的一种风俗，他们认为，地上涂牛粪不但清洁而且吉利。
    印度人很讲卫生，盛食物的器皿总是洗了再洗才用，食物过夜就不吃了；吃过饭还把杨树的细枝放进嘴里大嚼一通，达到清洁牙齿的目的。唐僧想，这一定是因为印度大部分地区气候炎热，食物容易腐败，为了防止病从口入，不得不多些讲究，日长时久，也就养成了卫生的习惯。
    印度中北部有个至那仆底国，因为从中国秦始皇时起，外国就开始有人把中国叫做“至那”，唐僧于是向随行人员打听，这个至那仆底国的国名，与中国是不是有点关系。一问，果然不错。原来在公元1世纪（中国东汉）时，河西地区有一些少数民族的子弟。到了印度，当地的国王很优待那些中国人，特地指定一个地区给他们在冬天居住，这就是至那仆底国的起源。
    这时至那仆底国的居民，虽然早已与印度民族同化，但他们见到唐僧，都很敬重。一些老人还自豪地指给年轻人看，说：“这位大唐高僧，是咱们祖先的故乡人！”
    除了至那仆底这个国名，印度的桃子和梨子的名称也带着“至那”。桃子叫“至那你”，意思是从中国来的，梨子叫“至那罗 （舌）弗 （达）逻”，意思是中国的王子。唐僧问了这里的居民才知道，原来印度的桃子和梨子，就是由中国东汉时到印度的少数民族子弟带去的！
    在富饶的中印度，唐僧先后游历了三十多个国家，停留的时间也最长。他沿着 伽河（今恒河），一面巡礼佛教的遗迹，一面向高僧、学者学习求教。在羯（竭）苦鞠 国的首府曲女城，他看到，这里单是佛教寺院就有一百多所。他在城内一座寺院里学习了三个月，才离开这里，渡过三四里宽的印度河，到达阿瑜陀国。
    然后，唐僧和随行同伴八十多人，乘上一艘大帆船，沿着印度河向东驶去。
    河的两岸，是阿瑜陀森林，当时正值初秋，树木郁郁葱葱。唐僧站在船头，欣赏着岸边美丽的景色，感到十分惬意。
    帆船行了一百多里，忽然从密林深处的小港汊里，荡出二十来只小船，船上的人挥刀舞棒，大喊大叫，直逼大帆船而来——真是糟糕，唐僧他们又碰上了强盗！
    当地强盗的凶狠是出名的，大帆船上的人见情况不好，顿时惊慌起来，有的吓得腿都软了，有的赶紧跳下水去逃命。小船一眨眼就靠上了大帆船。强盗们跃上大帆船，抢过逢索一拉，把大帆船驶到岸边，然后，用刀尖逼迫着唐僧等人上了岸。
    强盗把他们推进森林，剥掉衣服，搜尽身上的钱财，用绳索连成一串捆绑起来。只有唐僧，强盗把他和大家分开，单独绑在一边。
    “好汉，”唐僧不知强盗们要干什么，喊道：“钱财衣服你们尽管拿去。我是东土大唐来贵国取佛经的僧人，这些是我的随行伙伴。俗话说，‘不看僧面看佛面’，你们就放我们一条生路吧！”
    “什么僧面佛面的，你知道我们是什么人？”强盗头领问。
    “不知道。”
    “告诉你吧，我们是信奉突伽天神的。每年秋天，弟史们都要祭神，杀掉一个体格健壮、容貌端庄的人作为牺牲品——这回就选中你啦！”
    唐僧听了，暗暗叫苦，但他还是很镇静，问：
    “好汉们要把我作为祭天神的牺牲品，那我的这些同伴，总可以给一条生路吧！”
    “可以。但是，要祭过天神后才能放走他们。”
    唐僧点点头，不再说什么，闭上眼睛，念起了佛经。
    随行同伴见强盗非杀唐僧不可，都跪下来请求他们高抬贵手，有的还表示愿意代他去死。可是强盗们不答应。那个头领咋咋唬唬地叫喽罗们砍下几棵不大不小的树，搭成一座祭坛，然后把五花大绑的唐僧推上坛去。
    唐僧到了祭坛顶上，依然盘膝坐下，他略抬一抬眼皮，对强盗头领说：
    “好汉，让我把这卷佛经念完后再祭神，这对天神想必更加敬重。请好汉们不要逼得太急了。”
    强盗头领想，一卷经能念多少时间，就让他念吧，便回答：
    “你念快点，别耽误了祭神！”
    唐僧不再同他罗唆，微闭眼睛，喃喃地念了起来。
    他这一卷佛经念得很长，念完了再回上去从头开始念，念了一遍又一遍，反正他是用中文念的。强盗们怎么也听不明白。唐僧为什么要这么念呢？他是想拖延时间。因为这回遇到的强盗跟大森林那回不同，这次是在印度河岸边，说不定会有其他船只，甚至船队打这儿经过。要是船多人众，一定会上岸搭救；要是船单人少，也会往前驶去叫人来救……
    他念啊念啊，念得嘴都干了，还是不住地念，一边念，一边用眼角瞟着印度河，指望有船帆出现。
    他念了总有一个多时辰，强盗们都等得不耐烦了，而印度河上连一叶小舟都没出现。可是，也不知怎么会有那样巧的事情。刚才还是蓝天白云的好天气，就在唐僧大声念诵佛经的当儿，天色渐渐变得阴沉起来，终于，刮起了飓风。飓风夹杂着隆隆雷声，刮得印度河上卷起了白浪，强盗的小船翻了好几只；刮得那座树木搭成的祭坛摇摇欲坠，强盗们大惊失色。
    强盗头子问边上的小强盗：“方才我没留神听，这和尚说他是从哪儿来的？”
    “他说是从大唐东土来的！”
    “他叫什么名字？”
    “不知道。”
    强盗惊慌失措的脸色是显而易见的。唐僧随行同伴中一个比较大胆的赶紧对强盗头子说：
    “这位高僧是从大唐来的玄奘法师。法师道行高深，法力无边。一定是他念佛经招来了风神，给好汉们一个警告。要是你们真的把他杀了，别说佛法不容，连天神都会发怒的！”
    这伙强盗本来迷信，听了这几句话，都露出恐惧的神色。强盗头领赶紧登上祭坛，向唐僧跪下磕头谢罪，并且说：
    “我们只是一心想祭天神，没想到冒犯了法师。请法师恕罪！”
    唐僧随行同伴中有会说中国话的，知道强盗听不懂，就大声对祭坛上的唐僧说了几句中国话，告诉他，强盗们这会儿正害怕，赶快乘势把他们收服了
    强盗头领等不及唐僧回答，恐怕他再作什么法术，自己带头把手中的弯刀扔进了印度河，接着命令手下小强盗也都把武器统统扔下水，并交出刚才从唐僧等人身上抢去的钱财衣服。
    唐僧本是聪明人，瞧这情势，连忙站起来，走下祭坛，到强盗头领跟前，要他跪下，还用手在他头顶上摩来摩去，说：
    “你等既然放下屠刀，改恶从善，从今后就皈依佛法吧！”
    强盗头领听了，满脸堆笑，频频点头，还招唤同伙也都跪下，听法师点化。
    唐僧用佛教教义劝了他们一阵，最后又为他们授了五戒，表示接受这些人加入佛教徒行列。
    一场大祸戏剧性地结束了，唐僧和随行同伴登上帆船继续向东行驶时，悔过自新的强盗还跪在岸边为他们送行哩！
    唐僧等人又向东和东南行进了三千多里，到达了劫比罗 （素）诸国（在今印度北方邦）的都城。这里有佛祖释迦牟尼父亲净饭王在位时的正殿，里面有释迦牟尼诞生处等古迹。但唐僧巡礼到这里时，好多古迹都已荒废了。
    王殿南门外，有一个大深坑，随行同伴告诉唐僧，这里是释迦牟尼掷象落地处。原来释迦牟尼在成佛前，练过武功，力大无穷。有一次，国中一个大力士把一头大象打死了。死象塞往道路，行人不通，但没人移得开它。另一个大力士看到了，拖着鼻子把死象拉到路边去，人们都说这个大力士力气更大。释迦牟尼来了，问明情由，双手把象一抓，举过头顶，用力一掷，只见死象径直飞过城墙，落到地下，陷成了一个深坑。比起那两个大力士，释迦牟尼简直是神力了！
    离开了净饭王王殿遗址，唐僧等人在连绵不断的荒山丛要中行走了一千多里。途中最使他感动的，是两座与动物有关的小宝塔。
    一座叫救火宝塔。传说这里的森林，有一次不知道是遭了雷击还是什么原因，起了大火。风狂火猛，烈焰腾腾，飞鸟走兽，争相逃命。有一头雉（至，好野鸡）感念森林平日养育之恩，飞到河边，浸湿翅膀，然后飞到大火上空，把身上的水珠拌落下来。这么来来回回，力气渐渐没有，但还是奋不顾身地到河里去浸湿翅膀，吃力地飞到火上，洒水灭火。天帝见了，对这头雉说：“你好愚蠢，白白费这力气！噍，大火都烧红了天空，你每次往返洒落出几滴水珠，怎么都扑灭火灾呢？”雉听到声音，抬头问：“谁跟我说话？”天帝回答：“我是天帝。”雉气愤地说：“天帝法力无边，要灭森林大火，救飞鸟走兽，是多么容易，可是你非但不帮忙，反而说我愚而无功，是何道理？大火烧得这么厉害，我要救火，不跟你说话了！”说完，雉又扑打着沉重的翅膀，向火势最猛的地方飞去。天帝受到感动，帮义雉把火灭了。后来，人们在这里建了一座纪念义雉的宝塔，称为救火宝塔。
    还有一座宝塔，叫救生宝塔。说的也是森林里起那场大火的时刻，野兽纷纷窜出树林逃命。可是来到一条小河前，会游泳的游过去了，不会游泳的急得不知怎么才好。后有烈焰卷来，前有河水挡路，生命危在旦夕。一头鹿见此情景，十分同情这些小动物，就不顾自己危险，驮着它们一头一头地过河，后来来了一只兔子，兔子见这头鹿已经筋疲力尽，就帮它渡起小动物来……结果，那义鹿和义兔都因救同类而溺死在水中，人们为了纪念它们，在此建立了救生宝塔。
    唐僧听了这两个故事，很是感动。随后他到了著名佛教胜地婆罗 （逆）斯国，礼拜了释迦牟尼曾经洗澡、洗衣的地方，但心中仍念念不忘那三头动物，雉、鹿和兔子。
    接着，唐僧他们南渡 伽河，到达大乘佛教的中心摩揭陀国，在这里逗留了七天，然后，他们又到释迦牟尼觉悟成佛的菩提树下，顶礼膜拜了一番。
    经过几千里的旅行，巡礼，历险，唐僧和他的随行同伴们，折向西北，朝摩揭陀国著名的佛寺——那烂陀寺前进。


十二、留学那烂陀寺

    早在唐僧二十七岁还在长安时，就从那烂陀寺戒贤法师的弟子波颇密多罗口中，了解到这座全印度最宏大、最壮丽的佛教寺院，并对全印度最闻名的学者、佛学权威戒贤法师，产生了无比的景仰。现在，他真的来到那烂陀寺，并且就要拜见戒贤法师了，心不由得怦怦直跳。
    那烂陀寺果然名不虚传。这座佛寺共有八个大院，中央一座砖石结构的大殿，是七层楼高的房子，柱子和四壁都有着非常精美的艺术雕塑；八个大院规模宏大，气势雄祎，高高矗立在蓝天下，与周围五十多所佛寺交相辉映，分外壮观。
    这座闻名全印度的佛寺，常住的僧人就有四千多人，加上做客或前来学习的和尚与佛教徒，常常有上万人。摩揭陀国国王为了发展学术文化，拨出一百多个城市的收入，作为这座寺院的费用。所以，这里的和尚或佛教徒都能不愁衣食，安心学习。
    寺内僧人主要研究大乘佛教，也有一些人对上乘佛教、小乘佛教都很熟悉。他们研究大乘佛教，又大多以瑜伽法门为主。戒贤法师就是这一派的代表。
    除了研究佛教，寺内僧人还研究学习佛经以外的各种知识，如前面提到过的因明学、声明学，以及“ 陀”（宗教知识）等等。
    那烂陀寺不仅是当时全印度的佛教中心，而且也是当时全印度的文化中心。寺内藏书十分丰富，佛教经典可以说应有尽有。此外，还有许多天文、地理、医药、技艺等各方面的书。
    早在三年前，戒贤法师就听说大唐有个高僧玄奘来到印度留学，所以一直在盼望他来到那烂陀寺。唐僧到达那烂陀寺的这天，戒贤法师派了寺内二百多个和尚等候在路上，几千人老百姓也都自动出来迎接。他们手捧着香炉和鲜花，又是赞叹，又是欢呼，气氛非常热烈。
    在那烂陀寺里，唐僧与僧侣们一一以礼相见。然后，按照这里的规矩，大家簇拥着唐僧，去参见戒贤法师。
    戒贤法师已经一百多岁了，在寺内极受尊敬，被尊称为“正法藏”（“正法”就是佛法，“藏”的意思是包含万有；“正法藏”指通晓了佛教全部经典的人）。他见了唐僧，客气地请他坐下，问：
    “法师从哪里来？”
    唐僧恭敬地回答：“弟子玄奘从中国来，愿拜正法藏为师，请求指点。”
    听了唐僧如流的对答，戒贤法师不由得喜上心头。原来，佛教经典包括经、律、论三个方面，也称为“三藏”，在那烂陀寺四千多个和尚中，精通二十部经、律、论的，有一千多人；精通三十部经、律、论的，仅仅五百多人；而精通五十部经、律、论的，更是凤毛麟角，不算戒贤法师本人，一共只有九名。精通五十部经、律、论的，可称为“三藏法师”。那烂陀寺既然是全国佛教的中心，按照教规，除了“正法藏”戒贤法师之外，还应该有十名“三藏法师”。可是许多年来，这个教规一直没有能实现，它成了戒贤法师的一桩心事。现在，唐僧来了，他是精通五十部以上经、律、论的高僧，可以当之无愧地被称为“三藏法师”（所以《西游记》里也称唐僧为唐三藏）。这么一来，那烂陀寺的“三藏法师”就满了十名人数，达到了教规的要求。戒贤法师的心愿实现了，怎么能不高兴呢！
    戒贤法师对于唐僧寄予很大希望，不仅勉励他在学问上精益求精，生活上也贵宾一样招待他。那烂陀寺每天供应给唐僧担步罗果一百二十枚，槟榔子二十棵，豆蔻二十颗，龙脑香一两，并供给“大人米”一升。“大人米”是摩揭陀国的特产，米烂特别大，煮出的饭香软可口，平时只供国王和最有成就的学者食用。他们给唐僧这么优厚的待遇，一方面是因为他是从中国来的高僧，另一方面也是敬重他的知识学问。
    在唐僧到那烂陀寺以前，戒贤法师因为过了百岁高龄，体弱多病，已经许多年没有说法讲经了。但是为了唐僧，他决定破例开讲《瑜伽师地论》。每次讲经时，远近赶来听讲的，总是好几千人。戒贤法师为唐僧一连讲了一年零三个月，才把《瑜伽师地论》讲完。
    唐僧万里迢迢来到那烂陀寺求学，当然决不会以听戒贤法师讲讲经文为满足。他除了一度巡礼这座寺院附近的佛教胜迹外，在寺里起早摸黑专心致志地修学了五个年头。五年中，他读完了寺内收藏的所有佛教经典，通晓了其中的奥妙，又进一步研究了印度佛教各家各派的学说，学习了东、南、西、北、中——印度名国的语言。花这一番功夫是非常值得的，这为他以后把印度文的佛经翻译成中文（汉语），打下了扎实的基础。
    正如中国古时格言所说：“学然后知不足。”五年后，已经三十六岁的唐僧，并不以自己已经学到的知识为满足，又辞别了戒贤法师，到各处去游学。
    他先到东印度临近孟加拉湾的伊烂体伐多国（印度比哈尔邦），跟两位高僧学习了一年。在以后的两三年时间里，他最东到迦摩缕波（印度阿萨密邦），最南到罗毗荼（皮途，印度买索尔邦班加罗尔一带），最西到狼揭罗（巴基斯坦俾路支省东南一带）。每到一地，他就虚心向当地的有名学者请教，研读那里收藏的佛经和各种学术书籍，开阔自己的视野，丰富自己的知识。
    他这几年游学所经过的地方，都是属于陵谷纵横的热带地区，气候异常炎热。酷烈的太阳晒得他喘不过气，劈头盖脸的暴雨又常常淋得他浑身上下没一块干的地方，幸好他总是把抄录到的佛经包在油纸里，小心保护着不让他受到损失。此外，热带地方的猛兽很多，弄不好就给它们一口吃了。但是，无论是气候的难以忍受，还是种种危及生命的险境，都影响和阻挠不了唐僧游学的意志。他在艰苦的环境中锻炼得更加坚强，并且终于克服了种种困难，使自己的佛学造诣更成熟更精湛了。
    游学了东、南、西印度各国后，唐僧满载而归，回到那烂陀寺，向戒贤法师报告了游学的经过。
    戒贤法师问了他一些问题，感到他的学问比出去游学前更渊博，就对他说：
    “大唐三藏法师，你的佛学知识已经超过了我其余几名弟子。我想现在就请你为本寺僧人开讲佛经，你看怎么样？”
    唐僧听了，深感戒贤法师对自己的器重和信任。他行了礼，回答说：
    “正法藏慧眼赏识，弟子十分荣幸。但弟子听说，本寺附近低罗择迦寺的般若跋陀较法师，学问甚好；本寺东南杖林山的胜军法师，研究天文、地理颇有心得，对于《唯识抉择论》尤其精深。所以，弟子打算先到那个地方学习过后，再回来听凭正法藏吩咐。”
    戒贤法师见他求学心切，也就点头同意了。唐僧在低罗择迦寺向般若跋陀罗学习了两个月，到杖林山向胜军法师学习了一年多。他这种遍访名师、虚心学习的精神，使他的学术达到了成熟，也博得了印度人民尤其是佛学界的钦佩和赞叹。


十三、声誉日上

    唐贞观十四年，四十一岁的唐僧又回到了那烂陀寺。他遵奉戒贤法师的命令，为大家讲起了大乘佛教喻伽法门的主要经典《摄大乘论》和《唯识抉择论》。
    那烂陀寺平时，每天有一百多种讲座，同时开讲。胄僧讲经时，戒贤法师另一名大弟子、同他一样名列：“三藏法师”的师子光，正在寺里讲《中观论》和《百论》两部佛经。
    师子光虽说是戒贤法师的弟子，与唐僧同属于大乘佛教信徒，但是，他的派别和专长与唐僧不同：唐僧是瑜伽法门的，师子光却是中观法门的。
    瑜伽法门与中观法门是大乘佛教的两大派别，两者原来就有分歧。师子光一方面为了宣扬中观法门，另一方面也是对唐僧受到戒贤法师的称赞感到不服气。所以，他在讲经时，时常贬低瑜伽法门，以达到打击唐僧的目的。
    俗话说：“不怕不识货，就怕货比货。”师子光与唐僧同时开设佛经讲座，唐僧不仅经讲得比师子光好，而且他并不攻击中观法门。结果，许多听师子光讲经的人，都去听唐僧的讲座了，连一些师子光的学生，都投到了唐僧的门下。
    师子光大为恼火，对唐僧攻击得更厉害了。
    唐僧听到了师子光攻击自己的风言风语，并不很计较。他认为；大乘佛教中这两大派别的学说，对于佛教教义，各有侧重发挥，只是由于过去没有融会贯通，就以为两者是互相矛盾的，甚至互相排斥和攻讦（jie结）。
    为了团结师子光。，调和瑜伽和中观两派的学说，唐僧就写了《会宗论》三千颂，阐明自己的观点。戒贤法师看了《会宗论》，大加称许，叫人把这篇论文悬挂在寺门口，让大家学习议论。全寺僧人围观着《会宗论》，也都赞不绝口。
    师子光起初不肯去看那篇文章，经不住大家纷纷赞美，就挤在人堆里看了一遍。不料他看完后不仅没有认识自己的错误，反而一张脸从双颊红到脖子根，又羞又恼地跑了。
    他跑到一座名叫菩提寺的佛寺，请自己的同学、东印度著名学者旃（zhān毡）陀罗僧河，到那烂陀寺去与唐僧辩论，好替自己出一口气。旃陀罗僧河非但雄辩，好胜心也很强，听老同学一说，立刻出发前往那烂陀寺。
    在那烂陀寺寺门口，旃陀罗僧河看到了悬挂在那儿的《会宗论》。他从头到尾读了一遍，不由得对唐僧的高见产生了由衷的佩服，但是，既然应了老同学之托来这里辩论，总不能就这么回去呀，他想，唐僧写文章，是经过深思熟虑再落笔在纸上的，而且打好草稿后还可以一再修改，最后才誊抄成文；要是听他口头讲讲，必能捉到他几个漏洞，然后根据他的漏洞再反驳就是了。想到这里，旃陀罗僧河跑进那烂陀寺里，求见唐僧，并三言两语说明了来意。
    旃陀罗僧河虽然没讲自己是师子光请来的，可是唐僧心中早已猜着了八九分。他只当不知道，请客人坐下，然后就从从容容他讲了起来。
    唐僧一口气讲了一个多时辰，讲得很真诚，也很在理，旃陀罗僧河听着听着，竟忘记自己是做什么来的了，听到入味的地方，还不由自主地把头点了又点。
    唐僧讲完，说是请客人多多批评。这时旃陀罗僧河才如梦初醒，站起来向唐僧行了个礼，一言不发，转身退出了寺院。
    旃陀罗僧河回去后，对师子光说了与唐僧“辩论”的经过，并且劝他服从真理，不要再意气用事。师子光平下心来想想，自己的佛学知识既不如唐僧深，学术风格也不及唐僧高，一年以后，他就回到那烂陀寺，与唐僧言归于好了。
    从那以后，唐僧的声名已誉满了五印度（指东、南、西，北、中）。
    当唐僧在那烂陀寺苦读佛经、钻研佛学时，印度的中部和北部，正由曷（he河）利沙帝国的戒日王统治着。戒日王率领军队征讨恭御陀国（印度奥里萨邦东南海岸的甘詹姆港附近），途中经过乌荼国（印度奥里萨邦东南），碰到了一件不愉快的事。
    原来，戒日王是大乘佛教的信徒。而那个乌荼国中，却有不少僧人信奉小乘佛教。其中有一个名叫般若 多的学者，还写了一篇《破大乘论》七百颂，攻击大乘佛教的经义理论，说大乘佛教不是佛祖释迹牟尼本来的主张，是空花外道。
    大乘佛教与小乘佛教，原是佛教中的新派与旧派，但都认为自己才真正掌握了佛教的真谛。大乘佛教特别不愿意小乘佛教攻击它不是佛祖本来的主张。而小乘佛教教徒们读了《破大乘论》，眉飞色舞，简直高兴得要发狂了。
    戒日王知道乌荼国的般若 多写了《破大乘论》，好不气恼。偏偏乌荼国还派出几个僧人，带了《破大乘论》的抄本去见戒日王，并对他说：
    “这是我们小乘佛教最新最完善的经典论著。大乘佛教中无论多么有能耐的高僧，也绝对没有人可以攻倒其中一个字！”
    “什么？”戒日王听了，气得胡子翘到耳朵根，他压下怒气，回答说：“我曾经听说这样一个故事：有一只狐狸在鼷（希）鼠群里自吹自擂，说它比狮子还要勇猛。这话传到一只狮子的耳朵里，狮子就去找狐狸，想同它较量一下。可是，狐狸听说狮子要来，竟吓得魂飞魄散，撒腿跑了。我想，你们大概是没见过大乘佛教的高僧，所以固执地抱着愚蠢的教义，而且敢于漫天吹牛。要是真的遇到了大乘佛教的高僧，恐怕你们全都会像那只见不得狮子的狐狸呢！”
    这些小乘佛教的和尚听了，很不服气，嚷嚷说：“大王不要奚弄人。假如大王不相信我们的话，不妨请召集两派学者，当面辩论，决一胜负！”
    “好！”戒日王说，“这有什么难的，我今天就写信到那烂陀寺去。那烂陀寺里除了正法藏戒贤法师，还有十名三藏法师，其中一名从东土大唐来的玄奘法师，更是了得，只怕我把人家请来了，你们像见到狮子的狐狸，全都溜跑了呢！”
    “没有的事。别说玄类法师或别的谁到乌荼国来，就是大王召开五印度大法会，我们也决无害怕之理！，“
    “那就等着瞧吧！”戒日王踌躇满志他说。
    当天晚上，戒日王果然写了封信，叫一名卫士送到那烂陀寺，请戒贤法师派唐僧等几名高足到乌茶国来和小乘佛教的和尚辩论。然后，他继续率领部下，向恭御陀国进军去了。
    戒贤法师接到戒日王写来的信，与几位弟子商量了这件事，最后，决定派海慧、智光、师子光和唐僧四人去乌茶国。戒贤法师想，自己年老体弱，不能前往，而这四位都是三藏法师。尤其唐僧，一定不会辜负期望的。
    没想到，师子光和海慧、智光三人，得知乌茶国小乘佛教和尚不但学问深，而且善于雄辩，竟顾虑重重，畏缩起来。师子光还出主意，“咱们就请正法藏自己去乌茶国。他要是去，是输是赢，咱都可以不管七他要是不去，咱也可以说：连老师都不敢去，咱们去能行吗？”
    他们三人把这话跟唐僧一说，唐僧差点儿发起火来：“你们怎么好意思讲出口。正法藏一百多岁高龄了，身体又不好，居然要他亲自到乌茶国去辩论，那老师不是白教咱们了吗！” “那么，你能不能保证辩论得胜？”师子光不信任：“我不敢保证一定得胜。但是，小乘佛教的主要经典，我在中国时，以及到印度后在迹湿弥罗国等国，可以说已经读遍。我了解它的底细，料定它绝对破不了大乘教义。所以，尽管我才疏学浅，到乌茶国辩论还是对付得了的。”
    “要是失败了，那烂陀寺的名声就完了，这你不能不考虑啊！”师子光还是不放心，“这倒不必担心，我是大唐来的，万一辩论输了，也是我的事，与各位无关，
    可是，他们还没出发，又收到了戒日王派人送来的第二封信，以及托送信人捎来的《破大乘论》的原叉。戒日王在信上说，由于对恭御陀国的战争还没有结束，自己不能脱身赶到乌荼国去，所以请唐僧等暂缓一步，同时也可以利用这段时间，把《破大乘论》研究一下。唐僧等人也觉得这样做很有必要，就琢磨起《破大乘论》来。
    唐僧原来以为自己读遍了小乘佛教的主要经典，卖《破大乘论》没有问题，可是真读起来，却有好几处弄不懂。因为这《破大乘论》是般若 多新近写的，不少内容发展了小乘经典，难怪乌荼国小乘佛教的和尚要如获至宝欣喜若狂了。
    这一天，唐僧正和师子光等人研讨《破大乘论》，门外来了一个“顺世外道”的婆罗门教徒。这婆罗门教徒是从乌茶国来到那烂陀寺要求辩论的。他写了四十条经义论纲，挂在那烂陀寺门口，高声喊道：
    “那烂陀寺的僧人们听着：如果你们中伺有人能破我经义论纲中的一个字，我情愿砍下自己的脑袋认输！”
    在当时，印度学术界辩论的风气很浓。一般说，辩论失败的，要骑在驴背上，并被人用一瓢屎从他的头上浇到脚下；然后胜利者将这人收为侍从仆役，也有的人觉得这么输赢还不过瘾，就把性命押上去，这婆罗门便属于这样一种人。
    挑战者上了门，唐僧却不理睬他。因为这时唐僧的心思，全扑在研究《破大乘论》上。辩论同打仗一样嘛）要知己知彼，才能百战不殆。
    可是，一连几天，只听到那婆罗门高声叫喊着挑战，就不见那烂陀寺里哪一个和尚前去应战。到后来，婆罗门教徒也懒得喊叫了，只是斜靠在寺门边上，阴阳怪气他说：
    “什么那烂陀寺，连个辩论的人都挑不出来，我看戒贤法师已经半截入了土，这寺院让给我，由我来当家得了！”
    说罢，他对和尚们乜（mie畔）起了白眼，还发出了阵阵冷笑。
    有人把婆罗门教徒的言行报告了正在埋头研究《破大乘论》的唐僧。唐僧霍然站起，对身边一个小和尚说道：
    “你去，到门口取下那婆罗门教徒悬挂着的东西当场撕碎，扔到脚下踩个稀烂！”
    对那婆罗门教徒，小和尚胸中早积着一股窝囊气，听唐僧这么吩咐，连忙大踏步地跨到寺门外，一把扯下“顺世外道”的四十条经义论纲，“哗哗”撕成碎片，丢到地下狠狠地踩了几下。
    婆罗门教徒没想到小和尚敢这般无理，怒气冲天，一手抓住小和尚，一手拧住他的耳朵，骂道：
    “你是什么东西，敢如此无礼！”
    “住手！是我叫他撕的！”
    “你是谁？”婆罗门教徒放开小和尚，气势汹汹地对已走过来的唐僧摆开了打架的招式。看他的神气。
    真要把唐僧一口吞了呢！
    “贫僧玄奘，恭听足下高论。”唐僧可不想同对方打架。一听来的是唐僧，婆罗门教徒顿时减了一大半锐气。他知道对方是来应战的，就发问说：
    “法师有理可以说，撕毁论纲，践踏脚下，道理何在？”
    唐僧不做正面回答，却微笑着请那人进寺内正式辩论，并请戒贤法师和师子光等高僧做证。婆罗门教徒心中忿忿，在戒贤法师等人面前刚一坐下，就重复了先前提出的那个问题：
    “法师凭什么指使人撕踏我的论纲尸唐僧目光炯炯，慷慨回答：
    “就是撕踏了，又有什么不对呢？你先看看自己身上，是什么样儿吧。”
    婆罗门教徒瞅了一下自己的衣服）又肮脏又破烂；再看看手和脚，更是龌龊得能刮下污垢来。但他一点不以为然，说：
    “这又怎么啦？这就是我们修行的表现。修行需要的是苦行，苦行就不能讲究清洁。这个道理连小孩子都懂，难道堂堂的大唐三藏法师反倒不明白？
    唐僧反唇相讥：“嘿，我怎么不明白，我光看你们的衣着外表，就可以知道你们的论纲是不是有道理了！你们这一门教派的人，有的用灰涂满全身，像钻进灰堆的猫；有的把头发拔光、以痛苦来积，功德’；有的把死人骷髅挂在脖子上，作为装饰品；有的更不像话，睡粪堆，吃垃圾，像头猪一样，还以为这样才算苦行，才能升天。你想过没有，出家修行应该身体干净，清心寡欲，着眼于修性；而像你这样，实在愚蠢到了极点，又哪能叫别人信服呢！”
    婆罗门教徒听唐僧说得合情合理，不由得自惭形秽，低下了头。
    唐僧接着说：“我读过婆罗门教的经典，了解你们的教义，不看你的论纲，也可以同你辩论。刚才我叫人撕踏你悬挂的论纲，只是因为你口出狂言，甚至伤及了我尊敬的老师，所以我要给你一点惩罚，接着，唐僧向那入侃侃而谈，阐述了大乘佛教的宗旨理论，批判了外道（佛教以外的宗教）的不经之谈，有说得婆罗门教徒低头红脸，哑口无言。
    最后，婆罗门教徒离开座位，跪在地下，伸长了脖子说：
    “我已经认输。请法师照前约执行吧。”
    他说的“，前约”，就是指砍下脑袋。可是唐僧怎么会那样做呢，倒是笑着说：“算了吧！你也知道，我们佛门是不杀生的，赶快起来，别趴在地下了。”
    婆罗门教徒对唐僧的宽宏大量十分感激，但他心里总过意不去，请求唐僧至少也得按照一般规矩办，把他放到驴背上浇一阵粪水，然后收为侍从。
    唐僧想了想，说：“好吧，你既然对佛教已心悦诚服，暂且在我身边充做侍从也好。不过浇粪水什么的万万不可行。我方才已说过，佛教主张身体干净，清心寡欲，怎么可以拿污水浇人？你要真这么做，那股臭气谁受得了呀！”
    戒贤法师等人方才见唐僧辩论获胜，都满心欢喜，这会儿听他这么一说，忍不住放声笑了起来。
    婆罗门教徒也惭愧地笑了。他赶紧由刚才被他拧过耳朵的小和尚陪着，到寺门外河里洗了澡，换了干净衣服，回到唐僧身边，正式当了侍从。
    唐僧先前曾听说，这婆罗门教徒来那烂陀寺前到过乌荼国，这时就问他：
    “你在乌荼国时，听过般若毯多演讲《破大乘论》吗？”
    “听是听过的，可是没怎么听懂。”
    “你听过，总比我没听过强。是不是请你给我讲解一下？”
    唐僧说得既虚心又诚恳，那婆罗门教徒十分感动。但他总有点不自在，回答说：“我现在是法师的侍从，怎么可以为法师讲解经文呢！”
    “这是哪儿的话！”唐僧连忙摇头，“眼下你虽说暂时委屈当着侍从，我心里可是一直把你看做朋友。再说，你听过般若毯多讲《破大乘论》，不管懂多少，比我总强些吧。你不必多虑，请讲好了！”
    婆罗门教徒见唐僧这样虚心、诚恳，只得点了点头，为他从头到尾把《破大乘论》讲了一遍。
    唐僧听他讲过后，弄懂了许多疑难问题，井找到了《破大乘论》中不少漏洞和谬误。然后，他花了一番心血，写了一篇《制恶见论》一千六百颂。《制恶见论》不仅针锋相对地驳斥了《破大乘论》，而且对其他各教各派攻击非难大乘佛教的言论，也进行了有力的批驳。
    《制恶见论》写成后，唐僧用印度文字工整地誊清，呈上请戒贤法师指正。戒贤法师看了后）十分满意，一个字都不改动，就命令一位三藏法师宣读给寺中僧人们听。大家听了后也都纷纷发出赞叹，表示无限钦佩。
    在众人赞叹钦佩的当儿，唐僧又想起了那个婆罗门教徒，对他说：
    “你已下决心诚意修行，这回又给了我不少帮助，用不着再坚持当什么侍从了。现在请你自由行动吧。”
    那人见唐僧的话很是真挚，也就拜谢了一番，离开了那烂陀寺。
    不久，他到了东印度的迹摩缕波国，向国王鸠摩罗王百般赞扬大唐高僧玄类怎么怎么道德高尚，怎么怎么学问渊博。鸠摩罗王虽然并不专信佛教，但十分敬重德高望重的学者。鸠摩罗王是个急性子，想到什么就要干什么，他当天就派了一名使者，送信到那烂陀寺，邀请唐僧到迹摩缕波国讲解佛经。


十四、曲女城大法会

    唐僧自从写成了《制恶见论》后；又等了些日子，但始终没接到戒日王的信，估计戒日王对恭御陀国的战争一时间结束不了，而他自己对于祖国的思念却一天深似一天。为了早日回到长安，翻译佛经传给后世，并统一中国佛学界的各派学说，他决定回祖国去。
    他把自己的想法跟戒贤法师等人说了。他们起先舍不得他走，但唐僧再三说明，自己回国是为了传播佛经，光大佛法，大家这才同意了。至于戒日王那边，就由戒贤法师出面，写封信去解释一下，好在《制恶见论》足可以把《破大乘论》驳得体无完肤，玄奘法师的东归，想来戒日王也能谅解的。
    谁知，戒贤法师还没把给戒日王的信写好，鸠摩罗王的使者就到了那烂陀寺。
    戒贤法师展读了鸠摩罗王的信，召集寺内僧人商议这件事。唐僧因为这封信是写给戒贤法师的，自己不便拒绝，只是低头不语。戒贤法师明白唐僧归国心切，于是说：
    “依我看，这件事还是婉言谢绝的好。一来玄奘法师准备回国，不宜再耽搁日子；二来戒日王比鸠摩罗王邀请在先，假如让玄奘法师到迎摩缕波国去，戒日王那里不好交代。你们的意思怎么样？”
    戒贤法师既然已经这么说了，大家自然没有异议。
    戒贤法师于是唤送信的使者进来，请他回去告诉鸠摩罗王，就说玄类法师准备回国去了，望原谅他不能应邀前往。
    可是，使者回国对鸠摩罗王这么说了后，鸠摩罗王很不高兴。他叫使者再一次去那烂陀寺，说：“就算玄樊法师要回国去，请他先到我这儿来讲几天经再走难道不行吗？”
    戒贤法师经过再三考虑，还是让使者回去了。
    两次邀请唐僧都遭到了拒绝，鸠摩罗王这一回大大地发火了。、他提起笔，“沙沙”地写了封信，叫使者骑上快马，日夜兼程送到那烂陀寺，面交戒贤法师。
    戒贤法师一打开鸠摩罗王的信，眉头立时皱起了疙瘩，原来，这封信上说：“我学识浅薄，所以再三邀请玄奘法师驾临敝国开导。可是你戒贤法师却不让他来，那等于说我是个恶人，不值得赐教）既然我横竖是恶人，索性率领象军前来，踏于那烂陀寺，把它碎成尘土。我说得到做得到，你们等着瞧好了！
    戒贤法师急忙把唐僧请来，用商量的口气说：“鸠摩罗王性子暴躁，这件事咱们得认真对待，我想，他几次来邀请你，确实是诚心诚意的。你是不是考虑一下，如果能到他那儿去讲些日子佛经，不但可以使本寺避免遭难，还能趁机在迹摩缕波国宣扬我大乘佛教，你看怎么样？”
    唐僧想想，也只有如此，就回答说，“正法藏说得有理。既然如此，弟子即刻前往就是了。”
    戒贤法师打发使者先回去报告鸠摩罗王，然后，派人护送唐僧往迦摩缕波国而去。
    玄奘到迎摩缕波国后，受到了鸠摩罗王的热烈欢迎。他抓紧时间为当地僧人和百姓讲开了大乘佛教的经文。鸠摩罗王听得出神，渐渐萌发了信奉大乘佛教的念头。
    日子过得很快，唐僧在迹摩缕波国讲了一个多月的佛经。这时，戒日王已经结束了对恭御陀国的军事行动，班师回到曲女城。他派使者到那烂陀寺请唐僧。找贤法师只好向使者说明，鸠摩罗王以武力威胁，不寻已已经让唐僧到迹摩缕波国去了，戒日王信仰佛教，听说鸠摩罗王这么无礼，气上心头，马上派使者到迦摩缕波国，向鸠摩罗王传言：
    “我与玄奘法师有约在先，没想到你倒抢在前头了。你赶快把法师送到曲女城来广
    鸠摩罗王没想到戒日王突然派来使者要唐僧赶快去曲女城，说话的口气又那么大，伊然是发布命令。
    鸠摩罗王想：“我好歹也是一国之主，就听你这么颐指气使？”他心里一火，话就冲口出来了：
    “赶快送去？哪有这么便当的事！你回去对戒日王说：我的头可以给你，要我立刻把法师送去，办不到！”
    使者碰了钉子，回去把经过一说，戒日王勃然大怒：“好个大胆的鸠摩罗王！你先是扬言要踏平那烂陀寺，已是对佛法的大不尊敬；现在又敢违抗我的命令，分明是不把我全印度的领袖戒日王放在眼里！”说着，他把佩刀交给使者：
    “你再去，传我的话：‘既然你说头可以给，送法师来办不到，那就割下你的头，交使者带来给我！’”
    使者接过佩刀，立即出发，赶到迦摩缕波国，一字不漏地把戒日王的原话作了转告。
    鸠摩罗王上回在火头上对戒日王的使者说过那过分的气话以后，心里也很懊悔，如今戒日王真的要头颅来了！他思前付后，只好向使者赔笑，说：
    “你回去禀告大王，就说我将亲自把玄奘法师送去。”
    戒日王的使者走了，鸠摩罗王心中还忐忑不安，他恐怕戒日工到那时再翻脸，就调集了象军二万乘战船三万艘，名义上是为欢送唐僧壮行色，暗中也为万一戒日玉要大动干戈做好准备。
    鸠摩罗王率领着象军船队，到了兢伽河北岸驻下。他请唐僧先休息休息，自己渡过河去见戒日王。
    戒日王先前听了使者的回报，现在又见鸠摩罗王亲自护送唐僧来到，气儿全消了，就问他。
    “玄奘法师怎么不和你一一同过河来呢？”
    鸠摩罗王听对方的口气已经不再怪罪，心上的石头也就落了地。他想挽回一点前来赔罪的面子，于是借唐僧的威望说：
    “玄奘法师现在河北岸。但是，大工既然仰慕玄奘法师，理当亲自过河去，恭恭敬敬地迎接法师。怎么可以拿大国之王的架子，要法师来见大王呢？”
    “对，对！”戒日王听了这话，连连点头，“这么吧，你先回去，禀告玄奘法师，就说我明天一早就亲自渡过河去，恭迎法师。”
    鸠摩罗王回到北岸，对唐僧说：“戒日王不生气了。他虽然说自己明天过河来迎接法师，但我瞧他那副心急的样子，说不定今天夜里就等不及要过河来呢！”
    唐僧听了这话，高兴地说：“那咱们就别睡觉了，省得他突然到来时措手不及。”
    “那倒不必。戒日王的仪杖有一点与众不同：他行动的时候，总是带着几百面金鼓；每走一步，几百名鼓手就一齐击一下鼓，叫做节步鼓。这个仪仗是戒日王独占的，别的国王都不许用。只要听到节步鼓声，就知道戒日王来了。”
    说完，鸠摩罗王吩咐卫队长注意动静，自己和唐僧等人各自安息去了。
    当天半夜一更多， 伽河南岸出现了一片辉煌灯火，庄严的节步鼓声由远渐近。鸠摩罗王得到报告，连忙和唐僧等人穿好衣服，点燃灯煜，前往河岸边迎接戒日王。
    戒日王一见到唐僧，就向他献上鲜花，恭敬地行礼致意，并问起了关于中国的情况。唐僧根据自己叫知道的，向戒日王介绍了中国的悠久历史，以及唐朝文化、经济、政治等方面的情况，戒日王听了，非常满意。
    天亮以后，唐僧和鸠摩罗王随着戒日王，又渡过 伽河，来到戒日王的行宫。唐僧将自己写的《制恶见论》呈上，并为戒日王讲了一会儿佛经。戒日王听了，十分赞赏，说：“太阳出来了，萤火灯煜就不再明亮了；天雷轰鸣了，锤凿敲击的声音就听不见了。”意思说大乘佛教是太阳、天雷，小乘佛教是萤火、灯煜、锤凿，两者是无法相比的，更不要说佛教以外的“外道”了。
    戒日王请唐僧来，本来是要他和乌荼国的小乘佛教徒辩论的；现在读了他写的《制恶见论》，听了他讲解的佛经，就想把辩论的范围扩大到全印度。他对唐僧说：
    “法师讲的道理好极了。弟子听了不胜钦佩，并且认为，这些道理应该让各地的小乘教徒和‘外道’都知道，否则他们是不肯信服的。我想在曲女城召开一次大法会，邀请五印度的和尚、婆罗门教徒，以及教外人士来听你讲经，展开辩论，使大乘佛教以外的各教各派从此信服，不再攻击大乘佛经。”
    唐僧听了，又惊又喜，举行全印度规模的大法会，一定可以结识到不少印度最有学问的学者，使自己的佛学知识更上一层楼，这将是多么有益啊！但是他很谨慎也很谦虚，对戒日王说：
    “大王有此盛举，贫僧实在感到高兴。只怕我年纪尚轻，佛学根底还浅，大法会的主讲人，大王最好另外考虑。”
    “这你就别客气了！”戒日王连连摇头，“依我看，只有你主讲，才是最适当的！”
    鸠摩罗王也在一边鼓吹说：“法师不必过谦。我本来并不专信大乘佛教，听你讲了经后，已经成为大乘佛教的信徒，这难道还不足以证明你的佛学根底和雄辩艺术吗？”
    唐僧听了，只好合掌说：“那就听凭大王安排吧！”
    当天，戒日王就发出文书，通知各国，邀集佛教等各界人士，某月某日在曲女城举行大法会。
    应邀参加曲女城大法会的，有五印度十八个国家的国王，以及各国的高僧和学者；大乘和小乘介教徒三千多人，婆罗门教和其他宗教的教徒二千多人；那烂陀寺也有一千多僧人出席大法会。这些人士，再加上他们的随行人员和想听唐僧讲经的百姓等人，总共有一万多人。他们赴会时，有的乘象，有的坐车，有的执幢，有的举幡，浩浩荡荡，盛况空前，几十里路都没有一点空隙。
    戒日王先叫人在会场上搭了两从可以容给一千人的便殿，并在自己的行宫里铸了一个金佛像。大法会召开这天，他叫人把金佛像放在一头大象的北上，然后自己手执白拂，站在佛像的右方；鸠摩罗王手执宝伞，站在佛像的左方。载金佛像的大象后面，又装饰了两头大象，满载鲜花，一路前行，一路散花。唐僧和其他一些有名望的法师，每人乘了一头大象，排在载鲜花的大象后面。再后面是十八国国王和他们的大臣们，乘坐着三百头大象。整个象队以开路，稳稳当当地走向会场。
    到了会场门口，大家下了象。戒日王亲自捧了金佛像走上便殿，把它安放在宝座上。然后，他和鸠摩罗王及唐僧等人，依次上前行礼；十八国国王和各国有名望有帝问的法师一千人有名望的婆罗门教徒五百人、各国大臣二百人，也都入了殿，集体向金佛像行礼。
    戒日王恭请唐僧为论主（主讲人），坐下开讲。
    唐僧讲的主要内容，是他写的《会宗论》和《制恶见论》，他用这两篇论著，阐发大乘佛教的精义，驳斥小乘佛教及其他宗教对大乘佛教的非难和攻击。他在便殿里开讲的时候，那烂陀寺的戒贤法师，就站在门外，向大众宣读唐僧所讲的内容。戒日王还叫人把《会宗论》和《制恶见论》抄出来，悬挂在大法会会场门口，并依照辩论的习惯声明：
    “如果有人发觉这两篇论文中有一个字没有道理，并能够据理把玄奘法师驳倒的，就斩论主的头，向大家谢罪。“
    当天直到傍晚，没有人提出意见，戒日王大为欢喜，宣布散会，明天继续再讲。
    第二天开讲的仪式，和第一天一样，到晚上，还是没人反驳。
    第三天过去了，仍旧没有一个反对的，唐僧精彩的论述赢得了各方面人士的钦佩和敬仰。
    第四天，有一个精通小乘佛教的慧天法师，向唐僧提出了几点异议；另外还有几个一向自以为博学而雄辩的人，趁慧天发难的机会也说了几句不同意大乘佛教的话。但唐僧胸有成竹，从容不迫地一一作了答辩。结果，慧天法师等人全都哑口无言，只有向唐僧行记表示折服。
    第五天是最后一天，从早到晚，没有一个人出来辩论的。
    唐僧的声誉达到了高峰。
    戒日王高兴极了。不料，正当他要宣布大法会将进入下一个议程——各教各派自由讨论的时候，得到了一个消息：有人要暗害唐僧！
    原来，参加曲女城大法会的人，虽然属于各教各派，信仰不同，但大多学问渊博而又擅长雄辩。他们听了唐僧的演讲，都认为这是自己平生听到的论据最充足、说服力最强的演讲，心中非常佩服。可是，有极少数的人，没有本领驳倒唐僧的论点，却又嫉妒他赢得的声誉，于是打算暗害唐僧。他们还没动手，就被戒日王的卫士得知了消息。
    戒日王听说有人要搞阴谋，气得脸都发了青，马上宣布了一道命令：
    “中国法师为颂扬大乘佛教来到这里。凡在学术上有不同意见的，都可以出来发言，辩论。但如果有人底毁法师，我要割他的舌头，如果有人伤害法师，我要斩他的脑袋！”
    戒日王是全鳊的盟主，他的厉害谁不晓得？这么一宣布，那些坏家伙再也不敢轻举妄动了。
    曲女城大法会一连开了十八天，直到散会，再没有一个人对唐僧的论点和论据提出任何不同的意见；许多人还因为受到唐僧演讲的鼓动，转而信奉了大乘佛教。
    这次大法会可以说是佛教史上的一次盛典，鳊人民至今还津津乐道，把它看做是中屯两国人民友谊的纪念。
    散会的那天，戒日王送给唐僧金钱一万、银钱三万、一等僧衣一百件；各国国王也纷纷赠送给唐僧许多珍贵的礼品。但唐僧统统谢绝了。
    戒日王只好对唐僧说：
    “法师不受礼物，弟子勉强不得。但按照印度古法，凡是辩论得胜的，应骑象游行一周。为了显扬法师以义服人、独立不倚的精神，这一点请法师不要推辞。”
    唐僧是个谦虚的人，听说要请他骑上大象游行，让万众瞻仰，脸都红了，他再三谦让，戒日王就是不让步，最后他只好同意了。
    于是，唐僧乘上那头装饰得十分华丽的大象，绕场一周。大家走在大象的两边，掀舞着唐僧的袈裟，并高声宣唱：
    “中国大法师发扬大乘教义，破除一切异见，十八天来没人敢和他争论，普天下的人都应当知道这件事呵！”
    人们捧着香和鲜花，向唐僧欢呼跳跃，还争着给唐僧赠送荣誉的称号。大乘佛教方面称颂他为“摩诃耶那提婆”（意见是大乘天），小乘佛教方面称颂他为“木叉提婆”（意思是解脱天）。
    曲女城大法会闭幕时，唐僧已四十二岁了，他虽然身在国外游历了士 一年，但心中却一直萦念着遥远的祖国。现在，取佛经求佛法的目的既然已经达到，他也就更加急着想回大唐，于是他向戒日王表示了这一心愿。
    戒日王见唐僧归心似箭，不再阻拦，只是诚恳地说：
    “这里每五年召开一次无遮大会，先前开了五次，现在弟子已在大施场准备了无数财物，即将开第六次。法师何不暂留些日子，等开过无遮大会再启程呢？”
    主人盛情难却，唐僧也就只好同意。他随着戒日王等到了 伽河与朱木拿河之间的钵罗耶伽国大施场，参加了历时七十五天的规模宏大而又非常奇特的无遮施舍大会。到会的僧人，百姓等有五十万人，戒日王和各国国王等都布施了财物。这次无遮大会，成为印度历史上参加人数最多，规模最大的一次无遮大会。


十五、载誉归国

    无遮大会开过后，唐僧提出要回国去，这一回戒日王再也不好留他了。
    可是鸠摩罗王还舍不得，他对唐僧说：“法师要是能留在弟子国内，弟子要为法师造一百座寺院。”
    “大王的好意，贫僧心领了。”唐僧婉转地表示谢绝，并且再三向鸠摩罗王等说明，自己回国去，是为了翻译佛经，光大佛教，印度人民的深情厚谊，自己是终生也不会忘怀的。
    他这么一说，大家也就不再勉强了。
    戒日王问唐僧：“法师返回大唐，打算走陆路呢，还是走海路？如果走海路，我叫人准备船只，送法师回国。”
    唐僧说：“贫僧当年来印度时，路过高昌国，高昌国王 文泰待我很好，而且我与他有留在高昌讲三年经的约定，所以打算还是从原路回去。”
    戒日王见唐僧这么遵守诺言，讲究信用，更感到由衷的敬佩。他和鸠摩罗王要把许多珍贵的礼物赠送给唐僧，可是唐僧怎么也不肯收下，最后，接受了戒日王赠送的一头大象，鸠摩罗王赠送的一件披肩；另外，为了沿途花费需要，他还收下了金钱三千、银钱一万。
    唐僧动身那天，戒日王、鸠摩罗王和其他一些国王，还有僧侣和百姓等等，都来送行，一时万人空巷，气氛极其热烈。唐僧用大象、马匹驮运他多年来访求收集到的佛经、佛像和中亚、南亚特产的奇花异果种子，满载着荣誉和中印人民的友谊，踏上了归途。
    送行的人们一直把唐僧送出城外好几十里路，才依依不舍地挥泪告别，戒日王再三祝愿唐僧归途平安，并写了一封信，命四名官员带上信件伴送唐僧，信中写明，要求沿路中、北印度各国，节节护送中国法师出境。
    唐僧刚到印度时，曾在北印度遇到强盗。他恐怕回去时再碰上意外，致使佛经等遭受损失，到了北印度一些不大安宁的地区，就派一名和尚先走一步，大声宣布：“后面来的法师，是从大唐到印度来取经的，现在回东土大唐去，携带的只是一些经典佛像，并无财物！”唐僧的名志早已响彻了五印度，这么喊过以后，他后来在路上虽也遇到过强盗，可是都不动掠他。
    当他们走到 叉尸罗国，横渡信度河时，船到中流，忽然刮起了大风，船身被波浪颠摇，五十夹经本和那些奇花异草的种子掉进了河里。这件事让唐僧心里不痛快了好多天。
    这时，迦毕试王正在渡口附近的乌铎迦汉荼城。他听说唐僧到了，连忙亲自走到河边迎接，一同回到城里。唐僧为了搜求失落的经文，在这里停留了五十多天；然后随同迦毕试王向西北行，途中又因迦毕试王举行无遮大会，耽搁了两个多月。
    从迦毕试国朝北走，是铁门关，再依当初西行的原路反方向前行，就可以到高昌国。但是唐僧在这里得到一个消息：就在他动身回国去的一年前，由于高昌伙同西突厥阻截“丝绸之路”，唐太宗已经举兵灭了高昌， 文泰则早在城破前就病死了。既然如此，也就用不着再走原路去高昌国践约了；不过铁门关，向东北行，翻越大雪山，路要近不少。
    翻越雪山又是一段艰难的历程。特别是山上，冰天雪地，随时有滑入深谷的危险；凛冽的寒风刺入肌骨，吹得身子都站不稳。他们好容易才走出雪山，又经过几个小国，到达葱岭。
    当唐僧一行到 盘陀国（今新疆塔什库尔干自治县）时，发现有强盗的踪迹，只好匆匆忙忙地登山躲避。结果，强盗倒是给避开了，戒日王送的大象却溺死在一条河里，象背上驮的一部分佛经也遭到了损失。
    他们费力地到了于阗。于阗王得到消息，特地在中处迎接，并殷勤地邀请唐僧住些日子，为僧人们讲经。唐僧也想派人到屈支、疏勒等国访求和补抄失去的经文，于是在一座佛寺里暂住下来。
    在于阗，唐僧回顾了一二十年来的经历，心想，当初自己是违反禁令冒险出国的，现在虽说已功成名就，可是，朝廷会谅解自己吗？他踌躇再三，最后，提笔写了封信，请于阗的商队带到长安，呈递给唐太宗。
    唐僧在信中写道，贞观元年秋天，他为了要深入研究佛学，寻求佛经，违反朝廷规定，冒险出关西行去印度。一路上经过浩浩的流沙、险峻的铁门、巍峨的雪山，跋涉了五万多里路程，经历了千万重险阻，才到达印度。在印度他拜师留学，周游各国，一面学习佛教经典，一面宣扬唐朝的文化。现在因为大象溺死，带回来许多经典，没有鞍乘可以运送，所以停留在于阗，等候朝廷的命令。
    没有多久，唐僧接到了唐太宗派人送来的亲笔信，信上说：
    “听说法师从国外归来，我非常高兴，但愿早日和法师相见。外国了解梵语和经义的和尚，也可以让他们同到中国来，我已命令于阗等地派人马护送法师，并要敦煌等处的地方官在途中迎接法师。”
    唐贞观十九年正月二十四日，唐僧平安到达长安，他回到阔别了将近二十年的祖国的都城。心里有说不出的高兴和喜悦。他出国时年方二十八岁，正是青壮年时代，等到返国，已是一个饱经风霜、头发斑白的半老和尚了。
    那时唐太宗正住在洛阳行宫，得知唐僧将到长安，就叫留守京城宰相记庇龄派人欢迎接待。长安市民听说唐僧快到长安，也都不约而同地聚集在城门外，想见一见这位了不起的高僧。由于城门口被群众拥挤得水泄不通，唐僧无法进城，只好在西门外住一宿。许多老百姓还不肯散去，竟然露宿等候。
    第二天，喜气笼罩着整个长安，人们熙熙攘攘、挨挨挤挤地伫立在大街两旁，等待着瞻仰这位满载着荣誉和中印友谊胜利归来的三藏法师。唐僧由官员赔同，骑着高头大马，手捧佛像，后面跟着驮经的马队，在万众的热烈欢迎中，缓缓进入了长安城。
    唐僧进城后，住在弘福寺。第二天，在长安最壮丽宏阔的朱雀大街南端，展览了他从印度用二十匹马驮回的一百五十粒佛舍利（相传是佛骨）、高三尺多的金佛像和高四尺多的银佛像，大小乘佛教的经典及因明、声明等经典六百多部，以及印度的帐舆旌旗和僧尼的袈裟法衣。从早到晚，长安城空中弥散着香烟的气息，街道上鲜花缤纷；朱雀大街人山人海，观众排成好几十里长的队伍，都为这位大法师不平凡的经历和丰富的收获啧啧称赞。
    二月间，唐太宗在洛阳召见了唐僧。他了解了唐僧冒险出关、艰难西行的经过。询问了往返途中所见所闻的风土人情。唐僧一一对答如流。唐太宗听了非常满意，请唐僧写一部传记，详细叙说西行的各种见闻。唐僧高兴地答应了。
    唐太宗见唐僧博学多才，就起了一个念头，劝说道：
    “法师有如此才学，何不还俗做官，辅助朝廷呢？”
    还俗就是不当和尚，这在唐僧是无论如何也不肯答应的。于是他再一次陈述了自己希望从事翻译佛经的心愿，并请求说：
    “嵩山的少林寺是南北朝菩提达摩三藏翻译佛经的地方。玄奘想去少林寺译经，以利于国家，还望陛下允准。”
    唐太宗想了想，说：“法师立志译经，也不必到少林寺去，弘福寺后有禅院，十分清静，法师不妨就在弘福寺内住下，译经所需要的一切，朝廷都会安排好的。”
    唐僧听了，高兴地向唐太宗行礼拜谢，不久就回长安去了。


十六、精心著译

    唐贞观十九年三月一日，唐僧回到长安弘福寺，开始组织大规模的翻译佛教经典的工作；当年五月中旬，正式开始著译。
    唐僧当年西行取经时，唐太宗和他的父亲唐高祖，是对佛教不感兴趣的，怎么他从印度回来，唐太宗就那么支持鼓励呢？
    这里面是有社会背景的。
    首先，唐太宗想消灭西突厥的割据政权，统一多民族的中国，并发展与中亚、南亚和西亚各国的友好往来。因此，他迫切需要了解西域广大地区的情况。
    其次，唐太宗也看到，佛教比道教更能吸引人，也就是更能欺骗麻痹人民。他要利用佛教巩固统治。
    正是为了满足唐太宗迫切需要了解西域情况的愿望，唐僧做的第一件一，就是休中精力写一本《大唐西域记》。
    经过一年多时间的努力，由唐僧口授，由他的学生辨机和尚执笔记录的《大唐西域记》全部完成了。
    《大唐西域记》一共十二卷，十多万字。它如实地记载了唐僧离开高昌国后的行迹，以及他在十七年旅行中所亲身经历的一百一十个国家和所传闻的二十八个国家的山川形势、地理位置、历史沿革、风土人情、宗教信仰、气候物产等等。这本书的文字生动流畅，使人看了好像身临其境一样。
    由于战火等原因，唐僧当曾经巡礼过的一些名胜，后来渐渐湮没。近代和现代的考古工作者，就依据他留下的这本《大唐西域记》，把王舍城的旧址、鹿野苑的古寺、阿 陀的石窟和那烂陀寺的遗迹，一一发掘出来。在那烂陀寺遗迹发掘出的文物中，有一幅珍贵的唐僧画像，描绘他赶路的神情；唐僧手执佛尘，脚蹬草鞋，背上负有一件竹制的架子，好像一张颠倒的、截去四只脚的靠背竹椅子。架子分好几层，里面大概是盛放衣物、铺盖和书籍的；最上面是一把张开的伞，可以遮雨挡阳；前方还有一盏吊下的油灯，以便黑夜里行走照亮道路。
    《大唐西域记》写成后，唐僧把它连同另外二十多部已经译好的指经，一起呈送给唐太宗。唐太宗亲自回信说：“别的书可以不看，只有这本《大唐西域记》是非看不可的。我一定要仔细阅读！”
    从唐太宗这几句话中，也可以看出唐僧这本著作是多么重要，多么有意义了。
    唐僧在写《大唐西域记》的同时，还邀请全国各地高僧、学者，组成了翻译机构，弘福寺成了规模庞大的翻译佛教经籍的中心。
    翻译一般说来是很难代替原作的，要使翻译出的本子既忠实于原作又恰到好处，实在是件不容易的事。但唐僧不仅精通汉训，而且精通梵文梵语，同时对佛教也极有研究，这是一般翻译佛经的人所没有的条件。更重要的是，他的翻译态度十分严谨，总是先把原文读熟嚼烂了，弄通了原文，然后才动笔；译成后，总是反复核对，推敲，润色，使译文流畅而明白。
    唐贞观二十二年十一月，皇太子李治为纪念他母亲而建造的慈恩寺少成了，邀请唐僧到那里去做主持法师，并在慈恩寺内的“翻经院”继续进行译经工作。
    这时，唐僧唯恐自己的生命有限，来不及译完带回的佛经就死去，于是夜以继日地工作，不肯虚耗半点光阴。他通常总是五更时分就起身，把当天所要翻译的佛经诵读一遍，并用红笔加以圈点；白天，他和大家一起翻译，除了吃饭，可以说一刻也不停息；黄昏和晚上要为寺内僧人讲经，并接待从各地来向他请教的和尚和学者，直到深废三更才能就寝。
    为了珍藏从印度带回来的佛像，佛舍利和几百部佛教经籍，唐永徽三年（公元652年），唐僧向已经当上了皇帝的李治（即唐高宗）递上奏折，要求在慈恩寺西院建造宝塔，得到了恩准。
    从动工那天起，参加这一工程的工匠和和尚们，常常看到一个五十多岁的法师，同大家一起挑土搬砖，他就是唐僧。别人劝他说：“您年纪那么大了，身体又不好，还有那么繁重的译经工作，这儿的活就让我们干吧。”可是唐僧却回答说：“我挑砖运土，是尽自己一点心意。再说我又没像你们那样从早干到晚，累不着的！”
    不久，宝塔建成了，称做大雁塔。大雁塔的塔基四面各一百四十尺，共五层，高一百八十尺。后来，因战火毁损等原因，曾几次重建，现在留下的大雁塔有七层，高一百九十二尺。唐显庆四年（公元659年），唐高宗请唐僧迁进玉华寺，继续进行译经工作。
    由于唐僧少年时代用功过度，西行取经又备受风寒艰辛，加上连年翻译工作的伤神劳累，健康受到很大损害。他患着一种心胸时常发痛和怕冷的病；尤其在他生命的最后三年，几乎全靠服药来维持。但是，尽管这样，这位从来不畏艰难的老人，还是以顽强的毅力，译完了一部长达六百卷、二十万颂的佛学巨著《大般若经》。
    唐僧不懈地进行了十九年的翻译工作，直到生命垂危。在由他领导的翻译工作机构的协助下，一共译出佛经七十四部、一千三百二十三卷，计一千三百多万字。（不包括《大唐西域记》在内）这么浩瀚的卷帙，就是在数量上，也是很惊人的了。
    唐高宗麟德元年，（公元664年）正月初一，六十五岁的唐僧就是在这新春佳节，也不肯休息。他一手按住阵阵绞痛的心胸，一手提笔翻译《大宝积经》，可是才写了几行，就实在支持不住了，只好把笔搁下，从此卧床不起。到二月初五的半夜，这位一生不肯向困难低头的佛教学者、翻译家、旅行家，对中印学术文化交流做出贡献的唐僧，就在玉华寺逝世了。
    唐高宗听到唐僧逝世的消息，仰天长叹说：“僧人失去了导师，佛门失去了栋梁，国家失去了瑰宝！”
    当年四月十四日，朝廷在长安城东的白鹿原，为唐僧举行了隆重的安葬仪式。这一天，方圆五百里有一百多万人来为他送葬；夜里，有三万多人露宿在他的墓旁。五年后，唐高宗将唐僧火化后的遗骨，迁葬到樊州（今陕西西安南），并在那里为他建立了佛塔和庙宇。后来，由于佛塔损毁，遗骨渐渐散失，现在只有一小部分保存在南京市博物馆里。但是，这位伟人的名字却永远铭记在人们的心中！