首页

王维咏佛诗文集

［唐］王维 著 [image] 清凉书屋辑

·2003.12·


前言: 禅悦的诗人王维

禅悦的诗人王维

    王维是盛唐时代著名的诗人，字摩诘，生于武后圣历二年（699），一说长安元年（701），先世为太原祁（今山西祁县）人，其父官至汾州司马，迁居于浦（今山西永济县），遂为河东人。他的《相思》诗：“红豆生南国，秋来发几枝。劝君多采撷，此物最相思。”千百年来脍炙人口。而《九月九日忆山东兄弟》诗：“独在异乡为异客，每逢佳节倍思亲。遥知兄弟登高处，遍插茱萸少一人。”《送元二使安西》诗：“渭城朝雨浥轻尘，客舍青青柳色新。劝君更尽一杯酒，西出阳关无故人。”更为传诵不衰的名篇。王维才华卓异，他不仅写下诸多绝妙的诗句，还善于属文、作画，同时对音乐也十分精通，他于开元九年（721）进士及第，在朝廷里所担任的第一个官职就是大乐丞。
    王维“以般若力，生菩提家”（《赞佛文》），其全家人均虔信佛法，茹素戒杀。王维的名字本身就深含禅机，他名维，字摩诘，连读恰为“维摩诘”。稍通佛学的人，都会知道有一部《维摩诘所说经》，其中通达甚深般若智慧，神通广大的维摩诘长者，是一位得到释尊称许的大居士。又此经专说般若，是禅宗的根本经典之一。王维既以维摩诘作为自己的名与字，可以观见他对其人的仰慕之情，又可透露出他与佛教、尤其是与禅宗的深厚缘分。王维一生遍访名僧大德，“以玄谈为乐”，颇有所证悟。据《神会语录》载，神会居南阳时，王维曾以修道解脱之事相询，神会答曰：“众生本自心净，若更欲起心有修，即是妄心，不可得解脱。”不假方便，直指心性妙圆。王维听后很是吃惊，叹言：“大奇！”并说：“曾闻大德，皆未有作如此说。”便与神会禅师“语经数日”，反复参究，深膺其旨，叹曰：“此南阳郡，有好大德，有佛法甚不可思议！”后来王维受神会之托，作《六祖能禅师碑铭》，极力称扬六祖大师：“世之至人，有证于此，得无漏不尽漏，度有为非无为者，其唯我曹溪禅师乎！”《碑铭》中还谈到神会北上传法，因“世人未识”，遭受波折，“尤多抱玉之悲”的无奈，及“谓余知道，以颂见托”的缘起。由此可以观见王维之于禅宗已独膺曹溪顿悟之旨，且妙解契道，颇得神会之认许。他因受荷泽神会禅师所托，作《六祖能禅师碑铭》，成为后来研究禅宗史的重要史料。
    苏轼在《东坡志林》中说：“味摩诘之诗，诗中有画；观摩诘之画，画中有诗。”对王维的诗艺意境作了很好的总结。王维的诗作受到禅宗思想很深的影响，他的山水诗和酬赠诗中往往包含深远的禅意，此外还有大量以佛教修行为主题的咏禅诗。王维诗中最爱用“静”“澹”“远”“闲”一类字样，还有“禅”“寂”“空”“无生”等佛家用语，他能够用静定从容的闲适心情，去观察大自然，抒写于笔端，作成绝佳的诗句。王维在诗艺上的成就，其很大程度上得益于他对于禅理的玩味与修习。正是由于他常以一位禅者的目光览观万物，才使他的诗有了一种其他诗人所难以企及的静美、澄旷、寂悦。特别是他在描写大自然中一刹那间的纷纭动象，是那样的清净与静谧，禅韵盎然，如：“人闲桂花落，夜静春山空。月出惊飞鸟，时鸣春涧中。”（《鸟鸣磵》）“飒飒秋雨中，浅浅石榴泻。跳波自相溅，白鹭惊复下。”（《栾家濑》）以及名句“明月松间照，清泉石上流”（《山居秋暝》）等，往往荡涤读者之胸襟，给人以恬澹宁和的无尽遐思。
    王维早年诗作《春日上方即事》有“好读高僧传，时看辟谷方”，及“北窗桃李下，闲坐但焚香”的诗句，其向道之心油然。他所交游的僧人为数甚多，记于他的诗文之中的就有道光禅师、璿上人、道一禅师、瑗公上人及北上传法的六祖门下神会禅师等十余僧，且几乎均为禅僧。与他关系密切的居士则有胡居士、萧居士、魏居士等，也都以禅法自娱。对于潜心向佛的诗人王维来说，对方外高人的参访及与意气相投的道友们的共修，自然而然地成为他日常生活的重要部分，尤其是他隐居生涯的主要内容，这些情形也都反映在他的诗作中。如《山中寄诸弟妹》诗：“山中多法侣，禅诵自为群。城郭遥相望，唯应见白云。”是讲他在山中与一班道友结缘共修时的欣悦之情。《期游方丈寺》诗：“共仰头陀行，能忘世谛情。”表达他对佛家出世之道和励节苦行精神的仰慕。《投道一师兰若宿》诗有“鸟来还语法，客去更安禅”的佳句和表明自己心迹的“岂唯留暂宿，服事将穷年”的直白。《蓝田山石门精舍》描写他所亲见的寺僧日常生活：“老僧四五人，逍遥荫松柏。朝梵林未曙，夜禅山更寂。”令人欣然神往。他还有于“草木尽焦卷，川泽皆竭涸”的炎炎夏日，靠修持功夫，万缘放下，“忽入甘露门，宛然清凉乐”的禅修体验（《苦热》）。到他晚年，更有“龙钟一老翁，徐步谒禅宫”的自我写照和“山河天眼里，世界法身中”的甚深证悟（《夏日过青龙寺谒操禅师》）。至于他的描述禅门修持功夫的诗句：“薄暮空潭曲，安禅制毒龙”（《过香积寺》），是讲禅门行者以戒定之功、般若智慧之力，降服心中的贪、瞋、痴三毒和由此而起的种种妄想迷惑颠倒，独标禅门修行之宗要，是王维咏禅诗中的名句。
    佛教主张众生平等，恩德布施八方上下，深大无量，不可胜言。而慈心不杀，严格茹素，更是大乘佛法的必然要求，也是汉传佛教的一贯传统。王维生于素食之家，他的母亲崔氏在他很小的时候就开始带发修行，并因同乡的关系，师事一代名僧大照（《宋高僧传》记为大慧）普寂禅师30余年，一生“褐衣蔬食，持戒安禅”（《请施庄为寺表》），对事母至孝的王维产生了莫大的影响。激发王维山水诗创作灵感，环境极为幽静的蓝田辋川山居（即辋川别业），就是他为了方便自己母亲宴坐经行修道之用而购置、营建的。他的弟弟王缙，《新唐书》记其“素奉佛，不茹荤食肉，晚节尤谨”，甚至劝说代宗皇帝李豫信佛。王维自己也是常年素食，到晚岁就更加严格，《旧唐书》说他“斋中无所有，唯茶铛、药臼、经案、绳床而已。”素食生活的淡安与平和，在王维的笔下，更是多了几分舒惬的雅韵和审美的意味。王维说：“君子以布仁施义，活国济人为适意”，“纵其道不行”，其行为也决不背离本衷。他由衷地赞扬德人达士：“虽方丈盈前，而蔬食菜羹；虽高门甲第，而毕竟空寂。人莫不相爱，而观身如聚沫；人莫不自厚，而视财若浮云。”（《与魏居士书》）和“比布衣以同年，甘蔬食而没齿”（《为人祭李舍人文》）的高贵品格与闲淡旷达的胸襟。他在《谒璿上人》一诗中写有“誓从断荤血，不复婴世网”的诗句，决心谨遵佛法教敕、上人风训，茹素戒杀，勤求出世解脱之道。他说：“设罝守毚兔，垂钓伺游鳞，此是安口腹，非关慕隐沦。吾生好清净，蔬食去情尘。”（《戏赠张五弟諲三首》）对那些虽然也有兴致尝试过退隐的生活，但却因口腹之欲而捕兔钓鱼的行为表示不满，他标明自己与众不同的素食追求，赞扬蔬食可以养护人的慈柔清净的志趣，可以有益于澹泊物欲，怡性安神。他还称赞在家居士“药藉茹荤，虽愈疾而不受”的严明自律（《京兆王氏墓志铭》）。他的诗句：“悲哉世上人，甘此膻腥食。”（《赠李颀》）对于世人受口腹之欲的盲目驱使，不惜杀生害命，迭相吞噉的不幸事实表示了深切的悲悯。
    在王维的诗文中，常年的素食生活并没有使他感到丝毫的清苦，相反却使诗人的情思更加的欣悦润泽。请看他的《游感化寺》诗：“抖擞辞贫里，归依宿化城。绕篱生野蕨，空馆发山樱。香饭青菰米，佳蔬绿芋羹。誓陪清梵末，端坐学无生。”一碗青菰米，一钵绿芋羹，在他眼里竟是那样的色香味美。而诗句：“山中习静观朝槿，松下清斋折露葵。”（《积雨辋川庄作》）描写简朴自然的素食生活，竟也有了几分超然出尘的余韵。王维的素食选择是与他对人生终极目标的追求紧密相关的，他相信仁德博厚可以感动天地万物，宇宙苍生本来可以各得其所，相敬相和。在《大唐大安国寺故大德净觉禅师碑铭》有这样的名句：“猛虎舐足，毒蛇熏体；山神献果，天女献花。澹尔宴安，曾无喜惧。”称赞净觉禅师德业纯厚，感动天人，兼及禽兽，无不倾心向善。他的《戏赠张五弟諲三首》诗中，还有这样的怡人诗章：“我家南山下，动息自遗身。入鸟不相乱，见兽皆相亲。”以及“青苔石上净，细草松下软。窗外鸟声闲，阶前虎心善。”人在大自然中，原来是可以那样的物我相亲，任运自在，一幅人与自然万物泯然无间、尽善尽美的和谐画卷，尽收眼底，感人至深。
    王维不仅栖心于禅门之参究，也曾留意于摄机最广的净土法门，留下了一些非常珍贵的称赞净土的文字。如他阐释十念往生之理：“《易》曰：‘游魂为变。’《传》曰：‘魂气则无不之。’固知神明更生矣。辅之以道，则变为妙身，之于乐土。”（《画西方阿弥陀变赞》）称赞仰仗他力的净土法门：“究竟达于无生，因地从于有相”，是大雄世尊“以不思议力，开方便门”（《西方变画赞》）。他还称赞西方极乐世界的超世希有：“法王安详，圣众围绕。湛然不动，疑过于往来；寂尔无闻，若离于言说。林分宝树，七重绕于香城；衣捧天花，六时散于金地。迦陵欲语，曼陀未落。众善普会，诸相具美。”（同上）他在《绣如意轮像赞》中以诗偈称赞观世音大士：“菩萨神力不思议，能以一身遍一切。常转法轮无所转，众生随念得解脱。”而在《西方变画赞》中更以诗偈极赞十方如来和净土导师，其偈曰：“稽首十方大导师，能以一法见多法。以种种相导群生，其心本来无所动。稽首无边法性海，功德无量不思议。于已不色等无碍，不住有无亦不舍。我今深达真实空，知此色相体清净。愿以西方为导首，往生极乐性自在。”由此也可看到除禅宗外，净土一法在唐代上流社会中的流行盛况。
    王维才思绝妙超群，品格也极为高贵，在史书中更以笃诚奉佛而著称。王维事母至孝，其母去世后，他“柴毁骨立，殆不胜丧。”他的妻子去世很早，大约在王维三十来岁的时候，其妻便不幸亡故了，他从此终身独处，史称“妻亡不再娶，三十年孤居一室，屏绝尘累。”（《旧唐书·王维传》）甚是希有。经历了安史之乱的惨痛遭遇，晚年的他更是苦行斋心，“不衣文彩”，除饭僧施粥外，“退朝之后，焚香独坐，以禅诵为事。”（同上）他还曾向皇帝上表，将自己最为钟爱的辋川山庄施作僧寺，供抽选出来的“名行僧”“精勤禅诵，斋戒住持”之用（《请施庄为寺表》）。他还不止一次上状，恳求朝廷允许自己将所得的职田献出，作为周济穷苦、布施粥饭之用。读王维的《谢除太子中允表》和《责躬荐弟表》，可知安史之乱时他被拘反贼之中，曾一度想出家修道。有两首诗最能表现他晚境的心迹，一首是《叹白发》：“宿昔朱颜成暮齿，须臾白发变垂髫。一生几许伤心事，不向空门何处销。”另一首是《秋夜独坐》：“独坐悲双鬓，空堂欲二更。雨中山果落，灯下草虫鸣。白发终难变，黄金不可成。欲知除老病，唯有学无生。”可以说是万缘放下，唯以佛法自励，在诗句中表现得十分充分。王维的临终最后一着，也是颇有意味。《旧唐书·王维传》云：“临终之际，以缙在凤翔，忽索笔作别缙书。又与平生亲故作别书数幅，多敦厉朋友奉佛修心之旨，舍笔而卒。”临终正念分明，又甚从容，可证他平素修持之功确实非比寻常，令人赞叹。
    谛观王维诗文，见其于佛家名相精审明辨，于第一义谛知解圆妙，曾有“心王自在，万有皆如；顶法真空，一乘不立”的妙语（《西方变画赞》）。又能理事圆融，称扬净土。晚年万缘放下，唯以佛法自励。临终一着，更是正念分明。其一生与佛教的殊胜因缘及对于佛学义理、特别是禅学的深究亲行，可称是一代诗人中之绝唱。


古　诗

蓝田山石门精舍

落日山水好，漾舟信归风。
玩奇不觉远，因以缘源穷。
遥爱云木秀，初疑路不同。
安知清流转，偶与前山通。
舍舟理轻策，果然惬所适。
老僧四五人，逍遥荫松柏。
朝梵林未曙，夜禅山更寂。
道心及牧童，世事问樵客。
暝宿长林下，焚香卧瑶席。
涧芳袭人衣，山月映石壁。
再寻畏迷误，明发更登历。
笑谢桃源人，花红复来觌。

饭覆釜山僧

晚知清净理，日与人群疏。
将候远山僧，先期扫敝庐。
果从云峰里，顾我蓬蒿居。
藉草饭松屑，焚香看道书。
燃灯昼欲尽，鸣磬夜方初。
已悟寂为乐，此生闲有余。
思归何必深，身世犹空虚！

谒璿上人（并序）

    上人外人内天，不定不乱。舍法而渊泊，无心而云动。色空无得，不物物也。默语无际，不言言也。故吾徒得神交焉，玄关大启，德海群泳。时雨既降，春物俱美。序于诗者，人百其言。

少年不足言，识道年已长。
事往安可悔，余生幸能养。
誓从断荤血，不复婴世网。
浮名寄缨佩，空性无羁鞅。
夙从大导师，焚香此瞻仰。
颓然居一室，覆载纷万象。
高柳早莺啼，长廊春雨响。
床下阮家屐，窗前筇竹杖。
方将见身云，陋彼示天壤。
一心在法要，愿以无生奖。

燕子龛禅师

山中燕子龛，路剧羊肠恶。
裂地竞盘屈，插天多峭崿。
瀑泉吼而喷，怪石看欲落。
伯禹访未知，五丁愁不凿。
上人无生缘，生长居紫阁。
六时自捶磬，一饮尚带索。
种田烧白云，斫漆响丹壑。
行随拾栗猿，归对巢松鹤。
时许山神请，偶逢洞仙博。
救世多慈悲，即心无行作。
周商倦积阻，蜀物多淹泊。
岩腹乍旁穿，涧唇时外拓。
桥因倒树架，栅值垂藤缚。
鸟道悉已平，龙宫为之涸。
跳波谁揭厉，绝壁免扪摸。
山木日阴阴，结跏归旧林。
一向石门里，任君春草深！

寄崇梵僧

崇梵僧，崇梵僧，秋归覆釜春不还。
落花啼鸟纷纷乱，涧护山窗寂寂闲。
峡里谁知有人事，郡中遥望空云山。

留别山中温古上人兄并示舍弟缙

解薜登天朝，去师偶时哲。
岂唯山中人，兼负松上月。
宿昔同游止，致身云霞末。
开轩临颍阳，卧视飞鸟没。
好依盘石饭，屡对瀑泉歇。
理齐少狎隐，道胜宁外物。
舍弟官崇高，宗兄此削发。
荆扉但洒扫，乘闲当过拂。

胡居士卧病遗米因赠

了观四大因，根性何所有？
妄计苟不生，是身孰休咎？
色声何谓客？阴界复谁守？
徒言莲花目，岂恶杨枝肘？
既饱香积饭，不醉声闻酒。
有无断常见，生灭幻梦受。
即病即实相，趋空定狂走。
无有一法真，无有一法垢。
居士素通达，随宜善抖擞。
床上无毡卧，镉中有粥否？
斋时不乞食，定应空漱口。
聊持数斗米，且救浮生取。

与胡居士皆病，寄此诗，兼示学人（二首）

一兴微尘念，横有朝露身。
如是睹阴界，何方置我人。
碍有固为主，趣空宁舍宾？
洗心讵悬解，悟道正迷津。
因爱果生病，从贪始觉贫。
色声非彼妄，浮幻即吾真。
四达竟何遣，万殊安可尘？
胡生但高枕，寂寞与谁邻？
战胜不谋食，理齐甘负薪。
子若未始异，讵论疏与亲！

浮空徒漫漫，泛有定悠悠。
无乘及乘者，所谓智人舟。
讵舍贫病域，不疲生死流。
无烦君喻马，任以我为牛。
植福祠迦叶，求仁笑孔丘。
何津不鼓棹，何路不摧辀？
念此闻思者，胡为多阻修？
空虚花聚散，烦恼树稀稠。
灭想成无记，生心坐有求。
降吴复归蜀，不到莫相尤。

酬黎居士淅川作

侬家真个去，公定随侬否？
着处是莲花，无心变杨柳。
松龛藏药裹，石唇安茶臼。
气味当共知，哪能不携手！

过李楫宅

闲门秋草色，终日无车马。
客来深巷中，犬吠寒林下。
散发时未簪，道书行尚把。
与我同心人，乐道安贫者。
一罢宜城酌，还归洛阳社。

同比部杨员外十五夜游，有怀静者季

承明少休沐，建礼省文书。
夜漏行人息，归鞍落日余。
岂知三五夕，万户千门辟。
夜出曙翻归，倾城满南陌。
陌头驰骋尽繁华，王孙公子五侯家。
由来月明如白日，共道春灯胜百花。
聊看侍中千宝骑，强识小妇七香车。
香车宝马共喧阗，个里多情侠少年。
竞向长杨柳市北，肯过精舍竹林前。
独有仙郎心寂寞，却将宴坐为行乐。
倘觅忘怀共往来，幸沾同舍甘藜藿。

哭殷遥

人生能几何，毕竟归无形。
念君等为死，万事伤人情。
慈母未及葬，一女才十龄。
泱漭寒郊外，萧条闻哭声。
浮云为苍茫，飞鸟不能鸣。
行人何寂寞，白日自凄清。
忆昔君在时，问我学无生。
劝君苦不早，令君无所成。
故人各有赠，又不及生平。
负尔非一途，痛哭返柴荆。

附：储光羲《同王十三维哭殷遥》

生理无不尽，念君在中年。
游道虽未深，举世莫能贤。
筮仕苦贫贱，为客少田园。
膏腴不可求，乃在许西偏。
四邻尽桑柘，咫步开墙垣。
内艰未及虞，形影随化迁。
茅茨俯苫盖，双殡两楹间。
时闻孤女号，迥出陌与阡。
慈乌乱飞鸣，猛兽亦以跧。
故人王夫子，静念无生篇。
哀乐久已绝，闻之将泫然。
太阳蔽空虚，雨雪浮苍山。
迢递亲灵榇，顾予悲绝弦。
处顺与安时，及此乃空言。

赠从弟司库员外絿

少年识事浅，强学干名利。
徒闻跃马年，苦无出人智。
即事岂徒言，累官非不试。
既寡遂性欢，恐招负时累。
清冬见远山，积雪凝苍翠。
浩然出东林，发我遗世意。
惠连素清赏，夙语尘外事。
欲缓携手期，流年一何驶！

赠房卢氏琯

达人无不可，忘己爱苍生。
岂复小千室，弦歌在两楹。
浮人日已归，但坐事农耕。
桑榆郁相望，邑里多鸡鸣。
秋山一何净，苍翠临寒城。
视事兼偃卧，对书不簪缨。
萧条人吏疏，鸟雀下空庭。
鄙夫心所向，晚节异平生。
将从海岳居，守静解天刑。
或可累安邑，茅茨君试营。

戏赠张五弟諲（三首）

吾弟东山时，心尚一何远。
日高犹自卧，钟动始能饭。
领上发未梳，床头书不卷。
清川兴悠悠，空林对偃蹇。
青苔石上净，细草松下软。
窗外鸟声闲，阶前虎心善。
徒然万象多，澹尔太虚缅。
一知与物平，自顾为人浅。
对君忽自得，浮念不烦遣。

张弟五车书，读书仍隐居。
染翰过草圣，赋诗轻《子虚》。
闭门二室下，隐居十年余。
宛是野人野，时从渔父渔。
秋风日萧索，五柳高且疏。
望此去人世，渡水向吾庐。
岁晏同携手，只应君与予。

设罝守毚兔，垂钓伺游鳞。
此是安口腹，非关慕隐沦。
吾生好清静，蔬食去情尘。
今子方豪荡，思为鼎食人。
我家南山下，动息自遗身。
入鸟不相乱，见兽皆相亲。
云霞成伴侣，虚白侍衣巾。
何事须夫子，邀予谷口真。

偶然作（六首）

楚国有狂夫，茫然无心想。
散发不冠带，行歌南陌上。
孔丘与之言，仁义莫能奖。
未尝肯问天，何事须击壤？
复笑采薇人，胡为乃长往！

田舍有老翁，垂白衡门里。
有时农事闲，斗酒呼邻里。
喧聒茅檐下，或坐或复起。
短褐不为薄，园葵固足美。
动则长子孙，不曾向城市。
五帝与三王，古来称天子。
干戈将揖让，毕竟何者是？
得意苟为乐，野田安足鄙！
且当放怀去，行行没余齿。

日夕见太行，沉吟未能去。
问君何以然？世网婴我故。
小妹日成长，兄弟未有娶。
家贫禄既薄，储蓄非有素。
几回欲奋飞，踟蹰复相顾。
孙登长啸台，松竹有遗处。
相去讵几许，故人在中路。
爱染日已薄，禅寂日已固。
忽乎吾将行，宁俟岁云暮。

陶潜任天真，其性颇耽酒。
自从弃官来，家贫不能有。
九月九日时，菊花空满手。
中心窃自思，倘有人送否？
白衣携壶觞，果来遗老叟。
且喜得斟酌，安问升与斗。
奋衣野田中，今日嗟无负。
兀傲迷东西，蓑笠不能守。
倾倒强行行，酣歌归五柳。
生事不曾问，肯愧家中妇。

赵女弹箜篌，复能邯郸舞。
夫婿轻薄儿，斗鸡事齐主。
黄金买歌笑，用钱不复数。
许史相经过，高门盈四牡。
客舍有儒生，昂藏出邹鲁。
读书三十年，腰下无尺组。
被服圣人教，一生自穷苦。

老来懒赋诗，唯有老相随。
宿世谬词客，前身应画师。
不能舍余习，偶被世人知。
名字本皆是，此心还不知！

苦 热

赤日满天地，火云成山岳。
草木尽焦卷，川泽皆竭涸。
轻纨觉衣重，密树苦阴薄。
莞簟不可近，絺绤再三濯。
思出宇宙外，旷然在寥廓。
长风万里来，江海荡烦浊。
却顾身为患，始知心未觉。
忽入甘露门，宛然清凉乐。

终南别业

中岁颇好道，晚家南山陲。
兴来每独往，胜事空自知。
行到水穷处，坐看云起时。
偶然值林叟，谈笑无还期。

叹白发

我年一何长，鬓发日已白。
俯仰天地间，能为几时客？
怅惆故山云，徘徊空日夕。
何事与时人，东城复南陌。


近 体 诗

春日上方即事

好读高僧传，时看辟谷方。
鸠形将刻杖，龟壳用支床。
柳色春山映，梨花夕鸟藏。
北窗桃李下，闲坐但焚香。

山中示弟等

山林吾丧我，冠带尔成人。
莫学嵇康懒，且安原宪贫。
山阴多北户，泉水在东邻。
缘合妄相有，性空无所亲。
安知广成子，不是老夫身！

山中寄诸弟妹

山中多法侣，禅诵自为群。
城郭遥相望，唯应见白云。

口号又示裴迪

安得舍尘网，拂衣辞世喧。
悠然策藜杖，归向桃花源。

过福禅师兰若

岩壑转微径，云林隐法堂。
羽人飞奏乐，天女跪焚香。
竹外峰偏曙，藤阴水更凉。
欲知禅坐久，行路长春芳。

过感化寺昙兴上人山院

暮持筇竹杖，相待虎溪头。
催客闻山响，归房逐水流。
野花丛发好，谷鸟一声幽。
夜坐空林寂，松风直似秋。

附：裴迪《同咏》

不远灞陵边，安居向十年。
入门穿竹径，留客听山泉。
鸟啭深林里，心闲落照前。
浮名竟何益，从此愿栖禅。

夏日过青龙寺谒操蝉师

龙钟一老翁，徐步谒禅宫。
欲问义心义，遥知空病空。
山河天眼里，世界法身中。
莫怪销炎热，能生大地风。

附：裴迪《同咏》

安禅一室内，左右竹亭幽。
有法知不染，无言谁敢酬？
鸟飞争向夕，蝉噪已先秋。
烦暑自兹退，清凉何所求！

过香积寺

不知香积寺，数里入云峰。
古木无人径，深山何处钟。
泉声咽危石，日色冷青松。
薄暮空潭曲，安禅制毒龙。

登辨觉寺

竹径从初地，莲峰出化城。
窗中三楚尽，林上九江平。
软草承趺坐，长松响梵声。
空居法云外，观世得无生。

投道一师兰若宿

一公栖太白，高顶出云烟。
梵流诸壑遍，花雨一峰偏。
迹为无心隐，名因立教传。
鸟来还语法，客去更安禅。
昼涉松露尽，暮投兰若边。
洞房隐深竹，清夜闻遥泉。
向是云霞里，今成枕席前。
岂唯留暂宿，服事将穷年。

过庐员外宅看饭僧共题

三贤异七圣，青眼慕青莲。
乞饭从香积，裁衣学水田。
上人飞锡杖，檀越施金钱。
趺坐檐前日，焚香竹下烟。
寒空法云地，秋色净居天。
身逐因缘法，心过次第禅。
不须愁日暮，自有一灯燃。

青龙寺昙壁上人兄院集（并序）

    吾兄大开荫中，明彻物外。以定力胜敌，以惠用解脱。深居僧坊，傍俯人里。高原陆地，下映芙蓉之池。竹林果园，中秀菩提之树。八极氛霁，万汇尘息。太虚寥廓，南山为之端倪。皇州苍茫，渭水贯于天地。经行之后，趺坐而闲。升堂梵筵，饵客香饭。不起而游览，不风而清凉。得世界于莲花，记文章于贝叶。时江宁大兄持片石命维序之。诗五韵，坐上成。

高处敞招提，虚空讵有倪？
坐看南陌骑，下听秦城鸡。
渺渺孤烟起，芊芊远树齐。
青山万井外，落日五陵西。
眼界今无染，心空安可迷。

附：王昌龄《同咏》

本来清净所，竹树引幽阴。
檐外含山翠，人间出世心。
圆通无有象，圣境不能侵。
真是吾兄法，何妨友弟深。
天香自然会，灵异识钟音。

附：王缙《同咏》

林中空寂舍，阶下终南山。
高卧一床上，回看六合间。
浮云几处灭，飞鸟何时还？
问义天人接，无心世界闲。
谁知大隐客，兄弟自追攀。

附：裴迪《同咏》

灵境信为绝，法堂出尘氛。
自然成高致，向下看浮云。
逶迤峰岫列，参差闾井分。
林端远堞见，风末疏钟闻。
吾师久禅寂，在世超人群。

游感化寺

翡翠香烟合，琉璃宝地平。
龙宫连栋宇，虎穴傍檐楹。
谷静唯松响，山深无鸟声。
琼峰当户拆，金涧透林鸣。
郢路云端迥，秦川雨外晴。
雁王衔果献，鹿女踏花行。
抖擞辞贫里，归依宿化城。
绕篱生野蕨，空馆发山樱。
香饭青菰米，嘉蔬绿芋羹。
誓陪清梵末，端坐学无生。

游悟真寺

闻道黄金地，仍开白玉田。
掷山移巨石，咒岭出飞泉。
猛虎同三径，愁猿学四禅。
买香燃绿桂，乞火踏红莲。
草色摇霞上，松声泛月边。
山河穷百二，世界满三千。
梵宇聊凭视，王城遂渺然。
霸陵才出树，渭水欲连天。
远县分诸郭，孤村起白烟。
望云思圣主，披雾忆群贤。
薄宦惭尸素，终身拟尚玄。
谁知草庵客，曾和柏梁篇。

与苏、卢二员外期游方丈寺，而苏不至，因有是作

共仰头陀行，能忘世谛情。
回看双凤阙，相去一牛鸣。
法向空林说，心随宝地平。
手巾花氎净，香帔稻畦成。
闻道邀同舍，相期宿化城。
安知不来往，翻以得无生。

过乘如禅师、萧居士嵩邱兰若

无著天亲弟与兄，嵩邱兰若一峰晴。
食随鸣磬巢乌下，行踏空林落叶声。
迸水定侵香案湿，雨花应共石床平。
深洞长松何所有，俨然天竺古先生。

同崔兴宗送瑗公

言从石菌阁，新下穆陵关。
独向池阳去，白云留故山。
绽衣秋日里，洗钵古松间。
一施传心法，唯将戒定还。

附：崔兴宗《同咏》

行苦神亦秀，泠然溪上松。
铜瓶与竹杖，来自祝融峰。
常愿入灵岳，藏经访遗踪。
南归见长老，且为说心胸。

与庐员外象过崔处士兴宗林亭

绿树重阴盖四邻，青苔日厚自无尘。
科头箕踞长松下，白眼看他世上人。

苑舍人能书梵字，兼达梵音，皆曲尽其妙，戏为之赠

名儒待诏满公车，才子为郎典石渠。
莲花法藏心悬悟，贝叶经文手自书。
楚辞共许胜扬马，梵字何人辨鲁鱼。
故旧相望在三事，愿君莫厌承明庐。

附：苑咸《答诗（并序）》

    王员外兄以予尝学天竺书，有戏题见赠。然王兄当代诗匠，又精禅理，枉采知音，形于雅作。辄走笔以酬焉，且久未迁，因而嘲及。

莲花梵字本从天，华省仙郎早悟禅。
三点成伊犹有想，一观如幻自忘荃。
为文已变当时体，入用还推间气贤。
应同罗汉无名欲，故作冯唐老岁年。

重酬苑郎中（并序）

    顷辄奉赠，忽枉见酬。叙末云：“且久不迁，因而嘲及。”诗落句云：“应同罗汉无名欲，故作冯唐老岁年。”亦解嘲之类也。

何幸含香奉至尊，多惭未报主人恩。
草木岂能酬雨露，荣枯安敢问乾坤？
仙郎有意怜同舍，丞相无私断扫门。
扬子解嘲徒自遣，冯唐已老复何论！

冬晚对雪忆胡居士家

寒更传晓箭，清镜览衰颜。
隔牖风惊竹，开门雪满山。
洒空深巷静，积素广庭闲。
借问袁安舍，翛然尚闭关？

过沈居士山居哭之

杨朱来此哭，桑扈返于真。
独自成千古，依然旧四邻。
闲檐暄鸟雀，故榻满埃尘。
曙月孤莺啭，空山五柳春。
野花愁对客，泉水咽迎人。
善卷明时隐，黔娄在日贫。
逝川嗟尔命，邱井叹吾身。
前后徒言隔，相悲讵几晨！

酬张少府

晚年唯好静，万事不关心。
自顾无长策，空知返旧林。
松风吹解带，山月照弹琴。
君问穷通理，渔歌入浦深！

辋川别业

不到东山向一年，归来才及种春田。
雨中草色率堪染，水上桃花红欲燃。
优娄比丘经论学，伛偻丈人乡里贤。
披衣倒屣且相见，相欢语笑衡门前。

积雨辋川庄作

积雨空林烟火迟，蒸藜炊黍饷东菑。
漠漠水田飞白鹭，阴阴夏木啭黄鹂。
山中习静观朝槿，松下清斋折露葵。
野老与人争席罢，海鸥何事更相疑。

归辋川作

谷口疏钟动，渔樵稍欲稀。
悠然远山暮，独向白云归。
菱蔓弱难定，杨花轻易飞。
东皋春草色，惆怅掩柴扉。

辋川闲居

一从归白社，不复到青门。
时倚檐前树，远看原上村。
青菰临水映，白鸟向山翻。
寂寞於陵子，桔槔方灌园。

宫槐陌

仄径荫宫槐，幽阴多绿苔。
应门但迎扫，畏有山僧来。

酬虞部苏员外过蓝田别业不见留之作

贫居依谷口，乔木带荒村。
石路枉回驾，山家谁候门？
渔舟胶冻浦，猎火烧寒原。
唯有白云外，疏钟闻夜猿。

晚春严少尹与诸公见过

松菊荒三径，图书共五车。
烹葵邀上客，看竹到贫家。
鹊乳先春草，莺啼过落花。
自怜黄发暮，一倍惜年华！

黎拾遗昕、裴迪见过，秋夜对雨之作

促织鸣已急，轻衣行向重。
寒灯坐高馆，秋雨闻疏钟。
白法调狂象，玄言问老龙。
何人顾蓬径，空愧求羊踪。

秋夜独坐

独坐悲双鬓，空堂欲二更。
雨中山果落，灯下草虫鸣。
白发终难变，黄金不可成。
欲知除老病，唯有学无生。

叹白发

宿昔朱颜成暮齿，须臾白发变垂髫。
一生几许伤心事，不向空门何处销！


赞 佛 文

    窃以真如妙宰，具十方而无成。涅槃至功，满四生而不庶。故无边大照，不照得空有之深。万法偕行，无行为满足之地。唯兹化佛，即具三身。不舍凡夫，本无五蕴。实藉津梁法相，脱落尘容。始于度门，渐于空舍。然后金刚道后，为三界大师。玉毫光相，得一生补处。
    左散骑常侍摄御史中丞崔公第十五娘子，于多劫来，植众德本。以般若力，生菩提家。含哺则外荤膻，胜衣而斥珠翠。教从半字，便会圣言。戏则剪花，而为佛事。常侍公顷以入朝天阙，上简帝心。虽功在于生人，深辞拜命。愿赏延于爱女，密启出家。白法宿修，紫书方降。即令某月日，敬对三世诸佛、十方贤圣，稽首合掌，奉诏落发。久清三业，素成菩萨之心。新下双鬟，如见如来之顶。绮襦方解，树神献无价之衣。香饭当消，天王持众宝之钵。唯娘子舍诸珍宝，涂彼戒香。在微尘中，见亿佛刹。如献珠顷，具六神通。
    伏愿以度人设斋功德，尚奉皇帝圣寿无疆。记椿树以为年，土宇无垠。包莲花而为界，又用庄严。常侍公出为法将，入拜台臣，身在百官之中，心超十地之上。夫人以文殊智，本是法王，在普贤心，长为佛母。郎君、娘子等，住诫性为孝顺，用□德为道场，将遍众生之慈，迥同一子之想。又愿普同法界，尽及有情，共此胜因，俱登圣果。


《西方变》画赞

《西方变》画赞（并序）

    法身无对，非东西也。净土无所，离空有也。若依佛慧，既洗涤于六尘。未舍法求，厌如幻于三有。故大雄以不思议力，开方便门。我心犹疑，未认宝藏。商人既倦，且息化城。究竟达于无生，因地从于有相。
    《西方净土变》者，左常侍摄御史中丞崔公夫人李氏，奉为亡考故某官中祥之所作也。夫人门为士族之先，道为梵行之首。大师继踵，望尘而理印。命妇盈朝，闻风而素履。心王自在，万有皆如。顶法真空，一乘不立。以示见故，菩萨为胜鬘夫人。同解脱因，天女赞维摩长者。陟岵何至，哀哀缞绖。顺有漏法，泣血以居。念罔极恩，灭性非报。唯兹十力所护，岂与百身之赎？不宝缨络，资于绘素。图极乐国，象无上乐。法王安详，圣众围绕。湛然不动，疑过于往来。寂尔无闻，若离于言说。林分宝树，七重绕于香城。衣捧天花，六时散于金地。迦陵欲语，曼陀未落。众善普会，诸相具美。于是竭诚稽首，陨涕焚香。愿立功德，以备梯航。得彼佛身，常以慈悲为女。存乎法性，还在菩提之家。偈曰：

稽首十方大导师，能于一法见多法。
以种种相导群生，其心本来无所动。
稽首无边法性海，功德无量不思议。
于已不色等无碍，不住有无亦不舍。
我今深达真实空，知此色相体清净。
愿以西方为导首，往生极乐性自在。


绣如意轮像赞

绣如意轮像赞（并序）

    寂等于空，非心量得。如则不动，离意识界。实无所住，常遍群生。不舍有为，悬超万行。法性如是，岂可说耶！如意轮者，观世音菩萨陀罗尼三昧门。现方便于幻眼，六臂色身。以究竟为佛心，一体真相。随念即藏，乃无缘之慈。应度而来，斯不共之力。众生如意，菩萨何心。
    崇通寺尼无疑、道登等，贵族出家，梵筵上首。久积净业，三世皆空。长在道场，一乘自立。亡兄故河南少尹，虽明世典，深达实相，以不二法，处于百官。花萼相连，恩深女弟。旃檀旧绕，望绝仁兄。虽曰如梦，无宁丧我。烦恼性净，示有同凡之悲。菩提路空，强为助道之相。选伎唯洁，底功加敬。针锋线缕，日就月将。五彩相宣，千光欲发。金莲捧足，宝珠垂髻。原夫审像于净心，成形于纤手。珊瑚掌内，疑现不动如来。频婆口中，同乎无法可说。焚香赞叹，散花瞻仰。有情苦业，灭而不生。无上法轮，转而恒寂。愿以此福，冥用庄严。乃为偈曰：

菩萨神力不思议，能以一身遍一切。
常转法轮无所转，众生随念得解脱。
色即是定非空有，是故以色像观音。
愿以净斯六趣福，回向过去不可得。


画《西方阿弥陀变》赞

给事中窦绍为亡弟故驸马都尉于孝义寺浮图画《西方阿弥陀变》赞（并序）

    《易》曰：“游魂为变。”《传》曰：“魂气则无不之。”固知神明更生矣。辅之以道，则变为妙身，之于乐土。大觉曰圣，离妄曰性。克修其业，以正其命。得无法者，即六尘为净域。系有相者，凭十念以往生。
    《西方变》者，给事中窦绍，敬为亡弟故驸马都尉某官之所画也。天理之爱，加人数等。悲让佞而无所，痛殒身而莫赎。倾无长之工，不平分于我生，将厚贷于泉路。尚兹绘事，涤彼染业。宝树成列，金砂自映。迦陵欲语，曼陀未落。坠此中年，登乎上品。池莲宝座，将逾棠棣之荣。水鸟法音，当悟鹡鸰之力。赞曰：

生因妄念，没有遗识。
凭化而迁，转身不息。
将免六趣，唯兹土力。
哀此仁兄，友于后生。
不知世界，毕意经营。
傍熏获悟，自性当成。


送衡岳瑗公南归诗序

    衡岳瑗上人者，常学道于五峰，荫松栖云，与狼虎杂处，得无所得矣。天宝癸巳岁，始游于长安。手提瓶笠，至自万里。宴居吐论，缁属高之。初给事中房公，谪居宜春，与上人风土相接，因为道友，伏腊往来。房公既海内盛名，上人亦以此增价。秋九月，杖锡南返，扣门来别。秦地草木，摵然已黄。苍梧白云，不日而见。滇阳有曹溪学者，为我谢之。


荐福寺光师房花药诗序

    心舍于有无，眼界于色空，皆幻也，离亦幻也。至人者不舍幻，而过于色空、有无之际。故目可尘也，而心未始同。心不世也，而身未尝物。物方酌我于无垠之域，亦已殆矣。上人顺阴阳之动，与劳侣而作。在双树之道场，以众花为佛事。天上海外，异卉奇药。《齐谐》未识，伯益未知者。地始载于兹，人始闻于我。琼蕤滋蔓，侵回阶而欲上。宝庭尽芜，当露井而不合。群艳耀日，众香同风。开敷次第，连九冬之月。种类若干，多四天所雨。至用杨枝，已开贝叶。高阁闻钟，升堂觐佛。右绕七匝，却坐一面。则流芳忽起，杂英乱飞。焚香不俟于旃檀，散花奚取于优钵。漆园傲吏，著书以稊稗为言。莲座大仙，说法开《药草》之品。道无不在，物何足忘。故歌之咏之者，吾愈见其默也。


能禅师碑

能禅师碑（并序）

    无有可舍，是达有源。无空可住，是知空本。离寂非动，乘化用常。在百法而无得，周万物而不殆。鼓枻海师，不知菩提之行。散花天女，能变声闻之身。则知法本不生，因心起见。见无可取，法则常如。世之至人，有证于此，得无漏不尽漏，度有为非无为者，其唯我曹溪禅师乎！
    禅师俗姓卢氏，某郡某县人也。名是虚假，不生族姓之家。法无中边，不居华夏之地。善习表于儿戏，利根发于童心。不私其身，臭味于耕桑之侣。苟适其道，膻行于蛮貊之乡。年若干，事黄梅忍大师。愿竭其力，即安于井臼。素刳其心，获悟于稊稗。每大师登座，学众盈庭。中有三乘之根，共听一音之法。禅师默然受教，曾不起予。退省其私，迥超无我。其有犹怀渴鹿之想，尚求飞鸟之迹，香饭未消，弊衣仍覆。皆曰升堂入室，测海窥天，谓得黄帝之珠，堪受法王之印。大师心知独得，谦而不鸣。天何言哉！圣与仁岂敢。子曰：“赐也，吾与汝弗如。”临终，遂密授以祖师袈裟，而谓之曰：“物忌独贤，人恶出己。吾且死矣，汝其行乎！”禅师遂怀宝迷邦，销声异域。众生为净土，杂居止于编人。世事是度门，混农商于劳侣。如此积十六载。
    南海有印宗法师，讲《涅槃经》。禅师听于座下，因问大义，质以真乘。既不能酬，翻从请益，乃叹曰：“化身菩萨，在此色身。肉眼凡夫，愿开慧眼。”遂领徒属，尽诣禅居。奉为挂衣，亲自削发。于是大兴法雨，普洒客尘。乃教人以忍，曰：“忍者无生，方得无我。始成于初发心，以为教首。至于定无所入，慧无所依。大身过于十方，本觉超于三世。根尘不灭，非色灭空。行愿无成，即凡成圣。举足下足，长在道场。是心是情，同归性海。商人告倦，自息化城。穷子无疑，直开宝藏。其有不植德本，难入顿门。妄系空花之狂，曾非慧日之咎！”常叹曰：“七宝布施，等恒河沙。亿劫修行，尽大地墨。不如无为之运，无碍之慈，弘济四生，大庇三有。”
    既而道德遍覆，名声普闻。泉馆卉服之人，去圣历劫。涂身穿耳之国，航海穷年。皆愿拭目于龙象之姿，忘身于鲸鲵之口。骈立于户外，趺坐于床前。林是旃檀，更无杂树。花唯薝葡，不嗅余香。皆以实归，多离妄执。九重延想，万里驰诚，思布发以奉迎，愿叉手而作礼。则天太后、孝和皇帝，并敕书劝谕，征赴京城。禅师子牟之心，敢忘凤阙？远公之足，不过虎溪。固以此辞，竟不奉诏。遂送百衲袈裟，及钱帛等供养。天王厚礼，献玉衣于幻人。女后宿因，施金钱于化佛。尚德贵物，异代同符。
    至某载月日，忽谓门人曰：“吾将行矣！”俄而异香满室，白虹属地。饭食讫而敷坐，沐浴毕而更衣。弹指不留，水流灯焰。金身永谢，薪尽火灭。山崩川竭，鸟哭猿啼。诸人唱言，人无眼目。列郡恸哭，世且空虚。某月日，迁神于曹溪，安座于某所。择吉祥之地，不待青乌。变功德之林，皆成白鹤。
    呜呼！大师至性淳一，天姿贞素。百福成相，众妙会心。经行宴息，皆在正受。谈笑语言，曾无戏论。故能五天重迹，百越稽首。修蛇雄虺，毒螫之气销。跳殳弯弓，猜悍之风变。畋渔悉罢，蛊鸩知非。多绝膻腥，效桑门之食。悉弃罟网，袭稻田之衣。永惟浮图之法，实助皇王之化。
    弟子曰神会，遇师于晚景，闻道于中年。广量出于凡心，利智逾于宿学。虽末后供，乐最上乘。先师所明，有类献珠之愿。世人未识，犹多抱玉之悲。谓余知道，以颂见托。偈曰：

五蕴本空，六尘非有。众生倒计，不知正受。
莲花承足，杨枝生肘。苟离身心，孰为休咎。

至人达观，与物齐功。无心舍有，何处依空。
不著三界，徒劳八风。以兹利智，遂与宗通。

愍彼偏方，不闻正法。俯同恶类，将兴善业。
教忍断瞋，修慈舍猎。世界一花，祖宗六叶。

大开宝藏，明示衣珠。本源常在，妄辙遂殊。
过动不动，离俱不俱。吾道如是，道岂在吾。

道遍四生，常依六趣。有漏圣智，无义章句。
六十二种，一百八喻。悉无所得，应如是住。


净觉禅师碑铭

大唐大安国寺故大德净觉禅师碑铭（并序）

    光宅真空，心王之四履。建功无旱，法将之万胜。故大块群籁，无弦出法化之声。恒沙众形，□□为宝严之色。至如六师兆乱，四谛徂征。开甘露狭小之门，出臭烟朽故之宅。踞宝床而摇白拂，徐诱草庵。沃金瓶而系素缯，遂登莲座。足使天口雄辩，刮语烧书。河目大儒，掊仁击义。斯为究竟，孰不归依！
    禅师法名净觉，俗姓韦氏，孝和皇帝庶人之弟也。中宗之时，后宫用事。女谒寖盛，主柄潜移。戚里之亲，同分圭组。属籍之外，亦绾银黄。况乎天伦，将议封拜。促上方令铸印，命尚书使备策。诘朝而五土开国，信宿而驷马朝天。禅师叹曰：“昔我大师，尚以菩提释位。今我小子，欲以恩泽为侯。仁远乎哉？行之即是。”裂裳裹足以宵遁，乞食糊口以兼行。入太行山，削发受具，寻某禅师故兰若居焉。
    猛虎舐足，毒蛇熏体。山神献果，天女散花。澹尔宴安，曾无喜惧。先有涸泉枯柏，至是布叶跳波。东魏神泉，应焚香而忽涌。北天众果，候飞锡而还生。禅枝必复之征，法水再兴之象。闻东京有赜大师，乃脱履户前，抠衣坐下。天资义性，半字敌于多闻。宿植圣胎，一瞬超于累劫。九次第定，乘风云而不留。三解脱门，揭日月而常照。雪山童子，不顾芭蕉之身。云地比丘，欲成甘蔗之种。大师委运，遂广化缘。海澄而龙额珠明，雷震而象牙花发。外家公主，长跽献衣。荐绅先生，却行拥篲。乞言于无说，请益于又损。天池杯水，遍含秋月之辉。草叶树根，皆沾宿雨之润。不窥世典，门人与宣父中分。不受人爵，廪食与封君相比。至于律仪细行，周密护持。经典深宗，毫厘剖析。穷其二翼，即入佛乘。趣得一毛，亦成僧宝。
    于是同凡现疾，处顺将终，忽谓众人：“有疑皆问，我于是夜，当入无余。”开口万言，音和水鸟。踊身七树，光映天人。如蹔出行，泯然趺坐。以某载月日，归大寂灭。某月日，迁神于少陵原赤谷兰若。香油细氎，用以茶毗。合璧连珠，为之葬具。城门至于谷口，幡盖相连。法侣之与都人，缟素相半。叩膺拔发，洒水坌尘。升堂入室之徒，数逾七十。破山澍海之哭，声振三千。则有僧某乙、尼某乙、故惠庄某氏某郡主、贤者某乙等，各在众中，共为上首。或行如白雪，或名亚红莲，或为胜鬘夫人，或称毗耶居士。二空法外，何处进求。七觉分中，谁当决释。犹衣舍利，冀获菩提。身塔不出虎溪，泪碑有同羊岘。表心成相，相非离于真如。叙德以言，言岂著于文字。乃为铭曰：

小三千界，后五百年。空乘玉牒，莫睹金仙。
无量义处，如来之禅。皆同目论，谁契心传。

弟在人间，姊归凤阙。去日留训，别时剪发。
累赐金钱，将加印绂。忽尔宵遁，终然两绝。

救头学道，裹足寻师。一花宝树，八水香池。
戒生忍草，定长禅枝。不疑少父，更似婴儿。

既立胜幡，并摧邪网。利眼金翅，圆身宝掌。
巧撮死龙，能调老象。魔种败坏，圣胎长养。

四生灭度，五阴虚空。无说无意，非异非同。
此身何处，彼岸成功。当观水月，莫怨松风。


道光禅师塔铭

大荐福寺大德道光禅师塔铭（并序）

    禅师讳道光，本姓李，绵州巴西人。其先有特有流，若实有蜀。盖子孙为民。大父怀节，隐峨嵋山，行无辙迹。其季父荣，为道士，有文知名。禅师幼孤，在诸儿，其神独不偶。家颇苦乏绝，去诣乡校，见周、孔书，曰：“世教耳。”誓苦行求佛道。入山林，割肉施鸟兽。炼指烧臂。入般舟道场，百日昼夜经行。遇五台宝鉴禅师，曰：“吾周行天下，未有如尔可教。”遂密授顿教，得解脱知见。舍空不域，既动无眹。不观摄见，顺有离觉。毛端族举佛刹，掌上断置世界。不睹非咎，应度方知。得其门者寡，故道俗之烦而息化城，指尽谓穷性海而已。（上有阙文）焉足知恒沙德用，法界真有哉！春秋五十二，凡三十二夏。以大唐开元二十七年五月二十三日，入般涅槃于荐福僧坊。门人明空等，建塔于长安城南毕原。人天会葬，涕泗如雨。禅师之不可得法如此。其世行遗教，如一切贤圣。维十年座下，俯伏受教。欲以毫末，度量虚空，无有是处，志其舍利所在而已。铭曰：

呜呼人天尊！全身舍利在毕原。


京兆王氏墓志铭

工部杨尚书夫人赠太原郡夫人
京兆王氏墓志铭

    夫人讳某，京兆霸城人也。晋出三家，公子尊于魏国。秦亡六国，时人谓之王家。河南则分虎临人，华阴则老罴当道。高祖德真，皇左仆射。祖九思，京兆府三原县令。父潜，河南府告成县令。大名之后，重光不替。
    夫人令仪淑德，发于天姿。闲礼明诗，传乎世业。言成女诫，可著于缣缃。行为女师，讵资于行待。岂止弹琴吐论，诵赋吟诗而已。及乎有行，嫔于君子。事姑至孝，旁穆六姻。为母深慈，均养七子。男以无双令德，降帝子于凤楼。女则第一解空，归法王之象教。闺门之训，朝野称多。既而家列公侯，地连妃主。珠翠满座，不御彩衣。方丈盈前，唯甘素食。同德大师大照和尚，睹如来之奥，昭群有之源。夫人一入空门，便蒙法印。朱帘绀幰，无复余乘。龙藏宝经，悉通至义。慧用圆满，戒力坚严。药藉茹荤，虽愈疾而不受。心已久净，纵没齿而常安。
    以某年月日，奄归大寂于长兴里之私第。厥初寝疾，弥旷旬时。驸马、上人，柴毁骨立。挥泪尝药，身不解衣。泣血持经，手不释卷。昼夜忏悔，非止六时。身命供养，宁唯七宝。御医继踵，中使重迹。魂兮不反，空焚外国之香。生也有涯，非无上天之乐。
    某月日，有诏追赠太原郡夫人。襄城石窌，增宠其荣名。翟茀鱼轩，空悲于象设。以某月日，安厝于某原，礼也。功德之至，散花天女不留。释梵之筵，胜鬘夫人何在？呜呼哀哉！乃为铭曰：

天生淑德，实俾宜家。
特能柔顺，深弃骄奢。
讵离环佩，不御铅华。

妇道允谐，母仪俱美。
每出诫夫，停餐训子。
赋掩《西征》，书教内史。

门容高幰，庭列长筵。
男乘翠凤，女比红莲。
繁华贵里，寂寞安禅。

食必箪笥，衣无重彩。
已度爱河，长游法海。
石舃虚封，玉颜如在。

繁霜密雪，碎菊摧兰。
山花喜静，□□春寒。
平原松柏，谁忍回看！


为人祭李舍人文

    年月日，某以茶药之奠，祭于故舍人李公之灵。呜呼！见人多矣，未有如子。生于德门，长于贵里。名高江夏之童，貌夺河阳之美。行比曾颜，才兼文史。含恣轻肥，仰偃纨绮，恶如涕唾，弃如尘滓。比布衣以同年，甘蔬食而没齿。呜呼！深入度门，高居道源。独一静处，寂默无言。待草诫之真性，归化光之法尊。旷无净染，顿离尘根。岂期昨日分首，别离未久。万法皆空，一生何有。无余涅槃，应无所受。无漏智慧，斯为不朽。予以凡情，哀哀其后。世相谓然，道心斯丑。敢不从俗，子其无咎。尚飨！


为幹和尚进《注仁王经》表

    沙门惠幹言：法离言说，了言说即解脱者，终日可言。法无名相，知名相即真如者，何尝坏相。实际以无际可示，无生以不生相传。非夫自得性空，密印心地，见闻自在，宗说皆通者，何以证玉毫之光，辨金口之义。
    伏惟乾元光天皇帝陛下，高登十地，降抚九天。宏济群生，濡莲花之足。示行世法，屈金粟之身。心净超禅，顶法悬解。广释门之六度，包儒行之五常。老僧空空，复何语语？以无见之见，不言之言。浅智胜疑冰之虫，微戒愈溺泥之象。以自觉离念，注先圣微言。如人何足尽思，食木偶然成字。岂堪上尘慧眼，仰称圣心。有命自天，藏拙无地。
    伏以《集解仁王般若经》十卷，谨随表奉进，无任惭惶。然本注经，先发大愿，释第一义，开不二门。与四十九僧，离一百八句，六时禅诵，三载恳祈。俾廓妖氛，得瞻慧日。三千世界，悉奉仁王。五千善神，常卫乐土。令果荡定，无量安宁。缁服苍生，不胜庆跃。


为舜阇黎谢御题大通、大照和尚塔额表

    沙门僧某等言：伏蒙圣札题二大师塔额，及度僧、抽僧等并毕。伏喜天心，俯从人欲。恩光至重，抃舞难胜。臣闻圣者正也，住正法者为圣人。佛者觉也，得觉满者入佛慧。伏惟光天皇帝陛下，登满足地，超究竟天。入三解脱门，过九次第定。见闻自在，不住无为。理事皆如，终非有漏。复皇国而御宇，尊白法以教人。百谷顺成，六气时若。不加兵而贼破，不扰物以人和。缁侣胜缘，苍生厚幸。
    昨蒙书额、度僧等，龙腾金榜，凤转银钩。河汉昭回，烟云飞动。韦诞耻其遗法，梁鹄惭为古人。降出天门，升于宝塔。玉绳缀于重级，珠斗挂于露盘。以方宸翰，实多惭德。又宿修梵行，愿在法流者，覆以惭愧之衣，落其烦恼之发。冀成宝器，仁王为琢玉之因。广运佛心，圣主受恒沙之佑。沙门等叨承禅训，幸偶昌期。御札赐书，足报本师之德。梵筵邀福，愿酬大圣之恩。不胜戴荷之至。


为僧等请上佛殿梁表

    僧某言：天地之大，未满法身。绀殿朱宫，岂云光宅。陛下尊崇像教，大舍外财。白法利人，黄金布地。不役一人之力，不费一家之产。崇崇宝坊，云构将毕。所营某寺，以某月日上佛殿梁。伏望天恩，内赐一伞。庶使大千世界，悉入盖中。六合人天，共归宇下。然后以无碍慧，大化群物。将使四生皆度，岂唯比屋可封。则中天之台，才留幻士。画云之观，徒候神人。以古况今，前王何陋。谨诣右银台门，奉表陈谢以闻。


谢除太子中允表

    臣维稽首言：伏奉某月日制，除臣太子中允。诏出宸衷，恩过望表。捧戴惶惧，不知所裁。臣闻食君之禄，死君之难。当逆胡干纪，上皇出宫。臣进不得从行，退不能自杀。情虽可察，罪不容诛。
    伏惟光天文武至圣皇帝陛下，孝德动天，圣功冠古。复宗社于坠地，救涂炭于横流。少康不及君亲，光武出于支庶。今上皇返正，陛下御乾。历数前王，曾无比德。万灵抃跃，六合欢康。仍开祝网之恩，免臣衅鼓之戮。投书削罪，端衽立朝。秽污残骸，死灭余气。伏谒明主，岂不自愧于心？仰厕群臣，亦复何施其面？局天内省，无地自容。且政化之源，刑赏为急。陷身凶虏，尚沐官荣。陈力兴王，将何宠异？
    况臣夙有诚愿：伏愿陛下中兴，逆贼殄灭，臣即出家修道，极其精勤，庶裨万一。顷者身方待罪，国未书刑。若慕龙象之俦，是避魑魅之地。所以钳口，不敢萌心。今圣泽含弘，天波昭洗。朝容罪人食禄，必招屈法之嫌。臣得奉佛报恩，自宽不死之痛。谨诣银台门，冒死陈请以闻。无任惶恐战越之至。


责躬荐弟表

    臣维稽首言：臣年老力衰，心昏眼暗。自料涯分，其能几何。久窃天官，每惭尸素。顷又没于逆贼，不能杀身。负国偷生，以至今日。陛下矜其愚弱，托病被囚。不赐疵瑕，累迁省阁。昭洗罪累，免负恶名。在于微臣，百生万足。昔在贼地，泣血自思：一日得见圣朝，即愿出家修道。及奉明主，伏恋仁恩。贪冒官荣，荏苒岁月。不知止足，尚忝簪裾。始愿屡违，私心自咎。
    臣又闻，用不才之士，才臣不来。赏无功之人，功臣不劝。有国大体，为政本源。非敢议论他人，窃以兄弟自比：臣弟蜀州刺史缙，太原五年，抚养百姓，尽心为国，竭力守城。臣即陷在贼中，苟且延命。臣忠不如弟，一也。缙前后历任，所在著声。臣忝职甚多，曾无裨益。臣政不如弟，二也。臣顷负累，系在三司，缙上表祈哀，请代臣罪。臣之于缙，一无忧怜。臣义不如弟，三也。缙之判策，屡登甲科，众推才名，素在臣上。臣小言浅学，不足谓文。臣才不如弟，四也。缙言不忤物，行不上人，植性谦和，执心平直。臣无度量，实自空疏。臣德不如弟，五也。臣之五短，弟之五长，加以有功，又能为政。顾臣谬官华省，而弟远守方州。外愧妨贤，内惭比义。痛心疾首，以日为年。
    臣又逼近悬车，朝暮入地。阒然孤独，迥无子孙。弟之与臣，更相为命。两人又俱白首，一别恐隔黄泉。倘得同居，相视而没。泯灭之际，魂魄有依。伏乞尽削臣官，放归田里。赐弟散职，令在朝廷。臣当苦行斋心，弟自竭诚尽节，并愿肝脑涂地，陨越为期。葵藿之心，庶知向日。犬马之意，何足动天。不胜私情恳迫之至。


请施庄为寺表

    臣维稽首。臣闻罔极之恩，岂有能报。终天不返，何堪永思。然要欲强有所为，自宽其痛。释教有崇树功德，宏济幽冥。臣亡母故博陵县君崔氏，师事大照禅师三十余岁。褐衣蔬食，持戒安禅。乐住山林，志求寂静。臣遂于蓝田县营山居一所。草堂精舍，竹林果园，并是亡亲宴坐之余，经行之所。臣往丁凶衅，当即发心，愿为伽蓝，永劫追福。比虽未敢陈请，终日常积恳诚。
    又属元圣中兴，群生受福。臣至庸朽，得备周行。无以谢生，将何答施？愿献如天之寿，长为率土之君。唯佛之力可凭，施寺之心转切。效微尘于天地，固先国而后家。敢以鸟鼠私情，冒触天听。伏乞施此庄为一小寺，兼望抽诸寺名行僧七人，精勤禅诵，斋戒住持。上报圣恩，下酬慈爱。无任恳款之至。


请回前任司职田粟施贫人粥状

    右臣比见道路之上，冻馁之人，朝尚呻吟，暮填沟壑。陛下圣慈怜愍，煮公粥施之。顷年已来，多有全济。至仁之德，感动上天。故得年谷颇登，逆贼皆灭。报施之应，福佑昭然。
    臣前任中书舍人、给事中，两任职田，并合交纳。近奉恩敕，不许并请。望将一司职田，回与施粥之所。于国家不减数粒，在穷窘或得再生。庶以上福圣躬，永弘宝祚。仍望令刘晏分付所由讫，具数奏闻。如圣恩允许，请降墨敕。


山中与裴秀才迪书

    近腊月下，景气和畅，故山殊可过。足下方温经，猥不敢相烦。辄便往山中，憩感配寺，与山僧饭讫而去。北涉玄灞，清月映郭。夜登华子冈，辋水沦涟，与月上下。寒山远火，明灭林外。深巷寒犬，吠声如豹。村墟夜舂，复与疏钟相间。此时独坐，僮仆静默。多思曩昔，携手赋诗，步仄径，临清流也。当待春中，草木蔓发，春山可望。轻鯈出水，白鸥矫翼。露湿青皋，麦陇朝雊。斯之不远，倘能从我游乎！非子天机清妙者，岂能以此不急之务相邀？然是中有深趣矣，无忽。因驮黄蘖人往。不一。山中人王维白。


与魏居士书

    足下太师之后，世有明德，宜其四代五公，克复旧业。而伯仲诸昆，顷或早世。唯有寿光，复遭播越。幼生弱侄，藐然诸孤，布衣徒步，降在皂隶。足下不忍其亲，杖策入关，降志屈体，托于所知。身不衣帛，而于六亲孝慈。终日一饭，而以百口为累。攻苦食淡，流汗霡霖，为之驱驰。仆见足下，裂裳毁冕，二十余年，山栖谷饮，高居深视。造次不违于仁，举止必由于道。高世之德，欲盖而彰。
    又属圣主搜扬仄陋，束帛加璧，被于岩穴。相国急贤，以副旁求，朝闻夕拜。片善一能，垂章拖组。况足下崇德茂绪，清节冠世。风高于黔娄善卷，行独于石门荷蓧。朝廷所以超拜右史，思其入践赤墀，执牍珥笔，羽仪当朝，为天子文明。且又禄及其室养，昆弟免于负薪，樵苏晚爨。柴门闭于积雪，藜床穿而未起。若有称职，上有致君之盛，下有厚俗之化。亦何顾影局步，行歌采薇？是怀宝迷邦，爱身贱物也。岂谓足下利钟釜之禄，荣数尺之绶？虽方丈盈前，而蔬食菜羹。虽高门甲第，而毕竟空寂。人莫不相爱，而观身如聚沫。人莫不自厚，而视财若浮云。于足下实何有哉！
    圣人知身不足有也，故曰：“欲洁其身，而乱大伦。”知名无所著也，故曰：“欲使如来，名声普闻。”故离身而返屈其身，知名空而返不避其名也。古之高者曰许由，挂瓢于树，风吹瓢，恶而去之。闻尧让，临水而洗其耳。耳非驻声之地，声无染耳之迹。恶外者垢内，病物者自我。此尚不能至于旷士，岂入道者之门欤！降及嵇康，亦云：“顿缨狂顾，逾思长林而忆丰草。”顿缨狂顾，岂与俯受维絷有异乎？长林丰草，岂与官署门阑有异乎？异见起而正性隐，色事碍而慧用微。岂等同虚空，无所不遍；光明遍照，知见独存之旨耶？此又足下之所知也。
    近有陶潜，不肯把板屈腰见督邮，解印绶弃官去，后贫。《乞食诗》云：“叩门拙言辞。”是屡乞而多惭也。尝一见督邮，安食公田数顷。一惭之不忍，而终身惭乎！此亦人我攻中，忘大守小，不□其后之累也。孔宣父云：“我则异于是，无可无不可。”可者适意，不可者不适意也。君子以布仁施义、活国济人为适意。纵其道不行，亦无意为不适意也。苟身心相离，理事俱如，则何往而不适？此近于不易，愿足下思可不可之旨。以种类俱生，无行作以为大依，无守默以为绝尘，以不动为出世也。
    仆年且六十，足力不强。上不能原本理体，裨补国朝。下不能殖货聚谷，博施穷窘。偷禄苟活，诚罪人也。然才不出众，德在人下，存亡去就，如九牛一毛耳。实非欲引尸祝以自助，求分谤于高贤也。略陈起予，唯审图之。


旧唐书·王维传

    王维，字摩诘，太原祁人。父处廉，终汾州司马，徙家于蒲，遂为河东人。维开元九年进士擢第。事母崔氏以孝闻。与弟缙俱有俊才，博学多艺亦齐名，闺门友悌，多士推之。历右拾遗、监察御史、左补阙、库部郎中。居母丧，柴毁骨立，殆不胜丧。服阕，拜吏部郎中。天宝末，为给事中。
    禄山陷两都，玄宗出幸。维扈从不及，为贼所得。维服药取痢，伪称喑病。禄山素怜之，遣人迎置洛阳，拘于普施寺，迫以伪署。禄山宴其徒于凝碧宫，其乐工皆梨园弟子、教坊工人。维闻之悲恻，潜为诗曰：“万户伤心生野烟，百官何日再朝天？秋槐花落空宫里，凝碧池头奏管弦。”贼平，陷贼官三等定罪。维以《凝碧诗》闻于行在，肃宗嘉之。会缙请削己刑部侍郎，以赎兄罪。特宥之，责授太子中允。乾元中，迁太子中庶子、中书舍人，复拜给事中，转尚书右丞。
    维以诗名盛于开元、天宝间。昆仲宦游两都，凡诸王、驸马、豪右、贵势之门，无不拂席迎之。宁王、薛王，待之如师友。维尤长五言诗。书画特臻其妙，笔踪措思，参于造化。而创意经图，即有所缺。如山水平远，云峰石色，绝迹天机，非绘者之所及也。人有得《奏乐图》，不知其名。维视之曰：“《霓裳》第三叠第一拍也。”好事者集乐工按之，一无差，咸服其精思。
    维弟兄俱奉佛，居常蔬食，不茹荤血。晚年长斋，不衣文彩。得宋之问蓝田别墅，在辋口。辋水周于舍下，别涨竹洲花坞。与道友裴迪，浮舟往来，弹琴赋诗，啸咏终日。尝聚其田园所为诗，号《辋川集》。在京师，日饭十数名僧，以玄谈为乐。斋中无所有，唯茶铛、药臼、经案、绳床而已。退朝之后，焚香独坐，以禅诵为事。妻亡不再娶，三十年孤居一室，屏绝尘累。乾元二年七月卒。临终之际，以缙在凤翔，忽索笔作别缙书。又与平生亲故作别书数幅，多敦厉朋友奉佛修心之旨，舍笔而绝。
    代宗时，缙为宰相。代宗好文，常谓缙曰：“卿之伯氏，天宝中诗名冠代，朕尝于诸王座闻其乐章。今有多少文集，卿可进来。”缙曰：“臣兄开元中诗百千余篇。天宝事后，十不存一。比于中外亲故间，相与编缀，都得四百余篇。”翌日上之，帝优诏褒赏。缙自有传。

（录自《旧唐书·列传第一百四十》）


新唐书·王维传

    王维，字摩诘。九岁知属辞，与弟缙齐名，资孝友。开元初，擢进士，调太乐丞，坐累为济州司仓参军。张九龄执政，擢右拾遗。历监察御史。母丧，毁几不生。服除，累迁给事中。
    安禄山反，玄宗西狩。维为贼得，以药下利，阳喑。禄山素知其才，迎置洛阳，迫为给事中。禄山大宴凝碧池，悉召梨园诸工合乐，诸工皆泣，维闻悲甚，赋诗悼痛。贼平，皆下狱。或以诗闻行在，时缙位已显，请削官赎维罪，肃宗亦自怜之，下迁太子中允。久之，迁中庶子，三迁尚书右丞。
    缙为蜀州刺史未还。维自表：“己有五短，缙五长。臣在省户，缙远方。愿归所任官，放田里，使缙得还京师。”议者不之罪。久乃召缙为左散骑常侍。上元初卒，年六十一。疾甚，缙在凤翔，作书与别，又遗亲故书数幅，停笔而化。赠秘书监。
    维工草隶，善画，名盛于开元、天宝间。豪英贵人虚左以迎，宁、薛诸王待若师友。画思入神，至山水平远，云势石色，绘工以为天机所到，学者不及也。客有以《按乐图》示者，无题识。维徐曰：“此《霓裳》第三叠最初拍也。”客未然，引工按曲，乃信。
    兄弟皆笃志奉佛，食不荤，衣不文彩。别墅在辋川，地奇胜，有华子冈、欹湖、竹里馆、柳浪、茱萸沜、辛夷坞。与裴迪游其中，赋诗相酬为乐。丧妻不娶，孤居三十年。母亡，表辋川第为寺。终葬其西。
    宝应中，代宗语缙曰：“朕尝于诸王座，闻维乐章。今传几何？”遣中人王承华往取。缙裒集数十百篇上之。

（录自《新唐书·列传第一百二十七》）


居士传·王摩诘传

    王摩诘，名维，世为祁县人，后徙家于蒲，与弟缙俱有俊才。开元九年，擢进士第，历官至监察御史。母博陵县君崔氏，持戒安禅。摩诘于蓝田营山庄，为母经行之处。既卒，乃上表于朝，请施庄为寺，诏许之。天宝末，为给事中。安禄山陷京师，为所得。以药下痢，佯喑。禄山迎置洛阳，迫为给事中。贼平论罪，时缙已官刑部侍郎，请削官赎兄罪。乃左迁太子中允，累迁尚书右丞。
    在京师，从荐福寺道光禅师游。日饭数十名僧，斋中无所有，唯药铛、茶臼、经案、绳床而已。居常不茹荤血，不衣文彩。妻亡不再娶，三十年孤处一室，焚香独坐，以禅诵为业。时与友人裴迪，往来山庄，弹琴啸咏，乐之忘归。
    同时有魏处士者，高不仕之节，屡征不应。摩诘为书遗之曰：“圣人知身之不足有也，故曰：‘欲洁其身而乱大伦。’知名之无所著也，故曰：‘欲使如来名声普闻。’古之高者曰许由，闻尧让，临水而洗其耳。耳非驻声之地，声无染耳之迹。恶外者垢内，病物者自我。岂入道者之门欤？孔宣父云：‘我则异于是，无可无不可。’愿足下思可不可之旨，无守默以为绝尘，以不动为出世也。”
    乾元二年七月，有疾。以缙在凤翔，索笔作别缙书。又与亲故书数幅，多敦厉奉佛修心之旨，舍笔而逝。(《唐书》、《右丞文集》)

（录自彭际清《居士传》第十九）


荷泽神会禅师语录(节录)

荷泽神会禅师语录（节录）

    门人刘相倩，云于南阳郡，见侍御史王维，在湍驿中屈神会和上，及同寺僧惠澄禅师，语经数日。于时王侍御问和上言：“若为修道得解脱？”答曰：“众生本自心净，若更欲起心有修，即是妄心，不可得解脱。”
    王侍御惊愕云：“大奇！曾闻大德，皆未有作如此说。”乃为寇太守、张别驾、袁司马等曰：“此南阳郡，有好大德，有佛法甚不可思议。”寇太守云：“此二大德见解并不同。”
    王侍御问和上：“何故得不同？”答曰：“今言不同者，为澄禅师要先修定以后，定后发慧。即知不然，今正共侍御语时，即定慧俱等。《湼槃经》云：‘定多慧少，增长无明。慧多定少，增长邪见。若定慧等者，名为见佛性。’故言不同。”王侍御问：“作没时是定慧等？”和上答：“言定者，体不可得。所言慧者，能见不可得体，湛然常寂，有恒沙巧用。即是定慧等学。”
    众起立厅前，澄禅师咨王侍御云：“惠澄与会阇梨，刚证不同。”王侍御笑谓和上言：“何故不同？”答：“言不同者，为澄禅师先修定，得定已后发慧。会即不然，正共侍御语时，即定慧俱等。是以不同。”侍御言：“阇梨，只没道不同。”答：“一纤毫不得容。”又问：“何故不得容？”答：“今实不可同，若许道同，即是容语。”

（录自《中国佛教思想资料选编》第二卷第四册）


唐金陵钟山元崇传

    释元崇，俗姓王氏，琅琊临沂人也。晋丞相始兴文献公子荟之后。自南朝伦废，世居句容。祖祢已来，非贤即哲。崇幼而孤秀，嶷若断山。心喻芙蕖，形同玉洁。风尘不杂，立志夷简。时年十五，奉道辞家。负笈洞天，餐霞卧云。师范陶、许，精研妙句，独证微隐。乃恐至理未融，解脱方阻，因归心释典，大畅佛乘。三教齐驱，遘心世表。于是声振吴越，缁素异焉。采访使润州刺史齐平阳公，闻其行业，虚伫久之。适会恩制度人，裒充举首。以开元末年，因从瓦官寺璿禅师，咨受心要，日夜匪懈，无忘请益。璿公乃揣骨千里，骏足可知，因授深法。崇灵台虚彻，可舍百神，心鉴高悬，尘无私隐。既而声价光远，物望所知。金陵诸德，请移所配栖霞寺。春秋逾纪，服勤道务。彝伦有叙，时众是瞻。
    至德初，并谢绝人事，杖锡去郡。历于上京，遍奉明师。栖心闲境，罕交俗流。遂入终南，经卫藏，至白鹿，上蓝田。于辋川，得右丞王公维之别业。松生石上，水流松下。王公焚香静室，与崇相遇，神交中断。于时天地未泰，豺狼构患。朝贤国宝，或在薖轴。起居萧舍人昕，与右丞诸公，并硕学雄才，尊儒重道。偶兹一会，抗论弥日。钩深索隐，襟期许与。王、萧叹曰：“佛法有人，不宜轻议也矣！”
    及言旋河洛，登陟嵩少。怀达磨之旨要，得《华严》之会归。声价渐高，衣冠羡仰。京师名德，咸请住持。志在无为，翛然不顾。乃放浪人世，追踪道流，考盘灵踪。遂东适吴越天台、四明，清心养素。数年之后，遐想钟山，飞锡旧居，考以云房。道俗咸喜，玉反山辉。
    大历五年，刺史南阳樊公，雅好禅寂，及属县行春，顺风稽首，咨请道要，益加师礼矣。时道俗以为此寺灵胜，游憩者多。监主护持，须选名德。佥议无以易禅师者。崇频告辞恳苦，众咸再三，事不获已，顺受弥缝其间，总二十年。藉四方之财，因道化之力，栾栌云构，丹雘日新，盖存乎无为无所不为者也。功成身退，安禅高顶。前后学徒，讵可胜计。
    至大历十二年，示疾言归，不加药饵。八月二日，卒于山院，春秋六十有五。临终命门人，无令封树。弟子如泉、澄添等，奉全师教，以其月八日，瘗于摄山之阳。依岩为窟，累石不磨不砻，遵遗诰也。
    崇身长六尺，仪表端肃，望之俨然，即之生畏。意密情恕，心和行高。天姿龙象，生此岐嶷。享龄非永，惜哉！弟子等共建丰碑，以纪化迹，树于寺之门首焉。

（录自《宋高僧传》卷十七）