封面

《唯识札记》
（惟贤法师 著）
北京三学读书会 敬印
中华佛典宝库 制作
2006年2月25日


目　录

前　　言
唯识学在佛法中的地位
唯识法相问答
唯识种子义
论转识成智
阿赖耶识浅说
因明十四相似过类略释
唯识二十论提要
唯识三十颂概说
瑜伽真实品讲义
唯识学的业报论
唯识要义
唯识答疑在读书会
玄奘法师与唯识学
玄奘精神与西部文化研讨会总结提纲
玄奘精神与人间佛教
读解深密经笔记
读楞伽经笔记
缘生要义
附录：惟贤法师小传


前　　言

    唯识思想是人类思想史上最伟大的成就之一。在包括中国和印度的东方各家学说中，能与西方哲学的组织化、系统化相匹敌，从一个观念而导引出许多连锁观念、系统观念，可说唯有佛教的唯识学最具此种精神。而希腊哲学的严密，虽然早在公元前三世纪，已由亚里士多德的形式逻辑推动发展，体系谨严，但由个人的身心推演到主客观、推演到内外世界、宇宙万象，乃至生命的形上、形下各层意义，同时又由理论符合到实践意义，透露出实践的方法，可以断言，在希腊及整个西方哲学史上，绝难举出可与唯识学相媲美的一例。
    唯识学在上个世纪前期中国佛教研究的三支（唯识学、佛教史和禅宗）主要路向中，又对思想界的影响最为深刻——二十世纪中国可数的几个大思想家之中，如梁启超、章太炎等，无不跟唯识学有着密切的关系。在当时唯识学的研究领域，形成了以欧阳竟无先生领导的南京支那内学院、太虚大师创办的世界佛学苑（主要是其中的武昌佛学院和汉藏教理院）、韩清净主持的北京三时学会为中心的三股重要力量。本书的作者惟贤老法师早年曾先后分别在四川南充龟山书院和重庆汉藏教理院师事过在支那内学院进修过的国学和佛学大师王恩洋先生及著名佛教思想家和改革家太虚大师。王先生和太虚大师二人在唯识学等方面的精深造诣，在他们至今已是八十五岁高龄的高足惟贤老法师身上得到了独到的承嗣。老法师虽已是耄耋之寿，可撰文讲说，丝毫不让当年，引经据典，思想深刻，层次分明，逻辑严密，这与他早年跟随二位大德而打下的扎实的唯识学基础和深厚的中国传统文化素养分不开。
    唯识学的理论千头万绪，体系宏大繁复，思辩性极强，古来不少人将之称为最繁琐的哲学，望而生畏。虽然表面看起来，本书一如书名所示的那样，是多篇文稿的札记，收录的文章或讲记篇幅的总量也不算大，似乎难以将唯识学的全貌展现无遗；但是其中每一篇，字里行间无不昭显出作者对唯识学要旨的深刻领悟，真乃解行并举所获的心得之谈；所以才能将深邃的唯识思想借助浅显易懂的语言表达出来，纲举目张，清晰明了。不仅为初学者开卷有益，专攻者亦可备为深入瑜伽之难得参考资料，有心的读者若稍事浏览本书便可察知此言不虚。更为可贵的是，老法师通过对唯识学话题的解说，将佛法的思想核心和修持要领也一并揭示出来，展现出佛法独具的博大和睿智、慈悲与超然，彰显出古老的佛教所高扬的理性的光芒。
    本书所收的文稿，是对老法师若干年来相关唯识学作品（包括唯识讲座录音的文字整理稿）的一次小的汇集。在内容上，举凡唯识学上具有的问题，几乎都涉及到了；在时间跨度上，其中最早的文章与最晚的文章的写作时间相隔达六十余年。六十年中的变化，不论是思想界外部，还是教界内部都已经非常巨大，但是真理的光辉不会因时间的迁流而变化，昭示真理的文字的价值也不会随着年轮的更替而被泯灭。因为生命性的信仰，是亘古不变的。包括唯识学在内的佛法，是宇宙和人生的真理，尽管时光荏苒，岁月匆匆，千数百年前的人如是追求，千数百年后的人仍追求如是。追求的信仰理论前后是一致的，所以，就内涵来说，前后相距数十年，俨然无所差异，有差异的只是人世的变幻而已。
    佛法讲因缘，本书能够顺利出版也是众多因缘和合而成。首先感谢惟贤师父的慈悲，在百忙中抽空讲解部分内容和认真审阅全部稿件。其次还有正澄法师、滕树琴、王学胜、汤愈群，以及王瑜、杨大治、高鸿、正济、李力、正诚、正光、正观、高玉磊、关维东、郑文强等众多善士的鼎力相助，是本书面世的重要增上缘，在此一并致谢！

    惟贤法师著作编辑室


唯识学在佛法中的地位

    一、唯识学思想的发展历史
    佛在世时说法，当时无文字记载，佛灭度以后，佛说的法，经过弟子们三四次结集，这就形成大小乘经典。因为是佛亲口宣说，内容即是佛的自证境界，是圣言量。后世的大小乘论师们，根据佛的经典，加以研究发挥，就成为论义，于是有小乘论、大乘论。根据时间的推移，论的内容，是有系统的，逐步将佛所说的法发挥光大。太虚法师在《判摄佛法》中提到：佛灭度以后，初五百年，是小行大隐时期，就是说当时流通的是小乘佛教，大乘佛教是隐而不彰。第二个五百年，是大主小从时期，大乘佛教开始逐步发扬。第三个五百年，是密主显从时期，由于当时印度王朝处于衰落时期，婆罗门教复兴，佛教的弘扬不得不依靠婆罗门教，以婆罗门教的形式来发扬佛教中观思想，采取一种密宗的方式，所以这个五百年呢，是密主显从时期，以密宗为主，显宗为辅。大概在这个时期，印度佛教就衰落了。
    （一）第一个五百年，小行大隐时期
    小乘在结集的时候，分为两部，就是上座部和大众部，上座部就是窟内结集，大众部就是窟外结集。由这两部逐步发展，上座部分为十一部，大众部分为九部。从这时开始，就分为二十个部派。经典即《四阿含经》，论说部分，有《毗婆沙论》、《俱舍论》，重点是阐扬了四谛十二因缘的教义。
    （二）第二个五百年，大主小从时期
    大乘佛教开始发扬，是在佛灭度后五百年开始。马鸣菩萨写《大乘起信论》，发挥了佛说，把“心”分为“心生灭门”、“心真如门”。“心生灭门”就是凡夫流转生死的境界，“心真如门”就是闻法以后逐步解脱，进入圣者的境界。这个时候，大乘就开始流行。
    到了六百年间，龙树菩萨发扬了大乘的空义，根据《大般若经》写《大智度论》、《中论》、《十二门论》，他的弟子提婆菩萨写了《百论》。这些论著都是“空宗”根据《大般若经》而发扬的主要论典。
    到了八九百年间，无著菩萨出世，还有无著菩萨的弟弟世亲。无著菩萨宣扬大乘，特别是瑜伽派，根据弥勒菩萨讲的《瑜伽师地论》无著菩萨写了《摄大乘论》等，宣扬大乘唯识，后来世亲菩萨受无著菩萨感化，弃小向大，也弘扬唯识，写的著作很多。世亲菩萨很聪明，大小乘方面写了很多论著，他被尊称为“千部论师”。根据时间的推移，佛教的大乘教义到了无著世亲时代，是大大地发扬了，这表现在经典多，论著多，比以前小行大隐时期和空宗盛行时期，从体系来讲，更完整，更有系统。佛所说的唯识法相到这个时候，就显出它的系统性，它的教义博大精深。
    无著世亲菩萨以后，大概在一千年左右，继续世亲菩萨的有十大论师：护法、净月、欢喜、智月等等（注：十大论师为：1.护法；2.德慧；3.安慧；4.亲胜；5.欢喜；6.净月；7.火辨；8.胜友；9.胜子；10.智月）。世亲菩萨写完《三十唯识论》后就圆寂了，没进一步写，这十大论师就各自发挥妙义，解释世亲菩萨的《三十唯识论》。在这个时候，佛教的瑜伽及法相唯识思想发展到了登峰造极，无著、世亲、十大论师的弘扬，使这个思想遍及五印。
    （三）第三个五百年，密主显从时期
    这时候，婆罗门教复兴，密宗盛行，佛教的教义就衰落了，谈不上教义的弘扬。佛教在这个时候，在印度，随着婆罗门的影响，随着外来的教派的侵略影响，开始逐步衰落。
    在汉哀帝到汉明帝时期，佛教由印度传到中国。
    佛教在中国的发展，经过三国、魏晋、南北朝到隋唐，总体来讲是一个大乘的系统，小乘没有大乘兴盛。这个跟中国文化传统有关系，由魏晋、南北朝翻译讲学，逐步酝酿到了隋唐，建立了十个宗派，大乘八宗，小乘二宗。
    当时玄奘法师由长安到印度去留学，在印度依止那兰陀寺的戒贤论师学法，主要学瑜伽、唯识法相，当然也学空宗、小乘、外道的一切论著。玄奘法师很广博，学成以后回到中国，由于唐太宗的护法，设立译场，当时的译场规模很大，有一千多人，全是国库开支。玄奘白天译经，晚上讲学，主要成就是在唯识法相方面，特别是他的弟子窥基法师，直接传承他的思想。
    玄奘法师下面有十大弟子，第一个就是窥基法师，因明唯识都学得很好，他是受玄奘法师之命，把十大论师的著作糅合起来，集成《成唯识论》。他又写了《成唯识论述记》，解释《成唯识论》。窥基以后，就是慧沼，慧沼以后，就是智周。慧沼写《了义灯》，解释《成唯识论》；智周呢，解释《成唯识论述记》写了《演秘》。《成唯识论述记》、《成唯识论了义灯》、《成唯识论述记演秘》就是研究唯识的三大部，这是研究唯识必须要学的。
    学习唯识，基础的书，有《百法明门论》、《大乘五蕴论》、《唯识二十论》、《唯识三十论》、《八识规矩颂》，进一步有《摄大乘论》、《成唯识论》、《显扬圣教论》等。唯识的论著是一本十支，本就是《瑜伽师地论》，这是根本论著，《瑜伽师地论》有一百卷，为弥勒菩萨所说。将《瑜伽师地论》发扬出来的有十部论著，即：《成唯识论》、《显扬圣教论》、《辨中边论》、《唯识二十论》、《大乘庄严经论》、《大乘五蕴论》、《摄大乘论》、《百法明门论》、《分别瑜伽论》、《阿毗达磨杂集论》。
    唯识法相从印度到了中国以后，由于玄奘法师、窥基法师、慧沼法师、智周法师的继承，典著更加完备，意义更加发扬光大。当时译经的长安，是个文化的首都，越南、日本、朝鲜的僧人都来这里留学，这就把佛教的各宗派，特别是唯识法相传播出去。佛教流传，从印度到中国，根据时间的推移，唯识法相的发扬，解释佛说的唯识经典，如《解深密经》、《楞伽经》、《华严经》等，更加完备，更加精深博大，更有系统，超过其他的宗派了，小乘、大乘的空宗都比不上。这就是整个系统，是佛教的主流。

    二、唯识的中心思想，从小乘到大乘
    佛最初说法，从讲“四谛十二因缘”开始，这时主要是讲业感缘起，十二因缘，说明众生怎样流转世间，怎样出离世间。流转世间，无非是由于业。业呢就是由于烦恼、无明，无明烦恼生起，造业是由于什么呢？心！小乘的“业报论”重点就是突出这一点。唯心因果，是佛教的基本思想。
    马鸣菩萨的《大乘起信论》把心分为生灭门、真如门，由生灭门流转生死，由真如门回到解脱的境界，证得法身。这就是对于小乘思想的进一步发扬。到了六七百年间，龙树菩萨、提婆菩萨发扬大乘般若。般若就是讲智慧，有文字般若、观照般若、实相般若三种。文字、观照、实相都离不开能观智、所观境，也离不开心。中国天台宗继承了这个思想，即“一心三观”，一个心对诸法作三种观察，空、假、中，三谛圆融，都是把般若思想进一步发挥，还是离不开心。龙树菩萨有首偈子：
    诸佛出生处，
    堕地狱未减，
    成佛原未增，
    应敬礼此心。
    到了无著、世亲菩萨时代，就把大乘经典如《华严经》、《解深密经》、《楞伽经》、《胜鬘经》等等，进一步发扬，明确的提出了“三界唯心，万法唯识”。
    “三界唯心”就是指三界的业报，业、报都离不开心，唯心所造。“万法唯识”指认识一切世间的现象，离不开内心的分别，“识”就是分别的意思。“能分别”是心的作用，“所分别”也是由心观察对象的作用。在唯识学上，就是识体生起“见分”和“相分”，“见分”就是能观察、能认识，“相分”就是所认识，“相分”里面有“疏相分”、“亲相分”，“疏相分”就是根身山河大地，“亲相分”就是自己的“识”变现的影像。直接了解这个影像，我们缘的影像，不是直接对外。“见分”缘“相分”，而“见分”与“相分”都离不开心。色不离识，相不离见（相分不离见分）。也就是说外境是由识所变，你要认识它，有能认识的“见分”，有所认识的“相分”，而“相”不离“见”，“见”不离“心”。“三界唯心，万法唯识”就是说明这个道理，这个道理贯穿于整个唯识的理论。佛教不管是小乘还是大乘，中心思想讲“唯心因果”，从小乘的“业报缘起”到大乘的“性空缘起”、“真如缘起”、“赖耶缘起”，这一切缘起都离不开心。
    一般讲“诸恶莫作，众善奉行，自净其意，是诸佛教”，说明“身口意”三业以“意”业为主，意业发动身语二业，所以修行人就要自净其意。
    “意识”是心，《法句经》上讲：
    若远行独行，
    无身寐于窟，
    调此难调心，
    我说真梵志。
    形容这个“意识”，它的缘虑很远，它是单独生起来的，所以说是“远行与独行”。
    “无身”是看不到，似藏在洞里，很深。这个心是很难调的，能够把这个心给调伏下去，就是真正的修行人。
    “我说真梵志”，突出修行是以修心为主。
    在大乘空宗，龙树菩萨的《十住毗婆沙论》讲难行道、易行道，难行道要经过三大阿僧祇劫的修习，易行道讲念佛号可以生西方，都是由心。另外讲“空”，破我执法执，也是离不开心，在唯识经典中就更为突出。
    《华严经》讲：外境如虚幻，唯识与心作，若人欲了知，三世一切佛，应观法界性，一切唯心造。心如工画师，能画诸世间，五蕴悉从生，无法而不造。”《心地观经》、《大乘起信论》讲：“心生法生，心灭法灭，心染国土染，心净国土净”。《楞伽经》讲：“佛语心为宗，无门为法门”。“佛语”就是佛说的语言，以心为宗，“无门”就是不要执着，去掉执着，就是走入这个门的路径。
    “三界唯心，万法唯识”，不管小乘，还是大乘的空宗和瑜伽有宗，都贯通于这一个主题思想。这个主题思想到了唯识法相，更加有系统，并把它发扬广大。

    三、唯识学的系统
    从佛说《解深密经》、《楞伽经》的内容到无著菩萨的《摄大乘论》、世亲菩萨的《唯识三十颂》、十大论师的《成唯识论》，是有系统的，内容是一层接一层。唯识分为以下几个部分说明：
    什么叫唯识？唯识的内容如何？
    唯识不是否定一切色法，它是色不离心，境不离识，它不像一般的哲学、科学把心与物分开，它不是这样讲的。唯识，有心就有境，有境就有心，境不离心，色不离识。但是色与境，是虚妄的、幻化的，梦幻泡影，应该认识心的主要，心的能动性，在修行方面，就需要净化心灵，目的是达到转识成智。转识成智，就证大菩提，消灭无明烦恼，就证大涅槃。大菩提、大涅槃，其中心思想是不舍众生，它的修学是有次序，有阶梯的。所以，唯识者，唯即一切外境离不开心识，有识就有境，有境就有心，外境是虚妄的，要改变外境，以心为主，心能转化一切，心是主要的因，这即是唯识的意义或者宗旨。
    现在讲什么西洋唯心论、唯物论，这些思想在古代的印度和中国都有。佛家所讲的“唯识”，恰恰不是那么一回事，所以说到唯识唯心，有人认为是空虚的，不是那回事，它是个综合观点，看问题是综合的，不偏于哪方面，但要抓住根本。它的教义，细分即是唯识相、唯识性、唯识观、唯识行、唯识果。总括起来，分为两大部分：一是从事相方面来看唯识道理，二是从观行方面来看唯识道理。
    （一）什么叫唯识相
    一切山河大地，根身，这种境相为什么有呢？离不开心。相代表一切境相，代表一切事物，一切现象。心以哪几个为主体？以三能变：即异熟能变、思量能变、了境能变为主体。
    异熟能变即代表阿赖耶识（第八识），这是生命的主体识。
    思量能变，思量我，处处有个我的观点，人我，法我，这是生起无明烦恼的根本，叫末那识（第七识）。
    了境能变是前六识，即眼、耳、鼻、舌、身、意，其中对外的为粗了别，是前五识。比较细的，既对外又对内，有观察能力，由观察、归纳、推理、作出结论，是第六意识，能了解内外境。前五识了解外，第六识叫细了别，不单了别外，而且了别内。了别就是认识，认识一切境象，产生整体思想，产生逻辑的结论，这即是第六意识。
    所以“变”即离不开这三种识体。如何“变”法，又分为两种：因能变或称因缘变，果能变或称变现变。
    因能变，就离不开种子，你说了话，做了事，发生了作用，就熏习成种子，这个能力是潜在的。所以我们说业力，是指你造了业，就有一种力量，这种力量就是一种潜伏的、潜在的势力，就成为种子，这个种子条件一成熟，就可以感果，感报。有因有缘，又叫因缘变。
    佛教讲，我们这一期生命完结以后，还有种子存在，业力存在。种子又分为：等流种子、异熟种子。等流就包括物质和精神，物质的就是相分种，精神的就是见分种，由于善恶性质不同，善因成为善种子，成熟以后，感得乐果，恶因成为恶种子，成熟以后，感得苦果，平等流类，没得错乱。这即是等流种子，也叫做名言种子（分为表义名言和显境名言）。
    第二是业种子，就是由于第六意识强有力的作用，由于这个作用，作为增上缘，恶业善业，力量不失，到了成熟的时候，感得果报。在唯识学来讲，人，经过生有这个阶段以后，到了死有，又经过中有，在将要生的时候，由于业种子的激动，业种子激动识种子，识种子又激动大种子（地水火风四大、相种）。感得十一个色法，六根六尘，对内来说即有根身，对外来说就有世界，根身是不共种，世界是共种，分得很详细。不共种中有“不共中共”，共种中有“共中不共”，这样，就是“内有根身，外有器界”，离不开异熟种子的感生，离不开阿赖耶识的种子。种子即分为这两类，因缘成熟，即内变根身，外变器界，这是从现象本体来讲的。为什么会有这些现象呢？本体离不开识，识中就有种子。
    现代的物理科学家爱因斯坦讲，质能互变，能可以变质，质可以化为能，它完全通于唯识道理。能，就是一种能力，潜在的能力，一切山河大地，没有能力，地球都不会运动。能可以变质，质可以化能，种子的道理跟这个差不多，种子即是能嘛，一切现象就是质，能可以变质，质转过来又可以形成能，循环不断，就像车轮一样。为什么有这些现象，即是本体：心识，能变的心识，还有主要的种子。从现象看到本体，一切唯心造。这即是现象论，本体论。
    从认识论来讲，识生起来以后，它会有能认识，所认识，唯识学上即是分为：见分、相分、自证分、证自证分，四种作用。相分是所缘，见分是能缘，自证分就是能缘的体，证自证分是认识这个缘正不正确，是一种反观作用。所以识体生起来以后，就会有：相分、见分、自证分、证自证分，而其中最重要的，对内对外，是见分和相分。
    在认识方面，离开了见分，离开了识体，你就不晓得一切事物的存在。孔子说：“心不在焉，视而不见，听而不闻，食而不知其味”，心不在，哪怕外面是电闪雷打，地动山摇，你心不在，你就不晓得，没有认识。所以物体、现象、认识它，离不开“识”，识离不开种子。所变就是根身和外面的现象，及识体产生的见分、相分，都是所变。《成唯识论》中讲了很多这方面的内容，意义比较多，有系统，当然其中还有一些争论。
    唯识新派和唯识旧派，对于种子是新熏的，还是本有的；识生起来的，是四分，还是三分、二分等，识体与种子的一异等争论很多，但是十师中正论是护法论师，《成唯识论》代表护法论师的论点，比较完备。
    （二）什么叫唯识性
    唯识性，有三性三无性，结归到真如性、圆成实性。三性即是把世间法、出世间法归为三种，即：遍计执性、依他起性、圆成实性，概括了世间、出世间、有漏、无漏、染、净。世出世间法虽多，总括就是三性。
    为什么叫“遍计执”呢，它是虚妄的，众生执着我，执着法，认为有人我、法我，实际上没有，但是众生普遍执着，所以叫“遍计执”。
    “依他起性”就是因缘生法，有两起，一种是“染污依他”，一种是“清净依他”。“染”就是妄心，由“妄心”生起的现象，有执着。“清净依他”就是从开始皈依佛教，闻熏正法，就慢慢转为清净。染污依他是有漏的道路，清净依他是无漏的道路，逐步转识成智，那么在“依他起”法上，逐步的把染污清除，转为清净，转成“圆成实”。
    “圆成实”的圆，就是指真如性是普遍的，成即是其性常住不生不灭，实就是真实不虚，非如外道的神我，这个性就是真如性、法性、佛性。彻底认识这个三性，必须建立“三无性”。
    三无性就是相无性、生无性、胜义无性。“相无性”就是在一切法上，是没实我、实法相的。生无性，就是说一切法因缘生，不是上帝生，也不是自然生。胜义无性，就是达到我空、法空，证入胜义境界，由二空显现真如，即是胜义无性。
    （三）什么是唯识观
    接下来讲唯识观、唯识行、唯识果。唯识观主要是五重唯识观，就是说观察事物有五个标准。
    第一观，遣虚存实。遣除虚妄的，保存真实的，服从真理，这是虚实相对观。在三性中，认识遍计执，是虚妄的，都是众生的执着。实，是依他起，是幻有、假有，但是不能否定因果存在。圆成实，就是断一分烦恼，就证一分真如，也即诸法空性，佛菩萨的胜义境界。
    第二观，舍滥留纯。唯识，以识为主，不要以相为主，相是虚妄的，是附带于心识而产生的。舍相分，你应该看清它，舍弃它；留纯，以识为主，识体，自证分；见分是属于主体的东西，不要执相，要保存心体和见分的作用。一般的唯物论，客观经验论，主要就是看到相，没有看到心的作用，把根本舍弃了。这就是舍滥留纯，也就是心境相对：能缘的心，见分；所缘的境，相分；其中相分是附属于心，附属于见分。应该看到主要的，看到根本，叫做舍滥留纯。
    第三观，摄末归本。本是识体，是心；末是见分、相分，识体生起来的时候，认识外物，它有能缘的见分，所缘的相分，能认识，所认识，所以说识体才是本。见分、相分是末，既不能偏重于相分，也不能偏重于见分，认识见分、相分的产生离不开根本的识体。这即是摄末归本，体用相对，从体到用的一个认识。
    第四观，隐劣显胜。什么是胜？什么是劣？胜就是心王，劣就是心所，讲心就包括心王心所。八个心王，五十一个心所，都叫唯心，但是中间分为胜与劣。心所是依心王而生，与心相应，它不占主体，它是一种附属的东西，隐劣显胜，心所是劣，胜是心，学唯心，首先就要见到心，八识的心，是心王，抓住主要。这就是心王与心所胜劣相应。
    第五观，遣相证性。遣什么相？遣依他起相，学佛就要由有漏转为无漏，由染转为清净，就需要遣相证性。依他起相就是妄心显的妄相，是有漏法，我们必须熏习无漏法，逐步把染污种子遣除，转为清净种子，证入真如实性、圆成实性。这才是究竟的。
    所以说，观察唯识的道理，必须从五个方面来观察，叫五重唯识观。遣虚存实，虚实相对；舍滥留纯，心境相对；摄末归本，体用相对；隐劣显胜，王所相对；遣相证性，事理相对。也就是说处处要抓住根本，归于“三界唯心，万法唯识”这个主体。众生境界、普通学术界说相就忘心，这就与唯识的宗旨恰恰相反，就不能修行，不能作正确观察。
    （四）什么是唯识行、唯识果
    唯识行分为五位：资粮位、加行位、见道位、修道位、究竟位。唯识行包括《华严经》的五十二位，即是菩萨修行要经过五十二位：十信、十住、十行、十回向、十地、等觉、妙觉。
    1. 资粮位
    积聚资粮。是一种渐进的阶梯，与人生佛教、人间佛教是相合的。由人乘到佛乘，它不是顿教，顿教是一步到位，一步登天，它是渐进式的，做人，把人做好，逐步升华。资粮位重点是以信为主，而这信呢，又离不开修福修慧。修福就是积累福德，做好事，修慧就是多闻熏习，福慧双修，学佛人在受了三皈五戒以后，要建立正信、正见、正行，积累福德智慧资粮，这是先决条件。这包括《华严经》的前四十位：十信、十住、十行、十回向，十信就是建立信仰，十住就是保持正念，十行就是利益众生的行动，十回向以功德回向众生。这些都是资粮位里面的。
    2. 加行位
    修止观，加功用行，勤修止观，就是说要把我们的虚妄意识转过来，对事物作出正确的认识，去除执着。唯识的加行位就是以四寻思观，四如实智，中间产生四种定，经过暖、顶、忍、世第一位而入见道。
    暖就是初步得到法喜，了解“三界唯心，万法唯识”这个道理后，得到法乐，全身很暖和了，在定中很暖和，叫暖位。这个定就叫明得定，就是得了智慧，认识正确的道理。
    顶就是进一步发挥，相当于人爬山，爬到了山顶，可登高望远。这个智慧进一步增长了，叫明增定。明得定，是起初的了解，一切所缘、外境都是虚妄的，不离心；明增定就是进一步增长了这个智慧。
    第三，印顺定，就是进一步由所缘的境不实在，一切唯心，所缘不可得，所缘空，观心亦不执着，能缘的心也空，这就是印顺定，即进入了忍位。忍，就是对法义得到认识忍可了，进一步坚定了，叫住忍位。
    第四，世第一位，无间定。什么叫无间定呢？接着印顺定之后，不间断，刹那相续，对于所缘空、能缘空，所缘的境界不可得，进一步了解能缘的心也不可得，能缘所缘都空，得到一个综合的认识，叫无间定。
    暖、顶、忍、世第一是加行位。止观双运，空除了所缘执、能缘执，能缘所缘都空。唯识讲空，讲心要空心，你对主观的执着都是不行的，就像般若讲空一样，空还要空，空空，唯识也是这样，讲一切唯心，所缘是虚，空！讲心也不要执着心，能缘空，能缘所缘都空，所取能取空，就可以见唯识真理，到了这个境界，就是无间定，进一步进入见道位，等于是禅宗的开悟境界，见到了真理。
    3. 见道位
    就是一种证悟境界。这个证悟是渐进而来的，不是一步登天的。见道位就是见到真空，进入能所俱空的境界，就是虚空粉碎、大地平沉的境界。见道位以后就是初地，开始进入修道位。
    4. 修道位
    从初地到十地，叫修道位。为什么叫修呢？第一地，见了空的道理，叫欢喜地，明空的道理，得到法喜，但是进一步需要修、要实践，要解行并重。在初地除了断掉分别所生的烦恼障、所知障以外，本来自己与生俱有的、先天的烦恼障、所知障，也要进一步把它现行和种子给除掉。所以必须要修。
    以后是离垢地、发光地、焰慧地，就是勤修戒定慧；离垢要修戒、要持戒，不持戒你是不能离垢的；发光，就必须修定，定力加深，定光发现，智慧就生。
    极难胜地，总修胜义、世俗二谛圆融，艰难而殊胜。
    远行地是第七地，要必须经过长时间的加功用行，观因缘生法自性如幻，修无相行，叫远行地。
    第八地是不动地，观缘起性空，此时无功用行，是自然而然的。
    七地以后，俱生的我执和烦恼障基本得到了摧伏，我执的现行和它的种子基本断除，但是从八地到十地，俱生所知障的种子还是潜伏着的，还是需要继续修。初地是由后天的分别、邪师邪见导致的烦恼障、所知障，在初地就伏了，但是与生俱有的、无始以来的烦恼障、所知障，必须继续摧伏到第七地，把俱生的烦恼障现行和种子伏除了，而所知障的种子还在，第八地以后，很微细，必须继续修，到第十地，经过金刚道，就把种子全部斩断，进入等觉、妙觉，这就是佛位。
    生死分为两种生死：分段生死和变易生死。分段生死就是受业报，一生了一生接着来，七地断烦恼障就脱离了分段生死，但是所知障的种子还在，还在生，还在灭，这叫变易生死，这是八地菩萨以上的境界。必须到了金刚道以后，证入佛位，才能除变易生死，就完全脱离生死。《成唯识论》里把这个道理讲得很详细，修什么，除什么惑，什么叫俱生惑，什么叫分别惑，现行到哪里伏，种子到哪里断，证什么真如，讲得很详细。
    5. 究竟位
    就是证到了佛果，在唯识来讲，转识成智，转烦恼障证入涅槃，转所知障了解二空，证得菩提，这就是佛的境界，即是究竟位。
    唯识五位就是依次序来的，资粮位、加行位、见道位、修道位、究竟位，包括了《华严经》的五十二位：十信、十住、十行、十回向、十地、等觉、妙觉。这就是唯识行、唯识果，分分断惑，分分证真，断一分惑就证一分真，踏踏实实的，你若不是依这个道路来，哪怕你修止观，也要走邪路。
    所以佛家修行和断惑，它与外道不同，与世间不同，为什么不同呢？重点就是破我执、法执。烦恼障、所知障的种子也要消灭，达到这个目的，你不这样走路的话，妄想马上由禅定得神通，那你就是外道，结果走火入魔，就出现很多怪现象，像狂乱、神经病都出现，这就是没有把根本抓住。所以佛法讲资粮位，坚定信心，修习福德智慧资粮，一步一个脚印来，这是真正的修行。修四加行，修止观，是正确的，不能舍本逐末。
    唯识法相上的五位跟后来太虚大师讲的人生佛教、赵朴老提的人间佛教是完全相合的，它是由人生完成人格，发菩提心修菩萨行，作为成佛的基础，这就是唯识行，也包括唯识果。

    四、唯识理论的建立
    建立唯识理论，是由因明学来的，要懂因明。十大论师的陈那论师，是因明学的祖师之一，写了《因明正理门论》（在陈那之先，由商羯那主写了《因明入正理门论》）。它是根据事实、根据道理来建立，来显出真理，它不是乱说的，要合乎因明嘛，现在讲要合乎逻辑，因明主要是根据八法，自悟悟他，来建立逻辑，建立论理，八法中有四法是衡量自悟，有四法是衡量悟他，你自己都没有悟，没有根据，怎样去悟他呢？
    自悟是哪几种呢？真现量、真比量、似现量、似比量。现量是根据现在实证，现证现知，这个现量不像现在实验的科学，只见到物质一边，现量的内容很宽广的，包括五俱现量、意识现量、自证现量、瑜伽现量四种。
    五俱现量就是根据五根（眼耳鼻舌身）现量所证。
    意识现量就是结合眼耳鼻舌身同时意识，正确的观察，得到的结论。
    自证现量，就是说如人饮水，冷暖自知，自己证得了悟的境，真实不虚。
    瑜伽现量，就是你所见的，与佛的真理，与涅槃菩提、与佛的教理行果都相应。这个现量现证就比唯物的科学宽得多了。假如违反这一点，就是似现量，是相似的，假的。比量就是根据已知得到未知，比如你看那座山，若是起了烟，起了雾，就知道要下雨，或者晓得那里有人家住，推理而知嘛。在道理上来讲，是由因知果呀，种了什么因，得了什么果。你要晓得你的过去，就看你的现在，你要晓得你的未来，也要看你的现在，由因知果。正确的推理，这就是比量，假若不根据正确的推理，以相似的观点来推，就是似比量。
    你若没有这个基础，不懂真现量，真比量，那就是妄见妄断，你自己都搞不清楚，怎么能够引导其他人呢？不以盲引盲，这个阶段，叫自悟，这就是八法中的前四法，是属于自悟方面的。后四法就是悟他，悟他是建立什么呢？有三支比量。真能立，真能破，似能立，似能破，能立能破，立中有破，破中有立，就要靠三支比量的论式。起先是五支比量，后来到了陈那论师，总合起来叫三支比量，即宗、因、喻，陈那论师把原来五支的合、结归到喻里面，就成为三支比量。
    第一支，宗，即是主张，论点。
    佛法讲一切法无我，一切法无常，人生是苦，都是个主张，这叫作宗，宗，就是个主题、论点。
    第二支，因，就是要举出道理。
    宗是论点，因就是论依，依就是依据道理，不能乱说，是依据道理而得来的。譬如说诸法无我，这是个论点，依据什么呢？它的因是什么呢？因是缘生无性故，因缘生法，没有实体，无主宰，不常住，这个就叫因，叫论依。
    第三支，喻，就是论据。
    论据是什么呢，就是要举事实，什么事实呢？《金刚经》上讲的“梦幻泡影，如露如电”，都是事实。
    再举个三支比量来说，一切唯识现，这是宗，因是什么呢？因外境虚妄故，所有外境都不实在，都是唯心所现，是虚妄的。论据是什么呢？譬如有目翳人看到眼前有花，有影子，有种种东西，这就是喻。唯识的论据，根据因明来讲，一切都是由论点、论依、论据，最后作结论。这就是三支比量或叫做能立。
    三支比量，立了以后，就可以破敌人论点，立中就有破，不然你就不能破斥，说一切无常，就要破他的常见，说一切法无我，就要破除我见，若是真能立，就可以真能破，假若反过来说，相似的，不真实的，叫似能立，似能破，你就不能破他。若要细分，这个论点、论据、论依，假若错误了，就有很多过失，因明学上，宗方面错了，就是九种过失，因方面错了，就有十四种过失，喻错了，就有十种过失。在语言上产生过失，你不但不能破别人，你自己的论点都建立不起来，还能破别人吗？所以因明学，组织很严密，建立论点、根据，还要举出事实，这样才能够能立、能破，才能悟他。
    唯识学根据因明的发挥，既不违反事实，也不违反真理，合乎真理，合乎事实，就把佛学这个“唯心因果”的观点阐扬出来了，这就是唯识的特点，这个特点，是其他宗派没有的。
    玄奘法师学了因明，他后面的窥基法师、慧沼法师、智周法师都擅于因明，印度的陈那论师，是建立因明学的。这就是唯识学的特点，是结合因明来讲的。书籍就有：《因明正理门论》、《因明入正理门论》、《集量论》等，汉文藏经有，藏文的藏经也有。玄奘法师把这个更加发扬广大，他在印度留学的时候，他的《真唯识量》，在曲女城，万人以上都没有能破掉，有小乘、有外道、还有大乘的人，没有一个人能破。这以后，他的声誉很高，小乘尊之为解脱天，大乘尊他为大乘天，受到万众的恭敬。

    五、唯识学既通于现在，更胜于现代
    为什么这样说呢？现代社会讲人本主义，讲科学，科学就主张实验、分析、归纳、判断，不轻信，不轻易下决断。而唯识的系统，他的理论的根据，恰恰就是这个方法，它不是懵懂的，三界唯心，万法唯识，是需要说出道理的，它根据因明，有分析、有归纳，举出事实，所以现在的大学中的研究院，研究唯识的不少。现代的科学发展，用科学方法观察事物，完全有关系，可以说出道理，要能说出所以然，若知其然而不能知其所以然，就不行。
    那么，它胜于科学的方面是哪些呢？心物综合，谈唯识，并不是离开色，离开境，有识就有色、就有境，有见分就有相分，色不离心，见不离相，综合的观点，就胜于科学了，而且对于唯物论、经验论还有指导思想，可以纠正一些偏向。譬如说现在讲究物质，讲究自然科学，专门在物质方面发展，结果人心偏向，私心杂念多，就破坏了物质，破坏了自然，破坏了人与人的关系，不融洽，就发生社会染污、环境染污、水源染污，什么都染污。清除这个现象，物与心不能分离，要有理性、德性，发挥人生价值，来应用这个物质科学，纠正他的偏向，若不纠正偏向，只是从物质、经济发展，结果人欲、我执心更重，形成争斗，于是乎，国家的建设偏于军事，世界强国的建设，都偏于军事，大力生产原子弹等等，竞争就越来越激烈，文化教育建设，都赶不上军事建设，人们生活就会很困难，整个世界就会混乱！
    发展军备，发展财富，这个财富又掌握在少数人手中，所以要真正纠正这个偏向，必须要以唯心因果的道理，以精神驾驭物质，以唯心的道德使科学的偏向得到纠正，走上正路，使它发展，能够使人们生活提高，物质丰富，这是正路，这就离不开佛教唯心因果的道理。潮流的正常发展，只有这个方向。

    附问答
    （备注：听完惟老将近二个小时的对于《唯识学在佛法中的地位》深入浅出、圆融无碍的讲解，弟子正根提问如下：）
    问：唯识学的思想是不是贯穿于整个佛教所有宗派？所有宗派均是以唯识学思想为基础，只是形式不一样而已？
    答：对的。不管小乘、大乘，性宗、相宗，它都是以唯识学为基础。我刚才所说：业感缘起，业，行动，行动又由无明烦恼，烦恼又由意识，都是讲识，要净心，诸恶莫作，众善奉行，自净其意，也是以意识为主，有意就会发动身业、语业。

    问：既然唯识学的思想是贯穿于整个佛教所有宗派，但是如今唯识宗派却并不兴旺，那么如何才能让唯识宗派更好复兴？
    答：由于唯识理论比较高，比较深，书比较多，中下水平一般就不适宜。但要如何发展呢，一是观点要正确，要有八宗平等的思想，这是太虚大师提出来的，不要有所偏向；第二要看主流，佛教的主流是什么，唯心因果；第三要普及，通俗普及，那么这方面的读物就需要很浅显，由浅入深，有基础读物才行，这需要努力。

    问：是不是可以这样讲，如果把唯识思想学通了，其他各个宗派的思想就一通百通？
    答：是这样子的，它有连带关系，一通百通，你若晓得什么是业感缘起，什么是性空缘起，什么是法界缘起，把唯识学通了，它都是一致的，八宗平等，到了那个悟的境界，就一条道路，你看密宗到了大圆满境界，都是这个道理，悟得空，所以一通百通。

    问：我学修的体会是：如果对其他宗派的道理明白一些，也会有助于唯识学的学习？
    答：这是可以的，相辅相成，不能脱离，百川归大海嘛。

    问：唯识学门派在国内其他地方还有没有传承？
    答：有。各个佛学院都在研究唯识法相，各个大学、国家的宗教研究机构研修唯识比较有系统。现在应该怎么作呢？重点是要做普及工作，普及于一般的群众，要通俗化、大众化，目前这个工作做得很差。

    问：现在学习唯识学，看到的一些书籍，全是文言文，加上各种名相，根本就搞不懂。应该怎么办呢？
    答：这就需要通俗化。用语体文来解释，把唯识的基础书用语体文把它翻译出来，普及于大众，这是很重要的，但这个工作目前还没有人做。

    2004年7月21日讲于重庆慈云寺
    正根记录整理


唯识法相问答

    问：唯识法相所明何事？有何重要意义？
    答：唯识法相系说明染净因果缘起事，此因果缘起不离于心。佛法重点是指出心灵的修养，达到心灵净化，证得解脱。无论大小显密，尽管修法不同，但都不能超越此中心。
    唯识法相之重要：第一，有六经十一论的根据，有完整而精密的系统。第二，以因明立论，富有逻辑性，不落于空虚玄谈，有文化底蕴和科学头脑的人，会深感兴趣，明白佛法确是伟大的真理。

    问：谈唯识是否拨开物质？
    答：谈唯识不拨有本质尘（又名疏所缘缘，即外在物质），但此本质尘亦由本识（阿赖耶）种子之所变，种子随业力而现行。识变不离因缘，非上帝生，非如主观，客观唯心论所说，片面而不可靠。

    问：何谓唯识？
    答：唯者，遮止义，简别离心之实有不变的外境，此外境非有。识者，指八识及心所，表显此心识非无。以外境如幻非实故，内心存在而相续不断故。既破人我执，又破法我执，而建立无我的真空智。

    问：何谓法相？
    答：法的定义：持存自性，轨范他解。此范围较广，无论具体的、抽象的，言论上可以言说的，思想上可以思想的，事物上之有无，皆称为法。
    相有三义：相貌、义相、体相。
    1. 相貌：眼能见，同时意识能了别之色，如显色、形色、表色等。
    2. 义相：意识上能了解之相，谓意识所分别、思维、判断。此为第六意识，第七末那识所取之相（第七末那识为隐微之我相）。意识所了宽广，末那唯执我，故简略。
    3. 体相：最单纯实体之感觉，只适用于前五识，非第六意识。
    在三境中，相貌、体相，通于性境；义相，通于带质境，独影境。
    法相者，即所知一切法之相貌，义相乃至体相。所知即是被知，能知谓人类及其他动物心灵的能了知作用。

    问：唯识与法相的关系怎样？
    答：太虚大师说：“法相示唯识之所现，而唯识所现即一切法相；唯识立法相之所宗，故法相必宗唯识”。法相纷呈，不离识变，能所主次分明，故简言之：“唯识必摄法相，法相必宗唯识”，这是弥勒瑜伽学的真义。

    问：唯识讲识变，变的定义如何？
    答：这种变，不是戏法上的变，而是有因果规律的变。
    1. 讲变不离识体，三能变中，第八识为异熟能变，第七识为思量能变，前六识为了别能变。
    2. 能变的根本原因是种子，即含藏在阿赖耶识中能生起有漏无漏诸法的潜伏功能（染种和净种）。
    3. 种子分两类，即等流种和异熟种。善、恶、无记三性的因，产生三性的果，性质不杂乱，平等流类，故名等流。异熟种亦称业种，由善恶业力熏，成为感果的助力（增上缘），异类而熟，故名异熟种。印顺法师谓等流种为质料因，异熟种为组合因。
    等流种又称名言种子，由第六意识能诠表义理的名句文所熏成名表义名言；由前七识缘境所熏成名显境名言。前者成为见分种子，后者为相分种子。
    4. 种子遇缘生起现行（种生现）；现行复熏成种子（现熏种）为同时因果，未遇缘时，种子一类相续，为异时因果。
    5. 以上种现生熏为因能变。八识体生时，缘境生起见相二分（见分是能认识的作用，相分是所认识的影相），名为果能变，以识体为种子所生果故。
    6. 因能变又名因缘变、生变；果能变又名变现变，缘变。
    《成唯识论》云：
    “阿赖耶识，因缘力故，自体生时，内变根身，外变器界；即以所变为自所缘，行相仗之而得起故”。
    这段论文，包括了因能变和果能变两义。简释如下：
    因能变：业种→识种→大种（内：根身；外：器界）
    果能变：识体→见分→相分
    依现代物理科学讲，能与质可以互变，即能力变成物质，物质也可转化成能力，唯识学的种现生熏，可以此比例，做出正确认识。

    问：五蕴中的色蕴，百法论第三类中的色法，其定义和内容怎样？
    答：依正义讲，色以质碍为义。但依广义讲，色法包括：1. 有见有对；2. 有见无对；3. 无见无对三类。
    此三类又摄在十一种色法（五根、六尘中）。
    第十一尘法处所摄色，实为意识所取色，为眼等所不能见，如化学上之电子、原子、基本粒子；天文学家所推想之宇宙之类等。
    法处所摄色有五种：1. 极略色，谓分析有质之实色至极微处故名；2. 极迥色，谓推测虚空明暗等无质之色，至极远处难为达见者故名；3. 定所引色，谓禅定所变现之色声香味等境；4. 受所引色，又名无表色，谓受戒时动作上言语上受感动而得成戒体故名。5. 遍计所执色，谓于意识假想上虚妄计度执为实有，如执我相法相，执有神我及创造世界之上帝等。

    问：何谓唯识中道？
    答：唯识中道，依遍计执、依他起、圆成实三相建立。此三相包括世出世间，染、净、有为无为诸法，实为佛教完整的宇宙观。
    1. 遍计执：谓义相之颠倒妄相，如我相、法相、常相、断灭相等。
    2. 依他起：依因缘和合所起之有为相（相对性的）。
    3. 圆成实：谓证得二空所显的圆满成就真实不变之体相，亦名真如法性（绝对性的）。
    此三相中，遍计非有，依他幻有，圆成实胜义有，亦有亦空（即妙有真空），非空非有（即依他，圆成非空，遍计非有），是名中道，亦即诸法的实相。

    问：何为唯识之行？
    答：若能通达万法皆不离识，依多闻熏习，缘法义为境，以四种寻思（名、义、自性、差别），四如实智（如实了达四种寻思），渐修五重唯识观（遣虚存实、舍滥留纯、摄末归本、隐劣显胜、遣相证性），登地破执，广行四摄六度大菩萨行，历十地而至金刚道，断二执、破二障、证二空，入究竟位，圆成佛果。
    复次，破我执法执，证唯识性（即圆成实、真如），决非知见狭小而欲速（一身即成就）者之所能为。若我、法执未断而恣谈成佛，则当知是魔。若我执、法执已破，则佛且不言成，何迟速之有？行菩萨道，是真菩萨，必勇猛精进，得大无畏，难行能行，难忍能忍，一念万年，万年一念，不问劫之长短，究竟圆满菩提，能证所证，俱无所得。观音、地藏、弥勒之愿行，大心之士，应如是学。

    2003年8月地藏菩萨圣诞日


唯识种子义

    修学佛法首先要具足智慧，智就是不迷惑，崇尚真理，这绝不是一般世俗人所讲的迷信。有智慧就必须有正见。什么叫正见？即正确的见解，有正确的见解才有正确的信仰，也才能巩固正信。这种正见不是世俗之见，是佛说的缘起中道之见。持有缘起中道见者，一方面相信因果，另一方面具足无我慧（空慧）。相信因果就不落于断灭论，具足空慧就破除常见论。一方面破除断见，一方面破除常见，即妙有不离真空，真空不离妙有，这就叫中道之正见。故佛成道后，讲四谛八正道，在八道里第一就讲正见，这就说明正见的重要。
    正见如何产生？须修闻、思、修三慧，特别是闻熏，多闻熏习。《华严经》里记载的善财童子“五十三参”，依次参学五十三位圣者，读诵经典，亲近善知识，如此才能把世俗之见改为正见。故唯识学的种子熏习的道理，非常重要。
    唯识学讲“转识成智”，凡人之识有分别、妄情、迷执，转为智后就消灭了虚妄分别，远离颠倒妄想，消除了执着（我执、法执），这样才能达到转识成智，才能解脱，最终证得佛果。故必须要闻熏正法，熏习成为一种清净种子，逐步消灭染污（有漏）种子，逐步增盛善法（清净无漏）种子，最后就会真正转识成智，完成佛果。《法句经·多闻品》言：
    多闻令志明，
    已明智慧增，
    智者博解义，
    见义行法安。
    即说能够多闻，你的志向就明确了，善恶、是非就有比较了，就能走正道，有利于人，有利于己，故说“多闻令志明，已明智慧增。”你能够自己明确增加了，就可从智慧中体验一切，了解真理，故第三句说“智者博解义”,即有智慧就可很广博地解释一切道理。“见义行法安”就是见真理了在行动方面就如理如法。安是得到心安、身安，不单是自己心安、身安，也可使别人达到心安、身安。若人有烦恼、痛苦就得不到心安、身安、故此偈赞扬多闻，是佛说的法语。

    一、种子六义
    （一）种子定义
    一定的条件可产生现行果。就如春天种的各种植物种子，遇到人工、土壤、肥料、雨水等因缘，逐步发芽、开花、结果，这就是种子的力量。此种子为因，产生结果就是果。亲生自果就是某种因产生某种果，因果不杂乱。具体的讲，摄藏于第八识中能够亲生自果的潜在功能就叫种子。潜在力量可以推动生命的发展，推动事物的发展，世界上各种现象均离不开种子。如现在物理学讲，没有能就不会产生运动。没有运动，事物不会产生和发展。唯识学里讲的种子就类似于这种能。唯识学讲：有种子才有主观世界和客观世界，即包括精神界和物质界。精神界相当于有情的受、想、行、识，物质界是指色身及大地山河，宇宙万有，这些都离不开种子。种子是主因，其特性有六个方面（又称“种子六义”）。
    1. 刹那灭，即种子的自体一定是刹那生灭的有为之法，有生灭转变，才能结果；反之，就无果的产生。这是从时间上讲。
    2. 果俱有，即因与果同时和合而有，简别前后相生以及相离的他身等，非异处异时。如春播种、发芽、开花、结果是一步一步的，有因就有果，因果不相离。在佛教讲有修就有证。念一声佛，拜一拜佛，读一卷经，做一件善事，种因时就有果在里面，种一分因同时就有一分果，一分一分地积累，最后就圆满了。
    3. 恒随转，即种子恒时一类的相续，没有间断，没有变异。简别非如七转识，因七转识有间断转易，不能生果。
    4. 性决定，其体性是决定了的，善、恶、无记、有漏、无漏等性各别，不能混淆。由同类因产生同类果，简别异性不能为亲因。
    5. 待众缘，即等待所有条件（众缘和合）才能产生现行，简别非一神、非自然。
    6. 引自果，即决定后，什么性就感什么果，善性感善果，恶性感恶果，有漏性感有漏果，无漏性感无漏果，色法种产生色法果，心法种产生心法果。这是同类因引自己的等流果。
    （二）种子的种类
    1. 以有漏无漏来分，流转生死的有为法熏成就是有漏种子，属于解脱法门熏成的就是无漏法种子。有漏即有烦恼，有变化的；无漏即清净不变的。
    2. 以善、恶、无记此三性来分，善性有人天善、解脱善、菩萨善。人天善即修五戒十善法，解脱善即修戒定慧的解脱行，菩萨善就是依悲愿心修六度四摄等。恶性就是五逆十恶，如杀父、杀母、出佛身血，焚毁寺庙，破和合僧等。十恶即杀、盗、淫、妄等。无记就是非善非恶的中庸性。
    3. 名言和异熟种子，凡是可以用语言文字了解的，属第六意识的范围所熏成的种子叫名言种子。名言就是表示能依文解义，包括概念、推理、判断。某种概念和思维熏成了某一种潜在的种子，此限于第六意识，叫表义名言。另有显境名言，指前七转识，前七转识有缘外境的作用，由缘境意识所熏成的种子。此种子性能很强，作为增上缘，能助长将来感各种异熟报果。由引业感总报，满业感别报。
    （三）种子的来源
    此在唯识学分三个派别，佛示灭之后一千年左右，唯识学很昌盛，解释世亲菩萨的《唯识三十论》有十大论师，其中：
    1. 护月论师认为种子，无论有漏无漏种，善恶种都是本有的，所谓本有者就是生性带来的，先天有的。如中国儒家孟子讲，人之初，性是善的；荀子讲，人之初，性是恶的。护月论师说，熏习只是增长养成本有种子而已。
    2. 难陀论师主张新熏，一切种子都是后天熏的，人生来是一张白纸，把它涂成什么颜色，就是什么色。后天的熏习，如遇邪师恶友就熏习恶法，染法；亲近明师善友就熏习善法，清净法。他说，能熏与所熏无始以来就同时存在，种子又名习气，说明由熏而有。
    3. 护法论师，主张既本有又新熏，种子既有先天的，又有后天的。如佛性，佛性本有，众生都有佛性，一直延续到佛果位，佛种都保持着。由于众生境界累劫以来，被无明障蔽，若学佛多闻熏习，净种增长，恶种逐步消灭，佛性种就开发了，这就由于新熏。其中有理佛性和行佛性。理佛性就是本有的，行佛性就后天熏习的。行即修行，修行就必须多闻熏习，佛性若本来没有就无从开发。如开金矿、银矿，矿里本身没有金、银，你再开发也没有。众生本来有佛性，但由于无明障蔽了，经明师善友指示，精进修行，佛性就能开发出来，使一颗灵珠（真性）放光。若遇邪师恶友，听了邪教，恶教就熏成了恶种子，佛性被越盖越厚，流转的时间也就越来越久。本有种子叫本性住种，新熏种子名习所成种。这是护法论师的主张，比较圆融合理。
    （四）种子熏习
    能熏与所熏各具四义，方有作用。
    所熏即被熏习的识体，在八识之中只有阿赖耶识才是被熏，因根本识能含藏种子。其自体必须要具备四个条件：
    1. 坚住性，即从始至终，其性质一类相继不断，没有变异，此简别不是前七识和色法等，有变异故，非坚住性。
    2. 无记性，即非善非恶，若是善则不能容恶，若是恶则不能容善。
    3. 可熏性，即本身是自在又不是一种常住坚密的实体，没有自在的假法和常住坚密法就不能受熏。如依于他起的心所法。色法和坚密常住的无为法都不能受熏。
    4. 与能熏和合性，所熏的体与能熏的现行是同时同处和合不分离，反之则不能受熏。如讲经说法，说法者与听法者和合无间才能接受。
    能熏法的四个条件：能熏法即前七识现行能熏成种子，其条件是：
    1. 有生灭，即有为生灭法，刹那刹那的转变，若无生灭转变就不能产生现行果报。
    2. 有胜用，谓有能缘而强胜的作用，能缘的作用就是心和心所法，强胜的胜用就是心和心所法的善性、恶性、染污性，如此就有熏种能力。
    3. 有增减，熏善，恶法即减；熏恶，善法即减；熏无漏法即有漏法减，熏有漏法即无漏法减，无增无减就不能为能熏。
    4. 与所熏和合性，谓前七识现行时必须与根本识同时同处互相相应，这样才能产生种子，两者非相隔相离。
    （五）熏习之相
    即见分熏、相分熏。见分属能认识，相分属所认识。前七识在现行中就熏成此二分的种子。见分熏主要指第七识，因第七识我执很重，处处有我见，即有我痴、我爱、我慢等。相分熏主要指前五识在缘外境过程中熏成的，称相分种。第六意识既有见分熏又有相分熏，因第六有了别内外的作用，所产生的种称见分种，另有相分种。由此就成为主观的认识和客观的存在，主观的认识即由于见分熏产生的见分种，客观的存在包括根身器界以及亲相分等都是由于相分种而有。故说从我至山河大地，从精神到物质现象一切不离心。

    二、种子与识的关系
    就体用讲，种子是第八识体上的作用，摄用归体都属无记，故体用非异。若体用别论，种子为三隐伏，现行果已显现，则非一。

    三、近代佛学者对于种子的认识
    （一）支那内学院欧阳渐（又名欧阳竟无）先生提出：1. 种子是一种能，此能既不是心，也不是色，遍于宇宙，故起念时，种子现行，一念即可包括全宇宙。2. 种子起现行的时候，相分不离见分，见分代表识心分别，识心分别的发生就摄尽全宇宙，其中就没有大小之分，小可入大，大可摄小，故无一处不是法界，此与天台宗的一念三千相同。3. 了解种子真谛，必须依靠止观，入见道后初地以上菩萨方能够契证。
    （二）闽南佛学院田光烈教授提出，种子是一种功能，一种力，是亘万古不变，充满宇宙的。种子生现行，现行即是宇宙森罗万象，各式各样的事物。现行是果，种子是因，由果溯因，可知种子就具有生命性、运动性、能变性、能化性、综合性、整体性、全息性、全能性、全知性、染净性、善恶性、超越时空性。又以现代科学讲，形成了电磁场、功能场、信息场等，这些场都离不开种子，故种子是超载时空，超越心物界限，人我界限，微观与宏观的界限。依华严教义讲，种子交遍法界，事事无碍。根据此理，故种子由染转净，转识成智后，可发神通，神通能六根互用，不为时空所限制。在众生界中，各有阿赖耶，就各有宇宙，全众生界合起来就是大宇宙，兼容相通，如光光相网，无有阻碍。

    四、唯识种子论的旨趣
    了解种子义后，应知如何净化心灵，就必须要有正见，有正见才有智慧，有智慧才能转化心灵，由染转净，由迷转悟，由凡成圣。在学佛阶段启发正见离不开多闻熏习，此即说明佛法讲的修证很实际，所谓信解行证，有信必有解，有解有正见才能巩固信，也才能行，有行才有证，这方法对学佛人很重要。以此来净化人间，也是相当重要的。在新世纪即将到来之际，弘扬佛学就要起此种重要作用，在物质科学昌明的时代必须要以精神文明，特别是佛学作指导，世界就会在净化中得到安定，人类社会就可消灭战争，得到和谐，实现和平，这就是佛家的精神，也是修学大乘菩萨的目的。

    1998年9月10日于重庆慈云寺


论转识成智

    学佛的目的，就是在唯识学里讲的“转依”。转依有二：一转染成净，二转识成智；转染成净为涅槃，转识成智为菩提。涅槃即自性清净，菩提即觉悟，能证得菩提是般若（依中观宗讲），或称正智即无分别智（依唯识宗讲）。
    众生在迷惑与染污中，没有智慧，不懂因果。学佛就是首先注重正确的熏习，多闻熏习后逐渐由染转净成为清净种子，恢复本有佛性。我们现在处于资粮位。唯识把修行的次第分为五位：一资粮位，二加行位，三见道位，四修习位，五究竟位。一资粮位系积福德智慧资粮，二加行位修定（唯识观），三见道位见唯识理，四修习位断烦恼、所知二障的现行和种子，至金刚道一切染种断完，坚如金刚，金刚道至等觉入妙觉即证佛果。
    转识成智：谓转八识成四智（三身四智）。众生的识以分别为主，分别即虚妄分别，去除虚妄分别，即是净智。
    集起名心，思量名“意”，了别名“识”。第八识能够含藏种子和种子现行互熏，是心；第七识执我，是思量；前六识对境是了别，此中前五识缘境是粗了别，第六识缘境由外到内，为细了别，第六识分五俱意识，散位意识，独头意识。五俱意识与前五识同时俱起；散位意识未接触外境亦可随时生起；独头意识就是无中生有的幻想。末那识以思量为主；阿赖耶识以受熏和执持（种子、根身器界）为主。总的来说，识都是虚妄分别，具染污性。
    阿赖耶识是就凡夫位而言，到佛果位叫无垢识。认识事物有分别都是有漏、有为，是不究竟的，是流转生死的根源，由此而有业障、烦恼障的生起。业力是感异熟果报，果报有正报和依报两种。正报依五蕴身讲，依报依山河大地讲，这是我们的障碍，称之为障，又称为杂染，这都是由虚妄分别而生起。分别生起的原因是有情的“我执”习气。我执有“人我执”和“法我执”两种，要彻底断除生死根本就必须断我执。虚妄分别之生起，一方面以我为主体，由贪心被境所染；另一方面损害他人，举手投足都要损害他人。凡夫不损害他人是很难的，五官就只能发挥此作用，学佛人就不同了，因在转变过程中，第六识虚妄分别逐渐减少。人们对自体没有正确认识，对共业所感的所有现象没有正确的观察，因受空间、时间的限制，加上烦恼障和业习的障碍就产生邪见，故而彼此之间常形成愚痴的对立与斗争。此为生死痛苦之源。
    杂染，虚妄分别等都由识而转变，其修持方法是守根护意（持戒），不受外境的感染就是守根，保持正念即是护意，学佛就先要守根，进一步护意。如念佛、念法、念僧、念因果、念众生等，由戒生定，有定力才发智慧，有智慧就有辨别能力。修持禅定，目的都是达到护持正念，进而开悟。般若宗讲，从文字般若到观照般若，最后到实相般若。禅宗也有文字，如《六祖坛经》，祖师禅讲不立文字，明心见性。由闻而思，护持正念，严持禁戒是基本功夫。唯识宗讲，闻的阶段就是熏习正法，同时要结合自身实行。熏习可从书上学，也可听善知识讲解。第六意识有虚妄分别，圣者无分别的智慧，不同于凡夫的世智辨聪。我们现在虽处于基础的位次（资粮位），但我们的宿世善根，也都是来的很不容易的。蕅益大师说：他在定中见到弥勒菩萨，对他说：“有分别是识，无分别是智；识属染，智属净；染有生死，智无诸佛”，智即空慧，空慧境界如六祖云：“本来无一物，何处染尘埃”。
    资粮位是积福德智慧资粮，属顺解脱分；加行位修止观，属抉择分；见道位见真理，去掉了理上的执着（禅宗的开悟、密宗的大圆满、唯识宗的真见道）。
    入地后，初地至十地都是修习位，在此阶段分别断烦恼、所知二障的现行和种子；入金刚道才把所有的种子断完。故修行要务实，要一步一步脚踏实地。入等觉至妙觉佛果成就，此时方转八识成四智。
    坛经言：“六七因中转，五八果上圆”。六识七识未成佛以前初地可以消灭二障现行；前五识与第八识的二障种子（包括六七识）至金刚位才能断尽。前五识转为成所作智，谓能成就众生一切事业，现化身来解除众生的痛苦。转第六识成妙观察智，能够微妙地观察诸法之自相与共相。转第七识为平等性智，清除我痴、我慢、我爱、我见而对一切众生平等，起大悲大行。转第八识成大圆镜智，第八识是我们的生命总体，众生位称阿赖耶识，因受了染污、迷惑而不能发光，不能照见一切，到佛果称为无垢识，如大圆镜能鉴照一切，不受外尘所染，光明遍照，至此，即可得三身四智。第八识现法身，第六七识现报身，报身有他受用身和自受用身，他受用身为地上菩萨说法所现之身；自受用身，是无量福慧成就的唯佛感受之身。前五识现化身，有应化身、变化身二种。应化身如八相成道，变化身即应机随类变化之身。证得三身四智的佛身，才叫无上正等正觉。

    1997年12月19日讲于重庆慈云寺
    1997年12月27日定清整理


阿赖耶识浅说

    一、阿赖耶定义
    梵语阿赖耶，华译为“藏”，有能藏、所藏、我爱执藏三义。
    1. 能藏：谓此识能含藏染、净、善、恶、无记三性诸法种子，如仓库能收纳稻麦等五谷种子。
    2. 所藏：此识为前七现行识之所熏，熏成习气（种子异名），收藏在此识中，遇缘再现行。就受熏言，前七识为能熏，此识为所熏。
    3. 我爱执藏：此识系生命主体，常被第七末那识执为自我，包括人我相、法我相，生起我痴、我见、我慢、我爱，为生死根本。
    4. 此识有三相：以被第七识执我为自相，以含藏种子能生现行为因相，以此识体为业力招感受异熟总报为果相。

    二、阿赖耶三位
    从凡夫起，到发心修行的历程中，共有三位，即：1. 阿赖耶识位，2. 善恶业果位，3. 相续执持位。
    1. 从凡夫到第七远行地菩萨位——阿赖耶识位
    2. 从凡夫到第十法云地——善恶业果位
    3. 从凡夫到佛果——相续执持位
    其理由：
    1. 由资粮位、加行位、入见道位、悟契真空，登初欢喜地，了达诸法自相、共相，最初转为妙观察智，至第七远行地，二障伏尽，方得圆满；第七末那识，不再执我，观诸法，众生平等，同时转为平等性智，即舍去阿赖耶之名。
    2. 凡夫有分段生死，菩萨有变异生死（俱生习气未断尽，犹有起伏故），至第十法云地，都属业果相续。
    3. 十地以后，经金刚道、解脱道，证入佛位，为纯善无漏的净种相续。此识亦名阿陀那识（译名执持），谓此识无论在凡位、圣位，都执持种子，相续不断故。但在佛位，因纯属清净，以大智大悲，分身利乐有情，此识转为庵摩罗识，译云无垢识。

    三、阿赖耶识转依
    第八识于究竟位，方得圆满转依。
    （一）舍烦恼障，得大涅槃（无住涅槃）
    （二）舍所知障，得大菩提（真性菩提）
    此识转成的智，名大圆镜智，何谓大圆镜智？如成唯识论云：“大圆镜智相应心品，谓此心品，离诸分别，所缘行相微细难知，不忘不愚一切境相，性相清净离诸杂染，纯净圆满现种依持，能现能生身土智影，无间无断穷未来际，如大圆镜现众色相”。（详解可参考释论）前五识亦于此时，圆满转为成所作智，分身尘刹，利乐有情。
    佛果具足的三身四智，如下图：

                  ┌1.法身：自性清净身
            ┌三身┤2.报身：受用身
            │　　│自受用身、他受用身
            │　　└3.化身：应化身、变化身
究竟位：佛果┤
            │　　┌1.转前五识：成所作智
            │　　│2.转第六识：妙观察智
            └四智┤3.转第七识：平等性智
                  └4.转第八识：大圆镜智

    四、阿赖耶存在的理由
    （一）经论依据
    成唯识论根据佛说，以五教十理证明有此识的存在。
    五教的经典有：《大乘阿毗达摩经》、《解深密经》、《入楞伽经》及小乘上座部，化地部的原始论著等。此不繁引。
    十理者：
    1. 契经说此识能集起杂染清净诸法种子（集诸种子，起诸现行），故名为心。若无此识，一切染净诸法的功能无处潜存，也无从现起。岂不唐捐？事实并不如此。
    2. 契经说：此识名异熟心，由执持善恶业种遇缘而感受有情的正报依报，若无此识，彼异熟心名即不能成立。
    3. 有情流转五趣四生，若无此识，趣生之体即不可得。
    4. 有色报身，是由此识执受。
    5. 寿暖识三，构成寿命，若无此识，寿暖即不能久住，以前六识有间断，不能恒时相续。
    6. 此识“去后来先作主公”，若无此识，生死相续，三世轮转，即不能成立。
    7. 初生刹那，“名、色、识”三相依而住，若无此识，名色（初形成的胎体和未现行的六、七识）即无所依。
    8. 有情依四食而住，即段食、触食、思食、识食。此识食即指第八识。
    9. 入灭尽定，六识不起，寿暖尚存，仍有生命，即由此识执持故。
    10. 此识能持染净诸种，契经说：“心杂染故有情杂染，心清净故有情清净”，因果不杂乱，即由于此识持种不失。
    （二）现代观点
    1. 中国的传统说法，心脏是思想的主体，所谓“心之官则思”、“心藏神”等。实际上，心脏是主血液循环，心血旺则气爽神清，心衰则引起各种疾患。
    2. 现代生理学主张，脑神经是思想的主体，20世纪50年代苏联学者巴甫洛夫，编著出版有《神经学》，主张神经有：第一信号系统（思想），第二信号系统（语言），并有兴奋性过程、抑制性过程、有条件反射、无条件反射等等，可谓详细。但谈到神经细胞是怎样组合成思维的？神经的交流电波是如何产生的？脑部神经有病被截除后，为什么还会有意识和生命存在（中外都有实例）？则没有解释，仍然是谜。
    西方科学家爱因斯坦、爱迪生……中国现代科学家钱学森都说：意识和生命的潜在力还存在着，没有挖掘出来，不能随意否定；否则不是科学家的态度。
    3. 依现代科学实验，物质、能力，都是不灭的。唯物论者讲，思想、意识是最高的物质，怎样就消灭了没有？
    4. 欧洲的宗教家和印度的吠坛多派，都认为万物有一个始因，但根据生命相续，物质不灭的道理，这是说不通的。譬如说：此谷种之有，是由于此前谷种发生功能的结果，前复有前，后复有后，前前无始，后后无终，决不会有一个始因主宰，也不会断灭。因此，现在心力的存在，不过是过去心力的继续。现在的心力，还要相续未来，不会停顿。德国哲学家莱布尼茨名言：“一个知觉自然地从另一个知觉而来，等于一个运动自然地从另一个运动而来一样。”
    太虚大师曾比喻说：“人工制造的生姜决不能生芽，制造的鸡蛋决不能生出鸡子，因为它没有生机或生命”，这是很有意义合符事实的譬比。
    像这样的譬喻，在《佛说譬喻经》、《百喻经》等里面还很多。不否定生命存在，而有圣凡十法界的存在，这是佛陀经过修行的实证境界，是客观存在的真理。佛是大智慧者，佛法是灿烂的指路明灯。

    2003年3月在慈云寺为居士解说


因明十四相似过类略释

    明者：五明之总称，因是五明之一也。为印度足目论师所释，佛教徒采取之，经过步步之改革，而以作显正破邪之工具也，无斯佛教正理不足以显出，外道邪见不足以摧破，故因明之功用，大矣！然因明为精深博大之学，所谓真能立也，似能立也，真能破也，似能破也，……其组织之严密，内容之完善，诚非今日西洋论理学所能及。故初学者，研究之殊颇不易。今为便于明暸起见，将因明似能破之十四相似过类叙出；盖明此虽不能说可窥因明之全豹，亦可见其一斑也。

    一、同法相似
    由敌者以无质碍之因出立者共不定过；以异法虚空作同品，能成立自己常住之宗。如立者以所作性因成无常，敌者以无质碍，因成常住，如斯二因声皆具有，谓汝立者究竟以所作性因成立声是无常耶？亦以无质碍因成立声是常住耶？如此则犯共不定过。
    立者破：此因非是，何耶？以无质碍之因是疑因，所作性之因是定因，立者之定因使敌者相违，而遭失败；盖无质碍因为异品中一分转故：如异品之瓶乐，瓶是无此无质碍因性，乐是有此无质碍因性，遂成不定。
    且共不定就一因上显，若同品异品皆有此因，方成不定。如人必有死，存在物故，同犬异石。此存在物性，犬石皆有，人不能决定如犬之存在物可死，如石之存在物不可死，遂有过失。而汝敌以梦因显共不定，故与因明之定义实不相干也。
    敌者又难：谓声中有两因，依汝所作性成立无常，依我无质碍成立常住，则汝之量犯有决定相违过。
    立者又破：谓成相违决定过，要两者因性各有三相具足，如声中有所闻性及所作性，胜论师对数论师成立声是无常，举所作性因、同瓶、异空。数论师对胜论师成立声是常住，举所闻性因、同声性、异瓶。此所闻所作各皆三相具足，方成决定相违。而汝无质碍之因只具二相，缺第三相，于异品苦乐等一分转故，苦乐等无质碍故是无常，声无质碍故声亦无常耶？故汝敌者成为不定因，何能云我宗为决定相违。
    显真能破：要立者建立之三支比量，真实具有共不定过；及敌者自己之因不犯不定过，方可破立者，成真能破。

    二、异法相似
    敌者以立者同喻作自己之异喻，难立者因犯不定。谓汝立者所立之量，同喻瓶中一分是同，一分是异，则有怀疑。以声与瓶同有所作性，固可同证无常义，然声不同于瓶之有质碍，瓶有质碍故是无常，声无质碍故应成常住。正举量云：“声是常，无质碍故，同空，异瓶。”瓶是无常，无常之法决有质碍，则可反显声无质碍，声应是常。由是汝立者，因犯不定过：究竟以所作性因据瓶为同喻成立声是无常耶？亦如我之以无质碍因据瓶为异喻成立声是常住耶？
    立者破：按异品须要异品遍无性方能反显，如汝异品之瓶一分有质碍故，从许反显声是常，而异品复有一分心心所有质碍是无常，转证声无质碍声应是无常，何得独证其常耶？汝之因缺第三相，自既不定，焉能破他！

    三、分别相似
    上两难第一以异作同，第二以同作异，不过加以颠倒。此处则于同异二品之差别义加以分析，显前因犯共不定，而难立者。
    敌者谓：汝之量举瓶之同一因性成立无常，不有异性则可耳；然今细加分析，声应不同于瓶，如声不可见不可烧，而瓶可见可烧；可见可烧之法是无常，声既不同于瓶之可见可烧应是常住。举量一：“声是常住，不可烧故，同空，异瓶。”凡无常者皆是可见可烧，瓶可见可烧是无常；反显不可见不可烧之法皆是常住；声不可见不可烧应是常住。
    由是汝因犯不定：为如所作性故，同喻如瓶，成立声是无常耶？亦如我之不可见或不可烧故，异喻如瓶，成立声是常住耶？
    立者破：谓汝敌者第一与现见相违，盖声无常者：以彼由现见明知是因缘所作性，有生灭变化，决定应成无常，故汝以不可见不可烧之似比量来难，实不能遮遣无常性，而成非难。如有成立声非所闻，如瓶；然依现量明显声是所闻，何非所闻耶？
    且汝敌者因犯不定过：如声是常住，不可见故，同空，异瓶。以异品心心所有不可见性故，心心所不可见故是无常，而反显汝声不可见亦无常耶？——不可见如是，不可烧性亦惟能异品中一分，犯不定过。
    敌者又另举因难：以瓶之非所闻性是无常，反显立者之声是所闻性应成常住。如云：“声是常住，所闻性故，同空，异瓶。”如此则汝立者之因不定，以声之所作性异空成立无常耶？亦以声之所闻性异瓶成立常住耶？
    立者又破：汝敌者所闻性之击出，不能遮遣我之声无常；异品之瓶虽是无常，然无常之法不一定显示遮遣所闻性，反显常住；盖常住之法不一定有所闻性故。如汝所立之量中，同品虚空是常住法，应有所闻性，而彼无所闻性。故瓶无常何能说遮所闻性？以不遮故，则不能反显声是常住。
    即进一步纵许汝可以异瓶无常遮遣所闻性，然虚空非所闻性是常，亦可反显声所闻性应是无常。如正理门论云：“不应以其是所闻性，遮遣无常，非唯不见能遮遣故。若不两者，只应遣常。”

    四、无异相似
    （一）宗喻无异——此难古师，古师有一派曰：同类义称为同品。谓汝声同瓶无常，因为声是无常同品，以同类故，应无区别：如声中不可烧不可见瓶应有，瓶可烧可见声亦应有，遂成无异。量云：“声应可烧可见，所作性故，如瓶。”如是汝所作性之因则犯不定。如同喻之瓶成立声可烧可见耶？亦如异品之心心所成立声不可烧不可见耶？按此虽无异，实反显有异，以声不同于瓶之可烧可见，应成立常住。
    立者破：声瓶就无常同一之所作因性上说，不说其差别义，若差别瓶可烧可见是无常，声不可烧不可见应成常，则与世间现见相违，又照汝妄自分别，在宗上根本不能成立敌争论之点。
    复于因上犯不定过，以汝所作性中同喻之瓶可反显声是可烧可见，然异品之意味等是不可烧不可见，此声亦应成为不可烧不可见，何能成立可烧可见耶！
    复次，就汝反显有异之量说，亦犯不定。如声是常住，不可烧故，同空，异瓶。此同空不可烧性可证明声是常；然异瓶一分心心所不可烧是无常，亦反显声不可烧应成无常耶？故汝之量犯不定过。
    （二）宗因无异——敌难立，谓汝之勤勇性因据现在一刹那成无常可尔。若据过去一刹那，则因未说，因既无故，宗何能成？两者无体，犯所依不成。又据现在一刹那，勤勇性之因成宗，俱显非究竟常住之无常义，则宗因相同，两者无异，以皆显无常，无区别故。此如声是无常，以无常故，而汝以一无常成宗，一无常成因，便犯他随一不成过。
    立者破：谓据前难，我宗言三支就现在说，过去之宗因量根本无有，不过由汝妄自增加，何能据之以破。复据后难：无常之宗是表灭义，勤勇之因是表生义，虽总显无常同而义实有别也。如基师云：“勤发兴无常，总虽非毕竟，别据生灭义，宗因义自分”是也。
    显真能破：若于现在一刹那立量上，就因生宗灭之差别义兴难，可成能破。如正理门论云：“此以本无而生极成因法，证灭后无，若即立彼，可成能破。”
    （三）二宗无异——立者之声是无常，所作性故，同瓶，异空。敌者谓此所作性为相违因，应成常住。因以瓶推之，瓶是所作性，瓶可烧可成无常，声虽所作，然不同于瓶之可烧，以瓶作异，应成常住，如是则犯法自相相违因。
    立者破：汝难成非，盖因明定义，就无常共同之总相说，而汝以瓶与声可烧不可烧之别义来显，实与因明定义不合。如正理门论云：“唯取总法建立比量，不取别义，若取别义，决定异故，比量应无。”
    显真能破：若就总义之共相无常，难因犯相违可成常住，方是能破。又所作因，非是决定，苦乐等一分转故。若因决定可称相违，然此不尔。

    五、可得相似
    敌者谓立者勤勇因仅无常宗之一分，独有余因可得，如电光等，由现见因，可成立电光等无常，如是汝之因非无常唯一之正确因，不能决定成立无常；以“唯”勤勇是无常，方为定因故。量：“无常法见非勤勇无间所发，现见知故，如电光等。”
    立者破：我之勤勇因为九句因中之第八正因，于异品不转故，不犯有不定过；盖勤勇因成立无常，若异品常住法之虚空有勤勇因，方犯不定也。敌者复难：谓汝以勤勇因成立声是无常，声非全由勤勇因所发，故汝不遍于外执受大种因声，犯一分两俱不成过。如尼干子所立之“一切草木悉有神识，以有眠故，如人。”此有眠故不能遍是宗法性，以一切草木之范围甚广，草木中一部分方有眠，如含羞草。故此有过失，以不具因之初相故。
    立者再破：我之勤勇因单成立内声无常，非就一切声成立，此例不成故我无失。且吾今反难汝，汝之因非遍是宗法性，由现见知不遍故；如过未法不能现见，亦可成立无常，故汝因不遍，何能难我。
    前之真能破：若立者所立之无常，于异品有此因性，可成能破。
    后之真能破：若立者所立内声之无常中，有一分无勤勇性，可成能破。

    六、犹豫相似
    敌难立者：谓汝之声是无常，勤勇无间所发生故，然此无常有二：一生起无常，二坏灭无常，今汝之无常指生起无常耶？亦指坏灭无常耶？复次，勤勇因有二种：一生二显。生者，此法本来无而今有，可成立无常，如瓶为人工所造，是生起之因，终必归于坏灭。显者，本来即有，由今显此，可成立常住，如掘树根及开井水，此树根井水本来即有，还过加人工之显出，故是常有。今汝之勤勇因指生耶？亦指显耶？如是宗因遂成犹豫不定。此虽变标二义，重在因上出过，谓何能以此因证明声是无常耶？
    立者破：谓吾之声宗专指坏灭无常义说，非有生起之増益，若照汝妄加生起，则成画蛇添脚。又因亦就生起之义立无常，不容许妄情增益杂因。且汝所说显因为常住，此说非是，盖树根井水，将来终归于坏灭，亦是无常，何能依汝之妄计立为常住耶？故知勤勇生显皆是无常，非犯不定。

    七、义准相似
    义准者：即以义类推也。立者以勤勇因成立声是无常，敌者生难，谓由此类推亦可以非勤勇因如电等成立常住；然实际电等是无常。若许非勤勇不是常住，则汝说之勤勇应是常住，而成非决定因。
    立者破：按此成似不定，盖我之勤勇因于异品不转，是决定因。——若虚空常住有此勤勇因性，则此因性成犯常与无常不定，今既不然不受汝破也。
    复次，我之勤勇因性本来唯是无常，非唯是勤勇因成无常，别无他因，以电等一分无常非勤勇故。今汝增益唯是勤勇可成无常，遂以电等无彼勤勇，亦无常为难，然实际我之勤勇性因专指常品非有，即是三相具足之正因，此难不成。
    显真能破：若立者之勤勇因于异品有，可成无常亦可成常；或唯以勤勇因成立一切无常，敌者据此可破。

    八、至不至相似
    敌难立者：谓汝之声是无常，勤勇无间所发性故，此勤勇因至宗上成耶？亦不至宗上成耶？至不至均有过失：若因至宗上，则宗因无因果之区别，无区别则不成能立所立；如池水流入大海，二水无异。量云：“宗之与因应无因果，以相至故，如池海水。”
    又难：若因至宗无能成所成之区别，则所立宗不能成立，由是因应不至宗上，以至宗上亦不成立故。即退一步说：纵许无常宗可以成立，既本身能成立，何必随因成立耶？如窥基大师云：“所立若不成，此因何所至？所立若成就，何烦此因至？”
    复次，若因不至宗成，则与不正之似因无差别故，如立声常，限所见故，此眼所见故与声宗不合，不能至宗，而为似因所摄。量云：“勤勇所发应不成因，不至宗故，犹如非因。”
    立者破：因至宗无区别，此难非理。今姑以世俗作喻，如宾至主家，亦有宾主之分；海与池水不过为同品中之一分，其实不能全说同也。且我之因非是生因，而是了因，了因无前后，无至不至；以声原具无常义，不过以因照了之，如灯光破暗，不一定至暗中去破，亦有破暗之用；此了因无须至宗，亦可明声为无常宗。
    又非因不由至不至分，而是由缺因三相分；我为三相具足之正因，依汝说因不至宗通于非因，究根据何种而说？又汝所难且成自害：试问汝所立之量破亦至耶？亦不至耶？难我还自害，岂不与自语相违？

    九、无因相似
    敌难立者：谓三世因俱不能立宗：若就过去，因在宗前，则此因为谁之因？而此因无从建立。若就未来，因在宗后，所立宗已成，复何须因？若就现在，宗因同时，两者皆不成，何以故？如牛二角，不能辨其因果故。
    立者破：此难不然，盖我以言生因智生因义生因，成所立宗；智生义生属于自悟，间接发言；言属于悟他。此言望于他，（敌者）他能了我之宗，即承此言直接生，而承智义间接生也。故我悟他为正式具足三相之言生因，真现比量为根据，非以似现比量为根据也。汝敌者谓我犯无因过，以非理破具三相之真因，是为似破。又汝所言与世俗相违，以世俗论：因体即在果前，因名即在果后故。且汝所难有自害过，遮遣同故；汝以三世遮遣我之因不能成立汝自之因，遮遣亦同，定能成立耶？
    显真能破：若以如理如量之正理来说，及与世间相合不违，可成能破。

    十、无说相似
    敌难立：汝之声是无常，勤勇无间所发性故，然因未说之前不能成宗，以无因故，犯不成过，且宗成相违；未说勤发，声应是常，而不是无常故。量云：“未说勤发因前声是常，无勤发因故，如空”。
    立者破：谓我用言三支立量，非未说之前立量，汝说不成，应于言三支出过；然未说量前汝不应出过。且我因无故，汝于无因中妄加非勤勇因，成立声常，而犯无因增益过。
    显真能破理：敌于立者之三支比量中，发现无能成立因，而加以指责，成立者立量时无有因支，遂出过破，名真能破。

    十一、无生相似
    立者以勤勇因成立声是无常，敌发难谓：声是所依，因是能依，未说所依声即谈不到能依因，如是则犯无因过失；无勤勇因则与所立之无常宗相违反应成常。量云：“一声未生前无如是因应非无常，无勤发因故，如空。”此与前第十过之区别，前谓能依不成，显因过失；此谓所依不成，显因过失。
    立者破：我之声宗未说之前，汝不能如空中楼阁，妄自增非勤勇因，成立常住来破。显真能破：立者声宗已成立，若勤勇因无，可成能破。

    十二、所作相似
    敌难立者：谓瓶为人工所作，声为咽喉所作，若与瓶为同法喻，推证声是无常，因瓶所作声上无故，则汝立者之因不遍于宗，于宗仅成一分，为他随一不成。
    又汝因犯法自相相违，以声音是咽喉所作，同瓶则无，无则瓶应转成异品：如瓶是人工所作是无常，声音非人工所作应成常住，由是犯相违过。
    复次，此同喻瓶以同法故，应有能立所立，今无有声之咽喉所作性，则犯能立不成之喻过。
    再者：声之咽喉所作性，于异品虚空非有；如是同异瓶空皆无此因，则犯不共不定过。
    立者总破：汝所难全非，盖我以共相建立三支比量，共相者：但取因缘所作性成立声是无常宗也。而不取差别义；今汝分别声为咽喉造，瓶为人工造，举此破我，实则成为似破也。

    十三、生过相似
    敌者就喻上难：谓汝立者之所作性，仅能代表宗法因性，而同喻瓶无此因性；所作性可成立声是无常，瓶以何因成立为无常耶？既无能成所成，应知如是喻上则犯所立不成。
    立者破：有举必须因证，以声无常非是共许，故有举因之必要。若瓶无常为共同许，何必以因来证？

    十四、常住相似
    敌者：谓声应是常住，非是无常，以彼有恒常之无常性相随逐故。若照汝立者所说，则有宗违比量之过。
    立者破：汝之量义为似比量，无常性非是常住故，今声之自性由因缘和合生，本无今有，暂有还无，说彼为无常性，如业感缘起之异熟果，是由种善恶因缘感得，离去善恶因缘外无从他处寻异熟果；此声亦然，除因缘假合外无处寻常住性，说常住者：不过由汝妄自增加而已！
    上来已明因十四过类，为避繁述，力从简略。总之：十四过类之议论浩繁，渊深无穷，精于佛学者，犹多理解不透，远非吾初学者所能道出，故有错谬之处，祈诸大德谅而教之。

    本文载于1938年重庆版《海潮音》月刊
    作者当时年仅18岁


唯识二十论提要

    小　 序

    这篇文章，是我在汉藏教理院读书时，听雪松法师讲授《唯识二十论》后所作的提要，是研究法相唯识的心得。那时我的年岁，还不到二十（约在1939年）。相隔四十多年，这篇手稿不知遗落何处？我也完全忘记了。今年10月初旬，一次我去罗汉寺藏经楼，查阅《五蕴论》的参考资料，适原汉院同学圣芳（现名叶俊章）、同杰（现名陈文杰）两位老友，正在清理经典，同杰偶然于书丛中翻出此原稿递我说：“看，这是你青年时的大作。”我接阅之下，看到是我四十年前写的材料，异常惊喜！看到自己读书时的墨笔手迹，勾起若干回忆，又不禁感慨万分。
    如在废墟中重新拾到久已失落的珍珠，这是我求学时的粗浅之作，但是佛法，是难得的宝贵的真理，我的兴奋心情是不可形容的。
    从青年到现在，我饱受风霜，在艰难挫折中，总感自己佛法的正见尚未失掉，“三界唯心，万法唯识”的道理，于经历中有所实证，翻阅旧作，倍感亲切。加深了勤求佛道的信心和勇气。
    唯识二十论，重在破外，但破中有立，虽不详尽，能循此以深研唯识法相之理，解行相应，是会升堂入奥的。
    佛理并不空虚玄秘，能透视现实即可悟得，愿智者勉力为之。

    1983年12月14日于重庆南岸慈云寺

    唯识二十论提要

    一、泛论唯识
    常人谓佛学中之唯识，仅谈主观之心，而否认客观境界之存在者。克实以论，唯识法相非驳斥外境之有，只斥离心识以外所执之实境，而仍承认不离内心之境的存在，五位唯识中之色法，即是物质，其范围且较普通所论之物质为广大。云何应知色不离识耶？曰：物无定性，随心转变故。心有分别，外境乃起故，人有欲求，乃须物用；随欲有异，所须即殊故。心离欲染，则淡泊超然；贪求无厌，则心随物转故。常人执心外有实物，于是自他，人我，种种是非因之以生，诸大圣者，本真现量，泯心物之分，故远离颠倒，证大菩提，作大佛事，故知吾人心识，为染净因果，转凡成圣之关键，学佛者不可不慎也。

    二、本论缘起与所明
    印度世亲菩萨，受乃兄无著菩萨之感化，转小入大后，为摧破邪山，制此论颂，为建正法幢，制三十唯识颂。本论专在破邪，不纯立理，即以所破为所立。本论内容，据欧阳渐居士《唯识讲义》赞云：“……妙义无边，方隅略示。”

    三、正论
    （一）依大乘教立唯识理
    大乘三界唯识者，此立宗也。唯大乘中，特显此理故，虽十二缘起，三乘通教，即唯心理。于彼密诠，此乃显说，非彼境界，难了知故。《楞伽经》云：“阿陀那识甚深细，一切种子如瀑流，我于凡愚不开演，恐彼分别执为我。”唯识之理，亦复如是，唯大乘菩萨能了斯义，故特安立。“三界唯心”系《华严经》中说，此以圣言量成立唯识也。心、意、识、了，命名虽有四种，体皆同故，故说唯心，义即唯识。积起名心、思量名意、认识名识、解了名了，此四皆心用。又据胜言，第八名心，第七名意，前六名识。说心即摄心所，恒相应故。必遮外境，是生死沉沦本故。内识生时，似有外境显现，然此境无实体。如有眩翳人，见发蝇等，《解深密经》云：“我说识所缘，唯识所现故。此中都无少法能取少法，然即此心，如是生时，即有如是影像显现。”故知外境不离心生，凡情但执为内为外也。
    （二）依次释外人七难
    1. 释小乘外道四难，证知唯识。
    甲、四难与解答
    外问：若内识有、外境无者，则有四问题发生：(1) 地方有定不应成立。（2） 时间有定不应成立。（3）各类众生缘境时，不定一见而共同缘见不应成立。（4）一切作用不应成立。
    论主初别答：（1）以梦喻释初两难，谓如梦中，虽无实境，而处时仍有决定。（2）如饿鬼以同业故，共见肱河，不应随其一见。（3）如梦中损失精血等，虽随心变，仍有作用。
    次以地狱一喻总答：谓如堕地狱有情，其地狱境虽由业识幻现，而仍有定处，定时；共见狱卒狱具；受其逼害作用，故四义皆成。此中论师主张狱卒等非实有情，而大众、正量、犊子、有部、经部等，则许为心外实有，如论详辨。
    依唯识理：境有性境，带质、独影之三。现量缘性境时，决无内外之分。带质境系意识所缘，虽仗本质境生，其变相仍属虚妄。独影境则由意识随起，不依境生者。山河、大地、根身等本质境界，随人识生即有一定，以业力定故。其体幻化无常，但随心转，亦非实用。
    乙、辨色等十二处教
    因经部师执着熏习在内，感果在外（如狱卒等）之义，唯识师破之，谓熏习与感果，均在识内。于是外人复难，谓若一切法唯识，则佛不应说色等十二处，由此证明外境佛亦许实有。
    唯识师答：佛之说法，针对机感不同，所说有异，而含有密意，如对断见外道，说有中有身，此但依业识相续不断而假立，说此亦在对治断见外道：“我体既无，谁往后世”之错误。如是六识依于内种之功能生，当识生时，即有似存于外之色等六境显现；因此佛依种子说为内六处，依色等境说为外六处。经部未建立第八识，不承认种子义。论主为解说方便，以种子作为六根、说根即代表种子。
    实则依唯识正义，五识之生、内借自种以为因缘；依八识所变净色根，为俱有依增上缘，以八识所变器界诸色，为疏所缘缘；自识所变相分，为亲所缘缘；以自见分为能缘，自证分为自体。
    说十二处，即在破我。知六识由六根六境生，则无我见，我闻、我嗅、我尝、我触、我知，是名人无我。若达唯识教遍计执无，依他起与圆成实有之义，复可悟入法无我。然说唯识者，不能执有主观的识，执此等同执有外境，亦在破斥之例。
    丙、 破外境之单位——极微
    外人执着色等法有实体，唯识师遂由聚色分析成极微破之。外人实有之执分四：（1）如胜论师执色境为一实体有。（2）如有部师执多体之实有极微各别为五识所缘。（3）如经部师执由多实极微合成和合相，为五识缘。（4）如正理论师执实体极微各具和集相，共成聚色之和集相，为五识所缘。
    唯识师依次破之：
    （1）色体非一实有，有分色（如人体）由分色（如细胞）合成，分色是多体，有分色亦应多体。
    （2）依据现量，极微各别非五识所缘，故多体不成。
    （3）经部和合相与。
    （4）正理论师和集相，均不成立，以实体之极微根本不能存在故。
    如何实有极微不存在耶？
    （1）就单一极微体与其余六方极微有合无合破。
    （2）就极微本体有方分无方分破，均有过失。（如正文解）
    依唯识师释极微义，如《成唯识论》说：“识变现时随量大小顿现一相，非别变成众多极微，合成一物。然由破实体故、从大析小，非小积大；大小均属假相也。”
    最后，外人复由色相执色体是实有，唯识师就一实体三义，以五义分别破之，结成唯识，如正文解。
    2. 释以现量证境实有难。
    外问：佛法楷定事理三标准，曰现量、比量、圣言量。此三量中，以现量为胜，现量者，谓对于外境之现前证知，无有错谬。如无外境，现量如何可成？
    论主解释此难，首举梦喻，谓梦由心变，而人于梦中，仍有外境可缘，但此境不离心，余非梦时亦尔。又据理言之，第一、当现量初刹那缘性境时，本无内外之分。而此影像于第二刹那流入第六意识中时，方有名相，种类，内外等种种分别；故此以境为外，系意识计度，已非现量。第二、色等外境，刹那变灭，吾人于第二刹那分别此是外境时，初刹那现境已灭。如何许有现量实境？
    外复转难：谓须五识先缘实有外境，意识方能回忆，亦可证明实有外境。论主复破；谓如前说，内识生时有二分起，一曰见分，二曰相分。此相分似外在有，而不离识。识但缘亲相分，疏相分（山河大地等）系由第八识中色种变现，故境不离识变，知非实有。
    3. 释以梦例觉时应知境有难。
    外问：世人知梦境无、觉时境有，所知既异，境应不同，外境应是实有。
    论主答，常人知梦境无、觉境有，执现境为实，此实谬见。盖诸众生，无始以来，由能取（我）所取（法）之执，起诸颠倒分别，熏习成种，妄执内外，为无明所愚，烦恼所恼，生死长流，如在梦中，而不自知为梦。若能修行，于见道位时，得离我法虚妄分别之无漏正智，证法实性；此后得世间净智，观察世相，则知一切现象，如梦如幻，不生贪执矣。
    4. 释二识成决定，外境非无难。
    外难：有情善恶二识，随于他教而得决定，非是但由自识转变，自作主宰而得生起，有友教故，由是证知外境实有。
    论主答：言唯识者，第一，非唯自一心识，而否认其他众生之识，以十方凡圣尊卑，各有心识故。第二、他识所变色境，对自仍为外境，但仅作增上缘，而非亲因缘。如是诸善恶友、言教音声，但于余识作增上缘；余识仗之，为疏所缘缘，另变相分，为亲所缘缘。故诸有情虽受友教，非直接受，彼亲所受，仍是自识变现。诸佛说法，众生随类各得解放。称讥毁誉，智者不为动，而小人必生动摇故。以是之义，说名唯识，然经云善知识友教，为修行者精进之增上缘，此义不可不慎也。
    5. 释梦觉心位造行感果有异难。
    外难：梦位与觉位均属于心，何缘梦觉造业，感果不同，论主答：造业由心，因心力有强弱，故感果不同。业力羸劣不能感果，以彼无能摄植业种故，如是梦位由睡眠心所所坏，令心暗昧，不能感果（觉时狂醉等位，势力劣弱，亦可类推）。
    佛法云如行一布施，若希求果报行施者，则得人天果。若观三轮体空而行施者，则为菩萨大行，功德无量无边。此亦由心力强弱有异也。
    6. 释羊等为他所杀难。
    外难：羊等为屠者手足刀杖等杀，证明外境是有。若不为他所杀，屠者云何得杀生罪？
    唯识师答；他之手足刀杖，亦先由意业发动，此意业为被杀者致死之增上缘，仍属唯识，并举数例以明之，兹不详赘。
    依唯识理，有情内识生时，因缘力故，内变根身，外变器界，而他人之浮尘根，亦为自识所变之一部分。故有情间，互变互缘，如众灯明，光光相纲，不相障碍。王恩洋居士《二十唯识论疏》云：“……是故此时杀业，彼能杀者，乃其自识所变身手，持自所变刀，向自所变他根依处而行杀害，故能杀之。其受杀者，乃其自识所变他身处身手，持自所变刀，向自识变自根依处而行杀害，故尔受杀。二者皆不越各自识变相分色等，自行杀害，由是说名自识转变增上力故，令他有情死耳。”识力业力，不可思议，此义甚精，应详思择。
    7. 释他心智难。
    外难：他心智以他心为境，若不缘者，不名他心智；若缘，唯识理不成。
    唯识师答：他心智虽知他心，然不如实，如自心智，言不如实者，一、缘自心他心，均须变相而缘，决定不能亲取故。二、凡夫位到菩萨位，由无明障复故，起能取所取执，于自他心，均不能如实知，非知如佛净智所行境界。由此可知，他心智所缘，仍不离识。

    四、结论
    唯识理趣，精深博大，法相浩繁，难测渊深。凡夫仅据理以明一二，即地上菩萨，二障未全断故，亦不能全证，非佛谁能全知，此论者于本书结束时之深赞推崇佛陀也。本书仅明七难以破外人之执，重在于破邪。至建立正理，则见《摄大乘论》及《成唯识论》等书。诸有智者，应深研学。

    1984年2月重抄于重庆南岸慈云寺


唯识三十颂概说

    一、本论缘起
    《唯识三十颂》在法相唯识中是一部很重要的著作，而且是唯识学的纲要，《唯识三十颂》系世亲菩萨晚年所著，没有作注解，世亲菩萨就圆寂了。
    世亲菩萨是佛涅槃后九百年的人，他诞生在北印健驮逻国的都市布路沙布罗中，在佛教界中最享盛名的筏苏槃度（译为天亲或世亲）菩萨。他初出家于小乘萨婆多部，博学多闻，涉猎小乘三藏一切有部，经量部，著《俱舍论》二十卷，世称为《聪明论》，分析法相为七十五法，但对此并不满足，后到北印度继续学习《大毘婆娑论》，对论文不满意，进行批评，师父警告说：没有证果的人这样诽谤佛法，对自己是不利的。世亲菩萨回到本国后，诽谤大乘非佛说，其兄阿僧伽（译为无著）为他的行为感到焦虑，开导学大乘，故遣门人诵《华严经十地品》和《阿毘达磨经摄大乘品》，给予听到，世亲听后非常惭愧，悔恨自己向来见解浅薄，诽谤了大乘佛法，请求把自己舌头割掉，无著菩萨劝说，用不着割掉舌头，过去你将它造业，现在你可将它弘扬大乘佛法将功补罪，岂不是忏悔已往的罪愆吗？后来世亲深研大乘，弘扬大乘佛法的精神，著了许多书，世称为千部论师。他的一生著作中伟大而最精深的，是晚年出的这部《唯识三十论》，总三百六十言。所谓“含万教于一字，约千训于一言”，但因年高，不久圆寂，时八十岁，故没有给予注解。
    后来有十大论师先后给《唯识三十论》作注解，这十大论师是：1. 达摩波罗，译为护法；2. 姜拏未底，译为德；3. 悉止萨未底，译为安；4. 畔徒室利，译为亲胜；5. 难陀，译为欢喜；6. 戎陀战达罗，译为净月；7. 质咀罗婆拏，译为火辨；8. 世沙密多罗，译为胜友；9. 若那弗多罗，译为胜兴；10. 若那战达罗，译为智月。
    中国唐代高僧玄奘大法师到印度求学，在中天竺那兰陀寺依止戒贤论师学习，学习范围广，有大小乘，印度哲学等，但以瑜伽为主。学成归国后，于长安白天译经，晚上讲学，以唯识法相为主。根据十大论师解释，内容很丰富。玄奘法师是中国法相宗的祖师，应弟子窥基的请求，将十大论师之说，百卷之文，以护法菩萨的释文为主，糅合成《成唯识论》十卷。窥基法师为此造了《成唯识论述记》，其弟子慧沼作《成唯识论了义灯》，惠沼的弟子智周又作《唯识论演秘》，合称唯识三大部。这是研究《成唯识论》应读之书。
    菩萨造此论的动机不外乎是“令正法长住，利乐诸有情”，在当时印度教徒与非教徒之间，这些学者各抒己见，邪执盛起，而唯识道妙，反隐没不彰于世。菩萨为破斥邪执，显扬正理故作此论。
    大家可在印度佛教史上看到，印度佛教历史大概在佛灭后一百年的期间，此时风平浪静，一味无诤。到一百六十年后，发生大天（五事）之诤。（参看印度佛教历史）。于是小乘佛教分裂成二十部，各自主张其义。到三百年间有迦旃延尼子出，造《发智论》，此时又有法救世友师等出，于是小乘的我空法有又风靡一时，教界中人，大都兴起诸法实有之执见，大乘佛法几乎沉晦无闻。到七百年间有龙树菩萨出世，作《中论》，《十二门论》等，而此时排斥诸法实有之执，宣扬毕竟皆空之旨，故当时印度佛教界中产生了不执于空就执于有的两大思潮。到佛灭度九百年间，自无著、世亲菩萨出，宏扬唯识中道之旨，扫荡执空执有的邪见，故本论的动机正是破执显理。

    二、本颂要义
    （一）识变
    法相与唯识是不可分离的，大虚大师说：“法相必宗唯识，唯识必摄法相”。法相是物质和精神的种种现象，万法离不开心识所摄故。《华严经》曰：“应观法界性，一切唯心造”、“心如工画师，能画诸世间。”《心地观经》曰：“心生则法生，心灭则法灭，心染则国土染，心净则国土净”。这说明一个现象，就是万法随心而生灭，心的作用之大。用现代语讲，心可改造世间，心具有主观能动性，心体的转变可以使一切现象转变，其中包括了有情轮转、生死相续、正报依报、根身器界的建立，这些都是识体转变而有的。在世出世间一切法中，什么是染污的？什么是清净的？怎样转染成净？转识成智？具体包括了三性三无性，区别世出世间的法相。同时依三性说明什么是有，什么是空。唯识正显非空非有之理，即是中道之义。审观一切诸法无一法偏有，无一法偏空，无不具备中道之妙理。心为能变之体，分三种：（1）异熟能变，指第八识。（2）思量能变指第七识。（3）分别能变指前六识。其变又分两种，即因能变和果能变。因能变概指种子生现行，现行熏种子。果能变指识体生时，又变起见分和相分。前为宇宙众生界本质和现象的关系，后为心识认识外境的能缘与所缘的作用，构成唯识学心物不可分离的统一体，证明物不离心，境不离识。详如正文释，附识变表解。
    （二）三性
    三性：遍计执性、依他起性、圆成实性。
    1. 何谓遍计执性？遍计是周遍计度义，妄执所缘的对象，对于因缘所生法，只看到浮现在主观意识上的虚妄影相，看不到它本来的真相，不了解这种影相是唯识所变，却执为心外实有，起种种的实我实法差别。当人们心缘境时，对于能缘与所缘之间，产生一种实有我法的妄境。妄计的种种我法，毕竟不过是现于主观迷情上的执相，故《三十论》说：“此遍计所执，自性无所有”。遍计所执性只是在凡情上才有，在真理上没有，“情有理无”，如龟毛兔角，是体性都无之法。
    2. 依他起性：依是依托，他是众缘，起是生起。一切有为法都是依托众缘而生起，所谓四缘生诸法；因缘、增上缘、所缘缘、等无间缘。心所法依四缘生起，色法依二缘（因缘、增上缘）生起。故百法中从缘所生的心法（精神作用）、心所法（心理作用）、色法（物质）等，皆是依托众缘而生，假有而无自性。这和中观“缘起性空”的思想是一致的。既然依因缘和合而存在，非固定的实有，故《三十论》曰：“依他起自性，分别缘所生。”依他起性不是迷情上的妄想，也就是说不是由依名生义的遍计所执性而起，故是有。在此，可以证明一切事物都是因缘所生，即无自性的“假”法。
    3. 圆成实性：圆是圆满，成是成就，实是真实。即去掉妄情执着后所证得的真如法性，或者是事物的真实体性，即诸法真如，其体不生不灭，不变不易，是依他起法的体性，远离了遍计所执的实我实法。故《三十论》曰：圆成识于彼，常远离前性。这里可见，真如性是绝对的，它不同于遍计所执的情有理无，也不同于依他起性的如幻假有，而是“理有情无”的中道实相，我法二空所显真实。
    （三）三无性
    三性的道理如从另一角度来解释便是三无性。也就是说：遍计执，依他起，圆成实三性是从有的方面说明万法的状态，而相无性、生无性、胜义无性者则是从空的方面诠显诸法的状态。故《三十论》解释说：“即依此三性，立彼三无性，故佛密意说：一切法无性。初即相无性，次无自然性，后由远离前，所执我法性”。因此，三无性是对三自性的真实体性的说明。
    1. 相无性：是对遍计所执自性说的。相是体相义，无性是无自性。遍计所执性不过是迷情上所执的妄相，犹如病眼见空华，其体本无。为什么说遍计所执自性其体本无呢？因为这种自性完全是妄想安立，若离二取，就根本没有什么“自相”可得，故名“相无自性”。
    2. 生无性：是对依他起自性的说明。为什么说依他起性是生无自性性呢？因为依他起自性是众缘所生的有为法，是有生有灭的，它的生是依因托缘的生，而不是自然而然的生，故说无性。说它无自性并不否认依他起的万法都没有，是说依他起自性仅有“缘生性”而没有“自然生性”（自然生性是不待众缘，自然而有，固定不变的意思）。正因为一切事物是依他而起不是无因而生，故叫做“生无自性性。”
    3. 胜义无性：是对圆成实自性的说明。圆成实自性是在依他起上远离妄计所执我法的净智所缘的境界，是一切法的实体，故名“胜义”。圆成实性又是依诸法无自性显示和安立的，故叫“无自性性”。圆成实性的本身就是诸法的二无我智所缘的胜义。故名胜义无性。
    综上所述，三性是就能知与所知而言，三无性是就三性的本质而言。佛陀在三性之外说一切法皆无自性，就是为了要摒除对诸法实有的执着，从而悟入诸法缘起性空的妙理。三无性是依三性安立的，三无性的体不离三性，三性的体自具三无性义。所谓有是空的有，空是有的空，有不离空，空不离有。有与空是宇宙间万法的二面观，非但有，非但空，从三性上说有，不偏于自性有。从三性上说空，并非完全空无。说有说空或非有非空，只是为了遮止边见执著以诠显中道妙理而施设的方便，偏空偏有，执着任何一边，中道的实义就无从体现。亦空亦有乃是中道之教。
    （四）唯识观
    唯识的理论，还要结合修持，如闻思修与戒定慧三学，中心都离不开止观，止观在各宗派中都有所不同，唯识学以五重唯识讲明唯识的止观。
    第一重遣虚存实识，即遣遍计所执的虚妄计度，而存依他起性及圆成实性的实体——虚实相对。
    第二重舍滥留纯识，即舍除杂乱的外境，而存留纯粹的识，舍相分，存见分，证自证分——心境相对。
    第三重摄未归本识，从见相二分的技末作用上，摄归自证分的本体——体用相对。
    第四重隐劣显胜识，隐心所的劣，显心王的胜——心王所相对。
    第五重遣相证性识，遣差别的事相，证无差别的理性，也可以说遣一切法相，证一切法性——事理相对。或者说遣依他起，证圆成实。五重识观，从宽至狭，从浅至深，从粗到细，以遣相证性为究竟。
    （五）唯识的行与果
    菩萨修行要经过三大阿僧祇劫，根据《华严经》里讲的五十二位，十信、十住、十行、十回向、十地、等觉、妙觉，说明唯识由行到果的经过。
    具体的讲，转识成智、须经过修积福德智慧的资粮位；产生胜定的加行位，引发二空智的见道位，分断烦恼、所知二障现行和种子的十地位，入于金刚道，由等觉到妙觉，方证涅槃菩提，成就三身四智的佛陀妙果。详如正论释。

    三、唯识学的重要性
    （一）学佛的目的是要修心，这需要明白一个道理——因果缘起，否则谈不上修心，要得到解脱，就要伏除心里的烦恼。因果缘起是佛教的中心思想，不论大小乘，包括中国的各宗派都共同遵从的准则。不信因果就修不了心，佛教与其它宗教不同之处，就是在因缘道理上，事物的发生要有它的因有它的缘才能有它的果（现象），因果缘起都离不开心识。《华严经》曰：“应观法界性，一切唯心造”。唯识学有精密的理论。唯识学的境行果，贯通了佛法的教理行果。
    （二）唯识学很适应现代科学。科学重分析、归纳、推理、实验四种方法。唯识学最有逻辑性、理论性。唯识的理论就建立在因明的基础上，故很适应现代人的根机。弘扬唯识最早是玄奘法师，他对印度因明很有研究。十大论师用因明建立了唯识之理。中国科学家钱学森在分析世界八大知识时，提到思维科学和人体科学。他的原话：“思维同其它事物一样，是一种物质运动，或者是运动着的物质”。思维科学分析有形象、逻辑、灵感、创造四种。要扩大人类的精神财富，必须有精密的思维。在唯识学中，第六意识以思维为主体，若在唯识学上深研明辨，悟得唯识理义，思维学可以得到深化。对气功是怎么回事，特异功能为何出现，科学回答不了。唯识学能解决这些问题，从佛学上看气功，特异功能并不希奇，气功是止观中的调身、调心、调息的一种现象。能把身心气息调好，可以益寿延年，增强身体健康，发挥大脑的智慧。止观修成后，六根运用，首先由戒生定，由定发慧，由慧发通。在唯识法相中，强调“八识转变”，种子转为现行，现行又熏成为种子，种现熏生，发挥了心识的潜在功能，这是人体固有的力量。
    （三）唯识学能结合实际行动，首先是内心的“净化和解脱”，要求发大悲愿度众生，庄严国土，利乐有情，实现人间净土。以人间佛教的精神对社会主义两个文明作贡献，弘法利生，绍隆佛种。

    四、纠正几种对唯识的错误认识
    （一）不能将唯识混同于普通的唯心论。唯心论分主观、客观两种。主观唯心论认为宇宙万有都是人的主观所决定的。客观唯心论认为客观上有一个主宰世界的造物主，都比较玄虚。如古希腊柏拉图的“理念世界”，德国黑格尔的“绝对精神”，中国古代的玄学，皆谈玄说妙。有些人对唯识产生了误解，将唯识混同于世间的唯心论。佛法讲实际重行持，这点与别的宗教不同。佛教理论是建立在三量上，即现量、比量、圣言量。（1）现量：现证现知对所认识的外境并不否定，如前五识了别色声香味触法六尘初刹那时候，以及定中缘境，正智契真如，第八识所缘的境界都叫做现量。（2）比量：进行推论，如远见烟就知彼处有火，听到隔壁有说话的声音，就知道里面有人，以及由因知果。（3）圣言量：又名圣教量，对佛说的法深信不疑，深信因果，三宝功德，根据圣人的言教才认识真理。
    “心本无生因境有，前境若无心亦无“，唯识学并不否定万法的存在，怎能与普通的唯心论混为一体呢？
    （二）佛教讲唯识，并非说阿赖耶识可以主宰一切，同梵天、上帝一样。佛教讲的是缘生法，诸法生起不离因缘，非常非断。众生流转皆由因缘。因缘有时空上的变化。根本识和前七转识的变动，都由于各种条件，并不是有常恒不变的我体。
    （三）言唯识并不否定众生心识和处境的存在，人各有其独特的环境，正报依报因业力而异，但有互相依存关系。山河大地社会环境，人类共有，乃是人们的共业所感。
    （四）修唯识观不光是参禅打坐，修解脱行，而要发悲愿度众生。《瑜伽师地论》弥勒菩萨所讲，其中提到六度四摄学习五明的菩萨行并没有脱离社会。故学佛应该以出世的精神来办入世的事业，荷担如来家业，弘法利生。

    1985年讲于成都四川尼众佛学院
    藏青记录


瑜伽真实品讲义

    一
    《瑜伽师地论·菩萨地真实品》云：
    “云何真实义？谓略有二种：一者依如所有性诸法真实性；二者依尽所有诸法一切性。如是诸法真实性、一切性，应知总名真实义”。
    真者，指认识事物的本来面目，此从认识论的角度讲。实者，指事实的客观存在性，此事实不待他物而实有。
    如所有性真实，指一切现象共具有的真常不变的体性，即真如、法界、实相。尽所有诸法一切性，或称尽所有性，指一切现象各各具有的性质、相状、力用、关系等，指的是缘起缘生，一切法相。前者系无为法，后者系有为法：一名胜义谛，一名世俗谛，总包括在诸法真实义中。
    《真实品》又云：“此真实义品类差别，复有四种：一者世间极成真实；二者道理极成真实；三者烦恼障净智所行真实；四者所知障净智所行真实”。
    （一）世间极成真实：“极成”系因明学的术语，谓人们所共同认可的。此真实系根据世间习惯，以大家共用的名词概念，所表示的具有某种性质的事物、现象。如论文云：“谓地唯是地，非是火等。如地如是，水、火、风、色、香、味、触、饮食、衣、乘、诸庄严具、资产什物……等，当知亦尔。苦唯是苦，非是乐等；乐唯是乐，非是苦等……”这些，包括在感性上的认识中。
    （二）道理极成真实：经过现比量进行思辨推理认识事物的固有法则、客观规律，由证成道理所建立。如逻辑学、哲学等，此属世间哲人的理性认识，也通出世间由语言建立的文字般若。
    以上二种真实，不离语言文字，是相对性的。
    （三）烦恼障净智所行真实：是修行圣者（声闻、缘觉）依无漏智，观四谛理，断除烦恼障，悟人无我，证得解脱的境界。
    （四）所知障净智所行真实，是修行圣者（大乘菩萨）对所知一切法，以无漏无分别智，破除所知障，悟法无我，证得真如、实相的不可思议境界。
    以上二种真实，是绝对真理。
    绝对真实，非感性、理性的认识所能实证，必须如法修行，离名相分别及能所对待，遣除法相，妙契真如，方能证入。
    《金刚经》云：“凡所有相，皆是虚妄，若见诸相非相，即见如来”。
    相者，即我相、法相、非法相等，必须遣除诸相，才能降伏其心，显出真心。
    《大日如来经》云：“云何菩提？谓如实知自心”。心为灵明的本体，消除无明的障蔽，明心见性，即能证见诸法实相，故学佛者以修心为第一。只研经教而不行，如说食数饱。

    二
    从四真实义中，破除增益、损减二执，符合三性中道。
    增益执，即执著由假名安立的诸法（世出世间）为实有性，而有我相、法相，常恒不断（常见）。
    损减执，即对假名安立而如幻如化的法相（有为、无为），否定为无，起断灭见。
    此增益执的常见，损减执的断见，称为边见，远离二边，方契合中道。
    依三性说：我相、法相的遍计执，是非有的；缘生如幻的依他起，以及由幻入空的圆成实，是非无的。非有非无，即名中道。
    菩萨以知空故起大智不住生死，以知如幻有故生大悲不住涅槃。如论文说：“又即此慧，是诸菩萨，能得无上正等菩提，广大方便”。“如实观察一切法，悟法无我，具平等智”。
    又说：“于诸明处，一切善巧，勤修习时，虽复遭遇一切劬劳，一切苦难，而不退转，速疾能令身无劳倦，心无劳倦，于诸善巧，速能成办……”菩萨因如是智，修六度行，具诸功德。
    于二边见中，对损减执的断见，论中特别提出破斥，称为“恶取空者”如论文说：“世尊依密意说言：宁如一类起我见者，不如一类恶取空者”。何以故？因为“起我见者，唯于所知境界迷惑，不谤一切所知境界，不由此因，堕诸恶趣……”恶取空者，则不如是，否定一切，拨无因果，毁谤正法，堕诸恶趣，受大苦恼。

    三
    世间愚夫，由于不了知如是理所显真如性，而有种种虚妄分别，轮转生死（如论说有八种分别）。菩萨行者，能以四寻思、四如实智观、息诸虚妄分别、得诸自在，获五种最上胜利：
    “一者，获得心极寂静，由住最静故，不由烦恼寂静故”。
    “二者，能于一切明处，无所挂碍，清净鲜白，妙智见转”。
    “三者，为利有情故，流转生死，无有厌倦”。
    “四者，善入一切如来密意”。
    “五者，所得大乘胜解，不可引夺，不从他缘”。
    由五种最上胜利而有五种胜利之业，而实现五种菩萨大行：（1） 谓自安乐而无杂染。（2）普能成熟一切佛法。（3）普能成熟一切有情。（4）护持如来无上正法。（5）摧毁他论，精进勇猛，正愿无动。
    四寻思，四如实智观，是属于菩萨加行位，观能取识，所取境皆空。所取的境虽多，而不出于名、义、自性、差别的四法。假名安立的境，并非实有，而是由因缘和合幻现的。如此推求寻思，名四寻思观，进而空掉能取所取，名为四如实智。智由明得、明增、印顺、无间四种定力产生，依次而入于加行的暖、顶、忍、世第一位，进入悟证空性的真见道位。接着，登上十地的修道位，修习十度大行，历金刚道，断惑证真，圆证菩提。

    1986年春讲于重庆慈云寺


唯识学的业报论

    生命的长河，前后相续不断，无始无终。众生在三界五趣中轮转不息，舍此报，趣彼报，全凭业力决定，故“业报论”（亦称业感缘起）为佛教的中心思想。

    一、苦集灭道
    佛在菩提树下静坐成道后，首先于鹿野苑中，对五比丘演说四谛法。四谛中苦、集为世间因果，灭道为出世因果。
    佛说的“此有故彼有，此无故彼无；此生故彼生，此灭故彼灭”，这是一切法的缘起法则，据此法则，才有一切因果现象。众生的生死轮转，是因果相续，既非无因论，也非断灭论。
    苦：三苦、八苦，乃至一百零八苦。
    集：（1）烦恼（亦称惑）贪、瞋、痴等根本烦恼和随烦恼。（2）业：即行为，有善业、恶业、不动业。
    灭：灭除烦恼痛苦证得的涅槃。
    道：戒定慧三学或八正道。
    此中集为苦之因，道为灭之因，苦为集之果，灭为道之果。
    由四谛开衍出十二因缘流转门和还灭门。
    流转门：建立三世两重因果：即过去二因；无明、行。现在五果：识、名色、六入、触、受。现在三因：爱、取、有。未来二果：生、老死。
    还灭门：若以出离心修道，则无明灭行灭……乃至生灭则老死灭，证得解脱。
    闻佛四谛教而开悟证道的曰声闻，观十二因缘而开悟证道的曰缘觉或独觉。

    二、大乘唯识论生死流转的道理
    《唯识三十颂》云：
    由诸业习气，
    二取习气俱，
    前异熟既尽，
    复生余异熟。
    前二句是明有情生死相续的原因，后二句是明相续的形相。
    诸业习气：即有漏的善业不善业的种子。二取习气：即见分相分所熏诸法的种子（见为能取，相为所取），又称名言种子。名言种为亲因，亦称质料因；业种为增上缘，亦称组合因。由此诸业习气的缘，和二取习气的因，“俱”谓同时而有，互相扶助，故生起异熟的果报。
    又约两世一重因果的十二有支来讲：
    （一）无明：与第六意识相应，于诸谛理，迷闇为性，分二：1. 迷于因果，曰异熟愚；2. 迷于解脱，曰真实义愚。迷于因果发非福业；迷于解脱，生福业和不动业。
    （二）行：以第六意识思心所为体，发福（善），非福（不善），不动（世间禅定）的有漏三业。
    （三）识：是未来三界的总报果体，为生真异熟的第八识种子。
    （四）名色：属异熟无记的五蕴种子（除未来第八识、六根、触、受）。
    （五）六处：为能生未来异熟无记的眼、耳、鼻、舌、身、意六根处种子。
    （六）触：为生未来异熟无记（赖耶体）的触心所之种子。
    （七）受：为生未来异熟无记的受心所种子。
    以上识等五支，是能生异熟果的“名言种子”，行支即是业种子。
    （八）爱：是与第六识相应俱生的下品贪爱。
    （九）取：是与第六识相应俱生的上品贪爱，及一切烦恼。
    以上爱取两支，名“润生惑”，行支及识等五支种子，必须在临终时受此两支数：滋润，才能生起现果。
    （十）有：行等六支种子，经过润缘后，具有招感当果的力量，当来果报即生，名有支。
    （十一）生：从母胎初生，其报体的五蕴还未衰老之前的阶段。
    （十二）老：从衰老到死。
    十二支中，无明，行为能引支；识、名色、六入、触、受、为所引支。爱、取、有三为能生支；生、老死为所生支。前十支是因，后二支是果。
    约过现门说，前十因是过去世，后二果是现在世。若约现未门说，则十因是现在世，二果是未来世。
    十二有支，不出惑、业、苦三类，行有二支属业；无明、爱、取属惑；识等五支及生、老死二支属苦。业种，属业习气；惑与苦，属二取习气；惑为能取，苦为所取（取者、执着、贪爱、追求）。
    前世的业力感今世的果；今世异熟果虽尽，又由新熏的名言种和业种，能招感未来的果报，故有情相续轮转无穷。

    三、业力不灭，是佛教的根本定律
    在自然科学中，物质不灭和能量不灭两大定律是自然科学的两大支柱。业力不灭，业感缘起，则是佛教生命学说的两大支柱。
    业是指生命的精神的活动和行为。如果这个业是虚幻不实的，没延续性的，那么过去就不会延伸到今天，人类文明也谈不上积累。没有这个原则，人们就不可能感知，记忆和回忆，更谈不上发明和创造；受、想、行、识这四大功能，就建立在这个基础上。
    这个业力，与物质和能量一样，可以从一种形态转变为另一种形态，或寄寓于其它形态之中。并因业感缘起故，运转为十二缘起，构成过去、现在、未来这样一条生命的环链。大乘唯识学的业报论，阐扬了这种奥义的精华。

    2004年元月讲于重庆慈云寺


唯识要义

    一、唯识者，据《成唯识论述记》云：“唯谓简别，遮无外境，识谓能了，诠有内心。”此指外境非实有，内识非虚无，非有非无，名曰中道。外实为增益执，内无为损减执，双遣二执故，方是唯识中道之义。
    识有本识和转识，本识即阿赖耶，为众生生命的本体，前后相续不断，能持诸种子，变现有情世间和器世间，即以所变为自所缘。转识即前七识，依止本识而起现行，又由现行熏成种子，藏于本识。
    唯识学虽讲识体，但不同于宗教中的上帝，外道的神我，也不同于哲学中的物本体、心本体。以识的变化，系因缘生法故，前后相续不断故。
    识为能变，境为所变，境识不离，内外浑融。所不离能，故曰唯识。

    二、能变之体为识
    能变分三：1. 因能变、果能变；2. 因缘变、分别变；3. 共变、不共变。
    因能变即种子能变，分名言种、异熟种、四大种。所变根身器界为其所缘。果能变即以现行识体为能变，见分相分为所变。在因果能变中，有因缘变、分别变的差别：三类境中的性境，有色心之实体实用，属因缘变。独影境与带质境，但随能缘识之分别力而变，属分别变。

    三、熏习：前七现行识为能熏，第八赖耶为所熏，受熏时成习气，即从熏习中留下的气分，潜伏于本识中有产生诸法的功能，曰种子。
    熏习有三：1. 名言熏习：即因名言相而熏习，能诠释义理，分别境相，产生差别法相之因。2. 我见熏习：执着于我，我所的观点而熏习，区别自、他、人、我、我相、法相的原因。3. 有支熏习，指善恶诸业的熏习，为死后招感不同果报的原因。

    四、唯识学的目的在超情离见、转识成智、转染成净。
    1. 转前五识，成成所作智（以行为饶益众生、成就众生）。
    2. 转第六识，成妙观察智（去除无明善观诸法的自相、共相、说法利生）。
    3. 转第七识成平等性智（破除自他人我妄执、视众生平等，兴无缘慈，同体悲）。
    4. 转第八识成大圆镜智：（此时为无垢识，如大圆镜、圆照诸法，而无分别。即法身、真如、菩提、涅槃境界）。
    转染成净：(1)断人我执，舍烦恼障，成涅槃。(2)断法我执，舍所知障，成菩提。

    五、唯识、般若二宗的空义
    唯识宗着重于心的分析，三论宗着重于境的分析。唯识认为一切现象（众生似我、似法之现象），都是迷情之遍计执，此我法是绝对的无，空此遍计所执，才能显出依他起（因缘生法）的妙有，圆成实的胜义有。
    三论宗则认为：缘起诸法之现象，不能说没有，此有为假有。即在假有上建立性空。不能把缘起法空掉才叫空。故中论云：“因缘所生法，我说即是空；亦名为假名，亦是中道义”。

    六、三性三无性是唯识指明诸法万有的实相
    1. 三自性：依他起性、遍计执性、圆成实性。
    依他起：有为之法，从自种子，增上势力，待因及缘而生。
    遍计执：非有计有，执我执法，由诸分别，缘名及相，执我而起。
    圆成实：我法二空所显真如，圆满、成就、真实。
    2. 三无性：
    相无自性：众生所执我法二相空故。
    生无自性：因缘生法非自然生故。
    胜义无自性：胜义即空，空为第一胜义故。

    七、唯识各派对第八赖耶认识的差别
    1. 地论学派视赖耶为净识与如来藏同。
    2. 摄论学派视赖耶为妄识，是一切烦恼之本。
    3. 法相宗则认为是真妄和合之识，染净两种境界均发源于赖耶（含藏染净种子故）是生命的主体，是宇宙万有的本源。

    八、新旧唯识师的不同论点
    在印度弘扬唯识学的无著、世亲二论师以后，有十大论师出，对发扬唯识教义各有论点，分出新旧两派。
    旧唯识学有护月、安慧、难陀。新唯识学有陈那、护法。
    1. 识体变现时：安慧主张一分（只有识的见分），难陀主张二分（即能缘见分、所缘相分），陈那主张三分（见分、相分、自证分），护法主张四分（即于三分外加证自证分）。
    2. 种子本有和新熏方面，护月主张本有，难陀主张新熏。陈那、护法则主张有本有种，又有新熏种。
    3. 旧唯识师主张无相唯识，即唯心无境。
    新唯识师主张有相唯识，即境不离识。唯识者，唯遮境离心实有，识表内心非无，非有非无，即中道义。

    九、以心灵净化庄严国土
    经云：“心净故国土净、心染故国土染”。云何心净？谓外不染六尘，内不执人我，不着常着断，慈悲和谐，故名净土。
    故此心清净，便是庄严国土。七宝宫殿、五彩栋宇，皆表面之装饰，此唯凡夫之所谓庄严，非菩萨之所谓庄严。四无量心，四摄六度，利生之万行，乃菩萨之庄严，学佛者能识此旨，才能做到悲智兼运，福慧双修，圆证菩提。

    1990年冬月讲于重庆慈云寺


唯识答疑在读书会

    问：佛家的“心”与一般哲学所讲的“心”的区别？
    答：因果缘起唯心所造，心是主观的，能动的。佛家讲的心不是一般哲学所讲的心，佛家讲的心，它是一个本体，是个“性”；它的作用是万法之中都可以包括，所以谈到心，与物就分不开，真心与一切相是不能分开的，谈心就有色法，谈色就有心法；它是一体的，是总和的，不能把它分开，像普通哲学的“唯心论”，是分开的。唯心论、唯物论、理性论、经验论，它是分开的，分开就有问题，难免片面看问题。整体看问题，就会比较清楚，这是最实际的。有许多人误会了，以为佛教是唯心论，为啥呢？讲心嘛，却不知道佛教的“心”不是一般哲学讲的那个“心”。佛教讲“心”就有“色”，就有“物质”，讲“物质”就有“心”，不能把它分开看。你是怎样的“心”就会有怎样的“相”，“相”由“心”变，你是怎样的起心动念，你造了业以后，你感得的“正报”和“依报”，就各有不同，各有天地，各有宇宙。
    《华严经》中讲“应观法界性，一切唯心造”，三界万法，唯心所造。第一个说一切唯心，第二个说心、佛、众生三无差别，圣凡都是在于心。悟则成圣，迷则成凡，都是离不开心，真心受蒙蔽，就是凡夫，真心显露，就是圣人，都在于心。三界唯心，万法唯识，有世界就会有分别，识就是分别。第三个是法界观，以心摄十法界，天台宗讲“一念三千”，起个念头就包括三千个世界，看你起哪个念头就是哪个世界，这都离不开心。
    百界千如，法界是很圆融的。四种法界包括：事法界，理法界，理事无碍法界，事事无碍法界。
    事法界就是宇宙各种事物皆各有其区别与界限，包括心法、色法、有为法、无为法、有漏法、无漏法、染法、净法。
    理法界就是指平等的本体界。就是说宇宙之一切万物，本体皆为真如，平等而无差别，即是本心、佛性、真如。
    理事法界是无碍的，为什么呢？它是平等相融的。有心就有这个事，有事就有这个心，这是平等相融，互相交摄的。就像这个灯和光一样，灯体就是心，发出的灯光就是相，光与灯体是分不开的，互相融合，这就叫理事无碍。理与事平等相摄，互相交融，不能相离，称为理事无碍。
    事事无碍法界，就是一切法相像心一样，心能容摄一切，事与事也是互相交融的，大中有小，多中有一，由小中见大，大中可以见小，一中有多，多中又可以见一。一切世界都是这样的，一切相都是如此，不能把它分开，这就是缘起法。
    晓得这些就晓得了缘起法，晓得了缘起法就晓得了一切，事与事也是互相交融的，大中有小，多中有一，由小中见大，大中可以见小，一中有多，多中又可以见一。一切世界都是这样的，一切相都是如此，不能把它分开，这就是缘起法。
    晓得这些就晓得了缘起法，晓得了缘起法就晓得了性空的道理、真心的道理。这就是佛家的修养，佛家观察问题的方法。
    这四种法界就是说一切都是心物融和的现象，是层层无尽的，心胸要广大，像虚空一样广大，就能够包容一切，就会产生智慧。法界观就是理事无碍、事事无碍，这一点，一般哲学是讲不到的，佛家境界是很高的。
    一般哲学是把心、物完全分开，要么专门讲心，要么专门讲物，这就是什么多元论、二元论、或者一元论，是分开来单独看问题的。佛教看问题是从整体来看，讲修心，把染污心转成清净心，这是一个过程，这样达到的目的就是法界缘起，转识成智。尽管佛教的宗派有很多，但是方便有多门，归元无二路，都是一个目的。般若讲空，唯识讲空，心空境空达到真如境界。密宗讲大圆满、大手印，还是讲空，最后达到这个境界。所以各个宗派的目的都是一样。学佛就要把这个中心思想给抓住。

    问：唯识中依他起的“缘起”与中观所讲的“缘起”有什么区别？
    答：中观讲缘起，讲因缘生法，但具体解释还是靠唯识来解释。
    中观，就是般若，在汉传佛教叫般若，西藏叫中观。首先是破“执”，破执着，破我执，破法执，怎样破呢？就是一切缘起，都比喻成梦幻泡影。般若经有十个喻，金刚经是六个喻，一切都是因缘生法，缘起法，缘生法。这就是中观的思想，至于这个“缘”怎样讲，“因”怎样讲？就得由唯识来讲。
    唯识是有立有破，中观讲缘起性空，由性空显缘起，重在破，重在空。当然，这个空不是空洞的空，也不是渺渺茫茫的空，是空除执着的“空”，如《金刚经》上所讲“应无所住而生其心”，离一切相即名诸佛。什么相呢？我相、法相、非法相。我相是执着五蕴身为“我”，法相是执着一切现象都是实有的，非法相就是执着一切都是空的、断灭的。这些都要破除，《金刚经》处处都讲到这些。
    《金刚经》有三个大题。第一个如何发心，第二个如何降伏其心，第三个如何生心。
    第一个，如何发心呢？就是要发菩提心，其中有大悲心、大智慧心。胎、卵、湿、化、有色、无色、有想、无想、非有想、非无想，我皆令入无余涅槃而灭度之，这就是大悲心。如是灭度无量无数无边众生，实无众生得灭度者，这就是大智慧了。发心就要这样子发心。
    第二个，如何降伏其心呢？要无所住，破除人相、我相、众生相、寿者相。这些“相”都属于我执，由我而引申的，分别我、人、众生、寿者，是我执。
    法相就是执着一切都是实有的东西，把精神的现象、物质的现象都认为是实有的东西。对于凡夫来说，就是对六尘境界贪恋不舍，攀缘追求、起无明、起烦恼、造业，我执、法执、我相、法相，这就是流转生死的根本。
    第三个，非法相。执着一切断灭了，人死了没得了，没得因果。这一切，就是断灭相，这个“空的”要破，它否定缘起法，缘起法是不能否定的。染污缘起，清净缘起，唯识讲的三性，第一性，依他起性，就分染的、净的，你若是不能破除执着，遍计执不能破，我执、法执不能破，你就走的是不能解脱的道路，是堕落的道路。你学了佛，有了信仰，又了解，而且在行动上有行持，就会慢慢转过来，成为清净的“依他”。这样就会有种子在，种子遇到缘起，就会发生现形。
    在六因里面，有能作因、俱有因、同类因、相应因、遍行因、异熟因。有心就有心所，都是同时而生起来的。那么你起了现行，种了因，种一份因就会有一份果，这个果是种子，是潜伏起来的，这就是因果同时。
    另一方面，你若真是修定，就会有受用。有慈悲心，同时就有一份慈悲的受用，就把瞋心一分分断了。一分断了就一分证真，这就是修道位。修道位从初地到十地，分分证分分断，证一分真就断一分烦恼，所以就叫因果同时。比如说现在你听到我的话以后，你就已经熏习到你的本识中成为一种种子了，这就同时存在。这个种子对于将来的果来说，种子又是因，将来又有果，那叫异时因果。所以有同时因果和异时因果。

    问：请开示分别意识的“识”与唯识的“识”的区别？
    答：唯识的“识”通指八个识，各有其作用，而这个分别意识的根根是第七识末那识，我执识，凡是夹着我执在里面，对一切相分别内外，分别我法，分别能所，其中生起执着，从而就生起“我的就贪，别人的我也要贪”，这个就是虚妄分别引起的。这个分别与正确的观察是有区别的。学佛以后，有正知正见，能够加上定力，临境不迷，就会善于观察，这就不叫分别，作用就转过来了，由染污种子转成了清净种子，积累多了，慢慢到了见道位，就是禅宗的“悟”的境界，就能完全转过来了，变成智慧。这个意识就不叫“意识”了，变成了智慧就叫住妙观察智。所以这个虚妄分别，要善于对待，若是夹着我执和妄心，就叫虚妄分别；正确观察，合法合理的，以佛家的观点来看问题，很冷静的，有定力的，那不叫虚妄分别。

    2003年3月16日讲于北京三学读书会
    正根整理


玄奘法师与唯识学

    玄奘法师与唯识学
    --纪念玄奘法师圆寂1335年

    唐代玄奘法师的毕生成就，举世闻名，其学问和品德实属千古第一人，他是佛学家、哲学家、旅行家、翻译家，是爱国主义者、国际和平主义者，本文拟将其生平特点和终生阐扬唯识学要旨作一概述。

    一、玄奘法师的卓越成就
    （一）博学求真
    玄奘法师幼年出家，披剃以后，在国内各地参访善知识，学习经论。由于当时翻译不成系统，对教义解释各有异说，特别是瑜伽唯识的经论还不完备。为了得到正确的了解和进行系统的研究，玄奘法师发心西行求法。他经历各种艰辛到达印度，在那里游学佛法十七年，除了依止那烂陀寺戒贤论师学习瑜伽外，凡般若及小乘经论均用心研读，并参访印度各地，学习印度各派哲学。其博学多闻穷极真理的精神，在当时誉满中印，普受赞扬。
    （二）艰苦奋斗
    在西行求法路上，当时交通闭塞，行路困难，在广阔的沙漠中，上无飞鸟，下无走兽，粮水缺乏，法师克服了各种困难，坚持西行求法，并发下猛利誓愿：“不求得大法，誓不东归一步”。到印度后，法师研习佛法孜孜不倦，禅灯夜月，手不释卷。回国以后，译出大批经典，白天译经，晚上讲学，培养后学，尤具苦心，共有三千门徒，其中有卓越成就者七十人，窥基、元测、慧沼、智周等法师特别著名。他以艰苦卓绝的精神，在求法、译经、讲学方面取得了光辉的成就。
    （三）品质高尚，不染世尘
    唐太宗在三藏圣教序中，赞扬玄奘法师说：“有玄奘法师者，法门之领袖也，幼怀贞敏，早悟三空之心，长契神情，先包四忍之行，松风水月，未足比其精华，仙露明珠，讵能方其朗润。”唐太宗的这一段话，是对玄奘法师的真实写照和高度赞扬。他坚持清苦修学、讲学，坚持真理，不为世俗所染。回国之初，唐太宗钦佩他的学识，曾劝其还俗参政，玄奘法师婉言谢绝，专志弘法，在困苦危难中，仍保持正念，不忘三宝，直到临终还默诵《心经》，安详示寂。他志愿坚贞，始终如一，古今流芳。
    （四）融会贯通，阐扬真义
    在中印历史上，大小乘之争，空有之争，历来不绝。玄奘法师趣大舍小，以小归大，并融会般若瑜伽，宣示中道，特别提出瑜伽的三自性义，破遍计所执性以明真空，不落常见；立依他起性显妙有，不落断见，由此断除我、法二执，证得圆成实性。此三自性说，有立有破，合符中道。玄奘法师在印度曾著有《会中论》解释此义，在印度与小乘和空见论者均有辩论，全使对方折服，以至小乘论师赞扬其为“解脱天”，大乘论师赞扬其为“大乘天”。这说明玄奘法师洞察真理，精宣妙义，合符佛陀心印，熄灭了诸家争论。
    （五）学绝千古，万代留芳
    从唐代开始，日本、朝鲜、越南等地，均派有留学生来中国学法，玄奘之学借此远播海外。至今日本、韩国、朝鲜等地，还保持有法相宗或慈恩宗，宣讲瑜伽唯识之学。现又由亚洲传播至欧美，世界各大学和学术团体均倾力研究之。瑜伽唯识之学精深博大，以“六经”、“十一论”为根据，以因明为体裁宣讲唯识。（因明即东方逻辑学，较西方逻辑完备）。在解释人体和生命方面，不研究唯识学，即不能探测人体和生命的奥秘。修学佛法者，在净化心灵、清净三业、转染成净方面不懂唯识学，就不能履行正道，达到转识成智的目的。玄奘法师从求法到译经讲学，均以弘扬瑜伽唯识为主，他终身的受用在此学，他辉煌的成就也在此学，堪称千古绝学，万代流芳，值得后人们探究并依止修为。

    二、唯识学精华
    （一）广阔的人生和宇宙观
    佛学在分析世出世间的森罗万象时，小乘有75法，唯识发展为百法，其中有为法共94种，无为法为6种，将心法、色法等分类，详释其定义和作用。心法与色法统一，其中包括有情世间和器世间，有情世间包括胎、卵、湿、化等各种生命，器世间包括山河大地等各种环境。从宏观上讲涉及三千大千世界，无量无边世界的范围，以现代语讲就是整个四维以上的时空。这种根身器界都由心识所变现，心物不可分离，所谓心、物一元，心、境不二。《华严经》讲的法界观即理可摄事，事通于理，理事无碍，事事无碍，一多相摄，大小相融。如称芥子可以纳须弥，须弥可以入芥子，由微观到宏观的境界非常广大。
    （二）人体和生命的奥秘
    有情身体的组合即是“五蕴”（又称：“五取蕴”，有情执受积集所感），即色、受、想、行、识五种要素。此五种要素，概括起来就是色、息、心。色就是四肢百骸，五脏六腑；息代表呼吸的气息；心指整个八识（眼、耳、鼻、舌、身、意、末那、阿赖耶）。色息以心摄持为主，一期的生命存在于业力，由业力决定寿命，有寿命即有呼吸和温度存在。假如人寿当尽，最后呼吸与温度就都随之消失了，色身虽坏而生命是不会消灭的。本识的种子存在，发挥着潜能，根据业力又有不同的根身器界变现。阿赖耶识受熏持种，种子生现行，现行又熏为种子；缺缘现行，种子即潜伏，此潜伏的能力，仍相续不断。以生灭故非常，由相续存在故非断，非断非常，空间宽，时间长，生命延续流转，成为有情和宇宙的基本原因。唯识学称此为阿赖耶缘起，此阿赖耶缘起就包括业感缘起，十二因缘的三世流转现象，就体现了业力不灭的道理。
    （三）世出世间诸法真实相
    唯识学家根据诸法三自性说明世、出世间诸法真实相。其中“遍计所执性”，指众生由于迷情，妄计主观、客观为我，生起我、法二执，实无我体、法体可得。此执以第七末那识为主，在意识上产生的虚妄分别执有实体成遍计所执性，此属染污性，为生死流转的根本。“依他起性”属于因缘生法，指有为法的一切现象，包括因缘果，由于是生灭法，如梦幻泡影，幻有而非实有。因缘生法通于三世，扩大其范围，充满空间时间，法法相望都有密切关系。此依他起性，带有六识妄见，属染污性的；若听闻正法，熏习善法种子，逐步增进，根据修行阶梯，由染转净，在转化过程中，净化生命，履行正道，逐步深化，成就福慧圆满的法身，即“圆成实性”。玄奘法师阐明中道了义之教，即根据此“三性”之正理。
    （四）生命进化的阶梯
    佛教提倡净化心灵，实现由恶转善，由邪转正，由染转净。心灵净化也引生语言和行动的净化。修学大乘菩萨行，据华严、楞严等经，需经历五十五位，唯识学概括为五位，即资粮位、加行位、见道位、修道位、究竟位。其核心在拔度众生，完成佛道。修学过程中，必须积累福德与智慧资粮，发四无量心和四弘誓愿，勤修四摄六度之行等菩提因，以至圆证菩提之果。心净则国土净，心染则国土染。净化自己和世界，庄严国土，利乐有情，这是学佛的最终目的。

    三、结语
    弘一大师说：“法相宗又名慈恩宗，此宗最重要，无论学何宗派，皆应先以此为根底。”南怀瑾先生曾说：“密宗修法的理论依据是以唯识学的理论依据为基础。”此宗既深湛又广博，全部佛学的显密二宗，都以法相唯识学为理论基础。玄奘法师所学、所阐扬的法相唯识学，对阿赖耶缘起，根据中观宗的俗谛，唯识三自性中的依他起而建立。显明空有真谛，解决宇宙人生的大问题。玄奘法师依此修学，在译经过程中并为弟子们讲学，阐发此宗妙义，他的所学所行及所有成就，皆因根据此宗精神而达到了理论与实践的结合。特别是他的品格清高，艰苦卓绝、始终如一的精神，皆因从中得到了受用。今天我们举行玄奘法师圆寂1355周年纪念，并召开玄奘国际学术研讨会，是要追念玄奘法师的伟大人格，其丰功伟业，是以弥勒菩萨所创立的瑜伽唯识学为根本。唯识学广博精微，具有极强的系统性、逻辑性，且与时代思潮相合。在自然科学发展的今天，应发掘唯识宝藏，探索生命宇宙奥秘，使生命和宇宙都得到净化；人与人之间、人与生物之间、人与自然之间，达到和谐相处，消灭染污，净化世界，这是追求真理的人们应该共同荷担的任务。

    1998年12月15日


玄奘精神与西部文化研讨会总结提纲

    时值西安大慈恩寺为纪念玄奘法师诞生1400周年之际（按：2000年11月21日至23日），由中国佛教协会主办，陕西省佛教协会和西安市佛教协会协办、大慈恩寺和陕西社会科学院宗教研究所承办，以及在陕西省市政有关部门领导的支持下，共举行了有重大意义的五项活动。这些活动是：
    玄奘三藏院落成典礼
    增勤法师荣任方丈升坐
    玄奘法师像揭幕
    玄奘法师项骨舍利安放法会
    玄奘精神与西部文化研讨会
    这些活动都是承前启后和继往开来的盛事，有划时代的重要意义。
    今天对大会学术研讨做一提要总结（七项）

    一、研讨会的指导思想和目的：
    1. 如何继承和弘扬祖国的优秀传统文化？
    2. 如何探索中国佛教在新世纪的发展道路？
    3. 如何发扬中国佛教的优良传统，为建设具有中国特色的社会主义做出应有的贡献？
    （以上在陕西省社会科学院副院长杨学义的开幕词和大慈恩寺增勤法师的欢迎词中指出。）

    二、出席研讨会的54人，来自三市（北京、上海、重庆）七省（山西、河南、江苏、黑龙江、陕西、四川、广东）一区（新疆维吾尔自治区）。收到论文38篇。

    三、研讨会自21日下午开幕，23日午闭幕。其中有一次大会主题发言，两次大会交流，一次两个小组讨论，一次自由学术讨论。
    大会与小组都做到踊跃发言，热烈讨论，学术研讨气氛非常浓厚。

    四、论文内容分为八项：
    玄奘精神：如中国社会科学院教授、玄奘研究中心主任黄心川，增勤法师、彻性法师、俞朝卿教授等人撰写的文章共十篇。
    玄奘学术研究的共12篇。如玄奘法相唯识论、玄奘融通空有提出的中道论、阿赖耶识说、因明说、心经密咒意义、玄奘道问学与事佛性思想、玄奘融会思想。
    谈玄奘有关生平事迹的共3篇。
    从唐朝历史时代背景和有关地理环境情况来介绍玄奘情况的。
    从玄奘精神谈西部开发的2篇。
    法相唯识学建立到近代复兴及对玄奘翻译的评价2篇。
    建议创办玄奘书院和对宗教信仰及宗教学术研究2篇。
    有关玄奘《西域记》和如何对待玄奘顶骨的理论问题2篇。

    五、本次讨论会的特点（六项）
    论文内容见地极为丰富，体现了百花齐放、百家争鸣的学术研究风气。专家学者、各位法师都用了力，阐述了自己见解，增进了各界之间的了解。
    发言和争辩热烈，如对如何正确对待玄奘精神的问题，《西域记》与慈恩寺的关系，玄奘精神在求同存异，体现了“位中居和”、“和而不同”的中国传统文化精神，特别是重“求实”、“索真”的精神，以及客观的谦和态度。
    讨论的精神归结到玄奘精神如何在新时期继承，如何弘扬祖国优秀传统文化，如何对祖国两个文明建设和西部开发做出贡献，与大会的指导思想和目的是一致的。
    突出了玄奘的精神就是民族的“脊梁”、“牺牲”、“贡献”、“求实”和如何结合时代和实现人间佛教的精神。玄奘精神应为“脊梁”精神，提得很好。“大愿大行，敢于创新”是玄奘精神的精髓，提得很好。
    研讨会特别是教界与学界之间的交流，增加了相互的了解和团结友谊。
    老中青代表发言都有一定的水平，特别是青年人的发言，内容都有进步和提高，表明了后继有人的可喜现象。

    六、值得与学界继续商讨的问题：
    宗教与佛教的划分。以普通的宗教来解释佛教，不能概括佛教的特点，更不能表现出玄奘精神。
    佛教的“法”与政治上的“王法”的“法”是有区别的，甚至是本质的区别。
    “尊德性”、“道问学”是理学的提法，玄奘并非不讲佛性，他讲“理”、“行”的佛性。
    落实宗教政策后“政”与“教”分离的问题。
    对宗教学术研讨，即是广大信众的愿望，如何分析和解决，有待进一步的研究决定。

    七、两个实际问题：
    发扬玄奘精神。根据中国社科院哲学研究所刘培育教授提出的建议，创办“玄奘书院”和黄心川教授会后提出的建立“玄奘大学”，以培养德才兼备的人才，为社会主义建设做出贡献，非常重要。建议提出办公地点在西安、洛阳、北京三地，最好是玄奘翻译和讲学的西安，希望西安党政领导和佛协予以采纳，并对人事、预算、具体地点做出研究决定。
    就玄奘精神进行西部大开发，根据本如法师提出的如何发扬佛教的人才、文化、地理、经济资源的优势，以及山西省社科院周祝英编辑提出的西部地区环境的各种资源如何开辟的问题？如何使用科研人才、专家学者和培养人才的问题？发扬艰苦奋斗，排除万难，不怕牺牲的精神，对增进西部的开发中的两个建设是有实际意义的。西部开发着重发扬佛教的优势，建设高度文化，培养高素质人才，创办佛学院。
    这次讨论会的内容是实际的、广泛的，富有成果的。
    最后，谢谢主办、协办、承办单位的精心安排，省市有关领导的关怀和支持，大德法师、专家学者的同力合作，以及为研讨会服务的工作人员辛苦劳动，唐华宾馆服务人员的优质服务，最终使这次研讨会开得圆满成功。
    祝大家健康，吉祥如意。

    2000年11月23日


玄奘精神与人间佛教

    两千年来，以中印文化为主的东方文明，光耀世界，它是净化人心，指导人们履行正道的灯塔。从近代开始至今，西方科学发展，物质文明日新月异，使人们眼花缭乱，追求物质生活，各大国军备竞赛、核弹、导弹的制造，互竞优势，致战争潜伏，威胁和平。在此时期，人们精神空虚，前途悲观，于是，东方佛教文化提倡的净化心灵、明因识果、止恶行善；儒家提倡的诚意修身，维护人伦道德，实现和谐相处，作为人们提高理性维护社会秩序及世界和平的指导思想，日益显其重要。
    诞生于唐代的玄奘法师，广学多闻，深通佛教大小乘及世间各种学说，二谛圆融，智慧和品格很高，成就很大。可以说玄奘法师即是东方文化的代表，是千古第一人，应为世界学者所公认。
    西安大慈恩寺为玄奘法师率领门人翻译和讲学的场所，其中的大雁塔，为当时藏经之地，巍峨庄严，象征玄奘法师翻译和讲学的丰功伟绩。千余年来，几经兴衰，仍巍然屹立，为中外人士所向往。目前在西安佛协的领导、慈恩寺监院增勤法师的辛勤努力、以及各界人士的支持下，又建成规模宏伟的玄奘院。为继承和发扬玄奘精神，光大玄奘事业，裨益世道人心，都有甚深的意义。

    一、玄奘法师的精神
    （一）真诚学习，勇于探索真理
    玄奘法师自出家以后，在各地参访学习佛教大小乘教典，由于当时传入中国的经典有限，很不完备，众师解说不同，异说纷纭，无从获解。于是为了“一睹明法了义真文”，以求得佛教真理，决心西行求法，虽未得唐太宗批准，仍偷渡出境，冒险寻求真理。
    （二）不顾安危，受尽艰难而不退
    在西行道路上，备经艰难险阻，走过八百里大沙漠的行程，情况是“上无飞鸟，下无走兽，四顾茫茫，人马俱绝”。有时忍饥挨饿，有时盗贼威胁，但法师坚定志向，誓言：“不求得大法，誓不东归一步，”这种为法忘我，不怕牺牲的精神，体现了大乘菩萨“难行能行，难忍能忍”的行愿。
    （三）寻求真理，攀登学术高峰
    法师西行，历经五十余国，向各国佛教学者学习大小乘经典，还有因明、声明、梵文乃致婆罗门教典籍。在那烂陀寺依止戒贤法师学习瑜伽唯识、中论、百论等，被选为深通三藏的十德之一。法师是通达内外、大小、空有教义，并能会通融合，攀登了学术高峰。
    （四）建正法幢，作狮子吼
    法师为破斥外道邪说，捍卫真理，写也《制恶见论》；为融合般若瑜伽，建立中道观，息灭空有之争，写出《会中论》。在戒日王召开的曲女城佛学辩论大会上，立“真唯识量”，无人能破，一时名震五印，万人景仰，被大乘人尊为“大乘天”，小乘人尊为“解脱天”；又被请参加无遮大会，受到帝王、宰官、僧俗群众的推崇。
    （五）热爱祖国，在文化上做出贡献
    在西行道路上，被高昌王阻留，毫不动摇，绝食三日，以死表态，体现了中华民族的骨气。沿途传播唐代佛教儒道文化。回国以后，撰成《大唐西域记》12卷，备载唐代西北边境至印度的疆域、山川、物产、风俗、政事和大量佛教故事和史迹，为现在研究西域和印度古代政治、经济、宗教、文化、民族关系等问题的珍贵文献。他还把印度的天文、历算、医学、因明乃至制石蜜技术等介绍传入到中国，丰富了中国传统文化的宝库，成为中外文化交流的杰出使者，其爱国精神的巨大贡献，鲁迅誉为“中华民族的脊梁”。
    （六）译业彪炳，诲人不倦
    法师先后在长安慈恩寺和铜川玉华宫等地译经十九年，共译出经论75部，总计1335卷，其数量之巨，译文之精美，内容完备而符合梵文原本，实超前代译师，后代更无人与它相比。白昼译经，晚上继续，三更暂眠，五更复起。除译经外，每天晚饭后，还要抽出时间，为弟子讲演新译经论，解答提出的种种问题。并与寺中大德研讨各种理论，评述诸家异同，融会贯通。其译业彪炳，不辞劳瘁，诲人不倦，讲学论道的精神，也是空前卓绝的。

    二、玄奘精神与人间佛教
    （一）人间佛教思想
    中国佛教，由于受历史封建制度的影响，在民间蒙上神秘与消极的色彩，佛法真理不彰，被一部分人诬蔑为迷信和保守。轻视和打击佛教的现象，时有发生。20世纪30年代，提倡佛教革新运动的太虚大师，针对此流弊，在其《我的判摄佛法》一文中，提出《依人乘趣向菩萨乘》的“人生佛教”思想。
    他说：“人间世无一非佛法，无一非佛事。”
    “尽吾人的能力，专从事利益人群，便是学习佛的因行，废弃不干，便是断绝佛种。”
    “佛的因行，以敬信三宝，报酬四恩为本，随时代方国之不同而有种种差别。”
    太虚大师本此写有一首诗：
    仰止唯佛陀，
    完成在人格。
    人成即佛成，
    是名真现实。
    具体的讲，以皈依三宝，奉行五戒十善的人乘为基础，结合报答四恩，修学四无量心，四摄六度的菩萨行，以庄严国土，利乐有情，这就是“人生佛教”的思想。
    太虚大师据此写有《人乘佛教正法论》、《人生佛教》、《菩萨学处》等书。他的思想系统，系“教宗弥勒、学绍玄奘”，憧憬于弥勒龙华三会的人间净土。
    八十年代初，中国佛教协会会长赵朴老，继太虚大师的“人生佛教”又提出“人间佛教”，其中心是“一个思想”、“三个传统”。一个思想即佛教要顺应时代，与社会主义社会相适应。三个传统，即是要：1. 继承和发扬佛教的农禅结合；2. 学术研究；3. 增进国际友谊的优良传统。以农禅结合做到修行与劳动并重，维持经济独立，达到自给自养。以学术研究做到发扬佛教真理，建立正信，履行正道，弘法利生。以增进国际友谊，维护世界和平，消灭战争，净化世间。为实现人间佛教思想，赵朴老又提出教内的五个建设，即信仰建设、道风建设、教制建设、人才建设、组织建设。以培养僧才为骨干，加强佛教的自身建设，则能顺应时代，使佛教利生事业延续和发展，这是赵朴老的悲愿和苦心。
    （二）玄奘精神与人间佛教
    1. 德行的实践
    根据瑜伽唯识论所讲的菩萨修行的四十一位：
    十住：建立正信正见，修积福德智慧资粮。
    十行：广为利益众生之行。
    十回向：以大悲心救护一切众生（属三贤位）。
    十地：修十波罗蜜之十胜行（十圣位）。
    妙觉：为自觉觉他，觉行圆满，具三身四智微妙不可思议的佛果。
    这就说明证得佛果，必须经历积集福德智慧资粮而勤修菩萨大行。这种行持是渐进的、现实的、为人群谋利益的。而非玄妙的、空谈的、不切实际的。人间佛教正契合这一思想。
    玄奘法师的平生，德行清高，不慕荣利；艰苦奋斗，少欲知足，不图享受；悲愿宏深，为法为人，不惜生命；勤学实践，不落空谈；这正是超越世俗而又不舍众生的菩萨大行，诚如唐太宗赞扬说：
    “有玄奘法师者，法门之领袖也。幼怀贞敏，早悟三空之心，长契神情，先包四忍之行。松风水月，未足比其精华；仙露明珠，讵能方其朗润。”
    2. 真理的逻辑论证
    佛法真理，非如神学家的神秘，玄学家的空洞，西方唯心论哲学偏重思辩而不求实际，而是精密的、逻辑的、讲求实际的。佛教的因明学，以现量证知现实，以比量推察因果道理，以宗因喻三支比量作为论证事物真理的形式。玄奘法师探索真理，思想完备，对因明作了进一步的发展。在印度曲女城大会上，以“真唯识量”使大小乘及外道折服。回国以后，除译经外，抽时讲学。唯识学本具有精密完整的系统，在他为弟子的讲述中，更处处以因明论证唯识道理，使法相唯识学更加完备而发扬光大，成为慈恩宗的开山祖师。
    3. 爱国爱人民的情操
    如前曾述，法师在西行道上，眷恋祖国，在异邦宣传祖国文化。回国以后，近二十年中，翻译讲学，成绩卓著，充实了祖国的文化宝库。而其爱国人民的情怀，则见其所译所写论著中。
    法师所译的《瑜伽师地论》、《摄决择分》中，关于《佛为出爱王所说经》一节，借佛之口，对国王的“过失”、“功德”做了大段描述，提出做国王的十种过失，十种功德；又提出国王的五衰损门、五方便门（见经文，从略）。目的在劝诫国王力行功德而避免过失；广行方便而对治衰损。都是为了爱护人民，净化国土。上述内容被玄奘法师单独提出，经翻译后冠名《王法正理论》，单独流行，奉献于唐太宗，供臣民阅读。又在所著《西域记》中，借言地理风土人情，向太宗介绍佛教；在西域和回国以后，都曾宣讲《仁王护国经》，其目的是力图使国家最高统治者护法行善，使人民安宁，不受灾难痛苦。
    4. 增进国际友谊、维护世界和平
    玄奘法师游学印度十七年，前后游历了138个国家，遍访各地名僧大德，接触朝野各阶层人士，宣讲佛法真理，使国与国之间，人与人之间，互相尊重，和谐相处，避免战争，保持和平。中印历史千余年来，在漫长近万里的国界边疆上，由于玄奘法师和历代中印高僧的往来，传播真理，增进友谊，避免了战乱，维护了安定。所以玄奘法师不只是伟大的爱国主义者、真理的传播者，还是维护世界和平的国际主义者。
    玄奘法师的精神，如高山大海，永远为后代的人所学习和敬仰。

    2000年10月22日


读解深密经笔记

    一、本经特征
    1.经属瑜伽系，为弥勒菩萨撰述《瑜伽师地论》的主要根据。全经有系统地说明唯识的教义。
    2.解深密者，解谓解释，深密谓所说义理。是解释佛陀内证极理的甚深秘密妙义的经典。
    序品记佛陀现他受用身（卢舍那佛）于十八圆满的华藏世界，以弥勒、文殊等十大菩萨（极位大士）为对机而说；是非应身应土的说法，而是报身报土的说法。
    3. 说法以问答形式，极富论议的特点。
    4.本经译本共有四种，其中唐代玄奘法师所译共五卷（译于贞观二十一年）名《佛说解深密经》。译文较其他译本优美巧妙。其弟子圆测于《解深密经疏》中赞为“文义明净”，故通行本均采取玄译。

    二、各品概要（共八品）
    （一）序品，记佛演说本经缘起
    （二）胜义谛相品
    （从此品以下共七品为正宗分），品文共分四段：
    1.解甚深密意菩萨回答如理请问菩萨之问题，说明胜义谛（即真如）为离言说、绝分别的妙理，佛陀默然赞许。
    2. 佛对法涌菩萨说胜义谛超过一切寻思所行境界。
    3. 佛对善清净慧菩萨说胜义谛超过诸行一异之性相。
    4. 佛对善现菩萨说胜义谛为遍一切一味相。
    （三）心意识相品
    佛对广慧菩萨述第八识的体相。举出瀑流和镜面为譬喻，说明阿赖耶识生灭相续的相状，以悟生死之根源、知万法唯识之因由，此即唯识之事相。
    前胜义谛品为诸法实性，此品则显明世俗谛之现象。现象诸法由阿赖耶识的种子所生起，建立赖耶缘起。
    本品只提及阿赖耶识和前六识，尚无第七末那识。
    （四）一切法相品
    佛对德本菩萨说万有诸法皆具有遍计、依他、圆成三性，以说明杂染和清净的法相。
    遍计：我相，诸相；依他：缘生幻相；圆成：真如实相。
    （五）无自性相品分三
    佛对胜义生菩萨说诸三无自性相。
    1.遍计为情有，依他、圆成为理有。但有非遍有，含有空义，依彼三性有，建立相、生、胜义三无性的空义，为诸法无自性。
    2.依诸法本来无自性，故是清净涅槃，依此又可名一乘。此一乘唯根据理性说，但就众生根机，佛陀施教而有五性的差别。因不偏于空有，而树立诸法中道的正见。
    3.此品融和空有二边，会一乘五姓，划三时了不了义之教。
    （六）分别瑜伽品
    佛对慈氏菩萨说止观妙行，即于止中，观以上所明实性、法相，皆是识性、识相，心外无别法。悟得唯识所变之理。万法唯一心，一心摄万法，此即唯识观法。
    （七）地波罗蜜多品
    佛对观自在菩萨说明十地菩萨，依次修十波罗密之行，为趣证佛果之因。
    （八）如来成所作事品
    佛对文殊菩萨三身满德的大果，说明利生的妙因。菩萨修因，于十地金刚道，断变易生死，除二障，证二空，转识成智，证大菩提和大涅槃，分身尘刹，广度众生。
    以上八品总论：
    第一序分，明说法缘起。正宗分七品中，前四品为理论，后三品为实践。理论中，胜义谛品是明万有之实性。心意实相品至无自性相品明万有之现象。实践中，分别瑜伽品名唯识观法；地波罗密多品明唯识行径，以此二品为因，证得佛果，即如来成所事品，条理分明，次序井然。
    其中，分别瑜伽品对止观说明，特为详细。

    三、经文要义
    （一）如理菩萨问胜义谛分四（经卷一）
    初：如理请问菩萨问：“一切法无二者，何等一切法？云何为无二？”
    经文：“解甚深义密意菩萨谓如理请问菩萨曰：善男子，一切法者，略有二种，所谓有为、无为。是中有为非有为非无为，无为亦非无为非有为。”
    答意：有为、无为，均是本师假施设句，若是本师假施设句，都是遍计所执言辞。众生随名起执，执有定法，故非有为，亦非无为。但由佛于如幻等，依他因缘之法而说有为；于自证离言法性为他假说，谓之无为。
    1.此胜义谛，是超寻思所行相，由法涌菩萨请问，如来解答。寻思但行有相境界，而胜义谛超过一切寻思境相。寻思可言说，胜义不可言说，绝诸诤论。
    2.善清净慧菩萨问此胜义谛与诸法差别，是一耶？是异耶？佛答：若胜义谛与诸行相不异者，应同杂染。若异者，应非诸行共相（共相即诸法的苦空、无常、无我之相，圣者悟此而见真）故与诸法非一非异，佛以十四喻为示，略。
    3.善现（须菩提）就胜义谛遍一切一味相，诸增上慢者，不能了解，请问世事。佛答：此胜义谛相，微细最微细，甚深最甚深，难通达最难通达，通一切一味相。圣教中修行比丘，尚难通达，何况外道？
    （二）广慧菩萨问心意识（经卷一）
    初：广慧菩萨问：（1）佛说于心意识秘密善巧菩萨，能于心意识中善巧？（2）如来齐何施设彼为于心意识善巧？
    此二问中，前指地前菩萨，后指地上菩萨。
    佛答分第四：
    1. 名阿赖耶，赖耶为种子识，由种子成熟牵“生有”起，如是展转成为一期生命，依二执受。一者根身，受而又执；山河大地，执而不受。二者相名分别言说戏论，习气执受。此识名阿赖耶，又由我爱执藏故。第七意是以执我为主。
    2.即此第八亦名阿陀那，此云执持，能执持种子及色根故。
    3. 此识亦名心。由此识能积集滋长色、声、香、味、触、法等六尘种子故。
    4.由阿赖耶识为依止，故六识身转生，——五根五尘合生五识，同时有五俱意识生起。
    此心识义，地前菩萨依如理如量智而知。地上菩萨，证真如时，泯绝能所，心色诸法，得以契证。
    识随境风，生起识浪，而生命相续不断，经中喻言：“阿陀那识甚深细，一切种子如瀑流，我于凡愚不开演，恐彼分别执为我。”说明本识微细甚深。
    （三）德本菩萨问三性义（经卷二）
    德本菩萨问：齐何名为于诸法相善巧菩萨？如来齐何施设彼为于诸法相善巧菩萨？
    佛答：诸法相略有三种：一者遍计所执相，二者依他起相，三者圆成实相。
    1.遍计执相：一切法假名安立，自性差别。众生愚痴，随名执实（执我执法）
    2.依他起相：一切法由因缘生，谓此有故彼有，此生故彼生，如十二有支，由无明缘行……乃至招集纯大苦蕴。
    3.圆成实相：谓一切法平等真如，诸菩萨众，如理作意，无倒思维，因缘生法，渐次修习，圆证菩提。
    上三相义，经中以眩翳喻及颇胝迦宝喻明之。
    能如实了知诸无相法、杂染相法、清净相法，断染证净，如来施设彼为于诸法相善巧菩萨。
    （四）胜义生菩萨问三无性义（经卷二）
    胜义生菩萨问：世尊于经中处处宣说蕴处界等种种诸法，生灭染净知断证修。后时复说一切诸法皆无自性，无生无灭、本来寂静、自性涅槃，前后二说岂不相违？
    世尊解答分五：
    1.依三种无自性性密意，言说一切诸法皆无自性。
    （1）相无自性性，谓诸法遍计所执相（我相法相），诸法但假名安立，非实有自相故。
    （2）生无自性性，谓诸法依他起相，由依他缘力故有，非自然有。
    （3）胜义无自性性，圆成实相，亦名胜义无自性性。诸法无我，名为胜义。胜义二空所现，亦名真如。
    初，相无自性，喻如空花；次生无自性，喻如幻像；后胜义无自性，喻如虚空。
    2.建立三种无性因缘：由诸有情，随名言于依他，圆成执着遍计，由是因缘，起烦恼、业、生三种杂染。于生死中长时流转，受诸苦恼。
    3.就观机说三无性，初约四十心（十信、十住、十行、十回向）资粮位说；次约四善根（暖、顶、忍、世第一）说；后约地上菩萨位说。
    4.就秘密说一乘意，明三乘人同依无性之道，证得涅槃。二乘由人空，菩萨由人法二空所现真如，达胜义无自性性。
    但经中说明一切有情，由于下中上三根差别，而有五姓不同。
    5. 明有四种人于佛密意有了不了：
    （1）有善根，具足信解。
    （2）具善根有信无解。
    （3）具思择力，但随言执着，拨一切相是无相，落于空见，名恶取空。
    （4）末种善根，性非质直，不生信解，毁谤正法。
    无相之理，非凡能了，密意说一乘。虽说诸法无性，但密意明遍计所执诸法无性，不辩依他，圆成无性。依他幻有，圆成胜义有故。对此若加以否定，则世出世间因果不能建立，落于断见。
    世尊于此品中立三时教。初为声闻乘，说四谛法，明有世出世间因果。次于初发趣大乘者，为破其有执，说般若明诸法皆空。密说遍计性本无。末于第三时中为已学菩萨乘者，说深密经，具辨遍计所执性无，依他、圆成二性有，是为中道了义之教，前二时为不了义。
    （五）慈氏菩萨问止观义（经卷三）
    慈氏菩萨问止观义，世尊解说分二十六门，今提出内容重点十项：
    1. 止观以教为依，不舍大菩提愿为住。
    2. 止观所缘：
    （1）地前菩萨以观智依教修时，自变似法似义影像相分，以观心推求，名有分别影像所缘境事。
    （2）地前菩萨以止心所变似法义境，止心名无分别心，无分别心所现影像故，名无分别影像，所缘境事。
    （3）地上菩萨（初地到十地）止观所缘真如。真如遍满一切事法，故名事边际境所缘。
    （4）佛地世尊，所作一切成办，故佛地止观所缘名成办义境。
    3. 求善达止观：闻佛经教，是名闻慧；如法思维，是名思慧；以闻思慧依教法缘自心所变相分，内心相续见分，以之为境。如是安住于正行，起身心轻安，得其正定，即奢摩他。即于如是三摩地影像所知义中，能正思择，最极思择，周遍寻思，周遍伺察，安忍观察其义，是名毗钵舍那，是名菩萨能善求止观。
    4. 菩萨由十种相，了知于义：
    （1）知尽所有性（缘起）。
    （2）知如所有性（真如）。
    （3）知能取义（内五色根及心意识）。
    （4）知所取义（外六尘）。
    （5）知建立义（有情世间，器世间）。
    （6）知受用义（诸有情领受资具等）。
    （7）知颠倒意（执世间常乐我净等）。
    （8）知无倒义（三法印，四昷陀南等）。
    （9）知无杂染义（烦恼、业、生三杂染）。
    （10）知清净义（离三杂染，所有菩提分法）。
    5.知七种真如：
    （1）流转真如（诸行流转，无始无终）。
    （2）相真如（人法二无我相）。
    （3）分别真如（一切行唯是识性、识体以分别为性故）。
    （4）安立真如（苦圣谛）。
    （5）邪行真如（集圣谛）。
    （6）清净真如（灭圣谛）。
    （7）正行真如（道圣谛）
    6. 智见差别：缘于理的总法妙慧，名智；缘于事的别法妙慧，名见。
    7. 以十七空遣除十相，即文字相、生灭住异相、顾恋身相、我慢相、资财相、受用相等。此十相都是遍计所执，皆以观空除遣。总于依他圆成实上，若有所执，即为遍计，知所知空，名总空性。故离遍计执，是大乘中一切空相。了此空相，即有二利：
    （1）不失正行。
    （2）离增上慢。
    8. 止观作业：能解除相缚，粗重缚。粗重缚：即是烦恼见分种子。相缚：即是烦恼相分种子。
    9、止观障碍：
    （1）顾恋身财，不能少欲知足，是止障；于法义无增上意乐，不深观察是观障。
    （2）掉举、恶作是止障；昏沉、睡眠、疑惑是观障。
    10. 止观之果：
    以修止观故，息妄想分别，除烦恼，证涅槃。以修观故，息无明颠倒除所知障，证菩提。
    （六）观自在菩萨问诸地义（经卷四）
    世尊答观自在菩萨，正义分四： （1）辨地义。（2）辩地中所应学法，分二十三句。（3）明地中所断烦恼及得果。（4）辩说一乘意。
    1. 十地名义
    （1）欢喜地：初得无分别智，成就自利利他，而生欢喜。
    （2）离垢地：远离一切微细犯戒，具足净戒。
    （3）发光地：依于诸定能发智光，闻思修三慧照明，故名明地。
    （4）焰慧地：烦恼如薪，智如火焰，以智火烧烦恼薪，故名。
    （5）极难胜地：真俗二谛，由多艰难，方得相融，以出世间智方便善巧难度能度。
    （6）现前地：后智现前观于缘起，以无相修，无分别智多修，功用方现再前。
    （7）远行地：从初地起远至第七，经一僧祇，修无相行，方得无间，证入无相，与第八清净地为邻，超过二乘出世间道。
    （8）不动地：真智入无功用位，俗智虽有功用，而不为现前烦恼所动。
    （9）善慧地：获四无碍解（法、义、辞、乐说），说法无碍。
    （10）法云地：法身圆满，智如大云，充满虚空，普施法雨。
    2. 十地修学十度，依次为布施、持戒、忍辱、精进、禅定、智慧、方便、愿、力、智，余略。
    3. 初地，分别我法二执已断，俱生我法二执犹伏。七地，俱生人我执种子已尽，法执现行已伏，种子未尽，十地至佛地，法执种子断尽，能善观察诸法性相，烦恼、所知二障悉断。
    修诸度果：
    （1）得大财富（法身之财）。
    （2）往生善趣。
    （3）无怨无坏，多生喜乐（法喜）。
    （4）为众生主（导师）。
    （5）身无恼害（具自在威德力）。
    （6）有大宗叶（菩提树叶）
    4. 明密意说一乘：三乘圣道，事法差别，有上中下，如理则通一法界而不相违（全义如正文，略）。
    （七）曼殊室利请问三身义（经卷五）
    三身者，即法身（真如）、报身（万德庄严：自身受用、他受用身）、化身（悲愿度生：变化身、应化身）。
    佛答，以十四门辩（此不全举）。
    十四门中第五如来言音差别，特详述三藏内容，一者契经，二者调伏（戒），三者本母（论）。
    于经藏中，特明四事、九事、二十九事，于调伏（律藏）中，明七种相，即遮戒、性成、犯戒缘、犯性罪、持戒、悔过、舍戒等。于论藏（本母）中，明十一相，其中第四行相中，特明八行，第七行明四种道理，即诸法观待道理、作用道理、证成道理、法尔道理，意义广大而精微，此中证成道理，赞佛果功德，名一切智者相，共有五种：
    1. 一切智声，无不普闻（佛以一音演说法，众生随类各得解）。
    2. 具三十二丈夫相，八十种好，庄严美妙。
    3. 具足十力，断一切疑。
    4. 具足四无所畏，不为他说（外道邪说）所伏。
    5. 于善说法毗奈耶中，如三学、八正道、四沙门果、菩萨行境，皆可现证。

    2004年3月作于重庆华岩寺


读楞伽经笔记

    一、概论
    （一）《楞伽经》要义
    “佛语心为宗，无门为法门”，这是《楞伽经》的要义。本经为融通性相之学，指示空有不异的事理，说明理论与修证的实际，读时需慎思明辩，严谨分析，然后归纳论据，融会于心，才能了解其真义。
    （二）是心地法门
    达摩西来，传心印于二祖慧可，并言：吾有《楞伽经》四卷，亦用付汝。即是如来心地法门，令诸众生开示悟入。故在五祖弘忍以前，禅宗均奉行《楞伽经》。
    （三）一百零八个问题
    《楞伽经》的开始，首先由大慧大士发问，提出一百零八个问题，其中有关于人生的、宇宙的、物理的、人文的……，这些问题，都是古今中外人们心目中的疑问。
    对这些问题，佛都不随题作答，只是直截了当的说心、说性、说相，引向第一义谛，主要在直指人生的身心性命，与宇宙万象的根本体性。若依世俗循名辩相，则万类纷纭，毕竟永无止境，徒增分别执着。
    世尊由五法、三自性、八识、二无我加以析辨，指出一个心物实际的如来藏，作为总答。
    因此，本经为唯识法相学的宝典，般若是称性而说，于因缘假名如幻法中揭示如来自性。唯识法相学则于立中有破，破相破执，才是彻底说空的佛法。
    《华严经》与《瑜伽师地论》，有关由心识如何建立世界（有情世间、器世间、圣者世间）的道理，及如何真修实证以证成此道理，比较精微详细，值得研究。
    《华严经》说：“应观法界性，一切唯心造”，又说：“一切皆从法界流，一切还归于法界”。这说明森罗万象，统统是如来藏中的变相而已。
    （四）楞伽译义
    楞伽为宝名，又译不可到，即难入之义，佛于邻近南印度的狮子国，过去称锡兰，现称斯里兰卡，在此国的楞伽山上，说出本经。

    二、《楞伽经》的翻译
    本经译本，共三种：
    （一）宋译：公元443年间刘宋时代，求那跋陀罗（译云功德贤）译出《楞伽阿跋多罗宝经》，计四卷。
    （二）魏译：公元513年间，菩提流支译出《入楞伽经》，计七卷。
    （三）唐译：公元700年间，实叉难陀译出《大乘入楞伽经》，计七卷。
    普通流行本，都以宋译为准。

    三、《楞伽经》正文要义
    （一）卷第一：一切佛语心品之一
    1. 大慧大士赞佛大智大悲功德以后，提出一百零八个问题，请佛解答。
    2. 佛总答：“大乘诸度门，诸佛心第一”。
    这是本经的真义，谓大乘一切法门，是以诸佛的心地法门为第一。佛说：提出问题的本身，就是问题，一切应归之于心。
    3. 佛告大慧，诸识有两种“生、住、灭”的作用，都不是思量推测所能够明瞭的。何谓两种生？即流注生和相生；如川流不息地生生不已，名为流注生。因而发生所有相续不断现象，名为相生。何谓两种住？即流住和相住，如瀑布流注般的宛然相续，才有一切现象界的存在。何谓两种灭？谓流注灭和相灭，即是相续存在的力量同时不断的消逝，以及现象的消灭。
    佛法所谓识，相同于一般所说的精神。但依唯识的精义而言，通常所谓精神，还是唯识的变相作用。佛说三界唯心，万法唯识，乃是指宇宙万有的全体大机大用，只是唯识的变化。
    佛答大慧的话，是说明宇宙万有的识变过程，不外生起、存在和消逝的三个阶段，而这三个过程，归纳起来，又只如川流不息的相续与相互依存的力量，却由它发生现象（相、用）的两种作用。但是一般人都只在理论上去推测（从表面的片段现象和片面的推理），却不能亲身体验它的究竟。
    4. 佛告大慧：
    （1）一切识有三种现象：一是转相，乃是辗转变化的现象，称为转识。二是业相，乃是业力（善因乐果、恶因苦果）的现象，称为业识。三是真相，乃是圣智的现象，称为正智。
    （2）广泛说八个识，简说只有三种识，一是真识，乃是真相之识，如来藏识。二是现识，乃是对境可显的现量识，称为现识。三是分别事识，乃是能分别一切事物的识，称为分别事识，现识所显示的现量境的作用，犹如明镜照物，了了分明，相来不拒，相去不留。
    人们面对世间一切事物，最初还没有意识分别的升起，此即现识的现量境的作用。但刹那之间，立刻就会生起意识分别的作用。所以不能把握现量境，就无法认清现识的面目，而体验到唯心唯识的道理。
    现识吸收六尘的现象，和受无始以来习惯性的妄想熏染，就形成分别事识的因。
    要不著相，须首先消灭分别事识的作用，于外境当下消除妄念。分别意识灭了，就能证见如来藏包含宇宙万有之机的真面目。
    法相唯识之理，是说明凡夫心识现状，都是从如来藏识的业力流注为因，由无始时的我执和对法尘的遍计执，以及现行的业力互相辗转熏习，生起人我的八种心识现象作用，故名为八识，如果能灭掉妄想、熏习，不起遍计所执和依他而起的作用，就能顿断业识妄想之流，转识成智，证得真如性净的如来境界。
    灭一切业识之流的流注相，除掉幻有妄想种子的熏习，而成净智的圆明，契证无生法忍。
    了解唯心的缘起性空，逐步修行，从初地到十地，善于分别观察，达到如幻三眛境界，证得无生，入于如来境界，本慈悲愿，分身尘刹，方便度生。
    （3）由于意识攀缘外境，使平静无波的藏识海中，掀起波涛汹涌的洪流，当此全海既已生波，那平静的如来藏识，就统统变为识涛业浪了，众生在此虚妄境界中，愈陷愈深，轮转不息。
    偈云：
    譬如巨海浪，斯由猛风起，
    洪波鼓冥壑，无有间断时。
    藏识海常住，境界风所动，
    种种诸识浪，腾跃而转生。
    心与物的接触，发生世界种种事情。其实心与物是一体的，只是由于七转识分别现行而有差别。如海水之与波浪，波浪虽多，而不失水性。
    藏识是受熏能累积一切业力（业种）的根本，意识的作用就是增长业力。虽有心意识等差别，但都是根尘相对，其作用便是指能识别和所识别的作用。一念妄心起，就有内外种种分别，而有颠倒不实的认识。
    真心，是无相无住的。妄心，则根尘相对，而有种种分别（能所分别），故名唯识。若能把能觉想和所觉想的作用消除，就可证知心的真实面目。
    （4）成佛之道，须修圣智三相：
    ①无所有相：不住于相，观诸法空性。
    ②自愿处相：大悲大愿。
    ③自觉圣智究竟相：得如幻三昧之力，循诸佛修习所趣的诸地次第而行。
    （5）心物一元论：
    如来为使众生解悟，分别凡圣之路，说五法、三自性、八识、二无我。
    ①五法：
    名（对境相施设的各种名言）——名言执着；
    相——六尘事相；
    分别——妄心分别；
    正智——离分别心之智；
    如如——二空所显真如，圆成实。此中：能执——分别心，所执——名相＝属凡夫，能证——正智，所证——如如＝属圣者。
    偈云：
    名为遍计执，相是依他起；
    名相二俱遣，是名真胜义。
    ②三自性：遍计执——执着事相和名相；依他起——仗因托缘而生之有为法；圆成实——于依他起上舍离遍计之无为法。
    ③八识：眼、耳、鼻、舌、身、意、末那、阿赖耶。（解略）。
    ④二无我：人无我——去掉对五蕴身的妄执；法无我——去掉对蕴处界等法的妄执。
    破除妄执，修自性如幻三昧，地上菩萨到佛果，都是从修如幻三昧中产生。
    破执即空，空有七种：一、相空：诸法的自他共相本来是空，性非常住。二、法性自性空：法性本体，即是无生。三、行空：行者作用，凡夫身心的作用，是由于业力，业力无性。四、无行空：缘起作用无自性，本性清净，无有诸行。五、一切法离言说空：诸法自性，本无言说，绝思议。六、一切法第一义圣智大空：证得自觉圣智，一切诸见习气都自然远离。七、彼彼空：一切法显现的各种境相，都无自性，故空。
    空其实性，而非空除业力，业力是相续不断。自觉圣智，绝不在言说中。
    （二）卷第二：一切佛语心品之二
    1. 如来藏与外道所说真我不同，必须远离妄想，达到无所有的境界，才能契证如来藏自性。
    2. 大乘道修行方法：
    （1）善于分别万法都是自心所现。
    （2）善于观察外境都无自性。
    （3）善知诸法如梦幻泡影，了无形相实体可得，才能证入无生法忍。
    （4）得自觉圣智的无漏善，住第八不动地，了解五法、三自性、八识、二无我的实相，而获得意生身。
    意生身者，譬如人们心意识的作用，当它产生幻想时，立刻可以生起，驰骋于天地，自在无碍，故名意生。当它变化时，自由来去，不为石壁所阻，不为地域所限。人的意识，为何能够如此自由？因为人的思想，凭以前的经验，变成了记忆，记忆在心中，相续流注不绝，可以生起幻想。意识本身是无形无质，不为身形所囿，而意志行为，为一身主宰的源泉。
    菩萨证得意生身，弹指之间，以如幻三昧之力，具足一切神通妙用，能随本来愿力，遍于十方国土，供养诸佛，普度众生。
    意识根源于如来藏识，其种子功能，都是业力现象，生而无生。转识成智后，一切境界，都是意生身和如来藏的全体妙用。
    证入第八不动地，获得自在无碍的意生身，必须具足正见，循菩提正道而次第修习，切忌痴心妄想，舍本逐末，误入邪道歧途。
    3. 言语文字都是妄想所生，并无实性，佛法重在求证自觉圣智乐善的第一义。去除妄念，永断业力的相续统注，自能摆脱三有束缚。
    观世如幻，自不为幻象所惑。所谓：“知幻即离，离幻即觉”，心灵的如意珠，本来纯净无染，一旦开发，自能照见诸色相，了解森罗万象。
    4. 佛对一百零八句的总解。
    一百零八个问题，都是空无自性，惟有如来究竟境界，才能直探第一义。“善能分别一切法，于第一义而不动”。
    一切法有事有理，妄心执着即有相对性。即有：一异、俱不俱、有无、亦有亦无、非有非无、常无常等分别执着产生。
    5. 禅的类别。
    （1）愚夫所行禅：即声闻（厌离色身，只证人空）外道（世间定）之禅。
    （2）观察义禅：观察一切法，无真实自性。
    （3）缘真如禅：达到不生妄想，心无分别，寂静安宁。
    （4）如来禅：真实证入如来境地，得自觉圣智安乐。
    于禅定中现出众相，系心外有法之习气所生，必须远离众相，了无可行，才能证入如来禅。祖师禅者，并非离开如来禅。
    “心佛众生三无差别”，悟入真实空性，即无心、佛、众生可得。
    言说自性相——言语理论等即名言习气。
    事自性相——妄心所现差别境界，即相分习气。
    依真如之体，言真如之用，有何三世、自他之差别。
    法身自性虽然体空，却具无量神力，具足万法，用物质和世间语音，是不能推求和衡量的。法身者，妙觉明心也。
    真如自性体空，离言说，绝百非，于平常心中，自觉体证。
    6. 万有现象，是唯心现量的显现。
    物理现象，如梦、幻、泡、影、海市蜃楼，并非真实。智者不被其惑，即离一切分别妄想，悟证真如。
    惑乱境界——凡夫，心外执物——妄心。
    不二境界——圣者，现量证境——真如。
    断惑证真，若执有真，也为惑乱。真如实相，了不可得。谈空而执空。如渴鹿逐阳焰，误以为水。
    菩萨观一切法，都住于诸法本自无生的体性中，如经说：“是法住法性，法界性常住”。又说“无不从此法界流，无不返归此法界”。
    7. 四大：坚、湿、暖、动性，都属妄想的功能产生。由业种故，而有内外界种种境相，相续流注于无穷尽的未来。五蕴之身，亦是由妄想心所显现的幻境。
    由于意识，才有流注相续的现象，于境无著，波浪不起，意识分别灭，则其余诸识皆不生起。转识成智，善观诸法的自相、共相。
    8. 悟入空性，证得法喜，初欢喜地菩萨，发广大之愿，以十无尽愿而成就。
    （1）众生无尽；
    （2）世界无尽；
    （3）虚空界无尽；
    （4）法界无尽；
    （5）涅槃界无尽；
    （6）佛出现无尽；
    （7）如来智界无尽；
    （8）心所缘无尽；
    （9）佛智所入境界无尽；
    （10）世间转、法转、智转无尽。
    （三）卷第三：一切佛语心品之三
    1. 三种意生身
    （1）三昧乐正受意生身：菩萨入第三地、第四地、第五地，得三昧正受，自心寂静，安住于性海中，各种妄想的识浪不生。
    （2）觉法自性意生身：第八地菩萨，观察觉知一切内外诸法，如梦如幻，毕竟一无所得，身心转变，得如幻三昧和其他各种三昧，发自在神通妙用。
    （3）种类俱生无行作意生身：已经证觉一切佛法，得到自证实际的法乐。
    2. 佛说：“宁取人见如须弥山，不起空见（即断灭见）如芥子许”。
    3. 宗通：内证境界。说通：以各种语言文字，表达教义。
    4. “远离心意识，才能达真体，离二边颠倒，具足真知见”。
    5. 识与智的差别：根、境、识三和合而生的作用是识；觉悟自性无生的是智。（一有妄想分别，一无妄想分别）。
    藏识与七识俱生，即有能取和所取的功能，故有相对性的执着，而名言又系其代表。
    （四）卷第四：一切佛语心品之四
    1. 无住：“应无所住，而生其心”（《金刚经》）。
    应无所住——真如体。而生其心——真如妙用：悲、智、愿、行。
    2. 弥勒：瑜伽四依：
    （1）依法不依人;
    （2）依义不依语;
    （3）依了义经不依不了义经;
    （4）依智不依识。
    3. 无生，是圣贤所证之法，凡夫贪瞋痴，是内在我执、业习气、名言习气的连锁关系。
    4. 初期地到七地，已观察到三界唯心，从本以来，离我我所。
    菩萨虽住三昧，而不住于涅槃。若舍弃众生，不度众生，佛种会断。如此则违佛戒，不名菩萨。
    5. 唯识精义
    （1）藏识名者，以第八识与前七识俱生而起，如海中浪连续不断。觉知无我，妄心息灭，则恢复海的自性无垢，便得清净。
    凡夫七识分别诸境，被名相所缚，妄想攀缘，则有诸识的生灭，若离妄想分别，不再造业，则得解脱。
    （2）转了前七识和藏识的作用，即不为名相所缚，不再有能取所取之相。
    藏识因第七末那和前六识的分别，而有生灭；如来藏则已恢复清净，无有生灭。
    如来藏如一大圆镜，若依妄心而起，便有物像显现，而有能取、所取，众生由此计相执着，不见真实。
    （3）妄心是八识的总名，八个识是妄心的分层作用，举譬喻说明：妄心，是演戏技师。意识，是技师配角。前五识，犹如演戏的各种角色，成为一套班子，演出各种剧情。
    妄心的现象——七情六欲。身（包括语言）——各种造业的动作。
    凡夫世间的大舞台，就锣鼓喧天的演出了。
    （4）在五法中，六尘境界统称为相；依相施设文辞，加以区别，曰名；具有能缘，能分别的作用，即虚妄分别。了知名相如幻，生灭不停，无有实体，曰正智；泯绝名相，住无所得境界，曰如如。
    不执名相，也并非不要立名相，只是舍离有无二边的见解，住于中道实相的正见（例如圣言量、文字般若）。
    （5）发菩提心，具大悲愿的菩萨行者，应禁绝食肉，经文举出十五种的食肉过失（略）。
    经文说：佛不叫人吃肉，因佛是以大悲心为体的。应当视一切众生，犹如独子，不要自食子肉。
    偈云：
    食肉无慈慧，永背正解脱；
    及违圣表相，是故不应食。
    得生梵志种，及诸修行处，
    智慧富贵家，斯由不食肉。

    2004年春作于重庆华岩寺


缘生要义

    一切有为法，包括生物、植物、社会、自然等现象，均待缘生，非梵天、神灵主宰生，亦非无因自然生。世上决无无因之果，亦无无果之因。因果分明，不容杂乱。因、缘、果三义，是佛法的中心，通于五乘。
    《中论》云：
    诸法不自生，
    亦不从他生，
    不共不无因，
    是故知无生。
    不自生者，待众缘故；不他生者，以自种生自果故；不共生者，非众缘都作亲因，生果有自性，生因不容杂乱故。不无因者，非无因自然生故。是固知无生者，因缘生法，无实体性，假名如幻故。
    现依唯识学，略释缘生要义：一、四缘义；二、十因义；三、五果义；四、三种缘起义。

    一、 四缘义
    （一）因缘
    因缘者，《成唯识论》云：“谓有为法，亲办自果”。此因缘之体有二：一种子，二现行。
    种子者，系潜藏于第八阿赖耶识中的功能差别，虽无形象，而有势力，能正为因亲生自果。
    此种子有二：一等流种，亦称名言种；二异熟种，亦称业种。由色、心、善恶无记，有漏、无漏等种子各生自果故，平等流类，故名等流。由业种为增上，感生异熟报体，引业感总报，满业赶别报，《八识颂》云：“动身发语独为最，引满能招业力牵”，造业以第六意识的思心所为主，由思发动身语，为强有力的意志造作力量。
    现行者，现谓显现，行谓生起，即本识种遇缘生起的前七识心心所及色法，此现行为因，复熏成自类种藏于本识。种现生熏为同时因果；种未遇缘时，种子前后相续为异时因果。
    （二）等无间缘
    等无间缘者，《成唯识论》云：“等无间缘，谓八现识及彼心所前聚于后，自类、无间等而开导，令彼定生”。后心心所之续生，必赖前心心所为缘，同类相等，无有间断，而得开导引生。例如行者初见道心，必由前世第一法的无间定为之开导。又如相间道必由真见道后无间相续而起。此缘体仅限于现起的心心所法，非无为法及色法。
    （三）所缘缘
    《成唯识论》云：“所缘缘者，谓若有法，是带己相，心或相应，所虑所托”。谓作所缘之法，非龟毛兔角，龟毛兔角是无法，不能作所缘缘。此所缘之法，为心心所所虑所托。所托者，谓托此法而生起，所虑者，谓仗此法而缘虑故。故此所缘法，望于心心所必具三义：一是挟带己相故，二是托己而起故，三是缘虑于己故。为心心所所缘之缘，名所缘缘。此又分亲与疏两种：亲所缘缘即识体生起时，见分缘识所变之影象，属亲相分。疏所缘缘即识挟带外本质尘（根身山河大地）变相而缘，此本质尘与内有间隔故，属疏相分。
    （四）增上缘
    增上缘者，《成唯识论》云：“增上缘，谓若有法，有胜势用，能于余法，或顺或违”。
    增上，即是对他法生起的助力，如谷种之生，必须靠水、土、阳光、肥料、人工等，才能生长。八识之生，亦各有增上缘，如眼识九缘，耳识八缘，乃至第八识四缘等。
    凡增上缘，皆有正负二种功能，正是顺缘，负是逆缘。如谷种靠水、土、阳光、肥料、人工的培养得以滋长是顺缘；而酷日、暴风、水涝、冰雹等则是逆缘。修行人遇名师善友是顺缘，而邪师邪友的阻扰则是逆缘。
    心心所法、色法、善、恶、染、净等法都互作增上。

    二、十因义
    据《瑜伽师地论》三十八卷解释：
    （一）随说因：谓一切法，以名为先故想，想为先故说，由言说故能显诸法，故名随说因。
    （二）观待因：观待于此，此为因故，于彼彼事，若求若取。如观待手，手为因故，有执持业；观待于足，足为因故，有往来业；观待饥渴故，饥渴为因，于诸饮食，若求若取；观待有漏皆苦故，以有漏皆苦为因，勤修三学求证解脱。观待于此为因，而有彼彼作业，如是等无量道理，名观待因。
    （三）牵引因：一切种子，未成熟位，望后自果。如现世无名爱取种子，可引感后世生老死果，为牵引因。
    （四）摄受因：除种子亲因外，余一切缘，如等无间缘，增上缘，所缘缘等，能资助生果者，名摄受因。
    （五）生起因：种子已成熟位，能现生起近自果故（如内业重由爱水滋润而感报体），名生起因。
    （六）引发因：即初种子所生起果，望后种子所牵引果，如从无名支乃至有支，展转引发后后相续，望于余生生老死等，为引发因。
    （七）定异因：种种异类各别因缘，谓有为法各于自果有能起证差别势力，三界九趣果不同故，名定异因。
    （八）同事因：谓从观待因至定异因，六因为性，同办事业，于得果中，有和合力，即依此为同事因。
    （九）相违因：于生、住、成、得事中能起障碍，如霜雹之望禾稼，烦恼之望涅槃，真见之望生死等，名相违因。
    （十）不相违因：此障碍因，若缺若离，于生、住、成、得事中不相障碍，名不相违因。

    三、五果
    （一）等流果：谓善、恶、无记三性诸法，各别引生自同类法，此同类法望能引因名等流果。等谓等同，流谓流类，等流之果，其性相同，名等流果。
    （二）异熟果：由善业、恶业、不动业、分别感三界善趣、恶趣及色无色界世间禅定果，名异熟果。因是善恶，果是无记，故名异熟。此果自性者，谓即第八识真异熟果，是报主故，执持变现根身器界故。前六识由业所感诸无记法，从异熟起名异熟生，亦此果摄，属于别报，能圆满果体故。
    （三）离系果：离谓远离，是即断灭，系谓系缚，是即烦恼，由烦恼障系缚有情，恒处生死不得解脱，修习圣道，断灭彼故便证涅槃，名离系果。
    （四）士用果：《成唯识论》云：“谓诸作者，假诸作具，所办事业，此果正因，谓诸作者，此果助因，谓即作具，作者作具，是此果因，所办事业，即此果体。”
    从广义讲，凡人的活动所成办的事业，如艺术家之于工艺，农夫之于耕种，商人之于贸易，建筑师之于房屋等，凡用力亲办自果者，名士用果。狭义的说，凡等流、异熟、离系、增上、均可名士用果。
    （五）增上果：《瑜伽师地论》三十八卷云：“若眼识等是眼根增上果，乃至意识等是意根增上果；众生身分不散不坏是命根增上果”。……此就根作增上缘而产生的识与身的增上果。若就广义说，心心所法亦更为增上果。善法的产生，是由亲近善知识经过闻思修的增上果。恶法的产生，是接近邪师邪教熏染而成的增上果。……可知此果俱摄一切。

    四、三种缘起义
    据瑜伽义略解：
    （一）依第八赖耶建立分别自性缘起：由本识含藏种子生起诸法，诸法自性不同依因缘立，其性有善、恶、无记、染、净等差别故。
    （二）依十二有支建立爱非爱缘起，亦名业感缘起，由无明、行等因，引生善恶诸趣爱与非爱果故，即善业感乐果，恶业感苦果。
    （三）依前六识建立分别受用缘起，又依根及境作增上缘，六识得生，识生起已，缘于六尘境界能有受用，领受苦、乐、忧、喜、舍等。
    缘生义是佛法的中心思想，各宗派根据此义各有发挥，如业感缘起、性空缘起、赖耶缘起、法界缘起、六大缘起等，各有理论，不尽叙述。但具体而详细的，莫若瑜伽唯识，必须精进修学，方能升堂入奥。

    2004年9月作于重庆慈云寺


附录：惟贤法师小传

上一页 目录 全书完

附录：惟贤法师小传

    惟贤法师，俗名邱兆红，四川省蓬溪县文井镇新林黑堡堰村（徐家湾）人，生于1920年农历5月21日。两岁时母亲去世，父亲不久又亡，少小失恃，全仗四姐邱兆莲抚养成人。少年惟贤过早地品尝到了人间的苦辛。
    他七岁时开始读私塾，三年便读熟了《四书》、《五经》。十至十二岁在蓬溪县白塔寺出家，拜定光法师为师，深得定光师爱护。出家后仍背着书包念完了小学，写出了《小沙弥的新年》一文载于当时的蓬溪县报上。十三岁至十五岁时，到四川南充集凤王恩洋先生创办的龟山佛学院学习。王恩洋先生在“如何做人，如何完成做人的品格”方面，给了他很大的启发，奠定了他深厚的儒学基础。
    1936年，惟贤法师到重庆缙云山，考入太虚大师创办、法尊法师主持教务的世界佛学苑汉藏教理院，成为汉藏教理院最年轻的一名学生。在汉藏教理院，他由普通班升至专修班，循序渐进地进行了系统的学习，打下了坚实的佛学基础。此时的惟贤，学识精深，才华横溢，诗文并茂，并会藏语、英语，他频频在《海潮音》、《佛化》周刊上发表唯识、因明诸多论文，深得太虚大师、法尊法师的喜爱和器重。尤其是太虚大师对惟贤耳提面命，更是给予了他极大的教益。
    1938年，法尊法师为惟贤授沙弥戒。
    1941年于汉藏教理院毕业，同时依止雪松法师受比丘戒，开始弘法事业，随雪松法师在开县创办了大觉佛学院，先后任教授、教务主任、副院长等职。同时创办并主编《大雄》月刊，著有《心经讲录》、《唯识纲要》、《因明纲要》、《淡泊诗集》、《大觉诗稿》、《中国佛教青年之前途》等著作和刊于全国佛教报刊杂志上的若干佛教学术论文。
    建国初，法师任重庆能仁寺佛化学校教导主任兼重庆市佛教协会筹备工作组秘书长。1954年蒙冤受屈，在铁窗里度过了二十六年零十个月的漫长岁月，法师靠的是患难中的真情和坚定不移的信仰撑过劫难。
    1980年，法师回到重庆慈云寺，领时命、顾大局、理万机，投入到弘法利生的繁忙工作中，先后创办“佛教希望工程”，成立“佛教慈善功德会”，创办“母亲工程”，开办僧伽培训班等。
    近二十多年来，老法师曾先后参访过日本、泰国、新加坡、韩国和美国等国家，多次参加佛教学术、佛教文化方面的交流会议。在传戒、讲经说法等弘法事业方面，除了重庆、四川各地以外，他还多次应邀到深圳、上海等地，先后讲过《般若波罗蜜多心经》、《观世音菩萨普门品》、《楞严经》、《阿弥陀经》、《大般若经》、《法华经》、《十善业道经》、《普贤行愿品》、《华严经》等经典，著作有《惟贤法师诗文集（全三辑）》、《般若与人生》（已出版）、《法华经说什么》（已出版）、《唯识札记》（已出版）等。
    2000年，老法师参访尼泊尔，任中国佛协代表团副团长。
    2002年7月19日（农历六月初十），日理万机的惟老在接电话时，不慎摔断了左腿，左腿股骨骨折了，做手术换了人造骨头，8月20日即能下地行走，9月16日居然还能来京参加中国佛教协会第七次全国代表大会！
    2005年，为了响应“构建一个和谐的社会主义社会”的号召，85岁高龄的惟老，来到北京，走进人民大学、北京大学、北京佛教文化研究所，就“佛教哲学的现实意义、佛法的弘扬与构建和谐社会”发表专题演讲。他谈到“和谐本身就是传统文化——儒家、道家、佛家的重要内容，要实现和谐，就必须要继承和发扬传统文化！”
    老法师精通三藏，深研经论，博学多闻，他亲近一代佛门领袖太虚大师将近十年，除了“立品立德立行”外，还深得太虚大师“八宗平等、人生佛教、菩萨学处”思想心印真传，始终如一的以太虚大师思想为指导，按照太虚大师的志向在努力，践行人间佛教。他极力强调佛法弘扬一定要因时制宜、因地制宜、因机制宜，无论何时何地一定要契机契理，与所处的社会形态、社会环境、社会背景相适应，在“菩提心为因，大悲为根本，方便为究竟”（此三句话出自密宗经典《大日如来灌顶经》）的原则指导下，发扬“莲花精神”，积极参与社会主义社会各项事业建设，为当前社会服务，为现实人生服务，启迪人生智慧，为人们消除烦恼，解除身心病苦。
    他不辞辛劳，为法忘躯，四处应邀传戒、讲学、参访、弘法，足迹遍及祖国的大江南北，为佛教事业的发展呕心沥血，为佛教人才的培养竭尽全力，为佛教慈善工作的开展四处呼吁，为构建和谐社会尽心尽力！其所到之处，作狮子吼，宣妙法音，处处展示着敏捷的才思、严密的逻辑和健康、饱满、与时俱进的精神。其才华横溢不减当年！其广博的悲心可昭日月！
    老法师丰富的学识，广大的慈悲心，超凡的智慧，圆融的佛学思想，被佛教学术界尊称为“当今唯识学泰斗”，当代佛门高僧。现担任中国佛教协会咨议委员会副主席、重庆市政协委员、重庆市佛教协会会长、重庆市佛学院院长、重庆市反邪教协会副会长、重庆慈云寺方丈等职务。

     惟贤法师著作编辑室
     联系人：正根居士
     电话：010-89812999 13910754666
     网站：http://www.fojiao.org
          http://www.cqcs.org
     邮箱：tengyu333@vip.sina.com
     Q Q： 99811713

上一页 目录 全书完