封面

 《般若波罗蜜多心经诠注》
周止庵 著
 中华佛典宝库录入 2006年1月28日


目 录

緣起、凡例、注解要目
略疏原序、科文、異譯名稱
卷一·經文
卷二·求加被偈
  第一篇 總釋名題
    第一章 經題
      第一節 釋名
      第二節 辨體
      第三節 明宗
      第四節 論用
      第五節 判教
    第二章 人題
卷三·上
  第二篇 正釋經文
    第一章 顯說般若
      第一節 因人顯法
        第一項 能修之人
        第二項 所修之法
        第三項 觀行境界
        第四項 修證功能
卷三·下
      第二節 正示法空
        第一項 明蘊空
        第二項 顯空德
          第一款 總標
          第二款 別釋
            第一目 三科
              第一 五蘊
              第二 十二處
              第三 十八界
            第二目 十二因緣
            第三目 四諦
            第四目 智得
      第三節　顯彰妙果
        第一項 明菩薩得涅槃
        第二項 明諸佛得菩提
      第四節 結讃功能
    第二章 密說般若


《般若波羅蜜多心經詮注》

緣起、凡例、注解要目

  《般若波羅蜜多心經詮注》
            周止菴居士著述

    緣起

    世間一切宗教，以佛教為最奧衍廣博。止菴具縛凡夫，生際末劫，終日衣食於奔走，絕少與大德長老參究機會，何敢以一知半解，妄談注經。貽佛頭著糞之誚。所以有此一著者，因緣所繫，可得而言。余家居古越。高曾以來。代崇佛教，先王母倪太夫人長年茹素，持名甚虔。余幼時習聞，欲究其義苦無師承。光緒丁酉，丁本先生妣徐太夫人之憂，營建水陸道場於大善寺。住持以《楞嚴經》一帙，贈先嗣父味仁公。侍讀及之，喜其文義，是為余知讀大乘經典之始。民國三年，于役蘇州，友人王君復以《楞嚴經》見惠，夙習所熏，歡喜讚歎。嗣後涉歷所至，行筴中不離梵典。在天津時，與上方山兜率寺沙門清池上人遊，研討更切。以《般若波羅蜜多心經》辭約義豐，擷《大般若經》六百卷之菁華，觀世音菩薩悲願所感，斯土流傳，歷久彌廣。而白衣誦持，大多莫詳其義，甚至於經中照見五蘊皆空句，連上文時字併讀，句逗未明，遑論義解，竊嘗心焉病之。歷覽古德著述，陳義高者如窺基法師之《心經幽贊》多陳法相，非初機學者所能領悟。略者如朱石君居士之《心經注解》，寥寥數章，稍讀內典者，又不足以饜其求知之欲。倭難既起，避兵滬瀆。次兒永洪，以軍訓內傷肺部，於民國二十七年十二月十七日酉刻咯血死。屬纊時神志清明，強起與其母訣。余示以出世之恉，點頭領會。余亦了悟世緣如幻。眾生沈迷生死之苦。遂發願詮注心經。參考窺基法師之《心經幽贊》，靖邁法師之《心經疏》，賢首法師之《心經略疏》，智圓法師之《心經疏》，宏贊法師之《心經添足》，宗泐法師、如屺法師之《心經注解》，德清法師之《心經直說》，智旭法師之《心經釋要》，紫柏老人之《心經說》，續法法師之《心經解》。並世大德，如太虛法師之《心經淺說》，圓瑛法師之《心經講義》，應慈法師之《心經淺說》，韓德清居士之《心經略讃》，季聖一居士之《心經隨聞記》，丁福保居士之《心經詳注》，李翊灼居士之《心經密義述》，溫光熹居士之《心經演蘊》。亦復多所取資。融貫百家，惟求其是。宗派門戶之見不敢存，片詞隻義，凡可以闡明經恉者不敢略。譬如得食，不欲以甘者自私，將以導引初機同登覺路。凡數經修改，歷時十有四載，詮注合計，都十九萬餘言。居士林康甫世講讀之，以為可備初學參稽之需，慫慂付梓。因敍其緣起如此。

    周止菴

    再版凡例

    一、詮注以詮為主。首列經文，以宗經也。次列詮文，以釋經也。名相法數，非詮所能盡者，以注明之。注有未盡者，以復注詳之。注與復注，有時失之繁複，則以意在引導初機，故於介紹佛學常識，不厭求詳。
    二、注引經論，隨時注明出處，用備讀者繙閱原文，更求深造。
    三、諸經論外，多節取法雲法師之《繙譯名義集》，玄應法師、慧琳法師之《一切經音義》，希麟法師之《續一切經音義》，一如法師等之《三藏法數》，丁福保居士之《佛學大辭典》。讀者欲詳始末，可檢本書。
    四、注引經論，惟取簡稱。如《大般若波羅蜜多經》簡稱為《大般若經》，《大智度論》簡稱為《智度論》，《瑜伽師地論》簡稱為《瑜伽論》，《顯揚聖教論》簡稱為《顯揚論》。餘可類推。
    五、各經譯名，新舊不同。如《華嚴經》之道種智、一切種智，《大般若經》作道相智、一切相智。本書行文，概依《大般若經》，其引用經論及古德疏解者，則各仍原文。
    六、學佛之道，首在遣執。世尊說法四十九年，更無一字可得。達摩西來，不立文字，直指人心，見性成佛。故諸法實相，言忘慮絕，當無得無證之時。言語道斷，心行處滅。一涉思惟，即落知見。知見愈精，去道愈遠。《楞嚴經》曰，知見立知，即無明本。《金剛經》曰，知我說法如筏喻者，法尚應捨，何況非法。讀者當知佛說十二部經，亦不過為渡津舟筏。何況末學詮注，如蠡測海。宋永明延壽禪師云，切不可迷性徇修，執權害實，棄本逐末，認妄遣真，據世諦之名言，執無始之熏習，將言定旨，立解明宗，一向合塵，背於本覺。吾深望讀此經者，以詮注為筌蹄。不可執著文字，自墮理障。過江須用筏，到岸不需船，行者勉之。
    七、不慧志在潛修，夙以名聞為懼。初版行世後，承各方大德題贊之詞，愧不敢當，故未刊載。惟為啟示讀者修學方便，於卷首補錄賢首法師略疏自序一通，略加注釋。古德所詔示者，即末學所師承，冠之簡端，用示私淑。
    八、楊仁山先生云，《心經》以二百六十餘言，攝盡六百卷般若妙義。果能自淺而深，澈見真空實相。則一大藏教，無不從此流出。所謂般若為諸佛母也。讀者受持此經，當作難遭難遇之想。止菴末學鈍根，此次再版，參附臆見頗多，深恐所詮有誤，尚祈大德長老賜以教正。

    古今注解要目

唐代
    心經幽贊 釋窺基
    心經疏 釋靖邁
    心經略疏 釋法藏
    心經疏 釋慧淨
    心經贊 釋圓测
    心經略疏 釋明曠

宋代
    心經註 釋提婆
    心經疏 釋智圓
    心經疏詒謀鈔 釋智圓
    心經幽贊添改科 釋守千
    心經幽贊崆峒記 釋守千
    心經略疏顯正記 釋仲希
    心經略疏連珠記 釋師會
    心經註 釋道隆

明代
    心經指掌 釋元賢
    心經際決 釋大慧
    心經論 釋大慧
    心經一貫疏 釋益證
    心經注解 釋宗泐 如玘
    心經小談 釋貫衡
    心經正眼 釋大文
    心經發隱 釋正相
    心經開度 釋弘麗
    心經注解 釋真可
    心經直談 釋真可
    心經要論 釋真可
    心經說 釋真可
    心經說 釋洪恩
    心經直說 釋德清
    心經釋要 釋智旭
    心經添足 釋弘贊
    心經貫義 釋弘贊
    心經斲輪解 釋費隱通容
    心經文句 宋濂
    心經釋義 謝觀光
    心經釋疑 謝觀光
    心經提綱 李贄
    心經釋略 林兆恩
    心經概論 林兆恩
    心經註解 諸萬里
    心經註解 何道全

清代
    心經事觀解 釋續法
    心經理性解 釋續法
    心經句解 釋淨挺
    心經論 釋函是
    心經請益說 釋道需
    心經注釋 釋大顛
    心經略疏小鈔 錢謙益
    心經說 朱珪
    心經注疏 仲之屏
    心經彙纂 孫念劬
    心經解 徐昌治
    心經大意 王起隆

近代
    心經淺注 釋太虛
    心經義疏 釋倓虛
    心經講義 釋倓虛
    心經要解 釋顯慈
    心經講解 釋興慈
    心經淺說 釋應慈
    心經直指 釋傅晟
    心經筆記 釋月溪
    心經講義 釋圓瑛
    心經講義 釋慧三
    心經講義 釋南亭
    心經講錄 釋守培
    心經精義 濟陽破衲
    心經顯詮 陳子彞
    心經通俗解 證平
    心經釋義 駱岫青
    心經淺說 許止淨
    心經口義記 王弘願講 杜騰英記
    心經新疏 季聖一
    心經隨聞記 季聖一講周德彌季勝靈記
    心經分段貫攝 王驤陸
    心經略贊 韓德清
    心經密義述 李翊灼
    心經箋註 丁福保
    心經詳注 丁福保
    心經讀 歐陽漸
    心經演蘊 溫光熹
    心經淺說 張炳楨
    心經集解 胡連玉
    心經簡注 馬圻源
    心經詮注　 周止菴

日僧注解
    心經秘鍵 釋空海
    心經述義 釋智光
    心經釋 釋最澄
    講演心經義 釋源信
    心經解 釋宗純
    心經註解 釋圓耳
    心經口談 釋性潛
    心經止啼鈔 釋傳尊
    心經毒語注 釋圓慈
    心經秘鍵略注 釋覺鍐
    心經秘鍵開寶鈔 釋道範
    心經秘鍵聞書 釋杲寶
    心經秘鍵開藏鈔 釋賴瑜
    心經講義 吉祥真雄

各家總注
    《心經三注》 唐釋慧忠。宋釋道楷。懷深。
    《心經解義節要》 唐釋法藏。宋釋智圓。元釋元粹。性澄。明釋宗泐。居士宋濂。六家注節要。
    《心經略釋》 日僧真興集提婆。窺基。圓測。靖邁。啟。法藏。智開。武敏。空海。智光。十家注。

    以上古今注解。就著者所見。都一百種。僅知其目而未經讀過者不錄。雖曾讀過而出於乩筆者亦不錄。


略疏原序、科文、異譯名稱

    略疏原序
    唐賢首法師法藏撰

    夫以真源素範。沖漠隔於筌罤。妙覺玄猷。奧賾超於言象。
    【注】《顯正記》云。真源二字。即正指實相般若。為所觀理體也。真即真實。源即是喻。由此實相。本非偽妄故。素範者。謂此理體。惑不能染。故曰素。素。潔也。軌生物解。任持自性。故曰範。範。法也。法以軌持為義故。此嘆理體之德也。沖漠者。沖。深也。漠謂沙漠。謂此理體豎窮三世。故曰沖。《圓覺疏》云。過去無始。未來無終。橫徧十方。喻之沙漠。無有涯畔。此顯理體之量也。下示理體離過。故曰隔於筌罤。隔。猶絕也。筌能捕魚。罤能網兔。故《周易》云。得兔忘罤。得魚忘筌。今借筌罤喻言教。魚兔喻理境。見真理者須忘言教。猶得魚兔者須忘筌罤也。夫真理雖假文字詮顯。而真理之體本非文字。《佛頂經》云。妙性圓明。離諸名相。《般若經》云。總持非文字。文字顯總持。既體絕文字。故云隔於筌罤。妙覺二字。正指觀照般若。為能觀智體也。以此智體。言思罔及。故曰妙。靈明鑒照。故曰覺。玄猷者。玄即幽玄。猷。道也。即總指此智之體是幽玄至極之道也。然道有二義。一，因義。無量果德。非智不證故。二，能通義。始自凡夫。皆由此智到極果故。即總名猷。此歎智體之德也。奧賾者。即豎深之義。顯非權小之淺智。故云奧賾。以豎該橫。但標奧賾。此顯智體之量也。言。謂語言。象。似也。當其義也。夫語言義相。皆由分別。今此觀智。體非分別。故超言象也。《周易》云。得象忘言。得意忘象。《連珠記》云。真源者。即實相般若。無相真如也。清涼釋《剎那際三昧》云。即窮法真源。謂窮彼剎那。時相都寂。則剎那無際。由達清淨真如。本無相故。素範者。素表無瑕。範持自性。謂體若冰霜。性猶珠玉。在煩惱泥不改貞白。論云。如如體中。過恒沙染法。皆悉空空無所有故。沖曰深玄。漠言廣遠。妙覺。即觀照般若。清涼云。離覺所覺。而盡覺故。奧賾者。謂般若淵海。深而不可極也。大論云。智慧大海。惟佛窮底。

    雖真俗雙泯。二諦恒存。空有兩亡。一味常顯。
    【注】《顯正記》云。言真俗雙泯者。泯。亡也。真即真諦。一體無殊。俗即俗諦。萬境有異。今明真即俗。故真亡。俗即真。故俗亡。互奪兩亡。名為雙泯。二諦恒存者。存。在也。俗即真。故真在。真即俗。故俗在。相亡互在。故曰恒存。恒。常也。即顯而隱故雙泯。即隱而顯故恒存。隱顯同時。唯一實相。般若為所觀境。所觀之境既存亡不二。能觀之智亦隱顯同時。言空有者。空即照真。是如理智。有即照俗。是如量智。真境無相。智照名空。俗境萬差。智觀稱有。今以空即有。故空泯。有即空。故有泯。故曰兩亡。亡。泯也。一味者。總結存亡。不二唯一。觀照般若。為能觀之智。體非生滅。故曰常顯。《連珠記》云。以空假皆中。色空無寄。方為此經所宗第一義諦之真空故。《會要》云。以色即是空之空為真諦。以空即是色之色為俗諦。言雙泯者。色即空。故色泯。空即色。故空亡。言存者。謂即空之色。色雖泯而其相宛然。以相常存而即泯。故泯而恒存也。即色之空。空雖泯而其性不失。以性恒存而即泯。故泯而常在也。又色即空而空存。亦空即色而色存。以相即同時。故存泯齊立。空有等者。真諦故空。真空也。俗諦故有。假有也。亦由相即故雙亡也。空非異有之空。有非異空之有。色空不異。水乳無分。故曰一味。《法界觀》云。菩薩見空莫非見色。見色莫非見空。以二諦互融。故事理無閡。體即第一義真故。疏云。令悟二諦中道故。記云。此二不二。存泯同時。無性故緣生。空亡也。緣生故無性。有亡也。空有俱亡。為一味法。肇公曰。此直辨真諦以明非有。俗諦以辨非無。豈以諦二而二於物哉。玄鏡云。約融二諦義。初，會色歸空。明俗即是真。二，明空即色。顯真即是俗。三，色空無閡。明二諦雙現。四，泯絕無寄。明二諦俱泯。然色是有中之別稱。通是空有二門耳。

    良以真空未嘗不有。即有以辨於空。幻有未始不空。即空以明於有。
    【注】《顯正記》云。意謂前說真俗不二者。實由真諦之空。常自隨緣成俗諦有。未曾間斷。故云未嘗不有。既全空成有。反知有即真空。所以前說即俗是真。故云即有以辨於空也。俗諦之有。從緣無性。即真諦空。未曾有實。故云未始不空。既全有是空。反知空即幻有。所以前說即真是俗。故云即空以明於有。《連珠記》云。前科二諦圓融。空有一味者。以幻有真空無二為中道故。清涼云。由無性故空。是空義。緣生故空。是空之所以（所以即是因緣。由從緣生。所以無性。故緣生無性。是空之所以）。既是從緣生無性故空。故曰真空。而又不待壞彼差別法體。然後方空。是故真空未嘗不有。又即此有法緣生無性。便名真空。故云即有以辨於空。言幻有者。緣生故有是有義。無性故有是有之所以（特由無定性故。方始從緣而成幻有。故無性是有之所以）。既是從緣無性之有。則此有常無自性。故幻有未始不空。又即此無性舉體從緣而成於有。故云即空以明於有。

    有空有。故不有。空有空。故不空。
    【注】《顯正記》云。有空等者。上俗諦之幻有。是即空之有。體不異空。故云不有。此結上即俗之真也。空有等者。上真諦之真空。是即有之空。體不異有。故云不空。此結上即真之俗也。所觀既然。能觀亦爾。《連珠記》云。有空下。即於幻有真空之上。各顯一中道義也。初言有者。指幻法自體。即幻有上非不有義也。次言空有者。謂此幻法從緣無性。即空之有。是空家之有。故言空有。故不有者。以其舉體全空無所有故。即幻有上非有義也。非有非不有無二。是幻有義。《大品》云。諸法無所有。如是有。故非有非不有。名為幻有。次云空者。指真空上非不空義也。言有空者。謂此真空是緣生無性之空。即有之空。是有家之空。故云有空。故不空者。不待滅緣生方為空。故全有之空是不空。指真空上非空義也。非空非不空無二。是真空義。經云。空不空不可得。名為真空。《中論》云。無性法亦無。一切法空故。《小鈔引清涼疏》云。幻有即是不有有。真空即是不空空。不空空故。名不真空。不有有故。名非實有。非空非有。是中道義。

    不空之空。空而非斷。不有之有。有而不常。
    【注】《顯正記》云。言不空等者。顯上真空是即有之空。空若離有。即是斷空。今既不爾故云不斷。不有等者。顯上幻有是即空之有。有若異空。即成常有。今既不爾。故云不常。《連珠記》云。言不空等者。即無性故空。緣生故空。為真空也。清涼云。顯正也。空而非斷者。非無見斷見之空。清涼云。揀非也。斷見之無。是定性之無。定無則著斷。今緣生故空。非是定無。無性故空。亦非定無。定無者。一向無物。如龜毛兔角。今但從緣無性。故非定無。是故空而非斷也。不有之有者。即無性故有。緣生故有。此二種有。並非常見之有。常見之有。是定性有。今從緣無性之有。非定性有。顯是幻有。顯正也。既非定性之有。故曰有而不常。揀非也。則是真空妙有。離斷常之中道也。清涼云。緣生無性故空。則非無見斷見之空。為真空也。無性緣生故有。則非常見有見之有。是幻有也。肇公云。性常自空。故謂之性空。法性如是。故曰實相。言不有不無者。非有有見常見之有。邪見斷見之無耳。玄談云。雖空不斷。雖有不常。此即中論及智論文。且約空為真諦。有為俗諦者。空是即有之空。故雖空不斷。斯則即俗之真也。不同始教。如龜毛兔角。方說名空。雖有不常者。有是即空之有。故此有非常。斯則即真之俗也。若有定是有。便墮常見。故《中論》云。定有則著常。定無則著斷。是故有智者。不應著有無。非斷非常。即是中道。影公《中論·序》云。然統其要歸。則會通二諦。以真諦故無有。俗諦故無無。真故無有。則雖無而有。俗故無無。則雖有而無。雖有而無。則不累於有。雖無而有。則不滯於無。不滯於無。則斷見絕息。不存於有。則常見冰銷。

    四執既亡。百非斯遣。般若玄旨。斯之謂歟。
   【注】《顯正記》云。四執者。空有斷常。但計一種。故名四執。又一異有無。各有四句。隨計其一。亦名四執。言百非者。起信於一異有無等四句明之。謂一。非一。亦一亦非一。非一非非一。為一四句。異等例此。共成十六。又過，現，未來，各有十六。成四十八。又已起，未起，各四十八。并根本四。都成百非也。今疏意但不生分別。寂爾亡懷。情執自除。過非斯泯。故云四執既亡。百非斯遣。般若二字。正指此經。亦旁該廣部。玄妙旨趣。理極於此。故云斯之謂歟。斯者。此也。歟者。語辭也。《連珠記》云。四執亦云四謗。定有者。增益謗。定無者。損減謗。亦有亦無。相違謗。非有非無。戲論謗。執四句故皆成謗。般若離四句。不可以有無取。故四執既亡。即成四德。《小鈔引圭山》云。會色歸空。無增益謗。明空即色。無損減謗。色空無礙。無雙非戲論謗。泯絕無寄。無雙亦相違謗。四謗既無。百非斯絕。已當八部般若無相大乘之極致也。清涼云。今顯初門具德四句。一，真如是有。二，真性是空。三，真如亦有亦空。四，真性非有非空。一重四句中。更有四重四門。然執著成見取。成四謗。若能不住。無分別智徧入四句。則遠離四謗。不滯空有。何行不成。即有之空。方為具德之空。即空之有。方為具德之有。又隨一句必具餘三。若隨闕者則非具德。又云。為法之相。不出有無。設非有非無。若有此者。亦不出有。若無此句。亦不出無。但遣有無。萬法斯寂。《起信鈔》云。一異有無等各一四句。共成十六。又過，現，未來，各有十六。成四十八。又已起，未起，各四十八。共成九十六。并根本之四。都成百非。若以論下文真如自性。非有相。非無相。非有有相。非無無相。非有無俱相。例非一相非異等十句。此十句一一能生十使煩惱。亦成百非。記云。百非斯遣者。論曰。百非非非。千是非是。非百非。背千是。非非中中。皆背天天。演水之談。足斷而止。審慮之量。手亡而住。可謂般若二諦中道之大宗也。《釋摩訶衍論》云。百非非。非非百。非非非。中中。謂以非非非去其非。故無非也。《會要》云。此之空有。與肇論有無不同。彼論有無。隨世計說。相因而生。故論云。若以有為有。則以無為無。《密嚴經》云。要待於有法。而起於無見。如見牛有角。計兔無角等。二諦收之。但俗諦耳。《仁王經》曰。若取著一二。若有若無。即世俗諦。是也。此云即有之真空。即空之幻有。與彼徧計所執有無之理。居然異也。

    若歷事備陳。則言過二十萬頌。若撮其樞要。則理盡一十四行。
    【注】《顯正記》云。若歷下敍能詮。上敍所詮。既當實相觀照二種般若。今敍能詮。即是文字般若也。般若廣部六百卷。總開八部。謂大品小品等。其中所說始自色心。終乎種智。八十餘科。今顯其廣。故云二十萬頌。撮。取也。樞即門臼。喻其要也。以一總多曰要。理即義理。古來經文。皆以十七字為一行。故今經但有一十四行也。《連珠記》云。若歷等者。謂歷色心等事。備陳正理。則有八部二十萬頌。樞謂門樞。爾雅云。制扇以柎。門傍曰樞。以況八部所詮頓實之旨。斯經盡之。故曰。撮其樞要。理盡一十四行。《會要》云。二十萬頌。屬六百卷大部。西域法以頌定數三十二字為一頌。一頌為一數。故大部該二十萬頌。

    是知銓真之教。乍廣略而隨緣。超言之宗。性圓通而俱現。
    【注】《顯正記》云。教銓真理。故曰銓真之教。所敍或廣或略者。由機有利鈍。利者聞略說則悟。鈍者聞廣說方解。緣謂機緣。所銓之理。是一經之主。故名為宗。離言說相。故曰超言。能銓之教。雖有廣略。所銓之理。則無增減。本自圓融。平等顯現。故云性圓通等。《小鈔》云。廣略隨緣者。《依起信》云。或有眾生。以自力廣聞而取解。亦以自力少聞而多解。又或因廣論而得解。復以少文攝多義能取解故。《會要》云。宗謂宗旨。此所銓之性宗，在廣部銓量非增。在略部銓量非減。一皆圓滿融通也。

    般若心經者。實謂曜分衢之高炬。濟苦海之迅航。拯物導迷。莫斯為最。
    【注】《顯正記》云。實謂者。指定之辭。曜。照也。衢謂衢路。昏衢喻二障。即生死因。苦海即生死果。三界有情。常居苦趣。飄沈生死。不證菩提者。靡不由此。二障者。一，名煩惱障。體即根隨。二，名所知障。體即無明。《金剛疏》云。煩惱障障心。心不解脫。所知障障慧。慧不解脫。既是有情生死根本。又能障翳無生理智。其猶昏暗衢路。履即顛墜。故以為喻。高炬即火炬。喻般若也。謂若能依此經發深妙慧。了心本寂。見法元空。然後悲智兼修。自他俱運。泯取捨。亡順違。則二障潛祛。三空可契。猶火炬高照。昏衢頓明。迅航亦喻般若。苦即分段，變易，二種生死。由上二障之所感。故二死苦相。無有邊際。喻之苦海。然三界無定。靡不皆苦。眾生妄計為樂。以智觀之。有何可樂。故我大聖由悲願力。特演斯典。濟救有情。使登般若之智航。度竛竮之苦海。物謂物機。迷為迷惑。顯此經決能引導迷者。拯接物機。離二障昏暗之衢。踐智慧坦明之道。則涅槃高岸。尚可即登。生死微波。何疑不度。《連珠記》云。昏衢苦海。以喻有情奔馳生死。無智慧明。五苦八苦。不得邊底也。高炬迅航。以況斯經。三無相慧。拯接物機。導引迷徒。群修多羅。莫比斯最。《會要》云。昏衢高炬者。如《仁王經》以般若喻於摩尼大寶。體具眾德。乃至云。若於暗夜。置高床上。光照天地。明如日出。苦海迅航者。則般若獨能為舟也。若以六度共為舟。則施為船底。戒為船幫。忍如板。進如櫂。定如墜石。慧如艄人也。

    然則般若以神鑒為體。波羅蜜多以到彼岸為功。心顯要妙所歸。經乃貫穿言教。從法就喻。詮旨為目。故言般若波羅蜜多心經。
    【注】《顯正記》云。般若此云智慧。神名不測。鑒謂鑒照。體即性也。此智雖不可測。而性常鑒照。故云以神鑒為體也。波羅蜜多者。顯此智有離此到彼之功心顯等者。以人心藏。是一身所歸。要勁微妙之處。喻此略本。是彼廣部之要也。經乃等者。法喻並彰也。以經能持義喻線能貫華。顯不散失故。此經則是能持義理之言教。故曰經乃貫穿等。法即所喻。謂般若等。心是能喻。銓謂能銓。即經之一字。旨謂所銓旨趣。即上法喻等。是乃法喻能所合為此經題目。故總結云從法就喻等。《會要》云。依起信中。本覺。般若體也。此體靈明。本自神解。故云謂心體離念。離念相者。等虛空界。無所不徧。又云有大智慧光明義等。若始覺。般若用也。《無知論》曰。般若可虛而照。真諦可亡而知。萬動可即而靜。聖應可無而為。皆神妙也。今通銓二種。則實相屬本。觀照屬始也。《連珠記》云。肇公曰。然則智有窮幽之鑒。而無知焉。神有應會之用。而無慮焉。神無慮。故能獨王於世表。智無知。故能玄炤於事外。經云。般若無知。無所不知。則觀照實相也。功者。用也。謂漉人天龍。渡生死海。置涅槃岸。乃斯妙慧之功用也。前已廣敍所銓之經。此特顯能銓文字般若。略能攝廣是六百卷中之要妙。言是般若部中之心。如人心藏。是一身之要也。般若。法也。心乃喻焉。心經為銓。般若為旨。結為題目矣。

    科文

    本經異譯名稱

    摩訶般若波羅蜜咒經 吳支謙譯
    摩訶般若波羅蜜大明咒經 姚秦鳩摩羅什譯
    般若波羅蜜多心經 　唐玄奘譯
    般若波羅蜜多那經 　唐菩提流志譯
    般若波羅蜜多心經 　唐義淨譯
    摩訶般若隨心經 　　唐實叉難陀譯
    般若波羅蜜多心經 　 唐不空譯
    普徧智藏般若波羅蜜多心經 唐法月初譯重譯
    般若波羅蜜多心經 　唐般若共利言等譯
    般若波羅蜜多心經 　唐智慧輪譯
    般若波羅蜜多心經 　唐法成譯
    般若波羅蜜多心經 　宋契丹慈賢譯
    佛說聖佛母般若波羅蜜多心經 宋施護譯
    聖母智慧到彼岸經 　元達里麻剌怛那譯


卷一·經文

  《般若波羅蜜多心經詮注·卷一》
    震旦白衣周止菴學

    經 文

    將欲宣說此經。自應先列經文。以申皈敬。此經具稱。當云般若波羅蜜多心經。世間流布。簡稱心經。其有連上文多字並讀。稱多心經者。誤也。
    心經由梵譯漢。凡十四本。吳支謙。唐菩提流志。實叉難陀。大廣智不空。宋契丹慈賢。元達里麻剌怛那。六種譯本。已久佚。今所存者八譯。此八譯中唐義淨三藏所譯者。除咒後有誦此經破十惡五逆。九十五種邪道。若欲供養十方諸佛。報十方諸佛恩。當誦觀世音般若。百徧千徧。無間晝夜。常誦此經。無願不果。五十一字外。與玄奘三藏所譯相同。故世所流傳。僅稱七譯。
    此外大藏中尚有同名為心經者。一，為陀羅尼集經三。唐阿地瞿多譯之《般若波羅蜜多大心經》。係佛與梵天說般若波羅蜜多功德。二，為宋施護所譯之《帝釋般若波羅蜜多心經》。佛為帝釋說般若波羅蜜多甚深之義。均與本經不同。不可以譯名相同。而謂為同本也。
    【注】宣說者。宣明經恉。演說教法之義。《華嚴經·五》曰。以佛力故能宣說。
    古來誤稱多心經者，約有二義。一，以心字屬上文。為般若波羅蜜多心之簡稱。如唐·新羅·崔致遠《法藏和尚傳》，多心雖小不輕，疏出塵中經義。注曰《般若波羅蜜多心經》，多心屬上。心是般若之心。略云多心。此特簡稱費解。意尚不謬。二，因什師舊譯。依巴利語無尾音。作波羅蜜。新譯作波羅蜜多。後人逐以多字為別有含義，有作禪定之定字解者。則大誤矣。經文言波羅蜜多者，凡五處作定字解，即不可通。
    吳月支優婆塞支謙譯《摩訶般若波羅蜜咒經》。天竺三藏菩提流志譯《般若波羅蜜多那經》。于闐三藏實叉難陀譯《摩訶般若隨心經》。均見《開元釋教錄·十四》。有譯無本錄。唐天竺三藏大廣智不空譯《梵本般若波羅蜜多心經》。宋三藏慈賢譯《梵本般若波羅蜜多心經》。亦見《祥符錄》及《至元法寶勘同總錄》。元釋達里麻剌怛那譯《聖母智慧到彼岸經》。大明重刊《三藏聖教目錄》未著錄。今均佚。
    十惡。又名十不善。一，殺生。二，不與取。三，邪婬。四，虛誑語。五，離間語。六，麤惡語。七，雜穢語。八，貪欲。九，瞋恚。十，邪見。此十者並乖理而起。故名惡。《大乘義章·十二》云。順理名善。違理名惡。故又名十不善。為苦報之業因。故又名十惡業。十不善業。
    五逆。又名五無間業。《華嚴·孔目章·三》云。五逆。謂害父。害母。害阿羅漢。破僧。出佛身血。初二，背恩養。次三，壞福田。故名為逆。此通於三乘之五逆也。
    九十五種邪道。即外道也。於佛教外立道。在真理外之邪法也。《資持記·上》曰。言外道者。不受佛化。別行邪法。又曰僧祇總數。九十六種出家人。佛道為一。邪道九十五。《南本涅槃經·十》曰。世尊常說。一切外學九十五種。皆趣惡道。聲聞弟子。皆向正路。按《西域外道九十五種清涼華嚴疏》。束為十一。一，數論師。名劫比羅。此云黃髮。立二十五諦。即冥諦也。二，衛世師。新云吠世史迦薩多羅。此云勝論。即米齊外道也。三，塗灰外道。計自在天為萬物之因。四，圍陀論師。計那羅延天能生萬物。五，安荼論師。計本際生世間。最初由安荼出生梵天。化生萬物。六，時散外道。計一切物皆從時生。故時為萬物因。七，方論師。計方生人。人生天地。滅後還入於方。故方是萬物因。八，路迦耶論師。計色心等法皆極微所作。此云順世外道。九，口力論師。以虛空為萬物因。十，宿作論師。以眾生苦樂。皆隨宿世本業。故宿作為一切因。十一，無因論師。謂一切萬物。無因無緣。自然生滅。
    供養者。供奉財法。資養三寶也。一，財供養。以香華燈明飲食衣物等為供養也。二，法供養。如說修行。利益眾生也。見《普賢行願品》。十方諸佛者，東、西、南、北、東南、西南、東北、西北、上、下。過去、現在、未來，三世諸佛也。
    七譯詳略不同。今所詮釋。依唐玄奘法師譯本。但為闡明經恉。別譯亦不可不參稽互證。謹於詮釋本經之先。依時代先後。錄各種譯本經文如次。其義淨三藏譯本。準日本大藏經梵漢般若異本集記載。與奘師所譯相同。故略之。

    《摩訶般若波羅蜜大明咒經》（龍藏翔字函又據日本大藏本續藏本校正）
    姚秦天竺三藏鳩摩羅什譯
    觀世音菩薩。行深般若波羅蜜時。照見五陰空。度一切苦厄。舍利弗。色空故，無惱壞相。受空故，無受相。想空故，無知相。行空故，無作相。識空故，無覺相。何以故。舍利弗。非色異空。非空異色。色即是空。空即是色。受想行識。亦復如是。舍利弗。是諸法空相。不生、不滅、不垢、不淨、不增、不減。是空法非過去。非未來。非現在。是故空中無色。無受想行識。無眼耳鼻舌身意。無色聲香味觸法。無眼界。乃至無意識界。無無明。亦無無明盡。乃至無老死。亦無老死盡。無苦集滅道。無智。亦無得。以無所得故。菩薩依般若波羅蜜故。心無罣礙。無罣礙故。無有恐怖。遠離一切顛倒夢想苦惱。究竟涅槃。三世諸佛。依般若波羅蜜故。得阿耨多羅三藐三菩提。故知般若波羅蜜。是大明咒。是無上明咒。是無等等明咒。能除一切苦。真實不虛。故說般若波羅蜜咒。即說咒曰。揭帝揭帝。波羅揭帝。波羅僧揭帝。菩提僧莎呵。

    《般若波羅蜜多心經》（龍藏翔字函）
    唐三藏法師玄奘譯
    觀自在菩薩。行深般若波羅蜜多時。照見五蘊皆空。度一切苦厄。舍利子。色不異空。空不異色。色即是空。空即是色。受想行識。亦復如是。舍利子。是諸法空相。不生、不滅、不垢、不淨、不增、不減。是故空中無色。無受想行識。無眼耳鼻舌身意。無色聲香味觸法。無眼界。乃至無意識界。無無明。亦無無明盡。乃至無老死。亦無老死盡。無苦集滅道。無智。亦無得。以無所得故。菩提薩埵。依般若波羅蜜多故。心無罣礙。無罣礙故。無有恐怖。遠離顛倒夢想。究竟涅槃。三世諸佛。依般若波羅蜜多故。得阿耨多羅三藐三菩提。故知般若波羅蜜多。是大神咒。是大明咒。是無上咒。是無等等咒。能除一切苦。真實不虛。故說般若波羅蜜多咒。即說咒曰。揭諦揭諦。波羅揭諦。波羅僧揭諦。菩提薩婆訶。

    《普徧智藏般若波羅蜜多心經》（麗藏磻字函又據日本大藏本續藏本校正）
    唐摩竭提國三藏沙門法月重譯
    如是我聞。一時佛在王舍大城靈鷲山中。與大比丘眾滿百千人。菩薩摩訶薩七萬七千人俱。其名曰觀自在菩薩。文殊師利菩薩。彌勒菩薩等。以為上首。皆得三昧總持。住不思議解脫。爾時觀自在菩薩摩訶薩。在彼敷座。於其眾中。即從座起。詣世尊所。面向合掌。曲躬恭敬。瞻仰尊顏。而白佛言。世尊。我欲於此會中。說諸菩薩普徧智藏般若波羅蜜多心。唯願世尊。聽我所說。為諸菩薩宣秘法要。爾時世尊以妙梵音。告觀自在菩薩摩訶薩言。善哉善哉。具大悲者。聽汝所說。與諸眾生作大光明。於是觀自在菩薩摩訶薩蒙佛聽許。佛所護念。入於慧光三昧正受。入此定已。以三昧力行深般若波羅蜜多時。照見五蘊自性皆空。彼了知五蘊自性皆空。從彼三昧安詳而起。即告慧命舍利弗言。善男子。菩薩有般若波羅蜜多心。名普徧智藏。汝今諦聽。善思念之。吾當為汝分別解說。作是語已。慧命舍利弗白觀自在菩薩言。唯大淨者願為說之。今正是時。於斯告舍利弗。諸菩薩摩訶薩。應如是學。色性是空。空性是色。色不異空。空不異色。色即是空。空即是色。受想行識。亦復如是。識性是空。空性是識。識不異空。空不異識。識即是空。空即是識。舍利子。是諸法空相。不生。不滅。不垢。不淨。不增。不減。是故空中無色。無受想行識。無眼耳鼻舌身意。無色聲香味觸法。無眼界。乃至無意識界。無無明。亦無無明盡。乃至無老死。亦無老死盡。無苦集滅道。無智。亦無得。以無所得故。菩提薩埵。依般若波羅蜜多故。心無罣礙。無罣礙故。無有恐怖。遠離顛倒夢想。究竟涅槃。三世諸佛。依般若波羅蜜多故。得阿耨多羅三藐三菩提。故知般若波羅蜜多。是大神咒。是大明咒。是無上咒。是無等等咒。能除一切苦。真實不虛。故說般若波羅蜜多咒。即說咒曰。揭諦揭諦。波羅揭諦。波羅僧揭諦。菩提莎婆訶。佛說是經已。諸比丘及菩薩眾。一切世間天、人、阿修羅、乾闥婆等。聞佛所說。皆大歡喜。信受奉行。
    【注】至元法寶勘同總錄，貞元續錄。《普徧智藏般若波羅蜜多心經》一卷。宋天竺三藏達摩戰濕羅譯《般若波羅蜜多心經》一卷。罽賓沙門般若共利言等譯。右二經與前大明咒般若心等經。同本異譯。
    法月兩譯本經。字句小異。此其重譯本也。初譯本。王舍大城作王舍城。觀自在作觀世音。菩薩摩訶薩作菩薩。在彼敷坐於其眾中。作在彼眾中。詣世尊所。面向合掌。曲躬恭敬。瞻仰尊顏。而白佛言。作合掌向佛。瞻仰尊顏。目不暫捨。白佛言。於此會中說。作於此眾中宣說。無為諸菩薩宣秘法要句。佛所護念。入於慧光三昧正受。入此定已。以三昧力。行深般若波羅蜜多時。作以佛神力。入於慧光三昧。行深般若波羅蜜多。從彼三昧安詳而起。即告慧命舍利弗言。作三昧定起。告舍利子言。名普徧智藏。作名曰普徧智藏。吾當為汝分別解說。作是語已。作當為汝說。作是說已。慧命舍利弗白觀自在菩薩言。惟大淨者。願為說之。作舍利子白觀自在菩薩摩訶薩言。唯願宣說。於斯告舍利弗。作舍利子。遠離顛倒。作遠離一切顛倒。諸比丘作與諸比丘。

    《般若波羅蜜多心經》（麗藏桓字函又據日本大藏本續藏本校正）
    唐罽賓國三藏般若共利言譯
    如是我聞。一時佛在王舍城耆闍崛山中。與大比丘眾及菩薩眾俱。時佛世尊即入三昧。名廣大甚深。爾時眾中有菩薩摩訶薩。名觀自在。行深般若波羅蜜多時。照見五蘊皆空。離諸苦厄。即時舍利弗。承佛威力。合掌恭敬。白觀自在菩薩摩訶薩言。善男子。若有欲學甚深般若波羅蜜多行者。云何修行。如是問已。爾時觀自在菩薩摩訶薩。告具壽舍利弗言。舍利子。若善男子。善女人。行甚深般若波羅蜜多行者。應觀五蘊性空。舍利子。色不異空。空不異色。色即是空。空即是色。受想行識。亦復如是。舍利子。是諸法空相。不生。不滅。不垢。不淨。不增。不減。是故空中無色。無受想行識。無眼耳鼻舌身意。無色聲香味觸法。無眼界。乃至無意識界。無無明。亦無無明盡。乃至無老死。亦無老死盡。無苦集滅道。無智。亦無得。以無所得故。菩提薩埵。依般若波羅蜜多故。心無罣礙。無罣礙故。無有恐怖。遠離一切顛倒夢想。究竟涅槃。三世諸佛。依般若波羅蜜多故。得阿耨多羅三藐三菩提。故知般若波羅蜜多。是大神咒。是大明咒。是無上咒。是無等等咒。能除一切苦。真實不虛。故說般若羅蜜多咒。即說咒曰。蘖諦蘖諦。波羅蘖諦。波羅僧蘖諦。菩提娑婆訶。如是。舍利弗。諸菩薩摩訶薩，於甚深般若波羅蜜多行。應如是行。如是說已。即時世尊。從廣大甚深三摩地起。讃觀自在菩薩摩訶薩言。善哉善哉。善男子。如是如是。如汝所說。甚深般若波羅蜜多行。應如是行。如是行時。一切如來。皆悉隨喜。爾時世尊。說是語已。具壽舍利弗。大喜充徧。觀自在菩薩摩訶薩。亦大歡喜。時彼眾會天、人、阿修羅、乾闥婆等。聞佛所說。皆大歡喜。信受奉行。

    《般若波羅蜜多心經》（日本藏經書院續藏本又據日本大藏本校正）
    唐三藏沙門智慧輪譯
    如是我聞。一時薄誐梵住王舍城鷲山中。與大苾芻眾及大菩薩眾俱。爾時世尊入三摩地。名廣大甚深照見。時眾中有一菩薩摩訶薩。名觀世音自在。行甚深般若波羅蜜多行時。照見五蘊自性皆空。即時具壽舍利子。承佛威神。合掌恭敬。白觀世音自在菩薩摩訶薩言。聖者。若有欲學甚深般若波羅蜜多行。云何修行。如是問已。爾時觀世音自在菩薩摩訶薩。告具壽舍利子言。舍利子。若有善男子。善女人。行甚深般若波羅蜜多行時。應照見五蘊自性皆空。離諸苦厄。舍利子。色空。空性見色。色不異空。空不異色。是色即空。是空即色。受想行識。亦復如是。舍利子。是諸法性相空。不生。不滅。不垢。不淨。不增。不減。是故空中無色。無受想行識。無眼耳鼻舌身意。無色聲香味觸法。無眼界。乃至無意識界。無無明。亦無無明盡。乃至無老死。亦無老死盡。無苦集滅道。無智證。無得。以無所得故。菩提薩埵。依般若波羅蜜多住。心無罣礙。心無罣礙故。無有恐怖。遠離顛倒夢想。究竟寂然。三世諸佛。依般若波羅蜜多故。得阿耨多羅三藐三菩提。現成正覺。故知般若波羅蜜多。是大真言。是大明真言。是無上真言。是無等等真言。能除一切苦。真實不虛。故說般若波羅蜜多真言。即說真言。唵。誐帝誐帝。播（引）囉誐帝。播（引）囉散誐帝。冒（引）地娑縛（二合）賀。如是。舍利子。諸菩薩摩訶薩。於甚深般若波羅蜜多行。應如是學。爾時世尊。從三摩地安詳而起。讃觀世音自在菩薩摩訶薩言。善哉善哉。善男子。如是如是。如汝所說。甚深般若波羅蜜多行。應如是行。如是行時。一切如來。悉皆隨喜。爾時世尊。如是說已。具壽舍利子。觀世音自在菩薩。及彼眾會一切世間天、人、阿蘇囉、巘馱嚩等。聞佛所說。皆大歡喜。信受奉行。

    《般若波羅蜜多心經》（敦煌石室本）
    唐三藏法師沙門法成譯
    如是我聞。一時薄伽梵住王舍城鷲峰山中。與大苾芻眾及諸菩薩摩訶薩俱。爾時世尊等入甚深明了三摩地法之異門。復於爾時觀自在菩薩摩訶薩。行深般若波羅蜜多時。觀察照見五蘊體性。悉皆是空。時具壽舍利子。承佛威力。白聖者觀自在菩薩摩訶薩曰。若善男子。欲修行甚深般若波羅蜜多者。復當云何修學。作是語已。觀自在菩薩摩訶薩。答具壽舍利子言。若善男子。及善女人。欲修行甚深般若波羅蜜多者。彼應如是觀察。五蘊體性皆空。色即是空。空即是色。色不異空。空不異色。如是受想行識。亦復皆空。是故舍利子。一切法空性無相。無生。無滅。無垢。無離垢。無減。無增。舍利子。是故爾時空性之中。無色。無受。無想。無行。亦無有識。無眼。無耳。無鼻。無舌。無身。無意。無色。無聲。無香。無味。無觸。無法。無眼界。乃至無意識界。無無明。亦無無明盡。乃至無老死。亦無老死盡。無苦集滅道。無智。無得。亦無不得。是故舍利子。以無所得故。諸菩薩眾。依止般若波羅蜜多。心無障礙。無有恐怖。超過顛倒。究竟涅槃。三世一切諸佛。亦皆依般若波羅蜜多故。證得無上正等菩提。舍利子。是故當知般若波羅蜜多大密咒者。是大明咒。是無上咒。是無等等咒。能除一切諸苦之厄。真實無倒。故知般若波羅蜜多。是秘密咒。即說般若波羅蜜多咒曰。峨帝峨帝。波羅峨帝。波囉僧峨帝。菩提沙訶。舍利子。菩薩摩訶薩應如是修學甚深般若波羅蜜多。爾時世尊從彼定起。告聖者觀自在菩薩摩訶薩曰。善哉善哉。善男子。如是如是。如汝所說。彼當如是修學般若波羅蜜多。一切如來。亦當隨喜。時薄伽梵說是語已。具壽舍利子。聖者觀自在菩薩摩訶薩。一切世間天、人、阿蘇羅、乾闥婆等。聞佛所說。皆大歡喜。信受奉行。

    《佛說聖佛母般若波羅蜜多心經》（龍藏薄字函又據日本大藏本校正）
    宋西天譯經三藏施護譯
    如是我聞。一時世尊在王舍城鷲峰山中。與大苾芻眾千二百五十人俱。並諸菩薩摩訶薩。而共圍繞。爾時世尊。即入甚深光明宣說正法三摩地。時觀自在菩薩摩訶薩。在佛會中。而此菩薩摩訶薩已能修行甚深般若羅蜜多。觀見五蘊自性皆空。爾時尊者舍利子。承佛威神。前白觀自在菩薩摩訶薩言。若善男子。善女人。於此甚深般若波羅蜜多法門。樂欲修學者。當云何學。時觀自在菩薩摩訶薩。告尊者舍利子言。汝今諦聽。為汝宣說。若善男子。善女人。樂欲修學此甚深般若波羅蜜多法門者。當觀五蘊自性皆空。何名五蘊自性空耶。所謂即色是空。即空是色。色無異於空。空無異於色。受想行識。亦復如是。舍利子。此一切法如是空相。無所生。無所滅。無垢染。無清淨。無增長。無損減。舍利子。是故空中無色。無受想行識。無眼耳鼻舌身意。無色聲香味觸法。無眼界。無眼識界。乃至無意界。無意識界。無無明。亦無無明盡。乃至無老死。亦無老死盡。無苦集滅道。無智、無所得。亦無無得。舍利子。由是無得故。菩薩摩訶薩。依般若波羅蜜多相應行故。無所著。亦無罣礙。以無著、無礙故。無有恐怖。遠離一切顛倒妄想。究竟圓寂。所有三世諸佛依此般若波羅蜜多故。得阿耨多羅三藐三菩提。是故應知般若波羅蜜多。是廣大明。是無上明。是無等等明。而能息除一切苦惱。是即真實無虛妄法。諸修學者當如是學。我今宣說般若波羅蜜多大明曰。怛［寧＋也］ 他。唵。誐帝（引）誐帝（引）。播（引）囉誐帝（引）。播（引）囉僧誐帝。冒提莎（引）賀（引）。舍利子。諸菩薩摩訶薩。若能誦是般若波羅蜜多明句。是即修學甚深般若波羅蜜多。爾時世尊。從三摩地安詳而起。讃觀自在菩薩摩訶薩言。善哉善哉。善男子。如汝所說。如是如是。般若波羅蜜多。當如是學。是即真實最上究竟。一切如來亦皆隨喜。佛說此經已。觀自在菩薩摩訶薩。並諸苾芻。乃至世間天、人、阿修羅、乾達婆等。一切大眾。聞佛所說。皆大歡喜。信受奉行。
    以上七種譯文。詳略雖殊。經恉則一。皆出自同一梵本，吾國四眾間流通最廣者。自推玄奘法師譯本。文簡理具。本詮宗之。
    【注】四眾者。比丘。比丘尼。優婆塞。優婆夷也。《藥師經》曰。若有四眾。苾芻。苾芻尼。鄔波索迦。鄔波斯迦。此統指在家出家而言。若出家四眾。則為比丘。比丘尼。沙彌。沙彌尼。
    流通者。傳布無壅之義。《十地義記》云。傳布名流。無壅曰通。欲使正法流注於無窮。聖教不壅於方來也。

    自東晉道安法師以三分判釋經文。首序分。次正宗分。終流通分。冥符親光。為譯經者所宗。所謂彌天高判。今古同遵也。本經法月師譯本。自如是我聞至與諸眾生作大光明為序分。於是觀世音菩薩摩訶薩。蒙佛聽許。至菩提莎婆訶為正宗分。佛說是經已。至信受奉行。則流通分也。般若共利言等四師所譯皆然。什師奘師淨師譯本。簡擇精要。略去序分與流通分。
    【注】冥符親光者。先是道安法師。以三分判釋諸經。譯者宗之。及玄奘法師譯《佛地論》。始知西域親光菩薩判《佛地經》亦分三分。一，教起因緣分。二，聖教所說分。三，依教奉行分。與序、正、流通辭異義同。道安所見。與之冥符。
    彌天高判者。即指道安。以晉時民間習語。四海習鑿齒。彌天釋道安。極言其化行之廣也。
    序有二種。一，通序。諸經通有故。亦名證信序。證明佛說以起誠信故。亦名經後序。佛說經時。本無此序。至結集時始加入故。亦名《遺教序》。佛涅槃時。阿難尊者。奉佛遺教。結集時當置此序故。亦名《印定序》。諸經之首皆安立故。亦名《破邪序》。對破外道阿優故（外道經首。皆安阿優二字。阿此云無。優此云有。不出有無。即斷常計。經序以如是起首。如即真空。是即妙有。以對破邪宗之執斷執常）。二，別序。諸經所說緣起不同故。又名發起序。以發起本經說法因緣故。本經法月師譯本。如是我聞至與大比丘眾滿百千人菩薩摩訶薩七萬七千人俱。為通序。以下至與諸眾生作大光明。為別序。
    世尊說法。必具六緣。結集時即於通序見之。云如是者。信成就也。《智度論》云。佛法大海。信為能入。智為能度。信者。言是事如是。不信者。言是事不如是。肇公云。信則所言之理順。順則師資之道成。萬行中以信為首。故曰如是。云我聞者。我即阿難自指。五蘊假我。假立賓主。但是名字。聞謂耳根發識聽受。夫耳聞非識。識聞非耳。緣合方聞。雖因耳處。廢別從總。總該諸根。故稱我聞。云一時者。時成就也。師資合會。說聽究竟。一者。如來說經有無量時。不能別舉。二者。諸方時分。延促不定。故云一時。云佛者。主成就也。具稱佛陀。此云覺者。自覺異凡夫。覺他異二乘。覺滿異菩薩。三覺理圓。故稱妙覺。云在王舍大城靈鷲山中者。處成就也。在者。住也。佛內住無量三昧。迹住靈鷲山中。處有二。一，所化處。即王舍城。二，所住處。即靈鷲山中。云與大比丘眾滿百千人。菩薩摩訶薩七萬七千人俱者。眾成就也。《法華文句》。佛說經時。海眾云集。一，發起眾。發動本經說法因緣者。二，當機眾。夙植德本。當座聞法獲益者。三，影響眾。諸佛菩薩。隱其圓果。示同機眾者。四，結緣眾。過去根淺。三慧不生。現世雖見佛聞法。未能獲益。但作未來得度因緣者。《華嚴經清涼疏》。又有常隨眾。如普賢等常隨不離者。守護眾。如執金剛等。常勤守護者。莊嚴眾。如道場神等嚴淨佛宮殿者。通序所明。即此六緣。六緣既具。法會斯起。

    以上七譯。皆取梵文之意。紬譯華言。亦有直取梵音。表以漢字者。日本大藏經梵漢般若心經異本集有梵語《心經》一卷。題宋蘭谿大覺禪師將來。又題宋道隆將來。蓋亦由我國傳入者與敦煌石室所出唐梵翻對字音《般若波羅蜜多心經》。大同小異。茲為學者參考之便。並錄如次。

    梵語《心經》一卷（日本大藏經本）

    八羅娘波囉彌陀逆哩馱耶素怛囉。

    阿列婆嚕枳帝室縛羅母帝薩埵。嚴毗覽八囉娘波囉彌哆左焰左耶頗嚕也。縛嚕迦野地娑麼畔左思建馱娑怛寫娑婆婆縛戍涅縛室底娑麼伊賀。舍利補怛囉嚕畔戍涅戍涅多縛嚕縛。嚕畔曩比囊戍涅哆戍涅哆夜。囊比囊迦嚕畔。夜嚕也嚕畔娑戍涅哆哆也。戍涅多娑嚕畔伊縛弭縛。吠怛多三迦南散娑三迦喃。尾迦南伊賀。舍利補怛囉。薩囉縛達磨戍涅多洛叉拏。阿耨多婆左阿里也嚕馱。阿麼攞。阿尾也嚕攞。阿怒拏阿婆哩布攞怛。多娑磨捨哩布怛囉。戍涅哆耶戍涅多薩嚕畔。曩吠怛多。散迦。南三散娑迦。喃尾誐南。囊[石*斥]芻助嚕囉迦囉拏即賀縛迦野頗那悉莎嚕畔。攝那彥馱囉娑娑播囉瑟吒尾演達摩。曩斫芻馱都。也縛那麼怒尾迦南[馬*犬]都。那尾南。那尾南。吒喻那尾南。叉欲夜縛。那槎囉麼囉南。那左羅麼囉拏叉喻。那耨佉娑敏那野寧嚕馱縛室哩誐尾演缽羅誐婆囉弭。多縛室利誐尾賀囉野。枳陀婆囉誐。枳陀婆囉誐。那悉帝達麼那缽囉尾地那備。娑曼也[馬*犬]三曼。曩缽囉尾帝娑馱冒地三埵南。缽囉誐婆囉弭多。縛室哩耶奴答覽。三藐三牟備牟備。娑曼馱縛。室裏誐尾演。缽囉誐娑囉彌陀。摩訶曼怛羅。摩訶尾欲曼怛羅。阿耨多羅曼怛羅。阿娑婆三備曼怛羅。娑婆奴迦缽囉。舍婆那娑帝冒帝地演達摩。缽囉誐婆囉弭多目訖姤滿怛羅。怛姪哆。虐諦虐諦。播羅虐諦。播羅僧虐諦。菩提娑婆訶。
    【注】梵語。即印度文言。印度人自稱為梵天苗裔。故曰梵語。
    蘭谿大覺禪師。即道隆也。宋僧。俗姓冉氏。號蘭谿子。淳祐三年。應北條時賴之聘。赴日本。為日本建長寺之開山祖。著有《般若波羅心經注》。
    將者。持義。與偕義。將來者。猶云持來也。杭州方言猶然。
    敦煌石室。在甘肅省敦煌縣東南之鳴沙山。山麓有三界寺。寺旁石室甚多。舊名莫高窟。俗稱千佛洞。石室之一為書庫。內藏唐人手寫佛經。及其他美術品甚多。蓋西夏兵革時保存於此者。清光緒二十六年庚子發見。國人不知珍惜。大部為英人斯坦因。法人伯希和運去。藏倫敦圖書館。及巴黎國民圖書館者。達千餘卷。迨民國十九年。政府始前往收拾。舉其殘餘。運至京師圖書館。精萃者已傷失殆盡。國有瑰寶。不能自保。雖曰諸行無常。亦秦之無人也。

    《唐梵翻對字音般若波羅蜜多心經》（敦煌石室本）
    缽囉［二合］（般）誐攘［二合］（若）播（波）囉（羅）弭（蜜）哆（多）紇哩［二合］那野（心）素怛囕（經）。
    阿哩也［二合］（聖）嚩嚕枳帝（觀）濕嚩路（自在）冒地（菩）娑怛侮［二合］（薩）。儼鼻囕（深）缽囉［二合］（般）誐攘［二合］（若）播（波）囉（羅）弭（蜜）哆（多）左哩焰［二合］（行）左囉（行）麼女（時）尾也［二合］。嚩嚕［引］迦（照）底娑麼［二合］（見）畔左（五）塞建［引］馱［引］（蘊）娑怛［引］室左［二合］（彼）娑嚩（自）婆嚩［引］（性）戍你焰［二合］（空）跛失也［二合］底娑麼［二合］（現）伊賀（此）。捨（捨）哩（利）補怛囉［二合］（子）。嚕畔（色）戍你焰［二合］（空）戍你也［二合］（空）[口*帶]（性）嚩（是）嚕畔（色）。嚕播（色）曩（不）比[口*栗]［二合］他（異）戍你也［二合］哆（空）。戍你也［二合］（空）哆野（亦）曩引（不）比[口*栗]［二合］他（異）薩嚕［二合］畔（色）。夜（是）怒嚕［二合］畔（色）娑（彼）戍你也［二合］哆夜（空）戍你也［二合］哆（空）娑（彼）嚕畔（色）。噎嚩（如）弭嚩（是）。吠那曩（受）散誐攘（想）散娑迦［引］囉（行）尾誐攘［二合］喃（識）。伊賀（此）捨（捨）哩（利）補怛囉［二合］（子）。薩囉嚩（諸）達摩（法）戍你也［二合］哆（空）落乞叉［二合］拏（相）。阿怒（不）哆播［二合］。曩（生）阿寧（不）嚕馱（滅）。阿（不）麼攞（垢）阿（不）尾麼攞（淨）。阿（不）怒曩（滅）阿（不）播哩補攞拏［二合］（增）哆（是）娑每（故）捨（捨）哩（利）補怛囉［二合］（子）戍你也［二合］（空）哆焰（中）曩（無）嚕畔（色）。曩（無）吠［引］那囊（受）。曩（無）散誐攘（想）。曩（無）散娑迦囉（行）。曩（無）尾誐攘［二合］喃（識）。曩（無）斫乞芻（眼）戍嚕怛囉［二合］（耳）迦囉［二合］拏（鼻）[口*爾]賀嚩（舌）迦野（身）麼曩勒（意）。曩（無）嚕畔（色）攝那（聲）彥馱（香）囉娑（味）娑播囉［二合］瑟吒尾也［二合］（觸）達摩（法）。曩（無）斫乞芻（眼）馱都（界）哩也［二合］嚩（乃至）曩（無）麼怒（意）尾誐攘誐［二合］喃（識）馱都（界）。曩（無）尾你［二合］也（無明）。曩（無）尾你［二合］也（按梵語無明為阿尾你。此二句尾你也恐傳寫有誤。以原文如此。不敢擅改）。乞叉喻（盡）。野嚩（乃至）曩（無）[口*惹]囉（老）麼囉喃（死）曩（無）[口*惹]囉（老）麼囉拏（死）乞叉喻（盡）。曩（無）褥佉（苦）娑敏那野（集）寧嚕馱（滅）麼哩誐穰［二合］（道）曩（無）誐攘喃（智）。曩（無）缽囉［二合］比底（得）。曩（無）鼻娑麼（證）。哆（以）娑每（無）那（所）缽囉［二合］比底（得）怛嚩（故）。冒（菩）地（提）娑（薩）怛嚩（埵）喃缽囉［二合］（般）誐攘（若）播（波）囉（羅）弭（蜜）哆（多）麼室哩底也［二合］（依）尾賀（於）囉底也［二合］（住）。只哆［引］（心）嚩（無）囉拏（罣礙）只哆（心）嚩（無）囉拏（罣礙）曩（無）悉底怛嚩［二合］（有）那（恐）涅哩［二合］素都［二合］（怖）。尾播（顛）哩也［二合］娑（倒）底（遠）伽蘭哆（離）。寧瑟吒（究竟）寧哩也嚩［二合］（涅）喃（槃）。底哩也［二合］（三）馱嚩［二合］（世）尾也［二合］嚩（所）悉體哆（經）娑嚩（諸）沒馱（佛）。缽囉［二合］（般）誐攘二合（若）播（波）囉（羅）弭（蜜）哆（多）麼室哩底也二合（依）。阿耨哆蘭（上）參（正）藐也［二合］（等）參（正）沒地（覺）麼鼻參沒馱（現證）。哆引（是）娑每［二合］（故）誐攘［二合］哆（應）尾演（知）。缽囉［二合］（般）誐攘［二合］（若）播（波）囉（羅）弭（蜜）哆（多）麼賀［引］（大）滿怛囉（咒）。麼賀（大）尾你也［二合］（明）滿怛囉（咒）。阿（無）耨哆囉（上）滿怛囉（咒）。阿娑麼（無等）娑麼（等）滿怛囉（咒）薩嚩（一切）耨佉（苦）缽囉［二合］捨曩（止息）。娑（真）底也（實）麼弭（不）贊哩也［二合］怛嚩［二合］（虛）。缽囉［二合］（般）誐攘（若）播（波）囉（羅）弭（蜜）哆（多）目訖垢［二合］（說）滿怛囉（咒）。怛你也［二合］他（曰）。誐諦誐諦。播攞誐諦。播囉僧誐諦。冒地［引］。娑嚩賀。
    【注】此經原文見日本大正藏第八卷第八五一頁。題下注曰觀自在菩薩。與三藏法師玄奘親教授梵本。不潤色。原刻頗多衍文誤字。依孫慧風居士影印手校本。及民國三十二年。支那內學院蜀院木刻本。參互訂正。經前尚有一序文。題云。西京大興善寺石壁上錄出。慈恩和尚奉詔述序。梵本般若多心經者。大唐三藏之所譯也。三藏志逰天竺。路次益州。宿空惠寺道場內。遇一僧有疾。詢問行止。因話所之。乃難歎法師曰。為法忘體。甚為希有。然則五天迢遞。十萬餘逞（似當作程）。道涉流沙。波深弱水。胡風起處。動塞草以愁人。山鬼啼時。對荒兵（似當作林）之落葉。朝行雪巘。暮宿冰崖。樹掛猿猱。境多魑魅。層巒疊於蔥嶺。縈（似當作瑩）似帶雪之白雲。群木簇於鷲峰。聳（疑落一字）參天之碧嶠。逞（似當作程）途多難。去也如何。我有三世諸佛心要法門。師若受持。可保來往。遂乃口授與法師訖。至曉失其僧焉。三藏結束囊裝。漸離唐境。或途經厄難。或時有闕齋饈。憶而念之。四十九遍。失路即化人指引。思食則輒現珍蔬。但有誠祈。皆獲戩祜。至中天竺摩竭提國那爛陀寺。旋遶經藏次。忽見前僧。而相謂曰。逮涉艱嶮。喜達此方。賴我昔在支那國所傳三世諸佛心要法門。由斯經歷。保爾行途。取經早還。滿爾心願。我是觀音菩薩。言訖。沖空。既顯奇祥。為斯經之至驗。信為般若。囗為聖樞。如說而行。必超覺際。究如來旨。巨暦三祇。諷如來經。能銷三障。若人虔誠受持者。體理斯而懃焉。按大慈恩寺三藏法師傳。莫賀延磧。長八百餘里。古曰沙河。上無飛鳥。下無走獸。復無水草是時顧影。惟一心但念觀音菩薩及般若心經。初法師在蜀。見一病人。身瘡臭穢。衣服破污。愍將向寺。施與衣服飲食之具。病者慚愧。乃授法師此經。因常誦習。至沙河間。逢諸惡鬼。奇狀異類。遶人前後。雖念觀音。不能全去。及誦此經。發音皆散。在危獲濟。實所憑焉。與序中菩薩授經因緣相合。而本經持誦之驗。亦即此可徵焉。

    以上所列。則本經由梵譯漢之源流可知。至由梵譯藏。近人更由藏文轉譯者。就著者所見。凡有五本錄之如次。

    《般若心經》（日僧能海寬由藏文譯日文。茲更由日文轉譯）。

    疑念絕讃智慧到彼岸。不生不滅虛空性。各各自明智慧之境界。三世佛母尊前皈命禮。

    如是我聞。一時世尊在王舍城鷲峰山中。與大比丘眾及大菩薩眾俱。爾時世尊入三昧寂定。名甚深光耀法門時聖者觀自在菩薩摩訶薩。行深般若波羅蜜多。照見五蘊等自性皆空。爾時具壽舍利子承佛威力。白聖觀自在菩薩摩訶薩言。若有善男子善女人。欲修行深般若波羅蜜多行者。云何教彼修學。如是言已。聖觀自在菩薩摩訶薩。告具壽舍利子言。舍利子。若有善男子。善女人。欲修行深般若波羅蜜多行者。應照見五蘊等自性皆空。色不異空。空不異色。色即是空。空即是色。受想行識。亦復如是。一切法空無相。不生。不滅。無垢。無除垢。無減。無增。舍利子。是故空中無色。無受。無想。無行。無識。無眼。無耳。無鼻。無舌。無身。無意。無色。無聲。無香。無味。無觸。無法。無眼界。乃至無意界。無意識界。無無明。亦無無明盡。乃至無老死。亦無老死盡。無苦集滅道。無智。無得。亦無非得。舍利子。以無得故。菩提薩埵。依般若波羅蜜多。心無障礙。無怖畏。遠離顛倒。究竟大涅槃際。三世諸佛。亦依般若波羅蜜多。成就阿耨多羅三藐三菩提。故知般若波羅蜜多咒。是大明咒。是無上咒。是無等等咒。是能除一切苦咒。真實不虛。即說般若波羅蜜多咒曰。達陀耶多。唵。揭諦揭諦。波羅揭諦。波羅僧揭諦。菩提娑婆訶。舍利子。菩薩摩訶薩。於深般若波羅薩多。應如是行。爾時世尊從定而起。讃聖觀自在菩薩摩訶薩言。善哉。善哉。如是。如是。如汝所說修行般若波羅蜜多。諸佛如來。亦皆隨喜。世尊說是語已。具壽舍利子。聖觀自在菩薩摩訶薩。一切眾會。天，人，阿修羅，乾闥婆等。皆大歡喜。信受奉行。
    【注】此經經能海寬由藏文譯日文。著者更由日文轉譯。能海寬於日本明治三十六年十二月在藏圓寂。遺稿僅存此譯。由其友太田保一郎於明治四十四年刊布流通。
    經中達陀耶多。為陀羅尼起句。諸咒皆然。意為即說咒曰。與上文即說般若波羅蜜多咒曰句。似重複。但日文原本如此。譯者為存其真。未敢刪去。

    《佛說般若波羅蜜多心經》（孫慧風由藏文轉譯）
    無有言說般若度。不生不滅虛空性。各各自明智行境。敬禮三世尊勝母。
    如是我聞。一時薄伽梵在王舍城耆闍崛山中。與大苾芻眾及菩薩摩訶薩眾俱。爾時薄伽梵等入甚深觀照三摩地特異法門。復於爾時。聖觀自在菩薩摩訶薩。亦行甚深般若波羅蜜多。普徧觀察。照見彼五蘊等自性皆空。爾時具壽舍利子。承佛威力。白聖觀自在菩薩摩訶薩言。若善男子善女人。欲行甚深般若波羅蜜多行。應如何修學。作是語已。聖觀自在菩薩摩訶薩。告具壽舍利子言。舍利子。善男子。善女人。欲行甚深般若波羅蜜多行者。應作如是觀。如實觀察彼五蘊等自性皆空。色即是空。空即是色。色不異空。空不異色。受想行識。亦復如是。故舍利子。一切法自性空。無相。不生。不滅。無垢。無無垢。不減。不增。是故。舍利子。空中無色。無受。無想。無諸行。無識。無眼。無耳。無鼻。無舌。無身。無意。無色。無聲。無香。無味。無觸。無法。無眼界。乃至無意界。乃至亦無意識界。無無明。無無明盡。乃至無老死。亦無老死盡。無苦集滅道。無智。無得。亦無不得。是故。舍利子。諸菩薩眾。以無所得故。依甚深般若波羅蜜多而住。心無障礙。亦無恐怖。超越顛倒。究竟涅槃。三世常住一切佛。亦依甚深般若波羅蜜多。於阿耨多羅三藐三菩提。現證正覺。是故當知般若波羅蜜多真言。是大明真言。無上真言。無等等真言。能息一切苦真言。真實不虛。即說般若波羅蜜多真言曰。噶得噶得。巴阿惹噶得。巴阿惹桑噶得。玻瑅。娑哈。爾時薄伽梵。從彼三摩地而起。授聖觀自在菩薩摩訶薩言。善哉。善哉。善男子。彼如是。彼誠如是。行甚深般若波羅蜜多。應依汝所顯示。一切如來悉隨喜。薄伽梵說是語已。具壽舍利子。聖觀自在菩薩摩訶薩。及一切在會大眾。並諸世間天，人，阿修羅，乾闥婆等。皆大歡喜。現前讚揚薄伽梵所說。

    《般若波羅蜜多心經》（釋楚禪由藏文轉譯）
    離言絕思般若波羅蜜。無生無滅自性如虛空。各各自明智慧之行境。三世佛母尊前皈敬禮。
    如是我聞。一時佛在王舍城耆闍崛山。與大比丘及大菩薩僧伽眾俱。爾時世尊入住甚深明門平等三摩地。時聖者觀自在菩薩摩訶薩。行深般若波羅蜜多。照見五蘊自性皆空。於是長老舍利子。承佛威神。白聖者觀自在菩薩摩訶薩言。聖者。若善男女等。欲修甚深般若波羅蜜多行。應云何學。聖者觀自在菩薩摩訶薩。告長老舍利子言。舍利子。若善男子。善女人等。欲修甚深般若波羅蜜多行。應如是照見五蘊自性皆空。如實隨觀。色不異空。空不異色。色即是空。空即是色。受想行識。亦復如是。舍利子。是諸法空相。不生。不滅。不垢。不淨。不增。不減。是故空中無色。無受想行識。無眼，耳，鼻，舌，身，意。無色，聲，香，味，觸，法。無眼界乃至無意識界。無無明。亦無無明盡。乃至無老，死。亦無老，死盡。無苦集滅道。無智，亦無得。以無所得故。菩提薩埵。依般若波羅蜜多故。心無罣礙。無罣礙故。無有恐怖。遠離顛倒夢想。究竟涅槃。三世諸佛。依般若波羅蜜多故。得阿耨多羅三藐三菩提。故知般若波羅蜜多。是大神咒。是大明咒。是無上咒。是無等等咒。能除一切苦。真實不虛。故說般若波羅蜜多咒。即說咒曰。揭諦揭諦。波羅揭諦。波羅僧揭諦。菩提娑婆訶。舍利子。此甚深般若波羅蜜多行。菩薩摩訶薩。應如是學。世尊從三摩地起。讃聖者觀自在菩薩摩訶薩言。善哉。善哉。善男子。善說如是般若波羅蜜多行。諸佛如來。亦皆隨喜。說是語時。長老舍利子。聖者觀自在菩薩摩訶薩。以及會中一切天，人，阿修羅，乾闥婆等。皆現前如說讚歎。喜受奉行。
    【注】本譯及孫慧風慧清各譯。與日人能海寬日譯本。所準據之藏文。似係同出一本。
    楚禪。湖北漢陽人。民國十七年於漢口千佛寺披剃。抗戰後入西康雅安。興復鶴林寺。三十三年赴甘孜及德格竹菁等地參學。佛世社得其所譯心經。覺有情月刊第十卷第六期流布之。

    《般若波羅蜜多心經》（釋慧清由藏文轉譯）
    敬禮三世諸佛母。智度離言無說議。不生不滅虛空性。自內證知所行境。敬禮佛母般若波羅蜜多。
    如是我聞。一時佛在王舍城鷲峰山中。與大比丘眾及大菩薩俱。爾時世尊入法門定。名為顯現甚深。復於爾時。觀自在菩薩摩訶薩。照見甚深般若波羅蜜多行性。并於五蘊照見自性都空。即時具壽舍利子。承佛神力。請問觀自在菩薩摩訶薩言。若有善男子。或善女人。欲修行般若波羅蜜多行者。彼當云何修學。說是語已。觀自在菩薩摩訶薩。告具壽舍利子言。若有善男子，或善女人。欲修行般若波羅蜜多行者。彼當如是觀照。謂正隨觀見五蘊自性都空。色即是空。空性是色。色不異於空性。空性亦不異色。如是受想行識。亦即是空。舍利子。是故諸法空性無相。不生。不滅。無垢。亦無離垢。無減。無增。舍利子。是故於空性中。無色。無受。無想。無行。無識。無眼。無耳。無鼻。無舌。無身。無意。無色。無聲。無香。無味。無觸。無法。無眼界。乃至無意界。無意識界。無無明。亦無無明盡。乃至無老死。亦無老死盡。無苦集滅道。無智，無得。亦無非得。舍利子。如是菩薩由無得故。即能依住般若波羅蜜多。心無障礙。無有恐怖。遠離一切顛倒。究竟大涅槃際。三世諸佛。亦依般若波羅蜜多故。得阿耨多羅三藐三菩提。由是應知般若波羅蜜多即是咒。是大明咒是無上咒是無等等咒。是善能除滅一切苦咒。真實不虛。即說般若波羅蜜多咒曰。達嘉他。嗡姆。伽德黑。伽德黑。巴羅伽德黑。巴羅薩姆伽德黑。菩提薩娃訶。舍利子。菩薩摩訶薩。即應如是修學甚深般若波羅蜜多。爾時世尊乃從定起。讃曰。善哉。善哉。觀自在菩薩。如是如是。若善男子。如汝所說。修行甚深般若波羅蜜多。諸佛如來。亦所隨喜。世尊說是語已。具壽舍利子。觀自在菩薩摩訶薩。與彼一切所攝眷屬。及天，人，非天，健達婆等，諸世間。普皆隨喜。於佛所說。信受奉行。
    【注】此譯見世間解月刊第一期。

    《般若波羅蜜多心經》（釋超一由藏文轉譯）
    敬禮婆伽梵母般若波羅蜜多心。
    如是我聞。一時佛在王舍城鷲峰山中。與大比丘僧及諸菩薩摩訶薩俱。爾時婆伽梵即入甚深明了三摩地法之異門。其時觀自在菩薩摩訶薩。行深般若波羅蜜多。觀察照見五蘊所有自性皆空。復次，具壽舍利子。承佛威力。白聖者觀自在菩薩摩訶薩曰。若善男子欲修行甚深般若波羅蜜多者。彼應如何學。作是語已。觀自在菩薩摩訶薩。答具壽舍利子言。舍利子。若善男子，善女人。欲修行甚深般若波羅蜜多者。彼應審諦觀察五蘊一切自性皆空。色即是空。空即是色。色不異空。空不異色。是故受想行識。亦復皆空。舍利子。如是。一切法空性。無生。無滅。無垢。無淨。無減。無增。舍利子。是故空性之中。無色。無受。無想。無諸行。無識無眼。無耳。無鼻。無舌。無身。無意。無色。無聲。無香。無味。無觸。無法。無眼界。乃至無意識界。無無明。亦無無明盡。乃至無老死。亦無老死盡。如是。無苦集滅道。無智。無得。亦無不得。舍利子。以無所得故。諸菩提薩埵。依止般若波羅蜜多。心無罣礙。無有恐怖。遠離顛倒。究竟涅槃。三世諸佛。亦皆依此般若波羅蜜多故。證得無上正等菩提。是故諦知般若波羅蜜多咒。是大明咒。是無上咒。是無等等咒。能除一切苦。真實不虛。即說般若波羅蜜多咒曰。噶底噶底把拉噶底。把拉僧噶底。菩提莎哈。舍利子。菩薩摩訶薩。應如是學甚深般若波羅蜜多。於是婆伽梵從彼定起。讃觀自在菩薩摩訶薩言。善哉。善哉。善男子。如此也。善女人。如此也。如汝所說。行此甚深般若波羅蜜多者。一切如來。亦皆隨喜。婆伽梵說是語已，具壽舍利子。及觀自在菩薩摩訶薩。并一切世間天、人、阿修羅、乾達婆等。聞佛所說。皆大歡喜。信受奉行。
    《聖者般若波羅蜜多心經》終。

    南無敬禮上師。　敬禮佛。　敬禮法。　敬禮僧。　敬禮大母般若波羅蜜多。　敬禮彼等依止。 我等一切真實語。當願成就。
    如前自在帝釋天主，能於般若波羅蜜多義。甚深思惟。並且已作依止念誦。魔部等顛倒。一切遣除。如是。我亦能於大母般若波羅蜜多義。甚深思惟。並且已作依止念誦。當願魔部等顛倒遣除。當願無。當願寂滅。一切顛倒寂滅。梓擋孤魯也莎哈。
    寂滅八萬障難頌。 遠離相違災害緣。 成就圓滿諸順緣。 願彼吉祥此安樂。
    【注】此譯從善知識湯秉遴居士寄示真言研究社出版，超一法師新譯《無上三經》中錄出。與日僧能海寬及慧清孫慧風各譯。大致與由梵譯漢之法成譯本相同。楚禪譯本。色不異空至娑婆訶。與玄奘三藏譯本全同。可徵梵本流布。漢藏無異。

    《般若波羅蜜多心經詮注·卷一》


卷二·求加被偈

    《般若波羅蜜多心經詮注·卷二》
    震旦白衣周止菴學

    上卷已略述本經源流。及各種異譯。以次當依奘師譯本。分別詮注。
    【注】詮有能詮所詮。能與所相對。詮。《說文》云。具也。具說事理曰詮。詮顯經典之文句。以能顯義理謂之能詮。所顯之義理謂之所詮。《四教儀》云。教是能詮。理是所詮。注。灌也。注義於經下。若水之注物。又著也。為之解釋使其義著明也。詮以明經。注以釋詮。

    求加被偈
    般若勝義。非世間智慧所能窺測。茲依聖言。權說少分。敬以伽陀。上求加被。
    稽首大悲觀自在。宣說般若智無礙。少文多義攝無盡。世但誦文義則晦。我亦多生叢業障。西河觸動觀河悔。欲疏經義導初機。如管窺天蠡測海。求大慈悲賜加被。或冥或顯垂靈誨。願所闡揚真實義。悉符佛意無違背。以此般若大火聚。燒盡無明登不退。迴向法界諸有情。同證無量光三昧。
    【注】般若義詳詮文勝義者。對於世俗義而言。深妙之義理也。世間智慧者。通於世諦。事相之智慧。對出世間智言。謂之世智。窺測即下文管窺蠡測之意。漢書東方朔傳。以管窺天。以蠡測海。言所見之小也。聖言。聖者之言。茲者。此也。依者。依止。依止聖言者。詮注以經解經。間或旁採論疏。略參臆見。亦以不悖經恉為鵠。離經一字。便同魔說。三世諸佛。同證此言。權者。方便。《彌陀經·靈芝疏》云。權巧赴機。行法非一。權說者。為利有情。方便宣說也。少分者。聖言無量。僅說一分也。伽陀者梵語。此云諷頌。三字，四字，五字，七字，八字，九字，不等。以四句為一偈。孤起直說。故名直頌。亦名不重頌。加被者。佛力加持覆被也。
    稽首者。梵語作伴談。或伴題。《行宗記》云。頭至地為稽首。《周禮春官》。大祝辨九拜。一曰稽首。注，稽首，拜，頭至地也。疏，稽是稽留之義。頭至地多時。則為稽首也。拜中最重。荀子云。平衡曰拜。下衡曰稽首。注，平衡。頭與腰如衡之平也。大悲者。悲心廣大之義。三世諸佛。皆以大悲為根本。觀世音菩薩救度眾生。悲心最重。故《大悲心陀羅尼經》稱觀音為大悲主。《請觀音經》稱大悲觀世音。《觀經定善義》稱大悲菩薩。觀自在即觀音新譯之名。為本經說法主。宣說者。宣揚教義。說法度生也。智無礙者。即無礙智。《即身成佛義》云。無礙者。涉入自在義。謂通達自在說法之智也。於教法無滯曰法無礙。知教法所詮義理無滯曰義無礙。於諸方言詞通達自在曰詞無礙。為眾生樂說自在曰樂說無礙。《智度論·二十五》云。四無礙智者。義無礙智。法無礙智。詞無礙智。樂說無礙智（《大般若經·五百三十一》作辯無礙智）。《起信論》云。或有眾生無自智力。因於廣論而得解者。亦有眾生復以廣論文多為煩。心樂總持少文而攝多義能取解者。大經廣說般若至二十萬頌。菩薩為憫眾生故。在般若會中承佛印可。說諸菩薩普徧智藏般若波羅蜜多心。抉擇精要。簡而又簡。以一十四行盡之。故云少文多義攝無盡也。以精簡故。自唐以來。四眾間無人不誦。但白衣中亦間有一二。出於誤解者。余嘗以吾鄉人誦心經。照見五蘊皆空句連接上文時字併讀為誤。後讀明人注解。已先有之。又有以多字作定字解。稱為多心經者。則經義之晦可知。晦者昧也。
    我者。著者自稱。五蘊和合之假我也。非有我之實體。《佛地論》云。我，謂諸蘊世俗假者。《智度論》云。佛弟子輩。雖知無我。隨俗法說我。非實我也。業障，惑業報見四障之一（見《海意菩薩所問淨印法門經》）。眾生由貪瞋癡等惑。於諸善法。不能勤行。隨身口意造作惡業。障蔽正道也。西河，在今陝西省。以在黃河之西。故名西河。《禮記》子夏退老西河。喪其子而喪其明。觸者。動也。凡相感而心有所動曰觸。著者十六年前。因次兒永洪之逝。頓悟諸行無常。謝絕世緣。發願注經。期以一得之愚。引導初機。同出輪迴生死之苦。故曰西河觸動觀河悔。用《楞嚴經·二》。佛問波斯匿王觀河之見。明色身無常。真性不遷之義。欲者。希冀之詞。疏者。通也。疏通其義也。經義。契經之真義。導者。啟迪之義。初機。初發心之行者也。求者。乞也。大慈悲者。如《智度論·二十七》說。大慈與一切眾生樂。大悲拔一切眾生苦。觀音為慈悲門主。著者以至誠上求本尊之加被也。賜者。予也。或。不定詞。加被。有冥加。有顯加。以佛力陰為加被。資益神識。曰冥加。放光摩頂。顯有所示。曰顯加。自上施下曰垂。靈誨者。以靈感示誨也。願者。祈求。闡者。顯明。揚者。舉也。真實義者。諸法真實之義。《準菩薩善戒經》有四。一，世流布真實義。二，方便流布真實義。三，淨煩惱障真實義。四，淨智慧障真實義。此屬第二。悉者。皆也。符者。合也。佛意者。世尊所示正知正見也。無違背者。不相背戾也。以者。用也。此者。斯也。聚者。集合義。大火聚者。般若以智慧火。燒煩惱薪。無幽不爥。無穢不除。如大火聚也。盡者。無餘義。登者。上也。進也。不退者。梵語阿鞞跋致。菩薩所修德業。永不退轉之位。迴向者。以所修功德。平等共有迴向一切有情也。法界者。諸佛及眾生之本體。四聖六凡。感報不同。故台宗為差別塵沙事相。立十法界。一，佛法界。自覺覺他，覺行共滿之境界也。二，菩薩法界。為無上菩提，修六度萬行之境界也。三，緣覺法界。為入涅槃，修十二因緣觀之境界也。四，聲聞法界。為入涅槃依佛之聲教，修四諦觀之境界也。五，天法界。修上品十善，兼修禪定，生天受靜妙樂之境界也。六，人法界。修五戒中品十善，受人中苦樂之境界也。七，阿修羅法界。修下品十善，得通力自在之非人境界也。八，鬼法界。犯下品五逆十惡，受飢渴苦之餓鬼境界也。九，畜生法界。犯中品五逆十惡，受吞噉殺戮諸苦之畜類境界也。十，地獄法界。犯上品五逆十惡，受寒熱叫喚諸苦之地獄境界也。諸者。眾也。有情者。梵語薩埵。能有愛生。有情識故。故曰有情。同者。共也。證者。以無漏正智。如實證得真理也。阿彌陀佛。亦稱無量光佛。無量光三昧。即念無量光佛之三昧也。《華嚴經·普賢行願品》曰。親覩如來無量光。現前授我菩提記。修此三昧。必生淨土。一般念佛三昧。觀像，觀想，持名，為因行之念佛三昧。謂之修。由修此三種因行所成。心入禪定。或佛身現前。或法身實相。為果地之念佛三昧。謂之發得。《無量壽經》曰。於現身中。得念佛三昧。行者但具深信切願。勤修般若正行。一心念佛。決於現生可以證得。三昧者。此云正受。正受所觀之法也。亦云定。息慮凝心。定於一處而不動也。新譯作三摩地。此云等持。離沈浮則定慧等。故名等。心不散則住一境。故曰持也。

    詮釋此經。大科分二。初，總釋名題。次，正釋經文。


第一節 釋名

    第一篇 總釋名題

    第一章 經題

    台宗智者大師。說《法華經》經題。約名，體，宗，用，相。開為五重玄義。簡覈易明。今故倣之。

    第一節 釋名

    名者。實之賓也。所以標舉全經。列示概要。本經題名八字。為《般若波羅蜜多心經》。
    般若波羅蜜多六字。係梵語。具足應云摩賀缽羅枳孃播囉蜜多。心經二字係漢文。梵漢並舉。故名《般若波羅蜜多心經》。上七字是別。別於諸經。以諸經名題不同故。下一字是通。以經之一字。通於諸經如來所說同名為經故。上七字是所詮之義。後一字是能詮之教。就別題中。復有二義。上六字是所題之法。後一字為能顯之喻。法喻復列。以定此名。
    【注】諸經立題。例有七種。以人名經者。更分為四。一，舉說人名者。如《淨名經》、《勝鬘經》。二，舉問人名者。如《彌勒問經》。三，舉所說人名者。如《薩和擅太子經》。四，舉所為人名者。如《玉耶經》、《須摩提女經。以法名經者。如《涅槃經》。或有就事如《枯樹經》。就處如《彼伽耶山頂經》。就時如《時非時經》。皆當入此類也。以喻名經者。如《梵網經》。法喻復列者。如本經及《妙法蓮華經》。人法復列者。如《勝天王般若經》。人喻復列者。如《如來獅子吼經》。人法喻具足者。如《大方廣佛華嚴經》。本經般若波羅蜜多為法。心為喻。故曰法喻複列也。

    本經攝《大般若經》六百卷中之要義。文約義豐。就大經言。般若波羅蜜多為通名。心經為本經之專名。
    依什師譯本。經題尚有摩訶二字。摩訶此云大。本經為《大般若波羅蜜多經》之心要也。義亦無礙。但奘師譯本無摩訶字。今從通名。
    般若為梵語。依巴利語。譯作般惹。所以譯音而不譯義者。以尊重故。依奘師五不繙之例也。此間語謂之智慧。照了一切諸法皆不可得。而能通達一切無礙。體性圓融。超情離見。智為實相無分別之智。慧即無分別智中妙慧。與世間智慧。從識心生。分別塵境。執取名言。發妄知見。為有漏根者不同。梵語智曰若那。慧曰般若。照見為智。解了為慧。決斷為智。簡擇為慧。知俗諦為智。照真諦為慧。徹明妙有為智。契悟真空為慧。雖有二義。分而不分。故以無分別智中妙慧釋之。
    【注】《大般若經》。即《大般若波羅蜜多經》之略稱。凡六百卷。唐三藏法師玄奘於玉華寺譯。
    巴利語為古時南天竺地方語。文法簡易而較通俗。或云即古時摩迦陀語。
    般若為達如之慧名。在因為般若。在果即菩提。《大般若經·三百二十九》曰。菩薩摩訶薩。遠離般若波羅蜜多。則為遠離一切智智。又三百五十一曰。布施等五波羅蜜多。皆由般若波羅蜜多所攝受故。乃得名為波羅蜜多。又四百三十四曰。布施等六波羅蜜多。互相攝持。能到彼岸。然住般若波羅蜜多。具大勢力。方便善巧。能速圓滿所修布施，淨戒，安忍，精進，靜慮波羅蜜多。非住前五能辦是事。是故般若波羅蜜多。於前五種為最為勝。為尊為高。為妙為微妙。為上為無上。無等無等等。由是因緣。獨讃般若超勝餘五波羅蜜多。又五百十曰。甚深般若波羅蜜多。是諸佛母。能示世間諸法實相。是故如來應正等覺依法而住（中略）。此法即是甚深般若波羅蜜多。一切如來應正等覺。無不依止甚深般若波羅蜜多。《道行般若經·二》曰。般若波羅蜜。於五波羅蜜最尊。譬如極大地。種散其中。同時俱出。般若波羅蜜是地。五波羅蜜是種。從其中生。薩芸若者。從般若波羅蜜成。《智度論·百》云。般若波羅蜜是諸佛母。諸佛以法為師。法者是般若波羅蜜。
    奘師五不繙之例。一，秘密不繙。如諸陀羅尼是。二，含義多不繙。如婆伽梵之含自在、熾盛、端嚴、名稱、吉祥、尊貴等六義是。三，此土所無不繙。如閻浮提是。四，順古不繙。如阿耨多羅三藐三菩提是。摩騰以來存梵音故。五，尊重不繙。如般若二字。可令聞者生信。譯作智慧。含義輕淺。易與世智相混是。譯梵成漢。向有四例。一，音字俱繙者。如諸經文。二，音字俱不繙。如西來梵夾。三，繙音不繙字。如佛胸（卍）字。以此方萬字之音翻之。而字仍梵書。四，繙字不繙音。如諸陀羅尼。以此方之字。存彼土之音。至奘師更定五不繙之例。
    準龍樹菩薩《大智度論》。般若分類。約舉有三。一，實相般若。二，觀照般若。三，文字般若。
    實相般若者。謂法身真空之體。元無名相。於無名相中。建立假名而談實相。故名實相。心源湛然。非寂非照。理性常住無相而無不相。即吾人虛靈不昧之本覺真心也。
    【注】《淨名經·天台疏》云。諸經異名。說真性實相。或言一實諦。或言自性清淨心。或言如來藏。或言如如。或言實際。或言實相般若。或言一乘。或言首楞嚴。或言法性。或言中道。或言畢竟空。或言正因佛性。性淨涅槃。如是等種種異名。皆是實相之異稱。《智度論》云。般若是一法。佛說種種名。隨諸眾生類。為之立名字。
    寂謂寂靜。照謂照明。寂照皆非者。用遮二邊。以顯中道實相之德也。離虛妄相名為實相。無一切虛妄相。故曰無相。具足恒沙功德之相。故曰無不相。蓋實相即中道真實之妙理。曰法性。曰真如。皆同體而異名。就萬法體性言之曰法性。就其體真實常住言之曰真如。就真實常住為萬法本體言之曰實相。《涅槃經》曰。無相之相。名為實相。《法華文句》云。言實相者。非虛故實。非相為相。故名實相。《金剛經》曰。是實相者。則是非相。是故如來說名實相。又曰。凡所有相。皆是虛妄。若見諸相非相即見如來。見諸相非相是照見蘊空義即見如來。是實相義。
    本覺真心。即眾生本來心體之自性清淨心。離一切妄相。本來覺了。虛靈不昧之本性也（眾生迷之。故須修持）。《仁王經》曰。自性清淨名本覺性。

    觀照般若者。乃實相體所起之用。即心體上本具之智慧光明。以般若之實智。成能觀之妙慧。非照而照。了法無相。法性幽玄。非此莫鑑。照見五蘊諸法。是照俗諦。照見諸法皆空。是照真諦。依實相般若之體。起觀照般若之用。由觀照般若之用。契實相般若之體。蓋實相如明鏡。煩惱如塵垢。觀照如磨治。般若妙智。有如鏡光。眾生皆具實相。即皆有智慧光明。塵勞所蔽。如鏡蒙垢。但能用功觀照。靜極光通。自可契入真空妙理。是曰觀照般若。
    【注】非照而照者。謂理本非照。因觀而照。以顯觀照之實智也。

    文字般若者。詮釋般若之言教也。文字是能詮之文。般若是所詮之法。般若之用。無所不賅。隨緣不變。不變隨緣。橫徧十方。豎窮三際。凡足以示教利喜。斷疑生信者。實相所顯。觀照所得。皆可謂之文字。文字性空。性空之體即是般若。《楞嚴經》曰。妙性圓明。離諸名相。《大般若經》曰。總持無文字。文字顯總持。由般若大悲。離言以言說。誠以實相觀照。雖藉文字以顯。文字非般若之體。而般若藉文字以傳。亦如此土恒言。所謂文以載道也。蓋般若實相。眾生本具。但為無明所障。不得顯現。欲顯實相。必須言語道斷。心行處滅。自證自得。本不藉於文字。惟眾生蒙昧已久。不假方便。障無由開。道本無言。而道因言顯。故仍藉文字啟導。使得悟入。因文字而起觀照。由觀照而證實相。實相是體。觀照是用。以文字之方便善巧。分別諸法。因文見道。是曰文字般若。亦曰方便般若。
    【注】言教者。如來以言語垂示之教法也。《法華經·方便品》曰。種種譬喻。廣演言教。《大般若經·五百九十三》曰。一切法不離名言。若解諸法。若知諸法。俱不可說。然順有情所知而說。故名般若。
    真如之體。從本以來。畢竟平等。無有變易。不可破壞。體恒寂靜。無一異相。名不變真如。真如之性。本無生滅。然因無明熏動。起一切相。如水因風而生波。風止波平。元無動相。名隨緣真如。真如之本體不變。觸所緣而生起萬有。曰不變隨緣。雖觸緣而現萬有。其體仍真常不變。曰隨緣不變。
    亙於時間者曰豎。空間者曰橫。徧。普也。窮。極也。十方。東，西，南，北，東南，西南，東北，西北，上，下也。三際。猶云三世。過去，現在，未來三世也。示教利喜者。示謂示人之好醜。善不善。應行不應行。如生死為醜。涅槃為好。分別三乘。分別六波羅蜜等。教謂教以捨惡行善。利謂說法誘引。導之以利。喜謂隨其所行讚歎。令生歡喜。諸佛菩薩以莊嚴此四事說法。見《智度論》。
    蕅益大師曰。吾人現前一念介爾之心。虛明洞徹。了了常知。不在內外中間諸處。亦無過現未來形跡。即是觀照般若。吾人現前一念介爾之心。炳現根身器界。乃至十界假實國土。平等印持。不前不後。同時頓具。即是文字般若。蓋山河大地。明暗色空。一切境界。無非文字。不但紙墨語言也。吾人現前一念介爾之心。所有知覺之性。與境界之性。無分別。無能所。無是非。統惟一法界體。即是實相般若。
    言語道斷。心行處滅。即言忘慮絕之意。《大般若經·五百七十一》曰。性離文言。心行處滅。是名為法。一切法性皆不可說。其不可說，亦不可說。若有所說。即是虛妄。虛妄法中。都無實法。《三論玄義》云。諸法實相。言忘慮絕。心即心念。剎那遷流。故曰心行。究竟之真理。不可言說。故曰言語道斷。不可思念。故曰心行處滅。《仁王經》曰心行處滅。言語道斷。同真際。等法性。《止觀》云。言語道斷。心行處滅。名不可思議境。

    般若雖三。原同一相。無相之相。即是大覺圓常真空之體。一念正觀圓修。照了諸法皆空。是為圓證。
    窺基、圓測諸大師。依據《瑜伽》、《攝大乘》諸論。於上述三般若外。更說境界般若。眷屬般若二種。
    境界般若者。謂一切諸法為般若之所緣。即般若真智照了一切諸法皆不可得。通達無礙。皆以一切諸法為境界。境無自相。由智顯發。以根本智、後得智照了一切諸法境界。悉本空寂。從境得名。故名境界般若。
    【注】根本智。即如理智。亦名無分別智。菩薩親證本有之智。不依於心。不緣外證。了一切法皆是真如。無能緣所緣之別。冥符真理。一念之真智也。
    後得智為菩薩證根本智後所得行滿化他之智。菩薩起行度生。依心緣境。種種分別。據《攝大乘論·五》釋後得智凡五。一，通達。謂菩薩由後得智。能觀心中所知所見。一切境界。皆悉無礙。二，隨念。亦名憶持。謂菩薩由後得智。於前觀心中通達諸法境界之相。出觀之後。隨念憶持不失。三，安立。亦名成立。謂菩薩由後得智。於所通達諸法境界。能立正教。令他修行。四，和合。亦名相雜。謂菩薩由後得智。於先所緣一切諸法和合相雜境界。而能觀察照了。轉煩惱依菩提。五，如意。謂菩薩由後得智。既得轉煩惱依菩提。一切所欲。皆悉隨意。對如理智而言。後得智亦名如量智。

    眷屬般若者。謂煖、頂、忍、世第一，及戒、定、慧、解脫、解脫知見諸法。皆是觀照慧性之屬。故名眷屬般若。
    【注】煖、頂、忍、世第一，四者為加行位。戒即戒律，定即禪定，慧即智慧，解脫即自在，解脫知見謂智眼照了諸法皆空，無有障礙，而得自在也。此五功德法。謂之五分法身。由戒而生慧。由慧而生定。由定而得解脫。由解脫而有解脫知見。前三從因得名。後二就果受號。

    綜而論之。般若實為眾德之首。萬行之導。一切波羅蜜中。唯此最勝。實相。理也。觀照。慧也。文字。教也。境界。諸法也。眷屬。萬行也。諸法萬行。亦可攝於文字觀照之中。故廣之為五。約之為三。
    【注】般若有二種相。一，世間般若。謂諸菩薩惟依讀誦、書寫、演說三乘，勸化修行，滅除煩惱。如是般若，有見有相，是名世間般若。二，出世間般若。諸菩薩精勤修習。心如虛空。平等寂滅。離諸名相。如是般若。無取無著。是名出世間般若。
    諸師釋般若分境、行、果三義。境者。一切智，道相智，一切相智。所攝一切能詮之名言。與所詮之法相皆是。行有深廣二義。深即本經所示觀行之深般若。廣則六度（布施、持戒、精進、忍辱、靜虛、般若）四攝（布施、愛語、利行、同事）。果即由此甚深般若顯示妙義，引生六度萬行種種廣行所得之果（證三身四智之般若果。諸佛圓證。三乘各得一分）。又分體、相、用三義。體有真體俗體。俗體即俗智。真體分二。一者。親證般若。言忘慮絕。百非俱遣。此惟佛能究盡。二者。疏緣般若。般若本空。無可言說。但眾生沈迷生死。欲為拔度。必賴言詮。故以無量言說。談此勝義。以非親證。故為疏緣般若。相者。即一切法相。自初發心以至金剛道。斷煩惱執。因果宛然。義理和合。般若相現。用者。四諦，十二因緣，六度，萬行，一切諸還滅法皆是。二義參勘。般若之境，其體也。般若之行，其相也。般若之果，其用也。又有以二智釋般若者。一，真智般若。即實相般若。根本智也。二，俗智般若。即緣一切五明（一，聲明。明了一切聲教也。二，因明。明了萬法生起之因也。三，醫方明。明了一切病因通達對治之法也。四，工巧明。明了一切工業文化之巧妙也。五，內明。明了佛法內教一切對治之法也）而得之後得智也。以三慧釋者。一，聞慧般若。二，思慧般若。三，修慧般若。

    波羅蜜多亦梵語。舊譯作波羅蜜。依巴利語無尾音故。波羅此云彼岸。蜜多此云到。印度文法。名先動後。故順此土文字。當作到彼岸。《大智度論》譯作事究竟。《瑞應經》譯作度無極。《大乘義章》譯作度。義並可通。又以與梵語阿羅蜜語音相近。阿羅蜜此云遠離。故亦有以遠離釋波羅蜜者。慈恩所謂由行般若離諸障染也。要以到彼岸為最契合。
    【注】唐後以羅什法師所譯為舊譯。玄奘法師所譯為新譯。《華嚴經疏》云。譯經二派。會意譯經。秦朝羅什為最。敵對繙譯大唐三藏稱能敵對者。唐梵對字。三藏。即玄奘也。

    彼岸者，對此岸之稱。生死為此岸。煩惱為中流。涅槃為彼岸。即菩提，涅槃，二勝果也。行深般若者。照見五蘊皆空。無明盡滅。見煩惱即實相。生死即涅槃。超二死海。至三德岸。名到彼岸。迷者妄執身心為有。遂失慧光。不了諸法實相。沈淪生死。名住此岸。《華嚴經》曰。我觀一切眾生。俱有如來智慧德相。但以妄相執著而不證得。故纖情未盡。便隔彼岸。凡聖情忘。即到彼岸。《智度論》云。有無二見。皆屬此岸。二執俱空。始達彼岸。蓋岸屬假名。本無彼此。此岸彼岸，僅同設喻。為使人易解。姑以迷為此岸。覺為彼岸。迷覺之別。只在一心。《大般若經》曰。若菩薩摩訶薩。行深般若波羅蜜多時。不得彼岸。不得此岸。不得中流。是為菩薩摩訶薩甚深般若波羅蜜多。又曰。甚深般若波羅蜜多。非般若波羅蜜多。非非般若波羅蜜多。非此岸。非彼岸。非中流。非陸。非水。非高。非下。非平等。非不平等。非有相。非無相。非世間。非出世間。非有漏。非無漏。非有為。非無為。非善。非非善。非有記。非無記。非過去。非未來。非現在。《心經請益說》云。波羅蜜多。此翻彼岸到。所云到者。但照見此岸本空。此岸即是彼岸。非別有彼岸可到也。
    【注】二死者。一，分段生死。分即分限。段即形段。謂六道眾生。隨其業力所感果報。身有短長。命有壽夭。而流轉於生死也。二，變易生死。因移果易。名為變易。謂聲聞、緣覺、菩薩。雖離三界內分段生死，而有方便等土變易生死。初位為因。後位為果。後位為因。後後位為果。以其因移果易。故名變易生死。超二死海者。即超越分段變易二死之此岸也。
    慧光。智慧之光也。《無量壽經》曰。慧光明淨。超踰日月。
    諸法實相者。諸法即十界因果之法。實相者。實非虛妄。相即無相。離本來虛妄之相。即萬有本體之稱。法性、真如、實際、一相、無相、法身、涅槃，皆諸法實相異名。《智度論·三十二》云，如、法性、實際，是三皆是諸法實相異名。又七十九云。諸法實相。有種種名字。或說空。或說畢竟空。或說般若波羅蜜。或名阿耨多羅三藐三菩提。《思益經·二》曰。諸法實相。即是涅槃。諸宗又各以其義解之，如淨土宗以彌陀名號為諸法實相。華嚴宗以一真法界為諸法實相。唯識宗以圓成實性為諸法實相。天台宗以中道第一義諦為諸法實相。三論宗以八不中道為諸法實相。成實宗以皆空為諸法實相。是也。《阿彌陀經要解便蒙鈔》云。大乘經以實相為印。為經正體。《觀經智者疏妙宗鈔》云。諸法當處不生不滅。非有非空。無能無所。離言說相。離名字相。離心緣相。離此等相。名為實相。無相之相也。
    《心經請益說》云。依共般若。聲聞以苦集二諦為此岸。道諦為舟航。滅諦為彼岸。緣覺以十二因緣、三世流轉、循環無盡為此岸。觀智為舟航。緣生心空，即寂滅相，為彼岸。權乘菩薩以六蔽（一，慳貪。二，破戒。三，瞋恚。四，懈怠。五，散亂。六，愚癡）為此岸。六度為舟航。佛果為彼岸。若依不共般若。總以凡夫蘊、處、界，及三乘聖賢所修所證為此岸。以觀照般若為舟航。實相真空為彼岸。此經智慧到彼岸。即不共般若。
    《心經幽贊》云。波羅者彼岸義。古說有二。謂菩提、涅槃。今釋有五。一，所知。二，教。三，理。四，行。五，果。蜜多者。離義。到義。由行般若離諸障染。

    《心經幽贊》云。修波羅蜜多。約行相言。總具七種最勝。一，安住菩薩種性。謂志在大乘，不以定性二乘、不定性及無種性自卑也。二，依大菩提心。謂以佛心為心而不局於九界也。三，悲愍有情。謂凡有血氣，皆當憫其生死苦痛，不容漠視也。四，具行事業。謂施、戒、忍、進，一切善業，躬行實踐也。五，無相智攝。謂雖諸惡莫作，眾善奉行，而不著一相也。六，迴向菩提。謂一切功德，悉作佛力加被，莊嚴淨土，不自求報也。七，不為二障間雜。凡夫以煩惱障而間斷。二乘以所知障而夾雜。皆非大乘之器也。若行慧等一切善業。隨闕此一。非到彼岸。
    【注】行相者。相謂相狀。行境之相狀。名為行相。《俱舍光記·四》云。有所行境界相。故名行相。
    菩薩種性。為唯識宗所立五性之一。第一。定性聲聞。第二。定性緣覺。第三。定性菩薩。即菩薩種性也。第四。不定性。更分四。一，菩薩聲聞不定。二，菩薩緣覺不定。三，聲聞緣覺不定。四，聲聞緣覺菩薩不定。第五。無性。無三乘無漏種子者。
    大菩提心者。求大菩提之心也。菩提舊譯為道。道者通義。新譯為覺。覺者覺悟。有事理二法。理者涅槃。斷煩惱障而證涅槃之一切智是。通三乘之菩提也。事者一切有為之諸法。斷所知障而知諸法之一切相智。是佛之菩提也。佛之菩提。通於二者。故謂之大菩提。
    九界者。即十界中除佛法界而言。
    無相智者。證知中道之理。離二邊相之智慧也。《大乘義章·二》云。言無相者。釋有兩義。一，就理彰名。理絕眾相，故名無相。二，就涅槃法相釋。涅槃之法離十相（色相、聲相、香相、味相、觸相、生相、住相、壞相、男相、女相），故曰無相。
    迴向者。迴者。迴轉。向者。趣向。迴轉自己所修之功德。而趣向於所期。謂之迴向。迴向菩提者。迴轉己之功德。而趣求菩提也。《大乘義章·九》云。囘向不同。一門說三。一，菩提囘向。二，眾生囘向。三，實際囘向。
    梵語波羅。此云凡夫。世間常人也。新譯作異生。《大威德陀羅尼經》曰。於生死迷惑流轉。住不正道。故名凡夫。
    二乘。即聲聞乘與辟支佛乘。佛教有大乘、中乘、小乘之三乘。一者。聲聞乘。即小乘。有五種。一，決定聲聞。久留小乘，今世道熟，聞小乘而證果也。二，上慢聲聞。於小法未得謂得，未證謂證，即凡夫也。三，退大聲聞。菩薩於修行中疲厭生死，退大樂小，值佛出世，聞小法而證果也。四，應化聲聞。菩薩內祕外現，示聲聞之相也。五，佛道聲聞。以佛道之聲，使一切聞，一切眾生悉歸涅槃也。見《法華文句》。此等聲聞，速則三生，遲則六十劫間修空法。終於現世聞佛聲教，悟四諦理而證果也。一，須陀洹果。須陀洹，此云入流，即初果。謂斷三界見惑盡，預入聖流也。二，斯陀含果。斯陀含，此云一來。謂九品思惑中已斷前六品，因後三品思惑未盡，尚當於欲界人天受生一度也。三，阿那含果。阿那含，此云不還。謂已斷欲界後三品思惑，不再還欲界受生也。四，阿羅漢果。阿羅漢，此云無學。謂斷色無色界思惑已盡，四智已圓，超出三界，不受後有也。二者。辟支佛乘。辟支此云因緣覺。故亦曰緣覺乘。在三乘中為中乘。速則四生，遲則百劫間修空法。於其最後之生，感飛花落葉之外緣，悟十二因緣法，無師友教，自然獨悟。梵語具足當云缽刺翳迦佛陀舊譯緣覺。新譯獨覺。《華嚴會義》云。梵語畢靳支底迦。此云各各獨行。缽羅底迦。此云緣覺。辟支迦羅。名通二種。《智度論》二名俱存。謂初發心時值佛，思唯世間之法，後得道身。出無佛世，性好寂靜，加行滿而無師友之教，自然獨悟，故名獨覺。又觀待內外緣而悟聖果，故名緣覺。台宗則別之為二。無佛世之悟道者為獨覺。於佛世觀十二因緣得道者為緣覺。《智度論》云。先世種辟支佛道因緣，今世得少因緣出家，亦觀深因緣法成道，名辟支佛。三者。菩薩乘。菩薩具云菩提薩埵。此云覺有情。是為大乘。於無數劫間，修六度（布施、持戒、精進、忍辱、靜慮、般若）萬行（萬是此方大數。表其最多。行是修德都名。約之不出二種。一，慧行。二，行行。般若波羅蜜多名慧行。五波羅蜜多名行行。慧行名正行。行行名助行。助行有顯有密。清淨律儀為顯行。壇儀心咒為密行。又涅槃經明五種行。一，聖行。二，梵行。三，天行。四，嬰兒行。五，病行。聖行，天行為上求佛道之行。梵行、嬰兒行、病行，為下化眾生之行。是名次第五行。又有一心五行。則一行一切行。一切行一行。所謂一心圓五行也），植三十二福相因，以證無上菩提。
    二障者。一，煩惱障。由我執而生見思二惑。起種種昏煩之法。惱亂心神。以致障礙無漏法性。二，所知障。又名智障。由法執而生。因根本無明之惑。覆蔽法性。不能了知諸法實相。以致障礙菩提妙智。有煩惱障。則生死相續。無由脫離。故障涅槃。有所知障。則無明妄染。礙正知見。不達真如。故障菩提。煩惱。事障也。所知。理障也。事是煩惱。煩惱即障也。理是所知。所知非障。被障障所知也。此二障各有俱生、分別二種。俱生者。無始以來虛妄熏習之因力。恒與身俱。不俟外緣自然轉起之煩惱也。分別者。兼藉現世種種外緣。分別計度。然後方起之煩惱也。詳後注。

    菩薩從因位修習波羅蜜多。須經三階段。第一阿僧祇劫。自三賢四加行以至初地。修習各波羅蜜多。道力尚微。被煩惱伏。由斯煩惱不覺現行。名遠波羅蜜多。第二阿僧祇劫。自二地以至七地。修習各波羅蜜多。道力漸增。能伏煩惱。由斯煩惱故意方行。名近波羅蜜多。第三阿僧祇劫。自八地以至十地等覺。修習各波羅蜜多。道力全盛。畢竟能伏一切煩惱。由斯煩惱永不現行。名大波羅蜜多。
    【注】因位者。修行佛果之位次。自初發心以至等覺。皆在因地。成佛以後。方為果地。
    煩惱，亦名蓋。覆蓋善心。使不開發也。亦名漏。令人漏落於三惡道也。亦名惑。迷妄之心。迷於對境。顛倒真理也。諸經中開合不同。分類亦異。略舉如次。
    二煩惱。一，根本煩惱。貪、瞋、癡、慢、懷疑、惡見六大煩惱，為一切煩惱之本，故名根本煩惱。二，隨煩惱。忿、恨、惱、覆、誑、諂、憍、害、嫉、慳之十，為小隨煩惱。無慚、無愧之二，為中隨煩惱。不信、懈怠、放逸、惛沈、掉舉、失念、不正知、散亂之八，為大隨煩惱。又《華嚴經疏》。以無明種子潛伏藏識之中能生一切妄惑者，為隨眠煩惱。根塵相對，現起煩惱，為現行煩惱。
    三煩惱。一，見思煩惱。二，塵沙煩惱。三，無明煩惱。
    四煩惱。一，我癡。二，我見。三，我慢。四，我愛。
    六煩惱。一，貪煩惱。染著為性。生苦為業。二，瞋煩惱。憎恚為性。不安與惡行之所依為業。三，癡煩惱。迷闇為性。諸惑之所依為業。四，慢煩惱。恃己高舉為性。生苦為業。五，疑煩惱。猶豫為性。障信心為業。六，惡見煩惱。顛倒推求之惡慧為性。能障善見而生苦為業。
    十煩惱。上六煩惱中。第六惡見。又可開為五種。一，身見。固執實我。二，邊見。偏執我之斷常。三，邪見。撥無因果之理。四，見取見。固執諸見。及所依蘊為最勝。為一切鬥諍之本。五，戒禁取見。固執非理之戒禁。故合之則為六煩惱。開之則為十煩惱。
    百八煩惱。眼耳鼻舌身意六根。對色聲香味觸法六塵。各有好、惡、平，三種不同。則成十八煩惱。六根對六塵好、惡、平三種。各有苦受、樂受、不苦不樂受。復成十八煩惱。共成三十六種。積過去、現在、未來三世。總成百八煩惱。

    《大般若經》曰。般若波羅蜜多。即是如來、應、正等覺。如來、應、正等覺。即是般若波羅蜜多。又曰。甚深般若波羅蜜多。能生諸佛一切功德。能示世間諸法實相。又曰。如是般若波羅蜜多。能與一切善法為母。一切聲聞、獨覺、菩薩、如來、善法從此生故。如是般若波羅蜜多。普能攝受一切善法。一切聲聞、獨覺、菩薩、如來、善法依此住故。又曰。修行般若波羅蜜多。不住此岸。不住彼岸。不住中流。是謂菩薩摩訶薩行般若波羅蜜多。蓋般若波羅蜜多。總攝六度萬行。故為最勝。《智度論》云。般若波羅蜜多是諸佛母。父母之中。母功為重。是故佛以般若為母。般若波羅蜜能徧觀諸法分別實相。無事不達。無事不成。功德大故。名之為母。以是故。行者雖行六波羅蜜及種種功德。和合能具眾願。而但說當學般若波羅蜜。又云。菩薩行般若波羅蜜時。普觀諸法皆空。空亦復空。滅諸觀得無礙。般若波羅蜜。以大悲方便力。還起諸功德業。無願不得。其餘功德。離般若波羅蜜。無有無礙智慧。
    《華嚴經》於般若波羅蜜多。更開方便、願、力、智四波羅蜜多。合之六度。共成十波羅蜜多。而以般若為十度之綱領。《大般若經》曰。如是般若波羅蜜多。能與一切善法為母。一切聲聞獨覺菩薩如來善法。從此生故。如是般若波羅蜜多。並能攝受一切善法。一切聲聞獨覺菩薩如來善法。依此住故。《小品般若》曰。若過去諸佛阿耨多羅三藐三菩提。皆從般若波羅蜜生。未來諸佛阿耨多羅三藐三菩提。亦從般若波羅蜜生。現在無量阿僧祇世界諸佛阿耨多羅三藐三菩提，亦從般若波羅蜜生。
    【注】如來。應。正等覺。皆佛號也。《往生論註》曰。諸佛如來德有無量。德號亦無量。若欲具談。筆紙所不能載。是以諸經或舉十名。或騰三號。蓋存至宗而已。非以此為盡也。所謂三號。即如來。應。正等覺也。如來。梵語多陀阿伽陀。亦作怛他揭多夜。具云怛闥阿竭怛他蘖多夜。此云如來。亦云如去。《大疏》云。怛他是如義。揭多是來義。知解義。說義。去義。諸佛乘如實道。來成正覺。今佛亦如是來。故名如來。諸佛如法實相知解。知已為眾生說。今佛亦如是。故名如是知者。如是說者。《廣博嚴淨經》曰。能知過去如，亦知未來如。見一切法如是。故名如來。諸佛得如是安樂性。直至涅槃中。今佛亦如是去。故名如去。具含四義。而獨稱如來者。順古譯也。如者，真如。真如之道。從因來果而成正覺（道是因。覺是果。境智契合而未窮滿之位為因。已窮滿之位為果）。體離虛妄。故云如實。體如而來。故曰如來。如來有三身。理法聚名法身。聚集法性之法而成。梵語毘盧遮那。此云徧一切處。性相常然。身土無礙。《金剛經》曰。無所從來。亦無所去。故名如來是也。智法聚名報身。智與法性相合而成。內以智光照真法界。理智如如。修因感報。梵語盧舍那。此云淨滿。諸惑淨盡。眾德悉圓。《轉法輪經》曰。第一義諦名如。正覺名來是也。功德法聚名應身。智與體冥。起用化他。隨機應現。說法利生。梵語釋迦牟尼。釋迦。此云能仁。佛之姓也。牟尼。此云寂默。佛之名也。能仁故不住涅槃。寂默故不住生死。《成實論》曰。乘如實道（乘者。如如之智。如實者。如如之境）。來成正覺是也。有來有去。皆此應身。法身常住不動。無所謂來去。徧一切處。亦無須乎來去。所謂不取於相。如如不動也。應。即應供。梵語阿羅訶。謂智德圓滿。福慧具足。堪受人天供養也（梵語三名相通。一，阿羅訶。此云應供。二，阿羅漢。此云無生。亦云無著。三，阿盧訶。此云殺賊。故阿羅訶為五住究盡之號。與聲聞四果之阿羅漢不同。《準增一阿含經》。有三應供養。一，如來。出現世間。利樂一切眾生。於天人中最尊最上。不降伏者而降伏之。無救護者而救護之。未度脫者而度脫之。以是因緣。一切天人所應供養。二，阿羅漢。生死已盡。梵行已立。利益有情。為世福田。以是因緣。一切天人所應供養。三，轉輪聖王。以正法治天下。使人民不殺不盜。各得其所。以是因緣。一切人民所應供養）。正等覺。梵語三藐三菩提。以一切法平等開覺眾生。成無上覺。亦譯正徧知。謂具一切智於一切法無不了知也。此三號以外。尚有七名。即明行足（《大般若經》作明行圓滿）。梵語鞞侈遮羅那三般那。明者。宿命、漏盡、天眼之三明。行者。身口意諸行三業清淨。足者。滿足也。善逝。即妙往之義。梵語修伽陀。謂以無量智慧。能斷諸惑而入涅槃。妙出世間以成佛果也。世間解。梵語路伽憊。能解世出世間一切諸法也。無上士（《大般若經》作無上丈夫）。梵語阿耨多羅。謂業縛淨盡。於三界中第一。最上無等也。調禦丈夫（《大般若經》作調禦士）。梵語富樓沙曇藐婆羅提。謂具大丈夫力用。以種種方便。調伏制御一切眾生。令離垢染得涅槃也。天人師。梵語舍多提婆魔［少／兔］沙喃。謂三界眾生之師表也。佛。梵語具云佛陀。此云覺。謂具一切種智。自覺覺他覺行圓滿也。《廣博嚴淨經》曰。覺無明無知。其性無所有。已得於明智。是故名為佛。以上十名。《大般若經》。《瑜伽師地論》。合無上丈夫、調御士為一。連薄伽梵為十號。《成實論》合無上士、調禦丈夫為一。《佛說十號經》。合世間解、無上士為一。而另加世尊之稱為十號。《智度論》以世尊為十號外別一尊號。世尊。梵語路迦那他。謂萬德圓滿世所尊重也。《廣博嚴淨經》曰。不畏於生死。正住生死中。化度諸眾生。是故名世尊。薄伽梵。為總眾德至上之稱。《佛地論》云。自在、熾盛、與端嚴，名稱、吉祥、及尊貴，如是六德義圓滿。蓋如來永不屬諸煩惱繫縛，故云自在。智火猛燄，洞達無際，故云熾盛。三十二相，莊嚴妙好，故云端嚴。圓滿一切殊勝功德，十方世界，無不聞知，故云名稱。一切世間，讚歎供養，皆獲吉慶，故云吉祥。從兜率天，降生王宮，出家修道，位登妙覺，故云尊貴。以一名而具六義也。
    無礙者。涉入自在義。無礙智者。佛智之通達自在也。
    六度者。第一。檀那波羅蜜。檀那此云布施。運心普周曰布。輟己惠人名施。菩薩為令眾生心滿足故。內外悉捨而無所著。是名檀那波羅蜜。此度三行。一，財施。以己財物。施與他人。令其安樂。二，法施。以佛法為眾生演說。令其開悟。三，無畏施。慈心不殺。令無怖懼。第二。尸羅波羅蜜。尸羅有清涼義。此云戒。謂離熱鬧得清涼。亦云防止。謂調練身口意三業。止過防非。好行善道。不自放逸也。《戒經》云。菩薩具持眾戒而無所著。是名尸羅波羅蜜。此度三行。一，攝律儀戒。謂持佛戒律。具眾威儀。二，攝善法戒。謂身口意，所作善法。皆悉攝持。三，饒益有情戒。以無緣慈濟度眾生。拔苦與樂。平等利益。第三。羼提波羅蜜。羼提此云忍辱。他人加惱為辱。於辱安受曰忍。謂內心能安然忍受外辱。菩薩忍受一切諸惡。於諸眾生其心平等。無有搖動。是名羼提波羅蜜。此度三行。一，耐怨害忍。謂若遇怨憎毒害。安然忍耐。無返報心。二，安受苦忍。謂若遇水火刀杖。貧病寒熱。眾苦所逼。恬然忍受。三，諦察法忍。謂諦審諸法。體性虛幻。本無生滅。安然忍可。第四。毗梨耶波羅蜜。毗梨耶此云精進。精礪身心。進修善法。菩薩普發眾業。常修靡懈。諸有所作。恒不退轉。是名毗梨耶波羅蜜。此度三行。一，被甲精進。謂起大誓願。修諸勝行。二，攝善精進。謂修方便行。進趨無上菩提。三，利樂精進。謂勤化眾生。咸修正道。第五。禪那波羅蜜。禪那此云靜慮。亦曰定。亦曰三昧。亦曰智生。謂念慮皆忘。安心理境。思惟真理，定止散亂。依定而生智也。菩薩於色聲香味觸五欲境。無所貪著。初禪、二禪、三禪、四禪，諸次第定。悉能成就。是名禪那波羅蜜。此度三行。一，安住靜慮。謂亂想不起。深入禪定。遠離一切惛掉愛相。得輕安寂靜法樂。現法樂住。二，引發靜慮。謂智慧現前。生諸功德。引發六種神通。三，辦事靜慮。謂功行圓滿。利益眾生。第六。般若波羅蜜。般若此云智慧。決定審理為智。造心分別為慧。照了諸法。斷惑證真。菩薩於諸佛所。善觀諸法。得實相印。普入一切智門。是名般若波羅蜜。此度三行。一，生空無分別慧。謂平等照了俗諦諸法。無生滅相。二，法空無分別慧。謂平等照了真諦諸法。體相皆空。三，俱空無分別慧。謂等觀真俗二諦。並空亦空。《華嚴經》於六度以外。更從般若波羅蜜中。開出四波羅蜜。即第七。漚和俱舍羅波羅蜜。漚和俱舍羅。此云善巧方便。隨機利物。稱適緣宜也。菩薩運平等大慈之心。教化眾生。不生厭倦。是名漚和俱舍羅波羅蜜。此度三行。一，進趣果向方便。以前六度所集善根。共諸有情迴向無上菩提。二，巧會有無方便。謂善巧融會真俗二諦。三，拔濟方便。以大悲心拔濟眾生。了達能所皆空。第八。尼坻波羅蜜。尼坻。此云願。願即誓願。上求佛道。下化眾生。盡未來際。成就行願也。菩薩成就一切眾生。供養一切諸佛。盡未來劫。證如來智。是名尼坻波羅蜜。此度三行。一，求菩提願。願於當來速證菩提。二，利樂他願。救度一切眾生。三，外化願。外化有情。亦起自利利他之願。第九。末羅波羅蜜。末羅此云力。謂行滿功成。萬境無動。善辦眾事也。菩薩具深心力。無有雜染。乃至具加持力。令信解領受。是名末羅波羅蜜。此度三行。一，思擇力。謂思惟揀擇一切善法。二，修習力。謂修行數習殊勝妙行。三，變化力。謂神通力用。化度眾生。第十。闍那波羅蜜。闍那亦作若那。此云智。謂決斷無惑。證法怡神。善入佛慧。明了無礙也。菩薩知一切法真實。知一切如來力。普覺悟法界門。是名闍那波羅蜜。此度三行。一，無相智。謂觀達一切諸法。自性本空。二，受用法樂智。謂修行證得一切相智。恒自受用。得大自在。三，成就有情智。謂教化饒益一切眾生。成就道果。《大般若經·三百五十一》曰。若無般若波羅蜜多。布施等五。不得名為波羅蜜多。要因般若波羅蜜多。布施等五。乃得名為波羅蜜多。由此前五波羅蜜多。攝在般若波羅蜜多故。但有一波羅蜜多。是故一切波羅蜜多無差別相。又曰。甚深般若波羅蜜多。了達一切都無所有。能拔有情世俗作用。生老病死。由此故說甚深般若波羅蜜多。於布施等波羅蜜多。為最。為勝。為長。為尊。為妙。為微妙。為上。為無上。
  《成唯識論述記·九》云。六種波羅蜜多。通相。皆二。與智俱行。並名為智。與福俱行。並名為福。別相。前五說為福德。第六智慧。前五是福。非智性故。第六智慧。非福性故。正智自體故。或復前三惟福德攝。後一唯智。餘通二種。前三唯福。遠智慧故。第六唯智。性是慧故。餘通二種。即精進、定。鄰近於慧。亦起慧故。若依精進修布施、持戒、四無量等，名福。修三慧（聞思修）、六善巧（菩薩六種善巧方便。一，隨順巧方便。於彼深經如來旨趣。隨順其義。分別解說。而攝取之。二，立要巧方便。眾生求索。菩薩為立要言。令其疾修善法。遠離諸惡也。三，異相巧方便。教供養父母受持禁戒等。如不順時。乖異瞋責。為度彼故。使他畏懼也。四，逼迫巧方便。如有犯戒等事。斷絕供給。或加謫罰。使勤修善法。遠離惡法也。五，報恩巧方便。施與眾生財物。令知恩報德而行善也。六，清淨巧方便。自兜率天降生。出家學道。成無上菩提。使眾生捨離憍。慢。堅固信樂。同成佛道。詳見《菩薩地持經·六》）、觀四諦（苦集滅道）、緣生（十二因緣）法等，名智分。若依靜慮修四無量等，名福。修六善巧等，名智分。
    善法者。順理之法也。五戒十善為世間善法。三學（戒定慧）六度（布施，淨戒，安忍，靜慮，精進，般若）為出世間善法。攝受，亦作攝取。佛以慈心攝取眾生也。
    住為心不相應行法之一。使法住之實法也。

    心者。所引之喻。喻此經攝大部般若六百卷之精要。譬如人身心臟。為百體之要。大經隨機。義文俱溥。此經抉其秘要。故標心稱。喻此經總六百卷般若之精要也。法月譯本。菩薩白佛言。世尊。我欲於此會中說諸菩薩普徧智藏般若波羅蜜多心。《連珠記》引不空所譯亦同。奘師在益州空惠寺遇病僧所授者。亦以此為三世諸佛心要法門。曰般若波羅蜜多心。曰諸佛心要。皆指積聚精要心而言。非色非心。但為一喻。亦有以此心字作真心解者。然六百般若。皆談真心。非獨此經。故本詮不取。《幽贊》云。雖此心經。亦名般若。彼總此別。故但名心。
    【注】心有多名。一，肉團心。梵語紇利陀耶。亦名處中心。處於動物中心。即生理上人體之心臟。形如蓮花含苞未敷之狀。二，堅實心。梵語乾栗陀耶。亦名自性清淨心。第一義心。真如心。即吾人天賦之妙真如性。至誠無妄之真心也。三，草木心。梵語汙栗陀。草木之中心也。四，積聚精要心。梵語矣栗陀。積聚諸經精要。如本經積聚大般若經六百卷之菁華。集中要旨。亦名為心。五，思量心。梵語末那。此云意。分別思量相續執取之心。六，集起心。梵語阿賴耶。集諸種子生起現行。即第八識。七，緣慮心。梵語質多耶（亦名慮知心。了別心。緣影心）。攀緣對境而為見聞覺知之妄心也。就緣慮心說。可通八識。眼緣色。耳緣聲。鼻緣香。舌緣味。身緣觸。意緣法。末那緣思量。阿賴耶緣根身種子器世間。故八識總可心心。從集起說。能集種子起現行。惟八識專有。故惟第八識。始可名心。《入楞伽經》曰。藏識總名心。思量性名意。能了諸境相。是故名為識。《俱舍論》云。集起故名心。思量故名意。了別故名識。皆以第八識為心。末那識為意。前六識為識也。

    經為通名。梵語修多羅。舊譯作契經。一者契理。謂上契諸佛之理。為合道之言。二者契機。謂下契眾生之機。為逗根之教。今譯略契字。但名為經。經復多義。《佛地論》云。經者。貫攝為義。貫穿教義。攝持眾生。如綖貫花。如經持緯。《雜阿毘曇心論》則列五義。一者。出生。出生諸法故。二者。顯示。顯示教理故。三者。湧泉。義味無盡故。四者。繩墨。辨析邪正故。五者。結鬘。貫穿諸法故。此土解經亦有四義。一，常。二，法。三，經。四，典。綜其要歸。不出貫攝常法四義。蓋修多羅。西域正翻為線。線有貫攝義。貫則貫穿所說之理。攝則攝持所化之生。貫攝玄微。同登覺岸。常者。古今不易。法者。遠近同遵。常則久而行之。有共繇義。亦即經也。《妙玄》云。天魔外道。不能改壞為教常。真正不雜。無能逾過為行常。湛然不動。決無異趣為理常。析義尤盡。法者。軌而正之。法可軌。行可軌。理可軌。有定據義。亦即為典。故經者常道。此土聖哲垂教。亦皆稱經。執理定名。斯稱最當。
    【注】佛法始入中國。迦葉摩騰，竺法蘭等，首譯《四十二章經》。為內典稱經之始。


第二節　辨體

    名為假名。體則本體。故欲詮釋此經。首須辨明經體。體者。一經之指歸。眾義之中樞也。本經以中道實相為體。中道者。不偏於有。不偏於空。空有二邊。雙遮雙照。實相者。無相無不相。非有非空。即空即有。為諸法之實。一切境界。為諸法之權。如冰之與水。兩形雖異。濕性相同。即所謂實相般若。所以言空而不言有者。因此空為圓教真諦之真空。離言說。離心緣。離自離他。非空非不空。乃至遠離一切境界差別之相。一空一切空。無假無中。非空非有。既非外道之斷空。亦非二乘之偏空。論因則人人本具。論果則唯佛方能究盡。
    【注】假名釋之有二。一，就名釋。諸法無名。人為假設。一切名皆虛假不實。《大乘義章》云。諸法無名。假與施設。故曰假名。《起信論》云。一切言說。假名無實。二，就法釋。諸法皆由因緣和合而成。並無實體。假名差別諸法。離名則無差別。《維摩經》什師注云。諸法假名而有。故曰假名。廢名論法。法如幻化。非有非無。亦非非有。亦非非無。無一定相。可以自別。以名呼法。法隨名轉。方有種種諸法差別。乃有假名。
    是故諸法說為假名。《法華經·方便品》曰。但以假名字。引導於眾生。
    本體者。諸法之根本自體也。經體。即一經之本體。台宗以前諸師。說經不分宗體。台宗始以體為一經之主。而以宗為輔。
    中道實相。即中道真實之妙理。實則非虛。相即無相。中者。不二之義。絕待之稱。


第三節　明宗

    體為性德。本體既明。不可不知修持之法。修持之法無量。欲知以何為主。是曰明宗。宗為宗要。本經以一心三觀為宗。以吾人凡常之一心。為所觀之境。一曰空觀。具稱從假入空觀。觀一切法。全由妄念分別而成。了無自性。即能觀之心性。亦復剎那不住。生滅無常。是為體真止。破見思惑。見真諦理。證一切智。成般若德。二曰假觀。具稱從空出假觀。亦名平等觀。觀一切法。全依因緣湊合而成。本為假名。即能觀之心性。亦如夢幻泡影。毫無實際。是為方便隨緣止。破塵沙惑。見俗諦理。證道相智。成解脫德。三曰中觀。具稱中道第一義諦觀。觀一切法。若心若境。非有非空。非非有。非非空。不一不異。非不一。非不異。無內。無外。無中。無過去。現在。未來。心外無境。境外無心。遮照同時。隨機相應。離一切分別想。是為息二邊分別止。見中諦理。破無明惑。證一切相智。成法身德。惟以一心三觀。破三惑。證三智。成三德。本經曰觀。曰照見。曰色不異空。空不異色。色即是空。空即是色。皆一心三觀之證也。
    【注】見思惑者。見惑與思惑也。即枝末無明。概括三界煩惱之通稱。故名通惑。又名界內惑。見惑為意根對法塵迷於無常，無我，真諦道理。非理計度而起之我見，邊見等妄惑。思惑新譯作修惑。為眼耳鼻舌身五根對色聲香味觸五塵而起之貪瞋癡慢等妄惑。小乘俱舍以見惑由迷理而起為理惑。思惑由迷事而起為事惑。大乘唯識則以分別起之煩惱所知二障為見惑。俱生起之煩惱所知二障為思惑。見有二義。一者。照見。照見真理時所斷之惑也。二者。推度。此惑以推度為性也。思亦有二義。一者。思唯修習真理以斷此惑。二者。思唯世間幻妄事物而起之惑也。此二惑為眾生沉淪生死之因。故行者不可不先斷之。斷之有次第。見惑性猛。可以頓斷。所謂見斷如破石也。入見道位。即可一時斷之。思惑性鈍。須數數思唯諦理。方能漸斷。所謂思斷如藕絲也。斷思惑之位。謂之修道。二惑斷盡。則謂之無學道。二惑各分多品。大小乘不同。見惑小乘立為八十八品。一切煩惱中貪瞋癡慢疑，身見、邊見、邪見、見取見、戒禁取見之十惑，名為本惑。此十惑中貪瞋癡慢之四。通於見思、疑與五見之六。則唯見斷。五見與疑。直以諦理為所迷。故謂為親迷之惑。貪瞋癡慢以五見為所迷。故謂為疏迷之惑。此親疏之十惑。為迷於欲界苦諦真理而起之煩惱。故苦諦具足十惑。迷於集諦而起者。則僅七惑。因集諦為業因。無以業因而迷執我體者。故無身見。無身見。故無邊見。戒禁取見。滅諦者。涅槃。亦僅七惑。如集諦。道諦則具八惑。於前二諦七惑外。加一戒禁取見。因有一類外道。修無想定。誤為入涅槃之正道。是由迷於道諦之理而起之非道計道之戒禁取見也。如是欲界。總為三十二。上二界為定地。非如欲界之為散地。不起瞋恚之麤動煩惱。故於欲界之三十二品中。每諦各除瞋惑。為二十八。二界合為五十六。並欲界之三十二為八十八品（參看《俱舍論·十九》）。大乘立為百十二。即於欲界四諦下。各具十惑。為四十。色無色界四諦下。於十惑各除瞋惑。為三十六。二界合為七十二。並欲界之四十為百十二品（參看《唯識述記·九》）。思惑則小乘為十。即欲界為貪瞋癡慢之四。上二界各除瞋為貪癡慢三。二界合為六。並欲界之四為十。大乘為十六。即於欲界有貪瞋癡慢身見邊見之六惑。上二界於六惑中除瞋。各為五惑。合欲界之六惑共為十六。故合見思則小乘為九十八。謂之九十八隨眠。大乘為一百二十八。謂之百二十八根本煩惱。思惑既須漸斷。故聲聞乘為鈍根故。分十惑為九地各九品而分斷之。九地者。欲界五趣地為一。色界四禪，無色界四空，各四地。共為九地。九品者。此各地之思惑為上上，上中，上下，乃至下上，下中，下下，之九品。故九地共為八十一品。既斷見惑之聖者。為預流果。更進而斷欲界地一品乃至五品，為一來向。斷六品已。為一來果。以有後三品之欲惑。故尚須一往來於人天。次後斷欲界後三品之惑。為不還向。斷已謂之不還果。以不再還生欲界故也。次後漸斷上二界八地之七十二品，為阿羅漢向。斷竟為阿羅漢果。阿羅漢此云不生。以斷盡八十一品思惑。不再受生於三界也。
    三惑者。台宗分一切之妄惑為三種。一，見思惑。為涅槃之障。二，塵沙惑。為菩提之障。菩薩教化人之障也。蓋菩薩教化眾生。必通如塵如沙無量無數之法門。於長劫間修習。得道相智。非謂惑體如塵沙也。三，無明惑。為中道實相之障。此與思惑中之癡惑不同。彼為障蔽空理之惑。枝末無明也。此為迷於根本理體之惑。根本，無明也。此三惑中。見思為三緣共斷。故名通惑。塵沙、無明二惑為菩薩所別斷。故名別惑。
    真諦。真即真空。泯一切法。離於諸相。諸相若離。真空自見。是為真諦。俗諦。俗即世俗。諸法雖空。皆不可得。立一切法。假以觀照。是為俗諦。中諦。中即中正。諸法不離二邊。不即二邊。非真非俗。即真即俗。清淨洞徹。圓融無礙。是為中諦。近人江味農居士。則謂般若正明二諦。遮照同時即中。非二諦以外別有中諦。可備一說。
    三觀者。諸家說三觀。有天台三觀。華嚴三觀。南山三觀。慈恩三觀種種。詮文所云三觀。則指天台三觀。一，空觀。觀諸法之空諦也。二，假觀。觀諸法之假諦也。三，中觀。此有二。觀諸法非空、非假、即中。為雙非之中觀。觀諸法亦空、亦假、即中。為雙照之中觀。就性德之理言。謂之三諦。就修德之智言。謂之三觀。一心三觀者。以吾人凡常之一心為所觀之境而觀之也。
    三智者。謂一切智。道相智。一切相智。一切智者。謂共聲聞及獨覺智。蓋五蘊、十二處、十八界等差別法門。聲聞獨覺。亦能了知。而不能知一切道相。及一切法。一切種。故一切智是共聲聞及獨覺智。道相智者。謂共菩薩摩訶薩智。蓋菩薩應學徧知一切道相。謂聲聞道相。獨覺道相。菩薩道相。如來道相。諸菩薩摩訶薩。於此諸道應常修學。令速圓滿。雖令此道作所應作。而不令其證住實際。故道相智是共菩薩摩訶薩智。一切相智者。謂諸如來應正等覺不共妙智。知一切相。皆同一相。謂寂滅相。是故名為一切相智諸行狀相能表諸法。如來如實能徧覺知。是故名為一切相智（參讀《大般若經·四百六十二》）。
    三德者。法身、般若、解脫。具足常樂我淨。謂之三德。不遷不變之為常。安隱寂滅之為樂。自在無礙之為我。離垢無染之為淨。法身德者。諸佛由軌法而得成佛。故名法身。此法身在佛不增。在眾生不減。眾生迷之而成顛倒。諸佛悟之而得自在。迷悟雖殊。體性恒一。具足常樂我淨。是名法身德。般若德者。佛究竟始覺之智。自能覺了諸法不生不滅。清淨無相。平等無二。不增不減。具足常樂我淨。是名般若德。解脫德者。不繫為解。自在為脫。諸佛永離一切業累之縛。得大自在。具足常樂我淨。是名解脫德。


第四節　論用

    明宗之後。又須論用。用者。功用也。明宗以定自修之趨向。論用以顯利他之功能。自行化他為學大乘者特具之精神。本經以遣執度苦為用。凡夫外道。不悟中道實相。於是起五蘊、十二處、十八界之人執。受界內分段生死之苦。聲聞緣覺。縱能觀空、觀假。未能澈見圓中。於是起四諦、十二因緣之法執。受界外變易生死之苦。觀自在菩薩。以大悲心。宣說此經。遣蕩凡外人執。二乘法執。以中道實相。度脫諸苦。故得阿耨多羅三藐三菩提。非但自行般若波羅蜜多。亦以般若波羅蜜多。成就眾生。度諸苦厄。此本經全體之大用也。
    【 注】自行化他。又作自利利他。菩薩萬行。不出此二。《法華文句·八》云。別論口業是化他。身意是自行。通論三業自軌。即是自行之法。三業之教詔。即是化他之法。


第五節　判教

    欲判本經教相。不可不先知教相本義。教者。聖人被下之言。相者。分別同異之象。自法傳震旦。判別教相者凡二十餘家。以天台華嚴二宗所判。為最著。如來三十成道。終至鶴林涅槃。說法四十九年。三百餘會。天台宗智者大師。判為五時四教。五時者。一，華嚴時。佛成道後三七日中。說《華嚴經》時。二，鹿苑時。說《華嚴經》後十二年中。於鹿野苑等處。說小乘《阿含經》之時。三，方等時。說《阿含》後八年。說《維摩》《勝鬘》等諸大乘經。廣說了義。均被眾機之時。四，般若時。說方等經後二十二年。說諸部《般若經》時。五，法華涅槃時。說《般若經》後八年。說《法華經》。示寂前一日一夜。說《涅槃經》時。四教者。有二。曰化法四教。化儀四教。化法四教者。化益眾生之法門。一，藏教。經律論三藏。各含一切文理。說因緣生滅四諦。正教二乘，傍化菩薩之教也。二，通教。說即空無生四諦。以菩薩為正機二乘為傍機。教鈍根菩薩。雖觀無生四諦。但證真空。與藏教同。教利根菩薩。能於真空了達不空。即入別教。能知空不空。具一切法。即入圓教。兼通藏別圓三教。故曰通教。三，別教。說因緣假名無量四諦。獨被菩薩。不涉二乘。別於藏通。所談法門。行相隔歷。次第而不圓融。別於圓教。故曰別教。四，圓教。圓即不偏之義。說大乘圓觀無作四諦。以化最上利根之人。所詮中道之理。性相圓融。事理無礙。法法具足。故曰圓教。化儀四教者。教化眾生之儀式。一，頓教。為上根說別教圓教之大法者。如華嚴時。二，漸教。因機利導。漸次開示。如來於鹿苑時。破斥邪法。建立正教。專為二乘。此名漸初。即《阿含經》也。次於方等會上。彈偏斥小。令歸大法。此名漸中。即《淨名》等經也。後於般若會上。詳闡空慧。淘汰小乘大小各別之執情。會一切法。皆歸大乘。此名漸末。即《般若經》也。自淺至深。次第而進。故名漸教。三，秘密教。謂如來不思議智慧神通之力。能令大眾同會聽法。互不相知。隱密赴機。故名秘密教。四，不定教。謂如來不思議智慧神通之力。能令聽法之眾。或聞小法而證大果。或聞大法而證小果。聞解各異。得益不定。故名不定教。法華涅槃時。則純圓獨妙。非頓，非漸。非秘密。非不定也。以五味譬喻。華嚴時。如全牛生乳。鹿苑時。如從乳為酪。方等時。如從酪為生酥。般若時。如生酥為熟酥。法華涅槃時。如熟酥為醍醐。此為台宗所判教相。華嚴宗則判為小、始、終、頓、圓五教。始於杜順。成於賢首。一，小乘教。說長，中，增一，雜，四阿含經。及一切小乘律論。以隨機故。但說人空。不說法空。縱說法空。亦不明顯。但依六識三毒。建立染淨根本。未盡法源。二，大乘始教。亦名分教。廣說法相。少說法性。未盡大乘法理。名之為始。不示眾生皆有佛性之義。更分為相始教。如《深密經》等。分別五性。建立依他之萬法者是。空始教。如般若等經。說諸法皆空。顯無所得平等者是。三，終教。亦名實教。言定性聲聞。無性闡提。皆得成佛。方盡大乘至極之理。於中多說法性。少說法相。雖說法相。亦會歸性。如《楞伽》《勝鬘》等經。說真如緣起之理者是。四，頓教。明一念不生。即名為佛。不依階位漸次。故名曰頓。於中不說法相。惟明真性。如維摩之默顯不二。達摩之以心印心。以頓徹理性為教者是。五，圓教。所說惟是無盡法界。性海圓融。緣起無礙。相即相入。如帝網珠。重重無盡。一位即一切位。一切位即一位。故十信滿心。即成正覺。如華嚴、法華等經。明圓融具德之一乘者是。以兩宗所判對勘。華嚴宗之小。即台宗之藏。台宗之通。即華嚴宗之始。台宗之別。即華嚴宗之終。圓教在台宗則三諦圓融。即空、即假、即中。在華嚴宗則理事無礙。事事無礙。本經於化法為圓教。兼說通別。於化儀為漸末、秘密、不定。以五時論。屬第四時。以五味喻。則為熟酥。
    【注】台宗所判五時。華嚴時者。如來在寂滅道場。始成正覺。最初三七日。對大菩薩及宿世根熟之眾。即圓別之機。說自證法。如《華嚴經》正說圓教。同時兼說別教。向鈍根機類說自證法。試其適否。名擬宜時。阿含時者。在華嚴時。一類利根雖蒙化益。鈍根小機。仍未領悟。故說《華嚴經》後十二年間。於鹿野苑說《四阿含經》等。誘引小機。名誘引時。方等（台宗於方等有三釋。約理釋方謂方廣。等即平等。實相妙理。橫徧諸法。故名方廣。豎該凡聖。故言平等。約事釋。方者。廣也。等者。均也。廣說四教。均益利鈍之機也。約事理釋。方者。方法。等者。平等。依有、空，雙亦、雙非四門之方法。各契平等之理。即方者能契之行。等者所契之理也）。時者。阿含時誘引小機。非佛本意。故次八年中說《維摩》、《思益》、《楞伽》、《楞嚴》、《三昧》、《金光明》、《勝鬘》等經。兼說藏、通、別、圓四教。彈偏斥小。歎大褒圓。令小乘人恥小慕大。名彈呵時。般若時者。小乘回心向大。起大小二乘。其法各別之執情。故次二十二年間說諸部般若經。正說別圓二教。兼說通教會一切法。皆摩訶衍。淘汰小乘大小各別之執情。名淘汰時。法華涅槃時者。經前四時說教。鈍根小機，機緣漸熟，故最後八年間，二處三會，說《法華經》。正明圓教。開方便。顯真實。會三乘歸一乘。令開示悟入佛之知見。名開會時。臨滅一晝夜。一，為法華未熟人追說四教。具談佛性。令知真常。入大涅槃。名捃拾殘機教。二，為末代乘戒俱失。故更扶三藏。廣開常宗。設三種權。扶一圓實。名扶律談常教。法華會竟。無三唯一。涅槃最後談常。四教並是圓理。合稱法華涅槃時。華嚴宗之五教。杜順判為五門。一，法有我無門。小乘教也。二，生即無生門。大乘始教也。三，事理圓融門。大乘終教也。四，語觀雙絕門。大乘頓教也。五，華嚴三昧門。大乘圓教也。見《五教止觀》。賢首本之而判五教十宗。一，我法俱有宗。二，法有我無宗。三，法無去來宗。四，現通假實宗。五，俗妄真實宗。六，諸法但名宗。七，一切皆空宗。八，真德不空宗。九，相想俱絕宗。十，圓明具德宗。自一至六，為小乘教。七，當大乘始教。八，當大乘終教。九，當大乘頓教。十，當大乘圓教。清涼改一切皆空宗為三性空有宗。真德不空宗為真空絕相宗。相想俱絕宗為空有無礙宗。圓明具德宗為圓融具德宗。
    自來判教相者。自以天台智顗、華嚴賢首兩師之說為最備。但判教不始於兩師，兩宗以前以後各師。及其他大乘諸宗。除禪宗不立文字外。各判教相。人異其說。茲略述之如次。
    第一。三論宗所判教相。（一）一音教。更分二說。謂如來一音。同時集萬。大小並陳。即隨一音具說大小一切無盡法門者。後魏菩提流支之說也。謂佛一圓音。無思普應。機聞自殊。非謂言音本陳大小。如水本一味。隨器而異。如來言音。亦復如是。隨眾生心量而生無量差別。《淨名經》云。佛以一音演說法。眾生各各隨所解。姚秦鳩摩羅什之說也。一謂佛音各異。一謂隨機而殊。各得圓音一義。但以教本不分則一。見《華嚴·清涼疏》此古三論派也。（二）依《涅槃經》，及智度、地持、正觀等論立二藏。一，聲聞藏。即小乘教。二，菩薩藏。即大乘教。又依《法華經·信解品》立三輪。一，根本法輪。《華嚴經》也。佛始成正覺華嚴會之說法。純為菩薩開一因一果法門。二，枝末法輪。小乘諸經乃至《方等》、《般若》諸大乘經。因鈍根機類。不堪聞一因一果。故於一佛乘。分別說三。三，攝末歸本法輪。《法華經》也。四十餘年說三乘教。至法華會。始得會彼三乘。歸於一極。此唐初吉藏所判。所謂新三論派之嘉祥教判也。（三）依般若等經，中觀等論，立三時教。一，初時。為小根人說小乘法。明心境俱有。如《阿含經》。惟攝二乘。二，第二時。為中根人說法相大乘。明境空心有。如《解深密經》通攝大小三乘。三，第三時。為上根人說無相大乘。辨心境俱空。如《般若經》。惟攝菩薩。此為勝義俱空宗天竺那爛陀寺智光論師。遠承文殊龍樹。近稟青目清辨。所立之空教三時也。見《華嚴玄談》及《阿彌陀經通贊疏序》。
    第二。唯識宗所判教相。此宗先分頓悟、漸悟二機。頓悟者。無論聞有聞空。俱證中道。無前後次第可言。漸悟之機則分三時，按佛說法前後，立初、昔、今之次第。謂之年月三時。按佛說法義類，立有、空、中之分別。謂之義類三時。中間所判。或依年月前後。或依義理淺深。或年月義理並依。以年月前後。與義理淺深相待並具。成三時之教相。（一）第一時有教。凡夫外道。無始以來。妄認實我妄執。起惑造業。沈淪生死。佛成道後。為除其實我妄執。於鹿野苑說《阿含》等經。示四諦、十二因緣、五蘊等法。令小乘人悟我執空。蘊處界等諸法有。是曰初時我空法有論為小乘有教。（二）第二時空教。二乘聞初時有教。雖證我空。而不了知佛說法有之密意。迷執諸法實有。猶懷法我之見。佛為除彼法執。於靈鷲山等處。說《般若》等經。示蘊處界諸法皆無。令中根悟我法二空。捨小趣大。是曰第二時我法二空論。為大乘空教。（三）第三時中道教。大乘空教。尚屬誘引方便。因說諸法皆空。致聞者復起空執。便謂真俗二諦。性根皆空。佛為並除二執。於《解深密經》等會。說解深密諸大乘經。演唯識三性等教。示識有非空。破第二時空執。境空非有。破初時有執。令悟非有非空中道妙理。是曰第三時境空心有論。為大乘中道教。惟佛說法。隨機誘導。年月與義類。次第未必全同。如於《阿含經》前。說中道教之《華嚴經》。《法華經》後。說有教之《涅槃經》是也。此為應理圓實宗戒賢論師。遠承於彌勒無著。近踵於護法難陀。所立之有教三時也。唐玄奘三藏宗之。見《了義燈》。類似此判者。梁真諦三藏。亦判三時。一，有教。佛初成道七年以來說有教。五年度五俱倫（佛最初所度之五比丘。此五人自過去世以來。俱為同倫故。或作五拘鄰。五比丘中第一阿若憍陳如之別譯也。）第六年化舍利弗。第七年度三迦葉。總名有教。二，空教。從第八年至三十八年以來說《般若》等經是。三，非空非有教。從三十九年至臨涅槃時。說《法華》、《楞伽》、《思益》等經是。與戒賢所判不同者。戒賢將時就教。真諦以教就時。故不如戒賢之圓滿耳。見《阿彌陀經通贊疏·序》。
    第三。淨土宗所判教相。（一）約行之教相言。判為難行易行二道。謂於五濁惡世無佛時。求不退轉為難行道。譬如陸路。步行則苦。以信佛因緣。願生淨土。乘佛願力。便得往生。即入大乘正定之聚。為易行道。譬如水路。乘船則樂也。此為曇鸞大師所判。見《十住毘婆沙論》。（二）約證之教相言。判為聖道與淨土。於此娑婆世界。斷惑證理。入聖得果。名聖道門。依彌陀願力。往生極樂世界入聖得果。名淨土門。在此五濁惡世。聖道一門。理解深微。去聖遙遠。末法之時。不易證得。淨土法門。平易確實。所謂萬修萬人去也。與難行易行語異而意同。難行與聖道。同為自力進修。易行與淨土。兼仗他力接引。此為道綽法師所判。見《安樂集》。（三）約教之教相言。判為漸教與頓教。聲聞藏與菩薩藏。本宗於二教中屬頓教。二藏中屬菩薩藏。此善導法師所判。見《觀經四帖疏》。
    第四。律宗所判教相。此宗判如來一代時教。為化制二教。化教者。化益之教。即諸經論所示禪定智慧之法門。如《四阿含》，及《般若》《華嚴》等經。汎說因果。通化道俗。旨在開示慧解。非為制止過犯。更分為三。謂之南山三教（南山即終南山。此宗教判。始於道宣律師。住終南山。為此土律宗初祖）。 （一）性空教。立諸法性空無我之教。攝一切小乘。（二）相空教。立諸法本相是空。唯情妄見之教。攝一切大乘淺教。（三）唯識圓教。立諸法外塵本無。實惟有識之教。攝一切大乘深教。制教者。制戒之教。即諸律所詮令守戒法之法門。如四分律、五分律、十誦律、僧祇律等。說諸律儀。惟制內眾。故名制教。又名行教。約佛邊說曰制。約眾生邊說曰行也。起必由過。隨過制約。言唯持犯。事通製作。律宗所主。全在制教。約茲戒法。兼攝定慧。更分三宗。（一）實法宗。即立一切諸法實有之薩婆多部。如十誦律。此宗以色為戒體。屬當分小乘教。（二）假名宗。即立諸法惟有假名之曇無德部。如四分律。此宗以非色非心為戒體。屬過分小乘教。（三）圓教宗。即立一切諸法惟有識之唯識圓教。道宣律師即四分律成一乘圓頓妙戒。此宗以種子為戒體。為終窮大乘教。見《四分律行事鈔》。
    第五。密宗所判教相。有縱有橫。橫者。就一代時教。分為顯密二教。以應化身百億教法。顯略逗機。即大小乘三藏十二部經所說四諦、十二因緣、六度、萬行法門。是顯教。法身所說。如《大日經》、《金剛頂經》等金胎兩部法門。陀羅尼、印契念誦、灌頂、儀軌是密教。顯教隨他方便誘引教義。密教為對自眷屬內證法門。如來變化身。為地前菩薩，及二乘，凡夫等說三乘教法。他受用身。為地上菩薩說顯一乘等。並是顯教。自性受用，佛自受法樂故。與自眷屬說如來內證智境。謂之密教。就縱說。則依背暗向明心續生之次第而立十住心之階段。一，異生羝羊心。異生即凡夫。羝羊即牡羊。除水草婬欲以外無所知。以譬凡夫之愚癡闇昧。此心本不應列教判。以由此入第二心。故以之為初心。二，愚童持齋心。眾生以內熏外緣。亦修五戒十善及世間倫常教法。為人乘之教。三，嬰童無畏心。外道以生天得蘇息。修四禪六行之天乘教也。以上為世間三住心。以下為出世間。四，唯蘊無我心。為入佛法門最初之住心。觀四諦理。得唯我空。聲聞法也。五，拔業因種心。雖拔煩惱所作之因。而習氣尚在緣覺法也。以上二心為小乘教。六，他緣大乘心。他緣即無緣。住自他冤親平等之觀。悟真如平等度眾生入佛。與法相宗相當。彌勒菩薩內證法門也。七，覺心不生心。覺悟心性不生不滅入於心境俱空之證。三論宗八不與起信論所說相當。文殊菩薩內證法門也。以上二心為三乘教。八，一道無為心。又名如實一道心。如實知自心。空性無性心。《法華》所說。以心即境。無為無相為極意。與天台宗相當。觀世音菩薩內證法門也。九，極無自性心。有淺深二釋。淺者，華嚴法界。諸法即真如實相。真如隨緣。不守自性。染淨和合。事事無礙。重重無盡之義。深者，由毘盧遮那之教覺而無自性。華嚴之法門當之。普賢菩薩內證法門也。以上二心及下一心皆一乘教。自一至九。皆顯教所攝。十，秘密莊嚴心。金胎兩部六大、三密、五相、五智之無盡法門。等覺十地。亦不能見聞。故曰秘密。法門德相。故曰莊嚴。密教之心地也。胎藏界之十住心為橫。金剛界之十住心為豎。胎金不二之處謂為不二之十住心。此日本東密派（傳自不空）弘法大師所判。見《辨顯密二教論》《大日經疏》《十住心論》《決議鈔直牒》。
    第六。智顗判教以前諸師。及台宗後來諸師所判教相更有多說。（一）半字教與滿字教。聲聞藏談理未徧。若字之僅半曰半字教。菩薩藏談理圓滿。如字之完具曰滿字教。此西秦曇牟讖三藏所判。見《華嚴經疏》。（二）漸教與頓教。約漸悟之機。大由小起。具有三乘故名為漸。《法華經》等是也。若不由於小。逕超大乘。則名為頓。如《華嚴經》是也。此曇牟讖與真諦三藏所判。見《華嚴經探玄記》。（三）屈曲教與平道教。謂釋迦如來所說之經。隨機破執。方便委曲。如《涅槃經》雖說圓通一極之理。或對權顯實。或會異歸同。名屈曲教。亦名釋迦教。盧舍那所說之經。隨其法性平等而說。如《華嚴經》。雖隨眾生各別調伏。皆是稱性善巧。一時頓演。名平道教。亦名盧舍那教。此唐初印法師所判。見《華嚴經疏》。（四）梁真諦三藏除判頓漸外。於漸中更開為轉、照、持三輪。謂佛於二月八日成道。四月八日於波羅那國鹿野苑中為聲聞眾說四諦為轉法輪。七年後在舍衛國去祇園五里智慧河邊。為諸菩薩二乘說《般若》等經。以空照有。具轉照二輪。三十年後在毗舍離國鬼王堂中。為真常菩薩說《解節》等經。雙照空有。具轉照持三輪。見《華嚴經疏》。（五）劉宋上元寺慧觀。亦先判頓漸。於漸中更分為五時。一，有相教。於《阿含經》等別說四諦、十二因緣、六度。以因緣實有之法。分投聲聞緣覺菩薩三機。是為三乘別教。二，無相教。專說般若經。空諸有相。通化三乘。是為三乘通教。三，抑揚教。說《淨名》《思益》等經。抑挫聲聞。褒揚菩薩。義具抑揚。故曰抑揚教。四，同歸教。般若之後。涅槃之前。說《法華經》。會三乘歸一極。萬善悉向菩提。故曰同歸教。五，常住教。說《涅槃經》。明佛果常住。一闡提（《涅槃經》云。無信之人。名一闡提。《唯識樞要》云。第五性有三種。一，闡底迦。是樂欲義。業生死故。二，阿闡底迦。是不樂欲義。不樂涅槃故。三，阿顛底迦。是畢竟義。畢竟無涅槃性故。）皆得成佛。廣談佛性。故曰常住教。見《華嚴經疏》。（六）齊隱士劉虯亦先判頓漸。於漸中分五。一，人天教。謂佛初成道時。先為提謂長者說人天五戒十善。乃是因緣果報實有之法。二，有相教。三，無相教。四，同歸教。五，常住教。與慧觀同。見《華嚴經疏》。（七）梁光宅寺法雲。依《法華經》。謂臨門三車。即權教三乘。四衢則實教大乘。故立四乘教。一，聲聞乘教。聲聞以析空觀。觀於生滅四諦。破見思煩惱。證真諦理。離三界生死。如乘羊車出於火宅。二，緣覺乘教。緣覺以析空觀。觀十二因緣生滅。破見思煩惱。證真諦理。離三界生死。如乘鹿車出於火宅。三，菩薩乘教。藏教菩薩。發四弘誓。修六度萬行化導眾生同出三界生死。究竟至於真空涅槃。如乘牛車出於火宅。四，佛乘教。大乘菩薩。以圓融三觀。觀於諸法實相之理。頓破無明煩惱。成一切種智。頓超佛乘。如乘大白牛車出於火宅。見《華嚴經疏》。（八）唐初海東元曉法師。亦立四教。一，三乘別教。如《四諦緣起經》等。為三乘所共學。其中二乘未明法空。異於菩薩。故曰三乘別教。二，三乘通教。如《般若》、《解深密經》。皆明二空。為三乘所共學。故曰三乘通教。三，一乘分教。如《梵網經》等。菩薩不與二乘共學。故名一乘。未顯法之周徧圓融。故名分教。四，一乘滿教。如《華嚴經》。具明法界之理。故名一乘滿教。見《華嚴玄談》。（九）西天第十三祖龍樹論師。嘗立四教。一，有門。謂《阿含》小乘等經。說一切因果之法悉皆實有。是為有門。二，空門。謂《大般若》等經。說真空實相之理。蕩除眾生情執。是為空門。三，亦有亦空門。謂《深密經》等。說性空相有。是為亦有亦空門。四，非有非空門。謂中論等雙破空有。說一切法即空之有是非有。即有之空是非空。互泯互融。即第一義。見《華嚴經隨疏演義鈔》。（十）唐釋法寶則判為一，小乘教。二，大乘教。亦名般若教。三，三乘教。亦名深密教。四，一乘教。亦名法華教。五，佛性教。亦名涅槃教。見《五教章》。（十一）魏光統律師承佛陀三藏之說。以三教四宗判教。先分漸、頓、圓三教。一，漸教。為未熟者先說無常後說常。先說空後說不空。如是次第者。曰漸教。二，頓教。為根熟者於一法門頓說常無常。空不空者。曰頓教。三，圓教。為上達者說如來無礙解脫究竟果德，圓極秘密自在之法門。曰圓教。綜合三教。更立四宗。一，因緣宗。說一切現象為因緣假合。如《毘曇論》。二，假名宗。說一切現象僅屬假名而無實際。如《成實論·三假》。三，誑相宗。說一切現象為誑相非真。即說空之教。如大品、三論。四，常宗。說佛性常住。湛然不變。如涅槃、華嚴。光統弟子大衍寺曇隱。改常宗為真宗。誑相宗為不真宗。齊護身寺自軌。於光統四宗。加一法界宗。《華嚴經》也。以涅槃經為常宗。耆闍寺法凜。則於光統四宗之外。開華嚴為圓宗。法華為真宗。共為六宗。見《五教章》。（十二）隋闍那崛多及達摩岌多。判如來教為四時。一，生空教。即十二年前說《阿含經》是。二，法空教。即三十八年前說八部《般若》是。三，法相教。即三十八年後。四十九年來。說《楞伽》、《思益》、《法華經》等。廣明百法、三性、三無性、八識、二無我等是。四，觀行教。即說華嚴法界觀等是。見《阿彌陀經通贊疏·序》。（十三）武丘笈法師判為三教。一，頓教。佛成道後。最初為諸菩薩說《華嚴經》。如日初出。先照高山。為頓教。二，漸教。始自鹿苑。終至雙樹。從小至大為漸教。三，不定教。非頓非漸。惟明佛性常住。如《勝鬘》《光明》等經所說。為不定教。於漸教中更分為三。一，有相教。佛於十二年前說《阿含經》。小乘不離色心。見有得道。名有相教。二，無相教。十二年後至於法華。菩薩見空得道。名無相教。三，常住教。最後說涅槃經。有無雙照。明一切眾生。皆有佛性。闡提作佛。名常住教，嗣後宗愛益以同歸為四教。定林，柔次，益以抑揚為五教則同於慧觀所判矣。見《法華玄義》。（十四）唐中天竺沙門波羅頗迦羅滅多羅所判五教。一，四諦教。謂佛於《阿含經》。說苦集滅道四諦之法。為令聲聞之人修此而悟真空之理。二，無相教。謂佛於《般若經》中。說諸空慧法門。空諸有相。令悟大乘法空。三，觀行教。謂佛於《華嚴經》。說諸觀行法門。為令眾生觀察修行。四，安樂教。謂佛於《涅槃經》。說常樂我淨，四德常住寂滅之理。為令眾生得大安樂。五，守護教。謂佛於《大集經》等。說守護正法。為令眾生保持不失。見《華嚴玄談》。（十五）明袁宏道所判六教。一，假有教。說世間因果之人天教也。二，趨寂教。小乘寂滅趨向涅槃之教也。三，有餘教。了二空相理。趨大乘佛果。惟不許闡提二乘成佛。故名有餘。四，無餘教。一切眾生。悉當成佛。為大乘極則之教。五，頓悟教。不從地位漸次。故名為頓。六，圓極教。如法華、華嚴等。顯真實中道義。捨化城而歸寶所也。見《西方合論》。（十六）諸經論疏。有補充判教者。一，大收教與捃收教。《法華》開權顯實曰大收。餘眾機緣未熟。不列法華會中。最後說《涅槃經》。更說四教。具談佛性。歸入一乘圓常妙理。以捃收法華餘眾。曰捃收。見《法華玄義》。二，世間教與出世間教。生三界善處之善法曰世間教。出離生死之三乘教法曰出世間教。見《大乘義章》。三，了義教與不了義教。大乘諸經。顯明深理。曰了義教。小乘諸經。未了深義。曰不了義教。見《涅槃經》。四，顯露教與秘密教。對一會大眾。顯說大法。彼此咸知。曰顯露教。對此眾說法。他眾不知。或在此為顯。於彼為密。或互為顯密。各不相知者。曰秘密教。見《法華玄義》。五，偏教與圓教。藏通別為偏。圓教為圓也。見《止觀》。六，實教與權教。如來出世真實之教法。實教也。圓教屬之。因實教而權設者。權教也。藏通別三教屬之。見《止觀》。七，界內教與界外教。藏通二教。對沉淪三界眾生。斷見思二惑。出離三界之法門。界內教也。別圓二教。對於已斷見思惑之法身菩薩。教以解脫三界外方便土實報土。（台宗立四種土。一，凡聖同居土。人、天、凡、聖、及二乘聖者同居之國土。如娑婆為同居穢土。安養為同居淨土是。二，方便有餘土。斷見思煩惱。出離三界生死之人所居。因塵沙無明未淨。故曰有餘。變同居土之依身為方便土。又由方便土之依身。變實報土之依身。故又名變易土。三，實報無障礙土。方便土為證空理人之果報土。實報土則為證一分中道之理者之果報土。色心不相妨。故曰實報無障礙土。純為菩薩所居。無凡夫二乘。四，常寂光土。法身常寂之體。諸佛如來所依所居。然由圓融之理言之。四土總為不二。《止觀義例》曰。心體即常寂光。寂光諸土。無二無別。）變易生死。斷無明而證佛果之法門。界外教也。藏教究蘊處界事相法門為界內事教。通教窮理稍深為界內理教。別教菩薩迷中道之理重。故分別無量事法。以之為方便。而使悟理。為界外事教。圓教菩薩迷理已輕。故直談萬法為中道實相之妙理。為界外理教。見《法華玄義》。
    第七。華嚴宗自賢首判教以後。其弟子慧苑依《寶性論》更立四教。（一）迷真異執教。謂凡夫外道迷於真理廣起異計也。（二）真一分半教。謂小乘於真如隨緣不變二分義中，但得隨緣。故名一分。但說人空。不說法空。故名為半。（三）真一分滿教。謂初心菩薩。但得不變。不得隨緣。故名一分。雙顯人空法空之理。故名為滿。（四）真具分滿教。菩薩既了隨緣不變二義。顯真實理。識如來藏。故曰真具分滿教。華嚴五祖圭峰宗密禪師。和會禪教。一際融通。判立三宗三教。禪三宗者。一，息妄修心宗。說眾生雖本有佛性。而無始無明覆之不見。故輪迴生死。諸佛已斷妄想。故見性了了。出離生死。故須背境觀心。息滅妄念。念盡即覺。無所不知。如鏡蒙塵。塵盡明現。須修禪觀。遠離諠雜。調息調身。心注一境等。二，泯絕無寄宗。說凡聖等法。皆如夢幻。都無所有。本來空寂。非今斯無。即此達無之智。亦不可得。平等法界。無佛無眾生。法界亦是假名。心既不有。誰言法界。無修不修。無佛不佛。設有一法。勝過涅槃。我亦說如夢如幻。無法可拘。無佛可作。凡有所作。皆是迷妄。如了達本來無事。心無所寄。方免顛倒。始名解脫。三，直顯心性宗。說一切諸法。若有若空。皆惟真性。指示心性。復有二說。一云。即今能言語、動作、貪、瞋、慈、忍、造善惡、受苦樂等。即汝佛性。即此本來是佛。除此無別佛。了此天真自然。道即是心。性如虛空。不增不減。但隨時隨處。息業養神。自然神妙。此為真悟。二云。諸法如夢。妄念本寂。塵境本空。本空之心。靈知不昧。即此空寂之知。是汝真性。任迷任悟。心本自知。不藉緣生。不因境起。知之一字。眾妙之門。若頓悟此空寂之知。知且無念無形。誰為我相人相。覺諸相空。心自無念。念起即覺。覺之即無。此上兩說。皆是會相歸性。三教者。一，大乘法相教。即密意依性說相教。佛說三界六道。悉是真性之相。但是眾生迷性而起。無別自體。故云依性。然根鈍者遽難開悟。故隨他所見境相說法。漸漸度之。故云說相。說未彰顯。故云密意。此一教中。更分三類。一者。人天因果教。說善惡業報。令知因果。二者。斷惑滅苦教。說三界無安。皆如火宅之苦。令斷惑業之集。修道證滅等。三者。將識破境教。說上生滅等法。不關真如。但各是眾生無始以來。法爾有八種識。於中第八識。是其根本。頓變根身器界種子轉生七識。各能變現自分所緣。此八識外。都無實法。我此身相。及外世界。唯識所變。迷故執有我及諸境。既悟本無我法。惟有心識。遂依此二空之智。修唯識觀，及六度、四攝等行。漸漸伏斷煩惱、所知二障。證二空所顯真如。十地圓滿，轉八識成四智菩提。真如障盡。成法性身。大涅槃果。此與禪門息妄修心宗相扶會。以知外境皆空。故不修外境事相。唯息妄修心。息我法之妄。修唯識之心也。二，大乘破相教。即密意破相顯性教。據真實了義。則妄執本空。更無可破。無漏諸法。是真性隨緣妙用。永不斷絕。又不應破。但為一類眾生。執虛妄相。障真如實性。難得圓悟。故佛不揀善、惡、垢、淨、性、相，一切訶破。以真性及妙用。不無而云無。又意在顯性。語乃破相。意不形於言中。故云密也。此教說前教中所變之境。既皆虛妄。能變之識。豈獨真實。心境互依。空而依有。且心不孤起。託境方生。境不自生。由心故現。心如境謝。境滅心空。皆假眾緣。無自性故。是以一切諸法。無不是空。凡所有相。皆是虛妄。是故空中無五陰、六根、因緣、四諦，無智，亦無得。生死涅槃。平等如幻。與禪門泯絕無寄宗全同。三，一乘顯性教。即顯示真心即性教。直示自心即是真性。不約事相而示。亦不約破相而示。故云即性。不是方便隱密之意。故云顯示也。此教說一切眾生皆有空寂真心。無始本來。性自清淨。明明不昧。了了常知。盡未來際。常住不滅。名為佛性。亦名如來藏。亦名心地。達摩所傳。是此心也。見《宗鏡錄·三十四》及《原人論》。
    以上略舉各宗所判教相。意在使初機明瞭一代時教概念。但判別愈繁。轉涉事相。故唐清涼法師。不主分判教相。一者。理本一味。殊途同歸故。始隨機異故殊途。終歸顯實故一致。約機則異。就理常一。體外無權。權即是實。二者。一音普應。一雨普滋故。五性三乘不一。法雨一味無差。如大地百草。一雨普滋。三者。原佛本意為一事故。佛之出世。為一大事因緣。開示悟入佛之知見。轉迷成覺。《法華經》曰。我此九部法。（一切經分為十二部。一，修多羅。此云契經。二，祇夜。此云重頌。三，伽陀。此云諷誦。四，尼陀羅。此云因緣。五，伊帝目多。此云本事。六，闍多伽。此云本生。七，阿浮達磨。此云希有。八，阿波陀那。此云譬喻。九，優婆提舍。此云論議。十，優陀那。此云無問自說。十一，毗佛略。此云方廣。十二，和伽羅。此云授記。大乘之九部法。於十二部中。去因緣、論議、譬喻三部，以大乘直說佛法。不假因緣。惟談圓理。故絕論議。獨顯真常。不待譬喻也。小乘之九部法。於十二部中去方廣、授記、無問自說三部。因方廣為大乘常住之理。小乘惟說生滅之法。故無方廣。小乘未得成佛。故無授記。佛為小乘說法。必假問答為發起之緣。故無無問自說。）隨順眾生說。入大乘為本。無論說法前後。皆為一事。四者。隨一一文。眾解不同故。如諸經說無常。或以生滅代謝。故名無常。或云無彼常故。名為無常。或云。不生不滅。名為無常。或云。真如一法。隨染淨緣轉變不常。故名無常。或聞無常。便知對常以說無常。非常非無常。以為中道等。又苦集滅道。隨機解殊。乃有四種。又《涅槃經》曰。十二因緣。下智觀者。得聲聞菩提。中智觀者。得緣覺菩提。上智觀者。得菩薩菩提。上上智觀者。得佛菩提。皆隨人解而不同也。五者。多種說法。恐成枝流故。法欲滅時。有多種異說。何不尋條以得根。便欲派本以為末。混淳源之一味。成澆薄之枝流。以斯五義。故不可分。所言甚允。吾詮略述之者。專為初機闡示佛教輪廓。讀者明法以後。當如得魚忘筌。求究竟第一義。勿執著於文字相也。
    六識者。眼耳鼻舌身意之六識也。
    三毒又名三根。為一切煩惱根本。一，貪毒。引取之心名貪。以迷心對於一切順情之境引取無厭也。二，瞋毒。忿恚之心名瞋。以迷心對於一切違情之境起忿怒也。三，癡毒。迷闇之心名癡。心性闇迷。迷於事理。亦名無明。癡毒獨起時。名獨頭無明。與貪毒等共起。名相應無明。
    五性者。一，定性聲聞。因果不易名曰定性。聞佛聲教而得覺悟。名曰聲聞。惟習聲聞之因。而證聲聞之果。更不進求佛道。是曰定性聲聞。二，定性緣覺。觀因緣生滅之法。覺悟真空之理。名曰緣覺。惟習緣覺之因。而證緣覺之果。更不進求佛道。是曰定性緣覺。三，菩薩性。菩薩具云菩提薩埵。此云覺有情。菩薩悲智雙運。冤親等觀。廣利眾生。證菩提果。是曰菩薩性。四，不定性。謂遇緣熏習。修行不定。近聲聞即習聲聞法。近緣覺即習緣覺法。近菩薩即習菩薩法。各隨所習而成其性。是曰不定性。五，無種性。無種者。無善種也。撥無因果。不受化度。甘溺生死。不求解脫。是曰無種性。
    依他即依他性。依因緣而生之諸法也。諸法皆依眾緣相應而起。都無自性。
    帝網珠者。即帝釋天中因陀羅網之珠也。彼網皆以寶珠作之。一珠之中。現諸珠影。互相交映。重重無盡。一位即一切位。一切位即一位。見《華嚴探玄記》。
    以上說五重玄義竟。至本經在藏乘地位。則三藏之中。屬經藏攝。二藏之中。屬菩薩藏攝。三乘之中。屬菩薩乘攝。五乘之中。屬佛乘攝。以經中明示菩提薩埵。依般若波羅蜜多得究竟涅槃。三世諸佛。依般若波羅密多得阿耨多羅三藐三菩提也。
    【注】三藏者。藏有含藏之義。經律論三。各含文理。故曰三藏。一，經藏。梵語修多羅。貫攝經義。廣度眾生。二，律藏。梵語毘奈耶。或作毘尼。此云善治。能治貪瞋癡諸惡也。又調伏。謂能調練三業。制伏過非。調練通於三業。制伏惟明止惡。毘尼。此云滅。《圓覺略鈔》云。滅有三義。一滅業非。論云。滅惡故名毘尼。二滅煩惱。律云。世尊謂調伏貪瞋癡，令盡。故制增上戒學。三得滅果。《戒經》曰。戒淨有智慧。便得第一道。南山云。毗尼翻滅。從功能為名。非正譯也。正翻為律。律者。法也。從教為名。斷割重輕。開遮持犯。非法不定。又名波羅提木叉。此云解脫。道戒名解脫。以道性虛通。不隨緣別。但名解脫。事戒不爾。緣別而生。如僧尼受戒。隨對殺等事不作。別別無因。別別無果。故名別別解脫。摭華云。此云別解脫。謂三業七支。各各防非。別別解脫故。三，論藏。梵語阿毗達磨。舊譯作阿毗曇。此云對法。法有二種。一，勝義法。所謂涅槃是善是常。故名為勝。二，法相法。通四聖諦世出世異及因果異。故名為相。對亦有二。一，對向涅槃。以乘無漏聖道之因。感趣涅槃圓寂之果。二，對觀四諦。謂以淨慧之心。觀察四諦之法。攝大乘論世親釋。阿毗達磨有四義。謂對故。數故。伏故。通故。對義同前。數謂於一一法。數數宣說。訓釋言詞。自共相等。無量差別故。伏謂能勝伏他論故。通謂能通釋契經義故。亦名鄔波提鑠。此云論議。亦名摩怛哩迦。此云本母。謂妙慧因論議而生。亦名奢薩怛羅。此云論。謂論空有假實等法也。以上所說為總部大乘三藏。若別部小乘三藏。則以《阿含經》為經藏。四分、五分、十誦、律等為律藏。六足、發智等論為論藏。《智度論》所謂三藏是聲聞法。摩訶衍是大乘法也。
    二藏者。依佛說大小乘諸經而別。一，聲聞藏。詮小乘聲聞等。修因證果之法。包含緣覺乘在內。故曰聲聞等也。聲聞與緣覺雖教行少分不同。（聲聞之教為四諦。緣覺之教為十二因緣。聲聞之行。須歷四果。緣覺之行（一座成覺）。而理、果不殊（論理則同證生空。不證法空。論果則同斷我執。不斷法執。緣覺與聲聞之羅漢果同證無餘涅槃）。故合為一藏。二，菩薩藏，詮大乘菩薩修因證果之法。
    三乘。乘即運載之義。一，聲聞乘。依苦集滅道四諦法。修持精進。求出三界以向涅槃。《法華經》曰：如彼諸子。為求羊車出於火宅。二，辟支乘。即緣覺乘。因觀十二因緣。覺真諦理。求自然慧。樂獨善寂。《法華經》曰：如彼諸子。為求鹿車出於火宅。三，菩薩乘。勤修六度。廣化眾生。《法華經》曰：如彼諸子。為求牛車出於火宅。
    五乘者。於三乘外。益以人天乘與佛乘。人天乘以五戒、十善出地獄、餓鬼、畜生、修羅四趣。求下界五欲及上界淨妙之樂。法華喻為最小之車。佛乘以一乘實相之法。運諸眾生同到涅槃彼岸。《法華經》喻為大白牛車。又一說。五乘為人乘、天乘、聲聞乘、緣覺乘、菩薩乘。又一說五乘為佛乘、緣覺乘、聲聞乘、天乘、梵乘。梵者，淨義。菩薩以慈、悲、喜、捨四無量心。運諸眾生出生死海。即菩薩乘也。


第二章 人題

    前章詮釋經題。要義略具。佛以圓音說教。使眾生隨類聽聞。各得了解。佛滅度後。結集契經。方隅所限。同文未能則大法流傳。自不能不有待於紬譯。本經觀自在菩薩。在王捨大城靈鷲山法會。承佛印可。宣說法要。即從大部般若流出。為摩訶般若所攝。自梵譯漢。共有十四本。本詮所據則為

    唐三藏法師玄奘譯。
    李淵受隋帝禪。國號曰唐。三藏者。經、律、論。經詮一心；律規三業；論開慧辯。法者，軌也。師者，範也。法雖可軌，弘之在人。上弘大法，下為人師者，謂之法師。兼通經、律、論三藏法門，堪為人師表者，謂之三藏法師。
    【注】法師有五。一，受持法師。信力故受。念力故持。謂於如來言教，以堅固深信受之於己，憶持不忘，是為受持法師。二，讀經法師。對文曰讀。謂正心端坐，目睹經文，口宣句讀，是為讀經法師。三，誦經法師。背文曰誦。謂習讀既熟，不須對文，自然成誦，是為誦經法師。四，解說法師。謂以聖教之義，分明解釋，訓授於人，是為解說法師。五，書寫法師。謂於諸經典書寫廣傳，流通大法，是為書寫法師。見《法華文句·八·上》。
    法師法名玄奘。偃師陳氏子。本名褘。少窮困。十三歲。隨兄長捷出家於洛陽淨土寺。就慧景聽《涅槃經》。於嚴法師受《攝大乘論》。武德元年。與兄共入長安。尋赴成都。就道基、寶遷二師學《攝論毘曇》。就震法師聽講《發智論》五年。受具足戒。又習律部。旋往荊州講《攝論毘曇》。往相州參慧休。趙州參道深。入長安尋道岳學《俱舍論》。貞觀三年八月。出國西行。至五印度。歷西域百二十八國。徧訪大德參究。留學中印摩竭陀國之那爛陀寺。受業於戒賢論師、勝軍居士。歷治婆沙、俱舍、顯揚、順理、對法、因明、唯識諸論。而於瑜伽造詣尤深。貞觀十九年正月歸長安。以所獲梵典六百五十七部上於朝。二月六日。太宗使於弘福寺傳譯。貞觀二十二年五月二十四日。在終南山翠微宮翻經院譯本經成。示寂於麟德元年二月五日。世壽六十五。凡譯經十九年。成七十三部。一千三百三十卷。
    譯者。傳也。傳譯四夷之語。又陳也。陳設外內之言。又釋也。以彼此語言謄釋而通之也。又易也。換易言語使相解也。譯經者以此方之文。顯彼土之法。翻梵天之語。成漢土之言。言雖似別。義則大同。本經奘師主譯。筆受者沙門智仁也。
    【注】《涅槃經》有小乘、大乘二部。小乘《涅槃經》譯本有三。《佛般泥洹經》二卷，西晉白法祖譯。《大般涅槃經》三卷，東晉法顯譯。《般泥洹經》三卷。失譯人名。皆說八相化身成道之釋迦佛。於拘尸那城入涅槃前之情狀。《中阿含經》中有《涅槃經》。則說可得涅槃之觀行。大乘涅槃經。有《佛說方等泥洹經》二卷，西晉竺法護譯《大般泥洹經》六卷。東晉法顯譯《四童子三昧經》。隋闍那崛多譯。雖廣略不同。皆為大乘涅槃經之初分。北涼曇無讖譯《大般涅槃經》四十卷，稱北本涅槃。劉宋慧觀再治為三十六卷，稱南本涅槃。說涅槃非灰身滅智。及佛性常住不滅。唐若那跋陀羅譯《大涅槃經後分》二卷。說佛之付囑及荼毗分骨等事。以補充前經。亦稱《後分經》。
    成都。古蜀山氏。今改縣。為四川省治。
    攝論。即《攝大乘論》，無著菩薩造。毗曇即阿毗曇，新譯作阿毗達摩，此云無比，亦云對法。又小乘薩婆多部之論藏。如《發智》、《六足》（法蘊足、施設足、集異門足、識身足、界身足、品類足）、《毗婆娑》、《俱舍》諸論。亦總名《毗曇》。《發智論》為《阿毘達摩發智論》之略稱。佛滅後三百年。迦多衍尼子造。《俱舍論》即《阿毘達摩俱舍論》之略稱。世親菩薩造。
    貞觀為唐太宗年號。
    荊州。今湖北省江陵縣。相州。今河南省安陽縣。趙州。今河北省趙縣。長安。今陝西省長安縣。
    五印度即五天竺。《西域記》云。五印度之境。周九萬餘里。三垂大海。北背雪山。北廣南狹。形如半月。摩竭陀為中印度國名。王舍城所在。五印度中最大之國。那爛陀寺。為菩提道場之大覺寺東七驛。佛滅後。鑠迦羅阿逸多王所建。嗣君佛陀鞠多王。咀他揭多鞠多王。婆羅阿逸多王。先後增修。為五印度最大精舍。
    《婆娑論》為《阿毘達摩婆娑論》之略稱。佛滅後四百年。健陀羅國迦膩色迦王選五百聖眾造。《顯揚論》為《顯揚聖教論》之略稱，又名《總包集義論》，無著菩薩造。《順理論》為《阿毘達摩順正理論》之略稱，尊者眾賢造，以駁世親菩薩之俱舍論者，又名《俱舍雹論》。《對法論》即《阿毗達摩雜集論》，安慧菩薩造。《因明論》即《因明正理論》，陳那造。《因明入正理論》，陳那弟子商羯羅主造。《唯識論》即《唯識二十論》，世親菩薩造。《瑜伽論》即《瑜珈師地論》，彌勒菩薩造。
    終南山。在陝西省長安縣東五十里。東至藍田縣。西至郿縣。綿亙八百餘里。
    麟德。為唐高宗年號。
    周禮掌四方之語。各有其官。東方曰寄。南方曰象。西方曰狄鞮。北方曰譯。此特命官之別，其事則統謂之譯，謂之象胥，如越裳重譯之稱，見於《尚書大傳》是也。
    譯場受譯主之言。筆之以漢音。謂之筆受。宋時譯經院職司。準《佛祖統紀·四十三》所載凡九。一，譯主。正坐面外。宣傳梵文。二，證義。坐譯主之左。與譯主評量梵文。三，證文。坐譯主之右。聽譯主高讀梵文。以驗錯誤。四，書字。梵學僧審聽梵文。書成華字。猶是梵音。五，筆受。繙梵音成華言。六，綴文。回綴文字。使成句義。七，參譯。參考兩土文字。使無舛誤。八，刊定。刊削冗長，決定句義。九，潤文。南向設位。參詳潤色。
    《般若波羅蜜多心經詮注·卷二》


第一項 能修之人

    《般若波羅蜜多心經詮注·卷三·上》
     震旦白衣周止菴學

    第二篇 正釋經文

    正釋經文者。正謂純一不雜。釋謂解釋開演。經文含義深奧非解莫明。解以起信。信以生願。願以成行。故詮釋經文。必期有當經恉。本經所示。有顯有密。緣經生解。分為二章。第一，顯說般若。第二，密說般若。顯說令生慧解。密說令生福德。為滅二障。成二嚴故。
    【注】二障。亦名二礙。一，煩惱障。謂見思二惑。起種種昏煩之法。惱亂心神。障礙無漏法性。名煩惱障。二，所知障。亦名智障。執所知之法。障蔽智慧之性。名所知障。
    二嚴者。一，智慧莊嚴。研智慧而為身之莊嚴。六度中修般若者是。二，福德莊嚴。積福德而為身之莊嚴。六度中修檀那尸羅羼提毗梨耶禪那五度者是。

    第一章 顯說般若

    清涼釋經。於本章準常三分。謂序、正、流通。所謂彌天高判。今古同遵也。本經奘師譯本。既僅具正宗分。故前卷已依別譯三分之義。略說少分。以下即依經文次序。分別詮釋。
    顯者，無隱之義。說者，釋明意旨也。更分四節述之。

    第一節 因人顯法
    本節更分四項

    第一項 能修之人

    觀自在菩薩
    此五字有通有別。上三字是別名。別諸菩薩故。下二字是通號。通諸菩薩故。
    觀自在。梵語阿縛盧枳多伊濕伐羅。阿縛盧枳多。此云觀。伊濕伐羅。此云自在。多伊二字合音作底。故或作阿縛盧枳底濕伐羅。又梵名阿黎耶婆婁吉底輸。則譯作聖觀世音。蓋梵本自有二名。觀音表悲。自在表智。且此二名皆同於古佛。聖聖相承。先後一揆。
    【注】自在為八地以上菩薩通具之德。觀自在則為菩薩專有之名。二者不可混同。自在者。無滯義。菩薩修行教化。調伏一切眾生。圓滿菩提。神通無礙也。《華嚴大疏·六》有二義。一，觀境自在。謂菩薩以正智慧。照了真如之境。及能通達一切諸法。圓融自在也。二，作用自在。謂菩薩既以正智照了真如之境。由體起用。現身說法。化度眾生。圓融自在也。《大乘莊嚴經論·五》有四義。一，得分別自在。菩薩住不動地。捨一切功用之行。得無功用法。於一切法。遠離一切分別之想。而得自在也。二，得剎土自在。菩薩住不動地。深心清淨。於諸剎土。得清淨出生自在也。三，得智自在。菩薩住善慧地。得無礙智慧。演說諸法。稱理自在也。四，得業自在。菩薩住法雲地。於諸煩惱業縛。悉能通達。更無障礙也。《大寶積經·六十八》有五義。一，壽命自在。菩薩成就法身慧命。了無生死壽夭。延萬劫而不長。促一念而不短。但為度脫有情。以方便隨機示現長短壽命之相。其心無所罣礙也。二，生自在。菩薩為度脫有情。以大悲心隨類受生。饒益一切處。天宮非樂。地獄非苦。去住無礙也。三，業自在。菩薩萬行具足。悲智雙運。或現神通。或說妙法。或入禪定。或修苦行。所作行業。但為利他。縱任無礙也。四，覺觀自在。麤心曰覺。細心曰觀。菩薩或修禪觀。或起利生。雖有思惟。離諸散亂。隨願度生。平等無礙也。五，眾具果報自在。菩薩因行深廣。果報殊勝。於一切所須之具。不假經營。自然周具。心無染礙也。《華嚴經·三十八》有十義。一，命自在。菩薩得長壽慧命。經無量阿僧祇劫。住持世間。無有障礙也。二，心自在。菩薩智慧方便。調伏自心。能入無量諸大三昧。遊戲神通。無有障礙也。三，資具自在。謂菩薩能以無量珍寶。種種資具。嚴飾一切世界清淨。無障無礙也。四，業自在。謂菩薩能隨諸業。應時示現。受諸果報。無障無礙也。五，受生自在。謂菩薩隨其心念。能於諸世界中示現受生。無障無礙也。六，解自在。謂菩薩勝解成就。能現種種色身。演說妙法。無障無礙也。七，願自在。謂菩薩隨所願欲。於諸剎中應時出現。成等正覺。無障無礙也。八，神力自在（《十地經論》作如意自在）。謂菩薩神通廣大。威力難量。於世界中示現變化。無障無礙也。九，法自在。謂菩薩得大辯才。於諸法中廣能演說無邊法門。無障無礙也。十，智自在。謂菩薩具足智慧。於一念中能現如來十力（一，知是處非處智力。如來於一切因緣果報。審實能知。如作善業定得樂報。名知是處。若作惡業得受樂報。無有是處。名知非處。二，業異熟智力。如來於一切眾生過、現、未三世業報。皆悉徧知。三，知種種界智力。如來於世間眾生種種界分。皆如實知。四，知種種勝解智力。如來於諸世間種種勝解。皆如實知。五，知諸根勝劣智力。如來於諸有情諸根勝劣。皆如實知。六，知徧趣行智力。如來於一切徧趣行。皆如實知。七，知一切道品智力。如來於諸根、力、覺支、道支、靜慮、解脫、等持、等至、雜染、清靜皆如實知。八，知死生智力。如來證知天眼清淨。見諸眾生生時、死時、端正、醜陋、善惡、業緣無不徧知。九，知宿住隨念智力，如來於眾生宿命，死此生彼，姓名、飲食、苦樂、壽命如實徧知。十，知漏盡智力。於諸漏盡無漏心解脫。無漏慧解脫。皆如實知。了知我生已盡。梵行已立。所作已辦。不受後有。諸漏永盡）。無畏（由十力智內充。於大眾中凡有所說。無恐懼相。名無所畏。一，正等覺無畏。於世出世間一切諸法。盡知盡見。說法無畏也。二，漏盡無畏。惑業生死俱盡。安隱無所畏也。三，說障法無畏。說惑業等諸障法無所畏也。四，盡苦道無所畏。說戒定慧等諸盡苦之正道。而無所畏也）。成等正覺（諸佛無上之正智）。無所障礙也。
    觀自在。具足應云觀世自在。觀音。具足應云觀世音。唐人以避太宗諱。略去世字。後遂相沿。云此二名皆同於古佛者。《準無量壽經》。阿彌陀佛在因位時。於世自在王所出家。故阿彌陀佛本師為世自在王。《無量壽經鈔·二》云。義寂云。舊本名樓夷亙羅。翻之名自在王。法藏比丘成佛以後。即觀依本師而得此名。《菩提心義·十》曰。彼佛壽命無量。光明無量。眷屬無量。一切皆無量。故以立諡號。而本名觀自在王如來。眼如四大海。徧觀法界眾生。隨其機緣。拔苦與樂。故為名也。菩薩以阿彌陀佛為本師。師資相承。亦受此號。《大悲心陀羅尼經》。佛言。此菩薩名觀世音自在。《華嚴經·入法界品》。鞞瑟胝羅居士。告善財言。於此南方。有山名補怛洛迦。彼有菩薩。名觀自在。是為菩薩得名觀自在之由來。《楞嚴經·觀世音菩薩圓通章》。爾時觀世音菩薩。即從座起。頂禮佛足而白佛言。世尊。憶念我昔無數恒河沙劫。於時有佛出現於世。名觀世音。我於彼佛發菩提心。彼佛教我從聞思修入三摩地。又云。彼佛如來歎我善得圓通法門。於大會中授記我為觀世音號。由我觀聽十方圓明。故觀音名。徧十方界。《弘猛海慧經》。昔閻浮提有王名善首。有五百王子。第一太子名善光。在空王觀世音佛所發願。願我未來作佛。字觀世音。善光太子。即菩薩因地之名。《悲華經》。寶藏佛尋為授記。善男子。汝觀天、人、及三惡道一切眾生。生大悲心。欲斷眾生諸苦惱故。欲斷眾生諸煩惱故。欲令眾生住安樂故。善男子。今當字汝為觀世音。是為菩薩得名觀世音之由來。而此二名。皆同古佛。
    菩薩聖號。唐以前譯經。皆作觀世音。其作觀自在者。自玄奘法師始自後譯者。或作觀自在。或作觀世音。按觀自在。梵名為阿縛盧枳多伊濕伐羅。觀世音。梵名為婆婁古底輸。二名即一菩薩。則或譯觀自在。或譯觀世音。本無分別。或以西藏所譯諸經作無作觀世音者為疑。夫漢、藏契經。同出梵文。梵文既有二名。譯文互通。自不能執藏文以疑漢譯。又或以觀世音為意譯。觀自在為直譯者。是亦不然。因自在與世音。各有含義也。
    交光云。觀世音名。具彰二利之德。而所觀不同。《法華經》。苦惱眾生。一心稱名。菩薩即時觀其音聲。皆得解脫。則所觀者。世間音聲。蓋果門唯顯利他之德也。《楞嚴經》。由我觀聽十方圓明。故觀音名。徧十方界。則所觀者。聽音根性。蓋因門多彰自利之源也。《觀音玄義》云。能所圓融。照窮本性。故稱觀世音。是所觀之境。萬象流動。隔別不同。類音殊唱。俱蒙離苦。菩薩弘慈。一時普救。皆令解脫。世者為三。一，五陰世間。二，眾生世間。三，國土世間。釋迦所說。以音聲為佛事。故言觀世音。孤山云。觀即能照之智。世即所照之境。音即所照之機。以觀其音聲。即得解脫故。續法師《觀經直指疏》云。觀聽十方圓妙明音。是自行號。令彼十方苦惱眾生。觀其音聲。即得解脫。是利他號。
    《法華文句·十·下》云。觀有多種。謂析觀、體觀、次第觀、圓觀。析觀者，滅色入空也；體觀者，即色是空也；次第觀者，從析觀乃至圓觀也；圓觀者，即析觀是實相乃至次第觀亦實相也。今簡三觀惟論圓觀。世亦多種，謂有為世、無為世、二邊世、不思議世。有為世者，三界世也；無為世者，二涅槃也；二邊世者，生死、涅槃也；不思議世者，實相境也。今簡諸世，但取不思議世。音者，機也。機亦多種，人天機、二乘機、菩薩機、佛機。人天機者，諸惡莫作，眾善奉行也；二乘機者，厭惡生死，欣尚無為也；菩薩機者，先人後己，慈悲仁讓也；佛機者，一切諸法中，悉以等觀入一切無礙人，一道出生死也。今簡諸音之機，惟取佛音之機，名觀世音。《宗鏡錄·三十六》云：言觀一字，理有二種。一，觀矚。二，觀察。初觀矚者。如前五識緣五塵境。矚對前境。顯現分明。無推度故。現量性境之所攝故。次觀察者，向自識上安模建立。伺察推尋境分劑故。

    觀自在菩薩。不但名同古佛。其本地亦已早證妙覺。以大悲願力。普度眾生故。現作菩薩。為西方極樂世界阿彌陀佛左輔。位階補處。道成正覺。以般若妙智。觀照世間一切緣起實相。破除人法二執。觀空不著空。觀有不著有。根塵俱消。空有無礙。觀聽圓明。得大自在。能現眾生妙容。能說無邊秘密神咒。現一一形。誦一一咒。化身無量。無剎不現。成就三十二應。十四無畏。四不思議功德巍巍。度人最勝。
    【注】本地者。對於垂跡之稱。初地以上法身之菩薩及佛。由法身實體。應化以度眾生。其實體為本地。化身為垂跡。地者。能生之義。能現之本為本地。所現之末為垂跡。台宗於此立四句。一，本高跡下。如菩薩現聲聞身。二，本下跡高。如菩薩現佛身。三，本跡俱高。如佛現佛身。四，本跡俱下。如初地菩薩現初地之相也。見《法華玄義釋簽·十五》。菩薩本地早證妙覺者。妙覺即佛。《準觀音三昧經》。佛說。觀音在我前成佛。名正法明如來。我為苦行弟子。《千光眼觀自在菩薩秘密法經》。佛說。觀自在菩薩。在我前成佛。號曰正法明。十號具足。《大悲心陀羅尼經》。佛告阿難。此觀世音自在菩薩。有不可思議威神之力。於過去無量無數阿僧祇劫前。已成佛竟。號曰正法明如來。大悲願力。為欲成熟安樂一切眾生故。現作菩薩。
    彌陀三聖。一，阿彌陀佛。悲智二德全備。二，觀世音菩薩。主悲門。位於佛之左位。三，大勢至菩薩。主智門。位於佛之右位。故稱觀世音菩薩為彌陀左輔。
    嗣前佛而成佛之菩薩。即補前佛之處謂之補處。等覺菩薩。無明之惑未盡。尚有一番變易生死。過此一生。即登妙覺果佛之位。所以等覺菩薩。稱為一生補處。等者平等。覺者覺悟。大乘階位五十二位中。第五十一位之菩薩曰等覺。去佛之妙覺尚有一等。是菩薩之極位。《悲華經·三》。阿彌陀佛般涅槃已。菩薩於一念中間。成阿耨多羅三藐三菩提。號徧出一切光明功德山王如來。《觀世音菩薩受記經》。阿彌陀佛正法滅後。過中夜分。明相出時。觀世音菩薩於七寶菩提樹下。結跏跌坐。成等正覺。號普光功德山王如來。普光即徧出一切光明。文異義同。
    緣起者。待緣而起。故名緣起。亦云緣生。《俱舍論·九》。諸支因分。說名緣起。由此為緣。能起果故。諸支果分。說緣已生。由此皆從緣所生故。
    二執者。人執法執。人執執我為有。故又名我執。《成唯識論》云。我執略有二種。一者。俱生。二者。分別。俱生我執。無始時來。虛妄熏習。內因力故。恒與身俱。不待邪教及邪分別。任運而轉。故名俱生。此復二種。一，常相續。在第七識。緣第八識起自心想。執為實我。二，有間斷。在第六識。緣識所變。五取蘊相。或總或別。起自心想。執為實我。此二我執細。故難斷。後修道中數數修習勝生空觀。方能除滅。分別我執。非與身俱。必待現在外緣邪教邪分別。然後方起。惟在第六意識中有。此亦二種。一，緣邪教所說蘊相起自心相。分別計度。執為實我。二，緣邪教所說我相。起自心相。分別計度。執為實我。此二我執麤。故易斷。初見道時。觀一切法生空真如。即能除滅。法執亦有二。一者。俱生。二者。分別。俱生法執。以無始時。虛妄熏習內因力故。恒與身俱。不待邪教及邪分別。任運而轉。故名俱生。此復二種。一，常相續。在第七識緣第八識起自心相。執為實法。二，有間斷。在第六識緣識所變蘊、處、界、相。或總或別。起自心相。執為實法。此二法執細。故難斷。後十地中數數修習勝法空觀。方能除滅。分別法執。亦由現在外緣力故。非與身俱。要待邪教及邪分別。然後方起。惟在第六意識中有。此亦二種。一，緣邪教所說蘊、處、界、相。起自心相。分別計度。執為實法。二，緣邪教所說自性等相。起自心相。分別計度。執為實法。此二法執麤。故易斷。入初地時。觀一切法空真如。即能除滅。蓋此身由五蘊四大假合而成。名之為人。凡夫就此假名。妄執為我。本經說五蘊皆空。即為破此我執而悟人空。二乘計五蘊之法為實有。致生法執。本經說般若深慧。徹見五蘊皆空。即為破此法執而悟法空。
    觀空不著空者。菩薩以無相妙慧。照無相境。內外俱寂。《楞嚴經·六》曰：從聞思修入三摩地。初於聞中。入流亡所。所入既寂。動靜二相。了然不生。如是漸增。聞所聞盡。盡聞不住。覺所覺空。空覺極圓。空所空滅。生滅既滅。寂滅現前。即證此境。觀有不著有者。菩薩諦觀貪瞋癡等一切惡行。起於妄念。妄念起於顛倒。顛倒起於我見。了達我性本空。翻破無明昏闇。不著者。無執之義。無執則無繫縛。無繫縛則得解脫。非空之空。故曰真空。異於小乘偏執之但空。非有之有。故曰妙有。異於凡夫妄計之實有。非有非空。是為中道。《寶藏論》云。非有非空。萬物之宗。非空非有。萬物之母。
    根塵俱消者。如《楞嚴經·六》曰：根結若除。塵相自滅。諸妄銷亡。不真何待。空有無礙者。般若非有相非無相。非亦有亦無相。非非有非無相。一切諸法。本非偏有偏空。空為即有之空。有為即空之有。互融雙絕而不相礙。菩薩諦觀中道。以空觀破有執。有觀破空執。遣虛存實。理事無礙也。
    觀聽圓明。得大自在者。菩薩心精遺聞。見聞覺知不能分隔。成一圓融清淨寶覺。故能六根互用。無分觀聽。同一妙明真性。無適而不自在。《事觀解》云。實相觀照。救世自在。此約智悲說。觀音救苦。恒在那伽（《俱舍論·十三》云：那伽行在定。住在定。臥在定。坐在定）。此約慧定說。《法華》真、淨、智、慈、悲五觀。定也。妙、觀、梵、潮、勝五音。慧也。均等自在。五觀中。前三，智也。後二，悲也。五音中。三、四悲也。餘三智也。正顯智悲並運。真俗融通。上同下合。得大自在。此是帶果行因號也。圓測云。內證二空。外觀三業。不依功用。任運自在。一者。戒自在。二者。定自在。三者。慧自在。四者。心自在。從自行化他說。菩薩從聞思修入三摩地。觀聽圓明。得大自在。此自修自在也。又得無作妙力。自在成就。隨類現身。應機說法。此度生自在也。大自在者。從體起用。廣大之法力也。《法華經·弟子授記品》曰：諸佛有大自在神通之力。《大般涅槃經·二十三》。八大自在。一，能示一身為多身。二，示一塵身滿於三千大千世界。三，以滿此三千大千世界之身。輕舉飛空。過於二十恒河沙等諸佛世界。而無障礙。四，如來一心安住不動。而可示化無量形類。或造一事，而令眾生各各成辦。常住一土。而令他土一切悉見。五，諸根互用。一根能見色聞聲、嗅香、別味、覺觸、知法。亦能六根不見色，不聞聲，不嗅香，不別味，不覺觸，不知法。六，得一切法亦無得想。以無所得故。以無得故。名得涅槃。七，說一偈義。經無量劫不盡。八，如來徧滿一切諸處。猶如虛空。虛空之性。不可得見。如來亦爾。以自在故。令一切見。是為如來八大自在。菩薩以古佛垂化。救護眾生。故亦得大自在也。能現眾多妙容者。如《楞嚴經》曰。或現一首、三首、五首、七首、九首、十一首，如是乃至一百八首、千首、萬首、八萬四千爍迦羅（此云輪。又堅固不壞如金剛也）首。二臂、四臂、六臂、八臂、十臂、十二臂、十四、十六、十八、二十至二十四，如是乃至一百八臂、千臂、萬臂、八萬四千母陀羅（此云印）臂。二目、三目、四目、九目，如是乃至一百八目、千目、萬目、八萬四千清淨寶目。或慈或威。或定或慧。救護眾生。得大自在也。
    能說無邊秘密神咒者。既曰無邊。自不可以數計。《大般若經》曰。言無邊者。邊不可得。不可測度彼邊際故。姑就大藏中所見者。例舉一二。如《不空罥索陀羅尼經》《千手千眼觀世音菩薩廣大圓滿無礙大悲心陀羅尼經》《十一面觀世音菩薩經》《觀世音菩薩如意輪陀羅尼經》《青頸大悲心陀羅尼經》《葉衣觀自在菩薩經》《三世最勝心明王經》《千光眼觀自在菩薩秘密法經》《觀自在菩薩說普賢陀羅尼經》《怛嚩多唎隨心陀羅尼經》《請觀世音菩薩消伏毒害陀羅尼經》《阿唎多羅陀羅尼·阿嚕力品》《千轉陀羅尼觀世音菩薩咒》《大乘莊嚴寶王經》《觀世音菩薩秘密藏神咒經》《大方廣曼殊室利經》《一切如來名號陀羅尼經》《八大曼拏羅經》《陀羅尼集經》《陀羅尼雜集》《現證三昧大教王論》《菩薩所說神咒》已無慮數百種。為無邊秘密神咒中少分中之少分。行者但能清淨三業。任擇一種或數種。虔心持誦。久之自有不可思議之感應。惟誠則靈。行者勉之。
    菩薩所說神咒。流通最廣者。為大悲心陀羅尼。及六字大明王咒（見《大乘莊嚴寶王經·四》）。白衣大士咒（《陀羅尼雜集·十·觀世音說應現與願陀羅尼》咒語同）。二十一度母總度母咒（頻伽藏成字十三冊。聖救度佛母二十）。《種禮讚經》《磧砂藏·五百六十三冊》《佛說大方廣曼殊室利經·觀自在為多羅菩薩說陀羅尼》咒語均同。《陀羅尼集經·五·觀世音菩薩心印咒》日本《續藏經·楞嚴經》述旨二一五頁所引白衣咒。大致亦同）等。其持誦儀軌及手印真言等。詳見拙著《大悲心陀羅尼經補註》。
    現一一形者。即現眾多妙容也。菩薩應化示現。隨類而異其形。圖畫普門品有三十三觀音之像。一，楊柳觀音。二，龍頭觀音。三，持經觀音。四，圓光觀音。五，遊戲觀音。六，白衣觀音。七，蓮臥觀音。八，瀧見觀音。九，施藥觀音。十，魚籃觀音。十一，德王觀音。十二，水月觀音。十三，一葉觀音。十四，青頸觀音。十五，威德觀音。十六，延命觀音。十七，眾寶觀音。十八，岩石觀音。十九，能靜觀音。二十，阿耨觀音。二十一，阿麼提觀音。二十二，葉衣觀音。二十三，琉璃觀音。二十四，多羅尊觀音。二十五，蛤蜊觀音。二十六，六時觀音。二十七，普慈觀音。二十八，馬郎婦觀音。二十九，合掌觀音。三十，一如觀音。三十一，不二觀音。三十二，持蓮觀音。三十三，灑水觀音。不知所據何經考之二中 歷三。《三十三觀音頌》曰。不空罥索。不空勾。夜輪多羅。忿怒勾。阿魯利迦。如意輪。圓滿意願。大隨求。利樂金剛。滅惡趣。一髻羅剎。多羅女。蓮華髮生。披葉衣。千手千眼。十一面。大吉祥明。水吉祥。大吉祥變。大勢至。大明白身。毗俱胝。大吉大明。及豐財。馬頭。白身。白處尊。又加六大（即六觀音）三十三。數雖相同。而名稱不符。且十一面為六觀音之一，此處又另有十一面。則除去重出。亦未足三十三之數。《大本如意經》有八大觀音。一，圓滿意願明王菩薩。二，白衣自在。三，髻羅剎女。四，四面觀音。五，馬頭觀音。六，毗俱胝。七，大勢至。八，陀羅觀音。《諸尊真言句義抄》中有十五觀音。一，正觀音。二，千手觀音。三，馬頭觀音。四，十一面觀音。五，準胝觀音。六，如意輪觀音。七， 不空罥索觀音。八，白衣觀音。九，葉衣觀音。十，水月觀音。十一，楊柳觀音。十二，阿麼提觀音。十三，多羅觀音。十四，青頸觀音。十五，香王觀音。此外散見諸經及陀羅尼者。尚有四臂觀世音。六臂觀世音。十二臂觀世音。隨心觀世音。多唎心觀世音。一嗟三缽底迦囉觀世音等。《天台玄義》有六觀音。一，大悲觀音。二，大慈觀音。三，師子無畏觀音。四，大光普照觀音。五，天人丈夫觀音。六，大梵深遠觀音。《摩訶止觀·二》云。大悲觀世音。破地獄道三障。此道苦重。宜用大悲。大慈觀世音。破餓鬼道三障。此道飢渴。宜用大慈。師子無畏觀世音。破畜生道三障。獸王威猛。宜用無畏。大光普照觀世音。破阿修羅道三障。此道猜忌嫉疑。宜用普照。天人丈夫觀世音。破人道三障。人道有事有理。事伏憍慢稱天人。理則見佛性稱丈夫。大梵深遠觀世音。破天道三障。梵是天主。標主得臣也。密宗亦有六稱。一，千手觀音。同上大悲。二，聖觀音。同上大慈。三，馬頭觀音。同上師子無畏。四，十一面觀音。同上大光普照。五，準胝觀音。同上天人丈夫。六，如意輪觀音。同上大梵深遠。聖觀音亦稱聖觀自在。為諸觀音之總體。又有二十五觀自在。一，代苦觀自在。二，與智觀自在。三，施滿觀自在。四，除戟觀自在。五，除愚觀自在。六，進道觀自在。七，觀正觀自在。八，施無畏觀自在。九，施光觀自在。十，與甘露觀自在。十一，見天觀自在。十二，施妙觀自在。十三，見樂觀自在。十四，降魔觀自在。十五，靜慮觀自在。十六，作文觀自在。十七，見禪觀自在。十八，愍定觀自在。十九，調直觀自在。二十，空惠觀自在。二十一，護聖觀自在。二十二，清靜觀自在。二十三，正法觀自在。二十四，離欲觀自在。二十五，不動觀自在。見菩薩所說陀羅尼中。此外尚有。一，摩尼與願觀自在。二，持索觀自在。三，寶缽觀自在。四，寶劍觀自在。五，金剛觀自在。六，持杵觀自在。七，除怖觀自在。八，日精觀自在。九，月精觀自在。十，持寶弓觀自在。十一，速值觀自在。十二，藥王觀自在。十三，拂難觀自在。十四，持瓶觀自在。十五，現怒觀自在。十六，鎮難觀自在。十七，持環觀自在。十八，分荼利觀自在。十九，見佛觀自在。二十，鏡智觀自在。二十一，見蓮觀自在。二十二，見隱觀自在。二十三，仙雲觀自在。二十四，禪定觀自在。二十五，天花觀自在。二十六，破賊觀自在。二十七，念珠觀自在。二十八，持螺觀自在。二十九，縛鬼觀自在。三十，法音觀自在。三十一，智印觀自在。三十二，鉤召觀自在。三十三，慈杖觀自在。三十四，現敬觀自在。三十五，不離觀自在。三十六，大勢觀自在。三十七，般若觀自在。三十八，不轉觀自在。三十九，灌頂觀自在。四十，護地觀自在。又有：一，持杵觀音。二，大勢觀音。三，寶缽觀音。四，日精觀音。五，持索觀音。六，榜排觀音。七，白拂觀音。八，月精觀音。九，寶弓觀音。十，寶經觀音。十一，白蓮觀音。十二，紫蓮觀音。十三，寶箭觀音。十四，胡瓶觀音。十五，青蓮觀音。十六，蒲桃觀音。十七，寶鏡觀音。十八，玉環觀音。十九，頂上觀音。二十，軍持觀音。二十一，紅蓮觀音。二十二，錫杖觀音。二十三，化佛觀音。二十四，數珠觀音。二十五，寶螺觀音。二十六，髑髏觀音。二十七，寶篋觀音。二十八，五色雲觀音。二十九，安鉞斧觀音。三十，戟鞘觀音。三十一，楊柳觀音。三十二，寶鐸觀音。見《千光眼觀自在菩薩秘密法經》。菩薩從體起用。以一身現眾多妙容。非凡情所能測度。此所說者。僅其少分而巳。
    菩薩現形為摩尼與願觀自在。作慈悲體。身黃金色。頂有十一面。當前三面。為菩薩相。右邊三面。白牙出上相。左邊三面。忿怒相。當後一面。暴笑相。頂上一面。如來相。菩薩本面有三目。以袈裟、瓔珞、環等。莊嚴妙體。坐紅蓮座。處月輪中。半跏而坐。右押左。左手當心持摩尼。其珠吠琉璃色。黃光發燄。右手與願契屈臂向上。如上二十五菩薩形像。等同無異。惟所持法寶，各各不同。見《千光眼觀自在菩薩秘密法經》。
    菩薩現形為千手千眼聖尊時。如《千光眼觀自在菩薩秘密法經》說，觀自在菩薩，為眾生故，具足千臂。其眼亦爾。略說四十手法。其四十手分為五部。一者。如來部。二者。金剛部。三者。摩尼（此云寶）部。四者。蓮華部。五者。羯嚕磨（此云事業）部。一部之中。各配八手。其五部中。亦有五法。一者。息災法。用佛部尊。所以有化佛手。罥索手。施無畏手。白拂手。榜排手。鉞斧手。戟矛手。楊柳手。二者。調伏法。用金剛部尊。是故有跋折羅手。金剛杵（此用獨鈷）手。寶劍手。宮殿手。金輪手。寶缽手。日摩尼手。月摩尼手。三者。增益法。用摩尼部。是故有如意珠手。寶弓手。寶經手。白蓮手。青蓮手。寶鐸手。紫蓮手。蒲桃手。四者。敬愛法。用蓮華部。所以有蓮華合掌手。寶鏡手。寶印手。玉環手。胡瓶手。軍持手。紅蓮手。錫杖手。五者。鉤召法。用羯磨部。所以有鐵鉤手。頂上化佛手。數珠手。寶螺手。寶箭手。寶篋手。髑髏手。五色雲手。隨其所欲。無不成辦。菩薩住無畏地。得二十五三昧。壞二十五有。於千光王靜住如來所。親受大悲心陀羅尼已。超第八地。心得歡喜。發大誓願。應時具足千手千眼。即入三昧。名無所畏。於三昧光中。湧出二十五菩薩。身皆金色。具諸相好。如觀自在。各於頂上具十一面。身上具四十手。每手掌中有一慈眼（二十五菩薩各具四十手眼。合為千手千眼）。此二十五化菩薩。或入無垢三昧。破地獄有。或入無退三昧。壞畜生有。或入心樂三昧。壞餓鬼有。或入歡喜三昧。壞阿修羅有。或入日光三昧。破東勝神洲有。或入月光定。斷西牛貨洲有。或入熱炎定。破北上勝洲有。或入如幻三昧。斷南瞻部洲有。或入不動定。破四天處有。或入難伏三昧。斷忉利天有。或入悅意定。斷炎摩天有。或入青色三昧。破兜率天有。或入黃色三昧。破化樂天有。或入赤色三昧。斷他化自在天有。或入白色三昧。斷初禪有。或入種種三昧。破梵王有。或入雙三昧。破二禪有。或入雷音三昧。破三禪有。或入注雨定。斷四禪有。或入如虛空定。壞無想有。或入照鏡三昧。破淨居阿那含有。或入無礙三昧。斷空處有。或入常三摩地。壞識處有。或入樂三摩地。破無所有處有。或入我三摩地。壞非想非非想處有。菩薩成就諸三昧王。以一法身現二十五。亦以二十五現多菩薩（以上二十五菩薩。各從四十手現四十菩薩）。其一千菩薩。一一各於頂上具十一面。於其本面而有三目。一一如是具二十五。各於一界有四十菩薩。一一界中各配千眼皆是觀自在大悲所為。
    觀世音菩薩。顯教以為阿彌陀佛之弟子。如《大悲心陀羅尼經》。菩薩稱阿彌陀如來為本師是也。密教則以為阿彌陀佛之化身。如《大日經·一》曰。北方大精進。觀世自在者。光色如皓月。商佉（此云螺貝）軍那華（西方有此華。色鮮白）。微笑坐白蓮。髻現無量壽是也。《大日經疏·五》云。大日右方置大精進觀世自在者。即是蓮華部主。謂如來究竟觀察十緣生句。得成此普眼蓮華。故名觀自在。約如來之行。故名菩薩。頂現無量壽者。明此行之極果。即是如來普門方便智。《龍樹十二禮》云。觀音頂戴冠中住。種種妙相寶莊嚴。能伏外道魔憍慢。故我頂禮彌陀尊。亦以觀音為彌陀化身也。
    行者欲修觀世音菩薩觀想。應觀觀世音菩薩身長八十萬億那由他由旬。身紫金色。頂有肉髻。頂有圓光。面各百千由旬。其圓光中有五百化佛。如釋迦牟尼。一一化佛。有五百化菩薩。無量諸天以為侍者。舉身光中。五道眾生一切色相。皆於中現。頂上毗楞伽摩尼寶以為天冠。其天冠中有一立化佛。高二十五由旬。觀世音菩薩。面如閻浮檀金色。眉間毫相。備七寶色。流出八萬四千種光明。一一光明。有無量無數百千化佛。一一化佛。無數化菩薩以為侍者。變現自在。滿十方世界。臂如紅蓮華色。有八十億微妙光明。以為瓔珞。其瓔珞中普現一切諸莊嚴事。手掌作五百億雜蓮華色。手十指端。一一指端。有八萬四千畫。猶如印文。一一畫有八萬四千色。一一色有八萬四千光。其光柔軟。普照一切。以此寶手。接引眾生。舉足時。足下有千輻輪相。自然化成五百億光明台。下足時。有金剛摩尼華。布散一切。莫不彌滿。其餘身相。眾好具足。如佛無異。惟頂上肉髻。及無見頂相。不及世尊。是為觀世音菩薩真實色身相。見《觀無量壽佛經》。
    《聖救度佛母二十一種禮讚經》中之總度母本尊。舊稱多羅觀自在菩薩。即南海普陀山之觀世音菩薩也。見《瑜珈精舍印行》之《聖救度佛母修持法》。按多羅菩薩。為胎藏界曼陀羅觀音院三十七尊之一。即多羅觀音。蓮華部之部母也。觀音有定慧二德。毗俱胝主慧。多羅主定。作女人狀。《大日經·一》曰。彼右大稱名。聖者多羅尊。青白色相雜。中年女人狀。合掌持青蓮。圓光無不徧。暉發猶淨金。微笑鮮白衣。《大方廣曼殊室利經》曰。多羅大悲者。一切之慈母。天人及藥叉。無一非子者。故號世間母。《大日經疏·五》云。此是觀自在三昧。故作女人像。多羅是眼義。青蓮華是淨無垢義。以慈眼攝受群生。故作中年女人像。此皆菩薩從體起用。種種化身之一。《楞嚴經》所謂或慈、或威、或定、或慧。現女相者，表慈、表定而已，非本體為女身。蓋界內色界天以上。已無女身。何況已超三有之菩薩。彌陀大願。女人往生。尚不復為女像。何況彌陀左輔。世間供養。多作女相者。自唐以後始然。一由誤於傳說。二由不明菩薩化身無量之義也。
    誦一一咒者。即無邊秘密神咒。其同體形咒。如大悲心陀羅尼。以一身心現千手眼。照見法界。護持眾生。其異體形咒。則對異機而現異形。於異身而說異咒。或現身脫其苦惱。或說咒遂其願求。其形其咒。能以無畏施諸眾生是也。
    化身者。通義名應化身。變化身。《佛地論·七》云。變化身者。為欲利益安樂眾生。示現種種變化事故。從狹義說。則分應化為二。《大乘義章·十八》云。為化眾生。示現佛形。名為應身。示現種種六道之形。說為化身。無量者。廣大之異名。《大般若經·三百二十九》曰。言無量者。量不可得。《攝大乘論·十八》云。不可以譬類得知為無量。
    無剎不現者。菩薩慈護眾生。無私覆。無私載。如日月之經天。如江河之行地。尋聲救苦。無處不現。《法華經·普門品》。所謂十方諸國土。無剎不現身也。
    《楞嚴經》說菩薩三十二應入諸國土。一，佛身。二，獨覺身。三，緣覺身。四，聲聞身。五，梵王身。六，帝釋身。七，自在天身。八，大自在天身。九，天大將軍身。十，四天王身。十一，四天王太子身。十二，人王身。十三，長者身。十四，居士身。十五，宰官身。十六，婆羅門身。十七，比丘身。十八，比丘尼身。十九，優婆塞身。二十，優婆夷身。二十一，女主、國夫人、命婦、大家身。二十二，童男身。二十三，童女身。二十四，天身。二十五，龍身。二十六，藥叉身。二十七，乾闥婆身。二十八，阿修羅身。二十九，緊那羅身。三十，摩睺羅身。三十一，人身。三十二，非人身。與《法華經·普門品》普現色身示現之三十二應。大同小異。普門品併獨覺身、緣覺身為辟支佛身。無四天王身。而有毗沙門身。無人王身，四天王太子身。而有小王身。無女主、國夫人、命婦、大家身。而有長者居士宰官婆羅門婦女身。別有迦樓羅身及執金剛神身。則《楞嚴經》所無。《大乘莊嚴寶王經》觀自在現身說法。除佛身、緣覺身、聲聞身、大自在天身、梵王身、帝釋身、龍身、藥叉身、人王身、宰官身外。亦示現菩薩身、那羅延身、日天子身、月天子身、火天身、水天身、風天身、頻那夜迦身、多聞天王身、父母身。《大方廣曼殊室利經》。佛說觀自在菩薩摩訶薩。以清淨身。能為眾生作諸佛事。示現佛身、摩醯首羅身、帝釋身、迦樓羅身、緊那羅身、摩呼羅伽、悉地、明仙、日月、星宿、童男、童女種種之身。乃至異類。二足、四足、多足、無足、有情、無情、三界之身。而得度者。即皆現之而為說法。總之菩薩普門示現。隨類度生。非有限量。即瞋心最重禁入鐵地之大力阿蘇囉王。及其眷屬。亦現阿蘇囉身。為說《大乘莊嚴寶王經》。於苦趣最重不能聞法之大阿鼻地獄。放大光明。以拔其苦。又入餓鬼大城。十指毛孔。皆出大河。使餓鬼飲之。業火悉滅。變成清涼。菩薩悲願之深。不可以凡情測度。誠如《寶王經》佛說。觀自在菩薩摩訶薩。變現種種。救度無數百千萬俱胝那庾多有情。令得往生極樂世界。見無量壽如來。得聞法要。皆令得成菩提道也。《法華》《楞嚴》所云三十二應。不過如來於說法時略示其例而已。以菩薩位而能現佛身者。以菩薩帶果行因。雖在因位。已得佛之受用。上合諸佛同一慈力故。以菩薩過去劫前早已成佛故。
    十四無畏者。《楞嚴經》觀世音菩薩以金剛三昧無作妙力。與諸十方三世六道一切眾生。同一悲仰。令諸眾生獲得十四種無畏功德。一，不自觀音以觀觀者。不自觀音者。謂不自聲塵起知見也。以觀觀者。謂返照自性也。不起知見則無所妄。返照自性則一切真寂。無復苦惱。故令受苦眾生蒙此真觀。即得解脫。二，知見旋復。在心曰知。在眼曰見。菩薩旋轉知見以復真空。三，觀聽旋復。觀聽性動。則屬於水。菩薩旋轉觀聽以復真空。四，斷滅妄想。心無殺害。妄想作業。以殺為首。菩薩證悟實性。斷滅妄想。大慈不殺。化導祥和。五，熏聞成聞。六根銷復。同於聲聽。熏聞屬思。思其所聞。無性可得。則成真聞。六根害人。兵刃無異。菩薩六根銷盡。以復真空。一切塵境。同於聲聽。六，聞熏精明。明徧法界。菩薩從聞熏習所成慧性。明照十方。幽霾潛消。七，音性圓消。觀聽返入。菩薩動靜性滅。聲塵解脫。故其觀聽。返妄入真。八，滅音圓聞。徧生慈力。菩薩消滅音聲。圓成聞慧。徧生慈力。以濟群生。九，熏聞離塵。色不能劫。菩薩以思慧熏聞成性。離諸塵妄。不為色劫。能令一切多婬眾生。遠離貪欲。十，純音無塵。根境圓融。菩薩音性純淨。離諸妄塵。根境相入，圓融無礙。十一，銷塵旋明。菩薩除暗銷塵。旋復性明。能令一切昏鈍無善心人。癡暗遠離。十二，融形復聞。融形則礙滅。復聞則性真。菩薩涉入世間。而不壞世間相。十三，六根圓通。明照無二。菩薩六根圓融。通達無礙。含攝法界。如大圓鏡。晶瑩朗徹。明照無二。故能承順法門。受領無失。十四，菩薩一名與六十二億恒河沙諸法王子名。等無有異。菩薩得真圓通。一即一切。一切即一。平等圓融。更無分際。四不思議無作妙德者。理空非惑情可測。神奇非淺識所量。是曰不思議。任運自在。非出有為。是曰無作。觀自在菩薩。四不思議無作妙德。一者。能現眾多妙容。說無邊秘密神咒。救護眾生。得大自在。二者。十方微塵。無剎不現。能以無畏施諸眾生。三者。眾生見者。咸生歡喜。不惜身財。以求哀愍。四者。能以珍寶。供養如來。亦令眾生所求世出世法。無不隨願。
    法月譯本。觀世音菩薩入慧光三昧正受後。以三昧力行深般若波羅蜜多。照見五蘊皆空。乃至無智亦無得。已到佛地究竟境界。或謂菩薩猶未成佛。何能臻此極果。按觀世音菩薩。於過去久遠劫前。已成佛道。以悲心殊勝。故倒駕慈航。垂形六道。示菩薩願行。助諸佛宏化。與一般登地以上之法身大士不同。此觀經中所示修證境界可以知之。

    菩薩具名菩提薩埵。此云覺有情。舊譯作道眾生。分釋之。菩提是道義。覺悟義。無上智慧義。薩埵是有情義。薩遮。此云有。埵。此云情。一切有知覺者皆有情識也。自行成就。轉以覺悟眾生。謂之菩薩。故有自行、化他兩利三義。從自行說。菩薩雖分證如來。識情未盡。悟性真常。了惑除妄。此自覺義。從化他說。菩薩以悲憫心。運無緣慈。開悟一切有情。同登彼岸。此覺他義。從兩利說。菩薩上求大覺。下化有情。歷劫修因。行滿果圓。自他並利。是名菩薩。觀自在菩薩以等覺身。運無緣慈。悲憫眾生。故說此經。
    【注】菩薩有地前地上之別。未到初地。謂之地前菩薩。凡夫之菩薩也。初地以後。謂之地上菩薩。法身之菩薩也。薩埵舊譯眾生。惟眾生兼含有生命而無情感之植物。故不如新譯有情。較為確切。《唯識述記》云。薩埵此言有情，有情識故。又情者。性也。有此性故。愛也。能有愛生故。言眾生者。不盡理也。

    觀自在菩薩為本經說法之人。舊時說經者。如唐釋靖邁。謂登地以上諸大士。通有此德。非專指彌陀左輔。明·釋宗泐《心經註解》。亦以觀自在為能修般若之菩薩。但按法月、法成、智慧輪及施護各譯本。本經係世尊於靈鷲山中。入三摩地甚深光明。菩薩承佛威神宣說此經。即世尊大部般若之精要。菩薩所說。即是佛說。
    《連珠記》引不空譯云。菩薩白言。我欲於會中說諸菩薩普徧智藏般若波羅蜜多心。蒙佛聽許。入慧光定。照五蘊空。度苦厄等。鄭重宣說。不應但具通德之號。不顯本名。且諸經稱觀自在菩薩者。皆指觀世音菩薩。或且連稱為觀世音自在。蓋自在誠為八地以上菩薩所通具之德。而觀自在菩薩則為特定之稱。《心經幽贊》云。或處上位。諸具大心。妙慧成就。皆觀自在。或指示此令矚曰觀。非住西方來遊此者。彼《大經》中。不別顯故。意亦謂非專指彌陀左輔之觀世音。為後來釋經者異說所從起。但細按本經所說般若心要。與《大般若經》佛告舍利子者。大致相同。《大般若經》初分，至八分，及十五分，皆薄伽梵住王舍城鷲峰山頂所說。當日法筵清眾。觀自在菩薩摩訶薩。與得大勢菩薩摩訶摩訶薩。妙吉祥菩薩摩訶薩連名並列。《大品般若》則以觀世音菩薩與文殊師利菩薩同次。不可謂大經不別顯。《大經》與《心經》說法時處相同。所說無異。則當般若會中。佛告舍利子以後。菩薩承流宣化。闡演佛說。重告舍利子以般若心要。其為西方遊此彌陀左輔之觀自在菩薩。無可致疑。且依《千光眼觀自在菩薩秘密法經》。佛說。我念往昔時。觀自在菩薩於我前成佛。號曰正法明。十號具足。我於彼時。為彼佛下作苦行弟子。蒙其教化。今得成佛。十方如來。皆由觀自在教化之力故。於妙國土。得無上道。轉妙法輪。則依佛說可徴觀自在菩薩為正法明如來垂跡之號。決不可誤解為一般能觀自在之菩薩也。
    【注】《大般若經·四·初分相應品·第三之一》。舍利子。諸色空。彼非變礙相。諸受空。彼非領納相。諸想空。彼非取緣相。諸行空。彼非造作相。諸識空。彼非了別相。何以故。舍利子。色不異空。空不異色。色即是空。空即是色。受想行識不異空。空不異受想行識。受想行識即是空。空即是受想行識。何以故。舍利子。是諸法空相。不生。不滅。不染。不淨。不增。不減。非過去。非未來。非現在。舍利子。如是空中無色。無受想行識。無地界。無水火風空識界。無眼處。無耳鼻舌身意處。無色處。無聲香味觸法處。無眼界。無耳鼻舌身意界。無色界。無聲香味觸法界。無眼識界。無耳鼻舌身意識界。無眼觸。無耳鼻舌身意觸。無眼觸為緣所生諸受。無耳鼻舌身意觸為緣所生諸受。無無明生。無無明滅。無行，識，名，色，六處，觸，受，愛，取，有，生，老死，愁嘆苦憂惱生。無行，乃至愁嘆苦憂惱滅。無苦聖諦。無集，滅，道，聖諦。無得。無現觀。無預流。無預流果。無一來。無一來果。無不還。無不還果。無阿羅漢。無阿羅漢果。無獨覺。無獨覺菩提。無菩薩。無菩薩行。無佛。無佛菩提。舍利子。修行般若波羅蜜多菩薩摩訶薩。與如是等法相應。故當言與般若波羅蜜多相應。又四百三。第二分觀照品第三之二。四百八十。第三分舍利子品第二之二。佛告舍利子文均相同。
    《大品般若經二·習應品·第三》。舍利弗。色空故。無惱壞相。受空故。無受相。想空故。無知相。行空故。無作相。識空故。無覺相。何以故。舍利子。非色異空。非空異色。色即是空。空即是色。受想行識。亦如是。舍利弗。是諸法空相。不生。不滅。不垢。不淨。不增。不減。是空法。非過去。非未來。非現在。是故空中無色。無受想行識。無眼耳鼻舌身意。無色聲香味觸法。無眼界，乃至無意識界。亦無無明。亦無無明盡。乃至亦無老死。亦無老死盡。無苦集滅道。亦無智。亦無得。亦無須陀洹。無須陀洹果。無斯陀含。無斯陀含果。無阿那含。無阿那含果。無阿羅漢。無阿羅漢果。無辟支佛。無辟支佛道。無佛亦無佛道。舍利弗。菩薩摩訶薩如是習應。是名與般若波羅蜜多相應。
    王舍城。梵語羅閱祇伽羅。羅閱祇，此云王捨。伽羅，此云城。在中印度摩伽陀國。鷲峰山。梵語耆闍崛。亦云靈鷲山。有五峰。東名象頭。西名羊頭。南名馬頭。北名師子頭。中云鷲頭。從形稱也。有五精舍。一，天主穴山精舍。二，七葉穴山精舍。三，蛇神穴山精舍。四，少獨力山精舍。五，耆闍崛山精舍。即鷲峰山頂佛說法處也。


第二項　所修之法

    行深般若波羅蜜多時。
    行。梵語散娑歌囉。亦作遮梨夜。經歷義。以無漏淨慧。歷觀諸法。故名為行。又修行義。即因地所修清淨法行也。徧依十信、十住、十行、十迴向、四加行、十地以至等覺、妙覺諸位。依次修習。名差別行。亦名徧成諸行。依圓融法門。於諸位中。隨修一行。即具一切諸行。名普賢行。亦名頓成諸行。從聞而思。從思而修。故曰修行。
    【注】十信為入三賢之基。修萬行之首。五十二大乘階位中。從凡入聖之第一步。佛法無量。惟信為先。所謂信為道源功德母也。一，信心。心與理冥。決了無礙。妙信常住。中道純真。一切妄想。滅盡無餘。名曰信心。二，念心。無數劫中。捨身受身。憶念無忘。名曰念心。三，精進心。不雜曰精。無間曰進。進趣真淨。名精進心。四，慧心。心精現前。純以智慧。深入佛法。名曰慧心。五，定心。寂妙常凝。念慮皆忘。慧心明澈。湛然不動。名曰定心。六，不退心。定光發明。進修無懈。明性深入。名不退心。七，護法心。進趣功純。保持不失。十方如來。氣分相接。名護法心。八，迴向心。修持妙力。迴佛慈光。向佛安住。名迴向心。九，戒心。安住淨戒。心光常凝。名曰戒心。十，願心。徧遊十方。化導眾生。隨其所願。悉得滿足。名曰願心。此十信中。初信為初心。中間八信為住心。第十信為滿心。
    十住。又名十解。又名十發趣。以發起大心。趣入妙道也。由信而入。入則能住。一，發心住。以真方便。發十信心。圓成一心。名發心住。二，治地住。以前妙心。履以成地。名治地住。三，修行住。心地涉知。俱得明了。徧修諸行。皆無留礙。名修行住。四，生貴住。冥契妙理。行與佛同。氣分感通。成如來種。名生貴住。五，方便具足住。一切種智。具足成就。自行利他。方便不缺。名方便具足住。六，正心住。容貌如佛。心相不異。名正心住。七，不退住。身心增長。無有退缺。名不退住。八，童真住。十身（聲聞身。緣覺身。菩薩身。如來身。法身。智身。國土身。業報身。眾生身。虛空身。又如來身復具十身。菩提身。願身。化身。力持身。相好莊嚴身。威勢身。意生身。福德身。法身。智身。）靈相。一時具足。名童真住。九，法王子住。長養聖胎。紹隆佛種。名法王子住。十，灌頂住。表以成人。陳列灌頂。名灌頂住。
    十行者。菩薩經十信十住已成佛子。滿足自利。更進修利他之行也。增修善根。滋培長養。故又名十長養。一，隨順眾生。自他俱利。名歡喜行。二，饒益眾生。使得法利。名饒益行。三，自覺覺他。得無違拒。名無瞋恨行。四，豎徧三際。橫周十方。隨類示現。轉化無窮。名無盡行。五，了達法門。悉無錯誤。名離癡亂行。六，同異圓融。無差別相。名善現行。七，塵界交現。不相留礙。名無著行。八，無著行成。皆緣般若。六度之中。此為第一。名尊重行。九，妙觀慧中。顯圓融德。諸佛執持。名善法行。十，體即真如。無漏清淨。一真無為。性本然故。名真實行。十迴向。迴即迴轉。向即趨向。堅固不動。故又名十金剛。亦名十願。前之住行。出俗心多。大悲心少。此則濟以悲願。處俗利生。迴真向俗。迴智向悲。真俗圓融。智悲不二。於修十行後。神通滿足。以大悲心救度眾生。迴轉十行之善。向於三處。一，真如實際是所證。二，無上菩提是所求。三，一切眾生是所度。以能迴之心。及所迴善行。向彼萬類。圓滿萬行。等入法界。所謂迴因向果。迴自向他。迴事向理也。一，救護一切眾生離眾生相迴向。化度眾生。滅除度相。迴無為心。向涅槃路。二，不壞迴向。正顯中道。歸趣本覺。壞其可壞。遠離諸離。三，等一切佛迴向。本覺之性。湛然常住。能覺之智。齊於佛覺。四，至一切處迴向。能覺之智。無處不徧。既證真如。地如佛地。五，無盡功德藏迴向。一切世界。一切如來。互相涉入。得無罣礙。六，隨順平等善根迴向。於諸佛地。起萬行因。依因發揮。取涅槃道。七，隨順等觀一切眾生迴向。十方眾生。皆我本性。性圓成就。不失眾生。八，真如相迴向。離妄曰真。不異曰如。即一切法。離一切相。不即不離。二無所著。九，無縛無著解脫迴向。真如既現。智慧明了。互攝圓融。自在無礙。十，等法界無量迴向。性海圓成。法界量滅。含攝徧周。其量無外。
    四加行者。煖、頂、忍、世第一，之四善根也。為三賢入初地之準備。於十迴向之終。修四尋思四如實觀得之（四尋思者。一，名尋思。謂於諸法之中。推求一切名字。皆悉不實。二，事尋思。謂於諸法之中。推求五陰等事。生滅無常。皆悉不實。三，自體假立尋思。謂於諸法能詮名字。及所詮義理中。推求自體。惟是假立名言。皆悉不實。四，差別假立尋思。謂於諸法能詮之中。推求差別。惟是假立名言。皆悉不實。行者觀此四法。皆是自心所變。如幻虛假。尋求思察。假有實無。謂之四尋思觀。以此推求之觀為因。而生印可決定之智。不惟如實了知所取所緣之名等四法。為自性所變。假有實無。且了知印可能取能緣之名等四法。亦為假有實無。謂之四如實觀）。煖者。以佛覺用為己心。如火欲然。名為煖地。唯識宗謂之明得定。以初得無漏慧之明相也。頂者。以自心成佛。如登高山。身入虛空。下有微礙。名為頂地。唯識宗謂之明增定。以明相轉盛也。忍者。心佛兩同。善得中道。如忍事人。非懷非出。名為忍地。唯識宗謂之印順定。以無所取決定所持。無能取亦順樂忍也（忍有三品。下品名印忍。印所取無故。中品名樂順。樂無能取，順彼修故。上品名印順。印能取無，順觀彼故。故曰印順）。世第一者。以前三位。位位遞變。謂之世數。中邊各別。謂之間量。此位則加行位滿。無可遞變。邊中不立。亦無間量可得。煖位以佛覺為己心。頂位以自心為佛境。忍位則覺於中道。此位迷覺兩忘。中邊不立。雖未證理。於世間已為最勝。名為世第一。唯識宗謂之無間定。以能取所取。二空雙印。從此無間入見道位也。初地見道。名出世間。今是世間最後邊際。尚屬有漏。但在世間已為第一。若進十聖。極乎妙覺。則為出世間第一。
    十地之名。《準大乘同性經》所說。四乘不同。分列如次。
    聲聞乘十地。一，受三歸地。初受三歸之位。二，信地。信根成就之位。三，信法地。信四諦理之位。四，內凡夫地。修五停心觀等之位（五停心觀。一，不淨觀。觀境界不淨之相。停止貪欲之法。貪著心多者修之。二，慈悲觀。觀一切有情可憐之相。停止瞋恚之法。瞋心多者修之。三，因緣觀。觀十二因緣三世相續之理。停止愚癡之法。癡心盛者修之。四，界分別觀。分別諸法六界，或十八界，停止我見之法。我見多者修之。五，持息念觀。計呼吸數以停止散亂心之法。散心多者修之。或併界分別觀於因緣觀。而加觀佛觀。觀佛相好以治一切煩惱。業障多者修之）。五，學信戒地。三學（戒定慧）成就之位。六，八人地。見道之位（人者。忍也。八忍。即苦法忍、集法忍、滅法忍、道法忍、苦類忍、集類忍、滅類忍、道類忍）。七，須陀洹地。預流果之位。八，斯陀含地。一來果之位。九，阿那含地。不還果之位。十，阿羅漢地。無學果之位（聲聞乘四果。前三果為有學。阿羅漢果為無學。進趣圓滿。止息修習。故名無學）。
    緣覺乘十地。一，苦行具足地。修戒行之位。二，自覺甚深十二因緣地。修十二因緣觀法之位。三，覺了四聖諦地。修四諦觀之位。四，甚深利智地。生甚深無相智之位。五，八聖道地。修八聖道之位（聖者。正也。亦名八正道）六，覺了法界虛空界眾生界地。覺了此三界之位。七，證寂滅地。見道之位。八，六通地。得六神通之位（《宗鏡錄·十五》，明通有五種。一，道通。二，神通。三，依通。四，報通。五，妖通。此其一也。神者。不測之義。通者。無礙之義。一，神足智證通。又名神境通。身如意通。變現不思議境界。游涉往來自在之力也。二，天眼智證通。得色界天眼根。照視無礙。三，天耳智證通。得色界天耳根。聽聞無礙。四，他心智證通。知他人之心念。五，宿住隨念智證通。知自己及六道眾生之宿命。此五通為依有漏禪定。及咒力藥力所得。故外道仙人亦能有之。六，漏盡智證通。諸漏斷盡。一切無礙。為三乘之極致）。九，徹秘密地。證無學果之位。十，習氣漸薄地。侵減習氣之位。侵入見思二惑餘習之氣分而減輕之。蓋此位在緣覺乘為極地。在三乘共通十地中。則為第八辟支佛地。見思餘習至菩薩地而斷。至佛地而盡。故此位僅可云侵減。
    菩薩乘十地。《智度論·四十九》。謂之但菩薩地。一，歡喜地。菩薩初得聖性。破見惑。證二空理。生大歡喜。證徧行真如（徧一切諸法）。離異生性障。成就檀波羅蜜。二，離垢地。異性入同。同性亦滅。證最勝真如（斷無邊德。於一切法為最勝）。離邪行障。成就戒波羅蜜。三，發光地（有光地）。淨極明生。智慧顯發。證勝流真如（所流教法。於餘法中最勝故）。斷暗鈍障。成就忍辱波羅密。四，燄慧地（增曜地）。慧性熾盛。明極覺滿。證無攝受真如（不為我執所攝取故）斷微細煩惱現障。成就精進波羅蜜。五，極難勝地。求同異相。皆不可得。諸佛境界。無能勝者。證類無差別真如（非如眼耳等有類別故）。斷下乘涅槃障。成就禪波羅蜜。六，現前地（現在地）。無為真如。性淨明露。證無染淨真如（本性原來無染故）。斷粗相現行障。成就般若波羅蜜。七，遠行地（深入地）。盡真如際。證法無差別真如（教法雖多。無差異故）。斷細相現行障。成就方便波羅蜜。八，不動地。作無相觀。一真如心。證不增減真如（不隨染淨而有增減故）。斷無相中作加行障。成就願波羅蜜。九，善慧地（善相地）具足十力。發真如用。證智自在真如（以四無量智。起四無礙解。即法無礙解。義無礙解。詞無礙解。樂說無礙解）。斷利他門中不欲行障。成就力波羅蜜。十，法雲地。慈蔭妙雲。覆涅槃海。具足無邊功德。證業自在所依真如（得三業、五通、總持、禪定、四自在故）。斷於諸法中未得自在障。成就智波羅蜜。
    佛乘十地。一，甚深難知廣明智德地。除細習氣。於諸法皆得自在。二，清淨身分威嚴不思議明德地。轉正法輪。顯深義自在。三，善明月幢寶相海藏地。開說三乘差別之法自在。四，精妙金光功德神通智德地。說八萬法降四魔自在。五，火輪威藏明德地。摧異邪法。伏惡行自在。六，虛空內清淨無垢燄光開相地。現六神通。示無常事自在。七，廣勝法界藏明界地。為諸菩薩顯菩提自在。八，最淨普覺智藏能淨無垢徧無礙智通地。為諸菩薩受記莂自在。九，無邊億莊嚴回向能照明地。為諸菩薩現方便自在。十，毘盧遮那智海藏地。為諸菩薩能說法自在。佛在果地。本無差別。此十地皆為諸佛境界。非二乘及菩薩之所能行。
    《大般若經》所說十地。則為一，淨觀地。二，種性地。三，第八地。四，具見地。五，薄地。六，離欲地。七，已辦地。八，獨覺地。九，菩薩地。十，如來地。《智度論·四十九》以聲聞緣覺菩薩共通之十地。為共地。即台宗所立之通教十地也。一，乾慧地。欲習初乾。未得法性理水之潤。故屬外凡。二，性地。伏見思惑。見法性空。故屬內凡。三，八人地。人者。忍也。見道十五心之位。八忍七智。以八忍賅之也。四，見地。斷三界之見惑。見四諦理。即見道十六心之道類智也。五，薄地。斷欲界九品思惑中前六品之惑。得真諦理之位也。六，離欲地。斷盡欲界後三品思惑。離欲界生死之位也。七，已辦地。斷盡色無色界思惑。發真無漏之位也。八，辟支佛地。緣覺既斷三界見思二惑。更侵減見思惑餘習之氣分也。九，菩薩地。菩薩從空入假。深觀真俗二諦。進斷見思習氣與塵沙惑。得法眼淨。成道相智之位也。十，佛地。菩薩覺行圓滿。進趣妙覺之位也。
    菩薩乘十地。已預聖流。但據《法華經疏》。菩薩為化度眾生。前三地寄於人天諸乘。中四地寄於出世間三乘。後三地超世出世間。屬於佛乘。進修因行以顯證果。一，歡喜地。初地菩薩。既修檀那。示現世間以作人王。寄於人乘。二，離垢地。二地菩薩。修十善行。示現欲界。以作天王。寄欲界天乘。三，發光地。三地菩薩修色界四禪，無色界四空處定。行同於四禪四空。寄色無色界天乘。四，燄慧地。四地菩薩。初斷見惑。與形俱生身。觀三十七道品。同於初果。寄須陀洹乘。五，難勝地。五地菩薩。修四諦行。同於四果。寄阿羅漢乘。六，現前地。六地菩薩。觀於因緣。覺悟真空。同於緣覺。寄緣覺乘。七，遠行地。七地菩薩。修菩提行。涉入三界。不捨度生。寄菩薩乘。八，不動地。八地菩薩。證阿含德。及不住道。契合實理。離相離言。九，善慧地。九地菩薩。以無量智。觀察無邊世界。說法教化眾生。十，法雲地。十地菩薩。法身如雲。普覆眾生。意業自在。受勝職位。皆超世出世間。寄顯一乘。《仁王經》曰。十信為粟散王。十行為銅輪王。十迴向為銀輪王。初地為金輪王。二地為忉利天王。三地為夜摩天王。四地為兜率天王。五地為化樂天王。六地為他化天王。七地為初禪王。八地為二禪王。九地為三禪王。十地為四禪王。《華嚴》《瓔珞》等經。亦有菩薩寄報天王之說。
    以上十住十行十迴向諸位菩薩。雖已斷見思惑。尚有無明。未入聖位。故稱三賢。名異生性。十地菩薩。與佛體同。則稱十聖。名同生性。
    諸經論建立地位。多寡不同。如《法華》《瓔珞》等經。以十信、十住、十行、十迴向、十地、等覺、妙覺、五十二位為大乘階位。《仁王經》攝等覺於第十地為五十一位。大品攝十信於發心住為四十二位。華嚴攝等覺於十地為四十一位。四加行則為由三賢入初地之準備。故曰加行而不列位。《楞嚴經》則並列乾慧地與四加行為五十七位。加三漸次則為六十聖位。《法華玄義》云。三乘之初。同名乾慧。即是體發五停心。別相總相。住是觀中。修正勤、如意、根、力、覺、道。雖未得煖法相似理水。而總相智慧深利。故曰乾慧地。《智度論》釋乾慧地。有二。一者。聲聞為涅槃故。勤精進。持戒清淨。堪任受法。集諸善道。捨不善法。雖有智慧。不得禪定水。則不能得道。名乾慧地。二者。菩薩從初發心。乃至未得順忍（五忍中第三。五忍。即伏忍、信忍、順忍、無生忍、寂滅忍也）者。皆名乾慧地。《楞嚴經·長水疏》云。於乾慧心增明觀智以為方便。得入十信。亦在信位以前。至十地後。則獲金剛心中初乾慧地。
    等覺者。大乘階位五十二位中之第五十一位。與妙覺佛果。僅次一位。菩薩之極位也。自十信、十住、十行、十迴向，為地前菩薩。直至初地。歷第一阿僧祗劫。自二地至七地。歷第二阿僧祗劫。自八地至此位。歷第三阿僧祗劫。智慧功德。與諸佛等。故名等覺。望於妙覺。猶有一等。故名等覺。亦名一生補處。亦名金剛心菩薩。亦名無垢地菩薩。
    妙覺為大乘階位中之極地。自覺覺他。覺行圓滿。不可思議。即佛果之無上正覺也。二乘止於自覺。菩薩自覺覺他。未能圓滿。獨佛二覺圓滿。不可思議。故曰妙覺。
    《唯識論》於入道次第。束之為五位。一，資糧位。以十信、十住、十行、十迴向之四十位。具修種種福智。資益菩提法身。故名資糧位（資糧有二種。施、戒、忍，三波羅蜜多。是福德資糧。般若波羅蜜多。是智慧資糧。精進波羅蜜多。靜慮波羅蜜多。二資糧攝。若為智慧而行精進，是智慧資糧。若為福德而行精進，是福德資糧。若緣無量而修靜慮。是福德資糧。餘是智慧資糧）。二，加行位。即煖、頂、忍，世第一，之四加行。名加行位。三，通達位（見道位）。從加行入初地之菩薩。以無漏真智。體會真如。智照於理。得見中道。名通達位。四，修習位（修道位）。二地以上乃至等覺菩薩。依無分別智。斷分別起二障。依生法二空智。斷俱生二障種子及其習氣。證得菩提涅槃二轉依果。名修習位。五，究竟位。諸漏永盡。清淨圓明。得成無上正等正覺。證妙覺果。即佛果極地。謂之大乘五位。攝論則束為四位。一，勝解行位（始十信。終地前）。二，見道位。三，修道位。四，究竟位。至小乘五位。則以修五停心觀及別想念總想念者（小乘行人於修五停心觀之後。就苦諦而修之四念處觀。念是觀慧。處者境也。《大般若經》謂之四念住。有別相念處總相念處之二。別相念處者。分所觀之境為身、受、心、法，之四者。追順而別觀之。但於第四法念處。分雜緣、不雜緣，之二。不雜緣法念處。惟觀法之一境。雜緣法念處。於身受或身等四境合觀。蓋法塵通於前三也。總相念處者。於雜緣法念處之後念。不分身受等之四者。總合而觀諸有為法為無常。觀諸有漏法為苦。觀一切法為空、無我。故名總相念處。別相與總相。在於前境之分不分。又能觀之行相。別相為不淨、苦、無常、無我。總相為無常、苦、空、無我）為資糧位。四加行為加行位。斷三界見惑。證聲聞初果（須陀洹）者。為見道位。修四諦法。斷欲界思惑。證聲聞二果（斯陀含）三果（阿那含）者。為修道位。斷三界見思惑盡。證聲聞四果（阿羅漢）者。為無學位。《瑜伽》及《顯揚論》。入道次第。復依十三住分立七地。地者。攝持義。住者。受用居止義。一，種姓住（一，本性住種性。謂無始來依附本識。法爾所得無漏法因。二，習所成種性。謂聞法界等流法已。熏習所成）。但有大乘性根。未發無上菩提。十信位也。二，勝解行住。從發心住以至初地菩薩。修習諸行。勝解現前。十住、十行、十迴向、四加行，之地前菩薩也。三，極喜住。初地菩薩也。四，增上戒住。二地菩薩也。五，增上心住。三地菩薩也。六，覺分相應增上慧住。四地菩薩也。七，諸諦相應增上慧住。五地菩薩也。八，緣起相應增上慧住。六地菩薩也。九，有加行有功用無相住。七地菩薩也。十，無加行無功用無相住。八地菩薩也。十一，無礙解住。九地菩薩也。十二，最上成滿菩薩住。十地菩薩也。並攝等覺。十三，如來住。則妙覺佛果也。此十三住中。種姓住名種性地。勝解行住名勝解行地。極喜住名淨勝意樂地。增上戒住。增上心住。及三種增上慧住。有加行有功用無相住。名行正行地。無加行無功用無相住。名決定地。無礙解住。名決定行地。最上成滿菩薩住。如來住。名到究竟地。
    修行者。信解行證四法之一。如理修習作行也。通於身語意之三業。《法華經·藥草喻品》曰。漸漸修行。皆得道果。《無量壽經》曰。應當信順。如法修行。

    深。邃也。難見義。諸法空相。難可思議。名為甚深般若波羅蜜多。深般若波羅蜜多。即甚深境界之般若波羅蜜多。能取一切法空相故。人法俱空。色心齊遣。境觀兩忘。非凡夫二乘所知。菩薩依其能觀之慧。行此甚深境界般若波羅蜜多。如《解深密經》說。觀自在菩薩。復白佛言。世尊。菩薩以何等波羅蜜多。取一切法無自性性。佛告觀自在菩薩曰。善男子。以般若波羅蜜多。取法無自性性。又此般若波羅蜜多。善達空相。名深般若波羅蜜多。修此行故。名行深般若波羅蜜多。《心經贊》云。行謂進行。是能觀智。深有二種。一者。即行深。以無分別智。內證二空。離諸分別。無能所行以為行相。故曰行深。《大品》曰。不見行。不見不行。是名菩薩行深般若。二者。境深。謂二空理。離有無相。絕諸戲論。無分別智。證此深境。故曰行深。是知般若之體。約教有二。一，深。二，淺。淺者名人空般若。破除我執。但見於空。不見不空。為聲聞、緣覺、菩薩三乘所同修故。亦名共般若。此慧現前。但證偏真。故名為淺。深者名法空般若。既破我執。又破法執。不但見空。又見不空。盡破三惑。永斷二死。證入諸法第一義空。為菩薩所獨修。非權教三乘所共故。亦名不共般若。此慧若顯。能至菩提。故名為深。《大般若經》曰。甚深般若波羅蜜多。無相無狀。無言無說。又曰。菩薩摩訶薩行深般若波羅蜜多時。能以離相無漏之心。而行六種波羅蜜多。由離相無漏心力。能於一切無相、無覺無得、無影、無作、法中。圓滿六種波羅蜜多。亦能圓滿諸餘功德。又曰。善現白佛言。如是般若極為甚深。佛言。一切法甚深故。般若波羅蜜多甚深。是故般若波羅蜜多名極甚深。又曰。此法甚深。難見難覺。不可尋思。過尋思境。微妙沖寂。聰敏智者之所能知。非諸世間。卒能信受。謂深般若波羅蜜多。即是如來、應、正等覺所證無上正等菩提。又曰。舍利子。修行般若波羅蜜多時。不見諸法有覺有用。見一切如幻事。如夢境。乃至如變化事。都非實有。聞說諸法本性皆空。深生歡喜。當知是菩薩能行般若波羅蜜多。菩薩摩訶薩。行般若波羅蜜多時。不見菩薩。不見菩薩字。不見般若波羅蜜。不見我行般若波羅蜜。亦不見我不行般若波羅蜜。誠以修行之要。首須遣盡聞思諸慧。澈悟真空。由無所得無分別故。無行無不行。是名為行。是名為行深般若波羅蜜多。
    【注】《連珠記》云。人我執無處所顯真如。名人空。法我執無處所顯真如。名法空。如為所顯。智是能顯。二執空無。故名二空。廣承云。共般若者。三乘同修。二乘但見於空。不見不空。鈍根菩薩亦然。空即偏真。是故為淺。不共般若者。則圓菩薩所修。菩薩不見但空。但見不空空。即中道法界。故名深。菩薩久已入實。將說此經。示為儀式耳。
    三乘共修人空般若。轉五蘊成五分法身。一，轉色蘊成戒身。二，轉受蘊成定身。三，轉想蘊成慧身。四，轉行蘊成解脫身。五，轉識蘊成解脫知見身。大乘菩薩修法空般若。轉五蘊成三德。三德者。摩訶涅槃那也。此云大滅度。大者法身。即真如之理。滅者解脫。即自在之用。度者般若。即會真之智。轉色蘊成法身德。轉受想行三蘊成解脫德。轉識蘊成般若德。
    《小鈔》云。諸宗抑般若但為空教。恐謂菩薩空觀。亦同小乘人空。《賢首略疏》。正明菩薩此觀。真空絕相。頓入華嚴法界。已當八部般若無相大乘之極致。故曰行深般若也。
    第一義空。諸法中最第一法。名為涅槃。涅槃之法。空無有相。是名第一義空。
    離相者。三相之一。一，解脫相。無生死之相也。二，離相。無涅槃之相也。三，滅相。生死涅槃之無相。其無相亦無。即非有非無之中道也。無漏者。離煩惱之法。惑業已斷。不漏落於生死也。無相者。諸法悉空。名為無相。《大乘義章》云。言無相者。釋有二義。一，就理彰名。絕眾相故名無相。二，就涅槃法離十相（色聲香味觸男女生住滅）。故名無相。無覺者。初心在緣曰覺。覺知心亡。謂之無覺。無得者。體無相之真理。心中無所執著。無所分別之空慧也。無影者。一切受與相續俱滅。名為無影。亦名寂滅。無作者。不假身口意之動作。自然相續之法也。
    法之幽妙為之深。深之極度謂之甚深。甚深為如來所證真如理智境界。非聲聞、緣覺之所能知。一，義甚深。如來所證種智。性義微妙。不可思議也。二，實體甚深。如來所證實相理體。不空不有。非如非異。不可思議也。三，內證甚深。如來所證所得一切智慧。甚深無量。不可思議也。四，依止甚深。如來所證真如法體。徧一切處。無染無淨。不變不遷。於一切法。不即不離。不可思議也。五，無上甚深。如來所證阿耨多羅三藐三菩提。一切聲聞、緣覺所不能思議也。見《法華論》。
    如幻事。如夢境。乃至如變化事者。具說如《大般若經·四百二》曰。若菩薩摩訶薩。欲覺知一切法。如幻。如夢。如響。如像。如光影。如陽燄。如空華。如尋香城。如變化事。唯心所現。性相皆空。當學般若波羅蜜多。

    時有二名。梵語迦羅者。世間實際之時。如云某日某時。三摩耶者。但約時分以名剎那生滅之分位者。非有時之實性。故曰假時此所云時。即三摩耶。謂菩薩行深般若波羅蜜多。證入真空之一剎那時也。菩薩以無分別智。照了五蘊身心。廓然寂滅。性相皆空。即最後一剎那頃證入真空之時。而稱體起用。度一切苦厄。亦在一剎那時。由五蘊本空。苦厄斯度。故體用同時也。《大般若經》曰。皆以無性而為自性。用一剎那相應妙慧。證得無上正等菩提。《心地觀經》曰。一剎那心般若相應。悟三世法無餘。故此時為萬緣俱寂。無得無證之時。《頓悟入道要門論》云。問。經云言語道斷。心行處滅。其義如何。答。以言顯義。得義言絕。義即是空。空即是道。道即是絕言。故云言語道斷。實際更不起觀。不起觀故。即是無生。以無生故。即一切色性空。色性空即萬緣俱寂。萬緣俱寂。即是心行處滅。又曰。萬緣俱寂者。即一切法性空。法性空。即一切處無心是。若得一切處無心時。即無有一相可得。何以故。自性空故。無一相可得。即是實相。實相者。即是如來妙色身相。故此時亦即為一切處無心之時。亦可云無念時。無念者。無邪念。非無正念。正念惟念菩提。菩提假立名字。實不可得。不可得。即無有念。無念之念。是名真念。但知一切處無心。即是無念。得無念時。自然解脫。菩薩行深般若波羅蜜多時。一念不起。境忘心滅。定慧均等。能所雙忘。觀聽圓明。自在無礙之時也。
    【注】無分別智。即無分別心。離一切相。不可分別。體會真如之智也。亦名根本智。若最初一念。聞聲見色。得聲色自性時。是現量當前。即無分別智照。不屬生滅有無。此智纔發。分別之心頓泯。當體即是真空。若見真空。名見佛性。若剎那流入意地。起第二念。分別事理。即是生滅心。生滅妄想相續。隨他聲色流轉。即智而成識。若不起分別。境自如如。即識而成智矣。
    剎那者。計時之最小單位。一念中有九十剎那。一彈指頃六十五剎那。
    性相皆空者。性。體也。《大乘義章》云。性有四義。一，種子因本義。二，體義。三，不改義。四，性別義。相者。諸法體狀。謂之為相。離一切迷情所見之相。謂之真空。
    無性者。謂四大乃至涅槃等假名。畢竟皆空。悉無實體也。一切眾生於世間相。處處計著。執為實有。佛為除此妄執。說一切法皆無自性。曰相無性。一切諸法。皆託因緣和合而生。本無自性。曰生無性。因破眾生妄執。假說無性。非性全無。佛說真如勝義之性。遠離徧計妄執之性。曰勝義無性。《大般若經·五百四十五》曰。諸法一性。即是無性。諸法無性。即是一性。如是諸法一性無性。是本實性。此本實性。即是一相。所謂無相。
    自性者。一切諸法。各有不變不改之性。是名自性。眾生迷惑。不了諸法本空。妄執我身及一切法。周徧計度。執為實有。曰徧計自性。諸法皆以眾緣相應而起。卻無自性。惟是虛妄。曰依他自性。真如自性。不遷不變。圓滿成就。曰圓成自性。
    無生者。遠離生滅之真如實相也。
    梵語馱摩。此云法性。法性有二。一，實法性。一實之理。離虛妄相。本性平等。無有變易。一切諸佛。莫不依此法性。修之而成正覺。是名實法性。二，事法性。世間種種諸法。皆依於理。施設建立。所謂地水火風五蘊等法。隨俗所知所見。雖屬於事。實不外乎法性之理。是名事法性。見《地持經》。
    心行處滅者。《準起信論》說。惟心相滅。非心體滅。如水因風而有動相。以風滅故。動相即滅。非水體滅。
    無念之念。是名真念。真念者。並念亦無。行者莫謂一切時都無所著。即我真心。不知執此無著之心。即是妄想。《楞伽經》曰。無心之心量。我說為心量。故云。三際求心心不有。心不有故妄元無。妄心無處即菩提。生死涅槃本平等。故無念之念亦無。方為無念。《宗鏡錄·三十七》云。若以有念析歸無念。此念還成有。若以無心作空無會者。即成斷滅。皆落意地。不出見知。又六十五云。妙湛圓明。寂而常照。故云常在正念。亦名正知。非是有念有知。亦非無念無知。有無皆想。俱非正知。但無念而照。名曰正知。若惟無念。寂而失照。若但照體。照而失寂。並稱不正。正在雙行（按即寂而常照。照而常寂之意）。《還源集》云。聖人有二種用心。一，不見一切物皆空。惟見於空。不見一切物。二，見一切物即空。了了見一切有。不住於有。了了見一切空。不住於空。雙照有無。分別宛然。而無念動。猶如明鏡。覩其色像。一切皆於中現。用心亦爾。得其妙性起照。照見一切。了了知無所知。了了見無所見。
    時者。即是有為法上假立分位。或是心上分位影像。依色心等總假立故。是不相應行蘊所攝。


第三項　觀行境界

    照見五蘊皆空。
    照者。光明徧照之義。見者。根心觸境之用。照見是能觀之智。五蘊是所觀之境。皆空是觀行之果。菩薩以妙慧照見五蘊自性。當體即是真空。與二乘之滅色求空者不同。照字在果即觀。在因即吾人最初一念不起分別之現量。空觀之功行深。則斷見思惑。顯一切智。照見真諦。假觀之功行深。則斷塵沙惑。顯道相智。照見俗諦。中觀之功行深。則斷無明惑。顯一切相智。照見中諦。見非眼根及眼識所見。乃現量當前。菩薩以法眼於一切法得法自性。不見纖塵可得。所謂不見色。不見受想行識。非曰不見。見即無見。《楞嚴經》所謂離一切相，即一切法也。蓋由五蘊本空。即是實相。實相無相。故不可見。不可見而見。洞徹法界。非唯不見世間諸法。於出世間一切淨戒、禪定、智慧、解脫、解脫知見、無上正等正覺、菩提、涅槃等法悉空。故皆不見。都無所見。名為照見。瞥有少見。即墮妄想無明窟宅。照以達諸法之空。見以證實相之有。空有兩忘。是名照見。
    【注】《事觀解》云。照見者。觀照般若也。因地識強智弱。照屬六識。見屬八識。兼慧心所。果位智強識弱。照屬妙觀察智。見屬大圓鏡智。曰照。曰見。古師或謂從眼根證入。或謂由耳根返觀照性。按觀世音菩薩六根圓通。明照無二。見聞覺知。不能分隔。成一圓融清淨寶覺。一根返源。六根解脫。得自在我者。諸根互用。非如異生之見必以眼也。
    見有五義。一，證見名見。即根本智見分。二，照燭名見。此通根心俱有。三，能緣名見。即通內三分（見分、自證分、證自證分）。俱能緣故。四，念解名見。以念解所詮義理故。五，推度名見。即比量心推度一切見故。本經照見之見。是照燭義。證見義。
    一切智。謂共聲聞及獨覺智。五蘊、十二處、十八界等差別法門。聲聞、獨覺亦能了知之智也。道相智。謂共菩薩摩訶薩智。諸菩薩摩訶薩。應學徧知一切道相（聲聞道相。獨覺道相。菩薩道相。如來道相）。令速圓滿。作所應作。而不令其證住實際之智（成熟有情。嚴淨佛土。及修大願若已圓滿。乃於實際可以證住）也。一切相智。謂諸如來應正等覺不共妙智。諸行狀相。能表諸法。如來如實能徧覺知。知一切相。皆同一相。謂寂滅相。是故名為一切相智。菩薩摩訶薩。與佛俱住說法無差別性。佛於一切法自相、共相照了無闇。清淨具足。名已得一切相智。菩薩尚在因位。名隨得一切相智。菩薩於諸道（聲聞道、獨覺道、菩薩道、如來道）。徧學滿已。以勝知見超過八地（淨觀地乃至獨覺地）。由道相智得入菩薩正性離生（菩薩修行般若波羅蜜多時。安住種種法門。起想起著。是為菩薩隨順法愛。即此法愛。說名為生。如宿食生。能為過患。除遣此故。名為離生。菩薩修行般若波羅蜜多時。不見內空乃至無性自性空。作如是觀。名入菩薩正性離生）。既入菩薩正性離生位已。復用一切相智。永斷一切習氣相續。入如來地。爾乃成就一切智智。故經曰。一切智智。略有三種。謂一切智。道相智。一切相智。蓋就佛地位言。三智備具。若在二乘。則但得一切智。菩薩但得道相智。深位菩薩。但有隨得一切相智。見《大般若經·三百六十九》。四百零九。四百六十二。四百八十四。《止觀·三》云。佛智照空。如二乘所見。名一切智。佛智照假。如菩薩所見。名道種智。佛智照空、假、中皆見實相。名一切種智。一切種智。名薩婆若。薩婆若即般若異名。《大智度論》云。五波羅蜜福德入般若波羅蜜中。即得清淨般若。般若清淨。故得佛道。變名薩婆若。在因位曰般若。在果位即薩婆若。
    法眼者。五眼之一。眼是總名。從用分別。則有五種。一，肉眼。父母氣血所成。見近不見遠。見前不見後。見內不見外。見晝不見夜。見上不見下。因有色質障礙故。二，天眼。諸天因修禪定而得此眼。遠近前後。內外、晝夜、上下。皆悉能見。以無色質障礙故。三，慧眼。二乘之人以所得慧眼。照見真空無相之智慧。四，法眼。菩薩為度眾生。以清淨法眼。徧觀一切諸法。能知能行。因行是法。得證是道。亦知一切眾生種種方便門。令修令證。五，佛眼。具前四眼之用。無事不見。無事不知。無事不聞。聞見互用。無所思惟。一切皆見。以上五眼。見《智度論》。《瑜伽師地論》。《華嚴經離·世間品》。於法眼中開出智眼。於佛眼中開出光明眼。出生死眼。無礙眼。一切智眼。共成十眼。所謂肉眼。見一切色故。天眼。見一切眾生心故。慧眼。見一切眾生諸根境界故。法眼。見一切法實相故。佛眼。見如來十力故。智眼見諸法故。光明眼見佛光明故。出生死眼。見涅槃故。無礙眼。所見無障故。一切智眼。見普門法界故。
    妙慧為深妙之智慧。《法華經·序品》。佛子心無所著。以此妙慧。求無上道。
    現量者。心識三量之一。詳下三量注。
    淨戒。即尸羅波羅蜜。心口意三業。離一切過非也。
    禪定。為華梵雙舉之詞。禪具云禪那。亦作馱那演那。舊譯思惟修。新譯靜慮。因靜生定。故曰禪定。《大乘義章》云。禪定別名凡七。一，禪。二，定。三，三昧。四，正受。五，三摩地。六，奢摩他。七，解脫。亦名背捨。三摩地亦作三摩缽提。此云等。息慮凝思。制心於一處而不動也。《玄應音義》云。欲入定時。名三摩缽提。正入定時。名三摩半那。奢摩他。此云止。攝心住緣。於染淨等境。心不妄動也。《圓覺經》於禪那，與三摩地，及奢摩他，略有次第。《資中》云。奢摩他以寂靜為相。三摩地以幻化為相。禪那則俱離靜幻二相。孤山謂一止三名。奢摩他。即體真止。止於真諦。為實相之真。三摩地。即方便隨緣止。止於俗諦。實相徧一切處。隨緣歷境。安心不動也。禪那。即息二邊分別止。止於中道。生死涅槃靜散休息也。《相宗綱要》略云。定有七名。一，三摩呬多。此云等引（舊云三摩提）。通有無心（有心定及無心定）。唯定非散。名等引者。一謂能引於等。故名等引。謂定中身心分位安和平等之時曰等。此等由於定力所引。故名等引。二謂等之所引。故名等引。由前加行入定之時。以定勢力。制伏沉掉。即名為等。由此等故。引生在定分位。前之加行名等。今是彼之所引。故名等引。二，三摩地。此云等持（舊云三昧）。謂以平等持心心所。令不散亂。故名等持。惟有心定。通於定散。三，三摩缽底。此云等至（舊云三摩跋提）。通有無心。名等至者。一謂至等。故名等至。謂由定勢力。令身心等有安和相。名之謂等。由定勢力。能至於等。故名等至。由前加行。制伏沉掉。故名為等。此等已至。故名等至。四，馱那演那（舊云禪那）。此云靜慮（靜者。定之用。慮者。慧之用）。通攝有無心定、漏、無漏、染、無染。依色四地。定慧平等。故得此名（色界四地。定慧平等。得名靜慮。無色界。定勝慧劣。不名靜慮）。五，質多翳迦阿羯羅多。此云心一境性。質多。此云心。翳迦。此云一。阿羯羅。此云境。多。此云性也（舊云一心）。即等持之異名。心專一境。依教而緣。證解所緣。心便明淨。六，奢摩他。此云止。能止住心。故名曰止。惟是有心淨定。不通散位。七，現法樂住。唯在靜慮（簡四空處），根本（簡未至定）。非餘。淨不通散。從果得名也。此中等引與等至。二者分別。等引通攝一切有無心位諸功德法。較等至為寬。《大乘義章·十》云。修義不同。一門分三。止者。外國名奢摩他。守心住緣。離於散動。故名為止。止心不亂。故復名定。觀者。外國名毘婆舍那。於法推求簡擇名觀。觀達稱慧。捨者。外國名憂畢叉。行心平等。捨離偏執。故名為捨。
    智慧即般若度。真智圓明。觀達法性。
    解脫亦為禪那別名。解脫一切繫縛之義。梵語目帝羅。舊譯背捨。新譯作解脫。在因中厭離煩惱名背捨。具足觀鍊熏修。發真無漏。三界結盡。爾時背捨轉名解脫。故在因有漏。則名背捨。在果無漏。則曰解脫。似二譯可以並存。解脫有三種。一，空解脫。觀一切法。皆從因緣和合而生。自性本空。無我、我所。於諸法得自在。又名空三昧。與苦諦之空、無我二行相應。二，無相解脫。真如性體。圓明寂靜。離色、聲、香、味、觸五法。男、女二相。生、住、滅三有為相。於諸法得自在。又名無相三昧。三，無願解脫。知一切法無相。則於三界無所願求。不造作生死之業。即無果報之苦而得自在。又名無願三昧。無作三昧。無起三昧。就能修之行言之。曰三昧。就無漏之果言之。曰解脫。就所觀之理言之。曰三空。如《仁王經》所說。就對治三障言之。曰三治。如《十地經》所說。
    背捨者。背謂違背。捨即棄捨。《智度論》云。背此淨潔五欲（淨潔五欲。為色界、無色界之五欲。若欲界之色、聲、香、味、觸麄弊五欲。名為不淨五欲）。捨此著心（貪、愛、瞋、癡、欲、慢謂之六著心）。故名背捨。修此觀故。發無漏智慧。斷三界見思惑盡。證阿羅漢果。即轉名八解脫。背捨凡八。一，內有色相，外觀色背捨。行者先觀自己色身壞爛不淨。不可愛樂。更想皮肉脫落。但見白骨。有八色光明。以內骨人未滅。故曰內有色相。又為欲界貪欲難斷。雖自觀內色不淨。復以不淨心觀外色。令生厭惡。以求斷除。故曰外觀色。是初背捨位。二，內無色相，外觀色背捨。行者入二禪。已滅內身骨人色相。故曰內無色相。為欲界見思未斷。猶觀外色白骨不淨之相。令生厭惡以求斷除。故曰外觀色。是第二背捨位。三，淨背捨，身作證。行者於第二背捨後。除棄外色不淨之相。但攝心諦觀八色光耀之相。極令明淨。住心緣中。泯然入定。見外八色光明。清淨皎潔。猶如妙寶之色。故曰淨背捨。心既明淨。樂漸增長。徧身怡悅。故曰身作證。是第三背捨位。四，虛空背捨。行者於欲界後。已除自身皮肉不淨之色。初背捨後。已滅內身白骨之色。二背捨後。又除外身一切不淨之色。惟有八種淨色。此八種色。皆依心住。若心捨色。色即謝滅。一心緣空。與空相應。即入無邊空虛處定。故曰虛空處背捨。是第四背捨位。五，識處背捨。行者如捨虛空處。一心緣識入定時。即觀此定。依五蘊等。悉皆無常、苦、空、無我。虛妄不實。心生厭背。故曰識處背捨。是第五背捨位。六，無所有處背捨。行者如捨識處。一心緣無所有處入定時。即觀此定。依五蘊等。悉皆無常苦空無我。虛妄不實。心生厭背。故曰無所有處背捨。是第六背捨位。七，非有想非無想處背捨。行者如捨無所有處。一心緣非有想非無想入定時。即觀此定。依五蘊等。悉皆無常苦空無我。虛妄不實。心生厭背。故曰非有想非無想背捨。是第七背捨位。八，滅受想背捨。行者厭患此心散亂。欲入定休息。背滅似涅槃法。背滅非想、蘊、界、入，及諸心數法。所謂一受、二想、三行、四觸、五思、六欲、七解、八念、九定、十慧。不受非想。一心緣真。絕蘊、界、入。則非想、蘊、入、界、滅。一切諸行因緣悉滅。受滅乃至慧滅。愛、無明等諸煩惱滅。一切心數法滅。一切非心數法亦滅。故曰滅受想背捨。是第八背捨位。此八背捨為禪定之初步。《智度論》云。八背捨為初門。八勝處（一，內有色相外觀色少勝處。二，內有色相外觀色多勝處。三，內無色相外觀色少勝處。四，內無色相外觀色多勝處。五，青勝處。六，黃勝處。七，赤勝處。八，白勝處）為中行。徧一切處（青、黃、赤、白、地、水、火、風、空、識之十法。一一周徧於一切處之定）為成就。見《禪波羅蜜次第法門·十》。
    解脫除為禪定之別名外。尚有其本義。即離縛而得自在。解惑業之繫縛。脫三界之苦果也。《唯識述記》云。解謂離縛。脫為自在。《華嚴大疏》云。解脫者。謂作用自在。《傳心法要》云。前際無去。今際無住。後際無來。安然端住。任運不拘。方名解脫。涅槃之體。離一切之繫縛。故解脫亦為涅槃別稱。諸經分類不一。《俱舍論》分為一時解脫與不時解脫。鈍根之無學。待勝時入定。得脫煩惱之惑。曰一時解脫。利根之無學。不選時而入定。得脫煩惱之惑。曰不時解脫。《寶性論》分為性淨解脫與障盡解脫。性淨解脫者。眾生本性清淨。無繫縛染污之相也。障盡解脫者。眾生本性。雖然清淨。但由無始以來煩惱迷惑。不得顯現。必待斷盡惑障。始得自在也。《成實論》分為慧解脫與俱解脫。阿羅漢未得滅盡定。唯解脫證涅槃之智慧障者。曰慧解脫。阿羅漢已得滅盡定。同時解脫慧與定之障者。曰俱解脫。《大乘義章》分為心解脫與慧解脫。因此心離於貪愛之縛而得解脫者。曰心解脫。以智慧斷除無明惑業之縛而得解脫者。曰慧解脫。《華嚴經疏》分為有為解脫與無為解脫。有作之戒。依師傳授。如法奉持。防非止惡。離諸惑業。曰有為解脫。無作之戒。性本清淨。體本無為。雖持戒法。無持犯相。心體既空。罪性亦泯。曰無為解脫。《淨名經》以三昧神用。巨細相容。變化於法。自在無礙。名不可思議解脫。《華嚴經》明一多無礙之法相。曰無礙解脫。
    《華嚴經隨疏演義鈔》。明解脫五義。一者。生死不能縛。生死即五蘊起滅輪轉之相。菩薩不為生死所縛。二者。境相不能縛。菩薩離去凡情。雖見一切境界。不生貪著。三者。現惑（現前分別之見）不能縛。菩薩既不著所見之境。亦不起能見之心。自不為現前分別之見所縛。四者。有不能縛。有即一切有為之法。皆所見之相也。菩薩所見皆空。而無所著。五者。惑不能縛。惑即無明煩惱。菩薩了妄即真。無明即菩提。無著無不著也。
    解脫知見。知已得解脫之知見也。即後得智。由淨戒至解脫知見。由戒生定。由定生慧。由慧得解脫。由解脫而有解脫知見。前三，就因受名。後二，從果得號。由慧斷惑。無惑名解脫。出纏破障。反照觀心。名解脫知見。五者皆為佛之功德。故小乘以之為三身中之法身。
    無上正等正覺。及菩提，涅槃。詳後注。
    五蘊者。色受想行識也。梵語塞健陀。舊譯作陰。亦作眾。新譯作蘊。陰者。蓋覆之義。妄相煩惱。蓋覆真性也。眾者。眾多和集之義。蘊者。積聚之義。謂眾生由此五法。積聚成身。復由此身積聚無量塵勞煩惱。而受無量生死輪迴之苦也。五蘊中受想行識四者。無形體可見。但以名知之。故謂為名。色蘊為極微所成有質礙之物體。故謂為色。總之曰名色。即五蘊也。此五蘊中。色為色法。受想行識四者為心法。故別於色蘊而言。謂之非色四蘊。
    五蘊諸法。如幻如化。從因緣生。本無實性。故《大般若經》佛告善現。《大莊嚴經》佛為瓶沙王說喻。皆云色如聚沬。受如水泡。想如陽燄。行如芭蕉。識如幻事。菩薩以般若妙智觀此五蘊。色從四大假合而有。受想行識。由妄想境界而生。四大、妄想。本無自性。當體即空。故曰皆空。非謂寂然滅無為空。亦非有法能令彼空。以彼本自空故。眾生不了水月空花。故執五蘊幻有之色。而迷自性真空。夫真空、幻有。體非有二。以妄心分別。則見五蘊而遺真空。以般若觀照。則顯真空而亡五蘊。蓋真空即實相。實相即真如。即幻明空。實相自顯。真如常在。幻有都滅。幻有滅盡。五蘊皆空。《大般若經》曰。是諸愚夫。執諸法異本性空已。不如實知色。不如實知受想行識。由不知故。便執著色。執著受想行識。由執著故。便於色計我、我所。於受想行識。計我、我所。由妄計故。著內外物受後身色受想行識。由此不能解脫諸趣生、老、病、死、愁憂苦惱。往來三有。輪轉無窮。又曰。菩薩摩訶薩修行般若波羅蜜多時應以本性空觀一切法。作此觀時。於一切法。心無行處。是名菩薩摩訶薩無所攝受三摩地。又曰。一切法。非法，非非法。諸取相者皆是煩惱。菩薩照見五蘊皆空。即一切法心無行處境界。
    【注】《大般若經·四百七十一》曰。佛告善現。若菩薩摩訶薩，行深般若波羅蜜多時。如實知色乃至識。若相。若生滅。若真如。是名能學色乃至識。善現。云何菩薩摩訶薩，行深般若波羅蜜多時。如實知色相。謂菩薩摩訶薩，行深般若波羅蜜多時。如實知色。畢竟有孔。畢竟有隙。譬如聚沫。性不堅固。是名菩薩摩訶薩，行深般若波羅蜜多時。如實知色相。善現。云何菩薩摩訶薩，行深般若波羅蜜多時。如實知色生滅。謂菩薩摩訶薩，行深般若波羅蜜多時。如實知色。生時無所從來。滅時無所至去。雖無來無去。而生滅相應。是名菩薩摩訶薩，行深般若波羅蜜多時。如實知色生滅。善現。云何菩薩摩訶薩，行深般若波羅蜜多時。如實知色真如。謂菩薩摩訶薩，行深般若波羅蜜多時。如實知色真如。無生。無滅。無來。無去。無染。無淨。無增。無減。常如其性。不虛妄。不變易。故名真如。是名菩薩摩訶薩，行深般若波羅蜜多時。如實知色真如。善現。云何菩薩摩訶薩，行深般若波羅蜜多時。如實知受相。謂菩薩摩訶薩。行深般若波羅蜜多時。如實知受。畢竟如癰。畢竟如箭。速起。速滅。猶若浮泡。虛偽不住。三和合起。是名菩薩摩訶薩，如實知受相。善現。云何菩薩摩訶薩，行深般若波羅蜜多時。如實知受生滅。謂菩薩摩訶薩，行深般若波羅蜜多時。如實知受。生時無所從來。滅時無所至去。雖無來無去。而生滅相應。是名菩薩摩訶薩，行深般若波羅蜜多時。如實知受生滅。善現。云何菩薩摩訶薩，行深般若波羅蜜多時。如實知受真如。謂菩薩摩訶薩，行深般若波羅蜜多時。如實知受真如。無生。無滅。無來。無去。無染。無淨。無增。無減。常如其性。不虛妄。不變易。故名真如。是名菩薩摩訶薩，行深般若波羅蜜多時。如實知受真如。善現。云何菩薩摩訶薩，行深般若波羅蜜多時。如實知想相。謂菩薩摩訶薩，行深般若波羅蜜多時。如實知想如陽燄。水不可得。渴愛因緣。妄起此想。發假言說。是名菩薩摩訶薩，行深般若波羅蜜多時。如實知想相。善現。云何菩薩摩訶薩，行深般若波羅蜜多時。如實知想生滅。謂菩薩摩訶薩，行深般若波羅蜜多時。如實知想。生時無所從來。滅時無所至去。雖無來無去。而生滅相應。是名菩薩摩訶薩，行深般若波羅蜜多時。如實知想生滅。善現。云何菩薩摩訶薩，行深般若波羅蜜多時。如實知想真如。謂菩薩摩訶薩，行深般若波羅蜜多時。如實知想真如。無生。無滅。無來。無去。無染。無淨。無增。無減。常如其性。不虛妄。不變易。故名真如。是名菩薩摩訶薩。如實知想真如。善現。云何菩薩摩訶薩。行深般若波羅蜜多時。如實知行相。謂菩薩摩訶薩，行深般若波羅蜜多時。如實知行如芭蕉樹。葉葉析除。實不可得。是名菩薩摩訶薩，行深般若波羅蜜多時。如實知行相。善現。云何菩薩摩訶薩，行深般若波羅蜜多時。如實知行生滅。謂菩薩摩訶薩，行深般若波羅蜜多時。如實知行。生時無所從來。滅時無所至去。雖無來無去。而生滅相應。是名菩薩摩訶薩，行深般若波羅蜜多時。如實知行生滅。善現。云何菩薩摩訶薩，行深般若波羅蜜多時。如實知行真如。謂菩薩摩訶薩，行深般若波羅蜜多時。如實知行真如。無生。無滅。無來。無去。無染。無淨。無增。無減。常如其性。不虛妄。不變易。故名真如。是名菩薩摩訶薩，行深般若波羅蜜多時。如實知行真如。善現。云何菩薩摩訶薩，行深般若波羅蜜多時。如實知識相。謂菩薩摩訶薩，行深般若波羅蜜多時。如實知識。如諸幻事。眾緣和合。假施設有。實不可得。謂如幻師。或彼弟子。於四衢道。幻作四軍。所謂象軍。馬軍。車軍。步軍。或復幻作諸餘色類。相雖似有。而無其實。識亦如是。實不可得。是名菩薩摩訶薩，行深般若波羅蜜多時。如實知識相。善現。云何菩薩摩訶薩，行深般若波羅蜜多時。如實知識生滅。謂菩薩摩訶薩，行深般若波羅蜜多時。如實知識。生時無所從來。滅時無所至去。雖無來無去。而生滅相應。是名菩薩摩訶薩，行深般若波羅蜜多時。如實知識生滅。善現。云何菩薩摩訶薩，行深般若波羅蜜多時。如實知識真如。謂菩薩摩訶薩，行深般若波羅蜜多時。如實知識真如。無生。無滅。無來。無去。無染。無淨。無增。無減。常如其性。不虛妄。不變易。故名真如。是名菩薩摩訶薩，行深般若波羅蜜多時。如實知識真如。
    善現。即須菩提之譯名。梵語須菩提。此云善現。亦作善吉。善業。空生。佛十大弟子中解空第一，得無諍三昧。
    《大莊嚴經》。具云《方廣大莊嚴經》。唐地婆訶羅譯。凡十二卷。二十七品。與《普曜經》同本。而品有開合。
    色如聚沫。色即眾生色身。沫即水沫。謂沫因風吹水成聚。虛有相狀。體本不實。以譬眾生色身。亦如聚沫。虛假不實也。受如水泡。謂水因風動，或為物擊。忽爾成泡。須臾即沒。以譬眾生所受苦樂。亦如水泡。起滅無常也。想如陽燄。謂遠望曠野。日光發燄如水。渴者思飲。終不可得。以譬眾生妄想。本無實體。因念成想。終為虛妄也。行如芭蕉。謂芭蕉危脆。中無堅實。以譬眾生造作諸行亦如是也。識如幻事。謂如幻巾為馬。幻木為人。幻術所成。本無實體。以譬眾生識心分別諸法。隨境生滅。如幻無實也。《宗鏡錄》云。四大既空。五蘊無主。是以先觀色陰。從四大所造。展轉相因而生。四大中既無主宰。誰能合集以成色乎。以此觀之。色陰即空。色陰既空。四陰何有。以般若照見五蘊皆空。聚沫之色既虛。水泡之受何有。陽燄之想非實。芭蕉之行惟空。幻識倏爾無依。空大湛然不動。
    五蘊之法從因緣生。因緣即是眾生妄心計度。於妄想中立因緣性。虛妄不實。故《楞嚴經》說五蘊虛妄。本非因緣非自然性。即空五蘊義。

    自來釋五蘊者。性相二宗。立說不同。性宗又分二說。清涼以身、心為五蘊。身則色蘊。地水火風是。心則四蘊。受想行識是。故云。五蘊者。身心之異名。永嘉以一念為五蘊。謂穢污真性即色蘊。領納在心即受蘊。心緣此理即想蘊。行用此理即行蘊。歷歷分明即識蘊。此五蘊者。舉體即是一念。一念者。舉體全是五蘊。與《楞嚴經》色陰為堅固妄想。受陰為虛明妄想。想陰為融通妄想。行陰為幽隱妄想。識陰為顛倒微細精想之說。可以互相發明。相宗則以大乘百法中有為法為五蘊。即色法十一為色蘊。徧行法之受心所為受蘊。想心所為想蘊。餘心所四十九，不相應行二十四，為行蘊。八識心王為識蘊。約小乘七十五法言。則以其中七十二有為法為五蘊。無論大乘百法。小乘七十五法。均不攝無為法者。因蘊為積集性。無為法非積集。故不攝也。《俱舍論》云。蘊不攝無為。義不相應故。
    【注】性相二宗。為佛教二大學派。如來在世。應機說法。或有或空。本皆一味。文殊彌勒。各隨所聞，結集經論。及至馬鳴。龍樹。與無著。天親。分談性相。亦無宗派。千餘年後。南印度徤至國中。有清辨、護法二菩薩。同時出世。清辨依般若諸經。創立性宗。謂一切法皆悉是空。無生。無滅。本來寂靜。自性涅槃。故《金剛經》曰。一切有為法。如夢幻泡影，如露，亦如電。應作如是觀。《思益經》曰。以心分別。諸法皆邪。不以心分別。諸法皆正。《中論》云。若有不空法。應當即有空。不空尚不得。何況得於空。又云。諸佛或說我。或時說非我。諸法實相中。非我非非我。《大乘掌珍論》云。真性有為空。如幻緣生故。無為無有實。不起如空華。為此宗要義。傳入我國。衍為三論天台諸宗。護法依《解深密》諸經。創立相宗。謂一切法通有及無。即以徧計所執性。為情有理無。依他起性。為因緣假有。圓成實性。為理有情無。故《解深密經》曰。依所執故。說一切法皆無自性。《瑜伽論》云。依所執性故。《契經》說。一切諸法。皆無自性。《辯中邊論》云。虛妄分別有。於此二都無。此中唯有空。於彼亦有此。故說一切法。非空非不空。有無及有故。是故契中道。為此宗要義。傳入我國。衍為唯識等宗。西藏修習般若者。分廣般若、深般若二派。廣般若即相宗。無著菩薩祖述，彌勒菩薩所傳也。深般若即性宗。龍樹菩薩祖述，文殊菩薩所傳也。文殊以下有二支派。一，名言派。二，一切法無自性派。

    窺基師《心經幽贊》、靖邁師《心經疏》所引經文。於照見五蘊下有一等字。按之各本譯文則否。窺基、靖邁二師。殆以五蘊以外尚有處界諦緣等。故加一等字以總攝之。惟諸法不外色、心。開之為百法。合之則五蘊已足包含一切。
    按梵語心經。及由藏文轉譯各本。與唐梵翻對字音心經。此句五蘊下。尚有自性二字。由梵譯漢者。般若共利言本作五蘊性空。法成本作五蘊體性皆空。法月、智慧輪、施護各本。作五蘊自性皆空。夫一切法自性皆空。但言五蘊。不說自性。義亦無闕。故什師、奘師、淨師三譯略之。但為初機修學便利。以有自性二字為備。茲依別譯闡釋如次。
    諸法各自有不遷不變之性。謂之自性。但諸法非常，非滅。性本自空。故一切法皆無自性。《大般若經》。佛告善勇猛。無少法性是圓成實。一切皆是世俗假立。非於此中有少自性。無自性故。皆非實有。諸法皆以無性為性。是故諸法無實無生。又曰。色自性空。不由空故。受想行識自性空。不由空故。又曰。色色自性空。受想行識。受想行識自性空。是色自性。即非自性。受想行識自性。亦非自性。若非自性。即是般若波羅蜜多。又曰。色蘊自性離色蘊。受想行識蘊自性離受想行識蘊。此離自性。是謂般若波羅蜜多。即本經五蘊自性皆空義。
    性本自空。故一切法皆無自性者。即以無性為自性也。如《大般若經》曰。菩薩摩訶薩修行般若波羅蜜多時。於一切法不取有。不取非有。不取亦有亦非有。不取非有非非有。於不取亦不取（中略）由一切法自性不可得。何以故。以一切法以無性為自性故。又曰。甚深般若波羅蜜多中。色無所有。受想行識無所有（中略）。何以故。以一切法自性空故。又曰。於此般若波羅蜜多甚深經中。色自性無所有。不可得。受想行識自性無所有。不可得。又曰。一切法皆以空為自性。一切法皆以無相為自性。一切法皆以無願為自性。由是因緣。諸菩薩摩訶薩。應知一切法皆以無性為自性。大經所說。益足顯示蘊空真義。夫能洞達五蘊自性空無所起。故當體即是真如。
    【注】一切法者。總賅諸法之稱。《智度論·二》云。一切法。略說有三種。一者。有為法。二者。無為法。三者。不可說法。此三已攝一切法。
    體常不變。故名自性。見《佛地經論·七》，惟識宗立三自性。謂眾生迷惑。不了諸法本空。妄於我身及一切法。周徧計度。一一執為實有。曰徧計自性。所有諸法。皆依眾緣相應而起。都無自性。唯是虛妄。曰依他自性。真如自性。不遷不變。圓滿成就。曰圓成自性。見《顯揚論》。
    性者。體也。無性。即一切諸法皆無實體之義。唯識宗立三無性。謂眾生於世間相。處處計著執為實有。佛為除此妄執。說一切法皆無自性。曰相無性。謂一切諸法皆託因緣和合而生，曰生無性，謂相無性。生無性。因破眾生妄執之情。假說無性。非性全無。遠離徧計妄執。真如勝義之性。曰勝義無性。見《成唯識論》。

    皆者。俱也。同也。多數同一之義。蓋總括之詞。
    空者。梵語舜若多。湛然清靜。廓爾虛明之義。因緣所生之法。皆無自性。畢竟皆空。《淨名經》曰。諸法究竟無所有。是空義。肇註云。小乘觀法緣起。內無真主為空義。雖能觀空。於空見未能都泯。故不究竟。大乘在有不有。在空不空。理無不極。所以為究竟空。《大乘義章》云。空者。就理彰名。理寂名空。又云。絕眾相故名為空。綜合諸經論所說。為赴一時之機。因病與藥。語各不同。約其要恉。可分四義。一者。空無義。世間諸法。無論有情非情。總由因緣而生。凡因緣所生之法。自體不實。故謂之空。《中論偈》云。因緣所生法。我說即是空。《智度論》云。因緣生法。是名空相。見一切諸法。從因緣生。無有自性。無自性故空。空故諸見滅。此為無常、苦、空，之空。二者。虛空義。空。顯色也。雖無麤相之身。亦有微妙之色。《智度論》云。如虛空者。但有名而無實法。虛空非可見法。遠視故眼光轉見縹色。諸法亦如是。空無所有。三者。心空義。菩薩心上不著一物。無冤親。無貪瞋。無勝負。無人我。無妄想分別。一切俱捨。妙湛圓寂。萬境俱空。境空由於心空。心空則五蘊自空。六根、六塵、十八界、十二因緣、四諦等皆空。所謂心空境自空也。四者。法空。以空為諸法皆空之實相。即真如也。《起信論》云。所言空者。從本已來。一切染法不相應故。謂離一切法差別之相。以無虛妄心念故。當知真如自性。非有相。非無相。非非有相。非非無相。非有無俱相。非一相。非異相。非非一相。非非異相。非一異俱相。乃至總說依一切眾生。以有妄心。念念分別。皆不相應。故說為空。若離妄心。實無可空故。《涅槃經》曰。佛性名第一義空。《智度論》云。能使諸法實相空。名為第一義空。《三藏法數》云。諸法中最第一法。名為涅槃。涅槃之法。空無有相。是為第一義空。夫佛性為不生不滅之真體。故名真如。實者非妄。相者無相。故名實相。實相又名涅槃。故佛性、實相、真如、涅槃。皆為空之異名。照見五蘊皆空。是心空義。法空義。
    《大般若經》曰。菩薩修行般若波羅蜜多。以無所得為方便。觀一切法自相皆空。其心安住。名空解脫門。亦名空三摩地。觀一切法自相空故。皆無有相。其心安住。名無相解脫門。亦名無相三摩地。觀一切法自相空故。皆無所願。其心安住。名無願解脫門。亦名無願三摩地。觀即照見。惟觀一切法自相皆空。故照見五蘊皆空。皆空者。謂一一蘊人法二空也。生死之本。莫過人法二執。迷身心總相。故計人我為實有。迷五蘊自相。故計法我為實有。菩薩照見五蘊和合。假名為人。一一諦觀。但見五蘊。求人我相總不可得。先觀色蘊。即是觀身。了知堅則地。潤則水。煖則火。動則風。觀餘四蘊。則是觀心。了知領納為受。取相為想。造作為行。了別為識。依此身、心諦觀分明。求人我相終不可得。名為人空。若觀一一蘊。皆從緣生。都無自性。求蘊相不可得。則五蘊皆空。名為法空。是以照五蘊而二空理現。此清涼之說也。謂五陰舉體即是一念。一念舉體全是五陰。歷歷見在一念之中。無有主宰。即人空慧。見五蘊皆如幻化。即法空慧。此永嘉之說也。唯識宗按三性說五蘊。即徧計所執五蘊。依他起性五蘊。圓成實性五蘊。三性五蘊。一一皆有人法二空。即徧計所執本體。非有相。無自性。所以名空。依他體性。色如聚沫。受喻浮泡。想同陽燄。行類芭蕉。識猶幻事。生無自性。故亦名空。圓成實性。因觀所執空無方證或無如彼所執真性。故真勝義。亦名為空。而此宗護法。則以為三性非空非不空。為破有執。但遣所執。總名為空。非後二性盡遣。然後名空。二者廣狹不同。然於五蘊皆空之義。則一致也。
    【注】凡因緣所生之法。究竟無實體。故謂之空。《淨名經》曰。諸法究竟無所有。是空義。肇注云。小乘觀法之緣起。內無真主為空義。雖能觀空。而於空未能都泯。故不究竟。大乘在有不有。在空不空。理無不極。所以為究竟空義。
    《幽贊》云。此空者。即真如理。性非空有。因空所顯。遮執為有。故假名空。愚夫不知。執五蘊等。定離真有。起相分別。今推歸本體即真如事離於理。無別性故。
    諸經說空。立名不同，略舉之如左。
    一空。一切諸法。皆無自性。若色若心。若依若正。乃至聖凡因果之法，雖種種不同。求其體性。畢竟皆空。見《寂調音所問經》。
    二空。一，人空。即我空也。亦曰生空。凡夫妄計五蘊是我。強立主宰。引生煩惱。造種種業。佛為破此執故。說五蘊無我。二乘悟之。入無我理。是名人空。二，法空。二乘未達法空之理。猶計五蘊之法為實有。佛為破此執故。說般若深慧。徹見五蘊自性皆空。菩薩悟之入法空理。是名法空。見《唯識論》。又一，但空。二乘之人觀一切虛幻。但見於空。不見不空。二，不但空。諸菩薩不但見空。兼見不空。即成中道。見《止觀》。
    三空。一，我空。於五蘊之法。強立主宰。名為我執。若推求色受想行識之五法。皆為假名。並無自性。一切煩惱。皆由著我。則於我無著。證入空無我理。即斷見惑。離煩惱障。得我空無分別慧。二，法空。計五蘊法為實有。名為法執。若了所知結。皆由著法。破五蘊實法之執。即斷思惑。進而破涅槃淨法。即斷無明。於法無著。證法空無我理。離所知障。得法空無分別慧。成法解脫。三，俱空。我法二執俱遣。所空既盡。能空亦滅。空執兩忘。證二空空無我理。成平等空。得俱空無分別慧。見《金剛經刊定記》。蕅益大師曰。俱空實不生。非人法滅而俱空生。一切法不生。不生亦不生。心無所起。即名無生法忍。空、無相、無願之三解脫門。亦名三空。見《大乘義章·二》。
    四空。一，法相空。言有法之空。二，無法空。言無法之空。三，自法空。言自性之空。四，他法空。言他法之空。見《大乘義章·二》。
    六空。一，果報空。五蘊空是。二，受用空。十二處空是。三，性別空。十八界空是。四，徧到空。六大空是。五，境空。四諦空是。六，義空。十二因緣空是。見《天台仁王經疏》。
    七空。一，相空。謂一切諸法性中。自、他、共、離之相皆空（如動一念。心從根生。即自性。從塵生。即他性。根塵合生。即共性。離根塵生。即離性。於此四性之相。皆不執著。故曰皆空）。二，性自性空。謂於當念。觀一切所生之法。悉由因緣和合而成。本無自生之性。三，行空。謂五蘊之身。本無有我（執五蘊身。強立主宰。謂之我）。亦無我所（五蘊之身）。眾生不了。執蘊成我。從我起行。若順性推求則五蘊之法。了不可得。四，無行空。謂不離前所作行而能了達諸蘊。展轉緣起。無有自性可得。亦無所作之行。五，一切法離言說空。謂一切法皆自妄想而成。本無自性。離諸言說故。六，第一義聖智大空。謂佛自覺聖智（佛所證第一義心）。能空一切見過（一切見惑之過失）之習氣（餘習之氣分）。所空既空。能空亦空。七，彼彼空。謂彼外道所計之空。但能空於境。不能空於心。空於彼。不能空於此。如空舍之空。舍體非空。是為假空。見《入楞伽經·一》。又一，性空。二，自相空。三，諸法空。四，不可得空。五，無法空。六，有法空。七，無法有法空。見《智度論·三十六》。
    十一空。一，內空。二，外空。三，內外空。四，有為空。五，無為空。六，無始空。七，性空。八，無所有空。九，第一義空。十，空空。十一，大空。見《涅槃經·十六》。
    十三空。於上十一空中加波羅蜜空，因空，佛果空。而除無所有空。見《仁王經》。
    十四空。一，內空。二，外空。三，內外空。四，大空。五，空空。六，真實空。七，有為空。八，無為空。九，畢竟空。十，無前後空。十一，不捨離空。十二，佛性空。十三，自性空。十四，一切法空。見《十八空論》。
    十六空。一，內空。二，外空。三，內外空。四，空空。五，大空。六，勝義空。七，有為空。八，無為空。九，畢竟空。十，無際空。十一，無散空。十二，本性空。十三，相空。十四，一切法空。十五，無性空。十六，無性自性空。見《大般若經·四百八十三》。
    十八空。一，內空。二，外空。三，內外空。四，空空。五，大空。六，勝義空。七，有為空。八，無為空。九，畢竟空。十，無際空。十一，散無散空。十二，本性空。十三，自共相空。十四，一切法空。十五，不可得空。十六，無性空。十七，自性空。十八，無性自性空。見《大般若經·四百二十二》。又一，內空。二，外空。三，內外空。四，空空。五，大空。六，勝義空。七，有為空。八，無為空。九，無際空。十，無變異空。十一，無始空。十二，本性空。十三，自相空。十四，無相空。十五，無性空。十六，自性空。十七，無性自性空。十八，一切法空。見《帝釋般若波羅蜜多心經》。又一，內空。二，外空。三，內外空。四，空空。五，大空。六，第一義空。七，有為空。八，無為空。九，畢竟空。十，無始空。十一，散空。十二，性空。十三，自相空。十四，諸法空。十五，不可得空。十六，無法空。十七，有法空。十八，無法有法空。見《智度論四十六》。又一，內空。亦名受者空。二，外空。亦名所受空。三，內外空。謂身空也。四，大空。五，空空。六，真實空。謂真境空也。七，有為空。八，無為空。九，畢竟空。十，無前後空。亦名無始空。十一，不捨離空。十二，佛性空。十三，自相空。十四，一切法空。十五，無法空。十六，有法空。十七，無法有法空。十八，不可得空。見《十八空論》。
    二十空。一，內空。二，外空。三，內外空。四，空空。五，大空。六，勝義空。七，有為空。八，無為空。九，畢竟空。十，無際空。十一，散空。十二，無變異空。十三，本性空。十四，自相空。十五，共相空。十六，一切法空。十七，不可得空。十八，無性空。十九，自性空。二十，無性自性空。見《大般若經·五十一》。
    自十一空至二十空。各經大同小異。《準大般若經》說。內空者。內謂內法。眼耳鼻舌身意六根。皆無自性。非常非壞。故名內空。外空者。外謂外法。色聲香味觸法六塵。皆無自相。非常非壞。故名外空。內外空者。內六處。外六處。根塵皆無自性自相。內六處由外六處空。外六處由內六處空。非常非壞。故名內外空。空空者。一切法非常非壞。即空亦空。故名空空。大空者。大謂十方。東南西北四維、上、下皆空。非常非壞。故名大空。勝義空。即第一義空。涅槃非常非壞。本來空寂。故名勝義空。有為空者。欲界，色界，無色界，煩惱惑業。非常非壞。本無有為之相。故名有為空。無為空者。生、住、異、滅。諸相皆空。無為寂靜。非常非壞。故名無為空。畢竟空者。欲求有為無為諸法之相。悉皆空寂而不可得。非常非壞。故名畢竟空。無際空者。諸法起滅無初、中、後際，及往來際可得。非常非壞。故名無際空。散空者。散謂有放，有棄，有捨，可得。諸法因緣和合。無和合相。非常非壞。故名散空。無變異空者。無放，無棄，無捨，可得。不變不異。非常非壞。法性如如。故名無變異空。本性空者。有為無為諸法。本性清淨。非聲聞、獨覺、菩薩、如來所作。亦非餘所作。離性離相。非常非壞。故名本性空。自相空者。謂一切法自相。如變礙是色自相。領納是受自相。取像是想自相。造作是行自相。了別是識自相。如是等若有為法自相。若無為法自相。悉皆虛幻不實。非常非壞。故名自相空。共相空者。謂一切法共相。如苦是有漏法共相。無常是有為法共相。無我是一切法共相。如是等無量共相。本來空寂。非常非壞。故名共相空。一切法空者。謂五蘊、十二處、十八界、若色、無色。見、無見。對、無對。漏、無漏。為、無為。諸法。本性皆空。非常非壞。故名一切法空。不可得空者。一切法不可得。過去、未來、現在不可得。過去，無未來，現在可得。未來、無過去、現在可得。現在，無過去，未來可得。三世諸法。皆無所有。非常非壞。了無可求之相。故名不可得空。無性空者。諸法如幻。皆無實性可得。非常非壞。故名無性空。自性空者。謂諸法能和合自性。非常非壞。自無實性。故名自性空。無性自性空者。謂諸法無能和合性。有所和合自性。非常非壞。故名無性自性空。三藏法數則以無性空為即小空。謂須陀洹、斯陀含、阿那含、阿羅漢，四果之相皆空也。《智度論》解釋十八空義則小異。內空。謂內身三十六種（外相不淨十二：毛、發、爪、齒、眵、淚、涎、唾、屎、尿、垢、汗。內性不淨十二：皮、膚、血、肉、筋、脈、骨、髓、肪、膏、腦、膜。通於相性者十二：肝、膽、腸、胃、脾、腎、心、肺、生臓、熟臓、赤痰、白痰）不淨充滿。九孔（兩眼、兩耳、兩鼻孔、口、及穀道、尿道）常流。淨相不可得故。外空。謂外即外身。愚夫觀所著色。妄以為淨。亦如內身淨相不可得故。內外空。謂我身不淨。外亦如是。外身不淨。我亦如是。求其淨相不可得故。空空者。謂內身、外身、內外身皆空。而猶執空成病。復以空法而破三空也。大空者。謂十方世界。是四大造色。假名日出處為東方。日沒處為西方。如是方相。以世俗故有。若第一義中則一法不可得也。第一義空者。諸法中。最第一法。名為涅槃。涅槃之法。空無有相。有為空者。謂五蘊等法。無我、我所及常相。皆不可得故。無為空者。謂無所作為。則非有相。今對有為。故說無為。有為法既不可得。無為之法。更何所著。畢竟空者。謂以前八空。破一切法無餘。既無諸法。空亦無著也。無始空者。謂世間眾生。無有始相。如今生從前世因緣有。前世又從前世有。如是展轉。無始亦不可得故。散空者。謂五蘊和合。故有人相。散此五蘊。空無所有。如輻、輞、轅、轂。眾合為車。眾材離散。則失車名也。性空者。謂一切諸法。自性本空。皆從因緣和合而生。若不和合。則無是法。如是諸法。性不可得也。自相空者。謂一切法有二種相。一者。總相。生滅不住。本無今有。已有還無。皆是無常。二者。別相。如地有堅相。水有濕相。火有熱相。風有動相。如是二相皆空也。諸法空者。謂五蘊、十二處、十八界等法。無有實相。一切皆空。無取無捨。離一切諸見也。不可得空者。謂一切諸法及因緣（六根為因。六塵為緣）。畢竟皆空。不可得故。無法空者。謂諸法已滅。是滅亦無也。又謂過去、未來法。名為無法。如是無法亦空也。有法空者。謂諸法從因緣和合。故有法生。法體本不實也。又謂現在一切法。及無為法。名為有法。如是有法皆空也。無法有法空者。謂無法有法相。不可得故。又謂過去、未來、現在一切法。不可得故。
《楞伽經》云。剎尼迦者。名之為空。或呿提。秦云虛空。《圓覺經鈔》云。梵云舜若。此云空。空無之空也。舜若多。此云空性。即是空所顯性。故舜若。斷滅空也。舜若多。真性空也。


第四項 修證功能

    度一切苦厄。
    度者。超越義。渡也。過也。濟度自他。超拔眾苦也。
    一者。數之始。究竟非二。切者。盡際義。梵語娑娑。此云一切。普徧義。賅羅全體。包含無餘之意。又平等性義。凡所包含。悉無差別。
    苦。梵語豆佉盧。逼惱義。世出世間一切有為心行。常為無常患累逼迫。不能自適。故名為苦。厄者。困也。本經所用苦厄二字。義相連貫。故下文但云。能除一切苦。不及厄字。諸經言苦。有二苦、三苦、四苦、五苦、八苦、十九苦、百苦、百一十苦種種。皆由惑業而起。菩薩朗照五蘊。澈見真空。惑業既消。苦惱同盡。
    【注】從來解釋苦厄二字。分三義。一，持業釋。苦即厄也。二，依主釋。苦之厄也。三，相違釋。苦與厄也。此從持業釋（諸法以二義以上為名者。以六種法式。分別其名義。初，離釋二義。後，合釋二義。故謂之六離合釋。略稱曰六合釋。梵語殺三摩娑。殺，此云六。三摩娑，此云合也。一，持業釋。體能持用。謂之持業。此義雖二。而體則一之名也。如說藏識。識是體。藏是業用。用能顯體。體能持業。藏即識故。亦名同依釋。藏取含藏用。識依了別用。同一所依之法體故。二，依主釋。亦名依士釋。從所依之體。而立能依之法之名也。如說眼識。為依眼而生之識。眼為所依之體。識為能依之法也。三，有財釋。亦名多財釋。全取他名而為自名。如說唯識論。為有唯識之理之論也。四，相違釋。二體所詮。各別自主。不相隨順。而合之為一名。如說教觀。教與觀各有獨立之義。而合為一名也。五，鄰近釋。從近為名。如四念住。以慧為體。而與之相應而起之念力特強。故從近而名念住也。六，帶數釋。以數顯義。如五蘊、十二處、十八界是也。此六離合釋。往往兼通。一名非必局於一釋。如說五蘊。五即是蘊。此用自為名。即帶數而兼持業。如說眼等六識。取自他為名。即帶數而兼依主。如說五業為五無間。無間是果。五業是因。即因談果。全取他名。即帶數而兼有財）。
    二苦者。一，內苦。更分為二。甲，身苦。一大不調。生百一病。四大不調。生四百四病。是為身苦。乙，心苦。憂、愁、瞋、苦、嫉、妒、疑，是為心苦。二，外苦。虎狼毒害，風雨霜雪，身外所受襲擊皆是。見《智度論·十九》。惟識宗以世俗諦苦、勝義諦苦為二苦。世俗諦苦，為世間智境界。生、老、病、死、愛別離、怨憎會、求不得，各苦屬之。勝義諦苦，為出世間智境界。略攝五取蘊苦。見《雜集論·六》。
    三苦者。一，苦苦。二，壞苦。三，行苦。此三苦義有通別。別者。對三受言。一者。苦受。從苦緣生。有漏之身。性常逼迫。苦上加苦。是名苦苦。欲界苦也。二者。樂受。樂境盡時。苦相即至。樂極悲生。是名壞苦。色界苦也。三者。不苦不樂受。生住異滅。四相遷流。有漏之法。常不安穩。是名行苦。無色界苦也。若以通論。三受皆從苦緣生。全是苦苦。三受皆有壞相現。全是壞苦。三受均是無常相。全是行苦。見《俱舍論·十二》。又三苦者。一，依內苦。身心所受之苦。二，依外苦。人物見害之苦。三，依天苦。風雪霜露之苦。見《金七十論·上》。又無量眾生有三種身苦。老、病、死也。三種心苦。婬、瞋、癡也。三種後世苦。地獄、餓鬼、畜生也。見《智度論·九》。又一，會合所生苦。二，乖離所生苦。三，平等相續苦。見《瑜伽論·十四》。
    四苦者。一，生苦。果報始起為生。生時有苦。二，老苦。身體衰變為老。老時有苦。三，病苦。四大增損為病。病時有苦。四，死苦。五蘊壞離為死。死時有苦。是為四苦。見《大乘義章》。又一，生苦。二，緣內苦。三，緣外苦。四，麤重苦。見《瑜伽論·五十五》。
    五苦者。生、老、病、死外。加一獄苦。謂違法犯罪。枷鎖繫身。禁閉牢獄。受諸刑罰。統稱五苦。見《五苦章句經》。又八苦中合生、老、病、死四苦為一苦。加愛別離苦、怨憎會苦、求不得苦、五蘊盛苦。亦稱五苦。見《三藏法數引析玄記》。
    八苦者。一，生苦。一者受胎。識託母腹。窄狹不淨。二者種子。父精母血。構結成胎。隨母氣出入，不得自在。三者增長。住胎十月。內熱煎逼。身形漸成。寄於生臓之下。熟臓之上。間夾如獄。四者出胎。方出生時。冷風熱氣。以及衣物。觸體如刺。五者種類。既出生後。貧富貴賤。殘整妍醜。種種不齊。滋生煩惱。是名生苦。二，老苦。一者增長。從少至壯。從壯至衰。氣力羸弱。動止不寧。二者滅壞。盛去衰來。精爽消亡。其命日促。終至朽壞。是名老苦。三，病苦。一者身病。四大不調。眾病交攻。地大不調。舉身沈重。水大不調。舉身胖腫。火大不調。舉身蒸熱。風大不調。舉身木強。二者心病。心神苦惱。憂慮悲思。是名病苦。四，死苦。一者病死。命盡身喪。二者外緣。水火災厄。是名死苦。五，愛別離苦。親愛離散。不能常聚。是名愛別離苦。六，怨憎會苦。怨雠憎惡。求離反聚。是名怨憎會苦。七，求不得苦。世間名利愛樂。圖謀無望。是名求不得苦。八，五蘊盛苦。五陰熾盛。蓋覆真性。眾苦交集。是名五蘊盛苦。見《涅槃經·十二》。
    十苦者。一，生苦。二，老苦。三，病苦。四，死苦。五，愁苦。六，怨苦。七，苦受。八，憂苦。九，病惱苦。十，生死流轉苦。見《釋氏要覽引菩薩藏經》。
    十九苦者。一，愚癡異熟苦。二，行苦所攝苦。三，畢竟苦。四，因苦。五，生苦。六，自作逼惱苦。七，戒衰損苦。八，見衰損苦。九，宿因苦。十，廣大苦。十一，那落迦苦（那落迦。地獄也。此云惡者。造惡之人生彼處也）。十二，善趣所攝苦。十三，一切邪行所生苦。十四，一切流轉苦。十五，無智苦。十六，增長苦。十七，隨逐苦。十八，受苦。十九，麤重苦。見《瑜伽論·四十四》。
    百苦者。二十五有（二十五有。不出三界六道。欲界占十四有。四洲為四有。東，弗於逮洲。西，瞿耶尼洲。南，閻浮提洲。北，鬱單越洲。四惡趣為四有。六道中除人天外。修羅、餓鬼、畜生、地獄，四惡趣也。六欲天為六有。色界天占七有。初禪、二禪、三禪、四禪、初禪之大梵、四禪之無想、五那含。大梵、無想、五那含，所以於初禪天四禪天之外。別出其名。各占一有者。因外道以大梵天為萬物之主。無想以無心為涅槃。計五那含為真解脫。故特標以破之。無色界天占四有）。各有生、住、異、滅四有為相（生、住、異、滅。四相皆有為法。從生至死。就一期受報而言。為大四相。一念託胎。十月滿足。此身即生。是為生相。既出胎已。住於世間。是為住相。少時顏紅體潤。老年髮白面皺。是為異相。業盡命終。身亦壞滅。是為滅相。從一念起滅而言。為小四相。以根對塵。一念心生。是為生相。一念之心。暫爾相續。是為住相。一念之心。先後不同。是為異相。塵境既忘。心念亦滅。是為滅相）。有為身心。都成煩惱。合之成百苦也。
    百一十苦者。分之為一苦。二苦。三苦。四苦。五苦。六苦。七苦。八苦。九苦。十苦。一苦者。依無差別流轉之苦。二苦者。一，欲為根本苦。謂可愛事若變若壞所生之苦。二，癡異熟生苦。謂若猛利體受所觸。即於自體執我我所。愚癡迷悶。生極怨嗟。由是因緣。受二箭受。謂身箭受及心箭受。三苦者。一，苦苦。二，行苦。三，壞苦。四苦者。一，別離苦。謂愛別離所生之苦。二，斷壞苦。謂由棄捨眾同分死所生之苦。三，相續苦。謂從此後數數死生展轉相續所生之苦。四，畢竟苦。謂定無有般涅槃法諸有情類五取蘊苦。五苦者。一，貪欲纏緣苦。二，瞋恚纏緣苦。三，惛沈睡眠纏緣苦。四，掉舉惡作纏緣苦。五，疑纏緣苦。六苦者。一，因苦。習惡趣因故。二，果苦。生諸惡趣故。三，求財位苦。四，勤守護苦。五，無厭足苦。六，變壞苦。七苦者。一，生苦。二，老苦。三，病苦。四，死苦。五，怨憎會苦。六，愛別離苦。七，希求而不得苦。八苦者。一，寒苦。二，熱苦。三，飢苦。四，渴苦。五，不自在苦。六，自逼惱苦。謂無繫等諸外道類。七，他逼惱苦。謂遭遇他手塊及蚊虻等觸。八，一類威儀多時住苦。九苦者。一，自衰損苦。二，他衰損苦。三，親屬衰損苦。四，財位衰損苦。五，無病衰損苦。六，戒衰損苦。七，見衰損苦。八，現法苦。九，後法苦。十苦者。一，諸食資具匱乏苦。二，諸飲資具匱乏苦。三，騎乘資具匱乏苦。四，衣服資具匱乏苦。五，莊嚴資具匱乏苦。六，器物資具匱乏苦。七，香鬘塗飾資具匱乏苦。八，歌舞伎樂資具匱乏苦。九，照明資具匱乏苦。十，男女給侍資具匱乏苦。復有餘九種苦。一，一切苦。二，廣大苦。三，一切門苦。四，邪行苦。五，流轉苦。六，不隨欲苦。七，違害苦。八，隨逐苦。九，一切種苦。一切苦中復有二苦。一，宿因所生苦。二，現緣所生苦。廣大苦中復有四苦。一，長時苦。二，猛利苦。三，雜類苦。四，無間苦。一切門苦中復有四苦。一，那落迦苦。二，傍生苦。三，鬼世界苦。四，善趣所攝苦。邪行苦中復有五苦。一，於現法中犯觸於他他不饒益所發起苦。二，受用種種不平等食界不平等所發起苦。三，即由現法苦所逼切自然造作所發起苦。四，由多安住非理作意所受煩惱隨煩惱纏所起諸苦。五，由多發起諸身語意，種種惡行所受當來諸惡趣苦。流轉苦中復有六種輪轉生死不定生苦。一，自身不定。謂先為王後為僕隸。二，父母不定。三，妻子不定。四，奴婢僕使不定。五，朋友宰官親屬不定。謂先為父母乃至親屬。後時輪轉。反作怨害及惡知識。六，財位不定。謂先大富貴。後極貧賤。不隨欲苦中復有七苦。一，欲求長壽。不隨所欲。生短壽苦。二，欲求端正。不隨所欲。生醜陋苦。三，欲生上族。不隨所欲。生下族苦。四，欲求大富。不隨所欲。生貧窮苦。五，欲求大力。不隨所欲。生羸劣苦。六，欲求了知所知境界。不隨所欲。愚癡無知現行生苦。七，欲求勝他。不隨所欲。反為他勝而生大苦。違害苦中復有八苦。一，諸在家者妻子等事損減生苦。二，諸出家者貪等煩惱增益生苦。三，飢儉逼惱之所生苦。四，怨敵逼惱之所生苦。五，曠野險難迫迮逼惱之所生苦。六，繫屬於他之所生苦。七，支節不具損惱生苦。八，殺、縛、斫、截、捶打、驅擯、逼惱生苦。隨逐苦中復有九苦。依世八法有八種苦。一，壞法壞時苦。二，盡法盡時苦。三，老法老時苦。四，病法病時苦。五，死法死時苦。六，無利苦。七，無譽苦。八，有譏苦。是名八苦。九，悕求苦。一切種苦中復有十苦。一，因苦。二，受苦。三，唯無樂苦。四，受不斷苦。五，出離遠離寂靜菩提樂所對治家欲界結尋異生苦。六，逼迫苦。七，眾具匱乏苦。八，界不平等苦。九，所愛變壞苦。十，三界煩惱品麤重苦。總有一百一十種苦。見《瑜伽論·四十四》。
  以上所說諸苦皆世間苦也。若論出世間苦。則變易生死是也。蓋生死有二。一，分段生死。二，變易生死。分即分限。段即形段。具見思惑之一切眾生。隨諸有漏善不善業。由煩惱障助緣所感欲、色、無色三界之天、人、修羅、地獄、餓鬼、畜生、六道果報也。隨其業力。身有短長。命有夭壽。故名分段生死。屬世間苦。至變易生死。因聲聞、緣覺及菩薩。雖已斷見思惑。離三界內分段生死。隨諸無漏善業。依所知障助緣所感之界外果報也。無色形之勝劣。壽命之短長。迷想漸減。證悟漸增。而有方便土等之變易生死（一，方便生死，入涅槃之二乘也。二，因緣生死。初地之變易也。三，有有生死。十地之變易也。四，無有生死。更斷一品無明。入等覺位之金剛心也）。初位為因。後位為果。後位為因。後後位為果。因移果易。捨所住位。故名變易生死。為出世間苦。
    此處苦厄之厄。與苦同義。若專說厄。當有四種。一，見厄。即三界見惑。意根對於法塵起分別見。因此見惑。流轉三界。不能脫離。二，欲厄。即欲界思惑。五根貪愛五塵。成貪瞋慢。名為思惑。因此思惑。流轉欲界。不能脫離。三，有厄。因果不亡為有。色界無色界之思惑（即貪、慢）。因此思惑流轉色無色界。不能脫離。四，無明厄。此為迷於根本理體之惑。由此無明。流轉生死。不能脫離。
    苦之大者。無過於生死。煩惱障障涅槃。我執空則煩惱障滅。度分段生死之苦。所知障障菩提。法執空則所知障滅。度變易生死之苦。既證二空。苦惱斯盡。故曰度一切苦厄。
    《般若波羅蜜多心經詮注·卷三·上》


第一項 明蘊空

    《般若波羅蜜多心經詮注·卷三·下》
     震旦白衣周止菴學

     第二節 正示法空

    上來總說菩薩修證之恉。以次廣釋蘊空境諦。而觀照自在其中。以非觀照不能了達此境諦也。分述如左。

    第一項 明蘊空

    舍利子。色不異空。空不異色。色即是空。空即是色。受想行識。亦復如是。
    舍利子。梵語舍利弗怛羅。舍利，鳥名。此云鶖鷺。弗怛羅。此云子。故譯作鶖子。亦簡稱舍利弗。南天竺婆羅門提舍子。其母為婆羅門摩陀羅女。眼似舍利鳥。故名舍利。及懷此子。論議殊勝。從母立名。曰舍利弗怛羅。智慧無窮。決了諸疑。佛諸弟子中，智慧第一。般若會中。非利根上智。不足以當機起信。故舍利子現跡聲聞。為眾請問。菩薩呼而告之。
    【注】鶖子他經亦有譯作身子者。因梵語設利羅。此云身。設利。舍利。音相近也。
    世尊十大弟子中。摩訶迦葉。頭陀行第一。阿難陀。多聞第一。舍利弗。智慧第一。須菩提。解空第一。富樓那。說法第一。摩訶目犍連。神通第一。摩訶迦旃延。論議第一。阿[少/兔]樓陀。天眼第一。優婆離。持戒第一。羅睺羅。密行第一。此外又有摩訶拘絺羅。答問第一。摩訶離婆多。無倒亂第一。憍梵波提。受天供養第一。摩訶劫賓那。知星宿第一。薄拘羅。壽命第一。周利槃陀伽。義持第一。賓頭廬頗羅墮。應末世供福田第一。迦留陀夷。教化第一。孫陀羅難陀。儀容第一。
    現跡聲聞者《準法華文句》。身子久已成佛。號金龍陀。般若會雖在法華以前。但相去不遠。曰久已成佛。則可知在過去生中。早已成佛。此時以大權現羅漢身。為當機眾耳。

    是時佛在王舍城鷲峰山。與大比丘眾並諸菩薩摩訶薩俱。觀自在菩薩。白佛。欲說諸菩薩普徧智藏般若波羅蜜多心。承佛印可。菩薩入慧光三昧定。行深般若波羅蜜多。照見五蘊自性皆空。即從定起。告舍利子以色空不二之旨。蓋此經為般若波羅蜜多心。在般若會中。佛既以此詳示舍利子。菩薩行深般若已。為欲正示法空。故因舍利子之問而告之。
    【注】佛詳示舍利子。見《大般若經·四·初分相應品·第三》之一。又四百三。第二分觀照品第三之二。又四百八十。第三分舍利子品第二之二。《大品般若經·二·習應品·第三》。

    此段廣說五蘊自性皆空之義。色為五蘊之首。故舉色以賅其除。色即四大幻色。空乃般若真空。眾生因迷真空而成幻有之色。譬如水動成波。菩薩以般若觀慧。照見幻有緣生。原無自性。本體即空。如波平為水。水之與波。濕性無殊。幻有無異真空。如波之不異於水。故云。色不異空。所以破凡夫著相之心。真空無異幻相。如水之不異於波。故云空不異色。所以破小乘頑空之見。《大般若經》曰。色自性空。不由空故。色空非色。色不離空。空不離色。《了義般若經》曰。色自性空。空離性故。色體即空。離色無別空。空體即色。離空無別色。是義云何。名分別故。是知即色之空為真空。即空之色為幻色。非離色以明空。亦非滅色以明空。色空本體。是一非二。
    【注】華嚴三觀中之真空觀。一，會色歸空。會即融會。色即根身世界。謂根身世界。本是真如一心。 與生滅和合而有。今觀此色都無實體。歸於真心之空。故曰會色歸空。二，明空即色。明即明了。謂了真空之理。不異於色。色無自性。不異於空。故云明空即色。三，空色無礙。謂色體全是真空。真空之體。不異於色。若色是實色。即礙於空。空是斷空。即礙於色。今既色是幻色。故不礙空。空是真空。故不礙色。故曰空色無礙。四，泯絕無寄。泯即亡泯。絕即寂滅。寄。猶依也。謂所觀真空之理。不可言即色是空。亦不可言離色是空。空。不空。皆不可得。非言思能及。亦無所依。故云泯絕無寄。
《占察經》有二種觀法。於一切時一切處。隨身口意所有作業。於念念間。悉以空假中三觀。觀察所起之心。名唯識觀。思唯心性無生，無滅。不住見聞覺知。於念念間。悉以空假中三觀。觀於本心所具實相之理。名實相觀。
    言真空者。非斷滅空。非離色空。即有明空。亦無空相。故言真空。小乘析空觀。色盡方空。大乘體空觀。色即是空。蓋小乘既得人空。以為蘊空。不知蘊中無人。如云舍中無主。舍非空也。大乘則即色舉體是空。故蘊自性空。析空觀者。析色明空。以假想慧。析至極微。則色等空。又推極微有方分及無方分，皆不可得。則極微空。體空觀者。體色明空。謂緣生無性。故自、他、共、及無因，皆無生理。故《中論》云。未曾有一法。不從因緣生。是故一切法。無不是空者。
    《略疏》云。《寶性論》云。空亂意菩薩。有三種疑。一，疑空異色。取色外空。今明色不異空。以斷彼疑。二，疑空滅色。取斷滅空。今明色即是空。非色滅空。以斷彼疑。三，疑空是物。取空為有。今明空即是色。不可以空取空。以斷彼疑。三疑既盡。真空自顯。
    離色明空。如云牆處不空。牆外是空。滅色明空。如穿井者。除土出空。要須滅色。先有後無。是斷滅空。

    色即是空。空即是色者。正發明上文不異之旨。不異即即是也。又恐眾生因法成執。猶存色空二見。故正言以泯之。使行者妙契色空不二。如波即水。如水即波。動靜雖分。體性則一。永嘉云。無明實性即佛性。幻化空身即法身。是知幻境無異真如。色外無空。故色即是空。空外無色。故空即是色。《楞嚴經》曰。性色真空。性空真色。以色等本是真如一心。自性隨緣。與生滅和合。名阿賴耶識等。而為能變。變起根身器界種種幻色。雖成幻色。而體終不變。故色體全是真空。此如來藏中隨緣不變義也。真空者。自性不變。其體元空。雖其體元空。而用終不失。故空為真色。此如來藏中不變隨緣義也。《大般若經》曰。色自性空。不由空故。色空非色。色不離空。空不離色。色即是空。空即是色。受想行識自性空。不由空故。受想行識。空。非受想行識。受想行識不離空。空不離受想行識。受想行識即是空。空即是受想行識。又曰。菩薩摩訶薩。行般若波羅蜜多。不應於色求。不應於受想行識求。不應離色求。不應離受想行識求。所以者何。若色。若受想行識。若離色。若離受想行識。若菩薩摩訶薩。若般若波羅蜜多。若求如是一切。皆非相應。非不相應。非有色。非無色。非有見非無見。非有對。非無對。咸同一相。所謂無相。蓋無相即實相。色空原一實相。本無二致。凡夫執有身心。故見生滅而纏於生死二乘妄見五蘊實有其相。不了緣生。心起厭離。故墮聲聞。雖了緣生。不達無性。故墮緣覺。菩薩照了五蘊諸法。無性緣生。緣生無性。無性故空。空即真空。蓋法身真空之體。原非斷滅。故須於幻有中求。幻外無真。故曰真空。真外無幻。故曰幻色。真空幻色。不異，即是。為一經之要恉。般若之真宗。
    【注】法身者。三身之一。身者，聚集之義。聚集諸法而成身也。理法聚名法身。有五。一，法性法身。法性圓常。賅通萬有。二，功德法身。萬行功德所成。三，變化法身。無感不形。無機不應。如千江月。隨水現影。影雖有殊。月本是一。四，虛空法身。融通三際。包括大千。一性圓明。諸塵不染。五，實相法身。離諸虛妄。會極真如。不生不滅。故名實相。智法聚名報身。自受內證法樂之身。曰自受用報身。對於初地以上菩薩應現之報身。曰他受用報身。功德法聚名應身。對於初地菩薩應現者。為勝應身。應現於地前菩薩及二乘者。為劣應身。如來之法身。名毗盧遮那。此云徧一切處。報身名盧舍那。此云光明徧照。應身名釋迦牟尼。釋迦此云能。為族姓。牟尼。此云寂默。佛地論併法身、實報。皆名法身。以他受用及化身名生身。總之法身為一真法界真智所現之功德實相。報身為修因所成。應身則勝應同於他受用報身。劣應為地前菩薩及二乘所見依定而現之佛身。隨感而必應。應機示現種種異形。則為化身。《觀經淨影疏》云。八相現成者為應身。隨機現起者為化身。五種法身中之功德法身。同於報身。變化法身。同於化身。
幻境。即虛幻無實之境界。
    真如者。真實無妄之理也。梵語步多多他多。真謂真實。顯非虛妄。如謂如常。表無變易。謂此真實。於一切法常如其性。故曰真如。《大乘止觀》云。此心即自性清淨心。又名真如。亦名佛性。亦名法身。亦名如來藏。亦名法界。亦名法性。《教行信證》云。無為法身。即是實相。實相即是法性。法性即是真如。蓋皆同體而異名也。其曰一真如者。一真法界無差別也。《初門論》云。心真如者。即是一法界大總相法門體。所謂心性。不生不滅。一切諸法。唯依妄念而有差別。若離心念則無一切境界之相。是故一切法。從本以來。離言說相。離名字相。離心緣相。畢竟平等。無有變異。不可破壞。唯是一心。故名真如。其曰二真如者。更有種種。一，隨緣真如，與不變真如。隨無明之緣。而起九界之妄法。是為隨緣真如。雖隨緣而為妄法。然其真性不變。謂之不變真如。因隨緣故。真如即萬法。不變故。萬法即真如。二，空真如，與不空真如。真如究竟離染法而如明鏡。謂之空真如。真如具一切淨法。如明鏡之現萬象。謂之不空真如。三，清淨真如，與染淨真如。即隨緣真如，與不變真如之異名。四，有垢真如，與無垢真如。眾生所具云有垢真如。諸佛所顯云無垢真如。五，在纏真如，與出纏真如。即有垢真如，與無垢真如之異名。六，生空真如，與法空真如。空人我而所顯者曰生空。空法我而所顯者曰法空。七，依言真如，與離言真如。真如之體。本來離言說相。離心念相。是曰離言真如。依假名之言說而顯其相。是曰依言真如。八，安立真如，與非安立真如。即依言真如，與離言真如之異名。能生世、出世間，一切諸法而得安住。故名安立。從本以來。性自清淨。離一切相。寂滅無為。故曰非安立也。九，相待真如，與絕待真如。亦依言真如，與離言真如之異名。其曰三真如者。一，無相真如。謂諸法之體。無徧計所執之虛相也。二，無生真如。謂諸法因緣生，故無實性也。三，無性真如。謂諸法真體。言忘慮絕。故無妄情所執之實性也。其曰七真如者。一，流轉真如。謂眾生造作一切行業。流轉生死。真如之體。本無搖動。然亦不妨隨緣轉變。一切行業。不離真如。二，實相真如。無虛妄相。故名實相。了空人法二執。即是實相真如。三，唯識真如。一切行業。皆由識心。一切識心。皆由真如之理變現。是名唯識真如。四，安立真如。一切眾生色身行業有為之法。迷真逐妄。受生死苦。皆依真如之體建立。是名安立真如。為苦諦之實性。五，邪行真如。一切煩惱妄惑邪行之法，不離真如之體。是名邪行真如。為集諦之實性。六，清淨真如。如來所說涅槃清淨之理。本無染污。是名清淨真如。為滅諦之實性。七，正行真如。如來所說一切道品正行之法。皆依真如理體。是名正行真如。為道諦之實性。其曰十真如者。一，徧行真如。此真如為我法二空所顯。一法無所不在。故曰徧行。二，最勝真如。具足無邊功德。於一切法為最勝。三，勝流真如。教法殊勝。故名勝流。四，無攝受真如。非兩執之所依。故名無攝受。五，類無別真如。生死涅槃。二皆平等。無差別相。故名無別。六，無染淨真如。本性無染。故名無染淨。七，法無別真如。以多數法。種種安立。無別無異。故名法無別。八，不增減真如。不隨染淨而有增減。故名不增減。證此真如。則現相現土。俱得自在。故又名相土自在所依真如。九，智自在所依真如。若證此真如已。於無礙解得自在。十，業自在所依真如。於一切神通作業。陀羅尼定門。皆得自在。故以為名。又《大般若經》及《大涅槃經》十二無為。亦名十二真如。一，真如。二，法界。界者所依之義。三，法性。諸法體性也。四，不虛妄性。諸法有為。皆虛妄性。對之而言不虛妄也。五，不變異性。無變異也。六，平等性。無差別也。七，離生性。離生滅也。八，法定。法性常住也。九，法住。諸法住於真如也。十，實際。法性真實之際極也。十一，虛空界。喻理體之周徧法界也。十二，不思議界。理絕言思也。總之真如之性。實無差別。一切言說。假名無實。言真如者。亦無有相。真如之名。亦是假設。諸經隨其勝德而立假名。行者借以修證。不可執名誤實。
    如來藏者。真如隱覆。未成法身之名。如來者。理性。如來藏者。含藏之義。因中說果。故名如來。含藏者。有三義。一者。所攝真如。立於眾生之位。含和合不和合之二門。含和合門者。生一切之染法。含不和合門者。生一切之淨法。一切染淨之法。皆攝於真如。《勝鬘經·寶窟·下》曰。一切眾生。無有出如如境者。並為如如所攝。故名藏也。則眾生為如來所攝。二者。隱覆。如來性德。為煩惱隱覆而不顯也。《勝鬘經·寶窟·下》曰。如來性住在道前。為煩惱隱覆。眾生不見。故名為藏。是眾生藏如來也。三者。能攝。真如在煩惱中。含攝如來一切果地之功德。故名如來藏。《起信論》云。如來藏具足無量性功德故。《義記》云。隱時能出生如來。名如來藏。顯時為萬德依止。名為法身。憨山師《楞嚴圓鏡》。則以如來藏為三觀之體。一，空如來藏。謂此藏性。其體本空。一法叵得。如摩尼珠。其體空淨。了無色相。雖有隨方之色。色不離珠。以即珠故。真心本淨。了絕妄緣。雖有隨緣之妄。妄不離真。以即真故。名曰真空。故為觀者先示真心。以為觀體。能觀此體。名真空觀。即體真止（體無明顛倒。即是實相之真）。二，不空如來藏。謂此藏體雖空。具有恒沙稱性功德。包含融攝。纖悉不遺。如摩尼珠。其體雖淨。具有圓照之用。隨方現一切色。色即是珠。以珠現故。藏性雖如。而能隨緣顯現十界依正之相。相即是性。以性起（從緣無性。緣起即名性起。又法性隨緣。淨緣起常順於性。亦名性起。起有二。一，染。二，淨。淨謂如來大悲。菩薩萬行等。染謂眾生惑業等。以染奪淨。則屬眾生。故惟緣起。以淨奪染。惟屬諸佛。故名性起）故。名不真空。故為觀者示此藏性。以為觀體。能觀此體。名不空觀即方便隨緣止（實相徧一切處。隨緣歷境。安心不動）。三，空不空如來藏。謂此藏性。其體淨圓。能應能現。淨故非色。以即珠故圓故能應非不色。以即色故。淨故非相。以即性故。圓故能現非不相。以即相故。非相非性。名空不空。非相故空。非性故不空。非即非離。平等如如。名曰中道。故為觀者示此藏性。以為觀體。能觀此體。名中道觀。即離二邊分別止（生死涅槃。靜散休息）。
    相應者。契合義。如函蓋之相稱。一，事契合。如心心所之相應。二，理契合。如瑜伽之境（一切所緣境。與心相應）、行（一切行與理相應）、果（三乘聖果。與諸功德法相應）三種相應。
    有色。即有色身之欲界。色界。無色。即無色界。
    有見。即常見。執著於有。以為身心常住。增益實性之妄見也。無見。即斷見。執著於無。以為身心斷滅。永不續生。損減實性之妄見也。
    有對者。對。礙也。一，障礙。二，拘礙。就十八界分別。有三種有對。一，障礙有對。以五根、五境之十色為體。十色互相障礙。如手之礙手。石之礙石。此障礙也。二，境界有對。六根六識之十二界。與法界一分之心所法。為境所拘。三，所緣有對。六識及意根之七心界，與法界之一分心所法，八界。為所緣之境所拘。此二者皆拘礙也。從根及心識一邊言。為境界有對。從緣心與所緣之境一邊言。為所緣有對。
    幻有者。假幻無之事。以顯法之假有。迷真空之理。成幻有之事。虛假不實也。有二說。一，謂幻有必覆真空。幻有若現。真空必隱。二，謂幻有不礙真空。真空若顯。幻有自滅。
    非有之有（非如凡夫妄計之實有）。為妙有。非空之空（非如小乘偏執之但空）。為真空。以真空故。緣起之諸法宛然。以妙有故。因果之萬法一如。有二說。一，謂真空能滅幻有。若幻有不滅。即非真空。二，謂真空能成幻有。幻有若礙。亦非真空。

    色蘊既爾。四蘊皆然。故云受想行識亦復如是。如是者。指示之辭。指示四蘊不異於空。即是空性。與色蘊同也。《大般若經》曰。色不異空。空不異色。色即是空。空即是色。受想行識不異空。空不異受想行識。受想行識即是空。空即是受想行識。故經云五蘊皆空。菩薩以此現前五蘊身心為所觀境。了境唯心。觀心忘境。觀一蘊空。則蘊蘊皆空。《圓覺經》云。幻身滅故。幻心亦滅。幻心滅故。幻塵亦滅。幻塵滅故。幻滅亦滅。幻滅滅故。非幻不滅。圓覺破幻顯真。此經即幻是真。旨雖不同。其果則一。既知此心真妄同源。空有不二。即此現前一念。妄想起處。以智觀察。見幻無體。便是真空。即凡心而見佛心。從幻妄以悟真如。譬如磨鏡。垢盡鏡明。鏡性本明。非從外得。
    【注】五蘊之中。色為色法。受想行識為心法。上文既明色空不二之旨。故復推及心法四蘊。所以先色而後心者。以五蘊根元。重疊生起。由一念不覺。而轉為無明業識。因識有行。因行有想。因想有受。因受有色。自細至粗。譬如著衣。由內至外也。若欲滅除。則先除色。次除受想行，最後除識。從粗至細。譬如脫衣。先外後內也。《楞嚴經》曰。生因識有。滅從色除。長水云。生起則從細至麄。從內感外。一切諸法。唯識變故。故云生因識有。除斷則先麄後細。從外向內。如浣衣磨鏡。麄垢先落。故云滅從色除。


第一款 總標

    第二項 顯空德
    本項更分為二。上總標。下別釋。

    第一款 總標

    舍利子。是諸法空相。不生。不滅。不垢。不淨。不增。不減。
    是者。指示之辭。猶言此也。諸者。眾也。不一之義。諸法者。略則五蘊。廣則蘊，處，界，締，緣，七大，十法界，皆是。空相。則真空實相也。蓋諸法本空。空性亦空。空中之空。尚不可得。何況諸法。前言五蘊幻有。原無實性。而未及於相。或將疑為法性可空。而法相不爾。故此申之云諸法空相。既云諸法空相。則不可離諸法而別言空相。夫一切法無相。故諸法當體即是真空之相。譬如水月鏡花。不可作之使生。壞之使滅。染之使垢。治之使淨。加之使增。損之使減。何以故。以彼影象無實性故。當體即空。亦如虛空不可以生，滅，垢，淨，增，減。真空之相亦然。無相之相。強名之曰實相。此真空實相者。即自性。即真如。離言說相。離文字相。離心緣相。所謂言語道斷。心行處滅。非五眼所能窺。非心智所能測。惟證者知之。實相無相。故不落有。空相無無相。故不落空。空相亦空。是名真空。
    是諸法空相句。唐法成三藏譯本。作一切法空性無相。智慧輪三藏譯本。作是諸法性相空。由藏文轉譯者。能海寬本。作一切法空無相。孫慧風本。作一切法自性空無相。慧清本。作是故諸法空性無相。超一本。作一切法空性。可徵諸法真空實相。即是無相。以一切法非實有相。無色，無見，無對，一相。所謂無相。《大般若經》曰。一切法自相皆空。能取，所取，皆不可得故。又曰。如是無相。既非有相。亦非無相。何以故。非一切法先是有相。後成無相。以一切法本是無相。後亦無相。《中邊分別論》云。無二有此無。是二名空相。無二者。謂無能取，所取。有此無者。謂但有所取，能取無。是二名空相者。謂無及有無。是名空相。此顯真空無有二相。《辯中邊論》云。無二有無故。非有亦非無。非異亦非一。是說為空相。無二。謂無能取所取。有無。謂有二取之無。此即顯空無性為性。故此空相。非有非無。云何非有。無二有故。云何非無。有二無故。此顯空相非有非無。故《大般若經》曰。惟觀一切法。無不皆空。是為覺知諸法實相。以觀一切法空故。即無相亦不可執著。《宗鏡錄》云。若以無相為無相。無相即為相。捨有之無。猶逃峰而起壑。
    【注】空相者。實相也。經云。無相不相。名為實相。無相者。無生死相也。不相者。不涅槃相也。生死涅槃俱盡。常寂滅相。故名為空。不二不異。離虛偽顛倒，常樂我淨，即空假中，故名實相。
    無漏正智。能契合於所緣之真理謂之證。《大乘義章》。己情契實。名之為證。又曰。證者。智得之別名也。
    清涼云。無妄法之有。有妄法之無。有無有二。一，定性有無。二，真空妙有。無妄法之有。則無定性之有。非斷無矣。有妄法之無。是真空之無。便為妙有。是故若舉妄取真。則妄有真空。如三論說。若空有對辨。則妄空真有。如涅槃明。無能取、所取有者。則無妄法之有也。
    有能取、所取。無者。則有妄法之無也。故曰。遂令緣起之相。相無不盡。無性之理。理無不現。
    能取，所取，二名之義。相宗與性宗所說。廣略不同。以依他之能緣為能取。所緣為所取。即見、相二分。以見分能取相分。如眼見色。相分為見分所取。如色被見。此性宗之說也。以徧計之見執為能取。相執為所取。即執能取之見分。及所取之相分為實有。則不能了空。不能了空。則煩惱所知二障。不能伏斷。此相宗之說也。性宗捨妄取真。則妄有真無。相宗真俗相待。則妄無真有。有無不定。二即不二。如《雜集論·三》云。為捨執著能受用我故。觀察能取。受用我者。計我能得愛、不愛境。又云。謂諸能取。亦是所取。以眼根等意識所取故。或有所取，非能取。謂唯是取所行義。唯者。決定義。此言為簡。心所有法一切皆是所取。謂捨執著境界我故。觀察所取。
    無色者。謂有色相違。是無色義。無見者。謂有見相違。是無見義。無對者。謂有對相違。是無對義。見《雜集論·三》。
    一相者。謂一真法界之相。從本以來。離虛妄相。離言說相。離名字相。離一切諸法之相。故名一相。但一相亦不可執。故《起信論》云。當知真如自性。非有相。非無相。非非有相。非非無相。非有無俱相。非一相。非異相。非非一相。非非異相。非一異俱相。
    無相者。諸相寂靜故。諸相者。謂色、受等乃至菩提。諸所戲論。真如性中。彼相寂靜。故名無相。見《雜集論·二》。

    不者。否定之辭。本無今有名生。暫有還無名滅。緣聚則生。緣盡則滅。同屬虛妄。總非真實。《大般若經》曰。真實理中。無有一法。可生可滅。何以故。世間諸法。皆因緣生。無我、有情、作者、受者。因緣和合。說諸法生。因緣離散。說諸法滅。無一實法受生滅者。虛妄分別。於三界中但有假名。隨業煩惱。受果異熟。若以般若波羅蜜多如實觀察。則一切法無生、無滅、無作、無受。若法無作。是亦無行。則於諸法。心無所著。《勝天王問般若經》曰。一切諸法。自性本空。無生無滅。緣合謂生。緣散謂滅。自性非無。是故不生。自性非有。是故不滅。《智度論》云。空故無相。無相則無作無起。是法常住不壞。故無生無滅。
    【注】或謂因緣之法。正是生滅。何云不生不滅 。不知約俗諦言。緣聚則生。緣散則滅。係指法相。見法相之生滅。可證法性之本不生滅。執相昧性。凡夫所以有輪迴生死之苦。此治著有之病。若約真諦言之。則不生不滅。所以對治凡夫著生滅相之病。須知性相不二。空有同時。有即是空。故俗諦之生滅。為假生假滅。空即是有。故真諦之不生不滅。亦是假不生不滅。隨緣度生。性不離相。執性厭相。二乘所以有變易生死之苦。此治著空之病。
    圭峰師云。不生不滅。約境說有五。一，就徧計說。由是妄執。無法可生滅也。又理無故不生。情有故不滅。不滅，不生。同為一法。二，就依他說。謂緣會，生即無生。緣離，滅而不滅。又緣起無性。故不生。無性緣起，故不滅。《中論》云。以有空義故。一切法得成。是故不生，即不滅。不滅，即不生。為一物也。三，約圓成性說。謂非是有為故。無彼生滅相。又非妄心境故不生。聖智所證故不滅。不滅，即不生。為一物也。四，通論三性。混融於一法上。就徧計則一向生滅。就圓成惟不生滅。就依他亦生滅，亦不生滅。就三無性故。非生滅，非不生滅。五，即此四句。合為一聚。圓融無礙。約行說。妄念斯寂。有如虛空。何生，何滅。又雖起大用見心無生。用謝歸寂。了心無滅。又常稱真理。寂然居境。於此心中。有何生滅。
    無住禪師云。見境心不起名不生。不生即不滅。既無生滅。即不被前塵所縛。當處解脫。
    障染為垢。無垢為淨。《智度論》云。若法不生，不滅。如虛空。云何有垢，有淨。譬如虛空。雖萬歲雨而不濕。雖大火燒而不爇。何以故。本自無生故。
    【注】《會要》云。淨行為治。對染名淨。則信位十善淨行。治十惡染故。乃至金剛心位。覺生相無明之垢。故云垢淨位。賢首師云。已斷障故名淨。斷未盡故名垢。又修起淨德名淨。淨德未圓。猶帶障故名垢。又異前位故名淨。異後位故名垢。真空離此。故經不之。

    增者。增長結集之義。減者。減損衰退之義。《大般若經》曰。一切法非減，非增。是謂般若波羅蜜多。又曰。色蘊非減，非增。受想行識蘊。亦非減，非增。如是色蘊非減，非增。是謂般若波羅蜜多。如是受想行識蘊。亦非減，非增。是謂般若波羅蜜多。又曰。菩薩摩訶薩。如是行般若波羅蜜多。不見生。不見滅。不見染。不見淨。何以故。但假立客名。別別於法。而起分別。假立客名。隨起言說。如如言說。如是如是。生起執著。菩薩摩訶薩。修行般若波羅蜜多時。於如是等。一切不見。由不見故。不生執著。又曰。是諸法空相。不生，不滅。不染，不淨。不增，不減。非過去。非未來。非現在。
    【注】《大般若經·四百三十一》曰。此般若波羅蜜多所有義趣。不應以二相觀。不應以非二相觀。非有相。非無相。非入。非出。非增。非減。非染。非淨。非生。非滅。非取。非捨。非執。非不執。非住。非不住。非實。非不實。非相應。非不相應。非和會。非離散。非因緣。非非因緣。非法。非非法。非真如。非非真如。非實際。非非實際。如是義趣。有無量門。
    《賢首心經略疏》。於此節有三釋。一，就位釋。二，就法釋。三，就觀行釋。初就位釋者。不生，不滅。在道前凡位。謂諸凡夫死此生彼。流轉長劫。是生滅位。真空離此。故云不生，不滅。不垢，不淨。在道中菩薩等位。謂諸菩薩障染未盡。淨行已修。名垢淨位。真空離此。故云不垢，不淨。不增，不減。在道後佛果位中。生死惑障。昔未盡而今盡。是減也。修生萬德。昔未圓而今圓。是增也。真空離此。故云不增，不減。二，就法釋者。謂色從緣起。真空不生。色從緣謝。真空不滅。又隨流不染。出障非淨。障盡非減。德滿不增。此生滅等是有為法相。反此以顯真空之相。故云空相。三，就觀行釋者。謂於三性立三無性觀。於徧計所執性作無相觀。謂彼即空。無可生滅。於依他起性作無生觀。謂依他染淨從緣無性。於圓成實性作無性觀。謂前二不有而非減。觀智照現而不增。又在纏出障。性無增減。又妄法無生滅。緣起非染淨。真空無增減。以此三無性。顯彼真空相。道前。謂見道前也。即目十信以前。道中者。見修二道。十地位中。道後者。究竟位也。佛性論立三種佛性。一，道前。名自性住佛性。二，道中。名引出佛性。三，道後。名至得果佛性。佛性惟一。就位分三。真空無異。亦就位分異。清涼云。住自性性者。謂道前凡夫位。引出性者。從發心以上。窮有學聖位。至得性者。無學聖位。《會要》云。道前名自性住者。謂正因佛性。處於染中。性恒不變故。道中名引出佛性者。謂此位以有緣了二因。令性增長而顯發故。道後名至得者。以前二位雖得而非至。果位得極。方名至也。
    孤山云。色不異空。故不生。空不異色。故不滅。色不異空。故不垢。空不異色。故不淨。色不異空。 故不增。空不異色。故不減。生死即涅槃。故不生。涅槃即生死。故不滅。煩惱即菩提。故不垢。菩提即煩惱。故不淨。結業即解脫。故不增。解脫即結業。故不減。
    古雲云。法既常寂。妄自奚生。不受一塵。故曰空相。空一切妄。亦名實相。昔則不生。今則無滅。煩惱非垢。涅槃非淨。處聖不增。在凡不減。究竟平等。徧一切處。作是觀者。即同諸佛。
    《連珠記》云。一者。珠現青黃而珠不生。青黃遽亡而珠不滅。二者。如華華空。空不生華。華去空澄。空不加淨。三者。德本不生。真空本有。湛然不生。其何增耶。障本不滅。妄惑本空。滅無可滅。將誰減耶。
    上來所說生滅。約指五蘊，十二處，十八界。垢淨。約指四諦，因緣。增減。約指智，得。以蘊、處、界，迷真逐妄。故見生滅。十二因緣有流轉、還滅二門。流轉門，是苦、集二諦。為世間因果故垢。還滅門，是道、滅二諦。為出世間因果故淨。菩薩修行。道有所增。惑有所減。故云增減。今言不生不滅。不垢不淨。不增不減。是明真空相中。本無凡聖、修證、因果等法。直顯般若一真空體。諸見脫落。獨露真常。《法華經》曰。諸法從本來。常自寂滅相。諸法本自不生，不滅。既無生滅。自無垢淨增減可言。當體即是真空。真空即是實相。
    【注】《事觀解》云。生滅，約體。以真空體。非前際生。非後際滅。絕常絕斷。故云不生滅也。垢淨，約相。以真空相。非迷時垢，非悟時淨。離有離無。故云不垢淨也。增減，約用。以真空用。非聖位增。非凡位減。超異超一。故云不增減也。又生滅、世間蘊、處、界、法。垢淨、出世諦、緣、法。增減上上菩提，涅槃法。就世法言。蘊。是生、滅。處。是垢、淨。界。是增、減。就出世法言十二因緣，生滅、四諦、垢淨、智得、增減，真空離此，故云不也。又不生，實諦觀。不滅，世諦觀。合名第一義諦觀。不垢，空性觀。不淨，色相觀。兼則中心觀。不增，無為觀。不減，有為觀。連成性空觀。又不生滅。生空觀也。不垢淨。法空觀也。不增減。俱空觀也。六相既遣。空理自顯。如冰未消。自有凝、散、污、潔、巨、細等相。既化為水。便歸不生不滅體矣。真空亦然。


第一。五蘊

    第二款 別釋

    以下別明空相。五蘊、十二處、十八界、空。世間法也。十二因緣空。緣覺法也。四諦空。聲聞法也。智得空。權教菩薩法也。以權教菩薩隨相修行。有能得之智與所得之法也。本款所釋。大致同《楞嚴經》。楞嚴顯一心絕染。故言非。本經明諸法空相。故言無。以下依次釋之。

    第一目 三科

    科者。門類之義。三科者。五蘊、十二處、十八界也。《楞嚴經》以五蘊、六入、十二處、十八界為四科。今經合根、塵，為十二處。故作三科。
    真空實相。本離一切凡聖等法。故無蘊、處、界相可得。所以破眾生我執之見。迷於心偏重者。則合色為一。開心為四。云合色者。以五根、六塵。合之為色也。云開心者。於心法中開受、想、行（心所）、識（心王）之四也。令其細觀於心。故說五蘊。是為合色開心。迷於色偏重者。則開色為十半。謂五根、五塵為十處。及法處一分（意所取境。名之曰法。法處有四。一，心所。二，不相應行。三，無為。四，無表色。今但取無表色一分。故云半）。合心為一半。謂意處全。及法處一分（僅心所一分故云半）。令其細觀於色。故說十二處。是為開色合心。其色心共迷者。則開色為十半。謂五根、五塵及法處一分（無表色）。開心為七半。謂六識。意根及法處一分（心所）。令其一一細觀。故說十八界。是為心色俱開。
    眾生細觀色心二法。皆從虛妄因緣而生。起惑造業。輪轉生死。如以真空妙智。悟此妄源。無有實體。絕名離相。則自不為惑染所縛。次分釋之。
    【注】絕名離相云者。如《大般若經·三百八十四》曰。善現。如是等一切名。皆是假立。為表諸義。施設諸名。故一切名。皆非實有。諸有為法。亦但有名。由此無為。亦非實有。愚夫異生。於中妄執。菩薩摩訶薩行深般若波羅蜜多時。方便善巧。教令遠離。作如是言。名是分別妄想所起。亦是眾緣和合假立。汝等不應於中執著。名無實事。自性皆空。非有智者。執著空法。如是。善現。菩薩摩訶薩行深般若波羅蜜多時。方便善巧。為諸有情。說離名法。善現。是謂為名。云何為相。善現。相有二種。愚夫異生。於中執著。何等為二。一者。色相。二者。無色相。何謂色相。善現。諸所有色。若過去。若未來。若現在。若內。若外。若麤。若細。若劣。若勝。若遠。若近。於此剎那諸空法空中。愚夫異生。分別執著。是名色相。何謂無色相。善現。謂諸所有無色法中。愚夫異生。取相分別。生諸煩惱。是名無色相。菩薩摩訶薩行深般若波羅蜜多時。方便善巧。遠離二相。復教安住無相界中。雖教安住無相界中。而不令其墮二邊執。謂此是相。此是無相。如是。善現。菩薩摩訶薩行深般若波羅蜜多時。方便善巧。令諸有情。遠離眾相。住無相界而無執著。又曰。佛告善現。所化有情。住在名相虛妄分別。諸菩薩摩訶薩從彼名相虛妄分別。拔濟令出。

    第一。五蘊。

    是故空中無色。無受想行識。

    是故者。承上文而言。此真空實相之中。既不可以生滅垢淨增減求之。故總結云。無色，無受想行識，等。無者。梵語云阿。空義。一切法不生義。真空之中，無五蘊等法。法性自空。不待壞故。清涼云。性主於內。相主於外。二者相成。謂由從緣無性。名為性空。故令體相無不空寂。即法相空。此以性空。成於相空也。由諸相蕩盡。是故空中無色。無受想行識。方顯法性本空。此以相空成於性空也。既知諸相當體即空。則自無可執取。而得自在。
    梵語塞徤陀。此云蘊。積也。聚也。色受想行識諸有為法。和合積聚。謂之五蘊。
    【注】自漢以來。塞徤陀譯作陰。晉僧叡改譯為眾。奘師改譯為蘊。
小乘轉五蘊成五分法身。即轉色蘊成戒身。受蘊成定身。想蘊成慧身。行蘊成解脫身。識蘊成解脫知見身。見《請觀音經疏》。大乘轉五蘊成三德。即轉色蘊成法身德。受想行三蘊成解脫德。識蘊成般若德也。見《攝大乘論》。

    一。色蘊。
   色者。變礙義。變謂變壞。礙謂質礙。眾微聚集。自成形質。能為障礙也。和合積聚。故名為蘊。《廣五蘊論》云。云何色蘊。謂四大種及大種所造色。故色蘊之色。含義視色塵之色為廣。謂世間相續，品類，趣，處，差別。色等總略攝故。所有色。若過去。若未來。若現在。若內。若外。若麤。若細。若勝。若劣。若近。若遠。如是總攝為一色蘊。
    【注】世間者。別於出世間而言。蘊中不攝無為法也。相續者。言一切諸法。無論有情無情。皆是剎那生滅。前者滅。後者生。相續不斷也。品類。即種類。顯其種類不一。趣者。天人鬼畜地獄五趣也。處者。指人、天等處。是五趣雖雜居一處。而有差別。並不雜亂。故云差別。色等總略攝者。言一切差別色。總於一色蘊而略攝之也。見《廣五蘊論註》。
    《準阿含經》。無常已滅。名過去色。未生。名未來色。已生未謝。名現在色。自身名內色。其餘名外色。有對色名麤。無對色名細。染污色名劣。不染污色名勝。過去未來色名遠。現在色名近。
    色以變礙為相。《俱舍論》明色二義。一，變壞義。論云。始自色根。終乎無表。可變壞義（自色根至無表，皆為四大種所造色。大種變異。所造色亦變異。大種壞時。所造色亦壞）。名爲色蘊。釋云。變者。顯剎那無常。壞者。顯眾分無常。二，變礙義。論云。有說，變礙故名為色蘊。釋云。變謂變壞。礙謂質礙。眾微聚集。變礙義成。
    《顯揚論·五》云。色蘊有四種建立。一，相建立。二，生建立。三，損減建立。四，差別建立。相建立者，色蘊相略有五種。一，自相。二，共相。三，所依能依相屬相。四，受用相。五，業相。自相者，謂堅等是地等相。各別清淨是眼等相。共相者。謂一切色變壞相。所依能依相屬相者。謂大種是所依，造色是能依。受用相者。謂內處受用增上力故，各別外色境界得生。或有色聚。惟有堅生。或惟有濕。或惟有煖。或惟有動。或復雜生。由隨順內處受用故。業相者。如地等大種。有依持、攝受、成熟、增長相如是等。生建立者。有五種生。一，依止生。二，種子生。三，勢引生。四，順益生。五，違損生。依止生者。謂依止大種。即於大種處所，有餘所造色生。由是因故。說四大種。造，所造色攝在一處。是造義。種子生者。謂從自種子生。如堅硬聚。或時遇緣變生流濕。或流濕聚變生堅硬。或不煖聚變生煖熱。或有煖聚變生於冷。或從不動變生於動。或復從動變生不動。如是好色惡色等。展轉相生差別。應知，如是若就自相則互無。若就其種則互有。是故從彼彼聚如是如是差別色法生。如是等類。名種子生。應知。勢引生者。謂內色根增上力故。現常相續。外物得生。如器世間。又先業勢引故。諸內處生若樂欲現前諸天，及北洲人，所有眾具。多分由勢引生故流轉。應知。若人中器世間，唯常相續。如是等類勢引生。應知。順益生者。謂得自順益緣。彼彼色法。展轉滋長，展轉增勝而生。猶如水等潤洽芽等。如是等類。名順益生。翻此故名違損生。應知。損減建立者。謂建立極微。復由五種極微建立。應知。一，由分析故。二，由差別故。三，由獨一故。四，由助伴故。五，由無分性故。由分析故者。謂由慧分析諸麤色法。漸漸轉減。至最細邊。建立極微。非由體故。由如是因。故說極微。無起無滅。又亦非謂集諸極微以成麤色。由差別故者。略有十五種極微。謂眼等根極微有五種。色等境極微有五種。地等界極微有四種。法處所攝實有色極微有一種。由獨一故者。謂建立實極微自相。由助伴故者。謂建立聚極微。由於地等一極微處。有餘色法同處不相離故。建立聚極微。由無分性故者。非一極微。復有餘細分。由非聚故。若聚極微。可有眾分。若一極微。所住之處。此處不可分析。更立餘分。是故極微。無有細分。差別建立者。有二十六種色。一，欲界繫色。謂具諸色。二，色界繫色。謂除香味。三，無色界繫色。謂等持自在色。非業異熟色。四，清淨界色。謂出世法增上所生，如靜慮解脫色，及佛菩薩色。五，內色。謂根，及根所居處色。六，外色。謂除根，及 根所居處，餘色聲香味觸。七，所依色。謂眼等五根。八，所緣色。謂五境界，及法處所攝色。九，能取色。謂即所依色。十，所取色。謂即所緣色。十一，執受色。謂受起所依。如諸色根，及根所居處色。心，及心法，所居處故。同一損益。是執受義。十二，無執受色。謂此外餘色。十三，同分色。謂自識不空根色。由與識同境轉故。十四，彼同分色。謂自識空根色。唯自類相續相似轉故。十五，有見有對色。謂色處色。十六，無見有對色。謂餘九處色。十七，無見無對色。謂法處所攝色。十八，清淨色。謂五內處。十九，清淨所取色。謂五外處。二十，意所取色。謂法處所攝色。二十一，所依住色。謂風輪乃至大地。二十二。覆護色。謂宅舍等。二十三，資具色。謂十種資具。一，飲食。二，衣，及莊嚴具。三，眾具。四，戲笑。五，鼓舞。六，歌詠。七，音樂。八，香鬘塗飾。九，眾明。十，男女承事。二十四，根所居色。謂五種色根之所居處。二十五，根色。謂五種色根。二十六，等持境界色。《瑜伽論·五十三》云。色蘊差別。略由六種。一，由事故。二，由相故。三，由識執不執故。四，由識空不空故。五，由想所行故。六，由邊際故。事者。謂所有諸色。皆是四大種，及四大種所造。相者。略有三種。一，清淨色。二，清淨所取色。三，意所取色。又變礙相。是色共相。識執不執者。若識依執。名執受色。與此相違。非執受色。識空不空者。若識不空。名同分色。由此與識等義轉故。若識空者。名彼同分色。似自相續而隨轉故。想所行者。謂緣色相。略有三種。一，色想。二，有對想。三，別異想。色想亦三。一，有光影相。二，據方處相。三，積集住相。如是三相。隨其次第。三想所行取青等相。名為色想。能取行礙。名有對想。能取男女舍田等假。名別異想。是名想所行差別。邊際者。謂色邊際。略有二種。一，墮下界。謂欲纏色。二，墮中界。謂色纏色。當知此中就業增上所生諸色。說無色界無有諸色。非就勝定自在色說。何以故。由彼勝定。於一切色皆得自在。諸定加行令現前故。當知此色。名極微細定所生色。又五十四云。色蘊略由六相應知。一，自相。二，共相。三，能依所依相屬相。四，受用相。五，業相。六，微細相。自相者。謂地等以堅等（堅、濕、煖、動）為相。眼等以各別清淨色為相。共相者。謂一切色皆變礙相。能依所依相屬相者。大種為所依。造色是能依。受用相者。謂內色處有所受用增上力故。外色境界差別而生。或有色聚唯有堅生。或唯有濕。或唯有煖。或唯有動。或和合生。為欲隨順內諸色處受用差別故。業相者。謂地等諸大種。以依持、攝受、成熟、增長為相。微細相者。謂極微相。又《集論·一》云。色蘊何相。變現相，是色相。此有二種。一，觸對變壞。二，方所示現。云何名為觸對變壞。謂由手、足、塊石、刀、杖、寒、熱、飢、渴、蚊、虻、蛇、蝎，所觸對時。即便變壞。云何名為方所示現。謂由方所。可相示現如此如此色。如是如是色。或由定心。或由不定。尋伺相應種種搆畫。《雜集論·一》云。云何建立色蘊。謂諸所有色。若四大種。及四大種所造。所造者。謂以四大種為生、依、立、持、養，因義。四大種者。地界、水界、火界、風界。（能持自性所造色。故謂之界）。此復云何。謂地堅性。水溼性。火煖性。風輕動性。云大者。有四義。一，為所依故。與諸造色為所依處。二，體性廣於造色故。三，形相大故。大地，大水，大火，大風，相狀大故。四，起大用故。成壞世界作用大故。種有二義。一，因義。能起眾色故。二，類義。種類差別故。四大種為能造性。所造色為所造性。地水火風自性各異。一者。地界。地以堅固為性。謂眼耳鼻舌身等名為地大。若不假水。則不和合。經云。毛髮爪齒皮肉筋骨等皆歸於地是也。二者。水界。水以潤濕為性。謂唾涕津液等名為水大。若不假地。即便流散。經云。唾、涕、膿、血、津、液、涎、沫、痰、淚、精、氣、大小便利，皆歸於水是也。三者。火界。火以燥熱為性。謂身中暖氣名為火大。若不假風。則不增長。經云。煖氣歸火是也。四者。風界。風以動轉為性。謂出入息。及身動轉。名為風大。此身動作。皆由風轉。經云。動轉歸風是也。
    四大種所造色者。謂依止大種。即於大種處所有所造色生。故曰四大種所造色。攝在一處。名之為造。造者。因義。言以四大種為因。乃生所造色也。因有五。生因，依因，立因，持因，養因也。生因即是起因。謂離大種。此造色不得起故。依因即是轉因。謂諸造色不離大種處而轉。若捨大種。無別處可住故。立因即是隨轉因。謂由大種變異。諸所造色亦隨之變異故。蓋造色與大種同安危。大種壞時。造色亦壞也。持因即是住因。謂由大種執持之力。諸所造色。乃能相似相續而生。不斷絕故。養因即是長因。謂由大種養彼造色。令得增長故。由此諸因。生所造色。謂眼耳鼻舌身五根。色聲香味四塵。及觸一分（觸有能觸所觸。能觸中分二。一，觸心所法。二，能觸身根。所觸亦分二。一，能造四大種。二，所造觸處。此云一分者。於能所觸中。惟取所觸一分。所觸中惟取所造一分）。無表色等（法處所攝色。亦色蘊攝）。眼根。以色為境。淨色為性。耳根。以聲為境。淨色為性。鼻根。以香為境。淨色為性。舌根。以味為境。淨色為性。身根。以觸為境。淨色為性（舌、身二根。淨色徧滿所依處。眼、耳、鼻三根則僅一分）。色。謂眼之境。顯色、形色及表色等。聲謂耳之境。執受大種因聲。非執受大種因聲。俱大種因聲。香。謂鼻之境。好香、惡香、平等香。味。謂舌之境。甘、酸、鹹、辛、苦、淡等。觸一分。謂身之境。滑、濕、重、輕、冷、飢、渴等二十二相。無表色（意識緣於過去所見之境。雖分別明了而無表對。故云無表。雖無所表。於所緣境執著不忘。故云色。其體即善惡之思種子功能。善思種子有防身語惡、發身語善之功能。惡思種子有發身語惡、遮身語善之功能。善惡俱依身語。所以名為色者。以由有質礙之四大所生之法也）。謂有表業（有對無而言。表謂表示。業謂造作）。三摩地，所生無見無對色（諸色略有三種。一，可見有對，如顯色等。二，不可見有對。如眼根等。三，不可見無對。如有表業，三摩地，二者所生之色。以無可見，無所對。故云無見無對色）。有表業舉身語二表業之自體。何謂自體。能發動之思即是。能動身之思名身業。能動語之思名語業。身語二表。自性雖無記。由思動作。假名善惡。故通善、不善、無記三性（意識所起一切善法之性。曰善性。一切惡法之性。曰惡性。非善非惡不可記別者。曰無記性）。所生色者。舉能生以示所生。善，不善，即能生之表業。所生色即無表所生之體。此無表色乃依思之種子上建立（就思之現行位而言謂之業。就思之不現行位而言謂之種子。思有三種。一，審慮思。將發身語。先為審慮之思也。二，決定思。起決定心將作之思也。三，動發勝思。正發身語動作之思也。經三思後所行。名故思業。不經三思所行。名不故思業。故思業有五。一，他所教勅故思造業。如奉命而行者是。二，他所勸請故思造業。如被勸請引導而行者是。三，無所了知故思造業。不知其事後果。無所容心。隨意造作者是。四，根本執著故思造業。為貪、瞋等諸不善根纏蔽其心。猛利執著。起造諸業者是。五，顛倒分別故思造業。依顛倒分別之內見。愛樂邪法。為求當來可愛異熟，起造諸業者是。前三及不故思業。不能令種子增長。謂之不增長業。後二定受異熟果。謂之增長業）。故不可顯示也。
    三摩地所生色。亦名定果色。定所引色。定自在所生色。法處所攝色之一。
    四大種所造色。一者。可見有對色。如顯色形色表色等。二者。不可見有對色。如眼等五根之勝義根。及聲香味觸四塵。非眼所能見。
    三者。不可見無對色。如無表色等。
    《五事毗婆沙論》云。問依何義故說之為色。答。漸次積集。漸次散壞。種植生長。會遇怨親。能壞能成。皆是色義。佛說變壞故名為色。變壞即可是惱壞義。有說，變礙故名為色。問。過去、未來、極微、無表。皆無變礙。應不名色。答。彼亦是色。得色相故。過去諸色。雖無變礙。而曾變礙。故立色名。未來諸色。雖無變礙。而當變礙。故立色名。一一極微。雖無變礙。而可積集（眾微聚集）。變礙義成。諸無表色。雖無變礙。隨所依故。得變礙名。所依者何。謂四大種由彼變礙。無表名色。如樹動時。影亦隨動（無表依止大種轉時。如影依樹）。

    二。受蘊。
    受以領納為義。領納順，違，俱非，境相為性。起愛為業。和合積聚。故名為蘊。《廣五念蘊論》云。云何受蘊。受有三種。謂苦受。樂受。不苦不樂受。樂受者。謂此滅時。有和合欲。苦受者。謂此生時。有乖離欲。不苦不樂受者。謂無二欲。受以領納為義者。六根依六觸為緣而生六受。眼耳鼻舌身意六識。領納色聲香味觸法六塵也。領納順境。有適悅之樂。在眼耳鼻舌身之五識領納者。曰樂受。意識領納者。曰喜受。領納逆境。逼迫身心。在眼耳鼻舌身之五識領納者。曰苦受。意識領納者。曰憂受。六識領納不違，不順，非苦，非樂，平等之境。曰捨受。此五受中。屬於前五根者名外受。外受有三。苦受，樂受，捨受也。屬於意根者名內受。內受亦有三。憂受，喜受，捨受也。捨受又名不苦不樂受。非違，非順。非苦，非樂。內受外受。更無二相。又一切苦樂。皆緣受境。樂受於未得樂時。有希合欲。既得樂後有不乖離欲。苦受於未得苦時。有不合欲。既得苦後有乖離欲。惟捨受無此二欲。菩薩觀受是苦。以樂受是壞苦。苦受是苦苦。捨受是行苦。眾生顛倒。以苦為樂。
    【注】六根依六觸為緣而生六受者。《準法蘊足論·九》。謂眼觸所生受。耳鼻舌身意觸所生受。云何眼觸所生受。謂眼及色為緣生眼識。三和合故生觸。觸為緣故生受。此中眼為增上。色為所緣。眼觸為因。眼觸為等起（《瑜珈論》云。等起者。謂由三種。若事，若時，若補特伽羅，依處故）。是眼觸種類。是眼觸所生生。與眼觸所生作意相應。於眼識所了別。色，諸受乃至受所攝（諸受。等受。別受。受性。受所攝。是名受蘊）。是名眼觸所生受。如是耳鼻舌身意觸所生受。廣說亦爾。
    《大毘婆沙論·一百十五》略云。受有五種。一，自性受。謂樂受，苦受，不苦不樂受。二，現前受。如《大因緣法門經說》。受樂受時餘二受便滅。苦受，不苦不樂受亦爾。應知如是所受。是無常苦滅壞之法。離我（眾生所執之假名），我所（五蘊色身）。三，所緣受。如《識身論》說。眼色為緣。生於眼識。三和合故觸。觸為緣故受。如是乃至意法。廣說亦爾。四，相應受。謂樂受相應法。苦受相應法。不苦不樂受相應法。五，異熟受。謂順樂受業。順苦受業。順不苦不樂受業。
    《顯揚論·五》云。受蘊建立有六種。一，差別建立。二，出離建立。三，觀察建立。四，生建立。五，相建立。六，師句建立。差別建立者。或立一受。如說諸所有受。悉皆是苦。或立二受。謂身受及心受。或立三受。謂樂受，苦受，不苦不樂受。或立四受。謂欲繫，色繫，無色繫，及不繫受。或立五受。謂樂根，苦根，喜根，憂根，捨根。或立六受。謂眼觸所生受，乃至意觸所生受。或立十八受。謂十八意近行。六喜近行。六憂近行。六捨近行。或立三十六受。謂六依躭嗜喜。六依出離喜。如喜憂捨亦爾。或立一百八受。謂三十六受。各依三世。或開無量受。如其所受。起無數受。出離建立者。謂初靜慮出離憂根。第二靜慮出離苦根。第三靜慮出離喜根。第四靜慮出離樂根。無相心法三摩地出離捨根。觀察建立者。謂八種觀察於受。何者是受。何者是受集。何者是受滅。何者是趣受集行。何者是趣受滅行。何者是受味。何者是受過。何者是受出離。生建立者。謂從十六觸諸受生。何等十六。一，眼觸。二，耳觸。三，鼻觸。四，舌觸。五，身觸。六，意觸。七，有對觸。八，增語觸。九，順樂受觸。十，順苦受觸。十一，順不苦不樂受觸。十二，愛觸。十三，恚觸。十四，明觸。十五，無明觸。十六。非明非無明觸。相建立者。謂八種相。一，異熟相。二，非異熟相。三，有味著相。四，無味著相。五，依躭嗜相。六，依出離相。七，動相。八，住相。異熟相者。謂阿賴耶識相應受。非異熟相者。謂轉識相應受。有味著相者。謂欲繫受。無味著相者。謂色無色繫及不繫受。依躭嗜相者。謂欲貪相應受。依出離相者。謂出家所引不定地善法相應受。動相者。謂經中風喻所顯受。住相者，謂經中客舍喻所顯受。暫相續住義故。師句建立者。謂三十六師句。六依躭嗜喜。六依出離喜。六依躭嗜憂。六依出離憂。六依躭嗜捨。六依出離捨。《瑜伽論·五十三》云。受蘊差別。略由五種。一，由事故。二，由相故。三，由生故。四，由觀察故。五，由出離故，事者。謂領納及順領納法。相者。謂自相及共相。自相有三。樂受。苦受。不苦不樂受。樂受壞苦故苦。苦受苦苦故苦。不苦不樂受行苦故苦。由此因緣。諸所有受。皆說名苦。是名受共相。生者。謂一切受。十六觸所生。何等十六。謂眼觸。耳觸。鼻觸。舌觸。身觸。意觸。有對觸。增語觸。順樂受觸。順苦受觸。順不苦不樂受觸。愛觸。恚觸。明觸。無明觸。非明非無明觸。由所依及所取境故。建立六觸。及有對觸。由分別境故。建立增語觸。由領納境故。建立順樂受等觸。由染淨故。建立愛，恚，明，無明。非明非無明觸。是名受生差別。觀察差別者。一切如來應正等覺，出現世間。皆於諸受起八種觀。謂受有幾種。誰為受集。誰為受滅。誰是受集趣行。誰是受滅趣行。誰是受愛味。誰是受過患。誰是受出離。如是觀時。如實了知受有三種。觸集故受集。應知。如經分別廣說。如是八種觀察諸受。當知略顯自相觀。現法轉因觀。彼滅觀。後法轉因觀。彼滅觀。彼二轉因觀。彼二轉滅因觀。及清淨觀。是名觀察差別。出離者。謂初靜慮。出離憂根。第二靜慮。出離苦根。第三靜慮。出離喜根。第四靜慮。出離樂根。於無想界。出離捨根。是名出離差別。
    《法蘊足論·九》云。云何受蘊。謂諸受。等受。別受。受性。受所攝。是名受蘊。復有二受。說名受蘊。謂身受。心受。云何身受。謂五識身相應諸受。乃至受所攝。是名身受。云何心受。謂意識相應諸受。乃至受所攝。是名心受。復有二受。說名受蘊。謂有味受。無味受。云何有味受。謂有漏作意相應諸受。乃至受所攝。是名有味受。云何無味受。謂無漏作意相應俱受。乃至受所攝。是名無味受。有作是說。欲界作意相應受。名有味受。色無色界作意相應受。名無味受。今此義中。有漏作意相應受。名有味受。無漏作意相應受。名無味受。如有味受。無味受。如是墮受。不墮受。躭嗜依受。出離依受。順結受。不順結受。順取受。不順取受。順纒受。不順纒受。世間受。出世間受。亦爾。復有三受。說名受蘊。謂樂受。苦受。不苦不樂受。云何樂受。謂順樂觸所生身樂，心樂，平等受受所攝。是名樂受。復次修初，第二，第三，靜慮。順樂觸所起心樂。平等受受所攝。是名樂受。云何苦受。謂順苦觸所生身苦，心苦。不平等受受所攝。是名苦受。云何不苦不樂受。謂順不苦不樂觸所生身捨心捨。非平等非不平等受受所攝。是名不苦不樂受。復次。修未至定靜慮中間。第四靜慮。及無色定。順不苦不樂觸所生心捨。非平等非不平等受受所攝。是名不苦不樂受。復有四受。說名受蘊。謂欲界受。色界受。無色界受。不繫受。云何欲界受。謂欲界作意相應諸受。乃至受所攝。是名欲界受。云何色界受。謂色界作意相應諸受。乃至受所攝。是名色界受。云何無色界受。謂無色界作意相應諸受。乃至受所攝。是名無色界受。云何不繫受。諸無漏作意相應諸受。乃至受所攝。是名不繫受。復有五受。說名受蘊。謂樂受。苦受。喜受。憂受。捨受。如是五受。廣說如根品（順樂觸所生身樂心樂。平等受受所攝。修第三靜慮順樂觸所生心樂。平等受受所攝。順苦觸所生身苦。不平等受受所攝。順喜觸所生心喜。平等受受所攝。修初二靜慮順喜觸所生心喜。平等受受所攝。順憂觸所生心憂。不平等受受所攝。順捨觸所生身捨，心捨。非平等非不平等受受所攝。修未至定靜慮中間。第四靜慮及無色定。順不苦不樂觸所生心捨。非平等非不平等受受所攝）。復有六受。說為受蘊。謂眼觸所生受。耳鼻舌身意觸所生受。云何眼觸所生受。謂眼及色為緣。生眼識。三和合故。生觸。觸為緣故。生受。此中眼為增上。色為所緣。眼觸為因。眼觸為等起。是眼觸種類。是眼觸所生生。與眼觸所生作意相應。於眼識所了別色，諸受，乃至受所攝。是名眼觸所生受。如是耳鼻舌身意觸所生受。廣說亦爾。

    三。想蘊。
    想者。取像之義。於境取像為性。施設種種名言為業。根塵相對而成六想。和合積聚。故名為蘊。《廣五蘊論》云。云何想蘊。謂能增勝。取諸境相。故五蘊之想。專指有相想而言。
    【注】眼根對色。與識相應。而起色想。為眼觸所生想。耳根對聲。與識相應，而起聲想。為耳觸所生想。鼻根聞香。與識相應。而起香想。為鼻觸所生想。舌根嘗味。與識相應。而起味想。為舌觸所生想。身根覺觸。與識相應，而起觸想。為身觸所生想。意根分別諸法。與識相應，而起法想。為意觸所生想。謂之六想。
    有相想者。能取諸境界。隨起言說。而具明了，及分別，二相狀。無相想者。於能緣所緣。或闕分別。或闕明了。或二者共闕。如嬰孩未學語言。雖於色起想。而不能了此名為色也。
    《顯揚論·五》云。想蘊建立有三種。一，依差別。二，作意差別。三，境界差別。依差別者。謂六想身。眼觸所生想。乃至意觸所生想。作意差別者。有二種。一，有相想。二，無相想。有相想者。謂除欲界中未善言說者想，第一有想，及出世間想。餘有相作意相應想。無相想者。謂前所除無相作意相應想。境界差別者。有四種。一，小想。二，大想。三，無量想。四，無所有想。如其次第。緣欲界，緣色界，緣無色界，緣無所有處想。《瑜伽論·五十三》云。想蘊差別。略有五種。一，由事故。二，由相故。三，由顛倒故。四，由無顛倒故。五，由分別故。事者。謂取所緣相及隨順彼法。相者。自相有六種。一，有相想（即三、四、五、六之總稱）。二，無相想（有頂想，及一切出世間學，無學，想）。三，狹小想（欲）。四，廣大想（色）。五，無量想（空，識，無邊處）。六，無所有想（無所有處）。一切想皆等了相。等了相是共相。是名相差別。顛倒差別者。謂諸愚夫。無所知曉。隨逐無明。起不如理作意。於所緣境，無常計常。取相而轉。是名想倒。如於無常計常。於苦計樂。於不淨計淨。於無我計我。此想顛倒。諸在家者。能發心倒。一分出家者。能發見倒。是名顛倒差別。此想顛倒。復有差別。謂於四事。邪取其相。是名顛倒。若由如是等了相故。於境貪著。是名心倒。若由如是等了相故。有執著者。於顛倒事。堅執忍可。開示建立。是名見倒。無顛倒差別者。謂諸聰睿，隨智慧明，起如理作意。於所緣境。無常，知無常。苦，知苦。不淨，知不淨。無我，知無我。正取相轉。是名想無顛倒。心無顛倒。見無顛倒。是名無顛倒差別。分別差別者。略有五種想分別相。一，境界分別。二，領納分別。三，假設分別。四，虛妄分別。五，實義分別。若於境界。取隨味相。名境界分別。執取境界所生諸受。名領納分別。若於自他取如是名，如是類，如是性等種種世俗言說相。名假設分別。於諸境界取顛倒相。名虛妄分別。於諸境界取無倒相。名實義分別。如是總名想蘊分別差別。

    四。行蘊。
    行者。造作之義。謂思為主。令心造作善惡諸行。身行、語行、意行皆是。《廣五蘊論》云。云何行蘊。謂除受、想，諸餘心法及不相應行。即意識思惟塵境造作善惡行業。五十一心所有法中。除受、想二蘊外。餘四十九法及二十四不相應行法皆是。和合積聚故名為蘊。
    【注】《大乘義章》云。有為集起。目之為行。又云。內心涉境。說名為行。又云。起作名行。《俱舍論》云。行名造作。《法界次第》云。造作之心。能趣於果名行。
    行蘊有二。一，一分心相應行。即除受、想之四十九心法。二，心不相應行。即二十四不相應行。受、想二心法。本在徧行五心法中。今別立二蘊。故云除受、想諸餘心法。即五十一心法中除受、想二者。其餘之四十九心法也。
    《顯揚論·五》云。行蘊建立有三種。一，勝差別。二，依差別。三，諸行施設差別。勝差別者。惟思最勝。行蘊所攝。由造作心，令成雜染及清淨法轉故。依差別者。謂六思身。眼觸所生思。乃至意觸所生思。諸行施設差別者。有三種。一，雜染施設。二，清淨施設。三，分位施設。雜染施設者。謂煩惱及隨煩惱。清淨施設者。謂信等。分位施設者。謂生等心不相應行。《瑜伽論·五十三》云。行蘊差別亦由五相。一，由境界故。二，由分位故。三，由雜染故。四，由清淨故。五，由造作故。由境界者。謂於行蘊立六思身。由分位者。謂立生等不相應行。由彼生等，惟有分位所顯現故。由雜染者。謂於雜染諸行。建立煩惱及隨煩惱。由清淨者。謂於清淨諸行。建立信等。由造作者。謂如前說五造作相，為境隨與等。
    《準百法明門論》《大乘百法》約為五門。一者。色法十有一。眼鼻耳鼻舌身五根。色聲香味觸五境。及法處所攝一分色是（法處是意所取之境。具有四分。一，心所法。二，不相應行。三，無為。四，無表色。此云法處所攝一分色者。無表色也）。二者。心法八。即識也。眼，耳鼻舌身意末那，及阿賴耶之八識是。三者。心所有法五十有一。分六位。第一。徧行法五。一，作意（相應於心而起於所緣境。引心為業）。心未起，警之令起。已起，引之趣境。二，觸。根境識三者和合之結果也。三，受。領納前境也。四，想。於境取像也。五，思。令心造作意業。趨所緣之境也（《大般若經》說為六思。思即是業。六思之後。各起善不善無動業。即名為行。《成唯識論》云。思謂令心造作為性。於善品等役心為業。《界身足論》云。思云何。謂思、等思、現思、已思、當思、思所攝。造心意業。是名為思。《品類足論》云。思云何。謂思、等思、增上等思、已思、思類、心作意業，是名為思）。此五種法。周徧一切善、不善、無記性而起。故名徧行。第二。別境法五。一，欲。於愛樂事起希望也。二，勝解。於決定境，如所了知，決定印可也。三，念。於曾習事記憶不忘也。四，三摩地。此云等持。於所觀境。制心一處。專注不散也。故亦名定。五，慧。於所觀境善、惡、無記性。就諸法自相或共相為簡擇也。定於所觀境專注。慧於所觀境簡擇。此五法以愛樂、決定、曾習、所觀四境為所緣。欲、勝解、念、定、慧為能緣。一一差別而起。故曰別境。第三。善法十一。一，信。於業、果、諦、寳等。深正符順生淨信也（業謂身口意三業。作善感欲界人天果報為福業。作惡感欲界惡趣果報為非福業。修世間禪。感色、無色界、定地果報為不動業。果即四果。初果須陀洹。此言入流。入聖道之流也。二果斯陀含。此言一往來。由人生天，由天還人，一往來也。三果阿那含。此言不還。悉斷欲界諸惑。更不還生也。四果阿羅漢。此言善生。煩惱悉破，更不受生死果報也。諦即苦集滅道四諦。寳為佛法僧三寶）。二，慚。謂自增上及法增上羞已過失也。三，愧。謂他增上羞已過失也（自增上者。自重自尊義。法增上者。尊重善法義。他增上者。怖畏責罰或譏評義）。四，無貪。謂對於有情世間，器世間不生愛著。不但三界有漏因果。即無漏涅槃亦不生愛著也。五，無瞋。於諸有情慈愍為懷，不加損害也。六，無癡。修行如實正行。了知四諦，十二因緣，對治無明也。七，精進。勤勇修持。進善，斷惡，不退轉也。八，輕安。身心調暢。棄捨身三，口四，意三，十不善行。除二障也（身三，即殺、盜、婬。口四。妄語、惡口、兩舌、綺語。意三。貪、瞋、邪見。二障。即所知障、煩惱障）。九，不放逸。謂於無貪、無癡、無瞋、精進四法。斷惡修善也。十，捨。修持無貪、無瞋、無癡、精進四法。遠離惛沈、掉舉及諸雜染。平等正直。委心任運。一切放下也。十一，不害。悲心獨運。拔群生苦也。第四。煩惱法六。一，貪。謂於五取蘊（《集論·一》云。何故名取蘊。以取合故。名為取蘊。何等為取。謂諸蘊中所有欲貪。何故欲貪說名為取。謂於未來、現在諸蘊。能引不捨故，希求未來，染著現在，欲貪。名取）。染愛躭著，為所纏縛。輪迴三界。增長煩惱也。二，瞋。即瞋恚。身口二業為瞋。意業為恚。損害有情。自住於苦也。三，慢。其心高舉。於尊者有德倨傲不敬也（心高舉為其總性。差別之有七種，慢，謂於劣者視己勝之。於相同者計己相等也。過慢。謂相等者計己己勝之。於勝者計己與相等也。過過慢。謂於勝己者視己猶勝之也。我慢。執五取蘊為我，或我所，而起慢也。增上慢。謂未得增上殊勝之法自謂已得也。卑慢。謂於多分殊勝。自視歉然。以為未足也。邪慢。己實無德。自謂殊勝也）。四，無明。癡愚昏闇障理之惑也。五，見。凡五。薩迦耶見。於五取蘊隨執為我，或我所也。邊執見。執於一邊，障礙中道。見解鄙陋。障礙勝行也。邪見。謂謗因果，或謗作用，或壞善事也。見取。攝取以上三見及所依蘊，以為最勝也。戒禁取，隨順諸見戒禁，及所依蘊，執為最勝。取非理之戒法。於有漏法取為能淨，此復有二。一者。非因計因。如持牛戒，雞戒，以為生天之因者是。二者。非道計道。如修塗灰、斷食、自拔髮等種種苦行。以為涅槃之道者是。六，疑。懷疑四諦、三寶諸法。猶豫不決也。第五，隨煩惱法二十。一，忿。對於現前違逆，顯發暴惡也。二，恨。追懷已往之忿，結怨不捨也。三，覆。隱匿己過，不使發露也。四，惱。暴語淩人，自心憂苦也。五，嫉妒。忌他人名利也。六，慳。執著利養，吝惜不施也。七，誑。心懷虛妄，矯現功德，惑亂視聽也。八，諂。矯飾恭敬，曲心媚人也。九，憍。自恃有漏盛事。染著倨傲也。十，害。於諸有情心無悲憫，橫加損害也。以上十種。皆各別而起。非二法並生。其行最狹。名小隨惑。十一，無慚。所作罪惡，不知羞恥也。十二，無愧。所作罪惡，受責不羞也。以上二法能並生。然惟徧於不善性。不通一切染污法。名中隨惑。十三，惛沈。心神蒙昧，於境不堪任也。十四，掉舉。憶念樂境，囂動不靜也。十五，不信。陷於邪見，不信業、果、諦、寳諸法實德也。十六，懈怠。於諸善行懶惰不進也。十七，放逸。於諸煩惱不斷，於諸善品不修也。十八，失念。染污念勝，於諸善法不能明記也。十九，散亂。因貪瞋癡心神流散昏亂。障礙正定也。二十，不正知。於所觀境，不能正確觀察，起不正身語意行也。以上八種。既得俱起。又徧於一切染污法。故名大隨惑。第六。不定法四。云不定者。以通於善、惡、無記三性也。一，惡作。嫌惡所作之業。心生變悔。變者。造作之心。悔者。追悔也。此有善，不善二位。二位之中。復各有二。先不作善，後起悔心。及先已作惡，後起悔心。屬於善位。先不作惡，後起悔心。先已作善，後起悔心。此屬於不善位。二，睡眠。闇昧輕略。令心，心所，不自在轉也。坐寐曰睡。安寢曰眠。睡眠時五識皆不行。而意識獨轉。與定相同。惟定中能觀察諸法自相。睡眠則意識闇昧。此通三性。無夢，時屬無記性。善夢屬善。惡夢屬惡。三，尋。依思、慧分別尋求，推度，諸法麤相。云分別者。依思尋求則不能推度。依慧尋求則能推度也。四，伺，伺者。伺察義，與尋同。惟尋主麤相。伺主細相耳。上來五十一種。皆從阿賴耶識種子所生。依心所起。與心俱轉相應故。故名心所有法。四者。不相應行法二十有四。一，得。獲也。成就也。於物曰獲。於事曰成就。此復有三。謂種子成就。自在成就。現起成就也（種子成就。自在成就。是種子所得。現起成就。是現行所得。成就即得之總相）。如其所應。種子成就者。謂諸法雖不現行，而種子早已具足，故云成就。如凡夫身中成就三無漏根（一。未知當知根。謂諸學者未得現觀，未得聖果，之信，精進，念，定，慧五根也。二，已知當知根。謂諸學者已得現觀，已得聖果，之五根也。三，具知根。謂諸無學，若阿羅漢，獨覺，十地菩薩，如來，應，正等覺之五根也）。種子也。自在成就者。謂依定通自在力成就非分法。如依定力變土木為金寶是也。現起成就者。謂正成一切現行法。如身在欲界。則成欲界法。若身在欲界。已能離欲界染時。則已成以上界之現行法也。二，無想定。謂諸外道以想念為生死根本。故以滅想念為得涅槃。先在人中修無想定。已伏色界第三禪俱生煩惱。但仍為有漏定。未離第四禪以上之染。僅可生四禪無想天。三，滅盡定。亦名滅受想定。心無所緣煩惱不生之無漏定也（二乘，獨覺，三果，四果，皆入此定。菩薩於此定已得自在而不現入）。四，無想天。即色界四禪之第四天。為無想定所得之果。五，命根。謂第八識種子。由先世業為所引，能生住識功能。於眾生共同之五蘊分位上。有執持一期心身不壞之力（種子如無住識功能。肉身即壞。有一定分限。故曰一期）。六，眾同分。謂五趣（天、人、鬼、畜、地獄）有情，各有種類。同類相望。就其五蘊和合身形彼此相似之分位。七，生。謂眾同分所有諸行自無而有也。八，老。謂眾同分所有諸行相續變壞也。九，住。謂眾同分所有諸行相續隨轉也。十，無常。謂眾同分所有諸行相續謝滅也（四相遷流。剎那不停。故曰相續。本無今有曰生。有後暫用曰住。漸入衰廢曰老。由有歸無曰無常）。十一，名身。身者。積聚。依事立名。眾名聯合。諸法自性。由名而詮顯者謂之名身。如心為一名。經為一名。兩名和合成心經一名是。十二，句身。積言成句。二句以上聯合。諸法差別。因以詮顯也。如云諸行無常是生滅相。諸行是諸法。無常是差別。諸行無常為句。合諸行無常，是生滅相，為句身。十三，文身。文即字。聯合二字以上表顯了達其所有事義。謂之文身。即名身與句身所依之文字也（名身詮自性。句身詮差別。文身則僅為名句之所依而已）。十四，異生性。五趣四生。未得無漏聖道。各各差異之本性也。十五，流轉。因果相續。流轉不斷也。十六，定異，善惡因果決定不同也。十七，相應（契合義。梵語瑜伽。此云相應。分為三。一，境瑜伽。二，行瑜珈。三，果瑜伽。境與行果。行與果境並有相應之義）。因果和合不相違背也。十八，勢速。諸法遷流。不暫停住也。十九，次第。編列有序也。二十，時。時節也。二十一，方。方所也。二十二，數。數目也。二十三，和合。不相乖違也。二十四，不和合。互相乖違也。此二十四法有名無體。不與色法、心法及心所有法相應。故曰不相應行法。五者。無為法六。一，虛空無為。真空之理。離諸障礙。有如虛空。無所作為也。二，擇滅無為。擇即揀擇。滅即斷滅。以智滅惑。所顯真理。無所作為也。三，非擇滅無為。不假智力。斷滅諸惑。性本清淨。無所作為也。四，不動無為。第四禪天得不動地所修出世之理。無所作為也。五，受想滅無為。受想心滅。所顯真理。無所作為也。六，真如無為。不妄曰真。不異曰如。真如之理。無所作為也。以上色法，心法，心所有法，及不相應行法。皆是世間有為之法。無為法為出世間法。然百法不出乎色心。而色由心造。攝末歸本。唯心一法而已。故曰。三界唯心。又《準俱舍論》。小乘立一切法為七十五。攝為五類。一者。色法十有一。五根，五境，及無表色（依身口意發動之善惡二業。生於身內之無形色法。感苦樂果之業因也）。根境有質礙之用。故名色。無表色自體雖無質礙之用。以有質礙之四大為因而生。故亦名為色。二者。心法一。根境相對時。依根生了別境之總作用也。此一。心法。有心、意、識三名。梵語質多。此云心。是集起義。梵語末那。此云意。是思慮義。梵語毘惹南。此云識。是了別義。此一心法對所緣境惟取總相。必領有他之心所法。故對心所而言。名曰心王。以對境有六種差別。故心王亦有六種差別。即眼耳鼻舌身意六識。六識中前五。唯有自性分別（如眼識識別色。耳識識別聲）。意識則除自性分別外。尚有計度分別（散心意識相應智慧。於過、現、未，不現見事。計較量度也）。隨念分別（若散若定意識相應諸念。憶念分別過去等境也）。三者。心所有法四十六，又分六位。一，徧大地法十。受想思觸欲慧念，作意，勝解，三摩地。徧善惡無記等一切心故名大。所依行處（心王）故曰地。二，大善地法十。信、不放逸、輕安、捨、慚、愧、無貪、無瞋、不害、勤。徧與一切善心相應俱起。故名大善地法。三，大煩惱地法六。無明（癡）、放逸、懈怠、不信、惛沈、掉舉。徧與一切染心相應而起，故名大煩惱地法。四，大不善地法二。無慚。無愧。徧與一切不善心相應俱起。故名大不善地法。五，小煩惱地法十。忿覆慳嫉惱害恨諂誑憍。此十法雖與惡心，及有覆無記心，相應而起。惟為修道所斷。不通於見道所斷。與意識之無明相應。不通他識且各別現行。而非十法俱起。故名小煩惱地法。六，不定地法八。尋、伺、睡眠、惡作、貪、瞋、慢、疑。此八法徧善、惡、無記三性。而又非若大地法之定徧一切心而起。故名不定地法。四者。心不相應行法十四。得，非得，同分（能令有情展轉類等。名有情同分。能令蘊處界法自類相似。名法同分），無想果（即百法中之無想天），無想定，滅盡定，命根，生，住，異，滅，名身，句身，文身，五者。無為法三。虛空無為。擇滅無為。非擇滅無為也。
    《集論》云。云何建立行蘊。謂六思身。眼觸所生思。耳觸所生思。鼻觸所生思。舌觸所生思。身觸所生思。意觸所生思。由此思故。思作諸善。思作雜染。思作分位差別。又即此思。除受及想。凡餘心所法及心不相應行。總名行蘊。又云。行蘊何相。造作相是行相。謂由行故。令心造作。於善、不善、無記品中驅役心故。

    五。識蘊。

    識者。了別之義。對於種種塵境。照了分別謂之為識。和合積聚。故名為蘊。《廣五蘊論》云。云何識蘊。謂於所緣了別為性。亦名心。能採集故。亦名意。意所攝故。若最勝心。即阿賴耶識。能採集諸行種子故。八識心王。總名識蘊。一者。眼識。眼與色為緣而生識。識依根而生。根因識能見。此能見者名為眼識。二者。耳識。耳與聲為緣而生識。識依根而生。根因識能聽。此能聽者名為耳識。三者。鼻識。鼻與香為緣而生識。識依根而生。根因識能齅。此能齅者名為鼻識。四者。舌識。舌與味為緣而生識。識依根而生。根因識能嘗。此能嘗者名為舌識。五者。身識。身與觸為緣而生識。識依根而生。根因識能覺。此能覺者名為身識。六者。意識。意以法為緣而生識。識依根而生。根因識而能分別前五根所緣之五塵境界。分別六塵。名為意識。亦名分離識。以依於六根同取六塵故。與第七識均為分別事識。以能分別過去、未來、現在種種事相故。七者。末那識。末那者。梵語。具足應云訖利瑟吒耶末那。義為我執。為一切眾生妄惑之根本。亦作染污意。謂我癡、我見、我慢、我愛四惑常與之俱也。又名相續識。以無始以來無間斷故。又名分別識。以依於六塵諸境傳送第六識令起分別也。以其恒審思量。亦名曰意。但與第六之意識不同。第六識從根得名。此識則依其思量之本能而得號。蓋此識本無定體。即第八識之染分依第八識自證分而生。緣第八識見分而執為我。第六識雖能分別所緣塵境好惡。而傳送、相續、執取，以成染淨。則全由此識主之。八者。阿賴耶識。梁真諦三藏譯作無沒識。謂一切種子無所隱沒也。奘師譯作藏識。以其無法不含。無事不攝，含藏一切事物種子也。有能藏、所藏、執藏義故。此識染淨同源。不生滅與生滅和合。體具三藏。性含四分。如摩尼珠。體本清淨。又如明鏡。能含萬象。亦名宅識。以諸蘊於此中生。於此中滅。為一切種子所棲處故。亦名阿陀那識。阿陀那此云執持。以執持諸法種子，及諸識根，令不壞故。亦名種子識。以此識自證分能普徧執持有漏無漏諸種子故。亦名異熟識。能引生死、善、不善業異熟果故。亦名根本識。為一切法之根本，是諸識所依故。亦名現識。諸法皆於本識上現故。亦名心。以積集諸法種子，又生起現行故。亦名所知依。以能於染淨所知諸法為依止故。亦名果報識。從種子生故。亦名有分識。分者因義。三有之因。皆由此識故。亦名窮生死蘊。此識徧三界九地有生死處，即常徧為依。直至大乘金剛心末，煩惱盡時方捨故。亦名第八識。七後得名故。亦名第一識。從本向末，數為第一故。亦名顯識。顯現諸法故。總之此識從染分言。則無明依之而起。結業由之而生。具足煩惱塵勞。變現根身世界。若以淨體言之。則本覺心源。離念清淨。在聖不增。在凡不減。為諸識中之根本。第一識至第七識為轉識。第八識為本識。本者根本義。轉者不定義。謂三性，三量，三境，易脫不定故。
    八識之外。梁真諦三藏更立第九識曰菴摩羅識。譯作清淨識。亦曰白淨無垢識。乃一切眾生清淨本源心地。諸佛如來所證法身之果德。非生死之能羈。非涅槃之能寂。染淨俱泯。纖塵不立。明同皎月。湛若太虛。是為真如。《密嚴經》曰。賴耶有可得。解脫是非常。如來清淨藏。亦名無垢智。意亦同此。以出障故。不同異熟也。奘師譯經不立此識。諸佛如來。常以正覺轉諸識入菴摩羅。蓋眾生本有之性。其果位即菴摩羅識。為阿賴耶識之淨體。阿賴耶識去妄存真。至我見永不起位。即成菴摩羅識。不須別立此識也。
    【注】就通義說。八識總可名心。因慮知，依止，了別，諸義為八識所通具。故曰八識總名心。就別義說。則集起名心。第八識積集識心諸法種子。生起諸法。惟第八識始可名心。思量名意。第七識緣所緣境恒審思量。當名為意。了別名識。前六識對六境麤相辨別了解。當名為識。《唯識論》云。集起故名心。思量故名意。了別故名識。又云。心意識，一法異名。對數名心。能生名意。分別名識。又前起為心。次起為意。後了為識。
    意所緣為法塵。詮云分別六塵者。蓋意識外依五根，與五識，同時而起。亦得緣外五塵境界。《起信論》云。凡夫取著轉深。計我我所。分別六塵。名為意識。
    我癡即無明。愚於我相迷無我理也。
    我見者。不知此身為五蘊等法假合而成。妄執為我強立主宰也。凡夫計我為人。名人我見。二乘計一切法各有體性。怖畏生死。迷於法執。名法我見。
    我慢者。倨慢執我。令心高舉也。
    我愛者。妄執己身為我。深生躭著也。
    第六識依意根了別得名。即依意之識。故曰從根得名。第七識以第八識之見分為本質。自於識上別變相分。為第六識之所依。恒審思量。執我不捨。故曰依其思量之本能而得號。梵語末那。此云意。以簡別第六識故。故仍梵名。《顯揚論·一》云。意者謂從阿賴耶識種子所生。還緣彼識我癡、我愛、我、我所執、我慢相應。於一切時恃舉為行或平等行。與彼俱轉，了別為性。如薄伽梵說。內意處不壞。外法處現前。及彼所生作意正起。如是所生意識得生。《瑜伽論·一》云。意謂恒行意。及六識身無間滅意。初唯第七識。由具思量依止二義。說名為意。後通餘識。但由依止名意。又六十三云末那名意。於一切時執我我所及我慢等。思量為性。《成唯識論·四》略云。此名何異第六意識。此持業釋。如藏識名。識即意故。彼依主釋。如眼識等。識異意故。然諸聖教。恐此濫彼。故於第七。但立意名。或欲顯此與彼意識為近所依。故但名意。
    染分者。我癡我愛我見我慢四惑之自證分也。
    傳送者。遞轉義。
    相續者。於愛境生樂。不愛境生苦。覺心起念。相應不斷也。《俱舍論》云。何名相續。謂因果性。
    執取者。緣念苦樂等境心起執著也。
    第八識各種異名。無沒識。宅識。見《無相論》。藏識。見《六波羅蜜多經》。根本識。見《增一阿含經》。果報識。見《攝大乘論》。有分識。小乘上座部說。窮生死蘊。小乘化地部說。見《宗鏡錄》。現識。見《楞伽經》。第一識。第八識。見《了義燈》。顯識。見《顯識論》。《唯識論》第八識七名。曰心。曰阿陀那。曰種子識。曰所知依。等名。通一切位。曰阿賴耶。惟限於異生及有學諸位。因八地以上菩薩。及二乘無學。斷此識中煩惱盡故。不復執藏此識為自內我。永捨賴耶之名（非捨八識本體）。曰異熟識。通於異生二乘菩薩諸位。曰菴摩羅識。則惟如來果地方得稱之。
    體具三藏者。一，能藏。即能含藏義。猶如庫藏，能含藏寶貝。此能含藏雜染種。故名為藏。亦即持義。二，所藏。即所依義。猶如庫藏。是寶等所依故。此識藏自體於諸法。故於諸法上見妄想。是雜染法所依處故。三，執藏。堅守不捨義。猶如金銀等藏。為人堅守。執為自內我。此識為染末那堅執為我。故名為藏。
    性含四分者。一，相分。相即形相。謂此識能變現根身世界。及諸法名義相狀。皆由此分而生。如鏡中所現之影像也。二，見分。見即照了之義。謂此識能照燭一切諸法及其義理。如鏡中之明。能照萬象也。三，自證分。自證所具之法。謂此識能持見分相分親證無礙。如鏡之圓體。能持其明。能含萬象也。四，證自證分。證即能證之體。自證即所具之法。能持前自證分，見分，相分，皆不離此分。是第八識本體。如鏡之背也。或以自證分、證自證分二者合稱為自體分。《成唯識論》云。如是四分。或攝為三。第四攝入自證分故。或攝為二。後三俱是能緣性故。皆見分攝。此言見者。是能緣義。或攝為一。體無別故。如入楞伽伽他中說。蓋唯識四師。所立不同。安慧惟立一自證分。難陀立相、見二分。陳那於相、見二分外，加自證分為三分。此云四分者。護法所立也。
    阿陀那義為執持。一，執持諸法種子令不散失。二，執持有情根身令不壞爛。三，執取結生（由中有沒而託生於母胎。謂之結生。《俱舍論》云。時健達縛於二心中隨一現行。謂愛或恚。彼由此起二種倒心。便謂己身與所愛合。所憎不淨泄至胎時。謂是己有。心生喜慰。中有便沒。生有起已。名已結生）相續（因果次第不斷也。《俱舍論·四》云。何名相續。謂因果性）。此識真諦三藏名之為第七識。以別取第八識之染分立名也。《唯識百法》謂之第八識。通取染淨和合為目也。《解深密經》謂之第九識。即菴摩羅識。別取第八識之淨分立名也。故陀那一名。實通三識。《楞嚴經》曰。陀那微細識。習氣成暴流。真非真恐迷。我常不開演。是知此識實含染淨二分。通乎真妄。故本詮從唯識列為第八識之異名。《深密解脫經·一》曰。彼識名阿陀那識。以彼阿陀那識。取此身相應身故。亦名阿梨耶識。以彼身中住著故。一體相應故。
    阿賴耶識為徧計依他圓成三性所知法之所依。故又名所知依（《俱舍論》云。眼所現見。名為所見。從他傳聞。名為所聞。自運己心之所思構。名為所受。自內所受及自所證。名為所知）。
    本覺心源。離念清淨云者。《仁王經》曰。自性清淨。名本覺性。《起信論》云。心體離念。離念相者。等虛空界。無所不徧。法界一相。即是如來平等法身。依此法身。說名本覺。本覺心源之體。從真起妄而成不覺。返妄歸真。本覺體顯。是名始覺。依本覺故而有不覺。依不覺故而有始覺。蓋一切眾生本性之自性清淨心。本具照明之德。是名本覺。因無明之熏動而成不覺。由本覺內熏（無漏法性。冥冥熏習。令眾生厭生死苦。自信己身有真如法。發心修行。是為自體相熏習）。外緣修治（自法身立報身化身。使眾生成見佛聞法之外緣。得修治以復其初。是為用熏習。體相二大為內熏之因。用大為外緣修治所資）。漸生覺悟。謂之始覺。始覺者。如凡夫覺知前念起惡。能止後念令其不起。雖復名覺。以覺業不覺惑。仍名不覺。二乘初發意菩薩等。覺於念異。念無異相。以捨麤分別執著相。故雖未真證。而似於真。名相似覺。法身菩薩等（初地乃至九地）。覺於念住。念無住相。以離分別麤念相故。隨覺一分法性之理。覺道未圓。名隨分覺。菩薩地盡（十地並攝等覺）。滿足方便。一念相應。覺心初起。心無初相。以遠離微細念故。得見心性。心即常住。名究竟覺（心無初相。即謂無念。緣眾生從本以來。念念相續。未嘗離念。故云無始無明。若得無念。則心源湛寂。本無生滅。所謂一念不起。即十八界空。即身便是菩提華果。即身便是靈臺。瞥起一念便是境。若無一念。便是境忘心自滅）。復次。本覺隨染分別。名隨染本覺。覺體相者。名性淨本覺。詳見《起信論》。
    三性者。一，善性。謂第六識所起一切善法之性。世間善如五常十戒等。出世間善如六度四弘誓願（菩薩廣發誓願。內制其心志求滿足也。一，眾生無邊誓願度。此依苦諦境發誓。菩薩徧觀六道眾生。無量無邊。皆被生死諸苦所逼。欲度脫之。令出三界。二，煩惱無盡誓願斷。此依集諦境發誓。菩薩諦審煩惱惑業。無量無邊。招集生死苦果。流轉三界。無有窮盡。立願斷除。使六道眾生。亦悉斷除。令出三界。三，法門無量誓願學。此依道諦境發誓。菩薩諦審一切道法。無窮無盡。自既修學。亦令一切眾生修學。四，佛道無上誓願成。此依滅諦境發誓。菩薩諦審菩提之果。最勝無上。自成就已。普願一切眾生咸皆成就）等。二，惡性。謂第六識所起一切惡法之性。如五逆十惡等。三，無記性。謂第六識所起無善無惡之性。更分為二。一，有覆無記。妄惑之勢用微弱。雖無違損自他之力。然其體為妄惑。蘟覆聖道。又與此惑障俱者。謂之有覆無記。二，無覆無記。體非妄惑。又非與妄惑俱之法。其自性微弱。曾無損益自他。謂之無覆無記。
    三量者。一，現量。二，比量。三，非量。現量者。現謂顯現。即分明證境。無籌度心。親得法體。離妄分別。名之為現。言量者。量度。是楷定之義。謂心於境上楷定法之自體。不錯謬故。如鏡對物。現前明了。眼識於色。耳識於聲。皆是。比量者。比即比類。量即量度。以比類量度而知。故名比量。於不現顯之境。藉已知者比類量度而得也。非量者。謂心緣境時。於境錯亂。虛妄分別。不能正知。於非量處而起心量。境不稱心。故名非量。如見陽燄而指為水是也。《顯揚論》云。現量者。有三種相。一，非不現見相。二，非思構所成相。三，非錯亂所見相。比量者。此復五種。一，相比量。謂隨其所有相貌相屬。或由現在及先所推度境界。如見幢比知有車。見煙比知有火。二，體比量。由現見彼自體性。故比類彼物不現見體。或現見彼一分自體。比類餘分。如以現在比類去來等。三，業比量。謂以作用比業所依。如見遠物無有動搖。鳥集其上。比知是杌。若有動搖。比知是人等。四，法比量。謂於一切相屬著法。以一比餘。如屬無常比知有苦。以屬苦故。比空無我。以屬生故。比有老法。以屬老故。比有死法等。五，因果比量。謂因果相比。如見物行。比有所至。見有所至。比先有行。若見有人如法事王。比知當獲廣大祿位。見大祿位。比知先已如法事王等。八識中前五轉識與第八識。唯是現量。第六意識通於三量。第七末那。約有漏位中妄執第八見分為我。不稱境知。唯是非量。其內二分。則為現量。又《因明論》現量。比量。聖教量。《瑜伽論》證量。比量。至教量。亦稱三量。
    三境者。一，性境。謂眼識乃至身識及第八識等所緣色等實境相分。初心取境。未有分別。不起名言。無籌度心。是名性境。二，獨影境。謂如第六識緣空華、兔角、及過去、未來等所變相分。思量過去。惟有影現。獨緣法塵。不對實境。是名獨影境。三，帶質境。謂如第七識緣第八識見分境時。於現境分別質相。一半與本質同種生。一半與能緣見分同種生。以有塵相可分別故。是名帶質境。
    梵語阿世耶。此云種子。為對於現行法之稱。阿賴耶識中生一切有漏無漏有為法之功能。有如草木之種子也。為四緣中因緣之實體。四緣者。一，因緣。六根為因。六塵為緣也。二，等無間緣。舊譯作次第緣。心心所法。次第無間相續而起也。三，所緣緣。舊譯作緣緣。心心所法。依六塵為緣而生。還是自心之所緣慮也。四，增上緣。六根照境發識。有增上力用。諸法生時不生障礙也。《唯識論》云。種子有二類。一者。本有。謂無始以來。異熟法中。法爾而有。生蘊處界功能差別。名為本性住種。二者。始起。謂無始以來。數數現行。熏習而有。名為習所成種。故無始以來。從第八識所生有漏無漏一切有為法之功能為本有種子。種子由現行之前七識。隨所應而色心萬差之種種習氣（《唯識論》云。功能者。是習氣義。體即種子。略有三種習氣。一，名言習氣。謂有為法各別親種。名言有二。一，表義名言。即能詮義。音聲差別。二，顯境名言。即能了境心心所法。隨二名言所熏成種。作有為法各別因緣。二，我執習氣。謂虛妄執我我所種。我執有二。一，俱生我執。即修所斷我我所執。二，分別我執。即見所斷我我所執。隨二我執所熏成種。令有情等自他差別。三，有支習氣。謂招三界異熟業種。有支有二。一，有漏善。即是能招可愛果業。二，諸不善。即是能招非愛果業。隨二有支所熏成種。令異熟果善惡趣別）。皆悉落第八識中。更成生果之功能。為始起種子。種子生現行。現行熏種子。在色者二緣和合。在心者四緣和合時。阿賴耶識所持之種子生現行。為本有種子生果之功能。此之謂種子生現行。現行之法。必隨所應而熏種子。其所熏之種子。即新熏種子。此之謂現行熏種子。種子為能生。現行為所生。又因現行熏成種子。如第八識所持種子為因。生眼等之七轉識。又以七轉識之現行法為因。生第八識之種子。本識轉識。互為因果。故《宗鏡錄》云。本識是體。種子是用。種子是因。所生是果。
    種子識為阿賴耶識之異名。據《成唯識論》。凡有六義。一，剎那滅義。謂眼耳鼻舌身意等諸種子。剎那纔生。生即隨滅。念念不停而變異也。二，果俱有義。果者。識與根也。識、根同時俱起而成力用。如眼根照色境時。眼識即隨時同緣於諸實境分明顯了也。三，恒隨轉義。識起時種子亦隨而轉。如眼根照境時。種子隨而相續。無有間隔也。四，性決定義。諸識所緣之善、惡、無記三性。無有間雜。如眼識緣惡境則成惡法。而不能成善法。緣善境即成善法。而不能成惡法也。五，待眾緣義。識非由一因而生。必待眾緣而成就。如眼識之種子空明。須得根境等之緣而始顯發也。六，引自果義。諸識各引自體果用。如眼根照時。眼識即緣所對之實境。不混聲香味等別體也。
    異熟。舊譯作果報。依過去之善惡業所得之果報也。善惡二業為異熟所得引果（善惡業為能引。第八識為所引。故名引果）。善業感樂果。惡業感苦果。苦果樂果。皆無記性。與善惡業之善性惡性為異性。過去作業。現在受報。現在作業。招未來果。異時而成。人中造業。六道酬償。異類而報。因之與果。一者。異時而熟。異謂別異。屬因。熟謂成熟。是果。異因居過去。熟果即現在。二者。異性而熟。過去修異因。如五戒十戒等善業。為善性。十不善惡業為惡性。所招人天總別報異熟果。三塗總別報異熟果。皆無記性。三者。異類而熟。造異類業。受異類生。人中造業。受報則六趣各異。故曰異熟。至眼耳鼻舌身意六識之異熟。所得滿果（善惡一分別報來滿所得之果）。則名異熟生。非真異熟。以此六識之異熟。由阿賴耶識之異熟所生也。引果之識。徧三界有。具一實。二常。三徧。四無雜。四義。一切時相續酬牽引業。非如滿果之不徧而有間斷也。
    異熟因為六因之一。六因者。一，能作因。舊譯作無障因。謂不為障害。或且與助力。如眼與色為緣能生眼識。乃至意與法為緣能生意識。大地生草木。虛空之育萬物是也。二，俱有因。舊譯作共生因。謂心與心所更相佐助。如四大種及生住異滅等四相。同時俱有。互為因果。缺一不可是也。三，同類因。舊譯作自種因。謂同類之法。以同類之法為因。如過去善法、惡法、無記法各與現在之善法、惡法、無記法為因。現在者又與未來者為因是也。四，相應因。謂心與心所之法。同時相應而生。猶如親友和合成事是也。五，徧行因。舊譯作徧因。謂由同類因特開煩惱法而立。如苦集二諦之下惑（苦諦下惑。十使具足。即身見、邊見、戒禁取、見取、邪見、貪、瞋、癡、慢、疑也。集諦下惑。只有七使。無身見、邊見及戒禁取）徧於二諦也。六，異熟因。舊譯作報因。謂以善、惡因得善、惡報。異時異性異類而熟也。由異熟因所招異時異性異類之果。曰異熟果。由同類因與徧行因所招眾生由前之善、惡、無記轉生後之善、惡、無記。果隨業轉。業果相似。曰等流果。由俱有因與相應因所招世間諸法。依士夫造作之力用而得者。如農夫藝黍稷而收穫。商賈以貿遷而得利。曰士用果。由能作因所招依報身增上勝力而成者。如眼根雖有見性。若無眼識緣境。則無照用之力。必與他法和合方能成就者。曰增上果。以上四果。皆由六因所招。眾生因修八正道。遠離煩惱繫縛。不受果報者。曰離繫果。此以道力證得。不由前之六因。
    意識依意根而起。為了別法境之心王。一者。五同緣意識。又名同時意識。五俱意識。明了意識。與前五識同時而起。五根與五識同緣五塵明了取境。好惡長短。悉皆現前之意識也。為心之現量。以初心取境。未有分別。親得法之自體。故緣性境。以於五塵境上。分別好、惡、長、短種種塵相。故緣帶質境。二者。獨頭意識。不與五識同緣。而獨緣法塵。無境不對。為比量、非量。緣獨影境。更分為四。一，定中獨頭意識。緣於定境。定境之中。有理有事。事中有極略、極迴、及定自在所生等諸法處色。無一切塵境。為其對象。二，散位獨頭意識。謂不緣五塵之境。緣受所引及徧計所起諸法處色。非定非夢。如緣空華、兔角、鏡花、水月構畫種種色相。及過、現、未一切諸法皆是。三，夢中獨頭意識。不對諸塵。緣夢中境。徧計所執法處色。由心王性境變現而生諸相。四，亂意識。是散意識於五根中狂亂而起。然不與五識同緣。如患熱病見青為黃。非是眼識也。此四種皆名獨頭者。以不與前五識俱故。與末那、賴耶。仍係並起。
    一切生滅因緣。皆以阿賴耶識為體。意識為用。前五識取塵轉入意識。意識記法為因。第七識攀緣意識。造善惡業。第八識為六七兩識所依。以此生死苦果不斷。若前五識不取塵。即無六識。無六識則七識不生。七識不生。則無善惡業。無善惡業。則無生死。無生死。則如來藏心湛然常住。見《宗鏡錄·七十三》。
    《宗鏡錄·五十》云。第六識十名。一，對根得名。名為六識。二，能籌量是非。名為意識。三，能應涉塵境。名攀緣識。四，能徧緣五塵。名巡舊識。五，念念流散。名波浪識。六，能辨前境。名分別事識。七，所在壞他。名人我識。八，愛業牽生。名四住識（四住。即三界見思煩惱。一，見一切住地。三界一切之見惑也。二，欲愛住地。欲界一切之思惑也。三，色愛住地。色界一切之思惑也。四，有愛住地。無色界一切之思惑也）。九，令正解不生。名煩惱障識。十，感報終盡。心境兩別。名分段死識。第七識十名。一，六後得名。稱為七識。二，根塵不會。名為轉識。三，不覺習氣。忽然念起。名妄想識。四，無間生滅。名相續識。五，障理不明。名無明識。六，返迷從正。能斷四住煩惱。名解識。七，與涉玄途。順理生善。名行識。八，解三界生死。盡是我心。更無外法。名無畏識。九，照了分明。如鏡顯像。名現識。十，法既妄起。恃智為懷。令真性不顯。名智障識。第八識十名。一，七後得名。稱為八識。二，真偽雜間。名和合識。三，蘊積諸法。名為藏識。四，住持起發。名熏變識。五，凡成聖名。為出生識。六，藏體無斷。名金剛智識。七，體非靜亂。名寂滅識。八，中實非假。名為體識。九，藏體非迷。名本覺識。十，功德圓滿。名一切種智識。第九識十名。一，自體非偽。名為真識。二，體非有無。名無相識。三，軌用不改。名法性識。四，真覺常存。體非隱顯。名佛性真識。五，性絕虛假。名實際識。六，大用無方。名法身識。七，隨流不染。名自性清淨識。八，阿摩羅識。即菴摩羅識。此云無垢。九，體非一異。名真如識。十，勝妙絕待。名不可名目識。
    《成唯識論述記·五》云。七八相續。當體彰名。六有間斷。從依得稱。曰從依者。以六識皆有所依。眼識依眼根。耳識依耳根。鼻識依鼻根。舌識依舌根。身識依身根。意識依意根。意根者。末那也。從境得名。則曰色識乃至法識。謂於六境了別名識也。色等五識。惟了色等。法識通能了一切法。故或以能了別法獨得法識之名。 此八種識。具三能變（根身器界為所變）。一，異熟能變。即第八識。二，思量能變。即第七識。三，了別能變。即前六識。《惟識論》云。識所變相。雖無量種（根身器界皆是）。而能變識。類別惟三。一，謂異熟。即第八識。多異熟性故。二，謂思量。即第七識。恒審思量故。三，謂了境。即前六識。了境麤相故。第八識能變又有二。一，因能變。二，果能變。《唯識論》云。能變有二種。一，因能變。謂第八識中等流、異熟二因習氣。等流習氣。由七識中善、惡、無記熏令生長。異熟習氣。由六識中有漏善惡熏令生長。二，果能變。謂前二種習氣力故。有八識生現種種相。等流習氣因緣故。八識體相差別而生。名等流果。果似因故。異熟習氣為增上緣。感第八識酬引業力。恒相續故。立異熟名。感前六識酬滿業者。從異熟起。名異熟生。不名異熟。有間斷故。即前異熟及異熟生。名異熟果。果異因故。見《宗鏡錄·四十七》。
    阿賴耶識。建立有情無情。發生染法淨法。若有知有覺。則眾生界起。若無想無慮。則國土緣生。故《楞嚴經》曰。想澄成國土。知覺乃眾生。《瑜伽論》云。阿賴耶是一切雜染根本。所以者何。由此識是有情世間生起根本。能生諸根。根所依處。及轉識等故。亦是器世間生起根本。由能生起器世間故。亦是有情互起根本。一切有情相望互為增上緣故。
    一切有部說。阿賴耶識。有愛樂欣喜之四。《攝大乘論·二》云。世間眾生愛阿賴耶。樂阿賴耶。欣阿賴耶。喜阿賴耶。世親菩薩釋云。世間眾生愛阿賴耶者。是總標句。如其次第復以餘句。約就現在過去未來三時別釋。復有別義。謂於現在愛阿賴耶。於過去時樂阿賴耶由先世樂阿賴耶故。復於今世欣阿賴耶。由樂由欣阿賴耶故。於未來世喜阿賴耶。無性菩薩釋云。愛阿賴耶。此句總說貪著阿賴耶識。樂阿賴耶識者。樂現在世阿賴耶識。欣阿賴耶識者。欣過去世已生阿賴耶識。喜阿賴耶識者。喜未來世當生阿賴耶識。此性於彼極希願故。由樂欣喜。是故總名愛阿賴耶。
    識須藉緣以生。謂明空根境等九種之緣。生眼耳鼻舌等八種之識也。以眼耳鼻舌身五識依第八識相分建立。由第八識種子而生攬明空諸境而為相。第六識緣第八識相分而得生。取五塵境界而分別。依第七識而能執取。第七識緣第八識見分而得起。轉第六識染淨而為依。第八識為眾識之根本。含諸法之種子。依第七識轉託五根識而為相。識藉緣生。緣因識有。遞相依託。而多少不同。一，明緣。明者日月之光。能顯諸色相也。謂眼因明而見。無明則眼識不能發。故明為眼識之緣。二，空緣。空者蕩然無礙。而能顯諸色相也。謂眼以空而能見。耳以空而能聞。無空則眼耳之識不能發。故空為眼識耳識之緣。三，根緣。謂眼耳鼻舌身五根也。五識各依其根而能見。能聞。能覺齅。能覺嘗。能覺觸。若無五根則五識無所依。故五根為五識之緣。四，境緣。謂色聲香味觸。五塵之境。眼等五根雖具五識。如無塵境為之對象。則識無由發。故境為五識之緣。五，作意緣。作意即心所法。謂根與境對。便能有知。使第六識即起分別善惡之念。徧行一切識境。故作意為前六識之緣。六，根本依緣。根本為第八阿賴耶識。依即依託。謂第八識為諸識根本。眼等六識。依第八識相分而得生。第八識相分。託眼等六識而得起。故根本依為六識及八識之緣。七，染淨依緣。染淨依即第七末那識。謂一切染淨諸法。皆依此識而轉。眼等六識。於六塵境起諸煩惱惑業。則轉此煩惱染法歸於第八識。而成有漏。若六識修諸道品淨業。則轉此道品淨法。歸於第八識。而成無漏。然第七識亦依第八識而能轉。第八識依第七識而隨緣。互相依託。故染淨依為眼等八識之緣。八，分別依緣。分別即第六識。此識能分別善、惡、有漏、無漏、色、心諸法。以眼等五根。雖能取境。然皆依此識而有分別也。五根境之好惡。由分別而生。第七識之染淨。由分別而知。第八識之相分。由分別而顯。故分別依為眼等八識之緣。九，種子緣。即眼等八種識之種子也。謂眼識依眼根種子而能見色。耳識依耳根種子而能聞聲。鼻識依鼻根種子而能齅香。舌識依舌根種子而能嘗味。身識依身根種子而能覺觸。意識依意根種子而能分別。第七識依染淨種子而能相續。第八識依含藏種子而能出生諸法。以諸識各依種子而生。故種子為眼等八識之緣。種子生現行五識為親因緣。故稱內緣。其餘八者謂之外緣。根識之間。識為能依。根為所依。五根皆為第八識所執持。第八識隨業力而轉。無有間斷。故五根亦隨而相續。識則必待緣而生。如眼識須全具九緣。耳識須具八緣（九緣中去明）。鼻舌身三識須具七緣（九緣中去明與空）。第六識須具五緣（九緣中去明、空、染淨、分別）。第七識須具四緣（九緣中去明、空、根、染淨、分別）。第八識須具四緣（九緣中去明、空、根本、分別、根）。諸緣具足。方能生識。若加等無間緣。則八識各添一緣。等無間緣者。於心心所相續上所立之緣。滅於前念之心法。引起後念心法之作用也。前念後念各別相等謂之等。前心後心之間無他間隔之物體。無論經若干時。前念之心法。直與後念之心法為生緣。故曰無間。此緣惟限於心法有之。
    諸識有三種相。一，轉相。八識起時皆有生滅故。二，業相。動則是業。八識皆動故。三，真相。八識真心。盡名真相故。
    一一識中皆具能所。蓋心不孤起。必攀外境。心為能緣。境為所緣。能分別是識。所分別是境。能即依他性。所即分別性。
    阿賴耶識。《宗鏡錄》析為十類。一，大攝主阿賴耶識。即總相大識也。二，根本無明阿賴耶識。以一切染法為根本。出生增長。無斷絕時。三，清淨本覺阿賴耶識。自然本智。具足無漏圓滿功德。四，染淨本覺阿賴耶識。不守自性。受一切煩惱染法。與之俱轉不相捨離。五，業相業識阿賴耶識。無明業識。依不覺故心動。說名為業。六，轉相轉識阿賴耶識。能見境界之相而與轉識也。七，現相識阿賴耶識。境界相與現識具足行轉也。八，性真如理阿賴耶識。即正智所證清淨般若智境真如。九，清淨始覺阿賴耶識。本有清白始覺般若也。十，染淨始覺阿賴耶識。所謂隨緣始覺般若也。
    菴摩羅識在所緣為真如。在本覺即真如智。所緣即空如來藏。能緣即不空如來藏。空如來藏者。心體平等。絕染淨相。所起諸法。自性非有故。不空如來藏者。真如自體。具無漏清淨功德。及諸有漏惑業染法。如虛空之含有萬象。真如之體畢竟空寂。如明鏡之含攝萬物。無一實質也。此二並以真如為體。見《宗鏡錄·五十六》。
    《廣五蘊論》云。云何識蘊。謂於所緣了別為性。亦名心。能採集故。亦名意。意所攝故。若最勝心即阿賴耶識。此能採集諸行種子故。又此行相不可分別。前後一類相續轉故。又由此識從滅盡定、無想定、無想天起者。了別境界。轉識復生。待所緣緣差別轉故。數數間斷，還復生起。又令生死流轉迴環故。阿賴耶識者。謂能攝藏一切種子。又能攝藏我慢相故。又復緣身為境界故。又此亦名阿陀那識。能執持身故。最勝意者。謂緣藏識為境之識。恒與我癡，我見，我慢，我愛相應。前後一類。相續隨轉。除阿羅漢，聖道，滅定，現在前位。如是六轉識，及染污意，阿賴耶識。此八名識蘊。註云。八識心王。總名識蘊。受想行識同為心法。受想行為心所有法。名心所。識為心之本體。名心王。八識皆有了別集起依止三義。先就其對於所緣境能了別而言。故云於所緣了別為性。亦名心者。就其於諸行相能集起而言。故云能採集。亦名意者。就心王能為心所所依止而言。最勝心即阿賴耶識者。因心意識三名。通乎八識。若就最勝而言。則第八識始可名心。故云最勝。諸行。即一切法。指行蘊而言。謂此識能聚集一切法之種子也。識以了別為行相。相者。體也。即謂境相。行於境相，名為行相。或云。相者。相狀。行境之相狀。名為行相。阿賴耶識緣境之行相。極其微細。非聖智莫能知。故云不可分別。此識緣境。無間斷。無變易。就人之一期生死言。從投胎由此識執受以至命終。皆一味了別而轉。絕無少變。故云前後一類相續轉。滅盡定是無漏定。心無所緣。煩惱不生。有漏前七心、心所皆滅。故名滅盡。三果、四果及十地菩薩乃至佛果。皆得此定（《大般若經·五百九十二》曰。菩薩亦得滅受想定。謂於此定。已得自在而不現入）。無想定是有漏定。外道以想念為生死根本。故以滅想念為得涅槃。先在人中修無想定。身後生四禪無想天。無想天，即四禪之第四天。修無想定之外道依前生所修定力。生彼天後。所有不恒行心、心法皆滅。依此無心分位。假立無想天之名。轉識者。前七識也。八識中第八阿賴耶識為本識。前七識為轉識，阿賴耶識是所依。轉識是能依。滅盡定等雖能滅能依轉識。而不能滅所依阿賴耶識。故此識從定起時。轉識還復得生。所緣緣者。四緣之一。心法，依四緣生。一，因緣。二，等無間緣。三，所緣緣。四，增上緣也。心法是能緣。境是所緣。心必依境而起。故名所緣緣。待所緣緣差別而轉者。如滅盡定。已離無色界之無所有處。其阿賴耶識於非想非非想處。又緣極微細執受境。無想定生無想天後。其阿賴耶識又於色界緣廣大執受境是。數數間斷者。言阿賴耶識於所緣境念念生滅。剎那相續流轉。故云還復生起。蓋就阿賴耶識之行相言。緣境無間斷。無變易。就生死流轉相言。故云數數間斷也。第八識有三位。一，我愛執藏位。二，善惡業果位。三，相續執持位。在我愛執藏位。此識名阿賴耶。梵語阿賴耶。此云藏。有三義。謂能藏、所藏、我愛執藏也。就此識能攝藏諸法種子言。則此識為能藏。種子為所藏。就前七識雜染種子。藏於此識而言。則前七為能藏。此識為所藏。第七識恒執此識見分。執之為我。而起慢相。則我愛執藏也。雖有三義。而正取執藏為名。阿羅漢已破我執。即捨阿賴耶識之名。緣身為境界者。身為形之總稱。謂第八識能引眾生之善惡業種子。使異世成熟。受果報之身。故亦名異熟識。為境界者。謂即就本識所變之身。以為所緣之境界也。此在善惡業果位。八地以上菩薩。始捨異熟識之名。阿陀那。此云執持。謂此識從無始以來。相續執持。通乎果位。執者。果位正智所執。持者。含藏無漏種子。此相續執持位也。最勝意，即七識。於一切時皆執我我所。而以思量為性也。藏識為七識之所依。七識即緣所依以為自體。故云緣藏識為境之識。我癡。即無明。不知無我之理。愚於我相。故名我癡。我見。即我執。此身為五蘊等法假合而成。明明非我。而妄執以為我。凡夫計我為人，名人我見。二乘計一切法各有體性。怖畏生死。名法我見。我慢者。謂自恃有我。而起倨傲。令心高舉也。我愛即貪。於妄執之我，深生躭著也。此四屬根本煩惱。恒與第七識相應。阿羅漢示斷位。至此位。則染污意之現行種子皆斷。聖道、滅定、示伏位。聖道即修無漏道者。謂此識相應煩惱。無始時來。微細一類相續而轉。故有漏道不能伏滅。惟無漏心起。方能伏滅也。滅定，即滅盡定。入此定者。現無漏觀。極其寂靜。故亦能伏滅此識。現在前位者。猶言三者修證之果。現在於前之位次也。謂惟此三者。方能伏斷。否則此識總是相續隨轉也。
    《顯識論》謂一切三界。但惟有識。三界有二種識。一者。顯識。二者。分別識。顯識者。即是本識。本識轉作五塵四大等。分別識即是意識。於顯識中分別作人天長短大小男女樹籐諸物等。分別一切法。此識聚分別法塵。名分別識。顯識有九種。惟是梨耶。一，身識（即五根）。二，塵識（色界等乃至色塵。通名應受識）。三，用識（眼識界等六識。大論名為正受識）。四，世識（過未現三世。又生死相續不斷。故名世）。五，器識（略即器世界。廣即十方三界。大論名處識）。六，數識（算計量度）。七，四種言說識（一切言說。不出見聞覺知之四）。八，自他異識（依處各異。六趣不同。依處者。身也）。九，善惡生死識（生死不離善惡。善者人天。惡者四趣。善惡道不離生死。即生即滅。無停住故。）。分別識有二種。一，有身識（我見所覆。受六趣生）。二，受者識（意界名受者。識即三種意識。一，阿梨耶識。是細品意識。二，陀那識。是中品意識。三，常所明意識。是麤品意識）。合名意根。《楞伽經》分識為二。一，了別識。二，分別事識。又分識為三。一，真識。謂本覺。二，現識。謂第八。三，分別事識。謂餘七。《起信論》分識為五。一，業識。二，轉識。三，現識。四，智識。五，相續識。《宗鏡錄·五十六》分識為五。一，所依本一識。二，能依持藏識。三，意持識。四，徧分別識。五，隨順徧轉識。《轉識論》分識為三。一，果報識。即阿梨耶識。亦名本識。二，執識。即阿陀那識。三，塵識。即前六識。
    《顯揚論·五》云。識蘊建立有三種。一，種類差別。二，依差別。三，雜染清淨差別。種類差別者。有二種。一，阿賴耶識。二，轉識。依差別者。謂六識身。雜染清淨差別者。如經中說。有貪心。如實知有貪心。離貪心。如實知離貪心。如是有瞋離瞋。有癡離癡。乃至廣說。《瑜伽論·五十四》云。識蘊差別五種。一，由安住故。二，由雜染故。三，由所依故。四，由住故。五，由異相故。


第二。十二處。

    無眼。耳。鼻。舌。身。意。無色。聲。香。味。觸。法。
    梵語薩達耶怛那。此云處。缽羅吠舎。此云入。處者。出生義。謂出生六識之處。以六根為所依。六境為所緣。根境相依而生六識故。入者。涉入義。根境互相涉入。又根境均為識之所入故。
    十二處者。眼處。耳處。鼻處。舌處。身處。意處。為內六處。識之所依也。色處。聲處。香處。味處。觸處。法處。為外六處。識之所緣也。
    內六處又名六根。根者。能生義猶草木之根。能生枝乾也。識依根以生。無根則無識。謂之根者。言識所從生也。諸根皆有浮塵根、勝義根之別。吾人肉眼可見之五根器官。浮塵根也。諸根依其增上勝力。照境發識以成根用者。勝義根也。此所說者。為勝義根。
    【注】浮塵根又名扶塵根。浮者。四大所成。虛假不實之義。扶者。扶助。勝義根為其所扶助也。《楞嚴經》曰：眼如蒲萄朵。耳如新卷葉。鼻如雙垂爪。舌如初偃月，身如腰鼓顙。意如幽室見，除意外皆器官之可見者。或以浮塵根為當作浮根塵，或扶根塵。以《楞嚴經》有我今觀此浮根四塵。只在我面之語。《資中》云。浮虛不實。昏翳真性。故曰浮塵。本詮從之。勝義根又名淨色根。內根以淨色為性也。言浮塵者。四大地水火風是能造。四微色香味觸為所造。八法和合。得成根故。勝義根雖亦以八法為體。是不可見有對色。能照境發識。非同塵境粗淺。故名淨色。

    一者。眼。梵語斫蒭。斫者。行義。蒭者。盡義。謂能於境行盡見諸色故。名行盡。能見眾色。名之為眼。此根以色為境。淨色為性而能見。
    二者。耳。梵語娑路多羅戍縷多。能聞諸聲。名之為耳。此根以聲為境，淨色為性，而能聞。
    三者。鼻。梵語伽羅尼羯囉拏。能齅諸香。名之為鼻。此根以香為境，淨色為性，而能覺齅。
    四者。舌。梵語時乞縛。能嘗眾味。敷發言論。名之為舌。此根以味為境，淨色為性，而能覺嘗。
    五者。身。梵語有四名。一，迦野。二，設利羅。三，弟訶。四，應伽。此云積聚。諸根所隨。周徧積聚。故名為身。此根徧住身分。為諸根之所依止。以觸為境，淨色為性，而能覺觸。
    六者。意。梵語紇利陀耶。此云肉團心。即意根所託。故曰意如幽室見。此根能緣前五塵境界。分別好惡。根塵相對。緣具生識而能知。故《五蘊論》云。意處即是識蘊。
    【注】《品類足論·二》略云。眼處云何。謂眼是色已、正、當、能見、及彼同分。耳處云何。謂耳是聲已，正、當、能聞及彼同分。鼻處云何。謂鼻是香已、正、當、能齅及彼同分。舌處云何。謂舌是味已、正、當、能嘗及彼同分。身處云何。謂身是觸已、正、當、能觸及彼同分。意處云何。謂意是法已、正、當、能了及彼同分。按此內六處。眼耳鼻舌身意。為能見、能聞、能齅、能嘗、能觸、能了。則外六處之色聲香味觸法。即為所見、所聞、所齅、所嘗、所觸、所了。可知。
    《大毗婆娑論·七十一》略云。已見色者。謂過去眼。正見色者。謂現在眼。當見色者。謂未來眼。及彼同分者。諸見色眼。於自有情。名同分眼。於餘有情亦名同分。諸不見色眼。於自有情。名彼同分。於餘有情。亦名彼同分。見色眼與不見色眼。俱一界攝。俱一處攝，俱一根攝。同一見性。故見色眼。是不見色眼之同分。不見色眼。復是彼見色眼之同分。同分彼同分。品類差別。皆相似故。
    淨色者。指淨色之勝義根。五根必以淨色為性。而根得生。無即不生。舌身二根。淨色徧攝所依處。眼耳鼻三根。則僅有一分。而非徧滿。有說舌上亦有少不徧處。如一毛端無淨色根。
    意處即是識蘊。有大小乘之別。小乘以六識為意處。大乘則八識皆意處攝。
    意根在六根中最為造業之本。如《大涅槃經·三十七》曰。是業三種。謂身口意。善男子。身口二業。亦名為業。亦名業果。意唯名業。不名為果。以業因故。則名為業。善男子。身口二業。名為外業。意業名內。是三種業。共煩惱行故。作二種業。一者。生業。二者。受業。善男子。正業者。即意業也。期業者。謂身口業。先發故。名意業。從意業生。名身口業。是故意業得名為正。

    外六處。又名六塵。塵者，染污義。謂能染污情識。使真性不能顯發也。亦名六境。謂六根所緣之境也。
    一者。色。梵語俱蘭吒。亦作嚕畔。謂眼所行境。眼識所緣。四大所造。若顯色，若形色，若表色，為體。色蘊所攝。顯色者。顯即明顯。色即質礙。凡十有三。青黃赤白光影明闇煙云塵霧及空一顯色。形色者。形即形相。凡十。長短方圓粗細高下正與不正。表色者。雖屬動作。而依其作相。眼根可見。故亦屬色領。凡八。取捨屈伸行住坐臥是。
    【注】顯色之本色有四。即青黃赤白，餘則由此四色差別而出。《俱舍論》云。顯色有四。青黃赤白，餘顯是此四差別。
    須彌山四面空中之各一顯色。謂之空一顯色。北洲金色，東洲銀色，南洲碧色，西洲赤色。為莊嚴天空世間之色。
    《大毘婆沙論·一百二十二》略云。然諸色處。總有四種。一，有色處惟顯可了，非形。謂青黃赤白光影明闇。二，有色處惟形可了，非顯。謂身表色。三，有色處顯形俱可了。謂所餘若顯，若形，俱可了色。四，有色處顯形俱不可了。謂空界色。

    二者。聲。梵語設沒囉。謂耳所行境。耳識所緣。四大所造。可聞音為體。色蘊所攝。可聞音者。一，執受大種聲。執者攝持。受者領受。大種者。地水火風。謂眾生於內四大種有所執受而發之聲也。口舌手足之聲。發自有情之四大種者是。二，非執受大種聲。謂眾生於外四大種無所執受而發之聲。如風林溪水。發自非情之四大種者是。三，俱大種聲。執受不執受二者兼具之聲。如以手擊鼓。手屬執受大種。鼓非執受大種是。四，世所共成聲。世人因談論或問答所成之聲。五，成所引聲。聖人所說法音。引導眾生出離生死而成之聲。六，可意聲。歡樂之聲。聞之適意。七，不可意聲。愁苦之聲。違逆情意。八，俱相違聲。不苦不樂。非逆非順。九，徧計所執聲。外道於一切法徧計有無及常無常等執著所說而成之聲。十，聖言聲。即正直實語之聲也。十一，非聖言聲。反於聖言虛偽不實之聲也。
    【注】《大毘婆沙論·十三》云。聲處有八種。謂執受大種因聲。非執受大種因聲。此各有二。謂有情聲。非有情聲。此復各有可意不可意別。故成八種。
    內四大種。謂身中之地水火風。外四大種。謂世間之地水火風。

    三者。香。梵語獻馱囉。謂鼻所行境。鼻識所緣。四大所造。可齅物為體。色蘊所攝。可齅物者。一，好香。如沈香麝香。與鼻合時。於蘊相續。有所順益。二，惡香。如蒜韭等。與鼻合時。於蘊相續有所違損。三，平等香。如土石等。與鼻合時。無所損益。此以鼻根所取之相而分別者。若以境別。復立三名。一，俱生香。如旃檀等。其香與生俱來。二，和合香。其質由人工製作而成。三，變異香。其香由物質成熟變異而生。如果類成熟時增加之香是。
    四者。味。梵語佐塞。謂舌所行境。舌識所緣。四大所造。可嘗物為體。色蘊所攝。可嘗物者。一，甘味。二，酸味。三，鹹味。四，辛味。五，苦味。六，淡味。此依舌根所取之相而分別者。若以境別。復立三名。一，俱生味。如甘蔗之甘。黃連之苦。隨其本性而然者。二，和合味。多味和合而成。如世間烹調之味。三，變異味。如瓜熟而甘。薑老而辛之味。又有分一，甘味。二，不甘味。三，俱相違味。及一，可意味。二，不可意味。三，順捨處味者。《瑜伽論》云。或立一種味。謂由舌所行義故。或立二種。謂內及外。
    五者。觸。梵語紇囉瑟吒耶。謂身所行境。身識所緣。四大所造。可觸物為體。色蘊所攝。觸又分能觸所觸。能觸有二。一，觸心所法。二，能觸身根。所觸亦有二。一，能造四大種。二，所造觸處。此所云觸。僅所觸中之所造。故《五蘊論》謂之觸一分。謂非全分也。觸之差別相二十有二。一，滑性。二，澀性。三，輕性。四，重性。五，冷。六，飢。七，渴。八，軟。九，緩。十，急。十一，飽。十二，力。十三，劣。十四，悶。十五，癢。十六，黏。十七，病。十八，老。十九，死。二十，疲。二十一，息。二十二，勇。或緣光澤。或不光澤。或緣堅實。或不堅實。或緣執縛。或緣增聚。或緣乖違。或緣和順。若俱生。若和合。若變異。是名觸一分。
    【注】滑、澀、重、輕。從自性得名。故稱性。冷、飢、渴。係從結果為名。因煖欲、食欲、飲欲，是別境心所中之欲。由內身觸力令欲煖、欲食、欲飲。此之觸相。隱微難顯。煖欲為冷。食欲為飢。飲欲為渴。故從果為名。以顯其觸體也。
    觸之差別有多種。《瑜伽論》所說。最多者如十種觸。一，食觸。二，飲觸。三，乘觸。四，衣觸。五，莊嚴具觸。六，床座觸。七，機橙臺枕及方座觸。八，女觸。九，男觸。十，彼二相事受用觸。

    六者。法。梵語達摩。謂意根所緣之境。意根對前五根所緣境界。分別好醜而起善惡諸法。是名法塵。法塵所及。普徧五根。凡五根對境之時。意根即同時俱起。將所緣之境。攝入意根。吾人日常動作。雖已過去。而前塵影事。憶念不忘。即法塵之作用也。法之差別相凡四。一，生。二，住。三，異。四，滅。以根對塵。一念心生。是為生相。一念之心。暫爾相續。是為住相。一念之心。先後不同。是為異相。塵境既忘。心念亦滅。是名滅相。交光師謂初憶名生。正憶名住。初忘名異。忘盡名滅。雖曰四相。亦僅是二。以住即生際。異即滅際故。云法處者所含甚廣。《廣五蘊論》云。法處謂受想行蘊。并無表色等及諸無為。
    【注】四相有大四相小四相之分。大四相指一期受報而言。小四相就一念而言。《唯識論》云。本無今有名生，生位暫停名住，住別前後名異，暫有還無名滅。
    對五根所緣境界而起善惡諸法。如五根緣善境界。識中則有善性現起。緣惡境界。識中則有惡性現起。緣無記境界。識中則有無記性現起。
    十二處無一非法。獨此名法處者。以惟有意處對一切法故。對意者獨以法處名。見《大毘婆沙論·七十三》。
    在色處所攝顯色、形色、表色之外。法處所攝色。亦有五。一，極略色。分析色聲香味觸眼耳鼻舌身等有質之實色。令至極微。名極略色。二，極迴色。分析虛空青黃赤白等無質之顯色。令至極少。至不能見。名極迴色。三，受所引色。即無表色也。受者。領納義。思之種、現，上有防發功能。名所引色。因受戒而引發身內地水火風之色也。四，徧計所起色。徧計一切法之意識前所顯現之五根、五境等影像。如空華水月等。五，定所生自在色。禪定所變之色聲香味等境。以勝定力之故。於一切之色。變現自在。名定所生自在色。亦名定所引色。亦名定果色。《雜集論·一》參照。
    《顯揚論·一》云。法處所攝色。謂一切時意所行境。色蘊所攝。無見無對。此復三種。謂律儀色。不律儀色。及三摩地所行境色。律儀色云何。謂防護身語業者。由彼增上造作心、心法故。依彼不現行法。建立色性。不律儀色云何。謂不防護身語業者。由彼增上造作心、心法故。依彼現行法。建立色性。三摩地所行境色云何。謂由下中上三摩地俱轉相應心、心法故。起彼所緣影像色性。及彼成就所作色性。是名法處所攝色。
    《大毘婆沙論·十三》云。法處有七種。謂前四蘊及三無為於色蘊中。取無表色。三無為者。謂虛空、擇滅、非擇滅。
    法塵有二。逆緣前五塵落謝影子。為生法塵。不緣過未影子。內守幽閑靜境。為滅法塵。
    《廣五蘊論·注》云。法處兼攝一切有為法。無為法。受想行三法。及無表色等有為法也。諸無為者。指無為法也。并字示色法、心法相違義。及字示有為法無為法之界畔也。無為對有為而言。謂色、心諸法。非本來常住，必由四緣而生。故名有為。此諸法因果轉變。三世遷流。而生滅無常。故名有為法。無為法反之。非依四緣而生。其體離生滅遷流。本來常住。凝然一味。故名無為。
    《廣五蘊論》云。云何無為。謂虛空無為。非擇滅無為。擇滅無為。及真如等。虛空等。謂容受諸色。非擇滅者，謂若滅非離繫。云何非離繫。謂離煩惱對治諸蘊畢竟不生。云何擇滅。謂若滅是離繫。云何離繫。謂煩惱對治諸蘊畢竟不生。云何真如。謂諸法法性。法無我性。註云。虛空者。謂虛空能容受諸色。而了無障礙。真如於一切法。非一非異。非即非離。離諸障礙。猶如虛空。故從譬喻得名。當知此唯假有。非是實有。非擇滅者。謂諸煩惱。皆由無漏慧簡擇之力方得滅。今不由慧力而滅。故云非擇滅。繫者指諸煩惱之繫縛而言。離此繫縛。皆由慧之簡擇力。今不由此。故云若滅非離繫。離煩惱對治者。煩惱是所治。慧力是能治。今不由慧力。故云離煩惱對治。諸蘊指色心等一切法。畢竟不生有二義。一，謂真如本性。在凡在聖。本來明淨。不必由無漏簡擇力方顯。名非擇滅。二，謂色、心諸法由眾緣而生。若遇緣闕不生。則唯所依真理獨顯。此不生之滅所顯真理。亦名非擇滅。此滅名亦唯假有而非實有。謂煩惱對治者。謂由無漏慧簡擇力。故能滅煩惱雜染法。究竟證會真如。故名擇滅。此名亦唯假有而非實有。真如者。真以別於虛妄。如以別於顛倒。又真者。實義。如者。常義。諸法即色、心諸法。諸法雖虛妄顛倒。而法之本性。則是實、是常。離於人我執及法我執。故云法無我性。
    諸無為者，即論中所示之四無為。《準唯識論》。則此四無為外。尚有不動無為。就法性生四禪天離苦樂粗動之位所顯者名之也。想受滅無為。就法性入於聖者非想地所攝之滅盡定名之也。此為大乘之六無為。但此非謂六種別體。乃斷我法二執處所顯之一種真理。有、無、常、無常，皆不可名。但依法之實性從所顯之緣。分種種之名而已。虛空、擇滅、非擇滅、不動、想受滅，五種無為。為詮法性之相之假名。名體皆為假立。真如無為。體雖定在。而真如之名。亦為假立。小乘則薩婆多部。立三無為。一，擇滅無為。二，非擇滅無為。三，虛空無為。大眾部立九無為。一，擇滅。二，非擇滅。三，虛空。四，空無邊處。五，識無邊處。六，無所有處。七，非想非非想處。八，緣起支性。九，聖道支性。

    此十二處法。不過生長心與心所之作用。不但無我亦無我法故。經曰。無眼耳鼻舌身意。無色聲香味觸法。以無遣之。則十二處皆空。《大般若經》曰。眼處但有名。乃至法處但有名。眼處空乃至法處空是也。


第三。十八界。

    無眼界。乃至無意識界。

    無者。非有之義。乃至者。省文中略之辭。自眼界色界眼識界。耳界聲界耳識界。鼻界香界鼻識界。舌界味界舌識界。身界觸界身識界。意界法界意識界。根境識三者各六。凡十八界。經文僅舉最初眼界。及最後之意識界者。舉始末以賅餘名也。界。梵語馱都。差別之義。《大乘義章》曰。界別為界。諸法性別。故名為界。《法界次第》云。界以界別為義。根塵識各有界限。如眼以色為界。耳以聲為界。鼻以香為界。舌以味為界。身以觸為界。意以法為界。眼不能越色有見。耳不能越聲有聞。鼻不能越香有齅。舌不能越味有嘗。身不能越觸有覺。意不能越法有知。色以眼為界。以眼所見必色。非聲香等能對眼。故眼識必依眼根始發。餘根不能。而眼根除眼識外。亦不能發耳鼻等識。推之諸根皆然。界限分明。故名曰界。
    【注】諸論釋界。尚有多義。一界者。持義。謂能持大種自相不失。能持所造色相續不失。《俱舍論·八》云。能持自相。故名為界。二，界者。性義。《大乘義章·八》云。經名為界。亦名為性。三，種族義。《俱舍論·一》云。法種族義是界義。如是一身或一相續。有十八類諸法種族。名十八界。四，能取、所取、被取種子義。能取種子。謂眼等內六界。所取種子。謂色等外六界。被取種子。謂識等六識界。見《辯中邊論》。五，因義。《百法疏》云。界是因義。中間六境。藉六根發六境。牽生與識為因。故名曰界。六，藏義。《唯識論·十》云。界是藏義。七，發起義。《瑜伽論·五十七》云。發起諸法。是故名界。是牽引義。八，能持因果性義。《雜集論·二》云。謂於十八界中。根境諸界及六識界。如其次第。

    根境識三者。各占六界。名十八界。六根為內六界。六境為外六界。如十二處中所示。六識界者。依眼根而能見色。了別為性。名眼識界。依耳根而能聞聲。了別為性。名耳識界。依鼻根而能齅香。了別為性。名鼻識界。依舌根而能嘗味。了別為性。名舌識界。依身根而能覺觸。了別為性。名身識界。依意根而能分別一切法相。了別為性。名意識界。識依於根。能依也。根為識依。所依也。識入根內。能別於境。故名為識。《大般若經》曰。眼界但有名。耳鼻舌身意界但有名。色界但有名。聲香味觸法界但有名。眼識界但有名。耳鼻舌身意識界但有名。《瑜伽論》云。蘊處及界等。遠離諸性相能取所取執。諸法悉無我。平等如虛空。自性本不生。空性圓寂故。知諸法自性空。則十八界空。
    【注】識界者。五識身及有漏意識之六界也。《俱舍論》云。諸有漏識。名為識界。有漏者。因煩惱惑業。漏落生死之謂。識有八而只說眼耳鼻舌身意六識界者。以末那與阿賴耶。意識界識。更不別立也。此十八界中。色蘊占十處十界（眼耳鼻舌身色聲香味觸）及法處法界一分（無表色）。識蘊即意處及七心界（六識界及意界攝心王。故名七心界）。餘三蘊及色蘊一分（即無表色）並諸無為。即法處法界所攝。見《廣五蘊論》。
    《品類足論·二》云。意識界云何。謂意及法為緣。生意識。如是意為增上。法為所緣。於意所識法諸已、正、當、了別及彼同分。《大毘婆沙論·七十二》云。六識界皆是意界攝。已說意界有彼同分。應知即已說六識界。故不復說。問。若爾不應立六識界。此六即是意界攝故。答。雖即意界。而為建立根境識三。各有六故。復別說有六識差別。
    六根起識之用。不出見聞覺知。眼識之用為見。耳識之用為聞。鼻舌身三識之用為覺。意識之用為知。又云識。《智度論·四十》云。何以故。三識所知合為一。三識所知別為三。眼名為見。耳名為聞。意知名為識。鼻舌身識名為覺。答曰。是三識助道法多。是故別說。餘三識不爾。是故合說。是三識但知世間事。是故合為一。餘三亦知世間。亦知出世間。是故別說。

    如來逗眾生機。說此三科法門。各隨根性。任修一法。即能悟入。今此般若真空實相。體非變礙。領納取像。造作、了別等積聚之相。故無五蘊。體非根境能入所入之相。故無十二處。體非根境識了別之相。故無十八界。


第二目 十二因緣

    無無明。亦無無明盡。乃至無老死。亦無老死盡。

    梵語尼陀那。此云因緣。什法師云。力強為因。力弱為緣。肇法師云。前緣相生謂之因。現相助成謂之緣。生法師云。先無其事而從彼生為因。素有其分而從彼起為緣。故因親而緣疏。例如藝榖。種子為因。雨露與農夫之耕種為緣。因緣和合。斯生米榖。故一切法從因緣生。各由自緣。和合無闕。相續而起。故亦名緣起。從因而生。託眾緣轉。本無而有。有已散滅。能潤所潤。墮相續法。故亦名緣生。互相由藉。三世相續。永無間斷。故亦名鉤鎖。
    無無明第一無字。即空義。無明為一名詞。無明至老死。凡十二法。乃至者省文。舉始末以賅餘名。若具說應作無無明。亦無無明盡。無行亦無行盡。無識亦無識盡。無名色亦無名色盡。無六處亦無六處盡。無觸亦無觸盡。無受亦無受盡。無愛亦無愛盡。無取亦無取盡。無有亦無有盡。無生亦無生盡。無老死亦無老死盡。
    【注】《入楞伽經》曰。一切法因緣生。《楞嚴經》曰。彼外道等常說自然。我說因緣。《輔行》云。親生為因。疏助為緣。森羅萬象。必自因與緣而成。因為親因。緣為助緣。二者相合而生結果。謂之因緣合成。是十二法輾轉感果故名因。互相由藉故名緣。

    十二因緣者。無明緣行。行緣識。識緣名色。名色緣六處。六處緣觸。觸緣受。受緣愛。愛緣取。取緣有。有緣生。生緣老死。是為一切有情涉三世而輪迴之因緣。
    【注】三世。亦名三際。世者。遷流之義。際者。隔別之義。一，過去世。謂善惡諸行已起、已生、已轉、已聚集、已出現、落謝、變滅。過去所攝。二，未來世。謂善惡諸行未起、未生、未聚集、未出現。未來所攝。三，現在世。謂善惡諸行現起、現生、現聚集、現出現、未轉、未謝、未滅。現在所攝。
    此十二支生起行相。不了第一義諦。執著於我為無明。不正思唯。起於妄行為行。行熏於心為識。與識（現行）共生（揀現行非種故。名色與識互依。如水與塵。）。四取蘊（識蘊已屬所依識。故五蘊惟四）為名色。名色增長為六處（名增長成意處。色增長成餘五）。根識既顯。則對境為三。是觸。觸必領受。於受染著。是愛。愛增即取。取即起於業種。成有。業熟即起漏蘊為生。蘊熟則老。至壞為死。老非定有。故附死立支。
    無明行為能引支。能引識等五果種故。識名色六處觸受是所引支。是前二支所引發故。愛取有為能生支。近生當來生老死故。生老死為所生支。前三支近所生故。
    此十二支因果離合。各經論依便宜所說不同。前前為因。後後為果。無明惟因。老死惟果。餘望前後。亦因亦果。若顯循環。老死亦因。無明亦果。餘望前後。亦因亦果。又無明、愛、取是本。惟因。生、老死是末。惟果。餘通本末。亦因亦果。又惑因、苦果。業通因、果。又惑、業皆因。惟苦為果。又前十皆因。後二為果。又真心不覺為因。行等十一為果。
    《智度論·五》云。十二因緣。是名甚深法。如佛告阿難。是十二因緣法甚深。難解難知。又云。是中無明、愛、取三事名煩惱。行、有二事名業。餘七分名事。是十二因緣。初二，過去世攝。後二，未來世攝。中八，現前世攝。是略說三事。煩惱、業、苦是三事。展轉更互為因緣。是煩惱，業因緣。業，苦因緣。苦，苦因緣。苦，煩惱因緣。煩惱，業因緣。業，苦因緣。苦，苦因緣。是名展轉更互為因緣。過去世一切煩惱。是名無明。從無明生業。能作世界果故。名為行。從行生垢心。初身因如犢子識母。自相識故。名為識。是識共生無色四陰，及是所住色，是名名色。是名色中生眼等六情，是名六入。情塵識合。是名為觸。從觸生受，受中心著，是名渴愛。渴愛因緣求，是名取。從取後世因緣業，是名有。從有還受後世五眾，是名生。從生五眾熟壞，是名老死。老死生憂、悲、哭、泣種種愁惱，眾苦和合集。若一心觀諸法實相清淨。則無明盡。無明盡。故行盡。乃至眾苦和合集皆盡。是十二因緣相。
    十二因緣以時間分位說。可分四種。一，剎那十二支。謂剎那之頃具十二支。如由貪行殺。貪是無明。思欲行殺是行。了別所殺之人及諸境事是識。與識俱之色想行三蘊是名色。名色是總。六處是別。其所住之法。即是六處。六處是根。合其餘識境而生之心所是觸。領觸之心所是受。貪心是愛。與貪相應之諸煩惱是取。依此所起之身語二業是有。如是諸法之起是生。其法熟變是老。法終滅壞是死。於剎那中已完具十二支。《華嚴經》一念頓具十二。隨事貪欲與心共生是識。（本是真心。與貪相應便名識）。事是行。於行迷惑是無明。（緣）及心（因）共生（相應四蘊）是名色。名色增長為六處。六處三和合是觸。觸共生是受（同時必領納故）。受無厭足是愛。愛攝不舍是取。諸支和合是有。有所起是生。生熟為老。老壞為死。亦即斯意。二，連續十二支。因果無間連續而起也。三，分位十二支。各於其起位而分別之。故十二支各具五蘊。四，遠續十二支。依順後受及不定受業。而前分位之五蘊。隔越多生從無始遠續之因果也。

    無明者。惑也。梵語阿尾你。亦即煩惱。謂過去無始以來煩惱之惑。障覆本性。妄認四大為自身相。六塵緣影為自心相。是為無明。《顯揚論》云。無明者。謂不正了真實為體。或是俱生。或分別起。能障正了為業。緣者。引起之義。因煩惱惑造作諸法。而引起種種善不善業。故曰無明緣行。
    【注】各經論於無明分類。詳略不同。《起信論》分無明為二。一，根本無明。又名無始無明。不了真如原始一念之無明本體。二，枝末無明。因根本無明而起三細六粗之惑業之無明也。《佛說決定義經》分之為三。一，癡無明。謂眾生愚癡闇鈍無所明了。妄執倒見。於正法不能生信也。二，迷無明。謂眾生惑於塵境貪染昏迷也。三，顛無明。於正法起邪見。如常計無常。樂計非樂等。《宗鏡錄》分之為四。一，纏無明。謂由無明之惑纏縛。不能出離生死也。二，隨眠無明。謂無明煩惱。長時隨逐眠伏藏識之中也。三，相應無明。謂意識緣於六塵。識與境相應而起煩惱也。四，獨頭無明。亦名不共無明。謂未有六塵之境相對。意識獨緣想塵。識與境不相應也。《華嚴經疏》亦分為四。一，迷理無明。義通終始。二，發業無明。此在行前。三，覆業無明。此在行後識前。四，受生無明。與識同時（望能生識）或在識後（望過去種子心識）。《百法問答鈔》分之為五。一，相應無明。其義同上。二，不共無明。上之不共無明中。單與意識相應之不共無明也。三，恒行不共無明。上之不共無明中。單與末那識相應之不共無明也。恒時相續不斷。與意識相應之五位有間斷者不同。且與我癡慢三大惑相隨。故為殊別。四，主獨無明。不但不與本惑俱起。即與忿等隨惑亦不相應者。五，非主獨無明。與忿等隨惑俱起之無明也。《大毘婆沙論》分之為十五。一，根本無明。由無始之際。一念不覺。長夜昏迷。不了真理。能生一切諸惑煩惱者。二，枝末無明。心心所法相應而起。即有貪瞋慢疑見等煩惱者。三，共無明。一切結使共相造作一切有漏諸業者。四，不共無明。第七識無別體相。妄起染心。障蔽無漏聖法。恒不間斷者。五，相應無明。謂第七識恒與貪癡見慢四惑相應而起者。六，不相應無明。謂第七識不與餘識外緣粗顯之境相應者。七，迷理無明。謂根本無明障於中道之理不能顯發者。八，迷事無明。謂見思煩惱，障蔽生死之事不能出離者。九，獨頭無明。謂妄覺之心。不緣外境。孤然生起。生已增廣者。十，俱行無明。謂心心所法常相隨逐。曾不舍離者。十一，覆業無明。謂一切結使。覆蔽諸業。恐失名譽利養恭敬。不令人知者。十二，發業無明。謂貪癡我見慢等能發生一切惡業者。十三，種子子時無明。種子者。藏識含藏一切染淨種子。子時者。十二時之首。以喻藏識為諸識之首。染習種子蘊在藏識之中未發顯時也。十四，行業果無明。謂十二因緣中無明、行、愛、取、有五者是業因。識等七者是苦果也。十五，惑無明。謂俱生、分別及根本隨煩惱等惑也。
    根本無明與枝末無明之分甚細。《起信論義記講義》云。根本不覺者。迷真之用。以其為動念之原始故也。枝末不覺者。起妄之差別。即三細六粗也。結末歸本者。明三細（一，業相。從真起妄初動之相。蓋本覺心源。離念寂靜。因無明故。覺成不覺。遂成業相。《起信論》云。以依不覺故心動。說名為業。二，見相。見初動之相也。亦名轉相。依初動業識轉成能見之相也。三，境界相。轉相分別初動之境界也。亦名現相。由前轉相則境界妄現也）六粗（由藏識中初起之三細相而生。一，智相。依三細中第三之境界相。不了自心所現。妄起分別染淨。於淨境則愛。染境則不愛之相。二，相續相。依前智相分別。於愛境則生樂。不愛境則生苦。覺心起念相續不斷之相。三，執取相。依相續相緣念苦樂等境。心起執著之相。四，計名字相。依前妄執分別假立名言之相。五，起業相。依前名字執取生著。造種種業之相。六，業繫苦相。業繫纏縛。生死逼迫之苦相）之九相。盡歸根本無明也。此不了真如法相為能成之緣。故曰根本不覺。三細六粗為其所成。故曰枝末不覺。所謂迷真為根本不覺。起妄為枝末不覺也。
    凡外不明真諦。著於邪見。名見思無明。二乘不明俗諦。著於自利。名塵沙無明。權乘菩薩不明中諦。著於二邊。名根本無明。此台宗所立也。
    《雜集論·四》云。無明有二種業。一，令諸有情於有愚癡。二，與行作緣。令諸有情於有愚癡者。謂由彼所覆於前中後際不如實知故。由此因緣起如是疑。我於過去為有，為無，如是等。與行作緣者。由彼勢力。令後有業。得增長故。按於有愚癡。即能發生一切惡業。似即發業無明。與行作緣。令後有業增長。似即潤生無明。蓋煩惱有分別起（依邪師邪教邪思唯而起）。俱生起（習性自然而起）。意識起此二種煩惱。造善惡業。俱生起之煩惱。潤其業種而使受生。故有潤生無明之名。眾生於臨終時。有三愛。一，境界愛。愛著眷屬家財一切環境。二，自體愛。愛著身體。三，當生愛。愛著當來受生之處。潤生無明。即潤既造之業。使生苦果也。

    行。梵語散娑歌囉。為過去世之煩惱惑。起於身口意三業。造作一切善不善業。遷流於三世也。《成唯識論》。無明所發。乃名為行。意識起諸行時。識於行中生喜住著。故曰行緣識。
    【注】《大乘義章》云。內心涉境。說名為行。《法界次第》云。造作之心。能趣於果名行。《俱舍論》云。造作遷流二義名行。
    《瑜伽論·五十六》云。行有三種。謂身行、語行、意行。當知此中入出息風，名為身行。風為導首。身業轉故。身所作業亦名身行。由愚癡者。先起隨順身業風已。然後方起染污身業。如入出息能起身業。故名身行。如是尋、伺與諸語業。均名語行。受、想與意業。均名意行。又五十三云。行相略有三種。一，善行。二，不善行。三，無記行。又一切行皆造作相。又十云。行望識為三種緣。由能熏發彼種子故。為俱有緣。次後由彼勢力轉故。為無間滅生起緣。由彼當來果得生故。為久遠滅引發緣。
    《雜集論·四》云。行有二種業。一，令諸有情於諸趣中種種差別。二，與識作緣，令諸有情於趣差別者。由業勢力令諸有情趣種異趣故。與識作緣者。由習氣力能使當來名色等生起種子得增長故。

    識。梵語毘惹喃。心對於境之了別也。世俗所謂靈魂。即此神識。識者，心王。真妄和合。由過去世惑業牽引。從行生心。投託母體。一剎那間。染愛為種。結想成胎。分別諸法。是名為識。識但有名。凝滑屬色。故曰識緣名色。
    【注】識其有八。此時初入母胎。六根未生。故此處所云之識乃阿賴耶現行藏識。以過去業行為因。與父母三緣和合而結生。投胎時此識先來。命終時此識後去。識緣名者。謂非色四蘊。識緣色者謂羯羅藍。五蘊初起。六根未生。僅有名色。由阿賴耶識而生起。故云識緣名色。至六根成長以後。則識又依止於名色。《瑜伽論·九》云。此識當續生時。能感生業與異熟果。異熟生。識復依名色相續而轉。謂依眼等六依轉故。由是說言名色緣識。俱生五根。說名為色。無間滅等。說名為名。隨其所應。能與六識作所依止。識依彼故。乃至命終。數數隨轉。《大毘婆娑論·二十三》云。識緣名色。顯識作用。名色緣識。顯名色作用。識為緣故。名色續生。名色為緣。識得安住。故說此二，更互為緣。識緣名色。說初續生時。名色緣識。說續生後位。識緣名色。說續生時識。能生名色。名色緣識。說續生後識。依名色住。識緣名色。說所生名色。名色緣識。說能生名色。識緣名色。依前後說。名色緣識。依同時說。《法蘊足論》云。云何名色緣識。謂眼色為緣生眼識。此中眼及色名為色。即彼所生受想行識名為名。於中作意等能助生眼識。是名名色緣識。乃至意法為緣生意識等皆是。
    《成唯識論·八》云。此中識種。為本識因。又云。集論說識亦是能引。識中業種。名識支故。異熟識種。名色攝故。經說識支通能所引。業種識種。俱名識故。識是名色依。非名色攝故。
    《雜集論·四》云。識有二種業。一，持諸有情所有業縛。二，與名色作緣。持有情業縛者。與行所引習氣俱生滅故。與名色作緣者。由識入母胎。名色得增長故。

    名色。梵語那摩嚕拍。名即是心。心但有名而無形質。色即色質。《大乘義章·四》云。言名色者。心從詮目。故號為名。身形質礙。稱之為色。自神識入胎以後。六根未生以前。中間諸位。總名名色。識自託胎以後。在母腹中第一七日名羯羅藍。此云凝滑。父母不淨和合。凝滑如酪也。第二七日名遏蒲曇。此云如皰。第三七日名蔽尸。此云軟肉。第四七日名羯南。此云堅肉。亦作凝厚。皆名色攝。第五七日名缽羅奢佉。此云形位。亦作肢節。生諸根形四肢差別。自茲以往。漸入具根。故曰名色緣六處。
    【注】《大毘婆娑論·二十三》云。問。此經中說名色緣六處。應不徧說四生有情。謂胎卵濕生。諸根漸起。可說名色緣六處。化生有情。諸根頓起。云何可說名色緣六處。應說此經通說三界四生。謂化生者初受生時。雖具諸根。而未猛利。後漸增長。未猛利時初剎那（剎那為時之極短者。《俱舍論》云。壯士一彈指頃六十五剎那。《仁王經》曰。一念中有九十剎那。一剎那經九百生滅。《日藏》云。一千六百剎那名一迦羅。六十迦羅名模呼律多。三十模呼律多名為一晝夜）頃。名識支。第二剎那以後。名名色支。至猛利位。名六處支。問。六處即在名色中攝。何故說名色緣六處耶。答。未起眼等四色根。名名色位。四根起已。具六處故。名六處位。（受想行識四蘊。皆為心法。無形體可見。但以名而知之。故謂為名。色者色法。為極微所成有質礙之物體。故謂為色。識入母胎。五蘊初具。名名色支。）又云。云何名色。謂結生已。未起眼等四種色根。六處未滿。中間五位。謂羯刺藍，頞部曇，閉尸，建南，缽羅奢佉，是名色位。《瑜伽論·九》云。俱有依根曰色。等無間滅依根曰名。又云。又五色根。若根所依大種。若根處所。若彼能生大種。曰色。所餘曰名。
    藕益大師云。一真法性。惟如如理。及如如智。本無能所之分。由真如不守自性。不覺念起而有無明。遂成能所二妄。一切見分。但有其名。名之為心。一切相分。有質可緣。名之為色。名色二法。不出一真如心。
    《雜集論·四》云。名色有二種業。一，攝諸有情自體。二，與六處作緣。攝有情自體者。由彼生已。得預有情眾同分差別數故。與六處為緣者，由名色等前支為依止。六處等後支得生起故。

    六處即六根。又名六入。處。梵語薩達耶怛那。入。梵語缽羅吠舍。入缽羅奢佉位後。漸入具根。至第六七日。名髮毛爪齒位。第七七日名具根位。六根開張。有入六塵之用。自體圓滿。與觸作緣。故曰六處緣觸。
    【注】《俱舍論》云。眼等已生。至根境識未和合位。得六處名。《大毘婆娑論》云。云何六處。謂已起四色根。六處已滿。即缽羅奢佉位。眼等諸根。未能與觸作所依止。是六處位。
    《雜集論·四》云。六處有二種業。一，攝諸有情自體圓滿。二，與觸作緣。攝諸有情自體圓滿者。由彼生已餘根無缺故。
    《大毘婆沙論·二十三》云。問。此經中說六處緣觸。有餘處說。名色緣觸。餘處復說。二緣生觸。如是三種。有何差別。答。六處緣觸。顯觸所依。謂顯一切外物和合。必因於內。內法勝故。但說所依。故此經說六處緣觸。名色緣觸。顯觸自性。二緣生觸。顯觸所依及所緣別。復次。六處緣觸。說惡趣觸。名色緣觸。說欲界人天觸。二緣生觸。說色、無色界觸。復次。六處緣觸。說分位觸。名色緣觸。說現在觸。二緣生觸。說三和觸。復次。六處緣觸。說觸位觸。名色緣觸。說前位觸。二緣生觸。說後位觸。《法蘊足論·十》云。云何六處緣觸。謂眼及色為緣生眼識。三和合故生觸。乃至意及法為緣生意識。三和合故生觸。是名六處緣觸。復次。眼及色為緣生眼識。三和合故生觸。此中眼為內緣。色為外緣。生眼觸。乃至意及法為緣。生意識。三和合故生觸。此中意為內緣。法為外緣。生意觸。是名六處緣觸。復次。眼及色為緣生眼識。三和合故生觸。此中眼觸以眼、色、眼識為緣。乃至意及法為緣生意識。三和合故生觸。此中意觸以意、法、意識為緣。是名六處緣觸。復次。眼及色為緣生眼識。三和合故生觸。此中眼、色、眼識皆非是觸。由三和合而有觸生。乃至意及法為緣生意識。三和合故生觸。此中意、法、意識皆非是觸。由三和合而有觸生。是名六處緣觸。如是諸觸。六處為緣。六處為依。六處為建立故。起、等起、生、等生、聚集、出現，故名六處緣觸。又云。云何名色緣觸。謂眼及色為緣名眼識。三和合故生觸。此中眼及色名為色。即彼所生受想行識，名為名。如是名色為緣生眼觸。是名名色緣觸。乃至意及法為緣生意識。三和合故生觸。此中諸意識所了色。名為色。即彼所生受想行識，名為名。如是名色為緣生意觸。是名名色緣觸。

    觸。梵語薩婆羅奢。接觸之義。根境識三者和合。分別變異。依根取境。與受所依。故曰觸緣受。
    【注】《成唯識論·三》云。觸為三和。分別變異。令心心所觸境為性。受想思等所依為業。三和合位皆有順生心所功能。說名變異。觸似彼起。故名分別。
    與受所依者。以觸生受。近而勝故。依《起滿經》說。受想行蘊皆以觸為緣。《瑜伽》但說與受想思為所依者。思於行蘊為主勝故。舉此以《俱舍論·九》云。已至三和。未了三受因差別位。總名曰觸。《界身足論·上》云。觸云何。謂觸。等觸。現觸。已觸。當觸。是名觸。《品類足論·一》云。觸云何。謂三和合性。此有三種，謂順樂受觸。順苦受觸。順不苦不樂受觸。
《瑜伽論·十》云。問。若自所逼迫。若他所逼迫。若時候變異。若先業所引。皆得生受。何故此中但顯觸為彼緣。答。觸是彼近因故。由觸所引故。餘緣所生受。亦從觸生故。必不離觸。是故偏說。
    《雜集論·四》云。觸有二種業。一，令諸有情於所受用境界流轉。二，與受作緣。令有情於境流轉者。依此為門受用順樂受等三種境界故。

受。梵語，尾野達喃。領納為義。六塵觸對六根。領納苦、樂、不苦不樂三境。由領納而生貪著。於可愛境結念不捨。故曰受緣愛。
    【注】《成唯識論·三》云。受謂領納順、違、俱非、境相為性。起愛為業。
    《法蘊足論·十》云。云何受緣愛。謂眼及色為緣生眼識。三和合故生觸。觸為緣故生受。受為緣故生愛。乃至意及法為緣生意識。三和合故生觸。觸為緣故生受。受為緣故生愛。是名受緣愛。
    樂受及不苦不樂受，起愛固也。如何苦受亦與愛為緣。須知愛有五種。一，和合愛。二，不和合愛。三，別離愛。四，不別離愛。五，愚愛。樂受未生。起和合愛。已生。起不別離愛。苦受未生。起不和合愛。已生。起別離愛。不苦不樂受未生。起和合愛。已生。起不別離愛。於中多分生長愚愛。見《大毘婆沙論·二十四》。
    《俱舍論·十》云。六受謂眼觸所生受。乃至意觸所生受。六中前五。說為身受。依色根故。意觸所生，說為心受。但依心故。
    《雜集論·四》云。受有二種業。一，令諸有情於所受用生果流轉。二，與愛作緣。令有情於受用生果流轉者。由此為依受用種種可愛等業異熟故。與愛為緣者。希求與此和合等為門諸愛生故。
    六根緣境生識。根、境、識三者和合而生各觸。觸為緣故生受。受為緣故隨順而住。乃生貪念。執藏防護。堅著愛染。是名受緣愛。

    愛。梵語脫利司那。現在自體貪著義。凡諸所有染汙希求皆名為愛。壯年以後。貪欲轉盛。於五塵境廣徧馳求。愛必思得。競致四取。故曰愛緣取。
    【注】《楞嚴經》曰。異見成憎。同想成愛。《大乘義章》云。貪染名愛。故愛有貪著染污之義。
    五塵境。即色聲香味觸。
    《大毘婆沙論·二十九》略云。愛有二種。一，染污。謂貪。二，不染污。謂信。貪皆愛。有愛非貪即信。諸信皆愛。有愛非信。謂染污愛。
    《集異門論·八》云。四取者。一，欲取。二，見取。三，戒禁取。四，我語取。云何欲取。答。除欲界繫諸見，及戒禁取。諸餘欲界繫結縛，隨眠，隨煩惱纏。是名欲取。云何見取。答。謂四見。一，有身見。二，邊執見。三，邪見。四，見取。如是四見。合名見取。云何戒禁取。答。如有一類，於戒執取，謂執此戒。能清淨。能解脫。能出離。能超苦樂。至超苦樂邊。或於禁執取。謂執此禁。能清淨。能解脫。能出離。能超苦樂。至超苦樂邊。或於戒禁俱執取。謂執此戒、禁。俱能清淨。能解脫。能出離。能超苦樂。至超苦樂邊。是名戒禁取。云何我語取。答。除色、無色、界繫諸見、及戒、禁取。諸餘色、無色、界繫結縛、隨眠、隨煩惱纏。是名我語取。《俱舍論·九》略云。從欣受愛。起欲等取。此中欲者。謂五妙欲。見謂六十二見。戒謂遠離惡戒。禁謂狗牛等禁。如諸離繫、及婆羅門、播輸缽多、般利伐羅多迦等異類外道。受持種種露形、拔髮、杖鳥、鹿皮、持髻、塗灰、執三杖、剪鬚髮等無義苦行。我語。謂內身依之說我故。有說我見、我慢，名為我語。由此二種。說有我故。我非有故。說名我語。於前四種。取謂欲貪。諸經中說。云何為取。所謂欲貪。
    《法蘊足論·十》云。云何愛緣取。謂彼初生。說名為愛。愛增盛位。轉名為取。
    《雜集論·四》云。愛有二種業。一，引諸有情流轉生死。二，與取作緣。引諸有情流轉生死者。由彼勢力。生死流轉無斷絕故。與取作緣者。愛味求欲為門。於欲等中貪欲轉故。

    取。梵語鳥拍達那。希求未來染著現在欲貪之義。由欲希求未來自體為方便故。引取當蘊令起現前。由貪染著現在自體能為未來勝方便故，執取現蘊令不捨離。由取為緣，招後有業。故曰取緣有。
    【注】《大毘婆沙論·二十三》云。云何取。謂由三愛（欲愛、色愛、無色愛）。四方追求。雖涉危險。不辭勞倦。未為後有起善惡業，是取位。
    《雜集論·四》云。取有二種業。一，為取後有。令諸有情發有取識。二，與有作緣，為取後有發有取識者。為那落迦趣等差別。後有相續不斷，令業習氣得決定故。與有作緣者。由此勢力。諸行習氣。得轉變故。《瑜伽論·十》云。云何取望有為三種緣。答。由與彼俱。令業能招諸趣果故。為俱有緣。又由彼力於此生處能引識等故。為無間滅生起緣，又能引發彼界功能故。為久遠滅引發緣。

    有。梵語巴哇。馳求諸境。起善惡業。由前際因。生後際果。積集牽引，因果不亡之謂。現在世既依惑造業，未來世即依業受生。故曰有緣生。
    【注】有，有四義。一者。對於無或空而言。此有實有、假有、妙有之別。三世實有者。實有也，因緣依他之法。假有也。圓成實性。妙有也。二者有支。為造可牽當來果之業之位。即因也。三者。果之名。因果不亡之義。四者。生死相續之義。色、無色、界之定及依身。外道執之以為解脫。故遮遣之特謂之有。顯非真滅。上二界之貪謂之有貪。上二界之漏謂之有漏（《涅槃經》。欲界除無明外一切煩惱名欲漏。色無色界除無明外一切煩惱名有漏。三界一切無明名無明漏）即此義。有者。苦果之別名也。此所云者。屬第二義。就因果不亡之義說。諸經論詳略不同。約舉之如左。
    二有。一，實物有。五蘊等法成身。為實有之物也。二，施設有。世間之人。各各隨業受報。因假父母遺體。便即施設而有男女之名也。見《大毘婆沙論》。
    三有。三界之異名也。生死之境界。有因，有果，謂之有。一，欲有。欲界之生死也。二，色有。色界之生死也。三，無色有。無色界之生死也，見《顯識論》。又一，相待有。謂如長、短、彼、此等。實無長短。亦無彼此。以相待故。乃有其名。長因短有。短因長有。彼亦因此。此亦因彼。東西南北。亦皆如是。名相待有。二，假名有。虛假不實。如氈因毛、縷而成。如無毛、縷。氈則何有。是知毛、縷因緣假合。假名為氈。一切眾生四大和合。假名為身。亦復如是。名假名有。三，法有。一切諸法。從因緣生。緣合則成。緣散則滅。本無自性。雖無自性。非如兔角龜毛。有名無實。名曰法有。見《智度論》。
    四有。眾生作業感果。果必由因。因果相酬，則有生死。既有生死，必有色身。既有色身，必經中陰。輪轉不息，則成四有。一，生有。即中有後。本有前。正結生相續時。從中陰身來託母胎。一念識心相續。五蘊由此生起。是名生有。二，本有。即生有後。死有前。中間所有五蘊色身。為業報之本。是名本有。三，死有。本有後。中有前。五蘊色身。一時壞滅。是名死有。四，中有。死有後。生有前。識未託胎之中陰身也。見《俱舍論·九》。又一，中有。二，生有。三，業有。四，死有。見《顯識論》。
    七有。由身口意所作善惡之因。能招六趣生死之果。因果相續。乃生七有。一，地獄有。眾生由過去惡業之因。感現在地獄之果。名地獄有。二，畜生有。眾生由過去愚癡之因。感現在畜生之果。名畜生有。三，餓鬼有。眾生由過去慳吝之因。感現在飢餓之果。名餓鬼有。四，天有。眾生由過去戒定之因。感現在快樂之果。名天有。五，人有。人者。忍也。於違順境能安忍故。眾生由過去戒善之因。感現在人倫之果。名人有。六，業有。亦名行有。以身口意所作善惡業因。招未來善惡業果。名業有。七，中有。亦名中陰。眾生命終以後。識未託胎。現在所作善惡業因。必取當來善惡諸趣之果。名中有。見《長阿含十報法經》。又他毗梨部名有分識有者。以三界為三有。而別立四有。一，中有。二，生有。三，業有。四，死有。通前三有為七有。欲色二界具四有。無色界無中有。四有者。從識支至六歲。是生有。從七歲以上能分別生熟起貪，至未捨命。是業有。死有者。惟一念。中有。即中陰。正辯名為向生處。處者。有因緣名處也。見《顯識論》。與《俱舍論》略異。九有。三界中有情樂住之地處有九。一，欲界之人與六天。二，初禪天。三，二禪天。四，三禪天。五，四禪天。六，空處天。七，識處天。八，無所有處天。九，非想非非想處天。見《俱舍論·八》。
    二十五有。開三界為二十五有。欲界十四。四洲（東弗於逮。西瞿耶尼。南閻浮提。北鬱單越。）。四惡趣（修羅。餓鬼。地獄。畜生）。六欲天（四天王天。忉利天。夜摩天。兜率天。化樂天。他化自在天）。色界七（初禪。二禪。三禪。四禪。及初禪中之大梵。四禪中之無想。及五那含。）。無色界四（空處。識處。無所有處。非想非非想處）。見《輔行記·二》。
    《成唯識論·八》云。愛取合潤能引業種及所引因，轉名為有。俱能近有後有果故。有處惟說業種名有。親生當來識等種故。又云。有支習氣。謂招三界異熟業種。有支有二。一，有漏善。即是能招可愛果業。二，諸不善。即是能招非愛果業。隨二有支所熏成種。令異熟果善惡趣別。
    《俱舍論·九》云。因馳求故。積集能牽當有果業。此位名有。《大毘婆沙論·二十三》云。云何有。謂追求時。亦為後有起善惡業。是有位。
    《雜集論·四》云。有有二種業。一，令諸有情後有現前。二，與生作緣。令後有現前者。能引無間餘趣故。與生作緣者，由此勢力。餘眾同分轉故。
    生者。受生義。梵語仡那。一切有情依過去現在善惡之業，隨業感報。而於六道，四生，中受生也。五蘊初起。故名曰生。於眾同分所有諸行。本無今有為性。色身無常，還歸衰謝。故曰生緣老死。
    【注】六道者。眾生輪迴之道路也。各乘因業而趣。故亦名六趣。一，天。二，人。三，阿修羅。四，地獄。五，餓鬼。六，畜生。
    天道，梵語提婆，又作素洛，光明自然，清淨自在，最勝之義。欲界六天。色界十八天。無色界四天。欲界六天。在欲界最上。以同具情欲，色欲，食欲，婬欲，故名欲界。此六天中。更分為二。一，地居天（依須彌山而住。須彌此云妙高。凡四級。第一級有藥叉神。名堅手天。第二級持鬘天。第三級恒憍天。第四級在山半。即四天王天。山頂則忉利天也。）。二，虛空居天。地居天二。一，四天王天。東為持國天。住須彌山黃金埵。城名上賢。提頭賴吒天王。領乾闥婆、富單那二部。西為廣目天。住須彌山白銀埵。城名周羅。毗留博叉天王。領毗舍闍，毒龍等二部。南為增長天。住須彌山琉璃埵。城名善見。毗留勒叉天王，領鳩盤荼、薜荔多二部。北為多聞天。住須彌山水晶埵。城名天敬。毗沙門天王領夜叉、羅剎等二部。二，忉利天。又名三十三天。住須彌山頂。中為善見城天。都善見城。釋提桓因主之。四方各八天。共為三十三天。其名為善法堂天。住峰天。山頂天。善見城天。缽私陀天。俱吒天。雜殿天。歡喜園天。光明天。波利耶多天。雜險岸天。谷崖岸天。摩尼藏天。旋行天。金殿天。鬘影天。柔軟天。雜莊嚴天。如意天。微細行天。歌音喜樂天。威德輪天。月行天。閻摩那娑羅天。速行天。影照天。智慧行天。眾分天。曼陀羅天。上行天。威德顏天。威德燄輪光天。清淨天。虛空居天四。一，夜摩天。夜摩此云時分。二，兜率天。兜率此云知足。三，須洹蜜陀天。須洹蜜陀此云樂變化。四，婆舍跋提天。婆舍跋提，此云他化自在。他化自在天之上。別有魔羅天宮。波旬所居。亦他化自在天攝。六天婬欲相各不同。四天王天，忉利天，皆以男女形交為婬。夜摩天以相抱為婬。兜率天，以執手為婬。須洹密陀天，以相笑為婬。婆舍跋提天，以相視為婬。雖行婬欲。而無不淨。色界十八天。在欲界之上。已離諸欲。而仍有清淨之色。雖屬化生。仍有色質。既無女形。又無色染。修四靜慮而得之。故又名四靜慮天。修此種禪定所生之色界四天處也。初禪三天。一，梵眾天。二，梵輔天。三，大梵天。初禪以上。不須分段食。故無鼻舌二識。惟就眼耳身意四識。有喜受而與意識相應。有樂受而與三識相應。且有覺、觀（覺與觀為二法。覺，梵語毘怛迦。新譯作尋。觀，梵語毗遮羅。新譯作伺。尋謂尋求。伺謂伺察。粗思名尋，細思名伺。皆為妨定心者。因覺觀之有無。判定心之淺深。初禪及未至定。有覺，有觀。中間禪如大梵天。無覺，有觀。二禪以上。無覺、無觀。）。二禪三天。一，少光天。二，無量光天。三，光音天。又名極光淨天。二禪以上。僅有意識。並無眼耳身三識。故惟有喜舍二受。與意識相應。因意識之怡悅粗大。故是喜受而非樂受。但無覺觀。三禪三天。一，少淨天。二，無量淨天。三，徧淨天。是三天亦僅有意識。有樂、捨二受。與上相應。意識怡悅之相。至極靜妙。故立為樂受。四禪九天。一，福生天。二，福愛天。三，廣果天。此三天為凡夫修證者所住。四，無想天。為外道修證者所住。五，無煩天。六，無熱天。七，善見天。八，善現天。九，色究竟天。自五至九，五天。皆為證不還果之聖者所住。故統名五阿那含天。阿那含者，此云不還。故又名五不還天。惟聖人居。無異生雜。故又名五淨居天。色究竟天。《樓炭經》謂之阿迦尼吒天。華嚴亦作大自在天。梵語摩訶莫醯伊濕伐羅。與欲界第六天之婆舍跋提天不同。色究竟者。色天最勝之處。究竟無邊際也。此十八天。各經亦有小異。薩婆多部以大梵天併入梵輔天。無想天併入廣果天。故為十七天。此據上座部所分。共為十八天。又有合善見善現為一。而另立和音天之名者。《大般若經》。四天王天作四大王眾天。忉利天作三十三天。兜率天作覩史多天。梵輔天下有梵會天。少光天之上有光天。光音天作極光淨天。少淨天之上有淨天。廣果天之上有廣天。少廣天。無量廣天。而無福生天。福愛天。廣果天之下無無想天。善現天在善見天之上。經律異相。婆舍跋提天又名愛身天。無福生天。福愛天。廣果天。而有嚴飾天。少嚴飾天。無量嚴飾天。嚴飾果實天。世界名體志。則以福生天為無雲天。福愛天為福生天。均小異。無色界四天。一，空無邊處天。二，識無邊處天。三，無所有處天。四，非想非非想處天。此天於五蘊中但有受想行識，而無色質。故曰無色界天。
    人道。人者。忍也。於世間違順之情。能堪安忍。又仁也。天地之心。梵語作摩［少／兔］舍喃。各依夙業。分屬贍部洲。毗提訶洲。瞿陀尼洲。拘盧洲。四洲人形俱上立。瞻部洲人面如車箱。毗提訶洲人面如半月。瞿陀尼洲人面如滿月。拘盧洲人面如方池。見《大毘婆沙論》。
    阿修羅道。梵語舊翻無端正。新譯作非天。此神果報最勝。有天之福。無天之德。鄰次諸天而非天也。梵音素洛。此云天。阿此云無彼非天，故名阿素洛。又素洛為端正。彼非端正。名阿素洛。阿素洛在因之時。懷猜忌心。雖行五常。以欲勝他。故作下品十善。感此道身。雖為六道之一。有時亦分為別趣所攝。如《楞嚴經》曰。復有四種阿修羅類。若於鬼道。以護法力。乘通入空。此阿修羅。從卵而生。鬼趣所攝。若於天中。降德貶墜。其所卜居。鄰及日月。此阿修羅。從胎而出。人趣所攝。有修羅王。執持世界。力洞無畏。能與梵王，及天帝釋，四天，爭權。此阿修羅。因變化有。天趣所攝。別有一分下劣修羅。生大海心。沈水穴口。旦遊虛空。暮歸水宿。此阿修羅。因濕氣有。畜生趣攝。《起世經》曰。修羅所居宮殿，城郭，器用。降地居天一等。亦有婚姻男女。法式略如人間。修羅種類。男醜而女端正。
    地獄道又名火塗道。為三惡道之一。在地下鐵圍山間。瞻部洲下。過五百踰繕那。乃有地獄。其量大小不同。其壽延促各異。皆由眾生造極惡業。報盡命終。至此受苦。梵語那落迦。此云惡者。造惡者所生處也。亦云不可樂。亦云苦具。又作泥犁耶。此云無樂。皆地獄之義。其大者曰八大地獄，亦名八熱地獄。此八大地獄。每一獄有四門。每一門有四遊增小獄。四門共成十六。為罪人遊履時增加之獄。共大獄八。遊增小獄一百二十八。是故經說有一百三十六那落迦。《準經律異相》及《諸經要集》所說。十六遊增小獄之名。一，黑砂。二，沸屎。三，鐵釘。四，飢餓。五，渴。六，銅鍑。七，多銅鍑。八，石磨。九，膿血。十，量火。十一，灰河。十二，鐵丸。十三，釿斧。十四，豺狼。十五，劍樹。十六，寒冰。八大地獄者。一，想地獄。亦名等活地獄。其中眾生手生鐵爪。其爪甚利。互相瞋忿。以爪相攫。肉即墮落。或被斫刺磨擦。想為已死。冷風吹之。皮肉還生。尋復活起。名想地獄。二，黑繩地獄。此中獄卒。以熱鐵繩絣牽罪人。然後斬鋸。復有惡風。吹熱鐵繩。籠絡其身。燒皮徹肉。焦骨沸髓。苦毒萬端。名黑繩地獄。三，堆壓地獄。亦名眾合地獄。獄中有大石山。罪人入內。山自然合。堆壓其身。骨肉糜碎。名堆壓地獄。四，叫喚地獄。獄卒以罪人擲大鑊中。沸湯烹煮。受諸痛苦。號咷叫喚。名叫喚地獄。五，大叫喚地獄。沸湯烹已。業風吹活。再向熱鐵鏊中煮熬。痛苦極切。發大叫喚。名大叫喚地獄。六，燒炙地獄。以鐵為城。烈火猛燄。內外燒炙。皮肉糜爛。痛苦萬端。名燒炙地獄。七，大燒炙地獄。以罪人置鐵城中。烈火燒城。內外俱赤。燒炙罪人。又有火坑。火燄熾盛。其坑兩岸。復有火山。捉彼罪人。貫鐵叉上。著於火中。皮肉糜爛。名大燒炙地獄。八，無間地獄。即阿鼻地獄。為地獄之最重者。有罪眾生。至此受苦。無有間歇。故名無間。一者。趣果無間。謂極重罪者。依業受報。無有間歇。二者。受苦無間。受諸痛苦。無有間歇。三者。時無間。受苦時節。無有間歇。四者。命無間。受罪眾生壽命。為一中劫。無有間歇。五者。形無間。受罪眾生。生而復死。死已復生。身形無有間歇。附於阿鼻地獄者。更有十八小地獄。每一小地獄。各有十八寒地獄。十八黑闇地獄。十八小熱地獄。十八刀輪地獄。十八劍輪地獄。十八火車地獄。十八沸屎地獄。十八鑊湯地獄。十八灰河地獄。五百億劍林地獄。五百億刺林地獄。五百億銅柱地獄。五百億鐵機地獄。五百億鐵網地獄。十八鐵窟地獄。十八鐵丸地獄。十八尖石地獄。十八飲銅地獄。如是等眾多地獄。八熱地獄之外。又有八寒地獄。八寒地獄者。一，頞浮陀地獄。頞浮陀。此云皰。謂受罪眾生。因寒苦所逼。皮肉皰起也。二，泥賴浮陀地獄。尼賴浮陀。此云皰裂。謂受罪眾生。因寒苦所逼。皰即析裂也。三，阿吒吒地獄。阿吒吒亦作嚯嚯。謂受罪眾生寒苦增極。唇不能動。唯於舌中作此聲也。四，阿波波地獄。謂受罪眾生。寒苦增極。舌不能動。惟於唇間作此聲也。五，嘔喉地獄。謂受罪眾生。寒苦增極。唇舌均不能動。但於咽喉內振氣而作此聲也。六，鬱波羅地獄。鬱波羅，此云青蓮華。謂受罪眾生。寒苦增極。皮肉開析。似青蓮華也。七，波頭摩地獄。波頭摩，此云紅蓮華。謂受罪眾生。寒苦增極。肉色似紅蓮華也。八，芬陀利地獄。芬陀利，此云白蓮華。謂受罪眾生。寒苦增極，皮肉脫落。骨色如白蓮華也。（見《翻譯名義集》。按《諸經要集·十八》有十寒地獄。《經律異相·四十九》有九寒地獄，數既不同。名亦小異。《涅槃經·十一》。《智度論·十六》。說八種寒冰地獄。名亦不同。）此八寒地獄。與上八熱地獄。皆為根本地獄（八寒亦為根本地獄，準妙玄亦具遊增獄，與八熱地獄同，俱舍圖列熱豎寒橫。故八寒無遊增獄。）。根本地獄外。又有孤獨地獄。又名邊地獄。則在山間，曠野，樹下，空中。或一或多（或云八萬四千）。苦具畢備。隨業受報各各獨受。故曰孤獨地獄，詳見《地藏本願經》。《正法念處經》。《涅槃經》。《顯宗論》。恐繁不引。
    餓鬼道又名刀塗道，三惡道之一。餓鬼。梵語薜荔多。此鬼以前世時。心多妒嫉。慳吝不施。夙因憍慢。廣造十不善業。內無實德。空腹高心。凌人傲物。故受此報。寓氣為質。常困飢虛。因飢虛故。故名為餓。恐怯多畏。故名為鬼。其罪業極重者。歷劫不聞漿水之名。次者但伺求人間蕩滌膿血糞穢。又其次者。時或一飽。眾生由慳貪嫉妒造作惡業。生於此道。此為餓鬼通因。若別別之因。詳見《餓鬼報應經》。《佛說雜藏經》。《佛說鬼問目連經》等。恐繁不引。按餓鬼之名。舊譯特從鬼道中大量觀察。舉其最多者稱之。鬼中亦有勝劣。不皆為餓。故新譯曰鬼。不曰餓鬼。《順正理論·三十一》云。鬼之種類有三。一，無財鬼。二，少財鬼。三，多財鬼。此三又各有三。無財鬼之三者。一，炬口鬼。二，鍼口鬼。三，臭口鬼。少財鬼之三者。一，針毛鬼。其毛如針。以自刺刺他也。二，臭毛鬼。三，癭鬼，多財鬼之三者。一，希祠鬼。常居社廟中。希其食物也。二，希棄鬼。常希人之棄而食之也。三，大勢鬼。大勢大福如天也。《俱舍論·十一》云。或有端嚴。具大威德。受諸富樂。當屬此類。亦有具神通者。無財少財餓鬼之障由外者。如水變為火，為膿血。由內者。自身咽喉如針，如炬，如癭。由飲食者。或成燃燒。或為糞穢。或食自肉。縱得飲食。亦不能噉。《準正法念處經·十六》。餓鬼有三十六種。一，鑊身。二，針口。三，食吐。四，食糞。五，無食。六，食氣。七，食法。八，食水。九，希望。十，食唾。十一，食鬘。十二，食血。十三，食肉。十四，食香。十五，疾行。十六，伺便。十七，地下。十八，神通。十九，熾然。二十，伺嬰兒便。二十一，欲色。二十二，海渚。二十三，閻羅王使執杖。二十四，食小兒。二十五，食人精氣。二十六，羅剎。二十七，火爐燒食。二十八，不淨巷陌。二十九，食風。三十，食火炭。三十一，食毒。三十二，曠野。三十三，住塚間食熱灰土。三十四，樹中住。三十五，四交道。三十六，殺身。其所住略有二種。一者。人中住。二者。住餓鬼世界。在閻浮提下五百由旬。三惡道中之餓鬼道。當然指無財鬼與少財鬼而言。多財鬼則為福德鬼神，屬於八部。
    畜生道又名血塗道。三惡道之一。畜生，梵語底栗車。披毛，帶角，鱗，甲，羽，毛，四足，多足，有足，無足，水，陸，空，行。其類非一。互相吞噉。受苦無窮，《大毘婆沙論》云。畜謂畜養。謂其橫生覆身而行。形旁而行不正，故新譯作傍生。由愚癡故。由諂曲業故。生於此道。
    四生者。胎卵濕化也。依殼而起曰卵生。含藏而出號胎生。假潤而興為濕生。無而忽現名化生。如是四生。由內心思業為因。外殼，胎藏，溼潤，為緣。約藉緣多少而成次第。卵生具四。胎生具三。濕生具二。惟化生僅憑思業。此四生中。人及獸類屬胎生。鳥類水族屬卵生。如蚊如蛭。有水氣之所。生物自行出生者屬溼生。不藉外緣。無所依託。忽然而生者。如往生淨土，諸天，地獄，中有，屬化生。此從一般言也。特例則人亦有出於卵生者。如世羅鄔波世羅。生從鶴卵。鹿母所生三十二子。般遮羅王五百子等。出於溼生者。如曼馱多。遮盧鄔波。遮盧鴿鬘菴羅衛等。出於化生者。如劫初由光音天下降之人。見法苑珠林。鳥及龍類有具四生者。見《起世因本經》。阿修羅有具四生者。見《楞嚴經》。
    生淨土者三品九生。皆屬蓮華化生。其有志意猶豫。雖修善業。信力不堅者。則生邊地。五百歲不得見佛。亦名胎生。但仍係蓮華化生，並非胎育。見《大阿彌陀經》。
    《雜集論·二》云。生者。謂於眾同分諸行本無今有性。假立為生。問。外諸色等亦有生相。何故惟舉眾同分耶。答。為於有情相續，建立有為相故。所以者何。外諸色等有為相，成壞所顯。內諸行有為相，生老等所顯故。又四云。生有二種業。一，令諸有情名色，六處，觸，受，次第生起。二，與老死作緣。令名色等次第生起者。能引後後位差別故。與老死作緣者。由有此生，彼相續變壞，皆得有故。
    《法蘊足論·五》云。云何生。謂彼諸有情類即於彼彼有情聚中諸生，等生，趣入，出現，蘊得，界得，處得，諸蘊生，命根起，總名為生。《瑜伽論·十》云。生云何。謂於胎卵二生初託生時。等生云何。謂即於彼身分圓滿。仍未出時。趣云何。謂從彼出。起云何。謂出巳增長（界趣生等品類差別自體出現。說名為生。若無差別。後有相續。說名為起）。出現云何。謂於溼化二生身分頓起。蘊得云何。謂即於彼諸生位中五取蘊轉。界得云何。謂即彼諸蘊因緣所攝性。處得云何。謂即彼諸蘊餘緣所攝性。諸蘊生起云何。謂即彼諸蘊日日飲食之所資長。命根出現云何。謂即彼諸蘊餘壽力故。得相續住。又九云。生差別者。當知復有五種。一，界差別。二，趣差別。三，處所差別。四，勝生差別。五，自身世間差別。界差別者。謂欲界及色無色界生差別。趣差別者。謂於五趣四生差別。處所差別者。謂欲界中有三十六處生差別。色界中有十八處生差別。無色界中有四處生差別。如是總有五十八生。勝生差別者。謂欲界人中有三勝生。一，黑勝生生。謂如有一生旃荼羅（屠膾）家。若卜羯娑（除糞擔屍）家。若造車家。若竹作家。若生所餘下賤貧窮乏少財物飲食等家。如是名為人中薄福德者。二，白勝生生。謂如有一生剎帝利大富貴家。若婆羅門大富貴家。若諸長者大富貴家。若生所餘豪貴大富多諸財穀庫藏等家。如是名為人中勝福德者。三，非黑非白勝生生。謂如有一非前二種生處中家者。又欲界天中亦有三種勝生。一，非天生。二，依地分生。三，依虛空宮殿生。又色界中有三種勝生。一，異生無想天生。二，有想天生。三，淨居天生。又無色界中有三勝生。一，無量想天生。二，無所有想天生。三，非想非非想天生。自身世間差別者。謂於十方無量世界中。有無量有情。無量生差別。

    老。梵語歌囉。一切有情於眾同分諸行相續變異性。後起諸行。與前差別。衰退闇鈍。根熟變壞。說名為老。死。梵語摩刺喃一切有情。於眾同分移轉壞沒。退失別離。壽煖識滅。命根不轉。諸蘊破壞。說名為死。
    【注】《成唯識論·八》云。諸衰變位。總名為老。身壞命終。乃名為死。老非定有。附死立支。又云。老雖不定。徧故立支。諸界趣生。除中夭者。將終皆有衰朽行故。
    《俱舍論·五》云。命根體即壽。能持煖及識。何法名壽。謂有別法能持煖識。說明為壽。故世尊言。壽煖及與識。三法（阿賴耶識相分色法身根所得名煖。此識之種名壽。以能持識故。現行識名識。故云三法）。捨身時。所捨身僵仆。如木無思覺。又云。何法說名壽體。謂三界業所引同分住時勢分。說名壽體。《雜集論·二》云。命根者。謂於眾同分先業所感住時決定。假立壽命。眾同分者。於一生中諸蘊相續。住時決定者。齊爾所時。令眾同分常得安住。或經百年。或千年等。由業所引功能差別。
    《瑜伽論·八十四》云。死者其識棄捨心胸處故。《發智論·二》云。彼彼有情。從彼彼有情眾同分移轉壞沒。捨壽煖命根。滅棄諸蘊。身殞喪。是謂死。
    《雜集論·四》云。老死有二種業。一，數令有情時分變異。壞少盛故。二，數令有情壽命變異。壞壽命故。

    此十二支法。輾轉感果。因緣相續。循環無際。如輪迴轉。由過去世之無明（惑）與行（業）為因。感現在世之識名色六處觸受之五果（苦）。是過去與現在一重因果。復從現在果起愛，取（惑），有（業），三支惑業。成現在因。感未來世生、老死之二果（苦）。是現在與未來一重因果。兩重因果。通貫過去現在未來三世。現在之惑（愛取）業（有）既由現在之苦果（識名色六處觸受）而生。則過去之惑（無明）業（行）自亦由過去之苦果（生老死）而生。現在之苦果（識，名色，六處，觸，受）生現在之惑業。未來之苦果（生，老死）自亦生未來之惑業。上溯之則過去之惑業更從過去之苦果而來。下推之則未來之苦果更生未來之惑業。由因生果。果又成緣。過去無始。未來無終。無明、愛、取三支是惑為緣。行、有二支是業為因。識、名色、六處、觸、受、生、老死七支是苦為果。生死輪迴。流轉不息。總不出惑、業、苦之三道。是為生相順觀。亦名染緣起。是凡夫法。屬流轉門。緣生性空。空本無生。故曰。無無明乃至無老死
    【注】染緣起者。清涼云。無明緣行等。前能生後。生死流轉為染。無明緣行者。是觀過去。識乃至愛。是觀現在。愛乃至有。是觀未來。於是以後。展轉相續。
    《俱舍論·九》。頌曰。如是諸緣起。十二支三際。前後際各二。中八據圓滿。論曰。十二支者。一，無明。二，行。三，識。四，名色。五，六處。六，觸。七，受。八，愛。九，取。十，有。十一，生。十二，老死。言三際者。一，前際。二，後際。三，中際。即是過、未及現三生。云何十二支於三際建立。謂前後際各立二支。中際八支。故成十二。無明、行在前際。生、老死在後際。所餘八在中際。此中際八。一切有情。此一生中。皆具有不。非皆具有。若爾。何故說有八支據圓滿者。此中意說。補特伽羅歷一切位名圓滿者。非諸中天及色、無色。又云。有時但說二分緣起。一，前際攝。二，後際攝。前七支前際攝。謂無明乃至受。後五支後際攝。謂愛至老死。前後因果。二分攝故。

    若在緣覺。悟此諸法因緣。無明滅則行滅。行滅則識滅。識滅則名色滅。名色滅則六處滅。六處滅則觸滅。觸滅則受滅。受滅則愛滅。愛滅則取滅。取滅則有滅。有滅則生滅。生滅則老死滅。以還歸於寂滅之涅槃。所謂若了無明。生死自息。是為滅相逆觀。亦名淨緣起。是緣覺法。名還滅門。以真空故。盡無可盡。故云。亦無無明盡。乃至亦無老死盡。諸法從本來。常自寂滅相。故無可盡也。
    【注】流轉門對於還滅門而言。生觀順觀屬流轉門。生觀者觀緣無明生行，緣行生識，乃至緣生生老死，次第生起之相。順觀者。順生死觀。觀有漏業之行、有兩支為因。無明、愛、取三支為緣。感識乃至老死等七支苦果之相也。流轉門者。無始之無明。不達本覺之理性。起惑造業感生死之苦果。以流轉三界六道也。還滅門者。流轉之眾生。厭生死之苦。修戒定慧三學。以還歸於寂滅之涅槃也。滅觀逆觀屬之。滅觀者。觀無明滅則行滅，乃至生滅則老死滅，次第滅壞之相也。逆觀者。逆生死觀。觀無漏之正慧為因。正行為緣。證涅槃果之相也。
    淨緣起者。清涼云。反本還源為清淨也。

    《大般若經》曰。若菩薩摩訶薩。發一切智智相應之心。以無所得為方便。思惟無明緣行。行緣識。識緣名色。名色緣六處。六處緣觸。觸緣受。受緣愛。愛緣取。取緣有。有緣生。生緣老死。乃至純大苦蘊集。以無所得為方便。思惟無明滅故行滅。行滅故識滅。識滅故名色滅。名色滅故六處滅。六處滅故觸滅。觸滅故受滅。受滅故愛滅。愛滅故取滅。取滅故有滅。有滅故生滅。生滅故老死乃至純大苦蘊滅。憍尸迦。是謂菩薩摩訶薩般若波羅蜜多。蓋菩薩以般若觀慧。照了無明諸法。體性皆空。無生滅相。故云。無無明亦無無明盡。乃至無老死。亦無老死盡。言無無明。是舉流轉初相空。言無無明盡。是舉還滅初相空。言無老死。是舉流轉末相空。言無老死盡。是舉還滅末相空。乃至者。略去中間十支。舉始末以賅其餘也。無無明。無行。無識。無名色。無六處。無觸。無受。無愛。無取。無有。無生。無老死。是生相。以緣生性空故。無明盡。行盡。識盡。名色盡。六處盡。觸盡。受盡。愛盡。取盡。有盡。生盡。老死盡。是滅相。以無生真空故。經言無無明乃至無老死。無無明盡乃至無老死盡。蓋顯般若真空。既無流轉相。亦無還滅相。故無十二因緣。此不僅破眾生我執之見。亦除二乘法執之病。《楞嚴經》曰。真性有為空。緣生故如幻。無為無起滅。不實如空華。無為有為。同一幻相故。
    【注】憍尸迦為帝釋本姓。釋提桓因為人時。在摩訶陀國為婆羅門。名摩伽。姓憍尸迦。見《智度論》。
    《因果經》曰。爾時菩薩至第三夜。觀眾生性。以何因緣而有老死。即知老死以生為本。若離於生。則無老死。又復此生不從天生。不從自生。非無緣生。從因緣生。因於欲有、色有、無色有，業生。又觀三有業從何而生。即知三有業從四取生。又觀四取從何而生。即知四取從愛而生。又復觀愛從何而生。即便知愛從受而生。又復觀受從何而生。即便知受從觸而生。又復觀觸從何而生。即便知觸從六入生。又觀六入從何而生。即知六入從名色生。又觀名色從何而生。即知名色從識而生。又復觀識從何而生。即便知識從行而生。又復觀行從何而生。即便知行從無明生。若滅無明則行滅。行滅則識滅。識滅則名色滅。名色滅則六入滅。六入滅則觸滅。觸滅則受滅。受滅則愛滅。愛滅則取滅。取滅則有滅。有滅則生滅。生滅則老死憂悲苦惱滅。如是逆順觀十二因緣。第三夜分。破於無明。明星出時。得智慧光。斷於習障。成一切種智。
    十二因緣不出惑業苦三。業種自然。如惡叉聚（西域有樹。結果三為一聚。喻惑業苦三。不相離也）。《緣生論》云。初、八、九煩惱。第二、第十業。餘七皆是苦。三攝十二法。初二是過去。後二未來時。餘八是現在。此謂三時法。惱起業感報。報還生煩惱。煩惱復生業。亦由業有報。離惱何有業。業壞亦無報。無報則離惱。此三各自滅（初，無明。八，愛。九，取。是三煩惱，即惑。二，行。十，有。是業。餘七，識。名色。六處。觸。受。生。老死。是苦。此十二法三種所攝。初，無明。二，行。是過去時。十一，生。十二，老死。是未來時。識、名色、六處、觸、受、愛、取有八種。是現在時。又此等各各次第相生。由煩惱故有業。由業故有報。還由報故有煩惱。由煩惱故有業。由業故有報。若此心無煩惱。則不集業。若不作業。則不受報。若滅報。則亦不生煩惱。如是此三各各自滅）。《十二因緣論》云。因緣所生法。彼為三所攝。煩惱業及苦。次說應當知。煩惱初八九。業二及以十。餘七說為苦。三攝十二法。從三故生二。從二故生七。從七復生三。是故如輪轉（初為無明。八愛。九取。此三是煩惱所攝。二為行。十為有。此二是業所攝。餘七是苦所攝。從三生二。三是煩惱。二是業。謂從煩惱而生於業。從二生七。七者是苦。謂從於業而生於苦。從七生三者。謂從於苦而生煩惱。此說煩惱業苦三種迭互相生。是故生有輪轉不定。所言有者。所謂欲、色、無色、界等。彼中不住。喻如輪轉）。
    《四品法門經》曰。佛告阿難。智者應知。十二緣法。從因緣起。由因緣故。即有諸法。因緣者何。所謂無明緣行。行緣識。識緣名色。名色緣六處。六處緣觸。觸緣受。受緣愛。愛緣取。取緣有。有緣生。生緣老死憂悲苦惱。如是即一大苦蘊集。若了知緣生之法。因緣性空。緣聚即有。緣散即無。緣法無故。即無諸法。所謂無明滅即行滅。行滅即識滅。識滅即名色滅。名色滅即六處滅。六處滅即觸滅。觸滅即受滅。受滅即愛滅。愛滅即取滅。取滅即有滅。有滅即生滅。生滅即老死憂悲苦惱滅。如是即一大苦蘊滅。如是生滅之法。智者應當如實了達。《大乘舍黎娑擔摩經》。慈氏菩薩告舍利子。十二緣生。所謂無明緣行。行緣識。識緣名色。名色緣六處。六處緣觸。觸緣受。受緣愛。愛緣取。取緣有。有緣生。生緣老死憂悲苦惱。如是生者。即一大苦蘊生。彼無明滅即行滅。行滅即識滅。識滅即名色滅。名色滅即六入滅。六入滅即觸滅。觸滅即受滅。受滅即愛滅。愛滅即取滅。取滅即有滅。有滅即生滅。生滅即老死憂悲苦惱滅。如是滅即一大苦蘊滅。《智度論·五》云。十二因緣生法種種法門。能巧說煩惱業事次第展轉相續生。是名十二因緣。是中無明愛取三事為煩惱。行有二事名業。餘七分名事。是十二因緣。初二，過去世攝。後二，未來世攝。中八，現前世攝。是略說三事煩惱業苦。是三事展轉。更互為因緣。


第三目 四諦

    無苦。集。滅。道。

    諦有審、實二義。審就智言。菩薩大智。詳審無妄。實就境言。世。出世間。因果。決定真實。云四諦者。苦集滅道。前二諦是世間因果。令知苦以斷集。後二諦是出世間因果。使為滅以修道。集為迷之果。道為悟之因。滅為悟之果。所以先果而後因者。果易見而因難知。故先示苦令其厭。然後使斷其因。又示涅槃妙果使之樂。然後使修其道。是為誘引小乘初機之說法方便。但其理則通於大小乘一切佛法。台宗依《涅槃經》所說。立四種四諦，以配藏、通、別、圓四教。本經所說。為生滅四諦。屬藏教攝。聲聞乘所修之法也。聲聞以析空觀諦審苦集滅道之法。破見思煩惱。證真諦理。既無苦集。何有滅道。四諦皆空。故云無也。
    【注】四諦。《涅槃經》亦作四聖諦。四真諦。聖者。正也。真者。實也。惟諸聖者如實了知。故名聖諦。名真諦。
    四諦有三轉。一，示相轉。此是苦。逼迫性。此是集。招感性。此是滅。可證性。此是道。可修性。二，勸修轉。此是苦。汝應知。此是集。汝應斷。此是滅。汝應證。此是道。汝應修。三，作證轉。此是苦。我已知。此是集。我已斷。此是滅。我已證。此是道。我已修。苦集滅道四諦。各有四行相。即以智力向苦諦作無常（世間諸法，緣聚則生，緣盡則滅）、苦（於身心皆逼惱性）、空（謂無可為我之所有）、無我（無常。一主宰之義）之觀，是為苦諦四行相。向集諦作因（惑業能生苦果。如種生芽）、集（惑業積集成苦。如隱而現）、生（使苦果相續。生生不絕）、緣（助成苦果。如水土之滋潤植物）之觀，是為集諦四行相。向滅諦作滅（斷盡五蘊）、靜（止息三毒）、妙（無一切過患）、離（解脫諸災難）之觀，是為滅諦四行相。向道諦作道（聖賢踐履）、如（契於正理）、行（進趨涅槃）、出（超出生死）之觀，是為道諦四行相。共十六行相。如是觀成。即證煖位。
    聲聞觀四諦而生之八忍八智。謂之無漏十六心。凡斷一惑。必經無間、解脫二道。無間道有八忍。苦諦苦法智忍為第一心。苦類智忍為第三心。集諦集法智忍為第五心。集類智忍為第七心。滅諦滅法智忍為第九心。滅類智忍為第十一心。道諦道法智忍為第十三心。道類智忍為第十五心。解脫道有八智。苦諦苦法智為第二心。苦類智為第四心。集諦集法智為第六心。集類智為第八心。滅諦滅法智為第十心。滅類智為第十二心。道諦道法智為第十四心。道類智為第十六心。前十五心屬見道位。第十六心屬修道位。
    析空觀者。析即分析。謂分析五蘊十二處十八界。析色至於極微，析心至於一念之觀。小乘之觀法也。與大乘菩薩直觀諸法如幻如夢，即體顯空之體空觀不同。
    《文句》云。苦諦。謂二十五有依正二報也。集諦。謂見思惑也。滅諦。謂滅前苦集。顯偏真理。因滅會真。滅非真諦也。道諦。謂戒定慧也。《會要》云。逼迫名苦。增長名集。寂靜名滅。出離名道。清涼云。逼迫名苦。即有漏色心。增長名集。即業煩惱。寂靜名滅。謂即涅槃。出離名道。謂止觀等（等者。等取八正道等）。
    《瑜伽論·六十四》云。云何苦諦。謂生苦等。一切生雜染事皆名苦諦。云何集諦。謂說一切煩惱雜染及業雜染（能生後有諸行業及煩惱）。皆名集諦。云何滅諦。所謂一切煩惱永斷。云何道諦。謂資糧道、若方便道、若清淨道，如是一切總略為一。說名道諦。

    云何生滅四諦。謂因緣生法。有生有滅。一，苦諦。苦，梵語豆佉。以逼迫為義。一切有為心行。常為無常患累之所逼惱。受三界六道生死苦果。是名苦諦。二，集諦。集，梵語三牟提耶。以招聚為義。心與結業相應。以貪瞋癡等煩惱及善惡諸業。招聚未來三界六道生死苦果。是名集諦。為苦諦因。三，滅諦。滅，梵語尼樓陀。以寂滅為義。結業既盡。則無生死之患累。以諸煩惱結使滅故。三界業亦滅。即是滅諦有餘涅槃。因滅故果滅。捨此報身時。後世苦果。永不相續。名入無餘涅槃。諦審涅槃。實為寂滅。是名滅諦。四，道諦。道，梵語末迦。以能通為義。通涅槃之道路也。聲聞諦審戒定慧之道。能到涅槃。是名道諦。為滅諦因。道從泛義說。有正有助。正道為三十七道品。三解脫門。緣理慧行。助道為得解觀中諸對治法及諸禪定等。
    【注】四種四諦。一，生滅四諦。藏教所攝。如上所詮。二，無生四諦。通教所攝。謂三乘利根者。用體空觀（直觀法體如幻如夢。即體顯空之觀）。體達五蘊諸苦。當體即空。如幻如化。無逼迫相。是名苦諦。審實惑業之因。當體即空。無和合相。是名集諦。審實五蘊生死等苦。昔本無生。今亦無滅。是名滅諦。審實所破之集。能破之道。同一真空。無有二相。是名道諦。三，無量四諦。別教所攝。菩薩諦觀十法界果報不同。眾生生死諸苦。一一不虛。故云。苦有無量相。諦觀十法界眾生五住惑業。種種不同。實能招聚生死之苦。故云。集有無量相。諦觀六波羅蜜種種不同。能證涅槃寂滅之理。故云。滅有無量相。諦觀恒河沙法門。自利利他。故云。道有無量相。四，無作四諦。圓教所攝。大乘菩薩圓觀諸法。事事即理。無有造作。故云蘊（五蘊）處（六處）皆如（真如）。無苦可捨。是為苦諦。塵勞本清淨。煩惱即菩提。無招集生死之相。是為集諦。諦觀一切中道。離邊邪見。無煩惱之惑可斷。亦無菩提之道可修。是為道諦。生死涅槃。體元不二。無生死逼迫之苦可斷。亦無涅槃寂滅之樂可證。是為滅諦。
    六根為因。六塵為緣。根塵相對所起之心。謂之因緣生法。
    集諦為苦諦因者。因煩惱惑業等所集之集因（《雜集論》謂之因相，由業煩惱，是引發後有習氣之因故）、集集（《雜集論》謂之集相，謂彼彼有情所集習氣，於彼彼有情類為等起因，於人天等有情類中能為相似形貌種類平等起因故）、集生（《雜集論》謂之生相，謂諸有情各別內身相續決定趣生地等，所有一切品類差別，乃至有頂生因故）、集緣（《雜集論》謂之緣相，謂諸有情別別得捨之因，即得未曾得自體，捨已曾得自體故）為因。而生苦果。欲滅苦果。當滅苦因。故集諦滅則苦諦不生。
    滅諦以無我對治集諦煩惱。蓋一切煩惱結使。皆由我執而生。故無我為滅諦之體相。
    三十七道品者。第一。四念住（亦作四念處）。念即是觀。住即是境。一，身念住（雖於內身、外身、內外身住循身觀。不起身俱尋思。若為對治凡夫淨顛倒。以不淨為淨。則曰觀身不淨）。二，受念住（雖於內受、外受、內外受住循受觀。不起受俱尋思。若為對治凡夫樂顛倒。於苦計樂。則曰觀受是苦）。三，心念住（雖於內心、外心、內外心住循心觀。不起心俱尋思。若為對治凡夫常顛倒。於無常計常。則曰觀心無常）。四，法念住（雖於內法外法內外法住循法觀。不起法俱尋思。若為對治凡夫我顛倒。於無我計我。則曰觀法無我）。第二。四正斷（亦作四正勤）。發起正勤。策心持心。一，律儀斷。已生惡令永斷。二，斷斷。未生惡令不生。三，修斷。已生善法令增長。四，防護斷。未生善法令生。第三。四神足（亦作四如意足）。一，欲三摩地。二，勤三摩地。三，心三摩地。四，觀三摩地。修此四三摩地斷行成就神足（依離。依無染。依滅迴向捨）。第四。五根。一，信根。二，精進根。三，念根。四，定根。五，慧根。第五。五力。一，信力。二，精進力。三，念力。四，定力。五，慧力。第六。七等覺支（亦作七覺分）。一，念等覺支。二，擇法等覺支。三，精進等覺支。四，喜等覺支。五，輕安等覺支。六，定等覺支。七，捨等覺支（依離。依無染。依滅迴向捨。第七。八聖道支（亦作八正道）。一，正見。見四諦之理而明之。以無漏之慧為體。二，正思唯。見四諦之理而使真理增長。以無漏之心所為體。三，正語。以真智修口業。不作一切非理之語。以無漏之戒為體。四，正業。以真智除一切邪業。住於清淨之身業也。以無漏之戒為體。五，正命。清淨身口意三業。離五種之邪命（比丘行不如法事而為生活。一，詐現異相以求利養。二，自說功能以求利養。三，占相吉凶以求利養。四，大言現威以求利養。五，說利動人以求利養。謂之五邪命）。以無漏之戒為體。六，正精進。以真智勤修涅槃之道。以無漏之勤為體。七，正念。以真智憶念正道而無邪念。以無漏之念為體。八，正定。以真智入於無漏清淨禪定。以無漏之定為體（依離。依無染。依滅迴向捨）。以上七門。是為三十七菩提分法。
    三解脫門。一，空。二，無相。三，無願。
    緣理。即觀念真理之意。
    慧行。即般若波羅蜜之三行。六度萬行中之正行。
    得解觀中諸對治法。一，厭患對治。二，斷對治。三，持對治。四，遠分對治。厭患對治。謂加行道。在見道以前。緣苦集二諦生深為厭患之念也。斷對治。謂無間道。於無間道緣四諦而正斷煩惱也。持對治。謂解脫道。於無間道後起解脫道。更緣四諦攝持彼無間道所得擇滅之得。以使所斷煩惱不更起也。遠分對治。謂勝進道。於解脫道後入於勝進道。更緣四諦所斷之惑轉更遠也。
    禪定有八。初靜慮。第二靜慮。第三靜慮。第四靜慮。空處。識處。無所有處。非想非非想處。
    《瑜伽論·二十七》云。云何苦聖諦。謂生苦。老苦。病苦。死苦。怨憎會苦。愛別離苦。求不得苦。略說一切五取蘊苦。名苦聖諦。云何集聖諦。謂若愛。若後有愛。若喜貪俱行愛。若彼彼喜樂愛等。名集聖諦。云何滅聖諦。謂即此愛等無餘斷滅。名滅聖諦。云何道聖諦。謂八支等聖道。名道聖諦。《大毘婆沙論·七十七》云。逼迫是苦相。生長是集相。寂靜是滅相。出離是道相。又云。流轉是苦相。能轉是集相。止息是滅相。還滅是道相。又云。生依流轉是苦相。能轉生依是集相。生依止息是滅相。能滅生依是道相。

    此四諦法。如以藥病喻。苦集二諦。是世間因果。屬流轉門為病。滅道二諦。是出世間因果。屬還滅門為藥。凡夫二乘。不知三界如幻如化。本自無生。性相寂滅。生死涅槃。猶如昨夢。而於無生法中。妄見生滅。橫受輪迴。譬如陽燄非水。妄作水想。徒自疲勞。如來令彼知苦，斷集，慕滅，修道，永息苦本。聲聞之人。躭寂滅樂。以為實證菩薩修般若觀。見真空理。五蘊諸法。當體即空。無生滅修證之法。故生死即涅槃。煩惱即菩提。無苦可捨。無集可斷。無滅可慕。無道可修。以生滅，修證，自性空故。故曰無苦集滅道。


第四目 智得

    無智。亦無得。

    無者。空也。否定事物存在之辭。智。梵語若那。於事理決斷之義。知一切法之總相者為一切智。總相即空相。聲聞辟支佛之智也。知種種差別之道法者為道相智。菩薩智也。知總相別相。化道斷惑。一切三世法中諸法實相大小精麤，無事不知，以名相、文字、言說通達無礙者。名一切相智。佛智也。《止觀》云。佛智照空。如二乘所見。名一切智。佛智照假。如菩薩所見。名道種智。佛智照空假中。皆見實相。名一切種智。故言三智一心中得。
    得。梵語缽羅缽多。為二十四不相應行之一。於一切法造作成就也。
    【注】大小乘經分智之種類甚多。約舉如下。
    一智。即阿耨多羅三藐三菩提。見《智度論·八十五》。
    二智。有七種。一，如理智與如量智。諸佛菩薩以如實之智。徹見實際之理。妙極寂靜。名如理智。諸佛菩薩究竟通達一切境界。若見眾生乖於理智。則成生死。稱於理智。則得涅槃。是名如量智。二，觀察智與取相智。以智慧照了人法二空所顯真如之理。了知能證所證二俱不可得。名觀察智。善取法界之相。若事若理。以智慧照了。悉使法法圓融。事理無礙。名取相智。見《華嚴經隨疏演義鈔》。三，根本智與後得智。根本智亦名無分別智。此智不依於心。不緣外境。了一切法皆即真如。境智無異。如人閉目。外無分別。由此無分別智。能生種種分別。名根本智。依止於心。緣於外境種種分別。境智有異。如人開目。眾色顯現。以於根本智後所得。名後得智。見《攝大乘論》。四，盡智與無生智。阿羅漢斷三界見思惑竟。即知我生已盡。梵行清淨。名盡智。阿羅漢斷三界見思惑竟。知諸縛已解。更不於三界受生。名無生智。見《大集經》。五，一切智與道種智。一切內法內名。外法外名。能知能解。名一切智。即聲聞緣覺之智也。能用諸佛一切道法。發起眾生一切善種。名道種智。即菩薩之智也。見《觀音玄義》。六，真智與俗智。照了真諦理性之智曰真智。照了俗諦事相之智曰俗智。見《攝大乘論》。七，實智與權智。達於佛菩薩實理之智曰實智。通於佛菩薩權宜方便之智曰權智。又名方便智。見《維摩詰經會疏》。上開分別。隨方便說。名異實同。如如理智，與根本智，真智。皆同一義也。
    三智。一，真智。體解無物。本來寂靜。通達無涯。淨穢不二。故名真智。二，內智。自覺無明。割斷煩惱。心意寂靜。滅無有餘。此名內智。三，外智。分別根門。識了塵境。博覽古今。皆通俗事。此名外智。見《宗鏡錄·十五》。又一，世間智。凡夫外道於一切法執著分別。不能出離世間。名世間智。二，出世間智。聲聞。緣覺。以一切智。修四諦行。而能出離世間。名出世間智。三，出世間上上智。佛菩薩觀察一切諸法寂靜之相。不生不滅。得如來地。超出聲聞、緣覺之智也。見《楞伽經》。又一切智，道種智，一切種智，亦稱三智。見《智度論》。《凖瑜伽論》。於一切界（一，世界。二，有情界）。一切事（一，有為。二，無為）。一切品（即有為、無為二事無量品別。名一切品。謂自相輾轉種類差別故。共相差別故。因果差別故。界趣差別故。善不善無記等差別故）。一切時（一，過去。二，未來。三，現在）。智無礙轉。如實知故。名一切智。於一切法中無顛倒智。是名如來一切種智。《觀音玄義》云。能用諸佛一切道法。發起眾生一切道種者名道種智。
    無分別智有三種。一，加行無分別智。約因而差別之有三。謂因緣，引發，數習，生差別故（因緣者，種性為因而得生故。引發者，由前生數習為因而得生故。數習者，由現在生士用力為因而得生故）。二，根本無分別智。約人而差別之有三。謂喜足，無顛倒，無戲論，無分別，差別故（菩薩住異生地。知已到聞思究竟。便生喜足。諸有情計上生第一有，見為涅槃。便生喜足。名喜足無分別智。聲聞等知彼等通達真如。得無常等四無倒智。無常等四顛倒分別。名無顛倒無分別智。諸菩薩知菩薩於一切法乃至菩提皆無戲論，不可以言說宣示故。名無戲論無分別智）。三，後得無分別智。
四智。唯識宗所立。凡夫八識。如來轉成四智。一，轉第八識為大圓鏡智。有漏之第八識。變依正二報。而持有情之身。此智變如來之身土。而持一切之功德。名大圓鏡智。緣境無邊。照法界之事理。故又名一切種智。二，轉第七識為平等性智。反於第七識之我見。而達無我平等之理。於一切眾生起無緣大悲之智也。三，轉第六識為妙觀察智。觀察諸法之相。而施說法斷疑之用之智也。四，轉眼耳鼻舌身五識為成所作智。為利一切凡夫二乘。示現種種變化神通之智也。如來之現化身土及諸神通皆此智作用。見《唯識論·十》。此宗為破實我實法之所執。顯示心外無有實境。更立菩薩所觀四智。第一。相違識相智。同一處所。人，天，餓鬼所見。各隨業力而殊，境若實有。何能隨業而變。第二。無所緣識智。緣於過去，未來，夢幻非實之境時。境非實有。而心能現相。可徵一切境界。皆心所變。第三。自應無倒智。境若為實。則一切凡夫本來證悟心外之境。應不假功用。自然成就。今則不然。可徵境非實有。第四。隨三智轉智。一，隨自在者智轉智。已證得心自在者。依定力變土木為金寶。境若實有。何能隨心轉變。二，隨觀察者智轉智。得勝定而修觀者。觀一境而青瘀等相。隨心顯現。境若實有。何能隨心轉變。三，隨無分別智轉智。證得無分別智。一切境相皆不現前。境若實有。何能不現。菩薩成就所觀四智。於唯識理決定悟入。證知心外更無實境。又《集異門論·七》。以法智，類智，他心智，世俗智，為四智。復以苦智，滅智，集智，道智，為四智。《最勝王經》則以一，一切智。二，淨智。三，不思議智。四，不動智。為四智。
    五智。顯教轉八識成四智。密教加一法界體性智為五智。此智是轉菴摩羅識所得。法界有差別之義。諸法差別。其數過於塵沙。是為法界。法界體性即六大。大日住於六大法界之三昧。名為法界體性智。主方便究竟之德。以配大日如來。大圓鏡智主發菩提心之德。以配東方之阿閦如來。平等性智主修行之德。以配南方之寶生如來。妙觀察智主成菩提之德。以配西方之阿彌陀如來。成所作智主入涅槃之德。以配北方之不空成就如來。依五智而生三身。法界體性智之身業為毗盧遮那如來。口業為普賢菩薩。意業為不動金剛。大圓鏡之身業為阿閦如來。口業為文殊師利菩薩。意業為降三世金剛。平等性智之身業為寶生如來。口業為虛空藏菩薩。意業為軍荼利金剛。妙觀察智之身業為阿彌陀如來。口業為觀自在菩薩。意業為六足金剛。成所作智之身業為釋迦如來或不空成就如來。口業為金剛業菩薩。意業為摩訶藥叉金剛。見《蓮華三昧經》。
    八智。大乘菩薩證欲界四諦之智。謂之四法智。證上二界四諦之智。謂之四類智。四法，四類。合為八智。一，苦法智。斷欲界苦惑已而證真理之智也。二，集法智。斷欲界集惑已而證真理之智也。三，滅法智。斷欲界滅惑已而證真理之智也。四，道法智。斷欲界道惑已而證真理之智也。五，苦類智。斷上二界苦惑已而證真理之智也。六，集類智。斷上二界集惑已而證真理之智也。七，滅類智。斷上二界滅惑已而證真理之智也。八，道類智。斷上二界道惑已而證真理之智也。見《俱舍論·二十三》。
    十智。大乘十智為如來所具者。一，三世智。於三世法通達圓明之智也。二，佛法智。通達一切佛法說法度生之智也。三，法界無礙智。知一切眾生本具法界之體。事理圓融。不相障礙之智也。四，法界無邊智。知眾生色，心，諸法充滿一切而無邊際之智也。五，充滿一切世界智。如來從定起廣大妙用。周徧充滿於世間之智也。六，普照一切世間智。如來有大智慧光明普照無量世界之智也。七，住持一切世界智。如來有大神力，住持世間攝化一切眾生之智也。八，知一切眾生智。如來知一切眾生善惡因緣之智也。九，知一切法智。如來既知所化眾生。復知能化諸法之智也。十，知無邊諸佛智。如來出現於無邊諸佛世間。說法教化一切眾生之智也。見《華嚴經·十六》。小乘十智。一，世俗智。見諦以前一切凡夫之智也。與煩惱相應。故稱有漏智。二，法智。證欲界苦集滅道之智也。三，類智（《智度論·二》作比智）。證上二界苦集滅道之智也。四，苦智。五，集智。六，滅智。七，道智。知上下界苦集滅道之智也。八，他心智。知他人心之智。九，盡智。既斷盡一切煩惱。則知我既知苦，斷集，證滅，修道。即斷盡煩惱時所生之自信智也。十，無生智。利根羅漢於四諦知斷證修之事已畢。見思惑盡。更不受生三界之智也。鈍根羅漢有更退沒而需知斷證修者。則不能具此智。見《俱舍論·二十六》。
    十一智。菩薩摩訶薩大乘相有十一智。一，法智。知五蘊等差別相轉。二，類智。知蘊、界、處，及諸緣起若總、若別是無常等。三，世俗智。知一切法假設名字。四，他心智。知他有情心、心所，法及修行證滅。五，苦智。知苦應不生。六，集智。知集應永斷。七，滅智。知滅應作證。八，道智。知道應修習。九，盡智。知貪瞋癡盡。十，無生智。知有趣不復生。以上十智。皆以無所得為方便。故為大乘。十一，如實智。則如來之一切相智。一切諸法。皆無自性。無生無滅。本來寂靜。自性涅槃。無所得相。名一切相。一切行相。皆正了知。名一切相妙智。此十一智名目。分見《大般若經·三》、《智度論·二十三》。類智，論作比智。世俗智，論作世智。
    十三智。一，聞所生智。二，思所生智。三，世間修所生智。四，勝義智。五，他心智。六，法智。七，種類智。八，苦智。九，集智。十，滅智。十一，道智。十二，盡無生智。十三，大乘智。見《雜集論·三》。
    十八智。一，不二智。知一切二。二，無相智。知一切相。三，無分別智。知一切分別。四，無異智。知一切異。五，無差別智。知一切差別。六，無世間智。知一切世間。七，無世智。知一切世。八，無眾生智。知一切眾生。九，無執著智。知一切執著。十，無住處智。知一切住處。十一，無雜染智。知一切雜染。十二，無盡智。知一切盡。十三，究竟法界智。於一切世界示現身。十四，離言音智。示不可說言音。十五，一自性智。入於無自性。十六，一境界智。現種種境界。十七，知一切不可說智。現大自在言說。十八，證一切地智。為教化調伏一切眾生故。於一切世間示現大神通變化。見唐譯《華嚴經·五十五》。晉譯《華嚴經·三十八》。
    二十智。台宗約四教而明二十智。藏教七智。一，世智。二，外凡智。三，內凡智。四，四果智。五，辟支佛智。六，菩薩智。七，佛智。通教五智。一，四果智。二，支佛智。三，入空之菩薩智。四，出假之菩薩智。五，佛智。別教四智。一，十信智。二，住行向之三十心智。三，十地等覺智。四，佛果智。圓教四智。一，五品智（圓教外凡位淺深次序之別。有五品。一，隨喜品。二，讀誦品。三，說法品。四，兼行六度品。五，正行六度品）。二，六根智。三，住行向地之四十心智。四，佛智。見《輔行記·三》。
    三十五智。一，預流果智。二，一來果智。三，不還果智。四，阿羅漢果智。五，獨覺菩提智。六，諸佛無上正等菩提智。七，四念住智。八，四正斷、四神足、五根、五力、七等覺支、八聖道支智。九，空解脫門智。十，無相無願解脫門智。十一，四靜慮智。十二，四無量、四無色定智。十三，八解脫智。十四，八勝處、九次第定、十徧處智。十五，布施波羅蜜多智。十六，淨戒、安忍、精進、靜慮、般若波羅蜜多智。十七，一切陀羅尼門智。十八，一切三摩地門智。十九，苦聖諦智。二十，集滅道聖諦智。二十一，內空智。二十二，外空、內外空、空空、大空、勝義空、有為空、無為空、畢竟空、無際空、散空、無變異空、本性空、自相空、共相空、一切法空、不可得空、無性空、自性空、無性自性空智。二十三，真如智。二十四，法界、法性、不虛妄性、不變異性、平等性、離生性、法定、法住、實際、虛空界、不思議界智。二十五，菩薩十地智。二十六，五眼、六神通智。二十七，如來十力智。二十八，四無所畏，四無礙解，大慈、大悲、大喜、大捨，十八佛不共法智。二十九，無忘失法智。三十，恒住捨性智。三十一，一切智智（此謂一切智之智。與如來一切智智有別）。三十二，道相智，一切相智，智。三十三，一切世間出世間法智。三十四，有漏無漏法智。三十五，有為無為法智。是名聖法。見《大般若經·三百八十》。
    四十四智。約十二因緣中行、識、名色、六處、觸、受、愛、取、有、生、老死十一支各依四聖諦觀察。建立四十四有漏智。知行智。知行集智。知行滅智。知趣行滅行智。乃至知老死智。知老死集智。知老死滅智。知趣老死滅行智。不說無明者。以無明不以有支為因。亦非有支之果也。見《瑜伽論·十》。《大毘婆沙論·一百十》。《發智論·十》。
    七十七智。觀十二因緣中後十一支之聞思修三慧有漏智也。此一支每支各有七智。七智者。每支依順觀、逆觀為二智。按三世，過現未共得六智。此六智緣理如實而知。名真實智。屬思慧與修慧。更從聞教而知三世緣起之道。名法住智。為第七智。屬聞慧。十一支共得七十七智。見《對法論·四》。
    得有四種。一，法俱得。謂所得法在。法亦現在也。二，法前得。法尚未來。得生於前也。三，法後得。法已過去。得尚在也。四，非前後俱得。無過去、現在、未來之別。即擇滅、非擇滅之得。前三屬有為法。後一屬無為法。

    智即能觀之知。得即所證之理。無智則能觀知空。無得則所空境空。境非智不了。智非境不生。外境如如。內智寂寂。無如外之智能證於如。亦無智外之如為智所證。如智都冥。智得同空。無得則無空相。無智則無知空相者。無空相則無實相。無知空相者則無觀照。不但蘊、處、界、緣、諦諸法皆空。即三乘人能證所證。及修般若菩薩，空諸法之智。與空智所得之理亦無。蓋法性本空。蘊、處、界、緣、諦諸法空故。能證諸法本來是空之般若智慧亦空。此般若智慧空故。由般若智慧觀照所得之真空實相亦空。一物不幹。萬緣都盡。方是真般若。故《金剛經》曰。佛說般若波羅蜜。即非般若波羅蜜。《大般若經》曰。善男子善女人等。修般若時。作如是念。我能修慧。彼是慧境。此般若果。般若自性。彼修慧時名住般若。不名般若波羅密多。以有所得為方便故。若菩薩摩訶薩修般若時。不得慧者。慧境。慧果。般若自性。以無所得為方便故。能滿般若波羅蜜多。又曰。如是般若波羅蜜多。以虛空為相。以無著為相。以無相為相。何以故。般若波羅蜜多甚深相中。諸法諸相。皆不可得。無所有故佛言。善現。住菩薩乘諸善男子善女人等。若有方便善巧。以無所得為方便。於此般若波羅密多名。不取名相。不起耽著。不住憍慢。便能證得實相般若。又曰。雖達一切法自性皆空。而諸菩薩因此般若波羅蜜多。證得無上正等菩提。轉妙法輪。度無量眾。雖證菩提而無所證。證不證法皆不可得故。惟不可得。即無能證所證。諸妄知見。由無妄見。故無顛倒之煩惱。若有所證。即是顛倒夢想。豈得涅槃菩提。《智度論》云。菩薩深入空故。知空亦空。涅槃亦空。故無所證。以證不證法不可得故。始從五蘊。終至四諦。乃修道人所觀之境。夫境不能自空。假真智觀照以空。及空相既顯。則空理亦無。《楞嚴經》曰。覺所覺空。空所空滅。般若如大火聚。無論淨穢。觸處皆燒。真空理顯。凡情蕩盡。真如聖境。一切智悉不可得。故世間蘊處界。出世間因緣諸諦。以及能證之智。所證之得。莫不皆空。人法兩忘。境智雙泯。病去而藥亦除。故曰無智亦無得。《大般若經》曰。一切法自相皆空。能取所取不可得故。於一切法無所取著。能從此岸到彼岸故。若於諸法稍有取著。則於彼岸非為能到。又曰。過去未來現在智見。無著無縛。亦無解脫。何以故。以一切法著不可得。縛不可得。著縛既無。從彼解脫，亦不可得。但無智無得。並非灰身滅智之謂。其云無者。但破彼執著於二取。非謂真智聖境。一切都無。《顯揚論》云。無所得者。推求諸法不見自性。非一切種都無所得。《靖邁疏》云。上來為破於蘊等徧計所執。故借空以遣之。又恐人即以空為究竟所證得境。故又遣之。明此空亦復非是所證得境。《華嚴經》曰。無中無有二無二亦復無。蓋以空遣空。空空亦跡。遣之又遣。以至無遣。甚至無遣亦無。方為第一義空。《中觀論》云。大聖說空法。為離諸相故。若復見於空。諸佛所不取。何以故。本為有病。借空以除。有病既除。空亦不存。《略疏》云。知空智不可得。故云無智。所知空理亦不可得。故云無得。是故所取非有。能取亦無。無智之智。方為真智。無得之得。方為真得。
    【注】方便。方者方法。便者便用。便用契於一切眾生之機之方法也。又方為方正之理。便為巧妙之辭。《往生論》云。正直曰方。外己曰便。般若者。達如之慧名。方便者。通權之智稱。達如則心行寂滅。通權則備省眾機。方便是善巧之名。故常曰方便善巧。
    體無相之真理。心中無所執著。無所分別。名無所得。即空慧也。無分別智也。
    名相。一切之事物。有名有相。耳可聞謂之名。眼可見謂之相。皆是虛假。而非契於法之實性。凡夫常分別此虛假之名相。而起種種妄想。
    憍慢之慢。五順上分結之一。自高凌物之心也。《大乘義章》云。自舉凌物。稱曰憍慢。《俱舍論》云。慢對他心舉。憍由染自法。心高無所顧。百法中慢為煩惱法。憍為隨煩惱法。所謂上分結者。對於欲界之五順下分結（一，貪。二，瞋。三，身見。四，戒取。五，疑）而言。此則為上二界之結惑。一，色愛結。即色界思惑。於上妙五欲。取著無厭也。二，無色界結。即無色界思惑。無色界眾生。雖無色質。而於受想等法。未能捨離。取著四空禪定境界。不能脫離也。三，掉結。上二界眾生。心念散動。退失禪定。掉心繫縛。不能出離也。四，慢結。上二界眾生。愛染未斷。慢心不息。不能出離也。五，無明結。上二界眾生。躭著禪定。於真性無所明了。無明繫縛。不能出離也。所取者。取所行義。能取者。謂諸色根，及心，心所（三蘊全。色行蘊一分。根相及相應相。如其次第。十二界六處全。及法界法處一分相應自體）。為捨執著境界我故。觀察所取。為捨執著受用我故。觀察能取。能取有四。一，不至能取。謂眼耳意根。二，至能取。謂餘根。三，自相現在各別境界能取。謂五根所生自相共相。四，一切時一切境界能取。謂第六根所生，又由和合識等生故。假立能取性。所以者何。以依眾緣和合所生識等。假說能取。不由真實義。諸法無作用故。
    《大般若經·六百》曰。言著縛者。謂於法性執著繫縛。法性既無。故不可說有著有縛。言解脫者。謂脫著縛。彼二既無。故無解脫。無解脫者謂於諸法都無有能得解脫性。言無著者。謂於此中著不可得著無著性。著無實性。故名無著。以於此中能著所著。由此為此。因此屬此。皆不可得。故名無著。言無縛者。謂於此中縛不可得。縛無縛性。縛無實性。故名無縛。以於此中能縛所縛。由此為此。因此屬此皆不可得。故名無縛。若於諸法無著無縛。如何於法可說解脫無著無縛。亦無解脫。離繫清涼。名真解脫。若於諸法無執著者。則無繫縛。若於諸法無繫著（似當作縛）者。則無解脫。遠離三事離繫清涼。名真解脫。如是菩薩悟入諸法無著無縛。亦無解脫。得真智見。修行般若波羅蜜多。若諸菩薩能如是行。鄰近無上正等菩提。速能證得一切智智。又曰。諸佛所得一切智智。皆從般若波羅蜜多而得生故。一切智智。不異般若波羅蜜多。般若波羅蜜多。不異一切智智。又三百六十九曰。是菩薩摩訶薩。雖於如是所說八地。皆徧修學。而能以勝智見。超過用道相智而入菩薩正性離生。既入菩薩正性離生位已。復用一切相智。永斷一切習氣相續。入如來地。爾乃成就一切智智。故一切智智。為菩薩得一切相智後永斷習氣相續入如來地之名。
    無智無得。《凖楞嚴經》各家注解。孤山謂總非二乘理智。得即理也。小乘所證智理。謂非有我空之智。與非得我空之理。當屬聲聞乘。但其《心經疏》。則謂境智是菩薩，佛，法界。菩薩則分證境智。佛果則究竟境智。空無境智。九界俱空。即佛境界知空之智自無。故云無智。所得空理亦無。故云無得。意亦謂指菩薩法。《溫陵要解》謂聲聞修四諦法。以智為能證。以智為所得。故以此為非聲聞法。《長水疏》謂非四諦及能證所證。《通理指掌疏》謂非權教菩薩。提婆《心經註》云。能觀者智也。所觀者得也。既以苦樂兩忘。觀心不起。名之謂得無所得。此之一得。不同世得。為破菩薩有所得故。故言無智亦無得。宗泐、如玘兩師《心經注解》謂無智無得。繫大乘菩薩以智照境。既無五蘊四諦諸法。即是人法皆空。境智俱泯。《心經直說》謂智即觀智。乃六度之智慧。得即佛果。乃所求之境。若以有所得心求之。皆非真也。亦以空智，得，為菩薩事。《心經添足》則謂係空三乘人能證所證。及修般若菩薩空諸法之智。與空智之所得理亦無。《事觀解》云。觀智，得，即二空理境。智乃六度中一得是波羅蜜果。豈不局於大乘。故此為大乘菩薩而說。《心經句義》則以此為諸菩薩說六度萬行法。近人印光師以無智為無菩薩界法。無得為無佛界法。倓虛師以此為離權位菩薩法相。圓瑛師謂此文接於四諦之下。不必別作他說。守培師以楞嚴非智非得。為非菩薩法。古今諸師。於此各有不同見解。按經曰。以無所得故。菩提薩埵。依般若波羅蜜多故。心無罣礙。自非實教菩薩。不能到此境界。權教菩薩。隨相修行。既有能得之智。及所得之法。則本經說空智得。自不可謂專指二乘。菩薩惟能空智得。以無所得為方便。斯能心無罣礙。得究竟涅槃耳。即依本經說法層次推勘。為凡夫說空蘊、處、界三科法門。為緣覺說空十二因緣法門。為聲聞說空四諦法門。菩薩修六度萬行。則為之說空智、得法門。亦隨機施教之義。《義疏》云。此離權位菩薩法相也。智者。智度也。以一度攝前五度。得者以離真俗而得中道也。菩薩以智度上求佛道。下化眾生。得證佛果。云何無之。然無者。亦依妙有真空而言也。若有所明之智。即成理障。若有所得之果。即成事障。事理二障。即屬見相二分。如何復其自證分乎。今言無智得者。乃智無智相。得無得相。即智法而離智相。即得法而離得相。所謂離一切相。即一切法。而權位菩薩。從空出假。以有中道可得。竟不知即空，假，即中道也。蓋空者。泯一切法。假者。立一切法。中者。統一切法。而統一切法者。非有能統之中。所統之法。是乃法法皆中也。而空、假豈出法外乎。立一切法者。非有能立之假。所立之法。而中，空，豈出法外乎。泯一切法者非有能泯之空。所泯之法。乃法法皆空。而中，假，豈出法外乎。六度中布施、持戒、忍辱、精進、禪定五法。皆為事境假名。智慧一法。即理智之真空。前五屬事。無智不行。後一屬理。無事不顯。故事不離理。理不離事。則可知空即是假。假即是空。息空、假二邊之分別。則空、假即中矣。豈空，假之外別有中道可得乎。則顯然即。六度。即真空實相。方為稱性。六度豈事理不融之六度乎。故曰。無智亦無得也。《發隱》云。六度以智為體。智度既空。五度亦空。故曰無得。謂三諦理體周徧。能所俱泯。故云無。《連珠記》云。經云。若說有覺。猶未離幻。是故無智。又云。本無菩提及與涅槃。又云。設更有法勝過菩提涅槃。我亦說為如夢如幻。故云無得。印光法師云。是故諸法空想之中。無色受想行識之五蘊。無眼耳鼻舌身意之六根。無色聲香味觸法之六塵。無眼識界乃無意識界之六識。是無六凡界法。無無明乃至無老死。是無十二因緣流轉門。亦無無明盡乃至亦無老死盡。是無十二因緣還滅門。是無緣覺界法。無苦集滅道。是無聲聞界法。無智。智為六度末後之一度。是無菩薩界法。亦無得。得即菩提涅槃。是無佛界法。見《印光法師文鈔續編·上·答周孟由書》。


第一項 明菩薩得涅槃

    第三節　顯彰妙果
    本節更分二項。

    第一項　明菩薩得涅槃

    以無所得故。

    此承上文而言。正明所得。所得者何。菩薩得涅槃斷果。諸佛得菩提智果也。以者由也。故者。因也。謂由前諸法無所得。故菩薩因依之而修得究竟涅槃。故此無字。乃統一經之旨。無所得即空慧。體無相之真理。心中無所執著無所分別。是曰無所得。《淨名經》舍利弗曰。無所得故而得。《大品》曰。以無所得而為方便。《連珠記》云。前云。無智亦無得。故今躡為因行。由是而得果。前明所離是斷惑。今明所得是證果。《大般若經》曰。以一切法皆畢竟空。畢竟空中。都無有法。可名能證。可名所證。可名證處。可名證時。可名由此而有所證。所以者何。諸法皆空。若增若減。都無所有。皆不可得。又曰。佛告善現。佛證無上正等覺時。所得佛法。依世俗故。說名為得。若依勝義。能得所得俱不可得。何以故。善現。若謂此人得如是法。便有所得。有所得者。便執有二。執有二者。不能得果。亦無現觀。又曰。一切法自相皆空。能取所取。皆不可得。又曰。若無所得。即是得。即是現觀。即是無上正等菩提。《涅槃經》曰。無所得者。則名為慧。菩薩得是慧故。名無所得。又無所得者名大涅槃。菩薩安住大涅槃中。不見一切諸法性相。故名無所得。又無所得者名為大乘菩薩。不住諸法。故名大乘。清涼云。無所得即般若相。由得般若無得智慧故，方得也。《智度論》云。有所得者。以我心於諸法中取相故。諸法實相中。決定相不可得。故名無所得。《淨名經慧遠疏》云。菩薩破去情相。到無得處。名無所得。《仁王經·良賁疏》云。有所得為取相之心。無所得為無分別智。惟行不可得空。則空空亦空。空亦不可得。《金剛般若不壞假名論》云。若論菩薩證真實時。乃至法身亦無得故。蓋愛執一生。名有所得。若執有相。是增益邊。亦名常見。若執無相。是損減邊。亦名斷見。有所執者。名生死輪。一切凡夫輪迴生死。故有所得。菩薩永斷一切生死。名無所得。無所得者為慧。有所得者為無明。法性如如。體本寂滅。得與無得。俱絕名言。
    【注】執五蘊身心。過去現在未來相續不斷。是名常見謂五蘊身心今世滅已。更不再生。是名斷見。無論執斷執常。任執一邊。均為邊見。
    因緣所生之法。分別推求。本無自性。眾生不了。執之為有。曰增益邊。因緣所生之法。雖無自性。然非無因果功能。眾生不了。撥之為空。曰損減邊。
    於諸法中取相。三惑皆有之。《觀音玄義》曰。見思取生死相。塵沙取涅槃相。無明取二邊相。著心取相。即為有所得。故《金剛經》曰。不取於相。如如不動。不取於相。亦須無心。若是有心不取於相。仍是取相。仍為有所得。《淨名經》天女曰。我無得無證。若有得有證者。則於佛法為增上慢。
    法性如如。體本寂滅。即不生不滅之性。證性之時。智外無理。理外無智。智理冥合。無能證。無所證。靈光獨耀。寂照同時。謂之如如。

    菩提薩埵。依般若波羅蜜多故。心無罣礙。

    菩提薩埵是能依之人。般若波羅蜜多是所依之法。依者。依止之義。菩薩修習般若波羅蜜多。以為依止。了知諸法自性皆空。空性無相。於蘊、處、界、因緣、諦、相。及能證所證。皆無所得。惑不礙心。境不礙智。故心無罣礙。心無罣礙。即空解脫。是即般若觀空之效。
    【注】菩提名佛道，薩埵名成眾生。稱讚好法名為薩，好法體相名為埵。菩薩心自利利他故。度一切眾生故。知一切法實性故。行阿耨多羅三藐三菩提故。為一切賢聖之所稱讚故。是名菩提薩埵。所以者何。一切諸法中。佛法第一。是人欲取是法故。為賢聖所讚歎。復次，如是人為一切眾生脫生老死故，索佛道是名菩堤薩埵。復次，三種道皆是菩提。一者。佛道。二者。聲聞。三者。辟支佛道。辟支佛道聲聞道雖得菩提而不稱為菩提。佛功德中菩提稱為菩提。是名菩提薩埵。有大誓願。心不可動。精進不退。以是三事。名為菩提薩埵。初發心作願。我當作佛。度一切眾生。從是以來。名菩提薩埵。從初發心到第九無礙入金剛三昧中。是中間名為菩提薩埵。是菩提薩埵有兩種。有鞞跋致。有阿鞞跋致。見《智度論·四》。
    菩提薩埵釋義有三。一，菩提所求果。薩埵所度生。二，菩提所求果。薩埵能求人。三，菩提覺悟智。薩埵情慮識。總約悲、智、能、所、真、妄，以立名也。《法華玄讃》云。菩提覺義。是所求果。薩埵有情義。是自身也。《法華經嘉祥疏》云。菩提云道。薩埵云眾生。依大論釋。菩提名佛道。薩埵名成眾生。用諸佛道。成就眾生。故名菩提薩埵。又菩提是自行。薩埵是化他。自修佛道。又用化他。故名菩薩。《天台戒經義疏》云。摩訶菩提質帝薩埵。譯云大道心成眾生。今言菩薩者。略其餘字也。
    《大般若經·五百九十四》曰。若諸菩薩發菩提心作如是念。我於今者發菩提心。此是菩提。我今為趣此菩提故，發修行心，是諸菩薩有所得故。不名菩薩。但可名為狂亂薩埵。何以故。善勇猛。由彼菩薩決定執有發起性故。決定執有所發心故。決定執有菩提性故。若諸菩薩發菩提心有所執著，但可名為於菩提心有執薩埵，不名真淨發心菩薩。彼由造作發菩提心。是故復名造作薩埵。不名菩薩。彼由加行發菩提心。是故復名加行薩埵。不名菩薩。何以故。善勇猛。彼諸菩薩，由有所取，發菩提心。但可名為發心薩埵。不名菩薩。
    《會要》云。惑不礙心者，謂真智現前，照惑本無，不能礙心，心善解脫也。境不礙智者，謂真智無自。真諦無根。忘功合道，與道通同，慧善解脫也。真俗二諦。以色即空故，不礙如理之智，而會實相。以空即色故。不礙如量之智，而覺諸事。

    罣礙即障。罣為煩惱障。礙為所知障。煩惱障依於我執。能障涅槃。所知障依於法執。能障菩提。一切眾生。妄認四大六塵。執我及我所。輾轉生死。輪迴六道。是名罣礙。
    【注】《連珠記》云。煩惱障心。心不解脫。故造業輪轉。所知障慧。慧不解脫。故不了自心。不達諸法性相。縱出三界。亦滯下乘。不得成佛。今得般若深慧。二障種、現（種子、現行）俱亡。得二解脫。

    無罣礙故。無有恐怖。遠離顛倒夢想。

    此明菩薩斷障之功。無有恐怖。即無相解脫。由證諸法自性皆空。則知諸法無相。外不相礙。內無恐怖也。遠離顛倒夢想。即無願解脫。由證諸法無性。但是顛倒。猶如夢想。虛妄不實。是以遠離。不起願求也。外無魔冤之怖。則惡緣息。內無惑障之倒。則惡因盡。
    恐怖即恐懼怖畏之義。眾生身口意三業與罪相應。三界果報。猶如火宅。是可畏相。故曰恐怖。
    【注】《智度論》云。知一切法因緣和合故生，諸緣離故滅，無有起者。無有滅者。故不畏不怖。菩薩知一切法虛誑。無實無定。若死急時。若墮阿鼻泥犁。心猶不動。況聞虛聲而有怖畏。如人夢中。見怖畏事。覺已則無所畏。
    初學菩薩有五怖畏。一，不活畏。行布施時。恐影響自己生活。不能盡其所有。二，惡名畏。恐受惡名。不能為和光同塵之行。三，死畏。雖發大心。而顧惜身命。不能自捨。四，惡道畏。恐墮惡道。於不善法分別對治。令其不生。五，大眾威德畏。於王庭或善解法義人前。不敢暢論。惟恐有失。見《佛道論》。又有十種怖畏。一，死。二，煩惱垢。三，貧窮。四，惡業。五，惡道。六，求不得。七，謗法罪業。八，追求時縛不活。九，疑。十，大眾威德。見《十地經論·十》。《華嚴經》明十八種怖畏。一，險道。二，熱惱。三，迷惑。四，繫縛。五，殺害。六，貧窮。七，不活。八，惡名。九，死。十，大眾。十一，惡趣。十二，黑暗。十三，遷移。十四，愛別離。十五，怨憎會。十六，逼迫身。十七，逼迫心。十八，憂愁。

    遠離。梵語阿羅蜜。有名詞動詞二用。作名詞用者。即空之別名。與波羅蜜音近而義亦相會。作動詞用者。解脫一切事相繫縛之義。菩薩行般若波羅蜜。於一切法，心皆遠離也。《大般若經》曰。甚深般若波羅蜜多。遠離為相。諸法亦以遠離為相。又曰。但能遠離煩惱惡業。遠離聲聞獨覺作意。勤修般若波羅蜜多及諸餘殊勝功德。是名菩薩真遠離行。又曰。於一切煩惱、六趣、四生、蘊、界、處等而得遠離。故名般若波羅蜜多。
    【注】遠離有五。一，惡行遠離。二，欲遠離。三，資具遠離。四，憒鬧遠離。五，煩惱遠離。蓋遠離屬無為法。為永斷分結之義。謂諸染污、無記，作意不現行故。見《瑜伽論·十三》。
    《智度論》云。知諸法但是虛誑。無有真實菩薩得如是智慧。一切別相法中。皆得遠離。如色中離色。離色即是自性空。遠離者。空之別名。

    顛倒者。無明所使。反於真理之妄見也。迷真曰顛。逐妄曰倒。《圓覺經》曰。一切眾生。從無始來種種顛倒猶如迷人。四方易處。《淨名經》曰。虛妄分別孰為本。顛倒想為本。蓋為一切煩惱根本。
    【注】《文句》云。顛。頂也。顛倒。首倒懸也。
    種種顛倒。諸經所說不同。約舉如左。
    三顛倒。一，心顛倒。心即根塵相對所起一念之心。為群妄之源。起惑之始。因迷自性清淨之心。種種分別起諸顛倒。二，見顛倒。眼是諸見之本。由不了塵境虛幻。妄生執取。起諸顛倒。三，想顛倒。想取六塵之相。由不了六塵過患。傷失善根。妄生緣想。起諸顛倒。見《涅槃經·三十七》。
    四顛倒。有凡夫四顛倒。二乘四顛倒之分。凡夫四顛倒。一，常顛倒。於世間無常法起常見也。二，樂顛倒。不明樂為苦因妄起樂見也。三，我顛倒。於自身妄計為我。起我見也。四，淨顛倒。不了己身他身五種不淨（一，種子不淨。一者內種。謂觀此身從昔煩惱業生。二者外種。謂攬父母遺體而成此身。內外因種皆為不淨。二，住處不淨。觀此身在母胎生藏之下，熟藏之上，臭穢中住。三，自體不淨。觀此身由四大不淨所成。四，外相不淨。觀此身九孔常流穢惡，如破皮囊，滿盛不淨。五，究竟不淨。觀此身死後臭爛。究竟不淨）。妄生貪著也。二乘四顛倒。一，常計無常。常即法身常住之義。無常即變異之義。聲聞緣覺為無明所覆。於如來常住法身。妄計有生滅變異之相。是名無常顛倒。二，樂計非樂。樂即涅槃清淨之樂。二乘為無明所覆。於如來清淨涅槃。妄計是苦。名非樂顛倒。三，我計無我。我即佛性真實之我。二乘為無明所覆。不了無我法中尚有真我。妄計無我。是名無我顛倒。四，淨計不淨。淨即如來常住法身。二乘為無明所覆。但觀世間一切諸色。皆為不淨。不了如來常住法身之淨。是名不淨顛倒。見《俱舍論·九》。
    七顛倒。合上三顛倒、四顛倒而言。見《瑜伽論·八》。
    八顛倒。合凡夫四顛倒、二乘四顛倒而言。見《瑜伽論·七十七》。

    夢者睡夢。想者妄想。在寐為夢。在寤為想。無明幻惑。結想成夢。識性妄行。攀緣成想。顛倒夢想。謂顛倒妄見。虛妄不實。猶如夢想。
    【注】妄想根於五蘊。一，堅固妄想。即色蘊也。一切眾生。體因想生。心因想起。命因想傳。諸想交固而成色身。名此色身為堅固妄想。二，虛明妄想。即受蘊也。一切眾生。欲想登高。足先酸澀。違順二相。損益現馳。受蘊無體。虛有所明。是曰虛明妄想。三，融通妄想。即想蘊也。眾生念慮是虛。色身是實。虛實不倫而能相使者。想融之也。心生虛想，形取實物。心形異用而能相應者。想通之也。至於寤寐。心境相隨而無間斷。皆此妄想主之。是曰融通妄想。四，幽隱妄想。即行蘊也。眾生一期色身生化之理。自幼至衰。無暫停息。默運潛移。體遷無覺。是曰幽隱妄想。五，顛倒微細精想。即識蘊也。眾生識精之湛。並非真實。如急流水。望似恬靜。實因急流。細不可見。湛了之內。罔象虛無。是曰顛倒妄想。是五受陰。五妄想成。見《楞嚴經·十》。
    《廣承》云。罣礙者。結業也。恐怖者。生死也。顛倒夢想者。無明也。菩薩依般若故。達結業即解脫。故無罣礙。達生死即涅槃。故無恐怖。達無明即智慧。故無顛倒夢想。

    究竟涅槃

    此明菩薩證得之果。謂由前諸法無所得故。菩薩因依之而修得究竟涅槃。涅槃亦作泥洹。具云涅槃那。梵音正名應作波利泥縛喃。云涅槃者。略稱也。《智度論》云。涅名為趣。槃名為出。求出諸趣，故名涅槃。波利。此云圓泥縛南。此云寂。故譯為圓寂。寂滅。滅者。滅生死因果。圓謂德無不備。寂謂障無不盡。
    【注】涅槃譯名甚多。一，大滅度。大即法身。滅即解脫。度即般若。二，大涅槃。涅言不生。槃言不滅。不生不滅。名大涅槃。三，無為。虛無寂寞。妙絕於有為。四，滅度。大患永滅。超越四流也。五，圓寂。德無不備曰圓。障無不盡曰寂。此奘師所譯也。六，寂滅。生死永滅。圭峰師所名也。七，安樂。八，無生。九，滅。十，解脫。十一，不織。十二，不取。十三，不定。十四，不覆。十五，無相。十六，無苦。十七，無後有。十八，出稠林。十九，離繫縛。二十，無臭。要皆引申生義。當以圓寂為正譯也。
    涅槃近因有四。一，近善智識。二，聽聞正法。三，思唯其義。四，如說修行。聽聞正法即聞。思唯即思。修行即修。是為三慧。《楞嚴經》曰。從聞思修。入三摩地。
    涅槃有四種。一，本來自性清淨涅槃。謂真如隨緣變造一切諸法。雖有煩惱垢染。而本性清淨。具足無量微妙功德。無生無滅。湛若虛空。一切眾生。平等共有。與一切法不一不異。離一切相。一切分別。尋思路絕。名言道斷，惟真聖者自內所證。其性本寂。故名本來自性清淨涅槃。二，有餘依涅槃。謂煩惱之障雖滅。尚餘欲界五蘊之身而為所依。故名有餘依涅槃。三，無餘依涅槃。謂煩惱既盡。所餘五蘊之身亦滅。故名無餘依涅槃。四，無住處涅槃。謂不住生死。不住涅槃。窮未來際。利樂有情。用而常寂。故名無住處涅槃。見《成唯識論·十》。
    又有分涅槃為三種者。一，性淨涅槃。謂諸法實相之理不可染。不可淨。不染即不生。不淨即不滅。不生不滅。名性淨涅槃。二，圓淨涅槃。智極名圓。惑盡名淨。據性而言。雖無染淨。約修而說。惑智宛然。智若契理。惑畢竟不生。智畢竟不滅。不生不滅。名圓淨涅槃。三，方便淨涅槃。方便猶善巧也。謂智能契理。即照群機。照必垂應。機感即生。此生非生。機緣既盡。應身即滅。此滅非滅。不生不滅。名方便淨涅槃。見《金光明經玄義》。
    涅槃有四樂。一，無苦樂。世間之樂。即為苦因。惟能斷樂。則無有苦。二，寂靜樂。涅槃之性。是大寂靜。以遠離一切憒鬧法故。三，大知樂。諸佛如來。有大智慧。於一切法。悉知悉見。四，不壞樂。如來之身。猶如金剛。歷劫不壞。見《大涅槃經》。
    《連珠記》云。德無不備者。無住處大般涅槃。具足常等無盡故。菩提得果。不同無得。乃具佛德空也。惑障本如。無盡可盡。無斷可斷。

    究竟猶言至。極大義。無餘義。決定終極義。一，得永常。故名究竟。究竟涅槃，梵語摩訶涅槃那。譯作大滅度。大者。美滅德之稱。滅者。滅煩惱。度者。度生死。那者。此云息。息煩惱，息生死也。大即法身。滅即解脫。度即般若。又大者實相。滅者蘊空。度者越苦。以究盡涅槃之際。體性常寂。故菩薩觀諸法空。離實相理。五住究盡。二死永斷。三障頓空。三德同圓，是為究竟涅槃。
    【注】究竟涅槃。亦名無餘依涅槃。以究盡涅槃之際故。亦名無住處涅槃。非同二乘但離見思惑。名為解脫。權得化城之涅槃。非究竟也。五住。即五住地惑也。三界見惑為一住。三界思惑分三住。根本無明為一住。由此五惑。能令眾生住著生死。故名住地。一，一切見住地惑。一切見即三界分別見惑。謂諸眾生由意根對法塵分別起諸邪見，住著三界。故名一切見住地惑。二，欲愛住地惑。欲愛者。即欲界思惑也。謂諸眾生由五根對五塵境起貪愛心。而於欲界住著生死。故名欲愛住地惑。三，色愛住地惑。色愛。即色界思惑。謂諸眾生不了此惑。住著色界禪定。不能出離。故名色愛住地惑。四，有愛住地惑。有愛。即無色界思惑。謂諸眾生不了此惑。住於禪定。不能出離。故名有愛住地惑。五，無明住地惑。即根本無明惑。謂聲聞緣覺未了此惑。沈滯真空。即住方便土。大乘菩薩方能除斷。由餘惑未盡。住實報土。故名無明住地惑。見《華嚴經隨疏演義鈔》。
    三障。障者。蔽也。謂諸眾生被惑業障蔽。不見正道。善心不能生起。故名障也。一，煩惱障。昏煩之法。惱亂心神。故名煩惱。謂貪欲瞋恚愚癡等惑。障蔽正道。是名煩惱障。二，業障。業名業行。謂由貪瞋癡造作身口意惡業。障蔽正道。是名業障。三，報障。報即果報。謂由煩惱惑業。生在餓鬼地獄畜生諸趣。障蔽正道。是名報障。見《涅槃經·十一》。煩惱障又分為三。一，皮煩惱障。即三界中思惑。謂貪瞋等煩惱對外六塵而起。如皮在身外也。二，肉煩惱障。即三界中見惑。謂斷常有無等見。皆屬內心分別。如肉在皮內也。三，心煩惱障。謂此無明之惑。由迷真心逐妄而起。故名心煩惱障。見《華嚴孔目》。
    三德者。法身、般若、解脫也。以苦惑業三染易三德。一，翻苦身成法身德。法即軌法。謂諸佛由軌法而得成佛。故名法身。法身即一切法平等實性。小乘不談理性。僅以五分功德法為法身。一，戒。謂如來身口意三業離一切過非之戒法身也。二，定。謂如來真心寂靜離一切妄念之定法身也。三，慧。謂如來以根本智觀達法性之慧法身也。四，解脫法身。謂如來身心解脫一切繫縛成涅槃德也。五，解脫知見法身。謂如來智眼照了諸法皆空。自知無縛成後得智也。大乘各宗中。如三論宗則以真空無相為法身。唯識宗之總相法身。兼理智二法。以所證之真如與能照之真覺為法身。別相法身。則以無為之真如為法身。華嚴宗以所證之理為法身。密宗之自性法身分二。法界諸法。體用寂然法爾不改。名理法身。即胎藏界之四重圓壇也。一切之法。互相周徧。冥理同體。名智法身。即金剛界一印會之大日法身也。綜合諸說。不外理、智，顯現有為、無為一切功德法，體性之所依而已。《金光明經》曰。惟有如如智。是名法身。如如者。平等之義。以性德論。本覺理性。諸佛眾生。皆同一相。惟眾生為無明所蔽。諸佛以始覺智顯。等虛空界。無所不徧。是為理法身。以修德論。究竟始覺之智。契合本覺之理。理智互融。色心不二。為智所現。是為智法身。法身在諸佛不增。在眾生不減。眾生迷之而成顛倒。諸佛悟之而得自在。迷即三障。悟即三德。迷悟雖殊。體性則一。於生滅無常之身。若能觀察五蘊本空。不生不滅。即成法身。故曰翻苦身成法身德。二，翻煩惱成般若德。般若義即智慧。謂於意根所起諸惑。若能觀察惑體本空。自性不實。於一切法。無不了達。即成智慧。故曰翻煩惱成般若德。三，翻結業成解脫德。不繫為解。自在為脫。謂於身口所作諸業。若能觀察業性本空。則無繫縛之相。於一切法無不自在。即成解脫。故曰翻結業成解脫德。《宗鏡錄·九十》云。云何三。云何德。法身、般若、解脫，是為三。常、樂、我、淨，是為德。法身者。法名可軌。諸佛軌之而得成佛故。經云。諸佛所師所謂法。身者。聚也。一法具一切法。無有缺減。故名為身。經云。我身即是一切眾生真善知識。般若者。覺了諸法集、散、非集、非散。即是覺了三諦之法。解脫者。於諸法無染無住。此三法皆具常樂我淨之四德。諦觀一念之心。即空。即假。即中。即空故。一空一切空。無假。無中。而不空。空無積聚而名藏。藏具足故。名之為德。即假故。一假一切假。無空。無中。而不假。假攝諸法。亦名為藏。藏具足故。名之為德。即中故。一中一切中。無空。無假。而不中。中攝一切。亦名為藏。藏具足故。稱之為德。不可思議。不縱不橫。不並不別。諸佛以即中為體。故名法身。以即空為命。故名般若。以即假為力。故名解脫。一一皆常樂我淨。無有缺減。故稱三德。《觀經智者疏妙宗鈔》云。三德性本圓融。一一互具。故直法身非法身。法身必具般若解脫。直般若非般若。般若必具解脫。法身。直解脫非解脫。解脫必具法身。般若。三德即是教行理三。般若是教。智在說故。解脫是行。用從緣故。法身屬理。是所顯故。按法身者。三身之一。三身已見前注。《宗鏡錄·八十九》云。夫諸佛唯一法身。云何說三身差別。答，約用分三。其體當一。《識論》云。如是法身有三相別。一，自性身。謂諸如來真淨法界。受用、變化平等所依。離相寂然。絕諸戲論。具無邊際真常功德。是一切平等實性。即此自性。亦名法身。大功德法所依止故。二，受用身。此有二種，一自受用。謂諸如來修集無量福慧資糧，所起無邊真實功德，及極圓淨常徧色身，相續湛然，盡未來際，恒自受用廣大法樂。二他受用。謂諸如來由平等智。示現微妙淨功德身。居純淨土。為住十地諸菩薩眾，現大神通，轉正法輪，決眾疑網，令彼受用大乘法樂。三，變化身。謂諸如來由成事智，變現無量隨類化身，居淨穢土。為未登地諸菩薩眾、二乘、異生。稱彼機宜。現通說法。令各獲得諸利樂事。是以轉滅三心得三身。一，根本心。即第八識。轉得法身。二，依本心。即第七識。轉得報身。三，起事心。即前六識。轉得化身。又一，斷德。斷一切煩惱。即法身。二，智德。總四智為報身。三，恩德。恩憐悲育一切有情。為化身。則八解（八解脫）六通（六神通）一心而起。三身（法、報、化）四智（大圓鏡智、平等性智、妙觀察智、成所作智）八識（眼、耳、鼻、舌、身、意、末那、賴耶）所成。終無一理一行而從外來。皆從自識施為。一心而轉。


第二項 明諸佛得菩提

    第二項 明諸佛得菩提

    三世諸佛。依般若波羅蜜多故。

    三世諸佛。為能依之人。般若波羅蜜多為所依之法。三世亦作三際。世者遷流之義。際者隔別之義。過去、現在、未來。約縱以晐一切時代。有為之事物。一剎那間。亦不止息。生已即滅。因之謂善惡諸行。未起、未生者為未來世。現起、現在、未轉、未滅者為現在世。已起、已生、落謝、變滅者為過去世。此於事物遷流幻相。假立三世之名。離去事物。即無世之實體。
    諸者。眾義。約橫以晐十方世界。
    佛者。梵語具云佛陀。此云覺者。覺具三義。一者。自覺。悟真常性。了虛妄惑。二者。覺他。運無緣慈。度有情界。三者。覺行圓滿。歷劫修因。行滿果圓。智慧具足。故名佛陀。《大般若經》曰。具壽善現白佛言。世尊如來常說佛陀。以何義故。名為佛陀。佛言。善現，隨覺實義故，名佛陀。復次善現，現覺實法故，名佛陀。復次善現，通達實義故，名佛陀。復次善現，於一切法如實現覺故，名佛陀。復次善現，於一切法自相、共相、有相、無相，自然開覺故，名佛陀。復次善現，於三世法及無為法一切種相無障智轉故，名佛陀。復次善現，如實開覺一切有情，令離顛倒惡業眾苦故，名佛陀。復次善現，能如實覺一切法相所謂無相故，名佛陀。
    【注】凡夫不能自覺。二乘自覺而不能覺他。菩薩自覺覺他而未圓滿。惟佛三覺圓滿。三覺者。自覺異凡夫。覺他異二乘。覺滿異菩薩。又離心名自覺。離色名覺他。俱離名覺滿。
    無緣慈為三種緣慈之一。一，有情緣慈。亦名眾生緣慈。菩薩以平等智。觀一切眾生。猶如一子。運大慈心而弘濟之。令其皆得安樂。是名有情緣慈。二，法緣慈。菩薩以平等智。觀一切法皆從因緣和合而生。了無自性。雖無自性。而能運大慈心以弘濟之。令其皆得安樂。是名法緣慈。三，無緣慈。菩薩以平等智。無心攀緣一切眾生。而令一切眾生自然獲益。運此慈悲。徧覆法界。任運拔苦。自然與樂。是名無緣慈。

    三世諸佛者。過去、現在、未來，三世諸佛也。三世之三大劫中。每一大劫。總有成住壞空之八十增減小劫。其住劫之二十小劫中。千佛出世。過去名莊嚴劫。如華光佛、人中尊佛、乃至毘婆尸佛、尸棄佛、毘舍浮佛。現在名賢劫。如拘留孫佛、拘那含牟尼佛、迦葉佛、釋迦牟尼佛。未來名星宿劫。如日光佛、龍威佛，乃至須彌相佛。就現在之賢劫。更分三世。則拘留孫佛、拘那含牟尼佛、迦葉佛為過去佛。釋迦牟尼佛為現在佛。自此至第十增減劫之減劫。有彌勒佛出世。次有師子佛乃至樓至佛等。九百九十五佛出世。為未來佛。
    【注】三世諸佛名。見《過去莊嚴劫千佛名經》、《現在賢劫千佛名經》、《未來星宿劫千佛名經》。劫。梵語具云劫波。此云分別時節。人壽八萬四千歲時。歷百年減一歲。減至人壽十歲為止。歷百年增一歲。增至八萬四千歲為止。一增一減。為一小劫。二十小劫。為一中劫。總成住壞空四中劫。為一大劫。成劫者。世界初成立也。有二十小劫。第一小劫。因過去劫壞空之後。第二禪光音天。空中布金色云。注大洪雨。積風輪上。結為水輪。有大風起。吹水生沫。而成須彌等山。時一切有情。皆集光音天中。其福減者。下生世間。最初有一天子。從光音天來。生大梵天中。是為梵王。其壽六十小劫。第二小劫。光音諸天。來生初禪天中。為梵輔天。其壽四十小劫。第三小劫。光音諸天。來生梵眾天中。其壽二十小劫。如是漸漸下生欲界天中。時光音諸天有福盡者。化生為人。飛行自在。無男女相。地湧甘泉。味如酥蜜。因試嘗之。遂生味著。失去神通身光。世間大暗。黑風吹海。漂出日月。置須彌山腹。照四天下。乃有晝夜。彼時眾生。由躭地味故。顏色麤悴。復食自然粳稻。殘穢在身。為欲蠲除。便生二道。成男女根。宿習力故。因生婬欲。光音諸天後來生者。入母胎中。始有胎生。時自然粳稻。朝刈暮熟。刈後隨生。米長四寸。後因人多貪取。漸生糠秕。刈已不生。第四小劫乃至第二十小劫。一增一減。名為成劫。住劫者。世界已成而安住也。亦有二十小劫。至第九小劫人壽減至五萬歲時。第一拘留孫佛出世。減至四萬歲時。第二拘那含牟尼佛出世。減至二萬歲時。第三迦葉佛出世。減至一百歲時。第四釋迦牟尼佛出世。至第十小劫。人壽減至八萬歲時。第五彌勒佛出世。第十五小劫。於減劫中第六師子佛，乃至欲樂佛等相繼出世。至第二十小劫增劫中。樓至佛出世。滿足千佛。名為住劫。壞劫者。世界壞滅也。亦有二十小劫。如火災起時壞至初禪天。始從地獄。終至梵天。有情眾生經十九增減劫。次第壞盡。惟器世間空曠而住。至最後一增減劫方壞。壞時七日從海底出。大海盡竭。須彌崩壞。風吹猛燄。燒上梵天。悉成灰燼。乃至三千世界。一時都盡。名為壞劫。空劫者。世界空虛也。亦有二十小劫。自初禪以下。世界空虛。猶如墨穴。不分晝夜。亦無日月。名為空劫。

    依者。止也。梵語膩地。依止之義。三世諸佛。依止般若波羅蜜多以為修證也。
    【注】《小品·二》曰。諸佛薩婆若。從般若波羅蜜生。《智度論·十八》云。是般若波羅蜜在佛心中變名為一切種智。

    得阿耨多羅三藐三菩提。

    得者。獲成就也。梵語缽羅缽多。使諸法獲得於身之實法也。《小品般若》曰。過去諸佛。皆因般若波羅蜜得阿耨多羅三藐三菩提。未來諸佛。亦因般若波羅蜜得阿耨多羅三藐三菩提。現在十方無量阿僧祇世界諸佛。亦因般若波羅蜜得阿耨多羅三藐三菩提。《大般若經》曰。出世般若波羅蜜多。能如實知。故名為證。後智通達。故名為得。《思益經》曰。佛言我坐道場時。惟得顛倒所起煩惱。畢竟空性。以無所得故得。以無所知故知。阿耨多羅三藐三菩提。遵古不翻。故存梵語。以義譯之。阿，此云無。耨多羅，此云上。三，此云正。藐，此云等。菩提，此云覺。合之為無上正等正覺。舊譯作無上正徧知。謂真正平等覺知一切真理之無上智慧也。在因為智。在果為覺。極果超因。故云無上。正則正觀中道。等則雙照二邊。轉八識以成四智。證法空而悟真如。是為諸佛真淨妙覺。由此現覺諸法一切種相。謂之菩提。《大般若經》曰。具壽善現白佛言。世尊，如來常說菩提。以何義故。名為菩提。佛言。善現。證法空義是菩提義。證真如義是菩提義。證實際義是菩提義。證法性義是菩提義。證法界義是菩提義。復次，善現，假立名相施設言說，能真實覺最上勝妙，故名菩提。復次，善現，不可破壞，不可分別，故名菩提。復次，善現，法真如性、不虛妄性、不變異性、無顛倒性，故名菩提。復次，善現，惟假名相，謂為菩提，而無真實名相可得，故名菩提。復次，善現，諸佛所有真淨妙覺，故名菩提。復次，善現，諸佛由此現覺諸法一切種相。故名菩提。
    【注】阿耨多羅三藐三菩提。即是般若。但名字異。在菩薩心中為般若。在佛心中名阿耨多羅三藐三菩提。菩提此云覺。舊譯作道。諸佛所證清淨究竟之理。以理體分。有三。一，真性菩提。真名不偽。性名不改。真性為道也。二，實智菩提。能照真性之智。稱理不虛。實智為道也。三，方便菩提。善巧隨機。化用自在。方便為道也。見《金光明經玄義》。以行者根器分，亦有三。一，聲聞菩提。行者於聲聞行中。雖已自發菩提之心。而不勸化眾生發菩提心。亦不習學大乘經義。以是行故，獨得解脫。曰聲聞菩提。二，緣覺菩提。行者於緣覺行中。雖已自發菩提之心。而不勸化眾生發菩提心。亦不習學大乘經義。以是行故，獨得解脫。曰緣覺菩提。三，諸佛菩提。諸佛在因位時。自發菩提心已，復能勸眾生發菩提心。習學大乘經義。自既解脫。亦令眾生解脫。曰諸佛菩提。見《出生菩提經》。以修習階位分。有五。一，發心菩提。十信菩薩。於無量生死中為阿耨多羅三藐三菩提而發大心。為發心菩提。二，伏心菩提。十住十行十迴向菩薩。折諸煩惱。降伏其心。行諸波羅蜜。利益眾生。為伏心菩提。三，明心菩提。登地以上菩薩。觀三世諸法本末、總相、別相、分別籌量。得諸法實相。清淨明了。與般若波羅蜜相應。為明心菩提。四，出到菩提。八地九地十地菩薩。於般若波羅蜜中得方便力故。亦不著般若波羅蜜。滅一切煩惱。見一切十方諸佛。得無生法忍。出離三界。到薩婆若。為出到菩提。五，無上菩提。等覺菩薩。坐於道場。斷諸煩惱。成阿耨多羅三藐三菩提。為無上菩提。見《智度論·五十三》。佛菩提又分應化佛菩提。報身佛菩提。法身佛菩提。見《法華玄義·十》。菩提為覺。所覺之境。有事理二法。理者，涅槃。斷煩惱障而證涅槃之一切智。通三乘之菩提也。事者，一切有為諸法。斷所知障而知諸法之一切種智。佛獨證之菩提也。佛之菩提並通二者。故曰大菩提。至菩提之覺體。《俱舍論》以盡智及無生智二者當之。《唯識論》以大圓鏡智、平等性智、妙觀察智、成所作智當之。《智度論》以一切智、道種智、一切種智當之。密宗則以法界體性智、大圓鏡智、平等性智、妙觀察智、成所作智當之。
    《大方廣如來秘密藏經》曰。身之實性，是菩提實性。菩提實性，是心實性。心之實性，即是一切法之實性。覺是一切諸法實性。故名覺菩提。《大莊嚴法門經》曰。於一切眾生心法中。悉有菩提。何以故。若彼心無色，離色分別，體性如幻，彼此內外不相續者。是名菩提。《守護國主陀羅尼經》曰。善男子。欲知菩提。當了自心。若了自心。即了菩提。何以故，心與菩提。真實之相。畢竟推求。俱不可得。同於虛空。故菩提相，即虛空相。是故菩提無所證相。無能證相。亦無能所契合之相。何以故，菩提畢竟無諸相故。善男子。以一切法即虛空相。是故菩提畢竟無相。又曰。一切智智，及與菩提，從心而生。何以故。心之實性，本清淨故。綜合諸經所說。可知菩提不出一心。眾生一念之間。背塵合覺。即是菩提。道不在遠。行者勉之。
    中道。各宗所取不同。唯識宗以唯識為中道。三論宗以八不為中道。天台宗以實相為中道。華嚴宗以法界為中道。中者，不二之義。絕待之稱。雙非雙照之目也。《中論偈》云。因緣所生法。我說即是空。亦名為假名。亦是中道義。
    中道有四種。一，對偏中。對於大小學人斷常之偏病而說中道。謂之對偏中。二，盡偏中。大小學人有斷常之偏病。則不成中。偏病盡則中顯。謂之盡偏中。三，絕待中。對治偏病故有中。偏病既除。中亦不立。非中非偏。為度眾生而強名曰中。謂之絕待中。四，成假中。以有無為假。非有非無為中。曰非有非無。故說有無。如是之中。為成有無之假。故謂之成假中。見《三論玄義》。
    二邊者。一，有邊。謂世間一切事物。必假眾緣具足。和合而生。皆無自性。雖無自性。不得言無。故名有邊。二，無邊。謂世間一切事物。既假眾緣具足和合而生。本無自性。無自性則一切法皆空。不得言有。故名無邊。
    菩薩以無所得心依般若而得涅槃。三世諸佛亦以無所得心依般若而得無上菩提。菩提涅槃。原無二致。皆依般若而得。捨此般若無能得者。故《大般若經》曰。如來亦由修行般若波羅蜜多。能修行安住圓滿具足種種功德。故得無等等色。無等等受想行識。證無等等菩提。轉無等等法輪。度脫無量諸有情類。令獲殊勝利益安樂。又曰。過去未來現在諸佛。皆依般若波羅蜜多精勸修學。證得無上正等菩提。又曰。一切如來、應、正等覺。乘如是乘。行如是道。乃得無上正等菩提。此乘此道。當知即是甚深摩訶般若波羅蜜多。諸法自相空。即是阿耨多羅三藐三菩提。菩薩行般若作佛已。變涅槃為菩提。蓋涅槃是如如理，理必契智。菩提是如如智，智必冥理。涅槃是斷德，斷住一切煩惱惑業。菩提是智德。以平等智慧。照了一切諸法。通達無礙隨眾生根器大小說法。菩提涅槃。同為極聖所證二轉依果。以惑非智不斷。智非斷不圓。故《大般若經》曰。菩薩於菩提道及一切波羅蜜多已圓滿故。由一剎那相應妙慧。證得如來一切相智。爾時一切煩惱習氣相續永不生故。名無餘斷。則名如來、應、正等覺。如是二果。皆依般若波羅蜜多而得應就。
    【注】菩提智果。翻煩惱而復本有如如智性，乃即寂之照，涅槃斷果。翻生死而復本有如如理性，乃即照之寂，照真不變。則菩提之用彰。達妄本無。則涅槃之功著。《楞嚴經》曰。無始菩提涅槃元清淨體。以如來藏性。二果本具。故云無始。以本來不與妄染相應，故云元清淨體。
    《楞嚴經·資中疏》云。二轉依號者。不了一法界相。忽然起妄。由初迷真念動。以至不覺。翻此不覺。了本無生。即名為覺。此菩提之號，由不覺立也。由迷有生。生必有滅。翻此生滅。顯不生滅。此涅槃之號。對生滅立也。生滅既滅。更無所依。故名轉依。以真如為迷悟依。轉此迷依以為悟依。故名轉依。菩提涅槃。初非有異。但轉迷名無上菩提。轉有名大涅槃。以有故迷。以覺故空。是知菩提涅槃。因迷故有。如人因睡而有覺名。非本一真而有二果之異。
    《攝大乘論》云。轉依謂即依他起性對治起時。轉捨染分。轉得清淨分。
    《真際》云。轉依有二解。一云。依謂能依。體是依他性。與染淨二法而為所依。染即徧計性。淨即圓成性。轉謂改轉。有轉捨轉得二義。以修無分別智斷於二障。故能轉捨依他性上徧計染法。及能轉得依他性中圓成淨法。二云。依謂所依。體是真如。為生死涅槃之所依。故凡夫迷真。則受生死。聖人悟真。則證涅槃。轉亦二義。以修智斷障。轉依真之生死，得依真之涅槃。故名轉依。
    《成唯識論》云轉依位別。略有六種。一，損力益能轉。謂初二位由習勝解及慚愧故。損本識中染種勢力。益本識內淨種功能。雖未斷障種實證轉依。而漸伏現行。亦名為轉。二，通達轉。謂通達位由見道力。通達真如。斷分別生二障麤重。證得一分真實轉依。三，修習轉。謂修習位由數修習十地行故。漸斷俱生二障麤重。漸次證得真實轉依。《攝大乘論》說。通達轉在前六地有無相觀。通達真俗間雜現前。令真非真現不現故。修習轉在後四地純無相觀。長時現前。勇猛修習。斷餘麤重。多令非真不顯現故。四，果圓滿轉。謂究竟位。由三大劫阿僧企耶。修習無邊難行勝行。金剛喻定現在前時。永斷本來一切麤重。頓證佛果。圓滿轉依。窮未來際。利樂無盡。五，下劣轉。謂二乘位。專求自利。厭苦欣寂。惟能通達生空真如。斷煩惱種。證真擇滅。無勝堪能。名下劣轉。六，廣大轉。謂大乘位為利他故。趣大菩提。生死涅槃。俱無欣厭。且能通達二空真如。雙斷所知，煩惱，障種。證無上菩提涅槃。有勝堪能。名廣大轉。
    習氣為現行氣分熏習（熏者。熏發義。習者。數數義。數數熏發。如以香熏衣令染香氣也。真妄互熏。相續不斷。無明熏真如。使現染相。真如熏無明。使成淨用。謂之習熏。業識返熏無明。現行心境諸惑相資。謂之資熏。身口所現諸行。意所現思想。為現行法。其氣分留於真如或阿賴耶識者為種子。或習氣。此其作用。即名熏習。有三。一，名言熏習。第六識分別名字言說之識。由第七識傳送第八識成就染分之相。二，色識熏習。第六識分別眼根對境所生之識。由第七識傳送第八識成就染分之相。三，煩惱熏習。第六識所起貪瞋邪見。由第七識傳送第八識。成就染分之相）所成見惑過失之餘習也。大乘之妄惑。分現行與種子及習氣。三者。既斷惑之現行。且斷惑之種子，尚有惑之氣分而現惑相，是名習氣。


第四節 結讚功能

    第四節 結讚功能

    故知般若波羅蜜多。是大神咒。是大明咒。是無上咒。是無等等咒。

    故者。承前起後之辭。知者，喻義，覺義，了了自覺也。承上菩薩諸佛皆依此深般若而證涅槃，菩提。故知般若功用。不可思議。非復名言數量所能稱說。乃以四種咒義。別讚功能。《大般若經》曰。如是般若波羅蜜多。是大神咒。如是般若波羅蜜多。是大明咒。如是般若波羅蜜多。是無上咒。如是般若波羅蜜多。是無等等咒。如是般若波羅蜜多。是一切咒王。最上最妙。無能及者具大威力。能伏一切。不為一切之所降伏。
    咒者。願也。四種陀羅尼之一。陀羅尼者。梵語。此云總持。持善不失。持惡不生。總一切法。持無量義故名總持。亦譯遮持。能持能遮。持者持善，遮者遮惡也。
    【注】《智度論·五》。略謂。陀羅尼。秦言能持。或言能遮。能持者。集種種善法。而持令不散不失。譬如完器盛水。水不漏散。能遮者。惡，不善，根心生，能遮令不生，若欲作惡罪，持令不作，是名陀羅尼。又云。得。陀羅尼菩薩。一切所聞法。以念力故。能持不失。復次。是陀羅尼法。常逐菩薩。譬如間日瘧病。是陀羅尼不離菩薩。譬如鬼著。是陀羅尼常隨菩薩。如善，不善，律儀。復次，是陀羅尼持菩薩不令墮二地坑。譬如慈父愛子。子欲墮坑。持令不墮。復次。菩薩得陀羅尼力故。一切魔王、魔民、魔人，無能動，無能破，無能勝。譬如須彌山。凡人口吹。不能令動。是陀羅尼多種。一名聞持陀羅尼，得是陀羅尼者。一切語言諸法。耳所聞者。皆不忘失。復有分別知陀羅尼。得是陀羅尼者。諸眾生、諸法、大、小、好、醜。分別悉知。復有入音聲陀羅尼。菩薩得此陀羅尼者。聞一切語言音。不喜、不瞋。一切眾生，如恒河沙等劫，惡言罵詈，心不憎恨。是菩薩雖未盡漏。大智利根，能思惟除遣瞋心。作是念。若耳根不到聲邊。惡聲著誰。又如罵聲聞便直過。若不分別。誰當瞋者。凡人心著吾我。分別是非，而生恚恨。復次，若人能知諸言隨生隨滅。前後不俱。則無瞋恚。亦知諸法內無有主。誰罵誰瞋。若有人聞殊方異語。此言為好。彼以為惡。好惡無定。雖罵不瞋。若有人知語聲無定。則無瞋喜。如親愛罵之。雖罵不恨。非親惡言。聞則生恚。但以慈悲。息此諸惡。不生瞋心。復次，菩薩知諸法不生、不滅。其性皆空。若人瞋恚罵詈。若打若殺。如夢如化。誰瞋誰罵。復次，若有人如恒河沙等劫眾生，讚歎，供養衣食、臥具、醫藥、華香、瓔珞，得忍菩薩其心不動、不喜、不著。知種種供養恭敬。是皆無常。菩薩觀一切法如夢、如響。誰讚、誰喜。如是等相。名為入音聲陀羅尼。復有名寂滅陀羅尼。無邊旋陀羅尼。隨地觀陀羅尼。威德陀羅尼。華嚴陀羅尼。音淨陀羅尼。虛空藏陀羅尼。海藏陀羅尼。分別諸法地陀羅尼。明諸法義陀羅尼。如是等略說五百陀羅尼門。若廣說則無量。
    四種陀羅尼。一，法陀羅尼。謂諸菩薩得念慧力。持所聞法。經無量時。永不忘失。又名聞持陀羅尼。二，義陀羅尼。謂諸菩薩於諸法大、小、善、惡、分別。悉知無量義趣。永不忘失。又名分別知陀羅尼。三，咒陀羅尼。謂諸菩薩獲得如是總持咒願。悉皆靈驗也。華言咒。梵言陀羅尼。此特華梵雙標。就人釋。為佛菩薩之定力。能持神咒之功德。就法釋。神咒語句。總持無量之文義也（諸經中於此陀羅尼有五名。一，陀羅尼。二，明。三，咒。四，密語。五，真言。總持諸法。旋轉無礙。名陀羅尼。佛說陀羅尼。能淨一切蓋障。故謂之明。其義不異。曰咒者。佛法未入中國前。此土本有咒禁之術。陀羅尼能發神通。滿足一切行願。與咒禁相似。故譯為咒。凡夫二乘所不能知。故曰密語。如來所說。能顯諸法實相。絕諸戲論。真實不虛。故曰真言）。四，忍陀羅尼。忍即安忍。謂菩薩成就堅固之行，於所聞法得精進忍。讚歎不喜。罵詈不憎。又名入音聲陀羅尼。此四種陀羅尼。一為名持。二為義持。三為遮持。四為行持。法陀羅尼。以法為境。即能詮之名言也。以念慧為體。義陀羅尼體雖相同。而以所詮義為境。咒陀羅尼以定為體。以咒為境。忍陀羅尼以無分別智為體。以法為境。
    密宗所謂陀羅尼。專指咒陀羅尼。為佛菩薩從禪定所發之秘密言句。有多字、一字、無字之別。多字者。如本經所說。及楞嚴咒、大悲咒等。一字者。如密部之唵字吽字。無字者。如《圓覺經》云。有大陀羅尼。名為圓覺。《勝天王般若經》曰。眾法不入陀羅尼。過諸文字。言不能入。心不能量。是也。

    大神咒者。具大神力之陀羅尼。陰陽不測之謂神。除障不虛。名大神咒。
    大明咒者。明為咒之別名。佛於光中說陀羅尼。以大光明破眾生闇。鑑照無昧。名大明咒。
    【注】梵語尾儞。此云明。破闇為義。梵語漫怛羅。此云真言。真言能破煩惱闇障。故亦譯曰明。《大日經·疏》云。若心、口出者名真言。從一切身分任運生者。名之為明。

    無上咒者。無上。梵語阿耨多羅。是最勝義。窮理盡性。證得菩提涅槃。更無有法能出其上。名無上咒。
    無等等咒。無等等。梵語阿娑摩娑摩。超絕無倫之義。一切諸法。無能與等也。佛無與等。故曰無等。惟般若波羅蜜與佛相等。故名無等等。蓋般若勝義。佛所依止。為諸佛秘密心印。更無他法。能與倫比。名無等等咒。
    【注】《智度論》。無等名涅槃。一切有為法。無有與涅槃等者。涅槃有三。聲聞涅槃。辟支佛涅槃。佛涅槃。般若能與大乘涅槃故。名無等等。復次，諸佛法第一微妙。無能與等。無能及者。無可為比。般若波羅蜜能令眾生得是心故。名無等等。復次。無等名諸法實相。諸觀諸行。無能及者。故名無等。菩薩得是無等。能於眾生中生慈悲心。故名無等等。

    《略疏》於此有三釋。一，就法釋。除障不虛。名為神咒。智鑒不昧。名為明咒。更無加過。名無上咒。獨絕無倫。名無等等咒。二，約功能釋。一者。能破煩惱。二者。能破無明。三者。令因行滿。四者。令果德圓。三，就位釋。一，過凡。二，越小。三，超因。四，齊果。謂無等之位。互相齊等。故云無等等。《十地論》云。謂佛比餘眾生彼非等故。重言等者。此。彼。法身等故。何故不但說無等耶。示現正等覺故。《會要》云。以般若神力有破惑障之能。故曰神咒。有破智礙之能。故曰明咒。由般若力歷進諸位。成就萬行。至等覺無間道中。即因滿位也。此位滿時。更無極上之因。故曰無上咒。對上因行。即解脫道中萬德皆圓也。此果圓後。更無能等之德。與此相等。故曰無等等。以過凡故名為神咒。神猶聖也。般若神智。非凡有故。雖本智靈明。內外緣熏未具。無勢力故。故云過也。越小者。以羊鹿車人。雖有盡智。斷煩惱障出於界繫。不除無明故。不斷智障故。今甚深般若。以反無明。所以明也。超因者。牛車之人。雖二障俱離。一心顯照。因行未滿。猶有加故。今般若究竟。更無加上。故云無上。齊果者。謂果位相齊也。果位至極。名無等位。《宗鏡錄》云。豎無高蓋。故言無上。橫無儔例。故言無等。等於十方三世諸佛。故言無等等。

    能除一切苦。真實不虛。

    此總結功能也。能者。勝任義。除者。去義。以般若能去一切苦也。一切苦，義見前釋。真實不虛者。決定無虛妄義。佛為不妄語者。故所說皆真實義。般若妙用。了妄即真。決定息苦。故云真實不虛。所以除疑勸信也。《大般若經》曰。學此般若波羅蜜多大咒王時。於我及法雖無所得。而能證得無上正等菩提。
    【注】真實義有四。一，世流布真實義。世間之法。悉同其名。眾生見地即言是地。見火即言是火。終不言是水是風乃至見苦終不言樂。見樂終不言苦。雖於假名立相。然稱認皆同。是為世流布真實義。二，方便流布真實義。世間有智之人。先以心意籌量。隨宜方便。造作經書論義。以開導人。是為方便流布真實義。三，淨煩惱障真實義。聲聞緣覺以無漏道破諸煩惱。得無礙智。是為淨煩惱障真實義。四，淨智慧障真實義。聲聞緣覺得無礙智。未能顯發中道之理。名智慧障。佛菩薩斷此障。則中道之理自顯。是為淨智慧障真實義。見《菩薩善戒經》。


第二章 密說般若

上一页 目录 全文完

第二章 密說般若

    故說般若波羅蜜多咒。即說咒曰。揭諦揭諦。波羅揭諦。波羅僧揭諦。菩提薩婆訶。

    上文顯說般若。並以般若即咒。形容般若功能。此則承上而密說之。觀自在菩薩在般若會中因舍利弗之啟請。承佛印可而宣說者。亦即重演佛之密語也。
    此密說般若。是不思議境。體即真空。無異顯說。但恐顯說為人依文解義。依說起見。復執真空實有體相。遂成實法。還同生滅。致忘真空亦空之義。反生執著。復墮無明。故更密說。《大般若經》曰。一切法自性空。空性不應執著。如以智求智。智則應解。解即失真。起於照心。照則立境。隨照失體。反成影事。是以大智現前。翻為名相之境。永嘉云。不離當處常湛然。覓則知君不可見。今此密說般若。正使人情忘智泯。不假尋求。真空現前。倏然默證。踰於符契。故名之曰咒。即如來秘密真實不可思議之語。咒願眾生。如佛無異。是故持誦者。當空其心，而一其念。念念無間。如蜾蠃之祝螟蛉。自然冥妄起真。即凡成聖。或云。顯說令解生慧。滅煩惱障。密說令誦生福。滅罪業障。般若即咒。咒即般若。不分顯密。各具四悉檀益。
    【注】四悉檀者。悉。普也。徧也。檀。具云檀那。此云施。華梵並稱。悉檀義為普施。一。世界悉檀。又名樂欲悉檀。佛以人我等假名，隨順眾生所樂。說世界法（世謂遷流。界謂方位）。令聞者歡喜。二，各各為人悉檀。又名生善悉檀。佛視眾生機宜大小。宿根深淺。說各人所應之法。令發正信。增長善根。三，對治悉檀。又名斷惡悉檀。因病施藥。隨證對治。四，第一義悉檀。又名入理悉檀。佛見眾生機緣成熟。為說諸法實相。令入真證。

    經顯義理。咒宗秘密。義理可詮。秘密不可說故咒語古皆不翻。其義有五。一者。諸佛密語。惟佛與佛能相了解。二者。總持一一字句。含藏多義。如薄伽梵之具六義是。三者。或是鬼神王名。呼之敕以守護行者。四者。諸佛密印。如世間王官印信。無往不通。五者。是不思議力所加持。但能密誦。即獲大益。《靖邁心經疏》云。諸經咒詞。所有文字。皆為諸佛菩薩威力加被。一一字句。皆攝多義。若翻就此方言詞。或增或減。於義有闕。誦無良驗。或則別告鬼神及諸天旁生。所有語音。多非印度常詞。故諸咒例不翻華。此中含義至宏。與外道無義惡咒。但以聽聞而為究竟者不同。《賢首法師心經略疏》云。咒詞不可釋。以諸佛秘語。非因位所解。但當誦持。除障生福。不須強釋。如必欲知之。亦可略言。揭諦，此云去。意猶度也。即深慧之功能。揭，為行不可得義。諦，為一切諸法如如不可得義。乘如之行。是為真行。行者。無住之謂。故譯曰去。重言之者。自度亦度他也。波羅此云彼岸。亦譯究竟。圓滿最勝之義。生死為此岸。涅槃為彼岸。煩惱為中流。彼岸者。度所到之處也。僧。梵語僧伽。總也。眾也。和合之義。波羅僧揭諦者。自度、度他、同到彼岸也。菩提者。覺路。舊譯為道。新譯為覺。有事理二法。理者。涅槃。斷煩惱障而證涅槃之一切智是。為通三乘之菩提。事者。一切有為之諸法。斷所知障而知諸法之一切種智是。為諸佛之菩提。即所到之彼岸也。薩婆訶。此云成就。為一切真言結句。令成就正覺也。但既云密說。自不可以常義釋之。必也名言雙絕。理事兩忘。爍迦羅眼窺摸不著。方符咒義。一落心思。便成知見渣滓。為無明根本。無明一起。萬劫沈淪。一切苦厄。何由得度。行者當知狂心歇處。即是菩提。觀照之極。無得無證。言語道斷。心行處滅。心思絕則知見泯。知見泯則無明破。無明破則彼岸到。而般若之功用盡。
    【注】不思議力。即不可思議之力。不可思議者。理空非惑情所測。神奇非淺識所量。《淨名經慧遠疏》云。不可思議者。經中亦名不思議。通釋是一。於中分別。據實望情。名不思議。據情望實。名不可思議。諸經所言不可思議。約有五種。一，眾生不可思議。二，業力不可思議。三，龍力不可思議。四，禪定力不可思議。五，佛力不可思議。見《淨土論注》。
    爍迦羅。又作灼羯羅。斫迦羅。斫迦婆羅。此云金剛。有堅固精進之義。又翻為輪。
    知見二字當分釋。就意識曰知。就眼識曰見。覺了曰知。推求曰見。三智曰知。四眼曰見。皆為慧之作用。
    薩婆訶。真言結句。往往有之。惟諸經譯音不同。蘇婆訶。娑婆訶。娑縛訶。率縛訶。娑縛賀。馺婆訶。娑訶。音同字異。其義則有十一。一者。成就。二者。吉祥。三者。圓寂。四者。息災增益。五者。無住。六者。警覺。七者。圓滿。八者。散。九者。攝取。十者。究竟。十一者。本誓。此取成就之義。成就菩提之德也。
    咒語雖按梵音直譯。然各本亦有小異。什師譯本。菩提僧莎呵。法月譯本。與奘師譯本同。惟薩婆訶作莎婆訶。般若共利言譯本。揭諦作蘖諦。薩婆訶作莎婆訶。其餘亦同。智慧輪譯本。則作唵。——誐帝誐帝。播——囉誐帝。播——囉散誐帝。冒——地娑縛賀。法成譯本。作峨帝峨帝。婆囉峨帝。波囉僧峨帝。菩提莎訶。施護譯本。作怛［寧＊也］他。唵。誐帝誐帝。播囉誐帝。播囉僧誐帝。冒提莎訶。清高宗御書心經石刻本。在西湖聖因寺者。作答達鴉塔阿。噶得噶得。巴阿唎噶得。巴阿唎桑噶得。玻提娑訶。
    《大般若經》第六百卷後。有般若佛姆心咒曰。怛耶他。唵。伽帝。伽帝。缽囉伽帝。缽囉僧伽帝。菩提薩嚩訶。《大乘理趣六波羅蜜多經·二·護持國界品》。智慧波羅蜜多菩薩。說真言曰。南謨薄伽伐帝曳（二合）。揭帝揭帝。波羅揭帝。波羅僧揭帝。冒地莎訶。《陀羅尼集經·三》。般若大心陀羅尼咒曰。跢姪他。揭帝揭帝。波囉揭帝。波囉僧揭帝。菩提莎訶。均與本經咒詞相同。

    上來詮釋《般若波羅蜜多心經》竟。

    因說偈曰。

    輪迴生死事堪哀。　　　三界唯心萬法晐。
    兩執同空諸相泯。　　　無明了盡即如來。

    【注】偈。此云頌。梵語偈他。省云偈。按偈他。正音當作伽陀。《華嚴經疏》有四種。一，阿耨窣覩婆。不論長行與偈。凡滿三十二字即為一頌。二，伽陀。此云諷頌。三字四字五字七字八字九字不等。以四句為一偈。孤起直說。故名直頌。亦名不重頌。《大乘義章》云。一切四言五言七言九言不重頌者。皆名伽陀。三，祗夜。應前已說之散文。重頌以申明之。名曰應頌。亦曰重頌。四，縕馱南。此云集施。謂以少言集多義。施人誦習也。《百論疏》云。婆娑列四種偈。一者。以八字為一句。三十二字為一偈。此是結偈法。名阿[少/兔]吒闡。此云處中偈。《嘉祥法華義疏》。謂之首盧伽陀。二者。六字為句。名初偈。三者。二十六字為句。名摩羅。此云後偈。四者。六字以下為句之四句偈。名周梨荼。《嘉祥法華義疏》。皆謂之結句伽陀。
    輪迴。謂眾生無始以來。旋轉於六道之生死。如車輪之輾轉無窮也。《法華經·方便品》曰。以諸欲因緣。墜墮三惡道。輪迴六趣中。備受諸苦毒。《心地觀經》曰。有情輪迴生六道。猶如車輪無始終。《三昧經》曰。三界眾生。輪迴六趣。如旋火輪。《身觀經》曰。循環三界內。猶如汲井輪。《圓覺經》曰。一切世界。始終生滅。前後有無。聚散起止。念念相續。循環往復。種種取捨。皆是輪迴。又曰。當知輪迴。愛為根本。由有諸欲助發愛性。是故能令生死相續。欲因愛生。命因欲有。眾生愛命。還依欲本。愛欲為因。愛命為果。由於欲境。起諸違順。境背愛心。而生憎嫉。造種種業。是故復生地獄、餓鬼。知欲可厭。愛厭業道。捨惡樂善。復現天、人。又知諸愛可厭惡故。棄愛樂舍。還滋愛本。便現有為增上善果。皆輪迴故。不成聖道。是故眾生欲脫生死，免諸輪迴。先斷貪欲，及除愛渴。
    事者。對理之稱。梵語曰迦他。不生不滅之無為法曰理性。一切生滅有為法曰事相。堪者。可也。任也。哀者。悲也。哀愍眾生。悉令度脫也。界者。限也。別也。謂三界分限。各別不同。故名界也。一，欲界。欲有四種。一者。情欲。二者。色欲。三者。食欲。四者。淫欲。下極阿鼻地獄。上至他化自在天。男女相參。多諸染欲。故名欲界。二，色界。色即色質。謂雖離欲界穢惡之色。仍有清淨之色也。三，無色界。謂但有心識而無色質也。合欲界、色界、無色界謂之三界。
    梵語摩怛剌多。此云唯。有三義。一，簡別。二，決定。三，顯勝。云唯心者。一切諸法。惟有內心。無心外之法。亦云唯識。心有集起之義。集起諸法故云心。識有了別之義。了別諸法故云識。一心本具萬法。而能成立眾事。心性周徧。虛澈靈通。散之則應萬事。斂之則成一念。若善若惡。若聖若凡。無不皆由此心。《華嚴經》曰。三界無別法。唯是一心作。蓋世、出世間一切諸法。唯是真心所現。法唯心現。全法是心。心既圓融。法亦無礙。故曰。知一切法。即心自性。又曰。統觀法界性。一切唯心造。《華嚴經》就集起之義。而曰唯心。《唯識論》就了別之義。而曰唯識。其體則一。但亦稍有別。唯心之名。通於因果。唯識之稱。唯在因位。經義通因果。總言唯心。論說唯在因。但稱唯識。
    萬法者總晐萬有事理之語。三界唯心萬法晐者。謂一切法盡出於一心也。唐譯《華嚴經·三十一》曰。三界所有。惟是一心。晉譯《華嚴經·十》曰。心如工畫師。畫種種五陰。一切世間中。無法而無造。《大般若經·五百六十八》曰。於一切法。心為善導。若能知心。悉知眾法。《心地觀經·八》曰。心如畫師。能畫種種色故。心如僮僕。為諸煩惱所策役故。心如國王。起種種事得自在故。心如怨賊。能令自身受大苦故。晐者。兼覆之義。咸也。備也。空者。盡也。虛也。謂了達諸法無實相。自性本空。無我及我所也。《淨名經》曰。諸法究竟無所有。是空義。兩執同空者。二空理顯也。既以般若觀照而滅幻有。幻有滅盡。五取蘊（五取蘊者。謂取以為身假集故。以此五種取境起業，集聚有為，無為，有漏，無漏種，為來世因故。補特伽羅數取趣故。又名五受陰。以是眾生所受報法故。此五受陰。亦可通名為想。通名為識。以受想行三陰皆是識之心所。色陰即是識之相分故。亦可通名為行。以色受想識皆是遷流造作法故。亦可通名為色。以初是有對有表色。後四皆是無對無表色故。見《楞嚴文句》）。空。五取蘊空，則人執法執空。人執法執空，則諸相自泯。
    諸相者。諸者。眾義。相即色相。三界一切品類。洪纖妍醜。情與無情。及根塵諸法。各有形狀。此諸差別之事物形相。名為諸相。《淨名經》曰。法常寂然。滅諸相故。即諸相泯義。釋詁。泯。滅盡也。我相。人相。眾生相。壽者相。亦即一切相。《金剛般若波羅蜜經》曰。若見諸相非相。則見如來。又曰。離一切諸相。則名諸佛。能知一切相皆是虛妄。即不逐妄。即可見性。四相皆由執我而起。故四相實即一相。有廣狹二義。從狹義言。執五蘊色身為我。即是我相。凡夫皆有此執。由現在而計未來。起種種妄想。現在為我相。未來為人相。因互相對待也。再由此身。起盛衰苦樂之象。是眾生相。計五蘊色身命根不斷。是壽者相。此就自己五蘊計度分別而生之四相。更就廣義言之。計我即我相。與我對待者即人相。對象不一。即眾生相。相續不斷。即壽者相。要知四相皆從我見開出。開即四相。合即我相。我相從五蘊色身起執。四相空即我執空。又名人空。更進言之。法相。從法上起執。兩執同空。則法相亦空。又名法空。窮空到底。即空亦空。是即般若遣執之效。了者。訖也。畢也。盡也。止也。終也。竭也。即者。就也。餘均詳前注。
    如來者。修證之極果。云無明了盡即如來者。亦猶《楞嚴經》。明極即如來之義。誠以心佛眾生。雖在因在果。迷悟不同。理性所具。初無有異。如青銅作鏡。本體無殊。經磨治者光明。受污染者昏闇。既了無明。即復本性。憨山大師云。一切眾生。具有如來智慧德相。但以妄相顛倒執著而不證得。諸佛悟之而為普光明智。名佛知見。眾生迷之而為無明業識。生死根株。一見此心。當下是佛。《華嚴經》曰。心佛與眾生。是三無差別。一念心體。凡聖不二。具足十法界、十如是（不異名如。無非曰是。十法界各具十如是因果之法。一，如是相。相即相貌。相以據外。覽而可別。始自地獄。終至佛界。是名如是相。二，如是性。性即性分。性以據內。自分不改。始自地獄。終至佛界。性各不同。是名如是性。三，如是體。體即體質。由性相所合成。始自地獄。終至佛界。俱以色身而為體質。是名如是體。四，如是力。由體所生之力。力即力用。始自地獄。終至佛界。皆有力用功能。是名如是用。五，如是作。作即造作。由用所作之業。始自地獄。終至佛界。皆能運為造作。是名如是作。六，如是因。因即習因。始自地獄。終至佛界。善惡業因。皆由自種而生。習續不斷。是名如是因。七，如是緣。緣即緣助。始自地獄。終至佛界。各有緣起之法。助成習因。是名如是緣。八，如是果。果即習果。始自地獄。終至佛界。皆由習因習續於前。習果剋獲於後。是名如是果。九，如是報。報即報果。始自地獄。終至佛界。皆由習因習果而感其報。是名如是報。十，如是本末究竟。以上種種合而為一。具於一界。初相為本。後報為末。本末皆同。實相一理。平等無二。是名如是本末究竟）等法。諸佛眾生。心元平等。是名心無差別。十方諸佛。了悟十法界、十如是等法而成正覺。即是悟本心之所具。亦是悟眾生之所迷。迷悟雖殊。其體不二。是名佛無差別。九界眾生。各具十法界、十如是等法。本心所具之法。與佛之所悟。其體不二。是名眾生無差別。故眾生與佛。僅有迷悟之殊。本覺心源。原來不二。眾生自無始以來。為無明由藉。輪迴生死。不能自脫。一旦證悟。惑盡障消。真如顯現。即心是佛。猶如明鏡蒙塵。一經拂拭。光明瑩然。與初無二。故曰無明了盡即如來。此土恒言。舜何人也。我何人也。有為者亦若是。見賢思齊。事同一理固不可以凡濫聖。蹈大我慢。亦不可妄自菲薄。甘於暴棄。行者當知人身難得佛法難聞。古德有言。一口氣不來更從何處安身立命。趁此色身未謝之時。精進修持。爭取向上一著。蓮邦不遠。相期共證。

    復次，說偈迴向。
    般若甚深微妙法。　　我依聖教隨分釋。
    迴施功德利群生。　　同證菩提登極樂。
    【注】凡更端處曰復次。猶云再者。般若。甚深。義均見前。微妙者。法體幽玄曰微。不可思議曰妙。法者。梵語達摩。軌持之義。為通於一切之語。小者、大者、有形、無形、真實、虛妄、事物、道理，皆悉為法。《唯識述記》云。軌謂軌範。令物生解。持謂任持。不捨自體。依此義釋之有二。一者。自體。二者。軌則。兼攝有體無體。總賅萬有事理。蓋萬有事理。一一有自體。具軌則。故皆名法。乃至龜毛兔角。畢竟無者。亦名為法。以彼有無之自體與無之軌則也。萬法由因緣而生。為自然之法。因緣生之法。無有自性。無性故空。即以空為性也。萬法各有一空性。謂之一如。一者。不二義。如者。相似義。對萬而言曰一如。對妄而言曰真如。以大乘至極之義。說萬物之性相。則萬法是真如。真如是萬法。萬法指染淨諸法。真如指離染淨之實體。真如之體如水。萬法之相如波。波性即水。猶萬法之性即真如。水隨緣而現波相。猶真如之體。應緣而現萬法之相。《淨名經》曰。萬法即真如。由不變故。真如是萬法。由隨緣故。我有主、宰二義。主有自在力。宰有割斷力。主是我體。宰是我所或我用。主是俱生我。無分別故，屬第七識我。宰是分別我。有割斷故，屬第六識我。我有六種。一，執我。謂分別俱生。在於凡位。二，慢我。謂但俱生。在有學位。三，習氣我。謂二我餘習。在無學位。四，隨世流布我。謂諸佛等隨世假稱。五，自在我。謂八自在等。如來後得智為性。六，真我。謂真如常樂我淨等。以真如為性。見《宗鏡錄·六十五》、《六十七》。依。說文倚也。又從也。聖教。猶言正教。《宗輪論述記》云。聖者。正也。與正理合為聖。又契理通神。名之為正。此所說教。名為聖教。《圓覺經》曰。聞此聖教。隨順開悟。《解深密經·一》曰。已善奉行如來聖教是也。隨分者。隨應有之分限也。釋者。解釋開演之義。
    迴施者。以此功德平等共有迴向施與一切眾生也。功者。福利之功能。此功能為善行之德。故曰功德。《大乘義章》云。功謂功能。善有資潤福利之功。故名為功。此功是其善行家德。名為功德。《天台仁王經疏》云。施物名功。歸己名德。《勝鬘經》曰。德者。得也。修功所得。故名功德也。利者。利益。《法華文句·六》云。自益名功德。益他名利益。群者。眾也。群生即眾生。《華嚴經·普賢行願品》曰。悉除一切惡道苦。等與一切群生樂。《無量壽經》曰。求清白之法。以惠利群生。利益有情。拔苦與樂。菩薩利他之行也。
    同者。共同。以無漏正智，契合於所緣之真理曰證。二乘極果及初地以上乃至十地等覺為分證。妙覺為滿證。菩提義亦見前。極樂即西方淨土之極樂國。阿彌陀佛之國土也。又作安養。安樂。無量清淨土。無量光明土。無量壽佛土。蓮華藏世界。密嚴國。清泰國等。梵語須摩提。此云妙樂。諸事具足圓滿。惟有樂而無苦也。《阿彌陀經》曰。從是西方過十萬億佛土。有世界名曰極樂。其土有佛。號阿彌陀。今現在說法。舍利弗。彼土何故名為極樂。其國眾生。無有眾苦。但受諸樂。故名極樂。《無量壽經》曰。法藏菩薩。今已成佛。現在西方。去此十萬億剎。其佛世界名曰安樂。《稱讚淨土經》曰。於是西方。去此世界過百千俱胝那庾多佛土。有佛世界名曰極樂。其中世尊。名無量壽及無量光。《鼓音聲經》曰。西方安樂世界。今現有佛號阿彌陀。其國號曰清泰。《觀音授記經》曰。西方過此億百千剎。有世界名安樂。其國有佛。號阿彌陀。《秘藏記》云。華藏世界者。最上妙樂在其中。故曰極樂。當知極樂與華藏。雖名異而非異所。《密嚴經》曰。依自難思定。現於眾妙色。色相無有邊。非餘所能見。極樂莊嚴國。世尊無量壽。是知華嚴之華藏世界。密教之密嚴國。皆極樂國之異名。登詳前注。

    願以此功德。　　普及於一切。　　我與諸有情。　　皆共成佛道。
    亡過諸先靈。　　世琪及永洪。　　仗此勝妙因。　　超生極樂國。
    【注】梵語尼坻。此云願。志求滿足也。《法界次第》云。自制其心。名之曰誓。志求滿足。故云願也。有總願、別願。總願，如四弘誓。別願，如藥師佛十二願，千手觀世音之六願、十願，普賢之十願，阿彌陀佛之二十四願、四十八願。釋迦牟尼佛之五百願。
    普。博也。大也。徧也。及。逮也。至也。普及。猶云徧至也。於。語辭。與于通。于。在也。指定之辭。
    一切。晐羅事物之稱。《玄應音義》云。說文云。一切。普也。普即徧具之義。一以普及為言。切以盡際為義。與。及也。偕也。梵語薩埵。此云有情。有情識故。又情者。愛也。能有愛生故。舊譯作眾生。
    皆。俱也。同也。統括之辭。共。同也。皆也。合也。公也。成。就也。畢也。凡功卒業就謂之成。佛道者。通於佛之道路。梵語菩提。新譯曰覺。舊譯為道。道者。通義。圓通無礙也。在因則到於佛之萬行。在果則無上正等正覺。《法華經·方便品》曰。是諸世尊。皆說一乘法。化無量眾生。令入於佛道。
    亡。失也。過。往也。已往曰過。先靈。先世祖先之神識也。
    世琪。姓許氏。為止菴原配。賦性貞毅。言行不苟。逝世時年六十二。怛然奄化。無諸痛苦。越四日大斂。四體柔軟。面含笑容。余以願力。助其往生。
    永洪。為止菴次子。生而岐嶷。性不好弄。童稚即如成人。聰穎好學。自小學至大學。考試皆列前茅。性慈善。乘車遇御者老弱，即給資遣之去，而步行到校。生平不作妄語。待朋友尤誠懇。一日遇同學與相戲。出不意推墮路軌中。傷手部大出血。醫者以釘釘之。始可縫合。痛苦劇甚。面不改容。其母詢推者姓名。堅不肯告。曰。知之徒多怨。不必道也。其堅忍能容如此。事親孝。其母患[(病-丙)+扁]。強起侍疾日久無倦意。至臨歿前夕猶然。其卒也。以肺部及胃出血死。得疾之由。則以應當時政府強迫軍訓。受不合理之劇烈勞動。得病回來。正值倭寇內侵。隨余奔走道途。失於調理。終至不起。余有詩八絕悼之云。
    一生行事率天真
    三育無慚智勇仁
    跖壽顏夭天夢夢
    更從何處說前因
    福虛吾憶仲任語（善人之命不長，惡人之命不短。見王充《論衡》）
    至孝如何不永年
    熱血滿腔含淚逝
    臨危辭母祝安全
    巍科高第神明瘁（先考味仁公於清光緒癸卯以第一人成進士。入詞林。不久以腦溢血逝世）
    卅載思親淚未乾
    太息斯兒同一轍（兒高中畢業後，應會考列甲等）
    有才無命我心酸
    同時達者多先逝
    後死原知業未消
    蕙折可憐嗟短命
    不堪身世日蕭條
    國危自合教民戰
    絕臏何能成士材（九一八後。政府勵行軍訓。以下級軍官任教。不諳教育方法。但以軍隊劇烈動作。令學生作苦。體弱者多被折磨以死）
    我為宗邦重歎息
    不應戕賊好人才
    清寒省識衰親苦
    儉讀尤難秉性真
    今日只餘書劍在
    每展遺挂倍傷神
    生死相逢一日中（兒生於戊午十二月十七日巳時。歿於戊寅十二月十七日酉時。在世適滿二十歲）
    廿年光景太匆匆
    劇憐生小岐嶷甚
    一現曇華萬事空
    轉劫似聞已入仙（己卯冬至前夕。夢中聞豐隆聲。見天際雲開。兒飄然御風冉冉上。旁一人告余曰。此轉劫也。汝行亦往耳。方欲有語。已瞿然醒矣。餘音猶在耳也）
    九原待我共昇天
    傷心莫說人間事
    說到人間總黯然
    兒平日不好茹葷。出於自然。歿日適為先母忌日。以素菜祭。兒強起與祭。最後一飯。亦未近葷辛。觀其去來之跡。非有夙根者不能。吾所以詳述之者。以兒之夭亡。頓起余諸行無常之感。為詮注本經發起因緣。可謂以鳩摩羅浮多（鳩摩羅。此云童。八歲以上乃至未娶者之總名。浮多。此云真。見《玄應音義》）導我於善道者也。
    仗，憑依也。此，斯也。指定之辭。勝因，殊勝之善因也。妙因，絕妙之行因也。
    超，越也，不囿於常格也。生，往生也。去娑婆世界往阿彌陀如來之極樂淨土謂之往。化生於彼土蓮華中謂之生。餘均詳前注。

    謹以至心。發大誓願。
    【注】謹，說文，慎也。玉篇，敬也。廣韻，絜也。增韻，毖也。專也。重也。易乾卦。庸行之謹。至。猶極也。至心。至誠之心也。《金光明經文句·二》云。至心者。徹到心源。盡心實際。故言至心。發。廣韻，起也。大。猶弘也。梵語僧那。此云誓。尼坻，此云願。天台云。廣普之緣謂之弘。自製其心謂之誓。志求滿足乃稱願。《萬善同歸集·四》云。發大願者。萬行之因。能長慈悲。不斷佛種。大事成辦。所作剋終。成道利生。皆因弘誓。

    我於娑婆無所戀　　　求成佛道度眾生
    盡化煩惱作菩提　　　徧虛空界成淨土
    止菴居士發願竟
    【注】於者。在也。指定之辭。
    娑婆。梵語。新作索訶。此云能忍。堪忍之義。此土眾生堪忍眾苦不肯出離也。《法華文句》云。娑婆，此翻忍。其土眾生安於十惡。不肯出離。從人名土。故稱為忍。《法華玄讚》云。梵云索訶，此云堪忍。諸菩薩行利樂時。多諸怨嫉。眾苦逼惱。堪耐勞倦而忍受故。《悲華經》曰。云何名娑婆。是諸眾生忍受三毒及諸煩惱。故名忍土。亦名雜會。九道共居故。《西域記》云。索訶世界。三千大千國土。為一佛化攝也。
    無，不有也。所，指示事物之辭。戀，慕也。心所係念而不釋也。戀慕執著諸可意境而不捨離也。
    求。取也。索也。度。與渡通。過也。自此岸達彼岸也。
    梵語僕呼繕那。或薩多婆。此云眾生。摩訶衍云。意及意識。一切眾染合集而生。故名眾生。《同性經》曰。佛言。眾生者。眾緣和合。名曰眾生。所謂地水火風空識名色六入因緣生。《楞伽經》曰。此眾生者。無明為本。依愛而住。以業（身口意）為因。《法鼓經》曰。萬法和合施設。名為眾生。《大乘義章》云。依於五陰和合而生。故名眾生。又云。多生相續。名曰眾生。《般若燈論》云。有情者數數生。故名眾生。《法華文句·四》云。處處受生。故名眾生。
    盡，終也，竭也，達於極也。化，自然之變易也。荀子正名。狀變而實無別而為異者謂之化。注。化者，改舊形之名。
    梵語吉隸舍。此云煩惱。貪欲、瞋恚、愚癡等諸惑、煩心惱身也。《智度論》云。能令心煩能作惱故。《大乘義章》云。勞亂之義。名曰煩惱。《唯識述記》云。煩是擾義。惱是亂義。擾亂有情。故名煩惱。又名蓋。覆蓋之義。覆蓋行者清淨信心。不得開發也。又名漏。煩惱現行。令心連注流散不絕也。作。為也。
    梵語菩提。此云道。肇師云。道之極者稱曰菩提。秦無言以譯之。後代諸師。皆譯為道。以大論翻為佛道故。《守護國界主陀羅尼經》曰。善男子。欲知菩提。當了自心。若了自心。即了菩提。何以故。心與菩提真實之相。畢竟推求俱不可得。同於虛空。故菩提相。即虛空相。是故菩提無所證相。無能證相。亦無能所契合之相。何以故。菩提畢竟無諸相故。善男子。以一切法。即虛空相。是故菩提畢竟無相。又曰。此虛空性。即心性故。如其心性。即菩提性。《華嚴經》曰。若能善用其心。即獲一切勝妙功德。凡夫由昧心源。故隨妄念。能於妄念深照性空。名解大道。化煩惱作菩提者。如昔人云。觀婬怒癡。相同水月。了染淨體。性如虛空。遇順無著。遇違不瞋。於惡境界。得解脫門。
    徧。匝也。周也。《入楞伽經》曰。梵語剎尼迦。名之為空。或呿提。秦云虛空。《涅槃經》明虛空喻。立三義。一，無變易。亙古騰今。時移俗化。惟此虛空。常無變易。二，無邊際。物分表裏。空無內外。故無邊際。三，無罣礙。物體質礙。空性虛通。《釋摩訶衍論》。虛空十義。一，無障礙義。諸色法中無障礙故。二，周徧義。無所不至故。三，平等義。無簡擇故。四，廣大義。無分際故。五，無相義。絕色相故。六，清淨義。無塵累故。七，不動義。無成壞故。八，有空義。滅有量故（為有之空）。九，空空義。離空著故（為空之空）。十，無得義。不能執取故。《大乘義章》云。虛空有體有相。體則周徧。相則隨色彼此別異。虛空界者。謂眼所見之大空也。《中阿含經》曰。譬如月無垢。遊於虛空界。《智度論》云。虛空界無量諸佛土。《楞嚴經》曰。空生大覺中。如海一漚發。有漏微塵國。皆依空所生。
    欲知淨土為何。應先明性土相土。法性之理。非穢非淨。非廣非狹。猶如虛空。徧滿於一切處。是曰性土。如常寂光土是也。淨土對於穢土而言。二者均屬相土。隨眾生心量所現而有淨穢差別。淨土為金銀琉璃所成。種種莊嚴。且無四趣（修羅、畜生、餓鬼、地獄）五濁（劫濁、見濁、煩惱濁、眾生濁、命濁是名五濁。亦名五滓。亦名五渾。劫濁為總。餘四濁為別。劫，梵語具云劫波。此云分別時節。住劫中人壽二萬歲時為始。初時濁輕。末法澆薄。眾生競造惡業。濁遂增長。至減劫人壽減至三十歲時。飢饉災起。減至二十歲時。疾疫災起。減至十歲時。刀兵災起。世界眾生。無不被害。謂之劫濁。劫濁無別體。但約四濁立此假名。見濁以身見、邊見、邪見、見取、戒禁取之五利使為體。迷於四諦理性而起。其性銳利。故名利使。眾生迷於見惑。不修善道也。煩惱濁以貪、瞋、癡、慢、疑之五鈍使為體。迷於世間事物而起。其性闇鈍。故名鈍使。眾生緣諸愛欲。慳貪鬥諍。惱亂心神也。眾生濁亦無別體。攬五鈍五利之十使所應受果報。假立此名。眾生造作惡業，自受其果也。命濁以連持色心為體。人生壽命。由增而減。以惡業故。摧年促壽也。《楞嚴經·四》以空見不分，有空無體，有見無覺，相織妄成，為劫濁。故色陰破即超劫濁。以無色則無空。無空則見無所織也。以身搏四大為體。見、聞、覺、知。壅令留礙。水、火、風、土，旋令覺、知相織妄成，為見濁。故受陰破即超見濁。以無受即無搏。無搏則性大不織也。以性發知見。容現六塵。離塵無相，離覺無性，相織妄成，為煩惱濁。故想陰破則超煩惱濁。以無想則六識無用。惟根與塵。不生煩惱也。以生滅不停，知見每欲留於世間，業運每常遷於國土，相織妄成，為眾生濁。故行陰破即超眾生濁。以無行則無生滅。無生滅則識想盡而輪轉息也。以見聞元無異性，眾塵隔越，無狀異生，性中相知，用中相背，同異失準，相織妄成，為命濁。故識陰破即超命濁。以此濁以第八識體用相織為體。識陰破則色心不能連持。命根即斷也。與餘經所說五濁不同）等之濁穢者。如西方之極樂世界。穢土為瓦礫土石所成。充滿雜穢。如娑婆世界。淨、穢二土皆有報土化土之別。諸佛如來。歷無數劫。修習無量善根。以自己修因所感。自在無礙。稱性受用者。為自受用報土。對初地以上所現。由他機所感者。為他受用報土。應化身所居曰化土。佛菩薩為度凡夫二乘而變現之國土也。極樂世界為報土，抑為化土。人異其說。天台、淨影謂為化土。道綽、善導謂為報土。慈恩謂兼報化二土。若登地菩薩。各見他受用土。若地前便見化土。化土諸佛平等。無有優劣。若報土者。隨眾生現而有差別。
    《涅槃經》曰。一切善業。皆淨土因。一，修戒為因。遠離十惡。修行十善。自持淨戒。二，修施為因。施病醫藥。造立僧房。造像立塔。與持戒人及說法者種種供養。三，修慧為因。書寫經卷。乃至一偈。所受讀誦。為他演說。四，護法為因。守護正法。不謗方等。《淨名經》維摩詰言。菩薩成就八法。於此世界行無瘡疣。生於淨土。何等為八。饒益眾生而不望報。代一切眾生受諸苦惱。所作功德盡以施之。等心眾生。謙下無礙。於諸菩薩視之如佛。所未聞經聞之不疑。不與聲聞而相違背。不嫉彼供。不高己利。而於其中調伏其心。常省己過。不訟彼短。恒以一心求諸功德。是為八。
    東、西、南、北、四維、上、下。十方皆有淨土。而獨宗西方者。法藏願力。攝引往生故。娑婆教主。金口親宣故。華藏、密嚴。名異實同故。十方諸佛。同所護念故。極樂蓮邦。非三界攝故（地居故。非色界。有形故。非無色界。無欲故。非欲界。故云非三界攝）。阿彌陀佛。於此界眾生。偏有因緣故。普賢願王。導歸極樂故。十方佛國。境寬則心昧。專志西方。境狹則願切故。
    吾既發願竟。檢王日休居士《龍舒淨土文·四》云。祝變吾國，以至十方濁惡世界，皆為清淨極樂世界。喜古德已先我發願。願盡未來際，一切有情，離苦得樂，咸同斯願。
    止菴者。居士自號。幼讀時名祖恩。求學時名祖琛。伯澄。表字也。沙羅門多伽。吾師貢噶呼圖克圖所命也。名者。實之賓也。賓固非實。實亦非有。分別妄想。眾緣和合。依世俗義。假與施設。時政尚質。則留止菴一名以行世而已。恒沙劫來。吾之入胎出胎。不知凡幾。吾名亦不知凡幾。四大皆空。五蘊非實。即此止菴二字。他日者亦同歸於煙消雲滅。不應執著。亦無可執著也。
    止者。已也。息也。《廣韻》。止。停也。足也。易艮卦。艮。止也。時止則止。時行則行。老子《道德經》。知足不辱。知止不殆。莊子《德充符》。人莫鑒於流水而鑒於止水。惟止能止眾止。庚桑楚。知止乎其所不能知。至矣。《大學》云。知止而後有定。定而後能靜。靜而後能慮。慮而後能得。居士一生行事。避熱就冷。辭尊處卑。與世無爭。與人無忤。就世間法論。藉止以藏名拙。就出世法論。藉止以斷煩惱。梵語奢摩他此云止。靜息動心。止心於一處也。《佛地論》云。止謂三摩地。僧伽摩羅言。止者。諸結永盡。《起信論》云。止謂止一切境界相。隨順奢摩他觀義。《圓覺經》曰。善男子。若諸菩薩。悟淨圓覺。以淨覺心。取靜為行。由澄諸念。覺識煩動。靜慧發生。身心客塵。從此永滅。便能內發寂靜輕安。由寂靜故。十方世界諸如來心。於中顯現。如鏡中像。此方便者。名奢摩他。風雨如晦。雞鳴不已。雖不能至。心嚮往之。
    菴。亦作庵。隱遁者所居之茅屋也。《廣韻》云。菴。小草舍也。劉熙釋名云。草圓屋曰蒲。又謂之庵。庵。奄也。所以自奄覆也。《釋氏要覽》曰。西天僧俗修行者多居庵。
    居士之名。始見於《禮玉藻》。《居士錦帶》。鄭康成注。道藝處士也。梵語迦羅越。此云居士。《淨名經》慧遠疏云。在家修道。名為居士。《法華玄贊》云。守道自恬。寡欲蘊德。名為居士。在印度除王及王臣婆羅門種。其餘在家白衣。皆為居士。白衣者。在俗未出家之人。《涅槃經疏·十四》云。西域俗尚穿白。故曰白衣。《淨名經·方便品》曰。雖為白衣。奉持沙門清淨律行是也。
    發願發起誓願也。竟，終也。餘均詳前注。
    《般若波羅蜜多心經詮注·卷三·下》終

    《三世諸佛所說護法陀羅尼》（磧砂藏第五十八冊珍字，句讀另據《一切經音義·八》校正）

    三世諸佛。為護正法。說陀羅尼。擁護天王及人王等。令護正法久住世間。與諸有情作大饒益。陀羅尼曰。
    呾姪他（一）阿虎洛（二）屈洛罰底（三）虎剌拏莎窶荼（四）者遮者遮折尼（五）阿奔若剎多剎多（六）剎筵多剎也莎訶（七）陝末尼羯洛（八）鄔魯鄔魯罰底（九）迦邏跋底迦（十）阿鞞奢底尼莎剌尼（十一）祛闍祛闍末底（十二）阿罰始尼罰尸（十三）罰多罰多奴娑理尼（十四）部多奴悉沒栗底（十五）提罰多奴悉沒栗底莎訶（十六）
    天王當知。此大神咒。能令一切天、龍、藥叉、徤達縛、阿素洛、揭路荼、緊捺洛、莫呼洛伽、人、非人等一切有情。皆得安樂。此大神咒。三世諸佛。為護正法。及護天。王及人王等。令得安樂。以方便力而宣說之。是故天王及人王等。為令正法久住世故。自身眷屬得安樂故。國土有情無災難故。各應精勤至誠誦念。如是。則令怨敵、災難、魔事、法障皆悉消滅。由斯正法久住世間。與諸有情作大饒益。
    【注】以上陀羅尼自《大般若波羅蜜多經·五百七十一卷·第六分·無所得品第九》恭錄。

上一页 目录 全文完