封面

 《般若波罗蜜多心经诠注》
周止庵 著
 中华佛典宝库录入 2006年1月28日


目 录

缘起、凡例、注解要目
略疏原序、科文、异译名称
卷一·经文
卷二·求加被偈
  第一篇 总释名题
    第一章 经题
      第一节 释名
      第二节 辨体
      第三节 明宗
      第四节 论用
      第五节 判教
    第二章 人题
卷三·上
  第二篇 正释经文
    第一章 显说般若
      第一节 因人显法
        第一项 能修之人
        第二项 所修之法
        第三项 观行境界
        第四项 修证功能
卷三·下
      第二节 正示法空
        第一项 明蕴空
        第二项 显空德
          第一款 总标
          第二款 别释
            第一目 三科
              第一 五蕴
              第二 十二处
              第三 十八界
            第二目 十二因缘
            第三目 四谛
            第四目 智得
      第三节　显彰妙果
        第一项 明菩萨得涅槃
        第二项 明诸佛得菩提
      第四节 结赞功能
    第二章 密说般若


《般若波罗蜜多心经诠注》

缘起、凡例、注解要目

  《般若波罗蜜多心经诠注》
            周止庵居士著述

    缘起

    世间一切宗教，以佛教为最奥衍广博。止庵具缚凡夫，生际末劫，终日衣食于奔走，绝少与大德长老参究机会，何敢以一知半解，妄谈注经。贻佛头著粪之诮。所以有此一著者，因缘所系，可得而言。余家居古越。高曾以来。代崇佛教，先王母倪太夫人长年茹素，持名甚虔。余幼时习闻，欲究其义苦无师承。光绪丁酉，丁本先生妣徐太夫人之忧，营建水陆道场于大善寺。住持以《楞严经》一帙，赠先嗣父味仁公。侍读及之，喜其文义，是为余知读大乘经典之始。民国三年，于役苏州，友人王君复以《楞严经》见惠，夙习所熏，欢喜赞叹。嗣后涉历所至，行筴中不离梵典。在天津时，与上方山兜率寺沙门清池上人游，研讨更切。以《般若波罗蜜多心经》辞约义丰，撷《大般若经》六百卷之菁华，观世音菩萨悲愿所感，斯土流传，历久弥广。而白衣诵持，大多莫详其义，甚至于经中照见五蕴皆空句，连上文时字并读，句逗未明，遑论义解，窃尝心焉病之。历览古德著述，陈义高者如窥基法师之《心经幽赞》多陈法相，非初机学者所能领悟。略者如朱石君居士之《心经注解》，寥寥数章，稍读内典者，又不足以餍其求知之欲。倭难既起，避兵沪渎。次儿永洪，以军训内伤肺部，于民国二十七年十二月十七日酉刻咯血死。属纩时神志清明，强起与其母诀。余示以出世之恉，点头领会。余亦了悟世缘如幻。众生沉迷生死之苦。遂发愿诠注心经。参考窥基法师之《心经幽赞》，靖迈法师之《心经疏》，贤首法师之《心经略疏》，智圆法师之《心经疏》，宏赞法师之《心经添足》，宗泐法师、如屺法师之《心经注解》，德清法师之《心经直说》，智旭法师之《心经释要》，紫柏老人之《心经说》，续法法师之《心经解》。并世大德，如太虚法师之《心经浅说》，圆瑛法师之《心经讲义》，应慈法师之《心经浅说》，韩德清居士之《心经略赞》，季圣一居士之《心经随闻记》，丁福保居士之《心经详注》，李翊灼居士之《心经密义述》，温光熹居士之《心经演蕴》。亦复多所取资。融贯百家，惟求其是。宗派门户之见不敢存，片词只义，凡可以阐明经恉者不敢略。譬如得食，不欲以甘者自私，将以导引初机同登觉路。凡数经修改，历时十有四载，诠注合计，都十九万余言。居士林康甫世讲读之，以为可备初学参稽之需，怂恿付梓。因叙其缘起如此。

    周止庵

    再版凡例

    一、诠注以诠为主。首列经文，以宗经也。次列诠文，以释经也。名相法数，非诠所能尽者，以注明之。注有未尽者，以复注详之。注与复注，有时失之繁复，则以意在引导初机，故于介绍佛学常识，不厌求详。
    二、注引经论，随时注明出处，用备读者翻阅原文，更求深造。
    三、诸经论外，多节取法云法师之《翻译名义集》，玄应法师、慧琳法师之《一切经音义》，希麟法师之《续一切经音义》，一如法师等之《三藏法数》，丁福保居士之《佛学大辞典》。读者欲详始末，可检本书。
    四、注引经论，惟取简称。如《大般若波罗蜜多经》简称为《大般若经》，《大智度论》简称为《智度论》，《瑜伽师地论》简称为《瑜伽论》，《显扬圣教论》简称为《显扬论》。余可类推。
    五、各经译名，新旧不同。如《华严经》之道种智、一切种智，《大般若经》作道相智、一切相智。本书行文，概依《大般若经》，其引用经论及古德疏解者，则各仍原文。
    六、学佛之道，首在遣执。世尊说法四十九年，更无一字可得。达摩西来，不立文字，直指人心，见性成佛。故诸法实相，言忘虑绝，当无得无证之时。言语道断，心行处灭。一涉思惟，即落知见。知见愈精，去道愈远。《楞严经》曰，知见立知，即无明本。《金刚经》曰，知我说法如筏喻者，法尚应舍，何况非法。读者当知佛说十二部经，亦不过为渡津舟筏。何况末学诠注，如蠡测海。宋永明延寿禅师云，切不可迷性徇修，执权害实，弃本逐末，认妄遣真，据世谛之名言，执无始之熏习，将言定旨，立解明宗，一向合尘，背于本觉。吾深望读此经者，以诠注为筌蹄。不可执著文字，自堕理障。过江须用筏，到岸不需船，行者勉之。
    七、不慧志在潜修，夙以名闻为惧。初版行世后，承各方大德题赞之词，愧不敢当，故未刊载。惟为启示读者修学方便，于卷首补录贤首法师略疏自序一通，略加注释。古德所诏示者，即末学所师承，冠之简端，用示私淑。
    八、杨仁山先生云，《心经》以二百六十余言，摄尽六百卷般若妙义。果能自浅而深，澈见真空实相。则一大藏教，无不从此流出。所谓般若为诸佛母也。读者受持此经，当作难遭难遇之想。止庵末学钝根，此次再版，参附臆见颇多，深恐所诠有误，尚祈大德长老赐以教正。

    古今注解要目

唐代
    心经幽赞 释窥基
    心经疏 释靖迈
    心经略疏 释法藏
    心经疏 释慧净
    心经赞 释圆测
    心经略疏 释明旷

宋代
    心经注 释提婆
    心经疏 释智圆
    心经疏诒谋钞 释智圆
    心经幽赞添改科 释守千
    心经幽赞崆峒记 释守千
    心经略疏显正记 释仲希
    心经略疏连珠记 释师会
    心经注 释道隆

明代
    心经指掌 释元贤
    心经际决 释大慧
    心经论 释大慧
    心经一贯疏 释益证
    心经注解 释宗泐 如玘
    心经小谈 释贯衡
    心经正眼 释大文
    心经发隐 释正相
    心经开度 释弘丽
    心经注解 释真可
    心经直谈 释真可
    心经要论 释真可
    心经说 释真可
    心经说 释洪恩
    心经直说 释德清
    心经释要 释智旭
    心经添足 释弘赞
    心经贯义 释弘赞
    心经斫轮解 释费隐通容
    心经文句 宋濂
    心经释义 谢观光
    心经释疑 谢观光
    心经提纲 李贽
    心经释略 林兆恩
    心经概论 林兆恩
    心经注解 诸万里
    心经注解 何道全

清代
    心经事观解 释续法
    心经理性解 释续法
    心经句解 释净挺
    心经论 释函是
    心经请益说 释道需
    心经注释 释大颠
    心经略疏小钞 钱谦益
    心经说 朱圭
    心经注疏 仲之屏
    心经汇纂 孙念劬
    心经解 徐昌治
    心经大意 王起隆

近代
    心经浅注 释太虚
    心经义疏 释倓虚
    心经讲义 释倓虚
    心经要解 释显慈
    心经讲解 释兴慈
    心经浅说 释应慈
    心经直指 释傅晟
    心经笔记 释月溪
    心经讲义 释圆瑛
    心经讲义 释慧三
    心经讲义 释南亭
    心经讲录 释守培
    心经精义 济阳破衲
    心经显诠 陈子彝
    心经通俗解 证平
    心经释义 骆岫青
    心经浅说 许止净
    心经口义记 王弘愿讲 杜腾英记
    心经新疏 季圣一
    心经随闻记 季圣一讲周德弥季胜灵记
    心经分段贯摄 王骧陆
    心经略赞 韩德清
    心经密义述 李翊灼
    心经笺注 丁福保
    心经详注 丁福保
    心经读 欧阳渐
    心经演蕴 温光熹
    心经浅说 张炳桢
    心经集解 胡连玉
    心经简注 马圻源
    心经诠注　 周止庵

日僧注解
    心经秘键 释空海
    心经述义 释智光
    心经释 释最澄
    讲演心经义 释源信
    心经解 释宗纯
    心经注解 释圆耳
    心经口谈 释性潜
    心经止啼钞 释传尊
    心经毒语注 释圆慈
    心经秘键略注 释觉鍐
    心经秘键开宝钞 释道范
    心经秘键闻书 释杲宝
    心经秘键开藏钞 释赖瑜
    心经讲义 吉祥真雄

各家总注
    《心经三注》 唐释慧忠。宋释道楷。怀深。
    《心经解义节要》 唐释法藏。宋释智圆。元释元粹。性澄。明释宗泐。居士宋濂。六家注节要。
    《心经略释》 日僧真兴集提婆。窥基。圆测。靖迈。启。法藏。智开。武敏。空海。智光。十家注。

    以上古今注解。就著者所见。都一百种。仅知其目而未经读过者不录。虽曾读过而出于乩笔者亦不录。


略疏原序、科文、异译名称

    略疏原序
    唐贤首法师法藏撰

    夫以真源素范。冲漠隔于筌罤。妙觉玄猷。奥赜超于言象。
    【注】《显正记》云。真源二字。即正指实相般若。为所观理体也。真即真实。源即是喻。由此实相。本非伪妄故。素范者。谓此理体。惑不能染。故曰素。素。洁也。轨生物解。任持自性。故曰范。范。法也。法以轨持为义故。此叹理体之德也。冲漠者。冲。深也。漠谓沙漠。谓此理体竖穷三世。故曰冲。《圆觉疏》云。过去无始。未来无终。横遍十方。喻之沙漠。无有涯畔。此显理体之量也。下示理体离过。故曰隔于筌罤。隔。犹绝也。筌能捕鱼。罤能网兔。故《周易》云。得兔忘罤。得鱼忘筌。今借筌罤喻言教。鱼兔喻理境。见真理者须忘言教。犹得鱼兔者须忘筌罤也。夫真理虽假文字诠显。而真理之体本非文字。《佛顶经》云。妙性圆明。离诸名相。《般若经》云。总持非文字。文字显总持。既体绝文字。故云隔于筌罤。妙觉二字。正指观照般若。为能观智体也。以此智体。言思罔及。故曰妙。灵明鉴照。故曰觉。玄猷者。玄即幽玄。猷。道也。即总指此智之体是幽玄至极之道也。然道有二义。一，因义。无量果德。非智不证故。二，能通义。始自凡夫。皆由此智到极果故。即总名猷。此叹智体之德也。奥赜者。即竖深之义。显非权小之浅智。故云奥赜。以竖该横。但标奥赜。此显智体之量也。言。谓语言。象。似也。当其义也。夫语言义相。皆由分别。今此观智。体非分别。故超言象也。《周易》云。得象忘言。得意忘象。《连珠记》云。真源者。即实相般若。无相真如也。清凉释《刹那际三昧》云。即穷法真源。谓穷彼刹那。时相都寂。则刹那无际。由达清净真如。本无相故。素范者。素表无瑕。范持自性。谓体若冰霜。性犹珠玉。在烦恼泥不改贞白。论云。如如体中。过恒沙染法。皆悉空空无所有故。冲曰深玄。漠言广远。妙觉。即观照般若。清凉云。离觉所觉。而尽觉故。奥赜者。谓般若渊海。深而不可极也。大论云。智慧大海。惟佛穷底。

    虽真俗双泯。二谛恒存。空有两亡。一味常显。
    【注】《显正记》云。言真俗双泯者。泯。亡也。真即真谛。一体无殊。俗即俗谛。万境有异。今明真即俗。故真亡。俗即真。故俗亡。互夺两亡。名为双泯。二谛恒存者。存。在也。俗即真。故真在。真即俗。故俗在。相亡互在。故曰恒存。恒。常也。即显而隐故双泯。即隐而显故恒存。隐显同时。唯一实相。般若为所观境。所观之境既存亡不二。能观之智亦隐显同时。言空有者。空即照真。是如理智。有即照俗。是如量智。真境无相。智照名空。俗境万差。智观称有。今以空即有。故空泯。有即空。故有泯。故曰两亡。亡。泯也。一味者。总结存亡。不二唯一。观照般若。为能观之智。体非生灭。故曰常显。《连珠记》云。以空假皆中。色空无寄。方为此经所宗第一义谛之真空故。《会要》云。以色即是空之空为真谛。以空即是色之色为俗谛。言双泯者。色即空。故色泯。空即色。故空亡。言存者。谓即空之色。色虽泯而其相宛然。以相常存而即泯。故泯而恒存也。即色之空。空虽泯而其性不失。以性恒存而即泯。故泯而常在也。又色即空而空存。亦空即色而色存。以相即同时。故存泯齐立。空有等者。真谛故空。真空也。俗谛故有。假有也。亦由相即故双亡也。空非异有之空。有非异空之有。色空不异。水乳无分。故曰一味。《法界观》云。菩萨见空莫非见色。见色莫非见空。以二谛互融。故事理无阂。体即第一义真故。疏云。令悟二谛中道故。记云。此二不二。存泯同时。无性故缘生。空亡也。缘生故无性。有亡也。空有俱亡。为一味法。肇公曰。此直辨真谛以明非有。俗谛以辨非无。岂以谛二而二于物哉。玄镜云。约融二谛义。初，会色归空。明俗即是真。二，明空即色。显真即是俗。三，色空无阂。明二谛双现。四，泯绝无寄。明二谛俱泯。然色是有中之别称。通是空有二门耳。

    良以真空未尝不有。即有以辨于空。幻有未始不空。即空以明于有。
    【注】《显正记》云。意谓前说真俗不二者。实由真谛之空。常自随缘成俗谛有。未曾间断。故云未尝不有。既全空成有。反知有即真空。所以前说即俗是真。故云即有以辨于空也。俗谛之有。从缘无性。即真谛空。未曾有实。故云未始不空。既全有是空。反知空即幻有。所以前说即真是俗。故云即空以明于有。《连珠记》云。前科二谛圆融。空有一味者。以幻有真空无二为中道故。清凉云。由无性故空。是空义。缘生故空。是空之所以（所以即是因缘。由从缘生。所以无性。故缘生无性。是空之所以）。既是从缘生无性故空。故曰真空。而又不待坏彼差别法体。然后方空。是故真空未尝不有。又即此有法缘生无性。便名真空。故云即有以辨于空。言幻有者。缘生故有是有义。无性故有是有之所以（特由无定性故。方始从缘而成幻有。故无性是有之所以）。既是从缘无性之有。则此有常无自性。故幻有未始不空。又即此无性举体从缘而成于有。故云即空以明于有。

    有空有。故不有。空有空。故不空。
    【注】《显正记》云。有空等者。上俗谛之幻有。是即空之有。体不异空。故云不有。此结上即俗之真也。空有等者。上真谛之真空。是即有之空。体不异有。故云不空。此结上即真之俗也。所观既然。能观亦尔。《连珠记》云。有空下。即于幻有真空之上。各显一中道义也。初言有者。指幻法自体。即幻有上非不有义也。次言空有者。谓此幻法从缘无性。即空之有。是空家之有。故言空有。故不有者。以其举体全空无所有故。即幻有上非有义也。非有非不有无二。是幻有义。《大品》云。诸法无所有。如是有。故非有非不有。名为幻有。次云空者。指真空上非不空义也。言有空者。谓此真空是缘生无性之空。即有之空。是有家之空。故云有空。故不空者。不待灭缘生方为空。故全有之空是不空。指真空上非空义也。非空非不空无二。是真空义。经云。空不空不可得。名为真空。《中论》云。无性法亦无。一切法空故。《小钞引清凉疏》云。幻有即是不有有。真空即是不空空。不空空故。名不真空。不有有故。名非实有。非空非有。是中道义。

    不空之空。空而非断。不有之有。有而不常。
    【注】《显正记》云。言不空等者。显上真空是即有之空。空若离有。即是断空。今既不尔故云不断。不有等者。显上幻有是即空之有。有若异空。即成常有。今既不尔。故云不常。《连珠记》云。言不空等者。即无性故空。缘生故空。为真空也。清凉云。显正也。空而非断者。非无见断见之空。清凉云。拣非也。断见之无。是定性之无。定无则著断。今缘生故空。非是定无。无性故空。亦非定无。定无者。一向无物。如龟毛兔角。今但从缘无性。故非定无。是故空而非断也。不有之有者。即无性故有。缘生故有。此二种有。并非常见之有。常见之有。是定性有。今从缘无性之有。非定性有。显是幻有。显正也。既非定性之有。故曰有而不常。拣非也。则是真空妙有。离断常之中道也。清凉云。缘生无性故空。则非无见断见之空。为真空也。无性缘生故有。则非常见有见之有。是幻有也。肇公云。性常自空。故谓之性空。法性如是。故曰实相。言不有不无者。非有有见常见之有。邪见断见之无耳。玄谈云。虽空不断。虽有不常。此即中论及智论文。且约空为真谛。有为俗谛者。空是即有之空。故虽空不断。斯则即俗之真也。不同始教。如龟毛兔角。方说名空。虽有不常者。有是即空之有。故此有非常。斯则即真之俗也。若有定是有。便堕常见。故《中论》云。定有则著常。定无则著断。是故有智者。不应著有无。非断非常。即是中道。影公《中论·序》云。然统其要归。则会通二谛。以真谛故无有。俗谛故无无。真故无有。则虽无而有。俗故无无。则虽有而无。虽有而无。则不累于有。虽无而有。则不滞于无。不滞于无。则断见绝息。不存于有。则常见冰销。

    四执既亡。百非斯遣。般若玄旨。斯之谓欤。
   【注】《显正记》云。四执者。空有断常。但计一种。故名四执。又一异有无。各有四句。随计其一。亦名四执。言百非者。起信于一异有无等四句明之。谓一。非一。亦一亦非一。非一非非一。为一四句。异等例此。共成十六。又过，现，未来，各有十六。成四十八。又已起，未起，各四十八。并根本四。都成百非也。今疏意但不生分别。寂尔亡怀。情执自除。过非斯泯。故云四执既亡。百非斯遣。般若二字。正指此经。亦旁该广部。玄妙旨趣。理极于此。故云斯之谓欤。斯者。此也。欤者。语辞也。《连珠记》云。四执亦云四谤。定有者。增益谤。定无者。损减谤。亦有亦无。相违谤。非有非无。戏论谤。执四句故皆成谤。般若离四句。不可以有无取。故四执既亡。即成四德。《小钞引圭山》云。会色归空。无增益谤。明空即色。无损减谤。色空无碍。无双非戏论谤。泯绝无寄。无双亦相违谤。四谤既无。百非斯绝。已当八部般若无相大乘之极致也。清凉云。今显初门具德四句。一，真如是有。二，真性是空。三，真如亦有亦空。四，真性非有非空。一重四句中。更有四重四门。然执著成见取。成四谤。若能不住。无分别智遍入四句。则远离四谤。不滞空有。何行不成。即有之空。方为具德之空。即空之有。方为具德之有。又随一句必具余三。若随阙者则非具德。又云。为法之相。不出有无。设非有非无。若有此者。亦不出有。若无此句。亦不出无。但遣有无。万法斯寂。《起信钞》云。一异有无等各一四句。共成十六。又过，现，未来，各有十六。成四十八。又已起，未起，各四十八。共成九十六。并根本之四。都成百非。若以论下文真如自性。非有相。非无相。非有有相。非无无相。非有无俱相。例非一相非异等十句。此十句一一能生十使烦恼。亦成百非。记云。百非斯遣者。论曰。百非非非。千是非是。非百非。背千是。非非中中。皆背天天。演水之谈。足断而止。审虑之量。手亡而住。可谓般若二谛中道之大宗也。《释摩诃衍论》云。百非非。非非百。非非非。中中。谓以非非非去其非。故无非也。《会要》云。此之空有。与肇论有无不同。彼论有无。随世计说。相因而生。故论云。若以有为有。则以无为无。《密严经》云。要待于有法。而起于无见。如见牛有角。计兔无角等。二谛收之。但俗谛耳。《仁王经》曰。若取著一二。若有若无。即世俗谛。是也。此云即有之真空。即空之幻有。与彼遍计所执有无之理。居然异也。

    若历事备陈。则言过二十万颂。若撮其枢要。则理尽一十四行。
    【注】《显正记》云。若历下叙能诠。上叙所诠。既当实相观照二种般若。今叙能诠。即是文字般若也。般若广部六百卷。总开八部。谓大品小品等。其中所说始自色心。终乎种智。八十余科。今显其广。故云二十万颂。撮。取也。枢即门臼。喻其要也。以一总多曰要。理即义理。古来经文。皆以十七字为一行。故今经但有一十四行也。《连珠记》云。若历等者。谓历色心等事。备陈正理。则有八部二十万颂。枢谓门枢。尔雅云。制扇以柎。门傍曰枢。以况八部所诠顿实之旨。斯经尽之。故曰。撮其枢要。理尽一十四行。《会要》云。二十万颂。属六百卷大部。西域法以颂定数三十二字为一颂。一颂为一数。故大部该二十万颂。

    是知铨真之教。乍广略而随缘。超言之宗。性圆通而俱现。
    【注】《显正记》云。教铨真理。故曰铨真之教。所叙或广或略者。由机有利钝。利者闻略说则悟。钝者闻广说方解。缘谓机缘。所铨之理。是一经之主。故名为宗。离言说相。故曰超言。能铨之教。虽有广略。所铨之理。则无增减。本自圆融。平等显现。故云性圆通等。《小钞》云。广略随缘者。《依起信》云。或有众生。以自力广闻而取解。亦以自力少闻而多解。又或因广论而得解。复以少文摄多义能取解故。《会要》云。宗谓宗旨。此所铨之性宗，在广部铨量非增。在略部铨量非减。一皆圆满融通也。

    般若心经者。实谓曜分衢之高炬。济苦海之迅航。拯物导迷。莫斯为最。
    【注】《显正记》云。实谓者。指定之辞。曜。照也。衢谓衢路。昏衢喻二障。即生死因。苦海即生死果。三界有情。常居苦趣。飘沉生死。不证菩提者。靡不由此。二障者。一，名烦恼障。体即根随。二，名所知障。体即无明。《金刚疏》云。烦恼障障心。心不解脱。所知障障慧。慧不解脱。既是有情生死根本。又能障翳无生理智。其犹昏暗衢路。履即颠坠。故以为喻。高炬即火炬。喻般若也。谓若能依此经发深妙慧。了心本寂。见法元空。然后悲智兼修。自他俱运。泯取舍。亡顺违。则二障潜祛。三空可契。犹火炬高照。昏衢顿明。迅航亦喻般若。苦即分段，变易，二种生死。由上二障之所感。故二死苦相。无有边际。喻之苦海。然三界无定。靡不皆苦。众生妄计为乐。以智观之。有何可乐。故我大圣由悲愿力。特演斯典。济救有情。使登般若之智航。度竛竮之苦海。物谓物机。迷为迷惑。显此经决能引导迷者。拯接物机。离二障昏暗之衢。践智慧坦明之道。则涅槃高岸。尚可即登。生死微波。何疑不度。《连珠记》云。昏衢苦海。以喻有情奔驰生死。无智慧明。五苦八苦。不得边底也。高炬迅航。以况斯经。三无相慧。拯接物机。导引迷徒。群修多罗。莫比斯最。《会要》云。昏衢高炬者。如《仁王经》以般若喻于摩尼大宝。体具众德。乃至云。若于暗夜。置高床上。光照天地。明如日出。苦海迅航者。则般若独能为舟也。若以六度共为舟。则施为船底。戒为船帮。忍如板。进如桌。定如坠石。慧如艄人也。

    然则般若以神鉴为体。波罗蜜多以到彼岸为功。心显要妙所归。经乃贯穿言教。从法就喻。诠旨为目。故言般若波罗蜜多心经。
    【注】《显正记》云。般若此云智慧。神名不测。鉴谓鉴照。体即性也。此智虽不可测。而性常鉴照。故云以神鉴为体也。波罗蜜多者。显此智有离此到彼之功心显等者。以人心藏。是一身所归。要劲微妙之处。喻此略本。是彼广部之要也。经乃等者。法喻并彰也。以经能持义喻线能贯华。显不散失故。此经则是能持义理之言教。故曰经乃贯穿等。法即所喻。谓般若等。心是能喻。铨谓能铨。即经之一字。旨谓所铨旨趣。即上法喻等。是乃法喻能所合为此经题目。故总结云从法就喻等。《会要》云。依起信中。本觉。般若体也。此体灵明。本自神解。故云谓心体离念。离念相者。等虚空界。无所不遍。又云有大智慧光明义等。若始觉。般若用也。《无知论》曰。般若可虚而照。真谛可亡而知。万动可即而静。圣应可无而为。皆神妙也。今通铨二种。则实相属本。观照属始也。《连珠记》云。肇公曰。然则智有穷幽之鉴。而无知焉。神有应会之用。而无虑焉。神无虑。故能独王于世表。智无知。故能玄照于事外。经云。般若无知。无所不知。则观照实相也。功者。用也。谓漉人天龙。渡生死海。置涅槃岸。乃斯妙慧之功用也。前已广叙所铨之经。此特显能铨文字般若。略能摄广是六百卷中之要妙。言是般若部中之心。如人心藏。是一身之要也。般若。法也。心乃喻焉。心经为铨。般若为旨。结为题目矣。

    科文

    本经异译名称

    摩诃般若波罗蜜咒经 吴支谦译
    摩诃般若波罗蜜大明咒经 姚秦鸠摩罗什译
    般若波罗蜜多心经 　唐玄奘译
    般若波罗蜜多那经 　唐菩提流志译
    般若波罗蜜多心经 　唐义净译
    摩诃般若随心经 　　唐实叉难陀译
    般若波罗蜜多心经 　 唐不空译
    普遍智藏般若波罗蜜多心经 唐法月初译重译
    般若波罗蜜多心经 　唐般若共利言等译
    般若波罗蜜多心经 　唐智慧轮译
    般若波罗蜜多心经 　唐法成译
    般若波罗蜜多心经 　宋契丹慈贤译
    佛说圣佛母般若波罗蜜多心经 宋施护译
    圣母智慧到彼岸经 　元达里麻剌怛那译


卷一·经文

  《般若波罗蜜多心经诠注·卷一》
    震旦白衣周止庵学

    经 文

    将欲宣说此经。自应先列经文。以申皈敬。此经具称。当云般若波罗蜜多心经。世间流布。简称心经。其有连上文多字并读。称多心经者。误也。
    心经由梵译汉。凡十四本。吴支谦。唐菩提流志。实叉难陀。大广智不空。宋契丹慈贤。元达里麻剌怛那。六种译本。已久佚。今所存者八译。此八译中唐义净三藏所译者。除咒后有诵此经破十恶五逆。九十五种邪道。若欲供养十方诸佛。报十方诸佛恩。当诵观世音般若。百遍千遍。无间昼夜。常诵此经。无愿不果。五十一字外。与玄奘三藏所译相同。故世所流传。仅称七译。
    此外大藏中尚有同名为心经者。一，为陀罗尼集经三。唐阿地瞿多译之《般若波罗蜜多大心经》。系佛与梵天说般若波罗蜜多功德。二，为宋施护所译之《帝释般若波罗蜜多心经》。佛为帝释说般若波罗蜜多甚深之义。均与本经不同。不可以译名相同。而谓为同本也。
    【注】宣说者。宣明经恉。演说教法之义。《华严经·五》曰。以佛力故能宣说。
    古来误称多心经者，约有二义。一，以心字属上文。为般若波罗蜜多心之简称。如唐·新罗·崔致远《法藏和尚传》，多心虽小不轻，疏出尘中经义。注曰《般若波罗蜜多心经》，多心属上。心是般若之心。略云多心。此特简称费解。意尚不谬。二，因什师旧译。依巴利语无尾音。作波罗蜜。新译作波罗蜜多。后人逐以多字为别有含义，有作禅定之定字解者。则大误矣。经文言波罗蜜多者，凡五处作定字解，即不可通。
    吴月支优婆塞支谦译《摩诃般若波罗蜜咒经》。天竺三藏菩提流志译《般若波罗蜜多那经》。于阗三藏实叉难陀译《摩诃般若随心经》。均见《开元释教录·十四》。有译无本录。唐天竺三藏大广智不空译《梵本般若波罗蜜多心经》。宋三藏慈贤译《梵本般若波罗蜜多心经》。亦见《祥符录》及《至元法宝勘同总录》。元释达里麻剌怛那译《圣母智慧到彼岸经》。大明重刊《三藏圣教目录》未著录。今均佚。
    十恶。又名十不善。一，杀生。二，不与取。三，邪淫。四，虚诳语。五，离间语。六，粗恶语。七，杂秽语。八，贪欲。九，嗔恚。十，邪见。此十者并乖理而起。故名恶。《大乘义章·十二》云。顺理名善。违理名恶。故又名十不善。为苦报之业因。故又名十恶业。十不善业。
    五逆。又名五无间业。《华严·孔目章·三》云。五逆。谓害父。害母。害阿罗汉。破僧。出佛身血。初二，背恩养。次三，坏福田。故名为逆。此通于三乘之五逆也。
    九十五种邪道。即外道也。于佛教外立道。在真理外之邪法也。《资持记·上》曰。言外道者。不受佛化。别行邪法。又曰僧祇总数。九十六种出家人。佛道为一。邪道九十五。《南本涅槃经·十》曰。世尊常说。一切外学九十五种。皆趣恶道。声闻弟子。皆向正路。按《西域外道九十五种清凉华严疏》。束为十一。一，数论师。名劫比罗。此云黄发。立二十五谛。即冥谛也。二，卫世师。新云吠世史迦萨多罗。此云胜论。即米齐外道也。三，涂灰外道。计自在天为万物之因。四，围陀论师。计那罗延天能生万物。五，安荼论师。计本际生世间。最初由安荼出生梵天。化生万物。六，时散外道。计一切物皆从时生。故时为万物因。七，方论师。计方生人。人生天地。灭后还入于方。故方是万物因。八，路迦耶论师。计色心等法皆极微所作。此云顺世外道。九，口力论师。以虚空为万物因。十，宿作论师。以众生苦乐。皆随宿世本业。故宿作为一切因。十一，无因论师。谓一切万物。无因无缘。自然生灭。
    供养者。供奉财法。资养三宝也。一，财供养。以香华灯明饮食衣物等为供养也。二，法供养。如说修行。利益众生也。见《普贤行愿品》。十方诸佛者，东、西、南、北、东南、西南、东北、西北、上、下。过去、现在、未来，三世诸佛也。
    七译详略不同。今所诠释。依唐玄奘法师译本。但为阐明经恉。别译亦不可不参稽互证。谨于诠释本经之先。依时代先后。录各种译本经文如次。其义净三藏译本。准日本大藏经梵汉般若异本集记载。与奘师所译相同。故略之。

    《摩诃般若波罗蜜大明咒经》（龙藏翔字函又据日本大藏本续藏本校正）
    姚秦天竺三藏鸠摩罗什译
    观世音菩萨。行深般若波罗蜜时。照见五阴空。度一切苦厄。舍利弗。色空故，无恼坏相。受空故，无受相。想空故，无知相。行空故，无作相。识空故，无觉相。何以故。舍利弗。非色异空。非空异色。色即是空。空即是色。受想行识。亦复如是。舍利弗。是诸法空相。不生、不灭、不垢、不净、不增、不减。是空法非过去。非未来。非现在。是故空中无色。无受想行识。无眼耳鼻舌身意。无色声香味触法。无眼界。乃至无意识界。无无明。亦无无明尽。乃至无老死。亦无老死尽。无苦集灭道。无智。亦无得。以无所得故。菩萨依般若波罗蜜故。心无挂碍。无挂碍故。无有恐怖。远离一切颠倒梦想苦恼。究竟涅槃。三世诸佛。依般若波罗蜜故。得阿耨多罗三藐三菩提。故知般若波罗蜜。是大明咒。是无上明咒。是无等等明咒。能除一切苦。真实不虚。故说般若波罗蜜咒。即说咒曰。揭帝揭帝。波罗揭帝。波罗僧揭帝。菩提僧莎呵。

    《般若波罗蜜多心经》（龙藏翔字函）
    唐三藏法师玄奘译
    观自在菩萨。行深般若波罗蜜多时。照见五蕴皆空。度一切苦厄。舍利子。色不异空。空不异色。色即是空。空即是色。受想行识。亦复如是。舍利子。是诸法空相。不生、不灭、不垢、不净、不增、不减。是故空中无色。无受想行识。无眼耳鼻舌身意。无色声香味触法。无眼界。乃至无意识界。无无明。亦无无明尽。乃至无老死。亦无老死尽。无苦集灭道。无智。亦无得。以无所得故。菩提萨埵。依般若波罗蜜多故。心无挂碍。无挂碍故。无有恐怖。远离颠倒梦想。究竟涅槃。三世诸佛。依般若波罗蜜多故。得阿耨多罗三藐三菩提。故知般若波罗蜜多。是大神咒。是大明咒。是无上咒。是无等等咒。能除一切苦。真实不虚。故说般若波罗蜜多咒。即说咒曰。揭谛揭谛。波罗揭谛。波罗僧揭谛。菩提萨婆诃。

    《普遍智藏般若波罗蜜多心经》（丽藏磻字函又据日本大藏本续藏本校正）
    唐摩竭提国三藏沙门法月重译
    如是我闻。一时佛在王舍大城灵鹫山中。与大比丘众满百千人。菩萨摩诃萨七万七千人俱。其名曰观自在菩萨。文殊师利菩萨。弥勒菩萨等。以为上首。皆得三昧总持。住不思议解脱。尔时观自在菩萨摩诃萨。在彼敷座。于其众中。即从座起。诣世尊所。面向合掌。曲躬恭敬。瞻仰尊颜。而白佛言。世尊。我欲于此会中。说诸菩萨普遍智藏般若波罗蜜多心。唯愿世尊。听我所说。为诸菩萨宣秘法要。尔时世尊以妙梵音。告观自在菩萨摩诃萨言。善哉善哉。具大悲者。听汝所说。与诸众生作大光明。于是观自在菩萨摩诃萨蒙佛听许。佛所护念。入于慧光三昧正受。入此定已。以三昧力行深般若波罗蜜多时。照见五蕴自性皆空。彼了知五蕴自性皆空。从彼三昧安详而起。即告慧命舍利弗言。善男子。菩萨有般若波罗蜜多心。名普遍智藏。汝今谛听。善思念之。吾当为汝分别解说。作是语已。慧命舍利弗白观自在菩萨言。唯大净者愿为说之。今正是时。于斯告舍利弗。诸菩萨摩诃萨。应如是学。色性是空。空性是色。色不异空。空不异色。色即是空。空即是色。受想行识。亦复如是。识性是空。空性是识。识不异空。空不异识。识即是空。空即是识。舍利子。是诸法空相。不生。不灭。不垢。不净。不增。不减。是故空中无色。无受想行识。无眼耳鼻舌身意。无色声香味触法。无眼界。乃至无意识界。无无明。亦无无明尽。乃至无老死。亦无老死尽。无苦集灭道。无智。亦无得。以无所得故。菩提萨埵。依般若波罗蜜多故。心无挂碍。无挂碍故。无有恐怖。远离颠倒梦想。究竟涅槃。三世诸佛。依般若波罗蜜多故。得阿耨多罗三藐三菩提。故知般若波罗蜜多。是大神咒。是大明咒。是无上咒。是无等等咒。能除一切苦。真实不虚。故说般若波罗蜜多咒。即说咒曰。揭谛揭谛。波罗揭谛。波罗僧揭谛。菩提莎婆诃。佛说是经已。诸比丘及菩萨众。一切世间天、人、阿修罗、乾闼婆等。闻佛所说。皆大欢喜。信受奉行。
    【注】至元法宝勘同总录，贞元续录。《普遍智藏般若波罗蜜多心经》一卷。宋天竺三藏达摩战湿罗译《般若波罗蜜多心经》一卷。罽宾沙门般若共利言等译。右二经与前大明咒般若心等经。同本异译。
    法月两译本经。字句小异。此其重译本也。初译本。王舍大城作王舍城。观自在作观世音。菩萨摩诃萨作菩萨。在彼敷坐于其众中。作在彼众中。诣世尊所。面向合掌。曲躬恭敬。瞻仰尊颜。而白佛言。作合掌向佛。瞻仰尊颜。目不暂舍。白佛言。于此会中说。作于此众中宣说。无为诸菩萨宣秘法要句。佛所护念。入于慧光三昧正受。入此定已。以三昧力。行深般若波罗蜜多时。作以佛神力。入于慧光三昧。行深般若波罗蜜多。从彼三昧安详而起。即告慧命舍利弗言。作三昧定起。告舍利子言。名普遍智藏。作名曰普遍智藏。吾当为汝分别解说。作是语已。作当为汝说。作是说已。慧命舍利弗白观自在菩萨言。惟大净者。愿为说之。作舍利子白观自在菩萨摩诃萨言。唯愿宣说。于斯告舍利弗。作舍利子。远离颠倒。作远离一切颠倒。诸比丘作与诸比丘。

    《般若波罗蜜多心经》（丽藏桓字函又据日本大藏本续藏本校正）
    唐罽宾国三藏般若共利言译
    如是我闻。一时佛在王舍城耆阇崛山中。与大比丘众及菩萨众俱。时佛世尊即入三昧。名广大甚深。尔时众中有菩萨摩诃萨。名观自在。行深般若波罗蜜多时。照见五蕴皆空。离诸苦厄。即时舍利弗。承佛威力。合掌恭敬。白观自在菩萨摩诃萨言。善男子。若有欲学甚深般若波罗蜜多行者。云何修行。如是问已。尔时观自在菩萨摩诃萨。告具寿舍利弗言。舍利子。若善男子。善女人。行甚深般若波罗蜜多行者。应观五蕴性空。舍利子。色不异空。空不异色。色即是空。空即是色。受想行识。亦复如是。舍利子。是诸法空相。不生。不灭。不垢。不净。不增。不减。是故空中无色。无受想行识。无眼耳鼻舌身意。无色声香味触法。无眼界。乃至无意识界。无无明。亦无无明尽。乃至无老死。亦无老死尽。无苦集灭道。无智。亦无得。以无所得故。菩提萨埵。依般若波罗蜜多故。心无挂碍。无挂碍故。无有恐怖。远离一切颠倒梦想。究竟涅槃。三世诸佛。依般若波罗蜜多故。得阿耨多罗三藐三菩提。故知般若波罗蜜多。是大神咒。是大明咒。是无上咒。是无等等咒。能除一切苦。真实不虚。故说般若罗蜜多咒。即说咒曰。蘖谛蘖谛。波罗蘖谛。波罗僧蘖谛。菩提娑婆诃。如是。舍利弗。诸菩萨摩诃萨，于甚深般若波罗蜜多行。应如是行。如是说已。即时世尊。从广大甚深三摩地起。赞观自在菩萨摩诃萨言。善哉善哉。善男子。如是如是。如汝所说。甚深般若波罗蜜多行。应如是行。如是行时。一切如来。皆悉随喜。尔时世尊。说是语已。具寿舍利弗。大喜充遍。观自在菩萨摩诃萨。亦大欢喜。时彼众会天、人、阿修罗、乾闼婆等。闻佛所说。皆大欢喜。信受奉行。

    《般若波罗蜜多心经》（日本藏经书院续藏本又据日本大藏本校正）
    唐三藏沙门智慧轮译
    如是我闻。一时薄誐梵住王舍城鹫山中。与大苾刍众及大菩萨众俱。尔时世尊入三摩地。名广大甚深照见。时众中有一菩萨摩诃萨。名观世音自在。行甚深般若波罗蜜多行时。照见五蕴自性皆空。即时具寿舍利子。承佛威神。合掌恭敬。白观世音自在菩萨摩诃萨言。圣者。若有欲学甚深般若波罗蜜多行。云何修行。如是问已。尔时观世音自在菩萨摩诃萨。告具寿舍利子言。舍利子。若有善男子。善女人。行甚深般若波罗蜜多行时。应照见五蕴自性皆空。离诸苦厄。舍利子。色空。空性见色。色不异空。空不异色。是色即空。是空即色。受想行识。亦复如是。舍利子。是诸法性相空。不生。不灭。不垢。不净。不增。不减。是故空中无色。无受想行识。无眼耳鼻舌身意。无色声香味触法。无眼界。乃至无意识界。无无明。亦无无明尽。乃至无老死。亦无老死尽。无苦集灭道。无智证。无得。以无所得故。菩提萨埵。依般若波罗蜜多住。心无挂碍。心无挂碍故。无有恐怖。远离颠倒梦想。究竟寂然。三世诸佛。依般若波罗蜜多故。得阿耨多罗三藐三菩提。现成正觉。故知般若波罗蜜多。是大真言。是大明真言。是无上真言。是无等等真言。能除一切苦。真实不虚。故说般若波罗蜜多真言。即说真言。唵。誐帝誐帝。播（引）啰誐帝。播（引）啰散誐帝。冒（引）地娑缚（二合）贺。如是。舍利子。诸菩萨摩诃萨。于甚深般若波罗蜜多行。应如是学。尔时世尊。从三摩地安详而起。赞观世音自在菩萨摩诃萨言。善哉善哉。善男子。如是如是。如汝所说。甚深般若波罗蜜多行。应如是行。如是行时。一切如来。悉皆随喜。尔时世尊。如是说已。具寿舍利子。观世音自在菩萨。及彼众会一切世间天、人、阿苏啰、巘驮嚩等。闻佛所说。皆大欢喜。信受奉行。

    《般若波罗蜜多心经》（敦煌石室本）
    唐三藏法师沙门法成译
    如是我闻。一时薄伽梵住王舍城鹫峰山中。与大苾刍众及诸菩萨摩诃萨俱。尔时世尊等入甚深明了三摩地法之异门。复于尔时观自在菩萨摩诃萨。行深般若波罗蜜多时。观察照见五蕴体性。悉皆是空。时具寿舍利子。承佛威力。白圣者观自在菩萨摩诃萨曰。若善男子。欲修行甚深般若波罗蜜多者。复当云何修学。作是语已。观自在菩萨摩诃萨。答具寿舍利子言。若善男子。及善女人。欲修行甚深般若波罗蜜多者。彼应如是观察。五蕴体性皆空。色即是空。空即是色。色不异空。空不异色。如是受想行识。亦复皆空。是故舍利子。一切法空性无相。无生。无灭。无垢。无离垢。无减。无增。舍利子。是故尔时空性之中。无色。无受。无想。无行。亦无有识。无眼。无耳。无鼻。无舌。无身。无意。无色。无声。无香。无味。无触。无法。无眼界。乃至无意识界。无无明。亦无无明尽。乃至无老死。亦无老死尽。无苦集灭道。无智。无得。亦无不得。是故舍利子。以无所得故。诸菩萨众。依止般若波罗蜜多。心无障碍。无有恐怖。超过颠倒。究竟涅槃。三世一切诸佛。亦皆依般若波罗蜜多故。证得无上正等菩提。舍利子。是故当知般若波罗蜜多大密咒者。是大明咒。是无上咒。是无等等咒。能除一切诸苦之厄。真实无倒。故知般若波罗蜜多。是秘密咒。即说般若波罗蜜多咒曰。峨帝峨帝。波罗峨帝。波啰僧峨帝。菩提沙诃。舍利子。菩萨摩诃萨应如是修学甚深般若波罗蜜多。尔时世尊从彼定起。告圣者观自在菩萨摩诃萨曰。善哉善哉。善男子。如是如是。如汝所说。彼当如是修学般若波罗蜜多。一切如来。亦当随喜。时薄伽梵说是语已。具寿舍利子。圣者观自在菩萨摩诃萨。一切世间天、人、阿苏罗、乾闼婆等。闻佛所说。皆大欢喜。信受奉行。

    《佛说圣佛母般若波罗蜜多心经》（龙藏薄字函又据日本大藏本校正）
    宋西天译经三藏施护译
    如是我闻。一时世尊在王舍城鹫峰山中。与大苾刍众千二百五十人俱。并诸菩萨摩诃萨。而共围绕。尔时世尊。即入甚深光明宣说正法三摩地。时观自在菩萨摩诃萨。在佛会中。而此菩萨摩诃萨已能修行甚深般若罗蜜多。观见五蕴自性皆空。尔时尊者舍利子。承佛威神。前白观自在菩萨摩诃萨言。若善男子。善女人。于此甚深般若波罗蜜多法门。乐欲修学者。当云何学。时观自在菩萨摩诃萨。告尊者舍利子言。汝今谛听。为汝宣说。若善男子。善女人。乐欲修学此甚深般若波罗蜜多法门者。当观五蕴自性皆空。何名五蕴自性空耶。所谓即色是空。即空是色。色无异于空。空无异于色。受想行识。亦复如是。舍利子。此一切法如是空相。无所生。无所灭。无垢染。无清净。无增长。无损减。舍利子。是故空中无色。无受想行识。无眼耳鼻舌身意。无色声香味触法。无眼界。无眼识界。乃至无意界。无意识界。无无明。亦无无明尽。乃至无老死。亦无老死尽。无苦集灭道。无智、无所得。亦无无得。舍利子。由是无得故。菩萨摩诃萨。依般若波罗蜜多相应行故。无所著。亦无挂碍。以无著、无碍故。无有恐怖。远离一切颠倒妄想。究竟圆寂。所有三世诸佛依此般若波罗蜜多故。得阿耨多罗三藐三菩提。是故应知般若波罗蜜多。是广大明。是无上明。是无等等明。而能息除一切苦恼。是即真实无虚妄法。诸修学者当如是学。我今宣说般若波罗蜜多大明曰。怛［宁＋也］ 他。唵。誐帝（引）誐帝（引）。播（引）啰誐帝（引）。播（引）啰僧誐帝。冒提莎（引）贺（引）。舍利子。诸菩萨摩诃萨。若能诵是般若波罗蜜多明句。是即修学甚深般若波罗蜜多。尔时世尊。从三摩地安详而起。赞观自在菩萨摩诃萨言。善哉善哉。善男子。如汝所说。如是如是。般若波罗蜜多。当如是学。是即真实最上究竟。一切如来亦皆随喜。佛说此经已。观自在菩萨摩诃萨。并诸苾刍。乃至世间天、人、阿修罗、干达婆等。一切大众。闻佛所说。皆大欢喜。信受奉行。
    以上七种译文。详略虽殊。经恉则一。皆出自同一梵本，吾国四众间流通最广者。自推玄奘法师译本。文简理具。本诠宗之。
    【注】四众者。比丘。比丘尼。优婆塞。优婆夷也。《药师经》曰。若有四众。苾刍。苾刍尼。邬波索迦。邬波斯迦。此统指在家出家而言。若出家四众。则为比丘。比丘尼。沙弥。沙弥尼。
    流通者。传布无壅之义。《十地义记》云。传布名流。无壅曰通。欲使正法流注于无穷。圣教不壅于方来也。

    自东晋道安法师以三分判释经文。首序分。次正宗分。终流通分。冥符亲光。为译经者所宗。所谓弥天高判。今古同遵也。本经法月师译本。自如是我闻至与诸众生作大光明为序分。于是观世音菩萨摩诃萨。蒙佛听许。至菩提莎婆诃为正宗分。佛说是经已。至信受奉行。则流通分也。般若共利言等四师所译皆然。什师奘师净师译本。简择精要。略去序分与流通分。
    【注】冥符亲光者。先是道安法师。以三分判释诸经。译者宗之。及玄奘法师译《佛地论》。始知西域亲光菩萨判《佛地经》亦分三分。一，教起因缘分。二，圣教所说分。三，依教奉行分。与序、正、流通辞异义同。道安所见。与之冥符。
    弥天高判者。即指道安。以晋时民间习语。四海习凿齿。弥天释道安。极言其化行之广也。
    序有二种。一，通序。诸经通有故。亦名证信序。证明佛说以起诚信故。亦名经后序。佛说经时。本无此序。至结集时始加入故。亦名《遗教序》。佛涅槃时。阿难尊者。奉佛遗教。结集时当置此序故。亦名《印定序》。诸经之首皆安立故。亦名《破邪序》。对破外道阿优故（外道经首。皆安阿优二字。阿此云无。优此云有。不出有无。即断常计。经序以如是起首。如即真空。是即妙有。以对破邪宗之执断执常）。二，别序。诸经所说缘起不同故。又名发起序。以发起本经说法因缘故。本经法月师译本。如是我闻至与大比丘众满百千人菩萨摩诃萨七万七千人俱。为通序。以下至与诸众生作大光明。为别序。
    世尊说法。必具六缘。结集时即于通序见之。云如是者。信成就也。《智度论》云。佛法大海。信为能入。智为能度。信者。言是事如是。不信者。言是事不如是。肇公云。信则所言之理顺。顺则师资之道成。万行中以信为首。故曰如是。云我闻者。我即阿难自指。五蕴假我。假立宾主。但是名字。闻谓耳根发识听受。夫耳闻非识。识闻非耳。缘合方闻。虽因耳处。废别从总。总该诸根。故称我闻。云一时者。时成就也。师资合会。说听究竟。一者。如来说经有无量时。不能别举。二者。诸方时分。延促不定。故云一时。云佛者。主成就也。具称佛陀。此云觉者。自觉异凡夫。觉他异二乘。觉满异菩萨。三觉理圆。故称妙觉。云在王舍大城灵鹫山中者。处成就也。在者。住也。佛内住无量三昧。迹住灵鹫山中。处有二。一，所化处。即王舍城。二，所住处。即灵鹫山中。云与大比丘众满百千人。菩萨摩诃萨七万七千人俱者。众成就也。《法华文句》。佛说经时。海众云集。一，发起众。发动本经说法因缘者。二，当机众。夙植德本。当座闻法获益者。三，影响众。诸佛菩萨。隐其圆果。示同机众者。四，结缘众。过去根浅。三慧不生。现世虽见佛闻法。未能获益。但作未来得度因缘者。《华严经清凉疏》。又有常随众。如普贤等常随不离者。守护众。如执金刚等。常勤守护者。庄严众。如道场神等严净佛宫殿者。通序所明。即此六缘。六缘既具。法会斯起。

    以上七译。皆取梵文之意。紬译华言。亦有直取梵音。表以汉字者。日本大藏经梵汉般若心经异本集有梵语《心经》一卷。题宋兰溪大觉禅师将来。又题宋道隆将来。盖亦由我国传入者与敦煌石室所出唐梵翻对字音《般若波罗蜜多心经》。大同小异。兹为学者参考之便。并录如次。

    梵语《心经》一卷（日本大藏经本）

    八罗娘波啰弥陀逆哩驮耶素怛啰。

    阿列婆噜枳帝室缚罗母帝萨埵。严毗览八啰娘波啰弥哆左焰左耶颇噜也。缚噜迦野地娑么畔左思建驮娑怛写娑婆婆缚戍涅缚室底娑么伊贺。舍利补怛啰噜畔戍涅戍涅多缚噜缚。噜畔曩比囊戍涅哆戍涅哆夜。囊比囊迦噜畔。夜噜也噜畔娑戍涅哆哆也。戍涅多娑噜畔伊缚弭缚。吠怛多三迦南散娑三迦喃。尾迦南伊贺。舍利补怛啰。萨啰缚达磨戍涅多洛叉拏。阿耨多婆左阿里也噜驮。阿么攞。阿尾也噜攞。阿怒拏阿婆哩布攞怛。多娑磨舍哩布怛啰。戍涅哆耶戍涅多萨噜畔。曩吠怛多。散迦。南三散娑迦。喃尾誐南。囊[石*斥]刍助噜啰迦啰拏即贺缚迦野颇那悉莎噜畔。摄那彦驮啰娑娑播啰瑟吒尾演达摩。曩斫刍驮都。也缚那么怒尾迦南[馬*犬]都。那尾南。那尾南。吒喻那尾南。叉欲夜缚。那槎啰么啰南。那左罗么啰拏叉喻。那耨佉娑敏那野宁噜驮缚室哩誐尾演钵罗誐婆啰弭。多缚室利誐尾贺啰野。枳陀婆啰誐。枳陀婆啰誐。那悉帝达么那钵啰尾地那备。娑曼也[馬*犬]三曼。曩钵啰尾帝娑驮冒地三埵南。钵啰誐婆啰弭多。缚室哩耶奴答览。三藐三牟备牟备。娑曼驮缚。室里誐尾演。钵啰誐娑啰弥陀。摩诃曼怛罗。摩诃尾欲曼怛罗。阿耨多罗曼怛罗。阿娑婆三备曼怛罗。娑婆奴迦钵啰。舍婆那娑帝冒帝地演达摩。钵啰誐婆啰弭多目讫姤满怛罗。怛侄哆。虐谛虐谛。播罗虐谛。播罗僧虐谛。菩提娑婆诃。
    【注】梵语。即印度文言。印度人自称为梵天苗裔。故曰梵语。
    兰溪大觉禅师。即道隆也。宋僧。俗姓冉氏。号兰溪子。淳祐三年。应北条时赖之聘。赴日本。为日本建长寺之开山祖。著有《般若波罗心经注》。
    将者。持义。与偕义。将来者。犹云持来也。杭州方言犹然。
    敦煌石室。在甘肃省敦煌县东南之鸣沙山。山麓有三界寺。寺旁石室甚多。旧名莫高窟。俗称千佛洞。石室之一为书库。内藏唐人手写佛经。及其他美术品甚多。盖西夏兵革时保存于此者。清光绪二十六年庚子发见。国人不知珍惜。大部为英人斯坦因。法人伯希和运去。藏伦敦图书馆。及巴黎国民图书馆者。达千余卷。迨民国十九年。政府始前往收拾。举其残余。运至京师图书馆。精萃者已伤失殆尽。国有瑰宝。不能自保。虽曰诸行无常。亦秦之无人也。

    《唐梵翻对字音般若波罗蜜多心经》（敦煌石室本）
    钵啰［二合］（般）誐攘［二合］（若）播（波）啰（罗）弭（蜜）哆（多）纥哩［二合］那野（心）素怛囕（经）。
    阿哩也［二合］（圣）嚩噜枳帝（观）湿嚩路（自在）冒地（菩）娑怛侮［二合］（萨）。俨鼻囕（深）钵啰［二合］（般）誐攘［二合］（若）播（波）啰（罗）弭（蜜）哆（多）左哩焰［二合］（行）左啰（行）么女（时）尾也［二合］。嚩噜［引］迦（照）底娑么［二合］（见）畔左（五）塞建［引］驮［引］（蕴）娑怛［引］室左［二合］（彼）娑嚩（自）婆嚩［引］（性）戍你焰［二合］（空）跛失也［二合］底娑么［二合］（现）伊贺（此）。舍（舍）哩（利）补怛啰［二合］（子）。噜畔（色）戍你焰［二合］（空）戍你也［二合］（空）[口*帶]（性）嚩（是）噜畔（色）。噜播（色）曩（不）比[口*栗]［二合］他（异）戍你也［二合］哆（空）。戍你也［二合］（空）哆野（亦）曩引（不）比[口*栗]［二合］他（异）萨噜［二合］畔（色）。夜（是）怒噜［二合］畔（色）娑（彼）戍你也［二合］哆夜（空）戍你也［二合］哆（空）娑（彼）噜畔（色）。噎嚩（如）弭嚩（是）。吠那曩（受）散誐攘（想）散娑迦［引］啰（行）尾誐攘［二合］喃（识）。伊贺（此）舍（舍）哩（利）补怛啰［二合］（子）。萨啰嚩（诸）达摩（法）戍你也［二合］哆（空）落乞叉［二合］拏（相）。阿怒（不）哆播［二合］。曩（生）阿宁（不）噜驮（灭）。阿（不）么攞（垢）阿（不）尾么攞（净）。阿（不）怒曩（灭）阿（不）播哩补攞拏［二合］（增）哆（是）娑每（故）舍（舍）哩（利）补怛啰［二合］（子）戍你也［二合］（空）哆焰（中）曩（无）噜畔（色）。曩（无）吠［引］那囊（受）。曩（无）散誐攘（想）。曩（无）散娑迦啰（行）。曩（无）尾誐攘［二合］喃（识）。曩（无）斫乞刍（眼）戍噜怛啰［二合］（耳）迦啰［二合］拏（鼻）[口*爾]贺嚩（舌）迦野（身）么曩勒（意）。曩（无）噜畔（色）摄那（声）彦驮（香）啰娑（味）娑播啰［二合］瑟吒尾也［二合］（触）达摩（法）。曩（无）斫乞刍（眼）驮都（界）哩也［二合］嚩（乃至）曩（无）么怒（意）尾誐攘誐［二合］喃（识）驮都（界）。曩（无）尾你［二合］也（无明）。曩（无）尾你［二合］也（按梵语无明为阿尾你。此二句尾你也恐传写有误。以原文如此。不敢擅改）。乞叉喻（尽）。野嚩（乃至）曩（无）[口*惹]啰（老）么啰喃（死）曩（无）[口*惹]啰（老）么啰拏（死）乞叉喻（尽）。曩（无）褥佉（苦）娑敏那野（集）宁噜驮（灭）么哩誐穰［二合］（道）曩（无）誐攘喃（智）。曩（无）钵啰［二合］比底（得）。曩（无）鼻娑么（证）。哆（以）娑每（无）那（所）钵啰［二合］比底（得）怛嚩（故）。冒（菩）地（提）娑（萨）怛嚩（埵）喃钵啰［二合］（般）誐攘（若）播（波）啰（罗）弭（蜜）哆（多）么室哩底也［二合］（依）尾贺（于）啰底也［二合］（住）。只哆［引］（心）嚩（无）啰拏（挂碍）只哆（心）嚩（无）啰拏（挂碍）曩（无）悉底怛嚩［二合］（有）那（恐）涅哩［二合］素都［二合］（怖）。尾播（颠）哩也［二合］娑（倒）底（远）伽兰哆（离）。宁瑟吒（究竟）宁哩也嚩［二合］（涅）喃（槃）。底哩也［二合］（三）驮嚩［二合］（世）尾也［二合］嚩（所）悉体哆（经）娑嚩（诸）没驮（佛）。钵啰［二合］（般）誐攘二合（若）播（波）啰（罗）弭（蜜）哆（多）么室哩底也二合（依）。阿耨哆兰（上）参（正）藐也［二合］（等）参（正）没地（觉）么鼻参没驮（现证）。哆引（是）娑每［二合］（故）誐攘［二合］哆（应）尾演（知）。钵啰［二合］（般）誐攘［二合］（若）播（波）啰（罗）弭（蜜）哆（多）么贺［引］（大）满怛啰（咒）。么贺（大）尾你也［二合］（明）满怛啰（咒）。阿（无）耨哆啰（上）满怛啰（咒）。阿娑么（无等）娑么（等）满怛啰（咒）萨嚩（一切）耨佉（苦）钵啰［二合］舍曩（止息）。娑（真）底也（实）么弭（不）赞哩也［二合］怛嚩［二合］（虚）。钵啰［二合］（般）誐攘（若）播（波）啰（罗）弭（蜜）哆（多）目讫垢［二合］（说）满怛啰（咒）。怛你也［二合］他（曰）。誐谛誐谛。播攞誐谛。播啰僧誐谛。冒地［引］。娑嚩贺。
    【注】此经原文见日本大正藏第八卷第八五一页。题下注曰观自在菩萨。与三藏法师玄奘亲教授梵本。不润色。原刻颇多衍文误字。依孙慧风居士影印手校本。及民国三十二年。支那内学院蜀院木刻本。参互订正。经前尚有一序文。题云。西京大兴善寺石壁上录出。慈恩和尚奉诏述序。梵本般若多心经者。大唐三藏之所译也。三藏志游天竺。路次益州。宿空惠寺道场内。遇一僧有疾。询问行止。因话所之。乃难叹法师曰。为法忘体。甚为希有。然则五天迢递。十万余逞（似当作程）。道涉流沙。波深弱水。胡风起处。动塞草以愁人。山鬼啼时。对荒兵（似当作林）之落叶。朝行雪巘。暮宿冰崖。树挂猿猱。境多魑魅。层峦叠于葱岭。萦（似当作莹）似带雪之白云。群木簇于鹫峰。耸（疑落一字）参天之碧峤。逞（似当作程）途多难。去也如何。我有三世诸佛心要法门。师若受持。可保来往。遂乃口授与法师讫。至晓失其僧焉。三藏结束囊装。渐离唐境。或途经厄难。或时有阙斋馐。忆而念之。四十九遍。失路即化人指引。思食则辄现珍蔬。但有诚祈。皆获戬祜。至中天竺摩竭提国那烂陀寺。旋绕经藏次。忽见前僧。而相谓曰。逮涉艰险。喜达此方。赖我昔在支那国所传三世诸佛心要法门。由斯经历。保尔行途。取经早还。满尔心愿。我是观音菩萨。言讫。冲空。既显奇祥。为斯经之至验。信为般若。囗为圣枢。如说而行。必超觉际。究如来旨。巨历三祇。讽如来经。能销三障。若人虔诚受持者。体理斯而勤焉。按大慈恩寺三藏法师传。莫贺延碛。长八百余里。古曰沙河。上无飞鸟。下无走兽。复无水草是时顾影。惟一心但念观音菩萨及般若心经。初法师在蜀。见一病人。身疮臭秽。衣服破污。愍将向寺。施与衣服饮食之具。病者惭愧。乃授法师此经。因常诵习。至沙河间。逢诸恶鬼。奇状异类。绕人前后。虽念观音。不能全去。及诵此经。发音皆散。在危获济。实所凭焉。与序中菩萨授经因缘相合。而本经持诵之验。亦即此可征焉。

    以上所列。则本经由梵译汉之源流可知。至由梵译藏。近人更由藏文转译者。就著者所见。凡有五本录之如次。

    《般若心经》（日僧能海宽由藏文译日文。兹更由日文转译）。

    疑念绝赞智慧到彼岸。不生不灭虚空性。各各自明智慧之境界。三世佛母尊前皈命礼。

    如是我闻。一时世尊在王舍城鹫峰山中。与大比丘众及大菩萨众俱。尔时世尊入三昧寂定。名甚深光耀法门时圣者观自在菩萨摩诃萨。行深般若波罗蜜多。照见五蕴等自性皆空。尔时具寿舍利子承佛威力。白圣观自在菩萨摩诃萨言。若有善男子善女人。欲修行深般若波罗蜜多行者。云何教彼修学。如是言已。圣观自在菩萨摩诃萨。告具寿舍利子言。舍利子。若有善男子。善女人。欲修行深般若波罗蜜多行者。应照见五蕴等自性皆空。色不异空。空不异色。色即是空。空即是色。受想行识。亦复如是。一切法空无相。不生。不灭。无垢。无除垢。无减。无增。舍利子。是故空中无色。无受。无想。无行。无识。无眼。无耳。无鼻。无舌。无身。无意。无色。无声。无香。无味。无触。无法。无眼界。乃至无意界。无意识界。无无明。亦无无明尽。乃至无老死。亦无老死尽。无苦集灭道。无智。无得。亦无非得。舍利子。以无得故。菩提萨埵。依般若波罗蜜多。心无障碍。无怖畏。远离颠倒。究竟大涅槃际。三世诸佛。亦依般若波罗蜜多。成就阿耨多罗三藐三菩提。故知般若波罗蜜多咒。是大明咒。是无上咒。是无等等咒。是能除一切苦咒。真实不虚。即说般若波罗蜜多咒曰。达陀耶多。唵。揭谛揭谛。波罗揭谛。波罗僧揭谛。菩提娑婆诃。舍利子。菩萨摩诃萨。于深般若波罗萨多。应如是行。尔时世尊从定而起。赞圣观自在菩萨摩诃萨言。善哉。善哉。如是。如是。如汝所说修行般若波罗蜜多。诸佛如来。亦皆随喜。世尊说是语已。具寿舍利子。圣观自在菩萨摩诃萨。一切众会。天，人，阿修罗，乾闼婆等。皆大欢喜。信受奉行。
    【注】此经经能海宽由藏文译日文。著者更由日文转译。能海宽于日本明治三十六年十二月在藏圆寂。遗稿仅存此译。由其友太田保一郎于明治四十四年刊布流通。
    经中达陀耶多。为陀罗尼起句。诸咒皆然。意为即说咒曰。与上文即说般若波罗蜜多咒曰句。似重复。但日文原本如此。译者为存其真。未敢删去。

    《佛说般若波罗蜜多心经》（孙慧风由藏文转译）
    无有言说般若度。不生不灭虚空性。各各自明智行境。敬礼三世尊胜母。
    如是我闻。一时薄伽梵在王舍城耆阇崛山中。与大苾刍众及菩萨摩诃萨众俱。尔时薄伽梵等入甚深观照三摩地特异法门。复于尔时。圣观自在菩萨摩诃萨。亦行甚深般若波罗蜜多。普遍观察。照见彼五蕴等自性皆空。尔时具寿舍利子。承佛威力。白圣观自在菩萨摩诃萨言。若善男子善女人。欲行甚深般若波罗蜜多行。应如何修学。作是语已。圣观自在菩萨摩诃萨。告具寿舍利子言。舍利子。善男子。善女人。欲行甚深般若波罗蜜多行者。应作如是观。如实观察彼五蕴等自性皆空。色即是空。空即是色。色不异空。空不异色。受想行识。亦复如是。故舍利子。一切法自性空。无相。不生。不灭。无垢。无无垢。不减。不增。是故。舍利子。空中无色。无受。无想。无诸行。无识。无眼。无耳。无鼻。无舌。无身。无意。无色。无声。无香。无味。无触。无法。无眼界。乃至无意界。乃至亦无意识界。无无明。无无明尽。乃至无老死。亦无老死尽。无苦集灭道。无智。无得。亦无不得。是故。舍利子。诸菩萨众。以无所得故。依甚深般若波罗蜜多而住。心无障碍。亦无恐怖。超越颠倒。究竟涅槃。三世常住一切佛。亦依甚深般若波罗蜜多。于阿耨多罗三藐三菩提。现证正觉。是故当知般若波罗蜜多真言。是大明真言。无上真言。无等等真言。能息一切苦真言。真实不虚。即说般若波罗蜜多真言曰。噶得噶得。巴阿惹噶得。巴阿惹桑噶得。玻瑅。娑哈。尔时薄伽梵。从彼三摩地而起。授圣观自在菩萨摩诃萨言。善哉。善哉。善男子。彼如是。彼诚如是。行甚深般若波罗蜜多。应依汝所显示。一切如来悉随喜。薄伽梵说是语已。具寿舍利子。圣观自在菩萨摩诃萨。及一切在会大众。并诸世间天，人，阿修罗，乾闼婆等。皆大欢喜。现前赞扬薄伽梵所说。

    《般若波罗蜜多心经》（释楚禅由藏文转译）
    离言绝思般若波罗蜜。无生无灭自性如虚空。各各自明智慧之行境。三世佛母尊前皈敬礼。
    如是我闻。一时佛在王舍城耆阇崛山。与大比丘及大菩萨僧伽众俱。尔时世尊入住甚深明门平等三摩地。时圣者观自在菩萨摩诃萨。行深般若波罗蜜多。照见五蕴自性皆空。于是长老舍利子。承佛威神。白圣者观自在菩萨摩诃萨言。圣者。若善男女等。欲修甚深般若波罗蜜多行。应云何学。圣者观自在菩萨摩诃萨。告长老舍利子言。舍利子。若善男子。善女人等。欲修甚深般若波罗蜜多行。应如是照见五蕴自性皆空。如实随观。色不异空。空不异色。色即是空。空即是色。受想行识。亦复如是。舍利子。是诸法空相。不生。不灭。不垢。不净。不增。不减。是故空中无色。无受想行识。无眼，耳，鼻，舌，身，意。无色，声，香，味，触，法。无眼界乃至无意识界。无无明。亦无无明尽。乃至无老，死。亦无老，死尽。无苦集灭道。无智，亦无得。以无所得故。菩提萨埵。依般若波罗蜜多故。心无挂碍。无挂碍故。无有恐怖。远离颠倒梦想。究竟涅槃。三世诸佛。依般若波罗蜜多故。得阿耨多罗三藐三菩提。故知般若波罗蜜多。是大神咒。是大明咒。是无上咒。是无等等咒。能除一切苦。真实不虚。故说般若波罗蜜多咒。即说咒曰。揭谛揭谛。波罗揭谛。波罗僧揭谛。菩提娑婆诃。舍利子。此甚深般若波罗蜜多行。菩萨摩诃萨。应如是学。世尊从三摩地起。赞圣者观自在菩萨摩诃萨言。善哉。善哉。善男子。善说如是般若波罗蜜多行。诸佛如来。亦皆随喜。说是语时。长老舍利子。圣者观自在菩萨摩诃萨。以及会中一切天，人，阿修罗，乾闼婆等。皆现前如说赞叹。喜受奉行。
    【注】本译及孙慧风慧清各译。与日人能海宽日译本。所准据之藏文。似系同出一本。
    楚禅。湖北汉阳人。民国十七年于汉口千佛寺披剃。抗战后入西康雅安。兴复鹤林寺。三十三年赴甘孜及德格竹菁等地参学。佛世社得其所译心经。觉有情月刊第十卷第六期流布之。

    《般若波罗蜜多心经》（释慧清由藏文转译）
    敬礼三世诸佛母。智度离言无说议。不生不灭虚空性。自内证知所行境。敬礼佛母般若波罗蜜多。
    如是我闻。一时佛在王舍城鹫峰山中。与大比丘众及大菩萨俱。尔时世尊入法门定。名为显现甚深。复于尔时。观自在菩萨摩诃萨。照见甚深般若波罗蜜多行性。并于五蕴照见自性都空。即时具寿舍利子。承佛神力。请问观自在菩萨摩诃萨言。若有善男子。或善女人。欲修行般若波罗蜜多行者。彼当云何修学。说是语已。观自在菩萨摩诃萨。告具寿舍利子言。若有善男子，或善女人。欲修行般若波罗蜜多行者。彼当如是观照。谓正随观见五蕴自性都空。色即是空。空性是色。色不异于空性。空性亦不异色。如是受想行识。亦即是空。舍利子。是故诸法空性无相。不生。不灭。无垢。亦无离垢。无减。无增。舍利子。是故于空性中。无色。无受。无想。无行。无识。无眼。无耳。无鼻。无舌。无身。无意。无色。无声。无香。无味。无触。无法。无眼界。乃至无意界。无意识界。无无明。亦无无明尽。乃至无老死。亦无老死尽。无苦集灭道。无智，无得。亦无非得。舍利子。如是菩萨由无得故。即能依住般若波罗蜜多。心无障碍。无有恐怖。远离一切颠倒。究竟大涅槃际。三世诸佛。亦依般若波罗蜜多故。得阿耨多罗三藐三菩提。由是应知般若波罗蜜多即是咒。是大明咒是无上咒是无等等咒。是善能除灭一切苦咒。真实不虚。即说般若波罗蜜多咒曰。达嘉他。嗡姆。伽德黑。伽德黑。巴罗伽德黑。巴罗萨姆伽德黑。菩提萨娃诃。舍利子。菩萨摩诃萨。即应如是修学甚深般若波罗蜜多。尔时世尊乃从定起。赞曰。善哉。善哉。观自在菩萨。如是如是。若善男子。如汝所说。修行甚深般若波罗蜜多。诸佛如来。亦所随喜。世尊说是语已。具寿舍利子。观自在菩萨摩诃萨。与彼一切所摄眷属。及天，人，非天，健达婆等，诸世间。普皆随喜。于佛所说。信受奉行。
    【注】此译见世间解月刊第一期。

    《般若波罗蜜多心经》（释超一由藏文转译）
    敬礼婆伽梵母般若波罗蜜多心。
    如是我闻。一时佛在王舍城鹫峰山中。与大比丘僧及诸菩萨摩诃萨俱。尔时婆伽梵即入甚深明了三摩地法之异门。其时观自在菩萨摩诃萨。行深般若波罗蜜多。观察照见五蕴所有自性皆空。复次，具寿舍利子。承佛威力。白圣者观自在菩萨摩诃萨曰。若善男子欲修行甚深般若波罗蜜多者。彼应如何学。作是语已。观自在菩萨摩诃萨。答具寿舍利子言。舍利子。若善男子，善女人。欲修行甚深般若波罗蜜多者。彼应审谛观察五蕴一切自性皆空。色即是空。空即是色。色不异空。空不异色。是故受想行识。亦复皆空。舍利子。如是。一切法空性。无生。无灭。无垢。无净。无减。无增。舍利子。是故空性之中。无色。无受。无想。无诸行。无识无眼。无耳。无鼻。无舌。无身。无意。无色。无声。无香。无味。无触。无法。无眼界。乃至无意识界。无无明。亦无无明尽。乃至无老死。亦无老死尽。如是。无苦集灭道。无智。无得。亦无不得。舍利子。以无所得故。诸菩提萨埵。依止般若波罗蜜多。心无挂碍。无有恐怖。远离颠倒。究竟涅槃。三世诸佛。亦皆依此般若波罗蜜多故。证得无上正等菩提。是故谛知般若波罗蜜多咒。是大明咒。是无上咒。是无等等咒。能除一切苦。真实不虚。即说般若波罗蜜多咒曰。噶底噶底把拉噶底。把拉僧噶底。菩提莎哈。舍利子。菩萨摩诃萨。应如是学甚深般若波罗蜜多。于是婆伽梵从彼定起。赞观自在菩萨摩诃萨言。善哉。善哉。善男子。如此也。善女人。如此也。如汝所说。行此甚深般若波罗蜜多者。一切如来。亦皆随喜。婆伽梵说是语已，具寿舍利子。及观自在菩萨摩诃萨。并一切世间天、人、阿修罗、干达婆等。闻佛所说。皆大欢喜。信受奉行。
    《圣者般若波罗蜜多心经》终。

    南无敬礼上师。　敬礼佛。　敬礼法。　敬礼僧。　敬礼大母般若波罗蜜多。　敬礼彼等依止。 我等一切真实语。当愿成就。
    如前自在帝释天主，能于般若波罗蜜多义。甚深思惟。并且已作依止念诵。魔部等颠倒。一切遣除。如是。我亦能于大母般若波罗蜜多义。甚深思惟。并且已作依止念诵。当愿魔部等颠倒遣除。当愿无。当愿寂灭。一切颠倒寂灭。梓挡孤鲁也莎哈。
    寂灭八万障难颂。 远离相违灾害缘。 成就圆满诸顺缘。 愿彼吉祥此安乐。
    【注】此译从善知识汤秉遴居士寄示真言研究社出版，超一法师新译《无上三经》中录出。与日僧能海宽及慧清孙慧风各译。大致与由梵译汉之法成译本相同。楚禅译本。色不异空至娑婆诃。与玄奘三藏译本全同。可征梵本流布。汉藏无异。

    《般若波罗蜜多心经诠注·卷一》


卷二·求加被偈

    《般若波罗蜜多心经诠注·卷二》
    震旦白衣周止庵学

    上卷已略述本经源流。及各种异译。以次当依奘师译本。分别诠注。
    【注】诠有能诠所诠。能与所相对。诠。《说文》云。具也。具说事理曰诠。诠显经典之文句。以能显义理谓之能诠。所显之义理谓之所诠。《四教仪》云。教是能诠。理是所诠。注。灌也。注义于经下。若水之注物。又著也。为之解释使其义著明也。诠以明经。注以释诠。

    求加被偈
    般若胜义。非世间智慧所能窥测。兹依圣言。权说少分。敬以伽陀。上求加被。
    稽首大悲观自在。宣说般若智无碍。少文多义摄无尽。世但诵文义则晦。我亦多生丛业障。西河触动观河悔。欲疏经义导初机。如管窥天蠡测海。求大慈悲赐加被。或冥或显垂灵诲。愿所阐扬真实义。悉符佛意无违背。以此般若大火聚。烧尽无明登不退。回向法界诸有情。同证无量光三昧。
    【注】般若义详诠文胜义者。对于世俗义而言。深妙之义理也。世间智慧者。通于世谛。事相之智慧。对出世间智言。谓之世智。窥测即下文管窥蠡测之意。汉书东方朔传。以管窥天。以蠡测海。言所见之小也。圣言。圣者之言。兹者。此也。依者。依止。依止圣言者。诠注以经解经。间或旁采论疏。略参臆见。亦以不悖经恉为鹄。离经一字。便同魔说。三世诸佛。同证此言。权者。方便。《弥陀经·灵芝疏》云。权巧赴机。行法非一。权说者。为利有情。方便宣说也。少分者。圣言无量。仅说一分也。伽陀者梵语。此云讽颂。三字，四字，五字，七字，八字，九字，不等。以四句为一偈。孤起直说。故名直颂。亦名不重颂。加被者。佛力加持覆被也。
    稽首者。梵语作伴谈。或伴题。《行宗记》云。头至地为稽首。《周礼春官》。大祝辨九拜。一曰稽首。注，稽首，拜，头至地也。疏，稽是稽留之义。头至地多时。则为稽首也。拜中最重。荀子云。平衡曰拜。下衡曰稽首。注，平衡。头与腰如衡之平也。大悲者。悲心广大之义。三世诸佛。皆以大悲为根本。观世音菩萨救度众生。悲心最重。故《大悲心陀罗尼经》称观音为大悲主。《请观音经》称大悲观世音。《观经定善义》称大悲菩萨。观自在即观音新译之名。为本经说法主。宣说者。宣扬教义。说法度生也。智无碍者。即无碍智。《即身成佛义》云。无碍者。涉入自在义。谓通达自在说法之智也。于教法无滞曰法无碍。知教法所诠义理无滞曰义无碍。于诸方言词通达自在曰词无碍。为众生乐说自在曰乐说无碍。《智度论·二十五》云。四无碍智者。义无碍智。法无碍智。词无碍智。乐说无碍智（《大般若经·五百三十一》作辩无碍智）。《起信论》云。或有众生无自智力。因于广论而得解者。亦有众生复以广论文多为烦。心乐总持少文而摄多义能取解者。大经广说般若至二十万颂。菩萨为悯众生故。在般若会中承佛印可。说诸菩萨普遍智藏般若波罗蜜多心。抉择精要。简而又简。以一十四行尽之。故云少文多义摄无尽也。以精简故。自唐以来。四众间无人不诵。但白衣中亦间有一二。出于误解者。余尝以吾乡人诵心经。照见五蕴皆空句连接上文时字并读为误。后读明人注解。已先有之。又有以多字作定字解。称为多心经者。则经义之晦可知。晦者昧也。
    我者。著者自称。五蕴和合之假我也。非有我之实体。《佛地论》云。我，谓诸蕴世俗假者。《智度论》云。佛弟子辈。虽知无我。随俗法说我。非实我也。业障，惑业报见四障之一（见《海意菩萨所问净印法门经》）。众生由贪嗔痴等惑。于诸善法。不能勤行。随身口意造作恶业。障蔽正道也。西河，在今陕西省。以在黄河之西。故名西河。《礼记》子夏退老西河。丧其子而丧其明。触者。动也。凡相感而心有所动曰触。著者十六年前。因次儿永洪之逝。顿悟诸行无常。谢绝世缘。发愿注经。期以一得之愚。引导初机。同出轮回生死之苦。故曰西河触动观河悔。用《楞严经·二》。佛问波斯匿王观河之见。明色身无常。真性不迁之义。欲者。希冀之词。疏者。通也。疏通其义也。经义。契经之真义。导者。启迪之义。初机。初发心之行者也。求者。乞也。大慈悲者。如《智度论·二十七》说。大慈与一切众生乐。大悲拔一切众生苦。观音为慈悲门主。著者以至诚上求本尊之加被也。赐者。予也。或。不定词。加被。有冥加。有显加。以佛力阴为加被。资益神识。曰冥加。放光摩顶。显有所示。曰显加。自上施下曰垂。灵诲者。以灵感示诲也。愿者。祈求。阐者。显明。扬者。举也。真实义者。诸法真实之义。《准菩萨善戒经》有四。一，世流布真实义。二，方便流布真实义。三，净烦恼障真实义。四，净智慧障真实义。此属第二。悉者。皆也。符者。合也。佛意者。世尊所示正知正见也。无违背者。不相背戾也。以者。用也。此者。斯也。聚者。集合义。大火聚者。般若以智慧火。烧烦恼薪。无幽不烛。无秽不除。如大火聚也。尽者。无余义。登者。上也。进也。不退者。梵语阿鞞跋致。菩萨所修德业。永不退转之位。回向者。以所修功德。平等共有回向一切有情也。法界者。诸佛及众生之本体。四圣六凡。感报不同。故台宗为差别尘沙事相。立十法界。一，佛法界。自觉觉他，觉行共满之境界也。二，菩萨法界。为无上菩提，修六度万行之境界也。三，缘觉法界。为入涅槃，修十二因缘观之境界也。四，声闻法界。为入涅槃依佛之声教，修四谛观之境界也。五，天法界。修上品十善，兼修禅定，生天受静妙乐之境界也。六，人法界。修五戒中品十善，受人中苦乐之境界也。七，阿修罗法界。修下品十善，得通力自在之非人境界也。八，鬼法界。犯下品五逆十恶，受饥渴苦之饿鬼境界也。九，畜生法界。犯中品五逆十恶，受吞啖杀戮诸苦之畜类境界也。十，地狱法界。犯上品五逆十恶，受寒热叫唤诸苦之地狱境界也。诸者。众也。有情者。梵语萨埵。能有爱生。有情识故。故曰有情。同者。共也。证者。以无漏正智。如实证得真理也。阿弥陀佛。亦称无量光佛。无量光三昧。即念无量光佛之三昧也。《华严经·普贤行愿品》曰。亲睹如来无量光。现前授我菩提记。修此三昧。必生净土。一般念佛三昧。观像，观想，持名，为因行之念佛三昧。谓之修。由修此三种因行所成。心入禅定。或佛身现前。或法身实相。为果地之念佛三昧。谓之发得。《无量寿经》曰。于现身中。得念佛三昧。行者但具深信切愿。勤修般若正行。一心念佛。决于现生可以证得。三昧者。此云正受。正受所观之法也。亦云定。息虑凝心。定于一处而不动也。新译作三摩地。此云等持。离沉浮则定慧等。故名等。心不散则住一境。故曰持也。

    诠释此经。大科分二。初，总释名题。次，正释经文。


第一节 释名

    第一篇 总释名题

    第一章 经题

    台宗智者大师。说《法华经》经题。约名，体，宗，用，相。开为五重玄义。简核易明。今故仿之。

    第一节 释名

    名者。实之宾也。所以标举全经。列示概要。本经题名八字。为《般若波罗蜜多心经》。
    般若波罗蜜多六字。系梵语。具足应云摩贺钵罗枳娘播啰蜜多。心经二字系汉文。梵汉并举。故名《般若波罗蜜多心经》。上七字是别。别于诸经。以诸经名题不同故。下一字是通。以经之一字。通于诸经如来所说同名为经故。上七字是所诠之义。后一字是能诠之教。就别题中。复有二义。上六字是所题之法。后一字为能显之喻。法喻复列。以定此名。
    【注】诸经立题。例有七种。以人名经者。更分为四。一，举说人名者。如《净名经》、《胜鬘经》。二，举问人名者。如《弥勒问经》。三，举所说人名者。如《萨和擅太子经》。四，举所为人名者。如《玉耶经》、《须摩提女经。以法名经者。如《涅槃经》。或有就事如《枯树经》。就处如《彼伽耶山顶经》。就时如《时非时经》。皆当入此类也。以喻名经者。如《梵网经》。法喻复列者。如本经及《妙法莲华经》。人法复列者。如《胜天王般若经》。人喻复列者。如《如来狮子吼经》。人法喻具足者。如《大方广佛华严经》。本经般若波罗蜜多为法。心为喻。故曰法喻复列也。

    本经摄《大般若经》六百卷中之要义。文约义丰。就大经言。般若波罗蜜多为通名。心经为本经之专名。
    依什师译本。经题尚有摩诃二字。摩诃此云大。本经为《大般若波罗蜜多经》之心要也。义亦无碍。但奘师译本无摩诃字。今从通名。
    般若为梵语。依巴利语。译作般惹。所以译音而不译义者。以尊重故。依奘师五不翻之例也。此间语谓之智慧。照了一切诸法皆不可得。而能通达一切无碍。体性圆融。超情离见。智为实相无分别之智。慧即无分别智中妙慧。与世间智慧。从识心生。分别尘境。执取名言。发妄知见。为有漏根者不同。梵语智曰若那。慧曰般若。照见为智。解了为慧。决断为智。简择为慧。知俗谛为智。照真谛为慧。彻明妙有为智。契悟真空为慧。虽有二义。分而不分。故以无分别智中妙慧释之。
    【注】《大般若经》。即《大般若波罗蜜多经》之略称。凡六百卷。唐三藏法师玄奘于玉华寺译。
    巴利语为古时南天竺地方语。文法简易而较通俗。或云即古时摩迦陀语。
    般若为达如之慧名。在因为般若。在果即菩提。《大般若经·三百二十九》曰。菩萨摩诃萨。远离般若波罗蜜多。则为远离一切智智。又三百五十一曰。布施等五波罗蜜多。皆由般若波罗蜜多所摄受故。乃得名为波罗蜜多。又四百三十四曰。布施等六波罗蜜多。互相摄持。能到彼岸。然住般若波罗蜜多。具大势力。方便善巧。能速圆满所修布施，净戒，安忍，精进，静虑波罗蜜多。非住前五能办是事。是故般若波罗蜜多。于前五种为最为胜。为尊为高。为妙为微妙。为上为无上。无等无等等。由是因缘。独赞般若超胜余五波罗蜜多。又五百十曰。甚深般若波罗蜜多。是诸佛母。能示世间诸法实相。是故如来应正等觉依法而住（中略）。此法即是甚深般若波罗蜜多。一切如来应正等觉。无不依止甚深般若波罗蜜多。《道行般若经·二》曰。般若波罗蜜。于五波罗蜜最尊。譬如极大地。种散其中。同时俱出。般若波罗蜜是地。五波罗蜜是种。从其中生。萨芸若者。从般若波罗蜜成。《智度论·百》云。般若波罗蜜是诸佛母。诸佛以法为师。法者是般若波罗蜜。
    奘师五不翻之例。一，秘密不翻。如诸陀罗尼是。二，含义多不翻。如婆伽梵之含自在、炽盛、端严、名称、吉祥、尊贵等六义是。三，此土所无不翻。如阎浮提是。四，顺古不翻。如阿耨多罗三藐三菩提是。摩腾以来存梵音故。五，尊重不翻。如般若二字。可令闻者生信。译作智慧。含义轻浅。易与世智相混是。译梵成汉。向有四例。一，音字俱翻者。如诸经文。二，音字俱不翻。如西来梵夹。三，翻音不翻字。如佛胸（卍）字。以此方万字之音翻之。而字仍梵书。四，翻字不翻音。如诸陀罗尼。以此方之字。存彼土之音。至奘师更定五不翻之例。
    准龙树菩萨《大智度论》。般若分类。约举有三。一，实相般若。二，观照般若。三，文字般若。
    实相般若者。谓法身真空之体。元无名相。于无名相中。建立假名而谈实相。故名实相。心源湛然。非寂非照。理性常住无相而无不相。即吾人虚灵不昧之本觉真心也。
    【注】《净名经·天台疏》云。诸经异名。说真性实相。或言一实谛。或言自性清净心。或言如来藏。或言如如。或言实际。或言实相般若。或言一乘。或言首楞严。或言法性。或言中道。或言毕竟空。或言正因佛性。性净涅槃。如是等种种异名。皆是实相之异称。《智度论》云。般若是一法。佛说种种名。随诸众生类。为之立名字。
    寂谓寂静。照谓照明。寂照皆非者。用遮二边。以显中道实相之德也。离虚妄相名为实相。无一切虚妄相。故曰无相。具足恒沙功德之相。故曰无不相。盖实相即中道真实之妙理。曰法性。曰真如。皆同体而异名。就万法体性言之曰法性。就其体真实常住言之曰真如。就真实常住为万法本体言之曰实相。《涅槃经》曰。无相之相。名为实相。《法华文句》云。言实相者。非虚故实。非相为相。故名实相。《金刚经》曰。是实相者。则是非相。是故如来说名实相。又曰。凡所有相。皆是虚妄。若见诸相非相即见如来。见诸相非相是照见蕴空义即见如来。是实相义。
    本觉真心。即众生本来心体之自性清净心。离一切妄相。本来觉了。虚灵不昧之本性也（众生迷之。故须修持）。《仁王经》曰。自性清净名本觉性。

    观照般若者。乃实相体所起之用。即心体上本具之智慧光明。以般若之实智。成能观之妙慧。非照而照。了法无相。法性幽玄。非此莫鉴。照见五蕴诸法。是照俗谛。照见诸法皆空。是照真谛。依实相般若之体。起观照般若之用。由观照般若之用。契实相般若之体。盖实相如明镜。烦恼如尘垢。观照如磨治。般若妙智。有如镜光。众生皆具实相。即皆有智慧光明。尘劳所蔽。如镜蒙垢。但能用功观照。静极光通。自可契入真空妙理。是曰观照般若。
    【注】非照而照者。谓理本非照。因观而照。以显观照之实智也。

    文字般若者。诠释般若之言教也。文字是能诠之文。般若是所诠之法。般若之用。无所不赅。随缘不变。不变随缘。横遍十方。竖穷三际。凡足以示教利喜。断疑生信者。实相所显。观照所得。皆可谓之文字。文字性空。性空之体即是般若。《楞严经》曰。妙性圆明。离诸名相。《大般若经》曰。总持无文字。文字显总持。由般若大悲。离言以言说。诚以实相观照。虽藉文字以显。文字非般若之体。而般若藉文字以传。亦如此土恒言。所谓文以载道也。盖般若实相。众生本具。但为无明所障。不得显现。欲显实相。必须言语道断。心行处灭。自证自得。本不藉于文字。惟众生蒙昧已久。不假方便。障无由开。道本无言。而道因言显。故仍藉文字启导。使得悟入。因文字而起观照。由观照而证实相。实相是体。观照是用。以文字之方便善巧。分别诸法。因文见道。是曰文字般若。亦曰方便般若。
    【注】言教者。如来以言语垂示之教法也。《法华经·方便品》曰。种种譬喻。广演言教。《大般若经·五百九十三》曰。一切法不离名言。若解诸法。若知诸法。俱不可说。然顺有情所知而说。故名般若。
    真如之体。从本以来。毕竟平等。无有变易。不可破坏。体恒寂静。无一异相。名不变真如。真如之性。本无生灭。然因无明熏动。起一切相。如水因风而生波。风止波平。元无动相。名随缘真如。真如之本体不变。触所缘而生起万有。曰不变随缘。虽触缘而现万有。其体仍真常不变。曰随缘不变。
    亘于时间者曰竖。空间者曰横。遍。普也。穷。极也。十方。东，西，南，北，东南，西南，东北，西北，上，下也。三际。犹云三世。过去，现在，未来三世也。示教利喜者。示谓示人之好丑。善不善。应行不应行。如生死为丑。涅槃为好。分别三乘。分别六波罗蜜等。教谓教以舍恶行善。利谓说法诱引。导之以利。喜谓随其所行赞叹。令生欢喜。诸佛菩萨以庄严此四事说法。见《智度论》。
    蕅益大师曰。吾人现前一念介尔之心。虚明洞彻。了了常知。不在内外中间诸处。亦无过现未来形迹。即是观照般若。吾人现前一念介尔之心。炳现根身器界。乃至十界假实国土。平等印持。不前不后。同时顿具。即是文字般若。盖山河大地。明暗色空。一切境界。无非文字。不但纸墨语言也。吾人现前一念介尔之心。所有知觉之性。与境界之性。无分别。无能所。无是非。统惟一法界体。即是实相般若。
    言语道断。心行处灭。即言忘虑绝之意。《大般若经·五百七十一》曰。性离文言。心行处灭。是名为法。一切法性皆不可说。其不可说，亦不可说。若有所说。即是虚妄。虚妄法中。都无实法。《三论玄义》云。诸法实相。言忘虑绝。心即心念。刹那迁流。故曰心行。究竟之真理。不可言说。故曰言语道断。不可思念。故曰心行处灭。《仁王经》曰心行处灭。言语道断。同真际。等法性。《止观》云。言语道断。心行处灭。名不可思议境。

    般若虽三。原同一相。无相之相。即是大觉圆常真空之体。一念正观圆修。照了诸法皆空。是为圆证。
    窥基、圆测诸大师。依据《瑜伽》、《摄大乘》诸论。于上述三般若外。更说境界般若。眷属般若二种。
    境界般若者。谓一切诸法为般若之所缘。即般若真智照了一切诸法皆不可得。通达无碍。皆以一切诸法为境界。境无自相。由智显发。以根本智、后得智照了一切诸法境界。悉本空寂。从境得名。故名境界般若。
    【注】根本智。即如理智。亦名无分别智。菩萨亲证本有之智。不依于心。不缘外证。了一切法皆是真如。无能缘所缘之别。冥符真理。一念之真智也。
    后得智为菩萨证根本智后所得行满化他之智。菩萨起行度生。依心缘境。种种分别。据《摄大乘论·五》释后得智凡五。一，通达。谓菩萨由后得智。能观心中所知所见。一切境界。皆悉无碍。二，随念。亦名忆持。谓菩萨由后得智。于前观心中通达诸法境界之相。出观之后。随念忆持不失。三，安立。亦名成立。谓菩萨由后得智。于所通达诸法境界。能立正教。令他修行。四，和合。亦名相杂。谓菩萨由后得智。于先所缘一切诸法和合相杂境界。而能观察照了。转烦恼依菩提。五，如意。谓菩萨由后得智。既得转烦恼依菩提。一切所欲。皆悉随意。对如理智而言。后得智亦名如量智。

    眷属般若者。谓暖、顶、忍、世第一，及戒、定、慧、解脱、解脱知见诸法。皆是观照慧性之属。故名眷属般若。
    【注】暖、顶、忍、世第一，四者为加行位。戒即戒律，定即禅定，慧即智慧，解脱即自在，解脱知见谓智眼照了诸法皆空，无有障碍，而得自在也。此五功德法。谓之五分法身。由戒而生慧。由慧而生定。由定而得解脱。由解脱而有解脱知见。前三从因得名。后二就果受号。

    综而论之。般若实为众德之首。万行之导。一切波罗蜜中。唯此最胜。实相。理也。观照。慧也。文字。教也。境界。诸法也。眷属。万行也。诸法万行。亦可摄于文字观照之中。故广之为五。约之为三。
    【注】般若有二种相。一，世间般若。谓诸菩萨惟依读诵、书写、演说三乘，劝化修行，灭除烦恼。如是般若，有见有相，是名世间般若。二，出世间般若。诸菩萨精勤修习。心如虚空。平等寂灭。离诸名相。如是般若。无取无著。是名出世间般若。
    诸师释般若分境、行、果三义。境者。一切智，道相智，一切相智。所摄一切能诠之名言。与所诠之法相皆是。行有深广二义。深即本经所示观行之深般若。广则六度（布施、持戒、精进、忍辱、静虚、般若）四摄（布施、爱语、利行、同事）。果即由此甚深般若显示妙义，引生六度万行种种广行所得之果（证三身四智之般若果。诸佛圆证。三乘各得一分）。又分体、相、用三义。体有真体俗体。俗体即俗智。真体分二。一者。亲证般若。言忘虑绝。百非俱遣。此惟佛能究尽。二者。疏缘般若。般若本空。无可言说。但众生沉迷生死。欲为拔度。必赖言诠。故以无量言说。谈此胜义。以非亲证。故为疏缘般若。相者。即一切法相。自初发心以至金刚道。断烦恼执。因果宛然。义理和合。般若相现。用者。四谛，十二因缘，六度，万行，一切诸还灭法皆是。二义参勘。般若之境，其体也。般若之行，其相也。般若之果，其用也。又有以二智释般若者。一，真智般若。即实相般若。根本智也。二，俗智般若。即缘一切五明（一，声明。明了一切声教也。二，因明。明了万法生起之因也。三，医方明。明了一切病因通达对治之法也。四，工巧明。明了一切工业文化之巧妙也。五，内明。明了佛法内教一切对治之法也）而得之后得智也。以三慧释者。一，闻慧般若。二，思慧般若。三，修慧般若。

    波罗蜜多亦梵语。旧译作波罗蜜。依巴利语无尾音故。波罗此云彼岸。蜜多此云到。印度文法。名先动后。故顺此土文字。当作到彼岸。《大智度论》译作事究竟。《瑞应经》译作度无极。《大乘义章》译作度。义并可通。又以与梵语阿罗蜜语音相近。阿罗蜜此云远离。故亦有以远离释波罗蜜者。慈恩所谓由行般若离诸障染也。要以到彼岸为最契合。
    【注】唐后以罗什法师所译为旧译。玄奘法师所译为新译。《华严经疏》云。译经二派。会意译经。秦朝罗什为最。敌对翻译大唐三藏称能敌对者。唐梵对字。三藏。即玄奘也。

    彼岸者，对此岸之称。生死为此岸。烦恼为中流。涅槃为彼岸。即菩提，涅槃，二胜果也。行深般若者。照见五蕴皆空。无明尽灭。见烦恼即实相。生死即涅槃。超二死海。至三德岸。名到彼岸。迷者妄执身心为有。遂失慧光。不了诸法实相。沉沦生死。名住此岸。《华严经》曰。我观一切众生。俱有如来智慧德相。但以妄相执著而不证得。故纤情未尽。便隔彼岸。凡圣情忘。即到彼岸。《智度论》云。有无二见。皆属此岸。二执俱空。始达彼岸。盖岸属假名。本无彼此。此岸彼岸，仅同设喻。为使人易解。姑以迷为此岸。觉为彼岸。迷觉之别。只在一心。《大般若经》曰。若菩萨摩诃萨。行深般若波罗蜜多时。不得彼岸。不得此岸。不得中流。是为菩萨摩诃萨甚深般若波罗蜜多。又曰。甚深般若波罗蜜多。非般若波罗蜜多。非非般若波罗蜜多。非此岸。非彼岸。非中流。非陆。非水。非高。非下。非平等。非不平等。非有相。非无相。非世间。非出世间。非有漏。非无漏。非有为。非无为。非善。非非善。非有记。非无记。非过去。非未来。非现在。《心经请益说》云。波罗蜜多。此翻彼岸到。所云到者。但照见此岸本空。此岸即是彼岸。非别有彼岸可到也。
    【注】二死者。一，分段生死。分即分限。段即形段。谓六道众生。随其业力所感果报。身有短长。命有寿夭。而流转于生死也。二，变易生死。因移果易。名为变易。谓声闻、缘觉、菩萨。虽离三界内分段生死，而有方便等土变易生死。初位为因。后位为果。后位为因。后后位为果。以其因移果易。故名变易生死。超二死海者。即超越分段变易二死之此岸也。
    慧光。智慧之光也。《无量寿经》曰。慧光明净。超逾日月。
    诸法实相者。诸法即十界因果之法。实相者。实非虚妄。相即无相。离本来虚妄之相。即万有本体之称。法性、真如、实际、一相、无相、法身、涅槃，皆诸法实相异名。《智度论·三十二》云，如、法性、实际，是三皆是诸法实相异名。又七十九云。诸法实相。有种种名字。或说空。或说毕竟空。或说般若波罗蜜。或名阿耨多罗三藐三菩提。《思益经·二》曰。诸法实相。即是涅槃。诸宗又各以其义解之，如净土宗以弥陀名号为诸法实相。华严宗以一真法界为诸法实相。唯识宗以圆成实性为诸法实相。天台宗以中道第一义谛为诸法实相。三论宗以八不中道为诸法实相。成实宗以皆空为诸法实相。是也。《阿弥陀经要解便蒙钞》云。大乘经以实相为印。为经正体。《观经智者疏妙宗钞》云。诸法当处不生不灭。非有非空。无能无所。离言说相。离名字相。离心缘相。离此等相。名为实相。无相之相也。
    《心经请益说》云。依共般若。声闻以苦集二谛为此岸。道谛为舟航。灭谛为彼岸。缘觉以十二因缘、三世流转、循环无尽为此岸。观智为舟航。缘生心空，即寂灭相，为彼岸。权乘菩萨以六蔽（一，悭贪。二，破戒。三，嗔恚。四，懈怠。五，散乱。六，愚痴）为此岸。六度为舟航。佛果为彼岸。若依不共般若。总以凡夫蕴、处、界，及三乘圣贤所修所证为此岸。以观照般若为舟航。实相真空为彼岸。此经智慧到彼岸。即不共般若。
    《心经幽赞》云。波罗者彼岸义。古说有二。谓菩提、涅槃。今释有五。一，所知。二，教。三，理。四，行。五，果。蜜多者。离义。到义。由行般若离诸障染。

    《心经幽赞》云。修波罗蜜多。约行相言。总具七种最胜。一，安住菩萨种性。谓志在大乘，不以定性二乘、不定性及无种性自卑也。二，依大菩提心。谓以佛心为心而不局于九界也。三，悲愍有情。谓凡有血气，皆当悯其生死苦痛，不容漠视也。四，具行事业。谓施、戒、忍、进，一切善业，躬行实践也。五，无相智摄。谓虽诸恶莫作，众善奉行，而不著一相也。六，回向菩提。谓一切功德，悉作佛力加被，庄严净土，不自求报也。七，不为二障间杂。凡夫以烦恼障而间断。二乘以所知障而夹杂。皆非大乘之器也。若行慧等一切善业。随阙此一。非到彼岸。
    【注】行相者。相谓相状。行境之相状。名为行相。《俱舍光记·四》云。有所行境界相。故名行相。
    菩萨种性。为唯识宗所立五性之一。第一。定性声闻。第二。定性缘觉。第三。定性菩萨。即菩萨种性也。第四。不定性。更分四。一，菩萨声闻不定。二，菩萨缘觉不定。三，声闻缘觉不定。四，声闻缘觉菩萨不定。第五。无性。无三乘无漏种子者。
    大菩提心者。求大菩提之心也。菩提旧译为道。道者通义。新译为觉。觉者觉悟。有事理二法。理者涅槃。断烦恼障而证涅槃之一切智是。通三乘之菩提也。事者一切有为之诸法。断所知障而知诸法之一切相智。是佛之菩提也。佛之菩提。通于二者。故谓之大菩提。
    九界者。即十界中除佛法界而言。
    无相智者。证知中道之理。离二边相之智慧也。《大乘义章·二》云。言无相者。释有两义。一，就理彰名。理绝众相，故名无相。二，就涅槃法相释。涅槃之法离十相（色相、声相、香相、味相、触相、生相、住相、坏相、男相、女相），故曰无相。
    回向者。回者。回转。向者。趣向。回转自己所修之功德。而趣向于所期。谓之回向。回向菩提者。回转己之功德。而趣求菩提也。《大乘义章·九》云。回向不同。一门说三。一，菩提回向。二，众生回向。三，实际回向。
    梵语波罗。此云凡夫。世间常人也。新译作异生。《大威德陀罗尼经》曰。于生死迷惑流转。住不正道。故名凡夫。
    二乘。即声闻乘与辟支佛乘。佛教有大乘、中乘、小乘之三乘。一者。声闻乘。即小乘。有五种。一，决定声闻。久留小乘，今世道熟，闻小乘而证果也。二，上慢声闻。于小法未得谓得，未证谓证，即凡夫也。三，退大声闻。菩萨于修行中疲厌生死，退大乐小，值佛出世，闻小法而证果也。四，应化声闻。菩萨内秘外现，示声闻之相也。五，佛道声闻。以佛道之声，使一切闻，一切众生悉归涅槃也。见《法华文句》。此等声闻，速则三生，迟则六十劫间修空法。终于现世闻佛声教，悟四谛理而证果也。一，须陀洹果。须陀洹，此云入流，即初果。谓断三界见惑尽，预入圣流也。二，斯陀含果。斯陀含，此云一来。谓九品思惑中已断前六品，因后三品思惑未尽，尚当于欲界人天受生一度也。三，阿那含果。阿那含，此云不还。谓已断欲界后三品思惑，不再还欲界受生也。四，阿罗汉果。阿罗汉，此云无学。谓断色无色界思惑已尽，四智已圆，超出三界，不受后有也。二者。辟支佛乘。辟支此云因缘觉。故亦曰缘觉乘。在三乘中为中乘。速则四生，迟则百劫间修空法。于其最后之生，感飞花落叶之外缘，悟十二因缘法，无师友教，自然独悟。梵语具足当云钵刺翳迦佛陀旧译缘觉。新译独觉。《华严会义》云。梵语毕靳支底迦。此云各各独行。钵罗底迦。此云缘觉。辟支迦罗。名通二种。《智度论》二名俱存。谓初发心时值佛，思唯世间之法，后得道身。出无佛世，性好寂静，加行满而无师友之教，自然独悟，故名独觉。又观待内外缘而悟圣果，故名缘觉。台宗则别之为二。无佛世之悟道者为独觉。于佛世观十二因缘得道者为缘觉。《智度论》云。先世种辟支佛道因缘，今世得少因缘出家，亦观深因缘法成道，名辟支佛。三者。菩萨乘。菩萨具云菩提萨埵。此云觉有情。是为大乘。于无数劫间，修六度（布施、持戒、精进、忍辱、静虑、般若）万行（万是此方大数。表其最多。行是修德都名。约之不出二种。一，慧行。二，行行。般若波罗蜜多名慧行。五波罗蜜多名行行。慧行名正行。行行名助行。助行有显有密。清净律仪为显行。坛仪心咒为密行。又涅槃经明五种行。一，圣行。二，梵行。三，天行。四，婴儿行。五，病行。圣行，天行为上求佛道之行。梵行、婴儿行、病行，为下化众生之行。是名次第五行。又有一心五行。则一行一切行。一切行一行。所谓一心圆五行也），植三十二福相因，以证无上菩提。
    二障者。一，烦恼障。由我执而生见思二惑。起种种昏烦之法。恼乱心神。以致障碍无漏法性。二，所知障。又名智障。由法执而生。因根本无明之惑。覆蔽法性。不能了知诸法实相。以致障碍菩提妙智。有烦恼障。则生死相续。无由脱离。故障涅槃。有所知障。则无明妄染。碍正知见。不达真如。故障菩提。烦恼。事障也。所知。理障也。事是烦恼。烦恼即障也。理是所知。所知非障。被障障所知也。此二障各有俱生、分别二种。俱生者。无始以来虚妄熏习之因力。恒与身俱。不俟外缘自然转起之烦恼也。分别者。兼藉现世种种外缘。分别计度。然后方起之烦恼也。详后注。

    菩萨从因位修习波罗蜜多。须经三阶段。第一阿僧祇劫。自三贤四加行以至初地。修习各波罗蜜多。道力尚微。被烦恼伏。由斯烦恼不觉现行。名远波罗蜜多。第二阿僧祇劫。自二地以至七地。修习各波罗蜜多。道力渐增。能伏烦恼。由斯烦恼故意方行。名近波罗蜜多。第三阿僧祇劫。自八地以至十地等觉。修习各波罗蜜多。道力全盛。毕竟能伏一切烦恼。由斯烦恼永不现行。名大波罗蜜多。
    【注】因位者。修行佛果之位次。自初发心以至等觉。皆在因地。成佛以后。方为果地。
    烦恼，亦名盖。覆盖善心。使不开发也。亦名漏。令人漏落于三恶道也。亦名惑。迷妄之心。迷于对境。颠倒真理也。诸经中开合不同。分类亦异。略举如次。
    二烦恼。一，根本烦恼。贪、嗔、痴、慢、怀疑、恶见六大烦恼，为一切烦恼之本，故名根本烦恼。二，随烦恼。忿、恨、恼、覆、诳、谄、憍、害、嫉、悭之十，为小随烦恼。无惭、无愧之二，为中随烦恼。不信、懈怠、放逸、惛沈、掉举、失念、不正知、散乱之八，为大随烦恼。又《华严经疏》。以无明种子潜伏藏识之中能生一切妄惑者，为随眠烦恼。根尘相对，现起烦恼，为现行烦恼。
    三烦恼。一，见思烦恼。二，尘沙烦恼。三，无明烦恼。
    四烦恼。一，我痴。二，我见。三，我慢。四，我爱。
    六烦恼。一，贪烦恼。染著为性。生苦为业。二，嗔烦恼。憎恚为性。不安与恶行之所依为业。三，痴烦恼。迷闇为性。诸惑之所依为业。四，慢烦恼。恃己高举为性。生苦为业。五，疑烦恼。犹豫为性。障信心为业。六，恶见烦恼。颠倒推求之恶慧为性。能障善见而生苦为业。
    十烦恼。上六烦恼中。第六恶见。又可开为五种。一，身见。固执实我。二，边见。偏执我之断常。三，邪见。拨无因果之理。四，见取见。固执诸见。及所依蕴为最胜。为一切斗诤之本。五，戒禁取见。固执非理之戒禁。故合之则为六烦恼。开之则为十烦恼。
    百八烦恼。眼耳鼻舌身意六根。对色声香味触法六尘。各有好、恶、平，三种不同。则成十八烦恼。六根对六尘好、恶、平三种。各有苦受、乐受、不苦不乐受。复成十八烦恼。共成三十六种。积过去、现在、未来三世。总成百八烦恼。

    《大般若经》曰。般若波罗蜜多。即是如来、应、正等觉。如来、应、正等觉。即是般若波罗蜜多。又曰。甚深般若波罗蜜多。能生诸佛一切功德。能示世间诸法实相。又曰。如是般若波罗蜜多。能与一切善法为母。一切声闻、独觉、菩萨、如来、善法从此生故。如是般若波罗蜜多。普能摄受一切善法。一切声闻、独觉、菩萨、如来、善法依此住故。又曰。修行般若波罗蜜多。不住此岸。不住彼岸。不住中流。是谓菩萨摩诃萨行般若波罗蜜多。盖般若波罗蜜多。总摄六度万行。故为最胜。《智度论》云。般若波罗蜜多是诸佛母。父母之中。母功为重。是故佛以般若为母。般若波罗蜜能遍观诸法分别实相。无事不达。无事不成。功德大故。名之为母。以是故。行者虽行六波罗蜜及种种功德。和合能具众愿。而但说当学般若波罗蜜。又云。菩萨行般若波罗蜜时。普观诸法皆空。空亦复空。灭诸观得无碍。般若波罗蜜。以大悲方便力。还起诸功德业。无愿不得。其余功德。离般若波罗蜜。无有无碍智慧。
    《华严经》于般若波罗蜜多。更开方便、愿、力、智四波罗蜜多。合之六度。共成十波罗蜜多。而以般若为十度之纲领。《大般若经》曰。如是般若波罗蜜多。能与一切善法为母。一切声闻独觉菩萨如来善法。从此生故。如是般若波罗蜜多。并能摄受一切善法。一切声闻独觉菩萨如来善法。依此住故。《小品般若》曰。若过去诸佛阿耨多罗三藐三菩提。皆从般若波罗蜜生。未来诸佛阿耨多罗三藐三菩提。亦从般若波罗蜜生。现在无量阿僧祇世界诸佛阿耨多罗三藐三菩提，亦从般若波罗蜜生。
    【注】如来。应。正等觉。皆佛号也。《往生论注》曰。诸佛如来德有无量。德号亦无量。若欲具谈。笔纸所不能载。是以诸经或举十名。或腾三号。盖存至宗而已。非以此为尽也。所谓三号。即如来。应。正等觉也。如来。梵语多陀阿伽陀。亦作怛他揭多夜。具云怛闼阿竭怛他蘖多夜。此云如来。亦云如去。《大疏》云。怛他是如义。揭多是来义。知解义。说义。去义。诸佛乘如实道。来成正觉。今佛亦如是来。故名如来。诸佛如法实相知解。知已为众生说。今佛亦如是。故名如是知者。如是说者。《广博严净经》曰。能知过去如，亦知未来如。见一切法如是。故名如来。诸佛得如是安乐性。直至涅槃中。今佛亦如是去。故名如去。具含四义。而独称如来者。顺古译也。如者，真如。真如之道。从因来果而成正觉（道是因。觉是果。境智契合而未穷满之位为因。已穷满之位为果）。体离虚妄。故云如实。体如而来。故曰如来。如来有三身。理法聚名法身。聚集法性之法而成。梵语毗卢遮那。此云遍一切处。性相常然。身土无碍。《金刚经》曰。无所从来。亦无所去。故名如来是也。智法聚名报身。智与法性相合而成。内以智光照真法界。理智如如。修因感报。梵语卢舍那。此云净满。诸惑净尽。众德悉圆。《转法轮经》曰。第一义谛名如。正觉名来是也。功德法聚名应身。智与体冥。起用化他。随机应现。说法利生。梵语释迦牟尼。释迦。此云能仁。佛之姓也。牟尼。此云寂默。佛之名也。能仁故不住涅槃。寂默故不住生死。《成实论》曰。乘如实道（乘者。如如之智。如实者。如如之境）。来成正觉是也。有来有去。皆此应身。法身常住不动。无所谓来去。遍一切处。亦无须乎来去。所谓不取于相。如如不动也。应。即应供。梵语阿罗诃。谓智德圆满。福慧具足。堪受人天供养也（梵语三名相通。一，阿罗诃。此云应供。二，阿罗汉。此云无生。亦云无著。三，阿卢诃。此云杀贼。故阿罗诃为五住究尽之号。与声闻四果之阿罗汉不同。《准增一阿含经》。有三应供养。一，如来。出现世间。利乐一切众生。于天人中最尊最上。不降伏者而降伏之。无救护者而救护之。未度脱者而度脱之。以是因缘。一切天人所应供养。二，阿罗汉。生死已尽。梵行已立。利益有情。为世福田。以是因缘。一切天人所应供养。三，转轮圣王。以正法治天下。使人民不杀不盗。各得其所。以是因缘。一切人民所应供养）。正等觉。梵语三藐三菩提。以一切法平等开觉众生。成无上觉。亦译正遍知。谓具一切智于一切法无不了知也。此三号以外。尚有七名。即明行足（《大般若经》作明行圆满）。梵语鞞侈遮罗那三般那。明者。宿命、漏尽、天眼之三明。行者。身口意诸行三业清净。足者。满足也。善逝。即妙往之义。梵语修伽陀。谓以无量智慧。能断诸惑而入涅槃。妙出世间以成佛果也。世间解。梵语路伽惫。能解世出世间一切诸法也。无上士（《大般若经》作无上丈夫）。梵语阿耨多罗。谓业缚净尽。于三界中第一。最上无等也。调御丈夫（《大般若经》作调御士）。梵语富楼沙昙藐婆罗提。谓具大丈夫力用。以种种方便。调伏制御一切众生。令离垢染得涅槃也。天人师。梵语舍多提婆魔［少／兔］沙喃。谓三界众生之师表也。佛。梵语具云佛陀。此云觉。谓具一切种智。自觉觉他觉行圆满也。《广博严净经》曰。觉无明无知。其性无所有。已得于明智。是故名为佛。以上十名。《大般若经》。《瑜伽师地论》。合无上丈夫、调御士为一。连薄伽梵为十号。《成实论》合无上士、调御丈夫为一。《佛说十号经》。合世间解、无上士为一。而另加世尊之称为十号。《智度论》以世尊为十号外别一尊号。世尊。梵语路迦那他。谓万德圆满世所尊重也。《广博严净经》曰。不畏于生死。正住生死中。化度诸众生。是故名世尊。薄伽梵。为总众德至上之称。《佛地论》云。自在、炽盛、与端严，名称、吉祥、及尊贵，如是六德义圆满。盖如来永不属诸烦恼系缚，故云自在。智火猛焰，洞达无际，故云炽盛。三十二相，庄严妙好，故云端严。圆满一切殊胜功德，十方世界，无不闻知，故云名称。一切世间，赞叹供养，皆获吉庆，故云吉祥。从兜率天，降生王宫，出家修道，位登妙觉，故云尊贵。以一名而具六义也。
    无碍者。涉入自在义。无碍智者。佛智之通达自在也。
    六度者。第一。檀那波罗蜜。檀那此云布施。运心普周曰布。辍己惠人名施。菩萨为令众生心满足故。内外悉舍而无所著。是名檀那波罗蜜。此度三行。一，财施。以己财物。施与他人。令其安乐。二，法施。以佛法为众生演说。令其开悟。三，无畏施。慈心不杀。令无怖惧。第二。尸罗波罗蜜。尸罗有清凉义。此云戒。谓离热闹得清凉。亦云防止。谓调练身口意三业。止过防非。好行善道。不自放逸也。《戒经》云。菩萨具持众戒而无所著。是名尸罗波罗蜜。此度三行。一，摄律仪戒。谓持佛戒律。具众威仪。二，摄善法戒。谓身口意，所作善法。皆悉摄持。三，饶益有情戒。以无缘慈济度众生。拔苦与乐。平等利益。第三。羼提波罗蜜。羼提此云忍辱。他人加恼为辱。于辱安受曰忍。谓内心能安然忍受外辱。菩萨忍受一切诸恶。于诸众生其心平等。无有摇动。是名羼提波罗蜜。此度三行。一，耐怨害忍。谓若遇怨憎毒害。安然忍耐。无返报心。二，安受苦忍。谓若遇水火刀杖。贫病寒热。众苦所逼。恬然忍受。三，谛察法忍。谓谛审诸法。体性虚幻。本无生灭。安然忍可。第四。毗梨耶波罗蜜。毗梨耶此云精进。精砺身心。进修善法。菩萨普发众业。常修靡懈。诸有所作。恒不退转。是名毗梨耶波罗蜜。此度三行。一，被甲精进。谓起大誓愿。修诸胜行。二，摄善精进。谓修方便行。进趋无上菩提。三，利乐精进。谓勤化众生。咸修正道。第五。禅那波罗蜜。禅那此云静虑。亦曰定。亦曰三昧。亦曰智生。谓念虑皆忘。安心理境。思惟真理，定止散乱。依定而生智也。菩萨于色声香味触五欲境。无所贪著。初禅、二禅、三禅、四禅，诸次第定。悉能成就。是名禅那波罗蜜。此度三行。一，安住静虑。谓乱想不起。深入禅定。远离一切惛掉爱相。得轻安寂静法乐。现法乐住。二，引发静虑。谓智慧现前。生诸功德。引发六种神通。三，办事静虑。谓功行圆满。利益众生。第六。般若波罗蜜。般若此云智慧。决定审理为智。造心分别为慧。照了诸法。断惑证真。菩萨于诸佛所。善观诸法。得实相印。普入一切智门。是名般若波罗蜜。此度三行。一，生空无分别慧。谓平等照了俗谛诸法。无生灭相。二，法空无分别慧。谓平等照了真谛诸法。体相皆空。三，俱空无分别慧。谓等观真俗二谛。并空亦空。《华严经》于六度以外。更从般若波罗蜜中。开出四波罗蜜。即第七。沤和俱舍罗波罗蜜。沤和俱舍罗。此云善巧方便。随机利物。称适缘宜也。菩萨运平等大慈之心。教化众生。不生厌倦。是名沤和俱舍罗波罗蜜。此度三行。一，进趣果向方便。以前六度所集善根。共诸有情回向无上菩提。二，巧会有无方便。谓善巧融会真俗二谛。三，拔济方便。以大悲心拔济众生。了达能所皆空。第八。尼坻波罗蜜。尼坻。此云愿。愿即誓愿。上求佛道。下化众生。尽未来际。成就行愿也。菩萨成就一切众生。供养一切诸佛。尽未来劫。证如来智。是名尼坻波罗蜜。此度三行。一，求菩提愿。愿于当来速证菩提。二，利乐他愿。救度一切众生。三，外化愿。外化有情。亦起自利利他之愿。第九。末罗波罗蜜。末罗此云力。谓行满功成。万境无动。善办众事也。菩萨具深心力。无有杂染。乃至具加持力。令信解领受。是名末罗波罗蜜。此度三行。一，思择力。谓思惟拣择一切善法。二，修习力。谓修行数习殊胜妙行。三，变化力。谓神通力用。化度众生。第十。阇那波罗蜜。阇那亦作若那。此云智。谓决断无惑。证法怡神。善入佛慧。明了无碍也。菩萨知一切法真实。知一切如来力。普觉悟法界门。是名阇那波罗蜜。此度三行。一，无相智。谓观达一切诸法。自性本空。二，受用法乐智。谓修行证得一切相智。恒自受用。得大自在。三，成就有情智。谓教化饶益一切众生。成就道果。《大般若经·三百五十一》曰。若无般若波罗蜜多。布施等五。不得名为波罗蜜多。要因般若波罗蜜多。布施等五。乃得名为波罗蜜多。由此前五波罗蜜多。摄在般若波罗蜜多故。但有一波罗蜜多。是故一切波罗蜜多无差别相。又曰。甚深般若波罗蜜多。了达一切都无所有。能拔有情世俗作用。生老病死。由此故说甚深般若波罗蜜多。于布施等波罗蜜多。为最。为胜。为长。为尊。为妙。为微妙。为上。为无上。
  《成唯识论述记·九》云。六种波罗蜜多。通相。皆二。与智俱行。并名为智。与福俱行。并名为福。别相。前五说为福德。第六智慧。前五是福。非智性故。第六智慧。非福性故。正智自体故。或复前三惟福德摄。后一唯智。余通二种。前三唯福。远智慧故。第六唯智。性是慧故。余通二种。即精进、定。邻近于慧。亦起慧故。若依精进修布施、持戒、四无量等，名福。修三慧（闻思修）、六善巧（菩萨六种善巧方便。一，随顺巧方便。于彼深经如来旨趣。随顺其义。分别解说。而摄取之。二，立要巧方便。众生求索。菩萨为立要言。令其疾修善法。远离诸恶也。三，异相巧方便。教供养父母受持禁戒等。如不顺时。乖异嗔责。为度彼故。使他畏惧也。四，逼迫巧方便。如有犯戒等事。断绝供给。或加谪罚。使勤修善法。远离恶法也。五，报恩巧方便。施与众生财物。令知恩报德而行善也。六，清净巧方便。自兜率天降生。出家学道。成无上菩提。使众生舍离憍。慢。坚固信乐。同成佛道。详见《菩萨地持经·六》）、观四谛（苦集灭道）、缘生（十二因缘）法等，名智分。若依静虑修四无量等，名福。修六善巧等，名智分。
    善法者。顺理之法也。五戒十善为世间善法。三学（戒定慧）六度（布施，净戒，安忍，静虑，精进，般若）为出世间善法。摄受，亦作摄取。佛以慈心摄取众生也。
    住为心不相应行法之一。使法住之实法也。

    心者。所引之喻。喻此经摄大部般若六百卷之精要。譬如人身心脏。为百体之要。大经随机。义文俱溥。此经抉其秘要。故标心称。喻此经总六百卷般若之精要也。法月译本。菩萨白佛言。世尊。我欲于此会中说诸菩萨普遍智藏般若波罗蜜多心。《连珠记》引不空所译亦同。奘师在益州空惠寺遇病僧所授者。亦以此为三世诸佛心要法门。曰般若波罗蜜多心。曰诸佛心要。皆指积聚精要心而言。非色非心。但为一喻。亦有以此心字作真心解者。然六百般若。皆谈真心。非独此经。故本诠不取。《幽赞》云。虽此心经。亦名般若。彼总此别。故但名心。
    【注】心有多名。一，肉团心。梵语纥利陀耶。亦名处中心。处于动物中心。即生理上人体之心脏。形如莲花含苞未敷之状。二，坚实心。梵语干栗陀耶。亦名自性清净心。第一义心。真如心。即吾人天赋之妙真如性。至诚无妄之真心也。三，草木心。梵语污栗陀。草木之中心也。四，积聚精要心。梵语矣栗陀。积聚诸经精要。如本经积聚大般若经六百卷之菁华。集中要旨。亦名为心。五，思量心。梵语末那。此云意。分别思量相续执取之心。六，集起心。梵语阿赖耶。集诸种子生起现行。即第八识。七，缘虑心。梵语质多耶（亦名虑知心。了别心。缘影心）。攀缘对境而为见闻觉知之妄心也。就缘虑心说。可通八识。眼缘色。耳缘声。鼻缘香。舌缘味。身缘触。意缘法。末那缘思量。阿赖耶缘根身种子器世间。故八识总可心心。从集起说。能集种子起现行。惟八识专有。故惟第八识。始可名心。《入楞伽经》曰。藏识总名心。思量性名意。能了诸境相。是故名为识。《俱舍论》云。集起故名心。思量故名意。了别故名识。皆以第八识为心。末那识为意。前六识为识也。

    经为通名。梵语修多罗。旧译作契经。一者契理。谓上契诸佛之理。为合道之言。二者契机。谓下契众生之机。为逗根之教。今译略契字。但名为经。经复多义。《佛地论》云。经者。贯摄为义。贯穿教义。摄持众生。如綖贯花。如经持纬。《杂阿毗昙心论》则列五义。一者。出生。出生诸法故。二者。显示。显示教理故。三者。涌泉。义味无尽故。四者。绳墨。辨析邪正故。五者。结鬘。贯穿诸法故。此土解经亦有四义。一，常。二，法。三，经。四，典。综其要归。不出贯摄常法四义。盖修多罗。西域正翻为线。线有贯摄义。贯则贯穿所说之理。摄则摄持所化之生。贯摄玄微。同登觉岸。常者。古今不易。法者。远近同遵。常则久而行之。有共繇义。亦即经也。《妙玄》云。天魔外道。不能改坏为教常。真正不杂。无能逾过为行常。湛然不动。决无异趣为理常。析义尤尽。法者。轨而正之。法可轨。行可轨。理可轨。有定据义。亦即为典。故经者常道。此土圣哲垂教。亦皆称经。执理定名。斯称最当。
    【注】佛法始入中国。迦叶摩腾，竺法兰等，首译《四十二章经》。为内典称经之始。


第二节　辨体

    名为假名。体则本体。故欲诠释此经。首须辨明经体。体者。一经之指归。众义之中枢也。本经以中道实相为体。中道者。不偏于有。不偏于空。空有二边。双遮双照。实相者。无相无不相。非有非空。即空即有。为诸法之实。一切境界。为诸法之权。如冰之与水。两形虽异。湿性相同。即所谓实相般若。所以言空而不言有者。因此空为圆教真谛之真空。离言说。离心缘。离自离他。非空非不空。乃至远离一切境界差别之相。一空一切空。无假无中。非空非有。既非外道之断空。亦非二乘之偏空。论因则人人本具。论果则唯佛方能究尽。
    【注】假名释之有二。一，就名释。诸法无名。人为假设。一切名皆虚假不实。《大乘义章》云。诸法无名。假与施设。故曰假名。《起信论》云。一切言说。假名无实。二，就法释。诸法皆由因缘和合而成。并无实体。假名差别诸法。离名则无差别。《维摩经》什师注云。诸法假名而有。故曰假名。废名论法。法如幻化。非有非无。亦非非有。亦非非无。无一定相。可以自别。以名呼法。法随名转。方有种种诸法差别。乃有假名。
    是故诸法说为假名。《法华经·方便品》曰。但以假名字。引导于众生。
    本体者。诸法之根本自体也。经体。即一经之本体。台宗以前诸师。说经不分宗体。台宗始以体为一经之主。而以宗为辅。
    中道实相。即中道真实之妙理。实则非虚。相即无相。中者。不二之义。绝待之称。


第三节　明宗

    体为性德。本体既明。不可不知修持之法。修持之法无量。欲知以何为主。是曰明宗。宗为宗要。本经以一心三观为宗。以吾人凡常之一心。为所观之境。一曰空观。具称从假入空观。观一切法。全由妄念分别而成。了无自性。即能观之心性。亦复刹那不住。生灭无常。是为体真止。破见思惑。见真谛理。证一切智。成般若德。二曰假观。具称从空出假观。亦名平等观。观一切法。全依因缘凑合而成。本为假名。即能观之心性。亦如梦幻泡影。毫无实际。是为方便随缘止。破尘沙惑。见俗谛理。证道相智。成解脱德。三曰中观。具称中道第一义谛观。观一切法。若心若境。非有非空。非非有。非非空。不一不异。非不一。非不异。无内。无外。无中。无过去。现在。未来。心外无境。境外无心。遮照同时。随机相应。离一切分别想。是为息二边分别止。见中谛理。破无明惑。证一切相智。成法身德。惟以一心三观。破三惑。证三智。成三德。本经曰观。曰照见。曰色不异空。空不异色。色即是空。空即是色。皆一心三观之证也。
    【注】见思惑者。见惑与思惑也。即枝末无明。概括三界烦恼之通称。故名通惑。又名界内惑。见惑为意根对法尘迷于无常，无我，真谛道理。非理计度而起之我见，边见等妄惑。思惑新译作修惑。为眼耳鼻舌身五根对色声香味触五尘而起之贪嗔痴慢等妄惑。小乘俱舍以见惑由迷理而起为理惑。思惑由迷事而起为事惑。大乘唯识则以分别起之烦恼所知二障为见惑。俱生起之烦恼所知二障为思惑。见有二义。一者。照见。照见真理时所断之惑也。二者。推度。此惑以推度为性也。思亦有二义。一者。思唯修习真理以断此惑。二者。思唯世间幻妄事物而起之惑也。此二惑为众生沉沦生死之因。故行者不可不先断之。断之有次第。见惑性猛。可以顿断。所谓见断如破石也。入见道位。即可一时断之。思惑性钝。须数数思唯谛理。方能渐断。所谓思断如藕丝也。断思惑之位。谓之修道。二惑断尽。则谓之无学道。二惑各分多品。大小乘不同。见惑小乘立为八十八品。一切烦恼中贪嗔痴慢疑，身见、边见、邪见、见取见、戒禁取见之十惑，名为本惑。此十惑中贪嗔痴慢之四。通于见思、疑与五见之六。则唯见断。五见与疑。直以谛理为所迷。故谓为亲迷之惑。贪嗔痴慢以五见为所迷。故谓为疏迷之惑。此亲疏之十惑。为迷于欲界苦谛真理而起之烦恼。故苦谛具足十惑。迷于集谛而起者。则仅七惑。因集谛为业因。无以业因而迷执我体者。故无身见。无身见。故无边见。戒禁取见。灭谛者。涅槃。亦仅七惑。如集谛。道谛则具八惑。于前二谛七惑外。加一戒禁取见。因有一类外道。修无想定。误为入涅槃之正道。是由迷于道谛之理而起之非道计道之戒禁取见也。如是欲界。总为三十二。上二界为定地。非如欲界之为散地。不起嗔恚之粗动烦恼。故于欲界之三十二品中。每谛各除嗔惑。为二十八。二界合为五十六。并欲界之三十二为八十八品（参看《俱舍论·十九》）。大乘立为百十二。即于欲界四谛下。各具十惑。为四十。色无色界四谛下。于十惑各除嗔惑。为三十六。二界合为七十二。并欲界之四十为百十二品（参看《唯识述记·九》）。思惑则小乘为十。即欲界为贪嗔痴慢之四。上二界各除嗔为贪痴慢三。二界合为六。并欲界之四为十。大乘为十六。即于欲界有贪嗔痴慢身见边见之六惑。上二界于六惑中除嗔。各为五惑。合欲界之六惑共为十六。故合见思则小乘为九十八。谓之九十八随眠。大乘为一百二十八。谓之百二十八根本烦恼。思惑既须渐断。故声闻乘为钝根故。分十惑为九地各九品而分断之。九地者。欲界五趣地为一。色界四禅，无色界四空，各四地。共为九地。九品者。此各地之思惑为上上，上中，上下，乃至下上，下中，下下，之九品。故九地共为八十一品。既断见惑之圣者。为预流果。更进而断欲界地一品乃至五品，为一来向。断六品已。为一来果。以有后三品之欲惑。故尚须一往来于人天。次后断欲界后三品之惑。为不还向。断已谓之不还果。以不再还生欲界故也。次后渐断上二界八地之七十二品，为阿罗汉向。断竟为阿罗汉果。阿罗汉此云不生。以断尽八十一品思惑。不再受生于三界也。
    三惑者。台宗分一切之妄惑为三种。一，见思惑。为涅槃之障。二，尘沙惑。为菩提之障。菩萨教化人之障也。盖菩萨教化众生。必通如尘如沙无量无数之法门。于长劫间修习。得道相智。非谓惑体如尘沙也。三，无明惑。为中道实相之障。此与思惑中之痴惑不同。彼为障蔽空理之惑。枝末无明也。此为迷于根本理体之惑。根本，无明也。此三惑中。见思为三缘共断。故名通惑。尘沙、无明二惑为菩萨所别断。故名别惑。
    真谛。真即真空。泯一切法。离于诸相。诸相若离。真空自见。是为真谛。俗谛。俗即世俗。诸法虽空。皆不可得。立一切法。假以观照。是为俗谛。中谛。中即中正。诸法不离二边。不即二边。非真非俗。即真即俗。清净洞彻。圆融无碍。是为中谛。近人江味农居士。则谓般若正明二谛。遮照同时即中。非二谛以外别有中谛。可备一说。
    三观者。诸家说三观。有天台三观。华严三观。南山三观。慈恩三观种种。诠文所云三观。则指天台三观。一，空观。观诸法之空谛也。二，假观。观诸法之假谛也。三，中观。此有二。观诸法非空、非假、即中。为双非之中观。观诸法亦空、亦假、即中。为双照之中观。就性德之理言。谓之三谛。就修德之智言。谓之三观。一心三观者。以吾人凡常之一心为所观之境而观之也。
    三智者。谓一切智。道相智。一切相智。一切智者。谓共声闻及独觉智。盖五蕴、十二处、十八界等差别法门。声闻独觉。亦能了知。而不能知一切道相。及一切法。一切种。故一切智是共声闻及独觉智。道相智者。谓共菩萨摩诃萨智。盖菩萨应学遍知一切道相。谓声闻道相。独觉道相。菩萨道相。如来道相。诸菩萨摩诃萨。于此诸道应常修学。令速圆满。虽令此道作所应作。而不令其证住实际。故道相智是共菩萨摩诃萨智。一切相智者。谓诸如来应正等觉不共妙智。知一切相。皆同一相。谓寂灭相。是故名为一切相智诸行状相能表诸法。如来如实能遍觉知。是故名为一切相智（参读《大般若经·四百六十二》）。
    三德者。法身、般若、解脱。具足常乐我净。谓之三德。不迁不变之为常。安隐寂灭之为乐。自在无碍之为我。离垢无染之为净。法身德者。诸佛由轨法而得成佛。故名法身。此法身在佛不增。在众生不减。众生迷之而成颠倒。诸佛悟之而得自在。迷悟虽殊。体性恒一。具足常乐我净。是名法身德。般若德者。佛究竟始觉之智。自能觉了诸法不生不灭。清净无相。平等无二。不增不减。具足常乐我净。是名般若德。解脱德者。不系为解。自在为脱。诸佛永离一切业累之缚。得大自在。具足常乐我净。是名解脱德。


第四节　论用

    明宗之后。又须论用。用者。功用也。明宗以定自修之趋向。论用以显利他之功能。自行化他为学大乘者特具之精神。本经以遣执度苦为用。凡夫外道。不悟中道实相。于是起五蕴、十二处、十八界之人执。受界内分段生死之苦。声闻缘觉。纵能观空、观假。未能澈见圆中。于是起四谛、十二因缘之法执。受界外变易生死之苦。观自在菩萨。以大悲心。宣说此经。遣荡凡外人执。二乘法执。以中道实相。度脱诸苦。故得阿耨多罗三藐三菩提。非但自行般若波罗蜜多。亦以般若波罗蜜多。成就众生。度诸苦厄。此本经全体之大用也。
    【 注】自行化他。又作自利利他。菩萨万行。不出此二。《法华文句·八》云。别论口业是化他。身意是自行。通论三业自轨。即是自行之法。三业之教诏。即是化他之法。


第五节　判教

    欲判本经教相。不可不先知教相本义。教者。圣人被下之言。相者。分别同异之象。自法传震旦。判别教相者凡二十余家。以天台华严二宗所判。为最著。如来三十成道。终至鹤林涅槃。说法四十九年。三百余会。天台宗智者大师。判为五时四教。五时者。一，华严时。佛成道后三七日中。说《华严经》时。二，鹿苑时。说《华严经》后十二年中。于鹿野苑等处。说小乘《阿含经》之时。三，方等时。说《阿含》后八年。说《维摩》《胜鬘》等诸大乘经。广说了义。均被众机之时。四，般若时。说方等经后二十二年。说诸部《般若经》时。五，法华涅槃时。说《般若经》后八年。说《法华经》。示寂前一日一夜。说《涅槃经》时。四教者。有二。曰化法四教。化仪四教。化法四教者。化益众生之法门。一，藏教。经律论三藏。各含一切文理。说因缘生灭四谛。正教二乘，傍化菩萨之教也。二，通教。说即空无生四谛。以菩萨为正机二乘为傍机。教钝根菩萨。虽观无生四谛。但证真空。与藏教同。教利根菩萨。能于真空了达不空。即入别教。能知空不空。具一切法。即入圆教。兼通藏别圆三教。故曰通教。三，别教。说因缘假名无量四谛。独被菩萨。不涉二乘。别于藏通。所谈法门。行相隔历。次第而不圆融。别于圆教。故曰别教。四，圆教。圆即不偏之义。说大乘圆观无作四谛。以化最上利根之人。所诠中道之理。性相圆融。事理无碍。法法具足。故曰圆教。化仪四教者。教化众生之仪式。一，顿教。为上根说别教圆教之大法者。如华严时。二，渐教。因机利导。渐次开示。如来于鹿苑时。破斥邪法。建立正教。专为二乘。此名渐初。即《阿含经》也。次于方等会上。弹偏斥小。令归大法。此名渐中。即《净名》等经也。后于般若会上。详阐空慧。淘汰小乘大小各别之执情。会一切法。皆归大乘。此名渐末。即《般若经》也。自浅至深。次第而进。故名渐教。三，秘密教。谓如来不思议智慧神通之力。能令大众同会听法。互不相知。隐密赴机。故名秘密教。四，不定教。谓如来不思议智慧神通之力。能令听法之众。或闻小法而证大果。或闻大法而证小果。闻解各异。得益不定。故名不定教。法华涅槃时。则纯圆独妙。非顿，非渐。非秘密。非不定也。以五味譬喻。华严时。如全牛生乳。鹿苑时。如从乳为酪。方等时。如从酪为生酥。般若时。如生酥为熟酥。法华涅槃时。如熟酥为醍醐。此为台宗所判教相。华严宗则判为小、始、终、顿、圆五教。始于杜顺。成于贤首。一，小乘教。说长，中，增一，杂，四阿含经。及一切小乘律论。以随机故。但说人空。不说法空。纵说法空。亦不明显。但依六识三毒。建立染净根本。未尽法源。二，大乘始教。亦名分教。广说法相。少说法性。未尽大乘法理。名之为始。不示众生皆有佛性之义。更分为相始教。如《深密经》等。分别五性。建立依他之万法者是。空始教。如般若等经。说诸法皆空。显无所得平等者是。三，终教。亦名实教。言定性声闻。无性阐提。皆得成佛。方尽大乘至极之理。于中多说法性。少说法相。虽说法相。亦会归性。如《楞伽》《胜鬘》等经。说真如缘起之理者是。四，顿教。明一念不生。即名为佛。不依阶位渐次。故名曰顿。于中不说法相。惟明真性。如维摩之默显不二。达摩之以心印心。以顿彻理性为教者是。五，圆教。所说惟是无尽法界。性海圆融。缘起无碍。相即相入。如帝网珠。重重无尽。一位即一切位。一切位即一位。故十信满心。即成正觉。如华严、法华等经。明圆融具德之一乘者是。以两宗所判对勘。华严宗之小。即台宗之藏。台宗之通。即华严宗之始。台宗之别。即华严宗之终。圆教在台宗则三谛圆融。即空、即假、即中。在华严宗则理事无碍。事事无碍。本经于化法为圆教。兼说通别。于化仪为渐末、秘密、不定。以五时论。属第四时。以五味喻。则为熟酥。
    【注】台宗所判五时。华严时者。如来在寂灭道场。始成正觉。最初三七日。对大菩萨及宿世根熟之众。即圆别之机。说自证法。如《华严经》正说圆教。同时兼说别教。向钝根机类说自证法。试其适否。名拟宜时。阿含时者。在华严时。一类利根虽蒙化益。钝根小机。仍未领悟。故说《华严经》后十二年间。于鹿野苑说《四阿含经》等。诱引小机。名诱引时。方等（台宗于方等有三释。约理释方谓方广。等即平等。实相妙理。横遍诸法。故名方广。竖该凡圣。故言平等。约事释。方者。广也。等者。均也。广说四教。均益利钝之机也。约事理释。方者。方法。等者。平等。依有、空，双亦、双非四门之方法。各契平等之理。即方者能契之行。等者所契之理也）。时者。阿含时诱引小机。非佛本意。故次八年中说《维摩》、《思益》、《楞伽》、《楞严》、《三昧》、《金光明》、《胜鬘》等经。兼说藏、通、别、圆四教。弹偏斥小。叹大褒圆。令小乘人耻小慕大。名弹呵时。般若时者。小乘回心向大。起大小二乘。其法各别之执情。故次二十二年间说诸部般若经。正说别圆二教。兼说通教会一切法。皆摩诃衍。淘汰小乘大小各别之执情。名淘汰时。法华涅槃时者。经前四时说教。钝根小机，机缘渐熟，故最后八年间，二处三会，说《法华经》。正明圆教。开方便。显真实。会三乘归一乘。令开示悟入佛之知见。名开会时。临灭一昼夜。一，为法华未熟人追说四教。具谈佛性。令知真常。入大涅槃。名捃拾残机教。二，为末代乘戒俱失。故更扶三藏。广开常宗。设三种权。扶一圆实。名扶律谈常教。法华会竟。无三唯一。涅槃最后谈常。四教并是圆理。合称法华涅槃时。华严宗之五教。杜顺判为五门。一，法有我无门。小乘教也。二，生即无生门。大乘始教也。三，事理圆融门。大乘终教也。四，语观双绝门。大乘顿教也。五，华严三昧门。大乘圆教也。见《五教止观》。贤首本之而判五教十宗。一，我法俱有宗。二，法有我无宗。三，法无去来宗。四，现通假实宗。五，俗妄真实宗。六，诸法但名宗。七，一切皆空宗。八，真德不空宗。九，相想俱绝宗。十，圆明具德宗。自一至六，为小乘教。七，当大乘始教。八，当大乘终教。九，当大乘顿教。十，当大乘圆教。清凉改一切皆空宗为三性空有宗。真德不空宗为真空绝相宗。相想俱绝宗为空有无碍宗。圆明具德宗为圆融具德宗。
    自来判教相者。自以天台智顗、华严贤首两师之说为最备。但判教不始于两师，两宗以前以后各师。及其他大乘诸宗。除禅宗不立文字外。各判教相。人异其说。兹略述之如次。
    第一。三论宗所判教相。（一）一音教。更分二说。谓如来一音。同时集万。大小并陈。即随一音具说大小一切无尽法门者。后魏菩提流支之说也。谓佛一圆音。无思普应。机闻自殊。非谓言音本陈大小。如水本一味。随器而异。如来言音。亦复如是。随众生心量而生无量差别。《净名经》云。佛以一音演说法。众生各各随所解。姚秦鸠摩罗什之说也。一谓佛音各异。一谓随机而殊。各得圆音一义。但以教本不分则一。见《华严·清凉疏》此古三论派也。（二）依《涅槃经》，及智度、地持、正观等论立二藏。一，声闻藏。即小乘教。二，菩萨藏。即大乘教。又依《法华经·信解品》立三轮。一，根本法轮。《华严经》也。佛始成正觉华严会之说法。纯为菩萨开一因一果法门。二，枝末法轮。小乘诸经乃至《方等》、《般若》诸大乘经。因钝根机类。不堪闻一因一果。故于一佛乘。分别说三。三，摄末归本法轮。《法华经》也。四十余年说三乘教。至法华会。始得会彼三乘。归于一极。此唐初吉藏所判。所谓新三论派之嘉祥教判也。（三）依般若等经，中观等论，立三时教。一，初时。为小根人说小乘法。明心境俱有。如《阿含经》。惟摄二乘。二，第二时。为中根人说法相大乘。明境空心有。如《解深密经》通摄大小三乘。三，第三时。为上根人说无相大乘。辨心境俱空。如《般若经》。惟摄菩萨。此为胜义俱空宗天竺那烂陀寺智光论师。远承文殊龙树。近禀青目清辨。所立之空教三时也。见《华严玄谈》及《阿弥陀经通赞疏序》。
    第二。唯识宗所判教相。此宗先分顿悟、渐悟二机。顿悟者。无论闻有闻空。俱证中道。无前后次第可言。渐悟之机则分三时，按佛说法前后，立初、昔、今之次第。谓之年月三时。按佛说法义类，立有、空、中之分别。谓之义类三时。中间所判。或依年月前后。或依义理浅深。或年月义理并依。以年月前后。与义理浅深相待并具。成三时之教相。（一）第一时有教。凡夫外道。无始以来。妄认实我妄执。起惑造业。沉沦生死。佛成道后。为除其实我妄执。于鹿野苑说《阿含》等经。示四谛、十二因缘、五蕴等法。令小乘人悟我执空。蕴处界等诸法有。是曰初时我空法有论为小乘有教。（二）第二时空教。二乘闻初时有教。虽证我空。而不了知佛说法有之密意。迷执诸法实有。犹怀法我之见。佛为除彼法执。于灵鹫山等处。说《般若》等经。示蕴处界诸法皆无。令中根悟我法二空。舍小趣大。是曰第二时我法二空论。为大乘空教。（三）第三时中道教。大乘空教。尚属诱引方便。因说诸法皆空。致闻者复起空执。便谓真俗二谛。性根皆空。佛为并除二执。于《解深密经》等会。说解深密诸大乘经。演唯识三性等教。示识有非空。破第二时空执。境空非有。破初时有执。令悟非有非空中道妙理。是曰第三时境空心有论。为大乘中道教。惟佛说法。随机诱导。年月与义类。次第未必全同。如于《阿含经》前。说中道教之《华严经》。《法华经》后。说有教之《涅槃经》是也。此为应理圆实宗戒贤论师。远承于弥勒无著。近踵于护法难陀。所立之有教三时也。唐玄奘三藏宗之。见《了义灯》。类似此判者。梁真谛三藏。亦判三时。一，有教。佛初成道七年以来说有教。五年度五俱伦（佛最初所度之五比丘。此五人自过去世以来。俱为同伦故。或作五拘邻。五比丘中第一阿若憍陈如之别译也。）第六年化舍利弗。第七年度三迦叶。总名有教。二，空教。从第八年至三十八年以来说《般若》等经是。三，非空非有教。从三十九年至临涅槃时。说《法华》、《楞伽》、《思益》等经是。与戒贤所判不同者。戒贤将时就教。真谛以教就时。故不如戒贤之圆满耳。见《阿弥陀经通赞疏·序》。
    第三。净土宗所判教相。（一）约行之教相言。判为难行易行二道。谓于五浊恶世无佛时。求不退转为难行道。譬如陆路。步行则苦。以信佛因缘。愿生净土。乘佛愿力。便得往生。即入大乘正定之聚。为易行道。譬如水路。乘船则乐也。此为昙鸾大师所判。见《十住毗婆沙论》。（二）约证之教相言。判为圣道与净土。于此娑婆世界。断惑证理。入圣得果。名圣道门。依弥陀愿力。往生极乐世界入圣得果。名净土门。在此五浊恶世。圣道一门。理解深微。去圣遥远。末法之时。不易证得。净土法门。平易确实。所谓万修万人去也。与难行易行语异而意同。难行与圣道。同为自力进修。易行与净土。兼仗他力接引。此为道绰法师所判。见《安乐集》。（三）约教之教相言。判为渐教与顿教。声闻藏与菩萨藏。本宗于二教中属顿教。二藏中属菩萨藏。此善导法师所判。见《观经四帖疏》。
    第四。律宗所判教相。此宗判如来一代时教。为化制二教。化教者。化益之教。即诸经论所示禅定智慧之法门。如《四阿含》，及《般若》《华严》等经。泛说因果。通化道俗。旨在开示慧解。非为制止过犯。更分为三。谓之南山三教（南山即终南山。此宗教判。始于道宣律师。住终南山。为此土律宗初祖）。 （一）性空教。立诸法性空无我之教。摄一切小乘。（二）相空教。立诸法本相是空。唯情妄见之教。摄一切大乘浅教。（三）唯识圆教。立诸法外尘本无。实惟有识之教。摄一切大乘深教。制教者。制戒之教。即诸律所诠令守戒法之法门。如四分律、五分律、十诵律、僧祇律等。说诸律仪。惟制内众。故名制教。又名行教。约佛边说曰制。约众生边说曰行也。起必由过。随过制约。言唯持犯。事通制作。律宗所主。全在制教。约兹戒法。兼摄定慧。更分三宗。（一）实法宗。即立一切诸法实有之萨婆多部。如十诵律。此宗以色为戒体。属当分小乘教。（二）假名宗。即立诸法惟有假名之昙无德部。如四分律。此宗以非色非心为戒体。属过分小乘教。（三）圆教宗。即立一切诸法惟有识之唯识圆教。道宣律师即四分律成一乘圆顿妙戒。此宗以种子为戒体。为终穷大乘教。见《四分律行事钞》。
    第五。密宗所判教相。有纵有横。横者。就一代时教。分为显密二教。以应化身百亿教法。显略逗机。即大小乘三藏十二部经所说四谛、十二因缘、六度、万行法门。是显教。法身所说。如《大日经》、《金刚顶经》等金胎两部法门。陀罗尼、印契念诵、灌顶、仪轨是密教。显教随他方便诱引教义。密教为对自眷属内证法门。如来变化身。为地前菩萨，及二乘，凡夫等说三乘教法。他受用身。为地上菩萨说显一乘等。并是显教。自性受用，佛自受法乐故。与自眷属说如来内证智境。谓之密教。就纵说。则依背暗向明心续生之次第而立十住心之阶段。一，异生羝羊心。异生即凡夫。羝羊即牡羊。除水草淫欲以外无所知。以譬凡夫之愚痴闇昧。此心本不应列教判。以由此入第二心。故以之为初心。二，愚童持斋心。众生以内熏外缘。亦修五戒十善及世间伦常教法。为人乘之教。三，婴童无畏心。外道以生天得苏息。修四禅六行之天乘教也。以上为世间三住心。以下为出世间。四，唯蕴无我心。为入佛法门最初之住心。观四谛理。得唯我空。声闻法也。五，拔业因种心。虽拔烦恼所作之因。而习气尚在缘觉法也。以上二心为小乘教。六，他缘大乘心。他缘即无缘。住自他冤亲平等之观。悟真如平等度众生入佛。与法相宗相当。弥勒菩萨内证法门也。七，觉心不生心。觉悟心性不生不灭入于心境俱空之证。三论宗八不与起信论所说相当。文殊菩萨内证法门也。以上二心为三乘教。八，一道无为心。又名如实一道心。如实知自心。空性无性心。《法华》所说。以心即境。无为无相为极意。与天台宗相当。观世音菩萨内证法门也。九，极无自性心。有浅深二释。浅者，华严法界。诸法即真如实相。真如随缘。不守自性。染净和合。事事无碍。重重无尽之义。深者，由毗卢遮那之教觉而无自性。华严之法门当之。普贤菩萨内证法门也。以上二心及下一心皆一乘教。自一至九。皆显教所摄。十，秘密庄严心。金胎两部六大、三密、五相、五智之无尽法门。等觉十地。亦不能见闻。故曰秘密。法门德相。故曰庄严。密教之心地也。胎藏界之十住心为横。金刚界之十住心为竖。胎金不二之处谓为不二之十住心。此日本东密派（传自不空）弘法大师所判。见《辨显密二教论》《大日经疏》《十住心论》《决议钞直牒》。
    第六。智顗判教以前诸师。及台宗后来诸师所判教相更有多说。（一）半字教与满字教。声闻藏谈理未遍。若字之仅半曰半字教。菩萨藏谈理圆满。如字之完具曰满字教。此西秦昙牟谶三藏所判。见《华严经疏》。（二）渐教与顿教。约渐悟之机。大由小起。具有三乘故名为渐。《法华经》等是也。若不由于小。迳超大乘。则名为顿。如《华严经》是也。此昙牟谶与真谛三藏所判。见《华严经探玄记》。（三）屈曲教与平道教。谓释迦如来所说之经。随机破执。方便委曲。如《涅槃经》虽说圆通一极之理。或对权显实。或会异归同。名屈曲教。亦名释迦教。卢舍那所说之经。随其法性平等而说。如《华严经》。虽随众生各别调伏。皆是称性善巧。一时顿演。名平道教。亦名卢舍那教。此唐初印法师所判。见《华严经疏》。（四）梁真谛三藏除判顿渐外。于渐中更开为转、照、持三轮。谓佛于二月八日成道。四月八日于波罗那国鹿野苑中为声闻众说四谛为转法轮。七年后在舍卫国去祇园五里智慧河边。为诸菩萨二乘说《般若》等经。以空照有。具转照二轮。三十年后在毗舍离国鬼王堂中。为真常菩萨说《解节》等经。双照空有。具转照持三轮。见《华严经疏》。（五）刘宋上元寺慧观。亦先判顿渐。于渐中更分为五时。一，有相教。于《阿含经》等别说四谛、十二因缘、六度。以因缘实有之法。分投声闻缘觉菩萨三机。是为三乘别教。二，无相教。专说般若经。空诸有相。通化三乘。是为三乘通教。三，抑扬教。说《净名》《思益》等经。抑挫声闻。褒扬菩萨。义具抑扬。故曰抑扬教。四，同归教。般若之后。涅槃之前。说《法华经》。会三乘归一极。万善悉向菩提。故曰同归教。五，常住教。说《涅槃经》。明佛果常住。一阐提（《涅槃经》云。无信之人。名一阐提。《唯识枢要》云。第五性有三种。一，阐底迦。是乐欲义。业生死故。二，阿阐底迦。是不乐欲义。不乐涅槃故。三，阿颠底迦。是毕竟义。毕竟无涅槃性故。）皆得成佛。广谈佛性。故曰常住教。见《华严经疏》。（六）齐隐士刘虬亦先判顿渐。于渐中分五。一，人天教。谓佛初成道时。先为提谓长者说人天五戒十善。乃是因缘果报实有之法。二，有相教。三，无相教。四，同归教。五，常住教。与慧观同。见《华严经疏》。（七）梁光宅寺法云。依《法华经》。谓临门三车。即权教三乘。四衢则实教大乘。故立四乘教。一，声闻乘教。声闻以析空观。观于生灭四谛。破见思烦恼。证真谛理。离三界生死。如乘羊车出于火宅。二，缘觉乘教。缘觉以析空观。观十二因缘生灭。破见思烦恼。证真谛理。离三界生死。如乘鹿车出于火宅。三，菩萨乘教。藏教菩萨。发四弘誓。修六度万行化导众生同出三界生死。究竟至于真空涅槃。如乘牛车出于火宅。四，佛乘教。大乘菩萨。以圆融三观。观于诸法实相之理。顿破无明烦恼。成一切种智。顿超佛乘。如乘大白牛车出于火宅。见《华严经疏》。（八）唐初海东元晓法师。亦立四教。一，三乘别教。如《四谛缘起经》等。为三乘所共学。其中二乘未明法空。异于菩萨。故曰三乘别教。二，三乘通教。如《般若》、《解深密经》。皆明二空。为三乘所共学。故曰三乘通教。三，一乘分教。如《梵网经》等。菩萨不与二乘共学。故名一乘。未显法之周遍圆融。故名分教。四，一乘满教。如《华严经》。具明法界之理。故名一乘满教。见《华严玄谈》。（九）西天第十三祖龙树论师。尝立四教。一，有门。谓《阿含》小乘等经。说一切因果之法悉皆实有。是为有门。二，空门。谓《大般若》等经。说真空实相之理。荡除众生情执。是为空门。三，亦有亦空门。谓《深密经》等。说性空相有。是为亦有亦空门。四，非有非空门。谓中论等双破空有。说一切法即空之有是非有。即有之空是非空。互泯互融。即第一义。见《华严经随疏演义钞》。（十）唐释法宝则判为一，小乘教。二，大乘教。亦名般若教。三，三乘教。亦名深密教。四，一乘教。亦名法华教。五，佛性教。亦名涅槃教。见《五教章》。（十一）魏光统律师承佛陀三藏之说。以三教四宗判教。先分渐、顿、圆三教。一，渐教。为未熟者先说无常后说常。先说空后说不空。如是次第者。曰渐教。二，顿教。为根熟者于一法门顿说常无常。空不空者。曰顿教。三，圆教。为上达者说如来无碍解脱究竟果德，圆极秘密自在之法门。曰圆教。综合三教。更立四宗。一，因缘宗。说一切现象为因缘假合。如《毗昙论》。二，假名宗。说一切现象仅属假名而无实际。如《成实论·三假》。三，诳相宗。说一切现象为诳相非真。即说空之教。如大品、三论。四，常宗。说佛性常住。湛然不变。如涅槃、华严。光统弟子大衍寺昙隐。改常宗为真宗。诳相宗为不真宗。齐护身寺自轨。于光统四宗。加一法界宗。《华严经》也。以涅槃经为常宗。耆阇寺法凛。则于光统四宗之外。开华严为圆宗。法华为真宗。共为六宗。见《五教章》。（十二）隋阇那崛多及达摩岌多。判如来教为四时。一，生空教。即十二年前说《阿含经》是。二，法空教。即三十八年前说八部《般若》是。三，法相教。即三十八年后。四十九年来。说《楞伽》、《思益》、《法华经》等。广明百法、三性、三无性、八识、二无我等是。四，观行教。即说华严法界观等是。见《阿弥陀经通赞疏·序》。（十三）武丘笈法师判为三教。一，顿教。佛成道后。最初为诸菩萨说《华严经》。如日初出。先照高山。为顿教。二，渐教。始自鹿苑。终至双树。从小至大为渐教。三，不定教。非顿非渐。惟明佛性常住。如《胜鬘》《光明》等经所说。为不定教。于渐教中更分为三。一，有相教。佛于十二年前说《阿含经》。小乘不离色心。见有得道。名有相教。二，无相教。十二年后至于法华。菩萨见空得道。名无相教。三，常住教。最后说涅槃经。有无双照。明一切众生。皆有佛性。阐提作佛。名常住教，嗣后宗爱益以同归为四教。定林，柔次，益以抑扬为五教则同于慧观所判矣。见《法华玄义》。（十四）唐中天竺沙门波罗颇迦罗灭多罗所判五教。一，四谛教。谓佛于《阿含经》。说苦集灭道四谛之法。为令声闻之人修此而悟真空之理。二，无相教。谓佛于《般若经》中。说诸空慧法门。空诸有相。令悟大乘法空。三，观行教。谓佛于《华严经》。说诸观行法门。为令众生观察修行。四，安乐教。谓佛于《涅槃经》。说常乐我净，四德常住寂灭之理。为令众生得大安乐。五，守护教。谓佛于《大集经》等。说守护正法。为令众生保持不失。见《华严玄谈》。（十五）明袁宏道所判六教。一，假有教。说世间因果之人天教也。二，趋寂教。小乘寂灭趋向涅槃之教也。三，有余教。了二空相理。趋大乘佛果。惟不许阐提二乘成佛。故名有余。四，无余教。一切众生。悉当成佛。为大乘极则之教。五，顿悟教。不从地位渐次。故名为顿。六，圆极教。如法华、华严等。显真实中道义。舍化城而归宝所也。见《西方合论》。（十六）诸经论疏。有补充判教者。一，大收教与捃收教。《法华》开权显实曰大收。余众机缘未熟。不列法华会中。最后说《涅槃经》。更说四教。具谈佛性。归入一乘圆常妙理。以捃收法华余众。曰捃收。见《法华玄义》。二，世间教与出世间教。生三界善处之善法曰世间教。出离生死之三乘教法曰出世间教。见《大乘义章》。三，了义教与不了义教。大乘诸经。显明深理。曰了义教。小乘诸经。未了深义。曰不了义教。见《涅槃经》。四，显露教与秘密教。对一会大众。显说大法。彼此咸知。曰显露教。对此众说法。他众不知。或在此为显。于彼为密。或互为显密。各不相知者。曰秘密教。见《法华玄义》。五，偏教与圆教。藏通别为偏。圆教为圆也。见《止观》。六，实教与权教。如来出世真实之教法。实教也。圆教属之。因实教而权设者。权教也。藏通别三教属之。见《止观》。七，界内教与界外教。藏通二教。对沉沦三界众生。断见思二惑。出离三界之法门。界内教也。别圆二教。对于已断见思惑之法身菩萨。教以解脱三界外方便土实报土。（台宗立四种土。一，凡圣同居土。人、天、凡、圣、及二乘圣者同居之国土。如娑婆为同居秽土。安养为同居净土是。二，方便有余土。断见思烦恼。出离三界生死之人所居。因尘沙无明未净。故曰有余。变同居土之依身为方便土。又由方便土之依身。变实报土之依身。故又名变易土。三，实报无障碍土。方便土为证空理人之果报土。实报土则为证一分中道之理者之果报土。色心不相妨。故曰实报无障碍土。纯为菩萨所居。无凡夫二乘。四，常寂光土。法身常寂之体。诸佛如来所依所居。然由圆融之理言之。四土总为不二。《止观义例》曰。心体即常寂光。寂光诸土。无二无别。）变易生死。断无明而证佛果之法门。界外教也。藏教究蕴处界事相法门为界内事教。通教穷理稍深为界内理教。别教菩萨迷中道之理重。故分别无量事法。以之为方便。而使悟理。为界外事教。圆教菩萨迷理已轻。故直谈万法为中道实相之妙理。为界外理教。见《法华玄义》。
    第七。华严宗自贤首判教以后。其弟子慧苑依《宝性论》更立四教。（一）迷真异执教。谓凡夫外道迷于真理广起异计也。（二）真一分半教。谓小乘于真如随缘不变二分义中，但得随缘。故名一分。但说人空。不说法空。故名为半。（三）真一分满教。谓初心菩萨。但得不变。不得随缘。故名一分。双显人空法空之理。故名为满。（四）真具分满教。菩萨既了随缘不变二义。显真实理。识如来藏。故曰真具分满教。华严五祖圭峰宗密禅师。和会禅教。一际融通。判立三宗三教。禅三宗者。一，息妄修心宗。说众生虽本有佛性。而无始无明覆之不见。故轮回生死。诸佛已断妄想。故见性了了。出离生死。故须背境观心。息灭妄念。念尽即觉。无所不知。如镜蒙尘。尘尽明现。须修禅观。远离諠杂。调息调身。心注一境等。二，泯绝无寄宗。说凡圣等法。皆如梦幻。都无所有。本来空寂。非今斯无。即此达无之智。亦不可得。平等法界。无佛无众生。法界亦是假名。心既不有。谁言法界。无修不修。无佛不佛。设有一法。胜过涅槃。我亦说如梦如幻。无法可拘。无佛可作。凡有所作。皆是迷妄。如了达本来无事。心无所寄。方免颠倒。始名解脱。三，直显心性宗。说一切诸法。若有若空。皆惟真性。指示心性。复有二说。一云。即今能言语、动作、贪、嗔、慈、忍、造善恶、受苦乐等。即汝佛性。即此本来是佛。除此无别佛。了此天真自然。道即是心。性如虚空。不增不减。但随时随处。息业养神。自然神妙。此为真悟。二云。诸法如梦。妄念本寂。尘境本空。本空之心。灵知不昧。即此空寂之知。是汝真性。任迷任悟。心本自知。不藉缘生。不因境起。知之一字。众妙之门。若顿悟此空寂之知。知且无念无形。谁为我相人相。觉诸相空。心自无念。念起即觉。觉之即无。此上两说。皆是会相归性。三教者。一，大乘法相教。即密意依性说相教。佛说三界六道。悉是真性之相。但是众生迷性而起。无别自体。故云依性。然根钝者遽难开悟。故随他所见境相说法。渐渐度之。故云说相。说未彰显。故云密意。此一教中。更分三类。一者。人天因果教。说善恶业报。令知因果。二者。断惑灭苦教。说三界无安。皆如火宅之苦。令断惑业之集。修道证灭等。三者。将识破境教。说上生灭等法。不关真如。但各是众生无始以来。法尔有八种识。于中第八识。是其根本。顿变根身器界种子转生七识。各能变现自分所缘。此八识外。都无实法。我此身相。及外世界。唯识所变。迷故执有我及诸境。既悟本无我法。惟有心识。遂依此二空之智。修唯识观，及六度、四摄等行。渐渐伏断烦恼、所知二障。证二空所显真如。十地圆满，转八识成四智菩提。真如障尽。成法性身。大涅槃果。此与禅门息妄修心宗相扶会。以知外境皆空。故不修外境事相。唯息妄修心。息我法之妄。修唯识之心也。二，大乘破相教。即密意破相显性教。据真实了义。则妄执本空。更无可破。无漏诸法。是真性随缘妙用。永不断绝。又不应破。但为一类众生。执虚妄相。障真如实性。难得圆悟。故佛不拣善、恶、垢、净、性、相，一切诃破。以真性及妙用。不无而云无。又意在显性。语乃破相。意不形于言中。故云密也。此教说前教中所变之境。既皆虚妄。能变之识。岂独真实。心境互依。空而依有。且心不孤起。托境方生。境不自生。由心故现。心如境谢。境灭心空。皆假众缘。无自性故。是以一切诸法。无不是空。凡所有相。皆是虚妄。是故空中无五阴、六根、因缘、四谛，无智，亦无得。生死涅槃。平等如幻。与禅门泯绝无寄宗全同。三，一乘显性教。即显示真心即性教。直示自心即是真性。不约事相而示。亦不约破相而示。故云即性。不是方便隐密之意。故云显示也。此教说一切众生皆有空寂真心。无始本来。性自清净。明明不昧。了了常知。尽未来际。常住不灭。名为佛性。亦名如来藏。亦名心地。达摩所传。是此心也。见《宗镜录·三十四》及《原人论》。
    以上略举各宗所判教相。意在使初机明了一代时教概念。但判别愈繁。转涉事相。故唐清凉法师。不主分判教相。一者。理本一味。殊途同归故。始随机异故殊途。终归显实故一致。约机则异。就理常一。体外无权。权即是实。二者。一音普应。一雨普滋故。五性三乘不一。法雨一味无差。如大地百草。一雨普滋。三者。原佛本意为一事故。佛之出世。为一大事因缘。开示悟入佛之知见。转迷成觉。《法华经》曰。我此九部法。（一切经分为十二部。一，修多罗。此云契经。二，祇夜。此云重颂。三，伽陀。此云讽诵。四，尼陀罗。此云因缘。五，伊帝目多。此云本事。六，阇多伽。此云本生。七，阿浮达磨。此云希有。八，阿波陀那。此云譬喻。九，优婆提舍。此云论议。十，优陀那。此云无问自说。十一，毗佛略。此云方广。十二，和伽罗。此云授记。大乘之九部法。于十二部中。去因缘、论议、譬喻三部，以大乘直说佛法。不假因缘。惟谈圆理。故绝论议。独显真常。不待譬喻也。小乘之九部法。于十二部中去方广、授记、无问自说三部。因方广为大乘常住之理。小乘惟说生灭之法。故无方广。小乘未得成佛。故无授记。佛为小乘说法。必假问答为发起之缘。故无无问自说。）随顺众生说。入大乘为本。无论说法前后。皆为一事。四者。随一一文。众解不同故。如诸经说无常。或以生灭代谢。故名无常。或云无彼常故。名为无常。或云。不生不灭。名为无常。或云。真如一法。随染净缘转变不常。故名无常。或闻无常。便知对常以说无常。非常非无常。以为中道等。又苦集灭道。随机解殊。乃有四种。又《涅槃经》曰。十二因缘。下智观者。得声闻菩提。中智观者。得缘觉菩提。上智观者。得菩萨菩提。上上智观者。得佛菩提。皆随人解而不同也。五者。多种说法。恐成枝流故。法欲灭时。有多种异说。何不寻条以得根。便欲派本以为末。混淳源之一味。成浇薄之枝流。以斯五义。故不可分。所言甚允。吾诠略述之者。专为初机阐示佛教轮廓。读者明法以后。当如得鱼忘筌。求究竟第一义。勿执著于文字相也。
    六识者。眼耳鼻舌身意之六识也。
    三毒又名三根。为一切烦恼根本。一，贪毒。引取之心名贪。以迷心对于一切顺情之境引取无厌也。二，嗔毒。忿恚之心名嗔。以迷心对于一切违情之境起忿怒也。三，痴毒。迷闇之心名痴。心性闇迷。迷于事理。亦名无明。痴毒独起时。名独头无明。与贪毒等共起。名相应无明。
    五性者。一，定性声闻。因果不易名曰定性。闻佛声教而得觉悟。名曰声闻。惟习声闻之因。而证声闻之果。更不进求佛道。是曰定性声闻。二，定性缘觉。观因缘生灭之法。觉悟真空之理。名曰缘觉。惟习缘觉之因。而证缘觉之果。更不进求佛道。是曰定性缘觉。三，菩萨性。菩萨具云菩提萨埵。此云觉有情。菩萨悲智双运。冤亲等观。广利众生。证菩提果。是曰菩萨性。四，不定性。谓遇缘熏习。修行不定。近声闻即习声闻法。近缘觉即习缘觉法。近菩萨即习菩萨法。各随所习而成其性。是曰不定性。五，无种性。无种者。无善种也。拨无因果。不受化度。甘溺生死。不求解脱。是曰无种性。
    依他即依他性。依因缘而生之诸法也。诸法皆依众缘相应而起。都无自性。
    帝网珠者。即帝释天中因陀罗网之珠也。彼网皆以宝珠作之。一珠之中。现诸珠影。互相交映。重重无尽。一位即一切位。一切位即一位。见《华严探玄记》。
    以上说五重玄义竟。至本经在藏乘地位。则三藏之中。属经藏摄。二藏之中。属菩萨藏摄。三乘之中。属菩萨乘摄。五乘之中。属佛乘摄。以经中明示菩提萨埵。依般若波罗蜜多得究竟涅槃。三世诸佛。依般若波罗密多得阿耨多罗三藐三菩提也。
    【注】三藏者。藏有含藏之义。经律论三。各含文理。故曰三藏。一，经藏。梵语修多罗。贯摄经义。广度众生。二，律藏。梵语毗奈耶。或作毗尼。此云善治。能治贪嗔痴诸恶也。又调伏。谓能调练三业。制伏过非。调练通于三业。制伏惟明止恶。毗尼。此云灭。《圆觉略钞》云。灭有三义。一灭业非。论云。灭恶故名毗尼。二灭烦恼。律云。世尊谓调伏贪嗔痴，令尽。故制增上戒学。三得灭果。《戒经》曰。戒净有智慧。便得第一道。南山云。毗尼翻灭。从功能为名。非正译也。正翻为律。律者。法也。从教为名。断割重轻。开遮持犯。非法不定。又名波罗提木叉。此云解脱。道戒名解脱。以道性虚通。不随缘别。但名解脱。事戒不尔。缘别而生。如僧尼受戒。随对杀等事不作。别别无因。别别无果。故名别别解脱。摭华云。此云别解脱。谓三业七支。各各防非。别别解脱故。三，论藏。梵语阿毗达磨。旧译作阿毗昙。此云对法。法有二种。一，胜义法。所谓涅槃是善是常。故名为胜。二，法相法。通四圣谛世出世异及因果异。故名为相。对亦有二。一，对向涅槃。以乘无漏圣道之因。感趣涅槃圆寂之果。二，对观四谛。谓以净慧之心。观察四谛之法。摄大乘论世亲释。阿毗达磨有四义。谓对故。数故。伏故。通故。对义同前。数谓于一一法。数数宣说。训释言词。自共相等。无量差别故。伏谓能胜伏他论故。通谓能通释契经义故。亦名邬波提铄。此云论议。亦名摩怛哩迦。此云本母。谓妙慧因论议而生。亦名奢萨怛罗。此云论。谓论空有假实等法也。以上所说为总部大乘三藏。若别部小乘三藏。则以《阿含经》为经藏。四分、五分、十诵、律等为律藏。六足、发智等论为论藏。《智度论》所谓三藏是声闻法。摩诃衍是大乘法也。
    二藏者。依佛说大小乘诸经而别。一，声闻藏。诠小乘声闻等。修因证果之法。包含缘觉乘在内。故曰声闻等也。声闻与缘觉虽教行少分不同。（声闻之教为四谛。缘觉之教为十二因缘。声闻之行。须历四果。缘觉之行（一座成觉）。而理、果不殊（论理则同证生空。不证法空。论果则同断我执。不断法执。缘觉与声闻之罗汉果同证无余涅槃）。故合为一藏。二，菩萨藏，诠大乘菩萨修因证果之法。
    三乘。乘即运载之义。一，声闻乘。依苦集灭道四谛法。修持精进。求出三界以向涅槃。《法华经》曰：如彼诸子。为求羊车出于火宅。二，辟支乘。即缘觉乘。因观十二因缘。觉真谛理。求自然慧。乐独善寂。《法华经》曰：如彼诸子。为求鹿车出于火宅。三，菩萨乘。勤修六度。广化众生。《法华经》曰：如彼诸子。为求牛车出于火宅。
    五乘者。于三乘外。益以人天乘与佛乘。人天乘以五戒、十善出地狱、饿鬼、畜生、修罗四趣。求下界五欲及上界净妙之乐。法华喻为最小之车。佛乘以一乘实相之法。运诸众生同到涅槃彼岸。《法华经》喻为大白牛车。又一说。五乘为人乘、天乘、声闻乘、缘觉乘、菩萨乘。又一说五乘为佛乘、缘觉乘、声闻乘、天乘、梵乘。梵者，净义。菩萨以慈、悲、喜、舍四无量心。运诸众生出生死海。即菩萨乘也。


第二章 人题

    前章诠释经题。要义略具。佛以圆音说教。使众生随类听闻。各得了解。佛灭度后。结集契经。方隅所限。同文未能则大法流传。自不能不有待于紬译。本经观自在菩萨。在王舍大城灵鹫山法会。承佛印可。宣说法要。即从大部般若流出。为摩诃般若所摄。自梵译汉。共有十四本。本诠所据则为

    唐三藏法师玄奘译。
    李渊受隋帝禅。国号曰唐。三藏者。经、律、论。经诠一心；律规三业；论开慧辩。法者，轨也。师者，范也。法虽可轨，弘之在人。上弘大法，下为人师者，谓之法师。兼通经、律、论三藏法门，堪为人师表者，谓之三藏法师。
    【注】法师有五。一，受持法师。信力故受。念力故持。谓于如来言教，以坚固深信受之于己，忆持不忘，是为受持法师。二，读经法师。对文曰读。谓正心端坐，目睹经文，口宣句读，是为读经法师。三，诵经法师。背文曰诵。谓习读既熟，不须对文，自然成诵，是为诵经法师。四，解说法师。谓以圣教之义，分明解释，训授于人，是为解说法师。五，书写法师。谓于诸经典书写广传，流通大法，是为书写法师。见《法华文句·八·上》。
    法师法名玄奘。偃师陈氏子。本名袆。少穷困。十三岁。随兄长捷出家于洛阳净土寺。就慧景听《涅槃经》。于严法师受《摄大乘论》。武德元年。与兄共入长安。寻赴成都。就道基、宝迁二师学《摄论毗昙》。就震法师听讲《发智论》五年。受具足戒。又习律部。旋往荆州讲《摄论毗昙》。往相州参慧休。赵州参道深。入长安寻道岳学《俱舍论》。贞观三年八月。出国西行。至五印度。历西域百二十八国。遍访大德参究。留学中印摩竭陀国之那烂陀寺。受业于戒贤论师、胜军居士。历治婆沙、俱舍、显扬、顺理、对法、因明、唯识诸论。而于瑜伽造诣尤深。贞观十九年正月归长安。以所获梵典六百五十七部上于朝。二月六日。太宗使于弘福寺传译。贞观二十二年五月二十四日。在终南山翠微宫翻经院译本经成。示寂于麟德元年二月五日。世寿六十五。凡译经十九年。成七十三部。一千三百三十卷。
    译者。传也。传译四夷之语。又陈也。陈设外内之言。又释也。以彼此语言誊释而通之也。又易也。换易言语使相解也。译经者以此方之文。显彼土之法。翻梵天之语。成汉土之言。言虽似别。义则大同。本经奘师主译。笔受者沙门智仁也。
    【注】《涅槃经》有小乘、大乘二部。小乘《涅槃经》译本有三。《佛般泥洹经》二卷，西晋白法祖译。《大般涅槃经》三卷，东晋法显译。《般泥洹经》三卷。失译人名。皆说八相化身成道之释迦佛。于拘尸那城入涅槃前之情状。《中阿含经》中有《涅槃经》。则说可得涅槃之观行。大乘涅槃经。有《佛说方等泥洹经》二卷，西晋竺法护译《大般泥洹经》六卷。东晋法显译《四童子三昧经》。隋阇那崛多译。虽广略不同。皆为大乘涅槃经之初分。北凉昙无谶译《大般涅槃经》四十卷，称北本涅槃。刘宋慧观再治为三十六卷，称南本涅槃。说涅槃非灰身灭智。及佛性常住不灭。唐若那跋陀罗译《大涅槃经后分》二卷。说佛之付嘱及荼毗分骨等事。以补充前经。亦称《后分经》。
    成都。古蜀山氏。今改县。为四川省治。
    摄论。即《摄大乘论》，无著菩萨造。毗昙即阿毗昙，新译作阿毗达摩，此云无比，亦云对法。又小乘萨婆多部之论藏。如《发智》、《六足》（法蕴足、施设足、集异门足、识身足、界身足、品类足）、《毗婆娑》、《俱舍》诸论。亦总名《毗昙》。《发智论》为《阿毗达摩发智论》之略称。佛灭后三百年。迦多衍尼子造。《俱舍论》即《阿毗达摩俱舍论》之略称。世亲菩萨造。
    贞观为唐太宗年号。
    荆州。今湖北省江陵县。相州。今河南省安阳县。赵州。今河北省赵县。长安。今陕西省长安县。
    五印度即五天竺。《西域记》云。五印度之境。周九万余里。三垂大海。北背雪山。北广南狭。形如半月。摩竭陀为中印度国名。王舍城所在。五印度中最大之国。那烂陀寺。为菩提道场之大觉寺东七驿。佛灭后。铄迦罗阿逸多王所建。嗣君佛陀鞠多王。咀他揭多鞠多王。婆罗阿逸多王。先后增修。为五印度最大精舍。
    《婆娑论》为《阿毗达摩婆娑论》之略称。佛灭后四百年。健陀罗国迦腻色迦王选五百圣众造。《显扬论》为《显扬圣教论》之略称，又名《总包集义论》，无著菩萨造。《顺理论》为《阿毗达摩顺正理论》之略称，尊者众贤造，以驳世亲菩萨之俱舍论者，又名《俱舍雹论》。《对法论》即《阿毗达摩杂集论》，安慧菩萨造。《因明论》即《因明正理论》，陈那造。《因明入正理论》，陈那弟子商羯罗主造。《唯识论》即《唯识二十论》，世亲菩萨造。《瑜伽论》即《瑜珈师地论》，弥勒菩萨造。
    终南山。在陕西省长安县东五十里。东至蓝田县。西至郿县。绵亘八百余里。
    麟德。为唐高宗年号。
    周礼掌四方之语。各有其官。东方曰寄。南方曰象。西方曰狄鞮。北方曰译。此特命官之别，其事则统谓之译，谓之象胥，如越裳重译之称，见于《尚书大传》是也。
    译场受译主之言。笔之以汉音。谓之笔受。宋时译经院职司。准《佛祖统纪·四十三》所载凡九。一，译主。正坐面外。宣传梵文。二，证义。坐译主之左。与译主评量梵文。三，证文。坐译主之右。听译主高读梵文。以验错误。四，书字。梵学僧审听梵文。书成华字。犹是梵音。五，笔受。翻梵音成华言。六，缀文。回缀文字。使成句义。七，参译。参考两土文字。使无舛误。八，刊定。刊削冗长，决定句义。九，润文。南向设位。参详润色。
    《般若波罗蜜多心经诠注·卷二》


第一项 能修之人

    《般若波罗蜜多心经诠注·卷三·上》
     震旦白衣周止庵学

    第二篇 正释经文

    正释经文者。正谓纯一不杂。释谓解释开演。经文含义深奥非解莫明。解以起信。信以生愿。愿以成行。故诠释经文。必期有当经恉。本经所示。有显有密。缘经生解。分为二章。第一，显说般若。第二，密说般若。显说令生慧解。密说令生福德。为灭二障。成二严故。
    【注】二障。亦名二碍。一，烦恼障。谓见思二惑。起种种昏烦之法。恼乱心神。障碍无漏法性。名烦恼障。二，所知障。亦名智障。执所知之法。障蔽智慧之性。名所知障。
    二严者。一，智慧庄严。研智慧而为身之庄严。六度中修般若者是。二，福德庄严。积福德而为身之庄严。六度中修檀那尸罗羼提毗梨耶禅那五度者是。

    第一章 显说般若

    清凉释经。于本章准常三分。谓序、正、流通。所谓弥天高判。今古同遵也。本经奘师译本。既仅具正宗分。故前卷已依别译三分之义。略说少分。以下即依经文次序。分别诠释。
    显者，无隐之义。说者，释明意旨也。更分四节述之。

    第一节 因人显法
    本节更分四项

    第一项 能修之人

    观自在菩萨
    此五字有通有别。上三字是别名。别诸菩萨故。下二字是通号。通诸菩萨故。
    观自在。梵语阿缚卢枳多伊湿伐罗。阿缚卢枳多。此云观。伊湿伐罗。此云自在。多伊二字合音作底。故或作阿缚卢枳底湿伐罗。又梵名阿黎耶婆娄吉底输。则译作圣观世音。盖梵本自有二名。观音表悲。自在表智。且此二名皆同于古佛。圣圣相承。先后一揆。
    【注】自在为八地以上菩萨通具之德。观自在则为菩萨专有之名。二者不可混同。自在者。无滞义。菩萨修行教化。调伏一切众生。圆满菩提。神通无碍也。《华严大疏·六》有二义。一，观境自在。谓菩萨以正智慧。照了真如之境。及能通达一切诸法。圆融自在也。二，作用自在。谓菩萨既以正智照了真如之境。由体起用。现身说法。化度众生。圆融自在也。《大乘庄严经论·五》有四义。一，得分别自在。菩萨住不动地。舍一切功用之行。得无功用法。于一切法。远离一切分别之想。而得自在也。二，得刹土自在。菩萨住不动地。深心清净。于诸刹土。得清净出生自在也。三，得智自在。菩萨住善慧地。得无碍智慧。演说诸法。称理自在也。四，得业自在。菩萨住法云地。于诸烦恼业缚。悉能通达。更无障碍也。《大宝积经·六十八》有五义。一，寿命自在。菩萨成就法身慧命。了无生死寿夭。延万劫而不长。促一念而不短。但为度脱有情。以方便随机示现长短寿命之相。其心无所挂碍也。二，生自在。菩萨为度脱有情。以大悲心随类受生。饶益一切处。天宫非乐。地狱非苦。去住无碍也。三，业自在。菩萨万行具足。悲智双运。或现神通。或说妙法。或入禅定。或修苦行。所作行业。但为利他。纵任无碍也。四，觉观自在。粗心曰觉。细心曰观。菩萨或修禅观。或起利生。虽有思惟。离诸散乱。随愿度生。平等无碍也。五，众具果报自在。菩萨因行深广。果报殊胜。于一切所须之具。不假经营。自然周具。心无染碍也。《华严经·三十八》有十义。一，命自在。菩萨得长寿慧命。经无量阿僧祇劫。住持世间。无有障碍也。二，心自在。菩萨智慧方便。调伏自心。能入无量诸大三昧。游戏神通。无有障碍也。三，资具自在。谓菩萨能以无量珍宝。种种资具。严饰一切世界清净。无障无碍也。四，业自在。谓菩萨能随诸业。应时示现。受诸果报。无障无碍也。五，受生自在。谓菩萨随其心念。能于诸世界中示现受生。无障无碍也。六，解自在。谓菩萨胜解成就。能现种种色身。演说妙法。无障无碍也。七，愿自在。谓菩萨随所愿欲。于诸刹中应时出现。成等正觉。无障无碍也。八，神力自在（《十地经论》作如意自在）。谓菩萨神通广大。威力难量。于世界中示现变化。无障无碍也。九，法自在。谓菩萨得大辩才。于诸法中广能演说无边法门。无障无碍也。十，智自在。谓菩萨具足智慧。于一念中能现如来十力（一，知是处非处智力。如来于一切因缘果报。审实能知。如作善业定得乐报。名知是处。若作恶业得受乐报。无有是处。名知非处。二，业异熟智力。如来于一切众生过、现、未三世业报。皆悉遍知。三，知种种界智力。如来于世间众生种种界分。皆如实知。四，知种种胜解智力。如来于诸世间种种胜解。皆如实知。五，知诸根胜劣智力。如来于诸有情诸根胜劣。皆如实知。六，知遍趣行智力。如来于一切遍趣行。皆如实知。七，知一切道品智力。如来于诸根、力、觉支、道支、静虑、解脱、等持、等至、杂染、清静皆如实知。八，知死生智力。如来证知天眼清净。见诸众生生时、死时、端正、丑陋、善恶、业缘无不遍知。九，知宿住随念智力，如来于众生宿命，死此生彼，姓名、饮食、苦乐、寿命如实遍知。十，知漏尽智力。于诸漏尽无漏心解脱。无漏慧解脱。皆如实知。了知我生已尽。梵行已立。所作已办。不受后有。诸漏永尽）。无畏（由十力智内充。于大众中凡有所说。无恐惧相。名无所畏。一，正等觉无畏。于世出世间一切诸法。尽知尽见。说法无畏也。二，漏尽无畏。惑业生死俱尽。安隐无所畏也。三，说障法无畏。说惑业等诸障法无所畏也。四，尽苦道无所畏。说戒定慧等诸尽苦之正道。而无所畏也）。成等正觉（诸佛无上之正智）。无所障碍也。
    观自在。具足应云观世自在。观音。具足应云观世音。唐人以避太宗讳。略去世字。后遂相沿。云此二名皆同于古佛者。《准无量寿经》。阿弥陀佛在因位时。于世自在王所出家。故阿弥陀佛本师为世自在王。《无量寿经钞·二》云。义寂云。旧本名楼夷亘罗。翻之名自在王。法藏比丘成佛以后。即观依本师而得此名。《菩提心义·十》曰。彼佛寿命无量。光明无量。眷属无量。一切皆无量。故以立谥号。而本名观自在王如来。眼如四大海。遍观法界众生。随其机缘。拔苦与乐。故为名也。菩萨以阿弥陀佛为本师。师资相承。亦受此号。《大悲心陀罗尼经》。佛言。此菩萨名观世音自在。《华严经·入法界品》。鞞瑟胝罗居士。告善财言。于此南方。有山名补怛洛迦。彼有菩萨。名观自在。是为菩萨得名观自在之由来。《楞严经·观世音菩萨圆通章》。尔时观世音菩萨。即从座起。顶礼佛足而白佛言。世尊。忆念我昔无数恒河沙劫。于时有佛出现于世。名观世音。我于彼佛发菩提心。彼佛教我从闻思修入三摩地。又云。彼佛如来叹我善得圆通法门。于大会中授记我为观世音号。由我观听十方圆明。故观音名。遍十方界。《弘猛海慧经》。昔阎浮提有王名善首。有五百王子。第一太子名善光。在空王观世音佛所发愿。愿我未来作佛。字观世音。善光太子。即菩萨因地之名。《悲华经》。宝藏佛寻为授记。善男子。汝观天、人、及三恶道一切众生。生大悲心。欲断众生诸苦恼故。欲断众生诸烦恼故。欲令众生住安乐故。善男子。今当字汝为观世音。是为菩萨得名观世音之由来。而此二名。皆同古佛。
    菩萨圣号。唐以前译经。皆作观世音。其作观自在者。自玄奘法师始自后译者。或作观自在。或作观世音。按观自在。梵名为阿缚卢枳多伊湿伐罗。观世音。梵名为婆娄古底输。二名即一菩萨。则或译观自在。或译观世音。本无分别。或以西藏所译诸经作无作观世音者为疑。夫汉、藏契经。同出梵文。梵文既有二名。译文互通。自不能执藏文以疑汉译。又或以观世音为意译。观自在为直译者。是亦不然。因自在与世音。各有含义也。
    交光云。观世音名。具彰二利之德。而所观不同。《法华经》。苦恼众生。一心称名。菩萨即时观其音声。皆得解脱。则所观者。世间音声。盖果门唯显利他之德也。《楞严经》。由我观听十方圆明。故观音名。遍十方界。则所观者。听音根性。盖因门多彰自利之源也。《观音玄义》云。能所圆融。照穷本性。故称观世音。是所观之境。万象流动。隔别不同。类音殊唱。俱蒙离苦。菩萨弘慈。一时普救。皆令解脱。世者为三。一，五阴世间。二，众生世间。三，国土世间。释迦所说。以音声为佛事。故言观世音。孤山云。观即能照之智。世即所照之境。音即所照之机。以观其音声。即得解脱故。续法师《观经直指疏》云。观听十方圆妙明音。是自行号。令彼十方苦恼众生。观其音声。即得解脱。是利他号。
    《法华文句·十·下》云。观有多种。谓析观、体观、次第观、圆观。析观者，灭色入空也；体观者，即色是空也；次第观者，从析观乃至圆观也；圆观者，即析观是实相乃至次第观亦实相也。今简三观惟论圆观。世亦多种，谓有为世、无为世、二边世、不思议世。有为世者，三界世也；无为世者，二涅槃也；二边世者，生死、涅槃也；不思议世者，实相境也。今简诸世，但取不思议世。音者，机也。机亦多种，人天机、二乘机、菩萨机、佛机。人天机者，诸恶莫作，众善奉行也；二乘机者，厌恶生死，欣尚无为也；菩萨机者，先人后己，慈悲仁让也；佛机者，一切诸法中，悉以等观入一切无碍人，一道出生死也。今简诸音之机，惟取佛音之机，名观世音。《宗镜录·三十六》云：言‘观’一字，理有二种。一，观瞩。二，观察。初观瞩者。如前五识缘五尘境。瞩对前境。显现分明。无推度故。现量性境之所摄故。次观察者，向自识上安模建立。伺察推寻境分剂故。

    观自在菩萨。不但名同古佛。其本地亦已早证妙觉。以大悲愿力。普度众生故。现作菩萨。为西方极乐世界阿弥陀佛左辅。位阶补处。道成正觉。以般若妙智。观照世间一切缘起实相。破除人法二执。观空不著空。观有不著有。根尘俱消。空有无碍。观听圆明。得大自在。能现众生妙容。能说无边秘密神咒。现一一形。诵一一咒。化身无量。无刹不现。成就三十二应。十四无畏。四不思议功德巍巍。度人最胜。
    【注】本地者。对于垂迹之称。初地以上法身之菩萨及佛。由法身实体。应化以度众生。其实体为本地。化身为垂迹。地者。能生之义。能现之本为本地。所现之末为垂迹。台宗于此立四句。一，本高迹下。如菩萨现声闻身。二，本下迹高。如菩萨现佛身。三，本迹俱高。如佛现佛身。四，本迹俱下。如初地菩萨现初地之相也。见《法华玄义释签·十五》。菩萨本地早证妙觉者。妙觉即佛。《准观音三昧经》。佛说。观音在我前成佛。名正法明如来。我为苦行弟子。《千光眼观自在菩萨秘密法经》。佛说。观自在菩萨。在我前成佛。号曰正法明。十号具足。《大悲心陀罗尼经》。佛告阿难。此观世音自在菩萨。有不可思议威神之力。于过去无量无数阿僧祇劫前。已成佛竟。号曰正法明如来。大悲愿力。为欲成熟安乐一切众生故。现作菩萨。
    弥陀三圣。一，阿弥陀佛。悲智二德全备。二，观世音菩萨。主悲门。位于佛之左位。三，大势至菩萨。主智门。位于佛之右位。故称观世音菩萨为弥陀左辅。
    嗣前佛而成佛之菩萨。即补前佛之处谓之补处。等觉菩萨。无明之惑未尽。尚有一番变易生死。过此一生。即登妙觉果佛之位。所以等觉菩萨。称为一生补处。等者平等。觉者觉悟。大乘阶位五十二位中。第五十一位之菩萨曰等觉。去佛之妙觉尚有一等。是菩萨之极位。《悲华经·三》。阿弥陀佛般涅槃已。菩萨于一念中间。成阿耨多罗三藐三菩提。号遍出一切光明功德山王如来。《观世音菩萨受记经》。阿弥陀佛正法灭后。过中夜分。明相出时。观世音菩萨于七宝菩提树下。结跏跌坐。成等正觉。号普光功德山王如来。普光即遍出一切光明。文异义同。
    缘起者。待缘而起。故名缘起。亦云缘生。《俱舍论·九》。诸支因分。说名缘起。由此为缘。能起果故。诸支果分。说缘已生。由此皆从缘所生故。
    二执者。人执法执。人执执我为有。故又名我执。《成唯识论》云。我执略有二种。一者。俱生。二者。分别。俱生我执。无始时来。虚妄熏习。内因力故。恒与身俱。不待邪教及邪分别。任运而转。故名俱生。此复二种。一，常相续。在第七识。缘第八识起自心想。执为实我。二，有间断。在第六识。缘识所变。五取蕴相。或总或别。起自心想。执为实我。此二我执细。故难断。后修道中数数修习胜生空观。方能除灭。分别我执。非与身俱。必待现在外缘邪教邪分别。然后方起。惟在第六意识中有。此亦二种。一，缘邪教所说蕴相起自心相。分别计度。执为实我。二，缘邪教所说我相。起自心相。分别计度。执为实我。此二我执粗。故易断。初见道时。观一切法生空真如。即能除灭。法执亦有二。一者。俱生。二者。分别。俱生法执。以无始时。虚妄熏习内因力故。恒与身俱。不待邪教及邪分别。任运而转。故名俱生。此复二种。一，常相续。在第七识缘第八识起自心相。执为实法。二，有间断。在第六识缘识所变蕴、处、界、相。或总或别。起自心相。执为实法。此二法执细。故难断。后十地中数数修习胜法空观。方能除灭。分别法执。亦由现在外缘力故。非与身俱。要待邪教及邪分别。然后方起。惟在第六意识中有。此亦二种。一，缘邪教所说蕴、处、界、相。起自心相。分别计度。执为实法。二，缘邪教所说自性等相。起自心相。分别计度。执为实法。此二法执粗。故易断。入初地时。观一切法空真如。即能除灭。盖此身由五蕴四大假合而成。名之为人。凡夫就此假名。妄执为我。本经说五蕴皆空。即为破此我执而悟人空。二乘计五蕴之法为实有。致生法执。本经说般若深慧。彻见五蕴皆空。即为破此法执而悟法空。
    观空不著空者。菩萨以无相妙慧。照无相境。内外俱寂。《楞严经·六》曰：从闻思修入三摩地。初于闻中。入流亡所。所入既寂。动静二相。了然不生。如是渐增。闻所闻尽。尽闻不住。觉所觉空。空觉极圆。空所空灭。生灭既灭。寂灭现前。即证此境。观有不著有者。菩萨谛观贪嗔痴等一切恶行。起于妄念。妄念起于颠倒。颠倒起于我见。了达我性本空。翻破无明昏闇。不著者。无执之义。无执则无系缚。无系缚则得解脱。非空之空。故曰真空。异于小乘偏执之但空。非有之有。故曰妙有。异于凡夫妄计之实有。非有非空。是为中道。《宝藏论》云。非有非空。万物之宗。非空非有。万物之母。
    根尘俱消者。如《楞严经·六》曰：根结若除。尘相自灭。诸妄销亡。不真何待。空有无碍者。般若非有相非无相。非亦有亦无相。非非有非无相。一切诸法。本非偏有偏空。空为即有之空。有为即空之有。互融双绝而不相碍。菩萨谛观中道。以空观破有执。有观破空执。遣虚存实。理事无碍也。
    观听圆明。得大自在者。菩萨心精遗闻。见闻觉知不能分隔。成一圆融清净宝觉。故能六根互用。无分观听。同一妙明真性。无适而不自在。《事观解》云。实相观照。救世自在。此约智悲说。观音救苦。恒在那伽（《俱舍论·十三》云：那伽行在定。住在定。卧在定。坐在定）。此约慧定说。《法华》真、净、智、慈、悲五观。定也。妙、观、梵、潮、胜五音。慧也。均等自在。五观中。前三，智也。后二，悲也。五音中。三、四悲也。余三智也。正显智悲并运。真俗融通。上同下合。得大自在。此是带果行因号也。圆测云。内证二空。外观三业。不依功用。任运自在。一者。戒自在。二者。定自在。三者。慧自在。四者。心自在。从自行化他说。菩萨从闻思修入三摩地。观听圆明。得大自在。此自修自在也。又得无作妙力。自在成就。随类现身。应机说法。此度生自在也。大自在者。从体起用。广大之法力也。《法华经·弟子授记品》曰：诸佛有大自在神通之力。《大般涅槃经·二十三》。八大自在。一，能示一身为多身。二，示一尘身满于三千大千世界。三，以满此三千大千世界之身。轻举飞空。过于二十恒河沙等诸佛世界。而无障碍。四，如来一心安住不动。而可示化无量形类。或造一事，而令众生各各成办。常住一土。而令他土一切悉见。五，诸根互用。一根能见色闻声、嗅香、别味、觉触、知法。亦能六根不见色，不闻声，不嗅香，不别味，不觉触，不知法。六，得一切法亦无得想。以无所得故。以无得故。名得涅槃。七，说一偈义。经无量劫不尽。八，如来遍满一切诸处。犹如虚空。虚空之性。不可得见。如来亦尔。以自在故。令一切见。是为如来八大自在。菩萨以古佛垂化。救护众生。故亦得大自在也。能现众多妙容者。如《楞严经》曰。或现一首、三首、五首、七首、九首、十一首，如是乃至一百八首、千首、万首、八万四千烁迦罗（此云轮。又坚固不坏如金刚也）首。二臂、四臂、六臂、八臂、十臂、十二臂、十四、十六、十八、二十至二十四，如是乃至一百八臂、千臂、万臂、八万四千母陀罗（此云印）臂。二目、三目、四目、九目，如是乃至一百八目、千目、万目、八万四千清净宝目。或慈或威。或定或慧。救护众生。得大自在也。
    能说无边秘密神咒者。既曰无边。自不可以数计。《大般若经》曰。言无边者。边不可得。不可测度彼边际故。姑就大藏中所见者。例举一二。如《不空罥索陀罗尼经》《千手千眼观世音菩萨广大圆满无碍大悲心陀罗尼经》《十一面观世音菩萨经》《观世音菩萨如意轮陀罗尼经》《青颈大悲心陀罗尼经》《叶衣观自在菩萨经》《三世最胜心明王经》《千光眼观自在菩萨秘密法经》《观自在菩萨说普贤陀罗尼经》《怛嚩多唎随心陀罗尼经》《请观世音菩萨消伏毒害陀罗尼经》《阿唎多罗陀罗尼·阿噜力品》《千转陀罗尼观世音菩萨咒》《大乘庄严宝王经》《观世音菩萨秘密藏神咒经》《大方广曼殊室利经》《一切如来名号陀罗尼经》《八大曼拏罗经》《陀罗尼集经》《陀罗尼杂集》《现证三昧大教王论》《菩萨所说神咒》已无虑数百种。为无边秘密神咒中少分中之少分。行者但能清净三业。任择一种或数种。虔心持诵。久之自有不可思议之感应。惟诚则灵。行者勉之。
    菩萨所说神咒。流通最广者。为大悲心陀罗尼。及六字大明王咒（见《大乘庄严宝王经·四》）。白衣大士咒（《陀罗尼杂集·十·观世音说应现与愿陀罗尼》咒语同）。二十一度母总度母咒（频伽藏成字十三册。圣救度佛母二十）。《种礼赞经》《碛砂藏·五百六十三册》《佛说大方广曼殊室利经·观自在为多罗菩萨说陀罗尼》咒语均同。《陀罗尼集经·五·观世音菩萨心印咒》日本《续藏经·楞严经》述旨二一五页所引白衣咒。大致亦同）等。其持诵仪轨及手印真言等。详见拙著《大悲心陀罗尼经补注》。
    现一一形者。即现众多妙容也。菩萨应化示现。随类而异其形。图画普门品有三十三观音之像。一，杨柳观音。二，龙头观音。三，持经观音。四，圆光观音。五，游戏观音。六，白衣观音。七，莲卧观音。八，泷见观音。九，施药观音。十，鱼篮观音。十一，德王观音。十二，水月观音。十三，一叶观音。十四，青颈观音。十五，威德观音。十六，延命观音。十七，众宝观音。十八，岩石观音。十九，能静观音。二十，阿耨观音。二十一，阿么提观音。二十二，叶衣观音。二十三，琉璃观音。二十四，多罗尊观音。二十五，蛤蜊观音。二十六，六时观音。二十七，普慈观音。二十八，马郎妇观音。二十九，合掌观音。三十，一如观音。三十一，不二观音。三十二，持莲观音。三十三，洒水观音。不知所据何经考之二中 历三。《三十三观音颂》曰。不空罥索。不空勾。夜轮多罗。忿怒勾。阿鲁利迦。如意轮。圆满意愿。大随求。利乐金刚。灭恶趣。一髻罗刹。多罗女。莲华发生。披叶衣。千手千眼。十一面。大吉祥明。水吉祥。大吉祥变。大势至。大明白身。毗俱胝。大吉大明。及丰财。马头。白身。白处尊。又加六大（即六观音）三十三。数虽相同。而名称不符。且十一面为六观音之一，此处又另有十一面。则除去重出。亦未足三十三之数。《大本如意经》有八大观音。一，圆满意愿明王菩萨。二，白衣自在。三，髻罗刹女。四，四面观音。五，马头观音。六，毗俱胝。七，大势至。八，陀罗观音。《诸尊真言句义抄》中有十五观音。一，正观音。二，千手观音。三，马头观音。四，十一面观音。五，准胝观音。六，如意轮观音。七， 不空罥索观音。八，白衣观音。九，叶衣观音。十，水月观音。十一，杨柳观音。十二，阿么提观音。十三，多罗观音。十四，青颈观音。十五，香王观音。此外散见诸经及陀罗尼者。尚有四臂观世音。六臂观世音。十二臂观世音。随心观世音。多唎心观世音。一嗟三钵底迦啰观世音等。《天台玄义》有六观音。一，大悲观音。二，大慈观音。三，师子无畏观音。四，大光普照观音。五，天人丈夫观音。六，大梵深远观音。《摩诃止观·二》云。大悲观世音。破地狱道三障。此道苦重。宜用大悲。大慈观世音。破饿鬼道三障。此道饥渴。宜用大慈。师子无畏观世音。破畜生道三障。兽王威猛。宜用无畏。大光普照观世音。破阿修罗道三障。此道猜忌嫉疑。宜用普照。天人丈夫观世音。破人道三障。人道有事有理。事伏憍慢称天人。理则见佛性称丈夫。大梵深远观世音。破天道三障。梵是天主。标主得臣也。密宗亦有六称。一，千手观音。同上大悲。二，圣观音。同上大慈。三，马头观音。同上师子无畏。四，十一面观音。同上大光普照。五，准胝观音。同上天人丈夫。六，如意轮观音。同上大梵深远。圣观音亦称圣观自在。为诸观音之总体。又有二十五观自在。一，代苦观自在。二，与智观自在。三，施满观自在。四，除戟观自在。五，除愚观自在。六，进道观自在。七，观正观自在。八，施无畏观自在。九，施光观自在。十，与甘露观自在。十一，见天观自在。十二，施妙观自在。十三，见乐观自在。十四，降魔观自在。十五，静虑观自在。十六，作文观自在。十七，见禅观自在。十八，愍定观自在。十九，调直观自在。二十，空惠观自在。二十一，护圣观自在。二十二，清静观自在。二十三，正法观自在。二十四，离欲观自在。二十五，不动观自在。见菩萨所说陀罗尼中。此外尚有。一，摩尼与愿观自在。二，持索观自在。三，宝钵观自在。四，宝剑观自在。五，金刚观自在。六，持杵观自在。七，除怖观自在。八，日精观自在。九，月精观自在。十，持宝弓观自在。十一，速值观自在。十二，药王观自在。十三，拂难观自在。十四，持瓶观自在。十五，现怒观自在。十六，镇难观自在。十七，持环观自在。十八，分荼利观自在。十九，见佛观自在。二十，镜智观自在。二十一，见莲观自在。二十二，见隐观自在。二十三，仙云观自在。二十四，禅定观自在。二十五，天花观自在。二十六，破贼观自在。二十七，念珠观自在。二十八，持螺观自在。二十九，缚鬼观自在。三十，法音观自在。三十一，智印观自在。三十二，钩召观自在。三十三，慈杖观自在。三十四，现敬观自在。三十五，不离观自在。三十六，大势观自在。三十七，般若观自在。三十八，不转观自在。三十九，灌顶观自在。四十，护地观自在。又有：一，持杵观音。二，大势观音。三，宝钵观音。四，日精观音。五，持索观音。六，榜排观音。七，白拂观音。八，月精观音。九，宝弓观音。十，宝经观音。十一，白莲观音。十二，紫莲观音。十三，宝箭观音。十四，胡瓶观音。十五，青莲观音。十六，蒲桃观音。十七，宝镜观音。十八，玉环观音。十九，顶上观音。二十，军持观音。二十一，红莲观音。二十二，锡杖观音。二十三，化佛观音。二十四，数珠观音。二十五，宝螺观音。二十六，髑髅观音。二十七，宝箧观音。二十八，五色云观音。二十九，安钺斧观音。三十，戟鞘观音。三十一，杨柳观音。三十二，宝铎观音。见《千光眼观自在菩萨秘密法经》。菩萨从体起用。以一身现众多妙容。非凡情所能测度。此所说者。仅其少分而巳。
    菩萨现形为摩尼与愿观自在。作慈悲体。身黄金色。顶有十一面。当前三面。为菩萨相。右边三面。白牙出上相。左边三面。忿怒相。当后一面。暴笑相。顶上一面。如来相。菩萨本面有三目。以袈裟、璎珞、环等。庄严妙体。坐红莲座。处月轮中。半跏而坐。右押左。左手当心持摩尼。其珠吠琉璃色。黄光发焰。右手与愿契屈臂向上。如上二十五菩萨形像。等同无异。惟所持法宝，各各不同。见《千光眼观自在菩萨秘密法经》。
    菩萨现形为千手千眼圣尊时。如《千光眼观自在菩萨秘密法经》说，观自在菩萨，为众生故，具足千臂。其眼亦尔。略说四十手法。其四十手分为五部。一者。如来部。二者。金刚部。三者。摩尼（此云宝）部。四者。莲华部。五者。羯噜磨（此云事业）部。一部之中。各配八手。其五部中。亦有五法。一者。息灾法。用佛部尊。所以有化佛手。罥索手。施无畏手。白拂手。榜排手。钺斧手。戟矛手。杨柳手。二者。调伏法。用金刚部尊。是故有跋折罗手。金刚杵（此用独钴）手。宝剑手。宫殿手。金轮手。宝钵手。日摩尼手。月摩尼手。三者。增益法。用摩尼部。是故有如意珠手。宝弓手。宝经手。白莲手。青莲手。宝铎手。紫莲手。蒲桃手。四者。敬爱法。用莲华部。所以有莲华合掌手。宝镜手。宝印手。玉环手。胡瓶手。军持手。红莲手。锡杖手。五者。钩召法。用羯磨部。所以有铁钩手。顶上化佛手。数珠手。宝螺手。宝箭手。宝箧手。髑髅手。五色云手。随其所欲。无不成办。菩萨住无畏地。得二十五三昧。坏二十五有。于千光王静住如来所。亲受大悲心陀罗尼已。超第八地。心得欢喜。发大誓愿。应时具足千手千眼。即入三昧。名无所畏。于三昧光中。涌出二十五菩萨。身皆金色。具诸相好。如观自在。各于顶上具十一面。身上具四十手。每手掌中有一慈眼（二十五菩萨各具四十手眼。合为千手千眼）。此二十五化菩萨。或入无垢三昧。破地狱有。或入无退三昧。坏畜生有。或入心乐三昧。坏饿鬼有。或入欢喜三昧。坏阿修罗有。或入日光三昧。破东胜神洲有。或入月光定。断西牛货洲有。或入热炎定。破北上胜洲有。或入如幻三昧。断南瞻部洲有。或入不动定。破四天处有。或入难伏三昧。断忉利天有。或入悦意定。断炎摩天有。或入青色三昧。破兜率天有。或入黄色三昧。破化乐天有。或入赤色三昧。断他化自在天有。或入白色三昧。断初禅有。或入种种三昧。破梵王有。或入双三昧。破二禅有。或入雷音三昧。破三禅有。或入注雨定。断四禅有。或入如虚空定。坏无想有。或入照镜三昧。破净居阿那含有。或入无碍三昧。断空处有。或入常三摩地。坏识处有。或入乐三摩地。破无所有处有。或入我三摩地。坏非想非非想处有。菩萨成就诸三昧王。以一法身现二十五。亦以二十五现多菩萨（以上二十五菩萨。各从四十手现四十菩萨）。其一千菩萨。一一各于顶上具十一面。于其本面而有三目。一一如是具二十五。各于一界有四十菩萨。一一界中各配千眼皆是观自在大悲所为。
    观世音菩萨。显教以为阿弥陀佛之弟子。如《大悲心陀罗尼经》。菩萨称阿弥陀如来为本师是也。密教则以为阿弥陀佛之化身。如《大日经·一》曰。北方大精进。观世自在者。光色如皓月。商佉（此云螺贝）军那华（西方有此华。色鲜白）。微笑坐白莲。髻现无量寿是也。《大日经疏·五》云。大日右方置大精进观世自在者。即是莲华部主。谓如来究竟观察十缘生句。得成此普眼莲华。故名观自在。约如来之行。故名菩萨。顶现无量寿者。明此行之极果。即是如来普门方便智。《龙树十二礼》云。观音顶戴冠中住。种种妙相宝庄严。能伏外道魔憍慢。故我顶礼弥陀尊。亦以观音为弥陀化身也。
    行者欲修观世音菩萨观想。应观观世音菩萨身长八十万亿那由他由旬。身紫金色。顶有肉髻。顶有圆光。面各百千由旬。其圆光中有五百化佛。如释迦牟尼。一一化佛。有五百化菩萨。无量诸天以为侍者。举身光中。五道众生一切色相。皆于中现。顶上毗楞伽摩尼宝以为天冠。其天冠中有一立化佛。高二十五由旬。观世音菩萨。面如阎浮檀金色。眉间毫相。备七宝色。流出八万四千种光明。一一光明。有无量无数百千化佛。一一化佛。无数化菩萨以为侍者。变现自在。满十方世界。臂如红莲华色。有八十亿微妙光明。以为璎珞。其璎珞中普现一切诸庄严事。手掌作五百亿杂莲华色。手十指端。一一指端。有八万四千画。犹如印文。一一画有八万四千色。一一色有八万四千光。其光柔软。普照一切。以此宝手。接引众生。举足时。足下有千辐轮相。自然化成五百亿光明台。下足时。有金刚摩尼华。布散一切。莫不弥满。其余身相。众好具足。如佛无异。惟顶上肉髻。及无见顶相。不及世尊。是为观世音菩萨真实色身相。见《观无量寿佛经》。
    《圣救度佛母二十一种礼赞经》中之总度母本尊。旧称多罗观自在菩萨。即南海普陀山之观世音菩萨也。见《瑜珈精舍印行》之《圣救度佛母修持法》。按多罗菩萨。为胎藏界曼陀罗观音院三十七尊之一。即多罗观音。莲华部之部母也。观音有定慧二德。毗俱胝主慧。多罗主定。作女人状。《大日经·一》曰。彼右大称名。圣者多罗尊。青白色相杂。中年女人状。合掌持青莲。圆光无不遍。晖发犹净金。微笑鲜白衣。《大方广曼殊室利经》曰。多罗大悲者。一切之慈母。天人及药叉。无一非子者。故号世间母。《大日经疏·五》云。此是观自在三昧。故作女人像。多罗是眼义。青莲华是净无垢义。以慈眼摄受群生。故作中年女人像。此皆菩萨从体起用。种种化身之一。《楞严经》所谓或慈、或威、或定、或慧。现女相者，表慈、表定而已，非本体为女身。盖界内色界天以上。已无女身。何况已超三有之菩萨。弥陀大愿。女人往生。尚不复为女像。何况弥陀左辅。世间供养。多作女相者。自唐以后始然。一由误于传说。二由不明菩萨化身无量之义也。
    诵一一咒者。即无边秘密神咒。其同体形咒。如大悲心陀罗尼。以一身心现千手眼。照见法界。护持众生。其异体形咒。则对异机而现异形。于异身而说异咒。或现身脱其苦恼。或说咒遂其愿求。其形其咒。能以无畏施诸众生是也。
    化身者。通义名应化身。变化身。《佛地论·七》云。变化身者。为欲利益安乐众生。示现种种变化事故。从狭义说。则分应化为二。《大乘义章·十八》云。为化众生。示现佛形。名为应身。示现种种六道之形。说为化身。无量者。广大之异名。《大般若经·三百二十九》曰。言无量者。量不可得。《摄大乘论·十八》云。不可以譬类得知为无量。
    无刹不现者。菩萨慈护众生。无私覆。无私载。如日月之经天。如江河之行地。寻声救苦。无处不现。《法华经·普门品》。所谓十方诸国土。无刹不现身也。
    《楞严经》说菩萨三十二应入诸国土。一，佛身。二，独觉身。三，缘觉身。四，声闻身。五，梵王身。六，帝释身。七，自在天身。八，大自在天身。九，天大将军身。十，四天王身。十一，四天王太子身。十二，人王身。十三，长者身。十四，居士身。十五，宰官身。十六，婆罗门身。十七，比丘身。十八，比丘尼身。十九，优婆塞身。二十，优婆夷身。二十一，女主、国夫人、命妇、大家身。二十二，童男身。二十三，童女身。二十四，天身。二十五，龙身。二十六，药叉身。二十七，乾闼婆身。二十八，阿修罗身。二十九，紧那罗身。三十，摩睺罗身。三十一，人身。三十二，非人身。与《法华经·普门品》普现色身示现之三十二应。大同小异。普门品并独觉身、缘觉身为辟支佛身。无四天王身。而有毗沙门身。无人王身，四天王太子身。而有小王身。无女主、国夫人、命妇、大家身。而有长者居士宰官婆罗门妇女身。别有迦楼罗身及执金刚神身。则《楞严经》所无。《大乘庄严宝王经》观自在现身说法。除佛身、缘觉身、声闻身、大自在天身、梵王身、帝释身、龙身、药叉身、人王身、宰官身外。亦示现菩萨身、那罗延身、日天子身、月天子身、火天身、水天身、风天身、频那夜迦身、多闻天王身、父母身。《大方广曼殊室利经》。佛说观自在菩萨摩诃萨。以清净身。能为众生作诸佛事。示现佛身、摩醯首罗身、帝释身、迦楼罗身、紧那罗身、摩呼罗伽、悉地、明仙、日月、星宿、童男、童女种种之身。乃至异类。二足、四足、多足、无足、有情、无情、三界之身。而得度者。即皆现之而为说法。总之菩萨普门示现。随类度生。非有限量。即嗔心最重禁入铁地之大力阿苏啰王。及其眷属。亦现阿苏啰身。为说《大乘庄严宝王经》。于苦趣最重不能闻法之大阿鼻地狱。放大光明。以拔其苦。又入饿鬼大城。十指毛孔。皆出大河。使饿鬼饮之。业火悉灭。变成清凉。菩萨悲愿之深。不可以凡情测度。诚如《宝王经》佛说。观自在菩萨摩诃萨。变现种种。救度无数百千万俱胝那庾多有情。令得往生极乐世界。见无量寿如来。得闻法要。皆令得成菩提道也。《法华》《楞严》所云三十二应。不过如来于说法时略示其例而已。以菩萨位而能现佛身者。以菩萨带果行因。虽在因位。已得佛之受用。上合诸佛同一慈力故。以菩萨过去劫前早已成佛故。
    十四无畏者。《楞严经》观世音菩萨以金刚三昧无作妙力。与诸十方三世六道一切众生。同一悲仰。令诸众生获得十四种无畏功德。一，不自观音以观观者。不自观音者。谓不自声尘起知见也。以观观者。谓返照自性也。不起知见则无所妄。返照自性则一切真寂。无复苦恼。故令受苦众生蒙此真观。即得解脱。二，知见旋复。在心曰知。在眼曰见。菩萨旋转知见以复真空。三，观听旋复。观听性动。则属于水。菩萨旋转观听以复真空。四，断灭妄想。心无杀害。妄想作业。以杀为首。菩萨证悟实性。断灭妄想。大慈不杀。化导祥和。五，熏闻成闻。六根销复。同于声听。熏闻属思。思其所闻。无性可得。则成真闻。六根害人。兵刃无异。菩萨六根销尽。以复真空。一切尘境。同于声听。六，闻熏精明。明遍法界。菩萨从闻熏习所成慧性。明照十方。幽霾潜消。七，音性圆消。观听返入。菩萨动静性灭。声尘解脱。故其观听。返妄入真。八，灭音圆闻。遍生慈力。菩萨消灭音声。圆成闻慧。遍生慈力。以济群生。九，熏闻离尘。色不能劫。菩萨以思慧熏闻成性。离诸尘妄。不为色劫。能令一切多淫众生。远离贪欲。十，纯音无尘。根境圆融。菩萨音性纯净。离诸妄尘。根境相入，圆融无碍。十一，销尘旋明。菩萨除暗销尘。旋复性明。能令一切昏钝无善心人。痴暗远离。十二，融形复闻。融形则碍灭。复闻则性真。菩萨涉入世间。而不坏世间相。十三，六根圆通。明照无二。菩萨六根圆融。通达无碍。含摄法界。如大圆镜。晶莹朗彻。明照无二。故能承顺法门。受领无失。十四，菩萨一名与六十二亿恒河沙诸法王子名。等无有异。菩萨得真圆通。一即一切。一切即一。平等圆融。更无分际。四不思议无作妙德者。理空非惑情可测。神奇非浅识所量。是曰不思议。任运自在。非出有为。是曰无作。观自在菩萨。四不思议无作妙德。一者。能现众多妙容。说无边秘密神咒。救护众生。得大自在。二者。十方微尘。无刹不现。能以无畏施诸众生。三者。众生见者。咸生欢喜。不惜身财。以求哀愍。四者。能以珍宝。供养如来。亦令众生所求世出世法。无不随愿。
    法月译本。观世音菩萨入慧光三昧正受后。以三昧力行深般若波罗蜜多。照见五蕴皆空。乃至无智亦无得。已到佛地究竟境界。或谓菩萨犹未成佛。何能臻此极果。按观世音菩萨。于过去久远劫前。已成佛道。以悲心殊胜。故倒驾慈航。垂形六道。示菩萨愿行。助诸佛宏化。与一般登地以上之法身大士不同。此观经中所示修证境界可以知之。

    菩萨具名菩提萨埵。此云觉有情。旧译作道众生。分释之。菩提是道义。觉悟义。无上智慧义。萨埵是有情义。萨遮。此云有。埵。此云情。一切有知觉者皆有情识也。自行成就。转以觉悟众生。谓之菩萨。故有自行、化他两利三义。从自行说。菩萨虽分证如来。识情未尽。悟性真常。了惑除妄。此自觉义。从化他说。菩萨以悲悯心。运无缘慈。开悟一切有情。同登彼岸。此觉他义。从两利说。菩萨上求大觉。下化有情。历劫修因。行满果圆。自他并利。是名菩萨。观自在菩萨以等觉身。运无缘慈。悲悯众生。故说此经。
    【注】菩萨有地前地上之别。未到初地。谓之地前菩萨。凡夫之菩萨也。初地以后。谓之地上菩萨。法身之菩萨也。萨埵旧译众生。惟众生兼含有生命而无情感之植物。故不如新译有情。较为确切。《唯识述记》云。萨埵此言有情，有情识故。又情者。性也。有此性故。爱也。能有爱生故。言众生者。不尽理也。

    观自在菩萨为本经说法之人。旧时说经者。如唐释靖迈。谓登地以上诸大士。通有此德。非专指弥陀左辅。明·释宗泐《心经注解》。亦以观自在为能修般若之菩萨。但按法月、法成、智慧轮及施护各译本。本经系世尊于灵鹫山中。入三摩地甚深光明。菩萨承佛威神宣说此经。即世尊大部般若之精要。菩萨所说。即是佛说。
    《连珠记》引不空译云。菩萨白言。我欲于会中说诸菩萨普遍智藏般若波罗蜜多心。蒙佛听许。入慧光定。照五蕴空。度苦厄等。郑重宣说。不应但具通德之号。不显本名。且诸经称观自在菩萨者。皆指观世音菩萨。或且连称为观世音自在。盖自在诚为八地以上菩萨所通具之德。而观自在菩萨则为特定之称。《心经幽赞》云。或处上位。诸具大心。妙慧成就。皆观自在。或指示此令瞩曰观。非住西方来游此者。彼《大经》中。不别显故。意亦谓非专指弥陀左辅之观世音。为后来释经者异说所从起。但细按本经所说般若心要。与《大般若经》佛告舍利子者。大致相同。《大般若经》初分，至八分，及十五分，皆薄伽梵住王舍城鹫峰山顶所说。当日法筵清众。观自在菩萨摩诃萨。与得大势菩萨摩诃摩诃萨。妙吉祥菩萨摩诃萨连名并列。《大品般若》则以观世音菩萨与文殊师利菩萨同次。不可谓大经不别显。《大经》与《心经》说法时处相同。所说无异。则当般若会中。佛告舍利子以后。菩萨承流宣化。阐演佛说。重告舍利子以般若心要。其为西方游此弥陀左辅之观自在菩萨。无可致疑。且依《千光眼观自在菩萨秘密法经》。佛说。我念往昔时。观自在菩萨于我前成佛。号曰正法明。十号具足。我于彼时。为彼佛下作苦行弟子。蒙其教化。今得成佛。十方如来。皆由观自在教化之力故。于妙国土。得无上道。转妙法轮。则依佛说可征观自在菩萨为正法明如来垂迹之号。决不可误解为一般能观自在之菩萨也。
    【注】《大般若经·四·初分相应品·第三之一》。舍利子。诸色空。彼非变碍相。诸受空。彼非领纳相。诸想空。彼非取缘相。诸行空。彼非造作相。诸识空。彼非了别相。何以故。舍利子。色不异空。空不异色。色即是空。空即是色。受想行识不异空。空不异受想行识。受想行识即是空。空即是受想行识。何以故。舍利子。是诸法空相。不生。不灭。不染。不净。不增。不减。非过去。非未来。非现在。舍利子。如是空中无色。无受想行识。无地界。无水火风空识界。无眼处。无耳鼻舌身意处。无色处。无声香味触法处。无眼界。无耳鼻舌身意界。无色界。无声香味触法界。无眼识界。无耳鼻舌身意识界。无眼触。无耳鼻舌身意触。无眼触为缘所生诸受。无耳鼻舌身意触为缘所生诸受。无无明生。无无明灭。无行，识，名，色，六处，触，受，爱，取，有，生，老死，愁叹苦忧恼生。无行，乃至愁叹苦忧恼灭。无苦圣谛。无集，灭，道，圣谛。无得。无现观。无预流。无预流果。无一来。无一来果。无不还。无不还果。无阿罗汉。无阿罗汉果。无独觉。无独觉菩提。无菩萨。无菩萨行。无佛。无佛菩提。舍利子。修行般若波罗蜜多菩萨摩诃萨。与如是等法相应。故当言与般若波罗蜜多相应。又四百三。第二分观照品第三之二。四百八十。第三分舍利子品第二之二。佛告舍利子文均相同。
    《大品般若经二·习应品·第三》。舍利弗。色空故。无恼坏相。受空故。无受相。想空故。无知相。行空故。无作相。识空故。无觉相。何以故。舍利子。非色异空。非空异色。色即是空。空即是色。受想行识。亦如是。舍利弗。是诸法空相。不生。不灭。不垢。不净。不增。不减。是空法。非过去。非未来。非现在。是故空中无色。无受想行识。无眼耳鼻舌身意。无色声香味触法。无眼界，乃至无意识界。亦无无明。亦无无明尽。乃至亦无老死。亦无老死尽。无苦集灭道。亦无智。亦无得。亦无须陀洹。无须陀洹果。无斯陀含。无斯陀含果。无阿那含。无阿那含果。无阿罗汉。无阿罗汉果。无辟支佛。无辟支佛道。无佛亦无佛道。舍利弗。菩萨摩诃萨如是习应。是名与般若波罗蜜多相应。
    王舍城。梵语罗阅只伽罗。罗阅只，此云王舍。伽罗，此云城。在中印度摩伽陀国。鹫峰山。梵语耆阇崛。亦云灵鹫山。有五峰。东名象头。西名羊头。南名马头。北名师子头。中云鹫头。从形称也。有五精舍。一，天主穴山精舍。二，七叶穴山精舍。三，蛇神穴山精舍。四，少独力山精舍。五，耆阇崛山精舍。即鹫峰山顶佛说法处也。


第二项　所修之法

    行深般若波罗蜜多时。
    行。梵语散娑歌啰。亦作遮梨夜。经历义。以无漏净慧。历观诸法。故名为行。又修行义。即因地所修清净法行也。遍依十信、十住、十行、十回向、四加行、十地以至等觉、妙觉诸位。依次修习。名差别行。亦名遍成诸行。依圆融法门。于诸位中。随修一行。即具一切诸行。名普贤行。亦名顿成诸行。从闻而思。从思而修。故曰修行。
    【注】十信为入三贤之基。修万行之首。五十二大乘阶位中。从凡入圣之第一步。佛法无量。惟信为先。所谓信为道源功德母也。一，信心。心与理冥。决了无碍。妙信常住。中道纯真。一切妄想。灭尽无余。名曰信心。二，念心。无数劫中。舍身受身。忆念无忘。名曰念心。三，精进心。不杂曰精。无间曰进。进趣真净。名精进心。四，慧心。心精现前。纯以智慧。深入佛法。名曰慧心。五，定心。寂妙常凝。念虑皆忘。慧心明澈。湛然不动。名曰定心。六，不退心。定光发明。进修无懈。明性深入。名不退心。七，护法心。进趣功纯。保持不失。十方如来。气分相接。名护法心。八，回向心。修持妙力。回佛慈光。向佛安住。名回向心。九，戒心。安住净戒。心光常凝。名曰戒心。十，愿心。遍游十方。化导众生。随其所愿。悉得满足。名曰愿心。此十信中。初信为初心。中间八信为住心。第十信为满心。
    十住。又名十解。又名十发趣。以发起大心。趣入妙道也。由信而入。入则能住。一，发心住。以真方便。发十信心。圆成一心。名发心住。二，治地住。以前妙心。履以成地。名治地住。三，修行住。心地涉知。俱得明了。遍修诸行。皆无留碍。名修行住。四，生贵住。冥契妙理。行与佛同。气分感通。成如来种。名生贵住。五，方便具足住。一切种智。具足成就。自行利他。方便不缺。名方便具足住。六，正心住。容貌如佛。心相不异。名正心住。七，不退住。身心增长。无有退缺。名不退住。八，童真住。十身（声闻身。缘觉身。菩萨身。如来身。法身。智身。国土身。业报身。众生身。虚空身。又如来身复具十身。菩提身。愿身。化身。力持身。相好庄严身。威势身。意生身。福德身。法身。智身。）灵相。一时具足。名童真住。九，法王子住。长养圣胎。绍隆佛种。名法王子住。十，灌顶住。表以成人。陈列灌顶。名灌顶住。
    十行者。菩萨经十信十住已成佛子。满足自利。更进修利他之行也。增修善根。滋培长养。故又名十长养。一，随顺众生。自他俱利。名欢喜行。二，饶益众生。使得法利。名饶益行。三，自觉觉他。得无违拒。名无嗔恨行。四，竖遍三际。横周十方。随类示现。转化无穷。名无尽行。五，了达法门。悉无错误。名离痴乱行。六，同异圆融。无差别相。名善现行。七，尘界交现。不相留碍。名无著行。八，无著行成。皆缘般若。六度之中。此为第一。名尊重行。九，妙观慧中。显圆融德。诸佛执持。名善法行。十，体即真如。无漏清净。一真无为。性本然故。名真实行。十回向。回即回转。向即趋向。坚固不动。故又名十金刚。亦名十愿。前之住行。出俗心多。大悲心少。此则济以悲愿。处俗利生。回真向俗。回智向悲。真俗圆融。智悲不二。于修十行后。神通满足。以大悲心救度众生。回转十行之善。向于三处。一，真如实际是所证。二，无上菩提是所求。三，一切众生是所度。以能回之心。及所回善行。向彼万类。圆满万行。等入法界。所谓回因向果。回自向他。回事向理也。一，救护一切众生离众生相回向。化度众生。灭除度相。回无为心。向涅槃路。二，不坏回向。正显中道。归趣本觉。坏其可坏。远离诸离。三，等一切佛回向。本觉之性。湛然常住。能觉之智。齐于佛觉。四，至一切处回向。能觉之智。无处不遍。既证真如。地如佛地。五，无尽功德藏回向。一切世界。一切如来。互相涉入。得无挂碍。六，随顺平等善根回向。于诸佛地。起万行因。依因发挥。取涅槃道。七，随顺等观一切众生回向。十方众生。皆我本性。性圆成就。不失众生。八，真如相回向。离妄曰真。不异曰如。即一切法。离一切相。不即不离。二无所著。九，无缚无著解脱回向。真如既现。智慧明了。互摄圆融。自在无碍。十，等法界无量回向。性海圆成。法界量灭。含摄遍周。其量无外。
    四加行者。暖、顶、忍、世第一，之四善根也。为三贤入初地之准备。于十回向之终。修四寻思四如实观得之（四寻思者。一，名寻思。谓于诸法之中。推求一切名字。皆悉不实。二，事寻思。谓于诸法之中。推求五阴等事。生灭无常。皆悉不实。三，自体假立寻思。谓于诸法能诠名字。及所诠义理中。推求自体。惟是假立名言。皆悉不实。四，差别假立寻思。谓于诸法能诠之中。推求差别。惟是假立名言。皆悉不实。行者观此四法。皆是自心所变。如幻虚假。寻求思察。假有实无。谓之四寻思观。以此推求之观为因。而生印可决定之智。不惟如实了知所取所缘之名等四法。为自性所变。假有实无。且了知印可能取能缘之名等四法。亦为假有实无。谓之四如实观）。暖者。以佛觉用为己心。如火欲然。名为暖地。唯识宗谓之明得定。以初得无漏慧之明相也。顶者。以自心成佛。如登高山。身入虚空。下有微碍。名为顶地。唯识宗谓之明增定。以明相转盛也。忍者。心佛两同。善得中道。如忍事人。非怀非出。名为忍地。唯识宗谓之印顺定。以无所取决定所持。无能取亦顺乐忍也（忍有三品。下品名印忍。印所取无故。中品名乐顺。乐无能取，顺彼修故。上品名印顺。印能取无，顺观彼故。故曰印顺）。世第一者。以前三位。位位递变。谓之世数。中边各别。谓之间量。此位则加行位满。无可递变。边中不立。亦无间量可得。暖位以佛觉为己心。顶位以自心为佛境。忍位则觉于中道。此位迷觉两忘。中边不立。虽未证理。于世间已为最胜。名为世第一。唯识宗谓之无间定。以能取所取。二空双印。从此无间入见道位也。初地见道。名出世间。今是世间最后边际。尚属有漏。但在世间已为第一。若进十圣。极乎妙觉。则为出世间第一。
    十地之名。《准大乘同性经》所说。四乘不同。分列如次。
    声闻乘十地。一，受三归地。初受三归之位。二，信地。信根成就之位。三，信法地。信四谛理之位。四，内凡夫地。修五停心观等之位（五停心观。一，不净观。观境界不净之相。停止贪欲之法。贪著心多者修之。二，慈悲观。观一切有情可怜之相。停止嗔恚之法。嗔心多者修之。三，因缘观。观十二因缘三世相续之理。停止愚痴之法。痴心盛者修之。四，界分别观。分别诸法六界，或十八界，停止我见之法。我见多者修之。五，持息念观。计呼吸数以停止散乱心之法。散心多者修之。或并界分别观于因缘观。而加观佛观。观佛相好以治一切烦恼。业障多者修之）。五，学信戒地。三学（戒定慧）成就之位。六，八人地。见道之位（人者。忍也。八忍。即苦法忍、集法忍、灭法忍、道法忍、苦类忍、集类忍、灭类忍、道类忍）。七，须陀洹地。预流果之位。八，斯陀含地。一来果之位。九，阿那含地。不还果之位。十，阿罗汉地。无学果之位（声闻乘四果。前三果为有学。阿罗汉果为无学。进趣圆满。止息修习。故名无学）。
    缘觉乘十地。一，苦行具足地。修戒行之位。二，自觉甚深十二因缘地。修十二因缘观法之位。三，觉了四圣谛地。修四谛观之位。四，甚深利智地。生甚深无相智之位。五，八圣道地。修八圣道之位（圣者。正也。亦名八正道）六，觉了法界虚空界众生界地。觉了此三界之位。七，证寂灭地。见道之位。八，六通地。得六神通之位（《宗镜录·十五》，明通有五种。一，道通。二，神通。三，依通。四，报通。五，妖通。此其一也。神者。不测之义。通者。无碍之义。一，神足智证通。又名神境通。身如意通。变现不思议境界。游涉往来自在之力也。二，天眼智证通。得色界天眼根。照视无碍。三，天耳智证通。得色界天耳根。听闻无碍。四，他心智证通。知他人之心念。五，宿住随念智证通。知自己及六道众生之宿命。此五通为依有漏禅定。及咒力药力所得。故外道仙人亦能有之。六，漏尽智证通。诸漏断尽。一切无碍。为三乘之极致）。九，彻秘密地。证无学果之位。十，习气渐薄地。侵减习气之位。侵入见思二惑余习之气分而减轻之。盖此位在缘觉乘为极地。在三乘共通十地中。则为第八辟支佛地。见思余习至菩萨地而断。至佛地而尽。故此位仅可云侵减。
    菩萨乘十地。《智度论·四十九》。谓之但菩萨地。一，欢喜地。菩萨初得圣性。破见惑。证二空理。生大欢喜。证遍行真如（遍一切诸法）。离异生性障。成就檀波罗蜜。二，离垢地。异性入同。同性亦灭。证最胜真如（断无边德。于一切法为最胜）。离邪行障。成就戒波罗蜜。三，发光地（有光地）。净极明生。智慧显发。证胜流真如（所流教法。于余法中最胜故）。断暗钝障。成就忍辱波罗密。四，焰慧地（增曜地）。慧性炽盛。明极觉满。证无摄受真如（不为我执所摄取故）断微细烦恼现障。成就精进波罗蜜。五，极难胜地。求同异相。皆不可得。诸佛境界。无能胜者。证类无差别真如（非如眼耳等有类别故）。断下乘涅槃障。成就禅波罗蜜。六，现前地（现在地）。无为真如。性净明露。证无染净真如（本性原来无染故）。断粗相现行障。成就般若波罗蜜。七，远行地（深入地）。尽真如际。证法无差别真如（教法虽多。无差异故）。断细相现行障。成就方便波罗蜜。八，不动地。作无相观。一真如心。证不增减真如（不随染净而有增减故）。断无相中作加行障。成就愿波罗蜜。九，善慧地（善相地）具足十力。发真如用。证智自在真如（以四无量智。起四无碍解。即法无碍解。义无碍解。词无碍解。乐说无碍解）。断利他门中不欲行障。成就力波罗蜜。十，法云地。慈荫妙云。覆涅槃海。具足无边功德。证业自在所依真如（得三业、五通、总持、禅定、四自在故）。断于诸法中未得自在障。成就智波罗蜜。
    佛乘十地。一，甚深难知广明智德地。除细习气。于诸法皆得自在。二，清净身分威严不思议明德地。转正法轮。显深义自在。三，善明月幢宝相海藏地。开说三乘差别之法自在。四，精妙金光功德神通智德地。说八万法降四魔自在。五，火轮威藏明德地。摧异邪法。伏恶行自在。六，虚空内清净无垢焰光开相地。现六神通。示无常事自在。七，广胜法界藏明界地。为诸菩萨显菩提自在。八，最净普觉智藏能净无垢遍无碍智通地。为诸菩萨受记莂自在。九，无边亿庄严回向能照明地。为诸菩萨现方便自在。十，毗卢遮那智海藏地。为诸菩萨能说法自在。佛在果地。本无差别。此十地皆为诸佛境界。非二乘及菩萨之所能行。
    《大般若经》所说十地。则为一，净观地。二，种性地。三，第八地。四，具见地。五，薄地。六，离欲地。七，已办地。八，独觉地。九，菩萨地。十，如来地。《智度论·四十九》以声闻缘觉菩萨共通之十地。为共地。即台宗所立之通教十地也。一，干慧地。欲习初干。未得法性理水之润。故属外凡。二，性地。伏见思惑。见法性空。故属内凡。三，八人地。人者。忍也。见道十五心之位。八忍七智。以八忍赅之也。四，见地。断三界之见惑。见四谛理。即见道十六心之道类智也。五，薄地。断欲界九品思惑中前六品之惑。得真谛理之位也。六，离欲地。断尽欲界后三品思惑。离欲界生死之位也。七，已办地。断尽色无色界思惑。发真无漏之位也。八，辟支佛地。缘觉既断三界见思二惑。更侵减见思惑余习之气分也。九，菩萨地。菩萨从空入假。深观真俗二谛。进断见思习气与尘沙惑。得法眼净。成道相智之位也。十，佛地。菩萨觉行圆满。进趣妙觉之位也。
    菩萨乘十地。已预圣流。但据《法华经疏》。菩萨为化度众生。前三地寄于人天诸乘。中四地寄于出世间三乘。后三地超世出世间。属于佛乘。进修因行以显证果。一，欢喜地。初地菩萨。既修檀那。示现世间以作人王。寄于人乘。二，离垢地。二地菩萨。修十善行。示现欲界。以作天王。寄欲界天乘。三，发光地。三地菩萨修色界四禅，无色界四空处定。行同于四禅四空。寄色无色界天乘。四，焰慧地。四地菩萨。初断见惑。与形俱生身。观三十七道品。同于初果。寄须陀洹乘。五，难胜地。五地菩萨。修四谛行。同于四果。寄阿罗汉乘。六，现前地。六地菩萨。观于因缘。觉悟真空。同于缘觉。寄缘觉乘。七，远行地。七地菩萨。修菩提行。涉入三界。不舍度生。寄菩萨乘。八，不动地。八地菩萨。证阿含德。及不住道。契合实理。离相离言。九，善慧地。九地菩萨。以无量智。观察无边世界。说法教化众生。十，法云地。十地菩萨。法身如云。普覆众生。意业自在。受胜职位。皆超世出世间。寄显一乘。《仁王经》曰。十信为粟散王。十行为铜轮王。十回向为银轮王。初地为金轮王。二地为忉利天王。三地为夜摩天王。四地为兜率天王。五地为化乐天王。六地为他化天王。七地为初禅王。八地为二禅王。九地为三禅王。十地为四禅王。《华严》《璎珞》等经。亦有菩萨寄报天王之说。
    以上十住十行十回向诸位菩萨。虽已断见思惑。尚有无明。未入圣位。故称三贤。名异生性。十地菩萨。与佛体同。则称十圣。名同生性。
    诸经论建立地位。多寡不同。如《法华》《璎珞》等经。以十信、十住、十行、十回向、十地、等觉、妙觉、五十二位为大乘阶位。《仁王经》摄等觉于第十地为五十一位。大品摄十信于发心住为四十二位。华严摄等觉于十地为四十一位。四加行则为由三贤入初地之准备。故曰加行而不列位。《楞严经》则并列干慧地与四加行为五十七位。加三渐次则为六十圣位。《法华玄义》云。三乘之初。同名干慧。即是体发五停心。别相总相。住是观中。修正勤、如意、根、力、觉、道。虽未得暖法相似理水。而总相智慧深利。故曰干慧地。《智度论》释干慧地。有二。一者。声闻为涅槃故。勤精进。持戒清净。堪任受法。集诸善道。舍不善法。虽有智慧。不得禅定水。则不能得道。名干慧地。二者。菩萨从初发心。乃至未得顺忍（五忍中第三。五忍。即伏忍、信忍、顺忍、无生忍、寂灭忍也）者。皆名干慧地。《楞严经·长水疏》云。于干慧心增明观智以为方便。得入十信。亦在信位以前。至十地后。则获金刚心中初干慧地。
    等觉者。大乘阶位五十二位中之第五十一位。与妙觉佛果。仅次一位。菩萨之极位也。自十信、十住、十行、十回向，为地前菩萨。直至初地。历第一阿僧祗劫。自二地至七地。历第二阿僧祗劫。自八地至此位。历第三阿僧祗劫。智慧功德。与诸佛等。故名等觉。望于妙觉。犹有一等。故名等觉。亦名一生补处。亦名金刚心菩萨。亦名无垢地菩萨。
    妙觉为大乘阶位中之极地。自觉觉他。觉行圆满。不可思议。即佛果之无上正觉也。二乘止于自觉。菩萨自觉觉他。未能圆满。独佛二觉圆满。不可思议。故曰妙觉。
    《唯识论》于入道次第。束之为五位。一，资粮位。以十信、十住、十行、十回向之四十位。具修种种福智。资益菩提法身。故名资粮位（资粮有二种。施、戒、忍，三波罗蜜多。是福德资粮。般若波罗蜜多。是智慧资粮。精进波罗蜜多。静虑波罗蜜多。二资粮摄。若为智慧而行精进，是智慧资粮。若为福德而行精进，是福德资粮。若缘无量而修静虑。是福德资粮。余是智慧资粮）。二，加行位。即暖、顶、忍，世第一，之四加行。名加行位。三，通达位（见道位）。从加行入初地之菩萨。以无漏真智。体会真如。智照于理。得见中道。名通达位。四，修习位（修道位）。二地以上乃至等觉菩萨。依无分别智。断分别起二障。依生法二空智。断俱生二障种子及其习气。证得菩提涅槃二转依果。名修习位。五，究竟位。诸漏永尽。清净圆明。得成无上正等正觉。证妙觉果。即佛果极地。谓之大乘五位。摄论则束为四位。一，胜解行位（始十信。终地前）。二，见道位。三，修道位。四，究竟位。至小乘五位。则以修五停心观及别想念总想念者（小乘行人于修五停心观之后。就苦谛而修之四念处观。念是观慧。处者境也。《大般若经》谓之四念住。有别相念处总相念处之二。别相念处者。分所观之境为身、受、心、法，之四者。追顺而别观之。但于第四法念处。分杂缘、不杂缘，之二。不杂缘法念处。惟观法之一境。杂缘法念处。于身受或身等四境合观。盖法尘通于前三也。总相念处者。于杂缘法念处之后念。不分身受等之四者。总合而观诸有为法为无常。观诸有漏法为苦。观一切法为空、无我。故名总相念处。别相与总相。在于前境之分不分。又能观之行相。别相为不净、苦、无常、无我。总相为无常、苦、空、无我）为资粮位。四加行为加行位。断三界见惑。证声闻初果（须陀洹）者。为见道位。修四谛法。断欲界思惑。证声闻二果（斯陀含）三果（阿那含）者。为修道位。断三界见思惑尽。证声闻四果（阿罗汉）者。为无学位。《瑜伽》及《显扬论》。入道次第。复依十三住分立七地。地者。摄持义。住者。受用居止义。一，种姓住（一，本性住种性。谓无始来依附本识。法尔所得无漏法因。二，习所成种性。谓闻法界等流法已。熏习所成）。但有大乘性根。未发无上菩提。十信位也。二，胜解行住。从发心住以至初地菩萨。修习诸行。胜解现前。十住、十行、十回向、四加行，之地前菩萨也。三，极喜住。初地菩萨也。四，增上戒住。二地菩萨也。五，增上心住。三地菩萨也。六，觉分相应增上慧住。四地菩萨也。七，诸谛相应增上慧住。五地菩萨也。八，缘起相应增上慧住。六地菩萨也。九，有加行有功用无相住。七地菩萨也。十，无加行无功用无相住。八地菩萨也。十一，无碍解住。九地菩萨也。十二，最上成满菩萨住。十地菩萨也。并摄等觉。十三，如来住。则妙觉佛果也。此十三住中。种姓住名种性地。胜解行住名胜解行地。极喜住名净胜意乐地。增上戒住。增上心住。及三种增上慧住。有加行有功用无相住。名行正行地。无加行无功用无相住。名决定地。无碍解住。名决定行地。最上成满菩萨住。如来住。名到究竟地。
    修行者。信解行证四法之一。如理修习作行也。通于身语意之三业。《法华经·药草喻品》曰。渐渐修行。皆得道果。《无量寿经》曰。应当信顺。如法修行。

    深。邃也。难见义。诸法空相。难可思议。名为甚深般若波罗蜜多。深般若波罗蜜多。即甚深境界之般若波罗蜜多。能取一切法空相故。人法俱空。色心齐遣。境观两忘。非凡夫二乘所知。菩萨依其能观之慧。行此甚深境界般若波罗蜜多。如《解深密经》说。观自在菩萨。复白佛言。世尊。菩萨以何等波罗蜜多。取一切法无自性性。佛告观自在菩萨曰。善男子。以般若波罗蜜多。取法无自性性。又此般若波罗蜜多。善达空相。名深般若波罗蜜多。修此行故。名行深般若波罗蜜多。《心经赞》云。行谓进行。是能观智。深有二种。一者。即行深。以无分别智。内证二空。离诸分别。无能所行以为行相。故曰行深。《大品》曰。不见行。不见不行。是名菩萨行深般若。二者。境深。谓二空理。离有无相。绝诸戏论。无分别智。证此深境。故曰行深。是知般若之体。约教有二。一，深。二，浅。浅者名人空般若。破除我执。但见于空。不见不空。为声闻、缘觉、菩萨三乘所同修故。亦名共般若。此慧现前。但证偏真。故名为浅。深者名法空般若。既破我执。又破法执。不但见空。又见不空。尽破三惑。永断二死。证入诸法第一义空。为菩萨所独修。非权教三乘所共故。亦名不共般若。此慧若显。能至菩提。故名为深。《大般若经》曰。甚深般若波罗蜜多。无相无状。无言无说。又曰。菩萨摩诃萨行深般若波罗蜜多时。能以离相无漏之心。而行六种波罗蜜多。由离相无漏心力。能于一切无相、无觉无得、无影、无作、法中。圆满六种波罗蜜多。亦能圆满诸余功德。又曰。善现白佛言。如是般若极为甚深。佛言。一切法甚深故。般若波罗蜜多甚深。是故般若波罗蜜多名极甚深。又曰。此法甚深。难见难觉。不可寻思。过寻思境。微妙冲寂。聪敏智者之所能知。非诸世间。卒能信受。谓深般若波罗蜜多。即是如来、应、正等觉所证无上正等菩提。又曰。舍利子。修行般若波罗蜜多时。不见诸法有觉有用。见一切如幻事。如梦境。乃至如变化事。都非实有。闻说诸法本性皆空。深生欢喜。当知是菩萨能行般若波罗蜜多。菩萨摩诃萨。行般若波罗蜜多时。不见菩萨。不见菩萨字。不见般若波罗蜜。不见我行般若波罗蜜。亦不见我不行般若波罗蜜。诚以修行之要。首须遣尽闻思诸慧。澈悟真空。由无所得无分别故。无行无不行。是名为行。是名为行深般若波罗蜜多。
    【注】《连珠记》云。人我执无处所显真如。名人空。法我执无处所显真如。名法空。如为所显。智是能显。二执空无。故名二空。广承云。共般若者。三乘同修。二乘但见于空。不见不空。钝根菩萨亦然。空即偏真。是故为浅。不共般若者。则圆菩萨所修。菩萨不见但空。但见不空空。即中道法界。故名深。菩萨久已入实。将说此经。示为仪式耳。
    三乘共修人空般若。转五蕴成五分法身。一，转色蕴成戒身。二，转受蕴成定身。三，转想蕴成慧身。四，转行蕴成解脱身。五，转识蕴成解脱知见身。大乘菩萨修法空般若。转五蕴成三德。三德者。摩诃涅槃那也。此云大灭度。大者法身。即真如之理。灭者解脱。即自在之用。度者般若。即会真之智。转色蕴成法身德。转受想行三蕴成解脱德。转识蕴成般若德。
    《小钞》云。诸宗抑般若但为空教。恐谓菩萨空观。亦同小乘人空。《贤首略疏》。正明菩萨此观。真空绝相。顿入华严法界。已当八部般若无相大乘之极致。故曰行深般若也。
    第一义空。诸法中最第一法。名为涅槃。涅槃之法。空无有相。是名第一义空。
    离相者。三相之一。一，解脱相。无生死之相也。二，离相。无涅槃之相也。三，灭相。生死涅槃之无相。其无相亦无。即非有非无之中道也。无漏者。离烦恼之法。惑业已断。不漏落于生死也。无相者。诸法悉空。名为无相。《大乘义章》云。言无相者。释有二义。一，就理彰名。绝众相故名无相。二，就涅槃法离十相（色声香味触男女生住灭）。故名无相。无觉者。初心在缘曰觉。觉知心亡。谓之无觉。无得者。体无相之真理。心中无所执著。无所分别之空慧也。无影者。一切受与相续俱灭。名为无影。亦名寂灭。无作者。不假身口意之动作。自然相续之法也。
    法之幽妙为之深。深之极度谓之甚深。甚深为如来所证真如理智境界。非声闻、缘觉之所能知。一，义甚深。如来所证种智。性义微妙。不可思议也。二，实体甚深。如来所证实相理体。不空不有。非如非异。不可思议也。三，内证甚深。如来所证所得一切智慧。甚深无量。不可思议也。四，依止甚深。如来所证真如法体。遍一切处。无染无净。不变不迁。于一切法。不即不离。不可思议也。五，无上甚深。如来所证阿耨多罗三藐三菩提。一切声闻、缘觉所不能思议也。见《法华论》。
    如幻事。如梦境。乃至如变化事者。具说如《大般若经·四百二》曰。若菩萨摩诃萨。欲觉知一切法。如幻。如梦。如响。如像。如光影。如阳焰。如空华。如寻香城。如变化事。唯心所现。性相皆空。当学般若波罗蜜多。

    时有二名。梵语迦罗者。世间实际之时。如云某日某时。三摩耶者。但约时分以名刹那生灭之分位者。非有时之实性。故曰假时此所云时。即三摩耶。谓菩萨行深般若波罗蜜多。证入真空之一刹那时也。菩萨以无分别智。照了五蕴身心。廓然寂灭。性相皆空。即最后一刹那顷证入真空之时。而称体起用。度一切苦厄。亦在一刹那时。由五蕴本空。苦厄斯度。故体用同时也。《大般若经》曰。皆以无性而为自性。用一刹那相应妙慧。证得无上正等菩提。《心地观经》曰。一刹那心般若相应。悟三世法无余。故此时为万缘俱寂。无得无证之时。《顿悟入道要门论》云。问。经云言语道断。心行处灭。其义如何。答。以言显义。得义言绝。义即是空。空即是道。道即是绝言。故云言语道断。实际更不起观。不起观故。即是无生。以无生故。即一切色性空。色性空即万缘俱寂。万缘俱寂。即是心行处灭。又曰。万缘俱寂者。即一切法性空。法性空。即一切处无心是。若得一切处无心时。即无有一相可得。何以故。自性空故。无一相可得。即是实相。实相者。即是如来妙色身相。故此时亦即为一切处无心之时。亦可云无念时。无念者。无邪念。非无正念。正念惟念菩提。菩提假立名字。实不可得。不可得。即无有念。无念之念。是名真念。但知一切处无心。即是无念。得无念时。自然解脱。菩萨行深般若波罗蜜多时。一念不起。境忘心灭。定慧均等。能所双忘。观听圆明。自在无碍之时也。
    【注】无分别智。即无分别心。离一切相。不可分别。体会真如之智也。亦名根本智。若最初一念。闻声见色。得声色自性时。是现量当前。即无分别智照。不属生灭有无。此智才发。分别之心顿泯。当体即是真空。若见真空。名见佛性。若刹那流入意地。起第二念。分别事理。即是生灭心。生灭妄想相续。随他声色流转。即智而成识。若不起分别。境自如如。即识而成智矣。
    刹那者。计时之最小单位。一念中有九十刹那。一弹指顷六十五刹那。
    性相皆空者。性。体也。《大乘义章》云。性有四义。一，种子因本义。二，体义。三，不改义。四，性别义。相者。诸法体状。谓之为相。离一切迷情所见之相。谓之真空。
    无性者。谓四大乃至涅槃等假名。毕竟皆空。悉无实体也。一切众生于世间相。处处计著。执为实有。佛为除此妄执。说一切法皆无自性。曰相无性。一切诸法。皆托因缘和合而生。本无自性。曰生无性。因破众生妄执。假说无性。非性全无。佛说真如胜义之性。远离遍计妄执之性。曰胜义无性。《大般若经·五百四十五》曰。诸法一性。即是无性。诸法无性。即是一性。如是诸法一性无性。是本实性。此本实性。即是一相。所谓无相。
    自性者。一切诸法。各有不变不改之性。是名自性。众生迷惑。不了诸法本空。妄执我身及一切法。周遍计度。执为实有。曰遍计自性。诸法皆以众缘相应而起。却无自性。惟是虚妄。曰依他自性。真如自性。不迁不变。圆满成就。曰圆成自性。
    无生者。远离生灭之真如实相也。
    梵语驮摩。此云法性。法性有二。一，实法性。一实之理。离虚妄相。本性平等。无有变易。一切诸佛。莫不依此法性。修之而成正觉。是名实法性。二，事法性。世间种种诸法。皆依于理。施设建立。所谓地水火风五蕴等法。随俗所知所见。虽属于事。实不外乎法性之理。是名事法性。见《地持经》。
    心行处灭者。《准起信论》说。惟心相灭。非心体灭。如水因风而有动相。以风灭故。动相即灭。非水体灭。
    无念之念。是名真念。真念者。并念亦无。行者莫谓一切时都无所著。即我真心。不知执此无著之心。即是妄想。《楞伽经》曰。无心之心量。我说为心量。故云。三际求心心不有。心不有故妄元无。妄心无处即菩提。生死涅槃本平等。故无念之念亦无。方为无念。《宗镜录·三十七》云。若以有念析归无念。此念还成有。若以无心作空无会者。即成断灭。皆落意地。不出见知。又六十五云。妙湛圆明。寂而常照。故云常在正念。亦名正知。非是有念有知。亦非无念无知。有无皆想。俱非正知。但无念而照。名曰正知。若惟无念。寂而失照。若但照体。照而失寂。并称不正。正在双行（按即寂而常照。照而常寂之意）。《还源集》云。圣人有二种用心。一，不见一切物皆空。惟见于空。不见一切物。二，见一切物即空。了了见一切有。不住于有。了了见一切空。不住于空。双照有无。分别宛然。而无念动。犹如明镜。睹其色像。一切皆于中现。用心亦尔。得其妙性起照。照见一切。了了知无所知。了了见无所见。
    时者。即是有为法上假立分位。或是心上分位影像。依色心等总假立故。是不相应行蕴所摄。


第三项　观行境界

    照见五蕴皆空。
    照者。光明遍照之义。见者。根心触境之用。照见是能观之智。五蕴是所观之境。皆空是观行之果。菩萨以妙慧照见五蕴自性。当体即是真空。与二乘之灭色求空者不同。照字在果即观。在因即吾人最初一念不起分别之现量。空观之功行深。则断见思惑。显一切智。照见真谛。假观之功行深。则断尘沙惑。显道相智。照见俗谛。中观之功行深。则断无明惑。显一切相智。照见中谛。见非眼根及眼识所见。乃现量当前。菩萨以法眼于一切法得法自性。不见纤尘可得。所谓不见色。不见受想行识。非曰不见。见即无见。《楞严经》所谓离一切相，即一切法也。盖由五蕴本空。即是实相。实相无相。故不可见。不可见而见。洞彻法界。非唯不见世间诸法。于出世间一切净戒、禅定、智慧、解脱、解脱知见、无上正等正觉、菩提、涅槃等法悉空。故皆不见。都无所见。名为照见。瞥有少见。即堕妄想无明窟宅。照以达诸法之空。见以证实相之有。空有两忘。是名照见。
    【注】《事观解》云。照见者。观照般若也。因地识强智弱。照属六识。见属八识。兼慧心所。果位智强识弱。照属妙观察智。见属大圆镜智。曰照。曰见。古师或谓从眼根证入。或谓由耳根返观照性。按观世音菩萨六根圆通。明照无二。见闻觉知。不能分隔。成一圆融清净宝觉。一根返源。六根解脱。得自在我者。诸根互用。非如异生之见必以眼也。
    见有五义。一，证见名见。即根本智见分。二，照烛名见。此通根心俱有。三，能缘名见。即通内三分（见分、自证分、证自证分）。俱能缘故。四，念解名见。以念解所诠义理故。五，推度名见。即比量心推度一切见故。本经照见之见。是照烛义。证见义。
    一切智。谓共声闻及独觉智。五蕴、十二处、十八界等差别法门。声闻、独觉亦能了知之智也。道相智。谓共菩萨摩诃萨智。诸菩萨摩诃萨。应学遍知一切道相（声闻道相。独觉道相。菩萨道相。如来道相）。令速圆满。作所应作。而不令其证住实际之智（成熟有情。严净佛土。及修大愿若已圆满。乃于实际可以证住）也。一切相智。谓诸如来应正等觉不共妙智。诸行状相。能表诸法。如来如实能遍觉知。知一切相。皆同一相。谓寂灭相。是故名为一切相智。菩萨摩诃萨。与佛俱住说法无差别性。佛于一切法自相、共相照了无闇。清净具足。名已得一切相智。菩萨尚在因位。名随得一切相智。菩萨于诸道（声闻道、独觉道、菩萨道、如来道）。遍学满已。以胜知见超过八地（净观地乃至独觉地）。由道相智得入菩萨正性离生（菩萨修行般若波罗蜜多时。安住种种法门。起想起著。是为菩萨随顺法爱。即此法爱。说名为生。如宿食生。能为过患。除遣此故。名为离生。菩萨修行般若波罗蜜多时。不见内空乃至无性自性空。作如是观。名入菩萨正性离生）。既入菩萨正性离生位已。复用一切相智。永断一切习气相续。入如来地。尔乃成就一切智智。故经曰。一切智智。略有三种。谓一切智。道相智。一切相智。盖就佛地位言。三智备具。若在二乘。则但得一切智。菩萨但得道相智。深位菩萨。但有随得一切相智。见《大般若经·三百六十九》。四百零九。四百六十二。四百八十四。《止观·三》云。佛智照空。如二乘所见。名一切智。佛智照假。如菩萨所见。名道种智。佛智照空、假、中皆见实相。名一切种智。一切种智。名萨婆若。萨婆若即般若异名。《大智度论》云。五波罗蜜福德入般若波罗蜜中。即得清净般若。般若清净。故得佛道。变名萨婆若。在因位曰般若。在果位即萨婆若。
    法眼者。五眼之一。眼是总名。从用分别。则有五种。一，肉眼。父母气血所成。见近不见远。见前不见后。见内不见外。见昼不见夜。见上不见下。因有色质障碍故。二，天眼。诸天因修禅定而得此眼。远近前后。内外、昼夜、上下。皆悉能见。以无色质障碍故。三，慧眼。二乘之人以所得慧眼。照见真空无相之智慧。四，法眼。菩萨为度众生。以清净法眼。遍观一切诸法。能知能行。因行是法。得证是道。亦知一切众生种种方便门。令修令证。五，佛眼。具前四眼之用。无事不见。无事不知。无事不闻。闻见互用。无所思惟。一切皆见。以上五眼。见《智度论》。《瑜伽师地论》。《华严经离·世间品》。于法眼中开出智眼。于佛眼中开出光明眼。出生死眼。无碍眼。一切智眼。共成十眼。所谓肉眼。见一切色故。天眼。见一切众生心故。慧眼。见一切众生诸根境界故。法眼。见一切法实相故。佛眼。见如来十力故。智眼见诸法故。光明眼见佛光明故。出生死眼。见涅槃故。无碍眼。所见无障故。一切智眼。见普门法界故。
    妙慧为深妙之智慧。《法华经·序品》。佛子心无所著。以此妙慧。求无上道。
    现量者。心识三量之一。详下三量注。
    净戒。即尸罗波罗蜜。心口意三业。离一切过非也。
    禅定。为华梵双举之词。禅具云禅那。亦作驮那演那。旧译思惟修。新译静虑。因静生定。故曰禅定。《大乘义章》云。禅定别名凡七。一，禅。二，定。三，三昧。四，正受。五，三摩地。六，奢摩他。七，解脱。亦名背舍。三摩地亦作三摩钵提。此云等。息虑凝思。制心于一处而不动也。《玄应音义》云。欲入定时。名三摩钵提。正入定时。名三摩半那。奢摩他。此云止。摄心住缘。于染净等境。心不妄动也。《圆觉经》于禅那，与三摩地，及奢摩他，略有次第。《资中》云。奢摩他以寂静为相。三摩地以幻化为相。禅那则俱离静幻二相。孤山谓一止三名。奢摩他。即体真止。止于真谛。为实相之真。三摩地。即方便随缘止。止于俗谛。实相遍一切处。随缘历境。安心不动也。禅那。即息二边分别止。止于中道。生死涅槃静散休息也。《相宗纲要》略云。定有七名。一，三摩呬多。此云等引（旧云三摩提）。通有无心（有心定及无心定）。唯定非散。名等引者。一谓能引于等。故名等引。谓定中身心分位安和平等之时曰等。此等由于定力所引。故名等引。二谓等之所引。故名等引。由前加行入定之时。以定势力。制伏沉掉。即名为等。由此等故。引生在定分位。前之加行名等。今是彼之所引。故名等引。二，三摩地。此云等持（旧云三昧）。谓以平等持心心所。令不散乱。故名等持。惟有心定。通于定散。三，三摩钵底。此云等至（旧云三摩跋提）。通有无心。名等至者。一谓至等。故名等至。谓由定势力。令身心等有安和相。名之谓等。由定势力。能至于等。故名等至。由前加行。制伏沉掉。故名为等。此等已至。故名等至。四，驮那演那（旧云禅那）。此云静虑（静者。定之用。虑者。慧之用）。通摄有无心定、漏、无漏、染、无染。依色四地。定慧平等。故得此名（色界四地。定慧平等。得名静虑。无色界。定胜慧劣。不名静虑）。五，质多翳迦阿羯罗多。此云心一境性。质多。此云心。翳迦。此云一。阿羯罗。此云境。多。此云性也（旧云一心）。即等持之异名。心专一境。依教而缘。证解所缘。心便明净。六，奢摩他。此云止。能止住心。故名曰止。惟是有心净定。不通散位。七，现法乐住。唯在静虑（简四空处），根本（简未至定）。非余。净不通散。从果得名也。此中等引与等至。二者分别。等引通摄一切有无心位诸功德法。较等至为宽。《大乘义章·十》云。修义不同。一门分三。止者。外国名奢摩他。守心住缘。离于散动。故名为止。止心不乱。故复名定。观者。外国名毗婆舍那。于法推求简择名观。观达称慧。舍者。外国名忧毕叉。行心平等。舍离偏执。故名为舍。
    智慧即般若度。真智圆明。观达法性。
    解脱亦为禅那别名。解脱一切系缚之义。梵语目帝罗。旧译背舍。新译作解脱。在因中厌离烦恼名背舍。具足观炼熏修。发真无漏。三界结尽。尔时背舍转名解脱。故在因有漏。则名背舍。在果无漏。则曰解脱。似二译可以并存。解脱有三种。一，空解脱。观一切法。皆从因缘和合而生。自性本空。无我、我所。于诸法得自在。又名空三昧。与苦谛之空、无我二行相应。二，无相解脱。真如性体。圆明寂静。离色、声、香、味、触五法。男、女二相。生、住、灭三有为相。于诸法得自在。又名无相三昧。三，无愿解脱。知一切法无相。则于三界无所愿求。不造作生死之业。即无果报之苦而得自在。又名无愿三昧。无作三昧。无起三昧。就能修之行言之。曰三昧。就无漏之果言之。曰解脱。就所观之理言之。曰三空。如《仁王经》所说。就对治三障言之。曰三治。如《十地经》所说。
    背舍者。背谓违背。舍即弃舍。《智度论》云。背此净洁五欲（净洁五欲。为色界、无色界之五欲。若欲界之色、声、香、味、触粗弊五欲。名为不净五欲）。舍此著心（贪、爱、嗔、痴、欲、慢谓之六著心）。故名背舍。修此观故。发无漏智慧。断三界见思惑尽。证阿罗汉果。即转名八解脱。背舍凡八。一，内有色相，外观色背舍。行者先观自己色身坏烂不净。不可爱乐。更想皮肉脱落。但见白骨。有八色光明。以内骨人未灭。故曰内有色相。又为欲界贪欲难断。虽自观内色不净。复以不净心观外色。令生厌恶。以求断除。故曰外观色。是初背舍位。二，内无色相，外观色背舍。行者入二禅。已灭内身骨人色相。故曰内无色相。为欲界见思未断。犹观外色白骨不净之相。令生厌恶以求断除。故曰外观色。是第二背舍位。三，净背舍，身作证。行者于第二背舍后。除弃外色不净之相。但摄心谛观八色光耀之相。极令明净。住心缘中。泯然入定。见外八色光明。清净皎洁。犹如妙宝之色。故曰净背舍。心既明净。乐渐增长。遍身怡悦。故曰身作证。是第三背舍位。四，虚空背舍。行者于欲界后。已除自身皮肉不净之色。初背舍后。已灭内身白骨之色。二背舍后。又除外身一切不净之色。惟有八种净色。此八种色。皆依心住。若心舍色。色即谢灭。一心缘空。与空相应。即入无边空虚处定。故曰虚空处背舍。是第四背舍位。五，识处背舍。行者如舍虚空处。一心缘识入定时。即观此定。依五蕴等。悉皆无常、苦、空、无我。虚妄不实。心生厌背。故曰识处背舍。是第五背舍位。六，无所有处背舍。行者如舍识处。一心缘无所有处入定时。即观此定。依五蕴等。悉皆无常苦空无我。虚妄不实。心生厌背。故曰无所有处背舍。是第六背舍位。七，非有想非无想处背舍。行者如舍无所有处。一心缘非有想非无想入定时。即观此定。依五蕴等。悉皆无常苦空无我。虚妄不实。心生厌背。故曰非有想非无想背舍。是第七背舍位。八，灭受想背舍。行者厌患此心散乱。欲入定休息。背灭似涅槃法。背灭非想、蕴、界、入，及诸心数法。所谓一受、二想、三行、四触、五思、六欲、七解、八念、九定、十慧。不受非想。一心缘真。绝蕴、界、入。则非想、蕴、入、界、灭。一切诸行因缘悉灭。受灭乃至慧灭。爱、无明等诸烦恼灭。一切心数法灭。一切非心数法亦灭。故曰灭受想背舍。是第八背舍位。此八背舍为禅定之初步。《智度论》云。八背舍为初门。八胜处（一，内有色相外观色少胜处。二，内有色相外观色多胜处。三，内无色相外观色少胜处。四，内无色相外观色多胜处。五，青胜处。六，黄胜处。七，赤胜处。八，白胜处）为中行。遍一切处（青、黄、赤、白、地、水、火、风、空、识之十法。一一周遍于一切处之定）为成就。见《禅波罗蜜次第法门·十》。
    解脱除为禅定之别名外。尚有其本义。即离缚而得自在。解惑业之系缚。脱三界之苦果也。《唯识述记》云。解谓离缚。脱为自在。《华严大疏》云。解脱者。谓作用自在。《传心法要》云。前际无去。今际无住。后际无来。安然端住。任运不拘。方名解脱。涅槃之体。离一切之系缚。故解脱亦为涅槃别称。诸经分类不一。《俱舍论》分为一时解脱与不时解脱。钝根之无学。待胜时入定。得脱烦恼之惑。曰一时解脱。利根之无学。不选时而入定。得脱烦恼之惑。曰不时解脱。《宝性论》分为性净解脱与障尽解脱。性净解脱者。众生本性清净。无系缚染污之相也。障尽解脱者。众生本性。虽然清净。但由无始以来烦恼迷惑。不得显现。必待断尽惑障。始得自在也。《成实论》分为慧解脱与俱解脱。阿罗汉未得灭尽定。唯解脱证涅槃之智慧障者。曰慧解脱。阿罗汉已得灭尽定。同时解脱慧与定之障者。曰俱解脱。《大乘义章》分为心解脱与慧解脱。因此心离于贪爱之缚而得解脱者。曰心解脱。以智慧断除无明惑业之缚而得解脱者。曰慧解脱。《华严经疏》分为有为解脱与无为解脱。有作之戒。依师传授。如法奉持。防非止恶。离诸惑业。曰有为解脱。无作之戒。性本清净。体本无为。虽持戒法。无持犯相。心体既空。罪性亦泯。曰无为解脱。《净名经》以三昧神用。巨细相容。变化于法。自在无碍。名不可思议解脱。《华严经》明一多无碍之法相。曰无碍解脱。
    《华严经随疏演义钞》。明解脱五义。一者。生死不能缚。生死即五蕴起灭轮转之相。菩萨不为生死所缚。二者。境相不能缚。菩萨离去凡情。虽见一切境界。不生贪著。三者。现惑（现前分别之见）不能缚。菩萨既不著所见之境。亦不起能见之心。自不为现前分别之见所缚。四者。有不能缚。有即一切有为之法。皆所见之相也。菩萨所见皆空。而无所著。五者。惑不能缚。惑即无明烦恼。菩萨了妄即真。无明即菩提。无著无不著也。
    解脱知见。知已得解脱之知见也。即后得智。由净戒至解脱知见。由戒生定。由定生慧。由慧得解脱。由解脱而有解脱知见。前三，就因受名。后二，从果得号。由慧断惑。无惑名解脱。出缠破障。反照观心。名解脱知见。五者皆为佛之功德。故小乘以之为三身中之法身。
    无上正等正觉。及菩提，涅槃。详后注。
    五蕴者。色受想行识也。梵语塞健陀。旧译作阴。亦作众。新译作蕴。阴者。盖覆之义。妄相烦恼。盖覆真性也。众者。众多和集之义。蕴者。积聚之义。谓众生由此五法。积聚成身。复由此身积聚无量尘劳烦恼。而受无量生死轮回之苦也。五蕴中受想行识四者。无形体可见。但以名知之。故谓为名。色蕴为极微所成有质碍之物体。故谓为色。总之曰名色。即五蕴也。此五蕴中。色为色法。受想行识四者为心法。故别于色蕴而言。谓之非色四蕴。
    五蕴诸法。如幻如化。从因缘生。本无实性。故《大般若经》佛告善现。《大庄严经》佛为瓶沙王说喻。皆云色如聚沬。受如水泡。想如阳焰。行如芭蕉。识如幻事。菩萨以般若妙智观此五蕴。色从四大假合而有。受想行识。由妄想境界而生。四大、妄想。本无自性。当体即空。故曰皆空。非谓寂然灭无为空。亦非有法能令彼空。以彼本自空故。众生不了水月空花。故执五蕴幻有之色。而迷自性真空。夫真空、幻有。体非有二。以妄心分别。则见五蕴而遗真空。以般若观照。则显真空而亡五蕴。盖真空即实相。实相即真如。即幻明空。实相自显。真如常在。幻有都灭。幻有灭尽。五蕴皆空。《大般若经》曰。是诸愚夫。执诸法异本性空已。不如实知色。不如实知受想行识。由不知故。便执著色。执著受想行识。由执著故。便于色计我、我所。于受想行识。计我、我所。由妄计故。著内外物受后身色受想行识。由此不能解脱诸趣生、老、病、死、愁忧苦恼。往来三有。轮转无穷。又曰。菩萨摩诃萨修行般若波罗蜜多时应以本性空观一切法。作此观时。于一切法。心无行处。是名菩萨摩诃萨无所摄受三摩地。又曰。一切法。非法，非非法。诸取相者皆是烦恼。菩萨照见五蕴皆空。即一切法心无行处境界。
    【注】《大般若经·四百七十一》曰。佛告善现。若菩萨摩诃萨，行深般若波罗蜜多时。如实知色乃至识。若相。若生灭。若真如。是名能学色乃至识。善现。云何菩萨摩诃萨，行深般若波罗蜜多时。如实知色相。谓菩萨摩诃萨，行深般若波罗蜜多时。如实知色。毕竟有孔。毕竟有隙。譬如聚沫。性不坚固。是名菩萨摩诃萨，行深般若波罗蜜多时。如实知色相。善现。云何菩萨摩诃萨，行深般若波罗蜜多时。如实知色生灭。谓菩萨摩诃萨，行深般若波罗蜜多时。如实知色。生时无所从来。灭时无所至去。虽无来无去。而生灭相应。是名菩萨摩诃萨，行深般若波罗蜜多时。如实知色生灭。善现。云何菩萨摩诃萨，行深般若波罗蜜多时。如实知色真如。谓菩萨摩诃萨，行深般若波罗蜜多时。如实知色真如。无生。无灭。无来。无去。无染。无净。无增。无减。常如其性。不虚妄。不变易。故名真如。是名菩萨摩诃萨，行深般若波罗蜜多时。如实知色真如。善现。云何菩萨摩诃萨，行深般若波罗蜜多时。如实知受相。谓菩萨摩诃萨。行深般若波罗蜜多时。如实知受。毕竟如痈。毕竟如箭。速起。速灭。犹若浮泡。虚伪不住。三和合起。是名菩萨摩诃萨，如实知受相。善现。云何菩萨摩诃萨，行深般若波罗蜜多时。如实知受生灭。谓菩萨摩诃萨，行深般若波罗蜜多时。如实知受。生时无所从来。灭时无所至去。虽无来无去。而生灭相应。是名菩萨摩诃萨，行深般若波罗蜜多时。如实知受生灭。善现。云何菩萨摩诃萨，行深般若波罗蜜多时。如实知受真如。谓菩萨摩诃萨，行深般若波罗蜜多时。如实知受真如。无生。无灭。无来。无去。无染。无净。无增。无减。常如其性。不虚妄。不变易。故名真如。是名菩萨摩诃萨，行深般若波罗蜜多时。如实知受真如。善现。云何菩萨摩诃萨，行深般若波罗蜜多时。如实知想相。谓菩萨摩诃萨，行深般若波罗蜜多时。如实知想如阳焰。水不可得。渴爱因缘。妄起此想。发假言说。是名菩萨摩诃萨，行深般若波罗蜜多时。如实知想相。善现。云何菩萨摩诃萨，行深般若波罗蜜多时。如实知想生灭。谓菩萨摩诃萨，行深般若波罗蜜多时。如实知想。生时无所从来。灭时无所至去。虽无来无去。而生灭相应。是名菩萨摩诃萨，行深般若波罗蜜多时。如实知想生灭。善现。云何菩萨摩诃萨，行深般若波罗蜜多时。如实知想真如。谓菩萨摩诃萨，行深般若波罗蜜多时。如实知想真如。无生。无灭。无来。无去。无染。无净。无增。无减。常如其性。不虚妄。不变易。故名真如。是名菩萨摩诃萨。如实知想真如。善现。云何菩萨摩诃萨。行深般若波罗蜜多时。如实知行相。谓菩萨摩诃萨，行深般若波罗蜜多时。如实知行如芭蕉树。叶叶析除。实不可得。是名菩萨摩诃萨，行深般若波罗蜜多时。如实知行相。善现。云何菩萨摩诃萨，行深般若波罗蜜多时。如实知行生灭。谓菩萨摩诃萨，行深般若波罗蜜多时。如实知行。生时无所从来。灭时无所至去。虽无来无去。而生灭相应。是名菩萨摩诃萨，行深般若波罗蜜多时。如实知行生灭。善现。云何菩萨摩诃萨，行深般若波罗蜜多时。如实知行真如。谓菩萨摩诃萨，行深般若波罗蜜多时。如实知行真如。无生。无灭。无来。无去。无染。无净。无增。无减。常如其性。不虚妄。不变易。故名真如。是名菩萨摩诃萨，行深般若波罗蜜多时。如实知行真如。善现。云何菩萨摩诃萨，行深般若波罗蜜多时。如实知识相。谓菩萨摩诃萨，行深般若波罗蜜多时。如实知识。如诸幻事。众缘和合。假施设有。实不可得。谓如幻师。或彼弟子。于四衢道。幻作四军。所谓象军。马军。车军。步军。或复幻作诸余色类。相虽似有。而无其实。识亦如是。实不可得。是名菩萨摩诃萨，行深般若波罗蜜多时。如实知识相。善现。云何菩萨摩诃萨，行深般若波罗蜜多时。如实知识生灭。谓菩萨摩诃萨，行深般若波罗蜜多时。如实知识。生时无所从来。灭时无所至去。虽无来无去。而生灭相应。是名菩萨摩诃萨，行深般若波罗蜜多时。如实知识生灭。善现。云何菩萨摩诃萨，行深般若波罗蜜多时。如实知识真如。谓菩萨摩诃萨，行深般若波罗蜜多时。如实知识真如。无生。无灭。无来。无去。无染。无净。无增。无减。常如其性。不虚妄。不变易。故名真如。是名菩萨摩诃萨，行深般若波罗蜜多时。如实知识真如。
    善现。即须菩提之译名。梵语须菩提。此云善现。亦作善吉。善业。空生。佛十大弟子中解空第一，得无诤三昧。
    《大庄严经》。具云《方广大庄严经》。唐地婆诃罗译。凡十二卷。二十七品。与《普曜经》同本。而品有开合。
    色如聚沫。色即众生色身。沫即水沫。谓沫因风吹水成聚。虚有相状。体本不实。以譬众生色身。亦如聚沫。虚假不实也。受如水泡。谓水因风动，或为物击。忽尔成泡。须臾即没。以譬众生所受苦乐。亦如水泡。起灭无常也。想如阳焰。谓远望旷野。日光发焰如水。渴者思饮。终不可得。以譬众生妄想。本无实体。因念成想。终为虚妄也。行如芭蕉。谓芭蕉危脆。中无坚实。以譬众生造作诸行亦如是也。识如幻事。谓如幻巾为马。幻木为人。幻术所成。本无实体。以譬众生识心分别诸法。随境生灭。如幻无实也。《宗镜录》云。四大既空。五蕴无主。是以先观色阴。从四大所造。展转相因而生。四大中既无主宰。谁能合集以成色乎。以此观之。色阴即空。色阴既空。四阴何有。以般若照见五蕴皆空。聚沫之色既虚。水泡之受何有。阳焰之想非实。芭蕉之行惟空。幻识倏尔无依。空大湛然不动。
    五蕴之法从因缘生。因缘即是众生妄心计度。于妄想中立因缘性。虚妄不实。故《楞严经》说五蕴虚妄。本非因缘非自然性。即空五蕴义。

    自来释五蕴者。性相二宗。立说不同。性宗又分二说。清凉以身、心为五蕴。身则色蕴。地水火风是。心则四蕴。受想行识是。故云。五蕴者。身心之异名。永嘉以一念为五蕴。谓秽污真性即色蕴。领纳在心即受蕴。心缘此理即想蕴。行用此理即行蕴。历历分明即识蕴。此五蕴者。举体即是一念。一念者。举体全是五蕴。与《楞严经》色阴为坚固妄想。受阴为虚明妄想。想阴为融通妄想。行阴为幽隐妄想。识阴为颠倒微细精想之说。可以互相发明。相宗则以大乘百法中有为法为五蕴。即色法十一为色蕴。遍行法之受心所为受蕴。想心所为想蕴。余心所四十九，不相应行二十四，为行蕴。八识心王为识蕴。约小乘七十五法言。则以其中七十二有为法为五蕴。无论大乘百法。小乘七十五法。均不摄无为法者。因蕴为积集性。无为法非积集。故不摄也。《俱舍论》云。蕴不摄无为。义不相应故。
    【注】性相二宗。为佛教二大学派。如来在世。应机说法。或有或空。本皆一味。文殊弥勒。各随所闻，结集经论。及至马鸣。龙树。与无著。天亲。分谈性相。亦无宗派。千余年后。南印度健至国中。有清辨、护法二菩萨。同时出世。清辨依般若诸经。创立性宗。谓一切法皆悉是空。无生。无灭。本来寂静。自性涅槃。故《金刚经》曰。一切有为法。如梦幻泡影，如露，亦如电。应作如是观。《思益经》曰。以心分别。诸法皆邪。不以心分别。诸法皆正。《中论》云。若有不空法。应当即有空。不空尚不得。何况得于空。又云。诸佛或说我。或时说非我。诸法实相中。非我非非我。《大乘掌珍论》云。真性有为空。如幻缘生故。无为无有实。不起如空华。为此宗要义。传入我国。衍为三论天台诸宗。护法依《解深密》诸经。创立相宗。谓一切法通有及无。即以遍计所执性。为情有理无。依他起性。为因缘假有。圆成实性。为理有情无。故《解深密经》曰。依所执故。说一切法皆无自性。《瑜伽论》云。依所执性故。《契经》说。一切诸法。皆无自性。《辩中边论》云。虚妄分别有。于此二都无。此中唯有空。于彼亦有此。故说一切法。非空非不空。有无及有故。是故契中道。为此宗要义。传入我国。衍为唯识等宗。西藏修习般若者。分广般若、深般若二派。广般若即相宗。无著菩萨祖述，弥勒菩萨所传也。深般若即性宗。龙树菩萨祖述，文殊菩萨所传也。文殊以下有二支派。一，名言派。二，一切法无自性派。

    窥基师《心经幽赞》、靖迈师《心经疏》所引经文。于照见五蕴下有一等字。按之各本译文则否。窥基、靖迈二师。殆以五蕴以外尚有处界谛缘等。故加一等字以总摄之。惟诸法不外色、心。开之为百法。合之则五蕴已足包含一切。
    按梵语心经。及由藏文转译各本。与唐梵翻对字音心经。此句五蕴下。尚有自性二字。由梵译汉者。般若共利言本作五蕴性空。法成本作五蕴体性皆空。法月、智慧轮、施护各本。作五蕴自性皆空。夫一切法自性皆空。但言五蕴。不说自性。义亦无阙。故什师、奘师、净师三译略之。但为初机修学便利。以有自性二字为备。兹依别译阐释如次。
    诸法各自有不迁不变之性。谓之自性。但诸法非常，非灭。性本自空。故一切法皆无自性。《大般若经》。佛告善勇猛。无少法性是圆成实。一切皆是世俗假立。非于此中有少自性。无自性故。皆非实有。诸法皆以无性为性。是故诸法无实无生。又曰。色自性空。不由空故。受想行识自性空。不由空故。又曰。色色自性空。受想行识。受想行识自性空。是色自性。即非自性。受想行识自性。亦非自性。若非自性。即是般若波罗蜜多。又曰。色蕴自性离色蕴。受想行识蕴自性离受想行识蕴。此离自性。是谓般若波罗蜜多。即本经五蕴自性皆空义。
    性本自空。故一切法皆无自性者。即以无性为自性也。如《大般若经》曰。菩萨摩诃萨修行般若波罗蜜多时。于一切法不取有。不取非有。不取亦有亦非有。不取非有非非有。于不取亦不取（中略）由一切法自性不可得。何以故。以一切法以无性为自性故。又曰。甚深般若波罗蜜多中。色无所有。受想行识无所有（中略）。何以故。以一切法自性空故。又曰。于此般若波罗蜜多甚深经中。色自性无所有。不可得。受想行识自性无所有。不可得。又曰。一切法皆以空为自性。一切法皆以无相为自性。一切法皆以无愿为自性。由是因缘。诸菩萨摩诃萨。应知一切法皆以无性为自性。大经所说。益足显示蕴空真义。夫能洞达五蕴自性空无所起。故当体即是真如。
    【注】一切法者。总赅诸法之称。《智度论·二》云。一切法。略说有三种。一者。有为法。二者。无为法。三者。不可说法。此三已摄一切法。
    体常不变。故名自性。见《佛地经论·七》，惟识宗立三自性。谓众生迷惑。不了诸法本空。妄于我身及一切法。周遍计度。一一执为实有。曰遍计自性。所有诸法。皆依众缘相应而起。都无自性。唯是虚妄。曰依他自性。真如自性。不迁不变。圆满成就。曰圆成自性。见《显扬论》。
    性者。体也。无性。即一切诸法皆无实体之义。唯识宗立三无性。谓众生于世间相。处处计著执为实有。佛为除此妄执。说一切法皆无自性。曰相无性。谓一切诸法皆托因缘和合而生，曰生无性，谓相无性。生无性。因破众生妄执之情。假说无性。非性全无。远离遍计妄执。真如胜义之性。曰胜义无性。见《成唯识论》。

    皆者。俱也。同也。多数同一之义。盖总括之词。
    空者。梵语舜若多。湛然清静。廓尔虚明之义。因缘所生之法。皆无自性。毕竟皆空。《净名经》曰。诸法究竟无所有。是空义。肇注云。小乘观法缘起。内无真主为空义。虽能观空。于空见未能都泯。故不究竟。大乘在有不有。在空不空。理无不极。所以为究竟空。《大乘义章》云。空者。就理彰名。理寂名空。又云。绝众相故名为空。综合诸经论所说。为赴一时之机。因病与药。语各不同。约其要恉。可分四义。一者。空无义。世间诸法。无论有情非情。总由因缘而生。凡因缘所生之法。自体不实。故谓之空。《中论偈》云。因缘所生法。我说即是空。《智度论》云。因缘生法。是名空相。见一切诸法。从因缘生。无有自性。无自性故空。空故诸见灭。此为无常、苦、空，之空。二者。虚空义。空。显色也。虽无粗相之身。亦有微妙之色。《智度论》云。如虚空者。但有名而无实法。虚空非可见法。远视故眼光转见缥色。诸法亦如是。空无所有。三者。心空义。菩萨心上不著一物。无冤亲。无贪嗔。无胜负。无人我。无妄想分别。一切俱舍。妙湛圆寂。万境俱空。境空由于心空。心空则五蕴自空。六根、六尘、十八界、十二因缘、四谛等皆空。所谓心空境自空也。四者。法空。以空为诸法皆空之实相。即真如也。《起信论》云。所言空者。从本已来。一切染法不相应故。谓离一切法差别之相。以无虚妄心念故。当知真如自性。非有相。非无相。非非有相。非非无相。非有无俱相。非一相。非异相。非非一相。非非异相。非一异俱相。乃至总说依一切众生。以有妄心。念念分别。皆不相应。故说为空。若离妄心。实无可空故。《涅槃经》曰。佛性名第一义空。《智度论》云。能使诸法实相空。名为第一义空。《三藏法数》云。诸法中最第一法。名为涅槃。涅槃之法。空无有相。是为第一义空。夫佛性为不生不灭之真体。故名真如。实者非妄。相者无相。故名实相。实相又名涅槃。故佛性、实相、真如、涅槃。皆为空之异名。照见五蕴皆空。是心空义。法空义。
    《大般若经》曰。菩萨修行般若波罗蜜多。以无所得为方便。观一切法自相皆空。其心安住。名空解脱门。亦名空三摩地。观一切法自相空故。皆无有相。其心安住。名无相解脱门。亦名无相三摩地。观一切法自相空故。皆无所愿。其心安住。名无愿解脱门。亦名无愿三摩地。观即照见。惟观一切法自相皆空。故照见五蕴皆空。皆空者。谓一一蕴人法二空也。生死之本。莫过人法二执。迷身心总相。故计人我为实有。迷五蕴自相。故计法我为实有。菩萨照见五蕴和合。假名为人。一一谛观。但见五蕴。求人我相总不可得。先观色蕴。即是观身。了知坚则地。润则水。暖则火。动则风。观余四蕴。则是观心。了知领纳为受。取相为想。造作为行。了别为识。依此身、心谛观分明。求人我相终不可得。名为人空。若观一一蕴。皆从缘生。都无自性。求蕴相不可得。则五蕴皆空。名为法空。是以照五蕴而二空理现。此清凉之说也。谓五阴举体即是一念。一念举体全是五阴。历历见在一念之中。无有主宰。即人空慧。见五蕴皆如幻化。即法空慧。此永嘉之说也。唯识宗按三性说五蕴。即遍计所执五蕴。依他起性五蕴。圆成实性五蕴。三性五蕴。一一皆有人法二空。即遍计所执本体。非有相。无自性。所以名空。依他体性。色如聚沫。受喻浮泡。想同阳焰。行类芭蕉。识犹幻事。生无自性。故亦名空。圆成实性。因观所执空无方证或无如彼所执真性。故真胜义。亦名为空。而此宗护法。则以为三性非空非不空。为破有执。但遣所执。总名为空。非后二性尽遣。然后名空。二者广狭不同。然于五蕴皆空之义。则一致也。
    【注】凡因缘所生之法。究竟无实体。故谓之空。《净名经》曰。诸法究竟无所有。是空义。肇注云。小乘观法之缘起。内无真主为空义。虽能观空。而于空未能都泯。故不究竟。大乘在有不有。在空不空。理无不极。所以为究竟空义。
    《幽赞》云。此空者。即真如理。性非空有。因空所显。遮执为有。故假名空。愚夫不知。执五蕴等。定离真有。起相分别。今推归本体即真如事离于理。无别性故。
    诸经说空。立名不同，略举之如左。
    一空。一切诸法。皆无自性。若色若心。若依若正。乃至圣凡因果之法，虽种种不同。求其体性。毕竟皆空。见《寂调音所问经》。
    二空。一，人空。即我空也。亦曰生空。凡夫妄计五蕴是我。强立主宰。引生烦恼。造种种业。佛为破此执故。说五蕴无我。二乘悟之。入无我理。是名人空。二，法空。二乘未达法空之理。犹计五蕴之法为实有。佛为破此执故。说般若深慧。彻见五蕴自性皆空。菩萨悟之入法空理。是名法空。见《唯识论》。又一，但空。二乘之人观一切虚幻。但见于空。不见不空。二，不但空。诸菩萨不但见空。兼见不空。即成中道。见《止观》。
    三空。一，我空。于五蕴之法。强立主宰。名为我执。若推求色受想行识之五法。皆为假名。并无自性。一切烦恼。皆由著我。则于我无著。证入空无我理。即断见惑。离烦恼障。得我空无分别慧。二，法空。计五蕴法为实有。名为法执。若了所知结。皆由著法。破五蕴实法之执。即断思惑。进而破涅槃净法。即断无明。于法无著。证法空无我理。离所知障。得法空无分别慧。成法解脱。三，俱空。我法二执俱遣。所空既尽。能空亦灭。空执两忘。证二空空无我理。成平等空。得俱空无分别慧。见《金刚经刊定记》。蕅益大师曰。俱空实不生。非人法灭而俱空生。一切法不生。不生亦不生。心无所起。即名无生法忍。空、无相、无愿之三解脱门。亦名三空。见《大乘义章·二》。
    四空。一，法相空。言有法之空。二，无法空。言无法之空。三，自法空。言自性之空。四，他法空。言他法之空。见《大乘义章·二》。
    六空。一，果报空。五蕴空是。二，受用空。十二处空是。三，性别空。十八界空是。四，遍到空。六大空是。五，境空。四谛空是。六，义空。十二因缘空是。见《天台仁王经疏》。
    七空。一，相空。谓一切诸法性中。自、他、共、离之相皆空（如动一念。心从根生。即自性。从尘生。即他性。根尘合生。即共性。离根尘生。即离性。于此四性之相。皆不执著。故曰皆空）。二，性自性空。谓于当念。观一切所生之法。悉由因缘和合而成。本无自生之性。三，行空。谓五蕴之身。本无有我（执五蕴身。强立主宰。谓之我）。亦无我所（五蕴之身）。众生不了。执蕴成我。从我起行。若顺性推求则五蕴之法。了不可得。四，无行空。谓不离前所作行而能了达诸蕴。展转缘起。无有自性可得。亦无所作之行。五，一切法离言说空。谓一切法皆自妄想而成。本无自性。离诸言说故。六，第一义圣智大空。谓佛自觉圣智（佛所证第一义心）。能空一切见过（一切见惑之过失）之习气（余习之气分）。所空既空。能空亦空。七，彼彼空。谓彼外道所计之空。但能空于境。不能空于心。空于彼。不能空于此。如空舍之空。舍体非空。是为假空。见《入楞伽经·一》。又一，性空。二，自相空。三，诸法空。四，不可得空。五，无法空。六，有法空。七，无法有法空。见《智度论·三十六》。
    十一空。一，内空。二，外空。三，内外空。四，有为空。五，无为空。六，无始空。七，性空。八，无所有空。九，第一义空。十，空空。十一，大空。见《涅槃经·十六》。
    十三空。于上十一空中加波罗蜜空，因空，佛果空。而除无所有空。见《仁王经》。
    十四空。一，内空。二，外空。三，内外空。四，大空。五，空空。六，真实空。七，有为空。八，无为空。九，毕竟空。十，无前后空。十一，不舍离空。十二，佛性空。十三，自性空。十四，一切法空。见《十八空论》。
    十六空。一，内空。二，外空。三，内外空。四，空空。五，大空。六，胜义空。七，有为空。八，无为空。九，毕竟空。十，无际空。十一，无散空。十二，本性空。十三，相空。十四，一切法空。十五，无性空。十六，无性自性空。见《大般若经·四百八十三》。
    十八空。一，内空。二，外空。三，内外空。四，空空。五，大空。六，胜义空。七，有为空。八，无为空。九，毕竟空。十，无际空。十一，散无散空。十二，本性空。十三，自共相空。十四，一切法空。十五，不可得空。十六，无性空。十七，自性空。十八，无性自性空。见《大般若经·四百二十二》。又一，内空。二，外空。三，内外空。四，空空。五，大空。六，胜义空。七，有为空。八，无为空。九，无际空。十，无变异空。十一，无始空。十二，本性空。十三，自相空。十四，无相空。十五，无性空。十六，自性空。十七，无性自性空。十八，一切法空。见《帝释般若波罗蜜多心经》。又一，内空。二，外空。三，内外空。四，空空。五，大空。六，第一义空。七，有为空。八，无为空。九，毕竟空。十，无始空。十一，散空。十二，性空。十三，自相空。十四，诸法空。十五，不可得空。十六，无法空。十七，有法空。十八，无法有法空。见《智度论四十六》。又一，内空。亦名受者空。二，外空。亦名所受空。三，内外空。谓身空也。四，大空。五，空空。六，真实空。谓真境空也。七，有为空。八，无为空。九，毕竟空。十，无前后空。亦名无始空。十一，不舍离空。十二，佛性空。十三，自相空。十四，一切法空。十五，无法空。十六，有法空。十七，无法有法空。十八，不可得空。见《十八空论》。
    二十空。一，内空。二，外空。三，内外空。四，空空。五，大空。六，胜义空。七，有为空。八，无为空。九，毕竟空。十，无际空。十一，散空。十二，无变异空。十三，本性空。十四，自相空。十五，共相空。十六，一切法空。十七，不可得空。十八，无性空。十九，自性空。二十，无性自性空。见《大般若经·五十一》。
    自十一空至二十空。各经大同小异。《准大般若经》说。内空者。内谓内法。眼耳鼻舌身意六根。皆无自性。非常非坏。故名内空。外空者。外谓外法。色声香味触法六尘。皆无自相。非常非坏。故名外空。内外空者。内六处。外六处。根尘皆无自性自相。内六处由外六处空。外六处由内六处空。非常非坏。故名内外空。空空者。一切法非常非坏。即空亦空。故名空空。大空者。大谓十方。东南西北四维、上、下皆空。非常非坏。故名大空。胜义空。即第一义空。涅槃非常非坏。本来空寂。故名胜义空。有为空者。欲界，色界，无色界，烦恼惑业。非常非坏。本无有为之相。故名有为空。无为空者。生、住、异、灭。诸相皆空。无为寂静。非常非坏。故名无为空。毕竟空者。欲求有为无为诸法之相。悉皆空寂而不可得。非常非坏。故名毕竟空。无际空者。诸法起灭无初、中、后际，及往来际可得。非常非坏。故名无际空。散空者。散谓有放，有弃，有舍，可得。诸法因缘和合。无和合相。非常非坏。故名散空。无变异空者。无放，无弃，无舍，可得。不变不异。非常非坏。法性如如。故名无变异空。本性空者。有为无为诸法。本性清净。非声闻、独觉、菩萨、如来所作。亦非余所作。离性离相。非常非坏。故名本性空。自相空者。谓一切法自相。如变碍是色自相。领纳是受自相。取像是想自相。造作是行自相。了别是识自相。如是等若有为法自相。若无为法自相。悉皆虚幻不实。非常非坏。故名自相空。共相空者。谓一切法共相。如苦是有漏法共相。无常是有为法共相。无我是一切法共相。如是等无量共相。本来空寂。非常非坏。故名共相空。一切法空者。谓五蕴、十二处、十八界、若色、无色。见、无见。对、无对。漏、无漏。为、无为。诸法。本性皆空。非常非坏。故名一切法空。不可得空者。一切法不可得。过去、未来、现在不可得。过去，无未来，现在可得。未来、无过去、现在可得。现在，无过去，未来可得。三世诸法。皆无所有。非常非坏。了无可求之相。故名不可得空。无性空者。诸法如幻。皆无实性可得。非常非坏。故名无性空。自性空者。谓诸法能和合自性。非常非坏。自无实性。故名自性空。无性自性空者。谓诸法无能和合性。有所和合自性。非常非坏。故名无性自性空。三藏法数则以无性空为即小空。谓须陀洹、斯陀含、阿那含、阿罗汉，四果之相皆空也。《智度论》解释十八空义则小异。内空。谓内身三十六种（外相不净十二：毛、发、爪、齿、眵、泪、涎、唾、屎、尿、垢、汗。内性不净十二：皮、肤、血、肉、筋、脉、骨、髓、肪、膏、脑、膜。通于相性者十二：肝、胆、肠、胃、脾、肾、心、肺、生脏、熟脏、赤痰、白痰）不净充满。九孔（两眼、两耳、两鼻孔、口、及谷道、尿道）常流。净相不可得故。外空。谓外即外身。愚夫观所著色。妄以为净。亦如内身净相不可得故。内外空。谓我身不净。外亦如是。外身不净。我亦如是。求其净相不可得故。空空者。谓内身、外身、内外身皆空。而犹执空成病。复以空法而破三空也。大空者。谓十方世界。是四大造色。假名日出处为东方。日没处为西方。如是方相。以世俗故有。若第一义中则一法不可得也。第一义空者。诸法中。最第一法。名为涅槃。涅槃之法。空无有相。有为空者。谓五蕴等法。无我、我所及常相。皆不可得故。无为空者。谓无所作为。则非有相。今对有为。故说无为。有为法既不可得。无为之法。更何所著。毕竟空者。谓以前八空。破一切法无余。既无诸法。空亦无著也。无始空者。谓世间众生。无有始相。如今生从前世因缘有。前世又从前世有。如是展转。无始亦不可得故。散空者。谓五蕴和合。故有人相。散此五蕴。空无所有。如辐、辋、辕、毂。众合为车。众材离散。则失车名也。性空者。谓一切诸法。自性本空。皆从因缘和合而生。若不和合。则无是法。如是诸法。性不可得也。自相空者。谓一切法有二种相。一者。总相。生灭不住。本无今有。已有还无。皆是无常。二者。别相。如地有坚相。水有湿相。火有热相。风有动相。如是二相皆空也。诸法空者。谓五蕴、十二处、十八界等法。无有实相。一切皆空。无取无舍。离一切诸见也。不可得空者。谓一切诸法及因缘（六根为因。六尘为缘）。毕竟皆空。不可得故。无法空者。谓诸法已灭。是灭亦无也。又谓过去、未来法。名为无法。如是无法亦空也。有法空者。谓诸法从因缘和合。故有法生。法体本不实也。又谓现在一切法。及无为法。名为有法。如是有法皆空也。无法有法空者。谓无法有法相。不可得故。又谓过去、未来、现在一切法。不可得故。
《楞伽经》云。刹尼迦者。名之为空。或呿提。秦云虚空。《圆觉经钞》云。梵云舜若。此云空。空无之空也。舜若多。此云空性。即是空所显性。故舜若。断灭空也。舜若多。真性空也。


第四项 修证功能

    度一切苦厄。
    度者。超越义。渡也。过也。济度自他。超拔众苦也。
    一者。数之始。究竟非二。切者。尽际义。梵语娑娑。此云一切。普遍义。赅罗全体。包含无余之意。又平等性义。凡所包含。悉无差别。
    苦。梵语豆佉卢。逼恼义。世出世间一切有为心行。常为无常患累逼迫。不能自适。故名为苦。厄者。困也。本经所用苦厄二字。义相连贯。故下文但云。能除一切苦。不及厄字。诸经言苦。有二苦、三苦、四苦、五苦、八苦、十九苦、百苦、百一十苦种种。皆由惑业而起。菩萨朗照五蕴。澈见真空。惑业既消。苦恼同尽。
    【注】从来解释苦厄二字。分三义。一，持业释。苦即厄也。二，依主释。苦之厄也。三，相违释。苦与厄也。此从持业释（诸法以二义以上为名者。以六种法式。分别其名义。初，离释二义。后，合释二义。故谓之六离合释。略称曰六合释。梵语杀三摩娑。杀，此云六。三摩娑，此云合也。一，持业释。体能持用。谓之持业。此义虽二。而体则一之名也。如说藏识。识是体。藏是业用。用能显体。体能持业。藏即识故。亦名同依释。藏取含藏用。识依了别用。同一所依之法体故。二，依主释。亦名依士释。从所依之体。而立能依之法之名也。如说眼识。为依眼而生之识。眼为所依之体。识为能依之法也。三，有财释。亦名多财释。全取他名而为自名。如说唯识论。为有唯识之理之论也。四，相违释。二体所诠。各别自主。不相随顺。而合之为一名。如说教观。教与观各有独立之义。而合为一名也。五，邻近释。从近为名。如四念住。以慧为体。而与之相应而起之念力特强。故从近而名念住也。六，带数释。以数显义。如五蕴、十二处、十八界是也。此六离合释。往往兼通。一名非必局于一释。如说五蕴。五即是蕴。此用自为名。即带数而兼持业。如说眼等六识。取自他为名。即带数而兼依主。如说五业为五无间。无间是果。五业是因。即因谈果。全取他名。即带数而兼有财）。
    二苦者。一，内苦。更分为二。甲，身苦。一大不调。生百一病。四大不调。生四百四病。是为身苦。乙，心苦。忧、愁、嗔、苦、嫉、妒、疑，是为心苦。二，外苦。虎狼毒害，风雨霜雪，身外所受袭击皆是。见《智度论·十九》。惟识宗以世俗谛苦、胜义谛苦为二苦。世俗谛苦，为世间智境界。生、老、病、死、爱别离、怨憎会、求不得，各苦属之。胜义谛苦，为出世间智境界。略摄五取蕴苦。见《杂集论·六》。
    三苦者。一，苦苦。二，坏苦。三，行苦。此三苦义有通别。别者。对三受言。一者。苦受。从苦缘生。有漏之身。性常逼迫。苦上加苦。是名苦苦。欲界苦也。二者。乐受。乐境尽时。苦相即至。乐极悲生。是名坏苦。色界苦也。三者。不苦不乐受。生住异灭。四相迁流。有漏之法。常不安稳。是名行苦。无色界苦也。若以通论。三受皆从苦缘生。全是苦苦。三受皆有坏相现。全是坏苦。三受均是无常相。全是行苦。见《俱舍论·十二》。又三苦者。一，依内苦。身心所受之苦。二，依外苦。人物见害之苦。三，依天苦。风雪霜露之苦。见《金七十论·上》。又无量众生有三种身苦。老、病、死也。三种心苦。淫、嗔、痴也。三种后世苦。地狱、饿鬼、畜生也。见《智度论·九》。又一，会合所生苦。二，乖离所生苦。三，平等相续苦。见《瑜伽论·十四》。
    四苦者。一，生苦。果报始起为生。生时有苦。二，老苦。身体衰变为老。老时有苦。三，病苦。四大增损为病。病时有苦。四，死苦。五蕴坏离为死。死时有苦。是为四苦。见《大乘义章》。又一，生苦。二，缘内苦。三，缘外苦。四，粗重苦。见《瑜伽论·五十五》。
    五苦者。生、老、病、死外。加一狱苦。谓违法犯罪。枷锁系身。禁闭牢狱。受诸刑罚。统称五苦。见《五苦章句经》。又八苦中合生、老、病、死四苦为一苦。加爱别离苦、怨憎会苦、求不得苦、五蕴盛苦。亦称五苦。见《三藏法数引析玄记》。
    八苦者。一，生苦。一者受胎。识托母腹。窄狭不净。二者种子。父精母血。构结成胎。随母气出入，不得自在。三者增长。住胎十月。内热煎逼。身形渐成。寄于生脏之下。熟脏之上。间夹如狱。四者出胎。方出生时。冷风热气。以及衣物。触体如刺。五者种类。既出生后。贫富贵贱。残整妍丑。种种不齐。滋生烦恼。是名生苦。二，老苦。一者增长。从少至壮。从壮至衰。气力羸弱。动止不宁。二者灭坏。盛去衰来。精爽消亡。其命日促。终至朽坏。是名老苦。三，病苦。一者身病。四大不调。众病交攻。地大不调。举身沉重。水大不调。举身胖肿。火大不调。举身蒸热。风大不调。举身木强。二者心病。心神苦恼。忧虑悲思。是名病苦。四，死苦。一者病死。命尽身丧。二者外缘。水火灾厄。是名死苦。五，爱别离苦。亲爱离散。不能常聚。是名爱别离苦。六，怨憎会苦。怨仇憎恶。求离反聚。是名怨憎会苦。七，求不得苦。世间名利爱乐。图谋无望。是名求不得苦。八，五蕴盛苦。五阴炽盛。盖覆真性。众苦交集。是名五蕴盛苦。见《涅槃经·十二》。
    十苦者。一，生苦。二，老苦。三，病苦。四，死苦。五，愁苦。六，怨苦。七，苦受。八，忧苦。九，病恼苦。十，生死流转苦。见《释氏要览引菩萨藏经》。
    十九苦者。一，愚痴异熟苦。二，行苦所摄苦。三，毕竟苦。四，因苦。五，生苦。六，自作逼恼苦。七，戒衰损苦。八，见衰损苦。九，宿因苦。十，广大苦。十一，那落迦苦（那落迦。地狱也。此云恶者。造恶之人生彼处也）。十二，善趣所摄苦。十三，一切邪行所生苦。十四，一切流转苦。十五，无智苦。十六，增长苦。十七，随逐苦。十八，受苦。十九，粗重苦。见《瑜伽论·四十四》。
    百苦者。二十五有（二十五有。不出三界六道。欲界占十四有。四洲为四有。东，弗于逮洲。西，瞿耶尼洲。南，阎浮提洲。北，郁单越洲。四恶趣为四有。六道中除人天外。修罗、饿鬼、畜生、地狱，四恶趣也。六欲天为六有。色界天占七有。初禅、二禅、三禅、四禅、初禅之大梵、四禅之无想、五那含。大梵、无想、五那含，所以于初禅天四禅天之外。别出其名。各占一有者。因外道以大梵天为万物之主。无想以无心为涅槃。计五那含为真解脱。故特标以破之。无色界天占四有）。各有生、住、异、灭四有为相（生、住、异、灭。四相皆有为法。从生至死。就一期受报而言。为大四相。一念托胎。十月满足。此身即生。是为生相。既出胎已。住于世间。是为住相。少时颜红体润。老年发白面皱。是为异相。业尽命终。身亦坏灭。是为灭相。从一念起灭而言。为小四相。以根对尘。一念心生。是为生相。一念之心。暂尔相续。是为住相。一念之心。先后不同。是为异相。尘境既忘。心念亦灭。是为灭相）。有为身心。都成烦恼。合之成百苦也。
    百一十苦者。分之为一苦。二苦。三苦。四苦。五苦。六苦。七苦。八苦。九苦。十苦。一苦者。依无差别流转之苦。二苦者。一，欲为根本苦。谓可爱事若变若坏所生之苦。二，痴异熟生苦。谓若猛利体受所触。即于自体执我我所。愚痴迷闷。生极怨嗟。由是因缘。受二箭受。谓身箭受及心箭受。三苦者。一，苦苦。二，行苦。三，坏苦。四苦者。一，别离苦。谓爱别离所生之苦。二，断坏苦。谓由弃舍众同分死所生之苦。三，相续苦。谓从此后数数死生展转相续所生之苦。四，毕竟苦。谓定无有般涅槃法诸有情类五取蕴苦。五苦者。一，贪欲缠缘苦。二，嗔恚缠缘苦。三，惛沉睡眠缠缘苦。四，掉举恶作缠缘苦。五，疑缠缘苦。六苦者。一，因苦。习恶趣因故。二，果苦。生诸恶趣故。三，求财位苦。四，勤守护苦。五，无厌足苦。六，变坏苦。七苦者。一，生苦。二，老苦。三，病苦。四，死苦。五，怨憎会苦。六，爱别离苦。七，希求而不得苦。八苦者。一，寒苦。二，热苦。三，饥苦。四，渴苦。五，不自在苦。六，自逼恼苦。谓无系等诸外道类。七，他逼恼苦。谓遭遇他手块及蚊虻等触。八，一类威仪多时住苦。九苦者。一，自衰损苦。二，他衰损苦。三，亲属衰损苦。四，财位衰损苦。五，无病衰损苦。六，戒衰损苦。七，见衰损苦。八，现法苦。九，后法苦。十苦者。一，诸食资具匮乏苦。二，诸饮资具匮乏苦。三，骑乘资具匮乏苦。四，衣服资具匮乏苦。五，庄严资具匮乏苦。六，器物资具匮乏苦。七，香鬘涂饰资具匮乏苦。八，歌舞伎乐资具匮乏苦。九，照明资具匮乏苦。十，男女给侍资具匮乏苦。复有余九种苦。一，一切苦。二，广大苦。三，一切门苦。四，邪行苦。五，流转苦。六，不随欲苦。七，违害苦。八，随逐苦。九，一切种苦。一切苦中复有二苦。一，宿因所生苦。二，现缘所生苦。广大苦中复有四苦。一，长时苦。二，猛利苦。三，杂类苦。四，无间苦。一切门苦中复有四苦。一，那落迦苦。二，傍生苦。三，鬼世界苦。四，善趣所摄苦。邪行苦中复有五苦。一，于现法中犯触于他他不饶益所发起苦。二，受用种种不平等食界不平等所发起苦。三，即由现法苦所逼切自然造作所发起苦。四，由多安住非理作意所受烦恼随烦恼缠所起诸苦。五，由多发起诸身语意，种种恶行所受当来诸恶趣苦。流转苦中复有六种轮转生死不定生苦。一，自身不定。谓先为王后为仆隶。二，父母不定。三，妻子不定。四，奴婢仆使不定。五，朋友宰官亲属不定。谓先为父母乃至亲属。后时轮转。反作怨害及恶知识。六，财位不定。谓先大富贵。后极贫贱。不随欲苦中复有七苦。一，欲求长寿。不随所欲。生短寿苦。二，欲求端正。不随所欲。生丑陋苦。三，欲生上族。不随所欲。生下族苦。四，欲求大富。不随所欲。生贫穷苦。五，欲求大力。不随所欲。生羸劣苦。六，欲求了知所知境界。不随所欲。愚痴无知现行生苦。七，欲求胜他。不随所欲。反为他胜而生大苦。违害苦中复有八苦。一，诸在家者妻子等事损减生苦。二，诸出家者贪等烦恼增益生苦。三，饥俭逼恼之所生苦。四，怨敌逼恼之所生苦。五，旷野险难迫迮逼恼之所生苦。六，系属于他之所生苦。七，支节不具损恼生苦。八，杀、缚、斫、截、捶打、驱摈、逼恼生苦。随逐苦中复有九苦。依世八法有八种苦。一，坏法坏时苦。二，尽法尽时苦。三，老法老时苦。四，病法病时苦。五，死法死时苦。六，无利苦。七，无誉苦。八，有讥苦。是名八苦。九，悕求苦。一切种苦中复有十苦。一，因苦。二，受苦。三，唯无乐苦。四，受不断苦。五，出离远离寂静菩提乐所对治家欲界结寻异生苦。六，逼迫苦。七，众具匮乏苦。八，界不平等苦。九，所爱变坏苦。十，三界烦恼品粗重苦。总有一百一十种苦。见《瑜伽论·四十四》。
  以上所说诸苦皆世间苦也。若论出世间苦。则变易生死是也。盖生死有二。一，分段生死。二，变易生死。分即分限。段即形段。具见思惑之一切众生。随诸有漏善不善业。由烦恼障助缘所感欲、色、无色三界之天、人、修罗、地狱、饿鬼、畜生、六道果报也。随其业力。身有短长。命有夭寿。故名分段生死。属世间苦。至变易生死。因声闻、缘觉及菩萨。虽已断见思惑。离三界内分段生死。随诸无漏善业。依所知障助缘所感之界外果报也。无色形之胜劣。寿命之短长。迷想渐减。证悟渐增。而有方便土等之变易生死（一，方便生死，入涅槃之二乘也。二，因缘生死。初地之变易也。三，有有生死。十地之变易也。四，无有生死。更断一品无明。入等觉位之金刚心也）。初位为因。后位为果。后位为因。后后位为果。因移果易。舍所住位。故名变易生死。为出世间苦。
    此处苦厄之厄。与苦同义。若专说厄。当有四种。一，见厄。即三界见惑。意根对于法尘起分别见。因此见惑。流转三界。不能脱离。二，欲厄。即欲界思惑。五根贪爱五尘。成贪嗔慢。名为思惑。因此思惑。流转欲界。不能脱离。三，有厄。因果不亡为有。色界无色界之思惑（即贪、慢）。因此思惑流转色无色界。不能脱离。四，无明厄。此为迷于根本理体之惑。由此无明。流转生死。不能脱离。
    苦之大者。无过于生死。烦恼障障涅槃。我执空则烦恼障灭。度分段生死之苦。所知障障菩提。法执空则所知障灭。度变易生死之苦。既证二空。苦恼斯尽。故曰度一切苦厄。
    《般若波罗蜜多心经诠注·卷三·上》


第一项 明蕴空

    《般若波罗蜜多心经诠注·卷三·下》
     震旦白衣周止庵学

     第二节 正示法空

    上来总说菩萨修证之恉。以次广释蕴空境谛。而观照自在其中。以非观照不能了达此境谛也。分述如左。

    第一项 明蕴空

    舍利子。色不异空。空不异色。色即是空。空即是色。受想行识。亦复如是。
    舍利子。梵语舍利弗怛罗。舍利，鸟名。此云鹙鹭。弗怛罗。此云子。故译作鹙子。亦简称舍利弗。南天竺婆罗门提舍子。其母为婆罗门摩陀罗女。眼似舍利鸟。故名舍利。及怀此子。论议殊胜。从母立名。曰舍利弗怛罗。智慧无穷。决了诸疑。佛诸弟子中，智慧第一。般若会中。非利根上智。不足以当机起信。故舍利子现迹声闻。为众请问。菩萨呼而告之。
    【注】鹙子他经亦有译作身子者。因梵语设利罗。此云身。设利。舍利。音相近也。
    世尊十大弟子中。摩诃迦叶。头陀行第一。阿难陀。多闻第一。舍利弗。智慧第一。须菩提。解空第一。富楼那。说法第一。摩诃目犍连。神通第一。摩诃迦旃延。论议第一。阿[少/兔]楼陀。天眼第一。优婆离。持戒第一。罗睺罗。密行第一。此外又有摩诃拘絺罗。答问第一。摩诃离婆多。无倒乱第一。憍梵波提。受天供养第一。摩诃劫宾那。知星宿第一。薄拘罗。寿命第一。周利槃陀伽。义持第一。宾头庐颇罗堕。应末世供福田第一。迦留陀夷。教化第一。孙陀罗难陀。仪容第一。
    现迹声闻者《准法华文句》。身子久已成佛。号金龙陀。般若会虽在法华以前。但相去不远。曰久已成佛。则可知在过去生中。早已成佛。此时以大权现罗汉身。为当机众耳。

    是时佛在王舍城鹫峰山。与大比丘众并诸菩萨摩诃萨俱。观自在菩萨。白佛。欲说诸菩萨普遍智藏般若波罗蜜多心。承佛印可。菩萨入慧光三昧定。行深般若波罗蜜多。照见五蕴自性皆空。即从定起。告舍利子以色空不二之旨。盖此经为般若波罗蜜多心。在般若会中。佛既以此详示舍利子。菩萨行深般若已。为欲正示法空。故因舍利子之问而告之。
    【注】佛详示舍利子。见《大般若经·四·初分相应品·第三》之一。又四百三。第二分观照品第三之二。又四百八十。第三分舍利子品第二之二。《大品般若经·二·习应品·第三》。

    此段广说五蕴自性皆空之义。色为五蕴之首。故举色以赅其除。色即四大幻色。空乃般若真空。众生因迷真空而成幻有之色。譬如水动成波。菩萨以般若观慧。照见幻有缘生。原无自性。本体即空。如波平为水。水之与波。湿性无殊。幻有无异真空。如波之不异于水。故云。色不异空。所以破凡夫著相之心。真空无异幻相。如水之不异于波。故云空不异色。所以破小乘顽空之见。《大般若经》曰。色自性空。不由空故。色空非色。色不离空。空不离色。《了义般若经》曰。色自性空。空离性故。色体即空。离色无别空。空体即色。离空无别色。是义云何。名分别故。是知即色之空为真空。即空之色为幻色。非离色以明空。亦非灭色以明空。色空本体。是一非二。
    【注】华严三观中之真空观。一，会色归空。会即融会。色即根身世界。谓根身世界。本是真如一心。 与生灭和合而有。今观此色都无实体。归于真心之空。故曰会色归空。二，明空即色。明即明了。谓了真空之理。不异于色。色无自性。不异于空。故云明空即色。三，空色无碍。谓色体全是真空。真空之体。不异于色。若色是实色。即碍于空。空是断空。即碍于色。今既色是幻色。故不碍空。空是真空。故不碍色。故曰空色无碍。四，泯绝无寄。泯即亡泯。绝即寂灭。寄。犹依也。谓所观真空之理。不可言即色是空。亦不可言离色是空。空。不空。皆不可得。非言思能及。亦无所依。故云泯绝无寄。
《占察经》有二种观法。于一切时一切处。随身口意所有作业。于念念间。悉以空假中三观。观察所起之心。名唯识观。思唯心性无生，无灭。不住见闻觉知。于念念间。悉以空假中三观。观于本心所具实相之理。名实相观。
    言真空者。非断灭空。非离色空。即有明空。亦无空相。故言真空。小乘析空观。色尽方空。大乘体空观。色即是空。盖小乘既得人空。以为蕴空。不知蕴中无人。如云舍中无主。舍非空也。大乘则即色举体是空。故蕴自性空。析空观者。析色明空。以假想慧。析至极微。则色等空。又推极微有方分及无方分，皆不可得。则极微空。体空观者。体色明空。谓缘生无性。故自、他、共、及无因，皆无生理。故《中论》云。未曾有一法。不从因缘生。是故一切法。无不是空者。
    《略疏》云。《宝性论》云。空乱意菩萨。有三种疑。一，疑空异色。取色外空。今明色不异空。以断彼疑。二，疑空灭色。取断灭空。今明色即是空。非色灭空。以断彼疑。三，疑空是物。取空为有。今明空即是色。不可以空取空。以断彼疑。三疑既尽。真空自显。
    离色明空。如云墙处不空。墙外是空。灭色明空。如穿井者。除土出空。要须灭色。先有后无。是断灭空。

    色即是空。空即是色者。正发明上文不异之旨。不异即即是也。又恐众生因法成执。犹存色空二见。故正言以泯之。使行者妙契色空不二。如波即水。如水即波。动静虽分。体性则一。永嘉云。无明实性即佛性。幻化空身即法身。是知幻境无异真如。色外无空。故色即是空。空外无色。故空即是色。《楞严经》曰。性色真空。性空真色。以色等本是真如一心。自性随缘。与生灭和合。名阿赖耶识等。而为能变。变起根身器界种种幻色。虽成幻色。而体终不变。故色体全是真空。此如来藏中随缘不变义也。真空者。自性不变。其体元空。虽其体元空。而用终不失。故空为真色。此如来藏中不变随缘义也。《大般若经》曰。色自性空。不由空故。色空非色。色不离空。空不离色。色即是空。空即是色。受想行识自性空。不由空故。受想行识。空。非受想行识。受想行识不离空。空不离受想行识。受想行识即是空。空即是受想行识。又曰。菩萨摩诃萨。行般若波罗蜜多。不应于色求。不应于受想行识求。不应离色求。不应离受想行识求。所以者何。若色。若受想行识。若离色。若离受想行识。若菩萨摩诃萨。若般若波罗蜜多。若求如是一切。皆非相应。非不相应。非有色。非无色。非有见非无见。非有对。非无对。咸同一相。所谓无相。盖无相即实相。色空原一实相。本无二致。凡夫执有身心。故见生灭而缠于生死二乘妄见五蕴实有其相。不了缘生。心起厌离。故堕声闻。虽了缘生。不达无性。故堕缘觉。菩萨照了五蕴诸法。无性缘生。缘生无性。无性故空。空即真空。盖法身真空之体。原非断灭。故须于幻有中求。幻外无真。故曰真空。真外无幻。故曰幻色。真空幻色。不异，即是。为一经之要恉。般若之真宗。
    【注】法身者。三身之一。身者，聚集之义。聚集诸法而成身也。理法聚名法身。有五。一，法性法身。法性圆常。赅通万有。二，功德法身。万行功德所成。三，变化法身。无感不形。无机不应。如千江月。随水现影。影虽有殊。月本是一。四，虚空法身。融通三际。包括大千。一性圆明。诸尘不染。五，实相法身。离诸虚妄。会极真如。不生不灭。故名实相。智法聚名报身。自受内证法乐之身。曰自受用报身。对于初地以上菩萨应现之报身。曰他受用报身。功德法聚名应身。对于初地菩萨应现者。为胜应身。应现于地前菩萨及二乘者。为劣应身。如来之法身。名毗卢遮那。此云遍一切处。报身名卢舍那。此云光明遍照。应身名释迦牟尼。释迦此云能。为族姓。牟尼。此云寂默。佛地论并法身、实报。皆名法身。以他受用及化身名生身。总之法身为一真法界真智所现之功德实相。报身为修因所成。应身则胜应同于他受用报身。劣应为地前菩萨及二乘所见依定而现之佛身。随感而必应。应机示现种种异形。则为化身。《观经净影疏》云。八相现成者为应身。随机现起者为化身。五种法身中之功德法身。同于报身。变化法身。同于化身。
幻境。即虚幻无实之境界。
    真如者。真实无妄之理也。梵语步多多他多。真谓真实。显非虚妄。如谓如常。表无变易。谓此真实。于一切法常如其性。故曰真如。《大乘止观》云。此心即自性清净心。又名真如。亦名佛性。亦名法身。亦名如来藏。亦名法界。亦名法性。《教行信证》云。无为法身。即是实相。实相即是法性。法性即是真如。盖皆同体而异名也。其曰一真如者。一真法界无差别也。《初门论》云。心真如者。即是一法界大总相法门体。所谓心性。不生不灭。一切诸法。唯依妄念而有差别。若离心念则无一切境界之相。是故一切法。从本以来。离言说相。离名字相。离心缘相。毕竟平等。无有变异。不可破坏。唯是一心。故名真如。其曰二真如者。更有种种。一，随缘真如，与不变真如。随无明之缘。而起九界之妄法。是为随缘真如。虽随缘而为妄法。然其真性不变。谓之不变真如。因随缘故。真如即万法。不变故。万法即真如。二，空真如，与不空真如。真如究竟离染法而如明镜。谓之空真如。真如具一切净法。如明镜之现万象。谓之不空真如。三，清净真如，与染净真如。即随缘真如，与不变真如之异名。四，有垢真如，与无垢真如。众生所具云有垢真如。诸佛所显云无垢真如。五，在缠真如，与出缠真如。即有垢真如，与无垢真如之异名。六，生空真如，与法空真如。空人我而所显者曰生空。空法我而所显者曰法空。七，依言真如，与离言真如。真如之体。本来离言说相。离心念相。是曰离言真如。依假名之言说而显其相。是曰依言真如。八，安立真如，与非安立真如。即依言真如，与离言真如之异名。能生世、出世间，一切诸法而得安住。故名安立。从本以来。性自清净。离一切相。寂灭无为。故曰非安立也。九，相待真如，与绝待真如。亦依言真如，与离言真如之异名。其曰三真如者。一，无相真如。谓诸法之体。无遍计所执之虚相也。二，无生真如。谓诸法因缘生，故无实性也。三，无性真如。谓诸法真体。言忘虑绝。故无妄情所执之实性也。其曰七真如者。一，流转真如。谓众生造作一切行业。流转生死。真如之体。本无摇动。然亦不妨随缘转变。一切行业。不离真如。二，实相真如。无虚妄相。故名实相。了空人法二执。即是实相真如。三，唯识真如。一切行业。皆由识心。一切识心。皆由真如之理变现。是名唯识真如。四，安立真如。一切众生色身行业有为之法。迷真逐妄。受生死苦。皆依真如之体建立。是名安立真如。为苦谛之实性。五，邪行真如。一切烦恼妄惑邪行之法，不离真如之体。是名邪行真如。为集谛之实性。六，清净真如。如来所说涅槃清净之理。本无染污。是名清净真如。为灭谛之实性。七，正行真如。如来所说一切道品正行之法。皆依真如理体。是名正行真如。为道谛之实性。其曰十真如者。一，遍行真如。此真如为我法二空所显。一法无所不在。故曰遍行。二，最胜真如。具足无边功德。于一切法为最胜。三，胜流真如。教法殊胜。故名胜流。四，无摄受真如。非两执之所依。故名无摄受。五，类无别真如。生死涅槃。二皆平等。无差别相。故名无别。六，无染净真如。本性无染。故名无染净。七，法无别真如。以多数法。种种安立。无别无异。故名法无别。八，不增减真如。不随染净而有增减。故名不增减。证此真如。则现相现土。俱得自在。故又名相土自在所依真如。九，智自在所依真如。若证此真如已。于无碍解得自在。十，业自在所依真如。于一切神通作业。陀罗尼定门。皆得自在。故以为名。又《大般若经》及《大涅槃经》十二无为。亦名十二真如。一，真如。二，法界。界者所依之义。三，法性。诸法体性也。四，不虚妄性。诸法有为。皆虚妄性。对之而言不虚妄也。五，不变异性。无变异也。六，平等性。无差别也。七，离生性。离生灭也。八，法定。法性常住也。九，法住。诸法住于真如也。十，实际。法性真实之际极也。十一，虚空界。喻理体之周遍法界也。十二，不思议界。理绝言思也。总之真如之性。实无差别。一切言说。假名无实。言真如者。亦无有相。真如之名。亦是假设。诸经随其胜德而立假名。行者借以修证。不可执名误实。
    如来藏者。真如隐覆。未成法身之名。如来者。理性。如来藏者。含藏之义。因中说果。故名如来。含藏者。有三义。一者。所摄真如。立于众生之位。含和合不和合之二门。含和合门者。生一切之染法。含不和合门者。生一切之净法。一切染净之法。皆摄于真如。《胜鬘经·宝窟·下》曰。一切众生。无有出如如境者。并为如如所摄。故名藏也。则众生为如来所摄。二者。隐覆。如来性德。为烦恼隐覆而不显也。《胜鬘经·宝窟·下》曰。如来性住在道前。为烦恼隐覆。众生不见。故名为藏。是众生藏如来也。三者。能摄。真如在烦恼中。含摄如来一切果地之功德。故名如来藏。《起信论》云。如来藏具足无量性功德故。《义记》云。隐时能出生如来。名如来藏。显时为万德依止。名为法身。憨山师《楞严圆镜》。则以如来藏为三观之体。一，空如来藏。谓此藏性。其体本空。一法叵得。如摩尼珠。其体空净。了无色相。虽有随方之色。色不离珠。以即珠故。真心本净。了绝妄缘。虽有随缘之妄。妄不离真。以即真故。名曰真空。故为观者先示真心。以为观体。能观此体。名真空观。即体真止（体无明颠倒。即是实相之真）。二，不空如来藏。谓此藏体虽空。具有恒沙称性功德。包含融摄。纤悉不遗。如摩尼珠。其体虽净。具有圆照之用。随方现一切色。色即是珠。以珠现故。藏性虽如。而能随缘显现十界依正之相。相即是性。以性起（从缘无性。缘起即名性起。又法性随缘。净缘起常顺于性。亦名性起。起有二。一，染。二，净。净谓如来大悲。菩萨万行等。染谓众生惑业等。以染夺净。则属众生。故惟缘起。以净夺染。惟属诸佛。故名性起）故。名不真空。故为观者示此藏性。以为观体。能观此体。名不空观即方便随缘止（实相遍一切处。随缘历境。安心不动）。三，空不空如来藏。谓此藏性。其体净圆。能应能现。净故非色。以即珠故圆故能应非不色。以即色故。净故非相。以即性故。圆故能现非不相。以即相故。非相非性。名空不空。非相故空。非性故不空。非即非离。平等如如。名曰中道。故为观者示此藏性。以为观体。能观此体。名中道观。即离二边分别止（生死涅槃。静散休息）。
    相应者。契合义。如函盖之相称。一，事契合。如心心所之相应。二，理契合。如瑜伽之境（一切所缘境。与心相应）、行（一切行与理相应）、果（三乘圣果。与诸功德法相应）三种相应。
    有色。即有色身之欲界。色界。无色。即无色界。
    有见。即常见。执著于有。以为身心常住。增益实性之妄见也。无见。即断见。执著于无。以为身心断灭。永不续生。损减实性之妄见也。
    有对者。对。碍也。一，障碍。二，拘碍。就十八界分别。有三种有对。一，障碍有对。以五根、五境之十色为体。十色互相障碍。如手之碍手。石之碍石。此障碍也。二，境界有对。六根六识之十二界。与法界一分之心所法。为境所拘。三，所缘有对。六识及意根之七心界，与法界之一分心所法，八界。为所缘之境所拘。此二者皆拘碍也。从根及心识一边言。为境界有对。从缘心与所缘之境一边言。为所缘有对。
    幻有者。假幻无之事。以显法之假有。迷真空之理。成幻有之事。虚假不实也。有二说。一，谓幻有必覆真空。幻有若现。真空必隐。二，谓幻有不碍真空。真空若显。幻有自灭。
    非有之有（非如凡夫妄计之实有）。为妙有。非空之空（非如小乘偏执之但空）。为真空。以真空故。缘起之诸法宛然。以妙有故。因果之万法一如。有二说。一，谓真空能灭幻有。若幻有不灭。即非真空。二，谓真空能成幻有。幻有若碍。亦非真空。

    色蕴既尔。四蕴皆然。故云受想行识亦复如是。如是者。指示之辞。指示四蕴不异于空。即是空性。与色蕴同也。《大般若经》曰。色不异空。空不异色。色即是空。空即是色。受想行识不异空。空不异受想行识。受想行识即是空。空即是受想行识。故经云五蕴皆空。菩萨以此现前五蕴身心为所观境。了境唯心。观心忘境。观一蕴空。则蕴蕴皆空。《圆觉经》云。幻身灭故。幻心亦灭。幻心灭故。幻尘亦灭。幻尘灭故。幻灭亦灭。幻灭灭故。非幻不灭。圆觉破幻显真。此经即幻是真。旨虽不同。其果则一。既知此心真妄同源。空有不二。即此现前一念。妄想起处。以智观察。见幻无体。便是真空。即凡心而见佛心。从幻妄以悟真如。譬如磨镜。垢尽镜明。镜性本明。非从外得。
    【注】五蕴之中。色为色法。受想行识为心法。上文既明色空不二之旨。故复推及心法四蕴。所以先色而后心者。以五蕴根元。重叠生起。由一念不觉。而转为无明业识。因识有行。因行有想。因想有受。因受有色。自细至粗。譬如著衣。由内至外也。若欲灭除。则先除色。次除受想行，最后除识。从粗至细。譬如脱衣。先外后内也。《楞严经》曰。生因识有。灭从色除。长水云。生起则从细至粗。从内感外。一切诸法。唯识变故。故云生因识有。除断则先粗后细。从外向内。如浣衣磨镜。粗垢先落。故云灭从色除。


第一款 总标

    第二项 显空德
    本项更分为二。上总标。下别释。

    第一款 总标

    舍利子。是诸法空相。不生。不灭。不垢。不净。不增。不减。
    是者。指示之辞。犹言此也。诸者。众也。不一之义。诸法者。略则五蕴。广则蕴，处，界，缔，缘，七大，十法界，皆是。空相。则真空实相也。盖诸法本空。空性亦空。空中之空。尚不可得。何况诸法。前言五蕴幻有。原无实性。而未及于相。或将疑为法性可空。而法相不尔。故此申之云诸法空相。既云诸法空相。则不可离诸法而别言空相。夫一切法无相。故诸法当体即是真空之相。譬如水月镜花。不可作之使生。坏之使灭。染之使垢。治之使净。加之使增。损之使减。何以故。以彼影象无实性故。当体即空。亦如虚空不可以生，灭，垢，净，增，减。真空之相亦然。无相之相。强名之曰实相。此真空实相者。即自性。即真如。离言说相。离文字相。离心缘相。所谓言语道断。心行处灭。非五眼所能窥。非心智所能测。惟证者知之。实相无相。故不落有。空相无无相。故不落空。空相亦空。是名真空。
    是诸法空相句。唐法成三藏译本。作一切法空性无相。智慧轮三藏译本。作是诸法性相空。由藏文转译者。能海宽本。作一切法空无相。孙慧风本。作一切法自性空无相。慧清本。作是故诸法空性无相。超一本。作一切法空性。可征诸法真空实相。即是无相。以一切法非实有相。无色，无见，无对，一相。所谓无相。《大般若经》曰。一切法自相皆空。能取，所取，皆不可得故。又曰。如是无相。既非有相。亦非无相。何以故。非一切法先是有相。后成无相。以一切法本是无相。后亦无相。《中边分别论》云。无二有此无。是二名空相。无二者。谓无能取，所取。有此无者。谓但有所取，能取无。是二名空相者。谓无及有无。是名空相。此显真空无有二相。《辩中边论》云。无二有无故。非有亦非无。非异亦非一。是说为空相。无二。谓无能取所取。有无。谓有二取之无。此即显空无性为性。故此空相。非有非无。云何非有。无二有故。云何非无。有二无故。此显空相非有非无。故《大般若经》曰。惟观一切法。无不皆空。是为觉知诸法实相。以观一切法空故。即无相亦不可执著。《宗镜录》云。若以无相为无相。无相即为相。舍有之无。犹逃峰而起壑。
    【注】空相者。实相也。经云。无相不相。名为实相。无相者。无生死相也。不相者。不涅槃相也。生死涅槃俱尽。常寂灭相。故名为空。不二不异。离虚伪颠倒，常乐我净，即空假中，故名实相。
    无漏正智。能契合于所缘之真理谓之证。《大乘义章》。己情契实。名之为证。又曰。证者。智得之别名也。
    清凉云。无妄法之有。有妄法之无。有无有二。一，定性有无。二，真空妙有。无妄法之有。则无定性之有。非断无矣。有妄法之无。是真空之无。便为妙有。是故若举妄取真。则妄有真空。如三论说。若空有对辨。则妄空真有。如涅槃明。无能取、所取有者。则无妄法之有也。
    有能取、所取。无者。则有妄法之无也。故曰。遂令缘起之相。相无不尽。无性之理。理无不现。
    能取，所取，二名之义。相宗与性宗所说。广略不同。以依他之能缘为能取。所缘为所取。即见、相二分。以见分能取相分。如眼见色。相分为见分所取。如色被见。此性宗之说也。以遍计之见执为能取。相执为所取。即执能取之见分。及所取之相分为实有。则不能了空。不能了空。则烦恼所知二障。不能伏断。此相宗之说也。性宗舍妄取真。则妄有真无。相宗真俗相待。则妄无真有。有无不定。二即不二。如《杂集论·三》云。为舍执著能受用我故。观察能取。受用我者。计我能得爱、不爱境。又云。谓诸能取。亦是所取。以眼根等意识所取故。或有所取，非能取。谓唯是取所行义。唯者。决定义。此言为简。心所有法一切皆是所取。谓舍执著境界我故。观察所取。
    无色者。谓有色相违。是无色义。无见者。谓有见相违。是无见义。无对者。谓有对相违。是无对义。见《杂集论·三》。
    一相者。谓一真法界之相。从本以来。离虚妄相。离言说相。离名字相。离一切诸法之相。故名一相。但一相亦不可执。故《起信论》云。当知真如自性。非有相。非无相。非非有相。非非无相。非有无俱相。非一相。非异相。非非一相。非非异相。非一异俱相。
    无相者。诸相寂静故。诸相者。谓色、受等乃至菩提。诸所戏论。真如性中。彼相寂静。故名无相。见《杂集论·二》。

    不者。否定之辞。本无今有名生。暂有还无名灭。缘聚则生。缘尽则灭。同属虚妄。总非真实。《大般若经》曰。真实理中。无有一法。可生可灭。何以故。世间诸法。皆因缘生。无我、有情、作者、受者。因缘和合。说诸法生。因缘离散。说诸法灭。无一实法受生灭者。虚妄分别。于三界中但有假名。随业烦恼。受果异熟。若以般若波罗蜜多如实观察。则一切法无生、无灭、无作、无受。若法无作。是亦无行。则于诸法。心无所著。《胜天王问般若经》曰。一切诸法。自性本空。无生无灭。缘合谓生。缘散谓灭。自性非无。是故不生。自性非有。是故不灭。《智度论》云。空故无相。无相则无作无起。是法常住不坏。故无生无灭。
    【注】或谓因缘之法。正是生灭。何云不生不灭 。不知约俗谛言。缘聚则生。缘散则灭。系指法相。见法相之生灭。可证法性之本不生灭。执相昧性。凡夫所以有轮回生死之苦。此治著有之病。若约真谛言之。则不生不灭。所以对治凡夫著生灭相之病。须知性相不二。空有同时。有即是空。故俗谛之生灭。为假生假灭。空即是有。故真谛之不生不灭。亦是假不生不灭。随缘度生。性不离相。执性厌相。二乘所以有变易生死之苦。此治著空之病。
    圭峰师云。不生不灭。约境说有五。一，就遍计说。由是妄执。无法可生灭也。又理无故不生。情有故不灭。不灭，不生。同为一法。二，就依他说。谓缘会，生即无生。缘离，灭而不灭。又缘起无性。故不生。无性缘起，故不灭。《中论》云。以有空义故。一切法得成。是故不生，即不灭。不灭，即不生。为一物也。三，约圆成性说。谓非是有为故。无彼生灭相。又非妄心境故不生。圣智所证故不灭。不灭，即不生。为一物也。四，通论三性。混融于一法上。就遍计则一向生灭。就圆成惟不生灭。就依他亦生灭，亦不生灭。就三无性故。非生灭，非不生灭。五，即此四句。合为一聚。圆融无碍。约行说。妄念斯寂。有如虚空。何生，何灭。又虽起大用见心无生。用谢归寂。了心无灭。又常称真理。寂然居境。于此心中。有何生灭。
    无住禅师云。见境心不起名不生。不生即不灭。既无生灭。即不被前尘所缚。当处解脱。
    障染为垢。无垢为净。《智度论》云。若法不生，不灭。如虚空。云何有垢，有净。譬如虚空。虽万岁雨而不湿。虽大火烧而不爇。何以故。本自无生故。
    【注】《会要》云。净行为治。对染名净。则信位十善净行。治十恶染故。乃至金刚心位。觉生相无明之垢。故云垢净位。贤首师云。已断障故名净。断未尽故名垢。又修起净德名净。净德未圆。犹带障故名垢。又异前位故名净。异后位故名垢。真空离此。故经不之。

    增者。增长结集之义。减者。减损衰退之义。《大般若经》曰。一切法非减，非增。是谓般若波罗蜜多。又曰。色蕴非减，非增。受想行识蕴。亦非减，非增。如是色蕴非减，非增。是谓般若波罗蜜多。如是受想行识蕴。亦非减，非增。是谓般若波罗蜜多。又曰。菩萨摩诃萨。如是行般若波罗蜜多。不见生。不见灭。不见染。不见净。何以故。但假立客名。别别于法。而起分别。假立客名。随起言说。如如言说。如是如是。生起执著。菩萨摩诃萨。修行般若波罗蜜多时。于如是等。一切不见。由不见故。不生执著。又曰。是诸法空相。不生，不灭。不染，不净。不增，不减。非过去。非未来。非现在。
    【注】《大般若经·四百三十一》曰。此般若波罗蜜多所有义趣。不应以二相观。不应以非二相观。非有相。非无相。非入。非出。非增。非减。非染。非净。非生。非灭。非取。非舍。非执。非不执。非住。非不住。非实。非不实。非相应。非不相应。非和会。非离散。非因缘。非非因缘。非法。非非法。非真如。非非真如。非实际。非非实际。如是义趣。有无量门。
    《贤首心经略疏》。于此节有三释。一，就位释。二，就法释。三，就观行释。初就位释者。不生，不灭。在道前凡位。谓诸凡夫死此生彼。流转长劫。是生灭位。真空离此。故云不生，不灭。不垢，不净。在道中菩萨等位。谓诸菩萨障染未尽。净行已修。名垢净位。真空离此。故云不垢，不净。不增，不减。在道后佛果位中。生死惑障。昔未尽而今尽。是减也。修生万德。昔未圆而今圆。是增也。真空离此。故云不增，不减。二，就法释者。谓色从缘起。真空不生。色从缘谢。真空不灭。又随流不染。出障非净。障尽非减。德满不增。此生灭等是有为法相。反此以显真空之相。故云空相。三，就观行释者。谓于三性立三无性观。于遍计所执性作无相观。谓彼即空。无可生灭。于依他起性作无生观。谓依他染净从缘无性。于圆成实性作无性观。谓前二不有而非减。观智照现而不增。又在缠出障。性无增减。又妄法无生灭。缘起非染净。真空无增减。以此三无性。显彼真空相。道前。谓见道前也。即目十信以前。道中者。见修二道。十地位中。道后者。究竟位也。佛性论立三种佛性。一，道前。名自性住佛性。二，道中。名引出佛性。三，道后。名至得果佛性。佛性惟一。就位分三。真空无异。亦就位分异。清凉云。住自性性者。谓道前凡夫位。引出性者。从发心以上。穷有学圣位。至得性者。无学圣位。《会要》云。道前名自性住者。谓正因佛性。处于染中。性恒不变故。道中名引出佛性者。谓此位以有缘了二因。令性增长而显发故。道后名至得者。以前二位虽得而非至。果位得极。方名至也。
    孤山云。色不异空。故不生。空不异色。故不灭。色不异空。故不垢。空不异色。故不净。色不异空。 故不增。空不异色。故不减。生死即涅槃。故不生。涅槃即生死。故不灭。烦恼即菩提。故不垢。菩提即烦恼。故不净。结业即解脱。故不增。解脱即结业。故不减。
    古云云。法既常寂。妄自奚生。不受一尘。故曰空相。空一切妄。亦名实相。昔则不生。今则无灭。烦恼非垢。涅槃非净。处圣不增。在凡不减。究竟平等。遍一切处。作是观者。即同诸佛。
    《连珠记》云。一者。珠现青黄而珠不生。青黄遽亡而珠不灭。二者。如华华空。空不生华。华去空澄。空不加净。三者。德本不生。真空本有。湛然不生。其何增耶。障本不灭。妄惑本空。灭无可灭。将谁减耶。
    上来所说生灭。约指五蕴，十二处，十八界。垢净。约指四谛，因缘。增减。约指智，得。以蕴、处、界，迷真逐妄。故见生灭。十二因缘有流转、还灭二门。流转门，是苦、集二谛。为世间因果故垢。还灭门，是道、灭二谛。为出世间因果故净。菩萨修行。道有所增。惑有所减。故云增减。今言不生不灭。不垢不净。不增不减。是明真空相中。本无凡圣、修证、因果等法。直显般若一真空体。诸见脱落。独露真常。《法华经》曰。诸法从本来。常自寂灭相。诸法本自不生，不灭。既无生灭。自无垢净增减可言。当体即是真空。真空即是实相。
    【注】《事观解》云。生灭，约体。以真空体。非前际生。非后际灭。绝常绝断。故云不生灭也。垢净，约相。以真空相。非迷时垢，非悟时净。离有离无。故云不垢净也。增减，约用。以真空用。非圣位增。非凡位减。超异超一。故云不增减也。又生灭、世间蕴、处、界、法。垢净、出世谛、缘、法。增减上上菩提，涅槃法。就世法言。蕴。是生、灭。处。是垢、净。界。是增、减。就出世法言十二因缘，生灭、四谛、垢净、智得、增减，真空离此，故云不也。又不生，实谛观。不灭，世谛观。合名第一义谛观。不垢，空性观。不净，色相观。兼则中心观。不增，无为观。不减，有为观。连成性空观。又不生灭。生空观也。不垢净。法空观也。不增减。俱空观也。六相既遣。空理自显。如冰未消。自有凝、散、污、洁、巨、细等相。既化为水。便归不生不灭体矣。真空亦然。


第一。五蕴

    第二款 别释

    以下别明空相。五蕴、十二处、十八界、空。世间法也。十二因缘空。缘觉法也。四谛空。声闻法也。智得空。权教菩萨法也。以权教菩萨随相修行。有能得之智与所得之法也。本款所释。大致同《楞严经》。楞严显一心绝染。故言非。本经明诸法空相。故言无。以下依次释之。

    第一目 三科

    科者。门类之义。三科者。五蕴、十二处、十八界也。《楞严经》以五蕴、六入、十二处、十八界为四科。今经合根、尘，为十二处。故作三科。
    真空实相。本离一切凡圣等法。故无蕴、处、界相可得。所以破众生我执之见。迷于心偏重者。则合色为一。开心为四。云合色者。以五根、六尘。合之为色也。云开心者。于心法中开受、想、行（心所）、识（心王）之四也。令其细观于心。故说五蕴。是为合色开心。迷于色偏重者。则开色为十半。谓五根、五尘为十处。及法处一分（意所取境。名之曰法。法处有四。一，心所。二，不相应行。三，无为。四，无表色。今但取无表色一分。故云半）。合心为一半。谓意处全。及法处一分（仅心所一分故云半）。令其细观于色。故说十二处。是为开色合心。其色心共迷者。则开色为十半。谓五根、五尘及法处一分（无表色）。开心为七半。谓六识。意根及法处一分（心所）。令其一一细观。故说十八界。是为心色俱开。
    众生细观色心二法。皆从虚妄因缘而生。起惑造业。轮转生死。如以真空妙智。悟此妄源。无有实体。绝名离相。则自不为惑染所缚。次分释之。
    【注】绝名离相云者。如《大般若经·三百八十四》曰。善现。如是等一切名。皆是假立。为表诸义。施设诸名。故一切名。皆非实有。诸有为法。亦但有名。由此无为。亦非实有。愚夫异生。于中妄执。菩萨摩诃萨行深般若波罗蜜多时。方便善巧。教令远离。作如是言。名是分别妄想所起。亦是众缘和合假立。汝等不应于中执著。名无实事。自性皆空。非有智者。执著空法。如是。善现。菩萨摩诃萨行深般若波罗蜜多时。方便善巧。为诸有情。说离名法。善现。是谓为名。云何为相。善现。相有二种。愚夫异生。于中执著。何等为二。一者。色相。二者。无色相。何谓色相。善现。诸所有色。若过去。若未来。若现在。若内。若外。若粗。若细。若劣。若胜。若远。若近。于此刹那诸空法空中。愚夫异生。分别执著。是名色相。何谓无色相。善现。谓诸所有无色法中。愚夫异生。取相分别。生诸烦恼。是名无色相。菩萨摩诃萨行深般若波罗蜜多时。方便善巧。远离二相。复教安住无相界中。虽教安住无相界中。而不令其堕二边执。谓此是相。此是无相。如是。善现。菩萨摩诃萨行深般若波罗蜜多时。方便善巧。令诸有情。远离众相。住无相界而无执著。又曰。佛告善现。所化有情。住在名相虚妄分别。诸菩萨摩诃萨从彼名相虚妄分别。拔济令出。

    第一。五蕴。

    是故空中无色。无受想行识。

    是故者。承上文而言。此真空实相之中。既不可以生灭垢净增减求之。故总结云。无色，无受想行识，等。无者。梵语云阿。空义。一切法不生义。真空之中，无五蕴等法。法性自空。不待坏故。清凉云。性主于内。相主于外。二者相成。谓由从缘无性。名为性空。故令体相无不空寂。即法相空。此以性空。成于相空也。由诸相荡尽。是故空中无色。无受想行识。方显法性本空。此以相空成于性空也。既知诸相当体即空。则自无可执取。而得自在。
    梵语塞健陀。此云蕴。积也。聚也。色受想行识诸有为法。和合积聚。谓之五蕴。
    【注】自汉以来。塞健陀译作阴。晋僧睿改译为众。奘师改译为蕴。
小乘转五蕴成五分法身。即转色蕴成戒身。受蕴成定身。想蕴成慧身。行蕴成解脱身。识蕴成解脱知见身。见《请观音经疏》。大乘转五蕴成三德。即转色蕴成法身德。受想行三蕴成解脱德。识蕴成般若德也。见《摄大乘论》。

    一。色蕴。
   色者。变碍义。变谓变坏。碍谓质碍。众微聚集。自成形质。能为障碍也。和合积聚。故名为蕴。《广五蕴论》云。云何色蕴。谓四大种及大种所造色。故色蕴之色。含义视色尘之色为广。谓世间相续，品类，趣，处，差别。色等总略摄故。所有色。若过去。若未来。若现在。若内。若外。若粗。若细。若胜。若劣。若近。若远。如是总摄为一色蕴。
    【注】世间者。别于出世间而言。蕴中不摄无为法也。相续者。言一切诸法。无论有情无情。皆是刹那生灭。前者灭。后者生。相续不断也。品类。即种类。显其种类不一。趣者。天人鬼畜地狱五趣也。处者。指人、天等处。是五趣虽杂居一处。而有差别。并不杂乱。故云差别。色等总略摄者。言一切差别色。总于一色蕴而略摄之也。见《广五蕴论注》。
    《准阿含经》。无常已灭。名过去色。未生。名未来色。已生未谢。名现在色。自身名内色。其余名外色。有对色名粗。无对色名细。染污色名劣。不染污色名胜。过去未来色名远。现在色名近。
    色以变碍为相。《俱舍论》明色二义。一，变坏义。论云。始自色根。终乎无表。可变坏义（自色根至无表，皆为四大种所造色。大种变异。所造色亦变异。大种坏时。所造色亦坏）。名为色蕴。释云。变者。显刹那无常。坏者。显众分无常。二，变碍义。论云。有说，变碍故名为色蕴。释云。变谓变坏。碍谓质碍。众微聚集。变碍义成。
    《显扬论·五》云。色蕴有四种建立。一，相建立。二，生建立。三，损减建立。四，差别建立。相建立者，色蕴相略有五种。一，自相。二，共相。三，所依能依相属相。四，受用相。五，业相。自相者，谓坚等是地等相。各别清净是眼等相。共相者。谓一切色变坏相。所依能依相属相者。谓大种是所依，造色是能依。受用相者。谓内处受用增上力故，各别外色境界得生。或有色聚。惟有坚生。或惟有湿。或惟有暖。或惟有动。或复杂生。由随顺内处受用故。业相者。如地等大种。有依持、摄受、成熟、增长相如是等。生建立者。有五种生。一，依止生。二，种子生。三，势引生。四，顺益生。五，违损生。依止生者。谓依止大种。即于大种处所，有余所造色生。由是因故。说四大种。造，所造色摄在一处。是造义。种子生者。谓从自种子生。如坚硬聚。或时遇缘变生流湿。或流湿聚变生坚硬。或不暖聚变生暖热。或有暖聚变生于冷。或从不动变生于动。或复从动变生不动。如是好色恶色等。展转相生差别。应知，如是若就自相则互无。若就其种则互有。是故从彼彼聚如是如是差别色法生。如是等类。名种子生。应知。势引生者。谓内色根增上力故。现常相续。外物得生。如器世间。又先业势引故。诸内处生若乐欲现前诸天，及北洲人，所有众具。多分由势引生故流转。应知。若人中器世间，唯常相续。如是等类势引生。应知。顺益生者。谓得自顺益缘。彼彼色法。展转滋长，展转增胜而生。犹如水等润洽芽等。如是等类。名顺益生。翻此故名违损生。应知。损减建立者。谓建立极微。复由五种极微建立。应知。一，由分析故。二，由差别故。三，由独一故。四，由助伴故。五，由无分性故。由分析故者。谓由慧分析诸粗色法。渐渐转减。至最细边。建立极微。非由体故。由如是因。故说极微。无起无灭。又亦非谓集诸极微以成粗色。由差别故者。略有十五种极微。谓眼等根极微有五种。色等境极微有五种。地等界极微有四种。法处所摄实有色极微有一种。由独一故者。谓建立实极微自相。由助伴故者。谓建立聚极微。由于地等一极微处。有余色法同处不相离故。建立聚极微。由无分性故者。非一极微。复有余细分。由非聚故。若聚极微。可有众分。若一极微。所住之处。此处不可分析。更立余分。是故极微。无有细分。差别建立者。有二十六种色。一，欲界系色。谓具诸色。二，色界系色。谓除香味。三，无色界系色。谓等持自在色。非业异熟色。四，清净界色。谓出世法增上所生，如静虑解脱色，及佛菩萨色。五，内色。谓根，及根所居处色。六，外色。谓除根，及 根所居处，余色声香味触。七，所依色。谓眼等五根。八，所缘色。谓五境界，及法处所摄色。九，能取色。谓即所依色。十，所取色。谓即所缘色。十一，执受色。谓受起所依。如诸色根，及根所居处色。心，及心法，所居处故。同一损益。是执受义。十二，无执受色。谓此外余色。十三，同分色。谓自识不空根色。由与识同境转故。十四，彼同分色。谓自识空根色。唯自类相续相似转故。十五，有见有对色。谓色处色。十六，无见有对色。谓余九处色。十七，无见无对色。谓法处所摄色。十八，清净色。谓五内处。十九，清净所取色。谓五外处。二十，意所取色。谓法处所摄色。二十一，所依住色。谓风轮乃至大地。二十二。覆护色。谓宅舍等。二十三，资具色。谓十种资具。一，饮食。二，衣，及庄严具。三，众具。四，戏笑。五，鼓舞。六，歌咏。七，音乐。八，香鬘涂饰。九，众明。十，男女承事。二十四，根所居色。谓五种色根之所居处。二十五，根色。谓五种色根。二十六，等持境界色。《瑜伽论·五十三》云。色蕴差别。略由六种。一，由事故。二，由相故。三，由识执不执故。四，由识空不空故。五，由想所行故。六，由边际故。事者。谓所有诸色。皆是四大种，及四大种所造。相者。略有三种。一，清净色。二，清净所取色。三，意所取色。又变碍相。是色共相。识执不执者。若识依执。名执受色。与此相违。非执受色。识空不空者。若识不空。名同分色。由此与识等义转故。若识空者。名彼同分色。似自相续而随转故。想所行者。谓缘色相。略有三种。一，色想。二，有对想。三，别异想。色想亦三。一，有光影相。二，据方处相。三，积集住相。如是三相。随其次第。三想所行取青等相。名为色想。能取行碍。名有对想。能取男女舍田等假。名别异想。是名想所行差别。边际者。谓色边际。略有二种。一，堕下界。谓欲缠色。二，堕中界。谓色缠色。当知此中就业增上所生诸色。说无色界无有诸色。非就胜定自在色说。何以故。由彼胜定。于一切色皆得自在。诸定加行令现前故。当知此色。名极微细定所生色。又五十四云。色蕴略由六相应知。一，自相。二，共相。三，能依所依相属相。四，受用相。五，业相。六，微细相。自相者。谓地等以坚等（坚、湿、暖、动）为相。眼等以各别清净色为相。共相者。谓一切色皆变碍相。能依所依相属相者。大种为所依。造色是能依。受用相者。谓内色处有所受用增上力故。外色境界差别而生。或有色聚唯有坚生。或唯有湿。或唯有暖。或唯有动。或和合生。为欲随顺内诸色处受用差别故。业相者。谓地等诸大种。以依持、摄受、成熟、增长为相。微细相者。谓极微相。又《集论·一》云。色蕴何相。变现相，是色相。此有二种。一，触对变坏。二，方所示现。云何名为触对变坏。谓由手、足、块石、刀、杖、寒、热、饥、渴、蚊、虻、蛇、蝎，所触对时。即便变坏。云何名为方所示现。谓由方所。可相示现如此如此色。如是如是色。或由定心。或由不定。寻伺相应种种构画。《杂集论·一》云。云何建立色蕴。谓诸所有色。若四大种。及四大种所造。所造者。谓以四大种为生、依、立、持、养，因义。四大种者。地界、水界、火界、风界。（能持自性所造色。故谓之界）。此复云何。谓地坚性。水湿性。火暖性。风轻动性。云大者。有四义。一，为所依故。与诸造色为所依处。二，体性广于造色故。三，形相大故。大地，大水，大火，大风，相状大故。四，起大用故。成坏世界作用大故。种有二义。一，因义。能起众色故。二，类义。种类差别故。四大种为能造性。所造色为所造性。地水火风自性各异。一者。地界。地以坚固为性。谓眼耳鼻舌身等名为地大。若不假水。则不和合。经云。毛发爪齿皮肉筋骨等皆归于地是也。二者。水界。水以润湿为性。谓唾涕津液等名为水大。若不假地。即便流散。经云。唾、涕、脓、血、津、液、涎、沫、痰、泪、精、气、大小便利，皆归于水是也。三者。火界。火以燥热为性。谓身中暖气名为火大。若不假风。则不增长。经云。暖气归火是也。四者。风界。风以动转为性。谓出入息。及身动转。名为风大。此身动作。皆由风转。经云。动转归风是也。
    四大种所造色者。谓依止大种。即于大种处所有所造色生。故曰四大种所造色。摄在一处。名之为造。造者。因义。言以四大种为因。乃生所造色也。因有五。生因，依因，立因，持因，养因也。生因即是起因。谓离大种。此造色不得起故。依因即是转因。谓诸造色不离大种处而转。若舍大种。无别处可住故。立因即是随转因。谓由大种变异。诸所造色亦随之变异故。盖造色与大种同安危。大种坏时。造色亦坏也。持因即是住因。谓由大种执持之力。诸所造色。乃能相似相续而生。不断绝故。养因即是长因。谓由大种养彼造色。令得增长故。由此诸因。生所造色。谓眼耳鼻舌身五根。色声香味四尘。及触一分（触有能触所触。能触中分二。一，触心所法。二，能触身根。所触亦分二。一，能造四大种。二，所造触处。此云一分者。于能所触中。惟取所触一分。所触中惟取所造一分）。无表色等（法处所摄色。亦色蕴摄）。眼根。以色为境。净色为性。耳根。以声为境。净色为性。鼻根。以香为境。净色为性。舌根。以味为境。净色为性。身根。以触为境。净色为性（舌、身二根。净色遍满所依处。眼、耳、鼻三根则仅一分）。色。谓眼之境。显色、形色及表色等。声谓耳之境。执受大种因声。非执受大种因声。俱大种因声。香。谓鼻之境。好香、恶香、平等香。味。谓舌之境。甘、酸、咸、辛、苦、淡等。触一分。谓身之境。滑、湿、重、轻、冷、饥、渴等二十二相。无表色（意识缘于过去所见之境。虽分别明了而无表对。故云无表。虽无所表。于所缘境执著不忘。故云色。其体即善恶之思种子功能。善思种子有防身语恶、发身语善之功能。恶思种子有发身语恶、遮身语善之功能。善恶俱依身语。所以名为色者。以由有质碍之四大所生之法也）。谓有表业（有对无而言。表谓表示。业谓造作）。三摩地，所生无见无对色（诸色略有三种。一，可见有对，如显色等。二，不可见有对。如眼根等。三，不可见无对。如有表业，三摩地，二者所生之色。以无可见，无所对。故云无见无对色）。有表业举身语二表业之自体。何谓自体。能发动之思即是。能动身之思名身业。能动语之思名语业。身语二表。自性虽无记。由思动作。假名善恶。故通善、不善、无记三性（意识所起一切善法之性。曰善性。一切恶法之性。曰恶性。非善非恶不可记别者。曰无记性）。所生色者。举能生以示所生。善，不善，即能生之表业。所生色即无表所生之体。此无表色乃依思之种子上建立（就思之现行位而言谓之业。就思之不现行位而言谓之种子。思有三种。一，审虑思。将发身语。先为审虑之思也。二，决定思。起决定心将作之思也。三，动发胜思。正发身语动作之思也。经三思后所行。名故思业。不经三思所行。名不故思业。故思业有五。一，他所教敕故思造业。如奉命而行者是。二，他所劝请故思造业。如被劝请引导而行者是。三，无所了知故思造业。不知其事后果。无所容心。随意造作者是。四，根本执著故思造业。为贪、嗔等诸不善根缠蔽其心。猛利执著。起造诸业者是。五，颠倒分别故思造业。依颠倒分别之内见。爱乐邪法。为求当来可爱异熟，起造诸业者是。前三及不故思业。不能令种子增长。谓之不增长业。后二定受异熟果。谓之增长业）。故不可显示也。
    三摩地所生色。亦名定果色。定所引色。定自在所生色。法处所摄色之一。
    四大种所造色。一者。可见有对色。如显色形色表色等。二者。不可见有对色。如眼等五根之胜义根。及声香味触四尘。非眼所能见。
    三者。不可见无对色。如无表色等。
    《五事毗婆沙论》云。问依何义故说之为色。答。渐次积集。渐次散坏。种植生长。会遇怨亲。能坏能成。皆是色义。佛说变坏故名为色。变坏即可是恼坏义。有说，变碍故名为色。问。过去、未来、极微、无表。皆无变碍。应不名色。答。彼亦是色。得色相故。过去诸色。虽无变碍。而曾变碍。故立色名。未来诸色。虽无变碍。而当变碍。故立色名。一一极微。虽无变碍。而可积集（众微聚集）。变碍义成。诸无表色。虽无变碍。随所依故。得变碍名。所依者何。谓四大种由彼变碍。无表名色。如树动时。影亦随动（无表依止大种转时。如影依树）。

    二。受蕴。
    受以领纳为义。领纳顺，违，俱非，境相为性。起爱为业。和合积聚。故名为蕴。《广五念蕴论》云。云何受蕴。受有三种。谓苦受。乐受。不苦不乐受。乐受者。谓此灭时。有和合欲。苦受者。谓此生时。有乖离欲。不苦不乐受者。谓无二欲。受以领纳为义者。六根依六触为缘而生六受。眼耳鼻舌身意六识。领纳色声香味触法六尘也。领纳顺境。有适悦之乐。在眼耳鼻舌身之五识领纳者。曰乐受。意识领纳者。曰喜受。领纳逆境。逼迫身心。在眼耳鼻舌身之五识领纳者。曰苦受。意识领纳者。曰忧受。六识领纳不违，不顺，非苦，非乐，平等之境。曰舍受。此五受中。属于前五根者名外受。外受有三。苦受，乐受，舍受也。属于意根者名内受。内受亦有三。忧受，喜受，舍受也。舍受又名不苦不乐受。非违，非顺。非苦，非乐。内受外受。更无二相。又一切苦乐。皆缘受境。乐受于未得乐时。有希合欲。既得乐后有不乖离欲。苦受于未得苦时。有不合欲。既得苦后有乖离欲。惟舍受无此二欲。菩萨观受是苦。以乐受是坏苦。苦受是苦苦。舍受是行苦。众生颠倒。以苦为乐。
    【注】六根依六触为缘而生六受者。《准法蕴足论·九》。谓眼触所生受。耳鼻舌身意触所生受。云何眼触所生受。谓眼及色为缘生眼识。三和合故生触。触为缘故生受。此中眼为增上。色为所缘。眼触为因。眼触为等起（《瑜珈论》云。等起者。谓由三种。若事，若时，若补特伽罗，依处故）。是眼触种类。是眼触所生生。与眼触所生作意相应。于眼识所了别。色，诸受乃至受所摄（诸受。等受。别受。受性。受所摄。是名受蕴）。是名眼触所生受。如是耳鼻舌身意触所生受。广说亦尔。
    《大毗婆沙论·一百十五》略云。受有五种。一，自性受。谓乐受，苦受，不苦不乐受。二，现前受。如《大因缘法门经说》。受乐受时余二受便灭。苦受，不苦不乐受亦尔。应知如是所受。是无常苦灭坏之法。离我（众生所执之假名），我所（五蕴色身）。三，所缘受。如《识身论》说。眼色为缘。生于眼识。三和合故触。触为缘故受。如是乃至意法。广说亦尔。四，相应受。谓乐受相应法。苦受相应法。不苦不乐受相应法。五，异熟受。谓顺乐受业。顺苦受业。顺不苦不乐受业。
    《显扬论·五》云。受蕴建立有六种。一，差别建立。二，出离建立。三，观察建立。四，生建立。五，相建立。六，师句建立。差别建立者。或立一受。如说诸所有受。悉皆是苦。或立二受。谓身受及心受。或立三受。谓乐受，苦受，不苦不乐受。或立四受。谓欲系，色系，无色系，及不系受。或立五受。谓乐根，苦根，喜根，忧根，舍根。或立六受。谓眼触所生受，乃至意触所生受。或立十八受。谓十八意近行。六喜近行。六忧近行。六舍近行。或立三十六受。谓六依耽嗜喜。六依出离喜。如喜忧舍亦尔。或立一百八受。谓三十六受。各依三世。或开无量受。如其所受。起无数受。出离建立者。谓初静虑出离忧根。第二静虑出离苦根。第三静虑出离喜根。第四静虑出离乐根。无相心法三摩地出离舍根。观察建立者。谓八种观察于受。何者是受。何者是受集。何者是受灭。何者是趣受集行。何者是趣受灭行。何者是受味。何者是受过。何者是受出离。生建立者。谓从十六触诸受生。何等十六。一，眼触。二，耳触。三，鼻触。四，舌触。五，身触。六，意触。七，有对触。八，增语触。九，顺乐受触。十，顺苦受触。十一，顺不苦不乐受触。十二，爱触。十三，恚触。十四，明触。十五，无明触。十六。非明非无明触。相建立者。谓八种相。一，异熟相。二，非异熟相。三，有味著相。四，无味著相。五，依耽嗜相。六，依出离相。七，动相。八，住相。异熟相者。谓阿赖耶识相应受。非异熟相者。谓转识相应受。有味著相者。谓欲系受。无味著相者。谓色无色系及不系受。依耽嗜相者。谓欲贪相应受。依出离相者。谓出家所引不定地善法相应受。动相者。谓经中风喻所显受。住相者，谓经中客舍喻所显受。暂相续住义故。师句建立者。谓三十六师句。六依耽嗜喜。六依出离喜。六依耽嗜忧。六依出离忧。六依耽嗜舍。六依出离舍。《瑜伽论·五十三》云。受蕴差别。略由五种。一，由事故。二，由相故。三，由生故。四，由观察故。五，由出离故，事者。谓领纳及顺领纳法。相者。谓自相及共相。自相有三。乐受。苦受。不苦不乐受。乐受坏苦故苦。苦受苦苦故苦。不苦不乐受行苦故苦。由此因缘。诸所有受。皆说名苦。是名受共相。生者。谓一切受。十六触所生。何等十六。谓眼触。耳触。鼻触。舌触。身触。意触。有对触。增语触。顺乐受触。顺苦受触。顺不苦不乐受触。爱触。恚触。明触。无明触。非明非无明触。由所依及所取境故。建立六触。及有对触。由分别境故。建立增语触。由领纳境故。建立顺乐受等触。由染净故。建立爱，恚，明，无明。非明非无明触。是名受生差别。观察差别者。一切如来应正等觉，出现世间。皆于诸受起八种观。谓受有几种。谁为受集。谁为受灭。谁是受集趣行。谁是受灭趣行。谁是受爱味。谁是受过患。谁是受出离。如是观时。如实了知受有三种。触集故受集。应知。如经分别广说。如是八种观察诸受。当知略显自相观。现法转因观。彼灭观。后法转因观。彼灭观。彼二转因观。彼二转灭因观。及清净观。是名观察差别。出离者。谓初静虑。出离忧根。第二静虑。出离苦根。第三静虑。出离喜根。第四静虑。出离乐根。于无想界。出离舍根。是名出离差别。
    《法蕴足论·九》云。云何受蕴。谓诸受。等受。别受。受性。受所摄。是名受蕴。复有二受。说名受蕴。谓身受。心受。云何身受。谓五识身相应诸受。乃至受所摄。是名身受。云何心受。谓意识相应诸受。乃至受所摄。是名心受。复有二受。说名受蕴。谓有味受。无味受。云何有味受。谓有漏作意相应诸受。乃至受所摄。是名有味受。云何无味受。谓无漏作意相应俱受。乃至受所摄。是名无味受。有作是说。欲界作意相应受。名有味受。色无色界作意相应受。名无味受。今此义中。有漏作意相应受。名有味受。无漏作意相应受。名无味受。如有味受。无味受。如是堕受。不堕受。耽嗜依受。出离依受。顺结受。不顺结受。顺取受。不顺取受。顺缠受。不顺缠受。世间受。出世间受。亦尔。复有三受。说名受蕴。谓乐受。苦受。不苦不乐受。云何乐受。谓顺乐触所生身乐，心乐，平等受受所摄。是名乐受。复次修初，第二，第三，静虑。顺乐触所起心乐。平等受受所摄。是名乐受。云何苦受。谓顺苦触所生身苦，心苦。不平等受受所摄。是名苦受。云何不苦不乐受。谓顺不苦不乐触所生身舍心舍。非平等非不平等受受所摄。是名不苦不乐受。复次。修未至定静虑中间。第四静虑。及无色定。顺不苦不乐触所生心舍。非平等非不平等受受所摄。是名不苦不乐受。复有四受。说名受蕴。谓欲界受。色界受。无色界受。不系受。云何欲界受。谓欲界作意相应诸受。乃至受所摄。是名欲界受。云何色界受。谓色界作意相应诸受。乃至受所摄。是名色界受。云何无色界受。谓无色界作意相应诸受。乃至受所摄。是名无色界受。云何不系受。诸无漏作意相应诸受。乃至受所摄。是名不系受。复有五受。说名受蕴。谓乐受。苦受。喜受。忧受。舍受。如是五受。广说如根品（顺乐触所生身乐心乐。平等受受所摄。修第三静虑顺乐触所生心乐。平等受受所摄。顺苦触所生身苦。不平等受受所摄。顺喜触所生心喜。平等受受所摄。修初二静虑顺喜触所生心喜。平等受受所摄。顺忧触所生心忧。不平等受受所摄。顺舍触所生身舍，心舍。非平等非不平等受受所摄。修未至定静虑中间。第四静虑及无色定。顺不苦不乐触所生心舍。非平等非不平等受受所摄）。复有六受。说为受蕴。谓眼触所生受。耳鼻舌身意触所生受。云何眼触所生受。谓眼及色为缘。生眼识。三和合故。生触。触为缘故。生受。此中眼为增上。色为所缘。眼触为因。眼触为等起。是眼触种类。是眼触所生生。与眼触所生作意相应。于眼识所了别色，诸受，乃至受所摄。是名眼触所生受。如是耳鼻舌身意触所生受。广说亦尔。

    三。想蕴。
    想者。取像之义。于境取像为性。施设种种名言为业。根尘相对而成六想。和合积聚。故名为蕴。《广五蕴论》云。云何想蕴。谓能增胜。取诸境相。故五蕴之想。专指有相想而言。
    【注】眼根对色。与识相应。而起色想。为眼触所生想。耳根对声。与识相应，而起声想。为耳触所生想。鼻根闻香。与识相应。而起香想。为鼻触所生想。舌根尝味。与识相应。而起味想。为舌触所生想。身根觉触。与识相应，而起触想。为身触所生想。意根分别诸法。与识相应，而起法想。为意触所生想。谓之六想。
    有相想者。能取诸境界。随起言说。而具明了，及分别，二相状。无相想者。于能缘所缘。或阙分别。或阙明了。或二者共阙。如婴孩未学语言。虽于色起想。而不能了此名为色也。
    《显扬论·五》云。想蕴建立有三种。一，依差别。二，作意差别。三，境界差别。依差别者。谓六想身。眼触所生想。乃至意触所生想。作意差别者。有二种。一，有相想。二，无相想。有相想者。谓除欲界中未善言说者想，第一有想，及出世间想。余有相作意相应想。无相想者。谓前所除无相作意相应想。境界差别者。有四种。一，小想。二，大想。三，无量想。四，无所有想。如其次第。缘欲界，缘色界，缘无色界，缘无所有处想。《瑜伽论·五十三》云。想蕴差别。略有五种。一，由事故。二，由相故。三，由颠倒故。四，由无颠倒故。五，由分别故。事者。谓取所缘相及随顺彼法。相者。自相有六种。一，有相想（即三、四、五、六之总称）。二，无相想（有顶想，及一切出世间学，无学，想）。三，狭小想（欲）。四，广大想（色）。五，无量想（空，识，无边处）。六，无所有想（无所有处）。一切想皆等了相。等了相是共相。是名相差别。颠倒差别者。谓诸愚夫。无所知晓。随逐无明。起不如理作意。于所缘境，无常计常。取相而转。是名想倒。如于无常计常。于苦计乐。于不净计净。于无我计我。此想颠倒。诸在家者。能发心倒。一分出家者。能发见倒。是名颠倒差别。此想颠倒。复有差别。谓于四事。邪取其相。是名颠倒。若由如是等了相故。于境贪著。是名心倒。若由如是等了相故。有执著者。于颠倒事。坚执忍可。开示建立。是名见倒。无颠倒差别者。谓诸聪睿，随智慧明，起如理作意。于所缘境。无常，知无常。苦，知苦。不净，知不净。无我，知无我。正取相转。是名想无颠倒。心无颠倒。见无颠倒。是名无颠倒差别。分别差别者。略有五种想分别相。一，境界分别。二，领纳分别。三，假设分别。四，虚妄分别。五，实义分别。若于境界。取随味相。名境界分别。执取境界所生诸受。名领纳分别。若于自他取如是名，如是类，如是性等种种世俗言说相。名假设分别。于诸境界取颠倒相。名虚妄分别。于诸境界取无倒相。名实义分别。如是总名想蕴分别差别。

    四。行蕴。
    行者。造作之义。谓思为主。令心造作善恶诸行。身行、语行、意行皆是。《广五蕴论》云。云何行蕴。谓除受、想，诸余心法及不相应行。即意识思惟尘境造作善恶行业。五十一心所有法中。除受、想二蕴外。余四十九法及二十四不相应行法皆是。和合积聚故名为蕴。
    【注】《大乘义章》云。有为集起。目之为行。又云。内心涉境。说名为行。又云。起作名行。《俱舍论》云。行名造作。《法界次第》云。造作之心。能趣于果名行。
    行蕴有二。一，一分心相应行。即除受、想之四十九心法。二，心不相应行。即二十四不相应行。受、想二心法。本在遍行五心法中。今别立二蕴。故云除受、想诸余心法。即五十一心法中除受、想二者。其余之四十九心法也。
    《显扬论·五》云。行蕴建立有三种。一，胜差别。二，依差别。三，诸行施设差别。胜差别者。惟思最胜。行蕴所摄。由造作心，令成杂染及清净法转故。依差别者。谓六思身。眼触所生思。乃至意触所生思。诸行施设差别者。有三种。一，杂染施设。二，清净施设。三，分位施设。杂染施设者。谓烦恼及随烦恼。清净施设者。谓信等。分位施设者。谓生等心不相应行。《瑜伽论·五十三》云。行蕴差别亦由五相。一，由境界故。二，由分位故。三，由杂染故。四，由清净故。五，由造作故。由境界者。谓于行蕴立六思身。由分位者。谓立生等不相应行。由彼生等，惟有分位所显现故。由杂染者。谓于杂染诸行。建立烦恼及随烦恼。由清净者。谓于清净诸行。建立信等。由造作者。谓如前说五造作相，为境随与等。
    《准百法明门论》《大乘百法》约为五门。一者。色法十有一。眼鼻耳鼻舌身五根。色声香味触五境。及法处所摄一分色是（法处是意所取之境。具有四分。一，心所法。二，不相应行。三，无为。四，无表色。此云法处所摄一分色者。无表色也）。二者。心法八。即识也。眼，耳鼻舌身意末那，及阿赖耶之八识是。三者。心所有法五十有一。分六位。第一。遍行法五。一，作意（相应于心而起于所缘境。引心为业）。心未起，警之令起。已起，引之趣境。二，触。根境识三者和合之结果也。三，受。领纳前境也。四，想。于境取像也。五，思。令心造作意业。趋所缘之境也（《大般若经》说为六思。思即是业。六思之后。各起善不善无动业。即名为行。《成唯识论》云。思谓令心造作为性。于善品等役心为业。《界身足论》云。思云何。谓思、等思、现思、已思、当思、思所摄。造心意业。是名为思。《品类足论》云。思云何。谓思、等思、增上等思、已思、思类、心作意业，是名为思）。此五种法。周遍一切善、不善、无记性而起。故名遍行。第二。别境法五。一，欲。于爱乐事起希望也。二，胜解。于决定境，如所了知，决定印可也。三，念。于曾习事记忆不忘也。四，三摩地。此云等持。于所观境。制心一处。专注不散也。故亦名定。五，慧。于所观境善、恶、无记性。就诸法自相或共相为简择也。定于所观境专注。慧于所观境简择。此五法以爱乐、决定、曾习、所观四境为所缘。欲、胜解、念、定、慧为能缘。一一差别而起。故曰别境。第三。善法十一。一，信。于业、果、谛、宝等。深正符顺生净信也（业谓身口意三业。作善感欲界人天果报为福业。作恶感欲界恶趣果报为非福业。修世间禅。感色、无色界、定地果报为不动业。果即四果。初果须陀洹。此言入流。入圣道之流也。二果斯陀含。此言一往来。由人生天，由天还人，一往来也。三果阿那含。此言不还。悉断欲界诸惑。更不还生也。四果阿罗汉。此言善生。烦恼悉破，更不受生死果报也。谛即苦集灭道四谛。宝为佛法僧三宝）。二，惭。谓自增上及法增上羞已过失也。三，愧。谓他增上羞已过失也（自增上者。自重自尊义。法增上者。尊重善法义。他增上者。怖畏责罚或讥评义）。四，无贪。谓对于有情世间，器世间不生爱著。不但三界有漏因果。即无漏涅槃亦不生爱著也。五，无嗔。于诸有情慈愍为怀，不加损害也。六，无痴。修行如实正行。了知四谛，十二因缘，对治无明也。七，精进。勤勇修持。进善，断恶，不退转也。八，轻安。身心调畅。弃舍身三，口四，意三，十不善行。除二障也（身三，即杀、盗、淫。口四。妄语、恶口、两舌、绮语。意三。贪、嗔、邪见。二障。即所知障、烦恼障）。九，不放逸。谓于无贪、无痴、无嗔、精进四法。断恶修善也。十，舍。修持无贪、无嗔、无痴、精进四法。远离惛沈、掉举及诸杂染。平等正直。委心任运。一切放下也。十一，不害。悲心独运。拔群生苦也。第四。烦恼法六。一，贪。谓于五取蕴（《集论·一》云。何故名取蕴。以取合故。名为取蕴。何等为取。谓诸蕴中所有欲贪。何故欲贪说名为取。谓于未来、现在诸蕴。能引不舍故，希求未来，染著现在，欲贪。名取）。染爱耽著，为所缠缚。轮回三界。增长烦恼也。二，嗔。即嗔恚。身口二业为嗔。意业为恚。损害有情。自住于苦也。三，慢。其心高举。于尊者有德倨傲不敬也（心高举为其总性。差别之有七种，慢，谓于劣者视己胜之。于相同者计己相等也。过慢。谓相等者计己己胜之。于胜者计己与相等也。过过慢。谓于胜己者视己犹胜之也。我慢。执五取蕴为我，或我所，而起慢也。增上慢。谓未得增上殊胜之法自谓已得也。卑慢。谓于多分殊胜。自视歉然。以为未足也。邪慢。己实无德。自谓殊胜也）。四，无明。痴愚昏闇障理之惑也。五，见。凡五。萨迦耶见。于五取蕴随执为我，或我所也。边执见。执于一边，障碍中道。见解鄙陋。障碍胜行也。邪见。谓谤因果，或谤作用，或坏善事也。见取。摄取以上三见及所依蕴，以为最胜也。戒禁取，随顺诸见戒禁，及所依蕴，执为最胜。取非理之戒法。于有漏法取为能净，此复有二。一者。非因计因。如持牛戒，鸡戒，以为生天之因者是。二者。非道计道。如修涂灰、断食、自拔发等种种苦行。以为涅槃之道者是。六，疑。怀疑四谛、三宝诸法。犹豫不决也。第五，随烦恼法二十。一，忿。对于现前违逆，显发暴恶也。二，恨。追怀已往之忿，结怨不舍也。三，覆。隐匿己过，不使发露也。四，恼。暴语凌人，自心忧苦也。五，嫉妒。忌他人名利也。六，悭。执著利养，吝惜不施也。七，诳。心怀虚妄，矫现功德，惑乱视听也。八，谄。矫饰恭敬，曲心媚人也。九，憍。自恃有漏盛事。染著倨傲也。十，害。于诸有情心无悲悯，横加损害也。以上十种。皆各别而起。非二法并生。其行最狭。名小随惑。十一，无惭。所作罪恶，不知羞耻也。十二，无愧。所作罪恶，受责不羞也。以上二法能并生。然惟遍于不善性。不通一切染污法。名中随惑。十三，惛沈。心神蒙昧，于境不堪任也。十四，掉举。忆念乐境，嚣动不静也。十五，不信。陷于邪见，不信业、果、谛、宝诸法实德也。十六，懈怠。于诸善行懒惰不进也。十七，放逸。于诸烦恼不断，于诸善品不修也。十八，失念。染污念胜，于诸善法不能明记也。十九，散乱。因贪嗔痴心神流散昏乱。障碍正定也。二十，不正知。于所观境，不能正确观察，起不正身语意行也。以上八种。既得俱起。又遍于一切染污法。故名大随惑。第六。不定法四。云不定者。以通于善、恶、无记三性也。一，恶作。嫌恶所作之业。心生变悔。变者。造作之心。悔者。追悔也。此有善，不善二位。二位之中。复各有二。先不作善，后起悔心。及先已作恶，后起悔心。属于善位。先不作恶，后起悔心。先已作善，后起悔心。此属于不善位。二，睡眠。闇昧轻略。令心，心所，不自在转也。坐寐曰睡。安寝曰眠。睡眠时五识皆不行。而意识独转。与定相同。惟定中能观察诸法自相。睡眠则意识闇昧。此通三性。无梦，时属无记性。善梦属善。恶梦属恶。三，寻。依思、慧分别寻求，推度，诸法粗相。云分别者。依思寻求则不能推度。依慧寻求则能推度也。四，伺，伺者。伺察义，与寻同。惟寻主粗相。伺主细相耳。上来五十一种。皆从阿赖耶识种子所生。依心所起。与心俱转相应故。故名心所有法。四者。不相应行法二十有四。一，得。获也。成就也。于物曰获。于事曰成就。此复有三。谓种子成就。自在成就。现起成就也（种子成就。自在成就。是种子所得。现起成就。是现行所得。成就即得之总相）。如其所应。种子成就者。谓诸法虽不现行，而种子早已具足，故云成就。如凡夫身中成就三无漏根（一。未知当知根。谓诸学者未得现观，未得圣果，之信，精进，念，定，慧五根也。二，已知当知根。谓诸学者已得现观，已得圣果，之五根也。三，具知根。谓诸无学，若阿罗汉，独觉，十地菩萨，如来，应，正等觉之五根也）。种子也。自在成就者。谓依定通自在力成就非分法。如依定力变土木为金宝是也。现起成就者。谓正成一切现行法。如身在欲界。则成欲界法。若身在欲界。已能离欲界染时。则已成以上界之现行法也。二，无想定。谓诸外道以想念为生死根本。故以灭想念为得涅槃。先在人中修无想定。已伏色界第三禅俱生烦恼。但仍为有漏定。未离第四禅以上之染。仅可生四禅无想天。三，灭尽定。亦名灭受想定。心无所缘烦恼不生之无漏定也（二乘，独觉，三果，四果，皆入此定。菩萨于此定已得自在而不现入）。四，无想天。即色界四禅之第四天。为无想定所得之果。五，命根。谓第八识种子。由先世业为所引，能生住识功能。于众生共同之五蕴分位上。有执持一期心身不坏之力（种子如无住识功能。肉身即坏。有一定分限。故曰一期）。六，众同分。谓五趣（天、人、鬼、畜、地狱）有情，各有种类。同类相望。就其五蕴和合身形彼此相似之分位。七，生。谓众同分所有诸行自无而有也。八，老。谓众同分所有诸行相续变坏也。九，住。谓众同分所有诸行相续随转也。十，无常。谓众同分所有诸行相续谢灭也（四相迁流。刹那不停。故曰相续。本无今有曰生。有后暂用曰住。渐入衰废曰老。由有归无曰无常）。十一，名身。身者。积聚。依事立名。众名联合。诸法自性。由名而诠显者谓之名身。如心为一名。经为一名。两名和合成心经一名是。十二，句身。积言成句。二句以上联合。诸法差别。因以诠显也。如云诸行无常是生灭相。诸行是诸法。无常是差别。诸行无常为句。合诸行无常，是生灭相，为句身。十三，文身。文即字。联合二字以上表显了达其所有事义。谓之文身。即名身与句身所依之文字也（名身诠自性。句身诠差别。文身则仅为名句之所依而已）。十四，异生性。五趣四生。未得无漏圣道。各各差异之本性也。十五，流转。因果相续。流转不断也。十六，定异，善恶因果决定不同也。十七，相应（契合义。梵语瑜伽。此云相应。分为三。一，境瑜伽。二，行瑜珈。三，果瑜伽。境与行果。行与果境并有相应之义）。因果和合不相违背也。十八，势速。诸法迁流。不暂停住也。十九，次第。编列有序也。二十，时。时节也。二十一，方。方所也。二十二，数。数目也。二十三，和合。不相乖违也。二十四，不和合。互相乖违也。此二十四法有名无体。不与色法、心法及心所有法相应。故曰不相应行法。五者。无为法六。一，虚空无为。真空之理。离诸障碍。有如虚空。无所作为也。二，择灭无为。择即拣择。灭即断灭。以智灭惑。所显真理。无所作为也。三，非择灭无为。不假智力。断灭诸惑。性本清净。无所作为也。四，不动无为。第四禅天得不动地所修出世之理。无所作为也。五，受想灭无为。受想心灭。所显真理。无所作为也。六，真如无为。不妄曰真。不异曰如。真如之理。无所作为也。以上色法，心法，心所有法，及不相应行法。皆是世间有为之法。无为法为出世间法。然百法不出乎色心。而色由心造。摄末归本。唯心一法而已。故曰。三界唯心。又《准俱舍论》。小乘立一切法为七十五。摄为五类。一者。色法十有一。五根，五境，及无表色（依身口意发动之善恶二业。生于身内之无形色法。感苦乐果之业因也）。根境有质碍之用。故名色。无表色自体虽无质碍之用。以有质碍之四大为因而生。故亦名为色。二者。心法一。根境相对时。依根生了别境之总作用也。此一。心法。有心、意、识三名。梵语质多。此云心。是集起义。梵语末那。此云意。是思虑义。梵语毗惹南。此云识。是了别义。此一心法对所缘境惟取总相。必领有他之心所法。故对心所而言。名曰心王。以对境有六种差别。故心王亦有六种差别。即眼耳鼻舌身意六识。六识中前五。唯有自性分别（如眼识识别色。耳识识别声）。意识则除自性分别外。尚有计度分别（散心意识相应智慧。于过、现、未，不现见事。计较量度也）。随念分别（若散若定意识相应诸念。忆念分别过去等境也）。三者。心所有法四十六，又分六位。一，遍大地法十。受想思触欲慧念，作意，胜解，三摩地。遍善恶无记等一切心故名大。所依行处（心王）故曰地。二，大善地法十。信、不放逸、轻安、舍、惭、愧、无贪、无嗔、不害、勤。遍与一切善心相应俱起。故名大善地法。三，大烦恼地法六。无明（痴）、放逸、懈怠、不信、惛沈、掉举。遍与一切染心相应而起，故名大烦恼地法。四，大不善地法二。无惭。无愧。遍与一切不善心相应俱起。故名大不善地法。五，小烦恼地法十。忿覆悭嫉恼害恨谄诳憍。此十法虽与恶心，及有覆无记心，相应而起。惟为修道所断。不通于见道所断。与意识之无明相应。不通他识且各别现行。而非十法俱起。故名小烦恼地法。六，不定地法八。寻、伺、睡眠、恶作、贪、嗔、慢、疑。此八法遍善、恶、无记三性。而又非若大地法之定遍一切心而起。故名不定地法。四者。心不相应行法十四。得，非得，同分（能令有情展转类等。名有情同分。能令蕴处界法自类相似。名法同分），无想果（即百法中之无想天），无想定，灭尽定，命根，生，住，异，灭，名身，句身，文身，五者。无为法三。虚空无为。择灭无为。非择灭无为也。
    《集论》云。云何建立行蕴。谓六思身。眼触所生思。耳触所生思。鼻触所生思。舌触所生思。身触所生思。意触所生思。由此思故。思作诸善。思作杂染。思作分位差别。又即此思。除受及想。凡余心所法及心不相应行。总名行蕴。又云。行蕴何相。造作相是行相。谓由行故。令心造作。于善、不善、无记品中驱役心故。

    五。识蕴。

    识者。了别之义。对于种种尘境。照了分别谓之为识。和合积聚。故名为蕴。《广五蕴论》云。云何识蕴。谓于所缘了别为性。亦名心。能采集故。亦名意。意所摄故。若最胜心。即阿赖耶识。能采集诸行种子故。八识心王。总名识蕴。一者。眼识。眼与色为缘而生识。识依根而生。根因识能见。此能见者名为眼识。二者。耳识。耳与声为缘而生识。识依根而生。根因识能听。此能听者名为耳识。三者。鼻识。鼻与香为缘而生识。识依根而生。根因识能嗅。此能嗅者名为鼻识。四者。舌识。舌与味为缘而生识。识依根而生。根因识能尝。此能尝者名为舌识。五者。身识。身与触为缘而生识。识依根而生。根因识能觉。此能觉者名为身识。六者。意识。意以法为缘而生识。识依根而生。根因识而能分别前五根所缘之五尘境界。分别六尘。名为意识。亦名分离识。以依于六根同取六尘故。与第七识均为分别事识。以能分别过去、未来、现在种种事相故。七者。末那识。末那者。梵语。具足应云讫利瑟吒耶末那。义为我执。为一切众生妄惑之根本。亦作染污意。谓我痴、我见、我慢、我爱四惑常与之俱也。又名相续识。以无始以来无间断故。又名分别识。以依于六尘诸境传送第六识令起分别也。以其恒审思量。亦名曰意。但与第六之意识不同。第六识从根得名。此识则依其思量之本能而得号。盖此识本无定体。即第八识之染分依第八识自证分而生。缘第八识见分而执为我。第六识虽能分别所缘尘境好恶。而传送、相续、执取，以成染净。则全由此识主之。八者。阿赖耶识。梁真谛三藏译作无没识。谓一切种子无所隐没也。奘师译作藏识。以其无法不含。无事不摄，含藏一切事物种子也。有能藏、所藏、执藏义故。此识染净同源。不生灭与生灭和合。体具三藏。性含四分。如摩尼珠。体本清净。又如明镜。能含万象。亦名宅识。以诸蕴于此中生。于此中灭。为一切种子所栖处故。亦名阿陀那识。阿陀那此云执持。以执持诸法种子，及诸识根，令不坏故。亦名种子识。以此识自证分能普遍执持有漏无漏诸种子故。亦名异熟识。能引生死、善、不善业异熟果故。亦名根本识。为一切法之根本，是诸识所依故。亦名现识。诸法皆于本识上现故。亦名心。以积集诸法种子，又生起现行故。亦名所知依。以能于染净所知诸法为依止故。亦名果报识。从种子生故。亦名有分识。分者因义。三有之因。皆由此识故。亦名穷生死蕴。此识遍三界九地有生死处，即常遍为依。直至大乘金刚心末，烦恼尽时方舍故。亦名第八识。七后得名故。亦名第一识。从本向末，数为第一故。亦名显识。显现诸法故。总之此识从染分言。则无明依之而起。结业由之而生。具足烦恼尘劳。变现根身世界。若以净体言之。则本觉心源。离念清净。在圣不增。在凡不减。为诸识中之根本。第一识至第七识为转识。第八识为本识。本者根本义。转者不定义。谓三性，三量，三境，易脱不定故。
    八识之外。梁真谛三藏更立第九识曰庵摩罗识。译作清净识。亦曰白净无垢识。乃一切众生清净本源心地。诸佛如来所证法身之果德。非生死之能羁。非涅槃之能寂。染净俱泯。纤尘不立。明同皎月。湛若太虚。是为真如。《密严经》曰。赖耶有可得。解脱是非常。如来清净藏。亦名无垢智。意亦同此。以出障故。不同异熟也。奘师译经不立此识。诸佛如来。常以正觉转诸识入庵摩罗。盖众生本有之性。其果位即庵摩罗识。为阿赖耶识之净体。阿赖耶识去妄存真。至我见永不起位。即成庵摩罗识。不须别立此识也。
    【注】就通义说。八识总可名心。因虑知，依止，了别，诸义为八识所通具。故曰八识总名心。就别义说。则集起名心。第八识积集识心诸法种子。生起诸法。惟第八识始可名心。思量名意。第七识缘所缘境恒审思量。当名为意。了别名识。前六识对六境粗相辨别了解。当名为识。《唯识论》云。集起故名心。思量故名意。了别故名识。又云。心意识，一法异名。对数名心。能生名意。分别名识。又前起为心。次起为意。后了为识。
    意所缘为法尘。诠云分别六尘者。盖意识外依五根，与五识，同时而起。亦得缘外五尘境界。《起信论》云。凡夫取著转深。计我我所。分别六尘。名为意识。
    我痴即无明。愚于我相迷无我理也。
    我见者。不知此身为五蕴等法假合而成。妄执为我强立主宰也。凡夫计我为人。名人我见。二乘计一切法各有体性。怖畏生死。迷于法执。名法我见。
    我慢者。倨慢执我。令心高举也。
    我爱者。妄执己身为我。深生耽著也。
    第六识依意根了别得名。即依意之识。故曰从根得名。第七识以第八识之见分为本质。自于识上别变相分。为第六识之所依。恒审思量。执我不舍。故曰依其思量之本能而得号。梵语末那。此云意。以简别第六识故。故仍梵名。《显扬论·一》云。意者谓从阿赖耶识种子所生。还缘彼识我痴、我爱、我、我所执、我慢相应。于一切时恃举为行或平等行。与彼俱转，了别为性。如薄伽梵说。内意处不坏。外法处现前。及彼所生作意正起。如是所生意识得生。《瑜伽论·一》云。意谓恒行意。及六识身无间灭意。初唯第七识。由具思量依止二义。说名为意。后通余识。但由依止名意。又六十三云末那名意。于一切时执我我所及我慢等。思量为性。《成唯识论·四》略云。此名何异第六意识。此持业释。如藏识名。识即意故。彼依主释。如眼识等。识异意故。然诸圣教。恐此滥彼。故于第七。但立意名。或欲显此与彼意识为近所依。故但名意。
    染分者。我痴我爱我见我慢四惑之自证分也。
    传送者。递转义。
    相续者。于爱境生乐。不爱境生苦。觉心起念。相应不断也。《俱舍论》云。何名相续。谓因果性。
    执取者。缘念苦乐等境心起执著也。
    第八识各种异名。无没识。宅识。见《无相论》。藏识。见《六波罗蜜多经》。根本识。见《增一阿含经》。果报识。见《摄大乘论》。有分识。小乘上座部说。穷生死蕴。小乘化地部说。见《宗镜录》。现识。见《楞伽经》。第一识。第八识。见《了义灯》。显识。见《显识论》。《唯识论》第八识七名。曰心。曰阿陀那。曰种子识。曰所知依。等名。通一切位。曰阿赖耶。惟限于异生及有学诸位。因八地以上菩萨。及二乘无学。断此识中烦恼尽故。不复执藏此识为自内我。永舍赖耶之名（非舍八识本体）。曰异熟识。通于异生二乘菩萨诸位。曰庵摩罗识。则惟如来果地方得称之。
    体具三藏者。一，能藏。即能含藏义。犹如库藏，能含藏宝贝。此能含藏杂染种。故名为藏。亦即持义。二，所藏。即所依义。犹如库藏。是宝等所依故。此识藏自体于诸法。故于诸法上见妄想。是杂染法所依处故。三，执藏。坚守不舍义。犹如金银等藏。为人坚守。执为自内我。此识为染末那坚执为我。故名为藏。
    性含四分者。一，相分。相即形相。谓此识能变现根身世界。及诸法名义相状。皆由此分而生。如镜中所现之影像也。二，见分。见即照了之义。谓此识能照烛一切诸法及其义理。如镜中之明。能照万象也。三，自证分。自证所具之法。谓此识能持见分相分亲证无碍。如镜之圆体。能持其明。能含万象也。四，证自证分。证即能证之体。自证即所具之法。能持前自证分，见分，相分，皆不离此分。是第八识本体。如镜之背也。或以自证分、证自证分二者合称为自体分。《成唯识论》云。如是四分。或摄为三。第四摄入自证分故。或摄为二。后三俱是能缘性故。皆见分摄。此言见者。是能缘义。或摄为一。体无别故。如入楞伽伽他中说。盖唯识四师。所立不同。安慧惟立一自证分。难陀立相、见二分。陈那于相、见二分外，加自证分为三分。此云四分者。护法所立也。
    阿陀那义为执持。一，执持诸法种子令不散失。二，执持有情根身令不坏烂。三，执取结生（由中有没而托生于母胎。谓之结生。《俱舍论》云。时健达缚于二心中随一现行。谓爱或恚。彼由此起二种倒心。便谓己身与所爱合。所憎不净泄至胎时。谓是己有。心生喜慰。中有便没。生有起已。名已结生）相续（因果次第不断也。《俱舍论·四》云。何名相续。谓因果性）。此识真谛三藏名之为第七识。以别取第八识之染分立名也。《唯识百法》谓之第八识。通取染净和合为目也。《解深密经》谓之第九识。即庵摩罗识。别取第八识之净分立名也。故陀那一名。实通三识。《楞严经》曰。陀那微细识。习气成暴流。真非真恐迷。我常不开演。是知此识实含染净二分。通乎真妄。故本诠从唯识列为第八识之异名。《深密解脱经·一》曰。彼识名阿陀那识。以彼阿陀那识。取此身相应身故。亦名阿梨耶识。以彼身中住著故。一体相应故。
    阿赖耶识为遍计依他圆成三性所知法之所依。故又名所知依（《俱舍论》云。眼所现见。名为所见。从他传闻。名为所闻。自运己心之所思构。名为所受。自内所受及自所证。名为所知）。
    本觉心源。离念清净云者。《仁王经》曰。自性清净。名本觉性。《起信论》云。心体离念。离念相者。等虚空界。无所不遍。法界一相。即是如来平等法身。依此法身。说名本觉。本觉心源之体。从真起妄而成不觉。返妄归真。本觉体显。是名始觉。依本觉故而有不觉。依不觉故而有始觉。盖一切众生本性之自性清净心。本具照明之德。是名本觉。因无明之熏动而成不觉。由本觉内熏（无漏法性。冥冥熏习。令众生厌生死苦。自信己身有真如法。发心修行。是为自体相熏习）。外缘修治（自法身立报身化身。使众生成见佛闻法之外缘。得修治以复其初。是为用熏习。体相二大为内熏之因。用大为外缘修治所资）。渐生觉悟。谓之始觉。始觉者。如凡夫觉知前念起恶。能止后念令其不起。虽复名觉。以觉业不觉惑。仍名不觉。二乘初发意菩萨等。觉于念异。念无异相。以舍粗分别执著相。故虽未真证。而似于真。名相似觉。法身菩萨等（初地乃至九地）。觉于念住。念无住相。以离分别粗念相故。随觉一分法性之理。觉道未圆。名随分觉。菩萨地尽（十地并摄等觉）。满足方便。一念相应。觉心初起。心无初相。以远离微细念故。得见心性。心即常住。名究竟觉（心无初相。即谓无念。缘众生从本以来。念念相续。未尝离念。故云无始无明。若得无念。则心源湛寂。本无生灭。所谓一念不起。即十八界空。即身便是菩提华果。即身便是灵台。瞥起一念便是境。若无一念。便是境忘心自灭）。复次。本觉随染分别。名随染本觉。觉体相者。名性净本觉。详见《起信论》。
    三性者。一，善性。谓第六识所起一切善法之性。世间善如五常十戒等。出世间善如六度四弘誓愿（菩萨广发誓愿。内制其心志求满足也。一，众生无边誓愿度。此依苦谛境发誓。菩萨遍观六道众生。无量无边。皆被生死诸苦所逼。欲度脱之。令出三界。二，烦恼无尽誓愿断。此依集谛境发誓。菩萨谛审烦恼惑业。无量无边。招集生死苦果。流转三界。无有穷尽。立愿断除。使六道众生。亦悉断除。令出三界。三，法门无量誓愿学。此依道谛境发誓。菩萨谛审一切道法。无穷无尽。自既修学。亦令一切众生修学。四，佛道无上誓愿成。此依灭谛境发誓。菩萨谛审菩提之果。最胜无上。自成就已。普愿一切众生咸皆成就）等。二，恶性。谓第六识所起一切恶法之性。如五逆十恶等。三，无记性。谓第六识所起无善无恶之性。更分为二。一，有覆无记。妄惑之势用微弱。虽无违损自他之力。然其体为妄惑。蘟覆圣道。又与此惑障俱者。谓之有覆无记。二，无覆无记。体非妄惑。又非与妄惑俱之法。其自性微弱。曾无损益自他。谓之无覆无记。
    三量者。一，现量。二，比量。三，非量。现量者。现谓显现。即分明证境。无筹度心。亲得法体。离妄分别。名之为现。言量者。量度。是楷定之义。谓心于境上楷定法之自体。不错谬故。如镜对物。现前明了。眼识于色。耳识于声。皆是。比量者。比即比类。量即量度。以比类量度而知。故名比量。于不现显之境。藉已知者比类量度而得也。非量者。谓心缘境时。于境错乱。虚妄分别。不能正知。于非量处而起心量。境不称心。故名非量。如见阳焰而指为水是也。《显扬论》云。现量者。有三种相。一，非不现见相。二，非思构所成相。三，非错乱所见相。比量者。此复五种。一，相比量。谓随其所有相貌相属。或由现在及先所推度境界。如见幢比知有车。见烟比知有火。二，体比量。由现见彼自体性。故比类彼物不现见体。或现见彼一分自体。比类余分。如以现在比类去来等。三，业比量。谓以作用比业所依。如见远物无有动摇。鸟集其上。比知是杌。若有动摇。比知是人等。四，法比量。谓于一切相属著法。以一比余。如属无常比知有苦。以属苦故。比空无我。以属生故。比有老法。以属老故。比有死法等。五，因果比量。谓因果相比。如见物行。比有所至。见有所至。比先有行。若见有人如法事王。比知当获广大禄位。见大禄位。比知先已如法事王等。八识中前五转识与第八识。唯是现量。第六意识通于三量。第七末那。约有漏位中妄执第八见分为我。不称境知。唯是非量。其内二分。则为现量。又《因明论》现量。比量。圣教量。《瑜伽论》证量。比量。至教量。亦称三量。
    三境者。一，性境。谓眼识乃至身识及第八识等所缘色等实境相分。初心取境。未有分别。不起名言。无筹度心。是名性境。二，独影境。谓如第六识缘空华、兔角、及过去、未来等所变相分。思量过去。惟有影现。独缘法尘。不对实境。是名独影境。三，带质境。谓如第七识缘第八识见分境时。于现境分别质相。一半与本质同种生。一半与能缘见分同种生。以有尘相可分别故。是名带质境。
    梵语阿世耶。此云种子。为对于现行法之称。阿赖耶识中生一切有漏无漏有为法之功能。有如草木之种子也。为四缘中因缘之实体。四缘者。一，因缘。六根为因。六尘为缘也。二，等无间缘。旧译作次第缘。心心所法。次第无间相续而起也。三，所缘缘。旧译作缘缘。心心所法。依六尘为缘而生。还是自心之所缘虑也。四，增上缘。六根照境发识。有增上力用。诸法生时不生障碍也。《唯识论》云。种子有二类。一者。本有。谓无始以来。异熟法中。法尔而有。生蕴处界功能差别。名为本性住种。二者。始起。谓无始以来。数数现行。熏习而有。名为习所成种。故无始以来。从第八识所生有漏无漏一切有为法之功能为本有种子。种子由现行之前七识。随所应而色心万差之种种习气（《唯识论》云。功能者。是习气义。体即种子。略有三种习气。一，名言习气。谓有为法各别亲种。名言有二。一，表义名言。即能诠义。音声差别。二，显境名言。即能了境心心所法。随二名言所熏成种。作有为法各别因缘。二，我执习气。谓虚妄执我我所种。我执有二。一，俱生我执。即修所断我我所执。二，分别我执。即见所断我我所执。随二我执所熏成种。令有情等自他差别。三，有支习气。谓招三界异熟业种。有支有二。一，有漏善。即是能招可爱果业。二，诸不善。即是能招非爱果业。随二有支所熏成种。令异熟果善恶趣别）。皆悉落第八识中。更成生果之功能。为始起种子。种子生现行。现行熏种子。在色者二缘和合。在心者四缘和合时。阿赖耶识所持之种子生现行。为本有种子生果之功能。此之谓种子生现行。现行之法。必随所应而熏种子。其所熏之种子。即新熏种子。此之谓现行熏种子。种子为能生。现行为所生。又因现行熏成种子。如第八识所持种子为因。生眼等之七转识。又以七转识之现行法为因。生第八识之种子。本识转识。互为因果。故《宗镜录》云。本识是体。种子是用。种子是因。所生是果。
    种子识为阿赖耶识之异名。据《成唯识论》。凡有六义。一，刹那灭义。谓眼耳鼻舌身意等诸种子。刹那才生。生即随灭。念念不停而变异也。二，果俱有义。果者。识与根也。识、根同时俱起而成力用。如眼根照色境时。眼识即随时同缘于诸实境分明显了也。三，恒随转义。识起时种子亦随而转。如眼根照境时。种子随而相续。无有间隔也。四，性决定义。诸识所缘之善、恶、无记三性。无有间杂。如眼识缘恶境则成恶法。而不能成善法。缘善境即成善法。而不能成恶法也。五，待众缘义。识非由一因而生。必待众缘而成就。如眼识之种子空明。须得根境等之缘而始显发也。六，引自果义。诸识各引自体果用。如眼根照时。眼识即缘所对之实境。不混声香味等别体也。
    异熟。旧译作果报。依过去之善恶业所得之果报也。善恶二业为异熟所得引果（善恶业为能引。第八识为所引。故名引果）。善业感乐果。恶业感苦果。苦果乐果。皆无记性。与善恶业之善性恶性为异性。过去作业。现在受报。现在作业。招未来果。异时而成。人中造业。六道酬偿。异类而报。因之与果。一者。异时而熟。异谓别异。属因。熟谓成熟。是果。异因居过去。熟果即现在。二者。异性而熟。过去修异因。如五戒十戒等善业。为善性。十不善恶业为恶性。所招人天总别报异熟果。三涂总别报异熟果。皆无记性。三者。异类而熟。造异类业。受异类生。人中造业。受报则六趣各异。故曰异熟。至眼耳鼻舌身意六识之异熟。所得满果（善恶一分别报来满所得之果）。则名异熟生。非真异熟。以此六识之异熟。由阿赖耶识之异熟所生也。引果之识。遍三界有。具一实。二常。三遍。四无杂。四义。一切时相续酬牵引业。非如满果之不遍而有间断也。
    异熟因为六因之一。六因者。一，能作因。旧译作无障因。谓不为障害。或且与助力。如眼与色为缘能生眼识。乃至意与法为缘能生意识。大地生草木。虚空之育万物是也。二，俱有因。旧译作共生因。谓心与心所更相佐助。如四大种及生住异灭等四相。同时俱有。互为因果。缺一不可是也。三，同类因。旧译作自种因。谓同类之法。以同类之法为因。如过去善法、恶法、无记法各与现在之善法、恶法、无记法为因。现在者又与未来者为因是也。四，相应因。谓心与心所之法。同时相应而生。犹如亲友和合成事是也。五，遍行因。旧译作遍因。谓由同类因特开烦恼法而立。如苦集二谛之下惑（苦谛下惑。十使具足。即身见、边见、戒禁取、见取、邪见、贪、嗔、痴、慢、疑也。集谛下惑。只有七使。无身见、边见及戒禁取）遍于二谛也。六，异熟因。旧译作报因。谓以善、恶因得善、恶报。异时异性异类而熟也。由异熟因所招异时异性异类之果。曰异熟果。由同类因与遍行因所招众生由前之善、恶、无记转生后之善、恶、无记。果随业转。业果相似。曰等流果。由俱有因与相应因所招世间诸法。依士夫造作之力用而得者。如农夫艺黍稷而收获。商贾以贸迁而得利。曰士用果。由能作因所招依报身增上胜力而成者。如眼根虽有见性。若无眼识缘境。则无照用之力。必与他法和合方能成就者。曰增上果。以上四果。皆由六因所招。众生因修八正道。远离烦恼系缚。不受果报者。曰离系果。此以道力证得。不由前之六因。
    意识依意根而起。为了别法境之心王。一者。五同缘意识。又名同时意识。五俱意识。明了意识。与前五识同时而起。五根与五识同缘五尘明了取境。好恶长短。悉皆现前之意识也。为心之现量。以初心取境。未有分别。亲得法之自体。故缘性境。以于五尘境上。分别好、恶、长、短种种尘相。故缘带质境。二者。独头意识。不与五识同缘。而独缘法尘。无境不对。为比量、非量。缘独影境。更分为四。一，定中独头意识。缘于定境。定境之中。有理有事。事中有极略、极回、及定自在所生等诸法处色。无一切尘境。为其对象。二，散位独头意识。谓不缘五尘之境。缘受所引及遍计所起诸法处色。非定非梦。如缘空华、兔角、镜花、水月构画种种色相。及过、现、未一切诸法皆是。三，梦中独头意识。不对诸尘。缘梦中境。遍计所执法处色。由心王性境变现而生诸相。四，乱意识。是散意识于五根中狂乱而起。然不与五识同缘。如患热病见青为黄。非是眼识也。此四种皆名独头者。以不与前五识俱故。与末那、赖耶。仍系并起。
    一切生灭因缘。皆以阿赖耶识为体。意识为用。前五识取尘转入意识。意识记法为因。第七识攀缘意识。造善恶业。第八识为六七两识所依。以此生死苦果不断。若前五识不取尘。即无六识。无六识则七识不生。七识不生。则无善恶业。无善恶业。则无生死。无生死。则如来藏心湛然常住。见《宗镜录·七十三》。
    《宗镜录·五十》云。第六识十名。一，对根得名。名为六识。二，能筹量是非。名为意识。三，能应涉尘境。名攀缘识。四，能遍缘五尘。名巡旧识。五，念念流散。名波浪识。六，能辨前境。名分别事识。七，所在坏他。名人我识。八，爱业牵生。名四住识（四住。即三界见思烦恼。一，见一切住地。三界一切之见惑也。二，欲爱住地。欲界一切之思惑也。三，色爱住地。色界一切之思惑也。四，有爱住地。无色界一切之思惑也）。九，令正解不生。名烦恼障识。十，感报终尽。心境两别。名分段死识。第七识十名。一，六后得名。称为七识。二，根尘不会。名为转识。三，不觉习气。忽然念起。名妄想识。四，无间生灭。名相续识。五，障理不明。名无明识。六，返迷从正。能断四住烦恼。名解识。七，与涉玄途。顺理生善。名行识。八，解三界生死。尽是我心。更无外法。名无畏识。九，照了分明。如镜显像。名现识。十，法既妄起。恃智为怀。令真性不显。名智障识。第八识十名。一，七后得名。称为八识。二，真伪杂间。名和合识。三，蕴积诸法。名为藏识。四，住持起发。名熏变识。五，凡成圣名。为出生识。六，藏体无断。名金刚智识。七，体非静乱。名寂灭识。八，中实非假。名为体识。九，藏体非迷。名本觉识。十，功德圆满。名一切种智识。第九识十名。一，自体非伪。名为真识。二，体非有无。名无相识。三，轨用不改。名法性识。四，真觉常存。体非隐显。名佛性真识。五，性绝虚假。名实际识。六，大用无方。名法身识。七，随流不染。名自性清净识。八，阿摩罗识。即庵摩罗识。此云无垢。九，体非一异。名真如识。十，胜妙绝待。名不可名目识。
    《成唯识论述记·五》云。七八相续。当体彰名。六有间断。从依得称。曰从依者。以六识皆有所依。眼识依眼根。耳识依耳根。鼻识依鼻根。舌识依舌根。身识依身根。意识依意根。意根者。末那也。从境得名。则曰色识乃至法识。谓于六境了别名识也。色等五识。惟了色等。法识通能了一切法。故或以能了别法独得法识之名。 此八种识。具三能变（根身器界为所变）。一，异熟能变。即第八识。二，思量能变。即第七识。三，了别能变。即前六识。《惟识论》云。识所变相。虽无量种（根身器界皆是）。而能变识。类别惟三。一，谓异熟。即第八识。多异熟性故。二，谓思量。即第七识。恒审思量故。三，谓了境。即前六识。了境粗相故。第八识能变又有二。一，因能变。二，果能变。《唯识论》云。能变有二种。一，因能变。谓第八识中等流、异熟二因习气。等流习气。由七识中善、恶、无记熏令生长。异熟习气。由六识中有漏善恶熏令生长。二，果能变。谓前二种习气力故。有八识生现种种相。等流习气因缘故。八识体相差别而生。名等流果。果似因故。异熟习气为增上缘。感第八识酬引业力。恒相续故。立异熟名。感前六识酬满业者。从异熟起。名异熟生。不名异熟。有间断故。即前异熟及异熟生。名异熟果。果异因故。见《宗镜录·四十七》。
    阿赖耶识。建立有情无情。发生染法净法。若有知有觉。则众生界起。若无想无虑。则国土缘生。故《楞严经》曰。想澄成国土。知觉乃众生。《瑜伽论》云。阿赖耶是一切杂染根本。所以者何。由此识是有情世间生起根本。能生诸根。根所依处。及转识等故。亦是器世间生起根本。由能生起器世间故。亦是有情互起根本。一切有情相望互为增上缘故。
    一切有部说。阿赖耶识。有爱乐欣喜之四。《摄大乘论·二》云。世间众生爱阿赖耶。乐阿赖耶。欣阿赖耶。喜阿赖耶。世亲菩萨释云。世间众生爱阿赖耶者。是总标句。如其次第复以余句。约就现在过去未来三时别释。复有别义。谓于现在爱阿赖耶。于过去时乐阿赖耶由先世乐阿赖耶故。复于今世欣阿赖耶。由乐由欣阿赖耶故。于未来世喜阿赖耶。无性菩萨释云。爱阿赖耶。此句总说贪著阿赖耶识。乐阿赖耶识者。乐现在世阿赖耶识。欣阿赖耶识者。欣过去世已生阿赖耶识。喜阿赖耶识者。喜未来世当生阿赖耶识。此性于彼极希愿故。由乐欣喜。是故总名爱阿赖耶。
    识须藉缘以生。谓明空根境等九种之缘。生眼耳鼻舌等八种之识也。以眼耳鼻舌身五识依第八识相分建立。由第八识种子而生揽明空诸境而为相。第六识缘第八识相分而得生。取五尘境界而分别。依第七识而能执取。第七识缘第八识见分而得起。转第六识染净而为依。第八识为众识之根本。含诸法之种子。依第七识转托五根识而为相。识藉缘生。缘因识有。递相依托。而多少不同。一，明缘。明者日月之光。能显诸色相也。谓眼因明而见。无明则眼识不能发。故明为眼识之缘。二，空缘。空者荡然无碍。而能显诸色相也。谓眼以空而能见。耳以空而能闻。无空则眼耳之识不能发。故空为眼识耳识之缘。三，根缘。谓眼耳鼻舌身五根也。五识各依其根而能见。能闻。能觉嗅。能觉尝。能觉触。若无五根则五识无所依。故五根为五识之缘。四，境缘。谓色声香味触。五尘之境。眼等五根虽具五识。如无尘境为之对象。则识无由发。故境为五识之缘。五，作意缘。作意即心所法。谓根与境对。便能有知。使第六识即起分别善恶之念。遍行一切识境。故作意为前六识之缘。六，根本依缘。根本为第八阿赖耶识。依即依托。谓第八识为诸识根本。眼等六识。依第八识相分而得生。第八识相分。托眼等六识而得起。故根本依为六识及八识之缘。七，染净依缘。染净依即第七末那识。谓一切染净诸法。皆依此识而转。眼等六识。于六尘境起诸烦恼惑业。则转此烦恼染法归于第八识。而成有漏。若六识修诸道品净业。则转此道品净法。归于第八识。而成无漏。然第七识亦依第八识而能转。第八识依第七识而随缘。互相依托。故染净依为眼等八识之缘。八，分别依缘。分别即第六识。此识能分别善、恶、有漏、无漏、色、心诸法。以眼等五根。虽能取境。然皆依此识而有分别也。五根境之好恶。由分别而生。第七识之染净。由分别而知。第八识之相分。由分别而显。故分别依为眼等八识之缘。九，种子缘。即眼等八种识之种子也。谓眼识依眼根种子而能见色。耳识依耳根种子而能闻声。鼻识依鼻根种子而能嗅香。舌识依舌根种子而能尝味。身识依身根种子而能觉触。意识依意根种子而能分别。第七识依染净种子而能相续。第八识依含藏种子而能出生诸法。以诸识各依种子而生。故种子为眼等八识之缘。种子生现行五识为亲因缘。故称内缘。其余八者谓之外缘。根识之间。识为能依。根为所依。五根皆为第八识所执持。第八识随业力而转。无有间断。故五根亦随而相续。识则必待缘而生。如眼识须全具九缘。耳识须具八缘（九缘中去明）。鼻舌身三识须具七缘（九缘中去明与空）。第六识须具五缘（九缘中去明、空、染净、分别）。第七识须具四缘（九缘中去明、空、根、染净、分别）。第八识须具四缘（九缘中去明、空、根本、分别、根）。诸缘具足。方能生识。若加等无间缘。则八识各添一缘。等无间缘者。于心心所相续上所立之缘。灭于前念之心法。引起后念心法之作用也。前念后念各别相等谓之等。前心后心之间无他间隔之物体。无论经若干时。前念之心法。直与后念之心法为生缘。故曰无间。此缘惟限于心法有之。
    诸识有三种相。一，转相。八识起时皆有生灭故。二，业相。动则是业。八识皆动故。三，真相。八识真心。尽名真相故。
    一一识中皆具能所。盖心不孤起。必攀外境。心为能缘。境为所缘。能分别是识。所分别是境。能即依他性。所即分别性。
    阿赖耶识。《宗镜录》析为十类。一，大摄主阿赖耶识。即总相大识也。二，根本无明阿赖耶识。以一切染法为根本。出生增长。无断绝时。三，清净本觉阿赖耶识。自然本智。具足无漏圆满功德。四，染净本觉阿赖耶识。不守自性。受一切烦恼染法。与之俱转不相舍离。五，业相业识阿赖耶识。无明业识。依不觉故心动。说名为业。六，转相转识阿赖耶识。能见境界之相而与转识也。七，现相识阿赖耶识。境界相与现识具足行转也。八，性真如理阿赖耶识。即正智所证清净般若智境真如。九，清净始觉阿赖耶识。本有清白始觉般若也。十，染净始觉阿赖耶识。所谓随缘始觉般若也。
    庵摩罗识在所缘为真如。在本觉即真如智。所缘即空如来藏。能缘即不空如来藏。空如来藏者。心体平等。绝染净相。所起诸法。自性非有故。不空如来藏者。真如自体。具无漏清净功德。及诸有漏惑业染法。如虚空之含有万象。真如之体毕竟空寂。如明镜之含摄万物。无一实质也。此二并以真如为体。见《宗镜录·五十六》。
    《广五蕴论》云。云何识蕴。谓于所缘了别为性。亦名心。能采集故。亦名意。意所摄故。若最胜心即阿赖耶识。此能采集诸行种子故。又此行相不可分别。前后一类相续转故。又由此识从灭尽定、无想定、无想天起者。了别境界。转识复生。待所缘缘差别转故。数数间断，还复生起。又令生死流转回环故。阿赖耶识者。谓能摄藏一切种子。又能摄藏我慢相故。又复缘身为境界故。又此亦名阿陀那识。能执持身故。最胜意者。谓缘藏识为境之识。恒与我痴，我见，我慢，我爱相应。前后一类。相续随转。除阿罗汉，圣道，灭定，现在前位。如是六转识，及染污意，阿赖耶识。此八名识蕴。注云。八识心王。总名识蕴。受想行识同为心法。受想行为心所有法。名心所。识为心之本体。名心王。八识皆有了别集起依止三义。先就其对于所缘境能了别而言。故云于所缘了别为性。亦名心者。就其于诸行相能集起而言。故云能采集。亦名意者。就心王能为心所所依止而言。最胜心即阿赖耶识者。因心意识三名。通乎八识。若就最胜而言。则第八识始可名心。故云最胜。诸行。即一切法。指行蕴而言。谓此识能聚集一切法之种子也。识以了别为行相。相者。体也。即谓境相。行于境相，名为行相。或云。相者。相状。行境之相状。名为行相。阿赖耶识缘境之行相。极其微细。非圣智莫能知。故云不可分别。此识缘境。无间断。无变易。就人之一期生死言。从投胎由此识执受以至命终。皆一味了别而转。绝无少变。故云前后一类相续转。灭尽定是无漏定。心无所缘。烦恼不生。有漏前七心、心所皆灭。故名灭尽。三果、四果及十地菩萨乃至佛果。皆得此定（《大般若经·五百九十二》曰。菩萨亦得灭受想定。谓于此定。已得自在而不现入）。无想定是有漏定。外道以想念为生死根本。故以灭想念为得涅槃。先在人中修无想定。身后生四禅无想天。无想天，即四禅之第四天。修无想定之外道依前生所修定力。生彼天后。所有不恒行心、心法皆灭。依此无心分位。假立无想天之名。转识者。前七识也。八识中第八阿赖耶识为本识。前七识为转识，阿赖耶识是所依。转识是能依。灭尽定等虽能灭能依转识。而不能灭所依阿赖耶识。故此识从定起时。转识还复得生。所缘缘者。四缘之一。心法，依四缘生。一，因缘。二，等无间缘。三，所缘缘。四，增上缘也。心法是能缘。境是所缘。心必依境而起。故名所缘缘。待所缘缘差别而转者。如灭尽定。已离无色界之无所有处。其阿赖耶识于非想非非想处。又缘极微细执受境。无想定生无想天后。其阿赖耶识又于色界缘广大执受境是。数数间断者。言阿赖耶识于所缘境念念生灭。刹那相续流转。故云还复生起。盖就阿赖耶识之行相言。缘境无间断。无变易。就生死流转相言。故云数数间断也。第八识有三位。一，我爱执藏位。二，善恶业果位。三，相续执持位。在我爱执藏位。此识名阿赖耶。梵语阿赖耶。此云藏。有三义。谓能藏、所藏、我爱执藏也。就此识能摄藏诸法种子言。则此识为能藏。种子为所藏。就前七识杂染种子。藏于此识而言。则前七为能藏。此识为所藏。第七识恒执此识见分。执之为我。而起慢相。则我爱执藏也。虽有三义。而正取执藏为名。阿罗汉已破我执。即舍阿赖耶识之名。缘身为境界者。身为形之总称。谓第八识能引众生之善恶业种子。使异世成熟。受果报之身。故亦名异熟识。为境界者。谓即就本识所变之身。以为所缘之境界也。此在善恶业果位。八地以上菩萨。始舍异熟识之名。阿陀那。此云执持。谓此识从无始以来。相续执持。通乎果位。执者。果位正智所执。持者。含藏无漏种子。此相续执持位也。最胜意，即七识。于一切时皆执我我所。而以思量为性也。藏识为七识之所依。七识即缘所依以为自体。故云缘藏识为境之识。我痴。即无明。不知无我之理。愚于我相。故名我痴。我见。即我执。此身为五蕴等法假合而成。明明非我。而妄执以为我。凡夫计我为人，名人我见。二乘计一切法各有体性。怖畏生死。名法我见。我慢者。谓自恃有我。而起倨傲。令心高举也。我爱即贪。于妄执之我，深生耽著也。此四属根本烦恼。恒与第七识相应。阿罗汉示断位。至此位。则染污意之现行种子皆断。圣道、灭定、示伏位。圣道即修无漏道者。谓此识相应烦恼。无始时来。微细一类相续而转。故有漏道不能伏灭。惟无漏心起。方能伏灭也。灭定，即灭尽定。入此定者。现无漏观。极其寂静。故亦能伏灭此识。现在前位者。犹言三者修证之果。现在于前之位次也。谓惟此三者。方能伏断。否则此识总是相续随转也。
    《显识论》谓一切三界。但惟有识。三界有二种识。一者。显识。二者。分别识。显识者。即是本识。本识转作五尘四大等。分别识即是意识。于显识中分别作人天长短大小男女树藤诸物等。分别一切法。此识聚分别法尘。名分别识。显识有九种。惟是梨耶。一，身识（即五根）。二，尘识（色界等乃至色尘。通名应受识）。三，用识（眼识界等六识。大论名为正受识）。四，世识（过未现三世。又生死相续不断。故名世）。五，器识（略即器世界。广即十方三界。大论名处识）。六，数识（算计量度）。七，四种言说识（一切言说。不出见闻觉知之四）。八，自他异识（依处各异。六趣不同。依处者。身也）。九，善恶生死识（生死不离善恶。善者人天。恶者四趣。善恶道不离生死。即生即灭。无停住故。）。分别识有二种。一，有身识（我见所覆。受六趣生）。二，受者识（意界名受者。识即三种意识。一，阿梨耶识。是细品意识。二，陀那识。是中品意识。三，常所明意识。是粗品意识）。合名意根。《楞伽经》分识为二。一，了别识。二，分别事识。又分识为三。一，真识。谓本觉。二，现识。谓第八。三，分别事识。谓余七。《起信论》分识为五。一，业识。二，转识。三，现识。四，智识。五，相续识。《宗镜录·五十六》分识为五。一，所依本一识。二，能依持藏识。三，意持识。四，遍分别识。五，随顺遍转识。《转识论》分识为三。一，果报识。即阿梨耶识。亦名本识。二，执识。即阿陀那识。三，尘识。即前六识。
    《显扬论·五》云。识蕴建立有三种。一，种类差别。二，依差别。三，杂染清净差别。种类差别者。有二种。一，阿赖耶识。二，转识。依差别者。谓六识身。杂染清净差别者。如经中说。有贪心。如实知有贪心。离贪心。如实知离贪心。如是有嗔离嗔。有痴离痴。乃至广说。《瑜伽论·五十四》云。识蕴差别五种。一，由安住故。二，由杂染故。三，由所依故。四，由住故。五，由异相故。


第二。十二处。

    无眼。耳。鼻。舌。身。意。无色。声。香。味。触。法。
    梵语萨达耶怛那。此云处。钵罗吠舍。此云入。处者。出生义。谓出生六识之处。以六根为所依。六境为所缘。根境相依而生六识故。入者。涉入义。根境互相涉入。又根境均为识之所入故。
    十二处者。眼处。耳处。鼻处。舌处。身处。意处。为内六处。识之所依也。色处。声处。香处。味处。触处。法处。为外六处。识之所缘也。
    内六处又名六根。根者。能生义犹草木之根。能生枝干也。识依根以生。无根则无识。谓之根者。言识所从生也。诸根皆有浮尘根、胜义根之别。吾人肉眼可见之五根器官。浮尘根也。诸根依其增上胜力。照境发识以成根用者。胜义根也。此所说者。为胜义根。
    【注】浮尘根又名扶尘根。浮者。四大所成。虚假不实之义。扶者。扶助。胜义根为其所扶助也。《楞严经》曰：眼如蒲萄朵。耳如新卷叶。鼻如双垂爪。舌如初偃月，身如腰鼓颡。意如幽室见，除意外皆器官之可见者。或以浮尘根为当作浮根尘，或扶根尘。以《楞严经》有我今观此浮根四尘。只在我面之语。《资中》云。浮虚不实。昏翳真性。故曰浮尘。本诠从之。胜义根又名净色根。内根以净色为性也。言浮尘者。四大地水火风是能造。四微色香味触为所造。八法和合。得成根故。胜义根虽亦以八法为体。是不可见有对色。能照境发识。非同尘境粗浅。故名净色。

    一者。眼。梵语斫刍。斫者。行义。刍者。尽义。谓能于境行尽见诸色故。名行尽。能见众色。名之为眼。此根以色为境。净色为性而能见。
    二者。耳。梵语娑路多罗戍缕多。能闻诸声。名之为耳。此根以声为境，净色为性，而能闻。
    三者。鼻。梵语伽罗尼羯啰拏。能嗅诸香。名之为鼻。此根以香为境，净色为性，而能觉嗅。
    四者。舌。梵语时乞缚。能尝众味。敷发言论。名之为舌。此根以味为境，净色为性，而能觉尝。
    五者。身。梵语有四名。一，迦野。二，设利罗。三，弟诃。四，应伽。此云积聚。诸根所随。周遍积聚。故名为身。此根遍住身分。为诸根之所依止。以触为境，净色为性，而能觉触。
    六者。意。梵语纥利陀耶。此云肉团心。即意根所托。故曰意如幽室见。此根能缘前五尘境界。分别好恶。根尘相对。缘具生识而能知。故《五蕴论》云。意处即是识蕴。
    【注】《品类足论·二》略云。眼处云何。谓眼是色已、正、当、能见、及彼同分。耳处云何。谓耳是声已，正、当、能闻及彼同分。鼻处云何。谓鼻是香已、正、当、能嗅及彼同分。舌处云何。谓舌是味已、正、当、能尝及彼同分。身处云何。谓身是触已、正、当、能触及彼同分。意处云何。谓意是法已、正、当、能了及彼同分。按此内六处。眼耳鼻舌身意。为能见、能闻、能嗅、能尝、能触、能了。则外六处之色声香味触法。即为所见、所闻、所嗅、所尝、所触、所了。可知。
    《大毗婆娑论·七十一》略云。已见色者。谓过去眼。正见色者。谓现在眼。当见色者。谓未来眼。及彼同分者。诸见色眼。于自有情。名同分眼。于余有情亦名同分。诸不见色眼。于自有情。名彼同分。于余有情。亦名彼同分。见色眼与不见色眼。俱一界摄。俱一处摄，俱一根摄。同一见性。故见色眼。是不见色眼之同分。不见色眼。复是彼见色眼之同分。同分彼同分。品类差别。皆相似故。
    净色者。指净色之胜义根。五根必以净色为性。而根得生。无即不生。舌身二根。净色遍摄所依处。眼耳鼻三根。则仅有一分。而非遍满。有说舌上亦有少不遍处。如一毛端无净色根。
    意处即是识蕴。有大小乘之别。小乘以六识为意处。大乘则八识皆意处摄。
    意根在六根中最为造业之本。如《大涅槃经·三十七》曰。是业三种。谓身口意。善男子。身口二业。亦名为业。亦名业果。意唯名业。不名为果。以业因故。则名为业。善男子。身口二业。名为外业。意业名内。是三种业。共烦恼行故。作二种业。一者。生业。二者。受业。善男子。正业者。即意业也。期业者。谓身口业。先发故。名意业。从意业生。名身口业。是故意业得名为正。

    外六处。又名六尘。尘者，染污义。谓能染污情识。使真性不能显发也。亦名六境。谓六根所缘之境也。
    一者。色。梵语俱兰吒。亦作噜畔。谓眼所行境。眼识所缘。四大所造。若显色，若形色，若表色，为体。色蕴所摄。显色者。显即明显。色即质碍。凡十有三。青黄赤白光影明闇烟云尘雾及空一显色。形色者。形即形相。凡十。长短方圆粗细高下正与不正。表色者。虽属动作。而依其作相。眼根可见。故亦属色领。凡八。取舍屈伸行住坐卧是。
    【注】显色之本色有四。即青黄赤白，余则由此四色差别而出。《俱舍论》云。显色有四。青黄赤白，余显是此四差别。
    须弥山四面空中之各一显色。谓之空一显色。北洲金色，东洲银色，南洲碧色，西洲赤色。为庄严天空世间之色。
    《大毗婆沙论·一百二十二》略云。然诸色处。总有四种。一，有色处惟显可了，非形。谓青黄赤白光影明闇。二，有色处惟形可了，非显。谓身表色。三，有色处显形俱可了。谓所余若显，若形，俱可了色。四，有色处显形俱不可了。谓空界色。

    二者。声。梵语设没啰。谓耳所行境。耳识所缘。四大所造。可闻音为体。色蕴所摄。可闻音者。一，执受大种声。执者摄持。受者领受。大种者。地水火风。谓众生于内四大种有所执受而发之声也。口舌手足之声。发自有情之四大种者是。二，非执受大种声。谓众生于外四大种无所执受而发之声。如风林溪水。发自非情之四大种者是。三，俱大种声。执受不执受二者兼具之声。如以手击鼓。手属执受大种。鼓非执受大种是。四，世所共成声。世人因谈论或问答所成之声。五，成所引声。圣人所说法音。引导众生出离生死而成之声。六，可意声。欢乐之声。闻之适意。七，不可意声。愁苦之声。违逆情意。八，俱相违声。不苦不乐。非逆非顺。九，遍计所执声。外道于一切法遍计有无及常无常等执著所说而成之声。十，圣言声。即正直实语之声也。十一，非圣言声。反于圣言虚伪不实之声也。
    【注】《大毗婆沙论·十三》云。声处有八种。谓执受大种因声。非执受大种因声。此各有二。谓有情声。非有情声。此复各有可意不可意别。故成八种。
    内四大种。谓身中之地水火风。外四大种。谓世间之地水火风。

    三者。香。梵语献驮啰。谓鼻所行境。鼻识所缘。四大所造。可嗅物为体。色蕴所摄。可嗅物者。一，好香。如沉香麝香。与鼻合时。于蕴相续。有所顺益。二，恶香。如蒜韭等。与鼻合时。于蕴相续有所违损。三，平等香。如土石等。与鼻合时。无所损益。此以鼻根所取之相而分别者。若以境别。复立三名。一，俱生香。如旃檀等。其香与生俱来。二，和合香。其质由人工制作而成。三，变异香。其香由物质成熟变异而生。如果类成熟时增加之香是。
    四者。味。梵语佐塞。谓舌所行境。舌识所缘。四大所造。可尝物为体。色蕴所摄。可尝物者。一，甘味。二，酸味。三，咸味。四，辛味。五，苦味。六，淡味。此依舌根所取之相而分别者。若以境别。复立三名。一，俱生味。如甘蔗之甘。黄连之苦。随其本性而然者。二，和合味。多味和合而成。如世间烹调之味。三，变异味。如瓜熟而甘。姜老而辛之味。又有分一，甘味。二，不甘味。三，俱相违味。及一，可意味。二，不可意味。三，顺舍处味者。《瑜伽论》云。或立一种味。谓由舌所行义故。或立二种。谓内及外。
    五者。触。梵语纥啰瑟吒耶。谓身所行境。身识所缘。四大所造。可触物为体。色蕴所摄。触又分能触所触。能触有二。一，触心所法。二，能触身根。所触亦有二。一，能造四大种。二，所造触处。此所云触。仅所触中之所造。故《五蕴论》谓之触一分。谓非全分也。触之差别相二十有二。一，滑性。二，涩性。三，轻性。四，重性。五，冷。六，饥。七，渴。八，软。九，缓。十，急。十一，饱。十二，力。十三，劣。十四，闷。十五，痒。十六，黏。十七，病。十八，老。十九，死。二十，疲。二十一，息。二十二，勇。或缘光泽。或不光泽。或缘坚实。或不坚实。或缘执缚。或缘增聚。或缘乖违。或缘和顺。若俱生。若和合。若变异。是名触一分。
    【注】滑、涩、重、轻。从自性得名。故称性。冷、饥、渴。系从结果为名。因暖欲、食欲、饮欲，是别境心所中之欲。由内身触力令欲暖、欲食、欲饮。此之触相。隐微难显。暖欲为冷。食欲为饥。饮欲为渴。故从果为名。以显其触体也。
    触之差别有多种。《瑜伽论》所说。最多者如十种触。一，食触。二，饮触。三，乘触。四，衣触。五，庄严具触。六，床座触。七，机橙台枕及方座触。八，女触。九，男触。十，彼二相事受用触。

    六者。法。梵语达摩。谓意根所缘之境。意根对前五根所缘境界。分别好丑而起善恶诸法。是名法尘。法尘所及。普遍五根。凡五根对境之时。意根即同时俱起。将所缘之境。摄入意根。吾人日常动作。虽已过去。而前尘影事。忆念不忘。即法尘之作用也。法之差别相凡四。一，生。二，住。三，异。四，灭。以根对尘。一念心生。是为生相。一念之心。暂尔相续。是为住相。一念之心。先后不同。是为异相。尘境既忘。心念亦灭。是名灭相。交光师谓初忆名生。正忆名住。初忘名异。忘尽名灭。虽曰四相。亦仅是二。以住即生际。异即灭际故。云法处者所含甚广。《广五蕴论》云。法处谓受想行蕴。并无表色等及诸无为。
    【注】四相有大四相小四相之分。大四相指一期受报而言。小四相就一念而言。《唯识论》云。本无今有名生，生位暂停名住，住别前后名异，暂有还无名灭。
    对五根所缘境界而起善恶诸法。如五根缘善境界。识中则有善性现起。缘恶境界。识中则有恶性现起。缘无记境界。识中则有无记性现起。
    十二处无一非法。独此名法处者。以惟有意处对一切法故。对意者独以法处名。见《大毗婆沙论·七十三》。
    在色处所摄显色、形色、表色之外。法处所摄色。亦有五。一，极略色。分析色声香味触眼耳鼻舌身等有质之实色。令至极微。名极略色。二，极回色。分析虚空青黄赤白等无质之显色。令至极少。至不能见。名极回色。三，受所引色。即无表色也。受者。领纳义。思之种、现，上有防发功能。名所引色。因受戒而引发身内地水火风之色也。四，遍计所起色。遍计一切法之意识前所显现之五根、五境等影像。如空华水月等。五，定所生自在色。禅定所变之色声香味等境。以胜定力之故。于一切之色。变现自在。名定所生自在色。亦名定所引色。亦名定果色。《杂集论·一》参照。
    《显扬论·一》云。法处所摄色。谓一切时意所行境。色蕴所摄。无见无对。此复三种。谓律仪色。不律仪色。及三摩地所行境色。律仪色云何。谓防护身语业者。由彼增上造作心、心法故。依彼不现行法。建立色性。不律仪色云何。谓不防护身语业者。由彼增上造作心、心法故。依彼现行法。建立色性。三摩地所行境色云何。谓由下中上三摩地俱转相应心、心法故。起彼所缘影像色性。及彼成就所作色性。是名法处所摄色。
    《大毗婆沙论·十三》云。法处有七种。谓前四蕴及三无为于色蕴中。取无表色。三无为者。谓虚空、择灭、非择灭。
    法尘有二。逆缘前五尘落谢影子。为生法尘。不缘过未影子。内守幽闲静境。为灭法尘。
    《广五蕴论·注》云。法处兼摄一切有为法。无为法。受想行三法。及无表色等有为法也。诸无为者。指无为法也。并字示色法、心法相违义。及字示有为法无为法之界畔也。无为对有为而言。谓色、心诸法。非本来常住，必由四缘而生。故名有为。此诸法因果转变。三世迁流。而生灭无常。故名有为法。无为法反之。非依四缘而生。其体离生灭迁流。本来常住。凝然一味。故名无为。
    《广五蕴论》云。云何无为。谓虚空无为。非择灭无为。择灭无为。及真如等。虚空等。谓容受诸色。非择灭者，谓若灭非离系。云何非离系。谓离烦恼对治诸蕴毕竟不生。云何择灭。谓若灭是离系。云何离系。谓烦恼对治诸蕴毕竟不生。云何真如。谓诸法法性。法无我性。注云。虚空者。谓虚空能容受诸色。而了无障碍。真如于一切法。非一非异。非即非离。离诸障碍。犹如虚空。故从譬喻得名。当知此唯假有。非是实有。非择灭者。谓诸烦恼。皆由无漏慧简择之力方得灭。今不由慧力而灭。故云非择灭。系者指诸烦恼之系缚而言。离此系缚。皆由慧之简择力。今不由此。故云若灭非离系。离烦恼对治者。烦恼是所治。慧力是能治。今不由慧力。故云离烦恼对治。诸蕴指色心等一切法。毕竟不生有二义。一，谓真如本性。在凡在圣。本来明净。不必由无漏简择力方显。名非择灭。二，谓色、心诸法由众缘而生。若遇缘阙不生。则唯所依真理独显。此不生之灭所显真理。亦名非择灭。此灭名亦唯假有而非实有。谓烦恼对治者。谓由无漏慧简择力。故能灭烦恼杂染法。究竟证会真如。故名择灭。此名亦唯假有而非实有。真如者。真以别于虚妄。如以别于颠倒。又真者。实义。如者。常义。诸法即色、心诸法。诸法虽虚妄颠倒。而法之本性。则是实、是常。离于人我执及法我执。故云法无我性。
    诸无为者，即论中所示之四无为。《准唯识论》。则此四无为外。尚有不动无为。就法性生四禅天离苦乐粗动之位所显者名之也。想受灭无为。就法性入于圣者非想地所摄之灭尽定名之也。此为大乘之六无为。但此非谓六种别体。乃断我法二执处所显之一种真理。有、无、常、无常，皆不可名。但依法之实性从所显之缘。分种种之名而已。虚空、择灭、非择灭、不动、想受灭，五种无为。为诠法性之相之假名。名体皆为假立。真如无为。体虽定在。而真如之名。亦为假立。小乘则萨婆多部。立三无为。一，择灭无为。二，非择灭无为。三，虚空无为。大众部立九无为。一，择灭。二，非择灭。三，虚空。四，空无边处。五，识无边处。六，无所有处。七，非想非非想处。八，缘起支性。九，圣道支性。

    此十二处法。不过生长心与心所之作用。不但无我亦无我法故。经曰。无眼耳鼻舌身意。无色声香味触法。以无遣之。则十二处皆空。《大般若经》曰。眼处但有名。乃至法处但有名。眼处空乃至法处空是也。


第三。十八界。

    无眼界。乃至无意识界。

    无者。非有之义。乃至者。省文中略之辞。自眼界色界眼识界。耳界声界耳识界。鼻界香界鼻识界。舌界味界舌识界。身界触界身识界。意界法界意识界。根境识三者各六。凡十八界。经文仅举最初眼界。及最后之意识界者。举始末以赅余名也。界。梵语驮都。差别之义。《大乘义章》曰。界别为界。诸法性别。故名为界。《法界次第》云。界以界别为义。根尘识各有界限。如眼以色为界。耳以声为界。鼻以香为界。舌以味为界。身以触为界。意以法为界。眼不能越色有见。耳不能越声有闻。鼻不能越香有嗅。舌不能越味有尝。身不能越触有觉。意不能越法有知。色以眼为界。以眼所见必色。非声香等能对眼。故眼识必依眼根始发。余根不能。而眼根除眼识外。亦不能发耳鼻等识。推之诸根皆然。界限分明。故名曰界。
    【注】诸论释界。尚有多义。一界者。持义。谓能持大种自相不失。能持所造色相续不失。《俱舍论·八》云。能持自相。故名为界。二，界者。性义。《大乘义章·八》云。经名为界。亦名为性。三，种族义。《俱舍论·一》云。法种族义是界义。如是一身或一相续。有十八类诸法种族。名十八界。四，能取、所取、被取种子义。能取种子。谓眼等内六界。所取种子。谓色等外六界。被取种子。谓识等六识界。见《辩中边论》。五，因义。《百法疏》云。界是因义。中间六境。藉六根发六境。牵生与识为因。故名曰界。六，藏义。《唯识论·十》云。界是藏义。七，发起义。《瑜伽论·五十七》云。发起诸法。是故名界。是牵引义。八，能持因果性义。《杂集论·二》云。谓于十八界中。根境诸界及六识界。如其次第。

    根境识三者。各占六界。名十八界。六根为内六界。六境为外六界。如十二处中所示。六识界者。依眼根而能见色。了别为性。名眼识界。依耳根而能闻声。了别为性。名耳识界。依鼻根而能嗅香。了别为性。名鼻识界。依舌根而能尝味。了别为性。名舌识界。依身根而能觉触。了别为性。名身识界。依意根而能分别一切法相。了别为性。名意识界。识依于根。能依也。根为识依。所依也。识入根内。能别于境。故名为识。《大般若经》曰。眼界但有名。耳鼻舌身意界但有名。色界但有名。声香味触法界但有名。眼识界但有名。耳鼻舌身意识界但有名。《瑜伽论》云。蕴处及界等。远离诸性相能取所取执。诸法悉无我。平等如虚空。自性本不生。空性圆寂故。知诸法自性空。则十八界空。
    【注】识界者。五识身及有漏意识之六界也。《俱舍论》云。诸有漏识。名为识界。有漏者。因烦恼惑业。漏落生死之谓。识有八而只说眼耳鼻舌身意六识界者。以末那与阿赖耶。意识界识。更不别立也。此十八界中。色蕴占十处十界（眼耳鼻舌身色声香味触）及法处法界一分（无表色）。识蕴即意处及七心界（六识界及意界摄心王。故名七心界）。余三蕴及色蕴一分（即无表色）并诸无为。即法处法界所摄。见《广五蕴论》。
    《品类足论·二》云。意识界云何。谓意及法为缘。生意识。如是意为增上。法为所缘。于意所识法诸已、正、当、了别及彼同分。《大毗婆沙论·七十二》云。六识界皆是意界摄。已说意界有彼同分。应知即已说六识界。故不复说。问。若尔不应立六识界。此六即是意界摄故。答。虽即意界。而为建立根境识三。各有六故。复别说有六识差别。
    六根起识之用。不出见闻觉知。眼识之用为见。耳识之用为闻。鼻舌身三识之用为觉。意识之用为知。又云识。《智度论·四十》云。何以故。三识所知合为一。三识所知别为三。眼名为见。耳名为闻。意知名为识。鼻舌身识名为觉。答曰。是三识助道法多。是故别说。余三识不尔。是故合说。是三识但知世间事。是故合为一。余三亦知世间。亦知出世间。是故别说。

    如来逗众生机。说此三科法门。各随根性。任修一法。即能悟入。今此般若真空实相。体非变碍。领纳取像。造作、了别等积聚之相。故无五蕴。体非根境能入所入之相。故无十二处。体非根境识了别之相。故无十八界。


第二目 十二因缘

    无无明。亦无无明尽。乃至无老死。亦无老死尽。

    梵语尼陀那。此云因缘。什法师云。力强为因。力弱为缘。肇法师云。前缘相生谓之因。现相助成谓之缘。生法师云。先无其事而从彼生为因。素有其分而从彼起为缘。故因亲而缘疏。例如艺榖。种子为因。雨露与农夫之耕种为缘。因缘和合。斯生米榖。故一切法从因缘生。各由自缘。和合无阙。相续而起。故亦名缘起。从因而生。托众缘转。本无而有。有已散灭。能润所润。堕相续法。故亦名缘生。互相由藉。三世相续。永无间断。故亦名钩锁。
    无无明第一无字。即空义。无明为一名词。无明至老死。凡十二法。乃至者省文。举始末以赅余名。若具说应作无无明。亦无无明尽。无行亦无行尽。无识亦无识尽。无名色亦无名色尽。无六处亦无六处尽。无触亦无触尽。无受亦无受尽。无爱亦无爱尽。无取亦无取尽。无有亦无有尽。无生亦无生尽。无老死亦无老死尽。
    【注】《入楞伽经》曰。一切法因缘生。《楞严经》曰。彼外道等常说自然。我说因缘。《辅行》云。亲生为因。疏助为缘。森罗万象。必自因与缘而成。因为亲因。缘为助缘。二者相合而生结果。谓之因缘合成。是十二法辗转感果故名因。互相由借故名缘。

    十二因缘者。无明缘行。行缘识。识缘名色。名色缘六处。六处缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死。是为一切有情涉三世而轮回之因缘。
    【注】三世。亦名三际。世者。迁流之义。际者。隔别之义。一，过去世。谓善恶诸行已起、已生、已转、已聚集、已出现、落谢、变灭。过去所摄。二，未来世。谓善恶诸行未起、未生、未聚集、未出现。未来所摄。三，现在世。谓善恶诸行现起、现生、现聚集、现出现、未转、未谢、未灭。现在所摄。
    此十二支生起行相。不了第一义谛。执著于我为无明。不正思唯。起于妄行为行。行熏于心为识。与识（现行）共生（拣现行非种故。名色与识互依。如水与尘。）。四取蕴（识蕴已属所依识。故五蕴惟四）为名色。名色增长为六处（名增长成意处。色增长成余五）。根识既显。则对境为三。是触。触必领受。于受染著。是爱。爱增即取。取即起于业种。成有。业熟即起漏蕴为生。蕴熟则老。至坏为死。老非定有。故附死立支。
    无明行为能引支。能引识等五果种故。识名色六处触受是所引支。是前二支所引发故。爱取有为能生支。近生当来生老死故。生老死为所生支。前三支近所生故。
    此十二支因果离合。各经论依便宜所说不同。前前为因。后后为果。无明惟因。老死惟果。余望前后。亦因亦果。若显循环。老死亦因。无明亦果。余望前后。亦因亦果。又无明、爱、取是本。惟因。生、老死是末。惟果。余通本末。亦因亦果。又惑因、苦果。业通因、果。又惑、业皆因。惟苦为果。又前十皆因。后二为果。又真心不觉为因。行等十一为果。
    《智度论·五》云。十二因缘。是名甚深法。如佛告阿难。是十二因缘法甚深。难解难知。又云。是中无明、爱、取三事名烦恼。行、有二事名业。余七分名事。是十二因缘。初二，过去世摄。后二，未来世摄。中八，现前世摄。是略说三事。烦恼、业、苦是三事。展转更互为因缘。是烦恼，业因缘。业，苦因缘。苦，苦因缘。苦，烦恼因缘。烦恼，业因缘。业，苦因缘。苦，苦因缘。是名展转更互为因缘。过去世一切烦恼。是名无明。从无明生业。能作世界果故。名为行。从行生垢心。初身因如犊子识母。自相识故。名为识。是识共生无色四阴，及是所住色，是名名色。是名色中生眼等六情，是名六入。情尘识合。是名为触。从触生受，受中心著，是名渴爱。渴爱因缘求，是名取。从取后世因缘业，是名有。从有还受后世五众，是名生。从生五众熟坏，是名老死。老死生忧、悲、哭、泣种种愁恼，众苦和合集。若一心观诸法实相清净。则无明尽。无明尽。故行尽。乃至众苦和合集皆尽。是十二因缘相。
    十二因缘以时间分位说。可分四种。一，刹那十二支。谓刹那之顷具十二支。如由贪行杀。贪是无明。思欲行杀是行。了别所杀之人及诸境事是识。与识俱之色想行三蕴是名色。名色是总。六处是别。其所住之法。即是六处。六处是根。合其余识境而生之心所是触。领触之心所是受。贪心是爱。与贪相应之诸烦恼是取。依此所起之身语二业是有。如是诸法之起是生。其法熟变是老。法终灭坏是死。于刹那中已完具十二支。《华严经》一念顿具十二。随事贪欲与心共生是识。（本是真心。与贪相应便名识）。事是行。于行迷惑是无明。（缘）及心（因）共生（相应四蕴）是名色。名色增长为六处。六处三和合是触。触共生是受（同时必领纳故）。受无厌足是爱。爱摄不舍是取。诸支和合是有。有所起是生。生熟为老。老坏为死。亦即斯意。二，连续十二支。因果无间连续而起也。三，分位十二支。各于其起位而分别之。故十二支各具五蕴。四，远续十二支。依顺后受及不定受业。而前分位之五蕴。隔越多生从无始远续之因果也。

    无明者。惑也。梵语阿尾你。亦即烦恼。谓过去无始以来烦恼之惑。障覆本性。妄认四大为自身相。六尘缘影为自心相。是为无明。《显扬论》云。无明者。谓不正了真实为体。或是俱生。或分别起。能障正了为业。缘者。引起之义。因烦恼惑造作诸法。而引起种种善不善业。故曰无明缘行。
    【注】各经论于无明分类。详略不同。《起信论》分无明为二。一，根本无明。又名无始无明。不了真如原始一念之无明本体。二，枝末无明。因根本无明而起三细六粗之惑业之无明也。《佛说决定义经》分之为三。一，痴无明。谓众生愚痴闇钝无所明了。妄执倒见。于正法不能生信也。二，迷无明。谓众生惑于尘境贪染昏迷也。三，颠无明。于正法起邪见。如常计无常。乐计非乐等。《宗镜录》分之为四。一，缠无明。谓由无明之惑缠缚。不能出离生死也。二，随眠无明。谓无明烦恼。长时随逐眠伏藏识之中也。三，相应无明。谓意识缘于六尘。识与境相应而起烦恼也。四，独头无明。亦名不共无明。谓未有六尘之境相对。意识独缘想尘。识与境不相应也。《华严经疏》亦分为四。一，迷理无明。义通终始。二，发业无明。此在行前。三，覆业无明。此在行后识前。四，受生无明。与识同时（望能生识）或在识后（望过去种子心识）。《百法问答钞》分之为五。一，相应无明。其义同上。二，不共无明。上之不共无明中。单与意识相应之不共无明也。三，恒行不共无明。上之不共无明中。单与末那识相应之不共无明也。恒时相续不断。与意识相应之五位有间断者不同。且与我痴慢三大惑相随。故为殊别。四，主独无明。不但不与本惑俱起。即与忿等随惑亦不相应者。五，非主独无明。与忿等随惑俱起之无明也。《大毗婆沙论》分之为十五。一，根本无明。由无始之际。一念不觉。长夜昏迷。不了真理。能生一切诸惑烦恼者。二，枝末无明。心心所法相应而起。即有贪嗔慢疑见等烦恼者。三，共无明。一切结使共相造作一切有漏诸业者。四，不共无明。第七识无别体相。妄起染心。障蔽无漏圣法。恒不间断者。五，相应无明。谓第七识恒与贪痴见慢四惑相应而起者。六，不相应无明。谓第七识不与余识外缘粗显之境相应者。七，迷理无明。谓根本无明障于中道之理不能显发者。八，迷事无明。谓见思烦恼，障蔽生死之事不能出离者。九，独头无明。谓妄觉之心。不缘外境。孤然生起。生已增广者。十，俱行无明。谓心心所法常相随逐。曾不舍离者。十一，覆业无明。谓一切结使。覆蔽诸业。恐失名誉利养恭敬。不令人知者。十二，发业无明。谓贪痴我见慢等能发生一切恶业者。十三，种子子时无明。种子者。藏识含藏一切染净种子。子时者。十二时之首。以喻藏识为诸识之首。染习种子蕴在藏识之中未发显时也。十四，行业果无明。谓十二因缘中无明、行、爱、取、有五者是业因。识等七者是苦果也。十五，惑无明。谓俱生、分别及根本随烦恼等惑也。
    根本无明与枝末无明之分甚细。《起信论义记讲义》云。根本不觉者。迷真之用。以其为动念之原始故也。枝末不觉者。起妄之差别。即三细六粗也。结末归本者。明三细（一，业相。从真起妄初动之相。盖本觉心源。离念寂静。因无明故。觉成不觉。遂成业相。《起信论》云。以依不觉故心动。说名为业。二，见相。见初动之相也。亦名转相。依初动业识转成能见之相也。三，境界相。转相分别初动之境界也。亦名现相。由前转相则境界妄现也）六粗（由藏识中初起之三细相而生。一，智相。依三细中第三之境界相。不了自心所现。妄起分别染净。于净境则爱。染境则不爱之相。二，相续相。依前智相分别。于爱境则生乐。不爱境则生苦。觉心起念相续不断之相。三，执取相。依相续相缘念苦乐等境。心起执著之相。四，计名字相。依前妄执分别假立名言之相。五，起业相。依前名字执取生著。造种种业之相。六，业系苦相。业系缠缚。生死逼迫之苦相）之九相。尽归根本无明也。此不了真如法相为能成之缘。故曰根本不觉。三细六粗为其所成。故曰枝末不觉。所谓迷真为根本不觉。起妄为枝末不觉也。
    凡外不明真谛。著于邪见。名见思无明。二乘不明俗谛。著于自利。名尘沙无明。权乘菩萨不明中谛。著于二边。名根本无明。此台宗所立也。
    《杂集论·四》云。无明有二种业。一，令诸有情于有愚痴。二，与行作缘。令诸有情于有愚痴者。谓由彼所覆于前中后际不如实知故。由此因缘起如是疑。我于过去为有，为无，如是等。与行作缘者。由彼势力。令后有业。得增长故。按于有愚痴。即能发生一切恶业。似即发业无明。与行作缘。令后有业增长。似即润生无明。盖烦恼有分别起（依邪师邪教邪思唯而起）。俱生起（习性自然而起）。意识起此二种烦恼。造善恶业。俱生起之烦恼。润其业种而使受生。故有润生无明之名。众生于临终时。有三爱。一，境界爱。爱著眷属家财一切环境。二，自体爱。爱著身体。三，当生爱。爱著当来受生之处。润生无明。即润既造之业。使生苦果也。

    行。梵语散娑歌啰。为过去世之烦恼惑。起于身口意三业。造作一切善不善业。迁流于三世也。《成唯识论》。无明所发。乃名为行。意识起诸行时。识于行中生喜住著。故曰行缘识。
    【注】《大乘义章》云。内心涉境。说名为行。《法界次第》云。造作之心。能趣于果名行。《俱舍论》云。造作迁流二义名行。
    《瑜伽论·五十六》云。行有三种。谓身行、语行、意行。当知此中入出息风，名为身行。风为导首。身业转故。身所作业亦名身行。由愚痴者。先起随顺身业风已。然后方起染污身业。如入出息能起身业。故名身行。如是寻、伺与诸语业。均名语行。受、想与意业。均名意行。又五十三云。行相略有三种。一，善行。二，不善行。三，无记行。又一切行皆造作相。又十云。行望识为三种缘。由能熏发彼种子故。为俱有缘。次后由彼势力转故。为无间灭生起缘。由彼当来果得生故。为久远灭引发缘。
    《杂集论·四》云。行有二种业。一，令诸有情于诸趣中种种差别。二，与识作缘，令诸有情于趣差别者。由业势力令诸有情趣种异趣故。与识作缘者。由习气力能使当来名色等生起种子得增长故。

    识。梵语毗惹喃。心对于境之了别也。世俗所谓灵魂。即此神识。识者，心王。真妄和合。由过去世惑业牵引。从行生心。投托母体。一刹那间。染爱为种。结想成胎。分别诸法。是名为识。识但有名。凝滑属色。故曰识缘名色。
    【注】识其有八。此时初入母胎。六根未生。故此处所云之识乃阿赖耶现行藏识。以过去业行为因。与父母三缘和合而结生。投胎时此识先来。命终时此识后去。识缘名者。谓非色四蕴。识缘色者谓羯罗蓝。五蕴初起。六根未生。仅有名色。由阿赖耶识而生起。故云识缘名色。至六根成长以后。则识又依止于名色。《瑜伽论·九》云。此识当续生时。能感生业与异熟果。异熟生。识复依名色相续而转。谓依眼等六依转故。由是说言名色缘识。俱生五根。说名为色。无间灭等。说名为名。随其所应。能与六识作所依止。识依彼故。乃至命终。数数随转。《大毗婆娑论·二十三》云。识缘名色。显识作用。名色缘识。显名色作用。识为缘故。名色续生。名色为缘。识得安住。故说此二，更互为缘。识缘名色。说初续生时。名色缘识。说续生后位。识缘名色。说续生时识。能生名色。名色缘识。说续生后识。依名色住。识缘名色。说所生名色。名色缘识。说能生名色。识缘名色。依前后说。名色缘识。依同时说。《法蕴足论》云。云何名色缘识。谓眼色为缘生眼识。此中眼及色名为色。即彼所生受想行识名为名。于中作意等能助生眼识。是名名色缘识。乃至意法为缘生意识等皆是。
    《成唯识论·八》云。此中识种。为本识因。又云。集论说识亦是能引。识中业种。名识支故。异熟识种。名色摄故。经说识支通能所引。业种识种。俱名识故。识是名色依。非名色摄故。
    《杂集论·四》云。识有二种业。一，持诸有情所有业缚。二，与名色作缘。持有情业缚者。与行所引习气俱生灭故。与名色作缘者。由识入母胎。名色得增长故。

    名色。梵语那摩噜拍。名即是心。心但有名而无形质。色即色质。《大乘义章·四》云。言名色者。心从诠目。故号为名。身形质碍。称之为色。自神识入胎以后。六根未生以前。中间诸位。总名名色。识自托胎以后。在母腹中第一七日名羯罗蓝。此云凝滑。父母不净和合。凝滑如酪也。第二七日名遏蒲昙。此云如疱。第三七日名蔽尸。此云软肉。第四七日名羯南。此云坚肉。亦作凝厚。皆名色摄。第五七日名钵罗奢佉。此云形位。亦作肢节。生诸根形四肢差别。自兹以往。渐入具根。故曰名色缘六处。
    【注】《大毗婆娑论·二十三》云。问。此经中说名色缘六处。应不遍说四生有情。谓胎卵湿生。诸根渐起。可说名色缘六处。化生有情。诸根顿起。云何可说名色缘六处。应说此经通说三界四生。谓化生者初受生时。虽具诸根。而未猛利。后渐增长。未猛利时初刹那（刹那为时之极短者。《俱舍论》云。壮士一弹指顷六十五刹那。《仁王经》曰。一念中有九十刹那。一刹那经九百生灭。《日藏》云。一千六百刹那名一迦罗。六十迦罗名模呼律多。三十模呼律多名为一昼夜）顷。名识支。第二刹那以后。名名色支。至猛利位。名六处支。问。六处即在名色中摄。何故说名色缘六处耶。答。未起眼等四色根。名名色位。四根起已。具六处故。名六处位。（受想行识四蕴。皆为心法。无形体可见。但以名而知之。故谓为名。色者色法。为极微所成有质碍之物体。故谓为色。识入母胎。五蕴初具。名名色支。）又云。云何名色。谓结生已。未起眼等四种色根。六处未满。中间五位。谓羯刺蓝，頞部昙，闭尸，建南，钵罗奢佉，是名色位。《瑜伽论·九》云。俱有依根曰色。等无间灭依根曰名。又云。又五色根。若根所依大种。若根处所。若彼能生大种。曰色。所余曰名。
    藕益大师云。一真法性。惟如如理。及如如智。本无能所之分。由真如不守自性。不觉念起而有无明。遂成能所二妄。一切见分。但有其名。名之为心。一切相分。有质可缘。名之为色。名色二法。不出一真如心。
    《杂集论·四》云。名色有二种业。一，摄诸有情自体。二，与六处作缘。摄有情自体者。由彼生已。得预有情众同分差别数故。与六处为缘者，由名色等前支为依止。六处等后支得生起故。

    六处即六根。又名六入。处。梵语萨达耶怛那。入。梵语钵罗吠舍。入钵罗奢佉位后。渐入具根。至第六七日。名发毛爪齿位。第七七日名具根位。六根开张。有入六尘之用。自体圆满。与触作缘。故曰六处缘触。
    【注】《俱舍论》云。眼等已生。至根境识未和合位。得六处名。《大毗婆娑论》云。云何六处。谓已起四色根。六处已满。即钵罗奢佉位。眼等诸根。未能与触作所依止。是六处位。
    《杂集论·四》云。六处有二种业。一，摄诸有情自体圆满。二，与触作缘。摄诸有情自体圆满者。由彼生已余根无缺故。
    《大毗婆沙论·二十三》云。问。此经中说六处缘触。有余处说。名色缘触。余处复说。二缘生触。如是三种。有何差别。答。六处缘触。显触所依。谓显一切外物和合。必因于内。内法胜故。但说所依。故此经说六处缘触。名色缘触。显触自性。二缘生触。显触所依及所缘别。复次。六处缘触。说恶趣触。名色缘触。说欲界人天触。二缘生触。说色、无色界触。复次。六处缘触。说分位触。名色缘触。说现在触。二缘生触。说三和触。复次。六处缘触。说触位触。名色缘触。说前位触。二缘生触。说后位触。《法蕴足论·十》云。云何六处缘触。谓眼及色为缘生眼识。三和合故生触。乃至意及法为缘生意识。三和合故生触。是名六处缘触。复次。眼及色为缘生眼识。三和合故生触。此中眼为内缘。色为外缘。生眼触。乃至意及法为缘。生意识。三和合故生触。此中意为内缘。法为外缘。生意触。是名六处缘触。复次。眼及色为缘生眼识。三和合故生触。此中眼触以眼、色、眼识为缘。乃至意及法为缘生意识。三和合故生触。此中意触以意、法、意识为缘。是名六处缘触。复次。眼及色为缘生眼识。三和合故生触。此中眼、色、眼识皆非是触。由三和合而有触生。乃至意及法为缘生意识。三和合故生触。此中意、法、意识皆非是触。由三和合而有触生。是名六处缘触。如是诸触。六处为缘。六处为依。六处为建立故。起、等起、生、等生、聚集、出现，故名六处缘触。又云。云何名色缘触。谓眼及色为缘名眼识。三和合故生触。此中眼及色名为色。即彼所生受想行识，名为名。如是名色为缘生眼触。是名名色缘触。乃至意及法为缘生意识。三和合故生触。此中诸意识所了色。名为色。即彼所生受想行识，名为名。如是名色为缘生意触。是名名色缘触。

    触。梵语萨婆罗奢。接触之义。根境识三者和合。分别变异。依根取境。与受所依。故曰触缘受。
    【注】《成唯识论·三》云。触为三和。分别变异。令心心所触境为性。受想思等所依为业。三和合位皆有顺生心所功能。说名变异。触似彼起。故名分别。
    与受所依者。以触生受。近而胜故。依《起满经》说。受想行蕴皆以触为缘。《瑜伽》但说与受想思为所依者。思于行蕴为主胜故。举此以《俱舍论·九》云。已至三和。未了三受因差别位。总名曰触。《界身足论·上》云。触云何。谓触。等触。现触。已触。当触。是名触。《品类足论·一》云。触云何。谓三和合性。此有三种，谓顺乐受触。顺苦受触。顺不苦不乐受触。
《瑜伽论·十》云。问。若自所逼迫。若他所逼迫。若时候变异。若先业所引。皆得生受。何故此中但显触为彼缘。答。触是彼近因故。由触所引故。余缘所生受。亦从触生故。必不离触。是故偏说。
    《杂集论·四》云。触有二种业。一，令诸有情于所受用境界流转。二，与受作缘。令有情于境流转者。依此为门受用顺乐受等三种境界故。

受。梵语，尾野达喃。领纳为义。六尘触对六根。领纳苦、乐、不苦不乐三境。由领纳而生贪著。于可爱境结念不舍。故曰受缘爱。
    【注】《成唯识论·三》云。受谓领纳顺、违、俱非、境相为性。起爱为业。
    《法蕴足论·十》云。云何受缘爱。谓眼及色为缘生眼识。三和合故生触。触为缘故生受。受为缘故生爱。乃至意及法为缘生意识。三和合故生触。触为缘故生受。受为缘故生爱。是名受缘爱。
    乐受及不苦不乐受，起爱固也。如何苦受亦与爱为缘。须知爱有五种。一，和合爱。二，不和合爱。三，别离爱。四，不别离爱。五，愚爱。乐受未生。起和合爱。已生。起不别离爱。苦受未生。起不和合爱。已生。起别离爱。不苦不乐受未生。起和合爱。已生。起不别离爱。于中多分生长愚爱。见《大毗婆沙论·二十四》。
    《俱舍论·十》云。六受谓眼触所生受。乃至意触所生受。六中前五。说为身受。依色根故。意触所生，说为心受。但依心故。
    《杂集论·四》云。受有二种业。一，令诸有情于所受用生果流转。二，与爱作缘。令有情于受用生果流转者。由此为依受用种种可爱等业异熟故。与爱为缘者。希求与此和合等为门诸爱生故。
    六根缘境生识。根、境、识三者和合而生各触。触为缘故生受。受为缘故随顺而住。乃生贪念。执藏防护。坚著爱染。是名受缘爱。

    爱。梵语脱利司那。现在自体贪著义。凡诸所有染污希求皆名为爱。壮年以后。贪欲转盛。于五尘境广遍驰求。爱必思得。竞致四取。故曰爱缘取。
    【注】《楞严经》曰。异见成憎。同想成爱。《大乘义章》云。贪染名爱。故爱有贪著染污之义。
    五尘境。即色声香味触。
    《大毗婆沙论·二十九》略云。爱有二种。一，染污。谓贪。二，不染污。谓信。贪皆爱。有爱非贪即信。诸信皆爱。有爱非信。谓染污爱。
    《集异门论·八》云。四取者。一，欲取。二，见取。三，戒禁取。四，我语取。云何欲取。答。除欲界系诸见，及戒禁取。诸余欲界系结缚，随眠，随烦恼缠。是名欲取。云何见取。答。谓四见。一，有身见。二，边执见。三，邪见。四，见取。如是四见。合名见取。云何戒禁取。答。如有一类，于戒执取，谓执此戒。能清净。能解脱。能出离。能超苦乐。至超苦乐边。或于禁执取。谓执此禁。能清净。能解脱。能出离。能超苦乐。至超苦乐边。或于戒禁俱执取。谓执此戒、禁。俱能清净。能解脱。能出离。能超苦乐。至超苦乐边。是名戒禁取。云何我语取。答。除色、无色、界系诸见、及戒、禁取。诸余色、无色、界系结缚、随眠、随烦恼缠。是名我语取。《俱舍论·九》略云。从欣受爱。起欲等取。此中欲者。谓五妙欲。见谓六十二见。戒谓远离恶戒。禁谓狗牛等禁。如诸离系、及婆罗门、播输钵多、般利伐罗多迦等异类外道。受持种种露形、拔发、杖鸟、鹿皮、持髻、涂灰、执三杖、剪须发等无义苦行。我语。谓内身依之说我故。有说我见、我慢，名为我语。由此二种。说有我故。我非有故。说名我语。于前四种。取谓欲贪。诸经中说。云何为取。所谓欲贪。
    《法蕴足论·十》云。云何爱缘取。谓彼初生。说名为爱。爱增盛位。转名为取。
    《杂集论·四》云。爱有二种业。一，引诸有情流转生死。二，与取作缘。引诸有情流转生死者。由彼势力。生死流转无断绝故。与取作缘者。爱味求欲为门。于欲等中贪欲转故。

    取。梵语鸟拍达那。希求未来染著现在欲贪之义。由欲希求未来自体为方便故。引取当蕴令起现前。由贪染著现在自体能为未来胜方便故，执取现蕴令不舍离。由取为缘，招后有业。故曰取缘有。
    【注】《大毗婆沙论·二十三》云。云何取。谓由三爱（欲爱、色爱、无色爱）。四方追求。虽涉危险。不辞劳倦。未为后有起善恶业，是取位。
    《杂集论·四》云。取有二种业。一，为取后有。令诸有情发有取识。二，与有作缘，为取后有发有取识者。为那落迦趣等差别。后有相续不断，令业习气得决定故。与有作缘者。由此势力。诸行习气。得转变故。《瑜伽论·十》云。云何取望有为三种缘。答。由与彼俱。令业能招诸趣果故。为俱有缘。又由彼力于此生处能引识等故。为无间灭生起缘，又能引发彼界功能故。为久远灭引发缘。

    有。梵语巴哇。驰求诸境。起善恶业。由前际因。生后际果。积集牵引，因果不亡之谓。现在世既依惑造业，未来世即依业受生。故曰有缘生。
    【注】有，有四义。一者。对于无或空而言。此有实有、假有、妙有之别。三世实有者。实有也，因缘依他之法。假有也。圆成实性。妙有也。二者有支。为造可牵当来果之业之位。即因也。三者。果之名。因果不亡之义。四者。生死相续之义。色、无色、界之定及依身。外道执之以为解脱。故遮遣之特谓之有。显非真灭。上二界之贪谓之有贪。上二界之漏谓之有漏（《涅槃经》。欲界除无明外一切烦恼名欲漏。色无色界除无明外一切烦恼名有漏。三界一切无明名无明漏）即此义。有者。苦果之别名也。此所云者。属第二义。就因果不亡之义说。诸经论详略不同。约举之如左。
    二有。一，实物有。五蕴等法成身。为实有之物也。二，施设有。世间之人。各各随业受报。因假父母遗体。便即施设而有男女之名也。见《大毗婆沙论》。
    三有。三界之异名也。生死之境界。有因，有果，谓之有。一，欲有。欲界之生死也。二，色有。色界之生死也。三，无色有。无色界之生死也，见《显识论》。又一，相待有。谓如长、短、彼、此等。实无长短。亦无彼此。以相待故。乃有其名。长因短有。短因长有。彼亦因此。此亦因彼。东西南北。亦皆如是。名相待有。二，假名有。虚假不实。如毡因毛、缕而成。如无毛、缕。毡则何有。是知毛、缕因缘假合。假名为毡。一切众生四大和合。假名为身。亦复如是。名假名有。三，法有。一切诸法。从因缘生。缘合则成。缘散则灭。本无自性。虽无自性。非如兔角龟毛。有名无实。名曰法有。见《智度论》。
    四有。众生作业感果。果必由因。因果相酬，则有生死。既有生死，必有色身。既有色身，必经中阴。轮转不息，则成四有。一，生有。即中有后。本有前。正结生相续时。从中阴身来托母胎。一念识心相续。五蕴由此生起。是名生有。二，本有。即生有后。死有前。中间所有五蕴色身。为业报之本。是名本有。三，死有。本有后。中有前。五蕴色身。一时坏灭。是名死有。四，中有。死有后。生有前。识未托胎之中阴身也。见《俱舍论·九》。又一，中有。二，生有。三，业有。四，死有。见《显识论》。
    七有。由身口意所作善恶之因。能招六趣生死之果。因果相续。乃生七有。一，地狱有。众生由过去恶业之因。感现在地狱之果。名地狱有。二，畜生有。众生由过去愚痴之因。感现在畜生之果。名畜生有。三，饿鬼有。众生由过去悭吝之因。感现在饥饿之果。名饿鬼有。四，天有。众生由过去戒定之因。感现在快乐之果。名天有。五，人有。人者。忍也。于违顺境能安忍故。众生由过去戒善之因。感现在人伦之果。名人有。六，业有。亦名行有。以身口意所作善恶业因。招未来善恶业果。名业有。七，中有。亦名中阴。众生命终以后。识未托胎。现在所作善恶业因。必取当来善恶诸趣之果。名中有。见《长阿含十报法经》。又他毗梨部名有分识有者。以三界为三有。而别立四有。一，中有。二，生有。三，业有。四，死有。通前三有为七有。欲色二界具四有。无色界无中有。四有者。从识支至六岁。是生有。从七岁以上能分别生熟起贪，至未舍命。是业有。死有者。惟一念。中有。即中阴。正辩名为向生处。处者。有因缘名处也。见《显识论》。与《俱舍论》略异。九有。三界中有情乐住之地处有九。一，欲界之人与六天。二，初禅天。三，二禅天。四，三禅天。五，四禅天。六，空处天。七，识处天。八，无所有处天。九，非想非非想处天。见《俱舍论·八》。
    二十五有。开三界为二十五有。欲界十四。四洲（东弗于逮。西瞿耶尼。南阎浮提。北郁单越。）。四恶趣（修罗。饿鬼。地狱。畜生）。六欲天（四天王天。忉利天。夜摩天。兜率天。化乐天。他化自在天）。色界七（初禅。二禅。三禅。四禅。及初禅中之大梵。四禅中之无想。及五那含。）。无色界四（空处。识处。无所有处。非想非非想处）。见《辅行记·二》。
    《成唯识论·八》云。爱取合润能引业种及所引因，转名为有。俱能近有后有果故。有处惟说业种名有。亲生当来识等种故。又云。有支习气。谓招三界异熟业种。有支有二。一，有漏善。即是能招可爱果业。二，诸不善。即是能招非爱果业。随二有支所熏成种。令异熟果善恶趣别。
    《俱舍论·九》云。因驰求故。积集能牵当有果业。此位名有。《大毗婆沙论·二十三》云。云何有。谓追求时。亦为后有起善恶业。是有位。
    《杂集论·四》云。有有二种业。一，令诸有情后有现前。二，与生作缘。令后有现前者。能引无间余趣故。与生作缘者，由此势力。余众同分转故。
    生者。受生义。梵语仡那。一切有情依过去现在善恶之业，随业感报。而于六道，四生，中受生也。五蕴初起。故名曰生。于众同分所有诸行。本无今有为性。色身无常，还归衰谢。故曰生缘老死。
    【注】六道者。众生轮回之道路也。各乘因业而趣。故亦名六趣。一，天。二，人。三，阿修罗。四，地狱。五，饿鬼。六，畜生。
    天道，梵语提婆，又作素洛，光明自然，清净自在，最胜之义。欲界六天。色界十八天。无色界四天。欲界六天。在欲界最上。以同具情欲，色欲，食欲，淫欲，故名欲界。此六天中。更分为二。一，地居天（依须弥山而住。须弥此云妙高。凡四级。第一级有药叉神。名坚手天。第二级持鬘天。第三级恒憍天。第四级在山半。即四天王天。山顶则忉利天也。）。二，虚空居天。地居天二。一，四天王天。东为持国天。住须弥山黄金埵。城名上贤。提头赖吒天王。领乾闼婆、富单那二部。西为广目天。住须弥山白银埵。城名周罗。毗留博叉天王。领毗舍阇，毒龙等二部。南为增长天。住须弥山琉璃埵。城名善见。毗留勒叉天王，领鸠盘荼、薜荔多二部。北为多闻天。住须弥山水晶埵。城名天敬。毗沙门天王领夜叉、罗刹等二部。二，忉利天。又名三十三天。住须弥山顶。中为善见城天。都善见城。释提桓因主之。四方各八天。共为三十三天。其名为善法堂天。住峰天。山顶天。善见城天。钵私陀天。俱吒天。杂殿天。欢喜园天。光明天。波利耶多天。杂险岸天。谷崖岸天。摩尼藏天。旋行天。金殿天。鬘影天。柔软天。杂庄严天。如意天。微细行天。歌音喜乐天。威德轮天。月行天。阎摩那娑罗天。速行天。影照天。智慧行天。众分天。曼陀罗天。上行天。威德颜天。威德焰轮光天。清净天。虚空居天四。一，夜摩天。夜摩此云时分。二，兜率天。兜率此云知足。三，须洹蜜陀天。须洹蜜陀此云乐变化。四，婆舍跋提天。婆舍跋提，此云他化自在。他化自在天之上。别有魔罗天宫。波旬所居。亦他化自在天摄。六天淫欲相各不同。四天王天，忉利天，皆以男女形交为淫。夜摩天以相抱为淫。兜率天，以执手为淫。须洹密陀天，以相笑为淫。婆舍跋提天，以相视为淫。虽行淫欲。而无不净。色界十八天。在欲界之上。已离诸欲。而仍有清净之色。虽属化生。仍有色质。既无女形。又无色染。修四静虑而得之。故又名四静虑天。修此种禅定所生之色界四天处也。初禅三天。一，梵众天。二，梵辅天。三，大梵天。初禅以上。不须分段食。故无鼻舌二识。惟就眼耳身意四识。有喜受而与意识相应。有乐受而与三识相应。且有觉、观（觉与观为二法。觉，梵语毗怛迦。新译作寻。观，梵语毗遮罗。新译作伺。寻谓寻求。伺谓伺察。粗思名寻，细思名伺。皆为妨定心者。因觉观之有无。判定心之浅深。初禅及未至定。有觉，有观。中间禅如大梵天。无觉，有观。二禅以上。无觉、无观。）。二禅三天。一，少光天。二，无量光天。三，光音天。又名极光净天。二禅以上。仅有意识。并无眼耳身三识。故惟有喜舍二受。与意识相应。因意识之怡悦粗大。故是喜受而非乐受。但无觉观。三禅三天。一，少净天。二，无量净天。三，遍净天。是三天亦仅有意识。有乐、舍二受。与上相应。意识怡悦之相。至极静妙。故立为乐受。四禅九天。一，福生天。二，福爱天。三，广果天。此三天为凡夫修证者所住。四，无想天。为外道修证者所住。五，无烦天。六，无热天。七，善见天。八，善现天。九，色究竟天。自五至九，五天。皆为证不还果之圣者所住。故统名五阿那含天。阿那含者，此云不还。故又名五不还天。惟圣人居。无异生杂。故又名五净居天。色究竟天。《楼炭经》谓之阿迦尼吒天。华严亦作大自在天。梵语摩诃莫醯伊湿伐罗。与欲界第六天之婆舍跋提天不同。色究竟者。色天最胜之处。究竟无边际也。此十八天。各经亦有小异。萨婆多部以大梵天并入梵辅天。无想天并入广果天。故为十七天。此据上座部所分。共为十八天。又有合善见善现为一。而另立和音天之名者。《大般若经》。四天王天作四大王众天。忉利天作三十三天。兜率天作睹史多天。梵辅天下有梵会天。少光天之上有光天。光音天作极光净天。少净天之上有净天。广果天之上有广天。少广天。无量广天。而无福生天。福爱天。广果天之下无无想天。善现天在善见天之上。经律异相。婆舍跋提天又名爱身天。无福生天。福爱天。广果天。而有严饰天。少严饰天。无量严饰天。严饰果实天。世界名体志。则以福生天为无云天。福爱天为福生天。均小异。无色界四天。一，空无边处天。二，识无边处天。三，无所有处天。四，非想非非想处天。此天于五蕴中但有受想行识，而无色质。故曰无色界天。
    人道。人者。忍也。于世间违顺之情。能堪安忍。又仁也。天地之心。梵语作摩［少／兔］舍喃。各依夙业。分属赡部洲。毗提诃洲。瞿陀尼洲。拘卢洲。四洲人形俱上立。瞻部洲人面如车箱。毗提诃洲人面如半月。瞿陀尼洲人面如满月。拘卢洲人面如方池。见《大毗婆沙论》。
    阿修罗道。梵语旧翻无端正。新译作非天。此神果报最胜。有天之福。无天之德。邻次诸天而非天也。梵音素洛。此云天。阿此云无彼非天，故名阿素洛。又素洛为端正。彼非端正。名阿素洛。阿素洛在因之时。怀猜忌心。虽行五常。以欲胜他。故作下品十善。感此道身。虽为六道之一。有时亦分为别趣所摄。如《楞严经》曰。复有四种阿修罗类。若于鬼道。以护法力。乘通入空。此阿修罗。从卵而生。鬼趣所摄。若于天中。降德贬坠。其所卜居。邻及日月。此阿修罗。从胎而出。人趣所摄。有修罗王。执持世界。力洞无畏。能与梵王，及天帝释，四天，争权。此阿修罗。因变化有。天趣所摄。别有一分下劣修罗。生大海心。沉水穴口。旦游虚空。暮归水宿。此阿修罗。因湿气有。畜生趣摄。《起世经》曰。修罗所居宫殿，城郭，器用。降地居天一等。亦有婚姻男女。法式略如人间。修罗种类。男丑而女端正。
    地狱道又名火涂道。为三恶道之一。在地下铁围山间。瞻部洲下。过五百逾缮那。乃有地狱。其量大小不同。其寿延促各异。皆由众生造极恶业。报尽命终。至此受苦。梵语那落迦。此云恶者。造恶者所生处也。亦云不可乐。亦云苦具。又作泥犁耶。此云无乐。皆地狱之义。其大者曰八大地狱，亦名八热地狱。此八大地狱。每一狱有四门。每一门有四游增小狱。四门共成十六。为罪人游履时增加之狱。共大狱八。游增小狱一百二十八。是故经说有一百三十六那落迦。《准经律异相》及《诸经要集》所说。十六游增小狱之名。一，黑砂。二，沸屎。三，铁钉。四，饥饿。五，渴。六，铜鍑。七，多铜鍑。八，石磨。九，脓血。十，量火。十一，灰河。十二，铁丸。十三，釿斧。十四，豺狼。十五，剑树。十六，寒冰。八大地狱者。一，想地狱。亦名等活地狱。其中众生手生铁爪。其爪甚利。互相嗔忿。以爪相攫。肉即堕落。或被斫刺磨擦。想为已死。冷风吹之。皮肉还生。寻复活起。名想地狱。二，黑绳地狱。此中狱卒。以热铁绳絣牵罪人。然后斩锯。复有恶风。吹热铁绳。笼络其身。烧皮彻肉。焦骨沸髓。苦毒万端。名黑绳地狱。三，堆压地狱。亦名众合地狱。狱中有大石山。罪人入内。山自然合。堆压其身。骨肉糜碎。名堆压地狱。四，叫唤地狱。狱卒以罪人掷大镬中。沸汤烹煮。受诸痛苦。号啕叫唤。名叫唤地狱。五，大叫唤地狱。沸汤烹已。业风吹活。再向热铁鏊中煮熬。痛苦极切。发大叫唤。名大叫唤地狱。六，烧炙地狱。以铁为城。烈火猛焰。内外烧炙。皮肉糜烂。痛苦万端。名烧炙地狱。七，大烧炙地狱。以罪人置铁城中。烈火烧城。内外俱赤。烧炙罪人。又有火坑。火焰炽盛。其坑两岸。复有火山。捉彼罪人。贯铁叉上。著于火中。皮肉糜烂。名大烧炙地狱。八，无间地狱。即阿鼻地狱。为地狱之最重者。有罪众生。至此受苦。无有间歇。故名无间。一者。趣果无间。谓极重罪者。依业受报。无有间歇。二者。受苦无间。受诸痛苦。无有间歇。三者。时无间。受苦时节。无有间歇。四者。命无间。受罪众生寿命。为一中劫。无有间歇。五者。形无间。受罪众生。生而复死。死已复生。身形无有间歇。附于阿鼻地狱者。更有十八小地狱。每一小地狱。各有十八寒地狱。十八黑闇地狱。十八小热地狱。十八刀轮地狱。十八剑轮地狱。十八火车地狱。十八沸屎地狱。十八镬汤地狱。十八灰河地狱。五百亿剑林地狱。五百亿刺林地狱。五百亿铜柱地狱。五百亿铁机地狱。五百亿铁网地狱。十八铁窟地狱。十八铁丸地狱。十八尖石地狱。十八饮铜地狱。如是等众多地狱。八热地狱之外。又有八寒地狱。八寒地狱者。一，頞浮陀地狱。頞浮陀。此云疱。谓受罪众生。因寒苦所逼。皮肉疱起也。二，泥赖浮陀地狱。尼赖浮陀。此云疱裂。谓受罪众生。因寒苦所逼。疱即析裂也。三，阿吒吒地狱。阿吒吒亦作嚯嚯。谓受罪众生寒苦增极。唇不能动。唯于舌中作此声也。四，阿波波地狱。谓受罪众生。寒苦增极。舌不能动。惟于唇间作此声也。五，呕喉地狱。谓受罪众生。寒苦增极。唇舌均不能动。但于咽喉内振气而作此声也。六，郁波罗地狱。郁波罗，此云青莲华。谓受罪众生。寒苦增极。皮肉开析。似青莲华也。七，波头摩地狱。波头摩，此云红莲华。谓受罪众生。寒苦增极。肉色似红莲华也。八，芬陀利地狱。芬陀利，此云白莲华。谓受罪众生。寒苦增极，皮肉脱落。骨色如白莲华也。（见《翻译名义集》。按《诸经要集·十八》有十寒地狱。《经律异相·四十九》有九寒地狱，数既不同。名亦小异。《涅槃经·十一》。《智度论·十六》。说八种寒冰地狱。名亦不同。）此八寒地狱。与上八热地狱。皆为根本地狱（八寒亦为根本地狱，准妙玄亦具游增狱，与八热地狱同，俱舍图列热竖寒横。故八寒无游增狱。）。根本地狱外。又有孤独地狱。又名边地狱。则在山间，旷野，树下，空中。或一或多（或云八万四千）。苦具毕备。随业受报各各独受。故曰孤独地狱，详见《地藏本愿经》。《正法念处经》。《涅槃经》。《显宗论》。恐繁不引。
    饿鬼道又名刀涂道，三恶道之一。饿鬼。梵语薜荔多。此鬼以前世时。心多妒嫉。悭吝不施。夙因憍慢。广造十不善业。内无实德。空腹高心。凌人傲物。故受此报。寓气为质。常困饥虚。因饥虚故。故名为饿。恐怯多畏。故名为鬼。其罪业极重者。历劫不闻浆水之名。次者但伺求人间荡涤脓血粪秽。又其次者。时或一饱。众生由悭贪嫉妒造作恶业。生于此道。此为饿鬼通因。若别别之因。详见《饿鬼报应经》。《佛说杂藏经》。《佛说鬼问目连经》等。恐繁不引。按饿鬼之名。旧译特从鬼道中大量观察。举其最多者称之。鬼中亦有胜劣。不皆为饿。故新译曰鬼。不曰饿鬼。《顺正理论·三十一》云。鬼之种类有三。一，无财鬼。二，少财鬼。三，多财鬼。此三又各有三。无财鬼之三者。一，炬口鬼。二，针口鬼。三，臭口鬼。少财鬼之三者。一，针毛鬼。其毛如针。以自刺刺他也。二，臭毛鬼。三，瘿鬼，多财鬼之三者。一，希祠鬼。常居社庙中。希其食物也。二，希弃鬼。常希人之弃而食之也。三，大势鬼。大势大福如天也。《俱舍论·十一》云。或有端严。具大威德。受诸富乐。当属此类。亦有具神通者。无财少财饿鬼之障由外者。如水变为火，为脓血。由内者。自身咽喉如针，如炬，如瘿。由饮食者。或成燃烧。或为粪秽。或食自肉。纵得饮食。亦不能啖。《准正法念处经·十六》。饿鬼有三十六种。一，镬身。二，针口。三，食吐。四，食粪。五，无食。六，食气。七，食法。八，食水。九，希望。十，食唾。十一，食鬘。十二，食血。十三，食肉。十四，食香。十五，疾行。十六，伺便。十七，地下。十八，神通。十九，炽然。二十，伺婴儿便。二十一，欲色。二十二，海渚。二十三，阎罗王使执杖。二十四，食小儿。二十五，食人精气。二十六，罗刹。二十七，火炉烧食。二十八，不净巷陌。二十九，食风。三十，食火炭。三十一，食毒。三十二，旷野。三十三，住冢间食热灰土。三十四，树中住。三十五，四交道。三十六，杀身。其所住略有二种。一者。人中住。二者。住饿鬼世界。在阎浮提下五百由旬。三恶道中之饿鬼道。当然指无财鬼与少财鬼而言。多财鬼则为福德鬼神，属于八部。
    畜生道又名血涂道。三恶道之一。畜生，梵语底栗车。披毛，带角，鳞，甲，羽，毛，四足，多足，有足，无足，水，陆，空，行。其类非一。互相吞啖。受苦无穷，《大毗婆沙论》云。畜谓畜养。谓其横生覆身而行。形旁而行不正，故新译作傍生。由愚痴故。由谄曲业故。生于此道。
    四生者。胎卵湿化也。依壳而起曰卵生。含藏而出号胎生。假润而兴为湿生。无而忽现名化生。如是四生。由内心思业为因。外壳，胎藏，湿润，为缘。约藉缘多少而成次第。卵生具四。胎生具三。湿生具二。惟化生仅凭思业。此四生中。人及兽类属胎生。鸟类水族属卵生。如蚊如蛭。有水气之所。生物自行出生者属湿生。不藉外缘。无所依托。忽然而生者。如往生净土，诸天，地狱，中有，属化生。此从一般言也。特例则人亦有出于卵生者。如世罗邬波世罗。生从鹤卵。鹿母所生三十二子。般遮罗王五百子等。出于湿生者。如曼驮多。遮卢邬波。遮卢鸽鬘庵罗卫等。出于化生者。如劫初由光音天下降之人。见法苑珠林。鸟及龙类有具四生者。见《起世因本经》。阿修罗有具四生者。见《楞严经》。
    生净土者三品九生。皆属莲华化生。其有志意犹豫。虽修善业。信力不坚者。则生边地。五百岁不得见佛。亦名胎生。但仍系莲华化生，并非胎育。见《大阿弥陀经》。
    《杂集论·二》云。生者。谓于众同分诸行本无今有性。假立为生。问。外诸色等亦有生相。何故惟举众同分耶。答。为于有情相续，建立有为相故。所以者何。外诸色等有为相，成坏所显。内诸行有为相，生老等所显故。又四云。生有二种业。一，令诸有情名色，六处，触，受，次第生起。二，与老死作缘。令名色等次第生起者。能引后后位差别故。与老死作缘者。由有此生，彼相续变坏，皆得有故。
    《法蕴足论·五》云。云何生。谓彼诸有情类即于彼彼有情聚中诸生，等生，趣入，出现，蕴得，界得，处得，诸蕴生，命根起，总名为生。《瑜伽论·十》云。生云何。谓于胎卵二生初托生时。等生云何。谓即于彼身分圆满。仍未出时。趣云何。谓从彼出。起云何。谓出巳增长（界趣生等品类差别自体出现。说名为生。若无差别。后有相续。说名为起）。出现云何。谓于湿化二生身分顿起。蕴得云何。谓即于彼诸生位中五取蕴转。界得云何。谓即彼诸蕴因缘所摄性。处得云何。谓即彼诸蕴余缘所摄性。诸蕴生起云何。谓即彼诸蕴日日饮食之所资长。命根出现云何。谓即彼诸蕴余寿力故。得相续住。又九云。生差别者。当知复有五种。一，界差别。二，趣差别。三，处所差别。四，胜生差别。五，自身世间差别。界差别者。谓欲界及色无色界生差别。趣差别者。谓于五趣四生差别。处所差别者。谓欲界中有三十六处生差别。色界中有十八处生差别。无色界中有四处生差别。如是总有五十八生。胜生差别者。谓欲界人中有三胜生。一，黑胜生生。谓如有一生旃荼罗（屠脍）家。若卜羯娑（除粪担尸）家。若造车家。若竹作家。若生所余下贱贫穷乏少财物饮食等家。如是名为人中薄福德者。二，白胜生生。谓如有一生刹帝利大富贵家。若婆罗门大富贵家。若诸长者大富贵家。若生所余豪贵大富多诸财谷库藏等家。如是名为人中胜福德者。三，非黑非白胜生生。谓如有一非前二种生处中家者。又欲界天中亦有三种胜生。一，非天生。二，依地分生。三，依虚空宫殿生。又色界中有三种胜生。一，异生无想天生。二，有想天生。三，净居天生。又无色界中有三胜生。一，无量想天生。二，无所有想天生。三，非想非非想天生。自身世间差别者。谓于十方无量世界中。有无量有情。无量生差别。

    老。梵语歌啰。一切有情于众同分诸行相续变异性。后起诸行。与前差别。衰退闇钝。根熟变坏。说名为老。死。梵语摩刺喃一切有情。于众同分移转坏没。退失别离。寿暖识灭。命根不转。诸蕴破坏。说名为死。
    【注】《成唯识论·八》云。诸衰变位。总名为老。身坏命终。乃名为死。老非定有。附死立支。又云。老虽不定。遍故立支。诸界趣生。除中夭者。将终皆有衰朽行故。
    《俱舍论·五》云。命根体即寿。能持暖及识。何法名寿。谓有别法能持暖识。说明为寿。故世尊言。寿暖及与识。三法（阿赖耶识相分色法身根所得名暖。此识之种名寿。以能持识故。现行识名识。故云三法）。舍身时。所舍身僵仆。如木无思觉。又云。何法说名寿体。谓三界业所引同分住时势分。说名寿体。《杂集论·二》云。命根者。谓于众同分先业所感住时决定。假立寿命。众同分者。于一生中诸蕴相续。住时决定者。齐尔所时。令众同分常得安住。或经百年。或千年等。由业所引功能差别。
    《瑜伽论·八十四》云。死者其识弃舍心胸处故。《发智论·二》云。彼彼有情。从彼彼有情众同分移转坏没。舍寿暖命根。灭弃诸蕴。身殒丧。是谓死。
    《杂集论·四》云。老死有二种业。一，数令有情时分变异。坏少盛故。二，数令有情寿命变异。坏寿命故。

    此十二支法。辗转感果。因缘相续。循环无际。如轮回转。由过去世之无明（惑）与行（业）为因。感现在世之识名色六处触受之五果（苦）。是过去与现在一重因果。复从现在果起爱，取（惑），有（业），三支惑业。成现在因。感未来世生、老死之二果（苦）。是现在与未来一重因果。两重因果。通贯过去现在未来三世。现在之惑（爱取）业（有）既由现在之苦果（识名色六处触受）而生。则过去之惑（无明）业（行）自亦由过去之苦果（生老死）而生。现在之苦果（识，名色，六处，触，受）生现在之惑业。未来之苦果（生，老死）自亦生未来之惑业。上溯之则过去之惑业更从过去之苦果而来。下推之则未来之苦果更生未来之惑业。由因生果。果又成缘。过去无始。未来无终。无明、爱、取三支是惑为缘。行、有二支是业为因。识、名色、六处、触、受、生、老死七支是苦为果。生死轮回。流转不息。总不出惑、业、苦之三道。是为生相顺观。亦名染缘起。是凡夫法。属流转门。缘生性空。空本无生。故曰。无无明乃至无老死
    【注】染缘起者。清凉云。无明缘行等。前能生后。生死流转为染。无明缘行者。是观过去。识乃至爱。是观现在。爱乃至有。是观未来。于是以后。展转相续。
    《俱舍论·九》。颂曰。如是诸缘起。十二支三际。前后际各二。中八据圆满。论曰。十二支者。一，无明。二，行。三，识。四，名色。五，六处。六，触。七，受。八，爱。九，取。十，有。十一，生。十二，老死。言三际者。一，前际。二，后际。三，中际。即是过、未及现三生。云何十二支于三际建立。谓前后际各立二支。中际八支。故成十二。无明、行在前际。生、老死在后际。所余八在中际。此中际八。一切有情。此一生中。皆具有不。非皆具有。若尔。何故说有八支据圆满者。此中意说。补特伽罗历一切位名圆满者。非诸中天及色、无色。又云。有时但说二分缘起。一，前际摄。二，后际摄。前七支前际摄。谓无明乃至受。后五支后际摄。谓爱至老死。前后因果。二分摄故。

    若在缘觉。悟此诸法因缘。无明灭则行灭。行灭则识灭。识灭则名色灭。名色灭则六处灭。六处灭则触灭。触灭则受灭。受灭则爱灭。爱灭则取灭。取灭则有灭。有灭则生灭。生灭则老死灭。以还归于寂灭之涅槃。所谓若了无明。生死自息。是为灭相逆观。亦名净缘起。是缘觉法。名还灭门。以真空故。尽无可尽。故云。亦无无明尽。乃至亦无老死尽。诸法从本来。常自寂灭相。故无可尽也。
    【注】流转门对于还灭门而言。生观顺观属流转门。生观者观缘无明生行，缘行生识，乃至缘生生老死，次第生起之相。顺观者。顺生死观。观有漏业之行、有两支为因。无明、爱、取三支为缘。感识乃至老死等七支苦果之相也。流转门者。无始之无明。不达本觉之理性。起惑造业感生死之苦果。以流转三界六道也。还灭门者。流转之众生。厌生死之苦。修戒定慧三学。以还归于寂灭之涅槃也。灭观逆观属之。灭观者。观无明灭则行灭，乃至生灭则老死灭，次第灭坏之相也。逆观者。逆生死观。观无漏之正慧为因。正行为缘。证涅槃果之相也。
    净缘起者。清凉云。反本还源为清净也。

    《大般若经》曰。若菩萨摩诃萨。发一切智智相应之心。以无所得为方便。思惟无明缘行。行缘识。识缘名色。名色缘六处。六处缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死。乃至纯大苦蕴集。以无所得为方便。思惟无明灭故行灭。行灭故识灭。识灭故名色灭。名色灭故六处灭。六处灭故触灭。触灭故受灭。受灭故爱灭。爱灭故取灭。取灭故有灭。有灭故生灭。生灭故老死乃至纯大苦蕴灭。憍尸迦。是谓菩萨摩诃萨般若波罗蜜多。盖菩萨以般若观慧。照了无明诸法。体性皆空。无生灭相。故云。无无明亦无无明尽。乃至无老死。亦无老死尽。言无无明。是举流转初相空。言无无明尽。是举还灭初相空。言无老死。是举流转末相空。言无老死尽。是举还灭末相空。乃至者。略去中间十支。举始末以赅其余也。无无明。无行。无识。无名色。无六处。无触。无受。无爱。无取。无有。无生。无老死。是生相。以缘生性空故。无明尽。行尽。识尽。名色尽。六处尽。触尽。受尽。爱尽。取尽。有尽。生尽。老死尽。是灭相。以无生真空故。经言无无明乃至无老死。无无明尽乃至无老死尽。盖显般若真空。既无流转相。亦无还灭相。故无十二因缘。此不仅破众生我执之见。亦除二乘法执之病。《楞严经》曰。真性有为空。缘生故如幻。无为无起灭。不实如空华。无为有为。同一幻相故。
    【注】憍尸迦为帝释本姓。释提桓因为人时。在摩诃陀国为婆罗门。名摩伽。姓憍尸迦。见《智度论》。
    《因果经》曰。尔时菩萨至第三夜。观众生性。以何因缘而有老死。即知老死以生为本。若离于生。则无老死。又复此生不从天生。不从自生。非无缘生。从因缘生。因于欲有、色有、无色有，业生。又观三有业从何而生。即知三有业从四取生。又观四取从何而生。即知四取从爱而生。又复观爱从何而生。即便知爱从受而生。又复观受从何而生。即便知受从触而生。又复观触从何而生。即便知触从六入生。又观六入从何而生。即知六入从名色生。又观名色从何而生。即知名色从识而生。又复观识从何而生。即便知识从行而生。又复观行从何而生。即便知行从无明生。若灭无明则行灭。行灭则识灭。识灭则名色灭。名色灭则六入灭。六入灭则触灭。触灭则受灭。受灭则爱灭。爱灭则取灭。取灭则有灭。有灭则生灭。生灭则老死忧悲苦恼灭。如是逆顺观十二因缘。第三夜分。破于无明。明星出时。得智慧光。断于习障。成一切种智。
    十二因缘不出惑业苦三。业种自然。如恶叉聚（西域有树。结果三为一聚。喻惑业苦三。不相离也）。《缘生论》云。初、八、九烦恼。第二、第十业。余七皆是苦。三摄十二法。初二是过去。后二未来时。余八是现在。此谓三时法。恼起业感报。报还生烦恼。烦恼复生业。亦由业有报。离恼何有业。业坏亦无报。无报则离恼。此三各自灭（初，无明。八，爱。九，取。是三烦恼，即惑。二，行。十，有。是业。余七，识。名色。六处。触。受。生。老死。是苦。此十二法三种所摄。初，无明。二，行。是过去时。十一，生。十二，老死。是未来时。识、名色、六处、触、受、爱、取有八种。是现在时。又此等各各次第相生。由烦恼故有业。由业故有报。还由报故有烦恼。由烦恼故有业。由业故有报。若此心无烦恼。则不集业。若不作业。则不受报。若灭报。则亦不生烦恼。如是此三各各自灭）。《十二因缘论》云。因缘所生法。彼为三所摄。烦恼业及苦。次说应当知。烦恼初八九。业二及以十。余七说为苦。三摄十二法。从三故生二。从二故生七。从七复生三。是故如轮转（初为无明。八爱。九取。此三是烦恼所摄。二为行。十为有。此二是业所摄。余七是苦所摄。从三生二。三是烦恼。二是业。谓从烦恼而生于业。从二生七。七者是苦。谓从于业而生于苦。从七生三者。谓从于苦而生烦恼。此说烦恼业苦三种迭互相生。是故生有轮转不定。所言有者。所谓欲、色、无色、界等。彼中不住。喻如轮转）。
    《四品法门经》曰。佛告阿难。智者应知。十二缘法。从因缘起。由因缘故。即有诸法。因缘者何。所谓无明缘行。行缘识。识缘名色。名色缘六处。六处缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。如是即一大苦蕴集。若了知缘生之法。因缘性空。缘聚即有。缘散即无。缘法无故。即无诸法。所谓无明灭即行灭。行灭即识灭。识灭即名色灭。名色灭即六处灭。六处灭即触灭。触灭即受灭。受灭即爱灭。爱灭即取灭。取灭即有灭。有灭即生灭。生灭即老死忧悲苦恼灭。如是即一大苦蕴灭。如是生灭之法。智者应当如实了达。《大乘舍黎娑担摩经》。慈氏菩萨告舍利子。十二缘生。所谓无明缘行。行缘识。识缘名色。名色缘六处。六处缘触。触缘受。受缘爱。爱缘取。取缘有。有缘生。生缘老死忧悲苦恼。如是生者。即一大苦蕴生。彼无明灭即行灭。行灭即识灭。识灭即名色灭。名色灭即六入灭。六入灭即触灭。触灭即受灭。受灭即爱灭。爱灭即取灭。取灭即有灭。有灭即生灭。生灭即老死忧悲苦恼灭。如是灭即一大苦蕴灭。《智度论·五》云。十二因缘生法种种法门。能巧说烦恼业事次第展转相续生。是名十二因缘。是中无明爱取三事为烦恼。行有二事名业。余七分名事。是十二因缘。初二，过去世摄。后二，未来世摄。中八，现前世摄。是略说三事烦恼业苦。是三事展转。更互为因缘。


第三目 四谛

    无苦。集。灭。道。

    谛有审、实二义。审就智言。菩萨大智。详审无妄。实就境言。世。出世间。因果。决定真实。云四谛者。苦集灭道。前二谛是世间因果。令知苦以断集。后二谛是出世间因果。使为灭以修道。集为迷之果。道为悟之因。灭为悟之果。所以先果而后因者。果易见而因难知。故先示苦令其厌。然后使断其因。又示涅槃妙果使之乐。然后使修其道。是为诱引小乘初机之说法方便。但其理则通于大小乘一切佛法。台宗依《涅槃经》所说。立四种四谛，以配藏、通、别、圆四教。本经所说。为生灭四谛。属藏教摄。声闻乘所修之法也。声闻以析空观谛审苦集灭道之法。破见思烦恼。证真谛理。既无苦集。何有灭道。四谛皆空。故云无也。
    【注】四谛。《涅槃经》亦作四圣谛。四真谛。圣者。正也。真者。实也。惟诸圣者如实了知。故名圣谛。名真谛。
    四谛有三转。一，示相转。此是苦。逼迫性。此是集。招感性。此是灭。可证性。此是道。可修性。二，劝修转。此是苦。汝应知。此是集。汝应断。此是灭。汝应证。此是道。汝应修。三，作证转。此是苦。我已知。此是集。我已断。此是灭。我已证。此是道。我已修。苦集灭道四谛。各有四行相。即以智力向苦谛作无常（世间诸法，缘聚则生，缘尽则灭）、苦（于身心皆逼恼性）、空（谓无可为我之所有）、无我（无常。一主宰之义）之观，是为苦谛四行相。向集谛作因（惑业能生苦果。如种生芽）、集（惑业积集成苦。如隐而现）、生（使苦果相续。生生不绝）、缘（助成苦果。如水土之滋润植物）之观，是为集谛四行相。向灭谛作灭（断尽五蕴）、静（止息三毒）、妙（无一切过患）、离（解脱诸灾难）之观，是为灭谛四行相。向道谛作道（圣贤践履）、如（契于正理）、行（进趋涅槃）、出（超出生死）之观，是为道谛四行相。共十六行相。如是观成。即证暖位。
    声闻观四谛而生之八忍八智。谓之无漏十六心。凡断一惑。必经无间、解脱二道。无间道有八忍。苦谛苦法智忍为第一心。苦类智忍为第三心。集谛集法智忍为第五心。集类智忍为第七心。灭谛灭法智忍为第九心。灭类智忍为第十一心。道谛道法智忍为第十三心。道类智忍为第十五心。解脱道有八智。苦谛苦法智为第二心。苦类智为第四心。集谛集法智为第六心。集类智为第八心。灭谛灭法智为第十心。灭类智为第十二心。道谛道法智为第十四心。道类智为第十六心。前十五心属见道位。第十六心属修道位。
    析空观者。析即分析。谓分析五蕴十二处十八界。析色至于极微，析心至于一念之观。小乘之观法也。与大乘菩萨直观诸法如幻如梦，即体显空之体空观不同。
    《文句》云。苦谛。谓二十五有依正二报也。集谛。谓见思惑也。灭谛。谓灭前苦集。显偏真理。因灭会真。灭非真谛也。道谛。谓戒定慧也。《会要》云。逼迫名苦。增长名集。寂静名灭。出离名道。清凉云。逼迫名苦。即有漏色心。增长名集。即业烦恼。寂静名灭。谓即涅槃。出离名道。谓止观等（等者。等取八正道等）。
    《瑜伽论·六十四》云。云何苦谛。谓生苦等。一切生杂染事皆名苦谛。云何集谛。谓说一切烦恼杂染及业杂染（能生后有诸行业及烦恼）。皆名集谛。云何灭谛。所谓一切烦恼永断。云何道谛。谓资粮道、若方便道、若清净道，如是一切总略为一。说名道谛。

    云何生灭四谛。谓因缘生法。有生有灭。一，苦谛。苦，梵语豆佉。以逼迫为义。一切有为心行。常为无常患累之所逼恼。受三界六道生死苦果。是名苦谛。二，集谛。集，梵语三牟提耶。以招聚为义。心与结业相应。以贪嗔痴等烦恼及善恶诸业。招聚未来三界六道生死苦果。是名集谛。为苦谛因。三，灭谛。灭，梵语尼楼陀。以寂灭为义。结业既尽。则无生死之患累。以诸烦恼结使灭故。三界业亦灭。即是灭谛有余涅槃。因灭故果灭。舍此报身时。后世苦果。永不相续。名入无余涅槃。谛审涅槃。实为寂灭。是名灭谛。四，道谛。道，梵语末迦。以能通为义。通涅槃之道路也。声闻谛审戒定慧之道。能到涅槃。是名道谛。为灭谛因。道从泛义说。有正有助。正道为三十七道品。三解脱门。缘理慧行。助道为得解观中诸对治法及诸禅定等。
    【注】四种四谛。一，生灭四谛。藏教所摄。如上所诠。二，无生四谛。通教所摄。谓三乘利根者。用体空观（直观法体如幻如梦。即体显空之观）。体达五蕴诸苦。当体即空。如幻如化。无逼迫相。是名苦谛。审实惑业之因。当体即空。无和合相。是名集谛。审实五蕴生死等苦。昔本无生。今亦无灭。是名灭谛。审实所破之集。能破之道。同一真空。无有二相。是名道谛。三，无量四谛。别教所摄。菩萨谛观十法界果报不同。众生生死诸苦。一一不虚。故云。苦有无量相。谛观十法界众生五住惑业。种种不同。实能招聚生死之苦。故云。集有无量相。谛观六波罗蜜种种不同。能证涅槃寂灭之理。故云。灭有无量相。谛观恒河沙法门。自利利他。故云。道有无量相。四，无作四谛。圆教所摄。大乘菩萨圆观诸法。事事即理。无有造作。故云蕴（五蕴）处（六处）皆如（真如）。无苦可舍。是为苦谛。尘劳本清净。烦恼即菩提。无招集生死之相。是为集谛。谛观一切中道。离边邪见。无烦恼之惑可断。亦无菩提之道可修。是为道谛。生死涅槃。体元不二。无生死逼迫之苦可断。亦无涅槃寂灭之乐可证。是为灭谛。
    六根为因。六尘为缘。根尘相对所起之心。谓之因缘生法。
    集谛为苦谛因者。因烦恼惑业等所集之集因（《杂集论》谓之因相，由业烦恼，是引发后有习气之因故）、集集（《杂集论》谓之集相，谓彼彼有情所集习气，于彼彼有情类为等起因，于人天等有情类中能为相似形貌种类平等起因故）、集生（《杂集论》谓之生相，谓诸有情各别内身相续决定趣生地等，所有一切品类差别，乃至有顶生因故）、集缘（《杂集论》谓之缘相，谓诸有情别别得舍之因，即得未曾得自体，舍已曾得自体故）为因。而生苦果。欲灭苦果。当灭苦因。故集谛灭则苦谛不生。
    灭谛以无我对治集谛烦恼。盖一切烦恼结使。皆由我执而生。故无我为灭谛之体相。
    三十七道品者。第一。四念住（亦作四念处）。念即是观。住即是境。一，身念住（虽于内身、外身、内外身住循身观。不起身俱寻思。若为对治凡夫净颠倒。以不净为净。则曰观身不净）。二，受念住（虽于内受、外受、内外受住循受观。不起受俱寻思。若为对治凡夫乐颠倒。于苦计乐。则曰观受是苦）。三，心念住（虽于内心、外心、内外心住循心观。不起心俱寻思。若为对治凡夫常颠倒。于无常计常。则曰观心无常）。四，法念住（虽于内法外法内外法住循法观。不起法俱寻思。若为对治凡夫我颠倒。于无我计我。则曰观法无我）。第二。四正断（亦作四正勤）。发起正勤。策心持心。一，律仪断。已生恶令永断。二，断断。未生恶令不生。三，修断。已生善法令增长。四，防护断。未生善法令生。第三。四神足（亦作四如意足）。一，欲三摩地。二，勤三摩地。三，心三摩地。四，观三摩地。修此四三摩地断行成就神足（依离。依无染。依灭回向舍）。第四。五根。一，信根。二，精进根。三，念根。四，定根。五，慧根。第五。五力。一，信力。二，精进力。三，念力。四，定力。五，慧力。第六。七等觉支（亦作七觉分）。一，念等觉支。二，择法等觉支。三，精进等觉支。四，喜等觉支。五，轻安等觉支。六，定等觉支。七，舍等觉支（依离。依无染。依灭回向舍。第七。八圣道支（亦作八正道）。一，正见。见四谛之理而明之。以无漏之慧为体。二，正思唯。见四谛之理而使真理增长。以无漏之心所为体。三，正语。以真智修口业。不作一切非理之语。以无漏之戒为体。四，正业。以真智除一切邪业。住于清净之身业也。以无漏之戒为体。五，正命。清净身口意三业。离五种之邪命（比丘行不如法事而为生活。一，诈现异相以求利养。二，自说功能以求利养。三，占相吉凶以求利养。四，大言现威以求利养。五，说利动人以求利养。谓之五邪命）。以无漏之戒为体。六，正精进。以真智勤修涅槃之道。以无漏之勤为体。七，正念。以真智忆念正道而无邪念。以无漏之念为体。八，正定。以真智入于无漏清净禅定。以无漏之定为体（依离。依无染。依灭回向舍）。以上七门。是为三十七菩提分法。
    三解脱门。一，空。二，无相。三，无愿。
    缘理。即观念真理之意。
    慧行。即般若波罗蜜之三行。六度万行中之正行。
    得解观中诸对治法。一，厌患对治。二，断对治。三，持对治。四，远分对治。厌患对治。谓加行道。在见道以前。缘苦集二谛生深为厌患之念也。断对治。谓无间道。于无间道缘四谛而正断烦恼也。持对治。谓解脱道。于无间道后起解脱道。更缘四谛摄持彼无间道所得择灭之得。以使所断烦恼不更起也。远分对治。谓胜进道。于解脱道后入于胜进道。更缘四谛所断之惑转更远也。
    禅定有八。初静虑。第二静虑。第三静虑。第四静虑。空处。识处。无所有处。非想非非想处。
    《瑜伽论·二十七》云。云何苦圣谛。谓生苦。老苦。病苦。死苦。怨憎会苦。爱别离苦。求不得苦。略说一切五取蕴苦。名苦圣谛。云何集圣谛。谓若爱。若后有爱。若喜贪俱行爱。若彼彼喜乐爱等。名集圣谛。云何灭圣谛。谓即此爱等无余断灭。名灭圣谛。云何道圣谛。谓八支等圣道。名道圣谛。《大毗婆沙论·七十七》云。逼迫是苦相。生长是集相。寂静是灭相。出离是道相。又云。流转是苦相。能转是集相。止息是灭相。还灭是道相。又云。生依流转是苦相。能转生依是集相。生依止息是灭相。能灭生依是道相。

    此四谛法。如以药病喻。苦集二谛。是世间因果。属流转门为病。灭道二谛。是出世间因果。属还灭门为药。凡夫二乘。不知三界如幻如化。本自无生。性相寂灭。生死涅槃。犹如昨梦。而于无生法中。妄见生灭。横受轮回。譬如阳焰非水。妄作水想。徒自疲劳。如来令彼知苦，断集，慕灭，修道，永息苦本。声闻之人。耽寂灭乐。以为实证菩萨修般若观。见真空理。五蕴诸法。当体即空。无生灭修证之法。故生死即涅槃。烦恼即菩提。无苦可舍。无集可断。无灭可慕。无道可修。以生灭，修证，自性空故。故曰无苦集灭道。


第四目 智得

    无智。亦无得。

    无者。空也。否定事物存在之辞。智。梵语若那。于事理决断之义。知一切法之总相者为一切智。总相即空相。声闻辟支佛之智也。知种种差别之道法者为道相智。菩萨智也。知总相别相。化道断惑。一切三世法中诸法实相大小精粗，无事不知，以名相、文字、言说通达无碍者。名一切相智。佛智也。《止观》云。佛智照空。如二乘所见。名一切智。佛智照假。如菩萨所见。名道种智。佛智照空假中。皆见实相。名一切种智。故言三智一心中得。
    得。梵语钵罗钵多。为二十四不相应行之一。于一切法造作成就也。
    【注】大小乘经分智之种类甚多。约举如下。
    一智。即阿耨多罗三藐三菩提。见《智度论·八十五》。
    二智。有七种。一，如理智与如量智。诸佛菩萨以如实之智。彻见实际之理。妙极寂静。名如理智。诸佛菩萨究竟通达一切境界。若见众生乖于理智。则成生死。称于理智。则得涅槃。是名如量智。二，观察智与取相智。以智慧照了人法二空所显真如之理。了知能证所证二俱不可得。名观察智。善取法界之相。若事若理。以智慧照了。悉使法法圆融。事理无碍。名取相智。见《华严经随疏演义钞》。三，根本智与后得智。根本智亦名无分别智。此智不依于心。不缘外境。了一切法皆即真如。境智无异。如人闭目。外无分别。由此无分别智。能生种种分别。名根本智。依止于心。缘于外境种种分别。境智有异。如人开目。众色显现。以于根本智后所得。名后得智。见《摄大乘论》。四，尽智与无生智。阿罗汉断三界见思惑竟。即知我生已尽。梵行清净。名尽智。阿罗汉断三界见思惑竟。知诸缚已解。更不于三界受生。名无生智。见《大集经》。五，一切智与道种智。一切内法内名。外法外名。能知能解。名一切智。即声闻缘觉之智也。能用诸佛一切道法。发起众生一切善种。名道种智。即菩萨之智也。见《观音玄义》。六，真智与俗智。照了真谛理性之智曰真智。照了俗谛事相之智曰俗智。见《摄大乘论》。七，实智与权智。达于佛菩萨实理之智曰实智。通于佛菩萨权宜方便之智曰权智。又名方便智。见《维摩诘经会疏》。上开分别。随方便说。名异实同。如如理智，与根本智，真智。皆同一义也。
    三智。一，真智。体解无物。本来寂静。通达无涯。净秽不二。故名真智。二，内智。自觉无明。割断烦恼。心意寂静。灭无有余。此名内智。三，外智。分别根门。识了尘境。博览古今。皆通俗事。此名外智。见《宗镜录·十五》。又一，世间智。凡夫外道于一切法执著分别。不能出离世间。名世间智。二，出世间智。声闻。缘觉。以一切智。修四谛行。而能出离世间。名出世间智。三，出世间上上智。佛菩萨观察一切诸法寂静之相。不生不灭。得如来地。超出声闻、缘觉之智也。见《楞伽经》。又一切智，道种智，一切种智，亦称三智。见《智度论》。《准瑜伽论》。于一切界（一，世界。二，有情界）。一切事（一，有为。二，无为）。一切品（即有为、无为二事无量品别。名一切品。谓自相辗转种类差别故。共相差别故。因果差别故。界趣差别故。善不善无记等差别故）。一切时（一，过去。二，未来。三，现在）。智无碍转。如实知故。名一切智。于一切法中无颠倒智。是名如来一切种智。《观音玄义》云。能用诸佛一切道法。发起众生一切道种者名道种智。
    无分别智有三种。一，加行无分别智。约因而差别之有三。谓因缘，引发，数习，生差别故（因缘者，种性为因而得生故。引发者，由前生数习为因而得生故。数习者，由现在生士用力为因而得生故）。二，根本无分别智。约人而差别之有三。谓喜足，无颠倒，无戏论，无分别，差别故（菩萨住异生地。知已到闻思究竟。便生喜足。诸有情计上生第一有，见为涅槃。便生喜足。名喜足无分别智。声闻等知彼等通达真如。得无常等四无倒智。无常等四颠倒分别。名无颠倒无分别智。诸菩萨知菩萨于一切法乃至菩提皆无戏论，不可以言说宣示故。名无戏论无分别智）。三，后得无分别智。
四智。唯识宗所立。凡夫八识。如来转成四智。一，转第八识为大圆镜智。有漏之第八识。变依正二报。而持有情之身。此智变如来之身土。而持一切之功德。名大圆镜智。缘境无边。照法界之事理。故又名一切种智。二，转第七识为平等性智。反于第七识之我见。而达无我平等之理。于一切众生起无缘大悲之智也。三，转第六识为妙观察智。观察诸法之相。而施说法断疑之用之智也。四，转眼耳鼻舌身五识为成所作智。为利一切凡夫二乘。示现种种变化神通之智也。如来之现化身土及诸神通皆此智作用。见《唯识论·十》。此宗为破实我实法之所执。显示心外无有实境。更立菩萨所观四智。第一。相违识相智。同一处所。人，天，饿鬼所见。各随业力而殊，境若实有。何能随业而变。第二。无所缘识智。缘于过去，未来，梦幻非实之境时。境非实有。而心能现相。可征一切境界。皆心所变。第三。自应无倒智。境若为实。则一切凡夫本来证悟心外之境。应不假功用。自然成就。今则不然。可征境非实有。第四。随三智转智。一，随自在者智转智。已证得心自在者。依定力变土木为金宝。境若实有。何能随心转变。二，随观察者智转智。得胜定而修观者。观一境而青瘀等相。随心显现。境若实有。何能随心转变。三，随无分别智转智。证得无分别智。一切境相皆不现前。境若实有。何能不现。菩萨成就所观四智。于唯识理决定悟入。证知心外更无实境。又《集异门论·七》。以法智，类智，他心智，世俗智，为四智。复以苦智，灭智，集智，道智，为四智。《最胜王经》则以一，一切智。二，净智。三，不思议智。四，不动智。为四智。
    五智。显教转八识成四智。密教加一法界体性智为五智。此智是转庵摩罗识所得。法界有差别之义。诸法差别。其数过于尘沙。是为法界。法界体性即六大。大日住于六大法界之三昧。名为法界体性智。主方便究竟之德。以配大日如来。大圆镜智主发菩提心之德。以配东方之阿閦如来。平等性智主修行之德。以配南方之宝生如来。妙观察智主成菩提之德。以配西方之阿弥陀如来。成所作智主入涅槃之德。以配北方之不空成就如来。依五智而生三身。法界体性智之身业为毗卢遮那如来。口业为普贤菩萨。意业为不动金刚。大圆镜之身业为阿閦如来。口业为文殊师利菩萨。意业为降三世金刚。平等性智之身业为宝生如来。口业为虚空藏菩萨。意业为军荼利金刚。妙观察智之身业为阿弥陀如来。口业为观自在菩萨。意业为六足金刚。成所作智之身业为释迦如来或不空成就如来。口业为金刚业菩萨。意业为摩诃药叉金刚。见《莲华三昧经》。
    八智。大乘菩萨证欲界四谛之智。谓之四法智。证上二界四谛之智。谓之四类智。四法，四类。合为八智。一，苦法智。断欲界苦惑已而证真理之智也。二，集法智。断欲界集惑已而证真理之智也。三，灭法智。断欲界灭惑已而证真理之智也。四，道法智。断欲界道惑已而证真理之智也。五，苦类智。断上二界苦惑已而证真理之智也。六，集类智。断上二界集惑已而证真理之智也。七，灭类智。断上二界灭惑已而证真理之智也。八，道类智。断上二界道惑已而证真理之智也。见《俱舍论·二十三》。
    十智。大乘十智为如来所具者。一，三世智。于三世法通达圆明之智也。二，佛法智。通达一切佛法说法度生之智也。三，法界无碍智。知一切众生本具法界之体。事理圆融。不相障碍之智也。四，法界无边智。知众生色，心，诸法充满一切而无边际之智也。五，充满一切世界智。如来从定起广大妙用。周遍充满于世间之智也。六，普照一切世间智。如来有大智慧光明普照无量世界之智也。七，住持一切世界智。如来有大神力，住持世间摄化一切众生之智也。八，知一切众生智。如来知一切众生善恶因缘之智也。九，知一切法智。如来既知所化众生。复知能化诸法之智也。十，知无边诸佛智。如来出现于无边诸佛世间。说法教化一切众生之智也。见《华严经·十六》。小乘十智。一，世俗智。见谛以前一切凡夫之智也。与烦恼相应。故称有漏智。二，法智。证欲界苦集灭道之智也。三，类智（《智度论·二》作比智）。证上二界苦集灭道之智也。四，苦智。五，集智。六，灭智。七，道智。知上下界苦集灭道之智也。八，他心智。知他人心之智。九，尽智。既断尽一切烦恼。则知我既知苦，断集，证灭，修道。即断尽烦恼时所生之自信智也。十，无生智。利根罗汉于四谛知断证修之事已毕。见思惑尽。更不受生三界之智也。钝根罗汉有更退没而需知断证修者。则不能具此智。见《俱舍论·二十六》。
    十一智。菩萨摩诃萨大乘相有十一智。一，法智。知五蕴等差别相转。二，类智。知蕴、界、处，及诸缘起若总、若别是无常等。三，世俗智。知一切法假设名字。四，他心智。知他有情心、心所，法及修行证灭。五，苦智。知苦应不生。六，集智。知集应永断。七，灭智。知灭应作证。八，道智。知道应修习。九，尽智。知贪嗔痴尽。十，无生智。知有趣不复生。以上十智。皆以无所得为方便。故为大乘。十一，如实智。则如来之一切相智。一切诸法。皆无自性。无生无灭。本来寂静。自性涅槃。无所得相。名一切相。一切行相。皆正了知。名一切相妙智。此十一智名目。分见《大般若经·三》、《智度论·二十三》。类智，论作比智。世俗智，论作世智。
    十三智。一，闻所生智。二，思所生智。三，世间修所生智。四，胜义智。五，他心智。六，法智。七，种类智。八，苦智。九，集智。十，灭智。十一，道智。十二，尽无生智。十三，大乘智。见《杂集论·三》。
    十八智。一，不二智。知一切二。二，无相智。知一切相。三，无分别智。知一切分别。四，无异智。知一切异。五，无差别智。知一切差别。六，无世间智。知一切世间。七，无世智。知一切世。八，无众生智。知一切众生。九，无执著智。知一切执著。十，无住处智。知一切住处。十一，无杂染智。知一切杂染。十二，无尽智。知一切尽。十三，究竟法界智。于一切世界示现身。十四，离言音智。示不可说言音。十五，一自性智。入于无自性。十六，一境界智。现种种境界。十七，知一切不可说智。现大自在言说。十八，证一切地智。为教化调伏一切众生故。于一切世间示现大神通变化。见唐译《华严经·五十五》。晋译《华严经·三十八》。
    二十智。台宗约四教而明二十智。藏教七智。一，世智。二，外凡智。三，内凡智。四，四果智。五，辟支佛智。六，菩萨智。七，佛智。通教五智。一，四果智。二，支佛智。三，入空之菩萨智。四，出假之菩萨智。五，佛智。别教四智。一，十信智。二，住行向之三十心智。三，十地等觉智。四，佛果智。圆教四智。一，五品智（圆教外凡位浅深次序之别。有五品。一，随喜品。二，读诵品。三，说法品。四，兼行六度品。五，正行六度品）。二，六根智。三，住行向地之四十心智。四，佛智。见《辅行记·三》。
    三十五智。一，预流果智。二，一来果智。三，不还果智。四，阿罗汉果智。五，独觉菩提智。六，诸佛无上正等菩提智。七，四念住智。八，四正断、四神足、五根、五力、七等觉支、八圣道支智。九，空解脱门智。十，无相无愿解脱门智。十一，四静虑智。十二，四无量、四无色定智。十三，八解脱智。十四，八胜处、九次第定、十遍处智。十五，布施波罗蜜多智。十六，净戒、安忍、精进、静虑、般若波罗蜜多智。十七，一切陀罗尼门智。十八，一切三摩地门智。十九，苦圣谛智。二十，集灭道圣谛智。二十一，内空智。二十二，外空、内外空、空空、大空、胜义空、有为空、无为空、毕竟空、无际空、散空、无变异空、本性空、自相空、共相空、一切法空、不可得空、无性空、自性空、无性自性空智。二十三，真如智。二十四，法界、法性、不虚妄性、不变异性、平等性、离生性、法定、法住、实际、虚空界、不思议界智。二十五，菩萨十地智。二十六，五眼、六神通智。二十七，如来十力智。二十八，四无所畏，四无碍解，大慈、大悲、大喜、大舍，十八佛不共法智。二十九，无忘失法智。三十，恒住舍性智。三十一，一切智智（此谓一切智之智。与如来一切智智有别）。三十二，道相智，一切相智，智。三十三，一切世间出世间法智。三十四，有漏无漏法智。三十五，有为无为法智。是名圣法。见《大般若经·三百八十》。
    四十四智。约十二因缘中行、识、名色、六处、触、受、爱、取、有、生、老死十一支各依四圣谛观察。建立四十四有漏智。知行智。知行集智。知行灭智。知趣行灭行智。乃至知老死智。知老死集智。知老死灭智。知趣老死灭行智。不说无明者。以无明不以有支为因。亦非有支之果也。见《瑜伽论·十》。《大毗婆沙论·一百十》。《发智论·十》。
    七十七智。观十二因缘中后十一支之闻思修三慧有漏智也。此一支每支各有七智。七智者。每支依顺观、逆观为二智。按三世，过现未共得六智。此六智缘理如实而知。名真实智。属思慧与修慧。更从闻教而知三世缘起之道。名法住智。为第七智。属闻慧。十一支共得七十七智。见《对法论·四》。
    得有四种。一，法俱得。谓所得法在。法亦现在也。二，法前得。法尚未来。得生于前也。三，法后得。法已过去。得尚在也。四，非前后俱得。无过去、现在、未来之别。即择灭、非择灭之得。前三属有为法。后一属无为法。

    智即能观之知。得即所证之理。无智则能观知空。无得则所空境空。境非智不了。智非境不生。外境如如。内智寂寂。无如外之智能证于如。亦无智外之如为智所证。如智都冥。智得同空。无得则无空相。无智则无知空相者。无空相则无实相。无知空相者则无观照。不但蕴、处、界、缘、谛诸法皆空。即三乘人能证所证。及修般若菩萨，空诸法之智。与空智所得之理亦无。盖法性本空。蕴、处、界、缘、谛诸法空故。能证诸法本来是空之般若智慧亦空。此般若智慧空故。由般若智慧观照所得之真空实相亦空。一物不干。万缘都尽。方是真般若。故《金刚经》曰。佛说般若波罗蜜。即非般若波罗蜜。《大般若经》曰。善男子善女人等。修般若时。作如是念。我能修慧。彼是慧境。此般若果。般若自性。彼修慧时名住般若。不名般若波罗密多。以有所得为方便故。若菩萨摩诃萨修般若时。不得慧者。慧境。慧果。般若自性。以无所得为方便故。能满般若波罗蜜多。又曰。如是般若波罗蜜多。以虚空为相。以无著为相。以无相为相。何以故。般若波罗蜜多甚深相中。诸法诸相。皆不可得。无所有故佛言。善现。住菩萨乘诸善男子善女人等。若有方便善巧。以无所得为方便。于此般若波罗密多名。不取名相。不起耽著。不住憍慢。便能证得实相般若。又曰。虽达一切法自性皆空。而诸菩萨因此般若波罗蜜多。证得无上正等菩提。转妙法轮。度无量众。虽证菩提而无所证。证不证法皆不可得故。惟不可得。即无能证所证。诸妄知见。由无妄见。故无颠倒之烦恼。若有所证。即是颠倒梦想。岂得涅槃菩提。《智度论》云。菩萨深入空故。知空亦空。涅槃亦空。故无所证。以证不证法不可得故。始从五蕴。终至四谛。乃修道人所观之境。夫境不能自空。假真智观照以空。及空相既显。则空理亦无。《楞严经》曰。觉所觉空。空所空灭。般若如大火聚。无论净秽。触处皆烧。真空理显。凡情荡尽。真如圣境。一切智悉不可得。故世间蕴处界。出世间因缘诸谛。以及能证之智。所证之得。莫不皆空。人法两忘。境智双泯。病去而药亦除。故曰无智亦无得。《大般若经》曰。一切法自相皆空。能取所取不可得故。于一切法无所取著。能从此岸到彼岸故。若于诸法稍有取著。则于彼岸非为能到。又曰。过去未来现在智见。无著无缚。亦无解脱。何以故。以一切法著不可得。缚不可得。著缚既无。从彼解脱，亦不可得。但无智无得。并非灰身灭智之谓。其云无者。但破彼执著于二取。非谓真智圣境。一切都无。《显扬论》云。无所得者。推求诸法不见自性。非一切种都无所得。《靖迈疏》云。上来为破于蕴等遍计所执。故借空以遣之。又恐人即以空为究竟所证得境。故又遣之。明此空亦复非是所证得境。《华严经》曰。无中无有二无二亦复无。盖以空遣空。空空亦迹。遣之又遣。以至无遣。甚至无遣亦无。方为第一义空。《中观论》云。大圣说空法。为离诸相故。若复见于空。诸佛所不取。何以故。本为有病。借空以除。有病既除。空亦不存。《略疏》云。知空智不可得。故云无智。所知空理亦不可得。故云无得。是故所取非有。能取亦无。无智之智。方为真智。无得之得。方为真得。
    【注】方便。方者方法。便者便用。便用契于一切众生之机之方法也。又方为方正之理。便为巧妙之辞。《往生论》云。正直曰方。外己曰便。般若者。达如之慧名。方便者。通权之智称。达如则心行寂灭。通权则备省众机。方便是善巧之名。故常曰方便善巧。
    体无相之真理。心中无所执著。无所分别。名无所得。即空慧也。无分别智也。
    名相。一切之事物。有名有相。耳可闻谓之名。眼可见谓之相。皆是虚假。而非契于法之实性。凡夫常分别此虚假之名相。而起种种妄想。
    憍慢之慢。五顺上分结之一。自高凌物之心也。《大乘义章》云。自举凌物。称曰憍慢。《俱舍论》云。慢对他心举。憍由染自法。心高无所顾。百法中慢为烦恼法。憍为随烦恼法。所谓上分结者。对于欲界之五顺下分结（一，贪。二，嗔。三，身见。四，戒取。五，疑）而言。此则为上二界之结惑。一，色爱结。即色界思惑。于上妙五欲。取著无厌也。二，无色界结。即无色界思惑。无色界众生。虽无色质。而于受想等法。未能舍离。取著四空禅定境界。不能脱离也。三，掉结。上二界众生。心念散动。退失禅定。掉心系缚。不能出离也。四，慢结。上二界众生。爱染未断。慢心不息。不能出离也。五，无明结。上二界众生。耽著禅定。于真性无所明了。无明系缚。不能出离也。所取者。取所行义。能取者。谓诸色根，及心，心所（三蕴全。色行蕴一分。根相及相应相。如其次第。十二界六处全。及法界法处一分相应自体）。为舍执著境界我故。观察所取。为舍执著受用我故。观察能取。能取有四。一，不至能取。谓眼耳意根。二，至能取。谓余根。三，自相现在各别境界能取。谓五根所生自相共相。四，一切时一切境界能取。谓第六根所生，又由和合识等生故。假立能取性。所以者何。以依众缘和合所生识等。假说能取。不由真实义。诸法无作用故。
    《大般若经·六百》曰。言著缚者。谓于法性执著系缚。法性既无。故不可说有著有缚。言解脱者。谓脱著缚。彼二既无。故无解脱。无解脱者谓于诸法都无有能得解脱性。言无著者。谓于此中著不可得著无著性。著无实性。故名无著。以于此中能著所著。由此为此。因此属此。皆不可得。故名无著。言无缚者。谓于此中缚不可得。缚无缚性。缚无实性。故名无缚。以于此中能缚所缚。由此为此。因此属此皆不可得。故名无缚。若于诸法无著无缚。如何于法可说解脱无著无缚。亦无解脱。离系清凉。名真解脱。若于诸法无执著者。则无系缚。若于诸法无系著（似当作缚）者。则无解脱。远离三事离系清凉。名真解脱。如是菩萨悟入诸法无著无缚。亦无解脱。得真智见。修行般若波罗蜜多。若诸菩萨能如是行。邻近无上正等菩提。速能证得一切智智。又曰。诸佛所得一切智智。皆从般若波罗蜜多而得生故。一切智智。不异般若波罗蜜多。般若波罗蜜多。不异一切智智。又三百六十九曰。是菩萨摩诃萨。虽于如是所说八地。皆遍修学。而能以胜智见。超过用道相智而入菩萨正性离生。既入菩萨正性离生位已。复用一切相智。永断一切习气相续。入如来地。尔乃成就一切智智。故一切智智。为菩萨得一切相智后永断习气相续入如来地之名。
    无智无得。《准楞严经》各家注解。孤山谓总非二乘理智。得即理也。小乘所证智理。谓非有我空之智。与非得我空之理。当属声闻乘。但其《心经疏》。则谓境智是菩萨，佛，法界。菩萨则分证境智。佛果则究竟境智。空无境智。九界俱空。即佛境界知空之智自无。故云无智。所得空理亦无。故云无得。意亦谓指菩萨法。《温陵要解》谓声闻修四谛法。以智为能证。以智为所得。故以此为非声闻法。《长水疏》谓非四谛及能证所证。《通理指掌疏》谓非权教菩萨。提婆《心经注》云。能观者智也。所观者得也。既以苦乐两忘。观心不起。名之谓得无所得。此之一得。不同世得。为破菩萨有所得故。故言无智亦无得。宗泐、如玘两师《心经注解》谓无智无得。系大乘菩萨以智照境。既无五蕴四谛诸法。即是人法皆空。境智俱泯。《心经直说》谓智即观智。乃六度之智慧。得即佛果。乃所求之境。若以有所得心求之。皆非真也。亦以空智，得，为菩萨事。《心经添足》则谓系空三乘人能证所证。及修般若菩萨空诸法之智。与空智之所得理亦无。《事观解》云。观智，得，即二空理境。智乃六度中一得是波罗蜜果。岂不局于大乘。故此为大乘菩萨而说。《心经句义》则以此为诸菩萨说六度万行法。近人印光师以无智为无菩萨界法。无得为无佛界法。倓虚师以此为离权位菩萨法相。圆瑛师谓此文接于四谛之下。不必别作他说。守培师以楞严非智非得。为非菩萨法。古今诸师。于此各有不同见解。按经曰。以无所得故。菩提萨埵。依般若波罗蜜多故。心无挂碍。自非实教菩萨。不能到此境界。权教菩萨。随相修行。既有能得之智。及所得之法。则本经说空智得。自不可谓专指二乘。菩萨惟能空智得。以无所得为方便。斯能心无挂碍。得究竟涅槃耳。即依本经说法层次推勘。为凡夫说空蕴、处、界三科法门。为缘觉说空十二因缘法门。为声闻说空四谛法门。菩萨修六度万行。则为之说空智、得法门。亦随机施教之义。《义疏》云。此离权位菩萨法相也。智者。智度也。以一度摄前五度。得者以离真俗而得中道也。菩萨以智度上求佛道。下化众生。得证佛果。云何无之。然无者。亦依妙有真空而言也。若有所明之智。即成理障。若有所得之果。即成事障。事理二障。即属见相二分。如何复其自证分乎。今言无智得者。乃智无智相。得无得相。即智法而离智相。即得法而离得相。所谓离一切相。即一切法。而权位菩萨。从空出假。以有中道可得。竟不知即空，假，即中道也。盖空者。泯一切法。假者。立一切法。中者。统一切法。而统一切法者。非有能统之中。所统之法。是乃法法皆中也。而空、假岂出法外乎。立一切法者。非有能立之假。所立之法。而中，空，岂出法外乎。泯一切法者非有能泯之空。所泯之法。乃法法皆空。而中，假，岂出法外乎。六度中布施、持戒、忍辱、精进、禅定五法。皆为事境假名。智慧一法。即理智之真空。前五属事。无智不行。后一属理。无事不显。故事不离理。理不离事。则可知空即是假。假即是空。息空、假二边之分别。则空、假即中矣。岂空，假之外别有中道可得乎。则显然即。六度。即真空实相。方为称性。六度岂事理不融之六度乎。故曰。无智亦无得也。《发隐》云。六度以智为体。智度既空。五度亦空。故曰无得。谓三谛理体周遍。能所俱泯。故云无。《连珠记》云。经云。若说有觉。犹未离幻。是故无智。又云。本无菩提及与涅槃。又云。设更有法胜过菩提涅槃。我亦说为如梦如幻。故云无得。印光法师云。是故诸法空想之中。无色受想行识之五蕴。无眼耳鼻舌身意之六根。无色声香味触法之六尘。无眼识界乃无意识界之六识。是无六凡界法。无无明乃至无老死。是无十二因缘流转门。亦无无明尽乃至亦无老死尽。是无十二因缘还灭门。是无缘觉界法。无苦集灭道。是无声闻界法。无智。智为六度末后之一度。是无菩萨界法。亦无得。得即菩提涅槃。是无佛界法。见《印光法师文钞续编·上·答周孟由书》。


第一项 明菩萨得涅槃

    第三节　显彰妙果
    本节更分二项。

    第一项　明菩萨得涅槃

    以无所得故。

    此承上文而言。正明所得。所得者何。菩萨得涅槃断果。诸佛得菩提智果也。以者由也。故者。因也。谓由前诸法无所得。故菩萨因依之而修得究竟涅槃。故此无字。乃统一经之旨。无所得即空慧。体无相之真理。心中无所执著无所分别。是曰无所得。《净名经》舍利弗曰。无所得故而得。《大品》曰。以无所得而为方便。《连珠记》云。前云。无智亦无得。故今蹑为因行。由是而得果。前明所离是断惑。今明所得是证果。《大般若经》曰。以一切法皆毕竟空。毕竟空中。都无有法。可名能证。可名所证。可名证处。可名证时。可名由此而有所证。所以者何。诸法皆空。若增若减。都无所有。皆不可得。又曰。佛告善现。佛证无上正等觉时。所得佛法。依世俗故。说名为得。若依胜义。能得所得俱不可得。何以故。善现。若谓此人得如是法。便有所得。有所得者。便执有二。执有二者。不能得果。亦无现观。又曰。一切法自相皆空。能取所取。皆不可得。又曰。若无所得。即是得。即是现观。即是无上正等菩提。《涅槃经》曰。无所得者。则名为慧。菩萨得是慧故。名无所得。又无所得者名大涅槃。菩萨安住大涅槃中。不见一切诸法性相。故名无所得。又无所得者名为大乘菩萨。不住诸法。故名大乘。清凉云。无所得即般若相。由得般若无得智慧故，方得也。《智度论》云。有所得者。以我心于诸法中取相故。诸法实相中。决定相不可得。故名无所得。《净名经慧远疏》云。菩萨破去情相。到无得处。名无所得。《仁王经·良贲疏》云。有所得为取相之心。无所得为无分别智。惟行不可得空。则空空亦空。空亦不可得。《金刚般若不坏假名论》云。若论菩萨证真实时。乃至法身亦无得故。盖爱执一生。名有所得。若执有相。是增益边。亦名常见。若执无相。是损减边。亦名断见。有所执者。名生死轮。一切凡夫轮回生死。故有所得。菩萨永断一切生死。名无所得。无所得者为慧。有所得者为无明。法性如如。体本寂灭。得与无得。俱绝名言。
    【注】执五蕴身心。过去现在未来相续不断。是名常见谓五蕴身心今世灭已。更不再生。是名断见。无论执断执常。任执一边。均为边见。
    因缘所生之法。分别推求。本无自性。众生不了。执之为有。曰增益边。因缘所生之法。虽无自性。然非无因果功能。众生不了。拨之为空。曰损减边。
    于诸法中取相。三惑皆有之。《观音玄义》曰。见思取生死相。尘沙取涅槃相。无明取二边相。著心取相。即为有所得。故《金刚经》曰。不取于相。如如不动。不取于相。亦须无心。若是有心不取于相。仍是取相。仍为有所得。《净名经》天女曰。我无得无证。若有得有证者。则于佛法为增上慢。
    法性如如。体本寂灭。即不生不灭之性。证性之时。智外无理。理外无智。智理冥合。无能证。无所证。灵光独耀。寂照同时。谓之如如。

    菩提萨埵。依般若波罗蜜多故。心无挂碍。

    菩提萨埵是能依之人。般若波罗蜜多是所依之法。依者。依止之义。菩萨修习般若波罗蜜多。以为依止。了知诸法自性皆空。空性无相。于蕴、处、界、因缘、谛、相。及能证所证。皆无所得。惑不碍心。境不碍智。故心无挂碍。心无挂碍。即空解脱。是即般若观空之效。
    【注】菩提名佛道，萨埵名成众生。称赞好法名为萨，好法体相名为埵。菩萨心自利利他故。度一切众生故。知一切法实性故。行阿耨多罗三藐三菩提故。为一切贤圣之所称赞故。是名菩提萨埵。所以者何。一切诸法中。佛法第一。是人欲取是法故。为贤圣所赞叹。复次，如是人为一切众生脱生老死故，索佛道是名菩堤萨埵。复次，三种道皆是菩提。一者。佛道。二者。声闻。三者。辟支佛道。辟支佛道声闻道虽得菩提而不称为菩提。佛功德中菩提称为菩提。是名菩提萨埵。有大誓愿。心不可动。精进不退。以是三事。名为菩提萨埵。初发心作愿。我当作佛。度一切众生。从是以来。名菩提萨埵。从初发心到第九无碍入金刚三昧中。是中间名为菩提萨埵。是菩提萨埵有两种。有鞞跋致。有阿鞞跋致。见《智度论·四》。
    菩提萨埵释义有三。一，菩提所求果。萨埵所度生。二，菩提所求果。萨埵能求人。三，菩提觉悟智。萨埵情虑识。总约悲、智、能、所、真、妄，以立名也。《法华玄赞》云。菩提觉义。是所求果。萨埵有情义。是自身也。《法华经嘉祥疏》云。菩提云道。萨埵云众生。依大论释。菩提名佛道。萨埵名成众生。用诸佛道。成就众生。故名菩提萨埵。又菩提是自行。萨埵是化他。自修佛道。又用化他。故名菩萨。《天台戒经义疏》云。摩诃菩提质帝萨埵。译云大道心成众生。今言菩萨者。略其余字也。
    《大般若经·五百九十四》曰。若诸菩萨发菩提心作如是念。我于今者发菩提心。此是菩提。我今为趣此菩提故，发修行心，是诸菩萨有所得故。不名菩萨。但可名为狂乱萨埵。何以故。善勇猛。由彼菩萨决定执有发起性故。决定执有所发心故。决定执有菩提性故。若诸菩萨发菩提心有所执著，但可名为于菩提心有执萨埵，不名真净发心菩萨。彼由造作发菩提心。是故复名造作萨埵。不名菩萨。彼由加行发菩提心。是故复名加行萨埵。不名菩萨。何以故。善勇猛。彼诸菩萨，由有所取，发菩提心。但可名为发心萨埵。不名菩萨。
    《会要》云。惑不碍心者，谓真智现前，照惑本无，不能碍心，心善解脱也。境不碍智者，谓真智无自。真谛无根。忘功合道，与道通同，慧善解脱也。真俗二谛。以色即空故，不碍如理之智，而会实相。以空即色故。不碍如量之智，而觉诸事。

    挂碍即障。挂为烦恼障。碍为所知障。烦恼障依于我执。能障涅槃。所知障依于法执。能障菩提。一切众生。妄认四大六尘。执我及我所。辗转生死。轮回六道。是名挂碍。
    【注】《连珠记》云。烦恼障心。心不解脱。故造业轮转。所知障慧。慧不解脱。故不了自心。不达诸法性相。纵出三界。亦滞下乘。不得成佛。今得般若深慧。二障种、现（种子、现行）俱亡。得二解脱。

    无挂碍故。无有恐怖。远离颠倒梦想。

    此明菩萨断障之功。无有恐怖。即无相解脱。由证诸法自性皆空。则知诸法无相。外不相碍。内无恐怖也。远离颠倒梦想。即无愿解脱。由证诸法无性。但是颠倒。犹如梦想。虚妄不实。是以远离。不起愿求也。外无魔冤之怖。则恶缘息。内无惑障之倒。则恶因尽。
    恐怖即恐惧怖畏之义。众生身口意三业与罪相应。三界果报。犹如火宅。是可畏相。故曰恐怖。
    【注】《智度论》云。知一切法因缘和合故生，诸缘离故灭，无有起者。无有灭者。故不畏不怖。菩萨知一切法虚诳。无实无定。若死急时。若堕阿鼻泥犁。心犹不动。况闻虚声而有怖畏。如人梦中。见怖畏事。觉已则无所畏。
    初学菩萨有五怖畏。一，不活畏。行布施时。恐影响自己生活。不能尽其所有。二，恶名畏。恐受恶名。不能为和光同尘之行。三，死畏。虽发大心。而顾惜身命。不能自舍。四，恶道畏。恐堕恶道。于不善法分别对治。令其不生。五，大众威德畏。于王庭或善解法义人前。不敢畅论。惟恐有失。见《佛道论》。又有十种怖畏。一，死。二，烦恼垢。三，贫穷。四，恶业。五，恶道。六，求不得。七，谤法罪业。八，追求时缚不活。九，疑。十，大众威德。见《十地经论·十》。《华严经》明十八种怖畏。一，险道。二，热恼。三，迷惑。四，系缚。五，杀害。六，贫穷。七，不活。八，恶名。九，死。十，大众。十一，恶趣。十二，黑暗。十三，迁移。十四，爱别离。十五，怨憎会。十六，逼迫身。十七，逼迫心。十八，忧愁。

    远离。梵语阿罗蜜。有名词动词二用。作名词用者。即空之别名。与波罗蜜音近而义亦相会。作动词用者。解脱一切事相系缚之义。菩萨行般若波罗蜜。于一切法，心皆远离也。《大般若经》曰。甚深般若波罗蜜多。远离为相。诸法亦以远离为相。又曰。但能远离烦恼恶业。远离声闻独觉作意。勤修般若波罗蜜多及诸余殊胜功德。是名菩萨真远离行。又曰。于一切烦恼、六趣、四生、蕴、界、处等而得远离。故名般若波罗蜜多。
    【注】远离有五。一，恶行远离。二，欲远离。三，资具远离。四，愦闹远离。五，烦恼远离。盖远离属无为法。为永断分结之义。谓诸染污、无记，作意不现行故。见《瑜伽论·十三》。
    《智度论》云。知诸法但是虚诳。无有真实菩萨得如是智慧。一切别相法中。皆得远离。如色中离色。离色即是自性空。远离者。空之别名。

    颠倒者。无明所使。反于真理之妄见也。迷真曰颠。逐妄曰倒。《圆觉经》曰。一切众生。从无始来种种颠倒犹如迷人。四方易处。《净名经》曰。虚妄分别孰为本。颠倒想为本。盖为一切烦恼根本。
    【注】《文句》云。颠。顶也。颠倒。首倒悬也。
    种种颠倒。诸经所说不同。约举如左。
    三颠倒。一，心颠倒。心即根尘相对所起一念之心。为群妄之源。起惑之始。因迷自性清净之心。种种分别起诸颠倒。二，见颠倒。眼是诸见之本。由不了尘境虚幻。妄生执取。起诸颠倒。三，想颠倒。想取六尘之相。由不了六尘过患。伤失善根。妄生缘想。起诸颠倒。见《涅槃经·三十七》。
    四颠倒。有凡夫四颠倒。二乘四颠倒之分。凡夫四颠倒。一，常颠倒。于世间无常法起常见也。二，乐颠倒。不明乐为苦因妄起乐见也。三，我颠倒。于自身妄计为我。起我见也。四，净颠倒。不了己身他身五种不净（一，种子不净。一者内种。谓观此身从昔烦恼业生。二者外种。谓揽父母遗体而成此身。内外因种皆为不净。二，住处不净。观此身在母胎生藏之下，熟藏之上，臭秽中住。三，自体不净。观此身由四大不净所成。四，外相不净。观此身九孔常流秽恶，如破皮囊，满盛不净。五，究竟不净。观此身死后臭烂。究竟不净）。妄生贪著也。二乘四颠倒。一，常计无常。常即法身常住之义。无常即变异之义。声闻缘觉为无明所覆。于如来常住法身。妄计有生灭变异之相。是名无常颠倒。二，乐计非乐。乐即涅槃清净之乐。二乘为无明所覆。于如来清净涅槃。妄计是苦。名非乐颠倒。三，我计无我。我即佛性真实之我。二乘为无明所覆。不了无我法中尚有真我。妄计无我。是名无我颠倒。四，净计不净。净即如来常住法身。二乘为无明所覆。但观世间一切诸色。皆为不净。不了如来常住法身之净。是名不净颠倒。见《俱舍论·九》。
    七颠倒。合上三颠倒、四颠倒而言。见《瑜伽论·八》。
    八颠倒。合凡夫四颠倒、二乘四颠倒而言。见《瑜伽论·七十七》。

    梦者睡梦。想者妄想。在寐为梦。在寤为想。无明幻惑。结想成梦。识性妄行。攀缘成想。颠倒梦想。谓颠倒妄见。虚妄不实。犹如梦想。
    【注】妄想根于五蕴。一，坚固妄想。即色蕴也。一切众生。体因想生。心因想起。命因想传。诸想交固而成色身。名此色身为坚固妄想。二，虚明妄想。即受蕴也。一切众生。欲想登高。足先酸涩。违顺二相。损益现驰。受蕴无体。虚有所明。是曰虚明妄想。三，融通妄想。即想蕴也。众生念虑是虚。色身是实。虚实不伦而能相使者。想融之也。心生虚想，形取实物。心形异用而能相应者。想通之也。至于寤寐。心境相随而无间断。皆此妄想主之。是曰融通妄想。四，幽隐妄想。即行蕴也。众生一期色身生化之理。自幼至衰。无暂停息。默运潜移。体迁无觉。是曰幽隐妄想。五，颠倒微细精想。即识蕴也。众生识精之湛。并非真实。如急流水。望似恬静。实因急流。细不可见。湛了之内。罔象虚无。是曰颠倒妄想。是五受阴。五妄想成。见《楞严经·十》。
    《广承》云。挂碍者。结业也。恐怖者。生死也。颠倒梦想者。无明也。菩萨依般若故。达结业即解脱。故无挂碍。达生死即涅槃。故无恐怖。达无明即智慧。故无颠倒梦想。

    究竟涅槃

    此明菩萨证得之果。谓由前诸法无所得故。菩萨因依之而修得究竟涅槃。涅槃亦作泥洹。具云涅槃那。梵音正名应作波利泥缚喃。云涅槃者。略称也。《智度论》云。涅名为趣。槃名为出。求出诸趣，故名涅槃。波利。此云圆泥缚南。此云寂。故译为圆寂。寂灭。灭者。灭生死因果。圆谓德无不备。寂谓障无不尽。
    【注】涅槃译名甚多。一，大灭度。大即法身。灭即解脱。度即般若。二，大涅槃。涅言不生。槃言不灭。不生不灭。名大涅槃。三，无为。虚无寂寞。妙绝于有为。四，灭度。大患永灭。超越四流也。五，圆寂。德无不备曰圆。障无不尽曰寂。此奘师所译也。六，寂灭。生死永灭。圭峰师所名也。七，安乐。八，无生。九，灭。十，解脱。十一，不织。十二，不取。十三，不定。十四，不覆。十五，无相。十六，无苦。十七，无后有。十八，出稠林。十九，离系缚。二十，无臭。要皆引申生义。当以圆寂为正译也。
    涅槃近因有四。一，近善智识。二，听闻正法。三，思唯其义。四，如说修行。听闻正法即闻。思唯即思。修行即修。是为三慧。《楞严经》曰。从闻思修。入三摩地。
    涅槃有四种。一，本来自性清净涅槃。谓真如随缘变造一切诸法。虽有烦恼垢染。而本性清净。具足无量微妙功德。无生无灭。湛若虚空。一切众生。平等共有。与一切法不一不异。离一切相。一切分别。寻思路绝。名言道断，惟真圣者自内所证。其性本寂。故名本来自性清净涅槃。二，有余依涅槃。谓烦恼之障虽灭。尚余欲界五蕴之身而为所依。故名有余依涅槃。三，无余依涅槃。谓烦恼既尽。所余五蕴之身亦灭。故名无余依涅槃。四，无住处涅槃。谓不住生死。不住涅槃。穷未来际。利乐有情。用而常寂。故名无住处涅槃。见《成唯识论·十》。
    又有分涅槃为三种者。一，性净涅槃。谓诸法实相之理不可染。不可净。不染即不生。不净即不灭。不生不灭。名性净涅槃。二，圆净涅槃。智极名圆。惑尽名净。据性而言。虽无染净。约修而说。惑智宛然。智若契理。惑毕竟不生。智毕竟不灭。不生不灭。名圆净涅槃。三，方便净涅槃。方便犹善巧也。谓智能契理。即照群机。照必垂应。机感即生。此生非生。机缘既尽。应身即灭。此灭非灭。不生不灭。名方便净涅槃。见《金光明经玄义》。
    涅槃有四乐。一，无苦乐。世间之乐。即为苦因。惟能断乐。则无有苦。二，寂静乐。涅槃之性。是大寂静。以远离一切愦闹法故。三，大知乐。诸佛如来。有大智慧。于一切法。悉知悉见。四，不坏乐。如来之身。犹如金刚。历劫不坏。见《大涅槃经》。
    《连珠记》云。德无不备者。无住处大般涅槃。具足常等无尽故。菩提得果。不同无得。乃具佛德空也。惑障本如。无尽可尽。无断可断。

    究竟犹言至。极大义。无余义。决定终极义。一，得永常。故名究竟。究竟涅槃，梵语摩诃涅槃那。译作大灭度。大者。美灭德之称。灭者。灭烦恼。度者。度生死。那者。此云息。息烦恼，息生死也。大即法身。灭即解脱。度即般若。又大者实相。灭者蕴空。度者越苦。以究尽涅槃之际。体性常寂。故菩萨观诸法空。离实相理。五住究尽。二死永断。三障顿空。三德同圆，是为究竟涅槃。
    【注】究竟涅槃。亦名无余依涅槃。以究尽涅槃之际故。亦名无住处涅槃。非同二乘但离见思惑。名为解脱。权得化城之涅槃。非究竟也。五住。即五住地惑也。三界见惑为一住。三界思惑分三住。根本无明为一住。由此五惑。能令众生住著生死。故名住地。一，一切见住地惑。一切见即三界分别见惑。谓诸众生由意根对法尘分别起诸邪见，住著三界。故名一切见住地惑。二，欲爱住地惑。欲爱者。即欲界思惑也。谓诸众生由五根对五尘境起贪爱心。而于欲界住著生死。故名欲爱住地惑。三，色爱住地惑。色爱。即色界思惑。谓诸众生不了此惑。住著色界禅定。不能出离。故名色爱住地惑。四，有爱住地惑。有爱。即无色界思惑。谓诸众生不了此惑。住于禅定。不能出离。故名有爱住地惑。五，无明住地惑。即根本无明惑。谓声闻缘觉未了此惑。沉滞真空。即住方便土。大乘菩萨方能除断。由余惑未尽。住实报土。故名无明住地惑。见《华严经随疏演义钞》。
    三障。障者。蔽也。谓诸众生被惑业障蔽。不见正道。善心不能生起。故名障也。一，烦恼障。昏烦之法。恼乱心神。故名烦恼。谓贪欲嗔恚愚痴等惑。障蔽正道。是名烦恼障。二，业障。业名业行。谓由贪嗔痴造作身口意恶业。障蔽正道。是名业障。三，报障。报即果报。谓由烦恼惑业。生在饿鬼地狱畜生诸趣。障蔽正道。是名报障。见《涅槃经·十一》。烦恼障又分为三。一，皮烦恼障。即三界中思惑。谓贪嗔等烦恼对外六尘而起。如皮在身外也。二，肉烦恼障。即三界中见惑。谓断常有无等见。皆属内心分别。如肉在皮内也。三，心烦恼障。谓此无明之惑。由迷真心逐妄而起。故名心烦恼障。见《华严孔目》。
    三德者。法身、般若、解脱也。以苦惑业三染易三德。一，翻苦身成法身德。法即轨法。谓诸佛由轨法而得成佛。故名法身。法身即一切法平等实性。小乘不谈理性。仅以五分功德法为法身。一，戒。谓如来身口意三业离一切过非之戒法身也。二，定。谓如来真心寂静离一切妄念之定法身也。三，慧。谓如来以根本智观达法性之慧法身也。四，解脱法身。谓如来身心解脱一切系缚成涅槃德也。五，解脱知见法身。谓如来智眼照了诸法皆空。自知无缚成后得智也。大乘各宗中。如三论宗则以真空无相为法身。唯识宗之总相法身。兼理智二法。以所证之真如与能照之真觉为法身。别相法身。则以无为之真如为法身。华严宗以所证之理为法身。密宗之自性法身分二。法界诸法。体用寂然法尔不改。名理法身。即胎藏界之四重圆坛也。一切之法。互相周遍。冥理同体。名智法身。即金刚界一印会之大日法身也。综合诸说。不外理、智，显现有为、无为一切功德法，体性之所依而已。《金光明经》曰。惟有如如智。是名法身。如如者。平等之义。以性德论。本觉理性。诸佛众生。皆同一相。惟众生为无明所蔽。诸佛以始觉智显。等虚空界。无所不遍。是为理法身。以修德论。究竟始觉之智。契合本觉之理。理智互融。色心不二。为智所现。是为智法身。法身在诸佛不增。在众生不减。众生迷之而成颠倒。诸佛悟之而得自在。迷即三障。悟即三德。迷悟虽殊。体性则一。于生灭无常之身。若能观察五蕴本空。不生不灭。即成法身。故曰翻苦身成法身德。二，翻烦恼成般若德。般若义即智慧。谓于意根所起诸惑。若能观察惑体本空。自性不实。于一切法。无不了达。即成智慧。故曰翻烦恼成般若德。三，翻结业成解脱德。不系为解。自在为脱。谓于身口所作诸业。若能观察业性本空。则无系缚之相。于一切法无不自在。即成解脱。故曰翻结业成解脱德。《宗镜录·九十》云。云何三。云何德。法身、般若、解脱，是为三。常、乐、我、净，是为德。法身者。法名可轨。诸佛轨之而得成佛故。经云。诸佛所师所谓法。身者。聚也。一法具一切法。无有缺减。故名为身。经云。我身即是一切众生真善知识。般若者。觉了诸法集、散、非集、非散。即是觉了三谛之法。解脱者。于诸法无染无住。此三法皆具常乐我净之四德。谛观一念之心。即空。即假。即中。即空故。一空一切空。无假。无中。而不空。空无积聚而名藏。藏具足故。名之为德。即假故。一假一切假。无空。无中。而不假。假摄诸法。亦名为藏。藏具足故。名之为德。即中故。一中一切中。无空。无假。而不中。中摄一切。亦名为藏。藏具足故。称之为德。不可思议。不纵不横。不并不别。诸佛以即中为体。故名法身。以即空为命。故名般若。以即假为力。故名解脱。一一皆常乐我净。无有缺减。故称三德。《观经智者疏妙宗钞》云。三德性本圆融。一一互具。故直法身非法身。法身必具般若解脱。直般若非般若。般若必具解脱。法身。直解脱非解脱。解脱必具法身。般若。三德即是教行理三。般若是教。智在说故。解脱是行。用从缘故。法身属理。是所显故。按法身者。三身之一。三身已见前注。《宗镜录·八十九》云。夫诸佛唯一法身。云何说三身差别。答，约用分三。其体当一。《识论》云。如是法身有三相别。一，自性身。谓诸如来真净法界。受用、变化平等所依。离相寂然。绝诸戏论。具无边际真常功德。是一切平等实性。即此自性。亦名法身。大功德法所依止故。二，受用身。此有二种，一自受用。谓诸如来修集无量福慧资粮，所起无边真实功德，及极圆净常遍色身，相续湛然，尽未来际，恒自受用广大法乐。二他受用。谓诸如来由平等智。示现微妙净功德身。居纯净土。为住十地诸菩萨众，现大神通，转正法轮，决众疑网，令彼受用大乘法乐。三，变化身。谓诸如来由成事智，变现无量随类化身，居净秽土。为未登地诸菩萨众、二乘、异生。称彼机宜。现通说法。令各获得诸利乐事。是以转灭三心得三身。一，根本心。即第八识。转得法身。二，依本心。即第七识。转得报身。三，起事心。即前六识。转得化身。又一，断德。断一切烦恼。即法身。二，智德。总四智为报身。三，恩德。恩怜悲育一切有情。为化身。则八解（八解脱）六通（六神通）一心而起。三身（法、报、化）四智（大圆镜智、平等性智、妙观察智、成所作智）八识（眼、耳、鼻、舌、身、意、末那、赖耶）所成。终无一理一行而从外来。皆从自识施为。一心而转。


第二项 明诸佛得菩提

    第二项 明诸佛得菩提

    三世诸佛。依般若波罗蜜多故。

    三世诸佛。为能依之人。般若波罗蜜多为所依之法。三世亦作三际。世者迁流之义。际者隔别之义。过去、现在、未来。约纵以赅一切时代。有为之事物。一刹那间。亦不止息。生已即灭。因之谓善恶诸行。未起、未生者为未来世。现起、现在、未转、未灭者为现在世。已起、已生、落谢、变灭者为过去世。此于事物迁流幻相。假立三世之名。离去事物。即无世之实体。
    诸者。众义。约横以赅十方世界。
    佛者。梵语具云佛陀。此云觉者。觉具三义。一者。自觉。悟真常性。了虚妄惑。二者。觉他。运无缘慈。度有情界。三者。觉行圆满。历劫修因。行满果圆。智慧具足。故名佛陀。《大般若经》曰。具寿善现白佛言。世尊如来常说佛陀。以何义故。名为佛陀。佛言。善现，随觉实义故，名佛陀。复次善现，现觉实法故，名佛陀。复次善现，通达实义故，名佛陀。复次善现，于一切法如实现觉故，名佛陀。复次善现，于一切法自相、共相、有相、无相，自然开觉故，名佛陀。复次善现，于三世法及无为法一切种相无障智转故，名佛陀。复次善现，如实开觉一切有情，令离颠倒恶业众苦故，名佛陀。复次善现，能如实觉一切法相所谓无相故，名佛陀。
    【注】凡夫不能自觉。二乘自觉而不能觉他。菩萨自觉觉他而未圆满。惟佛三觉圆满。三觉者。自觉异凡夫。觉他异二乘。觉满异菩萨。又离心名自觉。离色名觉他。俱离名觉满。
    无缘慈为三种缘慈之一。一，有情缘慈。亦名众生缘慈。菩萨以平等智。观一切众生。犹如一子。运大慈心而弘济之。令其皆得安乐。是名有情缘慈。二，法缘慈。菩萨以平等智。观一切法皆从因缘和合而生。了无自性。虽无自性。而能运大慈心以弘济之。令其皆得安乐。是名法缘慈。三，无缘慈。菩萨以平等智。无心攀缘一切众生。而令一切众生自然获益。运此慈悲。遍覆法界。任运拔苦。自然与乐。是名无缘慈。

    三世诸佛者。过去、现在、未来，三世诸佛也。三世之三大劫中。每一大劫。总有成住坏空之八十增减小劫。其住劫之二十小劫中。千佛出世。过去名庄严劫。如华光佛、人中尊佛、乃至毗婆尸佛、尸弃佛、毗舍浮佛。现在名贤劫。如拘留孙佛、拘那含牟尼佛、迦叶佛、释迦牟尼佛。未来名星宿劫。如日光佛、龙威佛，乃至须弥相佛。就现在之贤劫。更分三世。则拘留孙佛、拘那含牟尼佛、迦叶佛为过去佛。释迦牟尼佛为现在佛。自此至第十增减劫之减劫。有弥勒佛出世。次有师子佛乃至楼至佛等。九百九十五佛出世。为未来佛。
    【注】三世诸佛名。见《过去庄严劫千佛名经》、《现在贤劫千佛名经》、《未来星宿劫千佛名经》。劫。梵语具云劫波。此云分别时节。人寿八万四千岁时。历百年减一岁。减至人寿十岁为止。历百年增一岁。增至八万四千岁为止。一增一减。为一小劫。二十小劫。为一中劫。总成住坏空四中劫。为一大劫。成劫者。世界初成立也。有二十小劫。第一小劫。因过去劫坏空之后。第二禅光音天。空中布金色云。注大洪雨。积风轮上。结为水轮。有大风起。吹水生沫。而成须弥等山。时一切有情。皆集光音天中。其福减者。下生世间。最初有一天子。从光音天来。生大梵天中。是为梵王。其寿六十小劫。第二小劫。光音诸天。来生初禅天中。为梵辅天。其寿四十小劫。第三小劫。光音诸天。来生梵众天中。其寿二十小劫。如是渐渐下生欲界天中。时光音诸天有福尽者。化生为人。飞行自在。无男女相。地涌甘泉。味如酥蜜。因试尝之。遂生味著。失去神通身光。世间大暗。黑风吹海。漂出日月。置须弥山腹。照四天下。乃有昼夜。彼时众生。由耽地味故。颜色粗悴。复食自然粳稻。残秽在身。为欲蠲除。便生二道。成男女根。宿习力故。因生淫欲。光音诸天后来生者。入母胎中。始有胎生。时自然粳稻。朝刈暮熟。刈后随生。米长四寸。后因人多贪取。渐生糠秕。刈已不生。第四小劫乃至第二十小劫。一增一减。名为成劫。住劫者。世界已成而安住也。亦有二十小劫。至第九小劫人寿减至五万岁时。第一拘留孙佛出世。减至四万岁时。第二拘那含牟尼佛出世。减至二万岁时。第三迦叶佛出世。减至一百岁时。第四释迦牟尼佛出世。至第十小劫。人寿减至八万岁时。第五弥勒佛出世。第十五小劫。于减劫中第六师子佛，乃至欲乐佛等相继出世。至第二十小劫增劫中。楼至佛出世。满足千佛。名为住劫。坏劫者。世界坏灭也。亦有二十小劫。如火灾起时坏至初禅天。始从地狱。终至梵天。有情众生经十九增减劫。次第坏尽。惟器世间空旷而住。至最后一增减劫方坏。坏时七日从海底出。大海尽竭。须弥崩坏。风吹猛焰。烧上梵天。悉成灰烬。乃至三千世界。一时都尽。名为坏劫。空劫者。世界空虚也。亦有二十小劫。自初禅以下。世界空虚。犹如墨穴。不分昼夜。亦无日月。名为空劫。

    依者。止也。梵语腻地。依止之义。三世诸佛。依止般若波罗蜜多以为修证也。
    【注】《小品·二》曰。诸佛萨婆若。从般若波罗蜜生。《智度论·十八》云。是般若波罗蜜在佛心中变名为一切种智。

    得阿耨多罗三藐三菩提。

    得者。获成就也。梵语钵罗钵多。使诸法获得于身之实法也。《小品般若》曰。过去诸佛。皆因般若波罗蜜得阿耨多罗三藐三菩提。未来诸佛。亦因般若波罗蜜得阿耨多罗三藐三菩提。现在十方无量阿僧祇世界诸佛。亦因般若波罗蜜得阿耨多罗三藐三菩提。《大般若经》曰。出世般若波罗蜜多。能如实知。故名为证。后智通达。故名为得。《思益经》曰。佛言我坐道场时。惟得颠倒所起烦恼。毕竟空性。以无所得故得。以无所知故知。阿耨多罗三藐三菩提。遵古不翻。故存梵语。以义译之。阿，此云无。耨多罗，此云上。三，此云正。藐，此云等。菩提，此云觉。合之为无上正等正觉。旧译作无上正遍知。谓真正平等觉知一切真理之无上智慧也。在因为智。在果为觉。极果超因。故云无上。正则正观中道。等则双照二边。转八识以成四智。证法空而悟真如。是为诸佛真净妙觉。由此现觉诸法一切种相。谓之菩提。《大般若经》曰。具寿善现白佛言。世尊，如来常说菩提。以何义故。名为菩提。佛言。善现。证法空义是菩提义。证真如义是菩提义。证实际义是菩提义。证法性义是菩提义。证法界义是菩提义。复次，善现，假立名相施设言说，能真实觉最上胜妙，故名菩提。复次，善现，不可破坏，不可分别，故名菩提。复次，善现，法真如性、不虚妄性、不变异性、无颠倒性，故名菩提。复次，善现，惟假名相，谓为菩提，而无真实名相可得，故名菩提。复次，善现，诸佛所有真净妙觉，故名菩提。复次，善现，诸佛由此现觉诸法一切种相。故名菩提。
    【注】阿耨多罗三藐三菩提。即是般若。但名字异。在菩萨心中为般若。在佛心中名阿耨多罗三藐三菩提。菩提此云觉。旧译作道。诸佛所证清净究竟之理。以理体分。有三。一，真性菩提。真名不伪。性名不改。真性为道也。二，实智菩提。能照真性之智。称理不虚。实智为道也。三，方便菩提。善巧随机。化用自在。方便为道也。见《金光明经玄义》。以行者根器分，亦有三。一，声闻菩提。行者于声闻行中。虽已自发菩提之心。而不劝化众生发菩提心。亦不习学大乘经义。以是行故，独得解脱。曰声闻菩提。二，缘觉菩提。行者于缘觉行中。虽已自发菩提之心。而不劝化众生发菩提心。亦不习学大乘经义。以是行故，独得解脱。曰缘觉菩提。三，诸佛菩提。诸佛在因位时。自发菩提心已，复能劝众生发菩提心。习学大乘经义。自既解脱。亦令众生解脱。曰诸佛菩提。见《出生菩提经》。以修习阶位分。有五。一，发心菩提。十信菩萨。于无量生死中为阿耨多罗三藐三菩提而发大心。为发心菩提。二，伏心菩提。十住十行十回向菩萨。折诸烦恼。降伏其心。行诸波罗蜜。利益众生。为伏心菩提。三，明心菩提。登地以上菩萨。观三世诸法本末、总相、别相、分别筹量。得诸法实相。清净明了。与般若波罗蜜相应。为明心菩提。四，出到菩提。八地九地十地菩萨。于般若波罗蜜中得方便力故。亦不著般若波罗蜜。灭一切烦恼。见一切十方诸佛。得无生法忍。出离三界。到萨婆若。为出到菩提。五，无上菩提。等觉菩萨。坐于道场。断诸烦恼。成阿耨多罗三藐三菩提。为无上菩提。见《智度论·五十三》。佛菩提又分应化佛菩提。报身佛菩提。法身佛菩提。见《法华玄义·十》。菩提为觉。所觉之境。有事理二法。理者，涅槃。断烦恼障而证涅槃之一切智。通三乘之菩提也。事者，一切有为诸法。断所知障而知诸法之一切种智。佛独证之菩提也。佛之菩提并通二者。故曰大菩提。至菩提之觉体。《俱舍论》以尽智及无生智二者当之。《唯识论》以大圆镜智、平等性智、妙观察智、成所作智当之。《智度论》以一切智、道种智、一切种智当之。密宗则以法界体性智、大圆镜智、平等性智、妙观察智、成所作智当之。
    《大方广如来秘密藏经》曰。身之实性，是菩提实性。菩提实性，是心实性。心之实性，即是一切法之实性。觉是一切诸法实性。故名觉菩提。《大庄严法门经》曰。于一切众生心法中。悉有菩提。何以故。若彼心无色，离色分别，体性如幻，彼此内外不相续者。是名菩提。《守护国主陀罗尼经》曰。善男子。欲知菩提。当了自心。若了自心。即了菩提。何以故，心与菩提。真实之相。毕竟推求。俱不可得。同于虚空。故菩提相，即虚空相。是故菩提无所证相。无能证相。亦无能所契合之相。何以故，菩提毕竟无诸相故。善男子。以一切法即虚空相。是故菩提毕竟无相。又曰。一切智智，及与菩提，从心而生。何以故。心之实性，本清净故。综合诸经所说。可知菩提不出一心。众生一念之间。背尘合觉。即是菩提。道不在远。行者勉之。
    中道。各宗所取不同。唯识宗以唯识为中道。三论宗以八不为中道。天台宗以实相为中道。华严宗以法界为中道。中者，不二之义。绝待之称。双非双照之目也。《中论偈》云。因缘所生法。我说即是空。亦名为假名。亦是中道义。
    中道有四种。一，对偏中。对于大小学人断常之偏病而说中道。谓之对偏中。二，尽偏中。大小学人有断常之偏病。则不成中。偏病尽则中显。谓之尽偏中。三，绝待中。对治偏病故有中。偏病既除。中亦不立。非中非偏。为度众生而强名曰中。谓之绝待中。四，成假中。以有无为假。非有非无为中。曰非有非无。故说有无。如是之中。为成有无之假。故谓之成假中。见《三论玄义》。
    二边者。一，有边。谓世间一切事物。必假众缘具足。和合而生。皆无自性。虽无自性。不得言无。故名有边。二，无边。谓世间一切事物。既假众缘具足和合而生。本无自性。无自性则一切法皆空。不得言有。故名无边。
    菩萨以无所得心依般若而得涅槃。三世诸佛亦以无所得心依般若而得无上菩提。菩提涅槃。原无二致。皆依般若而得。舍此般若无能得者。故《大般若经》曰。如来亦由修行般若波罗蜜多。能修行安住圆满具足种种功德。故得无等等色。无等等受想行识。证无等等菩提。转无等等法轮。度脱无量诸有情类。令获殊胜利益安乐。又曰。过去未来现在诸佛。皆依般若波罗蜜多精劝修学。证得无上正等菩提。又曰。一切如来、应、正等觉。乘如是乘。行如是道。乃得无上正等菩提。此乘此道。当知即是甚深摩诃般若波罗蜜多。诸法自相空。即是阿耨多罗三藐三菩提。菩萨行般若作佛已。变涅槃为菩提。盖涅槃是如如理，理必契智。菩提是如如智，智必冥理。涅槃是断德，断住一切烦恼惑业。菩提是智德。以平等智慧。照了一切诸法。通达无碍随众生根器大小说法。菩提涅槃。同为极圣所证二转依果。以惑非智不断。智非断不圆。故《大般若经》曰。菩萨于菩提道及一切波罗蜜多已圆满故。由一刹那相应妙慧。证得如来一切相智。尔时一切烦恼习气相续永不生故。名无余断。则名如来、应、正等觉。如是二果。皆依般若波罗蜜多而得应就。
    【注】菩提智果。翻烦恼而复本有如如智性，乃即寂之照，涅槃断果。翻生死而复本有如如理性，乃即照之寂，照真不变。则菩提之用彰。达妄本无。则涅槃之功著。《楞严经》曰。无始菩提涅槃元清净体。以如来藏性。二果本具。故云无始。以本来不与妄染相应，故云元清净体。
    《楞严经·资中疏》云。二转依号者。不了一法界相。忽然起妄。由初迷真念动。以至不觉。翻此不觉。了本无生。即名为觉。此菩提之号，由不觉立也。由迷有生。生必有灭。翻此生灭。显不生灭。此涅槃之号。对生灭立也。生灭既灭。更无所依。故名转依。以真如为迷悟依。转此迷依以为悟依。故名转依。菩提涅槃。初非有异。但转迷名无上菩提。转有名大涅槃。以有故迷。以觉故空。是知菩提涅槃。因迷故有。如人因睡而有觉名。非本一真而有二果之异。
    《摄大乘论》云。转依谓即依他起性对治起时。转舍染分。转得清净分。
    《真际》云。转依有二解。一云。依谓能依。体是依他性。与染净二法而为所依。染即遍计性。净即圆成性。转谓改转。有转舍转得二义。以修无分别智断于二障。故能转舍依他性上遍计染法。及能转得依他性中圆成净法。二云。依谓所依。体是真如。为生死涅槃之所依。故凡夫迷真。则受生死。圣人悟真。则证涅槃。转亦二义。以修智断障。转依真之生死，得依真之涅槃。故名转依。
    《成唯识论》云转依位别。略有六种。一，损力益能转。谓初二位由习胜解及惭愧故。损本识中染种势力。益本识内净种功能。虽未断障种实证转依。而渐伏现行。亦名为转。二，通达转。谓通达位由见道力。通达真如。断分别生二障粗重。证得一分真实转依。三，修习转。谓修习位由数修习十地行故。渐断俱生二障粗重。渐次证得真实转依。《摄大乘论》说。通达转在前六地有无相观。通达真俗间杂现前。令真非真现不现故。修习转在后四地纯无相观。长时现前。勇猛修习。断余粗重。多令非真不显现故。四，果圆满转。谓究竟位。由三大劫阿僧企耶。修习无边难行胜行。金刚喻定现在前时。永断本来一切粗重。顿证佛果。圆满转依。穷未来际。利乐无尽。五，下劣转。谓二乘位。专求自利。厌苦欣寂。惟能通达生空真如。断烦恼种。证真择灭。无胜堪能。名下劣转。六，广大转。谓大乘位为利他故。趣大菩提。生死涅槃。俱无欣厌。且能通达二空真如。双断所知，烦恼，障种。证无上菩提涅槃。有胜堪能。名广大转。
    习气为现行气分熏习（熏者。熏发义。习者。数数义。数数熏发。如以香熏衣令染香气也。真妄互熏。相续不断。无明熏真如。使现染相。真如熏无明。使成净用。谓之习熏。业识返熏无明。现行心境诸惑相资。谓之资熏。身口所现诸行。意所现思想。为现行法。其气分留于真如或阿赖耶识者为种子。或习气。此其作用。即名熏习。有三。一，名言熏习。第六识分别名字言说之识。由第七识传送第八识成就染分之相。二，色识熏习。第六识分别眼根对境所生之识。由第七识传送第八识成就染分之相。三，烦恼熏习。第六识所起贪嗔邪见。由第七识传送第八识。成就染分之相）所成见惑过失之余习也。大乘之妄惑。分现行与种子及习气。三者。既断惑之现行。且断惑之种子，尚有惑之气分而现惑相，是名习气。


第四节 结赞功能

    第四节 结赞功能

    故知般若波罗蜜多。是大神咒。是大明咒。是无上咒。是无等等咒。

    故者。承前起后之辞。知者，喻义，觉义，了了自觉也。承上菩萨诸佛皆依此深般若而证涅槃，菩提。故知般若功用。不可思议。非复名言数量所能称说。乃以四种咒义。别赞功能。《大般若经》曰。如是般若波罗蜜多。是大神咒。如是般若波罗蜜多。是大明咒。如是般若波罗蜜多。是无上咒。如是般若波罗蜜多。是无等等咒。如是般若波罗蜜多。是一切咒王。最上最妙。无能及者具大威力。能伏一切。不为一切之所降伏。
    咒者。愿也。四种陀罗尼之一。陀罗尼者。梵语。此云总持。持善不失。持恶不生。总一切法。持无量义故名总持。亦译遮持。能持能遮。持者持善，遮者遮恶也。
    【注】《智度论·五》。略谓。陀罗尼。秦言能持。或言能遮。能持者。集种种善法。而持令不散不失。譬如完器盛水。水不漏散。能遮者。恶，不善，根心生，能遮令不生，若欲作恶罪，持令不作，是名陀罗尼。又云。得。陀罗尼菩萨。一切所闻法。以念力故。能持不失。复次。是陀罗尼法。常逐菩萨。譬如间日疟病。是陀罗尼不离菩萨。譬如鬼著。是陀罗尼常随菩萨。如善，不善，律仪。复次，是陀罗尼持菩萨不令堕二地坑。譬如慈父爱子。子欲堕坑。持令不堕。复次。菩萨得陀罗尼力故。一切魔王、魔民、魔人，无能动，无能破，无能胜。譬如须弥山。凡人口吹。不能令动。是陀罗尼多种。一名闻持陀罗尼，得是陀罗尼者。一切语言诸法。耳所闻者。皆不忘失。复有分别知陀罗尼。得是陀罗尼者。诸众生、诸法、大、小、好、丑。分别悉知。复有入音声陀罗尼。菩萨得此陀罗尼者。闻一切语言音。不喜、不嗔。一切众生，如恒河沙等劫，恶言骂詈，心不憎恨。是菩萨虽未尽漏。大智利根，能思惟除遣嗔心。作是念。若耳根不到声边。恶声著谁。又如骂声闻便直过。若不分别。谁当嗔者。凡人心著吾我。分别是非，而生恚恨。复次，若人能知诸言随生随灭。前后不俱。则无嗔恚。亦知诸法内无有主。谁骂谁嗔。若有人闻殊方异语。此言为好。彼以为恶。好恶无定。虽骂不嗔。若有人知语声无定。则无嗔喜。如亲爱骂之。虽骂不恨。非亲恶言。闻则生恚。但以慈悲。息此诸恶。不生嗔心。复次，菩萨知诸法不生、不灭。其性皆空。若人嗔恚骂詈。若打若杀。如梦如化。谁嗔谁骂。复次，若有人如恒河沙等劫众生，赞叹，供养衣食、卧具、医药、华香、璎珞，得忍菩萨其心不动、不喜、不著。知种种供养恭敬。是皆无常。菩萨观一切法如梦、如响。谁赞、谁喜。如是等相。名为入音声陀罗尼。复有名寂灭陀罗尼。无边旋陀罗尼。随地观陀罗尼。威德陀罗尼。华严陀罗尼。音净陀罗尼。虚空藏陀罗尼。海藏陀罗尼。分别诸法地陀罗尼。明诸法义陀罗尼。如是等略说五百陀罗尼门。若广说则无量。
    四种陀罗尼。一，法陀罗尼。谓诸菩萨得念慧力。持所闻法。经无量时。永不忘失。又名闻持陀罗尼。二，义陀罗尼。谓诸菩萨于诸法大、小、善、恶、分别。悉知无量义趣。永不忘失。又名分别知陀罗尼。三，咒陀罗尼。谓诸菩萨获得如是总持咒愿。悉皆灵验也。华言咒。梵言陀罗尼。此特华梵双标。就人释。为佛菩萨之定力。能持神咒之功德。就法释。神咒语句。总持无量之文义也（诸经中于此陀罗尼有五名。一，陀罗尼。二，明。三，咒。四，密语。五，真言。总持诸法。旋转无碍。名陀罗尼。佛说陀罗尼。能净一切盖障。故谓之明。其义不异。曰咒者。佛法未入中国前。此土本有咒禁之术。陀罗尼能发神通。满足一切行愿。与咒禁相似。故译为咒。凡夫二乘所不能知。故曰密语。如来所说。能显诸法实相。绝诸戏论。真实不虚。故曰真言）。四，忍陀罗尼。忍即安忍。谓菩萨成就坚固之行，于所闻法得精进忍。赞叹不喜。骂詈不憎。又名入音声陀罗尼。此四种陀罗尼。一为名持。二为义持。三为遮持。四为行持。法陀罗尼。以法为境。即能诠之名言也。以念慧为体。义陀罗尼体虽相同。而以所诠义为境。咒陀罗尼以定为体。以咒为境。忍陀罗尼以无分别智为体。以法为境。
    密宗所谓陀罗尼。专指咒陀罗尼。为佛菩萨从禅定所发之秘密言句。有多字、一字、无字之别。多字者。如本经所说。及楞严咒、大悲咒等。一字者。如密部之唵字吽字。无字者。如《圆觉经》云。有大陀罗尼。名为圆觉。《胜天王般若经》曰。众法不入陀罗尼。过诸文字。言不能入。心不能量。是也。

    大神咒者。具大神力之陀罗尼。阴阳不测之谓神。除障不虚。名大神咒。
    大明咒者。明为咒之别名。佛于光中说陀罗尼。以大光明破众生闇。鉴照无昧。名大明咒。
    【注】梵语尾你。此云明。破闇为义。梵语漫怛罗。此云真言。真言能破烦恼闇障。故亦译曰明。《大日经·疏》云。若心、口出者名真言。从一切身分任运生者。名之为明。

    无上咒者。无上。梵语阿耨多罗。是最胜义。穷理尽性。证得菩提涅槃。更无有法能出其上。名无上咒。
    无等等咒。无等等。梵语阿娑摩娑摩。超绝无伦之义。一切诸法。无能与等也。佛无与等。故曰无等。惟般若波罗蜜与佛相等。故名无等等。盖般若胜义。佛所依止。为诸佛秘密心印。更无他法。能与伦比。名无等等咒。
    【注】《智度论》。无等名涅槃。一切有为法。无有与涅槃等者。涅槃有三。声闻涅槃。辟支佛涅槃。佛涅槃。般若能与大乘涅槃故。名无等等。复次，诸佛法第一微妙。无能与等。无能及者。无可为比。般若波罗蜜能令众生得是心故。名无等等。复次。无等名诸法实相。诸观诸行。无能及者。故名无等。菩萨得是无等。能于众生中生慈悲心。故名无等等。

    《略疏》于此有三释。一，就法释。除障不虚。名为神咒。智鉴不昧。名为明咒。更无加过。名无上咒。独绝无伦。名无等等咒。二，约功能释。一者。能破烦恼。二者。能破无明。三者。令因行满。四者。令果德圆。三，就位释。一，过凡。二，越小。三，超因。四，齐果。谓无等之位。互相齐等。故云无等等。《十地论》云。谓佛比余众生彼非等故。重言等者。此。彼。法身等故。何故不但说无等耶。示现正等觉故。《会要》云。以般若神力有破惑障之能。故曰神咒。有破智碍之能。故曰明咒。由般若力历进诸位。成就万行。至等觉无间道中。即因满位也。此位满时。更无极上之因。故曰无上咒。对上因行。即解脱道中万德皆圆也。此果圆后。更无能等之德。与此相等。故曰无等等。以过凡故名为神咒。神犹圣也。般若神智。非凡有故。虽本智灵明。内外缘熏未具。无势力故。故云过也。越小者。以羊鹿车人。虽有尽智。断烦恼障出于界系。不除无明故。不断智障故。今甚深般若。以反无明。所以明也。超因者。牛车之人。虽二障俱离。一心显照。因行未满。犹有加故。今般若究竟。更无加上。故云无上。齐果者。谓果位相齐也。果位至极。名无等位。《宗镜录》云。竖无高盖。故言无上。横无俦例。故言无等。等于十方三世诸佛。故言无等等。

    能除一切苦。真实不虚。

    此总结功能也。能者。胜任义。除者。去义。以般若能去一切苦也。一切苦，义见前释。真实不虚者。决定无虚妄义。佛为不妄语者。故所说皆真实义。般若妙用。了妄即真。决定息苦。故云真实不虚。所以除疑劝信也。《大般若经》曰。学此般若波罗蜜多大咒王时。于我及法虽无所得。而能证得无上正等菩提。
    【注】真实义有四。一，世流布真实义。世间之法。悉同其名。众生见地即言是地。见火即言是火。终不言是水是风乃至见苦终不言乐。见乐终不言苦。虽于假名立相。然称认皆同。是为世流布真实义。二，方便流布真实义。世间有智之人。先以心意筹量。随宜方便。造作经书论义。以开导人。是为方便流布真实义。三，净烦恼障真实义。声闻缘觉以无漏道破诸烦恼。得无碍智。是为净烦恼障真实义。四，净智慧障真实义。声闻缘觉得无碍智。未能显发中道之理。名智慧障。佛菩萨断此障。则中道之理自显。是为净智慧障真实义。见《菩萨善戒经》。


第二章 密说般若

上一页 目录 全文完

第二章 密说般若

    故说般若波罗蜜多咒。即说咒曰。揭谛揭谛。波罗揭谛。波罗僧揭谛。菩提萨婆诃。

    上文显说般若。并以般若即咒。形容般若功能。此则承上而密说之。观自在菩萨在般若会中因舍利弗之启请。承佛印可而宣说者。亦即重演佛之密语也。
    此密说般若。是不思议境。体即真空。无异显说。但恐显说为人依文解义。依说起见。复执真空实有体相。遂成实法。还同生灭。致忘真空亦空之义。反生执著。复堕无明。故更密说。《大般若经》曰。一切法自性空。空性不应执著。如以智求智。智则应解。解即失真。起于照心。照则立境。随照失体。反成影事。是以大智现前。翻为名相之境。永嘉云。不离当处常湛然。觅则知君不可见。今此密说般若。正使人情忘智泯。不假寻求。真空现前。倏然默证。逾于符契。故名之曰咒。即如来秘密真实不可思议之语。咒愿众生。如佛无异。是故持诵者。当空其心，而一其念。念念无间。如蜾蠃之祝螟蛉。自然冥妄起真。即凡成圣。或云。显说令解生慧。灭烦恼障。密说令诵生福。灭罪业障。般若即咒。咒即般若。不分显密。各具四悉檀益。
    【注】四悉檀者。悉。普也。遍也。檀。具云檀那。此云施。华梵并称。悉檀义为普施。一。世界悉檀。又名乐欲悉檀。佛以人我等假名，随顺众生所乐。说世界法（世谓迁流。界谓方位）。令闻者欢喜。二，各各为人悉檀。又名生善悉檀。佛视众生机宜大小。宿根深浅。说各人所应之法。令发正信。增长善根。三，对治悉檀。又名断恶悉檀。因病施药。随证对治。四，第一义悉檀。又名入理悉檀。佛见众生机缘成熟。为说诸法实相。令入真证。

    经显义理。咒宗秘密。义理可诠。秘密不可说故咒语古皆不翻。其义有五。一者。诸佛密语。惟佛与佛能相了解。二者。总持一一字句。含藏多义。如薄伽梵之具六义是。三者。或是鬼神王名。呼之敕以守护行者。四者。诸佛密印。如世间王官印信。无往不通。五者。是不思议力所加持。但能密诵。即获大益。《靖迈心经疏》云。诸经咒词。所有文字。皆为诸佛菩萨威力加被。一一字句。皆摄多义。若翻就此方言词。或增或减。于义有阙。诵无良验。或则别告鬼神及诸天旁生。所有语音。多非印度常词。故诸咒例不翻华。此中含义至宏。与外道无义恶咒。但以听闻而为究竟者不同。《贤首法师心经略疏》云。咒词不可释。以诸佛秘语。非因位所解。但当诵持。除障生福。不须强释。如必欲知之。亦可略言。揭谛，此云去。意犹度也。即深慧之功能。揭，为行不可得义。谛，为一切诸法如如不可得义。乘如之行。是为真行。行者。无住之谓。故译曰去。重言之者。自度亦度他也。波罗此云彼岸。亦译究竟。圆满最胜之义。生死为此岸。涅槃为彼岸。烦恼为中流。彼岸者。度所到之处也。僧。梵语僧伽。总也。众也。和合之义。波罗僧揭谛者。自度、度他、同到彼岸也。菩提者。觉路。旧译为道。新译为觉。有事理二法。理者。涅槃。断烦恼障而证涅槃之一切智是。为通三乘之菩提。事者。一切有为之诸法。断所知障而知诸法之一切种智是。为诸佛之菩提。即所到之彼岸也。萨婆诃。此云成就。为一切真言结句。令成就正觉也。但既云密说。自不可以常义释之。必也名言双绝。理事两忘。烁迦罗眼窥摸不著。方符咒义。一落心思。便成知见渣滓。为无明根本。无明一起。万劫沉沦。一切苦厄。何由得度。行者当知狂心歇处。即是菩提。观照之极。无得无证。言语道断。心行处灭。心思绝则知见泯。知见泯则无明破。无明破则彼岸到。而般若之功用尽。
    【注】不思议力。即不可思议之力。不可思议者。理空非惑情所测。神奇非浅识所量。《净名经慧远疏》云。不可思议者。经中亦名不思议。通释是一。于中分别。据实望情。名不思议。据情望实。名不可思议。诸经所言不可思议。约有五种。一，众生不可思议。二，业力不可思议。三，龙力不可思议。四，禅定力不可思议。五，佛力不可思议。见《净土论注》。
    烁迦罗。又作灼羯罗。斫迦罗。斫迦婆罗。此云金刚。有坚固精进之义。又翻为轮。
    知见二字当分释。就意识曰知。就眼识曰见。觉了曰知。推求曰见。三智曰知。四眼曰见。皆为慧之作用。
    萨婆诃。真言结句。往往有之。惟诸经译音不同。苏婆诃。娑婆诃。娑缚诃。率缚诃。娑缚贺。馺婆诃。娑诃。音同字异。其义则有十一。一者。成就。二者。吉祥。三者。圆寂。四者。息灾增益。五者。无住。六者。警觉。七者。圆满。八者。散。九者。摄取。十者。究竟。十一者。本誓。此取成就之义。成就菩提之德也。
    咒语虽按梵音直译。然各本亦有小异。什师译本。菩提僧莎呵。法月译本。与奘师译本同。惟萨婆诃作莎婆诃。般若共利言译本。揭谛作蘖谛。萨婆诃作莎婆诃。其余亦同。智慧轮译本。则作唵。——誐帝誐帝。播——啰誐帝。播——啰散誐帝。冒——地娑缚贺。法成译本。作峨帝峨帝。婆啰峨帝。波啰僧峨帝。菩提莎诃。施护译本。作怛［宁＊也］他。唵。誐帝誐帝。播啰誐帝。播啰僧誐帝。冒提莎诃。清高宗御书心经石刻本。在西湖圣因寺者。作答达鸦塔阿。噶得噶得。巴阿唎噶得。巴阿唎桑噶得。玻提娑诃。
    《大般若经》第六百卷后。有般若佛姆心咒曰。怛耶他。唵。伽帝。伽帝。钵啰伽帝。钵啰僧伽帝。菩提萨嚩诃。《大乘理趣六波罗蜜多经·二·护持国界品》。智慧波罗蜜多菩萨。说真言曰。南谟薄伽伐帝曳（二合）。揭帝揭帝。波罗揭帝。波罗僧揭帝。冒地莎诃。《陀罗尼集经·三》。般若大心陀罗尼咒曰。跢侄他。揭帝揭帝。波啰揭帝。波啰僧揭帝。菩提莎诃。均与本经咒词相同。

    上来诠释《般若波罗蜜多心经》竟。

    因说偈曰。

    轮回生死事堪哀。　　　三界唯心万法赅。
    两执同空诸相泯。　　　无明了尽即如来。

    【注】偈。此云颂。梵语偈他。省云偈。按偈他。正音当作伽陀。《华严经疏》有四种。一，阿耨窣睹婆。不论长行与偈。凡满三十二字即为一颂。二，伽陀。此云讽颂。三字四字五字七字八字九字不等。以四句为一偈。孤起直说。故名直颂。亦名不重颂。《大乘义章》云。一切四言五言七言九言不重颂者。皆名伽陀。三，祗夜。应前已说之散文。重颂以申明之。名曰应颂。亦曰重颂。四，缊驮南。此云集施。谓以少言集多义。施人诵习也。《百论疏》云。婆娑列四种偈。一者。以八字为一句。三十二字为一偈。此是结偈法。名阿[少/兔]吒阐。此云处中偈。《嘉祥法华义疏》。谓之首卢伽陀。二者。六字为句。名初偈。三者。二十六字为句。名摩罗。此云后偈。四者。六字以下为句之四句偈。名周梨荼。《嘉祥法华义疏》。皆谓之结句伽陀。
    轮回。谓众生无始以来。旋转于六道之生死。如车轮之辗转无穷也。《法华经·方便品》曰。以诸欲因缘。坠堕三恶道。轮回六趣中。备受诸苦毒。《心地观经》曰。有情轮回生六道。犹如车轮无始终。《三昧经》曰。三界众生。轮回六趣。如旋火轮。《身观经》曰。循环三界内。犹如汲井轮。《圆觉经》曰。一切世界。始终生灭。前后有无。聚散起止。念念相续。循环往复。种种取舍。皆是轮回。又曰。当知轮回。爱为根本。由有诸欲助发爱性。是故能令生死相续。欲因爱生。命因欲有。众生爱命。还依欲本。爱欲为因。爱命为果。由于欲境。起诸违顺。境背爱心。而生憎嫉。造种种业。是故复生地狱、饿鬼。知欲可厌。爱厌业道。舍恶乐善。复现天、人。又知诸爱可厌恶故。弃爱乐舍。还滋爱本。便现有为增上善果。皆轮回故。不成圣道。是故众生欲脱生死，免诸轮回。先断贪欲，及除爱渴。
    事者。对理之称。梵语曰迦他。不生不灭之无为法曰理性。一切生灭有为法曰事相。堪者。可也。任也。哀者。悲也。哀愍众生。悉令度脱也。界者。限也。别也。谓三界分限。各别不同。故名界也。一，欲界。欲有四种。一者。情欲。二者。色欲。三者。食欲。四者。淫欲。下极阿鼻地狱。上至他化自在天。男女相参。多诸染欲。故名欲界。二，色界。色即色质。谓虽离欲界秽恶之色。仍有清净之色也。三，无色界。谓但有心识而无色质也。合欲界、色界、无色界谓之三界。
    梵语摩怛剌多。此云唯。有三义。一，简别。二，决定。三，显胜。云唯心者。一切诸法。惟有内心。无心外之法。亦云唯识。心有集起之义。集起诸法故云心。识有了别之义。了别诸法故云识。一心本具万法。而能成立众事。心性周遍。虚澈灵通。散之则应万事。敛之则成一念。若善若恶。若圣若凡。无不皆由此心。《华严经》曰。三界无别法。唯是一心作。盖世、出世间一切诸法。唯是真心所现。法唯心现。全法是心。心既圆融。法亦无碍。故曰。知一切法。即心自性。又曰。统观法界性。一切唯心造。《华严经》就集起之义。而曰唯心。《唯识论》就了别之义。而曰唯识。其体则一。但亦稍有别。唯心之名。通于因果。唯识之称。唯在因位。经义通因果。总言唯心。论说唯在因。但称唯识。
    万法者总赅万有事理之语。三界唯心万法赅者。谓一切法尽出于一心也。唐译《华严经·三十一》曰。三界所有。惟是一心。晋译《华严经·十》曰。心如工画师。画种种五阴。一切世间中。无法而无造。《大般若经·五百六十八》曰。于一切法。心为善导。若能知心。悉知众法。《心地观经·八》曰。心如画师。能画种种色故。心如僮仆。为诸烦恼所策役故。心如国王。起种种事得自在故。心如怨贼。能令自身受大苦故。赅者。兼覆之义。咸也。备也。空者。尽也。虚也。谓了达诸法无实相。自性本空。无我及我所也。《净名经》曰。诸法究竟无所有。是空义。两执同空者。二空理显也。既以般若观照而灭幻有。幻有灭尽。五取蕴（五取蕴者。谓取以为身假集故。以此五种取境起业，集聚有为，无为，有漏，无漏种，为来世因故。补特伽罗数取趣故。又名五受阴。以是众生所受报法故。此五受阴。亦可通名为想。通名为识。以受想行三阴皆是识之心所。色阴即是识之相分故。亦可通名为行。以色受想识皆是迁流造作法故。亦可通名为色。以初是有对有表色。后四皆是无对无表色故。见《楞严文句》）。空。五取蕴空，则人执法执空。人执法执空，则诸相自泯。
    诸相者。诸者。众义。相即色相。三界一切品类。洪纤妍丑。情与无情。及根尘诸法。各有形状。此诸差别之事物形相。名为诸相。《净名经》曰。法常寂然。灭诸相故。即诸相泯义。释诂。泯。灭尽也。我相。人相。众生相。寿者相。亦即一切相。《金刚般若波罗蜜经》曰。若见诸相非相。则见如来。又曰。离一切诸相。则名诸佛。能知一切相皆是虚妄。即不逐妄。即可见性。四相皆由执我而起。故四相实即一相。有广狭二义。从狭义言。执五蕴色身为我。即是我相。凡夫皆有此执。由现在而计未来。起种种妄想。现在为我相。未来为人相。因互相对待也。再由此身。起盛衰苦乐之象。是众生相。计五蕴色身命根不断。是寿者相。此就自己五蕴计度分别而生之四相。更就广义言之。计我即我相。与我对待者即人相。对象不一。即众生相。相续不断。即寿者相。要知四相皆从我见开出。开即四相。合即我相。我相从五蕴色身起执。四相空即我执空。又名人空。更进言之。法相。从法上起执。两执同空。则法相亦空。又名法空。穷空到底。即空亦空。是即般若遣执之效。了者。讫也。毕也。尽也。止也。终也。竭也。即者。就也。余均详前注。
    如来者。修证之极果。云无明了尽即如来者。亦犹《楞严经》。明极即如来之义。诚以心佛众生。虽在因在果。迷悟不同。理性所具。初无有异。如青铜作镜。本体无殊。经磨治者光明。受污染者昏闇。既了无明。即复本性。憨山大师云。一切众生。具有如来智慧德相。但以妄相颠倒执著而不证得。诸佛悟之而为普光明智。名佛知见。众生迷之而为无明业识。生死根株。一见此心。当下是佛。《华严经》曰。心佛与众生。是三无差别。一念心体。凡圣不二。具足十法界、十如是（不异名如。无非曰是。十法界各具十如是因果之法。一，如是相。相即相貌。相以据外。览而可别。始自地狱。终至佛界。是名如是相。二，如是性。性即性分。性以据内。自分不改。始自地狱。终至佛界。性各不同。是名如是性。三，如是体。体即体质。由性相所合成。始自地狱。终至佛界。俱以色身而为体质。是名如是体。四，如是力。由体所生之力。力即力用。始自地狱。终至佛界。皆有力用功能。是名如是用。五，如是作。作即造作。由用所作之业。始自地狱。终至佛界。皆能运为造作。是名如是作。六，如是因。因即习因。始自地狱。终至佛界。善恶业因。皆由自种而生。习续不断。是名如是因。七，如是缘。缘即缘助。始自地狱。终至佛界。各有缘起之法。助成习因。是名如是缘。八，如是果。果即习果。始自地狱。终至佛界。皆由习因习续于前。习果克获于后。是名如是果。九，如是报。报即报果。始自地狱。终至佛界。皆由习因习果而感其报。是名如是报。十，如是本末究竟。以上种种合而为一。具于一界。初相为本。后报为末。本末皆同。实相一理。平等无二。是名如是本末究竟）等法。诸佛众生。心元平等。是名心无差别。十方诸佛。了悟十法界、十如是等法而成正觉。即是悟本心之所具。亦是悟众生之所迷。迷悟虽殊。其体不二。是名佛无差别。九界众生。各具十法界、十如是等法。本心所具之法。与佛之所悟。其体不二。是名众生无差别。故众生与佛。仅有迷悟之殊。本觉心源。原来不二。众生自无始以来。为无明由藉。轮回生死。不能自脱。一旦证悟。惑尽障消。真如显现。即心是佛。犹如明镜蒙尘。一经拂拭。光明莹然。与初无二。故曰无明了尽即如来。此土恒言。舜何人也。我何人也。有为者亦若是。见贤思齐。事同一理固不可以凡滥圣。蹈大我慢。亦不可妄自菲薄。甘于暴弃。行者当知人身难得佛法难闻。古德有言。一口气不来更从何处安身立命。趁此色身未谢之时。精进修持。争取向上一著。莲邦不远。相期共证。

    复次，说偈回向。
    般若甚深微妙法。　　我依圣教随分释。
    回施功德利群生。　　同证菩提登极乐。
    【注】凡更端处曰复次。犹云再者。般若。甚深。义均见前。微妙者。法体幽玄曰微。不可思议曰妙。法者。梵语达摩。轨持之义。为通于一切之语。小者、大者、有形、无形、真实、虚妄、事物、道理，皆悉为法。《唯识述记》云。轨谓轨范。令物生解。持谓任持。不舍自体。依此义释之有二。一者。自体。二者。轨则。兼摄有体无体。总赅万有事理。盖万有事理。一一有自体。具轨则。故皆名法。乃至龟毛兔角。毕竟无者。亦名为法。以彼有无之自体与无之轨则也。万法由因缘而生。为自然之法。因缘生之法。无有自性。无性故空。即以空为性也。万法各有一空性。谓之一如。一者。不二义。如者。相似义。对万而言曰一如。对妄而言曰真如。以大乘至极之义。说万物之性相。则万法是真如。真如是万法。万法指染净诸法。真如指离染净之实体。真如之体如水。万法之相如波。波性即水。犹万法之性即真如。水随缘而现波相。犹真如之体。应缘而现万法之相。《净名经》曰。万法即真如。由不变故。真如是万法。由随缘故。我有主、宰二义。主有自在力。宰有割断力。主是我体。宰是我所或我用。主是俱生我。无分别故，属第七识我。宰是分别我。有割断故，属第六识我。我有六种。一，执我。谓分别俱生。在于凡位。二，慢我。谓但俱生。在有学位。三，习气我。谓二我余习。在无学位。四，随世流布我。谓诸佛等随世假称。五，自在我。谓八自在等。如来后得智为性。六，真我。谓真如常乐我净等。以真如为性。见《宗镜录·六十五》、《六十七》。依。说文倚也。又从也。圣教。犹言正教。《宗轮论述记》云。圣者。正也。与正理合为圣。又契理通神。名之为正。此所说教。名为圣教。《圆觉经》曰。闻此圣教。随顺开悟。《解深密经·一》曰。已善奉行如来圣教是也。随分者。随应有之分限也。释者。解释开演之义。
    回施者。以此功德平等共有回向施与一切众生也。功者。福利之功能。此功能为善行之德。故曰功德。《大乘义章》云。功谓功能。善有资润福利之功。故名为功。此功是其善行家德。名为功德。《天台仁王经疏》云。施物名功。归己名德。《胜鬘经》曰。德者。得也。修功所得。故名功德也。利者。利益。《法华文句·六》云。自益名功德。益他名利益。群者。众也。群生即众生。《华严经·普贤行愿品》曰。悉除一切恶道苦。等与一切群生乐。《无量寿经》曰。求清白之法。以惠利群生。利益有情。拔苦与乐。菩萨利他之行也。
    同者。共同。以无漏正智，契合于所缘之真理曰证。二乘极果及初地以上乃至十地等觉为分证。妙觉为满证。菩提义亦见前。极乐即西方净土之极乐国。阿弥陀佛之国土也。又作安养。安乐。无量清净土。无量光明土。无量寿佛土。莲华藏世界。密严国。清泰国等。梵语须摩提。此云妙乐。诸事具足圆满。惟有乐而无苦也。《阿弥陀经》曰。从是西方过十万亿佛土。有世界名曰极乐。其土有佛。号阿弥陀。今现在说法。舍利弗。彼土何故名为极乐。其国众生。无有众苦。但受诸乐。故名极乐。《无量寿经》曰。法藏菩萨。今已成佛。现在西方。去此十万亿刹。其佛世界名曰安乐。《称赞净土经》曰。于是西方。去此世界过百千俱胝那庾多佛土。有佛世界名曰极乐。其中世尊。名无量寿及无量光。《鼓音声经》曰。西方安乐世界。今现有佛号阿弥陀。其国号曰清泰。《观音授记经》曰。西方过此亿百千刹。有世界名安乐。其国有佛。号阿弥陀。《秘藏记》云。华藏世界者。最上妙乐在其中。故曰极乐。当知极乐与华藏。虽名异而非异所。《密严经》曰。依自难思定。现于众妙色。色相无有边。非余所能见。极乐庄严国。世尊无量寿。是知华严之华藏世界。密教之密严国。皆极乐国之异名。登详前注。

    愿以此功德。　　普及于一切。　　我与诸有情。　　皆共成佛道。
    亡过诸先灵。　　世琪及永洪。　　仗此胜妙因。　　超生极乐国。
    【注】梵语尼坻。此云愿。志求满足也。《法界次第》云。自制其心。名之曰誓。志求满足。故云愿也。有总愿、别愿。总愿，如四弘誓。别愿，如药师佛十二愿，千手观世音之六愿、十愿，普贤之十愿，阿弥陀佛之二十四愿、四十八愿。释迦牟尼佛之五百愿。
    普。博也。大也。遍也。及。逮也。至也。普及。犹云遍至也。于。语辞。与于通。于。在也。指定之辞。
    一切。赅罗事物之称。《玄应音义》云。说文云。一切。普也。普即遍具之义。一以普及为言。切以尽际为义。与。及也。偕也。梵语萨埵。此云有情。有情识故。又情者。爱也。能有爱生故。旧译作众生。
    皆。俱也。同也。统括之辞。共。同也。皆也。合也。公也。成。就也。毕也。凡功卒业就谓之成。佛道者。通于佛之道路。梵语菩提。新译曰觉。旧译为道。道者。通义。圆通无碍也。在因则到于佛之万行。在果则无上正等正觉。《法华经·方便品》曰。是诸世尊。皆说一乘法。化无量众生。令入于佛道。
    亡。失也。过。往也。已往曰过。先灵。先世祖先之神识也。
    世琪。姓许氏。为止庵原配。赋性贞毅。言行不苟。逝世时年六十二。怛然奄化。无诸痛苦。越四日大敛。四体柔软。面含笑容。余以愿力。助其往生。
    永洪。为止庵次子。生而岐嶷。性不好弄。童稚即如成人。聪颖好学。自小学至大学。考试皆列前茅。性慈善。乘车遇御者老弱，即给资遣之去，而步行到校。生平不作妄语。待朋友尤诚恳。一日遇同学与相戏。出不意推堕路轨中。伤手部大出血。医者以钉钉之。始可缝合。痛苦剧甚。面不改容。其母询推者姓名。坚不肯告。曰。知之徒多怨。不必道也。其坚忍能容如此。事亲孝。其母患[(病-丙)+扁]。强起侍疾日久无倦意。至临殁前夕犹然。其卒也。以肺部及胃出血死。得疾之由。则以应当时政府强迫军训。受不合理之剧烈劳动。得病回来。正值倭寇内侵。随余奔走道途。失于调理。终至不起。余有诗八绝悼之云。
    一生行事率天真
    三育无惭智勇仁
    跖寿颜夭天梦梦
    更从何处说前因
    福虚吾忆仲任语（善人之命不长，恶人之命不短。见王充《论衡》）
    至孝如何不永年
    热血满腔含泪逝
    临危辞母祝安全
    巍科高第神明瘁（先考味仁公于清光绪癸卯以第一人成进士。入词林。不久以脑溢血逝世）
    卅载思亲泪未干
    太息斯儿同一辙（儿高中毕业后，应会考列甲等）
    有才无命我心酸
    同时达者多先逝
    后死原知业未消
    蕙折可怜嗟短命
    不堪身世日萧条
    国危自合教民战
    绝膑何能成士材（九一八后。政府励行军训。以下级军官任教。不谙教育方法。但以军队剧烈动作。令学生作苦。体弱者多被折磨以死）
    我为宗邦重叹息
    不应戕贼好人才
    清寒省识衰亲苦
    俭读尤难秉性真
    今日只余书剑在
    每展遗挂倍伤神
    生死相逢一日中（儿生于戊午十二月十七日巳时。殁于戊寅十二月十七日酉时。在世适满二十岁）
    廿年光景太匆匆
    剧怜生小岐嶷甚
    一现昙华万事空
    转劫似闻已入仙（己卯冬至前夕。梦中闻丰隆声。见天际云开。儿飘然御风冉冉上。旁一人告余曰。此转劫也。汝行亦往耳。方欲有语。已瞿然醒矣。余音犹在耳也）
    九原待我共升天
    伤心莫说人间事
    说到人间总黯然
    儿平日不好茹荤。出于自然。殁日适为先母忌日。以素菜祭。儿强起与祭。最后一饭。亦未近荤辛。观其去来之迹。非有夙根者不能。吾所以详述之者。以儿之夭亡。顿起余诸行无常之感。为诠注本经发起因缘。可谓以鸠摩罗浮多（鸠摩罗。此云童。八岁以上乃至未娶者之总名。浮多。此云真。见《玄应音义》）导我于善道者也。
    仗，凭依也。此，斯也。指定之辞。胜因，殊胜之善因也。妙因，绝妙之行因也。
    超，越也，不囿于常格也。生，往生也。去娑婆世界往阿弥陀如来之极乐净土谓之往。化生于彼土莲华中谓之生。余均详前注。

    谨以至心。发大誓愿。
    【注】谨，说文，慎也。玉篇，敬也。广韵，洁也。增韵，毖也。专也。重也。易乾卦。庸行之谨。至。犹极也。至心。至诚之心也。《金光明经文句·二》云。至心者。彻到心源。尽心实际。故言至心。发。广韵，起也。大。犹弘也。梵语僧那。此云誓。尼坻，此云愿。天台云。广普之缘谓之弘。自制其心谓之誓。志求满足乃称愿。《万善同归集·四》云。发大愿者。万行之因。能长慈悲。不断佛种。大事成办。所作克终。成道利生。皆因弘誓。

    我于娑婆无所恋　　　求成佛道度众生
    尽化烦恼作菩提　　　遍虚空界成净土
    止庵居士发愿竟
    【注】于者。在也。指定之辞。
    娑婆。梵语。新作索诃。此云能忍。堪忍之义。此土众生堪忍众苦不肯出离也。《法华文句》云。娑婆，此翻忍。其土众生安于十恶。不肯出离。从人名土。故称为忍。《法华玄赞》云。梵云索诃，此云堪忍。诸菩萨行利乐时。多诸怨嫉。众苦逼恼。堪耐劳倦而忍受故。《悲华经》曰。云何名娑婆。是诸众生忍受三毒及诸烦恼。故名忍土。亦名杂会。九道共居故。《西域记》云。索诃世界。三千大千国土。为一佛化摄也。
    无，不有也。所，指示事物之辞。恋，慕也。心所系念而不释也。恋慕执著诸可意境而不舍离也。
    求。取也。索也。度。与渡通。过也。自此岸达彼岸也。
    梵语仆呼缮那。或萨多婆。此云众生。摩诃衍云。意及意识。一切众染合集而生。故名众生。《同性经》曰。佛言。众生者。众缘和合。名曰众生。所谓地水火风空识名色六入因缘生。《楞伽经》曰。此众生者。无明为本。依爱而住。以业（身口意）为因。《法鼓经》曰。万法和合施设。名为众生。《大乘义章》云。依于五阴和合而生。故名众生。又云。多生相续。名曰众生。《般若灯论》云。有情者数数生。故名众生。《法华文句·四》云。处处受生。故名众生。
    尽，终也，竭也，达于极也。化，自然之变易也。荀子正名。状变而实无别而为异者谓之化。注。化者，改旧形之名。
    梵语吉隶舍。此云烦恼。贪欲、嗔恚、愚痴等诸惑、烦心恼身也。《智度论》云。能令心烦能作恼故。《大乘义章》云。劳乱之义。名曰烦恼。《唯识述记》云。烦是扰义。恼是乱义。扰乱有情。故名烦恼。又名盖。覆盖之义。覆盖行者清净信心。不得开发也。又名漏。烦恼现行。令心连注流散不绝也。作。为也。
    梵语菩提。此云道。肇师云。道之极者称曰菩提。秦无言以译之。后代诸师。皆译为道。以大论翻为佛道故。《守护国界主陀罗尼经》曰。善男子。欲知菩提。当了自心。若了自心。即了菩提。何以故。心与菩提真实之相。毕竟推求俱不可得。同于虚空。故菩提相。即虚空相。是故菩提无所证相。无能证相。亦无能所契合之相。何以故。菩提毕竟无诸相故。善男子。以一切法。即虚空相。是故菩提毕竟无相。又曰。此虚空性。即心性故。如其心性。即菩提性。《华严经》曰。若能善用其心。即获一切胜妙功德。凡夫由昧心源。故随妄念。能于妄念深照性空。名解大道。化烦恼作菩提者。如昔人云。观淫怒痴。相同水月。了染净体。性如虚空。遇顺无著。遇违不嗔。于恶境界。得解脱门。
    遍。匝也。周也。《入楞伽经》曰。梵语刹尼迦。名之为空。或呿提。秦云虚空。《涅槃经》明虚空喻。立三义。一，无变易。亘古腾今。时移俗化。惟此虚空。常无变易。二，无边际。物分表里。空无内外。故无边际。三，无挂碍。物体质碍。空性虚通。《释摩诃衍论》。虚空十义。一，无障碍义。诸色法中无障碍故。二，周遍义。无所不至故。三，平等义。无简择故。四，广大义。无分际故。五，无相义。绝色相故。六，清净义。无尘累故。七，不动义。无成坏故。八，有空义。灭有量故（为有之空）。九，空空义。离空著故（为空之空）。十，无得义。不能执取故。《大乘义章》云。虚空有体有相。体则周遍。相则随色彼此别异。虚空界者。谓眼所见之大空也。《中阿含经》曰。譬如月无垢。游于虚空界。《智度论》云。虚空界无量诸佛土。《楞严经》曰。空生大觉中。如海一沤发。有漏微尘国。皆依空所生。
    欲知净土为何。应先明性土相土。法性之理。非秽非净。非广非狭。犹如虚空。遍满于一切处。是曰性土。如常寂光土是也。净土对于秽土而言。二者均属相土。随众生心量所现而有净秽差别。净土为金银琉璃所成。种种庄严。且无四趣（修罗、畜生、饿鬼、地狱）五浊（劫浊、见浊、烦恼浊、众生浊、命浊是名五浊。亦名五滓。亦名五浑。劫浊为总。余四浊为别。劫，梵语具云劫波。此云分别时节。住劫中人寿二万岁时为始。初时浊轻。末法浇薄。众生竞造恶业。浊遂增长。至减劫人寿减至三十岁时。饥馑灾起。减至二十岁时。疾疫灾起。减至十岁时。刀兵灾起。世界众生。无不被害。谓之劫浊。劫浊无别体。但约四浊立此假名。见浊以身见、边见、邪见、见取、戒禁取之五利使为体。迷于四谛理性而起。其性锐利。故名利使。众生迷于见惑。不修善道也。烦恼浊以贪、嗔、痴、慢、疑之五钝使为体。迷于世间事物而起。其性闇钝。故名钝使。众生缘诸爱欲。悭贪斗诤。恼乱心神也。众生浊亦无别体。揽五钝五利之十使所应受果报。假立此名。众生造作恶业，自受其果也。命浊以连持色心为体。人生寿命。由增而减。以恶业故。摧年促寿也。《楞严经·四》以空见不分，有空无体，有见无觉，相织妄成，为劫浊。故色阴破即超劫浊。以无色则无空。无空则见无所织也。以身搏四大为体。见、闻、觉、知。壅令留碍。水、火、风、土，旋令觉、知相织妄成，为见浊。故受阴破即超见浊。以无受即无搏。无搏则性大不织也。以性发知见。容现六尘。离尘无相，离觉无性，相织妄成，为烦恼浊。故想阴破则超烦恼浊。以无想则六识无用。惟根与尘。不生烦恼也。以生灭不停，知见每欲留于世间，业运每常迁于国土，相织妄成，为众生浊。故行阴破即超众生浊。以无行则无生灭。无生灭则识想尽而轮转息也。以见闻元无异性，众尘隔越，无状异生，性中相知，用中相背，同异失准，相织妄成，为命浊。故识阴破即超命浊。以此浊以第八识体用相织为体。识阴破则色心不能连持。命根即断也。与余经所说五浊不同）等之浊秽者。如西方之极乐世界。秽土为瓦砾土石所成。充满杂秽。如娑婆世界。净、秽二土皆有报土化土之别。诸佛如来。历无数劫。修习无量善根。以自己修因所感。自在无碍。称性受用者。为自受用报土。对初地以上所现。由他机所感者。为他受用报土。应化身所居曰化土。佛菩萨为度凡夫二乘而变现之国土也。极乐世界为报土，抑为化土。人异其说。天台、净影谓为化土。道绰、善导谓为报土。慈恩谓兼报化二土。若登地菩萨。各见他受用土。若地前便见化土。化土诸佛平等。无有优劣。若报土者。随众生现而有差别。
    《涅槃经》曰。一切善业。皆净土因。一，修戒为因。远离十恶。修行十善。自持净戒。二，修施为因。施病医药。造立僧房。造像立塔。与持戒人及说法者种种供养。三，修慧为因。书写经卷。乃至一偈。所受读诵。为他演说。四，护法为因。守护正法。不谤方等。《净名经》维摩诘言。菩萨成就八法。于此世界行无疮疣。生于净土。何等为八。饶益众生而不望报。代一切众生受诸苦恼。所作功德尽以施之。等心众生。谦下无碍。于诸菩萨视之如佛。所未闻经闻之不疑。不与声闻而相违背。不嫉彼供。不高己利。而于其中调伏其心。常省己过。不讼彼短。恒以一心求诸功德。是为八。
    东、西、南、北、四维、上、下。十方皆有净土。而独宗西方者。法藏愿力。摄引往生故。娑婆教主。金口亲宣故。华藏、密严。名异实同故。十方诸佛。同所护念故。极乐莲邦。非三界摄故（地居故。非色界。有形故。非无色界。无欲故。非欲界。故云非三界摄）。阿弥陀佛。于此界众生。偏有因缘故。普贤愿王。导归极乐故。十方佛国。境宽则心昧。专志西方。境狭则愿切故。
    吾既发愿竟。检王日休居士《龙舒净土文·四》云。祝变吾国，以至十方浊恶世界，皆为清净极乐世界。喜古德已先我发愿。愿尽未来际，一切有情，离苦得乐，咸同斯愿。
    止庵者。居士自号。幼读时名祖恩。求学时名祖琛。伯澄。表字也。沙罗门多伽。吾师贡噶呼图克图所命也。名者。实之宾也。宾固非实。实亦非有。分别妄想。众缘和合。依世俗义。假与施设。时政尚质。则留止庵一名以行世而已。恒沙劫来。吾之入胎出胎。不知凡几。吾名亦不知凡几。四大皆空。五蕴非实。即此止庵二字。他日者亦同归于烟消云灭。不应执著。亦无可执著也。
    止者。已也。息也。《广韵》。止。停也。足也。易艮卦。艮。止也。时止则止。时行则行。老子《道德经》。知足不辱。知止不殆。庄子《德充符》。人莫鉴于流水而鉴于止水。惟止能止众止。庚桑楚。知止乎其所不能知。至矣。《大学》云。知止而后有定。定而后能静。静而后能虑。虑而后能得。居士一生行事。避热就冷。辞尊处卑。与世无争。与人无忤。就世间法论。藉止以藏名拙。就出世法论。藉止以断烦恼。梵语奢摩他此云止。静息动心。止心于一处也。《佛地论》云。止谓三摩地。僧伽摩罗言。止者。诸结永尽。《起信论》云。止谓止一切境界相。随顺奢摩他观义。《圆觉经》曰。善男子。若诸菩萨。悟净圆觉。以净觉心。取静为行。由澄诸念。觉识烦动。静慧发生。身心客尘。从此永灭。便能内发寂静轻安。由寂静故。十方世界诸如来心。于中显现。如镜中像。此方便者。名奢摩他。风雨如晦。鸡鸣不已。虽不能至。心向往之。
    庵。亦作庵。隐遁者所居之茅屋也。《广韵》云。庵。小草舍也。刘熙释名云。草圆屋曰蒲。又谓之庵。庵。奄也。所以自奄覆也。《释氏要览》曰。西天僧俗修行者多居庵。
    居士之名。始见于《礼玉藻》。《居士锦带》。郑康成注。道艺处士也。梵语迦罗越。此云居士。《净名经》慧远疏云。在家修道。名为居士。《法华玄赞》云。守道自恬。寡欲蕴德。名为居士。在印度除王及王臣婆罗门种。其余在家白衣。皆为居士。白衣者。在俗未出家之人。《涅槃经疏·十四》云。西域俗尚穿白。故曰白衣。《净名经·方便品》曰。虽为白衣。奉持沙门清净律行是也。
    发愿发起誓愿也。竟，终也。余均详前注。
    《般若波罗蜜多心经诠注·卷三·下》终

    《三世诸佛所说护法陀罗尼》（碛砂藏第五十八册珍字，句读另据《一切经音义·八》校正）

    三世诸佛。为护正法。说陀罗尼。拥护天王及人王等。令护正法久住世间。与诸有情作大饶益。陀罗尼曰。
    呾侄他（一）阿虎洛（二）屈洛罚底（三）虎剌拏莎窭荼（四）者遮者遮折尼（五）阿奔若刹多刹多（六）刹筵多刹也莎诃（七）陕末尼羯洛（八）邬鲁邬鲁罚底（九）迦逻跋底迦（十）阿鞞奢底尼莎剌尼（十一）祛阇祛阇末底（十二）阿罚始尼罚尸（十三）罚多罚多奴娑理尼（十四）部多奴悉没栗底（十五）提罚多奴悉没栗底莎诃（十六）
    天王当知。此大神咒。能令一切天、龙、药叉、健达缚、阿素洛、揭路荼、紧捺洛、莫呼洛伽、人、非人等一切有情。皆得安乐。此大神咒。三世诸佛。为护正法。及护天。王及人王等。令得安乐。以方便力而宣说之。是故天王及人王等。为令正法久住世故。自身眷属得安乐故。国土有情无灾难故。各应精勤至诚诵念。如是。则令怨敌、灾难、魔事、法障皆悉消灭。由斯正法久住世间。与诸有情作大饶益。
    【注】以上陀罗尼自《大般若波罗蜜多经·五百七十一卷·第六分·无所得品第九》恭录。

上一页 目录 全文完