封面

于凌波居士讲授

佛光山丛林学院．台中慈明佛学研究所佛学讲义


目录

一、唯识三十颂讲记

第一讲 唯识宗学统概述
第二讲 三十颂科判大纲
第三讲 唯识学上的几个基本概念
第四讲 识变──八识三能变
第五讲 异熟能变──第八识
第六讲 思量能变──第七识
第七讲 了境能变──第六识
第八讲 前六识的王所相应至起灭分位
第九讲 正辨唯识与释违理难
第十讲 释违教难──三自性与三无性
第十一讲 明唯识性──真如
第十二讲 明唯识位──唯识五位修行

二、唯识二十颂讲记

第一讲 绪论──介绍唯识宗和唯识二十颂
第二讲 诠释第一至第三颂
第三讲 诠释第四至第八颂
第四讲 诠释第九至第十四颂
第五讲 诠释第十五至及十七颂
第六讲 注释第十八至第二十颂

三、简明成唯识论白话讲记

序言

第一篇　释归敬颂．释难破执．标宗归识．彰能变体

第一章　归敬颂与造释愿由
第二章　释难破执．破实我
第三章　释难破执．破实法
第四章　释难破执．破余乘
第五章　释难破执．释外妨难
第六章　彰能变体

第二篇　异熟能变识诠释

第一章　三相门
第二章　所缘行相门
第三章　心所相应门
第四章　五受相应门
第五章　三性分别门
第六章　心所例同门
第七章　因果譬喻门
第八章　伏断位次门
第九章　如何证明有第八阿赖耶识──五教证
第十章　如何证明有第八阿赖耶识──十理证

第三篇　思量能变识诠释

第一章　举体出名门
第二章　所依门
第三章　所缘门
第四章　体性行相门
第五章　合解染俱相应二门
第六章　三性分别门
第七章　界系分别门
第八章　起灭分位门
第九章　如何证明有第七识

第四篇　了境能变识诠解

第一章　能变差别门
第二章　自性行相门
第三章　三性分别门
第四章　心所相应门．泛说六位心所
第五章　三受门
第六章　心所相应门．详释六位心所
第七章　所依门．俱不俱转门
第八章　起灭分位门
第九章　综合分别八识

第五篇 广释所变 释违理难 释违教难 唯识实性

第一章 正辩唯识
第二章 问答辩难
第三章 释违理难．心法生起的原由
第四章 四缘．十因．五果
第五章 释违理难．有情生死相续的由来
第六章 惑、业、苦与十二有支
第七章 释违教难．三种自性
第八章 释违教难．三种无性与唯识实性

第六篇 明唯识位．唯识五位修行

第一章 总明五位
第二章 释资粮位
第三章 释加行位
第四章 释通达位
第五章 释修习位
第六章 释究竟位

四、八识规矩颂讲记


第一讲 唯识宗学统概述

一、唯识三十颂讲记

    第一讲 唯识宗学统概述
    <唯识三十颂> ，是唯识宗的基本论典，唯识宗即依此论典而建立。所以要讲三十颂，必须要由唯识宗的建立与传承说起。中国的唯识宗，源自印度大乘佛教的瑜伽行学派。而说到瑜伽行学派，又不能不追溯到中观学派，兹依次介绍如下。
    一、 印度大乘佛教的中观与瑜伽二派
    印度的大乘佛教，兴起于西元世纪开始之后。一代大哲龙树，住世年代约在西元一五零至二五零年之间，他出身于南印度的婆罗门种姓，自幼受婆罗门传统教育，后来皈依佛教。当时南印度已有大乘经典流行，他读之不以为走足，传说他游行北印度时，自雪山地区一个老比丘处得到一部分大乘经典，又在大龙族聚居之地得到许多大乘经典，这样就更充实了他的大乘理论。他回到南印度，把当时流行的般若思想组织起来，完成了‘缘起性空’的空宗哲学体系。
    原来龙树住世时代，印度思想界的潮流，一方面是外道的诸法实有、或常或断的思想，一方面是小乘有部的‘我空法有’，及‘法体恒有、三世实有’思想。龙树为破邪显正，他依据佛陀的根本思想缘起理论、及当时的般若思想，广造论典， 破斥邪说。 这种思想，表现在 <中观论> 一书中。如‘八不偈’所称：
    不生亦不灭，不常亦不断，不一亦不异，不来亦不出，能说是因缘，善灭诸戏论，我稽首礼佛，诸说中第一。
    八不，其实就是全盘否定──自诸法空性上，否定小乘、外道的生灭、常断、一异、来出诸戏论。诸法以因缘和合而生，非独立存在，故无自性。无自性即‘性空’，亦曰 ‘空性’性，这一点则表现在‘三是偈’上。即所谓：
    诸因缘生法，我说即是空，亦为是假名，亦是中道义。
    龙树菩萨的著作很多，古有千部论主之称，除 <中观论> 外，主要的尚有 <十二门论> ， <大智度论> 等。继承龙树学说的，是他的弟子提婆。提婆所著的 <百论> ，与龙树的 <中论> 及 <十二门论> ，合称三论。是后来我国三论宗所依的论典。而龙树、提婆这一系的理论，在印度被称为 ‘中观学派’，亦称‘空宗]。
    龙树、提婆的空观，是以诸法无自性立论，并非徒持空见，妄计一切皆空。惟传至后世，则流为‘顽空’──学者不解空义，妄执一切皆空，于世俗谛，不施设有； 于胜义谛，真理亦无。此谓之‘恶取空’，亦称为‘沈空’。佛灭后九百年倾，无著、世亲两大论师出世，为矫治当时沈空之弊，而标示 ‘有’义。此有，非是小乘外道之诸法实有，而是破我法二执后所显示的‘真空妙有’。这在印度称为‘有宗’，亦称‘瑜伽行学派’。
    无著菩萨住世的年代，约为西元三六零至四六零年之间。据说天宫兜率内院的弥勒菩萨，应无著之请，在中印度阿瑜遮那国，为无著说 <瑜伽师地论> 、 <分别瑜伽论> 、 <大乘庄严论> 、 <辩中边论> 、 <金刚般若论> 五部大论，无著承弥勒之说，与其弟世亲把五部大论做了一番综合整理工做，依此建立有宗，即印度的‘瑜伽行学派’。但弥勒不是历史上实有的人物，也许世间另有一个名叫弥勒的人。或者，五部大论根本是无著的著作，假托弥勒之名行世的。更可能的是，早在无著之前，就有许多无名的饱学的瑜伽师，而无著是继承他们学说而加以发扬的。
    无著梵名阿僧伽 Asaga、 是印度笈多王朝 (320─500) 中期的人，他是北印度健陀罗国富娄沙富城人，出身于婆罗门家庭，父名乔尸迦 Kausika、 居国师之位，有子三人，长即无著，次名世亲，幼名狮子觉。无著先在小乘佛教化地部出家，相传他因思惟空义不能得入，曾欲自杀，后得遇宾头罗罗汉为讲小乘空观，他初闻悟入，然犹不能满意，后来得到弥勒的五部大论，继承此说，集众宣之，由是大乘瑜伽法门传至四方。
    无著晚年游化于中天竺的乔赏弥国，百岁左右始入圆寂。他的著作很多，亦有千部论主之称。他所著的 <显扬圣教论> ，相当于 <瑜伽师地论> 的节略本； 而 在<摄大乘论>中已建立了唯识学的核心， <大乘阿毗达摩集论> 则是建立法相学的中心。无著的主要著作，有 <显扬圣教论> 、 <摄大乘论> 、 <大乘阿毗达摩集论> 、 <大乘庄严经论> 、 <金刚般若论> 、 <能断金刚般若论颂> 、 <六门教授习定论颂> 、 <顺中论> 等多种。
    世亲梵名 Vasabandhu、音译婆薮槃豆，是无著的异母弟，生卒年代约在西元三八零至四八零年间。陈代真谛译 <婆薮槃豆法师传> ，称他： [于萨婆多部 (即说一切有部) 出家，博学多闻，遍通坟典，师才俊朗无可为俦，戒行清高，难以相匹。’ 据说世亲为了取舍阿毗达摩一系理论，他曾匿名化装，到有部的学术中心迦湿弥罗城，学习有部教理四年，后来回到富娄沙富城，用经量部教义，批判有部，集众宣说。且随讲随写，著为 <阿毗达磨俱舍论 > 。此论一出，颇有争论，而无能破之者，时人称此论为聪明论。
    世亲在北印度宣扬小乘，隐蔽大乘，其兄无著悯之，托以疾病，诱其来见，命弟子于邻室宣读 <华严经、 十地品> ，世亲闻之，方知其兄苦心。他深悔以往弘扬小乘诽谤大乘的错误，要割舌以谢过。无著对他说： [你先前既用舌头诽谤大乘，现在何不用舌头来赞扬大乘呢？ ’这样世亲乃舍小入大，广造论释，宣扬大乘，而大成了唯识宗。
    世亲约于八十岁的时候，在阿瑜遮那国逝世，时其兄无著逝世已二十余年。他遗留的著作很多，与唯识学有关的，如下列所举：
    一、 <摄大乘论释> 十卷，有三种译本，陈真谛译本名 <摄大乘释论> ，隋达摩笈多译本名 <摄大乘论释论> ，唐玄奘译本名 <摄大乘论释> 。
    二、 <辨中边论释> 一卷，唐玄奘译。
    三、 <唯识二十颂> 一卷，唐玄奘译。
    四、 <唯识三十颂> 一卷，唐玄奘译。
    五、 <大乘五蕴论> 一卷，唐玄奘译。
    六、 <百法明门论> 一卷，唐玄奘译。
    印度古人造论，是先作本颂，总括全书要义，然后依颂作释，名曰长行，长行是论著的正文。而 <唯识三十颂> 一书，是世亲晚年之作，长行未作而已示寂。此际瑜伽行学派的理论已成为大乘佛教的主流，研究者极多，世亲寂后的百年之间，许多学者竞为三十多作释论，其中最著名者有十位，后世称为十大论师。十大论师的名字是：
    一、 亲胜： 梵名畔徒室利，Bahbhu'sri， 与世亲同时。
    二、 火辨： 梵名质旦罗婆拿 Citrabhana ，与世亲同时。
    三、 德慧： 梵名娄拿末底 Gunamati ，他是安慧的老师。
    四、 安慧： 梵名悉耻罗末底 Stharamati ，是大乘唯识宗有名的大学者。
    五、 难陀： 梵名 Nanda，意译欢喜。在唯识学心识上主张立相、见二分。
    六、 净月： 梵名质咀罗婆拿 Citrabhana ，与安慧同时。
    七、 护法： 梵名达磨波罗 Dharmapala ，六世纪中叶人。
    八、 胜友： 梵名毗世沙密多罗 Visesamitra， 曾在那烂陀寺从护法学唯识教义。
    九、 胜子： 梵名若那弗多罗 Jinaptra，著有 <瑜伽师地论释> 一卷，唐玄奘译。
    十、 智月： 梵名若那战多罗 Jnanacandra， 他也是护法的弟子。
    此处特别要介绍的是戒贤，他是西元六至七世间人。生于东印度三摩坦国，婆罗门种姓，少年好学，游历四方，访求名师，至中印度那烂陀寺，从护法受学出家，三十岁时，与南印度一大外道辩论获胜，受到国王的嘉赏，为他起造伽蓝。后来长期主持那烂陀寺，弘传唯识宗义，他依据 <解深密经> 、 <瑜伽师地论> 等经论，将佛教判为三时：
    一、 第一时教：谓释尊初说阿含，说‘我空法有’之旨，称为有教。指小乘教。
    二、 第二时教：谓释尊为大乘者说般若‘诸法皆空’之理，心境俱空，指大乘空宗。
    三、 第三时教：谓释尊以三自性三无性之说，肯定非空非有之中道教，指大乘有宗。
    我国唐代玄奘三藏游学印度时，曾在那烂陀寺师事戒贤，依之学习 <瑜伽师地论> 及十支论等唯识学说。时戒贤已一百零六岁为寺中大长老，众共尊称为正法藏。
    二、 中国唯识宗的建立
    玄奘大师，是我国的四大译经家之一，也是唯识宗的开创人。他俗家姓陈、名褛，河南偃师人，隋文帝开皇二十年生。他有兄长捷， 早年在洛阳净土寺出家，玄奘亦于十三岁时随兄出家。唐高宗武德元年，与兄同入长安，寻赴成都参访。武德五年受具戒重回长安，从法常、僧辩二大德听 <摄大乘论> ，以诸师所说，各异宗途，圣典亦有隐晦，不知所从，乃欲西行天竺以明之。表请不许，奘师不为屈，乃就番人学书语，唐太宗贞观三年，私发长安，途中历经险阻，历时五年，始抵中天竺，于那烂陀寺，依戒贤论师学 <瑜伽师地论> 及十支论奥义五年。复从胜军居士学 <唯识抉择论> 及 <庄严经论> 等论典二年。
    奘师于贞观十九年回国，由天竺携回梵典六百五十余部，归国后广译经论，先后译出七十五部，一千三百余卷，其中关于法相唯识一系的，有下列各种：
    一、 <解深密经> ： 五卷。
    二、 <瑜伽师地论> ： 弥勒菩萨造，一百卷。
    三、 <辩中边论> ： 弥勒菩萨造，三卷。
    四、 <摄大乘论> ： 无著菩萨造，三卷。
    五、 <显扬圣教论> ： 无著菩萨造，二十卷。
    六、 <大乘五蕴论> ： 世亲菩萨造，一卷。
    七、 <大乘百法明门论> ： 世亲菩萨造，一卷。
    八、 <瑜伽师地论释> ： 世亲菩萨造，一卷。
    九、 <观所缘缘论> ： 陈那论师造，一卷。
    十、 <唯识二十论> ： 世亲菩萨造，一卷。
    十一、 <唯识三十论> ： 世亲菩萨造，一卷。
    十二、 <成唯识论> ： 以十大论师之释论百卷，揉集为识论十卷。
    由于玄奘广译法相唯识一系经论，窥基复弘扬之，开创了我国的唯识宗。除上述经论外，他也译出了小乘说一切有部的论典，如 <阿毗达磨发智论> 及六足论， <大毗婆娑论> 、 <俱舍论> 等。玄奘于唐高宗麟德元年示寂，享年六十五岁。
    玄奘大师的入室弟子窥基，俗姓尉迟，字洪道，是元魏尉迟部后裔，为唐初勋臣尉迟恭犹子，唐代京兆长安人。出生于唐太宗贞观六年，禀性聪慧，体貌魁伟，年十七岁奉敕出家，为玄奘弟子，依玄奘学佛教经论及天竺语文。二十五岁参与译经，唐高宗显庆四年，玄奘译 <成唯识论> ，原拟将十家释论各别全译，并命窥基与神[日＋方]、嘉尚、普光四人，分别担任检文、笔受、纂义工作，数日之后，窥基请求退出，奘师固问其故，基言：[群圣制作，各驰誉于五天，虽文具传于贝叶，而义不备于一本，情见各异，禀者无依，请错综群言，以为一本…’。
    奘师乃礼遣三贤，窥基独任笔受，译出 <成唯识论> 十卷。其后奘师又为窥基阐说陈那之 <因明正理门论> ，及 <瑜伽师地论> 等，故窥基通达因明之学。窥基著述丰富，有[百部疏主’ 之称，其主要且与唯识有关者如有 <瑜伽师地论略纂> 十六卷， <瑜伽论劫章颂> ， <成唯识论述记> 二十卷， <成唯识论掌中枢要> 四卷， <唯识二十论述记> 三卷， <大乘百法明门论解> 一卷， <成唯识论别钞> 四卷， <辩中边论述记> 三卷， <杂集论述记> 十卷， <因明入正理论疏> 六卷， <大乘法苑义林章> 十四卷。
    由玄奘、窥基两代的弘扬，建立了我国大乘八宗之一的‘唯识宗’。唯识宗亦名法相宗、普为乘教宗、应理圆实宗、慈恩宗。由决判诸法体性相状故，名法相宗。由明万法唯识的妙理故，名唯识宗。由普为发趣一切乘者故，名普为乘教宗。由所谈的义理，均为圆满真实故，名应理圆实宗。由大唐慈恩寺玄奘、窥基二师所弘传故，名慈恩宗。
    窥基的弟子慧沼，淄州淄川 (今山东淄川) 人，生于唐高宗永徽二年，十五岁出家，曾亲炙玄奘法席，后转依窥基学唯识，深入堂奥。因为他住在淄川大云寺，故人称淄川大师。窥基示寂后，圆测著 <成唯识识疏> ，与窥基见解不同，慧沼撰 <成唯识论了义灯>破斥圆测之说，以显法相正义。他曾先后参加过义净、菩提流志的译场，担任正义，多所刊正。他的著作除 <成唯识论了义灯> 外，尚著有 <能显中边慧日论> 四卷、 <因明入正理论义纂要> 、 <金刚般若经疏> 、 <金光明最胜王经疏> 、 <劝发菩提心集> 等。
    智周是慧沼的弟子，濮阳人，唐高宗总章元年生。出家后初学天台，后师慧沼，著有<成唯识论演秘> 、 <因明入正理论疏前记> 三卷、 <因明入正理论后记> 三卷，及 <大乘入道次第章> 等十种。他的 <成唯识论演秘> ，与窥基的 <枢要> 及慧沼的 <了义灯>，合称为 <唯识三疏> 。智周的弟子如理，著有 <成唯识论义演> 及 <成唯识论演秘释>二书，唯内容则流于琐细。
    唯识宗建立后，宗风颇盛，百余年后，唐武宗‘会昌法难’兴起，此宗经疏大部焚毁，以后就日益式微了。
    三、 唯识宗所依经论
    唯识宗所依的经论，有所谓‘六经十一论’，及‘一本十支’之说。六经是： <大方广佛华严经> 、 <解深密经> 、 <如来出现功德庄严经> ：此经 中土未译。 <阿毗达磨经> ： 此经中土未译。 <楞伽经> 、 <厚严经> ： 此经中土未译。
    十一论是： <瑜伽师地论> 、 <显扬圣教论> 、 <大乘庄严经论> 、 <集量论> 、 <摄大乘论> 、 <十地经论> 、 <分别瑜伽论> 、 <辨中边论> 、 <二十唯识论> 、 <观所缘缘论> 、 <阿毗达磨杂集论> 。
    以上六经十一论，在六经中，以 <解深密经> 为本经； 在十一论中，以 <瑜伽师地论> 为本论。
    一本十支，又称‘十支论’，是以 <瑜伽师地论> 为本论，以百法、五蕴等十种论典为支论的名称，这是研究唯识学必读的论典，十支论的名称如下：
    一、 略陈名数支： <百法明门论> ，这是略录 <瑜伽师地论、 本地分> 中名数，以一切法无我为宗。
    二、 粗释体义支： <大乘五蕴论> ，这是摄 <瑜伽师地论、 本地分> 中境事，而以无我唯法为宗。
    三、 总苞众义支： <显扬圣教论> ，这是错综 <瑜伽师地论> 十七地要义，而以明教为宗。
    四、 广苞大义支： <摄大乘论> ，这是总括瑜伽、深密法门，诠释 <阿毗达磨集论>、 <摄大乘论> 宗要，以简小入地为宗。
    五、 分别名数支： <阿毗达磨杂集论> ，这是总括 <瑜伽师地论> 一切法门，集 <阿毗达磨经> 所有宗要，以蕴、处、界三科为宗。
    六、 离僻彰中支： <辨中边论> ，这是叙七品以成瑜伽法相，以中道为宗。
    七、 摧破邪山支： <二十唯识论> ，这是释七难以成瑜伽唯识，以唯识无境为宗。
    八、 高建法幢支： <三十唯识论>， 这是广诠瑜伽境体，以识外无别实有为宗。
    九、 庄严体义支： <大乘庄严论> ，这是总括瑜伽菩萨一地法门，以庄严大乘为宗。
    十、 摄散归观支： <分别瑜伽论> ，此论中土未译。


第二讲 三十颂科判大纲

    第二讲 三十颂科判大纲
    <唯识三十颂> ，是建立唯识宗的基本论典，古今注释三十颂的书不胜计数。在我国、以 <成唯识论> 最为重要。但 <识论> 十卷雄文，一方面是字字珠几，是发掘唯识要义的宝藏；另一方面它行文有如枝上岔枝，叶旁长叶。所谓 ‘文如钩锁，义若连环。’使人初读之下，如随入五里雾中，不知所来，亦不知所往。如何读通 ，成唯识论。 呢？唯有熟读本颂，以颂文对照识论，便有脉络可寻了。现在科分三十颂如下。
    一、 三十颂科分
    三十颂，乃世亲菩萨所造，以五言四句为一颂，全文三十颂，计六百字。在一般经论中，多以三科分判，即序分、正宗分、流通分。而本颂全文皆是正宗分，并无序分和流通分。在讲解三十颂之前，先要熟读三十颂全文，全文即是：

由假说我法 有种种相转 彼依识所变 此能变唯三

谓异熟思量 及了别境识 初阿赖耶识 异熟一切种

不可知执受 处了常与触 作意受想思 相应唯舍受

是无覆无记 触等亦如是 恒转如瀑流 阿罗汉位舍

次第二能变 是识名末那 依彼转缘彼 思量为性相

四烦恼常俱 谓我痴我见 并我慢我爱 及余触等俱

有覆无记摄 随所生所系 阿罗汉灭定 出世道无有

次第三能变 差别有六种 了境为性相 善不善俱非

此心所遍行 别境善烦恼 随烦恼不定 皆三受相应

初遍行触等 次别境谓欲 胜解念定慧 所缘事不同

善谓信惭愧 无贪等三根 勤安不放逸 行舍及不害

烦恼谓贪嗔 痴慢疑恶见 随烦恼谓忿 恨覆恼嫉悭

诳谄与害憍 无惭及无愧 掉举与昏沉 不信并懈怠

放逸及失念 散乱不正知 不定谓悔眠 寻伺二各二

依止根本识 五识随缘现 或俱或不俱 如波涛依水

意识常现起 除生无想天 及无心二定 睡眠与闷绝

是诸识转变 分别所分别 由此彼皆无 故一切唯识

由一切种识 如是如是变 以展转力故 彼彼分别生

由诸业习气 二取习气俱 前异熟既尽 复生余异熟

由彼彼遍计 遍计种种物 此遍计所执 自性无所有

依他起自性 分别缘所生 圆成实于彼 常远离前性

故此与依他 非异非不异 如无常等性 非不见此彼

即依此三性 立彼三无性 故佛密意说 一切法无性

初即相无性 次无自然性 后由远离前 所执我法性

此诸法胜义 亦即是真如 常如其性故 即唯识实性

乃至未起识 求住唯识性 于二取随眠 犹未能伏灭

现前立少物 谓是唯识性 以有所得故 非实住唯识

若时于所缘 智都无所得 尔时住唯识 离二取相故

无得不思议 是出世间智 舍二粗重故 便证得转依

此即无漏界 不思议善常 安乐解脱身 大牟尼名法

    三十颂颂文，如上所录。本颂内容，以一切法唯识所现。即以识有非空，境无非有为宗。先破小乘外道，继明唯识之理。以文科判 有三种判别方法：
    一、 以相、性、位三分科判： 即一者明唯识相； 二者明唯识性； 三者明唯位。这在三十首颂文中，由第一至第二十四颂是明唯识相，第二十五颂是明唯识性； 第二十六至第三十是明唯识位。
    二、 以初、中、后三分科判： 在三十首颂文中，初一颂半为初分，次二十三颂半为中分，后五颂为后分。
    三、 以境、行、果三分科判： 初二十五颂是明‘唯识境’，次四颂是明‘唯识行’，最后一颂是明‘唯识果’。
    现依第一种科判，分别说明三分如下：
    一、 明唯识相： 即依他起性之法。依他起法，仗因托缘生起，唯识所现。凡夫外道，不知唯识无境之理，执心外有别实境，因此生起我执法执。故论主最初以种种方便，广明唯识相状、即是依他起之诸法，以破除其我执法执。
    二、 明唯识性： 此即圆成实性，修唯识行者，虽知万法皆此心虚妄显现，而犹未能了达真性，是以次明唯识实性、即圆成实性，以此显示真如常住一味。
    三、 明唯识位： 三十颂的前二十五颂，说明唯识相、性，依他圆成，无非是说明依他如幻，使修唯识行者，断妄染执障，证到圆成真理，而成三身万德的佛果。然佛果功德，殊妙无边，非少修行可能证圆，必须历经资粮、加行、通达、修习、究竟五位，十住、十行、十回向、十地、妙觉四十一阶，历经三大阿僧祗劫，方能至三身万德之佛地，故次第三，明唯识位。
    二、 三十颂科分表
    现依相、性、境三科分，列表示明如下：
    唯识三十颂分科表：
    一、 明唯识相：前二十四须颂。
    甲、 略标：1、释难破执。2、标宗归识。3、彰能变体。
    乙、 广释：
    1、明能变相：异熟能变、 思量能变、 了境能变、
    2、正辨唯识。
    3、通释妨难：释违理难、 释违教难、
    二、 明唯识性：第二十五颂。
    三、 明唯识位：第二十六颂至第三十颂。
    依据上列的分科，于此拟定出讲解的顺序及内容，即是：
    一、 释难破执：由假说我法，有种种相转。
    二、 标宗归识：彼依识所变。
    三、 彰能变体：此能变唯三，谓异熟、思量，及了别境识。
    四、 异熟能变：
    1、三相门：初阿赖耶识，异熟一切种。
    2、所缘行相门：不可知；执受、处、了。
    3、心所相应门：常与触、作意、受、想、思相应。
    4、五受相应门：(相应) 唯舍受。
    5、三性分别门：是无覆无记。
    6、心所例同门：触等亦如是。
    7、因果譬喻门：恒转如瀑流。
    8、伏断位次门：阿罗汉位舍。
    五、 思量能变：
    1、举体出名门：次第二能变，是识名末那。
    2、所依门：依彼转。
    3、所缘门：缘彼。
    4、体性行相门：思量为性相。
    5、心所相应门：四烦恼常俱，谓我痴我见，并我慢我爱，及余触等俱。
    6、三性分别门：有覆无记摄。
    7、界系分别门：随所生所系。
    8、起灭分位门：阿罗汉灭定，出世道无有。
    六、 了境能变：
    1、能变差别门：次第三能变，差别有六种。
    2、自性行相门：了境为性相。
    3、三性分别门：善不善俱非。
    4、相应俱受门：
    甲、 列名六位：此心所遍行，别境善烦恼，随烦恼不定。
    乙、 受俱分别：皆三受相应。
    丙、 重明五位：
    遍行：初遍行触等。
    别境： 次别境谓欲，胜解念定慧，所缘事不同。
    善：善谓信惭愧，无贪等三根，勤安不放逸，行舍及不害。
    烦恼：烦恼为贪嗔，痴慢疑恶见。
    随烦恼：随烦恼为忿，恨覆恼嫉懂，诳谄与害娇，无惭及无愧、掉举与昏沉 不信并懈怠，放逸及失念，散乱不正知、不定：不定谓悔、眠，寻、伺二各二。
    5、所依门：依止根本识。
    6、俱不俱转门：五识随缘现，或俱或不俱，如涛波依水。
    7、起灭分位门：意识常现起，除生无想天，及无心二定，睡眠与闷绝。
    七、 正辨唯识：是诸识转变，分别所分别，由此彼皆无，故一切唯识。
    八、 释违理难──
    1、心法生起缘由：由一切种识，如是如是变，以辗转力故，彼彼分别生。
    2、有情相续缘由：由诸业习气，二取习气俱，前异熟既尽，复生余异熟。
    九、 释违教难：
    1、三种自性：
    正辨：遍计所执性：由彼彼遍计，遍计种种物，此遍计所执，自性无所有。
    依他起性：依他起自性， 分别缘所生。
    圆成实性：圆成实于彼，常远离前性。
    明不一不异：故此与依他，非异非不异，如无常等性。
    明依圆前后：非不见此彼。
    2、三种无性：
    总说：即依此三性 立彼三无性 故佛密意说 一切法无性
    别明：相无性：初即相无性。
    生无性：次无自然性。
    胜义无性：后由远离前，所执我法性。
    十、 明唯识性：此诸法胜义，亦即是真如，常如其性故，即唯识实性。
    十一、 明唯识位：
    1、资粮位：乃至未起识，求住唯识性，于二取随眠，犹未能伏灭。
    2、加行位：现前立少物，谓是唯识性，以有所得故，非实住唯识。
    3、通达位：若时于所缘，智都无所得，尔时住唯识，离二取相故。
    4、修习位：无得不思议，是出世间智，舍二粗重故，便证得转依。
    5、究竟位：此即无漏界，不思议善常，安乐解脱身，大牟尼名法。
    三、 与三十颂相关的论典
    讲完三十科判大纲，再介绍几本与三十颂相关的论典。首先要介绍的是注释三十颂的<成唯识论> ，凡十卷，护法等十大论师各造释论，唐代玄奘三藏奉诏译，翻经沙门窥基笔受，这是学习唯识学必读的重要论书。
    世亲晚年造 <唯识三十颂> ，本颂造出，未造释文而入寂，未几十大论师继起，各造释论，斯时法海波澜，至为壮阔。唐代玄奘三藏由印度回国，携回十家释论百卷，奘师译此论时，本主张十家释论各别全译，后以弟子窥基之请，糅集十家之义成为一部，其中异义纷纭之处，悉折中于护法之说，故 <成唯识论> 十卷，虽说是糅集十师之作，而实以护法一家为宗，名为传译，不啻新造。
    基师亦尝述其传译参糅之绩云： 十家别译之初，神[日＋方]、嘉尚、普光、窥基四人同受师命，共同翻译。数日之后，基请退出，奘师固问其故，基对曰： [群圣制作，各驰誉于五天，虽文具传于贝叶，而义不备于一本，情见各异，禀者无依。请错综群言，以为一本，楷定真谬，权衡盛则。’ 久之奘师乃许，故得此论行世。
    其次介绍 <成唯识论述记> ，述记十卷 (或二十卷，亦有六十卷本) ，是唐代大成法相唯识宗的窥基大师撰述，这是注解 <成唯识论> 的著作。本书内容分为五门，即：
    一、 教时机，分为说教时会与教所被机两种。
    二、 论宗体： 以唯识为宗而谓其体有四重。
    三、 藏乘所摄： 谓 <成唯识论> 为一乘之所摄，并为三藏中之菩萨乘所摄。
    四、 说教年主： 以慧恺之 <俱舍论> 序论说世亲与十大论师之年代。
    五、 本文判释： 即就本文述释其义。
    述记一书，是窥基随奘师笔受‘识论’时，以所闻之于师者，随时笔劄，识论完成，更为此记。凡识论中不尽之义，及己意当发抒者，皆于此记中见之。但这相当于随堂笔记，素称难读。传说清末状元夏同和，初读 ‘识论’，谓有如月下看花，再读述记，如堕如五里雾中。故学者若不专业研究，莫不半途而废，不能竟卷也。
    本书元代即告失传，清代末年杨仁山居士得之于日本，由金陵刻经处刻印行世。
    <成唯识论掌中枢要> 四卷，也是窥基撰述，略称 <成唯识论枢要> ，系唯识三疏之一。本书初叙 <成唯识论> 之成立、传入、揉译等因缘，次释本论之题目及所被之根机。再次释论文，于识论述记之未详尽处，更详加解释。其中对于唯识三十颂科判、五种姓、三类境等问题，均广泛加以解释。收入大正藏四十三册。注释书有唐外智周撰 <成唯识论枢要记> 二卷，唐代憬兴之 <成唯识论枢要记> 二卷。
    <成唯识论了义灯> 七卷 (或十三卷) ，是窥基的弟子慧沼撰述，略称 <唯识了义灯> ，唯识三疏之一。本书系显慈恩宗正义，而破斥有关解释 <成唯识论> 中的异说者。事实上是祖述窥基之说，而责难圆测、圆义、普光、慧观等之异说。此书颇有门户之见，且素称不易解读。本书收入大正藏第四十三册。
    <成唯识论演秘> 七卷 (或十四卷) ，是慧沼的弟子智周所撰，略称 <识论演秘> ，是注解 <成唯识论> 及 <成唯识论述记> 之书，亦为唯识三疏之一。现收入大正藏第四十三册。所谓‘唯识三疏’，是注释 <成唯识论> 、及 <成唯识论述记> 的三种注疏，即窥基撰的 <成唯识论掌中枢要> ，慧沼撰的 <成唯识论了义灯> ，及智周撰的 <成唯识论演秘> 。而注释‘述记’的书，有唐代道邑之 <成唯识论义蕴> 五卷，如理之 <成唯识论疏义演> 二十六卷，灵泰之 <成唯识论疏钞> 十八卷等。


第三讲 唯识学上的几个基本概念

    第三讲 唯识学上的几个基本概念
    三十颂颂文、科分，已如第二讲所述。在讲解颂文之前，有几个唯识学上的基本概念，先要认识清楚。不然，就无从讲起。首先要探讨的，就是叫什么叫‘识’，什么叫做唯识。说到识和唯识，又涉及现行、种子、薰习等，都要先有一个概念，兹分别诠释如下：
    一、 识即是心
    唯识学立论，以为宇宙间一切现象──即所谓法相，唯‘识’所变。欲了解识变，必先了解什么是‘识’。 <大乘法苑义林章> 曰： [识者心也，由心集起彩画为主之根本，故经曰唯心； 分别了达之根本，故论曰唯识。或经义通因果，总言唯心，论说唯在因，但称唯识。识了别义，在因位中识用强故，说识为唯，其义无二。二十论曰： 心意识了，名之差别。]
    由上文可知，识即是心。但是，心又是什么呢？ 此心，非我人胸腔中的肉团心，亦非我人脑壳中的大脑，而是一种功能──能力与功用。‘功能’二字，系无著菩萨于 <摄大乘论> 中所建立，而由世亲、护法等充实之，立为现行界的原因。于此可知识即功能，功能即识。依于此说探讨识之意义，可由下列三义以注释之：
    一、 识非有质碍性之物，而是一种功能： 识有四个名称，曰心、意、识、了。但此四者，都是指一种无质碍性的功能。唯识学解释谓： 积集义是心，思量义是意，了别义是识 (如张目见时钟，是名曰了，从而分别时刻，是名曰别。) 八识各有此四种功能，各得通称为心、意、识、了，但以功能胜显说，则第八识集诸法种子，生起诸法，名之为心。第七识恒审思量，执著自我，名之为意。前六识了别别境、及粗显之境，名之为识。以上数者，只是一种能变的法性，是离开名称言说的境界。而唯识之教，是 ‘即用显体’，说到其体，名之为‘如如’，说到其用，名之为‘能变’。能则势力生起，运转不居； 变则生灭如幻，非实有性。唯识立论，谓离识之外，无别有法。而所谓识，亦不过一能变的功能而已。
    二、 识之功能，非局限于肉身，而交遍于法界： 识与大脑之不同者，不仅大脑有质碍，识无质碍。尤其重要者，识的功能交遍法界，而大脑的作用仅局限于根身 (如感觉神经与运动神经，其作用仅局限于我人的肉身。) 什么叫做交遍法界？ 譬如我们登山临水，所见所闻，至远至广。举凡所见所闻，皆是我人眼识、耳识、意识 (此处指五俱意识) 之所在。试问此所见所闻，是在我人大脑之内，抑在大脑之外？ 大脑不过方寸之地，与所见所闻比较，有如爪上尘与大地土，其不是大脑所能范围者，至为明了。因此，识的功用在大脑之外，又不可以十百千万里计。
    是故其量必同虚空而无极，因此称识的功用交遍法界 (此系就种子而言，至于识的现行，则随量之大小而有局限。)
    三、 识为种子之现行，而种子起现行，必待缘俱： 识为一种功能，此功能未起现行之前，不称识而称种子； 种子起现行时，不称种子而称识。所以种子是潜在的功能，识是此潜在功能的发生作用 (即现行) 。而识之起现行，必待四缘俱备。四缘者，因缘、等无间缘、所缘缘、增上缘。
    上文称：‘识为种子之现行’，种子又是什么呢？种子仍然是功能。如前所述，‘功能’一词初见于无著菩萨的 <摄大乘论> ，世亲、护法诸论师继述之，谓一切功能，潜藏于现象界之后，而为现象作根□，建立本识以统摄之。功能是什么？ 是‘非物质而产生物质之力用’者，事实上即是物理学上之‘能’。‘能’为心物活动的潜力，亦为心物之原料，为产生有为法之果的功用势力。 <中论颂> 曰： [诸法不自生，亦不从他生，不共不无因。 ’<阿毗达磨杂集论> 释此颂曰： [自种有故不从他，待众缘故非自作，无作用故非共生，有功能故非无因。’ 是以诸法之因即是功能，而阿赖耶识所摄持的万法种子，种子生现行，现行熏种子，一切变现，皆是功能之力。所以所谓功能，即是种子异名。
    种子一词，法相宗所立，为唯识学上极重要之术语，指在阿赖耶识中，生起一切有漏无漏有为法的功能。 <成唯识论> 卷二曰： [此中何法名为种子，谓本识 (阿赖耶识) 中，亲自生果功能差别。此与本识及所生果，不一不异。体用因果，理应尔故。]
    识为一种功能，此功能未发生作用、於潜在状态时，不称识而称种子； 其发生作用──即起现行时，不称种子而称识。所谓现行，即是能生起色心各别不同现象的作用。种种不同色心现象，都自有他的亲因，此亲因即 <识论> 所称的功能。名为种子者，以其有生起诸法的作用，犹如草木种子，能生芽茎也。
    原来所谓宇宙诸法──即世间种种精神的、物质的现象，皆是阿赖耶识中种子变现而起。阿赖耶识摄持诸法种子，有生起色心诸法的力用，此力用即称为种子。沉隐的种子 (潜伏的功能) 生起色心诸法时，称为现行。所以种子、阿赖耶识、和它所生起的现行果法，这三者是体用因果的关系，是‘不一不异’。因为本识是体，种子是用，体用之间，体是体，用是用，所以非一； 但体是此用之体，用是此体之用，体不离用，用不离体，所以非异。再者，种子与现行之间，种子是因，现行是果，因是因，果是果，所以非一； 但因是此果之因，果是此因之果，所以非异。这体用因果的道理， ‘理应故尔’。于此，进一步诠释种子如下。
    二、 种子
    种子即是功能，此功能未发生作用、於潜隐状态时，称为种子，要具备一定的条件，在 <成唯识论> 卷二中，以六种条件来显示种子的体性，这叫做‘种子六义’。六义是刹那灭，果俱有，恒随转，性决定，待众缘，引自果。兹分述如下：
    一、 刹那灭： 所谓种子，只是一种‘能力’，即所谓功能。它无质量形色，不能以色声香味触而测知，但在发生作用时 (即生起现行时) ，却有力用。而当其起现行时，才生无间即灭。所谓 ‘无间即灭’，就是它生时即是灭时，中间没有‘住]的阶段。如果有生有住，就成为常法，即不是刹那灭了。刹那灭者，简别对于不生灭、或不转变者，而执为一切诸法能生的因。
    二、 果俱有： 以种子为因，生起现行，刹那即灭，但并不是灭后始成果，而是刹那生灭之际，‘正转变位，能取与果。’正转变位，有别于过去或未来的转变位； 与果，是以种子现行为因，所取之果，名曰与果。也就是即因生现果，因果同时，相依俱有。此处所称的果，事实上就是新熏的种子。果俱有，简除前后相生、以及相离的他身而生等。因为异时异处，便不能和合，便不是种子了。
    三、 恒随转： 种子起现行，刹那即灭，但不是灭已即断，而是前灭后生，刹那刹那，相似随转。即种子、现行与果同时俱有，才生即灭。但在灭了之后，现行成为新熏种子，再起现行，这叫做 ‘种子自类相生’。换句话说，种子、现行、新熏种子，三者一类相续转起，没有间断转易。古德有偈曰： [种子生现行，现行熏种子，三法 (种子、现行、熏习) 辗转，因果同时。’即指此恒随转而言。恒随转，简除七转识的有间断转易，不能维持生果的功能。 (虽然第七识也恒时相续，但在十地中法空智现前，也是有转变的。)
    四、 性决定： 此明种子随它本身能熏的善恶无记之性，生起现行时，也决定其现时的善恶无记之性。亦即是善种生起善的现行，恶种生起恶的现行，此一因果法则不能混乱。这是简别于有部小乘、如善恶因生无记果，或无记因善因生恶果等，明异性不能为亲因。
    五、 待众缘： 种子生现行，必待众缘和合。种子的功能虽是任运而转，但法不孤起，有了种子的因缘，尚须待增上等诸缘的和合，方能起现行生果。这是简除外道等自然因恒能生果，或小乘有部的缘体恒有 (倘缘体恒有，亦应恒时生果，如此于理有违。) 同时显示所待的缘不是恒有，故一切种子之果，不是恒时显生。
    六、 引自果： 种子不是一因生众果，而是各各引生自果。即是色法种子仍生色法之果，心法种子仍生心法之果，此一法则不能混乱。这是简别于外道的一因可生众果，及小乘有部主张色心互为因果。
    种子即是功能，但种子 (即功能) 由何而来呢？照唯识学上说，种子有二类，一者是本有种子，二者是新熏种子，此是指种子的来源或原因而说的。本有种子，谓阿赖耶识中，本来含藏有有漏无漏一切百有为法的种子； 新熏种子，谓阿赖耶识中所藏之种子，非为本来所固有，系由现行之前七识、随所应而色心万差之种种熏习，而成为有生果功能之新种子。于此，有护月、难陀、护法三师不同的主张。兹分述如下：
    一、 护月论师主张： 他主张本有说，他以为一切种子，是阿赖耶识的功能作用，本来俱有，并不是由新熏发生； 熏习不过能增长养成本来固有的种子，他引以下经论来证明他的理论： <无尽意经> ： [一切有情，无始时来，有种种界，如恶叉聚，法尔而有。] (界是因义，就是种子差别的异名。) <阿毗达磨经> ： [无始时来界，一切法等依。]
    二、 难陀论师主张： 他主张新熏说，他以为一切种子，都是由现行的熏习而发生的。因为能熏与所熏，都是无始以来俱有，所以从无始来就有熏生的种子。他以为、所谓种子者，必藉熏习而发生。再者种子是习气的异名，所谓习气，就是现行所熏习的气分，由之可知种子是由新熏而来。他引以下的经论来证明他的理论： <多界经> ： [诸有情心，染净诸法，所熏习故，无量种子之所积集。] <摄大乘论> ： [内种定有熏习，外种或有或无。]
    三、 护法论师的主张： 护法论师采取折衷之说，他以为诸法种子，本有两类，即本有种子和新熏种子。这两类种子，都是无始以来就有的。阿赖耶识中，具有法尔生起一切诸法的差别功能，这就是本有种子，此又名本性住种； 同时在无始以来，由现行的势力，留贮在阿赖耶识中而有生果的作用，这就是新熏种子，此又名习所成种。此本新二种，相待而能生起诸法的现行。
    后世唯识学者，都以护法的观点为正义。故种子依其生起来说，就分为本有种子和新熏种子。本有种子，又名本性住种，这是先天的、本能俱有的。新熏种子，又名习所成种，这是后天的、学习而来的。
    依种子的性质说，又分为有漏种子和无漏种子。一者有漏种子，这是能产生种种现象的种子，亦即三界六趣受生死的种子。此中又有名言种子、我执种子、有支种子之分。二是无漏种子，这是能生菩提之因的种子，亦即入见道位乃至阿罗汉、佛果位的出世种子。此中又有生空种子、法空种子、二空种子之分。 <成唯识论>二曰：
    [诸种子者，谓异熟识所持一切有漏法种，此识性摄，故是所缘。无漏种子虽然依附此识，而非此识性摄，故非所缘。]
    这是说，一切有漏种子为为第八阿赖耶识之识体所摄持，且为第八识见分所缘，故称[故是所缘’； 而无漏种子虽然也依附于阿赖耶识，但并非阿赖耶识之识性所摄，故不是此识所缘。无漏种子是能生菩提之因的种子，此有三种，一者生空无漏种子，即我空无漏，此属见道位无漏种子。二者法空无漏，属修道位无漏种子。三者二空 (我空、法空) 无漏种子，此为无学道无漏种子。
    无漏种子依于异熟识之自体分，而非异熟识性所摄持。以无漏种子，其性唯善，不是无记性，故不与异熟识之体性相顺，体性既不相顺，故此无漏种子与异熟识体性不可相即。无漏种子依于异熟识之自体分，以非异熟识所摄持，亦不为异熟识之见分所缘。
    有漏种子即生起诸种现象，三界六趣受生死的种子。此有三种，一者名言种子，二者我执种子，三者有支种子。种子又名习气，即是现行熏习的气分。 <瑜伽师地论> 五十二月： [云何略说安立种子？ 谓于阿赖耶识中，一切诸法遍计自性妄执习气，是名安立种子。]
    在前文之中，屡屡说到‘现行’二字。现行又作何解释，原来阿赖耶识有生一切法之功能，此能生之因，谓之种子，自此种子生起色心诸法，谓之现行。能生的种子是因，所生的现行是果。当种子生起现行之际，现行有强盛的势用，刹那间熏习起现行的种子、成为新种子，这就称为 ‘种子起现行，现行熏种子’。在种子起现行时，种子是因，现行是果。而现行熏种子时，现行是因，受熏的新种子是果。这三者是‘刹那生灭，与果俱有。’此 ‘种生现’的因果之同时，也是‘现生种’的因果。有如烛柱生炎 (种生现) 之时，同时也正是炎烧柱 (现熏种) 之时。
    于此，又出现‘熏习’二字。所谓薰习，是我人身、口所表现的善恶行为 (身行、语行)，或意识所生起的善恶思想 (意行)，其‘气分’留于阿赖耶识中，如香之熏衣，即谓之熏习。而我人身口意三者所表现之行为，就叫做现行。换句话说，第八阿赖耶识，能将经验的痕迹保下来，这就是气分或种子。而经验 (身口意三者的行为) 的痕迹，能影响一个人未来的性格及行为，这就是熏习。一个人习于为善，这善行是一种熏习，一个人惯于为恶，这恶行也是一种熏习。熏习不是刻意造成的，而是不知不觉任运进行。如人行雾中，他无意使衣服受湿，也不觉得衣服受湿，而事实上他的衣服己布满了湿气。 <大乘起信论> 曰： [熏习义者，如世间衣服实无于香，若人以香熏习故，则有香气。]
    种子生现行，种子是能生，现行是所生。能生的，是第八识中能生果法作用的种子，所生的是七转识，所以第八识为因，七转识是果，这是‘种子生现行的因果’。现行熏种子，现行是能熏，种子是所熏，能熏的是七转识的现行法，所熏的是第八识种子，于此，七转识是因，第八识是果，这是 ‘现行熏种子的因果’。阿赖耶的所藏之义，也于此可见。 <阿毗达磨经> 曰： [诸法于藏识，识于法亦尔，更互为果性，亦常为因性。]
    最后，我们再理清一个观念，就是‘唯识’一词。什么叫唯识呢？唯识二字，梵语Vijnapti-matrata、 音译毗若底摩坦喇多。梵语倒置，称为‘识唯’，汉土译为 ‘唯识]。识者心之别名，所谓唯识，即简去心外诸法，择取识心。这是遮简迷情、外界有实我实法的存在，表显内界识心的真性法相。换句话说，唯识宗立论，以我人心识之外的万有现象，皆是由我人心识自体所变现而来，亦即由第八阿赖耶识中之种子所变生，故除心识之外，万有现象皆非实在。因此说 ‘唯识无境’； 或自万有现象自识所变一面来说，称为‘唯识所变’。
    在 <百法明门论> 中，有‘五法事理唯识’一词，束百法以五位，即心王法、心所有法、色法、心不相应行法、无为法。此五位法，前四位是事，后一位是理，如下表所示：

     ┌─心王──────识之自相┐
     ├─心所──────与识相应┤ 五法事理唯识─┼─色───────识之所变┼─不离识─万法唯识
     ├─不相应行────识之分位┤
     └─无为────以上四法实性┘
    关于识变，有因能变与果能变之分，因能变者，即种子生起八识之变； 果能变者，各各识体上生起相、见二分，而有万法之生起。此留在后面再讲。


第四讲 识变──八识三能变

    第四讲 识变──八识三能变
    三十颂讲座，今天开始讲到正文。今天讲三十颂首颂：‘由假说我法，由种种相转，彼依识所变，此能变唯三。’首颂中有三个主题，即一、 释难破执──为问难者解释唯识之理，以破其执著；二、 标宗归识──标出万法唯识所变的宗旨；三、 彰能变体──说明能变之识唯有三种。现在依次讲解如下。
    一、 释难破执──由假说我法，有种种相转。
    唯识三十颂的主旨，在于说明心识之外，没有固定的实我，也没有固定的实法。但是在这世界上，明明有圆颅方趾的‘我相’，和芸芸众生；也明明有山河大地，房舍器物的[法相’，一定说没有我、法，如何能使世人信服呢？于是世亲菩萨，假借外人质疑之词，来说明万法唯识的妙理。外人质问曰：
    [如果照你们唯识家所说， ‘万法唯识，识外无法’，为什么世人皆说有我有法呢？纵然世人迷昧，说的不对，可是在你们觉悟的圣教中，不是也说菩萨、声闻等的我，和四谛、五蕴等的法呢？]
    外人这一问，问的非常尖锐。如果说有我相法相，唯识义就不能成立；如果说万法唯识，就不该说我相法相。准此以论，唯识家的言论犯了两种相违的过失：一者，世人皆说有我有法，你们唯识家说无我无法，就犯了‘世间相违过’；二者，你们唯识家说万法唯识，而圣教中又说我相法相，就犯了‘圣教相违过’。唯识家怎么回答呢？他用两句话回答：‘由假说我法，有种种相转。]
    于此，我们先来探讨什么叫做我，什么叫做法。‘我’，梵名 Atman、 音译阿特曼，原意为‘呼吸’，引伸为生命、自己、自我、自性等。这是印度婆罗门教，自四吠陀时代以来使用的名词。此我有四义，即一者恒常存在 (常)； 二者独一个体──不是集合体 (一)； 三者中心之所有主 (主)； 支配一切 (宰) ，所以称我者，有常、一、主宰之义。梵书时代，婆罗门教以 ‘梵’为宇宙最高原理，以我为为个人生命原理，有‘梵我一如]之说，此即佛教经典中所破的‘神我’。本来，‘我’只是五蕴诸法，因缘和合的集合体，何尝有一个恒、一、主宰的实我呢。
    法者， ‘轨持’义，轨者‘轨生物解’，持者‘任持自性’。<成唯识论> 卷一曰 ：[法谓轨持，轨者轨范可生物解； 持谓任持，不舍自相。’ 简单的说，我人的见闻觉知作用，对于任何一事一物，都会于那事物上起一种见解，即是轨生物解；世间任何事物，皆有它特别的体性，我们对于它所起的见解，无论是对是错，而它本身的体性，任运摄持，而不失不变，即是任持自性。以上所说的，是狭义的法。至于广义的法，是通于一切的意思。举凡世间一切，有形的、无形的，真实的、虚妄的，精神的、物质的，事物其物的、道理其理的，林林总总，统称之曰 ‘法’，故佛典上常用‘一切法’、‘诸法’、‘万法’等辞汇来表达宇宙万有。
    至于 ‘假’，是假托义，非真实义。成唯识论述记上，以‘两重二假’来解释这个假字。即一重是无体随情假，有体施设假；一重是以无依有假，以义依体假。分述如下：
    一、 无体随情假：宇宙万有，都是因缘和合而生起存在，本来没有实我实法的自体。不过在世人迷情的见解上，认为有实在的我，实我的法。其实这是我人执见上迷谬的见解，不是诸法的本相。不过佛陀为了说法的方便，随顺世情，假借我法两字，来显示所说的法体，这叫做无体随情假。
    二、 有体施设假：圣教所说的佛、菩萨、声闻──我，五蕴、十二处、十八界──法，虽然一一都有它的法体，但法体是没有名字的，不过假为施设，安立一个名字。而名字并不能代表其所指的法体，这叫有体施设假。
    以上两种我法，前者是世间的迷情妄执，后者是佛陀的随缘假设，都是没有实体的。
    三、 以无依有假：世人所执的我法，只是假名，没有实体，而其迷执的心，却是有体的。所以对于无体的我法说它是假，而它寄托在有体能变的心识上，假能迷的妄情而说我法，所以称为以无依有假。
    四、 以义依体假：义是义用，圣教所说的我法，是依于法体之义，假说我法。例如我人的身体，在一期生命期间，心识上的种种活动，看起来似乎有一个主宰的作用，发号施令，支配一切，似乎是我的意义；另一方面，在各种尘境上，使我们生起见闻觉知的了别作用，而那法体上又能任持其自性而不失，似乎是法的意义。
    因为法体有此意义和作用，假说我法，这叫以义依体假。
    以上二假，一是随妄情的迷解假说世间我法，一是随法体的义用假说圣敖我法。总结来说，我法二字，只是名言假设，只有假名，没有实体，佛菩萨为说法度生，假借名言，来施其教化，这就是‘由假说我法’。
    [有种种相转’ ，相即相状，转是生起。我相法法相，品类繁多，以其非一，故说种种，以上为第一主题的解释。
    二、 标宗归识──彼依识所变。
    识变，是唯识宗的独特的理论。它意谓宇宙万法，皆是识所变现，称为识变。 <成唯识论> 二曰： [然依识变，对遣妄执真实我法说假似言。’ 识变是由识转变、变现的意思。识论解释识变曰： [变谓识体转似二分，相见俱依自证起故，依斯二分施设我法，彼二离此无所依故。]
    上段论文是说： 八识心王、及各各相应心所，皆能从自体转变 (变现) 出似有实无 (似实实假) 的相分和见分。见分是能认识的作用，相分是似外境的影像，依此二分施设 (假说) 我法，而此相、见二分，是识体转变出来的，离开识体也就没有相、见二分，这就是识变。
    所谓识，本来是一种功能，此功能未起现行之前 (即潜隐的功能) ，不称识而称种子。此功能发生作用 (由潜隐而生起现行) ，不称种子而称识。种子生现行，必待缘俱。心法生起要具备四种缘，色法生起只须二种缘，此留待后文再讲。
    三十颂说，八识为三能变。 即颂文谓：[此能变唯三’，唯三，指八种识有三类能变，即异熟能变、思量能变、及了别境能变。 <成唯识论> 诠释能变，谓能变有二种，一者因能变，一者果能变。论曰： [此三皆名能变识者，能变有二种，一因能变，谓第八识中等流、异熟二因习气，等流习气，由七识中善恶无记熏令生长； 异熟习气，由六识中有漏善恶熏令生长。二果能变，谓前二种习气力故，有八识生，现种种相。]
    所谓 ‘因能变’，就是第八识所摄持的种子 (即等流、异熟二因习气) 的转变──由潜隐的种子起现行，转变为第八识 (即等流、异熟二因习气所生的果。) 。在此转变中，种子为因，第八识识体为果，故说名因能变；所谓‘果能变’，是第八识体生起时，前七识相继生起，在八个识及其心所的自体分上，各各生起相、见二分的变。
    事实上，因能变与果能变本是一件事，识体以种子为亲因而生，故说种子为因能变；而识体从种子生时，同时识体上变现出相、见二分，故说识体为果能变。因果二种变，非是前后异时，而是同时转变，但在意义上说，这是两种转变。
    简单的说，因能变，就是种子生起八识识体的变； 果能变，就是八识识体变现相、见二分的变。此处要注意的，即八识识体变现相、见二分时，其所相应的的心所，也各各变现出相、见二分。
    于此有一疑问，所谓因能变，是种子生起八识识体的变。而种子是第八识所摄持，何以又能生出第八识？ 答案是这样，所谓种子与识，基本上只是一种功能。第八识与其所含藏的种子，是无始以来同时俱有的，种子是能生之因，八识现行是所生之果； 而现行是能熏之因，受熏的新种子是所生之果，此二重因果，是刹那灭，果俱有。因此，种子能生出第八识，第八识同时也能摄持种子。
    果能变，是八识识体转变出相、见二分的变，但在转变相见二分的同时，识体本身就不称为识体，而称为自证分了。正如 <识论> 所称：‘变谓识体转似二分，相见俱依自证起故。’这时，八识心王，及一切心所，各各析为相、见、自证三分。由此而有了心物相对的世界。即自证分与见分，同属能缘虑作用的心识界，相分只是所缘虑的物质界。唯识家以相分随同见分，同依识体变现，此即是摄物归心，所以成其唯识。
    解释所变，十大论师所见不一。安慧但立识体一分，难陀立相见二分，陈那于相见之外立自证分，成为三分，护法于三分之外更立证自证分，成为四分。因此，就有了‘安难陈护，一二三四。’之说。不过，后世都以护法之说为正义。这就叫做‘识体四分’。
    四分，就是说心心所有四种作用。分是一分 (一部分)， 四分即指心、心所的四部分作用。四分即是相分、见分、自证分、证自证分。相分是客观的外境，唯此外境并非实有，而是内识所变现的。见分，这是主观的认识作用，它所认识的就是心识所变现的相分。自证分，这是对主观的认识作用加以证知的作用，它也就是识的自体。证自证分： 这是识的自体，对自证分再度证知的一种作用。
    唯识宗立八识心王，五十一相应心所，此心王、心所，体虽各一，而分别其所起的作用，则有四种，即上述之四分。三十颂颂文谓‘有种种相转’所谓种种相，指的是我的种种相，法的种种相，都是‘依’著内‘识所变’现的‘见分’、‘相分’而起假说。因此，这见分和相分都是识所变现出来的。兹再详说四分。
    一、 [相分’：即自心体上变现出为见分所缘的境相。这在唯识学上、摄尽一切所谓客观的现象。因为心识是能缘虑之法，心识生起时，识体变现出相见二分，见分是能缘虑的作用，相分是所缘虑的境相。唯识宗立论，以为宇宙万法，皆内识之所变现，故所谓相分，是第八识的色法种子──所谓相分色所变现的境相。
    相分之相与像字通用，如相片又称像片，亦称肖像，故所谓相，亦就是影像。此影像不是外境的‘本质色’，而是托第八阿赖耶识的‘相分色’，在眼识上再变现一重‘相分] (影像) ，由眼识的见分去缘。所以唯识学上说： [识所缘，唯识所变。]
    二、 [见分’：即心识的缘虑作用，亦即主观的认识主体。心识生起，自其自体变现出相、见二分，相分是色法，概括世间的一切物质现象； 见分是心法，有缘虑作用，是认识的主体。不过此见分与相分，都是识体之所变现，摄物归心，所以成其唯识。
    三、 自证分：又作自体分，自觉的证知作用。见分有缘虑、了别相分的作用，但不能自知其所见有无谬误，故必须另有一证知其作用者，即是自证分。自证分即识之自体，故又名自体分。
    四、 证自证分：心法四分之一，对自证分加以证知的作用，这是识体作用的一部分。自证分有证知见分的作用，但谁来证知自证分有无谬误呢？ 于是识体更起一种作用，以证知自证分的所证是否正确，此再度证知的作用，即是证自证分。但谁来证知证自证分有无谬误呢？ 就是原来的自证分，因为自证分和证自证分二者，能互缘互证，所以就不必另立一个证证自证分了。
    三、 彰能变体──谓异熟思量，及了别境识。
    唯识宗立八识，谓八识皆能转变，而此转变，只有三类。故三十颂颂文曰： [此能变唯三，谓异熟思量，及了别境识。’ 八识唯有三类能变。此三能变是：
    一、 初能变识： 又称异熟能变识，指第八阿赖耶识的转变。
    二、 第二能变识： 又称思量能变识，指第七末那识的转变。
    三、 第三能变识： 又称了别能变识，指前六识的转变。
    当识变时，并不是任何一识单独转变，而是三类识全体次第转变。转变的主因，是阿赖耶识中储藏的种子，何类种子成熟，则转变出何种境界。
    颂文中的此字，就是指依识所变的相见二分。能变是对所变而言，佛典用语，常有能、所二字。能是主动，所是被动。如心识缘境，有所谓能缘、所缘等是。所以相见二分是被变现的，名为所变；识是变现的主体，名为能变。能变之识，在体方面说，则有眼、耳鼻、舌、身、意、末那、阿赖耶八种识；但是约类来讲，‘唯’有三类。唯是决定义，既非是二，也非是四，决定是三。即初能变的异熟能变识，第二能变的思量能变识，第三的了境能变识。
    异熟能变识，是引业所感得的有情总报真异熟的果体。也就是阿赖耶识，所以阿赖耶识旧译果报识，新译异熟识。异熟是什么意思呢？异者不同，熟者成熟。异熟二字，有下述三义：
    一、 异时而熟：有情所造善恶之业，由造业到果熟受报，要经过相当的时间──或隔生而熟，或二三生而熟，由造业到成果的时间不同，曰异时而熟。这有如果树上结的果子，由开花结果，到果子成熟，要经过相当们的时间，这叫异时而熟。
    二、 变异而熟：有情由造业到受果，既然隔世，因望于果，其性质必有变异，曰变异而熟。譬如水果，由初结果到完全成熟，味道上必有变异，这叫变异而熟。
    三、 异类而熟：有情造作善恶诸业，善业感乐果，恶业感苦果。而苦乐之果非善非恶，是无记性，此无记之果对善恶之因而言，是异类而熟。譬如江河溪涧之水，性质各异，但流入大海时，就混同一味了，这叫异类而熟。
    思量能变识，即第七末那识。末那识梵文 Manas Vijnana ， Manas 意译为‘意’，Vijnana 意译为‘识’，合译为意识，这就与第六意识同名了。为避免与第六意识混淆，因此保留末那原名，以示区别。第六、七识虽然同名，但解释不同，第六识是依意根之识，是依主释； 第七识乃意即是识，是持业释。 <成唯识论> 曰： [此名何异第六意识，此持业释，如藏识名，识即意故。彼依主释，如眼识等，识异意故。]
    此识恒常执持第八识见分为‘我’，而思量计度，即是此末那识的体性行相。三十颂称其为‘思量为性相’。思者思虑，量者度量，识之缘境，凡有了别，即有思量，因此八个识皆有思量的作用。但此处何以特别突显第七识的思量作用？ 因为以八识作用殊胜来说，则‘集起名心，思量名意，了别名识。’末那义译为意，意的作用本来就是思量。并且此识的思量，是‘恒审思量]。
    恒是恒常，审是审察，所以末那识是恒常的‘审查思量’。以八个识分析，前五识没有审察思量，故说是‘非恒非审’的思量。第六识有思量，但此思量有时间断 (如在五位无心的情况下) ，所以是‘审而非恒’的思量。第八识恒时相续，没有间断，但它也没有审察思量，所以是‘恒而非审’的思量。唯有第七识是恒常的审察思量。第七识思量些什么呢？ 就是恒时执持第八识的见分为自我，而审察思量。此识命名，若思量属识，则识即思量，是持业释；若识属思量，即识之思量，是依主释。
    了别境能变识，指前六识而言，此六识各各了别各种粗显外境，名了别境识。三十颂曰： [次第三能变，差别有六种。’差别有六种者，谓了别境识是前六识的总名，若分别来说，包括眼、耳、鼻、舌、身、意六种识，了别色、声、香、味、触、法六种境。颂文中 ‘及了别境识’，及者合集义，即六识集合起来，总名了别境识。此了别境识命名，若了别属识，则了别即识，是持业释；若识属了别，即识之了别，是依主释。


第五讲 异熟能变──第八识

    第五讲 异熟能变──第八识
    今日讲三能变中的初能变、异熟能变识。古人讲异熟能变，以‘八段十义’科分。八段者以颂文标目，十义者以识体显义，兹列表如下：

     ┌三相门┌阿赖耶识──────────────────自相门
     │ ├异熟────────────────────果相门
     │ └一切种───────────────────因相门
     │所缘行相门──不可知──执、受、处─────────所缘门 八段─┤ 了───────────────行相门 十义 │心所相应门──常与触、作意、受、想、思相应─────相应门
     │五受相应门──（相应）唯舍受────────────五受门
     │三性分别门──是无覆无记──────────────三性门
     │心所例同门──触等亦如是
     │因果譬喻门──恒转如瀑流──────────────因果门
     └伏断位次门──阿罗汉位舍──────────────伏断门
    八段十义如上所示，现依八段次序诠释如下。
    一、三相门──初阿赖耶识，异熟一切种。
    以上二句颂文，是明此第八阿赖耶识的三种面相，即是自相、果相、因相。以‘阿赖耶识’是此识的自相，‘异熟’是此识的果相，‘一切种’是此识的因相。
    一、赖耶自相：赖耶自相，即‘阿赖耶（Alaya）识’，阿赖耶是吭语音译，义译为藏识，藏有三义，曰能藏、所藏、执藏。能藏者，此识贮藏万法种子，此识是能藏，种子是所藏；所藏者，种子起现行，受七转识薰习，受熏的新种子再藏入此识，新种子是能藏，此识是所藏；执藏者，第七识妄执第八识见分为‘我’，爱之不舍。就第七识执持此识来说，称为我爱执藏。此三藏义，以我爱执藏为正义。
    二、赖耶果相：赖耶的果相，是‘异熟’识。异熟识旧译果报识，成唯识论曰：‘此是能引诸界、趣、生，善不善业异熟果故，说名异熟。’论文中界指欲、色、无色三界，趣指天、人、畜生、饿鬼、地狱五趣，生指胎、卵、湿、化四生。此识是善恶之业引生异熟果报，故称异熟，此为赖耶果相。
    三、赖耶因相：阿赖耶识的因相，是‘一切种’。此识摄持诸法种子，又名一切种识，诸种子生起现行法，种子是现行之因，故称‘一切种’为此识因相。成唯识论曰：‘此能执持诸法种子，令不失故，名一切种。离此，余法能遍执持诸法种子不可得故。’因相是此识的第三位相，而自相是因相果相的总和，识论曰：‘此即显示初能变识所有自相，摄持因果为自相故。’
    作为总报体的真异熟──即阿赖耶识，必须具有业果、不断、遍三界三义：
    一、业果：就是酬善恶业因的‘异熟无记果’。如总报的果体其性唯善，则所感的恒是乐果，就没有作恶招苦果之义，就不会流转苦道了；反之，假如果体唯恶，恒招苦果，就没有为善招乐果之义，就不会有还灭觉悟的时候了。所以总报体必须是无记果，始有流转与还灭。
    二、不断：不断即是相续。如果总报体有断绝而不相续，则欲界色界的有情，在总报体中断时，岂不是有如死者？无色界有情本来没有色身，如果总报体中断，岂不是连心识也有了？所以作为三界有情的总报体，必须要相续不断。
    三、三界：这异熟总报的果体，必须遍通三界，如果不遍三界，岂不是某一界的有情，没有果报体了？
    以上三义，只有此第八阿赖耶识全具。前五识经常中断，色界二禅以上无前五识，没有遍三界义；第六识在五位无心时会中断，缺了不断义；第七识有不断和遍三界义，而没有业果义，所以都不能成为总报果体。
    第八阿赖耶识，从凡夫位到证得究竟圣果，要经过染净三种位次，其名称亦因之而异。此三位，曰我爱执藏现行位，善恶业果位，相续执持位。现分述如下：
    一、我爱执藏现行位：第七识妄执第八识见分为‘实我’，而起我爱执著。于此，第七识是能执，第八识是所执，故第八识又名‘我爱执藏’。由凡夫、二乘有学位、及七地以前菩萨，全为此位所摄。二乘修到无学位，菩萨修到八地，俱生我执断时，才舍去藏识之名，称为异熟识。
    二、善恶业果位：指为善恶的异熟业所支配招感的果位，阿赖耶识又名异熟识，因为它是善恶的异熟业所招感的异熟果，所以第八识有异熟识之名。由凡夫到二乘无学位圣者，大乘十地菩萨，全是此位所摄。必须到十地满心，即金刚喻定现前，一刹那间，永断世间二障种子，转第八识成大圆镜智，此时舍去异熟之名，而称为阿陀那识。
    三、相续执持位：证得佛果的第八识，至无终尽期，都名阿陀那（Adana）识。这是无上转依的清净位，纯粹是至善无漏的识体，故唯在佛果位才有。由凡夫、二乘行人的有学位、大乘七地菩萨，阿赖耶、异熟、阿陀那三名具备；二乘无学位，八地以去菩萨，已舍去阿赖耶识名称，只剩下异熟识及阿陀那识二名；到究竟佛果位，异熟一名也舍去，就只称阿陀那识了。
    二、所缘行相门──不可知执、受、处，了
    阿赖耶识能缘的作用，称之为其行相，能缘之识，必有其所缘之境，故三十颂中，将能缘、所缘二者并举，即颂文中‘不可知执、受、处、了’七个字。这其中，‘执、受、处’三者，是阿赖耶识所缘之境，‘了’是此识能缘的作用。了即了别，了别是此识自体的能缘作用，指的即是此识的‘见分’。执、受、处三者，是见分所缘的境，也就是相分。执是执持万法种子、及摄持根身，持令不坏；受是领根身为境，令生觉受；处是器界，即物质世界。因此，第八阿赖耶识所缘之境，有‘两类三法’。两类是指‘执受’和‘处’，三法即种子、根身、器界。兹再分述如下：
    一、种子：能生起万法的种子，储藏在第八阿赖耶识中，种子是所藏（所持），阿赖耶识是能藏。能藏，也就是‘执持’万法种子。
    二、根身：由四大和合而成的‘根身’─即眼、耳、鼻、舌、身的五根身，是第八识中的色法种子所变现的。此根身由第八阿赖耶识所‘摄持’，持令不坏，感生觉受。阿赖耶识离开根身，命根即不存在，一期生命就告终了。
    三、器界：器界即‘处’，也就是物质世界。此亦为第八阿赖耶识色法种子所变现者。第八阿赖耶识何以能内变根身，外变器界？原来第八识所执持的种子，是一种潜在的功能（潜在的能量），此潜在能量能变现出四种功能，即坚实的功能，流润的功能，炎热的功能，飘动的功能。由这四种功能集体发生作用，使我感觉到有物的形体存在。由于四种功能集合的成分不同，而显示出各种不同密度的物质。其实以上四种功能，也就是地、水、火、风四种物性主观上的感觉，地大虽然有坚实（质碍性）的功能，但分析到最后只是能量，根本不是实质。
    器界是有情共业所感，根身是有情别业所感。若详细说，此中又有共中共，共中不共，不共中共，不共中不共，不再往下细述。
    三、心所相应门──常与触、作意、受、想、思相应。
    心所相应门，指与第八识相应的心所。在八个识中，第八识的相应心所最少，只有五遍行心所──触、作意、受、想、思。遍行，遍乃周遍，所谓无处不至；行是心行，即能缘之心，游履于所缘之境。合而言之，就是周遍起行的意思。心若生时，此五心所相应俱起。它通于一切识──八识心王；一切性──善、恶、无记；一切时──过去、未来、现在；一切地──三界九地，故有遍行之名。现在分述如下：
    一、触心所：触是接触，是根、境、识三者的接触，故又称三和。成唯识论三曰：‘触谓三和，分别变异，令心、心所触境为性，受、想、思等所依为业。谓根、境、识，更相随顺，故名三和。’论文的意思是，根、境交涉，识必俱起，根为识之所伏，境为识之所取，三者和合，可以使心、心所同缘一境，并由此继续生些受、想、思的心理活动。
    二、作意心所：作意即是注意，成唯识论曰：‘作意，为能警心为性，于所缘境引心为业，谓此警觉，应起心种，引令趣境，故名作意。’故它的作用就是使心生起警觉，令缘其境，这就是生心动念之始。警心有二义，一者令心未起而起；二者心已起时，令引趣境。
    三、受心所：受是领纳、感受。成唯识论曰：‘受谓领纳顺违境相为性，起爱为业，能起合、离、二非欲故’这是说，受之自性，即是领纳，‘顺违俱非’者，即缘可爱之境谓之顺益，缘不可爱之境谓之违损，其非可爱亦非不可爱者，谓之俱非，即是中容境。‘起爱为业’，是心识缘顺违之境，则起苦乐感受，于乐受之境，未得则生贪欲，欲其得之；已得亦生贪欲，不使离失。于苦受之境，未得则有幸而不得之欲；已得则有愿即离失之欲。这种爱欲，恒由苦乐之受而起，故曰‘起爱为业’。
    四、想心所：想是心识构画的名言概念，成唯识论曰：‘谓于境取相为性，施设种种名言为业。’所谓取相，是于所缘种种境上，构画名言。如缘树时，计较此非花非草，而是树；缘马时，计较此非牛非羊，而是马。这种于树于马的取相，就是未出口的名言。如果心中没有取相作用，就没有出口的名言了。
    五、思心所：思是意志作用，成唯识论曰：‘谓令心造作为性，于善品等役心为业。’故思的自性，只是造作，以其造作的力用与心相应，使心于种种善恶之境，作出种种善恶的业用，这即是身、口、意三业中的意业。心识之生，由作意而至于思，思以审虑思、决定思、动发胜思三思之后，则善恶之念已经形成，而付之于行动，已不能中止了。由此而至于别境，就是必作之心了。
    四、五受相应门──（相应）唯舍受
    受有三受五受之分，三受是苦受、乐受、和不苦不乐的舍受。三受再加上忧受和喜受称为五受。在五受中，与阿赖耶识相应的，唯有舍受。第八识何以不与余受相应，一者此识行相极不明了，不能分别顺违境相，微细一类相续而转，故唯与舍受相应。二者此识是真异熟，与其相应的不能不是异熟受。三者此第八识为第七识缘之境，倘若和变异受（即苦乐忧喜之受）相应，那就不是常一我见之境了。
    五、三性分别门──是无覆无记
    三性，是指善、不善、无记三性。何谓善呢？简单的说，在此世来世，于自于他顺益者曰善；何谓不善呢？在此世来世，于自于他达损者谓不善；何谓无记呢？即既无顺益、亦无违损，非善非不善的中容之法──无记性。在唯识学上，无记又分为两种，即有覆无记和无覆无记。而阿赖耶识的性别，就是无覆无记。成唯识论曰：‘于善不善损益中，不可记别，故名无记’俱舍论曰：‘无记者，不可记为善不善性，故名无记。有说，不能成异熟果，故名无记。’
    第七末那识是有覆无记，因为第七识有烦恼心所覆盖，使之成为染污识。而第八识则是无覆无记──没有烦恼心所覆盖。第八识何以必须是无记性呢？因为‘冰炭不同炉、薰莸不同器。’善、恶相违而不能相容。第八识含藏万法种子，如果第八识性善，则不能容纳恶种子，如果性恶，则不能容纳善种子。必须是平等的中庸无记，才能兼蓄并容，统纳一切善恶种子。
    六、心所例同门──触等亦如是
    心所例同门，是以心王的体性，援心王之例，来推知与其相应心所的体性。与第八识相应的，只有五遍行心所，故颂文说：‘触等亦如是’。
    阿赖耶识，具有‘心王十义’──即八段十义中之十义。而触等五心所，以与此心王相应，例同心王，故在十义中与此心王相同的有六点。这六点是：
    1、触等五心所亦为前业所感，是真异熟。
    2、触等五心所，所缘行相，亦微细难知。
    3、此五心所，其所缘境，亦为种子、根身、器界三种。
    4、此五心所，它所相应的法也各有五种──即心王和此五心所共为六法，除去它各个的自体，而与余法相应。
    5、此五心所，其性亦是无覆无记。
    6、此五心所，亦至阿罗汉位，方究竟舍。
    此五心所，与心王十义中六义相同。但亦有不同者，如‘自相’义，此五心所没有执藏义，所以不例。‘持种’义，此五心所也没有，所以不例。‘了别行相’是心王的功能，所以也不例。此五心所和‘受’是不相应的，所以也没有例‘受俱’。在心王十义中，有果相、所缘、相应、三性、断位、以及所缘行相（三种境）不可知六义例等心王，故颂文中说：‘触等亦如是’。
    七、因果譬喻门──恒转如瀑流
    因果譬喻门，是指颂文中‘恒转如瀑流’一句。恒是相续而断，转是生灭变异。这是以瀑流譬喻第八识为生灭相续、非常非断之法。
    恒转二字，恒示其非断，转示其非常。第八识虽然恒时一类相续，而非常住。假使是常住，则体性坚密，就不能受一切法的薰习了。此识是前灭后生，念念相续，前后转变，所以能受一切法的熏习，这是转的意思。但此识虽非常住，有生灭转变，但也不能断灭，倘若断灭，则谁来摄持万法种子使之不失不坏呢？所以此识无始以来，恒时一类相续，没有间断，而为三界四生六道的主体，能摄持万法种子使令不失不坏，这是恒的意思。
    ‘如瀑流’三字，是喻此识因果断常之义。此识无始以来，刹那刹那，因减果生，果生因灭。因灭故不是常，果生故不是断，这样前因后果，非常非断，有如千丈瀑布，亘古长流，前水始去，后水已至，前后相续，无有间断。
    八、伏断位次门──阿罗汉位舍
    伏断位次门，是舍掉阿赖耶识的名称，而不是舍掉第八识体。因为第八识体，尽未来际，没有断舍的时候，故所谓断舍，只是舍去染污种子，转染成净，转识成智而已。‘阿罗汉位舍’者，阿罗汉有三义：
    1、l杀贼：谓杀尽三界间一切烦恼贼，故曰杀贼。
    2、应供：所有烦恼既断，则功德圆满，应受人天之供养。
    3、不生：谓永入涅槃，不再受分段生死。事实上，不仅是二乘无学果的阿罗汉位舍，大乘八地菩萨，也舍了阿赖耶识之名。


第六讲 思量能变──第七识

    第六讲 思量能变──第七识
    三能变识的初能变──异熟能变，已于上一讲讲完。今日讲‘次第二能变’，即思量能变末那识。古人讲第二能变，也是以八段十义来科分，现列表如下：

     ┌举体出名门──次第二能变，是识名末那────────标名门
     │所依门────依彼转────────────────所依门
     │所缘门────缘彼─────────────────所缘门
     │体性行相门──思量为性───────────────体性门 八段─┤ 相───────────────行相门 十义 │心所相应门──四烦恼常俱，谓我痴我见，并我爱我慢──染俱门
     │及余触等俱─────────────────────相应门
     │三性分别门──有覆无记摄──────────────三性门
     │界系分别门──随所生所系──────────────界系门
     └起灭分位门──阿罗汉灭定，出世道无有────────隐显门

    一、举体出名门──次第二能变，是识名末那
    次第二能变，是举其体，是识名末那，是出其名。
    末那识梵文Manas Vijnana，Manas 意译为‘意’，Vijnana意译为‘识’，合译为意识。如译为意识，这就与第六意识同名了，因此保留末那原名，以示区别。第六、七识虽然同名，但解释不同，第六识是依意根之识，是依主释，第七识是意识所依之根，其识体即是意，是持业释。成唯识论曰：‘此名何异第六意识，此持业释，如藏识名，识即意故。彼依主释，如眼识等，识异意故。’在经论中，以第七识名意，不名为意识者，大概有下列三种原因：
    一、若名为意识，即与第六意识相混淆。
    二、顺理正论卷十一曰：‘心、意、识体虽是一，而训词等义类有异，谓集起故名心，思量故名意，了别故名识。’第七末那集起的心义不及第八识，了别的识义不及第六识，唯思量的意义为他识所不及，故名为意。
    三、此识是第六识的近所依，故第六从于所依之根而立名，那所依之根的意，当然是第七识，故此名为意。
    二、所依门──依彼转
    凡心识生起，必有所依。如前五识依于五根，第六识依于第七识，而第七末那识所依的，是第八阿赖耶识。所以三十颂颂文曰：‘依彼转’。依是依止义，转是流转义，是相续、转起的意思。依彼转中的‘彼’，指的就是第八阿赖耶识。瑜伽师地论曰：‘由有阿赖耶故，得有末那。’末那识依止于阿赖耶识，相续流转，跟随著第八转现。何以第八识不立所依门，于此第七识才立所依呢？因为第八识是诸识的根本，为他识所依，依于他的意义不显著，故不立所依门，而前七识依于根本识的意义显著，始特别立所依一门。
    末那识和阿赖耶识，关系至为密切，就依止来说，末那识依于阿赖耶识，末那为能依，赖耶为所依。而事实上，阿赖耶识亦依于末那识，两者是互相为依。八识心王及其心所，皆有所依。譬如草木，以地为依，若离所依，则不能生长。诸识之所依有三种，曰因缘依、增上缘依、等无间缘依。兹分述如下：
    一、因缘依：因缘依亦名种子依，一切色、心诸法各有其种子，储藏于第八阿赖耶识中，待缘而起现行。成唯识论曰：‘诸有为法，皆托此依。’即是说一切有为的色、心现行法，皆须仗托各自种子为依，方能生起。此处说因缘依者，是对果得名，因即是缘，而现行名果，故能生现行的种子称因缘。
    二、增上缘依：此亦名俱有依。增上是增加其效果，促进其发展的意思，俱有是互为因果，互助互依的意思。以前五识来说，如眼识依于眼根，而眼根亦依眼识，若缺其一，则两者皆无作用，耳鼻舌身，亦复如是。
    三、等无间缘依：此亦名开导依。等无间者，前念后念相似曰等，相续不断，名为无间，等无间缘依，是前念为后念之所依，凡是心法，皆是如此。所谓心法，赅括心王心所在内，相续不断，始名无间，若不相续，便是有间了。故必须前念始灭，后念即生，永远不断，故名等无间缘。开导依者，即心法于一刹那间不得二体并起，故必俟前念心灭，让出其现行之位置，后念方起，这也就是前念开导后念的意思。
    此处有一点尚待说明，即诸识依于种子生起，是因缘依；诸识依于第八阿赖耶识──即根本识，是增上缘中的一种。
    三、所缘门──缘彼
    颂文中‘缘彼’二字，是指此第七末那识所缘之境，彼指的就是第八阿赖耶识。对法论卷二曰：‘意者，谓一切时，缘阿赖耶识。’末那所缘之境，是第八识阿赖耶识，但此亦有异说，十大论师所见不同，分述如下：
    一、难陀等师以为，第七识双缘第八识的心王心所，缘心王以执我，缘心所而执我所。
    二、火辨等师以为，第七识双缘第八识的见分相分，缘见分执我，缘相分执我所。
    三、安慧等师以为，第七识双缘第八识的现行、种子，缘现行执我，缘种子执我所。
    四、护法论师以为，第七识恒缘第八识的见分而起我执，以第八识无始以来，一类相续，似乎是‘常’、是‘一’，又恒为诸法之所依，好像有‘主宰’的作用，所以即执为‘实我’。何以说第七识唯缘第八识的见分？因为受境等作用，是见分所显示，所以第七识唯缘第八识的见分。
    以上四说，一般以护法论师之说为正义。
    四、体性行相门──思量为性相
    ‘思量为性相’一句，是指此第七识的体性与行相。所谓体性，指第七识的识体，也就是四分中的‘自证分’；所谓行相，就是能缘的作用，即四分中的‘见分’。既然体性和行相不同，所以在十义中分为二门，即‘体性门’与‘行相门’。
    此识恒常执持第八识见分为‘我’，而思量计度的作用，只是第七识见分的行相。但以第七识的体性微细难知，所以‘以用显体’以思量为其体性。思量的意义，思者思虑，量者度量，识之缘境，凡有了别，即有思量，因此宽泛的说，八个识皆有思量的作用。但此处何以特别突显第七识的思量作用？因为以八识作用的殊胜来说，则‘集起名心，思量名意，了别名识。’末那义译为意，意的作用本来就是思量。并且此识的思量，是‘恒审思量’。
    恒是恒常，审是审察，所以末那识是恒常的‘审察思量’。以八个识分析，前五识没有审察思量，故说是‘非恒非审’的思量。第六识有思量，但此思量有时间断（如在五位无心的情况下），所以是‘审而非恒’的思量。第八识恒时相续，没有间断，但它也没有审察思量的作用，所以是‘恒而非审’的思量。唯有第七识是恒常的审察思量。第七识思量些什么呢？就是恒时执持第八分的见分为自我，而审察思量。
    五、心所相应门──四烦恼常俱，谓我痴我见，并我慢我爱，及余触等俱。
    心所相应门，指与末那识相应的心所。八识规矩颂曰：‘八大遍行别境慧，贪痴我见慢相随。’指与此识相应的心所，有八大随烦恼心所──昏沉、掉举、不信、懈怠、放逸、失念、散乱、不正知。五遍行心所──触、作意、受、想、思。及别境中的慧心所，和四个根本烦恼心所──贪、痴、慢、见，一共十八个心所。而此十八个心所中，特别是与痴、见、慢、爱‘四烦恼’任运相应，恒时常俱。兹分述四烦恼如下：
    一、我痴：痴者无明义，于诸事理迷闇为性。此无明迷于我理，与我见相应，故曰‘我痴’。此无明有两种，一者相应无明，二者不共无明。相应无明，是指第六识与六种根本烦恼（贪、嗔、痴、慢、疑、恶见）相应而起者。不共无明分为两种，一为独行不共，是与第六识相应、而不和根本烦恼相应者。一为恒行不共，这唯与第七识相应。此处所称的我痴，即是恒行不共无明，这无明是不明无我之理，与我见相应，故名我痴。我痴居四烦恼之首，一切烦恼，皆由此无明而生起。
    二、我见：见者以推度为义，以慧为体。我见的见，就是根本烦恼中的不正见。不正见以‘染慧为性’，可开为身见、边见、邪见、见取见、戒禁取见五种，此处的我见，即五见中的身见，亦即是妄执五蕴和合之身，以为是常、一、主宰的实我。此又称为我执，这是与生俱起，恒时相续，缘非我的第八识而妄计为我的执著。原来我见有二，一者是分别我见，此是由邪师邪教引导而起者；二者是俱生我见，是与生俱有的，有我身即有我见，生生不离。俱生我见又有恒相续与有间断之别，恒相续者与第七识相应，有间断者与第六识相应。分别起的我见，则唯与第六识相应。
    三、我慢：慢者妄自尊大，轻蔑他人。慢是六根本烦恼之一，可开为七种，即慢、过慢、过过慢、我慢、增上慢、卑劣慢、邪慢。我慢即七慢中的第四种。我慢由我执而起。由我执故，进而贡高我慢。
    四、我爱：爱是贪的异名，大乘义章曰：‘贪染名爱’，即亦是六种根本烦恼心所的贪心所。爱有四种，一曰‘爱’，就是缘已得的自身而起贪爱。二曰‘后有爱’，缘未得的自身而起贪爱。三曰‘贪喜俱行爱’，缘已得的境界而起贪爱。四曰‘彼彼喜乐爱’缘未得的境界而起贪爱。以上四种爱，均与末那识相应，这是深爱于所执之我而生起的爱。在十根本烦恼（以恶见开为五种，故合为十）中，何以唯此四者与第七识相应，其余不与相应？因为其余心所，与第七识无共同活动的关系。以嗔来说，嗔是缘逆境而生起，而第七末那缘第八为我，乃属顺境，故嗔心所无由生起，以疑来说，第七末那缘第八阿赖耶为我，是一类相续，决走无疑，所以疑心所无由生起。至于其他如边见、邪见、见取见、戒禁取见，与我见同以慧心所为体，在同一性质的心所中，有某一心所生起，其他心所无由同时生起。并且邪见、见取见、戒禁取见，为分别起的我见。而末那相应的的我见，乃俱生起而非分别起，故不与之相应。还有一个边见，虽然也是分别起，但在我见之后，方起或常或断的边见。而与末那相应的我见，是一类相续，故边见就无由生起了。
    ‘及余触等俱’一句，明末那识相应的心所，除上面‘四烦恼’外，尚有遍于一切心的五遍行心所，遍于染心的八大随烦恼心所，及别境中的慧心所。
    六、三性分别门──有覆无记摄
    颂文‘有覆无记摄’句，是明此第二能变的末那识，在善、恶、无记三性中的属性。在善、恶、无记三性中，第七末那是无记。而无记又分两种，一曰有覆无记，二曰无覆无记。覆有二义，一是覆障，谓染法覆障圣进；二是覆蔽，谓染法能覆蔽心识令不净故。合此二义，称为有覆。而此第七末那，在两种无记中，以其与‘四烦恼’相应，故为‘有覆无记’所摄。
    第七末那既然与四烦恼相应，其性应属恶，何以为无记呢？原来此识虽与四烦恼相应，但不能感可爱非可爱果，没有善不善的记别，故曰无记。
    七、界系分别门──随所生所系
    颂文‘随所生所系’句，是指此第七末那识、在三界九地中系属于何界何地而言，故立此‘界系分别’一门。
    界地者，三界九地，即欲界的五趣杂居地，色界的离生喜乐地、定生喜乐地、离喜妙乐地、舍念清净地，无色界的空无边处地、识无边处地、无所有处地、非想非非想处地，这是有漏界的分类。系者系属，指被那一界地烦恼系缚，即系属于那一界地。颂文‘随所生所系’所生、指初能变的阿赖耶识。阿赖耶识为三界五趣总报的果体──是轮回的主体，以业力的牵引，在三界九地、四生六道中流转。此第七末那识以第八阿赖耶识为所依，第八阿赖耶亦以第七末那为所依，这二者互相为依，恒时同俱。所以阿赖耶识生于何界何地，第七末那便系属于何界何地，它自己是作不得主的。
    八、起灭分位门──阿罗汉灭定，出世道无有
    此起灭分位，也就是此思量能变的伏断位次。起灭就是生起和断灭，虽说是起灭，实际的意义是断灭；不过如但说断灭位，生起位就不得而知了。因此这一门是说明伏断的位次。末那伏断的位次有三，即阿罗汉位、灭定位、出世道位。‘无有’是灭义，就是染污末那伏断之谓。现分述三位如下：
    一、出世道位：出世道的‘道’，是指无漏智而说的。世间的智是有漏智，出世间智是无漏智。所以出世道就是观智──是指无漏的根本智和后得智现行的时候。原来第七识的烦恼，是任运生起，行相微细，有漏智不能使之伏灭，唯有无漏的观智才能使之伏灭。囚为‘生我执’与生空智相违，‘法我执’与法空智相违。故当生空的根本、后得二智现行时，生我执伏灭；法空的根本、后得二智现行时，法我执伏灭。换句话说，修唯识行，至见道位以上，末那识已转识成智。二执种子伏减，不起现行。
    二、灭定位：灭定即是灭尽定，亦名灭受想定。此定是三乘圣者，厌劳虑粗动之识，入于无心定，此位前六识心心所不起现行，染位末那心心所亦灭。此灭尽定，是生空智或法空智的等流果，是最寂静的无漏定，所以不是染污的末那识。
    以上二位，是染污末那现行的暂为伏灭，而非种子永灭。
    三、阿罗汉位：阿罗汉是三乘无学圣果，于不还果的最后一刹那无漏智现前时，末那识烦恼种子一时顿断，从此永不再生，也就是永灭，而不是暂伏。
    在此位烦恼种子虽然永灭，但所灭的只是生我执的烦恼种子，而非法我执的烦恼种子。所以于伏断位中，只言罗汉，不言菩萨，因为菩萨在八地以前，尚有俱生的法我执末除，故仍有染污末那也。
    以上三位，虽有暂伏和永灭的不同，但俱是指无染污的末那，若以有染污末那而言，由凡夫到证得究竟圣果，要经过染净三种位次，曰生我见相应位，法我见相应位，平等性智相应位。分述如下：
    一、生我见相应位：这是末那识缘阿赖见分生起的我执位，以此位有我执，一切凡夫、二乘有学、七地以前菩萨的有漏心位，都是此位所摄。
    二、法我见相应位：此位法执未空，一切凡夫，二乘证得声闻果缘觉果，及法空智果未现前的菩萨，都是此位所摄。
    三、平等性智相应位：菩萨见道位、修道位、法空智果现前，及转识成智，证得佛果，均此位所摄。
    以上三位，前二位是有漏位，第三位是无漏位。在有漏二位中，第一位是染污位，第二位是不染污位。


第七讲 了境能变──第六识

    第七讲 了境能变──第六识
    三能变识的第三能，是了别境能变。了别境能变指前六识而言，故三十颂颂文称‘次第三能变 差别有六种。’根据 <成唯识论> 的科判，以七段九义来解释颂文，现列其科判如下：

    ┌1、能变差别门──────次第三能变，差别有六种────体别门
    │2、自性行相门──────了境为性───────────自性门
    │　　　　　　　　　　　　　　　 相───────────行相门
    │3、三性分别门──────善不善俱非──────────三性门
    │4、相应门：
    │　A、列六位─此心所遍行，别境善烦恼，随烦恼不定─相应门相应门
    │　B、受俱──皆三受相应─────────────相应门受俱门
    │　　　　　　┌遍行──初遍行触等
    │　　　　　　│别境──次别境为欲，胜解念定慧
七段┤　　　　　　│善 ───善谓信惭愧，无贪等三根
九义│　　　　　释│　　　 　勤安不放逸，行舍及不害
    │ C、　　　六┤烦恼──烦恼为贪嗔，痴慢疑恶见
    │　　　　　位│随烦恼─随烦恼为忿，恨覆恼嫉懂
    │　　　　　　│　　　　诳谄与害娇，无惭及无愧
    │　　　　　　│　　　　掉举与昏沉，不信并懈怠
    │　　　　　　│　　　　放逸及失念，散乱不正如
    │　　　　　　└不定──不定谓悔眠，寻伺二各二
    │5、所依门─依止根本识─────────────────所依门
    │6、俱转不俱转门────────────────────俱转门
    └7、起灭分位门─────────────────────起灭门

一、 能变差别门── 次第三能变 差别有六种
    [次第三能变’ ，是对初之异熟能变，次之思量能变而言，现在是第三了境能变。‘差别有六种’句，谓了别境识是前六识的总名，若分别来说，包括眼、耳、鼻、舌、身、意六种识，了别色、声、香、味、触、法六种境。这六识得名的由来，有随根得名和随境得名两种。
    一、 随根立名： 随所依之根，而立六识之命。即依于眼、耳、鼻、舌、身、意六根，，而立眼、耳、鼻、舌、身、意六识之名，
    二、 随境立名： 即是随其所缘之境，而立六识之名。前六识所缘之境，是色、声、香、味、触、法六境，以其了别的尘境，而立色、声、香、味、触、法六识之名。
    唯随根立名通于自在位 (八地以上菩萨，可以五根互用) ，随境立名不通于自在位，故论典中多从随根立名。
    这六种识，前五识是五种感觉器官，依于眼、耳、鼻、舌、身五根，而生出的五种认识作用。第六识依于意根，是心理活动的综合中心。这六识的作用是：
    一、 眼识： 依于眼根，缘色境而生起了别认识作用
    二、 耳识： 依于耳根，缘声境而生起了别认识作用。
    三、 鼻识： 依于鼻根，缘香境而生起了别认识作用。
    四、 舌识： 依于舌根，缘味境而生起了别认识作用。
    五、 身识： 依于身根，缘触境而生起了别认识作用。
    六、 意识：依于意根，缘法境而生起了别认识作用。
    意识与前五识任何一识俱起，同缘外境，发生了别作用时，顺次生起的五种心念，即：
    一、 率尔心： 意识初对外境，于刹那间的轻率了别。
    二、 寻求心： 于率尔了别之后，进而生起寻求作用。
    三、 决定心： 意识寻到目标，进而决心了别。
    四、 染净心： 意识于了别外境后，对于怨亲顺违等境界，所生起的染净之心。
    五、 等流心： 染净之心 (善恶之心) 相续，即叫做等流心。
    以上五心，顺次生起，而前五识之染净，必定由意识为之引导。
    第六识的作用有两方面，一者意识与前五识同时而起，发生其了别作用，曰五俱意识；二者意识不与前五识同时俱起，而单独生起，称为独头意识，分释如下：
    一、 五俱意识：意识与前五识俱起，共同了别境。五俱不是同时五俱，而是或一俱，或二俱，或三、或五俱，视缘而定。即：
    1、意识与眼识同起，发生其分别作用，称眼俱意识。
    2、意识与耳识同起，发生其分别作用，称耳俱意识。
    3、意识与鼻识同起，发生其分别作用，称鼻俱意识。
    4、意识与舌识同起，发生其分别作用，称舌俱意识。
    5、意识与身识同起，发生其分别作用，称身俱意识。
    二、 独头意识：又称独散意识，即不与前五识俱起，而单独发生作用，此复有四种：
    1、独散意识：或追忆过去，或筹计未来，或比较推度种种想像分别，或意念游走东想西想，此称独散意识。
    2、梦中独头意识：这是在睡梦中，缘梦中境界而生起的意识。
    3、定中独头意识：这是在禅定中，缘定中境界所生起的意识。
    4、狂乱独头意识：狂是颠狂，类以精神病患者，他独言独语，或辅以肢体动作，别人不知所以，事实上他的意识、也是缘著他自己幻想的境界而活动。
    二、 自性行相门──了境为性相
    前六识皆以了别境界为其自性，也为其行相，所以说‘了境为性相]。 颂文中‘了境为’三字应重读，即了境为性，了境为相。性者体性，指识体的自证分；相者行相，即是作用，指能缘的见分。本来了别外境只是前六识的行相，以其体性微细难知，故以用显体，故双云了境为相，了境为性。
    三、 三性分别门──善不善俱非
    [善不善俱非]一句，不是说前五识非善非不善，而是说此六个识，通于善、恶、无记三性。此六识生起，与十一个善心所相应者，就是善； 与二十六个烦恼心所相应者，就是恶； 与善或烦恼心所均不相应者，就是无记。本来前五识只是感觉器官，没有善恶的分别，但以第六识的五俱意识与之俱起，五俱意识随著前五识缘境而了解分别，这时前五识随著第六识的引导，亦就通于三性了。
    四、 相应门──六位心所 (颂文不俱录)
    相应门，指与了别境能变识的相应心所而言。相应二字，有‘合作’的意义。它建立在时、依、缘、事的四义上。至于‘心所’二字，是心所有法的略称， <成唯识论> 曰：
    [恒依心起，与心相应，系属于心，故名心所。’ 分释三义如下：
    一、 恒依心起： 心王生起时，心所同时俱起，心王若无时，心所亦不生，它是依于心王势力方得生起。
    二、 与心相应： 心所依心王生起，复与心王协合如一，名为相应。相应复有五义：
    1、所依同： 心王与心所同依于一根，方得相应。如眼识心所，与眼识心王同依于一眼根。耳、鼻、舌、身等亦然。
    2、所缘同： 心所与心王俱缘一境，曰所缘同。
    3、行相相似： 心王心所各自有其固有的性能，但以‘相似’故，如眼识心王心所同缘青色时，王、所之相分即各别变作青色之相分。
    4、时同： 王、所俱时而生，无有先后。
    5、事同： 事字在此处是 ‘体’义，于一聚相应心王心所中，如心王自体是一，心所亦各各是一，如眼识一聚相应的心王心所，眼识心王是一，则触、作意等心所其体亦各各是一，例同心王。事实上，亦绝无一法，于一时中有二体并转者。
    三、 系属于心： 以心王为主，心所系属之，心王有自在力，为心所之所依。
    在百法中，心所有五十一个，分为六位，即遍行心所五，别境心所五，善心所十一，烦恼心所六，随烦恼心所二十，不定心所六，现在分别诠释如下：
    一、 遍行心所： 六位心所的第一位，共有五个，即颂文：‘初遍行触等’，触以下是作意、受、想、思。此已见于第五讲异熟能变识中，此处不赘。
    二、 别境心所： 六位心所的第二位，共有五个，即颂文：‘次别境谓欲，胜解、念、定、慧，所缘事不同。’所谓别境，以此五心所所缘之境，各别不同，非如遍行同缘一境。欲所缘者为所乐境，胜解所缘者为决定境，念所缘者为曾所习境，定所缘者为所观境，慧则于四境拣择为性。此五种心所，乃必作之心，善恶皆然。
    此五心所，具一切性──善恶无记； 一切地──三界九地，而不缘一切境，亦非相续。非心有即有，故无一切时； 非与一切心相应，故无一切俱。兹分述如下：
    1、欲心所：欲是希望， <识论> 曰： [于所缘境，希望为性，勤依为业。’ 故欲的自性就是希望，于所爱境希望必合，于所恶境希望必离。‘勤依为业’者，因为希望，方勤劬精进，故欲为勤之所依，能为勤所依，即是其业用。唯所谓精进，系指对善欲而言，若不善欲，就不是精进了。
    2、胜解心所：胜者殊胜，解者见解，即是殊胜的见解。 <识论> 曰： [于决定境，印持为性，不可引转为业。’ 所谓决定境，即于所缘实境、或义理境，无所犹豫。如缘青色，计此为青，不疑为红为蓝； 如受某种学说影响，对其义理承受无疑，均名决定境。心识于缘虑决定境时，有审决印持的作用，此即胜解的自性。既经审决印可，即不可引转，即其业用。于犹豫境，则不起胜解。
    3、念心所：念是记忆，于所经历过的事物记忆不忘，就称为念。 <识论> 曰： [于曾习境，令心明记，不忘为性，定依为业。’ 凡是感官接触过的境界，或思维过的义理，都是曾习境，于曾习境的记忆作用，就是念的自性； 定依为业者，由忆念曾习正理，念兹在兹，而生正定，即是其业用。但于未曾经历的境是，则不起忆念。
    4、定心所：定的梵语三摩地，译曰正定， <识论> 曰： [于所观境，令心专注，不散为性，智依为业。’ 令心专注是心力恒时凝聚，不随所缘流散，故心力专注是其自性，由心定之故，明智即生，此即其业用。散乱之心，不能生定，亦无所依之智。
    5、慧心所：慧即智慧，是明白拣择， <识论> 曰： <于所观境，简择为性，断疑为业。’ 简择是比量智，于一切所知境界，简择其得失，而推度决定，故简择即慧之自性，由拣择而除掉疑惑，即是慧的业用。在愚昧心中，疑惑心中，则不能起慧。再者，邪见之流，以其痴增上故，不能简择，亦不起慧。
    三、 善心所：六位心所的第三位，计有十一个，即信、惭、愧、无贪、无嗔、无痴、精进、轻安、不放逸、行舍、不害。
    何谓善，随顺法理，于此世他世顺益于自他者，谓之善； 反之，于此世他世损害于自他者，名不善。故以上十一种善心所，赅括世出世间一切善法，其自体远离一切秽恶，而聚集一切功德。兹分述如下：
    1、信心所：信是对佛教义理坚定的信仰。 <识论> 曰： [云何为信，于实德能深忍乐欲，心净为性，对治不信乐善为业。’ 信有三种，一者于诸法实事实理深信不疑； 二者于三宝净德深为信乐； 三者于一切善法深信有力，能得成就。
    2、惭心所：惭者羞恶之心，是自我人格的尊重，做了坏事内心感到羞耻，曰惭。 <识论> 曰： [云何为惭依自法力，崇重贤善为性，对治无惭，止息恶行为业。]由于本身自我尊重的促进之力，可以止息恶行。
    3、愧心所：愧者廉耻之心，尊重世间舆论，耻于自己过失。即做了坏事无颜见人曰愧。 <识论> 曰： [云何为愧，依世间力，轻拒暴恶为性，对治无愧，止息恶行为业。’ 愧和惭一样，可以止息恶行。
    4、无贪心所：对于财色名利无贪著之心曰无贪。<识论> 曰： [云何无贪，于有有具无著为性，对治贪著作善为业。’有是三有之果，三有即欲界、色界、无色界三界，这是有情生存的处所； 有具，是生于三有的原因，即是惑与业。无贪是对有情生存处所不生贪著，不造惑业。
    5、无嗔心所：逆境当前，不生恚恨之心，谓之无嗔。 <识论> 曰： [云何无嗔，于苦苦具，无恚为性，对治嗔恚，作善为业。’ 苦是三界苦果，即三苦──苦苦、坏苦、行苦。苦具，即生苦之因。对于苦及生苦之因，不起嗔恚之心，于诸有情，常存慈愍，曰无嗔。
    6、无痴心所：无痴，是明达事理，不为迷惑。 <识论> 曰： [云何无痴，于诸理事明解为性，对治愚痴，作善为业。’ 所谓明解理事，是指明确理解四圣谛、八正道等佛教义理而言。
    7、精进心所：此又名勤，即对修道、为善勤劬不懈。 <识论> 曰： [勤为精进，于善恶品，修断事中，勇悍为性，对治懈怠，满善为业。’ 精者不杂，进者不退；勇而无惰，悍而无惧。精进是修善断恶，勤于为恶者正是颠倒，不名精进。
    8、轻安心所：身心安适轻快，谓之轻安。 <识论> 曰： [安谓轻安，远离粗重，调畅身心，堪任为性，对治昏沉，转依为业。’ 粗重指贪痴烦恼而言，修行者调伏烦恼，远离粗重，为修禅定之必要条件。转依为业者，即转去粗重，依于轻安。此心所唯于定中生起。
    9、不放逸心所：对治放逸，断恶修善，曰不放逸。 <识论> 曰： [不放逸者，精进三根，依所修断，防修为怍，对治放逸，成满一切世出世间善业。’ 放逸是在贪、嗔、痴的基础上成就一切恶事； 不放逸，是在无贪无嗔无痴的基础上成就一切善事。精进三根，指精进、无贪、无嗔、无痴四法，不放逸是四法分位假立之法，别无实体。
    10、 行舍心所：行者行蕴，舍即舍弃，贪嗔痴三法令心昏沉掉举，舍弃昏沉、掉举，令心得到平等，安于寂静。 <识论> 曰： [云何行舍，精进三根，令心平等正直，无功用住为性，对治掉举，静住为业。’ 此亦精进三根上分位假立之法。
    11、 不害心所：不害即不恼损众生，以无嗔为性，于诸有情，不为恼损。 <识论>曰： [云何不害，于诸有情不为恼损，无嗔为性，能对治害，悲愍为业。’ 不害是损恼有情之害的反面，无嗔是慈，予众生以乐； 不害是悲，拔众生以苦。


第八讲 前六识的王所相应至起灭分位

    第八讲 前六识的王所相应至起灭分位
    本讲上次讲到相应门──即与前六识相应的心所，以课文过长，未能讲完，现在继续上一讲再往下讲解。
    四、 烦恼心所：六位心所的第四位，计有贪、嗔、痴、慢、疑、恶见六种。此又称六种根本烦恼，由此能生起随之而来的随烦恼。 <识论> 曰： [烦恼心所，其相云何，颂曰： 烦恼谓贪嗔，痴慢疑恶见。论曰： 此贪等六，性是根本烦恼摄故，得烦恼名。’何谓烦恼，烦者烦闷、烦扰，恼者恼乱、恼热， <大智度论> 七曰：[烦恼者，能令心烦，能作恼故，名为烦恼。’ 兹分述如下：
    1、贪心所：贪即贪欲， <识论> 曰： [云何为贪，于有、有具染著为性，能障无贪，生苦为业。’ 有即三有或三界，有具是生起三有之因，也就是惑与业。贪以染著为性，著即执著，执著于我及我所，对于财色杖位固持不释，障蔽无贪之心，起惑造业，堕于三有，承受苦报。
    2、嗔心所：嗔者嗔恚，与无嗔反。<识论> 曰：‘云何为嗔，于苦、苦具，憎恚为性，能障无嗔，不安隐性，恶行所依为业。]
    苦即三苦──苦苦、坏苦、行苦，苦具是造成三苦之因。嗔是对三苦及造成三苦之因生恚恨心，能令身心恼热，对家人眷属，一切众生，轻则诟骂，重则损害他命，甚至于伐城伐国，喋血千里，莫不由嗔心而起。
    3、痴心所：痴是愚昧不明，事理颠倒，因果迷乱，义理全乖，是无痴之反。 <识论> 曰 ： [云何为痴，于诸理事，迷□为性，能障无痴，一切杂染所依为业。]
    痴即十二缘起之首的无明，无明即是迷昧不觉，对世间道理及佛法义理迷惑不解，由此引起种种烦恼，即‘一切杂染所依为业’。
    4、慢心所：慢者傲慢，自以为处处优于他人。 <识论> 曰： [云何为慢，恃已于他，高举为性，能障不慢，生苦为业。]
    慢者自尊自大，轻举乔扬，不知谦卑，轻蔑他人。 <俱舍论> 把慢区分为七或九种，唯识宗继承了‘七慢’之说条。
    A、慢： 对于不如我的，我轻慢他，这叫 ‘于劣计己胜’； 对于和我相等者，我轻慢他，这叫‘于等计己等’。
    B、过慢： 对方和我相等，我以为胜过他，这叫 ‘于等计己胜’； 对方胜过我，我不承认，反说我胜过他，这叫‘于胜计己胜’。
    C、过过慢： 对方胜过我，我不承认，反说我胜过他甚多，这叫做 ‘于胜计己胜]。
    D、我慢： 执著于五蕴和合的身心，为我与我所，因而骄傲自大，叫做我慢。
    E、增上慢： 修行者 ‘未得言得，未证言证。’叫做增上慢。
    F、卑劣慢： 自甘卑劣的人，对于胜过他的人，以为 ：‘胜过我又该如何？ ’别人学佛修道，他以为： [我不信佛，还不是照样过日子？ ’此为自甘卑劣之慢。
    G、邪慢： 于慢上起邪见，自己无德，反说： [佛菩萨也不过如此’。甚至于不信因果，毁谤三宝，这叫邪慢。
    5、疑心所：对真理怀疑不定，曰疑。 <识论> 曰： [云何为疑，于诸谛理，犹豫为性，能障不疑善品为业。’ 所谓谛理，即苦、集、灭、道四圣谛而言。对谛理犹豫不信，故障蔽不疑的善品，此即其业用。
    6、恶见心所：恶见又称不正见，亦即是邪见。 <识论> 曰： [云何恶见，于诸谛理，颠倒推求，染慧为性，能障善见，招苦为业。’ 恶见心所是依慧心所所假立的，故云以为性。而慧通于善、恶、无记三性，此慧是染分之慧，非善性所摄，染慧能障善见，招感苦果，故称招苦为业。恶见可开为五种，即：
    A、萨伽耶见： 译曰身见，这是一种外道的见解，认为五蕴实有，执此为我，而生种种谬误的见解。 <识论> 曰： [萨伽耶见，谓于五取蕴执我我所，一切见趣所依为业。]
    B、边见： 有了我见，即计度我为死后常住不灭者，或计度我为死断灭者，此即佛教所反对的常见或断见。
    C、邪见： 认为世间无生果之因，亦无可招之果，故为恶不足惧，为善不足法，此种见解，乃见之最邪者，故名邪见。
    D、见取见： 于前种见上随执一端，以为最胜，即固执其所见，一切斗争依之而起，故以一切斗争所依为业。
    E、戒禁取见： 印度古代苦行外道，认为受持牛、狗、鸡等戒，可以得涅槃之果。这种非因计因，非道计道之见，是为戒禁取见。
    五、 随烦恼心所：六位心所的第五位，此又名随惑，是随根本烦恼所生起的烦恼。随有三义，一者自类俱起，二者遍不善性，三者遍诸染心。随烦恼心所二十个，分为小随、中随、大随三种。小随烦恼十个、中随烦恼二十个、大随烦恼八个。小、中、大的分别，以三义俱备者名大随，兼具二义者称中随 (自类俱起、遍不善性) 。于不善心中各别而起者称小随。现分述如下：
    小随烦恼心所，随根本烦恼生起之烦恼，计有十种，曰忿、恨、覆、恼、嫉、悭、诳、谄、害、乔。其发生作用面最小，而行相粗猛，于不善心中，各别生起。
    中随烦恼，随根本烦恼生起之烦恼，有二种，曰无惭、无愧，其发生之作用范围较小随烦恼为宽，俱自类俱起，遍不善心二义，故曰中随。此二者，对自己所犯的过恶不感到羞耻，是其共同点； 而惭者‘轻拒贤善’，愧者‘崇重暴恶’，是其相异点。大随烦恼，随根本烦恼生起之烦恼，有八种，曰掉举、昏沉、不信、懈怠、放逸、失念、散乱、不正知，其发生作用范围最广，俱自类俱起，遍不善性，遍诸染心三义，故曰大随烦恼。现分述二十种随烦恼如下：
    1、忿心所：对于违逆之境生起的忿怒，产生粗暴的身语表业。 <识论> 曰： [云何为忿，依对现前不饶益境，愤发为性，能障不愤，执杖为业。]
    2、恨心所：恨者怨恨，怀恶不舍，引起极度烦恼。 <识论> 曰： [云何为恨，由忿为先，怀恶不舍，结怨为性，能障不恨，热恼为业。]
    3、覆心所：覆是覆盖，犯了过恶，怕丧失名利，故把过恶隐藏起来。 <识论> 曰：[云何为覆，于自罪恶，恐失利誉，隐藏为性，能障不覆，悔恼为业。]
    4、恼心所：恼者恼怒，于忿恨之后，遇违逆事，因而爆怒，凶狠暴戾，有如蝎子螫人。 <识论> 曰： [云何为恼，忿恨为先，追触暴热，狠戾为性，能障不恼，蛆螫为业。]
    5、嫉心所：嫉者妒忌，他人荣盛，我怀忧戚，如妾妇之固宠，政敌之倾轧。 <识论> 曰 ： [云何为嫉，殉自名利，不耐他荣，妒忌为性，能障不嫉，忧戚为业。]
    6、悭心所：悭者悭吝，财物不肯施舍，法理秘不告人，鄙恶地蓄积财法。 <识论>曰：‘云何为悭，耽著财法，不能惠施，秘吝为性，能障不悭，鄙蓄为业。]
    7、诳心所：诳是欲谋取名誉或利益，自己无德而诈称有德的一种欺骗行为。 <识论> 曰 ： [云何为诳，为获利誉，矫现有德，诡诈为性，能障不诳，邪命为业。]
    8、谄心所：谄者谄曲，为了取得别人欢心而阿谀谄媚，以达到自己谋求的目的。 <识论 > 曰：‘云何为谄，为冈他故，矫设导仪，险曲为性，能障不谄，教诲为业。]
    9、害心所：害者损害，心无悲愍，损害有情，是不害之反。 <识论> 曰： [云何为害，于诸有情，心无悲愍，损恼为性，能障不害，逼恼为业。]
    10、 乔心所：乔者骄傲，由于得到世间名利而骄慢自大。 <识论> 曰： [云何为乔，于自盛事，深生染著，醉傲为性，能障不乔，染依为业。]
    11、 无惭心所：无惭是惭之反，即没有羞恶之心，不顾本身人格尊严，拒绝贤人的教诲，不接受世间出世间善法。 <识论> 曰： [云何无惭，不顾自法，轻拒贤善为性，能障碍惭，生长恶行为业。]
    12、 无愧心所：无愧是愧之反，没有廉耻之心，不顾世间清议，不畏社会舆论。 <识论>曰： [云何无愧，不顾世间，崇重暴恶为性，能障碍愧，生长恶行为业。]
    13、 掉举心所：掉举是心不安静，妄动浮燥，障碍禅定。 <识论> 曰： [云何掉举，令心于境不寂静为性，能障行舍奢摩他为业。’ 奢摩他为‘止’，即是禅定。
    14、 昏沉心所：昏沉是昏懵沉醉，迷□不明，障碍轻安和智慧。 <识论> 曰：‘云何昏沉，令心于境无堪任为性，能障轻安毗钵舍那为业。’ 毗钵舍那是‘观]，与奢摩他合称‘止观’。此又称定慧、寂照。
    15、 不信心所：不信者心存污秽，不信三相，即一者实有，即诸法实相； 二者德，即佛、法、僧三宝； 三者有能，有能力成就世出世间善法。 <识论> 曰： [云何不信，于实、德、能不忍乐欲，心秽为性，能障净信，堕依为业，谓不信者多懈怠故。]
    16、 懈怠心所：懈怠与精进相反，既不修善，亦不断恶，甚而对恶业勤奋。 <识论> 曰： [云何懈怠，于善恶品修断事中，懒堕为性，能障精进，增染为业。]
    17、 放逸心所：放逸者，放荡纵逸，于染法不能防，于净法不肯修。 <识论> 曰：[云何放逸，于染净品不能防修，纵荡为性，障不放逸，增恶损善所依为业。]
    18、 失念心所：失念即是遗忘，心意散乱，对于所修善法不能明记。 <识论> 曰：[云何失念，于诸所缘，不能明记为性，能障正念，散乱所依为业。]
    19、 散乱心所：散乱即不专心，令心流荡，，障碍正定，阻止善慧，增长恶慧。 <识论>曰： [云何散乱，于诸所缘，令心流荡为性，能障正定，恶慧所依为业。]
    20、 不正知心所：不正知即是邪知，误解世间法及出世间法，破坏佛教真理。 <识论> 曰 ： [云何不正知，于所观境，谬解为性，能障正知，毁犯为业。]
    六、 不定心所：六位心所的第六位，有四种，曰悔、眠、寻、伺。称不定者，意谓于识、性 (善、恶、无记。) 界 (欲、色、无色三界。) 都不确定。无法记别。
    1、悔心所：又名恶作，对于先所作事生起悔心。 <识论> 曰： [悔谓恶作，恶所作业，追悔为性，障止为业。’ 即对已作恶事追悔，就是善性； 对已作善事追悔，就是恶性。悔能令心怅怏不安，故有障碍止 (观) 作用。
    2、眠心所：眠即睡眠，昏迷而不自在，能障智慧。 <识论> 曰： [眠谓睡眠，令身不自在，昧略为性，障观为业。’ 睡眠之时，心极阇劣，身无力用，故有障碍 (止) 观的作用。故适度睡眠是为善法，过度睡眠是为恶法。
    3、寻心所：寻者寻求，对事理粗略具思考。 <识论> 曰： [寻谓寻求，令心偬遽，于意言境，粗转为性。]
    4、伺心所：伺者伺察，对事理细密的思考。 <识论> 曰： [何谓伺察，令心偬遽，于意言境，细转为性。’ 寻与伺，是依思心所与慧心所分位假立，本身没有实体。
    五、 所依门──依止根本识
    第三能变识，是集合前五识与第六识所合成，此六识之生起，皆以第八识为依止，故颂文首句指出：‘依止根本识’。识论解释此句曰：‘根本识者，阿陀那识，染净诸识生根本故。依止者，谓前六转识，以根本识为共亲依。
    心、心所的生起，要有三种依，即因缘依，增上缘依，等无间缘依。而前六识之生起，以种子赖耶为亲因缘，得有前六识之现行。再者，前五识以五根为不共依，而五根由现行第八识执受得有，故前五识亦可说是以现行第八识为所依，这是根本共依。再者，第六识以第七识为所依，而第七识以现行第八识为不共依，所以第六识可以说是以第八识为根本共依。简单的说，‘依止根本识’者，即是前六识以现行赖耶为共依──增上缘依，而以种子赖耶为亲因缘依。
    增上缘依非现行赖耶一种，而是有四种，若缺任何一种，五识即不生起，此四种依为：
    一、 同境依： 前五识依于眼耳鼻舌身五色根，此五根与五识共取现境，曰同境依。
    二、 分别依： 谓依于第六识，前五识任何一识生起，意识与之同时生起，与前五识同缘色声等境，而起了解分别，曰分别依。
    三、 染净依： 谓依于第七识，第七识与‘四烦恼常俱’，是染污识，前五识亦由此识染污而成有漏，故此第七识是前五识的染净依。
    四、 根本依： 谓依于第八识，第八识是根本识，前五识依第八识而得生起，故以第八识为根本依。
    六、 俱不俱转门──五识随缘现 或俱或不俱 如涛波依水
    颂文 ‘五识随缘’句，指前五识生起，必须众缘俱备，而五识俱缘各不相同，如眼识所缘的物件是色境，生起时需要九缘；而耳识需八缘，鼻舌身三识需七缘，兹分述如下：
    一、 眼识九缘：
    1、空缘： 空即空间，眼识取境，须保持适当距离，无空间不能取境。
    2、明缘： 明即光明，眼识取境，需要光明，无光明不能取境。
    3、根缘： 眼识依于眼根而生起。
    4、境缘： 眼根触对色境而生眼识，境为识之所缘缘。
    5、作意缘： 作意即是注意，不注意则 ‘视而不见’。
    6、分别依缘： 分别指第六识，依第六识以分别外境。
    7、染净依缘： 此指第七识，对怨亲顺违之境生起的染净心。
    8、根本依缘： 此指第八识，第八识为前七识之根本。
    9、种子依： 种子为生起识之亲因缘。
    二、 耳识八缘： 耳识生起，不需光明，故仅需八缘。
    三、 鼻、舌、身三识，是‘合中取境’，不需光明和距离，故只需七缘。
    或俱或不俱者，五识可同时生起，亦可或一、或二、或三四生起，视缘而定。如波涛依水句，喻藏识如大海，余识如波涛，外境如风，风起而波涛现。 <八识规矩颂> 谓：‘浩浩三藏不可穷，渊深七浪境为风。’即指此而言。
    七、 起灭分位门──意识常现起，除生无想天，及无心二定，睡眠与闷绝。
    在上节俱不俱转门中，虽然统指第三能变识而言，实际上讲的只是前五识。此门则唯就第六识的起灭予以说明。前五识生起，须俱或九或八或七缘，俱缘较多，缘不俱足则有中断。第六识生起，只俱根缘、境缘、作意缘、根本依缘、种子依缘五种，缘少较易俱，故常时现起。但有五种情形则不生起，此称为[五位无心’。此五种情形是：
    一、 生于无想天： 外道修行生于无想天，寿命五百大劫，在此期间意识不起现行。
    二、 入无想定： 外道修行，入无想定，意识不起现行。
    三、 灭尽定： 修此定者，前六识不起现行，第七识染心所亦不起现行。
    四、 睡眠； 深度熟睡而无梦者，意识不起现行。
    五、 闷绝： 俗称昏迷，医学上谓‘无意识状态’，这是由于大惊布、大剌激，或剧痛昏晕的情况下，前六识不起现行。但第七、八识仍恒时相续，故闷绝者并非死亡，而是第六识不起现行。


第九讲 正辨唯识与释违理难

    第九讲 正辨唯识与释违理难
    以前八讲，由唯识学统，科判大纲，讲到唯识学的基本概念，以至于三能变识，三十颂颂文已讲完十六颂，今天讲十七、十八、十九等三颂。这三颂在科判中是：七、 正辨唯识，八、 释违理难。释违理难又分为两个子目，即心法生起缘由，及有情相续缘由，故分做三段来讲。现在即依诠释。
    一 正辨唯识──是诸识转变，分别所分别，由此彼皆无，故一切唯识。
    正辨唯识的颂文，如标题所录。这一首颂文，是上承首颂‘彼依识所变，此能变唯三’二句，以‘是诸识转变，分别所分别’二句，来说明万法唯识的道理；再以‘由此彼皆无，故一切唯识’二句，总结之于唯识。
    在三能变的颂文中，说明八识及各各心所，皆由自证分变现的见分和相分。但外人仍继续追问：‘如何能知道宇宙万有，皆是识所变现，而无实我实法的存在呢？’唯识家为了解答这一问题，复说下颂曰：
    [是诸识转变，分别所分别，由此彼皆无，故一切唯识。]
    <成唯识论> 解释此颂曰：
    [是诸识者，谓前所说，三能变识，及彼心所，皆能变似见相二分，立转变名。所变见分，说名分别，能取相故。所变相分，名所分别，见所取故。由此正理，彼实我法，离识所变，定非实有。离能所取，无别物故，非有实物，离二相故。是故一切，有为无为，若实若假，皆不离识。唯言，为遮离识实物，非不离识心所等法。]
    诸识，自然是指三能变的八识 (含各各的心所) 。转变，即是由体起用，由识体变现出能缘的见分、和所缘的相分。能缘的见分为能分别，所缘的相分为所分别，以能分别的见分，分别所缘的相分，即是 ‘分别所分别’。
    这‘是诸识转变’的‘转变’二字，尚有下列三种意义：
    一、 变现义：诸识的转变，是因转而变，因变而现。也就是由识体变现出见相二分，见分是能缘，即是见闻觉知，相分是所缘，即是根身器界，种种我相法相。
    二、 变异义：变是生起，异是不同。由识体自证分生出见相二分，此见相二分，异于识体，故说是变异。再者，此见相二分，见分是能，相分是所，能所皆识体所变，而作用各异，故说是变异。
    三、 改转义：是说由识体改转成见相二分，而有种种的我相或法相，由于具足这三种意义，所以说：‘是诸识转变’。
    [由此彼皆无’ 者，此指的是能缘所缘的见分相分，彼指的是根身器界，种种我相法相。而此种种我法，都是能缘之心所变现。而能缘之心，也只是识体的作用。因此，若去掉这个识，不但没有外境的我相法相，也没有内境的见分相分。所以说，我人所认为一切的实我实法，不过是因缘和合的假有──也就是能缘所缘的见相二分而已。离开见相二分，即没有我法的存在；离开识，也没有见相二分的存在。故最终的结论是： ‘由此彼皆无，故一切唯识。]
    二 心法生起缘由──由一切种识，如是如是变，以辗转力故，彼彼分别生。
    唯识家解释了上颂以后，外人复问难曰：‘若唯有识，都无外缘，何缘而生种种之分别？’意思是说：‘照你们唯识家所说，宇宙万有，只是相见二分的分别所分别，除识以外，没有实我实法的外境。既无外境，那么，能分别的处别心究竟缘何而生？这岂不是成了分别无因吗？]
    为了解答这一问题，唯识家复说颂曰：
    [由一切种识，如是如是变，以辗转力故，彼彼分别生。]
    以上颂文，前二句明因，第三句明缘，第四句明所生的分别心。一切种识，指第八阿赖耶识。种是种子，色心诸法的种子，潜藏于第八识中，种子是第八识能生起万法的功能，以用从体，故曰一切种识。‘如是如是变’一句，变者，是潜隐的种子起现行，种子起现行，现行薰种子成为新种子，新种子复起现行，所谓：‘种子乍生现行，现行薰种子，三法辗转，因果同时。’ 这就是‘如是如是变’，也就是分别心生起之因。
    [以辗转力故，彼彼分别生。’ 辗转是相资的意思，盖法不孤起，一法生起，须仗他法相资，种子起现行，也须要仗因托缘。盖有为法的生起，必依因缘和合。有因有缘，必然生果。因此，唯识学上立有 ‘六因、四缘、五果。’之说。事实上，因和缘没有什么差别，概略的说，因即是众缘之一，缘也是生果之因，不过在生起万法的关系条件上，因是较重要的一个条件而已。因此，六因之说，只是四缘的另一种分类方式。于此介绍四缘，四缘是因缘、等无间缘、所缘、增上缘，分述如下：
    一、 因缘： 因缘，是事物生起的众多关系条件中，具有生果能力的条件。经上说，‘谓有为法，亲自办果]， 称为因缘。但仅只有因仍不能生果，要因、缘具备才能生果。同时、在唯识学上的因缘，又不同于一般缘起的因缘。唯识学以 ‘万法唯识’立论，万法生起，皆是种子起现行的后果，因此，唯识学上的亲因缘， 就是第八阿赖耶识中含藏的种子。以种子生现行，始有宇宙万法。但‘法不孤起’ ，种子生现行，须要下列三缘具备。
    二、 等无间缘： 等无间缘旧译次第缘，新译等无间，意思是‘密密迁移，等无间隙]，这是指我们的心识生起，念念生灭，刹那不停，前念心为后念心开导，引令后念心生起，前念为后念的缘，后念亦为前念的缘，次第生起，故亦称次第缘。
    三、 所缘缘： 所缘缘旧译缘缘，这是心识攀缘外境的时候，此能攀缘之心，对所攀缘之境而生起，即是以境为其所缘。所缘缘这两个缘字，前一个缘是境，后一个缘是四缘之一的缘。语云： [境由心生，心因境起。’心生之境是法境，属于心法，引心生起之境是外境，属于色法，二者全是心识攀缘的物件。
    四、 增上缘： 增上是增加或加强的意思，对于一法的生起，有扶助之义，所以也称助缘。增上缘有顺益、违损两方面，自顺益方面说，能促成一法生起或成长者，称[与力增上缘’ ，不妨碍一法生生起或成长者，称‘不障增上缘’； 自违损方面说，此一法对他一法有妨害障碍者，如雨露是花木的顺益增上缘，而霜雹为花木的违损增上缘。
    唯识学是以‘万法唯识’立论，以一切法（色法及心法）的生起，皆是种子起现行的果，因此，种子是一切法的亲因缘，。再者，心法生起，要四缘具足； 色法生起，只须因缘与增上缘两种缘。
    三 有情相续缘由──由诸业习气，二取习气具，前异熟既尽，复生余异熟。
    唯识家解释完了分别心生起的原因，外人仍不满意，复问难曰：‘虽有内识而无外缘，由何而有生死相续？]
    有情生死相续，在三界六道中轮回生死，是由于善恶业力所招感。而善恶之业，又是由于无贪等三善根、及贪嗔痴等诸烦恼所造作。前六识及其相应的心所，缘于外境的顺违，而有造作的活动。外人问的意思是，如果只有内识，而无外境，则心识缘何境而能起惑造业，如果没有惑业，又何能有生死相续？果然如此，岂不是乍生死无因了吗？因有外人此问，唯识家复说下一颂以释其疑：
    [由诸业习气，二取习气具，前异熟既尽，复生余异熟。]
    本颂的重点，在说明生死相续起于内因，非关外缘。生死轮回，起于造业，业就是行为的后果，行为有身、口、意三行，而以意行为主导。由于与意识相应的思心所的造作，而有种种或善、恶的业，这就是‘诸业’。习气，是当造业时其气分回薰藏识，留下了类似于本业的功能，此功能亦名习气，也就是种子的异名。合有漏的善、不善等种子，即称
    [诸业习气’。业是来自与前六识相应的思心所的造作，思心所与善法相应，即造作下种种善业；思心所与恶法相应，即造作下种种恶业。由善恶业所薰习的种子，称为业种子，业种子又名 ‘有支习气’。
    [二取习气俱’ ，二取、即能取与所取。能取即是见分，所取即是相分。取是取著，这二取，都是思想上的一种执著──执见分为实我，执相分为实法，时间长久了，就成为习气。生死相续，由于习气，习气总结为三种，一是名言习气，二是我执习气，三是有支习气。诸业习气的薰习的业种子，与二取习气薰习的二取种子，同时储藏于第八识中。在业习气与二取习气同俱的情况下，而有 ‘异熟果’的生起。这其间，二取习气是生起异熟果的亲因，业习气是生起异熟果的助缘。兹将三种习气意义再加以诠释：
    一、 名言习气：名言即名称言说，有情世间，为了表达思想，构通意见，不免有名称言说。薰习既久，就成为习气。凡表示意义的语言文字，称为表义名言；凡了别境界，用名言描述形容者，称显境后名言。这两种各名言所薰成的种子，贮藏于第八识中，成为一种潜伏的势力，此即为生起诸法的亲因缘。
    二、 我执习气：这是一种执有实我的执著，我执有二种，一为俱生我执，是先天与生俱有的；一是分别我执，是后天卓分别生起者。这两种习气，六七两识都有，起源于与四烦恼常俱的第七识，故第七识为我执习气的根本。此我执习气，也是生死之因。
    三、 有支习气：有支即十二有支，有支习气即是业习气，支者因义，为三有 (三界)之因，能招感三界异熟果，下文将详述。
    以上三种习气，名言及我执习气，属于二取习气，感的是等流果；有支习气即诸业习气，感的是异熟果。
    颂文第三、四句，‘前异熟既尽，复生余异熟。] 由于业习气与二取习气，而招感异熟果 (即生死轮回的阿赖耶识) 的生起，但当一期生命告终，由于业习气与二取习气薰成的种子，又招感来世的异熟果。如此辗展相生，就是有情生死相续的缘由。现在以十二有支的惑、业、苦，来说明有情生死相续的情形：
    一、 无明支：无明即愚痴，即迷暗不明。此无明与第六识相应，就是能造作善恶业的愚痴无明。这是十二缘起的第一支，人生的一切痛苦烦恼，皆由此而生起。
    二、 行支：行是造作的意思，是以无明而生起的蒙昧的意志活动，这种活动 (行) 的后果就是业。无明与行二支，亦可解释为过去世之惑，是过去世所造的业。
    三、 识支：识是认识作用，是精神作用的主体，也是业力寄托的所在，为生命轮回的主体。此支在无所其明的蒙昧意志活动下，纳识成胎，此即一期生命的开始。
    四、 名色支：名色即是五蕴，是精神与物质 (心识与色身) 的合称。色蕴即地、水、火、风四大，名即受、想、行、识四无色蕴，这是第八识‘纳识成胎’后，在母胎中由受精卵起、至六根未具以前的名称 (在五七日以内) 。在此位中，未具人形，状如息肉，故称名色。
    五、 六入支：入亦名处，即十二处中的内六处、也就是眼、耳、鼻、舌、身、意六根。这是由名色支发育成胎儿，六根具备，到出生之前这一阶段的名称。处是生长门义，由根为识的所依，令识得生。第三支的识，指第八识； 六入中的识，指第六识。
    六、 触支：触者接触，内六根对外六境而生六识，曰触，这是认识作用的开始。婴儿初生，天真未凿，爱憎分别之心尚不分明，根境相对，对境的感觉不曰识而曰触。 <分别缘起经> 曰：‘云何六触身，眼触、耳触、乃至意触。]
    七、 受支：受者领纳，即是感受，受有三种，苦受、乐受、舍受，若加忧、喜二受，称为五受。幼儿年龄渐长，有了分别心，六识对六境，就有了苦乐爱憎的感受。
    对苦受厌憎，对乐受贪著，结念不舍，而引起下支的爱。 <分别缘起经> 曰： [受有三种，谓乐受、苦受、不苦不乐受。]
    八、 爱支：爱是贪的异名，也与欲字同义。儿童发育成人，生理成熟，‘贪妙资具淫欲现行。’就是有了性欲的需要，同时，盲目的追求、占有之欲也日益炽盛。 <大乘义章 > 曰： [贪染名爱’。 <涅槃经> 曰： [习近五欲，是名为爱。]
    九、 取支：取者攫取，执持不舍。 <十地经> 称‘爱增名取’，是以贪为体，以爱为缘。由贪心炽盛，对于色、声、香、味、触五尘，财、色、名、食、睡五欲，周遍弛求，执著不舍。
    十、 有支：有是生命的存在，是行为的后果，有也就是业。由感受而有爱憎 (受缘爱) ，由爱憎而有取舍 (爱缘取) ，而取就是攫取、执持、占有，由而积集种种善恶之业，而业力能引生后有的苦果。
    十一、 生支：有即是业，既有业因，必成业果 (异熟果) ，这业果就是生 (转生) 。也就是第八阿赖耶识，受业力牵引，在三是五趣中轮回。
    十二、 老死支：业力是生之因，而老死就是生之果。 <佛说稻芊经> 曰： [住世衰变故名为老，最后败坏故名为死； 追感往事，言声哀蹙，名为忧苦； 事来逼身，是名苦恼； 追思相续，故名为悲，烦恼缠缚，故名为恼。’唯死后业识不灭，无明仍在，在业力牵引下再去投胎受生，开始另一期生命的轮回。
    以上十二有支，在远因近果、和已润未润的因果关系小上，诸支前后相望，在 <成唯识论> 中将其略摄为四支，即能引支、所引支、能生支、所生支。
    一、 能引支：能引支是无明和行二支，由于无明于诸谛理的迷暗无知，而有行的造作诸业，熏习第八阿赖耶识中，能引发识、名色、六入、触、受等五果的种子，故名能引支。 <成唯识论> 曰： [一能引支，谓无明行，能引识等五果种故。]
    二、 所引支：无明与行二支是能引支，由之生起的识、名色、六入、触、受等五支为所引支。 <成唯识论> 曰： [二所引支，谓本识内亲生当来异熟果摄识等五种，是前二所引故。]
    三、 能生支：能生支是爱、取、有三支，能近生当来世生老死果，故名能生。 <成唯识论> 曰： [三能生支，谓受取有，近生当来生老死故，。]
    四、 所生支：在十二有支中，所生支是由爱等五支引生的生、老死二支。从中有到初生以后，至本有中随其寿命长短的未衰变位，皆是生支。诸衰变位随其一期寿命、色心俱衰总名为老。身坏命终，入灭相位，即名为死。 <成唯识论> 曰： [四所生支，谓生老死，是爱取有近所生故，谓从中有，至本有中，未衰变来，皆生支摄。诸衰变位，说名为老。身坏命终，乃名为死。]
    以上十二有支，前十支是因，后二支是果，这十因二果，必定不是同世。若约过去现在世来说，则十因是过去世，二果是现在世；若约现在未来世来说，则十因是现在世，二果是未来世，这称作‘二世一重因果’。小乘佛教以十二有支为‘三世两重因果’，即无明与行二支，是过去世的因，识、名色、六入、触、受五支是现在世的果，这是一重因果；爱、取、有三支，是现在世的因，生与老死二支是未来世的果，这又是一重因果。过去的无明 (惑) 、 行 (业) ，和现在的爱、取 (惑)、有 (业) ，同是惑业，为能感之因，现在侍的识等五支，和未来的生、老死二支，同是所感的苦果，这样亦成为三世两重因果，以此遮去断常二见，故生死相续，轮回无穷。


第十讲 释违教难──三自性与三无性

    第十讲 释违教难──三自性与三无性
    三十颂上一讲，讲的是‘释违理难’──解释违背教理的问难。接著今天要讲‘释违教难’──解释违背教义的问难。释违教难颂文五首，在三十颂中是第二十颂至第二十四颂。此五首颂的内容，说的是唯识的基本宗义──三自性与三无性。今天讲解的方式，是先说明三自性三无性，最后再依照颂文，诠解 ‘释违教难’。
    三自性，即遍计所执性，依他起性，圆成实性。此三自性，为唯识宗一切法义的根本。唐义净三藏撰 <南海寄归内法传> ，有云： [相宗以三性为宗’ 。法相宗以唯识为中道，中道者，即是正显非空非有，简遮偏空偏有之谓。行者审观一切法，无一法偏于有，亦无一法偏于空，无不具备中道妙理。此若约横向而观，即是三自性。 <解深密经、 一切法相品谓> ： [谓诸法相略有三种，何等为三，一者遍计所执相，二者依他起相，三者圆成实相。’ 此中的相字，在此作性字解释。
    在三自性中，以依他起性为中心。诸法皆仗因托缘而起，有情于此因缘和合的假法上，若执著计较，认为是实我、实法，就是遍计所执性； 有情在依他起的假法上，了知诸法缘起，‘缘起性空’，诸法皆无实性，这就是圆成实性。
    若换一个方式表达，遍计所执性，是有情在依他起法上假立名相而起的。这本是情识上的妄有，而有情于此假立的名相上执著计较，这就是遍计所执性。依他起性，诸法是因缘 (众多因条件) 和合而有的，如以水、土和泥而成瓶钵，这是因缘和合的假有，本身没有体性，所以是依他 (因缘) 起性。圆成实性，是依他起诸法的体性，具有圆满、成就、实性三义，也就是真如实性。于此，分述三自性三无性如下。
    一、 三自性
    如上所述，三自性，即遍计所执性，依他起性，圆成实性。兹分述如下：
    一、 遍计所执性：凡夫之妄情，周遍计度种种因缘生起之诸法，执取为实有，曰遍计所执性。 <解深密经、 一切法相品> 曰： [云何诸法遍计所执相，谓一切法，名假安立，自性差别，乃至为令随起言说。]
    三十颂颂文称： [由彼彼遍计，遍计种种物，此遍计所执，自性无所有。] <成唯识论> 卷八，解释此颂曰： [周遍计度，故名遍计，品类众多，故名彼彼。谓能遍计，虚妄分别。即由彼彼虚妄分别，遍计种种所遍计物，谓所妄执蕴、处、界等，若我、若法自性差别，总名遍计所执性。如是自性，都无所有，理、教推征不可得故。]
    释文意谓： 一般人把世间事事物物，都认为是实有，妄执五蕴、十二处、十八界为实我、实法，因而周遍计度。实则这一切都是‘唯识所变’，是有情的虚妄分别所造成的，此谓之遍计所执性。
    十大论师对以上一颂的解说并不一致，难陀分遍计所执性为能遍计与所遍计两门； 而护法、安慧则分为能遍计、所遍计、遍计所执三门。难陀以上颂的首句是明能遍计，其余三句是明所遍计。所谓 <遍计种种物> 者，就是实我实法； 而护法、安慧则上颂首句是名能遍计，次句是明遍计所执之境，而三四句是说遍计所执的实我实法、都是无体性之法。兹分述如下：
    1、能遍计：对所遍计而言，称能遍计。三十颂颂文曰： [由彼彼遍计’，指的即是能遍计之识。‘遍计种种物’是所遍计之境。而‘此遍计所执，自性无所有’ ，即遍计所执性。对于能遍计之识，唯识诸家解释不同，无著认为第六意识是能遍计之识，故 <摄大乘论> 谓： [当知意识是能遍计，有分别故。’而安慧认为八个识都有‘能遍计’的作用。护法、难陀二师认为，只有第六第七两个识是 ‘能遍计’之识。一般以此说为正义。
    2、所遍计：遍计所执之法，虚妄的分别心识，对所缘境周遍计度，分别执为实我实法，此被分别的事事物物，即是所遍计。 <成唯识论述记> 九曰： [此即心外非有法也，即是由有能计心体计有物也。’ 所遍计并不是说心识之外有实境，而是此能遍计之心，误将幻有的事物当作真实。
    二、 依他起性：依他起之‘他’，指因缘而言。即依因缘而生起之万法，曰依他起性。 <解深密经、 一切法相品’谓： [云何诸法依他起相，谓一切法缘生自性，则此有故彼有，此生故彼生。谓无明缘行乃至招集纯大苦蕴。]
    缘生即是因缘生，因缘有四，名之曰‘四缘’。即因缘、等无间缘、所缘缘、增上缘。换言之，因缘即是第八识的种子。三十颂颂文曰： [依他起自性，分别缘所生。] <成唯识论> 卷八解释曰： [众缘所生心、心所体，及相见分，有漏、无漏，皆依他起，依他众缘而得起故。’ 此中众缘，即指四缘而说。
    唯识家以‘万法唯识，识外无境’立论，故客观的万法，皆是主观心识所变的幻影， <成唯识论> 卷八称： [众缘所引自心、心所虚妄变现，犹如幻事、阳焰、梦境、光影、谷响、水月变化所成，非有似有。]
    三、 圆成实性：此为空烦恼、所知二障而显的真理，亦即诸法真实的体性。此亦名真如、实相、法界、法性、皆同体而异名，为圆满成就诸法功德之实性，故名圆成实性。 <解深密经、 一切法相品> 曰： [云何诸法圆成实相，谓一切法平等真如。]
    <成唯识论> 曰： [二空所显圆满成就诸法实性，名圆成实。’又曰： [实相真如，谓无二我所显。’故我空、法空所显示的诸法真实的性质，就是圆成实性。
    三十颂颂文曰： [圆成实于彼，常远离前性。’也即是说，在依他起性上，恒常脱离遍计所执性，就是圆成实性。
    二、 三无性
    三无性，即相无性、生无性、胜义无性。这三无性是依三自性安立的。 <解深密经、无自性品> 谓：
    [汝应谛听吾当为汝解释所说一切诸法皆无自性无生无灭本来寂静自性涅槃所有密意。胜义生，当知我依三种无自性性密意所言一切诸法皆无自性，所谓相无自性性，生无自性性，胜义无自姓性性。………]
    三无自性，如上经文所说。释迦世尊以世间有情，对一切事物皆执有实在的自性，为破除这种妄执，故密意方便，说一切法皆无自性。这是以此三种药，对治三种妄执之病，不是说连依圆的法体也是空无的。密意者，是不显了的意思。换言之，说三无性者，是不了义教。三十颂颂文谓： [即依此三性，立彼三无性，故佛密意说，一切法无性。’ 兹先说明三无性如下：
    一、 相无性：此是依遍计所执性而安立的，以遍计所执之法假名安立，故说相无自性性。此谓一切众生，以妄心于因缘所生之事物，计度有我有法的我相法相，这就成了我执与法执，亦即是遍计所执性。遍计所执之法，如见绳误以为是蛇，而心识浮起蛇相，其相非实有，因此名曰‘相无性’。相无性在说明我、法体相，有如镜花水月，虚幻不实，众生所以认为有实我实法，是由事物的虚假名字而安立的，并没有真实的体性。 <解深密经> 曰：‘善男子，云何诸法相无自性性，谓诸法遍计所执相，何以故，此由假名安立为相，非由自相安立为相，是故说明相无自性性。]
    二、 生无性：此是依依他起性而安立的。即一切诸法，由于仗因托缘而生起，谓之依他起性。此依他起之法既由因缘和合而有，则‘缘起性空’，其无实性可知，其中并无实体，故名生无性。 <解深密经> 曰：‘云何诸法生无自性，谓诸法依他起相，何以故，此由依他缘力故有非自然有，是故说名生无自性性。]
    三、 胜义无自性：此是依圆成实性而安立的。圆成实性即是真如，真如为圆为常，为一切有为法的实性，是绝待的、永恒的理体，为我、法二空所显，自然没有自性。 <解深密经> 曰： [复有诸法圆成实相、亦名胜义无自性性，何以故，一切诸法、法无我性名为胜义，亦得名为无自性性，是一切法胜义谛故、无自性性之所显故，由此因缘名为胜义无自性性。]
    唯识宗立三自性三无性，目的在于显示非空非有的‘唯识中道’。而唯识中道的理论根据，系建立在 <辩中边论> 两首颂上。颂文是： [虚妄分别有，于此二都无，此中唯有空，于彼亦有此。故说一切法，非空非不空，有无及有故，是则契中道。]
    以上颂文的意思是说： 能取者是眼、耳、鼻、舌、身、意六识，所取者是色、声、香、味、触、法六境，而此两者，都是由于识的虚妄分别上而有，实际上这二者都是无，能取和所取都是空。而在此空中，是以识的虚妄分别而有。因此一切事物，有为无为，不是没有，故称非空； 也不是有，故称非不空。非空非不空，就是中道。
    <成唯识论> 卷七曰： [我、法非有，空识非无，离有离无，故契中道。]
    唯识中道有一特点，即是和三自性、三无性结合在一起。唯识家以为，世间万法──一切事物中都有三自性，一切事物中也都有三无性，三自性说明有 (非空) ，三无性说明空 (非有) ，所以唯识家把唯识的终极道理，归之于非空非有的中道。唯识中道，有三性各具中道与三性对望中道二义：
    一、 三性各具中道：唯识中道，是建立在三自性与三无性的基础上。即一切法的每一法，各具非空非有二义。即遍计所执性，情有故非空，理有故非无； 依他起性，如幻故非有，假有故非空； 圆成实性，真空故非有，妙有故非空。以此、则一一法上，各具三性非空非有中道。此名三性各具中道，亦名一性中道。
    二、 三性对望中道：三性对望中道，亦是建立在遍、依、圆三性上。在三性之中，遍计所执性，是我人的虚妄分别，显现于妄情上情有理无的妄法。依他起性，是仗因托缘生起，虽无体性，却有相用，这是假有实无的假法。圆成实性，是诸法的体性，这是实有相无的实法。所以在三性之中，遍计所执是空，依他圆成是有，空有对望，则非空非有。而真空妙有之中道亦由此而建立。此名三性对望中道，亦称一法中道。三性为唯识宗立论的根本，唯识宗以一切不离心为义， <成唯识论> 卷八曰： [三种自性，皆不离心、心所法。谓心、心所及所变现，众缘生故，如幻事等非有似有，诳惑愚夫，一切皆名依他起性； 愚夫于此横执我法、有无、一异、俱不俱等，如空华等性相都无，一切皆名遍计所执； 依他起上，彼所妄执我、法俱空，此空所显识等真性名圆成实。是故此三不离心等。]
    三、 释违教难
    由彼彼遍计，遍计种种物，此遍计所执，自性无所有。依他起自性，分别缘所生，圆成实于彼，常远离前性。故此与依他，非异非不异，如无常等性，非不见此彼。即依此三性，立彼三无性，故佛密意说，一切法无性。初即相无性，次无自然性，后由远离前，所执我法性。
    前面说明三自性及三无性，于此再依颂文，诠解‘释违教难’。兹先解释‘若没有境，则教说的三种自性即不能成立’的问难；继而再解释‘若没有识，则教说的三种无性即不能成立’的问难。
    释违教难，是解释外人对于违背教理的问难。所谓问难，就是外人的质问，外人继违理问难后，又继续质问曰：‘照你们唯识家说，唯有内识，没有外境。如果这样，则依他起的一性就够了，为什么圣教中处处说有三自性？’唯识家解答说：‘应知三自性亦不离识’ 。为什么呢？唯识家以上列五颂的前三颂答之。颂文的初二颂正辨三性，次一颂前三句，明三性的不一不异，末一句明依他圆成证得的前后。后二颂明三无性。分释如下：
    一、 由彼彼遍计，遍计种种物，此遍计所执，自性所无有：此是明能遍计的虚妄分别，遍计、即是周遍计度，遍缘一切境界，又计较推度是我是法。彼彼者，这个能遍计心的品类众多，故说彼彼。‘种种物’，即所逾遍计之境，如实我、实法等。这种若我若法的遍计所执，并没有实在的体性，故说：‘此遍计所执，自性所无有。]
    二、 依他起自性，分别缘所生：依他起的他，指的就因缘。是说色、心诸法，仗因托缘方得生起，故名依他起。色、心诸法生起的因缘有四，就是亲因缘、等无间缘、所缘缘、增上缘，见本文第九讲，此处不赘。色法生起，须籍亲因缘及增上缘二种，心法生起，须四缘俱足，方始现行。因此，说色、心诸法生起，及心体所起见、相二分，都是依他起性。‘分别’即是虚妄分别，也就是有漏的杂染诸法。有义，分别即是缘虑的异名，即依他诸法，是由分别的心、心所及众缘所生起，所谓‘唯识所现，众缘所生’ 者是。
    三、 圆成实于彼，常远离前性：圆成实三字，具有圆满、成就、真实三义。但所谓圆成实，不是在依他起之外另有一个圆成实，而是在依他起诸法上，恒常远离前面所说的遍计所执，便是圆成实了；反之，若于依他起法起种种实我实法执著，就是遍计所执了。
    四、 故此与依他，非异非不异，如无常等性：此三句颂文重点，在说明依他起与圆成实之间，既‘非异’亦‘非不异’之理。因为圆成实性，既然是在依他起诸法上，远离前面的遍计所执，就不能说这两者是‘异’。但这两者之间，也非 ‘不异’。何以故呢？如经中常说无常无我，色法是无常，乃至受、想、行、识亦是无常。这无常法性，遍及于一切法上。因此，无常与一切法是‘非异’；但就总相说虽然不异，而万法各有其别相，总相别相迥然不同，故又 ‘非不异’。因此，依他起与圆成实，若说是‘异’，离开了依他起，就不能显现圆成实的法性；若说‘不异’，那么圆成实同于依他起，岂不是成了生灭之法？
    五、 非不见此彼：此句颂文，是明证见依他起与圆成实的先后。‘此’指依他起，[彼’指圆成实。‘见’者证见，意谓非不见彼圆成实性、而能见此依他起也。换言之，必先以我法二空的观智 (根本智) 证见圆成实，此际已断除我法二执 (遍计所执) ，至此始 (以后得智) 了达如幻如化的依他起。 <成唯识论> 曰： [非不证见圆成实性、而能见此依他起性。]
    六、 初即相无性，次无自然性，后由远离前，所执我法性：颂文‘初即相无性’句，是依遍计所执性而立的。遍计所执只是妄情计度，并没有实在的体相。这有如空华，只是现于病目之前，实无其体相。‘次无自然性’ 句，是依依他起性而立的。依他起诸法是众缘和合而生，既待缘而生，则缘生性空，故曰生无性。‘后由远离前，所执我法性’二句，是依圆成实性而立的，此即胜义无自性。圆成实性是远离前面遍计所执 (我法二执) 所显的真理，此真理离一切相，毕竟皆空，故曰无自性。无自性即是性空，亦曰空性，实则空性就是真如，于下一讲中再详细诠释。


第十一讲 明唯识性──真如

    第十一讲 明唯识性──真如
    在 <唯识三十颂> 的科判中，一般多用相、性、位三分作为讲解的次序。即依三十首颂文，以前二十四首颂文明唯识相，第二十五首颂文明唯识性，第二十六至第三十首颂文明唯识位。于今，前二十四颂的明唯识相，已在第一至十讲中讲解完毕，今日讲第二十五颂── ‘明唯识性’。
    第二十五颂的颂文是：
    [此诸法胜义，亦即是真如，常如其性故，即唯识实性。]
    所谓唯识性──‘诸法胜义’，即是上一颂的末二句‘后由远离前，所执我法性’的圆成实性。而圆成实性也就是‘唯识实性’，同时也就是‘真如’ 。
    真如，是佛法中最高的真理。唯识宗修唯识行，历经三大阿僧祗劫，五位四十一阶，集无量福德智慧，无非是断灭二执、二障，证得我、法二空，转识成智，亲契真如，证得大菩提与涅槃的胜果。于此，我们来探讨这‘真如’究竟是什么。
    本来，如果简略的讲解‘唯识实性’──真如，数百字就可以讲解清楚。但以‘真如’此一概念，在整个佛法中占非常重要的地位，于此特别加以详细的解说。
    一、 真如与缘起
    真如、梵文 Bhuta Tathata、 音译部多多他多，是佛教表示最高真理的概念。要探讨真如，须先自佛陀证悟的‘缘起’说起。缘起又名缘生，这是略称，具足称 ‘因缘起’或[因缘生’。<良贲疏>曰 ：‘言缘生者，缘为众缘，生者起也，诸有为法，皆从缘生’。大致说来，缘生就是缘起，至于具足所称的因缘生，因是 ‘造’ 义，也是 ‘亲生’ 义。 <大毗婆沙论> 曰： [造是因义’， <大乘义章> 曰： [亲生义，目之为因’，这是说，以[因’而能致‘果’，因是能生，果是所生。于此，也把缘生和缘起加以区别。 <瑜伽师地论> 五十六曰： [因名缘起，果名缘生’。
    缘起 Pratityasamutpady，梵文的意思是‘由彼此关涉而生起’、或是‘现象界的生命与世间彼此关涉所由之道’。这就是说： 现象界中，没有孤立存在的事物，都是彼此关涉、对待而生起、存在的。所以原始经典 (杂阿含、 二九三、二九七经等) 上屡说：
    此有故彼有，此生故彼生。此无故彼无，此灭故彼灭。
    这种关涉、对待之间的依存关系有两种，一种是同时的依存关系，一种是异时的依存关系。异时的依存关系，即所谓‘此生故彼生’，此为因而彼为果。同时的依存关系，即所谓‘此有故彼有’，此为主而彼为从。而此因果主从，也不是绝对的，换一个观点来看，因果主从又可以倒置过来。所以 <杂阿含、 四六九经> 中说：
    [譬如三芦，立于空地，辗转相依而得竖立。若去其一，二亦不立；若去其二，一亦不立，辗转相依而得竖立。识缘名色，亦复如是，辗转相依而得生长。]
    这种关涉、对待、依存的关系，就是缘起。缘起的缘，就是事物生起存在的各种条件。因此，宇宙之间没有孤立存在的个体，也没有永恒不变的事物。这些关涉和变化，必须在一定的条件下才能生起、存在、变异、坏灭。因此，所谓‘诸法因缘生，法亦因缘灭]，因就是主要的条件，缘则是次要的条件。
    缘起，有其纵向的和横向的两种关涉对待关系。自纵向关系来观察事物，就有了前因后果的关系； 自横向关系──就时间的某一点上来观察事物，就有了彼此对待的关系。[ 此生故彼生’是纵向的因果关系； [此有故彼有’是横向的对待关系。后世发展的佛教，莫不重视缘起，以缘起为佛教的基本教理。但较多重视纵向的因果关系缘起，而忽略横向相待关系缘起。后来这种横向关涉对待的缘起被称为 ‘实相’Dharmata。实相，即一切事物真实的、常住不变的本性。这是平等的、最高的真理。
    事实上，缘起的本义，就是探究实相。龙树菩萨出世，鉴于小乘有部之说‘法体实有’，而揭示出‘空’的概念。即‘三是偈’所称： [因缘所生法，我说即是空’。空就是诸法实相。因为宇宙之间，没有永恒不变的事物，即凡是由因素条件集合而生起的存在，都具有成、住、异、灭四相，缘集则成，缘散则灭，此即是无常； 而凡是因素条件集合生起的存在，都没有独立的自性 (定性) ，不能决定自己的存在，此即是无我。换一个方式来说，由众多关涉条件生起的事物，其本身并没有一个固定的主体，所以 ‘无我’； 在关涉条件发生变化的时侯，此一法就会变异或坏灭，所以‘无常’。而此无常无我的本性是空──即是‘性空’或‘空性’。而缘起法中即含蕴著空性，所以说 ‘缘起性空’。
    实相──此一切事物真实的、常住不变的本性，也就是真如。即是说，自缘起法来说，一切法都是待缘而生起，故无自性 (也即是无固定不变之性) ，无自性即是性空，这是诸法的本质，是本来如此的、不增不减的法性，这就是‘真如’。
    真如，真者真实，如者如常，此为遍布于宇宙间真实之本体，也即是事物的真实相状、或真实性质。经典中表示真如的名称极多，如 <大般若经> 第三六零卷中，列出了十二名称：法性、法界、不虚妄性、不变异性、平等性、离生性、法定、法住、实际、虚空界、不思议界等，都是真如的异名，真如成了大乘佛教的标志。 <成唯识论> 卷二诠释真如曰： [真谓真实，显非虚妄； 如谓如常，表无变易。谓其真实于一切法，常如其性，故曰真如。]
    二、 二谛四重
    常住不变的真如，就是唯识的实性。对于‘世俗谛’而言，真如是‘胜义谛’，所以颂文称‘此诸法胜义’。这世俗、胜义二谛，乃是佛教的根本大法，诸佛依二谛而说法，众生依二谛而证道。 <中观论> 有偈子云：‘诸佛依二谛，为众生说法，一以世俗谛，二第一义谛，若人不能知，分别于二谛，则于深佛法，不知真实义。不依世俗谛，不得第一义，不得第一义，不能证涅槃。]
    第一义谛，就是胜义谛。何谓胜义谛呢？即圣者所见的真实理性──普遍的空如之理；何谓世俗谛呢？是迷情所见的世间事相──现象界经验面的理法。这二者均非虚谬，故说为谛。唯识宗具明二谛，于世俗、胜义二谛又各立四重，曰世间、道理、证得、胜义。
    <大乘法苑义林章> 卷八，二谛章谓：
    二谛法妙，非略尽言，聊述纲记……总名中，一世俗谛，亦名隐显谛；二胜义谛，旧名第一义谛，亦名真谛。
    列别名者，今明二谛有无体异事理义殊深浅不同，诠旨各别故，于二谛各有四重：亦名名事二谛、事理二谛、浅深二谛、诠旨二谛。
    世俗谛四名者，一世间世俗谛，亦名有名无实谛。二道理世俗谛，亦名随事差别谛。三证得世俗谛，亦名方便安立谛。四胜义世俗谛，亦名假名非安立谛……
    胜义谛四名者，一世间胜义谛，亦名体用显现谛。二道理胜义谛，亦名因果差别谛。
    三证得胜义谛，亦名依门显实谛。四胜义胜义谛，亦名废诠谈旨谛……
    以上四谛，在 <瑜伽师地论> 卷二十五中，又于世俗谛、胜义谛各开为四重，合为八谛。世俗四谛是：
    一、 世间世俗谛： 又名有名无实谛，如假立瓶、钵、军、林、有情、牛马等片名称，而所谓瓶者、钵者，无非是泥土和水而做成；军者、林者，无非是众兵与多树而立名。这些都是因缘和合的假法，唯有假名，并无实体，这是隐覆真理的世俗之法，故名世间； 但凡情认为实有，依情立名，故曰世俗谛，实则有名无实。
    二、 道理世俗谛： 又名随事差别谛，即是五蕴、十二处、十八界等法。这蕴、处、界等法门，是随著众多的事相，及依著众多的义理而安立的，故曰道理； 因事相差别容易了解，故曰世俗，亦名随事差别。
    三、 证得世俗谛； 又名方便安立谛，这是以佛之方便，安立知断恶修善的四谛法门，使行者循苦、集、灭、道四真理依法持，而证得圣果，故曰证得； 以其有相状分明可知，故曰世俗，亦名方便安立。
    四、 胜义世俗谛： 又名假名非安立谛，这是二空真如： 空我而得之我空真如，空法而得之法空真如。这是离诸相 (非安立) 而为圣者所觉，故曰胜义； 唯尚以假相安立，体非离言 (未离假名) ，故名世俗，亦即假名而非安立。
    以上四谛，称为世俗者，世谓隐覆真理，俗为有相显现。谛者实义，有如实有，无如实无，有无不虚，故称为谛。
    于此再诠述胜义四谛：
    一、 世间胜义谛： 又名体用显见谛，此即是世俗四谛中的第二谛、道理世俗谛的五蕴、十二处、十八界的三科等法。以其事相粗显，犹可破坏，故曰世间。此唯圣者后得智所知，胜于世间世俗谛，故名胜义。此亦名体用显现谛，其与第一世俗谛不同者，是有体有用，且事相粗显。
    二、 道理胜义谛： 又名自果差别谛，此即是世俗四谛中的第三谛、证得世俗谛的四谛法门。这是依著知苦、证集、慕灭、修道的染净因果道理而安立的，为殊胜的无漏智境，因胜于前二谛，谓之道理； 这是无漏智的境界，故名胜义。
    三、 证得胜义谛： 又名依门显实谛，此即是世俗四谛中的第四谛的二空真如，这是依二空圣智诠空门观而显的真理，故曰证得； 因为是凡愚所测的圣者之境，胜于前第三俗，故名胜义。
    四、 胜义胜义谛： 又名废诠归旨谛，此即是一实真如，妙体离言，超绝法相，故胜义。此唯根本无分别智所证，胜于前第四世俗。诸胜义中，唯此为最，故在胜义之上复冠以胜义。此谛理须废除言诠，但以正智证会。
    以上四者，称胜义谛者，胜谓殊胜，义有二种，一者境界名义，二者道理名义。谛者实义，是‘事如实事，理如实理。’理事不谬，名之为谛。
    以上所立，是三乘合明的二谛。若唯约菩萨乘而言，则以执为实我实法的瓶钵军林等为第一俗，以蕴处界三科为第二俗第一真，以三自性三无性唯识理等为第三俗第二真，以二空真如为第四俗第三真，以一真法界为第四真。如此建立虽为五重，然真俗相形，又复八重条然不繁也。
    盖真必依俗而真，俗必依真而俗。真者物中之实，若无其物，是为谁实？是故所言真者，即是俗中之真也；又俗者实上之假，若无其实，是为谁假？是故所言俗者，即是真中之俗也。故所以俗事中必有真理，真理中必有俗事，若缺其一，必失其二，独立之法不可得也。是故，并不是遣依他起而证圆成实，也不是没有俗谛就可建立真谛，而是真俗相依而建立的。
    如是世俗胜义各立四重，是明一切诸法，有者有实体，有者无实体。在有实体之中，有为事法，有为理法。在理法中，有因果差别的浅理，有真如的深理。在深理中，有显二空能诠说的是假，离掉假而真证圣智的是真。以有如此的不同，故各立四重，如下表所示：
    一、 无体───────────世间世俗
    二、 有体──事────────道理世俗
    理──浅─────证得世俗
    深─────胜义世俗
    三、 有体──事────────世间胜义
    理──浅─────道理胜义
    深──诠──证得胜义
    旨──胜义胜义
    又有四重相对，如下表所示：
    一、 以有体无体之不同，成第一对──无体────世间世俗
    有体────世间胜义
    二、 以事理意义之不同，成第二对──事法────道理世俗
    理法────道理胜义
    三、 以道理深浅之不同，成第三对──浅理────证得世俗
    深理────证得胜义
    四、 以诠旨各别之不同，成第四对──依诠────胜义世俗
    废诠────胜义胜义
    三、 唯识实性
    三十颂颂文：‘此诸法胜义，亦即是真如，常如其性故，即唯识实性。]
    颂文前两句‘此诸法胜义，亦即是真如。’诸法就是一切诸法，胜义，如上节所释，胜义谛虽有四重，但此处说的胜义，指的是‘二谛四重’中的最后一种， ‘胜义胜义谛]。此胜义谛，是‘体妙离言，回超众法。’是‘语言道断，心行处灭。’是‘废除言诠，但以正智’而证得，所以此‘胜义胜义谛’，就是圣者内证的真如── ‘亦即是真如’。
    颂文第三句，‘常如其性故’，其‘性’，就是诸法的‘实性’。 <成唯识论> 曰：
    [此性即是唯识性，谓唯识性，略有二种：一者虚妄，谓遍计所执；二者真实，谓圆成实，为简虚妄，说言实性。复有二赳种：一者世俗，谓依他起，二者胜义，谓圆成实，为简世俗，故说实性。]
    照以上论文内容看来，三自性中的遍计所执和依他起，都不是诸法实性，唯有此圆成实，才是诸法实性。以唯识方面说，此诸法实性，也这就是唯识的实性。所以颂文第四句说：‘即唯识实性]
    第二十五颂诠释完毕，附带一谈中国大乘宗派对真如的看法。真如本来是依缘起观而建立，以一切法待缘而生，无独立的自性，故曰性空，亦称空性。空性是诸法的本质，为本来如此，不增不减的理体。故真如是静态的、客体的、遍存于一切有的‘真理’。印度佛敌依此义说真如，唯识学亦依此义说真如。是以空宗以诸法空相为真如，有宗以圆成实性为真如。而中国大乘宗派，对真如的认知不同，如天台宗依据性具说，主张真如本身本来具足染净善恶诸法。华严宗依据性起说，主张 ‘本体即现象’，即真如本为万法，万法本为真如。这二者，都是受了 <大乘起信论> 的影响。
    中国真常唯心系的宗派，以 <大乘起信论> 标示一心开二门： [所谓不生不灭，与生灭和合，非一非异。’ 又谓： [真如净法，实无于染，但以无明而熏习故，则有染相……’，这样，真如就不仅是客体性的、静态的理体，亦是主体性的，动态的事用。成为‘不生不灭离言说相离名字相而能生万法之体’ 了。


第十二讲 明唯识位──唯识五位修行

    第十二讲 明唯识位──唯识五位修行
    <唯识三十颂> 的三十首颂文，前二十四颂在于明唯识相，第二十五颂在于明唯识性，最后五颂在于明唯识位。广明前二十五颂的用意，无非是使我人明了世间万法，唯是依他 (因缘) 而起，如幻如化；唯有证得圆成实的真理，始能转识成智，得到大菩提与大涅槃的佛果。然而要证得佛果，须要经过三大阿僧祗劫，修无量福德智慧，断得烦恼、所知二障，证得我、法二空，始能证得大菩提与大涅槃二种胜果。在三大阿僧祗劫的修行过程中，要经过五位、四十一阶位元的层次。
    唯识修行五位，一者是资粮位，二者是加行位，三者是通达位，四者是修习位，五者是究竟位。 <成唯识论> 卷九曰： [云何悟入唯识五位，一、 资粮位，谓修大乘顺解脱分。二、 加行位，谓修大乘顺抉择分。三、 通达位，谓诸菩萨所住见道。四、 修习位，谓诸菩萨所住修道。五、 究竟位，谓住无上正等正觉。]
    又曰： ‘云何渐次悟入唯识，谓诸菩萨，于识相性资粮位中，能深信解； 在加行位，能渐伏除所取能取，引发真见； 在通达位，如实通达； 修习位中，如所见理数数修习，伏断余障； 至究竟位，出障圆明，能尽未来化有情类，复令悟入唯识相性。]
    四十一阶，是十住、十行、十行、十回向、妙觉菩萨。现依次分释五位如下：
    一、 资粮位──乃至未起识，求住唯识性，于二取随眠，犹未能伏灭。
    资粮位，是唯识修行五位中的第一位，这是初步的准备阶段，于此位中修十住、十行、十回向之三十心，以储修道之资粮。
    资粮位，在修道五位中只是方便道。称资粮者，譬如有人远行，必先筹集资财粮食，以备途中所需。修唯识行，亦要先积聚下相当的福德智慧。福德智慧如何积聚，即是发菩提心，行菩萨道。修唯识行菩萨，以四种因缘力闻知唯识道理，但以定慧力量不够，尚不能了达唯识性相，而仍执取外境名言差别，故其所修之行，非禅定、观念等观行，而是客观的散心事相──六波罗蜜、三十七菩提分、四摄、四无量心等福智。三十颂于此位称：
    [乃至未起识，求住唯识性，于二取随眠，犹未能伏灭。]
    <成唯识论> 解释此颂曰： [从发深固大菩提心，乃至未起顺抉择识，求住唯识真胜义性，齐此皆是资粮位摄。’ 又谓： [于唯识义虽深信解，而未能了能所取空，多住外门修菩萨行，故于二取所引随眠，犹未有能伏灭功力，令彼不起二取现行。]
    颂文中未起识的识字，即未起顺扶择分的识。唯识性指圆成实性──真如。二取，是能取所取。随眠，又名习气，亦即烦恼障和所知障的种子。由于初修唯识行，其抉择的智慧尚未生起，未能伏灭二取随眠，故未能住于唯识实性中也。
    二、 加行位──现前立小物，谓是唯识性，以有所得致，非实住唯识。
    加行位，是唯识修行五位中的第二位，意谓加倍努力以积聚修行功德。修唯识行者，在资粮位中，于十住、十行、十回向三十心终，将入见道，勤修四寻思观、四如实智，而得暖、顶、忍、世第一法四善根，这是为入于见道位的方便加行。
    此加行位，迹近见道，故称‘顺抉择分’，即随顺真如境界，生起抉择的智慧。原来在资粮位时，修行者偏于修福，而于加行位，是重于修慧。所以在此位修四寻思观，四如实智观，以伏断分别起的二障、和俱生起的现行二障。
    此位菩萨，虽较资粮位行者观智殊胜，但因尚未起无漏智，在唯识三性观中，难免错观所变的相分为圆成实性。因此不能住于无相真如的唯识实性中。三十颂于此位称：
    [现前立小物，谓是唯识性，以有所得致，非实住唯识。]
    <成唯识论> 解释此颂曰： [菩萨先于初无数劫，善备福德智慧资粮，顺解脱分既圆满已，为入见道住唯识性，复修加行，伏除二取，谓暖、顶、忍、世第一法。此四总名顺抉择分，顺趣真实抉择分故； 近见道故，立加行名，非前资粮无加行义。]
    又谓： [菩萨此四位中犹于现前安立少物，谓是唯识真胜义性。以彼空有二相未除，带相观心有所得故，非实安住真唯识理。]
    在资粮位中，由于二取随眠未能伏灭，故未能安住于唯识实性。在加行位，以修四观四智故，印可二取皆空，似乎真如境界已现于前，但此时还有一点障碍，就是现前立有少物，谓此少物即是唯识实性。然唯识实性，非空非有，虽得而无所得。因此，以有所得之故，犹未能实住于唯识也。
    [四寻思观’，是唯识修行五位中、加行位所修的观法。即是名寻思观、义寻思观、自性寻思观、差别寻思观。名是能诠的名言，义是所诠的义理，自性是名和义的体性，差别是体性上种类的差别。兹再分释如下：
    一、 名寻思观： 名者一切事物的名称，在事物名称上去推求观察，则知所谓名者不过是假名施设，即‘谓于相上有所增语’，然名者实之宾，僧肇法师曰： [以名求物，物无当名之实； 以物求名，名无得物之功。’我人执名求实，徒生种种烦恼。由此推求名是假立，虚妄不实，此谓名寻思观。
    二、 义寻思观： 义者，依名而诠诸法之体相，如山河大地，人牛马羊，十二处、十八界等，这些色心诸法，皆是因缘和合、一时假有，亦即是唯识所变，虚幻不实，由此推求寻思，谓之义寻思观。
    三、 自性寻思观： 自性者，诸法各自之体性。有为色心诸法，皆是仗因托缘，唯识所现，离识非有。由是寻思，悟知诸法名义，自性皆空，谓自性寻思观。
    四、 差别寻思观： 差别者，名与义上的差别相。名之差别，如一言多言； 相之差别，如长短方圆，善恶美丑，一一法上，各有差别，而此差别，皆假有实无。由此寻思，悟知诸法名、义、自性云者，只是假有实空，曰差别寻思观。
    于加行位中，继四寻思观后的观行，是四如实智。即以前之四寻思观所推求的假有实无为因，再加以印可决定的观法。由此可知，‘所取’的名、义、自性、差别等，固然是离识非有，即是‘能取’之识也是了不可得，如此空掉能取所取，即名‘四如实智’：
    一、 名寻思观所引生的如实智。
    二、 义寻思观所引生的如实智。
    三、 自性寻思观所引生的如实智。
    四、 差别寻思观所引生的如实智。
    修四寻思观和四如实智观，要历经‘四加行位’──暖、顶、忍、世第一四位，前二位修四寻思观，观所取空； 后二位修四如实智观，观能取、所取俱空。四加行位又名四善根位，是唯识宗修暖、顶、忍、世第一法四种加行的阶位。
    此四加行，暖是下品的寻思观，顶是上品的寻思观； 忍是下品的如实智观，顶是上品的如实智观。这四种观，是由明得、明增、印顺、无间等四种定而发出的。兹分述如下：
    一、 暖位：<成唯识论> 曰： [依明得定，发下寻思，观无所取，立为暖位。’ 明得定中的明，指的是无漏慧。在此位中，始观名、义、自性、分别四法，都是有情心识所变，假名施设，非有自性，离识即不可得，以此伏断所取之境。
    二、 顶位：<成唯识论> 曰： [依明增定，发上寻思，观无所取，立为顶位。’ 明增，是智慧增长，增长后进一步观察所取境空，修寻思观至此达于绝顶，故称顶位。
    三、 忍位：<成唯识论> 曰：[依印顺定，发下如实智，于无所取决定印持，无能取，亦顺乐忍。’印顺定的印，是印可决定。印顺，是印前顺后，就是印持前面四种寻思智观，观所取名、义、自性、差别四种所取之境，皆空无自体，即能取之心识亦不可得， ‘所所取既无，能取亦空。’印前所取无，印后能取无，称印顺定。
    四、 世第一位：<成唯识论> 曰： [依无间定，发上品如实智，印持二空，立世第一位。’ 在前面忍位中，唯印可能取空； 在此世第一位中，印可能取、所取二空，此于异生法中，最为殊胜，曰世第一法。
    三、 通达位──若于时所缘，智都无所得，尔时住唯识，离二取相故。
    通达位，是唯识修行五位的第三位，这是菩萨的见道之位，于初地之入心 (十地各有入、住、出三心’，通达于二空无我之理，此即见道位。
    有情无始以来，为无明烦恼覆障，因而颠倒妄想，起惑造业，沈缅苦海。自发心学佛以来，历经多劫修行，犹未能认佚识唯识真实义性。不过，于世第一法的次刹那，于十地的初地极喜地，至此通达真实识性，入通达位，即是见道位。此位所见之道，即二空真如，亦即是唯识实性。三十颂曰：
    [若于时所缘，智都无所得，尔时住唯识，离二取相故。]
    <成唯识论> 解释此颂曰： [若时菩萨于所缘境，无分别智都无所得，不取种种戏论相故。尔时乃名实住唯识真胜义性，即证真如。智与真如，平等平等，俱离能取所取相故，能取所取俱是分别，有所得心戏论现故。]
    在加行位时，所修的四观四智，以犹带相故，未能实住唯识。而在此通达位，不但所取之境空，能取之心空，即能观之智亦空。而实证此二空境界之智，就是无分别智，无分别智是诸智的根本，故又名根本智。依于根本智，先亲证法性，即实住唯识──亲契真如，然后即起有分别的后得智。见道菩萨，即以此二智──根本智与后得智，缘真俗二境。
    四、 修习位──无得不思议，是出世间智，舍二粗重故，便证得转依。
    修习位，是唯识修行五位中的第四位，修行者在见道以后，达到第十地的满心佛果之前，重修习妙境以断余障，即是修习位，亦称修道位。
    修行菩萨于见道位，虽然证得无分别智，断除一切心识上的颠倒知见，但微细烦恼尚未断除，还需要修习。故菩萨于此位修十种胜行──即十波罗蜜，断十重障，证十真如，舍二种粗重，由此即能证得转依。即转烦恼障证得大涅槃，转所知障证得大菩提。三十颂称此位曰：
    [无得不思议，是出世间智，舍二粗重故，便证得转依。]
    <成唯识论> 解释此颂曰： [菩萨从见道起已，为断除余障证得转依，复数数修习无分别智。此智远离所取能取，故说无得及不思议，远离戏论，说为无得； 妙用难测，说不思议，是出世间无分别智，断世间故。名出世间。二取随眠，是世间本，唯此能断，独得出名。或出世名，依二义立，谓体无漏及证真如。此智俱斯二种义故，独名出世。余智不然，即十地中无中无分别智。]
    无分别智，是一种能所两空，‘无智、亦无得’的空慧。这种空慧不可思议，是一种出世间的智慧，它能舍灭烦恼障及所知障的种子，以此而证得菩提及涅槃二转依果。
    颂文中 ‘舍二粗重故，便证得转依。’粗重二字，仍是种子的异名。‘转依’，是‘转染成净’。转者转舍，依者依止。转舍去染污的烦恼、所知二障，依止于涅槃、菩提二果。此亦称转识成智──转前五识为成所作智，转第六识为妙观察智，转第七识为平等性智，转第八识为大圆镜智。
    阿赖耶识摄持无漏有漏种子，修唯识行，以修持熏习力，舍有漏种子转为清净种子，至见道位，证二空真如。转染成净后的阿赖耶识，即转舍虚妄的识心，变为清净的智心。转依，即‘转其所依’，唯对‘所依’的看法， <成唯识论’谓有二义：
    一、 第一师义谓： [依谓所依，即依他起，与染净法为所依故，染谓虚妄遍计所执，净谓真实圆成实性，转谓二分转舍转得。’ 据上所说，转依是由虚妄的依他起──即染分的阿赖耶识，转为净分的圆成实。
    二、 第二师义谓： [或依即是唯识真如，生死涅槃之所依故，愚夫颠倒迷此真如，故无始来受生死苦，圣者离倒悟此真如，便得涅槃毕竟安乐。’ 据第二义，谓依即是唯识真如，转舍迷妄颠倒的真如，转证悟的真如而得涅槃。
    转依，有能转道，所转依，所转舍，所转得四种意义。
    一、 能转道：此即是能转舍二障、转得二果的智 (能转道的道、即是智。)此有二类：
    1、能伏道： 即是有漏无漏的加行、根本、后得三智，此智慧伏二障的种子势力而使其不生现行。
    2、能断道： 即是无漏的根本后得二智，此智慧断除二障的种子。
    二、 所转依：即是能转之智，转舍染法，转得净法而成为所依，此亦有二类：
    1、持种依： 即是第八识，此识能任持染净诸法种子，故为所依，而使其转舍转得。
    2、迷悟依： 即是真如，若迷真如则生染法，悟之则生净法； 故为迷悟根本之所依，而使其转舍转得。
    三、 所转舍：即是由能转道所转舍的有漏种子，此亦分为二类：
    1、所断舍： 断舍的即是烦恼所知二障种子。在无漏的真无间道生时，此类种子乃被断舍。
    2、所弃舍： 弃舍的即非障的有漏法、及劣无漏法的种子。这些虽不是障法、而不用断舍，但能持的第八识转为纯净圆明的时候，即不能任持此类种子，而自行将其弃舍。
    四、 所转得：即是以能转道，转舍二障之因而转得者，此亦有二类：
    1、所显得： 显得者即真涅槃，断烦恼而显发者。
    2、所生得： 生得者即大菩提，断所知障而生起者。
    五、 究竟位──此即无漏界，不思议善常，安乐解脱身，大牟尼名法。
    究竟位，是唯识修行五位中的最后一位。修行菩萨于第十地满心金刚喻定无间道，刹那之间，断尽二障种子，并于解脱道永舍劣无漏、及有漏诸法，以证菩提妙果。此即是圆满究竟位。三十颂曰：
    [此即无漏界，不思议善常，安乐解脱身，大牟尼名法。]
    究竟位，事实上就是佛位，佛位是诸漏永尽，清净圆明，故称无漏。界是藏的意思，谓此中含藏无边希有大功德，故曰‘无漏界’。不思议者，佛之法身，不可执有，不可执无，离诸分别，绝诸戏论，故曰‘不思议’。善者微妙之净法，远离生死； 常者尽未来际，恒无变易。
    以上颂文，其中不思议、善、常、安乐，是二转依果体所具有的殊胜德性，是彰显究竟的无漏法界，兹分诠如下：
    一、 不思议： 无漏界、离心缘相，故不可思； 离言说相，故不可议。亦即是二转依的果体──涅槃与菩提，甚深微妙，断绝寻思之境，不可以世间一切譬喻言议，故曰不思议
    二、 善： 纯净法性，离诸烦恼。亦即谓清净法界的真涅槃，离生灭之法； 四智心品的大菩提，妙用无方，而二转依俱有顺益之相，与不善反，故成为善。
    三、 常： 二转依的果体，永不变灭，无有尽期。亦即是真涅槃无生无灭，性不变易；大菩提常住真如，为所依故，故成为常。
    四、 安乐： 清净法界，没有逼恼，亦能使所化有情安乐，故成其安乐。
    颂文 ‘解脱身大牟尼名法’者，解脱身是解脱烦恼障的缠缚而得到的果身。大牟尼、译为寂默。佛果的二障断除净尽，故名解脱身，亦名法身。法身是三身的总称，三身即自性身、受用身，变化身。


一、绪论──介绍唯识宗和唯识二十颂

第一讲 绪论──介绍唯识宗和唯识二十颂

二、唯识二十颂讲记

    第一讲 绪论──介绍唯识宗和唯识二十颂
    唯识二十颂，是大乘唯识宗所依的一部论典。要讲此二十颂，先要介绍这本书的作者、译者、译本，及这本书的中心思想、和内容纲要。同时，还要略述一下此宗的学统。
    在我国，唯识宗是大乘八宗之一，为法相宗的异名。法相宗又名普为乘教宗、应理圆实宗、慈恩宗。由决判诸法体性相状故，名为法相宗。由明万法唯识的妙理故，名为唯识宗。由普为发趣一切乘者故，名普为乘教宗。由所谈的义理，均为圆满真实故，名应理圆实宗。由大唐慈恩寺玄奘、窥基二师所弘传故，名慈恩宗。而此宗的学统，是传自印度的瑜伽行学派。
    印度的瑜伽行学派，是佛陀灭度后九百年倾──西元四、五世纪间，大乘佛教继中观学派之后兴起的一个学派，此学派在西元六、七世纪间，为印度大乘佛教的主流。而此学派的始创人，为无著与世亲二位菩萨。
    无著梵名阿僧伽 Asaga. 是印度笈多王朝 (320─500) 中期的人，住世年代约在西元三六零至四六零年之间。他是北印度健陀罗国富娄沙富城人，出身于婆罗门家庭，父名乔尸迦 Kausika、居国师之位，有子三人，长名无著，次子世亲，幼子狮子觉。无著先在小乘佛教化地部出家，相传他因思惟空义不能得入，曾欲自杀，后得遇宾头罗罗汉为讲小乘空观，他初闻悟入，然犹不能满意，传说兜率天宫的弥勒菩萨，降临中印度阿瑜遮那国的瑜遮那讲堂，为无著说五部大论： <瑜伽师地论> 、 <分别瑜伽论> 、 <大乘庄严论> 、<辩中边论> 、 <金刚般若论> 。唐代遁伦撰著 <瑜伽论记> ，卷一有谓： [慈氏菩萨随无著机，恒于夜分从知足天降于禅省，为说五论之颂......’无著承弥勒之说，集众宣之，由是大乘瑜伽法门传至四方。
    无著的著作很多，时有千部论主之称。他所著的 <显扬圣教论> ，相当于 <瑜伽师地论> 的节略本；而在 <大乘阿毗达摩集论> 则建立了法相学，在 <摄大乘论> 中建立了唯识思想的中心。后来世亲更完成了 <摄大乘论释> 、 <唯识二十颂> 及 <唯识三十颂> 等不朽之作，大成了唯识学的理论。
    世亲梵名 Vasabandhu.音译婆薮槃豆，是无著的异母弟，生卒年代约在西元三八零至四八零年之间。陈代真谛译 <婆薮槃豆法师传> ，称他： [于萨婆多部 (即说一切有部)出家，博学多闻，遍通坟典，师才俊朗无可为俦，戒行清高，难以相匹。’ 据说世亲为了取舍阿毗达摩一系理论，他曾匿名化装，到有部的学术中心迦湿弥罗城，学习有部教理四年，后来回到富娄沙富城，用经量部教义，批判有部，集众宣说。且随讲随写，著为 <阿毗达磨俱舍论> 。此论一出，颇有争论，而无能破之者，时人称此论为聪明论。
    世亲在北印度宣扬小乘，隐蔽大乘，其兄无著悯之，托以疾病，诱其来见，命弟子于邻室宣读 <华严经、十地品> ，世亲闻之，方知其兄苦心。他深悔以往弘扬小乘诽谤大乘的错误，要割舌以谢过。无著对他说： [你先前既用舌头诽谤大乘，现在何不用舌头来赞扬大乘呢？ ’这样世亲乃舍小入大，广造论释，宣扬大乘。世亲约于八十岁的时候，在阿瑜遮那国逝世，时其兄无著逝世已二十余年。他遗留的著作很多，主要者有：<摄大乘论释、 <唯识二十颂> 、 <唯识三十颂> 、 <大乘五蕴论> 、 <百法明门论> 等。
    唯识二十颂、又名唯识二十论、亦名二十唯识论，全文一卷，是唯识三十颂的姊妹作，而出于三十颂之前。世亲菩萨建立唯识宗，是以 <百法明门论> 总其宏纲，以 <唯识三十论> 完成组织。至于 <摄大乘论释> ，重在成立阿赖耶识； <唯识二十论> ，重在破斥邪说，以明唯识无境之理。是故三十论与二十论两部论典，二十论是破而不立，三十论立重于破。所以在‘一本十支’之学──以瑜伽师地论为本论，对阐释本论的五蕴论、百法论、二十论、三十论等称支论──中，二十论是 ‘摧破邪山支’。而三十论则是‘高建法幢支’。
    唯识宗所依的经论，有‘六经十一论’之说。在六经中以 <解深密经> 为主依，在十一论中以 <瑜伽师地论> 为主依。而 <解深密经> 的分别瑜伽品中，已建立了‘万法唯识’的思想。经云：‘世尊！若彼所行影像，即与此心无有异者，云何此心还见此心？ 善男子，此中无有少法能见少法，然即此心如是生时，即有如是影像显现。]
    以上一段经文，如果加以诠释的话，意思是说：一般以为我人所认识的境，是离心外在的。事实上我人所认识、所分别的，都是自已的心识，并不是真有外在的实境。因为外境是我人心识所变现的，所以当心识分别境时，事实上是在分别我人自己的心识。‘此中无少法能见少法’，虽说心分别境时，似乎是有所取，有所见，这是不了解‘万法唯识所现’的人，不知道这仍是分别自心。因此，上一段经文接著说： ‘善男子，我说识所缘，唯识所现故。]
    同时，唯识宗另一部所依的经典 <华严经> ，其中也申明此义。如晋译 <六十卷华严经> 十地品谓：‘此菩萨摩诃萨又作是念：三界虚妄，但是一心作，十二缘分，是皆依心。’ 此在唐译 <八十卷华严经> 十地品中译作：‘此菩萨摩诃萨复作是念：三界所有，唯是一心，如来于此分别演说十二有支，皆依一心如是而立。’ 经文的意思是：一切外境，都是由有情的心识所变现，一切外境诸法，只是虚妄的现象，并没有其实体 (自性) ，所以唯有内识，没有外境。即使是有情 (依于十二有支的) 生死相续，其原因也不是由于外境，而是由内心的贪爱。以上经文，都是建立唯识的理论根据。
    基于以上经论所述，唯识思想的要点，是否定可以做为客观外境的实在性，以建立万法唯识所变的理论，其理论基础可以下列三义说明：
    一、世间万法，由根身以至器界，皆是‘三能变识’之所变现，而第八阿赖耶识储藏的万法种子，实为万法的本源。
    二、三能变识变现时，各各识体上变现出相、见二分，见分是能认识的主体，相分是所认识之境的影像，由见相二分的‘能分别’与‘所分别’，始有宇宙人生的存在。
    三、宇宙人生，因相、见二分而显现，而相、见二分又皆为心识所变现，离此心识即无宇宙人生之存在，此所以成其万唯识之义。
    而唯识二十论的宗旨，即在于破斥外境实有的思想，以成其唯识宗义。二十论所破斥的物件，即是执外境实有的实在论者──其中包括著印度六派哲学之一的胜论派，及小乘佛教的萨婆多部 (即说一切有部) 、经量部、犊子部、正量部、大众部等。这在二十论颂文之后的长行中虽然没有指明，但在唐代窥基大师的 <唯识二十论述记> 中，却有明白的记载。
    唯识二十颂，在我国共有三种译本。最早的译本，是南北朝时代北魏般若流支所译，名 <大乘楞伽经唯识论> ；其次是陈代真谛三藏所译，名 <大乘唯识论> ；最后的译本是唐代玄奘三藏所的 <唯识二十论> 。同时，这三种译本不但在内容上互有出入，在颂文的数量上也不相同。菩提流支的译本，文多颂少，有二十三颂；真谛的译本，文少颂多，有二十四颂；而玄奘所译的，文颂均等，有二十一颂──于正文二十颂之外加一结颂。以上三种译本，均收入大正藏第三十一册。我们现在所使用的，是玄奘三藏的译本。
    玄奘大师是我国的四大译经家之一，也是唯识宗的开创人。他俗家姓陈名纬，河南偃师人，隋文帝开皇二十年生。他有兄长捷，早年在洛阳净土寺出家，奘师亦于十三岁时随兄出家。唐高宗武德元年，与兄同入长安，寻赴成都参访。武德五年受具戒重回长安，从法常、僧辩二大德听 <摄大乘论> ，以诸师所说，各异宗途，圣典亦有隐晦，不知所从，乃欲西行天竺以明之。表请不许，奘师不为屈，乃就番人学书语，唐太宗贞观三年，私发长安，途中历经险阻，历时五年，始抵中天竺，于那烂陀寺，依戒贤论师学 <瑜伽师地论> 及十支论奥义五年。复从胜军居士学 <唯识抉择论> 及 <庄严经论> 等论典二年。
    奘师于贞观十九年回国，由天竺携回梵典六百五十余部，归国后广译经论，先后译出七十五部，一千三百余卷，其中关于法相唯识一系的，有 <解深密经> ， <瑜伽师地论>， <摄大乘论> ， <大乘五蕴论> ， <百法明门论> ， <唯识二十颂> ， <成唯识论> 等多种。奘师唐高宗麟德元年圆寂，享年六十五岁。奘师之后，唯识之学，由其上座高弟窥基大师绍述之，而建立我国的唯识宗。
    唯识二十颂一书，在印度的注释极多，以世亲菩萨的弟子瞿波论为首，共有十余种注释本，其中以护法论师所造的 <成唯识宝生论> 五卷 (唐代义净法师译) ，最为重要。我国注释二十颂的，有窥基大师撰 <唯识二十识论述记> 二卷，新罗圆测撰 <唯识二十论疏> 二卷等。
    奘师译本的文字体裁，是采用似诗非诗的偈颂式，每颂四句，每句五字，共有二十一颂，每颂之后有长行加以解释 (其实这种解释，现代人很难看得懂。) 二十正颂之后的一颂是结叹语，用以结束全文，所以实际上仍算是二十颂。唯二十颂和三十颂一样，也是世亲菩萨假借外人质疑问难，用一问一答的颂文，来解释 ‘唯识无境’的道理，以破斥执著外境实有的小乘外道。
    外人所提出的质疑问难，计有七点：
    一、四事不成难：这是胜论派、大众部、犊子部、正量部、萨婆多部、经量部、顺正理师等的主张，他们以四事为例，而难唯识之理不能成立。他们的意思是：如果只有内识，没有外境，则对外境的认识，有一定的处所、时间，应不能成立；能缘之心具有普遍性也不能成立；世间的奎事物各具有其作用这一点也不能成立。
    二、外人现量难：这是萨婆多部、经量部、大众部等的主张，他们认为诸法的有无，应以现量最为殊胜，如果没有外境，如何有现量的认识呢。
    三、梦境不同难：这也是小乘外道的问难，梦中的境界，我人知其是唯心所变的幻境，但现境..........
    四、二识决定难：外人问：如果唯有内识，无有外境，则在心识之外自然也没存他人与圣教。果然如此，则因亲近善友恶友而闻正邪之法，岂不是不能成立？
    五、梦境业果不同难：唯识家以梦喻现境，但醒时造善恶业有苦乐果，梦中的善恶业何以独无果报呢？
    六、杀业不成难：杀羊之时，若无羊等外境，则不能杀生，或杀生之罪是否成立？
    七、他心智难：他心智，即具有知道他人心意的智慧。若有他心智，则证明他心之存在，如此则唯识无境之义就不能成立。
    以上七难，都是对‘万法唯识，识外无境’之说提出质疑，说明心外实境的存在。世亲针对以上七个难题，一一予以破释，以成其心外无法的唯识思想。
    二十首颂文，如果予以科分的话，可以十二科来讲解，此十二科为：
    一、第一颂：设难生起。
    二、第二、三颂：唯识家举出梦等譬喻，证明‘四义得成’，以成唯识义。
    三、第四、五、六颂：唯识家否定狱卒的实有性以成唯识义。
    四、第七、八颂：解释外人引圣教不成、以成唯识义。
    五、第九颂：略示二无我义。
    六、第十至第十四颂：以一、多破外境实有，以成唯识义。
    七、第十五颂及第十六之上半：破妄执现量以成唯识义。
    八、第十六颂下半颂：示在梦不觉以成唯识义。
    九、第十七颂上半颂：明二识转决定以成唯识义。
    十、第十七颂下半颂：显示睡眠时心坏以成唯识义。
    十一、第十八、十九颂：引意罚为重以成唯识义。
    十二、第二十颂：释他心智不如实以成唯识义
    本文自第二讲起，即依照此十二科分之顺序诠释。


第二讲 诠释第一至第三颂

    第二讲 诠释第一至第三颂
    一、第一颂──设难生起
    论文：安立大乘三界唯识，以契经说三界唯心，心意识了名之差别，此中说心意兼心所唯遮外境不遣相应，内识生时似外境现，如有眩翳见发蝇等，此中都无少分实义、即于此义有设难言。
    第一颂：外人提出‘若有心无境、四事皆不成’的质疑
    颂文：‘若识无实境，即处时决定，相续不决定，作用不应成。]
    论曰：此说何义，若离识实有色等识生识生不缘色等，何因此识有处得生非一切处。何故此处有时识起非一切时，同一处时有多相续，何不决定随一识生，如眩翳人见发蝇等，非无眩翳有此识生，复有何因诸眩翳者所见发等无发等用，梦中所得饮食刀仗毒药衣等无饮等用，寻香城等无城等用，余发等物其用非无。若实同无色等外境，唯有内识，似外境生，定处定时不定相续有作用物皆不应成，非皆不成。
    诠释：本文的绪论中说过，二十颂有三种译本，即北魏般若流支译本，陈真谛译本，唐玄奘译本──即我们现在所用的译本。三种译本中，魏译本有二十二颂，陈译本有二十三颂，唐译本只二十一颂──即正文二十颂，最后还有一首‘结颂’ 。在第一颂之前，魏译本及陈译本各有一‘标宗’颂。魏译本的标宗颂是：‘唯识无境界，以无尘妄见，若人目有翳，见毛、月等事。’而陈译本的标宗颂为： ‘实无有外尘，似尘识生故，犹如翳眼人，见毛、二月等。’而我们现在所用的唐译本，玄奘大师则将标宗颂化为长行，即颂前长行中‘内识生时，似外境现，如有眩翳见发、蝇等，此中都无少分实义。]
    唯识家即根据颂前长行之义，假设外人质疑，以问答方式，说明唯识无境的妙理。我们现在以通俗的语言文字，来诠释这深奥难读的二十首颂文。先释第一颂。
    唯识宗的基本理论，就是‘万法唯识，识外无境’。换句话说，内在的虚妄分别的心识是有，外在的似义显现的境界是无。我人所缘的外境，就像是眼睛有了翳病的人，看见眼前有毛、有两个月亮，其实都是一种幻相。但在外人看来，外境的山河大地，房舍器物，明明是真实质的存在，怎能说是幻相呢？ 因此就有人提出质疑──问难，质问唯识家说：假定照你们唯识家所说，世间一切现像都是心识所变现，没有实在的外境。如果唯有内识，没有外境，那么有四种情况，你们的理论不能够成立：
    一、外境处所决定这一点不能成立。
    二、外境时间决定这一点不能成立。
    三、相续不决定这一点不能成立。
    四、事物作用这一点不能成立。
    主张外境实有者，为什么提以上四个问题？ 因为照唯识家说，外境是心识所变现，没有其客观的实在性。外人以为、如果外境是心识所变现，以上所说的四种情况就不能成立。何以不能成立，兹再一一说明如下：
    一、如果外境是心识所变现，外境处所决定 (即有一定的处所) 这一点不能成立。因为我人所见的外境，都有一定的处所，例如要看阿里山，一定要到嘉义；要看峨嵋山，一定要到四川。如果外境不是实有，一切都是心识所变现，那么有心识的地方就应该有其境现，我们要看阿里山，阿里山即可现在眼前；我们要看峨嵋山，峨嵋山即可现在眼前。可是事实上并不可能，看阿里山必须要到嘉义，看峨嵋山必须要到四川。既然外境有一定处所，唯识所变义就不能成立。反过来说，外境如果是心识所变现，则 ‘处所决定’义就不能成立。
    二、如果外境是心识变现，外境时间决定 (即有一定的时间) 这一点不能成立。我们所见的外境，不但有一定的处所，同时也有一定的时间。例如要看雪、要看梅花，一定要在冬天；要看莲花、要听蛙鸣，一定要在夏天。如果外境非实有，一切都是心识所变现，那么夏天想看雪景和梅花，雪景和梅花就可以现眼前；冬天想看莲花、听蛙鸣，莲花就可以现在眼前，蛙鸣之声可以为我们听到。可是事实并不如此，看梅花和雪景仍然要在冬天，看莲花听蛙鸣仍然要在夏天。既然外境有一定的时间，唯识所变义就不能成立；反过来说，外境如果是心识所变现，则时间决定义就不能成立。
    三、如果外境是心识变现，相续不决定这一点不能成立。相续、是众生的异名，在此处作为人的代名词。人何以称相续，取其轮回生死，相续不断的意思。‘相续不决定’，是说外境既是一个人的心识所变现，应该由他一人所见，不应该众人共见。所以外人第三点质疑的意思是：照你们唯识家说，外境是心识所变现，如果许多人同在一个地方，由于这许多人的业报各不相同，照理说应该是各人的心识，变现出各人所见的外境，可是事实上许多人在同一场所，所见的外境都是一样。这样看来，许多人共见同一的外境，证明外境实有，这样唯识所变义就不能成立；反过来说，如果万法是唯识所变，有识无境的话，则外境由许多人决定，不能由一个人决定 (即‘相续不决定’一句颂文) ，这一点就不能成立。
    四、如果外境是心识变现，事物有作用这一点不能成立。世间万物，各有其作用，如土木砖石用以建屋，米麦粮食用以果腹，如果照你们唯识家所说，外境是心识变现，皆非实有，你们为什么不以土木砖石来充饥，不以米麦粮食来建屋呢？ 可是事实上米麦粮不能建屋，土木砖石也不能充饥。既然万物各有其作用，便是实有的东西，唯识所变义就不能成立；反过来说，外境如果是唯识所变，则万物作用义就不能成立。
    外人以上四点质疑，唯识家如果不能善予解答，不但失去其唯识家的立场，同时唯识之理也不能成立。而唯识家如何回答呢？ 他向却以四两拨千斤的方法，用下一颂四句颂文，来解答问难者的质疑。
    二、第二、三颂──通四难以成唯识义
    第二颂：举梦等四喻，证明四义得成
    颂文：处时定如梦，身不定如鬼，同见脓河等，如梦损有成。
    论曰：如梦意说如梦所见，谓如梦中虽无实境，而或有处见有村园男女等物非一切处，即于是处或时见有彼村园等非一切时，由此虽无离识实境，而处时定非不得成，说如鬼言，显如饿鬼，河中脓满故名脓河，如说酥瓶其中酥满，谓如饿鬼同业异熟，多身共集皆见脓河，非于此中定唯一见，等言显示或见粪等，及见有情执持刀杖遮捍守护不令得食，由此虽无离识实境，而多相续不定义成，又如梦中境虽无实而有损失精血等用，由此虽无离识实境，而有虚妄作用义成，如是且依别别譬喻，显处定等四义得成。
    诠释：第一颂，是外人提出四点质疑──问难，以如果外境是心识变现，则有四事不能成立。这一颂，是唯识家对外人的解答，举出种种譬喻，证明唯识之理正确无谬。于此亦分四点诠释：
    一、处时定如梦：这一句颂文，是解答外人质问：我人所见的外境，有一定的处所、时间，如果外境是心识所变现，则外境有一定的处所、一定的时间就不能够成立。唯识家解答说：我人所见的外境虽然有一定的处所、时间；但人在梦中时，梦中境界不是也有处所、时间吗？ 譬如我们梦中所见，有城市、有乡村，有房屋、有山林；我们在梦中也有白天、有夜间，有早上、有傍晚。梦中的处所、时间等境界，是心识所变现，以此例彼，白天的境界又何尝不是心识所变现？ 假使你一定执著于白天的境界、是离开识而实有，那你就得承认梦中境界亦是实有；如果你以为梦中境界是心识变现，那就得承认白天境界也是心识变现，因为这二者是相等的啊！
    二、身不定如鬼，同见脓河等：这两句颂文，是解答外人‘相续不决定’不能成立的问难。外人质问意思是若外境是心识变现，没有实有的外境，则每一个众生的业力不同，应该各自决定其境界，不应该大家同见一样境界。唯识家解答说：事实上正是如此，众生种类甚多，生在同一趣的众生，由于业力 (共业) 相同，可以见同一境界；不同一趣的众生，所见的境界就不一样。如同为一河之水，人见之为河水，天人见之为庄严地，鱼类见之为其宅窟，饿鬼见之为脓血之河，以其业报不同，所见亦不同。如饿鬼所见的脓河，这在人看来只是河水，可是在饿鬼眼中所见到的，因为他们共业异熟的障碍力，所以看到的是脓血之河。这不是一个饿鬼的所见，而是饿鬼道共同的所见。颂文 ‘同见脓河等’的等字，是包括著共同见到火焰、粪尿，及见暴恶有情、执持刀杖遮捍守护不令得食。所以脓血之河境虽无实，或者说根本是虚幻之境，而[相续] (指鬼道个别有情) 仍旧是同类同见。
    三、如梦损有用：这一句颂文，是解答前颂第四句‘作用不应成’的问难。外人质疑：世间万物各有其作用，如衣以御寒，食以充饥，如果万法都是心识所变现，则万物的作用这一点就不能成立。你刚才说白天也和梦境一样，可是梦中境界是不生作用的。如梦中饮酒不醉，梦中吃饭不饱；而白天却是饮酒会醉，吃饭能饱，你怎可拿梦境和白天相比呢？
    唯识家解答说，梦中境界虽然是心识所变现的幻境，但有时也有其作用，如男女梦淫时，却也能使男女流失精液，损害身体的作用。由此可见，梦境虽非实有，但也有其作用。梦中的境界是唯识所幻现，有其作用，以彼例此，吾人目前所见的境界，又何尝不是唯识所现呢？其实在我人生活中，有许多无有外境，但由心识的想像力 (独头意识的妄想分别)，也会发生作用。如晋时有人，饮酒时发觉杯中有小蛇误吞腹中，因此而生病，后来知道是壁上的弓影映入杯中，他的病也就不药而愈了，这就是 ‘杯弓蛇影’的故事。
    此外如 ‘望梅止渴’、‘谈虎色变’等故事，都是心识想像力发生的用。
    第三颂：再举地狱为喻，总答以上四难
    颂文：一切如地狱，同见狱卒等，能为逼害事，故四义皆成。
    论曰：应知此中一地狱喻，显处定等一切皆成，如地狱言，显在地狱受逼害苦诸有情类。
    谓地狱中虽无真实，有情数摄狱卒等事，而彼有情同业异熟增上力故，同处同时众多相续，皆共见有狱卒狗乌铁山物等来至其所为逼害事，由此虽无离识实境，而处定等四义皆成，何缘不许狱卒等类是实有情，不应理故，且此不应那落迦摄，不受如彼所受苦故，互相逼害应不可立彼那落迦，此狱卒等形量力既等，应不极相怖，应自不能忍受铁地炎热猛炎恒烧然苦，云何于彼能逼害他，非那落迦不应生彼，如何天上现有傍生，地狱亦然，有傍生鬼为狱卒等，此救不然。
    诠释：以上第一颂，是外人提出的四点质疑；第二颂是对四点质疑的解答。此第三颂，是于解答之后的补充意见，来总结质疑者的四个问题。第二颂中已以梦境和鬼道为喻，证明世间一切外境虚假不实；此处再以地狱作譬喻，来证明一切外境是心识变现的幻境，不是客观的实在。
    颂文首句‘一切如地狱]，一切二字是总指外人所质问的四个问题，[如地狱’三字，是举出地狱的譬喻，以地狱有情所见的种种境界，证明我们现在所见的一切境界，都是虚假不实的幻境。地狱，是六道或五趣之一。
    颂文第二句‘同见狱卒等’，总括‘处、时定如梦，身不定如鬼，同见脓河等’三个问题。这是说一切有情，以业力牵引，堕入地狱。在地狱中‘同见狱卒等’ ，等字包括牛头马面的狱卒，铁狗、铁鸟、刀山、剑树、镬汤、炉炭等种种刑具。这一切境界，为地狱一切有情所共见，‘能为逼害事’，地狱中的狱卒，逼害地狱有情，同受断头、剖腹、火灼、水煮之苦，地狱有情受刑时，感觉体肤糜烂，痛苦无比。这一切虽然都是地狱众生共业所感、唯识所现的幻境，但在受诸剧苦时，一切逼真，宛然非假。并且这一切境界，都有其一定的处所及一定的时间。以彼例此，我人现实所见的境界，也是唯识所现，何尝是实有呢？
    原来地狱中狱卒──牛头、马面、铁狗、铁鸟等，逼害地狱有情的境界，都是地狱有情的恶业所感，并不是真正有狱卒刑具等逼害地狱有情。因为地狱中众多有情所见狱卒等的逼害，是他们所造恶业所共变的幻境，并不是真实的。所以唯识家以地狱为喻，来证明我们人间所见的境界，也是人类的共业所感，唯识所变的。
    以上三句颂文：‘一切如地狱，同见狱卒等，能为逼害事。’总答首颂外境处所决定，外境时间决定，相续不决定，万物各有作用四个问题，证明有识无境的唯识之理，皆能够成立，所以说： ‘故四义皆成’。
    狱卒是否真实有情，这在印度各学派见解不一，例如大众部及正量部的学者、就不以狱卒为假有。于是外人针对此点，提出反驳，以狱卒亦为地狱有情。唯识家再予以破解，说明不承认地狱里的狱卒是真有情，有四点理由：一者，这些狱卒并非地狱道所摄，因为它们不和堕地狱的罪犯同样受苦，既不受地狱之苦，怎能说它是属于地狱呢；二者，狱卒在地狱中只逼害地狱罪犯，而不互相逼害，怎能说这些狱卒是真有情，为地狱道摄；三者，如果狱卒和罪犯同为地狱道所摄，则形量不会有大小悬殊，力量也不应有强弱不同，地狱罪犯便不应非常恐怖畏惧狱卒；四者，地狱是受苦之处，罪犯所不能忍受如热铁地等猛烈燃烧的苦楚，狱卒如何能忍受呢？
    唯识家破解后，问难者又提出他的意见：地狱里的狱卒，不妨说它不是地狱道所摄，但并不妨碍它是真有情，它也许是傍生道、鬼道有情，到地狱中去执行刑罚，例如不是天趣所摄的傍生，不是也可以生在天上吗？
    唯识家再以下列第四颂，来破解问难的此说。


第三讲 诠释第四至第八颂

    第三讲 诠释第四至第八颂
    三、第四、五、六颂──唯识家否定狱卒的实有性以成唯识义
    第四颂：以天道傍生作对照、证明狱卒是识所变现
    颂文：如天上傍生，地狱中不尔，所执旁生鬼，不受彼苦故。
    论曰。诸有傍生生天上者，必有能感彼器乐业生，彼定受器所生乐。非狱卒等受地狱中器所生苦，故不应许傍生鬼趣生那落迦。若尔应许彼那落迦业增上力生异大种，起胜形显量力差别，于彼施设狱卒等名，为生彼怖，变现种种动手足等差别作用。如羝羊山乍离乍合。刚铁林刺，或低或昂。非事全无，然不应理。
    诠释：这一首颂文，在魏般若流支的译本中，译作‘畜生生天中，地狱不如是，似在于天上，不受畜生苦。’同样是破解问难者说天上也有傍质疑。据唐窥基大师 <成唯识论述记> 中说，这一首颂，是破当时的大众、正量、及犊子等部的。
    颂文的第二、第三两颂，已经解答了外人质问的四个问题。但外人仍不心服，提出反驳的意见：如果地狱中的狱卒──如牛头、马面、铁狗、铁鸟等，都是唯识所现的幻有，那么天上也有龙、金翅鸟、蟒神、孔雀、凤凰等傍生有情，天上的傍生有情既然是真实的，地狱中的狱卒，为何不许是傍生趣有情到地狱中执行刑罚，为什么一定说它们是心识变现的假有呢？
    ──据佛经上说，欲界的下二层天──四天王天和忉利天，有傍生的存在。这种傍生非天趣所摄，而福报和天人相似，而在天上享受天趣之乐。按，傍生又作旁生，亦作畜生，是六道中的三恶道之一，指鸟兽虫鱼等一切动物而言。
    唯识家针对外人此一问题，提出答覆说：天上的傍生──龙、蟒、孔雀、凤凰等，与地狱中的牛头、马面、铁狗、铁鸟等是不相同的。天上的傍生，是由各自所造的善业，以其善业的因缘，生在欲界天的天道，感受天道的乐果，所以它们是虽不为天趣所摄，却是傍生趣的真有情；而地狱中的狱卒──牛头、马面、铁狗、铁鸟等，它们不是真有情，它们是地狱中受恶业果报的罪苦众生，心识上所变现的假鬼假畜，这怎能与天上真有情的傍生相比呢？
    何以证明地狱中的狱卒狗鸟等是假鬼假畜呢？ 因为它们在地狱中，大火炙之而不热，刀锯临之而不痛，它们是唯识所现的幻像，虽在地狱，而不受地狱之苦，以此证明它们是假鬼假畜。所以颂文说：‘地狱中不尔，所执旁生鬼，不受彼苦故。’它们与天道傍生不同的是：天道傍生 (龙、蟒、孔雀、凤凰求等) 是‘受’──受天道的乐果；地狱中的傍生 (牛马狗鸟等) 是‘不受’──不受地狱之苦。
    ──或有问曰：天上傍生，既然是由各自所造的善业，以善业因缘生于天上，但傍生道是三恶之一，它们既然造了善业，何以又生于恶道？ 其实这也有其因果的关系，这一类傍生，前生或多生前曾得人身，曾行十善，此生以善业成熟，得生天上，但以根性愚痴，所以堕入傍生道 (为傍生道所摄) 。事实上，因缘果报，幽微难知，唯有佛的智慧，始明究竟，我辈所说，都是忆测之词也。
    狱卒是否为真有情，这在部派佛教时代的学派间，有著不同的看法。唯识家以上一颂四句颂文，否定狱卒为傍生有情，问难者又提出转救的意见：你们不承认傍生、鬼趣有情可以到地狱执行刑罚，那么，这些狱卒应该是堕地狱者的罪犯，由于他们的罪业深重，以其‘业增上力’的因缘，感生了非自身所摄的‘别异] (别异，意谓非堕地狱者自身所摄、别一类的四大种。) 离心别有的大种 (地、水、火、风四大种) ，在这离心别有的四大种法上，又生出了或粗或细的形色，成为狱卒的形态。这种具有特殊变化的四大种法，又为了使堕地狱者生起恐怖的心理， ‘变现种种动手足等差别作用’，令罪人受诸痛苦。
    以上这种意见，据说是说一切有部──即萨婆多部的意见。
    第五颂：破有部说业力生及外大种生不应理
    颂文：若许由业力，有异大种生，起如是转变，于识何不许。
    论曰。何缘不许识由业力如是转变而执大种。
    诠释：此第五颂，在北魏般若流支的译本中，译作：‘若依众生业，四大如是变，何故不依业，心如是转变。’此较起来，魏译本意义似乎明显一点。这一颂，这是对问难者提出‘别异’之说的破解，否定地狱中的狱卒为真有情，以成其唯识义。
    颂文的前三句‘若许由业力，有异大种生，起如是转变。’是唯识家听了外人的意见后，即又破斥道：你们说狱卒是由堕地狱者业力所生，这一点我不否认。但你们不承认是由心识变现，我不能同意。若许堕地狱者是由其业力，便有别异大种法的生起，又在这别异大种法上，生起如是的、作为狱卒等活动的种种转变，由业风所吹， ‘变现种种动手足等差别作用’，令地狱罪犯受诸痛苦。那么，这和自已心识变现出假鬼假畜又有何差别？ 既然允许‘业增上力’感生离心别有的‘异大种’ 的转变，又‘于识何不许’其变现？ 为什么只许说业变，而不许说识变呢？
    以上四句颂文，就是破解萨婆多师提出的、以‘业增上力’感生‘别异大种’，再转变出狱卒的形相及活动的一段话。
    问难者见自已的意见又为唯识家所破，乃再提出经量部学者的主张来作为转救：地狱中的狱卒，我们也不以它们是真有情，我们以为这是地狱罪犯过去造作的恶业，由造业时薰习种子藏在识里面，等到堕入地狱受苦果时，先前薰习的业种子，此时以[业增上力’发生作用，感生了离心别有的‘异大种’法，由这别异的四大种上，转变出狱卒的形态、刑罚等种种差别。
    外人提出经量部的意见作为转救，唯识家乃再以下一颂来破解经量部。
    第六颂：破经量部所执薰习余处生果
    颂文：业薰习余处，执余处有果，所薰识有果，不许有何因。
    论曰。执那落迦由自业力生差别大种起形等转变。彼业熏习理应许在识相续中不在余处。有熏习识汝便不许有果转变。无熏习处翻执有果。此有何因。有教为因。谓若唯识似色等现无别色等。佛不应说有色等处。此教非因有别意故。
    诠释：上一颂说到为何只许说业变，而不许说识变呢。话说到这里，外人大又提出经量部的主张作为转救，他们说：地狱里的狱卒，我们也不承认它们是真有情，而是由地狱罪犯造作恶业时，薰成了业种子，这种业力种子相续不断的潜流下去，到种子成熟的时候，就招感狱卒出现的果报。
    能为生因性而生果的种子，诚然是业力薰习而成的，这也是唯识学上的基本理论。但在唯识学上，是以遍通三界的第八阿赖耶识为‘受薰处’，因为阿赖耶识摄持万法种子，受薰的种子储藏于阿赖耶识中，到了种子成熟，因缘具足，而生起受报的现行。而经量部诸师，对受薰处则有不同的意见。因为小乘佛教只说前六识，不知七、八识 (亦不承认有七、八识) ，所以在经量部中有一派，以为六根──特别是前五色根为受薰处 (因为前欲界有情，第六识的活动有间断，而五色根有安定性。) ；又有一派以前后识同类受薰──以后念识为前念识的同类，其类相同，后念识可以受前念识之薰 (这是约无色界有情而说的，因为无色有情无色身，所以业力薰习，只有薰习在识类中。)
    问难者既然提出业力薰习种子的问题，于是唯识家就以第五颂颂文，来破斥经量部的意见。颂文的意思是：你们说堕地狱者先前所造的业，薰习了种子。照道理说，种子应该摄持于识处，生果亦应该由持有业因种子的识处才对。而你们说的受薰处，却是你们所执的‘余处’──五色根或前后念。你们所执的‘余处’，根本不能受薰。
    所以颂文前两句称：‘业薰习余处，执余处有果。但是，‘所薰识 (此处指第八识)有果，不许有何因。 ’── 你们执‘余处’有果，为什么不许 (不承认) [所薰识有果’呢？
    四、第七、八颂──解释外人引圣教不成、以成唯识义
    第七颂：答外人引证佛说为证不能成立
    颂文：依彼所化生，世尊密意趣，说有色处等，如化生有情。
    论曰。如佛说有化生有情。彼但依心相续不断能往后世密意趣说。不说实有化生有情。说无有情我但有法因故。说色等处契经亦尔。依所化生宜受彼教。密意趣说非别害有。依何密意说色等十。
    讲解：这一颂，仍是解答外人的质疑之词。上一颂中，唯识家对问难者说：‘所薰识有果，不许为何因？ ’问难者就说：我这样说，也是依于佛教经典而说的。佛在经典常说十有色处 (就是眼、耳、鼻、舌、身、意内五根处；和色、声、香、味、触外五境处。) 佛既然说十有色处，你们唯识家为什么说唯有内在的心识，没有实在的外境 (即色、声、香、味、触等五境非实有) 呢？ 如果唯有内识，没有外境，佛就不该说十有色处；佛既说有十有色处，你们唯识家就不该说唯有内识，没有外境。不然，你们就犯了 ‘圣教相违过’。
    唯识家怎么回答呢？ 唯识家说：佛在经中确曾说内外处 (内者眼、耳、鼻、舌、身、意六根，外者色、声、香、味、触、法六境，此即十二处) 的教法，佛陀说此十二处教，不是为成立外境实有而说的，那是另有其 ‘密意趣’。目的是在破除凡夫执有[实我’的执著，才说有‘十有色处’。事实上，这只是佛的密意──以善巧方便的意趣而说的，并不是说心识之外一定有实境的色法。并且，佛陀的密意，是 ‘先立后破’──先说‘十有色处’，继而分析诸法缘生无性，实同幻化，使听者以此悟入我法二空之理。
    以上就是对本颂前三句颂文的注释。由于颂文过于简略，常使我们有会错意的地方。如前三句‘依彼所化生，世尊密意趣，说有色等处’的颂文，如果化为长行，意思应该是：世尊以善巧方便，对‘依彼所’应该接受内外处教‘化’ 、而悟入有情无我的众‘生’，而‘密意趣’的‘说有色等’内外处。’最后并举出例子说：‘如化生有情’。
    化生，是胎、卵、湿、化四生之一，化生有情种类非一，此处所说的不是西方极乐
    世界的莲花化生，也不是天道或地狱道的化生，而是‘四有’中的‘中有’化生有情。四有的‘有’，是存在的意思，现实存在的生命体称‘本有’，报尽命终，死亡的时候称‘死有] (死亡只是一期生命告终，仍要转生受报，故仍称有。) 死亡之后、未受生之前称 ‘中有’，正受生时称‘生有’。死后生前的中有，又称‘中阴身]，这也是方便说的。因为有一些凡夫外道，听了佛说‘无我’的道理，就以为人死如灯灭，死后一无所有，这又成为 ‘断灭论’了。世尊以此密意──方便而说‘中有’。
    世尊虽说中有化生有情，是生死之间的联系者，但并不表示中有化生有情是实有，这只是就第八阿赖耶识相续不断义上而假名安立的，当然这也是假有，不是实有。关于这一点，唯识家的见解是如此，经量部也同有此种看法 (其他部派另有不同看法的) ，所以唯识家特举出此‘化生有情’，中有化生为例子，以证明世尊虽说内外十二处的教法，亦像此化生有情一样，是世尊 ‘密意趣’而说的。
    至此，问难者又提出质问的意见：你们说世尊的十二处教，是依‘密意趣’而说的。但是世尊的‘密意趣’究竟是什么呢？ 唯识家乃又举颂以回答对方的质疑。
    第八颂：显佛说色等十处的意趣所在
    颂文：识从自种生，似境相而转，为成内外处，佛说彼为十。
    论曰。此说何义。似色现识从自种子缘合转变差别而生。佛依彼种及所现色。如次说为眼处色处。如是乃至似触现识从自种子缘合转变差别而生。佛依彼种及所现触。如次说为身处触处。依斯密意说色等十。此密意说有何胜利。
    诠释：这一颂的颂文，在陈真谛译本中，译作‘识自种子生，显现起似尘，具成内、外入，故佛说此二。’内、外入，即内、外二种处，内外二处仍然是十色处，故唐译本称：‘佛说彼为十’ 。
    世尊依心识相续不断义，故密意说化生有情。今说色等十处，世尊的意趣何在呢？
    所以唯识家在此一颂中，显示世尊的密意所在。
    [识从自种生’ 一句，是说明心识生起之所依。世尊所说的色等十处──五根、五境，前者为五识之所依，后者为五识之所缘。前五识的生起，一定要有其所依及其所缘，否则、若有根无境，识不得生。而小乘论师，特别是经量师，认为五根、五境是独立的，实有的 (如以五根可以受薰处) 。但唯识家不承认此说，在唯识学上，认为五根五境，都是心识之所变现，离开了能变的识，也就没有根境的存在了。
    所以 ‘识从自种生’句，显示识的生起所依；‘似境相而转’，说明识的自变自缘。前五识的生起，不但要有其自种，同时要内依于五根，外缘于五境，因缘俱足，识始得生，世尊 ‘依斯密意’，立内五处及外五处，‘说色等十’，此即颂文第三四句：‘为成内外处，佛说彼为十。]
    颂文第二句：‘似境相而转’，‘似境相’三字，是显示其似有非有，不是实有，以此‘似’字，否定了‘境相’的客观存在性。
    唯识家以上颂解答问难者质疑后，问难者又提出问题：像你所说世尊佛依‘密意趣’而说十二处教，这十二处教对众生又有什么利益呢？ 唯识家乃再用以下的颂文，解答外人的质问。


第四讲 诠释第九至第十四颂

    第四讲 诠释第九至第十四颂
    五、第九颂──略示二无我义
    第九颂：解释佛说十二处的利益
    颂文：依此教能入，数取趣无我 ，所执法无我，复依余教入。
    论曰。依此所说十二处教受化者，能入数取趣无我。谓若了知，从六二法，有六转识。都无见者乃至知者，应受有情无我教者，便能悟入有情无我。复依此余，说唯识教受化者，能入所执法无我。谓若了知唯识现似色等法起，此中都无色等相法。应受诸法无我教者，便能悟入入诸法无我。若知诸法一切种无，人法无我。是则唯识亦毕竟无，何所安立。非知诸法一切种无，乃得名为入法无我。然达愚夫遍计所执自性差别诸法无我，如是乃名入法无我。非诸佛境离言法性亦都无故名法无我。余识所执此唯识性，其体亦无名法无我。不尔余识所执境有，则唯识理应不得成。许诸余识有实境故。由此道理，说立唯识教，普令悟入一切法无我，非一切种拨有性故。复云何知佛依如是密意趣说有色等处。非别实有色等外法为色等识各别境耶。
    诠释：佛以密意，善巧方便说化生有情，是为除去凡夫外道的断见，故非无益；继而又说十二处色等诸法，这对众生有何利益呢？ 故唯识家以此颂回答：‘依此教能入，数取趣无我。’数取趣，梵语补特伽罗，意译为数取趣，意思是众生随业受果，死此生彼，数取诸趣，故译数取趣，也就是有情的异名。
    原来我人根据自已见、闻、觉、知的活动，误认为有一个‘实我’的存在，此即所谓‘人我执’。 并且对世间万有诸法执为实有，此即所谓‘法我执]。而大乘佛教修行的要点，在转识成智，证得涅槃。要转识成智，须修我法二空观，证得我法二空，始能亲契真如。佛陀为破除众生的 ‘人我执’，方便说有色等十二处。此即第七颂所述，佛的密意是先立后破，先说有十二处，然后再对十二处加以分析，说出十二处色等诸法，是因缘和合的假有，此中并无 ‘我’的成分。此颂的首二句，就令听者‘依此’十二处教，‘能’悟‘入数取趣无我’之理，这就是说十二处的利益。
    人我执已空，但法我执仍然存在。如何能使有情悟入‘法无我’呢？ 那要‘复依]此内外处教之‘余’的其他‘教’法，而去悟入。所谓其他教法，指的是唯识之教。
    唯识之教立‘三自性’，即遍计所执性，依他起性，圆成实性。我人的虚妄分别之心所取的客观境界，我人以为是离心之外实有存在，事实上那只是分别心上所现起的似境影像而已，我人妄执为实有，这就是三性中的遍计所执性。
    唯识家所说的诸法无我，目的是在破除众生所执的外境诸法实有，以显示遍计所之无实自性；但是对仗因托缘生起的依他起法，并不否定其‘如幻假有’，不然，如何建立善恶因果业报差别？ 至于圆成实性，是依他起法的离言法性，是万法的实性，也就是在依他起法上、遣除遍计所执所显的二空真如，这是实有的。
    六、第十至第十五颂──以一、多破外境实有，以成唯识义
    第十颂：破各学派执极微为实有
    颂文：[以彼境非一，亦非多极微，又非和合等，极微不成立。]
    论曰。此何所说？ 谓若实有外色等处，与色等识各别为境。如是外境或应是一，如胜论者执有分色。或应是多，如执实有众多极微各别为境。或应多极微和合及和集，如执实有众多极微，皆共和合集为境。且彼外境，理应非一，有分色体，异诸分色不可取故。理亦非多，极微各别，不可取故。又理非和合，或和集为境，一实极微理不成故。
    诠释：这一颂，主要在破各派所执的‘极微’。什么是极微呢？ 依照俱舍论卷十二所载，色法之极少者为极微，合七极微为一微量，合七微量为一金尘，合七金尘为一水尘，以至于七水尘为一兔毛尘，七兔毛尘为一羊毛尘，七羊毛为一牛毛尘....。极微，也就是物质分析至最微细的程度，非肉眼所能见，就称为极微。但分析至非肉眼可见，没有质碍，邻乎太虚，已不能称是色──物质；但它又是从物质分析而来，又不能说是空──空无所有，毕竟它是色的一部分，无以名之，姑名为极微。事实上，这只是概念上的存在，也就是相当于今日科学上的原子、质子、电子、量子，它是代表物质的最小单位。
    极微学说，不是佛教所创立，在印度的古老时代，哲学家即以地、水、火、风为构成物质世界的质料。如六派哲学之一的胜论派，即谓：‘其地、水、火、风是极微性，若劫坏时此等不灭，散在各处，体无生灭，说为常住。’虽然如此，但后世的各学派，对于极微的见解，又各不相同。所以此第十颂的颂文，就是为破各学派执于极微实有而说的。
    此颂颂文的言外之意，就是唯识家解释了佛说十二处的密意后，问难者又提出问题：你怎知佛说有色等处，是你上面所说的意趣呢？ 安知不是说离识之外，别有实色的外境呢？ 唯识家乃根据对方所问，再予以解答及破斥，现分述如下：
    一、破胜论派：胜论派学者认为极微实有，永久不灭，世界坏空时，极微散布虚空中，作为建立新世界的质料。胜论师又主张，极微的集合体称为‘有分色’，极微是常，有分色性是无常。世界虽由无量数的极微集合而成，但成立之后，便成为一个单位──‘其体是一’，而世界仍是无常，故有成住坏空。唯识家用 ‘以彼境非一’一句话破之。因为极微根本不能成立，如何能集合起来成为一个‘大一’呢？
    二、破说一切有部：有部是多元的实在论者，有部学者亦认为极微实有──所谓‘法体实有，三世实有。’众多极微集合成为‘聚色’。聚色是假，而极微是实，因此我人眼识所缘的色境，缘的是一一的极微，而不是集合的假色。
    ──胜论派和有部的理论，可拿众砖砌墙作譬喻。以众多的砖砌成一面墙，胜论学者眼中所见的，是一整面墙 (其体是一) ，而有部学者眼中所见的，是一块一块的砖，因为他们以砖是实，以墙为假，所以缘的不是整面的墙。
    唯识家对有部的理论不表认同，其理由是：极微等于虚空，无形无相，不是五识所能缘虑。如果能为五识所缘，一定可以再为分割，因此所谓极微，根本不能成立。若说集众多极微、和合而成聚色，则不应理。所以颂文第二句曰：‘亦非多极微’。
    三、破经量部：经量部学者虽然也承认极微为实有，但又认为极微微细，五识不能缘虑，必须集众多极微和合 (和合是泯灭自体的融和起来) 成为‘粗色’，才是五识所缘的境界。这和有部的理论正好相反，有部不承认‘聚色’可缘，五识所缘的是一一的极微；经部则以为极微不可缘，五识所缘的是众多极微和合的 ‘粗色’。如果仍用以砖砌墙为譬喻，有部学者面对墙壁，所缘的是一块一块的砖；而经部学者则以为，墙虽然是砖砌成，但既已成墙，则融和为一，所以五识所缘的是整个的墙，不是一块一块的砖。唯识家所以用颂文的第三句予以破斥曰： ‘又非和合等’。‘又非和合’下面有一个‘等’字，是还有下文，即同时还破斥顺正理师的执‘和集’为境。
    四、破顺正理师：当时还有一个学派，是顺正理师，这是出于说一切有部的一个学派。有部不承认五识可缘‘聚色’的假法，但缘一一极微。所以顺正理师不违自宗，也不承认五识可缘假法。但又不同意经量部的五识能缘粗色的理论。那么顺正理师的理论是什么呢？ 顺正理师承认色法中有极微，极微虽能组合，成为色法，但极微本身是现量境，不是五识所缘；由极微积聚所成的‘和集相] (和集是不舍自体的联合起来) ，是比量境，才是五识所缘的物件色。顺正理师此说，是既不违背自宗， (即承认极微为实有) ，又不触犯经量部，极微非可缘的原则。
    但以上 ‘和集’之说，唯识家仍以为不能成立，即以‘又非和合等’一语破斥之。何以五识所缘的不是‘有分色’，不是‘聚色’，不是和合的‘粗色’，也不是 ‘和集相’？ 因为‘极微不成故’──极微不能够成立。极微为什么不能成立，唯识家则以第十一颂予以说明。
    第十一颂：说明极微不能成立的理由
    颂文：‘极微与六合，一应分成六，若与六同处，聚应如极微。]
    论曰。若一极微六方各与一极微合。应成六分。一处无容有余处故。一极微处若有六微。应诸聚色如极微量。展转相望不过量故。则应聚色亦不可见。加湿弥罗国毗婆沙师言。非诸极微有相合义。无方分故离如前失。但诸聚色有相合理有方分故此亦不然。
    讲解：极微是物质分析到不可再分析的最后单元，这邻乎太虚的单元，有没有方分，是否可与六方相合？ 如果有方分，可与六方相合，那么一个极微仍可分成六分，分后的极微仍可再分下去，如果是这样，则所谓极微者，是但有其名，并无此物，因为它根本不可能存在。故颂文说：‘极微与六合，一应分成六。]
    ──方分，是佛学名词，其实就是体积。凡是物质，以其有质碍性，所以必有体积(即长乘阔乘高的三度空间) ，且占有空间。有体积，必有上下左右前后六接触面，此即颂文中的‘六合’。事实上，古代印度学者分析体积，用的是七分法，即一物分割去六个接触面后，还有中心的一部分，也就是一分为七。所以才合七极微为一微量，合七微量为一金尘。
    如果说极微没有方分 (即以其邻乎太虚，没有体积而言。) 则即使七极微合而为一，合后其量并没有加大，仍然是没有体积。如果是这样，则聚极微集合成粗色的理论就不能成立 (如果极微是零，聚多少零仍然是零。) 粗色仍不能为五识所缘。反之，如果粗色能为五识所缘，则证明极微有方分 (体积) ，极微又可‘一应分成六’了。
    所以颂文的后二句说：‘若与六同处，聚应如极微。]
    唯识家以上一颂说明极微不能成立的理由，外人又以有部毗婆娑师的理论来转救说：和合的东西要有方分，极微没有方分，不能和合，这一点我们承认。但由极微成为各种‘聚色’，聚色是有方分的，可以相合。这时唯识家再以下颂破之。
    第十二颂：破有部毗婆娑师的聚色有和合义
    颂文：极微既无合，聚有合者谁，或相合不成，不由无方分。
    论曰：今应诘彼所说理趣，既异极微别聚色，极微无合聚合者谁。若转救言：聚色展转亦无合义。则不应言极微无合无方分故。聚有分亦不许合，故极微无合不由无方分。是故一实极微不成。又许极微合与不合其过且尔，若许极微有分无分俱为大失。
    讲解：唯识家听了问难者转救的意见，反问难者说：你们说极微无方分、极微无合，聚色有方分，所以聚色有合。可是，聚色是由何物集合而成的？ 聚色是不是由众多极微聚合而成的？ 如果是极微聚合而成，则极微本身就可以合；如果极微无合，从那里来的聚色呢？ 所以用颂文首二句询问：‘极微既无合，聚有合者谁。]
    问难者又自相矛盾的转救说：由于极微无合，所以聚色也没有合的意义。唯识家立刻质问对方：你说极微无方分，所以无合，但聚色有方分，也没有合的意义。由此可见能合或不能合，并不是由于有无方分的关系。纵使极微有方分，同样也不能合。颂文后二句的意思：‘或相合不成，不由无方分。’就是指此而说的。
    第十三颂：再说极微有无方分的过失
    颂文：极微有方分，理不应成一，无应影障无，聚不异无二。
    论曰。以一极微六方分异，多分为体，云何成一？ 若一极微无异方分，日轮□举光照触时，云何余边德有影现？ 以无余分光所不及。又执极微无方分者，云何此彼展轮相障，以无余分他所不行，可说此彼展转相碍，既不相碍，应诸极微展转处同，则诸色聚同一极微量，过如前说。云何不许影障属聚不属极微。岂异极微，许有聚色，发影为障。不尔，若尔聚应无二。谓若聚色不异极微，影障应不成属聚色。觉慧分析，安布差别，立为极微，或立为聚，俱非一实。何用思择极微聚为，犹未能遮外色等相，此复何相，谓眼等境，亦是青等实色等性。应共审思，此眼等境，青等实性，为一为多？设尔、何失？ 二俱有过，多过如前，一亦非理。
    讲解：上一颂后两句，说明极微有无方分，皆不应理。这一颂是就上一颂的意义再加以补充：如果说‘极微有方分’，有方分就有‘六合’──有上下左右前后六个接触面，也就表示可以再自六面分割，如果是这样，则极微就同于聚色，是集合多数更微细的分子而成的，在道理上说就不应是 ‘一’，即颂文所称：‘理不应成一’。
    如果说极微无方分，也不应理，因为无方分即‘无应影无’──意思是无方分即是无体积，没有体积的东西，在光线照射下就没有影子。因为物质有‘质碍性’，光自东来，影自西现，极微没有体积，没有质碍，所以不应该有影。同时，无方分即无障碍 (没有体积当然没有质碍) 。极微既无方分，不但不应有影子，同时也不应该有障碍。所以后两颂文说：‘无应影障无，聚不异无二。’。意思是极微既无方分，则由众多极微集合而成 ‘聚色’，当然也不异于极微，也是无影子无障碍。可是事实上‘聚色’不但有影，并且有障──如我人穿不过墙壁，同一位置放下一张桌子就不能再放下第二张桌子。可见你们说极微无方分是不应理的。
    第十四颂：再说明执外境为一的过失
    颂文：一应无次行，俱时至未至，及多有间事，并难见细物。
    论曰。若无隔别，所有青等眼所行境，执为一物。应无渐次行大地理，若下一足至一切故。又应俱时，于此于彼，无至未至；一物一时，理不应有得未得故。又一方处，应不得有多象马等有问隙事。若处有一，亦即有余，云何此彼可辩差别？ 或二如何可于一处，有至不至，中间见空？ 又亦应无小水虫等，难见细物。彼与粗物同一处所，量应等故。若谓由相此彼差别，即成别物，不由余义；则定应许此差别物，展转分析成多极微。已辩极微非一实物，是则离识，眼等色等，若根若境，皆不得成。由此善成唯有识义。诸法由量刊定有无，一切量中现量为胜。若无外境，宁有此觉，我今现证如是境耶？
    讲解：唯识家在上一颂中，破斥极微实有，问难者至此仍不服输，继续争辩道：你们虽然破斥了极微的实有，但仍不能否定外境的实有存在；比如作为眼识所缘的青等色性，仍然是实有的呀。唯识家反诘问难者：你所说的眼等境相青等是实有，那么青等实性，是‘一’呢？ 还是多呢？ 如果是‘多’，过失如上颂所述；如果是‘一’，那就应该没有‘次行’。即颂文首句：‘一应无次行’ 。
    ──按：‘无次行’ 中的‘行’字，可作两种解释，一作‘行走’解，意指如果大地是‘一’，则举一步就应到一切处。另可作‘识行于境’解。此颂在真谛的译本上，首二句是 ‘若一无次行，俱无已未得’，大正藏本论注云‘已等于以’，这样颂文的意思就是‘若一、无次行’，‘俱无以无得’。若自此‘得’字推究，以 ‘识行于境’为正解。意思是眼睛看见一件事物时，就应该看见一切事物，因为外境是‘一]，既然是‘一’，那么一切事物应该同时看到，在一切事物上，应该没有 (无) [俱时至’或‘未至’的情形。也就是在‘一’ 的境界上，至则‘俱时至’，不至则俱‘未至’。此即本颂次句‘俱时至未至’的意义。但在此句颂文前，应加上第一句中的[应无’两个字，也就是 ‘应无’两个字要重读，全句即是‘应无俱时至未至’。
    颂文第三句：‘及多有间事’，颂文后面长行解释谓：‘又一方处，应不得有多象马等有间隙事，若处有一亦即有余，云何此彼可辨差别。’长行的意思是说：如果外境是 ‘一’，则在同一地方有很多象、马、牛、羊等，而象、马、牛、羊之间，应该没有间隙。象、马、牛、羊相融，和合为一；如此象所到的地方，马、牛、羊亦同到达，反之马所到的地方，象、牛、羊亦同到达。如果这样的话，怎么辨别象、马、牛、羊的差别呢？
    颂文最后一句：‘并难见细物’，细物、指我人目所不见的微小生物，如佛说一钵水中有八万四千虫。如果外境是‘一’，那么我们眼睛所不能见的细物，与彼粗物 (象、马、牛、羊等) 其量相等，也应该为我们肉眼所见。而事实上我们却不能见，因此，你们所执的外境是‘一’，是不能成立的。


第五讲 诠释第十五至及十七颂

    第五讲 诠释第十五至及十七颂
    七、第十五颂及第十六上半颂──破妄执现量以成唯识义
    第十五颂：解释外人现量证境的问难
    颂文：‘现觉如梦等，已起现觉时，见及境已无，宁许有现量。]
    论文：如梦等时，虽无外境，而亦得有如是现觉，余时现觉，应无不尔，故彼引此为证不成。又若尔时有此现觉义，我今现证如是色等；尔时于境能见已无。要在意识能分别故，时眼等识，必已谢故。刹那论者，有此觉时，色等现境亦皆已灭；如何此时，许有现量。要曾现受意识能忆，是故决定有曾受境，见此境者许为现量。由斯外境实有义成。如是要由先受后忆，证有外境理亦不成。何以故，颂曰
    诠释：上一讲的第六节，唯识家将外人所执外境实有的理论攻破，甚至于目不能见的‘极微’，也反覆破解其实有性。或问，极微目不能见，微不足道，何须反覆破解？ 不然，极微是外境一切物质的基础，若极微成立，如何能破得外境实有？ 以‘万法唯识，识外无境’立论，破极微是破外境的根本，所以要彻底破斥其实有性。第十四颂长行解释说：‘已辨极微非一实物，是则离识、眼等色等，若根若境皆不得成，由此善成唯有识义。]
    虽然如此，但主张外境实有的问难者仍不服输，又提出新问题，即第十四颂论文的末段，意思是说：外境是不是实有，要由量智 (即现量、比量、非量的三量) 来判定，而在三量之中，以现量 (即直觉) 最为正确，如果没有外境，又岂能有‘我见此物’的现量智？
    为了答覆此一问题，唯识家以本颂颂文破解。首句颂文：‘现觉如梦等’，现觉就是现量的觉知。外人以为用直觉了解现前之境，在现量的直觉下，觉其为有，就应该是实境了。唯识家却说，现觉如梦一样，梦中并没有实有的境界，但却有梦中的现觉。 ‘如梦等’，等字下面包括眩翳者‘现觉’的空华、第二月等。由此可见，现觉并不能够证明外境的实有。
    不仅如此，即你们所说的现量亦有问题，你们说‘我见此物’，以证明外境实有，但是在六识中，只有前五识是没有分别的‘现量’，这是根、境初接触一刹那的事。
    到了你生起‘我见此物’之念时，能见的眼识及所见的外境已成过去，已堕入第六识的‘比量’了，这时只是第六识就六尘缘影加以追忆、及虚妄分别而已。既然没有现量，何来的外在实境？
    因此，颂文的后三句说：‘已起现觉时，见及境已无，宁许有现量？ ]
    唯识家否定了外人的‘现量’，是同时破斥主张‘六识不并起’的正量部，及主张念念灭‘刹初论’的萨婆多部。问难者此时又提出转救的意见：纵然如你们唯识家所说， ‘现觉’不是‘现量’，是第六识就六尘缘影的追忆，但就是因为有过去的眼等五识‘现觉’的境，现在的意识才能对先所见境生起‘忆念’，若先无所见，现在又何有所忆？ 现在既有所忆，可知过去必有所见。而此能见，即是‘现量’。既有现量，所以外境实有仍是可以成立的。
    唯识家再以下两句颂文破解：
    [如说似境识，从此生忆念。’ 颂文的意思是：我们内识生时，‘似外境现’，作为自已心识的所缘。因此，我人所见的外境，都是自己心识变现的幻境，而不是实境。如果把颂文化为长行，就是： ‘（如） 前所 （说），虽然没有离识的外境，但内（识）生时，（似）外（境）现。如果后念意识（从此）前境，（生）起了（忆念）’，以此来证明外境实有，这种道理是不能成立的。
    八、第十六颂下半颂──方示在梦不觉以成唯识义
    第十六颂：说明梦境未觉不知是梦
    颂文： (如说似境识，从此生忆念) ，未觉不能知，梦所见非有。
    论文：如未觉位不知梦境非外实有，觉时乃知，如是世间虚妄分别串习，昏熟如在梦中，诸有所见皆非实有，未得真觉不能自知。若时得彼出世对治无分别智，乃名真觉，此后所得世间净智现在前位。如实了知彼境非实，其义平等。若诸有情，由自相续转变差别，似境识起，不由外境为所缘生，彼诸有情，近善恶友闻邪正法，二识决定，既无友教此云何成。
    诠释：在上一节中，唯识家以‘如说似境识，从此生忆念。’二句颂文，破解了外人所说的：由于过去五识的现觉，才有现在意识的忆念，以证明外境实有。问难者又翻出了第十五颂 ‘现觉如梦等’的旧帐，说：梦里诚然没有实有的境界，但我们醒过来的时候，立即知道那是梦境。如果我们醒著的时候也和梦中一样，外境不是实有，那么我们为什么不知道呢？
    唯识家以两句颂文回答说：‘未觉不能知，梦所见非有。’意思是说，在梦中没有觉醒的人，是不能知道身在梦中，所见的外境不是实有。必须到他觉醒之后，才知道适才是在做梦，梦中所见的都是幻境。而我们在醒著的时候，以无明蒙蔽，终日间昏昏昧，虚妄分别，和梦中没有差别，怎会知道一切是唯识变现，皆非实有呢？ 这要等到证得出世圣智──证得大觉位的佛果，以般若智光，照破无明，到那时有如梦中醒来，才知道生死迁流，虚妄执境，全是眼中幻翳，妄见空华，无一非假啊！
    唯识家说明有情未到大觉位，不能知道一切时处皆如梦境。问难者又提出两个问题。第一个问题，就是即本颂论文的第二段：‘若诸有情，由自相续转变差别。....]的一段文字。意思是说，如果一切都是有情心识变现，‘似境生起’，不假外境为其所缘，为什么世间的人，那些亲近到善知识，听闻到正法的人，就生起善心而去为善；那些亲近恶知识，听闻到邪法的人，就生起邪念而去为恶。那么，这决定生起正善之识，和决定生起邪恶之识，如果没有善友恶友之教，此二识是如何生起的呢？
    唯识家乃举出‘辗转增上力，二识决定成。’二句颂文，答覆对方所问。
    九、第十七颂下半颂──明二识转决定以成唯识义
    第十七颂： (上半颂) 释增上力仍由识决定义
    颂文：辗转增上力，二识成决定。
    论文：以诸有情自他相续诸识辗转为增上缘，随其所应二识决定，为余相续识差别故，令余相续差别识生各成决定不由外境。若如梦中境虽无实，而识得起，觉识亦然，何缘梦觉，造善恶行，爱非爱果，当受不同？
    诠释：论文中的‘以诸有情自他相诸识辗转为增上缘’一句，此有两种意义：一者，所谓唯识，是‘自他相续诸识’，并不是唯我有识，他人无识，而是无量有情，皆有其八识。 <成唯识论> 中有一段话说：‘奇哉固执，触处生疑，岂唯识教但说一识。不尔如何，汝应谛听....’以下论文语译为：‘如果唯有一识，怎会有十方凡圣，因果差别？ ....说到识，是总显一切有情，各有八识、六位心所、所变现的相见二分 (以此显示色法) ，及分位差别 (此指不相应行法) ，以及由我法二空之理所显的真如 (即无为法) 。此中的八识心王是识之自相，六位心所是与识相应，十一位色法是心王、心所之所变现，不相应行法是以上三法的分位，而无为法是以上诸法的实性。因为诸法皆不离识，所以总立识名。....]
    由上文可知，说唯识，是说各各有情所缘的境界，皆由自己之识所变，并不是说唯有自识，而无他识。基于此说，每个有情的活动，对自己。对其他有情，都是彼此互相增上的。
    再者，另一种意义，所谓唯识，并不是说自己的识之外全无外境，他人识之所变，对自识来说亦名外境。但是诸识缘此境时，并不是直接亲缘此境，亲缘的境，只是自识所变的相分境，他识所变的，但于自识作增上缘。例如你我对话，我听到你的声音，好像是听到外面的声尘之境，其实你的声音，只能作我耳识的疏所缘缘，我的耳识仗此疏所缘缘为本质，再从我自己的识上、变出一个相分声境为亲所缘缘。所以一切有情，虽然受到善知识或恶知识的言教，但他们亲所受的，仍是自识之所变。
    再如 ‘佛以一音演说法，众生随类各得解。’世尊在华严会上演说妙法，诸大声闻如盲如聋，不解一字，由此可见耳识所闻纵然完全一样，意识所领会的则各不相同，如果所听的声音是实境，怎会各人领会的全不一样？
    这就是 ‘辗转增上力，二识成决定’两句颂文的意义。
    唯识家解答了第一个问题，外人又提出第二个问题，即本颂论文的第二段，唯识家乃再以‘心由睡眠坏，梦觉果不同’二句颂文作答。
    十、第十七颂下半颂──显示睡眠时心坏以成唯识义
    第十七颂： (下半颂) 说明梦作不受果的理由
    颂文：心由睡眠坏，梦觉果不同。
    论文：在梦位心，由睡眠坏，势力羸劣，觉心不尔。故所造行，当受异熟胜劣不同，非由外境。若唯有识，无身语等，羊等云何为他杀？ 若羊等死不由他害，屠者云何得杀生罪？
    诠释：外人所质问的意思是：如果梦中境界等于现前境界，现前境界也如梦中境界，为什么醒时造作的善业恶业，会得到苦果乐果之报，而梦中造作的善业恶业，何以不受报呢？
    唯识家以‘心由睡眠坏，梦觉果不同’二句颂文回答。颂文的意思是：一个人在睡眠时，其心以在睡眠中故，心力薄弱，心识缘自识的境界，所以虽造恶业，不受苦果；虽造善业，不受乐果。而醒时不然，醒时的心识，势力增强，缘境明了，可以自我控制，自作主张，所以为善便是善，为恶便是恶，以其强盛的心力薰习种子，所以能感果受报。这仍是在 <唯识二十论述记> 中一段文字，可以作此颂文的注解：‘四不定中，睡眠心所，能令有情身分沉重，心分昏昧，在寐梦中，为此所坏，令心昧故，虑不分明，势力羸劣。其觉时心，既无眠坏，缘境明了，势力增强，不同梦位，故此二位所造善恶当受异熟，非梦果胜，梦果乃劣。非曰外境，其果不同。]
    唯识家说明梦中造作，以心力昏昧，势力羸弱，不受果报。这时问难者乃再提一个问题质疑唯识家：‘若唯有识，无身语等，羊等云何为他杀？ 若羊等死不由他害，屠者云何得杀生罪？ ]
    唯识家乃再以下一颂文来解答。


第六讲 注释第十八至第二十颂

    第六讲 注释第十八至第二十颂
    十一、第十八、十九颂──以引意罚为重以成唯识义
    第十八颂：解答若无外境应无杀罪的诘难
    颂文：‘由他识转变，有杀害事业，如鬼等意力，令他失念等。]
    论文：如由鬼等意念势力，令他有情失念得梦、或著魅等，变异事成。具神通者意念势力，令他梦中见种种事。如大迦多衍那意愿势力，令娑婆刺拿王等，梦见异事。又如阿练若仙人意愤势力，令吠摩质咀王梦见异事。如是由他识转变故，令他违害命根事起，应知死者为众同分，由识度变异相续断灭.
    诠释：在第十节之末，外人所提出的质疑，是两个问题。第一个问题即论文所说：‘若唯有识，无身语等，羊等云何为他所杀？ ’外人的意思是：假如照你们唯识家所说，只有内识，没有外境。如果真是这样，也就没有身业语业可言了。如果没有身和语的活动，那些猪羊鸡鸭等家畜家禽，云何为他人所杀？
    唯识家以颂文‘由他识转变，有杀害事业’二句作答。意思是说：‘由他’──即行凶者或屠宰著，以其心‘识’的‘转变’力量，然后才会 ‘有杀’生‘害’命的‘事业’。换句话说，在身、语、意三业中，以意为主导，由于先有杀害的意念，然后才有杀害的行动。同时，当屠杀者要屠杀猪羊鸡鸭的时候，其杀害的心念，有强盛的势力，由其强有力的心念活动，影响到弱小的被屠杀猪羊鸡鸭的心识活动，使它们生起被杀的恐惧心理，以它们自已所生的心念变异，生起被宰杀死亡的感觉，使生命趋于灭亡。所以这杀生罪，是由双方势力强弱不同的心识交织而成。当然，杀生者也承受杀生的罪业。这就是 <二十论述记> 所释：‘由能杀者，为增上缘，起杀害识，转变力故，令所杀者，有杀害己断命事成，故能杀者得杀生罪。]
    唯识家答覆后，再举出譬喻来证明：‘如鬼等意力，令他失念等。’颂文中‘鬼等’的等字，约指有神通者如天神、龙神、仙人等，当他们忿怒时，以其意念势力，恼害其他有情，使之精神失常、颠狂迷乱，甚而 ‘鬼等’意业增上，能使被害者丧命，而成就杀业。这就是第一段论文所称：‘如由鬼等意念势力，令他有情失念得梦，或著魅等，变异事成。’的意义。
    论文中说： [如大迦多衍那意愿势力，令娑婆剌拿王笃等，梦见异事；又如阿练若仙人意愿势力，令吠摩质咀利王梦见异事。’在这一段文字中，包括著两个印度古代故事，分述如下：
    一、 <中阿含经> 记载：娑婆罗那王，容貌端正，自谓天下无双，他想找人来比较，以显自已的殊胜。有人对他说：王舍城的大迦旃延形容甚好，世间无比。娑婆罗那王遣人迎之入宫。大迦旃延到了宫中，人人争看大迦旃延，没有人再看罗那王了。罗那王问何以如此，众人说迦旃延容貌胜大王。罗那王问迦旃延，以何因果各得殊胜容貌呢？ 迦旃延说多生前我出家，大王是乞丐，一天我在寺中扫地，大王来乞食，我扫地竟，令大王除粪，除粪后方与王食。以此业因，生人天中，各得容貌端正之报。罗那王闻之，即出家为迦旃延弟子。
    后来二人在阿槃地国山中修道，罗那王在山中另一处坐禅。一天阿槃地王钵树多，带著宫女入山游戏，宫女见罗那王容貌端正，围绕著看他。钵树多王看见，疑罗那王调戏他的宫女，令人鞭打得他身破闷绝而死。到夜间醒来，到迦旃延处，迦旃延为他疗伤，罗那王对迦旃延说：我向师请假，暂回本国，集全军队攻破阿槃地国，杀钵树多王，事毕回来依师修道。
    迦旃延答应了，并劝他留宿一夜，明日再走。罗那王睡到夜间，梦见集合了军队，征阿槃地国，不幸兵败被俘，被敌方红花插头，要斩首示众。罗那王梦中大叫，迦旃延叫醒他，对他说：你若征阿槃地国，必当兵败，如梦中所见。迦旃延复对他说：一切诸法，譬如国土等，都是假名无实；离开了房屋田地就没有国土，离开了砖石木柱等就没有房屋，乃至于说到极微亦非实有，无彼无此，无怨无亲。罗那王听法后，不再兴兵报仇，一心修道，后来证了阿罗汉果。
    二、 <中阿含经> 记载：有七百仙人住在阿练若 (阿练若，义译为闲寂，就是旷野之处，住在旷野处的仙人，名阿练若仙人。) 一时，天帝释来到此处，众仙人皆来恭敬帝释。时毗摩质多罗阿修罗王 (即吠摩态质咀利王) ，亦变为帝释到仙人处，而仙人对他并不恭敬。他心中愤恨云：汝等何故但敬帝释，而轻蔑我？ 诸仙忏谢，而毗摩质多罗王愤恨不已，不受众仙忏悔。这时众仙以心念之力，使毗摩质多罗王 ‘即大困苦’遂生悔心，惭谢诸仙，‘仙等心念，放赦其僭失’，毗摩质多罗王恢复正常。
    这个故事，经中说是使毗摩质多罗王‘困苦’，而本颂论文说使阿修罗得梦，故事不同，意义相似，都是强调‘意念’的力量。
    第十九颂：举仙人忿怒故事证明意罚为大罪
    颂文：弹诧迦等空，云何由仙忿，意罚为大罪，此复云何成。
    论文：若不许有他识转变增上力故，他有情死，云何世尊为成意罚是大罪故，返问长者邬波离言，汝颇曾闻何因缘故，禅宅迦末蹬林羯陵伽林，皆空闲寂？ 长者白佛言，乔答摩，我闻佛言，竟愤恚故。若执神鬼敬重仙人，知嫌为杀彼有情类，不但由仙意愤恚者，云何引彼，成立意罚为大罪性过于身语。由此应知，但由仙忿彼有情死理善成立。若唯有识，诸他心智知他心不，设尔若失，若不能知，何谓他欠心智；若能知者，唯识义应不成。虽知他心然不如实。
    诠释：这一颂，是唯识家说明了杀害的事业是由于‘意力’，恐外人犹不信服，所以用反诘的语气，再说此颂文加以补充。颂文中‘弹坨迦等空’一句，弹诧迦，有译为檀陀柯，意为‘治罚’ 。等字后面还有摩登伽和、羯陵伽，这也是出自 <中阿含经> 的故事。檀陀柯是一个国王的名字，他国内有一仙人，名摩登伽，在山中修行。他有妇为婆罗门女，极有容貌，每日到山中为摩登伽送饭。一日檀陀柯王到山中游戏，见此妇人，问是何人，随侍答是仙人妇。檀陀柯王说：仙人离欲，为何有妇？ 就把妇人带回宫中。仙人等不到妇人送食，借问他人，他人告知国王带到宫中去了。仙人到王宫中向王索妻，王坚不还，仙人告诉妇人说：你一心念我，勿暂舍我，今夜使此国土破坏。到了夜间，仙人以念力使天两大石，国王及国人皆死，国土成为废墟。而妇人以心念仙人，得以不死，又回到仙人身边。颂文 ‘弹诧迦等空，云何由仙愤。’说的就是这个故事。
    这个故事之后，还有还有两个类似的故事，大意都是由于仙人忿怒，以其‘意力]，使国土为墟。故事大意类似，就不再详述了。
    下半颂中，也有一个故事，是解释论文中‘云何世尊为成意罚是大罪故’一句。
    此故事也出自 <中阿含经> ，大意是说、六师外道之一的裸体外道 (以裸形涂灰作为离系修行的方法) ，有一个名阇提佛多罗者，他的弟子长热，往至佛所。佛问长热：
    你师父平常对教导你们，在三业中，他说那一业的责罚为大罪呢？
    此外道回答：我师父说，在三业之中，以身业责罚最重，口业次之，意业最轻。
    长热问佛：‘瞿昙今说何业为重名？ ’
    佛说：我认为，在三业中，意业的责罚最重，其次是口业，再其次才是身业。长热外道回去，将佛陀的意见向他师父报告。阇提佛多罗不以为然，就派遣一位邬波离长者，到佛陀处，和佛陀辩论，欲破佛说。邬波离立下论题：
    [我立三罚身为最重，次口、后心。瞿昙为何说心罚为重？ ]
    世尊这时在眉□罗国，这是一个人口众多的国家。佛问邬波离：‘若人行杀，几日可以杀尽此国的人？ ]
    邬波离答：‘或七日，或十日，或一月。]
    佛再问：‘如果仙人起嗔心杀，几日得尽？ ]
    邬波离答：‘一时国人皆尽。]
    佛又问：‘若有人长时行于布施，有人多时持戒，有人一时入八禅定，入无漏观，何者最胜？ ]
    邬波离答：‘入禅无漏功德最胜。]
    佛语长者：‘既然如此，你何以说身口罚重，心罚最轻呢？ ]
    经过一番辩论后，邬波离长者自知理屈，乃皈依佛陀，为佛弟子，后来并证了果。
    以上几则故事，都是印度古代流传下来，家喻户晓，并且深信不疑，所以佛陀才举此为喻。
    唯识家举出种种譬喻，说明‘意罚为大罪’后，外人又提出最后一个问题：[如果唯有内识，没有外境，你们所说的‘他心智’，知不知道他心呢？ 如果不能知，还叫什么他心智？ 如果知道，那么他人的心念就是外境，怎能说是唯识呢？ ]
    唯识家乃再以下一颂破解外人的质疑。
    十二、第二十颂──释他心智不如实以成唯识义
    第二十颂：释外人所举他心智不成难
    颂文：他心智云何，知境不如实，如知自心智，不知如佛境。
    论文：诸他心智，云何云何于法不如实知。如自心智，此自心智云何何于境不如实知。由无知故，二知于境各由无知所覆蔽故。不知如佛净智所行不可言境，此二于境不如实知，由似外境虚妄显现故，所取能取分别未断故。唯识理趣无边抉择品类差别，难度甚深，非佛谁能具广抉择。
    诠释：他心智，是知道他人心意的智慧，此又称为他心通，即六神通之一。如果仔细解释，即是以他心为本质，在自心上变起一种似于本质的他心影像，而为自心所缘。 <成唯识论述记> 解释说：‘以他心为质，而自变演，名他心智，非能亲取他心等故，名他心智。’这主要是说‘非能亲取他心’ 。自心智，自然就是知道自己心意的智慧了。外人质疑的意思是：若有他心智，就证明有他心的存在，如何能说是心外无境呢？
    ──同样的，自心智也不能亲取所缘，也是变相所缘。 <成唯识论述记> 卷四解释说：此自心智，说见分者，前后许自变相缘故。非自证分，名为自心智；彼如实知，无异解故。’这即是说，自心智是指 ‘见分’而说的。
    颂文前二句是外人所问：‘他心智云何，知境不如实。’──他心智为何不能知道他人的心事呢？ 唯识家告诉他说，具有他心智的人，不知不能如实的知道他心，亦不能如实的知道自心。何以故呢，因为它被无知 (即无明) 所覆蔽，致不能如实知道自心；同样的，了知他人心意的他心智，由于‘法执’的障碍，不能如实的知道他心。
    不但凡夫不能如实的知自心他心，就是二乘及菩萨，在未成佛以前，自心亦不能真知自心。这就像我人不知佛的境界一样。这就是第三、四句颂文的意思。由此颂可知，在未证佛果前，自心、他心、佛境，都是难可了知。然则所谓他心智云者，无非是随方便而说的。
    外人至此不再提出问题，‘二十颂’也至此结束。在二十首颂文之后，还有一首‘结颂’，是世亲菩萨以自谦及赞佛的语气作一结颂，以结束本文。结束的大意是：唯识的义理，甚深微妙。这种甚深的理趣，是诸佛胜智所行的境界，不是我辈所能尽知的。我已随自己的能力，约略的成此唯识大意，至于更深的义理，那是唯佛所知的。
    颂文曰：
    [我已随自能，略成唯识义，此中一功种，难思佛所行。]


简明成唯识论白话讲记序

序言

三、简明成唯识论白话讲记

    序言

    成唯识论，是我国法相唯识宗的基本论典。

    我国的唯识宗，源自印度的瑜伽行学派。佛典上说，释迦世尊灭度九百年顷，无著论师出世。他梵名阿僧伽，住世于印度笈多王朝（320｜500）时代，他是北印度健陀罗国富娄沙富城人，出身于婆罗门家庭，父名憍尸迦，居国师之位，有子三人，长即无著，次名世亲，幼名师子觉。无著先在小乘佛教化地部出家，相传他因思惟空义不能得入，曾欲自杀，后得遇宾头卢罗汉为讲小乘空观，他初闻悟入，然犹不能满意。据说天宫兜率内院的弥勒菩萨，应无著之请，在中印度阿瑜遮那国，为无著说《瑜伽师地论》、《分别瑜伽论》、《大乘庄严论》、《辩中边论》、《金刚般若论》五部大论，无著承弥勒之说，造对法、显扬等论，集众宣之，广弘此宗。此宗以《瑜伽师地论》为主依论典，故后人称之为瑜伽行学派。

    无著之异母弟世亲，梵名音译婆薮槃豆，于说一切有部出家，博学多闻，遍通内外之学。据说他为了取舍阿毗达磨一系的理论，曾匿名化装，到有部的学术中心迦湿弥罗城，学习有部教理四年，后来回到富娄沙富城，用经量部教义批判有部，集众宣说。且随讲随写，著为《阿毗达磨俱舍论》。此论一出，颇有争论，而无能破之者。世亲在北印度宣扬小乘，隐蔽大乘，其兄无著悯之，托以疾病，诱其来见，命弟子于邻室宣读《华严经十地品》，世亲闻之，方知其兄苦心。他深悔以往诽谤大乘的错误，要割舌以谢过。无著对他说：‘你先前既用舌头诽谤大乘，现在何不用舌头来赞扬大乘呢？’这样世亲乃舍小入大，广造论典，如《摄大乘论释》、《辨中边论释》、《唯识二十论》、《唯识三十颂》、《大乘五蕴论》、《百法明门论》等多种。

    世亲所造的论典中，特别是《唯识三十颂》一卷，集唯识教义之大成。原来印度古人造论，是先作本颂，总括全书要义，然后依颂作释，名曰长行，长行是论著的正文。而《唯识三十颂》一书，是世亲晚年之作，长行未作而已示寂。此际瑜伽行学派的理论已成为大乘佛教的主流，研究者极多，世亲寂后的百余年间，许多学者竞为三十颂作释论，其中最著名者十位，后世称为十大论师。十大论师的名字是亲胜、火辨、德慧、安慧、难陀、净月、护法、胜友、胜子、智月等人。

    我国的唯识宗，创始自唐代玄奘、窥基二位大师。唐太宗贞观三年，玄奘三藏西渡流沙，周游五印度十有七年，于中印度那烂陀寺，依护法论师的弟子戒贤，学《瑜伽师地论》及十支论奥义，复从胜军居士学《唯识抉择论》等论典二年。于贞观十九年回国，由印度携回梵典六百五十余部。归国后广译经典，先后译出经论七十五部，一千三百余卷，其中关于法相唯识一系的，如《解深密经》、《瑜伽师地论》、《摄大乘论》、《显扬圣教论》、《大乘五蕴论》《百法明门论》、《观所缘缘论》、《唯识二十论》、《唯识三十论》等多种。其中特别是《成唯识论》一书，系以十大论师的释论百卷，揉译为识论十卷。为我国唯识宗的基本论典。

    玄奘大师的入室弟子窥基，俗姓尉迟字洪道，唐代京兆长安人，为开国勋臣之子，出生于唐贞观六年。他禀性聪慧，体貌魁伟，年十七岁奉敕出家，为玄奘弟子，依玄奘学佛教经论及天竺语文。二十五岁参与译经。唐高宗显庆四年，玄奘译《成唯识论》，原拟将十大论师的释论各别全译，并命窥基、神昉、嘉尚、普光四人，分别担任检文、笔受、纂义工作，数日之后，窥基请求退出，奘师固问其故，窥基言：‘群圣制作，各驰誉于五天，虽文具传于贝叶，而义不备于一本，情见各异，禀者无依，请错综群言，以为一本……’。奘师乃礼遣三贤，窥基独任笔受，译出《成唯识论》十卷，故此十卷雄文，虽称揉译，不谛新造。

    但是法相唯识之学，是一门极为艰深，极为繁琐的学问。唯识经论，可说是‘文如钩锁，义如连环’；亦可说是‘字包千训，言含万象。’以现代人的语文训练，不要说不了解它的意义，甚至于读不通它的句子。特别是十卷《成唯识论》，它一方面字字珠玑，是发堀唯识妙理的宝藏；但另一方面，它揉集十家之说，破斥多家外道及小乘异说，所以在行文之时，有如枝上岔枝，叶旁长叶，顺著枝叶走下去很难再回到原点。据说清末状元夏同和语人，他初读《成唯识论》，自谓有如月下看花；再读《成唯识论述记》，直似堕如五里雾中，由此可见唯识之学，是一门‘甚深最甚深，微细最微细，难通达极难通达’的学问。

    笔者十余年来，滥芋于南北佛学院、所，讲授唯识学一系列的课程。但当讲到《成唯识论》时，发觉有些同学视此门课程为畏途，并且市面上也买不到诠释此论的参考书（坊间有售每套五大本、演培老法师的《成唯识论讲记》，售价千余元，不是一般学生所能买得起的）。笔者为解决学生用书困难，发愿以简单明了的方式，把此一钜著语译出来，命名曰《简明成唯识论白话讲记》。穷两年之力，语译完成，与台北佛陀教育基金会简丰文、林国营二位居士谈及此事，他二位认为此书可由基金会印出，普遍赠人结缘。这是这本书问世的因缘。

    《识论》一书，素称难读，其中隐晦难解之处极多。笔者不自量力，贸然语译，缪误之处，在所难免，尚祈方家赐正，无任铭感。

    公元二ΟΟ二年十二月于凌波序于台中雪庐纪念讲堂


第一章　归敬颂与造释愿由

    第一篇　释归敬颂．释难破执．标宗归识．彰能变体

    （归敬颂，颂文第一颂至第二颂的上半颂）

    第一章　归敬颂与造释愿由

    论文一：稽首唯识性，满分清净者，我今释彼说，利乐诸有情。

    讲解：印度古人造论，是先作本颂，总括全书要义，然后依颂作释，名曰长行，长行是论著的正文。而《唯识三十颂》一书，是世亲菩萨晚年之作，完成了颂文之后，长行未作而已示寂。当时瑜伽行学派的理论，已成为大乘佛教的主流，许多论师都研究唯识三十颂，为三十颂作释论（长行），作者为述发愿造释之意，故先作颂以致敬。

    所以本释论的颂文，即：‘稽首唯识性，满分清净者，我今释彼说，利乐诸有情。’，此颂并不是世亲菩萨所造，这是后来护法等诸大论师，于解释三十颂时所加的。这四句二十个字的颂文是什么意思呢？它的意思是说：向万法唯识的法性致敬，向圆满清净的佛陀致敬，也向多分清净的菩萨致敬。我现在解释世亲菩萨的《唯识三十颂》，是为了给有情众生带来利益和安乐。

    论文二：今造此论，为于二空有迷谬者生正解故；生解为断二重障故。由我、法二障俱生，若证二空，彼障随断。断障为得二胜果故。由断续生烦恼障故，证真解脱；由断碍解所知障故，故得大菩提。

    讲解：前面颂文中说：‘我今释彼说，利乐诸有情’。意思是我解释《唯识三十颂》的目的，是为了给有情众生带来利益和安乐。何以故呢？这要分做三层来说，一者是为那些对我、法二空迷惑不解的人，使它们对于二空生起正确的理解。如果理解得二空的道理，就能断除去烦恼障和所知障。果能断得二障，证得二空，就能得到大涅槃和大菩提两种殊胜的果报──断除了使众生生死相续的烦恼障，便能证得真解脱──就是大涅槃；断除了障碍对事物正确理解的所知障，便能证得大菩提。以上是第一层造论的理由。（注：一、真解脱：是摆脱一切系缚、烦恼的一种精神境界，即是涅槃。二、大菩提，菩提是梵文Bodhi的音译，意译为觉。大菩提即佛果──无上正等正觉，此对小乘声闻、缘觉而言，称大菩提。）

    论文三：又为开示：谬执我法，迷唯识者；令达二空，于唯识理，如实知故。

    讲解：其次是第二层造论的理由：开，是开导迷谬；示，是指示真理。于二空理不生正解的外道、二乘，执著内而身心的我，外而万有的法，都是实在而有其自性。不知这完全是自己识心之所变现，所谓：‘识所缘，唯识所现’，这便是‘谬执我法、迷唯识者’。现在造此论，就是为给这些迷谬的人一个开示，教它们了达我法二空，于唯识的真理，如实而知。

    论文四：复有迷谬唯识理者，或执外境，如识非无；或执内识，如境非有；或执诸识，用别体同；或执离心，无别心所。为遮此等种种异执，令于唯识深妙理中得如实解，故作斯论。

    讲解：这是第三层说明造论的理由：因为更有一些对唯识的道理，迷谬而不生正解的人，他们的迷谬可分为四种：一者、或执外境，如识非无；这是小乘萨婆多部的迷执。他们执著经上说有色、心二法，即认为心识以外的色等五尘境界，也同心识一样的非无。二者、或执内识，如境非有；这是中观学者清辩论师等一派的谬执。他们依胜义谛，说内识也同外面尘境似的非有。三者、或执诸识，用别体同；这是大乘性宗一类论师的谬执，他们认为诸识虽各有功用，但本体却是同一阿赖耶识。四者、或执离心无别心所：这是小乘经部觉天论师等的迷执。他们执著经上‘士夫三界染净由心’之说，认为离开心王之外别无心所。

    以上四种，唯识家通统认为他们是唯识理的迷谬者。因为前二种的执著，与唯识家有识无境的主张有异；第三种的执著，与唯识家诸识各有体用的主张有异；第四种的执著，与唯识家离心王外别有心所的主张有异。现为遮断此种种异执，教他们于唯识的妙理如实了知，故作此论。


第二章　释难破执．破实我

    第二章　释难破执．破实我

    论文一：若唯有识，云何世间，及诸圣教，说有我法。

    讲解：这是假藉问难的因缘，以引起颂端的话。唯识的主旨，在于说明心识之外，没有实我，也没有实法，这称做‘唯识无境’。但是外人不以为然，他们以为这世界上明明有圆颅方趾的‘我相’，和芸芸众生；也明明有山河大地，房舍器物的‘法相’，何以说‘唯识无境’，没有我、法呢？于是世亲菩萨，假借外人质疑之词，说明万法唯识的道理。外人质问曰：‘如果照你们唯识家所说，万法唯识，识外无境，为什么世人皆说有我有法呢？纵然世人迷昧，说的不对，可是你们圣教中不是也说预流、一来等的我，和四谛、五蕴等的法吗？’

    外人这一问，问的非常尖锐。如果说有我相法相，唯识义就不能成立；如果说万法唯识，就不该说我相法相。准此以论，唯识家的言论犯了两种相违的过失：一者，世人皆说有我有法，你们唯识家说无我无法，就犯了‘世间相违过’；二者，你们唯识家说万法唯识，而圣教中又说我相法相，就犯了‘圣教相违过’。

    唯识家怎么回答呢，我们看下面的颂文。

    论文二：颂曰：由假说我法，有种种相转；彼依识所变。此能变唯三，谓异熟思量，及了别境识。论曰：世间、圣教说有我法，但由假立，非实有性。我谓主宰；法谓轨持。

    讲解：针对外人的质问，唯识家作下面的回答：不错，世间凡夫以及圣教，确都说过有我有法。但他们所说的我、法都不过是假名施设安立的名相，并没有实在的体性。于此，我们把‘我’和‘法’做一解释。什么叫做我呢？我，梵名Atman，音译阿特曼，原意为‘呼吸’，引伸为生命，自己、自我、自性等。这是印度婆罗门教、自四吠陀时代即使用的名词。我有四义，一者恒常存在（常）；二者独一个体──不是集合体（一）；三者中心之所有主（主）；四者支配一切（宰），所以称我者，有常、一、主宰之义。梵书时代，婆罗门教以‘梵’为宇宙最高原理，以我为为个人生命原理，故有‘梵我一如’之说，此即佛教经典中所破的‘神我’。本来，‘我’只是五蕴因缘和合的集合体，不是常、一、主宰的实体，故称假我。

    至于‘法’呢？法者‘轨持’之义，轨者‘轨生物解’，持者‘任持自性’。本论中有谓：‘法谓轨持，轨者轨范、可生物解；持谓任持，不舍自相。’简单的说，我人的见、闻、觉、知作用，对于任何一事一物，都会于那事物上起一种见解，即是轨生物解；世间任何事物，皆有它特别的体性，我们对于它所起的见解，无论是对是错，而它本身的体性，任运摄持，而不失不变，即是任持自性。简单的说，‘法’所表示的事物有其一定的规范，法也就是宇宙万有。以上是对第一句颂文的诠释。

    论文三：彼二俱有种种相转。我种种相谓有情、命者等；预流、一来等。法种种相，谓实、德业等；蕴处界等。转谓随缘施设有异。

    讲解：这是对第二句颂文的诠释。以上二种我、法，有千差万别种种不同的名相转起。我的种种名相，大别有二：一者为有情、命者等。我具色、心二法，起心动念，受爱著贪染，这叫做有情；色、心相续，生死无间，这叫做命者。等者，是说此外还有其它很多关于‘我’的名相，如：士夫、作者、知者……不胜枚举，这是世间所说的种种我相。二者圣教说的种种我相，如预流、一来等，预流，是断三界见惑预入圣人之流的初果圣者。一来，是尚须来欲界受一次生，方断三界思惑的二果圣者。等者，是说此外还有三果、四果、缘觉等。

    法的种种名相，也大别有二：一者世间的种种法相，如婆罗门教六派哲学中，胜论派的实、德、业等。万有的本体称之为实。显体之相称之为德，体所起的作用称之谓业。这是胜论六句义的前三句（注：胜论六句义，是胜论学者观察世界各种‘存在’，纳之入六个范畴中。这六个范畴即是实、德、业、同、异、和合）；此外还有数论派的二十五谛，以下用一等字包括。这是世间所说的种种法相。二者圣教所说的种种法相，如蕴、处、界等，蕴者是色、受、想、行识的五蕴，处者是六根和六尘的十二处。界者是十二处再加六识成为十八界。这不过是圣教所说的世间法；此外还有出世间法如四圣谛、十二因缘、六度等，这在本节论文的等字中也包括了。

    何以世间、圣教会有我、法的种种相转呢？都为随著各自的因缘差别，所以安立的名相也就有种种差别了。不过世间的差别是随著遍计的因缘；圣教所说是随著方便的因缘。因为因缘不同，所安立的我、法自然有异，这就叫做‘转’。所以论文中说：‘转谓随缘施设有异’。

    论文四：如是诸相，若由假说，依何得成？彼相皆依识所转变而假施设。识谓了别。此中识言，亦摄心所，定相应故。变谓识体，转似二分。相见俱依自证起故。依斯二分，施设我法，彼二离此，无所依故。

    讲解：这是外人对第三句解释的质问和唯识家的回答。外人问曰：如果照你们唯识家所说：一切我、法，或是用妄情执著而假说，或是由方便施设而假说。那么，假必依真方得成立，既无二真作为凭借：二假依据什么而成立呢？

    唯识家答曰：这些世间和圣教所说的我相和法相，虽然不是依真而假说，但都是依于内识的转变而施设，而假立的名言相。什么叫做识呢？识者了别，了是了解，别是分别。如朦胧中睁眼见墙上挂钟，这叫做‘了’；细看几点几分，这就是‘别’。不过，说到识并不是单指八识心王，还包括著五十一个相应心所。因为心王是心所之王：心所是心王之所：王为主，所为从。既称为王，必有臣属辅佐，这臣属就是心所。

    论文中称：‘彼相皆依识所转变而假施设’。识如何转变呢？就是在识的自体上，转起似有实无的相、见二分。这相、见二分，好像蜗牛头上的两支触角，此触角依于蜗牛的头而生起。识体上转起见、相二分，此二分是依识体而生起，离开识体即无相、见二分。依此二分施设我、法。依能见的一分作用，施设我相；依所见的一分境界，施设法相。这我、法二相，离开了见、相二分就无所依附了。

    论文五：或复内识转似外境。我、法分别熏习力故，诸识生时变似我、法。此我、法相虽在内识，而由分别似外境现。诸有情类无始时来，缘此执为实我实法。如患梦者，患梦力故；心似种种外境相现。缘此执为实有外境。

    讲解：另有论师解释转似二字，显示我、法非实之理。一者我、法诸相，本来不是外境，而是内识的见、相二分，转变为似是而非的外境。二者由于过去世对我、法分别的熏习之力，潜藏在八识田中成为今世生起现行的种子，所以才由内识的自证分，变起见、相二分的似我、法相。三者内识所变现的似我、法相，虽然不是外境，然而分别起来，就好像显现在心外的境界一样；一切众生，从无始时来，就因此执著为实我实法了。四者，就好像患眼病的人、和在睡梦中的人似的，本来没有外境，由于眼花缭乱，睡梦颠倒之故，才由内心现出似是实有的种种境相，就执此为实有的外境。

    论文六：愚夫所计实我实法，都无所有，但随妄情而施设故，故说之为假。内识所变似我似法，虽有而非实我法性，然似彼现，故说为假。

    讲解：愚夫二字，指的是凡夫、外道、二乘等，他们不了解我、法非实，而计执于实我实法，这些实我实法，其实都是无所有的，只是随著他们的虚妄情执，施设为有主宰的我，有作用的法而已。因为这些全是计较执著，所以说它是假。而圣教所说，由内识所变现的似我似法，虽有依它缘起的似我法体，却没有实我法性。然此似我似法，因为是内识所变现，所以也得说它是假。

    论文七：外境随情而施设，非有如识；内识必依因缘生故，非无如境。由此便遮增、减二执。境依内识而假立故，唯世俗有；识是假境所依事故，亦胜义有。

    讲解：外境是随著世间妄情而施设，并非实有，岂如识之有体。依它起的内识，则必定依于种子因缘而生，体是实有，并非和遍计所执的外境一样。由于此内识非无：外境非有之故，便遮除了心外有境的增添执著：以及心境俱无的减损执著。因为外境是依托内识而安立的假我假法之相，只有世间俗流才执以为有。而内识是假我法相的外境所依托，所以不但世俗认为是有，就是超过世俗的胜义，也认为是有。但也不可误会假境所依的识，就是胜义谛。当知‘亦胜义有’的亦胜义，仅少胜于俗谛之俗，并非真胜义谛。真胜义中离言绝思，空尚不可说，何况说有。

    论文八：云何应知实无外境，唯有内识似外境生？实我实法不可得故。如何实我不可得耶？诸所执我略有三种：一者执我体常周遍，量同虚空，随处造业受苦乐故。二者执我其体虽常，而量不定，随身大小有卷舒故。三者执我体常至细，如一极微，潜转身中作事业故。

    讲解：一般外道小乘，对唯识无境之理不能了解，问曰：我、法是实，有目共睹，为什么说唯有内识、而由内识变现为好似的外境？论主答曰：因为真实的我和法，推究起来是不可得的。外道小乘（注：小乘包括犊子部、正量部、和经量部等）再问：为什么说实我实法不可得呢？论主回答说：这要从外道和小乘两方面说起：外道所执之我，类别不过三种，第一种是数论外道等所执的大我，他们认为‘我’的体性恒常不断，我相的范围量同虚空，我用的功能是可造善、恶诸业，受苦、乐果报。第二种耆那教的不定之我，他们认为‘我’虽是永恒，而我的身量却大小不一定，随著身量大小而舒展或卷缩。第三种是兽主外道等所执的小我，他们认为‘我’是永恒的，而我的身量像一个极微那样小，因此‘我’能够潜伏在众生身中，作种种造作。

    论文九：初且非理，所以者何，执我常遍，量同虚空，应不随身受苦乐等。又常遍故，应无动转，如何随身能造诸业？又所执我，一切有情为同为异？若言同者，一作业时一切应作，一受果时一切应受，一得解脱时一切应解脱，便成大过。

    讲解：第一种主张不合道理，苦乐是无常的，你们既然执著「我’是恒常周遍，就不应当再说随身能受苦乐。再者，你们所执的‘我’，既然量同虚空，那就应该壅塞不通，而没有转动的余地，何以能随身造作诸业呢？试问，你们所执的我，一切众生是共同一个呢，还是各各别异？若说是共同一个，那么一人作业时岂不是一切人都要同作？一人受果报时岂不是一切人都要同受？如果有一人修道得到解脱，岂不是一切人都同时解脱了吗？这种过失可够大了。

    论文十：若言异者，诸有情我，更相遍故，体应相杂。又一作业一受果时，与一切我处无别故，应名一切所作所受。若谓作受，各有所属，无斯过者，理亦不然。业、果及身与诸我合，属此非彼不应理故。一解脱时，一切应解脱，所修证法，一切我合故。

    讲解：如果你们所说的我，和一切有情众生各各别异，则一个有情众生的我体周遍，各有情众生的我体也应当周遍。既然各有情众生的我体互相周遍，就会各各互相涉入，这样就应该甲的体中有乙，乙的体中有丙，乃至一切众生的体都混杂不清，成为同一个我体。当一个人作业，一个人受报时，就成为一切人所作，一切人所受。因为你们执著一个人的我，和一切人的我同在一处，并无区别。

    如果说我体虽遍，但所作所受各自承担，就是各作各受，这样就没有彼此混杂的过失。这理由也说不通，因为业、果、身与各有情众生的‘我’相合为一体，不分彼此，说属于这个而不属于那个，在道理上讲不通。一个众生得解脱，一切众生都得解脱，是因为所修、所证和上述一切相杂的‘我’合为一体的原故。

    论文十一：中亦非理，所以者何，我体常住，不应随身而有舒卷，既有舒卷，如橐吁风应非常住。又我随身应可分析，如何可执我体一耶？故彼所言，如童竖戏。

    讲解：第二家说的也不合理，你们既然执著我体是常住的，常则不变，住则不动，就不应随身大小而有变动舒卷。既然我有舒卷不定的伸缩性，就应该不是常住，就好像风箱中的风一样不是恒常。如果我有舒卷，那也如风箱的风一样不是恒常。

    再者，你们所执的我，既是随身而有舒卷，就应当可以分析出或舒或卷的差别。身体既可分析，随身的我当然也可以分析，怎么可以执著我体是常一呢？所以你所说的就好像儿童游戏。

    论文十二：后亦非理，所以者何？我量至小如一极微，如何能令大身遍动？若谓虽小而速巡身，如旋火轮似遍动者，则所执我非一非常，诸有往来非常一故。

    讲解：不但前二说不合理，就是这第三种的小我执也不合理。你们所执著的我小的如一粒极微，如何能使大的身体转动？若说我量虽小，却能够很快的巡回全身，像回旋火轮似的周遍转动。那么你所执的我就不是一，也不是常了，因为所有往有来的东西都不是常一之故。

    论文十三：又所执我，复有三种：一者即蕴，二者离蕴，三者与蕴非即非离。初即蕴我，理且不然，我应如蕴，非常一故，又内诸色定非实我，如外诸色有质碍故。心、心所法，亦非实我，不恒相续，待众缘故。余行、余色，亦非实我，如虚空等非觉性故。

    讲解：外道的三种我执已如前破，另外还有三种我。一者是俗人执的即蕴我，执著此五蕴身便是我体。二者是数论派所执的离蕴我，执著离此五蕴身外，别有我体。三者是犊子部所执的非即蕴非离蕴我，执著于我与五蕴不同，又不是毫无关系。

    这三种我执全不合理，先说最初的即蕴我，因为我与色、受、想、行、识五蕴均非常住。内色的眼、耳、鼻、舌、身五根不是我，因为这和外面色的色、声、香、味、触的五尘一样，是有障碍性的物质。属于心所法的受、想、行三蕴，及属于心法的识蕴等，也不是实我，因为它不是恒常相续，而是待于众多因缘或断或续。其余的二十四个不相应行法，及除五根五尘外的无表色等，也不是实我，因为它们同虚空一样没有分别和觉性。

    论文十四：中离蕴我，理亦不然，应如虚空，无作受故。后俱非我，理亦不然。许依蕴立，应如瓶等，非实我故。又既不可说有为无为，亦应不说是我非我，故彼所执，实我不成。

    讲解：这中间的离蕴我执，也于理不合，因为离开了五蕴，就应该如虚空一样，没有能作业和能受报的人了，怎么能叫做我呢？

    不但即蕴我，和离蕴我执不对，这最后不即蕴、不离蕴的俱非我执也不对。因为犊子部等，执著我与我所依的五蕴，是不即不离的，然别有我体，是非常非无常的。又执瓶等外器，是依于色、香、味、触等四尘而建立的，然瓶与四尘，也是不即不离的。所以唯识家破之曰：你们所执的我并非实我，因为你们既许我是依蕴而立，又说我是不即蕴，不离蕴，这不是同依于四尘所立的瓶等一样是不即四尘，不离四尘吗？然而依于四尘的瓶等，不过是和合的假色，难道说依于五蕴的我，会是实我吗？彼等又立有过去、现在、未来、无为、不可说等五法藏。他们执著我是非常非无常，不可说是有为，也不可说是无为。所以唯识家又破他说，你们所执的我，既然不可说是有为、无为，也不应当不可说是我、非我，职是之故，彼犊子等所执的实我，是不能成立的。

    论文十五：又诸所执，实有我体，为有思虑，为无思虑？若有思虑，应是无常，非一切时有思虑故。若无思虑，应如虚空，不能作业亦不受果。故所执我理俱不成。

    讲解：再者，一般人所执的实体，是有思虑还是没有思虑？若说是有思虑，那么这个我就应该是非永恒的。因为思虑是有时起，有时不起，并不是一切时都有思虑。若说是没有思虑，那么这个我就应该像虚空一样，不能有任何造作，也不能受任何果报。所以你们所执著的实我，在道理上是不能成立的。

    论文十六：又诸所执，实有我体，为有作用，为无作用？若有作用，如手足等，应是无常；若无作用，如兔角等，应非实我。故所执我，二俱不成。

    讲解：还有，你们所执的实有我体，是有作用呢，还是没有作用？若说是有作用，应该如手足一样作息无常。若说没有作用，那就应该如兔角一样没有实我。所以你们所执的实我，不管在是有作用或没有作用，在道程上都不能成立。

    论文十七：又诸所执，实有我体，为是我见所缘境不？若非我见所缘境者，汝等云何知实有我？若是我见所缘境者，应有我见非颠倒摄，如实知故。若尔，如何执有我者，所信至教皆毁我见，称赞无我？言无我见，能证涅槃，执著我见沉沦生死。岂有邪见能证涅槃，正见翻令沉沦生死？

    讲解：再说，你们所执的实我，是不是我见亲能所缘之境呢？如果不能缘，你们又怎么知道有一个实我呢？如果我见能缘境，这个有‘我’的见解就应该不摄属于杯弓蛇影的错觉，而是如实的所知。倘若真的如此，为什么执有实我的外道、小乘，他们信奉了至极的圣教，都毁弃我见而称赞‘无我’呢？

    如果依你们所说，不执我的知见是邪见，执我的知见是正见。那么，岂有不执我的邪见能证涅槃成圣果，执我的正见反而沉沦生死呢？

    论文十八：又诸我见不缘实我，有所缘故，如缘余心，我见所缘定非实我，是所缘故，如所余法。是故我见不缘实我，但缘内识变现诸蕴，随自妄情种种计度。

    讲解：再说，由妄想产生的我见，绝对不能缘于真实的我体，因为我见有它托缘而起的所缘，就如其余的心法和心所法那样，都缘自体所变的相分，所以我见所缘的对象，肯定不是真实我体。因为属于我见所缘的缘故，就如其余的色法一样，是所缘，是假有，怎可说为实我呢？所以我见不缘真实的我，只是缘内识变现的五緼，在这五蕴法上生起种种计度，而成为所执的实我了。

    论文十九：然诸我执略有二种，一者俱生，二者分别。俱生我执无始时来，虚妄熏习内因力故，恒与身俱，不待邪教及邪分别，任运而转，故名俱生。此复二种：一常相续，在第七识缘第八识，起自心相，执为实我。二有间断，在第六识缘识所变五取蕴相，或总或别，起自心相执为实我。此二我执细故难断，后修道中数数修习，胜生空观方能除灭。

    讲解：外道、小乘所说的种种我执，总说只有两种，一种叫做俱生我执，一种叫做分别我执。俱生我执，是过去无始以来，由于虚妄熏习的内在因力，不需要外道邪师的说教及自己的邪分别，就自然的转起，所以叫做俱生我执。俱生我执又分两种，第一种是常相续的执著，这是第七末那识的见分，去缘第八阿赖耶识的见分时，在七、八两识的见分上所变出了一个相分，第七识即执之以为真实之我。二是有间断的执著，就是第六意识，缘第八识所变的五蕴相分，或在五蕴的总相上执以为我，或取五蕴任一执以为我，其实这都是第六识产生的幻像，而执著为常、一、有主宰的实我。这两种我执微细隐密，要在修道位上一再修行我空观才能灭除。（注一：修道位，是佛教修行的过程，与见道、无学道合称三道。注二：五取蕴：即色、受、想、行、识五蕴，因为欲、贪称为取，蕴能生取，或蕴从取生，所以称五取蕴。）

    论文二十：分别我执，亦由现在外缘力故，非与身俱，要待邪教及邪分别，然后方起，故名分别。唯在第六意识中有，此亦二种，一缘邪教所说蕴相，起自心相，分别计度执为实我；二缘邪教所说我相，起自心相。分别计度执为实我。此二我执粗故易断，初见道时观一切法生空真如即能灭除。

    讲解：分别我执，虽有过去无明熏习的内因，还要加上现在外面的助缘才能够生起。这种我执不是与生俱有，是由后来受到邪师说教的影响，和自己内心的不合正法的分别思维，然后才会生起，所以叫分别我执。这二种分别我执，行相粗猛，比隐微细密的俱生我执容易断些。在最初入见道（大乘初地入心，二乘预流向果）时，大乘观一切法空，二乘观一切生空，所悟真如之理，便能灭除。

    论文二十一：如是所说一切我执，自心外蕴，或有或无，自心内蕴，一切皆有，是故我执皆缘无常五取蕴相，妄执为我。然诸蕴相从缘生故是如幻有，妄所执我横计度故，决定非有。故契经说：苾刍当知，世间沙门、婆罗门等所有我见，一切皆缘五取蕴起。

    讲解：前面所说外道、小乘的一切我执，自心外蕴或者是有，或者是无（注：自心外蕴，就是不了知五蕴是自心所现的影家，横计心外有一个五蕴本质的实我。这自心外蕴，不是见分的亲所缘缘），自心内蕴一切皆有（注：自心内蕴，就是见分自缘自心所起的自心影像。这是亲所缘缘。），所以各种我执，都是缘无常的五取蕴相妄执为我。然而诸蕴相是仗因托缘而生，所以是幻有，由于人们的虚妄计度，执著为实我，这种我是决定没有的。所以佛经上说：‘比丘们呀！你们应当知道，世间的沙门、婆罗门等，所有的我见，都是由于攀缘五取蕴相而生起的。’

    论文二十二：实我若无，云何得有忆识、诵习、恩怨等事？所执实我既常无变，后应如前，是事非有。前应如后，是事非无，以后与前，体无别故。若谓我用前后变易，非我体者，理亦不然，用不离体，应常有故，体不离用，应非常故。然诸有情各有本识，一类相续，任持种子与一切法更互为因，熏习力故得有如是忆识等事。故所设难于汝有失，非于我宗。

    讲解：这是执有实我之见者的问难：如果没有一个实我，何以我人会有对往事的记忆，对现境界的认识，如能诵习书籍、学习技能，以及人间恩爱、怨恨等事呢？

    论主驳曰：你们所执实我，既是恒常而无变化，那么后来学习的知识技能，就应当和先前没有学过时一样的没有；从前没有学习过的知识技能，也应该和后来学习过一样，因为你们所执的实我，是前后一体无二无别的。

    如果说我的作用前后有变易，我的本体无变的，此理也说不通，因为用不离体，体既是常，用也应该是常；体不离用，用既是无常，体也应当是无常。然而，一切有情，各各有其第八阿赖耶识，一类相续，摄持种子使之不失不坏，种子与一切现行法更互为因，由于因果相续的熏习之力，所以才有记忆、认识、诵持、恩怨等事。你们这种诘难，失败的是你们，而不是我们唯识宗。

    论文二十三：若无实我，谁能造业？谁受果耶？所执实我，既无变易，犹如虚空，如何可能造业受果？若有变易，应是无常。然诸有情心、心所法，因缘力故，相续无断，造业受果，于理无违。

    讲解：执有我者再度问难说：如果没有实我，那么是谁在造业？谁受果报呢？

    论主第二次答曰：你们所执的实我，既然是常无变易，那不就如同虚空一样，如何可以造业受果呢？如果是有变易，那就不是恒常。然而由于一切有情，内托阿赖识自体种子变现的心法为因，外起贪、嗔、痴等的心所法为缘，由此因缘之力，相续不断的在四生、五趣中造业受果，这在道理上是没有违背的。

    论文二十四：若无实我，谁于生死轮回诸趣？谁复厌苦，求趣涅槃？所执实我既无生灭，如何可说生死轮回？常如虚空，非苦所恼，何为厌舍求趣涅槃？故彼所言常为自害。然有情类身心相续，烦恼业力轮回诸趣，厌患苦故，求趣涅槃。由此故知定无实我，但有诸识，无始时来前灭后生，因果相续，由妄熏习似我相现，愚者于中妄执为我。

    讲解：执有我者第三度问难说：如果没有实我，是谁在五趣中生死轮回呢？又是谁厌患生死轮回之苦，而求趣于不生不灭的涅槃呢？

    论主第三次回答说：你们所执的实我既然没有生灭，怎么又说‘若无实我，谁于生死轮回诸趣’呢？你们所执的实我，既然是‘常如虚空，非苦所恼’，何以还说‘谁复厌苦，求趣涅槃’呢？所以你们执著有一个恒常的实我，这种论调只徒为害自己而已。如实的说，一切有情类众生，是藉著一个五蕴假合的身心，相续不断的起烦恼惑、造善、恶业，轮回五趣，受苦、乐报。由于这样的在五趣中生生死死，深生厌患，所以才求趣涅槃。总结的说，那里有什么实我呢？

    最后，论主总结驳斥所执实我者的过失，显示唯识的正义曰：由于以上的破执辨难，证知决定没有实我。真正有的，只是八识的心、心所法，自无始以来，刹那刹那的前念才灭，后念又生，因果相续，由于虚妄熏习，好像有一个‘我相’现前似的。愚者不觉，迷昧颠倒，就执著这个似我之相为‘实我’了。


第三章　释难破执．破实法

    第三章　释难破执．破实法

    论文一：如何识外实有诸法，不可得耶？外道余乘，所执外法，理非有故。

    讲解：前面所破的是外道小乘的我执，现在开始破外道小乘的法执。为破此执，论主先自问自答的说：为什么心识之外，实有诸法不可得呢？因为外道和其余的小乘们，他们所执心识之外的实法，肯定是没有的。

    论文二：外道所执，云何非有？且数论者执我是思，受用萨埵、剌阇、答摩，所成大等二十三法，然大等法，三事合成，是实非假，现量所得。

    讲解：外道小乘所执的心外实法为什么没有呢？先以数论外道来说吧！数论外道认为，‘我’就是思虑。由受用萨埵、剌阇、答摩三种属性构成五大等二十三种法，而这五大等二十三法，是由萨埵、剌阇、答摩三法合成，是实非假，因为它们是现量所得（注：数论外道，印度的六派哲学之一，梵名僧佉，此翻数论──以数为度量诸法的根本，从数所起之论，名为数论。此学派立二十五谛，以明宇宙万有开展的根本原理，复执此二十五谛中的‘大’等二十三法，以冥谛为生因。以萨埵──贪，刺阇──嗔，答摩──痴等三事和合而成为自体。这三事合成的二十三法，为有思想的我知者──神我所受用，这些法并非虚假，而是现量所证得的实在情形。所谓二十五谛的名称、作用，是：冥谛、为万有的生因；三事为萨埵、剌阇、答摩；二十三法，为大、能生万有的作用；我执、为大所生且能生诸法，五唯、为色声香味触，五大、为地水火风空，五知根、为眼耳鼻舌身，五作业根、为口手足二便处，心根、指肉团心。）

    论文三：彼执非理，所以者何？大等诸法多事成故，如军、林等应假非实，如何可说现量得耶？

    讲解：数论外道的所执不合道理，为什么呢？因为数论自许的大等二十三法，是由萨埵、剌阇、答摩三事合成的，就好像聚众卒以成军，集众木以成林一样，这是假法，并非真实，假法如何可说是现量所得呢？

    论文四：又，大等法若是实有，应如本事，非三合成。萨埵等三即大等故。应如大等亦三合成。转变非常为例亦尔。

    讲解：再者，大等二十三法若是实有，就应当像自性一样，不是由萨埵、剌阇、答摩三法合成，因为萨埵等三种属性，就是五大等二十三法，就应当如五大等，也由萨埵等三种属性合成。自性就应当如五大等一样是有变易的，是无常的。

    论文五：又三本事，各多功能，体亦应多，能体一故。三体既遍，一处变时，余亦应尔，体无别故。许此三事体相各别，如何和合共成一相？不应合时变为一相，然未合时体无别故。若谓三事体异相同，便违己宗体相是一。体应如相，冥然是一。相应如体，显然有三。故不应言三合成一。

    讲解：再者，萨埵、剌阇、答摩三事，在合成二十三法上既然有多种功能，那么三事的体性也应当是多种的，因为功能和本体是一致的。萨埵等三既然普遍的造成二十三法，那么这二十三法有一法起变化，其余的一切法也应当起变化，因为法的体性是没有差别的。如果你们说萨埵等三事的体相各有区别，那怎能三事和合成一相呢？也不应当说三事在未合以前体相各别，既合以后就变为一相了，因为合时的体相与未和合时的体相前后是无差别的。

    如果认为萨埵等三事体虽是异，其相则同，便违背其体、相一致的主张。假使三事合成一相，本体应当如相状一般冥然合而为一，相状也应当像本体一样明显的分为三种。这样，三事的体，既然不成为三，合成的相，也不成其为一。所以不应该说三事合成一相。

    论文六：又三是别，大等是总，总别一故，应非一三。此三变时若不和合成一相者，应如未变，如何现见是一色等？若三和合成一相者，应失本别相，体亦应随失。

    讲解：萨埵、剌阇、答摩三事谓别、是三；合成大等二十三法谓总、是一。然而，若总别合而为一了，则总也不成其总，别也不成其别了。总别既都不成，那么一也不应该是一，三也不应该是三了。

    论文七：不可说三各有二相，一总、二别。总即别故，总亦应三，如何见一？若谓三体各有三相，和杂难知，故见一者，既有三相，宁见为一？复如何知三事有异？若彼一一皆具三相，应一一事能成色等，何所阙少，待三和合？体亦应各三，以体即相故。

    讲解：不可以说萨埵等三事各有二相，一总相二别相。因为大等总相，就是萨埵等三事的别相，所以大等总法应当也是三相，怎能说但见一总相呢？如果说，萨埵等三事各有三相──即萨埵一法兼具剌阇、答摩，乃至答摩一法亦兼具萨埵、剌阇，在这样和合杂揉所成的大等诸法里，三相难知，所以但见一相。这也不对，萨埵等三事既各有三相，所成大等还应是三相，怎能呈现一相呢？如果但见一相，又怎么知道萨埵等三事是各各别异呢？如果萨埵等三各具三相，那大等诸法就应当一事便成，何以有所缺少，必待萨埵等三事和合而后才能成为一相呢？还有，相有三种，本体也应当是各有三种，因为体就是相。

    论文八：又大等法，皆三合成，展转相望应无差别，是则因果、唯量、诸大、诸根差别皆不得成。若尔一根应得一切境，或应一境一切根所得，世间现见情与非情，净、秽等物，现、比量等，皆应无异，便为大失。故彼所执实法不成，但是妄情计度为有。

    讲解：再者，大等二十三法，本都是萨埵等三事和合而成，这样展转相望，彼此间应当是没有差别。这样，三事的因，二十三法的果，五唯、五大、十一根的差别，全都不能成立了。如果是这样的话，一个眼根就应当能缘色、声、香、味、触、法一切境，或者一种境六根都可以去缘，这样一来，就不必有什么根缘什么境的界限了。同时，世间现见的有情众生、无情器界、清净与污秽等物、现量与比量等法，都应当没有差别，这真是极大的过失。所以，以万法唯识的观点来看，数论派所执著的法不能成立，不过是人们的虚妄计度而认为是实有罢了。

    论文九：胜论所执，实等句义，多实有性，现量所得。

    讲解：本文前破数论学派，由此以下破胜论学派。胜论学派，也是印度六派哲学之一派，梵名‘吠世史迦’，此翻为‘胜’，造六句论，胜于一切，故名‘胜论’。

    所谓胜论六句，即实、德、业、大有性、同异性、和合性六种。实，是宇宙万有的本体。德，是体上庄严的德相。业，是体相上的业用。大有性，是实、德、业三，皆属有性之所有。同异性，是每一法上都有同有异。和合性，能令千差万别的异相和合在一处。以上六句，除末一句的和性处外，其余五句，都是直觉现量所得的实有性。所以说：‘多实有性，现量所得’。

    论文十：彼执非理，所以者何？诸句义中且常住者，若能生果应是无常，有作用故，如所生果。若不生果，应非离识实有自性，如兔角等。诸无常者，若有质碍，便有方分，应可分析，如军、林等非实有性。若无质碍，如心、心所，应非离此有实自性。

    讲解：胜论派所执著的六句义中，有常、无常、生果、不生果、有质碍、无质碍的种种分别。在未讲论文以前，先把该派所执的理论略说如下。一、实句中分为九种，为地、水、火、风、空、时、方、我、意。此中地、水、火、风四种能造极微常能生果，所造的极微无常亦能生果；空、时、方、我、意五种常而不能生果。二、德句中分为二十四种，为觉、乐、苦、欲、嗔、勤勇、法、非法、行、离、彼性、此性、声、香等十四种，无常不能生果。色、味、触、数、量、别性、合、重性、液性、润等十种，或常能生果，或无常不能生果。三、业句中分为五种：取、舍、屈、伸、行等，都是无常而能生果的。其余大有性、同异性、和合性等三句，都是常而不能生果的。诸句义中，除实句中的地、水、火、风、意五种是有质碍外，其余都是无质碍的。

    唯识家针对胜论外道以上的种种执著，予以破斥的说：你们这些执著，都没有道理。何以故呢？且就六句义中的常住来说吧，倘若这个常住是能生果的话，就应该是无常而不是常。因为凡是有作用的都是无常，生果是有作用，也像它所生的果一样是无常。倘若这个常住不能生果的话，就应该不是离开心识之外，实有一个常法的自体，因为唯识无境，识外之境好像兔角一样，只是意识想像而已。

    再就其六句义中的无常来说，倘若无常是有质碍的话，便有其方所与位分，那就可以分析，像众卒编成的军队，和多木聚成的树林一样，并非实有军队和树林的自体。倘若无常是无质碍的话，那又好像心王心所一样，应当不是离开心识之外，另有一个实在的自体。

    论文十一：又，彼所执地、水、火、风，应非有碍，实句义摄；身根所触故，如坚、湿、暖、动。即彼所执坚、湿、暖等应非无碍，德句义摄；身根所触故，如地、水、火、风。地、水、火三对青色等，俱眼所见，准此应责。故知无实地、水、火、风与坚、湿等各别有性，亦非眼见实地、水、火。

    讲解：胜论师所执实句义中的地、水、火、风，是有质碍的，德句义中触所摄的坚、湿、暖、动是没有质碍的。但地、水、火、风之性就是坚、湿、暖、动，又都同是身根所触的境。可谓矛盾已极。所以唯识家才反覆立量，予以破斥。

    第一量是：宗──地、水、火、风应非有碍及实句摄。因──身根所触故。喻──如坚、湿、暖、动。此比量意谓：胜论所执的地、水、火、风，应该没有质碍，也不是实句义所摄，因为胜论自许地等是身根所触的境，既是身根所触的境，应当同德句中触所摄的坚、湿、暖、动一样是没有质碍，也不是实句所摄。这是以其德破其实。

    第二量是：宗──坚、湿、暖、动应有质碍非德句摄。因──身根所触故。喻──如地、水、火、风。此比量意谓：反过来说，就是胜论所执坚、湿、暖、动，也应该不是没有质碍，更不是德句义摄，因为彼宗自许坚等是身根所触之境。既是身根所触之境，就应当同实句中身根所触的地、水、火、风一样不是没有质碍，也不是德句所摄。这是以其实破其德。

    不但用前面的二种比量可破其执，就是以地、水、火三对青、黄、赤色，俱以眼根所见为因，也可以照前量的格式，反覆立量而予以破之。基于以上理由，故知没有实在的地、水、火、风，与坚、湿、暖、动等各别不同的有性，为身根所触。也没有实在的地、水、火，与青、黄、赤色，为眼根所见。

    论文十二：又彼所执实句义中有碍常者，皆有碍故，如粗地等。应是无常。诸句义中，色根所取，无质碍法，应皆有碍。许色根取故。如地、水、火、风。

    讲解：胜论师执著六句义中的地、水、火、风的极微、和意根五种，是有质碍的常法。唯识家破他说：这五种法，应该是无常而不是常。因为胜论自许这五种法，都和无常的粗地一样的有质碍，当然也应同粗地一样无常。胜论宗执著于德句义中的色、味、香、声等，及业、有二句义，都是色根所取的无质碍法。唯识家破他说：这些无质碍法，应当是有质碍的。因为彼宗自许这些法，都和有质碍的地、水、火、风一样是色根所取之故。既同地等一样的是色根所取，当然也同地等一样是有质碍的。

    论文十三：又彼所执非实、德等，应非离识有别自性。非实摄故，如石女儿。非有实等，应非离识有别自性。非有摄故，如空华等。

    讲解：胜论师所执的六句义中，不属于实句的德等五句，应该不能离开心识别有其五句的自体。因为该宗自许德等五句，不是实句所摄。既非实句所摄，那就好像石女生儿一样。石女岂能生儿？不过是心识的虚妄想像而已（这是破诸句非实）。不属于有句的实等五句，也应当不能离开心识别有其五句的自体，因为该宗自许实等五句，不是有句所摄。既非有句所摄，那就好像空华一样，空中岂能有华？不过是心识所幻现的妄影而已（此破诸句非有）。

    论文十四：彼所执有，应离实等无别自性，许非无故，如实、德等。若离实等应非有性。许异实等故，如毕竟无等。如有非无，无别有性，如何实等有别有性？若离有法有别有性，应离无法有别无性，彼既不然，此云何尔？故彼有性唯妄计度。

    讲解：胜论所执的大有性，应当离开实、德、业等就没有另外一个大有性。何以故呢？因为他们自许大有性是非无，那就应当如实、德、业一样，不能离开另外有性。假如离开了实、德、业，那就应当没有大有性了，因为他们自许大有性是离开了实、德、业。既然离开了实、德、业，那便如同兔角一样，毕竟一无所有，那还成其为什么有性呢？如果说有性不是没有，那一定不能离开实、德、业，而另外有一个大有性。设若离开了有法另外有一个有的性，那就应当离开了无法另外也有一个无性。这话你当然不以为然，然而，‘彼既不然，此云何尔’？怎么可以说离此有法之外，别有一个有性呢？因此胜论所执著的有性，不过是虚妄计度罢了。并不是真的有个有性。

    论文十五：又，彼所执实、德、业性异实、德、业，理定不然。勿此亦非实、德、业性，异实等故，如德业等。又应实等非实等摄，异实等性故，如德、业、实等。地等诸性对地等体更相征诘，准此应知。如实性等无别实等性，实等亦应无别实性等。若离实等有实等性，应离非实等有非实等性，彼既不尔，此云何然？故同异性唯假施设。

    讲解：实、德、业，是同异性。如水和水是同性，水和火是异性。实、德、业性，是总同异性，地等诸性，是别同异性。以下破同异性的文字，不大好懂，我们先理出其中要点：即是实、德、业、地、水、火、风。实、德、业是总说，地、水、火、风是别说。

    胜论师所说的实上同异性，是离实体法上有的。这种道理决定不对，因为不可说这个同异性，不是实法上的同异性，和实体是异，德、业法也是如此。其次，如果同异性离开实法上而有的话，那么这个实也就不是实体上所摄，何以故呢。因为你们说不同实体上的同异性啊？实句解释过了，德字、业字也是如此。

    以上的总同异说过了，其次说别同异性。你们又说地上同异性，是离开地上法有，这个道理也决不对。你们不可以说这个同异性，不是地法上的同异性，和地是异，同离地法的水、火、风一样，如果同异性离开地法上有的话，那么你这个地也就不是地法上所摄。何以故呢？因为你们说不同地法上的同异性啊！地句是如此，水、火、风也是一样，这就是地、水、火、风别同异。

    如果实上的同异性，没有另外一个同异性，那么实上当然也就没有另外一个同异性。假如离开实体法别有一个实等的同异性，那就应当离非实等的法体，别有一个非实等的同异性了。这话你一定不认为是对的，那么‘彼既不尔，此云何然’？为什么说离开实等，别有一个同异性呢？所以你们所执著的同异性，不过是假缘施设而已，并不是真的有个同异性。

    论文十六：又彼所执，和合句义，定非实有，非有实等诸法摄故，如毕竟无。彼许实等现量所得，以理推征尚非实有。况彼自许和合句义非现量得，而可定有？设执和合，是现量境，由前理故，亦非实有。

    讲解：胜论师六句义，实、德、业、大有性、同异性，已讲解如上，现在是破第六句义。胜论师执实等的五句义外，别有一个实在的第六句义，能使实等五句相属而不相离，名‘和合性’。又执实等五句是现量所得，和合则否。于此唯识家破他说：和合句义决定不是实有，何以故呢？因为你们自已说，和合句是假法，不是大有性及实、德、业所摄。既是假法，那和龟毛兔角一样，毕竟没有所谓的和合性。前面的实、德、业等五句，你们自许是现量所得，现在以理推究，尚且没有实体，何况你们自许不是现量所得的和合义，而是实有的吗？如果你们执著和合也是现量境界的话，由前面种种道理说起来，这也不是实有。

    论文十七：然彼实等，非缘离识实有自体，现量所得。许所知故，如龟毛等。又缘实智，非缘离识实有自体，现量智摄，假合生故，如德智等。广说乃至缘和合智，非缘离识，和合自体现量智摄。假合生故，如实智等。故胜论者实等句义，亦是随情妄所施设。

    讲解：胜论所说的‘实’等句义，是离识而有实体的，又是能缘的心所知的现量境。所以唯识家破他说，你们所执的实等句义，不是离开心识别有一个实体的现量，而为能缘的心识之所缘得；因为彼宗自许是心识所缘知的境界之故。既为心识所缘知，那就如龟毛一样的离识无体。

    又，缘实句的智，并不是离开唯识实句的自体现量智所摄，乃是同假法和合而生之智，如同缘德、智等一样。缘实句的智是假智，缘其余五句的智，一样也是假智。由上面种种原故，所以胜论师所执的实等六句义，也都是随著自己的情执，虚妄施设。

    论文十八：有执有一大自在天，体实偏、常，能生诸法。

    讲解：印度有九十六种外道，归纳为十三家，除了数论、胜论两家外，大自在天也是其中一种，此在佛经中说是欲界第六天。大自在天王有三目、八臂，骑白牛，执白拂，是统理世界的主人。祀大自在天的外道，执此天体是真实、遍满、常住，能生一切法。

    论文十九：彼执非理，所以者何？若法能生，必非常故，诸非常者必不遍故，诸不遍者非真实故。体既常遍具诸功能，应一切时顿生一切法，待欲或缘方能生者，违一因论。或欲及缘亦应顿起，因常有故。

    讲解：唯识家对执于大自在天的外道，斥之为非理。如果你们执著的大自在天，能生起一切法，那决不是常住。凡不是常住的，决定不能遍满一切。凡不能遍满一切的，也决定不是真实。自在天体既是常遍，而且具备一切功用和能力，就应当于一切处、一切时，顿生一切法。如果要等待众生的欲望，或者要其他助缘才能生起，那岂不是以多法为因，违背了你们自许以自在天为唯一生因的主张了吗？或者众生的欲求和助缘也应当顿起，用不著相待，因为你们说是常有之故。

    论文二十：余执有一大梵、时、方、本际、自然、虚空、我等：常住实有，具诸功能，生一切法。皆同此破。

    讲解：外道除了数论、胜论、大自在天外，还有：大梵、时、方、本际、自然、虚空、我等七种。这七种外道，都执著是永恒的，实有的，并具备各种功能，能生宇宙间一切法，所以也同破大自在天的前例一样，予以破斥。

    论文二十一：有余偏执明论声常，能为定量表诠诸法，有执一切声皆是常，待缘显发，方有诠表。彼俱非理，所以者何？且明论声许能诠故，应非常住，如所余声。余声亦应非常，声体如瓶、衣等，待众缘故。

    讲解：外道除以上十种外，还有其余两种偏执的声论外道，一者是声生论，他主张声是常住，能够诠显一切法，这音声可以做为一切法决定量。二者是声显论，主张一切声性都是常住，但须要等待助缘而显才能发声，才能够诠显表示出来。

    以上声生论或声常论，所执都不合理。你们自许其声能表诠诸法，既有诠表，当然不是常住。因为不是一切时都有诠表，这岂不是和其余的一切外声一样要等待助缘，而后才能发声吗？内声尚且如此，其余的外声不必说也是无常．因为像瓶子和衣服一样，要待众缘齐备才能生起的。

    论文二十二：有外道执地、水、火、风极微实常，能生粗色，所生粗色不越因量，虽是无常而体实有。彼亦非理，所以者何？所执极微若有方分，如蚁行等体应非实。若无方分，如心、心所，应不共聚生粗果色。既能生果，如彼所生，如何可说极微常住。又所生果不越因量，应如极微不名粗色，则此果色应非眼等色根所取，便违自执。

    讲解：还有一种外道，他们执著有地、水、火、风四大的极微，是实是常，能和合聚积生起粗色的果。所生的粗色，不超越一个极微的因量。这粗果虽是无常，而其本因的体却是实有。

    你们所执极微是实是常，能生粗色，此不合理。所以者何？你们所执极微，有没有方向和分位呢？若有方分，则极微之体当像虫蚁爬行一样不是实常。若无方分，就应当像心王、心所一样，不能和合聚积生起粗的果色。既能生果，则能生的极微，就应该和所生的粗色一样，怎么可以说极微是常住呢？

    你们自己说，极微和合所生的粗果，是不能超越每一极微的因量。如不越因量，那就应当同极微一样的渺小，就不叫做粗色了。如果是这样，这粗果应当不是眼根所见得到的。既非眼根所见，岂不和你们自许眼根能见粗色的执著相违背了吗？

    论文二十三：若谓果色量德合故，非粗似粗，色根所取，所执果色既同因量，应如极微无粗德合，或应极微亦粗德合，如粗果色处无别故。若谓果色遍在自因，因非一故，可名粗者。则此果色体应非一，如所在因，处各别故。既尔，此果还不成粗，由此亦非色根所取。若果多分合故成粗，多因极微合应非细。足成根境，何用果为？既多分成，应非实有，则汝所执，前后相违。

    讲解：如果你们说这粗果色本来非粗，是因为许多极微和合之故，所以由本来不是粗色，而变成似是粗色，能为眼根所见所取。此理不然，因为你们所执的粗果色，既同一个本因极微一样渺小，就应当像极微一样没有粗德和合。再不然，就应当极微也和粗果色一样是粗德和合，好像粗果色一样，因为极微和粗果色之体相涉入，并没有两个处所的分别之故。

    假如你们说，果的粗色普遍的存在于自己的本因极微上，因为本因极微不止一个，而是许多个体的聚积之故，所以名之为粗。那么这个果色的体应当也不是一个，就如所在的本因极微一样，各住各的位子。如果这样，这果色还不能成其为粗，因为粗色既然同极微一样，那当然就不是眼根之所能见了。

    执极微实常的外道，又复转救曰：本因极微虽众多和合也不成粗，而果色则否，合使成粗，即是实有。唯识家再破曰：设若和合多分的果成为粗色的话，那么，和合多分的本因极微，也应当不成为细，足可构成眼根所见的粗境，那还要粗果色做什么？既然果是多分和合所成的粗色，就应当不是实有。如此，你们前曾执著果色不越因量，现在又执粗果是多分合成，这岂不是前后矛盾吗？

    论文二十四：又果与因俱有质碍，应不同处如二极微。若谓果因体相受入，如沙受水，药入镕铜，谁许沙、铜体受水、药。或应离变非一非常。又粗色果体若是一，得一分时应得一切，彼此一故彼应如此。不许违理，许便违事。故彼所执，进退不成。但是随情虚妄计度。

    讲解：再说，粗色的果，和细色的本因极微，既然都是有质碍的东西，就应当像两粒极微一样，不在同一处所，怎么说是多分合成呢？若再诡辩的说：果和因的体虽是二，但能互相受人，果色能容受本因极微，本因极微也能容受果色，好像沙能纳受水，药汁可以用以镕入铜一样。试问谁会承认这沙铜的体能受水、药的谬论呢？当知水药只能入二粒沙铜极微的空隙里，不能入一粒沙铜极微之体。所以当沙受水时，二沙应即分离，铜受药时，应即变质。离则非一，变则非常。果色和极微互相受入，也是非一非常。

    假如说，粗色果其体整个是一，那么随便得到那一分时，应该得到了一切分。因为你们执著彼此是一体之故，得此也应如得彼。你们赞不赞成这种说法呢？如果不赞成，那就违背了粗果色体是一的道理。如果赞成，便与世间彼此非一的事实相违。所以你们所说的实法，无论是许与不许，都不能够成立，不过是随著虚妄情执的计度而已。

    论文二十五：然诸外道，品类虽多，所执有法，不过四种。一执有法与有等性，其体定一，如数论等。彼执非理，所以者何？勿一切法即有性故，皆如有性体无差别，便违三德我等体异，亦违世间诸法差别。又若色等即色等性，色等应无青、黄等异。

    讲解：古代印度的外道有九十六种之多，不仅上文所破的十三种，即数论派，便有十八部之多。然而外道的种类虽多，究其所执的实有实法，归纳起来不过四种。第一种是数论外道。数论外道执二十五谛中的大等二十三谛，是所生的‘有法’，第一个冥谛是能生之性，这能生和所生之体，决定是一。论主认为此说没有道理，因为不可说一切法都是‘有’性，如果一切法都是有性，那一切法岂不都同有性一样，没有差别的法体了吗？这不但违背其自教三德（萨埵、剌阇、答摩），及‘我’等二十三法体相各异的宗旨，而且也违背了世间共许诸法差别的事实。再者，如果色等即是色等之性，那就没有青、黄、赤、白等的分别了。

    论文二十六：二执有法与有等性，其体定异，如胜论等。彼执非理，所以者何，勿一切法非有性故，如已灭无，体不可得，便违实等自体非无，亦违世间现见有物。又若色等，非色等性，应如声等非眼等境。

    讲解：前面说的所生之法和能生之性是一，论主已予破斥。又有胜论师执六句义中的有句是能生的‘有等性’，其余实等五句是所生的‘有法’，有法与有等性的体决定不同。论主仍斥为非理，因为不可执著一切法没有能生的性，若执一切法没有能生的性，当然也就没有依之所生之法，这岂不是像已竟消灭了的东西，连体性都没有了吗？这不但违背你们自教实、德、业等非无自体的宗旨，而且也违背了世间现见的所有一切。又如果色等没有色等的有性，那就应当像声、香、味一样，不是眼根所能缘之境。

    论文二十七：三执有法与有等性，亦一亦异，如无惭等。彼执非理，所以者何？一异同前一异过故，二相相违体应别故，一异体同，俱不成故，勿一切法皆同一体，或应一异，是假非实。而执为实，理定不成。

    讲解：论文中的‘如无惭等’，无惭指的是无惭外道，就是耆那教，为公元前六至五世纪间，尼乾陀若提子所创立。因该教信徒修裸体苦行，不知羞惭，故佛教毁之为无惭。无惭外道所执的，是一切法体的共相为‘有等性’，一一法体的别相为‘有法’。共相是一：别相是异，像无惭外道。此等执著也没有道理，你若执一，即同前数论等执一的过失一样；若执异，即同前胜论等执异的过失一样，一不是异，异也不是一：这二相既然相违，体也应当有别。否则，你这一异同体的二相，就互相抵消都不能成立了。所以不可执著一切法都是同一个体，或者说一也是假、说异也是假，你们一定执为实法，这道理定然不成。

    论文二十八：四执有法与有等性，非一非异，如邪命等。彼执非理，所以者何？非一异执同异一故。非一异言为遮、为表？若唯是表，应不双非，若但是遮，应无所执。亦遮亦表应互相违；非表非遮，应成戏论。又非一异，违世共知有一异物，亦违自宗色等有法决定实有，是故彼言唯矫避过。诸有智者勿谬许之。

    讲解：论文中的‘如邪命等’，邪命指的是邪命外道，创始人相传是六师外道之一的末伽梨俱舍梨子，他否认因果报应，自称正命（正当的生活），佛教斥之为邪命外道。邪命外道所执的，法和性既不是一，也不是异。

    论主斥此也无道理，因为非一就是异，非异就是一，非一非异的执著，同前面所破三家一异的过失是一样的。试问这非一非异的话，是遮遣之词呢？还是表显之词呢？设若是表显，就不应当双非，设若是遮遣，应当没有所执。若既遮又表，就应当是二相互违，非表非遮，就成为无意义的戏论了。

    同时，世间人所知道的，不是一，就是异。现在你说既不是一，又不是异，这就犯了世间相违过。一异俱非，也与自宗相违背。所以他们所说的话，由于上述原因，你们主张非一非异的话，完全是矫诈诡辩，苟且避过之词，凡是有智慧的人，不要谬许他们说的是离言自性。


第四章　释难破执．破余乘

    第四章　释难破执．破余乘

    论文一：余乘所执，离识实有色等诸法，如何非有？彼所执色、不相应行，及诸无为，理非有故。且所执色，总有二种：一者有对，极微所成；二者无对，非极微成。

    讲解：前面讲的是外道的法执，此下讲的是小乘的法执。余乘，就是大乘之外的小乘各部派。有人问曰：大乘以外，其余的小乘部派，他们执著于离开心识之外，而有色等六尘诸法，怎么说是没有呢？

    论主答曰：小乘佛教的七十五法，除了不执著心王法和心所有法是离心而有，故不必破之，其余所执的色法、不相应行法及诸无为法，按道理说都是‘没有’。（注：小乘说一切有部，建立五位七十五法，其中有为法七十二种，一者色法十一种：为眼、耳、鼻、舌、身、色、声、香、味、触、无表色。二者心法一种。三者心所有法四十六种，含遍大地法十种，为受、想、思、触、欲、慧、念、作意、胜解、定。大善地法十种，为信、勤、舍、惭、愧、无贪、无嗔、不害、轻安、不放逸。大烦恼地法六种，为无明、放逸、懈怠、不信、昏沉、掉举。大不善地法二种，无惭、无愧，小烦恼地法十种，为忿、覆、悭、嫉、恼、害、恨、谄、诳、憍。不定地法八种，为恶作、随眠、寻、伺、贪、嗔、慢、疑。心不相应行法十四种，为得、非得、同分、无想果、无想定、灭尽定、命根、生相、住相、异相、灭相、名身、句身、文身。无为法三种，为虚空无为、择灭无为、非择灭无为）

    且说有部所执的十一种色法，归纳起来不过二种，一种是有对碍的色法，有部说是极微所成。一种是无对碍的色法，那就不是极微所成。

    论文二：彼有对色，定非实有，能成极微非实有故。谓诸极微若有质碍，应如瓶等是假非实。若无质碍，应如非色，如何可集成瓶、衣等。

    讲解：这对碍的色法，决定不是实有。因为能成的极微就不是实有。现在来研究这能成色法的极微，到底有没有质碍？若有质碍，就应该像花瓶、衣服一样，是假合而不是实有。若说没有质碍，应当同虚空一样，怎么可以和合起来成为花瓶、衣服呢？

    论文三：又，诸极微若有方分，必可分析，便非实有。若无方分，则如非色，云何和合，承光发影？日轮才举照柱等时，东西两边光影各现，承光发影处既不同，所执极微定有力分。又若见触壁等物时，唯得此边，不得彼分，既和合物，即诸极微，故此极微，必有方分。又诸极微，随所住处，必有上下四方差别，不尔，便无共和集义。或相涉入，应不成粗。由此极微定有方分。

    讲解：小乘经量部计极微有方分，萨婆多部计极微无方分，极微即和合，和合即极微。论主破之曰：极微若有方向和位分，那必定可以分析，便不是实在有的东西。极微若无方分，那就如虚空一样，怎么能够和合为承光发影的粗色呢？例如早上太阳出来照到一根柱子，如果这柱子的东边承光，那西边一定会现影。承光和发影的处既不同，那么极微决定是有方分的。这是破经量部。又如当眼根见得或身根触得墙壁的这一面时，就不能同时见得触得那一面，你既然执和合物即是极微，今和合物有方分，所以极微也必然有方分。这是破萨婆多部。

    再者，诸极微无论细到什么样子，它总是物质，每一极微的周围，必定有上下四方等六分接触面（加上中心部分共为七分），不然的话，就没有众极微和集聚的意义。如果你说好像光影一样，可以互相涉入而为一粒极微，那就不能成为粗色。由此可知，极微决定是有方分。

    论文四：执有对色，即诸极极，若无方分，应无障隔，若尔，便非障碍有对。是故汝等所执极微，必有方分，有方分故便可分析，定非实有。故有对色实有不成。

    讲解：你们所执的有对色即是极微，那一定有方分。如果没有方分，应当如虚空一样，就没有障隔。果然如此，那极微便不是有对碍的色法了。以此之故，你们所执著的极微，必定是有方分，因为有方分便可分析，所以决定不是实有。因为能成的极征不是实有之故，所成的有对碍色，实有也不能成立。

    论文五：五识岂无所依缘色？虽非无色、而是识变。谓识生时，内因缘力，变似眼等色等相现，即以此相为所依缘。然眼等根，非现量得，以能发识比知是有，此但功能，非外所造。外有对色理既不成，故应但是内识变现，发眼等识，名眼等根，此为所依生眼等识。

    讲解：外人问曰：如果说，能成的极微及所成的对色都非实有，那么前五识岂不是没有所依的眼等五根、及所缘的色等五境了吗？因为五根及五境，都是有对碍的色法啊。论主答曰：虽然前五识不是没有所依的根与所缘的境，而根、境等色却是内识之所变现，并非离识别有极微所成的根境。也就是说：八识生起现行的时候，都是从第八识里种子因缘的力量，变现根身和器界的相分。前五识即以此相分所变的根为所依，所变的境为疏所缘缘，又在此疏境上变起自识的相分为亲所缘缘。

    我们要知道，眼等五根，不是现量可以得到的，因为它能够发生五识，所以是比量而知，以它有发识的功用与能力，所以称之为根，并不可以说它是外面的色法所造成的。外面的有对色既然不能成立，因此说是内识变现。因为能够发生眼等五识，所以才叫它是眼等五根，这就是眼等五识所依托的根。

    论文六：此眼等识，外所缘缘，理非有故。决定应许自识所变为所缘缘，谓能引生似自识者，汝执彼是此所缘缘。非但能生，勿因缘等，亦名此识，所缘缘故。

    讲解：此眼等前五识，若以外境作所缘缘，在道理说是没有的。既然没有外境为所缘缘，那就决定应许用自己的心识所变的相分，来做为自识见分的亲所缘缘。你们小乘把能够引生自识的，执之为此识的所缘缘。但做为所缘缘两有两个条件，一是能生，二是带相。如果但有能生，没有带相，那就不可以做所缘缘。因缘、等无间缘、增上缘，它们都有引生的功能，但因没有带相，所以都不能作所缘缘。

    论文七：眼等五识，了色等时但缘和合，似彼相故。非和合相异诸极微有实自体，分析彼时，似彼相识定不生故。彼和合相既非实有，故不可说是五识缘。勿第二月，能生五识故。非诸极微共和合位，可与五识各作所缘，此识上无极微相故。非诸极微，有和合相，不和合时无此相故。非和合位，与不合时，此诸极微，体相有异，故和合位如不合时，色等极微非五识境。

    讲解：小乘师谓：眼等五识了别色等五尘的时候，不缘极微，但缘极微所成的假和合相，此假和合相，名叫‘似彼相’。和合相，并不是离开极微别有其实在的自体，试把和合相分析到不成其为和合时，那似和合相的识，就决定不能生起。所以知道这和合相没有实在的自体。这和合相既然不是实有，就不可说它是前五识所缘做境界。因为不可说捏目所见的第二月，也能引生起前五识。所以无论是和合与不和的极微，都不是眼等五识的所缘之境。

    论文八：有执色等一一极微，不和集时非五识境，共和集位展转相资有粗相生，为此识境。彼相实有，为此所缘。彼执不然，共和集位与未集时体相一故。瓶、瓯等物极微等者，缘彼相识应无别故，共和集位一一极微，各各应舍微圆相故。非粗相识缘细相境，勿余境识缘余境故，一识应缘一切境故。

    讲解：以上是破极微但能为缘，不能为所缘，因五识不带极微相故。萨婆多部闻之自救曰：色等一粒一粒的极微，在没有和合集聚以前，当然不是眼等五识的所缘境，但在和集以后，彼此展转资助，便有粗相生起，可以作为五识的所缘境了。因为粗相是实有法，可以作为前五识的所缘缘了。

    论主说：这种执著还是不对，因为二极微和集相资，与未和合相资时的体相总是一样的，花瓶茶杯的形相虽然不同，而能成的极微是一样无二。所以缘彼极微相的识，就应当没有差别。到了共和集的时候，一一极微都舍弃了微圆的相，所以你不可以用缘和集粗相的识，去缘极微的细相境。如果用粗相识去缘细相境，那眼识可以缘音声，耳识也可以缘香臭，或者一个识也可以缘一切境了。

    论文九：许有极微，尚致此失，况无识外真实极微。由此定知，自识所变似色等相为所缘缘。见托彼生，带彼相故。

    讲解：赞成有实极微，尚且招致以上过失，何况按唯识正义，心识之外根本就没有真实极微。由以上各种道理推究，可以知道外色不能做所缘缘，决定是以自己的第八识所变的相分为所缘缘。此具足两个条件：一是自识的见分托彼相分而生；二是又能带彼相分而起，所以相分色才可以做所缘缘。

    论文十：然识变时随量大小，顿现一相，非别变作众多极微合成一物。为执粗色有实体者，佛说极微令彼除析，非谓诸色实有极微。诸瑜伽师以假想慧，于粗色相渐次除析，至不可析假说极微。虽此极微，犹有方分，而不可析，若更析之，便似空现，不名为色，故说极微是色边际。

    讲解：然当自识变现相分境的时候，是随著其体量的大小，顿现一相。并不是先变成许多极微，然后再和合成为一物。这就是大乘唯识家，和外道小乘不一样的地方。

    外人反问曰：你们为什么说没有极微呢？一般人执著粗色有实体，所以佛告诉他们分析粗色，看看极微有没有实体，并不是说极微就有极微的实体。修境、理、行、果、机相应的瑜伽师，用假想的观慧，渐渐把粗色作一次一次的分析，到无可再分的程度，假说叫做极微。此极微虽然犹有方分，却不可再分析下去，设若再分析下去，那极微便似虚空相现，不得名为色相了。所以说极微是色、空的边际。

    论文十一：由此应知，诸有对色皆识变现，非极微成。余无对色是此类故，亦非实有。或无对故如心、心所定非实色。诸有对色现起色相，以理推究离识尚无，况无对色现无色相，而可说为真实色法？

    讲解：由此应当知道，凡是有对碍的色法，都是由自己内识所变现，并不是由所谓极微的和合而成的。眼等五识所起的有对碍色，已如前破。其余‘法处’所起的无对碍色，也不是实有。因为它和这有对碍色是同类之故。或者因为它是无对碍的缘故，所以也同心、心所法一样，决定不是实有的色法。现有色相可见的一切有对色，以理推究，尚且不是离识而有实体，何况无色相可见的无对色，而可说为真实的色法吗？

    论文十二：表无表色，岂非实有？此非实有，所以者何，且身表色若是实有，以何为性？若言是形，便非实有，可分析故，长等极微不可得故。若言是动，亦非实有，才生即灭，无动义故。有为法灭不待因故，灭若待因应非减故。

    讲解：前面讲的是方圆大小的形色，现在讲的是行住坐卧的表色、和心理动态的无表色。外人问：你们唯识家既然说有、无对色都不是实有，那么有表色及无表色，岂不是实有吗？唯识家答曰：这表、无表色，当然也不是实有，什么理由呢？先说这依身而起的表色，如果身行的动作是实有的话，试问以什么东西来做他不变的体性呢？若说身的形色就是表色的体性，那便不是实有，因为凡是有形色的东西，都是可以分析的，至于说构成形色的长短极微，早已为长短形色而失其本圆相，更谈不到是实有了。

    若说身业的动作就是表色的体性，那也不是实有，因为有为法都是刹那生灭，根本没有动的实在性。所以有为的生灭法，并不等待什么灭的原因而后始灭，如果灭要待因的话，那就不是灭而是生、住了。

    论文十三：若言有色，非显非形心所引生，能动手等，名身表业，理亦不然。此若是动，义如前破。若是动因，应即风界，风无表色定不应名表。又触不应通善恶性，非显香味，类触应知。故身表业，定非实有。

    讲解：若说别有一种色法，既不是青、黄、赤、白的显色，也不是大、小、方、圆的形色，而是由心力所引生的色，能够令手足动作自在，这就叫做身表业。这种说法，在道理上也不对。此若是动，那在前面已经破过了。若说不是动而是动的因缘，那应当是风界，然而风是没有表示的，不应该叫做表色。

    又，身根是通于善、恶、无记三性的，风为触尘所摄，但通无记，不应名为身表业。应当知道不属于显色的香、味等尘，也同触尘一样不是身表业。所以你们所说的身表业，决定不是实有。

    论文十四：然心为因，令识所变手等色相，生灭相续，转趣余力，似有动作，表示心故假名身表。语表亦非实有声性，一刹那声无诠表故，多念相续便非实故。外有对色前已破故。然因心故识变似声，生灭相续似有表示，假名语表，于理无违。

    讲解：然而，以第六识内心为因，由第八识变现手等色相，好像有相在那里相续，似有动作，假名身表，并不是离心识之外，另有一个名身表的缘故，安立假名称为身表业。语表也没有真买的语性，一刹那之声不能表示一定的意思，多念相续心不是真实的存在。客观的有对色，前面已经破斥。然而也是由于第六识心动的缘故，第八阿赖耶识变现了相分声，生灭相续好像有所表示，假名为语表，实际上并没有实在的语音。这生灭相续好像是有，安立假名称为语表，在道理上并不违背。

    论文十五：表既实无，无表宁实？然依思愿善恶分限，假立无表，理亦无违。谓此或依发胜身语善恶思种，增长位立，或依定中止身语恶现行思立，故是假有。

    讲解：有表色已如前破，非实有之法，无表色可以说是实有吗？然而大乘所说的无表色，虽非实有，却是依思心所的活动，依思愿善、恶分限而假立，这在道理是不违背的。此外还有二种分别，一种是散无表，依发殊胜身、语善、恶的种子思心所，在止恶作善，止善作恶的功能增长时而假立的。二种是定无表，依定中止息身、语恶的现行思心所而假立的。这二种无表色，因为是假名安立，所以说是假有。

    论文十六：世尊经中，说有三业：拨身、语，业岂不违经？不拨为无，但言非色。能动身思说名身业，能发语思说名语业，审决二思意相应故，作动意故，说名意业。

    讲解：外人问：佛经中说有身、语、意三业，你们拨无身、语二业，说唯有识，岂不是与经义相违？唯识家答，我们何曾拨无身、语二业，不过说那不是色法，是由思心所主动罢了。思有三种，一是审虑思，二是决定思，三是动发胜思。这第三的动发胜思。能发动取、舍、屈、伸的身表，名叫身业，能发动名、句、文的语表，名叫语业。其余的审虑和决定二思，则是与意识相应而为意识活动，所以名叫意业。

    论文十七：起身语思，有所造作，说名为业。是审决思所游履故，通生苦乐异熟果故，亦名为道，故前七业道，亦思为自性。或身语表，由思发故，假说为业，思所履故，说名业道。由比应知，实无外色，唯有内识变似色生。

    讲解：这思心所，能够发动身、语有所造作，所以名之为业，这是经过审虑思和决定思，由思心所动发身语，造作善、恶之业，同时也通于善恶所生的苦、乐二种异熟当果。所以不但名之为业，也名之为道。不但意识所起的贪、嗔、痴等后三业道，是以思为体性的，就是属于身所造的杀、盗、淫，语所造的妄言、绮语、两舌、恶口等的前七业道，也是以思为体性的。

    最后总结前面所破的一切色法。由于前面破一切色法的道理，应当知道实在没有心外的色法，但有内识所变现那似是而非的色法生起。

    论文十八：不相应行，亦非实有。所以者何？得、非得等，非如色、心及诸心所体相可得，非异色、心及诸心所作用可得。由此故知，定非实有，但依色等分位假立。

    讲解：在小乘七十五法中，行蕴有二，一是相应行，就是四十六个心所，因为它们同心王相应，故称相应行；二是不相应行，就是十四个得、非得等，它们不与心王相应，故称不相应行。这十四个不相应行法，也不是实有。何以见得？因为它们不同于色法、心法、及心所有法一样有体相可得，也不是离了色法、心法、及心所有法，有作用可得，所以知道它不是实有：不过在色、心等法的分位上假立名言而已。

    论文十九：此定非异色、心、心所有实体用，如色、心等许蕴摄故。或心、心所及色、无为所不摄故，如毕竟无定非实有。或余实法所不摄故，如余假法，非实有体。

    讲解：这肯定不是有异于色法、心法、心所法的真实本体及作用，如色法、心法等可以是五蕴所摄，或者并非由心法、心所有法及色法、无为法所摄取，就如毕竟无那样肯定不是实有。或者说，心不相应行法，并不由其余的实法所摄取。所以，心不相应行法像其他虚假事物那样，并非实有其体。

    论文二十：且彼如何知得、非得，异色、心等，有实体用？契经说故，如说：如是补特伽罗成就善恶，圣者成就十无学法。又说异生不成就圣法，诸阿罗汉不成就烦恼。成不成言，显得非得。

    讲解：以下是依次别破十四个不相应行法。先假说问答：你怎样知道得、非得等，离开了色心等法，别有实在的体用呢？答曰：佛经上说过，就像补特伽罗成就善、恶一样，佛教圣人成就十种无学法，这就是成就。佛经还说凡夫不成就佛教圣法，诸阿罗汉不成就烦恼，这叫做不成就。成就就是‘得’，不成就就是‘非得’。（注一：契经，是上契佛理：下契众机的佛经。注二，补特伽罗，翻为数取趣，即异生之类，数数轮回于五趣之中。注三，十无学法是：正见、正思惟、正语、正业、正命、正精进、正念、正定、正解脱、正智。）

    论文二十一：经不说此异色、心等，有实体用，为证不成。亦说轮王成就七宝，岂即成就他身非情？若谓于宝有自在力，假说成就，于善、恶法何不许然，而执实得？若谓七宝在现在故，可假说成，宁知所成善恶等法，离现在有？离现实法理非有故。现在必有善种等故。

    讲解：外人引经为证，唯识家也以教理难曰：经上但说成不成，并没有说离开色、心等法，别有成不成的实在体用。所以你引经为证，是不能成立的。

    契经上也说转轮圣王成就七宝，难道说是轮王，变成他身有情及非情了吗？若说因为轮王七宝，有随心所欲的自在力用，所以假说名为成就，并非实有七宝可得。那么，凡夫于善恶法，为什么不许说是唯识所变，假名成就，一定要执著有实法可得呢？若说因为七宝是现在有的缘故，可以假说名为成就，那你又怎样知道所成的善、恶等法，是离开现在而有，不名成就呢？因为离开现在的实法，理上就没有，现在法必须有善种的缘故。

    论文二十二：又得于法有何胜用？若言能起，应起无为。一切非情应永不起，未得已失应永不生。若俱生得为因起者，所执二生便为无用。又具善、恶、无记得者，善、恶、无记应顿现前，若待余因，得便无用。

    讲解：再问，你这个得，在一切法上，究竟有什么殊用呢？若说这个得有生起诸法的胜用，那你们自许有得的无为，就应该能够生起。无得的非情器界，及未得、已失等法，就应该永久不生。然而事实并不如此，有得的无为，不见得就能够生起，无得的非情，及未得已失等法，反倒能够生起了。若说非情及未得已失等法，现虽无得，但它们都有一个与生俱生的得，能为后时生得之因。如此说来，那你们所执著的有为九法中的本生和随生，不是就没有互为能所的作用了吗。

    再者，俱生得，具有善、恶、无记三性，那善、恶、无记，就应当随著俱生得一时顿现。若虽有得，须待余因方能俱起者，那么，余因自能生法，要得干吗用呢？

    论文二十三：若得于法是不失因，有情由此成就彼故，诸可成法不离有情，若离有情，实不可得，故得于法，俱为无用。得实无故，非得亦无。

    讲解：假若这个得，于一切法是不失的因，所以有情类由此得因，就可以成就善、恶等法。照这样说，凡是可以成就的法，便不能离开有情，设若离开有情，那还有什么得？所以这个得，对于一切法来说是没用的。推究起来，得实无故，所以非得亦无。

    论文二十四：然依有情，可成诸法，分位假立，三种成就：一种子成就，二自在成就，三现行成就。翻此假立不成就名，此类虽多，而于三界见所断种未永害位，假立非得，名异生性，于诸圣法未成就故。

    讲解：然而依据有情可以成就之法，方便立为三种成就，一者种子成就，二者自在成就，三者现行成就（注：种子是业因，自在是业力，现行是业果）。正面既然是成就──得，翻过来当然是非得。这不成就的种类虽然很多，但对于三界见道所断的烦恼，在种子没有被圣道永远损害的时候，这方便建立叫做非得，名异生性（凡夫），因为对于圣人的无漏法，没有成就的原故。

    论文二十五：复如何知异色、心等有实同分？契经说故，如契经说此天同分，此人同分，乃至广说。

    讲解：不相应行第一为得，第二为非得，已如前破，现在破第三同分。小乘执同分为一实法，论主问曰：你又怎样知道离开色、心等法，别有一个同分的实法呢？外人答曰：这是佛经上说的。经上说：大家同是天人，就是天同分；同生人趣，就是人同分，乃至广说四圣六凡一切同分。

    论文二十六：此经不说异色、心等，有实同分，为证不成。若同智言因斯起故，知实有者。则草木等应有同分。又于同分起同智言。同分复应有别同分。彼既不尔，此云何然？

    讲解：此下是论主对外人的非难：经上但依色、心假说同分，并没有说离色、心之外，别有同分的自体，所以你举经上的证据，是不能成立的。同智言，就是对同分理解的智慧，及表诠的言说。如果你认为有了同分理解的智慧，及表诠的言说，所以知道实有同分。那么，则吾人亦尝对草木之类起同分的智解与言诠，了解它是那一类，难道也可以叫它是松同分，柏同分吗？因为佛经上没有说无情之物也有同分。

    还有，假如是因同智和同言，就说实有同分，这样一来，同分之中又可再分别同分，这样分了又分　岂不是犯了无穷之过吗？设若如此，为何说有一个真实的同分呢？

    论文二十七：若谓为因起同事、欲，知实有者理亦不然，宿习为因，起同事欲，何要别执有实同分？然依有情身、心相似，分位差别，假立同分。

    讲解：同事；是同作一种事业，同欲，是同趣一种欲境。假若你说，以同分为因，然后才能生起同事或同欲，所以知道有一个实在的同分，这道理也不对。因为这是由无始以来的熏习为因，才能生起现世的同事同欲，为什么要另执一个实在的同分呢？

    小乘执色、心之外别有实同分既被破斥，那么大乘的同分是怎样呢？唯识家只用假立两个字说：不过依于有情的身心相似，在分位的差别上假立一个同分的名而已。

    论文二十八：复如何知，异色、心等，有实命根。契经说故，如契经说，寿、暖、识三，应知命根，说名为寿。此经不说异色、心等，有实寿体，为证不成。又先已成色不离识，应此离识无别命根。又若命根，异识实有，应如受等，非实命根。

    讲解：论主问：你们又怎样知道，离开色、心等法，别有一个实在的命根呢？外人答：因为佛经上有这样说。经上说寿、暖、识三法就是命根。因此知道命根叫做寿命。

    论主非难曰：经上并没有说，离开色、心之外，别有寿的实体。所以你举经为证，不能成立。又前在破色法里，说了许多色法是不能离开心识的。那么暖也是色法的一种，命根又是寿、暖、识三法所摄。依理推征。离开了识别无所谓的命根。假使命根是离识而有的话，那就应当如离识无体的受、想一样，不是实在的命根了。

    论文二十九：若尔，如何经说三法？义别说三，如四正断。住无心位，寿、暖应无，岂不经说，识不离身？既尔，如何名无心位？彼灭转识非阿赖耶，有此识因后当广说。此识足为界、趣、生体，是遍恒续异热果故，无劳别执有实命根。然依亲生此识种子。由业所引功能差别，住时决定，假立命根。

    讲解：本节是外人与论主三问三答。外人一问：如果三法都是识的话，为什么经上说有寿、暖，识三法呢？答：那是对阿赖耶一识约义不同，所以分开说三。约识的相分身根所摄色，名叫做暖；约识的种子能持，名叫做寿；约识的现行，名叫做识。这同四正断一样，但是一个勤心所，约善、恶已生、未生二义，别说四法（注：四法即四正断，又名四正勤，为令已生恶除断而勤精进。为令未生恶不生而勤精进。为令未生善生起而勤精进。为令已生善增长而勤精进。）。

    外人二问：既然寿、暖体唯一识，那么入灭尽定的无心位时，心识都停，寿、暖为何不随之而无？答：经上说入灭尽定的人，因为识还没有离身，所以寿命照样存在。

    外人三问：入灭尽定的人，识既未灭，为什么叫它无心定呢？答：所谓无心，他灭的是前七转识，并不是连阿赖耶识都灭了。关于阿赖耶识，后面当有详细说明。

    此第八阿赖耶识，足能够为三界、五趣、四生等的轮回报体。它是普遍的、恒常的、相续的去受隔世成熟的果报，用不著另外执著一个实在的命根。第八阿赖耶识亲生自己现行法的种子，这种子由宿世善恶业力引生功能差别，决定了众生一期住世时限的长短，依此假立名为命根。

    论文三十：复如何知，二无心定，无想异熟，异色、心等有实自性？若无实性，应不能遮心、心所法，令不现起。

    讲解：此节是破不相应行第五无想定、第六灭尽定、第七无想果。二无心定，就是无想定及灭尽定。无想异熟就是无想果，亦名无想天，就是修无想定生天的果报。论主问：你怎样知道，无想定、灭尽定、无想天，离开色、心等法而有实在的自体？外人答：假若这三法没有实在的体性，就应当不能够遮碍心王及心所法，使它暂时不能现起。既有遮碍的功能，可见它们是有实体。

    论文三十一：若无心位，有别实法，异色、心等，能遮于心，名无心定，应无色时，有别实法，异色、心等，能碍于色，名无色定。彼既不尔，此云何然？又遮碍心，何须实法？如堤塘等，假亦应遮。

    讲解：论主破曰：倘若照你们说，这三种无心位离开色、心等法，别有一种非色非心的实法，能遮碍于心，令不起现行，就叫做无心定。那么，应当入无色位时，也别有一种非心非色的实法，能遮碍著色，令不现起，名无色定，你赞成吗？如果不赞成有一个实法能遮碍于色，那你为什么又要说有一个实法，来遮碍于心呢？同时，遮心何必一定要用实法；如堤、塘遮水一样，假法也可以遮碍于水不往外流啊！

    论文三十二：谓修定时，于定加行，厌患粗动心、心所故，发胜期愿，遮心、心所，令心、心所渐细渐微，微微心时，熏异熟识，成极增上，厌心等种。由此损伏心等种故，粗动心等暂不现行。依此分位，假立二定。此种善故，定亦名善。

    讲解：说一切有部认为，在修习禅定时，因加行功用，厌患那七转识粗动的心、心所，发起一种殊胜的期许与愿望，想著收到遮碍这心王心所的预期效果。令这些心王心所渐次由粗而细，由细而微，微之又微的刹那心时，熏在第八异熟识上，成了一种极增上厌心种子。由此一种加行厌患的势力，把这些心种慢慢的损灭或暂伏，到粗动的心王心所不起现行的时候，就在这一期无心的分位上，安立了无想定、灭尽定两个假名。因此厌心是善的种子，所以这两个定名也叫做善。

    论文三十三：无想定前，求无想果，故所熏成种，招彼异熟识。依之粗动想等不行，于此分位假立无想。依异熟立，得异熟名。故此三法，亦非实有。

    讲解：在修无想定的时候，其目的就是求无想果，所以由熏习而成的种子，招感无想天的异熟识报体。这时依本识而生的粗动心等，便不起现行。就在此无心的分位上，安立了无想的假名。因为是依于异熟识而建立的果法，所以也得名为异熟。由于以上所说的种种道理，这无想定、灭尽定、无想果三法，也不是实有。

    论文三十四：复如何知，诸有为相，异色、心等，有实自性？契经说故，如契经说有三有为之有为相，乃至广说。此经不说，异色心等，有实自性。为证不成。非第六声便表异体，色、心之体即色心故。非能相体定异所相，勿坚相等异地等故，若有为相异所相体，无为相体应异所相。

    讲解：此下破不相应行八至十一，生、住、异、灭四相。论主问外人曰：你们怎样知道生、住、异、灭四有为相，离开了色、心等法，别有实在的体性呢？外人答：因为佛经上说过，有为法，有三种有为相，生、住异、灭，因为住相为有情所爱著，为舍爱故，把住异合说为一。乃至广说，无常一相，生、灭二相，住异灭三相，这不过是四相开合不同罢了。

    经上但说，四相与色、心等法非一非异，并没有说离开了色、心等法之外，别有实在的自性，因此你们引用经上的证据，是不能成立的。

    你们不可以说，因为有第六的属声，便能够表示另外有一个异体。例如，色法和心法的体性，就是在色法和心法上有。不能说，离开色、心等法之外，另有什么色、心的体性。并不是能相的生、住、灭，离开了色、心等法的所相。试想坚、湿、暖、动的能相，能离开地、水、火、风的所相吗？当然不可以。如果照你们说，有为法的生、住、灭，一定离开了色心等法的体，那么，无为法的相，也可以离开无为法的体了（注：梵文文法，表示名词的变化，有八种语格，名八转声。这八转声是一体声、二业声、三具声、四为声、五从声、六属声、七依声、八呼声。第六声，就是这八转声中的第六属声。）

    论文三十五：又生等相，若体俱有，应一切时齐兴作用，若相违故用不顿兴，体亦相违，如何俱有？又住、异、灭用不应俱。

    讲解：又生、住、异、灭四相，设若其体性是同时俱有，就应当一切时都能够同起作用，何以不能呢？若说它们的作用是前后相违，所以起不同时；体非相违，故能俱有。那么，体与用是不相离的，用既相违，体也应当相违，怎能说它是同时俱有呢？又，住、异、灭三相的作用，也是不应当同起，因为它们前后相违。

    论文三十六：能相所相，体俱本有，用亦应然，无别性故。若谓彼用更待因缘，所待因缘应非本有，又执生等便为无用。所相恒有而生等合。应无为法亦有生等。彼此异因不可得故。

    讲解：有外人执：体为本有，用离体无。论主破曰：能相的生、住、异、灭，和所相的色、心等法，它们的体性都是本有。那么，它们的作用也应当都是本有，因为体和用是不能离开的。若说此体是本来俱有，用则须更待因缘，那么所待的因缘，当然不是本有的亲因缘了。这样一来，你们所执著的生、住、异、灭四相，对于色、心等法上，就没有关系了。

    假定说，色、心等法的所相三世恒有，因为和生、住、异、灭的能相合在一起的原故，所以使色心诸法也变成了无常相，如果照这样说起来，无为法恒有，就应当也有生、住、异、灭与之相合，这岂不是无为法也变成无常相了吗？因为有为法和无为法，都可以用生等相合之因，没有彼此的不同。

    论文三十七：又去来世，非现、非常，应似空华非实有性，生名为有，宁在未来？灭名为无，应非现在，灭若非无，生应非有。又灭违住，宁执同时？住不违生，何容异世？故彼所执，进退非理。

    讲解：对于四相的看法，小乘认为：生相属于未来，灭是属于现在。大乘主张：生是属于现在，灭是属于过去。又，小乘住灭可以同时，生住属于隔世。所以论主破曰：一者，过去世已成过去，未来世还没有到来，这既非现在，又非恒常，应当如空华一样，体性不是实有。二者，生因有而名生，未来既不是有，岂有生在未来之理？灭因无而名灭，现在既不是无，灭就应该不属于现在。若说灭相非无，那生相就不应该是有啊。三者，灭，明明是违背生，怎样可以执著是同时？住，是不会违背生的，为什么说他是异世？因此，你们所执著的，无论是进灭在现在，退生在未来，都不合于道理。

    论文三十八：然有为法因缘力故，本无今有，暂有还无，表异无为，假立四相。本无今有，有位名生，生位暂停，即说为住，住别前后，复立异名，暂有还无，无时名灭。前三有故，同在现在，后一是无，故在过去。

    讲解：然而有为法，都是依托著因缘的力量，本来没有，现在暂有；现在暂有，刹那还无。这不过为表示这不是无为法，所以才建立了生、住、异、灭四相的假名。

    本来没有现今有了，在此有位假立生名，生了之后，于暂停位假立住名，在暂停位以时间的推移，假立异名。法虽暂有，还归于无，这时又叫做灭。

    前面的生、住、异三相是有，所以同在现世，最后的灭是无，所以属于过去。

    论文三十九：如何无法与有为相？表此后无，为相何失？生表有法先非有；灭表有法后是无，异表此法非凝然，住表此法暂有用。故此四相，于有为法虽俱名表，而表有异。此依刹那，假立四相。

    讲解：外人问：假使灭法是无，怎么可以给有为法作相？答：灭法并不是表示现在有法，也不是表示本无、今无，是表示此现有法，于后时无。以此假作有为法相，有何过失？

    生，是表示现有的法，并不是先前就有。灭，是表示暂有的法，到后来终归于无。异，是表示此法并非凝然永不变灭，住，是表示此法暂时还有作用。所以这生、住、异、灭四相，在有为法中，虽然都名为表，而其所表的法，却各有不同的意义。这是依刹那生灭，假立的有为四相。

    论文四十：一期分位，亦得假立，初有名生，后无名灭，生已相似相续名住，即此相续，转变名异，是故四相皆是假立。

    讲解：上面是说，在刹那生灭中假立四相，其实从生至死的一期分位上　也可以假立四相。最初有的时候叫做生，到最后没有的时候叫做灭，生后相似相续的存在期间叫做住，即此相续盛衰的转变叫做异。因此之故，这一期四相，也都是假缘安立的。

    论文四十一：复如何知，异色、心等，有实诠表名、句、文身？契经说故，如契经说：佛得希有名、句、文身。

    讲解：此下破十四不相应行的最后三个，名、句、文身。论主问：你们又怎样知道，离开色、心等法，别有实在的名、句、文身呢？（注：显体为名，如五蕴是显色、心之体的名称。诠义为句，如五蕴皆空，是诠解色、心非有的句义。字名为文。聚积为身。聚积两个以上的名为名身，两个以上的句为句身，两个以上的字为文身。）

    外人答：因为佛经上说过：一成佛，就得未曾有的名、句、文身，所以知是实有。

    论文四十二：此经不说，异色、心等有实名等。为证不成。若名、句、文异声实有，应如色等，非实能诠。

    讲解：你们引经为证，可是经上并没有说虽开色、心等法，别有实在的名、句、文身。所以你们引用的证据不能成立。再进一步研究，假如名、句、文是离声而有实体的话，那名、句、文，如同色、香、味一样，就不是实在的能诠了。因为色、香、味是离开声音而有的，所以离开了声音就不能诠表了。

    论文四十三：谓声能生名、句、文者。此声必有音韵屈曲，此足能诠，何用名等？若谓声上音韵屈曲，即名、句、文异声实有，所见色上形量屈曲，应异色处别有实体。若谓声上音韵屈曲，如弦管声，非能诠者，此应如彼声，不别生名等。又谁说彼定不能诠。

    讲解：外人执名、句、文身由声而生。论主破他说：声如果能生名、句、文的话，那么这声本身就有音韵的调节，和屈曲的词义。这声音已足能诠解意义，何必再加上名、句、文身做甚么呢？若说声上的音韵屈曲，就是离声而实有的名、句、文身。那么我们看到色上的长、短、方、圆，并非离色别有，那名、句、文身又怎能离声而别有呢？若说声上的音韵屈曲，好像琴瑟等的弦声，笙萧等的管声一样，同样不能诠表义理。那么，声上也不能别有能诠的名、句、文身。如此说来，这语声上的屈曲，既如弦、管声一样不能诠表，就应当也如弦、管声一样，不能别生名、句、文。语声既不能别生名、句、文身，名、句、文即不离语声。又谁说彼决定不能诠表呢？

    论文四十四：声若能诠，风铃声等应有诠用。此应如彼，不别生实名、句、文身。若唯语声能生名等，如何不许唯语能诠？何理定知能诠即语？宁知异语别有能诠？语不异能诠，人天共了。执能诠异语，天爱非余。

    讲解：外人救曰：如果声音能起诠表作用，那么，风铃的声音应当也有诠表的作用，风铃声既不能诠表，那语声又如何能诠表呢？论主反驳曰：倘若照你们小乘的主张，这语声上的屈曲，就应当如风铃声一样，不能别生实有的名、句、文身。外人又申救说：如果认为只有语声能生名、句、文身，为什么不允许只有语声能够诠表，风铃声不能诠表呢？外人复问：根据什么理由，知道能诠表的就是语声？论主反诘：你又怎样知道离语声体，别有能诠的名、句、文身？言语和名、句、文，本来不是两个，这个道理不管是人是天都能了解。你们一定执著能诠的名、句、文身与语声无涉，则是你们这些天所怜憨的愚人这样说，其余的人是不会这样说的。

    论文四十五：然依语声分位差别，而假建立名、句、文身。名诠自性，句诠差别，文即是字，为二所依。此三离声虽无别体，而假实异，亦不即声，由此法、词，二无碍解，境有差别，声与名等，蕴、处、界摄，亦各有异。且依此土，说、名、句、文，依声假立，非谓一切。诸余佛土，亦依光明，妙香味等，假立三故。

    讲解：然而，依据语声分位差别，假立名、句、文身，名身诠释自性，句身诠释差别，文身就是梵文字母，是名身和句声的所依。名、句、文身虽然离声别无本体，由于名等之假和声上实有之间的区别，名、句、文身不等于声，由于法、词二无碍解缘境有别，声和名、句、文身于五蕴、十二处、十八界的所摄也各不相同。而且，依此娑婆国土以音声为教体而言，所以说名、句、文身依声而假立，并不是在一切处所都是这样，在其余的佛土也依据光明、妙香味等，假立触、思数上的名、句、文身。

    论文四十六：有执随眠，异心心所，是不相应，行蕴所摄。彼亦非理，名贪等故，如现贪等，非不相应。执别有余不相应行，准前理趣，皆应遮止。

    讲解：十四种不相应行诠释完毕，还有一家小乘，他们执著随眠（烦恼）的种子，离开心王心所，为不相应蕴之所摄。

    这种执著也不合理，因为随眠种子的名称，就是贪、嗔、痴、慢、疑诸惑，同现行的贪等没有两样，都是属于心、心所法，并非不相应行。还有执著其余的不相应行，如：流转、定异、相应、势速、次第、时、方、数、和合性、不和合性十种，也是实在的，那只要照前面所说的道理予以遮止，全不能够成立。

    论文四十七：诸无为法，离色、心等，决定实有，理不可得。且定有法略有三种，一现所知法，如色、心等。二现受用法，如瓶、衣等。如是二法，世共知有，不待因成。三有作用法，如眼、耳等。由彼彼用，证知是有。无为非世共知定有，又无作用，如眼、耳等。设许有用，应是无常。故不可执无为定有。

    讲解：十四个不相应行法己经破完，向下该破无为法了。小乘执有三种无为：虚空无为、择灭无为、非择灭无为，都是离开色、心等法，决定实有。论主斥之以理不可得。决定实有的法，略有三种，一是现在所知道的事物，例如色法心法。二是现在所受用的事物，例如花瓶和衣服等物。上面这两种东西　世界上的人都共知是有的，不须等待什么理由才能成立。三是有作用的法，例如眼、耳、鼻、舌、身等的五种净色根，虽然看不见，但由于五根发识的功能，所以证知它是有。

    无为法，不是世人共知是有，也不是有作用如眼、耳等。假设无为有作用，那就应当是无常。所以你们不可以执看著无为法定是实有。

    论文四十八：然诸无为，所知性故，或色、心等所显性故，如色、心等。不应执为离色、心等实无为性。

    讲解：三种无为法既非实有、究竟是怎样的非实有呢？一是佛、菩萨所知的境界。二是断我、法二执所证知的真如实性。三是由色、心等法所显的真如实性。所以是不能离开色、心等法之外，另有所谓实在的无为性。

    论文四十九：又虚空等，为一为多？若体是一，遍一切处，虚空容受色等法故，随能合法，体应成多。一所合处，余不合故。不尔，诸法应互相遍。若谓虚空不与法合，应非容受，如余无为。又色等中有虚空不？有应相杂，无应不遍。

    讲解：问：在虚空无为、择灭无为、非择灭无为中，虚空无为的自体，是只有一个呢？还是有许多个？如果是一体的话，虚空无为就应当遍一切处。如此的虚空无为，应能容受一切色法等。但色法不是一，所以虚空无为之体应成多个。又因为空体若是只有一个，则一处色合，和余处色就不合。如果不是这样的话，色法等应互相遍，此处色合时，余处色亦合，此处色即余处色。如果说虚空无为不与色法等合，就应当像择灭无为和非择灭无为一样，不受色法等。

    论文五十：一部一品结法断时，应得余部余品择灭。一法缘阙得不生时，应于一切得非择灭。执彼体一，理应尔故。

    讲解：结法，是烦恼的异名，迷于四谛之理的见惑四部，迷于事理的修惑一部，共为五部。按品类差别，分配于三界九地的见惑有八十八品，修惑有八十一品。择灭无为，是以智慧简择的功力，断除一切烦恼所证得的灭谛。

    上节讲虚空无为，本节讲择灭无为和非择灭无为。择灭，是智慧灭烦恼而证得灭理。意思是说，如果择灭无为是一的话，那么，断了三界见惑的时候，岂不是连三界思惑也断了吗。或者，一品的烦恼断了的时候，岂不是八十一品的烦恼全断了吗？因为你执无为是一，所以道理就是如此。至于非择灭无为，它是不由择法而证得的，那是因缺了生烦恼的缘。如果非择灭无为也是一的话，那么，一法缺缘到了不生的时候，应该对于一切法都要得到非择灭。因为你执其体是一，所以道理就是如此。

    论文五十一：若体是多，便有品类，应如色等非实无为。虚空又应非遍容受。余部所执离心、心所实有无为，准前应破。

    讲解：上节破无为其体是一，此节破无为其体是多。如果无为法的体是多，那便有品类各各不同，就应当同色法一样，不是实在的无为了。再者，若无为法其体是多的话，那虚空无为，就应当有许多普遍的容受。

    除了上面的三种无为外，还有大众四部等，执著杂开心王、心所，别有实在的四无为、六无为、九无为，都可以照前面三种无为的破法破之。

    论文五十二：又诸无为许无因果故，应如兔角，非异心等有。然契经说，有虚空等诸无为法。略有二种，一依识变，假施设有，谓曾闻说虚空等名，随分别有虚空等相。数习力故，心等生时，似虚空等，无为相现。此所现相，前后相似，无有变易，假说为常。

    讲解：有为法是因缘所生法，所以是因果之法。无为法不是因缘所生法，所以不是因果之法，应该像兔角一样，怎么可以离开色、心之外，别有什么实有的无为法呢？

    无为法既非实有，然而佛经上为什么要说虚空等各种无为呢？这有两种道理，一种是依心识的变现，假施设有。就是说，过去曾听过虚空的名字，随即起分别心以为是实有，所以出现了虚空无为等相分境界。因为不断闻说，数数熏习力故，所以当心生时，就好像有虚空无为等相的显现。这所现的相，前后又好像相似，没有什么变化，假说这就是常住不变的无为。

    论文五十三：二依法性，假施设有，谓空、无我所显真如，有、无俱非，心言路绝，与一切法，非一异等，是法真理，故名法性。离诸障碍，故名虚空。由简择力，灭诸杂染，究竟证会，故名择灭。不由择力，本性清净，或缘阙所显，故名非择灭。苦、乐受灭，故名不动。想、受不行，名想、受灭。此五皆依真如假立，真如亦是假施设名。遮拨为无，故说为有，遮执为有，故说为空。勿谓虚幻，故说为实，理非妄倒，故名真如。不同余宗，杂色、心等有实常法，名曰真如。故诸无为，非定实有。

    讲解：前说二种道理，第一种是依心识的变现，假施设有。第二种是依托宇宙万有，森罗万像的一切色、心等法的体性，假施设有。也就是说：由空无我法所显的真如，非有、非无、非俱有无、非非有无。它的真相，不但说不出，并且想不到，真个是心行路绝，言语道断，与一切法非一非异。因一切法有生灭，真如无生灭，所以非一；一切法本即真如（如波即水），真如随缘为一切法（如水成波），所以非异。这是万法的真理，所以名叫法性。

    唯识家在这真如法性显缘不同方面，假立了六种无为：一者因为这种真如不受任何障碍，所以称虚空无为。二者由于无漏慧的拣择力，灭除了各种杂染，最终证得，所以称为择灭无为。三者不用智慧的拣择力，本性清净，或由于阙缘不生所显的真相法性，称为非择灭无为。四者到了第四静虑天，灭一切粗动苦、乐等受所受所显的真如法性，称为不动无为。五者由非想地的灭尽定，想、受心所都不起现行的真如法性，称为想受灭无为。虚空、择灭、非择灭、不动、想受灭五种无为法，固然都是依此真如显缘的差别而假立，所以它们都是诠表法性之相的假名。所以这真如的名，也是依不可说如，不可说非如的法性而假立的。

    其实真如这个名词，也是方便施设的，为了遮遣恶取空及邪见的人认为法性全无，所以说之为有。又因为有些人执著是实有，所以又说它是空。其实法性是非有非不有。非实非不实。法性的理体，既非虚妄，又非颠倒，所以名叫真如。这非有非空非实非不实的大乘真如，绝对不同其余小乘的执著，离开色、心等法，别有一个实在常住之法名叫真如。所以，三无为、四无为、九无为等，都不是决定的实有。

    论文五十四：外道余乘，所执诸法，异心、心所，非实有性，是所取故，如心、心所。能取彼觉，亦不缘彼，是能取故，如缘此觉。

    讲解：前面所说的外道、小乘，他们所执著的事物（如外道的二十五谛、六句义，小乘的色法、不相应行法等），离开心王、心所之外，全没有所谓实在的体性。因为它们是能缘的见分所取的相分境，好像其余的心王心所相分一样。至于能缘的见分，也不能缘取心外的实法，因为相分只能彼见分所见，见分也只能缘自己的相分，同其余的心王心所的见分一样。

    论文五十五：诸心心所，依他起故，亦如幻事，非真实有。为遣妄执心、心所外实有境故，说唯有识。若执唯识真实有者，如执外境，亦是法执。

    讲解：不但外境非真实有，即一切心王心所，也不是真实有性，因为它们都是依托其他因绿而生起之故，如同以幻术变造的戏法一样。那么，心境既然都非实有，为什么说唯有识呢？那是因为遮遣外道余乘，一般执著心、心所外，别有实境之故，所以才方便说唯有识，并不是说唯识实有。若执唯识是实有者，那就同执著外境实有一样，也是法执。

    论文五十六：然诸法执，略有二种，一者俱生，二者分别。俱生法执无始时来，虚妄熏习内因力故，恒与身俱，不待邪教及邪分别，任运而转，故名俱生。此复二种：一常相续，在第七识缘第八识，起自心相，执为实法；二有间断：在第六识缘识所变蕴、处、界相，或总或别，起自心相，执为实法。此二法执，细故难断。后十地中，数数修习胜法空观，方能除减。

    讲解：外道、小乘的法执虽多，总略不过二种，第一种是俱生法执：第二种是分别法执。俱生法执是从无始以来，虚妄法的熏习因力，潜藏在第八阿赖耶识中，由于这内识种子潜在之力，永久与身俱生，勿须等待后天邪师、邪教，及自己的邪分别，自然而然的会展转生起，所以名叫俱生。

    这俱生法执又分二种，第一种是恒常相续，这是第七识的法我见去缘第八识，而生起自心的相分，执为实法。第二种有间断的法执，这是在第六识缘第八识所变的五蕴、十二处、十八界的相分境时，或执五蕴的总相：或执五蕴的别相，在第六识上又生起自心的相分，而执为实法。此三种法执，行相微细，比较难断。必须从初地菩萨开始，一地一地的数数修习殊胜的法空观，修到十地金刚喻定后，才能究竟除灭。

    论文五十七：分别法执，亦由现在外缘力故，非与身俱，要待邪教及邪分别然后方起。故名分别，唯在第六意识中有。此亦二种，一缘邪教所说蕴、处、界相，起自心相，分别计度，执为实法。二缘邪教所说自性等相，起自心相，分别计度，执为实法。此二法执粗故易断，入初地时，观一切法法空真如即能除灭。

    讲解：以上讲的是俱生法执，现在讲分别法执。分别法执如何生起？它不但有无始熏习的内因，也得由现在增上的外缘。它不是与身俱生，而是由后天的师友邪教，及自己的邪思维邪分别，然后才能够生起，所以名分别法执。分别法执，唯在第六意识中有，余识中无。这也有二种，一种是因为听了邪教所说五蕴、十二处、十八界的种种法相，生起了自心的相分境，就分别计度这相分境以为是实法。二种是听了邪教所说，如数论师的自性冥谛；胜论师的六句义等种种法相，生起了自心的相分境，就分别计度这相分境，以为是实法了。这二种分别法执，行相此较粗猛，所以也比较容易断除。只要进入初地菩萨的阶位，观察一切法空真如，就能够除灭。

    论文五十八：如是所说一切法执，自心外法或有或无，自心内法一切皆有。是故法执皆缘自心所现似法，执为实有。然似法相从缘生故，是如幻有。所执实法，妄计度故，决定非有。故世尊说：慈氏当知，诸识所缘，唯识所现，依他起性，如幻事等。

    讲解：像前面所说的一切法执，如果不是自己内心所变之法，那或者有相分、或者无有相分，则不一定。如果是从自己内心所变之法，那一定都有相分。因此之故，所有的一切法执，都是缘自心所变现的相分境，而自己不知道是自心之所变现，就执著这似是而非的法相以为是实有。然而一切似有的法相，因为是从内识种子因缘所生，所以是如幻假有，至于所执著的心外实法，那完全是虚妄计度，决定的没有。

    因此之故，所以世尊在《解深密经》里对弥勒菩萨说：慈氏，你应当知道，我们每人心识所缘的境界，并不是什么心外实法，其实还是从自己心识变现出来的，完全是依托众缘的依他起法，有如幻事一样。

    论文五十九：如是外道余乘所执，离识我法皆非实有。故心、心所，决定不用外色等法为所缘缘，缘用必依实有体故。现在彼聚心、心所法，非此聚识亲所绿缘。如非此所缘，他聚摄故。

    讲解：像以上这些外道和小乘，他们所执著的离开心识以外的我、法，那都不是实有。因此我们知道，各人的心王心所，决定不用心识以外的色等尘境，作为前五识的所缘缘。因为所缘缘的作用，必须依托著内识实有的自体分，决定不缘遍计所执的假法。

    八识的心、心所法，各为一聚。例如眼识的心王心所为一聚，耳识的心王心所亦为一聚，二聚相望为彼聚、此聚。余可类推。若在凡夫，以第六意识为此聚，余七识为彼聚。因意识可通缘余七，而余七不能互缘。若在圣人，则可互缘。

    譬如眼识一聚的心王心所，决定不能作耳识的亲所缘缘，而耳识一聚的心王心所，也不能作鼻识的亲所缘缘，何以故呢？因为亲所缘缘，必定要各识自己所变的相分，才是各识自己见分的亲所缘缘。如果是他一聚心所摄的声音，决定不是眼能所见。鼻识所摄的香臭，也不是耳识所能听到。因此，论文中说：如非所缘，他聚摄故。

    论文六十：同聚心所，亦非亲所缘，自体异故　如余非所取。由此应知实无外境，唯有内识似外境生。是故契经伽他中说：如愚所分别，外境实皆无，习气扰浊心，故似彼而转。

    讲解：不但各聚识的心、心所法，不能互为亲所缘缘，就是同聚识的心所法，也不能为同聚识的亲所缘缘。倒如：眼聚识不能亲缘眼聚识的心所法，耳聚识不能亲缘耳聚识的心所法。因为心所法的作用，与心的自体有异故。好像不是自心所取的其他余法一样。

    由于前面种种道理，应当知道，实在没有我、法等外境，唯有内识所变现的相分，好像外境生起一样。所以佛在《密严经》中有伽他说：愚痴凡夫所分别的一切外境，都不是实有，而是由无始时来的习气，扰乱了我们自心，好像有外境转起似的，其实唯是自心的妄现境界，那有实在的外境呢？


第五章　释难破执．释外妨难

    第五章　释难破执．释外妨难

    论文一：有作是难：若无离识实我、法者，假亦应无，谓假必依真事似事共法而立。如有真火，有似火人，有猛、赤法，乃可假说此人为火。假说牛等应知亦然。我法若无，依何假说？无假说故，似亦不成。如何说心，似外境转。

    讲解：有外人作此问难：你们唯识家说，离开心识之外，没有实我实法。倘若没有离识的实我、实法，那么假我假法也应当没有。因为假法必须依托真事、似事、共法这三个条件才能建立。例如：先要有一种真火，然后才有似火性的人。性凶猛而赤色，才可以假说这是火性之人。假说牛等，也是这样。要有真牛的凶猛和愚蠢，恰好有人也同牛一样，才可说此人似牛。（注：真事，指实我实法。似事指似我似法。猛赤法，猛指火的烈焰，赤指火的颜色，牛指猛性。）

    假我假法，必依实我实法而有，如果一定说没有实我实法，那假我假法也就不能成立了。假既没有，似亦不立，那你为什么要说心似外境转起呢？

    论文二：彼难非理，离识我法前已破故。依类依实，假说火等，俱不成故。依类假说，理且不成，猛、赤等德，非类有故。若无共德而假说彼；应亦于水等，假说火等名。

    讲解：论主驳斥曰，你们所设的问难，在道理上不对，因为你们所说的，离开心识之外，有一个实我实法，这前面已经破了。其实你们说依似，并不是依似，只可说依类。你说的依真，不是依真，只可说依实。实是俗事。因为是依类依事，才说火等牛等，也是不能成立。（注：依类，就是指似事和共法而言，因为似事、共法，必依类故，如人类的正报相似，依报相共。依实，就是指真事而言，因真事必依实体故。如实有火体，方名真火。这是上文外人问难时，所谓假事必须依据的三个条件。）

    依类假说，在道理不能成立。因为猛、赤等法仅是火德，而不是同异类俱有的共德。若于不共火德的人类，而可假说彼人似火，那就应当也可以假说水名为火了。这样依类假说的理，如何能够成立？

    论文三：若谓猛等，虽非类德，而不相离，故可假说。此亦不然。人类猛等，现见亦有互相离故。类既无德，又互相离。然有于人，假说火等。故知假说不依类成。

    讲解：如果你说，人之猛、赤，虽然不能同火德相类，但是猛、赤二法，决不相离。如人色赤者必性猛，而性猛者其色必赤，故可假说此人为火性。这种说法也是不对，因为人类猛、赤，不一定相同。我们常看见，赤色者，他的性不一定猛；或性虽猛而色不一定赤，所以猛、赤，也是相离的。

    人同火虽然是有类，然而无火之德，并且猛、赤有时候亦是互相分离的。但是有许多人，也可以假说他是火人。因此我们知道，假说，不一定是依类而成。

    论文四：依实假说，理亦不成。猛、赤等德，非共有故。谓猛、赤等在火在人，其体各别，所依异故，无共假说，有过同前。

    讲解：前面依类假说的理不成，此处依实假说的理亦不成。因为猛、赤等，并非火性人共有之故。假定一个猛赤德，是一部分在火，一部分在人，可以说是共法。唯其是共法，才可以依真火之猛赤，假说人的猛赤似火。今此猛赤德，但在火而不在人，其非共法可知。这是因为火是火，人是人，火与人的体既各别，所依的法自然也就不同了。如此猛赤既非火人共法，这依而假说的过失，岂不是如前面说水为火是一样吗？

    论文五：若谓人火德相似故，可假说者，理亦不然。说火在人，非在德故。由此假说，不依实成。

    讲解：假设你又说：人和火的德，虽不共其猛、赤，却也不无相似之处，故可假说此人似火。这道理也不对，因为必须在人的体上，也有火的猛赤，然后才可以假说火似人。并非毫无理由的在人的德上说有似火之处。试想人是有情，火是无情，此二者的德如何能够相似？所以我们知道，假说不一定是要依实事而成。

    论文六：又，假必依真事立者，亦不应理。真谓自相，假智及诠俱非境故。谓假智诠，不得自相。唯于诸法共相而转。亦非离此有别方便，设施自相为假所依。然假智诠必依声起，声不及处此便不转。能诠、所诠俱非自相。故知假说，不依实事。

    讲解：如果你们说：假法必依真事而建立，这种道理不能成立。因为真事是非证莫知的诸法自相，不是假智诠的分别言说所能及的心外之境。也就是说，假智诠的分别言说，不可能达到自相的境地，只能在诸法的共相上展转生起。例如：有为法以局于色、心等的一法为自相，统摄色心等法的生、住、异、灭等理为共相。色法又分十一处，以局于一处为自相，统摄十一处的根境等为共相：乃至每一事物又分许多极微，以局于每一极微为自相，统摄一切极微的事物为共相：如是展转至不可分别的言说为自相，尚可分别言说的极微为共相。据此推论，自相就是共相：共相就是自相：自既非自：共亦非共，都无实体，不过以假智诠的分别言说为共相，离分别言说为自相。实则无所谓自相与共相。所以并非离此共相以外，别有一个方便施设的自相，为假智诠所依托。

    然而假智诠必定依托著声音才能够生起。例如：闻雷声而起对雷的分别，说之为雷：闻他人说云的语声，而起对云的分别，亦说之为云。假使声音达不到的地方，这假智诠便失掉了分别言说的作用而不能转起。所以知道假说不是依托著真事而成立的。

    论文七：由此但依似事而转。似谓增益，非实有相。声依增益似相而转，故不可说假必依真。是故彼难不应正理。

    讲解：由此当知，所谓假说并不是依真事转起，但依影像的似事转起。什么叫做似事，谓似事本无，不过在自相上增添了一个并非实有而执为实有的妄相，名为似事而已。能诠的声，就是依托这似相而转起的。以此原因，所以不可说假必依真立。也因此之故，你们小乘等的种种问难，不应道理。

    论文八：然依识变，到遣妄执真实我法，说假似言。由此契经伽他中说：为对遣愚夫，所执实我法；故于识所变，假说我法名。

    讲解：然而假说虽不依真，却知是依托自识所变的见、相二分。为对治遣除愚夫外道等，虚妄执著的真实我、法故，所以才随情假说似我、似法的名言。因此《厚严经》的偈颂这样说：‘为了判治遣除愚者所妄执的真实我、法，所以依据一切都是识变的道理，假说我、法之名。’


第六章　彰能变体

    第六章　彰能变体

    论文一：识所变相，虽无量种；而能变识，类别唯三。一谓异热，即第八识，多异熟性故。二谓思量，即第七识，恒审思量故。三谓了境，即前六识，了境相粗故，及言显六合为一种。

    讲解：颂文彰能变体一颂，首句‘此能变唯三’，谓由识所变的相分虽然无量无数，而能变之识，分别起来，却只有三类，就是‘谓异熟思量，及了别境识’。

    第一类能变识的名字，叫做异熟识，此识旧译为果报识，新译为异熟识。什么叫做异熟呢，异熟摄有三义。一者异时而熟，即有情所造作的善恶之业，由造业到果熟受报，要经过相当的时间。或隔生而熟，或二三生而熟，由造业到成果的时间不同，曰异时而熟。这有如果树上结的果子，由开花结果，到果子成熟，要经过相当的时间，这叫异时而熟。二者变异而熟，有情由造业到受果，既然隔世，因望于果，其性质必有变异，曰变异而熟。譬如水果，由初结果到完全成熟，味道上必有变异，这叫变异而熟。三者异类而熟，有情造作善恶诸业，善业感乐果，恶业感苦果。而苦乐之果非善非恶，是无记性，此无记之果对善恶之因而言，是异类而熟。譬如江河溪涧之水，性质各异，但流入大海时，就混同一味了，这叫异类而熟。

    这异熟果报的第八识，是过去所造的种种业因，承受现世业果的总报主，它的异熟性，除佛之外，遍通于异生、二乘有学、无学、菩萨十地，所以说是‘多异熟性’。

    第二类能变识的名字，叫做思量识。思是思虑，量是度量。这思量就是第七识的意义。因为第八识的思量，是恒而非审的思量；第六识的思量，是审而非恒的思量，前五识的思量，是非恒非审的思。唯独第七识的思量，通于有漏、无漏，恒常审思著「我’。其思量的功用，胜于余识，所以说是‘恒审思量’。

    第三类能变识的名字，叫做了别境识。了是了解，别是分别，境就是境相。这了解分别境相，就是前六识的作用。因为前六识，都是以了别粗境为功能。所以说是‘了别相粗’。它不同于但了细境的七、八二识。所以把它们合并起来为‘了境’的一种。

    论文二：此三皆名能变识者，能变有二种。一因能变，谓第八识中等流、异熟二因习气。等流习气，由七识中，善、恶、无记，熏令生长；异热习气，由六识中，有漏善恶，熏令生长。二果能变，谓前二种习气力故，有八识生，现种种相。

    讲解：前面说异熟、思量、了境这三类识，所以都叫做能变识者，因为它们有二种能变的功用，称为因能变和果能变。因，是第八识所藏能生现果的种子。等流，是相似为等；同类为流。习气，是由过去世熏习所成的气分，也就是种子的别名。

    所谓‘因能变’，就是第八识里，有两种习气的变化作用。一者是感等流果的习气，是由前七识里善、恶、无记三性现行，熏于第八识，令三性种子，或始生或生长而成（第七识势用微弱，但通无记。六识遍通三性）。这种子将来所生的果，也和它这三性是相似同类。所以名为‘等流习气’。二者是感异熟果的习气，是由前六识里善、恶二性现行，熏于第八识而令生长。这种子将来所生的果，是异于它这善恶二性的无记性。所以名为‘异熟习气’。

    前七识现行法，是前因之果，也是后果之因，此处但举现行以显因变，非为果变。所谓果能变，就是由于前面等流习气能变之力，使第八识及前六识的无记异熟果生。这二果所显的见、相二分，色、心差别，所以说‘现种种相’。

    这二种习气是后果之因，也是前因之果。所以但举二种习气以显果变，非为因变。

    论文三：等流习气，为因缘故，八识体相差别而生，名等流果。果似因故。异熟习气，为增上缘，感第八识，酬引业力，恒相续故，立异热名。感前六识，酬满业者，从异熟起，名异熟生，不名异熟，有间断故。即前异热及异熟生，名异熟果，果异因故。

    讲解：以等流习气为生果的因缘，使八识的自体分，与见、相二分，生起千差万别的现行果法；这种因缘所生的果，与能生的因，是相似同类的善等三性，所以名等流果。

    异熟习气，是加强因缘势力的增上缘。它有两种感果的功能，一者是感招第八阿赖耶识，为酬答其一生所造的主要善恶业因，而引生其当来应得的五趣总报果。这种‘酬引业力’，无始以来相续不断，所谓‘恒转如瀑流’。因此，其名曰‘异熟’。二者感招前六识，为酬答其一般性的善恶业因，而圆满其当来在五趣中，应得的身体强弱、寿命长短、贫富贵贱等的别报果。这种‘酬满业者’，因为是间断的从异熟生起，所以名‘异熟生’，而不名‘异熟’。即此第八识的异熟，及前六识的异熟生，都叫做异熟果。因为它们的因是善、恶，果是无记，果异因故。

    论文四：此中且说我爱执藏，持杂染种，能变果识，名为异熟。非谓一切。

    讲解：以上所说的异熟果，虽然牵涉到第八识及前六识的关系，实际上是说我爱执藏，持杂染种子，能变现行果法的第八识名真异熟。并不是说连前六识异熟生的一切业感，都叫真异熟。


第一章　三相门

    第二篇　异熟能变识诠释

    （本篇颂文：初阿赖耶识，异熟一切种，不可知执受，处了常与触，作意受想思，相应唯舍受，是无覆无记，触等亦如是，恒转如瀑流，阿罗汉位舍。）

    第一章　三相门

    论文一：虽已略说能变三名；而未广辨能变三相。且初能变，其相云何？颂曰：初阿赖耶识，异熟一切种，不可知执受，处了常与触，作意受想思，相应唯舍受，是无覆无记，触等亦如是，恒转如瀑流，阿罗汉位舍。

    讲解：在前面第一篇中，诠释了《唯识三十颂》的六句颂文，即：‘由假说我法，有种种相转；彼依识所变。此能变唯三，谓异熟思量，及了别境识。’以上的一颂半颂文，仅是略标论宗，尚未讲到正论。在略标论宗中，仅诠释了三能变的名称，还没有把三种能变识的相状作详细的分析。现在先讲初能变识。论主假设外人问难之辞，曰：‘且初能变，其相云何’。论主以颂文来回答。颂文共十句，即：‘初阿赖耶识，异熟一切种，不可知执受，处了常与触，作意受想思，相应唯舍受，是无覆无记，触等亦如是，恒转如瀑流，阿罗汉位舍。’古人解释初能变的阿赖耶识，是以‘八段十义’科分。十义又称十门，这十门是：

    １．自相门：初阿赖耶识。

    ２．果相门：异熟。

    ３．因相门：一切种。

    ４．所缘门：不可知；执受、处。

    ５．行相门：了。

    ６．心所相应门：常与触、作意、受、想、思相应。

    ７．五受相应门：（相应）唯舍受。

    ８．三性分别门：是无覆无记。

    ９．因果譬喻门：恒转如瀑流。

    １０．伏断位次门：阿罗汉位舍。

    在十门中，如果把自相门、果相门、因相门合并为一，就称为三相门；再把所缘门和行相合并为一，称为所缘行相门，这样就成为八段。八段是就颂文而分，十义是依识体而解。所以十义中除掉‘心所例同门’，因为它不是识体，不过是例同而已。

    论文二：论曰，初能变识，大小乘教，名阿赖耶。此识具有能藏、所藏、执藏义故，谓与杂染互为缘故；有情执为自内我故。此即显示初能变识所有自相，摄持因果为自相故。此识自相分位虽多，藏识过重是故偏说。

    讲解：这一段论文，是十门中的自相门，即‘初阿赖耶识’。初能变的第八阿赖耶识，大小乘圣教名阿赖耶。阿赖耶是梵语音译，意译为‘藏识’，藏识之藏有三种义，即能藏、所藏、执藏。能藏、所藏，是指出阿赖与前七识的现行杂染等法，互相为缘而得名。如以阿赖耶识含藏杂染种子而论，则阿赖耶是能藏；如以杂染等法覆藏阿赖耶识而论，则阿赖耶识是所藏。执藏，是由第七识执著八识的见分以为自内之我而得名。以爱著我故，又名‘我爱执藏’。以上所说，就是显示初能变识所有的自体相状，自体相状是由于摄持因果而成的。能藏是因；所藏是果。自相为总，因果为别。以自相之总，含摄因果之别；以因果之别，依持自相之总。所以说是‘摄持因果’。这第八识的自相，分位的名称虽多，然而以阿赖耶执藏的过失最重，重于异熟等，所以偏说阿赖耶名。

    论文三：此是能引诸界、趣、生，善不善业异熟果故，说名异热。离此，命根、众同分等，恒持相续，胜异熟果不可得故。此即显示初能变识所有果相，此识果相虽多位多种；异熟宽不共，故偏说之。

    讲解：第一自相门的阿赖耶，已如上说。现在该讲第二果相门了。果相门即是‘异熟’。这初能变的第八识，因为它能够牵引造作善恶之业的众生，在三界、五趣、四生中轮回，去受那异时而熟的总报果，所以名叫异熟果。如果没有阿赖耶识，就没有命根、众同分等永恒相续生死的殊胜真异熟果体。这就是初能变第八识的所有果相。此识的果相虽有多位多种，以‘异熟’之名包括面宽，且能够不共于其余诸识，是故偏说。（注：阿赖耶识可以分为三位，即我爱执藏现行位、善恶业果位、相续执持位。也可以分为五位，即异生位、二乘有学位、三乘无学位、十地菩萨位、如来位，故称多位。此识具有离系果以外的四果，即异熟果、等流果、士用果、增上果，故称多种。）

    论文四：此能执持诸法种子，令不失故，名一切种。离此，余法能遍执持诸法种子不可得故。此即显示初能变识所有因相，此识因相虽有多种，持种不共，是故偏说。

    讲解：三种相的前二种，为自相、果相，已如上说。现在讲第三因相门的‘一切种’。这初能变的第八识，因为它能执持世、出世间诸法种子，令其生果的功能不致消失，所以名叫‘一切种识’。小乘经部譬喻师等，执著离开此第八识以外，别有所谓命根──寿命、众同分──众生的共报，穷生死蕴等，为异熟果。然而，在以上所执中，求之于恒时不断，生灭相续，是不可得的。这反而显示了唯第八初能变识，才能执持诸法种子。（注：第八识异熟识的因相，在唯识宗的十因中，异熟识通于八因，即观待因、牵引因、生起因、摄受因、引发因、定异因、同事因、不相违因。）

    论文五：初能变识，体相虽多，略说唯有如是三相。一切种相，应更分别。

    讲解：初能变识的体相，随义立名，虽有多种；略而言之，不过只有这自相、果相、因相三种。但一切种的因相，内容复杂，应该更详细的加以分别。

    论文六：此中何法名为种子，谓本识中，亲生自果，功能差别。此与本识，及所生果，不一不异。体用因果，理应尔故。

    讲解：外人问曰：什么叫做种子呢？唯识家答：第八根本识里，无始熏习的亲因，生起了各种不同的现行果法，这生果的不同功能，就叫做种子。那么这种子与本识（第八识），及其所生的果法，是一呢！是异呢？答曰：不一不异。因为本识是体，种子是用，体是体，用是用，所以不一；但体是此用之体，用是此体之用，体不离用，用不离体，所以非异。再者，种子与现行之间，种子是因，现行是果，因是因，果是果，所以非一；但因是此果之因，果是此因之果，这体用因果的关系，在道理上就是如此。

    论文七：虽非一异而是实有。假法是无非因缘故。此与诸法既非一异，应如瓶等是假非实。若尔，真如应是假有，许则便无真胜义谛。然诸种子唯依世俗说为实有，不同真如。

    讲解：外人又问曰：这种子与本识，及其所生的果，既然是因缘所生之法，非一非异，那不就如瓶、钵一样的假法吗？唯识家回答曰：种子与本识，及其所生的果法，虽然非一非异，而种子却有实体做生法的因缘。假法无体，有如龟毛兔角，因为它不是生法的因缘。外人再问：种子和它所生的现行法，既然都是因缘所生，非一非异，那就应当如瓶、钵一样是假非实。因为瓶钵等的假色法，也是以极微为因缘，而非一非异啊。

    论主反诘曰：假使非一非异的法，都是假有的话，那么真如法性，也与诸法是非一非异，难道说真如也是假有吗？若说真如是假有，那真胜义谛不是就没有了吗？如果没有胜义谛，试问依什么修行成佛呢？

    再者，第八识中的一切种子，依世俗谛，说为实有；若依胜义谛说，便成了虚妄假法。因为它不同于真如、在真俗二谛上都是实有。真如不但是世俗谛的胜义谛，而且是胜义谛的胜义谛，这是应当加以区别的。

    论文八：种子虽依第八识体，而是此识相分非余；见分恒取此为境故。

    讲解：种子虽然是依于第八识之体，但它只是第八识的相分，而不是见分，因为见分恒常缘取相分以为外境。

    论文九：诸有漏种与异熟识，体无异故，无记性摄。因果俱有善等性故，亦名善等。诸无漏种，非异熟识性所摄故。因果俱是善性摄故，唯名为善。

    若尔，何故决择分说，二十二根，一切皆有异熟种子，皆异熟生？虽名异热，而非无记。依异热故，名异熟种。异性相依，如眼等识。或无漏种，由熏习力，转变成熟，立异熟名．非无记性所摄异熟。

    讲解：这是以三性来判别第八识中的种子。第八识中的种子，分为有漏、无漏二类。其中有漏种子与异熟识，其体性本来没有差别，都是非善非恶的无记性。但由于能熏的现因，或所结的现果，都有善、恶、无记三性，所以这种子也可以称为善、恶、无记种子。至于无漏种子，因为不是无记性的异熟识所摄，因果俱属善性之故，所以只能名之为善，不名不善或无记。

    这时外人又问曰：如果是这样的话，为什么瑜伽决择分说：二十二根──无论是前十九有漏根，后三无漏根，都是异熟种子，都是异熟识所生呢？（注：二十二根，根者能生之义，是促进增生作用的根本，如眼根能生眼识等。二十二根是：眼根、耳根、鼻根、舌根、身根、意根、女根、男根、命根、苦根、乐根、忧根、喜根、舍根、信根、精进根、念根、定根、慧根、未知当知根、已知根、具知根。）

    唯识家回答说：那些无漏种子，虽然名叫异熟，而性非无记，由于所依的识是异熟，故称异熟种，并不是和异熟识同一体性。这异性相依，好像通于三性的眼识，依附著无记的眼根，而名眼识似的。识依根是这样，种子依于识也是这样。若约新熏一边说：无漏种子，由熏习的力量，展转变异到成熟的现行果法时，也立名叫做异熟。但这并不是无记性所摄的异熟。

    论文十：此中有义，一切种子皆本性有，不从熏生，由熏习力但可增长。如契经说：一切有情，无始时来，有种种界，如恶叉聚，法尔而有：界即种子差别名故。又契经说：无始时来界，一切法等依。界是因义。瑜伽亦说：诸种子体，无始时来，性虽本有，而由染净新所熏发。诸有情类无始时来，若般涅槃法者，一切种子皆悉具足；不般涅槃法者，便阙三种菩提种子。如是等文，诚证非一。

    讲解：种子从何而来呢？这在十大论师中，有护月、难陀、护法三家不同的主张。第一家护月论师等，认为一切种子，无论有漏无漏，都是本来就有的，并不是从现行的熏习而生。经论上虽然也说由熏习而有，但那是指增长而言，并不是本来没有，从今熏习就有了。因为熏习的势力，只能达到使种子增长，而不能使种子从无而有。说种子‘皆本性有，不从熏生’，在经论上是有其根据的。如《无尽意经》上说：‘一切有情，无始时来，有种种界，如恶叉聚，法尔而有’。界，是种子的别名。也就是说：从无始时来，这种子好像恶叉果（注：印度的一种毒果，落地聚在一处）似的，是法尔自然而有的。此外《阿毗达摩经》上说：‘无始时来界，一切法等依’（注：阿毗达磨经中的偈子：无始时来界，一切法等依，由此有六趣，及涅槃证得。阿毗达磨经中土未译。）界是因义，也就是种子的别名。这就是说：无始时来，这种子就为一切现行法等所依持（由种子生起现行）。不但佛经上如此说，就是《瑜伽师地论》上也这样说：一切种子的体性，虽是无始本有，而要由染净二种现行缘法的熏习，才能熏发为有漏无漏二种现行果法。一切有情自无始时来，假使有入无余涅槃可能，那便是它具足了一切有漏无漏的种子；假使没有入涅槃的可能，那便是它缺少了声闻、缘觉、佛的三种菩提种子。然而一切众生皆当成佛，可见有、无漏种，都是本有，就看它受熏的现缘是染是净，来决定它生死或涅槃的成果了。像这种子本有的引文，经论中很多，非此一说。

    论文十一：又诸有情，既说本有五种性别，故应定有法尔种子，不由熏生。又瑜伽说：地狱成就三无漏根，是种非现。又从无始展转传来，法尔所得本性住种。由此等证无漏种子法尔本有，不从熏生。有漏亦应法尔有种，由熏增长，不别熏生。如是建立因果不乱。

    讲解：既然经上说一切有情，有声闻、缘觉、菩萨、不定、及无种性五种性别，所以决定有法尔本有的种子，不是由熏习而产生的。《瑜伽师地论》还说：‘在地狱中受苦的罪报众生，它们也能成就三无漏根，这只能是种子，而不是现行。’可见凡夫不是没有无漏种子，不过是无漏种子未起现行罢了。由此证明，无漏种子本来具有，不是由熏习而生。有漏种子也应当是本来具有，由于熏习而增长，并不是由熏习而产生，这样才使因果关系不相杂乱。以上是护月论师等的主张。（注：五种性，是唯识宗特有的理论，认为众生先天具有的本性有五种，都是由阿赖耶识中储藏的种子决定的。此种子是先天具有而不可改变的。五种性是：一、菩萨种性，通过修行可成菩萨；二、缘觉种性，通过修行可成辟支佛；三、声闻种性，通过修行可成阿罗汉；四、三乘不定种性，通过修行究竟成为菩萨、辟支佛、或罗汉，不能肯定；五、无种性有情，永远沉沦于生死苦海，无论怎样修行都不能得到解脱者。）

    论文十二：有义，种子皆熏故生，所熏能熏俱无始有。故诸种子无始成就。种子既是习气异名，习气必由熏习而有。如麻香气，华熏故生。如契经说：诸有情心，染净诸法所熏习故，无量种子之所积集。论说内种定有熏习；外种熏习或有或无。

    讲解：这以下是第二家难陀等论师的主张。此与第一家本有论相反，认为种子都是由熏习而产生，并非本有。无论所熏的种子，及能熏种子之法，都是无始时有。假使没有无始能熏的法，那里会有无始所熏的种子。既然习气是种子的异名，习气必定由熏习才能产生。譬如印度人用以涂身香油的胡麻，胡麻本来不香，须先用一种香华和胡麻放在一起，令熏成香，然后榨油。当知此油香气，是由华熏而产生；法熏种子也是这样。

    如《多界经》说：‘一切有情的心，无非由染净诸法所熏习之故，才有无量种子的积集，是名为心。’《摄大乘论》也说：‘第八阿赖耶识里的种子，决定由熏习而有。至于世间麦、稻等无情生物的种子，或有熏习，或无熏习，则不一定。’

    论文十三：又名言等三种熏习，总摄一切有漏法种。彼三既由熏习而有，故有漏种必藉熏生。无漏种生亦由熏习。说闻熏习，闻净法界等流正法而熏起故。是出世心种子性故。

    讲解：前面已引经论证实其说，此处再以教理申明其义。现行法熏习在阿赖耶识里的习气有三种，即名言习气、我执习气、有支习气。这三种习气，既然都是由熏习而有，所以有漏法的种子，必然是藉著熏习的力量才能生起。不但有漏种子由熏习而生，即是无漏种子，也是由熏习而生的。据经论上说：是闻佛菩萨从清净法界平等真如性里，宣流出来的正法而熏起的。在未闻熏前是世间有漏；既闻熏后，便是出世心的无漏种子性。所以不是法尔本有。

    论文十四：有情本来种性差别。不由无漏种子有无，但依有障无障建立。如瑜伽说：于真如境，若有毕竟二障种者，立为不般涅槃法性。若有毕竟所知障种，非烦恼者，一分立为声闻种性，一分立为独觉种性。若无毕竟二障种者，即立彼为如来种性。故知本来种性差别，依障建立，非无漏种。所说成就无漏种言，依当可生，非已有体。

    讲解：第一家以有情本有五种性别，来证明确有法尔无漏种子。那知有情的种性差别，并不是以无漏种子的有无而建立的，而是依于烦恼、所知二障的有无而建立的。这是依有障无障来建立种性差别的引证。例如《瑜伽师地论》上说︰‘在真如法性的境上，若有烦恼、所知二障种子毕竟不可断的，立为不般涅槃的凡夫种性。若有但断烦恼，尚有所知障毕竟不可断者，钝的一分立为声闻种性；利的一分立为缘觉种性。若有二种障碍都可以彻底断尽的，就立它为如来种性。’

    由此证明种性的差别，是依于二障而建立的，与无漏种子无关。前文护月引证《瑜伽师地论》所说：‘地狱成就三无漏根’的话，那是说将来出了地狱，断了烦恼障后，可生无漏种子，并不是说现在地狱里的众生，本已有了无漏种子的体性。

    论文十五：有义，种子各有二类，一者本有，谓无始来异熟识中，法尔而有，生蕴、处、界功能差别。世尊依此说诸有情，无始时来有种种界，如恶叉聚法尔而有。余所引证广说如初，此即名为本性住种。二者始起：谓无始来数数现行熏习而有。世尊依此，说有情心染净诸法所熏习故，无量种子之所积集。诸论亦说染净种子由染净法熏习故生。此即名为习所成种。

    讲解：这是第三家护法论师的主张，它折中二说，认为本有与熏习兼具。他说：有漏种子和无漏种子各有二类，第一类是本有的，就是从无始时来，第八异熟识里，本来就有生起五蕴、十二处、十八界的差别功能。世尊依据此理，说一切有情，从无始来，就有各种不同的种子，好像恶叉果聚积在一处似的。这种子是法尔本有的，其在经论上的证据，如第一家护月所说。这种法尔本有的种子，就叫做‘本性住种’。

    第二类是始起，是从无始时来，由于现行数数不断的熏习而有的。世尊即依据此理，说有情的心，是由于各染净诸法所熏习的原故，第八阿赖耶识里，才有无量种子积集其中。很多论典上也说：一切染净法的种子，是由一切染净现行法所熏习而生起的。这些熏习始起的种子，就叫做‘习所成种’。

    论文十六：若唯本有，转识不应与阿赖耶为因缘性。如契经说：诸法于识藏，识于法亦尔；更互为果性，亦常为因性。此颂意言：阿赖耶识与诸转识于一切时展转相生，互为因果。摄大乘说：阿赖耶识与杂染法互为因缘；如炷与焰展转生烧。又如束芦互相依住。唯依此二建立因缘。所余因缘不可得故。若诸种子不由熏生，如何转识与阿赖耶有因缘义？非熏令长可名因缘，勿善恶业，与异热果为因缘故。又诸圣教说有种子由熏习生，皆违彼义，故唯本有，理教相违。

    讲解：这是破第一家护月之说。护月论师谓种子若唯本有，那么七转识就不应该与阿赖耶识作因缘性。然而经论上却说，七转识与阿赖耶识是互为因缘性的。如《阿毗达摩经》的偈子：‘诸法于识藏，识于法亦尔，更互为果性，亦常为因性。’意思就是说第八阿赖耶识，与七转识的现行诸法，都是展转相生，互为因果的。《摄大乘论》说：‘阿赖耶识与杂染法互为因缘；如炷与焰展转相烧，又如许多束芦互相依住，有如此阿赖耶识与杂染诸法互为因缘。除此以外，其余因缘不可得故。’若诸种子不是由熏习而生，如何转识与阿赖耶有因缘义？并不是由于熏习使种子增长即可称为因缘，因为不能说善恶之业与异热果为因缘，因为它只是增上缘。再者，圣教多处说：有种子是由熏习而生，都与唯本有之说相违。所以，唯本有之说与因果正理、及佛的教诲均相违背。

    《摄大乘论》上也说：‘阿赖耶识，与杂染法互为因缘’。第八阿赖耶识种子，能生七转识杂染现行诸法，但也为现行法之所熏。它们就是这样种生现、现熏种互为因缘的。现再举二喻以明之：一，如炷与焰，展转生烧。炷是灯心。焰是灯火。灯炷能生灯焰，灯焰也能烧灯炷，如是炷生焰；焰烧炷，展转生烧。好像种生现，现熏种展转生熏一样。二，又如束芦，互相依住。束芦是捆成一束束的芦苇。它们是互相依倚，才能站立得住。也好像种子与现行，谁也不能离谁而单独存在一样。

    若说种子唯是本有，不由熏生，这在论典上如何说七转识与阿赖耶识，有互为因缘的意义呢？若说纵然也有熏习，不过是熏习本有的种子使之增长而已，并不是本来没有种子因熏习而有。所以当善恶业现行熏习本有种子的时候，这善恶业与本有的种子，当然也可以名为因缘。照你这样说，那善恶业，只是异熟果的增上助缘，怎么可以叫做因缘呢？再者，圣教上都说种子由熏习而生。所以你那种子唯本有论，于理于教，都是相违背的啊。（七转识，即前七识，唯识宗把第八阿赖耶识称为本识，把前七识称为转识，意谓前七识是由本识转生的。）

    论文十七：若唯始起，有为无漏，无因缘故，应不得生，有漏不应为无漏种，勿无漏种，生有漏故。许应诸佛有漏复生，善等应为不善等种。

    讲解：这是破第二家难陀之说。若依第二家难陀之说，种子唯由熏习始得生起，那也不对。因为胜义涅縏的无为无漏，固然用不著种子因缘，然而三乘见道的有为无漏，那就不能没有种子因缘了。这有为无漏的种子因缘，如果不是本有，就应当如兔角一样的不得生起。无论怎样熏习，即令是最胜的世第一法，终属有漏，它只能在加行位中，做初无漏的增上缘。而不能做无漏种子的亲因缘。假定有漏种子可以做无漏种子的因缘，那无漏种子岂不是也可以生有漏法了吗？试问你许不许这样说？若许！则诸佛便应重生有漏，而为烦恼众生；善法也应当做恶法种子，恶法也应当做善法种子了。

    论文十八：分别论者虽作是说：心性本净，客尘烦恼所染污故，名为杂染。离烦恼时转成无漏，故无漏法非无因生。而心性言，彼说何义，若说空理，空非心因，常法定非诸法种子，以体前后，无转变故。若即说心，应同数论，相虽转变，而体常一。恶、无记心，又应是善。许则应与信等相应，不许便应非善心体。尚不名善，况是无漏？有漏善心既称杂染，如恶心等，性非无漏，故不应与无漏为因，勿善、恶等互为因故。若有漏心性是无漏，应无漏心性是有漏，差别因缘不可得故。

    讲解：分别论师，梵名毗婆阖婆提，或称大乘异师，他们也主张无法尔种子，故于此顺便破之。分别论者说：‘根本就没有法尔本有的种子。不过凡夫的心性本来就是清净的，因被生灭来去不清净的客尘烦恼所染污，所以才名叫杂染。如果离开了烦恼，便转彼杂染而成为无漏了。然而这里所说的心性是什么意思？若说心性是真空如理，则真空不动，不是心的因缘，如（真如）理常恒，也不是诸法种子。因为做因缘种子，必须是前后能够转变的生灭法。若说心性就是凡夫的心体，那就如同数论外道所说的二十五谛一样，其‘大’等二十三法的有漏心相虽能转变，而其谛、自性、及神我的无漏心体，则常一不动。如此说来，有漏的心体既是无漏，那恶、无记心，不是也可以名之为善了？若同意这种主张，则有漏恶等的心便应当与善心所法相应；若不同意这种主张，则有漏恶等的心体，就不应当是善法了。此不善心尚不名善，又怎能称为无漏法呢？既然有漏善心称为杂染，同恶心等其性并非无漏，所以不能成为无漏法之因。因为不可以善为恶因，恶为善因，善恶相违不可互相为因。如果有漏心是无漏，那么无漏心就成为有漏，在一性之中，这差别因缘就不存在了。

    论文十九：又，异生心若是无漏，则异生位无漏现行，应名圣者。若异生心，性虽无漏，而相有染，不名无漏，无斯过者，则心种子亦非无漏。何故汝论说有异生，唯得成就无漏种子？种子现行性相同故。

    讲解：倘若众生的有漏心是无漏的话，那么无漏心岂不也成为有漏？这样差别的因缘就不可得了。再者，流转五趣的异生之心若是无漏，则凡夫位，就应当在凡夫位起无漏现行，名为圣者了，何以仍名凡夫？若以为凡夫心的体性虽是无漏，而心的行相却是染污，所以不名无漏，这样说就没有上面的过失了。如此说来，那心的种子也不是无漏，为什么你们的论上说，凡夫唯得成就无漏种子，不说成就无漏现行呢？种子和现行的性质不都是一样吗？（注：异生，异于圣贤之生类，即是凡夫之谓。）

    论文二十：然契经说心性净者，说心空理所显真如，真如是心真实性故。或说心体非烦恼故，名性本净，非有漏心性是无漏，故名本净。由此应信，是诸有情，无始时来，有无漏种，不由熏习，法尔成就，后胜进位熏令增长，无漏法起以此为因。无漏起时复熏成种。有漏法种类此应知。

    讲解：然而《胜鬘经》说：心性清净，是修我、法二空观行，断烦恼、所知二障所显的真如理性，这真如就是心的真实体性。或者说因为心体并非烦恼，所以称为‘性本净’，并非有漏心的体性就是无漏，而称‘性本净’。因此应当相信诸有情无始时来，就有法尔成就的无漏种子。并不是由熏习而生，不过后来修行到殊胜进步的解脱分，由于修行熏习而使无漏种子增长。无漏法的生起以此为因。当这无漏现行生起的时候，又熏习成无漏种子而入于见道。这样种生现，现熏种，更番熏生而究竟涅槃。无漏法的种子是如此，有漏法的种子也可比类而知。

    论文二十一：诸圣教中，虽说内种定有熏习，而不定说一切种子皆熏故生，宁全拨无本有种子？然本有种亦由熏习令其增盛，方能得果，故说内种定有熏习。其闻熏习非唯有漏，闻正法时亦熏本有无漏种子，令渐增盛，展转乃至生出世心，故亦说此名闻熏习。闻熏习中有漏性者是修所断，感胜异熟为出世法胜增上缘。无漏性者非所断摄，与出世法正为因缘。此正因缘微隐难了，有寄粗显胜增上缘，方便说为出世心种。

    讲解：佛教的各种教法中，虽说第八识里的种子定有熏习，但并没有肯定说一切种子都是由熏习而生，怎可完全否定本有种子呢？不过本有种子也由熏习的助缘使之增长，才能成果，所以说第八识里的种子定有熏习。虽然其闻熏习只有有漏法，但在听闻正法时，也熏习了本有的无漏种子，使之增长而生起无漏现行，又由无漏现行熏成无漏种子，如是展转熏习，乃至生起出世之心。所以也说这由闻熏而增长的本有种子，名叫‘闻熏习’。然而在闻熏习中的有漏无漏怎样分别？闻熏习中，属于有漏性的，是修道所断的惑业种子，它能感招殊胜的异熟果报，作为出世法的增上缘。属于无漏性的，则不是修道所断的惑业种子，它可以直接作为出世法的正因缘。不过这种无漏种子的正因缘，微细隐秘难以了知，只有假借在粗显而易知的增上缘上，方便假说这是出世心种。其实出世心的正因缘，还是本有的无漏种子。

    论文二十二：依障建立种性别者，意显无漏种子有无，谓若全无无漏种者，彼二障种永不可害，即立彼为非涅槃法。若唯有二乘无漏种者，彼所知障永不可害，一分立为声闻种性，一分立为独觉种性。若亦有佛无漏种者，彼二障种俱可永害，即立彼为如来种性。故由无漏种子有无，障有可断不可断义。

    讲解：依于烦恼障和所知障存在的程度，建立种性差别的意义，是在显示无漏种子的有无。

    如果完全没有无漏种子，它那烦恼和所知二障的种子，永远不可断灭，即依此来建立没有涅槃的凡夫种性。假定有人但有二乘无漏种子，而没有成佛的无漏种子，则它的烦恼障种子虽可断灭，而所知障种子永远不能断灭，因此一部分立为声闻种性，一部分立为独觉种性。如果有人不但有二乘无漏种子，同时也有佛的无漏种子，那它的烦恼、所知二障种子毕竟可以断灭，就依之建立如来种性。所以由于无漏种子的有无，二障才有可断不可断的两种意义。

    论文二十三：然无漏种，微隐难知，故约彼障显性差别，不尔，彼障有何别因而有可害不可害者？若谓法尔有此障别，无漏法种宁不许然？若本全无无漏法种，则诸圣道永不得生。谁当能害二障种子，而说依障立种性别？既彼圣道必无生义，说当可生亦定非理。然诸圣教处处说有本有种子，皆违彼义，故唯始起，理教相违。由此应知诸法种子，各有本有始起二类。

    讲解：有人问曰：既然障有可断不可断，是由于无漏种子有无的原故，为什么要依有障无障来建立种性差别呢？答曰：二障虽由无漏种子的有无而有可断不可断义，然而因为无漏种子微隐难知，所以才约障的有无来显示种性差别。假使没有无漏种子，凭什么原因，说二障或可断或不可断的差别呢？

    若说没有任何原因，本来就有这二障可断不可断的差别。那么无漏法的种子，何以不许是法尔本有呢？如果没有法尔的无漏种子，那三乘圣道，不是就永远的不能生起了吗？如此，由谁来灭除二障种子呢？你们何以又说依障建立种性差别呢？如果是这样，圣道缺种肯定不能生起。如果你们说现在不生，当来可生，也决定没有无因生果的道理。何况诸经论里，处处说有本有种子，你们对圣教的正义不是一齐都违背了吗？所以你们但说种子由熏习起，不承认本有种子，不但不合道理，而且违背叙义。由此应知：一切法的种子，无论有漏无漏，各有法尔本有与始起的两类。

    论文二十四：然种子义略有六种：一、刹那减：谓体才生，无间必灭，有胜功力方成种子，此遮常法，常无转变，不可说有能生用故。二、果俱有：谓与所生现行果法，俱现和合，方成种子。此遮前后及定相离。现种异类，互不相违，一身俱时，有能生用，非如种子自类相生，前后相违，必不俱有。虽因与果有俱、不俱，而现在时可有因用，未生已灭，无自体故。依生现果立种子名，不依引生自类名种，故但应说与果俱有。三、恒随转：谓要长时一类相续至究竟位，方成种子。此遮转识，转易间断，与种子法不相应故。此显种子自类相生。四、性决定：谓随因力生善恶等功能决定，方成种子。此遮余部执异性因生异性果，有因缘故。五、待众缘：谓此要待自众缘合，功能殊胜，方成种子。此遮外道执自然因，不待众缘恒顿生果；或遮余部缘恒非无。显所待缘非恒有性，故种与果非恒顿生。六、引自果：谓于别别色、心等果各各引生，方成种子。此遮外道执唯一因生一切果；或遮余部执色、心等互为因缘。唯本识中，功能差别，具斯六义，成种非余。

    讲解：种子六义，讲的是种子的六种特性。种子本是一种功能（实即能量），所以种子的特性，与能量的特性近似。这六种特性是：

    一、刹那灭：所谓刹那灭，就是刚才生起的有为法体，在一念顷的刹那之间即灭，它由生到灭，中间没有片刻的间隙，即是没有‘住’的阶段。有这样殊胜生灭无间的功用和能力，才可以成为种子。这遮简不是无为真如的常法；也不是数论外道自性神我的常法。因为常法没有无常转变的种子义，所以不可说它有能生果的功能。

    二、果俱有：就是能生的种子，与所生的现行果法，不但在时间上俱是现在；就是在空间上也是和合在一起的，这样才可以成为种子。这遮简不是种子引种子的因果异时，前后相违。因为所生的现行果法，与能生的种子，它们的体性虽是异类，而互不相违，所以能够在一身中，同时有能生与所生的功用。不像那前念种子引后念种子，它们虽是自类相生，而前后相违，必不能俱时而有。问：何以但许种子生现行的异类因果是俱时，不许种子引种子的自类因果是俱时呢？答：种子生现行，现行虽亦熏种子，而所生的种子，未即生果，既不失为因缘：又无无穷之过，故许俱时。种子引种子，若许俱时，则一刹那便生多果，不但有无穷之过；而且也失掉了因缘的意义。

    虽然因和果，有生现果的俱时，有引自类的不俱时，而要以现在俱时，可能有生果的因力者，方合格为种子。此外，未来的因还没有生；过去的因已竟灭了，它们都没种子自体的资格。所以依能生现果的因，来建立种子的名称，不依引生自类的种子，名为种子。因此，但应说种子是与‘果俱有’的。

    三、恒随转：此是要恒长时间，其性一类相续──即性同一类的种子，前念灭时，后念即生。如是生灭非常；相续非断；一直到了对治道的究竟位止，才能成为种子。这是遮简七转识有变化间断，与恒随转的种子法则不相应，这表明种子自类相生。

    四、性决定：就是要随顺现行熏生之因的功能，决定善因生善果，恶因生恶果，无记因生无记果，才能成为种子。这是遮简小乘说一切有部，它们执于善因生恶果，恶因生善果，以此异性因生异性果有因缘意义。

    五、待众缘：种子的本身要等待众缘会合，来帮助它生果，才能成为种子。这是遮简外道所执的自然之因，不须众缘会合便能永远顿生现行之果；或破小乘说一切有部以众缘是一切时恒有的执著。假定众缘真的恒有，那种子岂不应当恒时生果吗？

    六、引自果。各别不同的色、心等果，各各都为它自己的种子所引生。如色法种子只能引生色法的现行果，心法种子只能引生心法的现行果，这样才能成为种子。这是遮简大自在天外道，唯以一‘大自在天’为因，生一切果法的执著。或破小乘说一切有部的主张，色、心种子可互为因缘的执著。

    唯有第八阿赖耶识中的种子，在生果的功能差别上，具足了这六种种子的意义，才可以名为种子。其余的七转识都不能成为种子。

    论文二十五：外榖、麦等，识所变故，假立种名，非实种子。此种势力生近、正果，名曰生因引远、残果，令不顿绝，即名引因。内种必由熏习生长，亲能生果是因缘性。外种熏习或有或无，为增上缘办所生果，必以内种为彼因缘，是共相种所生果故。

    讲解：唯有第八识里的种子具足六义，才能名为种子。那么，世间的谷、麦等非情之类，怎么也叫种子呢？答曰：谷、麦等的种子，因为都是内识所变的相分，假立种子之名，称为谷种麦种而已，其实这并不是真的种子。

    这内外种子，生果的势力有两种：一种是‘生近正果’，种子的势力，发展到恰好的近距离时，有一种正当的结果，如：内种所生现在的人身；外种所生茁壮的芽茎等：这种生近正果的因，就叫做‘生因’。二种是‘引远残果’，种子的势力，引伸到强弩之末的疏远距离时，倘有剩余的残败之果，不会马上就顿时灭绝，如：枯丧的尸骸，萎谢的花木等，这种引残果的因，就叫做‘引因’。

    第八识中储藏的内种，必定经过熏习而生，经过熏习而长。由熏习而生的，是新熏种子；由熏习而长的，是法尔种子。这种子，是亲生一切现行果法的因缘性。至于外种，则或有熏习，或无熏习，没有一定。例如：苣胜藉它华香，是有熏习；松柏生来苍翠，是无熏习。然而，这外种的熏习，只不过是增上缘。要成办生果大业，必须以第八识中的种子做为因缘。因为世间的谷、麦等，都是有情第八识里的共相种子所生的共报果法。

    论文二十六：依何等义立熏习名，所熏、能熏各具四义，令种生长，故名熏习。何等名为所熏四义？一、坚住性：若法始终一类相续，能持习气，乃是所熏。此遮转识，及声、风等，性不坚住，故非所熏。二、无记性：若法平等，无所违逆，能容习气，乃是所熏。此遮善、染势力强盛，无所容纳，故非所熏、由此如来第八净识，唯带旧种，非新受熏。三、可熏性：若法自在，性非坚密，能受习气，乃是所熏。此遮心所及无为法，依他坚密，故非所熏。四、与能熏共和合性：若与能熏同时同处，不即不离，乃是所熏。此遮他身刹那前后，无和合义，故非所熏。唯异熟识具此四义，可是所熏，非心所等。

    讲解：问：依据什么意义建立熏习的名称呢？唯识家答曰：熏习有能熏、所熏两种。这两种熏习，各要具备四种条件，能令种子生长，所以名为熏习。现在先讲所熏四义：

    第一是‘坚住性’：若有一法，始自无始，终至究竟，无论善、恶、无记，只要是同一类性相续不断，能够执持习气不令散失的，那便是所熏。这简别七转识不能成为所熏，风及声音不能成为所熏，十一种法色不能成为所熏。因为七转识的有漏种子，到了初见道的无漏心位就散失了；根境十色及法处所摄色等，到了无色界及灭尽定时也就没有了。风及声音无坚住性，当然也不能成为所熏。就是七转识及十一色法也是如此，所以不能成为所熏。

    第二是‘无记性’：若有一法，具有非善非恶的平等性，但于善恶习气，都能随顺而无所违逆的，那便是所熏。这遮简善法恶法势力强盛，不能互相容纳，且也不能自类相容。一如旃檀之香、阿魏之臭，俱不受熏习，所以也不是所熏。因此性唯无记的第八识才能受熏。所以佛的第八无漏净识，是从因地带来的旧种，并不是新受熏的。

    第三种是‘可熏性’：若有一法，其体自在，不做它法的附佣；而且性非坚密。体是虚疏，能够容受习气的，那便是所熏。这遮简心所法、无为法都不能受熏。因为心所法是心王的附佣，体不自在；无为法其性坚密，体非虚疏，不能容受习气，所以都不能成为所熏。

    第四种是‘与能熏共和合性’：和合是相应的意思，所熏与能熏，在同一时间，同一处所，虽能熏之体，不即是所熏，然能熏所熏亦不相离，有这样和合性的，便是所熏。这遮简不同一处的自它二身，不同一时的刹那前后。因为自它二身，各人自作自受，此人的业识不能熏他人的阿赖耶识，它人的阿赖耶识也不受外人的业识所熏。刹那前后的能所亦不相应。所以都不是‘所熏’。

    唯有第八异熟识才具以上四种条件，所以才是所熏。

    论文二十七：何等名为能熏四义？一、有生灭：若法非常，能有作用，生长习气，乃是能熏。此遮无为前后不变，无生长用，故非能熏。二、有胜用：若有生灭，势力增盛，能引习气，乃是能熏。此遮异熟心、心所等，势力羸劣，故非能熏。三、有增减：若有胜用，可增可减，摄植习气，乃是能熏。此遮佛果圆满善法，无增无减，故非能熏。彼若能熏，便非圆满，前后佛果应有胜劣。四、与所熏和合而转：若与所熏同时同处，不即不离，乃是能熏。此遮它身刹那前后，无和合义，故非能熏。唯七转识及彼心所，有胜势用而增减者，具此四义，可是能熏。

    讲解：所熏四义已如上说，现讲能熏四义：第一种是‘有生灭’：若有一法，前后刹那迁变无常，能有作用使习气生长的便是能熏。这遮简不是无为法。因为无为法是前后不变的恒常之法，而不是无常，没有能使习气生长的作用，所以它不是能熏。第二种是‘有胜用’：若有一法，生灭无常的势力特别强盛，能伙引生习气的那便是能熏。这遮简不是第八异热心、心所法。因为它们引生习气的势力太赢弱了，所以不是能熏。

    第三种是‘有增减’：若有一法，有强盛的势力和功用，可以增多，也可以减少，能够这样摄持习气的，那便是能熏。这遮简不是佛果。因为佛果是圆满的无漏善法，无可增减，所以不是能熏。假使佛果能熏，便是佛的功德尚未圆满，那就有前后胜劣的差别了。第四种是‘与所熏和合而转’：若能熏与所熏之间，是刹那同时，一身同处，不即不离，那便是能熏。这遮简不是不同处所的自他二身，也不是不同时的刹那前后。因为它们都没有不即不离的和合义，所以不是能熏。唯有以第八识为其所缘的七转识及其心所有法，有胜势用，能增能减，才具有以上四种条件，所以是能熏。

    论文二十八：如是能熏与所熏识，俱生俱灭，熏习义成，令所熏中种子生长，如熏苣胜，故名熏习。能熏识等从种生时，即能为因，复熏成种，三法展转，因果同时，如炷生焰，焰生焦炷；亦如束芦更互相依，因果俱时，理不倾动。能熏生种，种起现行，如俱有因得士用果。种子前后自类相生，如同类因引等流果。此二于果是因缘性。除此，余法皆非因缘，设名因缘应知假说。是谓略说一切种相。

    讲解：所熏、能熏，如前所讲，于此作一总结。能熏的七转识，与所熏的异熟识，生则俱生，灭则俱灭，熏习之义于此成立，这才能令所熏异熟识的种子，由生而长，恰似华熏苣胜，令香气生长一样，所以名为熏习。

    作为能熏的七转识，在从第八种子识里生起的时候，便能为生果之因。复以其所生的现行果法，熏成种子。能生的种子是一法，所生的现行是一法，现行所熏的种子又是一法。这样种生现，现熏种，三法展转，因果同时，好像灯炷生灯焰，灯焰又烧焦灯炷；又好像捆成一束束的芦苇，互相依立一样。这因果同时之理，就是如此。

    现行熏种子，种子起现行，仿佛像六因中的‘俱有因’，所得五果中的‘士用果’一样。前念种子，引生后念种子的自类相生，也仿佛像六因中的‘同类因’，引生五果中的‘等流果’一样。除此二因，可给其所生之果为因缘外，余法都不得名为因缘。如果说名为因缘，应知那是方便假说，不是辨体亲近的实因缘。

    赖耶三相，阿赖耶识是其自相，异熟是其果相，一切种是其因相。此处就是把种子作一总结，如论文说‘是谓略说一切种相’。（注一：俱有因：为能作因、俱有因、同类因、相应因、遍行因、异熟因的六因之一，意谓互为依存的条件，如三杖相依而得站立，三杖即互为俱有因。注二：士用果，为五果之一，亦称士夫果，‘士’为士夫，即人。‘用’为作用，即造作。士用果是人们利用工具造作出来的结果，也就是俱有因和相应因产生的结果。五果为异熟果、等流果、离系果、士用果、增上果。注三、同类因：为六因之一，亦称自种因，因与果的性质相同，其因称为同类因。注四：等流果：五果之一，谓果的性质与因的性质相同，即同类因和遍行因所得之果。）


第二章　所缘行相门

    第二章　所缘行相门

    论文一：此识行相，所缘云何？谓不可知执、受、处、了。了，谓了别，即是行相，识以了别为行相故。处，谓处所，即器世间；是诸有情所依处故。执受有二，谓诸种子及有根身。诸种子者，为诸相名分别习气；有根身者，谓诸色根及根依处。此二皆是识所执受，摄为自体，同安危故。执受及处，俱是所缘。阿赖耶识因缘力故，自体生时内变为种及有根身，外变为器。即以所变为自所缘，行相仗之而得起故。

    讲解：在初能变识八段十义的科分中，三相门之后是‘所缘门’；也就是三十颂第三首颂文：‘不可知执受，处了常与触，作意受想思，相应唯舍受。’这四句颂文中包括了所缘门，行相门，心所相应门，三受相应门四部分。颂文读起来是五字一句，但在讲解的时候，须作散文来讲，即‘不可知执、受、处、了，常与触、作意、受、想、思、相应，相应唯舍受。’此中不可知执、受、处是所缘门，‘了’是行相门，‘常与触，作意、受、想、思相应’是心所相应门，‘相应唯舍受’是三受相应门。

    颂文前‘不可知’三字，这是说第八识行相微细，我们所知不多，故曰‘不可知’。如八识规矩颂‘浩浩三藏不可穷’，也是这个意思。不可知之后的‘执、受、处’，是第八识的所缘的境，‘了’是第八识的行相，即其能缘的作用。分释如下：

    一、行相门的‘了’，了是了别，了解分别，了别就是第八识的行相。因为第八识的自体分，在识变时生起似有实无的相、见二分。这了别作用，就是第八识识体能见的那一部分，也就是见分。

    二、所缘门的‘执、受、处’是见分所缘的境，也就是相分。此中的处是处所，也就是器世间、物质世界，此与有情世间相对，而为一切有情所依住处。执、受有二，一是‘诸种子’；二是‘有根身’。种子前面已经讲过，就是生起万法的亲因缘，所生的一切事物就是见分所缘的境相。有根身就是有情的色身，眼、耳、鼻、舌、身五根。根有浮尘根和净色根之别，有形可见的浮尘根、和肉眼不可见的净色根。具有这些根的身，就叫做‘有根身’（注：执为摄义、持义。受为领义、觉义。第八识执有根身为自体，持使不坏；又共安危，能共苦乐等受，称为执受）。种子与根身，不但是第八识所执持与领受的东西，同时还把它们摄为阿耶识的自体，与之同安共危；所以叫做‘执受’。这执受的种子、根身，及有情赖以生存的器世间，都是第八阿赖耶识所缘的境。以此因缘，当阿赖耶识的自体生起时，就内变而为种子及根身；外变而为器世间。即以此自识所变的相分，还为自识见分所缘之境。见分的行相，就是仗托所缘的境而生起的。

    论文二：此中了者，谓异熟识，于自所缘有了别用；此了别用见分所摄。然有漏识，自体生时，皆似所缘、能缘相现，彼相应法应知亦尔。似所缘相说名相分，似能缘相说明见分。若心、心所无所缘相，应不能缘自所缘境。或应一一能缘一切，自境如余，余如自故。若心、心所无能缘相，应不能缘，如虚空等，或虚空等亦是能缘。故心、心所，必有二相。如契经说：一切唯有觉，所觉义皆无；能觉所觉分，各自然而转。

    讲解：这里所说的‘了’，就是第八异熟识，它在自己所缘的相分境上，有一种了解分别的作用。这了别作用就是自识的见分。然而当有漏识的自体生时，这本来是依它起的相、见二分，都好像是遍计所缘的境相，及能缘的行相，显现在心外一样。第八识心王既然有此能缘与所缘的见、相二分，和它相应的五个心所当然也不例外。这相似遍计所缘的境相名为相分，能缘的行相名为见分。

    倘若在缘境的时候，心，心所上没有带著所缘的境相，则见分就应当不能缘自心所缘的相分了。自识既没有相分做为见分的所缘境，见分又不能无境而缘，在这种情况下，见分所缘的境，必然是余识的相分无疑。如此，则每一个识的见分，不是都能缘一切识的相分了吗？例如眼识的见分，能缘耳识的相分声、鼻识的相分香、舌识的相分味等。倘若心、心所法没有能缘的行相，那就应当如虚空一样，没有缘境的功能。

    能缘的心、心所法，既如虚空一样的不能缘境，那么不能缘境的虚空，常然也如心、心所法一样的能缘境。由以上所说的道理，所以心、心所法，必定有所缘的境，及能缘的行相。例如契经上说：‘一切唯有觉，所觉义皆无，能觉所觉分，各自然而转’。前二句是说：一切法唯有能觉了的内识，至于所觉了的外境，都是虚幻而没有实义的。后二句是说：这能觉所觉的见、相二分，各自随著它的因缘和合而转，并不须要心外之法，或所谓大自在天等的造作。

    论文三：执有离识所缘境者，彼说外境是所缘，相分名行相，见分名事，是心、心所自体相故。心与心所同所依缘，行相相似，事虽数等，而相各异，识、受、想等相各别故。达无离识所缘境者，则说相分是所缘，见分名行相，相、见所依自体名事，即自证分。此若无者，应不自忆心、心所法，如不曾更境，必不能忆故。心与心所同所依根，所缘相似，行相各别，了别、领纳等作用各异故。事虽数等，而相各异，识、受等体有差别故。然心、心所一一生时，以理推征各有三分：所量、能量、量果别故；相见必有所依体故。如集量论伽它中说：似境相所量，能取相自证，即能量及果，彼三体无别。

    讲解：诸小乘部，主张离识之外有所缘的境，并且说外境是所缘的对象，相分名为行相，见分名为‘事’（注：事与理相对，离因缘的无为法是理，因缘和合的有为法名事，见分是仗因托缘生起，故名事），因为这是心法和心所法自体之相。心法和心所法同所依同所缘，俱依一根，俱缘一境，行相相似。心王见分的心、‘事’虽多种，其相各不相同，因为识相是了别，受相是领纳，想相是取境，作用各不相同。领悟到离识之外别无所缘之境的大乘论师，则说相分是所缘的境，见分称为行相。相、见二分共同依托的自体分才称做事，就是自体证知自己有缘境事功的‘自证分’。假使没有这个自证分为见、相二分所依托，心法和心所法自身就应当不能忆念，这好像不曾更境（注：不曾更境，就是没有经历过的事物），决定不能忆念。那怕做梦也梦不到。

    心王和心所是同依一根，如眼识心王、心所，同依眼根等。所缘的境，也仿佛相似，如缘青则皆变为青，缘黄则皆变为黄等。但其分别缘境的行相，却是各各别异。因为识的了别，和受的领纳等，都不一样。识的自体和心所，依缘的根境虽同，而行相各异。因为识有识体；受有受体；识、受等体，各有差别。

    然而当心王心所，一个个生起的时候，按道理推究，每一王所各有三分：一是所量的相分，二是能量的见分，三是量果的自证分。以心量境，好像以尺量物，物是所量，尺是能量，量知之数即是量果。故以所量名相分，能量名见分，量果为相、见二分所依的自体、即自证分。

    如集量论的偈子说：‘似境相所量。能取相自证；即能量及果，彼三体无别。’意思是说：唯识所现似有实无的外境相分，就是所量；能执取境相的见分，就是能量；自证分就是量果。它们的功能虽有三分，而唯一的识体并无差别。

    论文四：又心、心所，若细分别，应有四分，三分如前，复有第四证自证分。此若无者，谁证第三？心分既同，应皆证故。又自证分应无有果，诸能量者必有果故。不应见分是第三果，见分或时非量摄故。由此见分不证第三，证自体者必现量故。

    此四分中前二是外，后二是内。初唯所缘，后三通二。谓第二分但缘第一，或量非量，或现或比。第三能缘第二第四，证自证分唯缘第三，非第二者，以无用故，第三第四皆现量摄，故心、心所四分合成。具所、能缘无无穷过。非即非离唯识道成。

    讲解：再者，如果对心法和心所法仔细分别，则每一心王、心所应有四分：除前面所说的相分、见分、自证分三分之外，还有一个第四的‘证自证分’。因为如果没有这个证自证分，那么第二的见分，有第三的自证分来给它验证，但是谁来给自证分验证呢？应该就是证自证分了。无论第三的自证分，第二的见分，二者既然同是心体的一部分，，都应当有个验证，所以才建立第四的证自证分，来证明第三的自证分；也像自证分证知见分一样。

    见分是能量，自证分是量果。当自证分缘见分时，那见分便成为所量的相分；自证分便成为能量的见分了。那么，谁来做量果呢？这当然是证自证分了。因为凡是能量的，必定要有个量果。如果有人说：以第二的见分，回头来做第三的量果，不是也可以吗？何必要证自证分？事实不然，当知见分缘境，不一定是如镜照物一样正确的现量，所以见分不能回头来验证第三的自证分，因为证知自体一定要依靠现量。

    相分、见分、自证分、证自证分四分，前二分缘似外境而名外；后二分，自体内证而名内。第一的相分，只是所缘的境，而无能缘之用；其次的见分、自证分、证自证分，则通于所缘与能缘。也就是：第二见分只能缘第一相分，而不能反缘第三。因为它没有缘第三现量境的一定把握，因为它有时是亲自证到的现量，有时是推测而知的比量，有时甚至是非量。第三的自证分，不但能顺缘第二的见分；而且也能反缘第四的证自证分。证自证分，唯缘第三而不缘第二，因为第二已为第三所缘，用不著再缘了。第三和第四，因为都是现量所摄，有互为能缘及所缘的功用，所以心王和心所，只要四分合成，就不必再有第五缘第四，第六缘第五了。这四分自用来说是非一，自体来说是非异，唯识妙理，如此而成。四分的关系表解如下：

    相分───────────────所量

    见分───────能量──────所量

    自证分──────能量──────所量──────量果

    证自证分─────能量──────所量──────量果

    论文五：是故契经伽它中说：众生心二性，内外一切分；所取能取缠，见种种差别。此颂意说，众生心性，二分合成。若内若外，皆有所取、能取缠缚，见有种种，或量非量或现或比，多分差别。此中见者是见分故。如是四分或摄为三，第四摄入自证分故。或摄为二，后三俱是能缘性故，皆见分摄。此言见者，是能缘义。或摄为一，体无别故。如入楞伽伽它中说：由自心执著，心似外境转，彼所见非有，是故说唯心。如是处处说唯一心，此一心言亦摄心所。故识行相即是了别，了别即是识之见分。

    讲解：所以《厚严经》里有偈子说：‘众生心二性，内外一切分，所取能取缠，见种种差别。’偈子的意思是说：众生之心有内、外二性，外是缘外的见、相二分；内是缘内的自证分及证自证分。由于被这内外四分所取的妄境，和能取的妄见所缠缚，所以才见有现量、非量、比量等的种种差别。这里所说的‘见’，就是见分。

    以上所说的相分、见分、自证分、证自证分。也可以把证自证分归纳到自证分里合而为三。也可以把证自证分及自证分，都归纳到见分里，使之合而为二。也因为除了前面的第一分是‘所缘’之外，后面三分都是属于见分所摄的能缘。而所谓见分，纯粹是能缘，不带所缘。也可以把四分通统归纳起来，使之合而为一。因其作用虽然有四，而其体实无差别。

    例如《入楞伽经》中的偈子说：‘由自心执著，心似外境转，彼所见非有，是故说唯心。’意思是说，由于众生自心的执看，好像有外境转起一样，其实那里有什么外境，还不是唯识所变吗？以是之故，所以才说唯心。像这种唯是一心，更无外境的说法，经中处处可见。这里所说的一心，不仅指八识心王，也包括五十一个心所在内。由于以上所说的种种，所以识的行相就是了别。了别就是第八识的见分。（注：心识本有的性能称为行相。因为识自体分以了别为行相，行相也就是见分。）

    论文六：所言处者，谓异热识由共相种成熟力故，变似色等器世间相，即外大种及所造色。虽诸有情所变各别，而相相似，处所无异，如众灯明各遍似一。谁异熟识，变为此相？有义一切，所以者何？如契经说：一切有情业增上力共所起故。

    讲解：第八识的行相已如上说，以下讲所缘的执、受、处三字，分释如下：

    首先讲‘处’字，所谓处，就是第八异熟识里的共相种子（注：共相种子，指所生之果可使多人受用的种子，如山河大地，即众生共相种子所变），由于这种子成熟的因缘之力，变现出一种似实色而非实色的器世间相；也就是身外能造的地、水、火、风四大种，及所造的色、香、味、触四尘色（注：‘即外大种及所造色’，指本识中变为器世间外境的种子称外大种，此称能造四大。客观物质世界称为所造）。因其是外处，不是有情，故名为外；并不是心外的实法。

    诸有情类，唯识所变的东西各别不同，然而共业种子所感的共报果相的‘处’，却是相似无异。譬如众灯齐明，光耀一室，这遍满一室的灯光，虽是众灯所共照，却分不出彼此所照的光，好像只有一盏灯一样。

    或问，是谁的异熟识，变为此器世间相？此有三家不同的主张。第一家月藏认为：是一切有情众生的异熟识、共同变化为此相。为什么呢？如《立世经》所说：‘由于一切有情众生之业的促进力，共同生起此相。’

    论文七：有义，若尔，诸佛菩萨，应实变为此杂秽土，诸异生等，应实变为他方此界诸妙净土。又诸圣者厌离有色，生无色界，必不下生；变为此土，复何所用？是故现居及当生者，彼异熟识变为此界。经依少分说一切言，诸业同者，皆共变故。

    有义：若尔，器将坏时，既无现居及当生者，谁异熟识变为此界？又诸异生厌离有色，生无色界，现无色身，预变为土，此复何用？设有色身与异地器，粗细悬隔，不相依持，此变为彼，亦何所益？然所变土，本为色身依持受用；故若于身可有持用，便变为彼。由是设生它方自地，彼识亦得变为此土；故器世界将坏初成，虽无有情，而亦现有。此说一切共受用者，若别受用准此应知，鬼、人、天等，所见异故。

    讲解：第二家的难陀反驳月藏说：你说的未免儱侗，果如世界是‘一切有情业增上力共所起故’，一切有情当然包括六凡四圣，那么久已转染成净没有杂秽种子的诸佛菩萨，就不是假缘度化，而是实在的变成了我们这个杂染秽浊的国土；五趣异生的异熟识，也应当实变为他方极乐、此界灵鹫等的诸妙净土了。若以为有情不摄佛圣，器界不摄净土，但异生中有阿那含，器界中有无色界，不还果等的圣者，它们既已厌离了欲色界，上生无色界去了，必定不愿再来下生，那么变此秽土，又有何用呢？（注：‘他方、此界诸净妙土’一句，它方即此三千大千世界之外的化土，此界即娑婆世界，此方诸净妙土，指如灵鹫山等处。）

    是故，器世间，是由现身所住，及次当所生的人，随其凡圣的异熟，而变为他方、此界、或秽、或净的国上了。经上所说的‘一切’，是依少分同业而言，凡是一切造业相同的人，大家都可以变为一个器世间。

    第三家护法反驳难陀说：若照你所说，器世间濒临坏劫时，既没有现居者，也没有当生的人，是谁的异熟识变为这个世界呢？还有，已厌离欲界、色界，生到无色界的众生，他们已竟没有色身了，变土原为色身依住，既无色身，它预先变好这个秽土又有何用呢？即令有色身，与异地器界比较起来，粗细悬隔，何止天渊，这教他们如何依住？既不堪依住，那么，以此上界的异熟识，变彼下界的秽土，又有什么益处呢？然而所变的土，本为色身依持受用而变秽土，所以只要他认为于色身可能有依止受用价值的，便变为彼土。因此，不一定是现居及当生，就是生在他方世界的人，以彼界的异熟识，也可以变为此界之土。所以器世间，无论在将坏或初成，虽无现居及当生的人，而依然现有。

    这是说一切有情，可以共同受用的大千世界。至于在这共中不共的各别受用，亦应准此例知。例如鬼、人、天等，虽然都住在这个共同受用的大千世界，而其各自所见的局部境界，却是共中的不共。

    论文八：诸种子者，谓异熟识所持一切有漏法种，此识性摄，故是所缘。无漏法种虽依附此识，而非此性摄，故非所缘。虽非所缘，而不相离，如真如性不违唯识。有根身者，谓异熟识不共相种成熟力故，变似色根及根依处，即内大种及所造色。有共相种成熟力故，于他身处亦变似彼。不尔，应无受用他义。

    讲解：处字的解释已如上说，今讲‘执、受’二字。本识执受，有种子及根身二法，今先讲诸种子。什么叫做诸种子呢？就是第八异熟识所摄持的三性有漏种子，此种子由本识所摄，同时也为本识所缘的相分境。或问：有漏种子，依本识而为识所缘；无漏种子，亦依本识，何以不相提并论，而独言有漏呢？答曰：无漏种子，虽也依附于本识自体，但其不是无记性，而是善性，所以不能做有漏识的所缘。又问：识既不缘无漏种子，岂不违背唯识之理？答曰：无漏种子，虽然不是本识所缘之境，但也不像真如那样是离识别有的实法，故不违唯识之理。

    至于‘根身’，就是我们眼、耳、鼻、舌、身的五根身。这是第八异熟识里的不共相种子，（注：不共相种子，指所生之果不共受用的种子，如眼、耳、鼻、舌、身五根）成熟的因缘之力，变现为似色根和根依处（注：根依处即浮尘根）。也就是身内地、水、火、风四大种，及色、香、味、触的所造色。这在共相的器世间里，是共中的不共，所以由不共相种子所变现。

    异熟识里，还有一种共相种子，由于此种子成熟的因缘之力，于他人身处，也变为似彼相。否则，它人就不能有助于我，而为我所受用了。这在不共相的自他根里，是不共中之共，所以由共相种子所变现（注：共业不共业，有四种情况，称‘四变句’。一、共中共业：如自然界山河大地，为有情所共享者。二、共中不共业：人类社会有主的田宅，为所有人所独享者。三、不共中共业：即个人身体外根的浮尘根，这虽是个人所独有，但他人如夫妻者亦可共同享用者。四、不共中不共业：个人身体内根的胜义根，只供自己所用。）

    论文九：此中有义：亦变似根。辩中边说：似自、他身、五根现故。有义：唯能变似依处，他根于己非所用故。似自、他身五根现者，说自、他识各自变义。故生他地或般涅槃，彼余尸骸，犹见相续。

    讲解：关于‘有根身’，有两家不同的解释，第一家安慧认为：自识不但能变尘境，而且也变自他的根身。何以见得呢？《辩中边论》中说：‘似自他身五根现故’，意思是自身和它身的五根，都可以变现。但第二家护法则认为：自识只能变‘似依处’构成色根的物质。因为他人的净色根对自己来说，并非所用。似自、他五根显现，只能说是自、它之识各自变幻。故《辩中边论》里所说那‘似自它身，五根现故’的话，只是说自己和它人的阿赖耶识，各自变为各自的根，并不是自己的识能变它人的根。

    或有问曰：自识既不能变他根，怎样知道能变他根的依处呢？答：假使有人在此地报尽命终，转生他地，或修行者入无余涅槃之时，所剩下的尸骸，我们不是还看见它继续存在吗？这证明每个人的根依处，都是自它所共变的。否则，这剩余的尸骸，是谁的识所变的呢？

    论文十：前来且说业力所变外器、内身，界、地差别，若定等力所变器、身，界、地、自、他，则不决定。所变身、器多恒相续。变声、光等多分暂时，随现缘力击发起故。略说此识所变境者，谓有漏种、十有色处，及堕法处所现实色。

    讲解：前面已说有情业力所变的外而器界、内而根身，及界、地差别，若圣者以禅定神通等力，所变的器、身、界、地，自现他感，则不可一例决定。分别来说，所变之根身、器界，大部分恒时相续而现。所变声及光等，大部分是暂时的，如昙花一现，刹那即逝。因为这是随顺因缘之力，彼此击发而生起的，如雷声、电光，是随著阴阳电的缘力所击发，缘尽则不复相续。简单的说，阿赖耶识所变的外境，包括有漏种子，五根、五尘的十色处，和依威德定随著法处所现的实色等（注：法处为十二处之一，为意根所对之境，法处所摄色共有五种，即极略色，极迥色，受所引色，遍计所执色，定所生的自在色。）

    论文十一：何故此识，不能变似心、心所等为所缘耶？有漏识变略有二种：一随因缘势力故变，二随分别势力故变。初必有用，后但为境。异熟识变但随因缘，所变色等必有实用。若变心等，便无实用，相分心等不能缘故，须彼实用别从此生。变无为等亦无实用，故异熟识不缘心等。至无漏位胜慧相应，虽无分别，而澄净故。设无实用亦现彼影。不尔，诸佛应非遍智。

    讲解：有人问曰：为什么异熟识只能变色法，而不能变心、心所法为所缘呢？答曰：在凡位的有漏识变，略有二种，一是不加作意，随著种子因缘势力而变的，此称因缘变；二是随著六、七识分别势力而变的，此称分别变。随著种子因缘所变的，必定有其实在的功用；随著分别势力而变的，那只是当情所现的虚妄之境。

    异熟识变，是随著种子的因缘势力，不加作意，所以它所变的相分色，必有实用；若变心、心所，那就没有实用了。因为随著见分所变的相分心法，都如镜花水月，没有缘虑的实在体用，所以第八识不缘心法。那么，无为法有实体，变无为法好吗？答：无为法虽有实体，而非因缘，所以变无为法也不为所缘。因此异熟识但缘自识所变的相分色，而不缘心、心所等。

    第八识到达无漏位时，由于与殊胜的智慧相应，虽然没有筹度取相的分别，而澄净明澈，如镜海秋月，虽不缘实法，亦现心影，使万法不能逃其形。不然，诸佛就应当不是遍知一切法的正遍智了。

    论文十二：故有漏位，此异熟识，但缘身、器及有漏种，在欲、色界具三所缘，无色界中缘有漏种，厌离色故，无业果色，有定果色，于理无违，彼识亦缘此色为境。

    讲解：所以有漏位凡夫的异熟识，只能缘根身、器界、种子，在欲界、色界，具备了这三种所缘，在无色界则但缘种子。因为其厌离欲、色之故，虽无因业受报的业果色，但犹有由禅定引发的定果色，为异熟识所缘，这在道理上并不违背。

    论文十三：不可知者，谓此行相极微细故，难可了知。或此所缘内执受境亦微细故，外器世间量难测故，名不可知。云何是识取所缘境行相难知？如灭定中不离身识，应信为有。然必应许减定有识，有情摄故，如有心时。无想等位当知亦尔。

    讲解：在所缘行相门的颂文之前，有‘不可知’三字，不可知有二义，一是能缘的见分，因其行相极为微细，所以难可了知。二是所缘的相分，其内所执受种子及胜义根，也是微细难知；以至外所依住的器世间，更是量大难测，所以称‘不可知’。

    经量部及有部师问曰：为什么识所缘境的行相难知呢？既不可知，应不是识。论主答：如灭尽定中的‘不离身识’，它的行相就不可知。虽不可知，但应信灭尽定中有识，仍属有情众生，像未入定前有心时一样。灭尽定有识，无想定等当然也有识。


第三章　心所相应门

    第三章　心所相应门

    论文一：此识与几心所相应？常与触、作意、受、想、思相应。阿赖耶识无始时来乃至未转，于一切位，恒与此五心所相应，以是遍行心所摄故。

    讲解：本章讲心所相应门。第八阿赖耶识与几个心所相应呢？答曰：与触、作意、受、想、思五个心所相应。阿赖耶识从无始以来，直到尚未转为大圆镜智成佛以前，在九法界的一切位里，都恒常和这五个遍行心所相应。因为遍行心所是遍与八识相应的。

    论文二：触谓三和，分别变异，令心、心所触境为性，受、想、思等所依为业。谓根、境、识，更相随顺，故名三和。触依彼生，令彼和合，故说为彼。三和合位皆有顺生心所功能，说名变异。触似彼起，故名分别。根变异力引触起时，胜彼识、境，故集论等但说分别，根之变易。和合一切心及心所，令同触境，是触自性。既似顺起心所功能，故以受等所依为业。

    讲解：今先解释遍行中的触心所。触有二义：一、以根、境、识三法和合的分别变异之力，使心、心所与尘境接触，为触的体性。二、受、想、思等一切心所依之而起，是触的业用。也就是说，这一体三名的根、境、识，不但不互相乖违，而且更互相随顺，依根取境而生识，所以名叫三和合。因此触心所依彼三和合而生，亦能令彼三法和合。

    什么叫‘变异’？在根、境、识三法的和合位上，有随顺生起一切心所的功能，未和合以前则无此功能，所以说名变异。如何又叫‘分别’？触心所有似彼三法和合，顺生一切心所的变异功能，所以又名分别。或问：触心所既为根、境、识三法和合，说名分别变异，何以《集论》但说‘分别根之变异’呢？答曰：因为当根、境、识三法和合，引起触心所时，根的变异力量，超胜于识、境二法，所以《集论》但说‘分别根之变异’，而不说分别识、境的变异。其实触的功能，不但根、境、识三法缺一不可，而且还能和合一切心、心所的行相，都来和它同缘一境，这就是触的自性。既然好像三法和合，具有产生相应心所法的作用，所以能引生受等心所法。

    论文三：起尽经说：受、想、行蕴，一切皆以触为缘故，由斯故说识、触、受等，因二三四和合而生。瑜伽但说：与受、想、思为所依者，思与行蕴为主胜故，举此摄余。集论等说：为受依者，以触生受近而胜故。谓触所取可意等相，与受所取顺益等相极相邻近，引发胜故。

    讲解：这在《起尽经》里可找到证明，经里说：受、想、行三蕴，乃至一切心所，都是以触为缘而生起的，因此才说，识是因根、境二法和合而生；触是因根、境、识三法和合而生；而受、想、思等一切心所，则是因根、境、识、触四法和合而生。

    既然一切心所都是因触而生起，何以《瑜伽论》但说触以受、想、思为所依，而不说以行蕴为所依呢？那是因为行蕴是以思为主体，思的作业能力又较行等为胜，所以但举此‘思’来赅摄余法。若是如此，何以《集论》又说：触是以受为所依呢？那是因为受因触生，它们的关系比较接近，胜过余法之故。意思是说：触所取可意、不可意、俱相违之境，与受所领苦、乐、俱相违之境极相邻近，引发的机缘胜过余法之故。然触自性是实非假，在六六法中是心所之性，由食所摄，能为缘故。如受等性，就不是三位和合。（注一：六六法，即六识、六触、六受、六想、六思、六爱。）

    论文四：然触自性，是实非假，六六法中，心所性故，是食摄故，能为缘故，如受等性，即非三和。

    讲解：论主称：‘然触自性，是实非假’句，是针对小乘经量部而说的。小乘经量部以根、境、识三和合为借口，便说触无实体。论主破他说：触有触的自性，是实非假，其故有三：一，此触在六识、六触、六受、六想、六思、六爱的六六法中，是属于心所有法的缘故。二，此触为段食、触食、意思食、识食这四种食性所摄的缘故。三，此触为十二因缘中的第六因缘的缘故。由以上三种缘故，触和受、想、思，是同样的各有自性，怎能说他是无体性的三和？

    论文五：作意，谓能警心为性，于所缘境引心为业。谓此警觉，应起心种，引令趣境，故名作意。虽此亦能引起心所，心是主故，但说引心。有说令心回趣异境，或于一境持心令住，故名作意。彼俱非理，应非遍行，不异定故。

    讲解：作意心所，以能警觉未生心的种子使之生起，这就是作意的体性；能引既生心去攀缘尘境，就是作意的业用。所以作意的功能，一者警觉应生心的种子，二者引令趣缘尘境。那么，是不是也能引生心所呢？答：虽然这作意也能引起心所，但因为心王为主，心所为从，所以但说引心，对心所就略而不言了。

    正理师说它令心回转趣向异境。《杂集论》中说它于一境持心令住，不使散乱，这两种说法都不对，因为令心回趣异境，不是遍行心所的作用；于一境持心令住，那和禅定就没有区别了。

    论文六：受谓领纳顺、违、俱非境相为性，起爱为业，能起合离非二欲故。有作是说，受有二种，一境界受，谓领所缘；二自性受，谓领俱触。惟自性受是受自相，以境界受共余相故。彼说非理，受定不缘俱生触故。若似触生名领触者，似因之果应皆受性。

    又既受因，应名因受，何名自性？若谓如王食诸国邑，受能领触所生受体名自性受。理亦不然，违自所执，不自证故。若不舍自性名自性受，应一切法皆是自性受。故彼所说，但诱婴儿。然境界受非共余相，领顺等相定属己者，名境界受，不共余故。

    讲解：受心所，以领纳顺境、违境、或顺违俱非的境界为其体性；能引起众生的爱欲是其业用。怎样起爱？就是对于所领纳的顺境起合欲；违境起离欲；顺、违俱非的中庸境，那就无所谓合离二欲了。

    但正理论师说：受有二种，一种叫做境界受，能领纳所缘的境界。一种叫做自性受，能领纳‘俱触’。领纳俱触的意思就是‘受由触生’。同时触所触到的苦、乐、舍，都能够领纳。唯有自性受，能领纳触境，不与余法所共，可以说是受的自相。至于境界受，那是和其余的心、心所，共同领纳的境界。论主以为正理师之说非理，因为受由触生，如何后受能缘前触呢？若以为受由触生，与触相似，所以名为领触，如此，那一切从因所生，与因相似的等流果，都应当叫做自性受了。还有，既然触为受因，那触因所生的受，就应当名为因受，何以名自性受呢？小乘师救曰：譬如‘王食国邑’，王不过食国邑所产的物资，但从其能产而言，说‘食国邑’罢了。受能领触，也是如此，不过是领触所生的受体，但从其能生而言，说‘领触’。因为这是自领的意思，所以名叫自性受。

    论主驳曰：此理未必尽然，因为这自领的意义，和你们那‘心不自证’的执著，正是相违背的。若说自领并非自缘，而是不舍离自体，名叫自性受，那么尽世间所有的一切法，没有一法是舍离自体的，难道说都叫自性受吗？所以你们所说的谬理，只可以骗那襁褓中的婴儿，而不值方家一哂。

    自性受虽如上破，然而境界受只能感受自相，并非共于其余心相。领纳顺、违、及顺违俱非诸境，决定属于自己的，才可以叫境界受，因为它不共于其它心相。

    论文七：想谓于境取像为性，施设种种名言为业。谓要安立境分齐相，方能随起种种名言。

    讲解：想心所，以对外境取像为其体性；施设种种名字言说为其业用。怎样叫施设名言呢？就是安立境界相的种种名字言说。例如为要安立世间相的差别，才随起有情世间、器世间、乃至三界九地等种种名言。

    论文八：思谓令心造作为性，于善品等役心为业。谓能取境正因等相，驱役自心令造善等。

    讲解：思心所，令心造作为其体性；役使心识生起善、恶、无记等事是其业用。也就是说，思能取现境，为邪、正、俱相违行为之因，驱使自心去造作善、恶、无记之业。

    论文九：此五既是遍行所摄，故与藏识决定相应。其遍行相，后当广释。此触等五与异熟识行相虽异，而时、依同，所缘、事等，故名相应。

    讲解：以上这触、作意、受、想、思五个心所，既然属于遍行所摄，所以和第八藏识，决定相应。至于遍行的行相怎样，后面当有详细讲解。这触等五个心所，和第八异熟识，它们的见分行相虽异，然而同时生起、依于同根，所缘的相分境，及自体分，也是相似而等。所以名叫相应。


第四章　五受相应门

    第四章　五受相应门

    论文一：此识行相极不明了，不能分别违、顺境相，微细、一类，相续而转，是故唯与舍受相应。又此相应受唯是异熟，随先引业转，不待现缘，任善、恶势力转故，唯是舍受。苦、乐二受是异热生，非真异熟，待现缘故，非此相应。又由此识常无转变，有情恒执为自内我，若与苦、乐二受相应，便有转变，宁执为我？故此但与舍受相应。

    讲解：此为八段十门中的五受相应门。说到五受相应，《三十颂》称‘相应唯舍受’。这第八阿赖耶识，行相极不明了，它不能分别违境、顺境之相，它的行相微细，始终一类相续而转。因此只能和非苦非乐的舍受相应。

    再者，这个相应受，唯是第八异熟识总业所招感，随著先世业力的牵引，并不须要等待现前的助缘，任由过去世善恶势力的发展，而自然转起。因此，与第八识相应的，唯独是这个舍受。至于苦、乐二受，那是前六识的异熟生待缘方起，而不是第八识的真异熟，所以不和第八识相应。（注：唯识宗以第八识总报之果体称为真异熟；由此所生之前六识别报之果，即称为异熟生。）

    再者，由于第八识是一类相续常无转变，所以有情的第七识就执之为常、一的自内之我。倘若与苦乐二受相应，那就不是一类相续的舍受，而是有善、恶转变的余受了，因此第八识唯与舍受相应。

    论文二：若尔，如何此识亦是恶业异熟？既许善业能招舍受，此亦应然，舍受不违苦乐品故，如无记法善、恶俱招。

    讲解：说一切有部师问难曰：如果依你们唯识家所说，第八识唯与舍受相应的话，那么，为什么第八识不但是善业的异熟识，而且也是恶业的异熟识呢？论主回答：既允许善业能招感舍受，当然恶业也能招感舍受。因为舍受于苦乐二品皆不相违，如非善非恶的无记法，善业、恶业也都可以招感。我们说一个容易了解的譬喻，譬如一幅素绢，你随便画上什么颜色都可以。

    论文三：如何此识非别境等，心所相应？互相违故。谓欲，希望所乐事转，此识任业，无所希望。胜解，印持决定事转，此识瞢昧，无所印持。念唯明记曾习事转，此识昧劣，不能明记。定，能令心专注一境，此识任运，刹那别缘。慧，唯简择得等事转，此识微昧，不能简择。故此不与别境相应。

    讲解：有部论师又问：为什么这第八阿赖耶识，不与别境及善等心所相应呢？论主答：那是因为它们的行相互相违背。五个别境心所，欲心所是随著希望的乐事而转，第八识则是任听其过去的业力而转，没有所谓的希望。胜解心所是从犹豫不定中，即可坚持所决定的事而转的，第八识瞢瞢味昧，本非犹豫，所以也无所谓印持。念心所是由明记曾经熟习之事而转，第八识昧闇劣弱，它不能明记曾经缘过的境界。定心所能令心专注于所观之境，第八识则任运随业，刹那别缘。慧心所是唯以简择得失之事而转，第八识则隐微闇昧，不能简择。因此第八识不与别境心所相应。

    论文四：此识唯是异熟性故。善、染污等，亦不相应；恶作等四，无记性者，有间断故，定非异熟。

    讲解：因为此识是异熟性，所以它不但不与别境心所相应，不与善、烦恼等心所相应，同时也不与悔、眠、寻、伺四种无记性的不定心所相应。这四种不定心所虽然也是无记性，但它们都是前六识有间断的异熟生，前六识有间断，不是第八识的相续而转的真异熟，所以也不相应。


第五章　三性分别门

    第五章　三性分别门

    论文一：法有四种，谓：善、不善、有覆无记、无覆无记。阿赖耶识何法摄耶，此识唯是无覆无记，异熟性故。异熟若是善、染污者，流转还灭应不得成。又此识是善、染依故。若善、染者，互相违故，应不与二俱作所依。又此识是所熏性故，若善、染者，如极香臭，应不受熏，无熏习故，染、净因果俱不成立。故此唯是无覆无记。

    讲解：此章讲阿赖耶识的三性门。世间事物的属性有四种，即善、不善、有覆无记、无覆无记。阿赖耶识在这四类法中，属于无覆无纪，因为它是非善非恶的异熟性。假使异熟是局限于善性，那因业流转的凡夫，就不能成就五趣生死；假使异熟是属于恶性，那修道还灭的圣人，就不能成就涅槃妙果。再者，这第八识，虽然是善、恶二法同所依止的总报主，实际上它是非善非恶。它假使是善，便不能为恶法所依止；是恶，便不能为善法所依止，如此相违，怎为善、恶二法作同所依止的总报体呢？这第八识虽是善、恶之所熏体，而实非善、恶。假使它本身是善、恶的话，那就应当如极香的旃檀，或极臭的阿魏一样，不能再受熏习了。熏习，就是种子。如果第八识里没有熏习的种子，那一切染净法的因果，不是都不能成立了吗？因此，阿赖耶识唯是无覆无记。

    论文二：覆谓染法，障圣道故，又能蔽心，令不净故，此识非染，故名无覆。记，谓善、恶，有爱、非爱果，及殊胜自体，可记别故。此非善、恶，故名无记。

    讲解：‘覆’的意思是障蔽，是染法，能障碍成佛之道，不令悟入；蔽者能蔽真心，不使清净。而阿赖耶识不是染法，所以名为无覆。记的意思是善法有可爱果，恶法有非可爱果，及有此殊胜的善、恶法体可资记别。记别，就是记取其当来爱与非爱的差别果相。这阿赖耶识，没有善、恶因果可资记别，所以名为无记。


第六章　心所例同门

    第六章　心所例同门

    论文一：触等亦如是者，谓如阿赖耶识，唯是无覆无记性摄。触、作意、受、想、思亦尔。诸相应法必同性故。

    讲解：颂文中‘触等亦如是’句，意思是说触等五遍行心所，例同阿赖耶识，也是无覆无记性摄。因为凡是相应的心、心所法，它们在善、恶、无记三性中，必定是同属一性。

    论文二：又触等五，如阿赖耶亦是异热。所缘、行相俱不可知，缘三种境，五法相应，无覆无记，故说触等亦如是言。有义，触等如阿赖耶，亦是异热及一切种，广说乃至无覆无记，亦如是言无简别故。彼说非理，所以者何，触等依识不自在故。如贪、信等，不能受熏，如何同识能持种子？

    讲解：又有第二家这样说，触等五个心所，和阿赖耶识亦是异熟。所缘行相俱不可知，缘三种境，有五种相同的意义：一者触等五心所亦为前业所感，是真异熟报果。二者所缘、行相，俱不可知。三者同缘三种境：根身、器界、种子。四者与触等五法相应，即心王与此五心所共为六法，除去各个自体，而与余五法相应。五者其性亦是无覆无记。所以说：‘触等亦如是’。

    又有第三家说：触等五位心所法，也和阿赖耶识一样，是异熟果体，及有、无漏法的一切种子，乃至无覆无记。‘亦如是’的话，是指阿赖耶识的一切，并没有于此如是，于彼不如是的简别。护法论师认为：以上三家的观点都不对，因为触等心所，是依于本识心王而存在，它们并非自在。就像贪、嗔等烦恼心所，及信、精进等善心所一样，都不能受熏。既不能受熏，如何能像本识一样的执持种子呢？

    论文三：又若触等亦能受熏，应一有情有六种体。若尔，果起从何种生？理不应言从六种起，未见多种生一芽故。若说果生唯从一种，则余五种便为无用。亦不可说次第生果，熏习同时势力等故。又不可说六果顿生，勿一有情一刹那顷，六眼识等俱时生故。

    讲解：如果触等五个心所，也和阿赖耶识一样能够受熏，一个有情就有了六个持种之体（五个心所和一个阿赖耶识）。如果是这样，果从那个持种之体生起呢？不应该从六个种子共生一果，因为从未有见过多种同生一芽。若说果从一个种子而生，那末其余五个种子不都没有用途了吗？也不可说六个种子次第生果，因为种子既是同时熏习，势力是相等的，无分胜劣，那会有先后次第生果的道理。也不可说六个种子同时顿生六果。因为没有一个有情，在一刹那的顷刻，一个心王和五个心所同时生六个眼识、六个耳识等的现行果法。

    论文四：谁言触等亦能受熏持诸种子？不尔，如何触等如识名一切种？谓触等五有似种相，名一切种。触等与识所缘等故。无色触等有所缘故，亲所缘缘定应有故。此似种相不为因缘生现识等，如触等上，似眼根等，非识所依。亦如似火，无能烧用。

    讲解：第三家复申辩说：谁说触等五心所也能受熏，也能储藏种子呢？论主反诘说：你既不承认触等能受熏持种，为什么说触等也同阿赖耶识一样，名一切种子呢？第三家答：：那是因为触等五个心所所变的种子，和本识所变的种子相似之故，所以名‘一切种’。这有三个理由：一者触等五位心所与本识同所缘境，若触等不缘种子，便有与本识缘境不同的过失。二者至无色界，触等五位心所虽然已经不能缘色，但仍有所缘相，缘本识相分的亲所缘缘肯定是存在的。三者无论心王或心所，一定有它自己的相分种子，来做它自己见分的亲所缘缘。若但凭心王所变种子，而不在触等心所上现似种相，那便不是触等的亲所缘缘。但这似种子的影像，并不是生现行果识的因缘性。例如心所上所变的触似眼等五根，不能亲生眼等五识；亲生眼等五识的根，是心王所变，就如镜里所现的似火像，并没有燃烧的功用。

    论文五：彼救非理，触等所缘似种等相，后执受处，方应与识而相例故。由此前说一切种言，定自受熏能持种义。不尔，本颂有重言失。又彼所说亦如是言，无简别故，咸成例者定不成证。勿触等五亦能了别，触等亦与触等相应。由此故知，亦如是者，随所应说，非说一切。

    讲解：论主反驳说：这种答辩不合理，触等五位心所的所缘、似种等相，名一切种，要到后面所缘门的执、受、处中，才能与本识心王相例。如何说在执、受、处前的一切种里就可相例？因此，前句所说的‘一切种’，一定是能够受熏及执持种的意义，而不是缘似种相。不然，在前句‘一切种’里，业已说过了似种，到后句的执、受、处里，又说似种，那本颂岂非有重言的过失？

    再者，颂文所说‘亦如是’这句话，是没有简别，心王、心所一切皆可例同的证词，是决定不能成立。试问：识能了别，触等五个心所也能了别吗？识与触等相应，触等也与触等相应吗？因此，‘亦如是’这句话，是随其所应的无覆无记而说的，并不是没有简别，不管相应不相应就通亦如是。


第七章　因果譬喻门

    第七章　因果譬喻门

    论文一：阿赖耶识为断为常？非断非常，以恒转故。恒谓此识无始时来，一类相续，常无间断，是界、趣、生施设本故，性坚持种令不失故。转谓此识无始时来，念念生灭，前后变异，因灭果生，非常一故，可为转识熏成种故。恒言遮断，转表非常，犹如瀑流，因果法尔。

    讲解：有人问说：阿赖耶识是断灭呢，还是常住？论主答曰：非常非断，如颂文‘恒转如瀑流’这句所说。怎样叫做‘恒’呢？是说这阿赖耶识从无始以来，在善、恶、无记的三性中，总是一类无记性恒时相续，永无间断。因此它有两种功能：一是为三界、五趣、四生安立的根本；二是摄持种子，令不散失。‘转’的意思是这阿赖耶识，从无始以来，念念生灭，刹那不住的在前后变异，其前因既灭，后果又生，不是常一之法，所以才能为七转识所熏习，而成为一切染净法的种子。

    恒的意义是遮简非断；转的意义是表显非常。这非断非常的阿赖耶识，犹如瀑流一般，其前因后果的推演，自然是这样的。

    论文二：如瀑流水，非断非常，相续常时，有所漂溺。此识亦尔，从无始来生灭相续，非常非断，漂溺有情，令不出离。又如瀑流，虽风等击起诸波浪，而流不断。此识亦尔，虽遇众缘起眼识等，而恒相续。又如瀑流，漂水上下鱼、草等物，随流不舍。此识亦尔。与内习气外触等法，恒相随转。如是法喻，意显此识无始因果，非断、常义，谓此识性无始时来，刹那刹那果生因减。果生故非断；因减故非常。非断非常，是缘起理。故说此识，恒转如流。

    讲解：这是以瀑布及流水来譬喻阿赖耶识，以帮助我们对阿赖耶识的了解。此譬喻以阿赖耶识像瀑流之水，说它是‘断’吧，它却是‘不舍昼夜’的奔流；说它是‘常’呢？它却是‘逝者如斯夫’，后浪推前浪，前水逝去，后水续至。此外，它还有两种作用：一是漂泊，二是沉溺。此阿赖耶识，像瀑布或流水似的，它无始时来的烦恼业浪，生灭非常；相续非断，把三界有情，或漂泊到人天善趣，或沉溺到地狱饿鬼畜生三涂，使它们头出头没，而不能出离。再者，瀑布或流水，因风力吹击生起了层层波浪，然而它并不因此而中断其流动。这阿赖耶识也是这样，虽然因六尘缘影，现起了眼等六识的波浪，然而它并不因此而间断了它的因果相续。

    还有，像瀑布流水，漂著水上的草，水下的鱼，随流上下而不得舍离。这阿赖耶识也是这样，内而习气，外而触、受等法，也如鱼草一样，随著识浪的起伏，相续而转。以上这些譬喻，完全是显示这阿赖耶识的无始因果，不落于断常二边的意义。也就是说：这阿赖耶识的体性，从无始以来，就刹那刹那的在果生因灭，因减果生。刹那果生，所以非断；刹那因减，所以非常。这非断非常，就是缘起的正理。所以颂文说：‘恒转如瀑流’。

    论文三：过去未来，既非实有，非常可尔，非断如何？断岂得成缘起正理？过去、未来，若是实有，可许非断，如何非常？常亦不成缘起正理。岂斥它过，己义便成？若不摧邪，难以显正。前因灭位，后果即生，如秤两头，低昂时等；如是因果相续如流，何假去来，方成非断。

    讲解：小乘有部及正量部论师，反对唯识家‘非断非常，是缘起理’的正论，有人问难说：我们主张过去、未来实有体性，可以说未来的果生非断，过去的因灭非常。你们主张过去、未来既非实有，若说因灭非常，倒还可以，如何可说果生非断？难道说‘断’也可以成为缘起的正理吗？

    论主反问说：如果过去、未来是实有的话，可以说是未来非断；如何可说过去非常呢？你说我们的‘断’不是缘起正理，难道说你们的‘常’就是缘起正理吗？

    有部论师等反驳说：你们唯识家，怎么可以用破斥别人的过失，来成立自已的理论呢？论主答称：邪正不并立，若不摧邪，难以显正，所以要破斥你们的过失，来显示本宗的正义。正当前因灭时，后果即生，无间刹那，如以秤秤物，正当这头低垂的同时，那头就高昂起来了。这样因果相续，如瀑流水，已具足了非断非常的正义，何必要假藉过去、未来才能成立‘非断’？

    论文四：因现有位，后果未生，因是谁因？果现有时，前因已减，果是谁果？既无因果，谁离断常？若有因时已有后果，果既本有何待前因？因义既无果义宁有？无因无果岂离断常？因果义成依法作用，故所诘难非预我宗。体既本有用亦应然，所待因缘亦本有故；由是汝义，因果无定，应信大乘缘起正理。谓此正理深妙离言，因果等言皆假施设，观现在法有引后用，假立当果对说现因。观现在法有酬前相，假立曾因对说现果。假谓现识似彼相现。如是因果理趣显然，远离二边契会中道，诸有智者应顺修学。

    讲解：有部论师等再度辩称：若依你们‘果生因灭，非断非常’的说法，那么，现有因位的果，尚未生时，这个因，是谁的因呢？现有果位的因，已经灭了，这个果，又是谁的果呢？如此，有因无果，因亦非因；有果无因，果亦非果。既然因果都无，是谁离了断常，教你们在这里说非断非常呢？

    论主也再度反难：若依你们‘过去未来有体’的执著，则是现有因时，已经有了后果。果若本无，可待因生；今果既已本有，何须还待前因呢？这样，因义既然没有，果义那里还存在昵？没有因又没有果，怎能脱离断常呢？

    有部论师等辩称：过去、未来的因果，虽已有了法体，然而，因果意义的成立，是依法的作用，并非依于法体，所以你们的诘难与我宗无关。论主又驳他说：事物之体既然是本来就有，其作用也应当本来就有，即所待以起用的因缘，也应当是本有的；因为一切法的体用是没有差别的。因此，你们的执著，决定没有因果生灭的意义，所以你们应当信仰大乘的缘起正理。这大乘唯识的正理，深奥玄妙，到了‘离言绝相’的境地。至于前面有关因果等的言说，那不过是方便施设的假法而已。

    怎样假名施设呢？观察现法有引生当来之果的功用，即依此功用，假立当来之果，对此现法说名为因；观察现法的来源，有酬报前因之相，即依此相，假立一个曾有的因，对此现法说名为果。怎样叫做假？意谓依于现在识缘现法的时候，观其所从生，在识上变现一种过去非因似因，及现法非果似果的假相；观从其所生，在识上变现一种未来非果似果，及现法非因似因的假相。像这样假说因果，决不是心外实有因果。这样，因果的道理与义趣就明了，显然是远离断常二边，契合了非断非常的中道。因此，凡是有智慧的行者，都应当随顺修学这唯识的缘起正理。

    论文五：有余部说，虽无去来，而有因果恒相续义。谓现在法极迅速者，犹有初后生灭二时，生时酬因，灭时引果；时虽有二，而体是一。前因正灭，后果正生；体相虽殊，而俱是有。如是因果非假施设，然离断常又无前难。谁有智者舍此信余。

    讲解：有部论师等既遭破斥，另有大众、鸡胤等部，执实有现在因果之义，起而转救说：虽然没有过去、未来的法，却不无因果相续的意义。意谓现在的法变化极其迅速，仍有最初产生和后来毁灭二时，生的时候需要因，灭的时候引生果。时间虽然有两种，而本体却是一个。前边的因正在消灭的时后，后边的果正在产生，虽然法体与生灭二相是有差别的，然而都是现时而有。这样，因果并非虚假施设，却离断和常，又没有以前诸难。哪位有智之人，能舍此究竟胜义，而去信其他的不了义呢？

    论文六：彼有虚言，都无实义。何容一念而有二时？生灭相违宁同现在？灭若现在生应未来，有故名生，既是现在，无故名灭，宁非过去？灭若非无，生应非有；生既现有灭应现无。又二相违，如何体一？非苦乐等见有是事。生灭若一，时应无二，生灭若异，宁说体同？故生灭时俱现在有，同依一体理必不成。经部师等因果相续，理亦不成。彼不许有阿赖耶识能持种故。由此应信大乘所说：因果相续，缘起正理。

    讲解：论主对余师复破斥曰：你们这些说法，都是虚假的言词，没有实在的内容，怎能容许刹那一念之间，而有生灭二种时间呢？生、灭二法互相违逆，怎能同时现在呢？如果灭是现在，那么生应当是未来。因为前无今有称之为生，既是现在，那因无而名为灭的，岂不就是过去吗？假定灭不是无，那生就应当也不是有。既然生是现有，当然灭也是现无了，因为它们互相违逆，其体怎能同一呢？如苦乐不同一体，这是世间现见的事。生灭若是一体，就应当没有初后二时；生灭若是别异，又怎能说它是一体？因此，你们这生灭二法，俱现在有，同依一体的道理，必定不能成立。

    你们经部师等的主张，因果前灭后生，相续不断的道理，虽然也同大乘一样是胜义，但你们执著色心二法的功用就是种子，不承认有阿赖耶识摄持种子。所以这因果相续的道理也不能成立。因此，应当信奉大乘所说：‘种子生现行，现行熏种子’这样因果相续的缘起正理。


第八章　伏断位次门

    第八章　伏断位次门

    论文一：此识无始恒转如流，乃至何位当究竟舍？阿罗汉位方究竟舍。谓诸圣者断烦恼障究竟尽时，名阿罗汉。尔时此识烦恼粗重永远离故，说之为舍。此中所说阿罗汉者，通摄三乘无学果位。皆已永害烦恼贼故，应受世间妙供养故，永不复受分段生故。云何知然？决择分说：诸阿罗汉、独觉、如来皆不成就阿赖耶故。集论复说：若诸菩萨得菩提时，顿断烦恼及所知障，成阿罗汉及如来故。

    讲解：本章讲释‘阿罗汉位舍’的伏断位次门。有问曰：这无始时来，恒转如瀑布流水似的阿赖耶识，修行到何等果位才能究竟舍弃呢？答曰：要到阿罗汉位才能究竟舍弃。也就是说：三乘圣人，把烦恼障究竟断尽，这时的果位就叫做阿罗汉。到了阿罗汉位，阿赖耶识里的粗重烦恼，就永远断灭，此灭就名之为‘舍’。

    此处所称的阿罗汉，并非仅指声闻四果，而是把三乘无学果位通摄在内。无学，就是修学圆满，无可再学了。这无学位的阿罗汉，具有三义：一者杀贼──它们都已永远杀害了劫夺慧命的烦恼贼。二者应供──应受三界人天的上妙供养。三者无生──永远不再受分段生死的苦报。

    如何知道阿赖耶识三乘皆舍，阿罗汉名通摄三乘呢？因为《瑜伽论．决择分》里说：阿罗汉、独觉、如来，这三乘圣人，都不成就阿赖耶识，所以知这阿赖耶识是三乘皆舍。《杂集论》亦说：若诸菩萨，修行到金刚身后，得大菩提而成佛时，顿断烦恼、所知二障。约断烦恼障说，名阿罗汉；约断所知障说，名为如来。大乘菩萨，尚名阿罗汉，声闻、缘觉二乘更何待言？所以知道阿罗汉名，通摄三乘。（注：成就，为‘得’之一种。即已得、而现在相续不失之意。这是说一切有部的教义，然有部之论师亦有持异说者。俱舍论卷四载，‘成就’与‘获’均属于‘得’之一种。未得或已失而今得，称为获；已得而至今相续不失，则称为成就。得与成就之差别有‘未得而得名得，已得而得名成就’、‘初得而得名得，得已不断名成就’等七说。成就，就是继续称为阿赖耶识。不成就，即不再称为阿赖耶识。）

    论文二：若尔，菩萨烦恼种子未永断尽，非阿罗汉应皆成就阿赖耶识。何故即彼决择分说，不退菩萨，亦不成就阿赖耶识？彼说二乘无学果位，回心趣向大菩提者，必不退起烦恼障故，趣菩提故，即复转名不退菩萨。彼不成就阿赖耶识，即摄在此阿罗汉中，故彼论文不违此义。

    讲解：有外人问曰：若照你们唯识家说，把烦恼究竟断尽了，才能舍弃阿赖耶识，名阿罗汉。那么，不退菩萨的我爱执藏只是暂伏不起，尚未永远断尽，并不是三乘无学的阿罗汉，它们都应当成就阿赖耶识，为什么彼抉择分说：不退菩萨，也不成就阿赖耶呢？

    论主答：决择分说‘不退菩萨，不成就阿赖耶识’的话，并不是指直趣菩提的菩萨而言，而是说声闻、缘觉二乘，证了无学果位之后，更回心趣向于大菩提道，它们既然先已断了烦恼，又回小向大，必不会再退起烦恼，成就阿赖耶识，因其趣向菩提之故，也就由二乘无学转名为‘不退菩萨’了。抉择分所说那不成就阿赖耶识的不退菩萨，就是这里所说的阿罗汉。所以《瑜伽论》的文句，并不违背唯识论的意义。

    论文三：又不动地以上菩萨，一切烦恼永不行故；法驶流中任运转故，能诸行中起诸行故，刹那刹那转增进故，此位方名不退菩萨。然此菩萨虽未断尽异熟识中烦恼种子，而缘此识我见、爱等，不复执藏为自内我，由是永舍阿赖耶名，故说不成就阿赖耶识，此亦说彼名阿罗汉。

    讲解：护法论师认为：大乘十地，第八‘不动地’以上的菩萨，它们也舍弃了阿赖耶识之名，名为不退，所谓‘不动地前才舍藏’者是。因为它们具有四个条件：一者、一切烦恼种子，永远降伏而不起现行。二者、驾驶法筏，在生死流中，自由自在的任运而转。三者、能于六度万行的一切行中修一切行，不似七地以前，但以一切行庄严万行。四者无漏智慧，不为有漏所间断，刹那刹那在展转增进。因此，不动地以上菩萨，才能名为不退，而舍弃了阿赖耶名。

    不动地以上的菩萨，虽未究竟断尽异熟识里的烦恼种子，但当第七识的见分，缘第八识时的我见、我爱，已经不再执此藏识为自内之我了。因此，永远的舍弃了我爱执藏的名称。所以不退菩萨不成就阿赖耶识，也说它名叫阿罗汉。

    论文四：有义：初地以上菩萨，已证二空所显理故，巳得二种殊胜智故，已断分别二重障故，能一行中起诸行故。虽为利益起诸烦恼，而彼不作烦恼过失，故此亦名不退菩萨。然此菩萨虽未断尽俱生烦恼，而缘此识所有分别我见、爱等，不复执藏为自内我，由斯亦舍阿赖耶名，故说不成阿赖耶识，此亦说彼名阿罗汉。故集论中作如是说：十地菩萨虽未永断一切烦恼，然此烦恼犹如咒药，所伏诸毒，不起一切烦恼过失。一切地中如阿罗汉巳断烦恼，故亦说彼名阿罗汉。

    讲解：难陀论师认为，初地以上的菩萨，已证得我、法二空所显示之真理，也舍弃了阿赖耶识，名为不退。因为它们具有五个条件：一者已经证到了由我、法二空所显的真如。二者得到了‘正体’和‘后得’二种殊胜智慧。三者分别起的烦恼、所知二障都已断除。四者能于六波罗蜜的一行修集诸行。五者虽为方便利益有情，起诸烦恼，然而它并不作烦恼染污的过失。因此，初地以上菩萨，也可以名为‘不退’。

    这初地以上的不退菩萨，虽未把与生俱起的烦恼究竟断尽；然而缘第八识时，所有的分别我见和我爱，已经不再执此藏识为自内之我了。因此也舍弃了阿赖耶之名，所以说它不成就阿赖耶识，也说它名为阿罗汉。

    《杂集论》中说：‘从初地到十地的菩萨，虽只断了分别起烦恼，还没有把俱生起的烦恼永远断除，然而这俱生起烦恼，已为万行功德所降伏，好像被咒术和药力所降伏的毒蛇一样，不会再伤人了，因此不能再作起惑造业的过失了。这十地中的不退菩萨，和阿罗汉一样，都已断了烦恼，所以也说它们名阿罗汉。’

    论文五：彼说非理，七地已前，犹有俱生我见、爱等，执藏此识为自内我，如何已舍阿赖耶名？若彼分别我见、爱等，不复执藏说名为舍，则预流等诸有学位，亦应已舍阿赖耶名，许便违害诸论所说。

    讲解：论主破斥难陀等之说的非理，因为七地以前的菩萨，第七识的俱生我见和我爱，犹起现行，执此第八藏识为自内之我，如何能说已经舍了阿赖耶之名呢？若说七地以前的分别我见和我爱，不再执藏识为我，就说之为舍，那么小乘的预流果、一来果、不还果诸有学位，他们也都断了分别我执，难道说也舍弃了阿赖耶之名吗？然而圣教并没有这样说。若许他们也舍阿赖耶之名，便与经论所说相违。

    论文六：地上菩萨所起烦恼，皆由正知，不为过失，非预流等得有斯事，宁可以彼例此菩萨？彼六识中所起烦恼，虽由正知，不为过失，而第七识有漏心位，任运现行执藏此识，宁不与彼预流等同？由此故知彼说非理。然阿罗汉断此识中烦恼粗重究竟尽故，不复执藏阿赖耶识为自内我，由斯永失阿赖耶名，说之为舍，非舍一切第八识体。勿阿罗汉无识持种，尔时便入无余涅槃。

    讲解：难陀等师复自救曰：初地以上菩萨的烦恼，都是由于方便度生的正知而起，并没有染污惑业的过失。这不是小乘初果的预流、二果的一来、三果的不来所能做得到，如何拿它们来例同地上菩萨？

    论主再予反难曰：七地以前的地上菩萨，依前六识所起的粗重烦恼，虽由正知不为过失，而其第七末那识的有漏心位，那一类相续无间的微细烦恼，当不住还任运现行，执此藏识为我，岂不同那预流等的有学位是一样吗？因此你们所说并不合理。

    然而三乘无学的阿罗汉，究竟断尽了第八识里的粗重烦恼，不再以执藏的阿赖耶识为自内之我，从此舍掉了我爱执藏的阿赖耶名，这就叫做舍，并不是连能藏、所藏的第八识体一概都舍弃了。倘若把第八识体都舍弃了，于金刚心时，已无识持种，便应入无余涅槃，试问那有这样的阿罗汉？

    论文七：然第八识，虽诸有情皆悉成就，而随义别立种种名。谓或名心，由种种法薰习种子所积集故。或名阿陀那，执持种子及诸色根令不坏故。或名所知依，能与染、净所知诸法为依止故。或名种子识，能遍任持世、出世间诸种子故。此等诸名，通一切位。或名阿赖耶，摄藏一切杂染品法，令不失故，我见、爱等执藏以为自内我故。此名唯在异生有学，非无学位，不退菩萨有杂染法执藏义故。或名异熟识，能引生、死，善不善业，异熟果故。此名唯在异生二乘诸菩萨位，非如来地犹有异熟无记法故。或名无垢识，最极清净诸无漏法所依止故。此名唯在如来地有，菩萨、二乘及异生位持有漏种，可受熏习，未得善净第八识故。如契经说：如来无垢识，是净无漏界，解脱一切障，圆镜智相应。

    讲解：第八识是一切有情所成就的共法，但随其意义差别，建立以下七种异名：一者名心，由现行诸法熏习的种子都积集其中。二者名阿陀那，阿陀那意译为‘执持’，因为它能执持诸法种子及根身，使之不坏。三者名所知依，因为它能为所知的善、恶、无记三性作为依止。四者名种子识，因为它能够普遍任持世、出世间法的种子。以上四种异名，无论有漏无漏，若凡若圣，通统都有，所以说通一切位。

    五者名阿赖耶：因为它能够摄藏一切杂染品法，便之不失。又可以执藏我见、我爱等，被妄执为‘我’。阿赖耶识之名，只在凡夫和声闻、缘觉二乘有学位，不在无学位和不退菩萨，因为无学位和不退菩萨，都没有执藏杂染法的意义。六者名异熟识，因为它能牵引有情，在三界六道中生死轮回，受那由善恶业所感招的无记性果报。七者名无垢识：此识最极清净，为一切无漏法所依止，此名只在如来地有，因为菩萨和小乘的声闻、缘觉二乘及凡夫位，摄持有漏檀子，可以接受熏习，还没有证得善净的第八识。如《如来功德经》的偈子说：‘如来无垢识，是净无漏界，解脱一切障，圆镜智相应。’意思是如来的无垢识，是清净的无漏界，解脱了一切的烦恼障和所知障，与大圆镜智相应。

    论文八：阿赖耶名过失重故，最初舍故，此中偏说。异熟识体菩萨将得菩提时舍，声闻独觉入无余依涅槃时舍。无垢识体无有舍时，利乐有情无尽时故。心等通故，随义应说。

    讲解：阿赖耶的名称，过失最重，在三乘无学的阿罗汉位，就舍弃了藏识之名，所以颂文中说：‘阿罗汉位舍’。至于异熟识体，菩萨要到将得菩提的金刚心时，才能舍弃，所谓：‘金刚心生，异熟识灭’；声闻、独觉要到入无余依涅槃时舍。唯有无垢识体，则永无舍时，因为如来利乐有情的行愿是没有穷尽的。

    至于前面所说的：心、阿陀那、所知依、种子识，那是通于一切凡圣的。因为第八识的七种异名，有通一切凡圣，有三乘分位而舍，所以应各随其义而予以说明。


第九章　如何证明有第八阿赖耶识──五教证

    第九章　如何证明有第八阿赖耶识──五教证

    论文一：然第八识总有二位：一有漏位，无记性摄，唯与触等五法相应，但缘前说执、受、处境；二无漏位，唯善性摄，与二十一心所相应，谓遍行五、别境五、善十一、与一切心恒相应故。常乐证知所观境故，于所观境恒印持故，于曾受境恒明记故，世尊无有不定心故，于一切法常决择故，极净信等常相应故，无染污故，无散动故，此亦唯与舍受相应，任运恒时平等转故，以一切法为所缘境，镜智遍缘一切法故。

    讲解：此第八阿赖耶识，以三乘而谕，总略不过二位，即有漏位与无漏位。一者有漏位：为无记性的异熟所摄，唯与触、作意、受、想、思五法相应，但缘前述那执、受、处的种子、根身、器界三种境界。二者无漏位：就是功果圆满的如来地，这无漏位的第八识，异熟已空，唯是善性所摄，与五遍行、五别境、十一善心所相应。何以知其与遍行心所相应？因为触等五法，与一切心恒时相应，无漏心也不例外。何以与欲等五别境心所相应？因为佛常乐证知所观境相，就是欲。于所观境印持无疑，就是胜解。于曾习境明记不忘，就是念。没有不定的散心，就是定。于一切法常以智慧抉择，就是慧。因此，也与五别境心所相应。何以与十一善心所相应？因为如来至极清净，所以与信等十一善法相应。

    何以不与烦恼心所相应？因为佛无染污，所以不和贪等的根本烦恼六、随烦恼二十等染法相应。何以不和不定心所相应？因为如来身语，任运湛寂，性非散动，所以不和‘恶作’等的四法相应。

    这无漏位，也如本识因地一样，唯与苦乐俱非的舍受相应。因为佛智是任运恒时不变不动，不作分别的平等转故，所以唯与非苦非乐的舍受相应。至于缘境，则是十八界、有漏、无漏，无所不缘。因为大圆镜智，是遍缘一切法故。

    论文二：云何应知此第八识，离眼等识有别自体？圣教正理，为定量故。谓有大乘阿毗达摩契经中说：无始时来界，一切法等依；由此有诸趣，及涅槃证得。此第八识自性微细，故以作用而显示之。颂中初半显第八识为因缘用，后半显与流转还减作依持用。

    讲解：本文在第八章以前，是以八段十门解释本识。而本章节论文，是总明本识；此下是引五教十理，来证明实有本识。外人问曰：你们唯识家，怎样知道这第八识，在离开了眼等六识之外，别有它的自体呢？论主答：这不是世间的现量之境，而要以圣言的教典，及比知的正理二量，来作决定性的权衡而知。

    五教证的第一证，是《大乘阿毗达磨经》的颂文：‘无始时来界，一切法等依，由此有诸趣，及涅槃证得。’原来有情第八识里的有漏、无漏种子，为一切染净现行法所依止，因比才有流转六趣染法的凡夫，及证得涅槃净法的圣人。

    论识必当显体，不应约义。但这第八识的体性细微难显，所以‘以用显体’。这四句颂文的前二句，是显示第八识能给现法作因缘用；后二句，是显示与流转生死，及还灭涅槃作依持用。

    论文三：界是因义，即种子识；无始时来展转相续，亲生诸法，故名为因。依是缘义，即执持识；无始时来与一切法等为依止，故名为缘。谓能执持诸种子故，与现行法为所依故，即变为彼及为彼依。变为彼者，谓变为器及有根身。为彼依者，谓与转识作所依止。以能执受五色根故，眼等五识依之而转。又与末那为依止故，第六意识依之而转，末那、意识转识摄故，如眼等识依俱有根，第八理应是识性故，亦以第七为俱有依。是谓此识为因缘用。

    讲解：颂文‘无始时来界’，‘界’是‘因’义，指的是‘种子识’。它无始时来，种生现、现熏种，展转相续，刹那不断的生起一切现行果法，所以名之为‘因’。次句‘一切法等依’，这个‘依’字是‘缘’的意思，即执持识。它无始时来，为一切现行法所依止，所以名之为‘缘’。这个第八识，能执持诸法种子，种子生起现行，又为一切现行法所依止。‘即变为彼，及为彼依’句，变为彼就是由种子识变现为器世间，及有根身。‘为彼依’，意思就是第八识给七转识作为依止。如何给转识作依止？因为第八识能执受眼、耳、鼻、舌、身五种色根，所以眼等五识才得依五种色根而转起。又因为能给第七末那作依止故，所以第六意识，才得依这末那为心根而转起。这第七末那及第六意识，因为是属于转识之故，所以也同眼等五识一样的依俱有根。第八既是识的体性，按道理也应当以第七末那为俱有依。（注：诸识转生的同时，必有不可或缺的根，为所依托，就叫做俱有依）。这就是第八识的‘因缘用’。

    论文四：由此有者，由有此识；有诸趣者，有善恶趣，谓由有此第八识故，执持一切顺流转法，令诸有情流转生死。虽惑业生皆是流转，而趣是果，胜故偏说。或诸趣言通能、所趣，诸趣资具亦得趣名。诸惑业生皆依此识，是与流转作依持用。及涅槃证得者，由有此识，故有涅槃证得。谓由有此第八识故，执持一切顺还减法，令修行者证得涅槃。此中但说能证得道，涅槃不依此识有故。或此但说所证涅槃，是修行者正所求故。或此双说，涅槃与道俱是还减品类摄故。谓涅槃言显所证灭，后证得言显能得道，由能断道断所断惑，究竟尽位证得涅槃。能、所证断皆依此识，是与还灭作依持用。

    讲解：这是解释第三句颂文‘由此有诸趣’句。由此有，就是由于有此现行法所依的第八识。‘有诸趣’，就是有三界人、天、地狱、饿鬼、畜生诸趣。也就是说：由于有此第八识之故，所以才能执持一切‘顺流转’的染法种子，生起有漏现行，令一切有情，都流转生死。虽然依惑造业，由业引生集苦的一切有漏，都叫做流转；然而，五趣是生死苦果，在流转道中，最为殊胜，所以才偏说诸趣为流转。或者，诸趣这个名字，是通称能趣的惑业，和所趣的苦果，连这诸趣所须的资具──器世间，也得随著所趣而名之为趣。一切惑、业、生的有漏所摄法，都是依托这第八识才得成就。所以第八识为有情流转的依持用。

    ‘及涅槃证得’者，由于有此第八识故，所以才有涅槃证得。因为此第八识执持一切‘顺还灭’的净法种子，生起无漏现行，令修道谛的行人，能够证得灭谛涅槃。这又有下列三家不同的解释：第一家说，此处所说不过是能证的道谛，而不是所证的涅槃。因为清净寂灭的涅槃法，不是亲依这第八识而有的。第二家说，此处所说的是所证的涅槃，而不是能证的道谛。因为涅槃即修行人正所欲求的觉果。第三家说，此处是双说涅槃和道谛。因为，不但道是还，涅槃是灭；而且道和涅槃，都可以说之为还、为灭，所以它们都是属于还灭品类。要知道这一句颂里，前面的‘涅槃’二字，是显示所证的灭谛；后面的‘证得’二字，是显示能证的道谛。以这能断的道谛，去断那所断的惑业，到了究竟断尽的地位，便证得了所证的减谛──涅槃。无论能断的道、所断的惑、能证的道、所证的灭，都得依托这第八识才行。所以这第八识，是为这还灭法作依持用。

    论文五：又此颂中初句显示，此识自性无始恒有，后三显与杂染清净二法总别为所依止。杂染法者谓苦、集谛，即所能趣生及业、惑。清净法者谓灭、道谛，即所、能证涅槃及道。彼二皆依此识而有。依转识等理不成故。或复初句显此识体无始相续，后三显与三种自性为所依止，谓依它起、遍计所执、圆成实性，如次应知。今此颂中诸所说义，离第八识皆不得有。

    讲解：再者，此颂首句‘无始时来界’，是显示这第八识体是无始恒有。后三句是显示这第八识给杂染、清净二法作总别的依止。第二句‘一切法等依’，是显示为染、净二法的总所依止。第三句‘由此有诸趣’，是显示为染法的别所依止。第四句‘及涅槃证得’，是显示为净法的别所依止。杂染法就是苦、集二谛，也就是所趣的生死，及能趣的惑业。清净法就是灭、道二谛，也就是所证的涅槃及能证的道谛。这杂染和清净二法，都是依第八识而有的。若说是依七转识而有，则不应理。

    还有一种解释，说这四句颂的第一句，是显示这第八识体无始时来相续无间。后三句是显示这第八识与三种自性为所依止：一、依它起自性，就是第二句‘一切法等依’。因为现行的有、无漏法，都是依种子因缘而起的。二、遍计所执自性，就是第三句‘由此有诸趣’。因为诸趣都是由遍计所执的我、法而有的。三、圆成实自性，就是第四句’及涅槃证得’，因为无漏净法，就是圆成实性。所以说，‘后三显与三种自性为所依止，如次应知’。

    论文六：即彼经中复作是说：‘由摄藏诸法，一切种子识，故名阿赖耶，胜者我开示’。由此本识具诸种子，故能摄藏诸杂染法，依斯建立阿赖耶名，非如胜性转为大等。种子与果体非一故，能依所依俱生灭故。与杂染法互相摄藏，亦为有情执藏为我，故说此识名阿赖耶。已入见道诸菩萨众，得真现观，名为胜者。彼能证解阿赖耶识，故我世尊正为开示。或诸菩萨皆名胜者。虽见道前未能证解阿赖耶识，而能信解求彼转依，故亦为说，非诸转识，有如是义。

    讲解：这是五教证的第二证，《阿毗达摩经》中四句颂文：‘由摄藏诸法，一切种子识，故名阿赖耶，胜者我开示’。意思是：由于第八识能摄藏诸法一切种子，所以名叫阿赖耶。除非是入地菩萨的胜者，佛才给予开示。此识能够摄持所含藏的杂染诸法，依此意而建立阿赖耶名。并不像数论外道所说的由冥谛而生觉，由觉而生我心、五唯、五大、十一根、而归为神我所受用的二十五谛一样。因为本识种子与现行果法，非一非异，能依的诸法与所依的识体，都是生灭非常，所以不同于数论外道所说。

    第八识‘与杂染法，互相摄藏’，就是能藏与所藏。‘亦为有情执藏为我’，就是我爱执藏，有此三义，所以叫做阿赖耶识。已入初地见道位的菩萨，得到了由二空所显的真理现观，名为胜者。因为它们能够证知悟解阿赖耶识，不起分别我执，所以世尊才给它们正式开示，使达究竟后地。或者说，各种菩萨都称为胜者。它们虽在见道以前，尚未证解阿赖耶识，但却对阿赖耶识有了不疑的信解，希望转所依的二障种子为无漏真智，而得涅槃妙果，所以世尊也一样给它们说阿赖耶。以上所说：‘具诸种子、摄藏诸法，除却第八阿赖耶识外，并非七转识有这种作用。

    论文七：解深密经亦作是说：阿陀那识甚深细，一切种子如瀑流，我于凡愚不开演，恐彼分别执为我。以能执持诸法种子，及能执受色根依处，亦能执取结生相续，故说此识名阿陀那。无性有情不能穷底，故说甚深，趣寂种性不能通达，故名甚细。是一切法真实种子，缘击便生转识波浪，恒无间断，犹如瀑流。凡即无性，愚即趣寂，恐彼于此起分别执，堕诸恶趣，障生圣道，故我世尊不为开演。唯第八识有如是相。

    讲解：这是五教证的第三证。《解深密经》也有四句颂曰：‘阿陀那识甚深细，一切种子如瀑流，我于凡愚不开演，恐彼分别执为我’。阿陀那是第八识的异名，其相甚深，又甚微细，它所摄持的一切种子，刹那生灭，犹如瀑流，佛对凡夫、二乘向不轻易开演，恐怕它们分别执著为自内之我。

    阿陀那译为执持，具有以下三义：一者能执持有、无漏法的一切种子令不失坏。二者能执受色根及根所依处的身，令生觉受。三者能执取‘中有’去投胎结生，令本、中、后三有生死相续，所以第八识又名阿陀那。何以说‘阿陀那识甚深细’？五性中的无性有情，它们没有三乘无漏种子，不能穷究阿陀那识的本源底蕴，所以说是‘甚深’。趣寂种性的愚法二乘，它们虽有无漏种子，而趣向于灰心灭智的空寂愚法，不能通达实证阿陀那识，所以说是‘甚细’。阿陀那识，是一切法的真实种子，一遇到外缘击发，便会生起七转识的现行波浪，生灭相续，恒无间断，有如瀑布长流一般。凡是无性有情（注：五种性之一，又称无种性。），愚是趣寂二乘──声闻种性和缘觉种性。恐怕它们于此阿陀那识分别我、法二执，使之起惑造业，堕诸恶趣，所以我佛世尊，不给它们开演此识。

    论文八：入楞伽经亦作是说：如海遇风缘，起种种波浪，现前作用转，无有间断时。藏识海亦然，境等风所击，恒起诸识浪，现前作用转。眼等诸识无如大海恒相续转起诸识浪，故知别有第八识性。此等无量大乘经中，皆别说有此第八识。诸大乘经皆顺无我，违数取趣，弃背流转，趣向还灭，赞佛、法、僧，毁诸外道表蕴等法，遮胜性等。乐大乘者许能显示无颠倒理，契经摄故，如增一等，至教量摄。

    讲解：这是五教证的第四证。《入楞伽经》也这样说：‘如海遇风缘，起种种波浪，现前作用转，无有间断时。藏识海亦然，境等风所击，恒起诸识浪，现前作用转’。意思是说藏识也如大海之水一样，一遇风力鼓荡的外缘，便兴起了激湍的七识波浪，相续而转，无间断时。但是间断的眼等转识，没有像大海那样‘恒相续转，起诸识浪’的作用。因此，我们知道除眼等转识之外，别有一个第八识的存在。

    无量大乘经中，都别说有此第八识，诸大乘经皆顺应人无我之理，而违背数取趣──有情的我执，背弃流转生死的苦、集二谛，趣向还减的涅槃。赞扬佛、法、僧三宝做的利生功德，摧毁外道的邪说邪见，表显五蕴、十二处、十八界的缘起法，以简遮数论外道的‘二十五谛’，及胜论外道的‘六句义’。这些都和小乘的缘生无我之理一样。所以一切有情，乐行大乘者，皆称许大乘经典，能显示无颠倒的正理。这些经典，和小乘的《增一阿含经》等一样，同样的为佛所说，为至教所摄。

    论文九：又圣慈氏，以七种因，证大乘经真是佛说：一先不记故：若大乘经佛灭度后有余为坏正法故说，何故世尊非如当起诸可怖事先预记别？二本俱行故：大、小乘教，本来俱行，宁知大乘独非佛说？三非余境故：大乘所说广大甚深，非外道等思量境界。彼经论中曾所未说，设为彼说亦不信受，故大乘经非非佛说。四应极成故：若谓大乘是余佛说，非今佛语，则大乘教是佛所说，其理极成。五有无有故：若有大乘，即应信此诸大乘教是佛所说，离此大乘不可得故。若无大乘，声闻乘教亦应非有，以离大乘决定无有得成佛义，谁出于世说声闻乘？故声闻乘是佛所说非大乘教，不应正理。六能对治故：依大乘经勤修行者，皆能引得无分别智，能正对治一切烦恼，故应信此是佛所说。七义异文故：大乘所说义趣甚深，不可随文而取其义，便生诽谤谓非佛说。是故大乘真是佛说。如庄严论颂此义言：先不记俱行，非余所行境，极成有无有，对治异文故。

    讲解：前面五教证所引诸颂，是引自佛说的大乘经典，证明六识之外别有第八识的存在。今更引慈氏弥勒菩萨所造的《庄严论》中，有七种理由证实大乘真是佛说。理由是：

    一、先不记故：假使大乘经典，是佛灭度后有人为破坏正法，假托佛说所伪造者，那么佛在未灭度前，何不就像《正法灭经》所说：‘瞻波罗国城邑，有诸比丘灭我正法’似的，预先告知弟子：我灭度后，有人伪造大乘，破坏正法呢？佛既没有预为告知，可知大乘确是佛说无疑。

    二、本俱行故：大乘小乘，有如人的二足，车之双轮，同时俱行，当然都是佛说，怎能说小乘是佛说，大乘不是佛说呢？

    三、非余境故：大乘教理，广大甚深，决不是外道和小乘的思量境界。因此，在它们的经论中，不曾说过大乘的教理，就是说给他们听，他们亦不能信解受持，所以大乘经并非不是佛说。

    四、应极成故：如果你们以为大乘是古佛或他方佛所说，不是今佛释迦所说，如此，不论是那一位佛所说，则大乘是佛说，应是大小乘教所共许的‘至极成就’了。

    五、有无有故：如果你们不承认大乘经典，那就无话可说；若承认有大乘经，就应当相信大乘经真是佛说。因为离开佛说之外，别无能诠大乘妙理的教法了。假使没有大乘教，那声闻教也应当没有，因为离开了大乘，就没有修六度万行的菩萨，得证佛果。如果没有佛，是谁出世说声闻乘，教众生断烦恼了生死呢？所以声闻乘是佛所说，故应信大乘是佛所说。

    六、能对治故：依照大乘经勤修六波罗蜜，都能引得亲契真如的无分别智，对治贪、嗔、痴等一切烦恼。故应相信此大乘教是佛所说。

    七、义异文故：大乘所说的意趣至极深妙，往往义与文异，意在言外，不可随文取义，执指为月，便诽谤大乘非佛所说。

    以上七种理由，包括在《庄严论》的一首颂文中：‘先不记、俱行，非余所行境，极成、有无有，对治、异文故。’

    论文十：余部经中亦密意说，阿赖耶识有别自性。谓大众部阿笈摩中，密意说此名根本识。是眼识等所依止故。譬如树根是茎等本，非眼等识，有如是义。上座部经，分别论者俱密意说此名有分识。有谓三有，分是因义，惟此恒遍为三有因。化地部说此名穷生死蕴，离第八识，无别蕴法穷生死际无间断时。谓无色界诸色间断，无想天等余心等灭，不相应行，离色、心等无别自体，已极成故。唯此识名穷生死蕴。

    讲解：为证明有第八阿赖耶识，前面已经引大乘三经的四首偈子，现在更引小乘四经共为一教，也就是所引教证的第五证。此证理由是：不但大乘说有第八阿赖耶识，就是小乘一些部派的经论中，也以深密的微意，说离开六转识外，别有阿赖耶识的自体。像大众部阿含经中，密意说这第八识名‘根本识’。因为它是眼、耳、鼻、舌、身、意六识所依止故，这第八识譬如树根一样，是茎、干、枝、叶、花、果的根本。而眼等六识则没有这种意义。

    上座部的经和分别说部的论中，俱密意说此名‘有分识’。有是三有，就是欲界、色界、无色三界。分是‘因’义，有分识是三界之因。前六识非恒非遍，所以不是有分识。唯有这第八阿赖耶识，是恒常周遍于一切时处，而为三界有情的生死之因。

    化地部说此第八识名‘穷生死蕴’，除阿赖耶识外，没有它识能随顺生死，永无间断。在无色界各种色法间断了，无想天的有情前六识心都伏灭了，不相应行法离开了色、心二法别无自体，这是大、小乘教都承认的。所以唯有这遍于三界九地的阿赖耶识，可称之为‘穷生死蕴’。

    论文十一：说一切有部增一经中，亦密意说此名阿赖耶，谓爱阿赖耶、乐阿赖耶、欣阿赖耶、喜阿赖耶。谓阿赖耶识是贪总别三世境故，立此四名。有情执为真自内我，乃至未断恒生爱著，故阿赖耶识，是真爱著处，不应执余五取蕴等，谓生一向苦受处者，于余五取蕴不生爱著。被恒厌逆余五取蕴，念我何时，当舍此命、此众同分、此苦身心，令我自在受快乐故。

    讲解：说一切有部的《增一阿含经》，也密意说此第八识称为阿赖耶，更立出爱、乐、欣、喜四阿赖耶的名称。这四个阿赖耶名，是依于贪著三世总别之境而立的。有情众生妄执阿赖耶为真实自内之我，在未断这种妄执之前永生爱著，所以阿赖耶识是真正的爱著之处。不应当妄执其余五蕴等为真爱著处，在三恶趣受苦的众生们，对于五蕴不生爱著，他们往往厌恶五取蕴，总想我什么时能舍弃此五取蕴，舍除这种众同分，舍除这种受苦的身心，令我得到自在快乐。

    论文十二：五欲亦非真爱著处。谓离欲者，于五妙欲，虽不贪著，而爱我故。乐受亦非真爱著处。谓离第三静虑染者，虽厌乐受，而爱我故。身见亦非真爱著处。谓非无学，信无我者，虽于身见不生贪著，而于内我，犹生爱故。转识等亦非真爱著虚。谓非无学，求灭心者，虽厌转识等，而爱我故。色身亦非真爱著处，离色染者，虽厌色身而爱我故。不相应行，离色心等，无别自体，是故亦非真爱著处。异生有学，起我爱时，虽于余蕴，有爱非爱，而于此识我爱定生。故唯此是真爱著处。由是彼说阿赖耶名，定唯显此阿赖耶识。

    讲解：五欲也不是有情的真爱著处，因为声闻四果中的阿那含，它们已经断除了欲界的贪欲，于色界微妙的五欲尘境不起爱著，然而对于阿赖耶识的自内之我，仍旧爱著不舍。乐受也不是有情的爱著处，因为离了三禅天的天人，它们已到舍念清净的四禅，已没有乐受可言，然而还有舍不得我爱执藏的阿赖耶识。身见也不是有情的真爱著处，因为除了无学位的阿罗汉外，其余有学位的初、二、三果，它们于无我之理虽能够信解，不起身见，然而对于阿赖耶识的自内之我，还照样执著。转识等也不是有情的真爱著处，因为除无学位外，其余求灭尽定，及无想定等的有学、凡夫，它们虽已厌弃了七转识及心所有法，然而犹有第八阿赖耶识的我爱执藏。色身也不是有情的真爱著处。因为生到无色界的人，已离色染，厌离色身，而仍然以阿赖耶识自内之我为我爱执藏。不相应行也不是有情的真爱著处，因为它们离了色、心等法就没有自体，所以不是其真爱著处，仍以阿赖耶识自内之我为我爱执藏。

    此第八阿赖耶识，非到无学位不能究竟断除，所以当异生、有学他们起我爱时，虽于这五取蕴等的七种异执，或爱或不爱，但对于阿赖耶识的我爱是决无不生之理。所以，唯有这阿赖耶识才是有情的真爱著处。因此增一阿含所说的阿赖耶之名，决定是显示这真爱著处的阿赖耶识。


第十章　如何证明有第八阿赖耶识──十理证

    第十章　如何证明有第八阿赖耶识──十理证

    论文一：已引圣教，当显正理。谓契经说，杂染、清净诸法种子之所集起，故名为心。若无此识，彼持种心不应有故。谓诸转识在灭定等有间断故。根、境、作意、善等类别易脱起故，如电光等不坚住故，非可熏习不能持种，非染净种所集起心。此识一类恒无间断。如苣胜等坚住可熏，契当彼经所说心义。若不许有能持种心，非但违经亦违正理。谓诸所起染、净品法，无所熏故，不熏成种，则应所起唐捐其功。染净起时既无因种，应同外道执自然生。

    讲解：为证明有此第八阿赖识，前面已引五教为证，此下更引十理为证。佛经上说，由于杂染、清净种子之所集起，所以称为心。倘若没有这第八阿赖耶识，那持种的心就不应当有。因为七转识到灭尽定和无想定位，都会间断。至于前六识所依的六根，所缘的六境，及作意心所，和善、恶、无记三性，都是常常转易，起不俱时，容易脱漏。有如光、声等性不坚住，不能受熏，不能持种。因此它们都不是染、净种子所集起的。唯有这第八识，性唯无记、舍受，前后一类，永无间断，有如香花熏习苣胜（注：苣胜为印度的胡麻），可以受熏持种，契合了经上所说‘心’的意义。

    倘若不许有能持种的第八识心，不但违背了经义，而且也违背正理。何以故呢，因为所起能熏的染净品法，既没有所熏的对象，便不能熏成种子，既不能熏成种子，则其所起能熏的染、净功果，生死涅槃，岂不都没有作用了吗？如此，染、净起时既无种子为因，那就和无因外道一样，一切法都是自然而生了。

    论文二：色不相应非心性故，如声光等，理非染、净内法所熏，岂能持种？又彼离识无实自性，宁可执为内种依止？转识相应诸心所法，如识间断易脱起故，不自在故，非心性故，不能持种，亦不受熏，故持种心理应别有。

    讲解：色法和不相应行法，并非心性，好像音、光一样，理非染、净，不可受熏，不能持种。再者，这色法和不相应行法，它们离识之外没有实在自性，怎么能为内种所依止呢？与转识相应的心所有法，它们和相应的心王一样会间断，性不自在，所以不能持种，也不能受熏。因此除转识及相应心所法外，依理而论，别有一个第八识的持种心。

    论文三：有说六识无始时来，依根、境等前后分位，事虽转变，而类无别，是所熏习能持种子，由斯染、净因果皆成，何要执有第八识性？

    彼言无义，所以者何？执类是实，则同外道，许类是假，便无胜用，应不能持内法实种。又执识类何性所摄？若是善、恶应不受熏，许有记故，犹如择灭。若是无记，善恶心时，无无记心，此类应断，非事善、恶，类可无记。别类必同别事性故。又无心位此类定无，既有间断，性非坚住，如何可执持种受熏？又阿罗汉或异生心，识类同故，应为诸染无漏法熏，许便有失。又眼等根或所余法，与眼等识根法类同，应互相熏，然汝不许，故不应执识类受熏。又六识身若事若类前后二念既不俱有，如隔念者非互相熏，能熏、所熏必俱时故。执唯六识俱时转者，由前理趣既非所熏，故彼亦无能持种义。

    讲解：小乘经部师称，前六识从无始以来，依六根、六境、作意、三性等而有，在前后分位上虽有转变，而其识类前后并无差别。因此可以受熏，也能持种，染、净的因果都可以成立，何必一定要有一个受熏持种的第八识呢？

    论主驳曰，这种言论毫无意义，一者你们所执著的识类，是实是假？若执后念识类是有实体，那便同于外道。若许后念识类是假，那便没有殊胜的功用，就不能执持这真实的内法种子。二者，你们所执的识类，在三性中是属于那一性呢？若是属于善性或恶性，那就不能受熏。不但善和恶不能互为能熏与所熏，因为大家共许善、恶是属于有记之故。好像‘择灭无为’的无漏善，它不能再受善、染诸法的熏习。如果是属于无记，起善、恶心起时无记心就间断，如何能够受熏？也不可执著事是善、恶，类可无记。因为分别事的识类，必定与它所分别的事是同属一性。三者，当五位无心位时，这识类决定没有。像这样既有间断体性又不坚住的识类，如何可以持种受熏呢？

    又有师别破曰：若阿罗汉和异生之心，它们的识类若是相同，则阿罗汉便能为染法所熏，异生便能受无漏法所熏，若许此说，便有过失。再者，眼等六根，是识所依的根类；色等六境，是识所变的法类。如此根、法类同，就应当能够互相受熏，然而你们小乘不许，既不许根类和法类能够受熏，就不应当执著识类能受熏。再者，六识身若缘前后事，这前后二念非同时俱有，则必有间隔，有间隔者怎能互相受熏？因为所熏的识类必须是同时俱有才行。

    不信有能受熏持种的第八识，而执著有俱时而转的前六识者，由前面破识类受熏的道理予以例破。纵使六识俱时的说法能移成立，然而它既非所熏，当然也没有持种的意义了。

    论文四：有执色心自类无间，前为后种，因果义立，故先所说为证不成。彼执非理，无熏习故。谓彼自类既无熏习，如何可执前为后种？又间断者应不更生，二乘无学应无后蕴，死位色、心为后种故。亦不应执色、心展转互为种生。转识色等非所熏习，前已说故。

    讲解：有小乘师，执著于色与色为自类，心与心为自类，前色生后色，前心生后心，这样自类无间的前为后因，后为前果，建立了因果的意义。因此，所说的别有第八阿赖识不能成立。

    论主反驳说，这种主张不合理，因为没有熏习的缘故。既然色、心自类不能熏习，怎能说前念有后念种子？假定前念色、心能为后念种子的话，那么生在无色界时色法已断，生无想天时心法不起。既已间断，后来再堕落下界，就不能再生色心了。再者，二乘无学，他们也应当没有断尽烦恼的最后心，当然也不能入无余涅槃不受后有。因为你们说前念的死位色、心能为后因，后后应同前前，他如何能断尽烦恼，入无余涅槃，不受后有呢？

    也不可执著于色中有心的种子，后当生心；心中也有色的种子，后当生色，如是展转互为种生。当知，转识间断，色根非心，他们都不是所熏习的东西，如何能为诸法种子呢？

    论文五：有说三世诸法皆有，因果感赴无不皆成，何劳执有能持种识？然经说心为种子者，起染、净法势用强故。彼说非理！过去、未来非常非现，如空华等，非实有故。又无作用不可执为因缘性故。若无能持染、净种识，一切因果皆不得成。

    讲解：小乘有部师说：过去、现在、未来三世诸法都是实有，因能感果，果能赴因，因果感赴，无不皆成，何必另立执持种子的第八识体呢？

    论主反驳说，佛经上说阿赖耶之心能够摄持种子，是因为它生起染、净之法势用强盛。有部之说非理，因为过去法已灭，未来法未生，既非常无间断，又非现量所得，好像空华没有实体。既无实体，当然没有感果的作用，怎可执著它有种子的因缘性呢？因此，如果没有一个执持染、净法种的阿赖耶识，一切因果都不能成立。

    论文六：有执大乘遣相空理为究竟者，依似此量拨无此识及一切法，彼特违害前所引经，知断证修，染、净因果皆执非实，成大邪见。外遣毁谤染、净因果，亦不谓全无，但执非实故。若一切法皆非实有，菩萨不应为舍生死，精勤修集菩提资粮。谁有智者为除幻敌，求石女儿用作军旅？故应信有能持种心，依之建立染、净因果。彼心即是此第八识。

    讲解：清辩一系的无相大乘，以无相之空理为究竟，依据似是而非的比量，来否定阿赖耶识及一切染、净因果等法，这种论调，违背了我们前面所引证的经义。例如知苦、断集的染法因果；证灭、修道的净法因果，它一概都执为非实，这岂不是成为外道的大邪见？因为外道毁谤染、净因果，并非说完全没有，但执著于染因不能感恶果，净因不能感善果，染、净因果，没有实法而已。

    假使一切法都非实有，菩萨就不应起大悲舍生死，精勤修集菩提资粮。生死菩提既非实有，那位有智慧的人，肯为除灭虚幻之敌，而以石女之儿用作军旅呢？所以应当相信有一个能够执持种子的心，依此心建立染净因果。这个心就是阿赖耶识。

    论文七：又契经说：有异熟心，善、恶业感，若无此识，彼异熟心，不应有故。谓眼等识有间断故，非一切时是业果故，如电光等非异熟心。异熟不应断已更续，彼命根等无斯事故。眼等六识业所感者，犹如声等非恒续故，是异熟生，非真异熟。定应许有真异熟心，酬牵引业遍而无断，变为身器作有情依，身器离心理非有故。不相应法无实体故，诸转识等非恒有故，若无此心谁变身器？复以何法恒立有情。

    又在定中或不在定，有别思虑无思虑时，理有众多身受生起。此若无者，不应后时身有怡适或复劳损。若不恒有真异熟心，彼位如何有此身受？非佛起余善心等位，必应现起真异热心，如许起彼时非佛有情故。由是恒有真异熟心。彼心即是此第八识。

    讲解：这是所引的第二理证。契经上说，有异熟心，是前世善恶业因，感得今世的异熟总报果。假使没有这第八识，那异熟心也不应当有。因为眼等六识有时间断，并非一切时都可做业果，如石火电光一样，所以不是异熟心。异熟心不应当断了又续，因为命根和五根等的异熟是相续不断，断即不续，没有断了又续的情形。眼等六识，由业所感，并非永恒相续，所以是异熟生，并不是真异熟。我们要承认有一个真正的异熟心，它能够酬牵业因，引生报果，普遍于三界九地、五趣、四生，不间断的变现为根身器界，作为有情的依止。这根身器界，离开了异熟心是不存在的。不相应行法没有实体，六转识又非恒有，假定没有这异熟心，谁变根身器界，又凭什么恒立有情？

    又如禅师坐禅，若在定中或不在定中，或有思虑或无思虑，理应有很多不同的身受生起。如果没有第八识，出定后其身就不会有禅悦的怡适、或禅病的劳损。如果没有恒遍的真异熟心在定中领纳，它如何会有这身受的感觉。

    除佛以外的菩萨、二乘、及凡夫众生，所起的善、恶、无记心位，必定现起真异熟心，因为这九法界的众生，都不是佛所示现的有情。由于以上所说之理，故有情必定恒有真异熟心，此真异熟心就是第八阿赖耶识。

    论文八：又契经说：有情流转五趣、四生，若无此识，彼趣生体不应有故。谓要有实有、恒、遍、无杂，彼法可立正实趣、生。非异熟法趣、生杂乱。住此起余趣、生法故。诸异熟色及五识中业所感者，不遍趣、生，无色界中全无彼故。诸生得善及意识中业所感者，虽遍趣、生，起无杂乱，而不恒有。不相应行无实自体，皆不可立正实趣、生。

    唯异熟心及彼心所，实、恒、遍、无杂，是正实趣、生。此心若无，生无色界起善等位，应非趣、生。设许趣、生摄诸有漏，生无色界起无漏心应非趣、生。便违正理。勿有前过及有此失，故异熟法是正实趣、生。由是如来非趣、生摄，佛无异熟无记法故。亦非界摄，非有漏故，世尊已舍苦、集谛故。诸戏论种已永断故。正实趣、生既唯异熟心及心所，彼心、心所离第八识理不得成。故知别有此第八识。

    讲解：这是所引的第三理证。佛经上说：有情流转于五趣、四生，如果没有这第八真异熟识，五趣四生之体就不应当有。必须具备实有、恒续、周遍、无杂四个条件，那正实的趣、生法才可以建立。即一者要有实体，假法不能称为趣、生，因为趣、生实有，是业所感。二者要恒续，即无间断法方称趣、生之体，一期之中要恒续。三者周遍，通三界九地。四者无杂，意谓生此趣此生方起此法，名此趣此生。不然，将有下列诸种过失：一者，如果不具以上四义，那五趣四生之体便会杂乱。例如住在天趣的有情，而生起其余人、畜等趣的果法；住在卵生的有情，而生起其余胎、湿等生的果法，这五趣四生之体，不是就杂乱得不成其为趣、生了吗？二者，各种诸异熟色（即色法中的五根五境十处，除去声尘的九处），和前五识中业所召感的果，即异熟所生的苦、乐、舍三受，都不是周遍五趣、四生之法。天趣化生的无色界，完全没有各种异熟色、和前五识中业所召感的果。三者，由前世修行感得今世与生俱起的一切善法，及第六识业因所感的别报果，虽能周遍于五趣四生，起无杂乱，但非恒有，在五无心位时则又间断。四者，不相应行法不与色、心相应，因其没有自体，不能建立为正实趣、生的总报果。

    唯有真异熟心及其心所，具备了实有、恒常、周遍、无杂这四个条件，是正实的五趣、四生。如果没有这真异熟的无记心，那生到无色界的有情，生起善心位时，应当是没有五趣、四生的总报体。如果无色界的有情，它们所起的善法，是属于五趣四生所摄的三界有漏，应当有报体的话，那么二乘圣者的阿那含，生‘非想处’起‘无所有处’的无漏善法，就应当不是趣、生。假定真的如此，便违背了三界有情无一不是五趣所生的正理。要想避免前述过失，那就应以真异熟识为正确的五趣四生。

    由此可见，如来不属于趣、生所摄，因为佛没有异熟无记之法。也不是属于‘界’摄，因为佛不是有漏法，佛已舍去苦、集二谛一切有漏的戏论种子。既然唯有异熟心及其心所，是正实趣生，则这异熟的心、心所法，离开了第八识则不能成立。

    论文九：又契经说：有色根身是有执受，若无此识，彼能执受不应有故。谓五色根及彼依处，唯现在世是有执受，彼定由有能执受心。唯异熟心先业所引，非善、染等，一类、能遍、相续执受有色根身，眼等转识无如是义。此言意显眼等转识皆无一类、能遍、相续执受自内有色根身，非显能执受唯异熟心，勿诸佛色身无执受故。然能执受有漏色身唯异熟心，故作是说。谓诸转识现缘起故，如声、风等，彼善染等非业引故，如非择减。异熟生者非异熟故，非遍依故，不相续故，如电光等，不能执受有漏色身。诸心识言亦摄心所，定相应故，如唯识言。非诸色根不相应行，可能执受有色根身，无所缘故，如虚空等。故应别有能执受心，彼心即是此第八识。

    讲解：这是所引的第四理证。又有佛经说，有色根身之所以能够存在，是因为它有能执受的第八识。若无此识，那能执受的东西就不应当有。也就是说，眼等五根及根所依处，只有现在世有执受，这证明了有一个能执受之心，唯有这第八异熟识，才是能执受的心，因为此异熟心是前世先业所引生的总报体；它不是善、也不是恶，而是无覆无记性；在一期生死中，它始终一类能够周遍，永恒相续执受著有色根身。除此第八识外，眼等六转识没有以上执受的意义。

    以上所说，是显示除第八异熟心外，其余的六转识，没有一类普遍相续的意义、能执受自内的有色根身。这并不是说，唯有凡夫的异熟心才能执受，而诸佛的无漏识没有能执受的功能，不过是言说执受凡夫有漏色身，那就非异熟心不可了。以上所说的六转识，都是以现在的缘而生起，好像电光一样，没有执受的功用。

    以上所说心法也包括心所法，因为心法和心所法肯定相应，如唯识所说。各种色根和不相应行，不可以执受有色根身，因为没有缘虑作用。因此应当另有能执受之心，那种心就是第八识阿赖耶识。

    论文十：又契经说：寿、暖、识三更互依持，得相续住。若无此识能持寿、暖，令久住识不应有故。谓诸转识有间有转，如声、风等无恒持用，不可立为持寿、暖、识。唯异熟识无间无转，犹如寿、暖有恒持用，故可立为持寿暖识。经说三法更互依持。而寿与暖一类相续，唯识不然，岂符正理。

    讲解：这是所引的第五理证。又，佛经说：凡有色身的有情，寿命、暖气（体温）、与异熟识三法，如三足鼎立，更互依持而得相续而住。如果没有这异熟识持寿和暖，使之久住于世的识就不应当有。因为六转识有间断变易，如声、风一样，没有永恒执持的功用，不能成为执持寿和暖的识。唯有这第八异熟识，没有间断和变易，在从生到死的一期生命中，有恒久执持的功用。所以能立为执持寿和暖的识。佛经上说，寿、暖、识三法，是互相依持。假如寿、暖二法一类相续，唯有识不是这样的话，就不符合经上所说的正理了。

    论文十一：虽说三法更互依持，而许唯暖不遍三界，何不许识独有间转？此与前理非为过难。谓若是处具有三法，无间转者可恒相持。不尔，便无恒相持用。前以此理，显三法中所说识言，非诠转识，举暖不遍岂坏前理？故前所说，其理极成。又三法中，寿、暖二种既唯有漏，故知彼识如寿与暖定非无漏。生无色界起无漏心，尔时何识能持彼寿？由此故知有异熟识，一类恒遍能持寿、暖，彼识即是此第八识。

    讲解：外人诘难曰：经上虽说寿、暖、识三法互相依持，然而‘暖’却不遍三界，无色界有情则无暖，何以‘识’不可以间断呢？论主答：此难不能成立，佛经上说三法互相依持，那是说在欲、色界里同时俱有的寿、暖、识三法，没有间断和转易，可以恒相依持。否则，若有间断像六转识一样，便没有恒相依持的功用了。并不是说连无色界也有暖法。而且前面以恒相依的道理，所显示那寿、暖、识三法中的识，是指一类相续的第八识，并不是有间断的六转识。

    再者，三法互依的寿、暖二法，既唯有漏，所以知道三法中的识也不是无漏。生到无色界的人，生起无漏心，那时虽无色、暖，尚有寿命，试问是什么识在执持这寿命呢？既不是有间断的前六识，也不是无漏心，因此知道有一个一类无记，相续恒有、体遍三界的异熟识，能持寿、暖。这异热识就是第八识。

    论文十二：又契经说，诸有情类，受生命终必住散心，非无心、定，若无此识，生死时心，不应有故。谓生死时身心惛昧，如睡无梦，极闷绝时，明了转识必不现起。又此位中，六转识行相所缘不可知故，如无心位必不现行。六种转识、行相所缘，有必可知，如余时故。真异熟识极微细故，行相、所缘俱不可了，是引业果，一期相续，恒无转变，是散有心，名生死心不违正理。

    讲解：这是所引的第六理证。佛经上说：诸有情类，在投胎受生及报尽命终之时，必然住于散心位，而不是住于无心和定心。此位不过是没有六转识，并不是没有第八识。如果没有这第八识，那生死时就不应当有心识。因为有情在生死时，五识身及第六识都已惛沉闇劣，好像五无心位中的熟睡、闷绝一样。这时明了意识必定不能生起，并且此时六转识的行相与所缘均不可知，就如无心位时必定不起现行。假定生死位中有六转识，其行相与所缘肯定可知，像平常散心位一样。第八真异熟识极其微细，它的行相与所缘俱不可知，它是前世引业之果，在一期生死相续中恒无转变，是散心位，而不是定心；是有心位而不是无心。此第八真异熟识，名为‘生死心’，决定不违正理。

    论文十三：有说：五识此位定无，意识取境或因五识，或因他教，或定为因，生位诸因既不可得，故受生位意识亦无。

    讲解：有一派大乘异师说：五转识在生死位中决定没有，第六意识缘取外境，有三种因，或因五识缘尘境，随取影像；或因他人说教别取知解；或因禅定取殊胜境。既然是生位这些原因都不存在，所以受生位肯定没有第六意识。

    论文十四：若尔，有情生无色界，后时意识应永不生，定心必由散意识引，五识、他教彼界必无，引定散心无由起故。若谓彼定由串习力，后时率尔能现在前。

    彼初生时宁不现起？又欲、色界初受生时，串习意识亦应现起。若由惛昧初未现前，此即前因，何劳别说？有余部执生死等位，别有一类微细意识，行相所缘俱不可了。应知即是此第八识，极成意识不如是故。

    讲解：论主反驳说：如照你所说，那有情生到无色界时，他的意识就永远不能生起了，因为无色界的定心必由散心意识引生。能生意识的‘五识’和‘他教’二因，在无色界决定不存在，如此，则能够引定心的散心意识尚无从生起，试问那定心又怎样引生？

    大乘异师又救曰：无色界里虽无能生散意的二因，然而它们的定心，却是由于在下界时，散意引定的惯习之力，到无色界后随能现前，这又有什么不对呢？

    论主反难说：照你说定心既因下界惯习之力而起，何不起于初生刹那，而待后时呢？再者，欲、色界的有情初受生时，其前世串习的意识也应当现前，何以没有呢？若说无色界的定心，及下界的散心，在初生刹那不能现起者，是因为有情初生时惛昧之故，何必再用其它解释。小乘上座部师，主张在生死位中，别有一类微细意识，它的行相和所缘俱不可知。当知这微细意识，就是这第八识。因为大家所公认的意识，只有可以了知的一类，它不同于这不可了知的第八识。

    论文十五：又将死时，由善恶业上下身分，冷触渐起，若无此识，彼事不成。转识不能执受身故。眼等五识各别依故，或不行故，第六意识不住身故，境不定故，遍寄身中恒相续故，不应冷触由彼渐生。唯异熟心，由先业力，恒遍相续，执受身分，舍执受处冷触便生，寿、暖、识三不相离故。冷触起处，即是非情，虽变亦缘而不执受。故知定有此第八识。

    讲解：有情将命终时，善业重的从下向上冷，恶业重的由上向下冷，这是将舍执、受的第八识，带著今世所造的业因，或上生善趣，或下堕恶道，如果没有这个第八识，这种情况就不能成立，因为六转识不能执、受身体。眼等五识也不能执受，一者各别依根，各自缘境。二者或缘不具不起现行。若根坏缘缺，命终前则先舍五识，由此二因，眼等五识不能执、受。第六意识也不能执、受，它不是去后来先的主人翁，不住色身一处故；它缘不定；它遍寄身中诸根，随逐缘境，相续转故，不能说冷触是由意识生起。唯有第八真异熟心，是由先世业力所引的总报果，所以才恒、遍、相续的执、受根身。凡是舍弃了执受的部分，冷触便生。因为寿、暖、识三法是不相离的，识若离去，寿、暖、也必随之而离，所以冷触起处，便成了没有知觉的非情外器，这非情外器虽也为第八识所变与所缘，但却不为第八识所执、受。因此知道除六转识外，决定有一个第八识。

    论文十六：又契经说：识缘名色，名色缘识，如是二法，展转相依，譬如束芦俱时而转。若无此识，彼识自体不应有故。谓彼经中自作是释，名谓非色四蕴，色谓羯逻蓝等，此二与识相依而住，如二束芦更互为缘，恒俱时转，不相舍离。眼等转识摄在名中，此识若无，说谁为识？亦不可说名中识蕴，谓五识身，识谓第六。羯逻蓝时无五识故。又诸转识有间转故，无力恒时执持名色，宁说恒与名色为缘？故彼识言显第八识。

    讲解：这是所引的第七理证。佛经上说：‘识缘名色，名色缘识’，名色是五蕴的总名：受、想、行、识四蕴，是但以诠名而知的心法；色之一蕴，是有质碍性的色法，这在羯逻蓝位，名色与识互相依存，如二束芦同时安立。如果没有第八识，那‘识缘名色，名色缘识’的识指的是什么呢？

    不能说名中的识蕴是前五识，‘识缘名色’的识是第六意识，因为在羯逻蓝位没有前五谶。而且，因为六转识有间断，有转易，其性不坚，没有能力永远执持名色，怎能说永远与名色为缘呢？所以，经中说的‘识缘名色，名色缘识’的那个识，指的是第八识阿赖耶识。

    论文十七：又契经说：一切有情皆依食住。若无此识，彼识食体不应有故。谓契经说：食有四种：一者段食，变坏为相，谓欲界系，香、味、触三于变坏时能为食事，由此色处非段食摄，以变坏时色无用故。二者触食，触境为相，谓有漏触才取境时摄受喜等，能为食事，此触虽与诸识相应，属六识者食义偏胜，触粗显境，摄受喜、乐，及顺益舍，资养胜故。三意思食，希望为相，谓有漏思与欲俱转，希可爱境能为食事。此思虽与诸识相应，属意识者食义偏胜，意识于境希望胜故。四者识食，轨持为相。谓有漏识由段、触、思势力增长能为食事。此识虽通诸识自体，而第八识食义偏胜，一类相续执持胜故。由是集论，说此四食、三蕴、五处、十一界摄。此四能持有情身命，令不坏断，故名为食。

    讲解：这是所引的第八理证。佛经上说：三界、五趣、四生的一切有情，都要依靠‘食’而维持生命。如果没有这第八识，识食的自体就不应当存在。佛经上说食有四种，是段食、触食、意思食、识食。一者段食，段是形段，以消化为其自相，欲界有情以此食资养身命，必须食物含有香气、滋味，及冷、暖、坚、软的触尘。色境非段食摄，因以眼缘色，不能饱腹也。

    二者触食：以接触外境为其自相，由触心所与境接触，摄取喜、乐、舍受以资养身心而成为食事。触虽遍通八识，但对第六识来说食义偏胜。三者意思食：此食以希望为其自性，有漏的思心所和欲心所俱时转起，希求可爱的顺境以为食事。这意思食虽遍通八识，但对第六意识则食义偏胜。因为它对于可爱境界希望的殷切，不是余识之所能及。四者识食：此食以执持为其自相，这是凡夫的有漏识，由于段食、触食、意思食这三食资养之故，使其执持势力得以增长，能为食事。这识食虽遍通八识，但以第八识的食义偏胜。因为它是一类相续，恒不改易，执持身命的功用殊胜。

    所以《杂集论》说：这四种食，在五蕴里，属三蕴所摄：段食属色蕴，触、思二食属行蕴，识食属识蕴。在十二处里，属五处所摄：段食属香、味、触三处，触、思二食属法处，识食属意处。在十八界里属十一界所摄：段食属香、味、触三界，触、思二食属法界，识食属前六识及意根七界。因为这四种食，能够执持有情的身命，使之不坏，亦不断灭。所以名之为食。

    论文十八：段食唯于欲界有用。触、意、思食虽遍三界，而依识转，随识有无。眼等转识有间有转，非遍恒时能持身命，谓无心定、熟眠、闷绝、无想天中，有间断故。设有心位随所依缘，性、界、地等有转易故。于持身命，非遍非恒。诸有执无第八识者，依何等食，经作是言：一切有情，皆依食住。

    讲解：四食中的段食，唯在欲界有情有用，所谓欲，指饮食欲、睡眠欲、和男女的淫欲。触和意、思二食虽遍三界，但毕竟是依识而起作用，随著识的有无而转。前六识有时间断，有时转易，不是遍通三界恒时而有，如在五种无心位时就间断了。就是在有心位，也是随其所依的根和所缘的境，在善、恶、无记三性，及三界、九地里，时有转易。因此则六识非遍非恒，不能执持身命。一般人执著没有第八识，试问如果没有第八识，佛经如何说‘一切有情，皆依食住’呢？

    论文十九：非无心位，过去未来识等为食，彼非现常，如空华等，无体用故。设有体用，非现在摄，如虚空等，非食性故。亦不可说，入定心等与无心位有情为食，住无心时彼已灭故。过去非食已极成故。又不可说无想定等，不相应行即为彼食，段等四食所不摄故。不相应法非实有故。

    讲解：有人说：过去的识和未来的识，不是可以做识食的体吗？论主破曰：过去和未来，既不是现有，又不是恒常，如病眼所见的空华，没有体用。假如有体用，也不是现在所摄，与虚空无异，又怎能为识食的体性？也不可以说初入定时的心、离定前不远，可以给无心位的有情作为识食的体性。因为住无心位的有情，它那入定时的心，已被伏灭成为过去了，怎能为现在识食的体性呢？

    又不可以说当在无想定、灭尽定中，不相应行法，就是彼无心位的识食体性，何以故，因为段等四食并不包含无想定等，同时不相应行法也并非实有。

    论文二十：有执灭定等犹有第六识，于彼有情能为食事，彼执非理，后当广破。又彼应说生上二界无漏心时以何为食？无漏识等破坏有故，于彼身命不可为食。亦不可执无漏识中有有漏种能为彼食，无漏识等犹如涅槃，不能执持有漏种故。复不可说上界有情身命相持，即互为食，四食不摄彼身命故。

    讲解：上座部认为，入于灭尽定时犹有第六意识，可以作为定中有情的食事。论主称此说不合道理，后面当有详破。又有人执著，当灭尽定人上生色、无色界，生起无漏心时，以什么为食呢？你不可说：此时有漏意识既已间断，那就以无漏识为食吧。殊不知无漏识生起时要破坏有漏，无漏识犹如涅槃，怎能执持有漏的烦恼种子呢？也不可说色界和无色界的有情，起无漏心时，可以根身执持寿命，用寿命执持根身，这身、命相持，互为食事。因为佛只说四食，这身食和命食，不是四食所摄。

    论文二十一：又，无色无身命，无能持故，众同分等无实体故。由此定知，异诸转识有异熟识一类恒遍，执持身命令不坏断，世尊依此故作是言：一切有情皆依食住，唯依取蕴建立有情，佛无有漏非有情摄，说为有情依食住者，当知皆依示现而说。既异熟识是胜食性，彼识即是此第八识。

    讲解：再者，无色界的有情没有色身，拿什么来持命呢？命根和众同分属于不相应行，无有实体，也不能做识食之体。由此可知，决定知道另有一种与六转识不同的异熟识。它一类相续，恒常周遍，执持有情身命，使之不断不坏的识食之体。世尊即依此识的意义，而说：‘一切有情，皆依识食而得安住’。

    有设难曰：如这样说，佛也是依食而住的有情了，否则，何以言‘遍’。答曰：唯依有漏的五取蕴而建立有情，佛无‘有漏’，当然不属于有情所摄。然而，说为有情依食住者，当知那是依佛方便示现的应身而说的，实则佛非有情，非非有情。

    既知识食虽遍通八识，要以异熟为殊胜食体。那识食，实在即是此第八识。

    论文二十二：又，契经说：住减定者，语、身、心行无不皆灭。而寿不灭，亦不离暖，根无变坏，识不离身。若无此识住灭定者，不离身识不应有故。谓眼等识行相粗动，于所缘境起必劳虑。厌患彼故，暂求止息，渐次伏除至都尽位。依此位立住灭定者，故此定中彼识皆减。若不许有微细一类，恒遍执持寿等识在，依何而说识不离身。若谓后时彼识还起，如隔日疟，名不离身。是则不应说心行灭，识与想等起灭同故。寿、暖诸根应亦如识，便成大过。故应许识如寿、暖等实不离身。

    讲解：这是所引的第九理证。契经上说：住灭尽定的人，它们身行的出入息，语行的寻、伺，心行的受、想皆已灭除，而寿命不灭，也不离暖，根不变坏，识不离身。如果没有这第八识，那灭尽定人的‘不离身识’，就不应当有。

    或问：不离身的识，不许是六转识吗？答曰：不可，因为六转识行相粗显，于六尘境攀缘不定，而且因劳苦思虑而感疲劳，生起厌患，暂求止息，从粗到细，观无相想，渐次伏除，直到灭尽位，即依此位建立‘灭尽定’名。所以在灭尽定中的六转识，无不都灭。如果不许有一个微细难知的一类无记、恒无间断、体遍三界、执持寿、暖的第八识存在，经上依据什么说‘识不离身’呢？

    说一切有部救说：灭尽定的六转识虽已伏灭，但后来出定时还要再起。所以说‘识不离身’，就好像隔日一发的疟疾似的，名叫‘识不离身’。论主驳曰：照这样说，经中就不应说‘心行灭’，要说‘识灭’才对。因为说‘心行灭’，原本是为显示定中有识，现在你们所说的识，是和心行的受、想于定中同灭，定后同起。寿、暖二法，以及诸根也应当同识一样，在定中无，出定方有。这样岂不是等于死而复生。因比，我们应当承认转识之外，另有一个第八识，在灭尽定中与其所执持的寿、暖二法，不离于身。

    论文二十三：又此位中若全无识，应如瓦砾，非有情数，岂得说为住灭定者。又，异熟识此位若无，谁能执持诸根寿、暖？无执持故皆应坏灭，犹如死尸，便无寿等。既尔，后识必不还生，说不离身彼何所属？诸异熟识舍此身已，离托余身无重生故。

    讲解：住灭尽定位的人，若完全没有识，就应当如砖石瓦砾一样，不能叫做有情了，怎可说它是住灭尽定的人呢？又，住灭尽定位的人如果没有异熟识，谁能执持根身、寿、暖？既然没有能执持的识，那根身岂不要腐坏，同死尸一样没有寿了？如此则出定后的识如何还生？经中所说‘识不离身’的话，也就没有著落了。如果第八识真在灭尽定中舍了此身，它立刻会到别处转生另一他身。他是永恒存在，但不可能死后再生。

    论文二十四：又，若此位无持种识，后识无种如何得生？过去、未来不相应法，非实有体，已极成故。诸色等法离识皆无，受熏持种亦已遮故。然灭定等无心位中，如有心位定实有识。具根、寿、暖有情摄故。由斯理趣，住灭定者，决定有识实不离身。

    讲解：再者，在修灭尽定的时候，如果没有执持种子的识，那出定的识既无种子，如何得生？过去、未来及不相应行，皆非实有本体，这是大、小乘教所承认。十一色法离识即不存在，它们也不能受熏持种。然而在灭尽定等无心位中的人，肯定和有心位一样有识，因为一切有情都具有根身、寿、暖。由上所说，可知住灭尽定位的人，决定有个第八识，实不离身。

    论文二十五：若谓此位有第六识，名不离身亦不应理，此定亦名无心定故。若无五识名无心者，应一切定皆名无心，诸定皆无五识身故。意识摄在六转识中，如五识身灭定非有。或此位识行相所缘不可知故，如寿、暖等非第六识。若此位有行相所缘可知识者，应如余位，非此位摄，本为止息行相所缘可了知识，入此定故。

    讲解：如果认为修灭尽定时，有第六识名不离身识，此不应理。因为灭尽定又名无心定。如果没有前五识称为无心，那么一切定都可以名无心，因为一切定都没有前五识。意识包括在六转识中，它像前五识一样，修灭定时即不存在。你们或说，灭尽定中识的行相如寿、暖一样的微细难知，所以不是粗动的第六识。倘若在灭尽定位，有行相、所缘可知的第六识，这灭尽定位就应当如余位有心一样，而不是灭尽定位所摄了。

    论文二十六：又若此位，有第六识，彼心所法为有为无？若有心所，经不应言住此定者心行皆灭；又不应名灭受想定。此定加行但厌受想故，此定中唯受、想灭。受、想二法资助心强，诸心所中独名心行。说心行灭何所相违。无想定中应唯想灭，但厌想故，然汝不许，既唯受、想资助心强，此二灭时心亦应灭。如身行灭而身犹在，宁要责心令同行灭？

    讲解：又若灭尽定位尚有第六识存在，此第六识的心所法是有是无？若有心所法，经中就不应当说住灭尽定的人受、想都灭，同时，灭尽定也不该叫‘灭受想定’。

    经量部自救说：这减尽定的加行位，只是厌患受、想二法，所以定中唯减受、想。受、想二法资助心王的作用较强，独名之为‘心行’。这与经中所说的‘心行灭’并不相违。

    论主破曰：照你们说，在修‘灭尽定’前但厌受、想，唯受、想灭。那么无想定中，就应当唯有‘想’灭，因为定前只厌于‘想’。然而你们不许，为什么偏许灭尽定中，唯受、想灭呢？既然说受、想二法，资助心王的势用较强，那么这受、想二法灭时，那六识心王也应该随之而灭呀。

    经量部救曰：灭尽定人，就像身行灭时身犹存在一样，为什么要责第六识心王与心行的受、想同灭呢？

    论文二十七：若尔，语行寻、伺灭时语应不灭，而非所许。然行于法有遍非遍，遍行灭时法定随灭，非遍行灭法或犹在。非遍行者谓出入息，身息灭时身犹在故。寻、伺于语是遍行摄。彼若灭时语定无故。受、想于心亦遍行摄，许如思等大地法故。受、想灭时心定随减，如何可说彼灭心在。

    讲解：论主破曰：假定以‘身行灭而身不灭’为例，可使心行灭而意识不灭的话，那么，当语行的寻、伺灭时，语也应当不灭。然而这又是你们所不许，既不许语行灭而语不灭，为什么偏许心行灭而心不灭呢？

    ‘行’对法来说，有遍行和非遍行两种。遍行灭的时候，这个法也随之而灭；非遍行灭的时候，这个法或随之而灭，或依然存在。例如住灭尽定人，身行的出入息灭了，而身仍存在，这就是非遍行；而语行的寻、伺灭了，而语也决定随之而灭，这就是遍行。心行的受、想是遍行所摄，就像‘思’等‘大地法’一样（注：受、想、思、触、欲、慧、念、作意、胜解、三摩地等，是小乘所立与一切心相应而起的十大地法）。所以心行的受、想灭时，心法的第六识必定随之而灭。怎么可说，受、想虽灭，而意识犹在呢？

    论文二十八：又许思等是大地法，灭受、想时彼亦应灭。既尔，信等此位亦无。非遍行灭余可在故，如何可言有余心所？既许思等此位非无，受、想应然，大地法故。又此定中若有思等，亦应有触，余心所法无不皆依触力生故。若许有触亦应有受，触缘受故。既许有受，想亦应生，不相离故。如受缘爱，非一切受皆能起爱，故触缘受非一切触皆能生受，由是所难其理不成。

    讲解：论主反驳说：若许受、想、思等同是十大地法，那受、想二法灭时，思等八法应当与之俱灭，因为都是大地法的缘故。如果是这样，则信等善、不善法，在灭尽定位也就没有了。因为并不是遍行心所已灭，其余的非遍行还可以存在。如何可说灭尽定位，除受、想外，还有其余的心所法呢。反过来说，既许灭尽定位有思等八法，那受、想二法就应当也有，因为同属大地法的缘故。再者，灭尽定中如果有思等心所，有思应当先有触，因为其余的心所法都是依触的力量而生起的。若允许有触就应当有受，因为十二因缘法说：‘触缘受’。既许有受就应当生想，因为受、想二法是离不开的。

    经量部师救曰：如十二因缘所说的‘受缘爱’，并不是说一切受都能起爱。所以‘触缘受’也不是一切触都能生受。因此，你们所难的理由，是不能成立的。

    论文二十九：彼救不然，有差别故。谓佛自简唯无明触所生，诸受为缘生爱，曾无有处简触生受。故若有触必有受生，受与想俱，其理决定。或应如余位受、想亦不灭。执此位中有思等故。许便违害心行灭言，亦不得成灭受想定。

    讲解：论主破曰：你这种救法不能成立，因为‘触缘受’、与‘受缘爱’是有差别的，佛自己就曾经作过简别：‘唯有无明触所生的有漏受，才能为缘生爱’，从来没有说过：‘触有生受不生受的分别’，受不一定能移生爱，而有触一定有受，有受就一定有想，这道理是决定无移的。或有师申解曰：灭尽定位和其余的有心位一样，受、想不灭。论主破曰：你们执灭尽定中还有思心所，那便违背了‘受、想心行灭’的圣教；同时，如果还有受、想，那就不成为‘灭受想定’了。

    论文三十：若无心所，识亦应无，不见余心离心所故，余遍行灭法随灭故，受等应非大地法故，此识应非相应法故，许则应无所依缘等，如色等法亦非心故。

    讲解：以上是破有心所，此下破无心所。论主破曰：如果在灭尽定位没有心所，那第六识心也不应当存在。因为从未见过其余有心位的心法，能离开他的心所而存在。灭定位中受、想的心行灭，心法也就随之而灭，因为都是遍行法。如果遍行的受、想心行灭，而心法还存在不灭，那受、想、思等就不应该是大地法。假若按照你们的观点，心识独存，则灭定位中的心识就没有心所相应，则此识应如色等，不是相应法。如果你们真的认为是这样，则灭定位中的心识，就没有所依的根和所缘的境，这就如色法一样，而不是心法了。

    论文三十一：又，契经说：意法为缘生于意识，三和合触，与触俱起有受、想、思。若此定中有意识者，三和合故必应有触。触既定与受、想、思俱，如何有识而无心所？若谓余时三和有力，成触生触，能起受等，由此定前厌患心所，故在定位，三事无能不成生触，亦无受等。若尔，应名灭心所定，如何但说灭受想耶？若谓厌时唯厌受、想，此二灭故心所皆灭。依前所厌以立定名。既尔，此中心亦应灭，所厌俱故，如余心所。不尔，如何名无心定。

    讲解：再者，契经上说：意根缘法尘而生意识，根、尘、识三法和合而生触，与触俱起的有受、想、思。如果这灭尽定中有意识存在，则以根、境、识三和之故，必定有触生起，还能生起受等。既然触决定与受、想、思等的心所俱起，如何可说但有意识而没有心所呢？经量师转救曰：在灭尽定外的余时，根、境、识三法和合，有力成触，触能起受等心所。由于在定前加行、厌患心所之故，所以在灭尽定的过程中，根、境、识三事没有和合成触的能力，当然也没有与触俱起的受、想、思。论主反难曰：若如此说，定中既无一切心所，就应当称灭心所定，何以但说灭受想定呢？

    经量师复救言：在定前厌患心所时，但厌受、想二法。这受、想二法灭了，一切心所也就随之而灭，依于定前所厌的受、想二法，建立了‘灭受想’的定名。论主破曰：既然如此，灭尽定中的第六识心也应当灭，因为此心与其所厌患的受、想一样，是起则俱起，灭则俱灭。不然，为什么叫‘无心定’呢？

    论文三十二：又此定位，意识是何？不应是染或无记性。诸善定中无此事故。余染、无记心必有心所故。不应厌善起染等故。非求寂静翻起散故。若谓是善，相应善故，应无贪等善根相应。此心不应是自性善或胜义善，违自宗故，非善根等及涅槃故。若谓此心是等起善，加行善根所引发故，理亦不然，违自宗故。如余善心非等起故，善心无间起三性心，如何善心由前等起？故心是善，由相应力。既尔，必与善根相应，宁说此心独无心所？故无心所，心亦应无。

    讲解：再者，假定灭尽定位犹有意识，这意识在三性中是何属性？不应该说是染性或无记，因为凡是善性定，决定没有染性及无记，如果有染和无记，必然有二十六个烦恼心所，和遍行、别境及不定心所。灭尽定位既无心所，当然不是染性或无记。在定前加行时，就不应厌善而生起染污或无记。也不能说求禅定的人，反而生起了散心意识。

    小乘人执于善有相应善、自性善、胜义善、等起善（注：经量部以善有四种，胜义善即是涅槃，因为已经永灭各种痛苦。自性善是惭、愧、无贪、无嗔、无痴五法，这五法本身就是善。相应善是信、勤等善法，与五种自性善相应而起。等起善是由自性善等所产生的善法。）若说灭尽定位的第六识是善，那一定是相应善，与无贪、无嗔、无痴三善根相应。此位善心，不应说是自性善或胜义善，这与经量部主张相违，因为它不是三善根及惭、愧五法的‘自性善’，又不是涅槃胜义善。若说这灭尽定心是由加行善引发的‘等起善’，理亦不然，经量部并不认为其它散心位的善心为‘等起善’，如果其余散心位的善心，没有间断地生起善、恶、无记三性之心，怎能说此位善心是加行善根所引发的呢？所以灭尽定位的心法如果是善的话，则肯定是相应善，因为这是由相应力促成的。既然如此，肯定与善根相应，怎能说只有心法没有心所法呢？如果没有心所法，心法也应当没有。

    论文三十三：如是推征，眼等转识，于灭定位非不离身。故契经言：不离身者，彼识即此第八识。入灭定时，不为止息，此极寂静执持识故，无想位等类此应知。

    讲解：这样推究起来，眼等六识在灭尽定位里，并不是不离身识，所以经上所说那不离身识，就是第八阿赖耶识。因为入灭尽定时，止息的是那粗动的六转识，并不是这极其寂静起执持作用的第八识。灭尽定如此，则无想定、无想天，也是依此类推。

    论文三十四：又契经说：心杂染故有情杂染，心清净故有情清净。若无此识，彼染、净心不应有故。谓染、净法以心为本，因心而生，依心住故。心受彼熏，持彼种故。然杂染法略有三种：烦恼、业、果，种类别故。若无此识持烦恼种，界地往还、无染心后，诸烦恼起皆应无因。余法不能持彼种故，过去、未来非实有故。

    讲解：这是所引的第十理证。如《染净心经》称：‘心杂染故，有情杂染；心清净故，有情清净’。倘若没有这第八识，杂染或清净的心就不应当有。一切有漏、无漏的染净诸法，都是以心为本源。染、净法的现行，无非因心而生，种子也依心而住。本识受染、净现行的熏习，还持彼所熏的种子而起现行。这种生现就是‘因心而生’；现熏种就是‘依心而住’。

    杂染法有烦恼、业、果三种。一者烦恼，就是三界见、思二惑。二者业，就是因惑所起的一切有漏善、不善业。三者果，就是因业所感的异熟报果。这是三种染法不同的类别，如果没有第八识执持烦恼种子，那从欲界生到无色界的有情，已无染心，后来再由无色界还生欲界，此时所起的烦恼岂非无因？因为除了第八识外，其余的色、心等法都不能持种，过去、未来又非实有。如果烦恼无因而生，那就没有声闻、缘觉、菩萨三乘，也不会有有学、无学之果，则已断之烦恼还可以再起。倘若没有这第八识来执持业、果的种子，那生死往还于三界九地的有情，从甲地转生乙地、或从乙地转生丙地，其后所起的业果，岂不也是无因？若说除第八识外，其余的色、心之法可以持种，过去、未来可以为因，这在前面已经遮遣过了。

    论文三十五：若诸烦恼无因而生，则无三乘学、无学果，诸已断者皆应起故。若无此识持业果种，界地往还、异类法后，诸业果起，亦应无因。余种余因前已遮故。若诸业果无因而生，入无余依涅槃界已，三界业果，还复应生，烦恼亦应无因生故。又行缘识应不得成，转识受熏前已遮故。结生染识非行感故，应说名色行为缘故，时分悬隔无缘义故，此不成故后亦不成。

    讲解：假使各种业果可以无因而生，证入无余依涅槃以后，三界业果还可以再生，因为烦恼也可以无因而生的。再者，十二因缘所说的：‘行缘识’，就是由前面‘行’的因熏成了后面‘识’的果。如果没有这第八识，那‘行缘识’的因缘应当不能成立。若说是六转识受熏，前已遮遣，因为转识不能受熏。

    经量部师救曰：去投生时的染污第六意识，岂不是可以作‘行缘识’的识吗？论主曰：这也不对，因为结生染识是中阴身的第六意识，不是由行而感果之识（注：于轮回转生之间，由中有而托生于母胎曰结生）。有部复救曰：‘如果‘行缘识’不能成立，那么说：‘行缘名色’可以吗？论主曰：也不可以，因为行是过去所造的业，名色是现在母胎中的东西，时间隔了这么远，已没有做缘之义了。这样一来，那向后的‘名色缘六人’，乃至‘生缘老死’也都不能成立了。

    论文三十六：诸清净法亦有三种：世、出世道、断果别故。若无此识，持世、出世清净道种，异类心后，起彼净法，皆应无因；所执余因前已破故。若二净道无因而生，入无余依涅槃界已，彼二净道还复应生，所依亦应无因生故。

    讲解：上一节讲，有漏杂染种子要有第八识摄持，现在讲清净法。诸清净法也有三种：一者世间道，二者出世道，三者断果。如果没有第八识执持世、出世间清净道的种子，那由世道进入了出世道，或由出世道退回世道，在这‘异类心后’所生起的净法都应当无因（注：异类法后，指有情生于无色界的无所有处、和非想非非想处时，出世间心出现，世间心都要灭除，此时之境界称为异类法后）。至于经量部等所主张的其它原因，在前已经破斥。假如世、出世间二种清净道可以无因而生，那么入无余依涅以后，那二种清净道应当还可以再生。因为这二道所依的身智，也成为无因而生了。

    论文三十七：又出世道，初不应生，无法持彼法尔种故。有漏类别非彼因故。无因而生非释种故，初不生故后亦不生，是则应无三乘道果。若无此识持烦恼种，转依断果亦不得成。谓道起时，现行烦恼及彼种子俱非有故。染、净二心不俱起故。道相应心不持种故，自性相违如涅槃故。去、来、得等非实有故，余法持种理不成故。既无所断，能断亦无，依谁由谁而立断果？

    讲解：再者，如果没有第八识来执持法尔本有的无漏种子，那无漏的出世净道最初就不应生起。各种不同的有漏法不能做无漏法的因缘，因为有漏和无漏性类不同，有漏种不能作为生起无漏道的原因。主张无因而能生果者，可以说就是外道。当然，最初的无漏不生，后时的无漏亦应不生，这就不会有声闻、缘觉、菩萨的三乘道果。

    如果没有第八识执持烦恼种子，那转依断果也不能成立（注：断果即无为，断即是果，指无为法是由断惑所得的果）。因为无间道生起时，那现行烦恼及其种子都已断灭，以染、净二心不能同时俱起，与出世净道相应的心也不能持烦恼种子，它们的性质是相反的，好像涅槃断果，不能持烦恼种子一样。过去、未来，及‘得’等的不相应行，非实有体，不能持种。其余色、心等法，在道理上不能持种。如此，则既没有所断的惑，也没有能断的道，那么，依什么惑、由什么道来建立断德的涅槃果呢？经量部救曰：由最初的断道力故，使后惑不生起，即由此建立断果。

    论文三十八：若由道力后惑不生，立断果者，则初道起，应成无学。后诸烦恼皆已无因，永不生故。许有此识一切皆成。唯此能持染净种故，证此识有理趣无边，恐厌繁文，略述纲要。别有此识，教理显然，诸有智人应深信受。

    讲解：论主难曰：如此说来，则断道初起，就应该成为无学。因为后来的各种烦恼，由于初断道都已无因，因为没有种子，永不再生。如果承认有第八阿赖耶识，则一切染、净诸法都可以成立。因为唯有此第八识才执持染净二法种子之故。

    证明有此第八阿赖识的存在，理由很多，但恐过于繁琐，只述纲要。除了它识之外，别有一个阿赖耶识受熏持种，在五教十理里显而易见，有智慧的人应该相信。


第一章　举体出名门

    第三篇　思量能变识诠释

    (本篇颂文，由第五颂至第七颂。)

    第一章　举体出名门

    论文一：如是已说初能变相，第二能变其相云何？颂曰：次第二能变，是识名末那，依彼转缘彼，思量为性相，四烦恼常俱，谓我痴我见，并我慢我爱，及余触等俱，有覆无记摄，随所生所系，阿罗汉灭定，出世道无有。

    讲解：前面已经讲完初能变识的第八识之相，往下应讲第二能变的第七识之相了。第二能变又称思量能变，即是第七末那识之变，此思量能变的相状如何？如上列长行中颂文所说。古人诠释思量能变，也是以八段十门来科分，现列十门如下：

    一、举体出名门：次第二能变，是识名末那。────────标名门
    二、所依门：依彼转。──────────────────所依门
    三、所缘门：缘彼────────────────────所缘门
    四、体性行相门：思量为性。───────────────体性门
     （思量为）相。────────────────────行相门
    五、心所相应门：四烦恼常俱，谓我痴我见，并我慢我爱。──染俱门
     及余触等俱。────────────────────相应门
    六、三性分别门：有覆无记摄。──────────────三性门
    七、界系分别门：随所生所系。──────────────界系门
    八、起灭分位门：阿罗汉灭定，出世道无有。────────隐显门

    论文二：次初异熟能变识后，应辨思量能变识相。是识圣教别名末那，恒审思量胜余识故。此名何异第六意识？此持业释，如藏识名，识即意故。彼依主释，如眼识等，识异意故。然诸圣教恐此滥彼，故于第七但立意名。又标意名为简心识。积集了别劣余识故。或欲显此与彼意识为近所依，故但名意。

    讲解：初能变的第八异熟识前已说竟。现在诠释第二能变的第七思量识。这第七识，在圣教经典中通名谓‘识’，别名‘末那’。末那梵语，翻译为‘意’。意字的解释是恒审思量。宽泛的说，八识皆有思量，但第八识是恒而非审的思蕫，第六识是审而非恒的思量，前五识是非恒非审的思量，唯有第七识是既恒又审的思量，所以名之谓‘意’。有间曰：既然第七识通名谓识，别名谓意，综合通别，即名‘意识’，这和第六意识，有何不同。答曰：第七识是以意为识体，识为意用，在六离合释的解释中，属于‘持业释’，就像阿赖耶名谓‘藏识’一样，藏即识体。第六意识，依意根为主，在六离合释中属于‘依主释’，就像依眼根所发的识名叫眼识一样。所依的‘意’是第七识，能依的识是第六识。这是其分别之处。

    尽管第七的意识是‘持业释’，第六的意识是‘依主释’。但仍恐有人混滥不清，所以但名第七为‘意’，以示区别。积集为心，了别为识，而独标第七名为意者，为简别此识在积集的意义不及第八识，在了别的意义不及前六识，所以名意。


第二章　所依门

    第二章　所依门

    论文一：依彼转者，显此所依。彼谓即前初能变识。圣说此识依藏识故。有义：此意以彼识种而为所依，非彼现识，此无间断，不假现识，为俱有依方生故。有义：此意以彼识种及彼现识俱为所依。虽无间断而有转易，名转识故。必假现识为俱所依，方得生故。转谓流转，显示此识恒依彼识取所缘故。

    讲解：现在讲第二所依门。颂中所说的‘依彼转’三字如何解释呢？依彼的‘彼’，是指前面初能变的第八阿赖耶识，因为圣教中说，这第七识是依彼藏识之故。‘依’是依托（事物生起所依靠的条件）。依托什么？此有二说，第一家说这第七识，唯以第八识的种子为所依，并不是依第八识的现行果识。因为第七识的行相恒无间断，不须要藉第八识的现行做其俱有依才得生起。第二家说这第七识是以第八识的种子及现行果识俱为所依。因为第七识在因果位中虽无间断，然入见道时，却不能没有转易，所以它也名叫转识。既有转易，或染、或净，它必须假藉第八识的种子与现行，做为它的俱有依方得生起。‘转’是流转。相续为流，生起为转。这是显示第七识恒依第八识而转起，复取彼所依的第八识，为其所缘的境界。

    论文二：诸心、心所皆有所依，然彼所依总有三种：一、因缘依，谓自种子。诸有为法，皆托此依，离自因缘必不生故。二、增上缘依。谓内六处诸心、心所，皆托此依，离俱有根，心不转故。三、等无间缘依，谓前灭意。诸心、心所，皆托此依，离开导根必不起故。唯心、心所具三所依，名有所依，非所余法。

    讲解：各种心法和心所都有其所依。它们的所依共有三种。一者因缘依：因缘就是‘自种子’。一切法都是依其种子而起现行，若离此种子因缘，其现行果法必定不生。二者增上缘依：增上缘就是‘内六处’，即眼、耳、鼻、舌、身、意六根。八识心王和心所，都是依托这内六处而转的。所以内六处也名‘俱有根’。若离此俱有根，则心王和心所必不能转。三者等无间缘依：就是‘前灭意’，前念心灭，避开了它现在的处所，引导著后念的心、心所，令生彼处，所以前灭意的异名又叫做‘开导依’。八识心王和心所，都是依托这开导根而起，若离此开导依，心王心所必不能起。唯有心、心所法，具足以上这三种所依，才名叫‘有所依’。余如色法，只有因缘依。无心定，只有因缘依及等无间缘依：无为法，则三依俱无。所以都不得名为‘有所依’。

    论文三：初种子依：有作是说，要种灭已，现果方生。无种已生，集论说故。种与芽等不俱有故。有义：彼说为证不成，彼依引生后种说故，种生芽等非胜义故，种减芽生非极成故，焰炷同时互为因故。然种自类因果不俱，种现相生决定俱有，故瑜伽说，无常法与它性为因，亦与后念自性为因，是因缘义。自性言显种子自类前后为因，它性言显种与现行互为因义。摄大乘论亦作是说：藏识染法互为因缘，犹如束芦俱时而有。又说种子与果必俱，故种子依定非前后。设有处说种果前后，应知皆是随转理门，如是八识及诸心所，定各别有种子所依。

    讲解：现在先解释种子依，种子依就是三依中的因缘依。此有两家异说，第一家难陀论师等主张因果异时，它们认为要在种子灭了之后，那现行果法才能生起。这‘无种已生’的道理，是《阿毗达磨集论》上说的。譬如谷种与芽，这因果二法，并非同时俱有，不过是前后俱有罢了。

    第二家护法论师主张因果同时。它说：《杂集论》的证明不能成立，因为彼论是依前念种子引生后念种子而说的，并不是说已竟灭了的种子，还能生现行果法。至于说谷种生芽，种减芽生的话，那只是世俗之见，而不是唯识胜义的因缘，更不是大乘共许的极成之法。唯有种子生现行，现行熏种子，种现同时，好像灯炷生焰，灯焰烧炷，焰炷同时互为因果一样。这才能叫做因缘。

    然而，种子生种子的自类因果，是前后刹那，而不是同时俱有。种子与现行异类相生的因果，决定是同时俱有。因此，《瑜伽论》上说：凡是无常的有为法，可与它性为因，也可与自性为因，这都是因缘的意义。所谓‘自性’的话，就是显示种子为自类。自类引生，是前念种子引生后念种子，前为后因，后为前果。所谓‘它性’的话，就是显示种子与现行为异类。异类相生，是种子生现行，现行熏种子，种现同时，互为因果。如《摄大乘论》上也说：第八藏识与有漏染法，是互为因缘的。藏识藏染法，染法染藏识，好像束芦相倚而立，俱时而有。又说：种子与果法，必定俱时。所以‘种子依’，决定不是前后刹那。设或有经论上说：种子与果法是前后异时。应知那是随顺小乘的方便说法，而不是正义。因此，八识心王及一切心所，必定各有种子因缘做它的所依。

    论文四：次俱有依：有作是说，眼等五识意识为依。此现起时必有彼故。无别眼等为俱有依，眼等五根即种子故。二十唯识伽他中言：识从自种生，似境相而转，为成内外处，佛说彼为十。彼颂意说：世尊为成十二处故，说五识种为眼等根；五识相分为色等境。故眼等根即五识种。《观所缘缘论》亦作是说：识上色功能，名五根应理；功能与境色，无始互为因。彼颂意言：异熟识上能生眼等色种子名色功能，说为五根，无别眼等，种与色识常互为因，能熏与种递为因故。第七、八识无别此依，恒相续转自力胜故。第六意识别有此依。耍托末那而得起故。

    讲解：在因缘依之后是增上缘依，增上缘依又称‘俱有依’，这有四家不同的异说。第一家难陀等说：眼、耳、鼻、舌、身前五识，必定以第六意识为所依，因为前五识现起的时候，必定有第六意识与它们同缘现境。所以除意识外，别无眼等五根为俱有依。因为眼等五根，本来就是阿赖耶识的种子。

    《二十唯识颂》中说：‘识从自种生，似境相而转；为成内外处，佛说彼为十’。颂文的意思是说：世尊为破外道实有我执，成立六根六尘的十二处教。其中有十处是说五识的种子，就是眼等五根；五识的相分，就是色等五境。因此眼等五根，就是五识的种子。《观所缘缘论》中也有一首颂说：‘识上色功能，名五根应理；功能与境色，无始互为因’。颂文的意思是说，第八异熟识上，有能生眼等色识的种子。见分的识，变似相分的色，名为色识；即名此识变似色的功能，叫做五根。离此别无大种所造的实色，名为五根。种子的功能，与境相的色识，它们自无始以来，恒常互相为因。因为色识能熏种子，种子能生色识，能熏与种子，递为因故。

    第七、八二识则无此依，因为它们恒相续起的自力殊胜，不须要依赖其它的俱有根。第六意识有此俱有依，因为它的自体有间断，要依托著第七末那识才能生起。

    论文五：有义：彼说理教相违。若五色根即五识种，十八界种应成杂乱。然十八界各别有种，诸圣教中处处说故。又五识种，各有能生相见分异，为执何等名眼等根？若见分种应识蕴摄；若相分种应外处摄，便违圣教眼等五根皆是色蕴内处所摄。又若五根即五识种，五根应是五识因缘，不应说为增上缘摄。又鼻、舌根即二识种，则应鼻、舌唯欲界系，或应二识通色界系，许便俱与圣教相违。眼、耳、身根，即三识种，二地、五地为难亦然。又五识种既通善、恶，应五色根非唯无记。又五识种无执受摄，五根亦应非有执受。又五色根若五识种，应意识种即是末那，彼以五根为同法故。

    又瑜伽论说：眼等识皆具三依，若五色根即五识种，依但应二。又诸圣教说眼等根皆通现种，执唯是种，便与一切圣教相违。

    讲解：此下是第二家安慧的说法，它对第一家所说不以为然，斥之为‘理教相违’，因为它有下列九种过失：一者诸界杂乱失：倘若眼等五根，就是五识种子的话，那六根、六尘、六识的十八界种子，应当杂乱不分。然而十八界却各有各的种子，并非根种就是识种。二者二种俱非失：五识，各有其能生的相分种子和见分种子，这二分种子迥然不同。如果执著这二分种子，那么那一分名叫五根呢？若说是见分种子，那见分是心法，应该属于识蕴所摄，然而五根非心法，不属识蕴。若说是相分种子，那相分是外处的色法，应该属于外处的色蕴所摄。然而五根虽是色法，而不属外处。这便与圣教完全相违。因为圣教上说，五根都是属于色蕴的内处所摄。三者二缘相违失：倘若五根就是五识种子的话，那五根就应当是五识现行的因缘，不应当说五根是五识的增上缘。四者根识系异失：又若鼻、舌二根就是二识种子的话，那就应当唯系缚于欲界有情，才有鼻、舌二根，色界则无。若许色界有情也有鼻、舌二识，则与圣教相违。因为圣教说是，色界有情有鼻、舌二根，而无鼻、舌二识之故。又若眼、耳、身三根，就是眼、耳、身三识种子的话，那三根就应当唯二地有，三地至五地都无。或应三识五地都有也与圣教相违。因为圣教说是，眼、耳、身三根五地都有，三识则唯通二地之故。（注：五地指欲界一地，色界四地。）

    五者根通三性失：五识通善、恶、无记三性，五根唯属无记。如果五根就是五识的种子，那五根就应当不是唯属无记，而是通于善恶二性了。六者根无执受失：执为自体，能生觉受，名为‘执受’。五根有执受，种子无执受。如果五根就是五识的种子，那五根岂非也和种子一样的没有执受了吗？七者五七不齐失：第七意根末那，与五根同法。倘若五根就是五识的种子，那第七意根末那，就应当是第六意识的种子了。今末那既非意识种子，怎能说五根是五识的种子呢？八者三依阙一失：《瑜伽论》上说，眼等五识都有三依，即因缘依（种子），增上缘依（根），等无间缘依（前灭意）。若执五根为五识种子，那五识便阙五根的增上缘依，只有因缘及等无间缘二依了。九者诸根唯种失：一切经论都说，眼等五根通现行，亦通种子。若执五根唯是种子，而不通现行，岂非与圣教相违。

    论文六：有避如前所说过难，朋附彼执，复转救言：异熟识中皆感五识，增上业种，名五色根，非作因缘，生五识种。妙符二颂，善顺瑜伽。

    讲解：有人为避免前面所说的九种过失，朋比附和第一家的言论而作救言：所谓‘五根即五识种’者，是以异熟识中招感五识的增上业种，名五色根，并不是把五根当作亲生五识的种子因缘。这就可以符合《二十唯识论》和《观所缘缘论》二颂，也随顺了《瑜伽师地论》的主张。

    论文七：彼有虚言，都无实义，应五色根非无记故。又彼应非唯有执受，唯色蕴摄。唯内处故。鼻、舌唯应欲界系故，三根不应五地系故，感意识业应末那故，眼等不应通现种故。又应眼等非色根故，又若五识皆业所感，则应一向无记性摄，善等五识既非业感，应无眼等为俱有依，故彼所言非为善救。

    讲解：第二家驳转救的话说：你的主张只是虚诳之言，并无实义，过失更多至十种：一者业通三性，根唯无记。若执五识的增上业种名五根的话，那五根就应当非唯无记，而兼通善恶二性了。二者五根唯有执受，业则不定有无。例如身业有执受，语、意二业则无。如何业种就是五根？若执业种为根，那五根就不一定唯有执受了。三者在五蕴里，五根为色蕴所摄，业为身、语、意造作的行蕴所摄。如何五根能做业种？若执五根为业，那五根就不是色蕴所摄，而是行蕴所摄了。四者五根在内外根尘十处里，唯属内根五处，业通外尘色、声、法处。因此业种不可能就是五根。若执业种就是五根，那五根就不是唯属内五处了。五者五根在欲界一地、色界四地等五地都有。鼻、舌二识业唯欲界有，眼、耳、身三识业唯在二地。如此则业种怎能就是五根？若执业种就是五根，那鼻、舌二识业，就应同二根一样是五地都有，而不是唯在欲界了。眼、耳、身三根，也应同三识业一样唯在二地，而不是五地都有。

    六者如果感五识业种是五根的话，那感意识业种的，就应该是第七意根末那了，此说非理。七者眼等五根通识业种子，亦通现行。若执根唯业种，而无现行，如何五根能通现种。八者眼等五根，是有质碍的色法，身、语、意三业，是意识相应的思心所法。若执业种就是五根，那眼等五根，就不是有碍的色法了。九者五识通善、恶、无记三性，业种的五根，唯是无记。若执五识都是业种的五根所感，那五识就应当唯属无记，而不是通于善恶二性了。十者若说无记性的五识，是业种的五根所感；善恶等的五识，则非彼所感。如此说来，那五识既非业感，就应当没有眼等五根做它的俱有依了。

    论文八：又诸圣教，处处皆说，阿赖耶识变似色根、及根依处器世间等，如何汝等拨无色根？许眼等识变似色等，不许眼等藏识所变，如斯迷谬深违教理。然伽它说种子功能名五根者，为破离识实有色根，于识所变似眼根等，以有发生五识用故，假名种子及色功能。非谓色根即识业种。

    讲解：以下仍是第二家被斥第一家的言说：很多经论上都说：第八阿赖耶识变现了似是而非的色根，及根所依的身处，与国土世界。为什么你们拨无色根，只许由眼等五识变似色等五境，而不许眼等五根，为阿赖耶藏识所变呢？像这样迷失了根本的藏识，谬执五识的种子就是五根，岂非深违教理？然而《观所缘缘论》的颂中，虽有‘种子功能，名为五根’的话，但那是为破小乘经部所执‘离本识外，有实色根’而说的。因为阿赖耶识所变的眼等五根，有发生五识的功用，所以《二十唯识颂》假名为‘种子’，《观所缘缘论》假名之为‘功能’。并不是说色根就是能生五识的业种。

    论文九：又缘五境明了意识，应以五识为俱所依，以彼必与五识俱故，若彼不依眼等识者，彼应不与五识为依，彼此相依势力等故。又第七识虽无间断，而见道等既有转易，应如六识有俱有依。不尔，彼应非转识摄，便违圣教转识有七，故应许彼有俱有依。此即现行第八识摄。如瑜伽说：有藏识故，得有未那，末那为依，意识得转。彼论意言：现行藏识为依止故，得有未那，非由彼种。不尔，应说有藏识故，意识得转。由此彼说理教相违。是故应言前五转识，一一定有二俱有依，谓五色根、同时意识。第六转识，决定恒有一俱有依，谓第七识。若与五识俱时起者，亦以五识为俱有依。第七转识，决定唯有一俱有依，谓第八识。唯第八谓恒无转变，自能立故，无俱有依。

    讲解：以上讲前五识的俱有依，往下讲六、七、八识的俱有依。又，缘五境的明了意识，应以五识为俱有依。因为它必定与前五识俱起，同缘现境之故。倘若意识不依五识，也应不与五识为依，这样怎能缘境？应知五识必依意识而生，意识必依五识明了，它们彼此相依的势力是均等的。

    又第七识虽无间断，然而行人在由见道位到修道位的过程中，不能不由有漏转易为无漏。既有转易，就应当同六识一样的有俱有依，否则，那第七识就不是转识所摄了。这便与经论上‘转识有七’的圣教相违。因此我们应当许可第七识也有俱有依，这俱有依就是现行的第八识。怎知第七识的俱有依是现行的第八识，而不是它的种子呢？《瑜伽论》上说：‘有藏识故得有未那，末那为依，意识得转’。论中的意思明显的是说：由于有了现行的第八藏识作依止故，所以才有第七识的末那，并不是由它的种子。否则论中应当直说为‘有藏识故，意识得转’了。因比它们所说，与理、教相违。因此，前五转识决定各有两个俱有依，一个是五色根，一个是同时而起的意识。第六转识决定有一个第七识做它的俱有依，若和五识俱起的时候，那就也要以五识为俱有依了。第七识决定唯有一个第八识为俱有依，更无第二。七转识都须要有俱有依，唯独恒无转变，而能自立的第八识不须要。

    论文十：有义，此说犹未尽理。第八类余既同识性，如何不许有俱有依？第七、八识既恒俱转，更互为依，斯有何失？许现起识以种为依，识种亦应许依现识。能熏异熟为生长住依，识种离彼，不生长住故。又异熟识，有色界中能执持身，依色根转，如契经说：阿赖耶识业风所飘，遍依诸根恒相续转。瑜伽亦说：眼等六识各别依故，不能执受有色根身。若异熟识不遍依止有色诸根，应如六识非能执受，或所立因有不定失。是故藏识若现起者，定有一依谓第七识。在有色界亦依色根，若识种子定有一依，谓异热识。初熏习位亦依能熏，余如前说。

    讲解：这是第三家净月的说法，它认为第二家所说虽较第一家为胜，但也未尽合理。第八识既和其余七转识同属识性，何以许七转识有俱有依，不许第八识也有俱有依呢？第七、八二识既然都是恒时俱转，应许第七依第八、第八依第七，更互为依有何过失？

    既许现行识以种子为依，那种子识亦应当以现行识为依。有人问曰：种现相望，在前面的解释说是因缘，何以这里又说亦应为依？答：现行有二，一是能熏识，二是异熟识。能熏的现行识，是新熏种子的‘生’依、本有种子的‘长’依。这可以说是因缘。异熟的现行识，不能熏成种子，只是种子的‘住’依，而不是因缘。假定识的种子，离开了这能熏识和异熟识的二种现行，便不能使种子生起、增长、相续而住。

    再者，异熟识在欲、色界里，也能执持身命，依色根转，这有经论为证。例如《楞伽经》说：阿赖耶识，为宿世业风所飘，普遍的依止有色诸根，恒相续转。《瑜伽论》上也说：眼等六识，因为是各自依各自的根，而不是遍依诸根之故，所以它们不能执受有色根身。如果异熟识，不是遍依有色诸根，就应当同六识一样的不能执受。若说不遍依也能执受的话，那论中所说的‘各别依’，就不一定是不能执受根身的原因了，这便犯了因明论理的不定过失。因此第八藏识，若在三界现起，决定有一依止，这依止就是第七识。但在欲、色界里，除依第七识外，还得依止色根。这是说第八识的现行，若是识的种子，在住位也决定有一依止，这依止就是现行的异熟识。但在最初的熏习位时，除依异熟识外，也还得依能熏的现行识。这与前面第二家所说有别，余义皆同。

    论文十一：有义，前说皆不应理。未了所依与依别故。依，谓一切有生灭法，仗因托缘而得生住，诸所仗托皆说为依，如王与臣互相依等。若法决定、有境、为主、令心心所取自所缘，乃是所依，即内六处。余非有境定为主故。此但如王，非如臣等。故诸圣教，唯心心所名有所依。非色等法，无所缘故。但说心所心为所依，不说心所为心所依，彼非主故。

    讲解：这是第四家护法论师的正义。他指斥前面三家的说法都不合理，因为它们都不了解‘所依’与‘依’的差别。什么叫做‘依’：是一切有生灭变化的有为法，仗因托缘使本无得生，本有得住，不问亲疏，只要是所仗托的因缘，都叫做‘依’。好像国王和大臣互相依靠一样；什么叫做‘所依’？如果事物具备了决定、有境、为主、令心心所取自所缘的四个条件，就是‘所依’。也就是内六处──眼、耳、鼻、舌、身、意内六根。因为除六根外的其它事物，非有境、非决定、非为主。若以譬喻来说，这‘所依’义，只可喻之如王为臣之所依，非如臣等为王所依。所以经论上说，只有心、心所法称为有所依，色法等不能称为有所依。因为色法既无缘境之用，当然也无所缘之境。所以只能说心所以心为所依，不能说心所为心之所依。

    论文十二：然有处说依为所依，或所依为依，皆随宜假说。由此五识俱有所依，定有四种：谓五色根、六、七、八识。随缺一种必不转故。同境、分别、染净、根本，所依别故。圣教唯说依五根者，以不共故。又必同境近相顺故。第六意识，俱有所依，唯有二种：谓七、八识，随缺一种必不转故。虽五识俱，取境明了，而不定有，故非所依。圣教唯说，依第七者染净依故。同转识摄近相顺故。第七意识，俱有所依但有一种，谓第八识。藏识若无定不转故，如伽他说：阿赖耶为依，故有末那转；依止心及意，余转识得生。

    阿赖耶识俱有所依，亦但一种，谓第七识。彼识若无，定不转故。论说藏识恒与末那俱时转故。又说藏识恒依染污，此即末那。而说三位无末那者，依有覆说，如言四位无阿赖耶，非无第八，此亦应尔。虽有色界亦依五根，而不定有，非所依摄。识种不能现取自境，可有依义而无所依。心所所依随识应说，复各加自相应之心。若作是说，妙符理教。

    讲解：然而有许多经论上说，依即所依，所依即依。例如：本论在前面‘略释三依’中，就是把因缘依、增上缘依、等无间缘依这三依，说成诸心、心所的三种‘所依’了。何以这里定以内六处为‘所依’呢？当知那是随情随文的权宜之说。因此，诸心心所，或多或少，俱有所依，各识的所依如下：

    前五识的所依有四：一者五根的同境依。二者第六识的分别依。三者第七识的染净依。四者第八识的根本依。这四者随缺一种，那五识必不能转。何以故，五识必须依托五根，去同缘现境，所以五根是五识的同境依。五识本身没有分别，它必须藉著第六意识分别外境，所以第六意识是五识的分别依。五识非染非净，它必须随著第七识的染净以为染净依，所以第七识是前五识的染净依。第八阿赖耶识是一切识的根本，当然也是五识的根本依了。因为这四依义各有别，所以随缺一依，五识不转。既然五识有四种所依，何以圣教唯说依五根，不说依六、七、八识呢？那是因为唯有五识以五根为依，不共余识；它们又是同缘现境，此起疏远的余依来，不但相近，而且随顺之故，所以唯说以五根为依，其余约三依则略而不说。

    第六意识的所依有二，为第七识和第八识。这二依若缺其一，第六意识也决定不转。问：五识既以意识为分别依，意识亦应以五识为依才对，何以但说依七、八二识，而不说依五识呢？答：虽然五识与意识同缘现境，分别明了，但那是不一定的。五识不起时，意识亦有，所以五识但有依义，而非所依。

    第七识的所依，唯有第八识一种。如果没有第八藏识，那第七识也决定不能转起。如《楞伽经》颂中所说：‘阿赖耶为依，故有末那转；依止心及意，余转识得生。’第七末那以阿赖识为依止，所以才有末那的转起，依止第八的心，第七的意，其余的六转识才能够生起。

    第八阿赖耶识的所依，也只有第七识的一种。如果没有第七识，那第八识也决定不能转起。虽然《唯识三十颂》中说：阿罗汉、灭尽定、出世道，这三位没有末那，但那是依无覆无记来说的。因为这三位已竟没有隐覆圣道的妄惑了，所以说没有末那，并不是没有第七识体。这有如说声闻、独觉、不退菩萨、如来，这四位没有我爱执藏的阿赖耶一样，并非连第八识体都没有。

    有色界的第八识，虽也以五根为依，但不定有，所以五根不是所依。阿赖耶识的种子不能现缘自境，但有‘依’义而没有‘所依’。心所的所依又将如何？那只有随顺识而说，还要各加具自己相应的心法，即相应依。照这样说，就符合佛教的道理。

    论文十三：后开导依。有义，五识自它前后不相续故，必第六识所引生故，唯第六识为开导依。第六意识自相续故，亦由五识所引生故，以前六识为开导依。第七八识自相续故，不假它识所引生故，但以自类为开导依。

    讲解：所依门的三依为因缘依、增上缘依、等无间缘依，增上缘依又名俱有依，均已诠释，此下解释等无间缘依。等无间缘依亦名开导依，此有三家不同异说。第一家难陀等以为，前五识的生起唯一刹那，不能使前一刹那的自类，分后一刹那的他类，相续无间，因此它必须靠第六意识引生，所以只有第六意识为开导依。第六意识，一则有前后相续的自力，二则也可以由五识所引生。第七识和第八识自己本身可以相续不断，不用借助其他识所引生，只以自类为开导依。

    论文十四：有义，前说未有究理。且前五识，未自在位遇非胜境，可如所说。若自在位，如诸佛等，于境自在，诸根互用，任运决定，不假寻求，彼五识身宁不相续。等流五识既为决定染净作意势力引生，专注所缘未能舍顷，如何不许多念相续？故瑜伽说：决定心后方有染净，此后乃有等流眼识善不善转，而彼不由自分别力，乃至此意不趣余境。经尔所时眼、意二识，或善或染相续而转。如眼识生乃至身识应知亦尔。彼意定显经尔所时，眼、意二识俱相续转。既眼识时非无意识，故非二识互相续生。

    讲解：第二家安慧认为：前说并不尽理，前五识在没有得到自在无碍前的凡位，所遇的境界必非殊胜，这可以如你所说，五识唯一刹那，不能相续。倘若到了自在无碍的圣位，诸佛菩萨都能对境自在，五根互用，眼可闻声，耳可见色，并不须要假藉意识的推求，便能任运决定恒缘之境；像这佛菩萨的五识身，怎能说它不是相续无间？

    等流心后的五识，既为决定、染净、作意，这一连串势力所引生，专精贯注于所缘一境。如观佛像，意识和眼识，都不曾顷刻舍离，如何不许是多念相续？所以《瑜伽论》上说：决定心后，才有染、净，此后才有等流眼识或善或不善的转起。然眼识流转，并非由眼识自己的分别能力，而是出第六意识所引生。在这意识专注所缘，不趣向于另一余境的经过时间，眼识和意识，它们或善或恶，都是相续而转。以此类推，乃至身识，应知也是这样的。《瑜伽论》所说的意思，一定是显示在缘境经过的那段时间，眼识和意识是同时相续而转的。既然有眼识时也有意识，可见这眼、意二识，并不是你开导我，我开导你，这样更相翻递的相续而生。

    论文十五：若增盛境相续现前，逼夺身心，不能暂舍，时五识身理必相续。如热地狱，戏忘天等。故瑜伽言，若此六识，为彼六识等无间缘，即施设此，名为意根。若五识前后定唯有意识，彼论应言：若此一识为彼六识等无间缘；或彼应言若此六识为彼一识等无间缘。既不如是，故知五识有相续义。

    讲解：在平常的情况下，五识是有间断的，若遇强烈的外境连续出现，能逼夺身心使之不暇顷刻暂舍，这时的五识身必然是相续无间。例如八热地狱的苦盛，戏忘天的乐盛，这苦乐的盛境，逼夺著罪福人的身心，他如何能够暂舍，使五识不续呢？所以《瑜伽论》上说：如果前念的六识做后念六识的等无间缘，虚假施设以这前念引生后念的名叫做意根。据此可知，六识是各自为各自引生，并不是互相引生。倘若五识前后一定有意识夹杂，互相引生的话，那论上就应当说以前念一识，为后念六识的等无间缘；或者说以前念六识，为后念一识的等无间缘。论上既然不是这样说，所以我们知道，五识身并不须要意识引生，它自有前后相续的意义。（注：戏忘天，又作戏忘念天、游戏忘念天。此界天众因耽著於戏乐，而忘失正念，由彼处退没，故称戏忘念天。或谓此天为三十三天，或夜摩天；或为欲界六天中上之四天，诸说不一。）

    论文十六：五识起时，必有意识能引后念意识令起，何假五识为开导依？无心、睡眠、闷绝等位，意识断已后复起时，藏识末那既恒相续，亦应与彼为开导依。若彼用前自类开导，五识自类何不许然？此既不然，彼何云尔？

    讲解：五识生起时，必有意识和它同时俱起，即此意识，便能引生后念意识，使之相续，何必要假藉五识来做开导依呢？在灭尽定、无想定、无想天、熟睡、闷绝，这五无心位时，意识就间断了。到后来出无心位时，意识再起，这时的第八藏识，及第七末那，既是相续无间，就应当给间断的意识做开导依。若谓无心位的意识，可用它前念的自类为开导依，不假七、八二识的话，那为什么不许五识也以自类为开导依，不假第六意识呢？既不许五识自类开导，何以许无心位的意识，是自类开导？

    论文十七：平等性智相应末那初起，必由第六意识，亦应用彼为开导依。圆镜智俱第八净识初必六七、方便引生。又异熟心依染污意，或依悲愿相应善心。既尔，必应许第八识亦以六、七为开导依。由此，彼言都非究理。应说五识，前六识内随用何识为开导依。第六意识用前自类或第七、八为开导依。第七末那，用前自类或第六识为开导依。阿陀那识用前自类及第六、七为开导依。皆不违理，由前说故。

    讲解：与平等性智相应的末那识，最初转依生起时，须假藉著有漏意识才能生起，并用它为开导依。大圆镜智与第八净识同时俱起，最初必定先由第六意识转为妙观察智，第七识转为平等性智，藉著这二智的方便，才能引生。就是尚未转成大圆镜智的异熟心：或异生之类，依染污意，或菩萨十地，依悲愿相应的善心，这异熟心才得生起。所以第八识也应以六、七二识为开导依。因此，彼第一家所说，都不是究竟的道理。

    既然彼说非理，那就应当照我们这样说：五识，在前六识的范围里，随便用那个识，都可以做它的开导依。第六意识，可以用它前念的自类，或第七、八二识为开导依。第七末那，可以用它前念的自类，或第六意识为开导依。第八阿陀那识，可以用它前念的自类，或第六、七二识为开导依。唯有这样说才不违背正理。

    论文十八：有义，此说亦不应理，开导依者，谓有缘法、为主，能作等无间缘。此于后生心、心所法开辟引导，名开导依。此但属心，非心所等。若此与彼无俱起义，说此与彼有开导力，一身八识既容俱起，如何异类为开导依？若许为依应不俱起，便同异部心不并生。又一身中诸识俱起多少不定，若容互作等无间缘，色等应尔，便违圣说等无间缘唯心、心所。然摄大乘说色亦容有等无间缘者，是纵夺言，谓假纵小乘色、心前后有等无间缘夺因缘故。不尔，等言应成无用。若谓等言非遮多少，但表同类，便违汝执异类识作等无间缘。是故八识各唯自类为开导依，深契教理。自类必无俱起义故。心所此依，应随识说。

    讲解：这是第三家护法论师的正义。它说：所谓开导依者，必须具有如下三个条件，一是‘有缘法’，就是对境有缘虑作用的心法，而不是没有缘虑作用的色法。二是‘为主’，就是有自在力用的心王，而不是不能自主的心所。三能作等无间缘，只限自类识前念心王对后念的心、心所法开辟前路，引导令生，所以名叫开导依。因此开导依但属心王，而不是心所和色法。

    如果此识与彼识，是前后刹那，而不是同时俱起，倒还可说此识与彼识有开导力。既许一身八识同时俱起，为什么以异类的识为开导依呢？若许以异类为开导依，八识就不应同时俱起了。这就和小乘有部所说六识不俱起的理论相同了。一身中诸识俱起，多少不定，既非前后一法，岂得谓等？若许它们这些多少不等的识，能够互为等无间缘，那根境十处的色法，岂不是也可以互为等无间缘了吗？如此便与经论所说：‘等无间缘，唯是心法，而非色法’的话相违背了。

    然而《摄大乘论》说：色等也允许等无间缘，那是纵夺的话。纵是宽假一时；夺是拨无之义。因为小乘执著没有第八阿赖耶的种子识，但以前念色法，为生后念心法的因缘；或前念心法，为生后念色法的因缘。大乘为拨斥这色、心前后互为因缘的迷执，所以才这样说：纵令色、心前后有缘，也不过是等无间缘而已，那有因缘的意义呢？实际上，并不是说色法有等无间缘。

    如果不是这样解释，那等无间缘的‘等’宇就没有用了。因为前后各有一法，自类相似，才可以叫做‘等’。今色、心前后，多少不定，又不是相似的自类，这‘等’字要它何用？所以，八识唯各以其自类的前念，为引生后念的开导依。这才契合了教理。因为自类的前后念，必定没有同时俱起的意义。至于心所的开导依，应各随其本识心王而说，心王怎样，它也怎样。

    论文十九：虽心、心所异类并生，而互相应，和合似一，定俱生灭，事业亦同，一开导时余亦开导，故展转作等无间缘。诸识不然，不应为例。然诸心所非开导依，于所引生无主义故。若心、心所等无间缘各唯自类，第七、八识初转依时，相应信等此缘便阙，则违圣说，诸心、心所皆四缘生。无心、睡眠，闷绝等位意识虽断，而后起时彼开导依即前自类，间断五识应知亦然，无自类心于中为隔名无间故，彼先灭时已于今识为开导故，何烦异类为开导依？然圣教中说前六识互相引起，或第七、八依六、七生，皆依殊胜增上缘说，非等无间，故不相违。瑜伽论说：若此识无间，诸识决定生，说此为彼等无间缘。又此六识为彼六识等无间缘，即施设此名意根者，言总、意别亦不相违。故自类依，深契教理。

    讲解：有人问曰：假使八识同时俱起，不能作等无间缘，那心王和心所也是同时俱起，也应当不可以作后念的等无间缘了。答曰，那不可以为例，虽说心王和心所也是异类并生，但当它们相应和合生起的时候，好像王、所不分，决定俱生俱减，所作取境的事业也是相同。当一个心王做开导时，其余和它相应的心所也一齐来作开导。所以心王和心所之间有五个条件：一者相应。二者和合似一。三者俱生灭。四者事业同。五者开导同。异类的识不具此五义，不能为例。诸心所法，做等无间缘则可，做开导依则不可。因为‘缘’的意义为‘由’；而‘依’的意义为‘主’。心所在引生后念上，它只有缘‘由’的一分功用，而没有依‘主’的意义。

    问：心王既能自类引生，心所也应当能自类引生，为什么要心王做心所的开导，才叫做等无间缘？答：如果心王引心王，心所引心所，这样各引各的自类，那第七、八二识，最初转依二障，得二胜果时，不是就没有和它相应的‘信’等十一个善心所，来做等无间缘了吗？如此，则四缘阙一，便违背圣教所说：诸心心所，都是因缘、等无间缘、所缘缘、增上缘这四缘所生了。

    问：出无心位时，再起的第六意识，不是以恒转的七、八二识为开导依吗？怎能说是自类？答：在睡眠、闷绝、灭尽定、无想定、无想天，这五无心位的意识虽已间断；然而到后来出无心时的意识再起，它的开导依，并不是七、八二识，还是它先前入无心位时的自类。因为自类心从前念到后念，无论历时多久，并没有它识从中间隔，所以才名叫无间。它在前念灭时，已经让出位置给今识做了开导，何必麻烦异类的七、八二识来做开导依呢？

    问：圣教中说，前六识互相引生，或第七依第六，第八依第七：这异类为依，岂不与自类相违？答：不违，圣教所说都是依殊胜的增上缘说的，并不是等无间缘，所以不违。

    《瑜伽论》上说：如果此识无间，诸识决定生起，说此为彼等无间缘。而且此六识是彼六识等无间缘，即施设此六识名意根。这里的‘此’字，是指自类的前念而言：‘彼’字是指自类的后念而言，并不是异类相望，而言彼此。若一识以自类前后为等无间缘，六识生时，也各以其自类前后为等无间缘。这等无间缘，是意识分别的根本，所以也叫它名‘意根’。言虽总括六识，而其意趣却别说六识自类各各相望。言总意别，并不相违。所以自类依，深契教理。

    论文二十：傍论已了，应辨正论。此能变识虽具三所依，而依彼转言但显前二。为显此识依缘同故。又前二依有胜用故。或开导依易了知故。

    讲解：本章的正论是辩解第二能变识。为广释所依，把问题牵涉到诸识的傍论。现在傍论已了，应辨正论。这第二能变的第七识，虽具有因缘依、增上缘依、等无间缘依三种所依，然而颂中所说那‘依彼转’的话，但显前二，而不显后一。这有三种原故：一者为显第七识依第八种子识，为生法因缘；复缘此种子及现行为俱有依，所依即所缘故。二者前二依的因缘依，有亲生的胜用；俱有依，有亲近的胜用。后一的开导依则无此胜用。三者或因后一的开导依容易了知，所以略而不说。前二的因缘依、增上缘依，隐微深密，故但说之。


第三章　所缘门

    第三章　所缘门

    论文一：如是已说此识所依，所缘云何？谓即缘彼。彼谓即前此所依识，圣说此识缘藏识故。有义：此意缘彼识体及相应法，论说末那我、我所执恒相应故。谓缘彼体及相应法，如次执为我及我所，然诸心所不离识故，如唯识言无违教失。有义：彼说理不应然。曾无处言缘触等故。应言此意但缘彼识见及相分，如次执为我及我所。相、见俱以识为体故，不违圣说。有义：此说亦不应理。五色根、境非识蕴故。应同五识亦缘外故。应如意识缘共境故。应生无色者，不执我所故。厌色生彼不变色故。应说此意但缘藏识及彼种子，如次执为我及我所。以种即是彼识功能，非实有物，不违圣教。

    讲解：此下是思量能变的‘所缘门’。第七识的所缘是什么呢？就是颂中所说的‘缘彼’二字，彼就是其所依的第八阿赖耶识。因为经论上说，第七识的所缘之境，就是第八藏识之故。所以知道第七识的所缘，不是外境，而是它自己所依之境。然此有如下四家异说：第一家难陀诸师说：这第七识所缘的境是第八识体，及与第八识相应的五遍行心所。因为《瑜伽论》和《显扬圣教论》上都这样说：第七末那识，与我执和我所执恒相应故。

    第二家火辨诸师说：前面所说于理不当，经论上曾无一处说过，第七识缘触等心所的话。我等认为第七识但缘第八识的见分和相分，执见分为我，相分为我所。因为相、见二分，都是以识为体的，所以与圣教所说‘缘识’，并不相违。

    第三家安慧诸师说：前面说缘见、相二分也不合理，因为相分是属于色蕴的的五根五境，而不是为识蕴所摄，若以相分为所缘，便有下列三种过失：一者第七识如果缘相分，就应同前五识一样的缘五尘外境。二者意识遍缘五尘，名叫‘缘共境’，第七识如也缘五尘，岂非同意识缘共境一样吗？三者无色界无色，当然也没有相分可缘。那生到无色界的有情，如何执有我所？它本为厌离色界而生无色界，怎肯再变成色而为所缘？因此，应当说第七识只缘阿赖耶识及其种子，按照次第执为我和我所。因为种子是阿赖耶识的现识功能，并非实有之物，体是假有，所以这样才不违圣教。

    论文二：有义，前说皆不应理，色等种子，非识蕴故。论说种子是实有故。假应如无，非因缘故。又此识俱萨迦耶见，任运一类恒相续生，何容别执有我、我所？无一心中有断常等，二境别执俱转义故。亦不应说二执前后，此无始来一昧转故。应知此意，但缘藏识见分非余。彼无始来一类相续，似常一故，恒与诸法为所依故。此唯执彼为自内我，乘语势故说我所言，或此执彼是我之我，故于一见义说二言。若作是说善顺教理。多处唯言有我见故。我、我所执不俱起故。

    讲解：这是第四家护法论师的正义。它认为前三家说的都不合理，因为无论是色的种子或识的种子，总归都是种子，而不是所缘的识蕴。而且论上说，种子是实有法，若是假法，岂不等于无法一样？试问它怎能为现行果法的因缘？再者，这第七识的我见，并非由分别间断而起，而是任运一类相续而生，如何容许它有‘我’和‘我所’的二境别执呢？这好像一念心中，不能有断、常二境的别执俱起一样。也不可说这二执是前念执我、后念执我所。因为第八识自无始以来，只是一味转起，并没有前后二别。

    因此，我们应知：第七识但缘第八识的见分，不缘余法──相分、种子、心所。因为余法不是多类而非一，便是间断而非常。唯有藏识的见分，无始时来一类相续，虽非常一，而似常似一，它恒与一切法为所依止。所以这第七识，唯有执彼藏识的见分，而执为自内之我。

    至于论中说有‘我’和‘我所’的话，那不过是乘著语势之便所说而已。譬如：说军为军队，国为国家，都是乘著语势而说的，并不是军外有队，国外有家。说我、我所，亦复如是，并不是我外有所。或者，这第七识，执彼第八识是我的我。以前我为五蕴假合，后我为第七识所执。因此，在一念的我见上，就随义说出我及我所的两种话来，其实还不是一个我见吗？如果照这样说，就顺乎教理了。因为有很多经论上，唯说有我见，不说有我所。有了我执，就不能有我所执，它们是不能一念俱起的。

    论文三：未转依位，唯缘藏识，既转依已，亦缘真如及余诸法，平等性智，证得十种平等性故。知诸有情胜解差别，示现种种佛影像故。此中且说未转依时，故但说此缘彼藏识。悟迷通局理应尔故。无我我境遍不遍故，如何此识缘自所依，如有后识即缘前意。彼既极成此亦何咎？

    讲解：转依是转第八识的有漏种子，得无漏智，即名为‘转依’。凡夫位的第七识在未转依前，唯缘第八藏识。在初地转为下品平等性智，那就也缘真如及其余的一切法了。因为已转第七识的我见为平等性智，证得了十种的平等性。所以它能够知道九界有情胜解意乐的差别，随其所应，示现佛的受用身土，种种影像。

    论中是约未转依时来说的，所以但说缘第八藏识，不说遍缘一切法。因为转依为悟、为通，未转依为迷、为局，理应然故。悟时通达无我，故能遍缘诸境。迷时局于有我，则缘境不遍，那就只有缘第八藏识的见分了。

    再者，长行中‘缘彼’的‘彼’，就是所依。为什么第七识的所依与所缘，都是第八识呢？答曰：例如第六识缘前等无间缘意，即是缘其所依。彼既为大小乘教所共许，此第七识缘其所依的第八识，应无过失。（注：十种平等性，一者诸相增上喜爱。二者一切领受缘起。三者远离异相非相。四者弘济大慈。五者无待大悲。六者随诸有情所乐示现。七者一切有情敬爱所说。八者世间寂静皆同一味。九者世间诸法苦乐一味。十者修植无量功德究竟。）


第四章　体性行相门

    第四章　体性行相门

    论文一：颂言：思量为性相者，双显此识自性、行相。意以思量为自性故，即复用彼为行相故。由斯兼释所立别名。恒审思量名末那故。未转依位，恒审思量，所执我相，己转依位，亦审思量无我相故。

    讲解：第三‘所缘门’讲解完毕，现在讲解第四的‘体性门’，及第五的‘行相门’。颂中说‘思量为性相’，这句话是双显第七识的体性和行相。此识的体性和行相都是思量。由此思量的性相二义，再把末那一名附带作一解释：八识通名心、意、识，都有思量，为什么第七识别名末那──意呢？那是因为它的思量独具有‘恒审’的特性之故。在未转依位的初地以前，二乘有学，恒审思量著所执的我相；已转依位的初地以上，也恒审思量著无我相。可见末那这个名，是兼通无漏。


第五章　合解染俱相应二门

    第五章　合解染俱相应二门

    论文一：此意相应有几心所？且与四种烦恼常俱。此中俱言，显相应义。谓从无始至未转依，此意任运恒缘藏识，与四根本烦恼相应。其四者何？谓我痴、我见，并我慢、我爱，是名四种。我痴者，谓无明，愚于我相，迷无我理，故名我痴。我见者，谓我执，于非我法妄计为我，故名我见。我慢者，谓倨傲，恃所执我，令心高举，故名我慢。我爱者，谓我贪，于所执我，深生耽著，故名我爱。并表慢、爱有见、慢俱。遮余部执无相应义。此四常起，扰浊内心，令外转识恒成杂染，有情由此生死轮回不能出离，故名烦恼。

    讲解：本章合解第六‘染俱’，和第七‘相应’门。问：此第七识的相应的心所有几？答：且说和它常俱的烦恼有四种，‘俱’字是相应的意思。就是说，从无始以来，到未转识成智以前，这第七识任运恒缘第八藏识，和四种根本烦恼相应。这就是颂文的‘四烦恼常俱’一句。四烦恼是我痴、我见、我慢、我爱。我痴就是无明愚昧，对虚幻不实的我相，执为实我，迷失了无我的真理，所以名叫我痴。我见就是我执，对非我的五蕴之法，妄执为我，所以名叫我见。我慢就是倨傲，仗恃著我执的我，令心高举，睥睨一切，所以名叫我慢。我爱就是我贪。对所执的我，深深的生起了耽悦的执著，所以名叫我爱。‘并’字是表示慢、爱与见，见、慢与爱，三法俱起。遮简小乘萨婆多等，三法互不相应，各自为政的主张。这是解释颂文的六、七两句，‘谓我痴我见，并我慢我爱’。

    因为这四种烦恼，把第七识的内心扰乱得溷浊不清。所以六转识也成了三性的有漏杂染。有情就是因此造业受报，轮回于生死苦海，不得出离。所以名为烦恼。

    论文二：彼有十种，此何唯四？有我见故，余见不生。无一心中有二慧故。如何此识要有我见？二取邪见但分别生，唯见所断，此俱烦恼唯是俱生，修所断故。我所边见依我见生。此相应见不依彼起。恒内执有我，故要有我见。由见审决，疑无容起。爱著我故，嗔不得生。故此识俱烦恼唯四。见、爱、慢三，如何俱起？行相无违，俱起何失。瑜伽论说．贪令心下，慢令心举，宁不相违？分别俱生，外境内境，所陵所恃，粗细有殊，故彼此文，义无乖返。

    讲解：外人问：根本烦恼总有十种，是贪、嗔、痴、慢、疑、身见、边见、邪见、见取见、戒禁取见。为什么与第七识相应的只有四种？答曰：因为有了我见，就不能再有其余四见生起。见有审决之慧，没有一念心中，同时具有两种见解的。

    外人再问：为什么第七识不起余见，而起我见呢？因为见取、戒取、邪见，这三见都是起于后来的意识分别，见道即断。常俱烦恼，则是由无始时来与身俱生，一直到修道位才能断除。至于我所见的断、常边见，又是由我见而生。因此，第七识并非依见取、戒取、邪见、边见这四见相应而起，而是任运缘内，执藏识以为有我，所以第七识唯起我见。

    由于我见的审察决定之故，犹豫不决的‘疑’就无容生起。因为贪爱顺著我故，嗔也不得而生。所以与第七识相应的根本烦恼，唯有痴、见、慢、爱四种。

    外人复问：那见、慢、爱三法，如何能同时俱起？论主答：这三法的行相不相违背，同时俱起无失。外人又问：《瑜伽论》上说，贪能令心卑下，慢能令心高举，怎能说不是相违？论主再答：《瑜伽论》的话有三种解释，一者分别起与俱生起不同，由意识分别而起的贪、慢，势力粗猛，可以说是相违；与生俱起的贪、慢，微细相续，所以不违。二者外境内境不同，若缘外境，贪则心下，慢则心举，可以说是相违。若缘内境，对自身的贪爱，心不卑下而我慢自高，所以不违。三者所陵所恃不同，若欺陵它人，但起高慢而无贪下，可以说是相违。若因自恃而起贪爱，心必高慢，所以不违。第七识的贪、慢，在这三种释义里是属于俱生、缘内、自恃，故不相违。

    论文三：此意心所唯有四耶？不尔，及余触等俱故。有义，此意心所唯九，前四及余触等五法，即触、作意、受、想与思，意与遍行定相应故。前说触等异熟识俱，恐谓同前亦是无覆，显此异彼故置余言。及是集义。前四后五合与末那恒相应故。

    此意何故无余心所？谓欲希望未遂合事，此识任运缘遂合境，无所希望，故无有欲。胜解，印持曾未定境。此识无始恒缘定事，无所印持故无胜解。念唯记忆曾所习事，此识恒缘现所受境，无所记忆，故无有念。定唯系心专注一境。此识任运刹那别缘，既不专一，故无有定。慧即我见，故不别说。善是净故非此识俱，随烦恼生必依烦恼，前后分位差别建立。此识恒与四烦恼俱，前后一类，分位无别，故此识俱无随烦恼。恶作追悔先所造业。此识任运恒缘现境，非悔先业，故无恶作。睡眠必依身心重昧，外众缘力有时暂起，此识无始一类内执，不假外缘，故彼非有。寻伺俱依外门而转，浅深推度，粗细发言。此识唯依内门而转，一类执我，故非彼俱。

    讲解：外人问，第七识的相应心所，只有四个根本烦恼吗？答曰：不只有四，因为颂文在四烦恼下，还有‘及余触等俱’之句。但对这一余字，有两家不同异见。第一家说是烦恼之余的触等五法。第二家说是触等之余的随烦恼。

    第一家说，这第七识的心所只有九个。那就是根本烦恼四，及其余的遍行五法：触、作意、受、想、思。因为第七识和这遍行五法，决定相应之故。前说与第八异熟识相应的遍行，是无覆无记，这里与第七识相应的遍行，则是有覆无记。为恐有人误会这第七识的遍行心所，同前异熟识的遍行心所同是无覆，所以在文中安置一个‘余’字，来显示它们彼此的属性不同。‘及’是‘集’义，集前面的四烦恼，后面的五遍行，合为九个心所，与第七末那恒时相应。

    外人问：此第七识为什么只有九个心所，而没有其余的心所呢？第一家答曰：别境五法，欲心所是对于未遂合的乐事希望遂合，第七识是任运恒缘遂合境界，它没有对未遂合事的希望，所以无欲心所。胜解心所是对犹豫不定之境决定印持，第七识是无始时来，恒缘已经印持的既定之事，非先犹豫后方决定，所以没有胜解心所。念心所是记忆曾经习染之事。第七识是恒缘所受的现前境界，不须要记忆，所以无念心所。定心所是系心于专注的一境，第七识是任运别缘，前后刹那，而非专注，所以无定心所。慧心所就是我见，慧见不二，第七识既有我见，就不必再与慧心所相应了。

    善十一法，体性全是纯净无染，不是第七识俱生的有覆无记，所以没有善心所。随烦恼心所，是随在根本烦恼之后，依前后分位的差别而建立的。第七识恒与四根本烦恼俱起，它们是前后一类，没有分位上的差别。所以第七识俱生的只有根本烦恼，而没有随烦恼心所。

    不定四法，恶作是追悔先前所造的恶业，第七识是任运恒缘现境，它不是先已造业，今始追悔，所以没有恶作心所。睡眠，必定依于身心的沉重惛昧，这是由众多的外缘，如疲劳疾病等的压力所致，第七识是无始时来，一类向内执藏识为我，不假藉任何外缘，所以没有睡眠心所。寻、伺二法，都是依缘外境而生，所不同者，寻为浅的推度，发言粗疏；伺为深的推度，发言细密。第七识唯是缘内的一类我执，用不著推度发言，所以无寻、伺二心所。

    论文四：有义，彼释余义非理。颂别说此有覆摄故，又阙意俱随烦恼故，烦恼必与随烦恼俱，故此余言显随烦恼。

    讲解：第二家说：前师对‘余’字的解释并不合理，因为颂中特别的说，这触等五法是有覆无记性摄，已经简别不是异熟识俱的无覆无记了，何必要一‘余’字来简别呢？若说余字是四烦恼之余的触等五法，岂不又缺少了与第七识俱的随烦恼吗？因为根本烦恼必定与随烦恼俱，所以这个余字，指的是触等之余的随烦恼，而不是四烦恼之余的触等五法。但对此随烦恼的解释，又有四家不同的主张。

    论文五：此中有义，五随烦恼，遍与一切染心相应，如集论说：惛沉、掉举、不信、懈怠、放逸，于一切染污品中，恒共相应。若离无堪任性等，染污性成，无是处故。烦恼起时心既染污，故染心位必有彼五。烦恼若起，必由无堪任、嚣动、不信、懈怠、放逸故。掉举虽遍一切染心，而贪位增，但说贪分，如眠与悔虽遍三性心，而痴位增，但说为痴分。

    讲解：四家中的第一家说，五个随烦恼普遍与一切染心相应，在《杂集论》中上说：惛沉、掉举、不信、懈怠、放逸，这五个随烦恼，在一切染污的品类中是恒共相应的。如果没有惛沉的不堪任性，任何染污性都不能够成立。既然烦恼生起时心是染污性，所以在染心位必定有这五个随烦恼。因为烦恼的生起，必由无堪任性的惛沉、嚣动的掉举、不信、懈怠、放逸等所使然。

    问：掉举但属贪分，何以说与一切染心相应？答：掉举虽遍通一切染心，而于贪分较它增盛，所以但说掉举为贪分。这好像睡眠和追悔二法，它们虽遍通善、恶、无记三性，而于痴位较它增盛，所以但说为痴的一分。

    论文六：虽余处说有随烦恼，或六或十遍诸染心，而彼俱依别意说遍，非彼实遍一切染心。谓依二十随烦恼中，解通粗、细、无记、不善，通障定、慧，相显说六。依二十二随烦恼中，解通粗细二性，说十。故此彼说非互相违。然此意俱心所十五，谓前九法，五随烦恼，并别境慧。我见虽是别境慧摄，而五十一心所法中义有差别，故开为二。何缘此意无余心所，谓忿等十行相粗动，此识审细，故非彼俱。无惭、无槐，唯是不善。此无记故，非彼相应。散乱令心驰流外境，此恒内执一类境生，不外驰流，故彼非有。不正知者，谓起外门身、语、意行，违越轨则，此唯内执，故非彼俱。无余心所，义如前说。

    讲解：虽然瑜伽等论上说，余处有随烦恼或六种、或十种，都是遍通一切染心。但它们都是依据别种意思假说遍染，不是或六种或十种遍通一切染心。为什么呢？别有三意，一者说是依此大、中、小二十随烦恼，忿、恨、恼、覆、诳、谄、憍、害、嫉、悭，这十个小随烦恼，以粗细而论，但通粗相。无惭、无愧这两个中随烦恼，以无记、不善的二性而论，但通不善。惛沉、掉举，这两个大随烦恼，以障定、慧而论，掉举障定，惛沉障慧。唯有不信、懈怠、放逸、忘念、不正知、散乱，这六个大随烦恼，能够遍通粗、细二性，及障定慧。所以说之谓六。

    二者依二十二随烦恼说，二十随烦恼，再加邪欲和胜解，合为二十二。除但通粗相，及不善性的十二个中、小随烦恼外，其余的十个大随烦恼，遍通粗细及不善、无记二性。所以说之谓十。可见说六说十，无非都是依据别意，并不是说这六、十随惑，都能遍及一切染心。所以彼论说六说十，与唯识说五，并不相违。

    然而与第七识相应的心所，有十五个。那就是，前面所说的四个根本烦恼，及五遍行等的九法，再加上五个随烦恼，又一个别境的‘慧’。问：既有我见，何必再说有慧？答：我见虽即是慧，然而在五十一个心所法中，慧通三性，见唯染污，义有差别，故开为二。

    问：为什么第七识只有这十五个心所，而没有其余的心所呢？答：忿等十法，行相粗动；第七识审察细密，所以不和它们俱起。无惭无愧二法，唯属不善性摄，第七识是有覆无记，所以不和它们相应。散乱，令心驰流外境，间断非恒，异类非一，第七识是恒向内缘，一类所执的我境，它不向外境驰流，所以没有散乱。不正知，是起于外门的身、语、意业，违越了正知的轨则，第七识是唯向内执，所以不与彼俱。至于没有其余心所的意义，准如前说，勿庸费辞。

    论文七：有义，应说六随烦恼，遍与一切染心相应。瑜伽论说：不信、懈怠、放逸、忘念、散乱、恶慧一切染心皆相应故。忘念、散乱、恶慧若无，心必不能起诸烦恼。要缘曾受境界种类，发起忘念及邪简择，方起贪等诸烦恼故。烦恼起时，心必流荡，皆由于境起散乱故。惛沉掉举，行相互违，非诸染心皆能遍起。论说五法遍染心者，解通粗细，违唯善法，纯随烦恼，通二性故。说十遍言义如前说。然此意俱心所十九，谓前九法，六随烦恼，并念、定、慧，及加惛沉。此别说念，准前慧释。并有定者，专注一类，所执我境，曾不舍故。加惛沉者，谓此识俱无明尤重，心惛沉故。无掉举者，此相违故，无余心所，如上应知。

    讲解：第二家说，应说六个随烦恼，普遍与一切染心相应。因为《瑜伽论》上说：不信、懈怠、放逸、忘念、散乱、恶慧，这六个随烦恼与一切染心都相应之故。问：这六个随烦恼的前三种，遍与一切染心相应，已如前释。不知后三种何以也与一切染心相应呢？答：倘若没有忘念、散乱、恶慧三法，那染心位的一切烦恼必不能起。要缘曾经受过的种种境界，发起了忘念，及邪简择的恶慧，才能生起贪等的一切烦恼。烦恼起时，心必流荡，这都是由于缘境所起的散乱之故。

    问：遍染法中，何以没有惛沉、掉举？答曰：那是因为惛沉相下，掉举相高，它们的行相此起彼落，互相违反，并非于一切染心都能遍起。问：那么何以论上说，惛沉掉举等五随烦恼遍一切染心呢？答曰：因为它们的行相遍通粗细，简去唯通粗相的忿等十法。是唯违善法，简去不唯违善的散乱等法。是纯烦恼，简去亦名随惑的寻、伺、睡眠、恶作四法。是并通不善、无记二法，简去唯通不善的无惭、无愧。所以论说五法遍染，并不是一切染心都有五法。至于说十个随烦恼，遍一切染心的话，和前第一家所说的意义相同。

    然而与第七识相应的心所，有十九个。那就是：前面所说的四根本烦恼，及五遍行等的九法，再加六个随烦恼，三个别境的念、定、慧，一个惛沉。为什么在忘念的念之外，又别加上一个念呢？这与前师在我见的慧外，又别说一个慧的解释一样。见、慧有差别二义，念与忘念，也有明记、不明记的差别二义。为什么又说有定？那是因为第七识专注于一类所执的我境，无始以来，不曾暂舍之故，所以有定。为什么又要加上惛沉？那是因为第七识的无明迷执过重之故，所以要有惛沉。那么，为什么没有掉举？有惛沉就不能有掉举，它们的行相违背之故。还有其余不相应的心所，同以上第一家所说一样。

    论文八：有义：复说十随烦恼，遍与一切染心相应。瑜伽论说：放逸、掉举、惛沉、不信、懈怠、邪欲、邪胜解、邪念、散乱、不正知。此十，一切染污心起，通一切处，三界系故。若无邪欲邪胜解时，心必不能起诸烦恼。于所受境，要乐合离，印持事相，方起贪等诸烦恼故。诸疑理者，于色等事必无犹豫，故疑相应亦有胜解。于所缘事亦犹豫者，非烦恼疑，如疑人杌。余处不说此二遍者，缘非爱事，疑相应心，邪欲、胜解非粗显故。余互有无，义如前说。此意心所有二十四。谓前九法，十随烦恼，加别境五，准前理释。无余心所，如上应知。

    讲解：第三家说，有十个随烦恼，遍与一切染心相应。因为《瑜伽论》上说：放逸、掉举、惛沉、不信、懈怠、邪欲、邪胜解、邪念、散乱、不正知，这十个随烦恼，它们在一切染污心生起的时候，遍通于一切处，及三界的系缚。倘若没有邪欲及邪胜解，那凡夫的心必不能起一切烦恼。因它们对于所受的顺境要乐与之合；逆境要乐与之离。必须以胜解来印持这些事相，才能生起对顺境的贪，对逆境的嗔等一切烦恼。

    问：胜解，是决定印持。疑，是犹豫不定。这二法既然相违，如何都与一切染心相应？答：于理可疑，于事必印，凡是疑理的人，对于事实的印证，必定没有犹豫。所以与疑相应的染心，也有胜解。问：若在所缘的事上也有犹豫，则无所印持，这个疑不是就没有胜解了吗？答：那不是烦恼的疑。好像恍惚中看见一个木桩，疑是为人。问：这邪欲和邪胜解二法，如果是遍一切染心的话，何以余论不说？答：那是因为缘非所爱事，及与疑心相应的时候，这二法的行相微细，所以不说。此处粗显，所以才说。其余八个随惑的意义，在前面或第一家有第二家无；或第一家无第二家有。都同他们所说一样。然而第七识的相应心所，有二十四个。那就是：前面所说的四根本烦恼、五遍行，再加上十个随烦恼，及五个别境。其意义，准如前释。其余不相应的心所，如善十一、不定四、六根本烦恼、十小随烦恼，也都和上面的说法一样。

    论文九：有义，前说皆未尽理。且疑他世为有为无？于彼有何欲、胜解相？烦恼起位，若无惛沉，应不定有无堪任性。掉举若无，应无嚣动，便如善等非染污位。若染心中无散乱者，应非流荡非染污心。若无失念、不正知者，如何能起烦恼现前？故染污心决定皆与八随烦恼相应而生，谓惛沈、掉举、不信、懈怠、放逸、忘念、散乱、不正知。忘念、不正知、念、慧为自性者，不遍染心，非诸染心皆缘曾受，有简择故。若以无明为自性者，遍染心起，由前说故。然此意俱心所十八。谓前九法，八随烦恼，并别境慧。无余心所，及论三文，准前应释。若作是说，不违教理。

    讲解：这是第四家护法的正义。它说，前三家所说都未尽理。怀疑未来世是有是无，论说是五种疑相（它世、作用、因果、实中、诸谛）之一，怎能说疑事不是烦恼？既是烦恼，试问在这个它世有无的疑惑上，有什么希望决定的欲、胜解相？这是破彼第三家有欲、胜解的十遍染义。

    惛沉，以无堪任为性；掉举，以嚣动为性。如果烦恼起时，没有惛沉，那就不一定有无堪任性了。若有堪任，便是善性，怎能名谓烦恼？如果没有掉举，就应当没有嚣动。若无嚣动，便同善、无记一样，那就不是染污心了。这是破第二家无惛沉、掉举的六遍染义。

    散乱、失念、不正知，皆以无明为体，痴分所摄。假定染污心中，没有散乱，那就应当不是流荡，也不是染污心了。假定没有失念，及不正知二法，那如何能使烦恼现前？这是破第一家无散乱、忘念、不正知的五遍染义。

    因此，一切染心，决定都和八个大随烦恼相应而生。那就是惛沉、掉举、不信、懈怠、放逸、忘念、散乱、不正知。忘念和不正知二法，不可以别境的念、慧为它们的体性；若以念、慧为体性，那就不能遍一切染心了。因为并非一切染心，都缘曾经受过的境界，都有慧的简择。若以无明为性，那就遍与一切染心相应而生了。因此，第七识的相应心所有十八个。那就是四根本烦恼、五遍行，八个大随烦恼，再加上一个别境的慧。至于相应法中，没有的其余心所，如：别境四、善十一、根本烦恼六、小、中随烦恼十二、不定四、邪欲解二，以及所引的论文，都和前三家的解释一样。

    论文十：此染污意，何受相应？有义，此俱唯有喜受，恒内执我生喜爱故。有义，不然，应许喜受乃至有顶。违圣言故。应说此意四受相应。谓生恶趣忧受相应，缘不善业所引果故。生人欲天初、二静虑喜受相应，缘有喜地善业果故。第三静虑乐受相应，缘有乐地善业果故。第四静虑乃至有顶舍受相应，缘唯舍地善业果故。有义：彼说亦不应理。此无始来，任运一类缘内执我，恒无转易，与变异受不相应故。又此末那与前藏识义有异者，皆别说之，若四受俱，亦应别说。既不别说，定与彼同，故此相应，唯有拾受。未转依位与前所说心所相应。已转依位唯二十一心所俱起，谓遍行、别境各五，善十一。如第八识已转依位唯舍受俱。任运转故，恒于所缘，平等转故。

    讲解：这染污的第七识，在忧、喜、苦、乐、舍五受中，和那一受相应呢？此有三家异解：第一家说，第七识只和喜受相应，因为它恒向内执第八识为我，而起了对我的喜爱。

    第二家说，不然，因为经论上说，第七识是随著第八识流转到三界九地，高达于有顶天（注：有顶之名有二解，一者色界第四处色究竟天，在有形世界之最顶，称为有顶；二者无色界第四处非想非非想处，位于世界最顶，称为有顶。此处指第二说。）而喜受则仅止于色界二禅的‘定生喜乐地’。若说喜受与第七识俱，那就应许喜受亦通于有顶天。如此则与圣言相违。应当说第七识与忧、喜、乐、舍四受相应，即生到地狱、饿鬼、畜生三恶趣的，便与忧受相应，这是缘不善业所引的报果。生到欲界人、天趣，及色界的初、二禅天，便与喜受相应，这是缘有喜地的善业报果。生到第三禅天，便与乐受相应。这是缘有乐地的善业报果。生到第四禅天乃至无色界的非想非非想天──有顶天，便与舍受相应，这是缘唯有舍受的善业报果。

    第三家说：第二家所说的也不合理，因为第七识自无始来，任运一类缘内执我，从没有转变和改易，它与变异的忧、喜、苦、乐等受是不相应的。再者，凡第七末那与第八藏识，其义有别者，论中都予以别说。如果第七识与忧、喜、乐、舍四受相应，颂文也应当别说。既不别说，则第七识的相应受决定和第八藏识相同，因此和末那相应的唯有舍受。

    第七识在尚未转识成智以前，它的相应心所，与前师所说的一样。既已转为平等性智，那就唯与二十一个心所俱起，这二十一个心所是遍行五、别境五、善十一。也如第八识一样于转依位唯与舍受相应，任运而转，永远以平等性智对待所缘的对象。


第六章　三性分别门

    第六章　三性分别门

    论文一：末那心所，何性所摄？有覆无记所摄，非余。此意相应四烦恼等是染法故，障碍圣道，隐蔽自心，说名有覆。非善、不善，故名无记。如上二界诸烦恼等定力摄藏，是无记摄。此俱染法所依细故，任运转故，亦无记摄。若已转依，唯是善性。

    讲解：第七末那识及其相应心所，在善、恶、无记三性中，是那一性所摄呢？答曰：如颂文中所说‘有覆无记摄’，而非其他。因为末那识相应的贪、痴、见、慢四根本烦恼，是染污法，能障碍圣道，隐蔽了本非染污的清净自心，所以名为有覆；它不是善性，也不是恶性，所以称为无记。就像色界、无色界有情的一切烦恼，由于定力摄藏而是无记性一样，这第七识在未转依前的相应烦恼，虽无定力摄藏，而所依的心王行相微细，任运而转，所以也是无记性摄。若已转依，那就不是无记，而是唯一的善性了。


第七章　界系分别门

    第七章　界系分别门

    论文一：末那心所何地系耶？随彼所生，彼地所系。谓生欲界现行末那，相应心所即欲界系。乃至有顶应知亦然。任运恒缘自地藏识执为内我，非它地故。若起彼地异熟藏识现在前者，名生彼地，染污末那缘彼执我，即系属彼，名彼所系。或为彼地诸烦恼等之所系缚，名彼所系。若已转依，即非所系。

    讲解：界系分别门，是指第七末那识和它相应的心所，在三界九地中是系属于那一地？正如颂文所说：‘随所生所系’。即是随第八识，第八识生到那一地，它就为那一地所系属。例如第八识生到欲界，末那识和它的相应心所自然为欲界所系。以此例知，乃至生到有顶的非想非非想处地，也一样为非想非非想处地所系。因为这第七识是任运恒缘第八藏识执以为我，而不是缘其它的界地为执我故。

    倘若那一地，当前现起第八异熟藏识，就叫做‘生彼地’。染污的末那识缘彼藏识执以为我，也就系属于彼，而名为‘彼所系’了。或为彼地的一切烦恼所系缚，而名‘彼所系’，这是约第七识未转依而言；若末那识已转依为平等性智，那就不被界地所系缚了。


第八章　起灭分位门

    第八章　起灭分位门

    论文一：此染污意，无始相续，何位永断或暂断耶？阿罗汉、灭定、出世道无有。阿罗汉者，总显三乘无学果位，此位染意种及现行俱永断灭，故说无有。学位、灭定、出世道中俱暂伏灭，故说无有。谓染污意无始时来，微细一类任运而转。诸有漏道不能伏灭。三乘圣道有伏灭义。真无我解违我执故。后得无漏现在前时，是彼等流，亦违此意。真无我解及后所得俱无漏故，名出世道。灭定既是圣道等流，极寂静故，此亦非有。由未永断此种子故，从减尽定圣道起已，此复现行乃至未灭。然此染意相应烦恼是俱生故，非见所断，是染污故，非非所断，极微细故，所有种子与有顶地下下烦恼，一时顿断，势力等故。金刚喻定现在前时，顿断此种成阿罗汉，故无学位永不复起。二乘无学回趣大乘，从初发心至未成佛，虽实是菩萨，亦名阿罗汉，应义等故，不别说之。

    讲解：现在解释‘起灭分位门’。问：这染污的末那识，自无始以来永恒相续，要到什么果位才能永久断灭、或暂时断除呢？答：《唯识三十颂》中说：‘阿罗汉、灭定，出世道无有’。此处说的阿罗汉，并不是单指声闻四果而言，而是总显声闻、独觉、菩萨三乘的无学果位。因为这三乘无学位的阿罗汉，它们那染污的第七识，无论种子或现行，都永远断灭了，所以说：‘无有’。三乘有学的灭尽定，及出世的无漏圣道，也都能暂时伏断，所以说：‘无有’。

    这染污末那自无始时来，就是微细难知，一类相续，任运而转。因此世间的有漏道都不能伏灭，唯有二乘圣道的无漏心起，才有伏灭的可能。因为圣道的真无我解，违背我执；后得无漏，是无分别智的等同流类，也违背了这染污的末那。真无我解，及后所得智，都是无漏，所以名叫‘出世道’。灭尽定既是圣道的等流引生，极其寂静，所以也没有我执。然而这不过是暂时伏灭，还没有把烦恼种子完全断尽，一旦出定，烦恼就又复现行。

    然而这染污意的相应烦恼，在三断里因为是与生俱有之故，所以不是见道所断，因为是染污故，所以也不是非所断，极微细故，所以所有种子，都和有顶地下下品烦恼一时顿断，因为它的势力与智相等，唯障无学，所以一到金刚喻定，就把它们的种子一齐顿断，而成为阿罗汉了。因此无学位就永远不会再起烦恼。

    至于小乘声闻、缘觉二乘，回转小乘的根性而趣向大乘，从初发心，直到尚未成佛的过度时期，虽然实际上是菩萨，也称为阿罗汉，其义应相同，所以不另别说。（注：断乃断缚离系而得证之义，三断者，一者见道之位所断之法，二者修道之位所断之法，三者非所断，即非见道、修道之位所断之法。又作非所断之法。）

    论文二：此中有义，末那唯有烦恼障俱，圣教皆言三位无故。又说四惑恒相应故。又说为识杂染依故。有义：彼说教理相违，出世末那经说有故，无染意识如有染时，定有俱生不共依故。论说藏识决定恒与一识俱转，所谓末那。意识起时则二俱转，所谓意识及与末那。若五识中随起一识，则三俱转。乃至或时顿起五识，则七识俱转。若住灭定无第七识，尔时藏识应无识俱，便非恒定一识俱转。住圣道时若无第七，尔时藏识应一识俱，如何可言若起意识尔时藏识定二俱转？显扬论说末那恒与四烦恼相应，或翻彼相应恃举为行，成平等行，故知此意通染、不染。若由论说阿罗汉位无染意故，便无第七，应由论说阿罗汉位舍藏识故，便无第八。彼既不尔，此云何然？

    讲解：对以上所说，有两家诤论。第一家安慧说：末那识唯有烦恼障相应，因为经论上都说阿罗汉、灭尽定、出世道，这三位中没有末那。《显扬论》说，末那恒与我痴、我见、我慢、我爱四惑相应，《摄大乘论》说末那识为善、不善等的杂染法所依。所以说：‘末那唯有烦恼障俱’。

    第二家护法说：前说与教理相违。因为《解脱经》上说有出世末那，怎能说三位无末那呢？没有染污时的第六意识，也如染污时一样，它们决定各有其俱生的不共所依，就是染污时的意识，依染污末那；无染污时的意识，依出世末那。怎能说：‘末那唯有烦恼障俱’

    经论上说，第八藏识，决定恒有一识和它俱转。这个识，就是所谓第七末那识。意识起时，那就有两个识和它俱转。这两个识，就是第六意识和第七末那。若前五识中再生起一个识来，那就有三个识和它俱转。若前五识一时顿起，那当然再加意识和末那，就有七个识和它俱时而转了。因此，住灭尽定时，不可能没有第七净识。若无第七净识，这时的第八藏识，就应当没有识和它俱转。那便不是经论所说：‘藏识决定恒与一识俱转’了。住圣道时，也不可能没有第七净识。若无第七净识，这时的第八藏识，意识若起，就应当只有一识和它俱转。那如何经论上说：若起意识，这时的藏识，决定有二识（意识、末那）和它俱转呢？

    《显扬论》上说：第七末那，它恒常和四个烦恼相应。或翻转以自恃高举为行的相应烦恼为平等性行。所以知道这第七识，并通染、净的我、法二执与平等性智。

    若依论说：阿罗汉位没有染污的意，便说无第七识的话，那就应当也依论说：阿罗汉位，舍弃了我爱执藏的阿赖耶，就连清净的第八识体也没有了。既许彼第八识并通染净，如何说这第七识唯染位有呢？

    论文三：又诸论言，转第七识得平等智，彼如余智定有所依相应净识，此识无者彼智应无，非离所依有能依故。不可说彼依六转识，许佛恒行如镜智故。又无学位，若无第七识，彼第八识应无俱有依，然必有此依，如余识性故。又如未证补特伽罗无我者，彼我执恒行，亦应未证法无我者，法我执恒行。此识若无，彼依何识？非依第八，彼无慧故。由此应信二乘圣道、灭定、无学，此识恒行。彼未证得法无我故。又诸论中以五同法证有第七为第六依。圣道起时及无学位　若无第七为第六依，所立宗、因便俱有失。或应五识亦有无依。五恒有依，六亦应尔。是故定有无染污意，于上三位恒起现前。言彼无有者，依染意说。如说四位无阿赖耶，非无第八。此亦应尔。

    讲解：又，《庄严经论》和《摄大乘论》都说：转第七识得平等性智。这平等性智也如其他智一样，决定有所依的相应净识。如果没有第七净识，那平等性智又怎会有呢？不能说没有所依的识，而有能依的智。也不可说平等性智的所依是六转识。因为六转识是有间断的，平等性智和大圆镜智一样，是佛地恒无间断的妙行。

    三乘无学位如果没有第七识，则第八识不是就没有俱有依了吗？但肯定有此俱有依，也如其余的七个识一样。又如还没有证到人无我的补特加罗──凡夫，他们的我执恒起现行。还没有证到法无我的二乘，他们的法我执也恒起现行。如果二乘没有第七识，试问他那恒行的法执，依什么识？不能说是依第八识，因为第八识没有推度抉择的慧心所。因此应当相信二乘圣道、灭尽定、无学位，他们的第七识还照常现行。因为他们还没有证到法无我故。

    又诸论都说，前五识，在七识中同为转识，同有所依，所以名为‘五同法’（注：五同法，指第六意识与眼等五识，共同认识色香等五境。）以五同法有五根为依，证明确有第七意根，来做第六意识的所依。量谓：宗──有第七识。因──为第六识之所依故。喻──如五同法。圣道起时的有学及无学位，倘若没有这第七识为第六识所依，那量中所立的宗、因，便都有了自违和不定的过失；如果第六识没有所依，前五识也会有无所依的时候。但前五识恒有所依，那第六识也应当如此。因为大家既是同法，要有所依应都有所依。

    以上述原因，决定有一个无染污的清净末那，在二乘、灭尽定、无学，这三位里恒起现行。说三位无末那，那是约染污的末那而言。譬如说：声闻、独觉、菩萨、佛，这四位没有我爱执藏的阿赖耶，并不是连异熟识及无垢的第八识体也没有了。说四位无阿赖耶如此，说三位无末那亦然，并不是连清净的第七识体也没有了。

    论文四：此意差别，略有三种：一补特伽罗我见相应。二法我见相应。三平等性智相应。初通一切异生相续，二乘有学、七地以前一类菩萨，有漏心位，彼缘阿赖耶识起补特伽罗我见。次通一切异生、声闻、独觉相续，一切菩萨法空智果不现前位，彼缘异熟识起法我见。后通一切如来相续，菩萨见道及修道中，法空智果现在前位，彼缘无垢异熟识等，起平等性智。

    讲解：末那识的行相，分别起来略有三种，第一是补特伽罗──人我见相应，第二是法我见相应，第三是平等性智相应。这三种相应末那，第一种人我见相应，通于一切五趣异生，及二乘有学，与七地以前的一类菩萨。因为他们还在有漏心位，以第七末那识缘第八阿赖耶识见分，生人我见。

    第二种法我见相应，不但异生、二乘有学、七地以前菩萨，既有人我见，必有法我见；就是二乘无学、一切地菩萨，在法空观的平等智果未现前时，照样的也有法我见。因为它们虽然已了人空，犹以末那缘第八异熟识的相分生起法我见。

    第三种平等性智相应，一切如来，以及在见、修道中，法空智果现前的菩萨，都有平等性智。因为他们的第七识缘第八无垢的异熟识，及真如等，而生起平等性智。

    论文五：补特伽罗我见起位，彼法我见，亦必现前，我执必依法执而起。如夜迷杌等，方谓人等故。我、法二见用虽有别，而不相违，同依一慧。如眼识等体虽是一，而有了别青等多用，不相违故，此亦应然。二乘有学圣道，灭定现在前时，顿悟菩萨，于修道位，有学渐悟生空智果现在前时，虽皆唯起法执，我执已伏故。二乘无学及此渐悟法空智果不现前时，亦唯起法执，我执已断故。八地以上一切菩萨，所有我执皆永不行，或已永断，或永伏故。法空智果不现前时，犹起法执，不相违故。

    讲解：当人我见生起的时候，法我见也必定生起，因为我执肯定是依法执而生。好像夜间行路，看见一根木桩误以为是人一样。看不清木桩（喻法执），误以为是人（喻我执）。我、法二执虽然有区别，但不相违背。譬如眼识，识体虽然是一个，但有了别青、黄、赤、白的多种作用，不相违背。我、法二见作用虽有差别，但它们所依的慧体是一个，故不相违。

    声闻、缘觉二乘有学，在圣道及灭尽定现前时；顿悟菩萨在修道位时；回向大乘的有学渐悟菩萨，在生空智果现前的时候，都是唯有法执，因为它们的我执已伏。八地以上的一切菩萨，所有的我执都永远不起现行。因为这一切菩萨，或无学渐悟，我执永断；或有学渐悟及顿悟菩萨，我执永伏，所以不起现行。然而当它们的法空智果还没有现前的时候，犹起法执。因为人空不违法执之故。

    论文六：如契经说：八地以上一切烦恼不复现行，唯有所知障在。此所知障是现非种，不尔，烦恼亦应在故。法执俱意于二乘等虽名不染，于诸菩萨亦名为染，障彼智故。由此亦名有覆无记。于二乘等说名无覆，不障彼智故。是异熟生摄，从异熟识恒时生故，名异热生，非异熟果，此名通故，如增上缘，余不摄者，皆入此摄。

    讲解：如《解深密经》说，八地以上的菩萨，一切烦恼不再起现行，唯有法执的所知障依然存在。这所知障是现行而不是种子。不然的话，烦恼障的种子也应当存在。与法执俱起的第七末那，在二乘异生，虽不名为染污，但在一切菩萨则名为染，因为此法执能障蔽菩萨的法空智。由此可称为有覆无记；在二乘异生来说，就称为无覆无记，因为法执不能障蔽二乘的生空智果。

    这有法执的第七识，是属于异熟无记的‘异熟生’摄。异熟生，是从第八异熟识里，恒时所生而得名，不是由善、恶业因所生的异熟报果。为什么属于异熟生而不属于异熟果？那是因为异熟生的名称旁通甚广，异熟果的名称仅局限于第八识。譬如四缘的增上缘，其余的因缘、等无间缘、所缘缘，这三缘所不摄的，都归于增上缘所摄。


第九章　如何证明有第七识

    第九章　如何证明有第七识

    论文一、云何应知此第七识，离眼等识有别自体？圣教正理为定量故。谓薄伽梵处处经中说心、意、识三种别义，集起名心，思量名意，了别名识，是三别义。如是三义虽通八识，而随胜显。第八名心，集诸法种起诸法故。第七名意，缘藏识等恒审思量，为我等故。余六名识，于六别境粗动间断，了别转故。如入楞伽伽他中说：藏识说名心，思量性名意，能了诸境相，是说名为识。

    讲解：前面以八段十门分别解释颂文。以下是举圣教、正理，来证明确有此识。圣教有二，正理有六，依次说之。怎样知道这第七识，离开了前六识而别有自体呢？我们可以通过圣教和正理而得知。薄伽梵在《解深密经》及《楞伽经》中，多处说到心、意、识三种差别的意义，集起诸法种子而生起诸法的称为心，恒审思量执持自我的称为意，了别六尘粗显之境的称为识。这三种差别意义，虽可用作八个识的通名，但各随其偏胜来说，则第八识称心，因为它能积集现行诸法种子而生起诸法。第七识称意，因为它缘第八藏识，恒审思量执著自我。前六识称识，因为它们了别六尘别境。例如佛在《入楞伽经》中说：‘藏识说名心，思量性名意，能了诸境相，是说名为识’。意思是说：第八阿赖称为心，第七末那称为意，对六尘外境起了别作用的称为识。

    论文二：又，大乘经处处别说有第七识，故此别有。诸大乘经是至教量，前已广说，故不重成。解脱经中亦别说有此第七识。如彼颂言：染污意恒时，诸惑俱生灭，若解脱诸惑，非曾非当有。彼经自释此颂义言：有染污意从无始来，与四烦恼恒俱生灭，谓我见、我爱，及我慢、我痴。对治道生，断烦恼已，此意从彼便得解脱。尔时，此意相应烦恼非惟现无，亦无过未，过去、未来无自性故。如是等教，诸部皆有。恐厌广文，故不繁述。

    讲解：大乘经多处都别说有第七识，所以肯定有此末那识。因为各种大乘经都是至教量，前边已经讲过，此处不再重复。

    再如大小乘共许的《解脱经》里，也别说有此第七识。例如彼经的颂文说：‘染污意恒时，诸惑俱生灭，若解脱诸惑，非曾非当有。’它的意思是：这染污意的末那识恒时与诸烦恼同生同灭，它一旦从烦恼中解脱出来，这时第七识的相应烦恼，不但现在没有，就是连过去、未来的惑体都没有了。像这样的经教诸部都有，不再繁述。

    论文三：己引圣教，当显正理。谓契经说，不共无明微细恒行，覆蔽真实。若无此识，彼应非有。谓诸异生，于一切分恒起迷理不共无明，覆真实义，障圣慧眼。如伽他说：真义心当生，常能为障碍，俱行一切分，谓不共无明。是故契经说异生类恒处长夜，无明所盲，惛醉缠心，曾无醒觉。若异生位，有暂不起此无明时，便违经义。俱异生位迷理无明，有行不行，不应理故。此依六识皆不得成。应此间断彼恒染故。许有末那，便无此失。

    讲解：以上已引圣人教诲，此下当显示其基本正理。正理有六，如《缘起经》说：意识不与六尘相应时，所起的烦恼叫做不共无明。此不共无明行相微细，所以单与第七末那相应，恒起现行覆蔽真实义理。倘若没有这第七末那，那不共无明就不应该有。凡夫在一切趣生的位分，不断生起迷理的不共无明，隐覆了无我的真实义，也障蔽了无漏智的慧眼。例如《摄大乘论》颂说：‘真义心当生，常能为障碍，俱行一切分，谓不共无明。’意思是说：无漏真智本来应当生起，因为有不了诸法事理的闇钝障碍，常使它于一切位分，不能俱起现行。这障碍，就是不共无明。所以佛经中说，流转五趣的异生之类，他们恒时处在漫长的生死长夜，为不共无明盲了慧眼，惛醉沉迷，缠住了本净真心，从无醒觉。假使异生之类，有暂时不起不共无明，便与经义相违。因为同属异生之类的有情，它们那迷理的不共无明，都是一样的闇钝，那有行与不行之理。

    若说不共无明是依六识而起，根本没有第七末那，这理由不能成立，因为六识有断，且通于三性；不共无明恒与染俱。假使是依于六识的话，那不共无明就应当随六识而间断，六识也应当恒起染法。若许有第七末那，则无此过失。

    论文四：染意恒与四惑相应，此俱无明何名不共？有义：此俱我见、慢、爱，非根本烦恼，名不共何失？有义：彼说理教相违，纯随烦恼中不说此三故。此三，六十烦恼摄故，处处皆说染污末那与四烦恼恒相应故。应说四中无明是主，虽三俱起，亦名不共。从无始际恒内惛迷曾不省察，痴增上故。此俱见等应名相应。若为主时应名不共。如无明故许亦无失。有义：此痴名不共者，如不共佛法，唯此识有故。若尔，余识相应烦恼，此识中无，应名不共。依殊胜义立不共名，非互所无皆名不共。谓第七识相应无明，无始恒行障真义智，如是胜用余识所无，唯此识有，故名不共。既尔，此俱三亦应名不共。无明是主，独得此名。或许余三亦名不共。对余痴故，且说无明。

    讲解：小乘论师问：染污末那恒与我见、我爱、我慢、我痴四烦恼相应。这相应无明，何以名叫不共？此有三家异解：第一家说：与第七识相应的四个烦恼，除了无明的我痴是根本烦恼外，其余的我见、我慢、我爱，都是随烦恼所摄，而不是同根本烦恼俱有的共法，所以名为不共。

    第二家说：此说于理于教有违，纯粹的随烦恼中，并没有说我见、我慢、我爱三惑，这三惑是属于六根本烦恼，或十根本烦恼所摄。佛教的论典，多处说到染污的末那永远与四烦恼相应，应当说四烦恼中无明的痴是主，虽然三惑俱起，也称为不共。因为自无始以来，它们永恒内执惛迷，不曾省察，愚痴增盛。外人问曰：我见、我慢、我爱，不是为主，应当称为相应，若许为主，应当称为不共。论主答曰：我见等三为主时，也可以称为不共，如无明为主时一样，称为不共并无过失。

    第三家说：这愚痴的无明所以名为不共者，就像十八不共佛法一样。不共佛法，唯佛独具，不与二乘、菩萨所共有。这无明，也唯独第七识有，余识都无，所以名叫不共。外人问：如果是这样的话，那但与余识相应，这七识里没有的烦恼，不是也应当名为不共吗？论主回答说：依殊胜之义而立不共之名，并不是他识有此识无都称为不共。与第七识相应的无明，无始时来，恒起现行，永远障碍认识真如的智慧，像这样的殊胜作用，其他识没有，只有末那识有，所以称为不共。

    外人又问：既然如此，那与第七识相应的见、慢、爱三惑，也不是余识所有，也遍通三性，就应当也叫做不共了。论主答曰：无明是主。只有它独得不共之名。或允许其余三惑也称不共，不过这是对与余识相应的无明而言。前六识的无明不遍三性、不得名为不共，唯有第七识的无明遍通三性，方得不共之名，所以但说无明，不说余三见、慢、爱。（注：十八不共佛法：谓佛不同于小乘声闻、缘觉二乘的功德法，有十八种不共佛法：身无失，口无失，念无失，无异想，无不定心，无不知已舍，欲无减，精进无减，念无减，慧无减，解脱无减，解脱知无减，一切身业随智慧行，一切口业随智慧行，一切意业随智慧行，智慧知过去世无碍，智慧知未来世无碍，智慧知现世无碍。）

    论文五：不共无明，总有二种：一恒行不共，余识所无。二独行不共，此识非有。故瑜伽说：无明有二，若贪等俱者，名相应无明；非贪等俱者，名独行无明。是主独行，唯见所断，如契经说：诸圣有学，不共无明已永断故，不造新业。非主独行亦修所断，忿等皆通见所断故。恒行不共余部所无。独行不共此彼俱有。

    讲解：不共无明总有两种：一是恒行不共，唯第七识有，余识所无。二是独行不共，第七识无。故《瑜伽论》说：无明有二种，若与贪等俱起，叫做相应无明；若不与贪等俱起，叫独行无明。独行无明亦分两种：第一种是‘主独行’，它不与忿等十种随惑相应，便能独自分别而起，这是见道所断的粗惑。如契经上说：未证无学的圣者，它们的不共无明已经永断，不会再造新业了。第二种是‘非主独行’。这种无明，它无力独起，必须与忿等十惑相应，不但是见道所断，而且也通修道所断。因为忿等都是通于见道所断的随惑。第七识的恒行不共无明，小乘佛教没有，唯大乘独有。独行不共无明，大乘和小乘俱有。

    论文六：又契经说，眼、色为缘，生于眼识，广说乃至意、法为缘，生于意识。若无此识，彼意非有，谓如五识，必有眼等增上不共俱有所依。意识既是六识中摄，理应许有如是所依，此识若无，彼依宁有？不可说色为彼所依，意非色故。意识应无，随念、计度二分别故。亦不可说五识无有俱有所依。彼与五根俱时而转如芽影故。又识与根既必同境，如心、心所决定俱时，由此理趣极成意识，如眼等识，必有不共显自名处，等无间不摄，增上生所依，极成六识随一摄故。

    讲解：以上第一正理讲毕，现讲第二正理的‘意法为缘’。契经上说：以眼根和色境为缘而生眼识，乃至以意根和法境为缘而生意识。如果没有第七识做意根，这第六识如何生起？再者，前五识必有眼等五根的增上缘，来做各别不共的俱有依。意识既是前六识所摄，理应许它也有这样的俱有依．如果没有第七识，那第六识的俱有依怎会有呢？

    不能说胸中那块肉团的色法为意识所依的根（本段破上座部，该部主张胸中色物为其意根。）因为意根不是色法。如果意根是色法的话，那么第六意识就当同五识一样，只有自性分别，而没有随念分别和计度分别了。也不能说五识没有俱有依（此破经量部，该部主张依前念的五根生起后念的五识，所以五识没有俱有依。第六识和前五识一样，依前念的无间灭意生起后念的意识。）五识与五根同时发生作用，如芽与种子，影与形必定同时一样。又，五识与五根既是同缘一境，就应当如心王和心所一样必定同时。由此道理，大小乘所共许的意识，也像前五识一样，必有其不与它识所共的俱有根，来显示它在十二处里各自所得意、法的处名。这不属于次第灭意的等无间缘，也不属于亲生种子的因缘，而是增上缘生的俱有所依。这俱有所依，在共许的六识里，随便那一个识都有。

    论文七：又契经说：思量名意。若无此识，彼应非有。谓若意识现在前时，等无间意已灭非有，过去、未来理非有故。彼思量用定不得成。既尔，如何说名为意？若谓假说，理亦不然，无正思量，假依何立？若谓现在曾有思量，尔时名识，宁说为意？故知别有第七末那，恒审思量正名为意，已减依此假立意名。

    讲解：现在是讲第三正理‘思量名意’。又契经说，思量称为意。假使没有这第七识，那就不应说思量名意。小乘有部论师说：思量名意，是识的过去心，那叫做等无间，并不是第七识。论主破曰：不然，若第六意识现前时，那等无间意已经灭而非有了。依理而论，过去、未来都是不存在的，那思量的作用也不能成立。怎么说它名叫做‘意’？

    如果说思量名意是假说的，这理由也不能成立，因为假必依真，假使没有真的思量，这假思量依何建立呢？小乘有部师救曰：过去的意于现在时曾有思量，所以过去称为意。论主诘难曰：过去起思量作用称为意，现在了别称为识，怎能称识为意呢。由此可知，在前六识之外，别有一个恒审思量的末那识正名为意。已经灭了的前念，都依末那而起，即依此方便建立了等无间意的假名，而实非真正的意。

    论文八：又契经说：无想、减定，染意若无，彼应无别。谓彼二定，俱灭六识及彼心所。体数无异。若无染意于二定中一有一无，彼二何别？若谓加行界、地、依等有差别者，理亦不然。彼差别因由此有故。若此无者，彼因亦无。是故定应别有此意。

    讲解：现在讲第四正理‘二定差别’。又契经上说：如果没有染污的第七末那，则‘无想定’、‘灭尽定’就应当没有差别了。因为无想、灭尽二定，都一样的灭了前六识心王及其心所。心王为体，心所为数，体数无异，灭则俱灭。然而，无想定有染污，灭尽定无染污，俨然有别。倘若没有第七识，那二定既已俱灭六识王所，何以一个有染污，一个无染污呢？可见无想定仅是灭了六识王所，还有第七识的王所未灭；灭尽定，则兼第七识的王所而并灭了。

    如果说这两种禅定，是因为有加行、界地、所依等的不同之故，所以才有染、净的差别。这理由也不对，因为二者之所以有加行等差别的原因，完全是由于有第七识的染污之故。倘若没有这第七识，那二定也没有加行等来做染、净差别的原因了。因此，除了前六识外，肯定别有第七末那。（注：无想定，是加行的出离想；灭尽定，是加行的静住想。无想定，在色界的舍念清净地；灭尽定，在无色界的非想非非想处地。无想定是外道所修，灭尽定是佛教所修。）

    论文九：又契经说：无想有情，一期生中，心、心所灭。若无此识，彼应无染。谓彼长时无六转识，若无此意我执便无，非于余处有俱缚者，一期生中都无我执，彼无我执应如涅槃，便非圣贤同所诃厌。初后有故，无如是失。中间长时，无故有过。去来有故，无如是失。彼非现常，无故有过。所得无故，能得亦无。不相应法，前已遮破。藏识无故，熏习亦无。余法受熏，已辩非理。故应别有染污末那，于无想天，恒起我执。由斯贤圣同诃厌彼。

    讲解：现在讲第五正理‘无想有染’。佛经又说：无想天的有情，从生到死的一期生命中，前六识的心、心所都已伏灭，倘若没有末那，那无想有情就应当没有染污现行。换句话说：无想有情在一期生命中没有六转识，假使再没有第七识的话，它们的我执也就没有了。然而，无想有情也是属于余处有束缚的异生之类，并非于一期生中都无我执，若无我执，那就应当和涅槃一样了，那无想天就不是三乘圣贤同所诃厌的地方了。

    小乘有部救曰：在一期生命中，除中间很长的一段时期外，初生时和命终时，都有第六识的我执，这有什么过失呢？论主破之曰：若中间长期没有第七识，是谁在执我？这就是过失。小乘又救曰：过去和未来世虽然现在没有，但有不相应行法的‘得’，由于这种‘得’在现在，所以有现在的我执。论主又破他说：你那过去世、未来世既非现在，能得之‘得’亦无。因为能得非有，所以不成我执。

    小乘大众等部又转救说：‘得’虽没有，而种子非无，这种子岂非我执？论主破曰：那也不对，如果没有受熏的第八藏识，那里会有熏习的种子？只要有所执的藏识种子，便有能执的第七末那。至于除第八识外，其余的色、心等法也可受熏的话，在前面已经辨明其非理了。因此除前六识外，应当别有个染污的第七末那，在无想天里恒起我执。所以三乘圣贤，都讨厌这个出定后仍有烦恼的定果。

    论文十：又契经说：异生善、染、无记心时，恒带我执，若无此识，彼不应有。谓异生类三性心时，虽外起诸业，而内恒执我，由执我故，令六识中所起施等不能亡相。故瑜伽说：染污末那为识依止，彼未灭时，相了别缚不得解脱。末那灭已，相缚解脱。言相缚者，谓于境相不能了达如幻事等，由斯见分、相分所拘，不得自在，故名相缚。依如是义，有伽他言：如是染污意，是识之所依，此意未灭时，识缚终不脱。又，善、无覆无记心时，若无我执，应非有漏。自相续中，六识烦恼与彼善等不俱起故。去来缘缚理非有故，非有他惑成有漏故，勿由他解成无漏故。

    讲解：现在讲第六正理‘三性执我’。再者契经上说：凡夫位的善、染、无记三性心生起时，永远带有我执。倘若没有这第七识，那我执就不应当有。也就是说，凡夫位的善、染、无记三性心，虽外起善、恶、无记诸业，而第七识犹向内缘第八识的见分，执以为我。由于内执我故，使前六识里所起的布施、持戒等有漏善业，不能亡相。总想我能布施、我能持戒等。所以《瑜伽论》上说：染污的第七末那为六识所依。在末那还没有灭的时候，那六识分别境相的束缚，就不得解脱。必须末那灭了，相缚才能解脱。

    什么叫做相缚呢？就是对所缘的境相，不能以慧眼了知是因缘和合而生，如梦幻泡影似的虚妄不实。因此能缘的见分心，为所缘的相分境所拘碍不得自在，故名相缚。依于此义，所以《阿毗达磨经》有颂说：‘如是染污意，是识之所依，此意未灭时，识缚终不脱。’意思是说：像这样染污的第七末那，为前六识所依：只要这染污的末那尚未灭除，所有六识的烦恼终于不能得到解脱。

    又若在善和无覆无记心时，如果没有第七识的我执，就应当不是有漏。因为善等相续法中，不与六识烦恼俱起，既不与六识烦恼俱起，若再没有第七识的我执，它如何成为有漏？若说，善等虽不与烦恼俱起，然而过去、未来都有烦恼，所以成为有漏。这也不对，因为过去、未来的世体犹如兔角一样，那有什么烦恼？也并不是由它人的烦恼，成为自己的有漏，恰如不能由它人的解脱，成为自己的无漏一样。有漏、无漏，全在染污的末那灭与未减而定。所以三性成为有漏，是由于第七识的我执之故。

    论文十一：又不可说，别有随眠，是不相应现相续起，由斯善等成有漏法。彼非实有，已极成故。亦不可说从有漏种生彼善等，故成有漏，彼种先无因，可成有漏故。非由漏种彼成有漏，无学无漏心亦成有漏故。虽由烦恼引施等业而不俱起，故非有漏正因，以有漏言表漏俱故。又无记业非烦恼引，彼复如何得成有漏？然诸有漏，由与自身现行烦恼俱生俱灭，互相增益，方成有漏。由此熏成有漏法种，后时现起有漏义成。

    讲解：又不可像大众部所说，别有一种‘随眠’，是不相应行所摄，当这随眠相续生起的时候，使善、无覆无记也成了有漏。因为大、小乘教，都认为不相应行是离了色、心等法，而没有实体的。也不能像经量部所说，从有漏种子产生善性和无记性，使善法成为有漏。如果有有漏种子，能使善法成为有漏，那无学位的无漏心，岂不也可以成为有漏了吗？

    虽然由过去的烦恼，引发现在布施等善业成了污染，然而布施善业却不与烦恼同起，所以从前的烦恼，不是现在有施有漏善业的正因，不过是旁因而已。因为有漏表示此法与烦恼俱起，布施既不与烦恼俱起，当然不是有漏的正因。若谓烦恼所引发的就做有漏，那非善非恶的无记业，并非烦恼所引发，它怎么也成为有漏呢？然而，诸有漏法必须与自身的现行烦恼俱生俱灭，二者互相增益，这才成为有漏。由此有漏现行熏成了有漏种子，到后来这种子复起现行，有漏的意义是这样成立的。

    论文十二：异生既然，有学亦尔。无学有漏虽非漏俱，而从先时有漏种起，故成有漏，于理无违。由有末那恒起我执，令善等法有漏义成。此意若无，彼定非有。故知别有此第七识。证有此识理趣甚多，随摄大乘，略述六种。诸有智者应随信学。然有经中说六识者，应知彼是随转理门，或随所依六根说六，而识类别，实有八种。

    讲解：既然凡夫如此，初、二、三果的有学也是如此，无学有漏虽然不与现行有漏俱起，但因先前有漏种子生起，所以也成为有漏。这在道理上并不违背。由有第七末那恒起我执，使善、无记之法成为有漏，假使没有这第七末那，那一切善法也决不成有漏。

    证明除六识外别有一个第七识，还有很多理由，现在仅就《摄大乘论》所载，略说以上六种，凡是有智慧的人，都应当随信修学。然而，为什么也有的佛经中但说六识呢？应知那是随顺小根器者因人施教之理，或随所依六根但说六识，都非尽理，事实上，识实有八种。


第一章　能变差别门

    第四篇　了境能变识诠解

    (本篇颂文，由第八颂至第十六颂，如第一章科分。)

    第一章　能变差别门

    论文一：如是已说第二能变，第三龙变，其相云何？颂曰：次第三能变，差别有六种，了境为性相，善不善俱非。

    讲解：前面讲完了第二能变的第七末那识，那么第三能变的前六识，它的义相又是怎么样呢？《唯识三十颂》颂文曰：‘次第三能变，差别有六种，了境为性相，善不善俱非。’颂文的意思是：然后是第三能变，它有六种差别，其特点是了别外境，其性质包括善、恶、无记三性。

    本篇九章颂文，其中包括了九个题目，就是诠释前六识，是以七段九义来科分，七段又称七门，其科分如下：

    一、能变差别门　　次第三能变，差别有六种───────────体别门

    二、自性行相门　　了境为性──────────────────自性门

     相──────────────────行相门

    三、三性分别门　　善、不善、俱非───────────────三性门

    四、相应门：

     甲、列六位　此心所遍行，别境善烦恼，随烦恼不定───────相应门

     乙、受俱　　皆三受相应───────────────────受俱门

     遍行　　初遍行触等 　　别境　　次别境为欲，胜解念定慧

     善　　　善谓信惭愧，无贪等三根，勤安不放逸，行舍及不害

     烦恼　　烦恼为贪嗔，痴慢疑恶见

     随烦恼　随烦恼为忿，恨覆恼嫉悭，诳谄与害憍，无惭及无愧

     掉举与昏沉、不信并懈怠、放逸及失念，散乱不正如

     不定　　不定谓悔眠 寻伺二各二

    五、所依门　　　　依止根本识─────────────────所依门

    六、俱转不俱转门　五识随缘现，或俱或不俱，如波涛依水─────俱转门

    七、起灭分位门　　意识常现起，除生无想天

    及无心二定，睡眠与闷绝───────────起灭门

    论文二：次中思量能变识后，应辩了境能变识相。此识差别总有六种，随六根境种类异故。谓名眼识乃至意识，随根立名具五义故。五谓依、发、属、助、如根。虽六识身皆依意转，然随不共立意识名，如五识身无相滥过。或唯依意故名意识，辩识得名，心意非例。或名色识乃至法识，随境立名顺识义故，谓于六境了别名识。

    讲解：由此向下，先解释七门中的‘能变差别门’。论文曰：其次说罢第二思量能识后，应当解释第三了境能变识。这了境能变识总有六种，因为随顺六根六境不同的功能，称做：眼识、耳识、鼻识、舌识、身识、意识。

    或有问曰：识的立名，实通于根和境，为何要随根立名呢？论主答曰：因为随根立名有五种意义，例如：一者依于眼根之识，名叫眼识。二者眼根所发之识，名叫眼识。三者属于眼根之识，名叫眼识。四者帮助眼根了境之识，名叫眼识。五者识如于根名叫眼识（注：如眼根等是有情数，故眼识等也变为有情数）。眼识如此，耳、鼻、舌、身、意也是如此。六识皆仗意根而发生作用，今既依根立名，就应当都叫做意识才对，何以独名第六为意识呢？答曰：虽然六识都依末那识发挥作用，但只有第六识依第七不共意根而立意之名，如前五识，各依它们不共的五根而得名，这就没有混滥不清的过失。或者说，只有第六识依于意根，所以称为意识。

    问：若第六识依于意就名叫意识，那么第八识也是唯依于意；第七识，也是唯依于心，这样就应当称第八识为意识，第七识为心识才对啊！答曰：这是辩论六识之所以得名，与心意无关，不能比例。

    前六识或称色识、声识、香识、味识、触识、法识，这是随境立名，与随根立名为眼识乃至意识的名义不同。所谓随境立名，就是顺著识能了别六境的意义而立识名。

    论文三：色等五识唯了色等，法识通能了一切法，或能了别法，独得法识名，故六识名无相滥失。此后随境立六识名，依五色根未自在说。若得自在，诸根互用，一根发识，缘一切境，但可随根无相滥失。庄严论说：如来五根，一一皆于五境转者，且依粗显同类境说。佛地经说：成所作智，决择有情心行差别，起三业化，作四记等。若不遍缘，无此能故。然六转识所依所缘粗显极成，故此不说。前随义便，已说所依，此所缘境，义便当说。

    讲解：有问曰：色等前五识所了别的色等五境，都叫做法，第六法识所了别的法境里，也有色等五境在内，何以不名色等五识为法识呢？答曰：色等五识，只能各自了别各自的境界，所以不名法识；第六识能了别一切法，所以不名色等五识而名为法识。

    上面随境所立的六种识名，是依五种色根还没有得到自在位的凡夫而说的。若是得到自在位的二乘圣人，那时便能五根互用，无论用那一根发识，都能遍缘六境。因此，六识的名称只好随根而立，称眼识、耳识、鼻识、舌识、身识、意识，以免混滥。

    《大乘庄严论经》上说：如来的五根，每一根都能缘五境，但那是依粗显和同类的境界来说的。实际上，如来诸根互用，一缘一切。所以《佛地经》说：佛转五识为‘成所作智’，能够抉择各个有情的心行差别，而起身、语、意三业的对治教化。又能作一向记、分别记、反诘记、舍置记这四种记别，以决了当来的果相。如果如来不是一根遍缘诸境，怎么会有这种功能。然而六转识所依的根，所缘的境，色相粗显，这是大乘和小乘都承认的，所以本颂都略而不说。


第二章　自性行相门

    第二章　自性行相门

    论文一：次言了境为性相者，双显六识自性行相。识以了境为自性故，即复用彼为行相故。由是兼释所立别名，能了别境名为识故。如契经说：眼识云何，谓依眼根了别诸色，广说乃至意识云何？谓依意根了别诸法。彼经且说不共所依　未转依位见分所了，余所依了，如前已说。

    讲解：第一章能变差别门，已释颂文前两句‘次第三能变，差别有六种’。现在解释第三句颂文‘了境为性相’，此句颂文是双显前六识的自性与行相。所谓双显性相，就是识以了境为它的体性，也以了境为他的行相。由此，也解释了心、意、识中‘识’的别名。因为它能了别尘境，所以名之为‘识’，简别其不同于集起的心、思量的意。例如佛经上说：眼识是如何解释呢？就是依于眼根了别一切色尘，叫做眼识。以至于耳识、鼻识、舌识、身识，也是各依其根，各了其境；乃至意识也是依于意根，了别一切法境。经上只说六识各依其所依的根，不与余识所共，在未转识成智的凡位，是识的见分所了，至于与余识所共的：染净依、分别依、根本依，及自证分所了，在前文已讲过了。


第三章　三性分别门

    第三章　三性分别门

    论文一：此六转识何性摄耶？谓善、不善、俱非性摄。俱非者谓无记，非善、不善故名俱非。能为此世、他世顺益，故名为善。人、天乐果，虽于此世能为顺益，非于他世故不名善。能为此世、他世违损，故名不善。恶趣苦果虽于此世能为违损，非于他世，故非不善。于善、不善益损义中，不可记别，故名无记。此六转识若与信等十一相应，是善性摄。与无惭等十法相应，不善性摄。俱不相应，无记性摄。

    讲解：此六转识，在三性中为那一性所摄呢？答曰：如颂文所说：‘善、不善、俱非’。俱非，就是无记。因为它既不是善，也不是不善，所以称为‘俱非’。何谓善？能于此世、他世，得到二世乐果的利益，所以名之为善。人天乐果，虽于此世能为利益，而不能于他世亦为利益，这仅是无记乐果，所以不名为善。何谓不善？能于此世、他世，得到二世苦果的损害，所以名为不善。地狱、饿鬼、畜生的恶趣苦果，虽于此世受到了苦报的损害，并非于他世亦堕恶趣，这仅是无记苦果，所以不名不善。在善的利益、或不善的损害两种意义中都无可记别的，就名叫无记。

    这六转识如果和信等十一种善心所相应，那便是善性所摄。如果和无惭等十种不善法相应，那便是不善性所摄。如果善、不善都不相应，那便是无记性所摄。（注：无惭等十法：十法，是中随烦恼无惭无愧二，小随烦恼的忿、恨、恼、覆、嫉、悭、害七，及根本烦恼的嗔共为十法，此十法皆不善性摄。此外，大随烦恼八，小随烦恼的诳、谄、憍，根本烦恼的贪、痴、慢、疑、恶见，皆通不善及有覆无记摄，贪、慢不与中随烦恼同起者，全是有覆无记摄）

    论文二：有义：六识三性不俱，同外门转互相违故，五识必由意识导引，俱生，同境，成善染故。若许五识三性俱行，意识尔时应通三性，便违正理，故定不俱。瑜伽等说藏识一时与转识相应三性俱起者，彼依多念。如说一心、非一生灭，无相违过。

    讲解：对于六识是否与三性俱起，有两家不同的异说。第一家说：六识不能与三性同时俱起，一者六识同缘外境，而三性互违，有善即不能有恶，有恶即不能有善，善、恶不是无记，怎能同时俱起？二者前五识生起，必须由第六意识引导，才能同时俱生，同缘一境，才能成为善染。如果允许五识能够三性俱起，就应当使意识一念中也通于三性，这与正理相违，所以三性在六识里，决定不能俱起。虽然《瑜伽论》等有说：‘第八藏识，一时与转识相应，三性俱起’的话，但那是依多念而说的，并非一念俱起三性。例如说一心，并不是一念生减，所以没有三性相违的过失。

    论文三：有义：六识三性容俱，率尔、等流，眼等五识，或多或少容俱起故。五识与意虽定俱生，而善性等不必同故。前所设难于此唐捐。故瑜伽说：若遇声缘从定起者，与定相应，意识俱转，余耳识生。非谓彼定相应意识能取此声。若不尔者，于此音声，不领受故，不应出定。非取声时即便出定，领受声已，若有希望，后时方出。在定耳识率尔闻声，理应非善。未转依者率尔堕心，定无记故，由此诚证五俱意识，非定与五善等性同。诸处但言五俱意识亦缘五境，不说同性。杂集论说：等引位中五识无者，依多分说。若五识中三性俱转，意随偏注，与彼性同。无偏注者便无记性。故六转识三性容俱。自在位唯善性摄，佛色、心等，道谛摄故，已永灭除戏论种故。

    讲解：这是第二家护法论师的正义，他说：前六识可以三性俱起，因为率尔心是无记，而等流心有善、染，眼等五识缘境，识之生起或多或少不定，若五境当前，则五识俱起；若或一、或二、或三境当前，识就少起，这样，则眼识起率尔无记，耳识起等流善，鼻起等流不善，这不就是三性俱起了吗？因此，五识虽然和意识俱起，但他们的性质则不必相同，因此你们说六识不能与三性同时俱起，那是白说了。

    所以《瑜伽论》上说︰在定中的行人，若遇声音从定中起时，他那与定相应的意识是和耳识同时俱转，并非不要耳识但凭意识就能听到声音。假若不是意识和耳识俱起，于此声音便不能领受，他如何可以出定？再者，不是在将闻声而尚未闻声时便即出定，而是在定中的耳识先已闻声，到意识有了寻求希望之后才出定的。

    在定中的耳识率尔闻声，照理说这不是善法，因为在没有转识成智的凡夫位，率尔的堕心决定是无记（注：《瑜伽论》说：率尔等五心的率尔心、寻求心、决定心，肯定是无记性，这是就未转依位的五识而说，转依以后只能是善性。）由此可证五俱意识虽然与五识俱起，却不一定和五识同属一性。所以很多经论但说五俱意识亦缘五境，而不说与五识同性。

    虽然杂集论上说，在修等引定时定中没有五识，但那是约‘多分’而说的。所谓多分有两种情况：一者以时间论，在定中的耳识，不过是大部分时间不起，还有少部分时间是生起的。二者以五识而论，定中但有耳识，其余四识都没有。

    如果五识中的三性同时俱转，五俱意识则随著偏重于某境而专注一处，其专注之境若是善色，则眼俱意识同为善性；若是恶声，则耳俱意识便同为恶性。若没有专注而兼缘五境，便是无记。所以前六转识的善、恶、无记三性，是可以同时俱起的。

    以上所说，是指未得自在的凡夫位而言。如果达到解脱自在的佛位以后，则前六识纯属善性，因为佛的色、心属于无漏性的道谛所摄，此时已经永灭戏论种子了。


第四章　心所相应门．泛说六位心所

    第四章　心所相应门．泛说六位心所

    论文一：六识与几心所相应？颂曰：此心所遍行，别境善烦恼，随烦恼不定，皆三受相应。论曰：此六转识，总与六位心所相应，谓遍行等，恒依心起，与心相应，系属于心，故名心所，如属我物立我所名。心于所缘唯取总相，心所于彼亦取别相，助成心事得心所名。如画师资作模填彩。故瑜伽说：识能了别事之总相，作意了此所未了相，即诸心所所取别相。触能了此可意等相，受能了此摄受等相，想能了此言说因相，思能了此正因等相，故作意等名心所法。此表心所亦缘总相。

    讲解：论主自问自答：前六识与几位心所相应呢？三十颂的颂文曰：‘此心所遍行，别境善烦恼，随烦恼不定，皆三受相应。’意思是说：这六转识总与六位心所相应，就是遍行、别境、善、根本烦恼、随烦恼、不定。为什么这六位名叫心所呢？因为一者心所恒依心王而起，若离开心王，心所决定不生。二者心所与心王，生起同时，依于同根，缘于同境，所以他们才彼此相应。三者心所以心王为主，而系属于心王。因为有以上三义，所以名叫心所。好像属于我的东西，就说这东西是属我所有。

    心所和心王的行相有何不同呢？心王在所缘的境上只取总相，不取别相；而心所则总、别兼取，来助成心王的作用，所以得心所之名。这好比作画的师父，但作画模，再由弟子依模填彩，还要考虑著色的深浅。心王和心所取境的总、别，也是这样。

    所以《瑜伽论》上说：识是心王，能了别外境的总相。作意是心所，能兼了别心王所未了别的别相。触能了别外境可意、不可意等相，受能了别顺、违等相，想也能了别生起言说的因相（注：心中所想，若说出来，则想是言说之因，故称言说因相。）。思能了别业因的邪正等相，所以作意、触、受、想、思，这五法都叫做心所。这表示心所不但能缘别相，而且也兼缘总相。

    论文二：余处复说欲亦能了可乐事相，胜解亦了决定事相，念亦能了串习事相，定、慧亦了得失等相。由此于境起善、染等。诸心所法皆于所缘兼取别相。

    讲解：《辩中边论》上也说：欲心所也能了别可乐事相，胜解心所能了别决定事相，念心所能了别惯习事相，定、慧两个心所也能了别得失等相。由于以上这作意等十位心所，兼取外境的总相和别相，在所缘的境上生起了善十一法、烦恼二十六法、不定四法，这一切心所有法，都在所缘的境上兼取别相。

    论文三：虽诸心所名义无异，而有六位种类差别，谓遍行有五，别境亦五，善有十一，烦恼有六，随烦恼有二十，不定有四，如是六位合五十一。一切心中定可得故。缘别别境而得生故，唯善心中可得生故，性是根本烦恼摄故，唯是烦恼等流性故。于善、染等皆不定故。然瑜伽论合六为五，烦恼、随烦恼皆是染故。复以四一切辩五差别，谓一切性及地、时、俱，五中遍行具四一切，别境唯有初二一切，善唯有一谓一切地，染四皆无，不定唯一，谓一切性。由此五位种类差别。

    讲解：虽然一切心所在名义上没有差别，但却有不同的六位，就是遍行有五，别境有五，善有十一，烦恼有六，随烦恼有二十，不定有四。合起来总数是五十一个。

    五遍行心所，与一切心（八识心王）相应，五别境心所，是缘各别境而生起，十一善心所，唯在善心中才得生起，六个根本烦恼心所，他们的体性染污能生诸惑，二十个随烦恼心所，是根本烦恼所引的等同流类，四个不定心所，它们在善、恶、无记的三性中，不一定那一性所摄。

    然而《瑜伽论》上，却把六位心所合为五位，那是因为根本烦恼和随烦恼，同属染污，就把二者合而为一了。并且又以四种一切来分辨五位的差别，四一切是：一切性，指善、恶、无记三性。一切地，指三界九地。一切时，指过去、现在、未来。一切俱，是通于八识心王。在这四一切中，遍行心所具足四种一切，别境心所只有二种，即一切性和一切地。善心所唯有一切地，烦恼心所四种全无，不定心所唯有一切性。因此，心所才有五位种类的差别。


第五章　三受门

    第五章　三受门

    论文一：此六转识，易脱不定，故皆容与三受相应，皆领顺、违、非二相故。领顺境相适悦身心，说名乐受。领违境相逼迫身心，说名苦受。领中庸境相于身于心，非逼非悦，名不苦乐受。如是三受或各分二，五识相应，说名身受，别依身故；意识相应，说名心受，唯依心故。又三皆通有漏、无漏，苦受亦由无漏起故。或各分三，谓见所断、修所断、非所断。又学、无学、非二，为三。或总分四：谓善、不善、有覆、无覆二无记受。有义：三受容各分四，五识俱起任运贪、痴，纯苦趣中任运烦恼不发业者，是无记故，彼皆容与苦根相应。

    讲解：以上是解释颂文‘此心所遍行，别境善烦恼，随烦恼不定’前三句，现在解释‘皆三受相应’这一句。这一句不称心所相应门，而是‘受俱门’。这六转识，因为容易间断，不定一境，所以都与三受相应，皆能领纳顺、违，或顺违俱非的三种境相。领纳顺境，使身心感觉适悦的叫做乐受；领纳违境，使身心感觉逼迫的叫做苦受；领纳顺违俱非的中庸境，对身心既非逼迫又非适悦，叫做不苦不乐的舍受。

    这苦、乐、舍三受又各分为二，一者与前五识相应的，叫做五根之身受，二者与第六意识相应的，叫做心受，因为意识唯依心起。再者这三受不仅通于有漏位，也通于无漏位，因为苦受不但起于有漏，而且也由修无漏圣道的加行所生起。

    这苦、乐、舍三受，又可分为两个三种：第一是约‘断’的方面来说，由分别见惑所起的是见道所断，由俱生思惑所起的是修道所断，非见思二惑所起，而通于无漏的，是非所断。第二是约‘学’的方面来说，三受通于有学、无学、非有学无学。若是断了见惑，就是有学位，若是思惑也断了，就是无学位，若是二惑都没有断，当然是‘非学’的凡夫了。

    或者分为四种，就是：善心相应的三受，不善心相应的三受，有覆无记相应的三受，无覆无记相应的三受。安慧认为：三受可以各分为上述四种，因为在五识中有俱起的任运贪、痴，第六意识在纯苦趣中任运生起的烦恼，是不发业的，是无记性，它们都可以与苦根相应。

    论文二：瑜伽论说：若任运生一切烦恼，皆于三受现行可得。若通一切识身者，遍与一切根相应。不通一切识身者，意地一切根相应。杂集论说：若欲界系，任运烦恼发恶行者，亦是不善。所余皆是有覆无记。故知三受各容有四。

    讲解：无记通于苦受，有何为证？《瑜伽论》上说：若是任运而生起的一切烦恼──无记，它们都于三受可能现行。若是通于六识身的，那就遍六识身，都与苦、乐、舍三根相应。假如不遍通五识身，那就只有第六意识与苦、乐、舍相应了。

    《阿毗达磨杂集论》说：如果欲界所系的烦恼，假定是任运烦恼能发恶行的，也是属于不善所摄。其余不发恶行，及色、无色界任运而起的烦恼，皆是有覆无记。所以知道苦、乐、舍三受，容许分为善、不善、有覆无记、无覆无记四种性别。

    论文三：或总分五：谓苦、乐、忧、喜、舍。三中苦乐各分二者，逼悦身心，相各异故。由无分别，有分别故。尤重轻微有差别故。不苦不乐不分二者。非逼非悦相无异故。无分别故，平等转故。

    讲解：或把三受总分为五，即苦受、乐受、忧受、喜受、舍受。三受中的苦、乐二受可各分为二种，因为所缘外境有逼迫身心和适悦身心的区别。而前五识对此并无分别，意识则有分别。五识感觉粗重，意识感觉轻微。所以逼、悦与五识相应的，名谓苦受、乐受；与意识相应的，名谓忧受、喜受。为什么不把不苦不乐的舍受，也分为二呢？因为舍受既非逼迫，又非适悦，无论在前五识或意识里，都无所分别，平等而转，所以不必再分。

    论文四：诸适悦受，五识相应恒名为乐，意识相应若在欲界，初、二静虑近分，名喜，但悦心故。若在初、二静虑根本，名乐名喜，悦身心故。若在第三静虑近分根本，名乐，安静尤重无分别故。诸逼迫受，五识相应恒名为苦。

    讲解：凡是适悦之受与前五识相应的，通常都叫做乐受。若是与第六识相应的，则有如下三种分别：一者在欲界，及初、二禅的近分──未到定中，名叫喜受。因为它只是悦心，而不遍悦五根。二者在初、二禅的根本定中，那不但名叫乐受，同时也叫喜受，因为它是遍悦身心。三者在第三禅，无论是近分或是根本定中，都名叫乐受。因为第三禅定的安静更加深重，没有近分和根本的分别。与前五识相应的诸逼迫受，通常都叫做苦受，因为前五识没有计度分别，所以不叫忧受。

    论文五：意识俱者，有义：唯忧，逼迫心故，诸圣教说：意地戚受名忧根故。瑜伽论说：生地狱中诸有情类，异熟无间有异熟生，若忧相续。又说：地狱寻、伺忧俱，一分鬼趣，傍生亦尔。故知意地尤重戚受，尚名为忧，况余轻者？

    讲解：诸逼迫受，若与前五识相应的，通常都叫做苦受。但若与意识相应，则有两家不同的异说。第一家认为：与意识相应的只是忧，以其逼迫心的缘故，因为诸圣人之教，都说意识戚受称为忧根。《瑜伽论》上也说：生于地狱中的有情，他们的异熟报果从无有间断之时，由异熟所生的前六识，前五识所受的逼迫是苦，第六识所受的逼迫是忧，如是苦、忧相续而没有休止。

    《瑜伽论》又说：地狱里的有情，其寻、伺二位心所都与忧相应。一部分鬼趣和傍生趣也是如此，所以知道意识所感于地狱的最重逼迫，不称为苦而称为忧。地狱之苦尚名为忧，何况其余诸趣轻微的逼迫，自然也是忧了。

    论文六：有义：通二，人、天中者恒名为忧，非尤重故。傍生、鬼界名忧名苦，杂受纯受有轻重故。捺落迦中唯名为苦，纯受尤重无分别故。瑜伽论说：若任运生一切烦恼，皆于三受现行可得，广说如前。又说：俱生萨迦耶见，唯无记性。彼边执见应知亦尔。此俱苦受非忧根摄，论说忧根非无记故。又，瑜伽说：地狱诸根余三现行定不成就，纯苦鬼界傍生亦尔。余三定是乐、喜、忧根，以彼必成现行舍故。

    讲解：第二家护法论师认为：意识被逼迫时，通于忧、苦二受。在人道和天道中，通常都称忧受，因为这不是重逼。在畜生道和饿鬼道中，夹杂有喜乐的，叫做忧受；如果纯是逼迫而没有喜乐参杂在内，那就叫做苦受了。因为杂受轻，纯受重，所以才有忧、苦的分别。在捺落迦受罪处，那些地狱里的逼迫，唯名为苦，不名为忧。（注：捺落迦：梵语音译，亦称那落迦，意译不乐、可厌、苦具等；意谓地下牢狱。）同为在极严重的逼迫里，还分什么苦受忧受呢？

    《瑜伽论》上说：若是任运而生的一切烦恼，都与苦、乐、舍三受相应，戚受名苦，不称为忧，已如前说。又说：第七识与生俱来的萨迦耶见（注：我见），以及执常执断的边见，都是有覆无记所摄，这二见相应的苦受，自然是苦根，不是忧根所摄。因为论上说：忧根不是无记，而是染性。《瑜伽论》上又说：地狱有情，在二十二根中，十九根现行，‘余三’的乐根、喜根、忧根只有种子，不能生起现行。因为地狱界有情只有苦受，纯苦的鬼界和畜生界也是如此。所以不起现行的三根，就是乐根、喜根、忧根。为什么呢？因为七、八二识相续不断，必定成就现行舍受。

    论文七：岂不容舍，彼定不成。宁知彼文唯说容受，应不说彼定成意根。彼六容识有时无故。不应彼论唯说容受，通说意根无异因故。又若彼论依容受说，如何说彼定成八根？若谓五识不相续故，定说忧根为第八者，死生闷绝宁有忧根？有执苦根为第八者，亦同此破。设执一形为第八者，理亦不然，形不定故，彼恶业招容无形故。彼因恶业，令五根门恒受苦故，定成眼等，必有一形，于彼何用？非于无间大地狱中，可有希求淫欲事故。由斯第八定是舍根，第七、八识舍相应故。如极乐地意悦名乐无有喜根，故极苦处，意迫名苦无有忧根，故余三言定忧、喜、乐。余处说彼有等流乐，应知彼依随转理说。或彼通说余杂受处，无异熟乐名纯苦故。

    讲解：前面两家诤论的重点，在《瑜伽论》上说：‘地狱定成八根，余三定不成就’这句话。第一家主张地狱定成八根，第七根是意根，第八根是忧根，余三是乐根、喜根、舍根；而第二家护法主张，第七根是苦根，第八根是舍根，余三是乐根、喜根、忧根。舍根在‘定成八根’之列。

    这时第一家诘难曰：地狱有情完全是不可意境，那里容有舍受呢？并且论上说，‘余三’不成就，你怎知道不是舍受不成就，而是乐、喜、忧三受不成就呢？所以第一家要在余三中去掉舍受，加上忧受。

    护法论师回答：你怎么知道‘余三定不成就’就是舍受呢？如果是舍受的话，就应当不说定成意根啊。因为意根的建立，一则与舍受相应，二则能生意识。现在舍受既不成就，六转识又有时间断。可见意根不能成就，意根既不能成就，那第七识还是苦根。第七识既是苦根，那第八识当然是舍根而不是忧根了。《瑜伽论》上说‘余三不成就’，其中不成就说的就是舍受。如果认为因为五识不相续，所以一定要说忧根为第八根。在死生闷绝时怎么会有忧根呢？

    有一种人执苦根为第八根，此不应理，亦同此破。倘若执于男女二形的淫根，成就一形为第八根者，理亦不然，因为形是不一定的，由恶业招感的地狱罪报，也可能是无形的。地狱众生既由恶业之故，使五根不断受苦，才成就了眼等五根，试问他要男根何用？总不能说在无间大地狱中，还希望做出淫欲的行为。基于以上理由，那第八决定是舍根了。因为恒转的第七、八二识，是与舍受相应的。例如第三禅定的极乐地，只有意识所感的适悦名叫乐受，而没有喜根。所以地狱的极苦处，也只有意识所感的逼迫名叫苦受，而没有忧根。因此，那所谓‘余三不成就’，决定是忧、喜、乐三受，而不是舍受。

    那么，何以《摄论》上说：苦处也有等流之乐呢？须知这是随顺小乘转说，或者是通说其余的鬼、畜二趣，他们虽在受苦，间或也有少分等流乐受。所以叫做其余的杂受处。在无间地狱里毫无异熟乐之可言，全是纯苦之受。

    论文八：然诸圣教，意地戚受名忧根者，依多分说，或随转门，无相违过。瑜伽论说：生地狱中诸有情类，异熟无间有异熟生苦忧相续。又说，地狱寻、伺、忧俱，一分鬼趣，傍生亦尔者，亦依随转门。又彼苦根意识俱者，是余忧类，假说为忧。或彼苦根损身心故，虽苦根摄，而亦名忧。如近分喜，益身心故，虽是喜根而亦名乐。显扬论等具显此义。然未至地定无乐根，彼说唯有十一根故。由此应知意地戚受，纯受苦处亦苦根摄。此等圣教差别多门。恐文增广故不繁述。

    讲解：然而有经论上说：与意识相应的戚受叫做忧根。但那不是单约地狱来论，而是依人、天趣的全部，和鬼、畜趣的一部分而说的，或者是随顺小乘有部而说的，这和《瑜伽论》并不矛盾。《瑜珈论》上说：‘生在地狱里的有情，他们的异熟识没有间断；有异熟所生的前六识，五识所受的是苦；意识所受的是忧，就这样苦、忧相续。’又说：‘地狱有情，他们与意识相应的寻、伺二法，也与忧根相应。’不但地狱，就是一部分鬼趣和畜生也是这样，这也是随转小乘有部教理所说的方便法门。再者，地狱苦根与意识相应的，也同其余人、天等杂受处的忧根相似，虽亦假说为忧，宝际上并不是真正的忧受，而是假说为忧。地狱苦根能损害有情身心，虽属苦根所摄，但也可称为忧受。就像在初、二禅天未到根本定的近分定时，身心感到喜悦的顺益，虽是喜根，也可称为乐受。在《显扬论》等都有所显示此义。由此应知，意地戚楚之受，在纯粹受苦的处所也属于苦根。像这样的圣人教诲，差别是多方面的，如三受、五受、有报、无报、界地系、何地断等，涉及广泛，不再细述。

    论文九：有义，六识三受不俱，皆外门转，互相违故。五俱意识同五所缘，五三受俱，意亦应尔，便违正理，故必不俱。瑜伽等说：藏识一时与转识相应，三受俱起者，彼依多念，如说一心非一生灭，无相违过。

    讲解：这是两家在六识与三受俱不俱起上所起的诤论。第一家说：六识与三受是不能俱起的。因为六识都是向外缘境，而三受则是互相违背的。因为五俱意识与五识俱缘现境时，五识与三受相应，当然也与意识相应。这样一念有苦、乐、舍三受，便与六识同缘的正理相违背。所以六识与三受必不俱转。虽然《瑜伽》、《显扬》等论上说：第八藏识一时与前六识相应，三受俱起，但那是依多念而言，并不是一念俱起三受。如说一心，并不表示一念生灭，所以没有三受相违的过失。

    论文十：有义：六识三受容俱，顺、违、中境，容俱受故。意不定与五受同故。于偏注境起一受故，无偏注者便起舍故。由斯六识三受容俱。得自在位唯乐、喜、舍，诸佛已断忧苦事故。

    讲解：第二家护法认为：六识与三受是可以俱起的，它可以接受顺境、违境、顺违俱非的中庸境。但意识不一定与五识的三受相同。当意识与五识同缘五境时，那意识若专注于顺境，便生起乐受；若专注于违境，便生起苦受，若无偏重的顺、违之境可资专注，那便生起舍受。所以六识可以与三受相应俱起。以上是指未得自在的有漏位而言，若得自在位后，那就只有乐受、喜受、舍受相应，因为诸佛已经断了忧、苦之因。


第六章　心所相应门．详释六位心所

    第六章　心所相应门．详释六位心所

    第一节　遍行．别境心所

    论文一：前所略标六位心所，今应广显彼差别相。且初二位其相云何？颂曰：初遍行触等，次别境谓欲，胜解念定慧，所缘事不同。

    讲解：这是次举六颂的第二颂。前面已经略把六位心所标明，现在再详细解释六位心所的差别。问曰：这六位心所的前二位，他们的义相是怎么样呢？颂文答曰：‘初遍行触等，次别境谓欲，胜解念定慧，所缘事不同。’

    论文二：论曰：六位中初遍行心所即触等五，如前广说。此遍行相云何应知？由教及理为定量故。此中教者，如契经言：眼、色为缘生于眼识，三和合触，与触俱生有受、想、思。乃至广说，由斯触等四是遍行。又契经说：若根不坏，境界现前，作意正起，方能生识。余经复言：若复于此作意，即于此了别，若于此了别，即于此作意。是故此二恒共和合。乃至广说，由此作意亦是遍行。此等圣教诚证不一。

    讲解：颂文第一句‘初遍行触等’，是说六位中的遍行心所有五，就是触、作意、受、想、思。这五个遍行心所，在前面解释初能变中已经说过。然而这五个遍行的义相是什么呢？我们由圣教和正理来做认定的标准。圣教的经上说：‘以眼根为增上缘，色境为所缘缘，便能生起眼识。根、境、识三法和合便能生触。与触同时生起的有受、想、思。乃至广泛的说，以法为缘而生意识。所以知道这触、受、想、思四法是遍行心所。《象迹喻经》上说：倘若眼根没有坏，又有境界现前，而且作意生起，然后才能生识。《起尽经》上说：在这个境上生起作意，就在这个境生起了别；在这个境生起了别，也就在这个境上生起作意。因此，这作意与了别二法时常和合一处。由此可知作意心所也是遍行心所法之一。像这样的圣教很多，不止一经。

    论文三：理谓识起必有三和，彼定生触，必由触有。若无触者，心、心所法应不和合触一境故。作意引心令趣自境，此若无者，心应无故。受能领纳顺、违、中境，令心等起欢、戚、舍相，无心起时，无随一故。想能安立自境分齐，若心起时无此想者，应不能取境分齐相。思令心取正因等相，造作善等，无心起位无此随一，故必有思。由此证知触等五法心起必有，故是遍行。余非遍行，义至当说。

    讲解：前面是引教为证，现在是从理论上说。诸识生起，必定依根缘境，根、境、识三法和合，必定生触。反之三法和合，也必定因触而有。倘若没有触，心、心所法就不能和合起来共触一境，所以肯定触是遍行心所。

    作意心所的功能，是引导心王使他趣向于自心所缘的外境。作意若无，心王就不能生起。受能领纳适意的顺境、不适意的违境、顺违俱非的中庸境，使心随境生起乐、苦、舍相，这三相就叫做‘三受’。想的功能，是在自心所取的境上，安立了或青、或黄，或多、或少，或大、小等差别相。当心生起时，假使没有想心所，就不能取境界的分别相。还有思心所，他能令心取正、邪等业因，来造作善、恶、无记等业。在没有心识生起时，就没有这个思心所随之而起。但有心识生起，必有此思。由于以上道理的证明，我们知道这遍行五心所，心起必有，故称遍行。余非遍行，下文当说。

    论文四：次别境者，谓欲至慧，所缘境事多分不同，故六位中次初说故。云所为欲，于所乐境希望为性，勤依为业。有义：所乐谓可欣境，于可欣事欲见、闻等有希望故。于所厌事希彼不合，望彼别离，岂非有欲？此但求彼不合离时，可欣自体，非可厌事，故于可厌及中容境一向无欲。缘可欣事若不希望，亦无欲起。

    讲解：其次讲颂文的后三句：‘次别境谓欲，胜解念定慧，所缘事不同。’什么叫做‘欲’呢？就是对于所乐的境界生起希望，这是其体性；辛勤的追求，就是其业用。于此，有三家不同的异说。第一家说：所乐的定义，就是可欣的境界。对于可欣的境界，有欲见、欲闻、欲觉、欲知的希望，这就是欲。有问曰：对于讨厌的事未遇合的，希望不要遇合；既遇合的，希望早点离开，这岂不也是欲吗？论主答曰：这不过是希望不合，人们只追求可欣的外境，并不追求可厌的外境。因为对于可厌境和中庸境，不生希望，也没有欲心生起。

    论文五：有义：所乐，谓所求境，于可欣厌求合离等有希望故。于中庸境一向无欲，缘欣厌事若不希求亦无欲起。有义：所乐谓欲观境，于一切事欲观察者，有希望故。若不欲观，随因境势任运缘者，即全无欲，由斯理趣，欲非遍行。有说，要由希望境力，诸心、心所方取所缘，故经说欲为诸法本。

    讲解：第二家的解释是：所乐者就是所求境，对于可欣的事未合求合，既合求不离；对于可厌的事，未合求不合，既合求离。因为有此希望，所以才叫做欲。对于中庸境一向无欲。对于所缘可欣、可厌之境，若无合、离的希求，也不会有欲心所生起。

    第三家则说：所乐就是欲观境，对一切想观察的事物就有希望，这个观察的希望就是欲。如果你不想观察，只是随著境界的力任运而缘，那就不管他是好是坏，都不会有欲心所生起。由于这个道理，所以欲心所但属别境，而不属遍行。小乘有部说：因为有希望缘取外境之力，那一切心、心所才能取境，所以经上说欲是一切法的根本。

    论文六：彼说不然，心等取境由作意故，诸圣教说：作意现前能生识故，曾无处说，由欲能生心、心所故。如说诸法爱为根本，岂心、心所皆由爱生？故说欲为诸法本者，说欲所起一切事业，或说善欲能发正勤，由彼助成一切善事，故论说此勤依为业。

    讲解：论主答曰：这种说法不对，心、心所之缘取外境是由于作意，并不是欲。很多的经论上说：作意现前能够生识，没有一处说由欲而生起心、心所法。例如有说诸法以爱为本，难道说心、心所都是由爱而起吗？以此例知，所谓‘欲为诸法根本’的话，那是说，由欲所起的一切行为，都是以欲为根本的。或说善法的欲，能发正勤，复由正勤来助成欲的一切善事。所以《显扬圣教论》上说：欲是生起正勤的动力。

    论文七：云何胜解？于决定境印持为性，不可引转为业。谓邪正等教理证力，于所取境审决印持，由此异缘不能引转。故犹豫境胜解全无，非审决心亦无胜解，由斯胜解非遍行摄。有说：心等取自境时无拘碍故，皆有胜解。彼说非理，所以者何？能不碍者即诸法故，所不碍者即心等故。胜发起者根作意故，若由此故彼胜发起，此应复待余，便有无穷失。

    讲解：什么叫做胜解呢？就是对于外境的判断，一经决定，即不可引转。意思是说：对于邪教、邪理，或正教、正理，经过深思熟虑决定以后，纵然再遇异缘，也不能使他改变既定的决心。因此，犹豫不决的境界没有胜解，不是审决之心也没有胜解。由此可见，胜解心所但属别境，而不是遍行。

    说一切有部认为：只要心、心所缘取自心所缘的外境时，没有东西从中阻碍，都有胜解，何待审决印持？论主反驳说：这种说法不合理，因为能不阻碍的，是所缘的一切法，不是胜解；所不阻碍的，是心、心所法本身，也不是胜解。怎么以不碍为胜解呢？若说不碍的心、心所，由胜解的增上胜缘所发起，那也不对，那是根和作意二法，与胜解无关。若说胜解的增上之力，根和作意才能发起，那这胜解也应当更待余法来做他的增上缘，这样的缘复待缘，岂非有无穷的过失吗？

    论文八：云何为念，于曾习境令心明记不忘为性，定依为业。谓数忆持曾所受境令不忘失，能引定故。于曾未受体类境中全不起念。设曾所受不能明记念亦不生。故念必非遍行所摄。有说：心起，必与念俱，能为后时忆念因故。彼说非理，勿于后时，有痴、信等。前亦有故。前心、心所或想势力，足为后时忆念因故。

    讲解：什么叫做念？对于曾经熏习过的境界，令心明白记忆而不忘失，是禅定所依的基础。意思就是说，数数忆持，不断专注于曾经领受过的境界，令心不忘，能引生定。例如专念曾经闻受的正法，能令一心不乱，便是引定。对于未曾经受的事物不会起任何忆念。对于曾经闻受之境而不能明记不忘，则‘念’也不会生起。所以念心所但属别境，而不属于遍行。

    说一切有部认为：‘凡是心生起的时候，必定与念心所同起，能做为后来忆念的原因。’论主驳曰：这样说法不合理，不可说后面有痴、信等，从前也有，就是遍行，如果这样说，那痴但属染；信但属善，他如何能是遍行？再者，前心、心所取境熏习的功能，或凭想像明记的势力，已经足够为后时忆念之因，就不需要前念了。

    论文九：云何为定？于所观境令心专注，不散为性，智依为业。谓观得、失、俱非境中，由定令心专注不散，依斯便有决择智生。心专注言显所欲住即便能住，非唯一境。不尔，见道历观诸谛，前后境别应无等持。若不系心，专注于境，便无定起，故非遍行。有说：尔时亦有定起，但相微隐，应说诚言。若定能令心等和合，同趣一境，故是遍行。理亦不然，是触用故。若谓此定令刹那顷心不易缘，故遍行摄。亦不应理，一刹那心，自于所缘无易义故。若言由定心取所缘故遍行摄，彼亦非理，作意令心取所缘故。有说：此定体即是心。经说为心学，心一境性故。彼非诚证，依定摄心，令心一境，说彼言故。根、力、觉支、道支等摄。如念、慧等非即心故。

    讲解：什么叫做定呢？在所观的外境上，令心专注而不散乱，智慧依此而生。也就是说，在观察或得、或失，或得失俱非的境中，由此定令心专注而不散乱。依此便有决择的无漏智慧生起。所谓‘心专注’的话，是显示心所欲住于此，便能安住，并不是前后唯缘一境。否则，见道位中以十六心观各个真理时，前后之境就有区别，就不会有平等持心的三昧定了。若以散心别缘，而不系心专注于转深境位，便不会有禅定生起。所以定心所但属别境，而不是遍行。

    正理师认为：心不专注时也有定生起，不过他的行相微隐难知。谕主破他说：解释法义应说诚实语，如果说定能使心、心所和合同缘一境，所以也是遍行，这理由不对，和合是触的作用，与定无关。若说此定能令一刹那顷的心住于一境，不改易所缘，就是遍行所摄，也不合理，因为一刹那的心自能对于所缘的境没有改易，也不必有定。如果说由定才能令心取境，所以他是遍行所摄，也不合理，因为令心取境的是作意的功能，不是定的作用。

    又有经量部师说：这个定的自体就是心，不是另外有体。因为经上说三学中定是心学，令心一境为性。论主破斥说：心学是说定依摄于心，使心专注一境，所以称为心。并不是其体就是心。定是五根中的定根，五力中的定力，七觉支中的定觉支，八圣道中的正定分所摄，就像别境中的念、慧等心所一样，各有各体，并非定就是心。

    论文十：云何为慧？于所观境简择为性，断疑为业。谓观得、失、俱非境中，由慧推求得决定故。于非观境愚昧心中无简择故，非遍行摄。有说：尔时亦有慧起，但相微隐。天爱宁知？对法说为大地法故。诸部对法，展转相违，汝等如何执为定量。唯触等五经说遍行，说十非经，不应固执。然欲等五非触等故，定非遍行，如信、贪等。

    讲解：什么叫做慧呢？在所观察的境上，简别决择为性；断绝疑惑为业。对于所经受或得、或失，或得失俱非的尘境中，由慧推求，而得决定无疑。在非所观境、及愚昧心中，就没有简择的智慧。所以慧心所但属别境，不是遍行所摄。

    有部师说：在非所观境及愚昧心中也有慧起，不过他的行相微细隐伏，如微细物为大器盛受，不易显知。不过对法论上说：慧心所为十大地法之一，而小乘的大地法即相当于大乘的遍行。(注：大地法：俱舍论颂云：受想思触欲，慧念与作意，胜解三摩地，遍于一切心。此十皆名大地法）

    论主破曰：小乘诸部对法，如发智论、六足论等，展转差别相违，你们如何拿它作为定量？只有触、作意、受、想、思五法，经上说是遍行；至于有十个遍行的话，那不是经上所说。这欲、胜解、念、定、慧五法，与触等不同，别境所摄，一定不是遍行，例如善法的信等，烦恼法的贪等，属性不同。

    论文十一：有义：此五定互相资。随一起时必有余四。有义：不定。瑜伽说：此四一切中无后二故。又说：此五缘四境生，所缘能缘非定俱故。应说：此五或时起一，谓于所乐唯起希望，或于决定唯起印解，或于曾习唯起忆念，或于所观唯起专注。谓愚昧类为止散心，虽专注所缘，而不能简择。世共知彼有定无慧。

    讲解：此下讲欲等五法是否俱起，此有两家相反的说法。第一家说：这欲、胜解、念、定、慧五法，决定互相资助，有一法起时，其余的四法必定与之同起。第二家说：不然，因为《瑜伽论》上说：这五个心所，在四一切中（注：一切性、一切地、一切时、一切俱）没有后面一切时、一切俱两个一切。论上又说：这五个心所，是缘四种境界而生的，欲缘所乐境，胜解缘决定境，念缘曾习境，定、慧缘所观境。这所缘的四种境界，及能缘的五个心所，他们不可能同时俱起。

    这五个心所，对境一次只起一个，就是或在所乐境上，唯起希望的欲；或在决定境上，唯起印持的胜解；或在曾习境上，唯起不忘的念；或在所观境上，但起专注的定。愚昧的人为了摄敛粗动散心，虽然专注于所缘之境，但不能对此进行鉴别和判断，所以世间共知他们有定无慧。

    论文十二：彼加行位，少有闻思，故说等持缘所观境，或依多分，故说是言，如戏忘天专注一境，起贪、嗔等，有定无慧，诸如是等，其类实繁。或于所观，唯起简择。谓不专注，驰散推求。

    讲述：那些愚昧的人，在定前的加行位时，也有一点闻教于师，思维于己的闻、思二慧，所以说定所缘境，也叫做所观境。或者依所观之境，除少数人是有定无慧外，大部分的行者是定、慧俱起，所以就依此来说，这定境名为所观。例如欲界戏忘天人，他们亦专注于游乐一境，忘失正念，起了贪、嗔等烦恼，所以说他们于所观境有定无慧。像这样有定无慧的情况实在很多。或者是在所观境上，唯起简择之慧，谓掉举多者不能专注一境，唯务驰散推求法相或义理，所以有慧无定。

    论文十三：或时起二，谓于所乐、决定境中，起欲、胜解。或于所乐、曾习境中起欲及念。如是乃至于所观境起定及慧，合有十二。或时起三，谓于所乐、决定、曾习，起欲、解、念，如是乃至于曾习、所观起念、定、慧，合有十三。或时起四，谓于所乐、决定、曾习、所观境中起前四种，如是乃至于决定、曾习、所观境中起后四种，合有五四。或时起五，谓于所乐、决定、曾习、所观境中，俱起五种。如是于四起欲等五，总别合有三十一句。或有心位五皆不起，如非四境、率尔堕心及藏识俱，此类非一。

    讲述：有时对境一次，生起两种心所，如一者于所乐、决定境中，生起欲和胜解。二者于所乐、曾习境中，生起欲和念。三者于所乐及所观境中，生起欲和定。四者于所乐及所观境中，生起欲和慧。五者对决定及曾习境，生起胜解和念。六者对决定及所观境，生起胜解和定。七者对决定及所观境，生起胜解和慧。八者对曾习及所观境，生起念和定。九者对曾习及所观境，生起念和慧。十者对所观境，生起定及慧，合有十个二。

    有时对境一次，生起三个心所，合十次生起的心所，总共有十个三。如于所乐、决定、曾习三境中，生起欲、胜解、念。于所乐、决定、所观三境中，生起欲、胜解、定。余略。有时对境一次，生起四个心所，合五次所起的心所，有五个四。如于所乐、决定、曾习、所观境中，生起欲、胜解、念、定。于所乐、决定、曾习、所观境中，生起欲、胜解、念、慧。有时对境一次，生起五个心所，这当然是于所乐、决定、曾习、所观境中，生起欲、胜解、念、定、慧五个心所。

    综上所述，一次起一个心所的有五次，一次起两个心所的有十次，一次起三个心所的也有十次，一次起四个心所的有五次，一次起五个心所的有一次。这样连一次的‘总’及三十次的‘别’，一共三十一次。但这欲、胜解，念、定、慧五个心所，莫说在无心位，就是在有心位，也有全部不起的时侯。如果不是所乐、决定、曾习、所观的四境现前，而是率尔心所起的六识，及与藏识相应的心所，都没有它们。这一类说法很多，非止一类。

    论文十四：第七、八识，此别境五，随位有无，如前已说。第六意识诸位容俱，依转未转皆不遮故。有义：五识此五皆无。缘已得境无希望故，不能审决无印持故。恒取新境无追忆故，自性散动无专注故，不能推度无简择故。

    讲解：第七、八二识与五位别境，随位或有或无，前面已说。至于第六意识，在未转依位，或五法俱起，或一一别起；若在已转依位，那是全部都有的。因为无论转依的无漏，或未转依的有漏，都没有遮简。若在前五识，则有两家异说。第一家说：前五识里没有别境五心所，因为它只缘已得之境，不缘未得之境，所以没有希望的欲；它不能审虑作出决定，所以没有胜解。它永远缘取新境，不缘过去，所以没有追忆的念。它自性散动，不能专注一境，所以没有定。它不能推求和量度，所以也没有简择的慧。

    论文十五：有义：五识容有此五，虽无于境增上希望，而有微劣乐境义故。于境虽无增上审决，而有微劣印境义故。虽无明记曾习境体，而有微劣念境类故。虽不作意系念一境，而有微劣专注义故。遮等引故，说性散动，非遮等持故容有定。虽于所缘不能推度，而有微劣简择义故。由此圣教说眼、耳通，是眼、耳识相应智性。余三准此有慧无失。未自在位此五或无，得自在时此五定有。乐观诸境欲无减故，印境胜解常无减故，忆习增受念无减故，又佛五识缘三世故，如来无有不定心故，五识皆有作事智故。

    讲解：第二家说，前五识里，容或俱有这别境五法。因为前五识的缘境，虽然没有强烈的希望，但在第六识的导引下，对于乐境也有微劣的希望，所以有欲。虽然没有强盛的审决判断，但也有微劣印境的意义，所以有胜解。虽然不能明记曾经历境界，但也有微劣对现境的忆念，所以有念。虽然没有作意加行系念一境，但也有微劣专注的意义。因为其不能有等引之定，所以说它‘自性散动’，但不能否认有它有等持之定，所以容许有定。前五识虽然对于所缘外境不能推理，但有微弱的鉴别意义，所以《瑜伽师地论》上说：眼通与耳通，是与眼、耳二识相应的智慧。既然眼、耳二识有慧，所以其余的鼻、舌、身三识，与前二识一样，也有智慧，此说并无过失。

    在没有得到自在的凡位，这五种别境或许没有，但在自在解脱位，这五种别境则决定都有。因为自在圣位的五识，于乐观境的欲，印持境的胜解，忆习曾受境的念，都没有减损。再者，佛地的五识，能缘过去、现在、未来三世，佛心没有不定的时候。佛地的五识已经转为成所作智，又岂能无慧。（注：等持，定的别名，意谓平等持心，心住一境，平等维持。）

    论文十六：此别境五，何受相应？有义：欲三，除忧、苦受，以彼二境非所乐故。余四通四，唯除苦受，以审决等五识无故。

    讲解：这五个别境心所，与喜、乐、忧、苦、舍五受的何受相应呢？此有两家不同的说法。第一家说：除了忧、苦二受，欲心所和喜、乐、舍三受相应。因为忧、苦二受不是欲的所乐境。其余的胜解、念、定、慧四心所，则通于五受之四，唯除去苦受。因为与苦受相应的五识里，没有这胜解、念、定、慧的四个心所。

    论文十七：有义：一切五受相应。论说忧根于无上法，思慕愁戚求欲证故，纯受苦处希求解脱，意有苦根，前已说故。论说贪爱，忧苦相应，此贪爱俱必有欲故，苦根既有意识相应，审决等四苦俱何咎？又五识俱，亦有微细印境等四，义如前说。由斯欲等，五受相应。此五复依性、界、学等，诸门分别。如理应思。

    讲解：第二家说：五个别境都与五受相应。因为《瑜伽师地论》说：忧根对于无上妙法思慕愁戚，希望得证，是欲与忧相应之证。纯受苦处的地狱、鬼、畜，他们那希求解脱的意识里，也有苦根，前面已经说过。所以欲心所，也与苦受相应。论上还说，贪爱与忧、苦相应，此贪爱俱起时，必定有欲，这就是欲心所与忧、苦并俱之证。苦根既与意识相应，那其余与意识相应的胜解、念、定、慧四法，也可与苦受相应，有何过咎？

    再者，五识与意识俱起时，亦有微细印持境的胜解，曾习境的念，所观境的定、慧四法，其义已如前面所说。因此别境五法，都与五受相应。

    这五个别境，和有心必起的五遍行不同，所以在别境五法后，复依三性、三界、三学等诸门加以分别。例如：四一切的一切性，就是三性的分别；一切地，就是三界的分别；转依、未转依，就是依断见、思二惑的无学、未断思惑的有学、二惑未断的非学无学，这三学的分别，应该如理思索。

    第二节　善心所

    论文一：已说遍行、别境二位，善位心所其相云何？颂曰：善谓信惭愧，无贪等三根，勤安不放逸，行舍及不害。论曰：唯善心俱名善心所，谓信、惭等，定有十一。云何为信？于实德能，深忍乐欲，心净为性，对治不信，乐善为业。然信差别，略有三种：一信实有，谓于诸法实事、理中，深信忍故；二信有德，谓于三宝真净德中深信乐故。三信有能，谓于一切世、出世善深信有力，能得能成，起希望故。由斯对治不信彼心。爱乐证修世出世善。

    讲解：这是次举六颂的第三颂。前面已说遍行、别境二位，至于第三位的善心所，其义相是怎么样呢？颂文说：善心所十一个，是信、惭、愧、无贪、无嗔、无痴、勤、轻安、不放逸、行舍、不害。分别解释如下。

    长行解释颂文曰：所谓善心所，是唯独与善心俱起的心所，才能叫做善心所。善心所决定只有十一个。什么叫做信呢？对于实、德、能诸法，深能忍可欲乐，以心清净为性，以对治不信，好乐善法为其业用。然而信的差别有三种：第一是信实有体性之法，对于佛陀所说的世出世间诸法，实有其事，实有正理中的正因正果，深信不疑。第二是信有德，对于佛、法、僧三宝的真净功德，深信而喜乐。第三种是信有能，对于一切世、出世间之善法，深信其有势力，能得乐果，能成圣道，生起希望愿欲。由此三信，能够对治不信此三之心，以好乐而修证世、出世间的一切善法。

    论文二：忍谓胜解，此即信因。乐欲谓欲，即是信果。确陈此信自相是何？岂不适言心净为性？此犹未了彼心净言。若净即心，应非心所，若令心净惭等何别？心俱净法为难亦然。此性澄清能净心等，以心胜故立心净名，如水清珠能清浊水。惭等虽善，非净为相，此净为相，无滥彼失。又诸染法各别有相，唯有不信自相浑浊，复能浑浊余心、心所，如极秽物自秽秽他，信正翻彼，故净为相。

    讲解：外人问曰：根据上面所说，我们已经知道忍可的意义，就是胜解；也就是能生信的因。乐欲，就是欲心所，也就是信所生的果。那么，更应当确实指陈，这信的自相是什么？论主答曰：适才已说过，心净就是信的特性。

    外人诘难说：你还没有讲清楚‘心净’的意思，如果‘净就是心’，这是持业释，信就不应当是心所法。如果‘心净’是使心清净，这就是依主释，这与惭等又有什么区别呢？如果‘心净’是指心与净法相俱，此为邻近释，其诘难同上所述。

    论主解释说：这信的体性湛然澄清，能令其余的心、心所法清净。因为心王是主，所以但说心净，实际上亦包括心所。就像水清珠投入浊水，能使浊水清净一样。惭等体性是善，而他们的自相并非能净，不过是所净而已。唯有这信心所是以能净为自相。所以信和惭等并没有相滥的过失。

    再者，一切染法各有各的自相，唯有大随烦恼里的‘不信’，它不但自相浑浊，并且能令其余的心、心所法也和它一样浑浊。好像一个极其污秽的东西，不但自己污秽，而且也染污了其他的东西。信和浑浊的不信相反，所以信以净为特性。

    论文三：有说：信者爱乐为相。应通三性，体应即欲，又应苦集非信所缘。有执信者随顺为相。应通三性，即胜解欲。若印顺者即胜解故，若乐顺者即是欲故。离彼二体无顺相故，由此应知心净是信。

    讲解：有人说：信是以爱乐为其特性。如果照这样说，那信就应当不但是善，而是遍通善、恶、无记三性了。因为爱乐是‘欲’所缘之境，而‘欲’是通于三性的。再者，苦、集、灭、道四谛，都是信的所缘境，如果以爱乐为信，那苦、集二谛就不是信的所缘境了。那有圣者爱乐苦、集之理？

    又有诘难曰：信是以随顺为其特性。论主难曰：不然，境有三性，当然随顺亦通三性。果然如此，则随顺就成了胜解或欲，而不是信心所了。诘难者转救曰：虽然说随顺，本体并非胜解或欲。论主反难：不然，如果认定随顺，便是胜解，如果是所乐的随顺，便是欲。那么离开胜解、欲两个心所，便没有随顺的自相可言了。由此应知，所谓爱乐、随顺，都不是信的自相，心净才是信的自相。

    论文四：云何为惭？依自法力，崇重贤、善为性，对治无惭，止息恶行为业。谓依自法尊贵增上，崇重贤、善，羞耻过恶，对治无惭，息诸恶行。

    讲解：什么叫做惭？依靠自己之力和所理解的法，崇敬有贤德的人；对于一切有漏、无漏的善法皆生崇重，对治无惭，止息恶行。换句话说：就是依靠自身的自尊自重之力，去崇贤重善，以自己所犯的过恶感到羞耻，对治无惭，止息一切非法的恶行。

    论文五：云何为愧？依世间力，轻拒暴恶为性，对治无愧，止息恶行为业。谓依世间诃厌增上，轻拒暴恶羞耻过罪，对治无愧，息诸恶业。

    讲解：什么叫做愧？依于世间舆论的力量，对于暴恶的事拒而不作。愧的业用是对治无愧，止息恶行。也就是说：依于世人的诃责，和自己对于暴行的厌恶，以此二种增上缘力，拒与暴恶之人为伍，拒作暴恶之事，以对治无愧，止息一切非法的恶行。

    论文六：羞耻过恶，是二通相，故诸圣教假说为体。若执羞耻为二别相，应惭与愧体无差别。则此二法定不相应。非受、想等有此义故。若待自他立二别者，应非实有，便违圣教。若许惭、愧实而别起，复违论说十遍善心。

    讲解：对于自己所犯的过恶感到羞耻，是惭、愧共同的特性。所以诸圣教都依此共同特性，假说惭、愧二法别体。如果执著于羞耻是惭、愧二法的别相，则惭也是羞耻，愧也是羞耻，惭、愧二法就没有差别了。既没有差别，那就是一体。如是一体，则二法就不能相应同起。例如受、想等遍行五法各别有体，那才能相应，并不是一体相应。如果你们对自法是惭，对世间是愧，这样建立了二个别体，那也不对。因为二法既是待缘而成，那就应当不是实有。然而说不实有，又违背了经典的道理。如果许惭、愧实有而又各别而起，那又违背《瑜伽论》所说：十一种善法除了轻安之外，其余的十种都是遍一切善心，可见不是各别而起。

    论文七：崇重轻拒，若二别者，所缘有异应不俱生。二失既同，何乃偏责。谁言二法所缘有异？不尔、如何？善心起时随缘何境，皆崇重善及轻拒恶义。故惭与愧俱遍善心，所缘无别。岂不我说亦有此义？汝执惭愧自相既同，何理能遮前所设难？然圣教说顾自他者，自法名自，世间名他。或即此中崇拒善恶，于己损、益，名自他故。

    讲解：外人又问：惭是崇重善法，愧是轻拒恶法，以此建立二种别相。所以所缘的境既不相同，那惭、愧二法应当不能俱起。这和不俱、别起的两种过失相同，为什么偏要责难我们？论主回答：谁说惭、愧二法所缘的境有不同呢？外人难曰：不是不同是什么？论主解释：当善心生起的时候，随便缘什么境，都有崇重善法，轻拒恶法的意义，这是惭和愧的二种别相。别相就是不同的功用，惭的功用是崇善，愧的功用是拒恶。

    外人称：照你这样说，岂不和我前面所说一样吗？论主回答：你既然认为惭、愧二法自相相同，你有什么理由可以遮除我前面所设疑难？然而经论对自、他二别的解释是：自立的法叫做自，世间的法叫做他。或者就是上面说的：崇重有益于己的善法叫做‘自’；轻拒有损于己的恶法叫做‘他’。

    论文八：无贪等者，等无嗔、痴。此三名根，生善胜故，三不善根近对治故。云何无贪？于有、有具，无著为性，对治贪著，作善为业。

    讲解：以上合解惭、愧，此下解释颂文的‘无贪等三根’，等者就是连无嗔、无痴都包括在内。这无贪、无嗔、无痴三心所，为什么称为三善根？根者能生义，有能生善法的殊胜功用。又能各别对治三不善根贪、嗔、痴。什么叫做无贪？对于三界和造成三界轮回的条件皆无贪著，这是它的特性，对治贪著，令人行善，这是它的作用。‘于有、有具无著为性’，有是三有，亦即是三界，这是有情的依报。有具是生于三界之因，即惑与业。对三界不生耽著，是无贪的特性。对治贪著，止恶作善，是无贪的业用。

    论文九：云何无嗔？于苦、苦具，无恚为性，对治嗔恚，作善为业。善心起时，随缘何境皆于有等无著无恚。观有等立非要缘彼，如前惭愧观善恶立，故此二种俱遍善心。

    讲解：什么叫做无嗔？逆境当前不生恚恨之心叫无嗔。‘于苦、苦具无恚为性’，苦是三界苦果，即苦苦、坏苦、行苦，苦具是苦果生成之因。对于苦因苦果不起嗔恚，是无嗔的特性；对治嗔恚，止恶作善，是无嗔的业用。有问：无贪缘乐境，无嗔缘苦境，它们缘境有异，怎能同时生起？既不能同时生起，何以能遍一切善心？论主答：当善心起时，随便缘什么境都有它们生起。对于三界的乐境不起贪著，对于三界的苦境不起嗔恨，这是依观待苦乐而建立的。所以无贪、无嗔二法，是俱时而起，遍一切善心。

    论文十：云何无痴，于诸理事明解为性，对治愚痴，作善为业。有义：无痴，即慧为性。集论说此：报、教、证、智，决择为体。生得闻、思、修所生慧，如次皆是决择性故。此虽即慧，为显善品有胜功能，如烦恼见，故复别说。有义：无痴，非即是慧，别有自性正对无明。如无贪、嗔善根摄故。论说大悲，无嗔、痴摄，非根摄故。若彼无痴，以慧为性，大悲如力等应慧等根摄。又若无痴无别自性，如不害等应非实物。便违论说十一善中三世俗有，余皆是实。然集论说慧为体者，举彼因果显此自性，如以忍乐表信自体，理必应尔。以贪、嗔、痴六识相应，正烦恼摄，起恶胜故，立不善根。断彼必由通、别对治。通唯善慧，别即三根，由此无痴必应别有。

    讲解：什么叫做无痴？就是对于一切事理，明确理解而不迷惑，即为其特性；能够对治愚痴，令人止恶为善，即为其业用。如要细释，则有两家不同主张。第一家说：无痴是以别境的慧心所为体。《杂集论》上说：‘报、教、证、智，决择为体’，意思是：报是生得的智慧，因为生得善法以宿习为因；教是闻、思的智慧，就是从听闻正法所得的智慧；证是修得的智慧，就是由修习禅定所得的智慧，而智慧是以拣择和决断为其体性。问：如果说无痴的体是别境中的慧，为什么这善心所里，只说一个慧，而不说其余的四个心所呢？答曰：虽然这无痴的体即是慧，然而为表显善心所有殊胜功能，也和烦恼中的‘见’有胜用一样，所以特别彰显来说。

    第二家则说：无痴的体并不就是慧，他别有自体，正对治不善中的无明，好像无贪对治贪、无嗔对治嗔一样，都是三善根所摄。《瑜伽论》上说：诸佛的大悲，是无嗔和无痴所摄，并没有说是慧根所摄。无痴既然能摄大悲，可见其体性不是慧。如果无痴是以慧为体，那大悲就不是无嗔、无痴所摄，应该和佛的十力、四无畏一样，属于慧根所摄才对。再者，无痴若真没有自体，那就和不放逸、行舍、不害一样，不是实有的东西了。如此，便违背了《瑜伽论》所说：十一种善法中，除了不放逸、行舍、不害三法是世俗假有外，其余八法都是实有。《集论》上说：无痴是以慧为体，那是因为无痴的因果通于生得、闻、思、修四慧，所以举彼因果显此自性。好像‘忍’是信因，‘乐’是信果，即以忍、乐来表显信的自体一样。

    因为贪、嗔、痴是与六识相应的染法，为烦恼所摄，此三者造恶的力量较其余烦恼强胜，所以立它们为三不善根。要断除这三不善根，必须由通、别二种对治。通就是善慧；别就是用无贪对治贪、无嗔对治嗔、无痴对治痴。因为这种道理，无痴应当和无贪、无嗔一样，必定别有自体，才可以对治无明。

    论文十一：勤谓精进，于善恶品修断事中，勇悍为性，对治懈怠，满善为业。勇表胜进，简诸染法。悍表精纯，简净无记，即显精进唯善性摄。此相差别，略有五种：所谓被甲、加行、无下、无退、无足，即经所说有势、有勤、有勇、坚猛、不舍善轭，如次应知。此五别者，谓初发心、自分、胜进、自分行中三品别故。或初发心、长时、无间、殷重、无余，修差别故。或资粮等五道别故，二乘究竟道欣大菩提故，诸佛究竟道利乐他故。或二加行，无间、解脱，胜进别故。

    讲解：什么叫做勤？勤就是精进。在修善断恶的事上，以勇悍为其特性，对治懈怠，以圆满善法为其业用。勇悍的勇，是表示向善的精进，简别不是勇于染污的恶法；勇悍的悍，是表示精纯无杂，连无覆无记也简别净尽。这就表显精进在三性中唯属善性。

    这精进的义相，有五种差别：第一是被甲精进，第二是加行精进，第三是无下劣精进，第四是无退转精进，第五是无喜足精进。这五种精进，也就是经上所说的：有势精进、有勤精进、有勇精进、坚猛精进、不舍善轭精进（注：轭，是车辕前加在牛马颈上的曲木）上面的五种次第，名虽有异，而义实无别。

    五种差别外，还有四种解释。第一种解释是：一初发心，二下品自分行，三中品自分行，四上品自分行，五胜进行。第二种的解释是：一初发心，二长时修，三无间修，四殷重修，五无余修。第三种的解释是：一资粮位，二加行位，三通达位，四修习位，五究竟位。问：三乘究竟无学，既已满足，何以仍须精进？答：二乘的究竟道，是欣向大菩提果；诸佛的究竟道，是利乐有情，所以二乘虽究竟无学，但仍须精进。第四种的解释是：一远加行道，二近加行道，三无间道，四解脱道，五胜进道。

    论文十二：安谓轻安，远离粗重，调畅身心，堪任为性，对治惛沉，转依为业。谓此伏除能障定法。令所依此转安适故。

    讲解：什么叫做安？安就是轻安。因轻而安，所以能远离粗重，使身心调畅，就堪能胜任一切善法。所以它以对治惛沉为体性，转变身心为业用。也就是说，轻安伏除了能障禅定的惛沉，令所依止的身心，转粗重而为安适。

    论文十三：不放逸者，精进三根依所断修、防修为性，对治放逸，成满一切世出世间善事为业。谓即四法，于断修事皆能防修，名不放逸。非别有体，无异相故。于防恶事修善事中，离四功能无别用故。虽信、惭等亦有此能，而方彼四势用微劣。非根遍策，故非此依。岂不防修是此相用？防修何异精进三根？彼要待此方有作用。此应复待余，便有无穷失。勤唯遍策，根但为依，如何说彼有防修用？汝防修用其相云何？若普依持，即无贪等；若遍策录，不异精进。止恶进善即总四法，令不散乱应是等持，令同取境与触何别？令不忘失即应是念。如是推寻不放逸用，离无贪等竟不可得。故不放逸定无别体。

    讲解：什么叫不放逸？它是依精进，无贪、无嗔、无痴四法分位假立，对所断的恶，防令不起，对所修的善，修令增进，就是它的特性；以对治放逸，圆满成就一切世、出世间的善事，就是它的业用。也就是说：即此精进、无贪、无嗔、无痴四法，对于断恶修善的事，能尽到防修的责任。它没有自己独立的自体，离了以上四法，也就没有不放逸的作用。外人问：信、惭、愧等法，也有断恶修善的功能，何以不放逸不依它们为体呢？论主答：信、惭、愧等法虽然也有防恶修善的功能，但比起精进四法来势用较为微劣，以能生一切善法而论，它们不如三善根；以普遍策励一切善心而论，它们又不如精进。所以不放逸但依精进、三善根为体，不依信、惭、愧等法。

    外人问曰：精进只能是普遍的策励善心，而三根只能作为善法的所依，怎能说四法有防恶修善的作用呢？论主反问曰：你们所说的防恶修善的相状是什么样呢？如果普遍依持一切善心称为防恶修善，这就是无贪等三根。如果能够普遍促进善心的增长，这和精进就没有区别。所以防恶修善就是四法。如果令心不散乱就是防恶修善的话，就应当是定。如果令心、心所同取一境称为防恶修善，这与触有什么区别呢？如果使所作善恶忆念不忘称为防恶修善，这就应当是念。按照这种道理推论下去，不放逸的防恶修善作用，离开了精进、三根四法就不可得，所以不放逸肯定没有别体。

    论文十四：云何行舍？精进、三根令心平等、正直，无功用住为性，对治掉举，静住为业。谓即四法令心远离掉举等障，静住名舍。平等、正直、无功用住，初中后位辩舍差别。由不放逸先除杂染，舍复令心寂静而住。此无别体，如不放逸离彼四法无相用故，能令寂静即四法故，所令寂静即心等故。

    讲解：什么叫行舍？这是行蕴中的舍，它自己没有体性，也是依精进、无贪三根分位假立的。行舍令心平等正直，不藉加行功用而得安住。它是以对治不平等的掉举为业用，而住于寂静的心境，就叫做舍。平等、正直、无功用住，就是分初、中、后三位，来辩论舍的差别，即最初先离掉举、惛沉，使心平等。其次再离谄曲，令心正直。最后不藉加行功用，自然能安住寂静。其能令寂静的是四法，所令寂静的是心、心所。

    论文十五：云何不害，于诸有情不为损恼，无嗔为性，能对治害，悲愍为业。谓即无嗔于有情所不为损恼，假名不害。无嗔翻对断物命嗔，不害，正违损恼物害。无嗔与乐，不害拔苦。是谓此二粗相差别。理实无嗔实有自体。不害依彼一分假立，为显慈悲二相别故，利乐有情彼二胜故。有说：不害非即无嗔，别有自体，谓贤善性。此相云何？谓不损恼。无嗔亦尔，宁别有性，谓于有情不为损恼，慈悲贤善是无嗔故。

    讲解：什么叫做不害？就是对于一切有情，不去损害恼乱他们。不害是以无嗔为其体性，能对治损害，以慈悲怜愍为其业用。不害就是无嗔，对一切有情不为损害恼乱之事，以此建立不害的假名。无嗔是对治断害物命的嗔心，不害是违反损恼物类的害。无嗔是与有情以乐；不害是拔众生之苦。这不过是无嗔和不害的粗相。在道理上实说，无慎实有自体，不害是依托无嗔一分所假立的。为了表显无嗔是慈、不害是悲二相的不同，一个是予众生以乐；一个是拔众生之苦，是两种利乐有情的超胜力用。

    还有这样说：不害并非依无嗔为体，而是自已另有体性。这体性就是贤善，而是以不损恼众生为其业用。论主反驳曰：如果是这样，说那不害的体相不是和无嗔一样吗？怎能另外又有体性呢？对于一切有情不为损恼，因为慈悲和贤善就是无嗔。

    论文十六：及显十一义别心所，谓欣厌等善心所法，虽义有别说种种名，而体无异，故不别立。欣谓欲俱无嗔一分，于所欣境不憎恚故。不忿、恨、恼，嫉等亦无。随应正翻嗔一分故。厌谓慧俱无贪一分，于所厌境不染著故。不悭、憍等当知亦然，随应正翻贪一分故。不覆、诳、谄、无贪、痴一分。随应正翻贪痴一分故。

    讲解：十一个善心所已如上释，现在是解释颂中‘行舍及不害’中的这个‘及’字，因为在这个及字后面，还包括著欣、厌等十五种善法。这十五种善法，他们虽然与十一善心所的意义不同，然而他们的体性，却是在十一善心所外更无别体。所以不另外安立。

    欣是欣悦，是与善欲俱起，它是属于无嗔一分所摄。因为在欢欣的境界，不会生起憎恚。不但是欣，其余的不忿、不恨、不恼、不嫉，也是无嗔一分所摄。因为他们各别正翻的忿、恨、恼、嫉四个随惑，都是属于嗔的一分所摄。

    厌是厌离，它和善慧同起，为无贪一分所摄。因为在可厌境上，不会生起染著。其余的不悭、不憍也是一样。这也是正翻小随烦恼中憍和慢两种，属于贪的一分所摄。至于不覆、不诳、不谄三法，是无贪、无痴各一分所摄。因为他们各别正翻的覆、诳、谄三个随惑，是属于贪、痴的一分所摄。

    论文十七：有义：不覆唯无痴一分。无处说覆亦贪一分故。有义：不慢，信一分摄。谓若信彼，不慢彼故。有义：不慢，舍一分摄，心平等者不高慢故。有义：不慢惭一分摄，若崇重彼，不慢彼故。有义：不疑，即信所摄，谓若信彼无犹豫故。有义：不疑，即正胜解，以决定者无犹豫故。有义：不疑，即正慧摄。以正见者无犹豫故。不散乱体即正定摄。正见、正知俱善慧摄。不忘念者即是正念。悔、眠、寻、伺通染不染，如触、欲等，无别翻对。

    讲解：有人说：不覆，唯属无痴一分所摄，不属无贪。没有那个经论说，覆也是贪的一部分，可见不覆和无贪没有关系。有人说：不慢是属于信心所的一部分，因为既然信他，就不会轻慢他。有人说：不慢是属于舍的一分，因为舍心是平等的，他不会对人高慢。有人说：不慢，是属于惭的一部分，因为惭能崇重贤善，所以不慢。照古德注本：以上三说俱通。有人说：不疑是信心所摄，因为既已相信这个人或这件事，就不会有怀疑。又一种说法，不疑就是别境的正胜解，因其对于已经决定了的正当事理，就不会再有犹豫。又有人说：不疑是别境中正慧所摄，因为有了正见的人，那里还会有犹豫呢？古德说，以上三说俱通。

    不散乱是别境的正定所摄，和染见相反的正见，和不正知相反的正知，俱是别境的善慧所摄。和忘念相反的不忘念，就是别境的正念。至于悔、眠、寻、伺四个不定法，他们通于染及不染。就像遍行的触等，别境的欲等一样，善心所中没有与此相对的内容。

    论文十八：何缘诸染，所翻善中有别建立，有不尔者？相用别者，便别立之，余善不然，故不应责。又诸染法遍六识者，胜故翻之，别立善法。慢等忿等唯意识俱，害虽亦然，而数现起损恼他故，障无上乘胜因悲故，为了知彼增上过失，翻立不害。失念、散乱、及不正知，翻入别境，善中不说。染净相翻，净宁少染？净胜染劣，少敌多故。又解理通，说多同体，迷情事局随相分多，故于染净不应齐责。

    讲解：外人问：六种根本烦恼和二十种随烦恼，为什么有的翻过来就成为善法，有的何以不翻呢？论主答：有的翻过来，性质和作用都有区别，所以各别建立为善。其余的翻过来，性质和作用没有区别，故不一一别立，所以不应有所责难。

    还有，一切染法普遍存在于六识的，其作用殊胜，所以要翻过来别立为善。慢等七种根本烦恼（注：七种烦恼为慢、疑、身见、边见、邪见、见取见、戒禁取见），和忿等九种随烦恼（注：九种烦恼为忿、恨、覆、恼、嫉、悭，诳、谄、害），只与意识相应。害虽然也是这样，但它一再生起，损恼他人，障碍大乘殊胜原因之悲，为了表明它的强胜违害作用，所以要翻过来成立不害善法。失念、散乱、不正知翻过来是念、定、慧，列入别境心所法，并不列入善心所法。

    论文十九：此十一法，三是假有，谓不放逸、舍及不害，义如前说。余八实有，相用别故。

    讲解：在这十一个善心所中，有三个是假有，就是：不放逸、舍和不害。因为舍和不放逸，是以精进及三善根为体；不害，是以无嗔一分为体。这意义在前面已经说过。除此三法是假有外，其余八法都是实有。

    论文二十：有义：十一，四遍善心，精进三根遍善品故。余七不定，推寻事理未决定时不生信故。惭愧同类，依处各别，随起一时，第二无故。要世间道断烦恼时，有轻安故。不放逸、舍，无漏道时，方得起故，悲憨有情时乃有不害故。论说：十一，六位中起，谓决定位有信相应，止息染时有惭、愧起，顾自他故，于善品位有精进三根。世间道时有轻安起，于出世道有舍、不放逸，摄众生时有不害故。

    讲解：此下是两家对于善法是否俱起的诤论。第一家说：在十一善法里，有四法是普遍存在于善心中，就是精进和三善根，其余七法则不一定。因为在推寻事理没有决定的时候，不会生信。惭和愧虽是同类，但是惭是依仗自力，愧是依仗他力，依处各别。所以惭生起的时候无愧，愧生起的时候无惭，二者不同时俱起。要到世间道断了粗重烦恼时，才有轻安。至于不放逸和行舍，要到得了无漏道才能够生起。能够慈悲怜愍一切有情的时候才会有不害。《瑜伽论》上说：十一善法，要在六位中生起，即是说在决定位，不能与信相应。能够止息染污的时候，才有自力和他力的惭、愧生起。在善品位，一定有精进和三善根。得到了世间道，才有轻安生起。在出世道的时候，才有行舍和不放逸二法。能够摄护一切众生的时候，才有不害。

    论文二十一：有义：彼说未为应理，推寻事理未决定心，信若不生，应非是善，如染心等无净信故。惭、愧类异，依别境同，俱遍善心，前已说故。若出世道轻安不生，应此觉支非无漏故。若世间道无舍、不放逸，应非寂静防恶修善故。又应不伏掉举放逸故。有漏善心既具四法，如出世道应有二故，善心起时皆不损物，违能损法，有不害故。论说：六位起十一者，依彼彼增作此此说，故彼所说定非应理，应说信等十一法中，十遍善心，轻安不遍。要在定位方有轻安调畅身心，余位无故。决择分说：十善心所，定不定地，皆遍善心，定地心中增轻安故。

    讲解：第二家认为：前面所说的并不合理：推寻事理未决定之心，信若不生，此心就不是善法，和染污心一样，因为没有净信。至于惭和愧二法类虽不同，那不过是惭依自力，愧依他力，所依的增上缘力有自他差别而已。然而它们的境界都是遍一切善心，并无不同，这在前面已经说过。假使出世道时轻安不生，这种觉支就不应当是无漏。假使世间道没有行舍和不放逸，其心就不应当是寂静，也就不能防恶修善了，又凭什么来降伏掉举和放逸？既然有漏善心具有精进和三善根四法，世间道就应当同出世道一样，具有舍和不放逸二法。当善心生起的时候不损恼他人，因为违背了能损物的害法，所以才有不害。

    《瑜伽论》上说：‘六位起十一’者，那是依增上而说的。十一种善心所法在六位生起，因为在决定位有信生起，在止息染法的时候有惭或愧生起，由于自己的力量而使惭生起，由于他人的力量而使愧生起。在善位时有精进和三善根，在世间道时有轻安生起，在出世间道有舍和不放逸，当对众生怜愍的时候，有不害的生起。

    论文二十二：有义：定加行亦得定地名。彼亦微有调畅义故，由斯欲界亦有轻安，不尔，便违本地分说，信等十一通一切地。有义：轻安唯在定有，由定滋养有调畅故。论说：欲界诸心、心所由阙轻安名不定地。说一切地有十一者，通有寻、伺等三地皆有故。

    讲解：关于定地，又有两家不同解释。第一家认为，在未到定的加行位，也叫做定地，因为此时也有一点调畅身心的微义，所以欲界地也有轻安，不然的话，便违背《瑜伽论．本地分》所说：‘信等十一，通一切地’的道理了。

    第二家说：轻安唯在色、无色界的定地才有，欲界没有。因为由定的滋养，身心才能调畅。论上说：一切心王和心所，由于阙了轻安，所以叫做不定地。至于说：一切地都有十一种善法，那是对初禅的有寻有伺地、二禅的无寻有伺地、二禅以上的无寻无伺地说的，这三地都有轻安。而非欲界所有。

    论文二十三：此十一种前已具说，第七、八识随位有无，第六识中定位皆具，若非定位唯阙轻安。有义：五识唯有十种，自性散动无轻安故。有义：五识亦有轻安，定所引善者亦有调畅故，成所作智俱，必有轻安故。

    讲解：这十一种善法前已讲过，第七和第八识里，在有漏位全部没有，到无漏位全部都有。至于第六识，在定位全部都有；在不定位只有十种，唯阙轻安。有人说：前五识只有十种，因为它们自性散动，没有轻安。又有人说：前五识也有轻安。如果是定所引的善法，在五识身里也有调畅身心；前五识转成‘成所作智’的时候，必定是有轻安。

    论文二十四：此善十一何受相应？十、五相应，一除忧、苦，有逼迫受，无调畅故。此与别境皆得相应，信等欲等不相违故。十一唯善。轻安非欲，余通三界。皆学等三。非见所断，瑜伽论说：信等六根唯修所断，非见所断。余门分别，如理应思。

    讲解：问：这十一个善心所，在苦、乐、忧、喜、舍的五受中，与那一受相应呢？答：有十个都与五受相应，只有轻安一法不通五受，因为逼迫性的忧、苦二受，不能调畅身心，所以轻安一法只能与喜、乐、舍三受相应。

    这十一种善法，与别境五法都能相应。因为信等的善法，与欲等的别境，他们的体性并不相违。这十一法，在善、恶、无记三性里唯属善性；在欲、色、无色三界里，除轻安一法不通欲界外，其余的十法都遍通三界；在有学、无学、非有学无学的三位里，则是全部都有。

    这十一法，在见断、修断、非断的三断里，都不是见道所断。因为他们不是分别所起的烦恼、所知二障。《瑜伽论》上说：二十二根里的信根、精进根、念根、定根、慧根、未知当知根，这六种根，在有漏位是唯修所断；在无漏位那就是非所断了。

    第三节　烦恼心所

    论文一：如是已说善位心所，烦恼心所其相云何？颂曰：烦恼谓贪嗔，痴慢疑恶见。

    讲解：上文已经把十一种善位心所讲完。至于烦恼心所，其义相又是怎么样呢？颂文中答覆曰：烦恼有六，即贪、嗔、痴、慢、疑、恶见。

    论文二：论曰：此贪等六，性是根本烦恼摄故，得烦恼名。云何为贪？于有、有具染著为性，能障无贪，生苦为业。谓由爱力，取蕴生故。

    讲解：以下论文，是解释前二句颂文。论上说：这贪等六个心所，是属于根本烦恼所摄，所以得烦恼之名。什么叫做贪？爱著异熟报果的三有──即三界，及能生三有之因的‘有具’──即惑与业。故贪以染著为性，能障无贪，生起诸苦，就是贪的业用。也就是说，由贪爱的业力，生起了痛苦充满的五蕴身心。五蕴，因取著贪爱而有，又能取著贪爱，所以称五取蕴。

    论文三：云何为嗔，于苦、苦具憎恚为性，能障无嗔，不安隐性恶行所依为业。谓嗔必令身心热恼，起诸恶业，不善性故。云何为痴，于诸理、事迷闇为性，能障无痴，一切杂染所依为业。谓由无明起疑、邪见、贪等烦恼，随烦恼业，能招后生杂染法故。

    讲解：什度叫做嗔，嗔是对于三苦──苦苦、坏苦、行苦的苦果，及造成三苦之因的苦具，生起憎恚，以此憎恚为体性，能障碍无嗔，不能安心隐忍，一切恶行依之而起，即成了它的业用。有了嗔恚之心，必定能令身心热恼，一定会生起一切邪恶行为，因为它体性不善之故。

    什么叫做痴？对于一切真谛的道理、俗谛的事相，全都迷闇不明，就是痴的体性；能障碍无痴，一切有漏杂染依之而起，就是痴的业用。痴就是无明的别称，由无明次第生起疑、邪见、贪等烦恼、随烦恼，造作恶业，招感后生的杂染诸法。

    论文四：云何为慢？恃已于他，高举为性，能障不慢，生苦为业。谓若有慢，于德有德，心不谦下，由此生死轮转无穷，受诸苦故。此慢差别有七、九种。谓于三品、我、德处生，一切皆通见、修所断。圣位我慢既得现行，慢类由斯起亦无失。

    讲解：什么叫做慢？就是仗恃自己，以贡高我慢为其体性；能障不慢，生起诸种痛苦，就是它的业用。也就是说：有了高慢，对于三宝净功德法，及超过自己的有德之人，自心不肯谦虚卑下，由此招感生死轮转，受苦无穷。如果详细分析，慢的差别有七种、九种二说。（注：七种慢是：一者慢，对于不胜我的人，固然说我比他强；就是与我相等的人，也说他不过同我一样。二者过慢，不但对于和我相等的人说他不如我，就是对于胜过我的人，也说他不过和我相等。三者过过慢，对于胜我的人，反说他远不及我。四者我慢，就是执有实我及我所，使心高举。五者增上慢，自己才证得少分圣道，便伪称全证。六者卑劣慢，对于胜过我很多的人，说我不过比他少差一点。七者邪慢，分明自己无德，妄谓自已有德。九种慢是：一者我胜慢，二者我等慢，三者我劣慢，四者有胜我慢，五者有等我慢，六者有劣我慢，七者无胜我慢，八者无等我慢，九者无劣我慢。）

    论文五：云何为疑？于诸谛理犹豫为性，能障不疑，善品为业。谓犹豫者善不生故。有义，此疑以慧为体，犹豫简择说为疑故。毗助末底是疑义故，末底般若，性无疑故。有义，此疑别有自体，令慧不决非即慧故。瑜伽论说：六烦恼中见世俗有，即慧分故，余是实有，别有性故。毗助末底执慧为疑，毗助若南智应为识，界由助力义便转变，是故此疑非慧为体。

    讲解：什么叫做疑？对于一切真实不虚的道理，犹豫不决，就是疑的体性；能障不疑的善品，就是它的业用。也就是说，凡是犹豫不信的人，善法是不会生起的。

    关于疑的体性，有两家不同的说法。第一家安慧说：疑是以慧为体，就是对于所观之境，有一种犹豫的简择，所以叫做疑。毗助末底，就是疑的意思。毗是比的意思，助是辅助，末底是慧。合起来就就是比益辅助于慧。既然是辅助于慧，当然就是慧。末底和般若，都是慧的异名，并无别体。所以知道疑是以慧为体的。

    第二家护法反驳第一家说：此疑别有自体，能令慧犹豫不决，所以疑并不就是慧。《瑜伽论》上说︰在六个根本烦恼中，除了‘不正见’是世俗假有，属于邪慧所摄外，其余的五个根本烦恼──贪、嗔、痴、慢、疑，都实有自体，所以疑并不就是慧。如果说，在‘末底’上加一‘毗’字来帮助解释，就说慧是疑的体，那么，‘若南’二字是智，在‘若南’加一‘毗’字来帮助解释，就应当变智为识了。然而，识体并不是智，如何说‘毗助末底’就是慧呢？论文中的‘界’字是性义。

    论文六：云何恶见？于诸谛理颠倒推求，染慧为性，能障善见，招苦为业。谓恶见者，多受苦故。此见行相，差别有五：第一种是萨迦耶见，谓于五取蕴是我和我所，一切见趣所依为业。此见差别，有二十句，六十五等分别起摄。

    讲解：什么叫做恶见？对于佛教一切谛理，颠倒推度，以染慧为性，能障善见，招感苦报为业。也就是说，有恶见的人多遭苦报。这不过是总略的解释，若仔细分析，这恶见的差别，尚有五种。一者‘萨迦耶见’，译为身见，亦称我见。就是于五取蕴的这个假名不了如幻，执有实我及我所，一切邪见都依我见而起，起惑造业。因此，我见的差别又有二十句、或六十五句，都是属于后天分别起的烦恼。（注：二十句者，是五蕴各有四旬。例如：一、色是我。二、我有色。三、色属我。四、我在色中。如是乃至识是我……，合五四为二十句。六十五句，是计一蕴为我，余四蕴各有三所：一、我璎珞。二、我僮仆。三、我器物。合四三为十二，再加上一个我共为十三。这样推算起来，五蕴有五个我，六十个我所，总合为六十五句。）

    论文七：二边执见，谓即于彼随执断、常，障处中行，出离为业。此见差别，诸见趣中有执前际四遍常论，一分常论。及计后际有想十六，无想、俱非各有八论，七断灭论等。分别起摄。

    讲解：第二种是边执见，就是在我见之上或者执常、或者执断，能障碍非断非常中道的行相，它的业用，使人不得出离三界苦海。这种边执见的差别，有的主张前际四种遍常论和一分常论：有的主张后际有想十六论、无想八论、非有想非无想八论、七种断灭论。总括起来共有四十七种，这四十七见，都是后天分别所起的烦恼，其中常见四十种，断见七种。

    （注一：四遍常论：一、由下品宿住通，能忆前际二十成坏劫自他生死相续，便执我与世间，一切俱常。二、由中品宿住通，能忆前际四十成坏劫生死相续，便执我与世间俱常。三、由上品宿住通，能忆八十成坏劫生死相续。便执我与世间俱常。四、由天眼通，见一切有情死此生彼，诸蕴相续，便执我与世间俱常。这四种，执三界俱常，所以叫做遍常。）

    （注二：一分常论：一、有从梵天结束生命而生此世间者，得宿住通，执梵天是常，我是无常。二、执梵王所说：四大种是常，心是无常。三、有从戏忘天结束生命生此世间，得宿住通，执彼天是常，我是无常。四、从意愤天结束生命生此世间，得宿住通，执彼天是常，我是无常。这四种，但执梵天、大等是常，所以叫做一分常论。以上八见四遍常论和四一分常论，都是依过去所起的分别，所以说为前际。）

    （注三：有想十六论：一、我有色，死后有想。二、我无色，死后有想。三、我亦有色亦无色，死后有想。四、我非有色非无色，死后有想。五、执我有边，死后有想。六、执我无边，死后有想。七、执我亦有边亦无边，死后有想。八、执我非有边非无边，死后有想。九、我有一想。十、我有种种想。十一、我有少想。十二、我有无量想。十三、我纯有乐，死后有想。十四、我纯有苦，死后有想。十五、我纯有苦有乐，死后有想。十六、我纯无苦无乐，死后有想。）

    （注四：无想八论：一、我有色，死后无想。二、我无色，死后无想。三、执我亦有色亦无色，死后无想。四、执我非有色非无色，死后无想。五、执我有边，死后无想。六、执我无边，死后无想。七、执我亦有边亦无边，死后无想。八、执我非有边非无边，死后无想。）

    （注五：俱非八论：一、执我有色，死后非有想非无想。二、执我无色，死后非有想非无想。三、执我亦有色亦无色，死后非有想非无想。四、执我非有色非无色，死后非有想非无想。五、执我有边，死后非有想非无想。六、执我无边，死后非有想非无想。七、执我亦有边亦无边，死后非有想非无想。八、执我非有边非无边，死后非有想非无想。）

    （注六：七断灭论：认为死后断灭，已无思想，不再转生。包括以下七种：一、我有色，死后断灭。二、我欲界天，死后断灭。三、我色界天，死后断灭。四、我空无边处，死后断灭。五、我识无边处，死后断灭。六、我无所有处，死后断灭。七、我非想非非想处，死后断灭。以上有想、无想、俱非、断灭等三十九见，都是依未来所起的分别，所以说为后际。）

    论文八：三邪见。谓谤因果，作用实事，及非四见诸余邪执，如增上缘名义遍故。此见差别，诸见趣中，有执前际二无因论、四有边等、不死矫乱，及计后际五现涅槃，或计自在、世主、释、梵及余物类常恒不易。或计自在等是一切物因。或有横计诸邪解脱，或有妄执非道为道，诸如是等，皆邪见摄。

    讲解：第三种是‘邪见’，就是否定善恶因果，无此世间、无彼世间，无世间阿罗汉的实事。以及坚持除身见、边见、见取见、戒禁取见四见以外，其余的一切邪执。好像四缘的因缘、所缘缘、等无间缘这三缘所不摄的，都归于增上缘摄一样。因为邪见的名义较为普遍，所以摄法亦广。这邪见的差别，有的执著前际所起的二无因论，四有边论，四不死矫乱。有的执著后际所起的五现涅槃。或者主张大自在天、大梵天、帝释天和自性等永恒不变。或者主张大自在天等是产生世间万物之因，或者坚持各种错误虚假的解脱，或者错误地主张以非解脱之道为解脱之道，这一切都属邪见。

    （注一：二无因论：一、从无想天下生的人，虽然得宿命通，而回忆不起出无想心以前的生死成坏，便执世间一切都是无因而起。二、由于寻伺虚妄的推求，但能记忆今身之所更事，而不能忆及前身所更事，便执一切都是无因而起。）

    （注二：四有边论：一、由于天眼通的力量，能见到下自无间地狱，上至第四禅天，便执世界上下为有边。二、由于天眼通的力量，能忆边傍无有边际，乃生起无边之想。三、由天眼通的力量，能忆世界上下有边，傍布无边，便起亦有边，亦无边之想。四、由天眼通的力量，能忆坏劫分位，便起非有边，非无边之想。这四有边论，因为不计我见断常，所以边见不摄，而属于邪见所摄了。）

    （注三：四不死矫乱：一、无知矫乱，有一种无知外道，不肯回答别人提出的问题，他们认为唯有这样不说尽天意，死后便能生天。二、谄曲矫乱：有一种谄曲外道，故作神秘的不将自己修证的净天告诉别人，认为这样死后可以生天。三、恐怖矫乱：有一种心怀恐怖的外道，为了掩饰自己的无知，对别人所问的问题随便解答，认为这样死后可以生天。四、愚戆矫乱：有一种愚戆外道，不回答别人的问题，只是反诘，随人家答什么他都认为是正确的，认为这样死后可以生天。这四种人，因为迷信生天不死，才乱说一通。所以圣教毁之谓‘不死矫乱’。）

    （注四：五现涅槃：外道对涅槃有五种错误的认知：一、认为现在欲界所享受的色、声、香、味、触五欲就是涅槃。二、厌恶五欲，以现住入初定便认为是涅槃。三、厌离寻、伺，以现住入第二定便认为是涅槃。四、厌离第二定的喜受，以现住第三定便认为是涅槃。五、厌离第三定的乐受，以现住第四定便认为是涅槃。因为执著于这五种现法涅槃，对于过去来说，是从后际生起的妄见，故称后际五现涅槃。）

    论文九：四见取。谓于诸见，及所依蕴执为最胜，能得清净，一切斗诤所依为业。

    讲解：见取见，是对于一切恶见及所依的五蕴执为最胜，认为依此能得清净的涅槃果法。由于各执己见，一切外道的斗争都依此而起，这就是见取的业用。

    论文十：五戒禁取。谓于随顺诸见、戒禁及所依蕴，执为最胜能得清净，无利勤苦所依为业。然有处说执为最胜名为见取，执能得净，名戒取者，是影略说，或随转门。不尔，如何非灭计灭，非道计道，说为邪见，非二取摄？

    讲解：戒禁取见，即依于诸邪见而持戒守禁、及戒所依的五蕴，被认为是最殊胜能得涅槃的清净法。因此，一切外道，或受持牛戒而吃草、或受持狗戒而啖粪，以及拔发、裸体等种种没有利益的苦行，就是戒禁取的业用。

    然而有的经论上说，执为最胜的，叫做见取；执能得净的，叫做戒取。这种分法，只是捕风捉影或概略之说，或是随转小乘的方便说法。实则，见、戒二取，都一样的执为最胜和执能得净。如果不是这样的话，何以经论上说：不是真正的涅槃，他们以为是真正的涅槃──非灭计灭。不是无漏的圣道，他们以为是无漏的圣道──非道计道。这两种都是第三项的邪见所摄，不是见取和戒取所摄。

    论文十一：如是总别十烦恼中，六通俱生及分别起，任运思察俱得生故。疑后三见唯分别起，要由恶友或邪教力，自审思察方得生故。边执见中通俱生者，有义：唯断。常见相粗，恶友等力方引生故。瑜伽等说：何边执见是俱生耶？谓断见摄。学现观者起如是怖，今者我何所在耶？故禽兽等若遇违缘，皆恐我断而起惊怖。有义：彼论依粗相说，理实俱生亦通常见。谓禽兽等执我常存，炽然造集长时资具。故显扬等诸论皆说于五取蕴执断计常，或是俱生或分别起。

    讲解：在贪、嗔、痴、慢、疑、恶见六大根本烦恼中，此六根本烦恼是总，再把恶见分为身见、边见、邪见、见取、戒取五种，此五是别。这总别十种烦恼，贪、嗔、痴、慢、身见、边见六种，通于俱生起和分别起。因为任运而起的叫做俱生起，思察而起的称为分别起，以上六种，无论是任运、思察都能生起。而疑、邪见、见取、戒禁取四种，不通俱生，唯属分别。因为这要由恶友、邪教的影响，和自己的分别才能生起。

    边执见中通于俱生而起的，是断见呢还是常见？这有两家不同的说法。第一家说：俱生而起的是断见。因为常见的行相太粗，他必须由恶友、邪教，及自力的分别，才能引生。《瑜伽论》上说：边执见里的断、常二见，那一种是俱生起呢？答曰：断见。何以知断见是俱生起？例如见道以前学现观谛理的人，虽已断了分别烦恼，然而在心理上还这样的恐怖：如果我空，那我和我所，岂不就没有了吗？因此断见是俱生之故，所以禽兽一遇到猎杀它们的违缘，都为死后的我断灭而起了惊怖。

    第二家说：俱生唯断的话，那是《瑜伽论》依粗显的行相而说的。若依隐微的理实而论，俱生的断见里，也有常见。何以见得呢？禽兽就是因为执我常存之故，所以才炽然制造巢穴，集积食粮，作为他长期续命的资具，而唯恐我断。因此《显扬圣教论》也说：在五取蕴上的断、常二见，有俱生而起，也有分别而起。并没有不许俱生有常见的。

    论文十二：此十烦恼，谁几相应？贪与嗔疑，定不俱起，爱憎二境，必不同故，于境不决，无染著故。贪与慢见或得相应，所爱所陵境非一故，说不俱起。所染所恃境可同故，说得相应。于五见境皆可受故，贪于五见相应无失。嗔与慢疑或俱得起，所嗔所恃，境非一故，说不相应，所蔑所憎境可同故，说得俱起。初犹豫时未憎彼故，说不俱起。久思不决便愤发故，说得相应。疑顺违事随应亦尔。嗔与二取必不相应，执为胜道不憎彼故。此与三见或得相应。于有乐蕴，起身常见，不生憎故，说不相应。于有苦蕴，起身常见，生憎恚故，说得俱起。断见翻此说嗔有无。邪见诽拨恶事好事，如次说嗔或无或有。

    讲解：这十种烦恼，那些可以相应呢？贪和嗔、疑，决定不能俱起。因为贪的境界是爱，嗔的境界是憎，爱、憎二境，必定不能俱起。对于疑而不决的境界，是不会有贪著的，所以贪和疑，也决定不能俱起。

    贪和慢、见，或相应或不相应，则不一定。因为所爱的必贪，所陵的必慢，爱好和陵辱的境界不同，所以贪和慢不能俱起。然而，由爱惜自己所起的贪，仗恃自己所起的慢，正复同境，所以贪和慢又是相应的。由于五种邪见都是可爱的境界，所以说贪和五见相应，并没有什么过失。

    嗔和慢、疑，俱起或不俱起不定。因为嗔所憎的是他；慢所恃的是我；嗔和慢并非一境，故不相应。但是慢是轻蔑人，嗔是憎恚人，同是看不起人，所以又是俱起的。疑是犹豫，最初的疑心轻微，尚未起嗔，所以说嗔和疑不相俱起。然而久思不决，疑心渐深，就要发脾气，所以嗔和疑，也可以说是相应。若疑顺己之事，或许不起嗔，若疑违己之事，便嗔于彼。嗔与见取见、戒禁取见肯定不相应，因为见、戒二取，一个是执见为胜，一个是执戒为道，都是顺己之境，所以不会起嗔。但嗔与身、边、邪三见，那就不一定相应，因为在有乐的五蕴上，生起身见和常见，当然不会生嗔，可以说是不相应。对于苦蕴生起的身见和常见，那就不能不产生憎恨，所以说俱起。断见有嗔无嗔，恰于身见常见相反。于乐蕴所起的断见有嗔，于苦蕴所起的断见无嗔。至于邪见有嗔无嗔，那是依拨恶事好事的次第而说的。拨无恶事的邪见，不与嗔俱；否定好事之无，便与嗔俱。

    论文十三：慢与境定，疑则不然，故慢与疑无相应义。慢与五见皆容俱起，行相展转不相违故。然与断见必不俱生，执我断时无陵恃故。与身邪见一分亦尔。疑不审决，与见相违。故疑与见定不俱起。五见展转，必不相应。非一心中有多慧故。痴与九种皆定相应，诸烦恼生，必由痴故。

    讲解：慢与疑是不能俱起的，因为慢对境界已经决定，疑则对境界未决定。所以慢与疑不相应。慢和五见，容许可以俱起，因为他们的行相并不相违。然而慢和断见肯定不能俱起，因为既执我断，恐惧之不暇，那里还会有高慢？慢和身见、邪见，也有一分不俱，那就是：苦蕴的一分身见，和拨无恶事的一分邪见。

    疑与五见，定不俱起。因为疑是不审决，见是审决，他们的行相相违，所以不相应。就是五见的本身，也不能展转相应。因为见与慧俱，并不能于一念心中有多慧俱起。痴在十烦恼中，与其余约九种烦恼都决定相应，因为一切烦恼都是由痴上生起的。

    论文十四：此十烦恼何识相应？藏识全无，末那有四，意识具十，五识唯三，谓贪、嗔、痴，无分别故，由称量等，起慢等故。

    讲解：贪、嗔、痴、慢、疑，和不正见所开的五见，合为十个烦恼，这十个烦恼都是和什么识相应呢？第八藏识里全都没有，第七末那识只有我痴、我见、我慢、我贪四个。第六意识里，十个烦恼都有。前五识里，只有贪、嗔、痴三个俱生烦恼。因为五识没有分别，而慢等七法，是由称量推求等分别而起的。

    论文十五：此十烦恼何受相应？贪、嗔、痴三，俱生分别，一切容与五受相应，贪会违缘，忧苦俱故，嗔遇顺境喜乐俱故。有义：俱生分别起慢，容与非苦四受相应，恃苦劣蕴忧相应故。有义：俱生亦苦俱起，意有苦受前已说故。分别慢等纯苦趣无，彼无邪师、邪教等故，然彼不造引恶趣业，要分别起，能发彼故。

    讲解：这十种烦恼，于苦、乐、忧、喜、舍五受中，和那一受相应呢？答：贪、嗔、痴三种，无论是俱生而起的，或是分别而起的，都和五受相应。为什么贪会有忧苦，嗔会有喜乐呢？因为贪遇违缘便有忧苦，嗔遇有顺境便有喜乐。至于慢与何受相应？则有两家不同的说法。第一家说：不管是俱生起的慢，或分别起的慢，除不与苦受相应外，与其余的四受都是相应的。何以慢会与忧受相应？因为苦趣中的有情，他们由自恃苦劣蕴身所起的慢，是与忧受相应的。

    第二家说：俱生所起的慢，也与苦受相应。因为意识有苦受，由意地所生的慢，当然也有苦受，这在前面已经说过了。分别所起的慢，纯苦趣中没有。因为纯苦趣的三恶道中，没有邪师、邪教，及邪思维，所以没有分别起的慢。分别烦恼，原为能引发恶趣之故。纯苦趣中，既不造引发恶趣的业，所以也不需要分别起的慢。

    论文十六：疑后三见，容四受俱，欲疑无苦等，亦喜受俱故。二取若缘忧俱见等，尔时得与忧相应故。有义：俱生身边二见，但与喜乐舍受相应，非五识俱，唯无记故。分别二见容四受俱，执苦俱蕴为我、我所，常、断见翻此，与忧相应故。有义：二见若俱生者，亦苦受俱，纯受苦处，缘极苦蕴，苦相应故。论说俱生一切烦恼，皆于三受现行可得。广说如前，余如前说。此依实义。随粗相者，贪慢四见，乐喜舍俱，嗔唯苦忧舍受俱起，痴与五受皆得相应。邪见及疑，四俱除苦。贪痴俱乐，通下四地，余七俱乐，除欲通三，疑独行痴，欲唯忧舍，余受俱起，如理应知。

    讲解：疑、邪见、见取见、戒禁取见，这四种烦恼，除不与苦受俱起外，与其余的四受，都是俱生起的。问：如何疑会与喜受俱起，见、戒二取会与忧受相应呢？答曰：因为欲界众生的疑，他们犹豫来世没有苦事，所以也与喜受俱起。问：见取见和戒禁取见，为什么有忧受呢？因为苦行外道缘见、戒二取，种种苦行，怎能没有忧受呢？至于邪见，一定与喜受、忧受相应。

    身见和边见与何受相应？此有两家异说，第一家说：俱生起的身见和边见，但与喜、乐、舍三受相应。因为与这二见俱起的是意识，不是前五识，所以无苦受。分别起的身、边二见，除苦受外，与喜、乐、忧、舍四受俱起。这二见何以会有忧受？因为常见的人，执苦俱蕴为我、我所，唯恐常而不断；断见的人，执乐俱蕴为我、我所，唯恐断而不常。所以二见都与忧受相应。

    第二家说：身、边二见，若是俱生的，也与苦受相应。因为纯受苦处的恶趣，他们缘极苦蕴，是与苦受相应的。《瑜伽论》上说：俱生的一切烦恼，都与苦、乐、舍三受相应。其余详细的解释，在前面受俱门里已说过了。这不过是依实义而说，若随粗相而说，则贪、慢、身见、边见、见取、戒取六种，与乐、喜、舍三受俱起。嗔只与苦、忧、舍三受俱起。痴与五受都能相应，邪见及疑，除苦受外，与四受相应。

    与贪、痴俱起的乐受，在三界九地里，和欲界及色界的初、二、三禅，这下四地相应。与其余七种烦恼俱起的乐受，只通初、二、三禅。因为这是与意识相应的乐，不通欲界。欲界的乐受，唯与前五识俱起。

    疑和不共无明──痴，在欲界里唯有忧、舍。因为欲界没有与意识俱起的苦，及定生的喜、乐之故。喜、乐二受，唯色界俱。因为色界的疑、痴，是由喜、乐的定力之所引持。至于贪等与其余的喜、舍在何地相应，也应当如理而知。

    论文十七：此与别境，几互相应，贪、嗔、痴、慢容五俱起，专注一境得有定故。疑及五见，各容四俱，疑除胜解不决定故，见非慧俱，不异慧故。

    讲解：这十种烦恼，和五个别境有几相应呢？答曰：贪、嗔、痴、慢四烦恼，与五个别境都相应俱起。它们如果专注一境时，也容许有定。疑及五见六种烦恼，是各与四个别境相应的。因为胜解是决定，疑是不决定，所以疑不与胜解相应，只有与其余的欲、念、定、慧四个别境相应。至于五见，其本身就是慧，所以与慧不并存，只有与其余的欲、胜解、念、定四个别境相应。

    论文十八：此十烦恼，何性所摄，嗔唯不善，损自他故。余九通二，上二界者唯无记摄，定所伏故，若欲界系分别起者，唯不善摄，发恶行故。若是俱生发恶行者，亦不善摄，损自他故。余无记摄，细不障善，非极损恼自他处故。当知俱生身、边二见，唯无记摄，不发恶业，虽数现起，不障善故。

    讲解：这十种烦恼，在善、恶、无记三性里，属于何性呢？答曰：嗔唯不善，因为它是损恼自他的恶法。其余的九种烦恼通于不善及无记。在色、无色界，无论是俱生所起或分别所起的烦恼，都为无记性摄。因不善的恶性已被上二界的禅定心所伏了。在欲界系的贪等九种烦恼，如果是分别起的，属于恶性，因为它们一向发动恶行。如果是俱生起的，则有两种，发动恶行的属于恶性，因为它损恼自他。其余的属于无记性，其原因有四：一极端微细，二不障善法，三并不是极端损恼自他，四数数现行。应当知道身见和边执见只属无记，因为它们不发动恶行，虽然一再现行，但不障碍善法。

    论文十九：此十烦恼何界系耶？嗔唯在欲，余通三界。生在下地，未离下染，上地烦恼不现在前。要得彼地根本定者，彼地烦恼，容现前故。诸有漏道，虽不能伏分别起惑及细俱生，而能伏除俱生粗惑，渐次证得上根本定。彼但迷事，依外门转，散乱、粗动，正障定故。得彼定已，彼地分别俱生诸惑，皆容现前。生在上地下地诸惑，分别俱生皆容现起。生第四定中有中者，由谤解脱生地狱故。身在上地将生下时，起下润生俱生受故。而言生上不起下者，依多分说或随转门。下地烦恼亦缘上地，瑜伽等说欲界系贪，求上地生，味上定故。既说嗔恚憎嫉灭道，亦应憎嫉离欲地故。总缘诸行，执我我所，断常慢者，得缘上故。余五缘上，其理极成。

    讲解：这十种烦恼，在三界里系属于那一界呢？答：嗔唯在欲界，其余九种通于三界。生在下地的有情，如果没有离开下地烦恼，则上地烦恼也就不会现前。要等到得了上地的根本定时，上地烦恼才能现前。怎样才能得到根本定呢？答曰：要修有漏道。修有漏道虽不能伏除分别起之惑及俱生细惑，然而已能伏除了俱生的粗惑，这样就渐次证得了上地的根本定。为什么有漏道只伏修惑而不伏见惑呢？那是因为修道所伏的惑，但由迷事而起，缘外尘转，散乱粗动，能障定境的原故。

    得根本定已，上地的分别俱生诸惑，便都现前，同时也脱离了前所未伏的下地烦恼。问：生在上地，下地的烦恼还现起不？答曰：生在上地，下地的烦恼不问是分别、俱生，都可以现起。因为生到色界第四定中，‘有’中的人，（注：生死相续名之谓有），本非解脱，他认为已经解脱，不会再受后有了。一旦报尽，便谤佛所说的解脱谓为虚妄；以此谤佛法因缘，生地狱苦报，可知身在上地，将生下地的时候，便起了下地润业受生的俱生烦恼──无明我爱。然而有说生到上地，不起下地烦恼，那是依多分而的，并不是依唯谤解脱的少分。或者是随顺小乘，转变大乘教理的方便说法。

    烦恼的众生，如果求上地生的时候，也可以贪上地的境界。又说：有漏凡夫既缘出世灭谛、道谛，尚且起嗔恚、憎嫉，那对上界离欲地起嗔嫉，更不必说了。除了贪、嗔以外，还有身见、边见、慢三种，它们总缘三界的色心诸行，或执为我、或执为我所，或执我常，或执我断，或起憍慢，自恃陵他。这身、边、慢三种烦恼，都是缘上界而起。其余的痴、疑、邪见、见取、戒取，这五种缘上的理由，也都是极其成就的。

    论文二十：而有处言，贪嗔慢等，不缘上者，依粗相说，或依别缘。不见世间执他地法为我等故，边见必依身见起故。上地烦恼亦缘下地。说生上者，于下有情，恃己胜德而陵彼故。总缘诸行执我、我所，断常爱者得缘下故。疑后三见，如理应思。而说上惑不缘下者。彼亦多分，或别缘说。

    讲解：也有处说，下地烦恼的贪、嗔、慢等不缘上地，这是依粗相而说，或别缘自身为我而说的。有谁见过世间的人，执他地法为我或我所呢？所以我见不通上地，也不执他地法为我及我所。然上，上地的烦恼亦缘下地，经论上说，上地的有情对于下地有情，仗恃自己的胜德，去欺陵他们，便是以慢缘下。总缘三界诸行，或起身见执我、我所，或起边见执断、执常，或起贪爱。这我见、边见、贪三种烦恼，岂不是亦缘下地吗？疑、邪见、见取、戒取四种烦恼，想来也是缘下地的了。上地无嗔、痴，是大家都认同的，所以这里略而不说。然而，有经论上说：上地烦恼，不缘下地的，那也是依多分而说，或依别缘自地而说。否则，就不能说不缘下地了。

    论文二十一：此十烦恼，学等何摄？非学无学，彼唯善故。此十烦恼，何所断耶，非非所断，彼非染故。分别起者唯见所断，粗易断故。若俱生者唯修所断，细难断故。见所断十，实俱顿断，以真见道总缘谛故。然迷谛相，有总有别。总谓十种，皆迷四谛，苦、集是彼因依处故，减、道是彼怖畏处故。别谓别迷四谛相起。二唯迷苦，八通迷四，身边二见，唯果处起，别空非我，属苦谛故。

    讲解：贪等十种烦恼，在有学位、无学位，及非学无学的凡夫位里，是属于那一种呢？答曰：属于非学的凡夫位所摄。因为有学的初、二、三果，和无学的四果，都是属于善性，他们不摄染污性的烦恼。

    这十种烦恼，在见道断、修道断、非所断的三断之中，由那一种所摄呢？答曰：不是非所断的无漏道所摄。因为无漏道不是染污法。若是分别起的烦恼，那是属于见道所断，因其粗显易断。若是俱生起烦恼，那就是修道所断了。因为它的行相微细，所以比较难断。

    见道所断的十种烦恼，都是一刹那间顿断。因为真见道位，是总缘四谛之理，顿悟真如，而不是相见道的渐次断证。然而由见道迷于谛理所起的烦恼，有总、别二种。总的就是十种烦恼，都是迷于四谛而起。集是烦恼所造的业因，苦是烦恼所依的业果。众生迷此二谛，造业受报，所以说：苦、集是烦恼的因依处。灭是断了烦恼所证的涅槃，道是为断烦恼所修的道法。苦、集是障，灭、道是治，障和治是相违的，所以减、道是烦恼的怖畏处。由于这十烦恼迷昧了四谛真理，所以使有情不能够知苦、断集，慕灭、修道。

    别的就是迷于四谛的行相而起的，十种烦恼中，唯有身见和边见是唯迷苦谛而起，其余的八种烦恼，是通迷于苦、集、灭、道四谛而起。又身见和边见，唯在世间果报五蕴身上生起。问：怎见得身、边二见，是唯迷苦谛呢？答曰：身、边二见，是执著于有漏果处的五蕴为我而起，别观十六行相中的空、无我理，是属于苦谛之故。

    论文二十二：谓疑三见，亲迷苦理．二取执彼三见戒禁及所依蕴，为胜能净，于自他见，及彼眷属，如次随应起贪恚慢；相应无明，与九同迷，不共无明，亲迷谛理。疑及邪见亲迷集等，二取贪等准苦应知。然嗔亦能亲迷灭道，由怖畏彼生憎嫉故。迷谛亲疏，粗相如是。委细说者，贪嗔痴慢三，见疑俱生，随应如彼。俱生二见及彼相应，爱慢无明虽迷苦谛，细难断故修道方断。嗔余爱等，迷别事生，不违谛观，故修所断。

    讲解：疑、身见、边见、邪见四者，是亲迷苦谛所起的烦恼。见取见、戒禁取见、贪、嗔、慢五种，是疏迷苦谛所起的烦恼。即一、见取见：就是妄取迷于苦谛的前三见为最胜，以为依此能得清净解脱。二、戒禁取见：是执取由诸见所持的邪戒为胜，以为此戒能得清净解脱。三、贪：即对于上面的邪见和邪戒爱染取著。四、嗔：嗔是随著他人不同于自己的执见而生起的。五、慢：就是以自己的见为胜，以他人的见为劣，生了贡高我慢。以上五种烦恼，都不是直接亲迷于无我之理，所以是疏迷苦谛。

    此外还有亲疏并迷，无明有相应无明和不共无明二种，一者相应无明，与前九种烦恼相应同迷，与亲迷的惑相应，则同亲迷；与疏迷的惑相应，则同疏迷。二、不共无明，独迷空无我理，亲迷苦谛。

    迷于苦谛的十种烦恼，已如上说。至于迷于集、减、道三谛的烦恼，则是除身、边二见外，只有八种。疑、邪见、不共无明三种，是亲迷三谛。见取、戒取、贪、嗔、慢五种，是疏迷三谛，和同迷苦谛的说法一样。然而嗔恚也能亲迷灭、道。因为它是由怖畏灭、道而起的憎嫉之故。

    关于此十种烦恼，直接或间接迷于四谛的情况，大概如上所述。若详细而说，贪、嗔、慢、我见、边见、邪见和疑七种，如果是俱生的，随其所应，如彼见道所断。俱生的身见和边见，及其相应的贪、慢、无明，虽然迷于苦谛，但微细难断，修道位才能断除。嗔及其余的独行爱、慢和相应无明等，是迷色、心等的别事而生，都是迷事而起，不违理观，所以是修道所断。

    论文二十三：虽诸烦恼皆有相分，而所仗质或有或无，名缘有事无事烦恼。彼亲所缘虽皆有漏，而所仗质亦通无漏，名缘有漏无漏烦恼。缘自地者，相分似质名缘分别所起事境。缘灭道谛及他地者，相分与质不相似故，名缘分别所起名境。余门分别如理应思。

    讲解：虽然十种烦恼，都有相分为亲所缘缘之境，但相分所仗托的种子本质，则或有、或无。有本质的名叫缘有事的烦恼；无本质的名叫缘无事的烦恼。各种烦恼的亲所缘缘境虽是有漏，但其所仗托的本质亦通无漏，名叫缘有漏无漏烦恼。

    设若是缘自地的烦恼，相分与本质相似。但此似本质，也是由现在分别而起，所以名叫分别所起事境。缘灭、道二谛，及他地烦恼，相分与本质并不相似。但有分别所起的名字，所以名叫缘分别所起的名言境。因为没有修证，也没有见或闻，所以但有名字，而没有本质。上面根本烦恼，共用十门分别。至于余门分别，应如理思惟。

    第四节　随烦恼心所

    论文一：已说根本六烦恼相，诸随烦恼其相云何？颂曰：随烦恼谓忿，恨覆恼嫉悭，诳谄与与害憍，无惭及无愧，掉举与惛沉，不信并懈怠，放逸及失念，散乱不正知。

    讲解：以上讲完了六种根本烦恼，各种随烦恼的特性又是怎么样呢？《唯识三十颂》的颂文说：随烦恼二十个，名称是忿、恨、覆、恼、嫉、悭，诳、谄、害、憍，无惭、无愧，掉举、惛沉，不信、懈怠，放逸、失念，散乱、不正知。

    论文二：论曰：唯是烦恼分位差别，等流性故，名随烦恼。此二十种，类别有三：谓忿等十，各别起故，名小随烦恼；无惭等二遍不善故，名中随烦恼：掉举等八遍染心故，名大随烦恼。

    讲解：论文说：颂中所标示的二十个随烦恼心所，又分为三类，指忿等十法各别生起，名小随烦恼；无惭、无愧遍不善法，名中随烦恼。掉举等八个遍于染心，名大随烦恼。

    论文三：云何为忿？依对现前不饶益境，愤发为性，能障不忿，执仗为业，谓怀忿者，多发暴恶身表业故。此即嗔恚一分为体，离嗔无别忿相用故。

    讲解：什么叫做忿呢？对现前所见不顺意的违境，即发起忿怒，此为忿的体性；能障碍不忿，进而拿棍棒斗殴，就是忿的业用。也就是说，凡是心怀忿怒的人，大多数都要发起暴恶的身行。所以忿是以嗔恚的一分为体性，离开了嗔，也就没有忿的相用了。

    论文四：云何为恨，由忿为先，怀恶不舍，结怨为性，能障不恨，热恼为业。谓结恨者不能含忍，恒热恼故。此亦慎恚一分为体，离嗔无别恨相用故。

    讲解：什么叫做恨？由于心中有忿在先，事情虽已过去，而怀念旧恶不肯舍弃，深结怨仇，这就是恨的体性；能障碍不恨，心生热恼，就是恨的业用。也就是说，结下怨恨的人，因为不能含容忍耐，所以心中恒起热恼。这也是以嗔恚的一分为体性，离开了嗔，也就没有恨的相用了。

    论文五：云何为覆，于自作罪恐失利誉，隐藏为性，能障不覆，悔恼为业。谓覆罪者后必悔恼，不安隐故。有义，此覆，痴一分摄。论唯说此痴一分故，不惧当苦覆自罪故。有义：此覆，贪痴一分摄，亦恐失利誉，覆自罪故。论据粗显，唯说痴分，如说掉举是贪分故，然说掉举遍诸染心，不可执为唯是贪分。

    讲解：什么叫做覆？就是对自己所造的过恶，恐怕万一暴露，会失掉财利和名誉，不惜文过饰非，把它隐藏起来，就是覆的体性；能障碍不覆，后悔苦恼，就是覆的业用。也就是说，隐覆过恶的人，后来必定忧悔懊恼，心中不得安稳。有人说：覆是属于痴的一分所摄，因为论上说覆是痴的一分，所以才不怕当来受苦，而隐覆自罪。

    又有人说：这个覆是贪和痴的各一部分所摄。因为恐怕失掉了现前的财利名誉，所以才隐覆自罪。论上是依据粗显相而说痴分的，其实非唯属痴，亦属贪分。例如说掉举是贪分所摄，其实掉举是遍诸染心，不可以执著唯属贪分。

    论文六：云何为恼，忿、恨为先，追触暴热，狠戾为性，能障不恼，蛆螫为业，谓追往恶，触现违缘，心便狠戾，多发嚣暴，凶鄙粗言，蛆螫他故。此亦嗔恚一分为体，离嗔，无别恼相用故。

    讲解：什么叫做恼？先有忿恨在心，后来一经追触著它，便生起暴恶狠戾，就是恼的体性；能障碍不恼，犹如蜂蝎恼了螫人，就是恼的业用。也就是说，追念已往的旧恶，又遇上了现在的违缘，心情便会毒狠乖戾，发出宣嚣暴躁、凶险鄙恶的粗话来，好像蜂蝎恼了一样。这个恼也是以嗔恚一分为体性。离开了嗔，就别无恼的相用了。

    论文七：云何为嫉？殉自名利，不耐他荣，妒忌为性，能障不嫉，忧戚为业。谓嫉妒者闻见他荣，深怀忧戚，不安隐故。此亦嗔恚一分为体，离嗔无别嫉相用故。

    讲解：什么叫做嫉？自己为求名利，不惜舍上生命；然而对他人的荣盛却不能忍耐，去妒忌人家。这就是嫉的体性；能障碍不嫉，忧郁愁戚，就是嫉的业用。也就是说，有妒忌的人，听见他人的荣盛，便深怀忧戚，不得安稳。这个嫉也是以嗔恚一分为体性，离开了嗔，就别无嫉的相用了。

    论文八：云何为悭？耽著财法，不能惠舍，秘吝为性，能障不悭，鄙畜为业，谓悭吝者心多鄙涩，畜积财法，不能舍故。此即贪爱一分为体，离贪无别悭相用故。

    讲解：什么叫做悭？就是耽著财、法，不肯惠施于人，所以秘吝就是悭的体性；能障碍不悭，鄙吝积蓄就是悭的业用。即悭吝的人，把许多钱财积蓄起来。就是懂些佛法，也不肯讲给别人听。这是以贪爱的一分为其体性，离开了贪爱，就没有悭的相用了。

    论文九：云何为诳？为获利誉，矫现有德，诡诈为性，能障不诳，邪命为业。谓矫诳者心怀异谋，多现不实，邪命事故。此即贪、痴一分为体，离二，无别诳相用故。

    讲解：什么叫做诳？因为自己要得到财利名誉，自己本来无道德而假装有道德，所以诳的体性就是诡谲矫诈，能障碍不诳，以非法活命为他的业用。也就是说，矫诈虚诳的人，心中怀著怪诞的诈谋，做一些看相、卜卦、咒术等不实在的邪命事业。这个诳的体性是贪、痴各一部分的和合相。离开了贪、痴，就别无诳的相用了。

    论文十：云何为谄？为罔他故，矫设异仪，险曲为性，能障不谄，教诲为业。谓谄曲者为罔冒他，曲顺时宜矫设方便，为取他意或藏己失，不任师友正教诲故。此亦贪、痴一分为体，离二，无别谄相用故。

    讲解：什么叫做谄？为要欺骗他人，装出一付奉承人的态度，巧言令色讨好他人。这样险诈歪曲的心态，就是谄的体性，能障碍不谄的正教训诲，就是谄的业用。也就是说，谄曲的人，像渔、猎者一样去网罗他人，所以不惜曲顺时宜，假设方便，去取悦他人；或隐藏自己的过失，不令他人知道。所以谄也是以贪、痴的一部分为体性，离开了贪、痴，就别无谄的相用。

    论文十一：云何为害？于诸有情心无悲愍，损恼为性，能障不害，逼恼为业，谓有害者逼恼他故。此亦嗔恚一分为体，离嗔无别害相用故，嗔害别相准善应说。

    讲解：什么叫做害？对于一切有情没有慈悲怜愍之心，反而要去损恼他们。所以害的体性就是损恼众生；能障碍不害，逼恼众生就是害的业用。也就是说，存心害人的人，因为逼恼他人，所以名之为害。这也是以嗔恚一部分为体性，离开了嗔就别无害的相用。嗔和害也有其不同的别相。那就是自善心所来说，嗔障不嗔，所以无慈；害障不害，所以无悲，嗔和害，断人慈悲心。

    论文十二：云何为憍？于自盛事深生染著，醉傲为性，能障不憍，染依为业。谓憍醉者生长一切杂染法故。此亦贪爱一分为体，离贪，无别憍相用故。

    讲解：什么叫做憍，对于自己一时的荣盛之事，深生染著，惛迷沉醉，恃以傲物，就是憍的体性，能障碍不憍，为一切染污法所依托，就是憍的业用。也就是说，凡是有憍傲心的人，便会生起一切有漏的杂染法来。这也是以贪爱的一分为体性，离开了贪，就别无憍的相用了。

    论文十三：云何无惭？不顾自法，轻拒贤善为性。能障碍惭，生长恶行为业。谓于自法，无所顾者，轻拒贤善，不耻过恶，障惭生长诸恶行故。

    讲解：什么叫做无惭？不顾自己的人格、及自己信奉的教法，轻视违拒贤善的人，就是无惭的体性；能障碍惭，生长一切恶行，就是无惭的业用。也就是说：假如一个人对于自己的品格、及圣教的教法都不顾了，自然对贤善的人轻视违拒，做了过恶也不怕羞耻，所以才障碍惭而生起一切恶行了。

    论文十四：云何无愧？不顾世间，崇重暴恶为性，能障碍愧，生长恶行为业。谓于世间无所顾者，崇重暴恶，不耻过罪，障愧生长诸恶行故。

    讲解：什么叫做无愧？就是不顾世间人的指责非议，崇重暴恶行为，就是无愧的体性。能障碍愧，生长一切恶行，就是无愧的业用。也就是说，如果一个人，对于世间舆论的批评与责难都无所顾忌，他崇重暴恶，对于罪过还怕羞耻吗？因此才能为愧的障碍，而生起了一切恶行。

    论文十五：不耻过恶，是二通相，故诸圣教假说为体。若执不耻为二别相，则应此二体无差别。由斯二法应不俱生，非受、想等有此义故。若待自他立二别者，应非实有，便违圣教。若许此二实而别起，复违论说俱遍恶心。不善心时随缘何境，皆有轻拒善及崇重恶义。故此二法俱遍恶心，所缘不异无别起失。然诸理教说不顾自他者，自法名自，世间名他。或即此中拒善崇恶，于己益损名自他故。而论说为贪等分者，是彼等流，非即彼性。

    讲解：不耻过恶这句话，是无惭、无愧二法的通相。所以很多经论上，假说‘不耻’是无惭无愧的体性，如果一定要执著「不耻’是无惭、无愧的别相，那就应当无惭也是‘不耻’，无愧也是‘不耻’，这二法岂不成为一体，而没有差别了吗？如此，则自体不并，那二法就不能说是俱时而生了。例如受、想等的遍行五法，他们都是各有各体，才能俱生，并没有这一体俱生的意义。

    若说无惭是待自缘而起，无愧是待他绿而起，这样建立了二种别相，那也不对。无惭、无愧，既是待缘而起，就应当不是实有，岂不违背了经论所说这二法都是实有的道理吗？若许这无惭、无愧，虽是实法，却是别起，那就又违背了论上所说，二法是俱遍恶心了。怎样俱遍恶心，当不善心生起的时候，随便缘什么境界，都有轻拒善法，及崇重恶法的意义。所以无惭、无愧，是俱遍恶心，而不是前后别起。二法所缘的境界，既然都是一样，那里会有别起的过失呢？

    然而有很多经论上说，不顾自、他，是说自已和所奉的教法叫做自；世间的舆论和法令规章叫做他。或者就以这里所说，轻拒于己有益的善法，叫做自；崇重于己有损的恶法，叫做他。而论上说无惭无愧为贪、痴分所摄者，那是说为贪痴的等流，并不是贪痴的体性。

    论文十六：云何掉举？令心于境不寂静为性，能障行舍、奢摩他为业。有义：掉举贪一分摄，论唯说此是贪分故，此由忆昔乐事生故。有义：掉举非唯贪摄，论说掉举遍染心故，又掉举相谓不寂静，说是烦恼共相摄故。掉举离此无别相故。虽依一切烦恼假立，而贪位增，说为贪分。有义：掉举别有自性，遍诸染心，如不信等，非说他分体便非实，勿不信等亦假有故。而论说为世俗有者，如睡眠等随他相说。掉举别相谓即嚣动，令俱生法不寂静故。若离烦恼无别此相，不应别说障奢摩他。故不寂静非此别相。

    讲解：什么叫做掉举？令心于境不寂静为性，能障碍平等正直的行舍、及止的奢摩他，就是掉举的业用。下面对于掉举的等流，有三家不同的说法。第一家说：掉举是贪的一分所摄，因为论上说，这掉举是属于贪的一分之故，这是由追忆往昔的乐事而生起的。第二家说：掉举不唯是贪分所摄，因为论上说，掉举是普遍于一切染心，又因为掉举的行相是不寂静故，所以说它是烦恼的共相所摄。如果掉举离开了不寂静，就别无所谓掉举的行相了。虽然掉举是依一切烦恼而假立的，但在贪位时比较增盛，所以就说它为贪分所摄。

    第三家说：掉举，除贪等外，还别有他自己的体性。虽说掉举遍一切染心，但它同不信、懈怠一样，还是各有别体，并不是说属于其他一分，连自体也不是实有了。怎可以说不信等也是假有的。而论上说掉举是世俗假有，那是好像同睡眠一样，是随无明相一分而说的，其实还是有体的。

    所以掉举的别相就是嚣动，令俱生起等法，不能常时寂静。如果离开了一切烦恼，那就没有掉举的行相了。因此不应别说掉举是障碍奢摩他的止。故不寂静不是掉举的别相，它另有嚣动来做其别相。

    论文十七：云何惛沉？令心于境无堪任为性，能障轻安、毗钵舍那为业。有义：惛沉痴一分摄，论唯说此是痴分故，惛昧沉重是痴相故。有义：惛沉非但痴摄，谓无堪任是惛沉相，一切烦恼皆无堪任，离此无别惛沉相故。虽依一切烦恼假立，而痴相增但说痴分。有义：惛沉别有自性，虽名痴分而是等流，如不信等，非即痴摄。随他相说名世俗有，如睡眠等是实有性。惛沉别相，谓即懵重，令俱生法无堪任故。若离烦恼无别惛沉相。不应别说障毗钵舍那。故无堪任非此别相。此与痴相有差别者，谓痴于境迷闇为相，正障无痴而非懵重。惛沉为境懵重为相，正障轻安而非迷闇。

    讲解：什么叫做惛沉，就是令心于所缘的外境，没有堪能任持的功能，就是惛沉的体性。并且能障碍轻安及毗钵舍那的观照，就是惛沉的业用。对惛沉的等流有三家不同的说法。第一家说：惛沉是痴一分所摄。因为论上说惛沉痴的一分。惛昧和沉重就是痴的行相。第二家说：惛沉不唯是痴分所摄，那无堪任才是惛沉的行相。因为一切烦恼都没有堪任，如果离开了无堪任，就别无惛沉行相。虽然它是依托一切烦恼假立的，因为在痴上较为增盛，所以但说它是痴分所摄。

    第三家说：惛沉别有它自己的体性，是痴的等流，并不是痴摄，好像不信一样，各有各的自体。惛沉随痴相说，名世俗假有，好像睡眠、恶作一样，实际上它有自己的体性，故是实有。惛沉的自性就是昏懵沉重，他能够使俱生的心、心所法，没有堪任善法的能力。如果离开了烦恼，就别无惛沉的行相。不应当说惛沉能障毗钵舍那，因为无堪能任持并不是惛沉的特性，惛沉与痴的区别，在于痴对于境界以迷阎为性，障碍善法中的无痴。惛沉对外境昏懵、沉重，是其特性，正障善法中的轻安。但并不是对外境迷惑不解。

    论文十八：云何不信，于实、德、能不忍乐欲，心秽为性，能障净信，惰依为业，谓不信者多懈怠故。不信三相翻信应知，然诸染法各有别相，唯此不信自相浑浊，复能浑浊余心、心所，如极秽物自秽秽他，是故说此心秽为性。由不信故，于实、德、能不忍乐欲，非别有性。若于余事邪忍乐欲，是此因果，非此自性。

    讲解：什么叫做不信，对于三宝的实有事理，实有功德，实有能力，不肯忍可去好乐欲求，这种人的心地污秽，就是不信的体性；能障碍净信，为懒惰所依托，就是不信的业用。也就是说，不信三宝的人，在修行路上懈怠而不肯精进，不努力去断恶修善。不信也有三相，那就是与信相反，不信实、不信德、不信能。一切染污法，都各有各的别相，唯有这不信，他的自相是垢秽浑浊，并且能浑浊其余的心、心所法。好像一种极污秽的东西，不但自秽，而且也能秽他。因此才说这不信是以心秽为性。

    由于不信的原故，所以对实事真理，以及三宝的功德，圣贤的道德，善法的能力，都不能够忍受乐欲。这不忍乐欲就是不信，所以并没有别的体性。倘若在其余的染法上起了邪忍、邪乐、邪欲，那是不信的因果，并不是不信的自性。

    论文十九：云何懈怠？于善恶品修断事中，懒惰为性，能障精进，增染为业。谓懈怠者，滋长染故，于诸染事而策勤者，亦名懈怠，退善法故。于无记事而策勤者，于诸善品无进退故，是欲胜解，非别有性，如于无记忍可乐欲，非净非染，无信不信。

    讲解：什么叫做懈怠？对于善品的事不努力去修，对于恶品的事不努力去断，所以懒惰是懈怠的体性；能障碍精进，增长一切染污法，就是懈怠的业用。也就是说：懈怠的人，他能使染法滋长。不但对于善法不勤的人，名叫懈怠，就是对于一切染法而能勤勉的人，也名叫懈怠。因为善法随著染法的滋长而退失了。对于染净俱非的无记法而能勤勉的人，对于一切善法无进无退，那是别境的欲和胜解，并没有它自己的体性。如果对于无记法能够忍可乐欲，那是非染非净，当然也无所谓信与不信、精进与懈怠了。

    论文二十：云何放逸，于染净品不能防修，纵荡为性，障不放逸，增恶损善所依为业，谓由懈怠及贪嗔痴，不能防修染净品法，总名放逸，非别有体。虽慢疑等亦有此能，而方彼四势用微劣，障三善根，遍策法故，推究此相，如不放逸。

    讲解：什么叫放逸？对于恶法不能防使不起，对于善法不能修使增长，纵逸放荡，就是放逸的体性；能障碍不放逸，使恶法增长，善法损减，就是放逸的业用。也就是说：由于懈怠，及贪、嗔、痴四法，不能防恶修善，总名叫做放逸。除了以上四法，就没有放逸的体性。虽然慢、疑、不正见等法，也不能防恶修善，然而比起懈怠等四法来，它们的势用则嫌微劣。因为贪、嗔、痴能障碍不贪、不嗔、不痴的三善根，懈怠能障碍精进，不能普遍策励一切善法。要想推究这放逸的行相，只要把善法里的不放逸翻过来就是了。

    论文二十一：云何失念？于诸所缘，不能明记为性，能障正念，散乱所依为业，谓失念者心散乱故。有义：失念，念一分摄。说是烦恼相应念故。有义：失念，痴一分摄，瑜伽说此是痴分故，痴令念失故名失念。有义：失念，俱一分摄。由前二文，影略说故，论复说此遍染心故。

    讲解：什么叫做失念？对于一切所缘境界，不能明白记忆，致令忘失，就是失念的体性；能障碍正念，为散乱心所依托，就是失念的业用。也就是说：失念的人，心必散乱。失念的分位，有三家异说。第一家说：失念是五别境中念的一分所摄，因为这个念，是与烦恼相应的原故，所以说它是失念。第二家说：失念是三不善根之一的痴分所摄，。因为瑜伽论上说，失念是痴一分所摄。论曰：痴能够令人正念忘失，所以名叫失念。第三家说：失念，是念和痴各一分所摄。由于前两家都是捕风捉影的概略之说，所以第一家但说是念，第二家但说是痴，实则，为念、痴二者所摄。论上又说，失念是普遍存在于一切染心。

    论文二十二：云何散乱，于诸所缘，令心流荡为性，能障正定，恶慧所依为业，谓散乱者发恶慧故。有义：散乱痴一分摄。瑜伽说此痴一分故。有义：散乱贪嗔痴摄。集论等说是三分故。说痴分者，遍染心故。谓贪嗔痴令心流荡胜余法，故说为散乱。有义：散乱别有自体。说三分者，是彼等流，如无惭等非即彼摄。随他相说名世俗有。散乱别相谓即躁扰，令俱生法，皆流荡故。若离彼三无别自体，不应别说障三摩地。掉举、散乱，二用何别？彼令易解，此令易缘。虽一刹那解缘无易，而于相续有易义故。染污心时由掉乱力，常令念念易解易缘。或由念等力所制伏，如系猿猴，有暂时住，故掉与乱，俱遍染心。

    讲解：什么叫做散乱？对于所缘的一切外境，令心驰流、荡逸，就是散乱的体性；能障碍正定，为恶慧所依，就是散乱的业用。也就是说：心散乱的人，他能发起不正当的恶慧。对于散乱的摄属，有三家不同异说。第一家说：散乱，是属于痴的一分所摄。因为《瑜伽论》上说这是痴的一分故。

    第二家说：散乱是贪、嗔、痴三法所摄，因为《杂集论》、《五蕴论》等都这样说。《瑜伽论》但说是痴分所摄者，那是因为痴是普遍于一切染心之故。这里所谓的贪、嗔、痴，是三不善根。因为它们能令心流荡，其行相之猛，胜过余法之故，所以叫做散乱。第三家说：散乱，别有他自己的体性。至于说是贪、嗔、痴三分者：不过是彼等的等同流类而已。好像说无惭、无愧一样，虽说三分所摄，而不即是三分，不过随著三分的相，说是世俗假有而已，实则，散乱是别有自体的。

    散乱的别相就是躁扰。躁就是散，扰就是乱，它能使俱生的心、心所法，都成流荡。然而，流荡是余惑的共相，并不是散乱的自性。假如散乱离三法外，别无自体的话，那就应当通说三法共障正定，不应该说散乱能障正定。

    问：掉举和散乱，此二者的功用有何差别呢？答：掉举是更易能知之心，散乱是更易所缘之境。虽然在刹那一念之间，能缘的心和所缘的境没有变易，但在念念相续的时候却是有变的。一到了有染污心的时候，因为有掉举和散乱两种力量，所以令心和境念念转易。或者，由于念、定等力所制伏，好像绳系猿猴似的，暂时专注，但并非永断。所以掉举和散乱，都是普遍于一切染心。

    论文二十三：云何不正知，于所观境谬解为性，能障正知，毁犯为业，谓不正知者多所毁犯故。有义：不正知，慧一分摄。说是烦恼相应慧故。有义：不正知，痴一分摄。瑜伽说此是痴分故。令知不正名不正知。有义：不正知俱一分摄。由前二文影略说故。论复说此遍染心故。

    讲解：什么叫做不正知？就是对于所观察的境界，生起错误的见解，这是不正知的体性；能障碍正知毁法犯戒，就是不正知的业用。也就是说：凡是知见不正的人，多数是破坏因果，毁犯戒律。不正知的等流，有三家不同的解释。第一家说：不正知是慧的一分所摄，不过这是和烦恼相应的染污慧罢了。第二家说：不正知，是痴的一分所摄，《瑜伽论》上说：不正知属于痴分，因为痴能使知见不正，所以名不正知。第三家说：不正知，是痴、慧两种所摄，如一家说痴，一家说慧，都是捕风捉影的概略之说，并不是有慧无痴，或有痴无慧。因为论上还说，不正知是遍染心故，所以是慧、痴都摄。

    论文二十四：与并及言，显随烦恼非唯二十，杂事等说，贪等多种随烦恼故。随烦恼名亦摄烦恼，是前烦恼等流性故，烦恼同类，余染污法，但名随烦恼，非烦恼摄故。唯说二十随烦恼者，谓非烦恼，唯染、粗故。此余染法或此分位，或此等流，皆此所摄，随其类别，如理应知。

    讲解：以上把二十个随烦恼都讲完了，但颂中还有‘与’、‘并’、‘及’三字是什意思？那是显示随烦恼不止二十个，因为《杂事经》说：贪、嗔、痴等里面，有多种随烦恼，既说多种，当然不止二十。可见其余的随烦恼，也都摄在烦恼里面，因为是从根本烦恼流出来的。至于其余烦恼的同类染污法，只能名叫随烦恼，不得是烦恼的本身。

    以上但说二十个随烦恼者，有下列三义：一者非根本烦恼，但名随烦恼。二者体唯染污，不通三性。三者相唯粗猛，而非细惑。所以唯说二十，不说其余。其余的染法，或是随烦恼的分位，或是由随烦恼所起的等流，都被这二十所摄。随其类别，各归所属，如理应知。

    论文二十五：如是二十随烦恼中，小十、大三，定是假有。无惭、无愧、不信、懈怠，定是实有，教理成故。掉举、惛沉、散乱三种，有义是假，有义是实，所引理教，如前应知。二十皆通俱生分别，随二烦恼势力起故。

    讲解：二十个随烦恼，古人以十二门来分析它。这十二门的第一门是假实门，在二十个随烦恼中，小随十个，大随的忘念、放逸、不正知三个，这十三个定是假有。中随的无惭、无愧，和大随的不信、懈怠，这四个定是实有。这十三种假、四种实，都是由教理证明而成立的。至于大随里的掉学、惛沉、散乱三种，有人说是假，有人说是实，他们所引证的理教，都同前面诠释体业所说的一样。

    十二门的第二门是俱生、分别门。这二十个随烦恼，都通于俱生起和分别起的烦恼，因为他们都是随著这两种烦恼的势力而生起的。

    论文二十六：此二十中，小十展转定不俱起，互相违故，行相粗猛各为主故。中二一切不善心俱，随应皆得小大俱起。论说大八遍诸染心，展转小中皆容俱起。有处说六遍染心者，惛、掉增时不俱起故。有处但说五遍染者，以惛、掉等违唯善故。

    讲解：这是第三门自类相应门。这二十随烦恼里，忿等十个小随烦恼，决定不能同时俱起，因为它们的体性相违、行相粗猛、所以是各自为主。无惭、无愧两个中随烦恼，遍于一切不善心中，因此随其所应，可与小随、大随并起。论上说，掉举等的八个大随烦恼，遍于一切染心的，所以与小随、中随都可并起。

    然而，为什么有处说，只有六个大随烦恼遍一切染心呢？那是因为在惛沉和掉举的力量增盛时，一下、一高，不能俱起。所以在八大随烦恼里要除去他们。为什么有处说是五遍染心呢？那是因为八大随中的不信、懈怠、惛沉、掉举、放逸五法，是唯与善违。其余的失念和不正知二法，有痴分摄，有非痴分摄；散乱一法，有时也为定力所伏，都不是唯与善违。所以但说五法是俱遍染心。

    论文二十七：此唯染故，非第八俱。第七识中唯有八大，取、舍差别，如上应知。第六识俱，容有一切。小十粗猛，五识中无。中大相通，五识容有。

    讲解：这是第四门诸识相应门。这二十个随烦恼，因为它们的体唯染污，所以和第八阿赖耶识没有关系。第七末那识唯有八大随惑，中、小都无。或在八大随惑里，取六舍二，取五舍三，如此取舍差别，前文所说应知。第六意识容有一切烦恼。十个小随烦恼行相粗猛，前五识里没有，中二、大八的行相相通，前五识或可容有。

    论文二十八：由斯中、大五受相应。有义：小十除三，忿等唯喜忧舍三受相应，谄诳憍三，四俱除苦。有义：忿等四俱除乐。谄诳憍三，五受俱起。意有苦受前已说故。此受俱相，如烦恼说，实义如是。若随粗相，忿恨恼嫉害忧舍俱，覆悭喜舍，余三增乐，中大随粗，亦如实义。

    讲解：这是第五门诸受相应门。由于遍不善染的原故，所以中二、大八随惑，都与五受相应。至于小随烦恼是否与五受相应，此有二说，第一家说，十个小随烦恼中，除了诳、谄、憍三个外，其余忿等七个，唯与喜、忧、舍三受相应。至于谄、诳、憍三个，除苦受之外，与喜、忧、乐、舍四受相应。第二家说，十个小随烦恼中，除了诳、谄、憍三个外，其余忿等七种，除乐受外，与其余喜、忧、苦、舍四受相应。意识中有苦受，前已说过。

    以上是约审细的实义而说的，若随粗相而论：忿、恨、恼、嫉、害五法，是与忧受和舍受相应。覆、悭二法，是与喜、舍相应。其余的谄、诳、憍三法，是与喜、舍、乐三受相应。中随和大随的粗相，也同前面实义的说法一样，与五受相应。

    论文二十九：如是二十，与别境五皆容俱起，不相违故。染念、染慧，虽非念、慧俱，而痴分者亦得相应故。念亦缘现曾习类境，忿亦得缘刹那过去，故忿与念，亦得相应。染定起时，心亦躁扰，故乱与定，相应无失。

    讲解：这是第六门别境相应门。这二十个随烦恼，与别境五法，都可以俱起。因为他们的行相彼此不相违背。染念就是忘念，染慧就是不正知，虽然不能够与念、慧并起，然而以痴分为体的忘念和不正知，也得与念、慧相应。别境的念，是现在缘过去曾经熟习的境界，忿也可以缘刹那的过去境，所以念和忿也可以相应。就是染定生起的时候，心中还是躁扰，躁扰的行相就是散乱，所以说散乱与定相应并无过失。

    论文三十；中二大八，十烦恼俱。小十，定非见疑俱起。此相粗动，彼审细故。忿等五法，容慢痴俱，非贪恚并，是嗔分故。悭痴慢俱，非贪痴并，是贪分故。憍唯痴俱，与慢解别，是贪分故。覆诳与谄，贪痴慢俱。行相无违，贪痴分故。

    讲解：这是第七门根本相应门。中随烦恼二，大随烦恼八，这十种随烦恼，可以和十个根本烦恼相应俱起。小随烦恼十个，和根本烦恼中的见、疑二法，决定不能俱起。因为小随的行相粗动，见、疑审细，所以不能相应俱起。忿、恨、恼、嫉、害五法，可容与根本烦恼的慢、痴俱起，而不与贪、恚并生。因为忿等的自体就是嗔，所以不与嗔并。行相与贪相违，所以也不与贪并。

    小随烦恼的悭，与根本烦恼的痴、慢俱起，而不与贪、嗔俱生。因为悭的自体就是贪分，所以不与贪并；而行相与嗔相违，所以不与嗔俱。小随的憍，唯与根本烦恼的痴俱起，而不与慢、贪并起。因为憍、慢二法的解释不同，憍是由自高而起，慢是缘他下而生，所以不与慢俱。憍的自体就是贪分，所以也不与贪并。

    小随的覆、诳、谄三法，与根本烦恼的贪、痴、慢都可以俱起。因为它们的行相彼此互不相违。问：覆等的自体既是贪、痴分摄，何以与贪、痴俱起？答：因为是贪分故，所以与痴俱起；是痴分故，所以与贪俱起。

    论文三十一：小七中二，唯不善摄。小三、大八，亦通无记。

    讲解：这是第八门三性相摄门。小随烦恼的忿等七法，中随烦恼的无惭、无愧，在善、恶、无记三性里，唯为不善所摄，不通余二。小随烦恼的谄、诳、憍，和大随烦恼八个，通于不善及有覆无记。因为谄、诳、憍三个小随，若和无惭、无愧同起，属于不善；若不和无惭、无愧同起，则属于有覆无记。

    论文三十二：小七中二，唯欲界摄，诳谄欲色，余通三界。生在下地容起十一，耽定于他，起憍诳谄故。若生上地起下后十。邪见爱俱，容起彼故。小十生上，无由起下。非正润生，及谤灭故。中二大八下亦缘上。上缘贪等相应起故。有义：小十下不缘上，行相粗近不远取故。有义：嫉等亦得缘上，于胜地法生嫉等故。大八谄诳，上亦缘下。下缘慢等相应起故。梵于释子起谄诳故。憍不缘下，非所恃故。

    讲解：这是第九门界地摄缘门。小随的忿等七法，中随的无惭、无愧；这九个小、中随惑，唯欲界摄；诳、谄二法，可通欲界及色界初禅。至于小随的憍，及八个大随，则通于三界。生在下地的有情，容许生起上地十一种烦恼，就是谄、诳、憍及八个大随烦恼。因为耽著上地的禅定，起自高憍，对于其他的欲界有情，生起诳、谄。至于八个大随，那更是遍一切染法、润生，都有他们。倘若生在上地，容起下地的后十烦恼──中二和大八。因为上地有情，临命终时，所起谤无涅槃的邪见里，有中随二法；润生爱(注：俱生烦恼，在临命终时，所起的自体爱、境界爱、当生爱)里，有八大随烦恼。至于小随烦恼的忿等十法，若生上地，那就无从再缘下地而起了。因为忿等十法，唯是不善，而不是润生爱的无记，又没有谤无涅槃的邪见，所以不起。

    中二、大八这十个下地烦恼，也可以缘上地。因为它们同前面根本烦恼中所说，那缘上的贪、嗔，是相应而起之故，所以亦缘上地。十个小随的下地烦恼，是否缘上？有两家异说。第一家说：这十个小随，下不缘上。因为小随的行相粗近，不能远取上地境界。第二家说：小随中的忿等七法，决定不能缘上，而嫉、悭、憍三法是可以缘上的。因为下地有情，对胜地法，也会生起嫉等之故。对上地有情，所得静虑生嫉；对自地有情，恃己所证的上地法，而生悭、憍。

    大随烦恼八个，和小随烦恼的谄、诳，这十法上亦缘下。因为同根本烦恼缘下的慢等，是相应而起之故，所以上地的八大随烦恼缘下。例如梵王执马胜比丘手，对释迦的弟子生起谄、诳，所以上地有谄、诳缘下。唯有上地的憍不缘下地。因为下地法劣，不是上地有情所恃以憍人之故。

    论文三十三：二十皆非学无学摄。此但是染，彼唯净故。

    讲解：这是第十门学等相摄门。这二十个随烦恼，不是有学、也不是无学所摄。因为烦恼是属于染污法，学、无学唯是净法，所以二者没有关系。

    论文三十四：后十，唯通见修所断，与二烦恼相应起故。见所断者随迷谛相，或总或别，烦恼俱生，故随所应皆通四部。迷谛亲疏等，皆如烦恼说。前十，有义：唯修所断，缘粗事境任运生故。有义：亦通见修所断，依二烦恼势力起故。缘他见等，生忿等故，见所断者，随所依缘，总别惑力皆通四部。此中有义：忿等但缘迷谛惑生，非亲迷谛，行相粗浅，不深取故。有义：嫉等亦亲迷谛。于灭道等生嫉等故。

    讲解：这是第十一门见等所断门。二十烦恼的后十个，即中二大八，唯通见道及修道所断，非非所断。因为他们是和俱生、分别二种烦恼相应而起之故。属于见道所断的烦恼，随其所迷于四谛的行相，或十烦恼总迷，或各烦恼别迷，这总别能迷的烦恼，都随其所迷的谛理而俱生。所以随其所应，都通四谛。至于直接、间接的迷谛亲、疏，都如根本烦恼所说。比类可知。

    至于前面的十个小随烦恼，有两家异说：第一家说，这十个小随，是唯修所断。因为这十个小随烦恼缘的是粗事境界，任运生起，不是分别所起。第二家说：这十个小随，不但是修道所断，而且亦通于见道所断。因为这十个小随，是依俱生、分别的势力而起。并非但缘粗事，且亦缘其他身见、邪见，而生起忿等十个小随。

    属于见道所断的烦恼，随其所依与所缘，或总或别的惑力，都通四谛。但也有两家不同的解释：一家谓忿等十法，但缘迷于四谛之理的烦恼所生，而不是亲迷谛理。因为他们的行相粗浅，不能深取迷谛之故。一家谓除覆、诳、谄外的忿等七法，不但缘迷谛的烦恼，而且也亲迷谛理。因为对灭、道二谛，也会直接生起嫉等随惑之故。

    论文三十五：然忿等十，但缘有事，要托本质力得生故。缘有漏等，准上应知。

    讲解：这是第十二门的随境立名门。忿等十种小随烦恼，但缘有本质的相分。因为他们不是缘影像而起，要仗托著种子所生的本质才能生起。至于缘有漏、无漏的事境，应如烦恼所说，比类可知。

    第五节　不定心所

    论文一：已说二十随烦恼相，不定有四其相云何？颂曰：不定谓悔眠，寻伺二各二。论曰：悔眠寻伺，于善染等皆不定故，非如触等定遍心故，非如欲等定遍地故，立不定名。

    讲解：以上讲完二十个随烦恼的行相，四种不定心所，其行相又是如何呢？颂中答称：不定四法，就是悔、眠，寻、伺，这又各分为善和不善二种，所以称二各二。

    论文二：论曰：悔谓恶作，恶所作业，追悔为性，障止为业。此即于果假立因名，先恶所作业，后方追悔故。悔先不作亦恶作摄，如追悔言：我先不作如是事业，是我恶作。

    讲解：悔，就是恶作，就是厌恶先前所作过的善恶之业。以追悔为体性，障碍奢摩他止为业。恶作是因，悔体是果，就是在追悔的果上，假立恶作的因名。因为先对所作的事生了厌恶，然后才追悔故。不但追悔先所作业叫做恶作，就是追悔先所未作的业也叫作恶作。如追悔的人说：我先前为什么不去作这件事呢？因为那是我所恶作的事啊！

    论文三：眠谓睡眠，令身不自在，昧略为性，障观为业。谓睡眠位身不自在，心极闇劣。一门转故。昧简在定，略别寤时，令显睡眠非无体用。有无心位，假立此名，如余盖缠，心相应故。

    讲解：眠，就是睡眠，能令身不得自在，以闇昧简略为其体性，障碍观行是其业用。也就是说在睡眠中的人，不但身不自在，连心灵也极闇昧劣弱。因为他没有向外缘境的五识，只有一个意识在里面闇劣转起。闇昧不同于定中，简略不同于醒时的散心位，这显示睡眠并不是没有体用。有于无心位也称为睡眠，这是假立的，好像五盖和十缠一样，是与心相应的心所法，并非无体。（注：盖者烦恼之异名，即覆盖行者之心，使善心不能生起。盖有五种：一者贪欲盖，因贪外境以盖心性，障乐出家。二者嗔恚盖。对于违境怀忿怒以盖心性，障觉正行。三者惛沉睡眠盖。心昏身重，障碍修定。四者棹举恶作盖。五者疑盖。五盖能障三位，初乐出家，次修正行、后入正定。缠也是烦恼异名，因为烦恼使人之身心不得自在，不得解脱，故称之为缠。可以分为八种或十种。八种为惛沉、睡眠、棹举、恶作、嫉、悭、无惭、无愧。再加念、覆，即成十缠。）

    论文四：有义：此二唯痴为体，说随烦恼，及痴分故。有义：不然，亦通善故。应说此二染痴为体，净即无痴。论依染分，说随烦恼及痴分摄。有义：此说亦不应理，无记非痴，无痴性故。应说恶作，思慧为体，明了思择所作业故。睡眠合用思想为体，思想种种梦境相故，论俱说为世俗有故。彼染污者，是痴等流，如不信等，说为痴分。有义：彼说理亦不然。非思、慧、想，缠彼性故。应说此二各别有体，与余心所行相别故，随痴相说，名世俗有。

    讲解：关于悔、眠的体性，有四家不同的说法。第一家说，这悔、眠二法，是以痴心所为体。因为《瑜伽论》上说，悔、眠是随烦恼，是痴心所一分所摄。

    第二家说，不然，因为悔、眠不完全属于恶，而且也通于善。所以应当说，这悔眠二法，在染分是以痴为体，在净分又是以无痴为体。不过论上但约染分而说，说他是随烦恼，及为痴心所一分所摄。

    第三家说，这种通染净之说也不合理，因为论上都说是通于三性，三性中的无记，不是痴，也不是无痴，应当说是恶作，是以思、慧二法为体。因为慧能明了所作事业，思能拣择所作事业。睡眠是以思、想二法为体，思想能幻起种种梦境之故。因为这悔、眠二法，非别有体，所以论上说它们是世俗假有。如果是染污方面，是痴的等同流类，同不信等一样说为痴一分所摄。

    第四家说：三家所说理亦不然，悔、眠的体性是缠，而不是思、慧、想。因为思、慧、想，不是缠性。应当说：这悔、眠二法，各别有体，他们和其余的思等心所，行相不同。论上说名世俗有者，那是随著痴相而说的。

    论文五：寻谓寻求，令心偬遽，于意言境粗转为性。伺谓伺察，令心偬遽，于意言境细转为性。此二，俱以安不安住身心分位所依为业。并用思慧一分为体。于意言境不深推度，及深推度，义类别故。若离思、慧，寻、伺二种体类差别，不可得故。

    讲解：寻是寻求，能使心偬忙急遽，在意识所取的名言和境相上，粗转为性。伺是伺察，也能使心偬忙急遽，在意言上细转为性。这寻、伺二法，都是以心安住和不安住来分位的。思的寻伺细缓，心得安住；慧的寻、伺粗急，心不安住。心安住和不安住，都是依于寻、伺。所以说是‘所依为业’。

    寻、伺二心所，是以用思、慧一分为体性。不过在意识所取的名言境上，有浅、深不同的推度。思是不深推度，名之为寻；慧是深的推度，名之为伺，这是因义类来分别。如果离了思、慧这两个心所，那寻、伺二法体类的差别是不可得的。

    论文六：二各二者，有义：寻伺各有染净二类差别。有义：此释不应正理。悔、眠亦有染净二故。应说如前诸染心所，有是烦恼、随烦恼性，此二各有不善、无记，或复各有缠及随眠。有义：彼释亦不应理，不定四后，有此言故。应言二者显二种二：一谓悔、眠，二谓寻、伺。此二二种，种类各别，故一二言，显二二种。此各有二，谓染不染，非如善、染各唯一故。或唯简染，故说此言，有亦说为随烦恼故。为显不定义，说二各二言，故置此言，深为有用。

    讲解：二各二这句话，有三家异说：第一家说，二各二就是寻、伺二法，各有染污和清净两种差别，叫做二各二。第二家说，此说不合正理，因为悔，眠也有染、净两种。应当说同前面的染心所一样，有根本烦恼和随烦恼，这根、随两种烦恼，各有不善和无记二性。或复各有现行的缠和种子的随眠，就叫做二各二。

    第三家说，这样解释也不对。在不定四法之后，才有二各二的说法，应当说，第一个二是显示悔、眠和寻、伺二种，第二个二是说这悔、眠、寻、伺四法各有二种，一种是染，一种是不染。它不像前来的善染一样，善法唯是善性，染法唯是染性。或者简别这不是唯染，因为《瑜伽论》也说这是随烦恼。然而随惑唯染，不定四则通于三性。为显示不定与唯染不同，才说出二各二的话来，安置这一句话深为有用。

    论文七：四中寻伺，定是假有，思慧合成，圣所说故。悔眠，有义：亦是假有，瑜伽说为世俗有故。有义：此二是实物有，唯后二种说假有故。世俗有言随他相说，非显前二定是假有。又如内种，体虽是实，而论亦说世俗有故。

    讲解：古人以十二门来分别不定四法，第一是假实门。不定四法中的寻、伺二法，决定是假有，因为此二是思、慧二法所合成为体。悔和眠，则有两家异说，第一家说：悔、眠是假有，因为《瑜伽论》上说它是世俗有故。第二家说：这悔、眠二法是实有，因为论上但说寻、伺是假有，世俗有的话是随此说的，并没有说悔、眠也是假有。好像阿赖耶识里种子一样，本来有实体，而论上也说它是世俗的假有。

    论文八：四中寻伺，定不相应，体类是同，粗细异故。依于寻伺，有染杂染立三地别，不依彼种现起有无，故无杂乱。俱与前二容互相应，前二亦有互相应义。

    讲解：这是第二自类相应门。在四法中，寻和伺二法决定不能相应。因为他们的体同思慧，类同推度，好像指不触指，刀不割刀，自己不能和自己相应。这寻、伺的分位有二种：一者是欲界和初禅，是有寻有伺。二者是初禅至二禅，是无寻有伺。三者是二禅以上，是无寻无伺。这是依界地来分，不是以现行和种子来分，所以不会杂乱。寻、伺和悔、眠两种，是可以相应的。因为悔和眠的时候也有寻、伺。悔和眠也可以相应，因为睡眠的时候也可以生悔。

    论文九：四皆不与第七八俱，义如前说。悔眠唯与第六识俱，非五法故。有义，寻、伺亦五识俱，论说五识有寻伺故。又说寻伺即七分别，谓有相等。杂集复言，任运分别，谓五识故。有义：寻伺唯意识俱。论说寻求伺察等法，皆是意识不共法故。又说寻伺忧喜相应。曾不说与苦乐俱故。舍受遍故，可不待说。何缘不说与苦乐俱？虽初静虑有意地乐，而不离喜总说喜名。虽纯苦处有意地苦，而似忧故总说为忧。又说寻伺，以名身等义为所缘，非五识身，以名身等义为境故。然说五识有寻伺者，显多由彼起，非说彼相应。杂集所言，任运分别，谓五识者，彼与瑜伽所说分别，义各有异。彼说任运即是五识，瑜伽说此，是五识俱，分别意识，相应寻伺。故彼所引为证不成。由此五识定无寻伺。

    讲解：这是第三诸识相应门。不定四法，不和第七、八识相应，这在前面初、二能变的相应门早已说过。悔、眠二法，唯与第六意识相应，因为前五识是任运缘境，所以不和悔相应；眠时五识不行，所以不和眠相应。至于寻、伺二法，有两家异说，第一家说，寻、伺二法不但与意识俱起，也与五识俱起，因为论上说五识也有寻、伺。又说寻、伺，就是七种分别：有相分别，无相分别，任运分别，寻求分别，伺察分别，染污分别，不染污分别。《杂集论》上又说，任运分别，就是前五识。

    第二家说，寻、伺唯与意识相应，因为论上说，寻求和伺察等七种分别，都是意识独俱的不共法。又说：寻、伺与意识的忧、喜相应，不曾说过与五识的苦乐相应。所以知道五识里没有寻、伺。问：若因不说与苦、乐俱，便认为五识没有寻、伺的话，那么，不说与舍受俱，难道说寻、伺也不与舍受相应吗？答：舍受俱遍一切，故不待言，苦乐不遍，何缘不说与苦乐俱呢？既然不说与苦乐俱，当知五识定无寻、伺。问：有寻有伺地的初禅有乐，地狱有苦，岂不是五识有寻、伺吗？答：虽初禅有乐，但那是属于意地的乐。乐不离喜，总说为喜。虽地狱有苦，那也是属于意地的苦。苦、忧相似，总说为忧。所以五识没有寻伺。

    论上又说：寻、伺，是以名身、句身、文身所诠的义理，做它们的所缘，并不是五识以名身等义为所缘境。所以五识定无寻伺。论上虽然说五识有寻伺，但那是显示寻伺多分由五识引起，并不是说与五识相应。《杂集论》上所说的任运分别，与《瑜伽论》所说的七分别意义不同：《杂集论》所说的任运，就是五识；《瑜伽论》所说的七分别，是五俱意识的相应寻伺。所以他所引用的论证，是不能成立的。因此，五识决定没有寻伺。

    论文十：有义：恶作，忧舍相应，唯戚行转，通无记故。睡眠忧喜、舍受俱起，行通欢、戚中容转故。寻伺，忧喜舍乐相应，初静虑中意乐俱故。有义：此四亦苦受俱，纯苦趣中意苦俱故。

    讲解：这是第四诸受相应门。此有两家异说，第一家说，恶作是与忧、舍二受相应。因为恶作多属于忧戚，所以与忧相应，亦通无记，所以又与舍受相应。睡眠是与忧、喜、舍三受相应。因为睡眠的行相通于喜、忧、中容三种境界，故与舍俱。寻、伺与忧、喜、舍、乐四受相应。五识无寻、伺，何以与乐相应？那是因为初禅中有意地乐，非关五识。第二家说：这悔、眠、寻、伺四法，只与苦受相应，因为在地狱的纯苦趣中，有意地苦俱之故。

    论文十一：四皆容与五别境俱，行相所缘不相违故。

    讲解：这是第五的别境相应门。悔、眠、寻、伺四法，和五别境心所都可以俱起。因其能缘的行相，和所缘的境界都不相违。

    论文十二：悔、眠但与十善容俱，此唯在欲，无轻安故。寻、伺容与十一善俱。初静虑中轻安俱故。

    讲解：这是第六的信等相应门。悔、眠二法，但同信等十种善心所相应。因为悔、眠属欲界有情，在十一善法里没有轻安。寻、伺二法和十一种善心所全部相应。因为有寻有伺的初禅中也有轻安。

    论文十三：悔俱容与无明相应，此行相粗，贪等细故。睡眠、寻、伺，十烦恼俱，此彼展转，不相违故。

    讲解：这是第七的烦恼相应门。悔和无明可以相应，和其余九种烦恼不相应。因为悔的行相粗，贪等九法行相微细，粗细不能相应。睡眠、寻、伺三法，和十种烦恼完全可以相应，因为行相彼此展转，不相违故。

    论文十四：悔与中、大随惑容俱，非忿等十各为主故。睡眠、寻、伺二十容俱，眠等位中皆起彼故。

    讲解：这是第八的随惑相应门。悔，与中二、大八的十种随烦恼容许俱起，因为都是不善摄故。悔与忿等十种小随烦恼则不相应，因为十种小随烦恼，各自为主之故。至于睡眠、寻、伺三法，和二十个随烦恼全部能相应，因为睡眠、寻、伺位中，都能生起二十随惑之故。

    论文十五：此四皆通善等三性，于无记业，亦追悔故。有义：初二唯生得善，行相粗鄙及昧略故。后二亦通加行善摄，闻所成等有寻、伺故。有义：初二亦加行善，闻思位中有悔眠故。后三皆通染净无记，恶作非染，解粗猛故。四无记中悔唯中二，行相粗猛非定果故。眠除第四，非定引生异熟生心，亦得眠故。寻伺除初，彼解微劣，不能寻察名等义故。

    讲解：这是第九的三性相应门。悔、眠、寻、伺四法，都通于善、染、无记三性。于无记业也有追悔。此有二家异说。第一家说：悔、眠唯通生得善，不通加行善（注：任运而生的善法，名生得善。加行方便所得善心，曰加行善）。因为悔和眠的行相粗鄙昧略。寻、伺二法不但通生得善，而且也通加行善。因为由闻、思、修所成的法中，都有寻、伺。第二家说：悔、眠二法，不但通生得善，而且也通加行善，因为闻、思位中，也有悔、眠。

    眠、寻、伺三法，都通有覆无记和无覆无记。悔之一法，唯通无覆无记，不通有覆。因为恶作行相粗猛，有覆行相微细。在异熟、威仪、工巧、变化的四种无记中，悔之一法，唯通威仪无记和工巧无记两种。因为悔的行相粗猛，故不通异熟无记；不是定果，也不通变化无记。眠则通于异熟、威仪、工巧三种无记，因为不是定果所引生，所以不通变化无记；寻、伺二法，通于威仪、工巧、变化三种无记，因为异熟心的行相微劣，不能寻求伺察名、句、文等的诠义，所以不通异熟无记。（注：四无记，为无覆无记又分为四种，称为四无记，一者异熟无记，依前世业因得现世果报。二者威仪芜记，行、住、坐、卧等威仪时之心无记性。三者工巧无记。作图画、雕刻等种种工巧时之心无记性。四者变北无记，以神通力作种种变化时之心无记性。）

    论文十六：恶作睡眠，唯欲界有，寻伺在欲及初静虑。余界地法，皆妙静故。悔眠生上，必不现起。寻伺上下，亦起下上。下上寻伺，能缘上下。有义：悔眠不能缘上。行相粗近，极昧略故。有义：此二亦缘上境，有邪见者悔修定故，梦能普缘所更事故。

    讲解：这是第十的界系现缘门。恶作和睡眠，唯欲界才有。寻、伺二法，在欲界及色界的初禅也有。因为初禅以上的界地都是妙静，而悔、眠、寻、伺非妙静故。

    悔、眠二法，生到上地必定不会现起。因为悔、眠唯欲界有，不是上地的所有法。寻、伺二法，通于欲界和初禅，所以上下都可以现起。欲界的寻、伺能缘初禅，而初禅的寻、伺也能下缘欲界，此有两家不同解说：第一家说：悔、眠不能缘上。因为悔的行相粗近，眠的行相昧略之故。第二家说：悔、眠也能缘上，例如因邪见修定而生天的人，死后悔于修定，是悔能缘上；从上地下生欲界的人，在睡梦中能够普缘其所更的上地境界，是眠能缘上地。

    论文十七：悔非无学，离欲舍故。睡眠寻伺，皆通三种。求解脱者，有为善法，皆名学故。学究竟者，有为善法皆无学故。

    讲解：这是第十一的学等相摄门。悔，不是无学位所摄，因为三果阿那舍就已离开了欲界，而舍弃了悔。因为寻求解脱者的有为善法，都称为有学故，修学达到究竟位者，其有为善法都是无学。

    论文十八：悔眠，唯通见修所断，亦邪见等势力起故。非无漏道亲所引生故。亦非如忧，深求解脱故。苦已断故名非所断。则无学眠，非所断摄。寻伺虽非真无漏道，而能引彼，从彼引生，故通见修，非所断摄。有义：寻、伺非所断者，于五法中，唯分别摄。瑜伽说彼是分别故。有义：此二亦正智摄。说正思惟是无漏故。彼能令心寻求等故。又说彼是言说因故，未究竟位，于药病等未能遍知，后得智中，为他说法必假寻伺。非如佛地无功用说，故此二种亦通无漏。虽说寻伺必是分别，而不定说唯属第三，后得正智中，亦有分别故。余门准上如理应思。

    讲解：这是第十二的三断摄门。悔、眠二法，唯通见道及修道所断，不通非断。若是邪见引生者，属见道断，若是有漏善力引起者，是修道断。因为睡眠不是无漏道亲所引生，恶作也不像忧根一样的深求解脱，所以不通非所断。在已断二惑的无学位，一切有漏，都叫做非所断，所以无学位的睡眠，也是非所断摄。

    寻、伺二法，虽非无分别智的真无漏道，而能于寻、伺的加行引生无漏，所以通见、修二断。若是从彼无漏所引生的寻、伺，那就通非所断了。此下有两家不同解释：第一家说，非所断的寻、伺，在相、名、分别、正智、如如的五法中，唯属分别所摄。因为《瑜伽论》上说：‘寻、伺，就是分别’。第二家说，这非所断的寻、伺二法，也是有为无漏的正智所摄。因为《显扬论》等上说：正思惟就是无漏，他能令心寻求。又说，正思惟是言说之因。在未到究竟佛地的二乘无学，及十地菩萨，众生的病苦及能给的法药，未能一一遍知。因此，从后得智中为众生说法的时候，必须假藉寻、伺，这与佛地不假寻、伺的无功用说法不同。所以寻、伺二法，亦通无漏。论上虽说寻、伺必是分别，但不一定就是指五法中的分别，因为后得的正智中也有分别。

    以上十二门分别说毕，此外还有余门分别，准如上说道理比类推知。

    论文十九：如是六位诸心所法，为离心体有别自性？为即是心分位差别？设尔何失？二俱有过，若离心体有别自性，如何圣教说唯有识？又如何说心远独行？染净由心，士夫六界？庄严论说，复云何通？如彼颂言：许心似二现，如是似贪等，或似于信等，无别染善法。若即是心分位差别，如何圣教说心相应？他性相应，非自性故。又如何说心与心所俱时而起，如日与光？瑜伽论说复云何通？彼说心所非即心故。如彼颂言：五种性不成，分位差过失，因缘无别故，与圣教相违。

    讲解：外人问曰，照你的说法，以上六位心所有法，是离开八识心王别有自体呢？还是心王上分出来的六位差别？论主反问：如果是这样，有什么过失呢？外人难曰：两种都有过失，一、假使离心别有自体，如何圣教说唯有识，而不说唯有心所呢？又如何说：心远独行，染净由心，士夫为地、水、火、风、空、识六界所成，而不说：心所远行，染净由心所，士夫为心所所成呢？还有《庄严论》上的颂文说：‘许心有二现，如是似贪等，或似于信等，无别染善法。’这分明就是说：由一心变现似见、相二分，复由见、相二分变似贪等染法；或似善等的净法，都不是离心别有自体的心所。

    二、如果六位心所就是心王的分位，如何圣教上说心所与心王相应呢？既说相应，当然是两个东西，并不是自体和自体相应啊。又如何说：心王和心所好像日与光俱时而起呢？还有《瑜伽论》上所说：心所法并非就是心王，其颂文说：‘五种性不成，分位差过失，因缘无别故，与圣教相违。’意思是说：如果离开心王之外没有别的心所，那五蕴的体性就不能成立了。因为受、想、行，就是心所。若说五蕴是一心前后的分位差别，那也有两种过失：一则没有使一心分位差别的因缘；二则与圣教相违。

    论文二十：应说离心有别自性，以心胜故说唯识等，心所依心势力生故，说似彼现，非彼即心。又识心言亦摄心所，恒相应故。唯识等言及现似彼皆无有失。此依世俗。若依胜义，心所与心，非离非即，诸识相望应知亦然。是为大乘真俗妙理。

    讲解：这是对上文离心之外，有心所、无心所的两种解答。正确的说，六位心所，离开心王之外，各有各的自体。不过心王功用殊胜，为依的功用胜于心所，所以才说唯识；而心所是依于心王的势力而生起，所以说似心王所现。并不是说心所的体性就是心王。又，凡是说到识心，也摄心所在内，因为心所与心恒常相应。因此无论说唯识、说似彼现，都没有过失。

    以上是依世俗而说，若依胜义而说，心所和心王是‘非离非即’，八识之间，彼此相望，应知也是如此，不可定说是一、是异。这就是大乘真、俗二谛的妙理。


第七章　所依门．俱不俱转门

    第七章　所依门．俱不俱转门

    论文一：已说六识心所相应，云何应知现起分位？颂曰：依止根本识，五识随缘现，或俱或不俱，如波涛依水。意识常现起，除生无想天，及无心二定，睡眠与闷绝。

    讲解：在了境能变识的心所相应讲完之后，现在要讲前六识的现起和分位。三十颂的八句颂文，即是俱显三门：第一颂的前一句，是‘六识所依’门；后三句，是‘六识俱转’门；第二颂，是‘起灭分位’门。向下依论文详释。

    论文二：论曰：根本识者，阿陀那识，染净诸识生根本故。依止者，谓前六转识，以根本识为共亲依。

    讲解：现在先释‘六识所依门’。什么叫做根本识，就是第八阿陀那识，为染净诸识依止而生的根本，所以名叫根本识。什么叫做依止？就是前六转识，以根本现行识为共同依止，以种子识为各别亲依。

    论文三：五识者，谓前五转识，种类相似，故总言之。随缘现言显非常起，缘谓作意、根、境等缘。谓五识身，内依本识，外随作意、五根、境等众缘和合，方得现前。由此或俱不俱起，外缘合者有顿、渐故。如水波涛，现缘多少。此等法喻，广说如经。

    讲解：五识就是眼、耳、鼻、舌、身前五转识，因为它们俱依色根、俱缘现境、俱有间断，所以总称前五识。这前五识是随著缘俱而现起，以眼识为例，眼识现起要俱备九种缘，就是：一根缘、二境缘、三作意缘、四空缘、五明缘、六分别依缘的第六识、七染净依缘的第七识、八根本依缘的第八识、九因缘依缘的种子。耳识生起不需要光明，只需种八缘；鼻、舌、身三识不要明缘，也不需空缘，只需要七都缘，因缘俱足，识就生起。因为各识的外缘和合有顿、渐之故，所以五识或俱起，或不俱起，都不一定。就好像水的波涛，随著风缘来决定波涛的多少一样，风大则波涛多，风小则波涛少。这是以水喻本识，波涛喻众缘。


第八章　起灭分位门

    第八章　起灭分位门

    论文一：由五转识，行相粗动，所藉众缘，时多不具，故起时少不起时多。第六意识虽亦粗动，而所藉缘无时不具，由违缘故，有时不起。第七八识行相微细，所藉众缘一切时有，故无缘碍令总不行。又，五识身不能思虑，唯外门转，起藉多缘，故断时多，现行时少。第六意识自能思虑，内外门转，不藉多缘，唯除五位常能现起，故断时少，现起时多，由斯不说此随缘现。

    讲解：此下是解释第二颂的‘起灭分位门’。因为五转识的行相粗显浮动，其所藉以现起的众缘，又多不具足，所以现起时少，不起时多。第六意识虽亦粗动，而其所藉的缘比较少，所以容易现起。不过若在无想天等五无心位的情况下，也有不起的时候。第七识和第八识的行相微细，他们所藉的众缘一切时都有。所以除第七识在无漏及灭尽定时，染的一分不现起外，没有任何违缘能使之不现起。

    又、前五识，因为没有寻伺，不能思虑，唯缘外境，不缘内种，必须藉著很多的缘才能生起，所以它们间断时多，现行时少。第六意识自己能够思虑，内外并缘，不须要假藉根境等的众缘，但除五位无心外便常现行，所以间断时少，现起时多。因此，颂中不说意识随缘现，但说常现起。

    论文二：五位者何？生无想等。无想天者，谓修彼定，厌粗想力，生彼天中，违不恒行心及心所，想灭为首名无想天。故六转识于彼皆灭。

    讲解：五位是什么呢？就是生无想天等。什么叫做无想天？就是修无想定的外道，他们认为前六识的粗想是生死之因，所以要厌离，死后生到第四禅的无想天中，前六识在无想天中全都灭掉，不起现行。

    论文三：有义：彼天常无六识，圣教说彼无转识故，说彼唯有有色支故，又说彼为无心地故。有义：彼天将命终位，要起转识，然后命终。彼必起下润生爱故，瑜伽论说后想生已，是诸有情，从彼没故。然说彼无转识等者，依长时说，非谓全无。有义：生时亦有转识，彼中有必起润生烦恼故，如余本有初，必有转识故。

    讲解：前六识在无想天是否全灭，有三家不同的说法。第一家说：无想天的天人，从生到死的一期生死中，恒常没有前六识。因为圣教上说彼天没有六转识，唯有色支。又说他是无心地故。第二家说，无想天的天人，到临命终时，还是要先起六转识，然后才死。因为将生下地的天人，一定要起下地的爱，才去润生。所以《瑜伽论》上说：后面的想心再生起之后，这些无想天的有情就要死了。然而何以经论上又说他没有六转识呢？那是依临命终前的一段长时来说的，并不是临命终时也没有。第三家说：不但临命终时要生起意识，就是初生无想天时也有六转识。因为初去投生的中阴身，必定要生起润生的贪爱，和其余有情去投生一样，要有中阴身，有中阴身就有意识。

    论文四：瑜珈论说若生于彼，唯入不起，其想若生，从彼没故。彼本有初，若无转识如何名入？先有后无乃名入故，决择分言，所有生得心、心所灭，名无想故。此言意显彼本有初，有异熟生转识再起，宿因缘力后不复生，由斯引起异熟无记分位差别，说名无想，如善引生二定名善。不尔，转识一切不行，如何可言唯生得灭？故彼初位，转识暂起。彼天唯在第四静虑，下想粗动难可断故，上无无想异熟处故。即能引发，无想定思，能感彼天异熟果故。

    讲解：《瑜伽论》上说，倘若生到无想天，那想心就唯入不起；如果到了想心再起的时候，那就要从无想天命终了。这证明彼天本有的初位，是有六转识。若无六转识，怎么可以叫做‘入’？因为先有后无，才叫做‘入无心’。

    《瑜伽论》的决择分说：要所有生得的心王与心所完全灭了以后，才名叫无想。这句话的意义，是显示彼天本有的初位，有异熟生的六转识报心暂起。因为没有生无想以前，先修无想定，以宿习的因缘力，所以后来意识就不再生起了。由此无想定，引起了无想天异熟无记的报果，就叫他名为‘无想’。如善心引生的无想定和灭尽定，名为善定。不然的话，如果前六识一切不行，那怎可说生到无想天中就没有意识了呢？所以无想天本有的初位，还是有转识暂起，以后才会完全没有。

    无想天的位置在色界第四禅天。为何不在初、二、三禅呢？因为下地的想心粗动，不易灭除；那么何以不在无色界上地呢？那是圣者所居，没有受无想异熟的处所，故不在上，唯有第四禅天，能够引发无想定的思惟，才能感招无想天的异熟报果。

    论文五：及无心二定者，谓无想、灭尽定，俱无六识，故名无心。无想定者，谓有异生，伏遍净贪，未伏上染。由出离想作意为先，令不恒行心、心所灭。想灭为首，立无想名，令身安和，故亦名定。修习此定，品别有三，下品修者现法必退，不能速疾还引现前。后生彼天不甚光净，形色广大，定当中夭。中品修者现不必退，设退速疾还引现前，后生彼天虽甚光净，形色广大而不最极。虽有中夭而不决定。上品修者现必不退。后生彼天最极光净，形色广大，必不中夭，穷满寿量后方殒没。此定唯属第四静虑，又唯是善，彼所引故。下上地无，由前说故。四业通三，除顺现受。有义，此定唯欲界起，由诸外道说力起故，人中慧解极猛利故。有义：欲界先修习已，后生色界，能引现前。除无想天至究竟故。此由厌想欣彼果入，故唯有漏，非圣所起。

    讲解：以上讲的是无想天，往下讲无想定和灭尽定。因为这两种定都没有前六识，所以又叫做无心定。于此先说无想定：就是有一类凡夫，虽然已伏住色界第三禅天的贪烦恼，而第四禅以上的烦恼还没有伏灭，因此在他用功的时候，作意要离去这个想，久而久之，把不恒常现行的前六识心、心所法统统灭除。因为是以想灭为首，所以名为无想；又能令身平安和悦，所以亦名为定。

    修习这种无想定，有下、中、上三品之别：下品修者，所得的现法禅味必定还要退失。退失之后，就不能很快的再引生现前。死后纵能生到无想天去，也不会怎样的光明清净，形相虽然高大，决定活不到五百劫就得中途夭亡。中品修者，现法不必一定退失。设或退失，很快的就会恢复现前。死后生到无想天，虽然很光明清净，形相广大，而其光净广大的程度，还达不到顶点。不过虽也有中途夭亡的，但那不是决定性的非夭亡不可。上品修者，现法必定不退。死后生到无想天中，最极光明清净，形相也最极广大，必不至于短命夭亡，一直活到五百劫的寿数满了才会死亡。

    这无想定，唯系属于第四禅天，也唯是善法所摄，因为它是由善定所引生的。除第四禅外，上下地都无此定，因为下地的想心粗动，上地无色有心，这在前面都已说过了。此天在四业中(注：四业，一者顺现受业，二者顺生受业，三者顺后受业，四者不定受业)只有来世受天报，或是二生及多生受天报，决无现生生天的可能。所以说：‘四业通三，除顺现受’。

    至于无想定在那一界才可以生起呢？此有两家不同说法。第一家说：唯欲界起。因为这无想定，是起于外道说法之力，因其智慧和理解力比余趣众生来得殊胜，所以在修时能把想心压伏下去。第二家说：并非唯欲界起，而是先在欲界修习此定，死后生到色界第四禅的广果、福生、无云三地，由于欲界宿习定力，还能引发此定现前。但要生到无想天，那就受这种定的果报了。无想定是由于厌恶想，希望生于无想天，所以它是有漏的，佛教圣人不修此定。

    论文六：灭尽定者，谓有无学，或有学圣，已伏或离无所有贪，上贪不定，出止息想作意为先。令不恒行，恒行染污心、心所减，立灭尽名。令身安和，故亦名定。由偏厌受想，亦名减彼定。修习此定品别有三：下品修者现法必退，不能速疾还引现前。中品修者现不必退，设退速疾还引现前。上品修者毕竟不退。此定初修，必依有顶游观无漏为加行入，次第定中，最居后故，虽属有顶而无漏摄。若修此定已得自在，余地心后亦得现前。虽属道谛，而是非学非无学摄，似涅槃故。此定初起唯在人中，佛及弟子说力起故，人中慧解极猛利故。后上二界亦得现前。邬陀夷经是此诚证，无色亦名意成天故。于藏识教未信受者，若生无色不起此定，恐无色心成断减故。已信生彼亦得现前，知有藏识不断灭故。

    讲解：什么叫做灭尽定？就是四果无学，或除初、二果外，唯证不还果的有学圣者，他们虽对无色界无所有处的贪或已暂伏，或已永离，而于上地非非想处的贪，还不一定能够伏断。因此，先由止息想心的作意起修，使不恒行的前六识，和恒行的第七识染污末那等心、心所法，全都灭掉，依此建立灭尽的名称；又能令身安和，所以亦名为定。又因偏重于厌离受、想，所以也叫做灭受想定。

    修习灭尽定，也分下、中、上三品，下品修习的人，现生修法的时候，必定还要退失，一退失就不能很快恢复现前。中品修习的人，现法不必一定退失，假使退失，很快的能重引现前。上品修习的人，那就毕竟不会退失了。初修减尽定时，必须依无色界最高有顶的非想非非想天，游观（正思惟）无漏为加行，才能进入此定。因为在次第禅定中，减尽定是居于最后最高的定，其余的下地心粗，不能作此微细的行相。虽属有顶，而为出世的无漏所摄。

    行者若能够修习此定，身心已得安然自在，那就在余下的七地心后，也可以超入此定，使之现前。灭尽定虽属道谛，起于有学和无学，则是非有学、非无学所摄。因为此定与涅乐相似，他没有未入定前进趣止息的行相，所以不是有学所摄；但也不是真入涅乐，所以也不是无学所摄。此定的最初起因，唯在人间，因为是佛及佛弟子，在人间说教之力所引起，而人的慧解较其他五道猛利得多。修成功了之后，在色界和无色界中，此定也得现前，这在《邬陀夷经》上可以证明。经上说：‘超段食，随受一处意成天身，便能出入此定’。无色界也是超越段食，唯有意思存在的‘意成天’，所以无色界人，也可以入灭尽定。

    不过生到无色界的人，不一定都能入灭尽定，要看他们对第八藏识是否信受而作决定。不信有阿赖耶识而生无色界的人，不能入灭尽定。因为他们恐怕一入此定，没有色、心，就成断灭了。信有阿赖耶识而生无界色的人，灭尽定亦可现前，因为他们知道有阿赖耶识的存在，虽然色身和转识都没有了，但也不会断灭的。

    论文七：要断三界见所断惑，方起此定。异生不能伏断有顶心、心所故，此定微妙要证二空，随应后得所引发故。有义：下八地修所断惑中，要全断欲，余伏或断，然后方能初起此定。欲界惑种，二性繁杂障定强故。唯说不还，三乘无学及诸菩萨得此定故，彼随所应生上八地，皆得后起。有义：要断下之四地修所断惑，余伏或断，然后方能初起此定。变异受俱烦恼种子障定强故，随彼所应生上五地，皆得后起。若伏下惑，能起此定，后不断退生上地者，岂生上已却断下惑？断亦无失。如生上者，断下末那俱生惑故。然不还者对治力强，正润生位不起烦恼，但由惑种润上地生。虽所伏惑有退不退，而无伏下生上地义，故无生上却断下失。

    讲解：生起灭尽定的条件，是要把三界见道所断的烦恼断了之后，才能起此灭尽定。因为未断见惑的凡夫，不能伏断有顶天非非想地的心、心所法。这灭尽定的力用，微妙殊胜，要证到了我、法二空的根本智，然后随应生起后得智，才能引起灭尽定。这是讲见所断惑：至于修所断惑，有两家不同的异说。第一家说：在三界九地中，欲界一地的烦恼要全都断尽，其余初禅以上七地的烦恼，或伏、或断，才能生起此定。为什么欲界的烦恼要完全断了，才能生起此定呢？因为欲界的烦恼种子，有不善和有覆无记二性，繁复杂乱，障定的力量太强，所以只有三果的阿那含，和三乘无学，及诸菩萨，这五种人才能得此减定。他们各随其断惑功力的所应，从欲界生到上八地，都可以后起此定。第二家说：不但断欲界烦恼，要连色界的初、二、三禅一齐都断尽了，其余第四禅以上五地，或伏、或断，然后才能初起此定。因为初、二、三禅中有喜、乐等受的变异，同这变异受俱起的烦恼种子，障定的力量太强，所以要四地都断。随其所应，生到四禅以上五地，都可以后起此定。

    有问曰：若照你上面所说，伏了下地烦恼也能够起此定，不必完全断了下地的烦恼，那么因为末断烦恼种子而又退失，这样生到非非想地的人，岂不是要在上地再断下地烦恼吗？答曰：纵使生到上地而断下地烦恼，也没有什么过失。这也像生上地的圣者，以金刚心来断下地第七末那的俱生烦恼一样。然而不还果对治烦恼的力量很强，他在命终正润生时，不起现行烦恼，但由烦恼种子，润上地生。这样不管所伏的烦恼退与不退，反正还有烦恼种子去润上地生，便没有伏下地惑，生上地的意义了。既没有伏下地惑生上地的意义，当然也没有生到上地再断下地惑的过失了。

    论文八：若诸菩萨，先二乘位己得灭定，后回心者，一切位中能起此定。若不尔者，或有乃至七地满心，方能永伏一切烦恼。虽未永断欲界修惑，而如已断能起此定。论说已入远地菩萨，方能现起灭尽定故。有从初地，即能永伏一切烦恼，如阿罗汉，彼十地中皆起此定。经说菩萨，前六地中，亦能现起灭尽定故。

    讲解：上面讲的是二乘，现在来讲菩萨。若有菩萨，先在二乘位时，已经得了减尽定，到后来又回心趋向大乘，这类菩萨在一切地中都能起此灭定。如果不是由小向大，而是一发心就直入大乘的顿悟菩萨，那就不一定了，那要从初地以后，一地一地的渐次伏除诸烦恼障，一直到七地满心时，才能永伏三界一切烦恼。虽然还没有永断欲界修道所断的烦恼，但同已断修惑一样的能起此定。《显扬论》上说，已经进入第七远行地的菩萨，也能现起此定。若是顿悟菩萨，从初地时就能永远伏一切烦恼，同四果的阿罗汉一样，从初地到十地，都能够生起此定。所以经上说，菩萨不但七地以上，就是在前六地中，也能现起此灭尽定。

    论文九：无心睡眠与闷绝者，谓有极重睡眠闷绝，令前六识皆不现行。疲极等缘，所引身位，违前六识，故名极重睡眠。此睡眠时虽无彼体，而由彼似彼，故假说彼名。风、热等缘所引身位，亦违六识，故名极重闷绝。或此，俱是触处少分。

    讲解：五位无心的无想天、无想定、灭尽定已经讲解如上，此下讲解睡眠与闷绝二位。也就是在极重的睡眠和闷绝时，前六识都不起现行。什么叫做极重睡眠呢？就是由极度疲倦及其他等缘，所引起的沉重无心的身位，使前六识不起现行。这无心睡眠的时候，虽然没有眠体，而由彼眠所引起的沉重无心等相，却似有彼眠。所以假说这身的分位，叫做睡眠。什么叫做极重闷绝呢？就是由风、热等缘，所引起的身位，也违前六识，所以叫做极重闷绝。或者，这睡眠、闷绝，有有心、无心之别。无心位的睡眠闷绝，虽不觉有触，却是由有心位的疲倦、风、热等的触缘所引生。所以这无心的睡眠闷绝，都是触处的少分。

    论文十：除斯五位，意识恒起。正死生时亦无意识，何故但说五位不行。有义：死生及与言显。彼说非理，所以者何？但说六时名无心故，谓前五位及无余依。应说死生即闷绝摄，彼是最极闷绝位故。说及与言，显五无杂。此显六识断已，后时依本识中自种还起，由此不说入无余依。此五位中，异生有四，除在减定。圣唯后三，于中如来，自在菩萨，唯得存一，无睡闷故。

    讲解：除了这五位无心以外，第六意识都是恒常现起。问：有情正在正受生时，和正舍寿时，也没有意识。何以但说五位无心的意识不起现行呢？此有两家不同解答。第一家说：生死位虽然也没有意识，但颂文中的‘及’、‘与’二字，就是显示除五位之外，还有死生二位，共有七位意识不行。并不是但说五位无心。

    第二家反驳说，此说不对，因为经论上但说有六个时候名叫无心，就是前面所说的五位，再加一个二乘的无余依涅槃。因此，应当说生死二时，是五位中的闷绝所摄。因为生死苦逼，是最极闷绝之故。至于及、与二字，那是显示无心位只有前面五种，不再参加其余的在内。

    问：经论上既然说六位没有意识，为什么颂中但说五位无心，而不说入无余依涅槃呢？答：因为这五位无心，是显示意识虽已不行，但后来依托藏识里的意识种子，还是照常要生起现行。而入无余依涅槃，是显示意识永不复生。因此，但说五位，不说入无余依。

    这五位中，凡夫具有四位，除减尽定。三乘圣人唯有后三位，没有无想天及无想定。至于如来及八地以上的自在菩萨，唯有灭尽定一位，而没有睡眠和闷绝。


第九章　综合分别八识

    第九章　综合分别八识

    论文一：是故八识，一切有情，心与末那二恒俱转，若起第六则三俱转，余随缘合。起一至五，则四俱转，乃至八俱，是谓略说识俱转义。

    讲解：以上已把三能变的八个识讲完。此下是综合分别八识。依照上面种种的说法看来，一切有情八识的转起，第八阿赖耶识，和第七末那识，是恒时俱转的。若再生第六意识，那就是第八、第七、第六，三个识同时俱转。其余的前五识，若再随缘生起一识，那就是和第八、第七、第六，和前五识的一识，四个识同时俱转。倘若前五识一齐生起，那就是八个识同时俱转了。这不过是把八识俱转的意义，略说一下而已。

    论文二：若一有情多识俱转，如何说彼是一有情？若立有情，依识多少，汝无心位，应非有情。又、他分心现在前位，如何可说自分有情？然立有情依命根数或异熟识，俱不违理。彼俱恒时唯有一故。

    讲解：这一段论文，是以外人五次问难，论主五次答辩，来分别八识俱起的问题。

    问一：假设一个有情，有几个识同时俱转，那如何说他是一个有情呢？

    答：假使照你这样说，有情是依识的多少而建立的，那么，入无心定等的人，就应该不是有情了。再者，如欲界有情，现起上界的无漏心时，如何可以说他是欲界有情？可见有情并不是依识的多少来建立的。然而，建立有情，或依第八识种子假立的命根，或依第八识现行实法的异熟，都不违理。因为命根和异熟，无论在有心或无心位的一切时，都只有一个，不会有多识和无识的过失。

    论文三：一身唯一等无间缘，如何俱时有多识转？既许此一引多心所，宁不许此能引多心？又谁定言此缘唯一？说多识俱者，许亦缘多故。又、欲一时取多境者，多境现前宁不顿取，诸根境等和合力齐，识前后生不应理故。又心所性，虽无差别，而类别者，许多俱生，宁不许心异类俱起？又如浪像依一起多，故依一心，多识俱转。又、若不许意与五俱，取彼所缘应不明了，如散意识缘久灭故。

    讲解：问二：一个有情，只有一个等无间缘，怎可在同一时间有多识转起呢？

    答：你们小乘既然赞成一个等无间缘，能够引生后念许多善、恶心所生起，怎么又不赞成一个等无间缘，能引后念许多异类的后心同起呢？其实这不过是方便的说，并非大乘正义。正确的说，每个识各各都有等无间缘，那一个说等无间缘只限定一个呢？识既是多，而等无间缘也应随识而有。并不是一个等无间缘，来引生多识。

    再者，在同一时间，为什么会有多识同起呢？这是因为外境多的原故。当色、声、香、味、触、法六境既已现前，岂能不同起六识去顿取六境呢？这是因为一切根、境、空、明等缘和合的势力相齐之故，所以才有多识俱起。至于说诸识必要前后次第生起，那是不合理的。

    又，同是一类遍行、别境等心所的体性，虽然没有差别，而受、想、思等的功能还是各别不同。你既然允许这些不同的心所一念俱生，为什么不允许眼、耳等识的异类心王一念俱起呢？

    再者，譬如一个瀑流，遇到许多风缘，同时就起多浪；再如一面大镜，通缘同时能现的许多境像。以此喻彼，所以一个第八根本识心，遇到了许多境界的缘，也会有多识同时转起。

    还有，假使你们不许第六意识和五识同起，那五识取其所缘的境时，就应当不会明了，好像以散位意识，去缘那灭了很久的境界一样。

    论文四：如何五俱唯一意识，于色等境，取一或多？如眼等识，各于自境，取一或多，此亦何失？相、见俱有种种相故。何故诸识同类不俱？于自所缘，若可了者，一已能了，余无用故。若尔，五识已了自境，何用俱起意识了为？五俱意识，助五令起，非专为了五识所缘。又，于彼所缘能明了取，异于眼等识，故非无用。由此圣教说彼意识各有分别，五识不尔。多识俱转，何不相应？非同境故，设同境者，彼此所依，体数异故。如五根识互不相应。

    讲解：问三：为什么一个意识与五识俱起，而能取色、声、香等多境？

    答：例如眼识，能取青色，同时也能取黄、赤、白等色；乃至一个身识，能取一种坚的触境，同时亦能取湿、暖、等多种触境。以此为例，这一个五俱意识，能取色等多种境界，又有什么过失呢？因为诸识都有相、见二分，见分有种种能见相，相分有种种所见相，所以一识能取多境。

    间四：为什么诸识中自类相同的识，不能一时同起取境呢？(这意思是说：何以没有两个以上的眼识，乃至两个以上的身识同时俱起取境？)

    答：诸识对各自所缘的境，如果可以明了，一个识也就够了。假使不能明了，就是有同类俱起，又有何用？

    外人再难：这样说来，前五识既然各各能了别自己的境界，何必还用五俱意识帮忙？

    答：五俱意识的责任，是帮助五识令之生起，并不是专为明了五识的所缘境。又，意识对于所缘，能明了分别，深取境相，与眼等五识的作用不同，所以五俱意识，并非无用。因此，经论上但说第六意识名为分别识，不说五识名分别识。

    间五：多识同起，为什么不相应呢？

    答：因为各识不同境，所以不相应。如果是同境的话，例如眼识的心王，和眼识的心所，它们同依一眼根，同缘一色境，所以可以相应。至于前五识的根、境都不同，所以互不相应。

    论文五：八识自性，不可言定一。行相、所依、缘、相应异故。又一灭时余不灭故，能、所熏等相各异故。亦非定异，经说八识如水波等，无差别故，定异应非因果性故，如幻事等无定性故。如前所说识差别相，依理世俗，非真胜义，真胜义中心言绝故。如伽陀说：心意识八种，俗故相有别，真故相无别，相所相无故。

    讲解：八个识的自体，不可定说是一。因为八识的行相，与所依的根，所缘的境，以及相应的心所，都各各不同。当一个识灭的时候，其余七识，依然不灭。况且，前七识是能熏，第八识是所熏，它们的行相，也是各各不同，所以不可定说是一。但也不可定说是异，因为经上说：八识好像水和波浪一样，水、波并无差别，假定是异，八个识就应当不是互为因果的关系了。

    照前面所说，八个识各各都有差别的体相，这是依照四种世俗谛中，第二的道理世俗谛来说的，并不是四种胜义谛中的真胜义谛。真胜义谛，言语道断，心行路绝，那有什么一异可说？所以《楞伽经》中的颂文说：‘心意识八种，俗故相有别，真故相无别，相所相无故。’此颂的意思是说：积起的第八识（心）、思量的第七识（意）、了别的前六识（识），这八种识，以道理世俗谛而论，可以说是有差别相；若以真胜义谛而论，那就没有差别相了。因为用是能相，体是所相；能所二相，在离心言相的真胜义中，俱不可得。


第一章 正辩唯识

    第五篇 广释所变 释违理难 释违教难 唯识实性

    （颂文第十七颂至第二十五颂）

    第一章 正辩唯识

    论文一：已广分别三能变相，为自所变二分所依。云何应知依识所变假说我法，非别实有，由斯一切唯有识耶？颂曰：是诸识所变，分别所分别，由此彼皆无，故一切唯识。

    讲解：前面已把三能变相的八个识，和八识自体，以及见、相二分为自体所变，自体为见、相二分所依，都详细的讲过了。然而怎样知道依识所变的假我假法，不是另外实有的东西呢？三十颂的颂文答曰：‘是诸识所变，分别所分别，由此彼皆无，故一切唯识。’意思是说：世间万法，都是由八识的自体分，转变出来能分别的见分，和所分别的相分。由此见、相二分的原故，而有所谓宇宙人生。由此可知，所谓我相、法相，都是假有不实，因为这一切都是睢识所变的。

    论文二：论曰：是诸识者，谓前所说，三能爱识及彼心所，皆能变似见、相二分，立转变名。所变见分说名分别，能取相故；所变相分名所分别，见所取故。由此正理，彼实我法离识所变，皆定非有，离能所取无别物故。非有实物离二相故。是故一切有为、无为，若实若假，皆不离识。唯言为遮离识实物，非不离识心所法等。

    讲解：论上说：是诸识这句话，就是前面所说的三能变识及其心所有法。都能变似见分和相分，所以安立转变之名。所变的见分名叫‘分别’，因为它能执取相分；所变的相分名叫‘所分别’。因为它是被见分所执取的境相。由于这种正理，我人所执的实我、实法，离开了识所变的见、相二分，决定都不存在。

    因为离开了能取的见分和所取的相分，就没有别的东西存在了。并不是有个实在的东西能够离识而有。因此，世间万法，无论是有为、无为、若实、若假，都不能离识而别有。‘唯’字是遮除离能变识外的实有我、法，所以名叫‘唯识’：并不是连不离识的心所，和无为真如等法都遮除了，才名叫唯识。

    论文三：或转变者，谓诸内识转似我法，外境相现。此能转变即名分别，虚妄分别为自性故。谓即三界心及心所。此所执境，名所分别，即所妄执实我法性。由此分别，变似外境假我法相。彼所分别，实我法性决定皆无，前引教理已广破故。是故一切皆唯有识。虚妄分别有极成故。唯既不遮不离识法，故真空等亦是有性。由斯远离增减二边，唯识义成，契会中道。

    讲解：这是另一种解释。转变，就是由三能变的内识，转变出但有我、法的外境显现，这能转变的识就称为‘分别’，因为它是以虚妄分别为其性，这就是三界有情的心与心所。这所执的境就称为‘所分别’，也就是遍计所执的实我实法。由于这分别之心，变似依他相分假我、假法之相，这种遍计所执所分别的实我实法之性，决定都不存在，这在前面引教为证己详破斥。因此，一切有为、无为、假、实等法，都是唯识虚妄分别的至极成就。

    外人问：若一切唯识，那二空真如及心所法等，既不是能分别的内识，又不是所分别的外境，他们的自体是有呢还是没有？答曰：唯识的‘唯’字，既然不遮不离识的法。那不离识的真如，及心所等法，当然有体。所以远离了增、减二边见，成立了契会中道的唯识正义。


第二章 问答辩难

    第二章 问答辩难

    论文一：由何教理，唯识义成？岂不己说？虽说未了，非破他义己义便成。应更确陈成此教理。如契经说三界唯心，又说所缘唯识所现，又说诸法皆不离心，又说有情随心垢净，又说成就四智，菩萨能随悟入唯识无境。

    讲解：以下外人有九种问难，这是第一问难的‘唯识所因难’。

    外人难曰：由什么教理来成立唯识之义呢？论主答曰：我们前面不是已经说过了吗？何劳重说。外人称：前文虽已略说，但对专显唯识之义未说明白，大抵破他者多，但并不是专破他宗，自家的宗义就算成立，应当再把成立唯识的教理，确实敷陈一番。论主回答：如《华严经》说：‘三界唯心’。《解深密经》说：‘识所缘，唯识所现’。《楞伽经》说：‘诸法皆不离心’。《无垢经》说：‘有情随心垢净’。《阿毗达摩经》又说：‘成就四智的菩萨，便能悟入唯识无境’。

    论文二：一、相违识相智：谓于一处鬼人天等随业差别，所见各异。境若实有，此云何成？二、无所缘识智：谓缘过未梦境像等，非实有境，识现可得，彼境既无，余亦应尔。三、自应无倒智：谓愚夫智若得实境，彼应自然成无颠倒，不由功用，应得解脱。四、随三智转智：一随自在者智转智。谓已证得心自在者，随欲转变，地等皆成。境若实有，如何可变？二随观察者智转智。谓得胜定修法观者，随观一境，众相现前。境若是真，宁随心转？三随无分别智转智。谓起证实无分别智，一切境相皆不现前。境若是实，何容不现？

    讲解：什么叫做四智？第一是相违识相智，相违识相，就是鬼、人、天等共见河水，随其业感的差别，而所见各异。如鬼看见的是脓血，鱼虾等看见的是其宅舍，人看见的是河水，天看见的是璃璃宝地。假使外境实有，所见各异的相违识相如何成立？

    第二是无所缘识智，一切所缘过去、未来，以及梦中的境，镜中的像，都不是实有，不过是唯识所现而已。彼梦中的境，镜中的像既然不是实有，其余的现前境界，当知也不是实有。

    第三是自应无倒智，自应无倒，是菩萨的智慧。如果虚妄颠倒的愚痴凡夫，若能缘得不是虚妄的实境，他应当自然成就无颠倒智，不用修行，就可以解脱生死了。

    第四是随三智转智。这是说菩萨能令虚妄之境，随三种智慧而转变，称为随三智转智。一、随自在者智转智。就是已经证得了心自在的八地以上菩萨，他随心所欲，能把大地河山，转变为金银琉璃，及各种珍宝。可见境非实有，境若实有，那大地河山如何可以转变？二、随观察者智转智。就是得了胜妙禅定并在定中修法观者，他们随观一境，都有无常、苦、空、无我等相现前。如果外境实有，如何能随观察者的心去转变化呢？三、随无分别智转智。意谓菩萨证得无分别智时，一切境相都不现前。可见境不是实，若是实有，怎能使之不现前呢？

    论文三：菩萨成就四智者，于唯识理决定悟入。又伽他说：心意识所缘，皆非离自性，故我说一切，唯有识无余。此等圣教，诚证非一。

    讲解：菩萨成就以上四智，对唯识的道理决定悟入。所以《厚严经》上有颂曰：‘心意识所缘，皆非离自性，故我说一切，唯有识无余’。意思是说；八识的所缘，都不是离开了其自体而别有外境。所以我说一切有为、无为、世、出世法，都唯有识，而没有其余的外境。在经论上，诸如此类的证明很多，非止一颂。

    论文四：极成眼等识，五随一故，如余，不亲缘离自色等。余识识故，如眼识等，亦不亲缘离自诸法。此亲所缘定非离此，二随一故，如彼能缘。所缘法故，如相应法，决定不离心及心所。此等正理诚证非一，故于唯识，应深信受。

    讲解：眼等五识中的任何一识，和其余的四种识一样，不能直接缘取离自眼识的色等。因为共余的识也是识，和眼识等一样，也不能直接缘取离开自识的各种事物。这种直接所缘，肯定离不开识，相、见二分随一所摄，如彼能缘的见分。因为是所缘法，就如相应法一样，肯定离不开心法和心所法。像这样的正确道理，不只一种，确实能够证明唯识道理，所以对唯识应当深刻相信并接受。

    论文五：我法非有，空识非无。离有离无，故契中道。慈尊依此说二颂言：虚妄分别有，于此二都无，此中唯有空，于彼亦有此。故说一切法，非空非不空，有无及有故，是则契中道。此颂且依染依他说，理实亦有净分依他。

    讲解：心外所计的实我、实法，是不存在的；真如空理和能缘的识不是没有的，这样初离有、后离无，所以符合中道实理。弥勒菩萨依这种道理，说了二首偈颂曰：‘虚妄分别有，于此二都无，此中唯有空，于彼亦有此。故说一切法，非空非不空，有无及有故，是则契中道’。颂文的意思是：‘有情虚妄分别的心是有的，但在这虚妄分别的心里，能、所二取或我、法二相，那是没有的。虚妄分别的心裹，唯有胜义谛的空性；此空性中，也唯有世俗谛的虚妄分别。虚妄分别是有为法，空性是无为法。一切有为、无为，由于二谛有故，所以非空；二取无故，所以非不空。这二谛的有、二取的无、及虚妄分别与真空的互有，并不是一味的说空，也不是一昧的说有，而是分别中有空，空中有分别，就叫做符合中道。’这两首颂，虽然是依染分的依他而说，实际上这种道理亦有净分的依他，这是意在言的外说法。

    论文六：若唯内识似外境起，宁见世间情非情物，处、时、身用，定不定转？如梦境等，应释此疑。

    讲解：这是外人九种问难的第二问难，世事乖宗难。外人问曰：如果唯有内识，无心外之境，何以现见世间，有芸芸众生和无情的东西呢？并且有一定的处所、时间，大家同见，还有境界作用，决定转起，这是什么原因呢？

    论主答曰：好像梦境一样，梦境中也有定处、定时、作用，好像饿鬼一样，因为共报的多身饿鬼，还有别业妄见，他们虽在同一处、时，有的见是脓河，有的见是粪便，总不得食。用不定转，也好像梦境一样。因为梦中有时也有男女失精的作用，有时没有。这如梦等的解释，你应该没有疑惑了吧？

    论文七：何缘世尊尊说十二处？依识所变，非别实有。为人我空，说六二法。如遮断见，说续有情。为入法空，复说唯识，令知外法亦非有故。

    讲解：这是九难的第三，圣教相违难。外人问曰：如果没有心外实有的色法，为什么世尊在《阿含经》中，说有六根、六尘的十二处的教呢？论主答：其实这六根、六尘，仍是依托内识所变现。世尊为了要破众生的我执，证得我空，故说眼等六根和色等六境内外处的教法。也如为遮除断见（外道计众生死后断灭），说有中阴身续于死后一样，都是随宜的方便而说，非许实有。为化导执有实法的众生，证得法空，才又说这唯识之教，使知外法也不是实有。

    论文八：此唯识性，岂不亦空？不尔。如何？非所执故，谓依识变妄执实法，理不可得，说为法空。非无离言正智所证，唯识性故，说为法空。此识若无，便无俗谛，俗谛无故，真谛亦无，真、俗相依而建立故。拨无二谛是恶取空，诸佛说为不可治者。应知诸法有空不空，由此慈尊说前二颂。

    讲解：这是九难的第四，唯识成空难。外人问：若一切法空，这唯识性岂不是也空了吗？论主答曰：不空。怎样不空？答：因为唯识的真如性不是所执的法。也就是说，依内识所变的似有外法，众生妄计为实，然而以理推征，实不可得，所以说是法空，并不是离言正智所证的唯识实性也是没有。如果唯识也没有了，那就没有俗谛。俗谛若无，真谛也就没有了。因为真不自真，待俗而真；俗不自俗，待真而俗；真俗二谛，是互相对待而建立的啊。如果有人拨无二谛，那就是恶取空！诸佛都说，没有法药可以治疗这种人的空病。由此可知，诸法有遍计所执无的空，也有依他圆成实的不空。因此弥勒菩萨，才说出前面那两首颂文。

    论文九：若诸色处，亦识为体，何缘乃似色相显现，一类坚住，相续而转？名言熏习势力起故，与染净法为依处故。谓此若无，应无颠倒，便无杂染，亦无净法，是故诸识亦似色现。如有颂言：乱相及乱体，应许为色识，及与非色识，若无余亦无。

    讲解：这是九难的第五，色相非心难。外人问：色法是有质碍的，识是无质碍的。如果色法也是以识为其本体，为什么在缘境的时候，似有色相显现，前后一类坚住，无有变异亦无间断，多时相续呢？论主答：这是无始以来，名言熏习的势力所生起之故，可以给杂染、清净等法作为依托的处所。如果没有这个依托的处所，也就没有颠倒的迷执，当然也就没有染杂法及清净法。因此诸识缘境，也有似色相的显现。

    这好像《摄大乘论》上的颂文：‘乱相及乱体，应许为色识，及与非色识，若无余亦无。’此颂的意思是说：无论是所变乱相的色相，及能变乱识的心体，都是前面所说的色相和心识；假使没有所变的乱相，也就没有能变的乱识；没有能变的乱识，也就没有其余的乱相。所以，乱相、乱体、能变、所变，都不离识。

    论文十：色等外境，分明现证现量所得，宁拨为无？现量证时不执为外，后意分别妄生外想。故现量境是自相分识所变，故亦说为有。意识所执外实色等，妄计有故，说彼为无。又色等境，非色似色，非外似外，如梦所缘，不可执为是实外色。

    讲解：这是九难的第六，现量违宗难。外人问：色、声、香、味、触五境，分明是五识现证，现量所得，怎可以说是没有呢？论主答：现量证境时，不会执为是外面的境界，后来由于意识的虚妄分别，才妄生外想，执以为实。因为现量境是五识所变的相分，因为它是识所变，所以说为有。意识所执外法为心外实色，那是妄计情有，所以说他是无。又，色等五境，本来不是色好像是色，不是外好像是外。好像梦中所缘的境界，怎可执著为外面的实色呢？

    论文十一：若觉时色，皆如梦境不离识者，如从梦觉知彼唯心，何故觉时于自色境不知唯识？如梦未觉不能自知，要至觉时方能追觉，觉时境色应知亦尔。未至觉位不能自知，至真觉时亦能追觉。未得真觉恒处梦中。故佛说为生死长夜，由斯未了色境唯识。

    讲解：这是九难的第七，梦觉相违难。外人问曰：假如我们醒的时候，所见的色境都同梦境一样，也是不离于识，那从梦中醒觉的人，知道梦中境界全是虚假，是唯识的幻境；为什么我们现在醒的时候，不知道所见的山河大地是虚假的，是唯识所变的呢？

    论主答：正在梦中还没有醒觉的人，他也不能自知梦境是假，一定要到醒来以后，才能回想到梦境是假，唯识所变。正如我们现在所见的境界也是这样，在没有证到佛果的时候，不能自知是唯识所变。到了成佛之后，才能够知道未证佛果以前，如恒常的处在梦中，所以佛才说之为生死长夜，因此，不能了知色境是唯识所变。

    论文十二：外色实无，可非内识境，他心实有，宁非自所缘？谁说他心非自识境？但不说彼是亲所缘。谓识生时无实作用，非如手等亲执外物，日等舒光亲照外境，但如镜等似外境现，名了他心，非亲能了，亲所了者，谓自所变，故契经言，无有少法能取余法。但识生时似彼相现，名取彼物。如缘他心，色等亦尔。

    讲解：这是九难的第八，外取他心难。外人问难：外界的色等五境，实无自体，因为它是内识所变，不是内识所缘之境。但是他人的心识，在自心之外实有，怎么说它不是自识所缘呢？论主答曰：谁说他人之心不是自识所缘之境呢？只是不说他心是自心的亲所缘缘。也就是说，自识生起的时候，没有真实的作用，不能像手那样亲自去执持身外物，也不能像日光那样直照外境，心缘外境时像镜子照物一样，好似有外境显现在自心的镜子上，但并不是自心亲缘。亲所了者，是托本质自识上所变的影像，才是亲所缘缘。所以《解深密经》上说：没有少实法能够缘取心外实法。可见能取的见分，和所取的相分，都是自识自证分所变，但是自己识体生起的时候，变起了相似的影相，这样叫做‘取彼物’，缘他人的心是这样，缘一切色境也是这样的。

    论文十三：既有异境，何名唯识？奇哉！固执触处生疑。岂唯识教但说一识？不尔，如何？汝应谛听，若唯一识，宁有十方凡圣，尊卑因果等别？谁为谁说？何法何求？故唯识言有深意趣。识言，总显一切有情各有八识，六位心所，所变相、见，分位差别，及彼空理所显真如。识自相故，识相应故，二所变故，三分位故，四实性故。如是诸法皆不离识，总立识名。唯言但遮愚夫所执，定离诸识实有色等。

    讲解：这是九难的第九，异境非唯难。外人问难：既然离开自己心识之外有他人心识之境，怎么可以叫做唯识呢？论主答：奇怪呀，那有像你这样固执的人触处生疑呢？岂是唯识的教理，但说我一人有识呢？外人问：不是这样是什么？论主答，你仔细听，假如是唯我一人有识，怎么会有十方凡圣，和尊卑因果，色心的种种差别呢？谁来说法，谁来听法，更有谁来求法呢？

    唯识的言说，有深妙的意趣。‘识’字的意趣，是总显一切有情各有五法，即八识心王，六位心所，自体所变的相、见二分，色、心分位的二十四不相应行，彼二无我空理所显的真如。由识的自相，建立了识的自体；由识的相应法，建立了六位心所；由心、心所自体的所变，建立了相、见二分，由自体相、见二分的色心分位，建立了不相应行。由自体、相、见、不相应行，这四种实性，建立了真如。因为这五法都不离识，所以才总立一个识的名称。‘唯’字的意趣，是唯遮愚法二乘及一切凡夫、他们所执定那离开识外的实有色境。

    论文十四：若如是知唯识教义，便能无倒，善备资粮，速入法空，证无上觉，救拔含识生死轮回。非全拨无恶取空者，违背教理能成是事，故定应信一切唯识。

    讲解：如果能够这样了知唯识的教义，便不会执著我、法二执的颠倒迷妄，能够善备福、慧的修行资粮，证入法空，证到无上菩提的佛果，去救拔有情，使之出离生死轮回。不像那些拨无真、俗的恶取空者，违背了唯识的教理，能够成就此事。所以决定应信一切法，都是唯识所变。


第三章 释违理难．心法生起的原由

    第三章 释违理难．心法生起的原由

    论文一：若唯有识，都无外缘，由何而生种种分别？颂曰：由一切种识，如是如是变，以展转力故，彼彼分别生。

    讲解：外人问：如果照你们唯识家所说，只有心识，没有心外所缘之境，那种种的分别识心，又是从何生起的呢？论中答以颂曰：‘由一切种识，如是如是变，以展转力故，彼彼分别生’。颂文中的首三句表明妄缘，末一句显示分别，以下论文自有解释。

    论文二：论曰，一切种识，谓本识中能生自果功能差别，此生等流、异熟、士用、增上果故，名一切种。除离系者，非种生故。彼虽可证，而非种果。要现起道断结得故。有展转义非此所说，此说能生分别种故。此识为体，故立识名，种离本识无别性故。种、识二言简非种识，有识非种，种非识故。又种识言显识中种，非持种识，后当说故。

    讲解：此下是以论文解释颂文。论上说：一切种识，就是根本识中，能够生起各自果法的功能，能够生起等流、异熟、士用、增上四果的种子，所以叫做一切种识。为什么但生五果中的四果，而不生离系果呢？因为离系果不是由种子所生的。它虽说也有无为可证，而不是种子所生的果，要到现起无漏圣道断结之后才能证得。这无为法虽说也有展转证得的意义，而不是这里要说的重点，这里说的是能生分别种子。既是种子，何以又名为识呢？因为种子是依本识为体，他离了本识之外，就别无体性可言了，所以才立识为名，名为种识。

    种识二字，不同于与非种非识，有的识并非种子，也有的种子并不是识。并且，种识说明本识中的种子，并不是持种名为种识，这到后面还有详说。

    论文三：此识中种，余缘助故，即便如是如是转变，谓从生位转至熟时，显变种多，重言如是，谓一切种摄三熏习，共不共等，识种尽故。展转力者，谓八现识及彼相应相见分等，彼皆互有相助力故。即现识等，总名分别。虚妄分别为自性故。分别类多，故言彼彼。

    讲解：这第八识中的种子，要其余三种助缘的帮助，才能够如是如是的转变起来。从种子生起的因位，转变到成熟时期，为显示所变的种子很多，才反复的重言：‘如是如是’。所谓一切种，总摄名言、我执、有支三种熏习，及共、不共的识种都摄尽在内。展转力者，就是八个现行识及其相应心所，和他们自体所变的相、见二分，还有不相应行等，彼此都有互相帮助的力量。即此现行识，相、见二分，相应、不相应，都叫做‘分别’。因为他们都是以虚妄分别为其自性。分别的种类很多，所以说是彼彼。

    论文四：此颂意说虽无外缘，由本识中有一切种转变差别，及以现行八种识等展转力故，彼彼分别而亦得生，何假外缘，方起分别？诸净法起应知亦然，净种现行为缘生故。

    讲解：这首颂的意思是说：虽然没有心外之缘，但由于根本识中，有一切种的转变差别，及以现行的八种识等，展转相助之力，所以自体、相、见等的彼彼分别，亦得生起，何必假藉外缘才能生起分别呢？一切染法的生起既然如此，当知一切净法的生起也是这样的。因为无漏种生起无漏现行，也是缘生的原故。


第四章 四缘．十因．五果

    第四章 四缘．十因．五果

    论文一：所说种、现缘生分别，云何应知此缘生相？缘且有四：一因缘：谓有为法亲办自果，此体有二，一种子，二现行。种子者，谓本识中，善、染、无记诸界、地、等，功能差别，能引次后自类功能，及起同时自类现果。此唯望彼是因缘性。现行者，谓七转识及彼相应所变相、见、性、界、地等，除佛果善，极劣无记，余熏本识，生自类种，此唯望彼是因缘性。第八心品无所熏故，非简所依独能熏故。极微圆故，不熏成种。现行同类，展转相望，皆非因缘，自种生故。一切异类，展转相望，亦非因缘，不亲生故。有说异类，同类现行，展转相望，为因缘故，应知假说，或随转门。有唯说种是因缘生，彼说显胜，非尽理说。圣说转识与阿赖耶，展转相望为因缘故。

    讲解：外人问曰：前颂中说种子、现行的绿生分别，怎样知道这缘生分别之相呢？

    论主答曰：缘有四种，一是因缘。就是有为法能够亲自生出自果。这果体有二，一是种子，二是现行。什么叫种子？就是第八根本识中，所有的善、染、无记三性，及三界、九地、有漏、无漏等各种不同的功能。这不同的功能，又能引生次后的自类功能，及生起同时的现行之果。这种子对他自己所生的种子和现行来说，即为因缘性。

    什么叫做现行？就是七转识及其相应心所，所变现的相、见二分，三性、三界、九地，有漏、无漏等，除了圆满佛果的善性，及极劣的无记性外，其余的都能熏第八识，生起了自类种子。这现行望所熏的种子，也是属于因缘。

    能熏的现行法里，何以没有第八心品？因为第八心王已是所熏，所以它不是能熏的现行。心王既不能熏，心所也不能简去所依的心王而独自能熏。

    现行同类，展转相望，都不是因缘，因为现行法，都是各从本识的自种所生，并不是同类相望有因缘义。一切异类展转相望，也非因缘。因为异类不能亲生异类之果，既非亲生，当然也没有因缘的意义。何以有说异类和同类现行，展转相望成为因缘呢？应知那是方便假说，或随顺小乘，转变了大乘教理的说法。何以有的唯说种子是因缘呢？这是为显示种子胜于现行而说的，不是尽理的说法。因为经论上说，七转识的现行，与第八阿赖耶识的种子，展转相望成为因缘。并不是唯说种子是因缘性。

    论文二：二、等无间缘：谓八现识及彼心所，前聚于后，自类无间，等而开导，令彼定生。多同类种俱时转故，如不相应非此缘摄，由斯八识非互为缘。心所与心虽恒俱转，而相应故，和合似一，不可施设离别殊异，故得互作等无间缘。入无余心最极微劣，无开导用。又无当起等无间法，故非此缘。云何知然？论有诚说。若此识等无间，彼识等决定生。即说此是彼等无间缘故。即依此义应作是说，阿陀那识三界、九地，皆容互作等无间缘，下上死生相开导故。有漏无间有无漏生。无漏定无生有漏者。镜智起已必无断故。善与无记相望亦然。

    讲解：二是等无间缘。就是八个现识及其相应的心所，前念一聚的心王及心所，于后念一聚自类的心王及心所，中间没有任何间隔，这样前后平等，以前念灭心避开前路，引导后念使之决定生起。八识种子，彼此相望，虽同为识种，而是多类并生，同时俱转，并非一识自类前引后生，那好像不相应法一样，不是这等无间缘所摄。因此，八识相望，并非互相为缘。

    问：心与心所，既非自类，体用各殊，又同八识相望一样的恒俱时转，它何以能互相为缘？答：心所与心虽恒俱转，然而，因为是相应法故，和合起来恰似一识，同所依缘、同时而转，同属一性，不可施设使之殊异，故得互作等无间缘。

    入无余涅槃最后心时，势极微劣，因为他的身智既泯，一入永入，前无开导之用，后无当起之法，所以不是等无间缘。

    外人问：你怎么知道，入无余心，不是等无间，前一聚心望后一聚心是等无间呢？论主答：《瑜伽论》上说：‘若此识等无间，彼识等决定生。’，也就是说：此一聚心，是彼后一聚心的等无间缘。依此而论，第八阿陀那识，无论是三界九地，都可以容许互作等无间缘。无论是下死生上地，或上死生下地，都可以互相开导。其义相等。有漏的等无间可以生无漏，无漏则决定不会再生有漏，因为到了无漏果的大圆镜智生起之后，必定常无间断，他如何会再生有漏？无漏和有漏如此，善与无记相望亦然，唯有无记生善，决无善生无记之理。

    论文三：此何界后，引生无漏？或从色界，或欲界后。谓诸异生求佛果者，定色界后引生无漏。后必生在净居天上大自在宫，得菩提故。二乘回趣大菩提者，定欲界后引生无漏，回趣留身唯欲界故。彼虽必往大自在宫方得成佛，而本愿力，所留生身是欲界故。有义：色界亦有声闻回趣大乘愿留身者，既与理教俱不相违，是故声闻第八无漏色界心后亦得现前。然五净居无回趣者，经不说彼发大心故。

    讲解：外人问：这第八阿陀那识，要到三界的那一界后才生无漏呢？答：或从色界，或欲界后。也就是说：一切求佛果的异生，决定在色界后引生无漏，到后来必定生在净居天上的大自在宫，得菩提果。如果是二乘回小向大，决定在欲界后引生无漏。因为色界没有回心二乘；无色界无身可留，回趣留身唯在欲界。他虽然必往大自在官才能成佛，而依其本愿之力，受变易后，所留下的生身是欲界故。

    又有人说：色界也有声闻回趣大乘，愿留身的。此既然和教与理都不相违，所以声闻无漏的第八识，在色界心后也可以现前。然而，色界的五净居天，没有回小向大的声闻。因为大般若经上没说发心趣向大乘，也不说发无上菩提。

    论文四：第七转识，三界、九地，亦容互作等无间缘。随第八识生处系故。有漏、无漏，容互相生，十地位中得相引故。善与无记相望亦然，于无记中，染与不染亦相开导，生空智果前后位中，得相引故。此欲色界，有漏得与无漏相生，非无色界，地上菩萨不生彼故。第六转识，三界九地，有漏无漏，善不善等，各容互作等无间缘。润生位等更相引故。初起无漏唯色界后，决择分善唯色界故。眼耳身识二界二地，鼻舌两识，一界一地，自类互作等无间缘。善等相望应知亦尔。

    讲解：第七末那识，是在三界、九地中，也容许与第八识互作等无间缘。因为它是随著第八识所生所系。有漏和无漏第七识，容许互相引生，因为在十地位中二者可以互相引生。善与无记的互相关系也是如此。在无记中，染与不染也可互相开导，因为生空智果于前后位中，可以互相引生。

    在欲界和色界，有漏、无漏的末那识能互相引生，在无色界则不能，因为地上菩萨不能生于欲界。第六转识，在三界九地的有漏、无漏、善与不善等，都可以互作等无间缘。因为在此生彼临终的润生位，可以互相引生。最初生起的无漏，只在色界无漏意识以后，因为能够引发第六识的决择分善，唯在色界第四禅天。

    五识的眼、耳、身三识，通于欲界的五趣杂居地，和色界的离生喜乐地；鼻、舌二识，唯在欲界一地，他们都是自类开导，互作等无间缘的。乃至善、无记等的互相关系，应知也是如此。

    论文五：有义：五识有漏、无漏，自类互作等无间缘，未成佛时容互起故。有义：无漏有漏后起。非无漏后容起有漏，无漏五识非佛无故。彼五色根定有漏故，是异熟识相分摄故。有漏不共必俱同境，根发无漏识，理不相应故，此二于境，明昧异故。

    讲解：有论师说：前五识，无论有漏、无漏，都可以自类互作等无间缘。因为地上菩萨在未成佛时，容许互相引生。另有论师说：无漏生起于有漏之后，并不是无漏后再起有漏。因为无漏五识，在没有成佛时是不会有的。所以因地的五根，决定是有漏的，是第八异熟识的相分所摄。

    问：有漏根生无漏识，又有何不可呢？答：有漏的五根，不是有漏识和无漏识所共依，必定是根识同境。不然，有漏根发无漏识，在道理上是不相应的。因为有漏根于所缘之境，如翳目见物，昧而非明；无漏识于所缘之境，如净眼观空，明而非昧，二者大有差别，如何能够相应？

    论文六：三、所缘缘：谓若有法，是带己相，心或相应，所虑所托。此体有二，一亲、二疏。若与能缘体不相离，是见分等内所虑托，应知彼是亲所缘缘；若与能缘体虽相离，为质能起内所虑托，应知彼是疏所缘缘。亲所缘缘，能缘皆有，离内所虑托必不生故。疏所缘缘能缘或有，离外所虑托，亦得生故。

    讲解：三是所缘缘。所缘缘三字，上面所缘二字，是客观所缘之境；下一缘字，是主观生起的条件，即是四缘之一的缘。意思是心法、心所法的生起，必有它所缘之境，这所缘之境，为心、心所生起之缘。此指有体的实法，在为八识心王、或其相应心所之所虑所托，这所虑与所托的境相，浮在能缘的心、心所上，就叫做‘所缘’。这所缘的境，也就是生起心、心所的缘。倘若能缘的心上，不带所缘缘的境，那就不得名为所缘缘了。所缘缘的自体有二，一亲、二疏，如果所缘的境相，与能缘的心体不相隔离，是自识的见分等内所虑托，应知这就是亲所缘缘。倘若所缘的境，与能缘的心虽相隔离，但可为本质能起内所虑托之相分，应知这就是疏所缘缘。亲所缘缘，在能缘之心里都有，因为离了内所虑托的相分，肯定不能生起。至于疏所缘缘，在能缘之心里或有或无，离所虑托的相分之外，那能缘心照样可以生起。（注：有为识变，名内所虑，如见分缘相分；自证分缘见分等。无为真如，体不离识，名所虑托。）

    论文七：第八心品，有义，唯有亲所缘缘，随业因力任运变故。有义：亦定有疏所缘缘，要仗他变质自力变故。有义：二说俱不应理，自他身土可互受用，他所变者为自质故，自种与他无受用理，他变为此不应理故，非诸有情种皆等故。应说此品疏所缘缘，一切位中有无不定。

    讲解：以下是对八识来分别其疏所缘缘的有无，此有如下三家异说。第一家说：第八识唯有亲所缘缘，因为此识由业力及自因之力，可以任运变现，所以没有作意方起的疏所缘缘。第二家说：第八识不但有亲所缘缘，肯定也有疏所缘缘，因为要先仗他识所变的影像为本质，然后自己才能变起。例如种子，若不仗他识所变，自己又何从变起呢？

    第三家说：第一家说第八识没有疏所缘缘，此说不然。因为自己的身、土及他人的身、土，彼此之间都可以互相受用，所以要仗托他人所变的影像，作为自己所变的相分质，怎能说没有疏所缘缘呢？第二家说的也不对，自己的种子，不能给他人受用，那么他变为此种则不合理，因为一切有情的种子，并不是凡圣不分，多少相等，怎能互变为缘昵？因此，第三家主张，第八识的疏所缘缘，在一切因果位中有无不定。

    论文八：第七心品，未转依位，是俱生故，必仗外质，故亦定有疏所缘缘。已转依位，此非定有，缘真如等无外质故。第六心品，行相猛利，于一切位能自在转，所仗外质或有或无，疏所缘缘有无不定。前五心品未转依位，粗钝劣故，必仗外质，故亦定有疏所缘缘。已转依位，此非定有，缘过、未等，无外质故。

    讲解：这第七识有没有疏所缘缘呢？要以有转依未转依来作决定。在未转依的有漏因位，因为是与生俱生之故，他无力任运而转，必须要仗第八识以为外质，然后自己才能变为所缘的相分。所以第七识也决定有疏所缘缘。若在已转依的无漏果位，那可就不一定有。例如第七识根本智相应心品缘真如，不仗外质，就没有疏所缘缘；如以后得智缘现世有为诸法，必仗外质，那就非有疏所缘缘不可了。

    这第六识品，有无疏所缘缘不定。因为它行相猛利，在一切因果位中能自在转起，或是俱生起，必仗外质；或是分别起，不仗外质。所以其疏所缘缘有、无不定。前五识品有没有疏所缘缘呢？那也要看有没有转依而定。若在未转依位，它们的行相粗钝劣微，必须仗著第八识或第六识的外质，才能变境，所以也决定有疏所缘缘。若在已转依位，疏所缘缘不一定有。因为佛位遍缘一切过去，未来，都无外质之故。

    论文九：四增上缘：谓若有法有胜势用，能于余法或顺或违。虽前三缘亦是增上，而今第四除彼取余，为显诸缘差别相故。此顺违用，于四处转，生、住、成、得四事别故。

    讲解：四是增上缘。什么叫增上缘，若有一法，它俱有殊胜的势用，能对其余诸法，或顺或违，都能有为缘的力量，这便是增上缘。虽然前面所说的因缘、等无间绿、所缘缘，也都有增上的作用，但是此处所说的增上缘，是把前三缘除外，而取其缘所不及的余法为体，这是为了显示各缘之间的差别之相。增上缘的随顺和违逆，在四方面发生作用，因为在一切事物上均有生、住、成、得四种区别。顺缘能使生、住、成、得，违缘能使不生、不住、不成、不得。

    论文十：然增上用，随事虽多，而胜显者，唯二十二，应知即是二十二根。前五色根，以本识等所变眼等净色为性，男、女二根身根所摄，故即以彼少分为性，命根，但依本识亲种分位假立，非别有性。意根总以八识为性，五受根如应各自受为性，信等五根即以信等及善念等而为自性。

    讲解：然而，增上作用随顺之事虽然很多，而有明显作用的只有二十二种，当知就是二十二根。眼、耳、鼻、舌、身等五色根，是以第八根本识所变的眼等净色为体性。男女二根，为身根所摄，所以但以身根的少分为其体性。命根，是依第八根本识的亲因种子分位假立的，所以它没有独立的自性。意根，是总以八识为体性。五受根，是如其所应，各以其所受的苦、乐、忧、喜、舍为体性。信、精进、念、定、慧五根，是以十一善中的信、勤二法，及五别境中的念、定、慧三法为自性。

    论文十一：未知当知根体位有三种：一、根本位。谓在见道，除后刹那无所未知可当知故。二、加行位、谓暖、顶、忍、世第一法，近能引发根本位故。三、资粮位。谓从为得谛现观故，发起决定胜善法欲，乃至未得顺决择分所有善根，名资粮位，能远资生根本位故。

    讲解：前十九根的体性已如上述，于此讲解第二十的‘未知当知根’。未知当知根的体性分位有三，第一是根本位：此根在见道十六心里，要除去最后刹那的第十六心。因为前十五心的现观，尚有未知的谛理当知。到十六心时，进入修道位，对于法性已经了知，就没有未知可当知了。第二是加行位：在将入见道之前，积暖、顶、忍、世第一法的决择分善，加功用行，就近能引发根本位而入于见道。第三是资粮位：就是向圣位进趣的大乘行者，为了求得圣谛现观，发起了决定殊胜的善法欲，乃至未得决择分以前的所有善根，都叫做资粮位。因为它远能资助生起根本位故。

    论文十二：于此三位，信等五根，意、善、乐、舍为此根性，加行等位，于后胜法，求证愁戚，亦有忧根，非正善根，故多不说。

    讲解：前面所说未知当知根的根本、加行、资粮三位，是以信等五清净根，及意、喜、乐、舍四根，合为九根而为其体性。至于在加行及资粮二位，因对后来未知当知的涅槃胜法力求证得的时候，不免有患得的愁戚心情，似亦应有忧根，合十根为体性。但彼二位并不是真正的无漏善根，忧根又是戚行，都为无漏的根本位所不摄，故略而不说。

    论文十三：前三无色有此根者，有胜见道傍修得故，或二乘位回趣大者，为证法空，地前亦起九地所摄生空无漏，彼皆菩萨此根摄故。菩萨见道亦有此根，但说地前，以时促故。始从见道最后刹那，乃至金刚喻定，所有信等无漏九根，皆是已知根性。未离欲者于上解脱，求证愁戚亦有忧根，非正善根故多不说。诸无学位，无漏九根一切皆是具知根性。有顶虽有游观无漏，而不明利，非后三根。二十二根自性如是。诸余门义如论应知。

    讲解：这是解释无色界的前三无色，也就是无色界四地的前三地，空无边处地、识无边处地、无所有处地。这前三无色，何以有此未知当知根呢？因为有胜见道，为菩萨先傍修此上地定后才得入的，所以前三无色界也有此根。或二乘三果以上，回趣大乘者，他们为的要证初地法空，在尚未登地以前，亦起三无色等九地所摄的生空无漏，彼皆菩萨的未知当知根摄。初地入心的菩萨见道，也有此根。何以但说地前？那是因为入心的时问短，所以不说。

    第二十的未知当知根已如上述，现在讲第二十一、二十二的己知根及具知根。初从见道的最后一刹那起，乃至金刚喻定止，在这修道位中，所有的信等无漏九根，都是已知根的体性。至于那未离欲贪烦恼的人，对于上品解脱，因为还要求证的关系，不免仍有愁戚之感，所以也有忧根。虽然如此，但因不是真正的善根，故多略而不说。从金刚喻定进入无学位，诸无学位的无漏九根，一切都是具知根的体性。在三界最高的有顶天中，入灭尽定的前心，也有无漏，何以非三无漏根所摄？答曰：因为有顶天的想心微细，虽也有游观无漏，但不十分明利，所以不属于后三无漏根所摄。

    二十二根的自性已如前讲，至于其他诸门义理，如二十二根的业用假实，乃至界系余门分别，并如《瑜伽师地论》五十七卷所说。（注一：末知当知根，为三无漏根之一，意根、乐根、善根、舍根、信根、精进根、念根、定根、慧根，这九根在见道位，欲知未曾知的苦、集、灭、道四谛之理，并想按照四谛行动。在十六心中，此根只通前十五心。注二：已知根，意、乐、喜、舍、信、勤、念、定、慧九根，在修道位虽然已经知道四谛之理，但为断除其他烦恼，对四谛之理还要一再了知。注三：具知根：在无学道，意等九根已经完全知道四谛之理，具有其知，故称具知。）

    论文十四：如是四缘，依十五处义差别故，立为十因。云何此依十五处立？一、语依处：谓法名想所起语性，即依此处立随说因。谓依此语，随见闻等说诸义故，此即能说为所说因。有论说此是名、想、见，由如名字，取相执著，随起说故。若依彼说，便显此因是语依处。

    讲解：以上所说的因缘、等无间缘、所缘缘、增上缘，是依于十五处的意义差别，而建立了十种因。建立十因所依的十五处是什么？向下依次说明。

    第一是语依处：法，为现像界的一切事物；名，是表诠一切法的名称；想，是缘诸法的内心想像。综合来说，缘于诸法，起诸构想，由构想而立诸法的名称。所以这法、名、想三者，为所起语言的体性，同时亦即依语依处，建立了‘随说因’。这意思是说：诠一切法，必先起名取相，然后才有言说，即依此言说，随著见、闻、觉、知等事，宣说其所了解的一切义理。这就是以能说的语言，为所说诸法之因。

    然而《杂集论》上却说这随说因并不是法、名、想为因，而是以名、想、见为因。名是名字，取相是想，执著是见。随著这名、想、见三法而起言说之故。如果照他这样说，便显示这名、想、见的因体，就是语的依处了。

    论文十五：二、领受依处：谓所观待能所受性，即依此处，立观待因。谓观待此，令彼诸事或生或住，或成或得，此是彼观待因。

    讲解：第二是领受依处：就是所观待能所受性。相对为观，假藉为待，所观待的法，就是能受与所受的体性。因此，即依这领受依之处，建立了观待因。这意思是说，观待此法，能令彼所领受的诸事，或是生起、或是安住、或是成就、或是获得。所以这法就是那生、住、成、得诸事的‘观待因’。

    论文十六：三、习气依处：谓内外种未成熟位，即依此处立牵引因。谓能牵引远自果故。四、有润种子依处：谓内外种已成熟位，即依此处立生起因，谓能生起近自果故。

    讲解：第三是习气依处：习气就是种子的别名。这是就内而身心，外而器界，一切诸法种子未成熟位而说的。如内种子没有被贪爱之所滋润，外种子没有被水土等之所滋润，在此阶段，都叫做习气依处。即依此习气依处建立了‘牵引因’。因为种子在没有滋润时，但有牵引远自果的功能，所以立此因名。

    第四是有润种子依处：无论是内种外种，由未成熟位到已成熟位，都叫做有润种子依处。即依此处建立了‘生起因’。因为已成熟的种子，有生起近自果的功能。

    论文十七：五、无间灭依处：谓心、心所等无间缘。六、境界依处：谓心、心所所缘缘。七、根依处：谓心、心所所依六根。八、作用依处。谓于所作业、作具、作用，即除种子余助现缘。九、士用依处，谓于所作业、作者、作用，即除种子余作现缘。十、真实见依处，谓无漏见，除引自种于无漏法能助、引、证。总依此六立摄受因，谓摄受五，办有漏法，具摄受六办无漏故。

    讲解：第五是无间灭依处：就是心、心所法，自类开导的等无间缘，以心、心所法为自果，这在前面正解四缘时已经说过了。

    第六是境界依处：就是心、心所上带有所缘境相的所缘缘。虽体通一切法，而果唯心与心所，有漏、无漏并通因果。这也在正解四缘时说过了。

    第七是根依处：就是心、心所法，所依的眼等六根。

    第八是作用依处：作用就是对于所作事业，及其所用工具的作用。例如舟车有装载的作用，农具有耕耘收获的作用等。惟除内外的种生现、现生种的亲因缘外，其余的一切疏所助缘，都是这作用依处所摄。

    第九是士用依处：士者士夫，就是作业的人。士用是作业人所起的作用。如农人望于五谷，修行者人望于道果等。不过这也要除去亲因缘的内外种子，唯有其余的一切现缘，才是士用依处。

    第十是真实见依处：真实见就是无漏见。不过这也要除去引发的自种子。因为自种子是引发的亲因，而非此疏缘。唯于俱生的有为无漏，能助令增长；或于未证的无为无漏，能引令证得的，才是真实见的依处。

    总依以上第五至第十的六种依处，成立了第五的‘摄受因’。为什么总六依处立一摄受因呢？因为前五依的疏所摄受，只能成办三界的有漏诸法。若把六依的疏所摄受合并起来，便兼成办出世的无漏法了。

    论文十八：十一、随顺依处：谓无记染善现种诸行，能随顺同类胜品诸法，即依此处立引发因。谓能引起同类胜行，及能引得无为法故。十二，差别功能依处：谓有为法各于自果有能起证差别势力，即依此处立定异因。谓各能生自界等果，及各能得自乘果故。

    讲解：第十一是随顺依处：随顺，是互不相障的意思。谓无记、染、善的三性法，无论是现行或种子，都能随顺同一类性，而且是殊胜的上品诸法，就叫做随顺依处。即依此处，建立了第六的‘引发因’。因为能引起同类性的胜行，及引得无为法故。如欲界善法，能与三界善法及无漏为因；色界善法，能与色、无色界善法及无漏为因；无色界善法，能与无色界善法及无漏为因。总之、下能引上，非上引下，界系虽有差别，而果望于因，其性必同。

    第十二是差别功能依处。功能是种子的异名，功能差别，是说色、心诸法各各的种子。这种子，有能生自果和证得无为的差别势力，这差别的势力就叫做差别功能依处。即依此处，建立了第七的‘定异因’。自性相称叫做定，不共他法叫做异。若约三界而论，欲界的色、心等因，只能生起欲界的色、心等果；色、无色界亦然。若约三乘而论，也各有其有为、无为之因，各证其有为无为之果。这就是自性相称，不共他法的定异因。

    论文十九：十三、和合依处：谓从领受，乃至差别功能依处，于所生、住、成、得果中有和合力，即依此处立同事因。谓从观待乃至定异，皆同生等一事业故。十四、障碍依处：谓于生、住、成、得事中，能障碍法，即依此处立相违因。谓彼能违生等事故。十五、不障碍依处。谓于生、住、成、得事中，不障碍法。即依此处立不相违因。谓彼不违生等事故。

    讲解：第十三是和合依处：这是除去势力疏远，没有和合力用的第一语依处外，从第二的领受依处到第十二的差别功能依处，在这十一种依处所有的生、住、成、得四事果中，一一都有它和合力用，就叫做和合依处。即依此处，建立了第八的‘同事因’。所谓同事，就是从第二的观待因，到第七的定异因，这六因都同生、住、成、得的果法是一种事业。

    第十四是障碍依处。就是对生、住、成、得的四果事中，能作障碍，使当生不生，乃至当得不得，就叫做障碍依处。即依此处。建立了第九的‘相违因’。所谓相违，就是此法与彼法不相遂顺，因为它能违反生等的四事之故。第十五是不障碍依处。不障碍与障碍相反，它于生、住、成、得四事不作障碍，使当生者生，乃至当得者得，就叫做不障碍依处。即依此处建立第十‘不相违因’。因为不违反生等四事之故。

    论文二十：如是十因，二因所摄，一、能生，二、方便。菩萨地说牵引种子生起种子名能生因；所余诸因方便因摄。此说牵引、生起、引发、定异、同事、不相违中，诸因缘种未成熟位，名牵引种，已成熟位，名生起种，彼六因中，诸因缘种皆摄在此二位中故。虽有现起是能生因，如四因中生自种者，而多间断，此略不说。或亲办果亦立种名，如说现行谷、麦等种。所余因谓初、二、五、九，及六因中非因缘法，皆是生熟因缘种余，故总说为方便因摄。非此二种唯属彼二因，余四因中有因缘种故。非唯彼八名所余因，彼二因亦有非因缘种故。

    讲解：以上讲解依十五处建立十因，实际上此十因可用二因包括，即一者生因，二者方便因。但对这二因相摄，则有两家异说，第一家引用《瑜伽师地论菩萨地》文说：除了牵引的种子和生起的种子称为能生因外，其余各因统为方便因所摄。他解释能生因说：能生因为十因中第三的牵引、第四的生起、第六的引发、第七的定异、第八的同事、第十的不相违，这六因中所有的因缘种子，在尚未成熟时期，叫做牵引种子，若已被润成热，就叫做生起种子了。因为这六因中都有因缘种子能生的意义，所以统摄在牵引因和生起因二因中了，不然，二因便有摄因缘不尽的过失。

    有问曰：如果这样，现行熏成种子，也是因缘所收，为什么不摄在二因中呢？答：虽有现起，是能生因，如引发等四因中的现行生自种子，也是因缘，但那多分是有间断的，而不是恒相续的二因种子，所以这菩萨地中，略而不说。或此能亲办自果的现行，也名叫种子，为生起种摄，如同说现行谷麦，名谷种、麦种一样。

    第一家解释方便因说：十因中第一的随说因、第二的观待因、第五的摄受因、第九的相违因，以及前六因中的非因缘法，都是属于前说未润位的生因缘种，及已润的熟因缘种之所余，所以总说这四因的全部，及六因的一部分，为方便因摄。

    并不是菩萨地的牵引、生起二种，唯属彼十因中的牵引、生起二因。因为其余的引发等四因中，也有因缘种子，若不摄入牵引、生起，便有摄法不尽之失。翻过来说，也不是除牵引、生起二因外，其余的八因都叫做所余因。因为彼牵引、生起二因中，也有非因缘种子，若不摄入所余，也有摄法不尽之失。

    论文二十一：有寻等地，说生起因是能生因，余方便摄。此文意说：六因中现种是因缘者，皆名生起因，能亲生起自类果故，此所余因皆方便摄。非此生起唯属彼因，余五因中有因缘故。非唯彼九名所余因，彼生起因中有非因缘故。

    讲解：此第一家，先引菩萨地文说过之后，又引有寻等地文说：除第四的生起因是能生因外，其余都是方便因摄。又对此文意解释说：在六因中，无论是现行、种子，润与未润，只要是互为因缘的，都叫做生起因，属能生摄；因为他们都能生起自类果故。若在六因中除去部分的因缘种外，以及所余的四因全部，都是方便因摄。

    并不是这有寻等地的生起，唯属彼十因中的生起因。因为除生起因外，其余的牵引等五因中，也有因缘，若不摄入生起，便有摄法不尽之失。翻过来说，也不是除生起因外，唯有其余的九因叫做所余因。因为彼生起因中，也有非因缘法，若不摄入所余，也有摄法不尽之失。

    论文二十二：或菩萨地所说牵引、生起种子，即彼二因，所余诸因即彼余八。虽二因内有非能生因，而因缘种胜，显故偏说。虽余因内，有非方便因，而增上者多，显故偏说。有寻等地说生起因是能生因，余方便者，生起即是彼生起因，余因应知即彼余九。虽生起中有非因缘种，而去果近，亲显故偏说，虽牵引中亦有因缘种，而去果远，亲隐故不说。余方便摄，准上应知。

    讲解：第二家说：菩萨地所说的牵引、生起二种种子，就是十因中的牵引、生起二因；所说的所余诸因，就是在十因中除去牵引、生起外所余的八因。虽然牵引和生起二因里，也有部分非能生因，而其因缘种子，办体、受果的功能，比较胜显，所以偏说它是能生因。虽然所余的八因里，也有非方便因，但此八因，除四因中有少分因缘外，毕竟还是增上缘多，所以偏说他是方便因。

    有寻等地里所说的生起因是能生因，余方便摄者：生起，就是彼十因中第四的生起因，余因，就是除生起因外，其余的九因。虽然生起因中，也有不属于因缘种子的业种，但已滋润成熟的种子，离得果很近，较牵引因亲而且显，所以偏说生起因是能生因。虽然菩萨地的牵引因中，也有属于能生的因缘种子，但未被滋润，离得果尚远，较生起因的疏显而亲隐，所以不说他是能生因，理亦无违。至于‘所余因是方便摄’者，那是因为所余的九因，虽四因中也有少分因缘，但尚有四因的全部及五因的少分，都是方便因摄，准如以上所说应知。

    论文二十三：所说四缘，依何处立？复如何摄十因、二因？论说因缘，依种子立，依无间灭立等无间，依境界立所缘，依所余立增上，此中种子即是三、四、十一、十二、十三、十五，六依处中因缘种摄。虽现四处亦有因缘，而多间断，此略不说。或彼亦能亲办自果，如外麦等亦立种名。或种子言唯属第四，亲疏隐显，取舍如前，言无间灭境界处者，应知总显二缘依处，非唯五六，余依处中，亦有中间二缘义故。或唯五六，余处虽有而少隐故，略不说之。

    讲解：前面所说的四缘，在十五处中，是依于那一处建立的呢？又此四缘，与十因、二因是怎样的相摄呢？据《瑜伽论》上说：依第四的‘有润种子依处’建立因缘，依第五的‘无间灭依处’建立等无间缘。依第六的‘境界依处’建立所缘绿。依其余的十二种依处建立增上缘。但对论文中前三缘的依处，有二家不同异解。

    一、对于因缘依的解释：第一家说，这里所说的种子，就是十五依处中的第三习气、第四有润种子、第十一随顺、第十二差别功能、第十三和合、第十五不障碍，这六依处里的因缘种子所摄。虽除第三、第四两依处外，其余的四依处里，也有现行，应属因缘，然而因为他们多间断故，所以这里略而不说，但说种子。或彼四依处里的现行，能亲办自果，如外麦、谷等，也可以叫他名为种子。第二家说：所谓种子，唯属第四的有润种子依处。对亲疏隐显的取舍，如前二因相摄中说，此处不赘。也就是：取有润种子依处里亲显的生起因，说为种子；舍习气依处里疏隐的牵引因而不说。

    二、对等无间缘、所缘缘依的解释：第一家说：所谓无间灭依处，及境界依处，应知这是总显等无间缘、所缘缘的二缘依处，并非但指第五的无间灭依处，及第六的境界依处而言。因为其余的领受、和合、不障碍这三依处里，也有四缘中间的等无间缘、所缘缘的意义。第二家说：等无间缘及所缘缘这二缘依处，唯属第五的无间灭，及第六的境界依处，与其余的依处无关。虽然其余的领受、和合、不障碍，也有二缘依处的意义，然而因为其相状微隐之故，所以论中略而不说。

    论文二十四：论说因缘，能生因摄；增上缘性，即方便因；中间二缘，摄受因摄。虽方便内具后三缘，而增上多，故此偏说；余因亦有中间二缘，然摄受中，显故偏说。初能生摄，进退如前。

    讲解：四缘依处，已如上说，现在是解释四缘与十因、二因相摄的关系。据《瑜伽论》说：因缘是属于二因的能生因摄，增上缘是属于方便因摄，中间的等无间缘与所缘缘，是属于十因中第五的摄受因摄，其余的九因，当然属于因缘、增上缘所摄了。

    虽然方便因里，具有后三缘──等无间缘、所缘缘、增上缘，然而增上缘摄因较多，它除了观待、同事、不相违外，余无不摄，所以偏说方便因是增上缘。虽除摄受因外，余因中也有中间的等无间缘与所缘缘二缘，然而唯独摄受因中，很显然的有无间灭与境界的二依处名，余因不显，所以偏说摄受，不说余因。至于初说因缘是能生因摄，这能生的解释，应如前来菩萨地里，第一家进取六因为能生，第二家退取二因为能生，有寻等地里，第一家进取六因为能生，第二家退取一因为能生。

    论文二十五：所说因缘，必应有果。此果有几？依何处得？果有五种：一者异熟，谓有漏善及不善法，所招自相续异熟生无记。二者等流，谓习善等所叫同类，或似先业后果随转。三者离系，谓无漏道，断障所证善无为法。四者士用，谓诸作者，假诸作具所辨事业。五者增上。谓除前四，余所得果。

    讲解：前讲十因四缘，因缘必有其应得之果，此果有几，复依何处而得何果呢？果有五种：第一种是异熟果，就是由有漏善法及不善法，所招感本识自体相续的异熟生无记。第二种是等流果，就是以熏习的善、不善、无记为因，引生善、不善、无记的同类报果，叫做等流。或似先业后果随转，例如：先世杀生，令他短命，今世随著杀生的先业，感得短命的报果，此实是异熟，而前后短命，因果似同，叫做等流。第三种是离系果，就是由无漏道断烦恼、所知二障，所证得的善无为法，即三无为中的择灭，六无为中的真如。第四种是士用果，就是一切作业的人，假藉著一切作业的工具，所办的事业。第五种是增上果，就是除了前四果外，其余所得的果，都叫做增上。

    论文二十六：瑜珈等论说：习气依处，得异熟果；随顺依处，得等流果；真见依处，得离系果；士用依处，得士用果，所余依处，得增上果。习气处言，显诸依处感异熟果一切功能，随顺处言，显诸依处引等流果一切功能。真见处言，显诸依处证离系果一切功能。士用处言，显诸依处招士用果一切功能。所余处言，显诸依处得增上果一切功能。不尔，便应太宽太狭。

    讲解：以上所说的五果，都是依十五处的那一处得的呢？据《瑜伽》等论上说：异熟果，是依第三的习气依处而得的。等流果，是依第十一的随顺依处而得的。离系果，是依第十的真实见依处而得的。士用果，是依第九的士用依处而得的。增上果，是依所余的十一种依处而得的。但对此依处得果，还有二家不同解释。

    第一家解释说，所谓习气依处，是表显十五依处里的习气、有润、差别功能、和合、不障碍，这五依处所感异熟果的一切功能。所谓随顺依处，是表显习气、有润、真实见、随顺、差别功能、和合、不障碍，这七依处所引等流果的一切功能。所谓真见依处，是表显真见、随顺、差别功能、和合、不障碍，这五依处所证离系果的一切功能，所谓士用依处，是表显领受、士用、作用、和合、不障碍，这五依处所招士用果的一切功能，所谓所余依处，是表显语、境界、根、障碍，这四依处全部及其余十一依处的少分，所得增上果的一切功能。

    为何这样解释？如果不这样解？那五果的依处，便有增上太宽，余四太狭的过失。

    论文二十七：或习气者，唯属第三，虽异熟因余处亦有，此处亦有非异熟因；而异熟因去果相远，习气亦尔，故此偏说。随顺唯属第十一处，虽等流果余处亦得，此处亦得非等流果，而此因招胜行相显，随顺亦尔，故偏说之。真见处言，唯诠第十，虽证离系余处亦能，此处亦能得非离系，而此证离系，相显故偏说。士用处言唯诠第九，虽士用果余处亦招，此处亦能招增上果等，而名相显是故偏说。所余唯属余十一处，虽十一处亦得余果，招增上果余处亦能，而此十一多招增上，余已显余，故此偏说。

    讲解：第二家解释说：习气依处，唯属十五依处里第三的习气依处。虽说异熟因其余的四处亦有，这习气依处也有非异熟因，然而异熟因熟时，离果尚远，习气依处望果亦远，余处就不然了。所以偏说习气依处得异熟果。

    随顺依处，唯属十五依处里第十一的随顺依处。虽说等流果，其余的六依处亦能感得，这随顺依处，也能感得非等流果，然而这等流因，招感的胜有为法，行相显著，随顺依处亦然，所以遍说随顺依处招等流果。

    所谓真见依处，唯是诠释十五依处里第十的真实见依处。虽说证离系果，其余的四处亦能，这真见依处，也能得非离系果。然而以真见依处所证得的离系果相显现，所以偏说真见依处得离系果。

    所谓士用依处，唯是诠释十五依处里第九的士用依处。虽士用果，其余四处也能招得，这士用依处，也能招得增上等果，然而士用依处的名叫士用，其相甚显，所以偏说士用依处得士用果。

    所余依处，即十五依处除了习气、随顺、真见、士用四依处外，所余的十一种依处。虽然十一依处，也能招得其余四果；招增上果余四处亦能，然而唯十一依处所招的增上果多，余四依处也已各显其所得之果了，所以偏说这十一依处得增上果。

    论文二十八：如是即说此五果中，若异熟果、牵引、生起、定异、同事、不相违因，增上缘得。若等流果，牵引、生起、摄受、引发、定异、同事、不相违因，初后缘得。若离系果，摄受、引发、定异、同事、不相违因增上缘得；若士用果，有义观待、摄受、同事、不相违因，增上缘得。有义：观待、牵引、生起、摄受、引发、定异、同事，不相违因，除所缘缘，余三缘得，若增上果，十因四缘，一切容得。

    讲解：以上说依处得果完毕，现在来说十因、四缘的多少得果问题。果有五种，在五果中，一、若是异熟果，那它望于十因，即由牵引、生起、定异、同事、不相违五因，及四缘中的增上缘得。二、若是等流果，便为十因中的牵引、生起、摄受、引发、定异、同事、不相违七因，及四缘中的因缘、增上缘二缘所得。三、若离系果，便为十因中的摄受、引发、定异、同事、不相违五因，及四缘中的增上缘得。四、若士用果，那就有二种不同的说法。第一家说：为十因中的观待、摄受、同事、不相违四因，及四缘中的增上缘得。第二家说：为十因中的观待、牵引、生起、摄受、引发、定异、同事、不相违八因，及四缘中除所缘缘外，其余的三缘所得。五、若增上果，那就容为十因、四缘一切所得了。

    论文二十九：傍论己了，应辨正论。本识中种，容作三缘，生现分别，除等无间。谓各亲种是彼因缘，为所缘缘于能缘者。若种与彼，有能助力或不障碍，是增上缘。生净现行，应知亦尔。

    讲解：以上于傍论已经讲完，现在应当辩明四缘正论。第八根本识中的种子，容许作因缘、所缘绿、增上缘三缘，而生起现行的分别。所谓分别，是指心、心所而言。在四缘中唯属不能作等无间缘，因为此缘，是唯以心、心所法相望而立的。现在只讲种子，所以必须除去等无间缘。

    本识种子容作三缘，一者为第八识中亲办自果的种子，便是因缘。二者为能缘种子的心、心所法，这种子便是他的所缘缘。三者如果有的种子，对于现行法的生起能够给予助力，或不起障碍，都是增上缘。以上所说的是种子，容作三缘生起现行，不但染法种子生染法现行是如此，应知净法种子生净法现行也是如此。

    论文三十：现起分别，展转相望，容作三缘，无因缘故。谓有情类自他展转，容作二缘，除等无间。自八识聚展转相望，定有增上缘，必无等无间。所缘缘义或无或有。八于七有，七于八无，余七非八所仗质故。第七于六，五无一有，余六于彼，一切皆无，第六于五无，余五于彼有，五识唯托第八相故。

    讲解：以上说的，是以种望现为缘，能生分别。现在说的，是以现望现为缘，能生分别。无论自他相望，或自识相望，容许作三缘，于四缘中要除去因缘，只有等无间缘、所缘缘、增上缘。不过这三缘也有取舍，其取舍条件有五：一者有情类的自身，与他身展转相望，容作二缘。因为等无间缘是唯自类一识，这里是说自他相望兼摄见、相二分，所以在三缘中要除去等无间，但取所缘缘和增上缘。二者在自身的八识与其相应心所，及相、见分等的同聚法中，此聚与彼聚展转相望，决定有通于一切的增上缘；必无一识相望的等无间缘。就是所缘缘，也是在或有或无的未定之数。所缘缘是怎样的或有或无呢？第八识对于其余的七识有所缘缘，前七识对于第八无所缘缘。因为前七识不是第八识所依仗的本质。第七识望于第六识和前五识没有所缘缘义，前六识望于第七识都没所缘缘义。因为五识不缘第七，意识通绿一切法，第七不缘余六之故。第六意识望于前五识没有所缘缘，前五识于第六识则有所缘缘。因为前五识唯托第八识的相分为所缘境，不仗托意识之故。

    论文三十一：自类前后，第六容三，余除所缘，取现境故。许五后见缘前相者，五、七前后亦有三缘。前七于八所缘容有，能熏成彼相见种故。

    讲解：三者自身八识，各个自类前后相望，若是第六识聚的前念生后念，除因缘外容有三缘；其余七识，除因缘和所缘缘外，只有二缘，因为它们只缘现境。也容许五识后念见分，缘前念相分为所缘缘，并非但缘现境，所以五识及第七识的前后念，也同第六识一样的具有三缘。至于第八识何以没有所缘缘？那是因为他只是所熏，而不是能熏，所以它的前念相分，不是后念见分的所缘缘。

    在自身的八识相望中，前七望于第八，也容有所缘缘义，因为前七识都是能熏识，能熏成第八的相、见种子。如前五识能熏成第八的相分种，即是第八见分的所缘缘。第七识能熏成第八的见分种，是为第八自证分的所缘缘。如第六识若缘第八相、见为能熏，便能熏成第八的相、见二分种子，即是第八见分及自证分的所缘缘。

    论文三十二：同聚异体展转相望，唯有增上。诸相应法所仗质同，不相缘故。或依见分，说不相缘，依相分说有相缘义。谓诸相分互为质起，如识中种，为触等相质。不尔，无色彼应无境故。设许变色，亦定缘种，勿见分境不同质故。

    讲解：四者一识的俱时心、心所法，虽为同聚，而体用各异，在这同聚异体的彼此之间，展转相望，唯有增上，而无所缘。因为诸相应法，所仗以现起影像的本质，同为阿赖耶识之所变，他们都是同一所缘，没有互相为缘的意义。

    另有一种解释，或依见分的同聚心、心所说，那是不能互相为缘的，因为没有那个见分能缘同时的其他见分。若依相分来说，那就有相缘的意义了。因为一切相分都是互为本质而生起的。如本识中的诸法种子，同时为触等五遍行心所的相分本质。如果不是这样，那无色界人的触等心所，就无境可缘了。既然有境，那境必是仗著本识所变的质而生起的。纵许无色界的第八识能够变色，那触等五个心所，也同本识是一样的决定缘种。不可说第八王、所六个见分境不同本质，当知从诸相分容互为质说，所以有相缘义。

    论文三十三：同体相分，为见二缘，见分于彼，但有增上，见与自证相望亦尔。余二展转，俱作二缘。此中不依种相分说，但说现起互为缘故。

    讲解：五者同一心所的相、见等分，叫做同体。同体的相分，能为见分作所缘缘、增上缘二种缘。若是见分于彼相分，那就只有增上一缘，而没有所缘缘了，因为相分没有缘境的作用。见分与自证分相望，也是这样，见望自证，能为二缘，自证望见，但有增上。因为见分有时非量，它不能缘自证的现量境故。其余的自证分与证自证分，展转相望，都有所缘缘、增上缘二缘，因为它们都是现量所得，有互相为缘的功用。

    种子也属相分，为什么不说见分与种子互缘呢？应知这不是依种子为相分来说的，不过是说现行与现行互相为缘而已。

    论文三十四：净八识聚，自他展转皆有所缘，能遍缘故。唯除见分非相所缘，相分理无能缘用故。既现分别缘种现生，种亦理应缘现种起，现种与种能作几缘？种必不由中二缘起，待心、心所立彼二故。现于亲种具作二缘，与非亲种但为增上。种望亲种亦具二缘，于非亲种亦但增上。

    讲解：现行染八识聚，展转为缘之理，已如上述。现在说现行净八识聚展转为缘。净八识聚，无论是自身、他身，或自身八识的异体、同体，展转相望，都有所缘。因为究竟清净的佛果八识，能遍缘一切法故。但在同体的四分法中，要除去见分望于相分的非所缘缘。因为按道理说，相分是本识的亲所变相，它没有能缘的作用。

    既然现行分别，由其种子及现行而生，那种子按道理说，也应当由现行及种子而起。然则能生的现行、种子，给所生的种子作几缘呢？种子必定不由四缘中的等无间、所缘缘二缘而起，因为那中间二缘，是待心、心所为果而建立的，种子不是心、心所，所以它不由二缘生起。既然不由中间二缘生起，当然是由初后的因缘、增上缘二缘而起了。现行对于它亲自所熏的种子，具有因缘和增上二缘，若与非自亲所熏种，那就只有增上一缘了。种子望于亲所生种，亦具有因缘及增上二缘，若于异性的非亲种，也只有增上一绿。

    论文三十五：依斯内识互为缘起，分别因果理教皆成。所执外缘设有无用，况违理教，何固执为？虽分别言，总显三界心及心所，而随胜者，诸圣教中多门显示，或说为二、三、四、五等。如余论中，具广分别。

    讲解：依此内识的种子与现行，互为缘起，在理教上都能够成立。至于所执的心外之缘，莫说没有，有亦无用，况且违背理教。既然如此，何必要那样固执呢？颂中所说的‘彼彼分别’的话，虽是总显三界的心、心所法，然而随其偏胜而言，在一切圣教中曾以多门显示，或说为二、或说为三、或说为四、五不等，这在后面的三自性中，当为详释。余如《瑜伽》、《显扬》等论里，都有很多的说明。


第五章 释违理难．有情生死相续的由来

    第五章 释违理难．有情生死相续的由来

    论文一：虽有内识，而无外缘，由何有情生死相续？颂曰：由诸业习气，二取习气俱，前异熟既尽，复生余异熟。

    讲解：有问曰：‘虽然有内识，如果没有外缘的话，为什么三界有情，生死、死生，相续不断，难道说不是由于外缘之力吗？’颂中的答覆，前二句是说明生死相续之由；后二句是说明如何相续。

    论文二：论曰：诸业，谓福、非福、不动，即有漏善、不善、思业，业之眷属亦立业名，同招引满异熟果故。此虽才起无间即灭，无义能招当异熟果。而熏本识起自功能，即此功能说为习气，是业气分熏习所成，简曾现业，故名习气。如是习气，展转相续，至成热时，招异熟果，此显当果，胜增上缘。

    讲解：这以下是以论文来解释颂义。颂文首句曰‘由诸业习气’，诸业就是：福业、非福业、不动业，也就是有漏善、不善、思业。福，就是感得人天善趣的异熟总报，及顺五趣受的善业别报。非福，就是感得三恶趣的异熟总报，及顺五趣受的不善业别报。不动，就是感得色、无色界的异熟总报，及顺色、无色界受的禅定别报。业的眷属也立业之名，因为它们和业一样，能够招感总报和别报。这种业刚生起马上就消灭，无别义理能够招感当来真异熟果。现行之业当造之时，熏于本谶，生起自业之功能，这功能就是颂文所说的习气，因为这种功能是业的气分，这就是习气一名的由来。这习气是由现行熏习而来，它不同于萨婆多部过去有体的‘曾业’，也不同于顺世外道所说的一切果唯现业所得，所以称为习气。这种习气展转相续，到成熟的时候就能招感或总、或别的异熟报果，这表示习气是当来得果的增上缘。与亲能辨果的因缘不同。

    论文三：相见、名色、心及心所、本末，彼取皆二取摄。彼所熏发，亲能生彼本识上功能，名二取习气，比显来世异熟果心，及彼相应诸因缘种。俱谓业种二取种俱，是疏亲缘互相助义，业招生显，故颂先说。

    讲解：这是解释第二句颂文‘二取习气俱’。二取有四说，一者相、见二取，所取的相，及能取的见。二者名、色二取，即五蕴中的色蕴，受、想、行、识四无色蕴，即名。三者心及心所二取，一切五蕴，都不离心、心所法。四者本、末二取，取第八识的总报为本，取余识的别报为末。以上的四种二取，都属于颂文中的二取所摄。彼所熏发在根本识上那亲能生彼自果的功能，叫做二取习气。这表显二取习气，是未来世的异熟心，及彼相应诸法亲能办果的因缘种子，与业种子不同。

    ‘二取习气俱’的‘俱’字，是说诸业及二取种子，都能俱时感生自果。诸业种子，是感果的增上疏绿；二取种子，是生果的亲因缘，他们有互相为助的意义。二种虽是俱时，而业种子的感招生果力显，所以颂中先说业种子，后说因缘。

    论文四：前异熟者，谓前前生业异熟果；余异熟者，谓后后生业异熟果。虽二取种受果无穷，而业习气受果有尽，由异熟果性别难招，等流、增上性同易感。由感余生业等种熟，前异熟果受用尽时，复别能生余异熟果。由斯生死轮转无穷，何假外缘方得相续？此颂意说：由业、二取，生死轮回皆不离识，心、心所法为彼性故。

    讲解：这是解释后二句颂文，即‘前异熟既尽，复生余异熟’。所谓前异熟，不但是前世一生，也是前世之前多生的业感异熟报果。所谓‘后异熟’，不但是后世一生，也是后世之后多生的业感异熟报果。虽二取种子受果无穷，而业习气受果有尽。因为异熟果，在性别上业是善恶，果是无记；在招果上他必待异世成熟，方能得果，所以业习气受果有尽。等流和增上二果，一则性同，即业是善恶，果亦善恶；二则易感，即于熏成种子的同时，便能生果，所以二取种子受果无穷。

    为要感得当来余生业种，及二取种子的成熟，所以现在身中的前异熟果，到临终受用尽时，又能别生来世的余异熟果。由此业果不断，有情的生死轮转无穷。何必要假藉外缘才能生死相续呢。

    由上所讲，可知颂文的意思是：由于业及二取为因缘，从生死轮回都不离识，并不是心外之法使之生死相续。因为生死因果，是以心、心所法为体性的缘故。

    论文五：复次，生死相续，由诸习气，然诸习气总有三种：一、名言习气，谓有为法各别亲种。名言有二，一、表义名言，即能诠义音声差别。二、显境名言，即能了境心、心所法。随二名言所熏成种，作有为法各别因缘。二、我执习气，谓虚妄执我、我所种。我执有二，一、俱生我执，即修所断我、我所执。二、分别我执，即见所断、我我所执。随二我执所熏成种，令有情等自他差别。三、有支习气，谓招三界异熟业种。有支有二，一有漏善，即是能招可爱果业。二者诸不善，即是能招非爱果业。随二有支所熏成种，令异熟果善、恶趣别。应知我执有支习气，于差别果，是增上缘。

    讲解：再者，有情的生死相续，并非由于外缘，而是由一切习气之所使然。然而习气虽多，总说只有三种，第一种是名言习气，就是生起一切有为法的各自直接种子。名言种亦有二种，一者是表义名言，就是能诠表义理的音声差别。二者是显境名言，就是在前七识里，除去相分心外，其余能够了境的心、心所法。随著这表义、显境二种名言所熏成的种子，作为有为法亲办自果的各别因缘。

    第二种是我执习气，就是虚妄执著我及我所，熏成自他差别的种子。但这我执亦有二种，一是俱生我执，即修道位所断那第六、七识所执的我及我所。二是分别我执，即见道位所断的那第六意识所执的我及我所。随著这俱生、分别二种我执所熏成的种子，能使一切有情，有自、他的差别，所以叫做我执习气。

    第三种是有支习气，就是能招三界异熟果报的善、恶业种。但这有支亦有二种，一者是有漏善有支，就是能招人天善趣可爱果的业种。二者是诸不善有支，就是能招三恶趣非可爱果的业种。随著这有漏善、不善二种有支所熏成的种子，令异熟报果有善趣和恶趣的差别。

    以上这三种习气，我执习气和有支习气，在不同的果报上都是增上缘。

    论文六：此颂所言业习气者，应知即是有支习气；二取习气应知即是我执、名言二种习气，取我、我所及取名言而熏成故，皆说名取。俱等余文，义如前释。

    讲解：这颂中所说的‘诸业习气’，应知指的就是有支习气说的。至于‘二取习气’，应知指的就是我执、名言二种习气。因为二取习气，是取著我和我所，及取著名言而熏成的，所以都说为取，名二取习气。至于颂中其余的文义，都同前面的解释一样，这里就不再费词了。


第六章 惑、业、苦与十二有支

    第六章 惑、业、苦与十二有支

    论文一：复次，生死相续，由惑、业、苦，发业润生烦恼名惑，能感后有诸业名业，业所引生众苦名苦。惑、业、苦种皆名习气，前二习气与生死苦为增上缘，助生苦故，第三习气，望生死苦能作因缘，亲生苦故。颂三习气，如应当知。惑苦名取，能、所取故，取是著义，业不得名。俱等余文，义如前释。

    讲解：再者，有情的生死相续，并非由于外缘，而是出于惑、业、苦之所致。能够发业的是分别烦恼，滋润业种使之受生的，是俱生烦恼，这发业润生的烦恼就叫做惑。能招感后有总别报果的一切造作，就叫做业。业所引生的三苦、八苦，就叫做苦。

    由这现行惑、业、苦所熏成的种子，都叫做习气。前二种的惑、业习气，望生死苦果为增上疏缘。因为他们对于苦果，只能助生而不能亲生之故。第三种的苦习气，望生死苦果能作因缘。因为他能办体亲生苦故。

    颂中所说的三种习气，那二取习气，就是这里所说的惑、苦种子；业习气就是这里所说的业种子了。何以惑、苦二者名取，而业不名取呢？因为惑是能取，苦是所取，所以惑、苦都名为取。取是执著的意思，业非执著，所以他不得名之为取。至于‘俱’等其余的文义，同于前释，勿劳再说。

    论文二：此惑业苦，应知总摄十二有文，谓从无明乃至老死，如论广释。然十二支略摄为四，一、能引支：谓无明、行，能引识等五果种故。此中无明，唯取能发正感后世善、恶业者，即彼所发乃名为行。由此一切顺现受业，别助当业，皆非行支。

    讲解：应知这惑、业、苦，总包括十二有支，即是无明、行、识、名色、六入、触、受、爱、取、有、生、老死。这在《瑜伽论》上有详细解释。然而十二支可以略为四支，即一者能引支，就是无明、行，能够引生识、名色、六入、触、受五支果报的种子。但这里所说的无明，不同于常途所说，而是唯取能够引发正感后世善、恶总业者，至于那不能发业，或助感别业的无明，则非其所取。即这种无明所发正感后世善、恶总业，就叫做‘行’。由此当知，一切不感当果的顺现受业，以及唯助当果的别报业，都不是这能引支中的行支所摄。

    论文三：二、所引支：谓本识内，亲生当来异熟果摄识等五种，是前二支所引发故。此中识种谓本识因，除后三因，余因皆是名色种摄；后之三因，如名次第，即后三种。或名色种，总摄五因，于中随胜立余四种。六处与识总别亦然。集论说识亦是能引，论中业种名识支故，异熟识种名色摄故。经文识支通能所引，业种识种俱名识故，识是名色依，非名色摄故。识等五种由业熏发，虽实同时，而依主伴、总别、胜劣、因果相异，故诸圣教假说前后，或依当来现起分位有次第故，说有前后。由斯识等亦说现行，因时定无现行义故。复由此说生引同时，润未润时必不俱故。

    讲解：第二是所引支，就是第八识里亲生当来异熟果的识、名色、六入、触、受五果种子，因为他们都是前无明、行二支所引发的，所以叫做所引支。这五支中的识种，就是本识之因，也就是阿赖耶识的因缘种子。除了后三因外，其余的前二因，都属于名色种摄。后之三因，如其名称的次第，就是六入、触、受。或以名色种总摄五因，于中随其殊胜，建立了其余识、处、触、受四支种子，六入和识种，总别之义也是如此。六入与识的总别，准此亦然。也就是说，六入种与识种，也一样的可以总摄五因，随其殊胜，建立其余的四种。

    《集论》说识也是能引支，因为识中的业种子称为识支，异熟识的种子属于名色种子。《缘起经》说识支通能引支和所引支，业种子和识种子都称为识，识是名色的所依，并不属于名色。识等五支由业所熏发，感招之位虽然同时，但主伴、总别、胜劣、因果之相不同，所以诸圣人之教假说前后，或依当来生起分位，或依现在已起分位，因为次第而说识等五支前后不同。所以，《十地经论》等说，识等五支也有现行，因为在因位时肯定没有现行的意思。因此，《缘起经》又说生与引同时，润与未润肯定不能同时。

    论文四：三、能生支：谓爱取有，近生当来生老死故。谓缘迷内异熟果愚，发正能招后有诸业为缘，引发亲生当来生老死位五果种已，复依迷外增上果愚，缘境界受，发起贪爱，缘爱复生欲等四取，爱取合润，能引业种及所引因，转名为有，俱能近有后有果故。有处唯说业种名有，此能正感异熟果故。复有唯说五种名有，亲生当来识等种故。

    讲解：第三是能生支，就是爱、取、有三支，因其能近生当来生与老死的二苦果故，所以叫做能生支。有情在受内异熟时，由于迷内异熟果的无明，对后世的住、老死苦，不能如实了知，随其所应就发正能招感后有的诸业（行支），以此诸业为增上缘，引发当来生、老死位的识等五果因缘种。进一步复又依于迷外增上果的无明，以境界受为缘，发起贪爱烦恼（爱支），以爱为缘，复又生起欲取、见取、戒取、我语取等的四取（取支）。由这爱取和合的资润，能引业种及所引因的五种，就转名为有了。

    但为什么叫做有呢？因为这六类种子都能直接产生最近未来的结果。有的地方唯说业种名之为有，因为它能直接招感异熟果的关系。又有的经论说识、名色、六入、触、受五法种子称之为有，因为它们能够直接产生未来的识等。

    论文五：四、所生支：谓生、老死，是爱、取、有近所生故。谓从中有，至本有中，未衰变来皆生支摄，诸衰变位总名为老，身坏命终乃名为死。

    讲解：第四是所生支，就是生及老死二支。因为这二支是直接由爱、取、有三支的近所生果。意谓从中有初生以后到本有，未衰变位都是生支，衰变现象来到名之为老，身坏命终，乃名为死。

    论文六：老非定有，附死立支。病何非支？不遍定故。老虽不定，遍故立支。诸界趣生除中夭者，将终皆有衰朽行故。名色不遍，何故立支？定故立支，胎、卵、湿生者，六处未满，定有名色故。又名色支，亦是遍有。有色化生初受生位，虽具五根而未有用，尔时未名六处支故。初生无色虽定有意根，而不明了，未名意处故。由斯论说，十二有支，一切一分上二界有。

    讲解：有情不一定活到老，也有中途夭亡的，所以附属于死，共立为一支。

    外人问曰：病，为什么不立一病支呢？论主答曰：因为病不遍三界、五趣，并且不是定有。老虽然不定有，但由于它是普遍的有，所以立支。诸界、诸趣、诸生，除中途夭逝者外，临终之时，根、识都都会衰朽，显出老态，所以为立老支。

    外人复问：名色并非普遍存在，为什么要立支呢？论主答曰：名色是决定有，而且也是普遍有，色界化生的有情，在初生时虽已具足五根，但还没有生触的作用，此时但称名色，不名六处；初生于无色界的有情，虽定有意根，而思量尚不明了，但有名及色种依识而转，尚不称意处。由此《瑜伽论》说：十二有支在欲界全有，在色界、无色界各有一部分。

    论文七：爱非遍有，宁别立支？生恶趣者，不爱彼故。定故别立，不求无有。生善趣者定有爱故，不还润生爱虽不起，然如彼取定有种故。又爱亦遍，生恶趣者，于现我境亦有爱故。依无希求恶趣身爱，经说非有，非彼全无。

    讲解：外人问：爱并不是普遍的有，何以别立为一支呢？如生恶趣的有情，并不爱彼苦报啊！论主答称：爱虽非普遍，但决定是有，所以别立为支。怎知决定有呢？除了求无后有及生恶趣者外，其余不求无后有及生善趣者，都决定有爱。不还果人生地润生，虽然不起现爱，然而如彼自身取支一样，定有爱的种子。这不过是随问而答，并非尽理，还有依正理的解释：爱不但定有，而且也是遍有，因为生恶趣的有情，虽于未生当生的苦报不起爱欲，然而于已生的现我身境却不能无爱。经上依于没有希求当生恶趣身的爱，才说生恶趣没有爱起，并不是说恶趣有情诸爱全无。

    论文八：何缘所生立生老死，所引别立识等五支？因位难知差别相故，依当果位别立五支。谓续生时因识相显，次根未满名色相增，次根满时六处明盛，依斯发触，因触起受，尔时乃名受果究竟。依此果位立因为五，果位易了，差别相故，总立二支以显三苦。然所生果若在未来为生厌故，说生老死。若至现在，为令了知分位相生，说识等五。

    讲解：所生的是果，所引的是因。以因望于现行的果，因有多少，果亦应有多少。为什么所生只立生老死二支，而所引立有识等五支呢？论主回答：因为在因位，很难知其差别之相，所以经典上才依著当生的果位，别立因支为五。意谓于当来初生之时果识初起，即是因识相显。于次识位五根未满以前，名色相貌增长，至五根满时，因名、色而六处明盛，依此六处发触，因触起受，这时方名为受果究竟。即依识、名色、六入、触、受这当起果位的次第，立因支为五。

    所生果位，因其差别相容易了知，所以总立生、老死二支，来显示行苦、坏苦、苦苦的三苦──生显行苦、老显坏苦、死显苦苦。然而，这所生的果若在未来，为令有情生厌离心故，所以才说生、老死二支，若至现在，为令有情了知生、老死的分位生相之故，所以才说识等五支的差别。

    论文九：何缘发业总立无明，润业位中别立爱、取？虽诸烦恼皆能发润，而发业位无明力增，以具十一殊胜事故。谓所缘等，广如经说。于润业位爱力偏增，说爱如水，能沃润故。要数灌溉方生有芽。且依初后，分爱取二，无重发义，立一无明。虽取支中摄诸烦恼，而爱润胜，说是爱增。

    讲解：外人问：一切烦恼都能发业、润业，为什么在发业位中总立无明，在润业位中别立爱、取呢？论主答曰：虽然一切烦恼都能发业，然而在发业位中所有烦恼都没有无明的功力增胜，因为它具有十一种殊胜事件（注：十一殊胜事是：所缘胜、行相胜、因缘胜、等起胜、转异胜、邪行胜、相状胜、作业胜、障碍胜、随转胜、对治胜。）虽然各种烦恼皆能润生，但于润业位爱力偏增，因为圣教皆说爱有如水，能沃能润。经过多次濯溉才能使它生芽。而且依初后分爱、取支，发业之义不可重发，立一无明、如一芽生。虽然取支当中包括各种烦恼，但爱润生殊胜，故说爱增胜。

    论文十：诸缘起支皆依自地，有所发行依他无明，如下无明发上地行。不尔，初伏下地染者，所起上定应非行支，彼地无明犹未起故。从上下地生下上者，彼缘何受而起爱支？彼爱亦缘当生地受，若现若种，于理无违。

    讲解：外人问：诸缘起支，都是依自地缘起呢，还是亦依他地？论主答：虽然诸缘起皆依自地，但有所发行，也得依他地无明，如以下地无明发上地行者便是。否则的话，那初伏下地染，所起的未到上定，就应该不是行支了。因为上地无明，要到根本定后，才能生起，此时既无无明，他如何能发为行支。

    外人再问：有情从现在的上地，当生下地，或从现在的下地，当生上地时，他们是缘当生地的受，还是缘现居地的受？论主答曰：都缘，不但缘现居地受，而且也缘当生地受。无论是俱时的现行受，或前时的种子受，都于理无违。

    论文十一：此十二支，十因二果，定不同世。因中前七，与爱取有，或异或同。若二、三、七，各定同世。如是十二，一重因果，足显轮转及离断常，施设两重实为无用，或应过此，便致无穷。

    讲解：十二支的前十支是因，后二支是果，约一期生死为一世而论，这十二支的十因二果，定不同世。至于因中的前七支，与爱、取、有三支，或者异世，或者同世，则不一定。十二支中，生、老死二支，爱、取、有三支，无明、行、识、名色、六处、触、受七支，各各决定同世。这样的十二有支，只设立一重因果关系，就能说明轮回的理论，并脱离断见和常见。像说一切有部理论施设两重因果关系，实在无用。或者应更超过三世两重因果，这就犯无穷过失。

    论文十二：此十二支义门别者：九实、三假。已润六支，合为有故，即识等五，三相位别，名生等故。五是一事，谓无明、识、触、受、爱五，余非一事。三唯是染，烦恼性故。七唯不染，异熟果故。七分位中，容起染故，假说通二，余通二种。无明、爱、取，说名独相，不与余支相交杂故，余是杂相。六唯非色，谓无明、识、触、受、爱、取，余通二种。皆是有漏，唯有为摄，无漏无为，非有支故。

    讲解：此下是把十二有支，分作十六门来解释：一者假实分别门：前九支是实，后三支是假。何以说后三支是假？因为爱、取所已润的行、识、名色、六入、触、受六支种子，合名为有，即此六支中的识等五种子，于现起时所显那生、异、灭三相的分位差别，就叫做生、老死，这有、生、老死的后三支，都没有实在的自体，所以说之为假。

    二者一非一事门：十二支中有五支是各唯一事，非二别体，就是无明、识、触、受、爱五支。其余的七支，如：行通善染，取通余惑等，都非一事。

    三者染不染门：染是染污，不染是善、无记。无明、爱、取三支唯是染污，因为它们是以烦恼为体性。识等五支，及生、老死二支，这七支唯是不染，因为他们的体性是无记的异熟总果。但在现行的分位中，也容或起染，而体实非染，所以《瑜伽论》假说通染、不染二。其余的行通善、染；有通善、染、无记，所以说‘余通二种’。

    四者独杂分别门：无明、爱、取三支，说名独相。因为他们纯以自体为支，不与余支相交杂故。其余九支，都是杂相。原因是他们以行等六支转名为有、生、老死的，这样六转名三，三揽六成，岂不都成为杂相了吗。

    第五是色非色门：十二支中，无明、识、触、受、爱、取这六支唯是心法，所以说‘六唯非色’。其余行等六支，通色、心二法，所以说‘余通二种’。

    六者有漏有为无漏无为门：十二有支都是有漏，都属于有为法。因为无漏法没有缘起的意义，所以不是有支。

    论文十三：无明、爱、取，唯通不善、有覆无记，行唯善、恶，有通善、恶、无覆无记。余七唯是无覆无记，七分位中，亦起善、染。虽皆通三界，而有分有全。上地行支能伏下地，即粗苦等六种行相，有求上生而起彼故。一切皆唯非学无学，圣者所起有漏善业，明为缘故，违有支故，非有支摄。由此应知，圣必不造感后有业，于后苦果不迷求故。杂修静虑资下故业，生净居等，于理无违。

    讲解：七者三性门：无明、爱、取三支通不善及有覆无记。行支唯通善、恶，不通无记，因为无记不能感果。有支通善、恶、有覆无记三性，因为有支是行等六支所合。其余识等五支及生、老死二支，唯是无覆无记，因为这七支都是异熟性，假使是现起分位的话，那他也通善、恶。

    八者三界分别门：十二有支，虽说皆通三界，而分、全不等，欲界摄十二支全；色无色界各有一部分。所以论说欲界具一切支，色无色界一切一分。

    九者能治所治门：上地的行支，能伏下地烦恼。什么是上地行支？就是观下界的十二支为粗、苦、障；欣求上界为静、妙、离的六种行相，而求生上界者，为断下界烦恼所起的观行，所以是上地行支。

    十者学等分别门：谓十二有支，都非有学及无学，而是非学、非无学的异生，不通有学及无学，因为学、无学是与流转相违的，如初果以上的圣者，虽有所起的有漏善业，但他们以无漏明慧为缘所起，与有支相违，所以不属有支所属。由此应知圣者肯定不造招感后有的业，因为圣者们于后有苦果不迷不求。于此有一问题，不还果等杂修五净居业，是不是行支，若是行支，圣便造业；若不是行支，它如何能感生净居天的总报？答曰：当知不还的圣者，杂修第四静虑，以无漏资助所造的有漏事业，由净居以下的无云等三天而生于净居天，这业不是圣者所造，于道理不相违背的。

    论文十四：有义，无明唯见所断，要迷谛理能发行故，圣必不造后有业故。爱取二支唯修所断，贪求当有而润生故，九种命终心，俱生爱俱故，余九皆通见修所断。有义：一切皆通二断。论说预流果，已断一分有支，无全断者故。若无明支唯见所断，宁说预流无全断者？若爱、取支唯修所断，宁说彼已断一切支一分？又说全界一切烦恼皆能结生，往恶趣行，唯分别起烦恼能发，不言润生唯修所断，诸感后有行，皆见所断发。

    讲解：十一者是三断门：此有二种异说。第一师说：无明唯是见道所断。因为必须要迷于谛理的无明，才能发为行业，圣者必定不造后有业故。假使不是见道所断，那见道就不能照见真理，圣者也不能不造后有业了。爱、取二支唯是修道所断。因为贪求后有而是以爱、取为润生的；九种命终心（注：三界有情临命终时，各有润生三爱），都与俱生的润生爱俱起之故。假使不是修道所断，阿罗汉何以不受后有？其余九支，皆通见、修所断。

    第二师说：十二有支，一切都通见、修所断。因为《瑜伽论》上说：预流果已断一切一分有支，并没有一支一支的完全断尽。假使无明是唯见所断的话，那论上为什么不说预流果全断一切有支，而说无全断呢？假使爱、取二支是唯修所断的话，那论上为什么说预流果未断一切支，而说已断一切支的一分呢？又说：全界一切烦恼都能结生；往恶趣行，唯是分别所起的烦恼能发。既不说润生烦恼唯修所断，而说全界烦恼都能结生，怎知爱、取二支是唯修所断？既不说一切趣感后有行，都是由见道所断的烦恼所发，而说往恶趣行为分别烦恼所发，怎知无明是唯见所断。

    论文十五：由此故知无明、爱、取三支，亦通见修所断。然无明支正发行者，唯见所断，助者不定，爱、取二支正润生者，唯修所断，助者不定。又染污法自性应断，对治起时彼永断故。一切有漏不染污法，非性应断，不违道故。然有二义说之为断：一、离缚故，谓断缘彼杂彼烦恼。二、不生故，谓断彼依令永不起。依离缚断说有漏善、无覆无记唯修所断，依不生断，说诸恶趣，无想定等唯见所断。说十二支通二断者，于前诸断如应当知。

    讲解：第二师继续申张正义曰：由以上所说的道理，应当知道不但其余九支，即是此无明、爱、取三支，亦通见修所断。然而无明对于发行，有正、助之别，若是正发行的，唯见所断；若是助发行的，则不一定，因为论说往恶趣行，唯分别惑发，就是显示助发人天总报的业行，亦通修断。爱、取二支对于润生，也有正、助之别：若是正润生的，唯修所断；若是助润生的，也不一定。因为论说全界一切烦恼都能结生，四取俱名为取，所以亦通见断。

    有问曰：所谓十二支通见、修二断，是怎样的断法？一切不善及有覆无记的染污是自性应断；因为这染法种子，到了对治的无漏明法起时，他就永远的断绝了。一切善及无覆无记的有漏不染污法，非性应断，因为他们与无漏圣道并不相违。不过这善无记法，虽非性应断，然而有二种意义，也可以说之为断：一是离缚断：就是断缘彼烦恼，断杂彼烦恼。什么叫做断缘彼烦恼？随七转识缘彼有漏善法等境所生的烦恼，叫做‘缘彼烦恼’：能缘的烦恼断时，说所缘的善法等境名为得断，叫做‘断缘彼烦恼’。

    什么叫做断杂彼烦恼？有漏善法为烦恼所引而成，如六识所起的善法，就是依第七识的烦恼而成为有漏的，这就叫做‘杂彼烦恼’。第七识的烦恼断时，也说六识善法名为得断，叫做‘断杂彼烦恼’。除了离缚断之外，二是不生断：此有二义：一者，断彼因依，令果不生。如三恶趣果，因依见惑；见惑因断，则果永不生。二者，断彼果依，令因不起。如三恶趣的别报善业，果依见惑，见惑果断，则因永不起。

    依前‘离缚断’的缘故，所以《瑜伽论》上说：有漏善法及无覆无记，唯是修道所断。依后‘不生断’的缘故，所以又说：一切恶趣的异熟趣体，及无想定、无想天等，唯是见道所断。至于《瑜伽》等论说十二有支通二断者，于前诸断中如无明、爱、取三支，通见、修二断，亦通自性断。其余见修所断的染污者，通自性断：不染污者，通离缚、不生二断，这是应当知道的。

    论文十六：十乐舍俱，受不与受共相应故，老死位中，多分无乐及客舍故。十一苦俱，非受俱故。

    讲解：十二者是三受分别门：在这十二支中，除受、老死二支以外，其余十支，与乐受和舍受相应，因为受不与受相应。老死位中大部分无乐及客舍。十二支中，除受支以外的十一支与苦受相应，因为受不与受相应。

    论文十七：十一少分坏苦所摄，老死位中多无乐受，依乐立坏，故不说之。十二少分苦苦所摄，一切支中有苦受故。十二全分行苦所摄，诸有漏法皆行苦故。依舍受说，十一少分，除老死支，如坏苦说。实义如是，诸圣教中，随彼相增，所说不定。

    讲解：十三者是三苦分别门：十二有支，除老死外，其余十一支的少分，为乐事离去的坏苦所摄，因为老死位中多分没有乐受，今依乐受变坏建立坏苦，所以不说老死亦为坏苦所摄。十二支的少分为苦事所成的‘苦苦’所摄。原因是一切支中都有苦受。十二支的全分为迁流无常的‘行苦’所摄，因为诸有漏法，无非都是行苦。若依三受门的舍受来说行苦，除老死支外，其余十一支的少分为行苦所摄，其义同坏苦所说。

    以支摄苦的体相，实义不过如此，但在诸圣教中，或但约果，或通因果，随义相增的说法就不一定了。

    论文十八：皆苦谛摄，取蕴性故。五亦集谛摄，业烦恼性故。

    讲解：十四者是四谛门：十二有支都属于苦谛所摄，因为它们是以烦恼生蕴，蕴生烦恼的有漏‘取蕴’为性。其中行、有、无明、爱、取五支属于集谛，因为行、有二支是业性，无明、爱、取三支是烦恼性，都有集谛的招感义。

    论文十九：诸支相望增上定有，余之三缘有无不定，契经依定唯说有一，爱望于取，有望于生，有因缘义。若说识支是业种者，行望于识亦作因缘。余文相望无因缘义。而集论说无明望行有因缘义，依无明时业习气说。无明俱故假说无明，实是行种。瑜伽论说诸支相望无因缘者，依现爱取唯业有说。无明望行，爱望于取，生望老死，有余二缘。有望于生，受望于爱，无等无间，有所缘缘。余支相望二俱非有。此中且依邻近顺次，不相杂乱实缘起说。异此相望为缘不定。诸聪慧者如理应思。

    讲解：十五者是四缘门：十二支一一相望，四缘中的增上缘是决定有的：其余三缘有、无不定。契经上唯说有一增上缘者，就是依这决定有的意义而说的。爱支望于取支，有支望于生支，有因缘的意义。若以对法说识支是业种的话，则行支望于识支，识也可以作为行的因缘。除此之外，余支相望，都没有亲生因缘的意义。

    然而《集论》上说，无明望行有因缘义者，那是依无明俱时的思业习气而说的。因为业习气是与无明俱时的。《瑜伽论》说爱、取、有三支无因缘义，那是依现行的爱、取，及唯业种的有来说的，并非依种的爱、取，及识等五种的有而说。

    无明望行、爱望于取、生望老死，这三支不但有增上缘，且亦有等无间缘及所缘缘。若是有望于生、受望于爱，那就没有等无间，唯有所缘缘了。其余如行望于识，乃至触望于受、取望于有，则二缘俱无。因为他们都不是现行的心、心所相引生的，所以没有等无间：不是能缘虑心，所以没有所缘缘。

    此处所说诸支相望为缘，是依邻近、顺次、因果前后不相杂乱、实缘起的四个条件而说的。异此相望，则为缘不定。一切聪明智慧的人，应如理而思。

    论文二十：惑业苦三摄十二者：无明爱取是惑所摄，行有一分是业所摄，七、有一分是苦所摄。有处说业全摄有者，应知彼依业有说故。有处说识业所摄者，彼说业种为识支故。惑业所招独名苦者，唯苦谛摄为生厌故。由惑业苦即十二支，故此能令生死相续。

    讲解：第十六是三道门：惑、业、苦三道包括十二有支，无明、爱、取三支，是惑所摄。行支及行所润的一分是业所摄，识、名色、六入、触、受、生、老死七支全部，和有的一部分是苦所摄。《瑜伽论》上说业全摄有，应知这是依业有而说的。

    《集论》上说识也是为业所摄，意思是说业的种子为识支。何以惑业不名为苦，唯其所招的当果独名为苦呢？因为惑业亦属集谛，所招的当果唯苦谛摄。又为使有情对苦生厌，不再起惑造业之故，所以独以所招名之为苦。

    由于这惑、业、苦三，就是十二支的缘故，能令有情生死轮回，相续不断。

    论文二十一：复次、生死相续，由内因缘，不待外缘，故唯有识。因谓有漏、无漏二业正感生死，故说为因。缘为烦恼、所知二障助感生死，故说为缘。所以者何？生死有二：一、分段生死：谓诸有漏善、不善业，由烦恼障缘助势力，所感三界粗异熟果。身命短长随因缘力，有定齐限，故名分段。

    讲解：再者，有情的生死相续，由于内部因缘，不需要外部条件，所以说唯有识。什么是内部因缘，因就是有漏和无漏二业，因为这二业能正感生死，所以说名为因。缘就是烦恼障所知障，因为这二障能助二业招感生死，所以说名为缘。为什么要这样分别？因为生死有二种，一者分段生死，二者变易生死：一、分段生死：就是一切有漏善、不善业的正因，由烦恼障助缘的势力，所感三界的粗异熟果。由于因缘之力，身体和寿命的长短，都有一定的齐限，不得错乱。所以名为分段生死。

    论文二十二：二、不思议变易生死：谓诸无漏有分别业，由所知障缘助势力，所感殊胜细异熟果，由悲愿力改转身命，无定齐限，故名变易。无漏定愿正所资感，妙用难测，名不思议。或名意成身，随意愿成故，如契经说，如取为缘，有漏业因续后有者而生三有，如是无明习地为缘，无漏业因，有阿罗汉、独觉、已得自在菩萨，生三种意成身。亦名变化身，无漏定力转令异本，如变化故。如有论说，声闻、无学永尽后有，云何能证无上菩提？依变化身证无上觉，非业报身，故不违理。

    讲解：二、不思议变易生死：就是一切无漏后得的有分别业为亲因，由所知障助缘的力势，所感殊胜的细异熟果。这细异熟果，能由悲愿力改变身命的长短，没有一定的限度，所以名为变易。由无漏定愿的正所资生，正所感得妙用难测，非凡夫二乘所能计度，所以名不思议。也可以称为意成身。因为这生死果是随著大悲意愿之所成。

    《胜鬘经》上说：如果以取为缘（即烦恼障缘），以有漏业为因，继续后有者，便生三界之有：如果以无明习地为缘（即所知障缘），以无漏业为因，那就有阿罗汉、独觉、已得自在菩萨，生这三种的意成身了。这不思议变易生死，亦名变化身。因为由无漏定力，转令异于本有的分段身，清净微妙，如变如化故。这变化身，虽是从喻得名，亦不违理，例如《显扬论》上说：声闻、无学果等，他们已永尽后有，不再受分段生死，如何能不住涅槃，不厌生死，自行化他，证无上菩提呢？当知他们是依变化身证无上觉的，并不是业报身证得的，所以变化身从喻得名，并不违理。

    论文二十三：若所知障助无漏业能感生死，二乘定性应不永入无余涅槃。如诸异生拘烦恼故。如何道谛实能感苦？谁言实感？不尔、如何？无漏定愿，资有漏业，令所得果相续长时，展转增胜，假说名感。如是感时，由所知障为缘助力，非独能感。然所知障不障解脱，无能发业润生用故。何用资感生死苦为，自证菩提利乐他故。谓不定性独觉、声闻，及得自在大愿菩萨，己永断伏烦恼障故，无容复受当分段身。恐废长时修菩萨行，遂以无漏胜定愿力，如延寿法资现身因，令彼长时与果不绝，数数如是定愿资助，乃至证得无上菩提。

    讲解：有外人问曰：假使以所知障为助缘，无漏业能感变易生死的话，那二乘定性声闻就应当不能永入无余涅槃。论主答曰：二乘定性，为所知障所拘碍，驰流于无相涅槃，不趣无上正等菩提，那就像所有有情众生，虽有无漏种，但由于所知障所拘碍，驰流生死，不趣涅槃一样。

    外人又问：前说无漏正感生死，那无漏道谛，为什么实际上能招感生死苦报呢？答曰：谁说道谛实际上能感苦报？外人复问：如果不是这样，感义又是如何呢？答曰：由第四禅的无漏胜定，资有漏业，令其所得的果，相续长时，新新不绝，展转增胜，实则是有漏业感，不过由于无漏的资助力胜，假说名感而已，并不是无漏实能感苦。这样无漏感时，还得由所知障作为缘助，并不是无漏业独能感果。然所知障，但障菩提，不障解脱，因为他没有无明烦恼发业润生的功用。

    外人再问：二乘无学，他们尽此报身必永入灭，为什么还用资感生死苦呢？因为要自证菩提，利乐有情，所以要资感生死。就是不定性的独觉、声闻，以及得了自在的大愿菩萨，他们这些二乘已永断烦恼障：菩萨已永伏烦恼障，都无容再受当来的分段身了。然而又恐怕分段报尽，会废弃了长时修自他二利的菩萨大行，遂以无漏的胜定愿力，好像阿罗汉的延寿法一样，资助那能感现身的宿世业因，令其长时与果不绝。这样数数以定愿资助，乃至经三大劫之久，证得了无上菩提。

    论文二十四：彼复何须所知障助？既无圆证无相不悲，不执菩提有情实有，无由发起猛利悲愿。又所知障障大菩提，为永断除留身久住。又所知障为有漏依，此障若无彼定非有，故于身住有大助力。

    讲解：外人问曰：那些不定性二乘、自在菩萨，既以无漏定愿，资助现身的先业，令果不绝，又何须再以所知障的助力，方能感得此果呢？

    论主答曰：既然还没有圆满证得无相大悲，如果不执著于实际菩提可以求得，有情众生可度，就没有理由发起猛利大悲和誓愿。而且，所知障障碍大菩提，为了永远断除它，留身久任，说之为缘。而且这种所知障是一切有漏之依，这种所知障若无，那种能依的一切有漏肯定没有。所以对于变易生死身的久任，有很大的助力。

    论文二十五：若所留身，有漏定愿所资助者，分段身摄，二乘异生所知境故。无漏定愿所资助者，变易身摄，非彼境故。由此应知变易生死，性是有漏，异热果摄，于无漏业是增上果。有圣教中说，为无漏出三界者，随助因说。

    讲解：如果所留身，是三界有漏业和有漏愿所资助者，那便是属于分段生死，因为这是定性二乘，和有情众生所知之境。如果所留身，是无漏定及无漏愿所资助者，那便是妙用难测的变易生死。这不是二乘和有情众生所知之境。由此我们应知，这变易生死的性是有漏，属于五果之一的异熟果，于无漏业是增上果。于有的圣教中说，这变易生死，是无漏出三界者，那是随著无漏业的助因来说的，而其体实非无漏。

    论文二十六；颂中所言诸业习气，即前所说二业种子。二取习气即前所说二障种子，俱执著故。俱等余文义如前释。变易生死，虽无分段前后异熟别尽别生，而数资助前后改转，亦有前尽余复生义。虽亦由现生死相续，而种定有，颂偏说之。或为显示真异热，因果皆不离本识，故不说现。现异熟因，不即与果。转识间断，非异熟故。

    讲解：《唯识三十颂》中所说的‘诸业习气’，是这前面所说的有漏、无漏二业种子，也就是能感二种生死的因。颂中所说的‘二取习气’，就是前文所说的烦恼、所知二障种子，也就是能助二种生死的缘。因为障、取俱是执著，所以障亦名取，俱等余文，等是‘前异熟既尽，复生余异熟’等余文的意义，都同前面最初的解释一样。不过，问题在于，变易年死，不如分段别死别生，怎么可以说‘前异熟既尽、复生余异熟’呢？圣者的变易生死，虽然不同于分段那样的前后异熟别尽别生，而由于无漏定愿的数数资助，令后身命展转改易而胜于前，亦有前尽余复生的意义．

    外人又问：颂中何以不说生死相续亦由现行，而唯说习气呢？论主答：虽然亦由现行生死相续，但种子相续决定一切时有，不同于现行的间断，所以颂中偏说种子即业习气。或为显示真异熟因为本识所藏而成熟为果，这因果都不离本识，现行则否，所以不说现行。现行的善恶等法，虽然也是异熟因，但所熏的种子不能即时与果，须待异时方能与果，所以但说种子。六转识的现行，虽然也是异熟果，也不离识，而转识间断，非真异熟，不过是异熟生而已。所以颂中偏说第八识习气，而不说现行。

    论文二十七：前中后际，生死轮回，不待外缘，既由内识，净法相续，应知亦然。谓无始来，依附本识有无漏种，由转识等数数熏发，渐渐增胜，乃至究竟得成佛时，转舍本来杂染识种，转得始起清净识种，任持一切功德种子。由本愿力尽未来际，起诸妙用，相续无穷。由此应知唯有内识。

    讲解：过去、现在、未来的前中后三际，有情的生死轮回，既是不待外缘，但由内识，染法的相续是这样的，净法的相续应知也是这样。何以言之？无始以来依附于木识的无漏种子，由于前七转识的一再熏发，逐渐增胜，乃至究竟得成佛时，便转舍了本来有漏的杂染识种，转得了始起于本识的无漏清净识种，任持一切功德种子，由佛本有的大誓愿力，尽未来际生起一切利他妙用，相续无穷。由此所说的染、净道理，我们当知诸法相续，唯有内识。非由外缘。


第七章 释违教难．三种自性

    第七章 释违教难．三种自性

    论文一：若唯有识，何故世尊处处经中，说有三性？应知三性亦不离识。所以者何？颂曰：由彼彼遍计，遍计种种物，此遍计所执，自性无所有。依他起自性，分别缘所生，圆成实于彼，常远离前性。故此与依他，非异非不异，如无常等性，非不见此彼。

    讲解：外人问曰：如果唯有内识，没有外境，那就是唯有一性，何以世尊在处处经中说有三性呢？论主答曰：你应当知道，所说的三性亦不离识，并不是说性有三，便非唯识。为什么呢？《唯识三十颂》上说：‘由彼彼遍计，遍计种种物，此遍计所执，自性无所有。依他起自性，分别缘所生，圆成实于彼，常远离前性。故此与依他，非异非不异，如无常等性，非不见此彼。’颂文的意思是说：由于有情世间和器世间的种种分别活动，遂有各种各样事物的产生，实际上这些事物，都是一般人的虚妄计度，并没有其本身的自性，这叫做遍计所执性。依他起性，是仗著不同的因缘而生。圆成实性就是在依他起法上，永远远离遍计所执性。所以圆成实性和依他起性，既非有异，亦非不异，如无常等性，圆成实性不被见时，依他起性也见不到。

    论文二：论曰，周遍计度，故名遍计，品类众多，说为彼彼。谓能遍计虚妄分别。即由彼彼虚妄分别，遍计种种所遍计物。谓所妄执蕴处界等，若法若我自性差别。此所妄执自性差别，总名遍计所执自性。如是自性，都无所有，理教推征，不可得故。

    讲解：以下是各家解释颂文的意义。首先是难陀对第一颂的解释，他认为：一般人的心识，普遍认为客观事物实有，所以称为‘遍计’，心识品类众多，颂文说为‘彼彼’，此即能遍计的虚妄分别。也就是由各种心识的虚妄分别，普遍计度各种所遍计之物，就是人们所虚妄执著的五蕴、十二处、十八界等，不管是法还是我的自性差别。这种所虚妄执著的自性差别，总称为遍计所执自性，而这种自性都是不存在的，从佛的教诲和佛法教理中仔细推论，都没有这种自性。

    论文三：或初句显能遍计识，第二句示所遍计境，后半方申遍计所执若我若法自性非有，已广显彼不可得故。

    讲解：其次是护法、安慧等的解释。他说：‘由彼彼遍计’一句，是显示能遍计的识。‘遍计种种物’一句，是显示所遍计的境。后半颂‘此遍计所执，自性无所有。’才是申张遍计所执心外我、法的自性非有。

    论文四：初能遍计自性云何？有义，八识及诸心所有漏摄者，皆能遍计，虚妄分别为自性故，皆似所取能取现故，说阿赖耶，以遍计所执自性妄执种为所缘故。

    讲解：有问曰：颂文初句是能遍计，此能遍计的自性是什么呢？以下有安慧、护法二家异解。第一家安慧认为：八识心王及各种心所有法，只要不是无漏，凡属于有漏者都是能遍计。因为有漏心是以虚妄分别为自性，又都似所取、能取之相在显现，《瑜伽》、《显扬》等论都说：第八阿赖耶识，以遍计所执自性的妄执种子，为自己所缘之境。以此证明，所以有漏心都能遍计。

    论文五：有义：第六、第七心品执我法者，是能遍计。唯说意识能遍计故，意及意识名意识故，计度分别能遍计故，执我、法者，必是慧故，二执必与无明俱故，不说无明有善性故，痴无痴等不相应故，不见有执导空智故，执有达无不俱起故，曾无有执非能熏故。有漏心等不证实故，一切皆名虚妄分别。虽似所取能取相现，而非一切能遍计摄，勿无漏心亦有执故，如来后得应有执故。经说佛智现身土等种种影像，如镜等故，若无缘用，应非智等。虽说藏识缘遍计种，而不说唯，故非诚证。由斯理趣，唯于第六、第七心品，有能遍计。识品虽二，而有二、三、四、五、六、七、八、九、十等遍计不同，故言彼彼。

    讲解：而第二家护法认为：并不是一切心都是能遍计，只有执我、执法的第六、第七识是能遍计，为什么只有六、七二识是能遍计呢？这有十种理由可以证明：一者，《摄大乘论》唯说意识是能遍计，假使一切心都能遍计，何以摄论不说呢？二者，摄论说意识，事实上包括第七识在内，因为第七称意，第六称意识，二者合称意识，所以说意识是能遍计，就包含了六、七两识在内。三者，有计度分别的是能遍计，而第六、七两识有计度分别，他识则无，所以此二识是能遍计。四者，唯有执我执法的第六、七二识，必与慧俱，是能遍计，余识无慧，他们怎能遍计？五者，我、法二执，是染而非善，他必与无明俱起。六者，《瑜伽》等论都没有说过无明有善性的话。七者，若说一切有漏皆名不善，不过说行相轻微的不善名之为善，那也不对！痴与无痴这两个性质相违的法，是不能相应俱起的。八者，若说痴相轻微的名为无痴，那也不对，那加行心，不也成为轻微的痴相了吗？凡有痴即必有法执，他如何能引导空智使之现前？谁见过有执心能导空智来？九者，加行心随顺圣教作我、法空观，名为达无，既有法执，应名执有，这执有的心与达无的智如何能够俱起？可见加行心决无法执。十者，假使有漏心都有法执，那第八异熟心，不也成为能熏了吗？因为凡有执心都有能熏的势用，从来没有有执心不是能熏的。然而实际上第八异熟，并非能熏，只是所熏而已，所以他不是能遍计。

    如果是这样，那《楞伽》、《中边》等，何以说三界八识都是虚妄分别呢？原因有三：一者有漏心等，虽也能作空观假相，而不能像无漏一样能证实理，所以一切八识，都名为虚妄分别，并不是虚妄分别都是执心。二者，虽有漏心也有依他相似的所取能取相现，而不是一切有漏都能遍计。唯有计度分别的六、七两识，才是能遍计。若似二取都是有执，岂不是无漏心也有执吗？因为如来的后得智，也像菩萨二乘一样的有似二取相，难道说如来的无漏心也有执不成？若说如来的后得智没有似二取相，那便有违背圣教的过失！因为《佛地经》上说，佛智能现身土等种种影像，如：平等性智、妙观察智、成所作智、大圆镜智等，既能现种种影像，岂不是都有似二取吗？这证明无漏心是有相分的。既有相分，必有见分，若无见分，便无缘用，若无绿用，那如来智就应当不是智品所摄了。三者若有漏心都非有执，如何说藏识缘遍计种？

    虽说藏识缘遍计种，而不说唯，既不说唯缘遍计种子，那就是第八识所缘的种子，除遍计外，还有其他。所以他不能证明有漏心都是遍计。由于以上所说的种种理由，所以前五识及第八识都没有能遍计，唯独有漏的第六、第七两识才有能遍计。

    这里所说的遍计，虽只有第六、第七这二种识品，但《摄大乘论释》等还说有二至十等之多的遍计不同：二种遍计是：自性计（眼等色根）、差别遍计（常、无常等）。三种遍计是：我、法、用。四种遍计是：自性、差别、有觉、无觉。五种遍计是：依名计义、依义计名、依名计名、依义计义、依名义计名义。六种遍计是：自性、差别、觉悟、随眠、加行、名遍。七种遍计是：有相、无相、任运、寻求、伺察、染污、不染污。八种遍计是：自性、差别、总执、我、我所、爱、不爱、爱不爱俱违。

    九种遍计是：爱、恚、慢、无明、见、取、疑、嫉、悭。十种遍计是：根本分别（第八识）、缘相分别（缘虑之时）、显相分别（眼等识）、缘相变异分别、显相变异分别、他引分别（闻不正法）、不如理分别（外道）、如理分别（正法），执著分别（我见）、散动分别。此外种种乃至无量等的遍计，实难烦引。

    论文六：次所遍计自性云何，摄大乘说是依他起，遍计心等所缘缘故。圆成实性宁非彼境？真非妄执所缘境故。依展转说亦所遍计。遍计所执虽是彼境，而非所缘缘，故非所遍计。

    讲解：初能遍计的自性已如上说，其次，所遍计的自性又是怎么样呢？《摄大乘论》说所遍计的自性就是依他起自性，因为遍计心等以此为所缘缘。有问曰：圆成实性为何不是遍计所缘的境呢？答曰：依他起是虚妄法，所以是遍计的亲缘相分，圆成实性真实，所以不是妄执的亲缘相分。问：遍计所执的境，何以不名所遍计？答：无法名境，所缘缘只局于有法而不是无法，所以所执的虽是遍计心境，而不是所缘缘，既不是所缘绿，那当然也不是所遍计了。

    论文七：遍计所执其相云何？与依他起复有何别？有义：三界心及心所，由无始来虚妄熏习，虽各体一，而似二生，谓见、相分，即能、所取。如是二分，情有理无，此相说为遍计所执。二所依体，实托缘生，此性非无，名依他起，虚妄分别缘所生故。云何知然？诸圣教说，虚妄分别是依他起，二取名为遍计所执。

    讲解：遍计所执的体相是什么样子呢？他同依他起又有什么分别呢？此有两家异解。第一师安慧认为：三界有情的心及心所，由无始来的虚妄熏习，他们各自的体，虽是一个自证分，但似依他见、相二分而生，这二分就是所谓的能、所二取。如是二分，在妄情上似有，但教理上实际是无，此相据《辩中边论》说是遍计所执。

    其次，这见、相二分所依的自证分体，是仗因托缘而生，这托缘而生的就称为依他起。因为是仗托著虚妄分别的种子因缘所生之故。所以一切经论上都说：虚妄分别，是依他起，能、所二取，是遍计所执，这是有根据的。

    论文八：有义：一切心及心所，由熏习力所变二分，从缘生故，亦依他起。遍计依斯妄执定实有、无、一、异、俱、不俱等，此二方名遍计所执。诸圣教说，唯量唯二种种，皆名依他起故。又相等四法、十一识等，论皆说为依他起摄故。不尔，无漏后得智品二分，应名遍计所执，许应圣智不缘彼生，缘彼智品应非道谛，不许应知有漏亦尔。

    讲解：第二师护法认为，一切有漏、无漏，染与不染的心及心所，由熏习力所变的见、相二分，都是从因缘生，所以也是依他起。遍计心依此见、相二分，妄执为真实的有、无、一、异、俱、不俱等，这样的见相二分才名叫遍计所执。因为《摄大乘论》等说：唯识之量，与属于唯识的见、相二分，以及见、相二分的种种行相，都叫做依他起。还有五法中，除第五如如外的其余的四法，十一识，《瑜伽论》等说是依他起依所摄。不然的话，佛等无漏后得智品所变相、二分，应当称为遍计所执。如果允许无漏二分也是遍计所执，则圣者的后得智就不是缘彼依他起的二分所生，能缘依他所有智品应非道谛，若不许圣者非遍计所执，应知有漏心也是这样。（注一：论文中的相等四法，即五法前四的相、名、分别、正智。论文中的十一识，即摄大乘论所说的：一身识、即眼、耳、鼻、舌、身五色根。二身者识，即第七末那识。三受者识，即意根。四，彼所受识、即六尘。五彼能受识、即六识。六世识，即时间。七数识，即数目。八处识，即有情众生的住处。九言说识，即语言。十自他差别识，即自已与他人的差别。十一善、恶趣死生识，即有情众生的生死流转。）

    论文九：又若二分是遍计所执，应如兔角等非所缘缘，遍计所执体非有故。又应二分不熏成种，后识等生应无二分。又诸习气是相分摄，岂非有法能作因缘？若缘所生内相见分非依他起，二所依体例亦应然，无异因故。由斯理趣，众缘所生心、心所体，及相、见分，有漏、无漏皆依他起，依他众缘而得起故。

    讲解：如果有漏的见、相二分都是遍计所执，就应当像兔角一样的不是所缘绿，因为所缘绿是有体之法，遍计所执是无体之法。再者又如你所执的见、相二分，决定不能熏习成种，因为遍计是无体之法，他好像石女不能生儿一样，到后来识等生时，就应当没有见、相二分。然而后识生时非无二分，可知二分并不是遍计所执。而且，一切有漏习气是相分所摄，其体为非有之法，又怎能作因缘呢？假定从缘所生不离于识的相、见二分不是依他起，那二分所依依他起的自证分体，依例也应当同二分一样的不是依他起，因为它们都是因缘种子所生，并没有什么差别的。

    由于以上所说这道理与义趣，所以众缘所生的心、心所体，及相、见二分，无论是有漏、无漏，都是依他起。因为是依他众缘而得生起的缘故。

    论文十：颂言，分别缘所生者，应知且说染分依他。净分依他亦圆成故。或诸染净心、心所法皆名分别，能缘虑故。是则一切染净依他，皆是此中依他起摄。

    讲解：颂中所说的‘分别缘所生’句，应知这是唯说染分依他，为分别法的因缘所生。何以不说净分？因为净分依他就是圆成实性。或者一切染净的心、心所法都称分别，因为它们都能缘虑之故，所以一切染、净依他，都是这颂中所说的依他起摄了。

    论文十一：二空所显圆满成就诸法实性，名圆成实，显此遍常体非虚谬。简自共相、虚空、我等。无漏有为离倒究竟，胜用周遍，亦得此名。然今颂中说初非后。此即于彼依他起上，常远离前遍计所执，二空所显真如为性。说于彼言，显圆成实与依他起不即不离。常远离言，显妄所执能、所取性理恒非有，前言义显不空依他，性显二空非圆成实，真如离有离无性故。

    讲解：遍计所执、依他起，已如上文所说，现在该讲三性中的圆成实性了。什么叫做圆成实性？二空所显示的圆满、成就、和诸法实性，称为圆成实性，事实上就是真如。真如具备以下三义：一、圆满，是显示真如体遍，一切处有。二、成就，是显示真如体常，非生灭法。三、诸法实性，是显示真如实体，并非虚谬。如此说来，那净分的依他起，体非常遍，它如何也通圆成实性呢？因为净分依他，是无漏有为，他也具有如下三义：一者，是离于颠倒虚妄的实义。二者，是究竟能断一切染法的成义。三者，是胜用周遍，无境不缘的圆义。这三义同于真如，所以也得名为圆成实性。然而，因为净分依他不是证得的法性，故在颂中，说初真如名圆成实，非后净分。这圆成实，就是在彼依他起上，常常远离了前面的遍计所执，而以人、法二空所显的真如为自性。

    第三句颂中所说的‘于彼’二字，是显示圆成实与依他起的体是不即不离。何以说是不即？若即，就应当真如有灭，依他无生。然而真如并非有灭，依他也并非无生，所以说是不即。何以又说不离？若离，就应当真如不是依他之性，离依他外别有如性了，然而如性并不是离依他而别有，所以又说不离。第四句颂中所说的‘常远离’三字，是显示虚妄的遍计所执是能、所取性，并非暂无，理恒非有，所以说是常远离。‘前’字的意义，是显示空的是前面的遍计所执，不空依他起。‘性’字，是显示圆成实是二空所显的真如，而二空并非即是圆成实。因为真如是离有离无，若说二空就是圆成实，则是真如虽离于有，而尚未离于无了。

    论文十二：由前理故，此圆成实与彼依他起，非异非不异。异应真如非彼实性，不异此性应是无常。彼此俱应净非净境，则本后智用应无别。云何二性非异非一？如彼无常无我等性。无常等性与行等法异，应彼法非无常等，不异，此应非彼共相。由斯喻显此圆成实与彼依他，非一非异。法与法性理必应然，胜义、世俗相待有故。

    讲解：由前面所说道种，这圆成实性与依他起性既非异，亦非不异。若相异，即真如应非彼之实性，若不异，即此真如性应无常，所以说非一非异。再者，圆成实是净的根本智境，依他起是净通非净的后得智境，假使二体是一，彼依他起与此圆成实的境，都应当是净通非净，这样，则根本智与后得智的照用，就应当没有差别了。

    圆成实与依他起二性，是怎样的非异非一？这譬如无常、无我等性与行等诸法一样，若说无常等性与行等诸法是异，那行等诸法就应当不是无常等性了。然而行等诸法，却是生灭无常，所以说是非异。若说是一，那这无常等就应当不是彼行等诸法的共相了，然而无常等却是行等诸法的共相，与自相不同，所以说是非一。由此譬喻来显示这圆成实性与彼依他起性的非一非异。依他起的法与圆成实的法性，在道理上必然是这样的。因为圆成的胜义，与依他的世俗，是相待而立的。俗待真有，真待俗有，并不是像龟毛兔角一样说非一非异。

    论文十三：非不证见此圆成实，而能见彼依他起性。未达遍计所执性空，不如实知依他有故。无分别智证真如已，后得智中方能了达依他起性如幻事等。虽无始来，心、心所法已能缘自相、见分等，而我法执恒俱行故，不如实知众缘所引自心、心所虚妄变现，犹如幻事、阳焰、梦境、镜像、光影、谷响、水月、变化所成　非有似有。

    依如是义，故有颂言：非不见真如，而能了诸行，皆如幻事等，虽有而非真。

    讲解：这是解释第四句颂‘非不见此彼’，圆成、依他证见的次第。不能说未证得圆成实性，就能见到那依他起性，在没有达到所执性空之时，就不能如实了知依他起性之有。无分别智证得真如以后的后得智中，才能了达依他起性是如幻事等。虽然一切异生无始以来的心、心所已能缘其各自的相、见分等（注：见分缘相分，自证分缘见分及证自证分，证自证分缘自证分。）然而由于我、法二执恒时与心俱行之故，不能如实了知依他众缘所引的自心、心所是虚妄变现，犹如幻事、阳焰、梦境、镜像、光影、谷响、水月的变化所成，非有似有。依据此义，所以《厚严经》中有伽它说：‘非不见真如，而能了诸行，皆如幻事等，虽有而非真。’意思是说并非不证见真如，而能了达诸行无常，都如幻事等一样，所以虽有而不是真有。

    论文十四：此中义说三种自性，皆不远离心、心所法。谓心、心所及所变现众缘生故，如幻事等非有似有，诳惑愚夫，一切皆名依他起性。愚夫于此横执我法，有无、一异、俱不俱等，如空华等性相都无，一切皆名遍计所执。依他起上，彼所妄执我法俱空，此空所显识等真性，名圆成实。是故此三不离心等。

    讲解：本章所诠释的三首颂文，其大概的意义，是说遍计所执、依他起、圆成实这三种自性，都不是离开心、心所法而别有的。怎样不离心、心所法？心、心所法的自证分，及其所变现的相、见二分，都是众缘和合所生，所以如幻事等，非有似有。诳惑愚夫，世人不了知这是如幻如化的假法，执为实有，这一切都名叫依他起性。

    彼诳惑的愚夫，在这依他起上横执我、法是有、是无，是一、是异，是有无一异俱、不俱等，如空华水月，性相都无，这一切都名叫遍计所执性。若在依他起上，了达其所妄执的我、法都空无所有，由此空理所显的识及心所，一切相分等的真性，就名叫圆成实性。以是之故，这遍、依、圆三性，都不离心、心所法。

    论文十五：虚空、择灭、非择灭等，何性摄耶？三皆容摄。心等变似虚空等相，随心生故依他起摄。愚夫于中妄执实有，此即遍计所执性摄；若于真如假施设有虚空等义，圆成实摄。有漏心等，定属依他，无漏心等，容二性摄。众缘生故，摄属依他，无颠倒故，圆成实摄。

    讲解：这一段论文，是说明六无为与三性相摄的关系，以下分十二门辨释摄属。第一无为相摄门。问，虚空、择灭、非择灭、不动、想受灭、真如这六种无为，属于三性的那一性所摄呢？答曰：三性都摄。何以见得呢？因为心、心所、见、相分等，由数数闻熏，变现出非有似有的虚空无为等相，这是随心分别的缘所生故，所以是依他起摄。愚夫不达，于此依他起中，妄执虚空等相谓为实有，这就是遍计所执性摄。若于真如理上，假藉名言施设有虚空无为等义，便是圆成实摄。

    若依有漏、无漏心说，那依他起义就不一定了。假如是有漏心所变的虚空等相，决定唯属依他；假如是无漏心所变的虚空等相，那就容属依、圆二性所摄了。为什么属二性所摄？众缘生故，摄属依他；无颠倒故，圆成实收。

    论文十六：如是三性，与七真如，云何相摄？七真如者：一、流转真如，谓有为法流转实性。二、实相真如，谓二无我所显实性。三、唯识真如，谓染、净法唯识实性。四、安立真如，谓苦实性。五、邪行真如，谓集实性。六、清净真如，谓灭实性。七、正行真如，谓道实性。此七实性圆成实摄，根本后得二智境故。随相摄者，流转、苦、集三，前二性摄，妄执杂染故。余四皆是圆成摄。

    讲解：这是第二的真如相摄门。这遍、依、圆三性，与七真如的相摄关系是怎样呢？七种真如是：一、流转真如，是一切有为法生灭流转的实性。二、实相真如，是由人、法二无我的空义所显的实性。三、唯识真如，是染、净法，随染净心而为染净的唯识实性。四、安立真如，是苦谛的实性。五、邪行真如，是能招感诸苦─集谛的实性。六、清净真如，是证得涅槃─灭谛的实性。七、正行真如，是修三无漏学─道谛的实性。

    这七种真如，是约能诠义说的，并不是真如的体有七种差别。若废诠言体，那就只有一如实性了。若约实性来说，这七种真如，都属圆成实摄。因为他们都是根本、后得二智之所缘境──实相、唯识、清净三如实性，是根本智境。其余的四如实性，是后得智境。若以随相来说，流转、苦、集三如，属三性的前二性所摄。因为这三如约妄所执说，都属遍计执摄。若约诠杂染说，那就都属依他起摄了。至于其余的实相、唯识、清净、正行四如，都属圆成实摄。因为他们都是圣智所显的圣境。

    论文十七：三性六法相摄云何？彼六法中皆具三性。色受想行识及无为皆有妄执缘生理故。

    讲解：这是第三的六法相摄门。三性与六法的相摄是怎样呢？六法当中都具三性。因为色、受、想、行、识、无为六法，都有妄执、缘生的道理。于前色等五蕴，妄执我、法，所以是遍计执摄；众缘所生，所以是依他起摄；自性本空，所以是圆成实摄。后一的无为，如前第一门说。

    论文十八：三性五事相摄云何？诸圣教说相摄不定。谓或有处，说依他起，摄彼相、名、分别、正智，圆成实性摄彼真如，遍计所执不摄五事。彼说有漏心、心所法，变似所诠说名为相，似能诠现施设为名，能变心等，立为分别，无漏心等，离戏论故，但总名正智，不说能所诠，四从缘生，皆依他摄。

    讲解：这是第四的五事相摄门。三性与五事的相摄关系如何呢（注：五事为相、名、分别、正智、如如。）圣教经典说法不一。如《瑜伽论》等说，依他起性摄相、名、分别、正智，圆成实性摄持真如，遍计所执性不摄五事。为什么五事之四都属依他起摄呢？因为《瑜伽论》等，是约诠门而说的，他说，有漏的心、心所法，变似所诠的义理，就说名为‘相’，变似能诠的言说，就施设为‘名’，能变所诠能诠的心、心所法，就立名‘分别’，有漏心等不离戏论，所以有能诠所诠，无漏心等离戏论故，但总名‘正智’，不说有能诠所诠的差别。这相、名、分别、正智四事，都从有漏或无漏心等的因缘所生，所以都属依他起摄。

    论文十九：或复有处，说依他起，摄相、分别，遍计所执，唯摄彼名，正智、真如圆成实摄。彼说有漏心及心所相分名相，余名分别，遍计所执，都无体故，为显非有假说为名，二无倒故，圆成实摄。或有处说，依他起性唯摄分别，遍计所执摄彼相、名，正智、真如圆成实摄。彼说有漏心及心所相、见分等，总名分别，虚妄分别为自性故，遍计所执，能诠所诠，随情立为名相二事。复有处说，名属依他起性，义属遍计所执。彼说有漏心、心所法相、见分等，由名势力成所遍计，故说为名，遍计所执，随名横计，体实非有，假立义名。诸圣教中所说五事，文虽有异，而义无违。然初所说不相杂乱，如《瑜伽论》广说应知。

    讲解：这是第五的五事相摄门，有问曰，三性、五事如何相摄？答曰：圣教中诸说不一。或复有处，如《瑜伽》、《显扬》等说，依他起性摄持相及分别，遍计所执唯摄名之一事，正智、真如二事，则属圆成实摄。为什么三性摄尽五事？因为《辨中边论》是依见、相而说的。它说，有漏心及心所的相分名‘相’，其余的自证及见分等，都叫做分别，此二者皆因缘所生，所以是依他起摄。遍计所执，都无实体，为了显示其实体非有，所以假说为‘名’。正智、真如，二无颠倒，体属无漏，所以是圆成实摄。

    或有处如《楞伽经》说：依他起性，唯摄分别一事。遍计所执，摄相、名二事，正智、真如二事，属圆成实摄。因为《楞伽经》对见、相分等，及能诠、所诠的解释不同。它说：有漏心及心所的相、见分等，总名分别，因为他们都是以虚妄分别为自性的，所以属依他起摄。遍计所执，于能诠、所诠，随著妄计的情执，假立能诠为名，所诠为相，而体实非有，所以相、名二事，属遍计执摄。

    又有处如《摄大乘论》上说：名之一事，属依他起性。义（注：相及分别）之二事，属于遍计所执。因为有漏心、心所法的相、见、自证、证自证分，由名势力的缘起成所遍计，所以名属依他起性。遍计所执，即随此名横计于义，而体实非有，不过假立义名而已，所以义属遍计所执性。

    以上诸圣教中所说五事，文虽不同，而各据一义，互不相违。然在四说之中，以最初瑜伽所说的较为清晰，不相杂乱。详细如《瑜伽论》的广说。

    论文二十：又圣教中说有五相，此与三性相摄云何？所诠能铨各具三性，谓妄所计属初性摄，相名分别，随其所应，所诠、能诠，属依他起，真如正智，随其所应，所诠能诠，属圆成实，后得变似能诠相故。二相属相唯初性摄，妄执义名定相属故，彼执著相唯依他起，虚妄分别为自性故。不执著相，唯圆成实，无漏智等为自性故。

    讲解：这是第五的五相相摄门。圣教经典中说有五相（注：五相为所诠、能诠、相属、执著、不执著。），这五相与三性的相摄关系是怎样呢？所诠、能诠二相，各具三性。就是妄所计的所诠诸法，能诠诸名，属于遍计所执性摄。相、名、分别三事随其所应，所诠、能诠属依他起摄。正智、真如二事，随其所应，所诠、能诠属于圆成实摄。

    无漏正智，非能诠相，何以能诠并属三性？因为后得的正智，也以变似能诠相故，所以所诠、能诠并属三性。第三的能诠、所诠二‘相属相’，唯属遍计所执性摄，因为妄计能诠的名及所诠的义，决定是相属之故。第四的执著相，唯属依他起摄，因为执著是以虚妄分别为自性的。第五的不执著相，唯属圆成实摄，因为不执著是以无漏二智及无为等为自性的。

    论文二十一：又圣教中说四真实，与此三性相摄云何？世间道理所成真实，依他起摄，三事摄故。二障净智所行真实圆成实摄，二事摄故。辨中边论，说初真实唯初性摄，共所执故。第二真实，通属三性，理通执无执，杂染清净故。后二真实，唯属第三。

    讲解：这是第六的真实相摄门。圣教中所说的四种真实，与此三性的相摄关系如何呢（注：四种真实，一者是世间所成真实，就是一切世间事物由名言决定自他差别。二者是道理所成真实，就是由思择决定所行所知之事，以证成的道理。三者是烦恼障净智所行真实，就是解脱了烦恼障，使四谛三无漏所行的真实。四者是所知障净智所行真实，就是解脱了所知障，依一切法空观智所行的真实。）《瑜伽论》，《对法论》等说：世间、道理所成的二种真实，属依他起所摄。因为这二种真实，是五事中的相、名、分别三有漏法之所摄故。烦恼、所知二障净智所行的二种真实，属圆成实所摄。因为这二种真实，是五事中的正智、真如二无漏法之所摄。

    《辨中边论》说：第一的世间所成真实，唯属遍计所执性摄。因为那是一切世间共同所执的实我、法故。第二的道理所成真实，通属三性所摄。因为道理通执与无执，执中有能执、所执：所执是遍计执性，能执是依他起性。无执中有杂染清净，杂染的无执是依他起性；清净的无执是圆成实性。后二障净智所行的二种真实，唯属第三的圆成实摄，义同前释。

    论文二十二：三性四谛，相摄云何？四中一一皆具三性。且苦谛中，无常等四，各有三性。无常三者，一、无性无常，性常无故。二、起尽无常，有生灭故。三、垢净无常，位转变故。苦有三者，一、所取苦，我、法二执所依取故。二、事相苦，三苦相故。三、和合苦，苦相合故。空有三者，一、无性空，性非有故。二、异性空，与妄所执自性异故。三、自性空，二空所显为自性故。无我三者，一、无相无我，我相无故。二、异相无我，与妄所执我相异故。三、自相无我，无我所显为自相故。

    讲解：这是第七的四谛相摄门。三性与四谛的相摄关系是如何呢？四谛中一一各具三性，且苦谛中的无常、苦，空、无我四行，亦各具三性。有三种无常，一、无性无常，因为体性常无，所以是遍计所执性。二、起尽无常，因为是依缘而起的有生灭法，所以是依他起性。三、垢净无常，因为垢净虽位有转变，而性非无常，所以是圆成实性。

    苦有三者，一、所取苦，因为是我、法二能执心之所取故，所以是遍计所执性。二、事相苦，因为一切事的缘起，是以苦苦、坏苦、行苦这三苦为相的，所以是依他起性。三、和合苦，因为真如虽与一切有漏的苦相和合，而性实非苦，所以是圆成实性。

    空有三者，一、无性空，因为自性非有，妄计为有，所以是遍计所执性。二、异性空，因为是有为的有体法，与无性的妄执有异，缘之为空，而体实非空，所以是依他起性。三、自性空，因为是以人、法二空所显之理为自性故，所以是圆成实性。

    无我三者，一、无相无我，因为我相本无，唯妄所执，所以是遍计所执性。二、异相无我，因为与妄所执的我相有异，所以是依他起性。三、自相无我，因为是以无我所显的理为自相，所以是圆成实性。

    论文二十三：集谛三者，一、习气集，谓遍计所执自性执习气，执彼习气，假立彼名。二、等起集，谓业、烦恼。三、未离系集，谓未离障真如。灭谛三者，一、自性灭，自性不生故。二、二取灭，谓择灭二取不生故。三、本性减，谓真如故。道谛三者，一、遍知道，能知遍计所执故。二、永断道，能断依他起故。三、作证道，能证圆成实故。然遍知道，亦通后二。七三三性，如次配释。今于此中所配三性，或假或实，如理应知。

    讲解：集谛三者，一、习气集谛，这是遍计所执自性，执有我、法的习气，体虽依他，而从因假立彼名为遍计所执性。二、等起集，由烦恼起业，由业起果，烦恼、业、果平等缘起，所以是依他起性。三、未离系集，即尚未离障的在缠真如，所以是圆成实性。

    减谛三者，一、自性灭，灭是不生义，遍计所执的自性是不生的，所以是遍计所执性。二、二取灭，依智慧择灭，使能、所二取灭而不生，所以是依他起性。三、本性灭，灭是寂灭，真如实性本来是寂灭的，所以是圆成实性。

    道谛三者，一、遍知道，能知遍计所执，从所知立名，名遍计所执性。二、永断道，即能永断依他，从所断立名，名依他起性。三、作证道，即能证圆成实，从所证立名，名圆成实性。然而遍知道既能遍知，当然不仅能知初性的遍计所执，亦通后二性的依他起、圆成实。

    以上所说苦谛下有四种三，集、灭、道三谛下各有一种三，这七种三与三性相摄，如其次第的配属，已如上所解释。其中或谛实而性假，或谛假而性实，如理应知。

    论文二十四：三解脱门所行境界，与此三性相摄云何？理实皆通，随相各一。空、无愿、相，如次应知。缘此复生三无生忍：一、本性无生忍。二、自然无生忍。三、惑苦无生忍。如次此三，是彼境故。

    讲解：这是第八的解脱相摄门。空、无愿、无相三解脱门所行的境，与三性的相摄是怎样呢？约总相说，三解脱门皆通三性，若缘依他起，了无遍计执，即是圆成实。圆成实性既是因空而显，便是空境，于此不起愿求，便是无愿境。若以空缘三性，那当然是无相境了。随别相说，三性与三解脱门，各一相摄。空解脱门，为遍计所执性摄，无愿解脱门，为依他起性摄，无相解脱门，为圆成实性摄。如次应知。

    缘此三性，又生三无生忍：一、本性无生忍，即缘遍计所执的本体是无生的。二、自然无生忍，即依他缘起，并非自然而生。三、惑苦无生忍，即证圆成实时，那惑、业、苦果就不会再生起了。如次的配属，这三性就是彼三无生忍的所缘境。

    论文二十五；此三云何摄彼二谛？应知世俗具此三种，胜义唯是圆成实性。世俗有三：一、假世俗。二、行世俗，三、显了世俗。如次应知即此三性。胜义有三：一、义胜义，谓真如，胜之义故。二、得胜义，谓涅槃，胜即义故。三、行胜义，谓圣道，胜为义故。无变无倒，随其所应，故皆摄在圆成实性。

    讲解：这是第九的二谛相摄门。这三性如何摄持那世俗、胜义二谛呢？应知世俗谛具此三性，胜义谛唯是圆成实摄。世俗有三，一是假世俗，实在没有体性可言，不过假名为世俗而已。这在四种世俗谛中，属于第一的假名无实谛。第二是行世俗，这是有为依他，也是行人证悟的方便法门，这在四种世俗谛中，属于第二的随事差别谛，及第三的方便安立谛。第三是显了世俗，这是断了染分依他，及遍计所执，所显的真如。在四种世俗谛中，属于第四的胜义谛。这三种世俗谛，如其次第，属于遍计、依他、圆成三性所摄。

    胜义有三：第一是义胜义，即妙体离言的真如，为最胜之义，在四种胜义谛中，属于第四的胜义胜义谛。第二是得胜义，涅槃是证得的胜境，胜即是义，在四种胜义谛中，属于第三的证得胜义谛。第三是行胜义，即圣道的无漏智，是以知苦、断集、证灭、修道的胜法为所缘义，在四种胜义谛中，属于第二的道理胜义谛。这三胜义谛的前二谛，是理无变易，后一谛，是智无颠倒。所以随其所应，都摄在圆成实性。

    论文二十六：如是三性，何智所行？遍计所执，都非智所行，以无自体，非所缘缘故。愚夫执有，圣者达无，亦得说为凡圣智境。依他起性，二智所行。圆成实性，唯圣智境。

    讲解：这是第十的凡圣智境门。如是三性，于凡、圣二智，是那一智所行呢？遍计所执性，都无凡、圣智之所行，因为它没有自体，不是二智的所缘缘。然而，在这遍计执上，愚夫执以为有，圣者了达是无，也得说他是凡圣智境。依他起性，为凡、圣二智之所行，但依他起有为法，只能说他是世间无漏圣智之境，非出世智。圆成实性，唯圣智境，不是凡智所能亲缘的。

    论文二十七：此三性中几假几实？遍计所执妄安立故，可说为假，无体相故非假非实。依他起性有假有实，聚集、相续、分位性故说为假有，心、心所色从缘生故，说为实有。若无实法假法亦无，假依实因而施设故。圆成实性唯是实有，不依他缘而施设故。

    讲解：这是第十一的假实门。这三性中，有几性是假，几性是实呢？第一遍计所执性，若从妄情安立而论，可说是假，若以法体无相而论，可说是非假非实。第二的依他起性，有假有实：假有三种，一种是聚集假，就是由多法聚集所成的假法，如情与非情。二种是相续假，在刹那生灭的三世因果相续上所立的假法，如佛说：‘昔者鹿王，今我身是’。三种是分位假，如不相应行，都是从色、心等法的分位上假施设的。由此三假之故，所以说为假有：心、心所、色等，因为是从缘生故，所以说为实有。因缘所生法，分明就是聚集假，何以说为实有？若无实法，假法亦无，假是依实为因而施设的，今从其依因为论，说之为实。第三的圆成实性，唯是实有，因为是胜义所摄，不是依他众缘而施设的。

    论文二十八：此三为异为不异耶？应说俱非，无别体故，妄执缘起真义别故。如是三性义类无边，恐厌繁文，略示纲要。

    讲解：这是第十二的异不异门。这三性是相异呢，还是不异呢？应当说是非异、亦非不异。何以说是非异？因为不了依他起，才妄计所执，并非离依他外，别有执遍计执性。若了知依他起，不妄计遍计执，便是圆成实，并非离依他外，别有实性。这遍、依．圆三无差别，所以说非异。何以说是非不异？因为遍计是妄执性，依他是缘起性，圆成是真义性，三性各各有别，所以说非不异。如是三性的义类，深广无边，恐厌繁文，仅作以上十二门辨，略示纲要。


第八章 释违教难．三种无性与唯识实性

    第八章 释违教难．三种无性与唯识实性

    论文一：若有三性，如何世尊说一切法皆无自性？颂曰：即依此三性，立彼三无性，故佛密意说，一切法无性。初即相无性，次无自然性，后由远离前，所执我法性。此诸法胜义，亦即是真如，常如其性故，即唯识实性。

    讲解：本章开始初举三颂，诠释三自性。此下三颂，前二颂释三无性，后一颂释唯识实性。有问曰：‘如果不离识而有三性者，为什么世尊说一切法都没有自性呢？这岂不是与教相违吗？’论主乃举三颂以答所问：第一颂总答，第二颂别答，第三颂明唯识性。这颂中的意义，以下论文自有广释。

    论文二：论曰：即依此前所说三性，立彼后说三种无性，谓即相、生、胜义无性。故佛密意说一切法皆无自性，非性全无。说密意言，显非了义，谓后二性虽体非无，而有愚夫于彼增益，妄执实有我、法自性，此即名为遍计所执，为除此执，故佛世尊于有及无总说无性。

    讲解：此下是以长行解释颂义，今先释第一颂。论上说：三无自性，并非由别观而立，即是依前面所说的遍计所执、依他起、圆成实三性，建立后面所说的三种无性：即相无性，生无性，胜义无性。因此佛密意说，一切法皆无自性。并不是连依他、圆成的二性全都没有了。密意的话，显示不是究竟了义，而是权宜方便的说法。

    如何是权宜方便？后二性的依他、圆成，虽自体非无，然而犹有不达二空的愚夫，在彼依他起、圆成实二自性上，横起增益，妄执本无自性的我、法，谓为实有，这就叫做遍计所执。为了除此妄执，所以佛世尊才依三性的有体无体，总说三种无性。实则这三无性，无的是遍计所执，而不是依他、圆成。

    论文三：云何依此而立彼三？谓依此初遍计所执，立相无性。由此体相毕竟非有，如空华故。依次依他，立生无性。此如幻事托众缘生，无如妄执，自然性故，假说无性，非性全无。依后圆成实立胜义无性。谓即胜义，由远离前遍计所执我、法性故，假说无性，非性全无。如太虚空，虽遍众色，而是众色无性所显。虽依他起非胜义故，亦得说为胜义无性，而滥第二，故此不说。

    讲解：怎样依此三自性，来建立那三无性呢？就是依据遍计所执建立相无性，因为这遍计所执的体相毕竟无有，好像病眼所见的空华一样。依据依他起性建立生无性，因为这依他起性，是仗托众缘所生，有如幻事一样。它不像外道那样，妄执诸法是自然所生的自然性，所以假说无性，并不是依他起的自性全无。

    依据三性最后的圆成实性，建立胜义无性。因为圆成实就是胜义，由于远离了前面遍计所执的我、法性故，所以假说无性，并不是圆成实的自性全无。就如虚空一样，虽普遍的含有众色（物质），但各种色都无自性，为色即是空之所显现。胜义亦然，虽是诸法实性，却是于依他起上，无遍计所执之所显现。虽然依他起为有体法，而非胜义，非即是无，所以也得说他为胜义无性。然而，若说依他为胜义无性，便与第二的圆成胜义无性相滥，所以但说圆成为胜义无性，不说依他起。

    论文四：此性即是诸法胜义，是一切法胜义谛故。然胜义谛略有四种：一、世间胜义，谓蕴、处、界等。二、道理胜义，谓苦等四谛。三、证得胜义，谓二空真如。四、胜义胜义，谓一真法界。此中胜义依最后说，是最胜道所行义故。为简前三故作是说：此诸法胜义，亦即是真如。真谓真实，显非虚妄；如谓如常，表无变易。谓此真实于一切位常如其性，故曰真如，即是湛然不虚妄义。亦言显此复有多名，谓名法界及实际等，如余论中随义广释。此性即是唯识实性，谓唯识性略有二种：一者虚妄，谓遍计所执。二者真实，谓圆成实性。为简虚妄，说实性言。复有二性，一者世俗，谓依他起。二者胜义，谓圆成实。为简世俗，故说实性。

    讲解：诠释第二颂竟，现诠释第三颂。这圆成实性，就是一切法的胜义谛。然胜义谛随法之浅深，有下列四种，一者是世间胜义，就是五蕴、十二处、十八界等。事相粗显，尚可破壤，所以名为世间：又为圣者之所知，胜于世俗谛的第一世俗，所以名为胜义。二者是道理胜义，就是苦、集、灭、道的四谛。为知、断、证、修的因果差别，所以名为道理：又是无漏智境，胜于世俗谛的第二世俗，所以名为胜义。三者是证得胜义，就是二空真如。此理依圣智所诠的空门而显，所以名为证得，又为凡愚所不测，胜于世俗谛的第三世俗，所以名为胜义。四者是胜义胜义，就是一真法界。妙体离言，超一切法，所以名为胜义，又是圣者内智，胜于世俗谛的第四世俗，所以又名胜义。

    此颂中所说的诸法胜义，是依最后的胜义胜义而说的，因为这是最胜道的行义，特为简非前三胜义，故作此说。这诸法胜义，也就是真如。真者真实，显示不是有漏虚妄的遍计所执；如是如常，表示不是无漏有为生灭变易的依他起。也就是说，这真实在一切法位上，是常如其性的，所以叫做真如。也就是澈法底源，湛然离倒的不虚妄义。颂中所说‘亦即是真如’的‘亦’字，是显示这真如，除本论所立名外，还有很多不同的异名，如无我性、空性、无相、实际、法界等。至于这些异名的意义，如其余的《对法论》、《显扬圣教论》中的随义广释。

    这圆成实性，就是唯识实性。为什么要说唯识实性？因为唯识性略有二种：一是虚妄唯识性，就是非有而遣的遍计所执。二是真实唯识性就是非空而证的圆成实性。为要遮简虚妄，所以才说实性的话。这唯识复有二性：一是世俗唯识性，就是断然后净的依他起。二是胜义唯识性，就是唯证所净的圆成实。为的要简别世俗，所以才说为实性。

    论文五：三颂总显诸契经中说无性言，非极了义。诸有智者不应依之，总拨诸法都无自性。

    讲解：《唯识三十颂》中的这三首颂文，纯是显示各部佛经中所说的‘无性’那句话，并不是究竟了义。以此告诫有智慧的人，不应依据不了义经，认为一切法都无自性。


第一章 总明五位

    第六篇 明唯识位．唯识五位修行

    （颂文第二十六颂至三十颂）

    第一章 总明五位

    论文一：如是所成唯识相性，谁于几位，如何悟入？谓具大乘二种性者，略于五位渐次悟入。何谓大乘二种种性？一、本性住种性，谓无始来依附本识，法尔所得无漏法因。二、习所成种性，谓闻法界等流法已，闻所成等熏习所成。要具大乘此二种性，方能渐次悟入唯识。

    讲解：《唯识三十颂》的三十首颂文，已经诠释二十五颂。其中前二十四颂成唯识相，第二十五颂成唯识性。有问曰：如是所成的唯识相、性，在五乘不同的种性中，都是那些种性的人，经过几层阶位，才能悟入呢？答曰：具有大乘二种种性的人，大略经过五层阶位可以渐次悟入。什么是大乘二种种性？一是本性住种性，是指无始以来，依附在阿赖耶识法尔自然所得的无漏法之因，非由熏习，不自今有，所以名为本性住种性。二是习所成种性，就是闻听从法性流出，与法性相似的等流教法已后，依闻、思、修三慧熏习成长的无漏种子，所以名为习所成种性。只有具备这二种大乘种性，才能逐渐悟入唯识。

    论文二：何谓悟入唯识五位？一、资粮位，谓修大乘顺解脱分。二、加行位，谓修大乘顺决择分。三、通达位，谓诸菩萨所住见道。四、修习位，谓诸菩萨所住修道。五、究竟位，谓住无上正等菩提。

    讲解：什么叫做悟入唯识五位？一是资粮位，就是修学大乘顺解脱分，筹备佛道资粮。于十住、十行、十回向终，就叫做顺解脱分。二是加行位，就是修学大乘顺决择分，方便加行。见道前的暖、顶、忍、世第一等四善根，就叫做顺决择分。三是通达位，就是诸菩萨通达二空无我之理所住的见道。初地入心就叫做见道。四是修习位，就是诸菩萨修习妙观所住的修道。从初地住心到十地出心，全叫做修道。五是究竟位，就是究竟断惑证理，永住于无上正等菩提。

    论文三：云何渐次悟入唯识，谓诸菩萨，于识相性资粮位中，能深信解，在加行位能渐伏除所取、能取，引发真见，在通达位如实通达，修习位中，如所见理数数修习，伏所余障，至究竟位，出障圆明，能尽未来化有情类，复令悟入唯识相性。

    讲解：怎样才能渐次悟入唯识呢？是说诸菩萨对于识的外相和体性，在第一资粮位中，能深刻信仰和理解。在第二加行位中，能渐次伏除所取、能取，而引发真见。在第三的通达位中，起无漏现行二智，如实通达诸法相性。在第四修习位中，如其所见的真理，精勤不懈，数数修习，以伏除烦恼，断余智障。至第五究竟位中出离二障，于功德智慧，体无不备，此叫做圆；用无不行，此叫做明，既已圆明，不但自己悟入唯识相性，而且还能尽未来际，度化一切有情之类，教他们也能悟入唯识相性。


第二章 释资粮位

    第二章 释资粮位

    论文一：初资粮位其相云何？颂曰：乃至未起识，求住唯识性，于二取随眠，犹未能伏灭。

    讲解：五位中最初的资粮位，他的义相是怎样的呢？《唯识三十颂》说：由最初发心修行，即求住于唯识实性，但由于能取、所取的随眠还没有制服灭除，所以还未能安住。

    论文二：论曰：从发深固大菩提心，乃至未起顺决择识，求住唯识真胜义性，齐此皆是资粮位摄。为趣无上正等菩提，修习种种胜资粮故。为有情故，勤求解脱，由此亦名顺解脱分。此位菩萨，依因、善友、作意、资粮四胜力故，于唯识义虽深信解，而未能了能、所取空，多住外门修菩萨行，故于二取所引随眠，犹未有能伏灭功力，令彼不起二取现行。

    讲解：此下是以长行来解释颂义。论曰：菩萨从发深远坚固的大菩提心开始，乃至于还未生起顺决择识，以求住于唯识的真胜义性，这一阶段都是资粮位摄。为了要趣向无上正等菩提，才修习种种福智及殊胜资粮，譬如有人远行，必须要筹备川资食粮一样，所以名资粮位。趣无上菩提，非但自利，为度化有情故，勤求解脱，顺修解脱之因，由此亦名顺解脱分。

    资粮位的菩萨，依闻、熏、修的因力，善友的缘力，决定胜解的作意力，善修福智的资粮力，以这四种殊胜力故，对于唯识义趣虽已深生信解，而未能了达能、所取空。很少能内观真如，多住外门以散心修菩萨行。因此于二取所引的随眠，还没有能够伏减的功力，使他不起二取现行。

    论文三：此二取言，显二取取，执取能取所取性故。二取习气名彼随眠，随逐有情眠伏藏识，或随增过，故名随眠，即是所知、烦恼障种。烦恼障者，谓执遍计所执实我，萨迦耶见而为上首，百二十八根本烦恼，及彼等流诸随烦恼，此皆扰恼有情身心，能障涅槃，名烦恼障。所知障者，谓执遍计所执实法，萨迦耶见而为上首，见疑无明爱恚慢等，覆所知境，无颠倒性，能障菩提，名所知障。

    讲解：二取有执与非执之别，颂中所说的二取，就是显示能执相、见二取之取，并非说的就是二取，因为执取能、所二取为实有性，故名二取。若以二取名取，那非执的二取，岂是所伏断的吗？由二取现行所熏成的习气，名为二取随眠。因为它们随逐有情众生，眠伏于阿赖耶识中，或者随逐有情使增生过失，昏迷如睡，所以名为随眠。这二取习气的随眠，就是所知、烦恼二障的种子。

    什么叫做烦恼障？就是执著遍计所执的实我，以人我、我所的萨迦耶见而为上首的一百二十八种根本烦恼（注：此一百二十八种根本烦恼，属于见道所断的一百一十二种，修道所断的十六种。）以及与此平等流出的各种随烦恼，他们都扰恼有情身心。能障涅槃，所以名为烦恼障。什么叫做所知障？就是执著遍计所执的实法，以法我、我所的萨迦耶见而为上首的见、疑、无明、爱、恚、慢等，覆盖了所知之境的真实性，能够障碍菩提，所以名为所知障。

    论文四：此所知障，决定不与异熟识俱，彼微劣故，不与无明、慧相应故，法空智品与俱起故，七转识内，随其所应，或少或多，如烦恼说。眼等五识无分别故，法见、疑等定不相应，余由意力皆容引起。

    讲解：这所知障，决定不与第八异熟识相应，其故有三：一者因第八异熟识微细劣弱，同时也不与无明慧相应。如诸论所说，此第八识唯与作意等心所具。二者法执必与无明及慧相应，因无明迷暗，慧能计度，第八识唯与作意心所相应，与无明、慧是不相应的。三者法空智品与第八识是俱起的，法空智起，当然法执就不能现行了。在七转识里，根据不同情况，或多或少与所知障相应，就如烦恼障一样。前五识因为没有计度分别，肯定不能与法见、疑、慢等相应，余如贪、恚、痴等，由于五俱意识之力，皆容引起。

    论文五：此障但与不善、无记二心相应，论说无明唯通不善、无记性故，痴无痴等不相应故。烦恼障中此障必有，彼定用此为所依故。体虽无异，而用有别，故二随眠随圣道用，有胜有劣，断或前后。此于无覆无记性中是异熟生，非余三种。彼威仪等势用薄弱，非覆所知障菩提故。此名无覆望二乘说，若望菩萨亦是有覆。

    讲解：这所知障，但与不善、无记二种心相应，不通善性。因为《瑜伽论》上说：无明唯通不善、无记。无明就是痴，善心无痴，法执有痴，痴与无痴是不相应的。

    烦恼障中必定有所知障，因为法执体宽，烦恼障狭，狭隘的烦恼障，必须要用这宽润的所知障为所依故。这二障的体性虽不相违，但作用却有区别。所以二障随眠，随著声闻、缘觉、菩萨三乘圣道有胜有劣，断的时间或前或后。这所知障，在四种无覆无记性中，是异熟生无记，而不是其余的三种（注：无覆无记分为四种，为异熟无记，威仪无记，工巧无记，变化无记。）因为异熟无记的势力强大，覆所知境，能障菩提，其余三种无记的势用薄弱，他们既不能覆所知境，亦不能为菩提障。所知障称为无覆，是对小乘佛教声闻、缘觉二乘所说，如果对菩萨来说也是有覆。

    论文六：若所知障有见、疑等，如何此种契经说为无明住地？无明增故，总名无明，非无见等。如烦恼种，立见一处、欲、色、有爱四住地名，岂彼更无慢、无明等？

    讲解：倘若所知障中有恶见、疑等惑，如何契经上说，所知障为无明住地呢？（注：住地，依所生处称为住地。根本烦独是产生枝末烦恼的住地。住地有五：见一处住地，欲爱住地，色爱住地，无明住地。）论主回答：因为所知障中无明增盛，所以总说无明，并不是没有其余的恶见等。例如烦恼种子，见、修皆有，然以见道所断的，立见一处住地，修道所断的，立欲爱、色爱、有爱住地，这四住地的名，不过各约其偏增而立罢了，岂彼除见、爱外，更无贪、嗔、痴、慢等惑吗？

    论文七：如是二障，分别起者，见所断摄；任运起者，修所断摄。二乘但能断烦恼障，菩萨俱断。永断二种，唯圣道能，伏二现行，通有漏道。菩萨住此资粮位中，二粗现行虽有伏者，而于细者及二随眠，止观力微未能伏减。

    讲解：以上所说二障，若是由邪师所教及邪分别而起的，属于见道所断；若是由无始熏习，任运而起的，那就属修道所断。二乘唯能断烦恼障，不断所知障，因为二乘但取涅槃，不悟菩提，所知障不障涅槃故。菩萨则二障俱断，因菩萨直趣菩提大果，不唯取小果涅槃，要永断二障种子，唯初地入心，到十地出心的无漏圣道，才能成办。若暂伏二障现行，那就不唯无漏圣道，即地前的有漏道，亦能成办。在资粮位中的菩萨，对于二障的粗现行虽有多分被伏，但对于微细现行及二障随眠来说，由于止观之力微弱，还没有能够伏灭。

    论文八：此位未证唯识真如，依胜解力修诸胜行，应知亦是解行地摄。所修胜行，其相云何？略有二种，谓福及智。诸胜行中，慧为性者，皆名为智，余名为福。且依六种波罗密多，通相皆二，别相前五说为福德，第六智慧。或复前三唯福德摄，后一唯智，余通二种。复有二种，谓利自他。所修胜行，随意乐力，一切皆通自他利行。依别相说，六到彼岸，菩提分等自利行摄，四种摄事、四无量等，一切皆是利他行摄。如是等行差别无边，皆是此中所修胜行。

    讲解：本章开始是诠释颂文，此下是辨位修行。这资粮位的菩萨，还没有证得唯识真如，所以才依胜解之力，修一切胜行。应知此亦解行地摄（注：解行地，谓知解与修行，指未证真如前的三贤菩萨。）解行地所修的胜行是些什么呢？简略的说有二种，即福和智。在一切胜行中，凡是以慧为体性的，都叫做智，其余的都叫做福。现在别的胜行不说，且以六波罗密而言，约通相说，皆名福智。依别相说，前五种称为福德，第六种是智。或者以前三的布施、持戒、忍辱唯属福德，后一的般若唯属智慧，其余的精进、禅定通福、智二种。

    除福、智外，又有二种，即自利和利他。就是所修胜行，随其意乐之力　一切功德都通于自利、利他二行。若依别相来说，六度、三十七菩提分等，都是自利行摄；四摄、四无量心等，都是利他行摄。像这样的胜行，差别无边，都是资粮位中所修。

    论文九：此位二障虽未伏除，修胜行时有三退屈，而能三事练磨其心，于所证修勇猛不退。一闻无上正等菩提广大深远，心便退屈；引他已证大菩提者练磨自心，勇猛不退。二闻施等波罗密多甚难可修，心便退屈，省己意乐能修施等，练磨自心勇猛不退。三闻诸佛圆满转依极难可证，心便退屈，引他粗善况己妙因，练磨自心勇猛不退。由斯三事练磨其心，坚固炽然修诸胜行。

    讲解：在此资粮位中，烦恼、所知二障还没有伏灭断除，致使修胜行时有三种退屈，但有三事以磨练其心，于所证修勇猛精进，不令退屈。一者闻说无上正等菩提，广大无边，深远难测，心生退屈。此时即引用其他人已证大菩提者为例，来练磨自心，便能发大勇猛而不退转。二者闻说布施等六波罗密多甚难可修，心便退屈，此时即省察自己的意乐已能修施、戒等行，要再鼓余勇，不难圆满达到彼岸，这样磨练自心，而勇猛不退。三者闻说诸佛圆满转依，极难可证，心便退屈，此时应引用他人所行的施等粗善，来比况自己的妙因之行，粗善尚且可获善果，妙因岂能不证妙果？这样磨练自心，便勇猛不退。由上三事，练磨其心，使三种退屈坚固炽然的修诸胜行，而不再退转。


第三章 释加行位

    第三章 释加行位

    论文一：次加行位其相云何，颂曰：现前立少物，谓是唯识性，以有所得故，非实住唯识。

    讲解：五位修行的第二位是加行位，加行位的义相是怎样呢？《唯识三十颂》说：‘在修习四寻思观和四如实智的时候，仍有一种假立之物出现在前面，以为这就是唯识的实性，因为心中存著有所得之念，所以未能真正的住于唯识实性。’

    论文二：论曰，菩萨先于初无数劫，善备福德智慧资粮，顺解脱分既圆满已，为入见道住唯识性，复修加行，伏除二取，谓暖、顶、忍、世第一法。此四总名顺决择分，顺趣真实决择分故。近见道故立加行名，非前资粮无加行义。暖等四法，依四寻思、四如实智，初后位立。四寻思者，寻思名、义、自性、差别，假有实无。如实遍知。此四离识及识非有，名如实智。名、义相异，故别寻求。二二相同，故合思察。

    讲解：论中长行说，菩萨先于最初无数劫中，贮备福德智慧的胜行资粮，已使顺解脱分圆满成就，为要入见道并住唯识实性，所以还得更修加行以伏除二取，这就是暖、顶、忍、世第一法的四善根。这四善根总名为顺决择分，因为它随顺趣向于真实的决择分，近于见道，所以立加行之名，并非前资粮位没有加行的意义。

    暖等四法，依四寻思观而立初暖、顶二位，依四如实智观而立后忍、世第一法二位。所谓四寻思观，是寻思事物名、义、自性、差别，从而认识到这四法都是唯识所变，依他假有，遍计实无，这就叫做四寻思观。什么叫做如实智？前四寻思，但观所取的名等四境离识非有，此如实智更于忍可所取空后，进而如实遍知能取的识也决定非有。依此能、所俱空的空理，便能入圆成实性，所以叫做如实智。

    何以诸法的名、义要各别寻求，名义的自性、差别要合并思察呢？名是名，义是义，名义相异，所以要各别寻求。名义二种的自性同，差别亦同，这二二相同，所以要合为思察。

    论文三：依明得定发下寻思，观无所取立为暖位。谓此位中创观所取名等四法，皆自心变假施设有，实不可得。初获慧日前行相故，立明得名。即此所获道火前相，故亦名暖。

    讲解：初得无漏慧的明相，叫明得，明得之定叫做明得定。依此明得定，发下品寻思，观所取空，立为暖位。即在暖位中开始认识到所取外境的名、义、自性、差别四法，都是自心所变，假施设有，实际上是不可得的。这下寻思观，初获慧前的行相，喻如日出前的明相，所以立明得名。这也是所获净道之火以前的行相，所以又称为暖。

    论文四：依明增定发上寻思，观无所取立为顶位。谓此位中，重观所取名等四法，皆自心变，假施设有，实不可得。明相转盛，故名明增。寻思位极，故复名顶。

    讲解：明得定增上，叫做明增定。依此明增定，发上品寻思，观无所取，立为顶位。在这顶位当中，重观所取的名等四法，同暖位一样是自心所变，虚假施设，实不可得。但在所获慧前的明相，较前暖位的明相增盛，所以名为明增。寻思位到此已登峰造极，所以又名为顶位。

    论文五：依印顺定，发下如实智，于无所取决定印持，无能取中亦顺乐忍。既无实境，离能取识，宁有实识离所取境？所取能取，相待立故。印顺忍时，总立为忍。印前顺后，立印顺名。忍境识空，故亦名忍。

    讲解：印前所取无，印后能取无，叫做印顺定。依印顺定，发下品如实智，对无所取的境，决定印持，于无能取的识中，也顺乐忍可。为什么二取都无？既然没有实境离了能取的识而存在，那里有什么实识离了所取的境而独存呢？所取、能取本是相待而立的啊。

    忍有三名，下品为印忍，忍所取无；中上品为乐顺忍，忍能取无，印顺忍时，这三忍在四善根中总立为忍。因为此位能印前所取无，顺后能取无，所以立印顺名：忍可所取的境空，能取的识亦空，所以亦名为忍。

    论文六：依无间定，发上如实智，印二取空，立世第一法。谓前上忍唯印能取空，今世第一法二空双印，从此无间必入见道，故立无间名。异生法中此最胜故，名世第一法。

    讲解：与见道位邻近而无间隙，叫做无间定。依此无间定，发上品如实智，印可能、所二取皆空，立名世第一法，谓前忍位中的上忍，唯能印可能取空，不能即可所取亦空，今此世第一法，是能、所二空双印。从此不间断的双印二空，必入见道，所以立无间名。这在异生法中最为殊胜，所以名世第一法。

    论文七：如是暖、顶，依能取识，观所取空；下忍起时，印境空相，中忍转位，于能取识如境是空，顺乐忍可，上忍起时印能取空，世第一法，双印空相。

    讲解：像这样的暖位、顶位，依据能取之识，观所取境空，到了忍位的下品忍生起时，便能印持外境之空相，到了中忍转换为能取之识，也如所取的境一样也是空，顺乐后位的上品之忍。修到上品忍生起时，便能印持此能取空。再进到世第一法，便能双印能、所二取的空相。

    论文八：皆带相故，未能证实，故说菩萨此四位中，犹于现前安立少物，谓是唯识真胜义性。以彼空有二相未除，带相观心有所得故，非实安住真唯识理，彼相灭已，方实安住。依如是义，故有颂言：菩萨于定位，观影唯是心，义相既灭除，审观唯自想。如是住内心，知所取非有，次能取亦无，后触无所得。

    讲解：以上所说加行位的暖等四法，虽然印能、所取空，但在观心之前，还浮著有、空二相，未能真正证实。所以说菩萨在这四位中，犹于现观定中安立少物，以为这就是唯识的真胜义性。因此颂文前二句说：‘现前立少物，谓是唯识性’。事实上这少物是定心所变的似真如相，非真胜义，所以颂文的后二句说：‘以有所得故，非实住唯识。’要到那有、空二相灭了之后，才能实在的安住真唯识性。

    依据这种意义，所以《分别瑜伽论》上有颂文说：‘菩萨在定中修行，观名、义等的影像，唯是内心所变现，义相既已灭除，谛审观察，唯自心想，更无少物。这样便安住内心，先了知所取非有，次了知能取亦无，最后触觉到无所得的真唯识性。前面的两首颂中，第一颂初二句是明暖位，次二句是明顶位。第二颂的前二句是明下忍位，第三句是明中、上忍位，最后一句是明世第一法．

    论文九：此加行位，未遣相缚，于粗重缚，亦未能断。唯能伏除分别二取，违见道故。于俱生者及二随眠，有漏观心有所得故，有分别故，未全伏除，全未能灭。此位菩萨于安立谛，非安立谛俱学观察，为引当来二种见故，及伏分别二种障故，非安立谛是正所观，非如二乘唯观安立。

    讲解：有漏的现行境相系缚于心，不得自在，叫做相缚，二障种子，叫做粗重缚，合称二缚。这加行位既未遣除有、空的相缚，也未断灭二障种子的粗重缚，唯能伏除分别二取，不起现行。因为分别二取违于见道的，为入见道，所以要把它伏除。入见道位，方能永断二障的粗重缚。虽然如此，但于俱生现行，只能伏除少分，未全伏除。于分别、俱生二种随眠则全未能灭，因为此位是有漏观心，有所得相，有分别故，所以俱生现行未全伏除，二种随眠尽未能灭。

    在此加行位的菩萨，对于安立谛及非安立谛，都修学观察。什么叫安立谛，安立是施设义，即方便安立谛，谓于苦等诸法中，安立苦、集、灭、道四圣谛理。什么叫非安立谛，就是离差别名言的二空真如。此位菩萨，为引发当来的真、相二种见道，及伏除由分别所起的烦恼、所知二障，所以于安立、非安立谛，要都修学观察。不过菩萨为入二空观真如理，非安立谛是所正观；至于亦观安立，那是因为起胜进道，成熟佛法，以降伏二乘的方便之故。与二乘的唯观安立不同。

    论文十：菩萨起此暖等善根，虽方便时通诸静虑，而依第四方得成满。托最胜依入见道故。唯依欲界善趣身起。余慧厌心非殊胜故。此位亦是解行地摄，未证唯识真胜义故。

    讲解：菩萨生起暖、顶、忍、世第一法四善根，虽在前方便时通色界四禅，但是只有依第四禅才能成就圆满。因为第四禅望余禅为胜，必须托最胜依处，入见道故。若约界、趣而论，只能依靠欲界善趣的人身而起，因为色界和无色界的智慧，厌伏三界一切事物之心并非殊胜。修四善根，也同资粮位一样是解行地摄，因为它们还没有证到唯识的真正殊胜之义。


第四章 释通达位

    第四章 释通达位

    论文一：次通达位其相云何，颂曰：若时于所缘，智都无所得，尔时住唯识，离二取相故。

    讲解：第三通达位，它的义相是怎样的呢？《唯识三十颂》说：‘若时，当无分别智生起的时候，也就是世第一法的次刹那，菩萨于前加行位住于唯识性（诸法真如），以能证悟所缘真如的无分别智观察，一切都无所得。所谓无所得，就是没有能取、所取之像，这时就安住于唯识之理。’

    论文二：论曰，若时菩萨于所缘境，无分别智都无所得，不取种种戏论相故。尔时乃名实住唯识真胜义性，即证真如。智与真如，平等平等，俱离能取所取相故，能、所取相俱是分别，有所得心戏论现故。

    讲解：论文说，若时，即无分别智发生时，也就是世第一法次刹那，菩萨不仅对于所观境无所得，即能观的无分别智亦无所得，因为此时已无能取、所取的种种戏论相故。这时就称为实际住于唯识真正殊胜之理，也就是亲证得真如之智，体即真如，因为已远离能取、所取之相。能取、所取都是分别，若有所得便会戏论呈现。

    论文三：有义，此智二分俱无，说无所取能取相故。有义，此智相见俱有，带彼相起，名缘彼故。若无彼相名缘彼者，应色智等名声等智。若无见分应不能缘，宁可说为缘真如智？勿真如性亦名能缘，故应许此定有见分。

    讲解：颂文所说‘智都无所得’的‘智’，有三家异解。第一家说，无分别智已无相分和见分。‘离二取相’，就是显示没有所取、能取的相、见二分。第二家说，这无分别智，相、见二分都有。因为带彼相起，方可名为缘彼真如。带彼真如相起，是即显示有相分，所以说见、相俱有，才能名叫缘彼相。假使此智没有带彼真如之相，而名缘彼真如者，就应当是缘色相分之智，称为缘声相分之智，所以此智是决定有相分的。假使此智没有见分，就应当无能缘作用，怎可说为缘真如智呢？不能说真如之性也称为能缘吧！所以应当承认此智定有见分。

    论文四：有义，此智见有相无，说无相取　不取相故。虽有见分而无分别，说非能取，非取全无。虽无相分，而可说此带如相起，不离如故。如自证分缘见分时不变而缘，此亦应尔。变而缘者便非亲证，如后得智应有分别，故应许此有见无相。

    讲解：第三家护法说，这无分别智，有见分而无相分。因为《瑜伽论》说‘无相取’，就是没有相分可取；说‘不取相’，就是虽有见分而不取于相。第一师引‘无能取’的话，是表示虽有见分，而无分别，并不是连能取的见分也没有。第二师所引‘带彼相起’的话，是表示虽无相分，但可说此无分别智，是带著真如的体相而起的，所以名为所缘，并不是带著相分的影像而起，名叫缘如，因为根本智，是不离真如的。就如自证分缘见分时一样，不经变化而缘取，无分别智缘真如时也是这样。假使变相而缘，那就不是无分别智亲证如理了，岂不同后得智的有分别是一样吗？因此我们应当承认这缘真如的无分别智，是有见分而没有相分的。

    论文五：加行无间，此智生时，体会真如，名通达位，初照理故，亦名见道。

    讲解：在加行位无间修行，到无分别智生起的时候，去体会唯识实性的真如，这就称为通达位，又因此位最初照见真实如理，所以亦名见道位。

    论文六：然此见道，略说有二，一真见道，谓即所说无分别智，实证二空所显真理，实断二障分别随眠，虽多刹那事方究竟，而相等故，总说一心。有义：此中二空二障，渐证渐断，以有浅深粗细异故。有义：此中二空二障顿证顿断，由意乐力有堪能故。

    讲解：见道类别虽多，略说不过二种：一是真见道，就是所说的无分别智，因为是已证我、法二空所显的真如之理，实断烦恼、所知二障的分别随眠，此证断之事，虽经众多刹那方能究竟，而其念念刹那相似相等，所以总说为一心真见道。

    有人认为，这见道中的二空真理、二障种子，都是渐次而证，渐次而断的。因为理有浅深，障有粗细，人、法有异，所以不能顿证顿断。又有人认为，这见道中的二空之理，二障种子，都是一时顿证顿断的。因为在前加行时由意乐之力，有此可能。

    论文七：二相见道，此复有二，一、观非安立谛，有三品心：一内遣有情假缘智，能除软品分别随眠。二内遣诸法假缘智，能除中品分别随眠。三遍遣一切有情诸法假缘智，能除一切分别随眠。前二名法智，各别缘故；第三名类智，总合缘故。法真见道，二空见分，自所断障，无间解脱别总建立，名相见道。有义：此三是真见道，以相见遣缘四谛故。有义：此三是相见道，以真见道不别缘故。

    讲解：第二是相见道，此又有二种，第一种是观非安立谛，非安立谛就是真如，有以下三品心，即初起的智，力尚薄弱，名之曰‘软’；次起的智，胜于前者，劣于后者，名之曰‘中’；后起的智，胜于前二，名之曰‘上’。二障随眠，各分粗细，断有先后，也随这能断的智，如其次第的名谓软、中、上三品。一品是内遣有情假缘智，‘内’是内身，‘遣’是遣除，‘有情假’是有情为妄计所执，并无实体，唯有内心变似有情，‘缘智’就是能缘之心。合起来讲，就是缘内身为境，遣除有情假的能缘智。以下二心，准此例释。此初起智，力尚薄弱，只能除软品的分别随眠。二品是内遣诸法假缘智，此次起智，胜前劣后，能除中品的分别随眠。三品是遍遣一切有情诸法假缘智。此后起智，胜于前二，能除上品一切内外分别随眠。

    这三种缘智，前二种称为法智，因为是各别而缘；第三名为类智，因为是综合二类而缘。真见道的法中有我、法二空见分，就无间道中的我、法二见分，各别立此初、二品心：解脱道中的我、法二见分，总立此第三品心，这别总而立的三心，就叫做相见道。有人认为，这三心是真见道，因为相见道缘取四谛。又有人认为，这三心是相见道，因为真见道总缘真如，并不分别缘取。（注：安立谛，即施设差别之义。亦即用语言、名相来区别种种事物。反之，则为非安立。非安立乃超越相对之差别，不以语言、名相表示。）

    论文八：二缘安立谛，有十六心。此复有二，一者依观所取、能取，别立法类十六种心，谓于苦谛有四种心：一、苦法智忍，谓观三界苦谛真如，正断三界见苦所断二十八种分则随眠。二、苦法智，谓忍无间观前真如，证前所断烦恼解脱。三、苦类智忍，谓智无间无漏慧生，于法忍智，各别内证，言后圣法皆是此类。四、苦类智，谓此无间无漏智生，审定印可苦类智忍。如于苦谛，有四种心，集灭道谛应知亦尔。此十六心，八观真如，八观正智。法真见道，无间解脱，见自证分，差别建立，名相见道。

    二者依观下上谛境，别立法类十六种心，谓观现前不现前界，苦等四谛各有二心：一、现观忍，二、现观智。如其所应法真见道，无间解脱，见分观谛，断见所断百一十二分别随眠，名相见道。

    讲解：第二种是缘安立谛，包含有十六心，这又分为二种，第一依观所取的谛理和能取的缘理之智，各别安立法智和类智的十六种心。就是在苦谛上有四种心：一、苦法智忍，即通过观三界的苦谛真如，断三界见惑苦谛所断的二十八种分别随眠。二、苦法智，前忍是断惑；此智是证理，就是前法忍的无间道智，观察前苦谛真如，断除前分别烦恼，而证得解脱。三、苦类智忍，就是苦法智的无间道，无漏智慧生起，以此缘前各别证得的法忍、法智，各别内证的无间道。所说以后的圣法，皆是此类之智。四、苦类智，就是由此类忍的无间道，生起无漏解脱道智，以审定印可苦类智忍。如于苦谛有这四种心，应知于集、灭、道谛上也有一样的四种。这四谛十六种心，是以法忍、法智的八心观真如；类忍、类智的八心观正智。效法真见道中的无间道见分，建立法忍；解脱道的见分，建立法智；无间道的自证分，建立类忍；解脱道的自证分，建立类智。这样差别建立，名相见道。

    第二依观下上界四谛之境，各别建立法忍、法智、类忍、类智的十六种心。就是观现前的欲界，不现前的上二界苦等四谛，各有二心，一者现观忍，二者现观智。如其所应，在法真见道中的无间道见分观四谛法，断除见道所断的一百一十二种分别随眠（欲界四谛四十，上二界除嗔各三十六）。这就叫做相见道。

    论文九：若依广布圣教道理，说相见道有九种心。此即依前缘安立谛二十六种止观别立。谓法类品忍、智合说，各有四观，即为八心，八相应止总说为一。虽见道中止观双运，而于见义观顺非止，故此观止开合不同。由此九心，名相见道。

    讲解：前面说相见道，有二种十六心，那是依行人缘安立谛而说的，若依菩萨广布圣教的道理来说，相见道只有九种心。这就是依前缘安立谛的两个十六种止观而别立的。即法类的法忍和法智各有四心，合为八心，这八心与止相应，总说为一种。虽然见道中止观双运，定慧均等，但是见道的观并不是止，所以这观和止的开合也就不同。由此八观一止的九心，称为相见道。

    论文十：诸相见道，依真假说，世第一法无间而生，及断随眠，非实如是。真见道后，力得生故，非安立后起安立故，分别随眠，真已断故。前真见道，证唯识性，后相见道证唯识相，二中初胜，故颂偏说。

    讲解：以上所说，无论是三心的相见道，十六心相见道，九心相见道，一切都是依真之义而假说的。所谓由世第一法无间而生，以及断种种分别随眠，实际上并不是如此。因为十六心的相见道，是从一心真见道后才能得以产生，并不是安立谛以后才起安立的，到这时候，分别随眠才真正断除。见道既有真、相二种，何以颂中唯说真见道呢？因为前真见道，证唯识实性；后相见道，证唯识法相，前后二见道中，初胜于后，所以颂中偏说真见道。

    论文十一：前真见道，根本智摄；后相见道，后得智摄。诸后得智有二分耶？有义；俱无，离二取故。有义：此智见有相无，说此智品有分别故，圣智皆能亲照境故，不执著故，说离二取。有义，此智二分俱有。说此思惟似真如相，不见真实真如性故。又说此智，分别诸法自共相等，观诸有情根性差别，而为说故。又说此智现身土等，为诸有情说正法故：若不变现似色声等，宁有现身说法等事，转色蕴依不现色者，转四蕴依应无受等。又若此智不变似境，离自体法应非所缘，缘色等时，应缘声等。又缘无法等，应无所缘缘，彼体非实，无缘用故。由斯后智，二分俱有。

    讲解：这一节是说明真见道和相见道，为根本、后得二智所摄。真见道是无相的，所以根本智摄，相见道是有相的，所以后得智摄。至于后得智有没有见、相二分，则有三家异解。安慧认为，后得智无见、相二分，因为后得智是离了能、所二取相的。第二家说，此智但有见分，没有相分，因为诸圣教说，这后得智品是有分别的，所以有见分。第三家护法认为，此智见、相二分都有，因为《瑜伽论》说：‘这后得智，思惟变现似真如相，而不能亲见真如实性’。思惟就是见分，变似真如相就是相分。《佛地经》等又说，这后得智，能分别诸法的自相共相，观一切有情根性差别，而为说法。这是证明有见分，破第一师的无见分说。又说：这后得智，能变现身土，为诸有情宣说正法。假使不能变现似色、似声等相，怎能有现身说法等事？这是证明有相分，破第二家的无相分说。

    再者，这转依的通达位，并非无相，试以五蕴为例，若说转色蕴依，便不现色，那么转四蕴依，就应当没有受等四蕴了。既然转四蕴依，非无受等。怎能转色蕴依而不现色相呢？又，假使此智不能变现似相分境，那离了自身之法的他心、他身土等，就应当不是带彼相起的所缘缘了。假使所缘缘不是带彼相起，那缘色等时的智，就应当能缘声等相啊。又，缘无体法时，假使不变似境，那就应当无所缘缘。因为彼法既无实体，又无所变的相分，如何会有所缘缘的作用？由此可见，后得智有见分也有相分。

    论文十二：此二见道，与六现观，相摄云何？六现观者：一、思现观：谓最上品喜受相应思所成慧，此能观察诸法共相，引生软等加行道中观察诸法，此用最猛，偏立现观。暖等不能广分别法，又未证理，故非现观。二、信现观：谓缘三宝世出世间决定净信，此助现观令不退转，立现观名。三、戒现观：谓无漏戒，除破戒垢，令观增明，亦名现观。四、现观智谛现观：谓一切种，缘非安立根本、后得无分别智。五、现观边智谛现观：谓现观智谛现观后，诸缘安立世出世智。六、究竟现观：谓尽智等究竟位智。此真见道，摄彼第四现观少分；此相见道，摄彼第四、第五少分。彼第二、三，虽此俱起，而非自性，故不相摄。

    讲解：这真、相二种见道，与六现观的关系是怎样呢？六现观是：一、思现观：就是在五受中与最胜的上品喜受相应，因思所成的智。此思现观，能观察诸行无常的共相，引生暖、顶、忍、世第一法，在加行道中观察诸法。因此思能生修，在见道前的功用猛利，所以特别立为现观。暖等加行不能广泛分别诸法，又未得印证真理，所以不是现观。二、信现观：就是缘佛、法、僧三宝及世、出世间的坚定信仰，能决定净信。净信能助现观不令退转，所以也得立为现观。三、戒现观：此无漏戒，就是与无漏道共生的‘道共戒’。因为这无漏戒，能除破戒的垢污，令现观增明，所以也名之为现观。四、现观智谛现观：就是缘非安立谛的根本、后得无分别的一切种智。五、现观边智谛现观：就是现观智谛现观已后，各种缘安立谛的世间智及出世间智。六、究竟现观：就是尽智（断尽烦恼时所生的智）等究竟位的无漏智。

    这真见道，包括第四现观的少分──根本智。这相见道，包括第四现观的少分──后得智，及第五现观的少分──见道智。至于第二的信现观、第三的戒现观，虽也与此见道俱起，但，信、戒不过是对现观的助、增而已，而不是现观慧的自性，所以与二种见道无关。

    论文十三：菩萨得此二见道时，生如来家，住极喜地，善达法界，得诸平等，常生诸佛大集会中，于多百门已得自在，自知不久证大菩提，能尽未来利乐一切。

    讲解：这是说明入地功德。菩萨得此二见道时，生法王家，成法王子，绍隆佛法，住于十地中的第一极喜地。善能通达法界，得一切有情、一切菩萨、一切如来的三种平等心性。常生诸佛大集会──受用土中。于诸佛国见百如来、成熟百种所化有情、智见能入百法明门、化作百身、现百菩萨眷属等的多百门中，已得自在。自知不久便能证得大菩提果，尽未来际，利乐一切有情。


第五章 释修习位

    第五章 释修习位

    第一节 总释颂文

    论文一：次修习位其相云何？颂曰：无得不思议，是出世间智，舍二粗重故，便证得转依。

    讲解：第四修习位，它的义相是怎样的呢？《唯识三十颂》说：‘此位菩萨，没有能取之心，也没有所取之境，这种出世间的无分间智，具有超越世间的不可思议功用，在此阶位，舍弃二障种子，便能证得二种转依。’

    论文二：论曰，菩萨从前见道起已，为断余障证得转依，复数数修习无分别智。此智远离所取能取，故说无得及不思议。或离戏论，说为无得；妙用难测，名不思议。是出世间无分别智。断世间故名出世间。二取随眠是世间本，唯此能断独得出名。或出世名依二义立，谓体无漏及证真如。此智具斯二种义故，独名出世，余智不然。即十地中无分别智。

    讲解：论中长行说，这修习位的菩萨，从以前通达位的见道生起已后，为了断除所余的俱生二障，证得了二种转依之故，又复数数的修习无分别智。这无分别智已经远离所取之境，名为无得；也远离能取之识，名不思议。所以颂曰:‘无得不思议’。或另有一种解释，远离有漏分别戏论、名为‘无得’，这种无分智的妙用难测，名‘不思议’。这是出世间的无分别智，因为它已经断除世间烦恼，所以名出世间。能、所二取的随眠是世间的根本，唯有此无分别智能使之断除，所以独得‘出’名。或者‘出世间’之名，是依一者自体无漏，二者证得真如。此智具有以上二义，所以独名出世。其余的后得智，不具此二义，也不名出世。这出世间智，也就是十地中的无分别智。

    论文三：数修此故，舍二粗重，二障种子，立粗重名，性无堪任，违细轻故。令彼永减，故说为舍。此能舍彼二粗重故，便能证得广大转依。

    讲解：数数重覆的修习这出世间的无分别智，便能‘舍二粗重’。二粗重，就是俱生的烦恼、所知二障种子。二障种子为何名叫粗重，因其性无堪任，违于微细轻妙无漏无分别智，故名粗重。数修此智至金刚心时，便能令二种粗重究竟永灭，所以说之为‘舍’。因为这无分别智，能够舍彼二粗重故，到十地究竟，证得佛果的广大转依。这是解释颂文的第三、四句。但是还有如下两家不同的解释。

    论文四：依谓所依，即依他起，与染净法为所依故。染谓虚妄遍计所执，净谓真实圆成实性。转谓二分转舍转得。由数修习无分别智，断本识中二障粗重，故能转舍依他起上遍计所执，及能转得依他起中圆成实性。由转烦恼得大涅槃，转所知障证无上觉，成立唯识，意为有情证得如斯二转依果。

    讲解：这是第一家对转依的解释：‘转依’的依字，意谓所依，就是依他起。因为依他起能与染、净诸法为所依故。染，就是虚妄的遍计所执。净，就是真实的圆成实性。‘转依’的转字，义谓染、净二分的转舍与转得。由于多次修习无分别智，断了第八根本识中的烦恼、所知二障种子，所以能够转舍依他起上的遍计所执，以及转得依他起中的圆成实性。由于转舍了烦恼障，便证得大涅槃；由于转舍所了所知障，便证得大菩提。成立唯识的意义，就是为了使一切有情，证得这样的二转依果。

    论文五：或依即是唯识真如，生死涅槃之所依故。愚夫颠倒迷此真如，故无始来受生死苦。圣者离倒悟此真如，便得涅槃毕竟安乐。由数修习无分别智，断本识中二障粗重，故能转灭依如生死，及能转证依如涅槃。此即真如离杂染性。如虽性净，而相杂染，故离杂染时假说新净，即此新净，说为转依。修习位中断障证得，虽于此位亦得菩提，而非此中颂意所显，颂意但显转唯识性。二乘满位名解脱身，在大牟尼名法身故。

    讲解：这是第二家对于转依的解释：‘依’就是依于唯识真如，而不是依于依他起，因为唯识真如是生死、涅槃之所依。世间愚夫为颠倒妄惑，迷了这真如之理，所以从无始以来受生死苦。出世间圣者远离颠倒妄惑，悟了这真如之理，便证得涅槃，毕竟安乐。由于数数修习无分别智，断除了根本识中的二障种子，所以能够转灭了依于真如的生死，转证了依于真如的涅槃，这就是真如远离杂染之性。这种真如虽然其性清净，但其相则杂染，所以当行人离此杂染相时，假说名为新净，即此新净说名转依。在修习位中渐断二障，要到金刚心后才能证得。虽然在修习位中也可以证得菩提，但并不是这里的颂意所显，这里颂意所显的是转唯识性。这唯识性，在二乘无学满位，名解脱身；在大牟尼，名为法身。牟尼是寂默之意，谓善寂空有二边，默契中道之理。

    论文六：云何证得二种转依？谓十地中修十胜行，断十重障，证十真如，二种转依由斯证得。

    讲解：怎样证得二种转依呢？答案有四，一者要历经十地，这是所经的位次。二者在十地中修十种胜行，这是所修的因。三者断十重障，这是所对治的断法：四者证得十真如，这是所观照之理。二种转依的果即是由此而证得。

    第二节 别释十地

    论文一：言十地者，一极喜地，初获圣性，具证二空，能益自他，生大喜故。二离垢地，具净尸罗，远离能起微细毁犯烦恼垢故。三发光地，成就胜定大法总持，能发无边妙慧光故。四焰慧地，安住最胜菩提分法，烧烦恼薪，慧焰增故。五极难胜地，真俗两智行相互违，合令相应极难胜故。六现前地，住缘起智，引无分别最胜般若，令现前故。七、远行地，至无相住功用后边，出过世间二乘道故。八不动地，无分别智任运相续，相用烦恼不能动故。九善慧地，成就微妙四无碍解，能遍十方善说法故。十法云地、大法智云含众德水，荫蔽一切如空粗重，充满法身故。

    讲解：证得二种转依，要历经十地修行，这十地是：一、极喜地：此地菩萨，初断分别起的二障，由凡性获得无漏圣性，具证人、法二空，简除二乘者但证人空。能利益自、他，简除二乘的但能自利。由此三因生大欢喜，故名极喜地。二、离垢地：此地菩萨，，遵守清净戒律，远离能够生起微细毁犯的烦恼尘垢，故名离垢地。三、发光地：此地菩萨，成就心一境相的殊胜禅定，而为广大教法总持，能发无边胜妙慧光，故名发光地。四、焰慧地：此地菩萨，安住于殊胜的菩提分法，以智慧火灭一切烦恼，如火烧薪，慧焰增胜，故名焰慧地。五、极难胜地：真谛智无分别，俗谛智有分别，这二智的行相互违。此地菩萨，能够使之和合相应，此事甚难，菩萨能办，故名极难胜地。六、现前地：此地菩萨，观十二支缘起，安住于缘生智，引生无分别最殊胜的般若智慧，使之现前，故名现前地。七、远行地：此地菩萨，能于空中起有胜行，远至无相功用的最后边际，超过世间及出世间的二乘道，故名远行地。八、不动地：此地菩萨，无分别智任运相续，不依加行功用，一切烦恼都动他不得，故名不动地。九、善慧地：此地菩萨，成就微妙的法、义、词、辩四无碍解，能遍于十方善说法要，成利他行，故名善慧地。十、法云地：此地菩萨，具足广大教法的共相境智，其大如云，名为大法智云。此法智云中含有总持。禅定各种功德净水，又像大云荫蔽虚空一样，消除了粗重二障，不令现前。这殊胜功德充满了所证的法身，故名法云地。

    论文二：如是十地，总摄有为无为功德，以为自性。与所修行为胜依持，令得生长，故名为地。

    讲解：以上所说的十地，是以总摄有为、无为的功德为自性。有为功德，是能证的正智；无为功德，是所证的如理。这有为、无为功德，何以能为地体而名之为地呢？因其能与所修的行作殊胜依持，令得生长，所以才能为地体而名之为地。

    第三节 别释十波罗密多

    论文一：十胜行者，即是十种波罗密多。施有三种，谓财施、无畏施、法施。戒有三种，谓律仪戒、摄善法戒、饶益有情戒。忍有三种，谓耐怨害忍、安受苦忍、谛察法忍。精进有三种，谓被甲精进、摄善精进、利乐精进。静虑有三种，谓安住静虑、引发静虑、办事静虑。般若有三种，谓生空无分别慧、法空无分别慧、俱空无分别慧。方便善巧有二种，谓回向方便善巧，拔济方便善巧。愿有二种，谓求菩提愿，利乐他愿。力有二种，谓思择力，修习力。智有二种，谓受用法乐智，成熟有情智。

    讲解：所谓的十胜行，就是十种波罗密多。波罗密多此翻为度，或到彼岸。十波罗密多为：第一、布施波罗密多，此有三种：一财施，以金钱财物给济贫困，以资益其身。二无畏施，以大无畏精神救人脱离险难，解除其恐怖心理，以资益其心。三法施，随宜说法，以资益其善根。

    第二、戒波罗密多有三种：一律仪戒，即严守戒律仪则，以防止过非。二摄善法戒，即摄持应修应证的一切善法。三饶益有情戒，即拔济众苦，利乐有情。

    第三、忍波罗密多有三种：一耐怨害忍，即菩萨对一切众生都不起烦恼，即令众生无端以怨敌加害，亦能忍耐。二安受苦忍，即菩萨对风雨寒暑老病死等，非人力所能抗拒的一切苦难，都能安然忍受。三谛察法忍，即谛审观察一切法本来不生，今亦不灭的真理，而安忍不动。

    第四、精进波罗密多有三种：一被甲精进，即修行波罗密多，如勇士身被坚甲上阵，没有怯弱。二摄善精进，即于一切善法，加行精进。三利乐精进，即利乐自他精进不息。

    第五、静虑波罗密多有三种：一安住静虑，就是安于现法乐住而不动。二引发静虑，就是由静虑所引发的神通妙用。三办事静虑，就是成办利生事业。

    第六、般若波罗密多有三种：一生空无分别慧，就是了达人空，而不起人我见的智慧。二法空无分别慧，就是了达法空，而不起法我见的智慧。三俱空无分别慧，就是了达人、法俱空，而不起人、法二种我见的智慧。

    第七、方便善巧波罗密多有二种：一回向方便善巧，就是菩萨行六度时，将所集的善根功德，回向于一切有情，共求无上正等菩提，是为大智。二拔济方便善巧，就是菩萨于生死海中拔济有情，使之出离。是为大悲。

    第八、愿波罗密多有二种：一求菩提愿，就是菩萨发愿成无上佛道。二利乐有情愿，就是菩萨发愿度无量众生。

    第九、力波罗密多有二种：一思择力，就是菩萨以思惟抉择之力，知所当行与不当行。二修习力，就是以修习力，修习所思择的当行之法。

    第十、智波罗密多有二种：一变受用法乐智，就是由六度所成立的殊胜妙智，于佛大集会中，变化种种受用法乐，是为自利。二成熟有情智，就是以此妙智，使有情由善因而成熟为果，而解脱生死，是为利他。

    论文二：此十性者，施以无贪及彼所起三业为性，戒以受学菩萨戒时三业为性，忍以无嗔、精进、审慧，及彼所起三业为性，精进以勤及彼所起三业为性，静虑但以等持为性，后五皆以择法为性，说是根本、后得智故。有义，第八以欲、胜解及信为性，愿以此三为自性故。此说自性，若并眷属，一一皆以一切俱行功德为性。

    讲解：这是说明波罗密多的自体。布施是以无贪及相应生起的身、语、意三业为体性。戒是以受菩萨戒及学菩萨戒时的三业为体性。忍是以无嗔、精进、审慧，及其所生起的三业为体性。精进是以勤勇及其所起的三业为体性。静虑唯以平等持心的三摩地定为体性，不通三业。以下六至第十的五种波罗密多（般若、方便善巧、愿、力、智），都是以择法为体性。因为《摄大乘论》上说，第六的般若是根本智，其余的四种是后得智。然而有人认为，余义无诤，唯第八波罗密多是以欲、胜解、信为自性，非以择法。因为‘愿’是以这欲等三法为自性故。这以上都是约自性为体而说的，若并有关的眷属而论，那十度的一一度，都以一切的俱行功德为体性。

    论文三：此十相者，要七最胜之所摄受，方可建立波罗密多。一、安住最胜，谓要安住菩萨种性。二、依止最胜，谓要依止大菩提心。三、意乐最胜，谓要悲愍一切有情。四、事业最胜，谓要具行一切事业。五、巧便最胜，谓要无相智所摄受。六、回向最胜，谓要回向无上菩提。七、清净最胜，谓要不为二障间杂。若非此七所摄受者，所行施等非到彼岸。由斯施等十对波罗密多，一一皆应四句分别。

    讲解：这是明十波罗蜜多的相。这十波罗蜜多的相是怎样建立的呢？必须有七种最胜所含摄之内容方可建立。七种最胜如下：一安住最胜，就是要安住于菩萨种性。因为在五性中，唯有菩萨种性是无上佛果的最胜因。二依止最胜，就是菩萨发心要以上求佛道，下化有情的大菩提为依止，才能建立波罗密多。三意乐最胜，就是要以大悲心怜愍一切有情为最胜意乐。四事业最胜，就是要具行随顺度生的一切事业，才是事业的最胜者。五巧便最胜，就是菩萨在行波罗密多时，要为三轮清净的无相智所摄受。如《心地观经》的布施偈云：‘能施所施及施物，于三世中无所得，我等安住最胜心，供养一切十方佛’。六、回向最胜，就是将行波罗密多的功德，回向人天小果，趣向于无上菩提。七、清净最胜，就是要以纯一的清净心去行波罗密多，不为烦恼、所知二障所间杂。如果波罗密多不被这七种最胜所摄持所含受，则其所行的施等就不是到彼岸了。因此这十种波罗密多，每一种都应当以四句进行分别。（注：四句分别，以布施为例，一有施非度。二有度非施。三有亦施亦度。四有非施非度。）

    论文四：此但有十不增减者，谓十地中，对治十障，证十真如，无增减故。复次，前六不增减者，为除六种相违障故，渐次修行诸佛法故；渐次成熟诸有情故。此如余论广说应知。又施等三，增上生道，感大财体及眷属故，精进等三，决定胜道，能伏烦恼成熟有情及佛法故，诸菩萨道，唯有此二。又前三种，饶益有情，施彼资财，不损恼彼，堪忍彼恼，而饶益故，精进等三，对治烦恼，虽未伏灭，而能精勤修对治彼诸善加行，永伏永灭诸烦恼故。

    讲解：波罗密多的名数，为什么刚好有十，不增不减呢？因为在菩萨十地中要对治十障，证十真如，都是无增无减，所以能对治的波罗密多也唯有十。这是总解。复次是把十波罗密多分为前六后四，次第明其不增不减之所以。前六不增不减的理由有如下六种：一、为的要除灭悭吝、犯戒、嗔恚、懈怠、散乱、恶慧这六种相违障故，所以有施等六度的建立。二、前四度是不散动的因，第五度是不散动的成熟，第六度得如实觉。为的要这样渐次修行诸佛法故，所以有施等六度的建立。三、施能摄受，戒能不害不恼，忍能耐苦不退，勤能策励不懈，定能使未定得定，慧能使定者解脱。菩萨为如是渐次成熟一切有情故，所以才有六度的建立。以上这三种，都如其余的《摄大乘论》等所广说，是应当知道的。四、又施等的前三度是增上生道，后三度是决定胜道。何谓增上生道？布施能感得富裕的大财，持戒能感得尊贵的大体，忍辱能感得一切有情咸来归附而为眷属。这就叫做增上生道。怎样叫做决定胜道？精进是伏除烦恼的方便，静虑是成熟有情的方便，智慧是成熟佛法的方便。这就叫做决定胜道。诸菩萨道，唯有此二，缺一不可。五、又前三度，能饶益有情，怎样饶益：一者布施能给有情资财。二者持戒能不损恼有情。三者忍辱能忍受有情无端加诸于我的损恼。后三度，能对治烦恼，怎样对治？一者精进虽未能伏灭烦恼，却能勤修善品加行而不为烦恼所倾动。二者静虑能永伏烦恼。三者般若能永害随眠。诸菩萨道，亦唯有此二，缺一不行。六、又由施等的前三度，能利乐未来际的一切有情，所以菩萨为利生故，不自安住于涅槃的寂灭，是谓大悲。由精进等的后三度，能断一切烦恼，所以菩萨为断惑故，亦不住于生死的染污，是谓大智。由不住涅槃，不住生死故，所以这六度实为修行‘无住处涅槃’的资粮。

    由于以上的六种理由，所以这前六度，不增不减恰好有六。至于后四度为什么也唯有四呢？因为它是助成前六度，使之修学满足的，所以也唯有四不增不减。若分开来说：方便善巧能摄受有情以助成施等三度，愿能以宏誓助成精进，力能如理作意，以胜解助成静虑，智能从定所发慧以助成般若。如是十度，能令菩萨修学圆满，这在《解深密经》中有详细的解释。

    论文五：十次第者，谓由前前引发后后，及由后后持净前前。又前前粗，后后细故，易难修习，次第如是。释总别名，如余处说。

    讲解：这十波罗密多，由施到智的次第，是由前者引生后者，由后者净化前者。而且由于前粗后细，前者容易修习，后者难于修习，所以成立这样的次第。至于总的释名和分别释名，如《解深密经》和《摄大乘论》所说。

    论文六：此十修者，有五种修：一、依止任持修。二、依止作意修。三、依止意乐修。四、依止方便修。五、依止自在修。依此五修，修习十种波罗密多，皆得圆满。如集论等广说其相。

    讲解：修习这十种波罗密多，有五种修习原则：一、依止任持修，谓依止于菩萨种性的因力、殊胜自体的果力、上求下化的愿力、简择的慧力，来任持对波罗密多所修的正行。二、依止作意修，就是依止与诸度相应的教法，于已得功德深起爱味，见他人行度深生随喜，于自他当来的胜品度行，深生愿乐，这样作意来修习波罗密多。三、依止意乐修，就是依止于大慈大悲无厌足的欢喜心，来修习波罗密多。四、依止方便修，就是以无分别智观察三轮清净，不执有所度、能度的人我相，及波罗密多的法相。五、依止自在修，就是为求依止于如来的自在身、自在行、自在说法，而修波罗密多。依此五种修习法则，修习十波罗密多皆得圆满。至于五种修的行相，如《杂集论》所说。

    论文七：此十摄者，谓十一一皆摄一切波罗密多，互相顺故。依修前行而引后者，前摄于后，必待前故，后不摄前，不待后故。依修后行持净前者，后摄于前，持净前故，前不摄后，非持净故。若依纯杂而修习者，展转相望应作四句。

    讲解：这十种波罗蜜多互相含摄的关系，即每一种都舍摄一切波罗蜜多，因为各波罗蜜多之间互相随顺。依靠修习前者，能够引发后者，前者包括后者，因为后者必须依靠前者。后者不包括前者，依修习者确认并净化前者。后者包括在前者之中，有施皆戒，因为后者确认并净化前者。前者不包括在后者之中，因为前者不确认并净化后者。如果依纯净和间杂修习的话，则展转相望，应作四句分别进行表达。（注：四句是施而非戒，戒而非施，亦施亦戒，非施非戒。前二句是一行纯修，后二句是诸行杂修。）

    论文八：此实有十而说六者，应知后四第六所摄。开为十者，第六唯摄无分别智，后四皆是后得智摄，缘世俗故。此十果者，有漏有四，除离系果；无漏有四，除异熟果。而有处说，具五果者，或互相资，或二合说。

    讲解：波罗密多实有十种，然而有处但说为六种者，应知那是因为后四种的方便善巧、愿、力、智四度，统归第六的般若所摄了。何以有处又开六为十呢？因为第六唯摄无分别智，后四都是后得智摄，为缘世俗起的后得智。这十波罗蜜多的果，属于有漏的为四果，即五果中除去离系果。属于无漏的也有四果，即五果中除去了异熟果。然而有处说具有异熟、等流、士用、增上、离系五果者，那是或约无漏资助有漏，亦得异熟，有漏资助无漏，亦得离系，或合有漏无漏，说有五果。

    论文九：十与三学互柏摄者，戒学有三，一、律仪戒，谓正远离所应离法。二、摄善法戒，谓正修证应修证法。三、饶益有情戒，谓正利乐一切有情。此与二乘有共不共，甚深广大，如余处说。

    讲解：十波罗蜜多与戒、定、慧三学，互相摄持的关系是怎样呢？戒学有三种，一者律仪戒，就是以七众戒为体，正要远离所应离去的一切恶法。二、摄善法戒，就是以有为无漏、无为无漏的善法为体，正要修证所应修证的一切善法。三、饶益有情戒，就是以三业为体，正要做那利乐有情的一切事业。

    大乘戒与二乘戒有共与不共的分别，杀、盗、淫、妄的性戒，这是大、小乘所共同受持的。饮酒等的遮戒，性虽非罪，而能引罪，故佛特为遮止，在菩萨或起现行，不与二乘共持。这共不共法，甚深广大，余如《摄大乘论》所说。

    论文十：定学有四：一、大乘光明定，谓此能发照了大乘理教行果智光明故。二集福王定，谓此自在集无边福，如王势力无等双故。三贤守定，谓此能守世、出世间贤善法故。四健行定，谓佛、菩萨大健有情之所行故。此四所缘、对治、堪能、引发、作业，如余处说。

    讲解：定学有四种：一者大乘光明定，这种禅定能发智慧光明，照耀大乘的理、教、行、果。二者集福王定，这种禅定能任运自在集无边福德，好像有国王的势力一样，无有与他相等。三者贤守定，这种禅定能够守护世、出世间的善法，不使亡失。四者健行定，佛菩萨修这种禅定刚健勇猛，叫做大健有情定。这四种禅定的所缘、对治、堪能、引发、作业种种差别，如《摄大乘论》所说。

    论文十一：慧学有三：一加行无分别慧，二根本无分别慧，三、后得无分别慧。此三自性、所依、因缘、所缘、行等，如余处说。如是三慧，初二位中，种具有三，现唯加行。于通达位。现二种三，见道位中，无加行故。于修习位七地以前，若种若现俱通三种，八地以去现二种三，无功用道违加行故，所有进趣皆用后得，无漏观中任运起故。究竟位中现种俱二，加行现种俱已舍故。

    讲解：慧学有三种，一者加行无分别慧，二者根本无分别慧，三者后得无分别慧。这三种慧的自性、所依、因缘、所缘、行等，如《摄大乘论》所说。这三种慧，在最初的资粮、加行二位中，以种子而论，则三慧俱有，因为法尔有无漏种子。以现行而论，则唯有加行而没有根本、后得。因为根本、后得是无漏慧，在见道前还没有证得。在第三的通达位中：以现行而论则唯有根本、后得二慧，而没有加行慧，因为加行是有漏慧，见道已断，若以种子而论则三慧俱有。在第四的修习位中，七地已前，无论种子现行，俱通三慧，因为菩萨在七地已前还有加行功用，若到八地以后，那现行就唯有根本、后得二慧，而没有加打了。因为已达无功用道，违加行故，既违加行，则所有进趣，都用后得慧在无漏观中任运而起。在第五的究竟位中，无论现行、种子，都唯有根本、后得二慧，因为无学道已究竟断惑证理，加行的现行种子都已舍去了。

    论文十二：若自性摄，戒唯摄戒，定摄静虑，慧摄后五。若并助伴，皆具相摄。若随用摄，戒摄前三，资粮自体眷属性故，定摄静虑，慧摄后五，精进三摄，遍策三故。若随显摄，戒摄前四，前三如前及守护故，定摄静虑，慧摄后五。

    讲解：讲完戒定慧三学，现在是讲三学与十波罗蜜多相摄。如果从三学的自性含摄而论，则戒学只含摄戒度，定学唯舍摄静虑，慧学唯含摄最后的般若等五度了。若和资助三学的伴侣并论，则三学与十波罗蜜多都互相含摄。如果随顺作用含摄来说，则戒学摄前三种波罗蜜多，因为布施是戒学的资粮，持戒是戒学的自体，忍辱是戒学的眷属。定学唯摄静虑，慧学摄最后五波罗蜜多。至于精进波罗蜜多，则三学俱摄，因为它能够普遍策励三学。如果从显现的关系而论相摄，则戒学摄前四种波罗蜜多，因为前三种的施、戒、忍为戒学所摄，义同前说，第四精进能守护戒故，所以亦为戒学所摄；定学唯摄静虑，慧学摄最后五度。

    论文十三：此十位者，五位皆具，修习位中其相最显。然初二位，顿悟菩萨种通二种，现唯有漏。渐悟菩萨，若种若现俱通二种，已得生空无漏观故。通达位中，种通二种，现唯无漏。于修习位七地已前，种现俱通有漏无漏，八地已去种通二种，现唯无漏。究竟位中若现若种，俱唯无漏。

    讲解：此处讲五位与十波罗蜜多相摄。这十种波罗蜜多五位都有，特别在修习位其相最明显，因其通有漏、无漏，能行不住有、无二边的中道。然在资粮、加行的初二位中，则有顿渐之别。在直闻大乘的顿悟菩萨，种子通有漏、无漏，现行唯通有漏。若是回小向大的渐悟菩萨，则无论种、现俱通有漏、无漏。为什么渐悟菩萨的现行能并通无漏？因为他在二乘无学位中，已得了生空的无漏智。在第三的通达位中，种子通有漏、无漏，现行唯通无漏。在第四的修习位中，七地已前，种、现俱通有漏、无漏，八地已后，种子通有漏、无漏，现行唯通无漏。在第五的究竟位中，种、现唯通无漏。

    论文十四：此十因位有三种名：一、名远波罗蜜多，谓初无数劫，尔时施等势力尚微，被烦恼伏，未能伏彼，由斯烦恼不觉现行。二、名近波罗蜜多，谓第二无数劫，尔时施等势力渐增，非烦恼伏，而能伏彼，由斯烦恼故意方行。三、名大波罗密多，谓第三无数劫，尔时施等势力转增，能毕竟伏一切烦恼，由斯烦恼永不现行。犹有所知微细现种及烦恼种，故未究竟。

    讲解：这十波罗蜜多，在未成佛以前的因位中，有三种名称：一、名远波罗密多，意谓在最初无数劫的修行期间，这时所行施等波罗密多的作用还很微弱，反被烦恼所制伏，而不能伏彼烦恼，因此那烦恼就不知不觉的起现行。二、名近波罗密多，意谓在第二无数劫的修行期间，距果地较近，这时施等波罗密多的作用增大，不但不被烦恼所伏，而且能伏彼烦恼，由于伏烦恼故，作意力生起。三、名大波罗密多，就是菩萨进入第三无数劫的修行期间，将得菩提大果，这时施等波罗密多作用增盛，能够毕竟降伏一切烦恼，因此那烦恼就永远不再现行。但是还有所知障的微细现行与种子，及烦恼障的微细种子存在，还没有究竟。

    论文十五：此十义类，差别无边，恐厌繁文，略示纲要。十于十地虽实皆修，而随相增地地修一。虽十地行有无量门，而皆摄在十到彼岸。

    讲解：这十波罗蜜多，义类差别无穷无尽，《解深密经》和《瑜伽论》都有论述，但文字繁琐，恐学人厌恶繁文，故仅略示纲要。十波罗蜜多虽实为十地所皆修，然而随其相增，每一地不过唯修一度而已，如初地以施为增上，唯修施度，乃至十地以智为增上，唯修智度。虽十地的行门有无量无边之多，然而都为十到彼岸的胜行所收。

    第四节 别释十重障

    论文一：十重障者：一异生性障。谓二障中分别起者，依彼种立异生性故。二乘见道现在前时，唯断一种，名得圣性，菩萨见道现在前时，具断二种，名得圣性。二真见道现在前时，彼二障种必不成就，犹明与暗定不俱生，如秤两头，低昂时等，诸相违法理必应然。是故二性无俱成失。无间道时，已无惑种，何用复起解脱道为？为惑证灭，期心别故，为舍彼品粗重性故。无间道时虽无惑种，而未舍彼无堪任性。为舍此故，起解脱道及证此品择灭无为。

    讲解：此下讲证得二转依的第三因，断十重障。十重障是：一、异生性障，就是由分别起的所知、烦恼二障，依其种子建立异生性，所以名为‘异生性障’。声闻、缘觉二乘见道出现在前时，唯能断除烦恼障种，称为获得圣性，菩萨见道现在前时，断除烦恼、所知二障种子，称为获得圣性。

    有小乘有部论师问难曰：若异生性在见道前舍，无漏果起，可以说没有凡圣俱起之失，今既在见道所断的惑种上立异生性，那就是无间道里还有异生未断的惑种存在，岂不是有凡圣俱起的过失吗？答曰：无失，此唯依分别的二障种子立异生性，所以当二真见道现在前时，那二障种子必定不能成就。这好像明生暗灭，明与暗决定不能俱生一样。又好像秤的两头，高低时等，这头高时那头必低。一切相违的法，在道理上必然是这样的。因此凡、圣二性，没有俱成的过失。

    又有小乘师问难曰：在无间道还有烦恼种子生起，到解脱道进行对治，你们却认为在无间道时已无烦恼种子，既无烦恼种子，何必还要再起解脱道？答：这有两种原因，一、无间道能够断烦恼，解脱道能够证灭，二心期望有别，所以无间道既已断烦恼，还得要再起解脱道以证灭理。二、无间道时虽无烦恼种子，犹有彼品粗重的无堪任性未舍，起解脱道，就是要舍彼品的无堪任性，及证得此品的择灭无为。

    论文二：虽见道生，亦断恶趣诸业果等，而今且说能起烦恼，是根本故。由斯初地，说断二愚及彼粗重。一、执著我法愚，即是此异生性障。二、恶趣杂染愚，即是恶趣诸业界等。应知愚品，总说为愚，后准此释。或彼唯说利钝障品，俱起二愚。彼粗重言，显彼二种，或二所起无堪任性。如入二定说断苦根，所断苦根虽非现种，而名粗重，此亦应然。后粗重言，例此应释。

    讲解：虽然在见道生时，不但断异生障，而且亦断恶趣人天所起的业果，然而现在且说能起的烦恼，因为烦恼是业果的根本。由此说初地菩萨，断二种愚及彼粗重。二愚者，一、执著我法愚，此愚执著心外有实我、实法，不达我、法二空，就是这里所说的异生性障。二、恶趣杂染愚，此愚即恶趣及诸人天分别所起的杂染业果。我、法二执，可以说是愚，业果何以也说是愚呢？应知业果的体虽非愚，然而业是因愚所起，果是因愚所感，所以总说为愚。后面说到愚时，都准此例解释。

    或者初地要断的二种愚，就是利、钝障品相应而起的二愚，如执著我、法愚，是与利障俱起的愚，而恶趣杂染愚，是与钝障俱起的愚。至于所谓‘彼粗重’的话，是显示二种愚的种子，或著就是彼二愚所起的无堪任性。如《瑜伽论》说，入第二定，断彼苦根，苦根的种子在初定中虽说已断，今第二定再断彼苦根粗重。这里所断的无堪任性，亦应如此。向后诸地所说的粗重，都应当以此释为例。

    论文三：虽初地所断，实通二障，而异生性障意取所知，说十无明非染污故，无明即是十障品愚。二乘亦能断烦恼障，彼是共故，非此所说。又，十无明不染污者，唯依十地修所断说。虽此位中亦伏烦恼，断彼粗重，而非正意，不断随眠，故此不说。理实初地修道位中，亦断俱生所知一分。然今且说最初断者，后九地断准此应知。住满地中时既淹久，理应进断所应断障。不尔，三时道应无别。故说菩萨得现观已，复于十地修道位中，唯修永灭所知障道，留烦恼障助愿受生，非如二乘速趣圆寂。故修道位不断烦恼，将成佛时方顿斯故。

    讲解：虽然初极喜地见道所断，实通二障，但异生性障则唯取所知障，不取烦恼障。因为《摄大乘论》上说，以十种无明望二乘来说，不得谓为染污，若取烦恼障，那十种无明便亦通污染，而为十障品之愚了。小乘的声闻缘觉二乘也能断烦恼障，这是大乘和小乘所共，所以不在这大乘所说的范围。

    《摄大乘论》说，十无明对二乘人说为不染污者，那是依十地修所断说的，若依见所断说，那就不是不染污了。虽此十地修道位中，也伏烦恼断彼粗重，但那不是正义，因为不能断除烦恼的随眠，故此处不说。按道理说，在初地的修道位中，也能够断除一部分俱生的所知障，但现在唯说分别起的异生性障，不说俱生起的修所断障者，完全是约最初的入心来说的。初地断障既约入心而说，后九地断障，也准此从初地所说。怎样知道初地等出了入心的见道之后，更断其余的烦恼呢？因为在住地心与满地心（即出地心）中，所经过的时间既然很久，在道理说应更进一步断其所应断的所知障，否则的话，那入、住、出的三时道，就应当没有三品的差别了。所以《对法论》说：菩萨行者，得到六现观中的四、五两现观，复于十地的修道位中，唯修永灭所知障道。留下烦恼障不断，以助悲愿受生，随类应化，他不如二乘人的速断烦恼而趣于涅槃。所以菩萨在修道位中不断烦恼，直到将成佛时，才一齐顿断。

    论文四：二、邪行障，谓所知障中俱生一分，及彼所起误犯三业。彼障二地极净尸罗，入二地时便能永断。由斯二地说断二愚及彼粗重。一、微细误犯愚，即是此中俱生一分。二、种种业趣愚，即彼所起误犯三业。或唯起业，不了业愚。

    讲解：二、邪行障，就是所知障中俱生的一部分，及由此障所起误犯的身、语、意三业。这三业入二地时便能永断，不再误犯。所以《瑜伽论》说，菩萨进入二地要断二愚及其粗重。什么叫做二愚？一、微细误犯愚，就是所知障中俱生起的一部分。二、种种业趣愚，就是一部分俱生所知障，所生起的误犯三业。或者，唯说第一的微细误犯愚，是起业之愚；第二的种种业趣愚，是不了业之愚。这又是一种解释。

    论文五：三、闇钝障，谓所知障中俱生一分，令所闻、思、修法忘失。彼障三地胜定总持，及彼所发殊胜三慧，入三地时便能永断。由斯三地说断二愚及彼粗重。一、欲贪愚。即是此中能障胜定即修慧者，彼昔多与欲贪俱故，名欲贪愚，今得胜定及修所成，彼既永断，欲贪随伏，此无始来依彼转故。二圆满闻持陀罗尼愚，即是此中能障总持闻、思、慧者。

    讲解：三、闇钝障，这也是俱生所知障的一部分，令所闻、所思、所修之法忘失，不能明记。因此能障三地殊胜无漏禅定与总持，以及由此禅定及总持所发的闻、思、修三慧。此障二地未断，入三地时便能永远断除。因此，三地所断有二种愚及其粗重。什么叫做二愚？一、欲贪愚，就是此中能障胜定及修慧的那个愚。因为它过去常与贪欲在一起，以此名欲贪愚，今因三地中得无漏胜定及修所成慧，彼所知障的根本既已永断，那欲贪的枝末也就随之而伏灭了。当知这欲贪烦恼，无始以来，就是依彼所知障而转变的。二、圆满闻持陀罗尼愚，就是此中所说能障总持闻、思、慧的那个愚。

    论文六：四、微细烦恼现行障，谓所知障中俱生一分，第六识俱身见等摄。最下品故，不作意缘故，远随现行故，说名微细。彼障四地菩提分法，入四地时便能永断。彼昔多与第六识中任运而生执我见等同体起故，说烦恼名。今四地中既得无漏菩提分法，彼便永减，此我见等，亦永不行。初二三地，行施戒修，相同世间。四地修得菩提分法，方名出世，故能永害二身见等。宁知此与第六识俱？第七识俱执我见等，与无漏道性相违故，八地已去，方永不行，七地已来犹得现起，与余烦恼为依持故。此粗彼细伏有前后，故此但与第六相应。身见等言，亦摄无始所知障摄定爱法爱，彼定法爱，三地尚增，入四地时，方能永断，菩提分法特违彼故。由斯四地说断二愚及彼粗重：一、等至爱愚，即是此中定爱俱者。二、法爱愚，即是此中法爱俱者。所知障摄二愚断故，烦恼二爱亦永不行。

    讲解：四、微细烦恼现行障，这也是俱生所知障的一部分，属于第六意识相应俱生的身见等。因为它是最下品，不由作意而生，永远随顺现行，所以称为微细。这微细的烦恼现行，能障四地的菩提分法，进入四地时便能永远断除。此所知障，在过去时，多分与第六识中任运而生的我见等同时生起，所以称为烦恼。今在四地中，既得无漏菩提分法，这种微细烦恼所行障便永远灭除，我见等也就永远不起现行了。

    问：为什么在初、二、三地不能断除我见等呢？论主答：初地行施，二地行戒，三地行修，这与世间众生相同。今第四地证得菩提分法，方名出世，所以才能永灭烦恼、所知二障中的身见等。问：怎知这微细烦恼唯与第六识在一起，而不与第七识俱呢？

    答：因为第七识执我见等，与无漏道的性质相违，要到八地以后无漏相续时，才能永断不再现行，七地以前犹有有漏，还得现起，俾与其余的贪、嗔等烦恼作为依持。又，与第六识相应的身见等粗，与第七识相应的身见等细，粗的先伏，细的后伏，所以这微细烦恼，唯与第六识相应。

    这里所说的身见等，非但指贪、嗔、痴、慢等的本惑，也包括无始以来，所知障包含的定爱、法爱。这种定爱、法爱在前三地还在增加，入四地时方能永断，因为四地的菩提分法，与定爱、法爱是相违背的。

    由此四地断除的二愚及粗重，一、等至爱愚，就是这里所说的由定爱所伴随的愚法。二、法爱愚，就是这里所说的由法爱所伴随的愚法。所知障包括的二愚断除以后，，那烦恼障的定爱、法爱愚也就永远的不起现行了。

    论文七：五、于下乘般涅槃障，谓所知障中俱生一分。令厌生死乐趣涅槃，同下二乘厌苦欣灭，彼障五地无差别道，入五地时便能永断。由斯五地说断二愚及彼粗重。一、纯作意背生死愚，即是此中厌生死者。二、纯作意向涅槃愚，即是此中乐涅槃者。

    讲解：五、下乘般涅槃障，这也是俱生所知障中的一部分，能使人厌离生死，乐趣涅槃，就像小乘声闻、缘觉二乘一样，厌苦欣灭。下乘般涅槃障四地犹有，能障五地无差别道，进入五地时缘真实如理，生死涅槃都无差别，便能永断这下般涅槃障。所以说第五地断二种愚及其粗重。那二种愚？一、纯作意背生死愚，就是这里所说的厌恶生死。二、纯作意向涅槃愚，就是这里所说的对涅槃感到欣乐。

    论文八：六、粗相现行障，谓所知障中俱生一分，执有染净粗相现行，彼障六地无染净道，入六地时便能永断。由斯六地说断二愚及彼粗重：一、现观察行流转愚，即是此中执有染者，诸行流转染分摄故。二、相多现行愚，即是此中执有净者，取净相故，相观多行，未能多时住无相观。

    讲解：六、粗相现行障，这也是俱生所知障中的一部分，由于执著或染或净的粗相现行，它障碍六地无染净的妙道，入六地时便能永断。由这种因缘，故说入六地时，断除二愚及其粗重，那二种愚？一、现观察行流转愚，就是在第五地中，执有实在杂染的行人，现观苦集诸行流转，为有漏染分所摄。二、相多现行愚，就是在第五地中，执有实在净相的行人，因执取无漏净相，多作有相观行，而未能多时住于无相妙观。

    论文九：七、细相现行障，谓所知障中俱生一分。执有生灭细相现行，彼障七地妙无相道，入七地时便能永断。由斯七地说断二愚及彼粗重。一、细相现行愚，即是此中执有生者，犹取流转细生相故。二、纯作意求无相愚，即是此中执有灭者，尚取还灭细灭相故，纯于无相作意勤求，未能空中起有胜行。

    讲解：七、细相现行障，也是俱生所知障中的一部分。仍执著于生死流转的细相现行，这种细相能障碍第七地的妙无相道，当证入第七地时，缘无相真如，便能永断这种细相现行障。由此原因，说第七地断二种愚及其粗重。那二种愚？一、细相现行愚，就是这第六地中执有生相的行人，还执取有流转的微细生相。二、纯作意求无相愚，就是第六地执有灭相的行人，还执取有还灭的微细灭相，纯于无相作意勤求，未能冥合真、俗二境，于无相空理之中，不加作意而起有观的胜行。

    论文十：无相中作加行障，谓所知障中俱生一分，令无相观不任运起。前之五地，有相观多无相观少；于第六地，有相观少无相观多，第七地中纯无相观，虽恒相续而有加行，由无相中有加行故，未能任运现相及土。如是加行障八地中无功用道，故若得入第八地时便能永断，彼永断故得二自在。由斯八地说断二愚及彼粗重。一、于无相作功用愚。二、于相自在愚。令于相中不自在故，此亦摄土相一分故。八地以上纯无漏道任运起故，三界烦恼永不现行。第七识中细所知障犹可现起，生空智果不违彼故。

    讲解：八、无相中作加行障，这也是俱生所知障中的一部分，使第七地于无相观不能任运生起。前五地的观心尚劣，所以有相观时多，无相观时少。进而到了第六地，有相观时少，无相观时多，更进而至于第七地中，断了生灭细相，才能作纯无相观。虽纯无相观恒时相续犹有加行，由于无相中还有加行之故，所以未能任运对一切庄严等相及净秽等土自在显现，这种加行能障第八地中的无功用道，令不得入。所以若得入第八地时，便能永远断除这加行障，获得任运现相、现土的二种自在。因此说第八地断二种愚及其粗重。那二种愚？一、于无相作功用愚，就是第七地中，于无相观尚有加行功用的那种愚痴。二、于相自在愚，就是能令于身、土相中，不得自在显现的那种愚痴。

    八地以上，纯无漏道任运现起，所以三界烦恼就永远不再现行了。不过第七识中的微细所知障还可以现行，因为八地的生空智果，与第七识的法执末那，不相违故。

    论文十一：九、利他中不欲行障，谓所知障中俱生一分，令于利乐有情事中，不欲勤行，乐修己利。彼障九地四无碍解，入九地时便能永断。由斯九地说断二愚及彼粗重。一、于无量所说法、无量名句字、后后慧辩、陀罗尼自在愚，于无量所说法陀罗尼自在者，谓义无碍解，即于所诠总持自在，于一义中现一切义故。于无量名句字陀罗尼自在者，谓法无碍解，即于能诠总持自在，于一名句字中现一切名句字故。于后后辩陀罗尼自在者，谓词无碍解，即于言音展转训释总持自在，于一音声中现一切音声故。二、辩才自在愚，辩才自在者，谓辩无碍解，善达机宜巧为说故。愚能障此四种自在，皆是此中第九障摄。

    讲解：九、利他中不欲行障，也是俱生所知障中的一部分，在做利乐有情的事业中，不欲勤奋行动，只是勤修自利。这种对饶益有情事不欲去行，是第九地义、法、词、辩四无碍解的大障，菩萨入第九地时便能永断。因此说第九地断二种愚及其粗重。

    那二种愚，一、于无量所说法、无量名句字、后后慧辩陀罗尼自在愚，就是以一陀罗尼贯通三无碍辩：一者于无量所说法陀罗尼自在，就是‘义无碍解’，在所诠释的义理上能够总持自在。因为菩萨说法，能于一义中现一切义故。二者于无量名句字陀罗尼自在，就是‘法无碍解’，在能诠的名句字上能总持自在。因为菩萨说法，能于一名句字中现一切名句字故。三者于后后慧辩陀罗尼自在，就是‘词无碍解’，在以言说音声展转为众生训解释义时，能总持自在。因为菩萨说法，能于一方音声中现一切音声故。二、辩才自在愚，就是‘辩无碍解’，菩萨能善达众生机缘，权宜巧便而为说法。以上所说的四无碍解，唯愚能障，使之不得自在，所以总说为愚。

    论文十二：十、于诸法中未得自在障，谓所知障中俱生一分，令于诸法不得自在。彼障十地大法智云，及所含藏所起事业，入十地时便能永断。由斯十地说断二愚及彼粗重：一、大神通愚，即是此中障所起事业者。二、悟入微细秘密愚，即是此中障大法智云及所含藏者。

    讲解：十、于诸法中未得自在障，也是俱生所知障中的一部分。菩萨因此障的存在，虽得四无碍解，犹于诸法不得自在。能障十地缘真如大法如云之智，及所含藏的陀罗尼门、三摩地门等功德，与所起的神通事业。从九地进入第十地时，便能永断此障。因此说十地断二种愚及其粗重。那二种愚？一、大神通愚，就是此九地中障碍所起利他事业，不令显现的愚痴。二、悟入微细秘密愚，就是第九地里能障微细秘密的大法智云，及其所含藏的诸功德等，不令悟入的那种愚痴。

    论文十三：此地于法虽得自在，而有余障，未名最极。谓有俱生微所知障，及有任运烦恼障种，金刚喻定现在前时，彼皆顿断入如来地。由斯佛地说断二愚及彼粗重。一、于一切所知境极微细著愚，即是此中微所知障。二、极微细碍愚，即是此中一切任运烦恼障种。故集论说：得菩提说，顿断烦恼及所知障，成阿罗汉及成如来，证大涅药大菩提故。

    讲解：这第十地菩萨，虽已对法得到自在，但是还有余障存在，未得名为最极。这余障就是俱生的微细所知障，及任运的烦恼障种子，要到金刚喻定现前的时侯，才能顿断此障入如来地。因此说佛地断二种愚及其粗重。那二种愚，一、于一切所知境极微细著愚，就是第十地里尚有俱生微所知障的执著。二、极微细碍愚，就是这十地里所有一切任运烦恼障种的那种愚。因为二愚为佛地所断，所以《杂集论》上说：得菩提时，顿断烦恼及所知障，成阿罗汉及成如来，证得了大涅槃及大菩提的二种极果。

    论文十四：此十一障　二障所摄。烦恼障中见所断种，于极喜地见道初断。彼障现起地前已伏。修所断种金刚喻定现在前时一切顿断。彼障现起地前渐伏，初地以上能顿伏尽，令永不行，如阿罗汉。由故意力前七地中虽暂现起，而不为失，八地以上毕竟不行。

    讲解：上文解释十重障，乘便也解释了佛地障，这就成为十一障了。这十一障，总为烦恼、所知二障所摄。以下说明这二障的伏断位次，今先明烦恼障。烦恼障中属于见道所断的分别种子，在菩萨极喜地的真见道时，无分别智生起之初便断，并非相见道的后得智能断此障。然而，彼烦恼障的分别现行，以直悟菩萨来说，他在未登地前的资粮、加行位中，已经被伏灭了。

    修道所断的俱生种子，到金刚喻定现前的时侯，才能一切顿断。然而，在地前的三贤位中已少分渐伏，初地以上便能顿时伏尽，使之永不现行，好像证了阿罗汉果一样。虽在前七地中，犹有不怕烦恼的菩萨，由故意力故暂起现行，但不会因烦恼而犯了过失。八地以上，就毕竟不起现行了。

    论文十五：所知障中见所断种，于极喜地见道初断。彼障现起，地前已伏。修所断种，于十地中渐次断灭，金刚喻定现在前时，方永断尽。彼障现起地前渐伏，乃至十地方永伏尽。八地以上，六识俱者不复现行，无漏观心及果相续能违彼故。第七俱者犹可现行，法空智果起位方伏。前五转识，设未转依，无漏伏故，障不现起。

    讲解：上节讲烦恼障伏断位次，此节讲所知障伏断位次。所知障中，属于见道所断的分别种子，在菩萨极喜地的见道位最初所断，至于此障的分别现行，也在极喜地前的加行位时已被伏断了。至于修道所断的俱生种子，在十地中一地一地的逐渐断灭，直到金刚喻定现前的时候才永远断尽。

    八地以上，与第六识俱起所知障不再现行，因为二空的无漏观智及漏尽定果，相续不断的起违抗作用。与第七识俱起的所知障还是可以现行，因第七识的法执，要到法空智果的金刚位时才能伏断。如果前五转识的所知障还没有证转依，就由第六识俱的无漏所伏，不令现起。

    论文十六：虽于修道十地位中，皆不断灭烦恼障种，而彼粗重亦渐断灭，由斯故说二障粗重，一一皆有三位断义。虽诸位中皆断粗重，而三位显，是故偏说。

    讲解：有问难曰：虽然在修道位的十地中，不能断灭烦恼障种子，但已将其粗重渐渐断灭。所以《瑜伽论》说，烦恼、所知二障的粗重，一一都有三位断义。断烦恼障的三位是；一者极喜地，断上中品烦恼。二者决定位，断下品烦恼。三者金刚位，断三品烦恼的习气随眠。断所知障的三位是：一者在皮，即见道位。二者在肤，即不动地位。三者在肉，即佛地位。有问曰：若烦恼粗重，不属种子，岂非地地皆断，何以但说三位？答：虽十地的每一阶位中皆断粗重，而三位特显，如无漏观心的初起、无间、圆满。所以偏说三位断，而不说地地皆断。

    论文十七：断二障种，渐顿云何？第七识俱烦恼障种，三乘将得无学果时，一刹那中三界顿断。所知障种，将成佛时，一刹那中一切顿断，任运内起无粗细故。余六识俱烦恼障种见所断者，三乘见位真见道中，一切顿断。修所断者，随其所应，一类二乘，三界九地，一一渐次，九品别断，一类二乘，三界九地，合为一聚，九品别断；菩萨要起金刚喻定，一刹那中三界顿断。所知障种，初地初心，顿断一切见所断者。修所断者，后于十地修道位中，渐次而断，乃至正起金刚喻定，一刹那中方能断尽。通缘内外粗细境生，品类差别有众多故。

    讲解：有问曰：断二障种子时，其渐顿的情况如何呢？答曰：与第七识俱起的烦恼障种子，在三乘圣者将要证得无学果时，三界所有烦恼，一刹那间顿断。与第七识俱起的所知障种子，在将成佛时一刹那间一切顿断。因为第七识的我、法二执，是任运而起，唯缘本识自内之境，他没有品类粗细的差别，所以能够顿断。与其余六识俱起烦恼障种子，属于见道所断，三乘人在见道位的真见道中一切顿断。在修道位所断除的，随其根的钝利所应，而有渐顿之别了。有一类渐次得果的钝根二乘人，在三界九地的八十一品烦恼，必须一地一地的各分九品而渐次别断，有一类超越不还的利根二乘，他能将三界九地的八十一品烦恼，合为一聚九品而一一别断，菩萨要到金刚喻定生起，于一刹那间三界顿断。与六识相应的所知障种子，属于见道所断的，菩萨于进入初地入心，一切顿断。属于修道所断的，后于十地的修道位中，渐次而断，直到正起金刚喻定时的一刹那间，才完全断尽。因为他不同于唯缘内境的第七识，而是通缘内外粗细境生，品类有很多差别，所以诸地渐次别断。

    论文十八：二乘根纯，渐断障时，必各别起无间、解脱、加行、胜进，或别或总。菩萨利根，渐断障位，非要别起无间解脱，刹那刹那能断证故。加行等四，刹那刹那前后相望，皆容俱有。

    讲解：二乘人的根机迟钝，所以他们于渐断障时，必然生起无间道、解脱道、加行道、胜进道，或分别生起，或总的生起。菩萨行者，因为根利，所以于修道的渐断障位，并非同二乘一样别起无间解脱，而是刹那刹那念念都能断惑证理；加行、无间、解脱、胜进四道，刹那刹那前后相望，每一道皆容许具有其余三道。

    第五节 别释十真如

    论文一：十真如者，一、遍行真如：谓此真如二空所显，无有一法而不在故。二、最胜真如：谓此真如具无边德，于一切法最为胜故。三、胜流真如：谓此真如所流教法，于余教法极为胜故。四、无摄受真如：谓此真如无所系属，非我执等所依取故。五、类无别真如：谓此真如类无差别，非如眼等类有异故。六、无染净真如：谓此真如本性无染，亦不可说后方净故。七、法无别真如：谓此真如虽多教法，种种安立而无异故。八、不增减真如：谓此真如离增减执，不随净染有增减故，即此亦名相土自在所依真如，谓若证得此真如已，现相现土俱自在故。九、智自在真如：谓若证得此真如已，于无碍解得自在故。十、业自在等所依真如，谓若证得此真如已，普于一切神通作业总持定门，皆自在故。

    讲解：本第五节的重点，是在如何证得二转依果。要证得二转依果，有四种能证之因，就是要历经十地，修十胜行（十波罗蜜多），断十重障，证十真如，至此始能证得二种转依。换一个方式来说，十地是所经的位次，十胜行（十波罗蜜多）是所修的因，十重障是所对治的断法，证十真如，就是所观照的真理。能证四因已讲解其三，于此来讲解第四因的十真如了：

    一、遍行真如：这是初地菩萨，证得我、法二空所显的平等如理，遍法界中没有任何一法不存在于此真如之中。

    二、最胜真如：这是二地菩萨，远离微细遮罪烦恼尘垢之所证，所以具有无边庄严的净德，在一切法中最为超胜。

    三、胜流真如：这是三地菩萨，成就总持大法的胜定所显，因此，从这真如流出的教法，望其余教法，极为殊胜。

    四、无摄受真如：这是四地菩萨，断了微细烦恼现行障之所显，因此，他无所系属，并非我执、我慢、我爱、无明、边见、我所见等之所依取。

    五、类无别真如：这是五地菩萨合真俗二观，无生死、涅槃差别之所证，他不同眼等，随著有情类而有别异一样。

    六、无染净真如：这是六地菩萨，观一切法缘生无性的如智之所显发。因此真如的本性并非染污，所以也不可说是后来才清净的。

    七、法无别真如：这是七地菩萨，离了生灭细相现行所显的如理，虽有胜义法界、实相等，多种教法的安立，而此真如，体实无异。

    八、不增减真如：这是八地菩萨，于无功用道中离了增、减二执的如理，他不随著得净而起增执，断染而起减执。即此离增减执，也可以名相土自在所依真如。因为证得了这真如已后，无论现相现土，都能不加功用的任运自在。

    九、智自在所依真如：这是九地菩萨，证得了这真如已后，能于四无碍解，获得了善说法要的自在，成利他行。

    十、业自在等所依真如：这是十地菩萨，证了这真如已后，遍于利乐有情的一切神通作业、陀罗尼的总持、三摩地的胜定，都能够自在无碍。

    论文二：虽真如性实无差别，而随胜德假立十种，虽初地中已达一切，而能证行犹未圆满，为令圆满，后后建立。

    讲解：虽然真如的性质，实际上并无差别，而随顺其殊胜功德，假立十种名称。虽然菩萨在于初地就已通达真如之理，但其能证的行位还没有圆满，为了使之圆满，所以才于初地之后，依次建立了这十种真如。

    论文三：如是菩萨于十地中，勇猛修行十种胜行，断十重障，证十真如，于二转依便能证得。

    讲解：菩萨在十地中，就是这样勇猛的修习十种胜行，断除十重障，证得十真如，这样就能够证得大菩提、大涅槃二种胜果。

    第六节 别释二转依

    论文一：转依位别，略有六种，一损力益能转，谓初二位，由习胜解及惭、愧故，损本识中染种势力，益本识内净种功能，虽未断障种，实证转依，而渐伏现行亦名为转。

    讲解：转依的位别，简略来说有六种，一、损力益能转，就是在第一资粮位和第二加行位，由于修习胜解及惭、愧，损减了阿赖耶识中染污种子的势力，增益了阿赖耶识中清净种子的功能，虽然尚未断二障种子，实际上已经证得转依，因为它已逐渐降伏二障现行，所以也得名为转依。

    论文二：二通达转，谓通达位，由见道力通达真如，断分别生二障粗重，证得一分真实转依。三修习转，谓修习位，由数修习十地行故，渐断俱生二障粗重，渐次证得真实转依。摄大乘中说通达转在前六地，有无相观，通达真俗间杂现前，令真非真现不现故。说修习转。在后四地。纯无相观，长时现前，勇猛修习断除粗重，多令非真不显现故。

    讲解：二、通达转，就是在通达位，由见道之力通达了真实如理，断除分别所生的二障粗重，证得了一部分真实的转依，所以名通达转。三、修习转，就是在修习位，数数不断的修习从初地住心到十地满心的波罗密多，渐次断俱生而起的二障粗重，证得了真实转依。《摄大乘论》上说，通达位在前六地，以有相观通俗，无相观通真，当真实义相显现的时候，非真实义相就不显现。《瑜伽论》等说修习转在后四地，无相观长时出现，经过勇猛修行，断除其粗重，使不真实的义相不再显现，所以名修习转。

    论文三：四、果圆满转，谓究竟位，由三大劫阿僧企耶，修习无边难行胜行，金刚喻定现在前时，永断本来一切粗重，顿证佛果圆满转依，穷未来际利乐无尽。五、下劣转，谓二乘位，专求自利，厌苦欣寂，唯能通达生空真如，断烦恼种，证真择灭，不能有所堪任，所以名下劣转。六、广大转。即大乘位，为利他故，趣大菩提，生死涅槃，俱无欣厌，具能通达二空真如，双断所知烦恼障种，顿证无上菩提涅槃。有胜堪能，名广大转。此中意说广大转依，舍二粗重而证得故。

    讲解：四、果圆满转，就是第五的究竟位，由于历经三大阿僧企耶，修习无边无际的难行和胜行，直到金刚喻定现前的时候，永远断除了本来的二障粗重，顿时证得究竟佛果，证得圆满转依，穷未来际利乐有情，无有尽时。

    五、下劣转，就是二乘行者，他们专求自利，不求利他，厌生死苦，欣寂灭乐，只通达生空真如，唯断烦恼障种子，证得真择灭，无殊胜功能，不能有所堪任，所以名下劣转。

    六、广大转，就是大乘的菩萨位，为利他故，趣向于菩提大果，不舍生死，不取涅叶，所以菩萨于生死涅槃，都无所欣厌，具能通达生空、法空二空真如，双双断了所知、烦恼二障种子，顿证无上菩提、及大般涅槃。因为有比殊胜的功能，有所堪任，所以名为广大转。转依义别虽有六种，但是颂中所取的转依体，是约第六的广大转依来说的。因为颂中说：‘舍二粗重故，便证得转依’，广大转依，就是菩萨修十地行，地地舍二粗重而证得的。

    论文四：转依义别，略有四种。一、能转道，此复有二：一能伏道，谓伏二障随眠势力，令不引起二障现行。此通有漏无漏二道，加行、根本、后得三智。随其所应渐顿伏彼。二、能断道，谓能永断二障随眠。此道定非有漏加行，有漏曾习相执所引，未泯相故：加行趣求所证所引，未成办故。

    讲解：转依的意义，简略来说有四种。第一种是‘能转道’，这又分为二种：一、能伏道，就是能降伏烦恼、所知二障随眠的势力，使之不能引起二障现行。它通有漏、无漏二道，及加行、根本、后得三智。随其三智的所应，或渐或顿的降伏二障随眠势力。二、能断道，就是永远断除二障随眠，能断道决定不是有漏加行，因为有漏心加行智和有漏后得智，前者是曾习道，后者是相执之所引，未能泯伏灭除此相，所以不能断惑。无分别智是加行所引，真如是加行智所趣所求，即由所引无分别智能证所证真如。

    论文五：有义，根本无分别智，亲证二空所显真理，无境相故，能断随眠。后得不然，故非断道。有义，后得无分别智，虽不亲证二空真理，无力能断迷理随眠，而于安立非安立相，明了现前，无倒证故，亦能永断迷事随眠。故瑜伽说：修道位中，有出世断道，世出世断道，无纯世间道，能永害随眠，是曾习故，相执引故。由斯理趣，诸见所断及修所断迷理随眠，唯有根本无分别智亲证理故，能正断彼。余修所断迷事随眠，根本后得俱能正断。

    讲解：有人认为，唯有根本无分别智，直接证得我、法二空所显的真理，因无外境相分，故能断除二障随眠。后得智就不然了。因为以后得智作无相观时，还有相分的境相存在，不能断障，所以他不是能断道。

    又有人认为，后得的无分别智，虽不能亲证二空所显真理，没有能力断除迷理随眠，但能明确认识安立谛及非安立谛相，因为没有颠倒认识，所以也能够永远断除迷事随眠。因此，《瑜伽论》上说：在修道位里有二种断道，一种是根本无分别智的出世断道，一种是后得无分别的世出世断道。没有有漏心的纯世间道，能够永断随眠，因为有漏心是曾习境，是由相执之所引生的。由此理趣可见，各种见道所断和修道所断的迷理随眠，唯有根本无分别智，亲证二空真理，才能正式断了它们。其余修道所断贪、嗔、无明、慢等的迷事随眠，则根本智和后得智都能正确断除。

    论文六：二所转依，此复有二，一持种依，谓根本识，由此能持染净法种，与染净法俱为所依，圣道转令舍染得净。余依他起性，虽亦是依，而不能持种，故此不说。二迷悟依，谓真如。由此能作迷悟根本，诸染净法依之得生，圣道转令舍染得净。余虽亦作迷悟法依，而非根本，故此不说。

    讲解：第二种是‘所转依’，这又分为二种：一、持种依，就是第八根本识，由于这根本识能执持染、净法种子，而为染、净法之所依，修行圣道，能够使它舍除染法，得到净法，所以名为转依。其余的依他起性，虽亦是转依，但不能执持种子，所以这里唯说根本识而不说依他。二、迷悟依，就是真如。由于这真如能作迷悟的根本，各种染法和净法都依之而生。修行圣道，能转令舍染得净，所以名为转依。其余的依他起性，虽亦为迷悟法之所依，而非根本，所以这里唯说真如为迷悟依，而不说依他。

    论文七：三所转舍，此复有二：一所断舍，谓二障种，真无间道现在前时，障治相违，彼便断灭，永不成就，说之为舍。彼种断故，不复现行妄执我法。所执我法不对妄情亦说为舍，由此名舍遍计所执。二所弃舍，谓余有漏劣无漏种，金刚喻定现在前时，引极圆明纯净本识，非彼依故，皆永弃舍。彼种舍已，现有漏法及劣无漏毕竟不生，既永不生，亦说为舍。由此名舍生死劣法。有义，所余有漏法种及劣无漏，金刚喻定现在前时，皆已弃舍，与二障种俱时舍故。有义，尔时犹未舍彼，与无间道不相违故，菩萨应无生死法故，此位应无所熏识故，住无间道应名佛故，后解脱道应无用故。由此应知余有漏等，解脱道起，方弃舍之，第八净识，非彼依故。

    讲解：第三种是‘所转舍’，这又分为二种，一、所断舍，就是烦恼、所知二障种子。真正无间道出现在前的时候，障碍和对治互相违逆，二障种子就断灭了，永远不再成就，所以称之为舍。因为二障种子断灭了，不再成为现行虚妄执著的我和法。所执实我实法本来是对妄情而说，现在妄情已断，不可能再对妄情发生作用了，所以应当随之而舍。所以，这叫做舍除遍计所执。二、所弃舍，就是有漏种子和弱劣的无漏种子，当金刚喻定出现在前的时候，引生极其圆满光明纯净无杂的阿赖耶识，它不是这种种子的所依，所以要永远舍除。这种种子舍除以后，有漏法种子和弱劣的无漏种子终究不能再生。既然永远不能再生，也称之为舍。由此道理名舍生死法及劣法。

    有人认为，二障所余的有漏法种及劣无漏法，在金刚喻定现前的时侯，都已经舍除。因为他们同二障种子俱时而生，当然也是俱时而舍。第二师说，金刚心时还没有弃舍，因为它们与无间道并不相违，菩萨应当是没有生死之法，因为此位应当没有所薰之识，住于无间道应当称为佛，以后的解脱道应当是没有作用了。由此应当知道，剩余的有漏等，当解脱道生起的时候，才能够丢弃舍除，因为解脱道位的第八净识，不是这劣无漏及余有漏法的所依。

    论文八：四所转得，此复有二。一所显得，谓大涅槃，此虽本来自性清净，而由客障覆令不显，真圣道生，断彼障故，令其相显，名得涅槃。此依真如离障施设，故体即是清净法界。

    讲解：第四种是‘所转得’，这又分为二种。一所显得，就是大涅槃。涅槃与小乘唯断烦恼的寂灭不同，所以称大涅槃。大涅药其本来自性虽然清净，由于客尘的烦恼、所知二障的覆盖，使他不得显现，到能证真理的圣道生时，把客障断了，才能使涅槃相显，因为大涅槃是依真如离障而施设的，并非有相，所以他的自体就是清净法界。

    论文九：涅槃义别，略有四种：一、本来自性清净涅槃，谓一切法相真如理，虽有客染而本性净，具无数量微妙功德，无生无灭，湛若虚空，一切有情平等共有，与一切法不一不异，离一切相一切分别。寻思路绝，名言道断，唯真圣者自内所证，其性本寂，故名涅槃。二、有余依涅药，谓即真如出烦恼障，虽有微苦所依未灭，而障永寂，故名涅槃。三、无余依涅药，谓即真如出生死苦，烦恼既尽，余依亦灭，众苦永寂，故名涅槃。四、无住处涅槃，谓即真如出所知障，大悲般若常所辅翼，由是不住生死涅槃，利乐有情穷未来际，用而常寂，故名涅槃。

    讲解：涅槃的义别，略有四种。一、本来自性清净涅槃，就是一切法相的真如理性，虽为客尘所染，而自性清净，具足无量数微妙功德，无生无灭，湛然凝寂，有如虚空，为十界凡圣一切有情平等共有。与一切法非一非异，离一切所取、能取的分别。因其非粗心境，所以寻思路绝，名言道断。唯是真正圣者的自内所证，其性本寂，所以名为涅槃。

    二、有余依涅槃，就是真如出离烦恼的障蔽，虽然还有微细苦果的依身未灭，而烦恼障却已永远的寂灭，所以名为涅槃。

    三、无余依涅槃，就是真如出离了生死苦的缠缚，此时烦恼的苦因既尽，所余的依身苦果亦灭，如是众苦永寂，所以名为涅槃。

    四、无住处涅槃，就是真如出离所知障，此时菩萨的大悲、大智，如鸟之两翼，相辅而行。由大智故，不住生死，由大悲故，不住涅槃。如是利乐有情，尽未来际，虽妙用无穷，而体常寂，所以名为涅槃。

    论文十：一切有情，皆有初一，二乘无学，容有前三，唯我世尊，可言具四。如何善逝有有余依？虽无实依，而现示有，或苦依尽，说无余依，非苦依在，说有余依，是故世尊可言具四。若声闻等有无余依，如何有处说彼非有？有处说彼都无涅槃，岂有余依彼亦非有，然声闻等身智在时，有所知障，若依未尽，圆寂义隐，说无涅槃，非彼实无烦恼障尽所显真理有余涅槃。尔时未证无余圆寂，故亦说彼无无余依，非彼后时灭身智已，无苦依尽无余涅槃。或说二乘无涅槃者，依无住处，不依前三。

    讲解：一切有情，都有第一种的自性清净涅槃。二乘无学容许有前三种涅槃，只有释迦世尊，具有四种涅槃。为什么善逝──佛，尚有有余依涅槃，难道说佛的苦依还没有尽吗？答曰：佛虽没有实在苦依未尽的有余依涅槃，然而为应化示现的苦谛，似有有余。或约苦依尽说，名无余依；约非苦的无漏依身而说，名有余依。以是之故，世尊是具足四种涅槃。

    声闻、缘觉二乘圣者，如平常说，有无余依涅槃。为何有处如《胜鬘经》说，彼二乘没有无余依呢？答曰：经上说这些二乘人，无论有余、无余涅槃全都没有，并不是但说无无余依。然而实在说，声闻、缘觉的二乘圣者，报身报智尚在而未灭的时候，尚有所知障及苦果的依身未尽，圆寂的意义隐昧不显，所以经上说他没有涅槃，并不是说二乘圣者，实无烦恼障断尽已后所显真理之有余依涅槃。尔时二乘圣者，还没有证到无余的圆寂，所以也说他没有无余依，并不是说他灭了身智已后，没有苦依已尽的无余涅槃。或者经说二乘没有涅槃，是依第四的无住处涅槃说的，并不是依前三涅槃而说。

    论文十一：又说彼无无余依者，依不定性二乘而说。彼才证得有余涅槃，决定迥心求无上觉，由定愿力，留身久住，非如一类入无余依。谓有二乘深乐圆寂，得生空观，亲证真如，永灭感生烦恼障尽，显依真理有余涅槃。彼能感生烦恼尽故，后有异熟无由更生。现苦所依任运灭位，余有为法既无所依，与彼苦依同时顿舍，显依真理无余涅槃。尔时虽无二乘身智，而由彼证，可说彼有。此位唯有清净真如，离相湛然，寂灭安乐，依斯说彼与佛无差：但无菩提利乐他业，故复说彼与佛有异。

    讲解：而且，这里说二乘无无余依者，是依不定性的二乘说的。他们才证得有余涅槃，就决定再回小向大，求无上觉。由于这样的定力和愿力，不厌生死，留身久住，在世间修利他行。这与那一类定性二乘，但厌生死，入无余涅槃不同，所以说他为无无余依。

    定性二乘，深深的耽乐圆寂，厌患生死，缘无我境，得生空观智，亲证真如，把感生死苦报的烦恼障灭除尽净，由于彼能感生死的烦恼因尽，后有的异熟报果，就无从再生，现在的苦所依身，也只有任运而灭了。在这现苦所依的任运灭位，那其余能依的有为法，既无所依，便与彼苦依同时顿舍，显示了依于真如理的无余涅槃。

    苦依与智既然同时而舍，谁能证于无余真理呢？要知入无余的那个时候，虽说没有二乘的身智，然而由彼二乘能证此灭，故亦可说二乘有无余依，并不是说身智在的时候，可说二乘名有无余依。或者有人说，既证无余，便与佛等，为什么二乘与佛有异？答曰：此位既断烦恼，证得清净真如，离分别妄想，得寂灭之乐，根据这一点意义，可说二乘与佛没有差别。但因二乘没有上求菩提、下化有情的事业，所以又说二乘与佛是有差别的。

    论文十二：诸所知障既不感生，如何断彼得无住处？彼能隐覆法空真如，令不发生大悲般若，穷未来际利乐有情，故断彼时显法空理，此理即是无住涅槃，令于二边俱不住故。

    讲解：外人问曰：一切所知障既然都不招感生死，怎么说断了所知障便能得无住处涅槃呢？答曰：所知障虽不感生死，但能隐覆法空真理，使之不能发生大悲般若，穷未来际利乐有情，所以断彼障时，才能显示法空的真理。当知这法空真理，就是无住处涅槃。因为令于生死、涅槃二边俱不住故。

    论文十三：若所知障，亦障涅槃，如何断彼，不得择灭？择灭离缚，彼非缚故。既尔，断彼宁得涅槃？非诸涅槃皆择灭摄。不尔，性净应非涅槃，能缚有情住生死者，断此说得择灭无为，诸所知障不感生死，非如烦恼，能缚有情，故断彼时，不得择灭。然断彼故，法空理显，此理相寂，说为涅槃，非此涅槃择灭为性，故四圆寂诸无为中，初后即真如，中二择灭摄。

    讲解：外人又问：假使所知障亦障涅槃的话，为什么断了所知障不能得到择灭呢？论主答曰：择灭无为是离烦恼障缚所显的，但所知障并不像烦恼那样系缚有情。外人又问：既然如此，断离缚怎样得到涅槃呢？论主答曰：并不是一切涅槃都归择灭所摄，不然的话，那不属择灭的自性清净．就应当不是涅槃了。要知道，能缚有情住于生死的东西，唯是烦恼，这烦恼断了，才叫做得择灭无为。诸所知障不感生死，并不像烦恼障那样能系缚有情，所以断彼障时，不得择灭。但是断除了此障，就使法空真理得以显现，这法空理相本寂灭，所以说名涅槃，并不是这涅槃以择灭为性。因此之故，四种涅槃在各种无为中，第一和第四种是真如，中间的有余、无余二种是择灭无为。

    论文十四：若唯断缚得择灭著，不动等二，四中谁摄？非择灭摄，说暂离故，择灭无为唯究竟灭，有非择灭，非永灭故。或无住处，亦择灭摄，由真择力，灭障得故。择灭有二：一灭缚得，谓断感生烦恼得者。二灭障得，谓断余障而证得者。故四圆寂诸无为中，初一即真如，后三皆择灭。不动等二暂伏灭者，非择灭摄，究竟灭者，择灭所摄。

    讲解：外人又问：假定如上所说，唯有断缚方得择灭的话，那不动无为及想受灭无为，在四种无为中何者所摄呢？论主答曰：并不属于择灭无为，因为《显扬圣教论》说，这二种无为不过暂时离缚，而择灭无为唯究竟灭。不动及想受灭，他们但有非择灭缺缘不生的意义，而不是永灭，所以是非择灭摄。

    或者还有一种解释，无住处涅槃，也可以说是择灭所摄。因其体虽非缚，却是由法空观智的真简择力，灭了所知障而证得之故，所以也是择灭所摄。择灭无为有二种：一种是灭缚得，即是断了感生死的烦恼所得的择灭；一种是灭障得，即断除烦恼之余的所知障而证得的择灭。所以四种涅槃在四无为法中：初一的自性涅槃即是真如，后三的有余、无余、无住处涅槃都是择灭。不动及想受灭这二种无为，是暂时伏灭的，并不属于择灭无为，究竟灭除的才属于择灭所摄。

    论文十五：既所知障亦障涅槃，如何但说是菩提障？说烦恼障但障涅槃，岂彼不能为菩提障？应知圣教依胜用说，理实俱能通障二果。如是所说四涅槃中，唯后三种名所显得。

    讲解：外人又问：既然所知障亦障涅槃，如何圣教中但说是菩提障呢？论主答曰：如果圣教说烦恼障但障涅槃，这岂不是说他不能为菩提障吗？应知所知障，以能障菩提的功用为胜；烦恼障，以能障涅槃的功用为胜，依这二障的殊胜作用来说的，理实而论，二障都能通障菩提、涅槃二果。像以上所说的四种涅槃中，唯有后三种称为所显得。

    论文十六：二、所生得，谓大菩提。此虽本来有能生种，而所知障碍故不生。由圣道力，断彼障故，令从种起，名得菩提。起已相续，穷未来际。此即四智相应心品。

    讲解：二、所生得，就是大菩提。它本来就有法尔能生的种子，然而由于所知障的障碍，使之不得生起。由于圣道之力断了所知障，令菩提从能生的种子而生起，这就叫做得菩提。起了现行已后，相续不断穷未来际，这就是四智相应心品。

    论文十七：云何四智相应心品？一、大圆镜智相应心品：谓此心品，离诸分别，所缘行相，微细难知，不忘不愚一切境相，性相清净离诸杂染，纯净圆德现种依持，能现能生身土智影，无间无断，穷未来际，如大圆镜，现众色像。

    讲解：什么叫四智相应心品？一、大圆镜智相应心品：就是说这种心品，远离各种虚妄分别，所缘行相微细难知。不忘、即一切种智不忘失于诸差别相；不愚、即一切智不愚闇于平等空性。此心品性相俱得清净，没有各杂染，纯净圆满具足一切德相，是现行功德所依，种子功德之持，能现无量身、土，乃至其余的三智等境皆悉影现。从无间断，穷无来际，好像一个大圆镜似的，影现各种色像。

    论文十八：二、平等性智相应心品：谓此心品，观一切法自他有情悉皆平等，大慈悲等恒共相应，随诸有情所乐，示现受用身土影像差别，妙观察智不共所依，无住涅槃之所建立，一味相续，穷未来际。

    讲解：二、平等性智相应心品，此心品在凡夫位时，因有我执，自、他差别：今转凡成圣，证得二无我理，观察一切法及自、他有情，都一律平等。大慈悲等恒与此智相应，随著各种有情众生之所乐，示现有差别的受用身土影像，与妙观察智是不共所依。悲智由无住涅槃所建立，如大海水一味不变，相续不断，穷未来际。

    论文十九：三、妙观察智相应心品：谓此心品，善观诸法自相共相，无碍而转，摄观无量总持定门，及所发生功德珍宝，于大众会，能现无边作用差别，皆得自在，雨大法雨，断一切疑，令诸有情皆获利乐。

    讲解：三、妙观察智相应心品：意谓这种心品，善于观察诸法的自相和共相，无碍而转，又能摄藏并观察无数无量的陀罗尼、三摩地，及其发生的六度道品、十力等的功德珍宝，在大众集会时示现无边神通，一一皆得自在，雨大法雨，断一切众疑，令诸有情都获得利益和安乐。

    论文二十：四、成所作智相应心品：谓此心品，为欲利乐诸有情故，普于十方示现种种变化三业，成本愿力所应作事。

    讲解：成所作智相应心品：谓此心品，为了使一切有情都得到安和利乐，普遍于十方世界示现种种变化，以身、语、意三业，成就本来愿力所应作的利他事业。

    论文二十一，如是四智相应心品，虽各定有二十二法，能变所变种现俱生，而智用增，以智名显。故此四品，总摄佛地一切有为功德皆尽。此转有漏八、七、六、五识相应品，如次而得，智虽非识，而依识转，识为主故，说转识得。又有漏位，智劣识强，无漏位中，智强识劣，为劝有情依智舍识，故说转八识而得此四智。

    讲解：像这样的四智相应心品，虽然各个心品定有二十二法（注：二十二法，为遍行心所五、别境心所五、善心所十一，及所取之心），及其能变的种子，所变的现行同时俱起，然而智的作用此较增上，故以智名来显示心品。这四智相应心品，总将佛地的一切有为功德都摄尽无余。

    这转有漏的八、七、六、五识的相应心品，是如其次第而转得的，即转第八识得大圆镜智，转第七识得平等性智，转第六识得妙观察智，转前五识得成所作智。

    智既非识，何以说转识得智？此有两种答案：一者智虽非识，而依识转，因为八识心王，有依之为主而转舍转得的意义，所以说转识成智。二者在有漏位，智的决断力劣，识的分别力强；在无漏位中，智的决断力强，识的分别力劣。为劝导有情依智舍识，所以说转舍八识而得此四智。

    论文二十二：大圆镜智相应心品：有义：菩萨金刚喻定现在前时，即初现起，异熟识种与极微细所知障种，俱时舍故。若圆镜智尔时未起，便无能持净种识故。有义：此品解脱道时，初成佛故，乃得初起，异热识种，金刚喻定现在前时，犹未顿舍，与无间道不相违故，非障有漏劣无漏法，但与佛果定相违故，金刚喻定无所熏识，无漏不增应成佛故。由斯此品，从初成佛，尽未来际，相续不断，持无漏种令不失故。

    讲解：以上讲解转识成智，此下讲解四智心品的现起位。大圆镜智相应心品什么时侯现起呢？有人说：在菩萨金刚喻定现前时，亦即大圆镜智初现起时。因为此时的异熟识种、与极微细的所知障种都完全舍弃，唯有能持清净种识的存在，如果大圆镜智在此时尚未现起，便没有能持清净种的识了。

    另有人认为：这大圆镜智相应心品，要到解脱道刚成佛时方得初起。因为异熟识种，在金刚喻定现在前时还没有舍除，此时所断的只是二障种子，未舍有漏善及劣无漏法，与那无间道是不相违背，不障有漏善及劣无漏法，但与佛果强有力的无漏法决定相违。假定金刚喻定时舍去异熟种的话，则金刚喻定就没有了所熏的识。所熏识无，无漏法不增长，那就应当成佛。可是事实不然，由此因缘，这大圆镜智相应心品，从初成佛时开始现起，尽未来际，相续不断，执持无漏法种子，使令永不散失。

    论文二十三：平等性智相应心品，菩萨见道初现前位，违二执故，方得初起。后十地中，执未断故，有漏等位，或有间断，法云地后，与净第八相依相续，尽未来际。

    讲解：平等性智相应心品，在菩萨真见道初现前位，便得初起。因为这平等性智，不是第七识的自力现起，而是由见道位的第六识，转为妙观察智之所引生。因为妙观察智的二空无漏，与第七识相应的我、法二执相违，使第七识的二执不能生起。如此平等性智与妙观察智俱时而起。后来到十地中，因为俱生二执的粗重未断，此智在这有漏等位的出空观时，或有间断，要直到究竟无漏的第十法云地后，乃成究竟无漏，以净第八识为所依，相续无间，尽未来际。

    论文二十四：妙观察智相应心品，生空观品，二乘见位，亦得初起。此后展转至无学位，或至菩萨解行地终，或至上位，若非有漏，或无心时，皆容现起。法空观品，菩萨见位方得初起，此后展转乃至上位，若非有漏，生空智果，或无心时，皆容现起。

    讲解：妙观察智相应心品，有生空观品与法空观品的分别。一者生空观品，在二乘见道的最初生起，以后展转到无学位方得究竟。假如是渐悟菩萨，到十住、十行、十回向的解行地终，或十地上位，在此中间，如果不是有漏或无心定时，都容许现起。二者法空观品，要到菩萨见道位初地入心，方得现起。从此以后，展转乃至十地最后心的上位，在此中间，如果不是有漏心或不达法空的生空智果，或无心定时，都容许现起。

    论文二十五：成所作智相应心品，有义：菩萨修道位中，后得引故，亦得初起。有义：成佛方得初起。以十地中，依异熟识所变眼等，非无漏故，有漏不共，必俱同境，根发无漏识，理不相应故，此二于境，明昧异故。由斯此品，要得成佛，依无漏根，方容现起，而数间断，作意起故。

    讲解：成所作智相应心品由何时现起？此有二种异说。第一家说：此心品在菩萨修道位中，因为第六意识的后得所引故，亦得初起。第二家说：此心品要到成佛的时侯，才可以初起。因为在十地中，依第八异熟识所变的眼等五根，并非无漏，而是有漏五识，不共余法，住必同境的俱有所依。像这样的有漏根发无漏识，是不相应的。应知漏与无漏，此二缘境明昧不同，如何能移发无漏识。以此缘故，此智心品，要到成佛的时侯，依无漏根，方容现起。但非相续，而数数间断。因为是作意方起之故，它不同余识，不假作意而恒时现起。

    论文二十六：此四种性，虽皆本有，而要熏发，方得现行，因位渐增，佛果圆满，不增不灭，尽未来际，但从种生，不熏成种，勿前佛德，胜后佛故。

    讲解：这四智相应心品，皆从本有的无漏种子生起，但要由无漏法的熏发，然后方得现行。而且熏有胜劣不同，所以在因位渐次增胜，直到佛果才究竟圆满，不增不减尽未来际。何以不增不减？因为这圆满的佛果，只是从本有的无漏种子生起现行，其所生起的现行，不复再熏成种子。因为不能说以前佛的果德优于以后的佛，所以用不著再熏。

    论文二十七：大圆镜智相应心品：有义：但缘真如为境，是无分别，非后得智，行相所缘，不可知故。有义：此品缘一切法。庄严论说：大圆镜智，于一切境不愚迷故。佛地经说：如来智镜，诸处境识众像现故。又此决定缘无漏种，及身土等诸影像故，行缘微细，说不可知，如何赖耶亦缘俗故。缘真如故是无分别，缘余境故后得智摄。其体是一，随用分二。了俗由证真，故说为后得，余一分二，准此应知。

    讲解：以上是讲解四智心品的现起，此下是明四智心品的缘境。大圆镜智相应心品之所缘境，有二家异说，第一家认为，此智心品但缘真如，不缘俗境。缘真如的是根本无分别智，而不是缘俗的后得智，其行相、所缘，都微细而不可测知。

    第二家认为，此智心品缘一切法，并不是但缘真如。因为《庄严论》上说：大圆镜智于一切真，俗之境，都不愚不迷。《佛地经》上说：大圆镜智，于根、尘、识十八界的众像，都无不显现。又，此智心品决定缘无漏种子，及身土等各种影像。前第一家说‘行缘微细，说不可知’，以因位的阿赖耶识既不可知，果位的镜智亦缘于俗，当然也不可知。至于根本、后得二智的差别，那是因为缘真的是无分别智，缘余境的是后得智摄，智体是一，不过随其功用的不同分之为二。了俗之智，是由证真已后所得的，所以说他是后得智，并非二智有二别体。当知余智心品的一体分二，准此可知。

    论文二十八：平等性智相应心品，有义：但缘第八净识，如染第七，缘藏识故。有义：但缘真如为境，缘一切法平等性故。有义：遍缘真俗为境，佛地经说，平等性智证得十种平等性故。庄严论说，缘诸有情自他平等，随他胜解，示现无边佛影像故。由斯此品，通缘真俗，二智所摄，于理无违。

    讲解：平等性智相应心品之缘境，有三家不同异说。第一家说：但缘第八净识，就像染污的第七末那，缘取第八阿赖耶识一样。第二家说：平等性智但缘真如为境，因为此智心品，是缘一切法的平等性，此平等性就是真如境界。第三家则认为，平等性智遍缘真俗为境，因为《佛地经》说，平等性智证得十种平等性故，《庄严经论》说，缘取各有情众生的自他平等，随顺他人的胜解力，示现无边无际佛的影像。因此这平等性智相应心品为缘真、俗的根本、后得二智所摄，在道理上并不相违。

    论文二十九：妙观察智相应心品，缘一切法自相共相，皆无障碍，二智所摄。

    讲解：妙观察智相应心品，缘一切法的自相和共相都没有障碍，为根本、后得二智所摄。

    论文三十：成所作智相应心品，有义：但缘五种现境。庄严论说：如来五根，一一皆于五境转故。有义：此品亦能遍缘三世诸法，不违正理。佛地经说：成所作智，起作三业诸变化事，决择有情心行差别，领受去来现在等义，若不遍缘，无此能故。然此心品，随意乐力，或缘一法，或二或多，且说五根于五境转，不言唯尔，故不相违。随作意生，缘事相境，起化业故，后得智摄。

    讲解：成所作智相应心品之缘境，有两家不同异说。第一家说，成所作智相应心品，只缘取五现境，因为《庄严经论》说，如来的五根，一一都于五境发挥作用。第二家说，不然，也能够普遍缘取过去、现在、未来的各种事物，与正理无违。《佛地经》说，成所作智生起三业的各种变化，来决择众生的心行差别，领受过去、未来、现在等义。如果不是遍缘的话，则无这种功能。

    然而这种心品，随其意乐之力，或缘一法，或缘二法，或缘多法，《庄严经论》上但说五根于五境转，并不说只唯缘尔境，不缘诸法，所以与遍缘诸法的道理并不相违。此智心品，因为随其作意而生，缘取事相外境，生起各种作业，是属后得智摄。

    论文三十一：此四心品，虽皆遍能缘一切法，而用有异。谓镜智品，现自受用身净土相，持无漏种；平等智品，现他受用身净土相，成事智品，能现变化身及土相，观察智品，观察自他功能过失，雨大法雨，破诸疑网，利乐有情。如是等门，差别多种。

    讲解：这四智相应心品，虽然都能够遍缘一切法，而其缘境的作用则有区别。大圆镜智相应心品，能够现起自受用身，及自受用的净土境相，执持无漏种子。平等性智相应心品，能够现起他受用身，及他受用的净土境相。成所作智相应心品，能够现起变化身，及变化的净秽土相。妙观察智相应心品，能够观察自他功能过失，于净秽土，雨大法雨，破一切疑网，利乐有情。像这样的门类有多种差别，此不繁举。

    论文三十二：此四心品，名所生得，此所生得总名菩提；及前涅槃名所转得。虽转依义总有四种，而今但取二所转得，颂说证得转依言故。此修习位，说能证得，非已证得，因位摄故。

    讲解：这四智心品，称为所生得，总名为菩提，再加上前面所显得的涅槃，就叫做所转得。虽然转依意义总有能转道、所转依、所转舍、所转得四种，但是现在但取第四的涅槃、菩提二所转得，不取余三。因为《唯识三十颂》中说：‘便证得转依’这句话。这种修习位被说成能证得，并不是已经证得。因为十地尚属因位所摄，还没有到达佛地的果位。


第六章 释究竟位

    第六章 释究竟位

    论文一：后究竟位，其相云何？颂曰：此即无漏界，不思议善常，安乐解脱身，大牟尼名法。论曰：前修习位所得转依，应知即是究竟位相。此谓此前二转依果，即是究竟无漏界摄。诸漏永尽，非漏随增，性净圆明，故名无漏。界是藏义，此中含容无边希有大功德故。或是因义，能生五乘世出世间利乐事故。

    讲解：唯识五位修行已讲其四，此下讲第五究竟位。这第五究竟位其相如何呢？《唯识三十颂》说：‘这就是无漏界，不可思议的善、常、安乐。这解脱身，就是称为大牟尼的最高真理。’以下是以论文解释颂义，论曰，以前修习位所得到的转依，应知即是究竟位的相状。这就是前面所说涅槃、菩提二转依果，属于究竟位的无漏界摄。二转依果何以名为无漏？因其一切杂染的诸漏已经断尽，不像取蕴那样，使有漏随之增长。其性清净、圆满，光明，所以称为无漏。

    ‘界’字是‘含藏’的意思，这二转依果中，含藏有无量无边甚为希有的大功德，涅槃含藏无为功德，菩提含藏有为功德。或者‘界’是‘因’义，因为能够产生人、天等五乘世、出世间的利益和安乐。

    论文二：清净法界，可唯无漏摄，四智心品，如何唯无漏？道谛摄故，唯无漏摄。谓佛功德及身土等，皆是无漏种性所生，有漏法种已永舍故。虽有示现作生死身，业烦恼等似苦集谛，而实无漏道谛所摄。

    讲解：有小乘师问曰：清净法界，是涅槃的理法，可以说是唯无漏摄。四智心品从种所生，有为无漏，是佛身中的有为功德，怎么也说是唯无漏呢？论主答曰：四智为四谛中的道谛所摄，道谛既是无漏，当然四智也唯是无漏摄了。我人当知，佛的六度道品，十力、四无畏等，一切功德及所现身土，都是无漏种子的道谛所生，有漏种子在金刚心后已经永远舍弃。或又有问曰：佛的变化身，示现生、老、病、死业烦恼等，怎么可说唯是道谛？答曰，如来虽有示现病痛烦恼等，入灭现有背痛，好像是苦谛与集谛，然而实际上是无漏的道谛所摄，不可以把它看为有漏。

    论文三：集论等说，十五界等，唯是有漏，如来岂无五根、五识、五外界等？有义：如来功德身土，甚深微妙，非有非无，离诸分别，绝诸戏论，非界处等法门所摄，故与彼说理不相违。

    讲解：小乘师又问：《阿毗达磨杂集论》上说：十八界除后三界，余十五界等唯是有漏。今言佛身唯无漏摄，如来岂能没有五根、五识、五外境的十五界吗？这个问题有三家异解。第一家说：如来功德及所现身土，非常深微奥妙，有而非有，无而非无，离诸能、所的分别，绝于名言戏论，不是界、处、蕴等的法门所摄。所以这里说佛身唯无漏摄，与彼所说十五界唯是有漏的道理，并不相违。

    论文四：有义，如来五根、五境，妙定生故，法界色摄。非佛五识虽依此变，然粗细异非五境摄。如来五识，非五识界，经说佛心恒在定故，论说五识性散乱故。成所作智何识相应？第六相应，起化用故。与观察智性有何别？彼观诸法自共相等，此唯起化，故有差别。此二智品应不并生，一类二识不俱起故。许不并起，于理无违：同体用分俱亦非失，或与第七净识相应，依眼等根缘色等境，是平等智作用差别。谓净第七，起他受用身土相者，平等品摄，起变化者，成事品摄。岂不此品转五识得？非转彼得，体即是彼，如转生死言得涅槃，不可涅槃同生死摄，是故于此不应为难。

    讲解：第二家说：如来的五根、五境，是无漏妙定所生，所以为法界色一分所摄。假使非佛而是其余的菩萨、异生等的五识，虽依佛妙定所变的根境上变为身土，然而粗细有异，即余所变者粗，属于五境，佛所变者细，非五境摄。如来的五识，不是五识界的有漏五识，因为经上说：佛心恒在定中：论上说：五识性是散乱。佛心既恒在定，当然不是散乱的五识界了。

    外人又问：佛的五识既非五识界摄，那依五识所转的成所作智，与什么识相应呢？论主答：与第六净识相应。因第六净识，对菩萨、二乘、异生三类，能随机现起分身的化用，非余识俱。问：既与第六识相应，那么与妙观察智又有什么差别呢？答：妙观察智能观诸法的自相共相，这成所作智，唯起作用，所以他们是有差别的。问：如此说来，这二智品应当不能并生，一类智品是不能俱起二识的，如何成所作智，能与第六识相应？答；若以前念后念刹那别起而论，就是许不并生，也于理无违；若以同一识体用分为二来说，就是许二俱起，也没有什么过失。

    或者成所作智与第七净识相应。因为依眼等根，缘色等境，不过是平等智品在作用上的差别。那么，成所作智与平等性智不是就没有差别了吗？问：第七净识，为化菩萨，起他受用身土相者，属平等性智心品所摄；为化异生，起变化身土相者，是成所作智心品所摄。问：这成所作智心品，岂不是由转五识而得的吗？既由转五识而得，何以与第七净识相应？答：并不是因为转彼五识得此智心品，便说此智心品的体性就是五识，譬如转生死说得涅槃，不可说涅槃同生死摄。所以不应在这里提出问难。

    论文五：有义：如来功德身土，如应摄在蕴处界中，彼三皆通有漏无漏。集论等说十五界等唯有漏者，彼依二乘粗浅境说，非说一切。谓余成就十八界中，唯有后三通无漏摄。佛成就者虽皆无漏，而非二乘所知境摄。然余处说佛功德等非界等者，不同二乘劣智所知界等相故，理必应尔。所以者何？说有为法皆蕴摄故，说一切法，界处摄故，十九界等圣所遮故。若绝戏论便非界等。亦不应说即无漏界善常安乐、解脱身等。又处处说，转无常蕴，获得常蕴，界处亦然，宁说如来非蕴处界？故言非者，是密意说。又说五识性散乱者，说余成者，非佛所成。故佛身中，十八界等皆悉具足，而纯无漏。

    讲解：第三家说：如来的功德，及所现身土，都如其所应的摄在蕴、处、界中。因此蕴、处、界三，皆通有漏、无漏，故佛无漏亦彼所摄。《阿毗达磨集论》等说，十五界等唯有漏者，那是依二乘人的粗浅境而说的，并不是说一切凡圣有情的十五界都是有漏。菩萨、二乘所成就的六根、六境、六识的十八界里，唯有后三的意根、法境、意识通无漏摄，余十五界唯是有漏。佛成就的虽皆无漏，而非二乘所知境摄。然而余处如《大般若经》说，佛的功德身土，非界、蕴、处者，那是表示佛的功德殊胜，不同二乘劣智所知的界、处等相，并非不属界等所摄，在道理上必然应当是这样的。何以故呢？诸论通说：有为法皆属蕴摄。又说；一切法，界、处都摄。佛的功德法，难道不是界、处所摄吗？假使不是界、处所摄，那就是十九界所摄了。（注：十九界就像是说六蕴、十三处一样，都是根本不存在之法。）

    然而十九界等说为圣教所否定，是不能成立的。如果不是戏论，就不会是界、处等，也不应当说是无漏界、善、常、安乐、解脱身等。《涅槃经》等说：转化无常蕴而得常蕴，界、处也是这样，怎能说如来不是蕴、处、界呢？所以说不是蕴、处、界者，那是依佛密意而说。又，论说五识之性散乱，那是指其余菩萨、二乘所成就而说的，不是佛所成就。所以在佛身之中，十八界等完全具足，且纯是无漏。

    论文六：此转依果又不思议，超过寻思言议道故，微妙甚深自内证故，非诸世间喻所喻故。

    讲解：以上讲解颂文‘此即无漏界’一句，此下讲解‘不思议、善、常、安乐’七字。这二转依果，是不可思议的。因为它超越了思虑和言议之道，微妙甚深，所缘境唯是自已内心证得，不是一切世间事物所可譬喻。

    论文七：此又是善，白法性故：清净法界，远离生灭，极安隐故　四智心品，妙用无方，极巧便故：二种皆有顺益相故，违不善故，俱说为善。论说处等，八唯无记，如来岂无五根、三境？此中三释，广说如前。一切如来身土等法，皆灭道摄，故唯是善，圣说灭道唯善性故，说佛土等非苦集故。佛识所变有漏不善、无记相等，皆从无漏善种所生，无漏善摄。

    讲解：此二转依果，颂文中又说是善，是以‘白法’为体性。白法是不是即有漏善呢？不，清净法界的大涅槃，远离生灭烦恼，至极安稳：四智心品的大菩提，妙用无方，至极巧便。这两种无为的涅槃，有为的菩提，都有顺益之相，既与有漏善不同，又与不善相违，所以俱说为善。

    外人问难：四智心品，既唯是善，何以《阿毗达磨杂集论》说，十二处里有八处唯是无记呢？如来怎能没有眼、耳、鼻、舌、身五根，和香、味、触三境呢？论主答：这问题在前面三释有漏里已经讲过，勿庸再说。

    一切如来的身土等法，都属灭谛和道谛所摄，所以唯是善性。因为经论上说：属于灭、道二谛的唯是善性。又说佛的身土非苦、集谛。既非苦、集，当然是善性的灭、道二谛了。至于由佛净识所变的似有漏、不善、无记相等，都是从无漏善种所生，所以也都是无漏善摄。

    论文八：此又是常，无尽期故。清净法界，无生无灭，性无变易，故说为常。四智心品所依常故，无断尽故，亦说为常。非自性常，从因生故，生者归灭，一向说故，不见色心，非无常故。然四智品，由本愿力，所化有情无尽期故，穷未来际无断无尽。

    讲解：这二转依果，颂中又说是常，因为此果永无尽期，清净法界的大涅槃，无生无灭，性无变易，所以说之为常。四智心品的大菩提，所依的真如是常，能依的智品无断无尽，所以也说为常。但这四智心品的常，不是自性常，因为他是从因生的，既从因生，必归于灭，一向都是这样说的，不见有谁说过，色、心不是无常。然而，四智心品，何以又说是常？由于本愿力的宏深，所化有情无有尽期，能化的四智心品也就穷未来际，无断无尽了，所以又说是常。

    论文九：此又安乐，无逼恼故。清净法界，众相寂静，故名安乐。四智心品永离恼害，故名安乐。此二自性皆无逼恼，及能安乐一切有情，故二转依俱名安乐。

    讲解：这二转依果，颂文又说是安乐。因为这二果对有情类没有逼迫恼害，所以名为安乐。清净法界的大涅槃果，众相寂静，所以名为安乐。四智心品的大菩提果，永杂恼害，所以也名为安乐。不但这二果的自性都无逼无恼，而且能利益安乐一切有情，所以二转依果都称为安乐。

    论文十：二乘所得二转依果，唯永远离烦恼障缚，无殊胜法，故但名解脱身。大觉世尊，成就无上寂默法，故名大牟尼。此牟尼尊所得二果，永离二障，亦名法身。无量无边力无畏等，大功德法所庄严故。体依聚义，总说名身。故此法身五法为性，非净法界独名法身，二转依果皆此摄故。

    讲解：以上讲解‘不思议、善、常、安乐’七字，此下讲解‘解脱身、大牟尼名法’八字。声闻、缘觉二乘人所得的二转依果，只是永远离了烦恼障的系缚，还没有离所知障，所以只称为解脱身，而不称法身。然而大觉世尊，由于成就了最极无上的寂默法故，所以名为‘大牟尼’。牟尼，译为寂默，即是一切法的性相离言之不二法门。唯我大牟尼世尊所得的二转依果，由于永离烦恼、所知二障之故，所以不但名解脱身，而且亦名法身。为什么叫做法身？因为这是无量无边十力、四无畏等大功德法所庄严之故。为什么名之为身呢？因为这是具有体性、依止、众德所聚的三义，所以总名为身。因此，这法身是以凊净真如及四智菩提的五法为性。以清净法界名为涅槃，四智心品名为菩提，合此二种名为法身，不独一种清净法界可名法身，因为二转依果摄此五法，而五法皆是此法身所摄。

    论文十一：如是法身，有三相别：一自性身，谓诸如来真净法界，受用、变化平等所依，离相寂然，绝诸戏论，具无边际真常功德，是一切法平等实性，即此自性亦名法身，大功德法所依止故。

    讲解：以上所说的法身，既是三义总名，当然也有三相差别。此三相为：一、自性身，这就是一切如来所证的真净法界，为受用身与变化身平等所依的实性，又是离相寂然，所以寻思路绝，离言说相，绝诸戏论。还具有无边无际的真常功德，是一切法平等实性。即此自性，不但名自性身，而且也名叫法身。为什么亦名法身？因为他是有为无为的大功德法所依止故。

    论文十二：二受用身。此有二种：一自受用，谓诸如来三无数劫，修集无量福慧资粮，所起无边真实功德，及极圆净常遍色身，相续湛然，尽未来际，恒自受用广大法乐。二他受用，谓诸如来由平等智，示现微妙净功德身，居纯净土，为住十地诸菩萨众，现大神通，转正法轮，决众疑网，令彼受用大乘法乐。合此二种，名受用身。三变化身，谓诸如来由成事智，变现无量随类化身，居净秽土，为未登地诸菩萨众、二乘、异生，称彼机宜，现通说法，令各获得诸利乐事。

    讲解：二、受用身：这有两种差别：一种是自受用。就是一切如来，经过三大阿僧祇的无数长劫，修集了无量福慧资粮，所生起的无边真实功德，以及极其圆满、清净、永恒、普遍存在的色身，相续不断，直至无穷无尽的未来际，恒自受用广大法乐。二种是他受用身。就是一切如来由平等性智，示现的微妙净功德身，居住于纯净无秽的国土，为住于十地的诸菩萨显现伟大的神通力，转正法轮，决断一切疑网，使大乘菩萨享用大乘佛法的法乐。综合这自、他受用二种，名为受用身。

    三、变化身：就是一切如来，由成所作智变现无量的随类化身，居住于净土和秽土，根据地前菩萨、二乘、异生的根机和时宜，随其利钝，现身说法，使他们各都获得一切利益和安乐。

    论文十三：以五法性摄三身者，有义：初二摄自性身。经说真如是法身故，论说转去阿赖耶识，得自性身，圆镜智品转去藏识而证得故。中二智品摄受用身。说平等智于纯净土，为诸菩萨现佛身故，说观察智大集会中，说法断疑，现自在故，说转诸转识得受用身故。后一智品摄变化身，说成事智，于十方土，现无量种难思化故，又智殊胜具摄三身，故知三身皆有实智。

    讲解：以真如、四智、五法摄三身的问题，有人认为，最初的真如和大圆镜智持自性身，因为《佛地经》上说，真如就是法身。《摄大乘论》上说：转去第八阿赖耶识而得自性身。又说：大圆智是转去藏识而证得的，可见是以大圆镜智摄自性身的。

    中间的平等、观察二智摄受用身。因为《大乘庄严论》上说：平等性智，是佛在纯净土为诸菩萨显现的佛身。又说：妙观察智使佛在大集会中说法，断除疑问，示现自在：又说：转诸转识，得受用身。可见平等、观察二智，是摄受用身的。

    最后的成所作智相应心品摄变化身，因为《大乘庄严论》上说：成所作智，于十方国土，表现出无量种类微妙难思的变化。所以成所作智摄变化身。又、《摄大乘论》上说：由于智品的殊胜，具摄三身。所以无论自性、受用、变化三身，都有实智。

    论文十四：有义，初一摄自性身，说自性身本性常故，说佛法身无生灭故，说证因得非生因故，又说法身诸佛共有，遍一切法，犹若虚空，无相无为，非色、心故。然说转去藏识得者，谓由转灭第八识中二障粗重，显法身故。智殊胜中说法身者，是彼依止彼实性故。自性法身，虽有真实无边功德，而无为故，不可说为色心等物。

    讲解：又有人说：五法中只有真如一法摄自性身，因为《佛地经论》等说，自性身是本性常住。又说，佛的法身，无生无灭。又说：法身是由能证的因地而证得的，并非由生因而生。又说：法身是诸佛共有，遍一切法，犹若虚空，无相无为，非色非心。这都是唯一真如摄自性身，非镜智亦摄的明证。然而前师引摄论所说，大圆镜智转去藏识而证得者，那是说由转灭第八识中的二障粗重，以显示法身，并不是法身同镜智一样由转识而得。又说智品殊胜，具摄三身中有法身者，那是因为法身是彼智品所依止的实性，并非法身为彼智品所摄。为什么大圆镜智不能摄持自性身呢？因为自性身虽然具有真实无边功德，然而由于是无为法，不可说它是镜智的色、心等物。

    论文十五：四智心品真实功德，镜智所起常遍色身，摄自受用，平等智品所现佛身，摄他受用。成事智品所现随类种种身相，摄变化身。说圆镜智是受用佛，转诸转识得受用故。虽转藏识亦得受用，然说转彼显法身故，于得受用略不说之。又说法身无生无灭，唯证因得，非色心等，圆镜智品，与此相违，若非受用，属何身摄？又受用身，摄佛不共有为实德。故四智品，实有色心，皆受用摄。

    讲解：四智相应心品中的真实功德，是怎样的摄持三身？大圆镜智所现起的常遍色身，摄三身中的自受用身。平等性智相应心品所现起的佛身，摄三身中的他受用身。成所作智相应心品，所现起随类种种变化身相，摄三身中的变化身。

    说大圆镜智是佛受用身而不是法身者，因为这是由转诸转识所得的受用身。那么，为什么《摄大乘论》不说转藏识亦得受用身呢？当知转于藏识虽亦得自受用，然而现在主要是说转得藏识以显法身，至于转染成净而得受用一义，就略而不说了。

    又如前说，法身是无生无灭的，唯是清净理智的证因之所证得，非色非心等。而此圆镜智品既有生灭，又是色、心，与法身相违，若非受用，他将属何身所摄？又受用身，通摄佛果位上，一切不共的有为真实功德。所以知道四智心品，实有色心，都是自受用所摄。

    论文十六：又他受用及变化身，皆为化他方便示现，故不可说实智为体。虽说化身智殊胜摄，而似智现，或智所起，假说智名，体实非智。但说平等、成所作智能现受用、三业化身，不说二身即是二智，故此二智自受用摄。

    讲解：还有一个道理，他受用身和变化身，都是为了化他有情而方便示现，所以不可说他以实智为体。可是有人问曰：圣教明白的说变化身智殊胜摄，怎能说不是实智？虽说化身是属智殊胜摄，然而那不过似智所现，或者是由智所现起，所以假说智名，而其体实在是非智。复有人问：前引平等、成事二智所现受用、变化二身，怎能说二身体实非智？答曰：但说平等性智能现受用身，成所作智能现三业化身，并不是说二身就是二智。所以这平等、成事二智，都是自受用身摄。

    论文十七：然变化身及他受用，虽无真实心及心所，而有化现心心所法。无上觉者神力难思，故能化现无形质法。若不尔者，云何如来现贪嗔等？久已断故。云何声闻及傍生等，知如来心？如来实心，等觉菩萨尚不知故。由此经说化无量类皆令有心，又说如来成所作智化作三业，又说变化有依他心，依他实心相分现故。虽说变化无根心等，而依余说，不依如来，又化色根心心所法，无根等用，故不说有。

    讲解：复有人问，若说二身的体实非智，那佛不是就没有心、心所法，去化其他有情了吗？答曰，变化身及他受用身，虽说没有真实的心及心所，却有化现的心、心所法。按凡情推测，心、心所法不是有形质的色身，怎么能够化现？因为无上觉者的神力不可思议，所以能化身为没有外部形质的东西。如果不是这样，那如来如何能应机示现久已断了的贪、嗔等相？又如何受化的声闻及傍生等，知道如来的心呢？因为如来的实心，等觉菩萨尚不能知，何况声闻傍生？

    因此《涅槃经》说：变化无量化人之类，皆令有心。又《佛地经》说：如来的成所作智，化作身、语、意三业。又《解深密经》说：变化身有依他之心，什么叫做依他心，就是依他实心为因缘，而相分现起。虽然《解深密经》说变化不依靠根、心等，是依据其余的有情众生而说，并不是依据如来而说。变化色根、心法、心所法，没有根等的作用，所以不说有变化根心。

    论文十八：如是三身，虽皆具足无边功德，而各有异。谓自性身唯有真实常乐我净，离诸杂染，众善所依无为功德，无色心等差别相用。自受用身，具无量种妙色心等真实功德。若他受用及变化身，唯具无边似色心等，利乐他用化相功德。

    讲解：像以上所说的自性、受用、变化三身，虽然都具足无边功德，而各各有异。即第一的自性身，唯具有真实的常、乐、我、净的功德。体非生灭，所以名常，寂灭安隐，所以名乐，得大自在，所以名我，解脱垢污，所以名净。这虽是离诸杂染，为众善所依的无为功德，却没有色、心等的差别相用。第二的自受用身，具有无量种妙色、心等的真实功德。至于第三的他受用身及变化身，唯具有无边似色、心等，为利乐他用的化相功德。

    论文十九：又自性身，正自利摄，寂静安乐，无动作故。亦兼利他，为增上缘，令诸有情得利乐故。又与受用及变化身为所依止，故俱利摄。自受用身，唯属自利。若他受用及变化身，唯属利他，为他现故。

    讲解：以三身二利说，自性身完全属于自利，因为它寂静安乐，在利他行上没有动作。但亦兼利他，因其能为利他作增上缘，能给有情带来利益和安乐。又自性身，能与受用身及变化身为所依止，所以为具有自、他二利。自受用身，唯属自利，不兼利他，因其为恒自受用广大法乐的常遍色身之故。至于他受用及变化身，则唯属利他，不兼自利，因其专为他有情类菩萨、二乘、异生，转法轮，决疑网的利他事业而示现。

    论文二十：又自性身，依法性土，虽此身土体无差别，而属佛法，相性异故，此佛身土俱非色摄，虽不可说形量大小，然随事相其量无边，譬如虚空遍一切处。

    讲解：又，自性身依法性土而安住，虽然这种身、土之体没有差别，然而身属于佛，土属于法，相、性是有差别的。因为佛是能证的觉相，为众德所聚的受用、变化二身的自体，所以名自性身。法是所证的理性，为诸法自性，能持自性，所以名法性土。

    这种佛身和法性土，都不是色法所摄。虽不可说形量大小，然随著诸法事相的显现，其量是广大无边的，就像虚空一样遍在于一切处所。

    论文二十一：自受用身还依自土，谓圆镜智相应净识，由昔所修自利无漏纯净佛土，因缘成熟，从初成佛尽未来际，相续变为纯净佛土，周圆无际，众宝庄严，自受用身常依而住。如净土量身量亦尔，诸根相好一一无边，无限善根所引生故。功德智慧既非色法，虽不可说形量大小，而依所证及所依身，亦可说言遍一切处。他受用身亦依自土。谓平等智大慈悲力，由昔所修利他无漏纯净佛土，因缘成熟，随住十地菩萨所宜变为净土，或小或大，或劣或胜，前后改转，他受用身依之而住。能依身量，亦无定限。

    讲解：自受用身，还是依自受用土而住，就是与大圆镜智相应的净识，由往昔所修的自利无漏纯净佛土，一旦因缘成熟，从最初成佛起一直到尽未来际，这净识即相续不断的变为纯净佛土，周圆无际，为诸珍宝之所庄严，自受用身即常依此而住。此能依的身量，也如所依的土量一样大小。不但身量，即身所具的根相，相所具的随形好，也都一一无边，因为是无限善根所引生的缘故。此身所具的功德智慧，既非色法，不可说他的形量大小。而智慧随其所证的如法，功德随其所依的佛身，也可以说是遍一切处。

    他受用身也是依受用土而住，就是平等性智大慈悲力，由过去所修的利他无漏纯净佛土，一旦因缘成熟，随顺住于十地菩萨的机宜，变为净土，或小、或大，或劣、或胜，前后变化，他受用身依之而住，能依的身量也没有一定的限制。

    论文二十二：若变化身，依变化土，谓成事智大慈悲力，由昔所修利他无漏净秽佛土，因缘成熟，随未登地有情所宜，化为佛土，或净或秽或小或大，前后改转，佛变化身依之而住，能依身量亦无定限。

    讲解：至于变化身，则是依变化土而住。那是通过成所作智的大慈悲力，由于过去所修利他的无漏净秽佛土，一旦因缘成熟，随顺著地前菩萨有情所适应的机宜，化为佛土，或凊净或污秽，或小或大，前后不同，佛的变化身即依之而住，能依的身量也没有一定大小的局限。

    论文二十三：自性身土，一切如来同所证故，体无差别。自受用身及所依土，虽一切佛各变不同，而皆无边，不相障碍。余二身土，随诸如来所化有情，有共不共。所化共者，同处同时，诸佛各变为身为土，形状相似，不相障碍，展转相杂，为增上缘，令所化生，自识变现。谓于一土有一佛身，为现神通说法饶益。于不共者唯一佛变。诸有情类无始时来，种性法尔更相系属，或多属一，或一属多，故所化生有共不共。不尔，多佛久住世间，各事劬劳，实为无益，一佛能益一切生故。

    讲解：自性身与法性土，为一切如来共同所证，其本体没有差别，这自受用身及所依的自受用土，虽一切佛各自所变的不同，但他们的形量都是无边际，不相障碍，如一室千灯，光光交融一样。其余的他受用与变化身土，是随诸如来所化的有情，有共与不共之别。所化共者，在同一地点，同一时间，诸佛各自变化为身为土，形状相似，互不障碍，彼此展转相杂，为增上缘，令其所化的有情，在自识的变现上，不见有诸佛身土的差别，认谓于一佛土有一佛身，为现神通，说法饶益。至于不共者，身土唯为一佛所变，而不是诸佛共变。

    为什么诸佛所化众生有共不共？诸有情类从无始时来，他们的种性，必然于诸佛化缘是更相系属的，或一生属于多佛，或多生属于一佛，或多生属于多佛，或一生属于一佛，因此所化众生有共不共。假使不是这样更相系属的话，那很多的佛，久住世间，各事劬劳，实在没有利益，因为一佛已能利益一切众生，何用多佛。

    论文二十四：此诸身土若净若秽，无漏识上所变现者，同能变识俱善无漏，纯善无漏因缘所生，是道谛摄，非苦、集故。蕴等识相不必皆同，三法因缘杂引生故。有漏识上所变现者，同能变识皆是有漏，纯从有漏因缘所生，是苦、集摄，非灭、道故。善等识相不必皆同，三性因缘杂引生故。蕴等同异类此应知。不尔，应无五、十二等。

    讲解：以上这些佛身和土，无论是纯净或污秽，只要是无漏识上所变现的，那就同能变的识一样，都是善无漏法，因为它们是纯善无漏的因缘所生，在四谛中属于道谛所摄，而不是苦、集二谛。蕴等的识相肯定都不相同，因为蕴、处、界三法因缘，混杂引生。从有漏识上所变现的，和能变识一样，都是有漏，纯粹是从有漏因缘所生，属于苦谛和集谛，并不属于灭谛和道谛。善等识相肯定都不相同，因为三性因缘混杂引生，蕴、处、界的相同和相异，以此为准应当知。不然的话，应当就没有五蕴、十二处、十八界的分别了。

    论文二十五：然相分等依识变现，非如识性依他中实。不尔，唯识理应不成，许识内境俱实有故。或识相见等从缘生，俱依他起，虚实如识，唯言遣外，不遮内境。不尔，真如亦应非实。

    讲解：然而，相、见二分，因为是依识自体所变现的，所以是虚妄计执，非如能变的识体，是依他缘起的实法，不然的话，那唯识的道理就应当不能成立；因许内识和外境，俱是实有之故。或者说：识的自体，相、见分等，都是因缘所生的依他起性，相、见二分的虚实如识体一样，识既非虚，相、见亦然。那么，为什么不说万法唯境，而说唯识呢？当知唯识的‘唯’字，唯遣心外的遍计所执，不遣内识所变的相分等境。不然的话，真如亦应非实。真如既实，那能缘真如的心岂容是假？

    论文二十六：内识与境，既并非虚，如何但言唯识非境？识唯内有，境亦通外，恐滥外故，但言唯识。或诸愚夫迷执于境，起烦恼业，生死沉沦，不解观心，勤求出离，哀愍彼故，说唯识言，令自观心，解脱生死，非谓内境如外都无。或相分等皆识为性，由熏习力，似多分生。真如亦是识之实性。故除识性无别有法。此中识言亦说心所，心与心所定相应故。

    讲解：外人问难曰：既然内境与识并非虚妄，为什么但说唯识无境？论主回答：所谓识，唯独属于内有，至于相分境，则不唯内有，且亦通外，内是依他起，外是遍计执，为恐内外相槛，所以但言唯识。再者，就是愚痴凡夫，迷于心外之境，执取为实，随至起烦恼业，沉沦生死，不了解观心之法，以勤求出离。大觉世尊为哀愍诸愚痴凡夫，特别为说此唯识之理，令其自知观心，以期解脱生死。并不是说内识也如外境都无。或者，相、见二分本来都是以识为性，不过由于往昔虚妄熏习之力，似有相、见二分的生起，若舍末归本，实则唯一识性，即自证分。外人难曰：假定这样说，那不是妄习所生的真如，就应当不是唯识了。论主答：不，因为真如也是识的实性，所以说言唯识，除了识性外，是无别有法的。这里所说的识，并非但指心王，亦兼心所，因为心与心所是决定相应的。

    论文二十七：此论三分成立唯识，是故说为成唯识论。亦说此论名净唯识，显唯识理极明净故。此本论名唯识三十，由三十颂，显唯识理，乃得圆满，非增减故。

    讲解：此论之名《成唯识论》，是由唯识相、唯识性、唯识位等三部分，成立了唯识的道理，故名说为《成唯识论》。此论亦称《净唯识》，因为论中唯识的理体，极为明净透澈，没有混杂故。本识亦名唯识三十，由三十首颂文，显示唯识之理，乃能圆满表达，非有增减。

    论文二十八：已依圣教及正理，分别唯识性相义，所获功德施群生，愿共速登无上觉。

    讲解：这是论师结束了他们解释本论之后，所造的一首颂文。与第一篇敬愿叙里的四句偈遥相呼应。颂文的意思是说：现在已经依于圣人的教诲、和正确的理论，辨明了唯识的体性和相状，把所获的功德，布施给有情众生。祝愿共证无上大觉。


第一讲 解释经题

四、八识规矩颂讲记

    第一讲 解释经题
    一 识者心之别名
    八识规矩颂，是唐代玄奘大师所造。这是玄奘大师于翻译得数百卷唯识经论之后，对于唯识学中的‘八识’，提纲携领所作出的总结。全部颂文，七言一句共四十八句，四句一颂分为十二颂，每三颂为一组，计四组。即前五识颂，第六识颂，第七识颂，第八识颂。八识的行相、业用、性别、识量、所缘、相应等，全包括在颂文之中。唯颂文辞约理著，言简义丰，每一颂中都有许多佛学专有名词，若不详加讲解，一般人很难了解。因此，乃有八识规矩颂讲座的开设。
    八识规矩颂这五个字颂题，重点在‘八识’二字，尤其是这个‘识’字，要特别加以诠释。识是什么？ <大乘义林章> 曰：‘识者心之别名’。因此、识就是‘心’。在唯识学上称识而不称心，只是一种方便，因为心与识是一体两面的东西。 <大乘广五蕴论> 上说：‘云何识蕴，谓于所缘，了别为性，亦名心，能采集故。亦名意，意所摄故。’这样看来，心、意、识三者，也全是一样东西了。那么，或有人问：‘心又是什么呢？ ’依照佛经上说，‘心’是我们精神作用的主体。原来依照佛教的教义，所谓‘宇宙] (物质世间，我人赖以生存的环) 和人生 (有情世间，我人的生命体) ，不是神 (大梵天或上帝)所创造，不是无因而生，这一切，都是‘因缘和合’而生起存在的。
    照佛经上说，构成宇宙和人生的质料有五类，叫做色、受、想、行、识。这在佛经上叫做‘五蕴’。蕴是积聚的意思，积聚许多同一性质、同一系列的事物或心理活动，把它归成一类，就叫做蕴。世界上所有的物质现象、和我人的心识活动，可以归纳成五类，就是前面所说的五蕴。由五蕴的‘因缘和合’，而有‘有情世间’──有情识、情见的众生，和‘器世间’──我人所赖以生存的物质世界的生起和存在。兹再分释五蕴如下：
    一、色蕴： 色蕴的色，是物质的意思 (不是颜色、美色的色) ，组成色蕴的内容是地、水、火、风四种元素。其实真正所指的不是地、水、火、风四种实物，指的是坚湿、暖、动四种物性。由此四种物性，构成宇宙万物，也包括著我们物质性的 身体在内，此即所谓‘色身’。
    二、受蕴： 受蕴是我人感官接触外境所生起的感受。此感受，有使我人愉快的乐受，有使我人不愉快的苦受，和既无愉快亦无不愉快的舍受。其实这就是感情作用。
    三、想蕴： 想蕴是知觉作用，也就是我人的感觉器官接触外境，心识上生起分别、认识的作用。这在现代心理学上，相当于‘知’，由知而形成概念。
    四、行蕴： 行蕴是我人的意志活动，这是心识中‘思心所’的作用。思心所作了决定，由身 (动作) 和口 (语言) 去执行，这就是身行、语行、意行。行就是行为，也称为‘造作’，行为的后果就是‘业’──身、语、意三种业。
    五、识蕴： 佛经上说，识蕴是‘于所缘境了别为性’。事实上就是我人认识作用的主体，也就是心识。在小乘佛教时代，只说‘六识’，就是眼、耳、鼻、舌、身、意六种识，大乘佛教发展为八识。就是在六识之后，发展出末那识、阿赖耶识。这在唯识学上称为‘八识心王’，也就是‘八识规矩颂’中八识二字的来源。
    佛经上说，我人的身心，是由五蕴组合而成的，即所谓；‘五蕴假合之身’。五蕴又称‘名色’，色是物质的组合，名是精神的组合，如下表所示：

    色──────────物质组合──物──色
    受──────────┐
    想──────────┼ 精神组合──心──名
    行──────────┤
    识──────────┘
    五蕴是构成宇宙万有的质料 (包括物质世界和各类有情──一切生命体) ，识蕴是‘主观的能认识的主体’，色、受、想、行四蕴是‘客观的所认识的物件’，如下表所示：

    识──────────主观的能认识的主体──我
    色──────────┐
    受──────────┼ 客观的所认识的物件──我所
    想──────────┤
    行──────────┘
    识者心之别名，识就是心，亦名月意，也就是我人精神活动的主体。
    二 不以规矩不成方圆
    规以正圆，矩以正方，所以古人说：‘不以规矩不成方圆’ 。规与矩，本来是木匠正方圆的工具，引申出来的意思，有轨范、法则的意义。所以八识规矩，表示八识行相，各具境、量、性、界的不同，有其规矩井然而不可杂乱者，于此，先抄录出全部颂文，再依次解释颂题：
    八识规矩颂
    唐三藏法师玄奘造
【前五识颂
性境现量通三性，眼耳身三二地居，遍行别境善十一，中二大八贪嗔痴。

五识同依净色根，九缘七八好相邻，合三离二观尘世，愚者难分识与根。

变相观空唯后得，果中犹自不诠真，圆明初发成无漏，三类分身息苦轮。

第六识颂
三性三量通三境，三界轮时易可知，相应心所五十一，善恶临时别配之。

性界受三恒转易，根随信等总相连，动身发语独为最，引满能招业力牵。

发起初心欢喜地，俱生犹自现缠眠，远行地后纯无漏，观察圆明照大千。

第七识颂
带质有覆通情本，随缘执我量为非，八大遍行别境慧，贪痴我见慢相随。

恒审思量我相随，有情日夜镇昏迷，四惑八大相应起，六转呼为染净依。

极喜初心平等性，无功用行我恒摧，如来现起他受用，十地菩萨所被机。

第八识颂
性唯无覆五遍行，界地随他业力生，二乘不了因迷执，由此能兴论主争。

浩浩三藏不可穷，渊深七浪境为风，受薰持种根身器，去后来先作主公。

不动地前才舍藏，金刚道后异熟空，大圆无垢同时发，普照十方尘刹中。】

    十二首颂文，如上所录，于此先解释颂题如下：
    一、八识： 识者心之别名，是我人精神作用的主体。在唯识学上，把识分析为八种，即是眼、耳、鼻、舌、身、意、末那、阿赖耶八个识。眼、耳、鼻、舌、身是五种感觉器官，合称前五识； 意识称为第六识，是我人心理活动的的综合中心； 末那识称第七识，是有情‘自我意识’的中心，阿赖耶识称第八识。它含藏‘万法种子’，是生起宇宙万法的本源。
    二、规矩： 规矩是规范或法则，这八个识，在众生位上，它们的行相、业用、境、量、性、界，固然有其规矩法则，即是在修行证果位上，也有其规矩法则，所以称八识规矩。
    三、颂： 颂是一种文字体栽，含有赞美的意思，印度梵语称为伽陀，义译为偈。颂的形式似诗而不用韵，通常四句一首，用四、五、六、七字均可，若意思未表达完，可以继续下去。佛经中用颂，目的在便于记忆。本颂用的是七字一句。
    四、唐： 朝代名，西元六一八年建国，传十九帝，西元九零六年为后梁所灭。‘盛唐’时代，是我国历史上少有的太平盛世，国威伸张于全世界，现在世界各大城市都有‘唐人街’的存在，是以‘唐人’代表中国人的意思。
    五、三藏： 佛经结集，有经、律、论三藏，合称大藏经。即佛陀所说的法称之为经，佛陀为僧团所订的戒律称之为律，后世佛弟子注释佛经、或依据佛经而发挥其义者，称之为论。
    七、法师： 法者轨则，师者教人以道，所谓‘传道、授业、解惑’也。指通达佛法，又能引导众生修行之人。三藏法师，指精通经、律、论三藏之法师。若仅通经或律，称为经师、律师。造论阐扬经义者，称论师。法师是一个很尊贵的名词，经律中广载，出家的比丘、比丘尼具足以下十种条件，称为法师。这十种条件是：
    一者五官端正，二者六根圆备，三者出身望族，四者品德善良，五者守持戒律，六者通研三藏，七者威仪具足，八者胜辩言词，九者声音美好，十者忍辱知足。<瑜伽师地论> 卷八十一中，对此有更详尽的说明。不过这个名词现在已通俗化了，变成泛称出家众的名称了。
    八、玄奘： 我国最有名的三藏法师，曾到印度求法，下一节再详予介绍。
    九、造： 造是著作的意思，如各种论典，均称某某造
    三 历史上伟大的译经家玄奘大师
    玄奘三藏，河南偃师人，生于隋文帝开皇二十年 (西元六零零) ，俗家姓陈名纬，有兄长捷先在洛阳净土寺出家，师于十三岁时亦随兄出家，就慧景听 <涅槃经> ，就严法师受 <摄大乘论> 。武德元年，与兄同入长安，未几赴成都，就道基、宝迁二师学 <摄论>、 <毗昙> ，武德五年受具戒，再入长安，时有法常、僧辩二大德俱讲 <摄论> ，师又就听之，以诸师各异宗途，圣典亦有隐诲，不知适从，乃欲西行天竺以明之，表请不许，师不为屈，乃就止蕃人学西域书语，于贞观三年私发长安，西行求法。
    师经兰州出玉门关，涉八百里流沙，途中失水，师誓西行一步而死，不愿东退一步而生，历经艰险，抵达高昌国，高昌国王麴文泰崇信佛法，于师礼供殊厚，派遗车马侍从，送师西行，经阿耆尼等国，度葱岭，至素叶城，谒突厥叶护可汗，再度铁门西行，于贞观七年始抵印度。他曾到过乔赏弥、阿瑜陀、舍卫城诸国，后来到中不竺那烂陀寺，依护法论师弟子戒贤 (时已逾百岁)， 学 <瑜伽师地论> 及十支论奥义，前后为时五年，复从杖林山胜军论师学 <唯识抉择> 及瑜伽、因明之学。然后巡礼圣迹，遍历天竺诸国，参访各地论师，之后再返那烂陀寺。以其和会中观、瑜伽二宗所造之 <会宗论> 三千颂呈戒贤论师，戒贤称善。
    时戒日王致书戒贤，请差大德四人，善大小内外之学者，与乌荼国小乘论师辩论。奘亦受是命，以 <制恶见论> 一千六百颂一破得乌荼国小乘论师之 <破大乘义七百颂> ，由是声誉益著。贞观十五年，戒日王于曲女城设大会，与会者有十八国王，大小乘僧三千余人，婆罗门及外道亦数千人。奘师受请登宝床为论主，以有名之 <真唯识量颂> 论文，阐扬大乘，破斥异说。大会十八日，无能破之者，戒日王宣布论主获胜，与会者共尊之为‘大乘天’──大乘的圣人。
    奘师于贞观十九年初，奘师回至长安，道俗出城相迎者数十万。二月谒太宗皇帝于洛洛阳，太宗迎慰甚厚。奘师由天竺请回经典六百余部，谒于长安弘福寺从事翻译，先后译出经论七十五部，一千三百三十五卷，其中以法相唯识一宗的经论为主。如于贞观二十二年译出 <瑜伽师地论> 百卷，以后络续译出 <解深密经>、 <摄大乘论> 、 <百法明门论>、 <大乘五蕴论>、 <唯识二十颂> 、 <唯识三十颂> 等。
    奘师译 <唯识三十颂> 时，本欲将十家释论各别全译，后以弟子窥基之请，糅集十家释论成为一部，其间异议纷纭之处，悉折中于护法之说，这就是中国唯识宗的基本典籍 <成唯识论> 。奘师之学，由窥基继之而加以发扬，开创了我国法相唯识一宗。
    <八识规矩颂> ，是奘师译得上千卷唯识经后，于‘八识’作一提纲携领之作。奘师一生‘译而不作’，他除了一部 <大唐西域记> 流传下来外，在天竺所写的 <会宗论> ，
    <制恶见论> ， <三身论> ，可惜都未译成汉文，梵文本已失传，而今流传下来的，就只有这 <八识规矩颂> 十二首颂文了。
    附记： 相关名相表解
    一、四大、五蕴： 四大具称四大种，为宇宙间物质的基本因素，大者普遍义，种者因义。 五蕴，为构成器世间与有情世间的质料，蕴者积聚义。我人的身心，前者是四大(色蕴)的组合，后者是受、想、行、识四蕴的组合，即所谓五蕴和合的生命体。

     ┌ 地──以坚为性
四大种┼ 水──以湿为性
     ├ 火──以暖为性
     └ 风──以动为性

     ┌ 色蕴──色为质碍义──为四大组合──物质────色
     ├ 受蕴──领纳──一苦乐感受──┐
五蕴─┼ 想蕴──摄取表像──形成概念─┼──精神作用──心
     ├ 行蕴──造作──意志行为───┤
     └ 识蕴──了别──认识作用───┘
    二、十二处、十八界： 五蕴是精神和物质的组合，事实只是色、心二法。物质是色法，色法粗显易解，所以归纳为一色蕴而诠释之； 受、想、行、识四蕴是心法，心法‘冥漠难彰’，所以开为四蕴以诠释之。但众生根器不一，迷悟程度不等，有人迷于心而不昧于物，故佛陀为之五蕴； 开心法为四，合色法为一。有人昧于色而不昧于心，佛陀复为之说十二处──合心法为一个半，开心法为十个半。亦有对色、心二法俱不了解者，佛陀复为之说十八界──开色法为十个半，开心法为七个半。其实这全是由色、心二法开展出来的。十二处、十八界如下表所示：


第二讲 唯识大意

    第二讲 唯识大意
    一 唯识学统
    <八识规矩颂> ，是诠释‘八识’的颂文。八识，是唯识学的基本理论。因此，要学习 <八识规矩颂> ，必先对唯识学有所了解，不然，根本不知道诠释八识的意义何在。于此先把唯识学的大意作一概述，并且先自唯识学的学统作一介绍。
    唯识学、是法相宗的宗义。而中国的法相宗，是源自印度的瑜伽行学派而建立的。原来印度的大乘佛教，以‘中观学派’与‘瑜伽行学派’为二大主流。中观学派，是西元二、三世纪间龙树菩萨所建立的。佛灭度后七百年，南印度龙树菩萨出世，当时凡夫外道、执著于我法实有，小乘有部，执著于我空法有。执常执断，计一计异，是一个邪说充斥的时代。龙树广造论典，揭示‘诸法性空’之义，破诸邪执，大成佛教空宗。此宗是依龙树的‘中观论’一书而建立的，后世称之为‘中观学派’。此后二百年，中观学派的学说是印度大乘佛教的主流。
    但龙树提倡的空观，是以‘缘起性空’，诸法无自性立论，并非徒持空见，妄计一切皆空。唯傅至后世，则流为‘恶取空’，于世俗谛，不施设有； 于胜义谛，真理亦无。此谓之恶取空，亦谓之沈空。佛灭后九百年顷，无著、世亲二大菩萨出世，当时印度的思想界，一方面是中观学派的空──一切皆空的恶取空，一方面是小乘外道的有──我法实有或我空法有。沈空或实有，皆是邪执，因此无著世亲二菩萨，资于小乘之实有，鉴于大乘之沈空，揭示大乘有义，大成大乘有宗。有宗之有，破斥我法二执，故不同小乘之有； 遮遣恶取空见，以矫治大乘沈空。故此有是真空妙有，唯识中道。
    大乘有宗，是依据弥勒菩萨的 <瑜伽师地论> 、 <大乘庄严论> 、 <辩中边论> 、 <金刚般若论> 、 <分别瑜伽论> 等五部大论而建立的。据说兜率天弥勒内院的弥勒菩萨，曾降临中印度阿瑜陀国，在瑜遮那讲堂，为无著说五部大论。事实上，弥勒菩萨并不是历史上实有的人物，或者是世间另有一位弥勒之人。或谓五部大论可能是无著所作，托以弥勒菩萨之名以示矜重。无著以 <瑜伽师地论> 为本论，又造 <显扬圣教论> 、 <摄大乘论> 、 <顺中论> 、 <集论> 等论典，演说瑜伽教理，故后世之为‘瑜伽行学派’。
    世亲是无著的异母弟，约在西元第五世纪初年出生。他初在小乘有部出家，修学小乘。他欲深究有部教理，曾到有部根据地伽湿弥罗城，精研有部教理四年，后来著造 <俱舍论> 一书，为中国俱舍宗所依的论典。世亲在北印度弘扬小乘，无著悯之，托以疾病，诱其来见，为之具说大乘要义。世亲闻兄教诲，自小乘转入大乘，继承无著的学说，广造论典，大成法相唯识宗义。世亲在唯识学方面的著作，主要者有 <摄大乘论释> 、 <百法明门论> 、 <大乘五蕴论> 、 <唯识二十论> 、 <唯识三十论> 等。其中尤以 <唯识三十论> 一书，为唯识学理论的基础。世亲之后，十大论师相继出世，各为 <唯识三十论> 造释论，阐扬此派学说。十大论师中，以护法的贡献最著。
    护法的弟子戒贤，在中印度佛学中心那烂陀寺，弘扬唯识。西元七世间，玄奘大师西行求法，从戒贤学唯识五年。回国之后，广译有宗经论。奘师曾把十大论师各造的 <三十论> 释论携回国内，欲各别翻译，后以弟子窥基之请，以护法的释论为主依，糅合十家之说，综合而成 <成唯识论> 。窥基继承奘师之学，造 <成唯识论述记> 、 <成唯识论掌中枢要> 、 <瑜伽论略纂> ， <杂集论述记> 等著述，大成我国法相唯识一宗。
    窥基之后，代有传人，窥基的弟子慧沼，造 <成唯识论了义灯> 、 <因明篡要>； 慧沼的弟子智周，造 <成唯识论演秘> 、 <因明疏前记> 及 <后记> 。智周的 <成唯识论演秘]，与窥基的 <成唯识论掌中枢要>， 及慧沼的 <成唯识了义灯> ，合称为‘唯识三疏]为研究 <成唯识论述记> 必读之书。智周的弟子如理，又作 <成唯识论疏义演>、<成唯识论演秘释> ，内容则流于琐细。此宗成立之后，百余年间，学习者甚众，宗风颇盛。唯后来华严及禅宗兴起，且如理之后，后继无人，此宗就逐渐衰微了。到唐武宗会昌法难兴起，此宗一脉相传的论疏多被焚毁，此宗就逐渐失传了。
    明季末年，普泰、明昱、德清、智旭诸师，及王肯堂、王□诸居士，曾从事研究，唯以重要注疏散佚，所得成果有限。未几清兵入关，研究风气也就中断了。到了清季末年，石棣杨仁山创设金陵刻经处，自日本请回我国散佚经典三百余种，其中不乏唯识论疏，刻版重印，加以提倡。入民国后，学人研究唯识，蔚为一种风气，南有南京‘支那内学院]的欧阳渐，北有北京‘三时学会’的韩清净，以及太虚大师创立‘武昌佛学院’的师生，都研究及弘扬唯识，此千年绝学，乃重告复兴。
    二 万法唯识
    唯识学的基本理论，即所谓‘万法唯识’，唯识家以为，宇宙间一切法相 (现象) ，全是识所变现，此即所谓‘唯识无境’──境，就是宇宙万有的一切现象。这一切现象，非外在的真实存在，而是识所变现出来的。这叫做：‘识所缘，唯识所变’。
    识是什么？ <大乘义林章> 曰：‘识者心之别名’，又曰：‘识者心也，由心集起彩画为主之根本，故经曰唯心； 分别了达之根本，故论曰唯识。或经义通因果，总言唯心，论说唯在因，但称唯识。识了别义，在因位中识用强故，说识为唯，其义无二。二十论曰： 心意识了，名之差别。]
    由上文可知，识就是心。但此心，并非我人胸中的肉团心。胸腔中的肉团心，只是循环系统中压衔血液的器官，没有了别认识的作用。或有人曰，既然不是胸中的肉团心，当然是脑袋壳中的大脑。这也只对了一半，因为离开大脑固然没有识，但大脑并不是识。这好比有了灯管 (电灯泡) 电才会发光，但灯管并不是电。灯管只是物质性的工具，通上电流才会发光。以此类推，大脑也只是物质性的工具，如果没有识，它同样没有了解、分别的认识作用。
    识究竟是什么？ 事实上，识只是一种‘功能’，功用和能力。简单的说，识就是一种[能量’。我们由下列三种界说，以说明之：
    一、识不是一种有质碍性的物质，而是一种功能。识有四个名称，曰心、意、识、了，唯识家解释这四种名称，谓：‘积集义是心，思量义是意，了别义是识。] 如抬头见时钟，这是明了； 继而分别时间，是名分别。而此四种名称，指的都是一种无质碍性的功能。并且八种识均有这四种功能。都可通称为心、意、识、了，不过以功能殊胜来说，则第八识积集诸法种子，生起诸法，名之为心； 第七识恒审思量，执著自我，名之为意； 前六识了别各别粗显之境，名之为识。以上数者，只是一种能变的法性，而法性是离开名称言说的境界，唯识之教，是‘即用显体’ 。说到其体，名为‘如如’： 说到其用，名为‘能变’。‘能’则势力生起，运转不居；‘变’则生灭如幻，非实有性。唯识立论，谓离识之外，无有外境。而所谓识，亦不过为一能变的‘功能’而已。
    二、识的功能，非局限于肉身，而交遍于法界 (全宇宙) 。大脑是有质碍性的物质，而识是无质碍性的功能。大脑的感觉神经、运动神经，作用只限于我人的身体；而我人的识，目之所见，耳之所闻，以至于意之所思 (所谓法境) ，山河大地，日月星晨，皆在我人心识之中。识量同于虚空而无极，因此识的功用交遍法界 (此系就种子而言，至于识的现行，则随量之大小而有局限。)
    三、识为种子起现行，而种子起现行必待众缘。识本来是一种功能，此功能未起现行时，不称识而称种子； 种子起现行时，不称种子而称识。所以种子是潜在的功能，识是潜在功能发生的作用。而种子起现行，必待缘具。此缘有四种，曰因缘、等无间缘、所缘缘，增上缘，此于后文再释。
    三 唯识中道
    西元七世纪间，印度的戒贤论师，依 <解深密经、无自相品> ，将如来一代时教，判为‘三时教相’。这三时教相是：
    一、第一时有教： 如来为使一切起惑造业的众生，入于佛道，而说业感因缘诸法，即四圣谛十二因缘法门，令诸凡夫外道趣入小乘教法。
    二、第二时空教： 如来为使一切虽断我执未断法执的小乘者，宣说诸法皆空之理，为令诸小乘趣入大乘的教法。
    三、第三时中道教： 如来更为欲断除小乘人偏有，及大乘人偏空的执著，而说非有非空的中道教。此中道教圆融俱足，是如来究竟了义的大乘教。
    以上三时教内，前二时为如来的方便教法，是不了义教； 第三时为如来的真实教法，是了义教。而法相唯识宗的教义，便是宣说三自性、三无性的唯识中道，故法相唯识宗又称为中道宗。
    中道是什么？ 经云：‘中以不二为义，道以能通为名。’中道是离开二边对立──离开常、断二见、有、无两边，而臻于不偏不倚的中正之境。
    唯识中道，是建立在三自性和三无性的理论基础上。唯识家以为，世间万法──一切存在的事物，都有三自性，也都有三无性。三自性是遍计所执性，依他起性，圆成实性；而三无性是相无性，生无性，胜义无性。
    原来唯识学立论，以为宇宙万法，皆是能变的心识、所变起之境，这即是‘万法唯识’。而心识所变的外境，依其原始的性质，可分做三类：
    一、妄有性： 这类事物本来没有本体，是我人假立名相而有的，而我人却普遍的执著计较，计较的物件，不外是名称言说或义理，名称言说不是实有，只有‘妄有]。
    二、假有性： 这类事物，是因缘和合──众多因素条件所生起的，如以砖瓦木石筑成房屋，以泥土工具做成瓶钵，它没有本身的实体、自性，不过是‘组合’的存在 (仗因托缘的生起存在) ，这也不是实有 ，只是‘假有’罢了。
    三、实有性： 这是诸法的实体、自性，它不是虚妄的、暂时的存在，而是绝待的、超越的存在，事实上这是诸法绝待的理体，也即是‘实性’──真实的存在。
    以上三类，在佛学术语上称为‘三自性’──即是遍计所执性，依他起性，圆成实性。如 <解深密经> 上说 ：‘云何诸法遍计所执相，谓一切法，假名安立，自性差别，乃至为令随起言说； 云何诸法依他起相，谓一切法缘生自相、、、、、、云何诸法圆成实相，谓一切法平等真如。’经文中的‘相’字，在此处就是性的意思。所以，换一个方式说，三自性就是：
    一、遍计所执性： 这是我人对一切事物，普遍的执著计较。执著于五蕴和合的假我为实我，执著于条件组合的假有为实法。或执于相，或执于名，或执于义理，时时计较，处处计较，这一切执著计较，就是我人烦恼生起的原因。
    二、依他起性： 依他起的‘他’，指的众缘──众多的因素条件。世间万有，没有孤立生起或存在的，全是因素条件的组合。既是组合，就会随著组合条件的改变而变化。所以它没有‘自性’ ──即是没有固定不变之性。
    三、圆成实性： 圆者圆满，成是成就，实是真实，合而言之，就是圆满成就的真实体性。这真实体性不是事相，而是‘理性’──超越相对的绝待真理。也就是二空──在我空和法空之后，所体证的理体。这理体也就是真如。
    三自性，是以依他起性为中心。仗因托缘生起的事物，只是暂时的现象，不是永恒的实体。我人若在这因缘和合的事物上执著计较，这就是遍计所执性──普遍的计较执著，执我执法、执常执断。如果彻悟诸法缘生，常一切时，在依他起诸法上、无遍计所执的实我实法，这就是圆成实性。 <唯识三十颂> 上说 ：‘依他起自性，分别缘所生，圆成实于彼，常远离前性。] 前性，指的是于依他起法上，远离普遍执著计较的遍计所执性。
    因此，圆成实性，是‘二空’──我空、法空之后，所显的圆满成就的诸法实性，也就是依他起诸法的‘法性’。
    一切诸法，各具三自性，同时也各具三无性，那就是相无性，生无性，胜义无性。无性，就是无自性。试想，宇宙万有，无非全是一时组合的假相，依此假相，而立假名。我人在这一切假名、幻相上执著计较，假名幻相何尝有其自性？ 其次说生无性，依他起之法，是仗因托而生起的，它是随著因缘的聚散而生灭，它何尝有固定不变的自性？ 最后是胜义无性，所谓胜义，就是真如。 <唯识三十颂> 曰：‘此诸法胜义，亦即是真如，常如其性故，即唯识实性。’唯识实性就是圆成实性。圆成实性是超言绝虑的绝待之法，显二空之妙理，所以说胜义无性──胜义如果有自性，就不是绝待的胜义了。
    附记： 相关名相表解
    一、三自性： 三自性为唯识宗一切法义的根本，南海寄归内法传曰： 相宗以三性为宗。

┌遍计所执性─于依他起之事物上、分别执著名相，妄认为实我实法
三自性─┼依他起性──万法皆以因缘和合生生起，只是组合，而无自性。
     └圆成实性──于依他起法上、常一切时远之离执著，即圆成实性。

     ┌相无性──此相为妄情所现，假名安立，故无自性。
三无性─┼生无性──仗因托缘而起的事物，只是组合，而非实有，故无自性。
     └胜义无性──胜义是二空所显真如，真如若有自性，就不是绝对的胜义了。
    二、三性中道： 中道是远离空有二边，无增无减的意思。世间一切法，每一法都具足三 性，谓之‘三性各具中道’，也各具三性对望中道。

     ┌情有──非空
     ┌遍计所执性┤
     │ └理无──非有
     │
     │ ┌假有──非空
三性各具中道─┼ 依他起性 ┤
     │ └实无──非有
     │
     │ ┌真实──非空
     └ 圆成实性 ┤
     └无相──非有

     ┌ 遍计所执性──体相都无───非有┐
三性对望中道─┴依他起性───如幻假有┐ ├中道
     └──非空 ┘


第三讲 八识心王

    第三讲 八识心王
    一 前五识
    古来大德和现代时贤，讲八识规矩颂的，多是一开始就由颂文讲起。按照颂文的顺序往下面讲。本颂四十八句颂文，已在第一讲中录出，我们看得出来，颂文中充满了佛学名词，并且颂文中的名词，前后都有连带关系。我们若一开始就讲颂文，势必把有连带关系的名词加以割裂，讲起来有困难，听的人也可能听不出头绪来。我们现在换一个方式，先讲解颂文中的名词，到名词全部了解，再讲解颂文，才能听出头绪，融会贯通。现在我们依照八识心王，五位心所，识体四分，九缘生识等顺序讲下去，最后再讲颂文。
    学习唯识学，有一本入门的论著必须要读，那就是世亲菩萨造的 <百法明门论> 。这本论著，在‘一本十支’之学中，称作‘略陈名数支’。顾名思义，就是粗略的解释百法名数。百法是什么？ 原来世间事物，林林总总，不可胜计，此泛称之为‘宇宙万法’。万法不能一一为之说明，乃用分类归纳的方法，把万法归类。因此，世亲菩萨将万法约之为百种，复□之以五位，称之为‘五位百法’。五位百法是：
    一、心王法： 八种，称为八识心王。
    二、心所有法： 五十一种，称为五十一位相应心所。
    三、色法： 十一种。
    四、心不相应行法： 二十四种。
    五、无为法： 六种。
    于此，今日就讲五位百法中的心王法──八识心王。
    八识心王，就是眼识、耳识、鼻识、舌识、身识、意识、末那识、阿赖耶识。识就是心，何以我人一心而八识？ 原来我人通常执著于实我实法──把宇宙间的一切视为实体。说到心时，也隐然有一整体的东西存在。唯识家以分析的方法，分析此心为八，以破遗我人的执著。于此先来探讨前五识。
    前五识、即眼、耳、鼻、舌、身五识，这是我人的五种感觉器官，其作用是：
    一、眼识： 依于眼根，缘色境所生起的了别认识作用。
    二、耳识： 依于耳根，缘声境所生起的了别认识作用。
    三、鼻识： 依于鼻根，缘香境所生起的了别认识作用。
    四、舌识： 依于舌根，缘味境所生起的了别认识作用。
    五、身识： 依于身根，缘触境所生起的了别认识作用。
    前五识，是感觉器官，依于我人色身中的五根 (即眼、耳、鼻、舌、身五根) 而生起
    ，所以又有以下五种名称：
    一、依根之识： 此识依其根而生起。
    二、根发之识： 此识由其根而发生。
    三、属根之识： 此识是属于其根之识。
    四、助根之识： 此识助其根而起分别。
    五、如根之识： 此识如其根而命名。
    五识依于五根而生起，但所依之根，又有内根、外根的分别。外根，就是我人视觉可见的眼睛、耳朵、鼻子、舌头、和身体。但这五种根，是四大合成的物质，它的作用是扶助内根，为内根所依托处，这在佛经上称为扶根尘、扶助内根的尘法。扶根尘不能生识，生识的是内根，又称之曰‘净色根’，亦名胜义根。佛经上说： 胜义根质净而细，有如琉璃，肉眼不可见，唯佛眼天眼可见之。近代科学发达，使我们知道所谓净色根，事实上就是人体的神经纤维和神经细胞。净色根有发识取境的作用，功能殊胜，故名胜义根。
    眼、耳、鼻、舌、身五识，缘色、声、香、味、触五境，五境又称五尘，麈者虚浮之法，生灭变异，随著因缘而改变； 尘也是染污的意思，以此五者，能染污我人的心识，所以称尘。五识所取之五境，分别说明如下：
    一、眼识： 眼识缘色境，此色是颜色之色，非有质碍性(物质) 之色。此色有三类：

    1、显色： 有十三种，青、黄、赤、白、光、影、明、暗、云、烟、雾、空。
    2、形色： 有十，长、短、方、圆、粗、细、高、下、正、不正。
    3、表色： 有八，取、舍、屈、伸、行、住、坐、卧。
    4、法处色： 有五，极回色、极略色、定自在所生色、受所引色、遍计所执色。
    二、耳识： 耳识缘声境，此境有三：

    1、执受大种因声： 人之语言、动作 (如鼓掌) 所发之声音。
    2、非执受大种因声： 自然界所发之声音，如风声、水声等。
    3、俱大种因声： 人与物质界共发之声音，如吹笛、奏萧，伐木、凿石等。
    三、鼻识： 鼻识缘香境，此有六种，三实三假，三实者，顺益者名好香、如沉檀； 违损者合恶香、如粪秽； 无顺违者名平等香，如土石。三假者名俱生香，和合香，变异香。
    四、味境： 舌识缘味境，此有六种，有甘、酸、咸、辛、苦、淡。
    五、身识： 身识缘触境，即是我人的触觉，略说如冷、暖、滑、涩，轻、重、痛、痒，细说有二十六种，不细述。
    五识只能了别自己界限以内的东西，不能越出自己的功能范围以外。如眼只能缘色，不能越色而缘声； 耳识只能缘声，不能越声缘香，其他各识亦然。并且，五识缘境，只是感觉，‘唯是现量，不带名言’，所以无分别的功能。分别色、声、香、味、触五境的内容，是第六意识的功能。此将在下一节叙述。
    二 第六识
    第六识名意识，这是我人心理活动的综合中心，我人的思考、判断、记忆、决定，以至于喜怒哀乐的情绪用，全是第六识的功能。
    前五识各有其根，第六识也是依根而生起。前五识是依于清净四大组成的净色根，是色法之根； 第六识依于第七末那识，是心法之根。前五识缘色、声、香、味、触五境，缘的是色法； 第六识缘法境，是心法。前五识只能了别自己界限以内的东西，而第六识则是前五识任何一识发生作用，第六识即与之同时俱起，以发生其了解分别的作用。
    意识与前五识比较，它有下列几种特点：
    一、意识缘虑法境，它能了解分别一切外境。
    二、意识能了别一切色法 (物质现象) 的自相与共相。即此物单独的形相，及与他物 比较的差别相。
    三、意识不仅了别现下之事之理，且能了别过去、未来之事之理。
    四、意识不仅是刹那了别，还能相继不断的了别。
    五、意识‘思心所’ 的造作，能造成业果。
    意识有‘五俱意识’ 与‘独头意识’的分别，五俱意识是：
    一、意识与眼识同起，发生其了别作用时，称为眼俱意识。
    二、意识与耳识同起，发生其了别作用时，称为耳俱意识。
    三、意识与鼻识同起，发生其了别作用时，称为鼻俱意识。
    四、意识与舌识同起，发生其了别作用时，称为舌俱意识。
    五、意识与身识同起，发生其了别作用时，称为身俱意识。
    五俱意识，并不是同时五俱，而是或一俱、或二俱、或三俱、或五俱，视缘而定。
    前六识缘外境，有四种原因。 <瑜伽师地论> 称：‘六识缘境，有四因故，能令作意警觉趣境。’这四因是：
    一、欲力： 欲是希望，如果心识对外境，生起爱著，就对外境生起作意 (注意) 力。
    二、念力： 念是记忆，如对外境‘似曾相识’，生起记忆，就对此境生起注意。
    三、境界力： 心识所缘的境界，极为特殊，就对此外境生起注意。
    四、数习力： 就是习惯性，如穿越马路，习惯上要注意有没有车辆。
    再者，五俱意识缘外境时，要经过五段程式，才能充分发生其了别作用。这五段程式，又称为‘五心’。五心是：
    一、率尔心： 这是前五识根境相对生识，刹那间的了别。
    二、寻求心： 这是五俱意识于前五识刹那了别之后，生起寻求之念，以了别外境。
    三、决定心： 五俱意识寻到了目标，决定去了别。
    四、染净心： 五俱意识了别外境后，所生起的善恶染净之心。
    五、等流心： 这是因五俱意识的善恶染净，相续流转，而成就善恶之业。
    独头意识，是不与前五识俱起，单独生起的意识。独头意识缘虑的只是法境。独头意识又分为四种：
    一、梦中独头意识： 这是在睡觉的时候，缘梦中境界生起的意识。梦境在三量中是非量，所以我们不必为梦境所困惑。
    二、定中独头意识： 这是在禅定时，缘定中境界生起的意识。定中意识，唯是现量。
    三、散位独头意识： 这是既不在梦中，也不在定中，也不与前五识同缘外境，而是平常情形下，散乱心起，在意念游走中，上下古今，恩怨情仇，胡思乱想个不停。这在佛教中叫做‘打妄想’ 。这多是比量或非量。
    四、狂乱独头意识： 人在颠狂──神经错乱的时候，常常自言自语，甚至于比手划脚，以加强语势。我们看他语无伦次，事实上他有他意识所缘的境界。这种境界，也是非量。
    三 七八识
    第六识是心理活动的综合中心，我们的见闻觉知，思想判断，全以第六识为主，第七、八识是属於潜意识的范围。但第七识是意识之根，第八识是宇宙万法的本源，无疑义的，第六识的活动，一定受到第七、八识的影响。于此我们来探讨第七、八识的行相业用。
    第七识名末那识，末那二字，是梵语的音译，义译曰意，但恐与第六识混淆，故保留末那原名。第七识唯一的作用，就是‘恒审思量’，思量些什么呢，它误认为第八识是恒、是一、是遍、是主宰的‘自我’。它恒常的审虑思量，执著自我。因此，它是一个自我中心，也是一个自私自利的中心。
    说到思量二字，八个识都有思量的作用。但前五识时常间断，也没有审虑作用，所以是‘非恒非审’的思量。第六识有审虑的作用，但也有时间断 (如五位无心) ，所以是审而非恒的思量。第八识是‘恒转] (恒转如瀑流) ，但它并不审虑，所以是恒而非恒的思量。唯有第七识，它恒时审虑思量，执著自我，维护自我，这就是我人何以时时以自我为中心，起惑造业，损人利己的原因了。
    最后说到第八识，第八识又名阿赖耶识，这也是梵语的音译，此在天竺义为‘无没]在我国译为藏识。称为无没者，是说此识含藏万法种子，不令失坏； 亦因它历经生死流转，永不坏灭。译为藏识者，藏是储藏意思，有能藏、所藏、执藏三种意义。能藏，是指它能储藏万法种子 (种子，见第二讲第二节。) 生起宇宙万法。这时，第八识是能藏，种子是所藏。在种子起现行 (发生作用) 的时候，受到前七识杂染法的薰习，现行种子受薰成为新种子，仍藏于第八识中。这时新种子称为能藏，第八识称为所藏。至于执藏二字，又称‘我爱执藏’，这是因为第七识误认第八识为自我，对于自我妄生贪爱，执著不舍，这称为‘我爱执’。这时第七识是能执，第八识是所执。
    第八识有许多异名，录出几个，顾名思义，就可知道它的作用：
    一、种子识： 此识含藏万法种子，能生起万法，故称种子识。
    二、本识： 此识是万法的根本，故称本识。
    三、宅识： 是藏识的别义，谓此识是种子的房宅。
    四、第一识： 八识顺序，由本向末数，此称第一识。
    五、现识： 言万法由本识现起，故称现识。
    六、异熟识： 此识是前生业力的异熟果报体，故名异熟识。
    七、转识： 转有漏的第八识为无漏的大圆镜智，故称转识。
    八、神识： 佛法中本无‘神我’之说，而此识含藏万法种子，功能殊胜，故称神识。
    九、阿陀那识： 阿陀那梵语，是执持之义，此识能摄持根身不坏，种子不失，故名。
    十、无垢识： 此识以修持力，转染成净，转识成智，称无垢识。
    相关名相表解
    一、五位百法： 百法、是把宇宙万有归纳为百种，束之以五位。前九十四种是因缘和合 的有为法，只是现象； 后六种是非因缘和合的无为法，是万法的体性。

     ┌ 心法八
     ├ 心所有法五十一
    ┌ 有为法│
    │ ├ 色法十一百法 (一切法)
    │ └ 心不相应行法二十四
    │
    └ 无为法六
    二、八识心王： 是五位百法中的第一位法，这是精神作用的主体。

     ┌眼识──缘色境──即视觉作用 ┐
     ├耳识──缘声境──即听觉作用 ┤
     ├鼻识──缘香境──即嗅觉作用 ┼此五者是五感觉器官
    八识─┼舌识──缘味境──即味觉作用 ┤
     ├身识──缘触境──即触觉作用 ┘
     ├意识──缘法境──是我人心理活动的综合中心
     ├末那识──执著自我，是自我意识中心
     └阿赖耶识──含藏万法种子，宇宙万法由此变现生起
    三、百法口诀：
    色法十一心法八，五十一位心所法，不相应行二十四，六种无为成百法。


第四讲 六位心所

    第四讲 六位心所
    一 遍行、别境
    六位心所，是五位百法中的第二位，名叫‘心所有法’，这是属于八识心王所有之法，简称心所，又称心数。心所与心王的关系，由下列三义建立： 一、恒依于心王，依八识心王而起。二、与心王相应。三、系属于心王。心所以上三义建立，得‘我所’名。这些心所，随著顺违之境，而起爱憎善恶之心，助成心王事业。认真的说，心王本身无善恶，不能单独造作，必须心所相应方有势力，心所协和于心王，互相呼应，以造作善恶之业。这八识心王，每一个心王好比是一位国王，既然是王，不能没有臣属辅佐。所以心所就好比是国王的臣属。心所有五十一位，分为六组，叫做‘六位心所’。这六组是：
    一、遍行心所； 五个，名称是触、作意、受、想、思。
    二、别境心所： 五个，名称是欲、胜解、念、定、慧。
    三、善心所： 十一个，名称是信、惭、愧、无贪、无嗔、无痴、勤、轻安、不放逸、行舍、不害。
    四、根本烦恼心所： 六个，名称是贪、嗔、痴、慢、疑、恶见。
    五、随烦恼心所： 二十个，又分为小随烦恼，中随烦恼，大随烦恼三种。小随烦恼十个，名称是忿、恨、覆、恼、嫉、悭、诳、谄、害、乔。中随烦恼二个，名称是无惭、无愧。大随烦恼八个，名称是昏沉、掉举、不信、懈怠、放逸、失念、散乱、不正知。
    六、不定心所： 四个，名称是悔、眠、寻、伺。
    由以个六位心所看来，善心所止有十一，而烦恼、随烦恼却有二十六，宜乎我们的善习少而恶习多，世人善行少而恶行多也。
    六位心所如上所述，现在先自遍行心所说起：
    遍行二字，是周遍起行的意思。心若生时，此五心所相应俱起。它的活动范围非常广泛，它通于一切心──八识心王； 通于一切时──过去、未来、现在； 一切性──善、恶、无记； 一切地──三界九地。遍行心所有五，是触、作意、受、想、思。
    一、触： 触是接触，五根与五境接触 (触) 而生识，根、境、识‘三和’就名为触。<百法明门论> 曰 ：‘令心心所触境为性，受想思等所依为业。’触与作意，有时互为先后。
    二、作意： 作意就是注意，因根、境、识的三和而引起注意，或先注意而生起触。论曰 ：‘谓能警心为性，于所缘境引心为业。’语云，‘心不在焉，视而不见，听而不闻，食而不知其味。’可见心识了别外境，须以作意为前导。
    三、受： 受是感受，心识领纳顺违之境生受。论曰 ：‘谓领纳违顺俱非境相为性，起爱为业。’受有三种，领纳顺境名乐受，领纳违境名苦受，领纳非顺非违境名舍受。若再加忧、喜二受，就称为五受。
    四、想： 想是认识作用，论曰 ：‘于境取相为性，施设种种名言为业。’就是于一切相上生起分别，再加上名称。如谓此是瓶、此是钵等。
    五、思： 思是造作的意思，论曰 ：‘令心造作为性，于善品等，役心为业。’思有三种，曰审虑思、决定思、动发胜思，它于是非善恶，筹量其可行不可行，决定之后，驱役自心，造作邪正善恶之业。其实这就是我人的意志作用。
    别境心所，是以其所缘之境各各不同，非如遍行心所同缘一境，故称别境。遍行心所是心识生起时，五心所相继生起。别境心所是专对某种特别情况，继五遍行心所之后，个别生起。别境所缘之境有四种，即欲缘所乐境，胜解缘决定境，念缘曾习境，定缘所观境，而慧则是于四境拣择为性。别境五心所，如下所释：
    一、欲： 欲是‘于所乐境，希望为性，勤依为业。’ 欲就是希望，对外境的希望追求，对所爱境，希望必合，对所恶境，希望必离。因此希求就有了善恶染净之分，希望成佛作祖，当然是净欲，追求财、色、名、食、睡，就是染欲了。
    二、胜解： 胜者殊胜，解者见解，对外境起决定性的理解。它是‘于决定境，印持为性，不可引转为业。’即于邪正善恶境，既经决定，必如此作，不可引转。所以在犹豫不决的情况下，没有胜解。
    三、念： 念是记忆，‘于曾习境，令心明记，不忘为性，定依为业。’即是对经历过的事明记不忘，叫做念。
    四、定： 定是三昧，译曰正定，它是‘于所观境，令心专注不散为性，智依为业。]心注一境而不散乱，叫做定。
    五、慧： 慧是智慧，智慧能断除疑惑，论曰 ：‘于所观境，简择为性，断疑为业。]这种慧是由定而发，所以对于善恶是非，能取得决定性的简择。
    二 善、烦恼
    六位心所的第三位，是善心所。善与恶相对，凡是性离衍恶，顺益世人者，叫做善。也可以说，对于佛陀的教法，依法而行，叫做善。善心所有十一个，是：
    一、信： 对善法能了知而实信，对佛法义理能坚定信仰者，曰信。此有三种，一者信实，信实事和实理； 二者信德，信功德及道德； 三者信能，信善恶之业的能力。
    二、惭： 惭者羞耻，做了坏事内心感羞耻，别人学问道德强过自己，感到耻不如人，都叫做惭。惭是自我尊重的促进力量。
    三、愧： 做了坏事，怕舆论的批评，怕别人的指责，无颜见人曰愧。在世俗社会，惭愧二字连在一起用，在此处，惭著重于崇重善法，愧著重轻拒恶法。
    四、无贪： 贪者贪爱，贪著世间财色名利，非分追求，非义而取，曰贪； 反之以己所有，惠施于人，广行布施，曰无贪。
    五、无嗔： 嗔者嗔恚，逆境当前，不能忍受，恼恨于心，生起恚恨，曰嗔。反之，慈愍待人，不做恶行，曰无嗔，
    六、无痴： 痴者愚昧不明，是非不分，起诸邪见，谤无因果。无痴意谓有智慧，明达事理，主要是指明确理解四圣谛、八正道、十二缘生的道理。
    七、勤： 勤又名精进，精者不杂，进者不退，对于为善断恶，佛法修持，勇猛前进，谓之精进。
    八、轻安： 轻者轻快，安者安乐，这是禅定时使身心得到轻适安稳的境界。
    九、行舍： 行是行蕴中的行，舍是舍弃，舍弃行蕴中的昏沉掉举，令心平等正直，论曰 ：‘精进三根令心平等正直，无功用住为性，对治掉举静住为业。’即由不放逸先除广杂染，令心寂静而住，处于平静的中庸状态。
    十、不放逸： 放者放荡，逸者奔逸。论曰 ：‘精进三根，于所断修，防修为性，对治放逸，成满世出世间善事为业。’也就是于五欲六尘心不希求，对治放逸。
    十一、不害： 害者损害、戕害，不害是‘于诸有情不为损恼，无嗔为性，能对治害，悲愍为业。’ 不害相当于慈悲，与人以乐，拔人以苦。
    六位心所的第四位，是烦恼心所。烦者烦扰，恼者恼乱。烦扰恼乱人心者，称为烦恼。烦恼心所有六，是贪、嗔、痴、慢、疑、恶见，此六者又称为根本烦恼心所。
    一、贪： 贪是贪欲，非义而取，心无厌足，曰贪。论曰 ：‘于有有具染著为性，能障无贪，生苦为业。’世人贪财贪色，贪名贪利，贪求种种欲乐，贪是爱、欲的同义语，是无贪之反。
    二、嗔： 嗔者嗔恚，逆境当前，妄动无明，论曰 ：‘必令身心热恼，起诸恶业。’所以嗔心起时，对家人眷属、乃至众生，心生憎恶，轻则恶声诟骂，重则刀杖相向，甚至于伐城伐国，喋血千里，莫不由嗔心而起。
    三、痴： 痴是无明的异名，无明者，迷昧不觉，起诸邪见，不辨是非，谤无因果。论曰 ：‘谓于诸事理迷暗为性，能障无痴，一切杂染所依为业。’一切杂染恶法，皆依无明生起，这就是众生生死轮回的根本。
    四、慢： 慢者骄傲，‘谓持己于他，高举为性，能障不慢，生苦为业。’慢也就是轻举乔扬，不知谦卑，轻蔑他人。慢可开为七种，此处从略。
    五、疑： 疑者信之反，‘谓于诸谛理，犹豫为性，能障不疑，善品为业。谓犹豫者，善不生故。’疑也就是对于三宝的功德，四谛的真理，因果的能力，都犹豫不信，所以能障不疑善品为业。
    六、恶见： 即不正确的见解，此又称邪见，此有五种，一者身见，即是我见。二者边见，即于我见上执常执断。三者邪见，否定因果善恶的见解。四者见取见，即固执己见，互相斗争。五者戒禁取见，认为持牛戒、狗戒、鸡戒，是生天证果之因，这称为非因计因。
    三 随烦恼、不定
    六位心所的第五位，是随烦恼心所。随烦恼，是随从根本烦恼而生起的烦恼。随有三义，一者自类俱起，二者遍不善性，三者遍诸染心。随烦恼心所二十个，又分为三类，即小随烦恼十个，中随烦恼二个，大随烦恼八个。小中大的分别，以三义俱备者名大； 兼俱二义者──自类俱起，遍不善性者称中随； 于不善心中各别而起者称小随。小随烦恼，行相粗猛，于不善心中各别而起，若一生时，必无第二。十小随烦恼如下：
    一、忿： 忿者忿怒，于不饶益境，‘愤发为性，执杖为业。’忿是以嗔一分为体。
    二、恨： 由忿为先，怀恶不舍，‘结怨为性，能障不恨，恼热为业。’亦以嗔为体。
    三、恼： 恼者‘狼戾为性，能障不恼，蛆螫为性。’ 由忿恨而起报复心，恼害于他。
    四、覆： 覆者隐藏，自作过恶，怕为人知，故以‘隐藏为性，能障不覆，悔恼为业、]
    五、嫉： 嫉者嫉□，嫉贤妒能，‘妒忌为性，能障不嫉，忧蹙为业。’亦以嗔为体。
    六、悭： 悭是悭吝，是‘耽著财法，不能惠施，秘吝为性，能障不悭，鄙畜为业。]
    七、诳： 诳是虚伪不实，[为获利誉，乔现有德，诡诈为性，能障不诳，邪命为业。]
    八、谄： 谄者谄媚，巧言令色，阿谀于人。[矫设异仪，险曲为性，能障不谄。]
    九、害： 害者不害之反，‘于诸有情，心无悲愍，损恼为性，能障不害，逼恼为业、]
    十、乔： 乔者倨傲，持己才能，淩辱他人‘醉傲为性，能障不乔，染依为业。]
    中随烦恼二个：
    一、无惭： 无惭者惭之反，做了坏事，不自羞耻，它‘不顾自法，轻拒贤善为性，能障碍惭，生长恶行为业。]
    二、无愧： 无愧者愧之反，做了坏事，不畏清议，不怕批评，谓之愧。它‘不顾世间，崇重暴恶为性，能障碍愧，生长恶行为业。’人到了无惭无愧的时候，了无忌惮，什么不仁不义、寡廉鲜耻的事都做得出来。
    大随烦恼八个：
    一、昏沉： 神志昏昧，无所堪能，无所肩任，使身不得轻安，而心不得入观。
    二、掉举： 神魂不定，妄想纷飞，‘令心于境不寂静为性，能障行舍及止为业。]
    三、不信： 不信者信之反，不信因果，诽谤圣贤，‘心秽为性，堕依为业。]
    四、懈怠： 不精进为善，不努力断恶，‘懒惰为性，能障净信，堕依为业。]
    五、放逸： 放荡纵逸，不防恶修善，‘纵荡为性，障不放逸，增恶损善所依为业。]
    六、散乱： 散者分散，乱者扰乱，‘令心流荡为性，能障正定，恶慧所依为业。]
    七、失念： 失念是失去正念，邪念增长，‘能障正念，散乱所依为业。]
    八、不正知： 知者知见，知见不正，邪见增长，‘于所观境谬解为性，毁犯为业。]
    六位心所的第六位，是不定，此有四种，谓悔、眠、寻、伺，曰‘悔眠寻伺，于善染等，皆不定故。’它可以成就善，可以成就恶。故曰不定。
    一、悔： 悔者追悔，于所作之善事追悔，即是恶； 于所作恶事追悔，即是善。或于未作之恶事追悔则是恶，或于未作善事追悔则是善。
    二、眠： 眠者睡眠，为调摄身心的适当睡眠是善，睡眠无度或昼夜颠倒者是恶。
    三、寻： 寻是对事理粗略的思考，若思善便属善，思恶则属恶。
    四、伺： 伺是对事理细密的思考，若思善便属善，思恶则属恶。
    附记： 相关名相表解
    二、六位心所： 六位心所、五位百法的第二位法，心所五十一个，分为六位。

     ┌遍行心所五
     ├别境心所五
     ├善心所十一： 信、惭、愧、无贪、无嗔、无痴、精进、轻安、
     │ 不放逸、行舍、不害。
     ├根本烦恼心所六： 贪、嗔、痴、慢、疑、恶见。
六位心所┼随烦恼心所二十： 又分为三类：
     │ 1、小随烦恼十： 忿、恨、覆、恼、嫉、悭、诳、谄、害、乔。
     │ 2、中随烦恼二： 无惭、无愧。
     │ 3、大随烦恼八： 昏沉、掉举、不信、懈怠、放逸、散乱、
     │ 失念、不知知。
     └不定心所四： 悔、眠、寻、伺。


第五讲 种子、薰习、识体四分

    第五讲 种子、薰习、识体四分
    一 种子
    本文第二讲第二节，讲过‘万法唯识’，其中说到，识是一种功能，功能未起现行时，不称识而称为种子； 种子起现行时，不占种子而称识。所以种子是潜在的功能，识是潜在功能发生作用。
    由上所述，可知种子只是一种功能，此功能非物质而有物质的力用。世间万法，皆自此能、此力生起。于此，种子有下述定义：
    一、种子非色非心，只是一种功能。
    二、此种功能遍宇宙，故种子亦遍宇宙。功能一旦起用 (起现行) ，宇宙万象森罗。故种子无尽，宇宙亦无尽。
    三、种子无大小轻重之分，种子起现行时，‘相分’由‘见分’而显示。故心识分别一生，即摄尽全宇宙，无一法不在心识之中。
    于此可知，所谓宇宙万法，皆是第八阿赖耶识中、含藏的万法种子变现而来。因此，<成唯识论> 卷二曰：
    ‘此中何法名为种子？ 谓本识 (阿赖耶识) 中，亲自生果，功能差别。此与本识，及所生果，不一不异。体用因果，理应尔故。]
    以上这段论文，如果加以语译的话，就是说： 什么叫叙种子呢？ 就是阿赖耶识中，能够亲自生出不同果法的功能，这种功能，与阿赖耶识，及所生果法，既不是一，也不是异。
    第八阿赖耶识中，含藏有万法种子，此种子从何而来呢？ 这有三种不同的说法：
    一、唯本有说： 这是印度护月论师等的主张，他认为，阿赖耶识中的一切有漏无漏种子，是无始以来，‘法尔本具’，后来再从薰习新生。
    二、唯新薰说： 这是印度难陀论师等的主张，他认为，一切种子，皆是无始以来，从现行薰习新生的。
    三、本有新薰并有说： 这是印度护法论师的折衷主张，他认为，无始以来，阿赖耶识中，有‘法尔本具’的种子，同时也有从现行薰习的新薰种子。
    以上三说，后世以护法的说法较为圆满。
    在 <成唯识论> 中，为种子的体性立有六条定义。这六条定义是：
    一、刹那灭： 种子只是一种功能，不可以色、声、香、味、触去测量，但在发生作用却有力用。这种力用，才生即灭，即所谓‘无间即灭’，中间没有‘住’的阶段，这叫做‘刹那灭’。
    二、果俱有： 种子起现行，虽然刹那即灭，但不是灭后始有果，而是刹那生灭之际，‘正位转变，能取与果’，也就是即因生现果，这果就是新薰的种子。
    三、恒随转： 种子起现行，刹那灭，果俱有。但不是灭了即断，而是前灭后生，相似随转，恒常不断。
    四、性决定： 种子随其能薰因力的善恶，而决定其性别，成为善业种子或为恶业种子，而在起现行的时候，善业种子起善的现行，恶业种子起恶业现行。此一原则，决定不变。
    五、待众缘： 种子起现行，要众缘具足，心法生起要具备四缘，色法生起具备二缘，关于各种缘，将在下一节课讲述。
    六、引自果： 种子并不是一类种子生各类的果，而是色法种子生色法的果，心法种子生心法的果，此一法则不能错乱。
    二 薰习
    种子是为第八识所摄持 (即储藏于第八识中) 、能生自果的一种功能。这种能生起万法的种子，在第八识中，是前念种子生后念种子，前灭后生，‘自类相续，有如瀑流’，这叫做‘种子生种子’ 。另一方面，某一类种子，在众缘和合 (四缘具备) 的时候，能生起各自的果法，这叫做‘种子生现行’。当其生起现行之刹那，有强盛的势用，刹那之间，再薰习各自的种子，这叫做‘现行薰种子’。被薰的种子成为新种子，则仍储藏于第八中。不过认真的说，所谓‘现行薰种子’，是具有见闻觉知作用的前七识。前七识的见闻觉知作用，就是‘现行’──现在的行为，身、语、意三方面的行为。
    种子生起现行的时候，种子是因，现行是果； 而现行薰习种子的时候，现行是因，受薰的新种子是果。这三者 (种子、现行、薰习) 之间的关系，是‘刹那生灭，与果俱有]。所以古德曾说：
    ‘种子生现行、现行薰种子，三法 (种子、现行、薰习) 辗转，因果同时。]
    种子生现行，现行薰种子，刹那灭，果俱有 (种子六义的第一二义) 。而受薰的种子成为新种子，新种子又起现行，这种前灭后生，有如瀑流，亘古不息者，就是‘恒随转]。在这前生后减的随转中，具有‘三法’和‘二重因果’。
    所谓三法，是能生的种子，生起的现行，和受薰的新种子。所谓二重因果，即种子生现行，种子是因，现行是果，是一重因果； 现行薰种子，现行薰种子，现行是因，种子是果，这是又一重因果。这三法辗转，刹那之间，成为二重因果。
    种子与第八识的关系，以因果来说，种子是因，第八识是果，因为第八识是现行，种子是生现行之因 (第八识是种子所生之果，后面另有解释。) 另以体用来说，第八识是体，种子是用，故摄用归体，摄果归因，这二者的关系，是‘非一非异’ 。
    种子与前七识的关系，是在‘因能变’中，种子生出第八识。在果能变中，第八识生出前七识，同时八个识体上各各生出‘相分’、‘见分’。前七识以其见闻觉知的认识作用，又薰习了起现行的种子。因此，就薰习面来说，前七识是因，受薰的新种子又成为果了。
    什么叫薰习呢？ 我人身、口、意三者所表现的善恶行为，其‘气分’留于第八识中，就叫做薰习。也可以说，第八识把我人行为经验的痕迹保留下来，这经验痕迹就就是种子，亦名气分，也叫习气。<大乘起信论> 曰：‘薰习义者，如世间衣服实无于香，若人以香而薰习故，则有香气。]
    在薰过程中，前七识是能薰，第八识是所薰。在能薰与所薰之间，各要具四种条件，所以在 <成唯识论> 中立有‘能薰四义’，在 <摄大乘论> 中立有‘所薰四义’。能薰者是前七识，它所具备的四种条件是：
    一、有生灭： 能薰者要有生灭，有生灭变化方有作用，方能薰习种子。无为法是不生灭的常法，不能薰习，前七识是因缘生起的生灭法，可以薰习。
    二、有胜用： 胜用有，一者能缘的势用，二者强胜的势用。心法中的前七识，具此二条件，所以为能薰。譬如用香料薰衣，香料要有强烈的气味才能薰，气味微弱不能薰，第八识性唯无记不能薰，物质无缘虑作用不能薰，唯前七识为能薰。
    三、有曾减： 有了胜用，且高下不定，有增有减，方是能薰。佛果是圆满的净法，不能薰； 前七识是杂染的有漏法，所以能薰。譬如以樟脑球放在衣箱中，衣服薰香了，樟脑球也散发了。金球玉球本身无增减，不散发，也不能薰衣。
    四、与所薰和合而转： 能薰与所薰同时同处，不即不离，和合而转。本身之前七识，唯能薰本身的第八识，不能薰他人的第八识。
    在 <摄大乘论> 中立有‘所薰四义’，所薰者是第八识，它所具备的条件是：
    一、坚住性： 受薰者要一类相续，能持习气，始可受薰。前六识有变易，第七识是染污识，不能受薰，第八识一类相续而不间断，可以受薰。
    二、无记性： 第八识性唯无记，法体平等，无所违拒，能容习气，故可受善恶现行的薰习。所以清净的佛果，和有漏的前识不能受薰。这好比沉麝不能薰成臭的，蒜薤不能薰成香的，因为它本身气味已固定了。
    三、可薰性： 这是指受薰体性非坚密，有隙可乘，始可受薰。真如坚密，不能受薰；第八识体性虚疏，能含容种子，可以受薰。这好比衣服体性虚疏，可以受薰，而金器玉器体质坚密，不能受薰。
    四、与能薰和合而转： 此与能薰的第四条相同，即第八识唯受本身的前七识所薰，不受他人的前七识所薰。
    三 识体四分
    宇宙万法，都是阿赖耶识含藏的万法种子变现而来的。它是如何变的呢？‘识变’、是唯识学中、是非常深奥难解的一部分，若要细说，几个小时讲不完。简单的说，阿赖耶识中的种子，生起现行，这时以种子为因，生出现行的果。此现行的果，就是第八阿赖耶识。此处有个疑问，种子含藏于第八识中，种子又如何生出第八识呢？ 原来无始以来，第八阿赖耶识，与它所藏的种子，是同时而有的。种子是生识之因，是能生； 第八识是所生之果，是所生。这能生与所生之间，是‘因果同 时’ ， 同时是念念相续，‘恒转如瀑流’似的，不停的转变、变现，因此，种子生出第八识，第八识同时也含藏、摄持种子。这种子生出第八识，以种子为因，第八识是果，这叫 做‘因能变’。
    在种子生出第八识的同时，第八识种子生出前七识，并且包括第八识及前七识在内的八个识，自识体上各各生出‘相分’、‘见分’二分。这第八识生出前七识，同时八识体各各生出相分、见分的变，是第八识识体的变。第八识识是种子生出的果，因此这种变叫做‘果能变’。
    八个识的识体，在果能变时，识体上各各生出相分、见分。什么叫做相分、见分呢？ 原来相分的相，就是世间万法──世间各种事物的形相。相分的分，是一部分的意思。因此，所谓相分，就是识体上事物形相的一部分。见分的见，是能‘了别’──了解分别的作用，也就是我们认识作用的一部分。
    原来唯识学的基本理论，就是‘万法唯识，识外无境。’我们六种识所触对的六种境──色、声、香、味、触、法方六境，都不是实境，全是我们心识上变现出来的。我们心识变出相分 (世间各种事物的形相) ，再由心识的见分去认识。这叫做‘识所缘，唯识所变。]
    <成唯识论> 卷二上说：‘以所缘相说名相分，以能缘相说名见分。’ 又解释说：‘相分名行相，见分名事，是心、心所自体相故。]
    现在再换一个方式来说，在果能变中，识体上变现出相、见二分，这时识体本身就叫做‘自证分’。如以眼识为例，了别 (认识) 色境的作用，是见分； 所了别的色境，是相分。换句话说，见分是主观做能认识的主体，相分是客观的所认识的对像。而所谓‘客观’，并不在心识之外，仍是在心识之内。原来我们眼识所见之境，是我们第八识的色法种子 (相分色) ，变成我们眼识的相分，因此，我们所看到之相，是八识种子变出出来的相，不是心识外的境相。
    当心识上变现出相分、见分的时候，八个识的识体就叫做‘自证分’。譬如以眼识为例，眼识了别外境的作用，即是见分； 眼识所了别的外境，即是相分。那么，见分了别外外境，会不会发生错误呢 (此即所谓非量) ？ 这时识体要来验证一下，因此识体就叫做自证分了。可是，识体的验证是不是正确呢？ 这时识体还有一种‘再度证知’的作用，这再度证知的作用叫做‘证自证分’ 。这样一来，每个识体就有了四分，那就是相分，见分，自证分，证自证分。
    所谓四分，就是识体的四种作用。相分是外境的影相 (这影相是第八识色法种子变现的) ，见分是心识的认识作用； 自证分是心识的验证作用，证自证分是心识再度证知的作用。如果以镜子为喻，相分好比镜子中的影像，见分、好比镜子能见照的作用，自证分好比是镜体，证自证分好比是活动镜架，镜子在活动镜架上，就可上下左右随意活动见照了。
    再以尺子量布为比喻，眼前有一块布，它由第八识的色子种子，在眼识的相分上映出影像，此就像是相分。而见分相当于尺子，去量布的宽度与长度； 自证分的作用，是根据尺子所量的结果，知道这块布的宽度与长度，证自证分就是再检查所量的结果是否正确。
    此处特别加以说明的一点，所谓‘识体四分’之说，正确的说，并不仅限于八识识体，而是包括各各相应的心所在内。
    附录： 相关名相表解
    一、种子的分类： 种子，是阿赖耶识中、能亲自生出不同果法的功能，它有种种不同的
    分类方法，如下表所示：

┌──本性住种，是无始以来法尔本具的，是先天本有的。
依生起分类┤
└──习所成种，是种子生起现行，受现行薰习而成的新种子。

     ┌──有漏种子，是三界六道众生轮回生死的种子。
依有无漏分类┤
     └──无漏种子，是大乘菩萨转染成净、修行证果的种子。

     ┌──善、不善、无记种子，是三界众生的有漏种子。
依三性分类┤
     └──纯善种子，是出世圣者转染成净的无漏种子。

     ┌──名言种子─表义名言│即等流种子│名言习气
有漏种子分类┤ 显境名言│ │我见习气
     └──业种子──即有支习气──亦名异熟种子

    二、识体四分： 是八识识体在‘果能变’时生起的四种功能。

     ┌──见分： 八识识体主能观的认识的功能。
识体四分─┼──相分： 为见分所认识的影像。
     ├──自证分： 识体证知见分所见有无谬误的功能。
     └──证自证分： 识体再度验证的功能。
     │ 圆成实性──真空妙有│


第六讲 九缘生识

    第六讲 九缘生识
    一 缘起
    缘起，是佛教的基本理论，释迦牟尼在菩提树下证悟真理，他所证悟的就是缘起。不过佛陀最初证悟的缘起，是有情生命流转的缘起。像 <过去现在因果经> 中说：
    ‘尔时菩萨，至第三夜，观众生性，以何因缘，而有老死，即知老死，以生为本；若离于生，则无老死。又复此生，不从天生，不从自生，非无缘生，从因缘生、、、、、、]
    这就是因缘二字的来源。因缘、简称为缘起或缘生。什么是缘起或缘生呢？ 在 <阿舍经> 中这么说：‘此有故彼有，此生故彼生； 此无故彼无，此灭故彼灭。’又说：‘譬如有两根□芦，互相依倚才能植立。朋友们，缘名色而有识，缘识而有名色； 此生则彼生，此灭则彼灭，正复如是。朋友们，两根束芦，拿去这根，那根便竖不起来，拿去那根，这根便竖不起来，名色灭则识灭，识灭则名色灭，正复如是。]
    名色和识互相依存，才有生命体的存在。所以因缘二字，简单的说，就是组成一切事物的关系和条件。生命体的存在，是以名色和识互相依存而有的。但其存在，有其前因后果的依存关系（因果关系），也有识和名色 (精神主体和物质性身体) 同时的依存关系。这异时的因果和同时的依存关系，就叫做因缘。不过最早的因缘──即缘起，是生命流转的缘起，到后来则扩大到万法生灭变化的缘起。譬如 <入楞伽经> 中说：
    ‘大慧，一切法因缘生有二种，谓内及外。外者谓以泥团、水、杖、轮、绳、人工等缘合成瓶、泥钵，草席、种芽、酪酥亦复如是，各外缘前后转生； 内者谓无明、爱、业等生蕴、处、界法，是谓内缘起，此但愚夫之所分别。]内缘起，是有情生命流转缘起，即是佛法中的‘十二缘生’，也就是：‘无明缘行，行缘识，识缘名色，名色缘六入，六入缘触，触缘受，受缘爱，爱缘取，取缘有，有缘生，生缘老死。]
    无明、是我们蒙昧的生命原动力，行、是盲目意志冲动之下的行为，识、是业力寄托的阿赖耶识，阿赖耶识受业力牵引，纳识成胎，这时的受精卵，已经成为精神和物质的混合体（即所谓生命体），所以称为名色。以名色为缘，而有六入，六入、就是母胎中的婴儿发育到六根位 （即眼、耳、鼻、舌、身、意六根具备）。 触是出生后数岁以内的幼儿，感觉器官与外界接触，童心未凿，只是直觉，无分别心，所以叫触。受、是年龄渐长，对外的感觉有了领纳的作用。领纳有三种，顺我意者称乐受，违我意者称苦受，不顺不违的称舍受。有了苦乐之受，以受为缘，就有了爱──爱憎取舍。爱就是贪，贪名贪利、贪财贪色，以贪为缘而生起取。取可说是占有，对所爱的一切固执不舍，由取而成为有。有是‘存在’的意思，也是业的意，这是由取而熟切追求，由此造成必得后报的业。有了业因，必有果报，这果报就是生──即是下一世生命开始的生。有了生、就必有老死。在生后死前，又有触、受、爱、取、有，周而复始，就是生命流转。
    外缘起，是万法生灭的缘起，最普通的例子，就是以麦种豆种为因，以阳光、雨露、及人工等为缘，就有麦子豆子的生起； 以泥土调水及工具为因，就有瓶、钵的生起。生起起要仗因托缘，变异、坏灭也要仗因托缘，仗因托缘，就是仗依生起此法的因素和条件。一切法是依赖因素条件组合而有，所以一切法只是现象，不是‘本体’。一切法受到因素条件 (因缘) 的变异而有变化，所以一切法无自性 (没有固定之性) 。无自性又称性空，此称之为‘缘起性空’。
    万法离不开缘起，大致说，这就是缘起。
    二 四缘五果
    有为法的生起，必依因缘之和合。有因有缘，必然生果。因此，唯识学上立有‘六因、四缘、五果。’之说。事实上，因和缘没有什么差别，概略的说，因即是众缘之一，缘也是生果之因，不过在生起万法的关系条件上，因是较重要的一个条件而已。因此，六因之说，只是四缘的另一种分类方式。于此先介绍四缘，四缘是因缘、等无间缘、所缘、增上缘：
    一、因缘： 因缘，是事物生起的众多关系条件中，具有生果能力的条件。经上说，‘谓有为法，亲自办果]， 称为因缘。但仅只有因仍不能生果，要因、缘具备才能生果。同时、在唯识学上的因缘，又不同于一般缘起的因缘。唯识学以‘万法唯识’ 立论，万法生起，皆是种子起现行的后果，因此，唯识学上的亲因缘，就是第八阿赖耶识中含藏的种子。以种子生现行，始有宇宙万法。但‘法不孤起’，种子生现行，须要下列三缘具备。
    二、等无间缘： 等无间缘旧译次第缘，新译等无间，意思是‘密密迁移，等无间隙]，这是指我们的心识生起，念念生灭，刹那不停，前念心为后念心开导，引令后念心生起，前念为后念的缘，后念亦为前念的缘，次第生起，故亦称次第缘。
    三、所缘缘： 所缘缘旧译缘缘，这是心识攀缘外境的时候，此能攀缘之心，对所攀缘之境而生起，即是以境为其所缘。所缘缘这两个缘字，前一个缘是境，后一个缘是四缘之一的缘。语云：‘境由心生，心因境起。’心生之境是法境，属于心法，引心生起之境是外境，属于色法，二者全是心识攀缘的物件。
    四、增上缘： 增上是增加或加强的意思，对于一法的生起，有扶助之义，所以也称助缘。增上缘有顺益、违损两方面，自顺益方面说，能促成一法生起或成长者，称‘与力增上缘’，不妨碍一法生生起或成长者，称‘不障增上缘’； 自违损方面说，此一法对他一法有妨害障碍者，如雨露是花木的顺益增上缘，而霜雹为花木的违损增上缘。
    唯识学是以‘万法唯识’ 立论，以一切法（色法及心法）的生起，皆是种子起现行的果，因此，种子是一切法的因缘。再者，心法生起，要四缘具足； 色法生起，只须因缘与增上缘两种缘。
    六因、是能作因、俱有因、相应因、同类因、遍行因、异熟因，事实上，六因只是四缘的另一种分类。也就是把四缘中能办生自果的因缘，开展为俱有因、相应因、同类因、遍行因、异熟因； 而把等无间缘、所缘缘、增上缘三种，合并为一个能作因。能作因不俱办生自果的功能，但能给具有生果功能的因予以资助，这又分积极与消极两方面，前者是予生果之因以资助，称为‘与力能作因’，后者是对生果之因不予障碍，称为‘不障能作因]，这与增上缘的功能类似，此处为篇幅所限，也就不再一一详述了。
    世间万法，因缘具足，必定生果，所生之果，分为五类，是异熟果、等流果、士用果、增上果、离系果，分述如下：
    一、异熟果： 这是有情生命流转的果，有情以其善恶行为所造作的业因，导致来生三界六道的苦乐之果。其实异熟果就是众生的第八识，第八识又名异熟识，旧译为果报识，所以称为生命流转的果体。
    异熟二字十分费解，据窥基大师 <成唯识论> 述记中的解释，谓异熟有三义：
    1、异时而熟： 由因到果，时间不同，称异时而熟。譬如果树，由开花结果，到果子成熟，必要经过一段时间。有情所造善恶诸业，由造业时望果熟受报，也要经过相当时间，此称异时而熟。
    2、变异而熟： 由因至果，必有不同程度的变异，曰变异而熟。譬如造酒，由水米和合到酝造成酒，必有变异。有情造作各种业因，到隔世成果，也必有变异，曰变异而曰变异而熟。
    3、异类而熟： 由因到果，类别有异，曰异类而熟。譬如江河之水，性质各异，但流入大海，就混同一味了。有情所造的或善或恶的业，，而善业感乐果，恶业感苦果，这苦乐之果非善非恶，则是无记。由因果之间性质不同，故曰异熟。
    二、等流果： 由因流出果，由本流出末，谓之等流。第八识中的善种子生善的现行，从恶种子生恶的现行，种子是因，现行是果，此果是等流果。
    三、士用果： 士是‘士夫’，是人的异名，用是作用，即人力之作用。如农夫耕作而有米麦之果，工匠工作而成器物之果，依其作用所获之果，称士用果。
    四、增上果： 以一因缘法之果，望其他因缘，曰增上果。因为一法生起获果，一切因缘皆予以增上之力，故曰增上果。
    五、离系果： 离系果是道果，这是修唯识行，断我、法二执，证我、法二空，断去烦恼、所知二障的系缚，证得的道果。
    三 九缘生识
    依照唯识学的理论，第八阿赖耶识，含藏万法──色心诸法种子，种子起现行，而有人生和世界 (主观的认识作用，和客观的外境) 。但色心诸法生起，要因缘具足。因缘，即上节所称的四缘。心法生起要具足四种缘，色法生起只需具备两种缘。但唯识学上又有一个名词，叫‘九缘生识’，意谓心识生起，要具足九种缘，这是不是矛盾呢？ 此处我们先看生识的九缘是那些缘，现在以眼识生起为例，眼识生起的九缘是：
    一、空缘： 空即空间，眼识取境，须保持距离，否则不能取境，此谓空缘。
    二、明缘： 明即光明，眼识取境，须要光明，否则不能取境，此谓明缘。
    三、根缘： 眼识依于眼根而生起，谓之根缘。
    四、境缘： 眼根触对色境，生起眼识，境为识之所缘缘，此谓境缘。
    五、作意缘： 作意即是注意，若不注意，则视而不见，此谓作意缘。
    六、种子缘： 阿赖耶识含藏的眼识种子，为生起眼识的亲因缘，此谓种子缘。
    七、分别依缘： 分别指第六识，眼识生起，依第六识分别外境，此谓分别依缘。
    八、染净依缘： 染净指第七识，此识是意识之根，亦影响前五识，此谓染净依。
    九、根本依缘： 根本指第八识，第八识为诸识根本，此谓根本依。
    以上九种缘，为生起眼识缺一不可的条件。但是这和四缘之说是否抵触呢？ 事实上并不抵触，原来以上九缘，种子缘就是四缘中的亲因缘（因缘），境缘就是四缘中的所缘缘，而其余的七种缘，全是增上缘。九缘之中，还少了一个等无间缘，但等无间缘、是在心识连续生起的时候才有的，此处的九缘生识，是在生识的横切面（不包括时间因素）来看，所以不把等无间缘列入。如心识连续生起，加上等无间缘，就成十缘了。
    眼识生起要具备九缘，那么耳、鼻、舌、身诸识呢？ 是否也需要九种缘呢？ 不需要，八种识的生起，所需的缘各不相同，兹列表如下，以资分别：
    一、眼识： 眼识生起要具九缘、已如上述。
    二、耳识： 耳识生起，须具八种缘，即在九缘中减去明缘。因耳识缘声境，耳朵听声音不需要光明，黑暗中也可以听，所以只须八缘。
    三、鼻识： 鼻识缘香境，是‘合中取境’，不需要光明和距离，所以在九缘减去空、明二缘，只须要七缘。
    四、舌识： 舌识缘味境，这也是‘合中取境’，根 (舌) 境 (饮食) 接触才能生识，所以也不需要光明和空间，只须要七缘。
    五、身识： 身识缘触境，必须接触才有感觉，这也是‘合中取境’，也不需要光明和空间，只须要七缘。
    六、意识： 意识取境，要具五缘，即根缘 (第六识以第七识为根，亦以第七识为染净依) 、境缘、作意缘、根本依缘，和种子依缘。即九缘中减去空、明、根、分别依四缘。
    七、末那识： 末那取境，只须四缘，即根缘 (末那识依阿赖耶识为根缘，复以阿赖耶识为根本依缘)、境缘 (末耶缘第八阿赖耶识) 、作意缘、种子依缘。
    八、阿赖耶识： 赖耶取境，也要四缘，即根缘 (赖耶识依末那识为根) 、境缘 (其境为根身、器界、种子) 、作意缘、种子依缘。
    附录： 相关名相表解
    一、六因、四缘、五果： 唯识学立有‘六因、四缘’，为万法生起之条件。有因有缘，必然生果，各如下表所示：

     ┌能作因
     ├俱有因
六因─┼相应因
     ├同类因
     ├遍行因
     └异熟因

     ┌因缘
四缘─┼等无间缘
     ├所缘缘
     └增上缘

     ┌异熟果
     ├等流果
五果─┼士用果
     ├增上果
     └离系果

    二、八识具缘： 八识生起，具缘不同，如下表：

     ┌眼识──九缘──空、明、根、境、作意、种子依、分别依、
     │ 染净依、根本依缘。
     ├耳识──八缘──空、明、根、境、作意、种子依、分别依、
     │ 染净依、根本 依缘。
     ├鼻识──七缘──┐
八识具缘┼舌识──七缘──┼── 各具根、境、作意、种子依、染净依、　　 │ 根本 依缘。
     ├身识──七缘──┘
     ├意识──五缘──根缘、境缘、作意缘、根本依缘、种子依缘。
     ├末那识──四缘──根缘、境缘、作意缘、种子依缘。
     └阿赖耶识──四缘──根缘、境缘、作意缘、种子依缘。


第七讲 三境三界

    第七讲 三境三界
    一 三境三量
    在 <八识规矩颂> 中，有几个以三为名数的名词，如三境、三量、三性、三受、以至于三界等，这些都是唯识学上非常重要的名词。如果不了解其内涵及意义，不但八识规矩颂读不懂，其他的唯识书也读不懂。我们先来探讨这些名词的意义，现在自三境说起。
    三境的境，一般说来，是感官与心识所认识的物件，亦即是眼、耳、鼻、舌、身、意六识，所缘虑了别的色、声、香、味、触、法六境。六境又称六尘，这即是我人所认识的客观世界。但在唯识学上，不以此客观世界是识外之境，而是八识变现的相分。唯识家以八识变现尘境性质的不同，而分为三类境，即是性境、独影境、带质境。
    原来一切有情，各有八识，而一切识，皆为能变。八识变现的方式有两类，一是因缘变，一是分别变。所谓因缘变，是能缘的心，任运而起 (任由因缘，非由作意筹度，称因缘变) ，其所变现的相分，是实种所生 (不与见分同种生起) 。分别变者，是随著心识分别势力而变现 (其变现的相分，不是实种所生，是随著见分种子生起) 。其所变之境，也就是八识的相分。前五识、第八识的相分，都是因缘变； 第六识的独散意识 (不包括五俱意识) 的相分，和第七识的相分，都是分别变。因缘变所变的相分，是性境； 分别变所变的相分，是带质境或独影境。兹分述三境如下：
    一、性境之性，是‘实’的意思，亦可说是现前的实境。性境是实种（色法种子）所生，是以因缘变而变现，不是随第七识的‘非量’认知，或第六识的分别心幻化假设，亦不是已落谢的六尘影子。所以在唯识学上，性境有三个条件：
    1、是实种所生： 前五识的相分，第六识五俱意识的相分，第八识的相分，所缘的全是色法，都是实种所生。
    2、有实体之用： 色法有质碍性，有其实用，
    3、现量所证： 现量有三个条件，一者现前显现，二者非构思所成，三者不是在错 乱情形下所见。
    玄奘大师有偈子曰 ：‘性境不随心，独影唯随见，带质通情本，性种等随应。’不随心者，是此境不随著第六识的分别心而改变其本质。
    二、独影境，独者简别于本质； 影者影像，即是相分，合而言之，就是没有本质的相分。这是能缘之心的虚妄分别而变起之境，它没有本质，仅为影像。如第六意识虚妄分别、以想像力变起龟毛、兔角的幻影。独影境不是色法实种所生，而是第六识见分的一部分，所以它是随心（第六识见分）生起。此境有三种随心： 一者性随心，谓境与能缘之心同一性，二者种随心，谓境 (相分) 与能缘之心 (见分) 由同一种子所生。三者系随心，谓种与能缘之心同一界系。
    三、带质境： 带质境即是此境兼带本质。能缘之心缘所缘之境，其相分是实种所生，有其所依的本质，而不能如实的为见分所认知者。如第七识之见分，缘第八识的见分（以第八识的见分为其相分），为常、一、主宰的自我，第八识见分不是自我，而是一种错误的认知，此称为‘真带质’，所谓‘以心缘心真带质，中间相分两头生’。又如第六识缘草绳误为是蛇，草绳固有其本质，但并不是蛇，这也是一种错误的认知。此称作 ：‘以心缘色似带质，中间相分一头生。]
    其次再探讨三量，三量，是现量、比量、非量。量是认识、知识，也是测量的准绳。如以斗量米，以尺量布，以至于以秤量物。唯识学立有三量，是明心识所具的量度。在我人的心识活动中，能认识的作用是识，所认识的物件是境，在此能认识与所认识之间，心识是能量，所认识之境是所量，此能所之间，有识量的生起。如贩布者不用尺量，则不知长度，吾人心识认识外境，如果没有心识的计虑量度，则不知此境是黑是白，是圆是方，可见识量在认识作用上的重要性。以能量量所量，所得之果曰量果──知识。识之量度有三种，随因的不同，其果亦有差别，即是，即现量、比量、非量。分述如下：
    一、现量： 现量是能缘之心，量所缘之境，不起分别计度所获之量果。但现量之境，要具备三个条件，即一者是现在，以简别于过去或未来。二者心识认识的物件必须要显现出来，亦即必须是现行位之法，在种子位不能成为现量。三者现有，在能所位上，即能量之心与所量之境，二者俱是明白现前，和合俱有。
    二、比量： 心识所量度的物件，没有呈现在前，但可藉著知识经验，推测比度而获致量果。如见山上有烟，推知该处必有火； 见墙外有双角，推知墙外有牛。
    三、非量： 此是一种错误的认知，即是于所缘之境，以错觉之心错为分别所获致之量果，如见绳以为是蛇，见骡误认为马，都属于非量。
    八识缘境，前五识量度之境，是根尘相对的而生识的直接感觉，此时无分别心，不杂名言，所以是现量。例如眼识缘色，唯缘青黄赤白四实色，不缘长短方圆之假色、及取舍伸屈之形色。但当五俱意识生起，有了分别，就堕入比量或非量了。第六识通于三量，在五俱意识初起刹那，也是现量，第二念就有了分别，即是比量或非量。第七识唯缘第八识的见分执为自我，唯是非量。第八识缘根身、器界、种子，唯是现量。
    二 三性三受
    在唯识学上，三性有两种，一者是称为‘三自性’的三性，即遍计所执性、依他起性、圆成实性。一者是善、恶、无记的三性，我们此处所讨论的，是善、恶、无记的三性。
    三性，是以善、不善等的性质，分一切诸法为善、不善、无记等三性。兹分述如下：
    一、善： 善是能顺益此世、他世之法，其定义是指能于现在世、未来世中，给与自他利益者。善与恶，都有理、事之分，理是分析善恶的性质，事是说明善恶的行为。先以善来说，在理的一面， <俱舍论> 十三，把善分为四种，一者胜义善，二者自性善， 三者相应善， 四者等起善。在事的一面来说，修唯识行，持五戒、行十善，是基本的行持。十善是：
    1、不杀生，进而行放生、救生、护生。
    2、不偷盗，进而行施舍，财施、法施、无畏施。
    3、不邪淫，进而修梵（清净）行，出家人则完全断淫。
    4、不妄言，进而说诚实语。
    5、不绮语，进而说质直语。
    6、不两舌，进而说调解语。
    7、不恶口，进而说柔软语。
    8、不贪，进而修不净观，以对治贪欲。
    9、不嗔，进而修慈悲观，大慈与一切众生乐，大悲拔一切众生苦。
    10、不痴，进而修因缘观。
    二、不善： 不善又称为恶，指其能违损此世他世之法。 <成唯识论> 中称：‘违损此世、他世为恶。] <俱舍论> 十三，把恶也分为四种，即一者胜义不善，二者自性不善，三者相应不善，四者等起不善。在事相一面，与十善相对者即是十恶。十恶就是杀生、偷盗、邪淫、妄言、绮语、两舌、恶口、贪婪、嗔恚、愚痴。
    三、无记： 非善非不善，不能记为善，不能记为恶，故称无记。
    三受之受，即五蕴中色、受、想、行、识的受蕴，也是心所有法五遍行心所中的受心所。受者领纳之义，也就是现代人所说的感受。 <成唯识论> 曰：‘受谓领纳顺违境相为性，起爱为业，能起合离二非欲故。’这在 <大乘广五蕴论> 说的更明白一点：‘云何受蕴，受有二种，谓乐受、苦受、不苦不乐受。乐受者，谓此灭时，有和合欲； 苦受者，谓此生时，有乖离欲； 不苦不乐受者，谓无二欲。无二欲者，谓无二和合及乖离欲，受谓识之领纳。]
    受也是‘十二缘生’ 中第七支‘触缘受、受缘爱’的受，所以 <缘起经> 中说，‘受有三种，谓乐受、苦不苦不乐受。’受以领纳为性，领纳、就是感受外境。受所领纳的外境，有顺益境，有违损境，有顺违俱非境。缘顺益境，就是乐受； 缘违损境，就是苦受；缘顺违俱非境，就是中容受、此亦称舍受。对于乐受有‘和合欲’，舍不得离开，对于苦受有‘乖离欲’，避之唯恐不及。对于非苦非乐的中容受，既无和合欲，亦无乖离。
    受是主观的感觉，苦乐是比较而来，没有一定标准。譬如穷人在烈日下挖土作工，以能有树荫蔽日为乐，富人在大厦中吹风品茗，以未装冷气为苦，可见苦乐不能以客观标准来衡量。不过苦乐之受，一般说是与前五识相应，这是生理上的感觉，忧喜之受，是与第六识相应的受，这是心理上相应的受。譬如儿子联考题名，分发国立的名大学，当然喜在心头； 若爱妻罹患重病，朝不保夕，难免忧心不已。三受加上忧喜二受，就称为五受了。
    三 三界九地
    三界，即欲界、色界、无色界，这是六道众生所依托生存的环境，是有情业力招感的依报。 <显扬圣教论> 上称：‘界有二种，一、欲等三界。二、三千世界。欲等三界者，一、欲界，谓未离欲地杂染烦恼诸蕴差别； 二、色界，谓己离欲地杂染烦恼差别； 三、无色界，谓离色、欲地杂染烦恼差别。、、、、、、]
    大致说来，欲界、是具有淫欲、情欲、色欲、食欲等有情所居的世界。欲界的范围，上自第六他化自在天，中包括人界之四大洲，下至无间地狱等二十处； 此界男女参居，多诸染欲，故称欲界。色界，色是变碍或示现之义，这是远离欲界淫、食二欲、而仍有清净色质等有情所居的世界。此界在欲界上，无有欲染，亦无女形，此界众生皆由化生。其所居宫室苑囿，壮丽高大，系由色之化生，一切均殊妙精好，以其尚有色质，故称色界。无色界者，此界无有色身，无淫、食二欲，无宫殿、国土及一切物质，唯以心识住于深妙之禅定，故称无色界，这只是一个精神存在的世界。
    照佛经上说，三界有九地、二十八天，兹列表说明如下：

    ┌──欲界──五趣杂居地
    │ ┌─离生喜乐地
    ├──色界┼─定生喜乐地
    │ └─离喜妙乐地
三界┤ └─舍念清净地
    │ ┌─空无边处地
    └─无色界┼─识无边处地
     ├─无所有处地
     └─非想非非想处地
    三界二十八天，为欲界六天，色界十八天，无色界四天。其名称为：
    欲界六天： 四天王天、仞利天、夜摩天、兜率天、化乐天、他化自在天。色界天： 初禅天三天，为梵众天、梵辅天、大梵天。
    二禅天三天，为少天、无量光天、光音天。
    三禅天三天，为少净天、无量净天、遍净天。
    四禅天九天，为无云天、福生天、广果天、无烦天、无热天、善见天、善现天、色究竟天、无想天。
    附录： 相关名相表解
    一、三境： 八识缘境，能缘的是见分，所缘的是相分，此相分即是境。而此境就其性质、分为三种，即性境、独影境、带质境。

     ┌──性境：性境就是实境，是实种所生，事实上就是色声香味触五
     │ 种物质实境。
三境─┼──独影境： 这是没有本质的影像，是第六识虚妄分别想像出来的
│ 影子。
     └──带质境： 这是有本质的相分，而为见分所错误认知者。

    二、三量： 量是测量的标准，引伸为认识、知识，唯识学上立为心识缘境的量度准则。 心识缘境，有三种量度，即现量、比量、非量。

     ┌──现量：心识缘境，缘当下性境，没有分别，不带名言，此称现
│ 量。
三量─┼──比量： 心识缘境，以知识、经验推测比度所获的量果。
     └──非量： 心识缘境，对所缘境认知谬误所获的量果。

    三、三性： 分为善、不善、无记三种。

     ┌──善性： 于现在世未来世、于自他顺益者。
三性─┼──不善性： 于现在世未来世、于自他违损者。
     └──无记性： 非善非不善，不能记为善、亦不能记为恶者。

    四、三受： 受是领纳作用，有苦、乐、舍三受，如加忧喜二受，就成为五受了。

     ┌──一苦受： 领纳违损境之谓。
三受─┼──乐受： 领纳顺益境之谓。
     └──舍受： 领纳顺违俱非境之谓。


第八讲 修行五位

    第八讲 修行五位
    一 修行五位
    八识规矩颂讲座，已讲过七次，今天是第八讲。八周以来，我们讲过八识、心所、种子、四分、四缘五果，三境三量等等，今天要讲修行五位。诸位或问，十二次讲座已过了三分之二，何以还没有讲到八识规矩颂的颂文？ 原因是这样，譬如建房子，我们先要把砖瓦木石准备齐全，材料不齐全不能动工，不然，中途势将因材料不齐而停顿。我们前八次讲的材料，都是准备后四次使用的，下一次起，即将次第讲到前五识、第六识、第七识及第八识的颂文。现在我们开始讲五位修行。
    学唯识，目的不是在增加知识，而是学得唯识后，依法修行。也许，我们的修持不够，尚不能修止修观，但在我们在了解得八识、五十一心所之后，我们于起心动意之时，常常省察我们的心识，我一念慈悲的善心生起，是那一个心王、心所的作用？ 我们一念嗔恚心，一念妒嫉心生起，又是那个心王、心所发生的作用？ 所谓‘究几于心意初动之时’，把唯识用在日常生活上，这就是修行。我人的前六识，一向是攀缘外境，与五欲六尘打交道，我们从来不曾想到过省察内心，观照内心。修行无非是修正身、语、意三者的行为，但三者以心识为主导，正本清源，我们要由修心做起，因此省察与观照我们的心识，就是修行的基础。现在我们开始讲修行五位。
    照唯识学的修行理论来说，修唯识行，要经过五个阶段，称为‘唯识五位’，五位是资粮位、加行位、通达位、修习位、究竟位。分述如下：
    一、资粮位： 这在五位修行中，只算是方便道，是修唯识行的初位。称资粮者，譬如有人远行，要先准备下资财粮食，以备途中所需； 修唯识行，也要先积聚下相当的智慧和福德，作为修行的资粮。智慧福德的资粮如何积聚呢？ 就是发菩提心，行菩萨道，修六波罗密、四摄法、四无量心、三十七道品。
    修此位的菩萨，是以四种‘胜因缘力’而开始修行的。即一者因力，就是具备有大乘种性。二者善友力，就是受善知识朋友的影响。三者作意力，即有修唯识行的决心。四者资粮力，是发心行菩萨道积聚下的智慧福德。
    二、加行位： 修行菩萨在资粮位所修的，如行菩萨道、六度四摄等，是福德重于智慧。而进入加行位要修的，是智慧重于福德。所以在此位的菩萨，要修四寻思观、四如实观，以伏断分别起和俱生起的所知、烦恼二障。四寻思观，是名寻思观，事寻思观，自性寻思观，差别寻思观。名是能诠的名言，事是所诠的事相、自性是事相的体性，差别是名事上的分齐。其内容是：
    1、名寻思观： 名是一切事物的名称，名是‘假名施设’，假为安立的，它虽代表一种事物，但并不是事物的本身。僧肇法师曰 ：‘以名求物，物无当名之实；以物求名，名无当物之功。’又曰：‘物不即名而就实，名不即物而履真。]人不了此理，执名求实，生出种种烦恼。寻思此义，以伏断执障。
    2、事寻思观： 事者事物，是见闻觉知的物件。如五蕴、十二处、十八界，以至于山河大地，人牛马羊。但一切事物，都是因缘的组合，并没有事物的本体。我人妄执一切为实有，以名推求，对事执著，也就成为种种执著与烦恼。
    3、自性寻思观： 世间万有，皆是仗因托缘生起的假法，其本身没有实在的体性。自唯识学上说，万法唯识所现，离识非有，由此可知名、事、自性皆空，此即自性寻思观。由此寻思，以伏断执著和烦恼。
    4、差别寻思观： 名称与事物，各有种种差别，名如名身句身，事如长短方圆，一一法上，各有差别相，唯此差别，皆是一时现象，假有实无，由此寻思，伏断执障和烦恼。
    以上四观，是唯识止观的最初入门观法，由此观察，可生四如实智。即是：
    1、由名寻思观所引生的如实智。
    2、由事寻思观所引生的如实智。
    3、由自性寻思观所引生的如实智。
    4、由差别寻思观所引生的如实智。
    如实智，是如实的了知诸法实相之智。由前述四观而引生四智，以此进入唯识实性。而修四观，引生四智，要经过暖位、顶位、忍位、世第一位四位。四位之中，前二位修四寻思观，观所取之境空，后二位修四如实智，观能取之境与所取之智空。
    三、通达位： 修唯识行，历经资粮、加行二位，执障伏断，智慧发出，已能体会出真如实相的境界，这时进入通达位，已算是‘见道’。所见之道，即是由二空所显的真如。此处又有真见道和相见道之分。真见道，是在此位起无漏的根本智，证见二空真如，断二种障。然后更起后得智，以了知一切差别相上的如幻俗事。见道菩萨，就是以此二智──根本智和后得智，缘真俗二境。
    四、修道位： 在资粮位中，修十住、十行、十回向三十心； 在加行位修四寻思观，得四如实智，在通达位已‘见道’，体会得唯识实相──二空真如。在见道位，已入十地中初地入心。十地由初地到十地，每地分入、住、出三心，故在此修道位，则是由初地住心、到十地出心，十地出心又称满心。在此阶段，数数修习无分别智，舍断烦恼所知二障种子，到十地满心，已是妙觉菩萨了。
    五、究竟位： 究竟位就是佛位，诸漏永尽，清净圆明，转八识成四智──转前五识为成所作智，转第六识为妙观察智，转第七识为平等性智，转第八识为大圆镜智，这时所证得大菩提与大涅槃二种胜果，便是圆满的佛果了。
    二 四十一阶
    大乘因位菩萨，修唯识行，要经过三大阿僧祗劫的长时，断我、法二执，烦恼所知二障，证得我法二空，而后才能证得大菩提与大涅槃二胜果──就是佛果。唯在修行过程中，要经过五位、四十一阶，才到达佛的果位。五位已如前述，四十一阶是十住、十行、十回向、十地。兹分述如下
    一、十住： 十住位，是修菩萨行者，在此位安立其心，唯于六度万行等，尚未殊胜，故曰住。在 <华严经> ，把修行阶位分为五十二阶，在十住之前，尚有‘十信]十个阶位，在妙觉菩萨之前，尚有等觉菩萨一个阶位。唐代慈恩大师窥基，把十信摄入十住的发心住，把等觉摄入十地的法云地，这样就成了四十一阶了。十住的名称是：
    1、发心住： 此位菩萨，发菩提心，修十信行，于六度等，尚未殊胜，曰发心住。
    2、治地住： 此位菩萨，净修身口意三业，大悲一切有情，有如大地能生万物。
    3、修行住： 此位菩萨，修胜理观，起六度妙行，称修行住。
    4、生贵住： 此位菩萨，依佛法教化，如圣贤生正法中，种性高贵，曰生贵住。
    5、方便住： 此位菩萨，所修善根，皆为救济有情，利益众生，曰方便住。
    6、正心住： 此位菩萨，于一切毁誉，心定不动，曰正心住。
    7、不退住： 此位菩萨，于所闻之法，心坚定而不退转，曰不退住。
    8、童真住： 此位菩萨，三业清净，不受世间法之染著，曰童真住。
    9、法王子住： 此位菩萨，解悟法王之法，有如将袭法王的王子，曰法王子住。
    10、灌顶住： 此位菩萨，如法修行，有如王子之堪受王位，曰灌顶住。
    二、十行： 修行菩萨，于此位修六度万行，逐渐殊胜，故称曰行。十行是：
    1、欢喜行： 此位菩萨，修布施行，施舍一切，令见者欢喜，曰欢喜行。
    2、饶益行： 此位菩萨，持三聚净戒，不染五欲，饶益有情，曰饶益行。
    3、无恚行： 此位菩萨，修忍辱行，忍受怨敌，曰无恚行。
    4、无尽行： 此位菩萨，修精尽行，受诸剧苦，精进不懈，曰无尽行。
    5、离痴乱行： 此位菩萨，常住禅定，于世出世法，无有痴乱，曰无痴乱行。
    6、善现行： 此位菩萨，修智慧行，悟入诸法皆无自性，不受系缚，不受染著，随机教化众生，曰善现行。
    7、无著行： 此位菩萨，修方便行，对于空有两端，通达无碍，一无所著。
    8、尊重行： 此位菩萨，修愿力行，尊重善根智慧，增益自利利他，曰尊重行。
    9、善法行： 此位菩萨，修力行，成就诸善慧法，除众生烦恼，曰善法行。
    10、真实行： 此位菩萨，修智行，成就诚实了悟，言行相应，日真实行。
    三、十回向： 菩萨修至此位，上为求菩提，下为度众生，以所修之善根，回向法界，故立十回向之名。十回向名称如下：
    1、救护众生离众生相回： 此位菩萨修六度四摄，救济一切有情，而怨亲平等。
    2、不坏回向： 此位菩萨，于三宝发不坏信，以己善根，回向有情。
    3、等诸佛回向： 此位菩萨，学三世诸佛悲智，与诸佛等，回向有情。
    4、至一切处回向： 此位菩萨，以所修善根，供养三世诸佛，利益一切众生。
    5、无尽功德藏回向： 此位菩萨于诸佛及一切众生所有善根，悉皆随喜，而回向之、
    6、随顺一切坚固善根回向： 此位菩萨，施舍一切，以身代众生苦，而回向之。
    7、等心随顺一切众生回向： 此位菩萨，以所修善根，回向一切众生。
    8、如相回向： 此位菩萨，以正智正念，随顺真如平等之相，而回向之。
    9、无著无缚解脱心回向： 此位菩萨，以无缚无著解脱之心，而回向之。
    10、 法界无量回回： 此位菩萨，说法利生，庄严世界，此善根回向，量同法界。
    四、十地： 由初地入心，至十地满心，要修两大阿僧祗劫之久，如下节所述。
    三 菩萨十地
    菩萨修行，进入见道位，已算是登地菩萨，唯还是在十地的初地入心修行。到了修习位，则是由初地住心，修至十地满心，。十地满心，已经是妙觉菩萨的地位，在此位中，以金刚心、无间道，便证得转依──转八识成四智，就是究竟佛果了。
    十地，是修唯识行最后十个阶位，十地的名称是：
    一、欢喜地： 始入见道位，见证我法二空，能自利利他，生大欢喜，曰欢喜地。
    二、离垢地： 修行菩萨，在此地时，一切戒垢，无论粗细，尽皆远离，名离垢地。
    三、发光地： 此地菩萨，成就胜定，能发无边妙慧，曰发光地。
    四、炎慧地： 此地菩萨，得最胜定，以智慧火，烧灭烦恼薪，曰炎慧地。
    五、极难胜地： 此地菩萨，其根本智与后得智，互相违返──即根本智无分别，而后得智辨析世俗诸法则有分别，在此地使之融摄，此事甚难，故曰极难胜地。
    六、现前地： 此地菩萨，观诸法缘起，以胜智力，引发最胜般若现前，故曰现前地。
    七、远行地： 此地菩萨，修迥向方便及济拔方便，以已所作一切善法，回向广大菩提，此即大智； 以种种方便九济拔众生，此即大悲。有此士悲智二种方便，故能远行，曰远行地。
    八、不动地： 此地菩萨，其根本无分别智，任运相续，不用加行力，亦能现前，不为一切烦恼、及一切境界所动，称不动地。
    九、善慧地： 此地菩萨，成就微妙四无碍智，此智慧微妙殊胜，故曰善慧地。
    十、法云地： 此地菩萨，总缘一切法智，具足自在，能藏众定慧功德，能隐覆无边惑障，犹如云荫作大法雨，称法云地。
    附录： 相关名相表解
    一、菩萨修行五位： 大乘因位菩萨，修唯识行，要经过三大阿僧祗劫的长时，断得烦恼、所知二障，证得我二空，才获致大菩提与大涅槃二胜果，这其间，其经过五位、
    四十一阶，如下表所示：

     ┌──资粮位─────────────┐
     ├──加行位─────────────┼方便道
菩萨修行五位┼──通达位──又名见道位──────┤
     ├──修习位──又名修道位──────┼ 无漏圣道
     └──究竟位──即证得佛果之位────┴ 佛果

     ┌──十住 (摄十信) ─────────┐
     ├──十行──────────────┼ 三贤位──凡
四十一阶─┼──十回向─────────────┤
     ├──十地──────因───────┤
     └──妙觉──────果───────┴───── 圣
    二、四加行位： 修行菩萨，进入加行位，修四寻思观，生四如实智，这其间，要经过暖位、顶位、忍位、世第一四位，于前二位修四寻思观，于后二位，修四如实智，如下表所示：

     ┌──暖位────┐
四加行位─┼──顶位────┼四寻思观────────────-有漏
     ├──忍位────┤ ──所取之境空
     └──世第一位──┴四如实智──所取之境与能取之智空-无漏


第九讲 前五识颂

    第九讲 前五识颂
    一 首颂诠释
    <八识规矩颂> 讲记，为了解释颂文中许多专用名词，占用了八次的时间。但是以往的时间并没有浪费，如果我们已经了解讲过的名词，现在来读颂文，大半的涵义都能读得懂了。由这一讲开始，进入十二首颂文的讲解，现在先讲前五识颂。
    八识规矩颂颂文的组织，十二首颂文分为四章，分别为前五识颂、第六识颂、第七识颂、第八识颂。每章颂文三首十二句，前八句颂凡夫位，后四句颂圣贤位。现在来分析前五识颂，在凡夫位的八句颂文中，前四句分为缘境、识量、性别、界地、相应五个主题，后四句分为依缘、业用两个主题； 在圣贤位的四句颂文中，包括智力、转依、果德三个主题。现在先看前四句颂文：
    性境现量通三性，眼耳身三二地居，遍行别境善十一，中二大八贪嗔痴。
    在首颂四句颂文中，包括缘境、识量、性别、界地、相应五个主题，分述如下：
    一、缘境： 性境，是三境之一。经云：‘法不孤起’ ，又说：‘心因境有’。心识生起，要因缘具足，而境，就是四缘中的所缘缘。境有三类，即性境、独影境、带质境，前五识所缘的，只是性境，不缘独影境和带质境。因为前五识是感觉器官，只缘‘色法’，不缘‘心法’。色法，是第八识中实种所生，有实体之相，且得境之自相者。此如镜之鉴物，故为性境。
    二、识量： 量指三量──现量、比量、非量。五识缘境，是根、境对照而生识 (即五遍行心所的触，触者三和。) 这是直接感觉，初一刹那，无筹度心，不带名言，所以是现量而非比量； 到堕入第二念，种种分别生起 (即第六识五俱意识生起)，这时就有比量和非量了。
    三、性别： 性别是指善、恶、无记三性，心王生起，与善心所相应者，就是善； 与烦恼心所相应者，就是恶； 与善或烦恼心所均不相应者，就是无记。五识是感觉器，本来没有善恶，但以第六识的五俱意识与之俱起，五俱意识随著前五识缘境而了解分别，因而善或烦恼心所与之相应，或善、烦恼不起一而是无记，这时前五识随著第六识的行动，亦就通于三性了。以上三项，就是首句‘性境现量通三性’的解释。
    四、界地： 界地，指的是三界九地。三界，即欲界、色界、无色界； 九地，是欲界的五趣杂居地； 色界的离生喜乐地，定生喜乐地，离喜妙乐地，舍念清净地； 无色界的空无边处地，识无边处地，无所有处地，非想非非想处地。我们所依托、生存的世界，是欲界、五趣杂居地。欲界的范围，上有六欲天──四天王天、仞利天、夜摩天、兜率天、化乐天、大梵天，中有人界四洲，下至无间地狱。生活在欲界的众生，即所谓五趣──天趣、人趣、畜生趣、饿鬼趣，地狱趣。五趣即是五道，如果再加上阿修罗道，就成为六道了。
    颂文第二句‘眼耳鼻三二地居’ ，所谓二地，是指欲界的五趣杂居地，及色界的杂生喜乐地。杂生喜乐地的范围，初禅三天皆属之。欲界有段食，除眼、耳、身三识外，尚须以鼻识嗅香，以舌识尝味，所以五识俱全； 若至色界初禅天的离生喜乐地，初禅天人，以禅悦为食，不食段食，故鼻舌两识无用，故只有眼、耳、身三识，所以称眼、耳、身三识‘二地居’，居是止的意思，眼、耳、身三识，亦只以初禅天为止，若到二禅天的定生喜乐地，其静虑之心，专注于第六识间，前五识都不现起（此界众生化生，有微妙色身，为庄严身相，五根完整，唯不起用。）所以欲界众生，八识具备； 色界初禅的离生喜乐地，前五识的鼻、舌二识不起作用，只有八识中的六识； 到二禅天，眼、耳、身三识亦不起用、、、、
    五、相应： 心王生起，必有心所与之下相应，而与前五识相应的心所，共有三十四个，它们的名称是： 五遍行心所，五别境心所，十一个善心所，两个中随烦恼心所，八个大随烦恼心所，还有根本烦恼中的贪、嗔、痴三个心所。
    遍行心所，是遍及于一切心、一切时、一切性、一切地，所以是必然生起的，前五识与五俱意识同起，而与意识相应的五别境心所，亦导引前五识对所缘之境、发起希望、决定、明记、专注、和抉择的作用。前五识既然通于三性，所以有时与善性相应，故十一个善心所全俱； 有时与不善相应，所以根本烦恼中贪、嗔、痴，中随烦恼的无惭无愧，大随烦恼全部，亦参与前五识的活动。
    二 次颂诠释
    前五识颂的次颂，有两个主题，一者是依缘，二者是业用，我们且看颂文：
    五识同依净色根，九缘七八好相邻，合三离二观尘世，愚者难分识与根。
    以上颂文，前两句说的是五识的依缘，后两句说的是五识的体用，分述如下：
    一、依缘： 五识依于五根生起，随根立名，根名眼、耳、，鼻、舌、身五根，识亦名眼、耳、鼻、舌、身五识，而根有两种，一者外根，一者内根。外根不能生识，生识的是内根。外根又名扶根尘，就是我人视觉可见的眼睛、耳朵、鼻子、舌头和身体。 <楞严经> 云：‘眼如葡萄朵，耳如新卷叶，鼻如双垂瓜，舌如初偃月，身如腰鼓类。’此称为扶根尘者，以其为扶持内根的尘法。内根又名净色根，亦称为胜义根。佛经上说，内根为清净四大所成，质净而细，犹如琉璃，肉眼不可见，唯佛眼天眼可见之。不过若以现代科学知识来看，内根就是五种感觉器官的神经纤维，和大脑中的神经细胞。五种感觉器官生起五感觉 (识) ，而由第六识了解分别。
    心识生起，必仗因托缘，生识之缘共有九种，而各识全缺则不相同，此已在第六讲中叙述。眼识生起须九缘具足，此处再加以说明如下：
    1、根缘： 眼识以眼根生起的助缘，如眼根损坏，则眼识不能生起。
    2、境缘： 眼识以色境为所缘缘，无境不能生识。此即心法四缘之一。
    3、空缘： 眼识是离中取境，识与境之间必须保持距离 (空间) ，否则识不生起。
    4、明缘： 眼识生起须以光明为助缘，否则不能了别。
    5、作意缘： 眼识了境，须以作意力为助缘，若无作意力，则视而不见。
    6、种子缘： 种子为眼识生起的亲因缘，此为四缘中的第一种缘。
    7、分别依缘： 第六识的作用是了解分别，故眼识以第六识为分别依缘。
    8、染净依缘： 第七识是意识之根，其染净亦影响前五识，故眼识以此为染净依。
    9、根本依缘： 根本识是第八识，此识是诸识根本，故眼识以此为根本依。
    二、业用： 颂文‘合三离二观尘世’句，指前五识之于境界，鼻、舌、身三识是合中取境，而眼、耳二识是离中取境。
    观尘世三字，尘是五尘，亦称五境，即是色、声、香、味、触五种境界。尘有染污的意思，以其能染污我人的心识，故称五尘。五尘是五根所照，为五识所缘。五识缘尘世之境，由于具缘多少的不同，就有了识取境合离的不同。如眼识生起要九缘，耳识不需要光明，只须七缘，这二者都是离中取境。鼻、舌、身三识取境时，必须根、境相合，识□发生作用，这三者是合中取境。
    [愚者难分识与根’ 一句，愚者、指当时的一部分二乘行者，因为分辨不出根与识的作用，就出现了一部分‘根见家]， 以为了境者是根； 另一部分识见家，主张了境者是识。当时为了‘根见’、‘识见’，曾引发过一阵诤论。根见识见，看起来是小问题，但这牵涉到哲学上‘唯心’、‘唯物’，就成为根本上的大问题了。
    三 末颂诠释
    前五识颂的第三颂，是颂前五识依无漏种子，转识成智──由有漏的前五识，转成无漏的成所作智。颂文全文是：
    变相观空唯后得，果中犹自不诠真，圆明初发成无漏，三类分身息苦轮。
    在这四句颂文中，包括有三个主题，即是智力、转依、果德，兹分述如下：
    一、智力： 修唯识行，在资粮位，历经十住、十行、十回向三十阶上，广修六度万行，储备福慧资粮，圆满顺解脱分的善根。进而于加行位，修四寻思观，得四如实智，此智又名加行智，由此更勇猛精进，至通达位，入十地的初地欢喜地 (极喜地) ，至此远离遍计所执的能取所取，亦即是证得所取之境空，能观之智空，证此二空之智，无能缘所缘之差别，名无分别智，亦称根本根，根本智是直契真如之智。由证得根本智后，再起分别一切差别相的智慧，此称分别智，亦称后得智。见道位的菩萨，就是以此根本、后得二智，缘真俗二境。根本智挟带本质，没有相分，心无分别，亦没有见分； 而后得智托质变相，似有相分，起认识 (分别) 作用，似有见分，即缘真如，亦不亲证，只能变我空的影像而审观之，这就是[变相观空唯得’。
    这后得智，在因、果二位都能证得。不过前五识与第八识，是联带相生的，因为五根是第八识所缘的相分，而五识是依五根而生起活动，所以在第八识未转识成智前，前五识不能单独转识成智，必须到十地满心，金刚无间道时，第八识转为大圆镜智，前五识同时转为成所作智。此即所谓：‘六七因中转，五八果上圆。’但已转为成所作智的前五识，在佛果位中仍不能亲契真如，何以故呢？ 当知五识依五根而起，缘现量、性境，但它只能观察诸法的事相，不能体悟诸法的理性。在因中如此，在果上亦是如此，所以说它‘果中犹自不诠真’。诠，在此处作[证得’讲。
    二、转依： 第三句颂文：‘圆明初发成无漏’ ，此是指第八识转为大圆镜初一刹那，前五识也同时转为无漏的成所作智。因为前五识是依五根而现起，而五根又是第八所变的相分。在能变现的第八识未转成无漏以前，其所变现的五根相分，当然不可能先变为无漏。所以必须在第八识圆明初发，五根五识才能转成无漏。至此，与前五识相应的根本烦恼贪、嗔、痴，大八随烦恼，中二随烦恼尽皆舍除，即五遍行心所、五别境心所、善法十一心所，也都转成无漏了。
    三、果德： 五识转为无漏，其所应作的自利事业──所应断应修的，皆已成办，所以名为成所作智。至此，要进一步成办利益一切众生的事业，这是果地的成所作智。为适应净秽国土中众生机宜需要，如来作三类分身，为三界九地、四生六道的众生，息其生死轮迥之苦也。三类分身是：
    1、为适应大乘四加行位菩萨的机宜，示现千丈卢舍那身，宣说地上的十波罗密，令其依法修行，息其变易生死的苦轮。
    2、为适应二乘及凡夫的机宜，示现丈六小化身，为说苦、集、灭、道四谛法门，令其依四谛法修行，息其分段生死的法苦轮。
    3、为适应各类不同的机宜，示现种种化身，随宜说法，令其离苦得乐。如来慈悲，怜愍众生备受众苦，运用方便，化三类分身，为不同的众生，说不同的教法，使得息诸苦轮也。
    附录： 相关名相表解
    一、前五识境、量、性、界等总表：

      ┌─境─性境。
      ├─量─现量。
      ├─三性─通善恶无记三性。
      ├─界地─眼、耳、身三识通欲界五趣杂居地、色界离生喜乐地。
     │ 鼻、舌二识唯通五趣杂居地。
前五识┼─相应心所─遍行五、别境五、善十一、根本烦恼三 (贪、嗔、
     │ 痴)、中随烦恼二、大随烦恼八。
     ├─依缘─眼识九缘、耳识八缘、鼻、舌、身三识七缘。
     ├─业用─眼、耳二识之离中取境，鼻、舌、身三识合中取境。
     ├─断惑─第八识转识成智时，根成无漏，前五识亦转为成所作智。
     └─果用─分为三类化身，教化众生，永息苦轮。


第十讲 第六识颂

    第十讲 第六识颂
    一 首颂诠释
    第六识，在八个识中，是作用最为明显、最强锐的一个。前五种感觉官的见闻觉知，全由第六识来了解分别； 善恶的造作，是非的分辨，美丑的观感，自他的争执，全是第六识的作用。所以，第六识可以说是我人心理活动的综合中心。
    前五识依于五净色根，所依的是色 (物质) 法之根； 第六识依于意根 (第七末那识) ，依的是心 (精神) 法之根。前五识缘色、声、香、味、触五种色境，是现量、性境，第六识缘法境 (宇宙万法) ，通于三境、三量、三性、三受，且于缘法境时，通于过去、现在、未来三时。于此，我们来看第六识颂首颂的颂文：
    三性三量通三境，三界轮时易可知，相应心所五十一，善恶临时分配之。
    在这四句颂文中，包括有五个主题，即是第六识的性别、识量、缘境、界地、相应，现在分别叙述如下：
    一、性别： 性别，指的是善、恶、无记三性。第六识作用范围宽乏，通于善、恶、无记三性，当心识生起，一念济世利人之心生起，十一个善心所与之相应，则为善法； 如一念损人利己之心生起，二十六个烦恼心所与之相应，则为恶法。如独头意识作意筹度，或利人或利己，亦通于善恶，如独头意识任由意念游走，既无有益人群之心，亦无谋己私利之意，就成为无记法。
    二、识量： 识量有三，曰现量、比量、非量，见第七讲。前五量唯是现量，第六识五俱意识初起，第一刹那是现量，第二念即堕入比量。独头意识中的定位意识是现量，梦中意识是非量，散位意识通于三量。
    三、缘境： 心识缘境，境有三类，曰性境、独影境、带质境，见第七讲。前五识唯缘性境，第六识通于三境。以上为首句‘三性三量通三境’的说明。
    四、界地： 界地，是解释‘三界轮时易可知’一句。三界即是欲界、色界、无色界，三界隶有九地，见第七讲。三界是有情业力招感的依报，意识行入相粗显，远非他识可及。虽然前五识能增强意识造业作用，但实际上牵引果报体受报的，仍是由第六识负责。意识通于三界，若造作五趣杂业，则业力寄托的果报体 (第八识) 就落欲果； 若造作四禅定业，果报体即落入色界； 若造作四空定业，则落入无色界。果报识在三界轮回，以造作的业力而定。所以鉴因知果，事先便有迹象可寻，此即是‘三界轮时亦易可知’也。
    五、相应： 此指的是‘王所相应’，即是心王与心所相应的情形。心王有八个，心所有五十一个，在八个心王中，唯一与五十一个心所全体相应的，只有第六识。
    王所相应，并不是心王与全体相应的心所同时生起，而是视临时的情况，一部分心所生起与之相应。如以第六识来说，第六识生起，遍行心所是必然生起的，别境则继遍行心之后，视特殊情况，需要某一心所，某一心所生起。善与烦恼心所，亦视情况需要，如果一念善心生起，十一个善心所与之相应，完成意识所要作的善行。相反的，如果一念不善心生起，则无惭、无愧两个中随烦恼心所，忿、恨、覆、恼、害、嫉、悭七个小随烦恼心所，及根本烦恼的嗔心所，共计十个心所与之相应，视需要而生起。如果意识接触不善和有覆无记境而生起活动，这时根本烦恼中的贪、痴、慢、疑、不正见五个心所，小随烦恼中的谄、害、骄三个心所，和八个大随烦恼心所，一共十六个心所与之相应，视需要而生起，完成意识所要作的恶业、及有覆无记。有覆无记、是无记的一种，其性染污，覆障圣道，染污心识，而其势用力弱，不能引生异熟果，故称有覆无记。至于不善法，以其势用强，可招感异熟果，故不称为有覆无记。
    如果以上善、烦恼心所全不与第六识相应，或相应后退出，这时唯有五遍行心所、五别境心所，与第六识相应。以上善、烦恼两类心所，体性相违，决不能同时生起。至于两类心所自类之间，十一个善心所体性相顺，所以可能同时生起； 至于烦恼心所，是否俱起或不俱起，则不一定，要看当时情形，有的可俱起，如无明 (痴心所) 与八大随烦恼心所，可与一切恶心所俱起； 至于贪与嗔，慢与疑，疑与见，不同时俱起； 十个小随烦恼心所，因为它们互相相望，彼此行相互相乖违，所以不能同时生起。至于两个中随烦恼，仅能与小随烦恼中的忿、恨、恼、嫉、悭、害、骄七个心所同时生起，而不能普遍与一切染心所及有覆无记性相应。至于五遍行、五别境、及四不定心所，本身没有善恶的属性，是随著善、恶、无记三种心性，其体也就成为或善或恶或不定性，所以可以与善、烦恼心所同时生起。
    二 次颂诠释
    第六识的第二首颂文，是：
    性界受三恒转易，根随信等总相连，动身发语独为最，引满能招业力牵。
    这四句颂文中，包括有第六识的行相、业用两个主题，分述如下：
    一、行相： 意识的活动，范围广泛，千头万绪。因此、它随时变易，来应付各种不同的境界。颂文中首句‘性界受三恒转易’，性，是善、恶、无记三性，界是欲界、色界、无色界三界，受是苦受、乐受、舍受三受，或加忧喜二受成为五受。第六识在活动时，有时是善心生起，有时是恶心生起，有时是无记心生起。当善心生起之际，也会忽然转变为不善心或无记心。而不善心生起之际，也会忽然转变为善心或无记心。
    第六识在活动时，欲界众生，有时也会生起色界、无色界之心，如欲界众生修四禅定，在定境中就生起色界之心。若欲界众生修四空定，在定境中就生起无色界心。在定境中是如此，但在出定之后，仍然生起欲界心。色界众生如修四空定，在境中也可生起无色界心，而出定后仍是色界之心。如天台宗的‘一念三千’，我人一念之中具足十法界，所以一念之中也可在三界中转易也。
    受者三受，即苦、乐、无记三受，若加上忧、喜二受，称为五受。这五种受，在第六识活动时也是不断的变易，这要看当时所缘的境而定。因为受是一种领纳作用，其所领纳的是当前的现量境 (忧喜通于三时) ，随著境的转变，苦乐忧喜舍之受、自然也随转变。所谓‘心随境转’，就是这个意思。
    颂文次句‘根随信等总相连’ ，根是六种根本烦恼，随是二十种大、中、小随烦恼，信是十一种善心所。第六识念念生灭，五十一个相应心所，随著心王之性别相应生起。如果识是善性，信等十一个善心所与之相应，如果识是不善或无记性，则贪等烦恼心所、或遍行、别境等心所与之相应。这三性的转易，心王与心所互相牵连，协同造作，造作的后果就是业。
    二、业用： 颂文‘动身发语独为最，引满能招业牵。’由于善、不善、无记心所与第六识相应，造作了善恶之业。而业有三种，称身业、语业、意业。三业之中，以意业为主导，身体的动作，口中的语言，全是受意识的支配。若认真的说，意业是以思心所为主导。思心所要经过三个程式，即是：
    1、审虑思： 尘境当前，思心所继想心所之后，先作一番筹度思量的工作，以审察应如何应付。
    2、决定思： 经过筹度，已有所决定。
    3、动发胜思： 此即是于决定之后，付之于行动。所谓行动，即是由身、语二者去执行。
    于此，若第六识一念起善，则有身语的善行善语； 若一念起恶，则有身语的恶行恶语，身语二者之行为，全是第六识推动引发，第六识作用强锐，所以称它‘动身发语独为最’。
    最后‘引满能招业力牵’ 句，身语意三业，能招引满二种业果，牵引八识受生死轮回之苦。引业、是起始之业，就是引导牵引。与第六识相应的思心所、造作的强有力的善恶业，熏习所成的业种子，含藏在第八阿赖耶识中，到了业力成熟时，能牵引第八识在五趣 (或六道) 中，感受一期相续不断苦乐总报体──即是在某一道中的一期生命体。满业、可说是业的究竟，这是缺乏推理作用、又不能发润的前五识相应的思心所所造的善恶业，此业亦是由第六识所引起，但不如引业之思强而有力，故其造成的业力非常薄弱，此种薄弱业力熏成的业种子，含藏在阿赖耶识中，到了业力成熟时，能招感五趣总报的别报。
    总报，是众生生命体之报，如生于人趣，则彼此之人类，受同一人界之果报，名为总报； 如同为人趣，六根有好丑，寿命有长短，种种差别，名为别报。于此附带解释正报依报，众生的身心──生命体，是正报； 生命体所依止的身外之物，如世界国土，房舍器物，衣服饮食，是依报。
    三 末颂诠释
    第六识颂的第三首、即末四句颂文，是颂第六识依无漏种子，转识成智的修习程式。这首颂文是
    发起初心欢喜地，俱生犹自现缠眠，远行地后纯无漏，观察圆明照大千。
    在这四句颂文中，也有两个主题，一者智力，二者转依。分述如下：
    一、智力： 智力，是以修习无漏之智，证得出世圣果。首句一颂文中的‘初心’、是在修习过程中，历十住、十行、十回向位，初登十地中的初地入心，至此始入见道位，己断分别起的我法二执，能自利利他，生大欢喜，故初地名欢喜地。入欢喜地，妙观察智已开始发起，故颂文曰：‘发起初心欢喜地’。
    唯此时分别起的我法二执虽断，而俱生起的我法二执犹未能断除，所以在入观位的时候，俱生起的我法二执不起，但在出观位时，有漏识依然生起，还不能做到无漏一味相续，这俱生起的我法二执，犹仍不时现前，故称‘俱生犹自现缠眠]。缠眠，为烦恼的异名，亦作现行解，眠即随眠，又称种子，俱生二执种子现行，即‘现缠眠’也。以俱生二执未断，所以第六识所转的妙观察智，仍是下品的妙观察智。古德云： 初地下品转，八地中品转，等觉上品转。
    二、转依： 此指‘远行地后成无漏，观察圆明照大千。’远行地，即十地中的第七地，远行地后，指的是八九十地，修行至八地，转为中品妙观察智，犹未至最极，直到十地满心，方转为上品，故曰圆明。在十地满心金刚喻定现前时，大圆镜智现起，这就是究竟位。在究竟位中，诸漏永尽，性净圆明，到此位时，第六识方纯净无漏，即转成妙观察智，而圆明普照于大千世界矣。
    附录： 相关名相表解
    一、第六识境、量、性、界等总表：

     ┌──境──通于性境、带质境、独影境三境。
     ├──量──通于现量、比量、非量三量。
     ├──三性──通于善、恶、无记三性。
     ├──界地──通于欲界、色界、无色界三界。
     ├──相应心所──五十一个心所全部与之相应。
     ├──依缘──依境、作意、染净依、根本依、种子依五缘。
第六识─┼──体相──随念分别、计度分别、自性分别。
     ├──业用──动身发语，造引满美，招轮回三界果报，三性、五
受变易。
     ├──断惑──资粮位中，渐伏我、法二执种子现行。
     │ 见道位中，分别起的我法二执种子断灭，在初地中
│ 转为下品妙观察智
     │ 修道位中，伏断俱生起的我法二执现行种子。
     │ 远行地后，俱生起的我执种子断灭，成纯无漏。
     │ 等觉位，俱生起的法执种子断灭，转为妙观察智。
     └──果用──智照大千内众生机宜，随应说法。


第十一讲 第七识颂

    第十一讲 第七识颂
    一 首颂诠释
    第七识即末那识，末那是梵语的音译，义译为‘意’，但恐与第六意识混淆，故保留末那原音。此识是第六意识之根，意识以末那为俱有依。何以第六名识，而末那名意呢？因为此识任运恒审思量，执著第八识的见分为自我。〈成唯识论〉卷五曰：‘恒审思量，正名为意。’
    〈八识规矩颂〉的第七识颂，首颂颂文如下：
    带质有覆通情本，随缘执我量为非，八大遍行别境慧，贪痴我见慢相随。
    此四句颂文，包括四个主题，即所缘、性别、识量、相应，兹分述如下：
    1、所缘：‘带质有覆通情本’一句，是说明末那所缘之境，即其识性。在第六讲中说到三境，即性境、独影境、带质境。而第七识所缘的境，就是带质境。带质境的意义，是心识不能如实认知此境，这在三量中就成为非量。
    第七末那势所缘的境，只是带质境一种（不通于三境），它是以第八识的见分为所缘境，即是托第八识的本质境，变起自心中的相分，作为自己的所缘，所以名为带质境。换句话说，第七识的见分是能缘之心，第八识的见分为所缘之境。七八识见分均为实种所生，称为‘真带质’，所谓：‘以心缘心真带质，中间相分两头生。’由七、八两识的见分生出一个相分，此即所谓‘通情本’。此带质境通于第七识的能缘之心，此能缘心恒起执著，即是妄情；又通于第八识见分，是所缘之境，此境是实种所生，自有其本质。此境以常似一之相配合，生出中间的相分，所以叫做‘真带质’。
    2、有覆：有覆二字，是明此识的性别。识性分为三类，即善、不善、无记，而此末那识在三性之中，是属于无记性。无记性又分两种，称‘有覆无记’和‘无覆无记’。无覆无记，是说识性既非顺益，又非违损，非善非不善，长保其中庸之性，无可记别。在八个识中、唯有第八识是无覆无记。而第七识，虽然也是非善非不善的中庸性，无奈它为‘四惑’──我痴、我见、我慢、我爱四种根本烦恼所覆盖，隐藏了它真实的义相，致令它辨别不清，幻起‘我相’的错觉。此外又有八大随烦恼和它相应，使它成为一个染污识，由于此识的污染，连带前六识也受到它的影响。
    3、识量：‘随缘执我量为非’一句，指的是此识的识量──即现量、比量、非量的量。末那以第八识的见分为所缘之境，它于所缘境上虚妄生起一个我相，并且‘恒审思量’，执持不舍。而第八识的见分并不是常、主宰之我，这是末那的错觉，所以在三量上属于非量。至于‘随缘执我’四字，末那识的作用，是随著因缘‘任运而转’，不假外力，所以是随缘执我。
    4、相应：相应，指与末那识相应的心所。与末那相应的心所有十八个，就是颂文所称：‘八大遍行别境慧，贪痴我见慢相随。’即是八大随烦恼心所，五遍行心所，四个根本烦恼心所－贪、痴、慢、见、再加一个五别境中的慧心所。为什么这十八个心所与之相应呢？因为爱著于我，故有我贪；迷恋于我，故有我痴；执著于我，故有我见；依持于我，故有我慢。八个大随烦恼，遍及于一切染心；五个遍行心所，遍及于一切心、性、时、地，而染慧生起，分别计度，所以都与第七末那相应。
    心所有法共五十一个，何以除此十八个外，其余三十三个心所全不与末那识相应呢？因为末那识性唯无记，并不是不善性，所以两个属于不善的中随烦恼不与相应。末那行相微细，而十个行相猛利的小随烦恼也不与之相应。末那唯缘现在境，它没有希望、不印持决定、也不忆念过去，也不须定境，所以别境中的欲、胜解、念、定、四心所不与之相应。
    末那识唯执著自我，爱恋自我，故没有嗔心所。末那唯执我见，所以无疑心所。末那性染，故不与十一善心所相应。末那不造善恶业，故无追悔心所。末那不缘外境，不感身心重昧，故无睡眠心所。末那于意言境（意之所思）不起推度，故无寻、伺心所。
    二 次颂诠释
    第七识颂的次颂，四句颂文是：
    恒审思量我相随，有情日夜镇昏迷，四惑八大相应起，六转呼为染净依。
    在这四句颂文中，包括三个主题，即是行相、业用、作依。分述如下：
    5、行相：首句‘恒审思量我相随’，是明末那的体性及行相。〈唯识三十颂〉颂文：　‘思量为性相’，意思是说末那以思量为性，以思量为相。不过认真的说，思量只是末那的行相（末那识见分的行相）。末那识的体性，微细难知，举用显体，就说末那是‘思量为性相’了。
    思量又名意，往宽泛的地方说，八个识皆可称意，皆有思量。但以作用殊胜说，只有末那识称思量。八个识的思量作用，有下列四种分别：
    1、恒而非审的思量，此指第八识，第八识无始以来，恒时相续，而不审察。
    2、审而非恒的思量，此指第六识，第六识有思量作用，但有时中断。
    3、非恒非审的思量，此指前五识，前五识既不恒常，也不审察。
    4、既恒又审的思量，此指第七识，第七识恒时相续，且审察思量。
    由上看来，唯有第七识是‘恒审思量’。它思量什么呢？它一味执取我相，从不暂舍。而我相，又有人我相与法我相的分别。人我相，就是执著于有情的生命体为实我；法我相，是于世间仗因托缘生起诸法上，执为实法。或问，末那识所执的我相，是人我执呢？还是法我执？据唯识学理论，是二执俱通的。因为第七末那识不了解阿赖耶识也是因缘生起的假法，以阿赖耶识执持根身、器界，故执我法为实有。护法论师曰：‘五八无法亦无人，六七二识甚均平。’是指五识八识无我法二执，六识七识有我法二执。
    6、业用：颂文‘有情日夜镇昏迷’句，是指末那的业用。有情，是指一切众生，一切众生各有八识，各以末那识执著自我。以执自我故，便有了彼、有了他，就有疆界与分别。为了自我的生存、享受，则衣食财产，名誉地位，贪得无厌，攫取追求。甚而为了保护自我的利益，不惜损人利己，斗争不已。这一切，不全是以执著自我而沉醉昏迷吗？有情日夜镇昏迷著，日夜表示生死，镇是常的意思。一切众生，沉迷于生死苦海，无以自拔者，皆以有我执之故也。
    7、作依：作依，是指第七末那，为第六识的染净依。颂文：‘四惑八大相应起，六转呼为染净依。’四惑，是我贪、我痴、我见、我慢，八大，是八个大随烦恼心所。四惑八大相应而起，就使这个本是中庸无记的末那识成为染污识，所以末那号称‘染污意’。
    在唯识学上，以第八阿赖耶识为本识，前七识通称转识，因为前七识都是由本识转变生起之故。前七识虽然同称转识，但彼此间又有相生为依的关系。如第六识以第七末那（意根）为所依，第六意识得以生起。前五识又以意识为所依（分别依），前五识得以生起。因此，前七识对本识而言，称七转识；前六识对末那识而言，称六转识，这是约前六的染净转易而说的。因为前六识的转染转净，全受末那识为影响故也。
    三 末颂诠释
    第七识颂文的末颂，是颂第七识依无漏种子，转识成智──由有漏的第七识，转成无漏的平等性智。颂文全文是：
    极喜初心平等性，无功用行我恒摧，如来现起他受用，十地菩萨所被机。
    在这四句颂文中，包括有三个主题，即智力、转依、果德，兹分述如下：
    8、智力：是末那识在修行阶位中，依无漏种子转识成智的情形。‘极喜初心’四字，极喜是十地中初地欢喜地的异称，初心是登入初地入心。修唯识行，至初地入心，此时分别起的我法二执已断，第六识由此际初转为下品的妙观察智，而末那识亦由此际转为下品的平等性智。此即所谓：‘六七因中转，五八果上圆’，六、七二识在登入初地已开始转识成智，而五、八二识必须到十地满心，金刚喻定无间道之后，才转为成所智和大圆镜智。末那识在修行位次中有三个位次，曰生我见相应位，法我见相应位，平等性智相应位。1)生我见相应位，又称人我见相应位，凡夫、二乘有学、或七地以前菩萨，以有漏的第七识见分、缘第八识见分执持为我，此时称生我见相应位。2)法我见相应位，指凡夫、二乘及未得法空智的菩萨，在法空智未现前时，末那识见分缘第八异熟识，法我执尚未断除，此时称法我见相应位。3)平等性智相应位，修行菩萨于登地后的见道位、修道位上，法空智果现前时，平等性智生起，称平等性智相应位，以至于证得佛果，亦为此位所摄。以上三位，前二位是有漏，后一位是无漏。有漏位中，第一位是染污位，第二位是无染位。
    9、转依：‘无功用行我恒摧’，无功用行，指第八地。第七识为第六识之根，第六识为第七识所发之识，在见道位前的资粮位、加行位上，以第六识的闻、思、修三慧，修习生、法二空的观智，对于第六识分别起的我法二执，尽力伏灭。到初地入心，始契合二空，见道证理，这时分别起的我法二执已灭，证得妙观察智。而第七识亦藉著第六识断执的力用，来阻碍自心俱生起的我法二执现行（第七识无分别起的我法二执），以此生起无漏的体性，转为下品的平等性智。但这只是第一番转，此后仍须藉第六识的推动力，续作二空观。而俱生我执非常顽强，由初地到七地所修的观行，不是‘任运而转’，仍属于有功用行。也就是行者入观时，无漏智现前，使俱生我执受到压制，但出观后无漏智不能相续，我执又生。必须至第八不动地，其时观行任运而转，自然发生作用，无漏的生空观智，即恒时无间断现行，俱生我执永伏不起，即‘无功用行我恒摧’，此际就转为中品的平等性智，也就是第二番转。在此以后，仍须藉著第六识的绵密观察，再来伏灭俱生法执，进而断所知障。一直到证得佛果的究竟位，烦恼、所知二障，种子、现行俱尽，这时平等性智转为上品，才算圆满。
    10、果德：此‘如来现起他受用，十地菩萨所被机。’二句，是指平等性智的妙用。菩萨证得平等性智，了解自他不二，为大悲心所驱使，而不住生死，不住涅槃，度他众生。进而随顺所应度化的机宜，示现各种不同的身相和国土，为十地菩萨众，现大神通，转正法轮。
    如来、指证觉的佛陀，如来所示现的身相，自性身、受用身、变化身三种。自性身又名法身，为一切诸法自性的本体，真常不变，无生无灭，而为受用、变化二身之所依止。
    〈成唯识论〉曰：
    ‘自性身者，谓如来真净法界，受用变化平等所依，离相寂然，绝诸戏论，具无边际、真净功德，是一切法平等实性，即此自性，亦名法身，大功德法所依止故。受用身，此有二种，一自受用，谓诸如来于无数劫修集无量福慧资粮所起无量真实功德，及极圆净常遍色身，相续湛然，尽未来际，恒常自受用广大法乐。二他受用，谓诸如来由平等性智，示现净功德身，居纯净土，为住十地诸菩萨众现大神通，转正法轮，决众疑网，令彼受用大乘法乐，合此二身名受用身。变化身，谓诸如来由成所作智变现无量随类化身，居净秽土，为未登地诸菩萨二乘异生称彼机宜现通说法，令各获得诸利乐事。’
    以上三身，如来以他受用身，为十地菩萨示现。如来现起的他受用身，何以独被机于十地菩萨呢，因为地前行者没有证得真如，仍有人相在，是佛变身度化的物件，要到十地菩萨地位，才能见到如来的受用身。
    【附　录】相关名相表解
    1、第七识境量界地等总表：

    境－真带质境。
    量－非量。
    三性－有覆无记
    界地－欲界、色界、无色界。
    相应心所－遍行五、别境一（慧）、善十一、根本烦恼四（贪、痴、慢、我见）、大随烦恼八，共十八心所。
    第七识 依缘－根（末那依阿赖耶为根据）、境（阿赖耶见分）、作意、根子依，共四缘。
    体相－恒审思量，执著自我
    业用－为前六转识染净之依。
    断惑－极喜地初心，俱生我法二执初伏，初转下品平等性智。到第七远行地后（八九十地），俱生我执永断，转中品平等性智。金刚喻定现前，俱生法执永断，转为上品平等性智。
    果用－现起他受用身，以十地菩萨为所被机而教化之。


第十二讲 第八识颂

上一页 目录 全书完

第十二讲 第八识颂

    第十二讲 第八识颂
    一 首颂诠释
    第八阿赖耶识，是八个识中最重要的一个识。它是前七识的根本 (前七识由第八识的种子生起) ，也是宇宙万法的本源。这宇宙万法本源作何解释？ 原来第八识摄持万法种子，在‘因能变’时，种子生起第八识； 在‘果能变’ 前七识相继生起，八识识体各各生起相、见二分。而第八识的见分，是识体‘能认识’的功能，它所认识的物件就是相分。第八识所缘的相分，是‘根身、器界、种子’ ，根身就是有情的肉体，第八识‘摄为自体]； 器界就是有情身外的物质世界，第八识‘领以为境’； 种子就是能生起万法的功能 (可以说就是一种能量) ，第八识‘持令不失’。由第八识的种子‘起现行’生起万法，这时就有了宇宙、人生。宇宙就是‘器界’，人生就是含有心识的‘根身’，所以才说第八识是宇宙万法的本源。这些、在下一节还会讲到，于此先诠释第一颂，颂文是：
    性唯无覆五遍行，界地随他业力生，二乘不了因迷执，由此能兴论主诤。
    在这四句颂文中，包括了四个主题，就是第八识的性别、相应心所、界地定位，及它的理证。兹分述如下：
    一、性别： 第八识在善、恶、无记三性中，它是属于‘无记’，无记有两种，一种是有烦恼心所覆盖，使之成为染污识，如第七识。一种是无烦恼心所覆盖，单纯的无记性，就是第八识。第八识何以必须是无记性呢？ 因为‘冰炭不同炉、薰莸不同器。’善、恶相违而不能相容。第八识含藏万法种子，如果第八识性善，则不容纳恶种子； 如果性恶，则不能容纳善种子。必须是平等的中庸无记，才能兼蓄并容，统纳一切善恶种子。
    二、相应： 相应就是相应心所，在八个识中，第八识的相应心所最少，只有五遍行心所──触、作意、受、想、思。五遍行心所，它是‘周遍而行’，通于一切识、一切时、一切性、一切地，所以五遍行心所与第八识相应。而且于五遍行的受心所，三受之中也只有与第八识相应，而苦受乐受不与第八识相应。因为苦乐二受容易转变，不是一性连续，而舍受却是‘性不变迁、相续不断’，所以与第八识相应。再者、因为第八识的活动是一类相续，行相微细难知，无以分别其顺违的境界，而苦乐二受 (或加忧喜二受) 行相粗显，亦是不能与第八识相应的原因。同时第八识为末那识所缘之境，它‘恒转如瀑流’，一类相续，而苦乐等受有转变、有中断，此亦为不能与第八心王相应的原因。以上就是‘性唯无覆五遍行]一句的诠释。
    三、界地： 此指‘界地随他业力生’句。界是三界、地是九地。‘由他业力生’句，他是指前六识。第八识本身并不造业，前六识以其思心所的作用，支配著身体、语言，造作下身、语、意三种业。业的性质又分为善、恶、无记三性，善业召感未来的乐果，恶业召感未来的苦果，无记业不感果。而或善或恶的业种子，就含藏在第八识中，到业因成熟，众缘具足，就是第八识受报的时候了。
    第八识又名异熟识，旧译为果报识，它是三界有情所招感的总报体。换言之，它是业力寄托的所在，也是生死轮回的主体。它以善恶业力的牵引，轮回于三界九地（此中即包括六道在内），所以界地由他业力生也。
    四、理证： 理证是指‘二乘不了因迷执，由此能兴论主诤’ 二句。第八阿赖耶识，行相深隐幽微，不但世间凡夫不能了解，即二乘圣者也难以通达。因为佛陀住世说法时代，只说到生灭无常的前六识，不曾说六识之后还有个执持自我的末那识，也不曾说末那识之后、还有个一类相续，含藏万法种子，执持根身器界的阿赖耶识。因此小乘行者不知道有个阿赖耶识的存在。当初佛陀在说 <阿含经> 时，何以不对二乘行者直说阿赖耶识呢？ 这在 <解深密经> 中如下说明：‘阿陀那识甚深细，一切种子如瀑流，我于凡愚不开演，恐彼分别执为我。’ 阿陀那识、就是阿赖耶识的异名。
    因为佛陀住世时代、不曾说过此识，所以二乘行者迷惑执著，不承认此识的存在，以此引起大小乘论师的诤论也。
    二 次颂诠释
    次颂的四句颂文是：
    浩浩三藏不可穷，渊深七浪境为风，受薰持种根身器，去后来先作主公。
    在这首颂文中，包括著第八识的体相、依缘、业用三个主题，分述如下：
    一、体相： 阿赖耶识，华译为藏识，此识有‘三藏’之义，即能藏、所藏、执藏：
    1、能藏： 能藏是能持的意思，犹如仓库，能藏一切米麦粮食。无始以来，有情所作一切善恶之业的种子，唯有此识能为储藏，此约其持种一面而说。
    2、所藏： 所藏是所依的意思，犹如仓库，为米麦之所依。此识是一切善染法所依处处，故名所藏，此约受识一面而说。
    3、执藏： 执是坚守不舍的意思，犹如米麦粮食为农家所坚守。此识为第七末那识执为自我，故第七末那为能执，第八阿赖耶为所执，故名执藏。
    二、依缘：‘浩浩三藏不可穷’者，喻此识如汪洋大海，浩翰无涯，不可穷尽。藏识如如海，渊深不可测； 而色、声、香、味、触、法诸境如风，境风鼓动，生起七识波浪。即所谓‘渊深七浪境如风’也。这比喻我人的前七识，为外境所转，起惑造业。 <楞严经> 有偈云：‘譬如巨海浪，斯由猛风起，洪波鼓冥壑，无有断绝时，藏识海常住，境界风所动，种种诸识浪，腾跃而转生。]
    三、业用： 业用，是指此识的作用。此识的作用，大概来说可分别为五种，即受熏、持种、内变根身、外变器界，以及‘去后来先作主公’。也就是第三、四句颂文[受薰持种根身器，去后来先作主公’。兹分述如下：
    1、受薰： 受薰、就是接受薰习。关于薰习，见本文第五讲，即七转识是能薰，第八识是所薰──接受七转识薰习的受薰体。受薰体有它一定的条件， <摄大乘论>中立有‘所薰四义’，即一者坚住性，受薰体要始终一类相续，能持习气。二者无记性，即受薰体性是无记，法体平等，不分善恶都能接纳。三者可薰性，受薰体性非坚密，有隙可乘。四者与能薰共和合性，即能薰与受薰之间同时同处，不即不离。在八个识中，只有阿赖耶识具备以上四个条件，所以可作受薰体。
    同时，在 <成唯识论> 中也立有‘能薰四义’，于此附带一述。所谓能薰者，指的是变动不居的前七识。能薰者也要具备四个条件，即一者有生灭，有生灭变化方有作用，有作用方能薰习种子。二者有胜用，胜用就是作用力强，此有二种，一者是能缘的势用，这是心及心所的作用，而色法无此作用； 二者是强盛的势用，是‘作意筹度’的作用。三者有增灭，其强盛的作用力高下不定，可增可减，方能发挥其作用。四者与所薰和合性，即能薰与所薰同时同处，和合相应。
    2、持种： 持种就是摄持种子，‘种子生现行’的种子，是能藏 (能持) ，‘现行薰种子’，就是所藏 (所持) 。这是指第八识摄持万法种子而说的。
    3、内变根身： 由四大和合而成的‘根身’──即眼、耳、鼻、舌、身的五根身，是第八识中的色法种子所变现。原来第八识所缘的，是根身、种子、器界三类色法，种子是识中的潜势力 (潜在的能量) ，根身、器界是从这潜势力变现出来的。种子何以能内变根身、外变器界？ 原来阿赖耶识能变现出四种功能，即坚实的功能，流润的功能，炎热的功能，飘动的功能。由这四种功能集体发生作用，使我感觉到有物形体的存在。由于四种功能集合的成分不同，而显示出各种不同密度的物质。其实以上四却种功能，也就是地、水、火、风四种物性主观上的感觉，地大虽然有坚实 (质碍性) 的功能，但它是众多极微所聚的假有，根本不是实质。
    4、外变器界： 器界即物质世界，佛经上称之为器世间，此亦第八识色法种子所变现，如上节所述。
    5、去后来先作主公： 第八识是无始以来、无终以后，一直存在。它无所从来，亦无所从去，所谓去后来先者，指一期生命的开始与结束而言。此识是有情业力寄托的所在，是生死轮回的主体，是三界的总报主。它在三界六道的生命之流里，头出头没，不知凡几。每当一期生命结束的时候，前七识的功能隐没，不起现行，第八识最后离开身体，至此命根即不存在，生命宣告结束。 <杂宝藏经> 有偈以明六道差别，偈云：‘顶圣眼生天，人心饿鬼腹，旁生膝盖离，地狱脚板出。]来先者，当第八识离开肉体，成为中阴身时，无明种子仍一念执著，蠢蠢欲动，以其过去业力之牵引，于冥□中遥见一片光明──淫光，与其有父母缘者正在行淫。 <瑜伽师地论> 卷一称：‘、、、、、、父母及子有相感业方入母胎。又彼中有欲入胎时，心即颠倒，若是男者于母生爱于父生憎，若是女者于父生爱于母生憎，于过去生所造诸业，而起妄想作邪解心、、、、、、其时中有作此念已即入母胎，应知受胎名羯罗蓝。]
    生命的开始，是由男女精子卵子结合、成为受精卵的一刹那，即‘纳识成胎]。
    此即所谓‘来先’ ，去后来先作主公，即是说明此识是生死轮回的主体。
    三 末颂诠释
    第八识颂的末一颂，是颂第八识依无漏种子，转识成智──由有漏的第八识，转成无以漏的大圆镜智。此四句颂文是：
    不动地前才舍藏，金刚道后异熟空，大圆无垢同时发，普照十方尘刹中。
    这四句颂文，可分为四段来讲，即三位转舍，智力断障，转依、果德，分述如下：
    一、第八识体，由凡夫到成佛，历经长时，要经过染净三个位次，三位名称是：
    1、我爱执藏现行位： 第七识妄执第八识见分为‘实我’，而起我爱执著。于此、第七识是能执，第八识是所执，故第八识又名‘我爱执藏’。由凡夫、二乘有学位、及七地以前菩萨，全为此位所摄。二乘无学修到无学位，菩萨修到八地，俱生我执断时，才舍去藏识之名，称为异熟识。此即‘不动地前才舍藏’。
    2、异熟业果位： 阿赖耶识又名异熟识，因为它是善恶的异熟业所招感的异熟果，所以第八识有异熟识之名。由凡夫到二乘无学位圣者，大乘十地菩萨，全是此位所摄。必须到十地菩萨满心，即金刚道现前，一刹那间，永断世间二障种子，转第八识成大圆镜智，此时舍去异熟之名，而称为阿陀那识，此即金刚道后异熟空。
    3、相续执持位： 证得佛果的第八识，至无终尽期，都名阿陀那识。这是无上转依的清净位，纯粹是至善无漏的识体故唯在佛果位才有。
    再明白一点说，由凡夫、二乘行人的有学位、大乘七地菩萨，阿赖耶、异熟、阿陀那三名具备； 二乘无学位，八地以上菩萨，已舍去阿赖耶识名称，只剩下异熟识及阿陀那识二名； 到究竟佛果位，异熟一名也舍去，就只称阿陀那识了。
    二、智力断障： 菩萨以智慧断除执障，有其次第，初地只能断除分别起的烦恼障与所知障，到七地才能断除俱生我执，而微细的俱生法执犹在，唯有到十地满心，才永断二障种子，转识成智。
    三、转依： 转依二字，转者转舍、也是转得，依是所依。即是转舍去第八识中的二障种子，转得菩提与涅槃二胜果，而所转舍的二障种子，与所转得的菩提与涅槃二妙胜果，都是以第八识为所依，故称转依。亦即是修行菩萨，到十地满心，于金刚喻定现前之际，刹那之间，二障种子断尽无遗，转第八识为大圆镜智，而清净的无垢识亦同时生起，与大圆镜智相应，即所谓‘大圆无垢同时发，普照十方尘刹中。]
    四、果德： 大圆镜智，具足佛果功德，一者证得万法平等实相，离诸分别； 二者所缘行相，微细难知； 三者不忘不愚一切境相； 四者性离染，净德依持，五者现身土影，尽未来际； 六者如大圆镜，现众色相。以此镜智，普照十方尘刹。

    附录： 相关名相表解
    一、第八识境、量、性、界总表：

      ┌──境
      ├──量──现量。
      ├──三性──无覆无记。
      ├──界地──欲、色、无色三界 (随他业力生)。
      ├──相应心所──遍行五。
      ├──依缘──根 (以末那识为俱有依) 、境 (以根身、器界、种子
第八识┤　　　　　　为所缘境) 、作意、种子依，共四缘。
      ├──体相──浩浩三藏不可穷。
      ├──业用──受薰，摄持种子、根身、器界，业力寄托、轮回主体。
      ├──断惑──不动地前 (远行地) 俱生我执已断，舍去藏识之名。
      │　　　　　　金刚道后，俱生法执永断，不感生死，空去异熟识之
      │　　　　　　名。至此转成‘大圆镜智’。
      └──果用──圆明普照于十方世界，微尘刹土。

上一页 目录 全书完