《禅宗大意》封面

中华佛典宝库制作 2004.10.16


目录

禅　宗　大　意
正果法师　编述

目 录

自序
一、达磨以前的中国禅学
二禅宗的创立
三禅宗的传法授衣
四中华五祖旁出尊宿简介
五禅宗门下的楞伽师
六禅宗的五家七派
七调和五事助参禅
八参禅的入门方便
九参禅宜观心
十曹洞临济参禅方法的差异
十一见性成佛
十二公案的启示
十三顿悟渐修
十四《心灯录》谈三玄三要
十五漫谈参禅


禅 宗 大 意

自　序

    一九八○年夏天，福州鼓山涌泉寺约我为该寺僧伽培训班作短期讲学。预定内容讲完之后，学员们要求我讲讲禅宗，我高兴地答应了。当时手边没有参考书，只好凭记忆及随身带去的一本禅学笔记，写出一份禅宗提纲的讲稿，大约四五千字，学员们把它刻写油印出来。这就是《禅宗大意》的雏形。
    一九八二年，为了给中国佛学院的学员讲“禅宗概论”，遂根据在鼓山讲的禅宗提纲，又看了一些有关的参考书，写成《禅宗大意》，油印成册，除发给中国佛学院学员参考外，各地佛学院、培训班以及留心禅悦者，纷纷来信索阅，已无存书。佛学院准备再油印一次，以结法缘。
    去冬病中，《法音》编辑部净慧法师来看我，提出他们准备将《禅宗大意》编入《法音文库》出版流通。我当即表示同意。病愈之后，又将原稿重新校对了一遍，并把《修心诀》全文和《心灯录》关于谈三玄三要的一段作为附录，成了现在印出来的这个小册子。
    《修心诀》一文对初学参禅者可以起到因指见月的作用，这一点禅师们大概是可以同意的；至于《心灯录》谈三玄三要的一段文字，或者有不同的看法。我觉得文字禅、葛藤禅虽是虚妄分别，但分别熄灭之后，心空及第，壁立万仞，人法双亡，心机泯绝；正凭么时，佛语、祖语、魔语、文字禅、葛藤禅，都没交涉。善恶无记三心绝，是个什么？你在什么地方？道着错！
    我从出家之年（十九岁）开始，就喜欢静坐。一九五○年冬至一九五三年夏，在北京菩提学会闲住，书不读，无事问，终日参究，追问审虑自己的本来面目是谁？有时亦孤明历历，不续前念，不引后念，当体孤立，对境无心。甚至废寝忘食，如痴如呆，行不知行，坐不知坐。在这当中，时有境界现前，好坏善恶，奇形怪状，种种现前，都不贪著，亦不欣厌，一切置之不理。见怪不怪，其怪自败，因而未堕魔境。只是平淡无事，无依无住，亦无迷悟，如是而已。
    至道无难，唯嫌简择。若欲成佛，莫染一物。取一法不成佛，舍一法不成佛。请诸位读者以此观点对《禅宗大意》给予批评、指正，这是我的愿望。
    这本小册子的出版，禅协有关部门的同人付出了辛勤的劳动。他们为这本书复核引文，校对资料，联系印刷事宜，承办发行业务，对此，我深表感谢！

    正果一九八六年春时年七十有四


一、达磨以前的中国禅学

    菩提达磨观见中国人有大乘根器，即泛海东来，经过三年时间，到达建康（今南京），这时正是梁武帝普通七年（５２２，有争议）。武帝迎达磨于宫中，相与问答。达磨知机不契，遂渡江北上，到河南洛阳嵩山少林寺面壁而坐。后来慧可断臂立雪求佛法印，达磨与安心竟，越九年授慧可袈裟，传以法印，以“二入四行”并《楞伽经》四卷，用付慧可，要他单传心印，开示迷悟，不立文字，直指人心，见性成佛。自此创立了中国的禅宗。直到六祖慧能，大行于中国，宋时远播朝鲜、日本，迄今流传未衰。
    禅宗，是中国佛教宗派中的特胜法门，教外别传的心宗，不落言诠，不立文字，重实修实证，真参实悟。说禅宗不文文字，并不等于不用文字。在自悟方面，强调藉教悟宗；在悟他方面，更离不开经典。如六祖说：“吾传佛心印，安敢违于佛经？”又说：“《涅槃经》，吾昔听尼无尽藏读诵一遍，便为讲说，无一字一义不合经义。”这些言语，说明禅宗并非完全排拨文字的。故达磨授慧可以《楞伽》，黄梅、曹溪弘演《金刚》，都说明经教文字，对禅宗亦有大助力。从经教的翻译与历代师祖大德的实践修禅来看，达磨没来以前，中国已有禅学的滥觞，对后来禅宗的影响很大。现将翻译禅经和注重禅观修持的祖师大德的史实，略加介绍，说明菩提达磨以前，中国确有禅学流行，亦有禅观之修持与实践。

    （一）安世高对禅经的翻译
    在东汉桓帝时，有安清字世高者，是安息国王正后的太子，幼以孝行见称。志业聪敏，刻意好学。外国典籍，以及七曜五行，医方异术，无所不通。国王死后，让国与叔，出家修道。于建和二年（１４８）来到洛阳，译出《安般守意》等经，为习禅者所重。这一史实可看作是中国禅学的开端。安世高本人既精习小乘经论，也讽持禅经验，备尽其妙。《高僧传》卷一说安世高“博晓经藏，尤精阿毗昙学。讽持禅经，备尽其妙。既而游方弘化，遍历诸国。以汉桓帝之初，始到中夏……出《安般守意》、《阴持入经》、大小十二门及六十品。初，外国三藏众护撰述《经要》为二十七章。高乃剖析护所集七章，译为汉文，即《道地经》也。”
    安世高从汉桓帝建和二年（１４８）至灵帝建宁（１６８-１７１）中二十余年，译出经论三十余部。现存的《佛说大安般守意经》（二卷）、《禅行法想经》（一卷）、《道地经》（一卷）三经中以《大安般守意经》对修习禅观特别重要。康僧会、道安等均为此经作了注解和疏释。

    （二）支娄迦谶敷演大乘禅教
    在安世高来中国的同时，月支国沙门支娄迦谶，亦来洛阳。于灵帝光和、中平（１７８-１８８）间，传译梵本。译出了《般若道行品经》、《首楞严经》、《兜沙经》等，开始敷演了大乘教义，是为中国大乘禅教的开端。《道行经》即《放光般若》，所讲空理，为禅教扫荡门中的要旨。《首楞严经》的初译，更为禅教所依用。《兜沙经》为《华严经·名号品》的异译，后来禅宗门下亦多引用。《首楞严经》在梁代已成缺本，《兜沙经》一卷，现在《大藏经》中。特别是《楞严经》的教义，为后来禅宗门下所引用，对禅宗的影响很深。

    （三）支谦译经与大乘禅教
    支谦是安世高、支谶以后的大译师。《历代三宝记》卷五说，支谶有弟子支亮，亮有弟子支谦，是为三支。当时人称“天下博知，不出三支”。支谦字恭明，一名越，月支国人。他的祖父法度，于汉灵帝世，率领该国人数百，来汉归化，拜为率善中郎将。谦生于中国，博览经籍，广智多能，世间技艺，多所综习，遍学异书，备通六国言语。献帝末年（２２６），汉室大乱，与乡人数十共奔吴地，孙权拜为博士。
    谦慨叹佛教虽已流行，而经多梵语，未尽翻译之美。于是广收众经旧本，译为汉言。自吴黄武元年（２２２）至建兴二年（２５３），译出《大明度经》、《净行品经》、《首楞严经》、《禅秘要经》、《修行方便经》、《维摩诘所说不思议法门经》等八十八部，一百十八卷。
    《禅秘要经》四卷，《修行方便经》二卷，都重在说明禅观之法。《首楞严经》，《维摩诘所说不思议法门经》三卷，尤为形成大乘禅教的要素，其说散见于诸禅书中，影响很大。

    （四）康僧会解说禅教
    沙门康僧会，其先康居国（今新疆北至中亚一带）人，世居天竺，其父因经商移居交趾。会年十九，二亲并亡，乃出家，励行甚峻，明解三藏，博学多识，兼善文学。于东吴赤乌十年（２４７）来建业，营立茅茨，设像行道，因感得舍利以献孙权。权遂为建塔寺，以始有佛寺，遂称建初寺。由是江右（长江以西之地）佛法大兴。僧会于建初寺译出《六度集经》、《杂譬喻经》等。又注释《安般守意》、《法镜》、《道树》三经，并制经序。解说禅教的《安般守意经》注解，当时习禅的人奉为龟鉴。这里抄录《出三藏记集》卷六所载康僧会《安般守意经序》中一段，以明康僧会对修禅方法及利益的重视。
    “夫安般者，诸佛之大乘，以济众生之漂流也。其事有六（数、随、止、观、还、净），以治六情。情有内外：眼、耳、鼻、口、身、心，谓之内矣；色、声、香、味、细滑、邪念，谓之外也。……弹指之间，心九百六十转。一日一夕，十三亿意。……是以行寂系意著息，数一至十，十数不误，意定在之。小定三日，大定七日。寂无他念，泊然若死，谓之一禅。禅，弃也，弃十三亿秽念之意。已获数定，转念著随，蠲除其八，正有二意（言意已十去其八，仅存数息相随二正意）。意定在随，由在数矣（相随时意定在随，其初由于数息）。垢浊消灭，心稍清净，谓为二禅也。又除其一，注意鼻端，谓之止也。得止之行，三毒四趣（生老病死），五阴六冥（即六尘），诸秽灭矣。昭然心明，逾明月珠（得止心明）。淫邪污心，犹镜处泥，秽垢污焉，偃以照天，覆以临土（偃镜以照天，覆镜以临土，皆无所见）。聪睿圣达，万土临照。虽有天地之大，靡一夫而能睹。所以然者，由其垢浊。众垢污心，有逾彼镜矣。若得良师，划刮莹磨，薄尘微曀，荡使无余，举之以照，毛发面理（面纹），无微不察。垢退明存，使其然矣。情溢意散，念万不识一矣。犹若于市，驰心放听，广采众音，退宴存思，不识一夫之言，心逸意散，浊翳其聪也。若自闲处，心思寂寞，志无邪欲，侧耳靖听，万句不失，片言斯著，心靖意清之所由也。行寂止意，悬之鼻头，谓之三禅也。还观其身，自头至足，反覆微察，内体污露。森楚毛竖，犹睹浓涕。于斯具照，天地人物。其盛若衰，无存不亡。信佛三宝，众冥皆明，谓之四禅也。摄心还念，诸阴皆灭，谓之还也。秽欲寂静，其心无想，谓之净也。得安般行者，厥心即明。举眼所观，无幽不睹。往无数劫方来之事，人物所更，现在诸刹，其中所有世尊教化，弟子诵习，无遐不见，无声不闻。恍惚仿佛，存亡自由（生死自主）。大弥八极，细贯毛氂。制天地，住寿命，猛神德，坏天兵，动三千，移诸刹。八不思议，非梵所测，神德无限，六行（数随止观还净）之由也。世尊初欲说斯经时，大千震动，人天易色，三日安般，无能质者。于是世尊化为两身，一曰何等，一尊主演，于斯义出矣。”
    康僧会在《安般守意经序》文中对数、随、止、观、还、净六妙门，解释得既深且透，清楚地说明了他对禅观的重视和修禅的体会，对后世修习禅观者的影响是非常之大的。

    （五）竺法护的译述对禅学的影响
    两晋时代佛教很盛，译经的人很多。成就大而影响深的译师当然推竺法护。他的祖先是月支国人，本姓支氏，世居敦煌，年八岁出家，事外道沙门竺高座为师，遂称竺姓（当时沙门多随师姓）。诵经验日万言，过目能记。天性纯懿，操行精苦，笃志好学，万里寻师，博览六经，涉猎百家之言，虽世务毁誉，未尝介于视听。时当晋帝之世，寺庙图像，虽崇京师，而方等深经，却蕴藏于西域。护乃慨然发愤志弘大道。遂随其师遍游西域诸国，通晓三十六国语言文字。西晋泰始二年（２６６），大赉梵本，自敦煌至长安，后入洛阳及往江右，沿路传译，未尝暂停。自泰始中，至永嘉二年（３０８），译出《光赞般若经》、《维摩经》、《正法华经》、《无量寿经》、《十地经》、《大哀经》、《般泥洹经》等。
    护于晋武帝末，隐居深山，寻立寺于长安青门外，精进行道，宣隆佛化，二十余年。僧徒宗奉者数千人。时人称为敦煌菩萨。他所译《光赞般若》等经，于禅道之勃兴颇具影响。般若乃禅学的本质，在禅宗建立以后，般若思想仍为禅师们所重视。

    （六）道安对禅学的影响
    道安姓卫氏，常山扶柳人。《高僧传》卷五说：
    “年十二出家，神性聪敏，而形貌甚陋，不为师之所重，驱役田舍，至于三年。执勤就劳，曾无怨色。笃性精进，斋戒无缺。数岁之后，方启师求经。师与《辩意经》一卷，可五千余言，安赉经入田，因息就览。暮归以经还师，更求余者。师曰：昨经未读，今复求耶？答曰：即已谙诵。师虽异之，而未信也。复与《成具光明经》一卷，减一万言，赉之如初，暮复还师。师执经覆之，不差一字。卷大惊嗟而敬异之。后为受具戒，恣其游学。”
    至邺城（今河南安阳）中寺，卷事佛图澄。更游学诸方，遍求经律。寻建寺塔，开讲筵，徒众数百，常宣法化。他高瞻远识，在佛教史上，是古今罕比的杰出僧雄，当时佛教界推尊为泰山北斗。
    自汉魏至晋，译经已多，但传译的人，多未说名字，后人追寻，莫测年代。道安乃总集自汉魏至晋译经目录，表其时代与译人，诠品新旧，撰为《综理众经目录》一卷，众经有据，实有其功，可惜其书久已佚遗。后在襄阳十五年，每岁常讲《放光般若》，未尝废缺。他在关中时，见当时沙门，多随师姓，以为依师莫如遵佛，主张僧尼应以释为姓。其后《增一阿含经》传来，果有“四水河入海，无复河名，四姓出家，同称释氏”之文，与道安之言相符。汉地僧尼以释为姓遂为永式。他又制定僧尼轨范，条为三例：一、行香定坐上经上讲法，二、常日六时行道饮食唱时法，三、布萨差使悔过等法。注释经论，立序禅、正、流通三分；又于经初置经题，皆自道安开始。道安以性空为宗，倡本无说，撰著《般若道行》、《密迹》、《安般》诸经注解，凡十九部二十二卷。今并湮没失传。
    在道安的著述中，与禅门至关重要者，则般若之弘通及禅经之注解。《出三藏记集》卷六，有道安作《安般注序》，《十二门经序》，卷七有《道行经序》，卷八有《摩诃钵罗若波罗蜜经抄序》。同书卷五有《新集安公注经及杂经志录》，列安公著作。
    道安所著诸经注解虽然湮没不传，但他的般若思想，尚可从现存的《安般注序》等文中窥其大概，对于当时修习禅定的人影响至深。
    当时实修禅法者，在《高僧传》中著其事迹者有竺僧显、帛僧光、竺道猷、释慧嵬、支昙兰等，或独处于山谷，或安禅于石室，皆依教修禅之辈。如《高僧传·释慧嵬传》说：
    “释慧嵬，不知何许人，止长安大寺。戒行澄洁，多栖处山谷，修禅定之业。……后冬时，天甚寒雪，有一女子来求寄宿。形貌端正，衣服鲜明，姿媚柔雅，自称天女，以上人有德，天遣我来，以相慰喻，谈说欲言，劝动其意。嵬，厥志贞确，一心无扰。乃谓女曰：吾心若死灰，无以革囊见试。女遂凌云而逝。顾叹曰：海水可端，须弥可倾，彼上人者，秉志坚贞。”
    当时修习的禅法虽与后来的大乘禅不同，然注重真修实证的作风，则是禅学史上甚可注意之事。

    （七）慧远倡导的念佛禅
    慧远本姓贾氏，雁门楼烦（今山西代县）人，二十一岁，与弟慧持，共入道安之门，听讲《般若经》豁然而悟，便与弟慧持依道安出家。既入道，以大法为己任，精思讽持，以夜继昼。通无生实相之玄，般若中道之妙，即色空慧之秘，缘门寂观之要。博识玄览，戒定兼明。道安尝叹曰：“使道流东国，其在远乎。”后随安公南游樊沔。前秦建元九年（３７３），秦将苻丕，寇并襄阳。道安为朱序拘，不能得去。乃分张徒众，各随所之。临路，诸长德皆被诲约，远不蒙一言。远乃跪曰：“独无训勗，惧非人例。”安曰：“如汝者，岂复相忧。”（《高僧传·慧远传》）远于是与弟子数十人去荆州等处，及入庐山，刺史桓伊为之建立东林寺，创白莲社，弘通净业，发禅净一致之端。后世净业念佛之徒，以慧远为净土宗始祖。
    慧远之念佛，为修禅念佛，而非口唱念佛。如《高僧传·慧远传》说：“远创造精舍，洞尽山美……复于寺内，别置禅林。”其修禅的情形，传中虽未载，然《佛祖统纪》卷二十六记其同门慧永习禅事迹云：
    “西林法师慧永……初习禅于恒山，与远师同依安法师，期结宇罗浮。及远师为安公所留，师乃欲先度五岭。太元初，至浔阳，刺史陶范，素挹道风，乃留憩庐山，舍宅为西林以奉。师布衣蔬食，精心克己，容常含笑，语不伤物。峰顶别立茅屋，时往禅思。至其室者，常闻异香，因号香谷。……刘程之……性好佛理，乃之庐山……遂于西林涧北，别立禅坊，养志安贫，精研玄理，兼持净戒。……尝贻书关中，与什、肇扬槯经义，著《念佛三昧诗》，以见专念坐禅之意。”
    由上述记载所说念佛习禅之意，可以想见慧远倡导的念佛禅的大概情形。

    （八）鸠摩罗什之译经与禅法
    鸠摩罗什，具云鸠摩罗什婆，略云罗什，或云什，译云童寿。其父鸠摩罗炎，自天竺移居龟兹。龟兹国王，闻而敬慕之，请为国师，以其妹耆婆妻之，遂生什，所谓鸠摩罗什，即合取父母两称为名者。什年七岁随母出家，受学毗昙、六足，并寻访外道经论。时有须耶利苏摩，深通大乘，什师事之。明究摩诃衍学，受诵中、百论等。未几，罗什道誉及于西域，名称闻于东土。迨至后秦弘始三年（４０１），秦王姚兴遣使迎什入关，待以国师之礼，令于西明阁及逍遥园从事译经。于时十方义学沙门，云集从什受业者达三千人。就中道生、僧肇、道融、僧睿、道恒、僧影、慧观、慧严，称什门八俊；又生、肇、融、睿，谓之什门四圣，加昙影、慧严、慧观、僧[契-大+石]、道常、道标，谓之什门十哲，各有著述。
    罗什译出《大品般若经》、《坐禅三昧经》、《大智度论》、《中论》、《百论》、《十二门论》、《成实论》等经律论集，现存五十二部、三百零二卷。以弘始十一年（４０９）寂于长安大寺。
    罗什传译的《大品般若经》、《法华经》、《维摩诘经》、《中论》、《百论》、《十二门论》等，对大乘禅学的影响很深远。他还译出了不少禅经。据《出三藏记集》所载有《禅法要解》二卷（或云《禅要经》，《禅经》三卷（一名《菩萨禅法经》，与《坐禅三昧经》同），《禅法要》三卷，又据《历代三宝记》卷八所记，尚有《禅秘要经》三卷，《思维要略法经》一卷。这些直接弘演禅学经典的译出，对禅法的传播产生了重要的影响。
    罗什弘唱空宗，是后来大乘禅宗兴隆的内涵；所译禅经，为禅学的兴起奠定了巩固的基础。《出三藏记集》卷九载僧睿撰《关中出禅经序》说：
    “禅法者，向道之初门，泥洹之津径也。此土先出修行、大小十二门、大小安般，虽是其事，既不根悉，又无受法，学者之戒，盖阙如也。鸠摩罗什法师，以辛丑之年十二月二十日自姑臧（凉州）至长安，予即于其月二十六日从受法。既蒙启受，乃知学有成准，法有成条……寻蒙抄撰众家禅要，得此三卷。……夫驰心纵想，则情愈滞而惑愈深；系意念明，则澄见朗照而造极弥密。心如水火，拥之聚之，则其用弥全；决之散之，则其势弥薄。故论云：质微则势重，质重则势微；如地质重故，势不如水；水性重故，力不如火；火不如风；风不如心；心无利故力无上。神通变化，八不思议，心之力也。心力既全，乃能转昏入明；明虽愈于不明，而明未全也。明全在于忘照，照忘然后无明非明；无明非明，尔乃几乎息矣！几乎息矣，慧之功也。故经云：无禅不智，无智不禅。然则禅非智不照，智非禅不成。大哉禅智之业，可不务乎。”
    僧睿在序文中介绍了他本人从罗什领受禅法的经过，和他对禅观在佛教实践上的重要性的体会。

    （九）佛驮跋陀罗弘传出世禅法
    佛驮跋陀罗，译云觉贤，又云佛贤，北天竺迦维罗卫人。十七岁出家，与同学数人诵经，众皆一月，觉贤一日诵毕。其师叹曰：觉贤一日敌三十天。及受具戒，本业精勤，博学群经，多所通达，以禅律驰名。尝与同学僧伽达多共游罽宾，会遇中国沙门智严至西域，邀贤到中国弘法。于是杖锡跋涉，经历三年，于义熙二年（４０６）来长安。当时鸠摩罗什在关中，贤往见之，什大欣悦。共论法相，振发玄绪，多有妙旨。什每有疑义，必共谘决。
    时秦主姚兴，专志经法，供养三千余僧，往来宫阙，盛修人事，唯觉贤守静，不与众同。即于长安专弘禅法，四方乐静者，并闻风而至，从修禅业者甚多。一日偶向弟子们说：我昨见本乡有五舶俱发。既而弟子传告外人。弟子中有自言得阿那含果者，贤不即检问，以此致谤。罗什门下僧[契-大+石]、道恒等，以为显异惑众，乃以三千僧摈遣觉贤，驱迫令去。乃与弟子慧观等四十余人，飘然南下。神志从容，初无异色。识真者咸共叹惜，缁素送者达千余人。觉贤渡江至庐山，慧远欣然迎之。寻应请译出《达摩多罗禅经》二卷（一名《不净观经》或《修行道地经》），并亲自开讲。江东自是始耽禅悦。
    觉贤志在游化，居无求安。以义熙八年（４１２）适荆州，遇外国舶主，既而讯访，果是天竺五舶，先所见者。
    后至建康。义熙十二年（４１６）于道场寺与法显共译《摩诃僧只律》。十三年（４１７）又与显共译出六卷本《泥洹经》。自十四（４１８）年至宋永初二年（４２１），译出《大方广禅华严经》凡六十卷，通称《晋译华严》，又称《六十华严》。永初二年（４２１），译出新《无量寿经》。此外还译出《大方等如来藏经》等，凡十余部。以元嘉六年（４２９）卒，世寿七十一岁。
    佛驮跋陀罗传译的禅经，应不只《达摩多罗禅经》一种，如《出三藏记集》卷十四记其在庐山的译经情况时说：“自夏迄冬，译出禅数诸经。”可见他译的禅经并非一部。《出三藏记集》卷九有慧远法师撰《庐山出修行方便禅经统序》，既言统序，应非一种可知。
    值得注意的是，佛驮跋陀罗的禅法是有传承的。如《达摩多罗禅经》卷一云：“佛灭度后，尊者大迦叶、尊者阿难、尊者摩田地、尊者舍那婆斯、尊者优波崛、尊者婆须密、尊者僧摩罗叉、尊者达摩多罗，乃至尊者不若密多罗诸持法者，以此慧灯，次第传授。我今如其所闻，而说是义。”
    《出三藏记集》卷九载佛驮跋陀罗的高足弟子慧观所作的《修行地不净观经序》，述禅法传承情况颇悉。文云：“夫禅典之妙，盖是三乘之所游。……佛涅槃后，阿难曲奉圣旨，流行千载。先与同行弟子摩田地，摩田地传与舍那婆斯。此三应真，大愿弘覆，冥构于昔，神超事外。慈在宁济，潜行救物，偶会无差。……后百年中……乃有五部之异。是化运有方，开彻有期。五部既举，则深浅殊风，遂有支流之别。既有其别，可不究本详而后学耶？此一部典，名为具足清净法场。传此法至于罽宾，转至富若蜜罗。富若蜜罗亦尽诸漏，具足六通。后至弟子富若罗，亦得应真。此二人于罽宾中为第一教首。富若蜜罗去世以来五十余年，弟子去世二十余年，昙摩多罗菩萨与佛陀斯那俱共，谘得高胜，宣行法本。佛陀斯那化行罽宾，为第三训首。有于彼来者，亲从其受法教诲，见其涅槃时遗教言，我所化人众数甚多，入道之徒具有七百。富若蜜罗所训为教师者十五六人，于今于西域中炽盛教化，受学者众。昙摩罗从天竺来，以是法要传与婆陀罗；婆陀罗（传）与佛陀斯那。佛陀斯那愍此旃丹无真习可师，故传此法本流至东州。亦欲使了其真伪，途无乱辙，成无虚构。”
    佛陀斯那是佛驮跋陀罗之师，其传承如次：富若蜜罗（不若蜜多罗）-富若罗-昙摩多罗-婆陀罗-佛陀斯那-佛驮跋陀罗。序文将不若蜜多罗作富若蜜罗，其实为同一梵字的音译，不言可知。如《传法正宗记》卷五评曰：“《出三藏记集》所谓不若多罗，而此曰般若多罗；又谓弗若蜜多，而此曰不如蜜多，何其异耶？曰：此但梵音小转。”
    在后来的禅宗史上，认为佛驮跋陀罗所述传承不是正统，而是旁传。这里没有辩论这个问题的必要。不管佛驮跋陀罗的禅法传承是正是旁，总是有传承的。他的修禅方法，有精妙独特之处，且在本国就已经得“不还果”。来长安传授禅法，对弟子进行指授，得益者多，习禅者益众。既遭谤到庐山，译出禅经，并加开示演讲，促成远公立禅室行道，开禅净双修的先河。由此可以想见佛驮跋陀罗对当时禅学影响之大。

    （十）僧睿之参禅
    僧睿，《高僧传》卷六说：
    “魏郡长乐人也。少乐出家，至年十八始获从志。依投僧贤法师为弟子，谦虚内敏，学与时竟。至年二十二，博通经论。尝听僧朗法师讲《放光经》，屡有讥难。朗与贤有濠上之契，谓贤曰：“睿比格难，吾累思不能通，可谓贤贤弟子也。”至年二十四，游历名邦，处处讲说……常叹曰：经法虽少，足识因果，禅法未传，厝心无地。什后至关，因请出《禅法要》三卷。始是鸠摩罗陀所制，末是马鸣所说，中间是外国”诸圣共造，亦称菩萨禅。睿既获之，日夜修习，遂精炼五门，善入六静。”
    所谓《禅法要》三卷者，即《坐禅三昧经》上下二卷，现存于大藏经中。僧睿所作《关中出禅经序》说：
    “禅法者，向道之初门，泥洹之津径也……鸠摩罗什法师，以辛丑之年（东晋隆安五年，４０１）十二月二十日，自姑臧至长安，余即于其月二十六日，从受禅法，既蒙启授，乃知学有成准，法有成条……寻蒙抄撰众家禅要，得此三卷。”
    由僧睿传记和所作《关中出禅经序》来看，可知他追求禅法、修习禅法的热忱。隆安五年（弘治三年）十二月二十日什到长安，同月二十六日，僧睿即从什学习禅法，并达到“精炼五门，善入六静”的精妙境地。

    （十一）僧肇对禅门之影响
    僧肇，京兆人。“家贫以佣书为业。遂因缮写，乃历观经史，备尽坟籍，志好玄微，每以庄、老为心要。尝读老子《道德章》，乃叹曰：美则美矣，然期栖神冥累之方，犹未尽善。后见旧《维摩经》，欢喜顶受，披寻玩味，乃言：始知所归矣。因此出家。学善方等，兼通三藏，及在冠年，而名振关辅……。后罗什至姑臧，肇自远从之，什嗟赏无极。及什适长安，肇亦随入。及姚兴命肇与僧睿等，入逍遥园助详定经论。肇以去圣久远，文义舛杂，先旧所解，时有乖谬。及见什谘禀，所悟更多。因出《大品》之后，肇便著《般若无知论》，凡二千余言，竟以呈什，什读之称善。乃谓肇曰：吾解不谢子，辞当相挹。”《《高僧传》卷六》）
    僧肇以后又著《不真空论》、《物不迁论》、《涅槃无名论》、《宝藏论》、《维摩诘所说经注》等，对后来禅宗影响至大。有禅宗大德因读《涅槃无名论》而豁然大悟者。如论中说：“夫至人空洞无相，而万物无非我造。会万物以成己者，其唯圣人乎。”云庵云：“昔石头和尚读至于此，遂豁然大悟曰：圣人靡己，靡所不己，法身无相，谁云自他。圆鉴虚照于其间，万象体玄而自现。”其他几种著述，禅宗门下引用甚多。

    （十二）道生顿悟成佛说对禅宗的影响
    道生为什门四圣之一。他秉赋极高，悟玄理于言象之外。其所以倡导，妙契禅理，为后世禅宗大德所常言之。道生始幽栖于庐山七年，后游长安，师事罗什。《高僧传》卷七说：
    “竺道生本姓魏，钜鹿人，寓居彭城（今江苏铜山县），家世仕族。父为广戚令，乡里称为善人。生幼而颖悟，聪哲若神……后值沙门竺法汰，遂改俗归依，伏膺受业。既践法门，俊思奇拔。研味句义，即自开解。故年在志学，便登讲座。……初入庐山，幽栖七年，以求其志。常以入道之要，慧解为本。故钻仰群经，斟酌杂论，万里随法，不惮疲苦。后与慧睿、慧严同游长安，从什公受业。关中僧众，咸谓神悟。……生既潜思日久，彻悟言外。乃喟然叹曰：夫象以尽意，得意则象忘；言以诠理，入理则言息。自经典东流，译人重阻，多守滞文，鲜见圆义。若忘筌取鱼，始可与言道矣。于是校阅真俗，研思因果。乃言善不受报，顿悟成佛。又著《二谛论》、《佛性当有论》、《法身无色论》、《佛无净土论》、《应有缘论》等。笼罩旧说，妙有渊旨。而守文之徒，多生嫌嫉，与夺之声，纷然竞起。又六卷《泥洹》先至京都，生剖析经理，洞入幽微，乃说一阐提人皆得成佛。于时大本未传，孤明先发，独见忤众。于是旧学以为邪说，讥愤滋甚，遂显大众摈而遣之。生活于大众中正容誓曰：若我所说反于经义者，请于现身即表疠疾；若与实相不相违背者，愿舍寿之时，据师子座。言竟，拂衣而游。初投吴之虎丘山。旬日之中，学徒数百……俄而投迹庐山，销影岩岫……后《涅槃》大本至于南京，果称阐提悉有佛性。与前所说，合若符契。生既获新经，寻即讲说。以宋元嘉十一年（４３４）冬十一月庚子，于庐山精舍升于法座。神色开朗，德音俊发。论议数番，穷理尽妙。观听之众，莫不悟悦。法席将毕，忽见尘尾纷然而坠。端坐正容，隐几而卒。颜色不异，似若入定。道俗嗟骇，远近悲泣。于是京邑诸僧，内惭自疚，追而信服。其神鉴之至，徵瑞如此。”
    道生秉赋天才，研究教义，剖析经理，彻悟言外。其“顿悟成佛说”对后来的禅宗影响至为巨大。见性成佛至高至极的绝唱，传灯相续不绝，成了禅宗永久承传的孤明朗照的心灯。
    道生的顿悟成佛说立义如何，已不得而知，但观其所撰《法华经疏·见塔品注》说：“既云三乘是一，一切众生，莫不是佛。”又说：“以神通力，接诸大众，皆在虚空。所以接之者，欲明众生大悟之分，皆成于佛，示此相耳。”由此可以推知生公“顿悟成佛”说妙理之一斑了。
    道生的顿悟成佛说在当时盛传一时。如《高僧传》卷八说：
    “释道猷，吴人。初为生公弟子，随师之庐山。师亡后，隐临川郡山，乃见新出《胜鬘经》，披卷而叹曰：先师昔义，暗与经同。但岁不待人，经集义后，良可悲哉！因注《胜鬘》以翊宣遗训。凡有五卷，文烦不行。宋文筒问慧观，顿悟之义，谁复习之？答云：生弟子道猷。即敕临川郡，发遣出京。既至，即延入宫内。大集义僧，命猷伸述顿悟。时竞辩之徒，关责互起。猷既积思参玄，又宗源有本，乘机挫锐，往必摧锋。帝乃抚几称快。”
    《高僧传》卷八说：“释法瑗，姓辛，陇西人。……瑗幼而阔达，倜傥殊群。路见贫寒，辄脱衣为惠。初出家，事梁州沙门竺慧开……后东适建业，依道场慧观为师。笃志大乘，傍寻数论。……后入庐山，守静味禅。澄思五门，游心三观。……后文帝访觅述生公顿悟义者，乃敕下都。使顿悟之旨，重申宋代。”使顿悟之说与修禅相结合。

    （十三）玄高、宝云、慧观的修禅
    随佛驮跋陀罗受学禅法的，有玄高、宝云、慧观等名僧。然而以习禅独擅美名者，则为玄高。如《高僧传》卷十二说：
    “释玄高，姓魏，本名寻育，冯翊万年人也。……既背俗乖世，改名玄高。……受戒已后，专精禅律。闻关右有浮驮跋陀禅师，在石羊寺弘法，高往师之。旬日之中，妙通禅法。……高徒众三百，往居山舍，神情自若，禅慧弥新。”
    释宝云，未详氏族，传云凉州人。少出家，精勤有学行。于东晋隆安初往西竺求法，亲拜圣迹，遍学梵书。天竺诸国音字诂训，悉皆备解。后还长安，随佛驮跋陀罗禅师学习禅观。安止京都道场寺时，众僧以云志力坚猛，弘道绝域，莫不披襟咨问，敬而爱焉。云译出新《无量寿经》等。晚出诸经，云所治定。华梵兼通，音训允正。云之所定，众咸信服。云性好幽居，以保闲寂。遂适六合山寺。又译《佛本行赞经》等。山多荒民，俗好草窃，云说法教诱，多有改悟。礼事供养，十室而九。以元嘉二十六年（４４９）终于山寺，春秋七十有四。
    释慧观，俗姓崔，清河人。十岁便以博见驰名。弱年出家，游方受业。与宝云为友，从慧远、罗什学。又从佛驮跋陀罗谘询禅要。慧观风神秀雅，思入玄微。时人称之曰：“通情则生、融上首，精难则观、肇第一。”故向他求法问道者，日不空筵。
    在这同一时期，精于禅法而驰名于世的，还有智严、慧觉、罽宾沙门昙摩密多，西域沙门畺良耶舍，天竺水少门僧伽达多、僧伽罗多哆等。都是兼明三藏，而以禅门为专业，明悟超群，数日入定，正受三昧。大弘禅业，以禅定知名于世者，具载《名僧传抄》、《高僧传》中，不一一备举了。

    （十四）宝志是祖师禅的肇始者
    据《高僧传》所说，宝志（亦作保志）是一位神异莫测的异人，示现的灵迹甚多。他少年出家，即师事锺山道林寺僧俭，专修禅观。《高僧传》卷十一说：
    “释保志，本姓朱，金城人，少出家，止京师道林寺。师事沙门僧俭为和尚，修习禅业。至宋泰始（４６６-４７１）初，忽如僻异。居止无定，饮食无时，发长数寸，常跣行街巷，执一锡杖，杖头挂剪刀及镜，或挂一两匹帛。齐建元（４８０-４８２）中，稍见异迹。数日不食，亦无饥容。与人言，始若难晓，后皆效验。时或赋诗，言如谶记。京土士庶，皆敬事之。齐武帝谓其惑众，收驻建康。明旦人见其入市，还检狱中，志犹在焉。……（梁武帝）即位，下诏曰：志公迹拘尘垢，神游冥寂。水火不能焦濡，蛇虎不能侵惧。语其佛理，则声闻以上。谈及隐沦，则遁仙高者。岂得以俗士常情，空相拘制，何其鄙狭一至于此。自今行来，随意出入，勿得复禁。志自是多出入禁内。……志知名显奇，四十余载。士女恭事者，数不可称。至天监十三年（５１４）冬，于台后堂谓人曰：菩萨将去。未及旬日，无疾而终。尸骸香软，形貌熙悦。临亡，自燃一烛，以付后阁舍人吴庆。庆即启闻。上叹曰：大师不复留矣！烛者，将以后事嘱我乎？因厚加殡送，葬于锺山独龙之阜。仍于墓所立开善精舍，敕陆倕制铭辞于冢内。王筠勒碑文于寺门。传其遗像，处处存焉。初志显迹之始，年可五六十许，而终亦不老。人咸莫测其年。有徐捷道者，居于京师九日台北，自言是志外舅弟，小志四年。计志亡时，应年九十七。”
    宝志于生活起居，行住坐卧，都无定相，变幻莫测，示现灵迹之事很多，所说隐语，都成应验。其答梁武帝所问，俱为祖师禅的机锋，如涂毒鼓、太阿剑，闻之者丧，婴之者断，不可以心思意解者。梁武帝一日问志公元：“弟子烦恼未除，何以治之？”答云：“十二（识者以为十二因缘治惑药也）。”又问十二之旨。答云：“旨在书字时节刻漏中（识者以为书之在十二时中）。”又问：“弟子何时得静心修习？”答云：“安乐禁（识者以为禁者止也，至安乐时乃止耳）。”其辞旨隐没难解，类皆如此。
    宝志还作有《大乘赞》十首，《十四科颂》十四首，《十二时颂》十二首。辞意内涵，与后时禅宗旨趣多所冥符，禅宗门下诸祖师多有引用者。故说宝志之倡导教化，已开祖师禅之先河，实不为过。

    （十五）傅翕写出了大乘禅的《心王铭》
    与宝志同时的清信士名傅翕者，自号当来下生善慧大士，于松山顶，躬耕而居之。乃说一偈曰：“空手把锄头，步行骑水牛，人从桥上过，桥流水不流。”有人盗菽麦瓜果，大士见之，即与篮笼盛去。日常佣作，夜则行道。见释迦、金粟、定光三如来放光袭其体。自言“我得首楞严定”（见《景德传灯录》卷二十七）。
    梁大通六年（５３４）正月二十八日，遣弟子致书于梁武帝。书曰：
    “双林树下，当来解脱善慧大士，白国主救世菩萨，今欲条上中下善，希能受持。其上善，略以虚怀为本，不著为宗。亡相为因，涅槃为果。其中善，略以治身为本，治国为宗。天上人间，果报安乐。其下善，略以护养众生，胜残去杀，普为百姓，俱禀六斋。今闻皇帝崇法，欲伸论义，未遂襟怀；故遣弟子傅睢告白。”（同上）
    武帝览书后，迎住建业。有所谘问，大士答者，多属禅门旨趣的机锋语句。梁武帝请大士讲《金刚经》，大士才升座，以尺挥案一下，便下座。帝愕然！宝志曰：陛下还会么？”帝曰：“不会。”志公曰：“大士讲经竟。”又一日，正讲经时，武帝至。大众皆起，大士端坐不动。近臣报曰：“圣驾在此，何不起立？”大士曰：“法地若动，一切不安。”
    陈太建元年（５６９）己丑四月二十四日，大士示众曰：“此身甚可厌恶，众苦所集，须慎三业，勤修六度。若堕地狱，卒难得脱，常须忏悔。”又曰：“……《大品经》云：‘有菩萨从兜率来，诸根猛利，疾与般若相应’即吾身是也。”言讫趺坐而终，寿七十三。示意为弥勒菩萨示现，世人称之为傅大士。
    大士曾创设轮藏，如《神僧传》卷四说：
    “初大士在日，常以经目繁多，人或不能遍阅，乃就山中建大层龛，一柱八面，实以诸经，运行不碍，谓之轮藏。仍有愿言：登吾藏门者，生生世世不失人身。从劝世人，有发菩提心者，能推轮藏，是人即以持诵诸经功德无异。今天下所建轮藏，皆设大士像，实始于此。”
    至舍宅建寺，施家资为众生，供养三宝，预示悬知等事甚多，这里不具录。大士著有《心王铭》，对禅宗意趣的影响甚为深远。兹抄录全文如下。
    观心空王，玄妙难测。无形无相，有大神力，
    能灭千灾，成就万德。体性虽空，能施法则。
    观之无形，呼之有声，为大法将，心戒传经。
    水中盐味，色里胶青，决定是有，不见其形。
    心王亦尔，身内居停，面门出入，应物随情。
    自在无碍，所作皆成。了本识心，识心见佛。
    是心是佛，是佛是心，念念佛心，佛心念佛。
    欲得早成，戒心自律。净律净心，心即是佛。
    除此心王，更无别佛。欲求成佛，莫染一物。
    心性虽空，贪嗔体实，入此法门，端坐成佛。
    到彼岸已，彼波罗蜜。慕道真士，自观自心。
    知佛在内，不向外寻，即心即佛，即佛即心。
    心明识佛，晓了识心，离心非佛，离佛非心。
    非佛莫测，无所堪任，执空滞寂，于此漂沉。
    诸佛菩萨，非此安心，明心大士，悟此玄音。
    身心性妙，用无更改，是故智者，放心自在。
    莫言心王，空无体性，能使色身，作邪作正。
    非有非无，隐显不定，心性离空，能凡能圣。
    是故相劝，好自防慎，刹那造作，还复漂沉。
    清净心智，如世黄金，般若法藏，并在身心。
    无为法宝，非浅非深，诸佛菩萨，了此本心。
    有缘遇者，非去来今。
    即心即佛的禅宗旨趣，辞句中透露无余，有缘遇者，也许当下把着鼻孔！
    除上来所举历代传译和弘倡禅法的大德祖师外，在《高僧传》卷十一《习禅篇》有传的二十一人，附见的十一人；《景德传灯录》卷二十七亦说“禅门达者虽不出世，有名于时者十人”。不见僧传，而在别的佛教著述中提到的修习禅法的人也还不少。这些，都说明了达磨没有来中国以前，中国已经有禅学在流传，从小乘禅到大乘禅以至祖师禅，以发展的轨迹隐然可寻。所以在达磨来中国以前，只能说没有奕叶传灯的禅宗，但禅学的传译倡导和修习，还是由无而有，由有而熏修法备，遂步兴盛发展起来。


二禅宗的创立

    读了《续高僧传》、《宝林传》、《传法正宗记》、《景德传灯录》、《释门正统》、《付法藏传》、《林间录》、《三宝记》、《内典录》、《人天眼目》、《佛祖统纪》、《佛祖历代通载》、《中国禅学考》等十几种佛教史籍，对有关菩提达磨的承传，来中国的年代，与梁武帝的问答，九年面壁、传衣法、定宗旨、六次受毒、只履西归等事迹的记载，各有差异，有辩证的，也有非难者，谁正谁谬，谁是谁非，让佛教历史学者去研究考证吧。我还是以《景德传灯录》、《传法正宗记》等为主，按传统说法来谈菩提达磨开创中国禅宗的史实。因为禅宗的极则，实无一法相传，更无一法授人，只是以心心契合的证明来表示相传，称之为“千圣不传的传”。所以对文字记载，字斟句酌的辩证，在传灯史实上，虽有不同的说法，然禅自有禅的传灯授法的由来，即以释尊的正觉为禅宗的起源。所以禅宗又称为“佛心”宗。
    禅宗传授的基础，不在于经典，是在于大圆满的佛心。所以达磨大师说：“不立文字，教外别传，直指人心，见性成佛。”因此说到菩提达磨来中国传授禅宗，还得从佛直传大迦叶尊者的大圆满觉心说起。
    相传世尊一日在灵山会上，拈一枝金婆罗花示众。时大众皆默默不得其要领，唯独大迦叶尊者破颜微笑。世尊曰：“吾有正法眼藏，涅槃妙心，实相无相，微妙法门，不立文字，教外别传，付嘱摩诃迦叶。”此即禅宗所传的“拈花微笑”公案，亦即释尊与迦叶的大法授受。在这拈花微笑，心心交照之间，迦叶尊者就成为传灯的第一祖。
    世尊至多子塔前，命摩诃迦叶分座令坐，以僧迦黎围之，遂告曰：“吾以正法眼藏，密付于汝，汝当护持，并敕阿难副贰传化，无令断绝。”并说偈曰：“法本法无法，无法法亦无，今付无法时，法法何曾法。”尔时世尊说此偈已，复告迦叶：“吾将金缕僧伽黎衣传付于汝，转授补处，至慈氏佛出世，勿令朽坏。”迦叶闻偈，头面礼足，曰：“善哉！善哉！我当依敕，恭顺佛教。”（以上见《传灯录》、《指月录》、《传法正宗记》）
    《传法正宗记》卷一评曰：
    “付法于大迦叶者，其于何时，必何以而明之耶？曰：昔涅槃会之初，如来告诸比丘曰：“汝等不应作如是语，我今所有无上正法，悉以付嘱摩诃迦叶。是迦叶者，当为汝等作大依止。”（见《涅槃经》卷二）此其明矣。然正宗者，盖圣人之密相传授，不可得必知其处与其时也，以经酌之，则《法华》先而《涅槃》后也，方说《法华》而大迦叶预焉，及《涅槃》而吾谓付法之时，其在二经之间耳。”
    禅的始传，自释尊与迦叶间授受以后，二十八传至菩提达磨，形成了直指单传的禅宗，菩提达磨为中国禅宗的初祖。
    菩提达磨南天竺国人，姓刹帝利（《续高僧传·菩提达磨传》云是婆罗门种），是香至王的第三子。因二十七祖般若多罗至其国受王供养，说法王宫，乃得相见。及父王去世，遂辞诸兄，从般若多罗出家。《传法正宗记》卷五说：
    “我素不顾国位，欲以法利物，然未得其师，久有所待。今遇尊者，出家决矣，愿悲智见容。般若受其礼，为之剃度曰：汝先入定，盖在日光三昧耳，汝于诸法已得通量，今宜以菩提达磨为汝之名。会圣僧与受具戒。当此时其地三震，月明昼现，尊者寻亦成果。自此其国俗因以达磨多罗称之。……益嘱尊者曰：汝且化此国，后于震旦，当有大因缘，然须我灭后六十七载，乃可东之，汝若速往，恐衰于日下。”
    所谓“后于震旦，有大因缘”者，菩提达磨曾问般若多罗尊者，震旦有大士堪为法器否，尊者答他说：“汝所化之方，获菩提者不可胜数。”
    般若多罗入灭之后，达磨从师教，且留本国勉行教化。时有比丘名佛大先者，俱出于般若多罗之门，故二人每以兄弟之礼相遇，并弘大法，时人称美，谓之二甘露门。
    达磨化导其国六十余年，遵从师教，震旦缘熟，行化时至，乃先辞祖塔，次别同学，后至王所，慰而勉之曰：“当勤修白业，护持三宝，吾去非晚，一九即回。”王闻师言，涕泪不能留，即为治装，载以大舶，躬率亲戚臣属，送于海岸。国人观者，皆泣下而别。达磨泛重溟，经过三年，达于中国南海。时当梁武帝普通元年（５２０）庚子九月二十一日（传灯诸书说是梁普通八年，今按史书记载普通纪年只有七年）。广州刺史萧昂，备礼迎接，上表奏闻于武帝。帝览表后，遣使持诏迎请，其年十一月一日遂至建业（传灯诸书皆称萧昂以达磨事奏闻武帝，及考昂传，不见其做广州刺史事，惟昂侄萧励当时尝作此州刺史，恐皆传录音误以励为昂耳”。既至皇宫，诏尊者陪坐正殿，帝乃问曰：“朕即位以来，尝造寺写经度僧，不可胜纪，有何功德？”师曰：“并无功德，”帝曰：“何以无功德？”师曰：“此但人天小果有漏之因，如影随形，虽有非实。”帝曰：“如何是真功德？”答日：“净智妙国，体自空寂，如是功德，不以世求。”帝又曰：“如何是圣谛第一义？”师曰：“廓然无圣。”帝日：“对朕者谁？”师曰：“不识。”帝不能领悟。祖知机缘不契，是月十九日潜回江北，十一月二十三日届于洛阳。实当后魏孝明太和十年（４８６，《传法正宗记》作孝明正光元年，５２０）。寓止于嵩山少林寺，面壁而坐，终日默然，人莫能测，谓之壁观婆罗门。
    洛阳有僧名神光者，乃旷达之士，久居伊洛，博览群书，善谈玄理，每自叹曰：“孔老之教，礼术风规，庄易之书，未尽妙理，及闻达磨大士风范尊严，住止少林，至人在兹，我当往师之。”遂去彼处，晨夕参承。光虽事之尽礼，祖常端坐面壁，未始为语。光自感曰：“昔人求道，敲骨取髓，刺血济饥，布发掩泥，投崖饲虎。古尚若此，我又何人，今岂有万万分之一耶？”其年十二月九日夜，天下大雪，光坚立不动，积雪过膝，立愈恭敬，祖顾而悯之，问曰：“汝久立雪中，当求何事？”光悲泪曰：“惟愿和尚慈悲，开甘露法门，广度群品。”祖曰：“诸佛无上妙道，虽旷劫精勤，能行难行，能忍难忍，尚不得至，岂此微劳小效而辄求大法！”光闻师诲励，潜取利刀，自断左臂，置于师前。师知是法器，乃曰：“诸佛最初求道，为法忘形，汝今断臂吾前，求亦可在。”……光曰：“诸佛法印可得闻乎？”师日：“诸佛法印，非从人得！”光曰：“我心未宁，乞师与安！”师曰：“将心来与汝安！”曰：“觅心了不可得。”师曰：“与汝安心竟。”光由是有所契悟，祖遂易其名曰慧可。
    此后缁白之众，皆靡然趋之于祖，其声既振，遂闻于魏朝，孝明帝闻祖异迹，遣使持诏迎请，前后三次，祖不下少林，帝弥加钦尚，遂赐二摩纳袈裟，金银器物若干，祖皆辞让，以至三返。帝意弥坚，祖乃受之。自此缁白之众，倍加信向。
    祖在魏地居止九年，一天忽向其门人曰：我欲西返天竺，时将至矣，汝等盍各言所得乎？门人道副对曰：“如我所见，不执文字，不离文字，而为道用。”师曰：“汝得吾皮。”尼总持曰：“我今所解，如庆喜见阿閦佛国，一见更不再见。”师曰：“汝得吾肉。”道育曰：“四大本空，五阴非有，而我见处，无一法可得。”师曰：“汝得吾骨。”最后慧可礼拜，依位而立。师曰：“汝得吾髓。”乃顾慧可而告之曰：“昔如来以正法眼付迦叶，而辗转至我。我今以付于汝，汝当护持。并授袈裟，以为法信。各有所表，宜可知矣。”可曰：“请师指陈。”师曰：“内传法印，以契证心；外付袈裟，以定宗旨，后代浇薄，疑虑竞生，云吾西天之人，言汝此方之子，凭何得法？以何证之？汝今受此衣、法，却后难生，但出此衣并吾法偈，用以表明，其化无碍。至吾灭后二百年，衣止不传，法周沙界。明道者多，行道者少。说理者多，悟性者少。虽潜符密证，千万有余。汝当阐扬，勿轻未悟，一念回机，便同本得。听吾偈曰：
    吾本来兹土，传法救迷情；
    一花开五叶，结果自然成。
    祖又谓慧可曰：“此有《楞伽经》四卷，亦用付汝。此经是如来心地要门，极谈法要。可以为世间众生开示悟人。”祖还说：“我离开南印来此东土，见此赤县神州，有大乘气象而未得其应，遂逾大海，越过沙漠，为法求人久默待之，今得付授，其殆有终。”
    据《别记》说，祖初居少林寺九年，为二祖说法，只教“外息诸缘，内心无喘，心如墙壁，可以入道。”慧可种种说心说性，曾未契理，祖只遮其非，不为说无念心体。慧可忽曰：“我已息诸缘。”祖曰：“莫成断灭去否？”可曰：“不成断灭。”祖曰：“何以验之，云不断灭？”可曰：“了了常知，言之不可及。”祖曰：“此诸佛所传心体，更勿疑也。”
    这一段记录，值得参禅的人善为注意，特别是初下手用功的人，尤须仔细善用。
    祖在说完了上面一段话后，乃与徒众往禹门千圣寺。居止三天，有其城太守杨衒之者，其人素喜佛事。闻祖至，乃来敬礼。因问曰：“西土五印，师承为祖，其道如何？”祖曰：“明佛心宗，寸无差误，行解相应，名之曰祖。”又问：“此外如何？”祖曰：“须明他心，知其古今，不厌有无，亦非取故。不贤不愚，无迷无悟，若能是解，亦名为祖。”衒之复曰：“弟子归心三宝，亦有年矣，，而智慧昏蒙，尚迷真理。适听师言，罔知攸措，愿师慈悲，开示宗旨。”祖知恳到，即说偈曰：
    亦不睹恶而生嫌，亦不观善而勤措。
    亦不舍愚而近贤，亦不抛迷而就悟。
    达大道兮过量，通佛心兮出度。
    不与凡圣同躔，超然名之曰祖。
    衒之闻偈，悲喜交集，并说：“愿师久住世间，化导群有。”师曰：“吾即逝矣，不可久留，根性万差，多逢患难。”衒之问：“不知是什么人，弟子为师除得否？”祖曰：“吾以传佛秘密，利益迷途，害彼自安，必无此理。”衒之曰：“自师至此，谁曾见伤？幸示其人，我为除之。”祖曰：“言之则将有损，吾宁往矣，岂忍残人快己。”而衒之问得更坚决，益恳曰：“非敢损人，但欲知之耳。”祖不得已，遂说偈曰：
    江槎分玉浪，管炬开金锁，
    五口相共行，九十无彼我。
    衒之闻偈，莫测其义，默记于怀，礼辞而去。
    《续高僧传》卷十九说，“壁观四行，为达磨之道。”《传法正宗记》卷六说，四独昙行琳序之，余书则未见，认为非达磨传道的极谈。纵使是昙琳得之于达磨，亦恐系达磨随机方便而说。但“二入四行”强调参禅者应借教悟宗，深信含生同一真性的观点，我觉得这也是达磨对参禅者至关重要的教导。且敦煌石窟发现的《楞伽师资记·菩提达磨传》里也说：“此四行是达磨禅师亲说，余则弟子昙琳记师言行，集成一卷，名为《达磨论》也。”兹据《景德传灯录》卷三十录全文如下：
    《菩提达磨略辨大乘入道四行》，弟子昙琳序：
    “法师者，西域南天竺国，是大婆罗门国王第三之子也。神慧疏朗，闻皆晓悟，志存摩诃衍道，故舍素从缁，绍隆圣种，冥心虚寂，通鉴世事。内外俱明，德超世表。悲海边隅，正教陵替。遂能远涉山海，游化汉魏。忘心之士，莫不归信，存见之流，乃生讥谤。于时唯有道育、慧可，此二沙门，年虽后生，俊志高远，幸逢法师，事之数载，虔恭谘启，善蒙师意。法师感其精诚，诲以真道。令如是安心，如是发行，如是顺物，如是方便。此是大乘安心之法，令无错谬。如是安心者壁观，如是发行者四行，如是顺物者防护讥嫌，如是方便者遣其不著，此略序所由云尔。
    夫入道多途，要而言之，不出二种：一者理入，二者行入。理入者，谓藉教悟宗，深信含生，同一真性，但为客尘妄想所覆，不能显了。若也舍妄归真，凝住壁观，无自无他，凡圣等，一坚住不移，更不随于文教，此即为理冥符，无有分别，寂然无为，名之理入。行入者，谓四行，其余诸行，悉入此中。何等四耶？一、报冤行，二、随缘行，三、无所求行，四、称法之行。云何报冤行，谓修道行人，若受苦时，当自念言：我从往昔无数劫中，弃本从末，流浪诸有，多起冤憎，违害无限。今虽无犯，是我宿殃恶业果熟，非天非人所能见与，甘心忍受都无冤诉。经云：逢苦不忧。何以故？识达故。此心生时，与理相应，体冤进道，故说言报冤行。二、随缘行者，众生无我，并缘业所转，苦乐齐受，皆从缘生。若得胜报荣誉等事，是我过去宿因所感，今方得之，缘尽还无，何喜之有。得失从缘，心无增减，喜风不动，冥顺于道，是故说言随缘行也。三、无所求行者，世人长迷，处处贪著，名之为求。智者悟真，理将俗反，安心无为，形随运转，万有斯空，无所愿乐，功德黑昱，常相随逐。三界久居，犹如火宅，有身皆苦，谁得而安。了达此处，故舍诸有，息想无求。经云：“有求皆苦，无求乃乐。”判知无求，真为道行，故言无所求行也。四、称法行，性净之理，目之为法，此理众相斯空，无染无著，无此无彼。经云：“法无众生，离众生垢故。法无有我，离我垢故。”智者若能信解此理，应当然称法而行。法体无悭，于身命财，行檀舍施，心无吝惜，达解三空，不倚不著，但为去垢，称化众生，而不取相，此为自行，复能利他。亦能庄严菩提之道。檀施既尔，余五亦然。为除妄想，修行六度，而无所行，是为称法行。”
    居千圣寺不久，祖以化缘既毕，端居而逝。其时必后魏幼主钊与孝庄帝废立之际。是岁乃当梁武帝大通二年（５２８）。以其年葬于熊耳山，起塔于定林寺。
    传说其后三年，魏宋云自西域返回时，与达磨相遇于葱岭，见其手携只履，翩翩独行。云即问曰；“大师何往？”祖曰：“西天去。”即谓云曰：“汝主已崩。”云听闻茫然相别。云回复命，明帝果已去世。云寻以其事奏闻于后主孝庄帝，帝令发其圹视之，唯一草履尚在。朝廷为之惊叹，诏取所遗之履，存于少林寺供奉。至唐开元十五年（７２７）丁卯，为信道者窃往五台山僧寺供养，后亦亡之，今不知所在。


三禅宗的传法授衣

    禅的起源，在于世尊的正觉。虽然从历史记载上看传灯似乎成为问题，然禅的传灯授受，心心相印，有其由来。如《景德传灯录》卷一说，世尊一日在灵山会上告弟子摩诃迦叶：“吾以清净法眼，涅槃妙心，实相无相，微妙正法，将付于汝，汝当护持。并敕阿难副贰传化，无令断绝。”而说偈言：
    法本法无法，无法法亦法。
    今付无法时，法法何曾法。
    尔时世尊说此偈已，复告迦叶：“吾将金缕僧伽黎衣，传付于汝。转授补处，至慈氏佛出世，勿令朽坏。”迦叶闻偈，头面礼足，曰：“善哉！善哉！我当依敕，恭顺佛教。”
    经过这大法授受，大迦叶尊者于是成了禅宗第一祖。自此历代祖师传法付衣，成为大法传授、灯灯相续的真传。直到菩提达磨继承这一传授，成为第二十八祖。梁普通年间，菩提达磨尊者来到中国，传授给慧可，于是达磨成了开创中国禅宗的初祖。达磨亦付慧可僧伽黎衣和宝钵，以为法信。所谓“内传法印，以契证心；外付袈裟，以定宗旨。”并说：“吾灭后二百年，衣钵止不传，法亦大盛。”乃说偈曰：
    吾本来兹土，传法救迷情；
    一花开五叶，结果自然成。
    祖又曰：“吾有《楞伽经》四卷，亦用付汝。即是如来心地要门，令诸众生开示悟人。”
    二祖慧可大师，武牢人，姓姬氏。母始怀妊时，有异光发其家，及出生而名之曰光。少小超群好学，世间之书无不博览，尤其善谈老庄。后览禅书遂尽弃前学。年三十远游求师，至洛阳龙门香山，依宝静禅师出家，寻得戒于永穆寺。遍学大小乘教义，未几而经论皆通。三十二岁复返香山，终日宴坐，又经八载，于寂默中忽见一神入告曰：“将欲受果，何滞此耶？大道非遥，汝其南矣。”第二天，忽觉头痛，至不可忍。其师欲为治之，忽闻空中有声曰：“此乃换骨，非是常痛。”往见其师述说其事，静视之，见顶骨如五峰秀出，以有神异，更名神光。其师宝静与之曰：“汝相吉祥，当有所证，神令汝南者，斯则少林达磨大士必汝之师也。”可遂至少林寺，立雪断臂求法印，果得其传授，达磨为其易名慧可。
    北齐天保二年（５５１），有一居士，年四十许，不称姓名，趋前礼拜而问可曰：“弟子身缠风恙，请和尚忏罪。”可曰：“将罪来，与汝忏。”居士良久云：“觅罪了不可得。”可曰：“我与汝忏罪竟，宜依佛法僧住。”士曰：“今见和尚，已知是僧，未审何名禅法？”师曰：“是心是佛，是心是法。法佛无二，僧宝亦然。”士曰；“今日始知罪性不在内，不在外，不在中间，如其心然，佛宗法无二也。”可深器之，即为剃发云：“此法宝也，宜名僧璨。”其年三月十八日，于先福寺受具。自兹疾渐愈。执侍巾瓶二载，可乃告曰：“菩提达磨远自竺乾，以正法眼藏并信衣密付于吾，吾今授汝。汝当守护无令断绝。听吾偈曰：
    本来缘有地，因地种花生；
    本来无有种，花亦不曾生。
    付衣法已曰：“我有宿累在邺，将往偿之，善去善行。”于是即于邺都随宜说法，一音演畅，四众归依。如是积三十四载，后邑宰翟仲侃惑僧辨和邪说，加师以非法，祖怡然委顺，因是而化，世寿一百七岁。即隋文帝开皇十三年（５９３）癸丑三月十六日。葬于磁州滏阳县东北七十里。唐德宗谥大祖禅师。
    三祖僧璨大师，不知何许人。以白衣谒见二祖慧可，不称姓名，因答有悟，乃师之出家。授法付衣后，可诫之曰：“后必有难，汝当远引避之。”璨从其言，遂隐于舒州皖公山。当后周武帝毁灭佛法，璨往来于太湖县司空山，居无常处，积十余载，时人无能知者。
    隋开皇年间，有沙弥道信者，年始十四岁，一旦来礼座下，请问之曰：“愿和尚慈悲，乞与解脱法门？”师曰：“谁缚汝？”曰：“无人缚。”璨曰：“何更求解脱乎？”信于言下大悟，愿以弟子礼事之。服劳九载，后于吉州受戒，侍奉尤谨。祖屡试以玄微，知其缘熟，乃付衣法。“昔如来大法眼藏，今以付汝，并其衣钵，汝皆将去。听吾偈曰：
    花种虽因地，从地种花生。
    若无人下种，花地尽无生。
    并曰：“汝善传之，无使其绝。”
    祖传法以后，孑然往适罗浮山，悠游二载，却回旧址。逾月士民奔趋大设坛供，祖为四众广宣心要讫，于法会大树下，合掌立化。时当隋朝大业丙寅年（６０６）十月十五日。唐玄宗谥鉴智禅师，塔曰觉寂。
    僧璨著有《信心铭》，兹录全文如下：
    至道无难，唯嫌拣择。但莫憎爱，洞然明白。
    毫厘有差，天地悬隔。欲得现前，莫存顺逆。
    违顺相争，是为心病。不识玄旨，徒劳念静。
    圆同太虚，无欠无余。良由取舍，所以不如。
    莫逐有缘，勿住空忍。一种平怀，泯然自尽。
    止动归止，止更弥动。唯滞两边，宁知一种。
    一种不通，两处失动。遣有没有，从空背空。
    多言多虑，转不相应。绝言绝虑，无处不通。
    归根得旨，随照失宗。须臾返照，胜却前空。
    前空转变，皆由妄见。不用求真，唯须息见。
    二见不住，慎莫追寻。才有是非，纷然失心。
    二由一有，一亦莫守。一心不生，万法无咎。
    无咎无法，不生不心。能由境灭，境逐能沉。
    境由能境，能由境能。欲知两段，无是一空。
    一空同两，齐含万象。不见精粗，宁有偏觉。
    大道体宽，无易无难。小见狐疑，转急转迟。
    执之失度，必入邪路。放之自然，体无去住。
    任性合道，逍遥绝恼。系念乖真，昏沉不好。
    不好劳神，何用疏亲。欲取一乘，勿恶六尘。
    六尘不恶，还同正觉。智者无为，愚人自缚。
    法无异法，妄自爱著。将心用心，岂非大错。
    迷生寂乱，悟无好恶。一切二边，良由斟酌。
    梦幻空华，何劳把捉。得失是非，一时放却。
    眼若不睡，诸梦自除。心若不异，万法一如。
    一如体玄，兀尔忘缘。万法齐观，归复自然。
    泯其所以，不可方比。止动无动，动止无止。
    两既不成，一何有尔。究竟穷极，不存轨则。
    契心平等，所作俱息。狐疑尽净，正信调直。
    一切不留，无可记忆。虚明自照，不劳心力。
    非思量处，识情难测。真如法界，无他无自。
    要急相应，唯言不二。不二皆同，无不包容。
    十方智者，皆入此宗。宗非促延，一念万年。
    无在不在，十方目前。极小同大，忘绝境界。
    极大同小，不见边表。有即是无，无即是有。
    若不如是，必不须守。一即一切，一切即一。
    但能如是，何虑不毕。信心不二，不二信心。
    言语道断，非去来今。
    四祖道信大师司马氏，世居河内，后徙蕲州广济县。师生而超异，幼慕空宗诸解脱门，宛如宿习。隋开皇十二年（５９２），以沙弥参见僧璨尊者，既问答悟道，遂礼拜师之。又九年，乃得其付法授衣。既嗣祖风，摄心无寐，胁不至席六十年。
    唐武德七年（６２４），祖返蕲之破头山，（即今之双峰山），大弘所得之法，四方学士，云集法筵。太宗闻其风尚，尝三诏皆辞不起。又诏并谓使臣曰：“今复不从吾命，即取首来。”诏至，“果逆上意”。祖即引颈待刃。使者还，以此奏之。太宗嘉其坚贞，慰谕甚盛。此时，祖已居山二十年。
    一日往黄梅县，路逢一小儿，可七岁许，骨相奇秀，异乎常童。祖因问曰：“子何姓？”答曰：“姓即有，非常姓。”祖曰：“是何姓？”答曰：“是佛性。”祖曰：“汝无姓耶？”答曰：“性空，故无。”祖默识其为法器，即顾侍者道：“此儿非凡之器，后当大兴佛事。”遂请允其父母舍为弟子。祖为剃度，名之曰弘忍。其后乃命曰：“昔如来传正法眼，转至于我，我今付汝，并前祖信物衣钵，汝皆将之。勉其传授，无使断绝，听吾偈曰：
    花种有生性，因地花生生。
    大缘与信合，当生生不生。
    高宗永徽辛亥岁（６５１）闰九月四日，忽垂诫门人曰：“一切诸法，悉皆解脱，汝等各自护念，流化未来。”言讫安坐而逝。世寿七十二，塔于本山。代宗谥大医禅师，塔曰慈云。
    五祖弘忍大师，蕲州黄梅人，姓周氏。传其前生为破头山中栽松道者，尝请于四祖曰：“法道可得闻乎？”祖曰：“汝已老，脱有闻，其能广化邪？倘若再来，吾尚去迟汝。”路经水边，见一女子洗衣，向其揖曰：“寄宿得否？”女曰：“我有父兄，可往求之。”曰：“汝答应了，我即敢行。”女首肯之。女周氏季子也。归辄怀孕，父母大恶，逐之。女无所归，日佣纺里中，夕止于众馆之下。不久，生一子，以为不祥，因抛浊港中，明日见之，溯流而上，气体鲜明。大惊，遂举之。抚养成童。随母乞食，里人呼为无姓儿，性大聪明，有所闻见，无难易者，一皆晓了。风骨绝异，有圣人相。有智者见之叹曰：“此儿具大人相，所不及如来者，缺七种相耳。”七岁时遇道信大师，出家受戒，嗣法后，化于破头山，教化大盛。是时天下慕其风者，不远千里而趋之，学者称为东山法门。
    《景德传灯录》卷三说：
    “咸亨中（６７０-６７３）有一居士，姓卢名慧能，自新州来参谒。师问曰：“汝自何来？”曰：“岭南。”师曰：“欲须何事？”曰：“唯求作佛。”师曰：“岭南人无佛性，若为得佛？”曰：“人即有南北，佛性岂然？”师知是异人，乃呵曰：“著槽厂去。”能礼足而退，便入碓坊，服劳于杵臼之间，昼夜不息。经八月，师知付授时至，遂告众曰：“正法难解，不可徒记吾言，持为己任。汝等各自随意述一偈，若语意冥符，则衣法皆付。”时会下七百余僧。上座神秀者，学通内外，众所宗仰，咸共推称云：“若非尊秀，畴敢当之？”神秀窃聆众誉，不复思惟，乃于廊壁书一偈曰：
    身是菩提树，心如明镜台。
    时时勤拂拭，莫使惹尘埃。
    师因经行，忽见此偈，知是神秀所述，乃赞叹曰：“后代依此修行，亦得胜果。”其壁本欲令处士卢珍绘《楞伽变相》，及见题偈在壁，遂止不画，各令诵念。能在碓坊，忽聆诵偈，乃问同学：“是何章句？”同学曰：“汝不知和尚求法嗣，令各述心偈？此则秀上座所述。和尚深加叹赏，必将付法传衣也。”能曰：“其偈云何？”同学为诵。能良久曰：“美则美矣，了则未了。”同学呵曰：“庸流何知，勿发狂言。”能曰：“子不信耶？愿以一偈和之。”同学不答，相视而笑。能至夜，密告一童子，引至廊下，能自秉烛，令童子于秀偈之侧，写一偈曰：
    菩提本无树，明镜亦非台。
    本来无一物，何处惹尘埃。
    大师后见此偈曰：“此是谁作，亦未见性。”众闻师语，遂不之顾。逮夜，乃潜令人自碓坊召能行者入室告曰：“诸佛出世为一大事故，随机大小而引导之，遂有十地、三乘、顿渐等旨，以为教门。然以无上微妙、秘密圆明、真实正法眼藏，付于上首大迦叶尊者，辗转传授二十八世。至达磨届于此土，得可大师承袭以至于吾，今以法宝及所传袈裟用付于汝。汝自保护，无令断绝。”听吾偈曰。
    有情来下种,因地果还生。
    无情既无种，无性亦无生。”
    能居士跪受衣法，启曰：“法则既受，衣付何人？”祖曰：“昔达磨初至，人未知信，故传衣以明得法。今信心已熟，衣乃争端，止于汝身，不复传也。且当远隐，俟时行化，所谓授衣之人，命如悬丝也。”能曰：“当隐何所？”师曰：“逢怀即止，遇会且藏。”能礼足已，捧衣而出。是夜南迈，大众莫知。忍大师自此不复上堂。凡三日。大众疑怪，致问。祖曰：“吾道行矣！何更询之？”复问：“衣法谁得耶？”师曰：“能者得。”于是众议卢行者名能，寻访既失，悬知彼得，即共奔逐。忍大师既付衣法，复经四载，至上元二年（６７５），忽告众曰：“吾今事毕，时可行矣。”即入室，安坐而逝。寿七十有四。建塔于黄梅之东山。代宗皇帝谥大满禅师、法雨之塔。”
    六祖慧能大师，俗姓卢氏，其祖先范阳人，父名行瑫，武德年中，谪宦新州，乃生慧能，遂为新州籍人。三岁丧父，其母守志，不复适人。独养尊者，以终其身。然其家贫，母子生活艰难，尊者遂打柴以养母。一日负柴至市中，闻有人读诵《金刚经》，至“应无所住而生其心”，有所感悟，因问诵经人曰：“此何经耶？君得之于何人？”曰：“此名《金刚经》，得于黄梅忍大师。大师尝谓人曰：“若持此经，得速见性。”尊者闻语欢喜，欣然发意出家求法。乃乞于一友，为母积备资粮，辞母告其往黄梅为法寻师之意。既抵黄梅，参礼五祖。弘忍大师一见，默识其法器。乃使之人碓房中去踏米。经八个月，祖知其机已熟，乃召集座下众僧，教令各试呈得法偈语。当慧能呈偈后五祖潜入碓房问曰：“米熟也未？”慧能曰：“米熟已久，犹欠筛在。”这就是说虽已彻悟，单立无依，灵明不昧，尚未得师之印可。五祖去后，慧能于三更入五祖室。五祖复徵其初悟“应无所住而生其心”语，慧能言下大彻，遂启五祖曰：“一切万法，不离自性。何期自性，本自清净；何期自性，本不生灭；何期自性，本自具足；何期自性，本无动摇；何期自性，能生万法。”五祖知悟本性，谓慧能曰：“不识本心，学法无益，若识自本心，见自本性，即名丈夫、天人师、佛。”遂传衣法，慧能受衣法后，南还广州，落发于法性寺，得具戒后，至韶阳曹溪，四众云归，方以其法普传。
    《五灯会元》卷一说：“一日，六祖谓众曰：诸善知识，汝等各各净心，听吾说法。汝等诸人，自心是佛，更莫狐疑。外无一物而能建立，皆是本心生万种法故。经云：心生种种法生，心灭种种法灭。若欲成就种智，须达一相三昧，一行三昧。若于一切处而不住相，彼相中不生憎爱，亦无取舍，不念利益成坏等事，安闲恬静，虚融淡泊，此名一相三昧。若于一切处，行住坐卧，纯一直心，不动道场，真成净土，名一行三昧。若人具二三昧，如地有种，能含藏长养，成就其实。一相一行。亦复如是。我今说法，犹如时雨溥润大地。汝等佛性，譬诸种子，遇兹沾洽，悉得发生。承吾旨者，决获菩提。依吾行者，定证妙果。”先天元年（７１２）告诸四众曰：“吾忝受忍大师衣法，今为汝等说法，不付其衣。盖汝等信根纯熟，决定不疑，堪任大事。听吾偈曰：
    心地含诸种，普雨皆悉生。
    顿悟华情已，菩提果自成。
    说偈已，复曰：“其法无二，其心亦然。其道清净，亦无诸相。汝等慎勿观净及空其心。此心本净，无可取舍。各自努力，随缘好去。”祖说法利生，经四十载，其年七月六日，命弟子往新州国恩寺，建报恩塔，仍令倍工。国恩寺乃祖家旧址，为塔之意乃欲报其父母之德。
    先天二年七月一日，谓门人曰：“吾欲归新州，汝速理舟楫。”时大众哀慕，乞师且住。祖曰：“诸佛出现，犹示涅槃。有来必去，理亦常然。吾此形骸，归必有所。”曰：“师从此去早晚却回。”祖曰：“叶落归根，来时无口。”又问：“师之法眼，何人传受？”祖曰：“有道者得，无心者通。”
    《指月录》卷四说：
    “八月三日复示众曰：吾灭度后，莫作世情，悲泣雨泪，受人吊问，身著孝服，非吾弟子，亦非正法。但识自本心，见自本性，无动无静，无生无灭，无去无来，无是无非，无住无往。恐汝等心迷，不会吾意，今再嘱汝，令汝见性。吾灭度后，依此修行，如吾在日，若违吾教纵，吾在世，亦无有益。复说偈曰：
    兀兀不修善，腾腾不造恶。
    寂寂断见闻，荡荡心无著。”
    说偈己，端坐至三更，谓门人曰：吾行矣。奄然迁化。于时异香满室，白虹属地，林木变白，禽兽哀鸣。十一月，广、韶、新三郡官僚暨门人僧俗争迎真身，莫决所之。乃焚香祷曰：香烟指处，师所归焉。时香烟直贯曹溪。十一月十三日，迁神龛并衣钵曹溪。次年七月入塔。春秋七十有六。盖年二十四而传衣，三十九祝发，说法利生三十七载。
    唐宪宗皇帝谥大鉴禅师，塔曰元和灵照。


四中华五祖旁出尊宿简介

    禅宗正传旁传的关系，犹如中国封建时代一家之嫡庶关系，虽然嫡庶有别，但其血脉系统则是一。得其传法，直下相承，则为正传，显其尊贵。旁传者虽得其同一之法，则称为支派，表示其有别于正传，不如正传尊贵。在印度第二祖阿难尊者，就旁传一人，即末田底迦。第二十四祖师子尊者，亦旁传法嗣一人，就是达磨达。如是直到中国五祖以前旁传的共有二百零五人。
    这里介绍的是禅宗五祖的旁传情况，选择其可述者，略加介绍，使初参学者，知道禅宗有正传旁传的差别而已，非有鄙视旁传之意，学者当知之。

    初祖达磨大师，旁出法嗣三人。
    释迦世尊以化期将尽，在灵山会上，拈花示众，传法给摩诃迦叶，在说付法偈后，复将金缕僧伽黎衣传付与他。因此历代诸祖传法，亦必授衣，成为禅宗大法授受的正传。至菩提达磨大师到中国传法授衣为第二十八传。
    菩提达磨大师在河南嵩山少林寺面壁九年后，欲返天竺，乃命门人曰：“时将至矣，汝等盍各言所得乎？”门人道副对曰：“如我所见，不执文字，不离文字，而为道用。”祖曰：“汝得吾皮。”尼总持曰：“我今所解，如庆喜见阿閦佛国，一见更不再见。”师曰：“汝得吾肉。”道育曰：“四大本空，五阴非有，而我见处，无一法可得。”师曰：“汝得吾骨。”最后慧可礼拜，依位而立。师曰：“汝得吾髓。”乃顾慧可而告之曰：“昔如来以正法眼付迦叶大士，辗转嘱累，而至于我。我今付汝，汝当护持。并授汝袈裟，以为法信。各有所表，宜可知矣。”（见《景德传灯录》卷第一）
    从道副等三人的答话和慧可的表态来看，其他三人落于言诠，慧可超脱无依，高深莫测。承受大法和接受金缕僧伽黎衣，当然落在慧可身上，成为中国禅宗正传的第二祖。道副等三人，则为初祖的旁传法嗣了。
    道副、尼总持、道育三禅师，因无机缘语句，也就无所叙述。

    二祖慧可大师旁传十七人，介绍三人。
    １.僧那禅师，姓马氏，少年神俊，喜欢研究儒家的经典著作。二十一岁讲说《礼记》、《易经》等，听者如集市。会遇二祖说法，感其玄妙，便与同志十人，投可祖出家，奉头陀行。他对门人慧满说：“汝欲明本心者，当审谛推察，遇声遇色，未起觉观时，心何所之，是无耶？是有耶？既不堕有无处所，则心珠独朗，常照世间，而无一尘许间隔，未尝有一刹那顷断续之相。”（见《指月录》卷六）这实际就是，以无相的孤明心体，朗照世间万法。他还把四卷《楞伽经》传付给慧满，教他宜善护持，非人慎勿传之。僧那付法以后，游方行化，莫知其终。
    ２.向居士，是一个幽栖林野、木食涧饮的清士。北齐天保初，闻二祖盛化，乃致书通好。书中有“幻化非真，谁是谁非，虚妄无实，何空何有？将知得无所得，失无所失”之句。二祖写信答他说：“……无明智慧等无异，当知万法即皆如。……观身与禅不差别，何须更觅彼无余。居士捧读二祖书信，乃伸礼觐，密承印记。
    ３.相州隆化寺慧满禅师，是荥阳人，姓张氏。初于本寺遇僧那禅师，开示法要，志存俭约，常行乞食。尝示人曰：“诸禅说心，令知心相是虚妄；今乃重加心相，深违佛意；又增论议，殊乖大理。”常持《楞伽经》四卷，以为心要，如说而行，盖遵历世之遗付耳。后于陶冶中，无疾坐化，寿七十许。
    其余还有十四人不录，名见《景德传灯录》卷第三、《传法正宗记》卷十八等。学者可翻阅参考。

    三祖僧璨大师无有旁传。

    四祖道信大师旁出法嗣一人。
    牛头山法融禅师为四祖道信大师旁出。融（５９４-６５７），润州延陵人，以隋开皇十四年（５９４）生，十九岁即博通经史，寻阅大部《般若》，知儒道世典非究竟法，遂入茅山，从三论宗的灵法师出家。后入金陵牛头山幽栖寺北岩之石室枯坐，感百鸟衔花之瑞。唐贞观中，四祖道信大师遥观气象，知彼山有奇异之人，乃躬自寻访，相与问答之后，融礼请祖为说真要。祖曰：“夫百千法门，同归方寸，河沙妙德，总在心源。一切戒门、定门、慧门，神通变化，悉自具足，不离汝心。一切烦恼业障，本来空寂。一切因果，皆如梦幻。无三界可出，无菩提可求。人与非人，性相平等。大道虚旷，绝思绝虑。如是之法，汝今已得，更无缺少，与佛何殊？更无别法，汝但任心自在，莫作观行，亦莫澄心，莫起贪瞋，莫怀感虑，荡荡无碍，任意纵横，不作诸善，不作诸恶，行住坐卧，触目遇缘，总是佛之妙用。快乐无忧，故名为佛。”师曰：“心即具足，何者是佛？何者是心？”祖曰：“非心不问佛，问佛非不心。”师曰：“既不许作观行，于境起时，心如何对治？”祖曰：“境缘无好丑，好丑起于心。心若不强名，妄情从何起？妄情既不起，真心任遍知。汝但随心自在，无复对治，即名常住法身，无有变异。吾受璨大师顿教法门，令付于汝。汝今谛受吾言，只住此山。向后当有五人达者，绍汝玄化。”师自尔法席大盛。
    唐永徽中，徒众乏粮，师往丹阳缘化。去山八十里，躬负米一石八斗，朝去暮还，供僧三百，二时不缺。三年，邑宰萧元善请于建初寺讲《大般若经》，听者云集。显庆二年（６５７）闰正月二十三日终于建初。寿六十四，葬于鸡笼山。
    在禅宗史上，称法融一系为牛头禅，法门极盛，著有《心铭》（载《景德传灯录》卷三十）。门弟子有道纂、道凭、智岩、昙璀等十三人。此派是道信下别自建立的“于空处显示不空妙生”之一派，为中国禅宗分派的嚆矢，是值得注意的一个禅派。其弟子中智岩传其衣钵，以次传慧方、法持、智威、慧忠。自法融至慧忠六世，是为“牛头六祖”。慧忠下有维则，则下有云居智。又智威之门有玄素，素下有道钦。钦开径山，受唐代宗之信仰，赐号国一。钦门有鸟窠道林，因与白居易问答而驰名。牛头门风，振盛于唐，后遂不振，递传数代而绝。牛头禅明诸法如梦，以休心不起，本来无事为悟，忘情为修。如宗密之《中华传心地禅门师资承袭图》说：“牛头宗意者，体诸法如梦，本来无事，心境本寂，非今始空，迷之为有，即见荣枯贵贱等事。事迹既有相违相顺，故生爱恶等情，情生则为诸苦所系。梦作梦受，何损何益，有此能了之智，亦如梦心。乃至设有一法过于涅槃，亦如梦如幻。既达本来无事，理宜丧己忘情。情忘即绝苦因，方度一切苦厄，此以忘情为修也。”即此可见其宗风。
    南宗诸师，对牛头一派禅风颇有异词。如《景德传灯录》卷九载黄檗希运禅师说：“夫出家人，须知有从上来事分。且如四祖下牛头融大师，横说竖说，犹未知向上关捩子。有此眼脑，方辨得邪正宗党。”此举一例，可知其余了。

    五祖弘忍大师，旁出法嗣共十三人。即北宗神秀、嵩岳慧安、蒙山道明、扬州昙光、随州禅慥、金州法持、资州智侁、舒州法照、越州义方、枝江道俊、常州玄赜、越州僧达、白松山刘主簿。这里简略地介绍神秀、慧安、道明三禅师如下：
    １.北宗神秀禅师，开封尉氏人，俗姓李氏，少年精研儒业，博学多闻，不久舍弃所学，出家寻师访道，至蕲州双峰东山寺，遇五祖弘忍大师，专以坐禅为务，乃叹服曰：“此真吾师也。”于是誓心苦节，以打柴担水自役，而求其道。五祖默识之，深加器重，请为七百人的教授师。五祖对神秀说：“吾度人多矣，至于悟解，无及汝者。”观其得法偈：“身是菩提树，心如明镜台，时时勤拂拭，勿使惹尘埃。”主渐悟之法。渐次拂拭烦恼，以入于菩提。以“伏心灭妄”为修行宗旨。五祖寂后，秀遂往江陵当阳山玉泉寺，高扇宗风大弘禅法。唐天授二年（７０１），则天武后闻其名，请至宫中，于内道场供养，武后对之行跪拜礼。当时王公士庶，皆望尘拜伏。及中宗即位，尤加礼敬。大臣张说尝问法要，执弟子礼。师有偈示众曰：“一切佛法，自心本有。将心外求，舍父逃走。”神龙二年（７０６）二月二十八日于东都天宫寺入灭，春秋百岁，谥大通禅师。羽仪法物，送殡于龙门，帝送到桥，王公士庶皆送至葬所。张说及征士卢鸿一各为碑诔。门人普寂、义福等并为朝野所重。
    神秀的得道弟子十九人，其中以普寂、义福、敬贤、巨方、香育最为有名。普寂后来也被谥为大慧禅师，其弟子四十六人，其中有道璇，于日本圣武天平八年（７３６）东渡日本，传北宗禅于日大安寺行表，行表传其法于传教大师。义福（６５８-７３６）和普寂共传道二十年，寂后谥大智禅师。北宗一系因有二人的弘传，一时颇盛。普寂、义福即为第七祖。
    在禅宗史上，一般称慧能一系的禅法为“南宗禅”，一云“南顿”；称神秀一系的禅法为“北宗禅”，一云“北渐”，故有“南能北秀”或“南顿北渐”之称。北派数传即衰，独南派盛行不替。因此后世的禅宗，均属慧能一系。
    ２.嵩岳慧安国师，荆州枝江人，姓卫氏，得法于黄梅五祖。行头陀行，遍历名胜。麟德元年（６６４）游终南山石壁，认为是息身之处，遂驻锡如此。自尔从他习禅者辐辏相接。有坦然、怀让二僧来参礼，问曰：“如何是自己意？”师曰：“当观密作用。”曰：“如何是密作用？”师以目开合示之。坦然于言下知归，更不他去。怀让机缘不逗，辞往曹溪。
    隋炀帝尝征诏，慧安辞不赴诏。及唐高宗诏，师亦不赴。武后时，以师礼迎请至辇下，与神秀禅师同加钦重。后尝问师：“甲子多少？”师曰：“不记。”后曰“何不记耶？”师曰：“生死之身，其若循环。环无起尽，焉用记为？况此心流注，中间无间。见沤起灭者，乃妄想耳。从初识生至动相灭时，亦只如此。何年月而可记乎？”后闻稽颡信受。中宗即位，益加钦礼。时人尊称他为“老安国师”。
    神龙三年（７０７）师辞归嵩岳，三月三日以后事嘱门人。至八日，闭户偃身而寂，春秋一百二十八。门人遵旨，舁置林间，野火自燃，得舍利八十粒，内五粒色紫，留于宫中。至先天二年（７１３），建塔供奉。
    ３.袁州蒙山道明禅师，鄱阳人，是陈宣帝之裔孙，国亡，落于民间。因其是王孙，尝受官署，因有将军之号。少年时于永昌寺出家，慕道心切，遂往依五祖法会，极意研寻，初无解悟。及闻五祖密付衣法与卢行者慧能，即率同志数十人，蹑迹追逐，至大庾岭，师最先见，余辈未及。卢见师奔至，即掷衣钵于磐石曰：“此衣表信，可力争耶！任君将去。”师遂举之，如山不动，踟躇悚栗，乃曰：“我来求法，非为衣也。愿行者开示于我！”卢曰“不思善，不思恶，正凭么时，阿哪个是明上座本来面目？”师当下大悟，遍体汗流，泣礼数拜，问曰：“上来密语密意外，还更别有意旨否？”卢曰：“我今与汝说者，即非密也。汝若返照自己面目，密在汝边。”师曰：“某甲虽在黄梅随众，实未省自己面目。今蒙指授入处，如人饮水，冷暖自知。今行者即是某甲师也。”卢曰：“汝若如是，则是吾与汝同师黄梅，善自护持。”师又问：“某甲向后宜往何所？”卢曰：“逢袁可止，遇蒙即居。”师礼谢，即回岭下。独往庐山布水台，三年后，始往袁州蒙山，大唱玄机。师初名慧明以避六祖讳，改名道明。座下诸弟子，尽遣往岭南，参礼六祖。
    上来已简略介绍旁传的善知识七人，其余未叙述者，或于史书中已立传，或唯列其名，可于《传灯录》、《广灯录》、《传法正宗记》等书中参考之。


五禅宗门下的楞伽师

    禅宗初祖达磨大师，在向二祖慧可传法时说：“昔如来以正法眼付迦叶大士，辗转嘱累而至于我，我今付汝，汝当护持。并授汝袈裟以为法信，各有所表，宜可知矣。”又曰：“吾有《楞伽经》四卷，亦用付汝，即是如来心地要门，令诸众生，开示悟人。”这是《景德传灯录》的记述。达磨传法授衣后，还传授了《楞伽经》四卷，并说明此经是如来心地要门，要二祖慧可弘传，开示众生悟人。指出了《楞伽经》对参禅者的重要性。
    但是达磨大师又说，他所传授的禅法，是“不立文字，教外别传，直指人心，见性成佛”。指出了禅的立宗基础及体验的方法。既然是“教外别传”，故无所依的经典；既然是“不立文字”，故也没有文字上构思推究的理论，只以“见性”一事为“成佛”之道。根据这些教导，所以禅宗接化学人，都是用解粘去缚的方法，应病与药，使学人直悟，冷暖自知，以心传心，师资默契而已。禅的主眼，是亲证真如法界，不是一种真理的概念，这必须如实体验，始得理会。故说禅是“不立文字，教外别传”，但也并不轻视经典。如中峰和尚在《山房夜话》里说：“譬如四序成一岁之功，而春夏秋冬之令，不容不别也。其所不能别者，一岁之功也。密宗，春也；天台、贤首、慈恩等宗，夏也；南山律宗，秋也；少林单传之宗，冬也。就理言之，但知禅为诸宗之别传，而不知诸宗亦禅之别传也。会而归之，密宗乃宣一佛大慈悲拔济之心也；教宗乃阐一佛大智开示之心也；律宗乃持一佛大行庄严之心也；禅宗乃传一佛大觉圆满之心也。”日本临济宗的创建者荣西禅师在《兴禅护国论》里说：“与而论之，一大藏教，皆是禅所依之经典；夺而言之，无有一言为禅所依之经典。”扫除了禅教的矛盾。教即是禅，禅即是教，故教无可舍，一切教都是禅。所以禅宗对经典的看法，亦自和其他各宗不同，可取则取，可舍则舍，不受任何束缚，自由任用。凡有助于禅旨的举扬，三藏教典，拈来就用，用罢即了。这是禅的经教观。如四时、五时教或三时教的分类，悉非所问，是之谓“不立文字，教外别传”。在参禅者自己用功方面来说，有时也须要看经教，所谓“以教照心”，就是根据经典所说的思想，来对照自己的体验，鉴定其正确与否。从这点来说，禅人也有应用经教的时候，古来禅门大德，从看经教而开悟的亦大有人在。所以“不立文字”，不等于不用文字。因此，初祖达磨大师传《楞伽经》四卷给二祖慧可大师，是有其深远用意的。
    禅宗的正式建立是从六祖慧能大师开始的。在这之前，从初祖达磨至五祖弘忍及其旁出诸大德，都称为楞伽师。下面简略介绍一下这方面的情况。
    毫无疑问，达磨大师本人是受持《楞伽经》的。《楞伽师资记》说初祖“谓慧可曰，有《楞伽经》四卷，仁者依行，自然度脱”。又说：慧可“记师言行，集成一卷，名之《达磨论》也。菩提师又为坐禅众释《楞伽》要义一卷，有十二三纸，亦名《达磨论》也。此两本论文，化理圆满，天下流通。”如果达磨大师自己不受持《楞伽经》，怎能将此经传授给慧可，并为坐禅众解释《楞伽》要义？所以达磨大师是受持和传授《楞伽经》的初祖。
    二祖慧可大师，在承受《楞伽经》之后，即于邺都随宜说法，一音演畅，四众归依，如此积化三十四载。《楞伽师资记》说二祖曾引《楞伽经》云：“牟尼寂静观，是则远离生死，是名为不取。今世后世，净十方诸佛，若有一人，不因坐禅而能成佛者，无有是处。”这说明二祖对《楞伽经》的重视。《景德传灯录》卷三在二祖旁出的僧那禅师传中说：“故我初祖兼付《楞伽经》四卷，谓我二祖曰：‘吾观震旦，唯有此经，可以印心，仁者依行，自得度世’。”又二祖凡说法竟乃曰：“此经四世之后，变成名相，深可悲哉！我今付汝，宜善护持，非人慎勿传之。”从僧那禅师对二祖传过《楞伽经》与他的叙述中，可知不但传法授衣，还必须兼付《楞伽经》四卷，而且慎重告诫：“宜善护持，非人慎勿传之”，可见其对《楞伽经》之尊重珍视，慎其传授了。同时还说明，六祖以前的禅宗传法，不但对正传付与《楞伽经》，对旁出也毫无例外地传法必授经。《灯录》还在二祖旁出的慧满禅师传中说：“常赉《楞伽经》四卷，以为心要，如说而行，盖遵历世之遗付也”。慧满禅师所持《楞伽经》当然是从二祖那里承受而得，并且如说而行，是遵行历世之遗付，既显示了参禅者遵从禅门历世的遗付，重视《楞伽经》的印证，也说明达磨大师所说入道的“二人四行”与《楞伽》宗旨是一致的。
    三祖僧璨大师，受二祖传法授衣后，《灯录》说他隐于舒州之皖公山，值北周武帝破灭佛法，师往来太湖县司空山，居无常处，积十余载，时人无能知者。后来为世民所知，奔趋礼拜，大设斋供法会，他为四众广宣心要，即于法会中在大树下，合掌立终。所谓广宣心要者，也可以理解为宣扬《楞伽经》的微妙第一真实了义教。因为达磨付《楞伽经》给二祖慧可时，曾说此经“即是如来心地要门，令诸众生，开示悟人。”《楞伽师资记》也把璨大师列入师资之一。并说“可后璨禅师，隐思空山，萧然静坐，不出文记。这与《灯录》所说“积十余载，时人无能知者”是一致的。璨大师重在“静坐”，对经教妙谛，不广为宣传，但时节因缘成熟时（即北周武帝灭佛之事已过去），还是广为四众宣扬心要。
    四祖道信大师，《楞伽师资记》上是这样说的：“唐朝蕲州双峰山道信禅师承璨禅师后。其信禅师，再敞禅门，宇内流布，有《菩萨戒法》一本，及《制入道安心要方便法门》，为有缘根熟者，说我此法，要依《楞伽经》，诸佛心第一。”此后还举出四祖引证的《文殊说般若经》、《华严经》等多种经教，阐述参禅办道的微妙方法。在《灯录》上说：“既嗣祖风，摄心无寐，胁不至席者，凡六十年。”说他在隋大业十三年（６１７），于吉州教群众念“摩诃般若波罗蜜”，因而使围城之兵自动退却。可见信祖在大弘禅法的同时，也大弘《楞伽经》和别的经教，故《楞伽师资记》将他列为宗祖之一。
    五祖弘忍大师，在《楞伽师资记》中说：承信禅师后，忍传妙法，人尊为东山法门。又缘京洛道俗称叹，蕲州东山多有得果人，故称东山法门。又说，其弟子玄赜亲受付嘱而撰写《楞伽人法志》一书。如《师资记》说：“玄赜以咸亨元年（６７０），至双峰山，恭承教诲，恭奉驱驰，首尾五年，往还三觐，道俗齐会，仂身供养，蒙示《楞伽》义云：此经唯心证乃知，非文疏能解。”又记弘忍大师之语云：“如吾一生教人无数，好者并亡，后传吾道者，只可十耳。我与神秀论《楞伽经》，玄理通快，必多利益。资州智侁、白松山刘主簿，兼有文性，莘州慧藏、隋州玄约，忆不见之。嵩山老安，深有道行，潞州法如、韶州慧能、扬州高丽僧智德，此并堪为人师，但一方人物。越州义方，仍便讲说，又语玄赜曰：汝之兼行，善自保爱，吾涅槃后，汝与神秀，当以佛日再晖，心灯重照。”这些记述，说明《楞伽经》在忍大师弘扬下，已成为最有名的正宗禅学了。到神秀做国师时，由于他自称是“东山法门”的楞伽宗的一派，楞伽宗发展到势不可当了。
    如上所说，可知从初祖到五祖的正传和旁出，都称为楞伽师，到五祖下神秀做国师时，秀大师自称是楞伽宗的一派，并说明他传授的世系，是出于蕲州东山法门。他的世系表见于张说作的大通（神秀谥号）禅师碑铭：“达磨-慧可-僧璨-道信-弘忍-神秀”。神秀做了六年（７０１-７０６）国师，已经使楞伽宗成为禅学的正宗了。在神秀圆寂后，他的弟子普寂、义福的地位更加崇高，使楞伽宗已成为当时佛教界盛况空前的宗派了。玄赜的《楞伽人法志》，就是叙述楞伽师的宗门谱系。此书虽然已不传，但它却是禅宗最早的史书。玄赜的弟子净觉撰写《楞伽师资记》，以宗奉《楞伽经》，故推四卷本《楞伽经》译者求那跋陀罗为初祖，降达磨于第二，共介绍了历代传灯的八代，即于神秀之后加玄赜、普寂。如《师资记》最后说：“自宋代以来，大德师代代相承，起自宋求那跋陀罗三藏，历代传灯，至于唐朝总八代，得道获果，有二十四人也。”禅宗五祖弘忍已开始重视《金刚经》，而六祖慧能则大力弘演《金刚经》，另辟蹊径，时号南宗，称神秀一系为北宗。
    楞伽宗托始于初祖菩提达磨，达磨来自南印度，《楞伽经》正是南方经典，所以教人只读《楞伽经》。慧可以下，承袭此风，就成为楞伽宗，又称为南天竺一乘宗。
    《楞伽经》有四种译本：北凉昙无谶译《楞伽经》四卷，宋求那跋陀罗译《楞伽阿跋多罗宝经》四卷，元魏菩提流支译《入楞伽经》十卷，唐实叉难陀译《大乘入楞伽经》七卷。楞伽师以忘言忘念，无得正观为宗。其宗旨传承疏注等事，如《续高僧传·法冲传》中说：
    “冲以《楞伽》奥典，沉沦日久，所在追访，无惮夷险。会可师后裔盛习此经，即依师学，屡击大节。便舍徒众，任冲转教。即相续讲三十余遍。又遇可师亲传授者，依南天竺一乘宗讲之，又得百遍。其经本是宋代求那跋陀罗三藏翻，慧观法师笔受，故其文理克谐，行质相贯。专唯念慧，不在话言。于后达磨禅师传之南北，忘言忘念，无得正观为宗。后行中原，慧可禅师创得纲纽，魏境文学多不齿之。领宗得意者时能启悟，今以人代转远，纰缪后学，可公别传略以详之。今叙师承，以为承嗣，所学历然有据。
    （１）达磨禅师后有慧可、慧育二人，育师受道心行，口未曾说。
    （２）可禅师后，粲禅师、惠禅师、盛禅师、那禅师、端禅师、长藏师、真法师、玉法师。以上并口说玄理，不出文记。
    （３）可师后，善师（出抄四卷）、丰禅师（出疏五卷）、明禅师（出疏五卷）、胡明师（出疏五卷）。
    （４）远承可师后，大聪师（出疏五卷）、道荫师（抄四卷）、冲法师（疏五卷）、岸法师（疏五卷）、宠法师（疏八卷）、大明师（疏十卷）。
    （５）不承可师、自依《摄论者》，迁禅师（疏四卷）、尚德律师（出《传入楞伽》十卷）。
    （６）那老师后，实禅师、惠禅师、旷法师、宏智师（名住京师西明，身亡法绝）。
    （７）明禅师后，伽法师、宝瑜师、宝迎师、道莹师（并次第传灯，于今扬化）。
    冲公自从经术，加以《楞伽》命家，前后敷弘，将二百遍，须便为引，曾未涉文。……师学者苦请出义，……事不获已，作疏五卷，题为私记，今盛行之。”
    法冲唐高宗麟德时年七十九，上推其出生年代约当隋文帝开皇六年（５８６）。道宣晚年认识法冲，对《法冲传》的材料尚未整理，就圆寂了。但读了《法冲传》中如上所引的一般记述，对楞伽宗的传承及《楞伽经》的弘扬注疏等事有了大概的了解。


六禅宗的五家七派

    这里所说的禅宗五家七派，都是指的南宗慧能以下分宗分派的情况。自初祖达磨五传而至五祖弘忍，忍之下分北宗神秀与南宗慧能二派。北宗行于北地，数传而绝。南宗行于南地，普传既广，改变了师弟单传的做法，往往一师传几个弟子，各为一家。于是愈衍愈繁，禅风遍于全国，各务其师之说，竞自为家，遂为沩仰、临济、曹洞、云门、法眼五家。七派者，在五家中的临济宗第六代石霜楚圆下分为黄龙慧南与杨歧方会二派，是为五家七派。其中沩仰早歇，曹洞仅存，而云门、临济、法眼三家，在宋朝还很盛。到清末民初，临济则遍天下，曹洞仅一角了。然其宗派的兴衰，非法有强弱，在得人不得人耳。五家七派之分，唯以家风不同而有差别，不是宗旨或教义有差异。今将五家分派之系统，列表如下 。

    （一）沩仰宗
    沩仰宗是慧能为代表的禅宗中最先成立的一个宗派，由于此宗的开创者灵祐和他的弟子慧寂，先后在潭州的沩山（今湖南省宁乡县西）、袁州的仰山（今江西省宜春县南），举扬一家的宗风，后世就称为沩仰宗。
    灵祐禅师是福州赵氏子，十五岁依本郡建善寺法常律师出家，于杭州龙兴寺受戒，二十三岁游江西，参礼百丈怀海禅师。一日侍立至深夜，百丈云：“汝拨炉中有火否？”师拨云：“无火。”百丈起身深拨得少火，举以示之曰：“此不是火？”师由是发悟，礼谢陈其所解。百丈曰：“此乃暂时歧路耳。经云：欲识佛性义，当观时节因缘。时节既至，如迷忽悟，如忘忽忆，方省己物不从他得。故祖师云：悟了同未悟，无心亦无法。只是无虚妄凡圣等心，本来心法元自备足。汝今既尔，善自护持。”
    仰山慧寂禅师，韶州怀化人，姓叶氏。年十五欲出家，父母不许。后二载，师断手二指，跪父母前，誓求正法，以报答父母劬劳之恩，父母乃许。遂依南华寺通禅师落发，未受具足戒即游方。初谒耽源，已悟玄旨。后参沩山，遂升堂奥。耽源谓师曰：“国师（慧忠）当时传得六代祖师圆相，共九十七个，授与老僧。乃曰：‘吾灭后三十年，南方有一沙弥到来，大兴此教，次第传授，无令断绝。’我今付汝，汝当奉持。”遂将其本过与师。师接得一览，便将火烧却。耽源一日问：“前来诸相，甚宜秘惜。”师曰：“当时看了便烧却也。”源曰：“吾此法门无人能会，唯先师及诸祖师、诸大圣人方可委悉，子何得焚之？”师曰：“慧寂一览，已知其意。但用得不可执本也。”源曰：“然虽如此于子即得，后人信之不及。”师曰：“和尚若要重录不难，即重集一本呈上，更无遗失。”源曰：“然。”耽源上堂，师出众，作此“○”相以手托呈了，却叉手立。源以两手相交，作拳示之。师进前三步，作女人拜。源点头，师便礼拜。
    参礼沩山灵祐禅师时，沩问：“汝是有主沙弥，无主沙弥？”师曰：“有主。”曰：“主在什么处？”师从西过东立，沩知是异人，便垂开示。师问：“如何是真佛住处？”沩曰：“以思无思之妙，返思灵焰之无穷，思尽还源，性相常住，事理不二，真佛如如。”师于言下顿悟。自此执侍前后，盘桓十五载（见《五灯会元》卷九。不久往江陵受具足戒，住夏探究律藏（见《景德传灯录》卷十一）。
    沩仰宗的家风，审细密切，师资唱和，事理并行。体用语似争而默契。《人天眼目》说：“沩仰宗者，父慈子孝，上令下从；你欲吃饭，我便捧羹；你欲渡江，我便撑船；隔山见烟，便知是火；隔墙见角，便知是牛。”亦方圆默契之意。《五家参详要路门》说：“沩仰宗明作用。”如普请摘茶的时候，沩山问仰山曰：“终日摘茶，只闻子声，不见子形，请现本形相见。”仰山摇撼茶树。沩山说：“子只得其用，不得其体。”仰山说：“未审和尚如何？”沩山良久不语。仰山说：“和尚棒某甲吃，某甲棒教谁吃？”沩山曰：“放子三十棒。”此即“明作用论亲疏为旨”的意趣。又如《归心录》说：“沩仰家风，机用圆融，室中验人，句能陷虎。”又《五家宗旨纂要》说：“沩仰宗风，父子一家，师资唱和。语默不露，明暗交驰，体用双彰，无舌人为宗，圆相明之。”
    在禅宗五家中，沩仰宗最早兴起，但衰亡也较早。其法脉流传约一百五十年。

    （二）临济宗
    临济宗是禅宗五家中继沩仰宗之后而成立的一个宗派，由于开创此宗的义玄禅师，在河北镇州（今河北省正定县）的临济院，举扬一家宗风，后世就称为临济宗。
    临济义玄禅师曹州南华人，姓邢氏，幼负出尘之志，及落发进受具戒，便慕禅宗。起初在黄檗希运禅师会下随众参侍，行业纯一。时睦州为第一座，见师行止乃叹曰：“虽是后生，与众有异。”遂问：“上座在此多少时候？”师曰：“三年。”州曰：“曾经参问过和尚吗？”师曰：“不曾参问，不知问个什么？”州曰：“何不问堂头和尚，如何是佛法的大意？”师便去。问声未绝，黄檗便打。师下来，州曰：“问话作么生？”师曰：“某甲问声未绝，和尚便打，某甲不会。”州曰：“便更去问。”师又问，黄檗又打。如是三度问，三度被打。遂向州告辞曰：“早承激劝问法，累承和尚赐棒，自恨障缘，不领深旨。今且辞去，往诸方行脚参访。”州曰：“汝若去，须辞和尚了去。”师礼拜退。州先到黄檗处曰：“问话上座，虽是后生，却甚奇特。若来辞，方便接引。已后为一株大树覆荫天下人去在。”师来日辞黄檗，檗曰：“不须他去，只往高安滩头参大愚，必为汝说。”
    师到大愚，愚曰：“什么处来？”师曰：“黄檗来。”愚曰：“黄檗有何言句？”师曰：“某甲三度问佛法的大意，三度被打。不知某甲有过无过？”愚曰：“黄檗恁么老婆心切，为汝得彻困，更来这里问有过无过？”师于言下大悟。乃曰：“元来黄檗佛法无多子。”愚掐住曰：“这尿床鬼子，适来道有过无过，如今却道黄檗佛法无多子。你见个什么道理？速道！速道！”师于大愚肋下筑三拳，愚拓开曰：“汝师黄檗，非干我事。”
    师辞大愚，却回黄檗。檗见便问：“这汉来来去去，有甚了期？”师曰：“只为老婆心切。便人事了。”侍立，檗问：“甚处去来？”师曰：“昨蒙和尚慈旨，令参大愚去来。”檗曰：“大愚有何言句？”师举述前话。檗曰：“遮大愚老汉，待来见与打一顿。”师曰：“说甚待见，即今便打。”随后便掌。檗曰；“这疯癫汉来这里捋虎须。”师便喝。檗唤侍者曰：“引这疯癫汉参堂去。”后来沩山举此话问仰山云：“临济当时得大愚力？得黄檗力？”仰云：“非但骑虎头，亦解把虎尾。”
    临济与黄檗一起栽松时，檗曰；“深山里栽许多松作甚么？”师曰：“一与山门作境致，二与后人作标榜。”说了将锄头打地三下。黄檗曰：“虽然如是，子已吃吾三十棒了也。”师又以锄头打地三下，作嘘嘘声。黄檗曰：“吾宗到汝，大兴于世。”
    师后住河北镇州临济禅院，学侣云集。一日，谓普化、克符二上座曰：“我欲于此建立黄檗宗旨，汝且成褫我。”二人珍重下去。三日后，普化却上来问：“和尚三日前说甚么？”师便打。三日后克符上来问：“和尚前日打普化作甚么？”师亦打。
    师上堂说：“汝等诸人，赤肉团上有一无位真人，常向汝诸人面门出入，未证据者看看。”当时有个僧人问：“如何是无位真人？”师下禅床把住云：“道！道！”僧拟议，师拓开曰：“无位真人，是什么干屎橛。”便归方丈。
    师接引学人有三玄（三种原则）、三要（三种要点），四料简（四种简别）等施设。师上堂时说：“山僧今日见处，与祖佛不别。若第一句中荐得，堪与祖佛为师。若第二句中荐得，堪与人天为师。若第三句中荐得，自救不了。”僧便问：“如何是第一句？”师曰：“三要印开朱点窄，未容拟议主宾分。”曰：“如何是第二句？”师曰：“妙解岂容无著问，沤和争负截流机。”曰：“如何是第三句？”师曰：“但看棚头弄傀儡，抽牵全藉里头人。”乃曰：“大凡演唱宗乘，一句中须具三玄门，一玄门须具三要。有权有实，有照有用。汝等诸人作么生会？”
    师小参时指示接引学人方法云：“有时夺人不夺境，有时夺境不夺人，有时人境两俱夺，有时人境俱不夺。”诸方目此为四料简。
    师接化学人常用棒唱，他说：“有时一喝如金刚王宝剑，有时一喝如踞地狮子，有时一喝如探竿影草，有时一喝不作一喝用。汝作么生会？”僧拟议，师便喝。（见《五灯会元》卷十一）
    师示众曰：“我有时先照后用，有时先用后照，有时照用同时，有时照用不同时。先照后用有人在，先用后照有法在，照用同时，驱耕夫之牛，夺饥人之食，敲骨取髓，痛下针锥。照用不同时，有问有答，立宾立主，合水合泥，应机接物。若是过量人，向未举已前，撩起便行，犹较些子。”师见僧来，举起拂子。僧礼拜，师便打。又有僧来，师亦举拂子。僧不顾，师亦打。又有僧来参，师举拂子。僧曰：“谢和尚指示。”师亦打。
    师示众曰：“参禅之人，大须子细。如宾主相见，便有言论往来。或应物现形，或全体作用，或把机权喜怒，或现半身，或乘狮子或乘象王，如有真正学人便喝。先拈出一个胶盆子，善知识不辨是境，便上他境上作模作样，便被学人又喝，前人不肯放下，此是膏肓之病，不堪医治，唤作宾看主。或是善知识，不拈出物，只随学人问处即夺，学人被夺，抵死不肯放，此是主看宾。或有学人应一个清净境，出善知识前，知识辨得是境，把得抛向坑里。学人言：大好善知识。知识即云：咄哉！不识好恶。学人便礼拜。此唤作主看主。或有学人，披枷带锁，出善知识前，知识更与安一重枷锁。学人欢喜，彼此不辨，唤作宾看宾。大德，山僧所举，皆是辨魔拣异，知其邪正。”
    师云：“山僧无一法与人，只是治病解缚。尔取山僧口里语，不如休歇无事去。”“你若能歇得念念驰求心，便与祖佛不别。”师示众云：“今时学佛法者，且要求真正见解，若得真正见解，生死不染，去住自由，不要求殊胜，殊胜自至。”又说：“大德！三界无安，犹如火宅。此不是你久停住处，无常杀鬼，一刹那间，不择贵贱老少。尔要与祖佛不别，但莫外求。尔一念清净心光，是尔屋里法身佛；一念无分别心光，是尔屋里报身佛；一念无差别心光，是尔屋里化身佛。此三种身，是尔即今目前听法的人，只为不向外驰求，有此功用。”
    唐咸通八年（８６７）丁亥四月十日，将示灭，说传法偈曰：
    临流不止问如何，真照无边说似他。
    离相离名人不禀，吹毛用了急须磨。
    复谓众曰：“吾灭后，不得灭却吾正法眼藏。”三圣出曰：“争敢灭却和尚正法眼藏？”师曰：“已后有人问，你向他道甚么？”圣便喝。师曰：“谁知吾正法眼藏，向这瞎驴边灭却。”言讫，端坐而逝。塔全身于大名府西北隅，谥慧照禅师，塔曰澄灵。
    临济宗的家风，机用峻烈，自古有“临济将军，曹洞土民”之称。意谓临济宗似指挥百万师旅之将军，如以铁锤击石，现火光闪闪之机用。故《五家参详要路门》说：“临济宗战机锋。”指出义玄，最初入处痛快，悟后参禅瞥脱。虽有五家各立宗旨，但初中后事，头正尾正，中兴如来正法眼藏，明了祖师西来密旨者，只此临济一宗最为至当。五祖法演禅师说：“五逆五雷”之喝，一喝之下，头脑破裂，如五逆罪人，为五雷所裂。其禅之峻烈可知。凡僧有问，即喝破，或擒住，拓开等。其接化之热烈辛辣，五家中罕见其比。如《归心录》说：临济家风，白拈手段，势如山崩，机似电卷。又《五家宗旨纂要》说：“临济家风，全机大用，棒喝齐施，虎骤龙奔，星驰电掣。负冲天意气，用格外提持。卷舒纵擒，杀活自在。扫除情见，迥脱廉纤。以无位真人为宗，或棒或喝，或竖拂明之。”
    总起来讲：临济宗接人的方法，单刀直入，机锋峻烈，对学人剿情绝见，使其省悟。此宗流传最广最久，是同它所具备的这些特点分不开的。
    这里引证《人天眼目·临济门庭》之语供学者参考：“临济宗者，大机大用，脱罗笼，出窠臼。虎骤龙奔，星驰电激。转天关，斡地轴，负冲天意气，用格外提持。卷舒纵擒，杀活自在。是故示三玄、三要、四宾主、四料简、金刚王宝剑、踞地狮子、探竿、影草、一喝不作一喝用、一喝分宾主、照用一时行。四料简者：中下根人来，夺境不夺法；中上根人来，夺境夺法不夺人；上上根人来，人境两俱夺；出格人来，人境俱不夺。四宾主者：师家有鼻孔，名主中主；学人有鼻孔，名宾中主。师家无鼻孔，名主中宾；学人无鼻孔，名宾中宾。与曹洞宾主不同。三玄者：玄中玄、体中玄、句中玄。三要者：一玄中具三要，自是一喝中体摄三玄三要也。金刚王宝剑者：一刀挥尽一切情解。踞地狮子者：发言吐气，威势振立，百兽恐悚，众魔脑裂。探竿者：探尔有师承无师承，有鼻孔无鼻孔。影草者：欺瞒做贼，看尔见也不见。一喝分宾主者：一喝中自有宾有主也。照用一时行者：一喝中自有照有用。一喝不作一喝用者：一喝中具如是三玄、三要、四宾主、四料简之类。大约临济宗风不过如此。要识临济么，青天轰霹雳，陆地起波涛。”

    （三）曹洞宗
    曹洞宗是禅宗五家之一。由于此宗开创人良价及其弟子本寂先后在江西高安县洞山、吉水县曹山弘扬一家宗风，后世称为曹洞宗。宗名有两说：一为取六祖慧能所居曹溪及良价所居洞山之名故称曹洞宗；二为取本寂所居曹山及良价所居洞山之名，后人为语音之便，不称洞曹而称为曹洞宗。实则取曹溪与洞山合称更近于情理。
    良价悟本禅师，会稽俞氏子。幼年从师念《般若心经》，至“无眼耳鼻舌身意”处，忽以手扪面，问师曰：“某甲有眼耳鼻舌等，何故经言无？”其师骇然异之，曰：“吾非汝师。”即指往五泄山礼胜默禅师披剃。二十一岁具戒于嵩山后即游方参学。
    首诣南泉，泉赞曰：“此子虽后生，甚堪雕琢。”次谒沩山，问曰：“顷闻南阳忠国师有无情说法话，某甲末究其微。”沩曰：“阇梨莫记得么？”师云：“记得。”沩山云：“试举看。”师举了。沩云：“我这里亦有，只是难得其人。”师云：“乞师指示。”沩竖起拂子点一点曰：“会么？”师曰：“请和尚为某甲说。”沩云：“父母所生口，终不为子说。”师云：“还有与师同时慕道者么？”沩令见云岩。师辞，直到云岩请示前话。岩云；“不见《弥陀经》云：水鸟树林，悉皆念佛念法也。”师因有省，乃述偈呈云岩曰：
    也大奇，也大奇，无情说法不思议，
    若将耳听终难会，眼处闻声方得知。
    一日师问云岩：“某甲有余习未尽。”岩曰：“汝曾作什么来？”师曰：“圣谛亦不为。”岩曰：“还欢喜也未？”师云：“欢喜则不无，如粪扫堆头拾得一颗明珠。”
    师辞云岩，问曰：“百年后忽有人问，还貌得师真否？如何祇对。”岩曰：“但向伊道‘只这个是。’师沉吟。岩云：“价阇梨，承当个事，大须审细。”师犹涉疑。后因过水睹影，大悟“渠正是汝”之旨。因作偈曰：
    切忌从他觅，迢迢与我疏，
    我今独自往，处处得逢渠。
    渠今正是我，我今不是渠，
    应须凭么会，方得契如如。
    僧问：“师寻常人行鸟道，未审如何是鸟道？”师曰：“不逢一人。”曰：“如何行？”师曰：“直须足下无私去。”曰：“只如行鸟道，莫便是本来面目否？”师曰：“阇梨因甚颠倒！”曰：“什么处是学人颠倒？”师曰：“若不颠倒，因甚么却认奴作郎？”曰：“如何是本来面目？”师曰：“不行鸟道。”
    师因曹山辞别，遂嘱咐曰：“吾在云岩先师处，亲印《宝镜三昧》，事穷的要，今付与汝。”词曰：
    如是之法，佛祖密付，汝今得之，宜善保护。
    银碗盛雪，明月藏鹭，类之弗齐，混则知处。
    意不在言，来机亦赴，动成窠臼，差落顾佇。
    背触俱非，如大火聚，但形文彩，即属染污。
    夜半正明，天晓不露，为物作则，用拔诸苦。
    虽非有为，不是无语。如临宝境，形影相睹。
    汝不是渠，渠正是汝，如世婴儿，五相完具。
    不去不来，不起不住，婆婆和和，有句无句，
    终不得物，语未正故。重离六爻，偏正回互，
    叠而为三，变尽成五。如荎草味，如金刚杵。
    正中妙挟，敲唱双举。通宗通途，挟带挟路。
    错然则吉，不可犯忤。天真而妙，不属迷悟。
    因缘时节，寂然昭著。细入无间，大绝方所，
    毫忽之差，不应律吕。今有顿渐，缘立宗趣，
    宗趣分矣，即是规矩。宗通趣极，真常流注。
    外寂中摇，系驹伏鼠，先圣悲之，为法檀度。
    随其颠倒，以缁为素。颠倒想灭，肯心自许。
    要合古辙，请观前古。佛道垂成，十劫观树，
    如虎之缺，如马之馵。以有下劣，宝几珍御。
    以有惊异，狸奴白牯。羿以巧力，射中百步。
    箭锋相直，巧力何预。木人方歌，石女起舞。
    非情识到，宁容思虑。臣奉于君，子顺于父。
    不顺非孝，不奉非辅。潜行密用，如愚若鲁。
    但能相续，名主中主。
    师作《五位君臣颂》曰：
      正中偏，三更初夜月明前。
      莫怪相逢不相识，隐隐犹怀昔日嫌。
      偏中正，失晓老婆逢古镜。
      分明觌面别无真，休更迷头犹认影。
      正中来，无中有路出尘埃。
      但能不触当今讳，也胜前朝断舌才。
      兼中至，两刃交锋要回避。
      好手犹如火里莲，宛然自有冲天志。
      兼中到，不落有无谁敢和。
      人人尽欲出常流，折合还归炭里坐。
    依曹山本寂的解释，正者是体、是空、是理；偏者是用、是色、是事。正中偏是背理就事，从体起用；偏中正是舍事入理，摄用归体；兼是正偏兼带，理事混融，内外和合，非染非净，非正非偏。
    洞山为了广接上、中、下三根，因势利导，从事理各别交涉的关系上，根据《宝境三昧》所说：“重离六爻，偏正回互，叠而为三，变尽成五”之意立正偏五位以接引、勘验学人。总起来讲，五位有四种：正偏、功勋、君臣、王子。其中正偏五位，功勋五位都是良价的创说，君臣五位，王子五位，则为曹山本寂禅师所立。
    曹洞宗的五位，诸祖语录中大都有所解说。除意义大体相同外，也互有指责，以己说为正，以他义为非者。特详者如《大正藏》第八十二卷的《报恩编》，于五位立说“洞上五位辨的”，广辨五位大义，非他所说，以己说为正。乐广知者，可取阅读。今引《佛学大辞典》第四册所说，以供参考。
    “洞山良价禅师为广接上中下之三根而开五位。其法从《易》之卦爻而来。先以阴阳之爻如下相对。
    —　正也、体也、君也、空也、真也、理也、黑也。
    --偏也、用也、臣也、色也、俗也、事也、白也。
    取离卦回互叠变之而为五位。先言变叠之次第，则离卦如 [image] ，第一重之，则为 [image] 重离卦。第二取重离卦中之二爻，加于上下，则为 [image] 中孚卦。第三取中孚卦中之二爻，加于上下，则为 [image] 大过卦，更取其中之二爻，加于上下，则还于前之重离卦，故三变而止。《宝镜三昧》谓之“叠而为三”。次取单离，以其中爻回于下，则为 [image] 巽卦，以中爻回于上，则为 [image] 兑卦，依之而成前后之五卦。《宝镜三昧》谓之“变尽成五”。以此五卦判证修之浅深，名为功勋之五位；示理事之交涉，名为君臣之五位。功勋之五位，为洞山之本意；君臣之五位，为曹山之发明。又由卦爻之形而图黑白之五位，是亦洞山之发明。
     [image] 巽卦　　 [image] 君住　　正中偏
     [image] 兑卦　　 [image] 臣位　　偏中正
     [image] 大过卦　 [image] 君视臣正中来
     [image] 中孚卦○君视臣正中来
     [image] 重离卦 [image] 君臣合兼中到
    第一正中偏，正者，体也、空也、理也；偏者、用也、色也、事也。正中之偏者，正位之体处，具偏用事相之位也。是能具为体，所具为用，故以能具之体，定为君住。是君臣五位之君位也。学者始认体具之用，理中之事，作有为修行之位，为功勋五位之第一位。配于大乘之阶位，则与地前三贤之位相当。第二偏中正，是偏位之用具正位之体之位也。因之以能具之用定为臣位，即君臣五位之臣位也。在修行上论之则为正认事具之理用中之体，达于诸法皆空真如平等之理之位，即大乘之见道也。第三正中来，是有为之诸法如理、随缘、如性缘起者，即君视臣之位也。学者于此，如理修事，如性作行，是与法身菩萨由初地至七地之有功用修道相当者。第四偏中至（一本作兼中至，《林间录》以之为大谬），是事用全契于体，归于无为者，即臣向君之位也。学者于此终日修而离修念，终夜用而不见功用，即由八地至十地之无功用修道位也。第五兼中到，是体用兼到，事理并行者。即君臣合体之位，而最上至极之佛果也。已上就法而论理之回互，为君臣之五位，就修行上而判浅深，为功勋之五位。《五灯会元》卷十三《曹山本寂禅师》章载：“师因僧问五位君臣旨诀，师曰：‘正位即空界，本来无物。偏位即色界，有万象形。正中偏者，背理就事。偏中正者，舍事入理。兼带者，冥应众缘，不堕诸有，非染非净，非正非偏，故曰虚玄大道，无著真宗。从上先德，推此一位，最妙最玄，当详审辨明。君为正位，臣为偏位。臣向君是偏中正，君视臣是正中偏。君臣道合是兼带语。’”兼带者，言兼中到之一位。白隐之《五家参详要路门》曰：“却怪大圆镜智光黑如漆，此道正中偏一位，于此入偏中正一位，修宝镜三昧多时，果证得平等性智，初入理事无碍法界境致，行者以此不为足，亲入正中来一位，依兼中至真修，获得妙观察智、成所作智等四智。最后到兼中到一位，折合还归炭里坐。”黑白之五相，《五灯会元》以第四偏中至作纯白，第五兼中到造纯黑者非也（是由偏中至误为兼中至而来）。洞山之作有五位显诀，五位逐位颂，功勋五位颂。曹山之作，有解释洞山五位显诀、五位旨诀、黑白五相偈。”
    师又向曹山说：“末法时代，人多乾慧，若要辨验真伪，有三种渗漏：一曰见渗漏，机不离位，堕在毒海。二曰情渗漏，滞在向背，见处偏枯。三曰语渗漏，和妙失宗，机昧终始。浊智流转于此三种，子宜知之。”（《五灯会元》卷十三）曹山本寂禅师拜受而去。唐咸通十年（８６９）三月，师命剃发澡身披衣，击钟俨然坐化。时大众号痛不止，师忽开目谓众曰：“出家人心不附物，是真修行，劳生惜死，哀悲何益。”复令主事办愚痴斋，众犹慕恋不已，延至七日，食具方备，师亦随众斋毕。乃曰：“僧家之事，大率临行之际，勿须喧动。”遂归丈室，端坐长往。寿六十有三，腊四十二。谥悟本禅师，塔曰慧觉。
    曹山本寂禅师，福建泉州莆田县人，俗姓黄，少业儒学，十九岁往福州灵石出家。二十五受具足戒，不久即参谒洞山良价禅师。山问：“阇梨名什么？”对曰：“本寂。”山曰：“向上更道。”师曰：“不道。”山曰：“为什么不道？”师曰：“不名本寂。”洞山深器之，自此入室，密印所解。盘桓数载，乃辞洞山。洞山问：“什么处去？”师曰：“不变异处去。”洞山曰：“不变异处岂有去耶？”师曰：“去亦不变异。”乃辞去。山密授洞山宗旨，师拜受而别。遂至曹溪礼慧能六祖塔。后还止江西吉水，大众请开法。因追念六祖的遗风，便把所住吉水山改名为曹山，后又居荷玉山。二处法席，学者云集。
    有僧问：“于相何真？”本寂说：“即相即真。”又有僧问：“幻本何真？”本寂说：“幻本元真。”又问：“当幻何显？”本寂说：“即幻即显。”这是曹山为启发上机而说的道理。僧问：“学人通身是病，请师医。”师曰：“不医。”又问曰：“为什么不医？”师曰：“教汝求生不得，求死不得。”师作四禁偈曰：“莫行心处路，不挂本来衣，何须正凭么，切忌未生时。”师有三种堕：“一者披毛戴角，二者不断声色，三者不受食。”有稠布衲问：“披毛戴角是什么堕？”师曰：“是类堕。”曰：“不断色声是什么堕？”师曰：“是随堕。”曰：“不受食是什么堕？”师曰：“是尊贵堕。”
    问：“沙门岂不是具大慈悲的人？”师曰：“是。”又曰：“忽遇六贼来时如何？”师曰：“亦须具大慈悲。”曰：“如何具大慈悲？”师曰：“一剑挥尽。”曰：“尽后如何？”师曰：“始得和同。”师示人偈曰：
    从缘荐得相应疾，就体消停得力迟，
    瞥起本来无处所，吾师暂说不思议。
    问：“学人十二时中如何保任？”师曰：“如经蛊毒之乡，水也不得沾著一滴。”
    僧举：“有人问香严如何是道？”答曰：“枯木里龙吟。”曰：“如何是道中人？”答曰：“骷髅里眼睛。”学人不会，后问石霜：“如何是枯木里龙吟？”石霜云：“犹带喜在。”又问：“如何是骷髅里眼睛？”石霜说：“犹带识在。”师因而颂曰：
    枯木龙吟真见道，髑髅无识眼初明。
    喜识尽时消息尽，当人那辨浊中清。
    其僧复问师：“如何是枯木里龙吟？”师曰：“血脉不断。”曰：“如何是骷髅里眼睛？”师曰：“乾不尽。”曰：“未审还有得闻者无？”师曰：“尽大地未有一人不闻。”曰：“未审枯木里龙吟是何章句？”师曰：“不知是何章句，闻者皆丧。”
    天复辛酉（９０１）夏夜，师问知事僧：“今日是几何日月？”曰：“六月十五。”师曰：“曹山平生行脚到处，只管九十日为一夏。明日辰时行脚去。”及时，焚香宴坐而化。寿六十有二，腊三十七。门人树塔于山之西阿，谥元证禅师，塔曰福圆。
    曹洞宗的家风：《五家参详要路门》说为“究心地”，即丁宁绵密。《十规论》说敲唱为用，即师徒常相交接，以回互不回互之妙用，使弟子悟本性真面目，是极其亲切之手段，宗风可称绵密。丛林有“临济将军，曹洞士民”之说，意谓曹洞接化学人，似是精耕细作田土的农夫，绵密回互，妙用亲切，这也是曹洞宗接化学人的一种特色。

    （四）云门宗
    云门宗是中国禅宗五家之一。由于此宗的开创者文偃在韶州五家山（今广东乳源县北）的光泰禅院（今名大觉禅寺），举扬一家宗风，后世就称它为云门宗。
    《五灯会元》卷十五说，韶州云门山光泰院文偃禅师，嘉兴人也，姓张氏。幼依空王寺志澄律师出家。及长，落发禀具于毗陵坛，侍澄数年，探穷律部。以己事未明，往参睦州。州才见来，便闭却门。师乃扣门。州曰：“谁？”师曰：“某甲。”州曰：“作甚么？”师曰：“己事未明，乞师指示。”州开门一见便闭却。师如是连三日扣门，至第三日，州开门，师乃拶入，州便擒住曰：“道！道！”师拟议，州便推出曰：“秦时[轴-由+度]轹钻。”遂掩门，损师一足。师从此悟入。州指见雪峰。师到雪峰庄，见一僧乃问：“上座今日上山去耶！”僧曰：“是。”师曰：“寄一则因缘，问堂头和尚，只是不得道是别人语。”僧曰：“得。”师曰：“上座到山中见和尚上堂，众才集便出，握腕立地曰：‘这老汉项上铁枷，何不脱却？’”其僧一依师教。雪峰见这僧与么道，便下座拦胸把住曰：“速道！速道！”僧无对。峰拓开曰：“不是汝语。”僧曰：“是某甲语。”峰曰：“侍者将绳棒来。”僧曰：“不是某语，是庄上一浙中上座教某甲来道。”峰曰：“大众去庄上迎取五百人善知识来。”师次日上雪峰，峰才见便曰：“因甚么得到与么地！”师乃低头，从兹契合。温研积稔，密以宗印授焉。
    后来历访洞岩、疏山、曹山、天童、归宗、灌溪等处，最后往曹溪礼六祖塔，便到灵树如敏处，如敏很器重他，请他为首座，最后便继承如敏的法席，晚年移住云门光泰禅院，恢宏法化。有《云门匡真禅师广录》三卷，法嗣有香林澄远，德山缘密等六十一人。
    《指月录》卷二十一说：“南汉乾和七年（９４９）四月十日端坐示寂。迨北宋乾德元年（９６３），雄武军节度推官阮绍庄，梦师以拂子招曰：寄语秀华宫使特进李托，我在塔久，可开塔乎？托时奉使韶州，监修营诸寺院。因得绍庄之语，奏闻，诏迎师肉身内宫供养。启塔颜貌如昔，须发犹生。自南汉乾和七年（９４９），至宋乾德元年（９６３），盖十七年矣。留京师月余，仍送还山。
    云门宗旨有三句、一字关及顾、鉴、咦三字旨。师重视一切现成、“即事而真”的石头希迁思想。上堂，师每顾见僧即曰：“鉴”。僧欲酬之，则曰：“咦”。率以为常。故门弟子目之为“顾、鉴、咦”。德山缘密禅师，删去“顾”字，但以鉴咦二字为颂，谓之抽顾颂。禅学者认为，顾鉴咦三字是云门宗旨，必须亲切参究才能体会。上堂说：“函盖乾坤，目机殊两，不涉世缘，作么生承当？”众无对。自代曰：“一镞破三关。”后来他的法嗣德山缘密把它析为“三句”，即函盖乾坤句，截断众流句，随波逐流句。颂初句云：“乾坤开万象，地狱及天堂，物物皆真现，头头总不伤。”恰当地说明了一切现成的见解。因函盖乾坤，即本真本空，一色一味，凡有语句，无不包罗，不待踌躇，全该妙体。师语函盖相合，立使学人悟旨。截断众流、随波逐流二句，则是说他接引学人的教学方法。云门经常用截断众流的方法接引人，每用一语一字，蓦地截断葛藤，使问者转机，无所用心，立悟世谛门中一法不立。例如有僧问：“如何是佛？”师曰：“乾矢橛。”又有僧问：“不起一念，还有过也无？”师曰：“须弥山。”可谓奔流突止之概。他还常用一字回答问者，如僧问：“如何是云门剑？”师回答说：“祖。”问：“如何是禅？”回答说：“是。”问：“如何是云门一路？”师答说：“亲。”问：“如何是正法眼？”回答说：“普。”问：“三身中那身说法？”答曰：“要。”当时禅学者称为一字关。《五家参详要路门》评云门为“择言句”。法演禅师评云门下之事为“红旗闪烁”。都是说他言悟顿机的作用、宗旨、家风。总起来说，此宗家风，孤危险峻，简洁明快。其接化学人，不用多语饶舌，于片言只句之间，超脱意言，不留情见。以无伴为示，或一字或多语，随机拈示明之。

    （五）法眼宗
    法眼宗是禅宗五家之一。由于此宗的开创者文益禅师圆寂后，南唐中主李璟给以大法眼禅师的称号，后世遂称此宗为法眼宗。
    文益（８８５-９５８）是青原下第八世，余杭人，姓鲁氏。七岁依新定智通院全伟禅师出家，于越州开元寺受具足戒后，到明州鄮山育王寺从律师希觉学律，复旁探儒家典籍。既而玄机顿发，抛掉一切杂物，振锡南迈，抵福州参长庆禅师，无所契悟，乃同绍修、法进三人游方参学。路过漳州，值遇天雪，暂时住在城西的地藏院，因而参谒玄沙师备的法嗣罗汉桂琛，琛问师曰：“此行何往？”师曰：“行脚去。”琛曰：“作么生是行脚事？”师曰：“不知。”琛曰：“不知最亲切。”雪霁辞去，琛送出门，问曰：“上座寻常说三界唯心，万法唯识”，乃指庭下片石曰：“且道此石在心内？在心外？”师曰：“在心内。”琛曰：“行脚人著甚么来由，安片石在心头？”师窘无以对，即放衣包，依琛席下求抉择。经一月余，每日呈见解，说道理。琛语言之曰：“佛法不凭么。”师曰：“某甲词穷理绝也。”琛曰：“若论佛法，一切现成。”师于言下大悟。后至临川崇寿院，开堂接众。
    僧慧超问：“如何是佛？”师曰：“汝是慧超。”生法师曰：“敲空作响，击木无声。”师忽闻斋橹声，谓侍者曰：“还闻么？适来若闻，如今不闻，如今若闻，适来不闻，会么？”师尝指竹问僧曰：“还见么？”曰；“见。”师曰：“竹来眼里？眼到竹边？”曰：“总不与么。”师笑曰：“死急作么。”因开井被沙塞泉眼，师曰：“泉眼不通，被沙碍，道眼不通，被什么碍？”僧无对。师代曰：“被眼碍。”问：“十二时中如何行履，即得与道相应？”师曰：“取舍之心成巧伪。”问：“如何是沙门所重处？”师曰：“若有纤毫所重，即不名沙门。”如则监院在师会中，却不曾参请入室。一日师问云：“则监院何不来入室？”则云：“和尚岂不知，某甲于青林处，有个入头。”师云：“汝试为我举看。”则云：“某甲问如何是佛？”林云：“丙丁童子来求火。”师云：“好语。恐尔错会，可更说看。”则云：“丙丁属火，以火求火；如某甲是佛，更去觅佛。”师云：“监院果然错会了也。”则愤而起单渡江去。师云：“此人若回可救，若不回救不得也。”则到中路自思忖云，他是五百人善知识，岂可赚我耶？遂回再参。师云：“尔但问我，我为尔答。”如则便问：“如何是佛？”师云：“丙丁童子来求火。”则于言下大悟。这段公案，久参者一举便知落处。法眼下谓之箭锋相拄，更不用五位君臣、四料简等，一句便见，当阳便透；若向句下寻思，卒摸索不着。
    师出世有五百众，此时佛法大兴，当时天台山德韶禅师，久依疏山，自谓得旨。乃集疏山平生文字，领众行脚。至师会下，他不去入室参请，只令学人随众入室。一日师升座，有僧问：“如何是曹源一滴水？”师曰：“是曹源一滴水。”其僧惘然而退。韶在众中闻之，忽然大悟。后出世承嗣。有颂呈云：“通玄峰顶，不是人间，心外无法，满目青山。”师印可曰：“只这一颂，可继吾宗。”并告曰：“子后有王侯敬重，吾不如汝。”后德韶果为吴越国师。
    法眼宗的宗风，简明处似云门，稳密处类曹洞。其接化之言句似颇平凡，而句下自藏机锋，有当机觌面而能使学人转凡入圣者。《五家参详要路门》说：“法眼宗先利济。”直论箭锋相拄，是其家风。一句下便见，当阳便透。随对方人之机宜，接得自在，故说为“先利济。”《人天眼目》卷四曰：“法眼宗者，箭锋相拄，句意合机；始则行行如也，终则激发。渐服人心，削除情解，调机顺物，斥滞磨昏。”此亦先利济的意思。《归心录》说：“法眼宗风，对症施药，垂机顺利，扫除情解。”又《五家宗旨纂要》说：“法眼宗家风，则闻声悟道，见色明心。句里藏锋，言中有响。三界唯心为宗，拂子明之。”
    师前后三坐道场，朝夕演旨。时诸方丛林，咸遵风化，异域有慕其法者，涉远而至。师调机顺物，斥滞磨昏，皆应病与药，随根悟入者，不可胜纪。以周显德五年戊午（９５８）七月十七日示疾，李后主驾至慰问。闰月五日剃发沐身告众讫，跏趺而逝，颜貌如生。世寿七十有四，戒腊五十四。于江宁县丹阳起塔，谥大法眼禅师，塔曰无相。法嗣有德韶（吴越国师）、文遂、慧炬（高丽国师）等十三人，各化一方。有《金陵清凉院文益禅师语录》一卷及文益自撰《宗门十规定论》等行世。
    法眼宗在宋初极其隆盛，后即逐渐衰微，到宋代中期，法派遂绝，时间不过一百年。
    法眼禅师的《宗门十规论》，说四家宗风，其时尚无四家五家的名称，但已有门户之见。自宋以后，揭出五家宗名者，以契嵩的《传法正宗记》为开始。此外《人天眼目》、《普灯录》、《五灯会元》、《五家正宗赞》、《续传灯录》、《会元续录》、《佛祖统纪》、《佛祖通载》等书，亦说五家区别。

    （六）杨歧派
    杨歧派是是禅宗五家临济下面的一个支派。由于此派的创始人方会在袁州杨歧山（今江西省萍乡县北）举扬一宗家风，后世就称其为杨歧派。
    袁州杨歧方会禅师（９９２-1046），袁州宜春人，姓冷氏，是临济下第八世。二十岁时，到筠州（今江西省高安县）九峰山投师剃发出家。阅读经典，心融神会，又能折节参学。慈明住南原时，师住依参。及明迁石霜，师亦随往，并自请总院事。依之虽久，然未有省发。每次谘参，明辄曰：“库司事繁，且去。”他日又问。明曰：“监寺异时儿孙遍天下在，何用忙为？”一日，明适出，值雨作。师侦之小径，既见，遂扭住曰：“这老汉今日须与我说。不说打你去。”明曰：“监寺知是般事便休。”语未卒，师大悟，即拜于泥途。问曰：“狭路相逢时如何？”明曰：“你且躲避，我要去那里去。”师归，来日具威仪，诣方丈礼谢。明呵曰：“未在。”
    慈明饭后经常游山经行，禅学者想问道，多失所在，师窥其出未远，即打鼓集众，明遽还，怒曰：“作什么？”师曰：“晚参。”明遂示众，丛林因号“晚参。”
    一日，明上堂，师出问：“幽鸟语喃喃，辞云入乱峰时如何？”明曰：“我行荒草里，汝又入深村。”师曰：“官不容针，更借一问。”明便喝。师曰：“好喝。”明又喝，师亦喝。明连喝两喝，师礼拜。明曰：“此事是个人方能担荷。”师拂袖便行。一日慈明问师：“马祖见让师便悟去，且道迷却在什么处？”师曰：“要悟即易，要迷即难。”
    一日师示众罢下座，九峰勤和尚把住云：“今日喜得个同参。”师曰：“作么生是同参底事？”曰：“九峰牵犁，杨歧拽耙。”师曰：“正凭么时，杨歧在前，九峰在前？”勤拟议，师拓开曰；“将谓同参，元来不是。”
    问来僧曰：“云深路僻，高驾何来？”曰：“天无四壁。”师曰：“踏破多少草鞋？”僧便喝。师曰：“一喝两喝后，作么生？”曰；“看这老和尚着忙。”师曰：“拄杖不在，且坐吃茶。”
    示众云：“身心清净，诸境清净。诸境清净，身心清净。还知杨歧老也落处么？河里失钱河里摝。”
    杨歧的根本思想，是临济正宗，重在一切现成。所以《续传灯录》说他接化学人，提纲振领和云门文偃相类似；又说他勘验学者的机锋类似南院慧顒，他兼具临济、云门两家的风格。当时称他兼百丈怀海、黄檗希运之长，双得马祖的大机大用，谓其宗如龙。洪觉范赞曰：“会如玉人之治璠玙，碔砆废矣。故其子孙皆光明照人，克旺其家，盖碧落碑无赝也。”《五家正宗》卷二赞曰：“神机颖悟，逸气轩渠……斤削铿锵，拟石匠之击墁垩；钳锤妙密，如玉人之治璠玙。”
    庆历六年（1046）移住潭州云盖山海慧寺。皇祐改元（1049）示寂，塔于云盖，有《杨歧方会和尚语录》、《杨歧方会和尚后录》各一卷。嗣法弟子有十二人，以白云守端、保宁仁勇为上首。
    杨歧派后期恢复了临济旧称，所以临济后期的历史，也就是杨歧派的历史。此派禅法，在宋元两代传入日本，创行别派，在日本镰仓时代禅宗二十四派中，有二十派皆出于杨歧法系。

    （七）黄龙派
    黄龙派，是禅宗临济下的一个支派。此派开创者为慧南，在隆兴（今江西省南昌市）黄龙山举扬一家的宗风，后世就称其为黄龙派。
    黄龙慧南（1002-1069）禅师，是临济下八世，信州玉山（今江西玉山县）章氏子，童年不吃荤、不嬉戏。年十一出家，十九岁受具足戒。依泐潭怀澄禅师学云门禅，受泐潭印证，令分座接物，名振诸方。临济宗人云峰文悦见之叹曰：“南有道之器也，惜未受本色钳锤耳！”偶然会元峰文悦禅师同游西山，夜间谈论云门法道，因问泐潭所授之旨，师言其要。峰曰：“澄公虽是云门之后，法道异矣。”师诘其所以异，峰曰：“云门如九转丹砂，点铁成金。澄公如药汞银，徒可玩，入煅则流去。”师怒，以枕投之。明日，峰谢过。又曰：“云门气宇如王，甘死语下乎？澄公有法授人，死语也。死语，其能活人乎？”语讫，即背去，师挽之曰：“若如是，则谁可汝意？”峰曰：“石霜圆手段出诸方，子宜见之，不可后也。”师默计之曰：“悦师翠岩，使我见石霜，于悦何有哉！”即造石霜。中途闻慈明不事事，慢侮丛林，遂不往，登衡岳，谒福严贤，贤命掌书记。不久贤圆寂，郡守以慈明补之。师心喜，且欲观其人，以验云峰之言。明既至。贬剥诸方，斥为邪解。而泐潭密付之旨，皆在所斥中，师为之气索。乃曰：“大丈夫为此事求抉择，岂可置疑胸中。”遂造其室怀香求指示。明曰；“书记领徒游方，借使有疑，可坐而商略。”师哀恳愈切。明曰：“公学云门禅，必善其旨。如云放洞山三顿棒，是有吃棒分，无吃棒分？”师曰：“有吃棒分。”明色庄而言曰：“从朝至暮，雀噪鸦鸣，皆应吃棒。”明即端坐，受师炷香作礼。明复问曰：“如汝会云门意旨，则赵州道：台山婆子，我为汝勘破了也。且那里是他勘破婆子处？”师汗下不能答。次日又诣，明诟骂不已。师曰：“骂岂慈悲法施邪？”明曰：“你作骂会那？”师于言下大悟。作颂日：“杰出丛林是赵州，老婆勘破没来由。而今四海清如镜，行人莫与路为仇。”呈慈明，明以手指“没”字，师为易“有”字。明点头印证之。
    后来在同安（今福建同安县）崇胜禅院开法，初受请日，泐潭遣僧来审，师提唱之语，有曰：“智海无性，因觉妄而成凡；觉妄无虚，即凡心而见禅。便尔休去，将谓同安无折合，随汝颠倒所欲？南斗七，北斗八。”僧归，举似澄，澄不择。自是泐潭旧好绝矣。既而又移住庐山归宗寺。上堂：“道远乎哉？触事而真；圣远乎哉？体之即神。”乃拈拄杖曰：“道之与圣，总在归宗拄杖头上。汝等诸人，何不识取？若也识得，十方刹土不行而至，百千三昧无作而成。”他这样指示，揭出临济宗“触事而真”的见解。不久他又移住筠州（今江西万安县）黄檗山，有开示说：“道不用修，但莫污染。禅不假学，贵在息心。心息故，心心无处。不修故，步步道场。无虑，则三界可出，不修，则无菩提可求。”
    因化主归，上堂：“世间有五种不易：一化者不易，二施者不易，三变生为熟者不易，四端坐吃者不易，更有一种不易是甚么人？”良久云：“聻！”便下座。
    宋景佑三年（1036），在隆兴黄龙山振兴禅宗，自言：“黄龙出世，时当末运，击将颓之法鼓，整已坠之玄纲。”法席盛极一时。师室中常问僧曰：“人人尽有生缘，上座生缘在何处？”正当问答交锋，却复伸手曰：“我手何似佛手？”又问：“诸方参请，宗师所得？”却复垂足曰：“我脚何似驴脚？”三十余年，示此三问，学者莫能契其旨。天下丛林目之为黄龙三关。师颂曰：“生缘断处伸驴脚，驴脚伸时佛手开。为报五湖参学者，三关一一透将来。”熙宁己酉（1069）三月七日午时，端坐示寂。阇维得五色舍利，塔于前山，谥普觉禅师。有《黄龙禅师语录》等行世。嗣法弟子有八十三人，其中黄龙祖心、宝峰克文、东林常总等，门叶繁茂，形成了黄龙一派。
    慧南初学云门，经云峰文悦指点而参石霜大悟，明了以死句教人的错误。但在接引学人方法上，还是参用云门的宗风。因此，门庭严峻，人喻之如虎。如南州居士潘兴尝问师设三关所以？慧南说：“已过关者，掉臂径去，安知有关吏；从关问可否，此未过关者也。”可见其设三关的机用，是要学人触机即悟，而不应死于句下。
    黄龙派流传最广的有祖心、克文、常总三系，其中除祖心系灵源惟清六传而得日本明庵荣西而传域外，其余大都一二世而绝。黄龙派的兴起到衰竭，止一百多年而已。


七调和五事助参禅

    参禅，是以见性契悟涅槃妙心为主，除此皆是助道之法。禅之一字，本是天竺语音，具体应名禅那，翻成汉语意为思维修。
    禅的体性，经教祖语，立种种不同名称。《梵网经》说名心地。《般若经》说名菩提，亦称为涅槃。《华严经》立为法界。《楞伽经》说名如来藏识。如是等名，不烦多举。一法千名，应缘立号。祖师门下，有时呼为自己，有时名为正眼，有时号曰妙心，有时名曰主人翁、无底钵、没弦琴等等，不可俱录。若见性悟心，诸名尽晓，迷昧自性，诸名皆滞。
    禅定一行，最为神妙，能发起自性的无漏智慧。一切妙用，万德万行，乃至神通光明，皆从禅定生。故三乘人欲求圣道，必须修禅，离此无门，离此无路。但禅有深浅、内外、大小，三乘各异。如来禅、祖师禅，必须心无所著，方可参究妙悟。
    修禅之法，在形式上必须静坐，诸佛菩萨，三乘圣者，没有不通过静坐修禅而悟道解脱的。在行住坐卧四威仪中，端身静坐，最易定身息心，有利于用心参究。
    释迦太子，修苦行六年，不得解脱，悟知苦行非道，非菩提因，遂从座起，至足连河沐浴，受牧女难陀波罗乳糜供养，气力充足，诣佛陀伽耶，厚敷净软草座于毕波罗树下，跏趺而坐，端身正念，发大誓言：我今若不证无上大菩提，宁可碎是身，终不起此座。于是端坐思维，经过降魔等阶段，终于十二月八日明星出时，豁然大悟，得无上正真之道，成最正觉。
    开创中国禅宗的菩提达摩大师，梁普通年间来到中国，武帝迎入宫中问法，帝不能领悟。大师知机不契，遂到河南嵩山少林寺面壁而坐，九年如一日。终日默默，人莫之测，谓之“壁观婆罗门”。
    这是佛祖给修习禅定者做出的榜样。虽然六祖为破斥死坐不用心者，而向薛简说：“道由心悟，岂在坐耶”的方便语。但参禅最正确的形式，还是应以佛祖为榜样，以结跏静坐为主，于参禅易得成就。若为保任禅心，亦须在行住坐卧时，融化贯彻于生活中。故永嘉禅师在《证道歌》里说：“行亦禅，坐亦禅，语默动静体安然。”参禅在形式上来说，以坐为主，坐是四威仪中最稳健中正的方法，姿态形式最为端正，故结跏趺坐是修禅的要道。
    坐禅首先要发心，百丈禅师《坐禅仪》说：“夫学般若菩萨，起大悲心，发弘誓愿。精修三昧，誓度众生，不为一身独求解脱。”常住大悲心以无量功德回向众生。誓断烦恼，誓证菩提，一切莫为，只管打坐，放舍诸缘，休息万事，身心一如，动静无间，一定能得到禅定而开悟，作祖成佛。
    静坐之先，选择环境，亦至关重要，必须选择寂静处，即远离喧杂，不闻杂乱的人畜之声的处所。其次调和五事：
    １.调食：饮食本为滋身进道之所需。但食之过饱，则气急身满，百脉不通，令心闭塞，坐即不安。若食之过少，则身体羸虚，意虑不固。多食少食都非得定之道。还有吃了杂秽之物，令心识昏迷。若吃与自身不相宜的食物，则触动旧病，使四大相违，身心不安，也不利于修定。所以说“身安则道隆，饮食知节量，常乐在空闲，心静乐精进，是名诸佛教。”吃饭之后，必须休息半小时才能入坐，否则身息不调。
    ２.调睡眠：睡眠本是无明惑覆，不可纵之，若睡眠过多，非唯废修圣法，亦复丧失功夫，令心暗昧，善根沉昧，要经常思念无常，调伏睡眠，令神气清白，念心明静，如是方可栖心圣境，三昧现前。故经云：“初夜后夜，亦勿有废。无以睡眠因缘，令一生空过，无所得也。”
    ３.调身：调身就是关于坐禅时对自己身体的调整。先需厚铺坐具，使身体能安稳久坐，无所妨碍。次当整定，即调整定式。坐法有两种：一、结半跏趺坐，即以左脚置右脚上，牵来近身，令左脚指与右膝齐，右脚指与左膝齐。二、全跏趺坐，先将右脚置于左膝上，再将左脚安于右膝上。古来分别称为“吉祥坐”与“降魔坐”。禅宗本来没有这种区别，唯以坐久疲劳时，左右上下交替结跏都无否可，但总以半跏趺坐方为相宜。
    其次宽解衣带，使衣带周正，不令坐时脱落。衣带勿使过紧，过紧身体窄迫，气息亦不调。迥松时易生颓堕，以松紧适度为要。
    次当安手，以左手掌置右掌上，两手大拇指相接，当心而安。照印相说，名为“法界定印”。
    次当正身，先当摇动其身及诸支节，约反覆七八次，如按摩法，勿令手脚差异。如是坐已，则身端坐直，令脊骨勿曲勿耸，不得左倾右斜，前躬后仰。坐时不可依靠墙壁及屏障等物，否则久坐成患。
    次当正颈，鼻子与脐对，不偏不斜，不低不昂，平面正坐。
    次当口吐浊气，吐气之法，开口放气，不可令粗急，宜缓细深长，绵绵恣气而出，想自身百脉不通处俱随放息而出。闭口，鼻纳清气。如是至三至七次，若身息调和，但一次亦足。
    次当闭口，唇齿相依，舌顶上颚。
    次当闭眼，只令断外光而已。
    当端身正坐，犹如奠石，无得身首四肢辄尔动摇，是初人禅定调身之法。举要言之，不宽不急是身调相。
    又极寒极热或过寒过热及迎风处，皆不宜静坐。光线也应选择适当，过明过暗，都非所宜。
    如上所讲，住处衣食似乎与坐禅无关，实则不然，住处影响于心，饮食影响于身，睡眠影响进修，衣带松紧影响于调息。所以调和五事不可轻忽。
    ４.调息：调息就是调和呼吸，健康人的呼吸，大都正常；一旦四大不调，或精神异常时，脉搏就会变动，呼吸也就不规则了，这是每一坐禅人都有的经验。坐禅的时候，呼吸不调，心自然也因之而不调，身体浮动，就不能把心镇静下来，不能心安意悦，就不能明净入定。
    息有四种相：一风、二喘、三气、四息。前三种是不调相，后一种为调相。
    坐时鼻中之息，出入有声，叫做风相。
    坐时鼻息的出入，虽无声音，而息出入结滞不通，是为喘相。
    坐时息已无声，亦不结滞，但出入不细，是为气相。
    坐时鼻息出入无声音，不结滞，不粗浮，出入绵绵，若存若亡，资神安稳，情抱悦豫，此是息相。
    守风则散，守喘则结，守气则劳，气息则定。
    静坐时有风喘气三相，是名不调。若用功参究，复为心患，心亦难定。若欲调之，当依三法：一、下住安心，即把心放于气海丹田（气海丹田即脐下一寸五分之处）），把心镇静下来，将下腹部徐徐用力，使之稍稍向前，精神安住，呼吸自然调顺。二、放宽身体，不要矜持，放舍一切，使身体轻松愉快。三、想气从遍身毛孔出入，通行无障。
    息调则众患不生，散心易定。总起来讲，无声音，不结滞，不涩不滑，是息调相。
    ５.调心：调心之法有两种：一、调伏乱想，令心与参究相应，不令越逾。二、当令沉浮宽急适得其所。什么叫沉相？若坐时心中昏暗，心非明历，无所参究，头好低垂，是为沉相。这时当系念于鼻端，坐安心于发际、眉间（两眉中心），或令心明历，专注本参，无分散意，此可对治沉相。
    什么叫浮相？若坐时心好掉动，身亦不安，念外异缘，寻思杂事，这是浮相。这时应安心向下，最好安住在气海丹田、或肚脐中。更主要者，振奋精神，心住本参，止住散念，心即定住，则心容易安静。总起来讲，心无乱想，不浮不沉是心调相。
    调身、调息、调心这三种方法，在初、中、后（也就是入、住、出），特别是在初、中阶段，若有不调相，皆需随时适当调整。
    若欲出定，徐徐动身，安详而起，不得卒暴。出定之后，也要常作方便，护持定力。
    禅之可尊贵者，以得法的要道，全在实修、实证、真参，真究，因此称之为“坐禅办道”。
    今引百丈怀海禅息《坐禅仪》全文，以资共勉。
    “夫学般若菩萨，起大悲心，发弘誓愿。精修三昧，誓度众生。不为一身，独求解脱。放舍诸缘，休息万念。身心一如，动静无间。量其饮食，调其睡眠。于闲静处，厚敷坐物。结跏趺坐，或半跏趺。以左掌安右掌上，两大拇指相拄。正身端坐，令耳与肩对，鼻与脐对，舌拄上颚。唇齿相著，目须微开，免致昏睡。若得禅定，其力最胜。古习定高僧，坐常开目。法云圆通禅息呵人闭目坐禅谓黑山鬼窟，有深旨矣。一切善恶，都莫思量，念起即觉，常觉不昧。不昏不散，万年一念，非断非常，此坐禅之要术也。坐禅乃安乐法门，而人多致疾者，盖不得其要，得其要，则自然四大轻安，精神爽利，法味资神。寂而常照，寤寐一致，生死一如。但办肯心，必不相赚。然恐道高魔盛，逆顺万端。若能正念现前，一切不能留碍。如《楞伽经》、天台《止观》、圭峰《修证仪》，具明魔事，皆自心生非由外有。定慧力胜，魔障自消矣。若欲出定，徐徐动身，安详而起，不得卒暴。出定之后，常作方便，护持定力。诸修行中，禅定为最。若不安禅静虑，三界流转，触境茫然。所以道探珠宜静浪，动水取应难。定水澄清，心珠自现。故《圆觉经》云：‘无碍清净慧，皆依禅定生’。《法华经》云：‘在于闲处，修摄其心。安住不动，如须弥山。’是知超凡超圣，必假静缘，坐脱立亡，须凭定力。一生取办尚恐蹉跎，况乃迁延，将何敌业。幸诸禅友，三复斯文。自利利他，同成正觉。”


八参禅的入门方便

    很多学佛的人，想通过参禅的方法冲破凡圣关，了脱生死累，转凡成圣，成为无挂无碍的见道人，证得自由自在的大解脱。但是对于参禅怎样用心、怎样体会、怎样实践、怎样参究、怎样受用，如此等等，想在佛经祖语里去找现成的答案是很难的。即使有所阐发，也大都是些否定的话。真是承言者丧，逐句者迷，向上一著没有你插嘴处，问者给三十棒。禅师们主张不论禅定解脱，只须自见本性，以无念为宗、无相为体、无住为本。凡落言诠皆是错误，不疑语句是大危险。起心即乖，动念即错。说似一物即不中，说一佛字，满面羞惭，念一句佛，漱口三日。如人立在十字街头，辨不出东南西北，不知道向哪里走才是。于是就行脚参方，求师问道，想在自己的本分上讨个分晓。但从上各家接引学人的方便却不相同：有的说当体是，佛不要再参再学，自然解脱。有的说鼻直眉横，本来是佛，只要时刻保任便是。有说万事无心，只问自己是谁，自然相应。有说空心静坐，久之必悟。有说放下一切，穿衣吃饭，脱体现成。有说不染一物，自然成佛。有说一念净心，便是参禅。有说只管打坐，终为妙悟。有说要得妙悟，必须破关。有说参一句话头，必得开悟。如此等等，是则俱是，非则全非，弄得想参禅的人，不知所措，好像呆子似的找不到一个门路。
    禅宗以“佛语心为宗，无门为法门”。既是无门，那怎么透去？祖师说：从门入者，不是家珍，从缘得者，始终成坏。这样说来，大似掉棒打月，隔靴抓痒，永处缠缚，无有出期了。其实不然，禅虽然深邃，还是有门可入的。
    《华严经·如来出现品》说：“佛子！如来智慧无处不至。何以故？无一众生而不具有如来智慧，但以妄想颠倒执著，而不证得。若离妄想，一切智、自然智、无碍智，则得前。”这是释迦如来最初成道后的教导，也就是禅的来源和禅的本质。经文告诉我们像如来那样的智慧人人本具，只因妄想执著而不证得。如来是通过修习禅定开悟的，那么我们只要穷心参究于禅定，也就会发生无漏的根本智而证得一切智智。禅是什么？就是我们的心；心是什么？就是禅的体。所以禅的起源，在于释尊的正觉，正觉即禅心禅体。用参究的方法，彻见心的本源，即可得其本旨。禅宗的本源，是佛的正觉，不在语言文字上，必须领会正觉的意义，以心为宗。
    “禅”即梵语“禅那”的略语，汉译为思维修，亦名为静虑，是静止念虑散乱的意思，亦即定慧的通称。知道了禅的本源和意义，就会觉得禅门是有方便可入的。
    《传灯录》上说：世尊在灵山会上拈花示众，是对众皆默然，唯迦叶尊者破颜微笑。世尊曰：“吾有正法眼藏，涅槃妙心，实相无相，微妙法门，不立文字，教外别传，传付摩诃迦叶。”这是释尊与迦叶在拈花微笑、心心交照之间的大法授受，迦叶就成为传灯的第一祖。这样的传授，完全是公开的授受，绝无一丝一毫的神秘之处。如果说它是神秘，无非是教外别传，以心传心而已。
    自此二十八传至菩提达磨，自印度来中国倡导不涉名言、不历修证、直指人心、见性成佛的禅法，是为中国禅宗的初祖。他在《血脉论》里说：“若要觅佛，直须见性，性即是佛。佛是自在人，无事无作人。若不见性，终日茫茫，向外驰求觅佛，元来不得。”“即心是佛，无心是道。”我觉得这两句话可以作为参禅的入门方便。禅是心宗，必须体会心的正觉，才能悟得即心是佛，唯证乃知。众生的心，都是妄想，只有断除妄想彻底无心，才能通达即心是佛。大死一番而后大活，无心而后真心现前，心与法界，共同一体，无挂无碍，智境双忘，脱体无依，无依亦不存，方是大解脱之时。
    马祖道一示众说：“汝等诸人，各信自心是佛，此心即是佛心。达磨大师从南天竺国来至中华，传上乘一心之法，令汝等开悟。又引《楞伽经》文，以印众生心地，恐汝颠倒不自信，此心之法各各有之，故《楞伽经》云：‘佛语心为宗，无门为法门。’又云：夫求法者，应无所求，心外无别佛，佛外无别心，不取善，不舍恶，净秽两边俱不依怙，达罪性空，念念不可得，无自性故，故三界唯心，森罗万象，一法之所印。”
    马祖这段教导，对于即心是佛的意思，开示得非常明确。当时有大梅法常初参马祖，问：“如何是佛？”马祖答：“即心是佛。”常即领悟，遂到大梅山隐居。马祖令僧去问他：“得到什么好处，便在此住山？”他说：“马大师问我说即心是佛，我便向这里住。”僧说：“大师近日佛法又别，说非心非佛。”常说：“任他非心非佛，我只管即心是佛。”其僧回来说给马祖听，马祖说：“梅子熟也！”印证法常坚持“即心是佛”是正确的，马祖赞许他对禅的认识和参究的工夫成熟了。
    即心即佛是禅宗的根本观点，是诸大禅师一贯的主张。如僧法海参六祖慧能，问曰：“即心即佛，愿垂指谕。”祖曰：“前念不生即心，后念不灭即佛。成一切相即心，离一切相即禅。我若具说，穷劫不尽。听吾偈曰：即心名慧，即佛乃定。定慧等持，意中清净，悟此法门，由汝习性。用本无生，双修是正。”法海言下大悟。以偈赞曰：“即心元是佛，不悟而自屈，我知定慧因，双修离诸物。”说明领悟了即心是佛语，就能大彻大悟，直到不疑之地，解脱自在。特别是“成一切相即心，离一切相即佛”，值得参禅者深思体会，不要放过。
    五祖弘忍曾经对六祖说：“不识本心，学法无益。若识本心，见自本性，名大丈夫、天人师、佛。”这些言教与《华严经》所说“心佛及众生，是三无差别”，完全一致。所以初祖传法给二祖慧可时说：“外息诸缘，内心无喘，心如墙壁，可以入道”，也是独指妙心为禅源体性。这个宗旨，竖义于达磨，弘演于诸祖。因为参禅学道的人，停滞于经教语言，终不能契合妙心，立地成佛，所以达磨提倡不立文字，教外别传，独传妙心，悟此心当体是佛，虽万劫轮回而不动的天真佛性从无迁变。二祖悟得禅源的妙心后，忽然向初祖说道：“我已息诸缘”。初祖问曰：“莫不成断灭否？”二祖答曰：“不成断灭，了了常知，言之不可及。”初祖印证曰：“此是诸佛所传心体。”因为息却诸缘，则外境相空寂；内心无喘，则内寻合等绝；如墙壁则心行处灭；言不及则言语道断；了了常知而无妄念，则寂照同时，心境不二，迷悟不二，生佛不二。其恰到好处时，心亦不可得，妙亦不可得，不可得亦不可得。非心非不心，非妙非不妙，行住坐卧，莫非妙心体现。这就是“行亦禅，坐亦禅，语默动静体安然”的境界。
    宝志公《大乘赞》说：“不解即心即佛，真似骑驴觅驴。”傅大士《心王铭》说：“了本识心，识心见佛，是心是佛，是佛是心，念念佛心，佛心念佛。……自观自心，知佛在内，不向外寻，即心即佛，即佛即心。”
    诸佛诸祖，赞叹即心是佛的语句甚多，不烦广为引证。但马祖又曾答僧问而说“非心非佛”，因此引起了后世禅者的争议辩论，以非心非佛为极致之谈，从而引起《宗镜录》的破斥。《传灯录·马祖章》说：“僧问‘和尚为什么说即心即佛？’师云：‘为止小儿啼。’僧云：‘啼止时如何？’师云：‘非心非佛’。”《宗镜录》说：“问：‘如上所说，即心即佛之旨，西天此土祖佛同诠。理事分明，如同眼见。云何又说非心非佛？’答：‘即心即佛是其表诠，直表其事，令证自心，了了见性。若非心非佛，是其遮诠，即护过遮非，去疑破执。……近代有滥参禅门不得旨者，相承不信即心即佛之旨，判为是教乘所说，未得幽玄，我自有宗门向上事在，唯重非心非佛之说，并是指鹿为马，期悟遭迷，执影是真，以病为法。’”可见妄执非心非佛的人，必然走上邪途，不但不能开悟正觉，而且永沉三界。禅宗门下，诸祖许多言句，都是为对治学人的妄执愚迷解粘去缚而设施的，把抽钉拔楔的语句，迷执为是，岂不大错特错！还有别的祖师对此也有斥责，那就不再引证了。
    即心即佛既是参禅最好的入门方便，用什么方法去参究，才能真正证得即心即佛呢？古德说：“即心即佛，唯证乃知。”不是嘴上说说就能真正了知的。成佛实际上是以根本无分别智亲证实相。实相就是无相之相。亲证无相，刹那间是智境冥合，能所双忘，虚空粉碎，大地平沉。这样的境界，绝不是有分别心能通能证的。因此，我觉得古德所谓“无心是道”的说法，是正确的方便法门。如黄檗答僧问时就说：“即心是佛，无心是道。”达磨传心给二祖慧可时说：“外息诸缘，内心无喘，心如墙壁，可以入道。”就是彻底的无心。所谓无心者，非无真心，而是没有一切杂念妄想，只有孤明历历的心。六祖说：“我此法门，从上以来，先立无念为宗，无相为体，无住为本。”无念就是无一切念，一切处无心，对一切境界不动不起，无念时即真念，一切处无心，六根即无染，自然得入诸佛知见，即称无念。入佛知见复从何建立？从无念立。如《维摩经》说：“从无住本，立一切法。”所谓“无相为体”，诸法实相，是一切法无相，在无相中不分别是佛是众生，若起分别，即见相取相，不见法界平等相。真如佛性，本来无相。所谓“无住为本”，无住即实相异名，实相即性空异名。《维摩经》文殊师利问颠倒想孰为本？维摩大士答曰：“无住为本”。所以六祖说：“无相者，于相而离相。无念者，于念而无念。无住者，人之本性。……念念之中，不思前境。若前念今念后念，念念相续不断，名为系缚。于诸法上，念念不住，即无缚也。此是以无住为本。”六祖最初教导惠明时，就是用无心是道的方便。他教惠明屏息诸缘，勿生一念：“不思善、不思恶，正与么时，哪个是明上座本来面目？”惠明遂于言下得悟。说明无心是道，是令学人大彻大悟的最好方便。六祖自己，也是从体认无心是道而悟入的。五祖给他说《金刚经》至“应所住而生其心”，他便言下契悟。众生的心，本无所住，因境来触，遂生其心。不知境性是空，执世法是实，便在境上生心住心，正犹猿猴捉月，病眼看花，自生颠倒。一切万法，皆从心生，若悟真性，即无所住。无所住，即是智慧，无诸恼烦，譬如太空，无有挂碍。有所住心即是妄念，六尘竞起，譬如浮云往来不定。《传心法要》说：“你但离却有无诸法，心如日轮常在虚空，光明自然不照而照，不是省力的事，到此之时，无栖泊处，即是行诸佛行，便是应无所住而生其心。此是你清净法身，名为阿耨菩提。”从达磨“教外别传，不立文字，直指人心，见性成佛”，传佛心印以来，参禅入门之道，可以说都是用的“无心是道”的方便。
    但是同安察祖《十玄谈》第九却说：“莫谓无心便是道，无心犹隔一重关。”这实际上也是对学人解粘去缚，抽钉拔楔的手法。怕学人在用功上迷执死法而给与否定，使其百尺竿头再进一步。在参禅上讲，真正的宗师，决不以实法与人，随时给学人拨转迷头，令其处处无碍，事事圆通。禅的真实相，是本来无物，说似一物即不中，“道个佛字，拖泥带水；道个禅字，满面惭愧。”从这点出发，一切言语，一切心行，都是多余的，岂能停滞在无心是道上面？当知以为“无心”还是一种执著。为了打破“无心是道”，使学人在参学上活泼泼地见性成佛去，所以说“无心犹隔一重关。”
    明白了祖师否定无心是道的意趣，还是扶着这根拐棍去努力用功，猛参实究。黄檗说：“不悟此心体，便于心上生心，向外求佛，著相修行，皆是恶法，非菩提道。”向外求佛，著相修行，那就永远求不到佛，修不了真正清净的行。真正的修行，就是要对境心不起，主要在忘心，如果不忘心，对境必著相，无相的一真法界，怎么会现前呢？所以欲忘境最好是忘心。但用功人往往不敢忘心，恐怕忘心落空，无捞摸处。不知空本无空，无念之时，正是孤明的心，保护孤明，就是修禅最好的一着子。这个方法要求学人，对已经生起的心，不让它继续生；对未生起的心，不让它生起。不续前，不引后，中间自孤。黄檗说：“但自忘心，同于法界，但得自在，此即是要节也。”一切善恶，都莫思量。过去事已过去，而莫思量，过去心自绝；未来事未至，莫愿莫求，未来心自绝；现在事念念不停，不要把捉。于一切事，但知无著。无著者，不起爱憎心，现在心自绝。于三世事不生心，则心忘境自空。
    南岳怀让禅师礼拜六祖，六祖问他什么物、恁么来？怀让答曰：“说似一物即不中。”问：“还可修证不？”答：“修证即不无，染污即不得。”祖曰：“只此不染污，诸佛之所护念。汝既如是，吾亦如是。”马祖示众也说：“道不用修，但莫染污。何为染污？但有生死心，造作趋向，皆是染污。若欲直会其道，平常心是道。何为平常心？无造作，无是非，无取无舍，无断常，无凡无圣。”虚灵本心无物可比，所以说似一物即不中。此虚灵的本心，不可染污，不必另用心修行，只对孤明历历的心加以保任护持，令不染污即是。
    禅宗常用“牧牛”做比喻，以显示无心是道的方法。如马祖问慧藏禅师作什么？慧藏答：“牧牛。”马祖问他怎样牧？回答说：“一回入草去，便把鼻拽来。”马祖说：“子真牧牛。”参禅要保持无心，必须时刻反省内心，照顾当前一念，如牧牛一般，不让它犯人苗稼，做到一回入草去，立即把鼻拉回。就是念起即觉，觉之即无。做到对境心不起，亦无散动，透过一切色声，无有滞障，名为道人。如一团火相似，触物便烧。古人说，直截径要处，一刀两断，直下便休。
    无心者，即是内照反省，一念触境生心，就是生死，离境无生灭，就是解脱。一念无心，凡夫等佛，烦恼即菩提。六祖说：“前念迷即凡，后念悟即佛；前念著境即烦恼，后念离境即菩提。”此是“最尊最上最第一，无住无往亦无来，三世诸佛从中出。当用大智慧打破五蕴烦恼尘劳。如此修行，定成佛道。悟此法者，即是无念无忆无著，不起狂妄，用自真如性，以智慧观照。于一切法，不取不舍，即是见性成佛。”参禅贵实践，即真参实悟；多知多解，翻成壅塞。但销溶凡情圣解，都无依执，心如虚空，离有无诸去，到此无栖泊处，即是行诸佛路，无所住而生其心。古人道：“争似无为实相门，一超直入如来地。”若不会此，纵是多知勤苦，草衣木食，不识自心，尽是邪行。今但学无心，实修实悟，死却心猿，杀却意马，一念不生，颠倒心绝，妄息心空，真知自现，枯木生花，大事了毕。如《净名经》云：“即时豁然，还得本心。”始知不从他得，庆快平生。
    再说一点对于心的认识问题。心有两种，一种是真心，以灵知寂照为心，不空无住为体，实相为相。一种是妄心，以六尘缘影为心，无住为体，攀缘思虑为相。参禅用功，要保任孤明历历，不续前念，不引后念，逼使中间孤明，那就要时时对治妄心，使真心得以显现。真心以实相为相，必须是无念无相之心才能冥合亲证。明乎此，“即心即佛”、“无心是道”是参禅最初的方便之门，还有什么可怀疑呢？佛言：“出家沙门者，断欲去爱，识自心源，达佛深理，悟无为法，内无所得，外无所求，心不系道，亦不结业，无念无作，无修无证，不历诸位而自崇最，名之为道。”《起信论》也说：“若离心念，则无一切境界之相。是故一切法，从本以来，离言说相，离名字相，离心缘相，毕竟平等，无有变异。”一达到这种绝对境界时，便处处无碍，事事通达，大用现前，一切光明。这便是不存规则的自在无碍境界。
    最后，借永嘉禅师的一个颂文，帮助参禅者时刻检验用心之正确与否。偈曰：“惺惺寂寂是，无记寂寂非，寂寂惺惺是，乱想惺惺非。”黄龙死心禅师说：“此身不向今生度，更向何生度此身。”黄檗断际禅师说：“尘劳迥脱事非常，紧把绳头做一场，不是一番寒彻骨，怎得梅花扑鼻香。”禅，重在真参实悟，上来闲扯葛藤，以死法给人，自感惭愧，应该痛杖三十棒！


九参禅宜观心

    参禅贵实践，要真参实悟，才能得到受用。所谓真参，就是要在不落言诠、寻思、拟议处用功；所谓实悟，必须悟在无所得处。所以六祖大师说：“本来无一物，何处惹尘埃。”说似一物即不中，岂有死执一法能参禅！然而沩山灵祐禅师又说；“实际理地，不受一尘；佛事门中，不舍一法。”舍一法不成法身，住一法也不成法身。如此说来，参禅也可随取一法作方便，追虑审问参究，作破参的敲门砖。所谓敲门砖者，到击破门时，砖亦弃舍，破门而出，刹那之间，能所双忘，内外脱然，与虚空浑然一体，真正达到“本来无一物，何处惹尘埃”的境界。能如此，则身心世界洞然无物，忽然超越世出世间，永离烦恼，得大自在，诸苦顿断，佛果可期。这一种实证之境，只在当人一念观心之极，无念无相，归无所得，无所得亦不可得，这才成就了真参实悟的功夫。
    要真参实悟，首先要坚信自己本来是佛，天真自性人人具足，涅槃妙体，个个圆成，不假他求，从来自备。故三祖僧璨大师《信心铭》说：“圆同太虚，无欠无余，良由取舍，所以不如。”这种正信，须要当人解会深信。怎么解会呢？我觉得“净念观心”是最切要的方便法门。
    佛陀在《法华经·方便品》里说：“佛所成就第一希有难解之法，唯佛与佛乃能究竟诸法实相。”又说：“止止不须说，吾法妙难思。”佛是为一大事因缘出现于世的。所谓大事因缘者，就是开示众生悟入佛陀亲证实相的知见，除此无别事。故经云：“唯此一事实，余二即非真。”又说：“诸佛世尊，唯以一大事因缘故，出现于世。舍利弗，云何名诸佛世尊唯以一大事因缘故，出现于世？诸佛世尊欲令众生开佛知见，使得清净故，出现于世。欲示众生佛之知见故，出现于世。欲令众生悟佛知见故，出现于世。欲令众生入佛知见故，出现于世。舍利弗，是为诸佛以一大事因缘故，出现于世。”佛说为令众生悟入佛之知见，就是要众生亲证实念。实念是无形无相，必须以无相之心才能亲证，冥契无智亦无得，方能成就阿耨多罗三藐三菩提。明了这种极其深妙的道理，自然会坚信“净念观心”是亲证实相无相最好的方便之法。
    佛陀在华严会上说：“无一众生而不具有如来智慧，但以妄想颠倒执著，而不证得。若离妄想，一切智、自然智、无碍智，则得现前。”这说明每个众生，都具有如来智慧德相，个个现成，本来是佛，只因妄想执著而不能证得，若离妄想执著，一切现前。所以佛陀又说：“知一切法，即心自性，成就慧身，不由他悟。”我觉得最重要的一着，还得从观心反照作起，除此别求，则愈求愈远。故《华严经·升须弥山顶品》说：“若住于分别，则坏清净眼，愚痴邪见增，永不见诸佛。”同经《夜摩宫中品》里说到观心的重要性：“若人欲了知，三世一切佛，应观法界性，一切唯心造。”参禅的同道们，净念观心吧！
    世尊在灵山会上拈花示众，这时大众皆默然，唯有大迦叶尊者破颜微笑，世尊曰：“吾有正法眼藏，涅槃妙心，实相无相，微妙法门，不立文字，教外别传，传付摩诃迦叶。”很清楚，释迦牟尼当众传给大迦叶的法门，就是离言无相的涅槃妙心。此即后来六祖自悟的无性空心，心圆众妙，明镜非台，即曹溪所说的自性。诸法缘生，生空无性；诸法唯心，心幻无性。此即概括了大乘般若与大乘瑜伽两家的宗旨。破我法二执，彰真俗二谛；发理智之智，证性相之智境。至无性妙心，心即诸法，则随手举来莫非涅槃（本空无性）妙心。这种境界，实非言诠假智、拟议寻思所至，故不立文字，教外别传。但要达到这种境界，其方便之法，我觉得还是要从净念观心作起。
    《心地观经》说：“三界之中，以心为主，能观心者，究竟解脱，不能观者，永处缠缚。”佛陀在此明确指导观心的重要。如果参禅人不循观心的方便法门，岂不与佛陀的教导相违。观心反照，是为了以无念相之心亲证无相之实相。众生自性，本来清净，一切现成，不用求，不用学，无你用心处，一有用心，便远之又远矣。所以当下一念休歇便是，不向一切法求、一切心求，到心法双忘，自能独契。虽然如是，在此一刹那以前，还须时刻提撕，回观反照。《遗教经》说：“是故汝等，当好制心，制心一处，无处不办。”
    心的作用，不可思议。《宗镜录》说：“心能作佛，心作众生，心作天堂，心作地狱。心异则千差竞起，心平则法界坦然，心凡则三毒萦缠，心圣则六通自在。心空则一道清净，心有则万境纵横。”四圣六凡，都从心起，而且只在当前一念，若不念念制心，念念透脱，岂能契会真如实相！《金刚经》云：“我于阿耨多罗三藐三菩提，乃至无有少法可得，是名阿耨多罗三藐三菩提。”参禅人若会得此意，方知佛道魔道俱错。无相之心，本来清净，皎皎地光洁无染。无方圆，无大小，无长短，乃至无一切形相。无漏无为，无迷无悟，亦无人，亦无佛。大千世界海中沤，一切圣贤如电拂。法身从古至今与佛祖一般，何处欠少一毫毛，如是了了见无一物，孤迥迥地观心，即会如是等意，大须努力，尽一生观心去。离此心外，无佛可成。过去诸如来，只是明心的人；现在诸贤圣，亦是修心的人；未来修学的人，当依如是法。愿诸修道人，切莫外求。心性无染，本自圆成，但离妄缘，即如如佛。所以二祖慧可常教导学人说：“是心是佛，是心是法，法佛无二，僧宝亦然。”三祖僧璨大师说：“至道无难，唯嫌拣择，但莫憎爱，洞然明白。”又说：“一心不生，万法无咎。”诸法如梦，亦如幻化，故妄念本寂，尘境本空，诸法皆空处，灵知不昧，即此空寂灵知之心，即是当人本来面目。亦是三世诸佛、历代祖师、天下善知识的相传的法印。若悟此心，真所谓不践阶梯，径登佛地，步步超三界，归家顿绝疑。
    下面抄几段祖师语录，以供参禅者观心时体会参考：
    六祖慧能大师说：“但一切善恶都莫思量，自然得人清净心体，湛然常寂，妙用恒沙。”
    一日谓众曰：“诸善知识，汝等各各净心，听吾说法，汝等诸人自心是佛，更莫狐疑，外无一物而能建立，皆是本心生万法故。经云：心生种种法生，心灭种种法灭。”
    “何名无念，若见一切法，心不染著，是为无念。”
    “悟无念法者，万法尽通；悟无念法者，见诸佛境界；悟无念法者，至佛地位。”
    “何名坐禅？”对于一切善恶境界，心念不起名为坐，内见自性不动名为禅。何名禅定？外离相名禅，内不乱为定。若见诸境不乱者，是真定也。”
    永嘉禅师曰：“忘缘之后寂寂，灵知之性历历，无记昏昧昭昭，契真本空皎皎。惺惺寂寂是，无记寂寂非；寂寂惺惺是，乱想惺惺非。……今言知者，不须知知，但知而已，则前不接灭，后不引起，前后断续，中间自孤，当体不顾，应时消灭。知体既已灭，豁然如托空，寂尔少时间，唯觉无所得，即觉无觉，无觉之觉，异乎木石，此是初心处。冥然绝虑，乍同死人，能所双忘，纤缘尽净，阒尔虚寂，似觉无知，无知之性，异乎木石，此是初心之处，领会难为。人初心时，三不应有：一恶，谓思维世间五欲等因缘。二善，谓思维世间杂善等事。三无记，谓善恶不思，阒尔昏住。”
    南岳怀让禅师，诣曹溪参六祖。祖问甚来？曰：嵩山。祖曰：什么物，凭么来！师无语。遂经八载，忽然有省，乃问祖曰：某甲有个会处。祖曰：作么生？师曰：说似一物即不中。祖曰：还假修证否？师曰：修证则不无，染污即不得。祖曰：只此不染污，诸佛之所护念。汝既如是，吾亦如是。
    马祖道一禅师示众云：“汝等诸人各信自心是佛，此心即达磨大师从南天竺来至中华，传上乘一心之法，令汝等开悟。”
    “道不用修，但莫染污。”
    问曰：“阿那个是慧海自家宝藏？”祖曰：即今问者，是汝宝藏，一切具足，更无欠少，使用自在，何假向外求觅。海于言下自识本心，不由知觉，踊跃礼谢。”
    百丈怀海禅师说：“灵光独耀，迥脱根尘，体露真常，不拘文字。心性无染，本自圆成，但离妄缘，即如如佛。”
    问：“如何是大众顿悟法要？师曰：汝等先歇诸缘，休息万事，善与不善，世出世间一切诸法，莫记忆，莫攀缘，放舍身心，令其自在，如水石无所辨别，心无所行。心地若空，慧日自现，如云开日出相似。”
    黄檗希运断际禅师说：“唯此一心即是佛，佛与众生更无别异。但是众生，著相外求，求之转失。使佛觅佛，将心捉心，穷劫尽形，终不能得，不知息念忘缘虑，佛自现前。”
    “学道人若欲得成佛，一切佛法，总不用学，唯学无求无著，无求即心不生，无著即心不灭，不生不灭，即是佛。”
    “忘境犹易，忘心至难。人不敢忘心，恐落空无捞摸处。不知空本无空，唯一真法界耳。”
    “但自忘心，同于法界，便得自在，此即是要节也。”
    “凡人多为境碍心，事碍理。常欲逃境以安心，屏事以存理。不知乃是心碍境，理碍事。但令心空境自空；但令理寂事自寂，勿倒用心也。”
    “尘劳迥脱事非常，紧把绳头做一场，不是一番寒彻骨，怎得梅花扑鼻香。”
    临济义玄禅师上堂云：“赤肉团上有一无位真人，常向汝诸人面门出入，未证据者看看。”时有僧出问：如何是无位真人？师下禅床，把住云：道！道！其僧拟议，师托开曰：“无位真人，是什么干屎橛。”。
    “道流，即今目前孤明历历地听法者，此人处处不滞，通贯十方，三界自在。”
    “尔取山僧口里语，不如休歇无事去。已起者莫续，未起者不要放起。便胜尔十年行脚。”
    南岳石头希迁大师，上堂曰：“吾之法门，先佛传授。不许禅定精进，唯达佛之知见。即心即佛，心佛众生，菩提烦恼，名异体一。汝等当知，自己心灵，体离断常，性非垢净。湛然圆满，凡圣齐同。应用无方，离心意识。三界六道，唯自心现。水月镜像，岂有生灭？汝能知之，无所不备。”
    洞山良价禅师：“直须心心不触物，步步无处所，常无间断，始得相应。”
    “道无心合人，人无心合道，欲识个中意，一老一不老。”
    曹山本寂禅师：“师辞洞山，洞山问：什么处去？曰：不变异处去。山云：不变异处岂有去耶？师曰：去亦不变异。遂辞去。”
    师作四禁偈曰：“莫行心处路，不挂本来衣，何须正凭么，切忌未生时。”
    五祖弘忍大师：“唯有一乘法，一乘者一心是。”“但守一心，即心真如门。”
    圆悟禅师：“不必厌喧求静，但令中虚外顺。”“内心既虚，外缘亦寂。”
    “直截省要最是先忘我见，使我虚静怡和，任运腾腾，腾腾任运，于一切法，皆无取舍。”
    晦堂：“诚能心无异缘，意绝妄想，六窗寂静，端坐默究，万不失一也。”
    傅大士：“欲求成佛，莫染一物。”
    临济云：“大凡学人，先要明悟自己真正见解，若悟得自己见解，就不被生死所染，去住自由。不要求他殊胜而殊胜自备。然今不得者，病在不自信取。自信不及，即便忙忙，徇一切世境，滞惑积业。诸仁者，若能歇得念念驰求心，便与祖佛不别。汝欲识佛祖么？即汝目前听法底是。由汝自信不及，便向外驰求，得者只是文字禅，与佛祖大远在。诸大德，此时不求真悟，万劫千生，轮回三界，徇好恶境，向驴牛肚里去也。汝若自信得及，欠少什么，六道神光未曾间歇。一念净光，是汝法身佛；一念无分别光，是汝报身佛；一念无差别光，是汝化身佛。此三身，即今目前听法底人。为不向外求，有此三种功用。然此三种，亦只是名言。故云身依义而立。据实而论，法性身，法性土，明知是光影。诸大德，切要识取弄光影人，是诸佛本源，是一切法根本。诸大德，四大色身，不解说法听法，虚空不解说法听法。是汝目前历历孤明勿形段者，解说法听法。所以山僧向汝道，五蕴身田，内有无位真人，堂堂显露，无丝毫许间隔，何不识取。心法无形，通贯十方。在眼曰见，在耳曰闻，在手执捉，在足运奔。心若不生，随处解脱。山僧见处，坐断报化佛头，十地满心，如客作儿。等妙二觉，如担枷锁。罗汉辟支，如著粪土。菩提涅槃，如系驴橛。何以如斯？盖为不达三祗劫空，有此障隔。若是真道流尽不如此……时光可惜。”
    如上所抄祖师们对观心的教导，善领会者，一定能受到很大启发，善巧用之，可以冲破凡圣关，直至成佛去。总起来讲，必须以无心之法对治妄心，真心才能显现。生死涅槃本来平等，妄心歇处即是菩提。有人疑惑说：人若无心，便同草木顽石，岂能参禅？这是错误的看法。所谓无心，非无心体，名为无心；心中无物，名曰无心。德山禅师说：“汝但无事于心，无心于事，则虚而灵，空而妙。”
    历代祖师说无心功夫，类各不同，有多种方法，今据《真心直说》略举三种以作参究：
    一曰觉察。谓做工夫时，平常绝念，提防念起，一念才生，便与觉破，妄念觉破，后念不生，此之念智，亦不须用，妄觉俱忘，名曰无心。故祖师云；“不怕念起，只恐觉迟。”三祖云：“不用求真，唯须息见。”此是息妄工夫。
    二曰休歇。谓做工夫时，不思善，不思恶，心起便休，遇缘便歇。古人云：“一条白练去，一念万年去，冷湫湫地去，古庙香炉去。”直得绝纤尘，离分别，如痴似兀，方有少分相应。此是休歇妄心工夫。
    三曰透出体用。谓做工夫时，不分内外，亦不辨东西南北，将四方八面只作一个大解脱门，圆陀陀地，光皎皎地，体用不分，无分毫渗漏，通身打成一片，其妄何处得起。古人云：“通身无缝罅，上下忒团圞。”是乃透出体用灭妄功夫。
    上引三种用功方法，但得一门相应，即便习之，工夫成熟，其妄自灭，真心即现。
    参禅观心，主要是息灭妄心，真心自现。如是做工夫，唯在静坐，还是亦通行住卧等？静坐参究是完全必要的，而且绝不可少，每天昼夜必须有一定时间静坐，但在行住坐卧日用云为中，都必须注意息妄工夫。动中得力，静坐时自然相应。永嘉云：“行亦禅，坐亦禅，语默动静体安然。”这是把禅与生活打成一片。工夫用得纯熟的人，千圣兴来惊不起，万般魔妖不回顾。只恐不信不为，若信若为，则四威仪中道必不失，常现在前。《起信论》说：“若修止者，住于静处，端身正意，不依气息，不依形色，不依于空，不依地水火风，乃至不依见闻觉知。一切诸想，随念皆除，亦遣除想。以一切法本来无相，念念不生，念念不灭，亦不得随心外念境界。后以心除心。心若驰散，即当摄来住于正念。是正念者，当知唯心，无外境界。既复此心亦无自相，念不可得。若从坐起、去来、进止，有所施作，于一切时，常念方便，随顺观察，久习纯熟，其心得住，以心住故，渐渐猛利，随顺得入真如三昧。深伏烦恼，信心增上，速成不退。”这是马鸣菩萨明确开示学人，在去来进止一切时中，常念方便，随顺观察，以息妄心。
    上来拉扯了许多葛藤，给人缠缚不少，与禅宗宗门下解粘去缚，无一实法与人的教导大相径庭。但我觉得初学做功夫的人，把这葛藤作为参禅的入门方便，还是有些用处的。


十曹洞临济参禅方法的差异

    中国的禅宗，有五家七派之分，在用功的方法上，也多少有些差异。沩仰、云门、法眼等久已绝响。今仅就曹洞、临济两宗的用功方法，略说其差异。
    曹洞主知见稳实，临济尚机锋峻烈。曹洞贵婉转，临济尚直截。曹洞似慈母，临济如严父。后世评论这两宗，有临济将军，曹洞士民之说。流衍及于宋代，一变而为大慧宗杲与宏智正觉相对立之禅风。
    曹洞的祖师药山惟俨禅师，一日坐次，有僧问：“兀兀地思量什么？”师曰：“思量个不思量底。”曰：“不思量底如何思量？”师曰：“非思量。”这一问答，成为曹洞参禅极致立场的根基，特别是日本的曹洞宗如此。思量，是有心；不思量，是无心。从偏于一方来说，有心即是病，无心也成病。现在不涉于有心的思量，也不沉于无心的不思量，以超脱散乱与昏沉的当体，名曰：“思量个不思量底。”换一句话来，即“非思量”是坐禅的当体，即离造作的种种意念，又非无心不思的冥顽状态，是思量而不思量，不思量而思量。所以这非思量的“非”，不是否定之意，是指坐禅时灵明寂照的正念，就是非思量的意义。非思量便是解脱。以此为坐禅的正念、正思维，便是脱体现成地离迷悟、超凡圣，念念悉正，心心皆不染污的心行。所以日本曹洞宗绍瑾莹山禅师在《坐禅用心记》中说：于此思量个不思量底，如何思量？谓非思量，此乃坐禅要法也。直须破断烦恼，亲证菩提。日本曹洞宗开祖道元禅师在《坐禅仪》中更说：“若得此意，则如龙得水，似虎靠山，当知正法自现象前，昏散先扑落。”在这里发生了坐禅与开悟有如何关系的问题。曹洞宗认为：正传之坐禅，不可求悟于坐禅之外。故坐禅的真境界，是在于不思量的正念。若正念相续，虽行住坐卧，动止威仪，亦不暂离，即可说是大悟的人。日本道元禅师说：“非可测知，以坐禅是悟门之事。悟者，只管打坐。”故此宗坐禅的正传，不是待悟的坐禅，坐禅的当体，就是坐佛、作佛。
    曹洞宗的这一参禅的立场，宏智正觉禅师所著的《默照铭》及《坐禅箴》中，阐发极透。如《默照铭》说：
    默默忘言，昭昭现前。鉴时廓尔，体处灵然。
    灵然独照，照中还妙。露月星河，雪松云峤。
    晦而弥明，隐而愈显。鹤梦烟寒，水含秋远。
    浩劫空空，相与雷同。妙存默处，功用照中。
    妙存何存，星星破昏。默照之道，离微之根。
    彻见离微，金梭玉机。正偏宛转，明暗因依。
    依无能所，底时回互。饮善见药，挝涂毒鼓。
    回互底时，杀活在我。门里出身，枝头结果。
    默唯至言，照唯普应。应不堕功，言不涉听。
    万象森罗，放光说法。彼彼证明，各各问答。
    问答证明，恰恰相应。照中失默，便见侵凌。
    证明问答，相应恰恰。默中失照，浑成剩法。
    默照理圆，莲花梦觉。百川赴海，千峰向岳。
    如鹅择乳，如蜂采花。默照至得，输我宗家。
    宗家默照，透顶透底。舜若多身，母陀罗臂。
    始终一揆，变态万差。和氏默璞，相如指瑕。
    当机有准，大用不勤。寰中天架，塞外将军。
    吾家底事，中规中矩。传去诸方，不要赚举。
    《铭》意说明，应以清净之心，默照内观，彻见法源，无纤毫障碍，廓然亡象。如澄净的秋潭水，如静夜的明月光，澄净孤明，自在无双。
    他在《坐禅箴》里说：“佛佛要机，祖祖机要，不触事而知，不对缘而照。不触事而知，其知自微；不对缘而照，其照自妙。其知自微，曾无分别之思，其知无偶而奇，曾无毫忽之兆，其照无取而了。水清彻底兮，鱼行迟迟；空阔莫涯兮，鸟飞杳杳。”
    《箴》之意趣是把非思量结合默照予以阐发说明，揭示出曹洞宗参禅的观点。
    临济的参禅，特别重视妙悟见性。其成为妙悟的条件，必须穷心绝路。就是要离却我们的感觉作用、思维作用、分别作用，达到平等无差，转变自我而达到无我无分别智。黄檗禅师《传心法要》说：“此心，即无心也。若离一切相，则众生与佛，更无差别，若能无心，便是究竟。”说明禅的极致就是要认取无心之心，将“知”穷追到百尺竿头，使之入于死地。这就是穷心绝路，已超越了主客观的对立，宇宙无双，物我不二，体得“天上天下，唯我独尊”之境。至此才是无生死、无修证、无凡圣，纯一绝待的境界。
    穷心绝路，不容易做到，但参禅者必须做到这一点，才能见性，悟无所得，否则必将半途而废。因此，黄壁禅师以悲切婆心，首先提出参“话头”的方法作为参禅的敲门砖。他在示众时说：“若是丈夫汉，看个公案。僧问赵州：狗子还有佛性也无？州云：无。但去二六时中，看个无字，昼参夜参，行住坐卧，著衣吃饭处，屙屎放尿处，心心相顾，猛著精采，守个无字。日久月深，打成一片，忽然心花顿发，悟佛祖之机，便不被天下老和尚舌头瞒。便会开大口，达磨西来，无风起浪。世尊拈花，一场败缺。到这里说甚阎罗老子，千圣尚不奈尔何。不信道，直有这般奇特，为甚如此，事怕有心人。”（见《黄檗断际禅师宛陵录》）
    赵州从谂禅师，是我国禅宗史上杰出的宗匠。当时人称“赵州古佛”。他在接引学人时有“狗子无佛性”的公案。僧问：狗子还有佛性也无？师云：无。问：上至诸佛下至蝼蚁皆有佛性，狗子为什么却无？师云：为伊有业识在。僧又问：狗子还有佛性也无？师云：有。问：既有，为什么入这皮袋里来？师曰：知而故犯。
    对于这个公案，赵州有两种答法：一说“有”，一说“无”。照理解上说，似乎有矛盾。但就赵州的立场而言，他是适应问话者的根性而有不同的答案，无定法与人，使提问的人不落于知见。赵州答“无佛性”的原因，著重于“业识在”，然而“业识在”的根本著眼点在这个“无”字上。这是打破禅关之门的铁椎，是截断烦恼及文字上种种葛藤的利斧。
    黄檗与赵州是同时代的大德，他认为赵州的“无”字公案是参禅的一关，打破这一关，必能心花顿发，彻悟祖佛之机。
    无门禅师曰：“参禅虽透祖师关，妙悟要穷心路绝。祖关不透，心路不绝，尽是依草附木精灵。且道如何是祖师关？只者一个无字，乃宗门一关也，遂目之曰：禅宗无门关。透得过者，非但亲见赵州，便可与历代禅师把手共行，眉毛厮结，同一眼见，同一耳闻，岂不庆快。莫有要透关底么？将三百六十骨节，八万四千毫窍，通身起个疑团，参个无字，昼夜提撕，莫作虚无会，莫作有无会，如吞了一个热铁丸相似，吐又吐不出，荡尽从前恶知恶觉，久久纯熟，自然内外打成一片，如哑子作梦，只许自知。蓦然打破，惊天动地，如夺得关，将军大刀在手，逢佛杀佛，逢祖杀祖；于生死岸头得大自在，向六道四生中游戏三昧。且作么生提撕？尽平生气力，举个无字，若不间断，好似法烛，一点便着。颂曰：狗子佛性，全提正令，才涉有无，丧身失命。”（见《大正藏》四八《无门关》）
    参话禅发展到宋朝，与宏觉正智禅师同时的大慧宗杲禅师，特别反对默照禅，而大力提倡参话禅，斥默照禅为邪禅。他说：“若未得真无心，只据说底，与默照邪禅，何以异哉？”又说：“若执寂静处便为究竟，则被默照邪禅之所摄持矣！”大慧宗杲觉参禅者用参话头的方法追虑审问，便可抵挡和打破一切杂念妄想而达到真正无心见自本性的目的。他说：“赵州狗子无佛性话，喜怒静闹处，亦须提撕，第一不得用意等悟，若用意等悟，则自谓我今即迷。执迷待悟，纵经尘动，亦不能得悟。但举话头时，略抖擞精神，看是个什么道理。”（见《大慧普觉禅师法语》卷十九）
    又说：“常以生不知来处，死不知去处，二事贴在鼻孔尖上，茶里饭里，静处闹处，念念孜孜，常似欠却人百万贯钱债，无所从出，心胸烦闷，回避无门，求生不得，求死不得，当凭么时，善恶路头，相次绝也。觉得如此时正好著力，只就这里看个话头。僧问赵州：狗子还有佛性也无？州云：无。看时不用博量，不用注解，不用要得分晓，不用向开口处承当，不用向举起处作道理，不用堕在空寂处，不用将心等悟，不用向宗师说处领略，不用掉在无事匣里。但行住坐卧，时时提撕：狗子还有佛性也无？无！提撕得熟，口议心思不及，方寸里七上八下，如咬生铁橛，没滋味时，切莫退志，得如此时，却是个好的消息。”（同上第二十一卷）
    又说：“但自时时提撕，妄念起时，亦不必将心止遏。只看个话头，行提撕，坐也提撕，提撕来，提撕去，没滋味，那时便是好处，不得放舍，忽然心花发明，照十方刹，便能于一毛端，现宝王刹，坐微尘里，转大法轮。”（见《大慈普觉禅书》）
    大慧宗杲在参话头方面，对四众参禅者指示教导很多，阐述也非常详尽，兹不多举了。
    参话头的方法虽各有不同，总起来说，都是参一则无义味语，使人不就意识思维穿凿，但净净地参究，大发疑情，力求透脱。如咬铁丸相似，定要咬碎，嚼不碎，拼命嚼。如是回光就己，返境观心，忽然把一切妄想杂念照破，[囫-勿+力]地一声，洞见父母未生以前本来面目。
    话头就是公案，又叫古则。《传灯录》中一千七百则公案都是话头。不过大慧宗杲特别喜欢提狗子无佛性的“无”字公案。其他如看“万法归一，一归何处”，要紧是一归何处。或参究“念佛是谁”，要紧是在念佛的是谁。或参须弥山、或参庭前柏树子、或参死了烧了、或参父母未生前本来面目等等，认定一个与自己意志相近，最能发起疑情者，二六时中追虑参究，即为自己的本参话头。确定本参话头之后，不要随便改换。似银山铁壁看去，一时不了，看一岁，一岁不了，看一纪。拼却今生来生，与之抵对。久之久之，一时参破，万有皆空。并此无义味话头，亦了不可得。当下百杂粉碎，觌体纯真。[囫-勿+力]地无声，省然无著落处，而知有著落在。
    参话头一法，禅家称为“无事不办”的法门，值得参禅者注意体会运用。
    中峰和尚《坐禅论》说：“坐禅别无用心处，只十二时中，放下一切尘劳妄想，常令自心如虚空，毫发计使无他念。若得自心清净，还不思善不思恶，正当与么时，如何是我父母未生以前本来面目。如是看，若工夫一片成，自然得有悟入。何名坐禅？外于一切善恶境界，念念不起名为坐，内见自性不动名为禅。如今学道人，不悟此心体，便于心上生心，而向外求佛，着相修行，皆是恶法，非菩萨道。”
    朝鲜高僧葆真大师，于明朝嘉靖万历年间住曹溪十数年，特别阐明临济宗旨，撰《禅家龟鉴》，并于各句下加以注释，由弟子惟政更作评文，授与室中弟子，以资参学。
    这里从《禅家龟鉴》引一段文如下：
    “大抵学者，须参活句，莫参死句。
    活句下荐得，堪与佛祖为师。死句下荐得，自救不了。此下特举活句，使自悟入。
    要见临济，须是铁汉。
    评曰：话头有句、意二门。参句者，径截门活句也。没心路，没语路，无摸索故也。参意者，圆顿门死句也。有理路，有语路，有闻解思想故也。
    凡本参公案上，切心做工夫。如鸡抱卵，如猫捕鼠，如饥思食，如渴思水，如儿忆母，必有透彻之期。
    祖师公案，有一千七百则，如狗子无佛性、庭前柏树子、麻三斤、乾屎橛之流也。鸡之抱卵，暖气相续也。猫之捕鼠，心眼不动也。至于饥思食、渴思饮、儿忆母，皆出于真心，非做作的心，故云切也。参禅无此切心，能透彻者，无有是处。
    参禅须具三要：一有大信根，二有大愤志，三有大疑情。苟缺其一，如折足之鼎，终成废器。
    佛云：成佛者，信为根本。永嘉云：修道者先须立志。蒙山云：参禅者不疑言句，是为大病。又云：大疑之下，必有大悟。
    日用应缘处，只举狗子无佛性话，举来举去，疑来疑去，觉得没理路，没义路，没滋味，心头热闹时，便是当人放身命处，亦是成佛作祖的基本也。
    僧问赵州：狗子无佛性也无？州云：无。
    此一无字，宗门之一关。亦是摧许多恶知恶觉的一杖。亦是诸佛面目，亦是诸佛骨髓也。须透得此关，然后佛祖可期也。古人颂云：赵州露刃剑，寒霜光焰焰，拟议问如何？分身作两段。
    话头不得举起处承当，不得思量承度。又不得将迷待悟，就不可思量处，思量心无所之。如老鼠入牛角，便见倒断也。又寻常计较安排的是识情，随生死迁流的是识情，怕怖张惶的是识情，今人不知是，只管在里许头出头没。
    话头有十种病，曰意根下卜度，曰扬眉瞬目处挆根（挆音朵，动摇、揣度之意），曰语路上作活计，曰文字中引证，曰举起处承当，曰飏在无事匣里，曰作有无会，曰作真无会，曰作道理会，曰将迷待悟也。离此十种病者，但举话时略抖擞精神，只疑是个甚么。
    此事如蚊子上铁牛，更不问如何若何，下咀不得处，拚命一攒，和身透人。
    重结上意：使参话句者，不得退屈。古云：参禅须透祖师关，妙悟要穷心路绝。
    工夫如调弦之法，紧缓得其中，勤则近执着，忘则落无明，惶惶历历，密密绵绵。
    弹琴者曰：
    缓急得中，然后清音普矣。工夫亦如是，急则动血囊，忘则入鬼窟。不徐不疾，妙在其中。
    工夫到行不知行，坐不知坐，当此之时，八万四千魔军，在六根门头伺候，随心生设。心若不起，争如之何？
    魔者，乐生死之鬼名也。八万四千魔军者，乃众生八万四千烦恼也。魔本无种，修行失念者，遂派其源也。众生顺其境故顺之，道人逆其境故逆之，故云道高魔盛也。禅定中，或见孝子而斫股，或见猪子而把鼻者，亦自心起见，感此外魔也。心若不起，则种种伎俩，翻为割水吹光也。古云：壁隙风动，心隙魔侵。
    起心是天魔，不起心是阴魔，或起或不起是烦恼魔，然我正法中，本无如是事。
    大抵忘机是佛道，分别是魔境。然魔境梦事，何劳辨诘。工夫若打成一片，则纵今生透不得，眼光落地之时，不为恶业所牵。
    业者无明也，禅者般若也。明暗不相敌，理固然也。”
    （《禅学大成》第四册《禅家龟鉴》）
    上面引证的文字，对于了解和认识临济宗旨及参究话头的意义，至关重要，故加以摘录，以供参禅者参考。


十一见性成佛

    见性是禅宗的根本目的，参禅者必须透过的关门，古今参禅人的第一要事。所谓“见性”，即开发自性，彻见自己本来心性，自觉到本来具有的佛性。换句话说，就是离一切对待，一切矛盾，超然独脱，无执著，无绊累，触着普遍法界的无我的大我作用，无碍地适应社会，至此名为“无位真人”，或曰“闲道人”。达磨大师来中国，举扬“直指人心，见性成佛”的宗旨，也就是传此见性之法，使参禅之人实现独脱自在的境界而已。
    五祖弘忍对六祖慧能宣说《金刚经》至“应无所住而生其心”，慧能言下悟彻一切万法不离自性之旨。遂启弘忍：“何期自性，本自清净；何期自性，本不生灭；何期自性，本自具足；何期自性，本无动摇；何期自性，能生万法。”弘忍知慧能已悟本性，遂谓之曰：“不识本心，学法无益。若识自本心见自本性，即名丈夫、天人师、佛。”大悟者，觉破了无始以来的迷妄，开显了真实的知见，身心廓然，没有一切尘垢习染，孤迥迥地，光皎皎地，活泼泼地，洞然同于太虚，不曾生，不曾灭，所以不生不灭。心的自性，不从外来，不自他得，性含万法，本自具足。自性本无动摇，自性能生万法。如《传心法要》说：“此灵觉性，无始以来，与虚空同寿，未曾生，未曾灭，未曾有，未曾无，未曾秽，未曾净，未曾喧，未曾寂，未曾少，未曾老。无方所，无内外，无数量，无形相，无色相，无音声。不可觅，不可求。不可以智慧识，不可以言语取，不可以境物会，不可以功用到。诸佛菩萨与一切蠢动含灵，同此大涅槃性。性即是心，心即是佛，佛即是法，一念离真，皆为妄想。不可以心更求于心，不可以佛更求于佛，不可以法更求于法。故学道人，直下无心，默契而已，拟心即差。以心传心，此为正见。”所谓“本心”者，就是不青不黄，不赤不白，不长不短，不去不来，非垢非净，不生不灭，湛然常寂的心体是。悟此本心，见此自性，其人功德，无有边际，内外圆明到处皆通。
    达磨来华时，中国佛教处在由译经进入研究的过渡时期，佛教界偏重于教理的研究，对生命的解脱疏忽，可以说是堕到戏论中去了。所以达磨大师特别提示出佛教的本旨，不在经教语言文字，是以求解脱为务。宋代的蒋之奇在《楞伽阿跋多罗宝经序》里说：“至于像法末法之后，去圣既远，人始溺于文字，有入海算沙之困，而于一真之体，乃漫不省解。于是有祖师出焉，直指人心，见性成佛，以为教外别传。”这是从外在的理由，即当时的佛教界客观上的趋势来说，达磨大师为了针砭时弊，而特地提出“见性成佛”。
    圭峰宗密禅师在《禅源诸诠集都序》里也说：“达磨受法天竺，躬至中华，见此方学人，多未得法，唯以名数为解，事相为行。欲令知月不在指，法是我心故，但以心传心，不立文字，显宗破执，故有斯言。非离文字，说解脱也。”达磨针对佛教学者这种疏忽内省的弊病，令知月不在指，而必须识自本心，见自本性，冲破凡圣关，直至解脱自在，所以说：“直指人心，见性成佛。”
    《景德传灯录》卷三载明初祖达磨大师付二祖衣法之后说：“吾灭后二百年，衣止不传法周沙界。明道者多，行道者少；说理者多，通理者少。潜符密证，千万有余。汝当阐扬，勿轻未悟，一念回机，便同本得。”教诫他不要随顺众流，负担起弘传正法眼藏的重任，要令诸众生开示悟入心地要门。
    从内在的理论来说，学佛的人，首先应该注重实践，经教语言，不过是对学佛人应当如何作为的教授教诫，作为思想修养的指导，对照自己的修行办道和体验是否正确，用以鞭策自己。解脱自在，并不在经教文字上，它不过是指示修道的方法而已。所以《华严经》说：“如人数他宝，自无半分钱，于法不修行，多闻亦如是。”《华严经·如来出现品》还说：“如来智慧无处不至。何以故？无一众生而不具有如来智慧，但以妄想颠倒执著，而不证得。若离妄想，一切智，自然智，无碍智，则得现前。”这是释迦世尊，对众生具足如来智慧德相，由于妄想执著而不能证得的慨叹。大慈大悲的佛陀，对众生是深怀爱念如一子想！
    释迦世尊在《法华经》里说：“舍利弗，诸佛随宜说法，意趣难解。所以者何？我以无数方便，种种因缘，譬喻言辞演说诸法，是法非思量分别之所能解。唯有诸佛，乃能知之。所以者何？诸佛世尊，唯以一大事因缘故出现于世。诸佛世尊，故令众生开佛知见，使得清净故，出现于世。欲示众生佛之知见故，出现于世。欲令众生，悟佛知见故，出现于世。欲令众生入佛知见道故，出现于世。舍利弗，是为诸佛以一大事因缘故，出现于世。”“佛知见”，即彻了实相真如的真见。在法，名一佛乘，在因，名一大事，在果，名一切种智。此真知见，生佛平等具有，本来清净，惟有情自己为无明烦恼障碍而迷失不能证得。如来大慈大悲，就是为了众生开示悟入佛的知见这一大因缘出现世间。所以达磨大师来到中国，倡导“直指人心，见性成佛。”
    见性成佛的“见性”，是见什么性？根据在哪里呢？所谓见性，即彻见自心之佛性。如达磨的《血脉论》说：“若欲见佛，须是见性。性即是佛。若不见性，念佛诵经，持斋持戒，亦无益处。”他在《悟性论》里说：“直指人心，见性成佛，教外别传，不立文字。”六祖也在《坛经》里说：“善知识菩提般若之智，世人本自有之，只缘心迷，不能自悟。须假大善知识，示导见性。当知愚人智人佛性本无差别。”黄檗《传心法要》说：“即心是佛，上至诸佛，下至蠢动含灵，皆有佛性，同一心体。所以达磨从西天来，唯传一法，直指一切众生本来是佛，不假修行。但如今识取自心，见自本性，更莫别求。”日本永平道元禅师法语也说：“见性者，佛性也。万法之实相，众生之心性也。”这些语句，都说明了见性就是彻见佛性。一个参禅办道人，如果能彻见自己的佛性，就能自由独立，成为解脱自在的无位真人。
    关于谈“见性”的道理，在许多大乘经典里都有所指示，但明确说一切众生皆有佛性而又说得最多者，则为《大般涅槃经》。如该经卷二七说：“一切众生悉有佛性，烦恼覆故，不能得见。”同卷还说：“佛性者，即是一切诸佛阿耨多罗三藐三菩提中道种子。”卷二十八说：“譬如初月，虽不可见，不得言无。佛性亦尔，一切凡夫虽不得见，亦不得言无佛性也。”同卷还说：“善男子！众生佛性诸佛境界，非是声闻缘觉所知。一切众生不见佛性，是故常为烦恼系缚，流转生死。见佛性故，诸结烦恼所不能系，解脱生死，得大涅槃。”卷十说：“一切众生同一佛性，无有差别。以其先闻如来密藏，后成佛时，自然得知。”卷二十说：“复愿诸众生，永破诸烦恼，了了见佛性，犹如妙德等。”这些经文说明一切众生皆具有佛性，为什么不能得见呢？就是为烦恼所缚，如果得见佛性，就能破除烦恼而证得解脱涅槃，所以说佛性是阿耨多罗三藐三菩提的种子。还说明了，既然一切众生都有佛性，声闻缘觉已断烦恼何以也不见佛性呢？佛说这不是声闻缘觉所能知道的，唯是诸佛的境界，所以声闻缘觉等不见不知，等于初月，虽不可见，不得言无。
    佛性如何见呢？首先说一说初祖达磨大师为二祖所说法偈：“外息诸缘，内心无喘，心如墙壁，可以入道。”二祖依所教导而行，果然达到空寂灵知，湛然圆寂，不生不灭，朗照明净，言语道断，心行处灭，心境一如，成为继承禅宗的二祖。
    读一读六祖慧能大师对惠明禅师的开示，也可以领会一些见性的意趣。六祖对惠明说：“汝既为法而来，可屏息诸缘，勿生一念，吾为汝说。”明良久。六祖云：“不思善，不思恶，正凭么时，哪个是明上座本来面目？”惠明言下大悟。“屏息诸缘，不生一念”，与达磨大师所说“外息诸缘，内心无喘”，是一致的。诸缘就是色声香味等一切世间所有的所缘相，都是自己虚妄心识的攀缘，必须屏息。内心中不生一念，就是十八界法空，一切处无心无念，即心便是灵智。善恶都莫思量，当处便出三界。诸法皆空之处，灵知不昧，即此空寂灵知之心，即是本真自性，亦是佛性，亦是本来面目。
    六祖四代法孙药山惟俨禅师在习禅时曾问石头希迁：“三乘十二分教，某甲粗知，尝闻南方直指人心，见性成佛，实未明了，伏望和尚慈悲指示。”石头曰：“凭么也不得，不凭么也不得，凭么不凭么总不得。子作么生？”师罔措。石头曰：“子因缘不在此，且往马大师处去。”师禀命参礼马祖，仍申前问。祖曰：“我有时教伊扬眉瞬目，有时不教伊扬眉瞬目，有时扬眉瞬目者是，有时扬眉瞬目者不是。子作么生？”师于言下契悟，便礼拜。祖曰：“你见什么道理便礼拜？”师曰：“某甲在石头处，如蚊子上铁牛。”祖曰：“汝既如是，善自护持。”侍奉三年，重反石头。这是以解粘去缚、抽钉拔楔、不立文字语言、不与死法模拟，实即不思善不思恶，离却一切粘著的教导手法，所以能使问者见性得悟。
    《修心诀》说：“问：‘作何方便，一念回机便悟自性？’答：‘只汝自心，更作什么方便，若作方便更求解会，比如有人不见自眼，以谓无眼，更欲求见，既是自眼，如何更见，若知不失，即为见眼。更无求见之心，岂有不见之想。自己灵知亦复如是。既是自心，何更求会。若欲求会，便会不得，但知不会，是即见性’。”又说：“诸法如梦，亦如幻化。故妄念本寂，尘境本空。诸法皆空之处，灵知不昧。即此空寂灵知之心，是汝本来面目，亦是三世诸佛、历代祖师、天下善知识，密密相传底法印也。若悟此心，真所谓不践阶梯，径登佛地。步步超三界，归家顿绝疑。”又说：“又僧问归宗和尚如何是佛？宗云：‘我今向汝道，恐汝不信。’僧云：‘和尚诚言，焉敢不信。’师云：‘汝即是。’僧云：‘如何保任？’师云：‘一翳在眼，空华乱坠。’其僧言下有省。”
    特别要注意的是：“一翳在眼，空华乱坠”。参禅办道的人在见色闻声时，但如此；穿衣吃饭时候，但如此；屙屎放尿时，但如此；对人接谈时，但如此。乃至行住坐卧，或语或默，或喜或怒，一切时中，一一如是。但虚舟驾浪，随高随下，如流水转山，遇曲遇直，而心心无知。今日腾腾任运，明日任运腾腾。随顺众缘，无障无碍。于善于恶，不断不修。质直无伪，视听寻常。则绝一尘而作对，何劳遣荡之功；无一念而生情，不假忘缘之力。但我们无始以来，烦恼习气深厚，在遇缘对境时，难免不被波动。若有念起，就体消停。就是念起即觉，觉之即无，久久忘缘，自成一片。
    诸修道人，莫生放逸，不忘照顾，无常迅速，身如朝露，命若西光，今日虽存，明亦难保，切须在意。此身不向今生度，更待何生度此身。一失人身，万劫难复，请须慎之。佛祖机要，唯此一事实。不必厌喧求静，但令中虚外顺，内心既虚，外缘亦寂，直截省要。最是先忘我见，内虚静恬，任运腾腾，腾腾任运，于一切法皆无取舍。然后无行不圆，于办道途中，得无间用力，见性成佛去吧。
    还应该特别注意，所谓“见性成佛”者，只是冲破了凡圣关，悟道而已，踏上了真正成佛的道路。古德说顿悟渐修之义，切不可忽视。未悟的参禅之士，更不可稍轻福智二资粮的培植。有个僧人问南阳慧忠国师：“若为得成佛去？”师曰：“佛与众生一时放却，当处解脱。”曰：“作么生得相应去？”曰：“善恶不思量，自见佛性。”曰：“即心是佛，可更修万行否？”师曰：“诸圣皆具二严，岂拨无因果耶？”离了福德智慧的庄严，谁也成不了佛！


十二公案的启示

    佛教各宗派，均有所依据的经验。依经论而有教相，依教相而显示其观点，判摄佛陀一生所说的经教。禅宗则不同，它没有所依的经论，完全是以自己的参究体验为其传道的依据。所谓公案者，就是对禅宗祖师的言行范例所作的归纳或总结，禅师们“拈弄”、“评唱”的因缘或“上堂”、“小参”所垂示的话头，后人都称之为“公案”。禅的教法，就是用公案来推动、来弘传的。
    “公案”，就是公府的案牍，即法律命令，至为严肃而不可违犯，可以为定法，可以断是非。从上佛祖的垂示，是宗门的正令，用以判断学人的迷悟。故宗门祖师大德，比拟佛祖的应化机缘，拈提的越格言语动作，名之为公案。圆悟禅师在《碧岩录》九十八则评唱中说：“古人事不获已，对机垂示，后人唤作公案。”中峰和尚在《山房夜话》卷上里说：“或问：佛祖机缘，世称公案者何耶？幻曰：公案，乃喻平公府之案牍也。法之所在，而王道之治乱实系焉。公者，乃圣贤一其辙，天下同其途之至理也。案，乃记圣贤为理之正文也。凡有天下者，未尝无公府；有公府者，未尝无案牍。盖欲取以为法，而断天下之不正者也。公案行，则理法用；理法用，则天下正；天下正，则王道治矣。夫佛祖机缘目之曰亦尔。盖非一人之臆见，乃会灵源，契妙旨，破生死，越情量，与三世十方百千开士同禀之至理也。且不可以义解，不可以言传，不可以文诠，不可以识度。如涂毒鼓，闻者皆丧。如大火聚，撄之则燎。故灵山谓之别传者，传此也。少林谓之直指者，指此也。自南北分宗，五家列派以来，诸善知识，操其所传，负其所指，于宾叩主应，得牛还马之顷，粗言细语信可捷出，如迅雷不容掩耳。如赵州庭前柏树子，洞山麻三斤、云门乾屎橛之类，略无义路与人穿凿。即之如银山铁壁之不可透。惟明眼者，能逆夺于语言文字之表。一唱一和，如空中鸟迹，水底月痕，虽千途万辙，放肆纵横，皆不可得而拟议焉。远自鹫岭拈花，迨于今日，又岂止乎一千七百则而已哉！无他，必待悟心之士，取以为证据耳。实不欲人益记持而资谈柄也。世称长老者，即丛林公府之长吏也；其编灯集者，即记其激扬提唱之案牍也。古人或匡徒之隙，或掩关之暇，时取以拈之判之，颂之别之，岂为炫耀见闻，抗衡古德而然，盖痛思大法之将弊，故曲施方便，开凿后昆之智眼，欲俾其共证之尔。言公者，防其己解。案者，必期与佛祖契同也。然公案通，则情识尽；情识尽，则生死空；生死空；则禅道治矣。所云契同者，乃佛祖大哀众生，自缚于生死情妄之域，积劫迨今，莫之自释。故于无言中显言，无象中垂象，待其迷绳既释，安有言象之可复议乎。且世之人，有事不得其平者，必求理于公府，而吏曹则举案牍以平之。犹学者有所悟解，不能自决，乃质之于师，则举公案以决之。夫公案即烛情识昏暗之慧炬也，揭见闻翳膜之金篦也，断生死命根之利斧也，鉴圣凡面之神镜也。祖意以之廓明，佛心以之开显。其全超迥脱，大达同证之要，莫越于此。”
    中峰和尚的这段话将公案的意义及作用说得透彻无余了。
    禅宗的语录，内容多系公案的提唱。禅宗自称是教外别传，没有所依据的经典。公案恰似教下各宗之于经典，以之作为观照禅法邪正的准绳。勘验禅法并没有现成的法则。禅师们以各自的实际体验及应化机宜的特性，显现出“棒”、“喝”、“擒”、“拿”、“推”、“踏”、“收放”、“与夺”、“杀活”等种种方便手法，以及拈颂、评唱，成为禅的基本方法。所以黄檗禅师说：“既是丈夫汉，应看个公案！”看公案看到和自己打成不二一体，就会发生真智而彻见自己本来面目，使自己入于与佛祖同一境界。由是可知，对公案的参究体会是如何的重要了。
    下面根据《景德传灯录》、《碧岩录》、《禅学讲话等》，选几则公案，加以简单地介绍，供初学参禅的人，参究商量。

    （一）廓然无圣
    菩提达磨大师于梁普通年间来中国，到达广州后，武帝派遣使臣请他到金陵宫中，相互问答。《景德传灯录》卷三说：“帝问曰：‘朕即位以来，造寺、写经、度僧，不可胜纪，有何功德？’师曰：‘并无功德。’帝曰：‘何以无功德？’师曰：‘此但人天小果，有漏之因，如影随形，虽有非实。’帝曰：‘如何是真功德？’答曰：‘净智妙圆，体自空寂。如是功德，不以世求。’帝又问：‘如何是圣谛第一义？’师曰：‘廓然无圣’。帝曰：‘对朕者谁？’师曰：‘不识’。帝不领悟。”
    这个问答，在历史的事实上虽有争议，但这并不影响这则公案在法义上的价值。以法为中心来商量这个公案是可以不问历史上的根据的。
    本则公案的重点，在于“廓然无圣”一语。武帝曾经三度舍身出家，尝受具足戒，身披袈裟，自讲《放光般若》等。办道奉佛，诏天下起寺度僧，依教修行，当时人们称他为佛心天子。达磨初见武帝，帝问“朕起寺度僧，有何功德？”磨说：“并无功德”。这答覆早是恶水蓦头浇了，而佛心天子不能领悟，还问为什么无功德。大慈大悲的达磨再给他揭破。若透得无功德话，许尔亲见达磨。且道起寺度僧，为什么都无功德？此意在什么处？
    武帝与娄约法师、傅大士、昭明太子，持论真俗二谛，根据教典上的说法，真谛以明非有，俗谛以明非无。真俗不二，即是圣谛第一义。这是教家极妙穷玄处，故帝拈此极则处问达磨：“如何是圣谛第一义？”磨云：“廓然无圣”！这是达磨与他一刀截断，帝不省，却以人我见故，再问：“对朕者谁？”达磨慈悲，又向他道：“不识”。直逼得武帝眼目定动不知落处。达磨端居而逝之后，武帝悔恨未悟达磨直示心印，给达磨做碑文，表露了怨悔的心情。如佛果圆悟禅师在《碧岩录》第一则评唱中说：“武帝追忆，自撰碑文云：‘嗟夫！见之不见，逢之不逢，遇之不遇，今之古之，怨之恨之。’复赞云：‘心有也，旷劫而滞凡夫；心无也，刹那而登妙觉。’且道，达磨即今在什么处？蹉过也不知。”
    前面说武帝与娄约法师、傅大士、昭明太子，持论真俗二谛，他们所论的二谛，都是教中所说的甚深的妙理。如《广弘明集》里说：“梁昭明太子曰：‘所言二谛者，一是真谛，二名俗谛。真谛，亦名第一义谛。’”武帝立足于佛教的二谛观，把这种真谛妙理，作为一种概念来问达磨，所以达磨答之曰：“廓然无圣”。意谓禅的根本法，是教外别传的，不是教典上所说的圣义谛，正是截断了教义中所说的妙理，显示出是佛自证自悟的真实境界，为超越凡圣的境界。是无佛无众生无古无今的境地。这个境地，就是禅的根本法。所以达磨答的廓然无圣的第一义，与武帝问的第一义，意义完全相异。问的是二谛中的真谛的第一义，达磨答的却是自证的第一义。这种自证的第一义，非言说寻思拟议之所能到，如《楞伽经》卷三说：
    “大慧覆白佛言：‘世尊！为言说即是第一义？为所说者是第一义？’佛告大慧：非言说是第一义。所以者何？谓第一义圣乐，言说所入，是第一义（魏译云：为令第一义随顺言语入圣境界，故有言语说第一义。）。非言说是第一义。第一义者，圣智自觉所得，非言说妄想觉境界。是故言说妄想，不显示第一义。言说者生灭动摇辗转因缘起，若辗转因缘起者，彼不显示第一义。大慧，自他相无性故，言说不显示第一义。复次大慧，随入自心现量故，种种相，外性非性，言说妄想不显示第一义。是故大慧，当离言说诸妄想相。’”
    照《楞伽经》的教导，任何言说都不能显示第一义，所以达磨答廓然无圣，正显示自证自悟之境，是超越了一切迷悟凡圣是非得失的清净自在无碍之境地。同时也是挥动廓然无圣的慧剑，截断梁武帝垢意情尘的知解，洒洒落落地显示了禅的生命。
    圆悟禅师在《碧岩录》里说：“所以道：参得一句透，千句万句一时透，自然坐得稳，把得定。古人道：粉骨碎身未足酬，一句了然超百亿。”这是说，参得廓然无圣一句透，便有自由分，不随一切言语转，脱体现成，一刀截断，洒洒落落，更不分是分非，辨得辨失，虽百亿劫的生死，也得超脱，稳坐于根本法位。

    （二）并却咽喉唇吻
    沩山、五峰、云岩同侍立百丈。百丈问沩山：“并却咽喉唇吻，作么生道？”山曰：“却请和尚道！”师曰：“不辞向汝道，恐已后丧我儿孙！”又问五峰。峰曰：“和尚也须并却！”师曰：“无人处斫额，望汝！”又问云岩，岩曰：“和尚有也未？”师曰：“丧我儿孙。”
    百丈怀海禅师，嗣马祖法，住江西百丈山大雄峰，时沩山、五峰、云岩为侍者。百丈自己是大彻大悟的大师，为了启发学者，故问沩山等人并却咽喉唇吻如何说禅？三人答处，各各不同，沩山答处，可以说是函盖乾坤，壁立千仞。五峰答处，可以说是截断众流，照用同时。云岩答处，可以说是随波逐浪，自救不了。
    百丈先问沩山：“并却咽喉唇吻，作么生道？”沩山曰：“却请和尚道。”这是用逆袭的方法回答，若依言语可以道得出禅来，那就请和尚道吧！这是壁立千仞，宾主互换，活鲅鲅（鲅音拨，鱼游貌）地，轻轻一拶，令人易见。亦似猛虎头上安角，有什么可近傍处。所以雪窦颂日：“却请和尚道，虎头生角出荒草。”戴角虎出荒草，可煞惊群，不妨奇特。请和尚道这一句话，婉转自在，又能把定封疆，塞断敌路。百丈对沩山说：“我不辞向汝道，恐以后丧我儿孙。”意思是说：我向你说没有不可以的，可是一说出来，恐以后要死绝了我的法嗣呢！这明显地指示着：若以言论传于人，便是一种学说，不是教外别传的东西。别传之法，是在于自觉的妙悟。如果说靠言语相传，是会绝却禅的后继人的。
    百丈复问五峰：“并却咽喉唇吻，作么生道。”峰云：“和尚也须并却！”五峰这一答处，是截断众流的手法，意思是说即超凡圣也难窥。可以说是照用同时，向廓然无圣处猛进。如马前相扑，不容拟议，直下使用，紧迅急峭。所以道，欲得亲切莫将向来问。五峰答处，当头坐断，不妨快俊。百丈云：“无人处斫额，望汝！”意思似乎说：“那末等你在独居无人处悟了再说吧！”且是肯他？是不肯他？是杀是活？见他阿辘辘地，只与他一点。所以雪窦颂云：“和尚也并却，龙蛇阵上看谋略，令人长忆李将军，万里天边飞一鹗（鹗，音，大鹗也，食鱼蛇，猛禽类）。”所谓龙蛇阵上看谋略者，古代作战，能够在排成的两阵中，突出突入，七纵八横，这样的人，是有大战斗才能的手脚，有大谋略的帅才人物，单枪匹马，向龙蛇阵上，出没自在，你有什么办法围得住他。这样的人，大似李广将军的神箭，天边飞来一鹗，一箭射落，是决定之事，不可放过。雪窦颂百丈问处如一鹗，五峰答处如一箭，对五峰是大加赞赏了。
    百丈又问云岩：“并却咽喉唇吻，作么生道？”岩云：“和尚有也未？”意思是和尚有呢，还是没有？这是以怀疑的口气表示不可能的意思，意谓第一义是没有语言的。不理解绝言绝虑才作如是说。可以说这答话，粘皮着骨，拖泥带水，前不构村，后不迭店。随波逐浪，自救不了。百丈见他如此，一时把来，打杀了也。所以百丈说：“丧我儿孙。”
    云岩在百丈，二十年作侍者，丈圆寂后，同道悟至药山惟俨禅师那里参学。药山问他：“你在百丈会下，为个什么事？”云岩说：“透脱生死。”药山说：“还透脱也未？”云岩说：“渠无生死。”药山说：“二十年在百丈，习气也未除！”云岩遂辞去，参见南泉。后来又回归药山，方得契悟。其因缘是，药山问百丈有何言句示徒，云岩说：“有时上堂，大众立定，以拄杖一时趁散，复召大众，众回首，丈曰：‘是什么？’山曰：‘何不早凭么道。今日因子得见海兄。’师于言下顿省，便礼拜。”看他古人，二十年参究，犹自半青半黄，粘皮着骨，不能颖脱，不见道，语不离窠臼，焉能出盖缠。雪窦颂云：“和尚有也未，金毛狮子不踞地。两两三三旧路行，大雄山下空弹指。”圆悟禅师评曰：“和尚有也未，雪窦据疑结案。是则是，只是金毛狮子争奈不踞地。狮子提物，藏牙伏爪，踞地返掷。物无大小，皆以全威，要全其功。云岩云：‘和尚有也未’，只是向旧路行，所以雪窦云，百丈向大雄山下空弹指。”

    （三）禅板，蒲团，久坐成劳
    禅板，蒲团，久坐成劳，都是关于提出祖师西来意的答覆。对西来意这个问题，在唐朝三百年间，是一个普遍的问答，在语录里被记录出来的有二百三十余则，但所答都不同。如僧问九峰：“如何是祖师西来意？”师云：“板齿生毛。”僧问龙牙：“如何是祖师西来意？”牙云：“待石乌龟解语，即向汝道。”曰：“石乌龟语也。”师曰：“向汝道什么？”僧问洛浦：“如何是祖师西来意？”师云：“青岚覆处，出岫波峰，白日辉时，碧潭无影。”仰山问沩山：“如何是祖师西来意？”沩山指灯笼曰：“大好灯笼。”仰曰：“莫只这便是么？”沩山曰：“这个是什么？”仰曰：“大好灯笼。”沩山曰：“果然不见。”又僧问沩山：“如何是祖师西来意？”沩山竖起拂子。
    同一问题，为什么应答都不同？那是因为禅的根本法，是超越一切的无生法，是离却形式或概念的，所以无碍自在，绝不会为任何语言文字形式手法等所拘束。也可以说，祖师西来时，全宇宙都为祖师西来而现前。因为宇宙万有都存在于西来意中，则任取一物，无不是西来意。是故西来意，绝非固定的概念，所以古来高僧大德，各自应其境，通其机，而自由自在的拈答。
    这里举出《碧岩录》第十七则和第二十则，关于问答祖师西来意的评唱，加以简单介绍：
    《碧岩录》第二十则举：“龙牙问翠微：‘如何是祖师西来意？’微云：‘与我过禅板来。’牙过禅板与翠微，翠微接得便打。牙云：‘打即任打，要且无祖师西来意！’牙又问临济：‘如何是祖师西来意？’临济云：‘与我过蒲团来！”牙取蒲团过与临济，济接得便打。牙云：‘打即任打，要且无祖师西来意！’”
    这个问答，可能是在龙牙壮年行脚时。因为龙牙先参翠微、临济，后参德山。曾向德山问云：“学人仗莫邪剑，拟取师头时如何？”德山引颈云：“[囫-勿+力]！”牙云：“师头落也。”山微笑便休去。次到洞山，洞山问他：“近离甚处？”牙云：“从德山来。”洞山问：“德山有何言句？”牙遂举前话。洞山云：“他道什么？”牙说：“他无语。”洞山云：“莫道他无语，且试将德山落底头，呈示老僧看。”牙于此有省。遂焚香遥望德山礼拜忏悔。因此停止于洞山，随众参请。一日问洞山：“如何是祖师西来意？”山曰：“待洞水逆流，即向汝道。”师始悟其旨，侍勤八稔。师有颂曰：“学道如钻火，逢烟未可休，直待金星现，归家始到头。这是龙牙在洞山豁然大悟之后，研味其旨，悲喜交集而说的偈颂。说明古人参禅受多少辛苦，参见尊宿，要明自己一段大事，可谓言不虚设，机不乱发，出在做工夫处。
    龙牙根性聪敏，担一肚皮禅行脚，直向长安翠微无学禅师，便问：“如何是祖师西来意？”翠微叫他拿禅板来，微接过禅板打他。龙牙说：“打即任你打，我要的是西来意的‘无’”。又到河北临济义玄禅师问这个问题，临济叫他拿蒲团来。这已提示出了超越否定与肯定的向上一着，可是龙牙不会。遵照翠微、临济两老的话，递给禅板、蒲团，却被两老打了一顿。这虽不外是向上接化的手段，但龙牙仍不会，还说着打即任你打，要且无祖师西来意。圆悟着语说，打得个死汉济甚事，也落在第二头了也。
    原来龙牙把禅专解为否定一边，意以“无”为禅。把达磨“廓然无圣”的话片面理解为禅，不解那“廓然”的意义，故唯将“无”的否定方面来应用。这就是他担了一肚皮禅行脚，一向自作主宰。但是翠微与临济，都是超过了否定和肯定、差别和平等的向上义，欲提示非禅道，非佛道，超越凡圣的向上一着，故说“过禅板来”、“过蒲团来”。圆悟评唱说：“大凡激扬要妙，提唱宗乘，向第一机下明得，可以坐断天下人舌头。”这即是说翠微、临济两人的机用：“倘或踌躇，落在第二。这二老汉，虽然打风打雨，惊天动地，要且不曾打着明眼汉。”这是龙牙作略。
    圆悟禅师又说：“且道当机承当得时令作么生？他不向活水处用，自去死水里作活计，一向作主宰，便道打即任打，要且无祖师西来意。”这是说当时过禅板和蒲团的立场。“死水里”者，是指堕于平等的一面而没有差别的作用，所谓“西来无意”，不外这个立场。
    圆悟禅师还说：且道翠微、临济二尊宿，又不同法嗣，为什么答处相似，用处一般？须知古人一言一句，不乱施为。龙牙后来住院，有僧问他：和尚当时见二尊宿是肯他不肯他？龙牙说：肯则肯，要且无祖师西来意。烂泥里有刺，放过与人，已落第二。这老汉把得定，只做得洞下尊宿。若是山僧则不然，只向他道：肯即未肯，要且无祖师西来意。不见僧问大梅法常禅师：“如何是祖师西来意？”梅云：“西来无意。”盐官海昌院齐安国师闻之，乃曰：“一个棺材两个死汉！”都评之为堕在无事无为中去，没有活用的意思。所以说，须参活句，莫参死句。活句下荐得，永劫不忘。死句下荐得，自救不了。他古人一言一句，不乱施为，前后相照，有权有实，有照有用，宾主历然。与我过禅板、蒲团来，似乎要试试龙牙的作略，这是假设的，所谓“权”者是；接得便打，这是所谓“实”。以权实自在得用，禅机泼刺地跃动。换句话说：将否定、肯定、放行、把住都超越过去，而且拿这些来自由运用，就成为“禅机”。象对于龙牙这样堕陷于否定一面的人，更必须打破这个死窟窿而使之达于活用。雪窦颂云：
    龙牙山里龙无眼，死水何曾振古风？
    禅板蒲团不能用，只应分付与卢公。
    这是说，龙牙原欲向翠微和临济张舞其爪牙，可是自己却是止于死水的一条瞎龙。若是活龙，须向洪波浩渺、白浪滔天处去。此言龙牙走入死水去，被人打。他却道，打即任打，要且无祖师西来意。招得雪窦说他死水何曾振古风！死水，是说无有那种像翻天倒地般的怒涛活力，到底不能振起达磨的真风。怎知龙牙是瞎龙是死水呢？因为他不能运用禅板、蒲团。在翠微、临济让他过禅板、蒲团来，龙牙便拿禅板、蒲团与他，岂不是死水里作活计。“只应分付与卢公”，“卢公”是雪窦的自称。如他题《晦迹自贻》云：
    图画当年爱洞庭，波心七十二峰青。
    而今高卧思前事，添得卢公倚自屏。
    雪窦的意思是说，假若那禅板、蒲团分付到我，便要大大的卖弄一下。我当时如作龙牙，待伊索蒲团、禅板，拈起劈面便掷。
    总之：关于这个公案，依龙牙和翠微、临济三人，显示出的禅的根本法，现成的就是绝对无。因为一滞凝在差别、平等、否定、肯定的任何一边，便失却自在的作用；若超过了这些对立面，并使之自在地运用起来，便是禅的真实义。
    《碧岩录》第十七则则举：“僧问香林：如何是祖师西来意？林云：久坐成劳”。
    香林即益州青城香林院澄远禅师。嗣法云门，依止云门十八年。云门每呼他为“远侍者”。待应诺，门则问曰：“是什么？”如此者十八年方有省悟。门曰：“我今后更不呼汝矣。”林一日辞门，门曰：“光含万象一句作么生道？”林拟议，门令更住三年。香林后回归四川，初住导江水晶宫，后住青城香林。在四川四十年，八十岁方迁化。将示寂，辞知府宋公珰曰：“老僧行脚去。”通判曰；“这僧疯狂，八十岁行脚，去哪里？”宋曰：“大善知识去住自由。”归谓众曰：“老僧四十年方打成一片。”言讫而逝。
    在答覆西来意问题方面，雪窦、圆悟两禅师以香林答的“久坐成劳”为最好最优，特予推赏。《碧岩录》卷二说：“古来答祖师西来意甚多，唯香林此一则，坐断天下人舌头，无尔计较作道理处。僧问：‘如何是祖师西来意？’香林云：‘久坐成劳！’可谓言无味，句无味，无味之谈，塞断人口，无你出气处。要见便见，若不见，切忌作解恽。香林曾遇作家来，所以有云门手段，有三句体调。”“久坐成劳”，从字面上看，不外是久坐辛苦劳累疲乏了。但一句答覆，竟成为名答。圆悟禅师说他得大自在，是脚踏实地，无许多佛法知见道理，临时运用，所谓法随法行，法幢随处建立。他说雪窦非常推赏“久坐成劳”的答覆，所以雪窦因风吹火，傍指出一个半个。颂曰：
    一个两个千万个,脱却笼头卸角驮。
    左转右转随后来,紫胡要打刘铁磨。
    一说到祖师西来意，一般人总以为达磨带来有什么东西似的，于是乎求法觅禅的人，不只是一个两个，而是千千万万的去行脚，请问祖师大德要求得到答覆。香林说：“原无可求的法，也无可参的禅，大家何苦来劳辛万千呢！”所以用无味之谈说：“久坐成劳”。使人听到这话，似乎自然地会把心中存在的一切问题都能放下，身心脱落，一任自在，变成洒洒落落的闲道人。可是仍有患着参禅病、公案病的人，东奔西跑，要求解决西来意。对这种人，就要像紫胡打刘铁磨那样，给他三十棒，醒醒他们的迷梦！
    紫胡打刘铁磨的公案，《景德传灯录》卷十说：衢州子胡岩利踪禅师，是南泉的法嗣。“有一尼到参，师曰：‘汝莫是刘铁磨否？’尼曰：‘不敢’。师曰：‘左转右转？’尼云：‘和尚莫颠倒。’师便打。”
    圆悟禅师对雪窦颂评曰：“雪窦直下，如击石火，似闪电光，拶出放教尔见。聊闻举著，便会始得，也不妨是他屋里儿孙，方能凭么道。若能直下便凭么会去，不妨奇特。‘一个两个千万个，脱却笼头卸角驮’。洒洒落落，不被生死所染，不被凡圣情解所缚。上无攀仰，下绝己躬，一如他香林、雪窦相似。何止只是千万个，直得尽大地人，悉皆如此；前佛后佛，也悉皆如此。苟或于言句中作解会，便似紫胡打刘铁磨相似。其实才举，和声便打。紫胡参南泉，与赵州岑大虫同参，时刘铁磨在沩山下卓庵，诸方不奈何他。一日紫胡得得去访云：‘莫便是刘铁磨否？’磨曰：“‘不敢’。胡曰：‘左转右转？’磨云：‘和尚莫颠倒。’胡和声便打。香林答这僧问‘如何是祖师西来意？’却云：‘久坐成劳。’惹凭么会得。左转右转随后来也。且道：雪窦如此颂出，意作么生？无事好，试请举看。”
    在“久坐成劳”这个答话里，得知具有一切超越、一切脱落之境；同时也得知达磨的“廓然无圣”，是否定一切，而且就在把否定也否定了的绝对否定的当处，无碍自在的境地乃即现前。
    禅的真理，一切都是自己所有，故此处更没有什么可求，求则愈远；唯照顾自己，也决没有向他可求。要之，只是透彻那不可得的而已。这个境界，是具有无限广大和无量深邃的世界，不着一丝云翳归于纯粹意识之境。这就是意识的超越，回归于无意识的本源境涯。这个境涯里根本无有可师，只是自己回归于自己，显现自己。此外别无他道。理解了这种境界，才能体会公案的意趣。否则就会落于雪窦禅师所说的“龙牙山里龙无眼，死水何曾振古风。”


十三顿悟渐修

    高丽国普照禅师修心诀

    三界热恼，犹如火宅。其忍淹留，甘受长苦。欲免轮回，莫若求佛。若欲求佛，佛即是心。心何远觅，不离身中。色身是假，有生有灭。真心如空，不断不变。故云：百骸溃散，归火归风。一物长灵，盖天盖地。嗟夫今之人，迷来久矣。不识自心是真佛，不识自性是真法。欲求法而远推诸圣，欲求佛而不观己心。若心外有佛，性外有法，坚执此情，欲求佛道者，纵经尘劫，烧身炼臂，敲骨出髓，刺血写经，长坐不卧，一食卯斋，乃至转读一大藏教，修种种苦行，如蒸砂作饭，只益自劳耳。但识自心，恒沙法门，无量妙义，不求而得。故世尊云：普观一切众生，具有如来智慧德相。又云：一切众生，种种幻化，皆生如来圆觉妙心。是知离此心外，无佛可成。过去诸如来，只是明心底人。现在诸贤圣，亦是修心底人，未来修学人，当依如是法。愿诸修道之人，切莫外求，心性无染，本自圆成。但离妄缘，即如如佛。
    问：若言佛性现在此身，既在身中，不离凡夫，因何我今不见佛性？更为消释，悉令开悟。
    答：在汝身中，汝自不见。汝于十二时，知饥知渴，知寒知热，或嗔或喜，竟是何物？且色身是地水火风四缘所集，其质顽而无情，岂能见闻觉知？能见闻觉知者，必是汝佛性。故临济云：四大不解说法听法，虚空不解说法听法，只汝目前，历历孤明，勿形段者，始解说法听法。所谓勿形段者，是诸佛之法印，亦是汝本来心也。则佛性现象在汝身，何假外求。汝若不信，略举古圣入道因缘，令汝除疑，汝须谛信。昔异见王问婆罗提尊者曰：何者是佛？尊者曰：见性是佛。王曰：师见性否？尊者曰：我见佛性。王曰：性在何处？尊者曰：性在作用。王曰：是何作用？我今不见。尊者曰：今现作用，王自不见。王曰：于我有否？尊者曰：王若作用，无有不是；王若不用，体亦难见。王曰：若当用时，当为我说。尊者曰：在胎曰身，处世曰人，在眼曰见，在耳曰闻，在鼻辨香，在舌谈论，在手执捉，在足运奔，遍现俱该沙界，收摄在一微尘。识者知是佛性，不识者唤作精魂。王闻心即开悟。又僧问归宗和尚如何是佛？宗云：我今向汝道，恐汝不信。僧云：和尚诚言，焉敢不信。师云：汝即是。僧云：如何保任？师云：一翳在眼，空花乱坠。其僧言下有省。上来所举，古圣入道因缘，明白简易，不妨省力，因此公案，若有信解处，即与古圣把手共行。
    问：汝言见性，若真见性，即是圣人，应现神通变化，与人有殊。何故今时，修心之辈，无有一人，发现神通变化耶？
    答：汝不得轻发狂言，不分邪正，是为迷倒之人。今时学道之人，口谈真理，心生退屈，返堕无分之失者，皆汝所疑。学道而不知先后，说理而不分本末者，是名邪见，不名修学。非唯自误，兼亦误他，其可不慎欤！夫入道多门，以要言之，不出顿悟、渐修两门耳。虽曰顿悟渐修，是最上根机得入也。若推过去，已是多生，依悟而修，渐熏而来。至于今生，闻即发悟，一时顿毕。以实而论，是亦先悟后修之机也。则知此顿、渐两门，是千圣轨辙也。从上诸圣，莫不先悟后修，因修乃证。所言神通变化，依悟而修，渐熏所现，非谓悟时，即发现也。如经云：理即顿悟，乘吾并消。事非顿除，因次第尽。故圭峰深明先悟后修之义曰：识冰池而全水，借阳气以熔消，悟凡夫而即佛，资法力以熏修。冰消则水流润，方呈溉涤之功。妄尽则心虚通，应现通光之用。是知事上神通变化，非一日之能成，乃渐熏而发现也。况事上神通，于达人分上，犹为妖怪之事，亦是圣末边事，虽或现之，不可要用。今时迷痴辈，妄谓一念悟时，即随现无量妙用，神通变化，若作是解，所谓不知先后，亦不分本末也。既不知先后本末，欲求佛道，如将方木逗圆孔也，岂非大错。既不知方便，故作悬崖之想，自生退屈，断佛种性者，不为不多矣。既自未明，亦未信他。既有解悟处，见无神通者，乃生轻慢，欺贤诳圣，良可悲哉！
    问：汝言顿悟、渐修两门，千圣轨辙也。悟既顿悟，何假渐修？修若渐修，何言顿悟？顿、渐二义，更为宣说，令绝余疑。
    答：顿悟者，凡夫迷时，四大为身，妄想为心。不知自性，是真法身。不知自己灵知，是真佛也。心外觅佛，波波浪走。忽被善知识指尔入路，一念回光，见自本性。而此性地，原无烦恼，无漏智性，本自具足，即与诸佛，分毫不殊，故云顿悟也。渐修者，顿悟本性，与佛无殊；无始习气，难卒顿除。故依悟而修，渐熏功成，长养圣胎，久久成圣，故云渐修也。比如孩子初生之日，诸根具足，与他无异，然其力未充，颇经岁月，方始成人。
    问：作何方便，一念回机，便悟自性？
    答：只汝自心，更作什么方便。若作方便，更求解会，比如有人，不见自眼，以谓无眼，更欲求见。既是自眼，如何更见，若知不失，即为见眼，更无求见之心，岂有不见之想。自己灵知，亦复如是。既是自心，何更求会。若欲求会，便会不得。但知不会，是即见性。
    问：上上之人，闻即易会。中下之人，不无疑惑。更设方便，令迷者趣入。
    答：道不属知不知，汝除却将迷待悟之心，听我言说。诸法如梦，亦如幻化。故妄念本寂，尘境本空，诸法皆空之处，灵知不昧。即此空寂灵知之心，是汝本来面目。亦是三世诸佛历代祖师，天下善知识，密密相传的法印也。若悟此心，真所谓不践阶梯，径登佛地。步步超三界，归家顿绝疑，便与人天为师，悲智相资，具足二利，堪受人天供养，日消万两黄金。汝若如是，真大丈夫，一生能事已毕矣。
    问：据吾分上，何者是空寂灵知之心耶？
    答：汝今问我者，是汝空寂灵知之心，何不返照，犹为外觅。我今据汝分上，直指本心，令汝便悟，汝须净心听我言说。从朝至暮，十二时中，或见或闻，或笑或语，或嗔或喜，或是或非，种种施为运转，且道毕竟是谁，能凭么运转施为耶？若言色身运转，何故有人一念命终，都未坏烂，即眼不得见，耳不能闻，鼻不辨香，舌不谈论，身不动摇，手不执捉，足不运奔耶！是知能见闻动作，必是汝本心，不是汝色身也。况此色身，四大性空，如镜中像，亦如水月，岂能了了常知，明明不昧，感而遂通，恒沙妙用也。故云神通并妙用，运水及搬柴。且入理多端，指汝一门，令汝还源。汝还闻鸦鸣、雀噪之声么？曰：闻。曰：汝返闻汝闻性，还有许多声么？曰：到这里一切声，一切分别，俱不可得。曰：奇哉！奇哉！此是观音入理之门。我更问你道，到这里一切声，一切分别，总不可得。既不可得，当凭么时，莫是虚空么？曰：原来不空，明明不昧。曰：作么生是不空之体？曰：亦无相貌，言之不可及。曰：此是诸佛诸祖寿命，更莫疑也。既无相貌，还有大小么？既无大小，还有边际么？无边际，故无内外。无内外，故无远近。无远近，故无彼此。无彼此，则无往来。无往来，则无生死。无生死，则无古今。无古今，则无迷悟。无迷悟，则无凡圣。无凡圣，则无染净。无染净，则无是非。无是非，则一切名言，俱不可得。既总无如是一切根境，一切妄念，乃至种种相貌，种种名言，俱不可得。此岂非本来空寂，本来无物也。然诸法皆空之处，灵知不昧，不同无情，性自神解，此是汝空寂灵知清净心体。而此清净空寂之心，是三世界诸佛胜净明心，亦是众生本源觉性。悟此而守之者，坐一如而不动解脱；迷此而背之者，往六趣而长劫轮回。故云，迷一心而往六趣者，去也、动也；悟法界而复一心者，来也、静也。虽迷悟之有殊，乃本源则一也。所以云：所言法者，谓众生心，而此空寂之心，在圣而不增，在凡而不减。故云在圣智而不耀，隐凡心而不昧。既不增于圣，不少于凡，佛祖奚以异于人？而所以异于人者，能自护心念耳。汝若得及，疑情顿息，立丈夫之名，发真正见解，亲尝其味，自到自肯之地，则是为修心人，解悟处也，更无阶级次第，故云顿也。如云于信因中，契诸佛果德分毫不殊，方成信也。
    问：既悟此理，更无阶级，何假后修，渐熏渐成耶？
    答：悟后渐修之义，前已具说，而复疑情未释，不妨重说。汝须净心，谛听谛听。凡夫无始旷大劫来，至于今日，流转五道，生来死去，坚执我相，妄想颠倒无明种习，久而成性，虽到今生，顿悟自性，本来空寂，与佛无殊，而此旧习，卒难除断。故逢逆顺境，嗔喜是非，炽然起灭，客尘烦恼，与前无异，若不于般若中着功力，焉能对治无明，得到大休大歇之地。故云顿悟虽同佛，多生习气深；风停波尚诵，理现念犹侵。又杲禅师云：往往利根之辈，不费多力，打发此事，便生容易之心，更不修治，日久月深，依前流浪，未免轮回。则岂可以一期所悟，便拨置后修耶！故悟后长须照察，妄念忽起，都不随之，损之又损，以至无为，方始究竟。天下善知识，悟后牧牛行是也。虽有后修，已先顿悟，妄念本空，心性本净，于恶断，断而无断；于善修，修而无修。此乃真修真断矣。故云：虽备修万行，唯以无念为宗。圭峰总判先悟后修之义云：顿悟此性，愿无烦恼，无漏智性，本自具足，与佛无殊，依此而修者，是名最上乘禅，亦名如来清净禅也。若能念念修习，自然渐得百千三昧。达磨门下，辗转相传者，是此禅也。则顿悟渐修之义，如车二轮，阙一不可。或者不知，善恶性空，坚坐不动，捺伏身心，如石压草，以为修心，是大惑矣。故云：声闻心心断惑，能断之心是贼，但谛观杀盗淫妄，从性而起，起即无起，当处便寂，何须更断。所以云：不怕念起，唯恐觉迟。又云：念起即觉，觉之即无。故悟人分上虽有客尘烦恼，俱成醍醐。但照惑无本，空花三界，如风卷烟；幻化六尘，如汤消冰。若能如是，念念修习，不忘照顾，定慧等持。则爱恶自然淡薄，悲智自然增明，罪业自然断除，功行自然增进。烦恼尽时，生死即绝。若微细流注永断，圆觉大智，朗然独存，即现千百亿化身，于十方国中，赴感应机，似月现九霄，影分万水，应用无穷，度有缘众生，快乐无忧，名之为大觉世尊。
    问：后修门中，定慧等持之义，实未明了，更为宣说，委示开迷，引入解脱之门。
    答：若谓法义，入理千门，莫非定慧。取其纲要，则但自性上体用二义，前所谓空寂灵知是也。定是体，慧是用也。即体之用故，慧不离定；即用之体故，定不离慧。定即慧故，寂而常知；慧即定故，知而常寂。如曹溪云：心地无乱自性定，心地无痴自性慧。若悟如是，任运寂知，遮照无二，则是为顿门个者双修定慧也。若言先以寂寂，治于缘虑；后以惺惺，治于昏住。先后对治，均调昏乱，以入于静者，是为渐门劣机所行也。虽云惺寂等持，未免取静为行，则岂为了事人，不离本寂本知，任运双修者哉！故曹溪云：自悟修行，不在于诤。若诤先后，即是迷人。即达人分上，定慧等持之义，不落功用。原自无为，更无特地时节。见色闻声时但伊么，着衣吃饭时但伊么，屙屎送尿时但伊么，对人接话时但伊么；乃至行住坐卧，或语或默，或喜或怒，一切时中，一一如是。但虚舟驾浪，随高随下，如流水转山，遇曲遇直，而心心无知。今日腾腾任运，明日任运腾腾。随顺众缘，无障无碍。于善于恶，不断不续。质直无伪，视听寻常。则绝一尘而作对，何劳遣荡之功；无一念而生情，不假忘缘之力。然障浓习重，观劣心浮，无明之力大，般若之力小。于善恶境界，未免被动静互换，心不恬淡者，不无忘缘遣荡功夫矣。如云：六根摄境，心不随缘谓之定；心境俱空，照鉴无惑谓之慧。此虽随相门定慧，渐门劣机所行，然在对治门中不可无也。若掉举炽盛，先以定门，称理摄散心不随缘，契乎本寂；若昏沉尤多，则次以慧门，择法观空，照鉴无惑，契乎本知。以定治乎乱想，以慧治乎无记，动静相亡，对治功终。则对境而念念归宗，遇缘而心心契道，任运双修，方为无事人。若如是，则真可谓定慧等持，明见佛性者也。
    问：据汝所判，悟后修门中定慧等指之义有二种，一自性定慧，二随相定慧。自性门则曰任运寂知，原自无为，绝一尘而作对，何劳遣荡之功，无一念而生情，不假忘缘之力。判云，此是顿门，个者不离自性，定慧等持也。随相门则曰称理摄散，择法观空，均调昏乱，以入无为。判云，此是渐门，劣机所行也。而两门定慧，不无疑焉。若有一人所行也，为复先依自性门定慧双修，然后更用随相门对治之功耶？为复先依随相门均调昏乱，然后以入自性门耶？若先依自性定慧，则任运寂知，更无对治之功，何须更取随相门定慧耶？如将皓玉雕文丧德。若先以随相门定慧，对治功成，然后趣于自性门，则宛是渐门中劣机，悟前渐熏也。岂云顿门个者，先悟后修，用无功之功也。若一时顿悟前后，则二门定慧，顿渐有异，如何一时并行也？则顿门个者，依自性门，任运亡功；渐门劣机，趣随相门，对治劳功。二门之机，顿渐不同，优劣皎然。云何先悟后修门中并释两种耶？请为通会，令绝疑情。
    答：所释皎然，汝自生疑，随言生解，转生疑惑，得意忘言，不劳致诘。若就两门，各判所行，则修自性定慧者，此是顿门。用无功之功，并运双寂，自修自性，自成佛道者也。修随相门定慧者，此是未悟前，渐门劣机，用对治之功，心心断惑，取静为行者。而此二门所行，顿渐各异，不可参乱也。然悟后修门中，兼论随相门中对治者，非全取渐机所行也。取其方便，假道托宿而已。何故？于此顿门，亦有机胜者，亦有机劣者，不可一例判其行李也。若烦恼淡薄，身心轻安，于善离善，于恶离恶，不动八风，寂然三受者，依自性定慧，任运双修，天真无作，动静常禅，成就自然之理，何假随相门对治之义也，无病不求药。虽先顿悟，烦恼浓厚，习气坚重，对境而念念生情，遇缘而心心作对，被他昏乱死杀，昧却寂知常然者，即借随相门定慧，不忘对治，均调昏乱，以入无为，即其宜矣。虽借对治功夫，暂调习气，以先顿悟，心性本净，烦恼本空故，即不落渐门劣机污染修也。何者？修在悟前，则虽用功不忘，念念熏修，着着生疑，未能无碍。如有一物，碍在胸中，不安之相，常现在前，日久月深，对治功熟，则身心客尘，恰似轻安。虽复轻安，疑根未断，如石压草，犹于生于死界不得自在。故云修在悟前，非真修也。悟人分上，虽有对治方便，念念无疑，不落污染，日久月深，自然契合。天真妙性，任运寂知，念念攀缘一切境，心心永断诸烦恼，不离自性，定慧等持，成就无上菩提，与前机胜更无差别。则随相门定慧，虽是渐机所行，于悟人分上，可谓点铁成金。若知如是，则岂于二门定慧有先后次第二见之疑乎？愿诸修道之人，研味此语，更莫狐疑，自生退屈。若具丈夫之志，求无上菩提者，舍此奚以哉！切莫执文，直须了义，一一消归自己，契合本宗，则无师之智，自然现前，天真之理，了然不昧，成就慧身，不由他悟。而此妙旨，虽是诸人分上，若非夙植般若种智，大乘根器者，不能一念而生正信。岂徒不信，亦乃谤讟，反招无间者，比比有之。虽不信受，一经于耳，暂时结缘，其功厥德，不可称量。如《唯心诀》云：“闻而不信，尚结佛种之因。况闻而信，学而成，守护不忘者，其功德岂能度量。追念过去轮回之业，不知其几千劫，随黑暗入无间，受种种苦，又不知其几何。而欲求佛道，不逢善友，长劫沉沦，冥冥无觉，造诸恶业，时或一思，不觉长吁，其可放缓，再受前殃。又不知谁复使我今值人生，为万物之灵，不昧修真之路，实谓盲龟遇木，纤芥投针，其为庆幸，曷胜道哉！我今若自退屈，或生懈怠，而恒常望后，须臾失命，退堕恶趣，受诸苦痛之时，虽欲愿闻一句佛法，信解受持，欲免辛酸，岂可复得乎？及到临危，悔无所益。愿诸修道之人，莫生放逸，莫着贪淫，如救头然，不忘照顾。无常迅速，身如朝露，命若西光，今日虽存，明亦难保。切须在意，切须在意。且凭世间，有为之善，亦可免三途苦轮，于天上人间，得殊胜果报，受诸快乐。况此最上乘甚深法门，暂时生信，所成功德，不可以比喻说其少分。如经云：若人以三千大千世间七宝，布施供养尔所世界众生，皆得充满。又教化尔所世界，一切众生，令得四果，其功德无量无边。不如一食顷，正思此法，所获功德。是知我此法门，最尊最贵，于诸功德，比况不及。故经云：一念净心是道场，胜造恒沙七宝塔。宝塔毕竟碎为尘，一念净心成正觉。愿诸修道之人，研味此语，切须在意。此身不向今生度，更待何生度此身！今若不修，万劫差违。今若强修难修之行，渐得不难，功行自进。
    嗟夫！今时人，饥逢王膳，不知下口；病遇医王，不知服药。不曰如之何如之何者，吾未知之何也已矣！且世间有为之事，其状可见，其功可验，人得一事，叹其希有。我此心宗，无形可观，无状可见，言语道断，心行处灭。故天魔外道毁谤无门，释梵诸天，称赞不及，况且夫浅识之流，其能仿佛？悲夫！井蛙焉知沧海之阔，野干何能狮子之吼？故知末法世中，闻此法门，生希有想，信解受持者，已于无量劫中，承事诸圣，植诸善根，深结般若正因，最上根性也。故《金刚经》云：于此章句，能生信心者，当知是人已于无量佛所，种诸善根。又云：为发大乘者说，为发最上乘者说。愿诸求道之人，莫生怯弱，须发勇猛之心，宿劫善因，未可知也。若不信殊胜，甘为下劣，生艰阻之想，今不修之，则纵有宿世善根，今断之故，弥在其难，辗转过矣。今既到宝所，不可空手而还。一失人身，万劫难复，请须慎之。岂有智者，知其宝所，反不求之，长怨孤贫。若欲获宝，放下皮囊。


十四《心灯录》谈三玄三要

    三玄三要，自临济公五代孙汾阳善昭以偈概之曰：“三玄三要事难分，得意忘言道易亲，一句明明该万象，重阳九日菊花新。”此偈一出，皆云三玄三要，是建化事，无益于道，绝无再谈此事者。唯康熙时上元湛愚老人《心灯录》（卷四）不服其说，曰：“济公说，玄，有三玄，要还他三玄；要，有三要，要还他三要。既有三玄，就要还他九要。……岂可不清楚分明，而竟颟顸抹煞。”乃大扯葛藤，用尽胸臆，说出三玄九要，津津乐道，自以为是。然亦不敢自信确定曰：“若要我之所解，必与临济公意相合，上下千古，岁月遥远，谁为证据。”故今抄录于此，为文字禅，葛藤禅，作一参考耳！
    三玄三要，乃临济公心法。能透得无丝毫障碍，才是临济公口吐儿孙。如其不然，则皆颟顸笼统，埋没济公苦心，万不可作涂毒鼓清凉幢会。若以涂毒鼓清凉幢会，则只用一无理路之句，截断众流，诸妄尽遣，犹如死去，何等清凉。而临济公乃絮絮叨叨说出这些话来，教人理会，何苦如此。临济公得悟黄檗无多子后，只有这无位道人，所历岁月深久，智慧圆满，彻底掀翻，可以为佛祖人天之师，才可以建立宗旨，普度群生。不是别公案语句，一味教人如金刚圈、栗棘蓬，死命去参。要悟本来面目，此乃建化门头，因人而施之事。若不能如此，则不可以为人之师也。惟悟得本性圆满，则建化亦圆满。惟建化圆满，则本性始圆满。如《指月录》中在建化上不圆满者，不可胜数。皆于三玄三要不能透彻故也。即如汾阳，乃济公五代孙，不能为学者细细分剖玄要，而以偈概之曰：“三玄三要事难分，得意忘言道易亲。一句明明该万象，重阳九日菊花新。”自从此偈一出，将济公建立玄要苦心，尘封高阁，绝无有提起者。皆云此是建化事，无益于道，皆汾阳启之也。汾阳说难分，谁敢再分，汾阳只能得无多子之意，何尝得玄要之意，竟硬将玄要之言忘之矣。所以说出“一句明明该万象”。此一句即自救不了之人亦知。但玄要之意未梦见在。要知后来济宗儿孙，皆汾阳儿孙，非济公儿孙也。
    济公说，玄，有三玄，要还他三玄。要，有三要，要还他三要。既有三玄，就要还他九要。有第一句，就要还他第一句。而第二句、第三句，就要还他第二句、第三句。岂可不清楚分明，而竟颟顸抹煞。又云：大凡演唱宗乘，一句中须具三玄门，一玄门须具三要。夫曰演唱宗乘，乃是辨别浅深，商量到最上之处，不是别等语句，教你去囫囵蛮参。所以有云：有权有实，有照有用，一一都要还他着落。故云：汝等诸人，怎么生会，若是教人悟我本来，只须一句两句足矣，何须用此许多。盖既已直指出这听法的无位道人，必要他圆满，能作人天佛祖之师，才是这听法的人本分到家时，不可落在自救不了的位分上。再者，济公初悟，说出无多子三字，已经露布，你也佛法无多子，我也佛法无多子，竟成了一个无多子的窠臼。那里知道这听法的人自悟后历历孤明，岁月深久，其中玄要之妙，惟自历而自知之，乃至能为佛祖之师，才是究竟。济公既到此地，如何忍而不以之告人，一者慈心为人详说，二者被后人执定无多子的窠臼，可谓婆心极矣。而后人谓之无益于道，真可哀也。
    南院顒问风穴曰：临济有三句，如何是“三要印开朱点窄，未容拟议主宾分”？风穴随声便喝。试问此一喝了得第一句么？又问：“妙解岂容无著问，沤和争负截流机”。风穴答曰：未问以前错。试问此一答了得第二句么？又问：“但看棚头弄傀儡，抽牵全藉里头人”。风穴答曰：明破即不堪。即明破亦未必不堪，然被临济公已明破久矣，而南院即许之可以支持济宗，此济宗所以堕地也。后风穴垂泪告首山曰：不幸临济之道，至吾将堕于地矣。此临老发真心语，何不参透三玄三要，振作济宗，为临济公吐气。而甘心自是，为南院颟顸所欺，以致对首山垂涕，其谁之过欤？一坠地于汾阳，再坠地于风穴，真可为痛哭流涕长太息也！
    神鼎諲三答，愈不足问。又云直是嫌佛不作，嫌法不说，方可如是。可笑先辈于三玄三要，总是一扫抹煞以掩其陋。那里知道三玄三要乃说法听法的人骨中之髓。若是无益于道，可以不必。则临济公何苦多事说这些话，令后人疑惑。若是藉此为涂毒鼓声，一死便是，请诸君子死后转来，恐不能不疑也。洪觉范谓张无尽许多说话，更无着落。只要人闻三玄三要，即刻死去，便是壁立万仞。殊不知古来当下大悟者，皆是触目闻声，或为师家点破，或被截断众流，一时偷心全死，而悟本来所以要死。惟三玄三要，乃偷心全死后，历历孤明所验入道之妙。张无尽不知详审，而竟领觉范之言，可笑也。问曰：临济公立三玄三要之旨，自示寂后，人都认作截断众流句，如清凉寂灭幢、涂毒鼓等句一例看。今为老人说明，真云开见日，不为众瞒。但古塔主独异众人，采集语句，表彰三玄，有是处否？曰：古塔主采集语句，凑泊三玄，而遗九要，不但见者为之神昏，即古塔主作此时，恐亦神倦。他分出空劫已前之自己是根蒂，今时日用之自己是根叶，其病根就在这里。所以将三玄分别出许多说话，而曰句中玄，体中玄，玄中玄。遂以语句凑泊三玄，闹烘烘的引出若干言句。不知古来可有人在古塔主言内看清了去。问曰：即看得清楚，转目即忘。盖他的意见多，看他的言句，令人心不引帖，且又遗却九要。曰：汝说得极是，彼含糊笼统玄要者不足论，视为截断众流者更不足论。但古塔主虽然乱，还肯用心，虽然能用心，却乱。而今若有一能用心者，就可以与之分别清楚，奈诸方总无一人问及此者。年来闻三峰著三玄三要之书，又觅不可得，真可叹也已。
    客曰：请老人大发慈悲，说明玄要，为后人开迷，岂不幸甚。曰：说何难也，但又起诸方谤议。然时节因缘，余亦不能自己。非细故也。临济公悟得无多子后，时时是历历孤明，日久遂看出自心所历三玄三要，权实照用，乃一现成之理。明明却有三层三句，一句中却有三玄，一玄中却有三要，不是临济公撰出，立建化之门，乃真实之理，真实之境。能历此到玄要至极安乐之地，才可以出而教人，为人天师，为佛祖师。所以为大众演唱宗乘，要人深自思维，不可鲁莽。如何以一喝便可承当；如何以苍天苍天便可承当。客曰：一喝能通五教，难道三玄三要不可通么？曰：尽一喝可以概三世诸佛，如何不能通三玄三要。若不能亲历玄要，还他清楚明白，只以一喝概之，则一切人皆能一喝，皆可以谓之通玄通要，则玄要宗旨，不求堕地，而堕地久矣。所以惟善能分别诸法相者，乃能于第一义而不动者也。汝等谛听，为汝分别。
    三玄九要者，乃知这听法的人而明明只有此我后惟历历孤明，则日复一日，月复一月，习气乃消，渐臻玄奥。其始也能自救，其继也可以为人天师，其终也可以为佛祖师。即三世诸佛之成就，虽有徐疾，然所历皆由于此。问曰：识得便休，何须如此？曰：天下总是汝辈这样鲁莽，所以将济宗坠地。盖玄要乃休后保任功夫绵密，日有所进妙境。彼心粗者即历此亦不能说出。惟济公悟无多子后，至多年，然后发出此义，乃是三世佛之至诣，说法听法的人之究竟，空前绝后之妙旨，乃我自心中所历，而他人不能知者，如何轻易看过。今人动辄曰：末后一句，始到牢关。我常追问之，进关后作么生？则皆发呆。嗟乎！玄要乃进关后事也。若据实而论，将《指月录》内诸公，要推倒十之八九，何况近代诸方。客无对。
    三玄者，乃体中玄，意中玄，句中玄也。由本体之玄发而为的的大意，则意亦玄矣。意之玄与体之玄固有分别，然而一也。玄至于言句，则有千变万化之差别。盖因对来人之机，所以有差别，惟意则一。至于体，则无一无万，所以能一能万。然玄虽有三，其实一也，亦无所谓一也。洪觉范谓济公何尝说有体、有意、有句，如何列体、意、句，不肯此说。然济公有三玄三要之说，你为什么又肯他。既肯他，即为他表明始得，又不能表明，我不知他具何意见，真令人不解。盖由体有意，由意有句，乃天然顺达现成之理，无丝毫异见搀杂，惟临济公于寂默看出，故尔云云也。
    古塔主不解体、意、句顺达现成之理，遗却意中玄，则矻矻不通。又于句中玄后硬加上玄中玄，可谓头上安头。但不知玄中玄，上玄字，还是体中玄、句中玄的玄字，还是另外又有一玄，又有一玄中之玄？不但于一句中之三玄，文理不顺于宗旨，而玄之又玄，岂不玄煞。又将句中玄说得特重，玄中玄都说在句中，不知如何是体中玄。根本不清，枝叶紊乱，令读者茫然不知头绪。其余至幻寄所辨，皆不清楚。
    一句有三玄，一玄有三要，则三玄有九要可知矣。而今只要明白九要，则三玄不辨而知。诸君子将九要总不一顾，而乱纷纷论三玄，有何益处。临济公云：山僧今日见处，与诸佛不则 。若第一句中荐得，堪与佛祖为师。试问诸公能为佛祖之师否？若第二句荐得，堪与人天为师。试问诸公能为人天师否？若第三句荐得，自救不了。试问诸公能自救否？人能自救，只明得一玄三要；能为人天师，则明得两玄六要；若明得三玄九要，则能为佛祖之师。乃这说法的人听法的人圆满处。然此理只有一句，因有此三等人，故一句分而为三句。若以三句论，则该有九玄。既有九玄，则该有二十七要。殊不知只有一句三玄九要。然归总来，又只有这听法的人一句而已。因这听法的人，只在师之一句言句上，悟得此我，已得句中之玄，不能再进得意中玄，所以自救不了，故谓之只得一玄三要。若能再进得意中玄，为人天师，则得六要。再进而得体中玄，则得九要，圆满究竟，为佛祖师。然三玄九要，总在我一心之中，乃人心粗，不能自照，则遂有浅深大小之异，其实不过一我而已矣。
    问曰：如何是句中玄三要？曰：句者言句也。学者为师家一句点破，直指此我。学者因有言之句，而悟得此无相之我，则此无相之我，丝毫不染不著，岂不玄乎？然此玄则因句所发明也。要乃紧要之要。盖言惟此为要，其余皆可缓也。其初悟时，脱离诸相，得知此我是为句中玄初要；既知此我则当保任此无相之我，是为中要；然以此我保我，则有想像光影，而思欲离之，犹不能忘，是为上要。故临济直指曰：“但看棚头弄傀儡，抽牵全藉里头人”。明明有人不能忘却，所以自救不了。此三要，已离却外边一切相，岂不玄乎！
    问曰：如何是意中玄三要？曰：人将此意字看作心意识意字便错。难道的的大意，西来意，如意珠三意字，皆错否？浮山远谓意中玄意字，非意识之意，甚是。而洪觉范非之，殊可笑。难道悟此我竟无意可乎？若不是意中悲悯众生，如何说出这许多法来？盖意中有玄，玄中有要。其初要，即句中之上要而离却上要。彼句中上要，在想像光影中。而今因保任功夫绵密，遂知离却想像光影，然犹有“离”在意中，此意中玄初要也。岂不玄乎？再工夫更觉绵密，而忘却“离”字，遂入无为正位。而身心轻安，受用无比。其始也，返照之意多。今也变返照而为寂照，端拱无为一无事道人而已，是为中要。岂不玄乎？再久之，则无所谓功夫。无功之功，其功甚大，即无为而浑化其无为之迹，亦无所谓无为，是为上要。岂不玄乎？到此地位，已明两玄六要，可以教化人天，为人天之师。盖谓人间天上得安乐者，皆是有为修善而得，然皆不能出生死，脱轮回。若入无为，遂超苦海，自救已了，而可以救拔人天。故临济公直指曰：“妙解岂容无著问，沤和争负载流机”盖谓斯理能解，而至于不可以言解，则妙矣。此意中玄三要之妙也。既不可以言解而至于妙，则起念来问者，岂不错乎？即善问者，如无著菩萨，亦无能措词矣，况其下者乎！此所以见无解无为之妙也。盖无为法门，其初已悟截流之机，入正位。则群流妄想皆断，彼有言问答，直沤和而已。沤和云者，乃水中之泡，一起一灭，谓之沤和。乃言一沤起，而又一沤起而和之，任你起百千万亿沤，聚而成块，怎能截此众流也？盖谓虽有百千问答，终归有解。岂能如无解之妙解，一齐放下，无问无答，当下即截断众流，而端坐证无为也。沤和又曰乃方便也。方便乃诱引之法，岂能当下荐得。意中玄，乃心中自解、自修、自证之妙。
    问曰：如何是体中玄三要？曰：意中玄与句中玄虽近，然犹可思议分别。至于体中玄与意中玄更近，则难于思议分别。然既曰更近，既有近字，岂无言说。要知自句中之玄，修到意中之玄，可谓妙矣。又修到意中玄之上要，可谓妙极矣。原来妙到极处，则妙自不能久炫其妙，而返淡矣。此淡字乃妙到尽处返而为淡。非今人不曾历过意义中之玄要，而妄言谈者。淡如水，水无味，同愚人一样无识无知，穿衣吃饭而已，此为体中玄初要。盖吾人本体，本是如此，而今复至于此，并无增加，然而还是初要，岂不玄乎？斯理原非妙字能尽，惟淡字好。众人一入淡，则飞走去。惟智者能安而乐之。淡虽无味，然无味中有一至味在焉。至味为何？原来不是色，不是空，不是一，不是万，不是凡，不是佛，不是境，不是物，不是有为，不是无为，于行住坐卧动静酬酢往来之中，而历历孤明，如朗月当头，推他不去，揽他不来，总无丝毫接续断灭影响之相，此是体中玄中要也。岂不玄乎？嗟呼，至此亦难言矣！世尊至此，见文殊迦叶白椎竟，便下座。古来诸禅师至此，便拂衣归方丈。寒山子曰：教我如何说。惟曹山有一句明此我上要。僧问曹山曰：如朗月当头时如何？山曰：犹是阶下汉。僧曰：请师接上阶。曰：月落时相见，湛愚老人若在当时，劈面与曹山一掌云：月落时作么相见？客曰：此时曹山便拂袖归室。曰：曹山拂袖归室，我便礼拜而退。此体中玄上要也。岂不玄乎？故济公直指曰：“三要印开朱点窄，未容拟议主宾分。”此三要，更不曾有人说破是何三要，却不是体中玄三要。盖体中玄三要，还是返本还源至寂灭究竟，自家大事了毕者。此三要，乃印开心地，发百千万陀罗尼，自然能度生建化门之妙用。所谓朱点者，心也。虽到上要，大事了毕，而悲智双运，自不能已。然化门应来人之机，有千变万化之不同，自返自心，窄而不广，不足以当众机，而投其所问。惟三要能印开此一点心地，包含大千世界，度尽众生。三要为何？乃吾人身、口、意最要最要者也。身则外现威仪，口则随机对答，意则慈悲智慧双运。以此为印，乃能开发心地。所谓印者，即如一官必有一印。有此印则无远不至，任我纵横开发，谁敢碍我。盖人能至体中玄上要则自能知此三要之印，本来已具，我今用此印，而开我心地，广大无边。凡一切料拣、与夺、权实、照用、宾主，何必拟议，而自然历历分明，当机即用。即有志必欲为佛为祖者，皆来投诚归依，而受我三玄九要印开朱点之妙。彼未入此门者不必论，已入此门者都在此三玄九要之内。我已历过三玄九要，彼学者能到某玄某要者，我即知之。或超入即得体中玄要者，斯为上智。或超入即得意中玄要者，斯为中智。或入而得句中玄要者，斯为下智。而引之前进，则孰有能逃我洞鉴之外。盖惟此三要能印开心地，而能为佛祖之师，则视彼得意中玄要者，岂不窄乎？再视彼得句中玄要者，岂不更窄乎？盖三玄九要法门，乃宗门至要，即《楞严经》所谓密因修证，体中玄上要即是大佛顶。惟是密因，故玄有三，而要有九，乃此心返本还源之路，不是执定一法进修，乃悟此心。即心即法，即法即心，惟此一真我而矣。惟此真我，即是听法的人而已矣。所以临济公乃曰：大凡演唱宗乘，一句中须具三玄，一玄须有三要。有权有实，有照有用。汝等诸人作么生会？难道一喝及云苍天，苍天几句无理路言句，即算会么？乃济公与人据实商量此密因修证，不是一问答，一转语，便算作能会。如能细细清楚，明白说破玄要，许他一喝。若遇来问者便喝，这一喝，值得什么？或曰：闻老人所解三玄三要，与历代古来禅师自汾阳以下大不相同。然一句一字，着实清楚，令人佩服。但不知当年临济公果是此意否？曰：若要我之所解，必与临济公之意相合，上下千古，岁月遥远，谁为证据。然读其言，玩其意，非细细详察，不如是会，而以无理路句一例会，恐辜负济公婆心。盖入此道者，即顿悟后，亦有渐入，岂能如龙女顿悟顿成。即赵州至四十年才打成一片。初祖谓二祖曰：心如墙壁，自然入道。玩这入字，可见其有渐进也。古德云：侍师多年，渐臻玄奥。又云：谛当甚谛当，管保老兄未彻在。未至彻时，还有进步。经云：贤圣以无为法而有差别，于《楞严》则直指出密因修证。又云：理虽顿悟，事要渐修。文殊赞观音自闻闻法门曰：岂惟观世音，我亦从此入。又赞曰：此是微尘佛，一路涅槃门。
    盖三玄九要，乃一路涅槃。至大佛顶，始为究竟。乃要人详察，据实商量，不可于他三句之外，另生怪异奇特之想。只还他一句一字的本义，岂可笼统一句话，就算会得，岂不令人失笑。只要据实而论，能依此修行，管保成佛去，何必问济公之意相合不相合也。
    临济公示寂时，谓吾灭后，不得灭却吾正法眼藏。三圣出曰：争敢灭却和尚正法眼藏。公曰：以后有人问你向他道什么？若湛愚老人在当时，便叉手向前曰：道这个。临济公自然瞑目而去。谁料三圣便喝。公曰：谁知吾正法眼藏，向这瞎驴边灭却。临济公一生喝人，如何示寂时，赚此一喝。盖临济公所主在这说法听法能喝的人，不在喝上，若在喝上追寻，则失却此人矣。所以三圣后不特特提出此人以接济宗之旨，公早已知之，真可痛惜。则后来惟以喝为事者，不谓之瞎驴不可也。
    学者将三玄九要，细细反覆详审清楚，原来乃一现成返本还源之理，并非造作。后观察十方三世诸佛，并历代祖师禅师，及大菩萨诸辟支缘觉声闻境界，无不了然。彼一有言句，或有理路，或无理路，凡五宗同异差别，便知其落处。若夫二十五圆通，二十五轮转，四十五圣位，并十地，至于等觉妙觉，十住十信十回向等修行之门，皆不能出我掌握之中。以至天魔外道，种种不能悉举。如《楞严》五十阴魔所执之病，不必用心照察，自能悉知。能入此玄要之门，则成佛有期，而人都忽略看过，真可谓鲁莽极矣。犹自称济宗儿孙，不亦愧乎？


十五漫谈参禅

    参禅，是学佛人修行办道的正行正道。但参禅一事，口说是容易，只要一念清净，时刻反省内照，乃至保持当念孤明历历，在行为上，任运腾腾，腾腾任运。如果掉举妄动太盛，参一个话头，就能有了悟之期，斩断生死命根，而得自在解脱。可是我们从无始以来，就在三界里生生死死，无穷无尽地流转，在用功的时候，就是有信心有决心，也难免有烦恼习气，业障事缘等种种障碍现前，若无助道对治，虽说念起即觉，觉之即无，久久忘缘，自成一片，可是事缘业障现前，有时也很难不随其事缘业障境相所转。有这些障缘，以至时光空过，岁月因循，染缘易就，道业难成，甚或一生虚度，真可痛惜！假使我们自己口头上说参禅，心识身行也愿意真参，并且多数时间确在参究，还要求有所证悟，就用功办道上来讲，不管省悟有否，都是有功德的，但在见性成佛上说，还是一生空过了！为什么会这样呢？我觉得很多参禅者之所以失败，就在于不注重修助行助道来扶持正行正道。所以我想谈一谈参禅者在认识上和实践上所应该采取的正确态度。

    （一）相信业果无我
    诸佛依二谛说法，二谛就是真谛和俗谛。谛，就是真实不虚。据教典上讲，俗谛明世间一切都是因缘和合而假有，真谛明胜义谛一切皆空。
    俗谛上一切因缘之有都是由自所造业和共所造业因而生起现有，学佛人必须深信因果历然，善因善业必招善果善报，恶因恶行必招恶果恶报，有原因必有结果。如《因果经》说：“欲知过去因者，见其现在果；欲知未来果者，见其现在因。”《涅槃经》说：“善恶之报，如影随形，三世因果，循环不失，此生空过，后无追悔。”《优婆塞戒经》说：“若善男子，有人不解如是业缘，无量世中流转生死，虽生非想非非想处，寿八万劫，福尽还堕三恶道故。佛告善男子，一切模画无胜于意，意画烦恼，烦恼画业，业则画身。”经教上这些教导，都说明了我们正报身、依报世界，一切一切，都是由造业受果而自作自受，因果历然。所以如来在《根本说一切有部毗奈耶药事》等经律中说：“假使百千劫，所作业不亡，因缘会遇时，果报还自受。”相信因果道理，以因果历然为自己的指导思想，则自己在任何环境，都能端身正意，不作损人利己之事，令自己的身语意，也就是语言、思想、行为都诸恶莫作，众善奉行，自净其意，则一切违缘业障等妨碍自己修行正道的阻力就会减少，以至于完全消除。《阿毗昙杂心论》说：“业能庄饰世，趣趣各处处，是以当思业，求离世解脱。”对业果决定一切的道理深信不疑，最要紧的就是要与自己身口意三业具体地结合起来，随时所作所为不违背因果规律，自然能得受用，使参禅正道无碍前进。对于因果道理有坚定信念之后，久而久之，自然达到达磨大师教导的“亦不睹恶而生嫌，亦不观善而勤措”的境界。此即禅门所谓的因果观也。
    既知世俗谛的因果法则为业行因缘而决定，由此而推之假有如幻如化，所有一切都无实体主宰。此理由圣人无漏智慧亲证所知而说，是圣人所证真实义，所以名胜义谛、圣谛、第一义谛等。“我”，是常一主宰的意思。对于自身，执有常一主宰的作用，就是人我执。对于一切，也就是万事万物，执有常一主宰的体性，就是法我执。换句话说，对自己执有此我，谓之自我，于他有情执有我体，谓之他我。但观察思维人身，是由色、受、想、行、识五蕴组织而成，是假和合而有，无常一主宰的我体。法亦如是，总为因缘和合生起显现，亦无常一主宰的我体。既无人我，亦无法我，则无自我他我，乃至种种不变的自性执，都彻底瓦解冰消了。此是圣人无漏智亲证亲知，故佛说通达无我法者，如来说名真实菩萨。人法都无我性，所以它成三法印的一印。一、诸行无常印，行是迁流的意义，谓一切有为法，念念生灭而无常，是为诸行无常印。二、诸法无我印，行字局限于有为法，法则通于无为法，言一切有为无为诸法中无有我的实体，是诸法无我印。三、涅槃寂静印，言涅槃之法，灭一切生死之苦而为无为寂静，是涅槃寂静印。印是楷定、决定、不变的意思，无常、无我、涅槃寂静，是佛教中印证一切法的三原则。如果某经所说法义合乎三法印，就是佛法；如果所说不合乎三法印，就不是佛法，是魔所说，是伪教假经。《大智度论》卷二十二及其它经论都阐明此义。
    了解无我以后，就可以独立自在自主，积极地培植福德智慧二资粮，确知一切所作，都是在自己第八识中种下种子，清净种子越多，转染成净的力量就越大。如果执著有我，我是常一固定的，那就不可转变，作什么也没用，乃至妄执为善亦死，为恶亦死，死了死了，一切都了，那还有什么道需要修，有什么善要作。弄得不好，就堕于常见断见中去，犹其堕于断灭见中，那真太可悲了，不堪设想！故佛说：宁起常见如须弥山，不可起断见如芥子许！

    （二）思念无常及诸苦
    学佛的人，认为宇宙人生是无常的痛苦的。因为是无常的痛苦的，所以要修道解脱痛苦，而且积极的修行办道，以求不因懈怠而堕落。这就要有无常的觉悟，就是要时刻思念无常。世间一切法，生灭迁流刹那不住，谓之无常。《涅槃经》说：“是身无常，念念不住，犹如电光、瀑水、幻 炎。”《大智度论》说：“一切有为法无常者，新新生灭故，属因缘故。”《六祖坛经》说：“生死事大，无常迅速。”有为诸法，依因缘之和合而生起，故说之为生；依因缘之离散而消灭，故说之为灭。故知一切有为法都是生灭变异，虚伪无主。如是观察，能自警真实参究，弃舍生死死生，生生死死如旋火轮似的无休止的流转。
    在思维无常方面，特别要思维三种死殁无常：１、思维决定要死，想死无常决定要来，没有办法躲避退却，因为自己从长期观察中得知，任受何等之身，定皆有死。《无常经》说：“无上诸世尊，独觉声闻众，尚舍无常身，何况诸凡夫。”经中还说：“住于何处死不入，如是方所定非有，空中非有海中无，亦非可住诸世间。”这就是说：住于任何环境中死殁都是逃不脱的。如是从多种道理思维死殁无常必来，就能对世间的财色名利等消沉厌倦而精进办道。２、思维死无定期，今天以后，百年以前，其死已定，但在中间何日而来，亦无定期。即在今日死与不死，俱无决定，谁也保证不了。修行办道人，应具有今日或明日必死的观念，这样就不会专为自身谋求长寿久住的所需，而积极地作善修福培慧，利乐一切有情。若于日日中能起死无定期的观念，则修行办道就会更积极，用功更亲切。故日日中定须发起必死之心，以促进自己的道业。３、思维死时什么都带不去，这世间一切名利财物，地位权势，一切的一切，都不能带走一丝一毫，除开自己所作的善恶业之外，其余的一切，既挽救不了自己的死，也一点带不走。俗话说，万般将不去，唯有业随身！将死时虽有极亲爱的人，诸如俱生骨肉父母儿女亲戚好友，以极大怜爱而相围绕呼嚎，亦须弃舍而死去，现世法中一切圆满之事皆必弃舍而去。思维死时什么都带不去，唯有业随身，大大可以警惕自己的道心，而积极修行办道。所谓八风（利、衰、毁、誉、称、讥、苦、乐）不动，三受（苦、乐、舍）寂然者，思维无常就可能做到，至少可以减轻贪著，确认唯法是依，唯法是靠，死时连自己的名字都没了，何况其余诸事！“诸行无常，是生灭法，生灭灭已，寂静为乐”。参禅办道的人宜慎思之。
    其次是思维诸苦。苦是逼迫的意思，我们领受的一切东西，都有逼恼身心的痛苦，不过轻重不同。如三苦中的苦苦、坏苦容易感受，第三行苦，就不容易感觉，而且往往以为是乐而领受之。八苦中的生、老、病、死、爱别离、求不得、怨憎会、五蕴炽盛苦，是比较容易感觉，都希望自己不发生这些痛苦，但谁也免不了。如《五王经》说佛为五王说法，“人生在世，常有无量众苦切身，今粗为汝等略说八苦，何谓八苦？生苦、老苦、病苦、死苦、爱别离苦、求不得苦、怨憎会苦、忧悲恼苦，是为八苦也。”在诸苦中，都是以我见为根本，而生起贪瞋痴等烦恼，特别是从贪欲起，多欲希求所作诸业为苦。由贪爱世间名利恭敬，色欲财宝，以致生死轮回，轮转六趣。天中死，人中生。人中死，天中生。天中死，生地狱中。地狱中死，生天上。天上死，生饿鬼中。饿鬼中死，还生天上。天上死，生畜生中。畜生中死，生天上。天上死，还生天上。地狱饿鬼畜生亦如是。欲界中死，色界中生。色界中死，欲界中生。欲界中死，无色界中生。无色界中死，欲界中生。欲界中死，欲界中生。色界无色界亦如是。生死流转，都以贪欲为因，招感生死苦果。所以佛在《八大人觉经》里说：“生死疲劳，从贪欲起。”《法华经·譬喻品》说：“诸苦所因，贪欲为本。若灭贪欲，无所依止。”又说：“三界无安，犹如火宅。”临济禅师也说：“大德，三界无安，犹如火宅，此不是你久停住处。无常杀鬼，一刹那间，不择贵贱老少，你要与祖佛不别，但莫外求。”《八大人觉经》又说：“少欲无为，身心自在。”修习少欲之人，心则坦然，无所忧畏。少欲既能生诸功德，无欲则更受无尽利益。多求增长罪恶，常念知足，则能安贫守道，惟修行办道是业，经常思念苦，则会渐渐减少对世间的种种贪求而离苦自乐。以此助道，扶持参禅正道，必能证悟解脱，永不受生死疲劳轮转不休之苦，岂不快哉！

    （三）发求解脱心和菩提心
    既知诸行无常，有漏皆苦，三界如火宅，不可久安住，则当发起希求解脱之心，亦名出离心，即出离三界之心。解脱者，解谓离缚，脱谓自在。我们在三界生死中流转，受烦恼业力的缠缚，永不自在。今欲得自在，就必须解脱生死中的烦恼及业。其方便之法，必须见五取蕴苦所有过患，和观察思维三界过患发起极欲舍离之心，则于苦集之法，不起欲得的追求。如《四百论》说：“谁于此无厌，彼岂爱寂静？如贪著自家，难出此三有（欲有、色有、无色有，即三界）。”故要解脱生死，必须于有漏生死法生起极大厌离心，不起烦恼，不造生死业，断除能系缚的法，才能得到解脱。《顿悟入道要门论》说：“问：欲修何法，即得解脱？答：唯有顿悟一门即得解脱。云何顿悟？答：顿者顿除妄念，悟者悟无所得。”
    人身是最难得的，是最宝贵的，是得解脱成佛道的最好最优越的条件。请注意，释迦世尊是在人间成佛的，人身是尊贵难得之宝。但人身难得而易失，如《菩萨处胎经》卷六说：“盲龟浮木孔，时时犹可值，人一失命根，亿劫复难是。海水深广大，三百三十六，一针投海中，求之尚可得，一失人身命，难得过于是。”《大乘庄严经论》也说：“离诸难亦难，生于人间难，既得离诸难，应当常精进。”世间三有的一切对我们来说，其现起的万物事象，名闻利养，都对我们有诱惑力。由于我执无明贪欲等的系缚，就支配我们去追求、逐取，顺意事起贪爱，违意事起瞋恚，起惑造业，乃至悭吝己物，贪求人财，嫉妒其富，瞋恨其贵，起诸邪见，拨无因果，好勇斗狠，欺老凌幼，由此父子不和，夫妻反目。不但造业受生流转三有，而且恶业多，善业少，失却了难得的人身。堕三恶趣中，更无顺境，不知为善，复得人身的机会就难上难了！所以在此既得难得的人身的基础上，应当善自珍重，常勤精进，修行办道。《念处经》说：“诸烦恼所依，独一谓懈怠；谁有一懈怠，俾便无诸法。”懈怠是令人堕落的堕下法。《菩萨本行经》说，“夫懈怠者，众行之累。居家庭懈怠，则衣食不供，产业不举。出家懈怠，不能出离生死之苦。”希求解脱的人，必须断除懈怠，无间断地常行精进。《成唯识论》说，勤谓精进，于善恶品修断事中勇悍为性。对治懈怠，满善为业。慈恩大师《上生经疏》说：“精谓精纯，无恶杂故；进谓升进，不懈怠故。”参禅办道的人，决不能懈怠，若悠悠忽忽，一生空过无成，如《华严经》说：“如钻燧求火，未出而数息，火势随止灭，懈怠者亦然。”必常行精进，才能破除烦恼，断除恶行，摧伏四魔（烦恼、五阴、死、自在天），克己造修，直至超出生死，得大利乐而后已。
    其次发菩提心。参禅办道的人，由于既学佛法，知道世间是苦，于生死流转，受尽痛苦，希求解脱，发解脱心、出离心，这是正确的发心，正确的念行。但是不知佛法，没有学习过佛法的人，不可胜数，他们都不知诸行无常，三界是苦，不求解脱，即使有心想解脱痛苦，也不知怎样才能解脱。有些人则争名夺利，人我是非，互相倾轧，利己害人之事，无所不为。有的人虽然学习了一些佛法，皈依了三宝，也愿意做一个很好的佛教徒，但于解脱入门不知方便，好者虽不作损人利己的坏事，做一些造善因求善果的有漏因缘，还是生死流转，可以说是既到宝山，空手而归。对于这些人，参禅求解脱者，岂能不发菩提心而度脱他们。所以在自己发起解脱心之后，还应该发大菩提心，令诸众生，觉生死苦，舍离五欲，修行圣道。
    菩提心，既无上正等正觉之心。《智度论》卷四十一说：“菩萨初发心，缘无上道，我当作佛，是名菩提心。”简单地说，就是为利有情愿成佛。
    菩提心有两种：一、缘事菩提心，是以四弘誓愿为体。１.众生无边誓愿度，念一切众生悉有佛性而发愿度之，令入大般涅槃，此为饶益有情戒，亦是恩德之心，亦是因缘佛性，亦是应身菩提之因。２.烦恼无尽誓愿断，愿求自断无边的烦恼，是摄律仪戒，亦是断德之心，正因佛性，法身菩提之因。３.法门无量誓愿学，愿求觉知无尽的佛法，是摄善法戒，智德之心，了因佛性，报身菩提之因。４.佛道无上誓愿成，是愿求证得无上佛果菩提。由前三行愿具足成就而证得三身圆满的菩提，不住生死，不住涅槃而广利益一切有情。二、缘理菩提心，一切诸法，本来寂灭，安住于此中道实相而成上求下化的愿行，是为最上菩提心。诸经论开导菩提心的教说很多，参究之士，应当广为阅读修学。但是经里说，任何发菩提心的人，各自可以发起很多不同的愿行，而四弘誓愿是菩萨的通愿，每个发菩提心的人都必须发心修学此四弘誓愿，才能称为菩萨。
    发起菩提心，必须修大慈大悲，对众生与乐拔苦，才能平等对待，怨亲平等，慈心普度；在身语意三业，常修四无量心、四摄法门、六波罗蜜等一切梵行，主要靠精进才能成就。如《遗教经》说：“汝等比丘，若勤精进，则事无难者。是故汝等当勤精进，譬如小水常流，则能穿石。若行者之心，数数懈废，譬如钻火，未热而息，虽欲得火，火难可得。是名精进。”
    《菩萨善戒经》把精进分为三种：一、庄严精进。即菩萨发心精勤修习，一切梵行，庄严道果，复为教化众生，于三界中，亦现受生，由慈悲故，乃至入地狱，代其受苦，心不休息，是名庄严精进。二、摄善法精进。谓菩萨既修六度梵行，不为烦恼恶业邪见之所倾动，摄持世间出世间一切善法，心不放逸，是名摄善法精进。三、利乐众生精进。谓菩萨于一切时修习圣道利益，于一切众生，以种种教法而化导之，都使之断灭恶因，成就善果。在时间上虽经历尘劫，心不疲倦，是名利益众生精进。《菩萨本行经》说：“直至成佛，皆由精进。”参禅的人，既发菩提心，当遵如来教导而修行菩萨道。

    （四）坚持禁戒
    从教理上讲，戒定慧三学，是修行的总纲。戒定慧三，摄尽六度等法门，故《摄大乘论》称为增上引生心学。戒学是定慧所依，由戒学为增上引生心学，即定学。心学为增上引生慧学，慧学为增上引证涅槃成满菩提。三学以顺益义，为胜因义，故名增上。广如《瑜伽师地论》说。参禅之士，为了参究易成，若不护持禁戒，不但参禅，修持别的任何法门，也不会得成就。世尊在《涅槃经》里说：“若不能持禁戒，云何当得见于佛性，一切众生虽有佛性，要因持戒，然后乃见，因见佛性，得成阿耨菩提。”见性成佛者，即见自己本有的佛性，若不持戒，见性成佛就成了空话。《涅槃经》还说：“欲见佛性，证大涅槃，必须深心修持净戒。若毁净戒，是魔眷属，非我弟子。”《大品经》说：“我若不持戒，当堕三恶道中，尚不得人身，况能成就众生，净佛国土，具一切种智。”《大智度论》说：“若人弃舍此戒，虽入山苦行，食果服药，与禽兽何异？若人虽处高堂大殿，好衣美食，而能持戒者，得生好处及得道果。”佛陀在这些经文里教导说，如果在家出家所受诸戒，如五戒、十戒、二百五十戒、菩萨三聚净戒等，悉能圆满护持，是真佛子，开佛性门，入涅槃道。如果不守持禁戒，堕三恶趣中，连人身都保不住，那里还能参禅开悟，成就众生，严净佛土！参禅之士，应当慎思，在参究时决不可忘掉持戒，借口参禅人不拘小节，胡作非为，死堕恶趣，岂不痛哉！持戒是入道的正门，菩提的真因，功德殊胜，未可思议，慎思慎思！
    《华严经》说：“戒是无上菩提本，应当具足持净戒，若能坚持于禁戒，是则如来所赞叹。”戒是获得无上正等正觉大菩提的根本，根本不固，一切难成。如建筑房屋，地基不巩固，一遇风雨则易倒塌。
    佛陀在《遗教经》说：“汝等比丘，于我灭后，当珍重尊敬波罗提木叉。”波罗提木叉，即戒律，又译为别解脱，或译处处解脱。七众佛弟子所受的戒律，能免过非，各别解脱身口七支的恶业，所以名别解脱。如来又说：“如暗遇明，如贫得宝。当知此则是汝等大师。若我住世无异此也。”这是如来最后的教诫，说戒是正顺解脱的根本，持戒则等于佛住世，戒就是佛弟子的大师。大师者佛也。能善教授教诫弟子一切应作不应作事，能化导无量众生，令至涅槃菩提，故名大师。世尊还说：“戒是正顺解脱之本，故名波罗提木叉，因依此戒，得生诸禅定，及灭苦智慧。”四百四病为身苦，忧愁嫉妒等为心苦，总合二种，名为内苦。恶贼虎狼等害及风雨寒暑等灾为外苦。持戒就能起消灭内外种种苦的无漏智慧。如来立教，其法有三：一曰戒律，二曰禅定，三曰智慧。然非戒无以生定，非定无以生慧，三法相依，不可缺一。所以如来又说：“是故比丘，当持净戒，勿令毁缺。若人能持净戒，是则能生善法。若无净戒，诸善功德皆不得生。是以当知戒为第一安稳功德之所住处。”五戒十善，是世间的善法，三学六度是出世间善法，虽有浅深差别，但皆为顺理益己之法，故名善法。所言功德者，善法有资润福利之功，故名为功，此功是其善行家之德，名为功德。若无净戒，诸善功德皆不得生。因此可知持戒是第一安稳功德之所住处。
    持戒要注意小恶，谨防慎之，则不至造大恶而无以防范，以致不欲作而违心作之。《涅槃经》中说：“莫轻小恶，以为无殃，水滴虽微，渐盈大器。”
    《大智度论》说：“若求大利，当坚持戒，如惜重宝，如护身命，以戒是一切善法住处。”
    千经万论赞叹持戒的殊胜功德，毁戒则是损坏一切功德而堕三恶趣之因。故参禅办道之士，应当遵佛教导，深思持戒功德，毁戒过患，小心谨慎地护持净戒。“诸恶莫作，众善奉行，自净其意，是诸佛教。”这是佛陀在戒律中的教导，修行办道的佛子，应当依教奉行。

    （五）参究
    参禅的参，就是要追虑审究，穷玄极妙，必使自己悟得本来面目，见性成佛。其方便之法，行住坐卧，不离这个，起心即乖，动念即错。起心动念，必也觉破，就体消停，久久忘缘，自成一片。在方便法门上，有结跏趺端身正坐参究，及历缘任运，无住、无心、无念、任运腾腾、腾腾任运，无处不在参究。如六祖说：“兀兀不修善，腾腾不作恶，寂寂断见闻，荡荡心无著。”兀兀即不动，腾腾即自在无为，寂寂即安静孤明，荡荡心无著，就是坦坦平平，心无所住。六祖为了针对欲得会道，必须坐禅的看法，而说“道由心悟，岂在坐耶。”其所谓禅者，乃四禅八定之禅，非参禅的最上乘禅。不可妄执以为参禅不须静坐，切莫迷执罢参恣纵自由放任，那是极其可悲痛的！六祖临入灭时，亦“端坐至三更，忽谓门人曰：‘吾行矣。’奄然迁化。”六祖如是，岂不坐耶？结跏趺坐与参禅得成就有极重要的关系，这是佛陀倡导的最殊胜的安稳坐，又称之为狮子坐。
    《大智度论》卷七说：“问曰：‘多有坐法，佛何以唯用结跏趺坐？’答曰：‘诸坐法中，结跏趺坐最安稳，不疲极。此是坐禅人坐法。摄持手足，心亦不散。又于一切四种身仪中最安稳。此是禅坐，取道法坐。魔王见之，其心忧怖。如此坐者，出家人法。在林树下结跏趺坐，众人见之，皆大欢喜，知此道人，必当取道。如偈说：若结跏趺坐，身安入三昧，威德人敬仰，如日照天下。除睡懒覆心，身轻不疲懈。觉悟亦轻便，安坐如龙蟠。见结跏趺坐，魔王亦愁怖，何况入道人，安坐不倾动。以是故结跏趺坐。复次，佛教弟子应如是坐。有外道辈，或常翘足求道，或常立，或荷足，如是狂狷，心没邪海，形不安稳。以是故佛教弟子结跏趺直身坐。何以故？直身心易正故。其身直坐，则心不懒。端心正意，系念在前，若心驰散，摄之令还，欲入三昧故。种种驰念，皆亦摄之。如是系念，入三昧王三昧。’”
    如来常在经里说：诸弟子不要打扰我，我要三日入定，七日入定，九十日入定。如来常在定，无有不定时。为什么还要三天入定乃至九十天入定呢？无非是示现此事，为弟子们作榜样。
    禅宗西天第十祖胁尊者，修行精苦，未尝寝寐，昼夜胁不至席，以故得号胁尊者。
    中华初祖达磨大师，于嵩山少林寺面壁九年，人莫测之，谓之壁观婆罗门。
    四祖道信大师，摄心无寐，胁不至席者六十年。
    福州长庆慧稄禅师，历参禅苑，往来雪峰、玄沙，十二年间，坐破七个蒲团。一日卷帘，忽大悟。
    参禅大德，重视并主张打坐的范例很多，不一一例举。古人说，坐破是悟门中事，悟者，只管打坐。坐禅的当体，是作佛，行佛受用三昧。一时打坐，一时佛；一日打坐，一日佛；一生打坐，一生佛。然后做到行亦禅，坐亦禅，语默动静体安然，可谓禅与生活打成一片了。
    下面说参禅用功的事。不取向上玄谈，唯取做功夫吃紧处。做功夫时，无论是坐习或行住等，皆以即心即佛，无心是道，历历孤明为正道。其方便法门略说三种：一、觉察。做功夫时，平常绝念，提防念起，一念才生，便与觉破，前念觉破，后念不生。此之觉智，亦不须用，妄觉俱忘，名曰无心。故祖师说，不怕无起，只恐觉迟。又说，不用求真，唯须息见。此即息妄功夫。二、休歇。做功夫时，不思善，不思恶，心起便休，遇缘便歇。古人说，一条白练去，冷湫湫地去，古庙香炉去，直得绝廉纤，离分别，如痴如兀，方有少分相应。此是休歇功夫。三、泯心存镜。做功夫时，于一切妄念俱息，不顾外境，但自息心。妄心已息，何害有境。如庞公云：“但自无心于万物，何妨万物常围绕。”此是泯心存境息妄功夫。
    如果对上述用功的方便法门用不上，可以参一则与自己相应的话头，如“狗子无佛性”、“庭前柏树子”、“须弥山”、“麻三斤”、“乾屎橛”、“万法归一，一归何处”、“我的本来面目”，等用心参究。
    大慧宗杲禅师，特别提倡参“狗子无佛性”，着重在“无”字上参，通身起个疑团，参个无字，昼夜提撕，莫作虚无会，莫作有无会。行住坐卧，穿衣吃饭，屙屎放尿，心心相顾，猛着精彩，守个无字，日久岁深，打成一片，忽然心华顿发，悟佛祖之机，便不被天下老和尚舌头瞒，便会开大口，到这里，说甚阎王老子，千圣也奈何不了。这是绝后再苏。此义在《曹洞临济参禅方法的差异》一节中已详说，今不再述。
    元天目高峰原妙参禅说：“若谓着实参禅，决须具足三要：第一、要有大信根。明知此事，如靠一座须弥山。第二、要有大愤志。如遇杀父冤贼，直欲便与一刀两段。第三、要有大疑情。如暗地做了一件极事，正在欲露未露之时。十二时中，果能具此三要，管取剋日成功，不怕瓮中走鳖。苟缺其一，譬如折足之鼎，终成废器。”
    中峰和尚说：“坐禅别无用心处，只十二时中，放下一切尘劳妄想境，常自心如虚空，毫发计使无他念。若得自心清净，还不思善，不思恶，正当与么时，如何是我父母未生以前本来面目？如是看，若工夫一片成，自然得有悟入。何名坐禅？外于一切善恶境界，心心不起名为坐，内见自性不动名为禅。如今学道人不悟此心体，便于心上生心，向外求佛，著相修行，皆是恶法，非菩萨道。”
    朝鲜西山大师退隐说：“凡本参公案上，切心做功夫，如鸡抱卵，如猫捕鼠，如饥思食，如渴思水，如儿忆母，必有透彻之期。参禅须具三要：一有大信根，二有大愤志，三有大疑情，苟缺其一，如折足之鼎，终成废器。”
    总起来说，凡欲成佛，不染一物。最初要发起一个坚强地破生死心，看破世界身心都是假缘，无实主宰，若不发明本具的大事，则生死不破。既生死心不破，无常杀鬼念念不停，却如何排遣？将破生死心一念，作个敲门砖子，猛着精彩，不顾身命，不望人救，不生别念，不肯暂止，直到以悟为则。
    做功夫贵在起疑情，什么是疑情？如生不知何来，不得不疑来处。死不知何去，不得不疑去处。生关窍不破。则疑情顿发，结在眉睫上，放亦不下，赶亦不去，忽然一朝扑破疑团，生死二字，是什么闲家具！古德所谓大疑大悟，小疑小悟，不疑不悟者此也。
    做功夫最怕耽着静境，做人困于枯寂，不知不觉。动境生厌，静境安然。原因是行人一向处于喧闹的环境，一与静境相应，如吃适合口胃的东西，则生耽着。又如人倦久喜睡，久久堕于无知，落于松散懈怠而不自觉得。
    做功夫要中正劲挺，不近人情。如果循情应对，则功夫做不上，不但做不上，日久月深，则必成为随顺流俗的阿师。
    做功夫疑团得力时，看山不是山，见水不是水，行不知行，坐不知坐，东西南北不辨，通身内外只是一个疑团。疑团不破，誓不罢休。
    做功夫举话头时，要历历明明，话头若失，立即再举，不破话头誓不甘休。不然则坐在鬼窟里，昏昏沉沉过了一生，有何所益。
    做功夫切莫信道不须参，若不参便云已得理，此则是天生弥勒，自然释迦。此辈名为可怜悯者，临命终时，手忙脚乱，悔之何及！
    做功夫时，不得将心待悟，若将心待悟，终不得悟，只须逼拶令悟。若大悟时，如莲花开，如大梦忽觉。看话头真切，逼拶心意，时节因缘会合时自悟。悟时如拨云见天而廓落无依，天旋地转，又是一番境界。
    黄檗禅师说：“尘劳迥脱事非常，紧把绳头做一场，不是一番寒彻骨，争得梅花扑鼻香。”此语最亲切，若将此偈时时警策，功夫自然做得上了。
    参！