杂阿含经

［刘宋］求那跋陀罗 译　 [image] 清凉书屋点校

·2005.11·


杂阿含经卷第一

（一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当观色无常，如是观者，则为正观；正观者，则生厌离；厌离者，喜贪尽；喜贪尽者，说心解脱。如是观受、想、行、识无常，如是观者，则为正观；正观者，则生厌离；厌离者，喜贪尽；喜贪尽者，说心解脱。如是比丘，心解脱者，若欲自证，则能自证：我生已尽，梵行已立，所作已作，自知不受后有。如观无常，苦、空、非我，亦复如是。”
    时诸比丘闻佛所说，欢喜奉行。

（二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于色当正思惟，观色无常如实知。所以者何？比丘，于色正思惟，观色无常如实知者，于色欲贪断；欲贪断者，说心解脱。如是受、想、行、识，当正思惟，观识无常如实知。所以者何？于识正思惟，观识无常者，则于识欲贪断；欲贪断者，说心解脱。如是心解脱者，若欲自证，则能自证：我生已尽，梵行已立，所作已作，自知不受后有。如是正思惟无常，苦、空、非我，亦复如是。”
    时诸比丘闻佛所说，欢喜奉行。

（三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于色不知、不明、不断、不离欲，则不能断苦。如是受、想、行、识，不知、不明、不断、不离欲，则不能断苦。诸比丘，于色若知、若明、若断、若离欲，则能断苦。如是受、想、行、识，若知、若明、若断、若离欲，则能堪任断苦。”
    时诸比丘闻佛所说，欢喜奉行。

（四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于色不知、不明、不断、不离欲，心不解脱者，则不能越生老病死怖。如是受、想、行、识，不知、不明、不断、不离欲贪，心不解脱者，则不能越生老病死怖。比丘，于色若知、若明、若断、若离欲，则能越生老病死怖。诸比丘，若知、若明、若离欲贪，心解脱者，则能越生老病死怖。如是受、想、行、识，若知、若明、若断、若离欲贪，心解脱者，则能越生老病死怖。”
    时诸比丘闻佛所说，欢喜奉行。

（五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于色爱喜者，则于苦爱喜；于苦爱喜者，则于苦不得解脱、不明、不离欲。如是受、想、行、识爱喜者，则爱喜苦；爱喜苦者，则于苦不得解脱。诸比丘，于色不爱喜者，则不喜于苦；不喜于苦者，则于苦得解脱。如是受、想、行、识，不爱喜者，则不喜于苦；不喜于苦者，则于苦得解脱。
    “诸比丘，于色不知、不明、不离欲贪，心不解脱；心不解脱者，则不能断苦。如是受、想、行、识，不知、不明、不离欲贪，心不解脱者，则不能断苦。于色若知、若明、若离欲贪，心得解脱者，则能断苦。如是受、想、行、识，若知、若明、若离欲贪，心得解脱者，则能断苦。”
    时诸比丘闻佛所说，欢喜奉行。

（六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于色不知、不明、不离欲贪，心不解脱者，则不能越生老病死怖。如是受、想、行、识，不知、不明、不离欲贪，心不解脱者，则不能越生老病死怖。诸比丘，于色若知、若明、若离欲贪，心解脱者，则能越生老病死怖。如是受、想、行、识，若知、若明、若离欲贪，心解脱者，则能越生老病死怖。”
    时诸比丘闻佛所说，欢喜奉行。

（七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于色爱喜者，则于苦爱喜；于苦爱喜者，则于苦不得解脱。如是受、想、行、识爱喜者，则爱喜苦；爱喜苦者，则于苦不得解脱。诸比丘，于色不爱喜者，则不喜于苦；不喜于苦者，则于苦得解脱。如是受、想、行、识，不爱喜者，则不喜于苦；不喜于苦者，则于苦得解脱。”
    时诸比丘闻佛所说，欢喜奉行。

无常及苦空，非我正思惟，
无知等四种，及于色喜乐。

（八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过去、未来色无常，况现在色？圣弟子如是观者，不顾过去色，不欣未来色，于现在色厌、离欲、正向灭尽。如是过去、未来受、想、行、识无常，况现在识？圣弟子如是观者，不顾过去识，不欣未来识，于现在识厌、离欲、正向灭尽。”
    如无常，苦、空、非我，亦复如是。
    时诸比丘闻佛所说，欢喜奉行。

（九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“色无常，无常即苦，苦即非我，非我者亦非我所，如是观者，名真实正观。如是受、想、行、识无常，无常即苦，苦即非我，非我亦非我所，如是观者，名真实正观。圣弟子如是观者，厌于色，厌受、想、行、识，厌故不乐，不乐故得解脱，解脱者真实智生：我生已尽，梵行已立，所作已作，自知不受后有。”
    时诸比丘闻佛所说，欢喜奉行。

（一○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“色无常，无常即苦，苦即非我，非我者即非我所，如是观者，名真实正观。如是受、想、行、识无常，无常即苦，苦即非我，非我即非我所，如是观者，名真实正观。圣弟子如是观者，于色解脱，于受、想、行、识解脱，我说是等解脱于生老病死、忧悲苦恼。”
    时诸比丘闻佛所说，欢喜奉行。

（一一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“色无常，若因、若缘生诸色者，彼亦无常；无常因、无常缘所生诸色，云何有常？如是受、想、行、识无常，若因、若缘生诸识者，彼亦无常；无常因、无常缘所生诸识，云何有常？如是诸比丘，色无常，受、想、行、识无常，无常者则是苦，苦者则非我，非我者则非我所。圣弟子如是观者，厌于色，厌于受、想、行、识，厌者不乐，不乐则解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。”
    时诸比丘闻佛所说，欢喜奉行。

（一二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“色无常，若因、若缘生诸色者，彼亦无常；无常因、无常缘所生诸色，云何有常？受、想、行、识无常，若因、若缘生诸识者，彼亦无常；无常因、无常缘所生诸识，云何有常？如是比丘，色无常，受、想、行、识无常，无常者则是苦，苦者则非我，非我者则非我所，如是观者，名真实正观。圣弟子如是观者，于色解脱，于受、想、行、识解脱，我说是等为解脱生老病死、忧悲苦恼。”
    时诸比丘闻佛所说，欢喜奉行。

（一三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若众生于色不味者，则不染于色；以众生于色味故，则有染著。如是众生于受、想、行、识不味者，彼众生则不染于识；以众生味受、想、行、识故，彼众生染著于识。诸比丘，若色于众生不为患者，彼诸众生不应厌色；以色为众生患故，彼诸众生则厌于色。如是受、想、行、识不为患者，彼诸众生不应厌识；以受、想、行、识为众生患故，彼诸众生则厌于识。诸比丘，若色于众生无出离者，彼诸众生不应出离于色；以色于众生有出离故，彼诸众生出离于色。如是受、想、行、识于众生无出离者，彼诸众生不应出离于识；以受、想、行、识于众生有出离故，彼诸众生出离于识。诸比丘，若我于此五受阴不如实知味是味、患是患、离是离者，我于诸天、若魔、若梵、沙门、婆罗门、天人众中，不脱、不出、不离，永住颠倒，亦不能自证得阿耨多罗三藐三菩提。诸比丘，我以如实知此五受阴，味是味、患是患、离是离故，我于诸天、若魔、若梵、沙门、婆罗门、天人众中，自证得脱、得出、得离、得解脱结缚，永不住颠倒，亦能自证得阿耨多罗三藐三菩提。”
    时诸比丘闻佛所说，欢喜奉行。

（一四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我昔于色味有求有行，若于色味随顺觉，则于色味以智慧如实见。如是于受、想、行、识味有求有行，若于受、想、行、识味随顺觉，则于识味以智慧如实见。诸比丘，我于色患有求有行，若于色患随顺觉，则于色患以智慧如实见。如是受、想、行、识患有求有行，若于识患随顺觉，则于识患以智慧如实见。诸比丘，我于色离有求有行，若于色随顺觉，则于色离以智慧如实见。如是受、想、行、识离有求有行，若于受、想、行、识离随顺觉，则于受、想、行、识离以智慧如实见。诸比丘，我于五受阴不如实知味是味、患是患、离是离者，我于诸天、若魔、若梵、沙门、婆罗门、天人众中，不脱、不离、不出，永住颠倒，不能自证得阿耨多罗三藐三菩提。诸比丘，我以如实知五受阴，味是味、患是患、离是离，我于诸天、若魔、若梵、沙门、婆罗门、天人众中，以脱、以离、以出，永不住颠倒，能自证得阿耨多罗三藐三菩提。”
    时诸比丘闻佛所说，欢喜奉行。

过去四种说，厌离及解脱，
二种说因缘，味亦复二种。

（一五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时有异比丘来诣佛所，稽首佛足，却住一面，白佛言：“善哉世尊！今当为我略说法要。我闻法已，当独一静处，修不放逸。修不放逸已，当复思惟：所以善男子出家，剃除须发，身着法服，信家非家，出家为究竟无上梵行，现法作证：我生已尽，梵行已立，所作已作，自知不受后有。”
    尔时世尊告彼比丘：“善哉善哉！比丘快说此言，云：‘当为我略说法要，我闻法已，独一静处，修不放逸，乃至自知不受后有。’如是说耶？”
    比丘白佛：“如是，世尊。”
    佛告比丘：“谛听谛听，善思念之，当为汝说。比丘，若随使使者，即随使死；若随死者，为取所缚。比丘，若不随使使，则不随使死；不随使死者，则于取解脱。”
    比丘白佛：“知已，世尊。知已，善逝。”
    佛告比丘：“汝云何于我略说法中广解其义？”
    比丘白佛言：“世尊，色随使使，色随使死；随使使，随使死者，则为取所缚。如是受、想、行、识，随使使，随使死；随使使，随使死者，为取所缚。世尊，若色不随使使，不随使死；不随使使，不随使死者，则于取解脱。如是受、想、行、识，不随使使，不随使死；不随使使，不随使死者，则于取解脱。如是世尊略说法中广解其义。”
    佛告比丘：“善哉善哉！比丘，于我略说法中广解其义。所以者何？色随使使，随使死；随使使，随使死者，则为取所缚。如是受、想、行、识，随使使，随使死；随使使，随使死者，则为取所缚。比丘，色不随使使，不随使死；不随使使，不随使死者，则于取解脱。如是受、想、行、识，不随使使，不随使死；不随使使，不随使死者，则于取解脱。”
    时彼比丘闻佛所说，心大欢喜，礼佛而退。独在静处，精勤修习，住不放逸。精勤修习，住不放逸已，思惟所以善男子出家，剃除须发，身着法服，信家非家，出家乃至自知不受后有。时彼比丘即成罗汉，心得解脱。

（一六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时有异比丘来诣佛所，所问如上。
    差别者：“随使使，随使死者，则增诸数。若不随使使，不随使死者，则不增诸数。”
    佛告比丘：“汝云何于我略说法中广解其义？”
    时彼比丘白佛言：“世尊，若色随使使，随使死；随使使，随使死者，则增诸数。如是受、想、行、识，随使使，随使死；随使使，随使死者，则增诸数。世尊，若色不随使使，不随使死；不随使使，不随使死者，则不增诸数。如是受、想、行、识，不随使使，不随使死；不随使使，不随使死者，则不增诸数。如是世尊，我于略说法中广解其义。”
    如是乃至得阿罗汉，心得解脱。

（一七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    有异比丘从座起，偏袒右肩，合掌白佛言：“善哉世尊！为我略说法要。我闻法已，当独一静处，专精思惟，住不放逸，所以善男子出家，剃除须发，身着法服，信家非家，出家学道，为究竟无上梵行，现法身作证：我生已尽，梵行已立，所作已作，自知不受后有。”
    尔时世尊告彼比丘：“善哉善哉！汝作是说：‘世尊，为我略说法要，我于略说法中广解其义，当独一静处，专精思惟，住不放逸，乃至自知不受后有。’汝如是说耶？”
    比丘白佛：“如是，世尊。”
    佛告比丘：“谛听谛听，善思念之，当为汝说。比丘，非汝所应之法，宜速断除。断彼法者，以义饶益，长夜安乐。”
    时彼比丘白佛言：“知已，世尊。知已，善逝。”
    佛告比丘：“云何于我略说法中广解其义？”
    比丘白佛言：“世尊，色非我所应，宜速断除；受、想、行、识非我所应，宜速断除；以义饶益，长夜安乐。是故世尊，我于世尊略说法中广解其义。”
    佛言：“善哉善哉！比丘，汝于我略说法中广解其义。所以者何？色者非汝所应，宜速断除。如是受、想、行、识非汝所应，宜速断除。断除已，以义饶益，长夜安乐。”
    时彼比丘闻佛所说，心大欢喜，礼佛而退。独一静处，精勤修习，住不放逸。精勤修习，住不放逸已，思惟所以善男子出家，剃除须发，身着法服，正信非家，出家乃至自知不受后有。时彼比丘成阿罗汉，心得解脱。

（一八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时有异比丘从座起，偏袒右肩，为佛作礼，却住一面，而白佛言：“善哉世尊！为我略说法要。我闻法已，当独一静处，专精思惟，不放逸住，乃至自知不受后有。”
    佛告比丘：“善哉善哉！汝作如是说：世尊，为我略说法要，我闻法已，当独一静处，专精思惟，不放逸住，乃至自知不受后有耶？”
    时彼比丘白佛言：“如是，世尊。”
    佛告比丘：“谛听谛听，善思念之，当为汝说。若非汝所应，亦非余人所应，此法宜速除断。断彼法已，以义饶益，长夜安乐。”
    时彼比丘白佛言：“知已，世尊。知已，善逝。”
    佛告比丘：“云何于我略说法中广解其义？”
    比丘白佛言：“世尊，色非我，非我所应，亦非余人所应，是法宜速除断；断彼法已，以义饶益，长夜安乐。如是受、想、行、识非我，非我所应，亦非余人所应，宜速除断；断彼法已，以义饶益，长夜安乐。是故我于如来略说法中广解其义。”
    佛告比丘：“善哉善哉！汝于我略说法中广解其义。所以者何？比丘，色非我，非我所应，亦非余人所应，是法宜速除断；断彼法已，以义饶益，长夜安乐。如是受、想、行、识非我，非我所应，亦非余人所应，是法宜速除断；断彼法已，以义饶益，长夜安乐。”
    时彼比丘闻佛所说，心大欢喜，礼佛而退。独一静处，精勤修习，不放逸住，乃至自知不受后有。时彼比丘心得解脱，成阿罗汉。

（一九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时有异比丘从座起，为佛作礼，而白佛言：“世尊，为我略说法要。我闻法已，当独一静处，专精思惟，不放逸住。不放逸住已，思惟所以善男子正信家非家，出家乃至自知不受后有。”
    尔时世尊告彼比丘：“善哉善哉！汝今作是说：善哉世尊，为我略说法要，我闻法已，当独一静处，专精思惟，不放逸住，乃至自知不受后有耶？”
    比丘白佛言：“如是，世尊。”
    佛告比丘：“谛听谛听，善思念之，当为汝说。比丘，结所系法，宜速除断。断彼法已，以义饶益，长夜安乐。”
    时彼比丘白佛言：“知已，世尊。知已，善逝。”
    佛告比丘：“汝云何于我略说法中广解其义？”
    比丘白佛言：“世尊，色是结所系法；是结所系法，宜速除断；断彼法已，以义饶益，长夜安乐。如是受、想、行、识，结所系法；是结所系法，宜速除断；断彼法已，以义饶益，长夜安乐。是故我于世尊略说法中广解其义。”
    佛告比丘：“善哉善哉！汝于我略说法中广解其义。所以者何？色是结所系法，此法宜速除断；断彼法已，以义饶益，长夜安乐。如是受、想、行、识，是结所系法，此法宜速除断；断彼法已，以义饶益，长夜安乐。”
    时彼比丘闻佛所说，心大欢喜，礼佛而退。独一静处，专精思惟，不放逸住。乃至心得解脱，成阿罗汉。

（二○）

    深经亦如是说。

（二一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时有异比丘从座起，为佛作礼，而白佛言：“世尊，为我略说法要。我闻法已，当独一静处，专精思惟，不放逸住。不放逸住已，思惟所以善男子正信非家，出家乃至自知不受后有。”
    尔时世尊告彼比丘：“善哉善哉！汝今作是说：善哉世尊，为我略说法要，我闻法已，当独一静处，专精思惟，不放逸住，乃至自知不受后有耶？”
    比丘白佛言：“如是，世尊。”
    佛告比丘：“谛听谛听，善思念之，当为汝说。比丘，动摇时则为魔所缚；若不动者，则解脱波旬。”
    比丘白佛言：“知已，世尊。知已，善逝。”
    佛告比丘：“汝云何于我略说法中广解其义？”
    比丘白佛言：“世尊，色动摇时，则为魔所缚；若不动者，则解脱波旬。如是受、想、行、识动摇时，则为魔所缚；若不动者，则解脱波旬。是故我于世尊略说法中广解其义。”
    佛告比丘：“善哉善哉！汝于我略说法中广解其义。所以者何？若色动摇时，则为魔所缚；若不动者，则解脱波旬。如是受、想、行、识动摇时，则为魔所缚；若不动者，则解脱波旬。”
    乃至自知不受后有，心得解脱，成阿罗汉。

（二二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时有比丘名劫波，来诣佛所，头面礼足，却住一面，白佛言：“如世尊说比丘心得善解脱，世尊，云何比丘心得善解脱？”
    尔时世尊告劫波曰：“善哉善哉！能问如来心善解脱。善哉劫波！谛听谛听，善思念之，当为汝说。劫波，当观知诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切悉皆无常。正观无常已，色爱即除；色爱除已，心善解脱。如是观受、想、行、识，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切悉皆无常。正观无常已，识爱即除；识爱除已，我说心善解脱。劫波，如是比丘心善解脱者，如来说名心善解脱。所以者何？爱欲断故，爱欲断者，如来说名心善解脱。”
    时劫波比丘闻佛所说，心大欢喜，礼佛而退。
    尔时劫波比丘受佛教已，独一静处，专精思惟，不放逸住，乃至自知不受后有，心善解脱，成阿罗汉。

（二三）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者罗睺罗往诣佛所，头面礼足，却住一面，白佛言：“世尊，云何知、云何见，我此识身及外境界一切相，能令无有我、我所见、我慢使系著？”
    佛告罗睺罗：“善哉善哉！能问如来，云何知、云何见，我此识身及外境界一切相，能令无有我、我所见、我慢使系著耶？”
    罗睺罗白佛言：“如是，世尊。”
    佛告罗睺罗：“善哉！谛听谛听，善思念之，当为汝说。罗睺罗，当观若所有诸色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切悉皆非我、不异我、不相在，如是平等慧正观。如是受、想、行、识，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、不异我、不相在，如是平等慧如实观。如是罗睺罗，比丘如是知、如是见。如是知、如是见者，于此识身及外境界一切相，无有我、我所见、我慢使系著。罗睺罗，比丘若如是于此识身及外境界一切相，无有我、我所见、我慢使系著者，比丘是名断爱欲，转去诸结，正无间等，究竟苦边。”
    时罗睺罗闻佛所说，欢喜奉行。

（二四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告罗睺罗：“比丘，云何知、云何见，我此识身及外境界一切相，无有我、我所见、我慢使系著？”
    罗睺罗白佛言：“世尊为法主，为导，为覆。善哉世尊！当为诸比丘演说此义，诸比丘从佛闻已，当受持奉行。”
    佛告罗睺罗：“谛听谛听，善思念之，当为汝说。”
    罗睺罗白佛：“唯然受教。”
    佛告罗睺罗：“当观诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、不异我、不相在，如是平等慧如实观。如是受、想、行、识，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、不异我、不相在，如是平等慧如实观。比丘如是知、如是见，我此识身及外境界一切相，无有我、我所见、我慢使系著。罗睺罗，比丘如是识身及外境界一切相，无有我、我所见、我慢使系著者，超越疑心，远离诸相，寂静解脱。是名比丘断除爱欲，转去诸结，正无间等，究竟苦边。”
    时罗睺罗闻佛所说，欢喜奉行。

使增诸数，非我非彼，结系动摇，
劫波所问，亦罗睺罗，所问二经。

（二五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘来诣佛所，为佛作礼，却住一面，白佛言：“如世尊说多闻，云何为多闻？”
    佛告比丘：“善哉善哉！汝今问我多闻义耶？”
    比丘白佛：“唯然，世尊。”
    佛告比丘：“谛听善思，当为汝说。比丘当知，若闻色是生厌、离欲、灭尽、寂静法，是名多闻。如是闻受、想、行、识，是生厌、离欲、灭尽、寂静法，是名多闻。比丘，是名如来所说多闻。”
    时彼比丘闻佛所说，踊跃欢喜，作礼而去。

（二六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时有异比丘来诣佛所，头面礼足，却住一面，白佛言：“如世尊所说法师，云何名为法师？”
    佛告比丘：“善哉善哉！汝今欲知如来所说法师义耶？”
    比丘白佛：“唯然，世尊。”
    佛告比丘：“谛听善思，当为汝说。”
    佛告比丘：“若于色说是生厌、离欲、灭尽、寂静法者，是名法师。若于受、想、行、识，说是生厌、离欲、灭尽、寂静法者，是名法师。是名如来所说法师。”
    时彼比丘闻佛所说，踊跃欢喜，作礼而去。

（二七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时有异比丘来诣佛所，头面作礼，却住一面，白佛言：“如世尊说法次法向，云何法次法向？”
    佛告比丘：“善哉善哉！汝今欲知法次法向耶？”
    比丘白佛：“唯然，世尊。”
    佛告比丘：“谛听善思，当为汝说。比丘，于色向厌、离欲、灭尽，是名法次法向。如是于受、想、行、识，向厌、离欲、灭尽，是名法次法向。”
    时彼比丘闻佛所说，踊跃欢喜，作礼而去。

（二八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时有异比丘来诣佛所，头面礼足，却住一面，白佛言：“世尊，如世尊所说得见法涅槃，云何比丘得见法涅槃？”
    佛告比丘：“善哉善哉！汝今欲知见法涅槃耶？”
    比丘白佛：“唯然，世尊。”
    佛告比丘：“谛听善思，当为汝说。”
    佛告比丘：“于色生厌、离欲、灭尽，不起诸漏，心正解脱，是名比丘见法涅槃。如是受、想、行、识，生厌、离欲、灭尽，不起诸漏，心正解脱，是名比丘见法涅槃。”
    时彼比丘闻佛所说，踊跃欢喜，作礼而去。

（二九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时有异比丘名三蜜离提，来诣佛所，头面礼足，却住一面，白佛言：“如世尊说说法师，云何名为说法师？”
    佛告比丘：“汝今欲知说法师义耶？”
    比丘白佛：“唯然，世尊。”
    佛告比丘：“谛听善思，当为汝说。若比丘于色说厌、离欲、灭尽，是名说法师。如是于受、想、行、识，说厌、离欲、灭尽，是名说法师。”
    时彼比丘闻佛所说，踊跃欢喜，作礼而去。

多闻善说法，向法及涅槃，
三蜜离提问，云何说法师。

（三○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者舍利弗在耆阇崛山中。
    时有长者子名输屡那，日日游行，到耆阇崛山，诣尊者舍利弗，问讯起居已，却坐一面，语舍利弗言：“若诸沙门、婆罗门，于无常色，变易、不安隐色，言：‘我胜、我等、我劣。’何故沙门、婆罗门作如是想，而不见真实？若沙门、婆罗门，于无常、变易、不安隐受、想、行、识，而言：‘我胜、我等、我劣。’何故沙门、婆罗门作如是想，而不见真实？若沙门、婆罗门，于无常色，变易、不安隐色，言：‘我胜、我等、我劣。’何所计而不见真实？于无常、变易、不安隐受、想、行、识，言：‘我胜、我等、我劣。’何所计而不见真实？”
    “输屡那，于汝意云何？色为常、为无常耶？”
    答言：“无常。”
    “输屡那，若无常，为是苦耶？”
    答言：“是苦。”
    “输屡那，若无常、苦，是变易法。于意云何？圣弟子于中见色是我、异我、相在不？”
    答言：“不也。”
    “输屡那，于意云何？受、想、行、识，为常、为无常？”
    答言：“无常。”
    “若无常，是苦耶？”
    答言：“是苦。”
    “输屡那，识若无常、苦，是变易法。于意云何？圣弟子于中见识是我、异我、相在不？”
    答言：“不也。”
    “输屡那，当知色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切色不是我、不异我、不相在，是名如实知。如是受、想、行、识，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切识不是我、不异我、不相在，是名如实知。输屡那，如是于色、受、想、行、识，生厌、离欲、解脱、解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。”
    时舍利弗说是经已，长者子输屡那远尘离垢，得法眼净。时长者子输屡那见法得法，不由于他，于正法中，得无所畏。从座起，偏袒右肩，胡跪合掌，白舍利弗言：“我今已度！我从今日归依佛、归依法、归依僧，为优婆塞。我从今日已，尽寿命，清净归依三宝。”
    时长者子输屡那闻舍利弗所说，欢喜踊跃，作礼而去。

（三一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者舍利弗在耆阇崛山。
    时有长者子名输屡那，日日游行，到耆阇崛山，诣舍利弗所，头面礼足，却坐一面。
    时舍利弗谓输屡那：“若沙门、婆罗门，于色不如实知，色集不如实知，色灭不如实知，色灭道迹不如实知故，输屡那，当知此沙门、婆罗门，不堪能断色。如是沙门、婆罗门，于受、想、行、识不如实知，识集不如实知，识灭不如实知，识灭道迹不如实知故，不堪能断识。输屡那，若沙门、婆罗门，于色如实知，色集如实知，色灭如实知，色灭道迹如实知故，输屡那，当知此沙门、婆罗门，堪能断色。如是输屡那，若沙门、婆罗门，于受、想、行、识如实知，识集如实知，识灭如实知，识灭道迹如实知故，输屡那，当知此沙门、婆罗门，堪能断识。输屡那，于意云何？色为常、为无常耶？”
    答言：“无常。”
    又问：“若无常者，是苦耶？”
    答言：“是苦。”
    舍利弗言：“若色无常、苦者，是变易法。圣弟子宁于中见色是我、异我、相在不？”
    答言：“不也。”
    “输屡那，如是受、想、行、识，为常、为无常耶？”
    答言：“无常。”
    又问：“若无常者，是苦耶？”
    答言：“是苦。”
    又问：“若无常、苦者，是变易法。圣弟子宁于中见识是我、异我、相在不？”
    答曰：“不也。”
    输屡那，“当知色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑，若远若近，于一切色不是我、不异我、不相在，是名如实知。输屡那，圣弟子于色生厌、离欲、解脱，解脱生老病死、忧悲苦恼。如是受、想、行、识，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切识不是我、不异我、不相在，是名如实知。输屡那，圣弟子于识生厌、离欲、解脱，解脱生老病死、忧悲苦恼。”
    时输屡那闻舍利弗所说，欢喜踊跃，作礼而去。

（三二）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者舍利弗在耆阇崛山。
    时有长者子名输屡那，日日游行，到耆阇崛山，诣舍利弗所，头面礼足，却坐一面。
    时舍利弗告输屡那：“若沙门、婆罗门，于色不如实知，色集不如实知，色灭不如实知，色味不如实知，色患不如实知，色离不如实知故，不堪能超越色。若沙门、婆罗门，于受、想、行、识不如实知，识集不如实知，识灭不如实知，识味不如实知，识患不如实知，识离不如实知故，此沙门、婆罗门不堪能超越识。若沙门、婆罗门，于色、色集、色灭、色味、色患、色离如实知，此沙门、婆罗门堪能超越色。若沙门、婆罗门，于受、想、行、识、识集、识灭、识味、识患、识离如实知，此沙门、婆罗门堪能超越识。输屡那，于汝意云何？色为常、为无常耶？”
    答言：“无常。”
    “无常者，为苦耶？”
    答言：“是苦。”
    “输屡那，若色无常、苦，是变易法。圣弟子于中宁有是我、异我、相在不？”
    答言：“不也。”
    “输屡那，于汝意云何？如是受、想、行、识，为常、为无常？”
    答言：“无常。”
    “若无常者，是苦耶？”
    答言：“是苦。”
    “输屡那，若无常、苦，是变易法。圣弟子于中宁有是我、异我、相在不？”
    答言：“不也。”
    “输屡那，当知色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，于一切色不是我、不异我、不相在，是名如实知。输屡那，受、想、行、识，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，于一切识不是我、不异我、不相在，是名如实知。输屡那，圣弟子于此五受阴，正观非我、非我所。如是正观，于诸世间无所摄受；无摄受者，则无所著；无所著者，自得涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    时长者子输屡那闻舍利弗所说，欢喜踊跃，作礼而去。

·清凉书屋标点本·
2005.11


杂阿含经卷第二

（三三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“色非是我，若色是我者，不应于色病苦生，亦不应于色欲令如是、不令如是。以色无我故，于色有病有苦生，亦得于色欲令如是、不令如是。受、想、行、识，亦复如是。比丘，于意云何？色为是常、为无常耶？”
    比丘白佛：“无常，世尊。”
    “比丘，若无常者，是苦不？”
    比丘白佛：“是苦，世尊。”
    “若无常、苦，是变易法。多闻圣弟子于中宁见有我、异我、相在不？”
    比丘白佛：“不也，世尊。”
    “受、想、行、识，亦复如是。是故比丘，诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、不异我、不相在，如是观察。受、想、行、识，亦复如是。比丘，多闻圣弟子于此五受阴非我、非我所，如实观察。如实观察已，于诸世间都无所取，无所取故无所著，无所著故自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三四）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告余五比丘：“色非有我，若色有我者，于色不应病苦生，亦不得于色欲令如是、不令如是。以色无我故。于色有病有苦生，亦得于色欲令如是、不令如是。受、想、行、识，亦复如是。比丘，于意云何？色为是常、为无常耶？”
    比丘白佛：“无常，世尊。”
    “比丘，若无常者，是苦耶？”
    比丘白佛：“是苦，世尊。”
    “比丘，若无常、苦，是变易法。多闻圣弟子宁于中见是我、异我、相在不？”
    比丘白佛：“不也，世尊。”
    “受、想、行、识，亦复如是。是故比丘，诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、非我所，如实观察。受、想、行、识，亦复如是。比丘，多闻圣弟子于此五受阴，见非我、非我所，如是观察，于诸世间都无所取，无所取故无所著，无所著故自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，余五比丘不起诸漏，心得解脱。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三五）

    如是我闻。一时佛住支提竹园精舍。
    尔时有三正士出家未久，所谓尊者阿[少/兔]律陀、尊者难提、尊者金毗罗。
    尔时世尊知彼心中所念，而为教诫：“比丘，此心、此意、此识，当思惟此，莫思惟此，断此欲，断此色，身作证具足住。比丘，宁有色，若常、不变易、正住不？”
    比丘白佛：“不也，世尊。”
    佛告比丘：“善哉善哉！色是无常、变易之法，厌、离欲、灭、寂、没。如是色从本以来，一切无常、苦、变易法。如是知已，缘彼色生诸漏害、炽然、忧恼，皆悉断灭；断灭已，无所著；无所著已，安乐住；安乐住已，得般涅槃。受、想、行、识，亦复如是。”
    佛说此经时，三正士不起诸漏，心得解脱。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三六）

    如是我闻。一时佛住摩偷罗国跋提河侧伞盖庵罗树园。
    尔时世尊告诸比丘：“住于自洲，住于自依，住于法洲、法依，不异洲，不异依。比丘，当正观察，住自洲、自依、法洲、法依、不异洲、不异依，何因生忧悲恼苦？云何有四？何故何系著？云何自观察未生忧悲恼苦而生，已生忧悲恼苦生长增广？”
    诸比丘白佛：“世尊法根、法眼、法依，唯愿为说，诸比丘闻已，当如说奉行。”
    佛告比丘：“谛听善思，当为汝说。比丘，有色，因色系著色，自观察未生忧悲恼苦而生，已生而复增长广大。受、想、行、识，亦复如是。比丘，颇有色，常、恒、不变易、正住耶？”
    答言：“不也，世尊。”
    佛告比丘：“善哉善哉！比丘，色是无常。若善男子知色是无常已，变易、离欲、灭、寂静、没。从本以来，一切色无常、苦、变易法知已，若色因缘生忧悲恼苦断。彼断已，无所著；不著故，安隐乐住；安隐乐住已，名为涅槃。受、想、行、识，亦复如是。”
    佛说此经时，十六比丘不生诸漏，心得解脱。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

竹园毗舍离，清净正观察，
无常苦非我，五三与十六。

（三七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我不与世间诤，世间与我诤。所以者何？比丘，若如法语者，不与世间诤。世间智者言有，我亦言有。云何为世间智者言有，我亦言有？比丘，色无常、苦、变易法，世间智者言有，我亦言有。如是受、想、行、识，无常、苦、变易法，世间智者言有，我亦言有。世间智者言无，我亦言无。谓色是常、恒、不变易、正住者，世间智者言无，我亦言无。受、想、行、识，常、恒、不变易、正住者，世间智者言无，我亦言无。是名世间智者言无，我亦言无。比丘，有世间世间法，我亦自知自觉，为人分别演说显示。世间盲无目者，不知不见，非我咎也。诸比丘，云何为世间世间法，我自知我自觉，为人演说分别显示，盲无目者不知不见？是比丘，色无常、苦、变易法，是名世间世间法。如是受、想、行、识，无常、苦，是世间世间法。比丘，此是世间世间法，我自知自觉，为人分别演说显示，盲无目者不知不见。我于彼盲无目不知不见者，其如之何！”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“世人为卑下业，种种求财活命，而得巨富，世人皆知。如世人之所知，我亦如是说。所以者何？莫令我异于世人。诸比丘，譬如一器，有一处人名为揵茨，有名钵，有名匕匕罗，有名遮留，有名毗悉多，有名婆阇那，有名萨牢。如彼彼所知，我亦如是说。所以者何？莫令我异于世人故。如是比丘，有世间法，我自知自觉，为人分别演说显示，知见而说。世间盲无目者，不知不见。世间盲无目者不知不见，我其如之何？比丘，云何世间世间法，我自知自觉，乃至不知不见？色无常、苦、变易法，是为世间世间法。受、想、行、识，无常、苦、变易法，是世间世间法。比丘，是名世间世间法，我自知自见，乃至盲无目者不知不见，其如之何！”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五种种子。何等为五？谓根种子、茎种子、节种子、自落种子、实种子。此五种子不断、不坏、不腐、不中风，新熟坚实，有地界而无水界，彼种子不生长增广。若彼种新熟坚实，不断、不坏、不中风，有水界而无地界，彼种子亦不生长增广。若彼种子新熟坚实，不断、不坏、不腐、不中风，有地、水界，彼种子生长增广。
    “比丘，彼五种子者，譬取阴俱识。地界者，譬四识住。水界者，譬贪喜四取攀缘识住。何等为四？于色中识住，攀缘色，喜贪润泽，生长增广；于受、想、行中识住，攀缘受、想、行，贪喜润泽，生长增广。比丘，识于中若来、若去、若住、若没、若生长增广。比丘，若离色、受、想、行，识有若来、若去、若住、若生者，彼但有言数，问已不知，增益生痴，以非境界故。色界离贪，离贪已，于色封滞，意生缚断；于色封滞，意生缚断已，攀缘断；攀缘断已，识无住处，不复生长增广。受、想、行界离贪，离贪已，于行封滞，意生触断；于行封滞，意生触断已，攀缘断；攀缘断已，彼识无所住，不复生长增广。不生长故不作行，不作行已住，住已知足，知足已解脱。解脱已，于诸世间都无所取、无所著；无所取、无所著已，自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。我说彼识不至东西南北、四维、上下，无所至趣，唯见法，欲入涅槃、寂灭、清凉、清净、真实。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“封滞者不解脱，不封滞则解脱。云何封滞不解脱？比丘，攀缘四取阴识住。云何为四？色封滞识住，受、想、行封滞识住，乃至非境界故，是名封滞故不解脱。云何不封滞则解脱？于色界离贪，受、想、行界离贪，乃至清凉、真实，是则不封滞则解脱。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五受阴，色受阴，受、想、行、识受阴。我于此五受阴，五种如实知：色如实知，色集、色味、色患、色离如实知；如是受、想、行、识如实知，识集、识味、识患、识离如实知。
    “云何色如实知？诸所有色，一切四大及四大造色，是名色，如是色如实知。云何色集如实知？于色喜爱，是名色集，如是色集如实知。云何色味如实知？谓色因缘生喜乐，是名色味，如是色味如实知。云何色患如实知？若色无常、苦、变易法，是名色患，如是色患如实知。云何色离如实知？若于色调伏欲贪、断欲贪、越欲贪，是名色离，如是色离如实知。
    “云何受如实知？有六受身，眼触生受，耳、鼻、舌、身、意触生受，是名受，如是受如实知。云何受集如实知？触集是受集，如是受集如实知。云何受味如实知？缘六受生喜乐，是名受味，如是受味如实知。云何受患如实知？若受无常、苦、变易法，是名受患，如是受患如实知。云何受离如实知？于受调伏欲贪、断欲贪、越欲贪，是名受离，如是受离如实知。
    “云何想如实知？谓六想身。云何为六？谓眼触生想，耳、鼻、舌、身、意触生想，是名想，如是想如实知。云何想集如实知？谓触集是想集，如是想集如实知。云何想味如实知？想因缘生喜乐，是名想味，如是想味如实知。云何想患如实知？谓想无常、苦、变易法，是名想患，如是想患如实知。云何想离如实知？若于想调伏欲贪、断欲贪、越欲贪，是名想离，如是想离如实知。
    “云何行如实知？谓六思身，眼触生思，耳、鼻、舌、身、意触生思，是名为行，如是行如实知。云何行集如实知？触集是行集，如是行集如实知。云何行味如实知？谓行因缘生喜乐，是名行味，如是行味如实知。云何行患如实知？若行无常、苦、变易法，是名行患，如是行患如实知。云何行离如实知？若于行调伏欲贪、断欲贪、越欲贪，是名行离，如是行离如实知。
    “云何识如实知？谓六识身，眼识身，耳、鼻、舌、身、意识身，是名为识身，如是识身如实知。云何识集如实知？谓名色集，是名识集，如是识集如实知。云何识味如实知？识因缘生喜乐，是名识味，如是识味如实知。云何识患如实知？若识无常、苦、变易法，是名识患，如是识患如实知。云何识离如实知？谓于识调伏欲贪、断欲贪、越欲贪，是名识离，如是识离如实知。
    “比丘，若沙门、婆罗门，于色如是知、如是见；如是知、如是见，离欲向，是名正向，若正向者，我说彼入。受、想、行、识，亦复如是。若沙门、婆罗门，于色如实知、如实见，于色生厌、离欲，不起诸漏，心得解脱；若心得解脱者，则为纯一；纯一者，则梵行立；梵行立者，离他自在，是名苦边。受、想、行、识，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有七处善、三种观义，尽于此法得漏尽，得无漏心解脱、慧解脱，现法自知身作证具足住：我生已尽，梵行已立，所作已作，自知不受后有。
    “云何比丘七处善？比丘，如实知色、色集、色灭、色灭道迹、色味、色患、色离如实知。如是受、想、行、识，识集、识灭、识灭道迹、识味、识患、识离如实知。
    “云何色如实知？诸所有色，一切四大及四大造色，是名为色，如是色如实知。云何色集如实知？爱喜是名色集，如是色集如实知。云何色灭如实知？爱喜灭是名色灭，如是色灭如实知。云何色灭道迹如实知？谓八圣道，正见、正志、正语、正业、正命、正方便、正念、正定，是名色灭道迹，如是色灭道迹如实知。云何色味如实知？谓色因缘生喜乐，是名色味，如是色味如实知。云何色患如实知？若色无常、苦、变易法，是名色患，如是色患如实知。云何色离如实知？谓于色调伏欲贪、断欲贪、越欲贪，是名色离，如是色离如实知。
    “云何受如实知？谓六受，眼触生受，耳、鼻、舌、身、意触生受，是名受，如是受如实知。云何受集如实知？触集是受集，如是受集如实知。云何受灭如实知？触灭是受灭，如是受灭如实知。云何受灭道迹如实知？谓八圣道。正见，乃至正定，是名受灭道迹，如是受灭道迹如实知。云何受味如实知？受因缘生喜乐，是名受味，如是受味如实知。云何受患如实知？若受无常、苦、变易法，是名受患，如是受患如实知。云何受离如实知？若于受调伏欲贪、断欲贪、越欲贪，是名受离，如是受离如实知。
    “云何想如实知？谓六想，眼触生想，耳、鼻、舌、身、意触生想，是名为想，如是想如实知。云何想集如实知？触集是想集，如是想集如实知。云何想灭如实知？触灭是想灭，如是想灭如实知。云何想灭道迹如实知？谓八圣道，正见乃至正定，是名想灭道迹，如是想灭道迹如实知。云何想味如实知？想因缘生喜乐，是名想味，如是想味如实知。云何想患如实知？若想无常、苦、变易法，是名想患，如是想患如实知。云何想离如实知？若于想调伏欲贪、断欲贪、越欲贪，是名想离，如是想离如实知。
    “云何行如实知？谓六思身，眼触生思，耳、鼻、舌、身、意触生思，是名为行，如是行如实知。云何行集如实知？触集是行集，如是行集如实知。云何行灭如实知？触灭是行灭，如是行灭如实知。云何行灭道迹如实知？谓八圣道，正见乃至正定，是名行灭道迹，如是行灭道迹如实知。云何行味如实知？行因缘生喜乐，是名行味，如是行味如实知。云何行患如实知？若行无常、苦、变易法，是名行患，如是行患如实知。云何行离如实知？若于行调伏欲贪、断欲贪、越欲贪，是名行离，如是行离如实知。
    “云何识如实知？谓六识身，眼识，耳、鼻、舌、身、意识身，是名为识，如是识如实知。云何识集如实知？名色集是识集，如是识集如实知。云何识灭如实知？名色灭是识灭，如是识灭如实知。云何识灭道迹如实知？谓八圣道，正见乃至正定，是名识灭道迹，如是识灭道迹如实知。云何识味如实知？识因缘生喜乐，是名识味，如是识味如实知。云何识患如实知？若识无常、苦、变易法，是名识患，如是识患如实知。云何识离如实知？若识调伏欲贪、断欲贪、越欲贪，是名识离如实知。比丘，是名七处善。
    “云何三种观义？比丘，若于空闲、树下、露地，观察阴、界、入，正方便思惟其义，是名比丘三种观义。
    “是名比丘七处善、三种观义，尽于此法得漏尽，得无漏心解脱、慧解脱，现法自知作证具足住：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“取故生著，不取则不著。谛听善思，当为汝说。”
    比丘白佛：“唯然受教。”
    佛告比丘：“云何取故生著？愚痴无闻凡夫于色见是我、异我、相在，见色是我、我所而取；取已，彼色若变、若异，心亦随转；心随转已，亦生取著摄受心住；摄受心住故，则生恐怖、障碍、心乱，以取著故。愚痴无闻凡夫于受、想、行、识，见我、异我、相在，见识是我、我所而取；取已，彼识若变、若异，彼心随转；心随转故，则生取著摄受心住；住已，则生恐怖、障碍、心乱，以取著故，是名取著。
    “云何名不取著？多闻圣弟子于色不见我、异我、相在，于色不见我、我所而取；不见我、我所而取已，彼色若变、若异，心不随转；心不随转故，不生取著摄受心住；不摄受住故，则不生恐怖、障碍、心乱，不取著故。如是受、想、行、识，不见我、异我、相在，不见我、我所而取；彼识若变、若异，心不随转；心不随转故，不取著摄受心住；不摄受心住故，心不恐怖、障碍、心乱，以不取著故，是名不取著。是名取著、不取著。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若生则系著，不生则不系著。谛听善思，当为汝说。
    “云何若生则系著？愚痴无闻凡夫于色集、色灭、色味、色患、色离不如实知故，于色爱喜、赞叹、取著，于色是我、我所而取；取已，彼色若变、若异，心随变异；心随变异故，则摄受心住；摄受心住故，则生恐怖、障碍、顾念，以生系著故。受、想、行、识，亦复如是。是名生系著。
    “云何不生不系著？多闻圣弟子，色集、色灭、色味、色患、色离如实知；如实知故，不爱喜、赞叹、取著，不系我、我所而取；以不取故，彼色若变、若异，心不随变异；心不随变异故，心不系著摄受心住；不摄受心住故，心不恐怖、障碍、顾念，以不生不著故。受、想、行、识，亦复如是。是名不生不系著。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五受阴。云何为五？色受阴，受、想、行、识受阴。若诸沙门、婆罗门，见有我者，一切皆于此五受阴见我。诸沙门、婆罗门，见色是我、色异我、我在色、色在我。见受、想、行、识是我、识异我、我在识、识在我。愚痴无闻凡夫，以无明故，见色是我、异我、相在，言我真实不舍；以不舍故，诸根增长；诸根增长已，增诸触。六触入处所触故，愚痴无闻凡夫起苦乐觉，从触入处起。何等为六？谓眼触入处，耳、鼻、舌、身、意触入处。如是比丘，有意界、法界、无明界。愚痴无闻凡夫，无明触故，起有觉、无觉、有无觉、我胜觉、我等觉、我卑觉、我知我见觉，如是知、如是见觉，皆由六触入故。多闻圣弟子，于此六触入处，舍离无明而生明，不生有觉、无觉、有无觉、胜觉、等觉、卑觉、我知我见觉。如是知、如是见已，先所起无明触灭，后明触觉起。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五受阴。云何为五？色受阴，受、想、行、识受阴。若沙门、婆罗门，以宿命智，自识种种宿命，已识、当识、今识，皆于此五受阴，已识、当识、今识。我过去所经，如是色，如是受，如是想，如是行，如是识。若可碍、可分，是名色受阴。相所碍，若手、若石、若杖、若刀、若冷、若暖、若渴、若饥、若蚊虻、诸毒虫、风雨触，是名触碍，是故碍是色受阴；复以此色受阴，无常、苦、变易。诸觉相是受受阴。何所觉？觉苦、觉乐、觉不苦不乐，是故名觉相是受受阴；复以此受受阴，是无常、苦、变易。诸想是想受阴。何所想？少想、多想、无量想，都无所有作无所有想，是故名想受阴；复以此想受阴，是无常、苦、变易法。为作相是行受阴。何所为作？于色为作，于受、想、行、识为作，是故为作相是行受阴；复以此行受阴，是无常、苦、变易法。别知相是识受阴。何所识？识色，识声、香、味、触、法，是故名识受阴；复以此识受阴，是无常、苦、变易法。
    “诸比丘，彼多闻圣弟子，于此色受阴作如是学：我今为现在色所食，过去世已曾为彼色所食，如今现在。复作是念：‘我今为现在色所食，我若复乐著未来色者，当复为彼色所食，如今现在。’作如是知已，不顾过去色，不乐著未来色，于现在色生厌、离欲、灭患、向灭。多闻圣弟子，于此受、想、行、识受阴学：我今现在为现在识所食，于过去世已曾为识所食，如今现在。我今已为现在识所食，若复乐著未来识者，亦当复为彼识所食，如今现在。如是知已，不顾过去识，不乐未来识，于现在识生厌、离欲、灭患、向灭，灭而不增，退而不进，灭而不起，舍而不取。
    “于何灭而不增？色灭而不增，受、想、行、识灭而不增。于何退而不进？色退而不进，受、想、行、识退而不进。于何灭而不起？色灭而不起，受、想、行、识灭而不起。于何舍而不取？色舍而不取，受、想、行、识舍而不取。灭而不增，寂灭而住。退而不进，寂退而住。灭而不起，寂灭而住。舍而不取，不生系著。不系著已，自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经时，众多比丘不起诸漏，心得解脱。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

我卑下种子，封滞五转七，
二系著及觉，三世阴世食。

（四七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“信心善男子应作是念：我应随顺法，我当于色多修厌离住，于受、想、行、识多修厌离住。信心善男子即于色多修厌离住，于受、想、行、识多修厌离住，故于色得厌，于受、想、行、识得厌。厌已，离欲解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“信心善男子正信非家出家，自念：我应随顺法，于色当多修厌住，于受、想、行、识多修厌住。信心善男子正信非家出家，于色多修厌住，于受、想、行、识多修厌住已，于色得离，于受、想、行、识得离。我说是等，悉离一切生老病死、忧悲恼苦。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告尊者阿难曰：“若信心长者、长者子来问汝言：‘于何等法知其生灭？’汝当云何答乎？”
    阿难白佛：“世尊，若有长者、长者子来问我者，我当答言：‘知色是生灭法，知受、想、行、识是生灭法。’世尊，若长者、长者子如是问者，我当如是答。”
    佛告阿难：“善哉善哉！应如是答。所以者何？色是生灭法，受、想、行、识是生灭法。知色是生灭法者，名为知色。知受、想、行、识是生灭法者，名为知识。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告尊者阿难曰：“若有诸外道出家来问汝言：‘阿难，世尊何故教人修诸梵行？’如是问者，云何答乎？”
    阿难白佛：“世尊，若外道出家来问我言：‘阿难，世尊何故教人修诸梵行’者，我当答言：‘为于色修厌、离欲、灭尽、解脱、不生故，世尊教人修诸梵行。为于受、想、行、识，修厌、离欲、灭尽、解脱、不生故，教人修诸梵行。’世尊，若有外道出家作如是问者，我当作如是答。”
    佛告阿难：“善哉善哉！应如是答。所以者何？我实为于色修厌、离欲、灭尽、解脱、不生故，教人修诸梵行。于受、想、行、识，修厌、离欲、灭尽、解脱、不生故，教人修诸梵行。”
    佛说此经已，尊者阿难闻佛所说，欢喜奉行。

（五一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今为汝说坏、不坏法，谛听善思，当为汝说。诸比丘，色是坏法，彼色灭，涅槃是不坏法。受、想、行、识是坏法，彼识灭，涅槃是不坏法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五二）

    郁低迦修多罗，如《增一阿含经》四法中说。

（五三）

    如是我闻。一时佛在拘萨罗国人间游行，于萨罗聚落村北申恕林中住。
    尔时聚落主大姓婆罗门，闻沙门释种子，于释迦大姓剃除须发，着袈裟衣，正信非家，出家学道，成无上等正觉，于此拘萨罗国人间游行，到此萨罗聚落村北申恕林中住。又彼沙门瞿昙，如是色貌、名称、真实功德，天人赞叹，闻于八方，为如来、应、等正觉、明行足、善逝、世间解、无上士、调御丈夫、天人师、佛、世尊，于诸世间诸天、魔、梵、沙门、婆罗门中，大智能自证知：我生已尽，梵行已立，所作已作，自知不受后有。为世说法，初、中、后善，善义善味，纯一满净，梵行清白，演说妙法。“善哉应见！善哉应往！善应敬事！”作是念已，即便严驾，多将翼从，执持金瓶、金杖、伞盖，往诣佛所，恭敬奉事。到于林口，下车步进，至世尊所，问讯安否，却坐一面，白世尊曰：“沙门瞿昙，何论何说？”
    佛告婆罗门：“我论因、说因。”
    又白佛言：“云何论因？云何说因？”
    佛告婆罗门：“有因有缘集世间，有因有缘世间集。有因有缘灭世间，有因有缘世间灭。”
    婆罗门白佛言：“世尊，云何为有因有缘集世间，有因有缘世间集？”
    佛告婆罗门：“愚痴无闻凡夫，色集、色灭、色味、色患、色离，不如实知。不如实知故，爱乐于色，赞叹于色，染著心住。彼于色爱乐故取，取缘有，有缘生，生缘老死、忧悲恼苦，是则大苦聚集。受、想、行、识，亦复如是。婆罗门，是名有因有缘集世间，有因有缘世间集。”
    婆罗门白佛言：“云何为有因有缘灭世间，有因有缘世间灭？”
    佛告婆罗门：“多闻圣弟子，于色集、色灭、色味、色患、色离如实知；如实知已，于彼色不爱乐、不赞叹、不染著、不留住；不爱乐、不留住故，色爱则灭，爱灭则取灭，取灭则有灭，有灭则生灭，生灭则老死、忧悲恼苦灭。受、想、行、识，亦复如是。婆罗门，是名有因有缘灭世间，是名有因有缘世间灭。婆罗门，是名论因，是名说因。”
    婆罗门白佛言：“瞿昙！如是论因，如是说因。世间多事，今请辞还。”
    佛告婆罗门：“宜知是时。”
    佛说此经已，诸婆罗门闻佛所说，欢喜随喜，礼足而去。

（五四）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    彼时毗迦多鲁迦聚落有婆罗门，来诣佛所，恭敬问讯，却坐一面，白佛言：“瞿昙，我有年少弟子，知天文、族姓，为诸大众占相吉凶，言有必有，言无必无，言成必成，言坏必坏。瞿昙，于意云何？”
    佛告婆罗门：“且置汝年少弟子知天文、族姓，我今问汝，随汝意答。婆罗门，于意云何，色本无种耶？”
    答曰：“如是，世尊。”
    “受、想、行、识，本无种耶？”
    答曰：“如是，世尊。”
    佛告婆罗门：“汝言我年少弟子知天文、族姓，为诸大众作如是说，言有必有，言无必无。知见非不实耶？”
    婆罗门白佛：“如是，世尊。”
    佛告婆罗门：“于意云何？颇有色常住百岁耶，为异生、异灭耶？受、想、行、识常住百岁耶，异生、异灭耶？
    答曰：“如是，世尊。”
    佛告婆罗门：“于意云何？汝年少弟子知天文、族姓，为大众说，成者不坏。知见非不异耶？”
    答曰：“如是，世尊。”
    佛告婆罗门：“于意云何？此法、彼法，此说、彼说，何者为胜？”
    婆罗门白佛言：“世尊，此如法说，如佛所说、显现开发。譬如有人溺水能救，获泅能救，迷方示路，暗惠明灯。世尊今日善说胜法，亦复如是显现开发。”
    佛说此经已，毗迦多鲁迦婆罗门闻佛所说，欢喜随喜，即从座起，礼足而去。

（五五）

    如是我闻。一时佛在波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“我今当说阴及受阴。云何为阴？若所有诸色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切总说色阴；随诸所有受、想、行、识，亦复如是，彼一切总说受、想、行、识阴，是名为阴。云何为受阴？若色是有漏、是取，若彼色过去、未来、现在，生贪欲、瞋恚、愚痴及余种种上烦恼心法；受、想、行、识，亦复如是，是名受阴。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五六）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“我今当说有漏、无漏法。若色有漏、是取，彼色能生爱、恚；如是受、想、行、识有漏、是取，彼识能生爱、恚，是名有漏法。云何无漏法？诸所有色无漏、非受，彼色若过去、未来、现在，彼色不生爱、恚；如是受、想、行、识无漏、非受，彼识若过去、未来、现在，不生爱、恚，是名无漏法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

二信二阿难，坏法郁低迦，
萨罗及世间，除漏无漏法。

（五七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊着衣持钵，入舍卫城乞食还，持衣钵，不语众，不告侍者，独一无二，于西方国土人间游行。
    时安陀林中有一比丘，遥见世尊不语众，不告侍者，独一无二。见已进诣尊者阿难所，白阿难言：“尊者，当知世尊不语众，不告侍者，独一无二而出游行。”
    尔时阿难语彼比丘：“若使世尊不语众，不告侍者，独一无二而出游行，不应随从。所以者何？今日世尊欲住寂灭，少事故。”
    尔时世尊游行，北至半阇国波陀聚落，于人所守护林中，住一跋陀萨罗树下。
    时有众多比丘诣阿难所，语阿难言：“今闻世尊住在何所？”
    阿难答曰：“我闻世尊北至半阇国波陀聚落，人所守护林中，跋陀萨罗树下。”
    时诸比丘语阿难曰：“尊者当知，我等不见世尊已久，若不惮劳者，可共往诣世尊，哀愍故。”
    阿难知时，默然而许。
    尔时尊者阿难与众多比丘，夜过晨朝，着衣持钵，入舍卫城乞食。乞食已，还精舍，举卧具，持衣钵，出至西方人间游行，北至半阇国波陀聚落，人守护林中。时尊者阿难与众多比丘，置衣钵，洗足已，诣世尊所，头面礼足，于一面坐。
    尔时世尊为众多比丘说法，示教利喜。
    尔时座中有一比丘作是念：“云何知、云何见，疾得漏尽？”
    尔时世尊知彼比丘心之所念，告诸比丘：“若有比丘于此座中作是念：云何知、云何见，疾得漏尽者。我已说法言：‘当善观察诸阴，所谓四念处、四正勤、四如意足、五根、五力、七觉分、八圣道分。’我已说如是法，观察诸阴。而今犹有善男子不勤欲作、不勤乐、不勤念、不勤信，而自慢惰，不能增进得尽诸漏。若复善男子于我所说法，观察诸阴，勤欲、勤乐、勤念、勤信，彼能疾得尽诸漏。
    “愚痴无闻凡夫，于色见是我，若见我者，是名为行。彼行何因、何集、何生、何转？无明触生爱，缘爱起彼行。彼爱何因、何集、何生、何转？彼爱受因、受集、受生、受转。彼受何因、何集、何生、何转？彼受触因、触集、触生、触转。彼触何因、何集、何生、何转？谓彼触六入处因、六入处集、六入处生、六入处转。彼六入处，无常、有为、心缘起法；彼触、受、爱、行，亦无常、有为、心缘起法。如是观者，而见色是我；不见色是我，而见色是我所；不见色是我所，而见色在我；不见色在我，而见我在色。不见我在色，而见受是我；不见受是我，而见受是我所；不见受是我所，而见受在我；不见受在我，而见我在受。不见我在受，而见想是我；不见想是我，而见想是我所；不见想是我所，而见想在我；不见想在我，而见我在想。不见我在想，而见行是我；不见行是我，而见行是我所；不见行是我所，而见行在我；不见行在我，而见我在行。不见我在行，而见识是我；不见识是我，而见识是我所；不见识是我所，而见识在我；不见识在我，而见我在识。不见我在识，复作断见、坏有见；不作断见、坏有见，而不离我慢；不离我慢者，而复见我，见我者即是行。彼行何因、何集、何生、何转？如前所说，乃至我慢。作如是知，如是见者，疾得漏尽。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五八）

    如是我闻。一时佛住舍卫国东园鹿母讲堂。
    尔时世尊于晡时从禅觉，于诸比丘前敷座而坐，告诸比丘：“有五受阴。云何为五？谓色受阴，受、想、行、识受阴。”
    时有一比丘从座起，整衣服，偏袒右肩，右膝着地，合掌白佛言：“世尊，此五受阴，色受阴、受、想、行、识受阴耶？”
    佛告比丘：“还坐而问，当为汝说。”
    时彼比丘为佛作礼，还复本坐，白佛言：“世尊，此五受阴，以何为根，以何集，以何生，以何触？”
    佛告比丘：“此五受阴，欲为根，欲集、欲生、欲触。”
    时彼比丘闻佛所说，欢喜随喜，而白佛言：“世尊为说五阴即受，善哉所说！今当更问。世尊，阴即受，为五阴异受耶？”
    佛告比丘：“非五阴即受，亦非五阴异受。能于彼有欲贪者，是五受阴。”
    比丘白佛：“善哉世尊，欢喜随喜！今复更问，世尊，有二阴相关耶？”
    佛告比丘：“如是如是。犹若有一人如是思惟：‘我于未来得如是色、如是受、如是想、如是行、如是识。’是名比丘阴阴相关也。”
    比丘白佛：“善哉所说，欢喜随喜！更有所问。世尊，云何名阴？”
    佛告比丘：“诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切总说阴，是名为阴。受、想、行、识，亦复如是。如是比丘，是名为阴。”
    比丘白佛：“善哉所说，欢喜随喜！更有所问。世尊，何因何缘名为色阴？何因何缘名受、想、行、识阴？”
    佛告比丘：“四大因、四大缘，是名色阴。所以者何？诸所有色阴，彼一切悉皆四大缘、四大造故。触因、触缘，生受、想、行，是故名受、想、行阴。所以者何？若所有受、想、行，彼一切触缘故。名色因、名色缘，是故名为识阴。所以者何？若所有识，彼一切名色缘故。”
    比丘白佛：“善哉所说，欢喜随喜！更有所问。云何色味，云何色患，云何色离？云何受、想、行、识味，云何识患，云何识离？”
    佛告比丘：“缘色生喜乐，是名色味。若色无常、苦、变易法，是名色患。若于色调伏欲贪、断欲贪、越欲贪，是名色离。若缘受、想、行、识生喜乐，是名识味。受、想、行、识，无常、苦、变易法，是名识患。于受、想、行、识，调伏欲贪、断欲贪、越欲贪，是名识离。”
    比丘白佛：“善哉所说，欢喜随喜！更有所问。世尊，云何生我慢？”
    佛告比丘：“愚痴无闻凡夫，于色见我、异我、相在，于受、想、行、识见我、异我、相在，于此生我慢。”
    比丘白佛：“善哉所说，欢喜随喜！更有所问。世尊，云何得无我慢？”
    佛告比丘：“多闻圣弟子，不于色见我、异我、相在，不于受、想、行、识见我、异我、相在。”
    比丘白佛：“善哉所说！更有所问。何所知、何所见，疾得漏尽？”
    佛告比丘：“诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、不异我、不相在。受、想、行、识，亦复如是。比丘，如是知，如是见，疾得漏尽。”
    尔时会中复有异比丘，钝根无知，在无明壳，起恶邪见，而作是念：“若无我者，作无我业，于未来世，谁当受报？”
    尔时世尊知彼比丘心之所念，告诸比丘：“于此众中，若有愚痴人，无智无明，而作是念：‘若色无我，受、想、行、识无我。作无我业，谁当受报？’如是所疑，先以解释。彼云何比丘，色为常耶，为非常耶？”
    答言：“无常，世尊。”
    “若无常者，是苦耶？”
    答言：“是苦，世尊。”
    “若无常、苦，是变易法。多闻圣弟子于中宁见是我、异我、相在不？”
    答言：“不也，世尊。”
    “受、想、行、识，亦复如是。是故比丘，若所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、非我所。如是见者，是为正见。受、想、行、识，亦复如是。多闻圣弟子如是观者，便修厌，厌已离欲，离欲已解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经时，众多比丘不起诸漏，心得解脱。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

阴根阴即受，二阴共相关，
名字因二味，我慢疾漏尽。


杂阿含经卷第三

（五九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五受阴。云何为五？色受阴，受、想、行、识受阴。观此五受阴是生灭法，所谓此色、此色集、此色灭；此受、想、行、识，此识集、此识灭。云何色集，云何色灭？云何受、想、行、识集，云何受、想、行、识灭？爱喜集是色集，爱喜灭是色灭。触集是受、想、行集，触灭是受、想、行灭。名色集是识集，名色灭是识灭。比丘，如是色集、色灭，是为色集、色灭。如是受、想、行、识集，受、想、行、识灭，是为受、想、行、识集，受、想、行、识灭。”
    佛说此经已，时诸比丘闻佛所说，欢喜奉行。

（六○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五受阴。何等为五？所谓色受阴，受、想、行、识受阴。善哉比丘！不乐于色，不赞叹色，不取于色，不著于色。善哉比丘！不乐于受、想、行、识，不赞叹识，不取于识，不著于识。所以者何？若比丘不乐于色，不赞叹色，不取于色，不著于色，则于色不乐，心得解脱。如是受、想、行、识，不乐于识，不赞叹识，不取于识，不著于识，则于识不乐，心得解脱。若比丘不乐于色，心得解脱。如是受、想、行、识不乐，心得解脱。不灭不生，平等舍住，正念正智。彼比丘如是知、如是见者，前际俱见，永尽无余；前际俱见，永尽无余已，后际俱见，亦永尽无余；后际俱见，永尽无余已，前后际俱见，永尽无余，无所封著；无所封著者，于诸世间都无所取；无所取者，亦无所求；无所求者，自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，时诸比丘闻佛所说，欢喜奉行。

（六一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五受阴。何等为五？谓色受阴，受、想、行、识受阴。云何色受阴？所有色，彼一切四大及四大所造色，是名为色受阴。复次彼色是无常、苦、变易之法。若彼色受阴永断无余，究竟舍离、灭尽、离欲、寂没，余色受阴更不相续、不起、不出，是名为妙，是名寂静，是名舍离一切有余、爱尽、无欲、灭尽、涅槃。云何受受阴？谓六受身。何等为六？谓眼触生受，耳、鼻、舌、身、意触生受，是名受受阴。复次彼受受阴无常、苦、变易之法，乃至灭尽、涅槃。云何想受阴？谓六想身。何等为六？谓眼触生想，乃至意触生想，是名想受阴。复次彼想受阴无常、苦、变易之法，乃至灭尽、涅槃。云何行受阴？谓六思身。何等为六？谓眼触生思，乃至意触生思，是名行受阴。复次彼行受阴无常、苦、变易之法，乃至灭尽、涅槃。云何识受阴？谓六识身。何等为六？谓眼识身，乃至意识身，是名识受阴。复次彼识受阴是无常、苦、变易之法，乃至灭尽、涅槃。
    “比丘，若于此法以智慧思惟、观察、分别、忍，是名随信行，超升离生，越凡夫地，未得须陀洹果，中间不死，必得须陀洹果。比丘，若于此法增上智慧思惟、观察、忍，是名随法行，超升离生，越凡夫地，未得须陀洹果，中间不死，必得须陀洹果。比丘，于此法如实正慧等见，三结尽断知，谓身见、戒取、疑。比丘，是名须陀洹果，不堕恶道，必定正趣三菩提，七有天人往生，然后究竟苦边。比丘，若于此法如实正慧等见，不起心漏，名阿罗汉，诸漏已尽，所作已作，舍离重担，逮得己利，尽诸有结，正智心得解脱。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五受阴，谓色受阴，受、想、行、识受阴。愚痴无闻凡夫无慧无明，于五受阴生我见系著使，心系著而生贪欲。比丘，多闻圣弟子有慧有明，于此五受阴，不为见我系著使，心结缚而起贪欲。
    “云何愚痴无闻凡夫，无慧无明，于五受阴见我系著使，心结缚而生贪欲？比丘，愚痴无闻凡夫无慧无明，见色是我、异我、相在。如是受、想、行、识，是我、异我、相在。如是愚痴无闻凡夫，无慧无明，于五受阴说我系著使，心结缚而生贪欲。
    “比丘，云何圣弟子有慧有明，不说我系著使，结缚心而生贪欲？圣弟子不见色是我、异我、相在。如是受、想、行、识，不见是我、异我、相在。如是多闻圣弟子有慧有明，于五受阴不见我系著使，结缚心而生贪欲。若所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切正观皆悉无常。如是受、想、行、识，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切正观皆悉无常。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五受阴，谓色受阴，受、想、行、识受阴。比丘，若沙门、婆罗门计有我，一切皆于此五受阴计有我。何等为五？诸沙门、婆罗门，于色见是我、异我、相在；如是受、想、行、识，见是我、异我、相在。如是愚痴无闻凡夫计我，无明分别。如是观，不离我所；不离我所者，入于诸根；入于诸根已，而生于触；六触入所触，愚痴无闻凡夫生苦乐，从是生此等及余，谓六触身。云何为六？谓眼触入处，耳、鼻、舌、身、意触入处。比丘，有意界、法界、无明界。无明触所触，愚痴无闻凡夫言有、言无、言有无、言非有非无、言我最胜、言我相似、我知、我见。复次比丘，多闻圣弟子住六触入处，而能厌离无明，能生于明。彼于无明离欲而生于明，不有、不无、非有无、非不有无、非有我胜、非有我劣、非有我相似、我知、我见。作如是知、如是见已，所起前无明触灭，后明触集起。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（六四）

    如是我闻。一时佛住舍卫国东园鹿子母讲堂。
    尔时世尊晡时从禅起，出讲堂，于堂阴中大众前敷座而坐。尔时世尊叹优陀那偈：

“法无有吾我，亦复无我所，
我既非当有，我所何由生？
比丘解脱此，则断下分结。”

    时有一比丘从座起，偏袒右肩，右膝着地，合掌白佛言：“世尊，云何无吾我，亦无有我所，我既非当有，我所何由生，比丘解脱此，则断下分结？”
    佛告比丘：“愚痴无闻凡夫计色是我、异我、相在，受、想、行、识是我、异我、相在。多闻圣弟子不见色是我、异我、相在，不见受、想、行、识是我、异我、相在，亦非知者，亦非见者。此色是无常，受、想、行、识是无常。色是苦，受、想、行、识是苦。色是无我，受、想、行、识是无我。此色非当有，受、想、行、识非当有。此色坏有，受、想、行、识坏有。故非我、非我所，我、我所非当有，如是解脱者，则断五下分结。”
    时彼比丘白佛言：“世尊，断五下分结已，云何漏尽，无漏心解脱、慧解脱，现法自知作证具足住：我生已尽，梵行已立，所作已作，自知不受后有？”
    佛告比丘：“愚痴凡夫、无闻众生，于无畏处而生恐畏。愚痴凡夫、无闻众生，怖畏无我、无我所，二俱非当生，攀缘四识住。何等为四？谓色识住、色攀缘、色爱乐、增进、广大、生长。于受、想、行识住，攀缘、爱乐、增进、广大、生长。比丘，识于此处，若来、若去、若住、若起、若灭，增进、广大、生长。若作是说：更有异法，识若来、若去、若住、若起、若灭、若增进、广大、生长者，但有言说，问已不知，增益生痴，以非境界故。所以者何？比丘，离色界贪已，于色意生缚亦断；于色意生缚断已，识攀缘亦断，识不复住，无复增进、广大、生长。受、想、行界离贪已，于受、想、行意生缚亦断；受、想、行意生缚断已，攀缘亦断，识无所住，无复增进、广大、生长。识无所住故不增长，不增长故无所为作，无所为作故则住，住故知足，知足故解脱，解脱故于诸世间都无所取，无所取故无所著，无所著故自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。比丘，我说识不住东方、南西北方、四维、上下，除欲见法，涅槃、灭尽、寂静、清凉。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

生灭以不乐，及三种分别，
贪著等观察，是名优陀那。

（六五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“常当修习方便禅思，内寂其心。所以者何？比丘常当修习方便禅思，内寂其心，如实观察。云何如实观察？此是色，此是色集，此是色灭。此是受、想、行、识，此是识集，此是识灭。
    “云何色集，受、想、行、识集？愚痴无闻凡夫，于苦、乐、不苦不乐受，不如实观察此受集、受灭、受味、受患、受离。不如实观察故，于受乐著生取，取缘有，有缘生，生缘老病死、忧悲恼苦，如是纯大苦聚从集而生。是名色集，是名受、想、行、识集。
    “云何色灭，受、想、行、识灭？多闻圣弟子，受诸苦、乐、不苦不乐受，如实观察受集、受灭、受味、受患、受离。如实观察故，于受乐著灭，著灭故取灭，取灭故有灭，有灭故生灭，生灭故老病死、忧悲恼苦灭，如是纯大苦聚皆悉得灭。是名色灭，受、想、行、识灭。
    “是故比丘常当修习方便禅思，内寂其心。比丘禅思住，内寂其心，精勤方便，如实观察。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如观察，如是分别、种种分别、知、广知、种种知、亲近、亲近修习、入、触、证十二经，亦如是广说。

（六六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“常当修习方便禅思，内寂其心。所以者何？修习方便禅思，内寂其心已，如实观察。云何如实观察？如实观察此色、此色集、此色灭；此受、想、行、识，此识集、此识灭。
    “云何色集，云何受、想、行、识集？比丘，愚痴无闻凡夫不如实观察色集、色味、色患、色离故，乐彼色，赞叹、爱著，于未来世色复生。受、想、行、识，亦如是广说。彼色生，受、想、行、识生已，不解脱于色，不解脱于受、想、行、识，我说彼不解脱生老病死、忧悲恼苦纯大苦聚。是名色集，受、想、行、识集。
    “云何色灭，受、想、行、识灭？多闻圣弟子如实观察色集、色灭、色味、色患、色离，如实知故，不乐于色，不赞叹色，不乐著色，亦不生未来色。受、想、行、识，亦如是广说。色不生，受、想、行、识不生故，于色得解脱，于受、想、行、识得解脱，我说彼解脱生老病死、忧悲恼苦纯大苦聚。是名色灭，受、想、行、识灭。是故比丘，常当修习方便禅思，内寂其心，精勤方便，如实观察。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如观察，如是乃至作证十二经，亦应广说。

（六七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“常当修习方便禅思，内寂其心。所以者何？比丘修习方便禅思，内寂其心已，如实观察。云何如实观察？如实知此色、此色集、此色灭；此受、想、行、识，此识集、此识灭。
    “云何色集，受、想、行、识集？愚痴无闻凡夫，不如实知色集、色灭、色味、色患、色离；不如实知故，乐著彼色，赞叹于色；乐著于色、赞叹色故取，取缘有，有缘生，生缘老死、忧悲恼苦，如是纯大苦聚生。是名色集，受、想、行、识集。
    “云何色灭，受、想、行、识灭？多闻圣弟子，如实知色集、色灭、色味、色患、色离；如实知故，不乐著色，不赞叹色；不乐著、赞叹色故，爱乐灭，爱乐灭故取灭，取灭故有灭，有灭故生灭，生灭故老病死、忧悲恼苦灭，如是纯大苦聚灭。多闻圣弟子如实知受、想、行、识，识集、识灭、识味、识患、识离；如实知彼故，不乐著彼识，不赞叹于识；不乐著、赞叹识故，乐爱灭，乐爱灭故取灭，取灭故有灭，有灭故生灭，生灭故老病死、忧悲恼苦灭，如是纯大苦聚灭，皆悉得灭。比丘，是名色灭，受、想、行、识灭。比丘，常当修习方便禅思，内寂其心。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如观察，乃至作证十二经，亦如是广说。

（六八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“常当修习方便禅思，内寂其心，如实观察。云何如实观察？如实知此色、此色集、此色灭；此受、想、行、识，此识集、此识灭。
    “云何色集，受、想、行、识集？缘眼及色，眼识生，三事和合生触，缘触生受，缘受生爱，乃至纯大苦聚生，是名色集。如是缘耳、鼻、舌、身、意，缘意及法生意识，三事和合生触，缘触生受，缘受生爱，如是乃至纯大苦聚生，是名色集，受、想、行、识集。
    “云何色灭，受、想、行、识灭？缘眼及色，眼识生，三事和合生触，触灭则受灭，乃至纯大苦聚灭。如是耳、鼻、舌、身、意，缘意及法，意识生，三事和合生触，触灭则受灭，受灭乃至纯大苦聚灭，是名色灭，受、想、行、识灭。是故比丘，常当修习方便禅思，内寂其心。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如观察，乃至作证十二经，亦如是广说。

受与生及乐，亦说六入处，
一一十二种，禅定三昧经。

（六九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当说有身集趣道及有身集灭道。云何有身集趣道？愚痴无闻凡夫，不如实知色集、色灭、色味、色患、色离；不如实知故，乐色、叹色、著色、住色；乐色、叹色、著色、住色故，爱乐取，缘取有，缘有生，缘生老病死、忧悲苦恼，如是纯大苦聚生。如是受、想、行、识广说，是名有身集趣道。比丘，有身集趣道，当知即是苦集趣道。
    “云何有身集灭道？多闻圣弟子，如实知色、色集、色灭、色味、色患、色离；如实知故，于色不乐、不叹、不著、不住；不乐、不叹、不著、不住故，彼色爱乐灭，爱乐灭则取灭，取灭则有灭，有灭则生灭，生灭则老病死、忧悲苦恼纯大苦聚灭。如色，受、想、行、识亦如是，是名有身灭道迹。有身灭道迹，则是苦灭道迹，是故说有身灭道迹。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如当说，有及当知，亦如是说。

（七○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当说有身苦边、有身集边、有身灭边，谛听善思念之，当为汝说。云何有身苦边？谓五受阴。何等为五？色受阴，受、想、行、识受阴，是名有身苦边。云何有身集边？谓爱当来有，贪喜俱，彼彼乐著，是名有身集边。云何有身灭边？即此爱当来有、贪喜俱、彼彼乐著，无余断、吐、尽、离欲、灭、寂、没，是名有身灭边。是故当说有身苦边、有身集边、有身灭边。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。
    如当说，有及当知，亦如是说。

（七一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当说有身、有身集、有身灭、有身灭道迹，谛听善思，当为汝说。云何有身？谓五受阴。云何为五？色受阴，受、想、行、识受阴，是名有身。云何有身集？当来有爱，贪喜俱，彼彼染著，是名有身集。云何有身灭？当来有爱，贪喜俱，彼彼乐著，无余断、吐、尽、离欲、灭，是名有身灭。云何有身灭道迹？谓八圣道，正见、正志、正语、正业、正命、正方便、正念、正定，是名有身灭道迹。是名当说有身、有身集、有身灭、有身灭道迹。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

    余如是说。差别者：“当知有身，当知断有身集，当知证有身灭，当知修断有身道迹。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如当说，有及当知，亦如是说。

    又复差别者：“比丘知有身，断有身集，证有身灭，修断有身道。是名比丘断爱欲缚、诸结等法，修无间等，究竟苦边。”
    又复差别者：“是名比丘究竟边际，究竟离垢，究竟梵行，纯净上士。”
    又复差别者：“是名比丘阿罗汉尽诸有漏，所作已作，已舍重担，逮得己利，尽诸有结，正智心解脱。”
    又复差别者：“是名比丘断关，度堑，超越境界，脱诸防逻，建圣法幢。”
    又复差别者：“云何断关？谓断五下分结。云何度堑？谓度无明深堑。云何超越境界？谓究竟无始生死。云何脱诸防逻？谓有爱尽。云何建圣法幢？谓我慢尽。”
    又复差别者：“是名比丘断五支，成六支，守护一，依四种，弃舍诸谛，离诸求，净诸觉，身行息，心善解脱，慧善解脱，纯一立梵行无上士。”

其道有三种，实觉亦三种，
有身四种说，罗汉有六种。

（七二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当说所知法、智及智者，谛听善思，当为汝说。云何所知法？谓五受阴。何等为五？色受阴，受、想、行、识受阴，是名所知法。云何为智？调伏贪欲、断贪欲、越贪欲，是名为智。云何智者？阿罗汉是。阿罗汉者，非有他世死、非无他世死、非有无他世死、非非有无他世死，广说无量，诸数永灭。是名说所知法、智及智者。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当说重担、取担、舍担、担者，谛听善思，当为汝说。云何重担？谓五受阴。何等为五？色受阴，受、想、行、识受阴。云何取担？当来有爱，贪喜俱，彼彼乐著。云何舍担？若当来有爱、贪喜俱、彼彼乐著，永断无余，已灭、已吐、尽、离欲、灭、没。云何担者？谓士夫是。士夫者，如是名，如是生，如是姓族，如是食，如是受苦乐，如是长寿，如是久住，如是寿命齐限。是名为重担、取担、舍担、担者。”
    尔时世尊而说偈言：

“已舍于重担，不复应更取，
重任为大苦，舍任为大乐。
当断一切爱，则尽一切行，
晓了有余境，不复转还有。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五受阴。何等为五？色受阴，受、想、行、识受阴。愚痴无闻凡夫，不如实知色、色集、色灭、色味、色患、色离。不如实知故，于色所乐、赞叹、系著住，色缚所缚，内缚所缚，不知根本，不知边际，不知出离。是名愚痴无闻凡夫，以缚生，以缚死，以缚从此世至他世，于彼亦复以缚生，以缚死。是名愚痴无闻凡夫，随魔自在，入魔网中，随魔所化，魔缚所缚，为魔所牵。受、想、行、识，亦复如是。
    “多闻圣弟子如实知色、色集、色灭、色味、色患、色离。如实知故，不贪喜色，不赞叹，不系著住，非色缚所缚，非内缚所缚，知根本，知津济，知出离。是名多闻圣弟子，不随缚生，不随缚死，不随缚从此世至他世，不随魔自在，不入魔手，不随魔所作，非魔所缚，解脱魔缚，离魔所牵。受、想、行、识，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五受阴。何等为五？谓色受阴，比丘于色厌、离欲、灭、不起、解脱，是名如来、应、等正觉；如是受、想、行、识，厌、离欲、灭、不起、解脱，是名如来、应、等正觉。比丘亦于色厌、离欲、灭，名阿罗汉慧解脱；如是受、想、行、识，厌、离欲、灭，名阿罗汉慧解脱。比丘，如来、应、等正觉，阿罗汉慧解脱，有何差别？”
    比丘白佛：“如来为法根、为法眼、为法依，唯愿世尊为诸比丘广说此义，诸比丘闻已，当受奉行。”
    佛告比丘：“谛听善思，当为汝说。如来、应、等正觉，未曾闻法，能自觉法，通达无上菩提。于未来世开觉声闻，而为说法，谓四念处、四正勤、四如意足、五根、五力、七觉、八道。比丘，是名如来、应、等正觉，未得而得，未利而利，知道、分别道、说道、通道，复能成就诸声闻，教授教诫。如是说正顺欣乐善法。是名如来、罗汉差别。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五受阴。何等为五？色受阴，受、想、行、识受阴。汝等比丘当观察于色，观察色已，见有我、异我、相在不？”
    诸比丘白佛言：“不也，世尊。”
    佛告比丘：“善哉善哉！色无我，无我者则无常，无常者则是苦，若苦者彼一切非我、不异我、不相在，当作是观。受、想、行、识，亦复如是。多闻圣弟子，于此五受阴，观察非我、非我所。如是观察已，于世间都无所取，无所取者则无所著，无所著者自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当断色欲贪，欲贪断已，则色断；色断已，得断知；得断知已，则根本断，如截多罗树头，未来不复更生。如是受、想、行、识欲贪断，乃至未来世不复更生。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若色起、住、出，则苦于此起，病于此住，老死于此出。受、想、行、识，亦如是说。比丘，若色灭、息、没，苦于此灭，病于此息，老死于此没。受、想、行、识，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过去、未来色尚无常，况复现在色？多闻圣弟子如是观察已，不顾过去色，不欣未来色，于现在色厌、离欲、灭、寂静。受、想、行、识，亦复如是。比丘，若无过去色者，多闻圣弟子无不顾过去色。以有过去色故，多闻圣弟子不顾过去色。若无未来色者，多闻圣弟子无不欣未来色。以有未来色故，多闻圣弟子不欣未来色。若无现在色者，多闻圣弟子不于现在色生厌、离欲、灭尽向。以有现在色故，多闻圣弟子于现在色生厌、离欲、灭尽向。受、想、行、识，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如无常，苦、空、非我三经，亦如是说。

（八○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当说圣法印，及见清净，谛听善思。若有比丘作是说：我于空三昧未有所得，而起无相、无所有、离慢知见者，莫作是说。所以者何？若于空未得者，而言我得无相、无所有、离慢知见者，无有是处。若有比丘作是说：我得空，能起无相、无所有、离慢知见者，此则善说。所以者何？若得空已，能起无相、无所有、离慢知见者，斯有是处。云何为圣弟子及见清净？”
    比丘白佛：“佛为法根、法眼、法依，唯愿为说，诸比丘闻说法已，如说奉行。”
    佛告比丘：“若比丘于空闲处树下坐，善观色无常、磨灭、离欲之法。如是观察受、想、行、识，无常、磨灭、离欲之法。观察彼阴无常、磨灭、不坚固、变易法，心乐清净解脱，是名为空。如是观者，亦不能离慢知见清净。复有正思惟三昧，观色相断，声、香、味、触、法相断，是名无相。如是观者，犹未离慢知见清净。复有正思惟三昧，观察贪相断，瞋恚、痴相断，是名无所有。如是观者，犹未离慢知见清净。复有正思惟三昧，观察我、我所从何而生？复有思惟观察我、我所，从若见、若闻、若嗅、若尝、若触、若识而生。复作是观察，若因、若缘而生识者，彼识因缘，为常、为无常？复作是思惟，若因、若缘而生识者，彼因彼缘皆悉无常。复次，彼因彼缘皆悉无常，彼所生识云何有常？无常者，是有为行，从缘起，是患法、灭法、离欲法、断知法。是名圣法印，知见清净。是名比丘当说圣法印、知见清净，如是广说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八一）

    如是我闻。一时佛住毗耶离猕猴池侧重阁讲堂。
    尔时有离车名摩诃男，日日游行，往诣佛所。时彼离车作是念：“若我早诣世尊所者，世尊及我知识比丘皆悉禅思。我今当诣七庵罗树阿耆毗外道所。”即往诣彼富兰那迦叶住处。
    时富兰那迦叶外道众主，与五百外道前后围绕，高声嬉戏，论说俗事。时富兰那迦叶，遥见离车摩诃男来，告其眷属，令寂静住：“汝等默然。是离车摩诃男，是沙门瞿昙弟子。此是沙门瞿昙白衣弟子，毗耶离中最为上首，常乐寂静，赞叹寂静。彼所之诣，寂静之众，是故汝等应当寂静。”
    时摩诃男诣彼众富兰那所，与富兰那共相问讯，相慰劳已，却坐一面。时摩诃男语富兰那言：“我闻富兰那为诸弟子说法：‘无因无缘众生有垢，无因无缘众生清净。’世有此论，汝为审有此，为是外人相毁之言，世人所撰？为是法，为非法？颇有世人共论，难问、嫌责以不？”
    富兰那迦叶言：“实有此论，非世妄传。我立此论，是如法论。我说此法，皆是顺法，无有世人来共难问而呵责者。所以者何？摩诃男，我如是见，如是说：无因无缘众生有垢，无因无缘众生清净。”
    时摩诃男闻富兰那所说，心不喜乐，呵骂已，从座起去。向世尊所，头面礼足，却坐一面。以向与富兰那所论事，向佛广说。
    佛告离车摩诃男：“彼富兰那为出意语，不足记也。如是富兰那，愚痴、不辩、不善、非因，而作是说：‘无因无缘众生有垢，无因无缘众生清净。’所以者何？有因有缘众生有垢，有因有缘众生清净。
    “摩诃男，何因何缘众生有垢？何因何缘众生清净？摩诃男，若色一向是苦、非乐、非随乐、非乐长养、离乐者，众生不应因此而生乐著。摩诃男，以色非一向是苦、非乐、随乐、乐所长养、不离乐，是故众生于色染著，染著故系，系故有恼。摩诃男，若受、想、行、识，非一向是苦、非乐、非随乐、非乐长养、离乐者，众生不应因此而生乐著。摩诃男，以识非一向是苦、非乐、随乐、乐所长养、不离乐，是故众生于识染著，染著故系，系故生恼。摩诃男，是名有因有缘众生有垢。
    “摩诃男，何因何缘众生清净？摩诃男，若色一向是乐、非苦、非随苦、非忧苦长养、离苦者，众生不应因色而生厌离。摩诃男，以色非一向乐、是苦、随苦、忧苦长养、不离苦，是故众生厌离于色，厌故不乐，不乐故解脱。摩诃男，若受、想、行、识，一向是乐、非苦、非随苦、非忧苦长养、离苦者，众生不应因识而生厌离。摩诃男，以受、想、行、识，非一向乐、是苦、随苦、忧苦长养、不离苦，是故众生厌离于识，厌故不乐，不乐故解脱。摩诃男，是名有因有缘众生清净。”
    时摩诃男闻佛所说，欢喜随喜，礼佛而退。

知法及重担，往诣观欲贪，
生及与略说，法印富兰那。

（八二）

    如是我闻。一时佛住支提竹园精舍。
    尔时世尊告诸比丘：“多闻圣弟子于何所而见无常、苦？”
    诸比丘白佛言：“世尊为法根、法眼、法依，唯愿为说，诸比丘闻已，当如说奉行。”
    佛告比丘：“谛听善思，当为汝说。多闻圣弟子于色见无常、苦，于受、想、行、识见无常、苦。比丘，色为是常、无常耶？”
    比丘白佛：“无常，世尊。”
    “比丘，无常者是苦耶？”
    比丘白佛：“是苦，世尊。”
    “比丘，若无常、苦，是变易法。多闻圣弟子宁于中见我、异我、相在不？”
    比丘白佛：“不也，世尊。”
    “受、想、行、识，亦复如是。是故比丘，所有诸色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切皆非我、非异我、不相在。受、想、行、识，亦复如是。多闻圣弟子如是观察，厌于色，厌受、想、行、识。厌故不乐，不乐故解脱，解脱故，我生已尽，梵行已立，所作已作，自知不受后有。”
    时诸比丘闻佛所说，欢喜奉行。

（八三）

    如是我闻。一时佛住毗耶离猕猴池侧重阁讲堂。
    尔时世尊告诸比丘：“多闻圣弟子于何所见非我、不异我、不相在，如是平等正观，如实知见？”
    比丘白佛：“世尊为法根、法眼、法依，唯愿为说，诸比丘闻已，如说奉行。”
    佛告比丘：“谛听善思，当为汝说。多闻圣弟子于色见非我、不异我、不相在，是名如实正观。受、想、行、识，亦复如是。”
    佛告诸比丘：“色为是常、为无常耶？”
    比丘白佛：“无常，世尊。”
    复告比丘：“若无常者，是苦不？”
    比丘白佛：“是苦，世尊。”
    “比丘，若无常、苦，是变易法。多闻圣弟子于中宁见有我、异我、相在不？”
    比丘白佛：“不也，世尊。”
    “受、想、行、识，亦复如是。是故比丘，所有诸色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切皆非我、不异我、不相在，是名如实正观。受、想、行、识，亦复如是。多闻圣弟子如是观察，于色得解脱，于受、想、行、识得解脱，我说彼解脱生老病死、忧悲恼苦，纯大苦聚。”
    佛说此经时，诸比丘闻佛所说，欢喜奉行。

（八四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“色是无常，无常则苦，苦则非我，非我者，彼一切非我、不异我、不相在如实知，是名正观。受、想、行、识，亦复如是。多闻圣弟子于此五受阴非我、非我所观察。如是观察，于诸世间都无所取，无所取故无所著，无所著故自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“比丘，于何所不见我、异我、相在？”
    比丘白佛：“世尊为法根、法眼、法依，唯愿为说，诸比丘闻已，如说奉行。”
    佛告比丘：“谛听善思，当为汝说。于色不见有我、异我、相在，不于受、想、行、识，亦复如是。比丘，色为是常、无常耶？”
    比丘白佛：“无常，世尊。”
    佛言：“比丘，若无常者，是苦不？”
    比丘白佛：“是苦，世尊。”
    “比丘，若无常、苦，是变易法。多闻圣弟子宁于中见我、异我、相在不？”
    比丘白佛：“不也，世尊。”
    “受、想、行、识，亦复如是。是故比丘，诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、不异我、不相在。受、想、行、识，亦复如是。比丘，多闻圣弟子观察五受阴非我、非我所。如是观察者，于诸世间都无所取，无所取者无所著，无所著故自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若无常色有常者，彼色不应有病、有苦，亦不应于色有所求，欲令如是，不令如是。以色无常故，于色有病、有苦生，亦得不欲令如是，不令如是。受、想、行、识，亦复如是。比丘，于意云何？色为常、为无常耶？”
    比丘白佛：“无常，世尊。”
    “比丘，无常为是苦不？”
    比丘白佛：“是苦，世尊。”
    “比丘，若无常、苦，是变易法。多闻圣弟子于中宁见是我、异我、相在不？”
    比丘白佛：“不也，世尊。”
    “受、想、行、识，亦复如是。是故比丘，诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、非我所如实知。受、想、行、识，亦复如是。多闻圣弟子正观于色，正观已，于色生厌、离欲、不乐、解脱；受、想、行、识，生厌、离欲、不乐、解脱：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“色是苦，若色非是苦者，不应于色有病、有苦生，亦不欲令如是，亦不令不如是。以色是苦，以色是苦故，于色病生，亦得于色欲令如是，不令如是。受、想、行、识，亦复如是。比丘，色为常、无常耶？”
    比丘白佛：“无常，世尊。”
    “比丘，无常者是苦不？”
    比丘白佛：“是苦，世尊。”
    “比丘，若无常、苦，是变易法。多闻圣弟子宁于中见我、异我、相在不？”
    比丘白佛：“不也，世尊。”
    “受、想、行、识，亦复如是。是故比丘，诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、不异我、不相在，如实观察。受、想、行、识，亦复如是。多闻圣弟子于色得解脱，于受、想、行、识得解脱，我说彼解脱生老病死、忧悲恼苦，纯大苦聚。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。


杂阿含经卷第四

（八八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有年少婆罗门名郁多罗，来诣佛所，与世尊面相问讯慰劳已，退坐一面，白佛言：“世尊，我常如法行乞，持用供养父母，令得乐离苦。世尊，我作如是，为多福不？”
    佛告郁多罗：“实有多福。所以者何？若有如法乞求，供养父母，令其安乐，除苦恼者，实有大福。”
    尔时世尊即说偈言：

“如法于父母，恭敬修供养，
现世名称流，命终生天上。”

    佛说此经已，年少郁多罗欢喜随喜，作礼而去。

（八九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有年少婆罗门名优波迦，来诣佛所，与世尊面相问讯慰劳已，退坐一面，白佛言：“瞿昙，诸婆罗门常称叹邪盛大会。沙门瞿昙亦复称叹邪盛大会不？”
    佛告优波迦：“我不一向称叹。或有邪盛大会可称叹，或有邪盛大会不可称叹。”
    优波迦白佛：“何等邪盛大会可称叹？何等邪盛大会不可称叹？”
    佛告优波迦：“若邪盛大会，系群少特牛、水特、水牸，及诸羊犊、小小众生，悉皆伤杀。逼迫苦切仆使作人，鞭笞恐怛，悲泣号呼，不喜不乐，众苦作役。如是等邪盛大会，我不称叹，以造大难故。若复大会不系缚群牛，乃至不令众生辛苦作役者，如是邪盛大会，我所称叹，以不造大难故。”
    尔时世尊即说偈言：

“祠祀等大会，造诸大难事，
如是等邪盛，大仙不称叹。
系缚诸众生，杀害微细虫，
是非为正会，大仙不随顺。
若不害众生，造作众难者，
是等名正会，大仙随称叹。
惠施修供养，为应法邪盛，
施者清净心，梵行良福田，
如是大会者，是则罗汉会，
是会得大果，诸天皆欢喜。
自行恭敬请，自手而施与，
彼我悉清净，是施得大果。
慧者如是施，信心应解脱，
无罪乐世间，智者往生彼。”

    佛说此经已，优波迦婆罗门闻佛所说，欢喜随喜，作礼而去。

（九○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    广说如上，差别者，谓随说异偈言：

“无为无诸难，邪盛时清净，
如法随顺行，摄护诸梵行，
馨香归世界，超过诸凡鄙，
佛于邪盛善，称叹此邪盛。
惠施修供养，邪盛随所应，
净信平等施，梵行良福田，
彼作如是施，是施罗汉田，
如是广大施，诸天所称叹。
自行恭敬请，自手而供养，
等摄自他故，邪盛得大果。
慧者如是施，净信心解脱，
于无罪世界，智者往生彼。”

    佛说此经已，优波迦婆罗门闻佛所说，欢喜作礼而去。

（九一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有年少婆罗门名郁阇迦，来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，俗人在家当行几法，得现法安及现法乐？”
    佛告婆罗门：“有四法，俗人在家得现法安，现法乐。何等为四？谓方便具足、守护具足、善知识具足、正命具足。
    “何等为方便具足？谓善男子种种工巧业处以自营生，谓种田、商贾，或以王事，或以书疏、算画，于彼彼工巧业处精勤修行，是名方便具足。
    “何等为守护具足？谓善男子所有钱谷，方便所得，自手执作，如法而得，能极守护，不令王、贼、水、火劫夺漂没令失，不善守护者亡失，不爱念者辄取，及诸灾患所坏，是名善男子善守护。
    “何等为善知识具足？若有善男子不落度、不放逸、不虚妄、不凶险，如是知识能善安慰，未生忧苦能令不生，已生忧苦能令开觉，未生喜乐能令速生，已生喜乐护令不失，是名善男子善知识具足。
    “云何为正命具足？谓善男子所有钱财，出内称量，周圆掌护，不令多入少出也，多出少入也。如执秤者，少则增之，多则减之，知平而舍。如是善男子称量财物，等入等出，莫令入多出少，出多入少。若善男子无有钱财而广散用，以此生活，人皆名为优昙钵花，无有种子，愚痴贪欲，不顾其后。或有善男子财物丰多，不能食用，傍人皆言是愚痴人，如饿死狗。是故善男子所有钱财，能自称量，等入等出，是名正命具足。如是婆罗门，四法成就，现法安，现法乐。”
    婆罗门白佛言：“世尊，在家之人有几法，能令后世安，后世乐？”
    佛告婆罗门：“在家之人有四法，能令后世安，后世乐。何等为四？谓信具足、戒具足、施具足、慧具足。
    “何等为信具足？谓善男子于如来所，得信敬心，建立信本，非诸天、魔、梵，及余世人同法所坏，是名善男子信具足。
    “何等戒具足？谓善男子不杀生、不偷盗、不邪淫、不妄语、不饮酒，是名戒具足。
    “云何施具足？谓善男子离悭垢心，在于居家，行解脱施，常自手与，乐修行舍，等心行施，是名善男子施具足。
    “云何为慧具足？谓善男子苦圣谛如实知，集、灭、道圣谛如实知，是名善男子慧具足。若善男子在家行此四法者，能得后世安，后世乐。”
    尔时世尊复说偈言：

“方便建诸业，积集能守护，
知识善男子，正命以自活。
净信戒具足，惠施离悭垢，
净除于迷道，得后世安乐。
若处于居家，成就于八法，
审谛尊所说，等正觉所知，
现法得安隐，现法喜乐住，
后世喜乐住。”

    佛说此经已，郁阇迦闻佛所说，欢喜随喜，作礼而去。

（九二）

    如是我闻。一时佛在拘萨罗人间游行，至舍卫国祇树给孤独园。
    尔时舍卫国有骄慢婆罗门止住，父母种姓俱净，无瑕点能说者，七世相承，悉皆清净。为婆罗门师，言论通达，诸论记典，悉了万名，解法优劣，分别诸字，悉知万事久远本末因缘，句句记说。容貌端正，或生志高，族姓志高，容色志高，聪明志高，财富志高，不敬父母、诸尊师长。闻沙门瞿昙在拘萨罗国人间游行，至舍卫国祇树给孤独园。闻已作是念：“我当往彼沙门瞿昙所，若有所说，我当共论。无所说者，默然而还。”
    时骄慢婆罗门乘白马车，诸年少婆罗门前后导从，持金柄伞盖，手执金瓶，往见世尊，至于园门，下车步进。
    尔时世尊与诸大众围绕说法，不时顾念骄慢婆罗门。时骄慢婆罗门作是念：“沙门瞿昙不顾念我，且当还去。”
    尔时世尊知骄慢婆罗门心念，而说偈言：

“骄慢既来此，不善更增慢，
向以义故来，应转增其义。”

    时骄慢婆罗门作是念：“沙门瞿昙已知我心。”欲修敬礼。
    尔时世尊告骄慢婆罗门：“止，止，不须作礼，心净已足。”
    时诸大众咸各高声唱言：“奇哉世尊，大德大力！今此骄慢婆罗门，恃生骄慢，族姓骄慢，容色骄慢，聪明骄慢，财富骄慢，不敬父母、诸尊师长。今于沙门瞿昙所，谦卑下下，欲接足礼。”
    时骄慢婆罗门于大众前，唱令静默，而说偈言：

“云何不起慢？云何起恭敬？
云何善慰谕？云何善供养？”

    尔时世尊说偈答言：

“父母及长兄，和尚诸师长，
及诸尊重者，所不应生慢。
应当善恭敬，谦下而问讯，
尽心而奉事，兼设诸供养。
离贪恚痴心，漏尽阿罗汉，
正智善解脱，伏诸骄慢心，
于此贤圣等，合掌稽首礼。”

    尔时世尊为骄慢婆罗门种种说法，示教照喜，如佛世尊次第说法，说布施、持戒、生天功德，爱欲味患，烦恼清净，出要远离，诸清净分，如是广说。
    如白净衣，无诸黑恶，速受染色。骄慢婆罗门即于座上，解四圣谛，苦、集、灭、道，得无间等。时骄慢婆罗门见法、得法、知法、入法，度诸疑惑，不由他度，于正法中，得无所畏。即从座起，整衣服，为佛作礼，合掌白佛：“我今可得于正法中出家，受具足不？”
    佛告骄慢婆罗门：“汝今可得于正法中出家，受具足。”
    彼即出家，独静思惟，所以善男子剃除须发，着袈裟衣，正信非家，出家学道，得阿罗汉，心善解脱。

（九三）

    如是我闻。一时佛在拘萨罗人间游行，至舍卫国祇树给孤独园。
    时有长身婆罗门，作如是邪盛大会：以七百特牛行列系柱，特牸、水牛及诸羊犊、种种小虫，悉皆系缚；办诸饮食，广行布施。种种外道，从诸国国，皆悉来集邪盛会所。
    时长身婆罗门，闻沙门瞿昙从拘萨罗人间游行，至舍卫国祇树给孤独园。作是念：“我今办邪盛大会，所以七百特牛行列系柱，乃至小小诸虫皆悉系缚，为邪盛大会故，种种异道从诸国国来至会所。我今当往沙门瞿昙所，问邪盛法。莫令我作邪盛大会，分数中有所短少。”作是念已，乘白马车，诸年少婆罗门前后导从，持金柄伞盖，执金澡瓶，出舍卫城，诣世尊所，恭敬承事。至精舍门，下车步进，至于佛前，面相问讯慰劳已，退坐一面，白佛言：“瞿昙，我今欲作邪盛大会，以七百特牛行列系柱，乃至小小诸虫皆悉系缚，为邪盛大会故，种种异道从诸国国皆悉来至邪盛会所。又闻瞿昙从拘萨罗人间游行，至舍卫国祇树给孤独园。我今故来请问瞿昙，邪盛大会法，诸物分数。莫令我所作邪盛大会，诸分数之中有所短少。”
    佛告婆罗门：“或有一邪盛大会主，行施作福，而生于罪，为三刀剑之所刻削，得不善果报。何等三？谓身刀剑、口刀剑、意刀剑。
    “何等为意刀剑，生诸苦报？如一会主，造作大会，作是思惟：‘我作邪盛大会，当杀尔所少壮特牛，尔所水特、水牸，尔所羊犊及种种诸虫。’是名意刀剑，生诸苦报。如是施主虽念作种种布施、种种供养，实生于罪。
    “云何为口刀剑，生诸苦报？有一会主，造作大会，作如是教：‘我今作邪盛大会，汝等当杀尔所少壮特牛，乃至杀害尔所微细虫。’是名口刀剑，生诸苦报。大会主虽作是布施、供养，实生于罪。
    “云何为身刀剑，生诸苦报？谓有一大会主，造作大会，自手伤杀尔所特牛，乃至杀害种种细虫，是名身刀剑，生诸苦报。彼大会主虽作是念，种种布施，种种供养，实生于罪。
    “然婆罗门，当勤供养三火，随时恭敬，礼拜奉事，施其安乐。何等为三？一者根本、二者居家、三者福田。
    “何者为根本火，随时恭敬，奉事供养，施其安乐？谓善男子方便得财，手足勤苦，如法所得，供养父母，令得安乐，是名根本火。何故名为根本？若善男子从彼而生，所谓父母，故名根本。善男子以崇本故，随时恭敬，奉事供养，施以安乐。
    “何等为居家火，善男子随时育养，施以安乐？谓善男子方便得财，手足勤苦，如法所得，供给妻子、宗亲、眷属、仆使、佣客，随时给与，恭敬施安，是名家火。何故名家？其善男子处于居家，乐则同乐，苦则同苦，在所为作，皆相顺从，故名为家。是故善男子随时供给，施与安乐。
    “何等名田火，善男子随时恭敬，尊重供养，施其安乐？谓善男子方便得财，手足勤劳，如法所得，奉事供养诸沙门、婆罗门，善能调伏贪、恚、痴者。如是等沙门、婆罗门，建立福田，崇向增进，乐分乐报，未来生天，是名田火。何故名田？为世福田，谓为应供，是故名田。是善男子随时恭敬，奉事供养，施其安乐。”
    尔时世尊复说偈言：

“根本及居家，应供福田火，
是火增供养，充足安隐乐，
无罪乐世间，慧者往生彼。
如法财复会，供养所应养，
供养应养故，生天得名称。”

    “然婆罗门，今善男子先所供养三火，应断令灭。何等为三？谓贪欲火、瞋恚火、愚痴火。所以者何？若贪火不断不灭者，自害害他，自他俱害，现法得罪，后世得罪，现法后世得罪，缘彼而生心法忧苦。恚火、痴火，亦复如是。婆罗门，若善男子事积薪火，随时辛苦，随时燃，随时灭火，因缘受苦。”
    尔时长身婆罗门默然而住。时有婆罗门子名郁多罗，于会中坐。长身婆罗门须臾默然思惟已，告郁多罗：“汝能往至邪盛会所，放彼系柱特牛，及诸众生受系缚者，悉皆放不？而告之言：‘长身婆罗门语汝：随意自在，山泽旷野，食不断草，饮净流水，四方风中受诸快乐！’”
    郁多罗白言：“随大师教。”即往彼邪盛会所，放诸众生，而告之言：“长身婆罗门语汝：随其所乐，山泽旷野，饮水食草，四风自适！”
    尔时世尊知郁多罗，知已为长身婆罗门种种说法，示教照喜。如律世尊说法先后，说戒、说施及生天功德，爱欲味患，出要清净，烦恼清净，开示显现。
    譬如鲜净白氎，易受染色。长身婆罗门亦复如是，即于座上见四真谛，得无间等。时长身婆罗门见法、得法、知法、入法，度诸疑惑，不由他度，于正法中，得无所畏。即从座起，整衣服，偏袒右肩，合掌白佛：“已度，世尊。我从今日尽其寿命，归佛、归法、归比丘僧，为优婆塞，证知我！唯愿世尊与诸大众，受我饭食。”
    尔时世尊默然而许。
    时长身婆罗门知佛受请已，为佛作礼，右绕三匝而去。长身婆罗门还邪盛处，作诸供办净美好者，布置床座，遣使请佛，白言：“时到，唯圣知时。”
    尔时世尊着衣持钵，大众围绕，往到长身婆罗门会所，大众前坐。
    时长身婆罗门知世尊坐定已，手自供养种种饮食。食已，澡漱洗钵毕，别敷卑床，于大众前端坐听法。
    尔时世尊为长身婆罗门说种种法，示教照喜已，从座起而去。

（九四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有年少婆罗门名僧迦罗，来诣佛所，与世尊面相问讯慰劳已，退坐一面，白佛言：“瞿昙，不善男子云何可知？”
    佛告婆罗门：“譬犹如月。”
    婆罗门复问：“善男子云何可知？”
    佛告婆罗门：“譬犹如月。”
    婆罗门白佛：“云何不善男子如月？”
    佛告婆罗门：“如月黑分，光明亦失，色亦失，所系亦失，日夜消减，乃至不现。如是有人，于如来所，得信寂心，受持净戒，善学多闻，损己布施，正见真实。于如来所净信、持戒、惠施、多闻、正见真实已，然后退失，于戒、闻、施、正见悉皆忘失，日夜消减，乃至须臾一切忘失。复次婆罗门，若善男子不习近善知识，不数闻法，不正思惟，身行恶行，口行恶行，意行恶行。行恶因缘故，身坏命终，堕恶趣泥梨中。如是婆罗门，不善男子，其譬如月。”
    婆罗门白佛：“云何善男子其譬如月？”
    佛告婆罗门：“譬如明月净分，光明色泽，日夜增明，乃至月满，一切圆净。如是善男子，于如来法律得净信心，乃至正见，真净增明。戒增、施增、闻增、慧增，日夜增长。复于余时亲近善知识，闻说正法，内正思惟，行身善行，行口善行，行意善行故，以是因缘，身坏命终，化生天上。婆罗门，是故善男子譬如月。”
    尔时世尊而说偈言：

“譬如月无垢，周行于虚空，
一切诸星中，其光最盛明。
净信亦如是，戒闻离悭施，
于诸悭世间，其施特明显。”

    佛说此经已，僧迦罗婆罗门闻佛所说，欢喜随喜，从座起而去。

（九五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有生闻婆罗门，来诣佛所，与世尊面相问讯慰劳已，退坐一面，白佛言：“瞿昙，我闻瞿昙说言：‘唯应施我，不应施余人，施我得大果，非施余人而得大果。应施我弟子，不应施余弟子，施我弟子得大果报，非施余弟子得大果报。’云何瞿昙，作是语者，为实说耶？非为谤毁瞿昙乎？为如说说、如法说、法次法说，不为余人以同法来诃责耶？”
    佛告婆罗门：“彼如是说者，谤毁我耳。非如说说、如法说、法次法说、不致他人来以同法呵责。所以者何？我不如是说：‘应施于我，不应施余，施我得大果报，非施余人得大果报。应施我弟子，施我弟子得大果报，非施余弟子得大果报。’然婆罗门，我作如是说者，作二种障。障施者施，障受者利。婆罗门，乃至士夫以洗器余食着于净地，令彼处众生即得利乐，我说斯等亦入福门，况复施人。婆罗门，然我复说，施持戒者得果报，不同犯戒。”
    生闻婆罗门白佛言：“如是瞿昙，我亦如是说，施持戒者得大果报，非施犯戒。”
    尔时世尊复说偈言：

“若黑若有白，若赤若有色，
犁杂及金色，纯黄及鸽色，
如是等牸牛，牛犊姝好者，
丁壮力具足，调善行捷疾，
但使堪运重，不问本生色。
人亦复如是，各随彼彼生，
刹利婆罗门，毗舍首陀罗，
旃陀罗下贱，所生悉不同，
但使持净戒，离重担烦恼，
纯一修梵行，漏尽阿罗汉，
于世间善逝，施彼得大果。
愚者无智慧，未尝闻正法，
施彼无大果，不近善友故。
若习善知识，如来及声闻，
清净信善逝，根生坚固力，
所往之善趣，及生大姓家，
究竟般涅槃，大仙如是说。”

    佛说此经已，生闻婆罗门闻佛所说，欢喜随喜，作礼而去。

（九六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊晨朝着衣持钵，入舍卫城乞食。
    时有异婆罗门，年耆根熟，执杖持钵，家家乞食。
    尔时世尊告婆罗门：“汝今云何年耆根熟，拄杖持钵，家家乞食？”
    婆罗门白佛：“瞿昙，我家中所有财物，悉付其子，为子娶妻，然后舍家，是故拄杖持钵，家家乞食。”
    佛告婆罗门：“汝能于我所，受诵一偈，还归于众中，为儿说耶？”
    婆罗门白佛：“能受，瞿昙。”
    尔时世尊即说偈言：

“生子心欢喜，为子聚财物，
亦为娉其妻，而自舍出家。
边鄙田舍儿，违负于父母，
人形罗刹心，弃舍于尊老。
老马无复用，则夺其[麦+廣]麦，
儿少而父老，家家行乞食。
曲杖为最胜，非子为恩爱，
为我防恶牛，危险地得安，
能却凶暴狗，扶我暗处行，
避深坑空井，草木棘刺林，
凭杖威力故，跱立不堕落。”

    时婆罗门从世尊受斯偈已，还归婆罗门大众中，为子而说。先白大众：“听我所说。”然后诵偈，如上广说。其子愧怖，即抱其父，还将入家，摩身洗浴，覆以青衣被，立为家主。
    时婆罗门作是念：“我今得胜族姓，是沙门瞿昙恩。我经所说：‘为师者如师供养，为和尚者如和尚供养。’我今所得，皆沙门瞿昙力，即是我师，我今当以上妙好衣以奉瞿昙。”时婆罗门持上妙衣，至世尊所，面前问讯慰劳已，退坐一面，白佛言：“瞿昙，我今居家成就，是瞿昙力。我经记说：‘为师者以师供养，为和尚者以和尚供养。’今日瞿昙即为我师，愿受此衣，哀愍故。”
    世尊即受，为哀愍故。尔时世尊为婆罗门说种种法，示教照喜。
    时婆罗门闻佛所说，欢喜随喜，作礼而去。

（九七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊晨朝着衣持钵，入舍卫城乞食。
    时有异婆罗门，年耆根熟，摄杖持钵，家家乞食。彼婆罗门遥见世尊，而作是念：“沙门瞿昙摄杖持钵，家家乞食。我亦摄杖持钵，家家乞食，我与瞿昙俱是比丘。”
    尔时世尊说偈答曰：

“所谓比丘者，非但以乞食，
受持在家法，是何名比丘。
于功德过恶，俱离修正行，
其心无所畏，是则名比丘。”

    佛说是经已，彼婆罗门闻佛所说，欢喜随喜，作礼而去。

（九八）

    如是我闻。一时佛在拘萨罗人间游行，至一那罗聚落，住一那罗林中。
    尔时世尊着衣持钵，入一那罗聚落乞食，而作是念：“今日太早，今且可过耕田婆罗豆婆遮婆罗门作饮食处。”
    尔时耕田婆罗豆婆遮婆罗门，五百具犁耕田，为作饮食。时耕田婆罗豆婆遮婆罗门，遥见世尊，白言：“瞿昙，我今耕田下种，以供饮食。沙门瞿昙亦应耕田下种，以供饮食。”
    佛告婆罗门：“我亦耕田下种，以供饮食。”
    婆罗门白佛：“我都不见沙门瞿昙，若犁、若轭、若鞅、若縻、若镵、若鞭，而今瞿昙说言，我亦耕田下种，以供饮食？”
    尔时耕田婆罗豆婆遮婆罗门即说偈言：

“自说耕田者，而不见其耕，
为我说耕田，令我知耕法。”

    尔时世尊说偈答言：

“信心为种子，苦行为时雨，
智慧为犁轭，惭愧心为辕，
正念自守护，是则善御者。
保藏身口业，如食处内藏，
真实为真乘，乐住为懈息，
精进无废荒，安隐而速进，
直往不转还，得到无忧处。
如是耕田者，逮得甘露果，
如是耕田者，不还受诸有。”

    时耕田婆罗豆婆遮婆罗门白佛言：“善耕田，瞿昙！极善耕田，瞿昙！”于是耕田婆罗豆婆遮婆罗门，闻世尊说偈，心转增信，以满钵香美饮食，以奉世尊。
    世尊不受，以因说偈得故。即说偈言：

“不因说法故，受彼食而食，
但为利益他，说法不受食。”

    如是广说，如前为火与婆罗门广说。
    时耕田婆罗豆婆遮婆罗门白佛言：“瞿昙，今以此食安着何处？”
    佛告婆罗门：“我不见诸天、魔、梵、沙门、婆罗门、天神、世人，堪食此食而得安身。婆罗门，汝持此食着无虫水中，及少生草地。”
    时婆罗门即持此食着无虫水中，水即烟起涌沸，啾啾作声。如热铁丸投于冷水，啾啾作声。如是彼食投着无虫水中，烟起涌沸，啾啾作声。
    时婆罗门作是念：“沙门瞿昙实为奇特，大德大力，乃令饮食神变如是。”时彼婆罗门见食瑞应，信心转增，白佛言：“瞿昙，我今可得于正法中出家，受具足不？”
    佛告婆罗门：“汝今可得于正法中出家，受具足，得比丘分。”
    彼即出家已，独静思惟，所以族姓子剃除须发，着袈裟衣，正信非家，出家学道，乃至得阿罗汉，心善解脱。

（九九）

    如是我闻。一时佛住王舍城。
    时有尊者名曰净天，在鞞提诃国人间游行，至弥絺罗城庵罗园中。时尊者净天，晨朝着衣持钵，入弥絺罗城乞食。次第乞食，到自本家。时净天母年老，在中堂持食祀火，求生梵天，不觉尊者净天在门外立。
    时毗沙门天王，于尊者净天所，极生敬信。时毗沙门天王，诸夜叉导从，乘虚而行，见尊者净天在门外立，又见其母手擎饮食，在中堂上供养祀火，不见其子在外门立。见已从空中下，至净天母前，而说偈言：

“此婆罗门尼，梵天极辽远，
为求彼生故，于此祠祀火，
此非梵天道，何为徒祀此？
汝婆罗门尼，净天住门外，
垢秽永无余，是则天中天。
萧然无所有，独一不兼资，
为乞食入舍，所应供养者。
净天善修身，人天良福田，
远离一切恶，不为染所染。
德同于梵天，形在人间住，
不著一切法，如彼淳熟龙。
比丘正念住，其心善解脱，
应奉以初揣，是则上福田。
应以净信心，及时速施与，
当预建立洲，令未来安乐。
汝观此牟尼，已渡苦海流，
是故当信心，及时速施与，
当预建立洲，令未来安乐。
毗沙门天王，开发彼令舍。”

    时尊者净天即为其母种种说法，示教照喜已，复道而去。

（一○○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异婆罗门，来诣佛所，面前问讯，相慰劳已，退坐一面，白佛言：“瞿昙，所谓佛者，云何为佛？为是父母制名？为是婆罗门制名？”
    时婆罗门即说偈言：

“佛者是世间，超渡之胜名，
为是父母制，名之为佛耶？”

    尔时世尊说偈答言：

“佛见过去世，如是见未来，
亦见现在世，一切行起灭。
明智所了知，所应修已修，
应断悉已断，是故名为佛。
历劫求选择，纯苦无暂乐，
生者悉磨灭，远离息尘垢，
拔诸使刺本，等觉故名佛。”

    佛说偈已，彼婆罗门闻佛所说，欢喜随喜，从座起去。

（一○一）

    如是我闻。一时佛在拘萨罗人间游行，有徙迦帝聚落、堕鸠罗聚落，二村中间，一树下坐，入昼正受。
    时有豆磨种姓婆罗门，随彼道行，寻佛后来，见佛脚迹，千辐轮相，印文显现，齐辐圆辋，众好满足。见已作是念：“我未曾见人间有如是足迹，今当随迹以求其人。”即寻脚迹至于佛所，来见世尊坐一树下，入昼正受，严容绝世，诸根澄静，其心寂定，第一调伏，止观成就，光相巍巍，犹若金山。见已白言：“为是天耶？”
    佛告婆罗门：“我非天也。”
    “为龙、夜叉、乾闼婆、阿修罗、迦楼罗、紧那罗、摩睺罗伽、人非人等？”
    佛告婆罗门：“我非龙，乃至人非人也。”
    婆罗门白佛：“若言非天，非龙，乃至非人、非非人，为是何等？”
    尔时世尊说偈答言：

“天龙乾闼婆，紧那罗夜叉，
无善阿修罗，诸摩睺罗伽，
人与非人等，悉由烦恼生。
如是烦恼漏，一切我已舍，
已破已磨灭，如芬陀利生，
虽生于水中，而未曾著水，
我虽生世间，不为世间著。
历劫常选择，纯苦无暂乐，
一切有为行，悉皆生灭故。
离垢不倾动，已拔诸剑刺，
究竟生死际，故名为佛陀。”

    佛说此经已，豆摩种婆罗门闻佛所说，欢喜随喜，从路而去。

（一○二）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊晨朝着衣持钵，入王舍城乞食。次第乞食，至婆罗豆婆遮婆罗门舍。
    时婆罗门手执木杓，盛诸饮食，供养火具，住于门边。遥见佛来，见已白佛，作是言：“住！住！领群特，慎勿近我门。”
    佛告婆罗门：“汝知领群特、领群特法耶？”
    婆罗门言：“我不知领群特，亦不知领群特法。沙门瞿昙知领群特及领群特法不？”
    佛言：“我善知是领群特及领群特法。”
    是时婆罗门即放事火具，疾敷床座，请佛令坐，白言：“瞿昙，为我说领群特及领群特法。”
    佛即就座，为说偈言：

“瞋恚心怀恨，隐覆诸过恶，
犯戒起恶见，虚伪不真实，
如是等士夫，当知领群特。
弊暴贪吝惜，恶欲悭谄伪，
无惭无愧心，当知领群特。
一生二生者，一切皆杀害，
无有慈愍心，是为领群特。
若杀缚槌打，聚落及城邑，
无道以切责，当知领群特。
住止及行路，为众之导首，
苦切诸群下，恐怛相迫胁，
取利以供己，当知领群特。
聚落及空地，有主无主物，
掠护为己有，当知领群特。
自弃薄其妻，又不入淫舍，
侵陵他所爱，当知领群特。
内外诸亲属，同心善知识，
侵掠彼所爱，当知领群特。
妄语欺诳人，诈取无证财，
他索而不还，当知领群特。
为己亦为他，举责及与责，
或复顺他语，妄语为他证，
如是妄语者，当知领群特。
作恶不善业，无有人知者，
隐讳覆藏恶，当知领群特。
若人问其义，而答以非义，
颠倒欺诳人，当知领群特。
实空无所有，而轻毁智者，
愚痴为利故，当知领群特。
高慢自称举，毁坏于他人，
是极卑鄙慢，当知领群特。
自造诸过恶，移过诬他人，
妄语谤清白，当知领群特。
前受他利养，他若来诣己，
无有敬报心，当知领群特。
沙门婆罗门，如法来乞求，
呵责而不与，当知领群特。
若父母年老，少壮气已谢，
不勤加奉养，当知领群特。
父母诸尊长，兄弟亲眷属，
实非阿罗汉，自显罗汉德，
世间之大贼，当知领群特。
初上种姓生，习婆罗门典，
而于其中间，习行诸恶业，
不以胜生故，障呵责恶道，
现法受呵责，后世堕恶道。
生旃陀罗家，世称须陀夷，
名闻遍天下，旃陀罗所无。
婆罗门刹利，大姓所供养，
乘于净天道，平等正直住。
不以生处障，令不生梵天，
现法善名誉，后世生善趣。
二生汝当知，如我所显示，
不以所生故，名为领群特，
不以所生故，名为婆罗门，
业为领群特，业为婆罗门。”

    婆罗门白佛言：

“如是大精进，如是大牟尼，
不以所生故，名为领群特，
不以所生故，名为婆罗门，
业故领群特，业故婆罗门。”

    时事火婆罗豆婆遮婆罗门，转得信心，以满钵好食，奉上世尊。
    世尊不受，以说偈得故，偈如上说。
    时事火婆罗豆婆遮婆罗门，见食瑞应已，增其信心，白佛言：“世尊，我今可得于正法律出家，受具足不？”
    佛告婆罗门：“汝今可得于正法律出家，受具足戒。”
    即得出家，独静思惟，如前说，乃至得阿罗汉，心善解脱。时婆罗豆婆遮婆罗门，得阿罗汉，心善解脱，自觉喜乐，而说偈言：

“非道求清净，供养祠祀火，
不识清净道，犹如生盲者。
今已得安乐，出家受具足，
逮得于三明，佛所教已作。
先婆罗门难，今为婆罗门，
沐浴离尘垢，度诸天彼岸。”


杂阿含经卷第五

（一○三）

    如是我闻。一时有众多上座比丘，住拘舍弥国瞿师罗园。
    时有差摩比丘，住拘舍弥国跋陀梨园，身得重病。
    时有陀娑比丘，为瞻病者。时陀娑比丘，诣诸上座比丘，礼诸上座比丘足，于一面住。
    诸上座比丘告陀娑比丘言：“汝往诣差摩比丘所，语言：诸上座问汝，身小瘥安隐、苦患不增剧耶？”
    时陀娑比丘受诸上座比丘教，至差摩比丘所，语差摩比丘言：“诸上座比丘问讯汝：苦患渐瘥不？众苦不至增耶？”
    差摩比丘语陀娑比丘言：“我病不瘥，不安隐身，诸苦转增无救。譬如多力士夫，取羸劣人，以绳缚头，两手急绞，极大苦痛。我今苦痛有过于彼。譬如屠牛，以利刀生割其腹，取其内脏，其牛腹痛当何可堪？我今腹痛，甚于彼牛。如二力士捉一劣夫，悬着火上，烧其两足。我今两足，热过于彼。”
    时陀娑比丘还至诸上座所，以差摩比丘所说病状，具白诸上座。
    时诸上座还遣陀娑比丘至差摩比丘所，语差摩比丘言：“世尊所说有五受阴。何等为五？色受阴，受、想、行、识受阴。汝差摩能少观察此五受阴非我、非我所耶？”
    时陀娑比丘受诸上座比丘教已，往语差摩比丘言：“诸上座语汝：世尊说五受阴，汝少能观察非我、非我所耶？”
    差摩比丘语陀娑言：“我于彼五受阴，能观察非我、非我所。”
    陀娑比丘还白诸上座：“差摩比丘言：我于五受阴，能观察非我、非我所。”
    诸上座比丘复遣陀娑比丘，语差摩比丘言：“汝能于五受阴观察非我、非我所，如漏尽阿罗汉耶？”
    时陀娑比丘受诸上座比丘教，往诣差摩比丘所，语差摩言：“比丘，能如是观五受阴者，如漏尽阿罗汉耶？”
    差摩比丘语陀娑比丘言：“我观五受阴非我、非我所，非漏尽阿罗汉也。”
    时陀娑比丘还至诸上座所，白诸上座：“差摩比丘言：我观五受阴非我、非我所，而非漏尽阿罗汉也。”
    时诸上座语陀娑比丘：“汝复还语差摩比丘：汝言：‘我观五受阴非我、非我所，而非漏尽阿罗汉。’前后相违。”
    陀娑比丘受诸上座比丘教，往语差摩比丘：“汝言：‘我观五受阴非我、非我所，而非漏尽阿罗汉。’前后相违。”
    差摩比丘语陀娑比丘言：“我于五受阴观察非我、非我所，而非阿罗汉者，我于我慢、我欲、我使，未断、未知、未离、未吐。”
    陀娑比丘还至诸上座所，白诸上座：“差摩比丘言：我于五受阴观察非我、非我所，而非漏尽阿罗汉者，于五受阴我慢、我欲、我使，未断、未知、未离、未吐。”
    诸上座复遣陀娑比丘，语差摩比丘言：“汝言有我，于何所有我？为色是我，为我异色？受、想、行、识是我，为我异识耶？”
    差摩比丘语陀娑比丘言：“我不言色是我，我异色；受、想、行、识是我，我异识。然于五受阴我慢、我欲、我使，未断、未知、未离、未吐。”
    差摩比丘语陀娑比丘言：“何烦令汝驱弛往反？汝取杖来，我自扶杖诣彼上座，愿授以杖。”差摩比丘即自扶杖，诣诸上座。
    时诸上座遥见差摩比丘扶杖而来，自为敷座，安停脚机，自往迎接，为持衣钵，命令就座，共相慰劳。慰劳已，语差摩比丘言：“汝言我慢。何所见我？色是我耶，我异色耶？受、想、行、识是我耶，我异识耶？”
    差摩比丘白言：“非色是我，非我异色；非受、想、行、识是我，非我异识，然于五受阴我慢、我欲、我使，未断、未知、未离、未吐。譬如优钵罗、钵昙摩、拘牟头、分陀利花香，为即根香耶，为香异根耶？为茎、叶、须、精粗香耶，为香异精粗耶？为等说不？”
    诸上座答言：“不也，差摩比丘，非优钵罗、钵昙摩、拘牟头、分陀利根即是香，非香异根。亦非茎、叶、须、精粗是香，亦非香异精粗也。”
    差摩比丘复问：“彼何等香？”
    上座答言：“是花香。”
    差摩比丘复言：“我亦如是，非色即我，我不离色；非受、想、行识即我，我不离识。然我于五受阴见非我、非我所，而于我慢、我欲、我使，未断、未知、未离、未吐。诸上座，听我说譬，凡智者因譬类得解。譬如乳母衣，付浣衣者，以种种灰汤，浣濯尘垢，犹有余气。要以种种杂香，熏令消灭。如是多闻圣弟子虽于五受阴，正观非我、非我所，然于五受阴我慢、我欲、我使，未断、未知、未离、未吐。然后于五受阴增进思惟，观察生灭：此色，此色集，此色灭；此受、想、行、识，此识集，此识灭。于五受阴如是观生灭已，我慢、我欲、我使，一切悉除，是名真实正观。”
    差摩比丘说此法时，彼诸上座远尘离垢，得法眼净。差摩比丘不起诸漏，心得解脱。法喜利故，身病悉除。
    时诸上座比丘语差摩比丘言：“我闻仁者初所说，已解已乐，况复重闻。所以问者，欲发仁者微妙辩才，非为娆乱，汝便堪能广说如来、应、等正觉法。”
    时诸上座闻差摩比丘所说，欢喜奉行。

（一○四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时有比丘名焰摩迦，起恶邪见，作如是言：“如我解佛所说法，漏尽阿罗汉身坏命终，更无所有。”
    时有众多比丘闻彼所说，往诣其所，语焰摩迦比丘言：“汝实作是说：如我解佛所说法，漏尽阿罗汉身坏命终，更无所有耶？”
    答言：“实尔，诸尊。”
    时诸比丘语焰摩迦：“勿谤世尊，谤世尊者不善。世尊不作是说，汝当尽舍此恶邪见。”
    诸比丘说此语时，焰摩迦比丘犹执恶邪见，作如是言：“诸尊，唯此真实，异则虚妄。”如是三说。
    时诸比丘不能调伏焰摩迦比丘，即便舍去。往诣尊者舍利弗所，语尊者舍利弗言：“尊者，当知彼焰摩迦比丘起如是恶邪见，言：‘我解知佛所说法，漏尽阿罗汉身坏命终，更无所有。’我等闻彼所说已，故往问焰摩迦比丘：‘汝实作如是知见耶？’彼答我言：‘诸尊，实尔，异则愚说。’我即语言：‘汝勿谤世尊，世尊不作此语，汝当舍此恶邪见。’再三谏彼，犹不舍恶邪见。是故我今诣尊者所，唯愿尊者，当令焰摩迦比丘息恶邪见，怜愍彼故。”
    舍利弗言：“如是，我当令彼息恶邪见。”
    时众多比丘闻舍利弗语，欢喜随喜，而还本处。
    尔时尊者舍利弗晨朝着衣持钵，入舍卫城乞食。食已出城，还精舍，举衣钵已，往诣焰摩迦比丘所。时焰摩迦比丘遥见尊者舍利弗来，即为敷座洗足，安停脚机，奉迎，为执衣钵，请令就座。
    尊者舍利弗就座洗足已，语焰摩迦比丘：“汝实作如是语：我解知世尊所说法，漏尽阿罗汉身坏命终无所有耶？”
    焰摩迦比丘白舍利弗言：“实尔，尊者舍利弗。”
    舍利弗言：“我今问汝，随意答我。云何焰摩迦，色为常耶，为非常耶？”
    答言：“尊者舍利弗，无常。”
    复问：“若无常者，是苦不？”
    答言：“是苦。”
    复问：“若无常、苦，是变易法。多闻圣弟子宁于中见我、异我、相在不？”
    答言：“不也，尊者舍利弗。”
    受、想、行、识，亦复如是。
    复问：“云何焰摩迦，色是如来耶？”
    答言：“不也，尊者舍利弗。”
    “受、想、行、识是如来耶？”
    答言：“不也，尊者舍利弗。”
    复问：“云何焰摩迦，异色有如来耶？异受、想、行、识有如来耶？”
    答言：“不也，尊者舍利弗。”
    复问：“色中有如来耶？受、想、行、识中有如来耶？”
    答言：“不也，尊者舍利弗。”
    复问：“如来中有色耶？如来中有受、想、行、识耶？”
    答言：“不也，尊者舍利弗。”
    复问：“非色、受、想、行、识有如来耶？”
    答言：“不也，尊者舍利弗。”
    “如是焰摩迦，如来见法真实如，住无所得，无所施设。汝云何言：‘我解知世尊所说，漏尽阿罗汉身坏命终无所有。’为时说耶？”
    答言：“不也，尊者舍利弗。”
    复问：“焰摩迦，先言：‘我解知世尊所说，漏尽阿罗汉身坏命终无所有。’云何今复言非耶？”
    焰摩迦比丘言：“尊者舍利弗，我先不解、无明故，作如是恶邪见说。闻尊者舍利弗说已，不解、无明一切悉断。”
    复问：“焰摩迦，若复问：‘比丘，如先恶邪见所说，今何所知见，一切悉得远离。’汝当云何答？”
    焰摩迦答言：“尊者舍利弗，若有来问者，我当如是答：漏尽阿罗汉色无常，无常者是苦，苦者寂静、清凉、永没。受、想、行、识，亦复如是。有来问者，作如是答。”
    舍利弗言：“善哉善哉！焰摩迦比丘，汝应如是答。所以者何？漏尽阿罗汉色无常，无常者是苦，若无常、苦者，是生灭法。受、想、行、识，亦复如是。”
    尊者舍利弗说是法时，焰摩迦比丘远尘离垢，得法眼净。
    尊者舍利弗语焰摩迦比丘：“今当说譬，夫智者以譬得解。如长者子，长者子大富多财，广求仆从，善守护财物。时有怨家恶人，诈来亲附，为作仆从，常伺其便。晚眠早起，侍息左右，谨敬其事，逊其言辞，令主意悦，作亲友想、子想，极信不疑，不自防护。然后手执利刀，以断其命。焰摩迦比丘，于意云何？彼恶怨家，为长者亲友，非为初始方便，害心常伺其便，至其终耶？而彼长者，不能觉知，至今受害。”
    答言：“实尔，尊者。”
    舍利弗语焰摩迦比丘：“于意云何？彼长者本知彼人诈亲欲害，善自防护，不受害耶？”
    答言：“如是，尊者舍利弗。”
    “如是焰摩迦比丘，愚痴无闻凡夫于五受阴，作常想、安隐想、不病想、我想、我所想，于此五受阴保持护惜，终为此五受阴怨家所害。如彼长者，为诈亲怨家所害，而不觉知。焰摩迦，多闻圣弟子于此五受阴，观察如病、如痈、如刺、如杀，无常、苦、空、非我、非我所。于此五受阴不著、不受，不受故不著，不著故自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    尊者舍利弗说是法时，焰摩迦比丘不起诸漏，心得解脱。
    尊者舍利弗为焰摩迦比丘说法，示教照喜已，从座起去。

（一○五）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时有外道出家名仙尼，来诣佛所，恭敬问讯，于一面坐，白佛言：“世尊，先一日时，若沙门、若婆罗门、若遮罗迦、若出家，集于希有讲堂，如是义称：‘富兰那迦叶为大众主，五百弟子前后围绕，其中有极聪慧者、有钝根者，及其命终，悉不记说其所往生处。复有末迦梨瞿舍利子为大众主，五百弟子前后围绕，其诸弟子有聪慧者、有钝根者，及其命终，悉不记说所往生处。如是先阇那毗罗胝子、阿耆多翅舍钦婆罗、迦罗拘陀迦栴延、尼揵陀若提子等，各与五百弟子前后围绕，亦如前者。’沙门瞿昙，尔时亦在彼论中言：‘沙门瞿昙为大众主，其诸弟子有命终者，即记说言：某生彼处、某生此处。’我先生疑，云何沙门瞿昙得如此法？”
    佛告仙尼：“汝莫生疑。以有惑故，彼则生疑。仙尼当知，有三种师。何等为三？有一师，见现在世真实是我，如所知说，而无能知命终后事，是名第一师出于世间。复次仙尼，有一师，见现在世真实是我，命终之后亦见是我，如所知说。复次仙尼，有一师，不见现在世真实是我，亦复不见命终之后真实是我。仙尼，其第一师见现在世真实是我，如所知说者，名曰断见。彼第二师见今世后世真实是我，如所知说者，则是常见。彼第三师不见现在世真实是我，命终之后亦不见我，是则如来、应、等正觉说，现法爱断、离欲、灭尽、涅槃。”
    仙尼白佛言：“世尊，我闻世尊所说，遂更增疑。”
    佛告仙尼：“正应增疑。所以者何？此甚深处，难见难知。应须甚深照微妙，至到聪慧所了。凡众生类，未能辩知。所以者何？众生长夜异见、异忍、异求、异欲故。”
    仙尼白佛言：“世尊，我于世尊所，心得净信。唯愿世尊为我说法，令我即于此座，慧眼清净。”
    佛告仙尼：“今当为汝随所乐说。”
    佛告仙尼：“色是常耶，为无常耶？”
    答言：“无常，世尊。”
    复问：“仙尼，若无常者，是苦耶？”
    答言：“是苦，世尊。”
    复问仙尼：“若无常、苦，是变易法。多闻圣弟子宁于中见我、异我、相在不？”
    答言：“不也，世尊。”
    受、想、行、识，亦复如是。
    复问：“云何仙尼，色是如来耶？”
    答言：“不也，世尊。”
    “受、想、行、识是如来耶？”
    答言：“不也，世尊。”
    复问：“仙尼，异色有如来耶？异受、想、行、识有如来耶？”
    答言：“不也，世尊。”
    复问：“仙尼，色中有如来耶？受、想、行、识中有如来耶？”
    答言：“不也，世尊。”
    复问：“仙尼，如来中有色耶？如来中有受、想、行、识耶？”
    答言：“不也，世尊。”
    复问：“仙尼，非色、非受、想、行、识有如来耶？”
    答言：“不也，世尊。”
    佛告仙尼：“我诸弟子，闻我所说，不悉解义，而起慢无间等。非无间等故，慢则不断。慢不断故，舍此阴已，与阴相续生。是故仙尼，我则记说，是诸弟子身坏命终，生彼彼处。所以者何？以彼有余慢故。
    “仙尼，我诸弟子，于我所说能解义者，彼于诸慢得无间等。得无间等故，诸慢则断。诸慢断故，身坏命终，更不相续。仙尼，如是弟子，我不说彼舍此阴已，生彼彼处。所以者何？无因缘可记说故。欲令我记说者，当记说彼：断诸爱欲，永离有结，正意解脱，究竟苦边。我从昔来及今现在，常说慢过、慢集、慢生、慢起，若于慢无间等，观众苦不生。”
    佛说此法时，仙尼出家远尘离垢，得法眼净。尔时仙尼出家见法、得法，断诸疑惑，不由他知，不由他度，于正法中，心得无畏。从座起，合掌白佛言：“世尊，我得于正法中出家修梵行不？”
    佛告仙尼：“汝于正法得出家，受具足戒，得比丘分。”
    尔时仙尼得出家已，独一静处，修不放逸住。如是思惟，所以族姓子剃除须发，正信非家，出家学道，修行梵行，见法自知得证：我生已尽，梵行已立，所作已作，自知不受后有，得阿罗汉。闻佛所说，欢喜奉行。

（一○六）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时有比丘名阿[少/兔]罗度，住耆阇崛山。
    时有众多外道出家，往诣阿[少/兔]罗度所，共相问讯。共相问讯已，于一面住，白阿[少/兔]罗度言：“欲有所问，宁有闲暇为解释不？”
    阿[少/兔]罗度语诸外道言：“随所欲问，知者当答。”
    诸外道复问：“云何尊者，如来死后为有耶？”
    阿[少/兔]罗度言：“如世尊说，此是无记。”
    又问：“如来死后为无耶？”
    阿[少/兔]罗度言：“如世尊说，此亦无记。”
    又问：“如来死后有无耶？非有非无耶？”
    阿[少/兔]罗度言：“如世尊说，此亦无记。”
    复问阿[少/兔]罗度言：“云何尊者，如来死后有耶，说言无记？死后无耶，说言无记？死后有无耶，非有非无耶，说言无记？云何尊者，沙门瞿昙为不知不见耶？”
    阿[少/兔]罗度言：“世尊非不知，非不见。”
    时诸外道于阿[少/兔]罗度所说，心不喜悦，呵骂已，从座起去。
    时阿[少/兔]罗度知诸外道去已，往诣佛所，稽首佛足，于一面住。以诸外道所问，向佛广说。白佛言：“世尊，彼如是问，我如是答。为顺诸法说耶？得无谤世尊耶？为顺法耶？为违法耶？无令他来难诘，堕呵责处耶？”
    佛告阿[少/兔]罗度言：“我今问汝，随所问答。阿[少/兔]罗度，色为常耶，为无常耶？”
    答言：“无常。”
    “受、想、行、识，为常、无常耶？”
    答言：“无常，世尊。”
    如《焰摩迦契经》广说，乃至：“识是如来耶？”
    答曰：“不也。”
    佛告阿[少/兔]罗度：“作如是说者，随顺诸说，不谤如来，非为越次，如如来说，诸次法说，无有能来难诘诃责者。所以者何？我于色如实知，色集、色灭、色灭道迹如实知。阿[少/兔]罗度，若舍如来，所作无知无见说者，此非等说。”
    佛说此经已，阿[少/兔]罗度闻佛所说，欢喜奉行。

（一○七）

    如是我闻。一时佛住婆祇国设首婆罗山鹿野深林中。
    尔时有那拘罗长者，百二十岁，年耆根熟，羸劣苦病，而欲觐见世尊及先所宗重知识比丘。来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我年衰老，羸劣苦病，自力勉励，觐见世尊及先所宗重知识比丘。唯愿世尊为我说法，令我长夜安乐。”
    尔时世尊告那拘罗长者：“善哉长者！汝实年耆根熟，羸劣苦患，而能自力觐见如来，并余宗重知识比丘。长者当知，于苦患身，常当修学不苦患身。”
    尔时世尊为那拘罗长者示教照喜已，默然而住。
    那拘罗长者闻佛所说，欢喜随喜，礼佛而去。
    时尊者舍利弗去世尊不远，坐一树下。那拘罗长者往诣尊者舍利弗所，稽首礼足，退坐一面。时尊者舍利弗问长者言：“汝今诸根和悦，貌色鲜明。于世尊所，得闻深法耶？”
    那拘罗长者白舍利弗：“今日世尊为我说法，示教照喜，以甘露法，灌我身心。是故我今诸根和悦，颜貌鲜明。”
    尊者舍利弗问长者言：“世尊为汝说何等法，示教照喜，甘露润泽？”
    那拘罗长者白舍利弗：“我向诣世尊所，白世尊言：‘我年衰老，羸劣苦患，自力而来，觐见世尊及所宗重知识比丘。’佛告我言：‘善哉长者！汝实衰老，羸劣苦患，而能自力诣我，及见先所宗重比丘。汝今于此苦患之身，常当修学不苦患身。’世尊为我说如是法，示教照喜，甘露润泽。”
    尊者舍利弗问长者言：“汝向何不重问世尊，云何苦患身，苦患心？云何苦患身，不苦患心？”
    长者答言：“我以是义故，来诣尊者，唯愿为我略说法要。”
    尊者舍利弗语长者言：“善哉长者！汝今谛听，当为汝说。愚痴无闻凡夫于色集、色灭、色患、色味、色离不如实知，不如实知故，爱乐于色，言色是我、是我所，而取摄受。彼色若坏、若异，心识随转，恼苦生。恼苦生已，恐怖、障碍、顾念、忧苦、结恋。于受、想、行、识，亦复如是。是名身、心苦患。
    “云何身苦患、心不苦患？多闻圣弟子于色集、色灭、色味、色患、色离如实知，如实知已，不生爱乐，见色是我、是我所。彼色若变、若异，心不随转恼苦生。心不随转恼苦生已，得不恐怖、障碍、顾念、结恋。受、想、行、识，亦复如是。是名身苦患，心不苦患。”
    尊者舍利弗说是法时，那拘罗长者得法眼净。尔时那拘罗长者见法、得法、知法、入法，度诸狐疑，不由于他，于正法中，心得无畏。从座起，整衣服，恭敬合掌，白尊者舍利弗：“我已超、已度，我今归依佛、法、僧宝，为优婆塞，证知我！我今尽寿归依三宝。”
    尔时那拘罗长者闻尊者舍利弗所说，欢喜随喜，作礼而去。

（一○八）

    如是我闻。一时佛住释氏天现聚落。
    尔时有西方众多比丘，欲还西方安居，诣世尊所，稽首佛足，退坐一面。
    尔时世尊为其说法，示教照喜。种种示教照喜已，时西方众多比丘从座起，合掌白佛言：“世尊，我西方众多比丘，欲还西方安居，今请奉辞。”
    佛告西方诸比丘：“汝辞舍利弗未？”
    答言：“未辞。”
    佛告西方诸比丘：“舍利弗淳修梵行，汝当奉辞，能令汝等以义饶益，长夜安乐。”
    时西方诸比丘，辞退欲去。
    时尊者舍利弗去佛不远，坐一坚固树下。西方诸比丘往诣尊者舍利弗所，稽首礼足，退坐一面，白尊者舍利弗言：“我等欲还西方安居，故来奉辞。”
    舍利弗言：“汝等辞世尊未？”
    答言：“已辞。”
    舍利弗言：“汝等还西方，处处异国，种种异众，必当问汝。汝等今于世尊所，闻善说法，当善受、善持、善观、善入，足能为彼具足宣说，不毁佛耶？不令彼众难问、诘责、堕负处耶？”
    彼诸比丘白舍利弗：“我等为闻法故，来诣尊者，唯愿尊者具为我说，哀愍故。”
    尊者舍利弗告诸比丘：“阎浮提人聪明利根，若刹利、若婆罗门、若长者、若沙门，必当问汝：‘汝彼大师云何说法？以何教授？’汝当答言：‘大师唯说调伏欲贪，以此教授。’当复问汝：‘于何法中调伏欲贪？’当复答言：‘大师唯说于彼色阴调伏欲贪，于受、想、行、识阴调伏欲贪，我大师如是说法。’彼当复问：‘欲贪有何过患故，大师说于色调伏欲贪，受、想、行、识调伏欲贪？’汝复应答言：‘若于色欲不断、贪不断、爱不断、念不断、渴不断者，彼色若变、若异，则生忧悲恼苦。受、想、行、识，亦复如是。见欲贪有如是过故，于色调伏欲贪，于受、想、行、识调伏欲贪。’彼复当问：‘见断欲贪有何福利故，大师说于色调伏欲贪，于受、想、行、识调伏欲贪？’当复答言：‘若于色断欲、断贪、断念、断爱、断渴，彼色若变、若异，不起忧悲恼苦。受、想、行、识，亦复如是。’
    “诸尊，若受诸不善法因缘故，令得现法乐住，不苦、不碍、不恼、不热，身坏命终生于善处者；世尊终不说言当断诸不善法，亦不教人于佛法中修诸梵行，得尽苦边。以受诸不善法因缘故，令现法苦住，障碍热恼，身坏命终堕恶道中；是故世尊说言当断不善法，于佛法中修诸梵行，平等尽苦，究竟苦边。若受诸善法因缘，现法苦住，障碍热恼，身坏命终堕恶道中者；世尊终不说受持善法，于佛法中修诸梵行，平等尽苦，究竟苦边。受持善法，现法乐住，不苦、不碍、不恼、不热，身坏命终生于善处；是故世尊赞叹教人受诸善法，于佛法中修诸梵行，平等尽苦，究竟苦边。”
    尊者舍利弗说是法时，西方诸比丘不起诸漏，心得解脱。
    尊者舍利弗说是法时，诸比丘欢喜随喜，作礼而去。

（一○九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“譬如池水方五十由旬，深亦如是，其水盈满。复有士夫，以毛以草，或以指爪，以滴彼水。诸比丘，于意云何？彼士夫水滴为多，池水为多？”
    比丘白佛：“彼士夫以毛以草，或以指爪，所滴之水，少少不足言。池水甚多，百千万倍，不可为比。”
    “如是诸比丘，见谛者所断众苦，如彼池水，于未来世永不复生。”
    尔时世尊说是法已，入室坐禅。
    时尊者舍利弗于众中坐，世尊入室去后，告诸比丘：“未曾所闻！世尊今日善说池譬。所以者何？圣弟子具足见谛，得无间等果。若凡俗邪见、身见根本、身见集、身见生、身见起，谓忧戚隐覆，庆吉保惜，说我、说众生、说奇特矜举。如是众邪，悉皆除灭，断除根本，如折多罗树，于未来世更不复生。诸比丘，何等为见谛圣弟子，断上众邪，于未来世永不复起？
    “愚痴无闻凡夫见色是我、异我、我在色、色在我；见受、想、行、识，是我、异我、我在识、识在我。云何见色是我？得地一切入处正受观已，作是念：‘地即是我，我即是地，我及地唯一无二，不异不别。’如是水、火、风、青、黄、赤、白，一切入处正受观已，作是念：‘行即是我，我即是行，唯一无二，不异不别。’如是于一切入处，一一计我，是名色即是我。云何见色异我？若彼见受是我，见受是我已，见色是我所；或见想、行、识即是我，见色是我所。云何见我中色？谓见受是我，色在我中；又见想、行、识即是我，色在我中。云何见色中我？谓见受即是我，于色中住，入于色，周遍其四体；见想、行、识是我，于色中住，周遍其四体，是名色中我。
    “云何见受即是我？谓六受身，眼触生受，耳、鼻、舌、身、意触生受。此六受身，一一见是我，是名受即是我。云何见受异我？谓见色是我，受是我所；谓想、行、识是我，受是我所，是名受异我。云何见我中受？谓色是我，受在其中；想、行、识是我，受在其中，是谓我中受。云何见受中我？谓色是我，于受中住，周遍其四体；想、行、识是我，于受中住，周遍其四体，是名受中我。
    “云何见想即是我？谓六想身，眼触生想，耳、鼻、舌、身、意触生想。此六想身，一一见是我，是名想即是我。云何见想异我？谓见色是我，想是我所；受、行、识是我，想是我所，是名想异我。云何见我中想？谓色是我，想在中住；受、行、识是我，想在中住，是谓我中想。云何见想中我？谓色是我，于想中住，周遍其四体；受、行、识是我，于想中住，周遍其四体，是名想中我。
    “云何见行是我？谓六思身，眼触生思，耳、鼻、舌、身、意触生思。于此六思身，一一见是我，是名行即是我。云何见行异我？谓见色是我，行是我所；受、想、识是我，行是我所，是名行异我。云何见我中行？谓色是我，行在中住；受、想、识是我，行在中住，是谓我中行。云何见行中我？谓色是我，于行中住，周遍其四体；谓受、想、识是我，于行中住，周遍其四体，是名行中我。
    “云何见识即是我？谓六识身，眼识、耳、鼻、舌、身、意识身。于此六识身，一一见是我，是名识即是我。云何见识异我？谓见色是我，识是我所；见受、想、行是我，识是我所，是名识异我。云何见我中识？谓色是我，识在中住；受、想、行是我，识在中住，是名我中识。云何识中我？谓色是我，于识中住，周遍其四体；受、想、行是我，于识中住，周遍其四体，是名识中我。
    “如是圣弟子见四真谛，得无间等果，断诸邪见，于未来世永不复起。所有诸色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，一向积聚，作如是观：一切无常、一切苦、一切空、一切非我，不应爱乐、摄受、保持。受、想、行、识，亦复如是，不应爱乐、摄受、保持。如是观，善系心住，不愚于法。复观精进，离诸懈怠，心得喜乐，身心猗息，寂静舍住，具诸道品，修行满足，永离诸恶，非不消炀，非不寂灭。灭而不起，减而不增，断而不生，不取不著，自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    舍利弗说是法时，六十比丘不受诸漏，心得解脱。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一○）

    如是我闻。一时佛住毗舍离猕猴池侧。
    毗舍离国有尼揵子，聪慧明哲，善解诸论，有聪明慢，所广集诸论，妙智入微，为众说法，超诸论师。每作是念：“诸沙门、婆罗门无敌我者，乃至如来亦能共论。诸论师辈，闻我名者，头额津，腋下汗，毛孔流水。我论议风，能偃草折树，摧破金石，伏诸龙象。何况人间诸论师辈，能当我者？”
    时有比丘名阿湿波誓，晨朝着衣持钵，威仪详序，端视平涉，入城乞食。
    尔时萨遮尼揵子，有少缘事，诣诸聚落，从城门出。遥见比丘阿湿波誓，即诣其所，问言：“沙门瞿昙为诸弟子云何说法？以何等法教诸弟子，令其修习？”
    阿湿波誓言：“火种居士，世尊如是说法，教诸弟子，令随修学，言：‘诸比丘，于色当观无我，受、想、行、识当观无我。此五受阴，勤方便观，如病、如痈、如刺、如杀，无常、苦、空、非我。’”
    萨遮尼揵子闻此语，心不喜，作是言：“阿湿波誓，汝必误听，沙门瞿昙终不作是说。若沙门瞿昙作是说者，则是邪见，我当诣彼难诘令止。”
    尔时萨遮尼揵子往诣聚落，诸离车等集会之处，语诸离车言：“我今日见沙门瞿昙第一弟子，名阿湿波誓，薄共论议。若如其所说者，我当诣彼沙门瞿昙，与共论议，进却回转，必随我意。譬如士夫刈拔茇草，手执其茎，空中抖擞，除诸乱秽。我亦如是，与沙门瞿昙论议难诘，执其要领，进却回转，随其所欲，去其邪说。如沽酒家，执其酒囊，压取清醇，去其糟滓。我亦如是，诣沙门瞿昙，论义难诘，进却回转，取其清真，去诸邪说。如织席师，以席盛诸秽物，欲市卖时，以水洗泽，去诸臭秽。我亦如是，诣沙门瞿昙所，与共论议，进却回转，执其纲领，去诸秽说。譬如王家调象之师，牵大醉象，入深水中，洗其身体，四支、耳、鼻，周遍沐浴，去诸尘秽。我亦如是，诣沙门瞿昙所，论议难诘，进却回转，随意自在，执其要领，去诸秽说。汝诸离车，亦应共往观其得失。”
    中有离车作如是言：“若萨遮尼揵子能与沙门瞿昙共论议者，无有是处。”
    复有说言：“萨遮尼揵子聪慧利根，能共论议。”
    时有五百离车，与萨遮尼揵子共诣佛所，为论议故。
    尔时世尊于大林中，坐一树下，住于天住。
    时有众多比丘出房外，林中经行。遥见萨遮尼揵子来，渐渐诣诸比丘所，问诸比丘言：“沙门瞿昙住在何所？”
    比丘答言：“在大林中，依一树下，住于天住。”
    萨遮尼揵子即诣佛所，恭敬问讯，于一面坐。诸离车长者亦诣佛所，有恭敬者，有合掌问讯者，问讯已，于一面住。
    时萨遮尼揵子白佛言：“我闻瞿昙作如是说法，作如是教授诸弟子：教诸弟子于色观察无我，受、想、行、识观察无我。此五受阴，勤方便观察，如病、如痈、如刺、如杀，无常、苦、空、非我。为是瞿昙有如是教，为是传者毁瞿昙耶？如说说耶，不如说说耶？如法说耶，法次法说耶？无有异人来相难诘，令堕负处耶？”
    佛告萨遮尼揵子：“如汝所闻，彼如说说，如法说，法次法说，非为谤毁，亦无难问令堕负处。所以者何？我实为诸弟子如是说法，我实常教诸弟子，令随顺法教，令观色无我，受、想、行、识无我，观此五受阴如病，如痈、如刺、如杀，无常、苦、空、非我。”
    萨遮尼揵子白佛言：“瞿昙，我今当说譬。”
    佛告萨遮尼揵子：“宜知是时。”
    “譬如世间一切所作，皆依于地。如是色是我人，善恶从生；受、想、行、识是我人，善恶从生。又复譬如人众、神界、药草、树木，皆依于地而得生长。如是色是我人，受、想、行、识是我人。”
    佛告火种居士：“汝言色是我人，受、想、行、识是我人耶？”
    答言：“如是，瞿昙。色是我人，受、想、行、识是我人。此等诸众，悉作是说。”
    佛告火种居士：“且立汝论本，用引众人为？”
    萨遮尼揵子白佛言：“色实是我人。”
    佛告火种居士：“我今问汝，随意答我。譬如国王，于自国土有罪过者，若杀、若缚、若摈、若鞭、断绝手足。若有功者，赐其象、马、车乘、城邑、财宝。悉能尔不？”
    答言：“能尔，瞿昙。”
    佛告火种居士：“凡是主者，悉得自在不？”
    答言：“如是，瞿昙。”
    佛告火种居士：“汝言色是我，受、想、行、识即是我。得随意自在，令彼如是，不令如是耶？”
    时萨遮尼揵子默然而住。
    佛告火种居士：“速说速说，何故默然？”
    如是再三，萨遮尼揵子犹故默然。
    时有金刚力士鬼神，持金刚杵，猛火炽燃，在虚空中，临萨遮尼揵子头上，作是言：“世尊再三问汝，何故不答？我当以金刚杵碎破汝头，令作七分。”
    佛神力故，唯令萨遮尼揵子见金刚神，余众不见。萨遮尼揵子得大恐怖，白佛言：“不尔，瞿昙。”
    佛告萨遮尼揵子：“徐徐思惟，然后解说。汝先于众中说色是我，受、想、行、识是我。而今言不，前后相违。汝先常说言，色是我，受、想、行、识是我。火种居士，我今问汝，色为常耶，为无常耶？”
    答言：“无常，瞿昙。”
    复问：“无常者，是苦耶？”
    答言：“是苦，瞿昙。”
    复问：“无常、苦者，是变易法。多闻圣弟子宁于中见我、异我、相在不？”
    答曰：“不也，瞿昙。”
    受、想、行、识，亦如是说。
    佛告火种居士：“汝好思而后说。”
    复问火种居士：“若于色未离贪、未离欲、未离念、未离爱、未离渴，彼色若变、若异，当生忧悲恼苦不？”
    答曰：“如是，瞿昙。”
    受、想、行、识，亦如是说。
    复问火种居士：“于色离贪、离欲、离念、离爱、离渴，彼色若变、若异，则不生忧悲恼苦耶？”
    答曰：“如是，瞿昙，如实无异。”
    受、想、行、识，亦如是说。
    “火种居士，譬如士夫，身婴众苦，常与苦俱。彼苦不断不舍，当得乐不？”
    答言：“不也，瞿昙。”
    “如是火种居士，身婴众苦，常与苦俱。彼苦不断、不舍，不得乐也。火种居士，譬如士夫，持斧入山，求坚实材，见芭蕉树，洪大臃直，即断其根叶，剽剥其皮，乃至穷尽，都无坚实。火种居士，汝亦如是，自立论端。我今善求真实之义，都无坚实，如芭蕉树也。而于此众中，敢有所说。我不见沙门、婆罗门中，所知所见，能与如来、应、等正觉所知所见共论议，不摧伏者。而便自说：‘我论议风，偃草折树，能破金石，调伏龙象。要能令彼额津、腋汗、毛孔水流。’汝今自论己义，而不自立。先所夸说能伏彼相，今尽自取，而不能动如来一毛。”
    尔时世尊于大众中，披郁多罗僧，现胸而示：“汝等试看，能动如来一毛以不？”
    尔时萨遮尼揵子默然低头，惭愧失色。
    尔时众中有一离车，名突目佉，从座起，整衣服，合掌白佛言：“世尊，听我说譬。”
    佛告突目佉：“宜知是时。”
    突目佉白佛言：“世尊，譬如有人执持斗斛，于大聚谷中，取二三斛，今此萨遮尼揵子亦复如是。世尊，譬如长者巨富多财，忽有罪过，一切财物悉入王家。萨遮尼揵子亦复如是，所有才辩，悉为如来之所摄受。譬如城邑聚落边有大水，男女大小悉入水戏，取水中蟹，截断其足，置于陆地，以无足故，不能还复入于大水。萨遮尼揵子亦复如是，诸有才辩，悉为如来之所断截，终不复敢重诣如来，命敌论议。”
    尔时萨遮尼揵子忿怒炽盛，骂呵突目佉离车言：“汝粗疏物，不审谛，何为其鸣？吾自与沙门瞿昙论，何预汝事？”
    萨遮尼揵子呵骂突目佉已，复白佛言：“置彼凡辈鄙贱之说，我今别有所问。”
    佛告萨遮尼揵子：“恣汝所问，当随问答。”
    “云何瞿昙为弟子说法，令离疑惑？”
    佛告火种居士：“我为诸弟子说：诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切如实观察，非我、非异我、不相在。受、想、行、识，亦复如是。彼学必见迹，不断坏，堪任成就，厌离知见，守甘露门，虽非一切悉得究竟，具向涅槃。如是弟子从我教法，得离疑惑。”
    复问：“瞿昙复云何教诸弟子，于佛法得尽诸漏，无漏心解脱、慧解脱，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有？”
    佛告火种居士：“正以此法，诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切如实知非我、非异我、不相在。受、想、行、识，亦复如是。彼于尔时成就三种无上，智无上、道无上、解脱无上。成就三种无上已，于大师所，恭敬、尊重、供养如佛。世尊觉一切法，即以此法调伏弟子，令得安隐，令得无畏，调伏寂静，究竟涅槃。世尊为涅槃故，为弟子说法。火种居士，我诸弟子于此法中，得尽诸漏，得心解脱，得慧解脱，于现法中自知作证：我生已尽，梵行已立，所作已作，自知不受后有。”
    萨遮尼揵子白佛言：“瞿昙，犹如壮夫，锋刃乱下，犹可得免。瞿昙论手，难可得脱。如盛毒蛇，犹可得避；旷泽猛火，犹可得避；凶恶醉象，亦可得免；狂饿狮子，悉可得免。沙门瞿昙论议手中，难可得脱。非我凡品轻躁鄙夫，论具不备，以论议故，来诣瞿昙。沙门瞿昙！此毗舍离丰乐国土，有遮波梨支提、漆庵罗树支提、多子支提、瞿昙在拘楼陀支提、婆罗受持支提、舍重担支提、力士宝冠支提。世尊，当安乐于此毗舍离国，诸天、魔、梵、沙门、婆罗门，及诸世间，于世尊所，常得恭敬、奉事、供养，令此诸天、魔、梵、沙门、婆罗门，长夜安乐。唯愿止此！明朝与诸大众，受我薄食。”
    尔时世尊默然而许。
    时萨遮尼揵子知佛世尊默然受请已，欢喜随喜，从座起去。
    尔时萨遮尼揵子于彼道中，语诸离车：“我已请沙门瞿昙及诸大众，供设饭食。汝等人各办一釜食，送至我所。”
    诸离车各还其家，星夜供办，晨朝送至萨遮尼揵子所。萨遮尼揵子晨朝洒扫敷座，供办净水，遣使诣佛，白言：“时到。”
    尔时世尊与诸大众着衣持钵，往萨遮尼揵子所，大众前坐。萨遮尼揵子自手奉施清净饮食，充足大众。食已，洗钵竟。萨遮尼揵子知佛食竟，洗钵已，取一卑床，于佛前坐。
    尔时世尊为萨遮尼揵子说随喜偈言：

“于诸大会中，奉火为其最；
闱陀经典中，婆毗谛为最；
人中王为最，诸河海为最；
诸星月为最，诸明日为最；
十方天人中，等正觉为最！”

    尔时世尊为萨遮尼揵子种种说法，示教照喜已，还归本处。
    时诸比丘于彼道中，众共论议：“五百离车各为萨遮尼揵子供办饮食，彼诸离车于何得福？萨遮尼揵子于何得福？”
    尔时诸比丘还自住处，举衣钵，洗足已，至世尊所，头面礼足，退坐一面，白佛言：“世尊，我等向于路中自共论议：五百离车为萨遮尼揵子供办饮食，供养世尊、诸大众，彼诸离车于何得福？萨遮尼揵子于何得福？”
    佛告诸比丘：“彼诸离车供办饮食，为萨遮尼揵子，于萨遮尼揵子所因缘得福。萨遮尼揵子得福，佛功德。彼诸离车得施有贪恚痴因缘果报，萨遮尼揵子得施无贪恚痴因缘果报。”

彼多罗十问，差摩焰仙尼，
阿[少/兔]罗长者，西毛端萨遮。


杂阿含经卷第六

（一一一）

    如是我闻。一时佛住摩拘罗山。
    时有侍者比丘名曰罗陀，晡时从禅觉，往诣佛所，礼佛足，退坐一面，白佛言：“如世尊说有流，云何名有流？云何名有流灭？”
    佛告罗陀：“善哉所问！当为汝说。所谓有流者，愚痴无闻凡夫于色集、色灭、色味、色患、色离不如实知，不如实知故，于色爱乐、赞叹、摄受、染著。缘爱乐色故取，缘取故有，缘有故生，缘生故老病死、忧悲恼苦增，如是纯大苦聚斯集起。受、想、行、识，亦复如是。是名有流。
    “多闻圣弟子于色集、色灭、色味、色患、色离如实知，如实知故，于彼色不起爱乐、赞叹、摄受、染著。不爱乐、赞叹、摄受、染著故，色爱则灭，爱灭则取灭，取灭则有灭，有灭则生灭，生灭则老病死、忧悲恼苦灭，如是纯大苦聚灭。受、想、行、识，亦复如是。是名如来所说有流、有流灭。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。

（一一二）

    如是我闻。一时佛住摩拘罗山。
    时有侍者比丘名罗陀，晡时从禅觉，往诣佛所，礼佛足，退坐一面，白佛言：“世尊，如世尊说色断知，受、想、行、识断知。世尊，云何色断知，受、想、行、识断知？”
    佛告罗陀：“善哉所问！当为汝说。于色忧悲苦恼尽、离欲、灭、息、没，是名色断知。于受、想、行、识，忧悲恼苦尽、离欲、灭、息、没，是名受、想、行、识断知。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。

（一一三）

    如是我闻。一时佛住摩拘罗山。时有侍者比丘名曰罗陀。
    时有众多外道出家，诣尊者罗陀所，共相问讯已，退坐一面，问尊者罗陀言：“汝何故于沙门瞿昙所出家修梵行？”
    尊者罗陀答言：“我为断苦故，于世尊所出家修梵行。”
    复问：“汝为断何等苦故，于沙门瞿昙所出家修梵行？”
    罗陀答言：“为断色苦故，于世尊所出家修梵行。断受、想、行、识苦故，于世尊所出家修梵行。”
    时诸外道出家闻尊者罗陀所说，心不喜，从座起，呵骂而去。
    尔时尊者罗陀，知诸外道出家去已，作是念：“我向如是说，将不毁谤世尊耶？如说说耶？如法说、法次法说耶？将不为他难问诘责，堕负处耶？”
    尔时尊者罗陀，晡时从禅觉，往诣佛所，稽首佛足，却坐一面，以其上事具白佛言：“世尊，我向所说，得无过耶？将不毁谤世尊耶？不为他人难问诘责，堕负处耶？如说说耶？如法说、法次法说耶？”
    佛告罗陀：“汝成实说，不毁如来，如说说，如法说，法次法说。所以者何？罗陀，色苦，为断彼苦故，出家修梵行。受、想、行、识苦，为断彼苦故，出家修梵行。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。

（一一四）

    如是我闻。一时佛住摩拘罗山。时有侍者比丘名曰罗陀。
    时有众多外道出家至尊者罗陀所，共相问讯已，退坐一面，问罗陀言：“汝为何等故，于沙门瞿昙所出家修梵行？”
    罗陀答言：“我为知苦故，于世尊所出家修梵行。”
    时诸外道闻罗陀所说，心不喜，从座起，呵骂而去。
    尔时罗陀，晡时从禅觉，往诣佛所，稽首佛足，退坐一面，以其上事具白佛言：“世尊，我向所说，得无毁谤世尊耶？将不令他难问诘责，堕负处耶？不如说说，非如法说，非法次法说耶？”
    佛告罗陀：“汝真实说，不毁如来，不令他人难问诘责堕负处也，是如说说，如法说，法次法说。所以者何？色是苦，为知彼苦故，于如来所出家修梵行。受、想、行、识是苦，为知彼苦故，于如来所出家修梵行。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。

（一一五）

    如是我闻。一时佛住摩拘罗山。时有侍者比丘名曰罗陀。
    时有众多外道出家至尊者罗陀所，共相问讯已，退坐一面，问罗陀言：“汝为何等故，于沙门瞿昙所出家修梵行？”
    罗陀答言：“为于色忧悲恼苦，尽、离欲、灭、寂、没故，于如来所出家修梵行。为于受、想、行、识忧悲恼苦，尽、离欲、灭、寂、没故，于如来所出家修梵行。”
    尔时众多外道出家闻是已，心不喜，从座起，呵骂而去。
    尔时罗陀，晡时从禅觉，往诣佛所，稽首礼足，退坐一面，以其上事具白佛言：“世尊，我得无谤世尊耶？不令他人来难问诘责堕负处耶？不如说说，非如法说，非法次法说耶？”
    佛告罗陀：“汝真实说，不谤如来，不令他人难问诘责堕负处也，如说说，如法说，法次法说。所以者何？罗陀，色忧悲恼苦，为断彼故，于如来所出家修梵行。受、想、行、识忧悲恼苦，为断彼故，于如来所出家修梵行。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。

（一一六）

    如是我闻。一时佛住摩拘罗山。时有侍者比丘名曰罗陀。
    时有众多外道出家至罗陀所，共相问讯已，退坐一面，问罗陀比丘言：“汝何故于沙门瞿昙所出家修梵行？”
    罗陀答言：“于色见我、我所、我慢使系著，彼若尽、离欲、灭、寂、没；于受、想、行、识，见我、我所、我慢使系著，彼若尽、离欲、灭、寂、没故，于世尊所出家修梵行。”
    诸外道出家闻是语，心不喜，从座起，呵骂而去。
    罗陀比丘，晡时从禅觉，往诣佛所，稽首礼足，退坐一面，以其上事具白佛言：“世尊，我之所说，得无毁谤世尊耶？不令他人难问诘责堕负处耶？不如说说，不如法说，非法次法说耶？”
    佛告罗陀：“汝真实说，不谤如来，不令他人难问诘责堕负处也，是如说说，如法说，法次法说。所以者何？于色见我、我所、我慢使系著，彼若尽、离欲、灭、寂、没故；受、想、行、识，见我、我所、我慢使系著，彼若尽、离欲、灭、寂、没故，于如来所出家修梵行。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。

（一一七）

    如是我闻。一时佛住摩拘罗山。时有侍者比丘名曰罗陀。
    时有众多外道出家至罗陀所，共相问讯已，退坐一面，问罗陀言：“汝何故于沙门瞿昙所出家修梵行？”
    罗陀答言：“于色有漏、障碍、热恼、忧悲，彼若尽、离欲、灭、寂、没；受、想、行、识，有漏、障碍、热恼、忧悲，彼若尽、离欲、灭、寂、没故，于如来所出家修梵行。”
    时众多外道出家闻是已，心不喜，从座起，呵骂而去。
    尔时罗陀，晡时从禅觉，往诣佛所，稽首佛足，退坐一面，以其上事具白佛言：“世尊，我之所说，将无谤世尊耶？不令他人难问诘责堕负处耶？不如说说，不如法说，非法次法说耶？”
    佛告罗陀：“汝真实说，不谤如来，不令他人难问诘责堕负处也，如说说，如法说，法次法说。所以者何？色有漏、有障碍、热恼、忧悲，彼若尽、离欲、灭、寂、没；受、想、行、识，有漏、障碍、热恼、忧悲，彼若尽、离欲、灭、寂、没故，于如来所出家修梵行。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。

（一一八）

    如是我闻。一时佛住摩拘罗山。时有侍者比丘名曰罗陀。
    时有外道出家至罗陀所，共相问讯已，退坐一面，问罗陀言：“汝何故于沙门瞿昙所出家修梵行？”
    罗陀答言：“于色贪、恚、痴，彼若尽、离欲、灭、寂、没；于受、想、行、识，贪、恚、痴，彼若尽、离欲、灭、寂、没，于如来所出家修梵行。”
    诸外道闻是语已，心不喜，从座起，呵骂而去。
    罗陀比丘晡时从禅觉，往诣佛所，稽首佛足，退坐一面，以其上事具白佛言：“世尊，我之所说，将无谤世尊耶？不令他人难问诘责堕负处耶？不如说说，不如法说，非法次法说耶？”
    佛告罗陀：“汝真实说，不谤如来，不令他人难问诘责堕负处也，如说说，如法说，法次法说。所以者何？于色贪、恚、痴，彼若尽、离欲、灭、寂、没；于受、想、行、识，贪、恚、痴，彼若尽、离欲、灭、寂、没故，于如来所出家修梵行。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。

（一一九）

    如是我闻。一时佛住摩拘罗山。时有侍者比丘名曰罗陀。
    时有众多外道出家至罗陀所，共相问讯已，退坐一面，问罗陀言：“汝何故于沙门瞿昙所出家修梵行？”
    罗陀答言：“于色欲、爱、喜，彼若尽、离欲、灭、寂、没；于受、想、行、识，欲、爱、喜，彼若尽、离欲、灭、寂、没故，于如来所出家修梵行。”
    时诸外道闻是语已，心不喜，从座起，呵骂而去。
    罗陀比丘晡时从禅觉，诣佛所，稽首佛足，退坐一面，以其上说具白佛言：“世尊，我之所说，不谤如来耶？不令他人难问诘责堕负处耶？不如说说，不如法说，非法次法说耶？”
    佛告罗陀：“汝真实说，不谤如来，不令他人难问呵责堕负处也，如说说、如法说、法次法说。所以者何？于色欲、爱、喜，彼若尽、离欲、灭、寂、没；于受、想、行、识，欲、爱、喜，彼若尽、离欲、灭、寂、没故，于如来所出家修梵行。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。

（一二○）

    如是我闻。一时佛住摩拘罗山。时有侍者比丘名曰罗陀。
    尔时世尊告罗陀言：“诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切当观皆是魔所作。诸所有受、想、行、识，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切当观皆是魔所作。”
    佛告罗陀：“色为常耶，为无常耶？”
    答曰：“无常，世尊。”
    复问：“若无常者，是苦耶？”
    答曰：“是苦，世尊。”
    受、想、行、识，亦复如是。
    复问罗陀：“若无常、苦者，是变易法。多闻圣弟子宁于中见色是我、异我、相在不？”
    答曰：“不也，世尊。”
    受、想、行、识，亦复如是。
    佛告罗陀：“若多闻圣弟子，于此五受阴，不见是我、是我所故，于诸世间都无所取，无所取故无所著，无所著故自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。

（一二一）

    如是我闻。一时佛住摩拘罗山。时有侍者比丘名曰罗陀。
    尔时世尊告罗陀比丘言：“诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切皆是死法。所有受、想、行、识，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切皆是死法。”
    佛告罗陀：“色为常耶，为无常耶？”
    答曰：“无常，世尊。”
    复问：“若无常者，是苦耶？”
    答曰：“是苦，世尊。”
    “受、想、行、识，为常、为无常耶？”
    答曰：“无常，世尊。”
    复问：“若无常者，是苦耶？”
    答曰：“是苦，世尊。”
    复问：“若无常、苦者，是变易法。多闻圣弟子宁于中见是我、异我、相在不？”
    答曰：“不也，世尊。”
    佛告罗陀：“若多闻圣弟子，于此五受阴，如实观察非我、非我所者，于诸世间都无所取，无所取者无所著，无所著故自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。

（一二二）

    如是我闻。一时佛住摩拘罗山。
    时有侍者比丘名曰罗陀，白佛言：“世尊，所谓众生者，云何名为众生？”
    佛告罗陀：“于色染著缠绵，名曰众生。于受、想、行、识染著缠绵，名曰众生。”
    佛告罗陀：“我说于色境界当散坏消灭，于受、想、行、识境界当散坏消灭，断除爱欲，爱尽则苦尽，苦尽者我说作苦边。譬如聚落中，诸小男小女嬉戏，聚土作城郭宅舍，心爱乐著，爱未尽、欲未尽、念未尽、渴未尽，心常爱乐守护，言：‘我城郭，我舍宅。’若于彼土聚爱尽、欲尽、念尽、渴尽，则以手拨足蹈，令其消散。如是罗陀，于色散坏消灭，爱尽，爱尽故苦尽，苦尽故我说作苦边。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。

（一二三）

    如是我闻。一时佛住摩拘罗山。
    时有侍者比丘名曰罗陀，往诣佛所，稽首礼足，退坐一面，白佛言：“善哉世尊！为我略说法要，我闻法已，我当独一静处，专心思惟，不放逸住。所以族姓子剃除须发，身着染衣，正信非家，出家学道，增加精进，修诸梵行，见法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。”
    尔时世尊告罗陀曰：“善哉罗陀！能于佛前问如是义，谛听善思，当为汝说。罗陀，当知有身、有身集、有身灭、有身灭道迹。何等为有身？谓五受阴，色受阴，受、想、行、识受阴。云何有身集？谓当来有爱，贪喜俱，于彼彼爱乐，是名有身集。云何有身灭？谓当有爱，喜贪俱，彼彼爱乐，无余断，舍、吐、尽、离欲、寂、没，是名有身尽。云何有身灭道迹？谓八正道，正见、正志、正语、正业、正命、正方便、正念、正定，是名有身灭道迹。有身当知，有身集当断，有身灭当证，有身灭道迹当修。罗陀，若多闻圣弟子，于有身若知、若断，有身集若知、若断，有身灭若知、若证，有身灭道迹若知、若修已，罗陀，名断爱、离爱、转结、止慢无间等，究竟苦边。”
    罗陀比丘闻佛所说，欢喜奉行，从座起，作礼而去。
    世尊如是教授已，罗陀比丘独一静处，专精思惟，所以善男子剃除须发，着染色衣，正信非家，出家学道，增益精进，修诸梵行，见法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。成阿罗汉，心善解脱。
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。

（一二四）

    如是我闻。一时佛住摩拘罗山。时有侍者比丘名曰罗陀。
    尔时世尊告罗陀比丘言：“诸比丘，有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切当观皆是魔。受、想、行、识，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切当观皆是魔。罗陀，于意云何，色为常耶，为无常耶？”
    答曰：“无常，世尊。”
    “若无常者，是苦耶？”
    答曰：“是苦，世尊。”
    “若无常、苦者，是变易法。多闻圣弟子宁于中见我不？”
    答曰：“不也，世尊。”
    “受、想、行、识，亦复如是。是故罗陀，多闻圣弟子于色生厌，于受、想、行、识生厌，厌故不乐，不乐故解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。

（一二五）

    如是我闻。一时佛住摩拘罗山。时有侍者比丘名曰罗陀。
    尔时世尊告罗陀比丘言：“诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切皆是魔所作。受、想、行、识，亦复如是。”
    佛告罗陀：“于意云何，色是常耶？为非常耶？”
    答曰：“无常，世尊。”
    复问：“若无常者，是苦耶？”
    答曰：“是苦，世尊。”
    复问：“受、想、行、识为是常耶，为无常耶？”
    答曰：“无常，世尊。”
    复问：“若无常者，是苦耶？”
    答曰：“是苦，世尊。”
    佛告罗陀：“若无常、苦者，是变易法。多闻圣弟子宁于中见我、异我、相在不？”
    答曰：“不也，世尊。”
    “是故罗陀，多闻圣弟子于色生厌，厌故不乐；于受、想、行、识生厌，厌故不乐，不乐故解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。

    第三经亦如是。所异者，佛告罗陀：“多闻圣弟子，于此五受阴，观察非我、非我所。观察已，于诸世间都无所取，不取故不著，不著故自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。

（一二六）

    如是我闻。一时佛住摩拘罗山。时有侍者比丘名曰罗陀。
    尔时世尊告罗陀言：“诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，当观彼一切皆是死法。受、想、行、识，亦复如是。”
    余如前说。

（一二七）

    如是我闻。一时佛住摩拘罗山。时有侍者比丘名曰罗陀。
    尔时世尊告罗陀言：“诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切当观皆是断法。受、想、行、识，亦复如是。多闻圣弟子如是观者，于色生厌，于受、想、行、识生厌，厌故不乐，不乐故解脱，解脱知见，自知我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。
    如是我观察断法，如是观察灭法、观察弃舍法、观察无常法、观察苦法、观察空法、观察非我法、观察无常、苦、空、非我法、观察病法、观察痈法、观察刺法、观察杀法、观察杀根本法、观察病、痈、刺、杀、杀根本法，如是诸经，皆如上说。

（一二八）

    如是我闻。一时佛住摩拘罗山。时有侍者比丘名曰罗陀。
    尔时世尊告罗陀言：“诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切当观皆是断法。观察已，于色欲贪断，欲贪断已，我说心善解脱。受、想、行、识，亦复如是。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。
    如是比，十四经亦如上说。

（一二九）

    如是我闻。一时佛住摩拘罗山。时有侍者比丘名曰罗陀。
    尔时世尊告罗陀言：“诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切当观皆是断法。观察断法已，于色欲贪断，欲贪断已，我说心善解脱。受、想、行、识，亦复如是。”
    佛说此经已，罗陀比丘闻佛所说，欢喜奉行。

（一三○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“欲断五受阴者，当求大师。何等为五？谓色受阴，受、想、行、识受阴。欲断此五受阴，当求大师。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如当断，如是当知、当吐、当息、当舍，亦复如是。
    如求大师，如是胜师者、顺次师者、教诫者、胜教诫者、顺次教诫者、通者、广通者、圆通者、导者、广导者、究竟导者、说者、广说者、顺次说者、正者、伴者、真知识者、亲者、愍者、悲者、崇义者、安慰者、崇乐者、崇触者、崇安慰者、欲者、精进者、方便者、勤者、勇猛者、固者、强者、堪能者、专者、心不退者、坚执持者、常习者、不放逸者、和合者、思量者、忆念者、觉者、知者、明者、慧者、受者、思惟者、梵行者、念处者、正勤者、如意足者、根者、力者、觉分者、道分者、止者、观者、念身者、正忆念者，亦复如是。

（一三一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若沙门、婆罗门习于色者，随魔自在，入于魔手，随魔所欲，为魔所缚，不脱魔系。受、想、行、识，亦复如是。若沙门、婆罗门不习色，如是沙门、婆罗门不随魔自在，不入魔手，不随魔所欲，解脱魔缚，解脱魔系。受、想、行、识，亦复如是。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。
    如是习近者、习著者、味者、决定著者、止者、使者、往者、选择者、不舍者、不吐者，如是等沙门、婆罗门随魔自在，如上说。

（一三二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若沙门、婆罗门于色不习近者，不随魔自在，不入魔手，不随魔所欲，非魔缚所缚，解脱魔系。不习受、想、行、识，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    乃至吐色，亦复如是。

（一三三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令众生无明所盖，爱系其首，长道驱驰，生死轮回，生死流转，不知本际？”
    诸比丘白佛言：“世尊是法根、法眼、法依。善哉世尊！唯愿哀愍，广说其义，诸比丘闻已，当受奉行。”
    佛告比丘：“谛听善思，当为汝说。诸比丘，色有故，色事起、色系著、色见我，令众生无明所盖，爱系其首，长道驱驰，生死轮回，生死流转。受、想、行、识，亦复如是。诸比丘，色为常耶，为非常耶？”
    答曰：“无常，世尊。”
    复问：“若无常者，是苦耶？”
    答曰：“是苦，世尊。”
    “如是比丘，若无常者是苦，是苦有故，是事起、系著、见我，令众生无明所盖，爱系其头，长道驱驰，生死轮回，生死流转。受、想、行、识，亦复如是。是故诸比丘，诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、非异我、不相在，是名正慧。受、想、行、识，亦复如是。如是见、闻、觉、识、求、得，随忆、随觉、随观，彼一切非我、非异我、不相在，是名正慧。若有见言有我、有世间、有此世，常、恒、不变易法，彼一切非我、非异我、不相在，是名正慧。若复有见，非此我、非此我所、非当来我、非当来我所，彼一切非我、非异我、不相在，是名正慧。若多闻圣弟子，于此六见处，观察非我、非我所。如是观者，于佛所狐疑断，于法、于僧狐疑断，是名比丘多闻圣弟子不复堪任作身、口、意业，趣三恶道；正使放逸，圣弟子决定向三菩提，七有天人往来，作苦边。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一三四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“多闻圣弟子，于此六见处，观察非我、非我所。如是观者，于苦狐疑断，于集、灭、道狐疑断，是名比丘多闻圣弟子，不复堪任作身、口、意业，趣三恶道。如是广说，乃至作苦边。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一三五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：广说如上，差别者：“若多闻圣弟子，于此六见处，观察非我、非我所。如是观者，于佛狐疑断，于法、僧、苦、集、灭、道狐疑断。如是广说，乃至作苦边。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一三六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于何所是事有故，何所起？何所系著？何所见我？诸比丘，令彼众生无明所盖，爱系其首，长道驱驰，生死轮回，生死流转，不知本际？”
    诸比丘白佛：“世尊是法根、法眼、法依。善哉世尊！唯愿哀愍，广说其义，诸比丘闻已，当受奉行。”
    佛告诸比丘：“谛听善思，当为汝说。诸比丘，色有故，是色事起、于色系著、于色见我，令众生无明所盖，爱系其首，长道驱驰，生死轮回，生死流转。受、想、行、识，亦复如是。诸比丘，色是常耶，为非常耶？”
    答曰：“无常，世尊。”
    复问：“若无常者，是苦耶？”
    答曰：“是苦，世尊。”
    “如是比丘，若无常者是苦，是苦有故，是事起、系著、见我，令彼众生无明所盖，爱系其首，长道驱驰，生死轮回，生死流转。受、想、行、识，亦复如是。是故诸比丘，诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、非异我、不相在，如是观者，是名正慧。受、想、行、识，亦复如是。如是见、闻、觉、识、求、得，随忆、随觉、随观，彼一切非我、非异我、不相在，是名正慧。若有见言有我、有此世、有他世、有常、有恒、不变易，彼一切非我、非异我、不相在，是名正慧。若复有见非此我、非此我所、非当来我、非当来我所，彼一切非我、非异我、不相在，是名正慧。若多闻圣弟子，于此六见处，观察非我、非我所。如是观者，于佛狐疑断，于法、僧狐疑断。是名比丘不复堪任作身、口、意业，趣三恶道；正使放逸，诸圣弟子皆悉决定向于三菩提，七有天人往生，作苦后边。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一三七）

    第二经亦如是，差别者：“于苦、集、灭、道狐疑断。”

（一三八）

    第三经亦如是，差别者：“于佛、法、僧狐疑断，于苦、集、灭、道狐疑断。”


杂阿含经卷第七

（一三九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系？何所著？何所见我？若未起忧悲恼苦令起，已起忧悲恼苦重令增广？”
    诸比丘白佛言：“世尊是法根、法眼、法依，唯愿广说，诸比丘闻已，当受奉行。”
    佛告诸比丘：“色有故，色起、色系著，故于色见我，未起忧悲恼苦令起，已起忧悲恼苦重令增广。受、想、行、识，亦复如是。诸比丘，于意云何，色为常耶，为非常耶？”
    答曰：“无常，世尊。”
    复问：“若无常者，是苦耶？”
    答曰：“是苦，世尊。”
    “如是比丘，若无常者是苦，是苦有故，是事起、系著、见我，若未起忧悲恼苦令起，已起忧悲恼苦重令增广。受、想、行、识，亦复如是。是故诸比丘，诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、非异我、不相在，是名正慧。受、想、行、识，亦复如是。若复见、闻、觉、识、起、求，忆、随觉、随观，彼一切非我、非异我、不相在，是名正慧。若见有我、有世间、有此世、有他世，常、恒、不变易，彼一切非我、非异我、不相在，是名正慧。若复有见，非此世我、非此世我所、非当来我、非当来我所，彼一切非我、不异我、不相在，是名正慧。若多闻圣弟子，于此六见处，观察非我、非我所。如是观者，于佛狐疑断，于法、僧狐疑断，是名比丘多闻圣弟子不复堪任作身、口、意业，趣三恶道；正使放逸，圣弟子决定向三菩提，七有天人往来，作苦边。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一四○、一四一）

    次经亦如是，差别者：“苦、集、灭、道狐疑断。”
    次经亦如是，差别者：“佛、法、僧、苦、集、灭、道狐疑断。”

（一四二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？未起我、我所、我慢系著使起，已起我、我所、我慢系著使，重令增广？”
    诸比丘白佛：“世尊是法根、法眼、法依。”如是广说。
    乃至佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一四三、一四四）

    第二、第三经亦复如上。

（一四五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？若未起有漏、障碍、烧燃、忧悲恼苦生，已起有漏、障碍、烧燃、忧悲恼苦重令增广？”
    诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一四六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？若三受于世间转？”
    诸比丘白佛言：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一四七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令三苦世间转？”
    诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一四八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令世八法世间转？”
    诸比丘白佛言：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一四九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：我胜、我等、我卑？”
    诸比丘白佛言：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一五○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：有胜我者、有等我者、有卑我者。”
    诸比丘白佛言：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一五一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：无胜我者、无等我者、无卑我者？”
    诸比丘白佛言：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一五二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我，令诸众生作如是见、如是说：有我、有此世、有他世，常、恒、不变易法，如尔安住？”
    诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一五三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：如是我、彼，一切不二、不异、不灭？”
    诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一五四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：无施，无会，无说，无善趣、恶趣业报，无此世、他世，无母，无父，无众生，无世间阿罗汉正到正趣，若此世、他世，见法自知身作证具足住：我生已尽，梵行已立，所作已作，自知不受后有？”
    诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一五五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：无力、无精进、无力精进、无士夫方便、无士夫精勤、无士夫方便精勤，无自作、无他作、无自他作，一切人、一切众生、一切神，无方便、无力、无势、无精进、无堪能，定分相续转变，受苦乐六趣？”
    诸比丘白佛言：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一五六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：诸众生此世活，死后断坏无所有。四大和合士夫，身命终时，地归地、水归水、火归火、风归风、根随空转。舆床弟子四人，持死人往冢间，乃至未烧可知，烧燃已，骨白鸽色。立骄慢者知施，黠慧者知受，若说有者，彼一切虚诳妄说。若愚若智，死后他世，俱断坏无所有？”
    诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一五七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：众生烦恼，无因无缘？”
    诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一五八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：众生清净，无因无缘？”
    诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一五九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：众生无知无见，无因无缘？”
    时诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一六○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说？”
    时诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一六一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：谓七身，非作、非作所作、非化、非化所化、不杀、不动、坚实？何等为七？所谓地身、水身、火身、风身、乐、苦、命。此七种身，非作、非作所作、非化、非化所化、不杀、不动、坚实，不转、不变、不相逼迫。若福、若恶、若福恶，若苦、若乐、若苦乐，若士、枭士首，亦不逼迫。世间若命、若身，七身间间容刀往返，亦不害命，于彼无杀、无杀者，无系、无系者，无念、无念者，无教、无教者？”
    诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一六二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：作、教作，断、教断，煮、教煮，杀、教杀，害众生、盗他财、行邪淫、知言妄语、饮酒、穿墙、断锁、偷夺、复道、害村、害城、害人民，以极利剑轮，剬割斫截，作大肉聚。作如是学，彼非恶因缘，亦非招恶。于恒水南杀害而去，恒水北作大会而来，彼非因缘福恶，亦非招福恶。惠施、调伏、护持、行利、同利，于此所作，亦非作福？”
    诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一六三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：于此十四百千生门、六十千六百五业、三业、二业、一业、半业、六十二道迹、六十二内劫、百二十泥黎、百三十根、三十六贪界、四十九千龙家、四十九千金翅鸟家、四十九千邪命外道、四十九千外道出家、七想劫、七无想劫、七阿修罗、七毗舍遮、七天、七人、七百人、七梦、七百梦、七险、七百险、七觉、七百觉、六生、十增进、八大士地，于此八万四千大劫，若愚若智，往来经历，究竟苦边。彼无有沙门、婆罗门作如是说：我常持戒，受诸苦行，修诸梵行，不熟业者令熟，已熟业者弃舍，进退不可知。此苦乐常住，生死定量，譬如缕丸掷着空中，渐渐来下，至地自住。如是八万四千大劫生死定量，亦复如是？”
    诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一六四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：风不吹，火不燃，水不流，箭不射，怀妊不产，乳不搆，日月若出若没、若明若暗不可知。
    诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一六五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：此大梵自在，造作自然，为众生父？”
    诸比丘白佛言：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一六六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：色是我，余则虚名；无色是我，余则虚名；色非色是我，余则虚名；非色非无色是我，余则虚名；我有边，余则虚名；我无边，余则虚名；我有边无边，余则虚名；我非有边非无边，余则虚名；一想、种种想、多想、无量想，我一向乐、一向苦、苦乐、不苦不乐，余则虚名？”
    诸比丘白佛言：“世尊是法根、法眼、法依。”
    广说次第如上三经。

（一六七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：色是我，余则妄想；非色、非非色是我，余则妄想；我有边，余则妄想；我无边，余则妄想；我非有边非无边，余则妄想。我一想、种种想、少想、无量想，我一向乐、一向苦、苦乐、不苦不乐？”
    诸比丘白佛言：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一六八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：我世间常、世间无常、世间常无常、世间非常非无常，世有边、世无边、世有边无边、世非有边非无边，命即是身、命异身异，如来死后有、如来死后无、如来死后有无、如来死后非有非无？”
    诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一六九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：世间我常、世间我无常、世间我常无常、世间我非常非无常，我苦常、我苦无常、我苦常无常、我苦非常非无常，世间我自作、世间我他作、世间我自作他作、世间我非自作非他作、非自非他无因作，世间我苦自作、世间我苦他作、世间我苦自他作、世间我苦非自非他无因作？”
    诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一七○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：若无五欲娱乐，是则见法般涅槃。若离欲恶不善法，有觉、有观，离生喜乐，入初禅，乃至第四禅，是第一义般涅槃？”
    诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一七一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“何所有故，何所起？何所系著？何所见我？令诸众生作如是见、如是说：若粗四大色断坏无所有，是名我正断。若复我欲界断坏死后无所有，是名我正断。若复我色界死后断坏无所有，是名我正断。若得空入处、识入处、无所有入处、非想非非想入处，我死后断坏无所有，是名我正断？”
    诸比丘白佛：“世尊是法根、法眼、法依。”
    如是广说，次第如上三经。

（一七二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若法无常者当断，断彼法已，以义饶益，长夜安乐。何法无常？色无常，受、想、行、识无常。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一七三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若过去无常法当断，断彼法已，以义饶益，长夜安乐。云何过去无常法？过去色是无常法，过去欲是无常法，彼法当断。断彼法已，以义饶益，长夜安乐。受、想、行、识，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如是未来、现在、过去现在、未来现在、过去未来、过去未来现在。

（一七四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“为断无常法故，当求大师。云何是无常法？谓色是无常法，为断彼法，当求大师。受、想、行、识，亦复如是。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。
    如是过去、未来、现在、过去现在、未来现在、过去未来、过去未来现在，当求大师，八种经。
    如是种种教随顺、安、广安、周普安、导、广导、究竟导、说、广说、随顺说、第二伴、真知识、同意、愍、悲、崇义、崇安慰、乐、崇触、崇安隐、欲、精进、方便、广方便、堪能方便、坚固、强健、勇猛、身心勇猛、难伏摄受、常学、不放逸修、思惟、念、觉、知、明、慧、辩、思量、梵行、如意、念处、正勤、根、力、觉、道、止、观、念身、正忆念，一一八经亦如上说。
    如断义，如是知义、尽义、吐义、止义、舍义，亦如是。

（一七五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“犹如有人火烧头衣，当云何救？”
    比丘白佛言：“世尊，当起增上欲，殷勤方便，时救令灭。”
    佛告比丘：“头衣烧燃尚可暂忘，无常盛火应尽除断灭。为断无常火故，勤求大师。断何等无常故，勤求大师？谓断色无常故，勤求大师。断受、想、行、识无常故，勤求大师。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如断无常，如是过去无常、未来无常、现在无常、过去未来无常、过去现在无常、未来现在无常、过去未来现在无常，如是八种救头燃譬经，如上广说。
    如求大师，如是求种种教、随顺教，如上广说。
    如断义，如是知义、尽义、吐义、止义、舍义、灭义、没义，亦复如是。

（一七六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“为断无常故，当随顺内身身观住。何等法无常？谓色无常，为断彼故，当随顺内身身观住。如是受、想、行、识无常，为断彼故，当随顺内身身观住。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如无常，如是过去色无常，未来色、现在色、过去未来色、过去现在色、未来现在色、过去未来现在色无常，断彼故，当随顺内身身观住。受、想、行、识，亦复如是。
    如随顺内身身观住八种，如是外身身观、内外身身观、内受受观、外受受观、内外受受观、内心心观、外心心观、内外心心观、内法法观、外法法观、内外法法观住，一一八经亦如上说。
    如断无常义，修四念处。如是知义、尽义、吐义、止义、舍义、灭义、没义故，随顺四念处，亦如上说。

（一七七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“犹如有人火烧头衣，当云何救？”
    比丘白佛言：“世尊，当起增上欲，殷勤方便，时救令灭。”
    佛告比丘：“头衣烧燃尚可暂忘，无常盛火应尽断。为断无常火故，随修内身身观住。云何为断无常火故，随顺内身身观住？谓色无常，为断彼故，随修内身身观住。受、想、行、识无常，为断彼故，随修内身身观住。”
    广说乃至佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如无常，如是过去无常、未来无常、现在无常、过去未来无常、过去现在无常、未来现在无常、过去未来现在无常。如内身身观住八经，如是外身身观八经，内外身身观八经，如上说。
    如身念处二十四经，如是受念处、心念处、法念处二十四经，如上说。
    如当断无常九十六经，如是当知、当吐、当尽、当止、当舍、当灭、当没，一一九十六经，亦如上说。

（一七八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“犹如有人火烧头衣，当云何救？”
    比丘白佛言：“世尊，当起增上欲，殷勤方便，时救令灭。”
    佛告比丘：“头衣烧燃尚可暂忘，无常盛火应尽断。为断无常火故，已生恶不善法当断，起欲精勤、摄心令增长。断何等无常法故，已生恶不善法为断故，起欲方便，摄心增进？谓色无常故，受、想、行、识无常当断故，已生恶不善法令断，起欲方便，摄心增进。”
    广说乃至佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如无常经，如是过去无常、未来无常、现在无常、过去未来无常、过去现在无常、未来现在无常、过去未来现在无常八经，亦如上说。
    如已生恶不善法当断故，如是未生恶不善法令不生、未生善法令生、已生善法令增广故，起欲方便、摄心增进八经，亦如上说。
    如当断无常三十二经，如是当知、当吐、当尽、当止、当舍、当灭、当没，一一三十二经，广说如上。

（一七九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“犹如有人火烧头衣，当云何救？”
    比丘白佛言：“世尊，当起增上欲，殷勤方便，时救令灭。”
    佛告比丘：“头衣烧燃尚可暂忘，无常盛火当尽断。为断无常火故，当修欲定断行成就如意足。当断何等法无常？谓当断色无常，当断受、想、行、识无常故，修欲定断行成就如意足。”
    如经广说，乃至佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如无常，如是过去无常、未来无常、现在无常、过去未来无常、过去现在无常、未来现在无常、过去未来现在无常八经，亦如上说。
    如修欲定，如是精进定、意定、思惟定，亦如是。
    如当断三十二经，如是当知、当吐、当尽、当止、当舍、当灭、当没，一一三十二经，亦如上说。

（一八○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“犹如有人火烧头衣，当云何救？”
    比丘白佛言：“世尊，当起增上欲，殷勤方便，时救令灭。”
    佛告比丘：“头衣烧燃尚可暂忘，无常盛火当尽断。为断无常火故，当修信根。断何等无常法？谓当断色无常，当断受、想、行、识无常故，修信根。”
    如是广说，乃至佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如无常，如是过去无常、未来无常、现在无常、过去未来无常、过去现在无常、未来现在无常、过去未来现在无常，亦如上说。
    如信根八经，如是修精进根、念根、定根、慧根八经，亦如上说。
    如当断四十经，如是当知、当吐、当尽、当止、当舍、当灭、当没四十经，亦如上说。

（一八一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“犹如有人火烧头衣，当云何救？”
    比丘白佛言：“世尊，当起增上欲，殷勤方便，时救令灭。”
    佛告比丘：“头衣烧燃尚可暂忘，无常盛火当尽断。为断无常火故，当修信力。断何等无常故，当修信力？谓断色无常故，当修信力。断受、想、行、识无常故，当修信力。”
    如是广说，乃至佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如无常，如是过去无常、未来无常、现在无常、过去未来无常、过去现在无常、未来现在无常、过去未来现在无常八经，亦如上说。
    如信力，如是精进力、念力、定力、慧力八经，亦如上说。
    如当断四十经，如是当知、当吐、当尽、当止、当舍、当灭、当没，一一四十经，亦如上说。

（一八二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“犹如有人火烧头衣，当云何救？”
    比丘白佛言：“世尊，当起增上欲，殷勤方便，时救令灭。”
    佛告比丘：“头衣烧燃尚可暂忘，无常盛火当尽断。为断无常火故，修念觉分。断何等法无常故，修念觉分？谓断色无常，修念觉分。当断受、想、行、识无常，修念觉分。”
    如是广说，乃至佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如无常，如是过去无常、未来无常、现在无常、过去未来无常、过去现在无常、未来现在无常、过去未来现在无常八经，如上说。
    如念觉分八经，如是择法觉分、精进觉分、喜觉分、除觉分、舍觉分、定觉分，一一八经，亦如上说。
    如当断五十六经，如是当知、当吐、当尽、当止、当舍、当灭、当没，一一五十六经，如上说。

（一八三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“犹如有人火烧头衣，当云何救？”
    比丘白佛言：“世尊，当起增上欲，殷勤方便，时救令灭。”
    佛告比丘：“头衣烧燃尚可暂忘，无常盛火当尽断。为断无常火故，当修正见。断何等无常火故，当修正见？断色无常故，当修正见。断受、想、行、识无常故，当修正见。”
    如是广说，乃至佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如无常，如是过去无常、未来无常、现在无常、过去未来无常、过去现在无常、未来现在无常、过去未来现在无常，亦如上说。
    如正见八经，如是正志、正语、正业、正命、正方便、正念、正定，一一八经，亦如上说。
    如当断六十四经，如是当知、当吐、当尽、当止、当舍、当灭、当没，一一六十四经，亦如上说。

（一八四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“犹如有人火烧头衣，当云何救？”
    比丘白佛言：“世尊，当起增上欲，殷勤方便，时救令灭。”
    佛告比丘：“头衣烧燃尚可暂忘，无常盛火当尽断无余。为断无常火故，当修苦集尽道。断何等无常法故，当修苦集尽道？谓断色无常故，当修苦集尽道。断受、想、行、识无常故，当修苦集尽道。”
    如是广说，乃至佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如无常，如是过去无常、未来无常、现在无常、过去未来无常、过去现在无常、未来现在无常、过去未来现在无常，亦如上说。
    如苦集尽道八经，如是苦尽道、乐非尽道、乐尽道，一一八经，亦如上说。
    如当断三十二经，如是当知、当吐、当尽、当止、当舍、当灭、当没，一一三十二经，亦如上说。

（一八五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“犹如有人火烧头衣，当云何救？”
    比丘白佛言：“世尊，当起增上欲，殷勤方便，时救令灭。”
    佛告比丘：“头衣烧燃尚可暂忘，无常盛火当尽断无余。为断无常火故，当修无贪法句。断何等法无常故，当修无贪法句？谓当断色无常故，修无贪法句。断受、想、行、识无常故，修无贪法句。”
    如是广说，乃至佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如无常，如是过去无常、未来无常、现在无常、过去未来无常、过去现在无常、未来现在无常、过去未来现在无常，亦如上说。
    如当修无贪法句八经，如是无恚、无痴诸句正句法句，一一八经，如上说。
    如当断二十四经，如是当知、当吐、当尽、当止、当舍、当灭、当没，一一二十四经，亦如上说。

（一八六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“犹如有人火烧头衣，当云何救？”
    比丘白佛言：“世尊，当起增上欲，殷勤方便，时救令灭。”
    佛告比丘：“头衣烧燃尚可暂忘，无常盛火当尽断。为断无常火故，当修止。断何等法无常故，当修止？谓断色无常故，当修止。断受、想、行、识无常故，当修止。”
    如是广说，乃至佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如无常，如是过去无常、未来无常、现在无常、过去未来无常、过去现在无常、未来现在无常、过去未来现在无常，亦如上说。
    如修止八经，如是修观八经，亦如上说。
    如当断十六经，如是当知、当吐、当尽、当止、当舍、当灭、当没，一一十六经，亦如上说。

    “诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、非异我、不相在，如实知。受、想、行、识，亦如是。多闻圣弟子如是正观者，于色生厌，受、想、行、识生厌，厌已不乐，不乐故解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

    如无常，如是动摇、旋转、尪瘵、破坏、飘疾、朽败、危顿、不恒、不安、变易、恼苦、灾患、魔邪、魔势、魔器、如沫、如泡、如芭蕉、如幻、微劣、贪嗜、杀摽、刀剑、疾妒、相残、损减、衰耗、系缚、捶打、恶疮、痈疽、利刺、烦恼、谪罚、阴盖、过患处、愁戚、恶知识、苦、空、非我、非我所、怨家、连锁、非义、非安慰、热恼、无荫、无洲、无覆、无依、无护、生法、老法、病法、死法、忧悲法、恼苦法、无力法、羸劣法、不可欲法、诱引法、将养法、有苦法、有杀法、有恼法、有热法、有相法、有吹法、有取法、深险法、难涩法、不正法、凶暴法、有贪法、有恚法、有痴法、不住法、烧燃法、挂碍法、灾法、集法、灭法、骨聚法、肉段法、执炬法、火坑法、如毒蛇、如梦、如假借、如树果、如屠牛者、如杀人者、如触露、如淹水、如驶流、如织缕、如轮涉水、如跳杖、如毒瓶、如毒身、如毒花、如毒果、烦恼动，如是比，乃至“断过去、未来、现在无常，乃至灭、没，当修止观。断何等法过去、未来、现在无常，乃至灭、没，修止观？谓断色过去、未来、现在无常，乃至灭、没，故修止观。受、想、行、识，亦复如是。是故诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、非异我、不相在，如实知。受、想、行、识，亦复如是。多闻圣弟子如是观者，于色生厌，于受、想、行、识生厌，厌故不乐，不乐故解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一八七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“以成就一法故，不复堪任知色无常，知受、想、行、识无常。何等为一法成就？谓贪欲。一法不成就，堪能知色无常，知受、想、行、识无常。何等一法成就？谓无贪欲。成就无贪欲法者，堪能知色无常，堪能知受、想、行、识无常。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

    如成就不成就，如是知不知、亲不亲、明不明、识不识、察不察、量不量、覆不覆、种不种、掩不掩、映翳不映翳，亦如是。如是知，如是识、解、受、求、辩、独证，亦复如是。如贪，如是恚、痴、瞋、恨、呰、执、嫉、悭、幻、谄、无惭、无愧、慢、慢慢、增慢、我慢、增上慢、邪慢、卑慢、骄慢、放逸、矜高、曲伪、相规利、诱利、恶欲、多欲、常欲、不敬、恶口、恶知识、不忍、贪嗜、下贪、恶贪、身见、边见、邪见、见取、戒取、欲爱、瞋恚、睡眠、掉悔、疑、惛悴、蹁跹、赑屃、懒、乱想、不正忆、身浊、不直、不软、不异、欲觉、恚觉、害觉、亲觉、国土觉、轻易觉、爱他家觉、愁忧恼苦。“于此等一一法，乃至映翳，不堪任灭色作证。何等为一法？所谓恼苦。以恼苦映翳故，不堪任于色灭尽作证，不堪任于受、想、行、识灭尽作证。一法不映翳故，堪任于色灭尽作证，堪任于受、想、行、识灭尽作证。何等一法？谓恼苦，此一法不映翳故，堪任于色灭尽作证，堪任于受、想、行、识灭尽作证。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。


杂阿含经卷第八

诵六入处品第二

（一八八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当正观察眼无常，如是观者，是名正见。正观故生厌，生厌故离喜、离贪；离喜、贪故，我说心正解脱。如是耳、鼻、舌、身、意，离喜、离贪；离喜、贪故，比丘，我说心正解脱。心正解脱者，能自记说：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如无常，如是苦、空、非我，亦如是说。

（一八九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于眼当正思惟，观察无常。所以者何？于眼正思惟，观察无常故，于眼欲贪断；欲贪断故，我说心正解脱。耳、鼻、舌、身、意，正思惟观察故，欲贪断；欲贪断者，我说心正解脱。如是比丘，心正解脱者，能自记说：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一九○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若于眼不识、不知、不断、不离欲者，不堪任正尽苦。耳、鼻、舌、身、意，亦复如是。诸比丘，于眼若识、若知、若断、若离欲者，堪任正尽苦。于耳、鼻、舌、身、意，若识、若知、若断、若离欲者，堪任正尽苦。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一九一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于眼若不识、不知、不断、不离欲者，不堪任越生老病死苦。耳、鼻、舌、身、意，不识、不知、不断、不离欲者，不堪任越生老病死苦。诸比丘，于色若识、若知、若断、若离欲者，堪任越生老病死苦。于耳、鼻、舌、身、意，若识、若知、若断、若离欲，堪任越生老病死苦。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一九二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若于眼不离欲，心不解脱者，不堪任正尽苦。于耳、鼻、舌、身、意不离欲，心不解脱者，不堪任正尽苦。诸比丘，若于眼离欲，心解脱者，彼堪任正尽苦。于耳、鼻、舌、身、意离欲，心解脱者，堪任正尽苦。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一九三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若于眼、色不离欲，心不解脱者，不堪任越生老病死苦。于耳、鼻、舌、身、意不离欲，心不解脱者，不堪任越生老病死苦。诸比丘，若于眼、色离欲，心解脱者，堪任越生老病死苦。于耳、鼻、舌、身、意离欲，心解脱者，堪任越生老病死苦。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一九四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若于眼生喜者，则于苦生喜；若于苦生喜者，我说彼不解脱于苦。于耳、鼻、舌、身、意生喜者，则于苦生喜；于苦生喜者，我说彼不解脱于苦。诸比丘，若于眼不生喜者，则于苦不生喜；于苦不生喜者，我说彼解脱于苦。于耳、鼻、舌、身、意不生喜者，则于苦不生喜；于苦不生喜者，我说彼解脱于苦。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一九五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“一切无常。云何一切无常？谓眼无常，若色、眼识、眼触，若眼触因缘生受，苦觉、乐觉、不苦不乐觉，彼亦无常。耳、鼻、舌、身、意，亦复如是。多闻圣弟子如是观者，于眼生厌，若色、眼识、眼触、眼触因缘生受，苦觉、乐觉、不苦不乐觉，于彼生厌。耳、鼻、舌、身、意、声、香、味、触、法、意识、意触、意触因缘生受，苦觉、乐觉、不苦不乐觉，彼亦生厌。厌故不乐，不乐故解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如无常经，如是苦、空、无我，亦如是说。

（一九六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“一切无常。云何一切？谓眼无常，若色、眼识、眼触、眼触因缘生受，若苦、若乐、不苦不乐，彼亦无常。如是耳、鼻、舌、身、意识，若法、意识、意触、意触因缘生受，若苦、若乐、不苦不乐，彼亦无常。多闻圣弟子如是观者，于眼解脱，若色、眼识、眼触、眼触因缘生受，若苦、若乐、不苦不乐，彼亦解脱。如是耳、鼻、舌、身、意、法、意识、意触、意触因缘生受，若苦、若乐、不苦不乐，彼亦解脱。我说彼解脱生老病死、忧悲恼苦。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如说一切无常，如是一切苦、一切空、一切非我、一切虚业法、一切破坏法、一切生法、一切老法、一切病法、一切死法、一切愁忧法、一切烦恼法、一切集法、一切灭法、一切知法、一切识法、一切断法、一切觉法、一切作证、一切魔、一切魔势、一切魔器、一切燃、一切炽燃、一切烧，皆如上二经广说。

（一九七）

    如是我闻。一时佛住迦阇尸利沙支提，与千比丘俱，皆是旧萦发婆罗门。
    尔时世尊为千比丘作三种示现教化。云何为三？神足变化示现、他心示现、教诫示现。
    神足示现者，世尊随其所应，而示现入禅定正受。陵虚至东方，作四威仪，行、住、坐、卧；入火三昧，出种种火光，青、黄、赤、白、红、玻璃色；水火俱现，或身下出火、身上出水，身上出火、身下出水。周圆四方，亦复如是。尔时世尊作种种神变已，于众中坐，是名神足示现。
    他心示现者，如彼心、如彼意、如彼识，彼应作如是念、不应作如是念，彼应作如是舍，彼应作如是身证住，是名他心示现。
    教诫示现者，如世尊说：“诸比丘，一切烧燃。云何一切烧燃？谓眼烧燃，若色、眼识、眼触、眼触因缘生受，若苦、若乐、不苦不乐，彼亦烧燃。如是耳、鼻、舌、身、意烧燃，若法、意识、意触、意触因缘生受，若苦、若乐、不苦不乐，彼亦烧燃。以何烧燃？贪火烧燃，恚火烧燃，痴火烧燃，生老病死、忧悲恼苦火烧燃。”
    尔时千比丘闻佛所说，不起诸漏，心得解脱。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一九八）

    如是我闻。一时佛住王舍城耆阇崛山。
    尔时尊者罗睺罗往诣佛所，稽首佛足，退住一面，白佛言：“世尊，云何知、云何见，我内识身及外一切相，令我、我所、我慢使系著不生？”
    尔时世尊告罗睺罗：“善哉罗睺罗！能问如来甚深之义。”
    佛告罗睺罗：“眼若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、非异我、不相在，如实知。耳、鼻、舌、身、意，亦复如是。罗睺罗，作如是知、如是见，我此识身及外一切相，令我、我所、我慢使系著不生。罗睺罗，如是我、我所、我慢使系著不生者，罗睺罗，是名断爱浊见，正无间等，究竟苦边。”
    佛说此经已，尊者罗睺罗闻佛所说，欢喜奉行。
    如内入处，如是外入处，色、声、香、味、触、法，眼识、耳、鼻、舌、身、意识，眼触、耳、鼻、舌、身、意触，眼触生受、耳、鼻、舌、身、意触生受，眼触生想、耳、鼻、舌、身、意触生想，眼触生思、耳、鼻、舌、身、意触生思，眼触生爱、耳、鼻、舌、身、意触生爱，亦如上说。

（一九九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告罗睺罗：“云何知、云何见，于此识身及外一切相，无有我、我所、我慢使系著？”
    罗睺罗白佛言：“世尊是法根、法眼、法依。善哉世尊！当为诸比丘广说此义，诸比丘闻已，当受奉行。”
    佛告罗睺罗：“善哉谛听，当为汝说。诸所有眼，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、非异我、不相在，如实正观。罗睺罗，耳、鼻、舌、身、意，亦复如是。罗睺罗，如是知、如是见，我此识身及外一切相，我、我所、我慢使系著不生。罗睺罗，如是比丘超越于二，离诸相，寂灭、解脱。罗睺罗，如是比丘断诸爱欲，转去诸结，究竟苦边。”
    佛说此经已，罗睺罗闻佛所说，欢喜奉行。
    如内入，如是外入，乃至意触因缘生受，亦如是广说。

（二○○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者罗睺罗往诣佛所，稽首佛足，退坐一面，白佛言：“善哉世尊，为我说法。我闻法已，独一静处，专精思惟，不放逸住。独一静处，专精思惟，不放逸住已，如是思惟：所以族姓子剃除须发，正信非家，出家学道，修持梵行，见法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。”
    尔时世尊观察罗睺罗心解脱慧未熟，未堪任受增上法，问罗睺罗言：“汝以授人五受阴未？”
    罗睺罗白佛：“未也，世尊。”
    佛告罗睺罗：“汝当为人演说五受阴。”
    尔时罗睺罗受佛教已，于异时为人演说五受阴。说已，还诣佛所，稽首佛足，退住一面，白佛言：“世尊，我已为人说五受阴。唯愿世尊为我说法，我闻法已，独一静处，专精思惟，不放逸住，乃至自知不受后有。”
    尔时世尊复观察罗睺罗心解脱智未熟，不堪任受增上法，问罗睺罗言：“汝为人说六入处未？”
    罗睺罗白佛：“未也，世尊。”
    佛告罗睺罗：“汝当为人演说六入处。”
    尔时罗睺罗于异时为人演说六入处。广说六入处已，来诣佛所，稽首礼足，退住一面，白佛言：“世尊，我已为人广说六入处。唯愿世尊为我说法，我闻法已，当独一静处，专精思惟，不放逸住，乃至自知不受后有。”
    尔时世尊观察罗睺罗心解脱智未熟，不堪任受增上法，问罗睺罗言：“汝已为人说尼陀那法未？”
    罗睺罗白佛言：“未也，世尊。”
    佛告罗睺罗：“汝当为人演说尼陀那法。”
    尔时罗睺罗于异时为人广说尼陀那法已，来诣佛所，稽首礼足，退住一面，白佛言：“世尊，为我说法，我闻法已，独一静处，专精思惟，不放逸住，乃至自知不受后有。”
    尔时世尊复观察罗睺罗心解脱智未熟，广说乃至告罗睺罗言：“汝当于上所说诸法，独于一静处，专精思惟，观察其义。”
    尔时罗睺罗受佛教敕，如上所闻法、所说法，思惟称量，观察其义，作是念：“此诸法一切皆顺趣涅槃，流注涅槃，后住涅槃。”
    尔时罗睺罗往诣佛所，稽首礼足，退住一面，白佛言：“世尊，我已于如上所闻法、所说法，独一静处，思惟称量，观察其义，知此诸法，皆顺趣涅槃，流注涅槃，后住涅槃。”
    尔时世尊观察罗睺罗心解脱智熟，堪任受增上法，告罗睺罗言：“罗睺罗，一切无常。何等法无常？谓眼无常，若色、眼识、眼触，如上无常广说。”
    尔时罗睺罗闻佛所说，欢喜随喜，礼佛而退。
    尔时罗睺罗受佛教已，独一静处，专精思惟，不放逸住。所以族姓子剃除须发，着袈裟衣，正信非家，出家学道，纯修梵行，乃至见法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。成阿罗汉，心善解脱。
    佛说此经已，罗睺罗闻佛所说，欢喜奉行。

（二○一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘来诣佛所，稽首佛足，退住一面，白佛言：“世尊，云何知、云何见，次第疾得漏尽？”
    尔时世尊告彼比丘：“当正观无常。何等法无常？谓眼无常，若色、眼识、眼触、眼触因缘生受，若苦、若乐、不苦不乐，当观无常。耳、鼻、舌、身、意，当观无常，若法、意识、意触、意触因缘生受，若苦、若乐、不苦不乐，彼亦无常。比丘，如是知、如是见，次第尽有漏。”
    时彼比丘闻佛所说，欢喜作礼而去。

    如是比丘所说经，若差别者：“云何知、云何见，次第尽一切结、断一切缚、断一切使、断一切上烦恼、断一切结、断诸流、断诸轭、断诸取、断诸触、断诸盖、断诸缠、断诸垢、断诸爱、断诸意、断邪见生正见、断无明生明。”
    “比丘，如是观察眼无常，乃至如是知、如是见，次第无明断、明生。”
    时彼比丘闻佛所说欢喜，欢喜已，作礼而去。

（二○二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘往诣佛所，稽首佛足，白佛言：“世尊，云何知、云何见，次第我见断，无我见生？”
    佛告彼比丘：“于眼正观无常，若色、眼识、眼触、眼触因缘生受，若苦、若乐、不苦不乐，彼亦正观无我。如是乃至意触因缘生受，若苦、若乐、不苦不乐，彼亦正观无我。比丘，如是知、如是见，次第我见断，无我见生。”
    时彼比丘闻佛所说欢喜，欢喜已，作礼而去。

（二○三）

    如是我闻。一时佛住毗舍离耆婆拘摩罗药师庵罗园。
    尔时世尊告诸比丘：“若有比丘能断一法者，则得正智，能自记说：我生已尽，梵行已立，所作已作，自知不受后有。”
    诸比丘白佛言：“世尊是法根、法眼、法依，唯愿演说，诸比丘闻已，当受奉行。”
    佛告诸比丘：“谛听善思，当为汝说。诸比丘，云何一法断故，乃至不受后有？所谓无明离欲明生，得正智，能自记说：我生已尽，梵行已立，所作已作，自知不受后有。”
    时有异比丘从座起，整衣服，偏袒右肩，为佛作礼，右膝着地，合掌白佛言：“世尊，云何知、云何见，无明离欲明生？”
    佛告比丘：“当正观察眼无常，若色、眼识、眼触、眼触因缘生受，若苦、若乐、不苦不乐，彼亦正观无常。耳、鼻、舌、身、意，亦复如是。比丘，如是知、如是见，无明离欲明生。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二○四）

    如是我闻。一时佛住毗舍离耆婆拘摩罗药师庵罗园。
    尔时世尊告尊者阿难：“于眼当如实知、如实见，若眼、眼色、眼识、眼触、眼触因缘生受，若苦、若乐、不苦不乐，彼亦如实知、如实见。耳、鼻、舌、身、意，亦复如是。彼如实知、如实见已，于眼生厌，若色、眼识、眼触、眼触因缘生受，若苦、若乐、不苦不乐，彼亦生厌。耳、鼻、舌、身、意，亦复如是。厌已不乐，不乐已解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二○五）

    如是我闻。一时佛住毗舍离耆婆拘摩罗药师庵罗园。
    尔时世尊说一切优陀那偈已，告尊者阿难：“眼无常、苦、变易、异分法，若色、眼识、眼触、眼触因缘生受，若苦、若乐、不苦不乐，彼亦无常、苦、变易、异分法。耳、鼻、舌、身、意，亦复如是。多闻圣弟子如是观者，于眼得解脱，若色、眼识、眼触、眼触因缘生受，彼亦解脱。耳、鼻、舌、身、意、法、意识、意触、意触因缘生受，若苦、若乐、不苦不乐，彼解脱。我说彼解脱生老病死、忧悲恼苦。”
    佛说此经已，尊者阿难闻佛所说，欢喜奉行。

（二○六）

    如是我闻。一时佛住毗舍离城耆婆拘摩罗药师庵罗园。
    尔时世尊告诸比丘：“当勤方便禅思，内寂其心。所以者何？比丘方便禅思，内寂其心，如是如实知显现。于何如实知显现？于眼如实知显现，若色、眼识、眼触、眼触因缘生受，若苦、若乐、不苦不乐，彼亦如实知显现。耳、鼻、舌、身、意，亦复如是。此诸法无常、有为，亦如是如实知显现。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二○七）

    如是我闻。一时佛住毗舍离耆婆拘摩罗药师庵罗园。
    尔时世尊告诸比丘：“当修无量三摩提，精勤系念。所以者何？修无量三摩提，精勤系念已，则如实显现。于何如实显现？于眼如实显现。如是广说，乃至此诸法无常、有为，此如实显现。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二○八）

    如是我闻。一时佛住毗舍离耆婆拘摩罗药师庵罗园。
    尔时世尊告诸比丘：“过去、未来眼无常，况现在眼。多闻圣弟子如是观者，不顾过去眼，不欣未来眼，于现在眼厌、不乐、离欲、向厌。耳、鼻、舌、身、意，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如无常，苦、空、无我，亦如是说。
    如内入处四经，如是外入处色、声、香、味、触、法四经，内外入处四经，亦如是说。

（二○九）

    如是我闻。一时佛住毗舍离耆婆拘摩罗药师庵罗园。
    尔时世尊告诸比丘：“有六触入处。云何为六？眼触入处，耳、鼻、舌、身、意触入处。沙门、婆罗门于此六触入处集、灭、味、患、离不如实知，当知是沙门、婆罗门去我法律远，如虚空与地。”
    时有异比丘从座起，整衣服，为佛作礼，合掌白佛言：“我具足如实知此六触入处集、灭、味、患、离。”
    佛告比丘：“我今问汝，汝随问答我。比丘，汝见眼触入处，是我、异我、相在不？”
    答言：“不也，世尊。”
    佛告比丘：“善哉善哉！于此眼触入处，非我、非异我、不相在，如实知见者，不起诸漏，心不染著，心得解脱。是名初触入处已断已知，断其根本，如截多罗树头，于未来法永不复起，所谓眼识及色。汝见耳、鼻、舌、身、意触入处，是我、异我、相在不？”
    答言：“不也，世尊。”
    佛告比丘：“善哉善哉！于耳、鼻、舌、身、意触入处，非我、非异我、不相在，作如是如实知见者，不起诸漏，心不染著，心得解脱。是名比丘六触入处已断已知，断其根本，如截多罗树头，于未来世欲不复生，谓意识法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二一○）

    如是我闻。一时佛住毗舍离耆婆拘摩罗药师庵罗园。
    尔时世尊告诸比丘：“莫乐莫苦！所以者何？有六触入处地狱，众生生彼地狱中者，眼所见不可爱色，不见可爱色；见不可念色，不见可念色；见不善色，不见善色；以是因缘故，一向受忧苦。耳声、鼻香、舌味、身触、意识法，见不可爱，不见可爱；见不可念，不见可念；见不善法，不见善法；以是因缘故，长受忧苦。
    “诸比丘，有六触入处，其有众生生彼处者，眼见可爱，不见不可爱；见可念色，非不可念色；见善色，非不善色；以是因缘故，一向长受喜乐。耳声、鼻香、舌味、身触、意所识法，可爱非不可爱，可念非不可念，见善非不善。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二一一）

    如是我闻。一时佛住毗舍离耆婆拘摩罗药师庵罗园。
    尔时世尊告诸比丘：“我昔未成正觉时，独一静处禅思，思惟自心多向何处？观察自心，多逐过去五欲功德，少逐现在五欲功德，逐未来世转复微少。我观多逐过去五欲心已，极生方便，精勤自护，不复令随过去五欲功德。我以是精勤自护故，渐渐近阿耨多罗三藐三菩提。汝等诸比丘，亦复多逐过去五欲功德，现在、未来亦复微少。汝今亦当以心多逐过去五欲功德故，增加自护，亦当不久得尽诸漏，无漏心解脱、慧解脱，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。所以者何？眼见色因缘生内受，若苦、若乐、不苦不乐。耳、鼻、舌、身、意法因缘生内受，若苦、若乐、不苦不乐。是故比丘，于彼入处当觉知，若眼灭，色想则离。耳、鼻、舌、身、意灭，法想则离。”
    佛说当觉六入处，言已，入室坐禅。
    时有众多比丘，世尊去后，作此论议：“世尊为我等略说法要，不广分别，而入室坐禅。世尊说言：‘当觉六入处，若彼眼灭，色想则离。耳、鼻、舌、身、意灭，法想则离。’我等今日于世尊略说法中犹故不解。今此众中，谁有慧力，能为我等于世尊略说法中，广为我等演说其义？”复作是念：“唯有尊者阿难，常侍世尊，常为大师之所赞叹，聪慧梵行。唯有尊者阿难，堪能为我等，于世尊略说法中演说其义。我等今日皆共往诣尊者阿难所，问其要义。如阿难所说，悉当奉持。”
    尔时众多比丘往诣尊者阿难所，共相问讯已，于一面坐，白尊者阿难言：“尊者当知，世尊为我等略说法要。”如上所说，具问阿难：“当为我等广说其义。”
    尊者阿难语诸比丘：“谛听善思，于世尊略说法中，当为汝等广说其义。世尊略说者，即是灭六入处有余之说，故言：‘眼处灭，色想则离；耳、鼻、舌、身、意入处灭，法想则离。’世尊略说此法已，入室坐禅。我今已为汝等分别说义。”
    尊者阿难说此义已，诸比丘闻其所说，欢喜奉行。

（二一二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我不为一切比丘说不放逸行，亦非不为一切比丘说不放逸行。
    “不向何等像类比丘说不放逸行？若比丘得阿罗汉，尽诸有漏，离诸重担，逮得己利，尽诸有结，心正解脱。如是像类比丘，我不为说不放逸行。所以者何？彼诸比丘已作不放逸故，不复堪能作放逸事。我今见彼诸尊得不放逸果，是故不为彼说不放逸行。
    “为何等像类比丘说不放逸行？若诸比丘在学地者，未得心意增上安隐，向涅槃住。如是像类比丘，我为其说不放逸行。所以者何？以彼比丘习学诸根，心乐随顺资生之具，亲近善友，不久当得尽诸有漏，无漏心解脱、慧解脱，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。所以者何？彼眼识所可爱乐、染著之色，彼比丘见已，不喜、不赞叹、不染、不系著住。以不喜、不赞叹、不染、不著住故，专精胜进，身心止息，心安极住不忘，常定一心，无量法喜，但逮得第一三昧正受，终不退减随于眼色。于耳、鼻、舌、身、意识法，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二一三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当为汝等演说二法，谛听善思。何等为二？眼、色为二，耳、声，鼻、香，舌、味，身、触，意、法为二，是名二法。若有沙门、婆罗门作如是说：‘是非二者，沙门瞿昙所说二法，此非为二。’彼自以意说二法者，但有言说，问已不知，增其疑惑，以非其境界故。所以者何？缘眼、色，眼识生，三事和合缘触，触生受，若苦、若乐、不苦不乐。若于此受集、受灭、受味、受患、受离不如实知者，种贪欲身触，种瞋恚身触，种戒取身触，种我见身触，亦种植增长诸恶不善法，如是纯大苦聚皆从集生。如是耳、鼻、舌、身、意、法，缘生意识，三事和合触，广说如上。复次眼缘色，生眼识，三事和合触，触缘受，若苦、若乐、不苦不乐，于此诸受集、灭、味、患、离如是知。如是知已，不种贪欲身触，不种瞋恚身触，不种戒取身触，不种我见身触，不种诸恶不善法。如是诸恶不善法灭，纯大苦聚灭。耳、鼻、舌、身、意法，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二一四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有二因缘生识。何等为二？谓眼色、耳声、鼻香、舌味、身触、意法。如是广说，乃至非其境界故。所以者何？眼、色因缘生眼识，彼无常、有为、心缘生。色若眼、识，无常、有为、心缘生。此三法和合触，触已受，受已思，思已想，此等诸法无常、有为、心缘生，所谓触、想、思。耳、鼻、舌、身、意，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二一五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者富留那比丘往诣佛所，稽首佛足，退住一面，白佛言：“世尊说现法，说灭炽然，说不待时，说正向，说即此见，说缘自觉。世尊，云何为现法，乃至缘自觉？”
    佛告富留那：“善哉富留那！能作此问。富留那，谛听善思，当为汝说。富留那比丘，眼见色已，觉知色、觉知色贪，我此内有眼识色贪，我此内有眼识色贪如实知。富留那，若眼见色已，觉知色、觉知色贪，我此内有眼识色贪如实知者，是名现见法。云何灭炽然？云何不待时？云何正向？云何即此见？云何缘自觉？富留那比丘，眼见色已，觉知色，不起色贪觉，我有内眼识色贪，不起色贪觉如实知。若富留那比丘，眼见色已，觉知色，不起色贪觉，如实知色，不起色贪觉如实知，是名灭炽然、不待时、正向、即此见、缘自觉。耳、鼻、舌、身、意，亦复如是。”
    佛说此经已，富留那比丘闻佛所说，欢喜奉行。

（二一六）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“言大海者，愚夫所说，非圣所说。此大海，小水耳。云何圣所说海？谓眼识色已，爱念、染著，贪乐身、口、意业，是名为海。一切世间阿修罗众，乃至天、人，悉于其中贪乐沉没，如狗肚藏，如乱草蕴，此世、他世绞结缠锁，亦复如是。耳识声、鼻识香、舌识味、身识触，此世、他世绞结缠锁，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如身、口、意业，如是贪、恚、痴，老、病、死，亦如是说。
    如五根三经，六根三经亦如是说。

（二一七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“所谓海者，世间愚夫所说，非圣所说大海，小水耳。眼是人大海，彼色为涛波，若能堪忍色涛波者，得度眼大海，竟于涛波洄澓诸水、恶虫、罗刹女鬼。耳、鼻、舌、身、意是人大海，声、香、味、触、法为涛波，若堪忍彼法涛波，得度于意海，竟于涛波洄澓、恶虫、罗刹女鬼。”
    尔时世尊以偈颂曰：

“大海巨涛波，恶虫罗刹怖，
难度而能度，集离永无余。
能断一切苦，不复受余有，
永之般涅槃，不复还放逸。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二一八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当为汝等说苦集道迹、苦灭道迹。谛听善思，当为汝说。
    “云何苦集道迹？缘眼、色，生眼识，三事和合触，缘触受，缘受爱，缘爱取，缘取有，缘有生，缘生老病死、忧悲恼苦集。如是耳、鼻、舌、身、意，亦复如是。是名苦集道迹。
    “云何苦灭道迹？缘眼、色，生眼识，三事和合触，触灭则受灭，受灭则爱灭，爱灭则取灭，取灭则有灭，有灭则生灭，生灭则老病死、忧悲恼苦灭，如是纯大苦聚灭。耳、鼻、舌、身、意，亦如是说。是名苦灭道迹。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二一九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当说涅槃道迹。云何为涅槃道迹？谓观察眼无常，若色、眼识，眼触因缘生受，内觉若苦、若乐、不苦不乐，彼亦无常。耳、鼻、舌、身、意，亦复如是。是名涅槃道迹。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二二○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有似趣涅槃道迹。云何为似趣涅槃道迹？观察眼非我，若色、眼识，眼触因缘生受，若内觉若苦、若乐、不苦不乐，彼亦观察无常。耳、鼻、舌、身、意，亦复如是。是名似趣涅槃道迹。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二二一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有趣一切取道迹。云何为趣一切取道迹？缘眼、色，生眼识，三事和合触，触缘受，受缘爱，爱缘取，取所取故。耳、鼻、舌、身、意，亦复如是，取所取故。是名趣一切取道迹。云何断一切取道迹？缘眼、色，生眼识，三事和合触，触灭则受灭，受灭则爱灭，爱灭则取灭，如是知。耳、鼻、舌、身、意，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二二二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当知一切知法，一切识法。谛听善思，当为汝说。云何一切知法，一切识法？诸比丘，眼是知法、识法，若色、眼识、眼触、眼触因缘生受，内觉若苦、若乐、不苦不乐，彼一切是知法、识法。耳、鼻、舌、身、意，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二二三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我不说一法不知、不识而得究竟苦边。云何不说一法不知、不识而得究竟苦边？谓不说于眼不知、不识而得究竟苦边，若色、眼识、眼触、眼触因缘生受，内觉若苦、若乐、不苦不乐，亦复不说不知、不见而得究竟苦边。耳、鼻、舌、身、意，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二二四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“一切欲法应当断。云何一切欲法应当断？谓眼是一切欲法应当断，若色、眼识、眼触、眼触因缘生受，内觉若苦、若乐、不苦不乐，彼一切欲法应当断。耳、鼻、舌、身、意，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二二五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我不说一法不知、不断而究竟苦边。云何不说一法不知、不断而究竟苦边？谓不说眼不知、不断而究竟苦边，若色、眼识、眼触、眼触因缘生受，内觉若苦、若乐、不苦不乐，彼一切不说不知、不断而究竟苦边。耳、鼻、舌、身、意，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二二六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当说断一切计，谛听善思，当为汝说。云何不计？谓不计我见色，不计眼我所，不计相属。若色、眼识、眼触、眼触因缘生受，内觉若苦、若乐、不苦不乐，彼亦不计乐我、我所，不计乐、相乐。不计耳、鼻、舌、身、意，亦复如是。如是不计者，于诸世间常无所取，无所取故无所著，无所著故自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如上所说眼等不计，一切事不计亦如是。

（二二七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“计者是病，计者是痈，计者是刺。如来以不计住故，离病、离痈、离刺。是故比丘欲求不计住，离病、离痈、离刺者，彼比丘莫计眼我、我所，莫计眼相属，莫计色、眼识、眼触、眼触因缘生受，内觉若苦、若乐、不苦不乐，彼亦莫计是我、我所、相在。耳、鼻、舌、身、意，亦复如是。比丘，如是不计者，则无所取，无所取故无所著，无所著故自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如眼等所说，余一一事亦如是。

（二二八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当说增长法、损灭法。云何增长法？谓缘眼、色，生眼识，三事和合触，触缘受，广说乃至纯大苦聚集，是名增长法。耳、鼻、舌、身、意，亦复如是，是名增长法。云何损灭法？缘眼、色，生眼识，三事和合触，触灭则受灭，广说乃至纯大苦聚灭。耳、鼻、舌、身、意，亦复如是，是名损灭法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如增长、损灭，如是起法、处变易法，集法、灭法，亦如上说。

（二二九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当说有漏、无漏法。云何有漏法？谓眼、色、眼识、眼触、眼触因缘生受，内觉若苦、若乐、不苦不乐。耳、鼻、舌、身、意、法、意识、意触、意触因缘生受，内觉若苦、若乐、不苦不乐，世俗者，是名有漏法。云何无漏法？谓出世间意，若法、意识、意触、意触因缘生受，内觉若苦、若乐、不苦不乐，出世间者，是名无漏法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。


杂阿含经卷第九

（二三○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有比丘名三弥离提，往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，所谓世间者，云何名世间？”
    佛告三弥离提：“谓眼、色、眼识、眼触、眼触因缘生受，内觉若苦、若乐、不苦不乐；耳、鼻、舌、身、意、法、意识、意触、意触因缘生受，内觉若苦、若乐、不苦不乐，是名世间。所以者何？六入处集则触集，如是乃至纯大苦聚集。三弥离提，若无彼眼、无色、无眼识、无眼触、无眼触因缘生受，内觉若苦、若乐、不苦不乐；无耳、鼻、舌、身、意、法、意识、意触、意触因缘生受，内觉若苦、若乐、若不苦不乐者，则无世间，亦不施设世间。所以者何？六入处灭则触灭，如是乃至纯大苦聚灭故。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如世间，如是众生、如是魔，亦如是说。

（二三一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有比丘名三弥离提，往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，所谓世间者，云何名世间？”
    佛告三弥离提：“危脆败坏，是名世间。云何危脆败坏？三弥离提，眼是危脆败坏法，若色、眼识、眼触、眼触因缘生受，内觉若苦、若乐、不苦不乐，彼一切亦是危脆败坏。耳、鼻、舌、身、意，亦复如是。是说危脆败坏法，名为世间。”
    佛说此经已，三弥离提比丘闻佛所说，欢喜奉行。

（二三二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有比丘名三弥离提，往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，所谓世间空，云何名为世间空？”
    佛告三弥离提：“眼空，常、恒、不变易法空，我所空。所以者何？此性自尔。若色、眼识、眼触、眼触因缘生受，若苦、若乐、不苦不乐，彼亦空，常、恒、不变易法空，我所空。所以者何？此性自尔。耳、鼻、舌、身、意，亦复如是。是名空世间。”
    佛说此经已，三弥离提比丘闻佛所说，欢喜奉行。

（二三三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当说世间、世间集、世间灭、世间灭道迹，谛听善思。云何为世间？谓六内入处。云何六？眼内入处，耳、鼻、舌、身、意内入处。云何世间集？谓当来有爱，喜贪俱，彼彼集著。云何世间灭？谓当来有爱、喜贪俱、彼彼集著无余断，已舍、已吐、已尽、离欲、灭、止、没。云何世间灭道迹？谓八圣道，正见、正志、正语、正业、正命、正方便、正念、正定。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二三四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我不说有人行到世界边者，我亦不说不行到世界边而究竟苦边者。”
    如是说已，入室坐禅。
    时众多比丘，世尊去后即共议言：“世尊向者略说法言：‘我不说有人行到世界边者，我亦不说不行到世界边而得究竟苦边者。’如是说已，入室坐禅。我等今于世尊略说法中未解其义，是中诸尊，谁有堪能于世尊略说法中，广为我等说其义者？”复作是言：“唯有尊者阿难，聪慧总持，而常给侍世尊左右，世尊赞叹多闻梵行。堪为我等于世尊略说法中，广说其义。今当往诣尊者阿难所，请求令说。”
    时众多比丘往诣尊者阿难所，共相问讯已，于一面坐，具以上事广问阿难。
    尔时阿难告诸比丘：“谛听善思，今当为说。若世间、世间名、世间觉、世间言辞、世间语说，此等皆入世间数。诸尊！谓眼是世间、世间名、世间觉、世间言辞、世间语说，是等悉入世间数。耳、鼻、舌、身、意，亦复如是。多闻圣弟子于六入处集、灭、味、患、离如实知，是名圣弟子到世界边、知世间、世间所重、度世间。”
    尔时尊者阿难复说偈言：

“非是游步者，能到世界边，
不到世界边，不能免众苦。
是故牟尼尊，名知世间者，
能到世界边，诸梵行已立。
世界边唯有，正智能谛了，
觉慧达世间，故说度彼岸。

    “如是诸尊，向者世尊略说法已，入室坐禅，我今为汝分别广说。”
    尊者阿难说是法已，众多比丘闻其所说。欢喜奉行。

（二三五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有师、有近住弟子，则苦独住。无师、无近住弟子，则乐独住。
    “云何有师、有近住弟子，则苦独住？缘眼、色，生恶不善觉，贪、恚、痴俱。若彼比丘行此法者，是名有师。若于此边住者，是名近住弟子。耳、鼻、舌、身、意，亦复如是。如是有师、有近住弟子，常苦独住。
    “云何无师、无近住弟子，常乐独住？缘眼、色，生恶不善觉，贪、恚、痴俱。彼比丘不行，是名无师。不依彼住，是名无近住弟子。是名无师、无近住弟子，常乐独住。若彼比丘，无师、无近住弟子者，我说彼得梵行福。所以者何？无师、无近住弟子比丘，于我建立梵行，能正尽苦，究竟苦集。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二三六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者舍利弗，晨朝着衣持钵，入舍卫城乞食。乞食已，还精舍，举衣钵，洗足已，持尼师坛，入林中昼日坐禅。时舍利弗从禅觉，诣世尊所，稽首礼足，退坐一面。
    尔时佛告舍利弗：“汝从何来？”
    舍利弗答言：“世尊，从林中昼日坐禅来。”
    佛告舍利弗：“今入何等禅住？”
    舍利弗白佛言：“世尊，我今于林中入空三昧禅住。”
    佛告舍利弗：“善哉善哉！舍利弗，汝今入上座禅住而坐禅。若诸比丘欲入上座禅者，当如是学。若入城时，若行乞食时，若出城时，当作是思惟：我今眼见色，颇起欲、恩爱、爱念著不？舍利弗，比丘作如是观时，若眼识于色有爱念染著者，彼比丘为断恶不善故，当勤欲方便，堪能系念修学。譬如有人，火烧头衣，为尽灭故，当起增上方便，勤教令灭。彼比丘亦复如是，当起增上勤欲方便，系念修学。若比丘观察时，若于道路，若聚落中行乞食，若出聚落，于其中间，眼识于色无有爱念染著者，彼比丘愿以此喜乐善根，日夜精勤，系念修习。是名比丘于行、住、坐、卧，净除乞食，是故此经名清净乞食住。”
    佛说此经已，尊者舍利弗闻佛所说，欢喜奉行。

（二三七）

    如是我闻。一时佛住毗舍离猕猴池侧重阁讲堂。
    时有长者名郁瞿娄，往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，何故有一比丘见法般涅槃？何故比丘不得见法般涅槃？”
    佛告长者：“若有比丘，眼识于色，爱念染著。以爱念染著故，常依于识，为彼缚故，若彼取故，不得见法般涅槃。耳、鼻、舌、身、意识法，亦复如是。若比丘眼识于色，不爱乐染著；不爱乐染著者，不依于识，不触、不著、不取故，此诸比丘得见法般涅槃。耳、鼻、舌、身、意识法，亦复如是。是故长者，有比丘得见法般涅槃者，有不得见法般涅槃者。”
    如长者所问经，如是阿难所问经，及佛自为诸比丘所说经，亦如上说。

（二三八）

    如是我闻。一时佛住毗舍离猕猴池侧重阁讲堂。
    时有异比丘往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，何因何缘眼识生？何因何缘耳、鼻、舌、身、意识生？”
    佛告比丘：“眼因缘色，眼识生。所以者何？若眼识生，一切眼、色因缘故。耳、声因缘，鼻、香因缘，舌、味因缘，身、触因缘，意、法因缘，意识生。所以者何？诸所有意识，彼一切皆意法因缘生故。是名比丘眼识因缘生，乃至意识因缘生。”
    时彼比丘闻佛所说，欢喜随喜，作礼而去。

（二三九）

    如是我闻。一时佛住毗舍离猕猴池侧重阁讲堂。
    尔时世尊告诸比丘：“我今当说结所系法及结法。云何结所系法？眼色、耳声、鼻香、舌味、身触、意法，是名结所系法。云何结法？谓欲贪，是名结法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二四○）

    如是我闻。一时佛住毗舍离猕猴池侧重阁讲堂。
    尔时世尊告诸比丘：“我今当说所取法及取法。云何所取法？眼色、耳声、鼻香、舌味、身触、意法，是名所取法。云何取法？谓欲贪，是名取法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二四一）

    如是我闻。一时佛住毗舍离猕猴池侧重阁讲堂。
    尔时世尊告诸比丘：“愚痴无闻凡夫，比丘，宁以火烧热铜筹，以烧其目，令其炽燃，不以眼识取于色相、取随形好。所以者何？取于色相、取随形好故，堕恶趣中，如沉铁丸。愚痴无闻凡夫，宁烧铁锥以钻其耳，不以耳识取其声相、取随声好。所以者何？耳识取声相、取随声好者，身坏命终，堕恶趣中，如沉铁丸。愚痴无闻凡夫，宁以利刀断截其鼻，不以鼻识取于香相、取随香好。所以者何？以取香相、取随香好故，身坏命终，堕恶趣中，如沉铁丸。愚痴无闻凡夫，宁以利刀断截其舌，不以舌识取于味相、取随味好。所以者何？以取味相、随味好故，身坏命终，堕恶趣中，如沉铁丸。愚痴无闻凡夫，宁以刚铁利枪以刺其身，不以身识取于触相及随触好。所以者何？以取触相及随触好故，身坏命终，堕恶趣中，如沉铁丸。诸比丘，睡眠者是愚痴活，是痴命，无利无福，然诸比丘宁当睡眠，不于彼色而起觉想。若起觉想者，必生缠缚、诤讼，能令多众起于非义，不能饶益安乐天人。
    “彼多闻圣弟子作如是学，我今宁以炽燃铁枪以贯其目，不以眼识取于色相，堕三恶趣，长夜受苦。我从今日当正思惟，观眼无常、有为、心缘生法，若色、眼识、眼触、眼触因缘生受，内觉若苦、若乐、不苦不乐，彼亦无常、有为、心缘生法。耳、鼻、舌、身入处，当如是学，宁以铁枪贯其身体，不以身识取于触相及随触好故，堕三恶道。我从今日当正思惟，观身无常、有为、心缘生法，若触、身识、身触、身触因缘生受，内觉若苦、若乐、不苦不乐，彼亦无常、有为、心缘生法。多闻圣弟子作如是学，睡眠者是愚痴活、痴命，无果、无利、无福。我当不眠，亦不起觉想，起想者生于缠缚、诤讼，令多人非义饶益，不得安乐。多闻圣弟子如是观者，于眼生厌，若色、眼识、眼触、眼触因缘生受，内觉若苦、若乐、不苦不乐，彼亦生厌，厌故不乐，不乐故解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。耳、鼻、舌、身、意，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二四二）

    如是我闻。一时佛住毗舍离猕猴池侧重阁讲堂。
    尔时世尊告诸比丘：“若眼不知、不识、不断、不离欲，不堪能正尽苦。于眼若知、若识、若断、若离欲，堪能正尽苦。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如眼四经，如是乃至意二十四经，如上说。

（二四三）

    如是我闻。一时佛住毗舍离猕猴池侧重阁讲堂。
    尔时世尊告诸比丘：“若诸比丘于眼味者，当知是沙门、婆罗门不得自在脱于魔手，魔缚所缚，入于魔系。耳、鼻、舌、身、意，亦复如是。若沙门、婆罗门于眼不味者，当知是沙门、婆罗门不随于魔，脱于魔手，不入魔系。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如味，如是欢喜、赞叹、染著、坚住、爱乐、憎嫉，亦如是说。
    如内入处七经，外入处七经亦如是说。

（二四四）

    如是我闻。一时佛住毗舍离猕猴池侧重阁讲堂。
    尔时世尊告诸比丘：“有六魔钩。云何为六？眼味著色，是则魔钩。耳味著声，是则魔钩。鼻味著香，是则魔钩。舌味著味，是则魔钩。身味著触，是则魔钩。意味著法，是则魔钩。若沙门、婆罗门眼味著色者，当知是沙门、婆罗门，魔钩钩其咽，于魔不得自在。”
    秽说、净说，广说如上。

（二四五）

    如是我闻。一时佛住拘留搜调伏驳牛聚落。
    尔时世尊告诸比丘：“我今当为汝等说法，初语亦善，中语亦善，后语亦善，善义善味，纯一满净，清白梵行，谓《四品法经》。谛听善思，当为汝说。
    “何等为《四品法经》？有眼识色，可爱、可念、可乐、可著，比丘见已，欢喜、赞叹、乐著、坚住。有眼识色，不可爱、不可念、不可乐著、苦厌，比丘见已，瞋恚、嫌薄。如是比丘于魔不得自在，乃至不得解脱魔系。耳、鼻、舌、身、意，亦复如是。
    “有眼识色，可爱、可念、可乐、可著，比丘见已，知喜不赞叹、不乐著坚实。有眼识色，不可爱、念、乐、著，比丘见已，不瞋恚、嫌薄。如是比丘，不随魔自在，乃至解脱魔系。耳、鼻、舌、身、意，亦复如是。是名比丘《四品法经》。”

（二四六）

    如是我闻。一时佛住王舍城耆阇崛山。
    尔时世尊晨朝着衣持钵，入王舍城乞食。
    尔时天魔波旬作是念：“沙门瞿昙晨朝着衣持钵，入王舍城乞食。我今当往，乱其道意。”
    时魔波旬化作御车像类，执杖觅牛，着弊衣，蓬头乱发，手脚剥裂。手执牛杖，至世尊前，问言：“瞿昙，见我牛不？”
    世尊作是念：“此是恶魔，欲来乱我。”即告魔言：“恶魔，何处有牛？何用牛为？”
    魔作是念：“沙门瞿昙知我是魔。”而白佛言：“瞿昙，眼触入处，是我所乘。耳、鼻、舌、身、意触入处，是我所乘。”复问：“瞿昙，欲何所之？”
    佛告恶魔：“汝有眼触入处，耳、鼻、舌、身、意触入处。若彼无眼触入处，无耳、鼻、舌、身、意触入处，汝所不到，我往到彼。”
    尔时天魔波旬即说偈言：

“若常有我者，彼悉是我所，
一切悉属我，瞿昙何所之？”

    尔时世尊说偈答言：

“若言有我者，彼说我则非，
是故知波旬，即自堕负处。”

    魔复说偈言：

“若说言知道，安隐向涅槃，
汝自独游往，何烦教他为？”

    世尊复说偈答言：

“若有离魔者，问度彼岸道，
为彼平等说，真实永无余，
时习不放逸，永离魔自在。”

    魔复说偈言：

“有石似段肉，饿乌来欲食，
彼作软美想，欲以补饥虚，
竟不得其味，折觜而腾虚。
我今犹如乌，瞿昙如石生，
不入愧而去，犹乌陵虚逝，
内心怀愁毒，即彼没不现。”

（二四七）

    如是我闻。一时佛住王舍城耆阇崛山。
    尔时世尊告诸比丘：“若沙门、婆罗门眼习近于色，则随魔所自在，乃至不得解脱魔系。耳、鼻、舌、身、意，亦复如是。若沙门、婆罗门眼不习近于色，不随魔自在，乃至得解脱魔系。耳、鼻、舌、身、意，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如习近，如是系著、如是味、如是邻、聚、若使、受持、系著、我所、求、欲、淳、浓、不舍，亦如上说。

（二四八）

    如是我闻。一时佛住波吒利弗多罗国鸡林园。
    尔时尊者阿难往诣尊者大纯陀所，共相问讯已，于一面坐。
    尔时尊者阿难语尊者纯陀言：“欲有所问，宁有闲暇见答以不？”
    尊者纯陀语尊者阿难言：“随仁所问，知者当答。”
    尊者阿难问尊者纯陀：“如世尊、如来、应、等正觉所知所见，说四大造色，施设、显露此四大色非我。如来、应、等正觉所知所见，亦复说识非我耶？”
    尊者纯陀语尊者阿难言：“仁者最为多闻，我从远来诣尊者所，为问此法故。今日尊者唯愿为说此义。”
    尊者阿难语纯陀言：“我今问尊者，随意见答。尊者纯陀，为有眼、有色、有眼识不？”
    答言：“有，尊者阿难。”
    复问：“为缘眼及色，生眼识不？”
    答言：“如是，尊者阿难。”
    复问：“缘眼及色生眼识，彼因、彼缘为常、为无常？”
    答言：“无常，尊者阿难。”
    又问：“彼因、彼缘生眼识，彼因、彼缘无常变易时，彼识住耶？”
    答曰：“不也，尊者阿难。”
    尊者阿难复问：“于意云何？彼法若生、若灭可知，多闻圣弟子于中宁见是我、异我、相在不？”
    答曰：“不也，尊者阿难。”
    “耳、鼻、舌、身、意、法，于意云何？有意、有法、有意识不？”
    答曰：“有，尊者阿难。”
    复问：“为缘意及法，生意识不？”
    答曰：“如是，尊者阿难。”
    复问：“若意缘法生意识，彼因、彼缘为常、为无常？”
    答曰：“无常，尊者阿难。”
    复问：“若因、若缘生意识，彼因、彼缘无常变易时，意识住耶？”
    答曰：“不也，尊者阿难。”
    复问：“于意云何？彼法若生、若灭可知，多闻圣弟子宁于中见我、异我、相在不？”
    答言：“不也，尊者阿难。”
    尊者阿难语纯陀言：“是故尊者，而如来、应、等正觉所知所见，说识亦无常。譬如士夫持斧入山，见芭蕉树，谓堪材用，断根截叶，斫枝剥皮，求其坚实，剥至于尽，都无坚处。如是多闻圣弟子正观眼识，耳、鼻、舌、身、意识，当正观时，都无可取，无可取故无所著，无所著故自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    彼二正士说是法时，展转随喜，各还其所。

（二四九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者阿难诣尊者舍利弗所，语尊者舍利弗：“欲有所问，宁有闲暇为解说不？”
    舍利弗言：“随仁所问，知者当答。”
    尊者阿难问尊者舍利弗：“六触入处尽、离欲、灭、息、没已，更有余不？”
    尊者舍利弗语阿难言：“莫作此问：‘六触入处尽、离欲、灭、息、没已，更有余不？’”
    阿难又问尊者舍利弗：“六触入处尽、离欲、灭、息、没已，无有余耶？”
    尊者舍利弗答阿难言：“亦复不应作如是问：‘六触入处尽、离欲、灭、息、没已，无有余耶？’”
    阿难复问尊者舍利弗：“六触入处尽、离欲、灭、息、没已，有余无余，非有余非无余耶？”
    尊者舍利弗答阿难言：“此亦不应作如此问：‘六触入处尽、离欲、灭、息、没已，有余无余，非有余非无余耶？’”
    尊者阿难又问舍利弗：“如尊者所说，六触入处尽、离欲、灭、息、没已，有亦不应说，无亦不应说，有无亦不应说，非有非无亦不应说，此语有何义？”
    尊者舍利弗语尊者阿难：“六触入处尽、离欲、灭、息、没已，有余耶？此则虚言。无余耶？此则虚言。有余无余耶？此则虚言。非有余非无余耶？此则虚言。若言六触入处尽、离欲、灭、息、没已，离诸虚伪，得般涅槃，此则佛说。”
    时二正士展转随喜，各还本处。

（二五○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时尊者舍利弗、尊者摩诃拘絺罗，俱在耆阇崛山。
    尊者摩诃拘絺罗晡时从禅觉，诣尊者舍利弗所，共相问讯已，退坐一面，语舍利弗言：“欲有所问，宁有闲暇见答已不？”
    尊者舍利弗语摩诃拘絺罗：“随仁所问，知者当答。”
    尊者摩诃拘絺罗问尊者舍利弗言：“云何尊者舍利弗，眼系色耶，色系眼耶？耳声、鼻香、舌味、身触、意法，意系法耶，法系意耶？”
    尊者舍利弗答尊者摩诃拘絺罗言：“非眼系色，非色系眼，乃至非意系法，非法系意。尊者摩诃拘絺罗，于其中间，若彼欲贪，是其系也。尊者摩诃拘絺罗，譬如二牛，一黑一白，共一轭鞅缚系。人问言：‘为黑牛系白牛，为白牛系黑牛？’为等问不？”
    答言：“不也，尊者舍利弗。非黑牛系白牛，亦非白牛系黑牛，然于中间若轭、若系鞅者，是彼系缚。”
    “如是尊者摩诃拘絺罗，非眼系色，非色系眼，乃至非意系法，非法系意；中间欲贪，是其系也。尊者摩诃拘絺罗，若眼系色，若色系眼，乃至若意系法，若法系意，世尊不教人建立梵行，得尽苦边。以非眼系色，非色系眼，乃至非意系法，非法系意故，世尊教人建立梵行，得尽苦边。尊者摩诃拘絺罗，世尊说眼见色，若好、若恶，不起欲贪。其余众生眼若见色若好、若恶，则起欲贪。是故世尊说当断欲贪，则心解脱，乃至意、法，亦复如是。”
    时二正士展转随喜，各还本处。

（二五一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者舍利弗、尊者摩诃拘絺罗，俱在耆阇崛山中。
    尊者摩诃拘絺罗晡时从禅觉，诣尊者舍利弗所，共相问讯已，退坐一面，语尊者舍利弗：“欲有所问，宁有闲暇见答以不？”
    舍利弗言：“随仁所问，知者当答。”
    尊者摩诃拘絺罗问尊者舍利弗言：“谓无明者，云何为无明？”
    尊者舍利弗言：“所谓无知，无知者是为无明。云何无知？谓眼无常不如实知，是名无知。眼生灭法不如实知，是名无知。耳、鼻、舌、身、意，亦复如是。如是尊者摩诃拘絺罗，于此六触入处如实不知、不见、不无间等、愚痴、无明、大冥，是名无明。”
    尊者摩诃拘絺罗又问尊者舍利弗：“所谓明者，云何为明？”
    舍利弗言：“所谓为知，知者是明。为何所知？谓眼无常，眼无常如实知。眼生灭法，眼生灭法如实知。耳、鼻、舌、身、意，亦复如是。尊者摩诃拘絺罗，于此六触入处如实知、见、明、觉、悟、慧、无间等，是名为明。”
    时二正士各闻所说，展转随喜，各还其所。

（二五二）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有比丘名优波先那，住王舍城寒林中冢间，蛇头岩下迦陵伽行处。
    时尊者优波先那，独一于内坐禅。时有恶毒蛇长尺许，于上石间堕优波先那身上。优波先那唤舍利弗，语诸比丘：“毒蛇堕我身上，我身中毒。汝等驶来，扶持我身，出置于外，莫令于内身坏，碎如糠糩聚。”
    时尊者舍利弗于近处，住一树下，闻优波先那语，即诣优波先那所，语优波先那言：“我今观汝色貌、诸根不异于常，而言中毒，持我身出，莫令散坏，如糠糩聚，竟为云何？”
    优波先那语舍利弗言：“若当有言我眼是我、我所；耳、鼻、舌、身、意，耳、鼻、舌、身、意是我、我所；色、声、香、味、触、法，色、声、香、味、触、法是我、我所；地界，地界是我、我所；水、火、风、空、识界，水、火、风、空、识界是我、我所；色阴，色阴是我、我所；受、想、行、识阴，受、想、行、识阴是我、我所者，面色、诸根应有变异。我今不尔，眼非我、我所，乃至识阴非我、我所，是故面色、诸根无有变异。”
    舍利弗言：“如是优波先那，汝若长夜离我、我所、我慢系著使，断其根本，如截多罗树头，于未来世永不复起，云何面色、诸根当有变异！”
    时舍利弗即周匝扶持优波先那身，出于窟外。优波先那身中毒碎坏，如聚糠糩。
    时舍利弗即说偈言：

“久植诸梵行，善修八圣道，
欢喜而舍寿，犹如弃毒钵。
久植诸梵行，善修八圣道，
欢喜而舍寿，如人重病愈。
久植诸梵行，善修八圣道，
如出火烧宅，临死无忧悔。
久植诸梵行，善修八圣道，
以慧观世间，犹如秽草木，
不复更求余，余亦不相续。”

    时尊者舍利弗供养优波先那尸已，往诣佛所，稽首礼足，退坐一面，白佛言：“世尊，尊者优波先那，有小恶毒蛇，如治眼筹，堕其身上，其身即坏，如聚糠糩。”
    佛告舍利弗：“若优波先那诵此偈者，则不中毒，身亦不坏，如聚糠糩。”
    舍利弗白佛言：“世尊，诵何等偈，何等辞句？”
    佛即为舍利弗而说偈言：

“常慈念于彼，坚固赖吒罗，
慈伊罗槃那，尸婆弗多罗，
钦婆罗上马，亦慈迦拘吒，
及彼黑瞿昙，难陀跋难陀。
慈悲于无足，及以二足者，
四足与多足，亦悉起慈悲。
慈悲于诸龙，依于水陆者，
慈一切众生，有量及无量。
安乐于一切，亦离烦恼生，
欲令一切贤，一切莫生恶，
常住蛇头岩，众恶不来集。
凶害恶毒蛇，能害众生命，
如此真谛言，无上大师说，
我今诵习此，大师真实语，
一切诸恶毒，不能害我身。
贪欲瞋恚痴，世间之三毒，
如此三恶毒，永除名佛宝，
法宝灭众毒，僧宝亦无余。
破坏凶恶毒，摄受护善人，
佛破一切毒，汝蛇毒今破。

    “故说是咒术章句，所谓：坞耽婆隶　耽婆隶　耽陆　波婆耽陆　奈渧　肃奈渧　枳跋渧　文那移　三摩移　檀谛　尼罗枳施　婆罗拘闭坞隶　坞娱隶　悉波呵
    “舍利弗，优波先那善男子尔时说此偈，说此章句者，蛇毒不能中其身，身亦不坏，如糠糩聚。”
    舍利弗白佛言：“世尊，优波先那未曾闻此偈，未曾闻此咒术章句。世尊今日说此，正为当来世耳。”
    尊者舍利弗闻佛所说，欢喜作礼而去。

（二五三）

    如是我闻。一时尊者优陀夷往拘萨罗国人间游行，至拘槃茶聚落，到毗纽迦旃延氏婆罗门尼庵罗园中住。
    时毗纽迦旃延氏婆罗门尼，有诸年少弟子，游行采樵，至庵罗园中。见尊者优陀夷坐一树下，容貌端正，诸根寂静，心意安谛，成就第一调伏。见已往诣其所，共相问讯已，退坐一面。
    时优陀夷为诸年少，种种说法劝励已，默然而住。
    彼诸年少闻尊者优陀夷所说，欢喜随喜，从座起去。
    时诸年少担持束薪，还至毗纽迦旃延氏婆罗门尼所，置薪束于地，诣毗纽迦旃延氏婆罗门尼所，白言：“我和尚尼当知，庵罗园中有沙门优陀夷，姓瞿昙氏，依于彼住，极善说法。”
    毗纽迦旃延氏婆罗门尼语诸年少言：“汝可往请沙门优陀夷瞿昙氏，明日于此饭食。”
    时诸年少弟子受毗纽迦旃延氏婆罗门尼教已，往诣尊者优陀夷所，白优陀夷言：“尊者当知，我和尚毗纽迦旃延氏婆罗门尼，请尊者优陀夷明旦饭食。”
    时优陀夷默然受请。时彼诸年少知优陀夷受请已，还归和尚毗纽迦旃延氏婆罗门尼所，白言：“和尚尼，我以和尚尼语请尊者优陀夷，尊者优陀夷默然受请，和尚尼自知时。”
    尔时尊者优陀夷，夜过晨朝，着衣持钵，往诣毗纽迦旃延氏婆罗门尼舍。
    时毗纽迦旃延氏婆罗门尼遥见尊者优陀夷来，疾敷床座，请令就坐。设种种饮食，自手供养，丰美满足。食已，澡漱洗钵讫，还就本座。
    时毗纽迦旃延氏婆罗门尼知食已讫，着好革屣，以衣覆头，别施高床，现起轻相，傲慢而坐，语优陀夷言：“欲有所问，宁有闲暇见答以不？”
    优陀夷答言：“姊妹，今是非时。”作此语已，从座起去。
    如是明日，诸弟子复至庵罗园采樵听法，还复白和尚尼，和尚尼复遣诣请食。如前三返，乃至请法，答言非时，不为说法。
    诸年少弟子复白和尚尼：“庵罗园中沙门优陀夷，极善说法。”
    和尚尼答言：“我亦知彼极善说法，再三请来，设食问法，常言非时，不说而去。”
    诸弟子言：“和尚尼着好革屣，以衣覆头，不恭敬坐，彼云何说？所以者何？彼尊者优陀夷以敬法故，不说而去。”
    和尚尼答言：“若如是者，更为我请彼。”
    诸弟子受教，更请供养如前。
    时和尚尼知食讫已，脱革屣，整衣服，更坐卑床，恭敬白言：“欲有所问，宁有闲暇见答以不？”
    优陀夷答言：“汝今宜问，当为汝说。”
    彼即问言：“有沙门、婆罗门，说苦乐自作，复有说言苦乐他作，复有说言苦乐自他作，复有说言苦乐非自非他作。尊者复云何？”
    尊者优陀夷答言：“姊妹，阿罗诃说苦乐异生，非如是说。”
    婆罗门尼复问：“其义云何？”
    优陀夷答言：“阿罗诃说从其因缘，生诸苦乐。”
    优陀夷复语婆罗门尼言：“我今问汝，随意答我。于意云何，有眼不？”
    答言：“有。”
    “有色不？”
    答言：“有。”
    “有眼识、眼触、眼触因缘生受，内觉若苦、若乐、不苦不乐不？”
    答言：“如是，尊者优陀夷。”
    优陀夷复问：“有耳、鼻、舌、身、意、意触、意触因缘生受，内觉若苦、若乐、不苦不乐不？”
    答言：“如是，尊者优陀夷。”
    优陀夷言：“此是阿罗诃说，从其因缘生于苦乐。”
    婆罗门尼言：“尊者优陀夷，如是阿罗诃说，从其因缘生苦乐耶？”
    优陀夷答言：“如是，婆罗门尼。”
    婆罗门尼复问：“沙门，云何阿罗诃说因缘生苦、乐、不苦不乐灭？”
    优陀夷答言：“我今问汝，随意答我。婆罗门尼，一切眼一切时灭无余，犹有眼触因缘生受，内觉若苦、若乐、不苦不乐耶？”
    答言：“无也，沙门。”
    “如是耳、鼻、舌、身、意，一切时灭，永尽无余，犹有意触因缘生受，内觉若苦、若乐、不苦不乐耶？”
    答言：“无也，沙门。”
    “如是婆罗门尼，是为阿罗诃说因缘生苦、乐、不苦不乐灭。”
    尊者优陀夷说是法时，毗纽迦旃延氏婆罗门尼远尘离垢，得法眼净。尔时毗纽迦旃延氏婆罗门尼见法、得法、知法、入法，度疑惑，不由于他，入佛教法，于法得无所畏。从座起，整衣服，恭敬合掌，白尊者优陀夷：“我今日超入决定。我从今日归依佛、归依法、归依僧，我从今日尽寿归依三宝。”
    尔时优陀夷为婆罗门尼说法，示教照喜已，从座起去。

（二五四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者二十亿耳，住耆阇崛山，常精勤修习菩提分法。
    时尊者二十亿耳，独静禅思，而作是念：“于世尊弟子精勤声闻中，我在其数，然我今日未尽诸漏。我是名族姓子，多饶财宝，我今宁可还受五欲，广行施作福。”
    尔时世尊知二十亿耳心之所念，告一比丘：“汝等今往二十亿耳所，告言：世尊呼汝。”
    是一比丘受佛教已，往诣二十亿耳所，语言：“世尊呼汝。”
    二十亿耳闻彼比丘称大师命，即诣世尊所，稽首礼足，退住一面。
    尔时世尊告二十亿耳：“汝实独静禅思作是念：世尊精勤修学声闻中，我在其数，而今未得漏尽解脱。我是名族姓子，又多钱财，我宁可还俗，受五欲乐，广施作福耶？”
    时二十亿耳作是念：“世尊已知我心。”惊怖毛竖，白佛言：“实尔，世尊。”
    佛告二十亿耳：“我今问汝，随意答我。二十亿耳，汝在俗时，善弹琴不？”
    答言：“如是，世尊。”
    复问：“于意云何？汝弹琴时，若急其弦，得作微妙和雅音不？”
    答言：“不也，世尊。”
    复问：“云何？若缓其弦，宁发微妙和雅音不？”
    答言：“不也，世尊。”
    复问：“云何？善调琴弦，不缓不急，然后发妙和雅音不？”
    答言：“如是，世尊。”
    佛告二十亿耳：“精进太急，增其掉悔。精进太缓，令人懈怠。是故汝当平等修习摄受，莫著、莫放逸、莫取相。”
    时尊者二十亿耳闻佛所说，欢喜随喜，作礼而去。
    时尊者二十亿耳常念世尊说弹琴譬，独静禅思，如上所说。乃至漏尽，心得解脱，成阿罗汉。
    尔时尊者二十亿耳得阿罗汉，内觉解脱喜乐，作是念：“我今应往问讯世尊。”
    尔时尊者二十亿耳往诣佛所，稽首礼足，退坐一面，白佛言：“世尊，于世尊法中得阿罗汉，尽诸有漏，所作已作，舍离重担，逮得己利，尽诸有结，正智心解脱。当于尔时，解脱六处。云何为六？离欲解脱、离恚解脱、远离解脱、爱尽解脱、诸取解脱、心不忘念解脱。
    “世尊，若有依少信心，而言离欲解脱，此非所应；贪、恚、痴尽，是名真实离欲解脱。若复有人依少持戒，而言我得离恚解脱，此亦不应；贪、恚、痴尽，是名真实解脱。若复有人依于修习利养远离，而言远离解脱，是亦不应；贪、恚、痴尽，是真实远离解脱。贪、恚、痴尽，亦名离爱，亦名离取，亦名离忘念解脱。如是世尊，若诸比丘未得罗汉，未尽诸漏，于此六处不得解脱。
    “若复比丘在于学地，未得增上乐涅槃，习向心住，尔时成就学戒，成就学根。后时当得漏尽、无漏心解脱，乃至自知不受后有。当于尔时，得无学戒，得无学诸根。譬如婴童愚小仰卧，尔时成就童子诸根。彼于后时渐渐增长，诸根成就，当于尔时成就长者诸根。在学地者亦复如是，未得增上安乐，乃至成就无学戒、无学诸根，若眼常识色，终不能妨心解脱、慧解脱，意坚住故，内修无量善解脱，观察生灭，乃至无常。耳识声、鼻识香、舌识味、身识触、意识法，不能妨心解脱、慧解脱，意坚住故，内修无量善解脱，观察生灭。譬如村邑，近大石山，不断、不坏、不穿，一向厚密，假使四方风吹，不能动摇，不能穿过。彼无学者亦复如是，眼常识色，乃至意常识法，不能妨心解脱、慧解脱，意坚住故，内修无量善解脱，观察生灭。”
    尔时二十亿耳重说偈言：

“离欲心解脱，无恚脱亦然，
远离心解脱，贪爱永无余，
诸取心解脱，及意不忘念。
晓了入处生，于彼心解脱，
彼心解脱者，比丘意止息，
诸所作已作，更不作所作。
犹如大石山，四风不能动，
色声香味触，及法之好恶，
六入处常对，不能动其心，
心常住坚固，谛观法生灭。”

    尊者二十亿耳说是法时，大师心悦。诸多闻梵行者，闻尊者二十亿耳所说，皆大欢喜。
    尔时尊者二十亿耳闻佛说法，欢喜随喜，作礼而去。
    尔时世尊知二十亿耳去不久，告诸比丘：“善心解脱者，应如是记说，如二十亿耳以智记说，亦不自举，亦不下他，正说其义。非如增上慢者，不得其义，而自称叹得过人法，自取损减。”

（二五五）

    如是我闻。一时尊者摩诃迦旃延，住阿磐提国湿摩陀江侧猕猴室阿练若窟。有鲁醯遮婆罗门，恭敬承事，如罗汉法。
    尔时尊者摩诃迦旃延，晨朝着衣持钵，入猕猴室聚落，次行乞食。乞食还，举衣钵，洗足已，入室坐禅。
    时鲁醯遮婆罗门有诸年少弟子，游行采薪，至尊者摩诃迦旃延窟边，共戏笑言：“此中剃发沙门住，是黑暗人，非世胜人。而鲁醯遮婆罗门尊重供养，如罗汉法。”
    时尊者摩诃迦旃延语诸年少言：“年少！年少！莫作声。”
    诸少年言：“终不敢复言。”如是再三，语犹不止。
    于是尊者摩诃迦旃延出户外，语诸年少言：“年少！年少！汝等莫语。我今当为汝等说法，汝等且听。”
    诸年少言：“诺！唯愿说法，我当听受。”
    尔时尊者摩诃迦旃延即说偈言：

“古昔婆罗门，修习胜妙戒，
得生宿命智，娱乐真谛禅，
常住于慈悲，关闭诸根门，
调伏于口过，古昔行如是。
舍本真实行，而存虚伪事，
守族姓放逸，从诸根六境，
自饿居冢间，三浴诵三典，
不守护根门，犹如梦得宝。
编发衣皮褐，戒盗灰坌身，
粗衣以蔽形，执杖持水瓶，
假形婆罗门，以求于利养。
善摄护其身，澄净离尘垢，
不恼于众生，是道婆罗门。”

    尔时诸年少婆罗门瞋恚不喜，语尊者摩诃迦旃延：“谤我经典，毁坏所说，骂辱婆罗门。”执持薪束，还鲁醯遮婆罗门所，语鲁醯遮婆罗门言：“和尚知不？彼摩诃迦旃延诽谤经典，毁呰言说，骂辱婆罗门。”
    鲁醯遮婆罗门语诸年少：“诸年少，莫作是语。所以者何？摩诃迦旃延宿重戒德，不应谤毁经典，毁呰言说，骂婆罗门。
    诸年少言：“和尚不信我言，当自往看。”
    时鲁醯遮婆罗门不信诸年少语，往诣摩诃迦旃延，共相问讯慰劳已，退坐一面，语摩诃迦旃延言：“我诸年少弟子来到此不？”
    答言：“到此。”
    “少多与共言语不？”
    答云：“与共言语。”
    鲁醯遮婆罗门言：“汝与诸年少共语，今可为我尽说是。”
    摩诃迦旃延即为广说。时鲁醯遮婆罗门亦复瞋恚，心得不喜，语摩诃迦旃延：“我先不信诸年少语。今摩诃迦旃延真实诽谤经典，毁呰而说，骂辱婆罗门。”作此语已，小默然住，须臾复语摩诃迦旃延：“仁者所说门，何等为门？”
    摩诃迦旃延言：“善哉善哉！婆罗门，所问如法，我今当为汝说门。婆罗门，眼是门，以见色故。耳、鼻、舌、身、意是门，以识法故。”
    婆罗门言：“奇哉！摩诃迦旃延，我问其门，即说其门。如摩诃迦旃延所说不守护门，云何不守护门？”
    摩诃迦旃延言：“善哉善哉！婆罗门，问不守护门，是如法问，今当为汝说不守护门。婆罗门，愚痴无闻凡夫眼见色已，于可念色而起缘著，不可念色而起瞋恚，不住身念处故，于心解脱、慧解脱无如实知，于彼起种种恶不善法，不得无余灭尽；于心解脱、慧解脱妨碍，不得满足。心解脱、慧解脱不满故，身满恶行，不得休息，心不寂静。以不寂静故，于其根门则不调伏、不守护、不修习。如眼色，耳声、鼻香、舌味、身触、意法，亦复如是。”
    鲁醯遮婆罗门言：“奇哉奇哉！摩诃迦旃延，我问不守护门，即为我说不守护门。摩诃迦旃延，云何复名善守护门？”
    摩诃迦旃延语婆罗门言：“善哉善哉！汝能问我善守护门义。谛听善思，当为汝说守护门义。多闻圣弟子眼见色已，于可念色不起缘著，不可念色不起瞋恚，常摄其心，住身念处，无量心解脱、慧解脱如实知，于彼所起恶不善法，寂灭无余，于心解脱、慧解脱而得满足。解脱满足已，身触恶行悉得休息，心得正念，是名初门善调伏、守护、修习。如眼及色，耳声、鼻香、舌味、身触、意法，亦复如是。”
    鲁醯遮婆罗门言：“奇哉！摩诃迦旃延，我问守护门义，即为我说守护门义。譬如士夫求毒药草，乃得甘露。今我如是，瞋恚而来，至此座坐，而摩诃迦旃延以大法雨，雨我身中，如雨甘露。摩诃迦旃延，家中多事，今请还家。”
    摩诃迦旃延言：“婆罗门，宜知是时。”
    时鲁醯遮婆罗门闻摩诃迦旃延所说，欢喜随喜，从座起去。


杂阿含经卷第十

（二五六）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者舍利弗、尊者摩诃拘絺罗，在耆阇崛山。
    时尊者拘絺罗，晡时从禅起，诣尊者舍利弗所，共相问讯，种种相娱悦已，却坐一面。时尊者摩诃拘絺罗语舍利弗言：“欲有所问，宁有闲暇为我说不？”
    舍利弗言：“随仁所问，知者当说。”
    摩诃拘絺罗问舍利弗言：“所谓无明，云何是无明？谁有此无明？”
    舍利弗答言：“无明者谓不知，不知者是无明。”
    “何所不知？”
    “谓色无常，色无常如实不知；色磨灭法，色磨灭法如实不知；色生灭法，色生灭法如实不知。受、想、行、识，受、想、行、识无常如实不知；识磨灭法，识磨灭法如实不知；识生灭法，识生灭法如实不知。摩诃拘絺罗，于此五受阴如实不知、不见、无无间等、愚暗、不明，是名无明。成就此者，名有无明。”
    又问：“舍利弗，所谓明者，云何为明？谁有此明？”
    舍利弗言：“摩诃拘絺罗，所谓明者是知，知者是名为明。”
    又问：“何所知？”
    “谓知色无常，知色无常如实知；色磨灭法，色磨灭法如实知；色生灭法，色生灭法如实知。受、想、行、识，受、想、行、识无常如实知；识磨灭法，识磨灭法如实知；识生灭法，识生灭法如实知。拘絺罗，于此五受阴如实知、见、明、觉、慧、无间等，是名为明。成就此法者，是名有明。”
    是二正士各闻所说，展转随喜，从座而起，各还本处。

（二五七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时尊者舍利弗、尊者摩诃拘絺罗，在耆阇崛山。
    时摩诃拘絺罗，晡时从禅起，诣尊者舍利弗所，共相问讯，种种相娱悦已，却坐一面。时尊者摩诃拘絺罗语舍利弗言：“欲有所问，宁有少暇为我说不？”
    舍利弗言：“仁者且问，知者当说。”
    摩诃拘絺罗问舍利弗言：“所谓无明，复云何为无明？谁有此无明？”
    舍利弗答言：“无明者谓不知，不知者是无明。”
    “何所不知？”
    “谓色不如实知，色集、色灭、色灭道迹不如实知。受、想、行、识不如实知，识集、识灭、识灭道迹不如实知。摩诃拘絺罗，于此五受阴不如实知、不知、不见、不无间等、愚暗、不明，是名无明。成就此者，名有无明。”
    又问舍利弗：“云何为明？谁有此明？”
    舍利弗言：“所谓明者是知，知者是明。”
    又问：“何所知？”
    舍利弗言：“色如实知，色集、色灭、色灭道迹如实知。受、想、行、识如实知，识集、识灭、识灭道迹如实知。拘絺罗，于此五受阴如实知、见、明、觉、慧、无间等，是名为明。成就此法者，是名有明。”
    是二正士各闻所说，展转随喜，从座而起，各还本处。

（二五八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者舍利弗、尊者摩诃拘絺罗，在耆阇崛山。
    时摩诃拘絺罗，晡时从禅起，诣舍利弗所，共相问讯，相娱悦已，却坐一面。时摩诃拘絺罗语舍利弗：“欲有所问，仁者宁有闲暇见答以不？”
    舍利弗言：“仁者且问，知者当答。”
    时摩诃拘絺罗语舍利弗言：“所谓无明，无明者为何谓耶？谁有此无明？”
    舍利弗言：“不知是无明。”
    “不知何等？”
    “谓色不如实知，色集、色灭、色味、色患、色离不如实知。受、想、行、识，识集、识灭、识味、识患、识离不如实知。摩诃拘絺罗，于此五受阴不如实知、不如实见、不无间等、若暗、若愚，是名无明。成就此法者，名有无明。”
    又问：“明者，云何为明？谁有此明？”
    舍利弗言：“知者是明。”
    “为何所知？”
    舍利弗言：“色如实知，色集、色灭、色味、色患、色离如实知。受、想、行、识如实知，识集、识灭、识味、识患、识离如实知。摩诃拘絺罗，于此五受阴如实知、如实见、明、觉、慧、无间等，是名为明。成就此者，名为有明。”
    时二正士各闻所说，欢喜而去。

（二五九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者舍利弗共摩诃拘絺罗，在耆阇崛山。
    摩诃拘絺罗晡时从禅起，诣舍利弗所，共相问讯，相娱悦已，却坐一面。时摩诃拘絺罗语舍利弗：“欲有所问，仁者宁有闲暇见答以不？”
    舍利弗言：“仁者且问，知者当答。”
    时摩诃拘絺罗问舍利弗言：“若比丘未得无间等法，欲求无间等法，云何方便求？思惟何等法？”
    舍利弗言：“若比丘未得无间等法，欲求无间等法，精勤思惟，五受阴为病、为痈、为刺、为杀、无常、苦、空、非我。所以者何？是所应处故。若比丘于此五受阴精勤思惟，得须陀洹果证。”
    又问舍利弗：“得须陀洹果证已，欲得斯陀含果证者，当思惟何等法？”
    舍利弗言：“拘絺罗，已得须陀洹果证已，欲得斯陀含果证者，亦当精勤思惟，此五受阴法为病、为痈、为刺、为杀、无常、苦、空、非我。所以者何？是所应处故。若比丘于此五受阴精勤思惟，得斯陀含果证。”
    摩诃拘絺罗又问舍利弗言：“得斯陀含果证已，欲得阿那含果证者，当思惟何等法？”
    舍利弗言：“拘絺罗，得斯陀含果证已，欲得阿那含果证者，当复精勤思惟，此五受阴法为病、为痈、为刺、为杀、无常、苦、空、非我。所以者何？是所应处故。若比丘于此五受阴精勤思惟，得阿那含果证。”
    摩诃拘絺罗又问舍利弗言：“得阿那含果证已，欲得阿罗汉果证者，当思惟何等法？”
    舍利弗言：“拘絺罗，得阿那含果证已，欲得阿罗汉果证者，当复精勤思惟，此五受阴法为病、为痈、为刺、为杀、无常、苦、空、非我。所以者何？是所应处故。若比丘于此五受阴法精勤思惟，得阿罗汉果证。”
    摩诃拘絺罗又问舍利弗：“得阿罗汉果证已，复思惟何等法？”
    舍利弗言：“摩诃拘絺罗，阿罗汉亦复思惟，此五受阴法为病、为痈、为刺、为杀、无常、苦、空、非我。所以者何？为得未得故，证未证故，见法乐住故。”
    时二正士各闻所说，欢喜而去。

（二六○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者舍利弗，诣尊者阿难所，共相问讯已，却坐一面。时尊者舍利弗问尊者阿难言：“欲有所问，仁者宁有闲暇见答以不？”
    阿难言：“仁者且问，知者当答。”
    舍利弗言：“阿难，所谓灭者，云何为灭耶？谁有此灭？”
    阿难言：“舍利弗，五受阴是本行所作、本所思愿，是无常、灭法；彼法灭故，是名为灭。云何为五？所谓色受阴是本行所作、本所思愿，是无常、灭法；彼法灭故，是名为灭。如是受、想、行、识，是本行所作、本所思愿，是无常、灭法；彼法灭故，是名为灭。”
    舍利弗言：“如是如是，阿难，如汝所说，此五受阴是本行所作、本所思愿，是无常、灭法；彼法灭故，是名为灭。云何为五？所谓色受阴是本行所作、本所思愿，是无常、灭法；彼法灭故，是名为灭。如是受、想、行、识，是本行所作、本所思愿，是无常、灭法；彼法灭故，是名为灭。阿难，此五受阴，若非本行所作、本所思愿者，云何可灭？阿难，以五受阴是本行所作、本所思愿，是无常、灭法；彼法灭故，是名为灭。”
    时二正士各闻所说，欢喜而去。

（二六一）

    如是我闻。一时尊者阿难住拘睒弥国瞿师罗园。
    时尊者阿难告诸比丘：“尊者富留那弥多罗尼子，年少初出家时，常说深法，作如是言：‘阿难，生法计是我，非不生。阿难，云何于生法计是我，非不生？色生，生是我，非不生。受、想、行、识生，生是我，非不生。譬如士夫手执明镜及净水镜，自见面生，生故见，非不生。是故阿难，色生，生故计是我，非不生。如是受、想、行、识生，生故计是我，非不生。云何阿难，色是常耶，为无常耶？’答曰：‘无常。’又问：‘无常者，是苦耶？’答曰：‘是苦。’又问：‘若无常、苦者，是变易法。圣弟子于中复计我、异我、相在不？’答曰：‘不也。’‘如是受、想、行、识，为是常耶，为无常耶？’答曰：‘无常。’‘若无常，是苦耶？’答曰：‘是苦。’又问：‘若无常、苦者，是变易法。多闻圣弟子于中宁复计我、异我、相在不？’答曰：‘不也。’‘阿难，是故色若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、不异我、不相在。如是受、想、行、识，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、不异我、不相在。如实知，如实观察，如是观者，圣弟子于色生厌、离欲、解脱：我生已尽，梵行已立，所作已作，自知不受后有。如是受、想、行、识，生厌、离欲、解脱：我生已尽，梵行已立，所作已作，自知不受后有。’
    “诸比丘当知，彼尊者于我有大饶益。我从彼尊者所闻法已，远尘离垢，得法眼净。我从是来，常以此法为四众说，非余外道、沙门、婆罗门出家者说。”

（二六二）

    如是我闻。一时有众多上座比丘住波罗奈国仙人住处鹿野苑中，佛般泥洹未久。
    时长老阐陀，晨朝着衣持钵，入波罗奈城乞食。食已还，摄衣钵，洗足已，持户钩，从林至林，从房至房，从经行处至经行处，处处请诸比丘，言：“当教授我，为我说法，令我知法、见法，我当如法知、如法观。”
    时诸比丘语阐陀言：“色无常，受、想、行、识无常，一切行无常，一切法无我，涅槃寂灭。”
    阐陀语诸比丘言：“我已知色无常，受、想、行、识无常，一切行无常，一切法无我，涅槃寂灭。”阐陀复言：“然我不喜闻一切诸行空寂、不可得、爱尽、离欲、涅槃。此中云何有我，而言如是知、如是见，是名见法？”第二、第三亦如是说。
    阐陀复言：“是中谁复有力，堪能为我说法，令我知法、见法？”复作是念：“尊者阿难今在拘睒弥国瞿师罗园，曾供养亲觐世尊，佛所赞叹，诸梵行者皆悉识知。彼必堪能为我说法，令我知法、见法。”
    时阐陀过此夜已，晨朝着衣持钵，入波罗奈城乞食。食已还，摄举卧具。摄卧具已，持衣钵，诣拘睒弥国。渐渐游行，到拘睒弥国，摄举衣钵，洗足已，诣尊者阿难所，共相问讯已，却坐一面。
    时阐陀语尊者阿难言：“一时诸上座比丘住波罗奈国仙人住处鹿野苑中。时我晨朝着衣持钵，入波罗奈城乞食。食已还，摄衣钵，洗足已，持户钩，从林至林，从房至房，从经行处至经行处，处处见诸比丘而请之言：‘当教授我，为我说法，令我知法、见法。’时诸比丘为我说法言：‘色无常，受、想、行、识无常，一切行无常，一切法无我，涅槃寂灭。’我尔时语诸比丘言：‘我已知色无常，受、想、行、识无常，一切行无常，一切法无我，涅槃寂灭。然我不喜闻一切诸行空寂、不可得、爱尽、离欲、涅槃。此中云何有我，而言如是知、如是见，是名见法？’我尔时作是念：‘是中谁复有力，堪能为我说法，令我知法、见法？’我时复作是念：‘尊者阿难今在拘睒弥国瞿师罗园，曾供养亲觐世尊，佛所赞叹，诸梵行者皆悉知识。彼必堪能为我说法，令我知法、见法。’善哉！尊者阿难，今当为我说法，令我知法、见法。”
    时尊者阿难语阐陀言：“善哉！阐陀，我意大喜。我庆仁者能于梵行人前，无所覆藏，破虚伪刺。阐陀，愚痴凡夫所不能解，色无常，受、想、行、识无常，一切诸行无常，一切法无我，涅槃寂灭。汝今堪受胜妙法，汝今谛听，当为汝说。”
    时阐陀作是念：“我今欢喜，得胜妙心，得踊悦心，我今堪能受胜妙法。”
    尔时阿难语阐陀言：“我亲从佛闻，教摩诃迦旃延言：‘世人颠倒，依于二边，若有、若无。世人取诸境界，心便计著。迦旃延，若不受、不取、不住、不计于我，此苦生时生、灭时灭。迦旃延，于此不疑、不惑，不由于他，而能自知，是名正见如来所说。所以者何？迦旃延，如实正观世间集者，则不生世间无见。如实正观世间灭，则不生世间有见。迦旃延，如来离于二边，说于中道。所谓此有故彼有，此生故彼生，谓缘无明有行，乃至生老病死、忧悲恼苦集。所谓此无故彼无，此灭故彼灭，谓无明灭则行灭，乃至生老病死、忧悲恼苦灭。’”
    尊者阿难说是法时，阐陀比丘远尘离垢，得法眼净。尔时阐陀比丘见法、得法、知法、起法，超越狐疑，不由于他，于大师教法，得无所畏。恭敬合掌，白尊者阿难言：“正应如是，如是智慧梵行善知识教授教诫说法。我今从尊者阿难所，闻如是法，于一切行皆空、皆寂、悉不可得、爱尽、离欲、灭尽、涅槃，心乐正住解脱，不复转还，不复见我，唯见正法。”
    时阿难语阐陀言：“汝今得大善利，于甚深佛法中，得圣慧眼。”
    时二正士展转随喜，从座而起，各还本处。

输屡那三种，无明亦有三，
无间等及灭，富留那阐陀。

（二六三）

    如是我闻。一时佛住拘留国杂色牧牛聚落。
    尔时佛告诸比丘：“我以知见故，得诸漏尽，非不知见。云何以知见故，得诸漏尽，非不知见？谓此色、此色集、此色灭。此受、想、行、识，此识集，此识灭。不修方便随顺成就，而用心求令我诸漏尽、心得解脱，当知彼比丘终不能得漏尽解脱。所以者何？不修习故。不修何等？谓不修习念处、正勤、如意足、根、力、觉、道。譬如伏鸡，生子众多，不能随时荫鹨，消息冷暖，而欲令子以觜、以爪啄卵自生，安隐出壳。当知彼子无有自力，堪能方便以觜、以爪安隐出壳。所以者何？以彼鸡母不能随时荫鹨冷暖，长养子故。如是比丘不勤修习随顺成就，而欲令得漏尽解脱，无有是处。所以者何？不修习故。不修何等？谓不修念处、正勤、如意足、根、力、觉、道。
    “若比丘修习随顺成就者，虽不欲令漏尽解脱，而彼比丘自然漏尽，心得解脱。所以者何？以修习故。何所修习？谓修念处、正勤、如意足、根、力、觉、道。如彼伏鸡善养其子，随时荫鹨，冷暖得所，正复不欲令子方便自啄卵出，然其诸子自能方便安隐出壳。所以者何？以彼伏鸡随时荫鹨，冷暖得所故。如是比丘善修方便，正复不欲漏尽解脱，而彼比丘自然漏尽，心得解脱。所以者何？以勤修习故。何所修习？谓修念处、正勤、如意足、根、力、觉、道。
    “譬如巧师、巧师弟子，手执斧柯，捉之不已，渐渐微尽，手指处现，然彼不觉斧柯微尽而尽处现。如是比丘精勤修习随顺成就，不自知见今日尔所漏尽，明日尔所漏尽，然彼比丘知有漏尽。所以者何？以修习故。何所修习？谓修习念处、正勤、如意足、根、力、觉、道。譬如大舶，在于海边，经夏六月，风飘日暴，藤缀渐断。如是比丘精勤修习随顺成就，一切结缚、使、烦恼、缠，渐得解脱。所以者何？善修习故。何所修习？谓修习念处、正勤、如意足、根、力、觉、道。”
    说是法时，六十比丘不起诸漏，心得解脱。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二六四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时有异比丘于禅中思惟，作是念：“颇有色常、恒、不变易、正住耶？如是受、想、行、识，常、恒、不变易、正住耶？”
    是比丘晡时从禅起，往诣佛所，头面礼足，却住一面，白佛言：“世尊，我于禅中思惟，作是念：‘颇有色常、恒、不变易、正住耶？如是受、想、行、识，常、恒、不变易、正住耶？’今白世尊，颇有色常、恒、不变易、正住耶？颇有受、想、行、识，常、恒、不变易、正住耶？”
    尔时世尊手执小土抟，告彼比丘言：“汝见我手中土抟不？”
    比丘白佛：“已见，世尊。”
    “比丘，如是少土，我不可得。若我可得者，则是常、恒、不变易、正住法。”
    佛告比丘：“我自忆宿命，长夜修福，得诸胜妙可爱果报之事。曾于七年中，修习慈心，经七劫成坏，不还此世。七劫坏时，生光音天。七劫成时，还生梵世，空宫殿中作大梵王，无胜、无上，领千世界。从是已后，复三十六反，作天帝释。复百千反，作转轮圣王，领四天下，正法治化。七宝具足，所谓轮宝、象宝、马宝、摩尼宝、玉女宝、主藏臣宝、主兵臣宝。千子具足，皆悉勇健。于四海内，其地平正，无诸毒刺。不威不迫，以法调伏。
    “灌顶王法，有八万四千龙象，皆以众宝庄严而校饰之，宝网覆上，建立宝幢，布萨象王最为导首，朝、晡二时，自会殿前。我时念言：‘是大群象，日日再反往来，蹈杀众生无数，愿令四万二千象百年一来。’即如所愿，八万四千象中，四万二千象百年一至。
    “灌顶王法，复有八万四千匹马，亦以纯金为诸乘具，金网覆上，婆罗马王为其导首。
    “灌顶王法，有八万四千四种宝车，所谓金车、银车、琉璃车、玻璃车，狮子、虎、豹皮、杂色钦婆罗以为覆衬，跋求毗阇耶难提音声之车为其导首。
    “灌顶王法，领八万四千城，安隐丰乐，人民炽盛，拘舍婆提城而为上首。
    “灌顶王法，有八万四千四种宫殿，所谓金、银、琉璃、玻璃，摩尼琉璃由诃而为上首。
    “比丘，灌顶王法，有八万四千四种宝床，所谓金、银、琉璃、玻璃，种种缯褥、氍氀、毾[登+毛]，迦陵伽卧具以敷其上，安置丹枕。
    “复次比丘，灌顶王法，复有八万四千四种衣服，所谓迦尸细衣、刍摩衣、头鸠罗衣、拘沾婆衣。
    “复次比丘，灌顶王法，有八万四千玉女，所谓刹利女、似刹利女，况复余女。
    “复次比丘，灌顶王法，有八万四千饮食，众味具足。
    “比丘，八万四千玉女中，唯以一人以为给侍。八万四千宝衣，唯着一衣。八万四千宝床，唯卧一床。八万四千宫殿，唯处一殿。八万四千城，唯居一城，名拘舍婆提。八万四千宝车，唯乘一车，名毗阇耶难提瞿沙，出城游观。八万四千宝马，唯乘一马，名婆罗诃，毛尾绀色。八万四千龙象，唯乘一象，名布萨陀，出城游观。
    “比丘，此是何等业报，得如是威德自在耶？此是三种业报。云何为三？一者布施，二者调伏，三者修道。比丘当知，凡夫染习五欲，无有厌足。圣人智慧成满，而常知足。比丘，一切诸行，过去尽灭、过去变易，彼自然众具，及以名称，皆悉磨灭。是故比丘，永息诸行，厌离、断欲、解脱。比丘，色为常、无常？”
    比丘白佛言：“无常，世尊。”
    “若无常者，是苦耶？”
    比丘白佛言：“是苦，世尊。”
    “比丘，若无常、苦，是变易法。圣弟子宁复于中计我、异我、相在不？”
    比丘白佛：“不也，世尊。”
    “如是受、想、行、识，为常、为无常？”
    比丘白佛言：“无常，世尊。”
    “若无常者，是苦耶？”
    比丘白佛言：“是苦，世尊。”
    “比丘，若无常、苦，是变易法。圣弟子宁复于中计我、异我、相在不？”
    比丘白佛：“不也，世尊。”
    佛告比丘：“诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、不异我、不相在。如是受、想、行、识，若过去、若未来，若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、不异我、不相在。比丘，于色当生厌、离欲、解脱。如是于受、想、行、识，当生厌、离欲、解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。”
    时彼比丘闻佛所说，踊跃欢喜，作礼而去。常念土抟譬教授，独一静处，精勤思惟，不放逸住。不放逸住已，所以善男子剃除须发，正信非家，出家学道，为究竟无上梵行，见法自知身作证：我生已尽，梵行已立，所作已作，自知不受后有。时彼尊者亦自知法，心得解脱，成阿罗汉。

（二六五）

    如是我闻。一时佛住阿毗陀处恒河侧。
    尔时世尊告诸比丘：“譬如恒河大水暴起，随流聚沫。明目士夫谛观分别，谛观分别时，无所有、无牢、无实、无有坚固。所以者何？彼聚沫中无坚实故。如是诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，比丘谛观思惟分别，无所有、无牢、无实、无有坚固，如病、如痈、如刺、如杀，无常、苦、空、非我。所以者何？色无坚实故。
    “诸比丘，譬如大雨水泡，一起一灭。明目士夫谛观思惟分别，谛观思惟分别时，无所有、无牢、无实、无有坚固。所以者何？以彼水泡无坚实故。如是比丘，诸所有受，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，比丘谛观思惟分别，谛观思惟分别时，无所有、无牢、无实、无有坚固，如病、如痈、如刺、如杀，无常、苦、空、非我。所以者何？以受无坚实故。
    “诸比丘，譬如春末夏初，无云无雨，日盛中时，野马流动。明目士夫谛观思惟分别，谛观思惟分别时，无所有、无牢、无实、无有坚固。所以者何？以彼野马无坚实故。如是比丘，诸所有想，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，比丘谛观思惟分别，谛观思惟分别时，无所有、无牢、无实、无有坚固，如病、如痈、如刺、如杀，无常、苦、空、非我。所以者何？以想无坚实故。
    “诸比丘，譬如明目士夫求坚固材，执持利斧，入于山林，见大芭蕉树，臃直长大，即伐其根，斩截其峰，叶叶次剥，都无坚实。谛观思惟分别，谛观思惟分别时，无所有、无牢、无实、无有坚固。所以者何？以彼芭蕉无坚实故。如是比丘，诸所有行，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，比丘谛观思惟分别，谛观思惟分别时，无所有、无牢、无实、无有坚固，如病、如痈、如刺、如杀，无常、苦、空、非我。所以者何？以彼诸行无坚实故。
    “诸比丘，譬如幻师、若幻师弟子，于四衢道头，幻作象兵、马兵、车兵、步兵。有智明目士夫，谛观思惟分别，谛观思惟分别时，无所有、无牢、无实、无有坚固。所以者何？以彼幻无坚实故。如是比丘，诸所有识，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，比丘谛观思惟分别，谛观思惟分别时，无所有、无牢、无实、无有坚固，如病、如痈、如刺、如杀，无常、苦、空、非我。所以者何？以识无坚实故。”
    尔时世尊欲重宣此义，而说偈言：

“观色如聚沫，受如水上泡，
想如春时焰，诸行如芭蕉，
诸识法如幻，日种姓尊说。
周匝谛思惟，正念善观察，
无实不坚固，无有我我所。
于此苦阴身，大智分别说，
离于三法者，身为成弃物。
寿暖及诸识，离此余身分，
永弃丘冢间，如木无识想。
此身常如是，幻伪诱愚夫，
如杀如毒刺，无有坚固者。
比丘勤修习，观察此阴身，
昼夜常专精，正智系念住，
有为行长息，永得清凉处。”

    时诸比丘闻佛所说，欢喜奉行。

（二六六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时佛告诸比丘：“于无始生死，无明所盖，爱结所系，长夜轮回，不知苦之本际。
    “有时长久不雨，地之所生百谷草木，皆悉枯干。诸比丘，若无明所盖，爱结所系，众生生死轮回，爱结不断，不尽苦边。
    “诸比丘，有时长夜不雨，大海水悉皆枯竭。诸比丘，无明所盖，爱结所系，众生生死轮回，爱结不断，不尽苦边。
    “诸比丘，有时长夜，须弥山王皆悉崩落。无明所盖，爱结所系，众生长夜生死轮回，爱结不断，不尽苦边。
    “诸比丘，有时长夜，此大地悉皆败坏。而众生无明所盖，爱结所系，众生长夜生死轮回，爱结不断，不尽苦边。
    “比丘，譬如狗子系柱，彼系不断，长夜绕柱，轮回而转。如是比丘，愚夫众生不如实知色、色集、色灭、色味、色患、色离，长夜轮回，顺色而转。如是不如实知受、想、行、识，识集、识灭、识味、识患、识离，长夜轮回，顺识而转。诸比丘，随色转、随受转、随想转、随行转、随识转。随色转故，不脱于色。随受、想、行、识转故，不脱于识。以不脱故，不脱生老病死、忧悲恼苦。
    “多闻圣弟子如实知色、色集、色灭、色味、色患、色离；如实知受、想、行、识，识集、识灭、识味、识患、识离故，不随识转。不随转故，脱于色，脱于受、想、行、识，我说脱于生老病死、忧悲恼苦。”
    佛说此经已，时诸比丘闻佛所说，欢喜奉行。

（二六七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生于无始生死，无明所盖，爱结所系，长夜轮回生死，不知苦际。诸比丘，譬如狗绳系着柱，结系不断故，顺柱而转，若住若卧，不离于柱。如是凡愚众生，于色不离贪欲、不离爱、不离念、不离渴，轮回于色，随色转，若住若卧，不离于色。如是受、想、行、识，随受、想、行、识转，若住若卧，不离于识。
    “诸比丘，当善思惟观察于心。所以者何？长夜心为贪欲所染，瞋恚、愚痴所染故。比丘，心恼故众生恼，心净故众生净。比丘，我不见一色种种如斑色鸟，心复过是。所以者何？彼畜生心种种故，色种种。是故比丘，当善思惟观察于心。诸比丘，长夜心贪欲所染，瞋恚、愚痴所染。心恼故众生恼，心净故众生净。比丘当知，汝见嗟兰那鸟，种种杂色不？”
    答言：“曾见，世尊。”
    佛告比丘：“如嗟兰那鸟，种种杂色，我说彼心种种杂，亦复如是。所以者何？彼嗟兰那鸟，心种种故，其色种种。是故当善观察思惟于心，长夜种种贪欲、瞋恚、愚痴所染。心恼故众生恼，心净故众生净。
    “譬如画师、画师弟子，善治素地，具众彩色，随意图画种种像类。如是比丘，凡愚众生不如实知色、色集、色灭、色味、色患、色离，于色不如实知故，乐著于色；乐著色故，复生未来诸色。如是凡愚不如实知受、想、行、识，识集、识灭、识味、识患、识离，不如实知故，乐著于识；乐著识故，复生未来诸识。当生未来色、受、想、行、识故，于色不解脱，受、想、行、识不解脱，我说彼不解脱生老病死、忧悲恼苦。
    “有多闻圣弟子，如实知色、色集、色灭、色味、色患、色离，如实知故，不乐著于色；以不乐著故，不生未来色。如实知受、想、行、识，识集、识灭、识味、识患、识离，如实知故，不染著于识；不乐著故，不生未来诸识。不乐著于色、受、想、行、识故，于色得解脱，受、想、行、识得解脱，我说彼等解脱生老病死、忧悲恼苦。
    佛说此经已，时诸比丘闻佛所说，欢喜奉行。

（二六八）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“譬如河水从山涧出，彼水深驶，其流激注，多所漂没。其河两岸，生杂草木，大水所偃，顺靡水边。众人涉渡，多为水所漂，随流没溺，遇浪近岸，手援草木，草木复断，还随水漂。
    “如是比丘，若凡愚众生不如实知色、色集、色灭、色味、色患、色离，不如实知故，乐著于色，言色是我，彼色随断。如是不如实知受、想、行、识、识集、识灭、识味、识患、识离，不如实知故，乐著于识，言识是我，识复随断。
    “若多闻圣弟子，如实知色、色集、色灭、色味、色患、色离，如实知故，不乐著于色。如实知受、想、行、识、识集、识灭、识味、识患、识离，如实知故，不乐著识。不乐著故，如是自知得般涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，时诸比丘闻佛所说，欢喜奉行。

（二六九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“非汝所应法，当尽舍离，舍彼法已，长夜安乐。比丘，何等法非汝所应，当速舍离？如是色、受、想、行、识，非汝所应，当尽舍离，断彼法已，长夜安乐。譬如祇桓林中树木，有人斫伐枝条，担持而去，汝等亦不忧戚。所以者何？以彼树木非我、非我所。如是比丘，非汝所应者，当尽舍离，舍离已，长夜安乐。何等非汝所应？色非汝所应，当尽舍离，舍离已，长夜安乐。如是受、想、行、识，非汝所应，当速舍离，舍彼法已，长夜安乐。诸比丘，色为常耶，为无常耶？”
    诸比丘白佛言：“无常，世尊。”
    “比丘，无常者，为是苦耶？”
    答言：“是苦，世尊。”
    佛告比丘：“若无常、苦，是变易法。多闻圣弟子宁于中见有我、异我、相在不？”
    答言：“不也，世尊。”
    “如是受、想、行、识，为是常耶，无常耶？”
    答言：“无常，世尊。”
    “比丘，若无常者，是苦耶？”
    答言：“是苦，世尊。”
    佛告比丘：“若无常、苦，是变易法。多闻圣弟子宁于中见有我、异我、相在不？”
    答言：“不也，世尊。”
    “比丘，是故诸所有色，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、不异我、不相在。如是受、想、行、识，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、不异我、不相在。圣弟子观此五受阴非我、非我所。如是观时，于诸世间无所取著，无所取著者自得涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，时诸比丘闻佛所说，欢喜奉行。

（二七○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“无常想修习多修习，能断一切欲爱、色爱、无色爱、掉、慢、无明。
    “譬如田夫，于夏末秋初，深耕其地，发荄断草。如是比丘，无常想修习多修习，能断一切欲爱、色爱、无色爱、掉、慢、无明。
    “譬如比丘，如人刈草，手揽其端，举而抖擞，萎枯悉落，取其长者。如是比丘，无常想修习多修习，能断一切欲爱、色爱、无色爱、掉、慢、无明。
    “譬如庵罗果着树，猛风摇条，果悉堕落。如是无常想修习多修习，能断一切欲爱、色爱、无色爱、掉、慢、无明。
    “譬如楼阁，中心坚固，众材所依，摄受不散。如是无常想修习多修习，能断一切欲爱、色爱、无色爱、掉、慢、无明。
    “譬如一切众生迹，象迹为大，能摄受故。如是无常想修习多修习，能断一切欲爱、色爱、无色爱、掉、慢、无明。
    “譬如阎浮提一切诸河，悉趣大海，其大海者最为第一，悉摄受故。如是无常想修习多修习，能断一切欲爱、色爱、无色爱、掉、慢、无明。
    “譬如日出，能除一切世间暗冥。如是无常想修习多修习，能断一切欲爱、色爱、无色爱、掉、慢、无明。
    “譬如转轮圣王，于诸小王最上、最胜。如是无常想修习多修习，能断一切欲爱、色爱、无色爱、掉、慢、无明。
    “诸比丘，云何修无常想，修习多修习，能断一切欲爱、色爱、无色爱、掉、慢、无明？若比丘于空露地，若林树间，善正思惟，观察色无常，受、想、行、识无常。如是思惟，断一切欲爱、色爱、无色爱、掉、慢、无明。所以者何？无常想者，能建立无我想。圣弟子住无我想，心离我慢，顺得涅槃。”
    佛说是经已，时诸比丘闻佛所说，欢喜奉行。

（二七一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时有比丘名曰低舍，与众多比丘集于食堂，语诸比丘言：“诸尊，我不分别于法，不乐修梵行，多乐睡眠，疑惑于法。”
    尔时众中有一比丘，往诣佛所，礼佛足，却住一面，白佛言：“世尊，低舍比丘以众多比丘集于食堂，作如是说，唱言：‘我不能分别于法，不乐修梵行，多乐睡眠，疑惑于法。’”
    佛告比丘：“是低舍比丘是愚痴人，不守根门，饮食不知量，初夜、后夜，心不觉悟，懈怠懒惰，不勤精进，不善观察思惟善法。彼于分别法，心乐修梵行，离诸睡眠，于正法中离诸疑惑，无有是处。若当比丘守护根门，饮食知量，初夜、后夜，觉悟精进，观察善法，乐分别法，乐修梵行，离于睡眠，心不疑法，斯有是处。”
    尔时世尊告一比丘：“汝往语低舍比丘言：大师呼汝。”
    比丘白佛：“唯然受教。”前礼佛足，诣低舍所，而作是言：“长老低舍，世尊呼汝。”
    低舍闻命，诣世尊所，稽首礼足，却住一面。
    尔时世尊语低舍比丘言：“汝低舍，实与众多比丘集于食堂，作是唱言：“诸长老，我不能分别于法，不乐修梵行，多乐睡眠，疑惑于法耶？”
    低舍白佛：“实尔，世尊。”
    佛问低舍：“我今问汝，随汝意答。于意云何？若于色不离贪、不离欲、不离爱、不离念、不离渴，彼色若变、若异，于汝意云何，当起忧悲恼苦为不耶？”
    低舍白佛：“如是，世尊。若于色不离贪、不离欲、不离爱、不离念、不离渴，彼色若变、若异，实起忧悲恼苦。世尊，实尔不异。”
    佛告低舍：“善哉善哉！低舍，正应如是不离贪欲说法。低舍，于受、想、行、识，不离贪、不离欲、不离爱、不离念、不离渴，彼识若变、若异，于汝意云何，当起忧悲恼苦为不耶？”
    低舍白佛：“如是，世尊。于识不离贪、不离欲、不离爱、不离念、不离渴，彼识若变、若异，实起忧悲恼苦。世尊，实尔不异。”
    佛告低舍：“善哉善哉！正应如是识不离贪欲说法。”
    佛告低舍：“于意云何？若于色离贪、离欲、离爱、离念、离渴，彼色若变、若异，时当生忧悲恼苦耶？”
    低舍白佛：“不也，世尊，如是不异。”
    “于意云何？受、想、行、识，离贪、离欲、离爱、离念、离渴，彼识若变、若异，当生忧悲恼苦耶？”
    低舍答曰：“不也，世尊，如是不异。”
    佛告低舍：“善哉善哉！低舍，今当说譬，夫智慧者以譬得解。如二士夫，共伴行一路，一善知路，一不知路。其不知者语知路者，作如是言：‘我欲诣某城、某村、某聚落，当示我路。’时知路者即示彼路，语言：‘士夫，从此道去，前见二道，舍左从右。前行复有坑涧渠流，复当舍左从右。复有丛林，复当舍左从右。汝当如是渐渐前行，得至某城。’”
    佛告低舍：“其譬如是，不知路者，譬愚痴凡夫。其知路者，譬如来、应、等正觉。前二路者，谓众生狐疑。左路者，三不善法，贪、恚、害觉。其右路者，谓三善觉，出要离欲觉、不瞋觉、不害觉。前行左路者，谓邪见、邪志、邪语、邪业、邪命、邪方便、邪念、邪定。前行右路者，谓正见、正志、正语、正业、正命、正方便、正念、正定。坑涧渠流者，谓瞋恚、覆障、忧悲。丛林者，谓五欲功德也。城者，谓般涅槃。”
    佛告低舍：“佛为大师，为诸声闻所作已作，如今当作，哀愍悲念，以义安乐，皆悉已作。汝等今日当作所作，当于树下，或空露地，山岩窟宅，敷草为座，善思正念，修不放逸，莫令久后心有悔恨。我今教汝。”
    尔时低舍闻佛所说，欢喜奉行。

（二七二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时众中有少诤事。世尊责诸比丘故，晨朝着衣持钵，入城乞食。食已出，摄举衣钵，洗足，入安陀林，坐一树下，独静思惟。作是念：“众中有少诤事，我责诸比丘。然彼众中多年少比丘，出家未久，不见大师，或起悔心，愁忧不乐。我已长夜于诸比丘生哀愍心，今当复还，摄取彼众，以哀愍故。”
    时大梵王知佛心念，如力士屈伸臂顷，从梵天没，住于佛前，而白佛言：“如是，世尊！如是，善逝！责诸比丘，以少诤事故。于彼众中多有年少比丘，出家未久，不见大师，或起悔心，愁忧不乐。世尊长夜哀愍摄受众僧。善哉世尊！愿今当还，摄诸比丘。”
    尔时世尊心已垂愍梵天故，默然而许。
    时大梵天知佛世尊默然已许，为佛作礼，右绕三匝，忽然不现。
    尔时世尊，大梵天王还去未久，即还祇树给孤独园，敷尼师坛，敛身正坐，表现微相，令诸比丘敢来奉见。
    时诸比丘来诣佛所，怀惭愧色，前礼佛足，却坐一面。
    尔时世尊告诸比丘：“出家之人，卑下活命，剃发持钵，家家乞食，如被禁咒。所以然者，为求胜义故，为度生老病死、忧悲恼苦，究竟苦边故。诸善男子，汝不为王、贼所使，非负债人，不为恐怖，不为失命而出家，正为解脱生老病死、忧悲恼苦。汝等不为此而出家耶？”
    比丘白佛：“实尔，世尊。”
    佛告比丘：“汝等比丘为如是胜义而出家，云何于中，犹复有一愚痴凡夫而起贪欲，极生染著，瞋恚凶暴，懈怠下劣，失念不定，诸根迷乱。譬如士夫从暗而入暗，从冥入冥，从粪厕出复堕粪厕，以血洗血，舍离诸恶还复取恶。我说此譬，凡愚比丘亦复如是。又复譬如焚尸火栝，捐弃冢间，不为樵伐之所采拾。我说此譬，愚痴凡夫比丘而起贪欲，极生染著，瞋恚凶暴，懈怠下劣，失念不定，诸根散乱，亦复如是。
    “比丘，有三不善觉法。何等为三？贪觉、恚觉、害觉。此三觉由想而起。云何想？想有无量种种，贪想、恚想、害想，诸不善觉从此而生。
    “比丘，贪想、恚想、害想，贪觉、恚觉、害觉，及无量种种不善，云何究竟灭尽？于四念处系心，住无相三昧，修习多修习，恶不善法从是而灭，无余永尽。正以此法，善男子、善女人信乐出家，修习无相三昧，修习多修习已，住甘露门，乃至究竟甘露涅槃。
    “我不说此甘露涅槃，依三见者。何等为三？有一种见，如是如是说：命则是身；复有如是见：命异身异；又作是说：色是我，无二无异，长存不变。
    “多闻圣弟子作是思惟：‘世间颇有一法可取，而无罪过者？’思惟已，都不见一法可取，而无罪过者。我若取色，即有罪过。若取受、想、行、识，则有罪过。作是知已，于诸世间则无所取，无所取者自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，时诸比丘闻佛所说，欢喜奉行。

应说小土抟，泡沫二无知，
河流祇林树，低舍责诸想。


杂阿含经卷第十一

（二七三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘独静思惟：“云何为我？我何所为？何等是我？我何所住？”从禅觉已，往诣佛所，稽首礼足，退住一面，白佛言：“世尊，我独一静处，作是思惟：云何为我？我何所为？何法是我？我于何住？”
    佛告比丘：“今当为汝说于二法，谛听善思。云何为二？眼、色为二，耳、声，鼻、香，舌、味，身、触，意、法为二，是名二法。比丘，若有说言：‘沙门瞿昙所说二法，此非为二。我今舍此，更立二法。’彼但有言数，问已不知，增其疑惑，以非境界故。所以者何？缘眼、色，生眼识。比丘，彼眼者，是肉形、是内、是因缘、是坚、是受，是名眼肉形内地界。比丘，若眼肉形、若内、若因缘、津泽、是受，是名眼肉形内水界。比丘，若彼眼肉形、若内、若因缘、明暖、是受，是名眼肉形内火界。比丘，若彼眼肉形、若内、若因缘、轻飘动摇、是受，是名眼肉形内风界。比丘，譬如两手和合，相对作声。如是缘眼、色，生眼识，三事和合触，触俱生受、想、思，此等诸法非我、非常，是无常之我，非恒、非安隐、变易之我。所以者何？比丘，谓生、老、死、没、受生之法。比丘，诸行如幻、如焰，刹那时顷尽朽，不实来实去。是故比丘，于空诸行当知、当喜、当念，空诸行常、恒、住、不变易法空、无我、我所。譬如明目士夫，手执明灯，入于空室，彼空室观察。如是比丘，于一切空行，心观察欢喜，于空法行常、恒、住、不变易法，空我、我所。如眼、耳、鼻、舌、身、意法因缘生意识，三事和合触，触俱生受、想、思，此诸法无我、无常，乃至空我、我所。比丘，于意云何？眼是常，为非常耶？”
    答言：“非常，世尊。”
    复问：“若无常者，是苦耶？”
    答言：“是苦，世尊。”
    复问：“若无常、苦，是变易法。多闻圣弟子宁于中见我、异我、相在不？”
    答言：“不也，世尊。”
    “耳、鼻、舌、身、意，亦复如是。如是多闻圣弟子于眼生厌，厌故不乐，不乐故解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。耳、鼻、舌、身、意，亦复如是。”
    时彼比丘闻世尊说合手声譬经教已，独一静处，专精思惟，不放逸住，乃至自知不受后有，成阿罗汉。

（二七四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“非汝有者，当尽弃舍，舍彼法已，长夜安乐。诸比丘，于意云何？于此祇桓中，诸草木枝叶，有人持去。汝等颇有念言：此诸物是我所，彼人何故辄持去？”
    答言：“不也，世尊。所以者何？彼亦非我、非我所故。”
    “汝诸比丘亦复如是，于非所有物，当尽弃舍，舍彼法已，长夜安乐。何等为非汝所有？谓眼，眼非汝所有，彼应弃舍，舍彼法已，长夜安乐。耳、鼻、舌、身、意，亦复如是。云何比丘，眼是常耶，为非常耶？”
    答言：“无常，世尊。”
    复问：“若无常者，是苦耶？”
    答言：“是苦，世尊。”
    复问：“若无常、苦者，是变易法。多闻圣弟子宁于中见我、异我、相在不？”
    答言：“不也，世尊。”
    “耳、鼻、舌、身、意，亦复如是。多闻圣弟子于此六入处，观察非我、非我所。观察已，于诸世间都无所取，无所取故无所著，无所著故自觉涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二七五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“其有说言，有大力者，其唯难陀，此是正说。其有说言，最端正者，其唯难陀，是则正说。其有说言，爱欲重者，其唯难陀，是则正说。诸比丘，而今难陀关闭根门，饮食知量，初夜、后夜精勤修习，正智成就，堪能尽寿，纯一满净，梵行清白。
    “彼难陀比丘关闭根门故，若眼见色，不取色相，不取随形好。若诸眼根增不律仪、无明暗障、世间贪忧、恶不善法，不漏其心，生诸律仪，防护于眼。耳、鼻、舌、身、意根，生诸律仪。是名难陀比丘关闭根门。
    “饮食知量者，难陀比丘于食系数，不自高，不放逸，不著色，不著庄严，支身而已。任其所得，为止饥渴，修梵行故；故起苦觉令息灭，未起苦觉令不起故；成其崇向故；气力安乐，无间独住故。如人乘车，涂以膏油，不为自高乃至庄严，为载运故。又如涂疮，不贪其味，为息苦故。如是善男子难陀，知量而食，乃至无间独住。是名难陀知量而食。
    “彼善男子难陀初夜、后夜精勤修业者，彼难陀昼则经行、坐禅，除去阴障，以净其身。于初夜时，经行、坐禅，除去阴障，以净其身。于中夜时，房外洗足，入于室中，右胁而卧，屈膝累足，系念明相，作起觉想。于后夜时，徐觉徐起，经行、坐禅。是名善男子难陀初夜、后夜精勤修习。
    “彼善男子难陀胜念正知者，是善男子难陀，观察东方，一心正念，安住观察。观察南、西、北方，亦复如是，一心正念，安住观察。如是观者，世间贪忧、恶不善法，不漏其心。彼善男子难陀，觉诸受起，觉诸受住，觉诸受灭，正念而住，不令散乱。觉诸想起，觉诸想住，觉诸想灭；觉诸觉起，觉诸觉住，觉诸觉灭，正念而住，不令散乱。是名善男子难陀正念正智成就。
    “是故诸比丘，当作是学。关闭根门，如善男子难陀。饮食知量，如善男子难陀。初夜、后夜精勤修业，如善男子难陀。正念正智成就，如善男子难陀。如教授难陀法，亦当持是为其余人说。”
    时有异比丘而说偈言：

“善关闭根门，正念摄心住，
饮食知节量，觉知诸心相，
善男子难陀，世尊之所叹。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二七六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时有如是像类大声闻尼众，住舍卫国王园中。比丘尼众其名曰：纯陀比丘尼、民陀比丘尼、摩罗婆比丘尼、波罗遮罗比丘尼、阿罗毗迦比丘尼、差摩比丘尼、难摩比丘尼、告难舍瞿昙弥比丘尼、优钵罗色比丘尼、摩诃波阇波提比丘尼，此等及余比丘尼，住王园中。
    尔时摩诃波阇波提比丘尼，与五百比丘尼前后围绕，来诣佛所，稽首礼足，退坐一面。
    尔时世尊为摩诃波阇波提比丘尼说法，示教照喜。种种说法，示教照喜已，发遣令还，言：“比丘尼，应时宜去。”
    摩诃波阇波提比丘尼闻佛所说，欢喜随喜，作礼而去。
    尔时世尊知摩诃波阇波提比丘尼去已，告诸比丘：“我年已老迈，不复堪能为诸比丘尼说法。汝等诸比丘僧，今日诸宿德上座，当教授诸比丘尼。”
    时诸比丘受世尊教，次第教授比丘尼。次至难陀，尔时难陀次第应至，而不欲教授。
    尔时摩诃波阇波提比丘尼，与五百比丘尼前后围绕，诣世尊所，稽首礼足，乃至闻法，欢喜随喜，作礼而去。
    尔时世尊知摩诃波阇波提比丘尼去已，问尊者阿难：“谁应次至教授诸比丘尼？”
    尊者阿难白佛言：“世尊，诸上座次第教授比丘尼，次至难陀，而难陀不欲教授。”
    尔时世尊告难陀言：“汝当教授诸比丘尼，为诸比丘尼说法。所以者何？我自教授比丘尼，汝亦应尔。我为比丘尼说法，汝亦应尔。”
    尔时难陀默然受教。时难陀夜过晨朝，着衣持钵，入舍卫城乞食。食已，还精舍，举衣钵，洗足已，入室坐禅。从禅觉，着僧伽梨，将一比丘往诣王园。
    诸比丘尼遥见尊者难陀来，疾敷床座，请令就坐。尊者难陀坐已，诸比丘尼稽首敬礼，退坐一面。
    尊者难陀语诸比丘尼：“诸姊妹！汝等当问，我今当为汝等说法。汝等解者，当说言解。若不解者，当说不解。于我所说义，若当解者，当善受持。若不解者，汝当更问，当为汝说。”
    诸比丘尼白尊者难陀言：“我等今日闻尊者教，令我等问，告我等言：‘汝等若未解者，今悉当问。已解者当言解，未解者当言不解。于我所说义，已解者当奉持，未解者当复更问。’我等闻此，心大欢喜。未解义者，今日当问。”
    尔时尊者难陀告诸比丘尼：“云何姊妹？于眼内入处观察，是我、异我、相在不？”
    答言：“不也，尊者难陀。”
    “耳、鼻、舌、身、意内入处观察，是我、异我、相在不？”
    答言：“不也，尊者难陀。所以者何？尊者难陀，我等已曾于此法如实知见，于六内入处观察无我。我等已曾作如是意解，六内入处无我。”
    尊者难陀告诸比丘尼：“善哉善哉！姊妹，应如是解，六内入处观察无我。诸比丘尼，色外入处是我、异我、相在不？”
    答言：“不也，尊者难陀。”
    “声、香、味、触、法外入处，是我、异我、相在不？”
    答言：“不也，尊者难陀。所以者何？尊者难陀，我已曾于六外入处，如实观察无我。我常作此意解，六外入处如实无我。”
    尊者难陀赞诸比丘尼：“善哉善哉！汝于此义应如是观，六外入处无我。若缘眼、色，生眼识，彼眼识是我、异我、相在不？”
    答言：“不也，尊者难陀。”
    “耳、鼻、舌、身、意法缘生意识，彼意识是我、异我、相在不？”
    答言：“不也，尊者难陀。所以者何？我已曾于此六识身，如实观察无我。我亦常作是意解，六识身如实无我。”
    尊者难陀告诸比丘尼：“善哉善哉！姊妹，汝于此义应如是观察，六识身如实无我。缘眼、色，生眼识，三事和合生触，彼触是我、异我、相在不？”
    答言：“不也，尊者难陀。”
    “耳、鼻、舌、身、意法缘生意识，三事和合生触，彼触是我、异我、相在不？”
    答言：“不也，尊者难陀。所以者何？我已曾于此六触，观察如实无我。我亦常如是意解，六触如实无我。”
    尊者难陀告诸比丘尼：“善哉善哉！当如实观察，于六触身如实无我。缘眼、色，生眼识，三事和合触，触缘受，彼触缘受是我、异我、相在不？”
    答言：“不也，尊者难陀。”
    “耳、鼻、舌、身、意法缘生意识，三事和合触，触缘受，彼受是我、异我、相在不？”
    答言：“不也，尊者难陀。所以者何？我等曾于此六受身，如实观察无我。我亦常作此意解，六受身如实无我。”
    尊者难陀告诸比丘尼：“善哉善哉！汝于此义应如是观察，此六受身如实无我。缘眼、色，生眼识，三事和合生触，触缘想，彼想是我、异我、相在不？”
    答言：“不也，尊者难陀。”
    “耳、鼻、舌、身、意法缘生意识，三事和合生触，触缘想，彼想是我、异我、相在不？”
    答言：“不也，尊者难陀。所以者何？我曾于此六想身，如实观察无我。我亦常作此意解，六想身如实无我。”
    尊者难陀告诸比丘尼：“善哉善哉！比丘尼，汝于此义应如是观察，此六想身如实无我。缘眼、色，生眼识，三事和合触，触缘思，彼思是我、异我、相在不？”
    答言：“不也，尊者难陀。”
    “耳、鼻、舌、身、意法缘生意识，三事和合触，触缘思，彼思是我、异我、相在不？”
    答言：“不也，尊者难陀。所以者何？我曾于此六思身，如实观察无我。我常作此意解，此六思身如实无我。”
    尊者难陀告诸比丘尼：“善哉善哉！比丘尼，汝于此义应如是观察，此六思身如实无我。缘眼、色，生眼识，三事和合触，触缘爱，彼爱是我、异我、相在不？”
    答言：“不也，尊者难陀。”
    “耳、鼻、舌、身、意法缘生意识，三事和合触，触缘爱，彼爱是我、异我、相在不？”
    答言：“不也，尊者难陀。所以者何？我曾于此六爱身，如实观察无我。我常作此意解，此六爱身如实无我。”
    尊者难陀告诸比丘尼：“汝于此义应如是观察，此六爱身如实无我。姊妹！譬因膏油，因炷，灯明得燃。彼油无常，炷亦无常，火亦无常，器亦无常。若有作是言：‘无油、无炷、无火、无器，而所依起灯光，常、恒、住、不变易。’作是说者，为等说不？”
    答言：“不也，尊者难陀。所以者何？缘油、炷、器燃灯，彼油、炷、器悉无常，若无油、无炷、无器，所依灯光亦复随灭、息、没、清凉、真实。”
    “如是姊妹，此六内入处无常。若有说言：‘此六内入处因缘生喜乐，常、恒、住、不变易、安隐。’是为等说不？”
    答言：“不也，尊者难陀。所以者何？我等曾如实观察：彼彼法缘，生彼彼法；彼彼缘法灭，彼彼生法亦复随灭、息、没、清凉、真实。”
    尊者难陀告诸比丘尼：“善哉善哉！比丘尼，汝于此义应如是观察：彼彼法缘，生彼彼法；彼彼法缘灭，彼彼生法亦复随灭、息、没、寂静、清凉、真实。诸姊妹！譬如大树根、茎、枝、叶，根亦无常，茎、枝、叶皆悉无常。若有说言：‘无彼树根、茎、枝、叶，唯有其影常、恒、住、不变易、安隐者。’为等说不？”
    答言：“不也，尊者难陀。所以者何？如彼大树根、茎、枝、叶，彼根亦无常，茎、枝、叶亦复无常。无根、无茎、无枝、无叶，所依树影，一切悉无。”
    “诸姊妹，若缘外六入处无常。若言：‘外六入处因缘生喜乐，常、恒、住、不变易、安隐者。’此为等说不？”
    答言：“不也，尊者难陀。所以者何？我曾于此义如实观察：彼彼法缘，生彼彼法；彼彼法缘灭，彼彼生法亦复随灭、息、没、寂静、清凉、真实。”
    尊者难陀告诸比丘尼：“善哉善哉！姊妹，汝于此义当如实观察：彼彼法缘，生彼彼法；彼彼法缘灭，彼彼生法亦复随灭、息、没、寂灭、清凉、真实。诸姊妹！听我说譬，夫智者因譬得解。譬如善屠牛师、屠牛弟子，手执利刀，解剥其牛，乘间而剥，不伤内肉，不伤外皮，解其肢节、筋骨，然后还以皮覆其上。若有人言：‘此牛皮、肉，全而不离。’为等说不？”
    答言：“不也，尊者难陀。所以者何？彼善屠牛师、屠牛弟子，手执利刀，乘间而剥，不伤皮肉，肢节、筋骨悉皆断截，还以皮覆上。皮、肉已离，非不离也。”
    “姊妹，我说所譬，今当说义。牛者譬人身粗色，如《箧毒蛇经》广说。肉者，谓内六入处。外皮者，谓外六入处。屠牛者，谓学见迹。皮肉中间筋骨者，谓贪喜俱。利刀者，谓利智慧。多闻圣弟子以智慧利刀，断截一切结、缚、使、烦恼、上烦恼、缠。是故诸姊妹，当如是学：于所可乐法，心不应著，断除贪故。所可瞋法，不应生瞋，断除瞋故。所可痴法，不应生痴，断除痴故。于五受阴，当观生灭。于六触入处，当观集灭。于四念处，当善系心，住七觉分。修七觉分已，于其欲漏，心不缘著，心得解脱。于其有漏，心不缘著，心得解脱。于无明漏，心不缘著，心得解脱。诸姊妹！当如是学。”
    尔时尊者难陀为诸比丘尼说法，示教照喜。示教照喜已，从座起去。
    时摩诃波阇波提比丘尼，与五百比丘尼眷属围绕，往诣佛所，稽首礼足，退住一面，乃至为佛作礼而去。
    尔时世尊知摩诃波阇波提比丘尼去已，告诸比丘：“譬如明月十四日夜，多众观月，为是满耶，为未满耶？当知彼月未究竟满。如是善男子难陀，为五百比丘尼正教授、正说法，于其解脱犹未究竟。然此等比丘尼，命终之时，不见一结不断，能使彼还生于此世。”
    尔时世尊复告难陀：“更为诸比丘尼说法。”
    尔时尊者难陀默然奉教。夜过晨朝，持钵入城乞食，食已，乃至往诣王园，就座而坐，为诸比丘尼说法，示教照喜。示教照喜已，从座起去。
    摩诃波阇波提比丘尼，复于异时，与五百比丘尼前后围绕，往诣佛所，稽首礼足，乃至作礼而去。
    尔时世尊知摩诃波阇波提比丘尼去已，告诸比丘：“譬如明月十五日夜，无有人疑月满不满者，然其彼月究竟圆满。如是善男子难陀，为诸比丘尼说如是正教授，究竟解脱。若命终时，无有说彼道路所趣，此当知即是苦边。”
    是为世尊为五百比丘尼授第一果记。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二七七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有不律仪、律仪。谛听善思，当为汝说。
    “云何不律仪？眼根不律仪所摄护，眼识著色；缘著故，以生苦受；苦受故，不一其心；不一心故，不得如实知见；不得如实知见故，不离疑惑；不离疑惑故，由他所误，而常苦住。耳、鼻、舌、身、意，亦复如是。是名不律仪。
    “云何律仪？眼根律仪所摄护，眼识识色，心不染著；心不染著已，常乐受住；心乐住已，常一其心；一其心已，如实知见；如实知见已，离诸疑惑；离诸疑惑已，不由他误，常安乐住。耳、鼻、舌、身、意，亦复如是。是名律仪。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二七八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有退、不退法、六触入处。谛听善思，当为汝说。
    “云何退法？谓眼识色，生欲觉，彼比丘欢喜、赞叹、执取、系著，随顺彼法回转，当知是比丘退诸善法，世尊所说是名退法。耳、鼻、舌、身、意，亦复如是。
    “云何名不退法？眼识色缘，不生欲觉结，彼比丘不喜、不赞叹、不执取、不系著，于彼法不随顺回转，当知是比丘不退转诸善法，世尊说是不退法。耳、鼻、舌、身、意，亦复如是。
    “云何六胜入处？眼识色缘，不生欲觉结染著，当知是比丘胜彼入处；胜彼入处，是世尊所说。耳、鼻、舌、身、意、亦复如是。若彼比丘于六胜入处胜已，贪欲结断，瞋恚、愚痴结断。譬如王者，摧敌胜怨，名曰胜王。断除众结，名胜婆罗门。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二七九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于此六根，不调伏、不关闭、不守护、不执持、不修习，于未来世必受苦报。何等为六根？眼根不调伏、不关闭、不守护、不修习、不执持，于未来世必受苦报。耳、鼻、舌、身、意根，亦复如是。愚痴无闻凡夫，眼根见色，执受相，执受随形好，任彼眼根趣向，不律仪执受住，世间贪忧、恶不善法，以漏其心，此等不能执持律仪，防护眼根。耳、鼻、舌、身、意根，亦复如是。如是于六根不调伏、不关闭、不守护、不执持、不修习，于未来世必受苦报。
    “云何六根善调伏、善关闭、善守护、善执持、善修习，于未来世必受乐报？多闻圣弟子，眼见色，不取色相，不取随形好，任其眼根之所趣向，常住律仪，世间贪忧、恶不善法，不漏其心，能生律仪，善护眼根。耳、鼻、舌、身、意根，亦复如是。如是六根善调伏、善关闭、善守护、善执持、善修习，于未来世必受乐报。”
    即说偈言：

“于六触入处，住于不律仪，
是等诸比丘，长夜受大苦。
斯等于律仪，常当勤修习，
正信心不二，诸漏不漏心。
眼见于彼色，可意不可意，
可意不生欲，不可不憎恶。
耳闻彼诸声，亦有念不念，
于念不乐著，不念不起恶。
鼻根之所嗅，若香若臭物，
等心于香臭，无欲亦无违。
所食于众味，彼亦有美恶，
美味不起贪，恶味亦不择。
乐触以触身，不生于放逸，
为苦触所触，不生过恶想，
平等舍苦乐，不灭者令灭。
心意所观察，彼种彼种相，
虚伪而分别，欲贪转增广，
觉悟彼诸恶，安住离欲心。
善摄此六根，六境触不动，
摧伏众魔怨，度生死彼岸。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二八○）

    如是我闻。一时世尊在拘萨罗国人间游行，到频头城北，申恕林中。
    尔时频头城中婆罗门长者，皆闻世尊于拘萨罗国人间游行，住频头城申恕林中。闻已悉共出城，至申恕林，诣世尊所，稽首礼足，退坐一面。
    尔时世尊告频头城婆罗门长者：“若人问汝言：‘何等像类沙门、婆罗门，不应恭敬尊重、礼事供养？’汝当答言：‘若沙门、婆罗门，眼见色，未离贪、未离欲、未离爱、未离渴、未离念，内心不寂静，所行非法行，行疏涩行。耳、鼻、舌、身、意法，亦复如是。如是像类比丘，不应恭敬尊重、礼事供养。’
    “作是说已，当复问言：‘何故如此像类沙门、婆罗门，不应恭敬尊重、礼事供养？’汝应答言：‘我等眼见色，不离欲、不离爱、不离渴、不离念，内心不寂静。耳、鼻、舌、身、意法，亦复如是。彼沙门、婆罗门，眼见色，亦不离贪、不离欲、不离爱、不离渴、不离念，内心不寂静，行非法行、疏涩行。耳、鼻、舌、身、意法，亦复如是。我于斯等求其差别，不见差别之行。是故我于斯等像类沙门、婆罗门，不应恭敬尊重、礼事供养。’
    “若复问言：‘何等像类沙门、婆罗门所，应恭敬尊重、礼事供养？’汝应答言：‘若彼眼见色，离贪、离欲、离爱、离渴、离念，内心寂静，不行非法行，行等行，不行疏涩行。耳、鼻、舌、身、意法，亦复如是。如是像类沙门、婆罗门所，应恭敬尊重、礼事供养。’
    “若复问言：‘何故于此像类沙门、婆罗门，恭敬尊重、礼事供养？’汝应答言：‘我等眼见色，不离贪、不离欲、不离爱、不离渴、不离念，内心不寂静，行非法行，行疏涩行。耳、鼻、舌、身、意法，亦复如是。斯等像类沙门、婆罗门，离贪、离欲、离渴、离念，内心寂静，行如法行，不行疏涩行。耳、鼻、舌、身、意法，亦复如是。我等于彼求其差别，见差别故，于彼像类沙门、婆罗门所，应恭敬尊重、礼事供养。’
    “如是说已，若复问言：‘彼沙门、婆罗门，有何行、有何形貌、有何相，汝等知是沙门、婆罗门离贪向、调伏贪，离恚向、调伏恚，离痴向、调伏痴？’汝应答言：‘我见彼沙门、婆罗门，有如是像类：住空闲处，林中树下，卑床草蓐，修行远离，离诸女人，近乐独人同禅思者。若于彼处，无眼见色可生乐著，无耳声、鼻香、舌味、身触可生乐著。若彼沙门、婆罗门有如是行、如是形貌、如是相，令我等知是沙门、婆罗门，离贪向、调伏贪，离恚向、调伏恚，离痴向、调伏痴。’”
    时诸沙门、婆罗门长者白佛言：“奇哉世尊！不自誉，不毁他，正说其义。各各自于诸入处，分别染污、清净，广说缘起，如如来、应、等正觉说。譬如士夫，溺者能救，闭者能开，迷者示路，暗处燃灯。世尊亦复如是，不自誉，不毁他，正说其义，乃至如如来、应、等正觉说。”
    尔时频头城婆罗门长者，闻佛所说，欢喜作礼而去。

（二八一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有萦发目揵连出家，来诣佛所，共相问讯，问讯已，退坐一面。
    尔时世尊告萦发目揵连：“汝从何来？”
    萦发目揵连白佛言：“我从彼众多种种异道沙门、婆罗门、遮罗迦出家集会未曾讲堂听法，从彼林来。”
    佛告萦发目揵连：“汝为何等福力故，从彼众多种种异道沙门、婆罗门、遮罗迦出家所，听其说法。”
    萦发目揵连言：“我试听其竞胜论义福利，听其相违反论议福利故。”
    佛告目揵连：“长夜久远，种种异道沙门、婆罗门、遮罗迦出家，竞胜论议，相违反论议福利，递相破坏。”
    萦发目揵连白佛言：“瞿昙，为诸弟子说何等法福利，令彼转为人说，不谤如来，不增不减，诚说、法说、法次法说，无有余人能来比校、难诘、诃责？”
    佛告目揵连：“明、解脱果报福利，为人转说者，不谤如来，不乖其理，法次法说，无有能来比校、难诘、嫌责。”
    萦发目揵连白佛言：“瞿昙，诸弟子有法，修习多修习，令明、解脱福利满足者不？”
    佛告萦发目犍连：“有七觉分，修习多修习，明、解脱福利满足。”
    萦发目揵连白佛言：“有法修习，能令七觉分满足不？”
    佛告萦发目揵连：“有四念处，修习多修习，能令七觉分满足。”
    萦发目揵连白佛：“复有法修习多修习，令四念处满足不？”
    佛告萦发目揵连：“有三妙行，修习多修习，能令四念处满足。”
    萦发目揵连白佛言：“复有法修习多修习，令三妙行满足不？”
    佛告目揵连：“有六触入处律仪，修习多修习，令三妙行满足。”
    萦发目揵连白佛言：“云何六触入处律仪，修习多修习，令三妙行满足？”
    佛告目揵连：“若眼见适意、可爱念、能长养欲乐、令人缘著之色，彼比丘见已，不喜、不赞叹、不缘、不著、不住。若眼见不适意、不可爱念、顺于苦觉之色，诸比丘见已，不畏、不恶、不嫌、不恚。于彼好色，起眼见已，永不缘著。不好色，起眼见已，永不缘著。内心安住不动，善修解脱，心不懈倦。耳、鼻、舌、身、意识法，亦复如是。如是于六触入修习多修习，满足三妙行。
    “云何修三妙行，满足四念处？多闻圣弟子，于空闲处，林中树下，作如是学，如是思惟：‘此身恶行，现世、后世必得恶报。我若行身恶行者，必当自生厌悔，他亦嫌薄，大师亦责，诸梵行者亦复以法而嫌我。恶名流布，遍于诸方。身坏命终，当堕地狱。’于身恶行，见现世、后世如是果报，是故除身恶行，修身妙行。口、意恶行，亦复如是。是名修习三妙行已，得四念处清净满足。
    “云何修四念处，得七觉分满足？目揵连，比丘如是顺身身观住，彼顺身身观住时，系念安住不忘，尔时方便修习念觉分，方便修习念觉分已，得念觉分满足。于彼心念选择于法，觉想思量，尔时方便修习择法觉分，方便修习择法觉分已，逮得择法觉分满足。选择彼法，觉想思量，方便修习精进觉分，方便修习精进觉分已，逮得精进觉分满足。勤精进已，生欢喜心，尔时修习方便欢喜觉分，修习欢喜觉分已，逮得欢喜觉分满足。心欢喜已，身心止息，尔时修习猗息觉分，修习猗息觉分已，逮得猗息觉分满足。身心息已，得三摩提，尔时修习定觉分，修习定觉分已，定觉分满足。谓一其心，贪忧灭息，内身行舍，方便修习舍觉分，方便修习舍觉分已，逮得舍觉分清净满足。受、心、法念处，亦如是说。如是修习四念处，七觉分满足。
    “云何修习七觉分，明、解脱满足？目揵连，若比丘修念觉分，依远离、依离欲、依灭，舍于进趣，修念觉分，逮得明、解脱清净满足。乃至修习舍觉分，亦如是说。是名修习七觉分已，明、解脱清净满足。如是目揵连，法法相依，从此岸而到彼岸。”
    说是法时，萦发目揵连远尘离垢，得法眼净。时萦发目揵连见法、得法、知法、入法，度诸疑惑，不由于他，于诸法律得无所畏。从座起，整衣服，为佛作礼，合掌白佛言：“我今宁得于正法律出家，得具足比丘分不？”
    佛告目揵连：“汝今已得于正法律出家，具足得比丘分。”
    得出家已，专精思惟，不放逸住，乃至成阿罗汉。

（二八二）

    如是我闻。一时佛住迦徵伽罗，牟真邻陀林中。
    时有年少名郁多罗，是波罗奢那弟子，来诣佛所，恭敬问讯已，退坐一面。
    尔时世尊告郁多罗：“汝师波罗奢那，为汝等说修诸根不？”
    郁多罗言：“说已，瞿昙。”
    佛告郁多罗：“汝师波罗奢那，云何说修诸根？”
    郁多罗白佛言：“我师波罗奢那说：眼不见色，耳不听声，是名修根。”
    佛告郁多罗：“若如汝波罗奢那说，盲者是修根不？所以者何？唯盲者眼不见色。”
    尔时尊者阿难在世尊后，执扇扇佛。尊者阿难语郁多罗言：“如波罗奢那所说，聋者是修根不？所以者何？唯聋者耳不闻声。”
    尔时世尊告尊者阿难：“异于贤圣法律无上修诸根。”
    阿难白佛言：“唯愿世尊为诸比丘说贤圣法律无上修根，诸比丘闻已，当受奉行。”
    佛告阿难：“谛听善思，当为汝说。缘眼、色，生眼识，见可意色，欲修如来厌离，正念正智。眼、色缘生眼识，不可意，欲修如来不厌离，正念正智。眼、色缘生眼识，可意、不可意，欲修如来厌离、不厌离，正念正智。眼、色缘生眼识，不可意、可意，欲修如来不厌离、厌离，正念正智。眼、色缘生眼识，可意、不可意、可不可意，欲修如来厌、不厌俱离，舍心住，正念正智。如是阿难，若有于此五句，心善调伏、善关闭、善守护、善摄持、善修习，是则于眼、色无上修根。耳、鼻、舌、身、意法，亦如是说。阿难，是名贤圣法律无上修根。”
    尊者阿难白佛言：“世尊，云何贤圣法律，为贤圣修根？”
    佛告阿难：“眼、色缘生眼识，生可意，生不可意，生可意不可意。彼圣弟子如是如实知，我眼、色缘生眼识，生可意，生不可意，生可意不可意；此则寂灭，此则胜妙，所谓俱舍，得彼舍已，离厌、不厌。譬如力士弹指顷灭，如是眼、色缘生眼识，生可意，生不可意，生可意不可意，俄尔尽灭，得离厌、不厌舍。
    “如是耳、声缘生耳识，生可意，生不可意，生可意不可意。圣弟子如是如实知，我耳识闻声，生可意，生不可意，生可意不可意；此则寂灭、胜妙，所谓为舍，得舍已，离厌、不厌。譬如大力士夫弹指，发声即灭。如是耳、声缘生耳识，生可意，生不可意，生可意不可意，生已尽灭，是则为舍，得彼舍已，离厌、不厌。
    “鼻、香缘生鼻识，生可意，生不可意，生可意不可意。圣弟子如是如实知，鼻、香缘生鼻识，生可意，生不可意，生可意不可意；此则寂灭，此则胜妙，所谓为舍，得彼舍已，离厌、不厌。譬如莲花，水所不染。如是鼻、香缘生鼻识，生可意，生不可意，生可意不可意，生已尽灭，所谓为舍，得彼舍已，离厌、不厌。
    “舌、味缘生舌识，生可意，生不可意，生可意不可意。彼圣弟子如是如实知，舌、味缘生舌识，生可意，生不可意，生可意不可意；生已尽灭、寂灭、胜妙，所谓为舍，得彼舍已，离厌、不厌。譬如力士舌端唾沫，尽唾令灭。如是舌、味缘生舌识，生可意，生不可意，生可意不可意，生已尽灭，所谓为舍，得彼舍已，离厌、不厌。
    “身、触缘生身识，生可意，生不可意，生可意不可意，生已尽灭。圣弟子如是如实知，身、触缘生身识，生可意，生不可意，生可意不可意；生已尽灭、寂灭、胜妙，所谓为舍，得彼舍已，离厌、不厌。譬如铁丸烧令极热，小滴水洒，寻即消灭。如是身、触缘生身识，生可意，生不可意，生可意不可意，生已尽灭，所谓为舍，得彼舍已，离厌、不厌。
    “意、法缘生意识，生可意，生不可意，生可意不可意，生已速灭。圣弟子如是如实知，意、法缘生意识，生可意，生不可意，生可意不可意；生已尽灭，是则寂灭，是则胜妙，所谓为舍，得彼舍已，离厌、不厌。譬如力士断多罗树头，如是意、法缘生意识，生可意，生不可意，生可意不可意，生已尽灭，所谓为舍，得彼舍已，离厌、不厌。阿难，是为贤圣法律，为圣弟子修诸根。”
    “云何为圣法律觉见迹？”
    佛告阿难：“眼、色缘生眼识，生可意，生不可意，生可意不可意，彼圣弟子惭耻厌恶。耳、鼻、舌、身、意法缘生意识，生可意，生不可意，生可意不可意，彼圣弟子惭耻厌恶。阿难，是名贤圣法律觉见迹。阿难，是名贤圣法律无上修诸根。已说贤圣修诸根，已说觉见迹。阿难，我为诸声闻所作，所作已作，汝等当作所作。”广说如《箧毒蛇经》。
    佛说此经已，尊者阿难闻佛所说，欢喜奉行。


杂阿含经卷第十二

（二八三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若于结所系法，随生味著、顾念、心缚，则爱生；爱缘取，取缘有，有缘生，生缘老病死、忧悲恼苦，如是如是纯大苦聚集。如人种树，初小软弱，爱护令安，壅以粪土，随时溉灌，冷暖调适，以是因缘，然后彼树得增长大。如是比丘，结所系法，味著将养，则生恩爱；爱缘取，取缘有，有缘生，生缘老病死、忧悲恼苦，如是如是纯大苦聚集。
    “若于结所系法，随顺无常观，住生灭观、无欲观、灭观、舍观，不生顾念，心不缚著，则爱灭；爱灭则取灭，取灭则有灭，有灭则生灭，生灭则老病死、忧悲恼苦灭，如是如是纯大苦聚灭。犹如种树，初小软弱，不爱护，不令安隐，不壅粪土，不随时溉灌，冷暖不适，不得增长。若复断根截枝，段段斩截，分分解析，风飘日炙，以火焚烧，烧以成粪，或扬以疾风，或投之流水。比丘，于意云何？非为彼树断截其根，乃至焚烧，令其磨灭，于未来世成不生法耶？”
    答言：“如是，世尊。”
    “如是比丘，于结所系法，随顺无常观，住生灭观、无欲观、灭观、舍观，不生顾念，心不缚著，则爱灭；爱灭则取灭，取灭则有灭，有灭则生灭，生灭则老病死、忧悲恼苦灭，如是如是纯大苦聚灭。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二八四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若于所取法，随生味著、顾念、心缚，其心驱驰，追逐名色；名色缘六入处，六入处缘触，触缘受，受缘爱，爱缘取，取缘有，有缘生，生缘老病死、忧悲恼苦，如是如是纯大苦聚集。譬大树根干、枝条、柯叶、花果，下根深固，壅以粪土，溉灌以水，彼树坚固，永世不朽。如是比丘，于所取法，随生味著、顾念、心缚，其心驱驰，追逐名色；名色缘六入处，六入处缘触，触缘受，受缘爱，爱缘取，取缘有，有缘生，生缘老病死、忧悲恼苦，如是如是纯大苦聚集。
    “若于所取法，随顺无常观，住生灭观、无欲观、灭观、厌观，心不顾念，无所缚著，识则不驱驰追逐名色，则名色灭；名色灭则六入处灭，六入处灭则触灭，触灭则受灭，受灭则爱灭，爱灭则取灭，取灭则有灭，有灭则生灭，生灭则老病死、忧悲恼苦灭，如是如是则纯大苦聚灭。犹如种树，不随时爱护，令其安隐，不壅粪土，不随时溉灌，冷暖不适，不得增长。若复断根截枝，段段斩截，分分解析，风飘日炙，以火焚烧，烧以成粪，或扬以疾风，或投之流水。比丘，于意云何？非为彼树断截其根，乃至焚烧，令其磨灭，于未来世成不生法耶？”
    答言：“如是，世尊。”
    “如是比丘，于所取法，随顺无常观，住生灭观、无欲观、灭观、舍观，不生顾念，心不缚著，识不驱驰追逐名色，则名色灭；名色灭则六入处灭，六入处灭则触灭，触灭则受灭，受灭则爱灭，爱灭则取灭，取灭则有灭，有灭则生灭，生灭则老病死、忧悲恼苦灭，如是如是纯大苦聚灭。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二八五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我忆宿命，未成正觉时，独一静处，专精禅思，生如是念：‘世间难入，所谓若生、若老、若病、若死、若迁、若受生。然诸众生，生、老、病、死，上及所依，不如实知。’我作是念：‘何法有故生有？何法缘故生有？’即正思惟，起无间等知：有有故生有，有缘故生有。复思惟：‘何法有故有有？何法缘故有有？’即正思惟，如实无间等起知：取有故有有，取缘故有有。又作是念：‘取复何法有故取有？何法缘故取有？’即正思惟，如实无间等起知：取法味著、顾念、心缚，爱欲增长，彼爱有故取有，爱故缘取，取缘有，有缘生，生缘老病死、忧悲恼苦，如是如是纯大苦聚集。诸比丘，于意云何？譬如缘膏油及炷，灯明得烧。数增油、炷，彼灯明得久住不？”
    答言：“如是，世尊。”
    “如是诸比丘，于色取味著、顾念、爱缚，增长爱缘故取，取缘有，有缘生，生缘老病死、忧悲恼苦，如是如是纯大苦聚集。我时复作是念：‘何法无故无此老病死？何法灭故老病死灭？’即正思惟，起如实无间等：无生则无老病死，生灭故则老病死灭。复作是念：‘何法无故无生？何法灭故生灭？’即正思惟，起如实无间等：有无故生无，有灭故生灭。又复思惟：‘何法无故有无？何法灭故有灭？’即正思惟，生如实无间等观：取无故有无，取灭故有灭。又作是念：‘何法无故取无？何法灭故取灭？’即正思惟，生如实无间等观：所取法无常、生灭、离欲、灭尽、舍离，心不顾念，心不缚著，爱则灭；彼爱灭故取灭，取灭故有灭，有灭故生灭，生灭故老病死、忧悲恼苦灭，如是如是纯大苦聚灭。诸比丘，于意云何？譬如油、炷燃灯，若不增油、治炷，非彼灯明未来不生、尽、磨灭耶？”
    比丘白佛言：“如是，世尊。”
    “如是诸比丘，于所取法，观察无常、生灭、离欲、灭尽、舍离，心不顾念，心不缚著，爱则灭，爱灭则取灭，乃至纯大苦聚灭。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二八六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我忆宿命，未成正觉时，独一静处，专精禅思。”如上广说，差别者：“譬如载樵十束、二十束、三十束、四十束、五十束、百束、千束、百千束，积聚烧燃，作大火聚。若复有人增其干草樵薪，诸比丘，于意云何？此火相续，长夜炽燃不？”
    比丘白佛言：“如是，世尊。”
    “如是诸比丘，于所取法，味著、顾念、心缚著，增其爱缘取，取缘有，乃至纯大苦聚集。诸比丘，若彼火聚炽燃，不增樵草。诸比丘，于意云何，彼火当灭不？”
    答言：“如是，世尊。”
    “如是诸比丘，于所取法，观察无常、生灭、离欲、灭尽、舍离，心不顾念、缚著，爱则灭，爱灭则取灭，如是广说，乃至纯大苦聚灭。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二八七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我忆宿命，未成正觉时，独一静处，专精禅思，作是念：‘何法有故老死有？何法缘故老死有？’即正思惟，生如实无间等：生有故老死有，生缘故老死有。如是有、取、爱、受、触、六入处、名色，何法有故名色有？何法缘故名色有？即正思惟，如实无间等生：识有故名色有，识缘故有名色有。我作是思惟时，齐识而还，不能过彼，谓缘识名色，缘名色六入处，缘六入处触，缘触受，缘受爱，缘爱取，缘取有，缘有生，缘生老病死、忧悲恼苦，如是如是纯大苦聚集。
    “我时作是念：‘何法无故则老死无？何法灭故老死灭？’即正思惟，生如实无间等：生无故老死无，生灭故老死灭。如是生、有、取、爱、受、触、六入处、名色、识、行，广说。我复作是思惟：‘何法无故行无？何法灭故行灭？’即正思惟，如实无间等：无明无故行无，无明灭故行灭，行灭故识灭，识灭故名色灭，名色灭故六入处灭，六入处灭故触灭，触灭故受灭，受灭故爱灭，爱灭故取灭，取灭故有灭，有灭故生灭，生灭故老病死、忧悲恼苦灭，如是如是纯大苦聚灭。
    “我时作是念：我得古仙人道、古仙人径、古仙人道迹，古仙人从此迹去，我今随去。譬如有人游于旷野，披荒觅路，忽遇故道，古人行处，彼则随行，渐渐前进，见故城邑，故王宫殿，园观浴池，林木清净。彼作是念：‘我今当往白王令知。’即往白王：‘大王当知，我游旷野，披荒求路，忽见故道古人行处，我即随行。我随行已，见故城邑，故王宫殿，园观浴池，林流清净。大王可往居止其中。’王即往彼，止住其中，丰乐安隐，人民炽盛。今我如是，得古仙人道、古仙人径、古仙人迹，古仙人去处，我得随去，谓八圣道，正见、正志、正语、正业、正命、正方便、正念、正定。
    “我从彼道见老病死、老病死集、老病死灭、老病死灭道迹；见生、有、取、爱、受、触、六入处、名色、识、行、行集、行灭、行灭道迹。我于此法自知自觉，成等正觉，为比丘、比丘尼、优婆塞、优婆夷，及余外道沙门、婆罗门，在家、出家，彼诸四众闻法正向、信乐、知法善、梵行增广，多所饶益，开示显发。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二八八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者舍利弗、尊者摩诃拘絺罗，在耆阇崛山。
    尔时尊者舍利弗，晡时从禅觉，诣尊者摩诃拘絺罗，共相问讯庆慰已，于一面坐，语尊者摩诃拘絺罗：“欲有所问，宁有闲暇见答以不？”
    尊者摩诃拘絺罗语尊者舍利弗言：“仁者且问，知者当答。”
    尊者舍利弗问尊者摩诃拘絺罗：“云何尊者摩诃拘絺罗，有老不？”
    答言：“有，尊者舍利弗。”
    复问：“有死不？”
    答言：“有。”
    复问：“云何老死自作耶？为他作耶？为自他作耶？为非自非他无因作耶？”
    答言：“尊者舍利弗，老死非自作，非他作，非自他作，亦非非自他作无因作，然彼生缘故有老死。”
    “如是生、有、取、爱、受、触、六入处、名色，为自作？为他作？为自他作？为非自他无因作？”
    答言：“尊者舍利弗，名色非自作，非他作，非自他作，非非自他作无因作，然彼名色缘识生。”
    复问：“彼识为自作？为他作？为自他作？为非自非他无因作？”
    答言：“尊者舍利弗，彼识非自作，非他作，非自他作，非非自他作无因作，然彼识缘名色生。”
    尊者舍利弗复问：“尊者摩诃拘絺罗，先言名色非自作、非他作、非自他作、非非自非他无因作，然彼名色缘识生，而今复言名色缘识，此义云何？”
    尊者摩诃拘絺罗答言：“今当说譬，如智者因譬得解。譬如三芦立于空地，展转相依，而得竖立。若去其一，二亦不立。若去其二，一亦不立。展转相依，而得竖立。识缘名色，亦复如是，展转相依，而得生长。”
    尊者舍利弗言：“善哉善哉！尊者摩诃拘絺罗。世尊声闻中，智慧明达，善调无畏，见甘露法，以甘露法具足身作证者，谓尊者摩诃拘絺罗，乃有如是甚深义辩，种种难问皆悉能答。如无价宝珠，世所顶戴。我今顶戴尊者摩诃拘絺罗，亦复如是。我今于汝所，快得善利。诸余梵行，数诣其所，亦得善利，以彼尊者善说法故。我今以此尊者摩诃拘絺罗所说法故，当以三十种赞叹，称扬随喜。尊者摩诃拘絺罗说老死厌患、离欲、灭尽，是名法师。说生、有、取、爱、受、触、六入处、名色、识，厌患、离欲、灭尽，是名法师。若比丘于老死厌患、离欲、灭尽向，是名法师。乃至识厌患、离欲、灭尽向，是名法师。若比丘于老死厌患、离欲、灭尽，不起诸漏，心善解脱，是名法师。乃至识厌患、离欲、灭尽，不起诸漏，心善解脱，是名法师。”
    尊者摩诃拘絺罗语尊者舍利弗言：“善哉善哉！于世尊声闻中，智慧明达，善调无畏，见甘露法，以甘露法具足身作证者，谓尊者舍利弗，能作如是种种甚深正智之问。犹如世间无价宝珠，人皆顶戴。汝今如是，普为一切诸梵行者之所顶戴，恭敬奉事。我于今日快得善利，得与尊者共论妙义。”
    时二正士更相随喜，各还所住。

（二八九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“愚痴无闻凡夫于四大身厌患、离欲、背舍而非识。所以者何？见四大身有增、有减、有取、有舍，而于心、意、识，愚痴无闻凡夫不能生厌、离欲、解脱。所以者何？彼长夜于此保惜系我，若得、若取，言是我、我所、相在，是故愚痴无闻凡夫不能于彼生厌、离欲、背舍。
    “愚痴无闻凡夫宁于四大身系我、我所，不可于识系我、我所。所以者何？四大色身，或见十年住，二十、三十，乃至百年，若善消息，或复少过。彼心、意、识，日夜时刻须臾转变，异生异灭。犹如猕猴游林树间，须臾处处攀捉枝条，放一取一。彼心、意、识，亦复如是，异生异灭。
    “多闻圣弟子于诸缘起善思惟观察，所谓乐触缘生乐受，乐受觉时，如实知乐受觉；彼乐触灭，乐触因缘生受亦灭、止、清凉、息、没。如乐受，苦触、喜触、忧触、舍触因缘生舍受，舍受觉时，如实知舍受觉；彼舍触灭，彼舍触因缘生舍受亦灭、止、清凉、息、没。彼如是思惟：此受触生、触乐、触缚，彼彼触乐故，彼彼受乐；彼彼触乐灭，彼彼受乐亦灭、止、清凉、息、没。如是多闻圣弟子于色生厌，于受、想、行、识生厌，厌故不乐，不乐故解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二九○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“愚痴无闻凡夫，于四大色身生厌、离欲、背舍，但非识。所以者何？四大色身现有增减、有取、有舍，若心、若意、若识，彼愚痴无闻凡夫不能于识生厌、离欲、背舍，长夜保惜系我，若得、若取，言是我、我所、相在，是故愚痴无闻凡夫不能于彼生厌、离欲、背舍。
    “愚痴无闻凡夫宁于四大色身系我、我所，不可于识系我、我所。所以者何？四大色身，或见十年住，二十、三十，乃至百年，若善消息，或复少过。彼心、意、识，日夜时刻须臾不停，种种转变，异生异灭。譬如猕猴游林树间，须臾处处攀捉枝条，放一取一。彼心、意、识，亦复如是，种种变易，异生异灭。
    “多闻圣弟子于诸缘起思惟观察，所谓乐触缘生乐受，乐受觉时，如实知乐受觉；彼乐触灭，乐因缘生乐受亦灭、止、清凉、息、没。如乐受，苦触、喜触、忧触、舍触因缘生舍受，舍受觉时，如实知舍受觉；彼舍触灭，舍触因缘生舍受亦灭、止、清凉、息、没。譬如两木相磨，和合生火；若两木离散，火亦随灭。如是诸受缘触集，触生、触集，若彼彼触集故，彼彼受亦集；彼彼触集灭故，彼彼受集亦灭、止、清凉、息、没。多闻圣弟子如是观者，于色解脱，于受、想、行、识解脱，于生老病死、忧悲恼苦解脱，我说彼于苦得解脱。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二九一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“我说内触法，汝等为取不？”
    时有异比丘从座起，整衣服，稽首礼足，合掌白佛言：“世尊所说内触法，我已取也。”
    时彼比丘于佛前如是如是自记说，如是如是世尊不悦。
    尔时尊者阿难在佛后执扇扇佛，佛告阿难：“如圣法律内触法，异于此比丘所说。”
    阿难白佛：“今正是时，唯愿世尊为诸比丘说贤圣法律内触法，诸比丘闻已，当受奉行。”
    佛告阿难：“善哉谛听，当为汝说。此诸比丘取内触法，应如是思惟：若众生所有种种众苦生，此苦何因、何集、何生、何触？作如是取时，当知此苦，亿波提因、亿波提集、亿波提生、亿波提转。复次比丘内触法，又亿波提何因、何集、何生、何触？彼取时，当复知亿波提爱因、爱集、爱生、爱触。
    “复次比丘取内触法，当复知爱何因、何集、何生、何触？如是取时，当知世间所念端正之色，于彼爱生而生、系而系、住而住。若诸沙门、婆罗门，于世间所念端正之色，作常想、恒想、安隐想、无病想、我想、我所想而见，则于此色爱增长。爱增长已，亿波提增长。亿波提增长已，苦增长。苦增长已，则不解脱生老病死、忧悲恼苦，我说彼不解脱苦。譬如路侧清凉池水，香味具足，有人以毒着中。阳春之月，诸行路者风热渴逼，竞来欲饮。有人语言：‘士夫，此是清凉池，色香味具足，然中有毒，汝等勿饮。若当饮者，或令汝死，或近死苦。’而彼渴者不信而饮，虽得美味，须臾或死，或近死苦。如是沙门、婆罗门，见世间可念端正之色，作常见、恒见、安隐见、无病见、我、我所见，乃至不得解脱生老病死、忧悲恼苦。
    “若诸沙门、婆罗门，于世间可念端正之色，观察如病、如痈、如刺、如杀、无常、苦、空、非我，彼爱则离，爱离故亿波提离，亿波提离故则苦离，苦离故则生老病死、忧悲恼苦离。譬如路侧清凉池水，香味具足，有人以毒着中。阳春之月，诸行路者风热渴逼，竞来欲饮。有人语言：‘此水有毒，汝等勿饮。若当饮者，或令汝死，或近死苦。’彼则念言：‘此水有毒，若当饮者，或令我死，或近死苦。我且忍渴，食干麨饭，不取水饮。’如是沙门、婆罗门，于世间可念之色，观察如病、如痈、如刺、如杀、无常、苦、空、非我，乃至解脱生老病死、忧悲恼苦。是故阿难，于此法如是见、如是闻、如是觉、如是知，于过去、未来，亦如此道，如是观察。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二九二）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“云何思量观察正尽苦，究竟苦边时，思量众生所有众苦，种种差别，此诸苦何因、何集、何生、何触？思量取因、取集、取生、取触；若彼取灭无余，众苦则灭。彼所乘苦灭道迹如实知，修行彼向次法，是名比丘向正尽苦，究竟苦边，所谓取灭。
    “复次比丘，思量观察正尽苦，究竟苦边时，思量彼取何因、何集、何生、何触？思量彼取，爱因、爱集、爱生、爱触；彼爱永灭无余，取亦随灭。彼所乘取灭道迹如实知，修习彼向次法，是名比丘向正尽苦，究竟苦边，所谓爱灭。
    “复次比丘，思量观察正尽苦，究竟苦边，则思量彼爱何因、何集、何生、何触？知彼爱，受因、受集、受生、受触；彼受永灭无余，则爱灭。彼所乘爱灭道迹如实知，修习彼向次法，是名比丘向正尽苦，究竟苦边，所谓受灭。
    “复次比丘，思量观察正尽苦，究竟苦边时，思量彼受何因、何集、何生、何触？知彼受，触因、触集、触生、触缘；彼触永灭无余，则受灭。彼所乘触灭道迹如实知，修习彼向次法，是名比丘向正尽苦，究竟苦边。
    “复次比丘，思量观察正尽苦，究竟苦边时，思量彼触何因、何集、何生、何触？当知彼触，六入处因、六入处集、六入处生、六入处触；彼六入处灭无余，则触灭。彼所乘六入处灭道迹如实知，修习彼向次法，是名比丘向正尽苦，究竟苦边。
    “复次比丘，思量观察正尽苦，究竟苦边时，思量彼六入处何因、何集、何生、何触？知彼六入处，名色因、名色集、名色生、名色触；名色永灭无余，则六入处灭。彼所乘名色灭道迹如实知，修习彼向次法，是名比丘向正尽苦，究竟苦边，所谓名色灭。
    “复次比丘，思量正尽苦，究竟苦边时，思量名色何因、何集、何生、何触？知彼名色，识因、识集、识生、识触；彼识欲灭无余，则名色灭。彼所乘识灭道迹如实知，修习彼向次法，是名比丘向正尽苦，究竟苦边，所谓识灭。
    “复次比丘，思量观察正尽苦，究竟苦边时，思量彼识何因、何集、何生、何触？知彼识，行因、行集、行生、行触。作诸福行，善识生；作诸不福不善行，不善识生；作无所有行，无所有识生。是为彼识，行因、行集、行生、行触；彼行欲灭无余，则识灭。彼所乘行灭道迹如实知，修习彼向次法，是名比丘向正尽苦，究竟苦边，所谓行灭。
    “复次比丘，思量观察正尽苦，究竟苦边时，思量彼行何因、何集、何生、何触？知彼行，无明因、无明集、无明生、无明触。彼福行，无明缘；非福行，亦无明缘；非福不福行，亦无明缘。是故当知彼行，无明因、无明集、无明生、无明触；彼无明永灭无余，则行灭。彼所乘无明灭道迹如实知，修习彼向次法，是名比丘向正尽苦，究竟苦边，所谓无明灭。”
    佛告比丘：“于意云何？若不乐无明而生明，复缘彼无明作福行、非福行、无所有行不？”
    比丘白佛：“不也，世尊。所以者何？多闻圣弟子不乐无明而生明，无明灭则行灭，行灭则识灭，如是乃至生老病死、忧悲恼苦灭，如是如是纯大苦聚灭。”
    佛言：“善哉善哉！比丘，我亦如是说，汝亦知此。于彼彼法起，彼彼法生，彼彼法灭，彼彼法灭、止、清凉、息、没。若多闻圣弟子，无明离欲而生明，身分齐受所觉，身分齐受所觉时如实知；若寿分齐受所觉，寿分齐受所觉时如实知；身坏时寿命欲尽，于此诸受一切所觉，灭尽无余。譬如力士取新熟瓦器，乘热置地，须臾散坏，热势悉灭。如是比丘无明离欲而生明，身分齐受所觉如实知，寿分齐受所觉如实知，身坏命终，一切受所觉悉灭无余。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二九三）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告异比丘：“我已度疑，离于犹豫，拔邪见刺，不复退转。心无所著故，何处有我？为彼比丘说法，为彼比丘说贤圣出世空相应缘起随顺法。所谓有是故是事有，是事有故是事起，所谓缘无明行，缘行识，缘识名色，缘名色六入处，缘六入处触，缘触受，缘受爱，缘爱取，缘取有，缘有生，缘生老死忧悲恼苦，如是如是纯大苦聚集，乃至如是纯大苦聚灭。
    “如是说法，而彼比丘犹有疑惑犹豫。先不得得想、不获获想、不证证想，今闻法已，心生忧苦、悔恨、朦没、障碍。所以者何？此甚深处，所谓缘起；倍复甚深难见，所谓一切取离、爱尽、无欲、寂灭、涅槃。如此二法，谓有为、无为。有为者若生、若住、若异、若灭。无为者不生、不住、不异、不灭。是名比丘诸行苦、寂灭、涅槃。因集故苦集，因灭故苦灭，断诸径路，灭于相续，相续灭，是名苦边。比丘，彼何所灭？谓有余苦。彼若灭、止、清凉、息、没，所谓一切取灭、爱尽、无欲、寂灭、涅槃。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二九四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“愚痴无闻凡夫，无明覆，爱缘系，得此识身。内有此识身，外有名色，此二因缘生触。此六触入所触，愚痴无闻凡夫，苦、乐受觉，因起种种。云何为六？眼触入处，耳、鼻、舌、身、意触入处。
    “若黠慧者，无明覆，爱缘系，得此识身。如是内有识身，外有名色，此二缘生六触入处。六触所触故，智者生苦、乐受觉，因起种种。何等为六？眼触入处，耳、鼻、舌、身、意触入处。愚夫、黠慧，彼于我所修诸梵行者，有何差别？”
    比丘白佛言：“世尊是法根、法眼、法依。善哉世尊！唯愿演说，诸比丘闻已，当受奉行。”
    尔时世尊告诸比丘：“谛听善思，当为汝说。诸比丘，彼愚痴无闻凡夫，无明所覆，爱缘所系，得此识身。彼无明不断，爱缘不尽，身坏命终，还复受身。还受身故，不得解脱生老病死、忧悲恼苦。所以者何？此愚痴凡夫，本不修梵行，向正尽苦，究竟苦边故，是故身坏命终，还复受身。还受身故，不得解脱生老病死、忧悲恼苦。
    “若黠慧者，无明所覆，爱缘所系，得此识身。彼无明断，爱缘尽，无明断、爱缘尽故，身坏命终，更不复受。不更受故，得解脱生老病死、忧悲恼苦。所以者何？彼先修梵行，正向尽苦，究竟苦边故，是故彼身坏命终，更不复受。更不受故，得解脱生老病死、忧悲恼苦。是名凡夫及黠慧者，彼于我所修诸梵行，种种差别。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二九五）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“此身非汝所有，亦非余人所有，谓六触入处，本修行愿受得此身。云何为六？眼触入处，耳、鼻、舌、身、意触入处。彼多闻圣弟子，于诸缘起，善正思惟观察：有此六识身、六触身、六受身、六想身、六思身，所谓此有故，有当来生老病死、忧悲恼苦，如是如是纯大苦聚集，是名有因有缘世间集。谓此无故，六识身无，六触身、六受身、六想身、六思身无，谓此无故，无有当来生老病死、忧悲恼苦，如是如是纯大苦聚灭。
    “若多闻圣弟子，于世间集、世间灭，如实正知，善见、善觉、善入，是名圣弟子招此善法、得此善法、知此善法、入此善法，觉知、觉见世间生灭，成就贤圣出离、贯穿、正尽苦，究竟苦边。所以者何？谓多闻圣弟子，世间集灭如实知，善见、善觉、善入故。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二九六）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“我今当说因缘法及缘生法。云何为因缘法？谓此有故彼有，谓缘无明行，缘行识，乃至如是如是纯大苦聚集。云何缘生法？谓无明、行。若佛出世，若未出世，此法常住，法住法界，彼如来自所觉知，成等正觉，为人演说，开示显发，谓缘无明有行，乃至缘生有老死。若佛出世，若未出世，此法常住，法住法界，彼如来自觉知，成等正觉，为人演说，开示显发，谓缘生故，有老病死、忧悲恼苦。此等诸法，法住、法空、法如、法尔，法不离如，法不异如，审谛、真实、不颠倒。如是随顺缘起，是名缘生法，谓无明、行、识、名色、六入处、触、受、爱、取、有、生、老病死忧悲恼苦，是名缘生法。
    “多闻圣弟子于此因缘法、缘生法，正智善见。不求前际，言我过去世若有、若无？我过去世何等类？我过去世何如？不求后际，我于当来世为有、为无？云何类？何如？内不犹豫，此是何等？云何有此？为前谁终？当云何之？此众生从何来？于此没当何之？若沙门、婆罗门起凡俗见所系，谓说我见所系、说众生见所系、说寿命见所系、忌讳吉庆见所系，尔时悉断、悉知，断其根本，如截多罗树头，于未来世成不生法。是名多闻圣弟子，于因缘法、缘生法，如实正知，善见、善觉、善修、善入。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二九七）

    如是我闻。一时佛住拘留搜调牛聚落。
    尔时世尊告诸比丘：“我当为汝等说法，初、中、后善，善义善味，纯一清净，梵行清白，所谓《大空法经》。谛听善思，当为汝说。云何为《大空法经》？所谓此有故彼有，此起故彼起，谓缘无明行，缘行识，乃至纯大苦聚集。
    “缘生老死者，若有问言：‘彼谁老死？老死属谁？’彼则答言：‘我即老死，今老死属我，老死是我。’所言‘命即是身’，或言‘命异身异’，此则一义，而说有种种。若见言‘命即是身’，彼梵行者所无有。若复见言‘命异身异’，梵行者所无有。于此二边，心所不随，正向中道，贤圣出世，如实、不颠倒、正见，谓缘生老死。
    “如是生、有、取、爱、受、触、六入处、名色、识、行，缘无明故有行。若复问言：‘谁是行？行属谁？’彼则答言：‘行则是我，行是我所。’彼如是‘命即是身’，或言‘命异身异’。彼见命即是身者，梵行者无有。或言命异身异者，梵行者亦无有。离此二边，正向中道，贤圣出世，如实、不颠倒、正见，所谓缘无明行。
    “诸比丘，若无明离欲而生明，彼谁老死，老死属谁者，老死则断、则知，断其根本，如截多罗树头，于未来世成不生法。若比丘无明离欲而生明，彼谁生，生属谁，乃至谁是行，行属谁者，行则断、则知，断其根本，如截多罗树头，于未来世成不生法。若比丘无明离欲而生明，彼无明灭则行灭，乃至纯大苦聚灭。是名《大空法经》。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二九八）

    如是我闻。一时佛住拘留搜调牛聚落。
    尔时世尊告诸比丘：“我今当说缘起法，法说、义说。谛听善思，当为汝说。
    “云何缘起法法说？谓此有故彼有，此起故彼起，谓缘无明行，乃至纯大苦聚集，是名缘起法法说。
    “云何义说？谓缘无明行者，彼云何无明？若不知前际、不知后际、不知前后际，不知于内、不知于外、不知内外，不知业、不知报、不知业报，不知佛、不知法、不知僧，不知苦、不知集、不知灭、不知道，不知因、不知因所起法，不知善、不善，有罪、无罪，习、不习，若劣、若胜，染污、清净，分别缘起，皆悉不知。于六触入处不如实觉知，于彼彼不知、不见、无无间等、痴暗、无明、大冥，是名无明。
    “缘无明行者，云何为行？行有三种，身行、口行、意行。
    “缘行识者，云何为识？谓六识身，眼识身、耳识身、鼻识身、舌识身、身识身、意识身。
    “缘识名色者，云何名？谓四无色阴，受阴、想阴、行阴、识阴。云何色？谓四大、四大所造色，是名为色。此色及前所说名，是为名色。
    “缘名色六入处者，云何为六入处？谓六内入处，眼入处、耳入处、鼻入处、舌入处、身入处、意入处。
    “缘六入处触者，云何为触？谓六触身，眼触身、耳触身、鼻触身、舌触身、身触身、意触身。
    “缘触受者，云何为受？谓三受，苦受、乐受、不苦不乐受。
    “缘受爱者，彼云何为爱？谓三爱，欲爱、色爱、无色爱。
    “缘爱取者，云何为取？四取，欲取、见取、戒取、我取。
    “缘取有者，云何为有？三有，欲有、色有、无色有。
    “缘有生者，云何为生？若彼彼众生，彼彼身种类生，超越和合出生，得阴、得界、得入处、得命根，是名为生。
    “缘生老死者，云何为老？若发白露顶，皮缓根熟，支弱背偻，垂头呻吟，短气前输，柱杖而行，身体黧黑，四体斑驳，暗钝垂熟，造行艰难羸劣，是名为老。云何为死？彼彼众生，彼彼种类没、迁移、身坏、寿尽、火离、命灭，舍阴时到，是名为死。此死及前说老，是名老死。是名缘起义说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（二九九）

    如是我闻。一时佛住拘留搜调牛聚落。
    时有异比丘来诣佛所，稽首礼足，退坐一面，白佛言：“世尊，谓缘起法，为世尊作，为余人作耶？”
    佛告比丘：“缘起法者，非我所作，亦非余人作。然彼如来出世及未出世，法界常住。彼如来自觉此法，成等正觉，为诸众生分别演说，开发显示，所谓此有故彼有，此起故彼起，谓缘无明行，乃至纯大苦聚集。无明灭故行灭，乃至纯大苦聚灭。”
    佛说此经已，时彼比丘闻佛所说，欢喜奉行。

（三○○）

    如是我闻。一时佛住拘留搜调牛聚落。
    时有异婆罗门来诣佛所，与世尊面相庆慰，庆慰已，退坐一面，白佛言：“云何瞿昙，为自作自觉耶？”
    佛告婆罗门：“我说此是无记。自作自觉，此是无记。”
    “云何瞿昙，他作他觉耶？”
    佛告婆罗门：“他作他觉，此是无记。”
    婆罗门白佛：“云何我问自作自觉，说言无记。他作他觉，说言无记。此义云何？”
    佛告婆罗门：“自作自觉则堕常见，他作他觉则堕断见。义说、法说，离此二边，处于中道而说法。所谓此有故彼有，此起故彼起，缘无明行，乃至纯大苦聚集。无明灭则行灭，乃至纯大苦聚灭。”
    佛说此经已，彼婆罗门欢喜随喜，从座起去。

（三○一）

    如是我闻。一时佛住那梨聚落深林中待宾舍。
    尔时尊者跚陀迦旃延诣佛所，稽首佛足，退住一面，白佛言：“世尊，如世尊说正见，云何正见？云何世尊施设正见？”
    佛告跚陀迦旃延：“世间有二种依，若有、若无，为取所触；取所触故，或依有、或依无。若无此取者，心境系著使，不取、不住、不计我，苦生而生，苦灭而灭。于彼不疑、不惑，不由于他而自知，是名正见，是名如来所施设正见。所以者何？世间集，如实正知见，若世间无者不有；世间灭，如实正知见，若世间有者无有。是名离于二边，说于中道。所谓此有故彼有，此起故彼起，谓缘无明行，乃至纯大苦聚集。无明灭故行灭，乃至纯大苦聚灭。”
    佛说此经已，尊者跚陀迦旃延闻佛所说，不起诸漏，心得解脱，成阿罗汉。

（三○二）

    如是我闻。一时佛住王舍城耆阇崛山。
    尔时世尊晨朝着衣持钵，出耆阇崛山，入王舍城乞食。
    时有阿支罗迦叶，为营小事，出王舍城，向耆阇崛山，遥见世尊。见已诣佛所，白佛言：“瞿昙，欲有所问，宁有闲暇见答以不？”
    佛告迦叶：“今非论时，我今入城，乞食来还，则是其时，当为汝说。”
    第二亦如是说。
    第三复问：“瞿昙，何为我作留难？瞿昙，云何有异？我今欲有所问，为我解说！”
    佛告阿支罗迦叶：“随汝所问，”
    阿支罗迦叶白佛言：“云何瞿昙，苦自作耶？”
    佛告迦叶：“苦自作者，此是无记。”
    迦叶复问：“云何瞿昙，苦他作耶？”
    佛告迦叶：“苦他作者，此亦无记。”
    迦叶复问：“苦自他作耶？”
    佛告迦叶：“苦自他作，此亦无记。”
    迦叶复问：“云何瞿昙，苦非自非他无因作耶？”
    佛告迦叶：“苦非自非他无因作者，此亦无记。”
    迦叶复问：“云何瞿昙，所问苦自作耶，答言无记？他作耶，自他作耶，非自非他无因作耶，答言无记？今无此苦耶？”
    佛告迦叶：“非无此苦，然有此苦。”
    迦叶白佛言：“善哉瞿昙！说有此苦。为我说法，令我知苦见苦。”
    佛告迦叶：“若受即自受者，我应说苦自作；若他受，他即受者，是则他作；若受自受他受，复与苦者，如是者自他作，我亦不说；若不因自他，无因而生苦者，我亦不说。离此诸边，说其中道。如来说法，此有故彼有，此起故彼起，谓缘无明行，乃至纯大苦聚集。无明灭则行灭，乃至纯大苦聚灭。”
    佛说此经已，阿支罗迦叶远尘离垢，得法眼净。时阿支罗迦叶，见法、得法、知法、入法，度诸狐疑，不由他知，不因他度，于正法律心得无畏，合掌白佛言：“世尊，我今已度。我从今日，归依佛、归依法、归依僧，尽寿作优婆塞，证知我！”
    阿支罗迦叶闻佛所说，欢喜随喜，作礼而去。
    时阿支罗迦叶，辞世尊去不久，为护犊牸牛所触杀。于命终时，诸根清净，颜色鲜白。
    尔时世尊入城乞食。时有众多比丘亦入王舍城乞食，闻有传说：阿支罗迦叶从世尊闻法，辞去不久，为牛所触杀，于命终时，诸根清净，颜色鲜白。
    诸比丘乞食已还出，举衣钵，洗足，诣世尊所，稽首礼足，退坐一面，白佛言：“世尊，我今晨朝众多比丘入城乞食，闻阿支罗迦叶从世尊闻法律，辞去不久，为护犊牛所触杀，于命终时，诸根清净，颜色鲜白。世尊，彼生何趣？何处受生？彼何所得？”
    佛告诸比丘：“彼已见法、知法、次法、不受于法，已般涅槃。汝等当往供养其身。”
    尔时世尊为阿支罗迦叶授第一记。

（三○三）

    如是我闻。一时佛住王舍城耆阇崛山中。
    尔时世尊晨朝着衣持钵，入王舍城乞食。于路见玷牟留外道出家，少有所营，至耆阇崛山游行，遥见世尊，往诣其所，共相庆慰，共相庆慰已，于一面住，白佛言：“瞿昙，欲有所问，宁有闲暇为解说不？”
    佛告玷牟留外道出家：“今非论时，须入城乞食，来还当为汝说。”
    第二说亦如是。
    第三复请：“沙门瞿昙，将于我所作留难不？欲有所问，为我解说！”
    佛告玷牟留外道出家：“随汝意问，当为汝说。”
    玷牟留外道出家即问：“沙门瞿昙，苦乐自作耶？”
    佛告玷牟留外道出家：“说苦乐自作者，此是无记。”
    复问：“沙门瞿昙，苦乐他作耶？”
    佛告玷牟留外道出家：“说苦乐他作者，此是无记。”
    复问：“瞿昙，苦乐为自他作耶？”
    佛告玷牟留外道出家：“说苦乐自他作者，此是无记。”
    复问：“瞿昙，苦乐非自非他无因作耶？”
    佛告玷牟留外道出家：“说苦乐非自非他无因作者，此是无记。”
    广说如上《阿支罗迦叶经》。
    乃至世尊为玷牟留外道出家授第一记。


杂阿含经卷第十三

（三○四）

    如是我闻。一时佛住拘留搜调牛聚落。
    尔时世尊告诸比丘：“我今当为汝等说法，初、中、后善，善义善味，纯一满净，梵行清白。谛听善思，有六六法。何等为六六法？谓六内入处、六外入处、六识身、六触身、六受身、六爱身。
    “何等为六内入处？谓眼入处、耳入处、鼻入处、舌入处、身入处、意入处。何等为六外入处？色入处、声入处、香入处、味入处、触入处、法入处。云何六识身？谓眼识身、耳识身、鼻识身、舌识身、身识身、意识身。云何六触身？谓眼触、耳触、鼻触、舌触、身触、意触。云何六受身？谓眼触生受、耳触生受、鼻触生受、舌触生受、身触生受、意触生受。云何六爱身？谓眼触生爱、耳触生爱、鼻触生爱、舌触生爱、身触生爱、意触生爱。
    “若有说言眼是我，是则不然。所以者何？眼生灭故，若眼是我者，我应受生死，是故说眼是我者，是则不然。如是若色、若眼识、眼触、眼触生受，若是我者，是则不然。所以者何？眼触生受，是生灭法，若眼触生受是我者，我复应受生死，是故说眼触生受是我者，是则不然，是故眼触生受非我。如是耳、鼻、舌、身、意触生受非我。所以者何？意触生受，是生灭法，若是我者，我复应受生死，是故意触生受是我者，是则不然，是故意触生受非我。
    “如是比丘，当如实知眼所作、智所作、寂灭所作，开发神通，正向涅槃。云何如实知见眼所作，乃至正向涅槃？如是比丘，眼非我，若色、眼识、眼触、眼触因缘生受，内觉若苦、若乐、不苦不乐，彼亦观察非我。耳、鼻、舌、身、意，亦如是说。是名如实知见眼所作，乃至正向涅槃，是名《六六法经》。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三○五）

    如是我闻。一时佛住拘留搜调牛聚落。
    尔时世尊告诸比丘：“我今当为汝等说法，初、中、后善，善义善味，纯一满净，梵行清白，所谓《六分别六入处经》，谛听善思，当为汝说。何等为《六分别六入处经》？谓于眼入处不如实知见者，色、眼识、眼触、眼触因缘生受，内觉若苦、若乐、不苦不乐，不如实知见；不如实知见故，于眼染著，若色、眼识、眼触、眼触因缘生受，内觉若苦、若乐、不苦不乐，皆生染著。如是耳、鼻、舌、身、意，若法、意识、意触、意触因缘生受，内觉若苦、若乐、不苦不乐，不如实知见，不如实知见故生染著。如是染著相应、愚暗、顾念、结缚其心，长养五受阴，及当来有爱、贪、喜悉皆增长。身心疲恶，身心烧燃，身心炽然，身心狂乱，身生苦觉。彼身生苦觉故，于未来世生老病死、忧悲恼苦，悉皆增长，是名纯一大苦阴聚集。
    “诸比丘，若于眼如实知见，若色、眼识、眼触、眼触因缘生受，内觉若苦、若乐、不苦不乐，如实知见；见已于眼不染著，若色、眼识、眼触、眼触因缘生受，内觉若苦、若乐、不苦不乐，不染著。如是耳、鼻、舌、身、意法如实知见，若法、意识、意触、意触因缘生受，内觉若苦、若乐、不苦不乐，如实知见；如实知见故，于意不染著，若法、意识、意触、意触因缘生受，内觉若苦、若乐、不苦不乐，不染。不染著故，不相杂、不愚暗、不顾念、不系缚，损减五受阴，当来有爱、贪、喜、彼彼染著，悉皆消灭。身不疲苦，心不疲苦，身不烧，心不烧，身不炽然，心不炽然，身觉乐，心觉乐。身心觉乐故，于未来世生老病死、忧悲恼苦，悉皆消灭，如是纯大苦聚阴灭。
    “作如是知、如是见者，名为正见修习满足，正志、正方便、正念、正定，前说正语、正业、正命清净修习满足，是名修习八圣道清净满足。八圣道修习满足已，四念处修习满足，四正勤、四如意足、五根、五力、七觉分修习满足。若法应知、应了者，悉知、悉了。若法应知、应断者，悉知、悉断。若法应知、应作证者，悉皆作证。若法应知、应修习者，悉已修习。何等法应知、应了，悉知、悉了？所谓名色。何等法应知、应断？所谓无明及有爱。何等法应知、应证？所谓明、解脱。何等法应知、应修？所谓正观。若比丘于此法应知、应了，悉知、悉了；若法应知、应断者，悉知、悉断；若法应知、应作证者，悉知、悉证；若法应知、应修者，悉知、悉修，是名比丘断爱结缚，正无间等，究竟苦边。诸比丘，是名《六分别六入处经》。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三○六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘，独一静处，专精思惟，作是念：“比丘云何知、云何见，而得见法？”作是思惟已，从禅起，往诣佛所，稽首礼足，退坐一面，白佛言：“世尊，我独一静处，专精思惟，作是念：比丘云何知、云何见，而得见法？”
    尔时世尊告彼比丘：“谛听善思，当为汝说。有二法，何等为二？眼、色为二。如是广说，乃至非其境界故。所以者何？眼、色缘生眼识，三事和合触，触俱生受、想、思。此四无色阴、眼色，此等法名为人。于斯等法，作人想、众生、那罗、摩[少/兔]阇、摩那婆、士夫、福伽罗、耆婆、禅头。又如是说：‘我眼见色，我耳闻声，我鼻嗅香，我舌尝味，我身觉触，我意识法。’彼施设又如是言说：‘是尊者如是名，如是生，如是姓，如是食，如是受苦乐，如是长寿，如是久住，如是寿分齐。’比丘，是则为想，是则为志，是则言说。此诸法皆悉无常、有为、思愿缘生。若无常、有为、思愿缘生者，彼则是苦。又复彼苦生，亦苦住，亦苦灭，亦苦数数出生，一切皆苦。若复彼苦无余断，吐、尽、离欲、灭、息、没，余苦更不相续，不出生，是则寂灭，是则胜妙，所谓舍一切有余，一切爱尽、无欲、灭尽、涅槃。
    “耳、鼻、舌、身触缘生身识，三事和合触，触俱生受、想、思。此四是无色阴，身根是色阴，此名为人。如上说，乃至灭尽、涅槃。
    “缘意、法，生意识，三事和合触，触俱生受、想、思。此四无色阴，四大士夫所依，此等法名为人。如上广说，乃至灭尽、涅槃。若有于此诸法，心随入住，解脱不退转，于彼所起系著无有我。比丘，如是知、如是见，则为见法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三○七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘，独一静处，专精思惟，作是念：“云何知、云何见，名为见法？”思惟已，从禅起，往诣佛所，稽首礼足，退坐一面，白佛言：“世尊，我独一静处，专精思惟，作是念：‘比丘云何知、云何见，名为见法？’今问世尊，唯愿解说。”
    佛告比丘：“谛听善思，当为汝说。有二法，眼、色缘生眼识。”如上广说。
    尊者如所说偈：

“眼色二种缘，生于心心法，
识触及俱生，受想等有因。
非我非我所，亦非福伽罗，
亦非摩[少/兔]阇，亦非摩那婆。
是则为生灭，苦阴变易法，
于斯等作想，施设于众生，
那罗摩[少/兔]阇，及与摩那婆，
亦余众多想，皆因苦阴生。
诸业爱无明，因积他世阴，
余沙门异道，异说二法者，
彼但有言说，闻已增痴惑。
贪爱息无余，无明没永灭，
爱尽众苦息，无上佛明说。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三○八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“诸天世人于色染著爱乐住，彼色若无常、变易、灭尽，彼诸天人则生大苦。于声、香、味、触、法染著爱乐住，彼法变易、无常、灭尽，彼诸天人得大苦住。
    “如来于色、色集、色灭、色味、色患、色离如实知，如实知已，于色不复染著爱乐住，彼色变易、无常、灭尽，则生乐住。于声、香、味、触、法，集、灭、味、患、离如实知，如实知已，不复染著爱乐住，彼色变易、无常、灭尽，则生乐住。
    “所以者何？眼、色缘生眼识，三事和合触，触缘受，若苦、若乐、不苦不乐，此受集、此受灭、此受味、此受患、此受离如实知，于彼色因缘生阨碍，阨碍尽已，名无上安隐涅槃。耳、鼻、舌、身、意、法缘生意识，三事和合触，触缘受，若苦、若乐、不苦不乐，彼受集、受灭、受味、受患、受离如实知，如实知已，彼法因缘生阨碍，阨碍尽已，名无上安隐涅槃。”
    尔时世尊而说偈言：

“于色声香味，触法六境界，
一向生喜悦，爱染深乐著，
诸天及世人，唯以此为乐，
变易灭尽时，彼则生大苦。
唯有诸贤圣，见其灭为乐，
世间之所乐，观察悉为怨。
贤圣见苦者，世间以为乐，
世间之所苦，于圣则为乐。
甚深难解法，世间痴惑生，
大暗所昏没，盲冥无所见，
唯有智慧者，发朦开大明。
如是甚深句，非圣孰能知？
不还受身者，深达谛明了。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三○九）

    如是我闻。一时佛住瞻婆国揭伽池侧。
    尔时尊者鹿纽，来诣佛所，稽首礼足，退坐一面，白佛言：“世尊，如世尊说，有第二住，有一一住。彼云何第二住？云何一一住？”
    佛告鹿纽：“善哉善哉！鹿纽，能问如来如是之义。”
    佛告鹿纽：“若眼识色，可爱乐念、可意，长养于欲，彼比丘见已，喜乐、赞叹、系著住；爱乐、赞叹、系著住已，心转欢喜，欢喜已深乐，深乐已贪爱，贪爱已阨碍。欢喜、深乐、贪爱、阨碍者，是名第二住。耳、鼻、舌、身、意，亦如是说。鹿纽，有如是像类比丘，正使空闲独处，犹名第二住。所以者何？爱喜不断、不灭故。爱欲不断、不知者，诸佛如来说第二住。
    “若有比丘，于可爱乐念、可意、长养于欲色，彼比丘见已，不喜乐、不赞叹、不系著住；不喜乐、不赞叹、不系著住已，不欢喜，不欢喜故不深乐，不深乐故不贪爱，不贪爱故不阨碍；不欢喜、深乐、贪爱、阨碍者，是名为一一住。耳、鼻、舌、身、意，亦如是说。鹿纽，如是像类比丘，正使处于高楼重阁，犹是一一住者。所以者何？贪爱已尽、已知故。贪爱已尽、已知者，诸佛如来说名一一住。”
    尔时尊者鹿纽闻佛所说，欢喜随喜，作礼而去。

（三一○）

    如是我闻。一时佛住瞻婆国揭伽池侧。
    尔时尊者鹿纽，来诣佛所，稽首礼足，退坐一面，白佛言：“善哉世尊！为我说法。我闻法已，当独一静处，专精思惟，不放逸住，乃至自知不受后有。”
    佛告鹿纽：“善哉善哉！鹿纽，能问如来如是之义。谛听善思，当为汝说。”
    佛告鹿纽：“若眼见可爱乐、可意、可念、长养于欲之色，见已欣悦、赞叹、系著、欣悦；赞叹、系著已，则欢喜集，欢喜集已则苦集。耳、鼻、舌、身、意，亦如是说。
    “鹿纽，若有比丘，眼见可爱乐、可念、可意、长养于欲之色，见已不欣悦、不赞叹、不系著；不欣悦、不赞叹、不系著故，不欢喜集，不欢喜集故则苦灭。耳、鼻、舌、身、意法，亦如是说。”
    尔时尊者鹿纽闻佛所说，欢喜随喜，作礼而去。
    尔时尊者鹿纽闻佛说法教诫已，独一静处，专精思惟，不放逸住，乃至得阿罗汉，心善解脱。

（三一一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者富楼那，来诣佛所，稽首礼足，退住一面，白佛言：“善哉世尊，为我说法。我坐独一静处，专精思惟，不放逸住，乃至自知不受后有。”
    佛告富楼那：“善哉善哉！能问如来如是之义。谛听善思，当为汝说。若有比丘，眼见可爱乐、可念、可意、长养欲之色，见已欣悦、赞叹、系著；欣悦、赞叹、系著已欢喜，欢喜已乐著，乐著已贪爱，贪爱已阨碍；欢喜、乐著、贪爱、阨碍故，去涅槃远。耳、鼻、舌、身、意，亦如是说。
    “富楼那，若比丘眼见可爱乐、可念、可意、长养欲之色，见已不欣悦、不赞叹、不系著；不欣悦、不赞叹、不系著故不欢喜，不欢喜故不深乐，不深乐故不贪爱，不贪爱故不阨碍；不欢喜、不深乐、不贪爱、不阨碍故，渐近涅槃。耳、鼻、舌、身、意，亦如是说。”
    佛告富楼那：“我已略说法教，汝欲何所住？”
    富楼那白佛言：“世尊，我已蒙世尊略说教诫，我欲于西方输卢那人间游行。”
    佛告富楼那：“西方输卢那人，凶恶、轻躁、弊暴、好骂。富楼那，汝若闻彼凶恶、轻躁、弊暴、好骂、毁辱者，当如之何？”
    富楼那白佛言：“世尊，若彼西方输卢那国人，面前凶恶、诃骂、毁辱者，我作是念：彼西方输卢那人贤善智慧，虽于我前凶恶、弊暴、好骂、毁辱我，犹尚不以手石而见打掷。”
    佛告富楼那：“彼西方输卢那人但凶恶、轻躁、弊暴、骂辱，于汝则可脱。复当以手石打掷者，当如之何？”
    富楼那白佛言：“世尊，西方输卢那人脱以手石加于我者，我当念言：输卢那人贤善智慧，虽以手、石加我，而不用刀杖。”
    佛告富楼那：“若当彼人脱以刀杖而加汝者，复当云何？”
    富楼那白佛言：“世尊，若当彼人脱以刀杖而加我者，当作是念：彼输卢那人贤善智慧，虽以刀杖而加于我，而不见杀。”
    佛告富楼那：“假使彼人脱杀汝者，当如之何？”
    富楼那白佛言：“世尊，若西方输卢那人脱杀我者，当作是念：有诸世尊弟子，当厌患身，或以刀自杀，或服毒药，或以绳自系，或投深坑。彼西方输卢那人贤善智慧，于我朽败之身，以少作方便，便得解脱。”
    佛言：“善哉富楼那！汝善学忍辱，汝今堪能于输卢那人间住止。汝今宜去，度于未度，安于未安，未涅槃者令得涅槃。”
    尔时富楼那闻佛所说，欢喜随喜，作礼而去。
    尔时尊者富楼那，夜过晨朝，着衣持钵，入舍卫城乞食。食已还出，付嘱卧具，持衣钵去，至西方输卢那人间游行。到已，夏安居，为五百优婆塞说法，建立五百僧伽蓝，绳床、卧褥、供养众具，悉皆备足。三月过已，具足三明，即于彼处入无余涅槃。

（三一二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时摩罗迦舅，来诣佛所，稽首礼足，退坐一面，白佛言：“善哉世尊！为我说法。我闻法已，独一静处，专精思惟，不放逸住，乃至不受后有。”
    尔时世尊告摩罗迦舅言：“诸年少聪明利根，于我法律出家未久，于我法律尚无懈怠。而况汝今日年耆根熟，而欲闻我略说教诫？”
    摩罗迦舅白佛言：“世尊，我虽年耆根熟，而尚欲得闻世尊略说教诫。唯愿世尊为我略说教诫，我闻法已，当独一静处，专精思惟，乃至自知不受后有。”第二、第三亦如是请。
    佛告摩罗迦舅：“汝今且止。”如是再三，亦不为说。
    尔时世尊告摩罗迦舅：“我今问汝，随意答我。”
    佛告摩罗迦舅：“若眼未曾见色，汝当欲见，于彼色起欲、起爱、起念、起染著不？”
    答言：“不也，世尊。”
    耳声、鼻香、舌味、身触、意法，亦如是说。
    佛告摩罗迦舅：“善哉善哉！摩罗迦舅，见以见为量，闻以闻为量，觉以觉为量，识以识为量。”而说偈言：

“若汝非于彼，彼亦复非此，
亦非两中间，是则为苦边。”

    摩罗迦舅白佛言：“已知，世尊。已知，善逝。”
    佛告摩罗迦舅：“汝云何于我略说法中广解其义？”
    尔时摩罗迦舅说偈白佛言：

“若眼已见色，而失于正念，
则于所见色，而取爱念相；
取爱乐相者，心则常系著，
起于种种爱，无量色集生；
贪欲恚害觉，令其心退减，
长养于众苦，永离于涅槃。
见色不取相，其心随正念，
不染恶心爱，亦不生系著；
不起于诸爱，无量色集生，
贪欲恚害觉，不能坏其心；
小长养众苦，渐次近涅槃，
日种尊所说，离爱般涅槃。
若耳闻诸声，心失于正念，
而取诸声相，执持而不舍；
鼻香舌尝味，身触意念法，
忘失于正念，取相亦复然；
其心生爱乐，系著坚固住，
起种种诸爱，无量法集生；
贪欲恚害觉，退减坏其心，
长养众苦聚，永离于涅槃。
不染于诸法，正智正念住，
其心不染污，亦复不乐著；
不起于诸爱，无量法集生，
贪瞋恚害觉，不退减其心；
众苦随损减，渐近般涅槃，
爱尽般涅槃，世尊之所说。

    “是名世尊略说法中广解其义。”
    佛告摩罗迦舅：“汝真于我略说法中广解其义。所以者何？如汝所说偈：

“若眼见众色，忘失于正念，
则于所见色，而取爱念相。”

    如前广说。
    尔时尊者摩罗迦舅闻佛所说，欢喜随喜，作礼而去。
    尔时尊者摩罗迦舅，于世尊略说法中广解其义已，于独一静处，专精思惟，不放逸住，乃至成阿罗汉，心得解脱。

（三一三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有经法，诸比丘崇向，而于经法异信、异欲、异闻、异行思惟、异见审谛忍，正知而说：我生已尽，梵行已立，所作已作，自知不受后有。”
    诸比丘白佛言：“世尊是法根、法眼、法依。善哉世尊！唯愿广说，诸比丘闻已，当受奉行。”
    佛告诸比丘：“谛听善思，当为汝说。比丘，眼见色已，觉知色而不觉色贪，我先眼识于色有贪，而今眼识于色无贪如实知。若比丘眼见于色已，觉知色而不起色贪，觉我先眼识有贪，而言今眼识于色无贪如实知者。诸比丘，于意云何？彼于此为有信、有欲、有闻、有行思惟、有审谛忍不？”
    答言：“如是，世尊。”
    “归于此法，如实正知所知所见不？”
    答言：“如是，世尊。”
    “耳、鼻、舌、身、意法，亦如是说。诸比丘，是名有经法，比丘于此经法崇向，异信、异欲、异闻、异行思惟、异见审谛忍，正知而说：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三一四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当断欲，断眼欲已，眼则已断已知，断其根本，如截多罗树头，于未来世永不复生。耳、鼻、舌、身、意，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三一五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若眼生、住、转出，则苦生、病住、老死出。耳、鼻、舌、身、意，亦如是说。若眼灭、息、没，苦生则灭，病则息，死则没。耳、鼻、舌、身、意，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三一六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“眼无常，若眼是常者，则不应受逼迫苦，亦应说于眼欲令如是，不令如是。以眼无常故，是故眼受逼迫苦生，是故不得于眼欲令如是，不令如是。耳、鼻、舌、身、意，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三一七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“眼苦，若眼是乐者，不应受逼迫苦，应得于眼欲令如是，不令如是。以眼是苦故，受逼迫苦，不得于眼欲令如是，不令如是。耳、鼻、舌、身、意，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三一八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“眼非我，若眼是我者，不应受逼迫苦，应得于眼欲令如是，不令如是。以眼非我故，受逼迫苦，不得于眼欲令如是，不令如是。耳、鼻、舌、身、意，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如内六入处三经，外六入处三经，亦如是说。

（三一九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有生闻婆罗门，往诣佛所，共相问讯，问讯已，退坐一面，白佛言：“瞿昙，所谓一切者，云何名一切？”
    佛告婆罗门：“一切者，谓十二入处，眼色、耳声、鼻香、舌味、身触、意法，是名一切。若复说言‘此非一切，沙门瞿昙所说一切，我今舍，别立余一切’者，彼但有言说，问已不知，增其疑惑。所以者何？非其境界故。”
    时生闻婆罗门闻佛所说，欢喜随喜，从座起去。

（三二○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有生闻婆罗门，往诣佛所，面相问讯已，退坐一面，白佛言：“瞿昙，所谓一切有，云何一切有？”
    佛告生闻婆罗门：“我今问汝，随意答我。婆罗门，于意云何，眼是有不？”
    答言：“是有，沙门瞿昙。”
    “色是有不？”
    答言：“是有，沙门瞿昙。”
    “婆罗门，有色、有眼识、有眼触、有眼触因缘生受，若苦、若乐、不苦不乐不？”
    答言：“有，沙门瞿昙。”
    耳、鼻、舌、身、意，亦如是说。如是广说，乃至非其境界故。
    佛说此经已，生闻婆罗门闻佛所说，欢喜随喜，从座起去。

（三二一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有生闻婆罗门，往诣佛所，共相问讯已，退坐一面，白佛言：“沙门瞿昙，所谓一切法，云何为一切法？”
    佛告婆罗门：“眼及色、眼识、眼触、眼触因缘生受，若苦、若乐、不苦不乐；耳、鼻、舌、身、意、法、意识、意触、意触因缘生受，若苦、若乐、不苦不乐，是名为一切法。若复有言‘此非一切法，沙门瞿昙所说一切法，我今舍，更立一切法’者，此但有言数，问已不知，增其痴惑。所以者何？非其境界故。”
    佛说此经已，生闻婆罗门闻佛说已，欢喜随喜，从座起去。
    如生闻婆罗门所问三经，有异比丘所问三经、尊者阿难所问三经、世尊法眼法根法依三经，亦如上说。

（三二二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，如世尊说眼是内入处，世尊略说，不广分别。云何眼是内入处？”
    佛告彼比丘：“眼是内入处，四大所造净色，不可见，有对。耳、鼻、舌、身内入处，亦如是说。”
    复白佛言：“世尊，如世尊说意是内入处，不广分别。云何意是内入处？”
    佛告比丘：“意内入处者，若心、意、识非色，不可见，无对，是名意内入处。”
    复问：“如世尊说色外入处，世尊略说，不广分别。云何世尊色外入处？”
    佛告比丘：“色外入处，若色四大造，可见，有对，是名色是外入处。”
    复白佛言：“世尊说声是外入处，不广分别。云何声是外入处？”
    佛告比丘：“若声四大造，不可见，有对。如声，香、味亦如是。”
    复问：“世尊说触外入处，不广分别。云何触外入处？”
    佛告比丘：“触外入处者，谓四大及四大造色，不可见，有对，是名触外入处。”
    复问：“世尊说法外入处，不广分别。云何法外入处？”
    佛告比丘：“法外入处者，十一入所不摄，不可见，无对，是名法外入处。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三二三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有六内入处。云何为六？谓眼内入处，耳、鼻、舌、身、意内入处。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三二四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有六外入处。云何为六？谓色是外入处，声、香、味、触、法是外入处，是名六外入处。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三二五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有六识身。云何为六？谓眼识身、耳识身、鼻识身、舌识身、身识身、意识身，是名六识身。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三二六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有六触身。云何为六触身？谓眼触身、耳触身、鼻触身、舌触身、身触身、意触身，是名六触身。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三二七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有六受身。云何为六？谓眼触生受，耳、鼻、舌、身、意触生受，是名六受身。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三二八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有六想身。云何为六？谓眼触生想，耳、鼻、舌、身、意触生想，是名六想身。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三二九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有六思身。云何为六？谓眼触生思，耳、鼻、舌、身、意触生思，是名六思身。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三三○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有六爱身。云何为六爱身？谓眼触生爱，耳、鼻、舌、身、意触生爱，是名六爱身。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三三一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有六顾念。云何为六？谓色顾念、声顾念、香顾念、味顾念、触顾念、法顾念，是名六顾念。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三三二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有六覆。云何为六？谓色有漏，是取，心覆藏。声、香、味、触、法有漏，是取，心覆藏。是名六覆。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三三三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过去、未来眼无常，况现在眼？多闻圣弟子如是观者，不顾过去眼，不欣未来眼，于现在眼生厌、离欲、灭尽向。耳、鼻、舌、身、意，亦如是说。”
    如无常，如是苦、空、非我，亦如是说。
    如内入处四经，外入处四经，亦如是说。

（三三四）

    如是我闻。一时佛住拘留搜调牛聚落。
    尔时世尊告诸比丘：“今当为汝说法，初、中、后善，善义善味，纯一满净，梵行清白。谛听善思，谓《有因有缘有缚法经》。云何《有因有缘有缚法经》？谓眼有因、有缘、有缚。何等为眼因、眼缘、眼缚？谓眼业因、业缘、业缚。业有因、有缘、有缚，何等为业因、业缘、业缚？谓业爱因、爱缘、爱缚。爱有因、有缘、有缚，何等为爱因、爱缘、爱缚？谓爱无明因、无明缘、无明缚。无明有因、有缘、有缚，何等无明因、无明缘、无明缚？谓无明不正思惟因、不正思惟缘、不正思惟缚。不正思惟有因、有缘、有缚，何等不正思惟因、不正思惟缘、不正思惟缚？谓缘眼、色，生不正思惟，生于痴。缘眼、色，生不正思惟，生于痴，彼痴者是无明，痴求欲名为爱，爱所作名为业。如是比丘，不正思惟因无明，无明因爱，爱因为业，业因为眼。耳、鼻、舌、身、意，亦如是说。是名《有因有缘有缚法经》。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三三五）

    如是我闻。一时佛住拘留搜调牛聚落。
    尔时世尊告诸比丘：“我今当为汝等说法，初、中、后善，善义善味，纯一满净，梵行清白，所谓《第一义空经》。谛听善思，当为汝说。云何为《第一义空经》？诸比丘，眼生时无有来处，灭时无有去处。如是眼不实而生，生已尽灭，有业报而无作者，此阴灭已，异阴相续，除俗数法。耳、鼻、舌、身、意，亦如是说，除俗数法。俗数法者，谓此有故彼有，此起故彼起，如无明缘行，行缘识，广说乃至纯大苦聚集起。又复此无故彼无，此灭故彼灭，无明灭故行灭，行灭故识灭，如是广说，乃至纯大苦聚灭。比丘，是名《第一义空法经》。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三三六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有六喜行。云何为六？如是比丘，若眼见色，喜于彼色处行。耳声、鼻香、舌味、身触、意识法，喜于彼法处行。诸比丘，是名六喜行。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三三七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有六忧行。云何为六？诸比丘，若眼见色，忧于彼色处行。耳声、鼻香、舌味、身触、意识法，忧于彼法处行。诸比丘，是名六忧行。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三三八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有六舍行。云何为六？诸比丘，谓眼见色，舍于彼色处行。耳声、鼻香、舌味、身触、意识法，舍于彼法处行。是名比丘六舍行。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三三九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有六常行。云何为六？若比丘眼见色，不苦不乐舍心住，正念正智。耳声、鼻香、舌味、身触、意识法，不苦不乐舍心住，正念正智。是名比丘六常行。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（三四○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有六常行。云何为六？若比丘眼见色，不苦不乐舍心住，正念正智。耳声、鼻香、舌味、身触、意识法，不苦不乐舍心住，正念正智。若比丘成就此六常行者，世间难得。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三四一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有六常行。云何为六？若比丘眼见色，不苦不乐舍心住，正念正智。耳声、鼻香、舌味、身触、意识法，不苦不乐舍心住，正念正智。若比丘成就此六常行者，世间难得，所应承事，恭敬供养，则为世间无上福田。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三四二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有六常行。云何为六？若比丘眼见色，不苦不乐舍心住，正念正智。耳声、鼻香、舌味、身触、意识法，不苦不乐舍心住，正念正智。若比丘成就此六常行者，当知是舍利弗等。舍利弗比丘眼见色已，不苦不乐舍心住，正念正智；耳声、鼻香、舌味、身触、意识法，不苦不乐舍心住，正念正智。舍利弗比丘成就此六常行故，世间难得，所应承事，恭敬供养，则为世间无上福田。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。


杂阿含经卷第十四

（三四三）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者浮弥比丘住耆阇崛山。
    时有众多外道出家，诣尊者浮弥所，共相问讯庆慰，共相问讯庆慰已，退坐一面，语尊者浮弥言：“欲有所问，宁有闲暇见答以不？”
    尊者浮弥语诸外道出家：“随汝所问，当为汝说。”
    时诸外道出家问尊者浮弥：“苦乐自作耶？”
    尊者浮弥答言：“诸外道出家说苦乐自作者，世尊说言此是无记。”
    复问：“苦乐他作耶？”
    答言：“苦乐他作者，世尊说言此是无记。”
    复问：“苦乐自他作耶？”
    答言：“苦乐自他作者，世尊说言此是无记。”
    复问：“苦乐非自非他无因作耶？”
    答言：“苦乐非自非他无因作者，世尊说言此是无记。”
    诸外道出家复问：“云何尊者浮弥，苦乐自作耶，说言无记？苦乐他作耶，说言无记？苦乐自他作耶，说言无记？苦乐非自非他无因作耶，说言无记？今沙门瞿昙说苦乐云何生？”
    尊者浮弥答言：“诸外道出家，世尊说苦乐从缘起生。”
    时诸外道出家闻尊者浮弥所说，心不欢喜，呵责而去。
    尔时尊者舍利弗，去尊者浮弥不远，坐一树下。尔时尊者浮弥，知诸外道出家去已，往诣尊者舍利弗所。到已，与舍利弗面相庆慰，庆慰已，以彼诸外道出家所问事，具白尊者舍利弗：“我作此答，得不谤毁世尊，如说说不？如法说不？为是随顺法、行法，得无为余因法论者来难诘呵责不？”
    尊者舍利弗言：“尊者浮弥，汝之所说，实如佛说，不谤如来，如说说、如法说、法行法说，不为余因论义者来难诘呵责。所以者何？世尊说苦乐从缘起生故。尊者浮弥，彼诸沙门、婆罗门所问苦乐自作者，彼亦从因起生；言不从缘起生者，无有是处。苦乐他作、自他作、非自非他无因作说者，彼亦从缘起生；若言不从缘生者，无有是处。尊者浮弥，彼沙门、婆罗门所说苦乐自作者，亦缘触生；若言不从触生者，无有是处。苦乐他作、自他作、非自非他无因作者，彼亦缘触生；若言不缘触生者，无有是处。”
    尔时尊者阿难，去舍利弗不远，坐一树下，闻尊者舍利弗与尊者浮弥所论说事。闻已，从座起，往诣佛所，稽首佛足，退住一面，以尊者浮弥与尊者舍利弗共论说，一一具白世尊。
    佛告阿难：“善哉善哉！阿难，尊者舍利弗有来问者，能随时答。善哉舍利弗！有应时智故，有来问者，能随时答。若我声闻，有随时问者，应随时答，如舍利弗所说。阿难，我昔时住王舍城山中仙人住处，有诸外道出家，以如是义、如是句、如是味来问于我，我为斯等以如是义、如是句、如是味而为记说，如尊者舍利弗所说。
    “阿难，若诸沙门、婆罗门，苦乐自作。我即往彼问言：‘汝实作是说，苦乐自作耶？’彼答我言：‘如是。’我即问言：‘汝能坚执持此义，言是真实，余则愚者，我所不许。所以者何？我说苦乐所起异于此。’彼若问我：‘云何瞿昙所说苦乐所起异者？’我当答言：‘从其缘起而生苦乐。’如是说苦乐他作、自他作、非自非他无因作者，我亦往彼，所说如上。”
    阿难白佛：“如世尊所说义，我已解知。有生故有老死，非缘余，有生故有老死。乃至无明故有行，非缘余，有无明故有行。无明灭则行灭，乃至生灭则老病死、忧悲恼苦灭，如是纯大苦聚灭。”
    佛说此经已，尊者阿难闻佛所说，欢喜随喜，作礼而去。

（三四四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者舍利弗、尊者摩诃拘絺罗，住耆阇崛山。
    时尊者摩诃拘絺罗，晡时从禅起，诣舍利弗所，共相庆慰，共相庆慰已，退坐一面，语尊者舍利弗：“欲有所问，宁有闲暇见答以不？”
    尊者舍利弗语尊者摩诃拘絺罗：“仁者且问，知者当答。”
    尊者摩诃拘絺罗语尊者舍利弗言：“多闻圣弟子，于此法律成就何法，名为见具足，直见成就，成就于佛不坏净，来入正法，得此正法，悟此正法？”
    尊者舍利弗语尊者摩诃拘絺罗：“多闻圣弟子于不善法如实知，不善根如实知，善法如实知，善根如实知。云何不善法如实知？不善身业、口业、意业，是名不善法，如是不善法如实知。云何不善根如实知？三不善根，贪不善根、恚不善根、痴不善根，是名不善根，如是不善根如实知。云何善法如实知？善身业、口业、意业，是名善法，如是善法如实知。云何善根如实知？谓三善根，无贪、无恚、无痴，是名三善根，如是善根如实知。尊者摩诃拘絺罗，如是多闻圣弟子，不善法如实知、不善根如实知、善法如实知、善根如实知故，于此法律正见具足，直见成就，于佛不坏净成就，来入正法，得此正法，悟此正法。”
    尊者摩诃拘絺罗语尊者舍利弗：“正有此等，更有余耶？”
    尊者舍利弗言：“有。若多闻圣弟子于食如实知，食集、食灭、食灭道迹如实知。云何于食如实知？谓四食。何等为四？一者粗抟食，二者细触食，三者意思食，四者识食，是名为食，如是食如实知。云何食集如实知？谓当来有爱，喜贪俱，彼彼乐著，是名食集，如是食集如实知。云何食灭如实知？若当来有爱，喜贪俱，彼彼乐著，无余断、舍、吐、尽、离欲、灭、息、没，是名食灭，如是食灭如实知。云何食灭道迹如实知？谓八圣道，正见、正志、正语、正业、正命、正方便、正念、正定，是名食灭道迹，如是食灭道迹如实知。若多闻圣弟子于此食如实知、食集如实知、食灭如实知、食灭道迹如实知，是故多闻圣弟子于正法律，正见具足，直见成就，于佛不坏净成就，来入正法，得此正法，悟此正法。”
    尊者摩诃拘絺罗复问尊者舍利弗：“正有此等，更有余耶？”
    尊者舍利弗语尊者摩诃拘絺罗：“复更有余。多闻圣弟子于病如实知，病集如实知，病灭如实知，病灭道迹如实知。云何有病如实知？谓三病，欲病、有病、无明病，是名病，如是病如实知。云何病集如实知？无明集是病集，是名病集如实知。云何病灭如实知？无明灭是病灭，如是病灭如实知。云何病灭道迹如实知？谓八正道，如前说，如是病灭道迹如实知。若多闻圣弟子于病如实知、病集如实知、病灭如实知、病灭道迹如实知故，多闻圣弟子于此法律，正见具足，乃至悟此正法。”
    尊者摩诃拘絺罗问尊者舍利弗：“正有此等，更有余耶？”
    尊者舍利弗语尊者摩诃拘絺罗：“亦更有余。多闻圣弟子于苦如实知，苦集如实知，苦灭如实知，苦灭道迹如实知。云何苦如实知？谓生苦、老苦、病苦、死苦、恩爱别苦、怨憎会苦、所欲不得苦、如是略说五受阴苦，是名为苦，如是苦如实知。云何苦集如实知？当来有爱，喜贪俱，彼彼染著，是名苦集，如是苦集如实知。云何苦灭如实知？若当来有爱，喜贪俱，彼彼染著，无余断，乃至息、没，是名苦灭，如是苦灭如实知。云何苦灭道迹如实知？谓八圣道，如上说，是名苦灭道迹，如是苦灭道迹如实知。多闻圣弟子如是苦如实知，苦集、苦灭、苦灭道迹如实知。如是圣弟子于我法律，具足正见，直见成就，于佛不坏净成就，来入正法，得此正法，悟此正法。”
    复问尊者舍利弗：“正有此法，复有余耶？”
    尊者舍利弗答言：“亦更有余，谓多闻圣弟子老死如实知，老死集如实知，老死灭如实知，老死灭道迹如实知，如前分别经说。云何老死集如实知？生集是老死集。生灭是老死灭。老死灭道迹，谓八正道，如前说。多闻圣弟子于此老死如实知，乃至老死灭道迹如实知。如是圣弟子于我法律，正见具足，直见成就，于佛不坏净成就，来入正法，得此正法，悟此正法。
    “如是生、有、取、爱、受、触、六入处、名色、识、行，圣弟子于行如实知，行集、行灭、行灭道迹如实知。云何行如实知？行有三种，身行、口行、意行，如是行如实知。云何行集如实知？无明集是行集，如是行集如实知。云何行灭如实知？无明灭是行灭，如是行灭如实知。云何行灭道迹如实知？谓八圣道，如前说。摩诃拘絺罗，是名圣弟子行如实知，行集、行灭、行灭道迹如实知，于我法律，正见具足，直见成就，于佛不坏净成就，来入正法，得此正法，悟此正法。”
    摩诃拘絺罗复问尊者舍利弗：“唯有此法，更有余耶？”
    舍利弗答言：“摩诃拘絺罗，汝何为逐？汝终不能究竟诸论，得其边际。若圣弟子断除无明而生明，何须更求！”
    时二正士共论义已，各还本处。

（三四五）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告尊者舍利弗：“如我所说波罗延耶阿逸多所问：

“若得诸法数，若复种种学，
具威仪及行，为我分别说。

    “舍利弗，何等为学？何等为法数？”
    时尊者舍利弗默然不答，第二、第三亦复默然。
    佛言：“真实，舍利弗！”
    舍利弗白佛言：“真实，世尊！世尊，比丘真实者，厌、离欲、灭尽向。食集生，彼比丘以食故，生厌、离欲、灭尽向。彼食灭是真实灭，觉知已，彼比丘厌、离欲、灭尽向，是名为学。”
    “复次真实，舍利弗！”
    舍利弗白佛言：“真实，世尊！世尊，若比丘真实者，厌、离欲、灭尽，不起诸漏，心善解脱。彼从食集生，若真实即是灭尽，觉知此已，比丘于灭生厌、离欲、灭尽，不起诸漏，心善解脱，是数法。”
    佛告舍利弗：“如是如是，如汝所说。比丘于真实生厌、离欲、灭尽，是名法数。”
    如是说已，世尊即起，入室坐禅。
    尔时尊者舍利弗知世尊去已，不久语诸比丘：“诸尊！我不能辩世尊初问，是故我默念住。世尊须臾复为作发喜问，我即开解如此之义。正使世尊一日一夜，乃至七夜，异句、异味问斯义者，我亦悉能乃至七夜，以异句、异味而解说之。”
    时有异比丘往诣佛所，稽首礼足，退住一面，白佛言：“世尊，尊者舍利弗作奇特未曾有说，于大众中，一向狮子吼言：‘我于世尊初问，都不能辩，乃至三问，默然无答。世尊寻复作发喜问，我即开解。正使世尊一日一夜，乃至七夜，异句、异味问斯义者，我亦悉能乃至七夜，异句、异味而解说之。’”
    佛告比丘：“彼舍利弗比丘，实能于我一日一夜，乃至七夜，异句、异味所问义中，悉能乃至七夜，异句、异味而解说之。所以者何？舍利弗比丘善入法界故。”
    佛说此经已，彼比丘闻佛所说，欢喜奉行。

（三四六）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“有三法，世间所不爱、不念、不可意。何等为三？谓老、病、死。世间若无此三法不可爱、不可念、不可意者，如来、应、等正觉不出于世间，世间亦不知有如来、应、等正觉知见，说正法律。以世间有老、病、死三法不可爱、不可念、不可意故，是故如来、应、等正觉出于世间，世间知有如来、应、等正觉所知所见，说正法律。
    “以三法不断故，不堪能离老、病、死。何等为三？谓贪、恚、痴。复有三法不断故，不堪能离贪、恚、痴。何等为三？谓身见、戒取、疑。复有三法不断故，不堪能离身见、戒取、疑。何等为三？谓不正思惟、习近邪道及懈怠心。复有三法不断故，不堪能离不正思惟、习近邪道及懈怠心。何等为三？谓失念、不正知、乱心。复有三法不断故，不堪能离失念、不正知、乱心。何等为三？谓掉、不律仪、不学戒。复有三法不断故，不堪能离掉、不律仪、不学戒。何等为三？谓不信、难教、懈怠。复有三法不断故，不堪能离不信、难教、懒堕。何等为三？谓不欲见圣、不欲闻法、常求人短。复有三法不断故，不堪能离不欲见圣、不欲闻法、常求人短。何等为三？谓不恭敬、戾语、习恶知识。复有三法不断故，不堪能离不恭敬、戾语、习恶知识。何等为三？谓无惭、无愧、放逸，此三法不断故，不堪能离不恭敬、戾语、习恶知识。所以者何？以无惭、无愧故放逸；放逸故不恭敬；不恭敬故习恶知识；习恶知识故，不欲见圣、不欲闻法、常求人短；求人短故，不信、难教、懒堕；懒堕故，掉、不律仪、不学戒；不学戒故，失念、不正知、乱心；乱心故，不正思惟、习近邪道、懈怠心；懈怠心故，身见、戒取、疑；疑故不离贪、恚、痴；不离贪、恚、痴故，不堪能离老、病、死。
    “断三法故，堪能离老、病、死。云何三？谓贪、恚、痴，此三法断已，堪能离老、病、死。复三法断故，堪能离贪、恚、痴。云何三？谓身见、戒取、疑，此三法断故，堪能离贪、恚、痴。复三法断故，堪能离身见、戒取、疑。云何为三？谓不正思惟、习近邪道、起懈怠心，此三法断故，堪能离身见、戒取、疑。复三法断故，堪能离不正思惟、习近邪道及懈怠心。云何为三？谓失念心、不正知、乱心，此三法断故，堪能离不正思惟、习近邪道及心懈怠。复三法断故，堪能离失念心、不正知、乱心。何等为三？谓掉、不律仪、犯戒，此三法断故，堪能离失念心、不正知、乱心。复有三法断故，堪能离掉、不律仪、犯戒。云何三？谓不信、难教、懒堕，此三法断故，堪能离掉、不律仪、犯戒。复有三法断故，堪能离不信、难教、懒堕。云何为三？谓不欲见圣、不乐闻法、好求人短，此三法断故，堪能离不信、难教、懒堕。复三法断故，堪能离不欲见圣、不欲闻法、好求人短。云何为三？谓不恭敬、戾语、习恶知识，此三法断故，离不欲见圣、不欲闻法、好求人短。复有三法断故，堪能离不恭敬、戾语、习恶知识。云何三？谓无惭、无愧、放逸。所以者何？以惭愧故不放逸；不放逸故，恭敬、顺语、为善知识；为善知识故，乐见贤圣、乐闻正法、不求人短；不求人短故，生信、顺语、精进；精进故，不掉、住律仪、学戒；学戒故，不失念、正知、住不乱心；不乱心故，正思惟、习近正道、心不懈怠；心不懈怠故，不著身见、不著戒取、度疑惑；不疑故，不起贪、恚、痴；离贪、恚、痴故，堪能断老、病、死。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三四七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    若王、大臣、婆罗门、长者、居士，及余世人，所共恭敬、尊重、供养佛及诸声闻众，大得利养、衣被、饮食、卧具、汤药。都不恭敬、尊重、供养众邪异道衣被、饮食、卧具、汤药。
    尔时众多异道聚会未曾讲堂，作如是论：“我等昔来常为国王、大臣、长者、居士及余一切之所奉事，恭敬供养衣被、饮食、卧具、汤药，今悉断绝，但恭敬供养沙门瞿昙声闻大众衣被、饮食、卧具、汤药。今此众中，谁有智慧大力，堪能密往诣彼沙门瞿昙众中出家，闻彼法已，来还广说。我等当复用彼闻法，化诸国王、大臣、长者、居士，令其信乐，可得还复供养如前。”
    时有人言：“有一年少，名曰须深，聪明黠慧，堪能密往沙门瞿昙众中出家，听彼法已，来还宣说。”
    时诸外道诣须深所，而作是言：“我今日大众聚集未曾讲堂，作如是论：‘我等先来为诸国王、大臣、长者、居士及诸世人之所恭敬奉事，供养衣被、饮食、卧具、汤药，今悉断绝。国王、大臣、长者、居士，及诸世间，悉共奉事沙门瞿昙声闻大众。我此众中，谁有聪明黠慧，堪能密往沙门瞿昙众中出家学道，闻彼法已，来还宣说，化诸国王、大臣、长者、居士，令我此众还得恭敬、尊重、供养。’其中有言：‘唯有须深聪明黠慧，堪能密往瞿昙法中出家学道，闻彼说法，悉能受持，来还宣说。’是故我等故来相请，仁者当行。”
    时彼须深默然受请，诣王舍城迦兰陀竹园。时众多比丘，出房舍外，露地经行。尔时须深诣众多比丘，而作是言：“诸尊！我今可得于正法中出家受具足，修梵行不？”
    时众多比丘将彼须深，诣世尊所，稽首礼足，退住一面，白佛言：“世尊，今此外道须深，欲求于正法中出家受具足，修梵行。”
    尔时世尊知外道须深心之所念，告诸比丘：“汝等当度彼外道须深，令得出家。”
    时诸比丘愿度须深出家，已经半月。有一比丘语须深言：“须深当知，我等生死已尽，梵行已立，所作已作，自知不受后有。”
    时彼须深语比丘言：“尊者，云何学离欲恶不善法，有觉有观，离生喜乐，具足初禅，不起诸漏，心善解脱耶？”
    比丘答言：“不也，须深。”
    复问：“云何离有觉有观，内净一心，无觉无观，定生喜乐，具足第二禅，不起诸漏，心善解脱耶？”
    比丘答言：“不也，须深。”
    复问：“云何尊者，离喜舍心住，正念正智，身心受乐，圣说及舍，具足第三禅，不起诸漏，心善解脱耶？”
    答言：“不也，须深。”
    复问：“云何尊者，离苦息乐，忧喜先断，不苦不乐，舍净念一心，具足第四禅，不起诸漏，心善解脱耶？”
    答言：“不也，须深。”
    复问：“若复寂静解脱，起色、无色，身作证具足住，不起诸漏，心善解脱耶？”
    答言：“不也，须深。”
    复问：“云何尊者所说不同，前后相违？云何不得禅定而复记说？”
    比丘答言：“我是慧解脱也。”
    作是说已，众多比丘各从座起而去。
    尔时须深知众多比丘去已，作是思惟：“此诸尊者所说不同，前后相违，言不得正受，而复记说自知作证。”作是思惟已，往诣佛所，稽首礼足，退住一面，白佛言：“世尊，彼众多比丘于我面前记说：‘我生已尽，梵行已立，所作已作，自知不受后有。’我即问彼尊者：‘得离欲恶不善法，乃至身作证，不起诸漏，心善解脱耶？’彼答我言：‘不也，须深。’我即问言：‘所说不同，前后相违。言不入正受，而复记说自知作证？’彼答我言：‘得慧解脱。’作此说已，各从座起而去。我今问世尊，云何彼所说不同，前后相违？不得正受，而复说言自知作证？”
    佛告须深：“彼先知法住，后知涅槃。彼诸善男子，独一静处，专精思惟，不放逸住，离于我见，不起诸漏，心善解脱。”
    须深白佛：“我今不知，先知法住，后知涅槃，彼诸善男子独一静处，专精思惟，不放逸法，离于我见，不起诸漏，心善解脱。”
    佛告须深：“不问汝知不知，且自先知法住，后知涅槃。彼诸善男子，独一静处，专精思惟，不放逸住，离于我见，心善解脱。”
    须深白佛：“唯愿世尊为我说法，令我得知法住智，得见法住智。”
    佛告须深：“我今问汝，随意答我。须深，于意云何？有生故有老死，不离生有老死耶？”
    须深答曰：“如是，世尊。有生故有老死，不离生有老死。”
    “如是生、有、取、爱、受、触、六入处、名色、识、行、无明，有无明故有行，不离无明而有行耶？”
    须深白佛：“如是，世尊。有无明故有行，不离无明而有行。”
    佛告须深：“无生故无老死，不离生灭而老死灭耶？”
    须深白佛言：“如是，世尊。无生故无老死，不离生灭而老死灭。”
    “如是乃至无无明故无行，不离无明灭而行灭耶？”
    须深白佛：“如是，世尊。无无明故无行，不离无明灭而行灭。”
    佛告须深：“作如是知、如是见者，为有离欲恶不善法，乃至身作证具足住不？”
    须深白佛：“不也，世尊。”
    佛告须深：“是名先知法住，后知涅槃。彼诸善男子，独一静处，专精思惟，不放逸住，离于我见，不起诸漏，心善解脱。”
    佛说此经已，尊者须深远尘离垢，得法眼净。尔时须深见法、得法、觉法、度疑，不由他信，不由他度，于正法中，心得无畏。稽首佛足，白佛言：“世尊，我今悔过！我于正法中盗密出家，是故悔过！”
    佛告须深：“云何于正法中盗密出家？”
    须深白佛言：“世尊，有众多外道来诣我所，语我言：‘须深当知，我等先为国王、大臣、长者、居士及余世人恭敬供养，而今断绝，悉共供养沙门瞿昙声闻大众。汝今密往沙门瞿昙声闻众中出家受法，得彼法已，还来宣说我等，当以彼闻法教化世间，令彼恭敬供养如初。’是故世尊，我于正法律中盗密出家。今日悔过，唯愿世尊听我悔过，以哀愍故！”
    佛告须深：“受汝悔过。汝当具说：‘我昔愚痴、不善无智，于正法律盗密出家，今日悔过，自见罪，自知罪，于当来世律仪成就，功德增长，终不退减。’所以者何？凡人有罪，自见、自知而悔过者，于当来世律仪成就，功德增长，终不退减。”
    佛告须深：“今当说譬，其智慧者以譬得解。譬如国王有防逻者，捉捕盗贼，缚送王所，白言：‘大王，此人劫盗，愿王处罪。’王言：‘将罪人去，反缚两手，恶声宣令，周遍国中，然后将出城外刑罪人处，遍身四体，劖以百矛。’彼典刑者受王教令，送彼罪人，反缚两手，恶声宣唱，周遍城邑，将出城外刑罪人处，遍身四体，劖以百矛。日中，王问：‘罪人活耶？’臣白言：‘活。’王复敕臣，复劖百矛。至日晡时，复劖百矛，彼犹不死。”
    佛告须深：“彼王治罪，劖以三百矛，彼罪人身宁有完处如手掌不？”
    须深白佛：“不也，世尊。”
    复问须深：“时彼罪人，劖以三百矛因缘，受苦极苦剧不？”
    须深白佛：“极苦，世尊。若劖以一矛，苦痛难堪，况三百矛当可堪忍！”
    佛告须深：“此尚可耳。若于正法律盗密出家，盗受持法，为人宣说，当受苦痛，倍过于彼。”
    佛说是法时，外道须深漏尽意解。
    佛说此经已，尊者须深闻佛所说，欢喜奉行。

（三四八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“如来成就十种力，得四无畏，知先佛住处，能转梵轮，于大众中震狮子吼言：此有故彼有，此起故彼起，谓缘无明行，广说乃至纯大苦聚集，纯大苦聚灭。诸比丘，此是真实教法显现，断生死流，乃至其人悉善显现。如是真实教法显现，断生死流，足令善男子正信出家，方便修习，不放逸住，于正法律精勤苦行，皮筋骨立，血肉枯竭，若其未得所当得者，不舍殷勤精进方便，坚固堪能。所以者何？懈怠苦住，能生种种恶不善法，当来有结炽然，增长于未来世生老病死，退其大义故。精进乐独住者，不生种种恶不善法，当来有结炽然苦报，不于未来世增长生老病死，大义满足，得成第一教法之场。所谓大师面前，亲承说法，寂灭涅槃，菩提正向，善逝正觉。是故比丘，当观自利、利他、自他俱利，精勤修学。我今出家，不愚不惑，有果有乐。诸所供养衣服、饮食、卧具、汤药者，悉得大果、大福、大利。当如是学。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（三四九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“善来比丘！善出家，善得己利，旷世时时得生圣处，诸根具足，不愚不痴，不须手语，好说、恶说堪能解义。我今于此世作佛，如来、应、等正觉、明行足、善逝、世间解、无上士、调御丈夫、天人师、佛、世尊，说法：寂灭、涅槃、菩提正向、善逝、等正觉，所谓此有故彼有，此起故彼起，谓缘无明行，缘行识，乃至纯大苦聚集；无明灭则行灭，乃至纯大苦聚灭。诸比丘，难得之处已得，生于圣处，诸根具足，乃至纯大苦聚集，纯大苦灭。是故比丘，当如是学，自利、利他、自他俱利。如是出家，不愚不痴，有果有乐，有乐果报。供养衣服、饮食、卧具、汤药者，悉得大果、大福、大利。是故比丘，当如是学。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三五○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“多闻圣弟子不作是念：‘何所有故此有？何所起故此起？何所无故此无？何所灭故此灭？’然彼多闻圣弟子，知所谓此有故彼有，此起故彼起，谓缘无明行，乃至纯大苦聚集；无明灭故行灭，乃至纯大苦聚灭。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（三五一）

    如是我闻。一时尊者那罗、尊者茂师罗、尊者殊胜、尊者阿难，住舍卫国象耳池侧。
    尔时尊者那罗语尊者茂师罗言：“有异信、异欲、异闻、异行觉想、异见审谛忍，有如是正自觉知见生，所谓生故有老死，不离生有老死耶？”
    尊者茂师罗言：“有异信、异欲、异闻、异行觉想、异见审谛忍，有如是正自觉知见生，所谓有生故有老死，不异生有老死，如是说有。”
    “尊者茂师罗，有异信，乃至异忍，得自觉知见生，所谓有灭，寂灭、涅槃耶？”
    尊者茂师罗答言：“有异信，乃至异忍，得自觉知见生，所谓有灭，寂灭、涅槃。”
    复问：“尊者茂师罗，有灭则寂灭、涅槃说者，汝今便是阿罗汉，诸漏尽耶？”
    尊者茂师罗默然不答，第二、第三问亦默然不答。
    尔时尊者殊胜语尊者茂师罗：“汝今且止，我当为汝答尊者那罗。”
    尊者茂师罗言：“我今且止，汝为我答。”
    尔时尊者殊胜语尊者那罗：“有异信，乃至异忍，得自觉知见生，所谓有灭则寂灭、涅槃。”
    时尊者那罗问尊者殊胜言：“有异信，乃至异忍，得自觉知见生，所谓有灭则寂灭、涅槃者，汝今便是漏尽阿罗汉耶？”
    尊者殊胜言：“我说有灭则寂灭、涅槃，而非漏尽阿罗汉也。”
    尊者那罗言：“所说不同，前后相违。如尊者所说，有灭则寂灭、涅槃，而复言非漏尽阿罗汉耶？”
    尊者殊胜语尊者那罗言：“今当说譬，夫智者以譬得解。如旷野路边有井，无绳无罐得取其水。时有行人，热渴所逼，绕井求觅，无绳无罐，谛观井水，如实知见，而不触身。如是我说有灭则寂灭、涅槃，而自不得漏尽阿罗汉。”
    尔时尊者阿难语尊者那罗言：“彼尊者殊胜所说，汝复云何？”
    尊者那罗语尊者阿难言：“尊者殊胜，善说真实，知复何言！”
    时彼正士各各说已，从座起去。

（三五二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若诸沙门、婆罗门，于法不如实知，法集、法灭、法灭道迹不如实知，彼非沙门、沙门数，非婆罗门、婆罗门数，彼亦非沙门义、婆罗门义，见法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。云何法不如实知？云何法集不如实知？云何法灭不如实知？云何法灭道迹不如实知？谓于老死法不如实知，老死集、老死灭、老死灭道迹不如实知。如是生、有、取、爱、受、触、六入处不如实知，六入处集、六入处灭、六入处灭道迹不如实知。如是诸法不如实知，法集、法灭、法灭道迹不如实知。
    “若诸沙门、婆罗门，于法如实知，法集、法灭、法灭道迹如实知，当知是沙门、婆罗门，沙门之沙门数，婆罗门之婆罗门数，彼以沙门义、婆罗门义，见法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。何等法如实知？何等法集、法灭、法灭道迹如实知？谓老死法如实知，老死集、老死灭、老死灭道迹如实知。如是生、有、取、爱、受、触、六入处如实知，六入处集、六入处灭、六入处灭道迹如实知。如是诸法如实知，法集、法灭、法灭道迹如实知。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（三五三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若沙门、婆罗门，于法不如实知，法集、法灭、法灭道迹不如实知，当知是沙门、婆罗门，非沙门之沙门数，非婆罗门之婆罗门数，彼亦非沙门义、非婆罗门义，见法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。何等法不如实知？何等法集、法灭、法灭道迹不如实知？谓六入处法不如实知，六入处集、六入处灭、六入处灭道迹不如实知，而于触如实知者，无有是处；触集、触灭、触灭道迹如实知者，无有是处。如是受、爱、取、有、生、老、死如实知者，无有是处。
    “若沙门、婆罗门于六入处如实知，六入处集、六入处灭、六入处灭道迹如实知者，于触如实知，斯有是处。如是受、爱、取、有、生、老、死如实知者，斯有是处。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（三五四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“若诸沙门、婆罗门，于六入处不如实知，而欲超度触者，无有是处；触集、触灭、触灭道迹超度者，无有是处。如是超度受、爱、取、有、生、老、死者，无有是处；超度老死集、老死灭、老死灭道迹者，无有是处。
    “若沙门、婆罗门，于六入处如实知，六入处集、六入处灭、六入处灭道迹如实知，而超度触者，斯有是处。如是超度受、爱、取、有、生、老、死者，斯有是处；乃至超度老死灭道迹者，斯有是处。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。
    如老死乃至六入处三经，如是老死乃至行三经，亦如是说。

（三五五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当觉知老死，觉知老死集、老死灭、老死灭道迹；如是乃至当觉知行、行集、行灭、行灭道迹。云何当觉知老死？觉知缘生故有老死，如是老死觉知。云何老死集？生集是老死集，如是老死集觉知。云何老死灭觉知？谓生灭是老死灭，如是老死灭觉知。云何老死灭道迹觉知？谓八圣道是老死灭道迹，如是老死灭道迹觉知。乃至云何行觉知？谓三行，身行、口行、意行，如是行觉知。云何行集觉知？谓无明集是行集，如是行集觉知。云何行灭觉知？无明灭是行灭，如是行灭觉知。云何行灭道迹觉知？谓八圣道是行灭道迹，如是行灭道迹觉知。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（三五六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四十四种智，谛听善思，当为汝说。何等为四十四种智？谓老死智，老死集智，老死灭智，老死灭道迹智。如是生、有、取、爱、受、触、六入处、名色、识、行智、行集智、行灭智、行灭道迹智，是名四十四种智。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三五七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有七十七种智，谛听善思，当为汝说。云何七十七种智？生缘老死智，非余生缘老死智，过去生缘老死智，非余过去生缘老死智，未来生缘老死智，非余未来生缘老死智，及法住智，无常、有为、心所缘生、尽法、变易法、离欲法、灭法、断知智。如是生、有、取、爱、受、触、六入处、名色、识、行、无明缘行智，非余无明缘行智，过去无明缘行智，非余过去无明缘行智，未来无明缘行智，非余未来无明缘行智，及法住智，无常、有为、心所缘生、尽法、变易法、无欲法、灭法、断智，是名七十七种智。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三五八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有增法、减法，谛听善思，当为汝说。云何增法？所谓此有故彼有，此起故彼起，谓缘无明行，缘行识，乃至纯大苦聚集，是名增法。云何减法？谓此无故彼无，此灭故彼灭，所谓无明灭则行灭，乃至纯大苦聚灭，是名减法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如增法、减法，如是生法、变易法，集法、灭法，如上说。
    如当说三经，有应当知三经，如上说。

（三五九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若思量、若妄想生，彼使，攀缘识住；有攀缘识住故，有未来世生老病死、忧悲恼苦，如是纯大苦聚集。
    “若不思量、不妄想，无使，无攀缘识住；无攀缘识住故，于未来世生老病死、忧悲恼苦灭，如是纯大苦聚灭。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三六○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若思量、若妄想者，则有使，攀缘识住；有攀缘识住故，入于名色；入名色故，有未来世生老病死、忧悲恼苦，如是纯大苦聚集。
    “若不思量、无妄想，无使，无攀缘识住；无攀缘识住故，不入名色；不入名色故，生老病死、忧悲恼苦灭，如是纯大苦聚灭。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三六一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若有思量、有妄想，则有使，攀缘识住；有攀缘识住故，入于名色；入名色故，则有往来；有往来故，则有生死；有生死故，则有未来世生老病死、忧悲恼苦，如是纯大苦聚集。
    “若不思量、无妄想，无使，无攀缘识住；无攀缘识住故，不入名色；不入名色故，则无往来；无往来故，则无生死；无生死故，于未来世生老病死、忧悲恼苦灭，如是纯大苦聚灭。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三六二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有多闻比丘，云何如来施设多闻比丘？”
    诸比丘白佛：“世尊是法根、法眼、法依，唯愿为说多闻比丘。诸比丘闻已，当受奉行。”
    佛告比丘：“谛听善思，当为汝说。诸比丘，若有比丘闻老、病、死，生厌、离欲、灭尽法，是名多闻比丘。如是生、有、取、爱、受、触、六入处、名色、识、行，生厌、离欲、灭尽法，是名多闻比丘。是名如来所施设多闻比丘，”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三六三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“所谓说法比丘，云何说法比丘？云何如来施设说法比丘？”
    诸比丘白佛：“世尊是法根、法眼、法依，唯愿为说说法比丘。诸比丘闻已，当受奉行。”
    佛告诸比丘：“若有比丘说老、病、死，生厌、离欲、灭尽法，是名说法比丘。如是说生、有、取、爱、受、触、六入处、名色、识、行，是生厌、离欲、灭尽法，是名说法比丘。诸比丘，是名如来施设说法比丘。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三六四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“谓法次法向，诸比丘，云何名为法次法向？”
    诸比丘白佛：“世尊是法根、法眼、法依。善哉世尊！唯愿为说，诸比丘闻已，当受奉行。”
    佛告诸比丘：“若比丘于老、病、死，生厌、离欲、灭尽向，是名法次法向。如是生，乃至行，生厌、离欲、灭尽向，是名法次法向。诸比丘，是名如来施设法次法向。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。


杂阿含经卷第十五

（三六五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“谓见法般涅槃，云何如来说见法般涅槃？”
    诸比丘白佛：“世尊是法根、法眼、法依。善哉世尊！唯愿为说见法般涅槃，诸比丘闻已，当受奉行。云何比丘得见法般涅槃？”
    佛告比丘：“谛听善思，当为汝说。若有比丘于老、病、死，厌、离欲、灭尽，不起诸漏，心善解脱，是名比丘得见法般涅槃。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三六六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“毗婆尸佛未成正觉时，独一静处，专精禅思，作如是念：‘一切世间皆入生死，自生自熟，自灭自没，而彼众生于老死之上出世间道不如实知。’即自观察：何缘有此老死？如是正思惟观察，得如实无间等起知：有生故有此老死，缘生故有老死。复正思惟：何缘故有此生？寻复正思惟，无间等起知：缘有故有生。寻复正思惟：何缘故有有？寻复正思惟，如实无间等起知：有取故有有。寻复正思惟：何缘故有取？寻复正思惟，如实无间等起观察：取法味著、顾念，缘触爱所增长。当知缘爱取，缘取有，缘有生，缘生老病死、忧悲恼苦，如是纯大苦聚集。譬如缘油、炷而燃灯，彼时时增油治炷，彼灯常明，炽燃不息。”如前来叹譬、城譬广说。
    佛说是经已，诸比丘闻佛所说，欢喜奉行。
    如毗婆尸佛，如是尸弃佛、毗湿波浮佛、迦罗迦孙提佛、迦那迦牟尼佛、迦叶佛，皆如是说。

（三六七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当勤方便，修习禅思，内寂其心。所以者何？比丘禅思，内寂其心，精勤方便者，如是如实显现。云何如实显现？老死如实显现，老死集、老死灭、老死灭道迹如实显现。生、有、取、爱、受、触、六入处、名色、识、行如实显现，行集、行灭、行灭道迹如实显现。此诸法无常、有为、有漏，如实显现。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三六八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当修无量三摩提，专精系念。修无量三摩提，专精系念已，如是如实显现。云何如实显现？谓老死如实显现，乃至行如实显现。此诸法无常、有为、有漏，如是如实显现。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三六九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“昔者毗婆尸佛未成正觉时，住菩提所，不久成佛，诣菩提树下，敷草为座，结跏趺坐，端坐正念，一坐七日，于十二缘起逆顺观察：所谓此有故彼有，此起故彼起，缘无明行，乃至缘生有老死，及纯大苦聚集，纯大苦聚灭。彼毗婆尸佛正坐七日已，从三昧觉，说此偈言：

“如此诸法生，梵志勤思禅，
永离诸疑惑，知因缘生法。
若知因生苦，知诸受灭尽，
知因缘法尽，则知有漏尽。
如此诸法生，梵志勤思禅，
永离诸疑惑，知有因生苦。
如此诸法生，梵志勤思禅，
永离诸疑惑，知诸受灭尽。
如此诸法生，梵志勤思禅，
永离诸疑惑，知因缘法尽。
如此诸法生，梵志勤思禅，
永离诸疑惑，知尽诸有漏。
如此诸法生，梵志勤思禅，
普照诸世间，如日住虚空，
破坏诸魔军，觉诸结解脱。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如毗婆尸佛，如是尸弃佛、毗湿波浮佛、迦罗迦孙提佛、迦那迦牟尼佛、迦叶佛，亦如是说。

（三七○）

    如是我闻。一时佛住郁毗罗尼连禅河侧大菩提所，不久当成正觉。往诣菩提树下，敷草为座，结跏趺坐，正身正念。如前广说。

（三七一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四食资益众生，令得住世，摄受长养。何等为四？谓一粗抟食、二细触食、三意思食、四识食。
    “此四食何因、何集、何生、何触？谓此诸食爱因、爱集、爱生、爱触。此爱何因、何集、何生、何触？谓爱受因、受集、受生、受触。此受何因、何集、何生、何触？谓受触因、触集、触生、触触。此触何因、何集、何生、何触？谓触六入处因、六入处集、六入处生、六入处触。六入处集是触集，触集是受集，受集是爱集，爱集是食集，食集故未来世生老病死、忧悲恼苦集，如是纯大苦聚集。
    “如是六入处灭则触灭，触灭则受灭，受灭则爱灭，爱灭则食灭，食灭故于未来世生老病死、忧悲恼苦灭，如是纯大苦聚灭。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三七二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四食资益众生，令得住世，摄受长养。何等为四？一粗抟食、二细触食、三意思食、四识食。”
    时有比丘名曰颇求那，住佛后扇佛，白佛言：“世尊，谁食此识？”
    佛告颇求那：“我不言有食识者，我若言有食识者，汝应作是问。我说识是食，汝应问言：‘何因缘故有识食？’我则答言：‘能招未来有，令相续生，有有故有六入处，六入处缘触。’”
    颇求那复问：“为谁触？”
    佛告颇求那：“我不言有触者，我若言有触者，汝应作是问为谁触。汝应如是问：‘何因缘故生触？’我应如是答：‘六入处缘触，触缘受。’”
    复问：“为谁受？”
    佛告颇求那：“我不说有受者，我若言有受者，汝应问为谁受。汝应问言：‘何因缘故有受？’我应如是答：‘触缘故有受，受缘爱。’”
    复问：“世尊，为谁爱？”
    佛告颇求那：“我不说有爱者，我若说言有爱者，汝应作是问为谁爱。汝应问言：‘何因缘故有爱？’我应如是答：‘缘受故有爱，爱缘取。’”
    复问：“世尊，为谁取？”
    佛告颇求那：“我不说言有取者，我若说言有取者，汝应问言为谁取。汝应问言：‘何缘故有取？’我应答言：‘爱缘故有取，取缘有。’”
    复问：“世尊，为谁有？”
    佛告颇求那：“我不说有有者，我若说有有者，汝应问言为谁有。汝今应问：‘何缘故有有？’我应答言：‘缘取故有有，能招当来有触生，是名有。’有六入处，六入处缘触，触缘受，受缘爱，爱缘取，取缘有，有缘生，生缘老病死、忧悲恼苦，如是纯大苦聚集。谓六入处灭则触灭，触灭则受灭，受灭则爱灭，爱灭则取灭，取灭则有灭，有灭则生灭，生灭则老病死、忧悲恼苦灭，如是纯大苦聚集灭。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三七三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四食资益众生，令得住世，摄受长养。云何为四？谓一粗抟食、二细触食、三意思食、四识食。
    “云何比丘观察抟食？譬如有夫妇二人，唯有一子，爱念将养。欲度旷野险道难处，粮食乏尽，饥饿困极，计无济理，作是议言：‘正有一子，极所爱念，若食其肉，可得度难，莫令在此三人俱死。’作是计已，即杀其子，含悲垂泪，强食其肉，得度旷野。云何比丘，彼人夫妇共食子肉，宁取其味，贪嗜美乐以不？”
    答曰：“不也，世尊。”
    复问：“比丘，彼强食其肉，为度旷野险道以不？”
    答言：“如是，世尊。”
    佛告比丘：“凡食抟食，当如是观。如是观者，抟食断知；抟食断知已，于五欲功德贪爱则断；五欲功德贪爱断者，我不见彼多闻圣弟子于五欲功德上有一结使而不断者。有一结系故，则还生此世。
    “云何比丘观察触食？譬如有牛，生剥其皮，在在处处，诸虫唼食，沙土坌尘，草木针刺；若依于地，地虫所食；若依于水，水虫所食；若依空中，飞虫所食；卧起常有苦毒此身。如是比丘，于彼触食，当如是观。如是观者，触食断知；触食断知者，三受则断；三受断者，多闻圣弟子于上无所复作，所作已作故。
    “云何比丘观察意思食？譬如聚落城邑边有火起，无烟无焰。时有士夫聪明黠慧，背苦向乐，厌死乐生，作如是念：‘彼有大火，无烟无焰，行来当避，莫令堕中，必死无疑。’作是思惟，常生思愿，舍远而去。观意思食，亦复如是。如是观者，意思食断；意思食断者，三爱则断；三爱断者，彼多闻圣弟子于上更无所作，所作已作故。
    “诸比丘，云何观察识食？譬如国王有防逻者，捉捕劫盗，缚送王所，如前《须深经》广说，以彼因缘，受三百矛苦，觉昼夜苦痛。观察识食，亦复如是。如是观者，识食断知；识食断知者，名色断知；名色断知者，多闻圣弟子于上更无所作，所作已作故。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三七四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四食资益众生，令得住世，摄受长养。何等为四？一者抟食，二者触食，三意思食，四者识食。
    “若比丘于此四食有喜有贪，则识住增长；识住增长故，入于名色；入名色故，诸行增长；行增长故，当来有增长；当来有增长故，生老病死、忧悲恼苦集，如是纯大苦聚集。
    “若于四食无贪无喜，无贪无喜故，识不住、不增长；识不住、不增长故，不入名色；不入名色故，行不增长；行不增长故，当来有不生不长；当来有不生长故，于未来世生老病死、忧悲恼苦不起，如是纯大苦聚灭。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三七五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四食资益众生，令得住世，摄受长养。何等为四？一者抟食，二者触食，三意思食，四者识食。诸比丘，于此四食有贪有喜，则有忧悲，有尘垢。若于四食无贪无喜，则无忧悲，亦无尘垢。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三七六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四食资益众生，令得住世，摄受长养。何等为四？一者抟食，二者触食，三意思食，四者识食。
    “诸比丘，于此四食有贪有喜，识住增长，乃至纯大苦聚集。譬如楼阁宫殿，北西长广，东西窗牖，日出东方，光照西壁。如是比丘，于此四食有贪有喜，如前广说，乃至纯大苦聚集。
    “若于四食无贪无喜，如前广说，乃至纯大苦聚灭。譬如比丘，楼阁宫殿，北西长广，东西窗牖，日出东方，应照何所？”
    比丘白佛言：“应照西壁。”
    佛告比丘：“若无西壁，应何所照？”
    比丘白佛言：“应照虚空，无所攀缘。”
    “如是比丘，于此四食无贪无喜，识无所住，乃至如是纯大苦聚灭。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三七七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四食资益众生，令得住世，摄受长养。何等为四？一者抟食，二者触食，三意思食，四者识食。诸比丘，于此四食有贪有喜，识住增长，乃至纯大苦聚集。譬如比丘，楼阁宫殿，北西长广，东西窗牖，日出东方，应照何所？”
    比丘白佛言：“应照西壁。”
    佛告比丘：“如是四食有贪有喜，识住增长，乃至如是纯大苦聚集。若于四食无贪无喜，亦无识住增长，乃至如是纯大苦聚灭。譬如比丘，画师、画师弟子，集种种彩色，欲妆画虚空，宁能画不？”
    比丘白佛：“不能，世尊。所以者何？彼虚空者，非色、无对、不可见。”
    “如是比丘，于此四食无贪无喜，亦无识住增长，乃至如是纯大苦聚灭。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三七八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四食资益众生，令得住世，摄受长养。何等为四？一者抟食，二者触食，三意思食，四者识食。诸比丘，于此四食有贪有喜，识住增长，乃至纯大苦聚集。譬如比丘，画师、若画师弟子，集种种彩，欲妆画于色，作种种像。诸比丘，于意云何？彼画师、画师弟子，宁能妆于色不？”
    比丘白佛：“如是，世尊，能妆画色。”
    佛告比丘：“于此四食有贪有喜，识住增长，乃至如是纯大苦聚集。诸比丘，若于四食无贪无喜。无有识住增长，乃至如是纯大苦聚灭。比丘，譬如画师、画师弟子，集种种彩，欲离于色有所妆画，作种种像，宁能画不？”
    比丘白佛：“不能，世尊。”
    “如是比丘，若于四食无贪无喜，无有识住增长，乃至如是纯大苦聚灭。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三七九）

    如是我闻。一时佛住波罗奈国鹿野苑中仙人住处。
    尔时世尊告五比丘：“此苦圣谛，本所未曾闻法，当正思惟，时生眼、智、明、觉。此苦集、此苦灭、此苦灭道迹圣谛，本所未曾闻法，当正思惟，时生眼、智、明、觉。
    “复次苦圣谛，智当复知，本所未闻法，当正思惟，时生眼、智、明、觉。苦集圣谛，已知当断，本所未曾闻法，当正思惟，时生眼、智、明、觉。复次苦集灭，此苦灭圣谛，已知当作证，本所未闻法，当正思惟，时生眼、智、明、觉。复次此苦灭道迹圣谛，已知当修，本所未曾闻法，当正思惟，时生眼、智、明、觉。
    “复次比丘，此苦圣谛，已知知已出，所未闻法，当正思惟，时生眼、智、明、觉。复次此苦集圣谛，已知已断出，所未闻法，当正思惟，时生眼、智、明、觉。复次苦灭圣谛，已知已作证出，所未闻法，当正思惟，时生眼、智、明、觉。复次苦灭道迹圣谛，已知已修出，所未曾闻法，当正思惟，时生眼、智、明、觉。
    “诸比丘，我于此四圣谛三转十二行，不生眼、智、明、觉者，我终不得于诸天、魔、梵、沙门、婆罗门闻法众中，为解脱、为出、为离，亦不自证得阿耨多罗三藐三菩提。我已于四圣谛三转十二行，生眼、智、明、觉，故于诸天、魔、梵、沙门、婆罗门闻法众中，得出、得脱，自证得成阿耨多罗三藐三菩提。”
    尔时世尊说是法时，时尊者憍陈如，及八万诸天，远尘离垢，得法眼净。
    尔时世尊告尊者憍陈如：“知法未？”
    憍陈如白佛：“已知，世尊。”
    复告尊者憍陈如：“知法未？”
    拘邻白佛：“已知，善逝。”
    尊者拘邻已知法故，是故名阿若拘邻。尊者阿若拘邻知法已，地神举声唱言：“诸仁者！世尊于波罗奈国仙人住处鹿野苑中，三转十二行法轮，诸沙门、婆罗门、诸天、魔、梵所未曾转，多所饶益，多所安乐，哀愍世间，以义饶益，利安天人，增益诸天众，减损阿修罗众！”
    地神唱已，闻虚空神天、四天王天、三十三天、焰摩天、兜率陀天、化乐天、他化自在天，展转传唱，须臾之间，闻于梵身天，梵天乘声唱言：“诸仁者！世尊于波罗奈国仙人住处鹿野苑中，三转十二行法轮，诸沙门、婆罗门、诸天、魔、梵及世间闻法未所曾转，多所饶益，多所安乐，以义饶益诸天世人，增益诸天众，减损阿修罗众！”
    世尊于波罗奈国仙人住处鹿野苑中转法轮，是故此经名《转法轮经》。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三八○）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“有四圣谛。何等为四？谓苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三八一）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“有四圣谛。何等为四？谓苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。若比丘于此四圣谛，未无间等者，当修无间等，起增上欲，方便堪能，正念正知，应当觉。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三八二）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“有四圣谛。何等为四？谓苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。若比丘于苦圣谛，当知、当解；于苦集圣谛，当知、当断；于苦灭圣谛，当知、当证；于苦灭道迹圣谛，当知、当修。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三八三）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“有四圣谛。何等为四？谓苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。若比丘于苦圣谛已知、已解，于苦集圣谛已知、已断，于苦灭圣谛已知、已证，于苦灭道迹圣谛已知、已修。如是比丘则断爱欲，转去诸结，于慢无间等，究竟苦边。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三八四）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“有四圣谛。何等为四？谓苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。若比丘于苦圣谛已知、已解，于苦集圣谛已知、已断，于苦灭圣谛已知、已证，于苦灭道迹圣谛已知、已修。如是比丘名阿罗汉，诸漏已尽，所作已作，离诸重担，逮得己利，尽诸有结，正智善解脱。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三八五）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“有四圣谛。何等为四？谓苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。若比丘于苦圣谛已知、已解，于苦集圣谛已知、已断，于苦灭圣谛已知、已证，于苦灭道迹圣谛已知、已修。如是比丘边际究竟、边际离垢、边际梵行已终，纯一清白，名为上士。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三八六）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“有四圣谛。何等为四？谓苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。若比丘于苦圣谛已知、已解，于苦集圣谛已知、已断，于苦灭圣谛已知、已证，于苦灭道迹圣谛已知、已修。如是比丘无有关键，平治城堑，度诸险难，解脱结缚，名为贤圣，建立圣幢。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三八七）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“有四圣谛。何等为四？谓苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。若比丘于苦圣谛已知、已解，于苦集圣谛已知、已断，于苦灭圣谛已知、已证，于苦灭道迹圣谛已知、已修。如是比丘无有关键，平治城堑，度诸险难，名为贤圣，建立圣幢。
    “诸比丘，云何无有关键？谓五下分结已断、已知，是名离关键。云何平治城堑？无明谓之深堑，彼得断知，是名平治城堑。云何度诸险难？谓无际生死，究竟苦边，是名度诸险难。云何解脱结缚？谓爱已断已知。云何建立圣幢？谓我慢已断已知，是名建立圣幢。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三八八）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“有四圣谛。何等为四？谓苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。若比丘于苦圣谛已知、已解，于苦集圣谛已知、已断，于苦灭圣谛已知、已证，于苦灭道迹圣谛已知、已修。是名比丘断五支，成六分，守护于一，依倚于四，舍除诸谛，离四衢，证诸觉想，自身所作，心善解脱，慧善解脱，纯一清白，名为上士。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三八九）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“有四法成就，名曰大医王者，所应王之具、王之分。何等为四？一者善知病，二者善知病源，三者善知病对治，四者善知治病已，当来更不动发。云何名良医善知病？谓良医善知如是如是种种病，是名良医善知病。云何良医善知病源？谓良医善知此病因风起、痰癊起、涎唾起、众冷起、因现事起、时节起，是名良医善知病源。云何良医善知病对治？谓良医善知种种病，应涂药、应吐、应下、应灌鼻、应熏、应取汗，如是比种种对治，是名良医善知对治。云何良医善知治病已，于未来世永不动发？谓良医善治种种病，令究竟除，于未来世永不复起，是名良医善知治病，更不动发。
    “如来、应、等正觉为大医王，成就四德，疗众生病，亦复如是。云何为四？谓如来知此是苦圣谛如实知，此是苦集圣谛如实知，此是苦灭圣谛如实知，此是苦灭道迹圣谛如实知。诸比丘，彼世间良医，于生根本对治不如实知，老病死、忧悲恼苦根本对治不如实知。如来、应、等正觉为大医王，于生根本知对治如实知，于老病死、忧悲恼苦根本对治如实知，是故如来、应、等正觉名大医王。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三九○）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“若诸沙门、婆罗门，于此苦圣谛不如实知，此苦集圣谛不如实知，此苦灭圣谛不如实知，此苦灭道迹圣谛不如实知，此非沙门之沙门，非婆罗门之婆罗门，彼亦不于沙门义、婆罗门义，见法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。
    “若沙门、婆罗门，于此苦圣谛如实知，此苦集圣谛如实知，此苦灭圣谛如实知，此苦灭道迹圣谛如实知，当知是沙门、婆罗门，沙门之沙门、婆罗门之婆罗门，于沙门义、婆罗门义，见法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。
    “是故比丘，于四圣谛无间等，当起增上欲，精勤堪能，方便修学。何等为四？谓苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三九一）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    广说如上，差别者：“于四圣谛不如实知，当知是沙门、婆罗门，非沙门数、非婆罗门数。于四圣谛如实知者，是沙门数、是婆罗门数。”
    乃至佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三九二）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“若沙门、婆罗门于苦圣谛不如实知，苦集圣谛不如实知，苦灭圣谛不如实知，苦灭道迹圣谛不如实知，当知是沙门、婆罗门不得脱苦。若沙门、婆罗门于苦圣谛如实知，于苦集圣谛如实知，于苦灭圣谛如实知，于苦灭道迹圣谛如实知，当知是沙门、婆罗门解脱于苦。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

    如于苦不解脱、解脱，如是舍恶趣不解脱、解脱，堪能舍戒退减、不舍戒退减，能自说得过人法自证、不能自说得过人法作证，能于此外求良福田、不能于此外求良福田，能于此外求大师、不能于此外求大师，不能越苦、堪能越苦，不堪能脱苦、堪能脱苦，如是上诸经重说，悉继以偈：

“若不知苦者，及彼众苦因，
一切诸苦法，寂灭永无余，
若不知道迹，能思一切苦，
心解脱于苦，慧解脱亦然，
不能越众苦，令苦究竟脱。
若如实知苦，亦知众苦因，
及一切诸苦，永灭尽无余，
若复如实知，息苦之道迹，
意解脱具足，慧解脱亦然，
堪能越众苦，究竟得解脱。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三九三）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“若善男子正信非家，出家学道，彼一切所应，当知四圣谛法。何等为四？谓知苦圣谛、知苦集圣谛、知苦灭圣谛、知苦灭道迹圣谛。是故比丘，于四圣谛未无间等者，当勤方便，修无间等。”
    如此章句，一切四圣谛经，应当具说。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如是知，如是见、如是无间等，悉应当说。

    又：“三结尽，得须陀洹，一切当知四圣谛。何等为四？谓知苦圣谛、知苦集圣谛、知苦灭圣谛、知苦灭道迹圣谛。”
    如是当知，如是当见、无间等。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

    “若三结尽，贪、恚、痴薄，得斯陀含，彼一切皆于四圣谛如实知故。何等为四？谓知苦圣谛、知苦集圣谛、知苦灭圣谛、知苦灭道迹圣谛。”
    如是当知，如是当见、如是无间等，亦如是说。

    “五下分结尽，生般涅槃阿那含，不还此世，彼一切知四圣谛。何等为四？知苦圣谛、知苦集圣谛、知苦灭圣谛、知苦灭道迹圣谛。”
    如是知，如是见、如是无间等，亦如是说。

    “若一切漏尽，无漏心解脱、慧解脱，见法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。彼一切悉知四圣谛。何等为四？谓知苦圣谛、知苦集圣谛、知苦灭圣谛、知苦灭道迹圣谛。”
    如是知，如是见、如是无间等，亦如是说。

    “若得辟支佛道证，彼一切知四圣谛故。何等为四？谓知苦圣谛、知苦集圣谛、知苦灭圣谛、知苦灭道迹圣谛。”
    如是知，如是见、如是无间等，亦如是说。

    “若得无上等正觉，彼一切知四圣谛故。何等为四？谓知苦圣谛、知苦集圣谛、知苦灭圣谛、知苦灭道迹圣谛。”
    如是知，如是见、如是无间等，亦如是说。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三九四）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“譬如日出，明相先起。如是正尽苦，亦有前相起，谓知四圣谛。何等为四？知苦圣谛、知苦集圣谛、知苦灭圣谛、知苦灭道迹圣谛。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如是知，如是见、如是无间等，亦如是说。

（三九五）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“若日月不出世间者，一切众星亦不出于世间，昼、夜、半月、一月、时节、岁数、克数、须臾，皆悉不现；世间常冥，无有明照，唯有长夜，纯大暗苦现于世间。若如来、应供、等正觉不出世间时，不说苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛现于世间，世间盲冥，无有明照，如是长夜，纯大暗冥现于世间。
    “若日月出于世间，众星亦现，昼、夜、半月、一月、时节、岁数、克数、须臾，悉现世间，长夜明照，出于世间。如是如来、应、等正觉出于世间，说苦圣谛现于世间，苦集圣谛、苦灭圣谛、苦灭道迹圣谛现于世间，不复暗冥，长夜照明，纯一智慧现于世间。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（三九六）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“譬如日出，周行空中，坏诸暗冥，光明显照。如是圣弟子，所有集法一切灭已，离诸尘垢，得法眼生，与无间等俱，三结断，所谓身见、戒取、疑。此三结尽，名须陀洹，不堕恶趣法，必定正觉趣，七有天人往生，作苦边。彼圣弟子，中间虽起忧苦，听彼圣弟子离欲恶不善法，有觉有观，离生喜乐，初禅具足住；不见彼圣弟子有一法不断，能令还生此世者，此则圣弟子得法眼之大义。是故比丘于此四圣谛未无间等者，当勤方便，起增上欲，精进修学。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（三九七）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“当作是说：我于苦圣谛未无间等，苦集圣谛、苦灭圣谛未无间等，而言我当得苦灭道迹圣谛无间等者，此说不应。所以者何？无是处故。若苦圣谛、苦集圣谛、苦灭圣谛未无间等，而欲苦灭道迹圣谛无间等者，无有是处。譬如有人言我欲取佉提罗叶，合集作器，盛水持行者，无有是处。所以者何？无是处故。如是言我于苦圣谛、苦集圣谛、苦灭圣谛未无间等，而欲得苦灭道迹圣谛无间等者，无有是处。
    “若复有言我当于苦圣谛、苦集圣谛、苦灭圣谛无间等已得，复得苦灭道迹圣谛者，斯则善说。所以者何？有是处故。若苦圣谛、苦集圣谛、苦灭圣谛无间等已，而欲苦灭道迹圣谛无间等者，斯有是处。譬如有言我以纯昙摩叶、摩楼迦叶，合集盛水持行者，此则善说。所以者何？有是处故。如是若言我于苦圣谛、苦集圣谛、苦灭圣谛无间等已，而欲苦灭道迹圣谛无间等者，斯则善说。所以者何？有是处故。若于苦圣谛、苦集圣谛、苦灭圣谛无间等已，而欲苦灭道迹圣谛无间等者，斯有是处故。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（三九八）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“如小绵丸、小劫贝花丸，置四衢道头，四方风吹，则随风去向于一方。如是若沙门、婆罗门，于苦圣谛不如实知，于苦集圣谛、于苦灭圣谛、苦灭道迹圣谛不如实知，当知彼沙门、婆罗门，常观他面，常随他说，以不如实知故，闻彼所说，趣说而受，当知此人不宿修习智慧故。
    “譬如因陀罗柱，铜铁作之，于深入地中，四方猛风不能令动。如是沙门、婆罗门，于苦圣谛如实知，苦集圣谛、苦灭圣谛、苦灭道迹圣谛如实知者，当知是沙门、婆罗门，不视他面，不随他语，是沙门、婆罗门智慧坚固，本随习故，不随他语。是故比丘，于四圣谛当勤方便，起增上欲，精进修学。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（三九九）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“譬如石柱，长十六肘，八肘入地，四方风吹，不能令动。如是沙门、婆罗门，于苦圣谛如实知，于苦集圣谛、苦灭圣谛、苦灭道迹圣谛如实知。斯等沙门、婆罗门，至诸论处，无能屈其心解脱、慧解脱者，能使余沙门、婆罗门反生忧苦。如是如实知、如实见，皆是先世宿习故，使智慧不可倾动。是故比丘，于四圣谛当勤方便，起增上欲，精进修学。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（四○○）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“譬如有人，火烧头衣，当起增上欲，急救令灭。”
    佛告比丘：“莫作是说！当置头衣，于四圣谛起增上欲，勤加方便，修无间等。何等为四？谓苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛未无间等，当勤方便，修无间等。所以者何？比丘，长夜炽然，地狱、畜生、饿鬼，诸比丘不见极苦。如苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛，未无间等者，是比丘当忍苦乐忧悲，于四圣谛勤加精进，方便修习无间等，应当学。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（四○一）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“譬如士夫年寿百岁，有人语言：‘士夫若欲闻法，当日日三时受苦，晨朝时受百枪苦，日中、晡时亦复如是，于一日中受三百枪苦。如是日日，至于百岁，然后闻法，得无间等。汝宁能不？’时彼士夫为闻法故，悉堪能受。所以者何？人生于世，长夜受苦，有时地狱，有时畜生，有时饿鬼，于三恶道空受众苦，亦不闻法。是故我今为无间等故，不以终身受三百枪为大苦也。是故比丘，于四圣谛未得无间等者，当勤方便，起增上欲，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四○二）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“于四圣谛平等正觉，名为如来、应、等正觉。何等为四？所谓苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。于此四圣谛平等正觉，名为如来、应、等正觉。是故诸比丘，于四圣谛未无间者，当勤方便，起增上欲，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四○三）

    如是我闻。一时佛在摩竭国人间游行。于王舍城、波罗利弗，是中间竹林聚落，国王于中造福德舍。尔时世尊与诸大众于中宿止。
    尔时世尊告诸比丘：“我与汝等，于四圣谛无知、无见、无随顺觉、无随顺受者，应当长夜流浪，驱驰生死。何等为四？谓苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。我与汝等，于四圣谛无知、无见、无随顺觉、无随顺受者，应当长夜驱驰生死。
    “以我及汝，于此苦圣谛顺知、顺入，断诸有流，尽诸生死，不受后有。于苦集圣谛、苦灭圣谛、苦灭道迹圣谛顺知、顺入，断诸有流，尽诸生死，不受后有。是故比丘，于四圣谛未无间等者，当勤方便，起增上欲，修无间等。”
    尔时世尊即说偈言：

“我常与汝等，长夜涉生死，
不见圣谛故，大苦日增长。
若见四圣谛，断有大海流，
生死永已除，不复受后有。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四○四）

    如是我闻。一时佛在摩竭国人间游行。王舍城、波罗利弗，是中间竹林聚落，大王于中作福德舍。尔时世尊与诸大众于中止宿。
    尔时世尊告诸比丘：“汝等当行，共至申恕林。”
    尔时世尊与诸大众到申恕林，坐树下。
    尔时世尊手把树叶，告诸比丘：“此手中叶为多耶？大林树叶为多？”
    比丘白佛：“世尊手中树叶甚少，彼大林中树叶无量，百千亿万倍，乃至算数譬类不可为比。”
    “如是诸比丘，我成等正觉，自所见法，为人定说者，如手中树叶。所以者何？彼法义饶益，法饶益，梵行饶益，明慧正觉，向于涅槃。如大林树叶，如我成等正觉，自知正法，所不说者，亦复如是。所以者何？彼法非义饶益，非法饶益，非梵行饶益，明慧正觉，正向涅槃故。是故诸比丘，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四○五）

    如是我闻。一时佛住毗舍离猕猴池侧重阁讲堂。
    尔时尊者阿难晨朝着衣持钵，入毗舍离城乞食。
    时有众多离车童子，晨朝从城内出，至精舍门，持弓箭，竞射精舍门孔，箭箭皆入门孔。
    尊者阿难见已，以为奇特，彼诸离车童子能作如是难事！入城乞食还，举衣钵，洗足已，往诣佛所，稽首佛足，退住一面，白佛言：“世尊，我今晨朝着衣持钵，入毗舍离城乞食。见有众多离车童子从城内出，至精舍门，竞射门孔，箭箭皆入。我作是念：此甚奇特，诸离车童子能为难事。”
    佛告阿难：“于意云何？离车童子竞射门孔，箭箭皆入，此为难耶？破一毛为百分，而射一毛分，箭箭悉中，此为难耶？”
    阿难白佛：“破一毛百分，射一分之毛，箭箭悉中，此则为难。”
    佛告阿难：“未若于苦圣谛生如实知，此则甚难。如是苦集圣谛、苦灭圣谛、苦灭道迹圣谛如实知见，此则甚难。”
    尔时世尊而说偈言：

“一毛为百分，射一分甚难，
观一一苦阴，非我难亦然。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四○六）

    如是我闻。一时佛住猕猴池侧重阁讲堂。
    尔时世尊告诸比丘：“譬如大地悉成大海，有一盲龟，寿无量劫，百年一出其头。海中有浮木，止有一孔，漂流海浪，随风东西。盲龟百年一出其头，当得遇此孔不？”
    阿难白佛：“不能，世尊。所以者何？此盲龟若至海东，浮木随风或至海西。南、北、四维，围绕亦尔，不必相得。”
    佛告阿难：“盲龟、浮木，虽复差违，或复相得。愚痴凡夫漂流五趣，暂复人身，甚难于彼。所以者何？彼诸众生不行其义、不行法、不行善、不行真实，展转杀害，强者凌弱，造无量恶故。是故比丘，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。


杂阿含经卷第十六

杂因诵第三品之四

（四○七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有众多比丘，集于食堂，思惟世间而思惟。
    尔时世尊知诸比丘心之所念，往诣食堂，敷座而坐，告诸比丘：“汝等比丘，慎莫思惟世间思惟。所以者何？世间思惟，非义饶益，非法饶益，非梵行饶益，非智非觉，不顺涅槃。汝等当正思惟，此苦圣谛，此苦集圣谛，此苦灭圣谛，此苦灭道迹圣谛。所以者何？如此思惟则义饶益、法饶益、梵行饶益，正智正觉，正向涅槃。
    “过去世时，有一士夫，出王舍城，于拘絺罗池侧，正坐思惟世间思惟。当思惟时，见四种军，象军、马军、车军、步军，无量无数，皆悉入于一藕孔中。见已作是念：‘我狂失性，世间所无，而今见之。’尔时去池不远，更有大众一处聚集。时彼士夫诣大众所语言：‘诸人！我今发狂，我今失性。世间所无，而我今见。’如上广说。时彼大众皆谓士夫狂发失性，世间所无，而彼见之。”
    佛告比丘：“然彼士夫非狂失性，所见真实。所以者何？尔时去拘絺罗池不远，有诸天、阿修罗，兴四种军，战于空中。时诸天得胜，阿修罗军败，退入彼池一藕孔中。
    “是故比丘，汝等慎莫思惟世间。所以者何？世间思惟，非义饶益，非法饶益，非梵行饶益，非智非觉，非正向涅槃。当思惟四圣谛。何等为四？苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四○八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有众多比丘集于食堂，作如是论：或谓世间有常；或谓世间无常、世间有常无常、世间非有常非无常；世间有边、世间无边、世间有边无边、世间非有边非无边；是命是身、命异身异；如来死后有、如来死后无、如来死后有无、如来死后非有非无。
    尔时世尊一处坐禅，以天耳闻诸比丘集于食堂论议之声，闻已往诣食堂，于大众前敷座而坐，告诸比丘：“汝等比丘众多聚集，何所言说？”
    时诸比丘白佛言：“世尊，我等众多比丘集此食堂，作如是论：或说有常，或说无常。”如上广说。
    佛告比丘：“汝等莫作如是论议！所以者何？如此论者，非义饶益，非法饶益，非梵行饶益，非智，非正觉，非正向涅槃。汝等比丘应如是论议：此苦圣谛，此苦集圣谛，此苦灭圣谛，此苦灭道迹圣谛。所以者何？如是论议，是义饶益、法饶益、梵行饶益、正智、正觉、正向涅槃。是故比丘，于四圣谛未无间等，当勤方便，起增上欲，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四○九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时有众多比丘集于食堂，或有贪觉觉者，或瞋觉觉者，或害觉觉者。
    尔时世尊知诸比丘心之所念，往诣食堂，敷坐具，于众前坐，告诸比丘：“汝等莫起贪觉觉，莫起恚觉觉，莫起害觉觉。所以者何？此诸觉，非义饶益，非法饶益，非梵行饶益，非智，非正觉，不向涅槃。汝等当起苦圣谛觉、苦集圣谛觉、苦灭圣谛觉、苦灭道迹圣谛觉。所以者何？此四圣谛觉，义饶益、法饶益、梵行饶益、正智、正觉、向于涅槃。是故诸比丘，于四圣谛，当勤方便，起增上欲，正智正念，精进修学。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四一○）

    如是我闻。一时，如上广说。
    差别者：起亲里觉、国土人民觉、不死觉。
    乃至闻佛所说，欢喜奉行。

（四一一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有众多比丘集于食堂，作如是论：或论王事、贼事、斗战事、钱财事、衣被事、饮食事、男女事、世间言语事、事业事、诸海中事。
    尔时世尊于禅定中，以天耳闻诸比丘论说之声，即从座起，往诣食堂，敷坐具，于众前坐，告诸比丘：“汝等比丘众多聚集，为何所说？”
    诸比丘白佛言：“世尊，我等于此聚集，或论说王事。”如上广说。
    佛告比丘：“汝等莫作是论，论说王事，乃至不向涅槃。若论说者，应当论说：此苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。所以者何？此四圣谛，以义饶益、法饶益、梵行饶益、正智、正觉、正向涅槃。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四一二）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有众多比丘集于食堂，作如是说：“我知法律，汝等不知。我所说成就，我等所说与理合，汝等所说不成就，不与理合。应前说者，则在后说。应后说者，则在前说。”而共诤论言：“我论是，汝等不如，能答者当答。”
    尔时世尊于禅定中，以天耳闻诸比丘诤论之声，如是广说，乃至于四圣谛无间等者，当勤起方便，起增上欲，学无间等。
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（四一三）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有众多比丘集于食堂，作如是论：“波斯匿王、频婆娑罗王，何者大力？何者大富？”
    尔时世尊于禅定中，以天耳闻诸比丘论说之声，即从座起，往诣食堂，敷坐具，于众前坐，问诸比丘：“汝等何所论说？”
    时诸比丘即以上事具白世尊。
    佛告比丘：“汝等用说诸王大力、大富为？汝等比丘，莫作是论。所以者何？此非义饶益，非法饶益，非梵行饶益，非智，非正觉，不向涅槃。汝等当说：此苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。所以者何？此四圣谛是义饶益、法饶益、梵行饶益、正智、正觉、正向涅槃。是故比丘，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四一四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有众多比丘集于食堂，作如是论：“汝等宿命作何等业？为何工巧？以何自活？”
    尔时世尊于禅定中，以天耳闻诸比丘论说之声，即从座起，往诣食堂，敷坐具，于众前坐，问诸比丘：“汝说何等？”
    时诸比丘以上所说具白世尊。
    佛告比丘：“汝等比丘，莫作是说，宿命所作。所以者何？此非义饶益，非法饶益，非梵行饶益，非智，非正觉，不向涅槃。汝等比丘，当共论说：此苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。所以者何？此义饶益、法饶益、梵行饶益、正智、正觉、正向涅槃。是故比丘，依于四圣谛，未无间等者，当勤方便，起增上欲，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四一五）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有众多比丘集于食堂，作如是论说：“某甲檀越作粗疏食，我等食已，无味无力。我等不如舍彼粗食，而行乞食。所以者何？比丘乞食，时得好食，又见好色，时闻好声，多人所识，亦得衣被、卧具、医药。”
    尔时世尊于禅定中，以天耳闻诸比丘论说之声，即诣食堂。如是广说，乃至正向涅槃。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四一六）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“汝等持我所说四圣谛不？”
    时有异比丘从座起，整衣服，为佛作礼，合掌白佛：“唯然，世尊所说四圣谛，我悉受持。”
    佛告比丘：“汝云何受持四圣谛？”
    比丘白佛言：“世尊说言，此是苦圣谛，我即受持。此苦集圣谛、此苦灭圣谛、此苦灭道迹圣谛，如是世尊说四圣谛，我即受持。”
    佛告比丘：“善哉善哉！我说苦圣谛，汝真实受持。我说苦集圣谛、苦灭圣谛、苦灭道迹圣谛，汝真实受持。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四一七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“汝等持我所说四圣谛不？”
    时有比丘从座起，整衣服，偏袒右肩，为佛作礼，合掌白佛：“唯然，世尊所说四圣谛，我悉受持。”
    佛告比丘：“汝云何持我所说四圣谛？”
    比丘白佛言：“世尊说苦圣谛，我悉受持，如如、不离如、不异如、真实、审谛、不颠倒，是圣所谛，是名苦圣谛。世尊说苦集圣谛、苦灭圣谛、苦灭道迹圣谛，如如、不离如、不异如、真实、审谛、不颠倒，是圣所谛，是为世尊说四圣谛，我悉受持。”
    佛告比丘：“善哉善哉！汝真实持我所说四圣谛，如如、不离如、不异如、真实、审谛、不颠倒，是名比丘真实持我四圣谛。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四一八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“汝持我所说四圣谛不？”
    时有异比丘从座起，整衣服，为佛作礼，合掌白佛言：“唯然，世尊所说四圣谛，我悉持之。云何四谛？世尊说苦圣谛，我悉持之。苦集圣谛、苦灭圣谛、苦灭道迹圣谛，我悉持之。”
    佛告彼比丘：“善哉善哉！如我所说四圣谛，汝悉持之。诸比丘，若沙门、婆罗门作如是说：‘如沙门瞿昙所说苦圣谛，我当舍，更立苦圣谛’者，但有言数，问已不知，增其疑惑，以非其境界故。‘苦集圣谛、苦灭圣谛、苦灭道迹圣谛，我今当舍，更立余四圣谛’者，彼但有言数，问已不知，增其疑惑，以非其境界故。是故比丘，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四一九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“若比丘于佛有疑者，则于苦圣谛有疑，苦集圣谛、苦灭圣谛、苦灭道迹圣谛则有疑惑。若于法、僧有疑者，则于苦圣谛疑惑，苦集圣谛、苦灭圣谛、苦灭道迹圣谛疑惑。
    “若于佛不疑惑者，则于苦圣谛不疑惑，苦集圣谛、苦灭圣谛、苦灭道迹圣谛不疑惑。若于法、僧不疑惑者，则于苦圣谛不疑惑，苦集圣谛、苦灭圣谛、苦灭道迹圣谛不疑惑。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四二○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“若沙门、婆罗门于苦圣谛有疑者，则于佛有疑，于法、僧有疑。若于集、灭、道疑者，则于佛有疑，于法、僧有疑。若于苦圣谛无疑者，则于佛无疑，于法、僧无疑。于集、灭、道圣谛无疑者，则于佛无疑，于法、僧无疑。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四二一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“汝等共行至深险岩。”
    诸比丘白佛：“唯然，世尊。”
    尔时世尊与诸大众至深险岩，敷座而坐，周匝观察深险岩已，告诸比丘：“此岩极大深险。”
    时有异比丘从座起，整衣服，为佛作礼，合掌白佛言：“世尊，此极深险，然复有一极深险，极险于此，甚可怖畏者不？”
    佛知其意。即告言：“如是比丘，此极深险，然复有大深险，险于此者，甚可怖畏。谓诸沙门、婆罗门于苦圣谛不如实知，苦集圣谛、苦灭圣谛、苦灭道迹圣谛不如实知。彼于生本诸行乐著，于老病死、忧悲恼苦生本诸行乐著，而作是行，老病死、忧悲恼苦行转增长故，堕于生，深险之处；堕于老病死、忧悲恼苦，深险之处。如是比丘，此则大深险，险于此者。是故比丘，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四二二）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“有大热地狱，若众生生于彼中，一向与烔燃。”
    时有异比丘从座起，整衣服，为佛作礼，合掌白佛言：“如世尊说，此则大热。世尊，唯此大热，复有大热过于此者，甚可怖畏，无有过上？”
    “如是比丘，此则大热，亦更有大热过于此者，甚可怖畏，无有过上。何等为更有大热，甚可怖畏，过于此者？谓沙门、婆罗门，此苦圣谛不如实知，苦集圣谛、苦灭圣谛、苦灭道迹圣谛不如实知，如是乃至生老病死、忧悲恼苦，大热炽然，是名比丘大热炽然，甚可怖畏，无有过者。是故比丘，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四二三）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“有大暗地狱，彼诸众生生彼中者，不见自身分。”
    时有异比丘从座起，整衣服，为佛作礼，合掌白佛言：“世尊，此则大暗！唯此大暗，复更有余大暗，甚可怖畏，过于此不？”
    佛告比丘：“如是更有大暗，甚可怖畏，过于此者。谓沙门、婆罗门于四圣谛不如实知，乃至堕于生老病死、忧悲恼苦大暗之中。是故比丘，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四二四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“如日游行，照诸世界。乃至千日千月，照千世界、千须弥山、千弗婆提、千阎浮提、千拘耶尼、千郁单越、千四天王、千三十三天、千炎摩天、千兜率天、千化乐天、千他化自在天、千梵天，是名小千世界。此千世界，中间暗冥。日月光照，有大德力，而彼不见。其有众生，生彼中者，不见自身分。”
    时有异比丘从座起，整衣服，为佛作礼，合掌白佛言：“世尊，如世尊说是大暗冥，复更有余大暗冥处，过于此耶？”
    佛告比丘：“有大暗冥过于此者，谓沙门、婆罗门于苦圣谛不如实知，乃至堕于生老病死、忧悲恼苦大暗冥中，是名比丘有大暗冥，过于世界中间暗冥。是故比丘，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说此经已，时诸比丘闻佛所说，欢喜奉行。

（四二五）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“从小千世界，数满至千，是名中千世界。于是中千世界，中间暗冥，如前所说。乃至于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四二六）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“从中千世界，数满至千，是名三千大千世界。世界中间暗冥之处，日月游行，普照世界，而彼不见。乃至堕于生老病死、忧悲恼苦大暗冥中。是故诸比丘，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四二七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“我今当说四圣谛，谛听谛听，善思念之。何等为四？谓苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛，是名四圣谛。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如当说，如是有、如是当知，亦如上说。

（四二八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“当勤禅思，正方便起，内寂其心。所以者何？比丘禅思，内寂其心成就已，如实显现。云何如实显现？谓此苦圣谛如实显现，此苦集圣谛、苦灭圣谛、苦灭道迹圣谛如实显现。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四二九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“当修无量三摩提，专心正念。所以者何？修无量三摩提，专心正念已，如是如实显现。云何如实显现？谓此苦圣谛如实显现，苦集圣谛、苦灭圣谛、苦灭道迹圣谛如实显现。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四三○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时佛告诸比丘：“如人掷杖于虚空中，寻即还堕，或根着地，或腹着地，或头着地。如是沙门、婆罗门于此苦圣谛不如实知，苦集圣谛、苦灭圣谛、苦灭道迹圣谛不如实知，当知是沙门、婆罗门或堕地狱，或堕畜生，或堕饿鬼。是故比丘，于四圣谛未无间等者，当勤方便，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四三一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“如人掷杖置虚空中，其必还堕，或堕净地，或堕不净地。如是沙门、婆罗门于苦圣谛不如实知，于苦集圣谛、苦灭圣谛、苦灭道迹圣谛不如实知，以不如实知故，或生善趣，或生恶趣。是故诸比丘，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四三二）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时佛告诸比丘：“譬如五节相续轮，大力士夫令速旋转。如是沙门、婆罗门于此苦圣谛不如实知，此苦集圣谛、苦灭圣谛、苦灭道迹圣谛不如实知，轮回五趣，而速旋转，或堕地狱，或堕畜生，或堕饿鬼，或人，或天，还堕恶道，长夜轮转。是故比丘，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四三三）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“如来、应、等正觉增上说法，谓四圣谛，开示、施设、建立、分别、散说、显现、表露。何等为四？谓苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。是故比丘，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四三四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“何等为黠慧？为此苦圣谛如实知，此苦集圣谛、苦灭圣谛、苦灭道迹圣谛如实知？为不知耶？”
    诸比丘白佛：“如我解世尊所说，于四圣谛如实知者，此为黠慧。”
    佛告比丘：“善哉善哉！于苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛如实知者，是则黠慧。是故诸比丘，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（四三五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时须达长者往诣佛所，稽首佛足，于一面坐，白佛言：“世尊，此四圣谛为渐次无间等？为一顿无间等？”
    佛告长者：“此四圣谛，渐次无间，非顿无间等。”
    佛告长者：“若有说言，于苦圣谛未无间等，而于彼苦集圣谛、苦灭圣谛、苦灭道迹圣谛无间等者，此说不应。所以者何？若于苦圣谛未无间等，而欲于苦集圣谛、苦灭圣谛、苦灭道迹圣谛无间等者，无有是处。犹如有人，两细树叶连合为器，盛水持行，无有是处。如是于苦圣谛未无间等，而欲于苦集圣谛、苦灭圣谛、苦灭道迹圣谛无间等者，无有是处。
    “譬如有人，取莲花叶，连合为器，盛水游行，斯有是处。如是长者，于苦圣谛无间等已，而欲于苦集圣谛、苦灭圣谛、苦灭道迹圣谛无间等者，斯有是处。是故长者，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四三六）

    如须达长者所问，有异比丘问，亦如是说。唯譬有差别：
    “如有四磴阶道，升于殿堂。若有说言不登初阶，而登第二、第三、第四阶，升堂殿者，无有是处。所以者何？要由初阶，然后次登第二、第三、第四阶，得升殿堂。如是比丘，于苦圣谛未无间等，而欲于苦集圣谛、苦灭圣谛、苦灭道迹圣谛无间等者，无有是处。
    “譬如比丘，若有人言：‘以四阶道升于殿堂，要由初阶，然后次登第二、第三、第四阶，得升殿堂。’应作是说。所以者何？要由初阶，然后次登第二、第三、第四阶，升于殿堂，有是处故。如是比丘，若言于苦圣谛无间等已，然后次第于苦集圣谛、苦灭圣谛、苦灭道迹圣谛无间等者，应作是说。所以者何？若于苦圣谛无间等已，然后次第于苦集圣谛、苦灭圣谛、苦灭道迹圣谛无间等者，有是处故。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四三七）

    如异比丘问，阿难所问亦如是说，唯譬差别。
    佛告阿难：“譬如四蹬梯，升于殿堂。若有说言不由初蹬，而登第二、第三、第四蹬，升殿堂者，无有是处。如是阿难，若于苦圣谛未无间等，而欲苦集圣谛、苦灭圣谛、苦灭道迹圣谛无间等者，此不应说。所以者何？若于苦圣谛未无间等，而于苦集圣谛、苦灭圣谛、苦灭道迹圣谛无间等者，无有是处。
    “譬如阿难，由四蹬梯，升于殿堂。若有人言，要由初蹬，然后次登第二、第三、第四蹬，升殿堂者，此所应说。所以者何？要由初蹬，然后次登第二、第三、第四蹬，升殿堂者，有是处故。如是阿难，于苦圣谛无间等已，然后次第苦集圣谛、苦灭圣谛、苦灭道迹圣谛无间等者，斯有是处。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（四三八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“譬如大地草木，悉取为锵，贯大海中一切水虫，悉能贯不？”
    比丘白佛：“不能，世尊。所以者何？大海诸虫，种种形类，或极细不可贯，或极大不可贯。”
    佛告比丘：“如是如是，众生界无数无量。是故比丘，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（四三九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊手执土石，问诸比丘：“于意云何，此手中土石为多？彼大雪山土石为多？”
    比丘白佛言：“世尊手中土石甚少少耳，雪山土石甚多无量，百千巨亿、算数譬类不可为比。”
    佛告比丘：“其诸众生于苦圣谛如实知者，苦集圣谛、苦灭圣谛、苦灭道迹圣谛如实知者，如我手中所执土石。其诸众生于苦圣谛不如实知，于苦集圣谛、苦灭圣谛、苦灭道迹圣谛不如实知者，如彼雪山土石，其数无量。是故比丘，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（四四○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“譬如湖池，深广五十由旬，其水盈满。若有士夫以发以毛，或以指端，滴彼湖水，乃至再三。云何比丘，如彼士夫所滴水多？湖池水多？”
    比丘白佛：“如彼士夫毛、发、指端，再三滴水，甚少少耳。彼湖大水，其量无数，乃至算数譬类不可为比。”
    佛告比丘：“如大湖水甚多无量，如是多闻圣弟子具足见谛，得圣道果，断诸苦本，如截多罗树头，于未来世成不生法。余不尽者，如彼士夫发、毛、指端所滴之水。是故比丘，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。
    如大湖水譬，如是萨罗多吒迦、恒伽、耶符那、萨罗游、伊罗跋提、摩醯，及四大海，其譬亦如上说。

（四四一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊手捉团土，大如梨果，告诸比丘：“云何比丘，我手中此团土为多？大雪山中土石为多？”
    诸比丘白佛言：“世尊手中团土少少耳，彼雪山王，其土石甚多，百千亿那由他，乃至算数譬类不得为比。”
    佛告诸比丘：“如我所捉团土，如是众生于苦圣谛如实知，于苦集圣谛、苦灭圣谛、苦灭道迹圣谛如实知者，亦复如是。如大雪山王土石者，如是众生于苦圣谛不如实知，于苦集圣谛、苦灭圣谛、苦灭道迹圣谛不如实知者，亦复如是。是故比丘，于四圣谛未无间等者，当勤方便，起增上欲，学无间等。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。
    如雪山王，如是尼民陀罗山、毗那多迦山、马耳山、善见山、佉提罗迦山、伊沙陀罗山、由揵陀罗山、须弥山王，及大地土石，亦复如是。
    如梨果，如是阿摩勒迦果、跋陀罗果、迦罗迦果、豆果，乃至蒜子譬，亦复如是。

（四四二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊以爪甲擎土已，告诸比丘：“于意云何，我爪甲上土为多？此大地土多？”
    诸比丘白佛言：“世尊甲上土甚少少耳，此大地土甚多无量，乃至算数譬类不可为比。”
    佛告比丘：“如甲上土者，若诸众生，形可见者，亦复如是。其形微细，不可见者，如大地土。是故比丘，于四圣谛未无间等者，当勤方便，学无间等。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

    如陆地，如是水性亦尔。
    如甲上土，如是众生人道者，亦复如是。如大地土，如是非人亦尔。
    如甲上土，如是生中国者亦尔。如大地土，如是生边地者亦尔。
    如甲上土，如是成就圣慧眼者亦如是。如大地土，如是不成就圣慧眼者亦尔。
    如甲上土，如是众生知此法律者亦如是。如大地土，如是众生不知法律者亦尔。如知，如是等知、普知、正想、正觉、正解、法无间等亦如是。
    如甲上土，如是众生知有父母亦尔。如大地土，如是众生不知有父母亦尔。
    如甲上土，如是知有沙门、婆罗门家之尊长，作所应作作福，此世他世畏罪行施，受斋持戒亦尔。如大地土，不知有沙门、婆罗门家之尊长，作所应作作福，此世他世畏罪行施，受斋持戒，亦如是说。
    如甲上土，如是众生不杀、不盗、不邪淫、不妄语、不两舌、不恶口、不绮语亦尔。如大地土，如是众生不持诸戒者亦尔。如是离贪、恚、邪见，及不离贪、恚、邪见，亦如是说。
    如甲上土，如是不杀、不盗、不邪淫、不妄语、不饮酒。如大地土，如是不持五戒者亦尔。
    如甲上土，如是众生持八戒者亦如是。如大地土，如是众生不持八戒者亦尔。
    如甲上土，如是众生持十善者亦如是。如大地土，如是众生不持十善者亦如是。
    如甲上土，如是众生从地狱命终，生人中者亦如是。如大地土，如是众生从地狱命终，还生地狱者亦如是。如地狱，如是畜生、饿鬼亦尔。
    如甲上土，如是众生从地狱命终，生天上者亦如是。如大地土，如是众生从地狱命终，还生地狱者亦如是。如地狱，如是畜生、饿鬼亦尔。
    如甲上土，如是众生人道中没，还生人道中者亦如是。如大地土，其诸众生从人道中没，生地狱中者亦如是。如地狱，如是畜生、饿鬼亦尔。
    如甲上土，其诸众生从天命终，还生天上者亦如是。如大地土，其诸众生天上没，生地狱中者亦如是。如地狱，畜生、饿鬼亦如是。

（四四三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我本未闻法时，得正思惟此苦圣谛，正见已生；此苦集圣谛、此苦灭圣谛、苦灭道迹圣谛，正见已生。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如已生，如是今生、当生亦如是。
    如生，如是起、习、近、修、多修、触、作证亦如是。

（四四四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“譬如眼药丸，深广一由旬，若有士夫取此药丸，界界安置，能速令尽，于彼界界不得其边。当知诸界，其数无量。是故比丘，当善界学，善种种界，当如是学。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四四五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生常与界俱，与界和合。云何众生常与界俱？谓众生行不善心时与不善界俱，善心时与善界俱，胜心时与胜界俱，鄙心时与鄙界俱。是故诸比丘，当作是学，善种种界。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（四四六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：广说如上。
    差别者，即说偈言：

“常会故常生，相离生则断。
如人执小木，而入于巨海，
人木则俱没，懈怠俱亦然，
当离于懈怠，卑劣之精进。
贤圣不懈怠，安住于远离，
殷勤精进禅，超度生死流。
胶漆得其素，火得风炽燃，
珂乳则同色，众生与界俱，
相似共和合，增长亦复然。”

（四四七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“众生常与界俱，与界和合。云何与界俱？谓众生不善心时与不善界俱，善心时与善界俱，鄙心时与鄙界俱，胜心时与胜界俱。时尊者憍陈如与众多比丘于近处经行，一切皆是上座多闻大德，出家已久，具修梵行。复有尊者大迦叶与众多比丘于近处经行，一切皆是少欲知足，头陀苦行，不畜遗余。尊者舍利弗与众多比丘于近处经行，一切皆是大智辩才。时尊者大目揵连与众多比丘于近处经行，一切皆是神通大力。时阿那律陀与众多比丘于近处经行，一切皆是天眼明彻。时尊者二十亿耳与众多比丘于近处经行，一切皆是勇猛精进，专勤修行者。时尊者陀骠与众多比丘于近处经行，一切皆是能为大众修供具者。时尊者优波离与众多比丘于近处经行，一切皆是通达律行。时尊者富楼那与众多比丘于近处经行，皆是辩才善说法者。时尊者迦旃延与众多比丘于近处经行，一切皆能分别诸经，善说法相。时尊者阿难与众多比丘于近处经行，一切皆是多闻总持。时尊者罗睺罗与众多比丘于近处经行，一切皆是善持律行。时提婆达多与众多比丘于近处经行，一切皆是习众恶行。是名比丘常与界俱，与界和合。是故诸比丘，当善分别种种诸界。”
    佛说是经时，诸比丘闻佛所说，欢喜奉行。

（四四八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    如上广说已，即说偈言：

“常会故常生，相离生则断。
如人执小木，而入于巨海，
人木则俱没，懈怠俱亦然，
当离于懈怠，卑劣之精进。
贤圣不懈怠，安住于远离，
殷勤精进禅，超度生死流。
胶漆得其素，火得风炽燃，
珂乳则同色，众生与界俱，
相似共和合，增长亦复然。”

（四四九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生常与界俱，与界和合。如是广说，乃至胜心生时与胜界俱，鄙心生时与鄙界俱，杀生时与杀界俱，盗淫、妄语、饮酒心时与饮酒界俱，不杀生时与不杀界俱，不盗、不淫、不妄语、不饮酒与不饮酒界俱。是故诸比丘，当善分别种种界。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（四五○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生常与界俱，与界和合。不信时与不信界俱，犯戒时与犯戒界俱，无惭无愧时与无惭无愧界俱。信心时与信界俱，持戒时与持戒界俱，惭愧心时与惭愧界俱。是故诸比丘，当善分别种种诸界。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。
    如信、不信，如是精进、不精进，失念、不失念，正受、不正受，多闻、少闻，悭者、施者，恶慧、善慧，难养、易养，难满、易满，多欲、少欲，知足、不知足，摄受、不摄受界俱，如上经，如是广说。

（四五一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当说种种诸界，谛听善思，当为汝说。云何为种种界？谓眼界、色界、眼识界，耳界、声界、耳识界，鼻界、香界、鼻识界，舌界、味界、舌识界，身界、触界、身识界，意界、法界、意识界，是名种种界。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（四五二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“缘种种界生种种触，缘种种触生种种受，缘种种受生种种爱。云何种种界？谓十八界，眼界、色界、眼识界，乃至意界、法界、意识界，是名种种界。云何缘种种界生种种触，乃至云何缘种种受生种种爱？谓缘眼界生眼触，缘眼触生眼触生受，缘眼触生受生眼触生爱。耳、鼻、舌、身、意界缘生意触，缘意触生意触生受，缘意触生受生意触生爱。诸比丘，非缘种种爱生种种受，非缘种种受生种种触，非缘种种触生种种界。要缘种种界生种种触，缘种种触生种种受，缘种种受生种种爱。是名比丘缘种种界生种种触，缘种种触生种种受，缘种种受生种种爱。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四五三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“缘种种界生种种触，缘种种触生种种受，缘种种受生种种爱。云何种种界？谓十八界，眼界、色界、眼识界，乃至意界、法界、意识界，是名种种界。云何缘种种界生种种触，缘种种触生种种受，缘种种受生种种爱？谓缘眼界生眼触，非缘眼触生眼界，但缘眼界生眼触。缘眼触生眼受，非缘眼受生眼触，但缘眼触生眼受。缘眼受生眼爱，非缘眼爱生眼受，但缘眼受生眼爱。如是耳、鼻、舌、身、意界缘生意触，非缘意触生意界，但缘意界生意触。缘意触生意受，非缘意受生意触，但缘意触生意受。缘意受生意爱，非缘意爱生意受，但缘意受生意爱。是故比丘，非缘种种爱生种种受，非缘种种受生种种触，非缘种种触生种种界。但缘种种界生种种触，缘种种触生种种受，缘种种受生种种爱。是名比丘当善分别种种界。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（四五四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“缘种种界生种种触，缘种种触生种种受，缘种种受生种种想，缘种种想生种种欲，缘种种欲生种种觉，缘种种觉生种种热，缘种种热生种种求。云何种种界？谓十八界，眼界，乃至法界。云何缘种种界生种种触，乃至缘种种热生种种求？谓缘眼界生眼触，缘眼触生眼受，缘眼受生眼想，缘眼想生眼欲，缘眼欲生眼觉，缘眼觉生眼热，缘眼热生眼求。如是耳、鼻、舌、身、意界缘生意触，缘意触生意受，缘意受生意想，缘意想生意觉，缘意觉生意热，缘意热生意求。是名比丘缘种种界故生种种触，乃至缘种种热生种种求。比丘，非缘种种求生种种热，非缘种种热生种种觉，非缘种种觉生种种想，非缘种种想生种种受，非缘种种受生种种触，非缘种种触生种种界。但缘种种界生种种触，乃至缘种种热生种种求。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。


杂阿含经卷第十七

杂因诵第三品之五

（四五五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“缘界种种故生种种触，缘种种触生种种想，缘种种想生种种欲，缘种种欲生种种觉，缘种种觉生种种热，缘种种热生种种求。云何种种界？谓十八界，眼界乃至法界。云何缘种种界生种种触？云何乃至缘种种热生种种求？谓缘眼界生眼触，非缘眼触生眼界，但缘眼界生眼触。缘眼触生眼想，非缘眼想生眼触，但缘眼触生眼想。缘眼想生眼欲，非缘眼欲生眼想，但缘眼想生眼欲。缘眼欲生眼觉，非缘眼觉生眼欲，但缘眼欲生眼觉。缘眼觉生眼热，非缘眼热生眼觉，但缘眼觉生眼热。缘眼热生眼求，非缘眼求生眼热，但缘眼热生眼求。如是耳、鼻、舌、身、意界缘生意触，乃至缘意热生意求，亦如是广说。是名比丘缘种种界生种种触，乃至缘种种热生种种求；非缘种种求生种种热，乃至非缘种种触生种种界；但缘种种界生种种触，乃至缘种种热生种种求。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。
    如内六入处，外六入处亦如是说。

（四五六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有光界、净界、无量空入处界、无量识入处界、无所有入处界、非想非非想入处界，有灭界。”
    时有异比丘从座起，整衣服，稽首礼足，合掌白佛言：“世尊，彼光界、净界、无量空入处界、无量识入处界、无所有入处界、非想非非想入处界、灭界，如此诸界，何因缘可知？”
    佛告比丘：“彼光界者，缘暗故可知。净界，缘不净故可知。无量空入处界者，缘色故可知。无量识入处界者，缘内空故可知。无所有入处界者，缘所有可知。非想非非想入处界者，缘有第一故可知。灭界者，缘有身可知。”
    诸比丘白佛言：“世尊，彼光界乃至灭界，以何正受而得？”
    佛告比丘：“彼光界、净界、无量空入处界、无量识入处界、无所有入处界，此诸界于自行正受而得。非想非非想入处界，于第一有正受而得。灭界者，于有身灭正受而得。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四五七）

    如是我闻。一时佛住舍卫国东园鹿子母讲堂。
    尔时世尊晡时从禅觉，于讲堂荫中敷座，于大众前坐，说优檀那句，告诸比丘：“缘界故生说，非不界。缘界故生见，非不界。缘界故生想，非不界。缘下界，我说生下说、下见、下想、下思、下欲、下愿、下士夫、下所作、下施设、下建立、下部分、下显示、下受生。如是中、如是胜界，缘胜界，我说彼生胜说、胜见、胜想、胜思、胜愿、胜士夫、胜所作、胜施设、胜建立、胜部分、胜显示、胜受生。”
    时有婆迦利比丘，在佛后执扇扇佛，白佛言：“世尊，若于三藐三佛陀起非三藐三佛陀见，彼见亦缘界而生耶？”
    佛告比丘：“于三藐三佛陀起非三藐三佛陀见，亦缘界而生，非不界。所以者何？凡夫界者，是无明界。如我先说，缘下界生下说、下见，乃至下受生；中、胜界生胜说、胜见，乃至胜受生。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四五八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有因生欲想，非无因。有因生恚想、害想，非无因。
    “云何因生欲想？谓缘欲界也。缘欲界故生欲想、欲欲、欲觉、欲热、欲求。愚痴凡夫起欲求已，此众生起三处邪，谓身、口、心。如是邪因缘故，现法苦住，有苦、有碍、有恼、有热；身坏命终，生恶趣中。是名因缘生欲想。
    “云何因缘生恚想、害想？谓害界也。缘害界生害想、害欲、害觉、害热、害求。愚痴凡夫起害求已，此众生起三处邪，谓身、口、心。起三处邪因缘已，现法苦住，有苦、有碍、有恼、有热；身坏命终，生恶趣中。是名因缘生害想。
    “诸比丘，若诸沙门、婆罗门如是安于生，生危险想，不求舍离、不觉、不吐。彼则现法苦住，有苦、有碍、有恼、有热；身坏命终，生恶趣中。譬如城邑聚落不远有旷野，大火卒起，彼无有力能灭火者，当知彼诸野中众生，悉被火害。如是诸沙门、婆罗门安于生，生危险想，身坏命终，生恶趣中。
    “诸比丘，有因生出要想，非无因。云何有因生出要想？谓出要界。缘出要界生出要想、出要欲、出要觉、出要热、出要求。谓彼慧者出要求时，众生三处生正，谓身、口、心。彼如是生正因缘已，现法乐住，不苦、不碍、不恼、不热；身坏命终，生善趣中。是名因缘生出要想。
    “云何因缘生不恚、不害想？谓不害界也。不害界因缘生不害想、不害欲、不害觉、不害热、不害求。彼慧者不害求时，众生三处正，谓身、口、心。彼正因缘生已，现法乐住，不苦、不碍、不恼、不热；身坏命终，生善趣中。是名因缘生不害想。
    “若诸沙门、婆罗门安于生，生不害想，不舍离、不觉、不吐，现法乐住，不苦、不碍、不恼、不热；身坏命终，生善趣中。譬如城邑聚落边有旷野，大火卒起，有人堪能手足灭火，当知彼诸众生依草木者，悉不被害。如是诸沙门、婆罗门安于生，生正想，不舍、不觉、不吐，现法乐住，不苦、不碍、不恼、不热；身坏命终，生善趣中。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四五九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有婆罗门来诣佛所，与世尊面相慰劳已，于一面住，白佛言：“众生非自作，非他作。”
    佛告婆罗门：“如是论者，我不与相见。汝今自来，而言我非自作，非他作。”
    婆罗门言：“云何瞿昙，众生为自作，为他作耶？”
    佛告婆罗门：“我今问汝，随意答我。婆罗门，于意云何？有众生方便界，令诸众生知作方便耶？”
    婆罗门言：“瞿昙，有众生方便界，令诸众生知作方便也。”
    佛告婆罗门：“若有方便界，令诸众生知有方便者，是则众生自作，是则他作。婆罗门，于意云何？有众生安住界、坚固界、出界、造作界，令彼众生知有造作耶？”
    婆罗门白佛：“有众生安住界、坚固界、出界、造作界，令诸众生知有造作。”
    佛告婆罗门：“若彼安住界、坚固界、出界、造作界，令诸众生知有造作者，是则众生自作，是则他作。”
    婆罗门白佛：“有众生自作，有他作。瞿昙，世间多事，今当请辞。”
    佛告婆罗门：“世间多事，宜知是时。”
    时彼婆罗门闻佛所说，欢喜随喜，从座起去。

（四六○）

    如是我闻。一时佛住拘睒弥国瞿师罗园。
    尔时瞿师罗长者诣尊者阿难所，礼尊者阿难足，退坐一面，白尊者阿难：“所说种种界，云何为种种界？”
    时尊者阿难告瞿师罗长者：“眼界异、色界异喜处，二因缘生识，三事和合生触，又喜触因缘生乐受。如是耳、鼻、舌、身、意、法，亦如是说。
    “复次长者，有异眼界、异色界忧处，二因缘生识，三事和合生苦触，彼苦触因缘生苦受。如是耳、鼻、舌、身、意、法，亦如是说。
    “复次长者，异眼界、异色界舍处，二因缘生识，三事和合生不苦不乐触，不苦不乐触因缘生不苦不乐受。如是耳、鼻、舌、身、意、法，亦如是说。”
    尔时瞿师罗长者闻尊者阿难所说，欢喜随喜，礼足而去。

（四六一）

    如是我闻。一时佛住拘睒弥国瞿师罗园。
    尔时瞿师罗长者诣尊者阿难所，稽首礼足，于一面坐，白尊者阿难：“所说种种界，云何为种种界？”
    尊者阿难告瞿师罗长者：“有三界。云何三？谓欲界、色界、无色界。”
    尔时尊者阿难即说偈言：

“晓了于欲界，色界亦复然，
舍一切有余，得无余寂灭。
于身和合界，永尽无余证，
三耶三佛说，无忧离垢句。”

    尊者阿难说是经已，瞿师罗长者欢喜随喜，作礼而去。

（四六二）

    如是我闻。一时佛住拘睒弥国瞿师罗园。
    尔时瞿师罗长者诣尊者阿难所，稽首礼足，退坐一面，白尊者阿难：“所说种种界，云何名为种种界？”
    尊者阿难告瞿师罗长者：“有三界，色界、无色界、灭界，是名三界。”
    即说偈言：

“若色界众生，及住无色界，
不识灭界者，还复受诸有。
若断于色界，不住无色界，
灭界心解脱，永离于生死。”

    尊者阿难说是经已，瞿师罗长者欢喜随喜，作礼而去。

（四六三）

    如是我闻。一时佛住拘睒弥国瞿师罗园。
    尔时瞿师罗长者诣尊者阿难所，稽首礼足，退坐一面，白尊者阿难：“所说种种界，云何为种种界？”
    尊者阿难答瞿师罗长者：“谓三出界。云何三？谓从欲界出至色界，色界出至无色界，一切诸行一切思想灭界，是名三出界。”
    即说偈言：

“知从欲界出，超逾于色界，
一切行寂灭，勤修正方便。
断除一切爱，一切行灭尽，
知一切有余，不复转还有。”

    尊者阿难说是经已，瞿师罗长者欢喜随喜，作礼而去。

（四六四）

    如是我闻。一时佛住拘睒弥国瞿师罗园。
    尔时尊者阿难往诣上座上座名者所，诣已，恭敬问讯。问讯已，退坐一面，问上座上座名者言：“若比丘于空处、树下、闲房思惟，当以何法专精思惟？”
    上座答言：“尊者阿难，于空处、树下、闲房思惟者，当以二法专精思惟，所谓止、观。”
    尊者阿难复问上座：“修习于止，多修习已，当何所成？修习于观，多修习已，当何所成？”
    上座答言：“尊者阿难，修习于止，终成于观。修习观已，亦成于止。谓圣弟子止、观俱修，得诸解脱界。”
    阿难复问上座：“云何诸解脱界？”
    上座答言：“尊者阿难，若断界、无欲界、灭界，是名诸解脱界。”
    尊者阿难复问上座：“云何断界，乃至灭界？”
    上座答言：“尊者阿难，断一切行，是名断界。断除爱欲，是无欲界。一切行灭，是名灭界。”
    时尊者阿难闻上座所说，欢喜随喜。往诣五百比丘所，恭敬问讯，退坐一面，白五百比丘言：“若比丘于空处、树下、闲房思惟，时当以何法专精思惟？”
    时五百比丘答：“尊者阿难，当以二法专精思惟，乃至灭界。”如上座所说。
    时尊者阿难闻五百比丘所说，欢喜随喜。往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，若比丘空处、树下、闲房思惟，当以何法专精思惟？”
    佛告阿难：“若比丘空处、树下、闲房思惟，当以二法专精思惟，乃至灭界。”如五百比丘所说。
    时尊者阿难白佛言：“奇哉世尊！大师及诸弟子，皆悉同法、同句、同义、同味。我今诣上座名上座者，问如此义，亦以此义、此句、此味答我，如今世尊所说。我复诣五百比丘所，亦以此义、此句、此味而问，彼五百比丘亦以此义、此句、此味答，如今世尊所说。是故当知师及弟子，一切同法、同义、同句、同味。”
    佛告阿难：“汝知彼上座为何如比丘？”
    阿难白佛：“不知，世尊。”
    佛告阿难：“上座者是阿罗汉，诸漏已尽，已舍重担，正智心善解脱。彼五百比丘，亦皆如是。”
    佛说此经已，尊者阿难闻佛所说，欢喜奉行。

（四六五）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者罗睺罗诣世尊所，稽首礼足，退坐一面，白佛言：“世尊，云何知、云何见，我此识身及外境界一切相，得无有我、我所见、我慢系著使？”
    佛告罗睺罗：“谛听善思，当为汝说。罗睺罗，若比丘于所有地界，若过去、若未来、若现在、若内若外、若粗若细、若好若丑、若远若近，彼一切非我、不异我、不相在如实知。水界、火界、风界、空界、识界亦复如是。罗睺罗，比丘如是知、如是见，于我此识身及外境界一切相，无有我、我所见、我慢系著使。罗睺罗，若比丘于此识身及外境界一切相，无有我、我所见、我慢系著使，是名断爱缚、诸结，断诸爱，正慢无间等，究竟苦边。”
    佛说此经已，尊者罗睺罗闻佛所说，欢喜奉行。

（四六六）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者罗睺罗往诣佛所，稽首礼足，退坐一面，白佛言：“世尊，云何知、云何见，我此识身及外境界一切相，得无有我、我所见、我慢系著使？”
    佛告罗睺罗：“有三受，苦受、乐受、不苦不乐受。此三受何因、何集、何生、何转？谓此三受，触因、触集、触生、触转。彼彼触因，彼彼受生，若彼彼触灭，彼彼受亦灭、止、清凉、没。如是知、如是见，我此识及外境界一切相，得无有我、我所见、我慢系著使。”
    佛说此经已，尊者罗睺罗闻佛所说，欢喜奉行。

（四六七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者罗睺罗往诣佛所，稽首礼足，退住一面，白佛言：“世尊，云何知、云何见，我此识身及外境界一切相，得无有我、我所见、我慢系著使？”
    佛告罗睺罗：“有三受，苦受、乐受、不苦不乐受。观于乐受而作苦想，观于苦受作剑刺想，观不苦不乐受作无常想。若彼比丘观于乐受而作苦想，观于苦受作剑刺想，观不苦不乐受作无常、灭想者，是名正见。”
    尔时世尊即说偈言：

“观乐作苦想，苦受同剑刺，
于不苦不乐，修无常灭想，
是则为比丘，正见成就者，
寂灭安乐道，住于最后边，
永离诸烦恼，摧伏众魔军。”

    佛说此经已，尊者罗睺罗闻佛所说，欢喜奉行。

（四六八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者罗睺罗往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，云何知、云何见，我此识身及外境界一切相，得无有我、我所见、我慢系著使？”
    佛告罗睺罗：“有三受，苦受、乐受、不苦不乐受。观于乐受，为断乐受贪使故，于我所修梵行。断苦受瞋恚使故，于我所修梵行。断不苦不乐受痴使故，于我所修梵行。罗睺罗，若比丘乐受贪使已断已知，苦受恚使已断已知，不苦不乐受痴使已断已知者，是名比丘断除爱欲缚，去诸结，慢无间等，究竟苦边。”
    尔时世尊即说偈言：

“乐受所受时，则不知乐受，
贪使之所使，不见出要道。
苦受所受时，则不知苦受，
瞋恚使所使，不见出要道。
不苦不乐受，正觉之所说，
不善观察者，终不度彼岸。
比丘勤精进，正知不动转，
如此一切受，慧者能觉知。
觉知诸受者，现法尽诸漏，
明智者命终，不堕于众数，
众数既已断，永处般涅槃。”

    佛说此经已，尊者罗睺罗闻佛所说，欢喜奉行。

（四六九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“大海深险者，此世间愚夫所说深险，非贤圣法律所说深险。世间所说者，是大水积聚数耳。若从身生诸受，众苦逼迫，或恼或死，是名大海极深险处。愚痴无闻凡夫于此身生诸受，苦痛逼迫，或恼或死，忧悲称怨，啼哭号呼，心乱发狂，长沦没溺，无止息处。多闻圣弟子于身生诸受，苦痛逼迫，或恼或死，不生忧悲、啼哭号呼、心生狂乱，不沦生死，得止息处。”
    尔时世尊即说偈言：

“身生诸苦受，逼迫乃至死，
忧悲不息忍，号呼发狂乱，
心自生障碍，招集众苦增，
永沦生死海，莫知休息处。
能舍身诸受，身所生苦恼，
切迫乃至死，不起忧悲想，
不啼哭号呼，能自忍众苦，
心不生障碍，招集众苦增，
不沦没生死，永得安隐处。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四七○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“愚痴无闻凡夫生苦受、乐受、不苦不乐受。多闻圣弟子亦生苦受、乐受、不苦不乐受。诸比丘，凡夫、圣人有何差别？”
    诸比丘白佛：“世尊是法根、法眼、法依。善哉世尊！唯愿广说，诸比丘闻已，当受奉行。”
    佛告诸比丘：“谛听善思，当为汝说。诸比丘，愚痴无闻凡夫，身触生诸受，增诸苦痛，乃至夺命，愁忧称怨，啼哭号呼，心生狂乱。当于尔时，增长二受，若身受、若心受。譬如士夫，身被双毒箭，极生苦痛。愚痴无闻凡夫亦复如是，增长二受，身受、心受，极生苦痛。所以者何？以彼愚痴无闻凡夫不了知故，于诸五欲生乐受触，受五欲乐，受五欲乐故，为贪使所使。苦受触故，则生瞋恚，生瞋恚故，为恚使所使。于此二受，若集、若灭、若味、若患、若离不如实知，不如实知故，生不苦不乐受，为痴使所使。为乐受所系终不离，苦受所系终不离，不苦不乐受所系终不离。云何系？谓为贪、恚、痴所系，为生老病死、忧悲恼苦所系。
    “多闻圣弟子，身触生苦受，大苦逼迫，乃至夺命，不起忧悲称怨、啼哭号呼、心乱发狂。当于尔时，唯生一受，所谓身受，不生心受。譬如士夫被一毒箭，不被第二毒箭。当于尔时，唯生一受，所谓身受，不生心受。为乐受触，不染欲乐，不染欲乐故，于彼乐受贪使不使。于苦触受不生瞋恚，不生瞋恚故，恚使不使。于彼二使，集、灭、昧、患、离如实知，如实知故，不苦不乐受痴使不使。于彼乐受解脱不系，苦受、不苦不乐受解脱不系。于何不系？谓贪、恚、痴不系，生老病死、忧悲恼苦不系。”
    尔时世尊即说偈言：

“多闻于苦乐，非不受觉知，
彼于凡夫人，其实大有闻。
乐受不放逸，苦触不增忧，
苦乐二俱舍，不顺亦不违。
比丘勤方便，正智不倾动，
于此一切受，黠慧能了知。
了知诸受故，现法尽诸漏，
身死不堕数，永处般涅槃。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四七一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“譬如空中狂风卒起，从四方来，有尘土风、无尘土风、毗湿波风、鞞岚婆风、薄风、厚风，乃至风轮起风。身中受风，亦复如是，种种受起，乐受、苦受、不苦不乐受，乐身受、苦身受、不苦不乐身受，乐心受、苦心受、不苦不乐心受，乐食受、苦食受、不苦不乐食受，乐无食、苦无食、不苦不乐无食受，乐贪受、苦贪受、不苦不乐贪受，乐出要受、苦出要受、不乐不苦出要受。”
    尔时世尊即说偈言：

“譬如虚空中，种种狂风起，
东西南北风，四维亦如是，
有尘及无尘，乃至风轮起。
如是此身中，诸受起亦然，
若乐若苦受，及不苦不乐，
有食与无食，贪著不贪著。
比丘勤方便，正智不倾动，
于此一切受，黠慧能了知。
了知诸受故，现法尽诸漏，
身死不堕数，永处般涅槃。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四七二）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“譬如客舍，种种人住，若刹利、婆罗门、长者、居士、野人、猎师、持戒、犯戒、在家、出家，悉于中住。此身亦复如是，种种受生，苦受、乐受、不苦不乐受，乐身受、苦身受、不苦不乐身受，乐心受、苦心受、不苦不乐心受，乐食受、苦食受、不苦不乐食受，乐无食受、苦无食受、不苦不乐无食受，乐贪著受、苦贪著受、不苦不乐贪著受，乐出要受、苦出要受、不苦不乐出要受。”
    尔时世尊即说偈言：

“譬如客舍中，种种人住止，
刹利婆罗门，长者居士等，
旃陀罗野人，持戒犯戒者，
在家出家人，如是等种种。
此身亦如是，种种诸受生，
若乐若苦受，及不苦不乐，
有食与无食，贪著不贪著。
比丘勤方便，正智不倾动，
于此一切受，黠慧能了知。
了知诸受故，现法尽诸漏，
身死不堕数，永处般涅槃。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四七三）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有异比丘独一静处禅思，念言：“世尊说三受，乐受、苦受、不苦不乐受，又说诸所有受悉皆是苦，此有何义？”
    是比丘作是念已，从禅起，往诣佛所，稽首礼足，退住一面，白佛言：“世尊，我于静处禅思，念言：世尊说三受，乐受、苦受、不苦不乐受，又说诸所有受悉皆是苦，此有何义？”
    佛告比丘：“我以一切行无常故，一切诸行变易法故，说诸所有受悉皆是苦。”
    尔时世尊即说偈言：

“知诸行无常，皆是变易法，
故说受悉苦，正觉之所知。
比丘勤方便，正智不倾动，
于诸一切受，黠慧能了知。
悉知诸受已，现法尽诸漏，
身死不堕数，永处般涅槃。”

    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（四七四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者阿难独一静处禅思，念言：“世尊说三受，乐受、苦受、不苦不乐受，又复说诸所有受悉皆是苦，此有何义？”作是念已，从禅起，诣世尊所，稽首礼足，退住一面，白佛言：“世尊，我独一静处禅思，念言：如世尊说三受，乐受、苦受、不苦不乐受，又说一切诸受悉皆是苦，此有何义？”
    佛告阿难：“我以一切行无常故，一切行变易法故，说诸所有受悉皆是苦。又复阿难，我以诸行渐次寂灭故说，以诸行渐次止息故说，一切诸受悉皆是苦。”
    阿难白佛言：“云何世尊以诸受渐次寂灭故说？”
    佛告阿难：“初禅正受时，言语寂灭。第二禅正受时，觉观寂灭。第三禅正受时，喜心寂灭。第四禅正受时，出入息寂灭。空入处正受时，色想寂灭。识入处正受时，空入处想寂灭。无所有入处正受时，识入处想寂灭。非想非非想入处正受时，无所有入处想寂灭。想受灭正受时，想受寂灭。是名渐次诸行寂灭。”
    阿难白佛言：“世尊，云何渐次诸行止息？”
    佛告阿难：“初禅正受时，言语止息。二禅正受时，觉观止息。三禅正受时，喜心止息。四禅正受时，出入息止息。空入处正受时，色想止息。识入处正受时，空入处想止息。无所有入处正受时，识入处想止息。非想非非想入处正受时，无所有入处想止息。想受灭正受时，想受止息。是名渐次诸行止息。”
    阿难白佛：“世尊，是名渐次诸行止息。”
    佛告阿难：“复有胜止息、奇特止息、上止息、无上止息。如是止息，于余止息无过上者。”
    阿难白佛：“何等为胜止息、奇特止息、上止息、无上止息，诸余止息无过上者？”
    佛告阿难：“于贪欲心不乐、解脱，恚、痴心不乐、解脱，是名胜止息、奇特止息、上止息、无上止息，诸余止息无过上者。”
    佛说此经已，尊者阿难闻佛所说，欢喜奉行。

（四七五）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“毗婆尸如来未成佛时，独一静处，禅思思惟，作如是观：观察诸受，云何为受？云何受集？云何受灭？云何受集道迹？云何受灭道迹？云何受味？云何受患？云何受离？如是观察，有三受，乐受、苦受、不苦不乐受；触集是受集；触灭是受灭；若于受爱乐、赞叹、染著、坚住，是名受集道迹；若于受不爱乐、赞叹、染著、坚住，是名受灭道迹；若受因缘生乐喜，是名受味；若受无常变易法，是名受患；若于受断欲贪、越欲贪，是名受离。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如毗婆尸佛，如是式弃佛、毗湿波浮佛、迦罗迦孙提佛、迦那迦牟尼佛、迦叶佛，及我释迦文佛，未成佛时思惟观察诸受，亦复如是。

（四七六）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时有异比丘独一静处禅思，如是观察诸受：云何受？云何受集？云何受灭？云何受集道迹？云何受灭道迹？云何受味？云何受患？云何受离？
    时彼比丘从禅觉已，诣世尊所，稽首礼足，退住一面，白佛言：“世尊，我独一静处禅思，观察诸受：云何为受？云何受集？云何受灭？云何受集道迹？云何受灭道迹？云何受味？云何受患？云何受离？”
    佛告比丘：“有三受，乐受、苦受、不苦不乐受。触集是受集。触灭是受灭。若于受爱乐、赞叹、染著、坚住，是名受集道迹。若于受不爱乐、赞叹、染著、坚住，是名受灭道迹。若受因缘生乐喜，是名受味。若受无常变易法，是名受患。若于受断欲贪、越欲贪，是名受离。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四七七）

    如异比丘问经，尊者阿难所问经亦如是。

（四七八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“云何为受？云何受集？云何受灭？云何受集道迹？云何受灭道迹？”
    诸比丘白佛言：“世尊是法根、法眼、法依。善哉世尊！唯愿广说，诸比丘闻已，当受奉行。”
    佛告诸比丘：“谛听善思，当为汝说。”
    佛告比丘：“有三受，乐受、苦受、不苦不乐受。触集是受集，触灭是受灭。若于受爱乐、赞叹、染著、坚住，是名受集道迹。若于受不爱乐、赞叹、染著、坚住，是名受灭道迹。若受因缘生乐喜，是名受味。若受无常变易，是名受患。若于受断欲贪、越欲贪，是名受离。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四七九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“若我于诸受不如实知，受集、受灭、受集道迹、受灭道迹、受味、受患、受离不如实知，我于诸天世间、魔、梵、沙门、婆罗门、天人众中，不得解脱、出离、脱诸颠倒，亦非阿耨多罗三藐三菩提。以我于诸受、受集、受灭、受集道迹、受灭道迹、受味、受患、受离如实知故，于诸天世间、魔、梵、沙门、婆罗门、天人众中，为脱、为出、为脱诸颠倒，得阿耨多罗三藐三菩提。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四八○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“若沙门、婆罗门于诸受不如实知，受集、受灭、受集道迹、受灭道迹、受味、受患、受离不如实知者，非沙门、非婆罗门，不同沙门、不同婆罗门，非沙门义、非婆罗门义，非现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。
    “若沙门、婆罗门于诸受如实知，受集、受灭、受集道迹、受灭道迹、受味、受患、受离如实知者，彼是沙门之沙门、婆罗门之婆罗门，同沙门、同婆罗门，沙门义、婆罗门义，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如沙门、非沙门，如是沙门数、非沙门数，亦如是。

（四八一）

    如是我闻。一时佛住壹奢能伽罗国壹奢能伽罗林中。
    尔时世尊告诸比丘：“我欲于此中半月坐禅，诸比丘勿复游行，唯除乞食及布萨。”即便坐禅，不复游行，唯除乞食及布萨。
    尔时世尊半月过已，敷坐具，于众前坐，告诸比丘：“我以初成佛时，所思惟诸禅少许禅分，于今半月思惟，作是念：诸有众生生受，皆有因缘，非无因缘。云何因缘？欲是因缘，觉是因缘，触是因缘。
    “诸比丘，于欲不寂灭、觉不寂灭、触不寂灭，彼因缘故，众生生受；以不寂灭因缘故，众生生受。彼欲寂灭、觉不寂灭、触不寂灭，以彼因缘故，众生生受；以不寂灭因缘故，众生生受。彼欲寂灭、觉寂灭、触不寂灭，以彼因缘故，众生生受；以不寂灭因缘故，众生生受。彼欲寂灭、觉寂灭、触寂灭，以彼因缘故，众生生受；以彼寂灭因缘故，众生生受。邪见因缘故，众生生受；邪见不寂灭因缘故，众生生受。邪志、邪语、邪业、邪命、邪方便、邪念、邪定、邪解脱、邪智因缘故，众生生受；邪智不寂灭因缘故，众生生受。正见因缘故，众生生受；正见寂灭因缘故，众生生受。正志、正语、正业、正命、正方便、正念、正定、正解脱、正智因缘故，众生生受；正智寂灭因缘故，众生生受。若彼欲不得者得、不获者获、不证者证生，以彼因缘故，众生生受；以彼寂灭因缘故，众生生受。是名不寂灭因缘，众生生受；寂灭因缘，众生生受。
    “若沙门、婆罗门如是缘缘、缘缘集、缘缘灭、缘缘集道迹、缘缘灭道迹不如实知者，彼非沙门之沙门、非婆罗门之婆罗门，不同沙门之沙门、不同婆罗门之婆罗门，非沙门义、非婆罗门义，非现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。
    “若沙门、婆罗门于此缘缘、缘缘集、缘缘灭、缘缘集道迹、缘缘灭道迹如实知者，当知是沙门之沙门、婆罗门之婆罗门，同沙门、同婆罗门，以沙门义、婆罗门义，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四八二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    夏安居时，尔时给孤独长者来诣佛所，稽首礼足，却坐一面。佛为说法，示教照喜。说种种法，示教照喜已，从座起，整衣服，为佛作礼，合掌白佛言：“唯愿世尊与诸大众，受我三月请，衣被、饮食、应病汤药。”
    尔时世尊默然而许。
    时给孤独长者知佛默然受请已，从座起去，还归自家。
    过三月已，来诣佛所，稽首礼足，退坐一面。
    佛告给孤独长者：“善哉长者！三月供养衣被、饮食、应病汤药。汝以庄严净治上道，于未来世当获安乐果报。然汝今莫得默然乐受此法，汝当精勤，时时学远离，喜乐具足身作证。”
    时给孤独长者闻佛所说，欢喜随喜，从座起而去。
    尔时尊者舍利弗于众中坐，知给孤独长者去已，白佛言：“奇哉世尊！善为给孤独长者说法，善劝励给孤独长者，言：‘汝已三月具足供养如来、大众，净治上道，于未来世当受乐报。汝莫默然乐著此福，汝当时时学远离，喜乐具足身作证。’世尊，若使圣弟子学远离，喜乐具足身作证，得远离五法，修满五法。云何远离五法？谓断欲所长养喜、断欲所长养忧、断欲所长养舍、断不善所长养喜、断不善所长养忧，是名五法远离。云何修满五法？谓随喜、欢喜、猗息、乐、一心。”
    佛告舍利弗：“如是如是，若圣弟子修学远离，喜乐具足身作证，远离五法，修满五法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四八三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有食念者，有无食念者，有无食无食念者；有食乐者，无食乐者，有无食无食乐者；有食舍者，有无食舍者，有无食无食舍者；有食解脱者，有无食解脱者，有无食无食解脱者。
    “云何食念？谓五欲因缘生念。云何无食念？谓比丘离欲、离恶不善法，有觉有观，离生喜乐，初禅具足住，是名无食念。云何无食无食念？谓比丘有觉有观息，内净一心，无觉无观，定生喜乐，第二禅具足住，是名无食无食念。
    “云何有食乐？谓五欲因缘生乐、生喜，是名有食乐。云何无食乐？谓息有觉有观，内净一心，无觉无观，定生喜乐，是名无食乐。云何无食无食乐？谓比丘离喜贪，舍心住正念正知，安乐住彼圣说舍，是名无食无食乐。
    “云何有食舍？谓五欲因缘生舍，是名有食舍。云何无食舍？谓彼比丘离喜贪，舍心住正念正知，安乐住彼圣说舍，第三禅具足住，是名无食舍。云何无食无食舍？谓比丘离苦息乐，忧喜先已离，不苦不乐，舍净念一心，第四禅具足住，是名无食无食舍。
    “云何有食解脱？谓色俱行。云何无食解脱？谓无色俱行。云何无食无食解脱？谓彼比丘贪欲不染解脱，瞋恚、愚痴心不染解脱，是名无食无食解脱。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四八四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者跋陀罗比丘及尊者阿难，俱住祇树给孤独园。
    尔时尊者阿难往诣尊者跋陀罗所，共相问讯慰劳已，于一面住。时尊者阿难问尊者跋陀罗比丘言：“云何名为见第一？云何闻第一？云何乐第一？云何想第一？云何有第一？”
    尊者跋陀罗语尊者阿难言：“有梵天，自在造作化如意，为世之父。若见彼梵天者，名曰见第一。阿难，有众生离生喜乐，处处润泽，处处敷悦，举身充满，无不满处，所谓离生喜乐。彼从三昧起，举声唱说，遍告大众：‘极寂静者，离生喜乐！极乐者，离生喜乐！’诸有闻彼声者，是名闻第一。复次阿难，有众生于此身离喜之乐润泽，处处润泽，敷悦充满，举身充满，无不满处，所谓离喜之乐，是名乐第一。云何想第一？阿难，有众生度一切识入处无所有，无所有入处具足住，若起彼想者，是名想第一。云何有第一？复次阿难，有众生度一切无所有入处，非想非非想入处具足住，若起彼有者，是名有第一。”
    尊者阿难语尊者跋陀罗比丘言：“多有人作如是见，如是说。汝亦同彼，有何差别？我作方便问汝，汝当谛听，当为汝说：如其所观，次第尽诸漏，是为见第一。如其所问，次第尽诸漏，是名闻第一。如所生乐，次第尽诸漏者，是名乐第一。如其所想，次第尽诸漏者，是名想第一。如实观察，次第尽诸漏，是名有第一。”
    时二正士共论说已，从座起去。

（四八五）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时瓶沙王诣尊者优陀夷所，稽首作礼，退坐一面。时瓶沙王白尊者优陀夷言：“云何世尊所说诸受？”
    优陀夷言：“大王，世尊说三受，乐受、苦受、不苦不乐受。”
    瓶沙王白尊者优陀夷：“莫作是言：‘世尊说三受，乐受、苦受、不苦不乐受。’正应有二受，乐受、苦受。若不苦不乐受，是则寂灭。”如是三说。
    优陀夷不能为王立三受，王亦不能立二受。俱共诣佛所，稽首礼足，退住一面。
    时尊者优陀夷以先所说，广白世尊：“我亦不能立三受，王亦不能立二受。今故共来，具问世尊如是之义，定有几受？”
    佛告优陀夷：“我有时说一受，或时说二受，或说三、四、五、六、十八、三十六，乃至百八受，或时说无量受。云何我说一受？如说所有受皆悉是苦，是名我说一受。云何说二受？说身受、心受，是名二受。云何三受？乐受、苦受、不苦不乐受。云何四受？谓欲界系受、色界系受、无色界系受及不系受。云何说五受？谓乐根、喜根、苦根、忧根、舍根，是名说五受。云何说六受？谓眼触生受，耳、鼻、舌、身、意触生受。云何说十八受？谓随六喜行、随六忧行、随六舍行受，是名说十八受。云何三十六受？依六贪著喜、依六离贪著喜、依六贪著忧、依六离贪著忧、依六贪著舍、依六离贪著舍，是名说三十六受。云何说百八受？谓三十六受，过去三十六、未来三十六、现在三十六，是名说百八受。云何说无量受？如说此受、彼受等，比丘，如是无量名说，是名说无量受。优陀夷，我如是种种说受如实义，世间不解故而共诤论，共相违反，终竟不得我法律中真实之义，以自止息。优陀夷，若于我此所说种种受义，如实解知者，不起诤论、共相违反、起未起诤，能以法律止令休息。
    “然优陀夷，有二受，欲受、离欲受。云何欲受？五欲功德因缘生受，是名欲受。云何离欲受？谓比丘离欲恶不善法，有觉有观，离生喜乐，初禅具足住，是名离欲受。若有说言，若众生依此初禅，唯是为乐非余者，此则不然。所以者何？更有胜乐过于此故。何者是？谓比丘离有觉有观，内净，定生喜乐，第二禅具足住，是名胜乐。如是乃至非想非非想入处，转转胜说，若有说言，唯有此处，乃至非想非非想极乐非余，亦复不然。所以者何？更有胜乐过于此故。何者是？谓比丘度一切非想非非想入处，想受灭身作证具足住，是名胜乐过于彼者。若有异学出家作是说言：‘沙门释种子，唯说想受灭，名为至乐。’此所不应。所以者何？应当语言：‘此非世尊所说受乐数。’世尊说受乐数者，如说优陀夷，有四种乐。何等为四？谓离欲乐、远离乐、寂灭乐、菩提乐。”
    佛说此经已，尊者优陀夷及瓶沙王闻佛所说，欢喜奉行。

（四八六）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“若于一法生正厌离、不乐、背舍，得尽诸漏，所谓一切众生由食而存。复有二法，名及色。复有三法，谓三受。复有四法，谓四食。复有五法，谓五受阴。复有六法，谓六内外入处。复有七法，谓七识住。复有八法，谓世八法。复有九法，谓九众生居。复有十法，谓十业迹。于此十法，生厌、不乐、背舍，得尽诸漏。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四八七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“若于一法生正厌离、不乐、背舍，究竟苦边，解脱于苦，谓一切众生由食而存。复有二法，名及色。复有三法，谓三受。复有四法，谓四食。复有五法，谓五受阴。复有六法，谓六内外入处。复有七法，谓七识住。复有八法，谓世八法。复有九法，谓九众生居。复有十法，谓十业迹。于此十法，生正厌离、不乐、背舍，究竟苦边，解脱于苦。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四八八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“若于一法，观察无常、观察变易、观察离欲、观察灭、观察舍离，得尽诸漏，谓一切众生由食而存。复有二法，名及色。复有三法，谓三受。复有四法，谓四食。复有五法，谓五受阴。复有六法，谓六内外入处。复有七法，谓七识住。复有八法，谓世八法。复有九法，谓九众生居。复有十法，谓十业迹。于此十法，正观无常、观察变易、观察离欲、观察灭、观察舍离，得尽诸漏。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（四八九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“若于一法，观察无常、观察变易、观察离欲、观察灭、观察舍离，究竟苦边，解脱于苦，谓一切众生由食存。复有二法，名及色。复有三法，谓三受。复有四法，谓四食。复有五法，谓五受阴。复有六法，谓六内外入处。复有七法，谓七识住。复有八法，谓世八法。复有九法，谓九众生居。复有十法，谓十业迹。于此十业迹，观察无常、观察变易、观察离欲、观察灭、观察舍离，究竟苦边，解脱于苦。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。


杂阿含经卷第十八

弟子所说诵第四品

（四九○）

    如是我闻。一时佛住摩竭提国那罗聚落。
    尔时尊者舍利弗亦在摩竭提国那罗聚落。
    时有外道出家名阎浮车，是舍利弗旧善知识，来诣舍利弗，问讯共相慰劳已，退坐一面，问舍利弗言：“贤圣法律中，有何难事？”
    舍利弗告阎浮车：“唯出家难。”
    “云何出家难？”
    答言：“爱乐者难。”
    “云何爱乐难？”
    答言：“乐常修善法难。”
    复问舍利弗：“有道有向，修习多修习，常修善法增长耶？”
    答言：“有，谓八正道，谓正见、正志、正语、正业、正命、正方便、正念、正定。”
    阎浮车言：“舍利弗，此则善道，此则善向，修习多修习，于诸善法常修习增长。舍利弗，出家常修习此道，不久疾得尽诸有漏。”
    时二正士共论议已，各从座起而去。
    如是比，阎浮车所问序，四十经。

    阎浮车问舍利弗：“云何名善说法者？为世间正向？云何名为世间善逝？”
    舍利弗言：“若说法调伏欲贪，调伏瞋恚，调伏愚痴，是名世间说法者。若向调伏欲贪，向调伏瞋恚，向调伏愚痴，是名正向。若贪欲已尽，无余断知；瞋恚、愚痴已尽，无余断知，是名善逝。”
    复问舍利弗：“有道有向，修习多修习，能起善断？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“谓涅槃者，云何为涅槃？”
    舍利弗言：“涅槃者，贪欲永尽，瞋恚永尽，愚痴永尽，一切诸烦恼永尽，是名涅槃。”
    复问舍利弗：“有道有向，修习多修习，得涅槃耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“何故于沙门瞿昙所出家修梵行？”
    舍利弗言：“为断贪欲故，断瞋恚故，断愚痴故，于沙门瞿昙所出家修梵行。”
    复问舍利弗：“有道有向，修习多修习，得断贪欲、瞋恚、愚痴耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“谓有漏尽，云何名为有漏尽？”
    舍利弗言：“有漏者，三有漏，谓欲有漏、有有漏、无明有漏。此三有漏欲尽无余，名有漏尽。”
    复问舍利弗：“有道有向，修习多修习，得漏尽耶？”
    舍利弗答言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“所谓阿罗汉者，云何名阿罗汉？”
    舍利弗言：“贪欲已断无余，瞋恚、愚痴已断无余，是名阿罗汉。”
    复问舍利弗：“有道有向，修习多修习，得阿罗汉耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“所谓阿罗汉者，云何名阿罗汉者？”
    舍利弗言：“贪欲永尽无余，瞋恚、愚痴永尽无余，是名阿罗汉者。”
    复问：“有道有向，修习多修习，得阿罗汉者耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“所谓无明者，云何为无明？”
    舍利弗言：“所谓无明者，于前际无知，后际无知，前、后、中际无知，佛、法、僧宝无知，苦、集、灭、道无知，善、不善、无记无知，内无知、外无知，若于彼彼事无知暗障，是名无明。”
    阎浮车语舍利弗：“此是大暗积聚。”
    复问舍利弗：“有道有向，修习多修习，断无明耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车复问尊者舍利弗：“所谓有漏，云何有漏？”
    如前说。

    阎浮车问舍利弗：“所谓有，云何为有？”
    舍利弗言：“有谓三有，欲有、色有、无色有。”
    复问舍利弗：“有道有向，修习多修习，断此有耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“所谓有身，云何有身？”
    舍利弗言：“有身者，五受阴。云何五受阴？谓色受阴，受、想、行、识受阴。”
    复问舍利弗：“有道有向，断此有身耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“所谓苦者，云何为苦？”
    舍利弗言：“苦者，谓生苦、老苦、病苦、死苦、恩爱别离苦、怨憎会苦、所求不得苦、略说五受阴苦，是名为苦。”
    复问舍利弗：“有道有向，断此苦耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“所谓流者，云何为流？”
    舍利弗言：“流者，谓欲流、有流、见流、无明流。”
    复问舍利弗：“有道有向，修习多修习，断此流耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“所谓轭者，云何为轭？”
    轭如流说。

    阎浮车问舍利弗：“所谓取者，云何为取？”
    舍利弗言：“取者，四取，谓欲取、我取、见取、戒取。”
    复问舍利弗：“有道有向，修习多修习，断此取耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“所谓缚者，云何为缚？”
    舍利弗言：“缚者，四缚，谓贪欲缚、瞋恚缚、戒取缚、我见缚。”
    复问舍利弗：“有道有向，修习多修习，断此缚耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“所谓结者，云何为结？”
    舍利弗言：“结者，九结，谓爱结、恚结、慢结、无明结、见结、他取结、疑结、嫉结、悭结。”
    复问舍利弗：“有道有向，修习多修习，断此结耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“所谓使者，云何为使？”
    舍利弗言：“使者，七使，谓贪欲使、瞋恚使、有爱使、慢使、无明使、见使、疑使。”
    复问舍利弗：“有道有向，修习多修习，断此使耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“所谓欲者，云何为欲？”
    舍利弗言：“欲者，谓眼所识色，可爱、乐、念，染著色；耳声、鼻香、舌味、身所识触，可爱、乐、念，染著触。阎浮车，此功德非欲，但觉想思惟者是。”
    时舍利弗即说偈言：

“非彼爱欲使，世间种种色，
唯有觉想者，是则士夫欲。
彼诸种种色，常在于世间，
调伏爱欲心，是则黠慧者。”

    复问舍利弗：“有道有向，修习多修习，断此欲耶？”
    舍利弗答言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗言：“所谓盖者，云何为盖？”
    舍利弗言：“盖者有五盖，谓贪欲盖、瞋恚盖、睡眠盖、掉悔盖、疑盖。”
    复问舍利弗：“有道有向，修习多修习，断此五盖耶？”
    舍利弗答言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“谓苏息者，云何为苏息？”
    舍利弗言：“苏息者，谓断三结。”
    复问舍利弗：“有道有向，修习多修习，断三结耶？”
    舍利弗答言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“谓得苏息者，云何为得苏息者？”
    舍利弗言：“得苏息者，谓三结已尽、已知。”
    复问：“有道有向，断此结耶？”
    舍利弗答言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“谓得上苏息，云何为得上苏息？”
    舍利弗言：“得上苏息者，谓贪欲永尽，瞋恚、愚痴永尽，是名得上苏息。”
    复问舍利弗：“有道有向，修习多修习，得上苏息耶？”
    舍利弗答言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“谓得上苏息处，云何为得上苏息处？”
    舍利弗言：“得上苏息处者，谓贪欲已断已知，永尽无余；瞋恚、愚痴已断已知，永尽无余，是为得上苏息处。”
    复问舍利弗：“有道有向，修习多修习，得上苏息处耶？”
    舍利弗答言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“所谓清凉，云何为清凉？”
    舍利弗言：“清凉者，五下分结尽，谓身见、戒取、疑、贪欲、瞋恚。”
    复问：“有道有向，修习多修习，断此五下分结，得清凉耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“谓得清凉，云何为得清凉？”
    舍利弗言：“五下分已尽、已知，是名得清凉。”
    复问舍利弗：“有道有向，修习多修习，得清凉耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“所谓上清凉者，云何为上清凉？”
    舍利弗言：“上清凉者，谓贪欲永尽无余，瞋恚、愚痴永尽无余，一切烦恼永尽无余，是名上清凉。”
    复问：“有道有向，得此上清凉耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“所谓得上清凉，云何名得上清凉？”
    舍利弗言：“得上清凉者，谓贪欲永尽无余，已断已知；瞋恚、愚痴永尽无余，已断已知，是名得上清凉。”
    复问舍利弗：“有道有向，得此上清凉耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“所谓爱，云何为爱？”
    舍利弗言：“有三爱，谓欲爱、色爱、无色爱。”
    复问：“有道有向，断此三爱耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“谓业迹，云何为业迹？”
    舍利弗言：“业迹者，十不善业迹，谓杀生、偷盗、邪淫、妄语、两舌、恶口、绮语、贪欲、瞋恚、邪见。”
    复问舍利弗：“有道有向，断此十业迹耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。

    阎浮车问舍利弗：“所谓秽者，云何为秽？”
    舍利弗言：“秽者，谓三秽，贪欲秽、瞋恚秽、愚痴秽。”
    复问舍利弗：“有道有向，断此三秽耶？”
    舍利弗言：“有，谓八正道，正见乃至正定。”
    时二正士共论议已，各从座起而去。
    如秽，如是垢、腻、刺、恋、缚亦尔。

（四九一）

    如阎浮车所问经，沙门出家所问亦如是。

（四九二）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者舍利弗亦在彼住。
    时尊者舍利弗语诸比丘：“若有比丘得无量三昧，身作证具足住，于有身灭涅槃心不乐著，顾念有身。譬如士夫，胶着于手，以执树枝，手即着树，不能得离。所以者何？胶着手故。比丘无量三摩提身作证，心不乐著有身灭涅槃，顾念有身，终不得离，不得现法随顺法教，乃至命终亦无所得，还复来生此界，终不能得破于痴冥。譬如聚落傍有泥池，泥极深溺，久旱不雨，池水干消，其地破裂。如是比丘不得现法随顺法教，乃至命终亦无所得，来生当复还堕此界。
    “若有比丘得无量三昧，身作证具足住，于有身灭涅槃，心生信乐，不念有身。譬如士夫以干净手执持树枝，手不着树。所以者何？以手净故。如是比丘得无量三昧，身作证具足住，于有身灭涅槃，心生信乐，不念有身，现法随顺法教，乃至命终不复来还生于此界。是故比丘，当勤方便，破坏无明。譬如聚落傍有泥池，四方流水及数天雨，水常入池，其水盈溢，秽恶流出，其池清净。如是皆得现法随顺法教，乃至命终不复还生此界。是故比丘，当勤方便，破坏无明。”
    尊者舍利弗说此经已，诸比丘闻其所说，欢喜奉行。

（四九三）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时尊者舍利弗告诸比丘：“若阿练若比丘，或于空地、林中、树下，当作是学，内自观察思惟，心中自觉有欲想不？若不觉者，当于境界，或于净相，若爱欲起，违于远离。譬如士夫用力乘船，逆流而上，身小疲怠，船则倒还，顺流而下。如是比丘思惟净想，还生爱欲，违于远离。是比丘学时，修下方便，不得淳净，是故还为爱欲所漂，不得法力，心不寂静，不一其心。于彼净相，随生爱欲，流注浚输，违于远离。当知是比丘不敢自记于五欲功德离欲解脱。
    “若比丘或于空地、林中、树下，作是思惟，我内心中为离欲不？是比丘当于境界，或取净相，若觉其心于彼远离，顺趣浚注。譬如鸟翮，入火则卷，不可舒展。如是比丘或取净相，即顺远离，流注浚输。比丘当如是知，于方便行，心不懈怠，得法寂静，寂止息乐，淳净一心，谓我思惟已，于净相顺于远离，随顺修道，则能堪任自记，于五欲功德离欲解脱。”
    尊者舍利弗说是经已，诸比丘闻其所说，欢喜奉行。

（四九四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尊者舍利弗在耆阇崛山中。
    尔时尊者舍利弗晨朝着衣持钵，出耆阇崛山，入王舍城乞食。于路边见一大枯树，即于树下敷坐具，敛身正坐，语诸比丘：“若有比丘修习禅思，得神通力，心得自在，欲令此枯树成地，即时为地。所以者何？谓此枯树中有地界，是故比丘得神通力，心作地解，即成地不异。若有比丘得神通力，自在如意，欲令此树为水、火、风、金、银等物，悉皆成就不异。所以者何？谓此枯树有水界故。是故比丘禅思，得神通力，自在如意，欲令枯树成金，即时成金不异；及余种种诸物，悉成不异。所以者何？以彼枯树有种种界故。是故比丘禅思，得神通力，自在如意，为种种物，悉成不异。比丘当知，比丘禅思神通境界不可思议。是故比丘，当勤禅思，学诸神通。”
    舍利弗说是经已，诸比丘闻其所说，欢喜奉行。

（四九五）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时尊者舍利弗在耆阇崛山中。
    尔时尊者舍利弗告诸比丘：“其犯戒者，以破戒故，所依退减，心不乐住；不乐住已，失喜、息、乐、寂静三昧、如实知见、厌离、离欲、解脱已，永不能得无余涅槃。如树根坏，枝、叶、花、果悉不成就。犯戒比丘亦复如是，功德退减，心不乐住；不信乐已，失喜、息、乐、寂静三昧、如实知见、厌离、离欲、解脱；失解脱已，永不能得无余涅槃。
    “持戒比丘根本具足，所依具足，心得信乐；得信乐已，心得欢喜、息、乐、寂静三昧，如实知见，厌离、离欲、解脱；得解脱已，悉能疾得无余涅槃。譬如树根不坏，枝、叶、花、果悉得成就。持戒比丘亦复如是，根本具足，所依成就，心得信乐；得信乐已，欢喜、息、乐、寂静三昧，如实知见，厌离、离欲、解脱，疾得无余涅槃。”
    尊者舍利弗说是经已，诸比丘闻其所说，欢喜奉行。

（四九六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时舍利弗告诸比丘：“若诸比丘诤起相言，有犯罪比丘、举罪比丘。彼若不依正思惟自省察者，当知彼比丘长夜强梁，诤讼转增，共相违反，结恨弥深。于所起之罪，不能以正法律止令休息。若比丘有此已起诤讼，若犯罪比丘，若举罪比丘，俱依正思惟，自省察克责，当知彼比丘不长夜强梁、共相违反、结恨转增，于所起之罪，能以法律止令休息。
    “云何比丘正思惟自省察？比丘应如是思惟：我不是、不类，不应作罪，令彼见我。若我不为此罪，彼则不见。以彼见我罪，不喜嫌责，故举之耳。余比丘闻者，亦当嫌责。是故长夜诤讼，强梁转增，诤讼相言，于所起之罪，不能以正法律止令休息。我今自知，如己输税。是名比丘于所起罪，能自观察。
    “云何举罪比丘能自省察？举罪比丘应如是念：彼长老比丘作不类罪，令我见之。若彼不作此不类罪者，我则不见。我见其罪，不喜故举。余比丘见，亦当不喜故举之。长夜诤讼，转增不息，不能以正法律止所起罪，令其休息。我从今日，当自去之，如己输税。如是举罪比丘善能依正思惟，内自观察。
    “是故诸比丘，有罪及举罪者，当依正思惟，而自观察，不令长夜强梁增长，诸比丘得不诤讼，所起之诤能以法律止令休息。”
    尊者舍利弗说是经已，诸比丘闻已，欢喜奉行。

（四九七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者舍利弗诣佛所，稽首佛足，退坐一面，白佛言：“世尊，若举罪比丘欲举他罪者，令心安住几法，得举他罪？”
    佛告舍利弗：“若比丘令心安住五法，得举他罪。云何为五？实非不实、时不非时、义饶益非非义饶益、柔软不粗涩、慈心不瞋恚。舍利弗，举罪比丘具此五法，得举他罪。”
    舍利弗白佛言：“世尊，被举比丘复以几法自安其心？”
    佛告舍利弗：“被举比丘当以五法令安其心。念言：彼何处得？为实莫令不实，令时莫令非时，令是义饶益莫令非义饶益，柔软莫令粗涩，慈心莫令瞋恚。舍利弗，被举比丘当具此五法，自安其心。”
    舍利弗白佛言：“世尊，我见举他罪者，不实非实、非时非是时、非义饶益非为义饶益、粗涩不柔软、瞋恚非慈心。世尊，于不实举他罪比丘，当以几法饶益，令其改悔？”
    佛告舍利弗：“不实举罪比丘，当以五法饶益，令其改悔。当语之言：‘长老！汝今举罪，不实非是实，当改悔。不时非是时，非义饶益非是义饶益，粗涩非柔软，瞋恚非慈心，汝当改悔。’舍利弗，不实举他罪比丘，当以此五法饶益，令其改悔，亦令当来世比丘不为不实举他罪。”
    舍利弗白佛言：“世尊，被不实举罪比丘，复以几法令不变悔？”
    佛告舍利弗：“被不实举罪比丘，当以五法不自变悔。彼应作是念：‘彼比丘不实举罪非是实，非时非是时，非义饶益非是义饶益，粗涩非柔软，瞋恚非慈心，我真不变悔。’被不实举罪比丘，当以此五法自安其心，不自变悔。”
    舍利弗白佛言：“世尊，有比丘举罪实非不实，时不非时，义饶益不非义饶益，柔软非粗涩，慈心非瞋恚。实举罪比丘，当以几法饶益，令不改变？”
    佛告舍利弗：“实举罪比丘，当以五法饶益，令不变悔。当作是言：‘长老！汝实举罪非不实，时不非时，义饶益不非义饶益，柔软非粗涩，慈心非瞋恚。’舍利弗，实举罪比丘，当以此五法义饶益，令不变悔，亦令来世实举罪比丘而不变悔。”
    舍利弗白佛言：“世尊，被实举罪比丘，当以几法饶益，令不变悔？”
    佛告舍利弗：“被举罪比丘，当以五法饶益，令不变悔。当作是言：‘彼比丘实举罪非不实，汝莫变悔。时不非时，义饶益不非义饶益，柔软非粗涩，慈心非瞋恚，汝莫变悔。’”
    舍利弗白佛言：“世尊，我见被实举罪比丘有瞋恚者。世尊，被实举罪瞋恚比丘，当以几法，令于瞋恨而自开觉？”
    佛告舍利弗：“被实举罪瞋恚比丘，当以五法令自开觉。当语彼言：‘长老！彼比丘实举汝罪，非不实，汝莫瞋恨。乃至慈心非瞋恚，汝莫瞋恨。’舍利弗，被实举罪瞋恚比丘，当以此五法，令于恚恨而得开觉。”
    舍利弗白佛言：“世尊，有实、不实举我罪者，于彼二人，我当自安其心。若彼实者，我当自知。若不实者，当自开解，言：‘此则不实，我今自知无此法也。’世尊，我当如是，如世尊所说《解林譬经》说，教诸沙门：‘若有贼来执汝，以锯解身，汝等于贼起恶念恶言者，自生障碍。是故比丘，若以锯解汝身，汝当于彼勿起恶心变易，及起恶言，自作障碍。于彼人所，当生慈心，无怨无恨，于四方境界，慈心正受具足住，应当学。’是故世尊，我当如是，如世尊所说，解身之苦，当自安忍，况复小苦、小谤而不安忍？沙门利，沙门欲，欲断不善法，欲修善法，于此不善法当断，善法当修，精勤方便，善自防护，系念思惟，不放逸行，应当学。”
    舍利弗白佛言：“世尊，我若举他比丘罪，实非不实、时非不时、义饶益非非义饶益、柔软非粗涩、慈心不瞋恚，然彼被举比丘有怀瞋恚者。”
    佛问舍利弗：“何等像类比丘，闻举其罪，而生瞋恚？”
    舍利弗白佛言：“世尊，若彼比丘谄曲、幻伪、欺诳、不信、无惭、无愧、懈怠、失念、不定、恶慧、慢缓、违于远离、不敬戒律、不顾沙门、不勤修学、不自省察、为命出家、不求涅槃，如是等人，闻我举罪，则生瞋恚。”
    佛问舍利弗：“何等像类比丘，闻汝举罪而不瞋恨？”
    舍利弗白佛言：“世尊，若有比丘不谄曲、不幻伪、不欺诳、有信、惭、愧、精勤、正念、正定、智慧、不慢缓、不舍远离、深敬戒律、顾沙门行、尊崇涅槃、为法出家、不为性命，如是比丘闻我举罪，欢喜顶受，如饮甘露。譬如刹利、婆罗门女，沐浴清净，得好妙花，爱乐顶戴，以冠其首。如是比丘不谄曲、不幻伪、不欺诳、正信、惭、愧、精勤、正念、正定、智慧、不慢缓、心存远离、深敬戒律、顾沙门行、勤修自省、为法出家、志求涅槃，如是比丘闻我举罪，欢喜顶受，如饮甘露。”
    佛告舍利弗：“若彼比丘谄曲、幻伪、欺诳、不信、无惭、无愧、懈怠、失念、不定、恶慧、慢缓、违于远离、不敬戒律、不顾沙门行、不求涅槃、为命出家，如是比丘不应教授，与共言语。所以者何？此等比丘破梵行故。
    “若彼比丘不谄曲、不幻伪、不欺诳、信心、惭、愧、精勤、正念、正定、智慧、不慢缓、心存远离、深敬戒律、顾沙门行、志崇涅槃、为法出家，如是比丘应当教授。所以者何？如是比丘能修梵行，能自建立故。”
    佛说此经已，尊者舍利弗闻佛所说，欢喜奉行。

（四九八）

    如是我闻。一时佛住那罗揵陀卖衣者庵罗园。
    尔时舍利弗诣世尊所，稽首礼足，退坐一面，白佛言：“世尊，我深信世尊，过去、当来、今现在诸沙门、婆罗门所有智慧，无有与世尊菩提等者，况复过上。”
    佛告舍利弗：“善哉善哉！舍利弗，善哉所说，第一之说，能于众中作狮子吼，自言深信世尊，言过去、当来、今现在沙门、婆罗门所有智慧，无有与佛菩提等者，况复过上。”
    佛问舍利弗：“汝能审知过去三藐三佛陀所有增上戒不？”
    舍利弗白佛言：“不知，世尊。”
    复问舍利弗：“知如是法、如是慧、如是明、如是解脱、如是住不？”
    舍利弗白佛言：“不知，世尊。”
    佛告舍利弗：“汝复知未来三藐三佛陀所有增上戒，如是法、如是慧、如是明、如是解脱、如是住不？”
    舍利弗白佛言：“不知，世尊。”
    佛告舍利弗：“汝复能知今现在佛所有增上戒，如是法、如是慧、如是明、如是解脱、如是住不？”
    舍利弗白佛言：“不知，世尊。”
    佛告舍利弗：“汝若不知过去、未来、今现在诸佛世尊心中所有诸法，云何如是赞叹，于大众中作狮子吼，说言：我深信世尊，过去、当来诸沙门、婆罗门所有智慧，无有与世尊菩提等者，况复过上。”
    舍利弗白佛言：“世尊，我不能知过去、当来、今现在诸佛世尊心之分齐，然我能知诸佛世尊法之分齐。我闻世尊说法，转转深，转转胜，转转上，转转妙。我闻世尊说法，知一法即断一法，知一法即证一法，知一法即修习一法，究竟于法，于大师所，得净信心，得净，世尊是等正觉。世尊，譬如国王有边城，城周匝方直，牢固坚密，唯有一门，无第二门，立守门者，人民入出，皆从此门。若入若出，其守门者虽复不知人数多少，要知人民唯从此门，更无他处。如是我知过去诸佛、如来、应、等正觉，悉断五盖恼心，令慧力羸、堕障碍品、不向涅槃者，住四念处，修七觉分，得阿耨多罗三藐三菩提。彼当来世诸佛世尊，亦断五盖恼心，令慧力羸、堕障碍品、不向涅槃者，住四念处，修七觉分，得阿耨多罗三藐三菩提。今现在诸佛、世尊、如来、应、等正觉，亦断五盖恼心，令慧力羸、堕障碍品、不向涅槃者，住四念处，修七觉分，得阿耨多罗三藐三菩提。”
    佛告舍利弗：“如是如是，舍利弗，过去、未来、今现在佛，悉断五盖恼心，令慧力羸、堕障碍品、不向涅槃者，住四念处，修七觉分，得阿耨多罗三藐三菩提。”
    佛说是经已，尊者舍利弗闻佛所说，欢喜奉行。

（四九九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者舍利弗在耆阇崛山中。
    时有月子比丘，是提婆达多弟子，诣尊者舍利弗，共相问讯慰劳已，退住一面。退住一面已，尊者舍利弗问月子比丘言：“提婆达多比丘为诸比丘说法不？”
    月子比丘答言：“说法。”
    尊者舍利弗问月子比丘言：“提婆达多云何说法？”
    月子比丘语尊者舍利弗言：“彼提婆达多如是说法，言：比丘心法修心，是比丘能自记说，我已离欲，解脱五欲功德。”
    舍利弗语月子比丘言：“汝提婆达多何以不说法言：比丘心法，善修心，离欲心、离瞋恚心、离愚痴心，得无贪法、无恚法、无痴法，不转还欲有、色有、无色有法，彼比丘能自记说言：我生已尽，梵行已立，所作已作，自知不受后有耶？”
    月子比丘言：“彼不能也，尊者舍利弗。”
    尔时尊者舍利弗语月子比丘言：“若有比丘心法，善修心者，能离贪欲心、瞋恚、愚痴心，得无贪法、无恚、无痴法，是比丘能自记说：我生已尽，梵行已立，所作已作，自知不受后有。
    “譬如村邑近有大石山，不断、不坏、不穿、厚密，正使东方风来，不能令动，亦复不能过至西方。如是南、西、北方、四维风来，不能倾动，亦不能过。如是比丘心法，善修心者，离贪欲心、离瞋恚心、离愚痴心，得无贪法、无恚法、无痴法，是比丘能自记说：我生已尽，梵行已立，所作已作，自知不受后有。
    “譬如因陀铜铁及铜柱，深入地中，筑令坚密，四方风吹，不能倾动。如是比丘心法，善修心已，离贪欲心、离瞋恚心、离愚痴心，得无贪法、无恚法、无痴法，是比丘能自记说：我生已尽，梵行已立，所作已作，自知不受后有。
    “譬如石柱长十六肘，八肘入地，四方风吹，不能倾动。如是比丘心法，善修心已，悉离贪欲心、离瞋恚心、离愚痴心，得无贪法、无恚法、无痴法，能自记说：我生已尽，梵行已立，所作已作，自知不受后有。
    “譬如火烧未烧者，烧已不复更烧。如是比丘心法，修心已，离贪欲心、离瞋恚心、离愚痴心，得无贪法、无恚法、无痴法，能自记说：我生已尽，梵行已立，所作已作，自知不受后有。”
    舍利弗说此经已，诸比丘闻其所说，欢喜奉行。

（五○○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时尊者舍利弗亦住王舍城迦兰陀竹园。
    尔时尊者舍利弗晨朝着衣持钵，入王舍城乞食。乞食已，于一树下食。
    时有净口外道出家尼，从王舍城出，少有所营。见尊者舍利弗坐一树下食，见已问言：“沙门食耶？”
    尊者舍利弗答言：“食。”
    复问：“云何沙门下口食耶？”
    答言：“不也，姊妹。”
    复问：“仰口食耶？”
    答言：“不也，姊妹。”
    复问：“云何方口食耶？”
    答言：“不也，姊妹。”
    复问：“四维口食耶？”
    答言：“不也，姊妹。”
    复问：“我问沙门食耶，答我言食。我问仰口耶，答我言不。下口食耶，答我言不。方口食耶，答我言不。四维口食耶，答我言不。如此所说，有何等义？”
    尊者舍利弗言：“姊妹！诸所有沙门、婆罗门，明于事者，明于横法，邪命求食者，如是沙门、婆罗门下口食也。若诸沙门、婆罗门，仰观星历，邪命求食者，如是沙门、婆罗门则为仰口食也。若诸沙门、婆罗门，为他使命，邪命求食者，如是沙门、婆罗门则为方口食也。若有沙门、婆罗门，为诸医方，种种治病，邪命求食者，如是沙门、婆罗门则为四维口食也。姊妹！我不堕此四种邪命而求食也。然我姊妹，但以法求食而自活也，是故我说不为四种食也。”
    时净口外道出家尼，闻尊者舍利弗所说，欢喜随喜而去。
    时净口外道出家尼，于王舍城里巷四衢处赞叹言：“沙门释子净命自活，极净命自活！诸有欲为施者，应施沙门释种子。若欲为福者，应于沙门释子所作福。”
    时有余外道出家，闻净口外道出家尼赞叹沙门释子声，以嫉妒心，害彼净口外道出家尼。命终之后，生兜率天，以于尊者舍利弗所，生信心故也。

（五○一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者大目揵连在王舍城耆阇崛山中。
    尔时尊者大目揵连告诸比丘：“一时世尊住王舍城迦兰陀竹园，我于此耆阇崛山中住。我独一静处，作如是念：‘云何为圣默然？’复作是念：‘若有比丘息有觉有观，内净一心，无觉无观三昧生喜乐，第二禅具足住，是名圣默然。’复作是念：‘我今亦当圣默然，息有觉有观，内净一心，无觉无观三昧生喜乐，具足住多住。’多住已，复有觉有观心起。尔时世尊知我心念，于竹园精舍没，于耆阇崛山中现于我前，语我言：‘目揵连，汝当圣默然，莫生放逸！’
    “我闻世尊说已，即复离有觉有观，内净一心，无觉无观三昧生喜乐，第二禅具足住。如是再三，佛亦再三教我：‘汝当圣默然，莫放逸！’我即复息有觉有观，内净一心，无觉无观三昧生喜乐，第三禅具足住。
    “若正说佛子从佛口生，从法化生，得佛法分者，则我身是也。所以者何？我是佛子，从佛口生，从法化生，得佛法分，以少方便，得禅、解脱、三昧、正受。譬如转轮圣王长太子，虽未灌顶，已得王法，不勤方便，能得五欲功德。我亦如是，为佛之子，不勤方便，得禅、解脱、三昧、正受。于一日中，世尊以神通力，三至我所，三教授我，以大人处所建立于我。”
    尊者大目揵连说此经已，诸比丘闻其所说，欢喜奉行。

（五○二）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者大目揵连在王舍城耆阇崛山中。
    尔时尊者大目揵连告诸比丘：“一时世尊住王舍城，我住耆阇崛山中。我独一静处，作如是念：‘云何名为圣住？’复作是念：‘若有比丘不念一切相，无相心正受，身作证具足住，是名圣住。’我作是念：‘我当于此圣住，不念一切相、无相心正受，身作证具足住多住。’多住已，取相心生。尔时世尊知我心念，如力士屈伸臂顷，以神通力，于竹园精舍没，于耆阇崛山中现于我前，语我言：‘目揵连，汝当住于圣住，莫生放逸！’我闻世尊教已，即离一切相，无相心正受，身作证具足住。如是至三，世尊亦三来教我：‘汝当住于圣住，莫生放逸！’我闻教已，离一切相，无相心正受，身作证具足住。
    “诸大德！若正说佛子者，则我身是，从佛口生，从法化生，得佛法分。所以者何？我是佛子，从佛口生，从法化生，得佛法分，以少方便，得禅、解脱、三昧、正受。譬如转轮圣王太子，虽未灌顶，已得王法，不勤方便，能得五欲功德。我亦如是，为佛之子，不勤方便，得禅、解脱、三昧、正受。于一日中，世尊以神通力，三至我所，三教授我，以大人处建立于我。”
    尊者大目揵连说此经已，诸比丘闻其所说，欢喜奉行。

（五○三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者舍利弗、尊者大目揵连、尊者阿难，在王舍城迦兰陀竹园，于一房共住。
    时尊者舍利弗于后夜时告尊者目揵连：“奇哉尊者目揵连！汝于今夜住寂灭正受，我都不闻汝喘息之声。”
    尊者目揵连言：“此非寂灭正受，粗正受住耳。尊者舍利弗，我于今夜与世尊共语。”
    尊者舍利弗言：“目揵连，世尊住舍卫国祇树给孤独园，去此极远，云何共语？汝今在竹园，云何共语？汝以神通力至世尊所，为是世尊神通力来至汝所？”
    尊者目揵连语尊者舍利弗：“我不以神通力诣世尊所，世尊不以神通力来至我所，然我于舍卫国王舍城中闻。世尊及我俱得天眼、天耳故，我能问世尊：‘所谓殷勤精进，云何名为殷勤精进？’世尊答我言：‘目揵连，若此比丘昼则经行、若坐，以不障碍法，自净其心。初夜若坐、经行，以不障碍法，自净其心。于中夜时，出房外洗足，还入房，右胁而卧，足足相累，系念明相，正念正知，作起思惟。于后夜时，徐觉徐起，若坐亦经行，以不障碍法，自净其心。目揵连，是名比丘殷勤精进。’”
    尊者舍利弗语尊者目揵连言：“汝大目揵连，真为大神通力，大功德力，安坐而坐。我亦大力，得与汝俱。目揵连，譬如大山，有人持一小石，投之大山，色味悉同。我亦如是，得与尊者大力大德，同座而坐。譬如世间鲜净好物，人皆顶戴。如是尊者目揵连大德大力，诸梵行者皆应顶戴。诸有得遇尊者目揵连，交游往来，恭敬供养者，大得善利。我今亦得与尊者大目揵连交游往来，亦得善利。”
    时尊者大目揵连语尊者舍利弗：“我今得与大智大德尊者舍利弗同座而坐，如以小石投之大山，得同其色。我亦如是，得与尊者大智舍利弗同座而坐，为第二伴。”
    时二正士共论议已，各从座起而去。


杂阿含经卷第十九

（五○四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者大目揵连在耆阇崛山。
    时释提桓因，居上妙堂观，于夜来诣尊者大目揵连所，稽首礼足，退坐一面。时释提桓因光明，普照耆阇崛山，周匝大明。
    尔时释提桓因坐已，即说偈言：

“能伏于悭垢，大德随时施，
是名施中贤，来世见殊胜。”

    时大目揵连问帝释言：“憍尸迦，云何为调伏悭垢，见于殊胜？而汝说言：

“能调伏悭垢，大德随时施，
是则施中贤，来世见殊胜。”

    时天帝释答言：“尊者大目揵连，胜婆罗门大姓、胜刹利大姓、胜长者大姓、胜四王天、胜三十三天，稽首敬礼故。尊者大目揵连，我为胜婆罗门大姓、胜刹利大姓、胜长者大姓、胜四王天、胜三十三天恭敬作礼，见斯果报，故说此偈。复次尊者大目揵连，乃至日所周行，照于诸方，至千世界，千月、千日、千须弥山王、千弗婆提舍、千郁多罗提舍、千瞿陀尼迦、千阎浮提、千四天王、千三十三天、千炎摩天、千兜率陀天、千化乐天、千他化自在天、千梵天，名为小千世界。此小千世界中，无有堂观与毗阇延堂观等者。毗阇延有百一楼观，观有七重，重有七房，房有七天后，后各七侍女。尊者大目揵连，于小千世界无有如是堂观，端严如毗阇延者。我见是调伏悭故，有此妙果，故说斯偈。”
    大目揵连语帝释言：“善哉善哉！憍尸迦，汝能见此胜妙果报，而说斯偈。”
    时天帝释闻尊者大目揵连所说，欢喜随喜，忽然不现。

（五○五）

    如是我闻。一时佛住王舍城。
    时尊者大目揵连在耆阇崛山中。
    尔时尊者大目揵连，独一静处禅思，作是念：“昔有时，释提桓因于界隔山石窟中，问世尊爱尽解脱之义，世尊为说，闻已随喜，似欲更有所问义。我今当往，问其喜意。”作是念已，如力士屈伸臂顷，于耆阇崛山没，至三十三天，去一分陀利池不远而住。
    时天帝释与五百婇女游戏浴池，有诸天女音声美妙。尔时帝释遥见尊者大目揵连，语诸天女言：“莫歌，莫歌。”时诸天女即便默然。天帝释即诣尊者大目揵连所，稽首礼足，退住一面。
    尊者大目揵连问帝释言：“汝先于界隔山中，问世尊爱尽解脱义，闻已随喜。汝意云何？为闻说随喜？为更欲有所问故随喜耶？”
    天帝释语尊者大目揵连：“我三十三天多著放逸乐，或忆先事，或时不忆。世尊今在王舍城迦兰陀竹园，尊者欲知我先界隔山中所问事者，今可往问世尊，如世尊说，汝当受持。然我此处有好堂观，新成未久，可入观看。”
    时尊者大目揵连默然受请，即与天帝释共入堂观。彼诸天女遥见帝释来，皆作天乐，或歌或舞。诸天女辈，着身璎珞庄严之具，出妙音声，合于五乐，如善作乐，音声不异。诸天女辈既见尊者大目揵连，悉皆惭愧，入室藏隐。
    时天帝释语尊者大目揵连：“观此堂观，地好平正，其壁、柱、梁、重阁、窗牖、罗网、帘障，悉皆严好。”
    尊者大目揵连语帝释言：“憍尸迦，先修善法福德因缘，成此妙果。”
    如是帝释三自称叹，问尊者大目揵连。尊者大目揵连亦再三答。
    时尊者大目揵连作是念：“今此帝释极自放逸，著界神住，叹此堂观。我当令彼心生厌离。”即入三昧，以神通力，以一足指，撇其堂观，悉令震动。时尊者大目揵连即没不现。
    诸天女众见此堂观震掉动摇，颠沛恐怖，东西驰走，白帝释言：“此是憍尸迦大师有此大功德力耶？”
    时天帝释语诸天女：“此非我师，是大师弟子大目揵连，梵行清净，大德大力者。”
    诸天女言：“善哉憍尸迦，乃有如此梵行，大德大力同学。大师德力，当复如何！”

（五○六）

    如是我闻。一时佛住三十三天骢色虚软石上，去波梨耶多罗拘毗陀罗香树不远，夏安居，为母及三十三天说法。
    尔时尊者大目揵连，在舍卫国祇树给孤独园安居。
    时诸四众诣尊者大目揵连所，稽首礼足，退坐一面，白尊者大目揵连：“知世尊夏安居处不？”
    尊者大目揵连答言：“我闻世尊在三十三天骢色虚软石上，去波梨耶多罗拘毗陀罗香树不远，夏安居，为母及三十三天说法。”
    时诸四众闻尊者大目揵连所说，欢喜随喜，各从座起，作礼而去。
    时诸四众过三月安居已，复诣尊者大目揵连所，稽首礼足，退坐一面。
    时尊者大目揵连为诸四众种种说法，示教照喜，示教照喜已，默然而住。
    时诸四众从座而起，稽首作礼，白尊者大目揵连：“尊者大目揵连，当知我等不见世尊已久，众甚虚渴，欲见世尊。尊者大目揵连，若不惮劳者，愿为我等往诣三十三天，普为我等问讯世尊，少病少恼，起居轻利，安乐住不？又白世尊：阎浮提四众愿见世尊，而无神力升三十三天礼敬世尊，三十三天自有神力来下人中。唯愿世尊，还阎浮提，以哀愍故。”
    时尊者大目揵连默然而许。
    时诸四众知尊者大目揵连默然许已，各从座起，作礼而去。
    尔时尊者大目揵连知四众去已，即入三昧，如其正受，如大力士屈伸臂顷，从舍卫国没，于三十三天骢色虚软石上，去波梨耶多罗拘毗陀罗香树不远而现。
    尔时世尊与三十三天众，无量眷属围绕说法。时尊者大目揵连遥见世尊，踊跃欢喜，作是念：“今日世尊，诸天大众围绕说法，与阎浮提众会不异。”
    尔时世尊知尊者大目揵连心之所念，语尊者大目揵连言：“大目揵连，非为自力，我欲为诸天说法，彼即来集。欲令其去，彼即还去。彼随心来，随心去也。”
    尔时尊者大目揵连稽首佛足，退坐一面，白世尊言：“种种诸天大众云集，彼天众中有曾从佛世尊闻所说法，得不坏净，身坏命终来生于此？”
    佛告尊者大目揵连：“如是如是，此中种种诸天来云集者，有从宿命闻法，得佛不坏净，法、僧不坏净，圣戒成就，身坏命终来生于此。”
    时天帝释，见世尊与尊者大目揵连叹说诸天众，共语已，语尊者大目揵连：“如是如是，尊者大目揵连，此中种种众会，皆是宿命曾闻正法，得于佛不坏净，法、僧不坏净，圣戒成就，身坏命终来生于此。”
    时有异比丘，见世尊与尊者大目揵连及天帝释语言，善相述可已，语尊者大目揵连：“如是如是，尊者大目揵连，是中种种诸天来会此者，皆是宿命曾闻正法，得于佛不坏净，法、僧不坏净，圣戒成就，身坏命终而来生此。”
    时有一天子从座起，整衣服，偏袒右肩，合掌白佛：“世尊，我亦成就于佛不坏净，故来生此。”
    复有天子言：“我得法不坏净。”
    有言：“得僧不坏净。”
    有言：“圣戒成就，故来生此。”
    如是诸天无量千数，于世尊前各自记说得须陀洹法，悉于佛前即没不现。
    时尊者大目揵连知诸天众去，不久从座起，整衣服，偏袒右肩，白佛言：“世尊，阎浮提四众稽首敬礼世尊足，问讯世尊，少病少恼，起居轻利，安乐住不？四众思慕，愿见世尊。又白世尊：我等人间无有神力升三十三天礼觐世尊，然彼诸天有大德力，悉能来下至阎浮提。唯愿世尊，还阎浮提，愍四众故。”
    佛告目揵连：“汝可还彼，语阎浮提人，却后七日，世尊当从三十三天，还阎浮提僧迦舍城，于外门外优昙钵树下。”
    尊者大目揵连受世尊教，即入三昧，譬如力士屈伸臂顷，从三十三天没，至阎浮提，告诸四众：“诸人当知，世尊却后七日，从三十三天还阎浮提僧迦舍城，于外门外优昙钵树下。”
    如期七日，世尊从三十三天，下阎浮提僧迦舍城，优昙钵树下。天龙鬼神，乃至梵天，悉从来下，即于此时，名此会名天下处。

（五○七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有四十天子，来诣尊者大目揵连所，稽首作礼，退坐一面。
    时尊者大目揵连语诸天子言：“善哉诸天子！于佛不坏净成就，法、僧不坏净成就。”
    时四十天子从座起，整衣服，偏袒右肩，合掌白尊者大目揵连：“我等于佛不坏净，于法、僧不坏净，圣戒成就，故生天上。”
    有一天言：“得于佛不坏净。”
    有言：“得法不坏净。”
    有言：“得僧不坏净。”
    有言：“圣戒成就，身坏命终得生天上。”
    时四十天子，于尊者大目揵连前，各自记说得须陀洹果，即没不现。
    如四十天子，如是四百、八百、十千天子，亦如是说。

（五○八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时尊者大目揵连与尊者勒叉那比丘，共在耆阇崛山中。
    尊者勒叉那晨朝诣尊者大目揵连所，语尊者大目揵连：“共出耆阇崛山，入王舍城乞食。”
    时尊者大目揵连默然而许，即共出耆阇崛山，入王舍城乞食。行至一处，尊者大目揵连心有所念，欣然微笑。
    尊者勒叉那见微笑已，即问尊者大目揵连言：“若佛及佛弟子欣然微笑，非无因缘。尊者今日何因何缘而发微笑？”
    尊者大目揵连言：“所问非时，且入王舍城，乞食还，于世尊前当问是事，是应时问，当为汝说。”
    时尊者大目揵连与尊者勒叉那，入王舍城乞食而还，洗足，举衣钵，俱诣佛所，稽首佛足，退坐一面。
    尊者勒叉那问尊者大目揵连：“我今晨朝与汝共出耆阇崛山乞食，汝于一处欣然微笑。我即问汝微笑因缘，汝答我言所问非时。今复问汝，何因何缘欣然微笑？”
    尊者大目揵连语尊者勒叉那：“我路中见一众生，身如楼阁，啼哭号呼，忧悲苦痛，乘虚而行。我见是已，作是思惟，如是众生得如此身，而有如是忧悲大苦，故发微笑。”
    尔时世尊告诸比丘：“善哉善哉！我声闻中住实眼、实智、实义、实法，决定通达，见是众生。我亦见此众生，而不说者，恐人不信。所以者何？如来所说，有不信者，是愚痴人，长夜受苦。”
    佛告诸比丘：“过去世时，彼大身众生，在此王舍城，为屠牛儿。以屠牛因缘故，于百千岁堕地狱中。从地狱出，有屠牛余罪，得如是身，常受如是忧悲恼苦。如是诸比丘，如尊者大目揵连所见不异，汝等受持。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五○九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者大目揵连与尊者勒叉那，在耆阇崛山。
    尊者勒叉那于晨朝时，诣尊者大目揵连所，语尊者大目揵连：“共出耆阇崛山，入王舍城乞食。”
    尊者大目揵连默然而许，即共出耆阇崛山，入王舍城乞食。行至一处，尊者大目揵连心有所念，欣然微笑。
    尊者勒叉那见尊者大目揵连微笑，即问言：“尊者，若佛及佛声闻弟子欣然微笑，非无因缘。尊者今日何因何缘而发微笑？”
    尊者大目揵连言：“所问非时，且乞食还，于世尊前当问是事，是应时问。”
    尊者大目揵连与尊者勒叉那，共入城乞食，食已还，洗足，举衣钵，俱诣佛所，稽首佛足，退坐一面。
    尊者勒叉那问尊者大目揵连：“我今晨朝与汝共入王舍城乞食，汝于一处欣然微笑。我即问汝何因缘笑，汝答我言所问非时。我今问汝，何因何缘欣然微笑？”
    尊者大目揵连语尊者勒叉那：“我于路中见一众生，筋骨相连，举身不净，臭秽可厌。乌、鸱、雕、鹫、野干、饿狗随而攫食，或从胁肋探其内脏而取食之，极大苦痛，啼哭号呼。我见是已，心即念言，如是众生得如是身，而受如是不饶益苦。”
    尔时世尊告诸比丘：“善哉比丘！我声闻中住实眼、实智、实义、实法，决定通达，见如是众生。我亦见是众生，而不说者，恐不信故。所以者何？如来所说，有不信者，是愚痴人，长夜当受不饶益苦。诸比丘，是众生者，过去世时，于此王舍城为屠牛弟子，缘屠牛罪故，已百千岁堕地狱中，受无量苦。彼屠牛恶行余罪缘故，今得此身，续受如是不饶益苦。诸比丘，如大目揵连所见，真实不异，汝等受持。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五一○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尊者大目揵连与尊者勒叉那，在耆阇崛山中。
    尊者勒叉那于晨朝时，诣尊者大目揵连所，语尊者大目揵连：“共出耆阇崛山，入王舍城乞食。”
    尊者大目揵连默然而许，即共出耆阇崛山，入王舍城乞食。行至一处，尊者大目揵连心有所念，欣然微笑。
    尊者勒叉那见尊者大目揵连微笑，即问言：“尊者，若佛及佛声闻弟子欣然微笑，非无因缘。尊者今日何因何缘而发微笑？”
    尊者大目揵连言：“所问非时，且乞食还，于世尊前当问是事，是应时问。”
    尊者大目揵连与尊者勒叉那，共入城乞食已还，洗足，举衣钵，俱诣佛所，稽首佛足，退坐一面。
    尊者勒叉那问尊者大目揵连：“我今晨朝共入王舍城乞食，汝于一处欣然微笑。我即问汝微笑因缘，汝答我言所问非时。我今问汝，何因何缘欣然微笑？”
    尊者大目揵连语勒叉那：“我于路中见一大众生，举身无皮，纯一肉段，乘空而行。乌、鸱、雕、鹫、野干、饿狗随而攫食，或从胁肋探其内脏而取食之，苦痛切迫，啼哭号呼。我即思惟，如是众生得如是身，乃受如是不饶益苦。”
    佛告诸比丘：“善哉比丘！我声闻中住实眼、实智、实义、实法，决定通达，见是众生。我亦见是众生，而不说者，恐不信故。所以者何？如来所说，有不信者，是愚痴人，长夜当受不饶益苦。诸比丘，是众生者，过去世时，于此王舍城为屠羊者。缘斯罪故，已百千岁堕地狱中，受无量苦。今得此身，余罪缘故，续受斯苦。诸比丘，如大目揵连所见，真实无异，汝等受持。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五一一）

    如是我闻。一时佛住王舍城。
    乃至尊者大目揵连于路中见一大身众生，举体无皮，形如脯腊，乘虚而行。
    乃至佛告诸比丘：“此众生者，过去世时，于此王舍城为屠羊弟子，屠羊罪故，已百千岁堕地狱中，受无量苦。今得此身，续受斯罪。诸比丘，如大目揵连所见，真实无异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五一二）

    如是我闻。一时佛住王舍城。
    乃至路中见一大身众生，举体无皮，形如肉段，乘虚而行。
    乃至佛告诸比丘：“此众生者，过去世时，于此王舍城自堕其胎。缘斯罪故，堕地狱中，已百千岁，受无量苦。以余罪故，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实无异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五一三）

    如是我闻。一时佛住王舍城。
    乃至尊者大目揵连于路中见一大身众生，举体生毛，毛如大针，针皆火燃，还烧其体，痛彻骨髓。
    乃至佛告诸比丘：“此众生者，过去世时，于此王舍城为调象士。缘斯罪故，已百千岁堕地狱中，受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如调象士，如是调马士、调牛士、好谗人者，及诸种种苦切人者，亦复如是。

（五一四）

    如是我闻。一时佛住王舍城。
    乃至尊者大目揵连于路中见一大身众生，举身生毛，毛利如刀，其毛火燃，还割其体，痛彻骨髓。
    乃至佛告诸比丘：“此众生者，过去世时，于此王舍城好乐战诤，刀剑伤人，已百千岁堕地狱中，受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五一五）

    如是我闻。一时佛住王舍城。
    乃至尊者大目揵连于路中见一大身众生，遍身生毛，其毛似箭，皆悉火燃，还烧其身，痛彻骨髓。
    乃至佛告诸比丘：“此众生者，过去世时，于此王舍城曾为猎师，射诸禽兽。缘斯罪故，已百千岁堕地狱中，受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五一六）

    如是我闻。一时佛住王舍城。
    乃至我于路中见一大身众生，举体生毛，毛如[矛+赞]矛，毛悉火燃，还烧其身，痛彻骨髓。
    乃至佛告诸比丘：“此众生者，过去世时，于此王舍城为屠猪人，[矛+赞]杀群猪。缘斯罪故，已百千岁堕地狱中，受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五一七）

    如是我闻。一时佛住王舍城。
    乃至我于路中见一大身无头众生，两边生目，胸前生口，身常流血，诸虫唼食，痛彻骨髓。
    乃至佛告诸比丘：“此众生者，过去世时，于此王舍城好断人头。缘斯罪故，已百千岁堕地狱中，受无量苦。今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如断人头，捉头亦如是。

（五一八）

    如是我闻。一时佛住王舍城。
    乃至我于路中见一众生，阴卵如瓮，坐则踞上，行则肩担。
    乃至佛告诸比丘：“此众生者，过去世时，于王舍城作锻铜师，伪器欺人。缘斯罪故，已地狱中受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如锻铜师，如是斗秤欺人、村主、市监，亦复如是。

（五一九）

    如是我闻。一时佛住王舍城。
    乃至路中见一众生，以铜铁罗网自缠其身，火常炽燃，还烧其体，痛彻骨髓，乘虚而行。
    佛告诸比丘：“此众生者，过去世时，于此王舍城为捕鱼师。缘斯罪故，已地狱中受无量苦。地狱余罪，今受此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如捕鱼师，捕鸟、网兔亦复如是。

（五二○）

    如是我闻。一时佛住王舍城。
    乃至路中见一众生，顶有铁磨，盛火炽燃，转磨其顶，乘虚而行，受无量苦。
    乃至佛告诸比丘：“彼众生者，过去世时，于此王舍城为卜占女人，转式卜占，欺妄惑人，以求财物。缘斯罪故，已地狱中受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五二一）

    如是我闻。一时佛住王舍城。
    乃至路中见一众生，其身独转，犹若旋风，乘虚而行。
    乃至佛告诸比丘：“此众生者，过去世时，于此王舍城为卜占师，误惑多人，以求财物。缘斯罪故，已地狱中受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五二二）

    如是我闻。一时佛住王舍城。
    乃至路中见一众生，伛身藏行，状如恐怖，举体被服悉皆火燃，还烧其身，乘虚而行。
    佛告诸比丘：“此众生者，过去世时，于此王舍城好行他淫。缘斯罪故，已地狱中受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五二三）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    时尊者大目揵连、尊者勒叉那比丘，晨朝共入波罗奈城乞食。于路中，尊者大目揵连思惟顾念，欣然微笑。
    时尊者勒叉那白尊者大目揵连言：“世尊及世尊弟子欣然微笑，必有因缘。何缘尊者今日欣然微笑？”
    尊者大目揵连语尊者勒叉那：“此非时问，且乞食还，诣世尊前，当问此事。”
    时俱入城乞食还，洗足，举衣钵，俱诣世尊，稽首礼足，退坐一面。
    时尊者勒叉那问尊者大目揵连：“晨朝路中，何因何缘欣然微笑？”
    尊者大目揵连语尊者勒叉那：“我于路中见一大身众生，举体脓坏，臭秽不净，乘虚而行，乌、鸱、雕、鹫、野干、饿狗随逐攫食，啼哭号呼。我念众生得如是身，受如是苦，一何痛哉！”
    佛告诸比丘：“我亦见此众生，而不说者，恐不信故。所以者何？如来所说，有不信者，是愚痴人，长夜受苦。此众生者，过去世时，于此波罗奈城为女人，卖色自活。时有比丘于迦叶佛所出家，彼女人以不清净心，请彼比丘。比丘直心受请，不解其意。女人瞋恚，以不净水洒比丘身。缘斯罪故，已地狱中受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（五二四）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    乃至我于路中见一大身众生，举体火燃，乘虚而行，啼哭号呼，受诸苦痛。
    乃至佛告诸比丘：“此众生者，过去世时，于此波罗奈城为自在王第一夫人，与王共宿，起瞋恚心，以燃灯油，洒王身上。缘斯罪故，已地狱中受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（五二五）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    乃至尊者大目揵连言：“我于路中见一众生，举体粪秽，以涂其身，亦食粪秽，乘虚而行，臭秽苦恼，啼哭号呼。”
    乃至佛告诸比丘：“此众生者，过去世时，于此波罗奈城为自在王师婆罗门，以憎嫉心，请迦叶佛声闻僧，以粪着饭下，试恼众僧。缘斯罪故，已地狱中受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五二六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    乃至尊者大目揵连言：“我于路中见一大身众生，头上有大铜镬，炽然满中烊铜，流灌身体，乘虚而行，啼哭号呼。”
    乃至佛告诸比丘：“此众生者，过去世时，于此舍卫国，迦叶佛所出家，为知事比丘。有檀越送油，应付诸比丘。时有众多客比丘，知事比丘不时分油，待客比丘去，然后乃分。缘斯罪故，已地狱中受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五二七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    乃至尊者大目揵连言：“我于路中见一大身众生，有炽热铁丸从身出入，乘虚而行，苦痛切迫，啼哭号呼。”
    乃至佛告诸比丘：“此众生者，过去世时，于此舍卫国，迦叶佛法中出家作沙弥，次守众僧果园，盗取七果，持奉和尚。缘斯罪故，已地狱中受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五二八）

    如是我闻。一时佛住舍卫国。
    乃至尊者大目揵连言：“我于路中见一大身众生，其舌广长，见有利斧，焰火炽燃，以斫其舌，乘虚而行，啼哭号呼。”
    乃至佛告诸比丘：“此众生者，过去世时，于此舍卫国，迦叶佛法中出家作沙弥，以斧斫石蜜，供养众僧。着斧刃者，盗取食之。缘斯罪故，入地狱中，受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五二九）

    如是我闻。一时佛住舍卫国。
    乃至尊者大目揵连言：“我于路中见是大身众生，有双铁轮在两胁下，炽燃旋转，还烧其身，乘虚而行，啼哭号呼。”
    乃至佛告诸比丘：“此众生者，过去世时，于此舍卫国，迦叶佛法中出家作沙弥，持石蜜饼供养众僧。盗取二饼，着于掖下。缘斯罪故，已地狱中受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五三○）

    如是我闻。一时佛住舍卫国。
    乃至尊者大目揵连言：“我于路中见一大身众生，以炽燃铁叶以缠其身，衣被、床卧悉皆热铁，焰火炽燃，食热铁丸，乘虚而行，啼哭号呼。”
    乃至佛告诸比丘：“此众生者，过去世时，于此舍卫国，迦叶佛法中出家作比丘，为众僧乞衣食。供僧之余，辄自受用。缘斯罪故，已地狱中受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如比丘，如是比丘尼、式叉摩那、沙弥、沙弥尼、优婆塞、优婆夷，亦复如是。

（五三一）

    如是我闻。一时佛住舍卫国。
    乃至尊者大目揵连言：“我于路中见一大身众生，炽燃铁车而驾其颈，拔其颈筋，及连四脚筋，以勒其颈，行热铁地，乘虚而去，啼哭号呼。”
    乃至佛告诸比丘：“此众生者，过去世时，于此舍卫国，驾乘牛车以自生活。缘斯罪故，于地狱中受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五三二）

    如是我闻。一时佛住舍卫国。
    乃至尊者大目揵连言：“我于路中见一大身众生，其舌长广，炽燃铁钉以钉其舌，乘虚而行，啼哭号呼。”
    乃至佛告诸比丘：“此众生者，过去世时，于此舍卫国，迦叶佛法中出家作比丘，为摩摩帝，呵责诸比丘言：‘诸长老，汝等可去。此处俭薄，不能相供。各随意去，求丰乐处，饶衣食所，衣、食、床卧、应病汤药，可得不乏。’先住比丘悉皆舍去，客僧闻之亦复不来。缘斯罪故，已地狱中受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五三三）

    如是我闻。一时佛住舍卫国。
    乃至尊者大目揵连言：“我于路中见一大身众生，比丘之像，皆着铁鍱以为衣服，举体火燃，亦以铁钵盛热铁丸而食之。”
    乃至佛告诸比丘：“此众生者，过去世时，于此舍卫国，迦叶佛法中出家作比丘，作摩摩帝。恶口形名诸比丘，或言此是恶秃，此恶风法，此恶衣服。以彼恶口故，先住者去，未来不来。缘斯罪故，已地狱中受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五三四）

    如是我闻。一时佛住舍卫国。
    乃至佛告诸比丘：“此众生者，过去世时，于此舍卫国，迦叶佛法中出家作比丘，好起诤讼，斗乱众僧，作诸口舌，令不和合。先住比丘厌恶舍去，未来者不来。缘斯罪故，已地狱中受无量苦。地狱余罪，今得此身，续受斯苦。诸比丘，如大目揵连所见，真实不异，当受持之。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五三五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者阿那律，住松林精舍。
    时尊者大目揵连，住跋祇聚落失收摩罗山恐怖稠林禽兽之处。
    时尊者阿那律，独一静处，禅思思惟，作是念：“有一乘道，净众生、离忧悲、灭恼苦，得真如法，所谓四念处。何等为四？身身观念处，受、心、法法观念处。若于四念处远离者，于贤圣法远离；于贤圣法远离者，于圣道远离；圣道远离者，于甘露法远离；甘露法远离者，则不能脱生老病死、忧悲恼苦。若于四念处信乐者，于圣法信乐；圣法信乐者，于圣道信乐；圣道信乐者，于甘露法信乐；甘露法信乐者，得脱生老病死、忧悲恼苦。”
    尔时尊者大目揵连知尊者阿那律心之所念，如力士屈伸臂顷，以神通力，于跋祇聚落失收摩罗山恐怖稠林禽兽之处没，至舍卫城松林精舍，尊者阿那律前现，语阿那律言：“汝独一静处，禅思思惟，作是念：有一乘道，令众生清净，离生老病死、忧悲恼苦，得真如法，所谓四念处。何等为四？身身观念处，受、心、法法观念处。若于四念处不乐者，于贤圣法不乐；圣法不乐者，于圣道不乐；不乐圣道者，于甘露法亦不乐；不乐甘露法者，则不能脱生老病死、忧悲恼苦。若于四念处信乐者，乐贤圣法；乐贤圣法者，乐于圣道；乐圣道者，得甘露法；得甘露法者，得脱生老病死、忧悲恼苦耶？”
    尊者阿那律语尊者大目揵连言：“如是如是。”
    尊者大目揵连语尊者阿那律言：“云何名为乐四念处？”
    “尊者大目揵连，若比丘身身观念处，心缘身，正念住，调伏、止息、寂静、一心、增进。如是受、心、法念处，正念住，调伏、止息、寂静、一心、增进。尊者大目揵连，是名比丘乐四念处。”
    时尊者大目揵连即如其像三昧正受，从舍卫国松林精舍没，还至跋祇聚落失收摩罗山恐怖稠林禽兽之处。

（五三六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    乃至尊者大目揵连问尊者阿那律：“云何名为四念处修习多修习？”
    尊者阿那律语尊者大目揵连言：“若比丘于内身起厌离想，于内身起不厌离想，厌离不厌离俱舍想，正念正知。如内身，如是外身、内外身、内受、外受、内外受、内心、外心、内外心、内法、外法、内外法，作厌离想、不厌离想、厌离不厌离俱舍想，住正念正知。如是尊者大目揵连，是名四念处修习多修习。”
    时尊者大目揵连即入三昧，从舍卫国松林精舍，入三昧神通力，如力士屈伸臂顷，还到跋祇聚落失收摩罗山恐怖稠林禽兽住处。


杂阿含经卷第二十

（五三七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者大目揵连、尊者阿那律，住舍卫国手成浴池侧。
    尊者舍利弗诣尊者阿那律所，共相问讯慰劳已，于一面坐。尊者舍利弗语尊者阿那律言：“奇哉阿那律，有大德神力。于何功德修习多修习，而能致此？”
    尊者阿那律语尊者舍利弗言：“于四念处修习多修习，成此大德神力。何等为四念处？内身身观念处，精勤方便，正念正知，调伏世间贪忧；如是外身、内外身，内受、外受、内外受，内心、外心、内外心，内法、外法、内外法观念处，精勤方便，正念正知，如是调伏世间贪忧。尊者舍利弗，是名四念处修习多修习，成此大德神力。尊者舍利弗，我于四念处善修习故，于小千世界少作方便，能遍观察。如明目士夫，于楼观上，观下平地种种之物。我少作方便，观察小千世界，亦复如是。如是我于四念处修习多修习，成此大德神力。”
    时二正士共论议已，各从座起而去。

（五三八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尊者舍利弗、尊者大目揵连、尊者阿难、尊者阿那律，住舍卫国。
    尔时尊者大目揵连诣尊者阿那律所，共相问讯慰劳已，于一面坐。时尊者大目揵连问尊者阿那律：“于何功德修习多修习，成此大德神力？”
    尊者阿那律语尊者大目揵连：“我于四念处修习多修习，成此大德神力。何等为四？内身身观系心住，精勤方便，正念正知，除世间贪忧；外身、内外身，内受、外受、内外受，内心、外心、内外心，内法、外法、内外法观系心住，精进方便，除世间贪忧。是名四念处修习多修习，成此大德神力。于千须弥山，以少方便，悉能观察。如明目士夫，登高山顶，观下千多罗树林。如是我于四念处修习多修习，成此大德神力，以少方便，见千须弥山。如是尊者大目揵连，我于四念处修习多修习，成此大德神力。”
    时二正士共论议已，各从座起而去。

（五三九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尊者舍利弗、尊者大目揵连、尊者阿难、尊者阿那律，住舍卫国手成浴池侧。
    尔时尊者阿难往尊者阿那律所，共相问讯慰劳已，于一面坐。尊者阿难问尊者阿那律：“于何功德修习多修习，成就如是大德大力大神通？”
    尊者阿那律语尊者阿难：“我于四念处修习多修习，成此大德大力。何等为四？内身身观念处系心住，精勤方便，正念正知，除世间贪忧；如是外身、内外身，内受、外受、内外受，内心、外心、内外心，内法、外法、内外法观念处系心住，精勤方便，除世间贪忧。
    “如是尊者阿难，我于此四念处修习多修习，少方便以净天眼过天人眼，见诸众生死时、生时、好色、恶色、上色、下色、善趣、恶趣，随业受生，皆如实见。此诸众生身恶行，口、意恶行，诽谤贤圣，邪见因缘，身坏命终，生地狱中。如是众生身善行，口、意善行，不谤贤圣，正见成就，以是因缘，身坏命终，得生天上。
    “譬如明目士夫，住四衢道，见诸人民，若来若去，若坐若卧。我亦如是，于四念处修习多修习，成此大德大力神通，见诸众生死时、生时、善趣、恶趣。如是众生身恶行，口、意恶行，诽谤贤圣，邪见因缘，生地狱中。如是众生身善行，口、意善行，不谤贤圣，正见因缘，身坏命终，得生天上。如是尊者阿难，我于四念处修习多修习，成此大德大力神通。”
    时二正士共论议已，各从座起而去。

（五四○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者阿那律在舍卫国松林精舍，身遭病苦。
    时有众多比丘诣尊者阿那律所，问讯慰劳已，于一面住，语尊者阿那律言：“尊者阿那律，所患增损，可安忍不？病势渐损，不转增耶？”
    尊者阿那律言：“我病不安，难可安忍，身诸苦痛，转增无损。即说三种譬，如上《叉摩经》说。然我身已遭此苦痛，且当安忍，正念正知。”
    诸比丘问尊者阿那律：“心住何所，而能安忍如是大苦，正念正知？”
    尊者阿那律语诸比丘言：“住四念处，我于所起身诸苦痛能自安忍，正念正知。何等为四念处？谓内身身观念处，乃至受、心、法观念处，是名住于四念处，身诸苦痛能自安忍，正念正知。”
    时诸正士共论议已，欢喜随喜，各从座起而去。

（五四一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时尊者阿那律在舍卫国松林精舍，病瘥未久。
    时有众多比丘往诣阿那律所，问讯慰劳已，于一面坐，问尊者阿那律：“安隐乐住不？”
    阿那律言：“安隐乐住，身诸苦痛渐已休息。”
    诸比丘问尊者阿那律：“住何所住，身诸苦痛渐得安隐？”
    尊者阿那律言：“住四念处，身诸苦痛渐得安隐。何等为四？谓内身身观念处，乃至法法观念处，是名四念处。住此四念处故，身诸苦痛渐得休息。”
    时诸正士共论议已，欢喜随喜，各从座起而去。

（五四二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时尊者阿那律在舍卫国松林精舍。
    时有众多比丘诣尊者阿那律所，共相问讯慰劳已，于一面坐，问尊者阿那律：“若比丘在于学地，上求安隐涅槃住。圣弟子云何修习多修习，于此法律得尽诸漏，无漏心解脱、慧解脱，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有？”
    尊者阿那律语诸比丘言：“若比丘在于学地，上求安隐涅槃心住，圣弟子云何修习多修习，于此法律得尽诸漏，无漏心解脱、慧解脱，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有者，当住四念处。何等为四？谓内身身观念处，乃至法法观念处。如是四念处修习多修习，于此法律得尽诸漏，无漏心解脱、慧解脱，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。”
    时诸比丘共闻尊者阿那律所说，欢喜随喜，各从座起而去。

（五四三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时尊者阿那律在舍卫国松林精舍住。
    时有众多比丘诣尊者阿那律所，与尊者阿那律共相问讯慰劳已，于一面坐，语尊者阿那律言：“若阿罗汉比丘，诸漏已尽，所作已作，舍离重担，离诸有结，正智心善解脱，亦修四念处耶？”
    尊者阿那律语比丘言：“若比丘诸漏已尽，所作已作，舍离重担，离诸有结，正智心善解脱，彼亦修四念处也。所以者何？不得者得，不证者证，为现法乐住故。所以者何？我亦离诸有漏，得阿罗汉，所作已作，心善解脱，亦修四念处故，不得者得，不到者到，不证者证，乃至现法安乐住。”
    时诸正士共论议已，欢喜随喜，各从座起而去。

（五四四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时尊者阿那律在舍卫国松林精舍。
    时有众多外道出家，诣尊者阿那律所，共相问讯慰劳已，于一面坐，语尊者阿那律：“尊者何故于沙门瞿昙法中出家？”
    尊者阿那律言：“为修习故。”
    复问：“何所修习？”
    答言：“谓修诸根，修诸力，修诸觉分，修诸念处。汝欲闻何等修？”
    复问：“根、力、觉分，我不知其名字，况复问义？然我欲闻念处。”
    尊者阿那律言：“谛听善思，当为汝说。若比丘内身身观念处，乃至法法观念处。”
    时众多外道出家，闻尊者阿那律所说，欢喜随喜，各从座起而去。

（五四五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者阿那律在舍卫国住松林精舍。
    时尊者阿那律语诸比丘：“譬如大树，生而顺下，随浚随输。若伐其根，树必当倒，随所而顺下。如是比丘修四念处，长夜顺趣浚输，向于远离；顺趣浚输，向于出要；顺趣浚输，向于涅槃。”
    尊者阿那律说此经已，诸比丘闻其所说，欢喜奉行。

（五四六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者摩诃迦旃延在跋兰那聚落乌泥池侧。
    时有执澡灌杖梵志，诣摩诃迦旃延所，共相问讯慰劳已，于一面坐，问摩诃迦旃延言：“何因何缘，王、王共诤，婆罗门居士、婆罗门居士共诤？”
    摩诃迦旃延答梵志言：“贪欲系著因缘故，王、王共诤，婆罗门居士、婆罗门居士共诤。”
    梵志复问：“何因何缘，出家、出家而复共诤？”
    摩诃迦旃延答言：“以见欲系著故，出家、出家而复共诤。”
    梵志复问摩诃迦旃延：“颇有能离贪欲系著及离此见欲系著不？”
    尊者摩诃迦旃延答言：“梵志，有。我大师如来、应、等正觉、明行足、善逝、世间解、无上士、调御丈夫、天人师、佛、世尊，能离此贪欲系著及见欲系著。”
    梵志复问：“佛世尊今在何所？”
    答言：“佛世尊今在婆罗耆人中，拘萨罗国舍卫城祇树给孤独园。”
    尔时梵志从座起，整衣服，偏袒右肩，右膝着地，向佛所住处合掌赞叹：“南无南无佛、世尊、如来、应供、等正觉，能离欲贪诸系著，悉能远离贪欲缚，及诸见欲，净根本。”
    时持澡灌杖梵志，闻尊者摩诃迦旃延所说，欢喜随喜，从座起去。

（五四七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尊者摩诃迦旃延在婆罗那乌泥池侧，与众多比丘集于食堂，为持衣事。
    时有执杖梵志，年耆根熟，诣食堂所，于一面柱杖而住。须臾默然已，语诸比丘：“诸长老！汝等何故见老宿士，不共语问讯，恭敬命坐？”
    时尊者摩诃迦旃延亦在众中坐，时尊者摩诃迦旃延语梵志言：“我法有宿老来，皆共语问讯，恭敬礼拜，命之令坐。”
    梵志言：“我见此众中，无有老于我者，不恭敬礼拜命坐。汝云何言，我法见有宿老，恭敬礼拜，命其令坐？”
    摩诃迦旃延言：“梵志，若有耆年八十、九十，发白齿落，成就年少法者，此非宿士。虽复年少，年二十五，色白发黑，盛壮美满，而彼成就耆年法者，为宿士数。”
    梵志问言：“云何名为八十、九十，发白齿落，而复成就年少之法。年二十五，肤白发黑，盛壮美色，为宿士数？”
    尊者摩诃迦旃延语梵志言：“有五欲功德，谓眼识色，爱、乐、念；耳识声、鼻识香、舌识味、身识触，爱、乐、念。于此五欲功德不离贪、不离欲、不离爱、不离念、不离渴。梵志，若如是者，虽复八十、九十，发白齿落，是名成就年少之法。虽年二十五，肤白发黑，盛壮美色，于五欲功德离贪、离欲、离爱、离念、离渴，若如是者，虽复年少，年二十五，肤白发黑，盛壮美色，成就老人法，为宿士数。”
    尔时梵志语尊者摩诃迦旃延：“如尊者所说义，我自省察，虽老则少。汝等虽少，成耆年法。世间多事，今便请还。”
    尊者摩诃迦旃延言：“梵志，汝自知时。”
    尔时梵志闻尊者摩诃迦旃延所说，欢喜随喜，还其本处。

（五四八）

    如是我闻。一时佛住舍卫国祇树给孤独园。尊者摩诃迦旃延在稠林中住。
    时摩偷罗国王，是西方王子，诣尊者摩诃迦旃延所，礼摩诃迦旃延足，退坐一面，问尊者摩诃迦旃延：“婆罗门自言：‘我第一，他人卑劣；我白，余人黑；婆罗门清净，非非婆罗门；是婆罗门子，从口生，婆罗门所化，是婆罗门所有。’尊者摩诃迦旃延，此义云何？”
    尊者摩诃迦旃延语摩偷罗王言：“大王，此是世间言说耳。世间言说，言婆罗门第一，余人卑劣；婆罗门白，余人黑；婆罗门清净，非非婆罗门；是婆罗门，从婆罗门生，生从口生，婆罗门所化，是婆罗门所有。大王当知，业真实者，是依业者。”
    王语尊者摩诃迦旃延：“此则略说，我所不解，愿重分别。”
    尊者摩诃迦旃延言：“今当问汝，随问答我。”即问言：“大王，汝为婆罗门王，于自国土诸婆罗门、刹利、居士、长者，此四种人悉皆召来，以财以力，使其侍卫，先起后卧，及诸使令，悉如意不？”
    答言：“如意。”
    复问：“大王，刹利为王、居士为王、长者为王，于自国土所有四姓悉皆召来，以财以力令其侍卫，先起后卧，及诸使令，皆如意不？”
    答言：“如意。”
    复问：“大王，如是四姓，悉皆平等，有何差别？当知大王，四种姓者，皆悉平等，无有胜如差别之异。”
    摩偷罗王白尊者摩诃迦旃延：“实尔尊者，四姓皆等，无有种种胜如差别。”
    “是故大王，当知四姓，世间言说为差别耳，乃至依业真实，无差别也。复次大王，此国土中有婆罗门，有偷盗者，当如之何？
    王白尊者摩诃迦旃延：“婆罗门中有偷盗者，或鞭，或缚，或驱出国，或罚其金，或截手、足、耳、鼻，罪重则杀。及其盗者，然婆罗门则名为贼。”
    复问：“大王，若刹利、居士、长者中有偷盗者，当复如何？”
    王白尊者摩诃迦旃延：“亦鞭，亦缚，亦驱出国，亦罚其金，亦复断截手、足、耳、鼻，罪重则杀。”
    “如是大王，岂非四姓悉平等耶？为有种种差别异不？”
    王白尊者摩诃迦旃延：“如是义者，实无种种胜如差别。”
    尊者摩诃迦旃延复语王言：“当知大王，四种姓者，世间言说，言婆罗门第一，余悉卑劣；婆罗门白，余人悉黑；婆罗门清净，非非婆罗门；婆罗门生，生从口生，婆罗门作，婆罗门化，婆罗门所有。当依业，真实业依耶？”
    复问：“大王，婆罗门杀生、偷盗、邪淫、妄言、恶口、两舌、绮语、贪、恚、邪见，作十不善业迹已，为生恶趣耶，善趣耶？于阿罗呵所，为何所闻？”
    王白尊者摩诃迦旃延：“婆罗门作十不善业迹，当堕恶趣。阿罗呵所，作如是闻。”
    刹利、居士、长者，亦如是说。
    复问：“大王，若婆罗门行十善业迹，离杀生，乃至正见，当生何所？为善趣耶，为恶趣耶？于阿罗呵所，为何所闻？”
    王白尊者摩诃迦旃延：“若婆罗门行十善业迹者，当生善趣。阿罗呵所，作如是闻。”
    如是刹利、居士、长者，亦如是说。
    复问：“云何大王，如是四姓为平等不？为有种种胜如差别耶？”
    王白尊者摩诃迦旃延：“如是义者，则为平等，无有种种胜如差别。”
    “是故大王，当知四姓悉平等耳，无有种种胜如差别。世间言说故，有婆罗门第一，婆罗门白，余者悉黑；婆罗门清净，非非婆罗门；婆罗门生，生从口生，婆罗门作，婆罗门化，婆罗门所有。当知业真实、业依。”
    王白尊者摩诃迦旃延：“实如所说，皆是世间言说故，有婆罗门胜，余者卑劣；婆罗门白，余者悉黑；婆罗门清净，非非婆罗门；婆罗门生，生从口生，婆罗门化，婆罗门所有。皆是业真实，依于业。”
    尔时摩偷罗王闻尊者摩诃迦旃延所说，欢喜随喜，作礼而去。

（五四九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者摩诃迦旃延住阿槃提国拘罗罗咤精舍。
    尊者摩诃迦旃延晨朝着衣持钵，入拘罗罗咤精舍，次第乞食，至迦梨迦优婆夷舍。
    时优婆夷见尊者摩诃迦旃延，即敷床坐，请令就坐。前礼尊者摩诃迦旃延足，退住一面，白尊者摩诃迦旃延：“如世尊所说答僧耆多童女所问，如世尊说僧耆多童女所问偈：

“实义存于心，寂灭而不乱，
降伏诸勇猛，可爱端正色。
一心独静思，服食妙禅乐，
是则为远离，世间之伴党，
世间诸伴党，无习近我者。

    “尊者摩诃迦旃延，世尊此偈，其义云何？”
    尊者摩诃迦旃延语优婆夷言：“姊妹！有一沙门、婆罗门言：‘地一切入处正受，此则无上，为求此果。’姊妹！若沙门、婆罗门于地一切入处正受，清净鲜白者，则见其本、见患、见灭、见灭道迹。以见本、见患、见灭、见灭道迹故，得真实义存于心，寂灭而不乱。姊妹！如是水一切入处、火一切入处、风一切入处、青一切入处、黄一切入处、赤一切入处、白一切入处、空一切入处、识一切入处，为无上者，为求此果。姊妹！若有沙门、婆罗门乃至于识处一切入处正受，清净鲜白者，见本、见患、见灭、见灭道迹。以见本、见患、见灭、见灭道迹故，是则实义存于心，寂灭而不乱，善见、善入。是故世尊答僧耆多童女所问偈：

“实义存于心，寂灭而不乱，
降伏诸勇猛，可爱端正色。
一心独静思，服食妙禅乐，
是则为远离，世间之伴党，
世间诸伴党，无习近我者。

    “如是姊妹！我解世尊以如是义故，说如是偈。”
    优婆夷言：“善哉尊者！说真实义。唯愿尊者受我请食。”
    时尊者摩诃迦旃延默然受请。
    时迦梨迦优婆夷知尊者摩诃迦旃延受请已，即办种种净美饮食，恭敬尊重，自手奉食。时优婆夷知尊者摩诃迦旃延食已，洗钵、澡嗽讫，敷一卑座，于尊者摩诃迦旃延前恭敬听法。
    尊者摩诃迦旃延为迦梨迦优婆夷种种说法，示教照喜，示教照喜已，从座起而去。

（五五○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者摩诃迦旃延在舍卫国祇树给孤独园。
    尊者摩诃迦旃延语诸比丘：“佛、世尊、如来、应、等正觉所知所见，说六法，出苦处升于胜处，说一乘道，净诸众生，离诸恼苦，忧悲悉灭，得真如法。
    “何等为六？谓圣弟子念如来、应、等正觉所行法，念如来、应、等正觉、明行足、善逝、世间解、无上士、调御丈夫、天人师、佛、世尊。圣弟子念如来应所行法故，离贪欲觉、离瞋恚觉、离害觉，如是圣弟子出染著心。何等为染著心？谓五欲功德。于此五欲功德，离贪、恚、痴，安住正念正智，乘于直道，修习念佛，正向涅槃。是名如来、应、等正觉所知所见，说第一出苦处升于胜处，一乘道净于众生，离苦恼，灭忧悲，得如实法。
    “复次圣弟子念于正法，念于世尊现法律，离诸热恼，非时通达，即于现法缘自觉悟。尔时圣弟子念此正法时，不起欲觉、瞋恚、害觉，如是圣弟子出染著心。何等为染著心？谓五欲功德。于此五欲功德，离贪、恚、痴，安住正念正知，乘于直道，修习念法，正向涅槃。是名如来、应、等正觉所知所见，说第二出苦处升于胜处，一乘道净于众生，离苦恼，灭忧悲，得如实法。
    “复次圣弟子念于僧法，善向、正向、直向、等向，修随顺行，谓向须陀洹，得须陀洹果，向斯陀含，得斯陀含，向阿那含，得阿那含，向阿罗汉，得阿罗汉，如是四双八士，是名世尊弟子僧戒具足、定具足、慧具足、解脱具足、解脱知见具足，供养恭敬礼拜处，世间无上福田。圣弟子如是念僧时，尔时圣弟子不起欲觉、瞋恚、害觉，如是圣弟子出染著心。何等为染著心？谓五欲功德。于此五欲功德，离贪、恚、痴，安住正念正知，乘于直道，修习念僧，正向涅槃。是名如来、应、等正觉所知所见，说第三出苦处升于胜处，一乘道净于众生，离苦恼，灭忧悲，得如实法。
    “复次圣弟子念于戒德，念不缺戒、不断戒、纯厚戒、不离戒、非盗取戒、善究竟戒、可赞叹戒、梵行、不憎恶戒。若圣弟子念此戒时，自念身中所成就戒，当于尔时不起欲觉、瞋恚、害觉，如是圣弟子出染著心。何等为染著心？谓五欲功德。于此五欲功德，离贪、恚、痴，安住正念正知，乘于直道，修戒念，正向涅槃。是名如来、应、等正觉所知所见，说第四出苦处升于胜处，一乘道净于众生，离苦恼，灭忧悲，得如实法。
    “复次圣弟子自念施法，心自欣庆，我今离悭贪垢，虽在居家，解脱心施、常施、舍施、乐施、具足施、平等施。若圣弟子念于自所施法时，不起欲觉、瞋恚、害觉，如是圣弟子出染著心。于何染著？谓五欲功德。于此五欲功德，离贪、恚、痴，安住正念正知，乘于直道，修施念，正向涅槃。是名如来、应、等正觉所知所见，说第五出苦处升于胜处，一乘道净于众生，离苦恼，灭忧悲，得如实法。
    “复次圣弟子念于天德，念四王天、三十三天，炎摩天、兜率陀天、化乐天、他化自在天，清净信心，于此命终，生彼诸天；我亦如是信、戒、施、闻、慧，于此命终，生彼天中。如是圣弟子念天功德时，不起欲觉、瞋恚、害觉，如是圣弟子出染著心。于何染著？谓五欲功德。于此五欲功德，离贪、恚、痴，安住正念正知，乘于直道，修天念，正向涅槃。是名如来、应、等正觉所知所见，说第六出苦处升于胜处，一乘道净于众生，离苦恼，灭忧悲，得如实法。”
    尊者摩诃迦旃延说此经已，诸比丘闻其所说，欢喜奉行。

（五五一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者摩诃迦旃延住释氏诃梨聚落精舍。
    时诃梨聚落长者诣尊者摩诃迦旃延所，稽首礼足，退坐一面，白尊者摩诃迦旃延：“如世尊《义品》答摩揵提所问偈：

“断一切诸流，亦塞其流源，
聚落相习近，牟尼不称叹。
虚空于五欲，永以不还满，
世间诤言讼，毕竟不复为。

    “尊者摩诃迦旃延，此偈有何义？”
    尊者摩诃迦旃延答长者言：“眼流者，眼识起贪，依眼界贪欲流出，故名为流。耳、鼻、舌、身、意流者，谓意识起贪，依意界贪识流出，故名为流。”
    长者复问尊者摩诃迦旃延：“云何名为不流？”
    尊者迦旃延语长者言：“谓眼识、眼识所识色，依生爱喜，彼若尽、无欲、灭、息、没，是名不流。耳、鼻、舌、身、意、意识、意识所识法，依生贪欲，彼若尽、无欲、灭、息、没，是名不流。”
    复问：“云何？”
    尊者摩诃迦旃延答言：“谓缘眼及色，生眼识，三事和合生触，缘触生受，乐受、苦受、不苦不乐受，依此染著流。耳、鼻、舌、身、意、意识、意识法，三事和合生触，缘触生受，乐受、苦受、不苦不乐受，依此受生爱喜流，是名流源。”
    “云何亦塞其流源？”
    “谓眼界取心法境界系著使，彼若尽、无欲、灭、息、没，是名塞流源。耳、鼻、舌、身、意取心法境界系著使，彼若尽、无欲、灭、息、没，是名亦塞其流源。”
    复问：“云何名习近相赞叹？”
    尊者摩诃迦旃延答言：“在家、出家共相习近，同喜同忧，同乐同苦，凡所为作，悉皆共同，是名习近相赞叹。”
    复问：“云何不赞叹？”
    “在家、出家不相习近，不同喜，不同忧，不同苦，不同乐，凡所为作，悉不相悦可，是名不相赞叹。”
    “云何不空欲？”
    “谓五欲功德，眼识色，爱、乐、念，长养爱欲，深染著。耳声、鼻香、舌味、身触，爱、乐、念，长养爱欲，深染著。于此五欲，不离贪，不离爱，不离念，不离渴，是名不空欲。”
    “云何名空欲？”
    “谓于此五欲功德，离贪、离欲、离爱、离念、离渴，是名空欲。说我系著使，是名心法还复满。彼阿罗汉比丘诸漏已尽，断其根本，如截多罗树头，于未来世更不复生，云何当复与他诤讼？是故世尊说《义品》答摩揵提所问偈：

“若断一切流，亦塞其流源，
聚落相习近，牟尼不称叹。
虚空于诸欲，永已不还满，
不复与世间，共言语诤讼。

    “是名如来所说偈义分别也。”
    尔时诃梨聚落长者闻尊者摩诃迦旃延所说，欢喜随喜，作礼而去。

（五五二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者摩诃迦旃延住释氏诃梨聚落精舍。
    时诃梨聚落主长者诣尊者摩诃迦旃延所，稽首礼足，退坐一面，白尊者摩诃迦旃延：“如世尊于界隔山天帝释石窟说言：‘憍尸迦，若沙门、婆罗门无上爱尽解脱，心正善解脱，究竟边际，究竟无垢，究竟梵行，毕竟清净。’云何于此法律究竟边际，究竟无垢，究竟梵行，毕竟清净？”
    尊者摩诃迦旃延语长者言：“谓眼、眼识、眼识所识色，相依生喜，彼若尽、无欲、灭、息、没，于此法律究竟边际，究竟无垢，究竟梵行，毕竟清净。耳、鼻、舌、身、意、意识、意识所识法，相依生喜，彼若尽、灭、息、没，比丘于此法律究竟无垢，究竟梵行，毕竟清净。”
    时诃梨聚落主长者闻尊者摩诃迦旃延所说，欢喜随喜，作礼而去。

（五五三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者摩诃迦旃延在释氏诃梨聚落。
    时聚落主长者诣尊者摩诃迦旃延所，稽首礼足，退坐一面，问尊者摩诃迦旃延：“如世尊界隔山石窟中为天帝释说言：‘憍尸迦，若沙门、婆罗门无上爱尽解脱，心善解脱，边际究竟，究竟无垢，究竟梵行，毕竟清净。’云何于此法律究竟边际，究竟无垢，究竟梵行，毕竟清净？”
    尊者迦旃延语长者言：“若比丘眼界取心法境界系著使，彼若尽、无欲、灭、息、没，于此法律究竟边际，究竟无垢，究竟梵行，毕竟清净。耳、鼻、舌、身、意、意界取心法境界系著使，若尽、离、灭、息、没，于此法律究竟边际，究竟无垢，究竟梵行，毕竟清净。”
    时诃梨聚落主长者闻尊者摩诃迦旃延所说，欢喜随喜，作礼而去。

（五五四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者摩诃迦旃延住释氏诃梨聚落。
    时诃梨聚落主长者身遭病苦。尊者摩诃迦旃延闻诃梨聚落主长者身遭病苦，闻已晨朝着衣持钵，入诃梨聚落乞食，次第入诃梨聚落主长者舍。诃梨聚落主长者遥见尊者摩诃迦旃延，从座欲起。
    尊者摩诃迦旃延见长者欲起，即告之言：“长者莫起！幸有余座，我自可坐于余座。”
    语长者言：“云何长者，病可忍不？身诸苦痛，渐瘥愈不？得无增耶？”
    长者答言：“尊者，我病难忍，身诸苦痛转增无损。”即说三种譬，如前《叉摩比丘经》说。
    尊者摩诃迦旃延语长者言：“是故汝当修佛不坏净、法不坏净、僧不坏净、圣戒成就，当如是学。”
    长者答言：“如佛所说四不坏净，我悉成就，我今成就佛不坏净、法不坏净、僧不坏净、圣戒成就。”
    尊者摩诃迦旃延语长者言：“汝当依此四不坏净，修习六念。
    “长者！当念佛功德，此如来、应、等正觉、明行足、善逝、世间解、无上士、调御丈夫、天人师、佛、世尊。
    “念法功德，于世尊正法律，现法离诸热恼，非时通达，缘自觉悟。
    “念僧功德，善向、正向、直向、等向，修随顺行，谓向须陀洹，得须陀洹，向斯陀含，得斯陀含，向阿那含，得阿那含，向阿罗汉，得阿罗汉。如是四双八士，是名世尊弟子僧，具足戒、定、慧、解脱、解脱知见，供养恭敬尊重之处，堪为世间无上福田。
    “念戒功德，自持正戒，不毁不缺，不断不坏，非盗取戒、究竟戒、可赞叹戒、梵行戒、不憎恶戒。
    “念施功德，自念布施，心自欣庆，舍除悭贪，虽在居家，解脱心施、常施、乐施、具足施、平等施。
    “念天功德，念四王天、三十三天、炎摩天、兜率陀天、化乐天、他化自在天，清净信戒，于此命终，生彼天中；我亦如是清净信、戒、施、闻、慧，生彼天中。长者！如是觉依四不坏净，增六念处。”
    长者白尊者摩诃迦旃延：“世尊说依四不坏净，增六念处，我悉成就。我当修习念佛功德，念法、念僧、念戒、念施、念天。”
    尊者摩诃迦旃延语长者言：“善哉长者！能自记说，得阿那含。”
    是时长者白尊者摩诃迦旃延：“愿于此食。”
    尊者摩诃迦旃延默然受请。诃梨聚落主长者知尊者摩诃迦旃延受请已，具种种净美食，自手供养。饭食讫，澡钵洗嗽毕，为长者种种说法，示教照喜，示教照喜已，从座起去。

（五五五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者摩诃迦旃延于释氏诃梨聚落住。
    时有八城长者名曰陀施，身遭病苦。
    尊者摩诃迦旃延闻陀施长者身遭苦患，晨朝着衣持钵，入八城乞食，次到陀施长者舍。
    如《诃梨长者经》广说。

（五五六）

    如是我闻。一时佛住娑祇城安禅林中。
    尔时众多比丘尼诣佛所，稽首礼足，退住一面。
    尔时世尊为众多比丘尼种种说法，示教照喜，示教照喜已，默然住。
    时诸比丘尼白佛言：“世尊，若无相心三昧，不涌不没，解脱已住，住已解脱。此无相心三昧，世尊说是何果、何功德？”
    佛告诸比丘尼：“若无相心三昧，不涌不没，解脱已住，住已解脱。此无相心三昧，智果、智功德。”
    时诸比丘尼闻世尊所说，欢喜随喜，作礼而去。
    时众多比丘尼往诣尊者阿难所，稽首礼足，退坐一面，白尊者阿难：“若无相心三昧，不涌不没，解脱已住，住已解脱。此三昧说是何果、何功德？”
    尊者阿难语诸比丘尼：“姊妹！若无相心三昧，不涌不没，解脱已住，住已解脱，世尊说是智果、智功德。”
    诸比丘尼言：“奇哉尊者阿难！大师及弟子同句、同味、同义，所谓第一句义。今诸比丘尼诣世尊所，以如是句、如是味、如是义问世尊，世尊亦以如是句、如是味、如是义为我等说，如尊者阿难所说不异。是故奇特，大师及弟子同句、同味、同义。”
    时诸比丘尼闻尊者阿难所说，欢喜随喜，作礼而去。

（五五七）

    如是我闻。一时佛住拘睒弥国瞿师罗园。
    尔时尊者阿难亦在彼住。
    时有阇知罗比丘尼诣尊者阿难所，稽首礼足，退坐一面，问尊者阿难：“若无相心三昧，不涌不没，解脱已住，住已解脱。尊者阿难，世尊说此何果、何功德？”
    尊者阿难语阇知罗比丘尼：“若无相心三昧，不涌不没，解脱已住，住已解脱，世尊说是智果、智功德。”
    阇知罗比丘尼言：“奇哉尊者阿难！大师及弟子同句、同味、同义。尊者阿难，昔于一时佛在娑祇城安禅林中，时有众多比丘尼往诣佛所，问如此义。尔时世尊以如是句、如是味、如是义，为诸比丘尼说。是故当知奇特，大师、弟子所说，同句、同味、同义，所谓第一句义。”
    时阇知罗比丘尼闻尊者阿难所说，欢喜随喜，作礼而去。
    如阇知罗比丘尼，迦罗跋比丘尼亦尔。

（五五八）

    如是我闻。一时佛住俱睒弥国瞿师罗园。
    尔时尊者阿难亦住俱睒弥国瞿师罗园。
    时有异比丘得无相心三昧，作是念：“我若诣尊者阿难所，问尊者阿难：‘若比丘得无相心三昧，不涌不没，解脱已住，住已解脱。此无相心三昧何果？世尊说此何功德？’尊者阿难若问我言：‘比丘，汝得此无相心三昧耶？’我未曾有实问异答。我当随逐尊者阿难，脱有余人问此义者，因而得闻。”
    彼比丘即随尊者阿难，经六年中，无有余人问此义者。即自问尊者阿难：“若比丘问无相心三昧，不涌不没，解脱已住，住已解脱，世尊说此是何果、何功德？”
    尊者阿难问彼比丘言：“比丘，汝得此三昧？”
    彼比丘默然住。
    尊者阿难语彼比丘言：“若比丘得无相心三昧，不涌不没，解脱已住，住已解脱，世尊说此是智果、智功德。”
    尊者阿难说此法时，异比丘闻其所说，欢喜奉行。


杂阿含经卷第二十一

（五五九）

    如是我闻。一时佛住波罗利弗妒路国。
    尊者阿难及尊者迦摩，亦在波罗利弗妒路鸡林精舍。
    时尊者迦摩诣尊者阿难所，共相问讯慰劳已，于一面坐，语尊者阿难：“奇哉尊者阿难！有眼有色，有耳有声，有鼻有香，有舌有味，有身有触，有意有法，而有比丘有是等法，能不觉知。云何尊者阿难，彼比丘为有想不觉知，为无想故不觉知？”
    尊者阿难语迦摩比丘言：“有想者亦不觉知，况复无想。”
    复问尊者阿难：“何等为有想，于有而不觉知？”
    尊者阿难语迦摩比丘言：“若比丘离欲恶不善法，有觉有观，离生喜乐，初禅具足住，如是有想比丘，有法而不觉知。如是第二、第三、第四禅、空入处、识入处、无所有入处具足住，如是有想比丘，有法而不觉知。云何无想，有法而不觉知？如是比丘一切想不忆念，无想心三昧，身作证具足住，是名比丘无想，于有法而不觉知。”
    尊者迦摩比丘复问尊者阿难：“若比丘无想心三昧，不涌不没，解脱已住，住已解脱。世尊说此是何果、何功德？”
    尊者阿难语迦摩比丘言：“若比丘无想心三昧，不涌不没，解脱已住，住已解脱，世尊说此是智果、智功德。”
    时二正士共论议已，欢喜随喜，各从座起去。

（五六○）

    如是我闻。一时佛住俱睒弥国瞿师罗园。
    尔时尊者阿难亦在彼住，时尊者阿难告诸比丘：“若比丘、比丘尼于我前自记说，我当善哉慰劳问讯，或求以四道。
    “何等为四？若比丘、比丘尼坐作如是住心，善住心、局住心、调伏心、止观一心、等受分别，于法量度，修习多修习已，得断诸使。若有比丘、比丘尼于我前自记说，我则如是善哉慰喻，或求是名说初道。
    “复次，比丘、比丘尼正坐思惟，于法选择思量住心，善住、局住、调伏、止观一心等受，如是正向多住，得离诸使。若有比丘、比丘尼于我前自记说，我当如是善哉慰喻，或求是名第二说道。
    “复次，比丘、比丘尼为掉乱所持，以调伏心坐，正坐住心，善住心、局住心、调伏、止观一心等受化，如是正向多住已，则断诸使。若有比丘、比丘尼于我前自记说，我则如是善哉慰喻，或求是名第三说道。
    “复次，比丘、比丘尼止观和合俱行，作如是正向多住，则断诸使。若比丘、比丘尼于我前自记说者，我则如是善哉慰喻教诫，或求是名第四说道。”
    时诸比丘闻尊者阿难所说，欢喜奉行。

（五六一）

    如是我闻。一时佛住俱睒弥国瞿师罗园。
    尊者阿难亦在彼住。
    时有异婆罗门诣尊者阿难所，共相问讯慰劳已，于一面坐，问尊者阿难：“何故于沙门瞿昙所修梵行？”
    尊者阿难语婆罗门：“为断故。”
    复问：“尊者何所断？”
    答言：“断爱。”
    复问：“尊者阿难，何所依而得断爱？”
    答言：“婆罗门，依于欲而断爱。”
    复问：“尊者阿难，岂非无边际？”
    答言：“婆罗门，非无边际，如是有边际，非无边际。”
    复问：“尊者阿难，云何有边际，非无边际？”
    答言：“婆罗门，我今问汝，随意答我。婆罗门，于意云何，汝先有欲来诣精舍不？”
    婆罗门答言：“如是，阿难。”
    “如是婆罗门，来至精舍已，彼欲息不？”
    答言：“如是，尊者阿难，彼精进、方便、筹量，来诣精舍。”
    复问：“至精舍已，彼精进、方便、筹量息不？”
    答言：“如是。”
    尊者阿难复语婆罗门：“如是婆罗门，如来、应、等正觉所知所见，说四如意足，以一乘道，净众生、灭苦恼、断忧悲。何等为四？欲定断行成就如意足，精进定、心定、思惟定断行成就如意足。如是圣弟子修欲定断行成就如意足，依离、依无欲、依出要、依灭、向于舍，乃至断爱，爱断已，彼欲亦息。修精进定、心定、思惟定断行成就，依离、依无欲、依出要、依灭、向于舍，乃至爱尽，爱尽已，思惟则息。婆罗门，于意云何，此非边际耶？”
    婆罗门言：“尊者阿难，此是边际，非不边际。”
    尔时婆罗门闻尊者阿难所说，欢喜随喜，从座起去。

（五六二）

    如是我闻。一时佛住拘睒弥国瞿师罗园。
    尊者阿难亦在彼住。
    尔时瞿师罗长者诣尊者阿难所，稽首礼足，退坐一面，白尊者阿难：“云何名为世间说法者？云何名世间善向？云何名世间善到？”
    尊者阿难语瞿师罗长者：“我今问汝，随意答我。长者，于意云何？若有说法，调伏贪欲、调伏瞋恚、调伏愚痴，得名世间说法者不？”
    长者答言：“尊者阿难，若有说法，能调伏贪欲、瞋恚、愚痴，是则名为世间说法。”
    复问：“长者，于意云何？若世间向，调伏贪欲、调伏瞋恚、调伏愚痴，是名世间善向。若世间已调伏贪欲、瞋恚、愚痴，是名善到耶，为非耶？”
    长者答言：“尊者阿难，若调伏贪欲，已断无余，瞋恚、愚痴已断无余，是名善到。”
    尊者阿难答言：“长者，我试问汝，汝便真实答我。其义如此，当受持之。”
    瞿师罗长者闻尊者阿难所说，欢喜随喜，作礼而去。

（五六三）

    如是我闻。一时佛住毗舍离猕猴池侧重阁讲堂。
    尊者阿难亦在彼住。
    尔时无畏离车，是尼揵弟子。聪明童子离车，是阿耆毗弟子。俱往尊者阿难所，共相问讯慰劳已，于一面坐。
    时无畏离车语尊者阿难：“我师尼揵子，灭炽然，清净超出，为诸弟子说如是道：‘宿命之业，行苦行故，悉能吐之。身业不作，断截桥梁，于未来世无复诸漏，诸业永尽。业永尽故，众苦永尽。苦永尽故，究竟苦边。’尊者阿难，此义云何？”
    尊者阿难语离车言：“如来、应、等正觉所知所见，说三种离炽然，清净超出道，以一乘道，净众生、离忧悲、越苦恼，得真如法。
    “何等为三？如是圣弟子住于净戒，受波罗提木叉，威仪具足，信于诸罪过，生怖畏想。受持如是具足净戒，宿业渐吐，得现法离炽然，不待时节，能得正法，通达现见观察，智慧自觉。离车长者，是名如来、应、等正觉说所知所见，说离炽然，清净超出，以一乘道，净众生、灭苦恼、越忧悲，得真如法。
    “复次离车，如是净戒具足，离欲恶不善法，乃至第四禅具足住，是名如来、应、等正觉，说离炽然，乃至得如实法。
    “复有三昧正受，于此苦圣谛如实知，此苦集圣谛、苦灭圣谛、苦灭道迹圣谛如实知。具足如是智慧，心业更不造，宿业渐已断，得现正法，离诸炽然，不待时节，通达现见，生自觉智。离车，是名如来、应、等正觉所知所见，说第三离炽然，清净超出，以一乘道，净众生、离苦恼、灭忧悲，得如实法。”
    尔时尼揵弟子离车无畏，默然住。
    尔时阿耆毗弟子离车聪慧，重语离车无畏言：“怪哉无畏！何默然住？于如来、应、等正觉所说，所知所见善说法，闻不随喜耶？”
    离车无畏答言：“我思惟其义，故默然住耳。谁闻世尊沙门瞿昙所说法不随喜者？若有闻沙门瞿昙说法而不随喜者，此则愚夫，长夜当受非义不饶益苦。”
    时尼揵弟子离车无畏、阿耆毗弟子聪慧，重闻佛所说法，尊者阿难陀所说，欢喜随喜，从座起去。

（五六四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尊者阿难亦在彼住。
    时有异比丘尼，于尊者阿难所，起染著心，遣使白尊者阿难：“我身遇病苦，唯愿尊者哀愍见看。”
    尊者阿难晨朝着衣持钵，往彼比丘尼所。彼比丘尼遥见尊者阿难来，露身体卧床上。
    尊者阿难遥见彼比丘尼身，即自摄敛诸根，回身背住。彼比丘尼见尊者阿难摄敛诸根，回身背住，即自惭愧，起着衣服，敷坐具，出迎尊者阿难，请令就座，稽首礼足，退坐一面。
    时尊者阿难为说法言：“姊妹，如此身者，秽食长养、骄慢长养、爱所长养、淫欲长养。姊妹，依秽食者，当断秽食；依于慢者，当断骄慢；依于爱者，当断爱欲。
    “姊妹，云何名依于秽食，当断秽食？谓圣弟子于食，计数思惟而食，无著乐想、无骄慢想、无摩拭想、无庄严想，为持身故、为养活故、治饥渴病故、摄受梵行故，宿诸受令灭，新诸受不生，崇习长养，若力、若乐、若触，当如是住。譬如商客，以酥油膏以膏其车，无染著想、无骄慢想、无摩拭想、无庄严想，为运载故。如病疮者，涂以酥油，无染著想、无骄慢想、无摩拭想、无庄严想，为疮愈故。如是圣弟子计数而食，无染著想、无骄慢想、无摩拭想、无庄严想，为养活故、治饥渴故、摄受梵行故，宿诸受离，新诸受不起，若力、若乐、若无罪触，安隐住。姊妹，是名依食断食。
    “依慢断慢者，云何依慢断慢？谓圣弟子闻某尊者、某尊者弟子，尽诸有漏，无漏心解脱、慧解脱，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。闻已作是念：彼圣弟子尽诸有漏，乃至自知不受后有，我今何故不尽诸有漏？何故不自知不受后有？当于尔时，则能断诸有漏，乃至自知不受后有。姊妹，是名依慢断慢。
    “姊妹，云何依爱断爱？谓圣弟子闻某尊者、某尊者弟子，尽诸有漏，乃至自知不受后有。我等何不尽诸有漏，乃至自知不受后有？彼于尔时，能断诸有漏，乃至自知不受后有。姊妹，是名依爱断爱。姊妹，无所行者，断截淫欲和合桥梁。”
    尊者阿难说是法时，彼比丘尼远尘离垢，得法眼净。彼比丘尼见法、得法、觉法、入法，度狐疑，不由于他，于正法律心得无畏。礼尊者阿难足，白尊者阿难：“我今发露悔过，愚痴不善，脱作如是不流类事。今于尊者阿难所，自见过，自知过，发露忏悔，哀愍故！”
    尊者阿难语比丘尼：“汝今真实自见罪，自知罪，愚痴不善。汝自知作不类之罪，汝今自知自见而悔过，于未来世得具足戒。我今受汝悔过，哀愍故，令汝善法增长，终不退减。所以者何？若有自见罪，自知罪，能悔过者，于未来世得具足戒，善法增长，终不退减。”
    尊者阿难为彼比丘尼种种说法，示教照喜已，从座起去。

（五六五）

    如是我闻。一时佛在桥池人间游行，与尊者阿难俱，至婆头聚落国北身恕林中。
    尔时婆头聚落诸童子，闻尊者阿难桥池人间游行，住婆头聚落国北身恕林中。闻已相呼聚集，往诣尊者阿难所，稽首礼尊者阿难足，退坐一面。
    时尊者阿难语诸童子言：“苦种！如来、应、等正觉说四种清净：戒清净、心清净、见清净、解脱清净。
    “云何为戒净断？谓圣弟子住于戒，波罗提木叉戒增长，威仪具足，于微细罪能生恐怖，受持学戒。戒身不满者能令满足，已满者随顺执持，欲精进方便超出，精勤勇猛堪能，诸身心法常能摄受，是名戒净断。
    “苦种！云何名为心净断？谓圣弟子离欲恶不善法，乃至第四禅具足住。定身未满者令满，已满者随顺执受，欲精进乃至常执受，是名心净断。
    “苦种！云何名为见净断？谓圣弟子闻大师说法，如是如是说法，则如是如是入如实正观，如是如是得欢喜、得随喜、得从于佛。复次圣弟子不闻大师说法，然从余明智尊重梵行者说，闻尊重梵行者如是如是说，则如是如是入如实观察，如是如是观察，于彼法得欢喜、随喜，信于正法。复次圣弟子不闻大师说法，亦复不闻明智尊重梵行者说，随先所闻受持者重诵习，随先所闻受持者如是如是重诵已，如是如是得入彼法，乃至信于正法。复次圣弟子不闻大师说法，不闻明智尊重梵行者说，又复不能先所受持重诵习，然先所闻法为人广说，先所闻法如是如是为人广说，如是如是得入于法，正智观察，乃至信于正法。复次圣弟子不闻大师说法，复不闻明智尊重梵行者说，又复不能先所受持重诵习，亦复不以先所闻法为人广说，然于先所闻法，独一静处，思惟观察，如是如是思惟观察，如是如是得入正法，乃至信于正法。如是从他闻，内正思惟，是名未起正见令起，已起正见令增广，是名未满慧身令满，已满者随顺摄受，欲精进方便，乃至常摄受，是名见净断。
    “苦种！云何为解脱清净断？谓圣弟子贪心无欲解脱，恚、痴心无欲解脱。如是解脱，未满者令满，已满者随顺摄受，欲精进乃至常摄受，是名解脱净断。苦种！”
    尊者阿难说是法时，婆头聚落诸童子闻尊者阿难所说，欢喜随喜，作礼而去。

（五六六）

    如是我闻。一时佛住庵罗聚落庵罗林中，与众上座比丘俱。
    时有质多罗长者诣诸上座比丘，稽首礼足，退坐一面。时诸上座比丘为质多罗长者种种说法，示教照喜。种种说法，示教照喜已，默然住。
    时质多罗长者稽首礼诸上座比丘足，往诣那伽达多比丘房，稽首礼那伽达多比丘足，退坐一面。
    时那伽达多比丘问质多罗长者：“如所说：

“枝青以白覆，一辐转之车，
离结观察来，断流不复缚。

    “长者，此偈有何义？”
    质多罗长者言：“尊者那伽达多，世尊说此偈耶？”
    答言：“如是。”
    质多罗长者语尊者那伽达多言：“尊者，须臾默然，我当思惟此义。”
    须臾默然思惟已，语尊者那伽达多言：“青者，谓戒也。白覆，谓解脱也。一辐者，身念也。转者，转出也。车者，止观也。离结者，有三种结，谓贪、恚、痴；彼阿罗汉诸漏已尽、已灭、已知、已断根本，如截多罗树头，更不复生，未来世成不起法。观察者，谓见也。来者，人也。断流者，爱流于生死，彼阿罗汉比丘诸漏已尽、已知，断其根本，如截多罗树头，不复生，于未来世成不起法。不缚者，谓三缚，贪欲缚、瞋恚缚、愚痴缚；彼阿罗汉比丘诸漏已尽、已断、已知，断其根本，如截多罗树头，更不复生，于未来世成不起法。是故尊者那伽达多，世尊说此偈：

“枝青以白覆，一辐转之车，
离结观察来，断流不复缚。

    “此世尊所说偈，我已分别也。”
    尊者那伽达多问质多罗长者言：“此义汝先闻耶？”
    答言：“不闻。”
    尊者那伽达多言：“长者，汝得善利，于此甚深佛法，贤圣慧眼得入。”
    时质多罗长者闻尊者那伽达多所说，欢喜随喜，作礼而去。

（五六七）

    如是我闻。一时佛住庵罗聚落庵罗林精舍，与众多上座比丘俱。
    时有质多罗长者诣诸上座比丘所，稽首礼足，退坐一面。时诸上座比丘为质多罗长者种种说法，示教照喜，示教照喜已，默然住。
    时质多罗长者诣尊者那伽达多比丘所，稽首礼足，退坐一面。
    尊者那伽达多告质多罗长者：“有无量心三昧、无相心三昧、无所有心三昧、空心三昧。云何长者，此法为种种义故种种名？为一义有种种名？”
    质多罗长者问尊者那伽达多：“此诸三昧，为世尊所说，为尊者自意说耶？”
    尊者那伽达多答言：“此世尊所说。”
    质多罗长者语尊者那伽达多：“听我小思惟此义，然后当答。”
    须臾思惟已，语尊者那伽达多：“有法种种义、种种句、种种味，有法一义、种种味。”
    复问长者：“云何有法种种义、种种句、种种味？”
    长者答言：“无量三昧者，谓圣弟子心与慈俱，无怨、无憎、无恚，宽弘重心，无量修习普缘，一方充满。如是二方、三方、四方、上下，一切世间，心与慈俱，无怨、无憎、无恚，宽弘重心，无量修习，充满诸方，一切世间普缘住，是名无量三昧。云何为无相三昧？谓圣弟子于一切相不念，无相心三昧身作证，是名无相心三昧。云何无所有心三昧？谓圣弟子度一切无量识入处，无所有，无所有心住，是名无所有心三昧。云何空三昧？谓圣弟子世间空，世间空如实观察，常住不变易，非我、非我所，是名空心三昧。是名为法种种义、种种句、种种味。”
    复问长者：“云何法一义、种种味？”
    答言：“尊者，谓贪有量，若无诤者第一无量。谓贪者是有相，恚、痴者是有相，无诤者是无相。贪者是所有，恚、痴者是所有，无诤者是无所有。复次无诤者空，于贪空，于恚、痴空，常住不变易空，非我、非我所，是名法一义、种种味。”
    尊者那伽达多问言：“云何长者，此义汝先所闻耶？”
    答言：“尊者，不闻。”
    复告长者：“汝得大利，于甚深佛法，现圣慧眼得入。”
    质多罗长者闻尊者那伽达多所说，欢喜随喜，作礼而去。

（五六八）

    如是我闻。一时佛住庵罗聚落庵罗林中，与诸上座比丘俱。
    时有质多罗长者诣诸上座比丘所，礼诸上座已，诣尊者伽摩比丘所，稽首礼足，退坐一面，白尊者伽摩比丘：“所谓行者，云何名行？”
    伽摩比丘言：“行者，谓三行，身行、口行、意行。”
    复问：“云何身行？云何口行？云何意行？”
    答言：“长者，出息、入息名为身行；有觉、有观名为口行；想、思名为意行。”
    复问：“何故出息、入息名为身行？有觉、有观名为口行？想、思名为意行？”
    答：“长者，出息、入息是身法，依于身、属于身、依身转，是故出息、入息名为身行。有觉、有观故则口语，是故有觉、有观是口行。想、思是意行，依于心、属于心、依心转，是故想、思是意行。”
    复问：“尊者，觉、观已，发口语，是觉、观名为口行。想、思是心数法，依于心、属于心、相转，是故想、思名为意行。”
    复问：“尊者，有几法？若人舍身时，彼身尸卧地，弃于丘冢间，无心如木石？”
    答言：“长者，寿暖及与识，舍身时俱舍，彼身弃冢间，无心如木石。”
    复问：“尊者，若死、若入灭尽正受，有差别不？”
    答：“舍于寿暖，诸根悉坏，身命分离，是名为死。灭尽定者，身、口、意行灭，不舍寿命，不离于暖，诸根不坏，身命相属。此则命终、入灭正受，差别之相。”
    复问：“尊者，云何入灭正受？”
    答言：“长者，入灭正受，不言我入灭正受，我当入灭正受。然先作如是渐息方便，如先方便，向入正受。”
    复问：“尊者，入灭正受时，先灭何法？为身行，为口行，为意行耶？”
    答言：“长者，入灭正受者，先灭口行，次身行，次意行。”
    复问：“尊者，云何为出灭正受？”
    答言：“长者，出灭正受者，亦不念言我今出正受，我当出正受。然先已作方便心，如其先心而起。”
    复问：“尊者，起灭正受者，何法先起？为身行，为口行，为意行耶？”
    答言：“长者，从灭正受起者，意行先起，次身行，后口行。”
    复问：“尊者，入灭正受者，云何顺趣、流注、浚输？”
    答言：“长者，入灭正受者，顺趣于离、流注于离、浚输于离，顺趣于出、流注于出、浚输于出，顺趣涅槃、流注涅槃、浚输涅槃。”
    复问：“尊者，住灭正受时，为触几触？”
    答言：“长者，触不动，触无相，触无所有。”
    复问：“尊者，入灭正受时，为作几法？”
    答言：“长者，此应先问，何故今问？然当为汝说：比丘入灭正受者，作于二法，止以观。”
    时质多罗长者闻尊者迦摩所说，欢喜随喜，作礼而去。

（五六九）

    如是我闻。一时佛住庵罗聚落庵罗林中，与众多上座比丘俱。
    时质多罗长者诣诸上座比丘所，稽首礼足，于一面坐。诸上座比丘为质多罗长者种种说法，示教照喜，示教照喜已，默然住。
    时质多罗长者从座起，偏袒右肩，右膝着地，合十指掌，请诸上座言：“唯愿诸尊，受我薄食。”
    时诸上座默然受请。
    时彼长者知诸上座默然受请已，礼足而去，还归自家，办种种饮食。敷床座，晨朝遣使白：“时到。”
    时诸上座着衣持钵，至长者舍，就座而坐。
    长者稽首礼诸上座足，于一面坐，白诸上座：“所谓种种界，云何为种种界？”
    时诸上座默然而住，如是再三。
    尔时尊者梨犀达多，众中下坐，白诸上座比丘言：“诸尊者，我欲答彼长者所问。”
    诸上座答言：“可。”
    长者质多罗即问言：“尊者，所谓种种界，何等种种界？”
    梨犀达多答言：“长者，眼界异，色界异，眼识界异；耳界异，声界异，耳识界异；鼻界异，香界异，鼻识界异；舌界异，味界异，舌识界异；身界异，触界异，身识界异；意界异，法界异，意识界异。如是长者，是名种种界。”
    尔时质多罗长者下种种净美饮食，供养众僧。食已，澡嗽、洗钵讫，质多罗长者敷一卑床，于上座前坐听法。
    尔时上座为长者种种说法，示教照喜已，从座起去。
    时诸上座于路中语梨犀达多：“善哉善哉！梨犀达多比丘，汝真辩捷，知事而说。若于余时，汝应常如此应。”
    时诸上座闻梨犀达多所说，欢喜奉行。

（五七○）

    如是我闻。一时佛住庵罗聚落庵罗林中，与众多上座比丘俱。
    时质多罗长者诣诸上座所，稽首礼足，退坐一面，白诸上座言：“诸世间所见，或说有我，或说众生，或说寿命，或说世间吉凶。云何尊者，此诸异见，何本、何集、何生、何转？”
    时诸上座默然不答，如是三问，亦三默然。
    时有一下座比丘名梨犀达多，白诸上座言：“我欲答彼长者所问。”
    诸上座言：“善能答者答。”
    时长者即问梨犀达多：“尊者，凡世间所见，何本、何集、何生、何转？”
    尊者梨犀达多答言：“长者，凡世间所见，或言有我，或说众生，或说寿命，或说世间吉凶。斯等诸见，一切皆以身见为本，身见集、身见生、身见转。”
    复问：“尊者，云何为身见？”
    答言：“长者，愚痴无闻凡夫见色是我、色异我、色中我、我中色；受、想、行、识见是我、识异我、我中识、识中我。长者，是名身见。”
    复问：“尊者，云何得无此身见？”
    答言：“长者，谓多闻圣弟子不见色是我，不见色异我，不见我中色，色中我；不见受、想、行、识是我，不见识异我，不见我中识，识中我，是名得无身见。”
    复问：“尊者，其父何名，于何所生？”
    答言：“长者，我生于后方长者家。”
    质多罗长者语尊者梨犀达多：“我及尊者二父，本是善知识。”
    梨犀达多答言：“如是，长者。”
    质多罗长者语梨犀达多言：“尊者若能住此庵罗林中，我尽形寿供养衣服、饮食、随病汤药。”
    尊者梨犀达多默然受请。时尊者梨犀达多受质多罗长者请，供养障碍故，久不诣世尊所。
    时诸上座比丘为质多罗长者种种说法，示教照喜。示教照喜已，质多罗长者欢喜随喜，作礼而去。

（五七一）

    如是我闻。一时佛住庵罗聚落庵罗林中，与众多上座比丘俱。
    时有质多罗长者诣诸上座所，稽首礼足，退坐一面，白诸上座比丘言：“唯愿诸尊，于牛牧中受我请食。”
    时诸上座默然受请。
    质多罗长者知诸上座默然受请已，既自还家，星夜备具种种饮食。晨朝敷座，遣使白诸上座：“时到。”
    诸上座着衣持钵，至牛牧中质多罗长者舍，就座而坐。时质多罗长者自手供养种种饮食。食已，洗钵、澡漱毕，质多罗长者敷一卑床，于上座前坐听法。
    时诸上座为长者说种种法，示教照喜，示教照喜已，从座起去。质多罗长者亦随后去。
    诸上座食诸酥酪蜜饱满，于春后月热时，行路闷极。
    尔时有一下座比丘名摩诃迦，白诸上座：“今日大热，我欲起云雨微风，可尔不？”
    诸上座答言：“汝能尔者佳！”
    时摩诃迦即入三昧，如其正受，应时云起，细雨微下，凉风亹亹，从四方来。
    至精舍门，尊者摩诃迦语诸上座言：“所作可止？”
    答言：“可止。”
    时尊者摩诃迦即止神通，还于自房。
    时质多罗长者作是念：“最下座比丘而能有此大神通力，况复中座及与上座。”即礼诸上座比丘足，随摩诃迦比丘至所住房，礼尊者摩诃迦足，退坐一面，白言：“尊者，我欲得见尊者过人法，神足现化。”
    尊者摩诃迦言：“长者，勿见恐怖。”
    如是三请，亦三不许。
    长者犹复重请：“愿见尊者神通变化。”
    尊者摩诃迦语长者言：“汝且出外，取干草木积聚已，以一张氎覆上。”
    质多罗长者即如其教，出外聚薪成积，来白尊者摩诃迦：“薪积已成，以氎覆上。”
    时尊者摩诃迦即入火光三昧，于户钩孔中出火焰光，烧其积薪都尽，唯白氎不燃。语长者言：“汝今见不？”
    答言：“已见，尊者，实为奇特！”
    尊者摩诃迦语长者言：“当知此者，皆以不放逸为本，不放逸集，不放逸生，不放逸转。不放逸故，得阿耨多罗三藐三菩提。是故长者，此及余功德，一切皆以不放逸为本，不放逸集，不放逸生，不放逸转。不放逸故，得阿耨多罗三藐三菩提，及余道品法。”
    质多罗长者白尊者摩诃迦：“愿常住此林中，我当尽寿供养衣被、饮食、随病汤药。”
    尊者摩诃迦有行因缘故，不受其请。
    质多罗长者闻说法已，欢喜随喜，即从座起，作礼而去。
    尊者摩诃迦不欲令供养利障罪故，即从座起去，遂不复还。

（五七二）

    如是我闻。一时佛住庵罗林中，与众多上座比丘俱。
    尔时众多上座比丘集于食堂，作如是论议：“诸尊，于意云何，谓眼系色耶？色系眼耶？如是耳声、鼻香、舌味、身触、意法，为意系法耶？法系意耶？”
    时质多罗长者行有所营，便过精舍，见诸上座比丘集于食堂，即便前礼诸上座足，礼足已，问言：“尊者集于食堂，论说何法？”
    诸上座答言：“长者，我等今日集此食堂，作如此论：为眼系色耶？色系眼耶？如是耳声、鼻香、舌味、身触、意法，为意系法耶？为法系意耶？”
    长者问言：“诸尊者于此义云何记说？”
    诸上座言：“于长者意云何？”
    长者答诸上座言：“如我意，谓非眼系色，非色系眼，乃至非意系法，非法系意。然中间有欲贪者，随彼系也。譬如二牛，一黑一白，驾以轭鞅。有人问言：‘为黑牛系白牛？为白牛系黑牛？’为等问不？”
    答言：“长者，非等问也。所以者何？非黑牛系白牛，亦非白牛系黑牛，然彼轭鞅是其系也。”
    “如是尊者，非眼系色，非色系眼，乃至非意系法，非法系意。然于中间，欲贪是其系也。”
    时质多罗长者闻诸上座所说，欢喜随喜，作礼而去。

（五七三）

    如是我闻。一时佛住庵罗林中。
    时有阿耆毗外道，是质多罗长者先人亲厚，来诣质多罗长者所，共相问讯慰劳已，于一面住。
    质多罗长者问阿耆毗外道：“汝出家几时？”
    答言：“长者，我出家已来二十余年。”
    质多罗长者问言：“汝出家来过二十年，为得过人法，究竟知见，安乐住不？”
    答言：“长者，虽出家过二十年，不得过人法，究竟知见，安乐住。唯有裸形、拔发、乞食，人间游行，卧于土中。”
    质多罗长者言：“此非名称法律，此是恶知，非出要道，非曰等觉，非赞叹处，不可依止。唐名出家，过二十年，裸形、拔发、乞食，人间游行，卧灰土中。”
    阿耆毗问质多罗长者：“汝为沙门瞿昙作弟子，于今几时？”
    质多罗长者答言：“我为世尊弟子，过二十年。”
    复问质多罗长者：“汝为沙门瞿昙弟子，过二十年，复得过人法，胜究竟知见不？”
    质多罗长者答言：“汝今当知，质多罗长者要不复经由胞胎而受生，不复增于丘冢，不复起于血气。如世尊所说五下分结，不见一结而不断者。若一结不断，当复还生此世。”
    如是说时，阿耆毗迦悲叹涕泪，以衣拭面，谓质多罗长者言：“我今当作何计？”
    质多罗长者答言：“汝若能于正法律出家者，我当给汝衣钵、供身之具。”
    阿耆毗迦须臾思惟已，语质多罗长者言：“我今随汝，示我所作。”
    时质多罗长者，将彼阿耆毗迦，往诣诸上座所，礼诸上座足，于一面坐，白诸上座比丘言：“尊者，此阿耆毗迦，是我先人亲厚，今求出家作比丘。愿诸上座度令出家，我当供给衣钵众具。”
    诸上座即令出家，剃除须发，着袈裟衣。出家已，思惟所以善男子剃除须发，着袈裟衣，出家增进学道，净修梵行，得阿罗汉。

（五七四）

    如是我闻。一时佛住庵罗聚落庵罗林中，与诸上座比丘俱。
    时有尼揵若提子，与五百眷属，诣庵罗林中，欲诱质多罗长者以为弟子。
    质多罗长者闻尼揵若提子将五百眷属来诣庵罗林中，欲诱我为弟子，闻已即往诣其所，共相问讯毕，各于一面坐。
    时尼揵若提子语质多罗长者言：“汝信沙门瞿昙，得无觉无观三昧耶？”
    质多罗长者答言：“我不以信故来也。”
    尼揵若提子言：“长者，汝不谄、不幻、质直、质直所生。长者，若能息有觉有观者，亦能以绳系缚于风。若能息有觉有观者，亦可以一把土断恒水流。我于行、住、坐、卧，智见常生。”
    质多罗长者问尼揵若提子：“为信在前耶？为智在前耶？信之与智，何者为先？何者为胜？”
    尼揵若提子答言：“信应在前，然后有智。信、智相比，智则为胜。”
    质多罗长者语尼揵若提子：“我已求得息有觉有观，内净一心，无觉无观三昧生喜乐，第二禅具足住。我昼亦住此三昧，夜亦住此三昧，终夜常住此三昧。有如是智，何用信世尊为？”
    尼揵若提子言：“汝谄曲、幻伪、不直、不直所生。”
    质多罗长者言：“汝先言我不谄曲、不幻、质直、质直所生，今云何言谄曲、幻伪、不直、不直所生耶？若汝前实者，后则虚。后实者，前则虚。汝先言：‘我于行、住、坐、卧，知见常生。’汝于前后小事不知，云何知过人法，若知、若见、若安乐住事？”
    长者复问尼揵若提子：“有于一问、一说、一记论，乃至十问、十说、十记论，汝有此不？若无一问、一说、一记论，乃至十问、十说、十记论，云何能诱于我？而来至此庵罗林中，欲诱诳我？”
    于是尼揵若提子息闭掉头，反拱而出，不复还顾。

（五七五）

    如是我闻。一时佛住庵罗聚落庵罗林中，与众多上座比丘俱。
    尔时质多罗长者病苦，诸亲围绕。
    有众多诸天，来诣长者所，语质多罗长者言：“长者！汝当发愿得作转轮王。”
    质多罗长者语诸天言：“若作转轮王，彼亦无常、苦、空、无我。”
    时长者亲属语长者：“汝当系念！汝当系念！”
    质多罗长者语亲属：“何故汝等教我系念系念？”
    彼亲属言：“汝作是言：无常、苦、空、无我。是故教汝系念系念也。”
    长者语诸亲属：“有诸天人来至我所，语我言：‘汝当发愿得作转轮圣王，随愿得果。’我即答言：‘彼转轮王亦复无常、苦、空、非我。’”
    彼诸亲属语质多罗长者：“转轮王有何，而彼诸天教汝愿求？”
    长者答言：“转轮王者，以正法治化。是故诸天见如是福利故，而来教我为发愿求。”
    诸亲属言：“汝今用心，当如之何？”
    长者答言：“诸亲属，我今作心，唯不复见胞胎受生，不增丘冢，不受血气。如世尊说五下分结，我不见有，我不自见一结不断。若结不断，则还生此世。”
    于是长者即从床起，结跏趺坐，正念在前，而说偈言：

“服食积所积，广度于众难，
施上进福田，植斯五种力。
以斯义所欲，俗人处于家，
我悉得此利，已免于众难。
世间所闻习，远离众难事，
生乐知稍难，随顺等正觉。
供养持戒者，善修诸梵行，
漏尽阿罗汉，及声闻牟尼。
如是超越见，于上诸胜处，
常行士夫施，克终获大果。
习行众多施，施诸良福田，
于此世命终，化生于天上。
五欲具足满，无量心悦乐，
获斯妙果报，以无悭吝故，
在所处受生，未曾不欢喜。”

    质多罗长者说此偈已，寻即命终，生于不烦热天。
    尔时质多罗天子作是念：“我不应停此，当往阎浮提礼拜诸上座比丘。”如力士屈伸臂顷，以天神力至庵罗林中，放身天光，遍照庵罗林。
    时有异比丘夜起出房，露地经行，见胜光明普照树林，即说偈言：

“是谁妙天色，住于虚空中，
譬如纯金山，阎浮檀净光。”

    质多罗天子说偈答言：

“我是天人王，瞿昙名称子，
是庵罗林中，质多罗长者。
以净戒具足，系念自寂静，
解脱身具足，智慧身亦然。
我知法故来，仁者应当知，
当于彼涅槃，此法法如是。”

    质多罗天子说此偈已，即没不现。


杂阿含经卷第二十二

（五七六）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈白佛：

“不处难陀林，终不得快乐，
忉利天宫中，得天帝名称。”

    尔时世尊说偈答言：

“童蒙汝何知，阿罗汉所说，
一切行无常，是则生灭法，
生者既复灭，俱寂灭为乐。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（五七七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子即说偈言：

“断一切钩锁，牟尼无有家，
沙门著教化，我不说善哉。”

    尔时世尊说偈答言：

“一切众生类，悉共相缠缚，
其有智慧者，孰能不愍伤？
善逝哀愍故，常教授众生，
哀愍众生者，是法之所应。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，即没不现。

（五七八）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“常习惭愧心，此人时时有，
能远离诸恶，如顾鞭良马。”

    尔时世尊说偈答言：

“常习惭愧心，此人实希有，
能远离诸恶，如顾鞭良马。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖悉过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（五七九）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“不习近正法，乐著诸邪见，
睡眠不自觉，长劫心能悟。”

    尔时世尊说偈答言：

“专修于正法，远离不善业，
是漏尽罗汉，险恶世平等。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖悉过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（五八○）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“以法善调伏，不随于诸见，
虽复著睡眠，则能随时悟。”

    尔时世尊说偈答言：

“若以法调伏，不随余异见，
无知已究竟，能度世恩爱。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（五八一）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“若罗汉比丘，自所作已作，
一切诸漏尽，持此后边身，
记说言有我，及说我所不？”

    尔时世尊即说偈答：

“若罗汉比丘，自所作已作，
一切诸漏尽，持此后边身，
正复说有我，我所亦无咎。”

    时彼天子复说偈言：

“若罗汉比丘，自所作已作，
一切漏已尽，持此最后身，
心依于我慢，而说言有我，
及说于我所，有如是说不？”

    尔时世尊说偈答言：

“已离于我慢，无复我慢心，
超越我我所，我说为漏尽。
于彼我我所，心已永不著，
善解世名字，平等假名说。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（五八二）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子说偈白佛：

“若罗汉比丘，漏尽持后身，
颇说言有我，及说我所不？”

    尔时世尊说偈答言：

“若罗汉比丘，漏尽持后身，
亦说言有我，及说有我所。”

    时彼天子复说偈言：

“若罗汉比丘，自所作已作，
已尽诸有漏，唯持最后身，
何言说有我，说何是我所？”

    尔时世尊说偈答言：

“若罗汉比丘，自所作已作，
一切诸漏尽，唯持最后身，
说我漏已尽，亦不著我所，
善解世名字，平等假名说。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（五八三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时罗睺罗阿修罗王，障月天子。
    时诸月天子，悉皆恐怖，来诣佛所，稽首佛足，退住一面，说偈叹佛：

“今礼最胜觉，能脱一切障，
我今遭苦恼，是故来归依。
我等月天子，归依于善逝，
佛哀愍世间，愿解阿修罗！”

    尔时世尊说偈答言：

“破坏诸暗冥，光明照虚空，
今毗卢遮那，清净光明显，
罗睺避虚空，速放飞兔像！
罗睺阿修罗，即舍月而还，
举体悉流汗，战怖不自安，
神昏志迷乱，犹如重病人。”

    时有阿修罗名曰婆稚，见罗睺罗阿修罗疾舍月还，便说偈言：

“罗睺阿修罗，舍月一何速，
神体悉流汗，犹如重病人！”

    罗睺罗阿修罗说偈答言：

“瞿昙说咒偈，不速舍月者，
或头破七分，受诸邻死苦。”

    婆稚阿修罗复说偈言：

“佛兴未曾有，安隐于世间，
说咒偈能令，罗睺罗舍月。”

    佛说此经已，时月天子闻佛所说，欢喜随喜，作礼而去。

（五八四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“为有族本不？有转生族耶？
有俱相属无？云何解于缚？”

    尔时世尊说偈答言：

“我无有族本，亦无转生族，
俱相属永断，解脱一切缚。”

    时彼天子复说偈言：

“何名为族本？云何转生族？
云何俱相属？何名为坚缚？”

    尔时世尊说偈答言：

“母为世族本，妻名转生族，
子俱是相属，爱欲为坚缚。
我无此族本，亦无转生族，
俱相属亦无，是名脱坚缚。”

    时彼天子复说偈言：

“善哉无族本，无生族亦善，
善哉无相属，善哉缚解脱！
久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（五八五）

    如是我闻。一时佛住释氏优罗提那塔所。
    尔时世尊新剃须发，于后夜时，结跏趺坐，直身正意，系念在前，以衣覆头。
    时优罗提那塔边有天神住，放身光明，遍照精舍，白佛言：“沙门忧耶？”
    佛告天神：“何所忘失？”
    天神复问：“沙门为欢喜耶？”
    佛告天神：“为何所得？”
    天神复问：“沙门不忧不喜耶？”
    佛告天神：“如是如是。”
    尔时天神即说偈言：

“为离诸烦恼？为无有欢喜？
云何独一住，非不乐所坏？”

    尔时世尊说偈答言：

“我无恼解脱，亦无有欢喜，
不乐不能坏，故独一而住。”

    时彼天神复说偈言：

“云何得无恼？云何无欢喜？
云何独一住，非不乐所坏？”

    尔时世尊说偈答言：

“烦恼生欢喜，喜亦生烦恼，
无恼亦无喜，天神当护持。”

    时彼天神复说偈言：

“善哉无烦恼，善哉无欢喜，
善哉独一住，不为不喜坏！
久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天神闻佛所说，欢喜随喜，稽首佛足，即没不现。

（五八六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“犹如利剑害，亦如头火燃，
断除贪欲火，正念求远离。”

    尔时世尊说偈答言：

“譬如利剑害，亦如头火燃，
断除于后身，正念求远离。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（五八七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“天女众围绕，如毗舍脂众，
痴惑丛林中，何由而得出？”

    尔时世尊说偈答言：

“正直平等道，离恐怖之方，
乘寂默之车，法想为密覆，
惭愧为长縻，正念为羁络，
智慧善御士，正见为前导。
如是之妙乘，男女之所乘，
出生死丛林，逮得安乐处。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（五八八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“有四轮九门，充满贪欲住，
深溺淤泥中，大象云何出？”

    尔时世尊说偈答言：

“断爱喜长縻，贪欲等诸恶，
拔爱欲根本，正向于彼处。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（五八九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“赖吒槃提国，有诸商贾客，
大富足财宝，各各竞求富，
方便欲财利，犹如燃炽火。
如是竞胜心，欲贪常驰骋，
云何当断贪，息世间勤求？”

    尔时世尊说偈答言：

“舍俗出非家，妻子及财宝，
贪恚痴离欲，罗汉尽诸漏，
正智心解脱，爱尽息方便。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（五九○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过去世时，拘萨罗国有诸商人，五百乘车共行治生，至旷野中。旷野有五百群贼，在后随逐，伺便欲作劫盗。
    “时旷野中有一天神，止住路侧，时彼天神作是念：‘当往诣彼拘萨罗国诸商人所，问其义理。若彼商人喜我所问，时解说者，我当方便令其安隐，得脱贼难。若不喜我所问者，当放舍之，如余天神。’时彼天神作是念已，即放身光，遍照商人车营，而说偈言：

‘谁于觉睡眠？谁复睡眠觉？
谁有解此义？谁能为我说？’

    “尔时商人中有一优婆塞，信佛、信法、信比丘僧，一心向佛、法、僧，归依佛、法、僧，于佛离疑，于法、僧离疑，于苦、集、灭、道离疑，见四圣谛，得第一无间等果，在商人中，与诸商人共为行侣。彼优婆塞于后夜时，端坐思惟，系念在前，于十二因缘逆顺观察：所谓是事有故是事有，是事起故是事起，谓缘无明行，缘行识，缘识名色，缘名色六入处，缘六入处触，缘触受，缘受爱，缘爱取，缘取有，缘有生，缘生老死忧悲恼苦，如是纯大苦聚集。如是无明灭则行灭，行灭则识灭，识灭则名色灭，名色灭则六入处灭，六入处灭则触灭，触灭则受灭，受灭则爱灭，爱灭则取灭，取灭则有灭，有灭则生灭，生灭则老死忧悲恼苦灭，如是如是纯大苦聚灭。
    “时彼优婆塞如是思惟已，而说偈言：

‘我于觉睡眠，我于睡眠觉，
我解知此义，能为人记说。’

    “时彼天神问优婆塞：

‘云何觉睡眠？云何睡眠觉？
云何能解知？云何能记说？’

    “时优婆塞说偈答言：

‘贪欲及瞋恚，愚痴得离欲，
漏尽阿罗汉，正智心解脱，
彼则为觉悟，我于彼睡眠。
不知因生苦，及苦因缘集，
于此一切苦，得无余灭尽，
又不知正道，等趣息苦处，
斯等为常眠，我于彼则觉。
如是觉睡眠，如是睡眠觉，
如是善知义，如是能记说。’

    “时彼天神复说偈言：

‘善哉觉睡眠，善哉眠中觉，
善哉解知义，善哉能记说！
久远乃今见，诸兄弟而来，
缘汝恩力故，令诸商人众，
得免于劫贼，随道安乐去。’

    “如是诸比丘，彼拘萨罗泽中诸商人众，皆得安隐，从旷野出。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五九一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过去世时，海洲上优婆塞至他优婆塞舍会坐，极毁呰欲，言：‘此欲者虚妄不实，欺诳之法，犹如幻化，诳于婴儿。’还自己舍，恣于五欲。
    “是优婆塞舍有天神止住，时彼天神作是念：‘是优婆塞不胜不类，于余优婆塞舍会坐众中极毁呰欲，言如是欲者虚伪不实，欺诳之法，如诳婴儿。还己舍已，自恣五欲。我今宁可发令觉悟。’而说偈言：

‘于大聚会中，毁呰欲无常，
自没于爱欲，如牛溺深泥。
我观彼会中，诸优婆塞等，
多闻明解法，奉持于净戒。
汝见彼乐法，而说欲无常，
如何自恣欲，不断于贪爱？
何故乐世间，畜妻子眷属？’

    “时彼天神如是如是开觉彼优婆塞已，如是如是彼优婆塞觉悟已，剃除须发，着袈裟衣，正信非家，出家学道，精勤修习，尽诸有漏，得阿罗汉。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五九二）

    如是我闻。一时佛住王舍城寒林中丘冢间。
    时给孤独长者有小因缘，至王舍城，止宿长者舍。夜见长者告其妻子、仆使、作人言：“汝等皆起，破樵燃火，炊饭作饼，调和众味，庄严堂舍。”
    给孤独长者见已作是念：“今此长者何所为作，为嫁女娶妇耶？为请宾客、国王、大臣耶？”念已即问长者：“汝何所作，为嫁女娶妇，为请宾客、国王、大臣耶？”
    时彼长者答给孤独长者言：“我不嫁女娶妇，亦不请呼国王、大臣。唯欲请佛及比丘僧，设供养耳。”
    时给孤独长者闻未曾闻佛名字已，心大欢喜，身诸毛孔皆悉怡悦，问彼长者言：“何名为佛？”
    长者答言：“有沙门瞿昙，是释种子，于释种中剃除须发，着袈裟衣，正信非家，出家学道，得阿耨多罗三藐三菩提，是名为佛。”
    给孤独长者言：“云何名僧？”
    彼长者言：“若婆罗门种，剃除须发，着袈裟衣，信家非家，而随佛出家；或刹利种、毗舍种、首陀罗种善男子等，剃除须发，着袈裟衣，正信非家，彼佛出家而随出家，是名为僧。今日请佛及现前僧，设诸供养。”
    给孤独长者问彼长者言：“我今可得往见世尊不？”
    彼长者答言：“汝且住此，我请世尊来至我舍，于此得见。”
    时给孤独长者即于其夜，至心念佛，因得睡眠。天犹未明，忽见明相，谓天已晓，欲出其舍，行向城门。至城门下，夜始二更，城门未开。王家常法，待远使命来往，至初夜尽，城门乃闭。中夜已尽，辄复开门，欲令行人早得往来。尔时给孤独长者见城门开，而作是念：“定是夜过，天晓门开。”乘明相出于城门，出城门已，明相即灭，辄还暗冥。
    给孤独长者心即恐怖，身毛为竖：“得无为人及非人，或奸妖人，恐怖我耶？”即便欲还。
    尔时城门侧有天神住，时彼天神即放身光，从其城门至寒林丘冢间，光明普照，告给孤独长者言：“汝且前进，可得胜利，慎勿退还！”
    时彼天神即说偈言：

“善良马百匹，黄金满百斤，
骡车及马车，各各有百乘，
种种诸珍奇，重宝载其上，
宿命种善根，得如此福报。
若人宗重心，向佛行一步，
十六分之一，过前福之上。

    “是故长者，汝当前进，慎勿退还！”
    即复说偈：

“雪山大龙象，纯金为庄饰，
巨身长大牙，以此象施人，
不及向佛福，十六分之一。

    “是故长者，当速前进，得其大利，非退还也。”
    复说偈言：

“金菩阇国女，其数有百人，
种种众妙宝，璎珞具庄严。
以此持施与，不及行向佛，
一步之功德，十六分之一。

    “是故长者，当速前进，得其胜利，非退还也。”
    时给孤独长者问天神言：“贤者，汝是何人？”
    天神答言：“我是摩头息揵大摩那婆，先是长者善知识。于尊者舍利弗、大目揵连所，起信敬心，缘斯功德，今得生天，典此城门。是故告长者，但当进前，慎莫退还，前进得利，非退还也。”
    时给孤独长者作是念：“佛兴于世，非为小事。得闻正法，亦非小事。是故天神劝我令进，往见世尊。”
    时给孤独长者寻其光明，径至寒林丘冢间。尔时世尊出房，露地经行。给孤独长者遥见佛已，即至其前，以俗人礼法，恭敬问讯：“云何世尊，安隐卧不？”
    尔时世尊说偈答言：

“婆罗门涅槃，是则常安乐，
爱欲所不染，解脱永无余。
断一切希望，调伏心炽然，
心得寂止息，止息安隐眠。”

    尔时世尊将给孤独长者往入房中，就座而坐，端身系念。尔时世尊为其说法，示教照喜已，世尊说诸法无常，宜布施福事、持戒福事、生天福事，欲味、欲患、欲出远离之福。
    给孤独长者闻法、见法、得法、入法、解法，度诸疑惑，不由他信，不由他度，入正法律，心得无畏。即从座起，正衣服，为佛作礼，右膝着地，合掌白佛言：“已度，世尊！已度，善逝！我从今日，尽其寿命，归佛、归法、归比丘僧，为优婆塞，证知我！”
    尔时世尊问给孤独长者：“汝名何等？”
    长者白佛：“名须达多，以常给孤贫辛苦故，时人名我为给孤独。”
    世尊复问：“汝居何处？”
    长者白佛言：“世尊，在拘萨罗人间，城名舍卫。唯愿世尊来舍卫国，我当尽寿供养衣被、饮食、房舍、床卧、随病汤药。”
    佛问长者：“舍卫国有精舍不？”
    长者白佛：“无也，世尊。”
    佛告长者：“汝可于彼建立精舍，令诸比丘往来宿止。”
    长者白佛：“但使世尊来舍卫国，我当造作精舍、僧房，令诸比丘往来止住。”
    尔时世尊默然受请。
    时长者知佛世尊默然受请已，从座起，稽首佛足而去。

（五九三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时给孤独长者疾病命终，生兜率天，为兜率天子，作是念：“我不应久住于此，当往见世尊。”作是念已，如力士屈伸臂顷，于兜率天没，现于佛前，稽首佛足，退坐一面。时给孤独天子身放光明，遍照祇树给孤独园。
    时给孤独天子而说偈言：

“于此祇桓林，仙人僧住止，
诸王亦住此，增我欢喜心。
深信净戒业，智慧为胜寿，
以此净众生，非族姓财物。
大智舍利弗，正念常寂默，
闲居修远离，初建业良友。”

    说此偈已，即没不现。
    尔时世尊其夜过已，入于僧中，敷尼师坛，于众前坐，告诸比丘：“今此夜中，有一天子容色绝妙，来诣我所，稽首我足，退坐一面，而说偈言：

“于此祇桓林，仙人僧住止，
诸王亦住此，增我欢喜心。
深信净戒业，智慧为胜寿，
以此净众生，非族姓财物。
大智舍利弗，正念常寂默，
闲居修远离，初建业良友。”

    尔时尊者阿难白佛言：“世尊，如我解世尊所说，给孤独长者生彼天上，来见世尊，然彼给孤独长者于尊者舍利弗极相敬重。”
    佛告阿难：“如是如是，阿难。给孤独长者生彼天上，来见于我。”
    尔时世尊以尊者舍利弗故，而说偈言：

“一切世间智，唯除于如来，
比舍利弗智，十六不及一。
如舍利弗智，天人悉同等，
比于如来智，十六不及一。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（五九四）

    如是我闻。一时佛住旷野精舍。
    时有旷野长者疾病命终，生无热天。生彼天已，即作是念：“我今不应久于此住，不见世尊。”作是念已，如力士屈伸臂顷，从无热天没，现于佛前。时彼天子，天身委地，不能自立。犹如酥油委地，不能自立。如是彼天子天身细软，不自持立。
    尔时世尊告彼天子：“汝当变化作此粗身，而立于地。”
    时彼天子即自化形，作此粗身，而立于地。于是天子前礼佛足，退坐一面。
    尔时世尊告手天子：“汝手天子，本于此间为人身时，所受经法，今故忆念不悉忘耶？”
    手天子白佛言：“世尊，本所受持，今悉不忘。本人间时，有所闻法，不尽得者，今亦忆念。如世尊善说，世尊说言：‘若人安乐处，能忆持法，非为苦处。’此说真实。如世尊在阎浮提，种种杂类，四众围绕，而为说法，彼诸四众闻佛所说，皆悉奉行。我亦如是，于无热天上，为诸天人大会说法，彼诸天众悉受修学。”
    佛告手天子：“汝于此人间时，于几法无厌足故，而得生彼无热天中？”
    手天子白佛：“世尊，我于三法无厌足故，身坏命终，生无热天。何等三法？我于见佛无厌足故，身坏命终生无热天；我于闻法无厌足故，生无热天；供养众僧无厌足故，身坏命终，生无热天。”
    时手天子即说偈言：

“见佛无厌足，闻法亦无厌，
供养于众僧，亦未曾知足。
受持贤圣法，调伏悭著垢，
三法不知足，故生无热天。”

    时手天子闻佛所说，欢喜随喜，即没不现。

（五九五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有无烦天子，容色绝妙，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“生彼无烦天，解脱七比丘，
贪瞋恚已尽，超世度恩爱。
谁度于诸流，难度死魔军？
谁断死魔縻，永超烦恼轭？”

    尔时世尊说偈答言：

“尊者优波迦，及波罗揵茶，
弗迦罗娑梨，跋提揵陀叠，
亦婆休难提，及波毗瘦[少/兔]，
如是等一切，悉皆度诸流。
断绝死魔縻，度彼难度者，
断诸死魔縻，超越诸天轭。
说甚深妙法，觉悟难知者，
巧便问深义，汝今为是谁？”

    时彼天子说偈白佛：

“我是阿那含，生彼无烦天，
故能知斯等，解脱七比丘，
尽贪欲瞋恚，永超世恩爱。”

    尔时世尊复说偈言：

“眼耳鼻舌身，第六意入处，
若彼名及色，得无余灭尽。
能知此诸法，解脱七比丘，
贪有悉已尽，永超世恩爱。”

    时彼天子复说偈言：

“鞞跋楞伽村，我于彼中住，
名难提婆罗，造作诸瓦器。
迦叶佛弟子，持优婆塞法，
供养于父母，离欲修梵行，
世世为我友，我亦彼知识。
如是等大士，宿命共和合，
善修于身心，持此后边身。”

    尔时世尊复说偈言：

“如是汝贤士，如汝之所说，
鞞跋楞伽村，名难提婆罗。
迦叶佛弟子，受优婆塞法，
供养于父母，离欲修梵行，
昔是汝知识，汝亦彼良友。
如是诸正士，宿命共和合，
善修其身心，持此后边身。”

    佛说此经已，时彼天子闻佛所说，欢喜随喜，即没不现。

（五九六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“此世多恐怖，众生常恼乱，
已起者亦苦，未起亦当苦，
颇有离恐处，唯愿慧眼说。”

    尔时世尊说偈答言：

“无有异苦行，无异伏诸根，
无异一切舍，而得见解脱。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（五九七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“云何诸众生，受身得妙色？
云何修方便，而得乘出道？
众生住何法，为何所修习？
为何等众生，诸天所供养？”

    尔时世尊说偈答言：

“持戒明智慧，自修习正受，
正直心系念，炽然忧悉灭。
得平等智慧，其心善解脱。
斯等因缘故，受身得妙色。
成就乘出道，心住于中学，
如是德备者，为诸天供养。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（五九八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“沉没于睡眠，欠呿不欣乐，
饱食心愦闹，懈怠不精勤，
斯十覆众生，圣道不显现。”

    尔时世尊说偈答言：

“心没于睡眠，欠呿不欣乐，
饱食心愦闹，懈怠不精勤，
精勤修习者，能开发圣道。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（五九九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“外缠结非缠，内缠缠众生，
今问于瞿昙，谁于缠离缠？”

    尔时世尊说偈答言：

“智者建立戒，内心修智慧，
比丘勤修习，于缠得解缠。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（六○○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“难度难可忍，沙门无知故，
多起诸艰难，重钝溺沉没，
心随觉自在，数数溺沉没。
沙门云何行，善摄护其心？”

    尔时世尊说偈答言：

“如龟善方便，以壳自藏六，
比丘习禅思，善摄诸觉想。
其心无所依，他莫能恐怖，
是则自隐密，无能诽谤者。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（六○一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“萨罗小流注，当于何反流？
生死之径路，于何而不转？
世间诸苦乐，何由灭无余？”

    尔时世尊说偈答言：

“眼耳鼻舌身，及彼意入处，
名色灭无余，萨罗小还流，
生死道不转，苦乐灭无余。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（六○二）

    如是我闻。一时佛住在舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“伊尼耶鹿腨，仙人中之尊，
少食不嗜味，禅思乐山林。
我今敬稽首，而问于瞿昙，
云何出离苦？云何苦解脱？
我今问解脱，于何而灭尽？”

    尔时世尊说偈答言：

“世间五欲德，心法说第六，
于彼欲无欲，解脱一切苦。
如是于苦出，如是苦解脱，
汝所问解脱，于彼而灭尽。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（六○三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“云何度诸流？云何度大海？
云何能舍苦？云何得清净？”

    尔时世尊即说偈言：

“信能度诸流，不放逸度海，
精进能除苦，智慧得清净。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。


杂阿含经卷第二十三

（六○四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊晨朝着衣持钵，共诸比丘僧入城乞食。如偈所说：

身色如金山，端严甚微妙，
行步如鹅王，面如净满月，
世尊与众俱。

    时世尊以足践城门限地，作六种震动。如偈所说：

大海及大地，城郭并诸山，
牟尼足所践，动摇如浪舟。

    佛变现如是神力，时诸民人高声唱言：“奇特未尝有法，变现神力！如佛世尊，入城示现如是种种未曾有法。”如偈所说：

地下即成平，高地反为下，
由佛威神故，荆棘诸瓦砾，
皆悉不复见。聋盲及喑哑，
即得见闻语。城郭诸乐器，
不击妙音出。

    时彼世尊光相普照，如千日之焰。如偈所说：

世尊身光明，普照城邑中，
民人蒙佛光，凉若栴檀涂。

    时世尊顺邑而行。时彼有两童子，一者上姓，二者次姓，共在沙中嬉戏，一名阇耶，二名毗阇耶。遥见世尊来，三十二大人相庄严其体。时阇耶童子心念言，我当以麦麨，仍手捧细沙，着世尊钵中。时毗阇耶合掌随喜。如偈所说：

见大悲世尊，通身一寻光，
勇颜睹世尊，心生大敬信，
捧沙即奉施，得离生老际。

    时彼童子而发愿言：“以惠施善根功德，令得一天下一伞盖王，即于此生，得供养诸佛。”如偈所说：

牟尼知彼心，及彼意所愿，
受果增善根，及福田力故，
即以大悲心，受其奉施沙。

    时阇耶以此善根，当得为王，王阎浮提，乃至得成无上正觉，故世尊发微笑。
    尔时阿难见世尊发微笑，即便合掌向佛，而白佛言：“世尊，诸佛世尊、阿罗诃、三藐三佛陀，非无因缘而能发微笑。今佛世尊以何因缘而发微笑？”如偈所说：

世尊离调笑，无上世中尊，
齿白如珂玉，最胜今发笑。
勇猛勤精进，无师而自觉，
妙言令乐闻，无上柔软音，
而记彼童子，梵音远清彻，
无上两足尊，记彼施妙果。

    尔时世尊告阿难曰：“如是如是，如汝所说，诸佛无有因缘，亦不发笑。我今笑者，其有因缘。阿难当知，于我灭度百年之后，此童子于巴连弗邑，统领一方，为转轮王，姓孔雀，名阿育，正法治化。又复广布我舍利，当造八万四千法王之塔，安乐无量众生。”如偈所说：

“于我灭度后，是人当作王，
孔雀姓名育，譬如顶生王，
于此阎浮提，独王世所尊。”

    “阿难，取此钵中所施之沙，舍着如来经行处，当行彼处。”
    阿难受教，即取钵沙，舍经行处。
    “阿难当知，于巴连弗邑，有王名曰月护。彼王当生子，名曰频头娑罗，当治彼国。彼复有子，名曰修师摩。
    “时彼瞻婆国有一婆罗门女，极为端正，令人乐见，为国所珍。诸相师辈，见彼女相，即记彼女当为王妃，又生二子，一当领一天下，一当出家学道，当成圣迹。
    “时彼婆罗门闻彼相师所说，欢喜无量，即持其女，诣巴连弗邑，种种庄严，庄严其体，欲嫁与修师摩王子。相师云：‘应嫁与频头娑罗王，彼女当生福德子，子当绍王基。’婆罗门即以其女嫁与此王。王见其女，端正有德，即为夫人。
    “前夫人及诸婇女，见是夫人来，作是念言：‘此女极为端正，国中所珍。王若与彼相娱乐者，弃舍我等，乃至目所不视。’诸女辈即使学习剃毛师业。彼悉学已，为王料理鬓发。料理之时，王大欢喜，即问彼女：‘汝何所求欲？’女启王言：‘唯愿王心爱念我耳。’如是三启。时王言：‘我是刹利灌顶王，汝是剃毛师，云何得爱念汝？’彼女白王言：‘我非是下姓生，乃是高族婆罗门之女。相师语我父云，此女应嫁与国王，是故来至此耳。’王言：‘若然者，谁令汝习下劣之业？’女启王言：‘是旧夫人及婇女令我学此。’王即敕言：‘自今勿复习下业。’王即立为第一夫人。
    “王恒与彼自相娱乐，仍便怀体，月满生子，生时安隐，母无忧恼。过七日后，立字无忧。又复生子，名曰离忧。无忧者，身体粗涩，父王不大附捉，情所不念。
    “父王欲试二子，呼宾伽罗阿时婆罗门言：‘和尚观我诸子，于我灭后，谁当作王？’婆罗门言：‘将此诸子出城，金殿园馆中，于彼当观其相。’乃至出往彼园。
    “时阿育王母语阿育言：‘承王出金殿园馆中，观诸王子，于我灭后，谁当作王。汝今云何不去？’阿育启言：‘王既不念我，亦复不乐见我。’母复言：‘但往彼所。’阿育复启：‘母复敕令往，今便往去，愿母当送饮食。’母言：‘如是，当出城去。’时出门逢一大臣，名曰阿[少/兔]罗陀，此臣问阿育言：‘王子今至何所？’阿育答言：‘闻大王出在金殿园馆，观诸王子，于我灭后，谁当作王。今往诣彼。’王先敕大臣：‘若阿育来者，当使其乘老钝象来，又复老人为眷属。’时阿育乘是老象，乃至园馆中，于诸王子中地坐。时诸王子各下饮食。阿育母以瓦器盛酪饭，送与阿育。如是诸王子各食饮食。
    “时父王问师言：‘此中谁有王相，当绍我位？’时彼相师视诸王子，见阿育具有王相，当得绍位。又作是念：‘此阿育，王所不应。我若语言当作王者，王必愁忧不乐。’即语言：‘我今总记。’王报言：‘如师所教。’师言：‘此中若有乘好乘者，是人当作王。’时诸王子闻彼所说，各念言：‘我乘好乘。’时阿育言：‘我乘老宿象，我得作王。’时王又复语师言：‘愿更为观授记。’师复答言：‘此中有第一座者，彼当作王。’诸王子各相谓言：‘我坐第一座。’阿育言：‘我今坐地，是我胜座，我当作王。’复语师：‘更为重观。’师又报言：‘此中上器、上食，此当得王。’乃至阿育念言：‘我有胜乘、胜座、胜食。’时王观子相毕，便即还宫。时阿育母问阿育言：‘谁当作王？婆罗门复记谁耶？’阿育启言：‘上乘、上座、上器、上食，当作王子。自见当作王：老象为乘，以地为坐，素器盛食，粳米杂酪饭。’
    “时彼婆罗门知阿育当作王，数修敬其母。其母亦重饷婆罗门，即便问言：‘大王崩后，谁当作王？’师答言：‘此不可说也。’如是乃至三问。师言：‘吾当语汝，慎勿使人知。汝生此子，名曰阿育，是其人也。’夫人白言：‘我闻此语，欢喜踊跃。若王闻者，于师所不生敬信。师今可还本住处，若子作王者，师当一切得吉利，尽形供养。’
    “时频头娑罗王边国怛叉尸罗反。时王语阿育：‘汝将四兵众，平伐彼国。’王子去时，都不与兵甲。时从者白王子言：‘今往伐彼国，无有军仗，云何得平？’阿育言：‘我若为王，善根果报者，兵甲自然来应。’发是语时，寻声地开，兵甲从地而出。即将四兵，往伐彼国。时彼诸国民人闻阿育来，即平治道路，庄严城郭，执持吉瓶之水，及种种供养，奉迎王子，而作是言：‘我等不反大王及阿育王子，然诸臣辈不利我等，我等是故违背圣化。’即以种种供养王子，请入城邑。
    “平此国已，又使至伐佉沙国。时彼二大力士为王平治道路，推诸山石。又复诸天宣令此国：‘阿育当王此天下，汝等勿兴逆意。’彼国王即便降伏。如是乃至平此天下，至于海际。
    “时修师摩王子出外游戏，又复遇逢一大臣，臣不修礼法，王子即使人打拍其身。大臣念言：‘此王子未得王位，用性如是。若得王者，不可而当。又闻阿育得天下，得坏五百大臣。我等相与立阿育为王，领此天下。’
    “又著叉尸罗国反，诸臣共议，令修师摩王子去，王亦应可。即便往彼国，不能降伏。时父王复得重疾，王语诸臣：‘吾今欲立修师摩为王，令阿育往至彼国。’时诸臣欲令阿育作王，以黄物涂阿育体及面、手、脚已，诸臣白王言：‘阿育王子今得重疾。’诸臣即便庄严阿育，将至王所：‘今且立此子为王，我等后徐徐当立修师摩为王。’时王闻此语，甚以不喜，忧愁不乐，默然不对。时阿育心念口言：‘我应正得王位者，诸天自然来，以水灌我顶，素缯系首。’寻声诸天即以水灌阿育顶，素缯系首。时王见此相貌，极生愁恼，即便命终。
    “阿育王如礼法殡葬父王已，即立阿[少/兔]楼陀为大臣。时修师摩王子闻父崩背，今立阿育为王，心生不忍，即集诸兵，而来伐阿育。阿育王四门中，二门安二力士，第三门安大臣，自守东门。时阿[少/兔]楼陀大臣，机关木象，又作阿育王像，像即骑象，安置东门外。又作无烟火坑聚，以物覆之。修师摩既来到时，阿[少/兔]楼陀大臣语修师摩王子：‘欲作王者，阿育在东门，可往伐之，能得此王者，自然得作王。’时彼王子即趣东门，即堕火坑，便即死亡。
    “尔时有一大力士，名曰跋陀罗由陀，闻修师摩终亡厌世，将无量眷属，于佛法中出家学道，加勤精进，逮得漏尽，成阿罗汉道。
    “阿育王正法治化，时诸臣辈以我等共立阿育为王故，轻慢于王，不行君臣之礼。王亦自知诸臣轻慢于我，时王语诸臣曰：‘汝等可伐花果之树，植于刺棘。’诸臣答曰：‘未尝见闻却除花果而植刺树，而见除伐刺树而植果实。’乃至王三敕令伐，彼亦不从。尔时国王忿诸大臣，即持利剑，杀五百大臣。
    “又时王将婇女眷属，出外园中游戏，见一无忧树，花极敷盛。王见已，此花树与我同名，心怀欢喜。王形体丑陋，皮肤粗涩，诸婇女辈，心不爱王，憎恶王故，以手毁折无忧花树。王从眠觉，见无忧树花狼藉在地，心生忿怒，系诸婇女，以火烧杀。王行暴恶，故曰暴恶阿育王。
    “时阿[少/兔]楼陀大臣白王言：‘王不应为是法，云何以手自杀人、诸臣、婇女？王今当立屠杀之人，应有所杀，以付彼人。’王即宣教，立屠杀者。
    “彼有一山，名曰耆梨，中有一织师家。织师有一子，亦名耆梨，凶恶挝打系缚小男小女，及捕水陆之生，乃至拒逆父母，是故世人传云凶恶耆梨子。时王诸使语彼：‘汝能为王斩诸凶人不？’彼答曰：‘一切阎浮提有罪者，我能净除，况复此一方！’时诸使辈还启王言：‘彼人已得凶恶者。’王言：‘觅将来也。’诸使呼彼，彼答言：‘小忍，先奉辞父母。’具说上事，父母言：‘子不应行是事。’如是三敕。彼生不仁之心，即便杀父母已，然后乃至。诸使问曰：‘何以经久不速来也？’时彼凶恶具说上事。诸使者以是事具启王。王即敕彼：‘我所有罪人，事应至死，汝当知之。’彼启王言：‘为我作舍。’王乃至为其作舍，屋室极为端严，唯开一门，门亦极精严。于其中间，作治罪之法，罗列状如地狱，彼狱极为胜好。时彼凶人启王言：‘今从王乞愿，若人来入此中者，不复得出。’王答言：‘如汝所启乞愿，当以与汝。’
    “时彼屠主往诣寺中，听诸比丘说地狱事。时有比丘讲地狱经，有众生生地狱者，地狱即执彼罪人，以热铁钳，钳开其口，以热铁丸着其口中。次融铜灌口，次复铁斧斩截其体，次复杻械枷锁检系其身，次复火车炉炭，次复铁镬，次复灰河，次复刀山剑树，具如《天五使经》所说。彼屠主具闻比丘说是诸事，关其住处，所作治罪之法，如彼所说，按此法而治罪人。
    “又一时，商主将其妇入于大海，入海时，妇便生子，名曰为海。如是在海十有余年，采诸重宝，还到本乡。道中值五百贼，杀于商主，夺彼宝物。尔时商主之子见父伤死，及失宝物，厌世间苦故，于如来法中出家学道，还其本土，游行诸国，次至巴连弗邑。过此夜已，晨朝着衣持钵，入城次第乞食，误入屠杀舍中。
    “时彼比丘遥见舍里，见火车、炉炭等，治诸众生，如地狱中。寻生恐怖，衣毛皆竖，便欲出门。时凶恶即往执彼比丘言：‘入此中者，无有得出，汝今于此而死！’比丘闻其所说，心生悲毒，泣泪满目。凶主问曰：‘汝云何如小儿啼？’
    “尔时比丘以偈答曰：

‘我不恐畏死，志愿求解脱，
所求不成果，是故我啼泣。
人身极难得，出家亦复然，
遇释狮子王，自今不重睹。’

    “尔时凶主语比丘曰：‘汝今必死，何所忧恼！’比丘复以哀言答云：‘乞我少时生命，可至一月。’彼凶不听。如是日数渐减，止于七日，彼即听许。时此比丘知将死不久，勇猛精进，坐禅息心，终不能得道。至于七日，时王宫内人，有事至死，送付凶恶之人，令治其罪。凶主将是女人着臼中，以杵捣之，令成碎末。时比丘见是事，极厌恶此身：‘呜呼苦哉！我不久亦当如是。’而说偈言：

‘呜呼大悲师，演说正妙法，
此身如聚沫，于义无有实。
向者美女色，今将何所在？
生死极可舍，愚人而贪著。
系心缘彼处，今当脱锁木，
今度三有海，毕竟不复生。
如是勤方便，专精修佛法，
断除一切结，得成阿罗汉。’

    “时彼凶恶人语此比丘：‘期限已尽。’比丘问曰：‘我不解尔之所说。’彼凶答曰：‘先期七日，今既已满。’比丘以偈答曰：

‘我心得解脱，无明大黑暗，
断除诸有盖，以杀烦恼贼。
慧日今已出，鉴察心意识，
明了见生死。今者愍人时，
随顺修圣法。我今此身骸，
任尔之所为，无复有吝惜。’

    “尔时彼凶主执彼比丘，着铁镬油中，足与薪火，火终不燃。假使燃者，或复不热。凶主见火不燃，打拍使者，而自燃火，火即猛盛。久久开铁镬盖，见彼比丘铁镬中莲花上坐，生希有心，即启国王。王即便严驾，将无量众，来看比丘。时彼比丘调伏时至，即身升虚空，犹如雁王，示种种变化。如偈所说：

王见是比丘，身升在虚空，
心怀大欢喜，合掌观彼圣：
‘我今有所白，意中所不解，
形体无异人，神通未曾有。
为我分别说，修习何等法，
令汝得清净？为我广敷演，
令得胜妙法。我了法相已，
为汝作弟子，毕竟无有悔。’

    “时彼比丘而作是念：‘我今调伏是王，多有所导，摄持佛法，当广分布如来舍利，安乐无量众生，于此阎浮提，尽令信三宝。’以是因缘故，自显其德，而向王说偈言：

‘我是佛弟子，逮得诸漏尽，
又复是佛子，不著一切有。
我今已调伏，无上两足尊，
息心得寂静，生死大恐怖。
我今悉得脱，有离三有缚，
如来圣法中，获得如是利。’

    “时阿育王闻彼比丘所说，于佛所生大敬信，又白比丘言：‘佛未灭度时，何所记说？’比丘答言：‘佛记大王，于我灭后，过百岁之时，于巴连弗邑有三亿家，彼国有王名曰阿育，当王此阎浮提，为转轮王，正法治化；又复广布我舍利，于阎浮提立八万四千塔。佛如是记大王。然大王今造此大地狱，杀害无量民人，王今宜应慈念一切众生，施其无畏，令得安隐。佛之所记大王者，王当如法修行。’而说偈言：

‘当行哀愍心，莫恼诸群生，
当修习佛法，广布佛舍利。’

    “时彼阿育王于佛所极生敬信，合掌向比丘作礼：‘我得大罪，今向比丘忏悔。我之所作，甚为不可，愿为佛子，受我忏悔，舍心勿复责。我愚人今复归命！’而说偈言：

‘我今归依佛，无上胜妙法，
比丘诸众尊，我今尽命归。
我今当勇猛，奉受世尊敕，
于此阎浮提，普立诸佛塔。
种种诸供养，悬缯及幡幢，
庄严世尊塔，妙丽世希有。’

    “时彼比丘度阿育王已，乘空而化。时王从彼地狱出。凶主白王言：‘王不复得去。’王曰：‘汝今欲杀我耶？’彼曰：‘如是。’王曰：‘谁先入此中？’答曰：‘我是。’王曰：‘若然者，汝先应取死。’王即敕人，将此凶主，着作胶舍里，以火烧之。又敕坏此地狱，施众生无畏。
    “时王欲建舍利塔，将四兵众，至王舍城，取阿阇世王佛塔中舍利。还复修治此塔，与本无异。如是取七佛塔中舍利，至罗摩村中。时诸龙王将是王入龙宫中，王从龙索舍利供养，龙即与之，王从彼而出。如偈所说：

罗摩罗村中，所有诸佛塔，
龙王所奉事，守护而供养。
王从龙索分，诸龙开塔与，
即持此舍利，渐进于余方。

    “时王作八万四千金、银、琉璃、玻璃箧，盛佛舍利；又作八万四千宝瓶，以盛此箧；又作无量百千幡幢伞盖。使诸鬼神各持舍利、供养之具，敕诸鬼神言：‘于阎浮提，至于海际，城邑聚落满一亿家者，为世尊立舍利塔。’时有国名著叉尸罗，三十六亿家，彼国人语鬼神言：‘三十六箧舍利与我等，起立佛塔。’王作方便，国中人少者，令分与彼。令满家数，而立为塔。
    “时巴连弗邑有上座，名曰耶舍。王诣彼所，白上座曰：‘我欲一日之中，立八万四千佛塔，遍此阎浮提，意愿如是。’如偈赞曰：

大王名阿育，于先八塔中，
各取其舍利，于此阎浮提，
建立诸佛塔，八万及四千，
纵广殊妙胜，一日都使毕。

    “时彼上座白王言：‘善哉大王！克后十五日月食时，令此阎浮提起诸佛塔。’如是乃至一日之中，立八万四千塔，世间民人兴庆无量，共号名曰法阿育王。如偈赞曰：

王圣种孔雀，安乐世间人，
于此阎浮提，建立胜妙塔。
本名为恶王，今造胜妙业，
共号名法王，相传至于后。

    “王已建八万四千塔，欢喜踊跃，将诸群臣往诣鸡雀精舍，白耶舍上座曰：‘更有比丘，佛所授记，当作佛事不？我当往诣彼所，供养恭敬。’上座答曰：‘佛临般涅槃时，降伏阿波罗龙王、陶师、旃陀罗、瞿波梨龙。诣摩偷罗国，告阿难曰：于我般涅槃后百年之中，当有长者名瞿多，其子名曰优波崛多，当出家学道，无相佛，教授于人，最为第一，当作佛事。佛告阿难曰：遥见彼山不？阿难白佛：见也，世尊。佛告阿难：此山名优留曼茶，是阿兰若处，名那茶婆低，随顺寂静。’而偈赞曰：

‘优波崛比丘，教授最第一，
名闻振四方，最胜之所记，
于我灭度后，当得作佛事，
度诸众生类，其数无有限。’

    “时王问上座曰：‘尊者优波崛今已出世不？’上座答曰：‘已出世，出家学道，降伏烦恼，是阿罗汉。共诸无量比丘眷属一万八千，住在优留曼茶山中阿兰若处。哀愍众生，如佛说净妙法，度无量诸天及人，令入甘露城。’王闻已，欢喜踊跃，即敕群臣，速办严驾，将无量眷属往诣彼所，修敬供养优波崛多。时臣白王言：‘彼圣既在王国，宜当遣信奉迎之，彼自当来。’王答臣曰：‘不宜遣信至彼所，应当自往，彼不宜来也。’而说偈曰：

‘汝得金刚舌，哪能不断坏？
谏我莫往彼，亲近田舍人。’

    “王即遣信，往彼尊者所，言：‘某日当来尊所。’时尊者思惟：‘若王来者，无量将从受诸大苦，逼杀害微虫、聚落人民。’作是念已，答使者曰：‘我当自往诣王所。’时王闻尊者自来，欢喜踊跃，从摩偷罗至巴连弗邑，于其中间，开安舟航，于航悬诸幢盖。时尊者优波崛愍念王故，将一万八千阿罗汉众，随于水道，径至王国。时国中人启王言：‘尊者优波崛将一万八千比丘众来至。’王闻，大欢喜踊跃，即脱璎珞，价直千万，而授与之。王将诸大臣眷属，即出往尊者所，为下食，五体投地，向彼作礼，长跪合掌，而作是言：‘我今领此阎浮提，受于王位，不以为喜。今睹尊者，踊跃无量。如来弟子，乃能如是，如睹于佛。’而说偈言：

‘寂灭已度世，汝今作佛事，
世间愚痴灭，如日照佛世。
为世作导师，说法中第一，
众生可依怙，我今大欢喜。’

    “时王敕使者宣令国界：‘尊者优波崛比丘今来此国！’如是唱言：

‘欲得富贵者，远离贫穷苦，
常处天上乐，解脱涅槃者，
当值优波崛，修敬今供养，
未见诸佛者，今睹优波崛。’

    “时王严饰国界，平治道路，悬缯幡盖，烧香散花，及诸伎乐。举国人民皆出奉迎尊者优波崛，供养恭敬。尔时尊者优波崛白王言：‘大王，当以正法治化，哀愍众生。三宝难遇，于三宝中，常以供养恭敬，修念赞叹，广为人说。所以者何？如来、应供、等正觉，知人见人，常为记说：我之正法寄在国王及我比丘僧等。’而说偈曰：

‘世雄人中尊，正胜妙大法，
寄付于大王，及我比丘僧。’

    “时王白优波崛曰：‘我已建正法。’而说偈曰：

‘我已造诸塔，庄严诸国界，
种种兴供养，幡幢及诸宝，
广布佛舍利，遍于阎浮提。
我兴如是福，意愿悉已满，
自身及妻儿，珍宝及此地，
今已悉舍施，供养贤圣塔。’

    “时尊者优波崛赞王言：‘善哉善哉！大王应行如是法。’而说偈言：

‘舍身及财命，世世无所忧，
受福无有穷，必得无上觉。’

    “时王请尊者优波崛入城，设种种座，请尊者就坐，众僧令往鸡雀精舍。白尊者曰：‘尊者颜貌端正，身体柔软。而我形体丑陋，肌肤粗涩。’
    “尊者说偈曰：

‘我行布施时，净心好财物，
不如王行施，以沙施于佛。’

    “时王以偈报曰：

‘我于童子时，布施于沙土，
今获果如是，何况余妙施？’

    “尊者复以偈赞曰：

‘快哉善大王，布施诸沙土，
无上福田中，植果无穷尽。’

    “时阿育王告诸大臣：‘我以沙布施于佛，获其果报如是，云何而不修敬于世尊？’王复白优波崛言：‘尊者，示我佛所说法、游行处所，当往供养礼拜，为诸后世众生摄受善根。’而说偈言：

‘示我佛说法，诸国及住处，
供养当修敬，为后众生故。’

    “尊者言：‘善哉善哉！大王能发妙愿，我当示王处所，为后众生。’时王将四兵军众，及持种种供养，香花、幡幢，及诸伎乐，便将尊者发去。
    “尊者至隆频林，此是如来生处，而说偈言：

‘如来初生处，生时行七步，
顾视诸四方，举手指天上：
我今最后生，当得无上道，
天上及于人，我为无上尊。’

    “时王五体投地，供养礼拜，即立佛塔。
    “尊者白王言：‘大王欲见诸天见佛生时行七步处不？’王白言：‘愿乐欲见！’时尊者举手，指摩耶夫人所攀树枝，而告彼树神曰：‘树神今现，令王见之，生大欢喜。’寻声即见，住尊者边，而作是言：‘何所教敕，我当奉行。’尊者语王言：‘此神见佛生时。’王以偈问神曰：

‘汝见严饰身，生时青莲花，
足行于七步，口中有所说？’

    “神以偈答曰：

‘我见相好身，生时二足尊，
举足行七步，口中有所说：
于诸天人中，我为无上尊。’

    “时王问神言：‘佛生有何瑞应？’神答言：‘我不能宣说妙胜诸事，今略说少分：

‘光明能彻照，身体具相好，
令人喜乐见，感动于天地。’

    “时王闻神所说欢喜，施十万两珍宝而去。
    “又将王入城里，语言：‘此处菩萨现三十二相、八十种好，庄严其体，紫磨金色。’时王向此处作礼，兴种种供养。又将王至天寺中，语王言：‘太子生时，令向彼神礼，时诸神悉礼菩萨。时诸民人为菩萨立名，今是天中天。’时王复以种种供养。又将示处，语王言：‘此处父王以菩萨示诸婆罗门，瞻其相德。’王复种种供养。又示：‘此处菩萨学堂，此处学乘象，此处学乘马、乘车、弓弩，如是学一切伎术处。此处是菩萨治身；此处菩萨六万夫人游戏处；此处菩萨见老、病、死人；此处菩萨坐阎浮提树下，坐禅得离欲，树影不离身，父王向其作礼；此处菩萨将百千天神，出城而去；此处菩萨脱璎珞与车匿，遣马还国。’而说偈曰：

‘菩萨于此处，脱璎珞及冠，
授与于车匿，遣马还于国，
独行无有侣，便入学道山。’

    “‘又此处菩萨从猎师易袈裟衣，被此衣已，而为出家；此处是仙人所稽请处；此处瓶沙王与菩萨半国处；此处问优蓝弗仙人；此处菩萨六年苦行。如偈所说：

‘苦行于六年，极受诸苦恼，
知此非真道，弃舍所习行。’

    “‘此处二女奉菩萨乳糜。如偈所说：

‘大圣于此中，受二女乳糜，
从此而起去，往诣菩提树。’

    “‘此处迦梨龙赞叹菩萨。如偈所说：

‘此处迦梨龙，赞叹于菩萨，
当随古时道，证无上妙果。’

    “时王向尊者而说偈曰：

‘我今欲见龙，彼龙见佛者，
从此趣菩提，证得胜妙果。’

    “时尊者以手指龙宫，语曰：‘迦梨龙王，汝以见佛，今当现身！’时龙王寻声即出，住在尊者前，合掌白言：‘何所教敕？’时尊者语王曰：‘此龙王见佛，赞叹如来。’

    “时王合掌向龙，而说偈曰：

‘汝见金刚身，我师无畴匹，
面如净满月，为我说彼德，
十力之功德，往诣道场时。’

    “时龙王以偈答曰：

‘我今当演说，足践于地时，
大地六种动，光耀倍于日，
遍照三千界，而趣菩提树。’

    “时王如是等处处种种供养，及立塔庙。
    “时尊者将王至道树下，语王曰：‘此树，菩萨摩诃萨以慈悲三昧力，破魔兵众，得阿耨多罗三藐三菩提。’而说偈言：

‘牟尼牛王尊，于此菩提树，
降伏恶魔军，得胜菩提果，
天人中特尊，无能与等者。’

    “时王舍无量珍宝，种种供养，及起大塔庙。
    “‘此处四天王各持一钵，奉上于佛，合为一钵；此处于贾客兄弟所，受诸饭食；此处如来诣波罗奈国时，阿时婆外道问佛；此处仙人园鹿野苑，如来于中为五比丘三转十二行法轮。’而说偈言：

‘此处鹿野苑，如来转法轮，
三转十二行，五人得道迹。’

    “时王于是处兴种种供养，及立塔庙。
    “‘此处如来度优楼频螺迦叶等仙人为道；此处如来为瓶沙王说法，王得见谛，及无量民人、诸天得道；此处如来为天帝释说法，帝释及八万诸天得道；此处如来示大神力，种种变化；此处如来至天上，为母说法，将无量天众，下于人间。’王复种种供养，及立塔庙。
    “时尊者语阿育王，至鸠尸那竭国，言：‘此处如来具足作佛事毕，于无余般涅槃而般涅槃。’而说偈言：

‘度脱诸天人，修罗龙夜叉，
建立无尽法，佛事既已终，
于有得寂灭，大悲入涅槃，
如薪尽火灭，毕竟得常住。’

    “时王闻是语，忧恼迷闷躃地。时诸臣辈以水洗心面，良久得苏，啼泣涕零。如是乃至兴种种供养，立大塔庙。
    “时王复白尊者曰：‘我意愿欲得见佛诸大弟子，佛之所记者，欲供养彼舍利，愿为示之。’时尊者白王言：‘善哉善哉！大王能发如是妙心。’时尊者将王至舍卫国，入祇桓精舍，以手指塔：‘此是尊者舍利弗塔，王当供养。’王曰：‘彼有何功德？’尊者曰：‘是第二法王，随转法轮。’而说偈言：

‘一切众生智，比于舍利弗，
十六之一分，以除如来智。
如来转法轮，是则能随转，
彼有无量德，谁复能宣说！’

    “时王生大欢喜，舍十万两珍宝，供养其塔，而说偈言：

‘我礼舍利弗，解脱诸恐怖，
名称普于世，智慧无有等。’

    “次复示大目揵连塔：‘王应供养此塔。’王复问曰：‘彼有何功德？’尊者答曰：‘是神足第一，以足指践地，地即震动。至于天宫，降伏难陀跋难陀龙王。’而说偈曰：

‘以足指动地，至于帝释宫，
神足无与等，谁能尽宣说？
二龙王凶暴，见者莫不怖，
彼于神足力，降伏息瞋恚。’

    “时王舍十万两珍宝，供养此塔，以偈赞曰：

‘神足中第一，离于老病死，
有如是功德，今礼目揵连！’

    “次复示摩诃迦叶塔，语王言：‘此是摩诃迦叶塔，应当供养。’王问曰：‘彼有何功德？’答曰：‘彼少欲知足，头陀第一，如来施以半座及僧伽梨衣。愍念众生，兴立正法。’即说偈曰：

‘功德田第一，愍念贫穷类，
着佛僧伽梨，能建于正法，
彼有如是德，谁能具宣说！’

    “时王舍十万两珍宝，供养是塔，以偈赞曰：

‘常乐于寂静，依止林薮间，
少欲知足富，今礼大迦叶！’

    “次复示尊者薄拘罗塔：‘此是薄拘罗塔，应当供养。’王问曰：‘彼有何功德？’尊者答曰：‘彼无病第一，乃至不为人说一句法，寂默无言。’王曰：‘以一钱供养！’诸臣白王：‘功德既等，何故于此供养一钱？’王告之曰：‘听吾所说：

‘虽除无明痴，智慧能鉴察，
虽有薄拘名，于世何所益？’

    “时彼一钱还来至王所。时大臣辈见是希有事，异口同音赞彼：‘呜呼尊者！少欲知足，乃至不须一钱。’
    “复示阿难塔，语王言：‘此是阿难塔，应当供养。’王曰：‘彼有何功德？’答曰：‘此人是侍佛者，多闻第一，撰集佛经。’而说偈曰：

‘奉持牟尼钵，念至能决断，
多闻之大海，辩才柔软音。
能悦天人众，善知三佛心，
一切悉明了，功德之宝箧。
最胜所称叹，降伏烦恼诤，
如是等功德，应当修供养。’

    “王即舍百亿两珍宝，而供养其塔。时诸臣白王言：‘何故于此布施供养皆悉胜前？’王曰：‘听吾所说心中所以：

‘如来之体身，法身性清净，
彼悉能奉持，是故供养胜。
法灯常存世，灭此愚痴冥，
皆由从彼来，是故供养胜。
如大海之水，牛迹所不容，
如是佛智海，余人不能持。
唯有阿难尊，一闻悉受持，
终无忘失时，是故供养胜。’

    “尔时王如是种种供养，向尊者合掌，而作是言：

‘我今受此形，不复负此身，
修无量功德，今为人中主。
我今取坚实，造立诸塔庙，
庄严在于世，如星庄严月。
奉佛弟子法，应行诸礼节，
我今悉已作，稽首尊者足。
蒙尊者恩力，今见胜妙事，
快获大善利，从是分别法。’

    “尔时王供养上种种事，恒遍至菩提道场树，此树下如来得阿耨多罗三藐三菩提。世间希有珍宝供养之事，供养菩提树。
    “时王夫人名曰低舍罗絺多，夫人作是念：‘王极爱念于我，我亦念王。王今舍我去，持诸珍宝至菩提树间。我今当作方便，杀是菩提树，树既枯死，叶便凋落，王当不复往彼，可与我常相娱乐。’即唤咒师，语咒师言：‘汝能杀菩提树不？’彼答曰：‘能，与我千两金。’时夫人即与千两金钱。咒师往菩提树间，以咒咒树，以綖系树。时树渐渐枯死，叶即萎落，未即枯死，其叶凋落。白夫人曰：‘复应以热乳浇树，乃可令枯。’夫人白王：‘我今欲以乳供养菩提树。’王曰：‘随卿意耶。’如是乃至以热乳浇之，树即枯燥。时诸夫人白王言：‘菩提树忽然枯死，叶叶变落。’而说偈言：

‘如来所依树，名曰菩提者，
于是得正觉，具足一切智。
大王今当知，是树今枯死，
叶色亦变异，不知何以故？’

    “时王闻是语，即迷闷躃地，诸人辈以水浇王心面，良久而苏，即便泣泪言：

‘我见菩提树，便见于如来，
今闻彼树死，我今亦随没！’

    “时彼夫人见王忧愁不乐，而白王言：‘王勿忧恼，我当喜悦王心。’王曰：‘若无彼树，我命亦无。如来于彼树得阿耨多罗三藐三菩提，彼树既无，我何用活耶？’夫人闻王决定语，还复以冷乳灌菩提树下，彼树寻复更生。王闻以乳溉灌，树还得生，日日送千瓮乳，溉灌其本，树还复如先。诸夫人辈白王言：‘菩提树今复如先，无复有异。’时王闻已，即生欢喜，诣菩提树下，睹于菩提树，目不暂舍，而说偈言：

‘诸王所未作，瓶沙持国等，
我今应供养，我今浴菩提，
诸乳及香水，花香及涂香，
当复供养僧，贤圣五部众。’

    “时王各办四宝瓮，金、银、琉璃、玻璃，盛诸香乳，及诸香汤，持种种饮食、幡幢、宝盖，各有千种，及种种花香、伎乐。受持八支斋布萨，着白净衣服，执持香炉，在于殿上，向四方作礼，心念口言：‘如来贤圣弟子在诸方者，怜愍我故，受我供养！’而说偈言：

‘如来贤圣子，正顺寂诸根，
离诸三界欲，诸天应供养，
今当悉来集，受我微心惠，
哀愍副我意，令法种增长。
常乐于寂止，解脱诸所著，
如来之真子，从法而化生，
诸天所供养，哀愍于我故，
今当悉来集，副我之微意。
诸圣在处处，罽宾多波婆，
大林离波多，阿耨大池边，
江河山薮间，如是一切处，
诸圣在中者，今当悉来集，
哀愍于我故，副我之微意。
又在于天上，尸梨婆宫殿，
香山石室中，神通具足者，
今当悉来集，哀愍于我故。’

    “时王如是语时，三十万比丘悉来集。彼大众中，十万是阿罗汉，二十万是学人及凡夫比丘，上座之座无人坐。时王问诸比丘：‘上座之座，云何而无人坐？’时彼大众中有一比丘名曰耶舍，是大阿罗汉，具足六通，白王言：‘此座上座之座，余者岂敢于中而坐？’王复问曰：‘于尊者所，更有上座耶？’尊者答曰：‘更有上座。大王，佛之所记，名曰宾头卢，是上座，应坐此处。’王大欢喜，而作是言：‘于中有比丘见佛者不？’尊者答曰：‘有也。大王，宾头卢者，犹故存世。’王复白曰：‘可得见彼比丘不？’尊者曰：‘大王，不久当见，寻当来至。’时王生大欢喜，而说偈言：

‘我今快得利，摄受于我故，
令我自目见，尊者宾头卢。’

    “时尊者宾头卢，将无量阿罗汉，次第相随，譬如雁王，乘虚而来，在于上座处坐。诸比丘僧各修礼敬，次第而坐。
    “时王见尊者宾头卢，头发皓白，辟支佛体。头面礼足，长跪合掌，睹尊者颜貌，而说偈言：

‘我今之王位，统领阎浮提，
不以为欢喜，今得见尊者。
我今见尊者，便是见生佛，
心怀大踊跃，胜见于王位。’

    “复白尊者曰：‘尊者见世尊耶？三界所尊仰。’
    “时尊者宾头卢以手举眉毛，视王而言：

‘我见于如来，于世无譬类，
身作黄金色，三十二相好，
面如净满月，梵音声柔软，
伏诸烦恼诤，常处于寂灭。’

    “王复问曰：‘尊者何处见佛？’尊者曰：‘如来将五百阿罗汉俱，初在王舍城安居，我尔时亦复在中。’而说偈言：

‘大牟尼世尊，离欲相围绕，
在于王舍城，结于夏三月。
我时在彼众，恒住如来边，
大王今当知，我目见真佛。’

    “‘又复佛住舍卫国时，如来大作神力，种种变化，作诸佛形，满在诸方，乃至阿迦尼吒天。我尔时亦在于中，见如来种种变化神通之相。’而说偈言：

‘如来神通力，降伏诸外道，
佛游于十方，我亲见彼相。’

    “‘又复如来在天上与母说法，时我亦在于中。与母说法竟，将诸天众，从天上来下僧迦奢国，时我见此二事，天人受福乐。优波罗比丘尼化作转轮圣王，将无量眷属，乘空而来，诣世尊所，我亦见此。’而说偈言：

‘如来在天上，于彼结夏坐，
我亦在于中，牟尼之眷属。’

    “‘又复世尊住舍卫国，五百阿罗汉俱。时给孤独长者女，适在于富楼那跋陀那国，时彼女请佛及比丘僧。时诸比丘各乘空而往彼，我尔时以神力，合大山往彼受请。时世尊责我：汝哪得现神足如是？我今罚汝常在于世，不得取涅槃，护持我正法，勿令灭也。’而说偈曰：

‘世尊受彼请，五百比丘俱，
时我以神力，挑大山而去。
世尊责罚我，住世未灭度，
护持我正法，勿令法没尽！’

    “‘又复如来将诸比丘僧入城乞食，时王共二童子沙土中戏，逢见佛来，捧于尘沙，奉上于佛。时世尊记彼童子：于我灭度百岁之后，此童子于巴连弗邑当受王位，领阎浮提，名曰阿育。当广布我舍利，一日之中，当造八万四千塔。今王身是也。我尔时亦在于中。’而说偈曰：

‘王于童子时，以沙奉上佛，
佛记于王时，我亦亲在中。’

    “时王白尊者曰：‘尊者今住在何处？’尊者答王曰：‘在于北山，山名揵陀摩罗，共诸同梵行僧。’王复问曰：‘有几眷属？’尊者答：‘六万阿罗汉比丘。’尊者曰：‘王何须多问？今当施设供养于僧，食竟使王欢喜。’王言：‘如是，尊者。然我今先当供养佛念所觉菩提之树，然后香美饮食施设于僧。’敕诸群臣，唱令国界：‘王今舍十万两金，布施众僧。千瓮香汤，溉灌菩提树。’集诸五众。
    “时王子名曰拘那罗，在王右边，举二指而不言说，意欲二倍供养。大众见之，皆尽发笑。王亦发笑，而语言：‘呜呼王子！乃有增益功德供养。’王复言：‘我复以三十万两金供养众僧，复加千瓮香汤，洗浴菩提树。’时王子复举四指，意在四倍。时王瞋恚，语臣曰：‘谁教王子作是事，与我兴竞？’臣启王言：‘谁敢与王兴竞？然王子聪慧利根，增益功德，故作是事耳。’时王右顾视王子，白上座曰：‘除我库藏之物，余一切物，阎浮提夫人、婇女、诸臣、眷属，及我拘那罗子，皆悉布施贤圣众僧。’唱令国界，集诸五众，而说偈曰：

‘除王库藏物，夫人及婇女，
臣民一切众，布施贤圣僧，
我身及王子，亦复悉舍与。’

    “时王、上座及比丘僧，以瓮香汤，洗浴菩提树。时菩提树倍复严好，增长茂盛。以偈颂曰：

‘王浴菩提树，无上之所觉，
树增于茂盛，柯条叶柔软。’

    “时王及诸群臣，生大欢喜。时王洗浴菩提树已，次复供养众僧。时彼上座耶舍语王言：‘大王，今大有比丘僧集，当发淳信心供养。’时王从上至下，自手供养。
    “时彼有二沙弥，得食已，各以麨团、饼、欢喜丸，更互相掷。王见即笑而言：‘此沙弥作小儿戏。’供养讫已，王还上座前立。上座语王言：‘王莫生不信敬心。’王答上座：‘无有不信敬心。然见二沙弥作小儿戏，如世间小儿以土团更互相掷，如是二沙弥以麨团、以饼、欢喜丸，更互相掷。’上座白王言：‘彼二沙弥是俱解脱阿罗汉，更相奉食。’王闻是已，增其信心，而作是念：‘此二沙弥能展转相施，我今亦当于一切僧人施绢、劫贝。’
    “时二沙弥知王心所念，二沙弥共相谓言，令王倍增敬信。一沙弥持镬授与王，一沙弥授以染草。王问彼沙弥：‘用作何等？’二沙弥白王言：‘王因我故，施与众僧绢及劫贝。我欲令大王染成其色，施与众僧。’时王作是念：‘我虽心念，口未发言，此二达士得他心智，而知我心。’王即稽首敬礼众僧，而说偈言：

‘孔雀之族姓，内外亲眷属，
因此惠施故，悉皆获大利，
遭值良福田，欢喜应时施。’

    “时王语沙弥言：‘我因汝等施僧衣。’施僧衣已，复以三衣，并四亿万两珍宝，嚫五部众。咒愿已，复以四十亿万两珍宝，赎取阎浮提宫人、婇女，及太子、群臣。
    “阿育王所作功德，无量如是。”


杂阿含经卷第二十四

第五诵道品第一

（六○五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四念处。何等为四？谓身身观念处，受、心、法法观念处。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六○六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四念处。何等为四？谓身身观念处，受、心、法法观念处。如是比丘，于此四念处修习满足，精勤方便，正念正知，应当学。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六○七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有一乘道，净诸众生，令越忧悲，灭恼苦，得如实法，所谓四念处。何等为四？身身观念处，受、心、法法观念处。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六○八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘离四念处者，则离如实圣法；离如实圣法者，则离圣道；离圣道者，则离甘露法；离甘露法者，不得脱生老病死、忧悲恼苦，我说彼于苦不得解脱。
    “若比丘不离四念处者，得不离圣如实法；不离圣如实者，则不离圣道；不离圣道者，则不离甘露法；不离甘露法者，得脱生老病死、忧悲恼苦，我说彼人解脱众苦。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六○九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当说四念处集、四念处没，谛听善思。何等为四念处集、四念处没？食集则身集，食灭则身没，如是随身集观住，随身灭观住，随身集灭观住，则无所依住，于诸世间永无所取。如是触集则受集，触灭则受没，如是随集法观受住，随灭法观受住，随集灭法观受住，则无所依住，于诸世间都无所取。名色集则心集，名色灭则心没，随集法观心住，随灭法观心住，随集灭法观心住，则无所依住，于诸世间则无所取。忆念集则法集，忆念灭则法没，随集法观法住，随灭法观法住，随集灭法观法住，则无所依住，于诸世间则无所取。是名四念处集、四念处没。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六一○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我当说修四念处，谛听善思。云何修四念处？谓内身身观念住，精勤方便，正知正念，调伏世间忧悲；外身、内外身观住，精勤方便，正念正知，调伏世间忧悲。如是受、心、法，内法、外法、内外法观念住，精勤方便，正念正知，调伏世间忧悲，是名比丘修四念处。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    过去、未来修四念处，亦如是说。

（六一一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有善法聚、不善法聚。云何善法聚？所谓四念处，是为正说。所以者何？纯一满净聚者，所谓四念处。云何为四？谓身身观念处，受、心、法法观念处。
    “云何不善聚？不善聚者，所谓五盖，是为正说。所以者何？纯一逸满不善聚者，所谓五盖。何等为五？谓贪欲盖、瞋恚盖、睡眠盖、掉悔盖、疑盖。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六一二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“如人执持四种强弓，大力方便射多罗树影，疾过无碍。如是如来四种声闻，增上方便，利根智慧，尽百年寿，于如来所百年说法教授，唯除食息、补泻、睡眠，中间常说、常听，智慧明利，于如来所说尽底受持，无诸障碍，于如来所不加再问。如来说法无有终极，听法尽寿百岁命终，如来说法犹不能尽。当知如来所说无量无边，名、句、味身亦复无量，无有终极，所谓四念处。何等为四？谓身念处，受、心、法念处。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    一切四念处经，皆以此总句，所谓：“是故比丘，于四念处修习，起增上欲，精勤方便，正念正智，应当学。”

（六一三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有不善聚、善聚。何等为不善聚？谓三不善根，是名正说。所以者何？纯不善积聚者，谓三不善根。云何为三？谓贪不善根、恚不善根、痴不善根。
    “云何为善聚？谓四念处。所以者何？纯善满具者，谓四念处，是名善说。云何为四？谓身念处，受、心、法念处。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

    如三不善根，如是三恶行，身恶行、口恶行、意恶行；三想，欲想、恚想、害想；三觉，欲觉、恚觉、害觉；三界，欲界、恚界、害界。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六一四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，如所说大丈夫，云何名大丈夫、非大丈夫？”
    佛告比丘：“善哉善哉！比丘能问如来大丈夫义。谛听善思，当为汝说。若比丘身身观念住，彼身身观念住已，心不离欲，不得解脱，尽诸有漏，我说彼非为大丈夫。所以者何？心不解脱故。若比丘受、心、法法观念住，心不离欲，不得解脱，尽诸有漏，我不说彼为大丈夫。所以者何？心不解脱故。
    “若比丘身身观念住，心得离欲，心得解脱，尽诸有漏，我说彼为大丈夫也。所以者何？心解脱故。若受、心、法法观念住，受、心、法法观念住已，心离贪欲，心得解脱，尽诸有漏，我说彼为大丈夫。所以者何？心解脱故。是名比丘大丈夫，及非大丈夫。”
    佛说此经已，诸比丘闻佛所说，欢喜随喜，礼足而去。

（六一五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者阿难晨朝着衣持钵，入舍卫城乞食。于路中思惟：“我今先至比丘尼寺。”即往比丘尼寺。
    诸比丘尼遥见尊者阿难来，疾敷床座，请令就座。时诸比丘尼礼尊者阿难足，退坐一面，白尊者阿难：“我等诸比丘尼，修四念处系心住，自知前后升降。”
    尊者阿难告诸比丘尼：“善哉善哉！姊妹，当如汝等所说而学。凡修习四念处，善系心住者，应如是知前后升降。”
    时尊者阿难为诸比丘尼种种说法，种种说法已，从座起去。
    尔时尊者阿难于舍卫城中乞食还，举衣钵，洗足已，诣世尊所，稽首佛足，退坐一面，以比丘尼所说具白世尊。
    佛告阿难：“善哉善哉！应如是学四念处，善系心住，知前后升降。所以者何？心于外求，然后制令求其心，散乱心不解脱，皆如实知。若比丘于身身观念住，于彼身身观念住已，若身耽睡，心法懈怠。彼比丘当起净信，取于净相；起净信心，忆念净相已，其心则悦；悦已，生喜；其心喜已，身则猗息；身猗息已，则受身乐；受身乐已，其心则定。心定者，圣弟子当作是学：我于此义，外散之心，摄令休息，不起觉想及已观想，无觉无观，舍念乐住；乐住已，如实知。受、心、法念，亦如是说。”
    佛说此经已，尊者阿难闻佛所说，欢喜奉行。

（六一六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当取自心相，莫令外散。所以者何？若彼比丘愚痴、不辩、不善，不取自心相，而取外相，然后退减，自生障碍。譬如厨士愚痴、不辩、不善巧便调和众味，奉养尊主，酸、咸、酢、淡不适其意，不能善取尊主所嗜酸、咸、酢、淡，众味之和。不能亲侍尊主左右，伺其所须，听其所欲，善取其心，而自用意调和众味，以奉尊主。若不适其意，尊主不悦，不悦故不蒙爵赏，亦不爱念。愚痴比丘亦复如是，不辩不善，于身身观住，不能除断上烦恼，不能摄取其心，亦复不得内心寂静，不得胜妙正念正知，亦复不得四种增上心法现法乐住、本所未得安隐涅槃。是名比丘愚痴、不辩、不善，不能善摄内心之相，而取外相，自生障碍。
    “若有比丘黠慧、才辩、善巧方便，取内心已，然后取于外相，彼于后时终不退减，自生障碍。譬如厨士黠慧、聪辩、善巧方便，供养尊主，能调众味，酸、咸、酢、淡，善取尊主所嗜之相，而和众味以应其心，听其尊主所欲之味，数以奉之。尊主悦已，必得爵禄、爱念、信重。如是黠慧厨士，善取尊主之心。比丘亦复如是，身身观念住，断上烦恼，善摄其心，内心寂止，正念正知，得四增上心法现法乐住，得所未得安隐涅槃。是名比丘黠慧、辩才、善巧方便，取内心相，摄持外相，终无退减，自生障碍。受、心、法观，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六一七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过去世时，有一鸟名曰罗婆，为鹰所捉，飞腾虚空。于空鸣唤言：‘我不自觉，忽遭此难。我坐舍离父母境界而游他处，故遭此难。如何今日为他所困，不得自在！’鹰语罗婆：‘汝当何处自有境界而得自在？’罗婆答言：‘我于田耕垄中自有境界，足免诸难，是为我家父母境界。’鹰于罗婆起骄慢言：‘放汝令去，还耕垄中，能得脱以不？’于是罗婆得脱鹰爪，还到耕垄大块之下，安住止处，然后于块上欲与鹰斗。鹰则大怒：‘彼是小鸟，敢与我斗？’瞋恚极盛，迅飞直搏。于是罗婆入于块下。鹰鸟飞势，臆冲坚块，碎身即死。时罗婆鸟深伏块下，仰说偈言：

‘鹰鸟用力来，罗婆依自界，
乘瞋猛盛力，致祸碎其身。
我具足通达，依于自境界，
伏怨心随喜，自观欣其力。
设汝有凶愚，百千龙象力，
不如我智慧，十六分之一，
观我智殊胜，摧灭于苍鹰。’

    “如是比丘，如彼鹰鸟愚痴，自舍所亲父母境界，游于他处，致斯灾患。汝等比丘亦应如是，于自境界所行之处，应善守持，离他境界，应当学。
    “比丘，他处他境界者，谓五欲境界：眼见可意爱念妙色，欲心染著；耳识声、鼻识香、舌识味、身识触可意爱念妙触，欲心染著，是名比丘他处他境界。比丘，自处父母境界者，谓四念处。云何为四？谓身身观念处，受、心、法法观念处。是故比丘，于自行处父母境界而自游行，远离他处他境界，应当学。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六一八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于四念处多修习，当得四果、四种福利。云何为四？谓须陀洹果、斯陀含果、阿那含果、阿罗汉果。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六一九）

    如是我闻。一时佛在拘萨罗人间游行，于私伽陀聚落北身恕林中。
    尔时世尊告诸比丘：“过去世时，有缘幢伎师，肩上竖幢，语弟子言：‘汝等于幢上，下向护我，我亦护汝，迭相护持，游行嬉戏，多得财利。’时伎弟子语伎师言：‘不如所言，但当各各自爱护，游行嬉戏，多得财利，身得无为安隐而下。’伎师答言：‘如汝所言，各自爱护。然其此义亦如我说，己自护时即是护他，他自护时亦是护己。’心自亲近，修习随护作证，是名自护、护他。云何护他自护？不恐怖他，不违他，不害他，慈心哀彼，是名护他自护。是故比丘当如是学，自护者修四念处，护他者亦修四念处。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六二○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“大雪山中寒冰险处，尚无猿猴，况复有人？或复有山，猿猴所居，而无有人。或复有山，人兽共居。于猿猴行处，猎师以黐胶涂其草上。有黠猿猴，远避而去。愚痴猿猴，不能远避，以手小触，即胶其手；复以二手欲解求脱，即胶二手；以足求解，复胶其足；以口啮草，辄复胶口；五处同胶，联卷卧地。猎师既至，即以杖贯，担负而去。比丘当知，愚痴猿猴舍自境界父母居处，游他境界，致斯苦恼。
    “如是比丘，愚痴凡夫依聚落住，晨朝着衣持钵，入村乞食，不善护身，不守根门，眼见色已则生染著，耳声、鼻香、舌味、身触皆生染著。愚痴比丘内根、外境被五缚已，随魔所欲。是故比丘，当如是学，于自所行处父母境界依止而住，莫随他处他境界行。云何比丘自所行处父母境界？谓四念处，身身观念住，受、心、法法观念住。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六二一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时尊者阿难与众多比丘诣世尊所，稽首礼足，退坐一面。
    尊者阿难白佛言：“世尊，此诸年少比丘，当云何教授？云何为其说法？”
    佛告阿难：“此诸年少比丘，当以四念处教令修习。云何为四？谓身身观念住，精勤方便，不放逸行，正智正念，寂定于心，乃至知身。受、心、法法观念住，精勤方便，不放逸行，正念正智，寂静于心，乃至知法。
    “所以者何？若比丘住学地者，未得进上，志求安隐涅槃时，身身观念住，精勤方便，不放逸行，正念正智，寂静于心；受、心、法法观念住，精勤方便，不放逸行，正念正智，寂静于心，乃至于法远离。若阿罗汉，诸漏已尽，所作已作，舍诸重担，尽诸有结，正知善解脱，当于彼时，亦修身身观念住，精勤方便，不放逸行，正念正智，寂静于心；受、心、法法观念住，乃至于法得远离。”
    时尊者阿难欢喜随喜，作礼而去。

（六二二）

    如是我闻。一时佛在跋祇人间游行，到鞞舍离国庵罗园中住。
    尔时庵罗女闻世尊跋祇人间游行，至庵罗园中住，即自庄严，乘车出鞞舍离城，诣世尊所，恭敬供养。诣庵罗园门，下车步进，遥见世尊与诸大众围绕说法。
    世尊遥见庵罗女来，语诸比丘：“汝等比丘，勤摄心住，正念正智。今庵罗女来，是故诫汝。云何为比丘勤摄心住？若比丘已生恶不善法当断，生欲方便，精进摄心；未生恶不善法不令起；未生善法令生；已生善法令住不忘，修习增满，生欲方便，精勤摄心，是名比丘勤摄心住。云何名比丘正智？若比丘去来威仪，常随正智，回顾视瞻、屈伸俯仰、执持衣钵、行住坐卧、眠觉语默，皆随正智住，是正智。云何正念？若比丘内身身观念住，精勤方便，正智正念，调伏世间贪忧；如是受、心、法法观念住，精勤方便，正智正念，调伏世间贪忧，是名比丘正念。是故汝等勤摄其心，正智正念，今庵罗女来，是故诫汝。”
    时庵罗女诣世尊所，稽首礼足，却住一面。
    尔时世尊为庵罗女种种说法，示教照喜，示教照喜已，默然而住。
    尔时庵罗女整衣服，为佛作礼，合掌白佛：“唯愿世尊与诸大众，明日受我请中食。”
    尔时世尊默然受请。
    庵罗女知世尊默然受请已，稽首礼足，还归自家，设种种食，布置床座。晨朝遣使，白佛时到。
    尔时世尊与诸大众，诣庵罗女舍，就座而坐。时庵罗女手自供养种种饮食。食讫，澡漱、洗钵竟，时庵罗女持一小床坐于佛前，听佛说法。
    尔时世尊为庵罗女说随喜偈：

“施者人爱念，多众所随从，
名称日增高，远近皆悉闻。
处众常和雅，离悭无所畏，
是故智慧施，断悭永无余。
上生忉利天，长夜受快乐，
尽寿常修德，娱乐难陀园，
百种诸天乐，五欲悦其心。
彼于此人间，闻佛所说法，
为善逝弟子，乐彼受化生。”

    尔时世尊为庵罗女种种说法，示教照喜，示教照喜已，从座起而去。

（六二三）

    如是我闻。一时佛住波罗奈仙人住处鹿野苑中。
    尔时世尊告诸比丘：“世间诸美色，世间美色者，能令多人集聚观看者不？”
    诸比丘白佛：“如是，世尊。”
    佛告比丘：“若世间美色，世间美色者，又能种种歌舞伎乐，复极令多众聚集看不？”
    比丘白佛：“如是，世尊。”
    佛告比丘：“若有世间美色，世间美色者，在于一处，作种种歌舞伎乐戏笑，复有大众云集一处。若有士夫不愚不痴，乐乐背苦，贪生畏死。有人语言：‘士夫，汝当持满油钵，于世间美色者所，及大众中过。使一能杀人者拔刀随汝，若失一滴油者，辄当断汝命。’云何比丘，彼持油钵士夫，能不念油钵，不念杀人者，观彼伎女及大众不？”
    比丘白佛：“不也，世尊。所以者何？世尊，彼士夫自见其后有拔刀者，常作是念：‘我若落油一滴，彼拔刀者当截我头。’唯一其心，系念油钵，于世间美色及大众中，徐步而过，不敢顾眄。”
    “如是比丘，若有沙门、婆罗门，正身自重，一其心念，不顾声色，善摄一切心法，住于身念处者，则是我弟子，随我教者。云何为比丘正身自重，一其心念，不顾声色，摄持一切心法，住身念处？如是比丘，身身观念住，精勤方便，正智正念，调伏世间贪忧；受、心、法法观念住，亦复如是。是名比丘正身自重，一其心念，不顾声色，善摄心法，住四念处。”
    尔时世尊即说偈言：

“专心正念，护持油钵，
自心随护，未曾至方。
甚难得过，胜妙微细，
诸佛所说，言教利剑，
当一其心，专精护持。
非彼凡人，放逸之事，
能入如是，不放逸教。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六二四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者郁低迦来诣佛所，稽首佛足，退坐一面，白佛言：“善哉世尊！为我说法。我闻法已，当独一静处，专精思惟，不放逸住，思惟所以善男子剃除须发，正信非家，出家学道。如上广说，乃至不受后有。”
    佛告郁低迦：“如是如是，如汝所说。但于我所说法，不悦我心，彼所事业亦不成就，虽随我后而不得利，反生障碍。”
    郁低迦白佛：“世尊所说，我则能令世尊心悦，自业成就，不生障碍。唯愿世尊为我说法，我当独一静处，专精思惟，不放逸住。如上广说，乃至不受后有。”如是第二、第三请。
    尔时世尊告郁低迦：“汝当先净其初业，然后修习梵行。”
    郁低迦白佛：“我今云何净其初业，修习梵行？”
    佛告郁低迦：“汝当先净其戒，直其见，具足三业，然后修四念处。何等为四？内身身观念住，专精方便，正智正念，调伏世间贪忧；如是外身、内外身身观念住，受、心、法法观念住，亦如是广说。”
    时郁低迦闻佛所说，欢喜随喜，从座起而去。
    时郁低迦闻佛教授已，独一静处，专精思惟，不放逸住，思惟所以善男子剃除须发，着袈裟衣，正信非家，出家学道，乃至不受后有。
    如郁低迦所问，如是异比丘所问，亦如上说。

（六二五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘名婆醯迦，来诣佛所，稽首礼足，退坐一面，白佛言：“世尊！善哉世尊！为我说法。”
    如前《郁低迦修多罗》广说，差别者：“如是婆醯迦比丘，初业清净，身身观念住者，超越诸魔；受、心、法法观念住者，超越诸魔。”
    时婆醯迦比丘闻佛说法教诫已，欢喜随喜，作礼而去。独一静处，专精思惟，不放逸住，乃至不受后有。

（六二六）

    第二经亦如上说，差别者：“如是比丘，超越生死。”

（六二七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者阿那律陀诣佛所，稽首礼足，退坐一面，白佛言：“世尊，若有比丘住于学地，未得上进安隐涅槃，而方便求。是圣弟子当云何于正法律修习多修习，得尽诸漏，乃至自知不受后有？”
    佛告阿那律：“若圣弟子住于学地，未得上进安隐涅槃，而方便求。彼于尔时当内身身观念住，精勤方便，正智正念，调伏世间贪忧；如是受、心、法法观念住，精勤方便，正智正念，调伏世间贪忧。如是圣弟子多修习已，得尽诸漏，乃至自知不受后有。”
    尔时尊者阿那律陀闻佛所说，欢喜随喜，作礼而去。

（六二八）

    如是我闻。一时佛住巴连弗邑鸡林精舍。
    时尊者优陀夷、尊者阿难陀，亦住巴连弗邑鸡林精舍。
    尔时尊者优陀夷诣尊者阿难所，共相问讯慰劳已，退坐一面，语尊者阿难：“如来、应供、等正觉所知所见，为诸比丘说圣戒，令不断、不缺、不择、不离、不戒取、善究竟、善持，智者所叹、所不憎恶。何故如来、应、等正觉所见，为诸比丘说圣戒，不断、不缺，乃至智者所叹、所不憎恶？”
    尊者阿难语优陀夷：“为修四念处故。何等为四？谓身身观念住，受、心、法法观念住。”
    时二正士共论议已，各还本处。

（六二九）

    如是我闻。一时佛住巴连弗邑鸡林精舍。
    尔时尊者阿难、尊者跋陀罗亦在彼住。
    时尊者跋陀罗问尊者阿难言：“颇有法修习多修习，得不退转耶？”
    尊者阿难语尊者跋陀罗：“有法修习多修习，能令行者得不退转，谓四念处。何等为四？身身观念住，受、心、法法观念住。”
    时二正士共论说已，各还本处。

（六三○）

    如是我闻。一时佛住巴连弗邑鸡林精舍。
    尔时尊者阿难、尊者跋陀罗亦在彼住。
    时尊者跋陀罗问尊者阿难：“颇有法修习多修习，令不净众生而得清净，转增光泽耶？”
    尊者阿难语尊者跋陀罗：“有法修习多修习，能令不净众生而得清净，转增光泽，谓四念处：身身观念住，受、心、法法观念住。”
    时二正士共论议已，各还本处。

（六三一）

    如是我闻。一时佛住巴连弗邑鸡林精舍。
    尔时尊者阿难、尊者跋陀罗亦在彼住。
    时尊者跋陀罗问尊者阿难：“颇有法修习多修习，能令未度彼岸众生得度彼岸？”
    尊者阿难语尊者跋陀罗：“有法修习多修习，能令未度彼岸众生得度彼岸，谓四念处。何等为四？谓身身观念住，受、心、法法观念住。”
    时二正士共论议已，各还本处。

（六三二）

    如是我闻。一时佛住巴连弗邑鸡林精舍。
    尔时尊者阿难、尊者跋陀罗亦在彼住。
    尊者跋陀罗问尊者阿难：“颇有法修习多修习，得阿罗汉？”
    尊者阿难语尊者跋陀罗：“有法修习多修习，而得阿罗汉，谓四念处。何等为四？谓身身观念住，受、心、法法观念住。”
    时二正士共论议已，各还本处。

（六三三）

    如是我闻。一时佛住巴连弗邑鸡林精舍。
    尔时世尊告诸比丘：“所说一切法，一切法者，谓四念处，是名正说。何等为四？谓身身观念住，受、心、法法观念住。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六三四）

    如是我闻。一时佛住巴连弗邑鸡林精舍。
    尔时世尊告诸比丘：“若比丘于四念处修习多修习，名贤圣出离。何等为四？谓身身观念住，受、心、法法观念住。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如出离，如是正尽苦、究竟苦边、得大果、得大福利、得甘露法、究竟甘露、甘露法作证，如上广说。

（六三五）

    如是我闻。一时佛住巴连弗邑鸡林精舍。
    尔时世尊告诸比丘：“若比丘于四念处修习多修习，未净众生令得清净，已净众生令增光泽。何等为四？谓身身观念住，受、心、法法观念住。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如净众生，如是未度彼岸者令度、得阿罗汉、得辟支佛、得阿耨多罗三藐三菩提，亦如上说。

（六三六）

    如是我闻。一时佛住巴连弗邑鸡林精舍。
    尔时世尊告诸比丘：“当为汝说修四念处。何等为修四念处？若比丘，如来、应、等正觉、明行足、善逝、世间解、无上士、调御丈夫、天人师、佛、世尊出兴于世，演说正法，上语亦善，中语亦善，下语亦善，善义善味，纯一满净，梵行显示。
    “若族姓子、族姓女，从佛闻法，得净信心，如是修学。见在家和合欲乐之过，烦恼结缚，乐居空闲，出家学道，不乐在家，处于非家，欲一向清净，尽于形寿，纯一满净，鲜白梵行：‘我当剃除须发，着袈裟衣，正信非家，出家学道。’作是思惟已，即便放舍钱财亲属，剃除须发，着袈裟衣，正信非家，出家学道。正其身行，护口四过，正命清净，习贤圣戒，守诸根门，护心正念。眼见色时，不取形相，若于眼根住不律仪，世间贪忧、恶不善法常漏于心，而令于眼起正律仪。耳、鼻、舌、身、意起正律仪，亦复如是。彼以贤圣戒律成就，善摄根门，来往、周旋、顾视、屈伸、坐卧、眠觉、语默，住智正智。
    “彼成就如此圣戒，守护根门，正智正念，寂静远离，空处、树下、闲房独坐，正身正念，系心安住。断世贪忧，离贪欲，净除贪欲；断世瞋恚、睡眠、掉悔、疑盖，离瞋恚、睡眠、掉悔、疑盖，净除瞋恚、睡眠、掉悔、疑盖。断除五盖恼，心慧力羸诸障碍分，不趣涅槃者。是故内身身观念住，精勤方便，正智正念，调伏世间贪忧；如是外身、内外身，受、心、法法观念住，亦如是说，是名比丘修四念处。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六三七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当修四念处。”如上广说，差别者：“乃至如是出家已，住于静处，摄受波罗提木叉律仪，行处具足，于细微罪生大怖畏。受持学戒，离杀、断杀、不乐杀生，乃至一切业迹如前说。衣钵随身，如鸟两翼。如是学戒成就，修四念处。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六三八）

    如是我闻。一时佛在王舍城迦兰陀竹园。
    尔时尊者舍利弗住摩竭提那罗聚落，疾病涅槃。纯陀沙弥瞻视供养。
    尔时尊者舍利弗因病涅槃。时纯陀沙弥供养尊者舍利弗已，取余舍利，担持衣钵，到王舍城。举衣钵，洗足已，诣尊者阿难所，礼尊者阿难足已，却住一面，白尊者阿难：“尊者当知，我和尚尊者舍利弗已涅槃，我持舍利及衣钵来。”
    于是尊者阿难闻纯陀沙弥语已，往诣佛所，白佛言：“世尊，我今举体离解，四方易韵，持辩闭塞。纯陀沙弥来语我言：‘和尚舍利弗已涅槃，持余舍利及衣钵来。’”
    佛言：“云何阿难，彼舍利弗持所受戒身涅槃耶？定身、慧身、解脱身、解脱知见身涅槃耶？”
    阿难白佛言：“不也，世尊。”
    佛告阿难：“若法我自知，成等正觉所说，谓四念处、四正断、四如意足、五根、五力、七觉支、八道支涅槃耶？”
    阿难白佛：“不也，世尊。虽不持所受戒身，乃至道品法而涅槃，然尊者舍利弗持戒多闻，少欲知足，常行远离，精勤方便，摄念安住，一心正受；捷疾智慧、深利智慧、超出智慧、分别智慧、大智慧、广智慧、甚深智慧、无等智慧，智宝成就；能视、能教、能照、能喜舍、能赞叹，为众说法。是故世尊，我为法故，为受法者故，愁忧苦恼。”
    佛告阿难：“汝莫愁忧苦恼。所以者何？若生、若起、若作，有为败坏之法，何得不坏？欲令不坏者，无有是处。我先已说，一切所爱念种种诸物，适意之事，一切皆是乖离之法，不可常保。譬如大树，根茎、枝叶、花果茂盛，大枝先折。如大宝山，大岩先崩。如是如来大众眷属，其大声闻先般涅槃。若彼方有舍利弗住者，于彼方我则无事，然其彼方，我则不空，以有舍利弗故。我先已说故，汝今阿难，如我先说，所可爱念种种适意之事，皆是别离之法，是故汝今莫大愁毒。阿难当知，如来不久亦当过去。是故阿难，当作自洲而自依，当作法洲而法依，当作不异洲不异依。”
    阿难白佛：“世尊，云何自洲以自依？云何法洲以法依？云何不异洲不异依？”
    佛告阿难：“若比丘身身观念处，精勤方便，正智正念，调伏世间贪忧；如是外身、内外身，受、心、法法观念处，亦如是说。阿难，是名自洲以自依，法洲以法依，不异洲不异洲依。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六三九）

    如是我闻。一时佛住摩偷罗国跋陀罗河侧伞盖庵罗树林中。尊者舍利弗、目揵连涅槃未久。
    尔时世尊月十五日布萨时，于大众前敷座而坐。尔时世尊观察众会已，告诸比丘：“我观大众，见已虚空，以舍利弗、大目揵连般涅槃故。我声闻唯此二人，善能说法，教诫教授，辩说满足。有二种财，钱财及法财。钱财者，从世人求。法财者，从舍利弗、大目揵连求。如来已离世财及法财。
    “汝等莫以舍利弗、目揵连涅槃故，愁忧苦恼。譬如大树，根茎、枝叶、花果茂盛，大枝先折。亦如宝山，大岩先崩。如是如来大众之中，舍利弗、目揵连二大声闻先般涅槃。是故比丘，汝等勿生愁忧苦恼。何有生法、起法、作法、为法、坏败之法，而不磨灭？欲令不坏，无有是处。
    “我先已说，一切可爱之物，皆归离散。我今不久，亦当过去。是故汝等当知，自洲以自依，法洲以法依，不异洲不异依。谓内身身观念住，精勤方便，正智正念，调伏世间贪忧；如是外身、内外身，受、心、法法观念住，精勤方便，正智正念，调伏世间贪忧。是名自洲以自依，法洲以法依，不异洲不异依。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。


杂阿含经卷第二十五

（六四○）

    尔时世尊告尊者阿难：“此摩偷罗国，将来世当有商人子，名曰掘多。掘多有子，名优波掘多。我灭度后百岁，当作佛事，于教授师中最为第一。阿难，汝遥见彼青色丛林不？”
    阿难白佛：“唯然已见，世尊。”
    “阿难，是处名为优留曼茶山。如来灭后百岁，此山当有那吒跋置迦阿兰若处，此处随顺寂默，最为第一。”
    尔时世尊作是念：“我若以教法付嘱人者，恐我教法不得久住。若付嘱天者，恐我教法亦不得久住，世间人民则无有受法者。我今当以正法付嘱人、天，诸天、世人共摄受法者，我之教法则千岁不动。”
    尔时世尊起世俗心。时天帝释及四大天王，知佛心念，来诣佛所，稽首礼足，退坐一面。
    尔时世尊告天帝释及四大天王：“如来不久当于无余涅槃而般涅槃，我般涅槃后，汝等当护持正法。”
    尔时世尊复告东方天王：“汝当于东方护持正法。”
    次告南方、西方、北方天王：“汝当于北方护持正法。”
    “过千岁后，我教法灭时，当有非法出于世间，十善悉坏。阎浮提中，恶风暴起，水雨不时，世多饥馑，雨则灾雹，江河消减，花果不成，人无光泽，虫村、鬼村悉皆磨灭，饮食失味，珍宝沉没，人民服食粗涩草木。
    “时有释迦王、耶槃那王、钵罗婆王、兜沙罗王，众多眷属。如来顶骨、佛牙、佛钵，安置东方。西方有王名钵罗婆，百千眷属，破坏塔寺，杀害比丘。北方有王名耶槃那，百千眷属，破坏塔寺，杀害比丘。南方有王名释迦，百千眷属，破坏塔寺，杀害比丘。东方有王，名兜沙罗，百千眷属，破坏塔寺，杀害比丘。四方尽乱，诸比丘来集中国。
    “时拘睒弥国有王，名摩因陀罗西那。其王生子，手似血涂，身似甲胄，有大勇力。其生之日，五百大臣生五百子，皆类王子，血手胄身。时拘睒弥国一日雨血。拘睒弥王见此恶相，即大恐怖，请问相师。相师白王：‘王今生子，当王阎浮提，多杀害人。’生子七日，字曰难当，年渐长大。
    “时四恶王，从四方来杀人民。摩因陀罗西那王闻则恐怖。时有天神告言：‘大王，且立难当为王，足能降伏彼四恶王。’时摩因陀罗西那王，受天神教，即舍位与子。以髻中明珠，冠其子首，集诸大臣，香水灌顶。召五百大臣同日生子，身被甲胄，从王出征，与四恶王大众战，胜，杀害都尽。王阎浮提，治在拘睒弥国。”
    尔时世尊告四大天王：“巴连弗国，于彼国当有婆罗门，名曰阿耆尼达多，通达《毗陀》经论。彼婆罗门当纳妻，后时中阴众生，当来与其作子，入母胎中，时彼母欲与人论议。彼婆罗门即问诸相师。相师答云：‘是胎中众生，当了达一切论，故令母生如是论议之心，欲将人论议。’如是日月满足，出生母胎，以为童子，了达一切经论，恒以经论教授五百婆罗门子，及余诸论教授余人，以医方教医方者，如是有众多弟子。有众多弟子故，名曰弟子。次当从父母求出家学道，乃至父母听其出家。彼即于我法中出家学道，通达三藏，善能说法，辩才巧妙，言语谈说，摄多眷属。”
    又复世尊告四大天王：“即此巴连弗邑国中，当有大商主，名曰须陀那。中阴众生来入母胎，彼众生入母胎时，令母质直柔和，无诸邪想，诸根寂静。时彼商主即问相师。相师答曰：‘胎中众生，极为良善，故令母如是，乃至诸根寂静。’至月满足，便生童子，名曰修罗他。年纪渐长，乃至启白父母，求出家学道，父母即听于我法中出家学道。勤行精进，修习道业，便得漏尽，证阿罗汉果。然寡闻、少欲、知足及少知，旧居在山薮林间，山名揵陀摩罗。
    “时彼圣人，恒来为难当王说法。彼父王当无常，无常之日，难当见父过世，两手抱父尸，悲号啼哭，忧恼伤心。时彼三藏，将多眷属，来诣王所，为王说法。王闻法已，忧恼即止，于佛法中生大敬信，而发声唱言：‘自今以后，我施诸比丘无恐畏，适意为乐。’而问比丘：‘前四恶王，毁灭佛法，有几年岁？’诸比丘答云：‘经十二年。’王心念口言，作狮子吼：‘我当十二年中，当供养五众。’乃至办诸供具，即便行施。行施之日，天当降香泽之雨，遍阎浮提，一切实种皆得增长。诸方人众皆持供养，来诣拘睒弥国，供养众僧。
    “时诸比丘，大得供养。诸比丘辈，食人信施，而不读诵经书，不萨阇为人受经。戏论过日，眠卧终夜。贪著利养，好自严饰，身着妙服。离诸出要、寂静、出家、三菩提乐。形类比丘，离沙门功德，是法中之大贼，助作末世，坏正法幢，建恶魔幢，灭正法炬，燃烦恼火，坏正法鼓，毁正法轮，消正法海，坏正法山，破正法城，拔正法树，毁禅定、智慧，断戒璎珞，污染正道。
    “时彼天、龙、鬼、神、夜叉、乾闼婆等，于诸比丘所生恶意，毁訾诸比丘，厌恶远离，不复相亲。异口同音：‘呜呼！如是恶比丘，不应于如来法中。’而说偈言：

‘非吉行恶行，行诸邪见法，
此诸愚痴人，打坏正法山。
行诸恶戒法，弃诸如法行，
舍诸胜妙法，拔除今佛法。
不信不调伏，乐行诸恶行，
谄伪诳世间，打破牟尼法。
毁形习诸恶，凶暴及千行，
依法诳世人，忿恨自贡高，
贪著求名利，无恶业不备。
如佛所说法，法没有是相，
今者悉已见，智者所轻贱。
此法今出已，牟尼正法海，
不久当枯竭。正法今少在，
恶人复来灭，毁坏我正法！’

    “时彼诸天、龙、神等，皆生不欢喜心，不复当护诸比丘。而同声唱言：‘佛法却后七日灭尽！’号啕悲泣，共相谓言：‘至比丘说戒日，共相斗诤，如来正法于中而灭。’如是诸天悲恼啼泣。
    “时拘睒弥城中有五百优婆塞，闻诸天之言，共诣诸比丘众中，谏诸比丘斗诤。而说偈言：

‘呜呼苦剧岁，愍念群生生，
其法今便灭，释狮子王法。
恶轮坏法轮，如是尽金刚，
乃能不即坏，安隐时已灭，
危险法已起，明智人已过，
今见如是相，当知不复久。
牟尼法断灭，世间无复明，
离垢寂灭口，牟尼日今没。
世人失伏藏，善恶无差别，
善恶无差已，谁能得正觉？
法灯今在世，及时行诸善，
无量诸福田，此法今当灭。
是故我等辈，知财不坚牢，
及时取坚实。’

    “至十五日说戒时，法当没。尔日五百优婆塞，一日之中造五百佛塔。时诸优婆塞各有余务，不复来往众僧众中。
    “尔时住揵陀摩罗山，修罗他阿罗汉，观阎浮提，今日何处有众僧说戒？见有拘睒弥国，如来弟子说戒为布萨，即诣拘睒弥。
    “时彼僧众，乃有百千人。中唯有一阿罗汉，名曰修罗他。又复有一三藏，名曰弟子。此是如来最后大众集。尔时维那行沙罗筹，白三藏上座言：‘众僧已集，有百千人，今为说波罗提木叉。’时彼上座答言：‘阎浮提如来弟子皆来集此，数有百千。如是众中，我为上首，了达三藏，尚不学戒律，况复余者而有所学？今当为谁而说戒律？’而说偈言：

‘今是十五日，夜静月清明，
如是诸比丘，令集听说戒。
一切阎浮提，僧众最后集，
我是众中上，不学戒律法，
况复余僧众，而有所学习？
何能牟尼法，释迦狮子王，
彼戒谁有持，是人乃能说。’

    “尔时彼阿罗汉修罗他，立上座前，合掌白上座言：‘上座，但说波罗提木叉。如佛在世时，舍利弗、目揵连等大比丘众所学法，我今已悉学。如来虽灭度，于今已千岁，彼所制律仪，我悉已备足。’而说偈言：

‘上座听我语，我名修罗他，
漏尽阿罗汉，僧中狮子吼，
牟尼真弟子。’

    “信佛诸鬼神，闻彼圣所说，悲哀泣流泪，低头念法灭：

‘从今去已后，无有说法者，
毗尼别解脱，不复在于世。
法桥今已坏，法水不复流，
法海已枯竭，法山已崩颓。
法会从今绝，法幢不复见，
法足不复行，律仪戒永没。
法灯不复照，法轮不复转，
闭塞甘露门，法师不在世。
善人说妙道，众生不识善，
不异于野兽。’

    “尔时佛母摩诃摩耶夫人，天上来下，诣诸众僧所，号啕啼泣：‘呜呼苦哉！是我之子经历阿僧祇劫，修诸苦行，不顾劳体，积德成佛。今者忽然消灭！’而说偈言：

‘我是佛亲母，我子积苦行，
经历无数劫，究竟成真道。
悲泣不自胜，念法忽磨灭，
呜呼智慧人，尔今何所在！
持法舍诤讼，从佛口所生，
诸王无上尊，真实佛弟子。
头陀修妙行，宿止林薮间，
如是真佛子，今为何所在！
今者于世间，无有诸威德，
旷野山林间，诸神寂无言。
施戒愍群生，信戒自庄严，
忍辱质直行，观察诸善恶，
如是诸胜法，今忽都已尽！’

    “尔时彼上座弟子作是念言：‘彼修罗他比丘自言，如来所制戒律，我悉备持。’尔时上座有弟子名曰安伽陀，起不忍之心，极生忿恨，从座起，骂辱彼圣：‘汝是下座比丘，愚痴无智，而毁辱我和尚！’即持利刀，杀彼圣人。而说偈言：

‘我名安伽陀，失沙之弟子，
利剑杀汝身，自谓我有德。’

    “尔时有一鬼，名曰大提木佉，作是念言：‘世间唯有此一阿罗汉，而为恶比丘弟子所害！’执持金刚利杵，杵头火燃，以此打破彼头，即便命终。而说偈言：

‘我是恶鬼神，名大提木佉，
以此金刚杵，破汝头七分！’

    “尔时阿罗汉弟子，见彼弟子杀害其师，忿恨不忍，即杀三藏。
    “尔时诸天、世人，悲哀啼泣：‘呜呼苦哉！如来正法今便都尽！’寻即此大地六种震动，无量众生号啕啼泣，极为愁恼：‘呜呼！今日正法不复现世！’作是语已，各各离散。
    “尔时拘睒弥国五百优婆塞闻已，往诣寺中，举手拍头，高声大哭：‘呜呼！如来愍念世间，济诸群生，无有巨细，谁当为我说法义？今者人天解脱不复可得！众生今日犹在暗暝，无有引导，长习诸恶，以此为欢，如诸野兽。不闻牟尼妙法，身坏命终，堕在三途，譬如流星。世人从今已后，无复念慧、寂静、三昧、十力妙法。’
    “尔时拘睒弥王，闻诸比丘杀真人阿罗汉，及三藏法师，心生悲恼，惋慨而坐。尔时诸邪见辈，诤竞打破塔庙，及害比丘，从是佛法索然顿灭。”
    尔时世尊语释提桓因、四大天王：“诸天、世人，于我灭度之后，法尽之相，如上所说。是故汝等今者不可不以勤力加于精进，护持正法，久令在世。”
    尔时诸天、世人，闻佛所说，各各悲颜，以手挥泪，顶礼佛足，各自退去。

（六四一）
阿育王施半阿摩勒果因缘经

    阿育王于如来法中得大敬信，时王问诸比丘言：“谁于如来法中，行大布施？”
    诸比丘白王言：“给孤独长者最行大施。”
    王复问曰：“彼施几许宝物？”
    比丘答曰：“以亿千金。”
    王闻已，如是思惟：“彼长者尚能舍亿千金，我今为王，何缘复以亿千金施？当以亿百千金施。”
    时王起八万四千佛塔，于彼一一塔中，复施百千金。复作五岁大会，会有三百千比丘，用三百亿金供养。于彼僧众中，第一分是阿罗汉，第二分是学人，第三分是真实凡夫。除私库藏，此阎浮提夫人、婇女、太子、大臣，施与圣僧，四十亿金还复赎取。如是计校，用九十六亿千金。
    乃至王得重病，时王自知命欲终尽。时有大臣名罗陀崛多，时王宿命是施佛土时同伴小儿。时彼大臣罗陀崛多，见王重病，命垂欲尽，稽首以偈问曰：

“颜貌常鲜泽，百千婇女绕，
譬如诸莲花，蜜蜂当聚集。
今睹圣王颜，无有诸鲜泽。”

    王即以偈答：

“我今无所忧，失财及王位，
此身及余亲，及诸种种宝。
我今所愁者，不复睹贤圣，
四事以供养，我今唯念此，
颜色有变异，心意无所宁。

    “又复我常所愿，欲以满亿百千金作功德。今愿不得满足，便就后世。”
    时计校前后所施金银珍宝，唯减四亿未满。王即办诸珍宝，送与鸡雀寺中。
    法益之子名三波提，为太子诸臣等启太子言：“大王将终不久，今以此珍宝送与寺舍中。今库藏财宝已竭，诸王法以物为尊，太子今宜断之，勿使大王用尽也。”时太子即敕典藏者，勿复出与大王用之。
    时大王自知索诸物不复能得，所食金器送与寺中。时太子令断金器，给以银器，王食已，复送与寺中。又断银器，给以铜器，王亦以此送与寺中。又断铜器，给以瓦器。
    时大王手中有半阿摩勒果，悲泪告诸大臣：“今谁为地主？”
    时诸臣启白大王：“王为地主。”
    时王即说偈答曰：

“汝等护我心，何假虚妄语，
我今坐王位，不复得自在。
阿摩勒半果，今在于我手，
此即是我有，于是得自由。
呜呼尊富贵，可厌可弃舍，
先领阎浮提，今一旦贫至。
如恒河驶流，一逝而不返，
富贵亦复然，逝者不复还。

    “又复如佛偈所说：

“凡盛必有衰，以衰为究竟，
如来神口说，真实无有异。
先时所教令，速疾无有碍，
今有所求索，无复从我教。
如风碍于山，如水碍于岸，
我今所教令，于今已永绝。
将从无量众，击鼓吹贝螺，
常作诸伎乐，受诸五欲乐，
婇女数百众，日夜自娱乐，
今者都永尽，如树无花实。
颜貌转枯尽，色力亦复然，
如花转萎悴，我今亦复尔。”

    时阿育王呼侍者言：“汝今忆我恩养，汝持此半阿摩勒果，送鸡雀寺中，作我意礼拜诸比丘僧足，白言：‘阿育王问讯诸大圣众！我是阿育王，领此阎浮提，阎浮提是我所有，今者顿尽，无有财宝布施众僧，于一切财而不得自在。今唯此半阿摩勒果，我得自由，此是最后布施檀婆罗蜜，哀愍我故，纳受此施，令我得供养僧福。’而说偈言：

“半阿摩勒果，是我之所有，
于我得自在，今舍于大众。
缘心在于圣，更无济我者，
怜愍于我故，纳受阿摩勒。
为我食此施，因是福无量，
世世受妙乐，用之无有尽。”

    时彼使者受王敕已，即持此半阿摩勒果，至鸡雀寺中。至上座前，五体着地作礼，长跪合掌，向上座而说偈曰：

“领于阎浮提，一伞击一鼓，
游行无所碍，如日照于世。
业行报已至，在世不复久，
无有王威德，如日云所翳。
号曰阿育王，稽首礼僧足，
送此布施物，谓半阿摩勒，
愿求来世福，哀愍彼王故。
圣众愍彼故，受是半果施！”

    时彼上座告诸大众：“谁闻是语而不厌世间？我等闻是事，不可不生厌离。如佛经所说，见他衰事，应生厌离。若有识类众生者，闻是事岂得不舍世间？”而说偈曰：

“人王世中最，阿育孔雀姓，
阎浮提自在，阿摩勒为主。
太子及诸臣，共夺大王施，
送半阿摩勒，降伏吝财者，
使彼生厌心。愚夫不识施，
因果受妙乐，示送半摩勒。”

    时彼上座作是念言：“云何令此半阿摩勒，一切众僧得其分食？”即教令研磨，着石榴羹中，行已众僧一切皆得周遍。
    时王复问傍臣曰：“谁是阎浮提王？”
    臣启王言：“大王是也。”
    时王从卧起而坐，顾望四方，合掌作礼，念诸佛德，心念口言：“我今复以此阎浮提施与三宝，随意用之。”而说偈曰：

“今此阎浮提，多有珍宝饰，
施与良福田，果报自然得。
以此施功德，不求天帝释，
梵王及人主，世界诸妙乐，
如是等果报，我悉不用受。
以是施功德，疾得成佛道，
为世所尊仰，成得一切智，
世间作善友，导师最第一。”

    时王以此语，尽书纸上，而封缄之，以齿印印之。作如是事毕，便即就尽。
    尔时太子及诸臣、宫人、婇女、国界人民，兴种种供养葬送，如王之法而阇维之。
    尔时诸臣欲立太子绍王位。中有一大臣，名曰阿[少/兔]罗陀，语诸臣曰：“不得立太子为王。所以者何？大王阿育在时，本誓愿满十万亿金作诸功德，唯减四亿，不满十万。以是故，今舍阎浮提施与三宝，欲令满足。今是大地属于三宝，云何而立为王？”
    时诸臣闻已，即送四亿诸金，送与寺中，即便立法益之子为王，名三波提。次复太子名毗梨诃波低，为绍王位。毗梨诃波低太子名曰毗梨诃西那，次绍王位。毗梨诃西那太子名曰沸沙须摩，次绍王位。沸沙须摩太子名曰沸沙蜜多罗，次绍王位。
    时沸沙蜜多罗问诸臣曰：“我当作何等事，令我名德，久存于世？”
    时贤善诸臣，信乐三宝者，启王言：“阿育大王是王之前种姓，彼王在世，造立八万四千如来塔，复兴种种供养，此之名德，相传至今。王欲求此名者，当造立八万四千塔，及诸供养。”
    王言：“大王阿育有大威德，能办此事。我不能作，更思余事。”
    中有恶臣，不信向者，启王言：“世间二种法，传世不灭，一者作善，二者作恶。大王阿育作诸善行，王今当行恶行，打坏八万四千塔。”
    时王用佞臣语，即兴四兵众，往诣寺舍，坏诸塔寺。王先往鸡雀寺中，寺门前有石狮子，即作狮子吼。王闻之即大惊怖：“非生兽之类，而能吼鸣？”还入城中。如是再三，欲坏彼寺。
    时王呼诸比丘来，问诸比丘：“使我坏塔为善，坏僧房为善？”
    比丘答曰：“二不应行。王其欲坏者，宁坏僧房，勿坏佛塔。”
    时王杀害比丘，及坏塔寺。如是渐渐至婆伽罗国，又复唱令：“若有人能得沙门释子头来者，赏之千金。”
    尔时彼国中有一阿罗汉，化作众多比丘头，与诸百姓，令送至于王所，令库藏财宝竭尽。时彼王闻阿罗汉作如是事，倍复瞋恚，欲杀彼阿罗汉。时彼罗汉入灭尽正受。王作无量方便，杀彼圣人，终不能得。入灭尽三昧力故，不伤其体。
    如是渐进至佛塔门边。彼所塔中有一鬼神，止住其中，守护佛塔，名曰牙齿。彼鬼神作是念：“我是佛弟子，受持禁戒，不杀害众生，我今不能杀害于王。”又复作念：“有一神名曰为虫，行诸恶行，凶暴勇健，求索我女，我不与之。今者为护正法故，当嫁与彼，令其守护佛法。”即呼彼神语言：“我今嫁女与汝，然共立约誓，汝要当降伏此王，勿使兴诸恶行，坏灭正法。”
    时王所有一大鬼神，名曰乌茶，威德具足，由彼神故，不奈王何。时牙齿神作方便：“今日王威势自然，由此鬼神，我今诱诳共作亲厚。”如是与彼神作知识，极作知识已，即将此神至于南方大海中。
    时彼虫神排挡大山，磓笮王上及四兵众，无不死尽。众人唱言：“快哉！快哉！”是世人相传，名为“快哉”。彼王终亡，孔雀苗裔于此永终，是故世间富乐不足为贪。
    阿育大王有智之人，觉世无常，身命难保，五家财物亦如幻化。觉了彼法，勤行精进，作诸功德，乃至临终系心三宝，念念不绝，无所吝惜，唯愿尽成阿耨多罗三藐三菩提。


杂阿含经卷第二十六

（六四二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有三根：未知当知根、知根、无知根。”
    尔时世尊即说偈言：

“觉知学地时，随顺直道进，
精进勤方便，善自护其心。
如自知生尽，无碍道已知，
以知解脱已，最后得无知。
不动意解脱，一切有能尽，
诸根悉具足，乐于根寂静，
持于最后身，降伏众魔怨。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六四三）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五根。何谓为五？谓信根、精进根、念根、定根、慧根。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六四四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五根。何等为五？谓信根、精进根、念根、定根、慧根。若比丘于此五根如实善观察，如实善观察者，于三结断知，谓身见、戒取、疑。是名须陀洹，不堕恶趣法，决定向于正觉，七有天人往生，究竟苦边。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六四五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于此五根如实观察者，不起诸漏，心得离欲解脱，是名阿罗汉，诸漏已尽，所作已作，离诸重担，逮得己利，尽诸有结，正智心善解脱。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六四六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五根。何等为五？谓信根、精进根、念根、定根、慧根。信根者，当知是四不坏净。精进根者，当知是四正断。念根者，当知是四念处。定根者，当知是四禅。慧根者，当知是四圣谛。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六四七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五根。何等为五？谓信根、精进根、念根、定根、慧根。
    “何等为信根？若比丘于如来所起净信心，根本坚固，余诸天、魔、梵、沙门、婆罗门，及余世间，无能沮坏其心者，是名信根。
    “何等为精进根？已生恶不善法令断，生欲方便，摄心增进；未生恶不善法不起，生欲方便，摄心增进；未生善法令起，生欲方便，摄心增进；已生善法住不忘，修习增广，生欲方便，摄心增进，是名精进根。
    “何等为念根？若比丘内身身观住，殷勤方便，正念正智，调伏世间贪忧；外身、内外身，受、心、法法观念住亦如是说，是名念根。
    “何等为定根？若比丘离欲恶不善法，有觉有观，离生喜乐，乃至第四禅具足住，是名定根。
    “何等为慧根？若比丘苦圣谛如实知，苦集圣谛、苦灭圣谛、苦灭道迹圣谛如实知，是名慧根。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六四八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“若比丘于此五根如实观察已，于三结断知。何等为三？谓身见、戒取、疑。是名须陀洹，不堕恶趣，决定正向三菩提，七有天人往生，究竟苦边。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六四九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“若比丘于此五根如实观察已，得尽诸漏，离欲解脱，是名阿罗汉，诸漏已尽，所作已作，离诸重担，逮得己利，尽诸有结，正智心得解脱。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六五○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“诸比丘，若我于此信根、信根集、信根灭、信根灭道迹不如实知者，我终不得于诸天、魔、梵、沙门、婆罗门中，为出为离，心离颠倒，亦不得成阿耨多罗三藐三菩提。如信根，精进根、念根、定根、慧根，亦如是说。
    “诸比丘，我于此信根正智如实观察故，信根集、信根灭、信根灭道迹正智如实观察故，我于诸天、魔、梵、沙门、婆罗门众中，为出为离，心离颠倒，成阿耨多罗三藐三菩提。如信根，精进、念、定、慧根，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六五一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“诸比丘，我此信根集、信根没、信根味、信根患、信根离不如实知者，我不得于诸天、魔、梵、沙门、婆罗门众中，为解脱，为出，为离，心离颠倒，成阿耨多罗三藐三菩提。如是精进根、念根、定根、慧根，亦如是说。
    “诸比丘，我于信根、信根集、信根没、信根味、信根患、信根离如实知故，于诸天、魔、梵、沙门、婆罗门众中，为解脱，为出，为离，心离颠倒，得成阿耨多罗三藐三菩提。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六五二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“若比丘于此五根，若利若满足，得阿罗汉；若软若劣，得阿那含；若软若劣，得斯陀含；若软若劣，得须陀洹。满足者成满足事，不满足者成不满足事，于此五根不空无果。若于此五根一切无者，我说彼为外道凡夫之数。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六五三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“若比丘于彼五根增上明利满足者，得阿罗汉俱分解脱；若软若劣者，得身证；于彼若软若劣，得见到；于彼若软若劣，得信解脱；于彼若软若劣，得一种；于彼若软若劣，得斯陀含；于彼若软若劣，得家家；于彼若软若劣，得七有；于彼若软若劣，得法行；于彼若软若劣，得信行。是名比丘根波罗蜜因缘，知果波罗蜜；果波罗蜜因缘，知人波罗蜜。如是满足者作满足事，减少者作减少事，于彼诸根则不空无果。若无此诸根者，我说彼为作凡夫数。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六五四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五根。何等为五？谓信根、精进根、念根、定根、慧根。此五根，一切皆为慧根所摄受。譬如堂阁众材，栋为其首，皆依于栋，以摄持故。如是五根，慧为其首，以摄持故。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六五五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五根。何等为五？谓信根、精进根、念根、定根、慧根。信根者，当知是四不坏净。精进根者，当知是四正断。念根者，当知是四念处。定根者，当知是四禅。慧根者，当知是四圣谛。此诸功德，一切皆是慧为其首，以摄持故。”
    乃至佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六五六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五根。何等为五？信根、精进根、念根、定根、慧根。若圣弟子成就慧根者，能修信根，依离、依无欲、依灭、向于舍，是名信根成就；信根成就，即是慧根。如信根，如是精进根、念根、定根、慧根，亦如是说。是故就此五根，慧根为其首，以摄持故。譬如堂阁，栋为其首，众材所依，以摄持故。如是五根，慧为其首，以摄持故。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六五七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五根。何等为五？信根、精进根、念根、定根、慧根。若圣弟子成就信根者，作如是学：圣弟子无始生死，无明所著，爱所系，众生长夜生死，往来流驰，不知本际。有因故有生死，因永尽者则无生死。无明大闇聚障碍，谁般涅槃？唯苦灭、苦息、清凉、没。如信根，如是精进根、念根、定根、慧根，亦如是说。此五根，慧为首，慧所摄持。譬如堂阁，栋为首，栋所摄持。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六五八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五根：信根、精进根、念根、定根、慧根。何等为信根？谓圣弟子于如来所起信心，根本坚固，诸天、魔、梵、沙门、婆罗门及诸世间法，所不能坏，是名信根。何等为精进根？谓四正断。何等为念根？谓四念处。何等为定根？谓四禅。何等为慧根？谓四圣谛。此诸功德，皆以慧为首，譬如堂阁，栋为其首。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六五九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五根。何等为五？谓信根、精进根、念根、定根、慧根。何等为信根？若圣弟子于如来发菩提心，所得净信心，是名信根。何等为精进根？于如来发菩提心，所起精进方便，是名精进根。何等为念根？于如来初发菩提心，所起念，是名念根。何等为定根？于如来初发菩提心，所起三昧，是名定根。何等为慧根？于如来初发菩提心，所起智慧，是名慧根。譬如堂阁，余如上说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六六○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五根。何等为五？谓信根、精进根、念根、定根、慧根。于此五根修习多修习，过去、未来、现在一切苦断。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如苦断，如是究竟苦边、苦尽、苦息、苦没、度苦流、于缚得解、害诸色，过去、未来、现在一切漏尽，亦如是说。

（六六一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有二种力。何等为二？谓数力及修力。
    “何等为数力？谓圣弟子坐闲林中树下，作如是思惟：身恶行，现法、后世受于恶报。我若行身恶行者，我当自悔，教他亦悔我，大师亦当悔我，大德梵行亦当悔我，以法责我，恶名流布；身坏命终，当生恶趣泥犁中。如是现法、后报身恶行断，修身善行。如身恶行，口、意恶行亦如是说，是名数力。
    “何等为修力？若比丘学于数力，圣弟子数力成就已，随得修力；得修力已，修力满足。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六六二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“圣弟子学数力成就已，贪、恚、痴若节若尽。如是圣弟子依于数力，尽立数力，随得修力；得修力已，修力满足。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六六三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“何等为修力？谓修四念处。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如四念处，如是修四正断、四如意足、五根、五力、七觉分、八圣道分、四道、四法句、止观，亦如是说。

（六六四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有三种力，何等为三？谓信力、精进力、慧力。复次三力，何等为三？谓信力、念力、慧力。复次三力，何等为三？谓信力、定力、慧力。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六六五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有三力，谓信力、精进力、慧力。如是比丘，当作是学，我当成就信力、精进力、慧力。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如精进力，念力、定力亦如是说。

（六六六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有三力，信力、念力、慧力。何等为信力？谓圣弟子于如来所入于净信，根本坚固，诸天、魔、梵、沙门、婆罗门及诸同法所不能坏，是名信力。何等为精进力？谓修四正断。何等为慧力？谓四圣谛。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    余二力，如上说。

（六六七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四力。何等为四？谓信力、精进力、念力、慧力。复次四力，信力、念力、定力、慧力。复次四力，觉力、精进力、无罪力、摄力。”
    此诸经，如上三力说，差别者：“何等为觉力？于善、不善法如实知，有罪、无罪，习近、不习近，卑法、胜法，黑法、白法，有分别法、无分别法，缘起法、非缘起法如实知，是名觉力。何等为精进力？谓四正断，如前广说。何等为无罪力？谓无罪身、口、意，是名无罪力。何等为摄力？谓四摄事，惠施、爱语、行利、同利。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六六八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“若最胜施者，谓法施。最胜爱语者，谓善男子乐闻，应时说法。行利最胜者，谓不信者能令入信，建立于信；立戒者以净戒，悭者以施，恶智者以正智令入建立。同利最胜者，谓阿罗汉以阿罗汉、阿那含以阿那含、斯陀含以斯陀含、须陀洹以须陀洹、净戒者以净戒而授于彼。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六六九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“若所有法是众之所取，一切皆是四摄事，或有一取施者，或一取爱语者，或一取行利者，或一取同利者。过去世时，过去世众以有所取者，亦是四摄事。未来世众，当有所取者，亦是四摄事，或一取施者，或一取爱语，或一取行利者，或一取同利。”
    尔时世尊即说偈言：

“布施及爱语，或有行利者，
同利诸行生，各随其所应，
以此摄世间，犹车因工运。
世无四摄事，母恩子养忘，
亦无父等尊，谦下之奉事。
以有四摄事，随顺之法故，
是故有大士，德被于世间。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六七○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四力。何等为四？谓觉力、精进力、无罪力、摄力，如上说。若比丘成就此四力者，得离五恐怖。何等为五？谓不活恐怖、恶名恐怖、众中恐怖、死恐怖、恶趣恐怖，是名五恐怖。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六七一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“圣弟子成就此四力者，当作是学：我不畏不活，我何缘畏不活？若身行不净行，口不净行，意不净行，作诸邪贪、不信、懈怠、不精进、失念、不定、恶慧、悭、不摄者，彼应畏不活。我有四力，谓觉力、精进力、无罪力、摄力，有此四力成就故，不应畏。”
    如不活畏，如是恶名畏、众中畏、死畏、恶趣畏，亦如上说。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六七二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四力，觉力、精进力、无罪力、摄力。
    “何等为觉力？谓慧、大慧、深慧、难胜慧，是名觉力。
    “何等为精进力？若于不善法、不善数，黑、黑数，有罪、有罪数，不应亲近、不应亲近数，离此诸法已；若诸余善、善数，白、白数，无罪、无罪数，应亲近、应亲近数，如此等修习，增上精勤，欲方便堪能，正念正知而学，是名精进力。”
    无罪力、摄力，如上修多罗说。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六七三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五力。何等为五？信力、精进力、念力、定力、慧力。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（六七四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“诸比丘当作是学：我当勤加精进，成就信力、精进力、念力、定力、慧力。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六七五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“彼信力，当知是四不坏净。精进力者，当知是四正断。念力者，当知是四念处。定力者，当知是四禅。慧力者，当知是四圣谛。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六七六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“是故诸比丘，当作是学：我成就信力、精进力、念力、定力、慧力。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六七七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五学力。何等为五？谓信力是学力，精进力是学力，惭力是学力，愧力是学力，慧力是学力。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六七八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“诸比丘，当作是学：我当成就信力是学力，成就精进力是学力，成就惭力是学力，成就愧力是学力，成就慧力是学力。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六七九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“何等信力是学力？于如来所，善入于信，根本坚固，诸天、魔、梵、沙门、婆罗门及余同法，所不能坏。
    “何等为精进力是学力？谓四正断，如前广说。
    “何等为惭力是学力？谓羞耻，耻于起恶不善法、诸烦恼数，受诸有炽然苦报，于未来世生老病死、忧悲苦恼，是名惭力是学力。
    “何等为愧力是学力？谓诸可愧事而愧，愧起诸恶不善法、烦恼数，受诸有炽然苦报，于未来世生老病死、忧悲苦恼，是名愧力是学力。
    “何等为慧力是学力？谓圣弟子住于智慧，成就世间生灭智慧，贤圣出、厌离、决定、正尽苦，是名慧力是学力。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六八○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“是故诸比丘，当作是学：我当成就信力是学力，精进力、惭力、愧力、慧力是学力。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六八一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘于善法若变、若退、若不久住者，他人审以五种白法来呵责汝。何等为五？言汝不以信入于善法，若依信者，能离不善法，修诸善法；汝无精进、无惭、无愧、无慧入于善法故，若依慧者，能离诸不善法，修诸善法。
    “若比丘于正法不变、不退、久住者，他人当以五种白法来庆慰汝。何等为五？正信入于善法，若依信者，离不善法，修诸善法；精进、惭、愧、慧入于善法，若依慧者，离不善法，修诸善法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六八二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘还戒者、退戒者，他人当以五种白法来呵责汝。何等为五？若比丘不以信入于善法，若依信者，离不善法，修诸善法；不以精进、惭、愧、慧入于善法，若依慧者，离不善法，修诸善法。
    “若比丘尽其寿命，纯一满净，梵行清白者，他人当以五种白法来庆慰汝，如上说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六八三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘若不欲令恶不善法生者，唯有信善法；若信退减者，不信永住，诸不善法则生。乃至欲令恶不善法不生者，唯有精进、惭、愧、慧；若精进、惭、愧、慧力退减，恶慧永住者，恶不善法则生。若比丘依于信者，则离不善法，修诸善法；依精进、惭、愧、慧者，则离不善法，修诸善法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六八四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘于色生厌、离欲、灭尽、不起、解脱，是名阿罗诃、三藐三佛陀；受、想、行、识，亦如是说。若复比丘于色生厌、离欲、不起、解脱者，是名阿罗汉慧解脱；受、想、行、识，亦如是说。诸比丘，如来、应、等正觉，阿罗汉慧解脱，有何种种别异？”
    诸比丘白佛：“世尊是法根、法眼、法依，唯愿为说，诸比丘闻已，当受奉行。”
    佛告比丘：“谛听善思，当为汝说。如来、应、等正觉者，先未闻法，能自觉知，现法自知得三菩提，于未来世能说正法，觉诸声闻，所谓四念处、四正断、四如意足、五根、五力、七觉分、八圣道分，是名如来、应、等正觉，所未得法能得，未制梵行能制，能善知道、善说道，为众将导。然后声闻成就随法随道，乐奉大师教诫教授，善于正法。是名如来、应、等正觉，阿罗汉慧解脱，种种别异。
    “复次五学力、如来十力。何等为学力？谓信力、精进力、念力、定力、慧力。
    “何等为如来十力？谓如来处非处如实知，是名如来初力。若成就此力者，如来、应、等正觉得先佛最胜处智，转于梵轮，于大众中能狮子吼而吼。
    “复次如来于过去、未来、现在业法受因事报如实知，是名第二如来力。如来、应、等正觉成就此力，得先佛最胜处智，能转梵轮，于大众中作狮子吼而吼。
    “复次如来、应、等正觉，禅、解脱、三昧、正受，染恶、清净处净如实知，是名如来第三力。若此力成就，如来、应、等正觉得先佛最胜处智，能转梵轮，于大众中狮子吼而吼。
    “复次如来知众生种种诸根差别如实知，是名如来第四力。若成就此力，如来、应、等正觉得先佛最胜处智，能转梵轮，于大众中狮子吼而吼。
    “复次如来悉知众生种种意解如实知，是名第五如来力。若此力成就，如来、应、等正觉得先佛最胜处智，能转梵轮，于大众中狮子吼而吼。
    “复次如来悉知世间众生种种诸界如实知，是名第六如来力。若于此力成就，如来、应、等正觉得先佛最胜处智，能转梵轮，于大众中狮子吼而吼。
    “复次如来于一切至处道如实知，是名第七如来力。若此力成就，如来、应、等正觉得先佛最胜处智，能转梵轮，于大众中狮子吼而吼。
    “复次如来于过去宿命种种事忆念，从一生至百千生，从一劫至百千劫，我尔时于彼生，如是族、如是姓、如是名、如是食、如是苦乐觉、如是长寿、如是久住、如是寿分齐，我于彼处死此处生，此处死彼处生，如是行、如是因、如是方，宿命所更，悉如实知，是名第八如来力。若此力成就，如来、应、等正觉得先佛最胜处智，能转梵轮，于大众中狮子吼而吼。
    “复次如来以天眼净过于人眼，见众生死时、生时、妙色、恶色、下色、上色、向于恶趣、向于善趣，随业法受，悉如实知：此众生身恶业成就，口、意恶业成就，谤毁贤圣，受邪见业，以是因缘，身坏命终，堕恶趣，生地狱中；此众生身善行，口、意善行，不谤贤圣，正见业法受，彼因彼缘，身坏命终，生善趣天上，悉如实知，是名第九如来力。若此力成就，如来、应、等正觉得先佛最胜处智，能转梵轮，于大众中狮子吼而吼。
    “复次如来诸漏已尽，无漏心解脱、慧解脱，现法自知身作证：我生已尽，梵行已立，所作已作，自知不受后有。是名第十如来力。若此力成就，如来、应、等正觉得先佛最胜处智，能转梵轮，于大众中狮子吼而吼。
    “如此十力，唯如来成就，是名如来与声闻种种差别。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六八五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“譬如婴儿，父母生已，付其乳母，随时摩拭，随时沐浴，随时乳哺，随时消息。若乳母不谨慎者，儿或以草、以土诸不净物，着其口中，乳母当即教令除去。能时除却者善，儿不能自却者，乳母当以左手持其头，右手探其哽。婴儿当时虽苦，乳母要当苦探其哽，为欲令其子长夜安乐故。”
    佛告诸比丘：“若婴儿长大，有所识别，复持草土诸不净物着口中不？”
    比丘白佛：“不也，世尊。婴儿长大，有所别知，尚不以脚触诸不净物，况着口中。”
    佛告比丘：“婴儿小时，乳母随时料理消息。及其长大，智慧成就，乳母放舍，不勤消息，以其长大不自放逸故。如是比丘，若诸声闻始学，智慧未足，如来以法随时教授而消息之。若久学智慧深固，如来放舍，不复随时殷勤教授，以其智慧成就不放逸故。是故声闻五种学力，如来成就十种智力，如上广说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六八六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“如来有六种力，若六种力成就，如来、应、等正觉得先佛最胜处智，能转梵轮，于大众中狮子吼而吼。谓处非处如实知，如来初力。复次过去、未来、现在，心乐法受如实知，如上广说，是名第二如来力。复次如来禅、解脱、三昧、正受如实知，如上广说，是名如来第三力。复次如来过去种种宿命之事如实知，如上广说，是名如来第四力。复次如来天眼净过于人眼，见诸众生死此生彼，如上广说，是名如来第五力。复次如来结漏已尽，无漏心解脱、慧解脱，如上广说，乃至于众中狮子吼而吼，是名如来第六力。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六八七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“若有来问我如来处非处智力，如如来处非处智力所知见觉，成等正觉，为彼记说。若复来问如来自以乐受智力，如如来自以乐受智力所知见觉，成等正觉，为彼记说，是名第二如来智力。若有来问如来禅定、解脱、三昧、正受智力，如如来禅定、解脱、三昧、正受，为彼记说。若有来问宿命所更智力，如如来宿命所更所知见觉，为彼记说。若有来问如来天眼智力，如如来天眼所见，为彼记说。若有来问如来漏尽智力，如如来漏尽智力所知见觉，为彼记说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六八八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有七力。何等为七？信力、精进力、惭力、愧力、念力、定力、慧力。”
    尔时世尊即说偈言：

“信力精进力，惭力及愧力，
正念定慧力，是说名七力，
成就七力者，得尽诸有漏。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六八九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有七力。”如上说，差别者：“是故比丘当如是学，我当成就信力，如是精进力、惭力、愧力、念力、定力、慧力，亦当学。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六九○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有七力。”如上说，差别者：尔时世尊即说偈言：

“信力精进力，及说惭愧力，
念力定慧力，是名为七力，
七力成就者，疾断诸有漏。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六九一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有七力。何等为七？信力、精进力、惭力、愧力、念力、定力、慧力。何等为信力？于如来所起信心，深入坚固，诸天、魔、梵、沙门、婆罗门及余同法，所不能坏，是名信力。何等为精进力？谓四正断，如上广说。何等为惭力？谓耻恶不善法，如上说。何等为愧力？于可愧事愧，愧起恶不善法，如上说。何等为念力？谓四念处，如上说。何等为定力？谓四禅，如上说。何等为慧力？谓四圣谛，如上说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六九二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有八力。何等为八？谓自在王者力、断事大臣力、结恨女人力、啼泣婴儿力、毁呰愚人力、审谛黠慧力、忍辱出家力、计数多闻力。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六九三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“谓自在王力者，王者现自在威力。断事大臣力者，大臣现断事之力。结恨女人力者，女人之法，现结恨力。啼泣婴儿力者，婴儿之法，现啼泣力。毁呰愚人力者，愚人之法，触事毁呰。审谛黠慧力者，智慧之人，常现审谛。忍辱出家力者，出家之人，常现忍辱。计数多闻力者，多闻之人，常现思惟计数。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六九四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者舍利弗诣世尊所，稽首礼足，退坐一面，白佛言：“世尊，漏尽比丘有几力？”
    佛告舍利弗：“漏尽比丘有八力。何等为八？谓漏尽比丘心顺趣于离、流注于离、浚输于离，顺趣于出、流注于出、浚输于出，顺趣涅槃、流注涅槃、浚输涅槃。若见五欲，犹见火坑。如是见已，于欲念、欲受、欲著，心不永住，修四念处、四正断、四如意足、五根、五力、七觉分、八圣道分。”
    佛说此经已，尊者舍利弗闻佛所说，欢喜奉行。

（六九五、六九六）

    如尊者舍利弗问经，如是异比丘问、佛问诸比丘二经，亦如上说。

（六九七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有九力。何等为九力？谓信力、精进力、惭力、愧力、念力、定力、慧力、数力、修力。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六九八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有九力。何等为九？谓信力、精进力、惭力、愧力、念力、定力、慧力、数力、修力。何等为信力？于如来所，起正信心，深入坚固，如上说。何等为精进力？谓四正断，如上说。何等为惭力？如上说。何等为愧力？如上说。何等为念力？谓内身身观住，如上说。何等为定力？谓四禅。何等为慧力？谓四圣谛。何等为数力？谓圣弟子若于闲房树下，作如是学：身、口、恶行者，于现法、后世当受恶报，如上广说。何等为修力？谓修四念处，如前说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（六九九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有十力。何等为十？自在王者力、断事大臣力、机关工巧力、刀剑贼盗力、结恨女人力、啼泣婴儿力、毁呰愚人力、审谛黠慧力、忍辱出家力、计数多闻力。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七○○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“谓自在王力者，王者现自在威力。断事大臣力者，大臣现断事之功力。机关工巧力，造机关者现其工巧力。刀剑盗贼力，盗贼必现刀剑力。结恨女人力者，女人之法，现结恨力。啼泣婴儿力者，婴儿之法，现啼泣力。毁呰愚人力者，愚人之法，触事毁呰。审谛黠慧力者，智慧之人，常现审谛。忍辱出家力者，出家之人，常现忍辱。计数多闻力者，多闻之人，常现思惟计数。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七○一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有十种如来力，若此力成就，如来、应、等正觉得先佛最胜处，能转梵轮，于大众中狮子吼而吼。何等为十？谓如来处非处如实知，是名初力；乃至漏尽，如上说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七○二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“若有来问如来处非处智力，如如来处非处智力，所知所见所觉，成等正觉，为彼记说。如是乃至漏尽智力，广说如上。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七○三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若所有法，彼彼意解作证，悉皆如来无畏智所生。若比丘来，为我声闻，不谄不伪，质直心生，我则教诫教授，为其说法。晨朝为彼教诫教授说法，至日中时得胜进处。若日暮时为彼教诫教授说法，至晨朝时得胜进处。如是教授已，彼生正直心，实则知实，不实知不实，上则知上，无上则知无上；当知、当见、当得、当觉者，皆悉了知，斯有是处，谓五学力、十种如来力。
    “何等为五学力？谓信力、精进力、念力、定力、慧力。
    “如来十种力，何等为十？谓是处非处如实知，如上十力广说。若有来问处非处智力者，如如来处非处智，等正觉所知所见所觉，为彼记说；乃至漏尽智力，亦如是说。诸比丘，处非处智力者，我说是定非不定；乃至漏尽智者，我说是定非不定。定者正道，非定者邪道。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七○四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若不正思惟者，未起贪欲盖则起，已起贪欲盖重生令增广；未起瞋恚、睡眠、掉悔、疑盖则起，已起瞋恚、睡眠、掉悔、疑盖重生令增广。未起念觉支不起，已起念觉支则退；未起择法、精进、猗、喜、定、舍觉支不起，已起择法、精进、猗、喜、定、舍觉支则退。
    “若比丘正思惟者，未起贪欲盖不起，已起贪欲盖令灭；未起瞋恚、睡眠、掉悔、疑盖不起，已起瞋恚、睡眠、掉悔、疑盖则断。未起念觉支则起，已起者重生令增广；未起择法、精进、猗、喜、定、舍觉支则起，已起者重生令增广。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七○五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五退法。何等为五？谓贪欲、瞋恚、睡眠、掉悔、疑盖，是则退法。若修习七觉支，多修习令增广，是则不退法。何等为七？谓念觉支、择法觉支、精进觉支、猗觉支、喜觉支、定觉支、舍觉支，是名不退法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七○六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五法，能为黑暗，能为无目，能为无智，能羸智慧，非明，非等觉，不转趣涅槃。何等为五？谓贪欲、瞋恚、睡眠、掉悔、疑。如此五法，能为黑暗，能为无目，能为无智，非明，非正觉，不转趣涅槃。
    “若有七觉支，能作大明，能为目，增长智慧，为明，为正觉，转趣涅槃。何等为七？谓念觉支、择法觉支、精进觉支、猗觉支、喜觉支、定觉支、舍觉支。为明，为目，增长智慧，为明，为正觉，转趣涅槃。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七○七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五障、五盖，烦恼于心，能羸智慧，障碍之分，非明，非正觉，不转趣涅槃。何等为五？谓贪欲盖、瞋恚盖、睡眠盖、掉悔盖、疑盖。如此五盖，为覆为盖，烦恼于心，令智慧羸，为障碍分，非明，非等觉，不转趣涅槃。
    “若七觉支，非覆非盖，不恼于心，增长智慧，为明，为正觉，转趣涅槃。何等为七？谓念觉支等，如上说，乃至舍觉支。如此七觉支，非翳非盖，不恼于心，增长智慧，为明，为正觉，转趣涅槃。”
    尔时世尊即说偈曰：

“贪欲瞋恚盖，睡眠掉悔疑，
如此五种盖，增长诸烦恼。
此五覆世间，深著难可度，
障蔽于众生，令不见正道。
若得七觉支，则能为照明，
唯此真谛言，等正觉所说。
念觉支为首，择法正思惟，
精进猗喜觉，三昧舍觉支。
如此七觉支，牟尼之正道，
随顺大仙人，脱生死怖畏。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七○八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若族姓子，舍诸世务，出家学道，剃除须发，着袈裟衣，正信非家，出家学道。如是出家，而于其中有愚痴士夫，依止聚落城邑，晨朝着衣持钵，入村乞食，不善护身，不守根门，不摄其念，观察女人少壮好色而生染著，不正思惟，心驰取相，趣色欲想，为欲心炽盛，烧心烧身，返俗还戒而自退没。厌离俗务，出家学道，而反染著，增诸罪业，而自破坏，沉翳没溺。
    “有五种大树，其种至微，而渐生长巨大，而能映障众杂小树，荫翳萎悴，不得生长。何等为五？谓揵遮耶树、迦椑多罗树、阿湿波他树、优昙钵罗树、尼拘留他树。如是五种心树，种子至微，而渐渐长大，荫覆诸节，能令诸节荫覆堕卧。何等为五？谓贪欲盖渐渐增长，睡眠、掉悔、疑盖渐渐增长，以增长故，令善心荫覆堕卧。
    “若修习七觉支，多修习已，转成不退。何等为七？谓念觉支，择法、精进、猗、喜、定、舍觉支。如是七觉支，修习多修习已，转成不退转。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七○九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    “若比丘专一其心，侧听正法，能断五法，修习七法，令其转进满足。何等为断五法？谓贪欲盖、瞋恚盖、睡眠盖、掉悔盖、疑盖，是名五法断。何等修习七法？谓念觉支、择法觉支、精进觉支、猗觉支、喜觉支、定觉支、舍觉支，修此七法，转进满足。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七一○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“圣弟子清净信心，专精听法者，能断五法，修习七法，令其满足。何等为五？谓贪欲盖、瞋恚、睡眠、掉悔、疑，此盖则断。何等七法？谓念觉支，择法、精进、猗、喜、定、舍觉支。此七法修习满足，净信者谓心解脱，智者谓慧解脱。贪欲染心者，不得、不乐；无明染心者，慧不清净。是故比丘，离贪欲者心解脱，离无明者慧解脱。若彼比丘离贪欲，心解脱，得身作证；离无明，慧解脱。是名比丘断爱缚结，慢无间等，究竟苦边。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七一一）

    如是我闻。一时佛住王舍城耆阇崛山中。
    时有无畏王子，日日步涉，彷徉游行，来诣佛所，与世尊面相问讯慰劳已，退坐一面，白佛言：“世尊，有沙门、婆罗门作如是见，作如是说：‘无因无缘众生烦恼，无因无缘众生清净。’世尊复云何？”
    佛告无畏：“沙门、婆罗门为其说，不思而说，愚痴、不辨、不善，非知思，不知量，作如是说：‘无因无缘众生烦恼，无因无缘众生清净。’所以者何？有因有缘众生烦恼，有因有缘众生清净故。何因何缘众生烦恼？何因何缘众生清净？众生贪欲增上，于他财物、他众具而起贪言：‘此物于我有者好。’不离爱乐。于他众生而起恨心、凶心，计校欲打、欲缚、欲伏，加诸不道，为造众难，不舍瞋恚。身睡眠、心懈怠、心掉动，内不寂静，心常疑惑，过去疑、未来疑、现在疑。无畏！如是因、如是缘，众生烦恼。”
    无畏白佛：“瞿昙，一分之盖，足烦恼心，况复一切！”
    无畏白佛：“瞿昙，何因何缘众生清净？”
    佛告无畏：“若婆罗门有一胜念，决定成就，久时所作，久时所说，能随忆念，当于尔时习念觉支，修念觉已，念觉满足。念觉满足已，则于选择、分别、思惟，尔时择法觉支修习，修择法觉支已，择法觉支满足。彼选择、分别、思量法已，则精进方便，精进觉支于此修习，修精进觉支已，精进觉支满足。彼精进方便已，则欢喜生，离诸食想，修喜觉支，修喜觉支已，则喜觉支满足。喜觉支满足已，身心猗息，则修猗觉支，修猗觉支已，猗觉满足。身猗息已，则爱乐，爱乐已心定，则修定觉支，修定觉支已，定觉满足。定觉满足已，贪忧灭，则舍心生，修舍觉支，修舍觉支已，舍觉支满足。如是无畏！此因此缘，众生清净。”
    无畏白佛：“瞿昙，若一分满足，令众生清净，况复一切！”
    无畏白佛：“瞿昙，当何名此经？云何奉持？”
    佛告无畏王子：“当名此为《觉支经》。”
    无畏白佛：“瞿昙，此为最胜觉分。瞿昙，我是王子，安乐亦常求安乐，而希出入。今来上山，四体疲极，得闻瞿昙说《觉支经》，悉忘疲劳。”
    佛说此经已，王子无畏闻佛所说，欢喜随喜，从座起，稽首礼佛足而去。


杂阿含经卷第二十七

（七一二）

    如是我闻。一时佛住王舍城耆阇崛山。
    如上说，差别者：“有沙门、婆罗门作如是见、如是说：‘无因无缘众生无智无见，无因无缘众生智见。’”如是广说。
    乃至无畏王子闻佛所说，欢喜随喜，礼佛足而去。

（七一三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有众多比丘，晨朝着衣持钵，入舍卫城乞食。时众多比丘作是念：“今日太早，乞食时未至，我等且过诸外道精舍。”众多比丘即入外道精舍，与诸外道共相问讯慰劳，问讯慰劳已，于一面坐已。
    诸外道问比丘言：“沙门瞿昙为诸弟子说法，断五盖，覆心，慧力羸，为障碍分，不转趣涅槃；住四念处，修七觉意。我等亦为诸弟子说断五盖，覆心，慧力羸；善住四念处，修七觉分。我等与彼沙门瞿昙有何等异？俱能说法。”
    时众多比丘闻外道所说，心不喜悦，反呵骂，从座起去。入舍卫城，乞食已，还精舍，举衣钵，洗足已，往诣佛所，稽首佛足，退坐一面，以诸外道所说，具白世尊。
    尔时世尊告众多比丘：“彼外道说是语时，汝等应反问言：‘诸外道，五盖者，种应有十。七觉者，种应有十四。何等为五盖之十，七觉之十四？’如是问者，彼诸外道则自骇散，说诸外道法，瞋恚、骄慢、毁呰、嫌恨、不忍心生，或默然低头，失辩潜思。所以者何？我不见诸天、魔、梵、沙门、婆罗门、天人众中，闻我所说欢喜随顺者，唯除如来及声闻众于此闻者。
    “诸比丘，何等为五盖之十？谓有内贪欲，有外贪欲；彼内贪欲者即是盖，非智非等觉，不转趣涅槃；彼外贪欲即是盖，非智非等觉，不转趣涅槃。谓瞋恚有瞋恚相，若瞋恚及瞋恚相即是盖，非智非等觉，不转趣涅槃。有睡有眠，彼睡彼眠即是盖，非智非等觉，不转趣涅槃。有掉有悔，彼掉彼悔即是盖，非智非等觉，不转趣涅槃。有疑善法，有疑不善法，彼善法疑、不善法疑即是盖，非智非等觉，不转趣涅槃，是名五盖说十。
    “何等为七觉分说十四？有内法心念住、有外法心念住，彼内法念住即是念觉分，是智是等觉，能转趣涅槃；彼外法念住即是念觉分，是智是等觉，能转趣涅槃。有择善法、择不善法，彼善法择即是择法觉分，是智是等觉，能转趣涅槃；彼不善法择即是择法觉分，是智是等觉，能转趣涅槃。有精进断不善法、有精进长养善法，彼断不善法精进即是精进觉分，是智是等觉，能转趣涅槃；彼长养善法精进即是精进觉分，是智是等觉，能转趣涅槃。有喜、有喜处，彼喜即是喜觉分，是智是等觉，能转趣涅槃；彼喜处亦即是喜觉分，是智是等觉，能转趣涅槃。有身猗息、有心猗息，彼身猗息即是猗觉分，是智是等觉，能转趣涅槃；彼心猗息即是猗觉分，是智是等觉，能转趣涅槃。有定、有定相，彼定即是定觉分，是智是等觉，能转趣涅槃；彼定相即是定觉分，是智是等觉，能转趣涅槃。有舍善法、有舍不善法，彼善法舍即是舍觉分，是智是等觉，能转趣涅槃；彼不善法舍即是舍觉分，是智是等觉，能转趣涅槃。是名七觉分说为十四。”
    佛说此经已，众多比丘闻佛所说，欢喜奉行。

（七一四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有众多比丘，如上说。
    差别者：“有诸外道出家作如是说者，当复问言：‘若心微劣犹豫者，尔时应修何等觉分？何等为非修时？若复掉心者，掉心犹豫者，尔时复修何等觉分？何等为非时？’如是问者，彼诸外道心则骇散，说诸异法，心生忿恚、骄慢、毁呰、嫌恨、不忍，或默然低头，失辩潜思。所以者何？我不见诸天、魔、梵、沙门、婆罗门、天人众中，闻我所说欢喜随喜者，唯除如来及声闻众于此闻者。
    “诸比丘，若尔时其心微劣、其心犹豫者，不应修猗觉分、定觉分、舍觉分。所以者何？微劣心生，微劣犹豫，以此诸法增其微劣故。譬如小火，欲令其燃，增以燋炭，云何比丘，非为增炭令火灭耶？”
    比丘白佛：“如是，世尊。”
    “如是比丘，微劣犹豫，若修猗觉分、定觉分、舍觉分者，此则非时，增懈怠故。
    “若掉心起，若掉心犹豫，尔时不应修择法觉分、精进觉分、喜觉分。所以者何？掉心起，掉心犹豫，以此诸法能令其增。譬如炽火，欲令其灭，足其干薪，于意云何？岂不令火增炽燃耶？”
    比丘白佛：“如是，世尊。”
    佛告比丘：“如是掉心生，掉心犹豫，修择法觉分、精进觉分、喜觉分，增其掉心。
    “诸比丘，若微劣心生，微劣犹豫，是时应修择法觉分、精进觉分、喜觉分。所以者何？微劣心生，微劣犹豫，以此诸法示教照喜。譬如小火，欲令其燃，足其干薪，云何比丘，此火宁炽燃不？”
    比丘白佛：“如是，世尊。”
    佛告比丘：“如是微劣心生，微劣犹豫，当于尔时修择法觉分、精进觉分、喜觉分，示教照喜。
    “若掉心生，掉心犹豫，修猗觉分、定觉分、舍觉分。所以者何？掉心生，掉心犹豫，此等诸法能令内住一心摄持。譬如燃火，欲令其灭，足其燋炭，彼火则灭。如是比丘，掉心犹豫，修择法觉分、精进觉分、喜觉分，则非时；修猗觉分、定觉分、舍觉分，自此则是时。此等诸法，内住一心摄持。念觉分者，一切兼助。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七一五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五盖、七觉分，有食、无食，我今当说。谛听善思，当为汝说。
    “譬如身依食而立，非不食；如是五盖依于食而立，非不食。贪欲盖以何为食？谓触相，于彼不正思惟，未起贪欲令起，已起贪欲能令增广，是名欲爱盖之食。何等为瞋恚盖食？谓障碍相，于彼不正思惟，未起瞋恚盖令起，已起瞋恚盖能令增广，是名瞋恚盖食。何等为睡眠盖食？有五法。何等为五？微弱、不乐、欠呿、多食、懈怠。于彼不正思惟，未起睡眠盖令起，已起睡眠盖能令增广，是名睡眠盖食。何等为掉悔盖食？有四法。何等为四？谓亲属觉、人众觉、天觉、本所经娱乐觉，自忆念、他人令忆念而生觉。于彼起不正思惟，未起掉悔令起，已起掉悔令其增广，是名掉悔盖食。何等为疑盖食？有三世。何等为三？谓过去世、未来世、现在世。于过去世犹豫、未来世犹豫、现在世犹豫，于彼起不正思惟，未起疑盖令起，已起疑盖能令增广，是名疑盖食。
    “譬如身依于食而得长养，非不食；如是七觉分依食而住，依食长养，非不食。何等为念觉分不食？谓四念处不思惟，未起念觉分不起，已起念觉分令退，是名念觉分不食。何等为择法觉分不食？谓于善法选择、于不善法选择，于彼不思惟，未起择法觉分令不起，已起择法觉分令退，是名择法觉分不食。何等为精进觉分不食？谓四正断，于彼不思惟，未起精进觉分令不起，已起精进觉分令退，是名精进觉分不食。何等为喜觉分不食？有喜、有喜处法，于彼不思惟，未起喜觉分不起，已起喜觉分令退，是名喜觉分不食。何等为猗觉分不食？有身猗息及心猗息，于彼不思惟，未生猗觉分不起，已生猗觉分令退，是名猗觉分不食。何等为定觉分不食？有四禅，于彼不思惟，未起定觉分不起，已起定觉分令退，是名定觉分不食。何等为舍觉分不食？有三界，谓断界、无欲界、灭界，于彼不思惟，未起舍觉分不起，已起舍觉分令退，是名舍觉分不食。
    “何等为贪欲盖不食？谓不净观，于彼思惟，未起贪欲盖不起，已起贪欲盖令断，是名贪欲盖不食。何等为瞋恚盖不食？彼慈心思惟，未生瞋恚盖不起，已生瞋恚盖令灭，是名瞋恚盖不食。何等为睡眠盖不食？彼明照思惟，未生睡眠盖不起，已生睡眠盖令灭，是名睡眠盖不食。何等为掉悔盖不食？彼寂止思惟，未生掉悔盖不起，已生掉悔盖令灭，是名掉悔盖不食。何等为疑盖不食？彼缘起法思惟，未生疑盖不起，已生疑盖令灭，是名疑盖不食。
    “譬如身依食而住、依食而立，如是七觉分依食而住、依食而立。何等为念觉分食？谓四念处思惟已，未生念觉分令起，已生念觉分转生令增广，是名念觉分食。何等为择法觉分食？有择善法、有择不善法，彼思惟已，未生择法觉分令起，已生择法觉分重生令增广，是名择法觉分食。何等为精进觉分食？彼四正断思惟，未生精进觉分令起，已生精进觉分重生令增广，是名精进觉分食。何等为喜觉分食？有喜、有喜处，彼思惟，未生喜觉分令起，已生喜觉分重生令增广，是名喜觉分食。何等为猗觉分食？有身猗息、心猗息，思惟，未生猗觉分令起，已生猗觉分重生令增广，是名猗觉分食。何等为定觉分食？谓有四禅，思惟，未生定觉分令生起，已生定觉分重生令增广，是名定觉分食。何等为舍觉分食？有三界。何等为三？谓断界、无欲界、灭界。彼思惟，未生舍觉分令起，已生舍觉分重生令增广，是名舍觉分食。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七一六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于内法中，我不见一法，能令未生恶不善法令生，已生恶不善法重生令增广，未生善法不生，已生则退，所谓不正思惟。诸比丘，不正思惟者，未生贪欲盖令生，已生者重生令增广；未生瞋恚、睡眠、掉悔、疑盖令生，已生者重生令增广。未生念觉分不生，已生者令退；未生择法、精进、喜、猗、定、舍觉分令不生，已生者令退。
    “我不见一法，能令未生恶不善法令不生，已生者令断，未生善法令生，已生者重生令增广，所谓正思惟。比丘，正思惟者，未生贪欲盖令不生，已生者令断；未生瞋恚、睡眠、掉悔、疑盖令不生，已生者令断。未生念觉分令生，已生者重生令增广；未生择法、精进、喜、猗、定、舍觉分令生，已生者重生令增广。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七一七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于外法中，我不见一法，未生恶不善法令生，已生者重生令增广，未生善法令不生，已生者令退，如恶知识、恶伴党。恶知识、恶伴党者，未生贪欲盖令生，已生者重生令增广；未生瞋恚、睡眠、掉悔、疑盖令生，已生者重生令增广。未生念觉分令不生，已生者令退；未生择法、精进、喜、猗、定、舍觉分令不生，已生者令退。
    “诸比丘，我不见一法，未生恶不善法令不生，已生者令断，未生善法令生，已生者重生令增广，所谓善知识、善伴党、善随从者。若善知识、善伴党、善随从者，未生贪欲盖令不生，已生者令断；未生瞋恚、睡眠、掉悔、疑盖令不生，已生者令断。未生念觉分令生，已生者重生令增广；未生择法、精进、喜、猗、定、舍觉分令生，已生者重生令增广。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七一八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者舍利弗告诸比丘：“有七觉分。何等为七？谓念觉分、择法觉分、精进觉分、喜觉分、猗觉分、定觉分、舍觉分。此七觉分，决定而得，不勤而得，我随所欲觉分正受。若晨朝时、日中时、日暮时，若欲正受，随其所欲，多入正受。譬如王、大臣，有种种衣服，置箱箧中，随其所须，日中所须，日暮所须，随欲自在。如是比丘，此七觉分，决定而得，不勤而得，随意正受。我此念觉分，清净纯白，起时知起，灭时知灭，没时知没，已起知已起，已灭知已灭。如是择法、精进、喜、猗、定、舍觉分，亦如是说。”
    尊者舍利弗说此经已，诸比丘闻其所说，欢喜奉行。

（七一九）

    如是我闻。一时佛住巴连弗邑。
    尔时尊者优波摩、尊者阿提目多，住巴连弗邑鸡林精舍。
    尔时尊者阿提目多，晡时从禅觉，诣尊者优波摩所，共相问讯慰劳已，退坐一面，问尊者优波摩：“尊者，能知七觉分方便，如是乐住正受，如是苦住正受？”
    优波摩答言：“尊者阿提目多，比丘善知方便，修七觉分，如是乐住正受，如是苦住正受。”
    复问：“云何比丘善知方便，修七觉分？”
    优波摩答言：“比丘方便修念觉分，时知思惟，彼心不善解脱，不害睡眠，不善调伏掉悔，如我念觉处法思惟，精进方便，不得平等。如是择法、精进、喜、猗、定、舍觉分，亦如是说。
    “若比丘念觉分方便，时先思惟，心善解脱，正害睡眠，调伏掉悔，如我于此念觉处法思惟已，不勤方便，而得平等。如是阿提目多，比丘知方便，修七觉分，如是乐住正受，如是不乐住正受。”
    时二正士共论义已，各从座起而去。

（七二○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者阿那律亦住舍卫国松林精舍。
    时有众多比丘诣阿那律所，共相问讯慰劳，问讯慰劳已，退坐一面，语尊者阿那律：“尊者知方便修七觉分时生乐住不？”
    尊者阿那律语诸比丘言：“我知比丘方便修七觉分时生乐住。”
    诸比丘问尊者阿那律：“云何知比丘方便修七觉分时生乐住？”
    尊者阿那律语诸比丘：“比丘方便修念觉分，善知思惟，我心善解脱，善害睡眠，善调伏掉悔。如此念觉分处法思惟已，精勤方便，心不懈怠，身猗息，不动乱，系心令住，不起乱念，一心正受。如是择法、精进、喜、猗、定、舍觉分，亦如是说。是名知比丘方便修七觉分时生乐住。”
    时众多比丘闻尊者阿那律所说，欢喜随喜，从座起而去。

（七二一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“转轮圣王出世之时，有七宝现于世间，金轮宝、象宝、马宝、神珠宝、玉女宝、主藏臣宝、主兵臣宝。如是如来出世，亦有七觉分宝现。
    “斋戒，处楼观上，大臣围绕，有金轮宝从东方出，轮有千辐，齐毂圆辋，轮相具足，有此吉瑞，必是转轮圣王：‘我今决定为转轮王！’即以两手承金轮宝，着左手中，右手旋转，而说是言：‘若是转轮圣王金轮宝者，当复转轮圣王古道而去。’于是轮宝即发，王蕃前随，而于东方乘虚而逝，向于东方，游古圣王正直之道。王随轮宝，四兵亦从。若所至方，轮宝住者，王于彼住，四兵亦住。东方诸国处处小王，见圣王来，悉皆归伏。
    “如来出兴于世，有七觉分现于世间，所谓念觉分、择法觉分、精进觉分、喜觉分、猗觉分、定觉分、舍觉分。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七二二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“转轮圣王出于世时，有七宝现于世间。
    “云何转轮圣王出于世时金轮宝现？有时刹利灌顶圣王，月十五日，沐浴清净，受持斋戒，于楼阁上，大臣围绕。有金轮宝从东方出，轮有千辐，齐毂圆辋，轮相具足，天真金宝。王作是念：‘古昔传闻，刹利灌顶大王，月十五日布萨时，沐浴清净，受持斋福，有轮宝现。今既如古，有斯吉瑞，当知我是转轮圣王。’即以两手承金轮宝，着左手中，右手旋转，而作是言：‘若是转轮圣王金轮宝者，当复转轮圣王古道而去。’作是语讫，于是轮宝即从王前乘虚而逝，向于东方，游古圣王正直之道。王及四兵，随轮去住。东方诸国处处小王，见圣王来，皆称：‘善哉！善来大王！此是王国，此国安隐，人民丰乐，愿于中止，教化国人，我等皆是天尊翼从。’圣王答言：‘诸聚落主，汝今但当善化国人，有不顺者，当来白我。当如法化，莫作非法，亦令国人善化非法。若如是者，则从我化。’于是圣王从东海度，乘古圣王道，至于南海；乘古圣王之道，度于南海，至于西海；乘于古昔圣王之道，度于西海，至于北海。南、西、北方诸小国王，奉迎启请，亦如东方广说。于是金轮宝，圣王随从，度于北海，还至王宫正治殿上，住虚空中。是为转轮圣王出兴于世，金轮宝现于世间。
    “云何为转轮圣王出兴于世，白象宝现于世间？若刹利灌顶大王纯白之象，其色鲜好，七支拄地。圣王见已，心则欣悦：‘今此宝象来应于我。’告善调象师，令速调此宝象，调已送来。象师受命，不盈一日，象即调伏，一切调伏相悉皆具足，犹如余象经年调者，今此象宝一日调伏亦复如是。调已送诣王所，上白大王：‘此象已调，唯王自知时。’尔时圣王观察此象调相已备，即乘宝象，于晨旦时周行四海，至日中时还归王宫。是名转轮圣王出兴于世，如此象宝现于世间。
    “何等为转轮圣王出兴于世，马宝现于世间？转轮圣王所有马宝，纯一青色，乌头朱尾。圣王见马，心生欣悦：‘今此神马来应我故。’付调马师，令速调之，调已送来。马师奉教，不盈一日，其马即调，犹如余马经年调者，马宝调伏亦复如是。知马调已，还送奉王，白言：‘大王，此马已调。’尔时圣王观察宝马调相已备，于晨旦时乘此宝马周行四海，至日中时还归王宫。是名转轮圣王出兴于世，马宝现于世间。
    “何等为转轮圣王出兴于世，摩尼宝珠现于世间？若转轮圣王所有宝珠，其形八楞，光泽明照，无诸瑕隙，于王宫内常为灯明。转轮圣王察试宝珠，阴雨之夜，将四种兵入于园林，持珠前导，光明照耀，面一由旬。是为转轮圣王出兴于世，摩尼宝珠现于世间。
    “何等为转轮圣王出兴于世，贤玉女宝现于世间？转轮圣王所有玉女，不黑不白，不长不短，不粗不细，不肥不瘦，支体端正。寒时体暖，热时体凉。身体柔软，如迦陵伽衣。身诸毛孔，出栴檀香。口鼻出息，作优钵罗香。后卧先起，瞻王意色，随宜奉事，软言爱语，端心正念，发王道意，心无违越，况复身、口，是为转轮圣王宝女。
    “云何为转轮圣王主藏臣宝现于世间？谓转轮圣王主藏大臣，本行施故，生得天眼，能见伏藏，有主无主，若水若陆，若远若近，悉能见之。转轮圣王若须珍宝，即便告敕，随王所须，辄以奉上。于是圣王有时试彼大臣，观其所能，乘船游海，告彼大臣：‘我须宝物。’臣白王言：‘小住岸边，当以奉上。’王告彼臣：‘我今不须岸边之宝，且须画时与我。’于是大臣即于水中出四金瓮，金宝满中，以奉圣王。随王所须，即取用之，若取足已，余则还归水中。圣王出世，则有如此主藏之臣现于世间。
    “云何圣王出兴于世，有主兵之臣现于世间？谓有主兵臣，聪明智辩，譬如世间善思量成就者，圣王所宜，彼则悉从，宜去宜住，宜出宜入，圣王四种兵行，道里顿止，不令疲倦。悉知圣王宜所应作，现法、后世功德之事，以白圣王。转轮圣王出兴于世，有如是主兵之臣。
    “如是如来、应、等正觉出兴于世，有七觉分现于世间。何等为七？谓念觉分、择法觉分、精进觉分、喜觉分、猗觉分、定觉分、舍觉分。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七二三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“善哉比丘，依人闻法，诸年少比丘供养奉事诸尊长老。所以者何？年少比丘供养奉事长老比丘者，时时得闻深妙之法。闻深法已，二正事成就，身正及心正。尔时修念觉分，修念觉分已，念觉分满足。念觉满足已，于法选择，分别于法，思量于法，尔时方便修择法觉分；乃至舍觉分修习满足。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七二四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘持戒、修德、惭、愧，成真实法，见此人者，多得果报。若复闻者，若随忆念者，随出家者，多得功德，况复亲近恭敬奉事。所以者何？亲近奉事如是人者，时时得闻深妙之法。得闻深法已，成就二正，身正及心正。方便修习定觉分，修习已修习满足，乃至舍觉分修习满足。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七二五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“说不善积聚者，所谓五盖，是为正说。所以者何？纯一不善聚者，谓五盖故。何等为五？谓贪欲盖、瞋恚盖、睡眠盖、掉悔盖、疑盖。
    “说善积聚者，谓七觉分，是为正说。所以者何？纯一满净者，是七觉分故。何等为七？谓念觉分、择法觉分、精进觉分、喜觉分、猗觉分、定觉分、舍觉分。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七二六）

    如是我闻。一时佛住王舍城夹谷精舍。
    尔时尊者阿难亦在彼住。时尊者阿难独一静处，禅思思惟，作如是念：“半梵行者，所谓善知识、善伴党、善随从，非恶知识、恶伴党、恶随从。”
    时尊者阿难从禅觉，往诣佛所，稽首礼足，退坐一面，白佛言：“世尊，我独一静处，禅思思惟，作是念：半梵行者，所谓善知识、善伴党、善随从，非恶知识、恶伴党、恶随从。”
    佛告阿难：“莫作是言：‘半梵行者，谓善知识、善伴党、善随从，非恶知识、恶伴党、恶随从。’所以者何？纯一满净，梵行清白，所谓善知识、善伴党、善随从，非恶知识、恶伴党、恶随从。我为善知识故，有众生于我所，取念觉分，依远离、依无欲、依灭、向于舍；如是择法觉分，精进、喜、猗、定、舍觉分，依远离、依无欲、依灭、向于舍。以是故当知，阿难，纯一满净，梵行清白，谓善知识、善伴党、善随从，非恶知识、非恶伴党、非恶随从。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七二七）

    如是我闻。一时佛在力士聚落人间游行，于拘夷那竭城希连河中间住。于聚落侧，告尊者阿难：“令四重襞叠，敷世尊郁多罗僧，我今背疾，欲小卧息。”
    尊者阿难即受教敕，四重襞叠，敷郁多罗僧已，白佛言：“世尊，已四重襞叠，敷郁多罗僧，唯世尊知时。”
    尔时世尊厚襞僧伽梨枕头，右胁而卧，足足相累，系念明相，正念正智，作起觉想，告尊者阿难：“汝说七觉分。”
    时尊者阿难即白佛言：“世尊，所谓念觉分，世尊自觉成等正觉，说依远离、依无欲、依灭、向于舍。择法、精进、喜、猗、定、舍觉分，世尊自觉成等正觉，说依远离、依无欲、依灭、向于舍。”
    佛告阿难：“汝说精进耶？”
    阿难白佛：“我说精进，世尊。我说精进，善逝。”
    佛告阿难：“唯精进修习多修习，得阿耨多罗三藐三菩提。”说是语已，正坐端身系念。
    时有异比丘即说偈言：

“乐闻美妙法，忍疾告人说，
比丘即说法，转于七觉分。
善哉尊阿难，明解巧便说，
有胜白净法，离垢微妙说。
念择法精进，喜猗定舍觉，
此则七觉分，微妙之善说。
闻说七觉分，深达正觉味，
身婴大苦患，忍疾端坐听。
观为正法王，常为人演说，
犹乐闻所说，况余未闻者！
第一大智慧，十力所礼者，
彼亦应疾疾，来听说正法。
诸多闻通达，契经阿毗昙，
善通法律者，应听况余者！
闻说如实法，专心黠慧听，
于佛所说法，得离欲欢喜，
欢喜身猗息，心自乐亦然。
心乐得正受，正观有事行，
厌恶三趣者，离欲心解脱。
厌恶诸有趣，不集于人天，
无余犹灯灭，究竟般涅槃。
闻法多福利，最胜之所说，
是故当专思，听大师所说。”

    异比丘说此偈已，从座起而去。

（七二八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有七觉分。何等为七？谓念觉分，乃至舍觉分。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七二九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当修七觉分。何等为修七觉分？谓念觉分，乃至舍觉分。若比丘修念觉分，依远离、依无欲、依灭、向于舍；如是修择法、精进、喜、猗、定、舍觉分，依远离、依无欲、依灭、向于舍。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七三○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“诸比丘，过去已如是修七觉分，未来亦当如是修七觉分。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七三一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘念觉分清净鲜白，无有支节，离诸烦恼，未起不起，除佛调伏教授；乃至舍觉分，亦如是说。诸比丘，念觉分清净鲜白，无有支节，离诸烦恼，未起而起，佛所调伏教授非余；乃至舍觉分，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七三二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“未起不起，除善逝调伏教授。未起而起，是则善逝调伏教授非余。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七三三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘来诣佛所，稽首礼足，退坐一面，白佛言：“世尊谓觉分，世尊，云何为觉分？”
    佛告比丘：“所谓觉分者，谓七道品法。然诸比丘，七觉分渐次而起，修习满足。”
    异比丘白佛：“世尊，云何觉分渐次而起，修习满足？”
    佛告比丘：“若比丘内身身观住，彼内身身观住时，摄心系念不忘，彼当尔时，念觉分方便修习，方便修习念觉分已，修习满足。满足念觉分已，于法选择、分别、思量，当于尔时修择法觉分方便，修方便已，修习满足。如是乃至舍觉分修习满足。如内身身观念住，如是外身、内外身，受、心、法法观念住，当于尔时专心系念不忘；乃至舍觉分，亦如是说。如是住者，渐次觉分起，渐次起已，修习满足。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七三四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告彼比丘：如上说，差别者：“若比丘如是修习七觉分已，当得二种果：现法得漏尽无余涅槃，或得阿那含果。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七三五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    如上说，差别者：“如是比丘修习七觉分已，多修习已，得四种果、四种福利。何等为四？谓须陀洹果、斯陀含果、阿那含果、阿罗汉果。”
    佛说此经已，异比丘闻佛所说，欢喜奉行。

（七三六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    如上说，差别者：“若比丘修习七觉分，多修习已，当得七种果、七种福利。何等为七？是比丘得现法智证乐；若命终时，若不得现法智证乐；及命终时，而得五下分结尽，中般涅槃；若不得中般涅槃，而得生般涅槃；若不得生般涅槃，而得无行般涅槃；若不得无行般涅槃，而得有行般涅槃；若不得有行般涅槃，而得上流般涅槃。”
    佛说此经已，异比丘闻佛所说，欢喜奉行。

（七三七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“所谓觉分，何等为觉分？”
    诸比丘白佛：“世尊是法根、法眼、法依，唯愿为说，诸比丘闻已，当受奉行。”
    佛告诸比丘：“七觉分者，谓七道品法。诸比丘，此七觉分渐次起，渐次起已，修习满足。”
    诸比丘白佛：“云何七觉分渐次起，渐次起已，修习满足？”
    “若比丘身身观念住，彼身身观念住已，专心系念不忘，当于尔时方便修念觉分，方便修念觉分已，修习满足。谓修念觉分已，于法选择，当于尔时修择法觉分方便，修择法觉分方便已，修习满足。如是精进、喜、猗、定、舍觉分，亦如是说。如内身，如是外身、内外身，受、心、法法观念住，专心系念不忘，当于尔时方便修念觉分，方便修念觉分已，修习满足；乃至舍觉分，亦如是说。是名比丘七觉分渐次起，渐次起已，修习满足。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七三八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“此七觉分修习多修习，当得二果：得现法智有余涅槃，及阿那含果。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七三九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“若比丘修习七觉分，多修习已，当得四果。何等为四？谓须陀洹果、斯陀含果、阿那含果、阿罗汉果。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七四○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    如上说，差别者：“若比丘修习此七觉分，多修习已，当得七果。何等为七？谓现法智有余涅槃；及命终时；若不尔者，五下分结尽，得中般涅槃；若不尔者，得生般涅槃；若不尔者，得无行般涅槃；若不尔者，得有行般涅槃；若不尔者，得上流般涅槃。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七四一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当修不净观，多修习已，当得大果大福利。云何修不净观，多修习已，得大果大福利？是比丘不净观俱念觉分，依远离、依无欲、依灭、向于舍。修择法、精进、喜、猗、定、舍觉分，依远离、依无欲、依灭、向于舍。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七四二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘修习随死念，多修习已，得大果大福利。云何比丘修习随死念，多修习已，得大果大福利？是比丘修随死念俱念觉分，依远离、依无欲、依灭、向于舍；乃至舍觉分，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七四三）

    如是我闻。一时佛住释氏黄枕邑。
    时众多比丘，晨朝着衣持钵，入黄枕邑乞食。时众多比丘作是念：“今日太早，乞食时未至，我等可过外道精舍。”尔时众多比丘即入外道精舍，与诸外道出家共相问讯慰劳已，于一面坐。
    诸外道出家言：“沙门瞿昙为诸弟子说如是法：‘不断五盖，恼心，慧力羸，为障碍分，不趣涅槃。善摄其心，住四念处，心与慈俱，无怨无嫉，亦无瞋恚，广大无量，善修充满。四方、四维、上下，一切世间，心与慈俱，无怨无嫉，亦无瞋恚，广大无量，善修习充满。如是修习悲、喜、舍心俱，亦如是说。’我等亦复为诸弟子作如是说。我等与彼沙门瞿昙，有何等异？所谓俱能说法。”
    时众多比丘闻诸外道出家所说，心不喜悦，默然不呵，从座起去。入黄枕邑，乞食已，还精舍，举衣钵，洗足已，往诣佛所，稽首礼足，退坐一面，以彼外道出家所说，广白世尊。
    尔时世尊告诸比丘：“如彼外道出家所说，汝等应问：‘修习慈心，为何所胜？修习悲、喜、舍心，为何所胜？’如是问时，彼诸外道出家，心则骇散，或说外异事，或瞋慢、毁呰、违背、不忍，或默然萎熟，低头失辩，思惟而住。所以者何？我不见诸天、魔、梵、沙门、婆罗门、天人众中，闻我所说随顺乐者，唯除如来及声闻众者。比丘，心与慈俱多修习，于净最胜；悲心修习多修习，空入处最胜；喜心修习多修习，识入处最胜；舍心修习多修习，无所有入处最胜。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七四四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘修习慈心，多修习已，得大果大福利。云何比丘修习慈心，得大果大福利？是比丘心与慈俱，修念觉分，依远离、依无欲、依灭、向于舍；乃至修习舍觉分，依远离、依无欲、依灭、向于舍。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七四五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘修空入处，多修习已，得大果大福利。云何比丘修空入处，多修习已，得大果大福利？是比丘心与空入处俱，修念觉分，依远离、依无欲、依灭、向于舍；乃至修舍觉分，依远离、依无欲、依灭、向于舍。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如修空入处，如是识入处、无所有入处、非想非非想入处三经，亦如上说。

（七四六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘修习安那般那念，多修习已，得大果大福利。云何修习安那般那念，多修习已，得大果大福利？是比丘心与安那般那念俱，修念觉分，依远离、依无欲、依灭、向于舍；乃至修舍觉分，依远离、依无欲、依灭、向于舍。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七四七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘修无常想，多修习已，得大果大福利。云何比丘修无常想，多修习已，得大果大福利？是比丘心口与无常想俱，修念觉分，依远离、依无欲、依灭、向于舍；乃至得舍觉分，依远离、依无欲、依灭、向于舍。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如无常想，如是无常苦想、苦无我想、观食想、一切世间不可乐想、尽想、断想、无欲想、灭想、患想、不净想、青瘀想、脓溃想、膖胀想、坏想、食不尽想、血想、分离想、骨想、空想，一一经如上说。


杂阿含经卷第二十八

（七四八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“如日出前相，谓明相初光。如是比丘正尽苦边、究竟苦边前相者，所谓正见。彼正见者，能起正志、正语、正业、正命、正方便、正念、正定。起定正受故，圣弟子心正解脱贪欲、瞋恚、愚痴。如是心善解脱圣弟子，得正知见：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七四九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若无明为前相故，生诸恶不善法，时随生无惭、无愧；无惭、无愧生已，随生邪见；邪见生已，能起邪志、邪语、邪业、邪命、邪方便、邪念、邪定。
    “若起明为前相，生诸善法，时惭愧随生；惭愧生已，能生正见；正见生已，起正志、正语、正业、正命、正方便、正念、正定，次第而起。正定起已，圣弟子得正解脱贪欲、瞋恚、愚痴。如是圣弟子得正解脱已，得正知见：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七五○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘诸恶不善法生，一切皆以无明为根本，无明集、无明生、无明起。所以者何？无明者无知，于善、不善法不如实知，有罪、无罪，下法、上法，染污、不染污，分别、不分别，缘起、非缘起，不如实知。不如实知故，起于邪见；起于邪见已，能起邪志、邪语、邪业、邪命、邪方便、邪念、邪定。
    “若诸善法生，一切皆以明为根本，明集、明生、明起。明于善、不善法如实知，有罪、无罪，亲近、不亲近，卑法、胜法，秽污、白净，有分别、无分别，缘起、非缘起，悉如实知。如实知者，是则正见；正见者，能起正志、正语、正业、正命、正方便、正念、正定；正定起已，圣弟子得正解脱贪、恚、痴；贪、恚、痴解脱已，是圣弟子得正智见：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七五一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若在家、若出家，而起邪事者，我所不说。所以者何？若在家、出家，而起邪事者，则不乐正法。何等为邪事？谓邪见，乃至邪定。若在家、出家，而起正事，我所赞叹。所以者何？起正事者，则乐正法，善于正法。何等为正事？谓正见，乃至正定。”
    尔时世尊即说偈言：

“在家及出家，而起邪事者，
彼则终不乐，无上之正法。
在家及出家，而起正事者，
彼则常心乐，无上之正法。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七五二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时迦摩比丘诣佛所，稽首佛足，退坐一面，白佛言：“世尊，所谓欲者，云何为欲？”
    佛告迦摩：“欲谓五欲功德。何等为五？谓眼识色，可爱、可意、可念，长养欲乐；如是耳、鼻、舌、身识触，可爱、可意、可念，长养欲乐，是名为欲。然彼非欲，于彼贪著者，是名为欲。”
    尔时世尊即说偈言：

“世间杂五色，彼非为爱欲，
贪欲觉想者，是则士夫欲。
众色常住世，行者断心欲。”

    迦摩比丘白佛言：“世尊，宁有道有迹，断此爱欲不？”
    佛告比丘：“有八正道，能断爱欲，谓正见、正志、正语、正业、正命、正方便、正念、正定。”
    佛说此经已，迦摩比丘闻佛所说，欢喜奉行。

（七五三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有比丘名阿梨瑟吒，诣佛所，稽首佛足，退坐一面，白佛言：“世尊，所谓甘露者，云何名为甘露？”
    佛告阿梨瑟吒：“甘露者，界名说，然我为有漏尽者，现说此名。”
    阿梨瑟吒比丘白佛言：“世尊，有道有迹，修习多修习，得甘露法不？”
    佛告比丘：“有，所谓八圣道分，谓正见乃至正定。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七五四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者舍利弗诣佛所，稽首佛足，退坐一面，白佛言：“世尊，所谓贤圣等三昧根本、众具，云何为贤圣等三昧根本、众具？”
    佛告舍利弗：“谓七正道分，为贤圣等三昧，为根本，为众具。何等为七？谓正见、正志、正语、正业、正命、正方便、正念。舍利弗，于此七道分为基业已，得一其心，是名贤圣等三昧根本、众具。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七五五～七五七）

    如上三经，如是佛问诸比丘三经，亦如是说。

（七五八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“无母子畏、有母子畏，愚痴无闻凡夫所说，而不能知无母子畏、有母子畏。诸比丘，有三种无母子畏，愚痴无闻凡夫所说。何等为三？诸比丘，有时兵凶乱起，残害国土，随流波迸，子失其母，母失其子，是名第一无母子畏，愚痴无闻凡夫所说。复次比丘，有时大火卒起，焚烧城邑聚落，人民驰走，母子相失，是名第二无母子畏，愚痴无闻凡夫所说。复次比丘，有时山中大雨，洪水流出，漂没聚落，人民驰走，母子相失，是名第三无母子畏，愚痴无闻凡夫所说。
    “然此等畏，是有母子畏，愚痴无闻凡夫说名无母子畏。彼有时兵凶乱起，残害国土，随流波迸，母子相失，或时于彼母子相见，是名第一有母子畏，愚痴无闻凡夫说名无母子畏。复次大火卒起，焚烧城邑聚落，人民驰走，母子相失，或复相见，是名第二有母子畏，愚痴无闻凡夫说名无母子畏。复次山中大雨，洪水流出，漂没聚落，此人驰走，母子相失，或寻相见，是名第三有母子畏，愚痴无闻凡夫说名无母子畏。
    “比丘，有三种无母子畏，是我自觉成三菩提之所记说。何等为三？若比丘，子若老时，无母能语子：‘汝莫老，我当代汝。’其母老时，亦无子语母：‘今莫老，我代之老。’是名第一无母子畏，我自觉成三菩提之所记说。复次比丘，有时子病，母不能语子：‘今莫病，我当代汝。’母病之时，子亦不能语母：‘莫病，我当代母。’是名第二无母子畏，我自觉成三菩提之所记说。复次子若死时，无母能语子：‘今莫死，我今代汝。’母若死时，无子能语母：‘今莫死，我当代母。’是名第三无母子畏，我自觉成三菩提之所记说。”
    诸比丘白佛：“有道有迹，修习多修习，断前三种有母子畏，断后三种无母子畏不？”
    佛告比丘：“有道有迹，断彼三畏。何等为道，何等为迹，修习多修习，断前三种有母子畏，断后三种无母子畏？谓八圣道分，正见、正志、正语、正业、正命、正方便、正念、正定。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七五九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有三受，无常、有为、心所缘生。何等为三？谓乐受、苦受、不苦不乐受。”
    诸比丘白佛：“世尊，有道有迹，修习多修习，断此三受不？”
    佛告比丘：“有道有迹，修习多修习，断此三受。何等为道，何等为迹，修习多修习，断此三受？”
    佛告比丘：“谓八圣道，正见、正志、正语、正业、正命、正方便、正念、正定。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七六○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“世有三法，不可喜、不可爱、不可念。何等为三？谓老、病、死，此三法不可喜、不可爱、不可念。世间若无此三法不可喜、不可爱、不可念者，无有如来、应、等正觉出于世间，世间亦不知有如来说法，教诫教授。以世间有此三法不可喜、不可爱、不可念故，如来、应、等正觉出于世间，世间知有如来说法，教诫教授。”
    诸比丘白佛：“有道有迹，断此三法不可喜、不可爱、不可念者不？”
    佛告比丘：“有道有迹，修习多修习，断此三法不可喜、不可爱、不可念。何等为道，何等为迹，修习多修习，断此三法不可喜、不可爱、不可念？谓八圣道，正见、正志、正语、正业、正命、正方便、正念、正定。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七六一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我当说学及无学，谛听善思念之。何等为学？谓学正见成就，学正志、正语、正业、正命、正方便、正念、正定成就，是名为学。何等为无学？谓无学正见成就，无学正志、正语、正业、正命、正方便、正念、正定成就，是名无学。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如学、无学，如是正士、如是大士，亦如是说。

（七六二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我当说圣漏尽。云何为圣漏尽？谓无学正见成就，乃至无学正定成就，是名圣漏尽。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七六三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当说八圣道分。何等为八？谓正见、正志、正语、正业、正命、正方便、正念、正定。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七六四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当说修八圣道，谛听善思。何等为修八圣道？是比丘修正见，依远离、依无欲、依灭、向于舍；修正志、正语、正业、正命、正方便、正念、正定，依远离、依无欲、依灭、向于舍，是名修八圣道。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七六五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当说比丘过去已修八圣道，未来当修八圣道。”
    乃至诸比丘闻佛所说，欢喜奉行。

（七六六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘正见清净鲜白，无诸过患，离诸烦恼，未起不起，唯除佛所调伏；乃至正定，亦如是说。若正见清净鲜白，无诸过患，离诸烦恼，未起能起；乃至正定，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如除佛所调，除善逝所调亦如上说。

（七六七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“说不善聚者，谓五盖，是为正说。所以者何？纯一不善聚者，所谓五盖。何等为五？谓贪欲盖，瞋恚、睡眠、掉悔、疑盖。
    “说善法聚者，所谓八圣道，是名正说。所以者何？纯一满净善聚者，谓八圣道。何等为八？谓正见、正志、正语、正业、正命、正方便、正念、正定。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七六八）

    如是我闻。一时佛住王舍城山谷精舍。
    时尊者阿难独一静处，作如是念：“半梵行者，谓善知识、善伴党、善随从。”
    乃至佛告阿难：“纯一满净具梵行者，谓善知识。所以者何？我为善知识故，令诸众生修习正见，依远离、依无欲、依灭、向于舍；乃至修正定，依远离、依无欲、依灭、向于舍。”
    佛说此经已，尊者阿难闻佛所说，欢喜奉行。

（七六九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者阿难晨朝着衣持钵，入舍卫城乞食。
    时有生闻婆罗门，乘白马车，众多年少翼从。白马、白车、白鞚、白鞭，头着白帽，白伞盖，手执白拂，着白衣服、白璎珞，白香涂身，翼从皆白，出舍卫城，欲至林中教授读诵。众人见之咸言：“善乘！善乘！谓婆罗门乘。”
    时尊者阿难见婆罗门眷属、众具，一切皆白。见已入城乞食，还精舍，举衣钵，洗足已，往诣佛所，稽首礼足，退坐一面，白佛言：“世尊，今日晨朝着衣持钵，入舍卫城乞食，见生闻婆罗门乘白马车，眷属、众具一切皆白，众人唱言：‘善乘！善乘！谓婆罗门乘。’云何世尊，于正法律，为是世人乘？为是婆罗门乘？”
    佛告阿难：“是世人乘，非我法律婆罗门乘也。阿难，我正法律乘、天乘、婆罗门乘、大乘，能调伏烦恼军者。谛听善思，当为汝说。阿难，何等为正法律乘、天乘、婆罗门乘、大乘，能调伏烦恼军者？谓八正道，正见乃至正定。阿难，是名正法律乘、天乘、梵乘、大乘，能调伏烦恼军者。”
    尔时世尊即说偈言：

“信戒为法轭，惭愧为长縻，
正念善护持，以为善御者。
舍三昧为辕，智慧精进轮，
无著忍辱铠，安隐如法行。
直进不退还，永之无忧处，
智士乘战车，摧伏无智怨。”

（七七○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“应离邪见，应断邪见。若邪见不可断者，我终不说应离断邪见。以邪见可断故，我说比丘当离邪见。若不离邪见者，邪见当作非义不饶益苦，是故我说当离邪见。如是邪志、邪语、邪业、邪命、邪方便、邪念、邪定，亦如是说。
    “诸比丘，离邪见已，当修正见。若不得修正见者，我终不说修习正见。以得修正见故，我说比丘应修正见。若不修正见者，当作非义不饶益苦，以不修正见作非义不饶益苦故，是故我说当修正见，以义饶益，常得安乐。是故比丘，当修正见。如是正志、正语、正业、正命、正方便、正念、正定，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七七一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有生闻婆罗门来诣佛所，与世尊面相问讯慰劳，问讯慰劳已，退坐一面，白佛言：“瞿昙，谓非彼岸及彼岸。瞿昙，云何非彼岸？云何彼岸？”
    佛告婆罗门：“邪见者非彼岸，正见者是彼岸。邪志、邪语、邪业、邪命、邪方便、邪念、邪定非彼岸，正见是彼岸，正志、正语、正业、正命、正方便、正念、正定是彼岸。”
    尔时世尊即说偈言：

“希有诸人民，能度于彼岸，
一切诸世间，徘徊游此岸。
于此正法律，能善随顺者，
斯等能度彼，生死难度岸。”

    时生闻婆罗门闻佛所说，欢喜随喜，从座起去。

（七七二～七七四）

    如是异比丘问、尊者阿难问、佛问诸比丘，此三经亦如上说。

（七七五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于内法中，我不见一法，能令未生恶不善法生，已生者重生令增广，如说不正思惟者。诸比丘，不正思惟者，未起邪见令起，已起重生令增广。如是邪志、邪语、邪业、邪命、邪方便、邪念、邪定，亦如是说。
    “诸比丘，于内法中，我不见一法，令未生恶不善法不生，已生恶不善法令灭，如说正思惟者。诸比丘，正思惟者，未生邪见令不生，已生者令灭。如邪见，邪志、邪语、邪业、邪命、邪方便、邪念、邪定，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七七六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于内法中，我不见一法，令未生善法不生，已生善法令退，如说不正思惟者。诸比丘，不正思惟者，未生正见令不生，已生正见令退。如是未生正志、正语、正业、正命、正方便、正念、正定令不生，已生者令退。
    “诸比丘，于内法中，我不见一法，令未生善法令生，已生善法重生令增广，如说正思惟者。诸比丘，正思惟者，未生正见令生，已生正见重生令增广。如是未生正志、正语、正业、正命、正方便、正念、正定令生，已生者重生令增广。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七七七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于内法中，我不见一法，令未生恶不善法生，已生恶不善法重生令增广，未生善法不生，已生者令退，所谓不正思惟。诸比丘，不正思惟者，未生邪见令生，已生者重生令增广，未生正见令不生，已生者令退。如是未生邪志、邪语、邪业、邪命、邪方便、邪念、邪定令生，已生者重生令增广；未生正志、正语、正业、正命、正方便、正念、正定不生，已生者令退。
    “诸比丘，我于内法中，不见一法，令未生恶不善法令不生，已生恶不善法令灭，未生善法令生，已生善法重生令增广，如说正思惟。诸比丘，正思惟者，令未生邪见不生，已生邪见令灭，未生正见令生，已生正见重生令增广。如是未生邪志、邪语、邪业、邪命、邪方便、邪念、邪定令不生，已生者令灭；未生正志、正语、正业、正命、正方便、正念、正定令生，已生者重生令增广。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七七八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于外法中，我不见一法，令未生恶不善法生，已生恶不善法重生令增广，如说恶知识、恶伴党、恶随从。诸比丘，恶知识、恶伴党、恶随从者，能令未生邪见令生，已生邪见重生令增广。如是未生邪志、邪语、邪业、邪命、邪方便、邪念、邪定令生，已生者重生令增广。
    “诸比丘，外法中，我不见一法，令未生恶不善法不生，已生恶不善法令灭，如说善知识、善伴党、善随从。诸比丘，善知识、善伴党、善随从者，能令未生邪见不生，已生邪见令灭；未生邪志、邪语、邪业、邪命、邪方便、邪念、邪定不生，已生者令灭。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七七九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于外法中，我不见一法，能令未生善法生，已生善法重生令增广，如说善知识、善伴党、善随从。诸比丘，善知识、善伴党、善随从者，能令未生正见生，已生正见重生令增广。如是未生正志、正语、正业、正命、正方便、正念、正定令生，已生者重生令增广。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七八○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于外法中，我不见一法，能令未生恶不善法生，已生恶不善法重生令增广，未生善法不生，已生善法令灭，如说恶知识、恶伴党、恶随从。诸比丘，恶知识、恶伴党、恶随从者，能令未生邪见令生，已生邪见者重生令增广，未生正见不生，已生正见令退。如是未生邪志、邪语、邪业、邪命、邪方便、邪念、邪定令生，已生者重生令增广；未生正志、正语、正业、正命、正方便、正念、正定令不生，已生者令退。
    “诸比丘，于外法中，我不见一法，能令未生恶不善法不生，已生恶不善法令灭，未生善法令生，已生善法重生令增广，如说善知识、善伴党、善随从。诸比丘，善知识、善伴党、善随从，能令未生邪见不生，已生邪见令灭，未生正见令生，已生正见重生令增广。如是未生邪志、邪语、邪业、邪命、邪方便、邪念、邪定令不生，已生者令灭；未生正志、正语、正业、正命、正方便、正念、正定令生，已生者重生令增广。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七八一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于内法中，我不见一法，能令未生恶不善法生，已生者重生令增广，未生善法不生，已生者令退，如说不正思惟。诸比丘，不正思惟者，能令未生邪见生，已生邪见令重生增广，未生正见不生，已生正见令退。
    “诸比丘，于内法中，我不见一法，能令未生恶不善法令不生，已生恶不善法令灭，未生善法令生，已生善法重生令增广，如说正思惟。诸比丘，正思惟者，能令未生邪见不生，已生者令灭，未生正见令生，已生者重生令增广。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如说邪见、正见，如是邪志、正志，邪语、正语，邪业、正业，邪命、正命，邪方便、正方便，邪念、正念，邪定、正定，七经如上说。
    如内法八经，如是外法八经，亦如是说。

（七八二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有非法、是法，谛听善思，当为汝说。何等为非法、是法？谓邪见非法，正见是法；乃至邪定非法，正定是法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如非法、是法，如是非律、正律，非圣、是圣，不善法、善法，非习法、习法，非善哉法、善哉法，黑法、白法，非义、正义，卑法、胜法，有罪法、无罪法，应去法、不去法，一一经皆如上说。

（七八三）

    如是我闻。一时佛住拘睒弥国瞿师罗园。
    尔时尊者阿难亦在彼住。
    有异婆罗门来诣尊者阿难所，与尊者阿难共相问讯慰劳，问讯慰劳已，退坐一面，白尊者阿难：“欲有所问，宁有闲暇为记说不？”
    阿难答言：“随汝所问，知者当答。”
    婆罗门问：“尊者阿难，何故于沙门瞿昙所出家修梵行？”
    阿难答言：“婆罗门，为断故。”
    复问：“断何等？”
    答言：“贪欲断，瞋恚、愚痴断。”
    又问：“阿难，有道有迹，能断贪欲、瞋恚、愚痴耶？”
    阿难答言：“有，谓八圣道，正见、正志、正语、正业、正命、正方便、正念、正定。”
    婆罗门言：“阿难，贤哉之道，贤哉之迹，修习多修习，能断斯等贪欲、恚、痴。”
    尊者阿难说是法时，彼婆罗门闻其所说，欢喜随喜，从座起去。
    如断贪、恚、痴，如是调伏贪、恚、痴，及得涅槃，及厌离，及不趣涅槃，及沙门义，及婆罗门义，及解脱，及苦断，及究竟苦边，及正尽苦，一一经皆如上说。

（七八四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有邪、有正，谛听善思，当为汝说。何等为邪？谓邪见乃至邪定。何等为正？谓正见乃至正定。何等为正见？谓说有施、有说、有斋，有善行、有恶行、有善恶行果报，有此世、有他世，有父母、有众生生，有阿罗汉善到、善向，有此世、他世，自知作证具足住：我生已尽，梵行已立，所作已作，自知不受后有。何等为正志？谓出要志、无恚志、不害志。何等为正语？谓离妄语、离两舌、离恶口、离绮语。何等为正业？谓离杀、盗、淫。何等为正命？谓如法求衣服、饮食、卧具、汤药，非不如法。何等为正方便？谓欲精进，方便出离，勤竞堪能，常行不退。何等为正念？谓念、随顺念，不妄不虚。何等为正定？谓住心不乱、坚固、摄持寂止、三昧一心。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七八五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：
    “何等为正见？谓正见有二种：有正见是世俗、有漏、有取、转向善趣；有正见是圣出世间、无漏、无取、正尽苦、转向苦边。何等为正见有漏、有取、向于善趣？若彼见有施、有说，乃至知世间有阿罗汉，不受后有，是名世间正见，世俗、有漏、有取、向于善趣。何等为正见是圣出世间、无漏、不取、正尽苦、转向苦边？谓圣弟子苦苦思惟，集、灭、道道思惟，无漏思惟相应，于法选择、分别、推求、觉知、黠慧、开觉、观察，是名正见是圣出世间、无漏、不取、正尽苦、转向苦边。
    “何等为正志？谓正志有二种：有正志世俗、有漏、有取、向于善趣；有正志是圣出世间、无漏、不取、正尽苦、转向苦边。何等为正志有世俗、有漏、有取、向于善趣？谓正志出要觉、无恚觉、不害觉，是名正志世俗、有漏、有取、向于善趣。何等为正志是圣出世间、无漏、不取、正尽苦、转向苦边？谓圣弟子苦苦思惟，集、灭、道道思惟，无漏思惟相应心法，分别、自决、意解、计数、立意，是名正志是圣出世间、无漏、不取、正尽苦、转向苦边。
    “何等为正语？正语有二种：有正语世俗、有漏、有取、向于善趣；有正语是圣出世间、无漏、不取、正尽苦、转向苦边。何等为正语世俗、有漏、有取、向于善趣？谓正语离妄语、两舌、恶口、绮语，是名正语世俗、有漏、有取、向于善趣。何等正语是圣出世间、无漏、不取、正尽苦、转向苦边？谓圣弟子苦苦思惟，集、灭、道道思惟，除邪命贪，口四恶行、诸余口恶行离，于彼无漏、远离、不著，固守摄持不犯，不度时节，不越限防，是名正语是圣出世间、无漏、不取、正尽苦、转向苦边。
    “何等为正业？正业有二种：有正业世俗、有漏、有取、向于善趣；有正业是圣出世间、无漏、不取、正尽苦、转向苦边。何等为正业世俗、有漏、有取、转向善趣？谓离杀、盗、淫，是名正业世俗、有漏、有取、转向善趣。何等为正业是圣出世间、无漏、不取、正尽苦、转向苦边？谓圣弟子苦苦思惟，集、灭、道道思惟，除邪命贪，身三恶行、诸余身恶行数，无漏、心不乐著，固守执持不犯，不度时节，不越限防，是名正业是圣出世间、无漏、不取、正尽苦、转向苦边。
    “何等为正命？正命有二种：有正命是世俗、有漏、有取、转向善趣；有正命是圣出世间、无漏、不取、正尽苦、转向苦边。何等为正命世俗、有漏、有取、转向善趣？谓如法求衣食、卧具、随病汤药，非不如法，是名正命世俗、有漏、有取、转向善趣。何等为正命是圣出世间、无漏、不取、正尽苦、转向苦边？谓圣弟子苦苦思惟，集、灭、道道思惟，于诸邪命，无漏、不乐著，固守执持不犯，不越时节，不度限防，是名正命是圣出世间、无漏、不取、正尽苦、转向苦边。
    “何等为正方便？正方便有二种：有正方便世俗、有漏、有取、转向善趣；有正方便是圣出世间、无漏、不取、正尽苦、转向苦边。何等为正方便世俗、有漏、有取、转向善趣？谓欲精进，方便超出，坚固建立，堪能造作，精进心法摄受，常不休息，是名正方便世俗、有漏、有取、转向善趣。何等为正方便是圣出世间、无漏、不取、正尽苦、转向苦边？谓圣弟子苦苦思惟，集、灭、道道思惟，无漏忆念相应心法，欲精进方便，勤踊超出，建立坚固，堪能造作，精进心法摄受，常不休息，是名正方便是圣出世间、无漏、不取、正尽苦、转向苦边。
    “何等为正念？正念有二种：有正念世俗、有漏、有取、转向善趣；有正念是圣出世间、无漏、不取、正尽苦、转向苦边。何等为正念世俗、有漏、有取、转向善趣？若念、随念、重念、忆念，不妄不虚，是名正念世俗、有漏、有取、正向善趣。何等为正念是圣出世间、无漏、不取、正尽苦、转向苦边？谓圣弟子苦苦思惟，集、灭、道道思惟，无漏思惟相应，若念、随念、重念、忆念，不妄不虚，是名正念是圣出世间、无漏、不取、正尽苦、转向苦边。
    “何等为正定？正定有二种：有正定世俗、有漏、有取、转向善趣；有正定是圣出世间、无漏、不取、正尽苦、转向苦边。何等为正定世俗、有漏、有取、转向善趣？若心住不乱不动、摄受寂止、三昧一心，是名正定世俗、有漏、有取、转向善趣。何等为正定是圣出世间、无漏、不取、正尽苦、转向苦边？谓圣弟子苦苦思惟，集、灭、道道思惟，无漏思惟相应心法，住不乱不散、摄受寂止、三昧一心，是名正定是圣出世间、无漏、不取、正尽苦、转向苦边。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七八六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘心向邪者，违背于法，不乐于法。若向正者，心乐于法，不违于法。何等为邪？谓邪见乃至邪定。何等为正？谓正见乃至正定。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七八七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“向邪者违于法，不乐于法。向正者乐于法，不违于法。
    “何等为向邪者违于法，不乐于法？谓邪见人，身业如所见，口业如所见，若思、若欲、若愿、若为，彼皆随顺，一切得不爱果，不念、不可意果。所以者何？以见恶故，谓邪见。邪见者起邪志、邪语、邪业、邪命、邪方便、邪念、邪定。是向邪者违于法，不乐于法。
    “何等为向正者乐于法，不违于法？谓正见人，若身业随所见，若口业，若思、若欲、若愿、若为，悉皆随顺，得可爱、可念、可意果。所以者何？以见正故，谓正见。正见者能起正志、正语、正业、正命、正方便、正念、正定。是名向正者乐于法，不违于法。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（七八八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“向邪者违于法，不乐于法。向正者乐于法，不违于法。
    “何等为向邪者违于法，不乐于法？若邪见人，身业如所见，口业如所见，若思、若欲、若愿、若为，彼皆随顺，一切得不爱果，不念、不可意果。所以者何？恶见谓邪见，邪见者起邪志、邪语、邪业、邪命、邪方便、邪念、邪定。譬如苦果种着地中，随时溉灌，彼得地味、水味、火味、风味，一切悉苦。所以者何？以种苦故。如是邪见人，身业如所见，口业如所见，若思、若欲、若愿、若为，悉皆随顺，彼一切得不爱、不念、不可意果。所以者何？恶见者，谓邪见，邪见者能起邪志乃至邪定。是名向邪者违于法，不乐于法。
    “何等为向正者乐于法，不违于法？若正见人，身业如所见，口业如所见，若思、若欲、若愿、若为，悉皆随顺，彼一切得可爱、可念、可意果。所以者何？善见谓正见，正见者能起正志乃至正定。譬如甘蔗、稻、麦、蒲桃种着地中，随时溉灌，彼得地味、水味、火味、风味，彼一切味悉甜美。所以者何？以种子甜故。如是正见人，身业如所见，口业如所见，若思、若欲、若愿、若为，悉皆随顺，彼一切得可爱、可念、可意果。所以者何？善见者，谓正见，正见者能起正志乃至正定。是名向正者乐于法，不违于法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

    世间、出世间，亦如是说，如上三经，亦皆说偈言：

“鄙法不应近，放逸不应行，
不应习邪见，增长于世间。
假使有世间，正见增上者，
虽复百千生，终不堕恶趣。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七八九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有生闻婆罗门来诣佛所，稽首佛足，与世尊面相问讯慰劳已，退坐一面，白佛言：“瞿昙，所谓正见者，何等为正见？”
    佛告婆罗门：“正见有二种：有正见世俗、有漏、有取、转向善趣；有正见是圣出世间、无漏、不取、正尽苦、转向苦边。
    “何等为正见世俗、有漏、有取、转向善趣？谓正见有施、有说、有斋，乃至自知不受后有。婆罗门，是名正见世俗、有漏、有取、向于善趣。
    “婆罗门，何等为正见是圣出世间、无漏、不取、正尽苦、转向苦边？谓圣弟子苦苦思惟，集、灭、道道思惟，无漏思惟相应，于法选择、分别、求觉、巧便、黠慧、观察，是名正见是圣出世间、无漏、不取、正尽苦、转向苦边。”
    佛说此经已，生闻婆罗门闻佛所说，欢喜随喜，从座起去。
    如正见，如是正志、正语、正业、正命、正方便、正念、正定，一一经如上说。

（七九○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有邪及邪道，有正及正道。谛听善思，当为汝说。何等为邪？谓地狱、畜生、饿鬼。何等为邪道？谓邪见乃至邪定。何等为正？谓人、天、涅槃。何等为正道？谓正见乃至正定。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七九一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有邪、有邪道，有正、有正道。谛听善思，当为汝说。何等为邪？谓地狱、畜生、饿鬼。何等为邪道？谓杀、盗、邪淫、妄语、两舌、恶口、绮语、贪、恚、邪见。何等为正？谓人、天、涅槃。何等为正道？谓不杀、不盗、不邪淫、不妄语、不两舌、不恶口、不绮语、无贪、无恚、正见。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七九二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“何等为恶趣道？谓杀父、杀母、杀阿罗汉、破僧、恶心出佛身血。”余如上说。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七九三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有顺流道，有逆流道。谛听善思，当为汝说。何等为顺流道？谓邪见乃至邪定。何等为逆流道？谓正见乃至正定。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如顺流、逆流，如是退道、胜道，下道、上道，及三经道迹，亦如上说。

（七九四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有沙门及沙门法，谛听善思，当为汝说。何等为沙门法？谓八圣道，正见乃至正定。何等为沙门？若成就此法者，是名沙门。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七九五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有沙门法、沙门义。何等为沙门法？谓八圣道，正见乃至正定。何等为沙门义？谓贪欲永尽，瞋恚、愚痴永尽，一切烦恼永尽，是名沙门义。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七九六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有沙门法及沙门果，谛听善思，当为汝说。何等为沙门法？谓八圣道，正见乃至正定。何等为沙门果？谓须陀洹果、斯陀含果、阿那含果、阿罗汉果。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。


杂阿含经卷第二十九

（七九七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有沙门法及沙门果，谛听善思，当为汝说。何等为沙门法？谓八圣道，正见乃至正定。何等为沙门果？谓须陀洹果、斯陀含果、阿那含果、阿罗汉果。
    “何等为须陀洹果？谓三结断。何等为斯陀含果？谓三结断，贪、恚、痴薄。何等为阿那含果？谓五下分结尽。何等为阿罗汉果？谓贪、恚、痴永尽，一切烦恼永尽。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七九八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有沙门法、沙门、沙门义，谛听善思，当为汝说。何等为沙门法？谓八圣道，正见乃至正定。何等为沙门？谓成就此法者。何等为沙门义？谓贪欲永断，瞋恚、痴永断，一切烦恼永断。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（七九九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“有沙门果。何等为沙门果？谓须陀洹果、斯陀含果、阿那含果、阿罗汉果。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八○○）

    如是婆罗门法、婆罗门、婆罗门义、婆罗门果，梵行法、梵行者、梵行义、梵行果，亦如上说。

（八○一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五法，多所饶益修安那般那念。何等为五？住于净戒、波罗提木叉律仪，威仪、行处具足，于微细罪，能生怖畏，受持学戒，是名第一，多所饶益修习安那般那念。复次比丘，少欲、少事、少务，是名二法，多所饶益修习安那般那念。复次比丘，饮食知量，多少得中，不为饮食起求欲想，精勤思惟，是名三法，多所饶益修安那般那念。复次比丘，初夜、后夜，不著睡眠，精勤思惟，是名四法，多所饶益修安那般那念。复次比丘，空闲林中，离诸愦闹，是名五法，多所饶益修习安那般那念。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八○二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当修安那般那念，若比丘修习安那般那念，多修习者，得身止息及心止息，有觉有观，寂灭纯一，明分想修习满足。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八○三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“修习安那般那念，若比丘修习安那般那念，多修习者，得身心止息，有觉有观，寂灭纯一，明分想修习满足。
    “何等为修习安那般那念，多修习已，身心止息，有觉有观，寂灭纯一，明分想修习满足？是比丘若依聚落城邑止住，晨朝着衣持钵，入村乞食，善护其身，守诸根门，善系心住。乞食已，还住处，举衣钵，洗足已，或入林中、闲房、树下，或空露地，端身正坐，系念面前，断世贪爱，离欲清净，瞋恚、睡眠、掉悔、疑断，度诸疑惑，于诸善法心得决定。远离五盖，烦恼于心，令慧力羸，为障碍分，不趣涅槃。念于内息，系念善学；念于外息，系念善学。息长、息短，觉知一切身入息，于一切身入息善学；觉知一切身出息，于一切身出息善学。觉知一切身行息入息，于一切身行息入息善学；觉知一切身行息出息，于一切身行息出息善学。觉知喜，觉知乐，觉知心行，觉知心行息入息，于觉知心行息入息善学；觉知心行息出息，于觉知心行息出息善学。觉知心，觉知心悦，觉知心定，觉知心解脱入息，于觉知心解脱入息善学；觉知心解脱出息，于觉知心解脱出息善学。观察无常，观察断，观察无欲，观察灭入息，于观察灭入息善学；观察灭出息，于观察灭出息善学。是名修安那般那念，身止息，心止息，有觉有观，寂灭纯一，明分想修习满足。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八○四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当修安那般那念，安那般那念修习多修习者，断诸觉想。云何安那般那念修习多修习，断诸觉想？若比丘依止聚落城邑住，如上广说，乃至于出息灭善学，是名安那般那念修习多修习，断诸觉想。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如断觉想，如是不动摇、得大果、大福利，如是得甘露、究竟甘露、得二果、四果、七果，一一经亦如上说。

（八○五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“如我所说安那般那念，汝等修习不？”
    时有比丘名阿梨瑟吒，于众中坐，即从座起，整衣服，为佛作礼，右膝着地，合掌白佛言：“世尊，世尊所说安那般那念，我已修习。”
    佛告阿梨瑟吒比丘：“汝云何修习我所说安那般那念？”
    比丘白佛：“世尊，我于过去诸行不顾念，未来诸行不生欣乐，于现在诸行不生染著。于内外对碍想，善正除灭。我已如是修世尊所说安那般那念。”
    佛告阿梨瑟吒比丘：“汝实修我所说安那般那念，非不修。然其比丘，于汝所修安那般那念所，更有胜妙过其上者。何等是胜妙过阿梨瑟吒所修安那般那念者？是比丘依止城邑聚落，如前广说，乃至于灭出息观察善学，是名阿梨瑟吒比丘，胜妙过汝所修安那般那念者。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八○六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊于晨朝时着衣持钵，入舍卫城乞食。食已，还精舍，举衣钵，洗足已，持尼师坛，入安陀林，坐一树下，昼日禅思。
    时尊者罽宾那，亦晨朝时着衣持钵，入舍卫城乞食还，举衣钵，洗足已，持尼师坛，入安陀林，于树下坐禅，去佛不远，正身不动，身心正直，胜妙思惟。
    尔时众多比丘晡时从禅觉，往诣佛所，稽首礼佛足，退坐一面。
    佛语诸比丘：“汝等见尊者罽宾那不？去我不远，正身端坐，身心不动，住胜妙住。”
    诸比丘白佛：“世尊，我等数见彼尊者正身端坐，善摄其身，不倾不动，专心胜妙。”
    佛告诸比丘：“若比丘修习三昧，身心安住，不倾不动，住胜妙住者，此比丘得此三昧，不勤方便，随欲即得。”
    诸比丘白佛：“何等三昧，比丘得此三昧，身心不动，住胜妙住？”
    佛告诸比丘：“若比丘依止聚落，晨朝着衣持钵，入村乞食已，还精舍，举衣钵，洗足已，入林中，若闲房、露坐，思惟系念，乃至息灭观察善学。是名三昧，若比丘端坐思惟，身心不动，住胜妙住。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八○七）

    如是我闻。一时佛住一奢能伽罗林中。
    尔时世尊告诸比丘：“我欲二月坐禅，诸比丘勿复往来，唯除送食比丘，及布萨时。”
    尔时世尊作是语已，即二月坐禅。无一比丘敢往来者，唯除送食，及布萨时。
    尔时世尊坐禅二月过已，从禅觉，于比丘僧前坐，告诸比丘：“若诸外道出家来问汝等：‘沙门瞿昙于二月中云何坐禅？’汝应答言：‘如来二月以安那般那念，坐禅思惟住。’所以者何？我于此二月念安那般那，多住思惟。入息时念入息如实知，出息时念出息如实知，若长若短，一切身觉入息念如实知，一切身觉出息念如实知，身行休息入息念如实知，乃至灭出息念如实知。我悉知已，我时作是念：‘此则粗思惟住，我今于此思惟止息已，当更修余微细修住而住。’尔时我息止粗思惟已，即更入微细思惟，多住而住。时有三天子，极上妙色，过夜来至我所。一天子作是言：‘沙门瞿昙时到。’复有一天子言：‘此非时到，是时向至。’第三天子言：‘非为时到，亦非时向至，此则修住，是阿罗诃寂灭耳。’”
    佛告诸比丘：“若有正说圣住、天住、梵住、学住、无学住、如来住，学人所不得当得、不到当到、不证当证，无学人现法乐住者，谓安那般那念，此则正说。所以者何？安那般那念者，是圣住、天住、梵住，乃至无学现法乐住。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八○八）

    如是我闻。一时佛住迦毗罗越尼拘律树园中。
    尔时释氏摩诃男，诣尊者迦磨比丘所，礼迦磨比丘足已，退坐一面，语迦磨比丘言：“云何尊者迦磨，学住者为即是如来住耶？为学住异，如来住异？”
    迦磨比丘答言：“摩诃男，学住异，如来住异。摩诃男，学住者，断五盖多住。如来住者，于五盖已断已知，断其根本，如截多罗树头，更不生长，于未来世成不生法。
    “一时，世尊住一奢能伽罗林中，尔时世尊告诸比丘：‘我欲于此一奢能伽罗林中，二月坐禅。汝诸比丘勿使往来，唯除送食比丘，及布萨时。’广说如前，乃至无学现法乐住。以是故知，摩诃男，学住异，如来住异。”
    释氏摩诃男闻迦磨比丘所说，欢喜从座起去。

（八○九）

    如是我闻。一时佛住金刚聚落跋求摩河侧萨罗梨林中。
    尔时世尊为诸比丘说不净观，赞叹不净观，言：“诸比丘修不净观，多修习者，得大果大福利。”
    时诸比丘修不净观已，极厌患身，或以刀自杀，或服毒药，或绳自绞，投岩自杀，或令余比丘杀。
    有异比丘极生厌患恶露不净，至鹿林梵志子所，语鹿林梵志子言：“贤首，汝能杀我者，衣钵属汝。”
    时鹿林梵志子即杀彼比丘，持刀至跋求摩河边洗刀。
    时有魔天住于空中，赞鹿林梵志子言：“善哉善哉！贤首，汝得无量功德，能令诸沙门释子持戒有德，未度者度，未脱者脱，未苏息者令得苏息，未涅槃者令得涅槃。诸长利衣钵杂物，悉皆属汝。”
    时鹿林梵志子闻赞叹已，增恶邪见，作是念：“我今真实大作福德，令沙门释子持戒功德者，未度者度，未脱者脱，未苏息者令得苏息，未涅槃者令得涅槃，衣钵杂物悉皆属我。”于是手执利刀，循诸房舍、诸经行处、别房、禅房，见诸比丘，作如是言：“何等沙门持戒有德，未度者我能令度，未脱者令脱，未苏息者令得苏息，未涅槃令得涅槃！”
    时有诸比丘厌患身者，皆出房舍，语鹿林梵志子言：“我未得度，汝当度我。我未得脱，汝当脱我。我未得苏息，汝当令我得苏息。我未得涅槃，汝当令我得涅槃。”
    时鹿林梵志子即以利刀杀彼比丘，次第乃至杀六十人。
    尔时世尊至十五日说戒时，于众僧前坐，告尊者阿难：“何因何缘诸比丘转少、转减、转尽？”
    阿难白佛言：“世尊为诸比丘说修不净观，赞叹不净观。诸比丘修不净观已，极厌患身，广说乃至杀六十比丘。世尊，以是因缘故，令诸比丘转少、转减、转尽。唯愿世尊更说余法，令诸比丘闻已，勤修智慧，乐受正法，乐住正法。”
    佛告阿难：“是故我今次第说依微细住，随顺开觉，已起、未起恶不善法，速令休息。如天大雨，起、未起尘，能令休息。如是比丘修微细住，诸起、未起恶不善法，能令休息。阿难，何等为微细住多修习，随顺开觉，已起、未起恶不善法，能令休息？谓安那般那念住。”
    阿难白佛：“云何修习安那般那念住，随顺开觉，已起、未起恶不善法，能令休息？”
    佛告阿难：“若比丘依止聚落，如前广说，乃至如灭出息念而学。”
    佛说此经已，尊者阿难闻佛所说，欢喜奉行。

（八一○）

    如是我闻。一时佛住金刚跋求摩河侧萨罗梨林中。
    尔时尊者阿难独一静处，思惟禅思，作如是念：“颇有一法，修习多修习，令四法满足；四法满足已，七法满足；七法满足已，二法满足？”
    时尊者阿难从禅觉已，往诣佛所，稽首礼足，退坐一面，白佛言：“世尊，我独一静处，思惟禅思，作是念：‘颇有一法，多修习已，令四法满足，乃至二法满足？’我今问世尊，宁有一法，多修习已，能令乃至二法满足耶？”
    佛告阿难：“有一法，多修习已，乃至能令二法满足。何等为一法？谓安那般那念，多修习已，能令四念处满足；四念处满足已，七觉分满足；七觉分满足已，明、解脱满足。
    “云何修安那般那念，四念处满足？是比丘依止聚落，乃至如灭出息念学。阿难，如是圣弟子入息念时，如入息念学；出息念时，如出息念学；若长、若短，一切身行觉知入息念时，如入息念学；出息念时，如出息念学；身行休息入息念时，如身行休息入息念学；身行休息出息念时，如身行休息出息念学。圣弟子尔时身身观念住，异于身者，彼亦如是随身比思惟。若有时圣弟子喜觉知、乐觉知、心行觉知、心行息觉知入息念时，如心行息入息念学；心行息出息念时，如心行息出息念学。是圣弟子尔时受受观念住，若复异受者，彼亦随受比思惟。有时圣弟子心觉知、心悦、心定、心解脱觉知入息念时，如入息念学；心解脱出息念时，如心解脱出息念学。是圣弟子尔时心心观念住，若有异心者，彼亦随心比思惟。若圣弟子有时观无常、断、无欲、灭，如无常、断、无欲、灭观住学。是圣弟子尔时法法观念住，异于法者，亦随法比思惟。是名修安那般那念，满足四念处。”
    阿难白佛：“如是修习安那般那念，令四念处满足。云何修四念处，令七觉分满足？”
    佛告阿难：“若比丘身身观念住，念住已，系念住不忘，尔时方便修念觉分，修念觉分已，念觉分满足。念觉满足已，于法选择、思量，尔时方便修择法觉分，修择法觉分已，择法觉分满足。于法选择、分别、思量已，得精勤方便，尔时方便修习精进觉分，修精进觉分已，精进觉分满足。方便精进已，则心欢喜，尔时方便修喜觉分，修喜觉分已，喜觉分满足。欢喜已，身心猗息，尔时方便修猗觉分，修猗觉分已，猗觉分满足。身心乐已，得三昧，尔时修定觉分，修定觉分已，定觉分满足。定觉分满足已，贪忧则灭，得平等舍，尔时方便修舍觉分，修舍觉分已，舍觉分满足。受、心、法法念处，亦如是说。是名修四念处，满足七觉分。”
    阿难白佛：“是名修四念处，满足七觉分。云何修七觉分，满足明、解脱？”
    佛告阿难：“若比丘修念觉分，依远离、依无欲、依灭、向于舍，修念觉分已，满足明、解脱。乃至修舍觉分，依远离、依无欲、依灭、向于舍，如是修舍觉分已，明、解脱满足。阿难，是名法法相类，法法相润。如是十三法，一法为增上，一法为门，次第增进，修习满足。”
    佛说此经已，尊者阿难闻佛所说，欢喜奉行。

（八一一～八一二）

    如是异比丘所问、佛问诸比丘，亦如上说。

（八一三）

    如是我闻。一时佛住金毗罗聚落金毗林中。
    尔时世尊告尊者金毗罗：“我今当说精勤修习四念处，谛听善思，当为汝说。”
    尔时尊者金毗罗默然住，如是再三。
    尔时尊者阿难语尊者金毗罗：“今大师告汝！”如是三说。
    尊者金毗罗语尊者阿难：“我已知，尊者阿难！我已知，尊者瞿昙！”
    尔时尊者阿难白佛言：“世尊！是时，世尊！是时，善逝！唯愿为诸比丘说精勤修四念处，诸比丘闻已，当受奉行。”
    佛告阿难：“谛听善思，当为汝说。若比丘入息念时，如入息学，乃至灭出息时，如灭出息学。尔时圣弟子念入息时，如念入息学，乃至身行止息出息时，如身行止息出息学，尔时圣弟子身身观念住。尔时圣弟子身身观念住已，如是知善内思惟。”
    佛告阿难：“譬如有人乘车舆，从东方颠沛而来。当于尔时，践蹈诸土堆垄不？”
    阿难白佛：“如是，世尊。”
    佛告阿难：“如是圣弟子念入息时，如入息念学，如是乃至善内思惟。若尔时圣弟子觉知喜，乃至觉知意行息学，圣弟子受受观念住。圣弟子受受观念已，如是知善内思惟。譬如有人乘车舆，从南方颠沛而来。云何阿难，当践蹈土堆垄不？”
    阿难白佛：“如是，世尊。”
    佛告阿难：“如是圣弟子受受观念住，知善内思惟。若圣弟子觉知心、欣悦心、定心、解脱心入息，如解脱心入息学；解脱心出息，如解脱心出息学，尔时圣弟子心心观念住。如是圣弟子心心观念住已，知善内思惟。譬如有人乘车舆从西方来，彼当践蹈土堆垄不？”
    阿难白佛：“如是，世尊。”
    佛告阿难：“如是圣弟子觉知心，乃至心解脱出息，如心解脱出息学，如是圣弟子尔时心心观念住，知善内思惟。善于身、受、心，贪忧灭舍，尔时圣弟子法法观念住。如是圣弟子法法观念住已，知善内思惟。阿难，譬如四衢道有土堆垄，有人乘车舆从北方颠沛而来，当践蹈土堆垄不？
    阿难白佛：“如是，世尊。”
    佛告阿难：“如是圣弟子法法观念住，知善内思惟。阿难，是名比丘精勤方便，修四念处。”
    佛说此经已，尊者阿难闻佛所说，欢喜奉行。

（八一四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当修安那般那念。修安那般那念，多修习已，身不疲倦，眼亦不患，乐随顺观住，乐觉知，不染著乐。云何修安那般那念，身不疲倦，眼亦不患，乐随观住，乐觉知，不染著乐？是比丘依止聚落，乃至观灭出息时，如灭出息学，是名修安那般那念，身不疲倦，眼亦不患，乐随观住，乐觉知，不染著乐。如是修安那般那念者，得大果大福利。
    “是比丘欲求离欲恶不善法，有觉有观，离生喜乐，初禅具足住，是比丘当修安那般那念。如是修安那般那念，得大果大福利。是比丘欲求第二、第三、第四禅、慈、悲、喜、舍、空入处、识入处、无所有入处、非想非非想入处具足；三结尽，得须陀洹果；三结尽，贪、恚、痴薄，得斯陀含果；五下分结尽，得阿那含果；得无量种神通力，天耳、他心智、宿命智、生死智、漏尽智者，如是比丘当修安那般那念。如是安那般那念，得大果大福利。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八一五）

    如是我闻。一时佛住舍卫国祇树给孤独园夏安居。
    尔时众多上座声闻，于世尊左右，树下、窟中安居。
    时有众多年少比丘诣佛所，稽首佛足，退坐一面。
    佛为诸年少比丘种种说法，示教照喜，示教照喜已，默然住。
    诸年少比丘闻佛所说，欢喜随喜，从座起，作礼而去。诸年少比丘往诣上座比丘所，礼诸上座足已，于一面坐。
    时诸上座比丘作是念：“我等当摄受此诸年少比丘，或一人受一人，或一人受二、三、多人。”作是念已，即便摄受，或一人受一人，或受二、三、多人，或有上座乃至受六十人。
    尔时世尊十五日布萨时，于大众前敷座而坐。尔时世尊观察诸比丘已，告比丘：“善哉善哉！我今喜诸比丘行诸正事。是故比丘，当勤精进，于此舍卫国，满迦低月。”
    诸处人间遊行比丘，闻世尊于舍卫国安居，满迦低月限已，作衣竟，持衣钵，于舍卫国人间游行，渐至舍卫国，举衣钵，洗足已，诣世尊所，稽首礼足已，退坐一面。
    尔时世尊为人间比丘种种说法，示教照喜已，默然住。
    尔时人间比丘闻佛说法，欢喜随喜，从座起，作礼而去。往诣上座比丘所，稽首礼足，退坐一面。
    时诸上座作是念：“我等当受此人间比丘，或一人受一人，或二、三，乃至多人。”即便受之，或一人受一人，或二、三，乃至有受六十人者。彼上座比丘受诸人间比丘，教诫教授，善知先后次第。
    尔时世尊月十五日布萨时，于大众前敷座而坐，观察诸比丘众，告诸比丘：“善哉善哉！诸比丘，我欣汝等所行正事，乐汝等所行正事。诸比丘，过去诸佛亦有比丘众，所行正事，如今此众。未来诸佛所有诸众亦当如是，所行正事，如今此众。所以者何？今此众中诸长老比丘，有得初禅、第二禅、第三禅、第四禅、慈、悲、喜、舍、空入处、识入处、无所有入处、非想非非想入处具足住。有比丘三结尽，得须陀洹，不堕恶趣法，决定向三菩提，七有天人往生，究竟苦边。有比丘三结尽，贪、恚、痴薄，得斯陀含。有比丘五下分结尽，得阿那含，生般涅槃，不复还生此世。有比丘得无量神通境界，天耳、他心智、宿命智、生死智、漏尽智。有比丘修不净观，断贪欲；修慈心，断瞋恚；修无常想，断我慢；修安那般那念，断觉想。云何比丘修安那般那念，断觉想？是比丘依止聚落，乃至观灭出息，如观灭出息学，是名修安那般那念，断觉想。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八一六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有三学。何等为三？谓增上戒学、增上意学、谓增上慧学。”
    尔时世尊即说偈言：

“三学具足者，是比丘正行，
增上戒心慧，三法勤精进。
勇猛坚固城，常守护诸根，
如昼如其夜，如夜亦如昼，
如前如其后，如后亦如前，
如上如其下，如下亦如上。
无量诸三昧，映一切诸方，
是说为觉迹，第一清凉集。
舍离无明诤，其心善解脱，
我为世间觉，明行悉具足。
正念不忘住，其心得解脱，
身坏而命终，如灯尽火灭。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八一七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“亦复有三学。何等为三？谓增上戒学、增上意学、增上慧学。何等为增上戒学？若比丘住于戒、波罗提木叉律仪，威仪、行处具足，见微细罪，则生怖畏，受持学戒。何等为增上意学？若比丘离欲恶不善法，乃至第四禅具足住。何等为增上慧学？是比丘此苦圣谛如实知，集、灭、道圣谛如实知，是名增上慧学。”
    尔时世尊即说偈，如上所说。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八一八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有比丘增上戒学，非增上意、增上慧学；有增上戒、增上意学，非增上慧学。圣弟子增上慧方便随顺成就住者，增上戒、增上意修习满足。如是圣弟子增上慧方便随顺成就住者，无上慧寿而活。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八一九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过二百五十戒，随次半月来，说波罗提木叉修多罗。令彼自求学者而学，说三学能摄诸戒。何等为三？谓增上戒学、增上意学、增上慧学。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八二○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“何等为增上戒学？谓比丘重于戒，戒增上；不重于定，定不增上；不重于慧，慧不增上。于彼彼分细微戒，犯则随悔。所以者何？我不说彼不堪能，若彼戒随顺梵行、饶益梵行、久住梵行，如是比丘戒坚固，戒师常住，戒常随顺生，受持而学。如是知、如是见，断三结，谓身见、戒取、疑。断此三结，得须陀洹，不堕恶趣法，决定趣三菩提，七有天人往生，究竟苦边，是名学增上戒。
    “何等为增上意学？是比丘重于戒，戒增上；重于定，定增上；不重于慧，慧不增上。于彼彼分细微戒，乃至受持学戒。如是知、如是见，断于五下分结，谓身见、戒取、疑、贪欲、瞋恚。断此五下分结，受生般涅槃阿那含，不还此世，是名增上意学。
    “何等为增上慧学？是比丘重于戒，戒增上；重于定，定增上；重于慧，慧增上。彼如是知、如是见，欲有漏心解脱，有有漏心解脱，无明有漏心解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。是名增上慧学。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八二一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过二百五十戒，随次半月来，说波罗提木叉修多罗。若彼善男子，自随意所欲而学者，我为说三学，若学此三学，则摄受一切学戒。何等为三？谓增上戒学、增上意学、增上慧学。
    “何等为增上戒学？是比丘重于戒，戒增上；不重于定，定不增上；不重于慧，慧不增上。于彼彼分细微戒，乃至受持学戒。如是知、如是见，断三结，谓身见、戒取、疑。贪、恚、痴薄，成一种子道；彼地未等觉者，名斯陀含；彼地未等觉者，名家家；彼地未等觉者，名七有；彼地未等觉者，名随法行；彼地未等觉者，名随信行。是名增上戒学。
    “何等为增上意学？是比丘重于戒，戒增上；重于定，定增上；不重于慧，慧不增上。于彼彼分细微戒学，乃至受持学戒。如是知、如是见，断五下分结，谓身见、戒取、疑、贪欲、瞋恚。断此五下分结，能得中般涅槃；彼地未等觉者，得生般涅槃；彼地未等觉者，得无行般涅槃；彼地未等觉者，得有行般涅槃；彼地未等觉者，得上流般涅槃。是名增上意学。
    “何等为增上慧学？是比丘重于戒，戒增上；重于定，定增上；重于慧，慧增上。如是知、如是见，欲有漏心解脱，有有漏心解脱，无明有漏心解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。是名增上慧学。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八二二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘具足戒住者，善摄持波罗提木叉，具足威仪、行处，见细微罪，能生怖畏。比丘具足戒住，善摄持波罗提木叉，具足威仪、行处，见细微罪，能生怖畏，等受学戒，令三学修习满足。何等为三？增上戒学、增上意学、增上慧学。
    “何等为增上戒学？是比丘戒为满足、少定、少慧，于彼彼分细微戒，乃至受持戒学。彼如是知、如是见，断三结，谓身见、戒取、疑。断此三结，得须陀洹，不堕恶趣法，决定趣三菩提，七有天人往生，究竟苦边。
    “何等为增上意学？是比丘戒满足、三昧满足、少于慧，于彼彼分细微戒，犯则随悔，乃至受持学戒。如是知、如是见，断五下分结，谓身见、戒取、疑、贪欲、瞋恚。断此五下分结，得生般涅槃阿那含，不复还生此世，是名增上意学。
    “何等为增上慧学？是比丘学戒满足、定满足、慧满足。如是知、如是见，欲有漏心解脱，有有漏心解脱，无明有漏心解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。是名增上慧学。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八二三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘具足戒住，善摄波罗提木叉，具足威仪、行处，见微细罪，能生怖畏，受持学戒住，满足三学。何等为三？谓增上戒、增上意、增上慧。
    “何等为增上戒？是比丘戒满足、少定、少慧，于彼彼分细微戒，乃至受持学戒。如是知、如是见，断三结，贪、恚、痴薄，得一种子道；若彼地未等觉者，得斯陀含；彼地未等觉者，名家家；彼地未等觉者，得须陀洹；彼地未等觉者，得随法行；彼地未等觉者，得随信行。是名增上戒学。
    “何等为增上意学？是比丘戒满足、定满足、少于慧，于彼彼分细微戒，乃至受持学戒。如是知、如是见，断五下分结，谓身见、戒取、疑、贪欲、瞋恚。断此五下分结，得中般涅槃；于彼未等觉者，得生般涅槃；于彼未等觉者，得无行般涅槃；于彼未等觉者，得有行般涅槃；于彼未等觉者，得上流般涅槃。是名增上意学。
    “何等为增上慧学？是比丘学戒满足、定满足、慧满足。如是知、如是见，欲有漏心解脱，有有漏心解脱，无明有漏心解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。是名增上慧学。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八二四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有三学。何等为三？谓上戒学、上威仪学、上波罗提木叉学。”
    尔时世尊即说偈言：

“学者学戒时，直道随顺行，
专审勤方便，善自护其心。
得初漏尽智，次究竟无知，
得无知解脱，知见悉已度，
成不动解脱，诸有结灭尽。
彼诸根具足，诸根寂静乐，
持此后边身，摧伏众魔怨。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八二五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“学戒多福利，住智慧为上，解脱坚固，念为增上。若比丘学戒福利，智慧为上，解脱坚固，念增上已，令三学满足。何等为三？谓增上戒学、增上意学、增上慧学。”
    尔时世尊即说偈言：

“学戒随福利，专思三昧禅，
智慧为最上，现生之最后，
牟尼持后边，降魔度彼岸。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八二六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“诸比丘，何等为学戒随福利？谓大师为诸声闻制戒，所谓摄僧，极摄僧，不信者信，信者增其信，调伏恶人，惭愧者得乐住，现法防护有漏，未来得正对治，令梵行久住。如大师已为声闻制戒，谓摄僧，乃至梵行久住。如是如是学戒者，行坚固戒、恒戒、常行戒、受持学戒，是名比丘戒福利。
    “何等智慧为上？谓大师为声闻说法，大悲哀愍，以义饶益，若安慰，若安乐，若安慰安乐。如是如是大师为诸声闻说法，大悲哀愍，以义饶益，安慰安乐。如是如是于彼彼法、彼彼处，智慧观察，是名比丘智慧为上。
    “何等为解脱坚固？谓大师为诸声闻说法，大悲哀愍，以义饶益，安慰安乐。如是如是说彼彼法，如是如是彼彼处得解脱乐，是名比丘坚固解脱。
    “何等为比丘念增上？未满足戒身者，专心系念安住；未观察者，于彼彼处智慧系念安住；已观察者，于彼彼处重念安住；未触法者，于彼彼处解脱念安住；已触法者，于彼彼处解脱念安住，是名比丘正念增上。”
    尔时世尊即说偈言：

“学戒随福利，专思三昧禅，
智慧为最上，现生最后边，
牟尼持后边，降魔度彼岸。”

    佛说是经已，诸比丘闻佛所说，欢喜奉行。
    《尸婆迦修多罗》如后，佛当说。
    如是阿难陀比丘及异比丘所问、佛问诸比丘，三经亦如上说。

（八二七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“譬如田夫，有三种作田，随时善作。何等为三？谓彼田夫随时耕磨，随时溉灌，随时下种。彼田夫随时耕磨、溉灌、下种已，不作是念：‘欲令今日生长，今日果实，今日成熟，若明日、后日也。’诸比丘，然彼长者耕田、溉灌、下种已，不作是念：‘今日生长，果实成熟，若明日，若复后日。’而彼种子已入地中，则自随时生长，果实成熟。
    “如是比丘于此三学随时善学，谓善戒学、善意学、善慧学已，不作是念：‘欲令我今日得不起诸漏，心善解脱，若明日，若后日。’不作是念：‘自然神力，能令今日，若明日、后日，不起诸漏，心善解脱。’彼已随时增上戒学、增上意学、增上慧学已，随彼时节，自得不起诸漏，心善解脱。
    “比丘，譬如伏鸡生卵，若十乃至十二，随时消息冷暖爱护。彼伏鸡不作是念：‘我今日，若明日、后日，当以口啄，若以爪刮，令其儿安隐得生。’然其伏鸡善伏其子，爱护随时，其子自然安隐得生。如是比丘善学三学，随其时节，自得不起诸漏，心善解脱。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八二八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“譬如驴随群牛而行，而作是念：‘我作牛声。’然其彼形亦不似牛，色亦不似，声出不似。随大群牛，谓己是牛，而作牛鸣，而去牛实远。如是有一愚痴男子违律犯戒，随逐大众，言：‘我是比丘，我是比丘。’而不学习胜欲增上戒学、增上意学、增上慧学，随逐大众，自言：‘我是比丘，我是比丘。’其实去比丘大远。”
    尔时世尊即说偈言：

“同蹄无角兽，四足具声口，
随逐大群牛，常以为等侣，
形亦非牛类，不能作牛声。
如是愚痴人，不随系心念，
于善逝教诫，无欲勤方便，
懈怠心轻慢，不获无上道。
如驴在牛群，去牛常自远，
彼虽随大众，内行常自乖。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八二九）

    如是我闻。一时佛住跋耆聚落。
    尊者跋耆子侍佛左右。尔时尊者跋耆子诣佛所，稽首礼足，退住一面，白佛言：“世尊，佛说过二百五十戒，令族姓子随次半月来，说波罗提木叉修多罗，令诸族姓子随欲而学。然今世尊，我不堪能随学而学。”
    佛告跋耆子：“汝堪能随时学三学不？”
    跋耆子白佛言：“堪能，世尊。”
    佛告跋耆子：“汝当随时增上戒学、增上意学、增上慧学。随时精勤增上戒学、增上意学、增上慧学已，不久当得尽诸有漏，无漏心解脱、慧解脱，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。”
    尔时尊者跋耆子闻佛所说，欢喜随喜，作礼而去。
    尔时尊者跋耆子受佛教诫教授已，独一静处，专精思惟，如上说，乃至心善解脱，得阿罗汉。


杂阿含经卷第三十

（八三○）

    如是我闻。一时佛住崩伽阇崩伽耆林中。
    尔时世尊为诸比丘说戒相应法，赞叹制戒法。
    尔时尊者迦叶氏，于崩伽聚落住，闻世尊说戒相应法，极赞叹是戒，心不忍不喜，言：“此沙门极赞叹是戒，极制是戒。”
    尔时世尊于崩伽聚落随所乐住已，向舍卫国去，次第游行，至舍卫国祇树给孤独园。
    时尊者迦叶氏，世尊去后不久，心即生悔：“我今失利，得大不利。于世尊所说戒相应法，赞叹制戒时，于世尊所，心不忍不喜，心不欢喜而作是言：‘沙门极制是戒，极赞叹是戒。’”
    时尊者迦叶氏，夜过晨朝，着衣持钵，入崩伽聚落乞食。食已，还精舍，付嘱卧具，自持衣钵，向舍卫城次第游行，至舍卫国，举衣钵，洗足已，诣世尊，稽首礼足，白佛言：“悔过，世尊！悔过，善逝！我愚我痴，不善不辨。我闻世尊为诸比丘说戒相应法，赞叹制戒时，于世尊所，不忍不喜，心不欣乐，而作是言：‘是沙门极制是戒，赞叹是戒。’”
    佛告迦叶氏：“汝何时于我所，心不忍不喜，不生欣乐，而作是言：‘此沙门极制是戒，赞叹是戒？’”
    迦叶氏白佛言：“时世尊于崩伽阇聚落，崩伽耆林中，为诸比丘说戒相应法，赞叹是戒。我尔时于世尊所，心得不忍不欢喜，心不欣乐而作是言：‘是沙门极制是戒，赞叹是戒。’世尊，我今日自知罪悔，自见罪悔，唯愿世尊受我悔过，哀愍故！”
    佛告迦叶氏：“汝自知悔，愚痴、不善、不辨，闻我为诸比丘说戒相应法，赞叹制戒，而于我所，不忍不喜，心不欣乐，而作是言：‘是沙门极制是戒，极叹是戒。’汝今迦叶自知悔、自见悔已，于未来世律仪戒生，我今授汝，哀愍故。迦叶氏，如是悔者，善法增长，终不退减。所以者何？若有自知罪、自见罪而悔过者，于未来世律仪戒生，善法增长，不退减故。
    “正使迦叶为上座者，不欲学戒，不重于戒，不叹制戒，如是比丘，我不赞叹。所以者何？若大师所赞叹者，余人则复与相习近、恭敬亲重；若余人与相习近、亲重者，则与同见，同彼所作；同彼所作者，长夜当得不饶益苦。是故我于彼长老，初不赞叹，以其初始不乐学戒故。如长老，中年、少年亦如是。
    “若是上座长老，初始重于戒学，赞叹制戒，如是长老，我所赞叹，以其初始乐学戒故。大师所赞叹者，余人亦当与相习近、亲重，同其所见。同其所见故，于未来世，彼当长夜以义饶益。是故于彼长老比丘，常当赞叹，以初始乐学戒故。中年、少年，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八三一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若诸上座长老比丘，初始不乐学戒、不重于戒，见余比丘初乐学戒、重于戒、赞叹制戒者，彼亦不随时赞叹。我于此等比丘所，亦不赞叹，以其初始不乐学戒故。所以者何？若大师赞叹彼者，余人当复习近、亲重，同其所见；以同其所见故，长夜当受不饶益苦。是故我于彼长老。中年、少年，亦复如是。乐学戒者，如前说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八三二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有三学。何等为三？谓增上戒学、增上意学、增上慧学。何等为增上戒学？若比丘住于戒、波罗提木叉，具足威仪、行处，见微细罪则生怖畏，受持学戒，是名增上戒学。何等为增上意学？若比丘离诸恶不善法，有觉有观，离生喜乐，初禅具足住，乃至第四禅具足住，是名增上意学。何等为增上慧学？若比丘此苦圣谛如实知，此苦集圣谛、此苦灭圣谛、此苦灭道迹圣谛如实知，是名增上慧学。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    三学余经，如前念处说。
    如禅，如是无量、无色；如四圣谛，如是四念处、四正断、四如意足、五根、五力、七觉分、八圣道、四道、四法句、止观修习，亦如是说。

（八三三）

    如是我闻。一时佛住毗舍离国猕猴池侧重阁讲堂。
    时有善调象师离车，名曰难陀，来诣佛所，稽首佛足，退坐一面。
    尔时世尊告离车难陀言：“若圣弟子成就四不坏净者，欲求寿命，即得寿命；求好色、力、乐、辩、自在，即得。何等为四？谓佛不坏净成就，法、僧不坏净、圣戒成就。我见是圣弟子于此命终，生于天上，于天上得十种法。何等为十？得天寿、天色、天名称、天乐、天自在、天色、声、香、味、触。若圣弟子于天上命终，来生人中者，我见彼十事具足。何等为十？人间寿命、人好色、名称、乐、自在、色、声、香、味、触。我说彼多闻圣弟子不由他信、不由他欲、不从他闻、不取他意、不因他思，我说彼有如实正慧知见。”
    尔时难陀有从者，白难陀言：“浴时已到，今可去矣。”
    难陀答言：“我今不须人间澡浴，我今于此胜妙法以自沐浴，所谓于世尊所，得清净信乐。”
    尔时离车调象师难陀闻佛所说，欢喜随喜，从座起，作礼而去。

（八三四）

    如是我闻。一时佛住毗舍离国猕猴池侧重阁讲堂。
    尔时世尊告诸比丘：“若圣弟子成就四不坏净者，不于人中贫活而活，不寒乞，自然富足。何等为四？谓于佛不坏净成就，法、僧、圣戒不坏净成就。是故比丘，当如是学：我当成就于佛不坏净，法、僧不坏净，圣戒成就。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八三五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“转轮王七宝具足，成就人中四种神力，王四天下，身坏命终，生于天上。虽复转轮圣王七宝具足，成就人间神力，王四天下，身坏命终得生天上，然犹未断地狱、畜生、饿鬼恶趣之苦。所以者何？以转轮王不得于佛不坏净，法、僧不坏净，圣戒不成就故。
    “多闻圣弟子持粪扫衣，家家乞食，草蓐卧具，而彼多闻圣弟子解脱地狱、畜生、饿鬼恶趣之苦。所以者何？以彼多闻圣弟子于佛不坏净，法、僧不坏净，圣戒成就。是故诸比丘，当作是学，于佛不坏净，法、僧不坏净，圣戒成就。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八三六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“汝等当起哀愍心、慈悲心，若有人于汝等所说，乐闻乐受者，汝当为说四不坏净，令入令住。何等为四？于佛不坏净、于法不坏净、于僧不坏净、于圣戒成就。所以者何？若四大，地、水、火、风，有变易增损。此四不坏净，未尝增损变异。彼无增损变异者，谓多闻圣弟子于佛不坏净成就，若堕地狱、畜生、饿鬼者，无有是处。是故诸比丘，当作是学：我当成就于佛不坏净，法、僧不坏净，圣戒成就；亦当建立余人令成就。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八三七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若信人者，生五种过患。彼人或时犯戒违律，为众所弃。恭敬其人者，当作是念：‘此是我师，我所敬重。众僧弃薄，我今何缘入彼塔寺？’不入塔寺已，不敬众僧；不敬僧已，不得闻法；不闻法已，退失善法，不得久住于正法中，是名信敬人，生初过患。
    “复次敬信人者，所敬之人犯戒违律，众僧为作不见举。敬信彼人者，当作是念：‘此是我师，我所敬重。而今众僧作不见举，我今何缘复入塔寺？’不入塔寺已，不敬众僧；不敬众僧已，不得闻法；不闻法已，退失善法，不得久住于正法中，是名敬信人故，生第二过患。
    “复次彼人若持衣钵，余方游行。敬彼人者，而作是念：‘我所敬人着衣持钵，余方游行，我今何缘入彼塔寺？’不入塔寺已，不得恭敬众僧；不敬众僧已，不得闻法；不闻法已，退失善法，不得久住于正法中，是名敬信人故，生第三过患。
    “复次彼所信敬人，舍戒还俗。敬信彼人者，而作是念：‘彼是我师，我所敬重，舍戒还俗。我今不应入彼塔寺。’不入寺已，不敬众僧；不敬僧已，不得闻法；不闻法已，退失善法，不得久住于正法中，是名敬信人故，生第四过患。
    “复次彼所信敬人，身坏命终。敬信彼人者，而作是念：‘彼是我师，我所敬重，今已命终。我今何缘入彼塔寺？’不入寺故，不得敬僧；不敬僧已，不得闻法；不闻法故，退失善法，不得久住于正法中，是名敬信人故，生第五过患。
    “是故诸比丘，当如是学：我当成就于佛不坏净，于法、僧不坏净，圣戒成就。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八三八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四种食，长养众生四大，增长摄受。何等为四？谓抟食、触食、意思食、识食。
    “如是福德润泽，为安乐食，何等为四？谓于佛不坏净，于法、僧不坏净，圣戒成就。是故诸比丘，当作是学：我当成就于佛不坏净，于法、僧不坏净，圣戒成就。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八三九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“于佛不坏净成就者，为闻法、众僧所念、圣戒成就。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八四○）

    次经亦如上说，差别者：“若于佛不坏净成就者，法、僧悭垢缠众生，离悭垢心，在家而住解脱心施，常行乐施，常乐于舍，行平等施，圣戒成就。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八四一）

    次经亦如上说，差别者：“如是圣弟子四种福德润泽，善法润泽，摄受称量功德，不可称量尔所果福、尔所果、尔所福果集，然彼得众多福利，是大功德聚数。譬如五河合流，谓恒河、耶菩那、萨罗由、伊罗跋提、摩醯，于彼诸水，无能度量百瓶、千瓶、百千万瓶者，然彼水多，是大水聚数。如是圣弟子成就四功德润泽者，无能度量其福多少，然彼多福，是大功德聚数。是故诸比丘，当作是学：我当成就于佛不坏净，于法、僧不坏净，圣戒成就。”
    尔时世尊即说偈言：

“众吉之巨海，自净能净彼，
汪洋而平流，实诸百川长。
一切诸江河，群生之所依，
悉归于大海。此身亦复然，
施戒修功德，百福流所归。”

（八四二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“婆罗门者说虚伪道，愚痴、恶邪、不正趣向，非智等觉向于涅槃。彼作如是化诸弟子：于十五日，以胡麻屑、庵罗摩罗屑，沐浴身体，着新劫贝，头垂长缕，牛屎涂地而卧于上，言：‘善男子，晨朝早起，脱衣举着一处，裸其形体，向东方驰走。正使道路逢凶象、恶马、狂牛、猘狗、棘刺、丛林、坑涧、深水，直前莫避，遇害死者，必生梵天。’是名外道愚痴邪见，非智等觉向于涅槃。
    “我为弟子说平正路，非愚痴，向智慧等觉，向于涅槃，谓八圣道，正见乃至正定。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八四三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告尊者舍利弗：“所谓流者，何等为流？”
    舍利弗白佛言：“世尊所说流者，谓八圣道。”
    复问舍利弗：“谓入流分，何等为入流分？”
    舍利弗白佛言：“世尊，有四种入流分。何等为四？谓亲近善男子、听正法、内正思惟、法次法向。”
    复问舍利弗：“入流者成就几法？”
    舍利弗白佛言：“有四分成就入流者。何等为四？谓于佛不坏净、于法不坏净、于僧不坏净、圣戒成就。”
    佛告舍利弗：“如汝所说，流者谓八圣道；入流分者有四种，谓亲近善男子、听正法、内正思惟、法次法向；入流者成就四法，谓于佛不坏净、于法不坏净、于僧不坏净、圣戒成就。”
    佛说此经已，尊者舍利弗闻佛所说，欢喜奉行。

（八四四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者舍利弗诣尊者阿难所，问讯慰劳已，退住一面。尊者舍利弗语尊者阿难：“欲有所问，宁有闲暇为记说不？”
    尊者阿难语舍利弗：“随意所问，知者当答。”
    舍利弗问尊者阿难：“为断几法，如来、应、等正觉所知所见，记说彼人得须陀洹，不堕恶趣法，决定向正觉，七有天人往生，究竟苦边？”
    尊者阿难语尊者舍利弗：“断四法、成就四法，如来、应、等正觉记说彼人得须陀洹，不堕恶趣法，决定向三菩提，七有天人往生，究竟苦边。何等为四？谓圣弟子于佛不信住则已断已知，成就于佛不坏净；于法、僧不信，恶戒，彼则已断已知，成就法、僧不坏净，及圣戒成就。如是四法断、四法成就，如来、应、等正觉所知所见，记说彼人得须陀洹，不堕恶趣法，决定正向三菩提，七有天人往生，究竟苦边。”
    尊者阿难语尊者舍利弗：“如是如是四法断、四法成就，如来、应、等正觉所知所见，记说彼人得须陀洹，决定向三菩提，七有天人往生，究竟苦边。”
    时二正士共论议已，展转随喜，从座起去。

（八四五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘于五恐怖怨对休息，三事决定，不生疑惑，如实知见贤圣正道，彼圣弟子能自记说：地狱、畜生、饿鬼恶趣已尽，得须陀洹，不堕恶趣法，决定正向三菩提，七有天人往生，究竟苦边。
    “何等为五恐怖怨对休息？若杀生因缘罪，怨对恐怖生；若离杀生者，彼杀生罪怨对因缘生恐怖休息。若偷盗、邪淫、妄语、饮酒罪，怨对因缘生恐怖；彼若离偷盗、邪淫、妄语、饮酒罪，怨对者因缘恐怖休息。是名罪怨对因缘生五恐怖休息。
    “何等为三事决定，不生疑惑？谓于佛决定离于疑惑，于法、僧决定离疑惑，是名三法决定离疑惑。
    “何等名为圣道如实知见？谓此苦圣谛如实知，此苦集圣谛、此苦灭圣谛、此苦灭道迹圣谛如实知，是名圣道如实知见。
    “若于此五恐怖罪怨对休息，于三法决定离疑惑，于圣意如实知见，是圣弟子能自记说：我地狱尽，畜生、饿鬼恶趣尽，得须陀洹，不堕恶趣法，决定正趣三菩提，七有天人往生，究竟苦边。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八四六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“何等为圣道如实知见？谓八圣道，正见乃至正定。”
    次经亦如是说，差别者：“何等为圣道如实知见？谓十二支缘起如实知见，如所说：是事有故是事有，是事起故是事起，如缘无明行，缘行识，缘识名色，缘名色六入处，缘六入处触，缘触受，缘受爱，缘爱取，缘取有，缘有生，缘生老病死、忧悲苦恼，是名圣弟子如实知见。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八四七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四种诸天天道，未净众生令净，已净者重令净。何等为四？谓圣弟子于佛不坏净，于法、僧不坏净，圣戒成就。是名四种诸天天道，未净众生令净，已净者重令净。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八四八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四种诸天天道。何等为四？谓圣弟子念如来事，如是如来、应、等正觉、明行足、善逝、世间解、无上士、调御丈夫、天人师、佛、世尊。于此如来事，生随喜心；随喜已，心欢悦；心欢悦已，身猗息；身猗息已，觉受乐；觉受乐已，三昧定；三昧定已，圣弟子作如是学：何等为诸天天道？复作是念：‘我闻无恚为上诸天天道。’作是念：‘我从今日，于世间若怖若安，不起瞋恚，我但当自受纯一满净诸天天道。’是名第一诸天天道，未净众生令净，已净者重令净。
    “复次比丘，圣弟子念于法事，谓如来说正法律，现法离诸炽然，不待时节，通达涅槃，即身观察，缘自觉知。如是知法事已，心生随喜；随喜已，身猗息；身猗息已，觉受乐；觉受乐已，三昧定；三昧定已，圣弟子作如是学：何等为诸天天道？复作是念：‘我闻无恚为上诸天天道，我从今日，于此世间若怖若安，不起瞋恚，我当受持纯一满净诸天天道。’是名第二诸天天道。
    “复次比丘，若于僧事起于正念，谓世尊弟子僧，正直等向，所应恭敬、尊重、供养，无上福田。彼如是于诸僧事正忆念已，心生随喜；心随喜已，得欢悦；欢悦已，身猗息；身猗息已，觉受乐；觉受乐已，三昧定；三昧定已，彼圣弟子作如是学：何等诸天天道？复作是念：‘我闻诸天无恚为上诸天天道，我从今日，于诸世间若怖若安，不起瞋恚，我但当受持纯一满净诸天天道。’是名第三诸天天道。
    “复次比丘，谓圣弟子自念所有戒事，随忆念言：‘我于此不缺戒、不污戒、不杂戒、明智所叹戒、智者不厌戒。’于如是等戒事正忆念已，心生随喜；随喜已，欢悦；欢悦已，身猗息；身猗息已，觉受乐；觉受乐已，三昧定；三昧定已，圣弟子作是念：‘何等为诸天天道？’复作是念：‘我闻诸天无恚为上诸天天道，我从今日，于诸世间若怖若安，不起瞋恚，我当受持纯一满净诸天天道。’是名第四诸天天道，未净众生令净，已净者重令净。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八四九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四种诸天天道，未净众生令净，已净者增其净。何等为四？谓圣弟子念如来事，如是如来、应、等正觉、明行足、善逝、世间解、无上士、调御丈夫、天人师、佛、世尊。彼如是念如来事已，则断恶贪，及断心恶不善过。念如来故，心生随喜；心随喜已，则欢悦；欢悦已，身猗息；身猗息已，觉受乐；觉受乐已，三昧定；三昧定已，圣弟子作如是学：何等为诸天天道？复作是念：‘我闻无恚为上诸天天道，我从今日，于诸世间若怖若安，不起瞋恚，但当受持纯一满净诸天天道。’如是法、僧、圣戒成就，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八五○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四种诸天天道，未净众生令净，已净者增其净。何等为四？谓圣弟子念如来事，如是如来、应、等正觉、明行足、善逝、世间解、无上士、调御丈夫、天人师、佛、世尊。彼圣弟子念如来事已，心离贪欲缠、瞋恚、愚痴缠，其心正直。念如来事，是圣弟子得法流水，得义流水，得念如来饶益随喜；随喜已，生欢悦；欢悦已，身猗息；身猗息已，觉受乐；觉受乐已，三昧定；三昧定已，是圣弟子作如是学：何等为诸天天道？复作是念：‘我闻无恚为上诸天天道，我从今日，于诸世间不起瞋恚，纯一满净诸天天道。’如是法、僧、圣戒成就，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八五一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当说《法镜经》，谛听善思，当为汝说。何等为《法镜经》？谓圣弟子于佛不坏净，于法、僧不坏净，圣戒成就，是名《法镜经》。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八五二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有众多比丘着衣持钵，入舍卫城乞食。乞食时，闻难屠比丘命终、难陀比丘尼命终、善生优婆塞命终、善生优婆夷命终。乞食已，还精舍，举衣钵，洗足已，诣佛所，稽首礼足，退坐一面，白佛言：“世尊，我今晨朝入舍卫城乞食，闻难屠比丘、难陀比丘尼、善生优婆塞、善生优婆夷命终。世尊，彼四人命终，应生何处？”
    佛告诸比丘：“彼难屠比丘、难陀比丘尼，诸漏已尽，无漏心解脱、慧解脱，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。善生优婆塞、善生优婆夷，五下分结尽，得阿那含，生于天上而般涅槃，不复还生此世。”
    尔时世尊告诸比丘：“我今当为汝说《法镜经》，于佛不坏净，乃至圣戒成就，是名《法镜经》。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八五三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    如上广说，差别者：有异比丘、异比丘尼、异优婆塞、异优婆夷命终，亦如上说。

（八五四）

    如是我闻。一时佛住那梨迦聚落繁耆迦精舍。
    尔时那梨迦聚落，多人命终。时有众多比丘着衣持钵，入那梨迦聚落乞食，闻那梨迦聚落，罽迦舍优婆塞命终，尼迦吒、佉楞迦罗、迦多梨沙、婆阇露、优婆阇露、梨色吒、阿梨色吒、跋陀罗、须跋陀罗、耶舍耶输陀、耶舍郁多罗，悉皆命终。闻已，还精舍，举衣钵，洗足已，诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我等众多比丘，晨朝入那梨迦聚落乞食，闻罽迦舍优婆塞等命终。世尊，彼等命终，当生何处？”
    佛告诸比丘：“彼罽迦舍等已断五下分结，得阿那含，于天上般涅槃，不复还生此世。”
    诸比丘白佛：“世尊，复有过二百五十优婆塞命终，复有五百优婆塞于此那梨迦聚落命终，皆五下分结尽，得阿那含，于彼天上般涅槃，不复还生此世？复有过二百五十优婆塞命终，皆三结尽，贪、恚、痴薄，得斯陀含，当受一生，究竟苦边？此那梨迦聚落复有五百优婆塞，于此那梨迦聚落命终，三结尽，得须陀洹，不堕恶趣法，决定正向三菩提，七有天人往生，究竟苦边？”
    佛告诸比丘：“汝等随彼命终、彼命终而问者，徒劳耳，非是如来所乐答者。夫生者有死，何足为奇？如来出世及不出世，法性常住。彼如来自知成等正觉，显现演说，分别开示，所谓是事有故是事有，是事起故是事起，缘无明有行，乃至缘生有老病死、忧悲恼苦，如是苦阴集。无明灭则行灭，乃至生灭则老病死、忧悲恼苦灭，如是苦阴灭。今当为汝说《法镜经》，谛听善思，当为汝说。何等为《法镜经》？谓圣弟子于佛不坏净，于法、僧不坏净，圣戒成就。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八五五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有难提优婆塞来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，若圣弟子于此五根，一切时不成就者，为放逸，为不放逸？”
    佛告难提：“若于此五根，一切时不成就者，我说此等为凡夫数。若圣弟子不成就者，为放逸，非不放逸。难提，若圣弟子于佛不坏净成就，而不上求，不于空闲林中，若露地坐，昼夜禅思，精勤修习胜妙出离，饶益随喜；彼不随喜已，欢喜不生；欢喜不生已，身不猗息；身不猗息已，苦觉则生；苦觉生已，心不得定；心不得定者，是圣弟子名为放逸。于法、僧不坏净，圣戒成就，亦如是说。
    “如是难提，若圣弟子成就于佛不坏净，其心不起知足想，于空闲林中，树下露地，昼夜禅思，精勤方便，能起胜妙出离随喜；随喜已，生欢喜；生欢喜已，身猗息；身猗息已，觉受乐；觉受乐已，心则定。若圣弟子心定者，名不放逸。法、僧不坏净，圣戒成就，亦如是说。”
    佛说此经已，难提优婆塞闻佛所说，欢喜随喜，从座起，礼佛足而去。

（八五六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有释氏难提，来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，若圣弟子于四不坏净，一切时不成就者，是圣弟子为是放逸，为不放逸？”
    佛告释氏难提：“若于四不坏净，一切时不成就者，我说是等为外凡夫数。释氏难提，若圣弟子放逸、不放逸，今当说。”广说如上。
    佛说此经已，释氏难提闻佛所说，欢喜随喜，从座起，作礼而去。

（八五七）

    如是我闻。一时佛住舍卫国祇树给孤独园，前三月夏安居竟。
    有众多比丘集于食堂，为佛缝衣。如来不久作衣竟，当着衣持钵，出精舍，人间游行。
    时释氏难提闻众多比丘集于食堂，为佛缝衣，如来不久作衣竟，着衣持钵，人间游行。释氏难提闻已，来诣佛所，稽首礼足，退坐一面，白佛言：“世尊，我今四体支解，四方易韵，先所闻法，今悉迷忘。闻众多比丘集于食堂，为世尊缝衣，言如来不久作衣竟，着衣持钵，人间游行。是故我今心生大苦，何时当复得见世尊及诸知识比丘？”
    佛告释氏难提：“汝见佛、若不见佛，若见知识比丘、若不见，汝当随时修习五种欢喜之处。何等为五？汝当随时念如来事，如来、应、等正觉、明行足、善逝、世间解、无上士、调御丈夫、天人师、佛、世尊；法事；僧事；自持戒事；自行世事，随时忆念，我得己利，我于悭垢众生所，当多修习离悭垢住，修解脱施，舍施，常炽然施，乐于舍，平等惠施，常怀施心。如是释氏难提，此五支定，若住若行，若坐若卧，乃至妻子俱，常当系心此三昧念。”
    佛说此经已，释氏难提闻佛所说，欢喜随喜，作礼而去。

（八五八）

    如是我闻。一时佛住舍卫国祇树给孤独园，前三月夏安居。
    时有释氏难提，闻佛于舍卫国祇树给孤独园，前三月结夏安居。闻已，作是念：“我当往彼，并复于彼造作供养众事，供给如来及比丘僧。”即到彼。
    三月竟，时众多比丘集于食堂，为世尊缝衣，而作是言：“如来不久作衣竟，着衣持钵，人间游行。”
    时释氏难提闻众多比丘集于食堂，言：“如来不久作衣竟，着衣持钵，人间游行。”闻已，来诣佛所，稽首礼足，退住一面，白佛言：“世尊，我今四体支解，四方易韵，先所受法，今悉迷忘。我闻世尊人间游行，我何时当复更见世尊及诸知识比丘？”
    佛告释氏难提：“若见如来、若不见，若见知识比丘、若不见，汝当随时修于六念。何等为六？当念如来、法、僧事、自所持戒、自所行施，及念诸天。”
    佛说此经已，释氏难提闻佛所说，欢喜随喜，作礼而去。

（八五九）

    如是我闻。一时佛住舍卫国祇树给孤独园，前三月结夏安居。
    如前说，差别者：时有长者名梨师达多及富兰那兄弟二人，闻众多比丘集于食堂，为世尊缝衣，如上《难提修多罗》广说。
    佛说此经已，梨师达多长者及富兰那闻佛所说，欢喜随喜，从座起，作礼而去。

（八六○）

    如是我闻。一时佛住舍卫国祇树给孤独园，前三月结夏安居竟。众多比丘集于食堂，为世尊缝衣。
    时有长者梨师达多及富兰那兄弟二人，于鹿径泽中修治田业，闻众多比丘在于食堂，为世尊缝衣，言：“如来不久作衣竟，着衣持钵，人间游行。”闻已，语一士夫言：“汝今当往诣世尊所，瞻视世尊，若必去者，速来语我。”
    时彼士夫即受教敕，往到一处，见世尊出。即速来还，白梨师达多及富兰那：“世尊已来，及诸大众。”
    时梨师达多及富兰那往迎世尊。
    世尊遥见梨师达多及富兰那随路而来，即出路边，敷尼师坛，正身端坐。
    梨师达多及富兰那稽首佛足，退坐一面，白佛言：“世尊，我今四体支解，四方易韵，所忆念事，今悉迷忘。何时当复得见世尊及诸知识比丘？世尊今出至拘萨罗，从拘萨罗至伽尸，从伽尸至摩罗，从摩罗至摩竭陀，从摩竭陀至殃伽，从殃伽至修摩，从修摩至分陀罗，从分陀罗至迦陵伽。是故我今极生忧苦，何时当复得见世尊及诸知识比丘？”
    佛告梨师达多及富兰那：“汝见如来及不见如来，见诸知识比丘及不见，汝且随时修习六念。何等为六？汝当念如来事，广说乃至念天。然其长者，在家愦闹，在家染著，出家空闲。难可俗人处于非家，一向鲜洁，纯一满净，梵行清白。”
    长者白佛：“奇哉世尊！善说此法。在家愦闹，在家染著，出家空闲。难可俗人处于非家，一向鲜洁，纯一满净，梵行清白。我是波斯匿王大臣，波斯匿王欲入园观，令我乘于大象，载王第一宫女。一在我前，一在我后，我坐其中。象下坂时，前者抱我颈，后者攀我背。象上坂时，后者抱我项，前者攀我衿。彼诸婇女为娱乐王故，衣缯彩衣，着众妙香，璎珞庄严。我与同游，常护三事：一者御象，恐失正道；二自护心，恐生染著；三自护持，恐其颠坠。世尊，我于尔时，于王婇女，无一刹那不正思惟。”
    佛告长者：“善哉善哉！能善护心。”
    长者白佛：“我在家中所有财物，常与世尊及诸比丘、比丘尼、优婆塞、优婆夷等共受用，不计我所。”
    佛告长者：“善哉善哉！汝拘萨罗国钱财巨富，无有与汝等者，而能于财不计我所。”
    尔时世尊为彼长者种种说法，示教照喜，示教照喜已，从座而去。


杂阿含经卷第三十一

（八六一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“人间四百岁，是兜率陀天上一日一夜。如是三十日一月，十二月一岁，兜率陀天寿四千岁。愚痴无闻凡夫于彼命终，生地狱、畜生、饿鬼中。多闻圣弟子于彼命终，不生地狱、畜生、饿鬼中。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八六二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“人间八百岁，是化乐天上一日一夜。如是三十日一月，十二月一岁，化乐天寿八千岁。愚痴无闻凡夫于彼命终，生地狱、畜生、饿鬼中。多闻圣弟子于彼命终，不生地狱、畜生、饿鬼中。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八六三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“人间千六百岁，是他化自在天一日一夜。如是三十日一月，十二月一岁，他化自在天寿一万六千岁。愚痴无闻凡夫于彼命终，生地狱、畜生、饿鬼中。多闻圣弟子于彼命终，不生地狱、畜生、饿鬼中。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如佛说六经，如是异比丘问六经、佛问诸比丘六经，亦如是说。

（八六四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘若行、若形、若相，离欲恶不善法，有觉有观，离生喜乐，初禅具足住。彼不忆念如是行、如是形、如是相，然于彼色、受、想、行、识法，作如病、如痈、如刺、如杀、无常、苦、空、非我思惟，于彼法生厌、怖畏、防护。生厌、怖畏、防护已，以甘露门而自饶益，如是寂静，如是胜妙，所谓舍离、余爱尽、无欲、灭尽、涅槃。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八六五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“如是知、如是见已，欲有漏心解脱，有有漏心解脱，无明漏心解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八六六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“若不得解脱，以欲法、念法、乐法故，取中般涅槃。若不如是，或生般涅槃。若不如是，或有行般涅槃。若不如是，或无行般涅槃。若不如是，或上流般涅槃。若不如是，或复即以此欲法、念法、乐法功德，生大梵天中，或生梵辅天中，或生梵身天中。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八六七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘如是行、如是形、如是相，息有觉有观，内净一心，无觉无观，定生喜乐，第二禅具足住。若不如是行、如是形、如是相忆念，而于色、受、想、行、识法，思惟如病、如痈、如刺、如杀、无常、苦、空、非我，于此等法心生厌离、怖畏、防护。厌离、防护已，于甘露法界以自饶益，此则寂静，此则胜妙，所谓舍离一切有余、爱尽、无欲、灭尽、涅槃。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八六八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“彼如是知、如是见，欲有漏心解脱，有有漏心解脱，无明漏心解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。若不解脱，而以彼欲法、念法、乐法，取中般涅槃；若不尔者，取生般涅槃；若不尔者，取有行般涅槃；若不尔者，取无行般涅槃；若不尔者，取上流般涅槃；若不尔者，彼以欲法、念法、乐法，生自性光音天；若不尔者，生无量光天；若不尔者，生少光天。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八六九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘如是行、如是形、如是相，离贪喜舍住，正念正智，觉身乐，圣人能说能舍念乐住，第三禅具足住。若不尔者，以如是行、如是形、如是相，于色、受、想、行、识法，思惟如病、如痈、如刺、如杀，乃至上流；若不尔者，以彼法欲、法念、法乐，生遍净天；若不尔者，生无量净天；若不尔者，生少净天。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八七○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘如是行、如是形、如是相，离苦息乐，前忧喜已灭，不苦不乐，舍净念一心，第四禅具足住。若不如是忆念，而于色、受、想、行、识，思惟如病、如痈、如刺、如杀，乃至上流般涅槃；若不尔者，或生因性果实天；若不尔者，生福生天；若不尔者，生少福天。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如四禅，如是四无色定，亦如是说。

（八七一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有风云天作是念：‘我今欲以神力游戏。’如是念时，风云则起。”
    如风云天，如是焰电天、雷震天、雨天、晴天、寒天、热天，亦如是说。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    说如是，异比丘问佛、佛问诸比丘，亦如是说。

（八七二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊于夜暗中，天时小雨，电光焰照。佛告阿难：“汝可以伞盖覆灯持出。”
    尊者阿难即受教，以伞盖覆灯，随佛后行，至一处，世尊微笑。尊者阿难白佛言：“世尊不以无因缘而笑，不审世尊今日何因何缘而发微笑？”
    佛告阿难：“如是如是，如来不以无因缘而笑。汝今持伞盖覆灯，随我而行。我见梵天亦复如是持伞盖覆灯，随拘邻比丘后行。释提桓因亦复持伞盖覆灯，随摩诃迦叶后行。袟栗帝罗色吒罗天王亦持伞盖覆灯，随舍利弗后行。毗楼勒迦天王亦持伞盖覆灯，随大目揵连后行。毗楼匐叉天王亦持伞盖覆灯，随摩诃拘絺罗后行。毗沙门天王亦持伞盖覆灯，随摩诃劫宾那后行。”
    佛说此经已，尊者阿难闻佛所说，欢喜奉行。

（八七三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四种善好调伏众。何等为四？谓比丘调伏、比丘尼调伏、优婆塞调伏、优婆夷调伏，是名四众。”
    尔时世尊即说偈言：

“若才辩无畏，多闻通达法，
行法次法向，是则为善众。
比丘持净戒，比丘尼多闻，
优婆塞净信，优婆夷亦然，
是名为善众，如日光自照。
如则善好僧，是则僧中好，
是法令僧好，如日光自照。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如调伏，如是辩、柔和、无畏、多闻、通达法、说法、法次法向、随顺法行，亦如是说。

（八七四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有三种子。何等为三？有随生子、有胜生子、有下生子。
    “何等为随生子？谓子父母不杀、不盗、不淫、不妄语、不饮酒，子亦随学不杀、不盗、不淫、不妄语、不饮酒，是名随生子。
    “何等为胜生子？若子父母不受不杀、不盗、不淫、不妄语、不饮酒戒，子则能受不杀、不盗、不淫、不妄语、不饮酒戒，是名胜生子。
    “云何下生子？若子父母受不杀、不盗、不淫、不妄语、不饮酒戒，子不能受不杀、不盗、不淫、不妄语、不饮酒戒，是名下生子。”
    尔时世尊即说偈言：

“生随及生上，智父之所欲；
生下非所须，以不绍继故。
为人法之子，当作优婆塞，
于佛法僧宝，勤修清净心，
云除月光显，光荣眷属众。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如五戒，如是信、戒、施、闻、慧经，亦如是说。

（八七五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四正断。何等为四？一者断断，二者律仪断，三者随护断，四者修断。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八七六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四正断。何等为四？一者断断，二者律仪断，三者随护断，四者修断。”
    尔时世尊即说偈言：

“断断及律仪，随护与修习，
如此四正断，诸佛之所说。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八七七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四正断。何等为四？一者断断，二者律仪断，三者随护断，四者修断。
    “云何为断断？谓比丘已起恶不善法断，生欲方便，精勤心摄受，是为断断。
    “云何律仪断？未起恶不善法不起，生欲方便，精勤摄受，是名律仪断。
    “云何随护断？未起善法令起，生欲方便，精勤摄受，是名随护断。
    “云何修断？已起善法增益修习，生欲方便，精勤摄受，是为修断。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八七八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四正断。何等为四？一者断断，二者律仪断，三者随护断，四者修断。
    “云何为断断？谓比丘已起恶不善法断，生欲方便，精勤心摄受，是为断断。
    “云何律仪断？未起恶不善法不起，生欲方便，精勤摄受，是名律仪断。
    “云何随护断？未起善法令起，生欲方便，精勤摄受，是名随护断。
    “云何修断？已起善法增益修习，生欲方便，精勤摄受，是名修断。”
    尔时世尊即说偈言：

“断断及律仪，随护与修习，
如此四正断，诸佛之所说。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八七九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四正断。何等为四？一者断断，二者律仪断，三者随护断，四者修断。
    “云何断断？若比丘已起恶不善法断，生欲方便，精勤摄受；未起恶不善法不起，生欲方便，精勤摄受；未生善法令起、生欲方便，精勤摄受；已生善法增益修习，生欲方便，精勤摄受，是名断断。
    “云何律仪断？若比丘善护眼根，隐密、调伏、进向；如是耳、鼻、舌、身、意根善护、隐密、调伏、进向，是名律仪断。
    “云何随护断？若比丘于彼彼真实三昧相，善守护持，所谓青瘀相、胀相、脓相、坏相、食不净相，修习守护，不令退没，是名随护断。
    “云何修断？若比丘修四念处等，是名修断。”
    尔时世尊即说偈言：

“断断律仪断，随护修习断，
此四种正断，正觉之所说，
比丘勤方便，得尽于诸漏。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如四念处，如是四正断、四如意足、五根、五力、七觉支、八道支、四道、四法句、止观修习，亦如是说。

（八八○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“譬如有人作世间建立，彼一切皆依于地。如是比丘修习禅法，一切皆依不放逸为根本，不放逸集、不放逸生、不放逸转。比丘不放逸者，能修四禅。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八八一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“如是比丘能断贪欲、瞋恚、愚痴。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如断贪欲、瞋恚、愚痴，如是调伏贪欲、瞋恚、愚痴，贪欲究竟、瞋恚、愚痴究竟，出要、远离、涅槃，亦如是说。

（八八二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“譬如百草药木，皆依于地而得生长。如是种种善法，皆依不放逸为本，如上说，乃至涅槃。
    “譬如黑沉水香，是众香之上。如是种种善法，不放逸最为其上。
    “譬如坚固之香，赤栴檀为第一。如是一切善法，一切皆依不放逸为根本，如是乃至涅槃。
    “譬如水陆诸花，优钵罗花为第一。如是一切善法，皆不放逸为根本，乃至涅槃。
    “譬如陆地生花，摩利沙花为第一。如是一切善法，不放逸为其根本，乃至涅槃。
    “譬如比丘，一切畜生迹中，象迹为上。如是一切诸善法，不放逸最为根本，如上说，乃至涅槃。
    “譬如一切畜生，狮子为第一，所谓畜生主。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如一切屋舍堂阁，以栋为第一。如是一切善法，不放逸为其根本。
    “譬如一切阎浮果，唯得阎浮名者，果最为第一。如是一切善法，不放逸为其根本。
    “譬如一切俱毗陀罗树，萨婆耶旨罗俱毗陀罗树为第一。如是一切善法，不放逸为根本，如上说，乃至涅槃。
    “譬如诸山，以须弥山王为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如一切金，以阎浮檀金为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如一切衣中，伽尸细氎为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如一切色中，以白色为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如众鸟，以金翅鸟为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如诸王，转轮圣王为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如一切天王，四大天王为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如一切三十三天，以帝释为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如焰摩天中，以宿焰摩天王为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如兜率陀天，以兜率陀天王为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如化乐天，以善化乐天王为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如他化自在天，以善他化自在天子为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如梵天，大梵王为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如阎浮提一切众流，皆顺趣大海，其大海者最为第一，以容受故。如是一切善法，皆顺不放逸，如上说，乃至涅槃。
    “譬如一切雨滴，皆归大海。如是一切善法，皆顺趣不放逸海，如上说，乃至涅槃。
    “譬如一切萨罗，阿耨大萨罗为第一。如是一切善法，不放逸为第一，如上说，乃至涅槃。
    “譬如阎浮提一切河，四大河为第一，谓恒河、新头、博叉、司陀。如是一切善法，不放逸为第一，如上说，乃至涅槃。
    “譬如众星光明，月为第一。如是一切善法，不放逸为第一，如上说，乃至涅槃。
    “譬如诸大身众生，罗睺罗阿修罗最为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如诸受五欲者，顶生王为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如欲界诸神力，天魔波旬为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如一切众生，无足、两足、四足、多足、色、无色、想、无想、非想非无想，如来为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如所有诸法，有为、无为，离贪欲为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如一切诸法众，如来众为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。
    “譬如一切所有诸界苦行，梵行圣界为第一。如是一切善法，不放逸为其根本，如上说，乃至涅槃。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八八三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四种禅：有禅三昧善，非正受善；有禅正受善，非三昧善；有禅三昧善，亦正受善；有禅非三昧善，非正受善。
    “复次四种禅：有禅住三昧善，非住正受善；有禅住正受善，非住三昧善；有禅住三昧善，亦住正受善；有禅非住三昧善，亦非住正受善。
    “复次四种禅：有禅三昧起善，非正受起善；有禅正受起善，非三昧起善；有禅三昧起善，亦正受起善；有禅非三昧起善，亦非正受起善。
    “复次四种禅：有禅三昧时善，非正受时善；有禅正受时善，非三昧时善；有禅三昧时善，亦正受时善；有禅非三昧时善，亦非正受时善。
    “复次四种禅：有禅三昧处善，非正受处善；有禅正受处善，非三昧处善；有禅三昧处善，亦正受处善；有禅非三昧处善，亦非正受处善。
    “复次四种禅：有禅三昧迎善，非正受迎善；有禅正受迎善，非三昧迎善；有禅三昧迎善，亦正受迎善；有禅非三昧迎善，亦非正受迎善。
    “复次四种禅：有禅三昧念善，非正受念善；有禅正受念善，非三昧念善；有禅三昧念善，亦正受念善；有禅非三昧念善，亦非正受念善。
    “复次四种禅：有禅三昧念不念善，非正受念不念善；有禅正受念不念善，非三昧念不念善；有禅三昧念不念善，亦正受念不念善；有禅非三昧念不念善，亦非正受念不念善。
    “复次四种禅：有禅三昧来善，非正受来善；有禅正受来善，非三昧来善；有禅三昧来善，亦正受来善；有禅非三昧来善，亦非正受来善。
    “复次四种禅：有禅三昧恶善，非正受恶善；有禅正受恶善，非三昧恶善；有禅三昧恶善，亦正受恶善；有禅非三昧恶善，亦非正受恶善。
    “复次四种禅：有禅三昧方便善，非正受方便善；有禅正受方便善，非三昧方便善；有禅三昧方便善，亦正受方便善；有禅非三昧方便善，亦非正受方便善。
    “复次四种禅：有禅三昧止善，非正受止善；有禅正受止善，非三昧止善；有禅三昧止善，亦正受止善；有禅非三昧止善，亦非正受止善。
    “复次四种禅：有禅三昧举善，非正受举善；有禅正受举善，非三昧举善；有禅三昧举善，亦正受举善；有禅非三昧举善，亦非正受举善。
    “复次四种禅：有禅三昧舍善，非正受舍善；有禅正受舍善，非三昧舍善；有禅三昧舍善，亦正受舍善；有禅非三昧舍善，亦非正受舍善。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八八四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有无学三明。何等为三？无学宿命智证通、无学生死智证通、无学漏尽智证通。”
    尔时世尊即说偈言：

“观察知宿命，见天恶趣生，
生死诸漏尽，是则牟尼明。
其心得解脱，一切诸贪爱，
三处悉通达，故说为三明。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八八五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有无学三明。何等为三？谓无学宿命智证通、无学生死智证通、无学漏尽智证通。
    “云何无学宿命智证通？谓圣弟子知种种宿命事，从一生至百千万亿生，乃至劫数成坏，我及众生宿命所更，如是名、如是生、如是性、如是食、如是受苦乐、如是长寿、如是久住、如是受分齐，我及众生于此处死、余处生，于余处死、此处生，有如是行、如是因、如是信受，种种宿命事，皆悉了知，是名宿命智证明。
    “云何生死智证明？谓圣弟子天眼净过于人眼，见诸众生死时、生时，善色、恶色，上色、下色、向于恶趣，随业受生如实知：如此众生身恶行成就、口恶行成就、意恶行成就，毁谤圣人，邪见受邪法因缘故，身坏命终，生恶趣泥犁中；此众生身善行、口善行、意善行，不谤毁圣人，正见成就，身坏命终，生于善趣天人中，是名生死智证明。
    “云何漏尽智证明？谓圣弟子此苦如实知，此苦集、此苦灭、此苦灭道迹如实知。彼如是知、如是见，欲有漏心解脱，有有漏心解脱，无明漏心解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。是名漏尽智证明。”
    尔时世尊即说偈言：

“观察知宿命，见天恶趣生，
生死诸漏尽，是则牟尼明。
知心得解脱，一切诸贪爱，
三处悉通达，故说为三明。”

    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（八八六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异婆罗门来诣佛所，与世尊面相慰劳，慰劳已，退坐一面，而作是说：“此则婆罗门三明，此则婆罗门三明。”
    尔时世尊告婆罗门言：“云何名为婆罗门三明？”
    婆罗门白佛言：“瞿昙，婆罗门父母具相，无诸瑕秽；父母七世相承，无诸讥论；世世相承，常为师长，辩才具足，诵诸经典、物类名字、万物差品、字类分合、历世本末，此五种记，悉皆通达，容色端正。是名瞿昙，婆罗门三明。”
    佛告婆罗门：“我不以名字言说为三明也。贤圣法门说真要实三明，谓贤圣知见、贤圣法律真实三明。”
    婆罗门白佛：“云何瞿昙，贤圣知见、贤圣法律所说三明？”
    佛告婆罗门：“有三种无学三明。何等为三？谓无学宿命智证明、无学生死智证明、无学漏尽智证明。”如上经广说。
    尔时世尊即说偈言：

“一切法无常，持戒寂静禅，
知一切宿命，已生天恶趣，
得断生漏尽，是为牟尼通。
悉知心解脱，一切贪恚痴，
我说是三明，非言语所说。

    “婆罗门，是为圣法律所说三明。”
    婆罗门白佛：“瞿昙，是真三明。”
    尔时婆罗门闻佛所说，欢喜随喜，从座起而去。

（八八七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异婆罗门来诣佛所，与世尊面相慰劳，慰劳已，退坐一面，白佛：“瞿昙，我名信。”
    佛告婆罗门：“所谓信者，信增上，戒、施、闻、舍、慧，是则为信，非名字是信也。”
    时婆罗门闻佛所说，欢喜随喜，从座起而去。

（八八八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异婆罗门来诣佛所，面相慰劳，慰劳已，退坐一面，白佛言：“瞿昙，我名增益。”
    佛告婆罗门：“所谓增益者，信增益，戒、闻、舍、慧增益，是为增益，非名字为增益也。”
    时婆罗门闻佛所说，欢喜随喜，从座起而去。

（八八九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异婆罗门来诣佛所，问讯安否，问讯已，退坐一面，白佛言：“世尊，我名等起。”
    佛告婆罗门：“夫等起者，谓起于信，起戒、闻、舍、慧，是为等起，非名字为等起也。”
    尔时婆罗门闻佛所说，欢喜随喜，从座起而去。

（八九○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当为汝说无为法，及无为道迹，谛听善思。云何无为法？谓贪欲永尽，瞋恚、愚痴永尽，一切烦恼永尽，是无为法。云何为无为道迹？谓八圣道分，正见、正智、正语、正业、正命、正方便、正念、正定，是名无为道迹。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如无为，如是难见、不动、不屈、不死、无漏、覆荫、洲渚、济渡、依止、拥护、不流转、离炽焰、离烧燃、流通、清凉、微妙、安隐、无病、无所有、涅槃，亦如是说。

（八九一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“譬如湖池，广长五十由旬，深亦如是。若有士夫，以一毛端，滴彼湖水。云何比丘，彼湖水为多？为士夫毛端一滴水多？”
    比丘白佛：“世尊，士夫毛端鲜少耳，湖水无量，千万亿倍，不得为比。”
    佛告比丘：“具足见真谛、正见具足世尊弟子，见真谛果，正无间等。彼于尔时，已断已知，断其根本，如截多罗树头，更不复生。所断诸苦，甚多无量，如大湖水；所余之苦，如毛端滴水。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如毛端滴水，如是草筹之端滴水亦如是。如湖池水，如是萨罗多吒伽、恒水、耶扶那、萨罗由、伊罗跋提、摩醯、大海，亦如是说。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八九二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有内六入处。云何为六？谓眼内入处，耳、鼻、舌、身、意内入处。于此六法观察忍，名为信行，超升离生，离凡夫地，未得须陀洹果，乃至未命终，要得须陀洹果。
    “若此诸法增上观察忍，名为法行，超升离生，离凡夫地，未得须陀洹果，乃至未命终，要得须陀洹果。
    “若此诸法如实正智观察，三结已尽、已知，谓身见、戒取、疑。是名须陀洹，决定不堕恶趣，定趣三菩提，七有天人往生，究竟苦边。
    “此等诸法正智观察，不起诸漏，离欲解脱，名阿罗汉，诸漏已尽，所作已作，离诸重担，逮得己利，尽诸有结，正智心善解脱。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如内六入处，如是外六入处、六识身、六触身、六受身、六想身、六思身、六爱身、六界身、五阴，亦如上说。

（八九三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有五种种子生，何等为五？谓根种子、茎种子、节种子、坏种子、种种子。此诸种子，不断、不破、不腐、不伤、不穿坚，新得地界，不得水界，彼诸种子不得生长增广；得水界，不得地界，彼诸种子不得生长增广；要得地界、水界，彼诸种子得生长增广。如是业、烦恼、有爱、见、慢、无明而生行。若有业而无烦恼、爱、见、无明者，行则灭。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如行，如是识、名色、六入处、触、受、爱、取、有、生、老死，亦如是说。

（八九四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于我世间，于世间及世间集，不如实知者，我终不得于诸天、魔、梵、沙门、婆罗门，及诸世间，为解脱、为出、为离，离颠倒想，亦不名阿耨多罗三藐三菩提。以我于世间及世间集如实知故，是故我于诸天、世人、魔、梵、沙门、婆罗门，及余众生，为得解脱、为出、为离，心离颠倒具足住，得成阿耨多罗三藐三菩提。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

    如是世间、世间集、世间灭，世间集、世间出，世间集、世间灭、世间味、世间患、世间出，世间集、世间灭、世间出，世间集、世间灭道迹，世间集、世间灭、世间集道迹、世间灭道迹，世间集、世间灭、世间味、世间患、世间出，世间集、世间灭、世间集道迹、世间灭道迹、世间味、世间患、世间出。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（八九五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有三爱。何等为三？谓欲爱、色爱、无色爱。为断此三爱故，当求大师。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如求大师，如是次师、教师、广导师、度师、广度师、说师、广说师、随说师、阿阇梨、同伴、真知识之善友、哀愍、慈悲、欲义、欲安、欲乐、欲触、欲通、欲者、精进者、方便者、出者、坚固者、勇猛者、堪能者、摄者、常者、学者、不放逸者、修者、思惟者、忆念者、觉想者、思量者、梵行者、神力者、智者、识者、慧者、分别者、念处、正勤、根、力、觉、道、止观、念身、正思惟求，亦如是说。

（八九六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有三有漏。何等为三？谓欲有漏、有有漏、无明有漏。为断此三有漏故，当求大师。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如求大师，如是乃至求正思惟，亦如是说。

（八九七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时尊者罗睺罗来诣佛所，稽首礼足，退坐一面，白佛言：“世尊，云何知，云何见，我此识身及外境界一切相不忆念，于其中间尽诸有漏？”
    佛告罗睺罗：“有内六入处。何等为六？谓眼入处，耳、鼻、舌、身、意入处。此等诸法，正智观察，尽诸有漏，正智心善解脱，是名阿罗汉，尽诸有漏，所作已作，已舍重担，逮得己利，尽诸有结，正智心得解脱。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如内六入处，如是外六入处，乃至五阴，亦如是说。

（八九八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“若比丘于眼欲贪断，欲贪断者，是名眼已断已知，断其根本，如截多罗树头，于未来世成不生法。如眼，如是耳、鼻、舌、身、意，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如内六入处，如是外六入处，乃至五阴，亦如是说。

（八九九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“若比丘眼生、住、成就显现，苦生，病住，老死显现；如是乃至意，亦如是说。若眼灭、息、没，苦则灭，病则息，老死则没；乃至意，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如内六入处，如是外六入处，乃至五阴，亦如是说。

（九○○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“若比丘于眼味著者，则生上烦恼；生上烦恼者，于诸染污心不得离欲，彼障碍亦不得断。乃至意入处，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如内六入处，如是外六入处，乃至五阴，亦如是说。

（九○一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“譬如世间所作，皆依于地而得建立。如是一切善法，皆依内六入处而得建立。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如内六入处，如是外六入处，乃至五阴，亦如是说。

（九○二）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“若有众生，无足、二足、四足、多足、色、无色、想、无想、非想非非想，于一切，如来最第一。乃至圣戒，亦如是说。”

（九○三）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“若诸世间众生所作，彼一切皆依于地而得建立。如是一切法，有为、无为，离贪欲法最为第一。如是广说，乃至圣戒，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九○四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“若诸世间众生，彼一切皆依于地而得建立。如是一切诸众，如来声闻众最为第一。如是广说，乃至圣戒。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。


杂阿含经卷第三十二

（九○五）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者摩诃迦叶、尊者舍利弗，住耆阇崛山中。
    时有众多外道出家诣尊者舍利弗，与尊者面相问讯慰劳已，退坐一面，语尊者舍利弗言：“云何舍利弗，如来有后生死耶？”
    舍利弗言：“诸外道，世尊说言此是无记。”
    又问：“云何舍利弗，如来无后生死耶？”
    舍利弗答言：“诸外道，世尊说言此是无记。”
    又问：“舍利弗，如来有后生死、无后生死耶？”
    舍利弗答言：“世尊说言此是无记。”
    又问：“舍利弗，如来非有后生死、非无后生死耶？”
    舍利弗答言：“诸外道，世尊说言此是无记。”
    诸外道出家又问尊者舍利弗：“云何所问如来有后生死、无后生死、有后无后、非有后非无后，一切答言：‘世尊说言此是无记。’云何为上座，如愚如痴，不善不辩，如婴儿无自性智？”作此语已，从座起去。
    尔时尊者摩诃迦叶、尊者舍利弗相去不远，各坐树下，昼日禅思。尊者舍利弗知诸外道出家去已，诣尊者摩诃迦叶所，共相问讯慰劳已，退坐一面，以向与诸外道出家所论说事，具白尊者摩诃迦叶：“尊者摩诃迦叶，何因何缘，世尊不记说后有生死、后无生死、后有后无、非有非无生死耶？”
    尊者摩诃迦叶语舍利弗言：“若说如来后有生死者，是则为色。若说如来无后生死，是则为色。若说如来有后生死、无后生死，是则为色。若说如来非有后、非无后生死，是则为色。如来者，色已尽，心善解脱。言有后生死者，此则不然；无后生死、有后无后、非有后非无后生死，此亦不然。如来者，色已尽，心善解脱，甚深、广大、无量、无数、寂灭、涅槃。舍利弗，若说如来有后生死者，是则为受、为想、为行、为识、为动、为虑、为虚诳、为有为、为爱；乃至非有非无后有，亦如是说。如来者，爱已尽，心善解脱。是故说后有者不然，后无、后有无、后非有非无者不然。如来者，爱已尽，心善解脱，甚深、广大、无量、无数、寂灭、涅槃。舍利弗，如是因、如是缘故，有问世尊，如来若有、若无、若有无、若非有非无后生死，不可记说。”
    时二正士共论议已，各还本处。

（九○六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者摩诃迦叶，住舍卫国东园鹿子母讲堂，晡时从禅觉，往诣佛所，稽首礼足，退坐一面，白佛言：“世尊，何因何缘，世尊先为诸声闻少制戒时，多有比丘心乐习学。今多为声闻制戒，而诸比丘少乐习学？”
    佛言：“如是迦叶，命浊、烦恼浊、劫浊、众生浊、见浊众生善法退减故，大师为诸声闻多制禁戒，少乐习学。迦叶，譬如劫欲坏时，真宝未灭，有诸相似伪宝出于世间，伪宝出已，真宝则没。如是迦叶，如来正法欲灭之时，有相似像法生，相似像法出世间已，正法则灭。譬如大海中船，载多珍宝，则顿沉没。如来正法则不如是，渐渐消灭。如来正法不为地界所坏，不为水、火、风界所坏。乃至恶众生出世，乐行诸恶、欲行诸恶、成就诸恶，非法言法、法言非法，非律言律、律言非律，以相似法句味炽然，如来正法于此则没。
    “迦叶，有五因缘，能令如来正法沉没。何等为五？若比丘于大师所，不敬不重，不下意供养，于大师所，不敬不重，不下意供养已，然复依倚而住；若法、若学、若随顺教、若诸梵行大师所称叹者，不敬不重，不下意供养，而依止住。是名迦叶，五因缘故，如来正法于此沉没。
    “迦叶，有五因缘，令如来法律不没、不忘、不退。何等为五？若比丘于大师所，恭敬尊重，下意供养，依止而住；若法、若学、若随顺教、若诸梵行大师所称叹者，恭敬尊重，下意供养，依止而住。迦叶，是名五因缘，如来法律不没、不忘、不退。是故迦叶，当如是学，于大师所，当修恭敬尊重，下意供养，依止而住；若法、若学、若随顺教、若诸梵行大师所赞叹者，恭敬尊重，下意供养，依止而住。”
    佛说是经已，尊者摩诃迦叶欢喜随喜，作礼而去。

（九○七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有遮罗周罗那罗聚落主，来诣佛所，面前问讯慰劳，问讯慰劳已，退坐一面，白佛言：“瞿昙，我闻古昔歌舞戏笑耆年宿士作如是说：‘若伎儿于大众中歌舞戏笑，作种种伎，令彼大众欢乐喜笑，以是业缘，身坏命终，生欢喜天。’于此瞿昙法中，所说云何？”
    佛告聚落主：“且止，莫问此义。”
    如是再三，犹请不已。
    佛告聚落主：“我今问汝，随汝意答。古昔此聚落众生，不离贪欲，贪欲缚所缚；不离瞋恚，瞋恚缚所缚；不离愚痴，愚痴缚所缚。彼诸伎儿于大众座中，种种歌舞伎乐嬉戏，令彼众人欢乐喜笑。聚落主，当其彼人欢乐喜笑者，岂不增长贪、恚、痴缚耶？”
    聚落主白佛言：“如是，瞿昙。”
    “聚落主，譬如有人以绳反缚，有人长夜以恶心欲令此人非义饶益，不安不乐，数数以水浇所缚绳，此人被缚岂不转增急耶？”
    聚落主言：“如是，瞿昙。”
    佛言：“聚落主，古昔众生亦复如是，不离贪欲、瞋恚、痴缚，缘彼嬉戏欢乐喜笑，更增其缚。”
    聚落主言：“实尔，瞿昙。彼诸伎儿令其众生欢乐喜笑，转增贪欲、瞋恚、痴缚。以是因缘，身坏命终，生善趣者，无有是处。”
    佛告聚落主：“若言古昔伎儿能令大众欢乐喜笑，以是业缘，生欢喜天者，是则邪见。若邪见者，应生二趣：若地狱趣，若畜生趣。”
    说是语时，遮罗周罗那罗聚落主悲泣流泪。
    尔时世尊告聚落主：“是故我先三问不答，言：‘聚落主，且止，莫问此义。’”
    聚落主白佛言：“瞿昙，我不以瞿昙说故而悲泣也。我自念，昔来云何为彼愚痴、不辩、不善诸伎儿辈所见欺诳，言大众中作诸伎乐，乃至生欢喜天？我今定思，云何伎儿歌舞嬉戏，生欢喜天？瞿昙，我从今日，舍彼伎儿恶不善业，归佛、归法、归比丘僧。”
    佛言：“善哉聚落主！此真实要。”
    尔时遮罗周罗那罗聚落主闻佛所说，欢喜随喜，顶礼佛足，欢喜而去。

（九○八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时战斗活聚落主来诣佛所，恭敬问讯，问讯已，退坐一面，白佛言：“瞿昙，我闻古昔战斗活耆年宿士作是言：‘若战斗活，身被重铠，手执利器，将士先锋，堪能方便摧伏怨敌，缘此业报，生箭降伏天。’于瞿昙法中，其义云何？”
    佛告战斗活：“且止，莫问此义。”
    如是再三问，亦再三止之，犹问不已。
    佛告聚落主：“我今问汝，随汝意答。聚落主，于意云何？若战斗活，身被甲胄，为战士先锋，堪能方便摧伏怨敌，此人岂不先起伤害之心，欲摄缚、枷锁、斫刺、杀害于彼耶？”
    聚落主白佛：“如是，世尊。”
    佛告聚落主：“为战斗活有三种恶邪，若身、若口、若意。以此三种恶邪因缘，身坏命终，得生善趣箭降伏天者，无有是处。”
    佛告聚落主：“若古昔战斗活耆年宿士，作如是见、作如是说，若诸战斗活，身被甲胄，手执利器，命敌先登，堪能方便摧伏怨敌，以是因缘，生箭降伏天者，是则邪见。邪见之人，应生二处：若地狱趣，若畜生趣。”
    说是语时，彼聚落主悲泣流泪。
    佛告聚落主：“以是义故，我先再三语汝：‘且止，不为汝说。’”
    聚落主白佛言：“我不以瞿昙语故悲泣，我念古昔诸斗战活耆年宿士，愚痴、不善、不辩，长夜欺诳，作如是言：‘若战斗活，身被甲胄，手执利器，命敌先登，乃至得生箭降伏天。’是故悲泣。我今定思，诸战斗活，恶业因缘，身坏命终，生箭降伏天者，无有是处。瞿昙，我从今日舍诸恶业，归佛、归法、归比丘僧。”
    佛告聚落主：“此真实要。”
    时战斗活聚落主闻佛所说，欢喜随喜，即从座起，作礼而去。

（九○九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有调马聚落主来诣佛所，恭敬问讯，退坐一面。
    尔时世尊告调马聚落主：“调伏马者，有几种法？”
    聚落主答言：“瞿昙，有三种法。何等为三？谓一者柔软，二者刚强，三者柔软刚强。”
    佛告聚落主：“若以三种法，马犹不调，当如之何？”
    聚落主言：“便当杀之。”
    聚落主白佛言：“瞿昙，无上调御丈夫者，当以几种法调御丈夫？”
    佛告聚落主：“我亦以三法调御丈夫。何等为三？一者柔软，二者刚强，三者柔软刚强。”
    聚落主白佛：“瞿昙，若三种调御丈夫，犹不调者，当如之何？”
    佛言：“聚落主，三事调伏，犹不调者，便当杀之。所以者何？莫令我法有所屈辱。”
    调马聚落主白佛言：“瞿昙法中，杀生者不净，瞿昙法中不应杀，而今说言不调伏者，亦当杀之？”
    佛告聚落主：“如汝所言，如来法中，杀生者不净，如来不应有杀。聚落主，然我以三种法调御丈夫，彼不调者，不复与语、不复教授、不复教诫。聚落主，若如来调御丈夫，不复与语、不复教授、不复教诫，岂非杀耶？”
    调马聚落主白佛言：“瞿昙，若调御丈夫，不复与语、不复教授、不复教诫，真为杀也。是故我从今日舍诸恶业，归佛、归法、归比丘僧。”
    佛告聚落主：“此真实要。”
    佛说此经已，调马聚落主闻佛所说，欢喜随喜，即从座起，作礼而去。

（九一○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有凶恶聚落主来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，不修何等法故，于他生瞋恚，生瞋恚故，口说恶言，他为其作恶性名字？”
    佛告聚落主：“不修正见故，于他生瞋，生瞋恚已，口说恶言，他为其作恶性名字。不修正志、正语、正业、正命、正方便、正念、正定故，于他生瞋，生瞋恚故，口说恶言，他为其作恶性名字。”
    复问：“世尊，修习何法，于他不瞋，不瞋恚故，口说善言，他为其作贤善名字？”
    佛告聚落主：“修正见故，于他不瞋，不瞋恚故，口说善言，他为其作贤善名字。修习正志、正语、正业、正命、正方便、正念、正定故，于他不瞋，不瞋恚故，口说善言，他为其作贤善名字。”
    凶恶聚落主白佛言：“奇哉世尊！善说此言。我不修正见故，于他生瞋，生瞋恚已，口说恶言，他为我作恶性名字。我不修正志、正语、正业、正命、正方便、正念、正定故，于他生瞋，生瞋恚故，口说恶言，他为我作恶性名字。是故我今当舍瞋恚、刚强、粗涩。”
    佛告聚落主：“此真实要。”
    佛说此经已，凶恶聚落主欢喜随喜，作礼而去。

（九一一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有摩尼珠髻聚落主来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，先日国王集诸大臣，共论议言：‘云何沙门释子比丘，自为受畜金银宝物，为净耶，为不净耶？’其中有言：‘沙门释子应受畜金银宝物。’又复有言：‘不应自为受畜金银宝物。’世尊，彼言沙门释子应自为受畜金银宝物者，为从佛闻，为自出意说？作是语者，为随顺法，为不随顺？为真实说，为虚妄说？如是说者，得不堕于呵责处耶？”
    佛告聚落主：“此则妄说，非真实说，非是法说，非随顺说，堕呵责处。所以者何？沙门释子自为受畜金银宝物者，不清净故。若自为己受畜金银宝物者，非沙门法，非释种子法。”
    聚落主白佛言：“奇哉世尊！沙门释子受畜金银宝物者，非沙门法，非释种子法，此真实说。世尊作是说者，增长胜妙。我亦作是说，沙门释子不应自为受畜金银宝物。”
    佛告聚落主：“若沙门释子自为受畜金银珍宝清净者，五欲功德悉应清净。”
    摩尼珠髻聚落主闻佛所说，欢喜作礼而去。
    尔时世尊知摩尼珠髻聚落主去已，告尊者阿难：“若诸比丘依止迦兰陀竹园住者，悉呼令集于食堂。”
    时尊者阿难即受佛教，周遍宣令，依止迦兰陀竹园比丘集于食堂。比丘集已，往白世尊：“诸比丘已集食堂，唯世尊知时。”
    尔时世尊往诣食堂，大众前坐，坐已告诸比丘：“今日有摩尼珠髻聚落主来诣我所，作如是言：‘先日国王集诸大臣，作如是论议：沙门释子自为受畜金银宝物，为清净不？其中有言清净者，有言不清净者。今问世尊，言清净者，为从佛闻，为自妄说？’如上广说。彼摩尼珠髻聚落主闻我所说，欢喜随喜，作礼而去。
    “诸比丘，国王、大臣共集论议，彼摩尼珠髻聚落主于大众前狮子吼说：‘沙门释种子不应自为受畜金银宝物。’诸比丘，汝等从今日，须木索木，须草索草，须车索车，须作人索作人，慎勿为己受取金银、种种宝物。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九一二）

    如是我闻。一时佛住瞻婆国揭伽池侧。
    时有王顶聚落主来诣佛所，稽首佛足，退坐一面。
    尔时世尊告王顶聚落主：“今者众生依于二边。何等为二？一者乐著卑下田舍常人凡夫五欲；二者自苦方便，不正、非义饶益。聚落主，有三种乐受欲乐卑下田舍常人凡夫；有三种自苦方便，不正、非义饶益。
    “聚落主，何等为三种卑下田舍常人凡夫乐受欲乐？有受欲者，非法滥取，不以安乐自供，不供养父母，给足兄弟、妻子、奴婢、眷属、朋友、知识，亦不随时供养沙门、婆罗门，仰求胜处安乐果报，未来生天，是名世间第一受欲。复次聚落主，受欲乐者，以法、非法滥取财物，以乐自供，供养父母，给足兄弟、妻子、奴婢、眷属、朋友、知识，而不随时供养沙门、婆罗门，仰求胜处安乐果报，未来生天，是名第二受欲乐者。复次聚落主，有受欲乐者，以法求财，不以滥取，以乐自供，供养父母，给足兄弟、妻子、奴婢、眷属、知识，随时供养沙门、婆罗门，仰求胜处安乐果报，未来生天，是名第三受欲乐者。
    “聚落主，我不一向说受欲平等。我说受欲者其人卑下，我说受欲者是其中人，我说受欲者是其胜人。何等为卑下受欲者？谓非法滥取，乃至不仰求胜处安乐果报，未来生天，是名我说卑下者受欲。何等为中人受欲？谓受欲者以法、非法而求财物，乃至不求未来生天，是名我说第二中人受欲。何等为我说胜人受欲？谓彼以法求财，乃至未来生天，是名我说第三胜人受欲。
    “何等为三种自苦方便，是苦非法、不正、非义饶益？有一自苦枯槁活，初始犯戒、污戒，彼修种种苦行，精勤方便住处住，彼不能现法得离炽然、过人法、胜妙知见、安乐住。聚落主，是名第一自苦方便枯槁活。复次自苦方便枯槁活，始不犯戒、污戒，而修种种苦行，亦不由此现法得离炽然、过人法、胜妙知见、安乐住，是名第二自苦方便枯槁活。复次自苦方便枯槁活，不初始犯戒、污戒，然修种种苦行方便，亦不能现法离炽然、得过人法、胜妙知见、安乐住，是名第三自苦方便枯槁活。
    “聚落主，我不说一切自苦方便枯槁活悉等。我说有自苦方便是卑劣人，有说自苦方便是中人，有说自苦方便是胜人。何等自苦方便卑劣人？若彼自苦方便，初始犯戒、污戒，乃至不得胜妙知见、安乐住，是名我说自苦方便卑劣人。何等为自苦方便中人？若彼自苦方便，不初始犯戒、污戒，乃至不得胜妙知见、安乐住，是名我说自苦方便中间人。何等为自苦方便胜人？若彼自苦方便枯槁活，不初始犯戒、污戒，乃至不得胜妙知见、安乐住，是名我说自苦方便胜人。聚落主，是名三种自苦方便，是苦非法、不正、非义饶益。
    “聚落主，有道有迹，不向三种受欲随顺方便，卑下田舍常人凡夫；不向三种自苦方便，是苦非法、不正、非义饶益。聚落主，何等为道，何等为迹，不向三种受欲、三种自苦方便？聚落主，为欲贪障碍故，或欲自害，或欲害他，或欲俱害，现法、后世得斯罪报，心法忧苦；瞋恚、痴所障，或欲自害，或欲害他，或欲俱害，现法、后世得斯罪报，心法忧苦。若离贪障，不欲方便自害、害他、自他俱害，不现法、后世受斯罪报，彼心心法常受喜乐；如是离瞋恚、愚痴障碍，不欲自害、不欲害他、自他俱害，不现法、后世受斯罪报，彼心心法常受安乐，于现法中，远离炽然，不待时节，亲近涅槃，即此身现缘自觉知。聚落主，如此现法永离炽然，不待时节，亲近涅槃，即此现身缘自觉知者，为八圣道，正见乃至正定。”
    当其世尊说是法时，王顶聚落主远尘离垢，得法眼净。时王顶聚落主见法、得法、知法、深入于法，度疑，不由于他，于正法律得无所畏。即从座起，整衣服，合掌白佛：“我今已度，世尊！归佛、归法、归比丘僧，从今尽寿为优婆塞。”
    时闻佛所说，欢喜随喜，作礼而去。

（九一三）

    如是我闻。一时佛在力士人间游行，到郁鞞罗住处鹦鹉阎浮林。
    时有竭昙聚落主，闻沙门瞿昙在力士人间游行，至郁鞞罗聚落鹦鹉阎浮林，说现法苦集、苦没。“我当往诣彼沙门瞿昙，若我诣沙门瞿昙者，彼必为我说现法苦集、苦没。”即往彼郁鞞罗聚落，诣世尊所，稽首礼足，退坐一面，白佛言：“世尊，我闻世尊常为人说现法苦集、苦没。善哉世尊！为我说现法苦集、苦没。”
    佛告聚落主：“我若说过去法苦集、苦没者，知汝于彼为信为不信，为欲不欲，为念不念，为乐不乐？汝今苦不？我若说未来苦集、苦没者，知汝于彼为信不信，为欲不欲，为念不念，为乐不乐？汝今苦不？我今于此说现法苦集、苦没。聚落主，若众生所有苦生，彼一切皆以欲为本，欲生、欲集、欲起、欲因、欲缘而苦生。”
    聚落主白佛言：“世尊极略说法，不广分别，我所不解。善哉世尊！唯愿广说，令我等解。”
    佛告聚落主：“我今问汝，随汝意说。聚落主，于意云何？若众生于此郁鞞罗聚落住者，若缚、若打、若责、若杀，汝心当起忧悲恼苦不？”
    聚落主白佛言：“世尊，亦不一向。若诸众生于此郁鞞罗聚落住者，于我有欲、有贪、有爱、有念、相习近者，彼遭若缚、若打、若责、若杀，我则生忧悲恼苦。若彼众生所，无欲、贪、爱、念、相习近者，彼遭缚、打、责、杀，我何为横生忧悲恼苦？”
    佛告聚落主：“是故当知，众生种种苦生，彼一切皆以欲为本，欲生、欲集、欲起、欲因、欲缘，而生众苦。聚落主，于意云何？汝依父母不相见者，则生欲、贪、爱、念不？”
    聚落主言：“不也，世尊。”
    “聚落主，于意云何？若见、若闻彼依父母，当起欲、爱、念不？”
    聚落主言：“如是，世尊。”
    复问：“聚落主，于意云何？彼依父母，若无常变异者，当起忧悲恼苦不？”
    聚落主言：“如是，世尊。若依父母无常变异者，我或邻死，岂唯忧悲恼苦！”
    佛告聚落主：“是故当知，若诸众生所有苦生，一切皆以爱欲为本，欲生、欲集、欲起、欲因、欲缘而生苦。”
    聚落主言：“奇哉世尊！善说如此依父母譬。我有依父母，居在异处，我日日遣信问其安否。使未时还，我已忧苦，况复无常而无忧苦？”
    佛告聚落主：“是故我说，其诸众生所有忧苦，一切皆以欲为根本，欲生、欲集、欲起、欲因、欲缘，而生忧苦。”
    佛告聚落主：“若有四爱念无常变异者，则四忧苦生。若三、二、若一爱念无常变异者，则一忧苦生。聚落主，若都无爱念者，则无忧苦尘劳。”
    即说偈言：

“若无世间爱念者，则无忧苦尘劳患，
一切忧苦消灭尽，犹如莲花不著水。”

    当其世尊说是法时，竭昙聚落主远尘离垢，得法眼净。见法得法，深入于法，度诸狐疑，不由于他，不由他度，于正法律得无所畏。从座起，整衣服，合掌白佛：“已度，世尊！我已超越。我从今日归佛、归法、归比丘僧，尽其寿命，为优婆塞，唯忆持我！”
    佛说此经已，竭昙聚落主闻佛所说，欢喜随喜，作礼而去。

（九一四）

    如是我闻。一时佛在摩竭提国人间游行，与千二百五十比丘、千优婆塞、五百乞残食人，从城至城，从聚落至聚落，人间游行，至那罗聚落好衣庵罗园中。
    时有刀师氏聚落主是尼揵弟子，诣尼揵所，礼尼揵足，退坐一面。
    尔时尼揵语刀师氏聚落主：“汝能共沙门瞿昙作蒺藜论，令沙门瞿昙不得语，不得不语耶？”
    聚落主言：“阿梨，我立何等论为蒺藜论，令沙门瞿昙不得语，不得不语？”
    尼揵语聚落主言：“汝往诣沙门瞿昙所，作是问：‘瞿昙常愿欲令诸家福利具足增长，作如是愿，如是说不？’若答汝言不者，汝当问言：‘沙门瞿昙与凡愚夫有何等异？’若言有愿有说者，当复问言：‘沙门瞿昙，若有如是愿、如是说者，今云何于饥馑世，游行人间，将诸大众千二百五十比丘、千优婆塞、五百乞残食人，从城至城，从村至村，损费世间，如大雨雹雨已，乃是减损，非增益也。瞿昙所说，殊不相应，不类不似，前后相违。’如是聚落主，是名蒺藜论，令彼沙门瞿昙不得语，不得不语。”
    尔时刀师氏聚落主受尼揵劝教已，诣佛所恭敬问讯，恭敬问讯已，退坐一面，白佛：“瞿昙，常欲愿令诸家福利增长不？”
    佛告聚落主：“如来长夜欲令诸家福利增长，亦常作是说。”
    聚落主言：“若如是者，云何瞿昙于饥馑世，人间乞食，将诸大众，乃至不似不类，前后相违？”
    佛告聚落主：“我忆九十一劫以来，不见一人施一比丘，有尽有减。聚落主，汝观今日，有人家大富，多钱财、多眷属、多仆从，当知其家长夜好施，真实寂止，故致斯福利。聚落主，有八因缘，令人损减，福利不增。何等为八？王所逼、贼所劫、火所焚、水所漂、藏自消减、抵债不还、怨憎残破、恶子费用。有是八种，为钱财难聚。聚落主，我说无常为第九句。如是聚落主，汝舍九因九缘，而言沙门瞿昙破坏他家。不舍恶言，不舍恶见，如铁枪投水，身坏命终，生地狱中。”
    时刀师氏聚落主心生恐怖，身毛皆竖，白佛言：“世尊，我今悔过！如愚如痴，不善不辩，于瞿昙所不实欺诳，虚说妄语。”
    闻佛所说，欢喜随喜，从座起去。

（九一五）

    如是我闻。一时佛住那罗聚落好衣庵罗园中。
    时有刀师氏聚落主，先是尼揵弟子，诣尼揵所，礼尼揵足，退坐一面。
    尔时尼揵语聚落主：“汝能共沙门瞿昙作蒺藜论，令沙门瞿昙不得语，不得不语？”
    聚落主白尼揵：“阿梨，何等为蒺藜论，令沙门瞿昙不得语，不得不语耶？”
    尼揵语聚落主：“汝往沙门瞿昙所，作如是言：‘瞿昙不常欲安慰一切众生，赞叹安慰一切众生耶？’若言不者，应语言：‘瞿昙与凡愚夫有何等异？’若言常欲安慰一切众生，赞叹安慰一切众生者，复应问言：‘若欲安慰一切众生者，以何等故，或为一种人说法，或不为一种人说法？’作如是问者，是名蒺藜论，令彼沙门瞿昙不得语，不得不语。”
    尔时聚落主受尼揵劝进已，往诣佛所，恭敬问讯已，退坐一面，白佛言：“瞿昙，岂不欲常安慰一切众生，叹说安慰一切众生？”
    佛告聚落主：“如来长夜慈愍安慰一切众生，亦常叹说安慰一切众生。”
    聚落主白佛言：“若然者，如来何故为一种人说法，又复不为一种人说法？”
    佛告聚落主：“我今问汝，随意答我。聚落主，譬如有三种田，有一种田沃壤肥泽，第二田中，第三田瘠薄。云何聚落主，彼田主先于何田耕治下种？”
    聚落主言：“瞿昙，于最沃壤肥泽者，先耕下种。”
    “聚落主，复于何田次耕下种？”
    聚落主言：“瞿昙，当于中田，次耕下种。”
    佛告聚落主：“复于何田次耕下种？”
    聚落主言：“当于最下瘠薄之田，次耕下种。”
    佛告聚落主：“何故如是？”
    聚落主言：“不欲废田，存种而已。”
    佛告聚落主：“我亦如是，如彼沃壤肥泽田者，我诸比丘、比丘尼，亦复如是。我常为彼演说正法，初、中、后善，善义善味，纯一满净，梵行清白，开示显现。彼闻法已，依于我舍、我洲、我覆、我荫、我趣，常以净眼观我而住，作如是念：‘佛所说法，我悉受持，令我长夜以义饶益，安隐乐住。’
    “聚落主，如彼中田者，我弟子优婆塞、优婆夷，亦复如是。我亦为彼演说正法，初、中、后善，善义善味，纯一满净，梵行清白，开发显示。彼闻法已，依于我舍、我洲、我覆、我荫、我趣，常以净眼观察我住，作如是念：‘世尊说法，我悉受持，令我长夜以义饶益，安隐乐住。’
    “聚落主，如彼田家最下田者，如是我为诸外道异学、尼揵子辈，亦为说法，初、中、后善，善义善味，纯一满净，梵行清白，开示显现。然于彼等少闻法者，亦为其说；多闻法者，亦为其说。然其彼众于我善说法中，得一句法，知其义者，亦复长夜以义饶益，安隐乐住。”
    时聚落主白佛：“甚奇世尊！善说如是三种田譬。”
    佛告聚落主：“汝听我更说譬类。譬如士夫有三水器：第一器不穿不坏，亦不津漏；第二器不穿不坏，而有津漏；第三器者，穿坏津漏。云何聚落主，彼士夫三种器中，常持净水着何等器中？”
    聚落主言：“瞿昙，当以不穿、不坏、不津漏者，先以盛水。”
    佛告聚落主：“次复应以何器盛水？”
    聚落主言：“瞿昙，当持彼器不穿、不坏而津漏者，次以盛水。”
    佛告聚落主：“彼器满已，复以何器为后盛水？”
    聚落主言：“以穿坏津漏之器最后盛水。所以者何？须臾之间，供小用故。”
    佛告聚落主：“如彼士夫不穿、不坏、不津漏器，诸弟子比丘、比丘尼，亦复如是。我常为彼演说正法，乃至长夜以义饶益，安隐乐住。如第二器不穿、不坏而津漏者，我诸弟子优婆塞、优婆夷，亦复如是。我常为彼演说正法，乃至长夜以义饶益，安隐乐住。如第三器穿坏津漏者，外道异学、诸尼揵辈，亦复如是。我亦为彼演说正法，初、中、后善，善义善味，纯一满净，梵行清白，开示显现。多亦为说，少亦为说，彼若于我说一句法知其义者，亦得长夜安隐乐住。”
    时刀师氏聚落主闻佛所说，心大恐怖，身毛皆竖，前礼佛足：“悔过世尊！如愚如痴，不善不辩，于世尊所不谛真实，虚伪妄说。”
    闻佛所说，欢喜随喜，礼足而去。

（九一六）

    如是我闻。一时佛住那罗聚落好衣庵罗园中。
    时有刀师氏聚落主尼揵弟子，来诣佛所，稽首礼足，退坐一面。
    尔时世尊告聚落主：“欲何所论？尼揵若提子为何所说？”
    聚落主言：“彼尼揵若提子说：‘杀生者，一切皆堕泥犁中，以多行故，则将至彼。如是盗、邪淫、妄语，皆堕泥犁中，以多行故，则将至彼。’”
    佛告聚落主：“若如尼揵若提子说杀生者堕泥犁中，以多行故，而往生彼者，则无有众生堕泥犁中。聚落主，于意云何？何等众生于一切时有心杀生，复于何时有心不杀生？乃至何时有心妄语，何时有心不妄语？”
    聚落主白佛言：“世尊，人于昼夜，少时有心杀生，乃至少时有心妄语，而多时不有心杀生，乃至妄语。”
    佛告聚落主：“若如是者，岂非无有人堕于泥犁中耶？如尼揵所说：‘有人杀生者，一切堕泥犁中，多习行者将往生彼，乃至妄语亦复如是。’聚落主，彼大师出兴于世，觉想筹量，入觉想地，住于凡夫地，自辩所说，随意筹量，为诸弟子作如是说法，言：‘杀生者，一切皆堕泥犁中，多习行将往生彼，乃至妄语亦复如是。’彼诸弟子若信其说，言：‘我大师知其所知，见其所见，能为弟子作如是说：若杀生者，一切皆堕泥犁中，多习行故，将往生彼。我本有心杀生、偷盗、邪淫、妄语，当堕泥犁中。得如是见，乃至不舍此见，不厌彼业，不觉彼悔，于未来世，不舍杀生，乃至不舍妄语。’彼意解脱不满足，慧解脱亦不满足；意解脱不满足，慧解脱不满足故，则为谤圣邪见；邪见因缘故，身坏命终，生恶趣泥犁中。
    “如是聚落主，有因有缘众生烦恼，有因有缘众生业烦恼。聚落主，如来、应、等正觉、明行足、善逝、世间解、无上士、调御丈夫、天人师、佛、世尊出兴于世，常为众生呵责杀生，赞叹不杀；呵责偷盗、邪淫、妄语，赞叹不盗、不淫、不妄语。常以此法，化诸声闻，令念乐信重，言：‘我大师知其所知，见其所见，呵责杀生，赞叹不杀，乃至呵责妄语，赞叹不妄语。我从昔来，以愚痴无慧，有心杀生。我缘是故，今自悔责。’虽不能令彼业不为，且因此悔责故，于未来世，得离杀生，乃至得离盗、淫、妄语。亦得满足正意解脱，满足慧解脱；意解脱、慧解脱满足已，得不谤贤圣，正见成就；正见因缘故，得生善趣天上。如是聚落主，有因有缘众生业烦恼清净。聚落主，彼多闻圣弟子作如是学：随时昼夜观察所起，少有心杀生，多有心不杀生。若于有心杀生，当自悔责，不是不类。若不有心杀生，无怨无憎，心生随喜；随喜已，欢喜生；欢喜已，心猗息；心猗息已，心受乐；受乐已，则心定；心定已，圣弟子心与慈俱，无怨无嫉，无有瞋恚，广大无量，满于一方正受住；二方、三方，乃至四方、四维、上下，一切世间，心与慈俱，无怨无嫉，无有瞋恚，广大无量，善修习，充满诸方，具足正受住。”
    尔时世尊以爪甲抄少土，语刀师氏聚落主言：“云何聚落主，我爪甲土多，大地为多？”
    聚落主白佛言：“世尊，爪甲土少少耳，大地土无量无数。”
    佛告聚落主：“如甲上之土甚少，大地之土其数无量。如是心与慈俱，修习多修习，诸有量业者如甲上土，不能将去，不能令住。如是偷盗对以悲心，邪淫对以喜心，妄语对以舍心，不得为比。”
    说是语时，刀师氏聚落主远尘离垢，得法眼净。聚落主见法、得法、觉法、知法、深入于法，离诸狐疑，不由于他，不随于他，于正法律得无所畏。从座起，整衣服，右膝着地，合掌白佛：“我已度，世尊！已越，世尊！我今归佛、归法、归比丘僧，尽其寿命，为优婆塞。世尊，譬如士夫欲求灯明，取其马尾以为灯炷，欲吹令燃，终不得明，徒自疲劳，灯竟不燃。我亦如是，欲求明智，于诸愚痴尼揵子所，愚痴习近，愚痴和合，愚痴奉事，徒自劳苦，不得明智。是故我今重归依佛、归法、归僧。从今以去，于彼尼揵愚痴不善不辩者所，少信、少敬、少爱、少念，于今远离。是故我今第三归佛、归法、归僧，乃至尽寿，为优婆塞，自净其心。”
    时刀师氏聚落主闻佛所说，欢喜随喜，作礼而去。

（九一七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“世间有三种调马。何等为三种？有马捷疾具足，色不具足，形体不具足；有马色具足，捷疾具足，形体不具足；有马捷疾具足，色具足，形体具足。如是有三种调士夫相。何等为三？有士夫捷疾具足，色不具足，形体不具足；有士夫捷疾具足，色具足，形体不具足；有士夫捷疾具足、色具足、形体具足。
    “比丘，何等为不调士夫捷疾具足，色不具足，形体不具足？有士夫于此苦如实知，此苦集、此苦灭、此苦灭道迹如实知。如是观者三结断，身见、戒取、疑。此三结断，得须陀洹，不堕恶趣法，决定正趣三菩提，七有天人往生，究竟苦边，是名捷疾具足。何等为非色具足？若有问阿毗昙、律，不能以具足句味，次第随顺，具足解说，是名色不具足。云何形体不具足？非大德名闻感致衣被、饮食、床卧、汤药、众具。是名士夫捷疾具足，色不具足，形体不具足。
    “何等为捷疾具足，色具足，形体不具足？谓士夫此苦如实知，此苦集、此苦灭、此苦灭道迹如实知，乃至究竟苦边，是捷疾具足。何等为色具足？若问阿毗昙、律，乃至能为解说，是名色具足。何等为形体不具足？非大德名闻，不能感致衣被、饮食、卧具、汤药。是名士夫捷疾具足，色具足，形体不具足。
    “何等为士夫捷疾具足，色具足，形体具足？谓士夫此苦如实知，此苦集、此苦灭、此苦灭道迹如实知，乃至究竟苦边，是名捷疾具足。何等为色具足？若问阿毗昙、律，乃至能解说，是名色具足。何等为形体具足？大德名闻，乃至卧具、汤药，是名形体具足。是名士夫捷疾具足，色具足，形体具足。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九一八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“世间有三种良马。何等为三？有马捷疾具足，非色具足，非形体具足；有马捷疾具足，色具足，非形体具足；有马捷疾具足，色具足，形体具足。于正法律，有三种善男子。何等为三？有善男子捷疾具足，非色具足，非形体具足；有善男子捷疾具足，色具足，非形体具足；有善男子捷疾具足，色具足，形体具足。
    “何等为善男子捷疾具足，非色具足，非形体具足？谓善男子苦圣谛如实知，苦集圣谛如实知，苦灭圣谛如实知，苦灭道迹圣谛如实知。作如是知、如是见已，断五下分结，谓身见、戒取、疑、贪欲、瞋恚。断此五下分结已，得生般涅槃阿那含，不复还生此世，是名善男子捷疾具足。云何色不具足？若问阿毗昙、律，不能解了句味，次第随顺，决定解说，是名色不具足。云何形体不具足？谓非名闻大德，能感财利供养、衣被、饮食、随病汤药。是名善男子捷疾具足，非色具足，非形体具足。
    “何等为捷疾具足，色具足，非形体具足？谓善男子此苦圣谛如实知，乃至得生般涅槃阿那含，不复还生此世，是名捷疾具足。云何色具足？若有问阿毗昙、律，能以次第句味，随顺决定而为解说，是名色具足。云何非形体具足？谓非名闻大德，能感财利供养、衣被、饮食、随病汤药。是名善男子捷疾具足，色具足，非形体具足。
    “何等为善男子捷疾具足，色具足，形体具足？谓善男子此苦圣谛如实知，乃至得阿那含，生般涅槃，不复还生此世，是名捷疾具足。何等为色具足？若有问阿毗昙、毗尼，乃至而为解说，是名色具足。何等为形体具足？谓名闻大德，能感财利，乃至汤药、众具，是名形体具足。是名善男子捷疾具足，色具足，形体具足。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。


杂阿含经卷第三十三

（九一九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“世间有三种良马。何等为三？谓有马捷疾具足，非色具足，非形体具足；有马捷疾具足，色具足，非形体具足；有马捷疾具足，色具足，形体具足。如是于此法律有三种善男子。何等为三？有善男子捷疾具足，非色具足，非形体具足；有善男子捷疾具足，色具足，非形体具足；有善男子捷疾具足，色具足，形体具足。
    “何等为善男子捷疾具足，非色具足，非形体具足？谓善男子此苦圣谛如实知，此苦集圣谛如实知，此苦灭圣谛如实知，此苦灭道迹圣谛如实知。如是知、如是见已，欲有漏心解脱，有有漏心解脱，无明有漏心解脱：我生已尽，梵行已立，所作已作，自知不受后有，是名捷疾具足。云何非色具足？若有问阿毗昙、律，乃至不能为决定解说，是名色不具足。何等非形体具足？谓非名闻大德，乃至不感汤药、众具，是名形体不具足。是名善男子捷疾具足，非色具足，非形体具足。
    “何等为善男子捷疾具足，色具足，非形体具足？谓善男子此苦圣谛如实知，乃至不受后有，是名捷疾具足。云何色具足？谓若有问阿毗昙、毗尼，乃至能为决定解说，是名色具足。何等为非形体具足？谓非名闻大德，乃至不能感汤药、众具。是名善男子捷疾具足，色具足，非形体具足。
    “何等为善男子捷疾具足，色具足，形体具足？谓善男子此苦圣谛如实知，乃至不受后有，是名捷疾具足。何等为色具足？谓善男子若有问阿毗昙、毗尼，乃至能为决定解说，是名色具足。何等为形体具足？谓善男子名闻大德，乃至能感汤药、众具，是名形体具足。是名善男子捷疾具足，色具足，形体具足。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九二○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“世有三种良马，王所服乘。何等为三？谓良马色具足，力具足，捷疾具足。如是于正法律，有三种善男子，世所奉事、供养、恭敬，为无上福田。何等为三？谓善男子色具足，力具足，捷疾具足。何等为色具足？谓善男子住于净戒、波罗提木叉律仪，威仪、行处具足，见微细罪，能生怖畏，受持学戒，是名色具足。何等力具足？已生恶不善法令断，生欲精勤方便，摄受增长；未生恶不善法不起，生欲精勤方便，摄受增长；未生善法令起，生欲精勤方便，摄受增长；已生善法住不忘失，生欲精勤方便，摄受增长，是名力具足。何等为捷疾具足？谓此苦圣谛如实知，乃至得阿罗汉，不受后有，是名捷疾具足。是名善男子色具足，力具足，捷疾具足。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九二一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“世有良马，四种具足，当知是良马，王所服乘。何等为四？所谓贤善、捷疾、堪能、调柔。如是善男子四德成就，世所宗重，承事供养，为无上福田。何等为四？谓善男子成就无学戒身、无学定身、无学慧身、无学解脱身。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九二二）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“世有四种良马：有良马驾以平乘，顾其鞭影驰驶，善能观察御者形势，迟速左右，随御者心，是名比丘，世间良马第一之德。复次比丘，世间良马不能顾影而自惊察，然以鞭杖触其毛尾，则能惊速，察御者心，迟速左右，是名世间第二良马。复次比丘，若世间良马不能顾影，及触皮毛，能随人心，而以鞭杖小侵皮肉，则能惊察，随御者心，迟速左右，是名比丘第三良马。复次比丘，世间良马不能顾其鞭影及触皮毛、小侵肤肉，乃以铁锥刺身，彻肤伤骨，然后方惊，牵车着路，随御者心，迟速左右，是名世间第四良马。
    “如是于正法律，有四种善男子。何等为四？谓善男子闻他聚落，有男子、女人疾病困苦乃至死，闻已能生恐怖，依正思惟，如彼良马顾影则调，是名第一善男子，于正法律能自调伏。复次善男子不能闻他聚落若男、若女老病死苦，能生怖畏，依正思惟；见他聚落若男、若女老病死苦，则生怖畏，依正思惟，如彼良马触其毛尾，能速调伏，随御者心，是名第二善男子，于正法律能自调伏。复次善男子不能闻、见他聚落中男子、女人老病死苦，生怖畏心，依正思惟；然见聚落城邑有善知识及所亲近老病死苦，则生怖畏，依正思惟，如彼良马，触其肤肉，然后调伏，随御者心，是名第三善男子，于圣法律而自调伏。复次善男子不能闻、见他聚落中男子、女人及所亲近老病死苦，生怖畏心，依正思惟；然于自身老病死苦能生厌怖，依正思惟，如彼良马侵肌彻骨，然后乃调，随御者心，是名第四善男子，于圣法律能自调伏。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九二三）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时有调马师名曰只尸，来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我观世间甚为轻贱，犹如群羊。世尊，唯我堪能调马。狂逸恶马，我作方便，须臾令彼态病悉现，随其态病，方便调伏。”
    佛告调马师聚落主：“汝以几种方便调伏于马？”
    马师白佛：“有三种法，调伏恶马。何等为三？一者柔软，二者粗涩，三者柔软粗涩。”
    佛告聚落主：“汝以三种方便调马，犹不调者，当如之何？”
    马师白佛：“遂不调者，便当杀之。所以者何？莫令辱我。”
    调马师白佛：“世尊是无上调御丈夫，为以几种方便调御丈夫？”
    佛告聚落主：“我亦以三种方便调御丈夫。何等为三？一者一向柔软，二者一向粗涩，三者柔软粗涩。”
    佛告聚落主：“所谓一向柔软者，如所说：此是身善行，此是身善行报；此是口、意善行，此是口、意善行报；是名天、是名人、是名善趣化生、是名涅槃，是为柔软。粗涩者，如所说：是身恶行，是身恶行报；是口、意恶行，是口、意恶行报；是名地狱、是名畜生、是名饿鬼、是名恶趣、是名堕恶趣，是名如来粗涩教也。彼柔软、粗涩俱者，谓如来有时说身善行，有时说身善行报，有时说口、意善行，有时说口、意善行报；有时说身恶行，有时说身恶行报，有时说口、意恶行，有时说口、意恶行报；如是名天、如是名人、如是名善趣、如是名涅槃；如是名地狱、如是名畜生、饿鬼、如是名恶趣、如是堕恶趣，是名如来柔软粗涩教。”
    调马师白佛：“世尊，若以三种方便调伏众生，有不调者，当如之何？”
    佛告聚落主：“亦当杀之，所以者何？莫令辱我。”
    调马师白佛言：“若杀生者，于世尊法为不清净，世尊法中亦不杀生，而今言杀，其义云何？”
    佛告聚落主：“如是如是，如来法中杀生不清净，如来法中亦不杀生。然如来法中以三种教授，不调伏者，不复与语，不教不诫。聚落主，于意云何？如来法中不复与语，不教不诫，岂非死耶？”
    调马师白佛：“实尔，世尊。不复与语，永不教诫，真为死也。世尊，以是之故，我从今日，离诸恶不善业。”
    佛告聚落主：“善哉所说！”
    时调马师聚落主只尸闻佛所说，欢喜随喜，礼足而去。

（九二四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“世间马有八态。何等为八？谓恶马临驾车时，后脚蹋人，前脚跪地，奋头啮人，是名世间马第一态。复次恶马就驾车时，低头振轭，是名世间恶马第二之态。复次世间恶马就驾车时，下道而去，或复偏厉车，令其翻覆，是名第三之态。复次世间恶马就驾车时，仰头却行，是名世间恶马第四之态。复次世间恶马就驾车时，小得鞭杖，或断缰折勒，纵横驰走，是名第五之态。复次世间恶马就驾车时，举前两足，而作人立，是名第六之态。复次世间恶马就驾之时，加之鞭杖，安住不动，是名第七之态。复次世间恶马就驾之时，丛聚四脚，伏地不起，是名第八之态。
    “如是世间恶丈夫于正法律有八种过。何等为八？若比丘，诸梵行者以见、闻、疑罪而发举时，彼则瞋恚，反呵责彼言：‘汝愚痴、不辩、不善，他立举汝，汝云何举我？’如彼恶马后脚双蹋，前脚跪地，断鞅折轭，是名丈夫于正法律第一之过。复次比丘，诸梵行者以见、闻、疑举，反出他罪，犹如恶马，怒项折轭，是名丈夫于正法律第二之过。复次比丘，诸梵行者以见、闻、疑举，不以正答，横说余事，瞋恚、骄慢、隐覆、嫌恨、不忍，无所由作，如彼恶马不由正路，令车翻覆，是名丈夫于正法律第三之过。复次比丘，诸梵行者以见、闻、疑举，令其忆念，而作是言：‘我不忆念！’抵突不伏，如彼恶马却缩转退，是名丈夫于正法律第四之过。复次比丘，诸梵行者以见、闻、疑举时，轻蔑不数其人，亦不数僧，摄持衣钵，随意而去，如彼恶马加以鞭杖，纵横驰走，是名丈夫于正法律第五之过。复次比丘，诸梵行者以见、闻、疑举时，自处高床，与诸上座共诤曲直，如彼恶马双脚人立，是名丈夫于正法律第六之过。复次比丘，诸梵行者以见、闻、疑举时，默然不应，以恼大众，如彼恶马加其鞭杖，兀然不动，是名丈夫于正法律第七之过。复次比丘，诸梵行者以见、闻、疑举时，则便舍戒，自生退没，到于寺门，而作是言：‘汝默然，快喜安住，我自舍戒退没。’如彼恶马丛聚四足，伏地不动，是名丈夫于正法律第八之过。是名比丘于正法律有八种丈夫过恶。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九二五）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“世间良马有八种德成就者，随人所欲，取道多少。何等为八？生于良马乡，是名良马第一之德。复次体性温良，不惊恐人，是名良马第二之德。复次良马不择饮食，是名良马第三之德。复次良马厌恶不净，择地而卧，是名良马第四之德。复次良马诸情态速为调马者现，马师调习，速舍其态，是名良马第五之德。复次良马安于驾乘，不顾余马，随其轻重，能尽其力，是名良马第六之德。复次良马常随正路，不随非道，是名良马第七之德。复次良马若病若老，勉力驾乘，不厌不倦，是名良马第八之德。
    “如是丈夫于正法律八德成就，当知是贤士夫。何等为八？谓贤士夫住于正戒、波罗提木叉律仪，威仪、行处具足，见微细罪，能生怖畏，受持学戒，是名丈夫于正法律第一之德。复次丈夫性自贤善，善调善住，不恼不怖诸梵行者，是名丈夫第二之德。复次丈夫次行乞食，随其所得，若粗若细，其心平等，不嫌不著，是名丈夫第三之德。复次丈夫心生厌离，于身恶业，口、意恶业，恶不善法，及诸烦恼，重受诸有，炽然苦报，于未来世生老病死、忧悲恼苦，增其厌离，是名丈夫第四之德。复次丈夫若有沙门过，谄曲不实，速告大师及善知识，大师说法，则时除断，是名丈夫第五之德。复次丈夫学心具足，作如是念：‘设使余人学以不学，我悉当学。’是名丈夫第六之德。复次丈夫行八正道，不行非道，是名丈夫第七之德。复次丈夫乃至尽寿，精勤方便，不厌不倦，是名丈夫第八之德。如是丈夫八德成就，随其行地，能速升进。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九二六）

    如是我闻。一时佛住那梨聚落深谷精舍。
    尔时世尊告诜陀迦旃延：“当修真实禅，莫习强梁禅。如强梁马，系槽枥上，彼马不念我所应作、所不应作，但念谷草。如是丈夫于贪欲缠多修习故，彼以贪欲心思惟，于出离道不如实知，心常驰骋，随贪欲缠而求正受；瞋恚、睡眠、掉悔、疑多修习故，于出离道不如实知，以疑盖心思惟，以求正受。诜陀，若真生马，系槽枥上，不念水草，但作是念驾乘之事。如是丈夫不念贪欲缠住，于出离如实知，不以贪欲缠而求正受；亦不瞋恚、睡眠、掉悔、疑缠多住，于出离瞋恚、睡眠、掉悔、疑缠如实知，不以疑缠而求正受。如是诜陀，比丘如是禅者，不依地修禅，不依水、火、风、空、识、无所有、非想非非想而修禅，不依此世，不依他世，非日、月，非见、闻、觉、识，非得、非求、非随觉、非随观而修禅。诜陀，比丘如是修禅者，诸天主伊湿波罗、波阇波提，恭敬合掌，稽首作礼，而说偈言：

“南无大士夫！南无士之上！
以我不能知，依何而禅定。”

    尔时有尊者跋迦利，住于佛后，执扇扇佛。时跋迦利白佛言：“世尊，若比丘云何入禅，而不依地、水、火、风，乃至觉、观，而修禅定？云何比丘禅，诸天主伊湿波罗、波阇波提，合掌恭敬，稽首作礼，而说偈言：

“南无大士夫！南无士之上！
以我不能知，依何而禅定。”

    佛告跋迦利：“比丘于地想，能伏地想；于水、火、风想、无量空入处想、识入处想、无所有入处、非想非非想入处想，此世、他世、日、月、见、闻、觉、识、若得、若求、若觉、若观，悉伏彼想。跋迦利，比丘如是禅者，不依地、水、火、风，乃至不依觉、观而修禅。跋迦利，比丘如是禅者，诸天主伊湿波罗、波阇波提，恭敬合掌，稽首作礼，而说偈言：

“南无大士夫！南无士之上！
以我不能知，何所依而禅。”

    佛说此经时，诜陀迦旃延比丘远尘离垢，得法眼净。跋迦利比丘不起诸漏，心得解脱。
    佛说此经已，跋迦利比丘闻佛所说，欢喜奉行。

（九二七）

    如是我闻。一时佛住迦毗罗卫国尼拘律园中。
    时有释种名摩诃男，来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，云何名为优婆塞？”
    佛告摩诃男：“在家清白，修习净住，男相成就，作是说言：‘我今尽寿归佛、归法、归比丘僧，为优婆塞，证知我！’是名优婆塞。”
    摩诃男白佛言：“世尊，云何名为优婆塞信具足？”
    佛告摩诃男：“优婆塞者，于如来所正信为本，坚固难动，诸沙门、婆罗门，诸天、魔、梵，及余世间所不能坏。摩诃男，是名优婆塞信具足。”
    摩诃男白佛言：“世尊，云何名优婆塞戒具足？”
    佛告摩诃男：“优婆塞离杀生、不与取、邪淫、妄语、饮酒，不乐作。摩诃男，是名优婆塞戒具足。”
    摩诃男白佛言：“世尊，云何名优婆塞闻具足？”
    佛告摩诃男：“优婆塞闻具足者，闻则能持，闻则积集。若佛所说，初、中、后善，善义善味，纯一满净，梵行清白，悉能受持。摩诃男，是名优婆塞闻具足。”
    摩诃男白佛言：“世尊，云何名优婆塞舍具足？”
    佛告摩诃男：“优婆塞舍具足者，为悭垢所缠者，心离悭垢，住于非家，修解脱施、勤施、常施，乐舍财物，平等布施。摩诃男，是名优婆塞舍具足。”
    摩诃男白佛言：“世尊，云何名优婆塞智慧具足？”
    佛告摩诃男：“优婆塞智慧具足者，谓此苦如实知，此苦集如实知，此苦灭如实知，此苦灭道迹如实知。摩诃男，是名优婆塞智慧具足。”
    尔时释氏摩诃男闻佛所说，欢喜随喜，从座起，作礼而去。

（九二八）

    如是我闻。一时佛住迦毗罗卫国尼拘律园中。
    尔时释氏摩诃男与五百优婆塞来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，云何名优婆塞？”
    佛告摩诃男：“优婆塞者，在家净住，乃至尽寿归依三宝，为优婆塞，证知我。”
    摩诃男白佛言：“世尊，云何名优婆塞须陀洹？”
    佛告摩诃男：“优婆塞须陀洹者，三结已断已知，谓身见、戒取、疑。摩诃男，是名优婆塞须陀洹。”
    摩诃男白佛言：“世尊，云何名优婆塞斯陀含？”
    佛告摩诃男：“谓优婆塞三结已断已知，贪、恚、痴薄。摩诃男，是名优婆塞斯陀含。”
    摩诃男白佛言：“世尊，云何名优婆塞阿那含？”
    佛告摩诃男：“优婆塞阿那含者，五下分结已断已知，谓身见、戒取、疑、贪欲、瞋恚。摩诃男，是名优婆塞阿那含。”
    时摩诃男释氏顾视五百优婆塞，而作是言：“奇哉！诸优婆塞，在家清白，乃得如是深妙功德！”
    时摩诃男优婆塞闻佛所说，欢喜随喜，从座起，作礼而去。

（九二九）

    如是我闻。一时佛住迦毗罗卫国尼拘律园中。
    尔时释氏摩诃男来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，云何名优婆塞？”
    佛告摩诃男：“优婆塞者，在家清白，乃至尽寿归依三宝，为优婆塞，证知我。”
    摩诃男白佛言：“世尊，云何为满足一切优婆塞事？”
    佛告摩诃男：“若优婆塞有信无戒，是则不具，当勤方便，具足净戒。具足信、戒，而不施者，是则不具，以不具故，精勤方便，修习布施，令具足满。信、戒、施满，不能随时往诣沙门，听受正法，是则不具；以不具故，精勤方便，随时往诣塔寺，见诸沙门，不一心听受正法，是不具足；信、戒、施、闻修习满足，闻已不持，是不具足；以不具足故，精勤方便，随时往诣沙门，专心听法，闻则能持，不能观察诸法深义，是不具足；不具足故，精勤方便，信、戒、施、闻、闻则能持、持已观察甚深妙义，而不随顺知法次法向，是则不具；以不具故，精勤方便，信、戒、施、闻、受持、观察、了达深义、随顺行法次法向。摩诃男，是名满足一切种优婆塞事。”
    摩诃男白佛：“世尊，云何名优婆塞能自安慰，不安慰他？”
    佛告摩诃男：“若优婆塞能自立信，不能令他立于正信；自持净戒，不能令他持戒具足；自行布施，不能以施建立于他；自诣塔寺见诸沙门，不能劝他令诣塔寺往见沙门；自专听法，不能劝人乐听正法；闻法自持，不能令他受持正法；自能观察甚深妙义，不能劝人令观深义；自知深法，能随顺行法次法向，不能劝人令随顺行法次法向。摩诃男，如是八法成就者，是名优婆塞能自安慰，不安慰他。”
    摩诃男白佛：“世尊，优婆塞成就几法，自安安他？”
    佛告摩诃男：“若优婆塞成就十六法者，是名优婆塞自安安他。何等为十六？摩诃男，若优婆塞具足正信，建立他人；自持净戒，亦以净戒建立他人；自行布施，教人行施；自诣塔寺见诸沙门，亦教人往见诸沙门；自专听法，亦教人听；自受持法，教人受持；自观察义，教人观察；自知深义，随顺修行法次法向，亦复教人解了深义，随顺修行法次法向。摩诃男，如是十六法成就者，是名优婆塞能自安慰，亦安慰他人。摩诃男，若优婆塞成就如是十六法者，彼诸大众悉诣其所，谓婆罗门众、刹利众、长者众、沙门众，于诸众中威德显曜。譬如日轮，初、中及后，光明显照。如是优婆塞十六法成就者，初、中及后，威德显照。如是摩诃男，若优婆塞十六法成就者，世间难得。”
    佛说此经已，释氏摩诃男闻佛所说，欢喜随喜，即从座起，作礼而去。

（九三○）

    如是我闻。一时佛住迦毗罗卫国尼拘律园中。
    尔时释氏摩诃男来诣佛所，稽首礼足，退坐一面，白佛言：“世尊，此迦毗罗卫国安隐丰乐，人民炽盛。我每出入时，众多翼从，狂象、狂人、狂乘，常与是俱。我自恐与此诸狂，俱生俱死，忘于念佛、念法、念比丘僧。我自思惟，命终之时，当生何处？”
    佛告摩诃男：“莫恐莫怖！命终之后不生恶趣，终亦无恶。譬如大树，顺下、顺注、顺输，若截根本，当堕何处？”
    摩诃男白佛：“随彼顺下、顺注、顺输。”
    佛告摩诃男：“汝亦如是，若命终时，不生恶趣，终亦无恶。所以者何？汝已长夜修习念佛、念法、念僧。若命终时，此身若火烧，若弃冢间，风飘日曝，久成尘末，而心意识久远长夜正信所熏，戒、施、闻、慧所熏，神识上升，向安乐处，未来生天。”
    时摩诃男闻佛所说，欢喜随喜，作礼而去。

（九三一）

    如是我闻。一时佛住迦毗罗卫国尼拘律园中。
    尔时释氏摩诃男来诣佛所，稽首礼足，退坐一面，白佛言：“世尊，若比丘在于学地，求所未得，上升进道，安隐涅槃。世尊，彼当云何修习多修习住，于此法律得诸漏尽，无漏心解脱、慧解脱，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有？”
    佛告摩诃男：“若比丘在于学地，求所未得，上升进道，安隐涅槃。彼于尔时当修六念，乃至进得涅槃。譬如饥人，身体羸瘦，得美味食，身体肥泽。如是比丘住在学地，求所未得，上升进道，安隐涅槃，修六随念，乃至疾得安隐涅槃。
    “何等六念？谓圣弟子念如来事：如来、应、等正觉、明行足、善逝、世间解、无上士、调御丈夫、天人师、佛、世尊。圣弟子如是念时，不起贪欲缠，不起瞋恚、愚痴心，其心正直，得如来义，得如来正法。于如来正法，于如来所，得随喜心；随喜心已，欢悦；欢悦已，身猗息；身猗息已，觉受乐；觉受乐已，其心定；心定已，彼圣弟子于凶险众生中，无诸挂碍，入法流水，乃至涅槃。
    “复次圣弟子念于法事：世尊法律，现法能离生死炽然，不待时节，通达现法，缘自觉知。圣弟子如是念法者，不起贪欲、瞋恚、愚痴，乃至念法所熏，升进涅槃。
    “复次圣弟子念于僧事：世尊弟子善向、正向、直向、诚向，行随顺法，有向须陀洹、得须陀洹、向斯陀含、得斯陀含、向阿那含、得阿那含、向阿罗汉、得阿罗汉。此是四双八辈贤圣，是名世尊弟子僧，净戒具足，三昧具足，智慧具足，解脱具足，解脱知见具足，所应奉迎，承事供养，为良福田。圣弟子如是念僧事时，不起贪欲、瞋恚、愚痴，乃至念僧所熏，升进涅槃。
    “复次圣弟子自念净戒：不坏戒，不缺戒，不污戒，不杂戒，不他取戒，善护戒，明者称誉戒，智者不厌戒。圣弟子如是念戒时，不起贪欲、瞋恚、愚痴，乃至念戒所熏，升进涅槃。
    “复次圣弟子自念施事：我得善利，于悭垢众生中而得离悭垢处，于非家行解脱施，常自手施，乐行舍法，具足等施。圣弟子如是念施时，不起贪欲、瞋恚、愚痴，乃至念施所熏，升进涅槃。
    “复次圣弟子念诸天事：有四大天王、三十三天、焰摩天、兜率陀天、化乐天、他化自在天。若有正信心者，于此命终，生彼诸天，我亦当行此正信；彼得净戒、施、闻、慧，于此命终，生彼诸天，我今亦当行此戒、施、闻、慧。圣弟子如是念天事者，不起贪欲、瞋恚、愚痴，其心正直，缘彼诸天。彼圣弟子如是直心者，得深法利，得深义利，得彼诸天饶益随喜；随喜已，生欣悦；欣悦已，身猗息；身猗息已，觉受乐；觉受乐已，得心定；心定已，彼圣弟子处凶险众生中，无诸挂碍，入法水流。念天所熏故，升进涅槃。
    “摩诃男，若比丘住于学地，欲求上升安乐涅槃，如是多修习，疾得涅槃者，于正法律速尽诸漏，无漏心解脱、慧解脱，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。”
    时释氏摩诃男闻佛所说，欢喜随喜，从座起，作礼而去。

（九三二）

    如是我闻。一时佛住迦毗罗卫国尼拘律园中。
    时有众多比丘集于食堂，为世尊缝衣。
    时释氏摩诃男，闻众多比丘集于食堂，为世尊缝衣。世尊不久三月安居讫，作衣竟，持衣钵，人间游行。闻已往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我四体不摄，迷于四方，闻法悉忘。以闻众多比丘集于食堂，为世尊缝衣。世尊不久安居讫，作衣竟，持衣钵，人间游行。是故我今思惟，何时当复得见世尊及诸知识比丘？”
    佛告摩诃男：“汝正使见世尊、不见世尊，见诸知识比丘及与不见，但当念于五法，精勤修习。摩诃男，当以正信为主，非不正信；戒具足、闻具足、施具足、慧具足为本，非不智慧。如是摩诃男，依此五法，修六念处。何等为六？此摩诃男，念如来当如是念：如来、应、等正觉，乃至佛、世尊。当念法、僧、戒、施、天事，乃至自行得智慧。如是摩诃男，圣弟子成就十一法者，则为学迹，终不腐败，堪任知见，堪任决定，住甘露门，近于甘露，不能一切疾得甘露涅槃。譬如伏鸡伏其卵，或五或十，随时消息，爱护将养，正复中间放逸，犹能以爪以口啄卵，得生其子。所以者何？以彼鸡母初随时消息，善爱护故。如是圣弟子成就十一法者，住于学迹，终不腐败，乃至不能一切疾得甘露涅槃。”
    佛说此经已，摩诃男释氏闻佛所说，欢喜随喜，作礼而去。

（九三三）

    如是我闻。一时佛住迦毗罗卫国尼拘律园中。
    时有众多比丘集于食堂，为世尊缝衣。
    时释氏摩诃男闻诸比丘集于食堂，为世尊缝衣。世尊不久安居讫，作衣竟，持衣钵，人间游行。闻已诣佛所，稽首礼足，退坐一面，白佛言：“世尊，我今四体不摄，迷于四方，先所闻法，今悉忘失。以闻众多比丘集于食堂，为世尊缝衣，乃至人间游行。我作是念：何时当复得见世尊及诸知识比丘？”
    佛告摩诃男：“汝见如来、不见如来，见诸比丘、不见诸比丘，且汝常当勤修六法。何等为六？正信为本，戒、施、闻、空、慧以为根本，非不智慧。是故摩诃男，依此六法已，于上增修六随念，念如来事，乃至念天。如是十二种念成就，彼圣弟子诸恶退减不增长，消灭不起，离尘垢不增尘垢，舍离不取，不取故不著，以不取著故缘自涅槃：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，释氏摩诃男闻佛所说，欢喜随喜，从座起，作礼而去。

（九三四）

    如是我闻。一时佛住迦毗罗卫国尼拘律园中。
    尔时释氏摩诃男来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，如我解佛所说，正受故解脱，非不正受。云何世尊，为先正受而后解脱耶？为先解脱而后正受耶？为正受、解脱不前不后，一时俱生耶？”
    尔时世尊默然而住。如是摩诃男第二、第三问，佛亦再三默然住。
    尔时尊者阿难住于佛后，执扇扇佛。尊者阿难作是念：“释氏摩诃男以此深义而问世尊，世尊病瘥未久，我今当说余事以引于彼。”语摩诃男：“学人亦有戒，无学人亦有戒；学人有三昧，无学人亦有三昧；学人有慧，无学人亦有慧；学人有解脱，无学人亦有解脱。”
    摩诃男问尊者阿难：“云何为学人戒，云何为无学人戒？云何学人三昧，云何无学人三昧？云何学人慧，云何无学人慧？云何学人解脱，云何无学人解脱？”
    尊者阿难语摩诃男：“此圣弟子住于戒、波罗提木叉律仪、威仪、行处，受持学戒。受持学戒具足已，离欲恶不善法，乃至第四禅具足住。如是三昧具足已，此苦圣谛如实知，此苦集如实知，此苦灭如实知，此苦灭道迹如实知。如是知、如是见已，五下分结已断已知，谓身见、戒取、疑、贪欲、瞋恚，此五下分结断，于彼受生，得般涅槃阿那含，不复还生此世。彼当尔时，成就学戒、学三昧、学慧、学解脱。复于余时，尽诸有漏，无漏解脱，慧解脱，自知作证：我生已尽，梵行已立，所作已作，自知不受后有。彼当尔时，成就无学戒、无学三昧、无学慧、无学解脱。如是摩诃男，是名世尊所说学戒、学三昧、学慧、学解脱，无学戒、无学三昧、无学慧、无学解脱。”
    尔时释氏摩诃男闻尊者阿难所说，欢喜随喜，从座起，礼佛而去。
    尔时世尊知摩诃男去不久，语尊者阿难：“迦毗罗卫释氏，乃能与诸比丘共论深义！”
    阿难白佛：“唯然，世尊。迦毗罗卫释氏，能与诸比丘共论深义。”
    佛告阿难：“迦毗罗卫诸释氏，快得善利，能于甚深佛法贤圣慧眼而得深入。”
    佛说此经已，尊者阿难闻佛所说，欢喜奉行。

（九三五）

    如是我闻。一时佛住迦毗罗卫国尼拘律园中。
    尔时释氏名曰沙陀，语释氏摩诃男：“世尊说须陀洹成就几种法？”
    摩诃男答言：“世尊说须陀洹成就四法。何等为四？谓于佛不坏净，法、僧不坏净，圣戒成就，是名四法成就须陀洹。”
    释氏沙陀语释氏摩诃男：“莫作是说！莫作是言：‘世尊说四法成就须陀洹。’然彼三法成就须陀洹。何等为三？谓于佛不坏净，于法不坏净，于僧不坏净，如是三法成就须陀洹。”
    如是第三说，释氏摩诃男不能令沙陀受四法，释氏沙陀不能令摩诃男受三法。共诣佛所，稽首佛足，退坐一面。
    释氏摩诃男白佛言：“世尊，释氏沙陀来诣我所，问我言：‘世尊说几法成就须陀洹？’我即答言：‘世尊说四法成就须陀洹。何等为四？谓于佛不坏净，于法、僧不坏净，圣戒成就，如是四法成就须陀洹。’释氏沙陀作是言：‘释氏摩诃男，莫作是语：世尊说四法成就须陀洹。但三法成就须陀洹，何等为三？谓于佛不坏净，于法不坏净，于僧不坏净，世尊说如是三法成就须陀洹。’如是再三说。我亦不能令彼释氏沙陀受四法，释氏沙陀亦不能令我受三法，是故俱来诣世尊所。今问世尊，须陀洹成就几法？”
    时沙陀释氏从座起，为佛作礼，合掌白佛：“世尊，若有如是像类法起，一者世尊，一者比丘僧，我宁随世尊，不随比丘僧。或有如是像类法起，一者世尊，一者比丘尼僧、优婆塞、优婆夷、若天、若魔、若梵、若沙门、婆罗门、诸天、世人，我宁随世尊，不随余众。”
    尔时世尊告释氏摩诃男：“如摩诃男，释氏沙陀作如是论，汝当云何？”
    摩诃男白佛：“世尊，彼沙陀释氏作如是论，我知复何说！我唯言善，唯言真实。”
    佛告摩诃男：“是故当知四法成就须陀洹，于佛不坏净，于法、僧不坏净，圣戒成就，如是受持。”
    时释氏摩诃男闻佛所说，欢喜随喜，从座起，作礼而去。

（九三六）

    如是我闻。一时佛住迦毗罗卫国尼拘律园中。
    时有迦毗罗卫释氏，集供养堂，作如是论，问摩诃男：“云何最后记说，彼百手释氏命终，世尊记彼得须陀洹，不堕恶趣法，决定正向三菩提，七有天人往生，究竟苦边？然彼百手释氏犯戒饮酒，而复世尊记彼得须陀洹，乃至究竟苦边？汝摩诃男，当往问佛，如佛所说，我等奉持。”
    尔时摩诃男往诣佛所，稽首礼足，退坐一面，白佛言：“世尊，我等迦毗罗卫诸释氏集供养堂，作如是论：‘摩诃男，云何最后记说，是中百手释氏命终，世尊记说得须陀洹，乃至究竟苦边？汝今当往重问世尊，如世尊所说，我等奉持。’我今问佛，唯愿解说。”
    佛告摩诃男：“善逝大师，善逝大师者，圣弟子所说，口说善逝，而心正念、直见，悉入善逝正法律。正法律者，圣弟子所说，口说正法，发心正念、直见，悉入正法。善向僧，善向僧者，圣弟子所说，口说善向，发心正念、直见，悉入善向。
    “如是摩诃男，圣弟子于佛一向净信，于法、僧一向净信。于法利智、出智、决定智，八解脱具足身作证，以智慧见，有漏断知。如是圣弟子不趣地狱、畜生、饿鬼，不堕恶趣，说阿罗汉俱解脱。
    “复次摩诃男，圣弟子一向于佛清净信，乃至决定智慧，不得八解脱身作证具足住，然彼知见有漏断，是名圣弟子不堕恶趣，乃至慧解脱。
    “复次摩诃男，圣弟子一向于佛清净信，乃至决定智慧，八解脱自作证具足住，而不见有漏断，是名圣弟子不堕恶趣，乃至身证。
    “复次摩诃男，若圣弟子一向于佛清净信，乃至决定智慧，不得八解脱身作证具足住，然于正法律如实知见，是名圣弟子不堕恶趣，乃至见到。
    “复次摩诃男，圣弟子一向于佛清净信，乃至决定智慧，于正法律如实知见，不得见到，是名圣弟子不堕恶趣，乃至信解脱。
    “复次摩诃男，圣弟子信于佛言说清净，信法、信僧言说清净，于五法增上智慧，审谛堪忍，谓信、精进、念、定、慧，是名圣弟子不堕恶趣，乃至随法行。
    “复次摩诃男，圣弟子信于佛言说清净，信法、信僧言说清净，乃至五法少慧，审谛堪忍，谓信、精进、念、定、慧，是名圣弟子不堕恶趣，乃至随信行。
    “摩诃男，此坚固树，于我所说能知义者，无有是处。若能知者，我则记说，况复百手释氏而不记说得须陀洹？摩诃男，百手释氏临命终时，受持净戒，舍离饮酒，然后命终。我记说彼得须陀洹，乃至究竟苦边。”
    摩诃男释氏闻佛所说，欢喜随喜，从座起，作礼而去。

（九三七）

    如是我闻。一时佛住毗舍离猕猴池侧重阁讲堂。
    时有四十比丘住波梨耶聚落，一切皆修阿练若行，粪扫衣，乞食，学人未离欲。来诣佛所，稽首佛足，退住一面。
    尔时世尊作是念：“此四十比丘住波梨耶聚落，皆修阿练若行，粪扫衣，乞食，学人未离欲。我今当为说法，令其即于此生不起诸漏，心得解脱。”
    尔时世尊告波梨耶聚落四十比丘：“众生无始生死，无明所盖，爱系其颈，长夜生死轮转，不知苦之本际。诸比丘，于意云何？恒水洪流，趣于大海，中间恒水为多？汝等本来长夜生死轮转，破坏身体，流血为多？
    诸比丘白佛：“如我解世尊所说义，我等长夜轮转生死，其身破坏，流血甚多，多于恒水百千万倍。”
    佛告比丘：“置此恒水，乃至四大海水为多？汝等长夜轮转生死，其身破坏，血流为多？”
    诸比丘白佛：“如我解世尊所说义，我等长夜轮转生死，其身破坏，流血甚多，逾四大海水也。”
    佛告诸比丘：“善哉善哉！汝等长夜轮转生死，所出身血甚多无数，过于恒水及四大海。所以者何？汝于长夜，曾生象中，或截耳、鼻、头、尾、四足，其血无量。或受马身，驼、驴、牛、犬、诸禽兽类，断截耳、鼻、头、足、四体，其血无量。汝等长夜或为贼盗，为人所害，断截头、足、耳、鼻，分离四体，其血无量。汝等长夜身坏命终，弃于冢间，脓坏流血，其数无量。或堕地狱、畜生、饿鬼，身坏命终，其流血出，亦复无量。”
    佛告比丘：“色为是常，为非常耶？”
    比丘白佛：“无常，世尊。”
    佛告比丘：“若无常者，是苦耶？”
    比丘白佛：“是苦，世尊。”
    佛告比丘：“若无常、苦者，是变易法，圣弟子宁复于中见是我、异我、相在不？”
    比丘白佛：“不也，世尊。”
    受、想、行、识，亦复如是。
    佛告比丘：“若所有色，过去、未来、现在，若内若外，若粗若细，若好若丑，若远若近，彼一切非我、不异我、不相在，如是如实知；受、想、行、识，亦复如是。圣弟子如是观者，于色厌离，于受、想、行、识厌离；厌离已不乐，不乐已解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说是法时，四十比丘波梨耶聚落住者，不起诸漏，心得解脱。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九三八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生无始生死以来，长夜轮转，不知苦之本际。”
    佛告诸比丘：“于意云何？恒河流水，乃至四大海，其水为多？为汝等长夜轮转生死，流泪为多？”
    诸比丘白佛：“如我解世尊所说义，我等长夜轮转生死，流泪甚多，过于恒水及四大海。”
    佛告比丘：“善哉善哉！汝等长夜轮转生死，流泪甚多，非彼恒水及四大海。所以者何？汝等长夜丧失父母、兄弟、姊妹、宗亲、知识，丧失钱财，为之流泪，甚多无量。汝等长夜弃于冢间，脓血流出，及生地狱、畜生、饿鬼。诸比丘，汝等从无始生死，长夜轮转，其身血泪，甚多无量。”
    佛告诸比丘：“色为常耶，为无常耶？”
    比丘白佛：“无常，世尊。”
    佛告比丘：“若无常者，是苦耶？”
    比丘白佛：“是苦，世尊。”
    佛告比丘：“若无常、苦者，是变易法，多闻圣弟子宁于其中见我、异我、相在不？”
    比丘白佛：“不也，世尊。”
    受、想、行、识，亦复如是。
    “诸比丘，圣弟子如是知、如是见，乃至于色解脱，于受、想、行、识解脱，解脱生老病死、忧悲恼苦。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九三九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生于无始生死，无明所盖，爱系其颈，长夜轮转，不知苦之本际。”
    佛告诸比丘：“于意云何？恒河流水及四大海，其水为多？汝等长夜轮转生死，饮其母乳为多耶？”
    比丘白佛：“如我解世尊所说义，我等长夜轮转生死，饮其母乳，多于恒河及四大海水。”
    佛告比丘：“善哉善哉！汝等长夜轮转生死，饮其母乳，多于恒河及四大海水。所以者何？汝等长夜或生象中，饮其母乳，无量无数。或生驼、马、牛、驴、诸禽兽类，饮其母乳，其数无量。汝等长夜弃于冢间，脓血流出，亦复无量。或堕地狱、畜生、饿鬼，髓血流出，亦复如是。比丘，汝等无始生死轮转已来，不知苦之本际。云何比丘，色为常耶，为无常耶？”
    比丘白佛：“非常，世尊。”
    乃至“圣弟子于五受阴观察非我、非我所，于诸世间得无所取，不取已，无所著，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。


杂阿含经卷第三十四

（九四○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生无始生死，长夜轮转，不知苦之本际。诸比丘，于意云何？若此大地一切草木，以四指量，斩以为筹，以数汝等长夜轮转生死所依父母，筹数已尽，其诸父母数犹不尽。诸比丘，如是无始生死，长夜轮转，不知苦之本际。是故比丘，当如是学，当勤精进，断除诸有，莫令增长。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九四一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生无始生死，长夜轮转，不知苦之本际。云何比丘，此大地土泥，悉以为丸，如婆罗果，以数汝等长夜生死以来所依父母，土丸既尽，所依父母其数不尽。比丘，众生无始生死，长夜轮转，不知苦之本际，其数如是。是故比丘，当勤方便，断除诸有，莫令增长，当如是学！”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九四二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生无始生死，长夜轮转，不知苦之本际。诸比丘，汝等见诸众生安隐诸乐，当作是念：‘我等长夜轮转生死，亦曾受斯乐，其趣无量。’是故比丘，当如是学：无始生死，长夜轮转，不知苦之本际，当勤精进，断除诸有，莫令增长。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九四三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生无始生死，长夜轮转，不知苦之本际。诸比丘，若见众生受诸苦恼，当作是念：‘我长夜轮转生死以来，亦曾更受如是之苦，其数无量。’当勤方便，断除诸有，莫令增长。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九四四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生无始生死，长夜轮转，不知苦之本际。诸比丘，汝等见诸众生而生恐怖，衣毛为竖，当作是念：‘我等过去必曾杀生，为伤害者，为恶知识，于无始生死，长夜轮转，不知苦之本际。’诸比丘，当作是学，断除诸有，莫令增长。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九四五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生无始生死，长夜轮转，不知苦之本际。诸比丘，若见众生爱念欢喜者，当作是念：‘如是众生过去世时，必为我等父母、兄弟、妻子、亲属、师友、知识，如是长夜生死轮转，无明所盖，爱系其颈，故长夜轮转，不知苦之本际。’是故诸比丘，当如是学，精勤方便，断除诸有，莫令增长。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九四六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异婆罗门来诣佛所，恭敬问讯，问讯已，退坐一面，白佛言：“瞿昙，未来世当有几佛？”
    佛告婆罗门：“未来佛者，如无量恒河沙。”
    尔时婆罗门作是念：“未来当有如无量恒河沙三藐三佛陀，我当从彼修诸梵行。”尔时婆罗门闻佛所说，欢喜随喜，从座起去。
    时婆罗门随路思惟：“我今唯问沙门瞿昙未来诸佛，不问过去。”即随路还，复问世尊：“云何瞿昙，过去世时复有几佛？”
    佛告婆罗门：“过去世佛，亦如无量恒河沙数。”
    时婆罗门即作是念：“过去世中有无量恒河沙等诸佛世尊，我曾不习近。设复未来如无量恒河沙三藐三佛陀，亦当不与习近娱乐。我今当于沙门瞿昙所修行梵行。”即便合掌白佛言：“唯愿听我于正法律出家修梵行。”
    佛告婆罗门：“听汝于正法律出家修梵行，得比丘分。”
    尔时婆罗门即出家受具足。出家已，独一静处思惟，所以善男子正信非家，出家学道，乃至得阿罗汉。

（九四七）

    如是我闻。一时佛住王舍城毗富罗山。
    尔时世尊告诸比丘：“有一人于一劫中生死轮转，积累白骨不腐坏者，如毗富罗山。若多闻圣弟子，此苦圣谛如实知，此苦集圣谛如实知，此苦灭圣谛如实知，此苦灭道迹圣谛如实知。彼如是知、如是见，断三结，谓身见、戒取、疑。断此三结，得须陀洹，不堕恶趣法，决定正向三菩提，七有天人往生，究竟苦边。”
    尔时世尊即说偈言：

“一人一劫中，积聚其身骨，
常积不腐坏，如毗富罗山。
若诸圣弟子，正智见真谛，
此苦及苦因，离苦得寂灭，
修习八道迹，正向般涅槃。
极至于七有，天人来往生，
尽一切诸结，究竟于苦边。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九四八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生于无始生死，长夜轮转，不知苦之本际。”
    时有异比丘从座起，整衣服，偏袒右肩，为佛作礼，右膝着地，合掌白佛：“世尊，劫长久如？”
    佛告比丘：“我能为汝说，而汝难知。”
    比丘白佛：“可说譬不？”
    佛言：“可说。比丘，譬如铁城，方一由旬，高下亦尔，满中芥子。有人百年取一芥子，尽其芥子，劫犹不竟。如是比丘，其劫者如是长久。如是长劫，百千万亿大苦相续，白骨成丘，脓血成流，地狱、畜生、饿鬼恶趣。是名比丘，无始生死，长夜轮转，不知苦之本际。是故比丘，当如是学，断除诸有，莫令增长。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九四九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生无始生死，长夜轮转，不知苦之本际。”
    时有异比丘从座起，整衣服，为佛作礼，右膝着地，合掌白佛：“世尊，劫长久如？”
    佛告比丘：“我能为汝说，汝难得知。”
    比丘白佛：“可说譬不？”
    佛言：“可说。比丘，如大石山，不断不坏，方一由旬。若有士夫以迦尸劫贝，百年一拂，拂之不已，石山遂尽，劫犹不竟。比丘，如是长久之劫，百千万亿劫受诸苦恼。乃至诸比丘，当如是学，断除诸有，莫令增长。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九五○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生无始生死，长夜轮转，不知苦之本际。”
    时有异比丘从座起，整衣服，为佛作礼，右膝着地，合掌白佛：“世尊，过去有几劫？”
    佛告比丘：“我悉能说，汝知甚难。”
    比丘白佛：“可说譬不？”
    佛言：“可说。譬如比丘，有士夫寿命百岁，晨朝忆念三百千劫，日中忆念三百千劫，日暮忆念三百千劫，如是日日忆念劫数，百年命终，不能忆念劫数边际。比丘当知，过去劫数无量如是。过去无量劫数，长夜受苦，积骨成山，髓血成流，乃至地狱、畜生、饿鬼恶趣。如是比丘，无始生死，长夜轮转，不知苦之本际。是故比丘，当如是学，断除诸有，莫令增长。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九五一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生无始生死，长夜轮转，不知苦之本际，无有一处不生不死者。如是长夜无始生死，不知苦之本际。是故比丘，当如是学，断除诸有，莫令增长。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九五二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生无始生死，长夜轮转，不知苦之本际，无有一处无父母、兄弟、妻子、眷属、宗亲、师长者。如是比丘，无始生死，长夜轮转，不知苦之本际。是故比丘，当如是学，断除诸有，莫令增长。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九五三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生无始生死，长夜轮转，不知苦之本际。譬如大雨滴泡，一生一灭。如是众生无明所盖，爱系其颈，无始生死，生者、死者，长夜轮转，不知苦之本际。是故比丘，当如是学，断除诸有，莫令增长。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九五四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生无始生死，长夜轮转，不知苦之本际。譬如普天大雨洪澍，东西南北无断绝处。如是东方、南方、西方、北方，无量国土劫成劫坏，如天大雨，普雨天下，无断绝处。如是无始生死，长夜轮转，不知苦之本际。譬如掷杖空中，或头落地，或尾落地，或中落地。如是无始生死，长夜轮转，或堕地狱，或堕畜生，或堕饿鬼。如是无始生死，长夜轮转。是故比丘，当如是学，断除诸有，莫令增长。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九五五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“众生无始生死，长夜轮转，不知苦之本际。譬如比丘，若有士夫转五节轮，常转不息。如是众生转五趣轮，或堕地狱、畜生、饿鬼，及人、天趣，常转不息。如是无始生死，长夜轮转，不知苦之本际。是故比丘，当如是学，断除诸有，莫令增长。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九五六）

    如是我闻。一时佛住王舍城毗富罗山侧。
    尔时世尊告诸比丘：“一切行无常，一切行不恒、不安、变易之法。诸比丘，于一切行，当生厌离，求乐解脱。
    “诸比丘，过去世时，此毗富罗山，名长竹山。有诸人民围绕山居，名低弥罗邑。低弥罗邑人寿四万岁。低弥罗邑人上此山顶，四日乃得往反。时世有佛，名迦罗迦孙提如来、应、等正觉、明行足、善逝、世间解、无上士、调御丈夫、天人师、佛、世尊，出兴于世，说法教化，初、中、后善，善义善味，纯一满净，梵行清白，开发显示。彼长竹山于今名字亦灭，低弥罗聚落人民亦没，彼佛如来已般涅槃。比丘，当知一切诸行皆悉无常、不恒、不安、变易之法，于一切行，当修厌离，离欲解脱。
    “诸比丘，过去世时，此毗富罗山，名曰朋迦。时有人民绕山而居，名阿毗迦邑，彼时人民寿三万岁。阿毗迦人上此山顶，经三日中乃得往反。时世有佛，名拘那含牟尼如来、应、等正觉、明行足、善逝、世间解、无上士、调御丈夫、天人师、佛、世尊，出兴于世，演说经法，初、中、后善，善义善味，纯一满净，梵行清白，开发显示。诸比丘，彼朋迦山名字久灭，阿毗迦邑人亦久亡没，彼佛世尊亦般涅槃。如是比丘，一切诸行皆悉无常、不恒、不安、变易之法，汝等比丘当修厌离，求乐解脱。
    “诸比丘，过去世时，此毗富罗山，名宿波罗首。有诸人民绕山居止，名赤马邑，人寿二万岁。彼诸人民上此山顶，经二日中乃得往反。尔时有佛，名曰迦叶如来、应供，乃至出兴于世，演说经法，初、中、后善，善义善味，纯一满净，梵行清白，开示显现。比丘，当知宿波罗首山名字久灭，赤马邑人亦久亡没，彼佛世尊亦般涅槃。如是比丘，一切诸行皆悉无常、不恒、不安、变易之法，是故比丘，当修厌离，离欲解脱。
    “诸比丘，今日此山名毗富罗，有诸人民绕山而居，名摩竭提国。此诸人民寿命百岁，善自消息，得满百岁。摩竭提人上此山顶，须臾往反。我今于此得成如来、应、等正觉，乃至佛、世尊，演说正法，教化令得寂灭涅槃、正道、善逝、觉知。比丘，当知此毗富罗山名亦当磨灭，摩竭提人亦当亡没，如来不久当般涅槃。如是比丘，一切诸行悉皆无常、不恒、不安、变易之法，是故比丘，当修厌离，离欲解脱。”
    尔时世尊即说偈言：

“古昔长竹山，低弥罗村邑；
次名朋迦山，阿毗迦聚落；
宿波罗首山，聚落名赤马；
今毗富罗山，国名摩竭陀。
名山悉磨灭，其人悉没亡，
诸佛般涅槃，有者无不尽。
一切行无常，悉皆生灭法，
有生无不尽，唯寂灭为乐。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九五七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有婆蹉种出家来诣佛所，合掌问讯，问讯已，退坐一面，白佛言：“瞿昙，欲有所问，宁有闲暇见答以不？”
    佛告婆蹉种出家：“随汝所问，当为汝说。”
    婆蹉种出家白佛言：“云何瞿昙，命即身耶？”
    佛告婆蹉种出家：“命即身者，此是无记。”
    “云何瞿昙，为命异身异耶？”
    佛告婆蹉种出家：“命异身异者，此亦无记。”
    婆蹉种出家白佛：“云何瞿昙，命即身耶，答言无记？命异身异，答言无记？沙门瞿昙有何等奇，弟子命终，即记说言：‘某生彼处，某生彼处。’彼诸弟子于此命终舍身，即乘意生身生于余处。当于尔时，非为命异身异也？”
    佛告婆蹉：“此说有余，不说无余。”
    婆蹉白佛：“瞿昙，云何说有余，不说无余？”
    佛告婆蹉：“譬如火，有余得燃，非无余。”
    婆蹉白佛：“我见火无余亦燃。”
    佛告婆蹉：“云何见火无余亦燃？”
    婆蹉白佛：“譬如大聚炽火，疾风来吹，火飞空中，岂非无余火耶？”
    佛告婆蹉：“风吹飞火，即是有余，非无余也。”
    婆蹉白佛：“瞿昙，空中飞火，云何名有余？”
    佛告婆蹉：“空中飞火，依风故住，依风故燃，以依风故，故说有余。”
    婆蹉白佛：“众生于此命终，乘意生身往生余处，云何有余？”
    佛告婆蹉：“众生于此处命终，乘意生身生于余处，当于尔时，因爱故取，因爱而住，故说有余。”
    婆蹉白佛：“众生以爱乐有余，染著有余。唯有世尊，得彼无余，成等正觉。沙门瞿昙，世间多缘，请辞还去。”
    佛告婆蹉：“宜知是时。”
    婆蹉出家闻佛所说，欢喜随喜，从座起而去。

（九五八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者大目揵连亦于彼住。
    时有婆蹉种出家诣尊者大目揵连所，与尊者目揵连面相问讯慰劳，慰劳已，退坐一面，语尊者大目揵连：“欲有所问，宁有闲暇见答以不？”
    目连答言：“婆蹉，随意所问，知者当答。”
    时婆蹉种出家问尊者目揵连：“何因何缘，余沙门、婆罗门，有人来问：‘云何如来有后死、无后死、有无后死、非有非无后死？’皆悉随答。而沙门瞿昙，有来问言：‘如来有后死、无后死、有无后死、非有非无后死。’而不记说？”
    目揵连言：“婆蹉，余沙门、婆罗门于色、色集、色灭、色味、色患、色出不如实知，不如实知故，于如来有后死则取著，如来无后死、有后死无后死、非有后死非无后死则生取著。受、想、行、识、识集、识灭、识味、识患、识出不如实知，不如实知故，于如来有后死生取著，无后死、有无后死、非有非无后死生取著。
    “如来者，于色如实知，色集、色灭、色味、色患、色出如实知，如实知故，于如来有后死则不著，无后死、有无后死、非有非无后死则不著。受、想、行、识如实知，识集、识灭、识味、识患、识出如实知，如实知故，于如来有后死则不然，无后死、有无后死、非有非无后死则不然，甚深、广大、无量、无数，皆悉寂灭。
    “婆蹉，如是因、如是缘，余沙门、婆罗门，若有来问如来有后死、无后死、有无后死、非有非无后死，则为记说。如是因、如是缘，如来若有来问如来有后死、无后死、有无后死、非有非无后死，不为记说。”
    时婆蹉种出家闻尊者大目揵连所说，欢喜随喜，从座起而去。

（九五九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有婆蹉种出家来诣佛所，合掌问讯，问讯已，退坐一面，白佛言：“瞿昙，何因何缘，余沙门、婆罗门，若有来问”，如上广说。
    尔时婆蹉种出家叹言：“奇哉瞿昙！弟子、大师，义同义、句同句、味同味，乃至同第一义。瞿昙，我今诣摩诃目揵连，以如是义、如是句、如是味而问于彼，彼亦以如是义、如是句、如是味而答我，如今瞿昙所说。是故瞿昙，真为奇特！大师、弟子，义同义、句同句、味同味，同第一义。”
    尔时婆蹉种出家有诸因缘至那梨聚落，营事讫已，诣尊者诜陀迦旃延所，共相问讯，问讯已，退坐一面，问诜陀迦旃延：“何因何缘，沙门瞿昙若有来问如来有后死、无后死、有无后死、非有非无后死，不为记说？”
    诜陀迦旃延语婆蹉种出家：“我今问汝，随意答我。于汝意云何？若因、若缘、若种施设诸行，若色、若无色，若想、若非想、若非想非非想。若彼因、彼缘、彼行无余行灭，永灭已，如来于彼有所记说，言有后死、无后死、有无后死、非有非无后死耶？”
    婆蹉种出家语诜陀迦旃延：“若因、若缘、若种施设诸行，若色、若非色，若想、若非想、若非想非非想。彼因、彼缘、彼行无余灭，云何瞿昙于彼记说如来有后死、无后死、有无后死、非有非无后死？”
    诜陀迦旃延语婆蹉种出家：“是故如来以是因、以是缘故，有问如来有后死、无后死、有无后死、非有非无后死，不为记说。”
    婆蹉种出家问诜陀迦旃延：“汝于沙门瞿昙弟子，为日久如？”
    诜陀迦旃延答言：“少过三年，于正法律出家修梵行。”
    婆蹉种出家言：“诜陀迦旃延，快得善利！少时出家，而得如是身律仪、口律仪，又得如是智慧辩才。”
    时婆蹉种出家闻诜陀迦旃延所说，欢喜随喜，从座起去。

（九六○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有婆蹉种出家来诣佛所，合掌问讯，问讯已，退坐一面，白佛言：“瞿昙，欲有所问，宁有闲暇为解说不？”
    佛告婆蹉种出家：“随所欲问，当为汝说。”
    婆蹉种出家白佛言：“瞿昙，何因何缘，有人来问如来有后死、无后死、有无后死、非有非无后死，而不为记说耶？”
    佛告婆蹉种出家，如上诜陀迦旃延广说，乃至非有非无后死。
    婆蹉种出家白佛言：“奇哉瞿昙！师及弟子，义义同，句句同，味味同，其理悉合，所谓第一句说。瞿昙，我为小缘事至那利伽聚落，营事讫已，暂过沙门迦旃延，以如是义、如是句、如是味问沙门迦旃延，彼亦以如是义、如是句、如是味答我所问，如今沙门瞿昙所说。是故当知，实为奇特，师及弟子，义、句、味，义、句、味悉同。”
    时婆蹉种出家闻佛所说，欢喜随喜，从座起而去。

（九六一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有婆蹉种出家来诣佛所，合掌问讯，问讯已，退坐一面，白佛言：“云何瞿昙，为有我耶？”
    尔时世尊默然不答。如是再三，尔时世尊亦再三不答。
    尔时婆蹉种出家作是念：“我已三问沙门瞿昙，而不见答，但当还去。”
    时尊者阿难住于佛后，执扇扇佛。尔时阿难白佛言：“世尊，彼婆蹉种出家三问，世尊何故不答？岂不增彼婆蹉种出家恶邪见，言沙门不能答其所问？”
    佛告阿难：“我若答言有我，则增彼先来邪见。若答言无我，彼先痴惑岂不更增痴惑？言先有我，从今断灭。若先来有我，则是常见。于今断灭，则是断见。如来离于二边，处中说法，所谓是事有故是事有，是事起故是事生，谓缘无明行，乃至生老病死、忧悲恼苦灭。”
    佛说此经已，尊者阿难闻佛所说，欢喜奉行。

（九六二）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时婆蹉种出家来诣佛所，与世尊面相问讯，问讯已，退坐一面，白佛言：“瞿昙，云何瞿昙作如是见、如是说：世间常，此是真实，余则虚妄耶？”
    佛告婆蹉种出家：“我不作如是见、如是说：世间常，是则真实，余则虚妄。”
    “云何瞿昙作如是见、如是说：世间无常、常无常、非常非无常，有边、无边、边无边、非边非无边，命即是身、命异身异，如来有后死、无后死、有无后死、非有非无后死？”
    佛告婆蹉种出家：“我不作如是见、如是说，乃至非有非无后死。”
    尔时婆蹉种出家白佛言：“瞿昙于此见，见何等过患，而于此诸见，一切不说？”
    佛告婆蹉种出家：“若作是见，世间常，此则真实，余则虚妄者，此是倒见，此是观察见，此是动摇见，此是垢污见，此是结见，是苦、是碍、是恼、是热，见结所系，愚痴无闻凡夫于未来世，生老病死、忧悲恼苦生。婆蹉种出家，若作是见，世间无常、常无常、非常非无常，有边、无边、边无边、非有边非无边，是命是身、命异身异，如来有后死、无后死、有无后死、非有非无后死，此是倒见，乃至忧悲恼苦生。”
    婆蹉种出家白佛：“瞿昙何所见？”
    佛告婆蹉种出家：“如来所见已毕。婆蹉种出家，然如来见，谓见此苦圣谛、此苦集圣谛、此苦灭圣谛、此苦灭道迹圣谛。作如是知、如是见已，于一切见、一切受、一切生、一切我、我所见、我慢系著使，断灭、寂静、清凉、真实。如是等解脱比丘，生者不然，不生亦不然。”
    婆蹉白佛：“瞿昙，何故说言生者不然？”
    佛告婆蹉：“我今问汝，随意答我。婆蹉，犹如有人于汝前燃火，汝见火燃不？即于汝前火灭，汝见火灭不？”
    婆蹉白佛：“如是，瞿昙。”
    佛告婆蹉：“若有人问汝：‘向者火燃，今在何处，为东方去耶？西方、南方、北方去耶？’如是问者，汝云何说？”
    婆蹉白佛：“瞿昙，若有来作如是问者，我当作如是答：若有于我前燃火，薪草因缘故燃，若不增薪，火则永灭，不复更起。东方、南方、西方、北方去者，是则不然。”
    佛告婆蹉：“我亦如是说，色已断已知，受、想、行、识已断已知，断其根本，如截多罗树头，无复生分，于未来世永不复起。若至东方，南、西、北方，是则不然，甚深、广大、无量、无数、永灭。”
    婆蹉白佛：“我当说譬。”
    佛告婆蹉：“为知是时。”
    婆蹉白佛：“瞿昙，譬如近城邑聚落，有好净地，生坚固林。有一大坚固树，其生已来经数千岁，日夜既久，枝叶零落，皮肤枯朽，唯干独立。如是瞿昙，如来法律离诸枝条柯叶，唯空干坚固独立。”
    尔时婆蹉出家闻佛所说，欢喜随喜，从座起去。

（九六三）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有婆蹉种出家来诣佛所，与世尊面相问讯慰劳已，退坐一面，白佛言：“瞿昙，彼云何无知故，作如是见、如是说：世间常，此是真实，余则虚妄；世间无常、世间常无常、世间非常非无常，世有边、世无边、世有边无边、世非有边非无边，命即是身、命异身异，如来有后死、无后死、有无后死、非有非无后死？”
    佛告婆蹉：“于色无知故，作如是见、如是说：世间常，此是真实，余则虚妄，乃至非有非无后死。于受、想、行、识无知故，作如是见、如是说：世间常，此是真实，余则虚妄，乃至非有非无后死。”
    婆蹉白佛：“瞿昙，知何法故，不如是见、如是说：世间常，此是真实，余则虚妄，乃至非有非无后死？”
    佛告婆蹉：“知色故，不如是见、如是说：世间常，此是真实，余则虚妄，乃至非有非无后死。知受、想、行、识故，不作如是见、如是说：世间常，此是真实，余则虚妄，乃至非有非无后死。如是不知知，如是不见见，不识识，不断断，不观观，不察察，不觉觉。”
    佛说此经已，婆蹉种出家闻佛所说，欢喜随喜，从座起而去。

（九六四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有婆蹉种出家来诣佛所，与世尊面相慰劳已，退坐一面，白佛言：“瞿昙，欲有所问，宁有闲暇为解说不？”
    尔时世尊默然而住。婆蹉种出家第二、第三问，佛亦第二、第三默然而住。
    时婆蹉种出家白佛言：“我与瞿昙共相随顺，今有所问，何故默然？”
    尔时世尊作是念：“此婆蹉种出家长夜质直，不谄不伪，时有所问，皆以不知故，非故恼乱。我今当以阿毗昙、律，纳受于彼。”作是念已，告婆蹉种出家：“随汝所问，当为解说。”
    婆蹉白佛：“云何瞿昙，有善不善法耶？”
    佛答言：“有。”
    婆蹉白佛：“当为我说善不善法，令我得解。”
    佛告婆蹉：“我今当为汝略说善不善法，谛听善思。婆蹉，贪欲者是不善法，调伏贪欲是则善法；瞋恚、愚痴是不善法，调伏恚、痴是则善法。杀生者是不善法，离杀生者是则善法；偷盗、邪淫、妄语、两舌、恶口、绮语、贪、恚、邪见是不善法，不盗乃至正见是则善法。是为婆蹉，我今已说三种善法、三种不善法。如是圣弟子于三种善法、三种不善法如实知，十种不善法、十种善法如实知者，则于贪欲无余灭尽，瞋恚、愚痴无余灭尽者，则于一切有漏灭尽，无漏心解脱、慧解脱，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。”
    婆蹉白佛：“颇有一比丘于此法律得尽有漏，无漏心解脱，乃至不受后有耶？”
    佛告婆蹉：“不但若一、若二、若三，乃至五百，有众多比丘于此法律尽诸有漏，乃至不受后有。”
    婆蹉白佛：“且置比丘，有一比丘尼于此法律尽诸有漏，乃至不受后有不？”
    佛告婆蹉：“不但一、二、三比丘尼，乃至五百，有众多比丘尼于此法律尽诸有漏，乃至不受后有。”
    婆蹉白佛：“置比丘尼，有一优婆塞修诸梵行，于此法律度狐疑不？”
    佛告婆蹉：“不但一、二、三，乃至五百优婆塞，乃有众多优婆塞修诸梵行，于此法律断五下分结，得成阿那含，不复还生此。”
    婆蹉白佛：“复置优婆塞，颇有一优婆夷于此法律修持梵行，于此法律度狐疑不？”
    佛告婆蹉：“不但一、二、三优婆夷，乃至五百，乃有众多优婆夷于此法律断五下分结，于彼化生，得阿那含，不复还生此。”
    婆蹉白佛：“置比丘、比丘尼、优婆塞、优婆夷修梵行者，颇有优婆塞受五欲，而于此法律度狐疑不？”
    佛告婆蹉：“不但一、二、三，乃至五百，乃有众多优婆塞，居家妻子，香花严饰，畜养奴婢，于此法律断三结，贪、恚、痴薄，得斯陀含，一往一来，究竟苦边。”
    婆蹉白佛：“复置优婆塞，颇有一优婆夷受习五欲，于此法律得度狐疑不？”
    佛告婆蹉：“不但一、二、三，乃至五百，乃有众多优婆夷在于居家，畜养男女，服习五欲，花香严饰，于此法律三结尽，得须陀洹，不堕恶趣法，决定正向三菩提，七有天人往生，究竟苦边。”
    婆蹉白佛言：“瞿昙，若沙门瞿昙成等正觉，若比丘、比丘尼、优婆塞、优婆夷修梵行者，及优婆塞、优婆夷服习五欲，不得如是功德者，则不满足。以沙门瞿昙成等正觉，比丘、比丘尼、优婆塞、优婆夷修诸梵行，及优婆塞、优婆夷服习五欲，而成就尔所功德故，则为满足。瞿昙，今当说譬。”
    佛告婆蹉：“随意所说。”
    婆蹉白佛：“如天大雨，水流随下。瞿昙法律亦复如是，比丘、比丘尼、优婆塞、优婆夷，若男若女，悉皆随流，向于涅槃，浚输涅槃。甚奇！佛、法、僧平等法律。为余异道出家来诣瞿昙所，于正法律求出家、受具足者，几时便听出家？”
    佛告婆蹉：“若余异道出家欲来于正法律求出家、受具足者，乃至四月于和尚所，受衣而住，然此是为人粗作齐限耳。”
    婆蹉白佛：“若诸异道出家来于正法律欲求出家、受具足，听于和尚所受衣着，满四月听出家者，我今堪能于四月在和尚所受衣着，于正法律而得出家、受具足。我当于瞿昙法中出家、受具足，修持梵行。”
    佛告婆蹉：“我先不说粗为人作分齐耶？”
    婆蹉白佛：“如是，瞿昙。”
    尔时世尊告诸比丘：“汝等当度彼婆蹉出家于正法律出家，受具足。”
    婆蹉种出家即得于正法律出家，受具足，成比丘分。乃至半月，学所应知、应识、应见、应得、应觉、应证，悉知、悉识、悉见、悉得、悉觉、悉证如来正法。尊者婆蹉作是念：“我今已学所应知、应识、应见、应得、应觉、应证，彼一切悉知、悉识、悉见、悉得、悉觉、悉证。今当往见世尊。”
    是时婆蹉诣世尊所，稽首礼足，于一面住，白佛言：“世尊，我于学所应知、应识、应见、应得、应觉、应证，悉知、悉识、悉见、悉得、悉觉、悉证世尊正法。唯愿世尊为我说法，我闻法已，当独一静处，专精思惟，不放逸住，思惟所以善男子剃除须发，着袈裟衣，正信出家学道，乃至自知不受后有。”
    佛告婆蹉：“有二法，修习多修习，所谓止观。此二法修习多修习，得知界果，觉了于界，知种种界，觉种种界。如是比丘，欲求离欲恶不善法，乃至第四禅具足住，慈、悲、喜、舍，空入处、识入处、无所有入处、非想非非想入处，令我三结尽，得须陀洹；三结尽，贪、恚、痴薄，得斯陀含；五下分结尽，得阿那含；种种神通境界，天眼、天耳、他心智、宿命智、生死智、漏尽智皆悉得。是故比丘，当修二法，修习多修习。修二法故，知种种界，乃至漏尽。”
    尔时尊者婆蹉闻佛所说，欢喜作礼而去。尔时婆蹉独一静处，专精思惟，不放逸住，乃至自知不受后有。
    时有众多比丘，庄严方便，欲诣世尊恭敬供养。尔时婆蹉问众多比丘：“汝等庄严方便，欲诣世尊恭敬供养耶？”
    诸比丘答言：“尔。”
    尔时婆蹉语诸比丘：“尊者，持我语，敬礼世尊，问讯起居轻利，少病少恼，安乐住不？言婆蹉比丘白世尊言：我已供养世尊，具足奉事，令欢悦非不欢悦；大师弟子所作皆悉已作，供养大师，令欢悦非不欢悦。”
    时众多比丘往诣佛所，稽首礼足，退坐一面，白佛言：“世尊，尊者婆蹉稽首敬礼世尊足，乃至欢悦非不欢悦。”
    佛告诸比丘：“诸天先已语我，汝今复说。如来成就第一知见，亦如婆蹉比丘，有如是德力。”
    尔时世尊为彼婆蹉比丘说第一记。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九六五）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有外道出家名曰郁低迦，来诣佛所，与世尊面相问讯慰劳已，退坐一面，白佛言：“瞿昙，云何瞿昙，世有边耶？”
    佛告郁低迦：“此是无记。”
    郁低迦白佛：“云何瞿昙，世无边耶？有边无边耶？非有边非无边耶？”
    佛告郁低迦：“此是无记。”
    郁低迦白佛：“云何瞿昙，世有边耶，答言无记？世无边耶，世有边无边耶，世非有边非无边耶，答言无记？瞿昙，于何等法而可记说？”
    佛告郁低迦：“知者、智者，我为诸弟子而记说道，令正尽苦，究竟苦边。”
    郁低迦白佛：“云何瞿昙，为诸弟子说道，令正尽苦，究竟苦边？为一切世间从此道出，为少分耶？”
    尔时世尊默然不答。第二、第三问，佛亦第二、第三默然不答。
    尔时尊者阿难住于佛后，执扇扇佛。尊者阿难语郁低迦外道出家：“汝初已问此义，今复以异说而问，是故世尊不为记说。郁低迦，今当为汝说譬，夫智者因譬得解。譬如国王，有边境城，四周坚固，巷陌平正，唯有一门。立守门者，聪明黠慧，善能筹量，外有人来，应入者听入，不应入者不听。周匝绕城，求第二门，都不可得，都无猫狸出入之处，况第二门？彼守门者，都不觉悟入者、出者，然彼士夫知一切人唯从此门若出若入，更无余处。如是世尊虽不用心觉悟众生一切世间从此道出及以少分，然知众生正尽苦，究竟苦边者，一切皆悉从此道出。”
    时郁低迦外道出家闻佛所说，欢喜随喜，从座起而去。

（九六六）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有尊者富邻尼住王舍城耆阇崛山中。
    时有众多外道出家诣尊者富邻尼，共相问讯慰劳已，退坐一面，问尊者富邻尼：“我闻沙门瞿昙作断灭破坏有教授耶？今问尊者富邻尼，竟为尔不？”
    富邻尼语诸外道出家：“我不如是知，世尊教语众生断灭坏有，令无所有者，无有是处。我作如是解：世尊所说，有诸众生计言有我、我慢、邪慢，世尊为说，令其断灭。”
    时诸外道出家闻富邻尼所说，心不喜悦，呵责而去。
    尔时尊者富邻尼，诸外道去已，往诣佛所，稽首礼足，退坐一面，以向诸外道出家所说具白世尊：“世尊，我向答诸外道说，得无谤毁世尊耶？为是法说，如佛所说，如法说，随顺法说，得不为诸论议者所见嫌责耶？”
    佛告富邻尼：“如汝所说，不谤如来，不失次第，如我记说，如法法说，随顺法说，不为诸论者之所嫌责。所以者何？富邻尼，先诸众生，我慢、邪慢、邪慢所迫、邪慢集、邪慢不无间等，乱如狗肠，如铁钩锁，亦如乱草，往反驱驰，此世他世，他世此世，驱驰往反，不能远离。富邻尼，一切众生于诸邪慢无余永灭者，彼一切众生长夜安隐快乐。”
    佛说此经已，富邻尼比丘闻佛所说，欢喜奉行。

（九六七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者阿难陀，于后夜时，向榻补河边，脱衣置岸边，入水洗手足，还上岸，着一衣，摩拭身体。时俱迦那外道出家亦至水边。尊者阿难陀闻其行声，闻声已，即便謦咳作声。
    俱迦那外道出家闻有人声，而问言：“为何等人？”
    尊者阿难陀答言：“沙门。”
    俱迦那外道言：“何等沙门？”
    尊者阿难陀答言：“释种子。”
    俱迦那外道言：“欲有所问，宁有闲暇见答以不？”
    尊者阿难陀答言：“随意所问，知者当答。”
    俱迦那言：“云何如来死后有耶？”
    阿难陀答言：“世尊所说，此是无记。”
    复问：“如来死后无耶，死后有无耶，非有非无耶？”
    阿难陀言：“世尊所说，此是无记。”
    俱迦那外道言：“云何如来死后有，答言无记？死后无，死后有无，死后非有非无，答言无记？云何为不知不见耶？”
    阿难陀答言：“非不知、非不见，悉知、悉见。”
    复问阿难陀：“云何知，云何见？”
    阿难陀答言：“见可见处，见所起处，见缠断处，此则为知，此则为见。我如是知、如是见，云何说言不知、不见？”
    俱迦那外道复问：“尊者何名？”
    阿难陀答言：“我名阿难陀。”
    俱迦那外道言：“奇哉！大师弟子，而共论议。我若知是尊者阿难陀者，不敢发问。”
    说是语已，即舍而去。

（九六八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时给孤独长者，日日出见世尊，礼事供养。给孤独长者作是念：“我今出太早，世尊及诸比丘禅思未起，我宁可过诸外道住处。”即入外道精舍，与诸外道共相问讯慰劳已，退坐一面。
    时彼外道问言：“长者，汝见沙门瞿昙，云何见？何所见？”
    长者答言：“我亦不知云何见世尊，世尊何所见。”
    诸外道言：“汝言见众僧，云何见众僧？众僧何所见？”
    长者答言：“我亦不知云何见僧，僧何所见。”
    外道复问：“长者，汝今云何自见？自何所见？”
    长者答言：“汝等各各自说所见，然后我说所见亦不难。”
    时有一外道作如是言：“长者，我见一切世间常，是则真实，余者虚妄。”
    复有说言：“长者，我见一切世间无常，此是真实，余则虚妄。”
    复有说言：“长者，世间常无常，此是真实，余则虚妄。”
    复有说言：“世间非常非无常，此是真实，余则虚妄。”
    复有说言：“世有边，此是真实，余则虚妄。”
    复有说言：“世无边，此是真实，余则虚妄。”
    复有说言：“世有边无边。”
    复有说言：“世非有边非无边。”
    复有说言：“命即是身。”
    复有说言：“命异身异。”
    复有说言：“如来死后有。”
    复有说言：“如来死后无。”
    复有说言：“如来死后有无。”
    复有说言：“如来死后非有非无，此是真实，余则虚妄。”
    诸外道语长者言：“我等各各已说所见，汝复应说汝所见。”
    长者答言：“我之所见，真实有为思量缘起。若复真实有为思量缘起者，彼则无常，无常者是苦，如是知已，于一切见都无所得。如汝所见：世间常，此是真实，余则虚妄者，此见真实有为思量缘起，若真实有为思量缘起者，是则无常，无常者是苦。是故汝等习近于苦，唯得于苦，坚住于苦，深入于苦。如是汝言世间常，此是真实，余则虚妄，有如是咎。世间无常、常无常、非常非无常，世有边、世无边、世有边无边、世非有边非无边，命即是身、命异身异，如来死后有、如来死后无、如来死后有无、如来死后非有非无，此是真实，余则虚妄，皆如上说。”
    有一外道语给孤独长者言：“如汝所说，若有见，彼则真实有为思量缘起者，是无常法，若无常者是苦。是故长者所见，亦习近苦，得苦，住苦，深入于苦。”
    长者答言：“我先不言所见者，是真实有为思量缘起法，悉皆无常，无常者是苦，知苦已，我于所见无所得耶？”
    彼外道言：“如是，长者。”
    尔时给孤独长者于外道精舍，伏彼异论，建立正论，于异学众中作狮子吼已，往诣佛所，稽首礼足，退坐一面，以向与诸外道共论事向佛广说。
    佛告给孤独长者：“善哉善哉！宜应时时摧伏愚痴外道，建立正论。”
    佛说是语已，给孤独长者欢喜随喜，作礼而去。

（九六九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有长爪外道出家来诣佛所，与世尊面相问讯慰劳已，退坐一面，白佛言：“瞿昙，我一切见不忍。”
    佛告火种：“汝言一切见不忍者，此见亦不忍耶？”
    长爪外道言：“向言一切见不忍者，此见亦不忍。”
    佛告火种：“如是知、如是见，此见则已断、已舍、已离，余见更不相续、不起、不生。火种，多人与汝所见同，多人作如是见、如是说，汝亦与彼相似。火种，若诸沙门、婆罗门舍斯等见，余见不起，是等沙门、婆罗门，世间亦少少耳。
    “火种，依三种见。何等为三？有一如是见、如是说：‘我一切忍。’复次有一如是见、如是说：‘我一切不忍。’复次有一如是见、如是说：‘我于一忍一不忍。’火种，若言一切忍者，此见与贪俱生，非不贪；与恚俱生，非不恚；与痴俱生，非不痴；系不离系，烦恼非清净，乐、取、染著生。若如是见：‘我一切不忍。’此见非贪俱、非恚俱、非痴俱，清净非烦恼，离系非系，不乐、不取、不著生。火种，若如是见：‘我一忍一不忍。’彼若忍者，则有贪，乃至染著生；若如是见不忍者，则离贪，乃至不染著生。
    “彼多闻圣弟子所学言：‘我若作如是见、如是说，我一切忍，则为二者所责所诘。何等二种？谓一切不忍，及一忍一不忍。则为此等所责，责故诘，诘故害。’彼见责、见诘、见害故，则舍所见，余见则不复生。如是断见、舍见、离见，余见不复相续、不起、不生。彼多闻圣弟子作如是学：‘我若如是见、如是说，我一切不忍者，则有二责二诘。何等为二？谓我一切忍，及一忍一不忍，如是二责二诘。’乃至不相续、不起、不生。彼多闻圣弟子作如是学：‘我若作如是见、如是说，一忍一不忍，则有二责二诘。何等为二？谓如是见、如是说，我一切忍，及一切不忍，如是二责。’乃至不相续、不起、不生。
    “复次火种，如是身色粗四大，圣弟子当观无常、观生灭、观离欲、观灭尽、观舍。若圣弟子观无常、观灭、观离欲、观灭尽、观舍住者，于彼身、身欲、身念、身爱、身染、身著，永灭不住。火种，有三种受，谓苦受、乐受、不苦不乐受。此三种受，何因、何集、何生、何转？谓此三受，触因、触集、触生、触转。彼彼触集则受集，彼彼触灭则受灭、寂静、清凉、永尽。彼于此三受，觉苦、觉乐、觉不苦不乐。彼彼受若集、若灭、若味、若患、若出如实知；如实知已，即于彼受观察无常、观生灭、观离欲、观灭尽、观舍。彼于身分齐受觉如实知，于命分齐受觉如实知。若彼身坏命终后，即于尔时，一切受永灭无余。彼作是念：‘乐受觉时，其身亦坏；苦受觉时，其身亦坏；不苦不乐受觉时，其身亦坏，悉为苦边。’于彼乐觉，离系不系；于彼苦觉，离系不系；于不苦不乐觉，离系不系。于何离系？离于贪欲、瞋恚、愚痴，离于生老病死、忧悲恼苦。我说斯等名为离苦。”
    当于尔时，尊者舍利弗受具足，始经半月。时尊者舍利弗住于佛后，执扇扇佛，时尊者舍利弗作是念：“世尊叹说于彼彼法断欲、离欲、欲灭尽、欲舍。”尔时尊者舍利弗，即于彼彼法观察无常、观生灭、观离欲、观灭尽、观舍，不起诸漏，心得解脱。
    尔时长爪外道出家远尘离垢，得法眼净。长爪外道出家见法、得法、觉法、入法，度诸疑惑，不由他度，入正法律，得无所畏。即从座起，整衣服，为佛作礼，合掌白佛：“愿得于正法律出家、受具足，于佛法中修诸梵行。”
    佛告长爪外道出家：“汝得于正法律出家、受具足，成比丘分。”即得善来比丘出家。
    彼思惟所以善男子剃除须发，着袈裟衣，正信非家，出家学道，乃至心善解脱，得阿罗汉。
    佛说是经已，尊者舍利弗、尊者长爪闻佛所说，欢喜奉行。


杂阿含经卷第三十五

（九七○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时王舍城有外道出家名舍罗步，住须摩竭陀池侧，于自众中作如是唱言：“沙门释子法我悉知，我先已知彼法律而悉弃舍。”
    时有众多比丘晨朝着衣持钵，入王舍城乞食，闻有外道名舍罗步，住王舍城须摩竭陀池侧，于自众中作如是唱言：“沙门释子所有法律，我悉已知，先已知彼法律，然后弃舍。”闻是语已，乞食毕，还精舍，举衣钵，洗足已，往诣佛所，稽首礼足，退坐一面，白佛言：“世尊，我等晨朝着衣持钵，入王舍城乞食，闻有外道出家名舍罗步，住王舍城须摩竭陀池侧，于自众中作是唱言：‘沙门释子法，我已悉知，知彼法律已，然后弃舍。’善哉世尊！可自往彼须摩竭陀池侧，怜愍彼故。”
    尔时世尊默然而许，于日晡时从禅觉，往到须摩竭陀池侧，外道舍罗步所。时舍罗步外道出家遥见世尊来，即敷床座，请佛令坐。佛即就坐，告舍罗步言：“汝实作是语：沙门释子所有法律，我悉已知，知彼法律已，然后弃舍耶？”
    时舍罗步默而不答。
    佛告舍罗步：“汝今应说，何故默然？汝所知满足者，我则随喜。不满足者，我当令汝满足。”
    时舍罗步犹故默然。如是第二、第三说，彼再三默然住。
    时舍罗步有一梵行弟子，白舍罗步言：“师应往诣沙门瞿昙，说所知见，今沙门瞿昙自来诣此，何故不说？沙门瞿昙又告师言：‘若满足者，我则随喜。不满足者，当令满足。’何故默然而不记说？”
    彼舍罗步，梵行弟子劝时，亦复默然。
    尔时世尊告舍罗步：“若复有言：‘沙门瞿昙非如来、应、等正觉。’我若善谏善问，善谏善问时，彼则辽落，说诸外事；或忿恚慢覆，对碍不忍，无由能现；或默然抱愧，低头密自思省，如今舍罗步。若复作如是言：‘非沙门瞿昙无正法律’者，我若善谏善问，彼亦如汝今日，默然而住。若复有言：‘非沙门瞿昙声闻善向’者，我若善谏善问，彼亦乃至如汝今日，默然而住。”
    尔时世尊于须摩竭陀池侧，狮子吼已，从座起而去。
    尔时舍罗步梵行弟子语舍罗步言：“譬如有牛截其两角，入空牛栏中，跪地大吼；师亦如是，于无沙门瞿昙弟子众中，作狮子吼。譬如女人欲作丈夫声，发声即作女声；师亦如是，于非沙门瞿昙弟子众中，作狮子吼。譬如野干欲作狐声，发声还作野干声；师亦如是，于非沙门瞿昙弟子众中，欲作狮子吼。”
    时舍罗步梵行弟子，于舍罗步面前呵责毁呰已，从座起去。

（九七一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时王舍城须摩竭陀池侧，有外道出家名上座，住彼池侧，于自众中作如是语：“我说一偈，若能报者，我当于彼修行梵行。”
    时有众多比丘，晨朝着衣持钵，入王舍城乞食。闻有外道出家名曰上座，住须摩竭陀池侧，于自众中作如是说：“我说一偈，有能报者，我当于彼所修行梵行。”乞食毕，还精舍，举衣钵，洗足已，诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我今晨朝与众多比丘入城乞食，闻有外道出家名曰上座，住须摩竭陀池侧，于自众中作如是说：‘我说一偈，有能报者，我当于彼修行梵行。’唯愿世尊应自往彼，哀愍故！”
    尔时世尊默然而许，即日晡时从禅觉，往至须摩竭陀池侧。时上座外道出家遥见世尊，即敷床座，请佛令坐。世尊坐已，告上座外道出家言：“汝实作是语：我说一偈，若能报者，我当于彼修行梵行耶？汝今便可说偈，我能报答。”
    时彼外道即累绳床以为高座，自升其上，即说偈言：

“比丘以法活，不恐怖众生，
意寂行舍离，持戒顺息止。”

    尔时世尊知彼上座外道心，即说偈言：

“汝于所说偈，能自随转者，
我当于汝所，作善士夫观。
观汝今所说，言行不相应。
寂止自调伏，莫恐怖众生，
行意寂远离，受持净戒者；
顺调伏寂止，身口心离恶，
善摄于住处，不令放逸者，
是则名随顺，调伏及寂止。”

    尔时上座外道出家作是念：“沙门瞿昙已知我心。”即从床而下，合掌白佛言：“今我可得于正法律出家、受具足，成比丘法不？”
    佛告上座外道出家：“今汝可得于正法律出家、受具足，成比丘分。”
    如是上座外道出家，得出家作比丘已，思惟所以善男子剃除须发，着袈裟衣，正信非家，出家学道，乃至心善解脱，得阿罗汉。

（九七二）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有众多婆罗门出家住须摩竭陀池侧，集聚一处，作如是论：“如是婆罗门真谛，如是婆罗门真谛。”
    尔时世尊知彼众多婆罗门出家心念，往到须摩竭陀池侧。时众多婆罗门出家遥见佛来，即为佛敷床座，请佛就坐。佛即就坐，告诸婆罗门出家：“汝等于此须摩竭陀池侧，众共集聚，何所论说？”
    婆罗门出家白佛言：“瞿昙，我等众多婆罗门出家集于此坐，作如是论：如是婆罗门真谛，如是婆罗门真谛。”
    佛告婆罗门出家：“有三种婆罗门真谛，我自觉悟，成等正觉，而复为人演说。汝婆罗门出家作如是说：‘不害一切众生。’是婆罗门真谛，非为虚妄。彼于彼言我胜、言相似、言我卑，若于彼真谛不系著，于一切世间作慈心色像，是名第一婆罗门真谛，我自觉悟，成等正觉，为人演说。复次婆罗门作如是说：‘所有集法，皆是灭法。’此是真谛，非为虚妄。乃至于彼真谛不计著，于一切世间观察生灭，是名第二婆罗门真谛。复次婆罗门作如是说：‘无我处所及事都无所有。’无我处所及事都无所有，此则真谛，非为虚妄。如前说，乃至于彼无所系著，一切世间无我像类，是名第三婆罗门真谛，我自觉悟，成等正觉，而为人说。”
    尔时众多婆罗门出家默然住。
    时世尊作是念：“今映彼愚痴，杀彼恶者。今此众中，无一能自思量欲造因缘，于沙门瞿昙法中修行梵行。”如是知已，从座起而去。

（九七三）

    如是我闻。一时佛住拘睒弥国瞿师罗园。
    尊者阿难亦住于彼。
    时有外道出家名曰栴陀，诣尊者阿难所，与尊者阿难共相问讯慰劳已，退坐一面，问尊者阿难言：“何故于沙门瞿昙所出家修梵行？”
    阿难答言：“为断贪欲、瞋恚、愚痴故，于彼出家修梵行。”
    栴陀复问：“彼能说断贪欲、瞋恚、愚痴耶？”
    阿难答言：“我亦能说断贪欲、瞋恚、愚痴。”
    栴陀复问：“汝见贪欲、瞋恚、愚痴有何过患，说断贪欲、瞋恚、愚痴耶？”
    阿难答言：“染著贪欲映障心故，或自害、或复害他、或复俱害，现法得罪、后世得罪、现法后世二俱得罪，彼心常怀忧苦受觉。若瞋恚映障、愚痴映障，自害、害他、自他俱害，乃至常怀忧苦受觉。又复贪欲为盲、为无目、为无智、为慧力羸、为障碍，非明、非等觉，不转向涅槃。瞋恚、愚痴，亦复如是。我见贪欲、瞋恚、愚痴有如是过患故，说断贪欲、瞋恚、愚痴。”
    栴陀复问：“汝见断贪欲、瞋恚、愚痴有何福利，而说断贪欲、瞋恚、愚痴？”
    阿难答言：“断贪欲已，不自害，又不害他，亦不俱害，又复不现法得罪、后世得罪、现法后世得罪，心法常怀喜乐受觉。瞋恚、愚痴，亦复如是。于现法中，常离炽然，不待时节，有得余现法缘自觉知见。有如是功德利益故，说断贪欲、瞋恚、愚痴。”
    栴陀复问：“尊者阿难，有道有迹，修习多修习，能断贪欲、瞋恚、愚痴不？”
    阿难答言：“有，谓八正道，正见乃至正定。”
    栴陀外道白尊者阿难：“此是贤哉之道、贤哉之迹！修习多修习，能断贪欲、瞋恚、愚痴。”
    时栴陀外道闻尊者阿难所说，欢喜随喜，从座起而去。

（九七四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者舍利弗诣佛所，稽首佛足，退坐一面。
    尔时世尊为尊者舍利弗种种说法，示教照喜，示教照喜已，默然而住。
    时尊者舍利弗闻佛所说，欢喜随喜已，稽首礼足而去。
    时有外道出家补缕低迦，随路而来，问尊者舍利弗：“从何所来？”
    舍利弗答言：“火种，我从世尊所，听大师说教授法来。”
    补缕低迦问尊者舍利弗：“今犹不离乳，从师闻说教授法耶？”
    舍利弗答言：“火种，我不离乳，于大师所，闻说教授法。”
    补缕低迦语尊者舍利弗言：“我久已离乳，舍师所说教授法。”
    舍利弗言：“汝法是恶说法律、恶觉，非为出离、非正觉道，坏法、非可赞叹法、非可依止法，又彼师者非等正觉，是故汝等疾疾舍乳，离师教法。譬如乳牛，粗恶狂骚，又少乳汁，彼犊饮乳，疾疾舍去。如是恶说法律、恶觉，非出离、非正觉道，坏法、非可赞叹法、非可依止法，又彼师者非等正觉，是故速舍师教授法。我所有法是正法律，是善觉，是出离、正觉道，不坏、可赞叹、可依止，又彼大师是等正觉，是故久饮其乳，听受大师说教授法。譬如乳牛，不粗狂骚，又多乳汁，彼犊饮时，久而不厌。我法如是，是正法律，乃至久听说教授法。”
    时补缕低迦语舍利弗：“汝等快得善利！于正法律，乃至久听说教授法。”
    时补屡低迦外道出家闻舍利弗所说，欢喜随喜，从道而去。

（九七五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时补缕低迦外道出家来诣佛所，与世尊面相问讯慰劳已，退坐一面，白佛言：“瞿昙，先日众多种种异道出家沙门、婆罗门集于未曾有讲堂，作如是论议：‘沙门瞿昙智慧犹如空舍，不能于大众中建立论议：此应此不应，此合此不合。譬如盲牛，偏行边畔，不入中田。沙门瞿昙亦复如是，无应不应，无合不合。’”
    佛告补缕低迦：“此诸外道论说应不应、合不合，于圣法律如小儿戏。譬如士夫年八、九十，发白齿落，作小儿戏，团治泥土，作象作马，种种形类。众人皆言：‘此老小儿。’如是火种，种种诸论，谓应不应、合不合，于圣法律如小儿戏。然于彼中，无有比丘方便所应。”
    补缕低迦白佛言：“瞿昙，于何处有比丘方便所应？”
    佛告外道：“不清净者令其清净，是名比丘方便所应。不调令调，是名比丘方便所应。诸不定者令得正受，是名比丘方便所应。不解脱者令得解脱，是名比丘方便所应。不断令断、不知令知、不修令修、不得令得，是名比丘方便所应。云何不净令净？谓戒不净者，令其清净。云何不调伏令其调伏？谓眼根、耳、鼻、舌、身、意根不调伏，令其调伏，是名不调伏者令其调伏。云何不定令其正受？谓心不正定，令得正受。云何不解脱者令得解脱？谓心不解脱贪欲、恚、痴，令得解脱。云何不断令断？谓无明、有爱，不断令断。云何不知令知？谓其名色，不知令知。云何不修令修？谓止观，不修令修。云何不得令得？谓般涅槃，不得令得。是名比丘方便所应。”
    补缕低迦白佛言：“瞿昙，是义比丘方便所应，是坚固比丘方便所应，所谓尽诸有漏。”
    时补缕低迦外道出家闻佛所说，欢喜随喜，从座起而去。

（九七六）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有外道出家名曰尸婆，来诣佛所，与世尊面相问讯慰劳已，退坐一面，白佛言：“瞿昙，云何为学？所谓学者，云何学？”
    佛告尸婆：“学其所学，故名为学。”
    尸婆白佛：“何所学？”
    佛告尸婆：“随时学增上戒，学增上意，学增上慧。”
    尸婆白佛：“若阿罗汉比丘，诸漏已尽，所作已作，舍诸重担，逮得己利，尽诸有结，正智善解脱。当于尔时，复何所学？”
    佛告尸婆：“若阿罗汉比丘，诸漏已尽，乃至正智善解脱。当于尔时，觉知贪欲永尽无余，觉知瞋恚、愚痴永尽无余故，不复更造诸恶，常行诸善。尸婆，是名为学其所学。”
    时尸婆外道出家闻佛所说，欢喜随喜，从座起去。

（九七七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尸婆外道出家来诣佛所，与世尊面相问讯慰劳已，退坐一面，白佛言：“瞿昙，有一沙门、婆罗门作如是见、如是说：‘若人有所知觉，彼一切本所作因。修诸苦行，令过去业尽，更不造新业，断于因缘，于未来世无复诸漏，诸漏尽故业尽，业尽故苦尽，苦尽者究竟苦边。’今瞿昙所说云何？”
    佛告尸婆：“彼沙门、婆罗门，实尔洛漠说耳，不审、不数、愚痴、不善、不辨。所以者何？或从风起苦，众生觉知；或从痰起，或从涎唾起，或等分起；或自害，或他害，或因节气。彼自害者，或拔发，或拔须，或常立举手，或蹲地，或卧灰土中，或卧棘刺上，或卧杵上，或板上，或牛屎涂地而卧其上，或卧水中，或日三洗浴，或一足而立，身随日转，如是众苦精勤有行，尸婆，是名自害。他害者，或为他手、石、刀、杖等种种害身，是名他害。尸婆，若复时节所害，冬则大寒，春则大热，夏寒暑俱，是名节气所害。世间真实，非为虚妄。尸婆，世间有此真实，为风所害，乃至节气所害，彼众生如实觉知。汝亦自有此患，风、痰、涎唾，乃至节气所害觉，如是如实觉知。尸婆，若彼沙门、婆罗门言：‘一切人所知觉者，皆是本所造因。’舍世间真实事，而随自见，作虚妄说。
    “尸婆，有五因五缘，生心法忧苦。何等为五？谓因贪欲缠，缘贪欲缠，生彼心法忧苦；因瞋恚、睡眠、掉悔、疑缠，缘瞋恚、睡眠、掉悔、疑缠，生彼心法忧苦。尸婆，是名五因五缘，生心法忧苦。
    “尸婆，有五因五缘，不生心法忧苦。何等为五？谓因贪欲缠，缘贪欲缠，生彼心法忧苦者，离彼贪欲缠，不起心法忧苦；因瞋恚、睡眠、掉悔、疑缠，缘瞋恚、睡眠、掉悔、疑缠，生彼心法忧苦者，离彼瞋恚、睡眠、掉悔、疑缠，不起心法忧苦。尸婆，是名五因五缘，不起心法忧苦，现法得离炽然，不待时节，通达现见，缘自觉知。尸婆，复有现法离炽然，不待时节，通达现见，缘自觉知，谓八正道，正见乃至正定。”
    说是法时，尸婆外道出家远尘离垢，得法眼净。时尸婆外道出家见法、得法、知法、入法，离诸狐疑，不由于他，入正法律，得无所畏。即从座起，整衣服，合掌白佛：“世尊，我今可得于正法律出家、受具足，得比丘分耶？”
    佛告尸婆：“汝今得出家。”
    如上说，乃至心善解脱，得阿罗汉。

（九七八）

    如是我闻。一时佛住那罗聚落好衣庵罗园中。
    尔时那罗聚落，有商主外道出家，百二十岁，年耆根熟，为那罗聚落诸沙门、婆罗门、长者、居士尊重供养，如阿罗汉。
    彼商主外道出家先有宗亲一人，命终生天，于彼天上见商主外道出家已，作是念：“我欲往教彼商主外道出家诣世尊所，修行梵行，恐其不随我语，我今当往彼，以意论令问。”即下那罗聚落，诣彼商主外道出家所，说偈而问：

“云何恶知识，现善知识相？
云何善知识，如己同一体？
何故求于断？云何离炽然？

    “若汝仙人持此意论而问于彼，有能分别解说其义而答汝者，便可从彼出家，修行梵行。”
    时商主外道出家受天所教，持诣富兰那迦叶所，以此意论偈问富兰那迦叶，彼富兰那迦叶尚自不解，况复能答？彼时商主外道出家复至末迦梨瞿舍利子所、那阇耶毗罗坻子所、阿耆多枳舍钦婆罗所、迦罗拘陀迦栴延所、尼乾陀若提子所，皆以此意论偈而问，悉不能答。
    时商主外道出家作是念：“我以此意论问诸出家师，悉不能答，我今复欲求出家为？我今自有财宝，不如还家，服习五欲。”复作是念：“我今可往诣沙门瞿昙。然彼耆旧诸师、沙门、婆罗门，富兰那迦叶等，悉不能答，而沙门瞿昙年少出家，讵复能了？然我闻先宿所说，莫轻新学年少出家。或有沙门年少出家，有大德力，今且当诣沙门瞿昙。”诣已，以彼意论心念而问，如偈所说。
    尔时世尊知彼商主心之所念，即说偈言：

“云何恶知识，现善友相者？
内心实耻厌，口说我同心，
造事不乐同，故知非善友；
口说恩爱语，心不实相应，
所作而不同，慧者应觉知；
是名恶知识，现善知识相，
与己同一体。云何善知识，
与己同体者？非彼善知识，
放逸而不制，沮坏怀疑惑，
伺求其端绪；安于善知识，
如子卧父怀，不为傍人间，
当知善知识。何故求于断？
生欢喜之处，清凉称赞叹，
修习福利果，清凉永息灭，
是故求于断。云何离炽然？
寂静止息味，知彼远离味，
远离炽然恶，饮以法喜味，
寂灭离欲火，是名离炽然。”

    尔时商主外道出家作是念：“沙门瞿昙知我心念。”而白佛言：“我今得入沙门瞿昙正法律中修行梵行，出家受具足，成比丘分不？”
    佛告商主外道出家：“汝今可得于正法律修行梵行，出家受具足，成比丘分。”
    如是出家已，思惟乃至心善解脱，得阿罗汉。

（九七九）

    如是我闻。一时佛住俱夷那竭国力士生处坚固双树林中。
    尔时世尊涅槃时至，告尊者阿难：“汝为世尊于双树间，敷绳床北首，如来今日中夜于无余涅槃而般涅槃。”
    尔时尊者阿难奉教，于双树间敷绳床北首讫，来诣佛所，稽首佛足，退住一面，白佛言：“世尊，已于双树间，敷绳床北首。”
    尔时世尊诣双树间，于绳床上，北首右胁而卧，足足相累，系念明想，正念正智。
    时俱夷那竭国，有须跋陀罗外道出家，百二十岁，年耆根熟，为俱夷那竭国人恭敬供养，如阿罗汉。彼须跋陀罗出家闻世尊今日中夜当于无余涅槃而般涅槃：“然我有所疑，希望而住。沙门瞿昙有力能开觉我，我今当诣沙门瞿昙，问其所疑。”即出俱夷那竭，诣世尊所。
    尔时尊者阿难于园门外经行，时须跋陀罗语阿难言：“我闻沙门瞿昙今日中夜于无余涅槃而般涅槃。我有所疑，希望而住，沙门瞿昙有力能开觉我。若阿难不惮劳者，为我往白瞿昙，少有闲暇，答我所问。”
    阿难答言：“莫逼世尊，世尊疲极。”
    如是须跋陀罗再三请尊者阿难，尊者阿难亦再三不许。
    须跋陀罗言：“我闻古昔出家耆年大师所说，久久乃有如来、应、等正觉出于世间，如优昙钵花。而今如来中夜当于无余涅槃界而般涅槃。我今于法疑，信心而住，沙门瞿昙有力能开觉我，若阿难不惮劳者，为我白沙门瞿昙。”
    阿难复答言：“须跋陀罗，莫逼世尊，世尊今日疲极。”
    尔时世尊以天耳闻阿难与须跋陀罗共语来往，而告尊者阿难：“莫遮外道出家须跋陀罗，令入问其所疑。所以者何？此是最后与外道出家论议，此是最后得证声闻善来比丘，所谓须跋陀罗。”
    尔时须跋陀罗闻世尊为开善根，欢喜增上，诣世尊所，与世尊面相问讯慰劳已，退坐一面，白佛言：“瞿昙，凡世间入处，谓富兰那迦叶等六师，各作如是宗：此是沙门，此是沙门。云何瞿昙，为实各各有是宗不？”
    尔时世尊即为说偈言：

“始年二十九，出家修善道，
成道至于今，经五十余年。
三昧明行具，常修于净戒，
离斯少道分，此外无沙门。”

    佛告须跋陀罗：“于正法律不得八正道者，亦不得初沙门，亦不得第二、第三、第四沙门。须跋陀罗，于此法律得八正道者，得初沙门，得第二、第三、第四沙门。除此已，于外道无沙门，斯则异道之师，空沙门、婆罗门耳。是故我今于众中作狮子吼。”
    说是法时，须跋陀罗外道出家远尘离垢，得法眼净。尔时须跋陀罗见法、得法、知法、入法，度诸狐疑，不由他信，不由他度，于正法律得无所畏。从座起，整衣服，右膝着地，白尊者阿难：“汝得善利！汝得大师！为大师弟子，为大师法雨雨灌其顶。我今若得于正法律出家、受具足，得比丘分者，亦当得斯善利。”
    时尊者阿难白佛言：“世尊，是须跋陀罗外道出家今求于正法律出家、受具足，得比丘分。”
    尔时世尊告须跋陀罗：“此比丘来，修行梵行！”
    彼尊者须跋陀罗即于尔时出家，即是受具足，成比丘分。如是思惟，乃至心善解脱，得阿罗汉。时尊者须跋陀罗得阿罗汉解脱乐，觉知已，作是念：“我不忍见佛般涅槃，我当先般涅槃。”
    时尊者须跋陀罗先般涅槃已，然后世尊般涅槃。

（九八○）

    如是我闻。一时佛在跋耆人间游行，至毗舍离国，住猕猴池侧重阁讲堂。
    时毗舍离国有众多贾客，欲向怛刹尸罗国，方便庄严。是众多贾客闻世尊于跋耆人间游行，至毗舍离国，住猕猴池侧重阁讲堂。闻已来诣佛所，稽首佛足，退坐一面。
    佛为诸贾客种种说法，示教照喜，示教照喜已，默然而住。
    时诸贾客从座起，整衣服，为佛作礼，合掌白佛言：“世尊，我等诸贾客方便庄严，欲至怛刹尸罗国。唯愿世尊与诸大众，明旦受我供养。”
    尔时世尊默然而许。
    时诸贾客知世尊受请已，从座起，礼佛足，各还自家，办种种净美饮食，敷床座，安置净水。晨朝遣使，白佛时到。
    尔时世尊与诸大众，着衣持钵，诣诸贾客所，就座而坐。时诸贾客以净美饮食，自手供养。食毕洗钵讫，取卑小床，于大众前坐，听佛说法。
    尔时世尊告诸贾客：“汝等当行于旷野中，有诸恐怖，心惊毛竖。尔时当念如来事：谓如来、应、等正觉，乃至佛、世尊。如是念者，恐怖则除。又念法事：佛正法律，现法能离炽然，不待时节，通达亲近，缘自觉知。又念僧事：世尊弟子，善向、正向，乃至世间福田。如是念者，恐怖即除。
    “过去世时，天、阿须伦共斗。时天帝释告诸天众：‘汝等与阿须伦共斗战之时，生恐怖者，当念我幢，名摧伏幢。念彼幢时，恐怖得除。若不念我幢者，当念伊舍那天子幢。若不念伊舍那天子幢者，当念婆留那天子幢。念彼幢时，恐怖即除。’如是诸商人，汝等于旷野中有恐怖者，当念如来事、法事、僧事。”
    尔时世尊为诸毗舍离贾客，说供养随喜偈：

“供养比丘僧，饮食随时服，
专念谛思惟，正智而行舍。
净物良福田，汝等悉具足，
缘斯功德利，长夜获安乐，
发心有所求，众利悉皆应。
两足四足安，道路往来安，
夜安昼亦安，一切离诸恶。
如沃壤良田，精纯好种子，
溉灌以时泽，收实不可量。
净戒良福田，精肴膳种子，
正行以将顺，终期妙果成。
是故行施者，欲求备众德，
当随智慧行，众果自然备。
于明行足尊，正心尽恭敬，
种植众善本，终获大福利。
如实知世间，得具备正见，
具足见正道，具足而升进，
远离一切垢，逮得涅槃道，
究竟于苦边，是名备众德。”

    尔时世尊为诸毗舍离贾客，说种种法，示教照喜已，从座起去。

（九八一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若比丘住于空闲、树下、空舍，有时恐怖，心惊毛竖者，当念如来事及法事、僧事，如前广说。念如来事、法事、僧事之时，恐怖即除。
    “诸比丘，过去世时，释提桓因与阿修罗共战。尔时帝释语诸三十三天言：‘诸仁者！诸天与阿修罗共斗战时，若生恐怖，心惊毛竖者，汝当念我伏敌之幢。念彼幢时，恐怖即除。’如是比丘，若于空闲、树下、空舍，而生恐怖，心惊毛竖者，当念如来：如来、应、等正觉，乃至佛、世尊。彼当念时，恐怖即除。所以者何？彼天帝释，怀贪、恚、痴，于生老病死、忧悲恼苦不得解脱，有恐怖、畏惧、逃窜、避难，而犹告诸三十三天，令念我摧伏敌幢。况复如来、应、等正觉乃至佛、世尊，离贪、恚、痴，解脱生老病死、忧悲恼苦，无诸恐怖、畏惧、逃避，而不能令其念如来者除诸恐怖？”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（九八二）

    如是我闻。一时佛住娑枳国安阇那林中。
    尔时世尊告尊者舍利弗：“我能于法略说、广说，但知者难。”
    尊者舍利弗白佛言：“唯愿世尊略说、广说、法说，于法实有解知者。”
    佛告舍利弗：“若有众生，于自识身及外境界一切相，无我、我所、我慢系著使，乃至心解脱、慧解脱，现法自知作证具足住者，于此识身及外境界一切相，无有我、我所、我慢使系著故，我心解脱、慧解脱，现法自知作证具足住。舍利弗，彼比丘于此识身及外境界一切相，无有我、我所见、我慢系著使，及心解脱、慧解脱，现法自知作证具足住，于此识身及外境界一切相，无有我、我所见、我慢系著使，彼心解脱、慧解脱，现法自知作证具足住。舍利弗，若复比丘于此识身及外境界一切相，无有我、我所见、我慢系著使，彼心解脱、慧解脱，现法自知作证具足住。舍利弗，若复比丘于此识身及外境界一切相，无我、我所见、我慢系著使，及心解脱、慧解脱，现法自知作证具足住，于此识身及外境界一切相，无我、我所见、我慢系著使，彼心解脱、慧解脱，现法自知作证具足住。舍利弗，是名比丘断爱缚结、慢无间等，究竟苦边。
    “舍利弗，我于此有余说，答波罗延富邻尼迦所问：

“世间数差别，安所遇不动，
寂静离诸尘，拔根无悕望，
已度三有海，无复老死患。”

    佛说是经已，尊者舍利弗闻佛所说，欢喜随喜，即从座起，作礼而去。

（九八三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者阿难住舍卫国祇树给孤独园，独一静处，如是思惟：“或有一人作如是念：我于此识身及外境界一切相，无有我、我所见、我慢系著使，及心解脱、慧解脱，现法自知作证具足住。于此识身及外境界一切相，无有我、我所见、我慢系著使，我当于彼心解脱、慧解脱，现法自知作证具足住。”
    尔时尊者阿难，晡时从禅觉，诣世尊所，稽首礼足，退坐一面，白佛言：“世尊，我独一静处，作是思惟：‘若有一人作如是言：我此识身及外境界一切相，乃至自知作证具足住。’”
    佛告阿难：“如是如是。若有一人作如是念：我此识身及外境界一切相，无有我、我所见、我慢系著使，及心解脱、慧解脱，现法自知作证具足住。阿难，彼比丘于此识身及外境界一切相，无有我、我所见、我慢系著使，及心解脱、慧解脱，现法自知作证具足住；于此识身及外境界一切相，无有我、我所见、我慢系著使，及彼心解脱、慧解脱，现法自知作证具足住。阿难，若复比丘于此识身及外境界一切相，乃至自知作证具足住，是名比丘断爱缚结、慢无间等，究竟苦边。
    “阿难，我于此有余说，答波罗延忧陀耶所问：

“断于爱欲想，忧苦亦俱离，
觉悟于睡眠，灭除掉悔盖，
舍念恚清净，现前观察法，
我说智解脱，灭除无明暗。”

    佛说是经已，尊者阿难闻佛所说，欢喜随喜，作礼而去。

（九八四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当说爱为网、为胶、为泉、为藕根，此等能为众生障碍、为盖、为胶、为守卫、为覆、为闭、为塞、为暗冥、为狗肠、为乱草、为絮，从此世至他世，从他世至此世，往来流转，无不转时。诸比丘，何等爱为网、为胶，乃至往来流转，无不转时？谓有我故，有我、欲我，尔时有我、无我、异我、当我、不当我、欲我，当尔时当异异我、或欲我、或尔我、或异、或然、或欲然、或尔然、或异，如是十八爱行从内起。比丘言有我，于诸所有言我欲、我尔，乃至十八爱行从外起，如是总说十八爱行。如是三十六爱行，或于过去起，或于未来起，或于现在起，如是总说百八爱行。是名为爱为网、为胶、为泉、为藕根，能为众生障、为盖、为胶、为守卫、为覆、为闭、为塞、为暗冥、为狗肠、为乱草、为絮，从此世至他世，从他世至此世，往来流转，无不转时。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（九八五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有从爱生爱，从爱生恚，从恚生爱，从恚生恚。
    “云何为从爱生爱？谓有一于众生有喜、有爱、有念、有可意，他于彼有喜、有爱、有念、有可意随行。此作是念：‘我于彼众生有喜、有爱、有念、有可意，他复于彼有喜、有爱、有念、有可意随行故，我于他人复生于爱。’是名从爱生爱。
    “云何从爱生恚？谓有一于众生有喜、有爱、有念、有可意，而他于彼不喜、不爱、不念、不可意随行。此作是念：‘我于众生有喜、有爱、有念、有可意，而他于彼不喜、不爱、不念、不可意随行故，我于他而生瞋恚。’是名从爱生恚。
    “云何为从恚生爱？谓有一于众生不喜、不爱、不念、不可意，他复于彼不喜、不爱、不念、不可意随行故，我于他而生爱念，是名从恚生爱。
    “云何从恚生恚？谓有一于众生不喜、不爱、不念、不可意，而他于彼有喜、有爱、有念、有可意随行。此作是念：‘我于彼众生不喜、不爱、不念、不可意，而他于彼有喜、有爱、有念、有可意随行，我于他所问起瞋恚。’是名从恚生恚。
    “若比丘离欲恶不善法，有觉有观，乃至初禅、第二、第三、第四禅具足住者，从爱生爱、从恚生恚、从恚生爱、从爱生恚已断已知，断其根本，如截多罗树头，无复生分，于未来世成不生法。若彼比丘尽诸有漏，无漏心解脱、慧解脱，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。当于尔时，不自举，不起尘，不炽然，不嫌彼。
    “云何自举？谓见色是我、色异我、我中色、色中我；受、想、行、识，亦复如是，是名自举。云何不自举？谓不见色是我、色异我、我中色、色中我；受、想、行、识，亦复如是，是名不自举。云何还举？谓于骂者还骂，瞋者还瞋，打者还打，触者还触，是名还举。云何不还举？谓于骂者不还骂，瞋者不还瞋，打者不还打，触者不还触，是名不还举。云何起尘？谓有我、我欲，乃至十八种爱，是名起尘。云何不起尘？谓无我、无我欲，乃至十八爱不起，是名不起尘。云何炽然？谓有我所、我所欲，乃至外十八爱行，是名炽然。云何不炽然？谓无我所、无我所欲，乃至无外十八爱行，是名不炽然。云何嫌彼？谓见我真实，起于我慢、我欲、我使，不断不知，是名嫌彼。云何不嫌彼？谓不见我真实，我慢、我欲、我使已断已知，是名不嫌彼。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九八六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有二事断难持。何等为二？若俗人处、非人处，于衣、食、床卧、资生众具，持彼断者，是则难行。又比丘非家出家，断除贪爱，持彼断者，亦甚难行。”
    尔时世尊即说偈言：

“世间有二事，持断则难行，
是真谛所说，等正觉所知。
在家财入出，衣食等众具，
世间贪爱乐，持断者甚难。
比丘已离俗，信非家出家，
灭除于贪爱，持断亦难行。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九八七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我于二法依止多住。云何为二？于诸善法未曾知足，于断未曾远离。于善法不知足故，于诸断法未曾远离故，乃至肌消肉尽，筋连骨立，终不舍离精勤方便，不舍善法，不得未得，终不休息，未曾于劣心生欢喜，常乐增进，升上上道。如是精进住故，疾得阿耨多罗三藐三菩提等。比丘，当于二法依止多住，于诸善法不生足想，依于诸断未曾舍离，乃至肌消肉尽，筋连骨立，精勤方便堪能，修习善法不息。是故比丘，于诸下劣勿生欢喜想，当修上上升进。多住如是修习，不久当得速尽诸漏，无漏心解脱、慧解脱，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九八八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时释提桓因，形色绝妙，于后夜时，来诣佛所，稽首佛足，退住一面。天身威力，光明遍照迦兰陀竹园。
    时释提桓因白佛言：“世尊！世尊曾于隔界山石窟中说言：‘若有沙门、婆罗门，无上爱尽解脱、心善解脱，彼边际究竟、边际离垢、边际梵行毕竟。’云何为比丘边际究竟、边际离垢、边际梵行毕竟？”
    佛告天帝释：“谓比丘若所有受觉，若苦、若乐、若不苦不乐，彼诸受集、受灭、受味、受患、受出如实知。如实知已，观察彼受无常、观生灭、观离欲、观灭尽、观舍。如是观察已，则边际究竟、边际离垢、边际梵行毕竟。拘尸迦，是名比丘于正法律，边际究竟、边际离垢、边际梵行毕竟。”
    乃至天帝释闻佛所说，欢喜随喜，作礼而去。

（九八九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者大目揵连住耆阇崛山，后夜起经行，见有光明遍照迦兰陀竹园。见已作是念：“今夜或有大力鬼神诣世尊所，故有此光明。”
    时尊者大目揵连，晨朝往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我于昨暮后夜，出房经行，见胜光明普照迦兰陀竹园。见已作是念：有何大力鬼神诣世尊所，故有此光明？”
    佛告尊者大目揵连：“昨暮后夜，释提桓因来诣我所，稽首作礼，退坐一面。”
    如上修多罗广说，欢喜随喜，作礼而去。

（九九○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者阿难，晨朝着衣持钵，诣舍卫城，次第乞食，至鹿住优婆夷舍。
    鹿住优婆夷遥见尊者阿难，疾敷床座，白言：“尊者阿难令坐。”
    时鹿住优婆夷稽首礼阿难足，退住一面，白尊者阿难：“云何言世尊知法？我父富兰那，先修梵行，离欲清净，不着香花，远诸凡鄙。叔父梨师达多，不修梵行，然其知足。二俱命终，而今世尊俱记二人同生一趣，同一受生，同于后世得斯陀含，生兜率天，一来世间，究竟苦边。云何阿难，修梵行、不修梵行，同生一趣，同一受生，同其后世？”
    阿难答言：“姊妹，汝今且停，汝不能知众生世间根之差别。如来悉知众生世间根之优劣。”如是说已，从座起去。
    时尊者阿难还精舍，举衣钵，洗足已，往诣佛所，稽首佛足，退坐一面，以鹿住优婆夷所说广白世尊。
    佛告阿难：“彼鹿住优婆夷云何能知众生世间根之优劣？阿难，如来悉知众生世间根之优劣。阿难，或有一犯戒，彼于心解脱、慧解脱不如实知，彼所起犯戒无余灭、无余没、无余欲尽。或有一犯戒，于心解脱、慧解脱如实知，彼所起犯戒无余灭、无余没、无余欲尽。于彼筹量者言：‘此亦有如是法，彼亦有是法，此则应俱同生一趣，同一受生，同一后世。’彼如是筹量者，得长夜非义饶益苦。阿难，彼犯戒者，于心解脱、慧解脱不如实知，彼所起犯戒无余灭、无余没、无余欲尽，当知此人是退非胜进，我说彼人为退分。阿难，有犯戒，彼于心解脱、慧解脱如实知，彼于所起犯戒无余灭、无余没、无余欲尽，当知是人胜进不退，我说彼人为胜进分。自非如来，此二有间，谁能悉知？是故阿难，莫筹量人人而取人，善筹量人人而病人。筹量人人，自招其患，唯有如来能知人耳。如二犯戒，二持戒亦如是，彼于心解脱、慧解脱不如实知，彼所起持戒无余灭；若掉动者，彼于心解脱、慧解脱不如实知，彼所起掉无余灭；彼若瞋恨者，彼于心解脱、慧解脱不如实知，彼所起瞋恨无余灭；若苦贪者，彼于心解脱、慧解脱如实知，彼所起苦贪无余灭；秽污、清净如上说，乃至如来能知人人。阿难，鹿住优婆夷愚痴少智，而于如来一向说法心生狐疑。云何阿难，如来所说岂有二耶？”
    阿难白佛：“不也，世尊。”
    佛告阿难：“善哉善哉！如来说法若有二者，无有是处。阿难，若富兰那持戒，梨师达多亦同持戒者，所生之趣，富兰那所不能知：梨师达多为生何趣？云何受生？云何后世？若梨师达多所成就智，富兰那亦成就此智者，梨师达多亦不能知：彼富兰那当生何趣？云何受生？后世云何？阿难，彼富兰那持戒胜，梨师达多智慧胜，彼俱命终，我说二人同生一趣，同一受生，后世亦同，是斯陀含，生兜率天，一来生此，究竟苦边。彼二有间，自非如来，谁能得知？是故阿难，莫量人人，量人人者，自生损减，唯有如来能知人耳。”
    佛说此经已，尊者阿难闻佛所说，欢喜奉行。

（九九一）

    如是我闻。一时佛住释氏弥城留利邑夏安居。
    有余比丘于舍卫国祇树给孤独园夏安居，时彼比丘于晨朝着衣持钵，入舍卫城乞食，次第至鹿住优婆夷舍。
    鹿住优婆夷遥见比丘来，疾敷床座，请比丘令坐，如上阿难修多罗说。
    时彼比丘语鹿住优婆夷：“姊妹且停，汝哪得知众生根之优劣！姊妹，唯有如来能知众生根之优劣。”如是说已，从座起去。
    时彼比丘三月夏安居讫，作衣竟，持衣钵，往诣弥城留利释氏邑。到已，举衣钵，洗足已，往诣佛所，稽首佛足，退坐一面，以共鹿住优婆夷所论说事，向佛广说。
    佛告比丘：“鹿住优婆夷云何能知世间众生诸根优劣？唯有如来能知世间众生诸根优劣耳。不离瞋恨、骄慢，时起贪法，不听受法，不学多闻，于法不调伏见，不能时时起解脱心法。比丘，若复有一不离瞋慢，时起贪法，然彼闻法，修学多闻，于善调伏见，时时能起解脱心法。若思量彼：‘此有是法，彼有是法，此则同一趣，同一受生，同一后世。’如是思量者，长得非义不饶益苦。比丘，若复彼人不离瞋慢，时时起贪法，亦不听法，不习多闻，不调伏见，亦不时时得解脱心法，我说此人卑鄙下贱。比丘，若复彼人不离瞋慢，时时起贪法，然彼闻法，乐多闻，调伏诸见，时时能得解脱心法，我说是人第一胜妙。彼二有间，自非如来，谁能别知？是故比丘，莫量人人，乃至如来能知优劣。比丘，复次有一不离瞋慢，时时起口恶行，余如上说。
    “比丘，复次有一贤善，安乐同止，欣乐明智，修梵行者乐与同止，而彼不乐闻法，乃至不时时得心法解脱，当知彼人住贤善地，不能转进。贤善地者，谓人、天趣。复次有一其性贤善，同止安乐，欣乐梵行以为伴侣，乐闻正法，学习多闻，善调伏见，时时能得解脱心法，当知彼人于贤善地能转胜进，当知此人于正法流有所堪能。此二有间，自非如来，谁能别知？是故比丘，莫量人人，量人人者，自招其患，唯有如来能知人耳。比丘，鹿住优婆夷愚痴少智，如上修多罗广说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（九九二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时给孤独长者来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，世间有几种福田？”
    佛告长者：“世间有二种福田。何等为二？学及无学。”
    即说偈言：

“世有学无学，大会常延请，
正直心真实，身口亦复然，
是则良福田，施者获大果。”

    佛说此经已，给孤独长者闻佛所说，欢喜奉行。


杂阿含经卷第三十六

（九九三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有诸上座比丘随佛左右，依止而住，所谓尊者阿若憍陈如、尊者摩诃迦叶、尊者舍利弗、尊者摩诃目揵连、尊者阿那律陀、尊者二十亿耳、尊者陀罗骠摩罗子、尊者婆那迦婆娑、尊者耶舍舍罗迦毗诃利、尊者富楼那、尊者分陀檀尼迦，如此及余上座比丘，随佛左右，依止而住。
    时尊者婆耆舍住舍卫国东园鹿子母讲堂。时尊者婆耆舍作是念：“今日世尊在舍卫国祇树给孤独园，诸上座比丘随佛左右，依止而住。我今当往至世尊所，各各说偈，叹诸上座比丘。”作是念已，往诣佛所，稽首佛足，退住一面，而说偈言：

“上上座比丘，已断诸贪欲，
超过诸世间，一切之积聚，
深智少言说，勇猛勤方便，
道德净明显，我今稽首礼。
已伏诸魔怨，远离于群聚，
不为五欲缚，常习于空闲，
清虚而寡欲，我今稽首礼。
遮罗延胜族，禅思不放逸，
内心乐正受，清净离尘秽，
辩慧显深义，是故稽首礼。
所得神通慧，超诸神通力，
六神通众中，自在无所畏，
神通最胜故，是故稽首礼。
于大千世界，五道诸趣生，
乃至于梵世，人天优劣想，
净天眼悉见，是故稽首礼。
精勤方便力，断除诸爱集，
坏裂生死网，心常乐正法，
离诸悕望想，超度于彼岸，
清净无尘秽，是故稽首礼。
永离诸恐畏，无依离财物，
知足度疑惑，伏诸魔怨敌，
身念观清净，是故稽首礼。
无有诸世间，烦恼棘刺林，
结缚使永除，三有因缘断，
精练灭诸垢，究竟明显现，
于林离林去，是故稽首礼。
无舍宅所依，幻伪痴恚灭，
调伏诸爱喜，出一切见处，
清净无瑕秽，是故稽首礼。
其心自在转，坚固不倾动，
智慧大德力，难伏魔能伏，
断除无明结，是故稽首礼。
大人离暗冥，寂灭牟尼尊，
正法离垢过，光明自显照，
照一切世界，是故名为佛。
地神虚空天，三十三天子，
光明悉映障，是故名为佛。
度生死有边，超逾越群众，
柔弱善调伏，正觉第一觉。
断一切结缚，伏一切异道，
降一切魔怨，得无上正觉，
离尘灭诸垢，是故稽首礼。”

    尊者婆耆舍偈赞叹时，诸比丘闻其所说，皆大欢喜。

（九九四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时尊者婆耆舍住舍卫国东园鹿子母讲堂，疾病困笃。尊者富邻尼为看病人，供给供养。
    时尊者婆耆舍语尊者富邻尼言：“汝往诣世尊所，持我语白世尊言：‘尊者婆耆舍稽首世尊足，问讯世尊，少病少恼，起居轻利，得自安乐住不？’复作是言：‘尊者婆耆舍住东园鹿子母讲堂，疾病困笃，欲求见世尊，无力方便堪诣世尊。善哉世尊，愿往至东园鹿子母讲堂尊者婆耆舍所，哀愍故！’”
    时尊者富邻尼即受其语，往诣世尊，稽首佛足，退坐一面，作是言：“尊者婆耆舍住东园鹿子母讲堂，疾病困笃，愿见世尊，无力方便堪能奉见。善哉世尊，愿往东园鹿子母讲堂尊者婆耆舍所，为哀愍故！”
    尔时世尊默然而许。
    时尊者富邻尼知佛许已，即从座起，礼佛足而去。
    世尊晡时从禅起，往诣尊者婆耆舍。尊者婆耆舍遥见世尊，凭床欲起。尔时世尊见尊者婆耆舍凭床欲起，语言：“婆耆舍，莫自轻动。”世尊即坐，问尊者婆耆舍：“汝所患苦，为平和可堪忍不？身诸苦痛，为增为损？”
    如前《焰摩迦修多罗》广说，乃至“我所苦患，转觉其增，不觉其损”。
    佛告婆耆舍：“我今问汝，随意答我。汝得心不染、不著、不污、解脱，离诸颠倒不？”
    婆耆舍白佛言：“我心不染、不著、不污、解脱，离诸颠倒。”
    佛告婆耆舍：“汝云何得心不染、不著、不污、解脱，离诸颠倒？”
    婆耆舍白佛言：“我过去眼识于色心不顾念，于未来色不欣想，于现在色不著。我过去、未来、现在眼识于色贪欲爱乐念，于彼得尽，无欲、灭、没、息、离、解脱。心解脱已，是故不染、不著、不污，离诸颠倒，正受而住。如是耳、鼻、舌、身、意识，过去于法心不顾念，未来不欣，现在不著。过去、未来、现在法中，念欲爱尽，无欲、灭、没、息、离、解脱。心解脱已，是故不染、不著、不污、解脱，离诸颠倒，正受而住。唯愿世尊，今日最后饶益于我，听我说偈！”
    佛告婆耆舍：“宜知是时。”
    尊者婆耆舍起，正身端坐，系念在前，而说偈言：

“我今住佛前，稽首恭敬礼。
于一切诸法，悉皆得解脱，
善解诸法相，深信乐正法。
世尊等正觉，世尊为大师，
世尊降魔怨，世尊大牟尼。
灭除一切使，自度群生类，
世尊于世间，诸法悉觉知。
世间悉无有，知法过佛者，
于诸天人中，亦无与佛等。
是故我今日，稽首大精进，
稽首士之上，拔诸爱欲刺。
我今是最后，得见于世尊，
稽首日种尊，暮当般涅槃。
正智系正念，于此朽坏身，
余势之所起，从今夜永灭，
三界不复染，入无余涅槃。
苦受及乐受，亦不苦不乐，
从触因缘生，于今悉永断。
苦受及乐受，亦不苦不乐，
从触因缘生，于今悉已知。
若内及与外，苦乐等诸受，
于受无所著，正智正系心。
于初中最后，诸聚无障碍，
诸聚既已断，了知受无余。
明见真实者，说九十一劫，
三劫中不空，有大仙人尊，
余空无洲依，唯畏恐怖劫。
当知大仙人，乃复出于世，
安慰诸天人，开眼离尘冥，
示悟诸众生，令觉一切苦。
苦苦及苦集，越苦之寂灭，
贤圣八正道，安隐趣涅槃。
世间难得者，现前悉皆得，
生世得人身，演说于正法，
随己之所欲，离垢求清净，
专修其己利，勿令空无果，
空过则生忧，邻于地狱苦。
于所说正法，不乐不欲受，
当久处生死，轮回息无期，
长夜怀忧悔，如商人失财。
我今众庆集，无复生老死，
轮回悉已断，不复重受生。
爱识河水流，于今悉枯竭，
已拔阴根本，连锁不相续。
供养大师毕，所作者已作，
重担悉已舍，有流悉已断，
不复乐受生，亦无死可恶，
正智正系念，唯待终时至。
念空野龙象，六十雄猛兽，
一旦免枷锁，逸乐山林中。
婆耆舍亦然，大师口生子，
厌舍于徒众，正念待时至。
今告于汝等，诸来集会者，
听我最后偈，其义所饶益。
生者悉归灭，诸行无有常，
速生速死法，何可久依怙！
是故强其志，精勤方便求，
观察有恐怖，随顺牟尼道，
速尽此苦阴，勿复增轮转。
佛口所生子，叹说此偈已，
长辞于大众，婆耆舍涅槃，
彼以慈悲故，说此无上偈。
尊者婆耆舍，如来法生子，
垂心哀愍故，说此无上偈，
然后般涅槃，一切当敬礼。”

（九九五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子而说偈问佛：

“阿练若比丘，住于空闲处，
寂静修梵行，于一坐而食，
以何因缘故，颜色特鲜明？”

    尔时世尊说偈答言：

“于过去无忧，未来不欣乐，
现在随所得，正智系念持，
饭食系念故，颜色常鲜泽。
未来心驰想，过去追忧悔，
愚痴火自煎，如雹断生草。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（九九六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“不欲起骄慢，善自调其心，
未曾修寂默，亦不入正受，
处林而放逸，不度死彼岸。”

    尔时世尊说偈答言：

“已离于骄慢，心常入正受，
明智善分别，解脱一切缚。
独一处闲林，其心不放逸，
于彼死魔怨，疾得度彼岸。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（九九七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“云何得昼夜，功德常增长？
云何得生天？唯愿为解说。”

    尔时世尊说偈答言：

“种植园果故，林树荫清凉；
桥船以济度，造作福德舍；
穿井供渴乏，客舍给行旅；
如此之功德，日夜常增长。
如法戒具足，缘斯得生天。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（九九八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“施何得大力？施何得妙色？
施何得安乐？施何得明目？
修习何等施，名曰一切施？
今启问世尊，愿为分别说。”

    尔时世尊说偈答言：

“施食得大力，施衣得妙色，
施乘得安乐，施灯得明目。
虚馆以待宾，是名一切施。
以法而诲彼，是则施甘露。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（九九九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子名悉鞞梨，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“诸天及世人，于食悉欣乐，
颇有诸世间，福乐自随逐？”

    尔时世尊说偈答言：

“净信心惠施，此世及后世，
随其所至处，福报常影随。
是故当舍悭，行无垢惠施，
施已心欢喜，此世他世受。”

    时彼悉鞞梨天子白佛言：“奇哉世尊！善说斯义：

“净信心惠施，此世及他世，
随其所至处，福报常影随。
是故当舍悭，行无垢惠施，
施已心欢喜，此世他世受。”

    悉鞞梨天子白佛言：“世尊，我自知过去世时曾为国王，名悉鞞梨，于四城门普施为福；于其城内有四交道，亦于其中布施作福。时有第一夫人来语我言：‘大王大作福德，而我无力修诸福业。’我时告言：‘城东门外布施作福，悉皆属汝。’时诸王子复来白我：‘大王多作功德，夫人亦同，而我无力作诸福业，我今愿得依于大王少作功德。’我时答言：‘城南门外所作施福，悉皆属汝。’时有大臣复来白我：‘今日大王多作功德，夫人、王子悉皆共之，而我无力作诸福业，愿依大王少有所作。’我时告言：‘城西门外所作施福，悉皆属汝。’时诸将士复来白我：‘今日大王多作功德，夫人、太子及诸大臣悉皆共之，唯我无力能修福业，愿依大王得有所作。’我时答言：‘城北门外所作施福，悉皆属汝。’国中庶民复来白我：‘今日大王多作功德，夫人、王子、大臣、诸将悉皆共之，唯我无力不能修福，愿依大王少有所作。’我时答言：‘于其城内四交道头所作施福，悉属汝等。’尔时国王夫人、王子、大臣、将士、庶民悉皆惠施，作诸功德，我先所作惠施功德，于兹则断。时我所使诸作福者，还至我所，为我作礼，而白我言：‘大王当知，诸修福处，夫人、王子、大臣、将士，及诸庶民，各据其处，行施作福。大王所施，于兹则断。’我时答言：‘善男子，诸方边国岁输财物应入我者，分半入库，分其半分，即于彼处惠施作福。’彼闻教旨，往诣边国，集诸财物，半送于库，半留于彼，惠施作福。
    “我先长夜如是惠施作福，长夜常得可爱、可念、可意福报，常受快乐，无有穷极。以斯福业及福果、福报，悉皆入于大功德聚数。譬如五大河合为一流，所谓恒河、耶蒲那、萨罗由、伊罗跋提、摩醯，如是五河合为一流，无有人能量其河水，百千万亿斗斛之数，彼大河水得为大水聚数。我亦如是，所作功德果、功德报，不可称量，悉得入于大功德聚数。”
    尔时悉鞞梨天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○○○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，皆悉遍照祇树给孤独园。
    时彼天子说偈问佛：

“何等人能为，远游善知识？
何等人能为，居家善知识？
何等人能为，通财善知识？
何等人能为，后世善知识？”

    尔时世尊以偈答言：

“商人之导师，游行善知识。
贞祥贤良妻，居家善知识。
宗亲相习近，通财善知识。
自所修功德，后世善知识。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○○一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“冥运持命去，故令人短寿，
为老所侵迫，而无救护者。
睹斯老病死，令人大恐怖，
唯作诸功德，乐往至乐所。”

    尔时世尊说偈答言：

“冥运持命去，故令人短寿，
为老所侵迫，而无救护者。
观此有余过，令人大恐怖，
当断世贪爱，无余涅槃乐。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○○二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“断除于几法？几法应弃舍？
而复于几法，增上方便修？
几聚应超越，比丘度驶流？”

    尔时世尊说偈答言：

“断除五舍五，增修于五根，
超越五和合，比丘度流渊。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○○三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“几人于觉眠？几人于眠觉？
几人取尘垢？几人得清净？”

    尔时世尊说偈答言：

“五人于觉眠，五人于眠觉，
五人取于垢，五人得清净。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○○四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“母子更相喜，牛主乐其牛，
众生乐有余，无乐无余者。”

    尔时世尊说偈答言：

“母子更相忧，牛主忧其牛，
有余众生忧，无余则无忧。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○○五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“何等人之物？何名第一伴？
以何而活命？众生何处依？”

    尔时世尊说偈答言：

“田宅众生有，贤妻第一伴，
饮食已存命，业为众生依。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○○六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“所爱无过子，财无贵于牛，
光明无过日，萨罗无过海。”

    尔时世尊说偈答言：

“爱无过于己，财无过于谷，
光明无过慧，萨罗无过见。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○○七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，来诣佛所，稽首礼足。身诸光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“刹利两足尊，犎牛四足胜，
童英为上妻，贵生为上子。”

    尔时世尊说偈答言：

“正觉两足尊，生马四足胜，
顺夫为贤妻，漏尽子之上。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○○八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“从地起众生，何者为最胜？
于空堕落者，复以何胜上？
凡所祈请处，何者最第一？
于诸言语中，何者为上辩？”

    时有一天子，本为田家子，今得生天上。以本习故，即便说偈答彼天子：

“五谷从地生，是则为最胜。
种子于空中，落地为最胜。
犎牛资养人，是则依中胜。
爱子有所说，是则言中胜。”

    彼发问天子语答者言：“我不问汝，何故多言轻躁妄说？我自说偈问世尊言：

“从地起众生，何者为最胜？
于空堕地者，复以何为胜？
凡所祈请处，何者为最胜？
于诸言语中，何者为上辩？”

    尔时世尊说偈答言：

“从下踊出者，三明为最上。
从空流下者，三明亦第一。
贤圣弟子僧，是师依之上。
如来之所说，诸说之最辩。”

    时彼天子复说偈言：

“世间几法起？几法相顺可？
世几法取爱？世几法损减？”

    尔时世尊说偈答言：

“世六法等起，世六法顺可，
世六法取爱，世六法损减。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○○九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“谁持世间去？谁拘牵世间？
何等为一法，制御于世间？”

    尔时世尊说偈答言：

“心持世间去，心拘引世间，
其心为一法，能制御世间。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○一○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“谁缚于世间？谁调伏令解？
断除何等法，说名得涅槃？”

    尔时世尊说偈答言：

“欲能缚世间，调伏欲解脱，
断除爱欲者，说名得涅槃。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○一一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“谁掩于世间？谁遮络世间？
谁结缚众生？何处建立世？”

    尔时世尊说偈答言：

“衰老掩世间，死遮络世间，
爱系缚众生，法建立世间。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○一二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“谁隐彼世间？谁系于世间？
谁忆于众生？谁建众生幢？”

    尔时世尊说偈答言：

“无明覆世间，爱结缚众生，
隐覆忆众生，我慢众生幢。”

    时彼天子即复说偈而问佛言：

“谁无有覆盖？谁复无爱结？
谁即出隐覆？谁不建慢幢？”

    尔时世尊说偈答言：

“如来等正觉，正智心解脱，
不为无明覆，亦无爱结系，
超出于隐覆，摧灭我慢幢。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○一三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“何等为上士，所有资财物？
云何善修习，而致于安乐？
云何众味中，得为最上味？
云何众生中，得为第一寿？”

    尔时世尊说偈答言：

“清净信乐心，名士夫胜财。
修行于正法，能招安乐果。
真谛之妙说，是则味之上。
贤圣智慧命，是为寿中最。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○一四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“云何为比丘，同己之第二？
云何为比丘，随顺教授者？
比丘于何处，游心自娱乐，
娱乐彼处已，能断诸结缚？”

    尔时世尊说偈答言：

“信为同己二，智慧教授者，
涅槃喜乐处，比丘断结缚。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○一五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“云何善至老？云何善建立？
云何为人宝？云何贼不夺？”

    尔时世尊说偈答言：

“正戒善至老，净信善建立，
智慧为人宝，功德贼不夺。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○一六）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“何法生众生？何等前驱驰？
云何起生死？何者不解脱？”

    尔时世尊说偈答言：

“爱欲生众生，意在前驱驰，
众生起生死，苦法不解脱。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○一七）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“何法生众生？何等前驱驰？
云何起生死？何法可依怙？”

    尔时世尊说偈答言：

“爱欲生众生，意在前驱驰，
众生起生死，业者可依怙。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○一八）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“何法生众生？何等前驱驰？
云何起生死？何法甚可畏？”

    尔时世尊说偈答言：

“爱欲生众生，意在前驱驰，
众生起生死，业为甚可畏。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○一九）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“何名为非道？云何日夜迁？
云何垢梵行？云何累世间？”

    尔时世尊说偈答言：

“贪欲名非道，寿命日夜迁，
女人梵行垢，女则累世间。
炽然修梵行，已洗诸非小。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○二○）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“何法映世间？何法无有上？
何等为一法，普制御众生？”

    尔时世尊说偈答言：

“名者映世间，名者世无上，
唯有一名法，能制御世间。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○二一）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“何法为偈因？以何庄严偈？
偈者何所依？何者为偈体？”

    尔时世尊说偈答言：

“欲者是偈因，文字庄严偈，
名者偈所依，造作为偈体。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一○二二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，却坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“云何知车乘？云何复知火？
云何知国土？云何知妻妇？”

    尔时世尊说偈答言：

“见幢盖知车，见烟则知火，
见王知国土，见夫知其妻。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。


杂阿含经卷第三十七

（一○二三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有尊者叵求那，住东园鹿母讲堂，疾病困笃。
    尊者阿难往诣佛所，稽首礼足，退住一面，白佛言：“世尊，尊者叵求那住东园鹿母讲堂，疾病困笃。如是病比丘，多有死者。善哉世尊！愿至东园鹿母讲堂，尊者叵求那所，以哀愍故！”
    尔时世尊默然而许，至日晡时从禅觉，往诣东园鹿母讲堂，至尊者叵求那房，敷座而坐，为尊者叵求那种种说法，示教照喜，示教照喜已，从座起去。
    尊者叵求那，世尊去后，寻即命终。当命终时，诸根喜悦，颜貌清净，肤色鲜白。
    时尊者阿难供养尊者叵求那舍利已，往诣佛所，稽首佛足，却住一面，白佛言：“世尊，尊者叵求那，世尊来后，寻便命终。临命终时，诸根喜悦，肤色清净，鲜白光泽。不审世尊，彼当生何趣？云何受生？后世云何？”
    佛告阿难：“若有比丘先未病时，未断五下分结，若觉病起，其身苦患，心不调适，生分微弱，得闻大师教授教诫，种种说法，彼闻法已，断五下分结。阿难，是则大师教授说法福利。复次阿难，若有比丘先未病时，未断五下分结，然后病起，身遭苦患，生分转微，不蒙大师教授教诫说法，然遇诸余多闻大德修梵行者教授教诫说法，得闻法已，断五下分结。阿难，是名教授教诫听法福利。复次阿难，若比丘先未病时，不断五下分结，乃至生分微弱，不闻大师教授教诫说法，复不闻余多闻大德诸梵行者教授教诫说法，然彼先所受法，独静思惟，称量观察，得断五下分结。阿难，是名思惟观察先所闻法所得福利。
    “复次阿难，若有比丘先未病时，断五下分结，不得无上爱尽解脱、不起诸漏、心善解脱，然后得病，身遭苦患，生分微弱，得闻大师教授教诫说法，得无上爱尽解脱，不起诸漏，离欲解脱。阿难，是名大师说法福利。复次阿难，若有比丘先未病时，断五下分结，不得无上爱尽解脱、不起诸漏、离欲解脱，觉身病起，极遭苦患，不得大师教授教诫说法，然得诸余多闻大德诸梵行者教授教诫说法，得无上爱尽解脱，不起诸漏，离欲解脱。阿难，是名教授教诫闻法福利。复次阿难，若有比丘先未病时，断五下分结，不得无上爱尽解脱、不起诸漏、离欲解脱，其身病起，极生苦患，不得大师教授教诫说法，不得诸余多闻大德教授教诫说法，然先所闻法，独一静处，思惟称量观察，得无上爱尽解脱，不起诸漏，离欲解脱。阿难，是名思惟先所闻法所得福利。
    “何缘叵求那比丘不得诸根欣悦，色貌清净，肤体鲜泽？叵求那比丘先未病时，未断五下分结，彼亲从大师闻教授教诫说法，断五下分结。”
    世尊为彼尊者叵求那，授阿那含记。
    佛说此经已，尊者阿难闻佛所说，欢喜随喜，作礼而去。

（一○二四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者阿湿波誓，住东园鹿母讲堂，身遭重病，极生苦患。尊者富邻尼瞻视供给。
    如前《跋迦梨修多罗》广说，谓说三受，乃至转增无损。
    佛告阿湿波誓：“汝莫变悔！”
    阿湿波誓白佛言：“世尊，我实有变悔。”
    佛告阿湿波誓：“汝得无破戒耶？”
    阿湿波誓白佛言：“世尊，我不破戒。”
    佛告阿湿波誓：“汝不破戒，何为变悔？”
    阿湿波誓白佛言：“世尊，我先未病时，得身息乐正受多修习。我于今日不复能得入彼三昧，我作是思惟：将无退失是三昧耶？”
    佛告阿湿波誓：“我今问汝，随意答我。阿湿波誓，汝见色即是我、异我、相在不？”
    阿湿波誓白佛言：“不也，世尊。”
    复问：“汝见受、想、行、识，是我、异我、相在不？”
    阿湿波誓白佛言：“不也，世尊。”
    佛告阿湿波誓：“汝既不见色是我、异我、相在，不见受、想、行、识是我、异我、相在，何故变悔？”
    阿湿波誓白佛言：“世尊，不正思惟故。”
    佛告阿湿波誓：“若沙门、婆罗门，三昧坚固，三昧平等，若不得入彼三昧，不应作念：我于三昧退减。若复圣弟子不见色是我、异我、相在，不见受、想、行、识是我、异我、相在，但当作是觉知：贪欲永尽无余，瞋恚、愚痴永尽无余。贪、恚、痴永尽无余已，一切漏尽，无漏心解脱、慧解脱，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。”
    佛说是法时，尊者阿湿波誓不起诸漏，心得解脱，欢喜踊悦，欢喜踊悦故，身病即除。
    佛说此经，令尊者阿湿波誓欢喜随喜已，从座起而去。
    《差摩迦修多罗》如五受阴处说。

（一○二五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘，年少新学，于此法律出家未久，少知识，独一客旅，无人供给，住边聚落客僧房中，疾病困笃。
    时有众多比丘诣佛所，稽首礼足，却坐一面，白佛言：“世尊，有一比丘，年少新学，乃至疾病困笃，住边聚落客僧房中。有是病比丘，多死无活。善哉世尊！往彼住处，以哀愍故。”
    尔时世尊默然而许，即日晡时从禅觉，至彼住处。彼病比丘遥见世尊，扶床欲起。佛告比丘：“息卧勿起。云何比丘，苦患宁可忍不？”
    如前《差摩迦修多罗》广说，如是三受，乃至病苦但增不损。
    佛告病比丘：“我今问汝，随意答我。汝得无变悔耶？”
    病比丘白佛：“实有变悔，世尊。”
    佛告病比丘：“汝得无犯戒耶？”
    病比丘白佛言：“世尊，实不犯戒。”
    佛告病比丘：“汝若不犯戒，何为变悔？”
    病比丘白佛：“世尊，我年幼稚，出家未久，于过人法胜妙知见，未有所得。我作是念：‘命终之时，知生何处？’故生变悔。”
    佛告比丘：“我今问汝，随意答我。云何比丘，有眼故有眼识耶？”
    比丘白佛：“如是，世尊。”
    复问：“比丘，于意云何？有眼识故有眼触、眼触因缘生内受，若苦、若乐、不苦不乐耶？”
    比丘白佛：“如是，世尊。”
    耳、鼻、舌、身、意，亦如是说。
    “云何比丘，若无眼则无眼识耶？”
    比丘白佛：“如是，世尊。”
    复问：“比丘，若无眼识则无眼触耶？若无眼触，则无眼触因缘生内受，若苦、若乐、不苦不乐耶？”
    比丘白佛：“如是，世尊。”
    耳、鼻、舌、身、意，亦如是说。
    “是故比丘，当善思惟如是法，得善命终，后世亦善。”
    尔时世尊为病比丘种种说法，示教照喜已，从座起去。
    时病比丘，世尊去后，寻即命终。临命终时，诸根喜悦，颜貌清净，肤色鲜白。
    时众多比丘诣佛所，稽首礼足，退坐一面，白佛言：“世尊，彼年少比丘，疾病困笃。尊者今已命终，当命终时，诸根喜悦，颜貌清净，肤色鲜白。云何世尊，如是比丘当生何处？云何受生？后世云何？”
    佛告诸比丘：“彼命过比丘，是真宝物。闻我说法，分明解了，于法无畏，得般涅槃。汝等但当供养舍利。”
    世尊尔时为彼比丘授第一记。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○二六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    如上说，差别者：“谛听善思，当为汝说。若彼比丘作如是念：‘我此识身及外境界一切相，无有我、我所见、我慢系著使，及心解脱、慧解脱，现法自知作证具足住；于此识身及外境界一切相，无有我、我所见、我慢系著使，及彼心解脱、慧解脱，现法自知作证具足住。’彼比丘，我此识身及外境界一切相，无有我、我所见、我慢系著使，及心解脱、慧解脱，现法自知作证具足住；于此识身及外境界一切相，无有我、我所见、我慢系著使，及心解脱、慧解脱，现法自知作证具足住。若彼比丘于此识身及外境界一切相，无有我、我所见、我慢系著使，及心解脱、慧解脱，现法自知作证具足住；于此识身及外境界一切相，无有我、我所见、我慢系著使，及彼心解脱、慧解脱，现法自知作证具足住者，是名比丘断爱欲，转诸结，止慢无间等，究竟苦边。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○二七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    如上说。差别者，乃至佛告病比丘：“汝不自犯戒耶？”
    比丘白佛言：“世尊，我不以持净戒故，于世尊所修梵行。”
    佛告比丘：“汝以何等法故，于我所修梵行？”
    比丘白佛：“为离贪欲故，于世尊所修梵行。为离瞋恚、愚痴故，于世尊所修梵行。”
    佛告比丘：“如是如是，汝正应为离贪欲故，于我所修梵行；离瞋恚、愚痴故，于我所修梵行。比丘，贪欲缠故，不得离欲。无明缠故，慧不清净。是故比丘，于欲离故心解脱，离无明故慧解脱。若比丘于欲离欲心解脱身作证，离无明故慧解脱，是名比丘断诸爱欲，转结缚，止慢无间等，究竟苦边。是故比丘，于此法善思惟。”
    如前广说，乃至授第一记。
    佛说此经已，诸比丘闻佛所说，欢喜随喜，作礼而去。

（一○二八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有众多比丘集于伽梨隶讲堂，时多有比丘疾病。
    尔时世尊晡时从禅觉，往至伽梨隶讲堂，于大众前敷座而坐已，告诸比丘：“当正念正智以待时，是则为我随顺之教。比丘，云何为正念？谓比丘内身身观念处，精勤方便，正念正智，调伏世间贪忧；外身身观念处、内外身身观念处，内受、外受、内外受，内心、外心、内外心，内法、外法、内外法法观念处，精勤方便，正念正智，调伏世间贪忧，是名比丘正忆念。云何正智？谓比丘若来若去，正知而住，瞻视观察、屈伸俯仰、执持衣钵、行、住、坐、卧、眠、觉，乃至五十、六十，依语默正智行。比丘，是名正智。
    “如是比丘正念正智住者，能起乐受，有因缘非无因缘。云何因缘？谓缘于身，作是思惟：‘我此身无常有为，心因缘生。乐受亦无常有为，心因缘生。’身及乐受，观察无常、观察生灭、观察离欲、观察灭尽、观察舍。彼观察身及乐受无常乃至舍已，若于身及乐受，贪欲使者，永不复使。
    “如是正念正智生苦受，因缘非不因缘。云何为因缘？如是缘身，作是思惟：‘我此身无常有为，心因缘生。苦受亦无常有为，心因缘生。’身及苦受，观察无常乃至舍，于此及苦受，瞋恚所使，永不复使。
    “如是正念正智生不苦不乐受，因缘非不因缘。云何因缘？谓身因缘，作是思惟：‘我此身无常有为，心因缘生。彼不苦不乐受，亦无常有为，心因缘生。’彼身及不苦不乐受，观察无常乃至舍，若所有身及不苦不乐受，无明所使，永不复使。
    “多闻圣弟子如是观者，于色厌离，于受、想、行、识厌离，厌离已离欲，离欲已解脱，解脱知见：我生已尽，梵行已立，所作已作，自知不受后有。”
    尔时世尊即说偈言：

“乐觉所觉时，莫能知乐觉，
贪欲使所使，不见于出离。
苦受所觉时，莫能知苦受，
瞋恚使所使，不见出离道。
不苦不乐受，等正觉所说，
彼亦不能知，终不度彼岸。
若比丘精勤，正智不倾动，
于彼一切受，黠慧能悉知。
能知诸受已，现法尽诸漏，
依慧而命终，涅槃不堕数。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○二九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    如上说，时有众多比丘集会迦梨隶讲堂，多有疾病。
    如上说，差别者，乃至“圣弟子如是观者，于色解脱，于受、想、行、识解脱，我说是等解脱生老病死。”
    尔时世尊即说偈言：

“智慧多闻者，非不觉诸受，
若于苦乐受，分别谛明了，
当知坚固事，凡夫有升降，
于乐不染著，于苦不倾动。
知受不受生，依于贪恚觉，
断除斯等已，其心善解脱，
系念缘妙境，正向待终期。
若比丘精勤，正智不倾动，
于此一切受，慧者能觉知。
了知诸受已，现法尽诸漏，
依慧而命终，涅槃不堕数。”

    佛说此经已，诸比丘欢喜，作礼而去。

（一○三○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时给孤独长者得病，身极苦痛。
    世尊闻已，晨朝着衣持钵，入舍卫城乞食，次第乞食，至给孤独长者舍。
    长者遥见世尊，凭床欲起。
    世尊见已，即告之言：“长者勿起，增其苦患！”
    世尊即坐，告长者言：“云何长者，病可忍不？身所苦患，为增为损？”
    长者白佛：“甚苦，世尊，难可堪忍。”乃至说三受，如《差摩修多罗》广说，乃至苦受但增不损。
    佛告长者：“当如是学：于佛不坏净，于法、僧不坏净，圣戒成就。”
    长者白佛：“如世尊说四不坏净，我有此法，此法中有我。世尊，我今于佛不坏净，法、僧不坏净，圣戒成就。”
    佛告长者：“善哉善哉！”即记长者得阿那含果。
    长者白佛：“唯愿世尊，今于此食。”
    尔时世尊默而许之。长者即敕办种种净美饮食，供养世尊。
    世尊食已，为长者种种说法，示教照喜已，从座起而去。

（一○三一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时尊者阿难，闻给孤独长者身遭苦患，往诣其舍。
    长者遥见阿难，凭床欲起。乃至说三受，如前《叉摩修多罗》广说，乃至苦患但增不损。
    时尊者阿难告长者言：“勿恐怖！若愚痴无闻凡夫，不信于佛，不信法、僧，圣戒不具，故有恐怖，亦畏命终及后世苦。汝今不信已断已知，于佛净信具足，于法、僧净信具足，圣戒成就。”
    长者白尊者阿难：“我今何所恐怖！我始于王舍城寒林中丘冢间见世尊，即得于佛不坏净，于法、僧不坏净，圣戒成就。自从是来，家有钱财，悉与佛弟子，比丘、比丘尼、优婆塞、优婆夷共。”
    尊者阿难言：“善哉长者！汝自记说是须陀洹果。”
    长者白尊者阿难：“可就此食。”
    尊者阿难默然受请。即办种种净美饮食，供养尊者阿难。食已，复为长者种种说法，示教照喜已，从座起而去。

（一○三二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者舍利弗闻给孤独长者身遭苦患，闻已语尊者阿难：“知不？给孤独长者身遭苦患，当共往看。”
    尊者阿难默然而许。时尊者舍利弗与尊者阿难，共诣给孤独长者舍。
    长者遥见尊者舍利弗，扶床欲起。乃至说三种受，如《叉摩修多罗》广说，身诸苦患转增无损。
    尊者舍利弗告长者言：“当如是学：不著眼，不依眼界生贪欲识；不著耳、鼻、舌、身、意亦不著，不依意界生贪欲识。不著色，不依色界生贪欲识；不著声、香、味、触、法，不依法界生贪欲识。不著于地界，不依地界生贪欲识；不著于水、火、风、空、识界，不依识界生贪欲识。不著色阴，不依色阴生贪欲识；不著受、想、行、识阴，不依识阴生贪欲识。”
    时给孤独长者悲叹流泪。
    尊者阿难告长者言：“汝今怯劣耶？”
    长者白阿难：“不怯劣也。我自顾念，奉佛以来二十余年，未闻尊者舍利弗说深妙法，如今所闻。”
    尊者舍利弗告长者言：“我亦久来未尝为诸长者说如是法。”
    长者白尊者舍利弗：“有居家白衣，有胜信、胜念、胜乐，不闻深法，而生退没。善哉尊者舍利弗！当为居家白衣说深妙法，以哀愍故。尊者舍利弗，今于此食。”
    尊者舍利弗等默然受请。即设种种净美饮食，恭敬供养。食已，复为长者种种说法，示教照喜，示教照喜已，即从座起而去。

（一○三三）

    达磨提离长者修多罗，亦如世尊为给孤独长者初修多罗广说。
    第二修多罗亦如是说，差别者：“若复长者依此四不坏净已，于上修习六念，谓念如来事，乃至念天。”
    长者白佛言：“世尊，依四不坏净，于上修六随念，我今悉成就。我常修念如来事，乃至念天。”
    佛告长者：“善哉善哉！汝今自记阿那含果。”
    长者白佛：“唯愿世尊受我请食。”
    尔时世尊默然受请。
    长者知佛受请已，即具种种净美饮食，恭敬供养。
    世尊食已，复为长者种种说法，示教照喜已，从座起而去。

（一○三四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有长寿童子，是树提长者孙子，身婴重病。
    尔时世尊闻长寿童子身婴重病，晨朝着衣持钵，入王舍城乞食，次第到长寿童子舍。
    长寿童子遥见世尊，扶床欲起。乃至说三受，如《叉摩修多罗》广说，乃至病苦但增无损。
    “是故童子，当如是学：于佛不坏净，于法、僧不坏净，圣戒成就，当如是学！”
    童子白佛言：“世尊，如世尊说四不坏净，我今悉有。我常于佛不坏净，于法、僧不坏净，圣戒成就。”
    佛告童子：“汝当依四不坏净，于上修习六明分想。何等为六？谓一切行无常想、无常苦想、苦无我想、观食想、一切世间不可乐想、死想。”
    童子白佛言：“如世尊说，依四不坏净，修习六明分想，我今悉有。然我作是念，我命终后，不知我祖父树提长者当云何？”
    尔时树提长者语长寿童子言：“汝于我所顾念且停。汝今且听世尊说法，思惟忆念，可得长夜福利，安乐饶益。”
    时长寿童子言：“我于一切诸行当作无常想、无常苦想、苦无我想、观食想、一切世间不可乐想、死想，常现在前。”
    佛告童子：“汝今自记斯陀含果。”
    长寿童子白佛言：“世尊！唯愿世尊，住我舍食。”
    尔时世尊默然而许。
    长寿童子即办种种净美饮食，恭敬供养。
    世尊食已，复为童子种种说法，示教照喜已，从座起而去。

（一○三五）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    时婆薮长者身遭苦患。
    尔时世尊闻婆薮长者身遭苦患。
    如前《达摩提那长者修多罗》广说，得阿那含果记，乃至从座起而去。

（一○三六）

    如是我闻。一时佛住迦毗罗卫国尼拘律园中。
    时有释氏沙罗，疾病委笃。
    尔时世尊闻释氏沙罗疾病委笃，晨朝着衣持钵，入迦维罗卫国乞食，次到释氏沙罗舍。
    释氏沙罗遥见世尊，扶床欲起。乃至说三受，如《差摩迦修多罗》广说，乃至患苦但增不损。
    “是故释氏沙罗，当如是学：于佛不坏净，于法、僧不坏净，圣戒成就。”
    释氏沙罗白佛言：“如世尊说，于佛不坏净，于法、僧不坏净，圣戒成就，我悉有之。我常于佛不坏净，于法、僧不坏净，圣戒成就。”
    佛告释氏沙罗：“是故汝当依佛不坏净，法、僧不坏净，圣戒成就，于上修习五喜处。何等为五？谓念如来事，乃至自所施法。”
    释氏沙罗白佛言：“如世尊说，依四不坏净，修五喜处，我亦有之。我常念如来事，乃至自所施法。”
    佛言：“善哉善哉！汝今自记斯陀含果。”
    沙罗白佛：“唯愿世尊，今我舍食。”
    尔时世尊默然而许。
    沙罗长者即办种种净美饮食，恭敬供养。
    世尊食已，复为沙罗长者种种说法，示教照喜已，从座起而去。

（一○三七）

    如是我闻。一时佛住那梨聚落曲谷精舍。
    尔时耶输长者，疾病困笃。
    如是乃至得阿那含果记，如《达摩提那修多罗》广说。

（一○三八）

    如是我闻。一时佛住瞻婆国竭伽池侧。
    时有摩那提那长者，疾病新瘥。时摩那提长者语一士夫言：“善男子，汝往尊者阿那律所，为我稽首阿那律足，问讯起居轻利，安乐住不？明日通身四人，愿受我请。若受请者，汝复为我白言：我俗人多有王家事，不能得自往奉迎，唯愿尊者时到，通身四人来赴我请，哀愍故。”
    时彼男子受长者教，诣尊者阿那律所，稽首礼足，白言：“尊者！摩那提那长者敬礼问讯，少病少恼，起居轻利，安乐住不？唯愿尊者，通身四人，明日日中，哀受我请。”
    时尊者阿那律默然受请。
    时彼士夫复以摩那提那长者语，白尊者阿那律：“我是俗人，多有王家事，不得躬自奉迎。唯愿尊者，通身四人，明日日中，哀受我请，怜愍故！”
    尊者阿那律陀言：“汝且自安，我自知时，明日通身四人，往诣其舍。”
    时彼士夫受尊者阿那律教，还白长者：“阿梨当知，我已诣尊者阿那律，具宣尊意。尊者阿那律言：‘汝且自安，我自知时。’”
    彼长者摩那提那，夜办净美饮食。晨朝复告彼士夫：“汝往至彼尊者阿那律所，白言时到。”
    时彼士夫即受教，行诣尊者阿那律所，稽首礼足，白言：“供具已办，唯愿知时。”
    时尊者阿那律着衣持钵，通身四人诣长者舍。
    时摩那提那长者，婇女围绕，住内门左，见尊者阿那律，举体执足敬礼，引入就座，各别稽首，问讯起居，退坐一面。
    尊者阿那律问讯长者：“堪忍安乐住不？”
    长者答言：“如是尊者，堪忍乐住。先遭疾病，当时委笃，今已蒙瘥。”
    尊者阿那律问长者言：“汝住何住，能令疾病苦患，时得除瘥？”
    长者白言：“尊者阿那律，我住四念处，专修系念故，身诸苦患，时得休息。何等为四？谓内身身观念住，精勤方便，正念正智，调伏世间贪忧；外身、内外身，内受、外受、内外受，内心、外心、内外心，内法、外法、内外法法观念住，精勤方便，正念正智，调伏世间贪忧。如是尊者阿那律，我于四念处系心住故，身诸苦患，时得休息。尊者阿那律，住故身诸苦患时得休息。”
    尊者阿那律告长者言：“汝今自记阿那含果。”
    时摩那提那长者，以种种净美饮食，自手供养，自恣饱满。食已，澡漱毕，摩那提那长者复坐卑床，听说妙法。
    尊者阿那律种种说法，示教照喜已，从座起去。

（一○三九）

    如是我闻。一时佛住王舍城金师精舍。
    时有淳陀长者来诣佛所，稽首佛足，退坐一面。
    尔时世尊问淳陀长者：“汝今爱乐何等沙门、婆罗门净行？”
    淳陀白佛：“有沙门、婆罗门，奉事于水，事毗湿波天，执杖澡罐，常净其手。如是正士能善说法，言：‘善男子月十五日，以胡麻屑、庵摩罗屑，以澡其发，修行斋法，被着新净长鬘白氎，牛粪涂地而卧其上。善男子晨朝早起，以手触地，作如是言：此地清净，我如是净手。执牛粪团，并把生草，口说是言：此是清净，我如是净。若如是者，见为清净。不如是者，永不清净。’世尊，如是像类沙门、婆罗门，若为清净，我所宗仰。”
    佛告淳陀：“有黑、黑报，不净、不净果，负重向下。成就如此诸恶法者，虽复晨朝早起，以手触地，唱言清净，犹是不净；正复不触，亦不清净。执牛粪团，并及生草，唱言清净，亦复不净；正复不触，亦不清净。淳陀，何等为黑法、黑报，不净、不净果，负重向下，乃至触以不触，悉皆不净？淳陀，谓杀生恶业，手常血腥，心常思惟，挝捶杀害，无惭无愧，悭贪吝惜，于一切众生，乃至昆虫，不离于杀。于他财物、聚落、空地，皆不离盗。行诸邪淫，若父母、兄弟、姊妹、夫主、亲族，乃至授花鬘者，如是等护，以力强干，不离邪淫。不实妄语，或于王家、真实言家，多众聚集，求当言处，作不实说，不见言见、见言不见、不闻言闻、闻言不闻、知言不知、不知言知，因自因他，或因财利，知而妄语而不舍离，是名妄语。两舌乖离，传此向彼，传彼向此，递相破坏，令和合者离，离者欢喜，是名两舌。不离恶口骂詈，若人软语、悦耳心喜、方正易知、乐闻无依说，多人爱念、适意、随顺三昧，舍如是等而作刚强、多人所恶、不爱、不适意、不顺三昧说，如是等言，不离粗涩，是名恶口。绮饰坏语，不时言、不实言、无义言、非法言、不思言，如是等名坏语。不舍离贪，于他财物而起贪欲，言此物我有者好。不舍瞋恚弊恶，心思惟言，彼众生应缚、应鞭、应杖、应杀，欲为生难。不舍邪见颠倒，如是见、如是说：无施、无报、无福，无善行恶行、无善恶业果报，无此世、无他世、无父母、无众生生世间，无世阿罗汉等趣等向，此世他世自知作证：我生已尽，梵行已立，所作已作，自知不受后有。淳陀，是名黑、黑报，不净、不净果，乃至触以不触，皆悉不净。
    “淳陀，有白、白报，净、有净果，轻仙上升。成就已，晨朝触地，此净我净者，亦得清净；若不触者，亦得清净。把牛粪团，手执生草，净因净果者，执与不执，亦得清净。淳陀，何等为白、白报，乃至执以不执，亦得清净？谓有人不杀生，离杀生，舍刀杖，惭愧，悲念一切众生。不偷盗，远离偷盗，与者取，不与不取，净心不贪。离于邪淫，若父母护，乃至授一花鬘者，悉不强干起于邪淫。离于妄语，审谛实说。远离两舌，不传此向彼，传彼向此，共相破坏；离者令和，和者随喜。远离恶口，不刚强，多人乐其所说。离于坏语，谛说、时说、实说、义说、法说、见说。离于贪欲，不于他财、他众具，作己有想而生贪著。离于瞋恚，不作是念：挝、打、缚、杀、为作众难。正见成就，不颠倒见，有施、有报、有福、有善恶行果报、有此世、有父母、有众生生，有世阿罗汉，于此世他世现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。淳陀，是名白、白报，乃至触与不触，皆悉清净。”
    尔时淳陀长者闻佛所说，欢喜随喜，作礼而去。

（一○四○）

    如是我闻。一时佛住王舍城金师精舍。
    时有异婆罗门，于十五日洗头已，受斋法，被新长鬘白氎，手执生草，来诣佛所，与世尊面相问讯慰劳已，退坐一面。
    尔时佛告婆罗门：“汝洗头被新长鬘白氎，是谁家法？”
    婆罗门白佛：“瞿昙，是学舍法。”
    佛告婆罗门：“云何婆罗门舍法？”
    婆罗门白佛言：“瞿昙，如是十五日，洗头受持法斋，着新净长鬘白氎，手执生草，随力所能，布施作福。瞿昙，是名婆罗门修行舍行。”
    佛告婆罗门：“贤圣法律所行舍行，异于此也。”
    婆罗门白佛：“瞿昙，云何为贤圣法律所行舍行？”
    佛告婆罗门：“谓离杀生，不乐杀生，如前清净分广说；依于不杀，舍离杀生，乃至如前清净分广说。离偷盗，不乐于盗；依于不盗，舍不与取。离诸邪淫，不乐邪淫；依于不淫，舍非梵行。离于妄语，不乐妄语；依不妄语，舍不实言。离诸两舌，不乐两舌；依不两舌，舍别离行。离于恶口，不乐恶口；依不恶口，舍于粗言。离诸绮语，不乐绮语；依不绮语，舍无义言。断除贪欲，远离苦贪；依无贪心，舍于爱著。断除瞋恚，不生忿恨；依于无恚，舍彼瞋恨。修习正见，不起颠倒；依于正见，舍彼邪见。婆罗门，是名贤圣法律所行舍行。”
    婆罗门白佛：“善哉瞿昙，贤圣法律所行舍行！”
    时婆罗门闻佛所说，欢喜随喜，从座起去。

（一○四一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有生闻梵志来诣佛所，与世尊面相问讯慰劳已，退坐一面，白佛言：“瞿昙，我有亲族，极所爱念，忽然命终。我为彼故，信心布施，云何世尊，彼得受不？”
    佛告婆罗门：“非一向得。若汝亲族生地狱中者，得彼地狱众生食以活其命，不得汝所信施饮食。若生畜生、饿鬼、人中者，得彼人中饮食，不得汝所施者。婆罗门，饿鬼趣中，有一处名为入处饿鬼，若汝亲族生彼入处饿鬼中者，得汝施食。”
    婆罗门白佛：“若我亲族不生入处饿鬼趣中者，我信施谁应食之？”
    佛告婆罗门：“若汝所可为信施亲族不生入处饿鬼趣者，要有余亲族知识生入处饿鬼趣中者得食之。”
    婆罗门白佛：“瞿昙，若我所为信施亲族不生入处饿鬼趣中，亦更无余亲族知识生入处饿鬼趣者，此信施食，谁当食之？”
    佛告婆罗门：“设使所为施亲族知识不生入处饿鬼趣中，复无诸余知识生饿鬼者，且信施而自得其福。彼施者所作信施，而彼施者不失达嚫。”
    婆罗门白佛：“云何施者行施，施者得彼达嚫？”
    佛告婆罗门：“有人杀生行恶，手常血腥，乃至十不善业迹，如《淳陀修多罗》广说，而复施诸沙门、婆罗门乃至贫穷乞士，悉施钱财、衣被、饮食、灯明、诸庄严具。婆罗门，彼惠施主若复犯戒，生象中者，以彼曾施沙门、婆罗门钱财、衣被、饮食乃至庄严众具故，虽在象中，亦得受彼施报，衣服、饮食乃至种种庄严众具。若复生牛、马、驴、骡等种种畜生趣中，以本施惠功德，悉受其报，随彼生处，所应受用，皆悉得之。婆罗门，若复施主持戒，不杀、不盗，乃至正见，布施诸沙门、婆罗门乃至乞士，钱财、衣服、饮食乃至灯明。缘斯功德，生人道中，坐受其报，衣被、饮食乃至灯明众具。复次婆罗门，若复持戒生天上者，彼诸惠施，天上受报，财宝、衣服、饮食乃至庄严众具。婆罗门，是名施者行施，施者受达嚫，果报不失。”
    时生闻婆罗门闻佛所说，欢喜随喜，从座起去。

（一○四二）

    如是我闻。一时佛在拘萨罗国人间游行，住鞞罗磨聚落北身恕林中。
    鞞罗聚落婆罗门长者，闻世尊住聚落北身恕林中，闻已共相招集，往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，何因何缘，有众生身坏命终生地狱中？”
    佛告诸婆罗门长者：“行非法行、行危险行因缘故，身坏命终生地狱中。”
    诸婆罗门长者白佛：“行何等非法行、危险行，身坏命终生地狱中？”
    佛告婆罗门长者：“杀生乃至邪见，具足十不善业因缘故，婆罗门，是非法行、危险行，身坏命终生地狱中。”
    婆罗门白佛：“何因缘，诸众生身坏命终，得生天上？”
    佛告婆罗门长者：“行法行，行正行，以是因缘故，身坏命终得生天上。”
    复问：“世尊，行何等法行、何等正行，身坏命终得生天上？”
    佛告婆罗门长者：“谓离杀生乃至正见，十善业迹因缘故，身坏命终得生天上。婆罗门长者，若有行此法行、行此正行者，欲求刹利大姓家、婆罗门大姓家、居士大姓家，悉得往生。所以者何？以法行、正行因缘故。若复欲求生四王、三十三天，乃至他化自在天，悉得往生。所以者何？以法行、正行故，行净戒者，其心所愿，悉自然得。若复如是法行、正行者，欲求生梵天，亦得往生。所以者何？以行正行、法行故，持戒清净，心离爱欲，所愿必得。若复欲求往生光音、遍净，乃至阿伽尼吒，亦复如是。所以者何？以彼持戒清净，心离欲故。若复欲求离欲恶不善法，有觉有观，乃至第四禅具足住，悉得成就。所以者何？以彼法行、正行故，持戒清净，心离爱欲，所愿必得。欲求慈、悲、喜、舍，空入处、识入处、无所有入处、非想非非想入处，皆悉得。所以者何？以法行、正行故，持戒清净，心离爱欲，所愿必得。欲求断三结，得须陀洹、斯陀含、阿那含果，无量神通，天耳、他心智、宿命智、生死智、漏尽智，皆悉得。所以者何？以法行、正行故，持戒离欲，所愿必得。”
    时婆罗门长者闻佛所说，欢喜随喜，作礼而去。

（一○四三）

    如是我闻。一时佛在拘萨罗国人间游行，住鞞罗磨聚落北身恕林中。
    时鞞罗磨聚落中婆罗门长者，闻世尊住鞞罗磨聚落身恕林中，闻已乘白马车，多将翼从，持金柄伞盖、金澡瓶，出鞞罗磨聚落，诣身恕林，至道口，下车步进，入于园门，至世尊前，面相问讯慰劳已，退坐一面，白佛言：“瞿昙，何因何缘，有人命终生地狱中，乃至生天？”如上修多罗广说。
    时鞞罗磨婆罗门闻佛所说，欢喜随喜，从座起而去。

（一○四四）

    如是我闻。一时佛住在拘萨罗人间游行，至鞞纽多罗聚落北身恕林中住。
    鞞纽多罗聚落婆罗门长者，闻世尊住聚落北身恕林中，闻已共相招引，往诣身恕林，至世尊所，面相慰劳已，退坐一面。
    尔时世尊告婆罗门长者：“我当为说自通之法，谛听善思。何等自通之法？谓圣弟子作如是学：我作是念，若有欲杀我者，我所不喜。我若所不喜，他亦如是，云何杀彼？作是觉已，受不杀生，不乐杀生，如上说。我若不喜人盗于我，他亦不喜，我云何盗他？是故持不盗戒，不乐于盗，如上说。我既不喜人侵我妻，他亦不喜，我今云何侵人妻妇？是故受持不他淫戒，如上说。我尚不喜为人所欺，他亦如是，云何欺他？是故受持不妄语戒，如上说。我尚不喜他人离我亲友，他亦如是，我今云何离他亲友？是故不行两舌。我尚不喜人加粗言，他亦如是，云何于他而起骂辱？是故于他不行恶口，如上说。我尚不喜人作绮语，他亦如是，云何于他而作绮语？是故于他不行绮饰，如上说。如是七种，名为圣戒。又复于佛不坏净成就，于法、僧不坏净成就，是名圣弟子四不坏净成就。自现前观察，能自记说：我地狱尽，畜生、饿鬼尽，一切恶趣尽，得须陀洹，不堕恶趣法，决定正向三菩提，七有天人往生，究竟苦边。”
    时鞞纽聚落婆罗门长者闻佛所说，欢喜随喜，从座起而去。

（一○四五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有相习近法，谛听善思，当为汝说。何等为相习近法？谓杀生者、杀生者习近。盗、淫、妄语、两舌、恶口、绮语、贪、恚、邪见，各各随类更相习近。譬如不净物、不净物自相和合。如是杀生、杀生，乃至邪见、邪见，自相习近。如是比丘，不杀生、不杀生相习近，乃至正见、正见更相习近。譬如净物、净物自相和合，乳生酪，酪生酥，酥生醍醐，醍醐自相和合。如是不杀、不杀更相习近，乃至正见、正见更相习近，是名比丘相习近法。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（一○四六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有蛇行法，谛听善思，当为汝说。何等为蛇行法？谓杀生恶行，手常血腥，乃至十不善业迹，如前《淳陀修多罗》广说。彼当尔时，身蛇行、口蛇行、意蛇行。彼如是身、口、意蛇行已，于其二趣，向一一趣，若地狱，若畜生。蛇行众生，谓蛇、鼠、猫、狸等腹行众生，是名蛇行法。
    “云何非蛇行法？谓不杀生，乃至正见，如前《淳陀修多罗》十善业迹广说，是名非蛇行法。身非蛇行、口非蛇行、意非蛇行，于其二趣，生一一趣，若天上，若人中，是名非蛇行法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○四七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有恶业因、恶心因、恶见因，如是众生身坏命终，必堕恶趣泥犁中。譬如圆珠，掷着空中，落地流转，不一处住。如是恶业因、恶心因、恶见因，身坏命终，必堕地狱中无住处。云何为恶业？谓杀生乃至绮语，如上广说，是名恶业。云何恶心？谓贪、恚心，如上广说，是名恶心。云何恶见？谓邪颠倒，如上广说，是名恶见。是名恶业因、恶心因、恶见因，身坏命终，必生恶趣泥犁中。
    “善业因、善心因、善见因，身坏命终，必生善趣天上。婆罗门，云何为善业？谓离杀生、不乐杀生，乃至不绮语，是名善业。云何善心？谓不贪、不恚，是名心善。云何为善见？谓正见不颠倒，乃至见不受后有，是名见善。是名业善因、心善因、见善因，身坏命终，得生天上。譬如四方摩尼珠，掷着空中，随堕则安。如是彼三善因，所在受生，随处则安。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（一○四八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若杀生人，多习多行，生地狱中；若生人中，必得短寿。不与取多习多行，生地狱中；若生人中，钱财多难。邪淫多习多行，生地狱中；若生人中，所有妻室为人所图。妄语多习多行，生地狱中；若生人中，多被讥论。两舌多习多行，生地狱中；若生人中，亲友乖离。恶口多习多行，生地狱中；若生人中，常闻丑声。绮语多习多行，生地狱中；若生人中，言无信用。贪欲多习多行，生地狱中；若生人中，增其贪欲。瞋恚多习多行，生地狱中；若生人中，增其瞋恚。邪见多习多行，生地狱中；若生人中，增其愚痴。
    “若离杀生，修习多修习，得生天上；若生人中，必得长寿。不盗修习多修习，得生天上；若生人中，钱财不丧。不邪淫修习多修习，得生天上；若生人中，妻室循良。不妄语修习多修习，得生天上；若生人中，不被讥论。不两舌修习多修习，得生天上；若生人中，亲友坚固。不恶口修习多修习，得生天上；若生人中，常闻妙音。不绮语修习多修习，得生天上；若生人中，言见信用。不贪修习多修习，得生天上；若生人中，不增爱欲。不恚修习多修习，得生天上；若生人中，不增瞋恚。正见修习多修习，得生天上；若生人中，不增愚痴。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（一○四九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“杀生有三种，谓从贪生故、从恚生故、从痴生；乃至邪见亦三种，从贪生、从恚生、从痴生。离杀生亦有三种，不贪生、不恚生、不痴生；乃至离邪见亦三种，不贪生、不恚生、不痴生。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（一○五○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“所谓有出法、出不出法。何等为出法、出不出法？谓不杀生出于杀生，乃至正见出于邪见。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（一○五一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有生闻婆罗门来诣佛所，稽首佛足，退坐一面，白佛言：“瞿昙所说此彼岸，云何此岸？云何彼岸？”
    佛告婆罗门：“杀生者，谓此岸；不杀生者，谓彼岸。邪见者，谓此岸；正见者，谓彼岸。”
    尔时世尊即说偈言：

“少有修善人，能度于彼岸；
一切众生类，驱驰走此岸。
于此正法律，观察法法相，
此等度彼岸，摧伏死魔军。”

    尔时生闻婆罗门闻佛所说，欢喜随喜，从座起去。
    如是异比丘所问、尊者阿难所问、佛问诸比丘三经，亦如上说。

（一○五二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有恶法，有真实法。谛听善思，当为汝说。云何为恶法？谓杀生、不与取、邪淫、妄语、两舌、恶口、绮语、贪、恚、邪见，是名恶法。云何为真实法？谓离杀生，乃至正见，是名真实法。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（一○五三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有恶法、恶恶法，有真实法、真实真实法。谛听善思，当为汝说。
    “云何为恶法？谓杀生，乃至邪见，是名恶法。云何为恶恶法？谓自杀生，教人令杀，乃至自起邪见，复以邪见教人令行，是名恶恶法。
    “云何为真实法？谓不杀生，乃至正见，是名真实法。云何为真实真实法？谓自不杀生，教人不杀，乃至自行正见，复以正见教人令行，是名真实真实法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○五四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有不善男子、善男子。谛听善思，今当为汝说。云何为不善男子？谓杀生者，乃至邪见者，是名不善男子。云何善男子？谓不杀生，乃至正见，是名善男子。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○五五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有不善男子、不善男子不善男子，有善男子、善男子善男子。谛听善思，当为汝说。
    “云何为不善男子？谓杀生，乃至邪见者，是名不善男子。云何为不善男子不善男子？谓手自杀生，教人令杀，乃至自行邪见，教人令行邪见，是名不善男子不善男子。
    “云何为善男子？谓不杀生，乃至正见者，是名善男子。云何为善男子善男子？谓自不杀生，教人不杀，乃至自行正见，复以正见教人令行，是名善男子善男子。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（一○五六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若成就十法者，如铁鉾钻水，身坏命终，下入恶趣泥犁中。何等为十？谓杀生，乃至邪见。
    “若成就十法，譬如铁鉾仰钻虚空，身坏命终，上生天上。何等为十？谓不杀生，乃至正见。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（一○五七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若成就二十法者，如铁鉾钻水，身坏命终，下生恶趣泥犁中。何等为二十？谓自手杀生，教人令杀，乃至自行邪见，复以邪见教人令行，是名二十法成就，如铁鉾钻水，身坏命终，下生恶趣泥犁中。
    “有二十法成就，譬如铁鉾仰钻虚空，身坏命终，上生天上。何等为二十法？谓自不杀生，教人不杀，乃至自行正见，复以正见教人令行，是名二十法成就，如铁鉾仰钻虚空，身坏命终，上生天上。”
    诸比丘闻佛所说，欢喜奉行。

（一○五八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“三十法成就者，如铁鉾钻水，身坏命终，下生恶趣泥犁中。何等为三十法？谓自手杀生，教人令杀，赞叹杀生；乃至自行邪见，复以邪见教人令行，常复赞叹行邪见者，是名三十法，如铁鉾钻水，身坏命终，下生恶趣泥犁中。
    “有三十法成就者，如铁鉾钻空，身坏命终，上生天上。何等为三十法？谓自不杀生，教人不杀，常复赞叹不杀功德；乃至自行正见，复以正见教人令行，常复赞叹正见功德，是名三十法成就，如铁鉾钻空，身坏命终，上生天上。”
    诸比丘闻佛所说，欢喜奉行。

（一○五九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四十法成就，如铁枪投水，身坏命终，下生恶趣泥犁中。何等为四十法？谓手自杀生，教人令杀，赞叹杀生，见人杀生心随欢喜；乃至自行邪见，教人令行，赞叹邪见，见行邪见心随欢喜，是名四十法成就，如铁枪投水，身坏命终，下生恶趣泥犁中。
    “有四十法成就，如铁枪钻空，身坏命终，上生天上。何等为四十？谓不杀生，教人不杀，口常赞叹不杀功德，见不杀者心随欢喜；乃至自行正见，教人令行，亦常赞叹正见功德，见人行者心随欢喜，是名四十法成就，如铁枪钻空，身坏命终，上生天上。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○六○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有非法，有正法。谛听善思，当为汝说。何等为非法？谓杀生，乃至邪见，是名非法。何等为正法？谓不杀生，乃至正见，是名正法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○六一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有非律，有正律。谛听善思，当为汝说。何等为非律？谓杀生，乃至邪见，是名非律。何等为正律？谓不杀，乃至正见，是名正律。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如非律、正律，如是非圣及圣，不善及善，非亲近、亲近，非善哉、善哉，黑法、白法，非义、正义，卑法、胜法，有罪法、无罪法，弃法、不弃法，一一经如上说。


杂阿含经卷第三十八

（一○六二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有尊者善生，新剃须发，着袈裟衣，正信非家，出家学道，来诣佛所，稽首佛足，退坐一面。
    尔时世尊告诸比丘：“诸比丘，当知此善生善男子，有二处端严：一者剃除须发，着袈裟衣，正信非家，出家学道。二者尽诸有漏，无漏心解脱，慧解脱，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。”
    尔时世尊即说偈言：

“寂静尽诸漏，比丘庄严好，
离欲断诸结，涅槃不复生，
持此最后身，摧伏魔怨敌。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○六三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘形色丑陋，难可观视，为诸比丘之所轻慢，来诣佛所。
    尔时世尊四众围绕，见彼比丘来，皆起轻想，更相谓言：“彼何等比丘，随路而来，形貌丑陋，难可观视，为人所慢！”
    尔时世尊知诸比丘心之所念，告诸比丘：“汝等见彼比丘来，形状甚丑，难可视见，令人起慢不？”
    诸比丘白佛：“唯然已见。”
    佛告诸比丘：“汝等勿于彼比丘起于轻想。所以者何？彼比丘已尽诸漏，所作已作，离诸重担，断诸有结，正智心善解脱。诸比丘，汝等莫妄量于人，唯有如来能量于人。”
    彼比丘诣佛所，稽首佛足，退坐一面。
    尔时世尊复告诸比丘：“汝等见此比丘稽首作礼，退坐一面不？”
    比丘白佛：“唯然已见。”
    佛告诸比丘：“汝等勿于是比丘起于轻想，乃至汝等莫量于人，唯有如来能知人耳。”
    尔时世尊即说偈言：

“飞鸟及走兽，莫不畏狮子，
唯狮子兽王，无有与等者。
如是智慧人，虽小则为大，
莫取其身相，而生轻慢心。
何用巨大身，多肉而无慧？
此贤胜智慧，则为上士夫。
离欲断诸结，涅槃永不生，
持此最后身，摧伏众魔军。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○六四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时提婆达多有利养起。摩竭陀王阿阇世毗提希子，日日侍从五百乘车，来诣提婆达多所，日日持五百釜食，供养提婆达多。提婆达多将五百人，别众受其供养。
    时有众多比丘，晨朝着衣持钵，入王舍城乞食，闻提婆达多有如是利养起，乃至五百人别众受其供养。乞食已，还精舍，举衣钵，洗足毕，往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我等晨朝着衣持钵，入王舍城乞食，闻提婆达多有如是利养起，乃至五百人别众受其供养。”
    佛告诸比丘：“汝等莫称是提婆达多所得利养。所以者何？彼提婆达多别受利养，今则自坏，他世亦坏。譬如芭蕉、竹芦，生果即死，来年亦坏。提婆达多亦复如是，受其利养，今世则坏，他世亦坏。譬如駏驉，受胎必死。提婆达多亦复如是，受诸利养，今世亦坏，他世亦坏。彼愚痴提婆达多，随几时受其利养，当得长夜不饶益苦。是故诸比丘，当如是学：我设有利养起，莫生染著。”
    尔时世尊即说偈言：

“芭蕉生果死，竹芦实亦然，
駏驉坐妊死，士以贪自丧。
常行非义行，多知不免愚，
善法日损减，茎枯根亦伤。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○六五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时舍卫国有手比丘，是释氏子，在舍卫国命终。
    时有众多比丘，晨朝着衣持钵，入舍卫城乞食，闻手比丘释子于舍卫国命终。闻已，入舍卫城乞食还，举衣钵，洗足毕，诣佛所，稽首佛足，退坐一面，白佛言：“世尊，今日晨朝，众多比丘着衣持钵，入舍卫城乞食，闻释氏子手比丘于舍卫国命终。云何世尊，手比丘命终，当生何处？云何受生？后世云何？”
    佛告诸比丘：“是手比丘成就三不善法，彼命终当生恶趣泥犁中。何等三不善法？谓贪欲、瞋恚、愚痴。此三不善法，结缚于心，释种子手比丘生恶趣泥犁中。”
    尔时世尊即说偈言：

“贪欲瞋恚痴，结缚士夫心，
内发还自伤，犹如竹芦实。
无贪恚痴心，是说为黠慧，
内发不自伤，是名为胜士。
是故当离贪，瞋恚痴冥心，
比丘智慧明，苦尽般涅槃。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○六六）

    如手比丘，《难陀修多罗》亦如是说。

（一○六七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者难陀，是佛姨母子，好着好衣，染色捣治光泽，执持好钵，好作嬉戏，调笑而行。
    时有众多比丘来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，尊者难陀是佛姨母子，好着好衣，捣治光泽，执持好钵，好作嬉戏，调笑而行。”
    尔时世尊告一比丘：“汝往诣难陀比丘所，语言：难陀，大师语汝。”
    时彼比丘受世尊教，往语难陀言：“世尊语汝。”
    难陀闻已，即诣佛所，稽首佛足，退住一面。
    佛告难陀：“汝实好着好衣，捣治光泽，好作嬉戏，调笑而行不？”
    难陀白佛：“实尔，世尊。”
    佛告难陀：“汝佛姨母子，贵姓出家，不应着好衣服，捣令光泽，执持好钵，好作嬉戏，调笑而行。汝应作是念：我是佛姨母子，贵姓出家，应作阿练若，乞食，着粪扫衣，常应赞叹着粪扫衣，当处山泽，不顾五欲。”
    尔时难陀受佛教已，修阿兰若行，乞食，着粪扫衣，亦常赞叹着粪扫衣者，乐处山泽，不顾爱欲。
    尔时世尊即说偈言：

“难陀何见汝，修习阿兰若，
家家行乞食，身着粪扫衣，
乐处于山泽，不顾于五欲。”

    佛说此经已，尊者难陀闻佛所说，欢喜奉行。

（一○六八）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    尔时尊者低沙，自念我是世尊姑子兄弟，故不修恭敬，无所顾录，亦不畏惧，不堪谏止。
    时有众多比丘往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，尊者低沙自念是世尊姑子兄弟，故不修恭敬，无所顾录，亦不畏惧，不堪谏止。”
    尔时世尊告一比丘：“汝往诣低沙比丘所，语言：低沙，大师语汝。”
    时彼比丘受世尊教，往语低沙比丘言：“世尊语汝。”
    低沙比丘即诣佛所，稽首佛足，退住一面。
    佛告低沙：“汝实作是念，我是世尊姑子兄弟，不修恭敬，无所顾录，亦不畏惧，不堪忍谏不？”
    低沙白佛：“实尔，世尊。”
    佛告低沙：“汝不应尔！汝应念言：我是世尊姑子兄弟，故应修恭敬畏惧，堪忍谏止。”
    尔时世尊即说偈言：

“善哉汝低沙，离瞋恚为善，
莫生瞋恚心，瞋恚者非善。
若能离瞋慢，修行软下心，
然后于我所，修行于梵行。”

    佛说此经已，低沙比丘闻佛所说，欢喜随喜，作礼而去。

（一○六九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有尊者毗舍佉般阇梨子，集供养堂，为众多比丘说法。言辞满足，妙音清彻，句味辩正，随智慧说，听者乐闻，无所依说，显现深义，令诸比丘一心专听。
    尔时世尊入昼正受，以净天耳，过于人耳，闻说法声。从三昧起，往诣讲堂，于大众前坐，告毗舍佉般阇梨子：“善哉善哉！毗舍佉，汝能为诸比丘，于此供养堂为众多比丘说法，言辞满足，乃至显现深义，令诸比丘专精敬重，一心乐听。汝当数数为诸比丘如是说法，令诸比丘专精敬重，一心乐听，当得长夜以义饶益，安隐乐住。”
    尔时世尊即说偈言：

“若不说法者，愚智杂难分，
此愚此智慧，无由自显现。
善说清凉法，因说智乃彰，
说法为明照，光显大仙幢，
善说为仙幢，法为罗汉幢。”

    佛说此经已，尊者毗舍佉般阇梨子闻佛所说，欢喜随喜，作礼而去。

（一○七○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有众多比丘集供养堂，悉共作衣。时有一年少比丘，出家未久，初入法律，不欲营助诸比丘作衣。
    时众多比丘诣世尊所，稽首礼足，退坐一面，白佛言：“世尊，时有众多比丘集供养堂，为作衣故。有一年少比丘，出家未久，始入法律，不欲营助诸比丘作衣。”
    尔时世尊问彼比丘：“汝实不欲营助诸比丘作衣耶？”
    彼比丘白佛言：“世尊，随我所能，当力营助。”
    尔时世尊知彼比丘心之所念，告诸比丘：“汝等莫与是年少比丘语。所以者何？是比丘得四增心法正受，现法安乐住，不勤而得。若彼本心所为，剃须发，着袈裟衣，出家学道，增进修学，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。”
    尔时世尊即说偈言：

“非下劣方便，薄德少智慧；
正向于涅槃，免脱烦恼锁。
此贤年少者，逮得上士处，
离欲心解脱，涅槃不复生，
持此最后身，摧伏众魔军。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○七一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有比丘名曰上座，独住一处，亦常赞叹独一住者，独行乞食，食已独还，独坐禅思。
    时有众多比丘诣佛所，稽首佛足，退坐一面，白佛言：“世尊，有尊者名曰上座，乐一独处，亦常赞叹独一住者，独入聚落乞食，独出聚落，还至住处，独坐禅思。”
    尔时世尊语一比丘：“汝往诣彼上座比丘所，语上座比丘言：大师告汝。”
    比丘受教，诣上座比丘所，白言：“尊者，大师告汝。”
    时上座比丘即时奉命，诣世尊所，稽首礼足，退住一面。
    尔时世尊告上座比丘：“汝实独一静处，赞叹独处者，独行乞食，独出聚落，独坐禅思耶？”
    上座比丘白佛：“实尔，世尊。”
    佛告上座比丘：“汝云何独一处，赞叹独住者，独行乞食，独还住处，独坐禅思？”
    上座比丘白佛：“我唯独一静处，赞叹独住者，独行乞食，独出聚落，独坐禅思。”
    佛告上座比丘：“汝是一住者，我不言非一住，然更有胜妙一住。何等为胜妙一住？谓比丘前者枯干，后者灭尽，中无贪喜。是婆罗门心不犹豫，已舍忧悔，离诸有爱，群聚使断。是名一住，无有胜住过于此者。”
    尔时世尊即说偈言：

“悉映于一切，悉知诸世间，
不著一切法，悉离一切爱，
如是乐住者，我说为一住。”

    佛说此经已，尊者上座闻佛所说，欢喜随喜，作礼而去。

（一○七二）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    时有尊者僧迦蓝，于拘萨罗人间游行，至舍卫国祇树给孤独园。
    彼僧迦蓝比丘有本二，在舍卫国中，闻僧迦蓝比丘于拘萨罗人间游行，至舍卫国祇树给孤独园。闻已，着好衣服，庄严花璎，抱其儿来诣祇洹，至僧迦蓝比丘房前。
    尔时尊者僧迦蓝出房，露地经行。时彼本二来到其前，作是言：“此儿幼小，汝舍出家，谁当养活？”
    时僧迦蓝比丘不共语。如是再三，亦不共语。
    时彼本二作如是言：“我再三告，不与我语，不见顾视，我今置儿！”着经行道头而去，言：“沙门，此是汝子，汝自养活，我今舍去！”
    尊者僧迦蓝亦不顾视其子。
    彼本二复言：“是沙门今于此儿都不顾视，彼必得仙人难得之处。善哉沙门！必得解脱。”情愿不遂，抱子而去。
    尔时世尊入昼正受，以天耳过人之耳，闻尊者僧迦蓝本二所说，即说偈言：

“来者不欢喜，去亦不忧戚，
于世间和合，解脱不染著，
我说彼比丘，为真婆罗门。
来者不欢喜，去亦不忧戚，
不染亦无忧，二心俱寂静，
我说是比丘，是真婆罗门。”

    佛说此经已，尊者僧迦蓝闻佛所说，欢喜随喜，作礼而去。

（一○七三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者阿难独一静处，作是思惟：“有三种香，顺风而熏，不能逆风。何等为三？谓根香、茎香、花香。或复有香，顺风熏，亦逆风熏，亦顺风逆风熏耶？”作是念已，晡时从禅觉，往诣佛所，稽首佛足，退住一面，白佛言：“世尊，我独一静处，作是思惟：有三种香，顺风而熏，不能逆风。何等为三？谓根香、茎香、花香。或复有香，顺风熏，逆风熏，亦顺风逆风熏耶？”
    佛告阿难：“如是如是，有三种香，顺风熏，不能逆风，谓根香、茎香、花香。阿难，亦有香，顺风熏、逆风熏、顺风逆风熏。阿难，顺风熏、逆风熏、顺风逆风熏者，阿难，有善男子、善女人，在所城邑聚落，成就真实法，尽形寿不杀生、不偷盗、不邪淫、不妄语、不饮酒。如是善男子、善女人，八方上下崇善士夫，无不称叹言：‘某方某聚落善男子、善女人，持戒清净，成真实法，尽形寿不杀，乃至不饮酒。’阿难，是名有香顺风熏、逆风熏、顺风逆风熏。”
    尔时世尊即说偈言：

“非根茎花香，能逆风而熏，
唯有善士女，持戒清净香，
逆顺满诸方，无不普闻知。
多迦罗栴檀，优钵罗末利，
如是比诸香，戒香最为上。
栴檀等诸香，所熏少分限，
唯有戒德香，流熏上升天。
斯等净戒香，不放逸正受，
正智等解脱，魔道莫能入。
是名安隐道，是道则清净，
正向妙禅定，断诸魔结缚。”

    佛说此经已，尊者阿难闻佛所说，欢喜随喜，作礼而去。

（一○七四）

    如是我闻。一时佛在摩竭提国人间游行，与千比丘俱，皆是古昔萦发出家，皆得阿罗汉，诸漏已尽，所作已作，舍诸重担，逮得己利，尽诸有结，正智善解脱，到善建立支提杖林中住。
    摩竭提王瓶沙，闻世尊摩竭提国人间游行，至善建立支提杖林中住。与诸小王，群臣翼从，车万二千乘，马万八千，步逐众无数。摩竭提婆罗门长者，悉皆从王出王舍城，诣世尊所，恭敬供养。到于道口，下车步进。及于内门，除去五饰，脱冠、却盖、除扇、去剑刀、脱革屣，到于佛前，整衣服，偏露右肩，为佛作礼，右绕三匝，自称姓名，白佛言：“世尊，我是摩竭提王瓶沙。”
    佛告瓶沙：“如是大王，汝是瓶沙！可就此坐，随其所安。”
    时瓶沙王重礼佛足，退坐一面。诸王、大臣、婆罗门、居士，悉礼佛足，次第而坐。
    时郁鞞罗迦叶亦在座中。时摩竭提婆罗门长者作是念：“为大沙门从郁鞞罗迦叶所修梵行耶？为郁鞞罗迦叶于大沙门所修梵行耶？”
    尔时世尊知摩竭提婆罗门长者心之所念，即说偈而问言：

“郁鞞罗迦叶，于此见何利，
弃汝先所奉，事火等众事？
今可说其义，舍事火之由。”

    郁鞞迦叶说偈白佛：

“钱财等滋味，女色五欲果，
观察未来受，斯皆大垢秽，
是故悉弃舍，先诸奉火事。”

    尔时世尊复说偈问言：

“汝不著世间，钱财五色味，
复何舍天人，迦叶随义说。”

    迦叶复以偈答世尊言：

“见道离有余，寂灭无余迹，
无所有不著，无异趣异道，
是故悉弃舍，先修奉火事。
大会等受持，奉事于水火，
愚痴没于中，志求解脱道。
盲无智慧目，向生老病死，
不见于正路，永离生死道。
今始因世尊，得见无为道，
大龙所说力，得度于彼岸。
牟尼广济度，安慰无量众，
今始知瞿昙，真谛超出者！”

    佛复说偈叹迦叶言：

“善哉汝迦叶，先非恶思量，
次第分别求，遂至于胜处。

    “汝今迦叶，当安慰汝徒众之心。”
    时郁鞞罗迦叶即入正受，以神足力，向于东方，上升虚空，作四种神变，行、住、坐、卧。入火三昧，举身洞燃，青、黄、赤、白、玻璃、红色。身上出水，身下出火，还烧其身，身上出水，以灌其身。或身上出火，以烧其身，身下出水，以灌其身。如是种种现化神通息已，稽首佛足，白佛言：“世尊，佛是我师，我是弟子。”
    佛告迦叶：“我是汝师，汝是弟子。随汝所安，复座而坐。”
    时郁鞞罗迦叶还复故座。
    尔时摩竭提婆罗门长者作是念：“郁鞞罗迦叶定于大沙门所修行梵行。”
    佛说此经已，摩竭提王瓶沙及诸婆罗门长者闻佛所说，欢喜随喜，作礼而去。

（一○七五）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有陀骠摩罗子，旧住王舍城，典知众僧饮食、床座，随次差请，不令越次。
    时有慈地比丘，频三过次，得粗食处，食时辛苦，作是念：“怪哉大苦！陀骠摩罗子比丘，有情故以粗食恼我，令我食时极苦。我当云何为其作不饶益事？”
    时慈地比丘有姊妹比丘尼，名蜜多罗，住王舍城王园比丘尼众中。蜜多罗比丘尼来诣慈地比丘，稽首礼足，于一面住。慈地比丘不顾眄，不与语。蜜多罗比丘尼语慈地比丘：“阿阇梨，何故不见顾眄，不共言语？”
    慈地比丘言：“陀骠摩罗子比丘，数以粗食恼我，令我食时极苦，汝复弃我！”
    比丘尼言：“当如何？”
    慈地比丘言：“汝可至世尊所，白言：‘世尊，陀骠摩罗子比丘非法不类，共我作非梵行，波罗夷罪。’我当证言：‘如是世尊，如妹所说。’”
    比丘尼言：“阿阇梨，我当云何于梵行比丘所，以波罗夷谤？”
    慈地比丘言：“汝若不如是者，我与汝绝，不复来往言语，共相瞻视。”
    时比丘尼须臾默念，而作是言：“阿阇梨欲令我尔，当从其教。”
    慈地比丘言：“汝且待我先至世尊所，汝随后来。”
    时慈地比丘即往，稽首礼世尊足，退住一面。
    蜜多罗比丘尼即随后至，稽首佛足，退住一面，白佛言：“世尊，一何不善不类！陀骠摩罗子于我所，作非梵行，波罗夷罪。”
    慈地比丘复白佛言：“如妹所说，我先亦知。”
    尔时陀骠摩罗子比丘即在彼大众中。尔时世尊告陀骠摩罗子比丘：“汝闻此语不？”
    陀骠摩罗子比丘言：“已闻，世尊。”
    佛告陀骠摩罗子比丘：“汝今云何？”
    陀骠摩罗子白佛：“如世尊所知，如善逝所知。”
    佛告陀骠摩罗子：“汝言如世尊所知，今非是时。汝今忆念，当言忆念；不忆念，当言不忆念。”
    陀骠摩罗子言：“我不自忆念。”
    尔时尊者罗睺罗住于佛后，执扇扇佛，白佛言：“世尊，不善不类！是比丘尼言：‘尊者陀骠摩罗子共我作非梵行。’慈地比丘言：‘如是世尊，我先已知，如妹所说。’”
    佛告罗睺罗：“我今问汝，随意答我。若蜜多罗比丘尼来语我言：‘世尊，不善不类！罗睺罗共我作非梵行，波罗夷罪。’慈地比丘复白我言：‘如是世尊，如妹所说，我先亦知’者，汝当云何？”
    罗睺罗白佛：“世尊，我若忆念，当言忆念。不忆念，当言不忆念。”
    佛告罗睺罗：“愚痴人！汝尚得作此语。陀骠摩罗子清净比丘，何以不得作如是语？”
    尔时世尊告诸比丘：“于陀骠摩罗子比丘，当忆念。蜜多罗比丘尼，当以自言灭。慈地比丘，僧当极善呵谏教诫：汝云何见？何处见？汝何因往见？”
    世尊如是教已，从座起，入室坐禅。
    尔时诸比丘，于陀骠摩罗子比丘，忆念。蜜多罗比丘尼，与自言灭。慈地比丘，极善呵谏教诫言：“汝云何见？何处见？何因往见？”如是谏时，彼作是言：“彼陀骠摩罗子，不作非梵行，不犯波罗夷。然陀骠摩罗子比丘，三以粗恶食恐怖，令我食时辛苦，我于陀骠摩罗子比丘爱恚痴怖，故作是说。然陀骠摩罗子清净无罪。”
    尔时世尊晡时从禅觉，至大众前，敷座而坐。
    诸比丘白佛言：“世尊，我等于陀骠摩罗子比丘所，忆念持。蜜多罗比丘尼，与自言灭。慈地比丘，极善呵谏，乃至彼言：‘陀骠摩罗子清净无罪。’”
    尔时世尊告诸比丘：“云何愚痴，以因饮食故，知而妄语！”
    尔时世尊即说偈言：

“若能舍一法，知而故妄语，
不计于后世，无恶而不为。
宁食热铁丸，如炽燃炭火，
不以犯禁戒，而食僧信施。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○七六）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者陀骠摩罗子诣佛所，稽首佛足，退住一面，白佛言：“世尊，我愿于佛前取般涅槃。”
    世尊默然。如是三启。
    佛告陀骠摩罗子：“此有为诸行，法应如是。”
    尔时尊者陀骠摩罗子，即于佛前入于三昧，如其正受，向于东方，升虚空行，现四威仪，行、住、坐、卧。入火三昧，身下出火，举身洞燃，光焰四布，青、黄、赤、白、玻璃、红色。身下出火，还烧其身，身上出水，以洒其身。或身上出火，下烧其身，身下出水，上洒其身。周向十方，种种现化已，即于空中，内身出火，还自焚其身，取无余涅槃，消尽寂灭，令无遗尘。譬如空中燃灯，油、炷俱尽。陀骠摩罗子空中涅槃，身心俱尽，亦复如是。
    尔时世尊即说偈言：

“譬如烧铁丸，其焰洞炽燃，
热势渐息灭，莫知其所归。
如是等解脱，度烦恼淤泥，
诸流永已断，莫知其所之，
逮得不动迹，入无余涅槃。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○七七）

    如是我闻。一时佛在央瞿多罗国人间游行，经陀婆阇梨迦林中。见有牧牛者、牧羊者、采柴草者，及余种种作人，见世尊行路，见已皆白佛言：“世尊，莫从此道去！前有央瞿利摩罗贼，脱恐怖人。”
    佛告诸人：“我不畏惧。”作此语已，从道而去。彼再三告，世尊犹去，遥见央瞿利摩罗，手执刀楯，走向世尊，以神力现身徐行，令央瞿利摩罗驶走不及。走极疲乏已，遥语世尊：“住！住！勿去。”
    世尊并行而答：“我常住耳，汝自不住。”
    尔时央瞿利摩罗即说偈言：

“沙门尚驶行，而言我常住；
我今疲倦住，说言汝不住。
沙门说云何，我住汝不住？”

    尔时世尊以偈答言：

“央瞿利摩罗，我说常住者，
于一切众生，谓息于刀杖；
汝恐怖众生，恶业不休息。
我于一切虫，止息于刀杖；
汝于一切虫，常逼迫恐怖，
造作凶恶业，终无休息时。
我于一切神，止息于刀杖；
汝于一切神，长夜苦逼迫，
造作黑恶业，于今不止息。
我住于息法，一切不放逸；
汝不见四谛，故不息放逸。”

    央瞿利摩罗说偈白佛：

“久乃见牟尼，故随路而逐，
今闻真妙说，当舍久远恶。”
作如是说已，即放舍刀楯，
投身世尊足，愿听我出家。
佛以慈悲心，大仙多哀愍，
告比丘善来，出家受具足。

    尔时央瞿利摩罗出家已，独一静处，专精思惟，所以族姓子剃除须发，着袈裟衣，正信非家，出家学道，增修梵行，现法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。
    时央瞿利摩罗得阿罗汉，觉解脱喜乐，即说偈言：

“本受不害名，而中多杀害，
今得见谛名，永离于伤杀。
身行不杀害，口意俱亦然，
当知真不杀，不迫于众生。
洗手常血色，名央瞿摩罗，
浚流之所漂，三归制令息。
归依三宝已，出家得具足，
成就于三明，佛教作已作。
调牛以捶杖，伏象以铁钩，
不以刀捶杖，正度调天人。
利刀以水石，直箭以温火，
治杖以斧斤，自调以黠慧。
人前行放逸，随后能自敛，
是则照世间，如云解月现。
人前放逸行，随后能自敛，
于世恩爱流，正念而超出。
少壮年出家，精勤修佛教，
是则照世间，如云解月现。
少壮年出家，精勤修佛教，
于世恩爱流，正念以超出。
若度诸恶业，正善能令灭，
是则照世间，如云解月现。
人前造恶业，正善能令灭，
于世恩爱流，正念能超出。
我已作恶业，必向于恶趣，
已受于恶报，宿债食已食。
若彼我怨憎，闻此正法者，
得清净法眼，于我修行忍，
不复兴斗讼，蒙佛恩力故。
我慈行忍辱，亦常赞叹忍，
随时闻正法，闻已随修行。”

    佛说此经已，央瞿利摩罗闻佛所说，欢喜奉行。

（一○七八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有异比丘，于夜明相出时，出榻补河边，脱衣着岸边，入水洗浴。浴已上岸，被一衣，待身干。
    时有一天子，放身光明，普照榻补河侧，语比丘言：“汝少出家，鲜白发黑，年始盛美，应习五欲，庄严璎珞，涂香花鬘，五乐自娱。而于是时，违亲背俗，悲泣别离，剃除须发，着袈裟衣，正信非家，出家学道。如何舍现前乐，而求非时之利？”
    比丘答言：“我不舍现前乐，求非时乐。我今乃是舍非时乐，得现前乐。”
    天问比丘：“云何舍非时乐，得现前乐？”
    比丘答言：“如世尊说，非时之欲，少味多苦，少利多难。我今于现法中，已离炽然，不待时节，能自通达，现前观察，缘自知觉。如是天子，是名舍非时乐，得现前乐。”
    天复问比丘：“云何复是如来所说非时之欲，少乐多苦？云何复是如来所说现法利乐，乃至缘自觉知？”
    比丘答言：“我年少出家，不能广宣如来所说正法律仪。世尊近在迦兰陀竹园，汝可往诣如来，问其所疑，如世尊说，随忆受持。”
    天子复言：“比丘，于如来所，有诸方天众多围绕，我先无问，未易可诣。比丘，汝若能为先白世尊者，我可随往。”
    比丘答言：“当为汝去。”
    天白比丘：“唯然尊者，我随后来。”
    时彼比丘往诣佛所，稽首礼足，退住一面，以向天子往反问答具白世尊：“今者世尊，彼天子诚实言者，须臾应至。不诚实者，自当不来。”
    时彼天子遥语比丘：“我已在此，我已在此。”
    尔时世尊即说偈言：

“众生随爱想，以爱想而住，
以不知爱故，则为死方便。”

    佛告天子：“汝解此偈者，便可发问。”
    天子白佛：“不解，世尊。不解，善逝。”
    佛复说偈而告天子曰：

“若知所爱者，不于彼生爱，
彼此无所有，他人莫能说。”

    佛告天子：“汝解此义者，便可发问。”
    天子白佛：“不解，世尊。不解，善逝。”
    佛复说偈言：

“见等胜劣者，则有言论生，
三事不倾动，则无软中上。”

    佛告天子：“解此义者，则可发问。”
    天子白佛：“不解，世尊。不解，善逝。”
    佛复说偈言：

“断爱及名色，除慢无所系，
寂灭息瞋恚，离结绝悕望，
不见于人天，此世及他世。”

    佛告天子：“解此义者，乃可发问。”
    天子白佛：“已解，世尊。已解，善逝。”
    佛说此经已，彼天子闻佛所说，欢喜随喜，即没不现。

（一○七九）

    如是我闻。一时佛在王舍城迦兰陀竹园。
    时有异比丘，于后夜时，至榻补河边，脱衣置岸边，入水洗浴。浴已还上岸，着一衣，待身干。
    时有一天子，放身光明，普照榻补河侧，问比丘言：“比丘，比丘，此是丘冢，夜则起烟，昼则火燃。彼婆罗门见已而作是言：‘坏此丘冢。’发掘者智，持以刀剑，又见大龟。婆罗门见已，作是言：‘除此大龟。’发掘者智，持以刀剑，见有氍氀。婆罗门见已，作此言：‘却此氍氀。’发掘者智，持以刀剑，见有肉段。彼婆罗门见已，作是言：‘除此肉段。’发掘者智，持以刀剑，见有屠杀。婆罗门见已，作是言：‘坏是屠杀处。’发掘者智，持以刀剑，见有楞耆。彼婆罗门见已，作是言：‘却此楞耆。’发掘者智，持以刀剑，见有二道。彼婆罗门见已，作是言：‘除此二道。’发掘者智，持以刀剑，见有门扇。婆罗门见已，作是言：‘却此门扇。’发掘者智，持以刀剑，见有大龙。婆罗门见已，作是言：‘止！勿却大龙，应当恭敬。’比丘，汝来受此论，往问世尊，如佛所说，汝随受持。所以者何？除如来，我不见世间诸天、魔、梵、沙门、婆罗门，于此论心悦乐者。若诸弟子从我所闻，然后能说。”
    尔时比丘从彼天所闻此论已，往诣世尊，稽首礼足，退坐一面，以彼天子所问诸论广问世尊：“云何为丘冢？云何为夜则起烟？云何为昼则火燃？云何是婆罗门？云何发掘？云何智者？云何刀剑？云何为大龟？云何氍氀？云何为肉段？云何为屠杀处？云何为楞耆？云何为二道？云何为门扇？云何为大龙？”
    佛告比丘：“丘冢者，谓众生身，粗四大色，父母遗体，抟食、衣服覆盖、澡浴摩饰长养，皆是变坏磨灭之法。夜起烟者，谓有人于夜时起，随觉随观。昼行其教，身业、口业。婆罗门者，谓如来、应、等正觉。发掘者，谓精勤方便。智士者，谓多闻圣弟子。刀剑者，谓智慧刀剑。大龟者，谓五盖。氍氀者，谓忿恨。肉段者，谓悭愱。屠杀者，谓五欲功德。楞耆者，谓无明。二道，谓疑惑。门扇者，谓我慢。大龙者，谓漏尽罗汉。如是比丘，若大师为声闻所作，哀愍悲念，以义安慰，于汝已作。汝等当作所作，当于曝露林中、空舍、山泽、岩窟，敷草树叶，思惟禅思，不起放逸，莫令后悔，是则为我随顺之教。”
    即说偈言：

“说身为丘冢，觉观夜起烟，
昼业为火燃，婆罗门正觉。
精进勤发掘，黠慧明智士，
以智慧利剑，厌离胜进者。
五盖为巨龟，忿恨为氍氀，
悭愱为肉段，五欲屠杀处。
无明为楞耆，疑惑于二道，
门扇现我慢，漏尽罗汉龙。
究竟断诸论，故我如是说。”

    佛说此经已，彼比丘闻佛所说，欢喜奉行。

（一○八○）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊晨朝着衣持钵，入波罗奈城乞食。时有异比丘，以不住心，其心惑乱，不摄诸根，晨朝着衣持钵，入波罗奈城乞食。是比丘遥见世尊，见已摄持诸根，端视而行。
    世尊见是比丘摄持诸根，端视而行，见已入城乞食毕，还精舍，举衣钵，洗足已，入室坐禅。晡时从禅觉，入僧中，敷坐具，于大众前坐，告诸比丘：“我今晨朝着衣持钵，入波罗奈城乞食，见有比丘，以不住心、惑乱心，诸根放散，亦持衣钵入城乞食。彼遥见我，即自敛摄，竟为是谁？”
    时彼比丘从座起，整衣服，到于佛前，偏袒右肩，合掌白佛：“世尊，我于晨朝入城乞食，其心惑乱，不摄诸根行，遥见世尊，即自敛心，摄持诸根。”
    佛告比丘：“善哉善哉！汝见我已，能自敛心，摄持诸根。比丘，是法应当如是。若见比丘，亦应自摄持。若复见比丘尼、优婆塞、优婆夷，亦当如是摄持诸根。当得长夜以义饶益，安隐快乐。”
    尔时众中复有异比丘说偈叹曰：

“以其心迷乱，不专系念住，
晨朝持衣钵，入城邑乞食。
中路见大师，威德容仪备，
欣悦生惭愧，即摄持诸根。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。


杂阿含经卷第三十九

（一○八一）

    如是我闻。一时佛住波罗奈国鹿野苑中。
    尔时世尊晨朝着衣持钵，入波罗奈城乞食。
    时有异比丘着衣持钵，入城乞食，于其路边，住一树下，起不善觉，以依恶贪。
    尔时世尊见彼比丘住一树下，以生不善觉，依恶贪嗜，而告之曰：“比丘比丘！莫种苦种，而发熏生臭，汁漏流出。若比丘种苦种子，自发熏生臭，汁漏流出者，欲令蛆蝇不竞集者，无有是处。”
    时彼比丘作是念：“世尊知我心之恶念！”即生恐怖，身毛皆竖。
    尔时世尊入城乞食毕，还精舍，举衣钵，洗足已，入室坐禅。晡时从禅觉，至于僧中，于众前敷座而坐，告诸比丘：“我今晨朝着衣持钵，入城乞食，见一比丘住于树下，以生不善觉，依恶贪嗜。我时见已，即告之言：‘比丘比丘！莫种苦种，发熏生臭，恶汁流出。若有比丘种苦种子，发熏生臭，恶汁流出，蛆蝇不集，无有是处。’时彼比丘即思念：‘佛已知我心之所念。’惭愧恐怖，心惊毛竖，随路而去。”
    时有异比丘从座起，整衣服，偏袒右肩，合掌白佛：“世尊，云何苦种？云何生臭？云何汁流？云何蛆蝇？”
    佛告比丘：“忿怒烦怨，名曰苦种。五欲功德，名为生臭。于六触入处，不摄律仪，是名汁流。谓触入处不摄已，贪忧诸恶不善心竞生，是名蛆蝇。”
    尔时世尊即说偈言：

“耳目不防护，贪欲从是生，
是名为苦种，生臭汁潜流，
诸觉观气味，依于恶贪嗜。
聚落及空处，若于昼若夜，
远离修梵行，究竟于苦边。
若内心寂静，决定谛明了，
卧觉常安乐，诸恶蛆蝇灭。
正士所习近，善说贤圣路，
了知八正道，不还更受身。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○八二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊晨朝着衣持钵，入舍卫城乞食。食毕，还精舍，洗足已，入安陀林坐禅。
    时有异比丘，亦复晨朝着衣持钵，入舍卫城乞食。食毕，还精舍，洗足已，入安陀林，坐一树下，入昼正受。是比丘入昼正受时，有恶不善觉起，依贪嗜心。
    时有天神，依安陀林住止者，作是念：“此比丘不善不类，于安陀林坐禅，而起不善觉，心依恶贪。我当往呵责！”作是念已，往语比丘言：“比丘比丘，作疮疣耶？”
    比丘答言：“当治令愈。”
    天神语比丘：“疮如铁镬，云何可复？”
    比丘答言：“正念正智，足能令复。”
    天神白言：“善哉善哉！此是真贤治疮。如是治疮，究竟能愈，无有发时。”
    尔时世尊晡时从禅觉，还祇树给孤独园，入僧中，于大众前敷座而坐，告诸比丘：“我今晨朝着衣持钵，入舍卫城乞食。乞食还，至安陀林坐禅，入昼正受。有一比丘亦乞食还，至安陀林，坐一树下，入昼正受，而彼比丘起不善觉，心依恶贪。有天神依安陀林住，语比丘言：‘比丘比丘，作疮疣耶？’如上广说，乃至‘如是比丘，善哉善哉，此治众贤。’”
    尔时世尊即说偈言：

“士夫作疮疣，自生于苦患，
愿求世间欲，心依于恶贪，
以生疮疣故，蛆蝇竞来集。
爱欲为疮疣，蛆蝇诸恶觉，
及诸贪嗜心，皆悉从意生。
钻凿士夫心，以求华名利，
欲火转炽然，妄想不善觉，
身心日夜羸，远离寂静道。
若内心寂静，决定智明了，
无有斯疮疣，见佛安隐路。
正士所游迹，贤圣善宣说，
明智所知道，不复受诸有。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○八三）

    如是我闻。一时佛住毗舍离国猕猴池侧重阁讲堂。
    时有众多比丘，晨朝着衣持钵，入毗舍离乞食。
    时有年少比丘，出家未久，不闲法律，当乞食时，不知先后次第。
    余比丘见已而告之言：“汝是年少，出家未久，未知法律，莫越莫重。前后失次而行乞食，长夜当得不饶益苦。”
    年少比丘言：“诸上座亦复越次，不随前后，非独我也。”如是再三，不能令止。
    众多比丘乞食已，还精舍，举衣钵，洗足已，诣佛所，稽首礼足，退坐一面，白佛言：“世尊，我等晨朝着衣持钵，入毗舍离乞食。有一年少比丘，于此法律出家未久，行乞食时，不以次第，前后复重。诸比丘等再三谏，不受而作是言：‘诸上座亦不次第，何故呵我？’我等诸比丘三呵不受，故来白世尊，唯愿世尊为除非法，哀愍故！”
    佛告诸比丘：“如空泽中有大湖水，有大龙象，而居其中，拔诸藕根，洗去泥土，然后食之，食已身体肥悦，多力多乐，以是因缘，常喜乐住。有异种族象，形体羸小，效彼龙象，拔其藕根，洗不能净，合泥土食，食之不消，体不肥悦，转转羸弱，缘斯致死，或同死苦。
    “如是宿德比丘，学道日久，不乐嬉戏，久修梵行，大师所叹，诸余明智修梵行者亦复加叹。是等比丘，依止城邑聚落，晨朝着衣持钵，入城乞食，善护身口，善摄诸根，专心系念，能令彼人不信者信，信者不异。若得财利、衣被、饮食、床卧、汤药，不染不著，不贪不嗜，不迷不逐。见其过患，见其出离，然复食之。食已身心悦泽，得色得力，以是因缘，常得安乐。
    “彼年少比丘，出家未久，未闲法律，依诸长老，依止聚落，着衣持钵，入村乞食，不善护身，不守根门，不专系念，不能令彼不信者信，信者不变。若得财利、衣被、饮食、卧具、汤药，染著贪逐，不见过患，不见出离，以嗜欲心食，不能令身悦泽，安隐快乐。缘斯食故，转向于死，或同死苦。所言死者，谓舍戒还俗，失正法正律。同死苦者，谓犯正法律，不识罪相，不知除罪。”
    尔时世尊即说偈言：

“龙象拔藕根，水洗而食之。
异族象效彼，合泥而取食，
因杂泥食故，羸病遂至死。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○八四）

    如是我闻。一时佛住王舍城寒林中丘冢间。
    尔时世尊告诸比丘：“寿命甚促，转就后世，应勤习善法，修诸梵行，无有生而不死者。而世间人不勤方便，专修善法，修贤修义。”
    时魔波旬作是念：“沙门瞿昙住王舍城寒林中丘冢间，为诸声闻如是说法：‘人命甚促，乃至不修贤修义。’我今当往，为作娆乱。”
    时魔波旬化作年少，往住佛前，而说偈言：

“常逼迫众生，得人间长寿，
迷醉放逸心，亦不向死处。”

    尔时世尊作是念：“此是恶魔来作恼乱。”
    即说偈言：

“常逼迫众生，受生极短寿，
当勤修精进，犹如救头燃，
勿得须臾懈，令死魔忽至。
知汝是恶魔，速于此灭去！”

    天魔波旬作是念：“沙门瞿昙已知我心。”惭愧忧戚，即没不现。

（一○八五）

    如是我闻。一时佛住王舍城寒林中丘冢间。
    尔时世尊告诸比丘：“一切行无常，一切行不恒、不安、非苏息，变易之法，乃至当止一切有为行，厌离、不乐、解脱。”
    时魔波旬作是念：“今沙门瞿昙住王舍城寒林中，为诸声闻说如是法：‘一切行无常、不恒、非苏息，变易之法，乃至当止一切有为，厌离、不乐、解脱。’我当往彼，为作娆乱。”即化作年少，往诣佛所，住于佛前，而说偈言：

“寿命日夜流，无有穷尽时，
寿命当来去，犹如车轮转。”

    尔时世尊作是念：“此是恶魔欲作娆乱。”即说偈言：

“日夜常迁流，寿亦随损减，
人命渐消亡，犹如小河水。
我知汝恶魔，便自消灭去！”

    时魔波旬作是念：“沙门瞿昙已知我心。”惭愧忧戚，即没不现。

（一○八六）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊夜起经行，至于后夜，洗足入室，敛身正坐，专心系念。
    时魔波旬作是念：“今沙门瞿昙于王舍城迦兰陀竹园，夜起经行，于后夜时，洗足入室，正身端坐，系念禅思。我今当往，为作娆乱。”即化作年少，住于佛前，而说偈言：

“我心于空中，执长绳罥下，
正欲缚沙门，不令汝得脱！”

    尔时世尊作是念：“恶魔波旬欲作娆乱。”即说偈言：

“我说于世间，五欲意第六，
于彼永已离，一切苦已断，
我已离彼欲，心意识亦然。
波旬我知汝，速于此灭去！”

    时魔波旬作是念：“沙门已知我心。”惭愧忧戚，即没不现。

（一○八七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊夜起经行，至后夜时，洗足入室，右胁卧息，系念明相，正念正智，作起觉想。
    时魔波旬作是念：“今沙门瞿昙住王舍城迦兰陀竹园，乃至作起觉想。我今当往，为作留难。”即化作年少，往住佛前，而说偈言：

“何眠何故眠？已灭何复眠？
空舍何以眠？得出复何眠？”

    尔时世尊作是念：“恶魔波旬欲作娆乱。”即说偈言：

“爱网故染著，无爱谁持去？
一切有余尽，唯佛得安眠。
汝恶魔波旬，于此何所说！”

    时魔波旬作是念：“沙门瞿昙已知我心。”惭愧忧戚，即没不现。

（一○八八）

    如是我闻。一时佛住王舍城耆阇崛山中。
    尔时世尊于夜暗时，天小微雨，电光睒现，出房经行。
    时魔波旬作是念：“今沙门瞿昙住王舍城耆阇崛山中，夜暗微雨，电光时现，出房经行。我今当往，为作留难。”执大团石，两手调弄，到于佛前，碎成微尘。
    尔时世尊作是念：“恶魔波旬欲作娆乱。”即说偈言：

“若耆阇崛山，于我前令碎，
于佛等解脱，不能动一毛。
假令四海内，一切诸山地，
放逸之亲族，令其碎成尘，
亦不能倾动，如来一毛发。”

    时魔波旬作是念：“沙门瞿昙已知我心。”内怀忧戚，即没不现。

（一○八九）

    如是我闻。一时佛住王舍城耆阇崛山中。
    尔时世尊夜起经行，至后夜时，洗足入房，正身端坐，系念在前。
    时魔波旬作是念：“今沙门瞿昙住王舍城耆阇崛山中，夜起经行，后夜入房，正身端坐，系念在前。我今当往，为作留难。”即化作大龙，绕佛身七匝，举头临佛顶上。身如大船，头如大帆，眼如铜炉，舌如曳电，出息入息若雷雹声。
    尔时世尊作是念：“恶魔波旬欲作娆乱。”即说偈言：

“犹如空舍宅，牟尼心虚寂，
于中而旋转，佛身亦如是。
无量凶恶龙，蚊虻蝇蚤等，
普集食其身，不能动毛发。
破裂于虚空，倾覆于大地，
一切众生类，悉来作恐怖，
刀矛枪利箭，悉来害佛身，
如是诸暴害，不能伤一毛。”

    时魔波旬作是念：“沙门瞿昙已知我心。”内怀忧戚，即没不现。

（一○九○）

    如是我闻。一时佛住王舍城毗婆罗山七叶树林石室中。
    尔时世尊夜起露地，或坐或经行，至后夜时，洗足入室，安身卧息，右胁着地，足足相累，系念明相，正念正智，作起觉想。
    时魔波旬作是念：“沙门瞿昙住王舍城毗婆罗山七叶树林石室中，夜起露地，若坐若行，至后夜时，洗足入室而坐，右胁卧息，足足相累，系念明相，正念正智，作起觉想。我今当往，为作留难。”化作年少，往住佛前，而说偈言：

“为因我故眠，为是后边故？
多有钱财宝，何故守空闲，
独一无等侣，而著于睡眠？”

    尔时世尊作是念：“恶魔波旬欲作娆乱。”即说偈言：

“不因汝故眠，非为最后边，
亦无多钱财，唯集无忧宝，
哀愍世间故，右胁而卧息。
觉亦不疑惑，眠亦不恐怖，
若昼若复夜，无增亦无损，
为哀众生眠，故无有损减。
正复以百枪，贯身常摇动，
犹得安隐眠，已离内枪故。”

    时魔波旬作是念：“沙门瞿昙已知我心。”内怀忧戚，即没不现。

（一○九一）

    如是我闻。一时佛住王舍城毗婆罗山七叶树林石室中。
    时有尊者瞿低迦，住王舍城仙人山侧黑石室中，独一思惟，不放逸行，修自饶益，时受意解脱身作证，数数退转，一二三四五六反退，还复得时受意解脱身作证，寻复退转。
    彼尊者瞿低迦作是念：“我独一静处思惟，不放逸行，精勤修习，以自饶益，时受意解脱身作证，而复数数退转，乃至六反，犹复退转。我今当以刀自杀，莫令第七退转。”
    时魔波旬作是念：“沙门瞿昙住王舍城毗婆罗山侧七叶树林石窟中。有弟子瞿低迦，住王舍城仙人山侧黑石室中，独一静处，专精思惟，得时受意解脱身作证，六反退转，而复还得。彼作是念：‘我已六反退，而复还得，莫令我第七退转。我宁以刀自杀，莫令第七退转。’若彼比丘以刀自杀者，莫令自杀，出我境界去。我今当往，告彼大师。”
    尔时波旬执琉璃柄琵琶，诣世尊所，鼓弦说偈：

“大智大方便，自在大神力，
得炽然弟子，而今欲取死，
大牟尼当制，勿令其自杀。
何闻佛世尊，正法律声闻，
学其所不得，而取于命终？”

    时魔说此偈已，世尊说偈答言：

“波旬放逸种，以自事故来。
坚固具足士，常住妙禅定，
昼夜勤精进，不顾于性命。
见三有可畏，断除彼爱欲，
已摧伏魔军，瞿低般涅槃。”
波旬心忧恼，琵琶落于地，
内怀忧戚已，即没而不现。

    尔时世尊告诸比丘：“汝等当来，共至仙人山侧黑石室所，观瞿低迦比丘以刀自杀。”
    尔时世尊与众多比丘，往至仙人山侧黑石室中，见瞿低迦比丘杀身在地。告诸比丘：“汝等见此瞿低迦比丘杀身在地不？”
    诸比丘白佛：“唯然已见，世尊。”
    佛告比丘：“汝等见瞿低迦比丘，周匝绕身黑暗烟起，充满四方不？”
    比丘白佛：“已见，世尊。”
    佛告比丘：“此是恶魔波旬，于瞿低迦善男子身侧，周匝求其识神。然比丘瞿低迦，以不住心，执刀自杀。”
    尔时世尊为瞿低迦比丘授第一记。
    尔时波旬而说偈言：

“上下及诸方，遍求彼识神，
都不见其处，瞿低何所之？”

    尔时世尊复说偈言：

“如是坚固士，一切无所求，
拔恩爱根本，瞿低般涅槃。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一○九二）

    如是我闻。一时佛住郁鞞罗聚落尼连禅河侧，于菩提树下成佛未久。
    时魔波旬作是念：“今沙门瞿昙住郁鞞罗聚落尼连禅河侧，于菩提树下成佛未久。我当往彼，为作留难。”即化作年少，往住佛前，而说偈言：

“独入一空处，禅思静思惟，
已舍国财宝，于此复何求？
若求聚落利，何不习近人？
既不习近人，终竟何所得？”

    尔时世尊作是念：“恶魔波旬欲作娆乱。”即说偈言：

“已得大财利，志足安寂灭，
摧伏诸魔军，不著于色欲。
独一而禅思，服食禅妙乐，
是故不与人，周旋相习近。”

    魔复说偈言：

“瞿昙若自知，安隐涅槃道，
独善无为乐，何为强化人？”

    佛复说偈答言：

“非魔所制处，来问度彼岸，
我则以正答，令彼得涅槃，
时得不放逸，不随魔自在。”

    魔复说偈言：

“有石似凝膏，飞乌欲来食，
竟不得其味，损觜还归空，
我今亦如彼，徒劳归天宫。”

    魔说是已，内怀忧戚，心生变悔，低头伏地，以指画地。
    魔有三女，一名爱欲，二名爱念，三名爱乐，来至波旬所，而说偈言：

“父今何愁戚，士夫何足忧？
我以爱欲绳，缚彼如调象，
牵来至父前，令随父自在。”

    魔答女言：

“彼已离恩爱，非欲所能招，
已出于魔境，是故我忧愁。”

    时魔三女，身放光焰，炽如云中电，来诣佛所，稽首礼足，退住一面，白佛言：“我今归世尊足下，给侍使令。”
    尔时世尊都不顾视，知如来离诸爱欲，心善解脱。
    如是第二、第三说。时三魔女自相谓言：“士夫有种种随形爱欲，今当各各变化，作百种童女色、作百种初嫁色、作百种未产色、作百种已产色、作百种中年色、作百种宿年色，作此种种形类，诣沙门瞿昙所，作是言：今悉归尊足下，供给使令。”作此议已，即作种种变化，如上所说，诣世尊所，稽首礼足，退住一面，白佛言：“世尊，我等今日归尊足下，供给使令。”
    尔时世尊都不顾念，如来法离诸爱欲。
    如是再三说已，时三魔女自相谓言：“若未离欲士夫，见我等种种妙体，心则迷乱，欲气冲击，胸臆破裂，热血熏面。然今沙门瞿昙，于我等所，都不顾眄。如其如来离欲解脱，得善解脱想，我等今日当复各各说偈而问。”复到佛前，稽首礼足，退住一面。
    爱欲天女即说偈言：

“独一禅寂默，舍俗钱财宝，
既舍于世利，今复何所求？
若求聚落利，何不习近人？
竟不习近人，终竟何所得？”

    佛说偈答言：

“已得大财利，志足安寂灭，
摧伏诸魔军，不著于色欲，
是故不与人，周旋相习近。”

    爱念天女复说偈言：

“多修何妙禅，而度五欲流？
复以何方便，度于第六海？
云何修妙禅，于诸深广欲，
得度于彼岸，不为爱所持？”

    尔时世尊说偈答言：

“身得止息乐，心得善解脱，
无为无所作，正念不倾动。
了知一切法，不起诸乱觉，
爱恚睡眠覆，斯等皆已离。
如是多修习，得度于五欲，
亦于第六海，悉得度彼岸。
如是修习禅，于诸深广欲，
悉得度彼岸，不为彼所持。”

    时爱乐天女复说偈言：

“已断除恩爱，淳厚积集欲，
多生人净信，得度于欲流，
开发明智慧，超逾死魔境。”

    尔时世尊说偈答言：

“大方便广度，入如来法律，
斯等皆已度，慧者复何忧！”

    时三天女志愿不满，还诣其父魔波旬所。
    时魔波旬遥见女来，说偈弄之：

“汝等三女子，自夸说堪能，
咸放身光焰，如电云中流，
至大精进所，各现其容姿，
反为其所破，如风飘其绵。
欲以爪破山，齿啮破铁丸，
欲以发藕丝，旋转于大山，
和合悉解脱，而望乱其心。
若能缚风足，令月空中堕，
以手抒大海，气歔动雪山，
和合悉解脱，亦可令倾动。
于深巨海中，而求安足地，
如来于一切，和合悉解脱，
正觉大海中，求倾动亦然。”

    时魔波旬弄三女已，即没不现。

（一○九三）

    如是我闻。一时佛住郁鞞罗处尼连禅河侧大菩提树下，初成佛道。
    天魔波旬作是念：“此沙门瞿昙在郁鞞罗住处尼连禅河侧菩提树下，初成佛道。我今当往，为作留难。”即自变身，作百种净不净色，诣佛所。
    佛遥见波旬百种净不净色，作是念：“恶魔波旬作百种净不净色，欲作娆乱。”即说偈言：

“长夜生死中，作净不净色，
汝何为作此，不度苦彼岸？
若诸身口意，不作留难者，
魔所不能教，不随魔自在。
如是知恶魔，于是自灭去！”

    时魔波旬作是念：“沙门瞿昙已知我心。”内怀忧戚，即没不现。

（一○九四）

    如是我闻。一时佛住郁鞞罗处尼连禅河侧菩提树下，初成正觉。
    尔时世尊独一静处，专心禅思，作如是念：“我今解脱苦行，善哉！我今善解脱苦行。先修正愿，今已果得无上菩提。”
    时魔波旬作是念：“今沙门瞿昙住郁鞞罗处尼连禅河侧菩提树下，初成正觉。我今当往，为作留难。”即化作年少，住于佛前，而说偈言：

“大修苦行处，能令得清净，
而今反弃舍，于此何所求？
欲于此求净，净亦无由得。”

    尔时世尊作是念：“此魔波旬欲作娆乱。”即说偈言：

“知诸修苦行，皆与无义俱，
终不获其利，如弓但有声。
戒定闻慧道，我已悉修习，
得第一清净，其净无有上。”

    时魔波旬作是念：“沙门瞿昙已知我心。”内怀忧戚，即没不现。

（一○九五）

    如是我闻。一时佛住娑罗婆罗门聚落。尔时世尊晨朝着衣持钵，入婆罗聚落乞食。
    时魔波旬作是念：“今沙门瞿昙，晨朝着衣持钵，入婆罗聚落乞食。我今当往，先入其舍，语诸信心婆罗门长者，令沙门瞿昙空钵而出。”
    时魔波旬随逐佛后，作是唱言：“沙门！沙门！都不得食耶？”
    尔时世尊作是念：“恶魔波旬欲作娆乱。”即说偈言：

“汝亲于如来，获得无量罪，
汝谓呼如来，受诸苦恼耶？”

    时魔波旬作是言：“瞿昙，更入聚落，当令得食。”
    尔时世尊而说偈言：

“正使无所有，安乐而自活，
如彼光音天，常以欣悦食。
正使无所有，安乐而自活，
常以欣悦食，不依于有身。”

    时魔波旬作是念：“沙门瞿昙已知我心。”内怀忧戚，即没不现。

（一○九六）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“我已解脱人天绳索，汝等亦复解脱人天绳索。汝等当行人间，多所过度，多所饶益，安乐人天。不须伴行，一一而去。我今亦往郁鞞罗住处人间游行。”
    时魔波旬作是念：“沙门瞿昙住波罗奈仙人住处鹿野苑中，为诸声闻如是说法：‘我已解脱人天绳索，汝等亦能。汝等各别人间教化，乃至我亦当至郁鞞罗住处人间游行。’我今当往，为作留难。”即化作年少，住于佛前，而说偈言：

“不脱作脱想，谓呼已解脱，
为大缚所缚，我今终不放。”

    尔时世尊作是念：“恶魔波旬欲作娆乱。”即说偈言：

“我已脱一切，人天诸绳索，
已知汝波旬，即自消灭去！”

    时魔波旬作是念：“沙门瞿昙已知我心。”内怀忧戚，即没不现。

（一○九七）

    如是我闻。一时佛住释氏石主释氏聚落。
    时石主释氏聚落，多人疫死。处处人民，若男若女，从四方来，受持三归。其诸病人，若男若女，若大若小，皆因来者自称名字：“我某甲等，归佛、归法、归比丘僧。”举村举邑，皆悉如是。
    尔时世尊勤为声闻说法，时诸信心归三宝者，斯则皆生人、天道中。
    时魔波旬作是念：“今沙门瞿昙住于释氏石主释氏聚落，勤为四众说法。我今当往，为作留难。”化作年少，往住佛前，而说偈言：

“何为勤说法，教化诸人民？
相违不相违，不免于驱驰，
以有系缚故，而为彼说法。”

    尔时世尊作是念：“恶魔波旬欲作娆乱。”即说偈言：

“汝夜叉当知，众生群集生，
诸有智慧者，孰能不哀愍？
以有哀愍故，不能不教化，
哀愍诸众生，法自应如是。”

    恶魔波旬作是念：“沙门瞿昙已知我心。”内怀忧戚，即没不现。

（一○九八）

    如是我闻。一时佛住释氏石主释氏聚落。
    尔时世尊独一静处，禅思思惟，作是念：“颇有作王，能得不杀，不教人杀，一向行法，不行非法耶？”
    时魔波旬作是念：“今沙门瞿昙住石主释氏聚落，独一禅思，作是念：‘颇有作王，不杀生，不教人杀，一向行法，不行非法耶？’我今当往，为其说法。”化作年少，往住佛前，作是言：“如是世尊，如是善逝，可得作王，不杀生，不教人杀，一向行法，不行非法。世尊今可作王，善逝今可作王，必得如意！”
    尔时世尊作是念：“恶魔波旬欲作娆乱。”而告魔言：“汝魔波旬，何故作是言：作王，世尊；作王，善逝，可得如意！”
    魔白佛言：“我面从佛闻，作是说：‘若四如意足修习多修习已，欲令雪山王变为真金，即作不异。’世尊今有四如意足，修习多修习，令雪山王变为真金，如意不异。是故我白世尊：作王，世尊；作王，善逝，可得如意！”
    佛告波旬：“我都无心欲作国王，云何当作？我亦无心欲令雪山王变为真金，何由而变？”
    尔时世尊即说偈言：

“正使有真金，如雪山王者，
一人得此金，亦复不知足。
是故智慧者，金石同一观。”

    时魔波旬作是念：“沙门瞿昙已知我心。”内怀忧戚，即没不现。

（一○九九）

    如是我闻。一时佛住释氏石主释氏聚落。
    时有众多比丘集供养堂，为作衣事。
    时魔波旬作是念：“今沙门瞿昙住于释氏石主释氏聚落。众多比丘集供养堂，为作衣故。我今当往，为作留难。”化作少壮婆罗门像，作大萦发，着兽皮衣，手执曲杖，诣供养堂，于众多比丘前默然而住，须臾语诸比丘言：“汝等年少出家，肤白发黑，年在盛时，应受五欲，庄严自娱。如何违亲背族，悲泣别离，信于非家，出家学道？何为舍现世乐，而求他世非时之乐？”
    诸比丘语婆罗门：“我不舍现世乐，求他世非时之乐，乃是舍非时乐，就现世乐。”
    波旬复问：“云何舍非时乐，就现世乐？”
    比丘答言：“如世尊说，他世乐少味多苦，少利多患。世尊说现世乐者，离诸炽然，不待时节，能自通达，于此观察，缘自觉知。婆罗门，是名现世乐。”
    时婆罗门三反掉头喑哑，以杖筑地，即没不现。
    时诸比丘即生恐怖，身毛皆竖：“此是何等婆罗门像，来此作变？”即诣佛所，稽首礼足，退坐一面，白佛言：“世尊，我等众多比丘集供养堂，为作衣故。有一盛壮婆罗门，萦发大髻，来诣我所，作是言：‘汝等年少出家，如上广说。’乃至三反掉头喑哑，以杖筑地，即没不现。我等即生恐怖，身毛皆竖。是何婆罗门像，来作此变？”
    佛告诸比丘：“此非婆罗门，是魔波旬来至汝所，欲作娆乱。”
    尔时世尊即说偈言：

“凡生诸苦恼，皆由于爱欲，
知世皆剑刺，何人乐于欲？
觉世间有余，皆悉为剑刺，
是故黠慧者，当勤自调伏。
巨积真金聚，犹如雪山王，
一人受用者，意犹不知足，
是故黠慧者，当修平等观。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一○○）

    如是我闻。一时佛住释氏石主释氏聚落。
    时有尊者善觉，晨朝着衣持钵，入石主释氏聚落乞食。食已还精舍，举衣钵，洗足已，持尼师坛，置右肩上，入林中坐一树下，修昼正受，作是念：“我得善利！于正法律出家学道。我得善利！遭遇大师如来、等正觉。我得善利！得在梵行、持戒、备德、贤善、真实众中。我今当得贤善命终，于当来世亦当贤善。”
    时魔波旬作是念：“今沙门瞿昙住石主释氏聚落，有声闻弟子名曰善觉，着衣持钵，如上广说，乃至贤善命终，后世亦贤。我今当往，为作留难。”化作大身，盛壮多力，见者怖畏，谓其力能翻覆发动大地，至善觉比丘所。
    善觉比丘遥见大身勇盛壮士，即生恐怖，从座起，诣佛所，稽首礼足，退住一面，白佛言：“世尊，我今晨朝着衣持钵，广说如上，乃至贤善命终，后世亦贤。见有大身士夫，勇壮炽盛，力能动地，见生恐怖，心惊毛竖。”
    佛告善觉：“此非大身士夫，是魔波旬欲作娆乱。汝且还去，依彼树下修前三昧，动作彼魔，因斯脱苦。”
    时尊者善觉即还本处，至于晨朝，着衣持钵，入石主释氏聚落乞食。食已还精舍，如上广说，乃至贤善命终，后世亦贤。
    时魔波旬复作是念：“此沙门瞿昙住于释氏，有弟子名曰善觉，如上广说，乃至贤善命终，后世亦贤。我今当往，为作留难。”复化作大身，勇壮炽盛，力能发地，往住其前。
    善觉比丘复遥见之，即说偈言：

“我正信非家，而出家学道，
于佛法僧宝，正念系心住。
随汝变形色，我心不倾动，
觉汝为幻化，便可从此灭！”

    时魔波旬作是念：“是沙门已知我心。”内怀忧戚，即没不现。

（一一○一）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“如来声闻作狮子吼，说言已知、已知。不知如来声闻，于何等法已知，已知故作狮子吼？谓苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。”
    时天魔波旬作是念：“沙门瞿昙住波罗奈国仙人住处鹿野苑中，为诸声闻说法，乃至已知四圣谛。我今当往，为作留难。”化作年少，住于佛前，而说偈言：

“何于大众中，无畏狮子吼，
谓呼无有敌，望调伏一切？”

    尔时世尊作是念：“恶魔波旬欲作娆乱。”即说偈言：

“如来于一切，甚深正法律，
方便狮子吼，于法无所畏，
若有智慧者，何故自忧怖？”

    时魔波旬作是念：“沙门瞿昙已知我心。”内怀忧戚，即没不现。

（一一○二）

    如是我闻。一时佛住王舍城多众践蹈旷野中，与五百比丘众俱，而为说法，以五百钵置于中庭。
    尔时世尊为五百比丘，说五受阴生灭之法。
    时魔波旬作是念：“沙门瞿昙住王舍城多众践蹈旷野中，与五百比丘俱，乃至说五受阴是生灭法。我今当往，为作留难。”化作大牛，往诣佛所，入彼五百钵间。诸比丘即驱，莫令坏钵。
    尔时世尊告诸比丘：“此非是牛，是魔波旬欲作娆乱。”即说偈言：

“色受想行识，非我及我所，
若知真实灭，于彼无所著。
心无所著法，超出色结缚，
了达一切处，不住魔境界。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一○三）

    如是我闻。一时佛住王舍城多众践蹈旷野中，与六百比丘众俱，为诸比丘说六触入处集、六触集、六触灭。
    时魔波旬作是念：“今沙门瞿昙住王舍城多众践蹈旷野，为六百比丘说六触入处，是集法，是灭法。我今当往，为作留难。”化作壮士，大身勇盛，力能动地，来诣佛所。
    彼诸比丘遥见壮士，身大勇盛，见生怖畏，身毛皆竖，共相谓言：“彼为何等，形状可畏！”
    尔时世尊告诸比丘：“此是恶魔，欲作娆乱。”
    尔时世尊即说偈言：

“色声香味触，及第六诸法，
爱念适可意，世间唯有此。
此是最恶贪，能系著凡夫，
超越斯等者，是佛圣弟子，
度于魔境界，如日无云翳。”

    时魔波旬作是念：“沙门瞿昙已知我心。”内怀忧戚，即没不现。


杂阿含经卷第四十

（一一○四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“若能受持七种受者，以是因缘得生天帝释处。谓天帝释本为人时，供养父母，及家诸尊长；和颜软语，不恶口，不两舌，常真实言；于悭吝世间，虽在居家而不悭惜，行解脱施，勤施，常乐行施，施会供养，等施一切。”
    尔时世尊即说偈言：

“供养于父母，及家之尊长，
柔和恭逊辞，离粗言两舌，
调伏悭吝心，常修真实语。
彼三十三天，见行七法者，
咸各作是言，当来生此天。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一○五）

    如是我闻。一时佛住鞞舍离国猕猴池侧重阁讲堂。
    时有离车名摩诃利，来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，见天帝释不？”
    佛答言：“见。”
    离车复问：“世尊，见有鬼似帝释形以不？”
    佛告离车：“我知天帝释，亦知有鬼似天帝释，亦知彼帝释法。受持彼法缘故，得生帝释处。离车！帝释本为人时，供养父母，乃至行平等舍。”
    尔时世尊即说偈言：

“供养于父母，及家之尊长，
柔和恭逊辞，离粗言两舌，
调伏悭吝心，常修真实语。
彼三十三天，见行七法者，
咸各作是言，当来生此天。”

    佛说此经已，时摩诃利离车闻佛所说，欢喜随喜，作礼而去。

（一一○六）

    如是我闻。一时佛住鞞舍离国猕猴池侧重阁讲堂。
    时有异比丘来诣佛所，稽首佛足，退住一面，白佛言：“世尊，何因何缘，释提桓因名释提桓因？”
    佛告比丘：“释提桓因本为人时，行于顿施。沙门、婆罗门、贫穷、困苦、求生、行路乞，施以饮食、钱财、谷帛、花香、严具、床卧、灯明。以堪能故，名释提桓因。”
    比丘复白佛言：“世尊，何因何缘故，释提桓因复名富兰陀罗？”
    佛告比丘：“彼释提桓因本为人时，数数行施衣被、饮食，乃至灯明。以是因缘故，名富兰陀罗。”
    比丘复白佛言：“何因何缘故，复名摩伽婆？”
    佛告比丘：“彼释提桓因本为人时，名摩伽婆。故释提桓因即以本名，名摩伽婆。”
    比丘复白佛言：“何因何缘，复名娑婆婆？”
    佛告比丘：“彼释提桓因本为人时，数以婆诜和衣，布施供养。以是因缘故，释提桓因名娑婆婆。”
    比丘复白佛言：“世尊，何因何缘，释提桓因复名憍尸迦？”
    佛告比丘：“彼释提桓因本为人时，为憍尸族姓人。以是因缘故，彼释提桓因复名憍尸迦。”
    比丘问佛言：“世尊，何因何缘，彼释提桓因名舍脂钵低？”
    佛告比丘：“彼阿修罗女名曰舍脂，为天帝释第一天后，是故帝释名舍脂钵低。”
    比丘白佛言：“世尊，何因何缘，释提桓因复名千眼？”
    佛告比丘：“彼释提桓因本为人时，聪明智慧，于一坐间，思千种义，观察称量。以是因缘，彼天帝释复名千眼。”
    比丘白佛：“何因何缘，彼释提桓因复名因提利？”
    佛告比丘：“彼天帝释于诸三十三天，为王为主。以是因缘故，彼天帝释名因提利。”
    佛告比丘：“然彼释提桓因本为人时，受持七种受，以是因缘，得天帝释。何等为七？释提桓因本为人时，供养父母，乃至等行惠施，是为七种受。以是因缘，为天帝释。”
    尔时世尊即说偈言：如上广说。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一○七）

    如是我闻。一时佛住鞞舍离国猕猴池侧重阁讲堂。
    尔时世尊告诸比丘：“过去世时，有一夜叉鬼，丑陋恶色，在帝释空座上坐。三十三天见此鬼丑陋恶色，在帝释空座上坐，见已咸各瞋恚。诸天如是极瞋恚已，彼鬼如是如是随瞋恚渐渐端正。
    “时三十三天往诣天帝释所，白帝释言：‘憍尸迦！当知有一异鬼，丑陋恶色，在天王空座上坐。我等诸天见彼鬼丑陋恶色，坐天王座，极生瞋恚。随彼诸天瞋恚，彼鬼随渐端正。’
    “释提桓因告诸三十三天：‘彼是瞋恚对治鬼。’尔时天帝释自往彼鬼所，整衣服，偏袒右肩，合掌三称名字而言：‘仁者！我是释提桓因。’随释提桓因如是恭敬下意，彼鬼如是如是随渐丑陋，即复不现。
    “时释提桓因自坐已，而说偈言：

“人当莫瞋恚，见瞋莫瞋报，
于恶莫生恶，当破坏骄慢，
不瞋亦不害，名住贤圣众。
恶罪起瞋恚，坚住如石山，
盛瞋恚能持，如制逸马车，
我说善御士，非谓执绳者。”

    佛告诸比丘：“释提桓因于三十三天为自在王，叹说不瞋。汝等如是正信非家，出家学道，亦应赞叹不瞋，当如是学！”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一○八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊晨朝着衣持钵，入舍卫城乞食。乞食已，还精舍，举衣钵，洗足已，持尼师坛着右肩上，至安陀林，布尼师坛，坐一树下，入昼正受。
    尔时祇桓中有两比丘诤起，一人骂詈，一人默然。其骂詈者即便改悔，忏谢于彼，而彼比丘不受其忏。以不受忏故，时精舍中众多比丘共相劝谏，高声闹乱。
    尔时世尊以净天耳过于人耳，闻祇桓中高声闹乱。闻已从禅觉，还精舍，于大众前敷座而坐，告诸比丘：“我今晨朝乞食还，至安陀林，坐禅入昼正受，闻精舍中高声大声纷纭闹乱，竟为是谁？”
    比丘白佛：“此精舍中有二比丘诤起，一比丘骂，一者默然。时骂比丘寻向悔谢，而彼不受。缘不受故，多人劝谏，故致大声高声闹乱。”
    佛告比丘：“云何比丘愚痴之人，人向悔谢，不受其忏？若人忏而不受者，是愚痴人，长夜当得不饶益苦。诸比丘，过去世时，释提桓因有三十三天共诤，说偈教诫言：

“于他无害心，瞋亦不缠结，
怀恨不经久，于瞋以不住。
虽复瞋恚盛，不发于粗言，
不求彼阙节，扬人之虚短。
常当自防护，以义内省察，
不怒亦不害，常与贤圣俱。
若与恶人俱，刚强犹山石，
盛恚能自持，如制逸马车，
我说为善御，非谓执绳者。”

    佛告诸比丘：“释提桓因于三十三天为自在王，常行忍辱，亦复赞叹行忍者。汝等比丘，正信非家，出家学道，当行忍辱，赞叹忍者，应当学！”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一○九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过去世时，天、阿修罗对阵欲战。释提桓因语毗摩质多罗阿修罗王：‘莫得各各共相杀害，但当论义，理屈者伏。’毗摩质多罗阿修罗王言：‘设共论义，谁当证知理之通塞？’天帝释言：‘诸天众中，自有智慧明记识者。阿修罗众，亦复自有明记识者。’毗摩质多罗阿修罗言：‘可尔。’释提桓因言：‘汝等可先立论，然后我当随后立论，则不为难。’
    “时毗摩质多罗阿修罗王即说偈立论言：

‘我若行忍者，于事则有阙，
愚痴者当言，怖畏故行忍。’

    “释提桓因说偈答言：

‘正使愚痴者，言恐怖故忍，
及其不言者，于理何所伤？
但自观其义，亦观于他义，
彼我悉获安，斯忍为最上。’

    “毗摩质多罗阿修罗复说偈言：

‘若不制愚痴，愚痴则伤人，
犹如凶恶牛，舍走逐触人。
执杖而强制，怖畏则调伏，
是故坚持杖，折伏彼愚夫。’

    “帝释复说偈言：

‘我常观察彼，制彼愚夫者，
愚者瞋恚盛，智以静默伏，
不瞋亦不害，常与贤圣俱。
恶罪起瞋恚，坚住如石山，
盛瞋恚能持，如制逸马车，
我说善御士，非谓执绳者。’

    “尔时天众中有天智慧者，阿修罗众中有阿修罗智慧者，于此偈思惟称量观察，作是念：‘毗摩质多罗阿修罗所说偈，终竟长夜起于斗讼战诤，当知毗摩质多罗阿修罗王教人长夜斗讼战诤。释提桓因所说偈，长夜终竟息于斗讼战诤，当知天帝释长夜教人息于斗讼战诤，当知帝释善论得胜。’”
    佛告诸比丘：“释提桓因以善论义，伏阿修罗。诸比丘，释提桓因于三十三天为自在王，立于善论，赞叹善论。汝等比丘亦应如是，正信非家，出家学道，亦当善论，赞叹善论，应当学！”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一一○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过去世时，有天帝释、天阿修罗，对阵欲战。释提桓因语三十三天众言：‘今日诸天与阿修罗军战，诸天得胜，阿修罗不如者，当生擒毗摩质多罗阿修罗王，以五系缚，将还天宫。’毗摩质多罗阿修罗王告阿修罗众：‘今日诸天、阿修罗共战，若阿修罗胜，诸天不如者，当生擒释提桓因，以五系缚，将还阿修罗宫。’当其战时，诸天得胜，阿修罗不如。时彼诸天捉得毗摩质多罗阿修罗王，以五系缚，将还天宫，缚在帝释断法殿前门下。帝释从此门入出之时，毗摩质多罗阿修罗缚在门侧，瞋恚骂詈。
    “时帝释御者见阿修罗王身被五缚，在于门侧，帝释出入之时，辄瞋恚骂詈。见已即便说偈，白帝释言：

‘释今为畏彼，为力不足耶，
能忍阿修罗，面前而骂辱？’

    “释即答言：

‘不以畏故忍，亦非力不足，
何有黠慧人，而与愚夫对！’

    “御者复白言：

‘若但行忍者，于事则有阙，
愚痴者当言，畏怖故行忍，
是故当苦治，以智制愚痴。’

    “帝释答言：

‘我常观察彼，制彼愚夫者，
见愚者瞋盛，智以静默伏。
非力而为力，是彼愚痴力，
愚痴违远法，于道则无有。
若使有大力，能忍于劣者，
是则为上忍，无力何有忍！
于他极骂辱，大力者能忍，
是则为上忍，无力何所忍！
于己及他人，善护大恐怖，
知彼瞋恚盛，还自守静默，
于二义俱备，自利亦利他。
谓言愚夫者，以不见法故，
愚夫谓胜忍，重增其恶口，
未知忍彼骂，于彼常得胜。
于胜己行忍，是名恐怖忍；
于等者行忍，是名忍诤忍；
于劣者行忍，是则为上忍。’”

    佛告诸比丘：“释提桓因于三十三天为自在王，常行忍辱，赞叹于忍。汝等比丘，正信非家，出家学道，亦应如是行忍，赞叹于忍，应当学！”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一一一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过去世时，释提桓因欲入园观，时敕其御者，令严驾千马之车，诣于园观。御者奉敕，即严驾千马之车，往白帝释：‘唯俱尸迦！严驾已竟，唯王知时。’天帝释即下常胜殿，东向合掌礼佛。尔时御者见则心惊毛竖，马鞭落地。
    “时天帝释见御者心惊毛竖，马鞭落地，即说偈言：

‘汝见何忧怖，马鞭落于地？’

    “御者说偈白帝释言：

‘见王天帝释，为舍脂之夫，
所以生恐怖，马鞭落地者。
常见天帝释，一切诸大地，
人天大小王，及四护世主，
三十三天众，悉皆恭敬礼。
何处更有尊，尊于帝释者，
而今正东向，合掌修敬礼？’

    “尔时帝释说偈答言：

‘我实于一切，世间大小王，
及四护世主，三十三天众，
最为其尊主，故悉来恭敬。
而复有世间，随顺等正觉，
名号满大师，故我稽首礼。’

    “御者复白言：

‘是必世间胜，故使天王释，
恭敬而合掌，东向稽首礼。
我今亦当礼，天王所礼者。’

    “时天帝释舍脂之夫说如是偈，礼佛已，乘千马车，往诣园观。”
    佛告诸比丘：“彼天帝释于三十三天为自在王，尚恭敬佛，亦复赞叹恭敬于佛。汝等比丘，正信非家，出家学道，亦应如是恭敬于佛，亦当赞叹恭敬佛者，应当学！”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一一二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    广说如上，差别者：“尔时帝释下常胜殿，合掌东向敬礼尊法。”
    乃至佛说此经已，诸比丘闻佛所说，欢喜奉行。

    如是我闻。一时佛住舍卫国祇树给孤独园。
    如上广说，差别者：“尔时帝释说偈答御者言：

‘我实为大地，世间大小王，
及四护世主，三十三天众，
如是等一切，悉尊重恭敬。
然复有净戒，长夜入正受，
正信而出家，究竟诸梵行，
故我于彼所，尊重恭敬礼。
又调伏贪恚，超越愚痴境，
修学不放逸，亦恭敬礼彼。
贪欲瞋恚痴，悉已永不著，
漏尽阿罗汉，复应敬礼彼。
若复在居家，奉持于净戒，
如法修布萨，亦复应敬礼。’

    “御者白帝释言：

‘是必世间胜，故天王敬礼，
我亦当如是，随天王恭敬。’

    “诸比丘，彼天帝释舍脂之夫，敬礼法、僧，亦复赞叹礼法、僧者。汝等已能正信非家，出家学道，亦当如是敬礼法、僧，当复赞叹礼法、僧者。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一一三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过去世时，有天帝释欲入园观，王敕御者，令严驾千马之车。御者受教，即严驾已，还白帝释：‘乘已严驾，唯王知时！’尔时帝释从常胜殿来下，周向诸方，合掌恭敬。
    “时彼御者见天帝释从殿来下，住于中庭，周向诸方，合掌恭敬。见已惊怖，马鞭落地，而说偈言：

‘诸方唯有人，臭秽胞胎生，
神处秽死尸，饥渴常燋然。
何故憍尸迦，故重于非家？
为我说其义，饥渴愿欲闻。’

    “时天帝释说偈答言：

‘我正恭敬彼，能出非家者，
自在游诸方，不计其行止。
城邑国土色，不能累其心，
不畜资生具，一往无欲定。
往则无所求，唯无为为乐，
言则定善言，不言则寂定。
诸天阿修罗，各各共相违，
人间自共诤，相违亦如是。
唯有出家者，于诸诤无诤，
于一切众生，放舍于刀杖，
于财离财色，不醉亦不荒，
远离一切恶，是故敬礼彼。’

    “是时御者复说偈言：

‘天王之所敬，是必世间胜，
故我从今日，当礼出家人。’

    “如是说已，天帝释敬礼诸方一切僧毕，升于马车，游观园林。”
    佛告比丘：“彼天帝释于三十三天为自在王，而常恭敬众僧，亦常赞叹敬僧功德。汝等比丘，正信非家，出家学道，亦当如是恭敬众僧，亦当赞叹敬僧功德。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一一四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过去世时，阿修罗王兴四种兵，象兵、马兵、车兵、步兵，与三十三天欲共斗战。
    “时天帝释闻阿修罗王兴四种兵，象兵、马兵、车兵、步兵，来欲共战，闻已即告宿毗梨天子言：‘阿公知不？阿修罗兴四种兵，象兵、马兵、车兵、步兵，欲与三十三天共战。阿公可敕三十三天兴四种兵，象兵、马兵、车兵、步兵，与彼阿修罗共战。’
    “尔时宿毗梨天子受帝释教，还自天宫，慢缓宽纵，不勤方便。阿修罗众已出在道路。帝释闻已，复告宿毗梨天子：‘阿公！阿修罗军已在道路。阿公可速告令，起四种兵，与阿修罗战。’
    “宿毗梨天子受帝释教已，即复还宫，懈怠宽纵。时阿修罗王军已垂至。释提桓因闻阿修罗军已在近路，复告宿毗梨天子：‘阿公知不？阿修罗军已在近路。阿公！速告诸天，起四种兵。’
    “时宿毗梨天子即说偈言：

‘若有不起处，无为安隐乐，
得如是处者，无作亦无忧，
当与我是处，令我得安隐。’

    “尔时帝释说偈答言：

‘若有不起处，无为安隐乐，
若得是处者，无作亦无忧，
汝得是处者，亦应将我去。’

    “宿毗梨天子复说偈言：

‘若处无方便，不起安隐乐，
若得彼处者，无作亦无忧，
当与我是处，令我得安隐。’

    “时天帝释复说偈答言：

‘若处无方便，不起安隐乐，
若人得是处，无作亦无忧，
汝得是处者，亦应将我去。’

    “宿毗梨天子复说偈言：

‘若处不放逸，不起安隐乐，
若人得是处，无作亦无忧，
当与我是处，令得安隐乐。’

    “时天帝释复说偈言：

‘若处不放逸，不起安隐乐，
若人得是处，无作亦无忧，
汝得是处者，亦应将我去。’

    “宿毗梨复说偈言：

‘懒惰无所起，不知作已作，
行欲悉皆会，当与我是处。’

    “时天帝释复说偈言：

‘懒惰无所起，得究竟安乐，
汝得彼处者，亦应将我去。’

    “宿毗梨天子复说偈言：

‘无事而得乐，无作亦无忧，
若与我是处，令我得安乐。’

    “天帝释复说偈言：

‘若见若复闻，众生无所作，
汝得是处者，亦应将我去。
汝若畏所作，不念于有为，
但当速净除，涅槃之径路。’

    “时宿毗梨天子严四兵，象兵、马兵、车兵、步兵，与阿修罗战，摧阿修罗众。诸天得胜，还归天宫。”
    佛告诸比丘：“释提桓因兴四种兵，与阿修罗战，精勤得胜。诸比丘，释提桓因于三十三天为自在王，常以精勤方便，亦常赞叹精勤之德。汝等比丘，正信非家，出家学道，当勤精进，赞叹精勤。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一一五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过去世时，有一聚落，有诸仙人于聚落边空闲处住止。时有诸天、阿修罗，去聚落不远，对阵战斗。
    “尔时毗摩质多罗阿修罗王，除去五饰，脱去天冠，却伞盖，除剑刀，屏宝拂，脱革屣，至彼仙人住处。入于门内，周向看视，不顾眄诸仙人，亦不问讯，看已还出。时有一仙人，遥见毗摩质多罗阿修罗王除去五饰入园，看已还出，见已语诸仙人言：‘此何等人？有不调伏色，不似人形，非威仪法，似田舍儿，非长者子。除去五饰，入于园门，高视观看，亦不顾眄问讯诸仙人。’有一仙人答言：‘此是毗摩质多罗阿修罗王，除去五饰，观看而去。’彼仙人言：‘此非贤士，不好不善，非贤非法。除去五饰，来入园门，看已还去，亦不顾眄问讯诸仙人。以是故，当知天众增长，阿修罗损减。’
    “时释提桓因，除去五饰，入仙人住处，与诸仙人面相问讯慰劳，然后还出。复有仙人，见天帝释除去五饰，入于园门，周遍问讯，见已问诸仙人：‘此是何人？入于园林，有调伏色，有可适人色，有威仪色，非田舍儿，似族姓子。除去五饰，来入园门，周遍问讯，然后还出。’有仙人答言：‘此是天帝释，除去五饰，来入园门，周遍问讯，然后还去。’彼仙人言：‘此是贤士，善、好、真实，威仪法，除去五饰，来入园门，周遍问讯，然后还去。以是当知天众增长，阿修罗众损减。’
    “时毗摩质多罗阿修罗王，闻仙人称叹诸天，闻已瞋恚炽盛。时彼空处仙人，闻阿修罗王瞋恚炽盛，往诣毗摩质多罗阿修罗王所，而说偈言：

‘仙人故来此，求乞施无畏，
汝能施无畏，赐牟尼恩教。’

    “毗摩质多罗以偈答言：

‘于汝仙人所，无有施无畏，
违背阿修罗，习近帝释故，
于此诸无畏，当遗以恐怖。’

    “仙人复说偈言：

‘随行植种子，随类果报生，
来乞于无畏，遗之以恐怖，
当获无尽畏，施畏种子故。’

    “时诸仙人于毗摩质多罗阿修罗王面前说咒已，凌虚而逝。即于是夜，毗摩质多罗阿修罗王心惊三起，眠中闻恶声言：‘释提桓因兴四种兵，与阿修罗战。’惊觉恐怖，虑战必败，退走而还阿修罗宫。
    “时天帝释，敌退得胜已，诣彼空闲仙人住处，礼诸仙人足已，退于西面诸仙人前，东向而坐。时东风起，有异仙人即说偈言：

‘今此诸牟尼，出家来日久，
腋下流汗臭，莫顺坐风下，
千眼可移坐，此臭难可堪。’

    “时天帝释说偈答言：

‘种种众香花，结以为花鬘，
今之所闻香，其香复过是，
宁久闻斯香，未曾生厌患。’”

    佛告诸比丘：“彼天帝释于三十三天为自在王，恭敬出家人，亦常赞叹出家人，亦常赞叹恭敬之德。汝等比丘，正信非家，出家学道，常应恭敬诸梵行者，亦当赞叹恭敬之德。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一一六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时天帝释晨朝来诣佛所，稽首佛足。以帝释神力，身诸光明，遍照祇树精舍。
    时释提桓因说偈问佛言：

“为杀于何等，而得安隐眠？
为杀于何等，而得无忧畏？
为杀何等法，瞿昙所赞叹？”

    尔时世尊说偈答言：

“害凶恶瞋恚，而得安隐眠。
害凶恶瞋恚，心得无忧畏。
瞋恚为毒根，灭彼苦种子，
灭彼苦种子，而得无忧畏。
彼苦种灭故，贤圣所称叹。”

    尔时释提桓因闻佛所说，欢喜随喜，作礼而去。

（一一一七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“于月八日，四大天王敕遣大臣，案行世间：为何等人供养父母、沙门、婆罗门、宗亲、尊重，作诸福德；见今世恶，畏后世罪，行施作福，受持斋戒，于月八日、十四日、十五日，及神变月，受戒布萨？至十四日，遣太子下，观察世间，为何等人供养父母，乃至受戒布萨。至十五日，四大天王自下世间，观察众生，为何等人供养父母，乃至受戒布萨。
    “诸比丘，尔时世间无有多人供养父母，乃至受戒布萨者，时四天王即往诣三十三天集法讲堂，白天帝释：‘天王当知，今诸世间，无有多人供养父母，乃至受戒布萨。’时三十三天众闻之不喜，转相告语：‘今世间人不贤不善，不好不类，无真实行，不供养父母，乃至不受戒布萨。缘斯罪故，诸天众减，阿修罗众当渐增广。’
    “诸比丘，尔时世间若复多人供养父母，乃至受戒布萨者，四天王至三十三天集法讲堂，白天帝释：‘天王当知，今诸世间，多有人民供养父母，乃至受戒布萨。’时三十三天心皆欢喜，转相告语：‘今诸世间贤善、真实、如法，多有人民供养父母，乃至受戒布萨。缘斯福德，阿修罗众减，诸天众增广。’时天帝释知诸天众皆欢喜已，即说偈言：

‘若人月八日，十四十五日，
及神变之月，受持八支斋，
如我所修行，彼亦如是修。’”

    尔时世尊告诸比丘：“彼天帝释所说偈言：

‘若人月八日，十四十五日，
及神变之月，受持八支斋，
如我所修行，彼亦如是修。’

    “此非善说。所以者何？彼天帝释自有贪、恚、痴患，不脱生老病死、忧悲恼苦故。
    “若阿罗汉比丘，诸漏已尽，所作已作，离诸重担，断诸有结，心善解脱，说此偈言：

‘若人月八日，十四十五日，
及神变之月，受持八支斋，
如我所修行，彼亦如是修。’

    “如是说者，则为善说。所以者何？阿罗汉比丘离贪、恚、痴，已脱生老病死、忧悲恼苦，是故此偈则为善说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一一八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过去世时，毗摩质多罗阿修罗王疾病困笃，往诣释提桓因所，语释提桓因言：‘憍尸迦，当知我今疾病困笃，为我疗治，令得安隐。’释提桓因语毗摩质多罗阿修罗言：‘汝当授我幻法，我当疗治汝病，令得安隐。’毗摩质多罗阿修罗语帝释言：‘我当还问诸阿修罗众，听我者，当授帝释阿修罗幻法。’
    “尔时毗摩质多罗阿修罗，即往至诸阿修罗众中，语诸阿修罗言：‘诸人当知，我今疾病困笃，往诣释提桓因所，求彼治病。彼语我言：汝能授我阿修罗幻法者，当治汝病，令得安隐。我今当往为彼说阿修罗幻法。’
    “时有一诈伪阿修罗，语毗摩质多罗阿修罗：‘其彼天帝释，质直好信，不虚伪。但语彼言：天王，此阿修罗幻法，若学者令人堕地狱，受罪无量百千岁。彼天帝释必当息意，不复求学，当言：汝去，令汝病瘥，可得安隐。’
    “时毗摩质多罗阿修罗复往帝释所，说偈白言：

‘千眼尊天王，阿修罗幻术，
皆是虚诳法，令人堕地狱，
无量百千岁，受苦无休息。’

    “时天帝释语毗摩质多罗阿修罗言：‘止！止！如是幻术，非我所须。汝且还去，令汝身病寂灭休息，得力安隐。’”
    佛告诸比丘：“释提桓因于三十三天为自在王，长夜真实，不幻不伪，贤善质直。汝等比丘，正信非家，出家学道，亦应如是，不幻不伪，贤善质直，当如是学！”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一一九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“时有天帝释，及鞞卢阇那子婆稚阿修罗王，有绝妙之容，于晨朝时，俱诣佛所，稽首佛足，退坐一面。时天帝释，及鞞卢阇那子婆稚阿修罗王，身诸光明，普照祇树给孤独园。
    “尔时鞞卢阇那阿修罗王说偈白佛：

‘人当勤方便，必令利满足，
是利满足已，何须复方便？’

    “时天帝释复说偈言：

‘若人勤方便，必令利满足，
是利满足已，修忍无过上。’

    “说是偈已，俱白佛言：‘世尊，何者善说？’
    “世尊告言：‘汝等所说，二说俱善。然今汝等复听我说：

‘一切众生类，悉皆求己利，
彼彼诸众生，各自求所应。
世间诸和合，及与第一义，
当知世和合，则为非常法。
若人勤方便，必令利满足，
是利满足已，修忍无过上。’

    “尔时天帝释，及毗卢阇那子婆稚阿修罗王，闻佛所说，欢喜随喜，作礼而去。”
    尔时世尊告诸比丘：“释提桓因于三十三天为自在王，修行于忍，赞叹于忍。汝等比丘，正信非家，出家学道，亦应如是，修行于忍，赞叹于忍。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一二○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过去世时，有天帝释白佛言：‘世尊，我今受如是戒：乃至佛法住世，尽其形寿，有恼我者，要不反报加恼于彼。’
    “时毗摩质多罗阿修罗王，闻天帝释受如是戒，乃至佛法住世，尽其形寿，有恼我者，我不反报加恼于彼。闻已执持利剑，逆道而来。
    “时天帝释遥见毗摩质多罗阿修罗王执持利剑，逆道而来，即遥告言：‘阿修罗住，缚汝勿动！’毗摩质多罗阿修罗王即不得动，语帝释言：‘汝今岂不受如是戒，若佛法住世，尽其形寿，有恼我者，必不还报耶？’天帝释答言：‘我实受如是戒，但汝自住受缚。’阿修罗言：‘今且放我！’帝释答言：‘汝若约誓不作乱者，然后放汝。’阿修罗言：‘放我，当如法作。’帝释答言：‘先如法作，然后放汝。’
    “时毗摩质多罗阿修罗王即说偈言：

‘贪欲之所趣，及瞋恚所趣，
妄语之所趣，谤毁贤圣趣，
我若娆乱者，趣同彼趣趣。’

    “释提桓因复告言：‘放汝令去，随汝所安！’
    “尔时天帝释，令阿修罗王作约誓已，往诣佛所，稽首佛足，退坐一面，白佛言：‘世尊，我于佛前受如是戒，乃至佛法住世，尽其形寿，有恼我者，我不反报。毗摩质多罗阿修罗王闻我受戒，手执利剑，随路而来。我遥见已，语言：阿修罗住，缚汝勿动！彼阿修罗言：汝不受戒耶？我即答言：我实受戒，且汝今住，缚汝勿动。彼即求脱，我告彼言：若作约誓不作乱者，当令汝脱。阿修罗言：且当放我，当说约誓。我即告言：先说约誓，然后放汝。彼即说偈，作约誓言：

贪欲之所趣，及瞋恚所趣，
妄语之所趣，谤毁贤圣趣，
我若作娆乱，趣同彼趣趣。

    “‘如是世尊，我要彼阿修罗王，令说约誓，为是法不？彼阿修罗复为娆乱不？’
    “佛告天帝释：‘善哉善哉！汝要彼约誓，如法不违。彼亦不复敢作娆乱。’
    “尔时天帝释闻佛所说，欢喜随喜，作礼而去。”
    尔时世尊告诸比丘：“彼天帝释于三十三天为自在王，不为娆乱，亦常赞叹不娆乱法。汝等比丘，正信非家，出家学道，亦应如是，行不娆乱，亦当赞叹不扰乱法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。


杂阿含经卷第四十一

（一一二一）

    如是我闻。一时佛住迦毗罗卫国尼拘律园。
    时有众多释氏来诣佛所，稽首礼足，退坐一面。
    尔时世尊告诸释氏：“汝等诸瞿昙，于法斋日及神足月，受持斋戒，修功德不？”
    诸释氏白佛言：“世尊，我等于诸斋日，有时得受斋戒，有时不得。于神足月，有时斋戒，修诸功德，有时不得。”
    佛告诸释氏：“瞿昙！汝等不获善利，汝等是骄慢者、烦恼人、忧悲人、恼苦人。何故于诸斋日，或得斋戒，或不得？于神足月，或得斋戒，作诸功德，或不得？诸瞿昙！譬人求利，日日增长，一日一钱，二日两钱，三日四钱，四日八钱，五日十六钱，六日三十二钱。如是士夫日常增长，八日、九日，乃至一月，钱财转增广耶？”
    长者白佛：“如是，世尊。”
    佛告释氏：“云何瞿昙，如是士夫钱财转增，当得自然钱财增广。复欲令我于十年中一向喜乐，心乐多住禅定，宁得以不？”
    释氏答言：“不也，世尊。”
    佛告释氏：“若得九年、八年、七年、六年、五年、四年、三年、二年、一年喜乐，心乐多住禅定以不？”
    释氏答言：“不也，世尊。”
    佛告释氏：“且置年岁，宁得十月、九月、八月，乃至一月喜乐，心乐多住禅定以不？复置一月，宁得十日、九日、八日，乃至一日一夜喜乐，心乐禅定多住以不？”
    释氏答言：“不也，世尊。”
    佛告释氏：“我今语汝，我声闻中有直心者，不谄不幻，我于彼人十年教化，以是因缘，彼人则能百千万岁一向喜乐，心乐多住禅定，斯有是处。复置十年，若九年、八年乃至一年，十月、九月乃至一月，十日、九日乃至一日一夜，我教化，至其明旦能令胜进；晨朝教化，乃至日暮能令胜进。以是因缘，得百千万岁一向喜乐，心乐多住禅定，成就二果，或斯陀含果、阿那含果，以彼士夫先得须陀洹故。”
    释氏白佛：“善哉世尊！我从今日，于诸斋日当修斋戒，乃至八支。于神足月受持斋戒，随力惠施，修诸功德。”
    佛告释氏：“善哉瞿昙，为真实要！”
    佛说此经已，时诸释种闻佛所说，欢喜随喜，作礼而去。

（一一二二）

    如是我闻。一时佛住迦毗罗卫国尼拘律园中。
    时有众多释氏，集论议堂，作如是论议。时有释氏语释氏难提：“我有时得诣如来恭敬供养，有时不得。有时得亲近供养知识比丘，有时不得。又复不知有诸智慧优婆塞，有余智慧优婆塞、智慧优婆夷疾病困苦，复云何教化、教诫说法？今当共往诣世尊所，问如此义，如世尊教，当受奉行。”
    尔时难提与诸释氏俱诣佛所，稽首礼足，退住一面，白佛言：“世尊，我等诸释氏，集论议堂，作如是论议。有诸释氏语我言：‘难提，我等或时见如来恭敬供养，或时不见。或时往见诸知识比丘亲近供养，或时不得。如是广说，乃至如佛所教诫，当受奉行。’我等今日请问世尊，若智慧优婆塞，有余智慧优婆塞、优婆夷疾病困苦，云何教化、教诫说法？”
    佛告难提：“若有智慧优婆塞，当诣余智慧优婆塞、优婆夷疾病困苦者所，以三种苏息处而教授之，言：‘仁者，汝当成就于佛不坏净，于法、僧不坏净。’以是三种苏息处而教授已，当复问言：‘汝顾恋父母不？’彼若有顾恋父母者，当教令舍，当语彼言：‘汝顾恋父母得活者，可顾恋耳。既不由顾恋而得活，用顾恋为？’彼若言不顾恋父母者，当叹善随喜，当复问言：‘汝于妻子、奴仆、钱财诸物有顾念不？’若言顾念，当教令舍，如舍顾恋父母法。若言不顾念，叹善随喜，当复问言：‘汝于人间五欲顾念以不？’若言顾念，当为说言：‘人间五欲恶露不净，败坏臭处，不如天上胜妙五欲。’教令舍离人间五欲，教令志愿天上五欲。若复彼言：‘心已远离人间五欲，先已顾念天胜妙欲。’叹善随喜，复语彼言：‘天上妙欲，无常、苦、空、变坏之法。诸天上有身，胜天五欲。’若言：‘已舍顾念天欲，顾念有身胜欲。’叹善随喜，当复教言：‘有身之欲，亦复无常、变坏之法。有行灭涅槃、出离之乐，汝当舍离有身顾念，乐于涅槃寂灭之乐，为上为胜。’彼圣弟子已能舍离有身顾念，乐涅槃者，叹善随喜。如是难提，彼圣弟子先后次第教诫教授，令得不起涅槃，犹如比丘百岁寿命，解脱涅槃。”
    佛说此经已，释氏难提等闻佛所说，欢喜随喜，作礼而去。

（一一二三）

    如是我闻。一时佛住迦毗罗卫国尼拘律园中。
    时有释氏名曰菩提，来诣佛所，稽首佛足，退坐一面，白佛言：“善哉世尊！我等快得善利，得为世尊亲属。”
    佛告菩提：“莫作是语：‘我得善利，得与世尊亲属故然。’菩提，所谓善利者，于佛不坏净，于法、僧不坏净，圣戒成就。是故菩提，当作是学：我当于佛不坏净，于法、僧不坏净，圣戒成就。”
    佛说此经已，释氏菩提闻佛所说，欢喜随喜，作礼而去。

（一一二四）

    如是我闻。一时佛住迦毗罗卫国尼拘律园中。
    尔时世尊告诸比丘：“若圣弟子得于佛不坏净成就，时若彼诸天先得于佛不坏净戒成就因缘往生者，皆大欢喜，叹言：‘我以得于佛不坏净成就因缘故，来生于此善趣天上。彼圣弟子今得于佛不坏净成就，以是因缘，亦当复来生此善趣天中。’”
    于法、僧不坏净，圣戒成就，亦如是说。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一二五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四种须陀洹道分：亲近善男子、听正法、内正思惟、法次法向。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一二六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四须陀洹分。何等为四？谓于佛不坏净，于法、僧不坏净，圣戒成就，是名须陀洹分。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一二七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若有成就四法者，当知是须陀洹。何等为四？谓于佛不坏净，于法、僧不坏净，圣戒成就。是名四法成就者，当知是须陀洹。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如不分别说，如是分别比丘、比丘尼、式叉摩尼、沙弥、沙弥尼、优婆塞、优婆夷，成就四法者，当知是须陀洹，一一经如上说。

（一一二八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四沙门果。何等为四？谓须陀洹果、斯陀含果、阿那含果、阿罗汉果。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一二九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有四沙门果。何等为四？谓须陀洹果、斯陀含果、阿那含果、阿罗汉果。何等为须陀洹果？谓三结断，是名须陀洹果。何等为斯陀含果？谓三结断，贪、恚、痴薄，是名斯陀含果。何等为阿那含果？谓五下分结断，是名阿那含果。何等为阿罗汉果？若彼贪欲永尽，瞋恚永尽，愚痴永尽，一切烦恼永尽，是名阿罗汉果。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一三○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若于彼处有比丘经行，于彼处四沙门果中得一一果者，彼比丘尽其形寿，常念彼处。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。
    如经行处，如是住处、坐处、卧处亦如是说。
    如是比丘，如是比丘尼、式叉摩尼、沙弥、沙弥尼、优婆塞、优婆夷，一一四经如上说。

（一一三一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“如四食，于四大众生，安立饶益摄受。何等为四？谓抟食、触食、意思食、识食。如是四种福德润泽、善法润泽安乐食。何等为四？谓于佛不坏净成就，福德润泽、善法润泽安乐食；法、僧不坏净，圣戒成就，福德润泽、善法润泽安乐食。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一三二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“于佛不坏净成就，福德润泽、善法润泽安乐食；于法不坏净，于诸闻法可意爱念，圣戒成就，福德润泽、善法润泽安乐食。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一三三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“于佛不坏净成就者，福德润泽、善法润泽安乐食；若法；若悭垢缠众生所，心离悭垢众，多住行解脱施，常施，乐于舍，等心行施，圣戒成就，福德润泽、善法润泽安乐食。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一三四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：如上说，差别者：“如是四种福德润泽、善法润泽安乐食，彼圣弟子功德果报，不可称量尔所福、尔所果报。然彼多福，堕大功德积聚数。”如前《五河譬经》说，乃至说偈。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一三五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时有四十天子，极妙之色，夜过晨朝，来诣佛所，稽首礼足，退坐一面。
    尔时世尊告诸天子：“善哉善哉！诸天子，汝等成就于佛不坏净，于法、僧不坏净，圣戒成就。”
    时天子从座起，整衣服，稽首佛足，合掌白佛言：“世尊，我成就于佛不坏净，缘此功德，身坏命终，今生天上。”
    一天子白佛言：“世尊，我于法不坏净成就，缘此功德，身坏命终，今生天上。”
    一天子白佛言：“世尊，我于僧不坏净成就，缘此功德，身坏命终，今生天上。”
    一天子白佛言：“世尊，我于圣戒成就，缘此功德，身坏命终，今生天上。”
    时四十天子各于佛前自记说须陀洹果已，即没不现。
    如四十天子，如是四百天子、八百天子、十千天子、二十千天子、三十千天子、四十千天子、五十千天子、六十千天子、七十千天子、八十千天子，各于佛前自记说须陀洹果已，即没不现。

（一一三六）

    如是我闻。一时佛住舍卫国迦兰陀竹园。
    尔时世尊告诸比丘：“当如月譬住，如新学惭愧软下，摄心敛形而入他家。如明目士夫，临深登峰，摄心敛形，难速前进。如是比丘如月譬住，亦如新学惭愧软下，御心敛形而入他家。迦叶比丘如月譬住，亦如新学惭愧软下诸高慢，御心控形而入他家。如明目士夫临深登峰，御心控形，正观而进。”
    佛告比丘：“于意云何，比丘为何等像类，应入他家？”
    诸比丘白佛言：“世尊是法根、法眼、法依，唯愿广说。诸比丘闻已，当受奉行。”
    佛告诸比丘：“谛听善思，当为汝说。若有比丘，于他家心不缚著贪乐，于他得利、他作功德，欣若在己，不生嫉想，亦不自举，亦不下人，如是像类比丘，应入他家。”
    尔时世尊以手扪摸虚空，告诸比丘：“我今此手，宁著空、缚空、染空不？”
    比丘白佛：“不也，世尊。”
    佛告比丘：“比丘之法常如是，不著、不缚、不染心而入他家。唯迦叶比丘，以不著、不缚、不染之心而入他家，于他得利及作功德，欣若在己，不生嫉想、不自举、不下人，其唯迦叶比丘应入他家。”
    尔时世尊复以手扪摸虚空，告诸比丘：“于意云何？我今此手，宁著空、缚空、染空以不？”
    诸比丘白佛言：“不也，世尊。”
    佛告比丘：“其唯迦叶比丘，心常如是，以不著、不缚、不染之心入于他家。”
    尔时世尊告诸比丘：“何等像类比丘，应清净说法？”
    诸比丘白佛：“世尊是法根、法眼、法依，唯愿广说。诸比丘闻已，当受奉行。”
    佛告比丘：“谛听善思，当为汝说。若有比丘作如是心，为人说法：‘何等人于我起净信心，为本已当得供养衣被、饮食、卧具、汤药？’如是说者，名不清净说法。若复比丘为人说法，作如是念：‘世尊显现正法律，离诸炽然，不待时节，即此现身，缘自觉知，正向涅槃。而诸众生沉溺老、病、死、忧悲恼苦，如此众生闻正法者，以义饶益，长夜安乐。’以是正法因缘，以慈心、悲心、哀愍心、欲令正法久住心而为人说，是名清净说法。唯迦叶比丘有如是清净心为人说法，以如来正法律，乃至令法久住心而为人说法。是故诸比丘，当如是学，如是说法，于如来正法律，乃至令法久住心为人说法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一三七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若有比丘欲入他家，作如是念：‘彼当施我莫令不施，顿施非渐施，多施非少施，胜施非陋施，速施非缓施。’以如是心而至他家，若他不施，乃至缓施，是比丘心则屈辱，以是因缘其心退没，自生障碍。若复比丘欲入他家，作如是念：‘出家之人，卒至他家，何由得施非不施，顿施非渐施，多施非少施，胜施非陋施，速施非缓施？’作如是念而至他家，若彼不施，乃至缓施，是比丘心不屈辱，亦不退没，不生障碍。唯迦叶比丘作如是念而入他家。是故诸比丘，当如是学，作如是念而入他家：出家之人，卒至他家，何由得施非不施，乃至速施非缓施。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一三八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者摩诃迦叶住舍卫国东园鹿子母讲堂，时尊者摩诃迦叶，晡时从禅觉，往诣佛所，稽首礼足，退坐一面。
    尔时世尊告尊者摩诃迦叶：“汝当为诸比丘说法、教诫教授。所以者何？我常为诸比丘说法、教诫教授，汝亦应尔。”
    尊者摩诃迦叶白佛言：“世尊，今诸比丘难可教授，或有比丘不忍闻说。”
    佛告摩诃迦叶：“汝何因缘作如是说？”
    摩诃迦叶白佛言：“世尊，我见有两比丘，一名槃稠，是阿难弟子；二名阿浮毗，是摩诃目揵连弟子。彼二人共诤多闻，各言：‘汝来当共论议，谁所知多？谁所知胜？’”
    时尊者阿难住于佛后，以扇扇佛，语尊者摩诃迦叶言：“且止，尊者摩诃迦叶！且忍，尊者迦叶！此年少比丘少智、恶智。”
    尊者摩诃迦叶语尊者阿难言：“汝且默然，莫令我于僧中问汝事。”
    时尊者阿难即默然住。
    尔时世尊告一比丘：“汝往至彼槃稠比丘、阿浮毗比丘所，作是言：大师语汝！”
    时彼比丘即受教，至槃稠比丘、阿浮毗比丘所，作是言：“大师语汝！”
    时槃稠比丘、阿浮毗比丘答言：“奉教。”即俱往佛所，稽首礼足，退住一面。
    尔时世尊告二比丘：“汝等二人，实共诤论，各言：汝来试共论议，谁多谁胜耶？”
    二比丘白佛言：“实尔，世尊。”
    佛告二比丘：“汝等持我所说修多罗、祇夜、受记、伽陀、优陀那、尼陀那、阿波陀那、伊帝目多伽、阇多伽、毗富罗、阿浮多达摩、优波提舍等法，而共诤论，各言：汝来试共论议，谁多谁胜耶？”
    二比丘白佛：“不也，世尊。”
    佛告二比丘：“汝等不以我所说修多罗，乃至优波提舍，而自调伏，自止息，自求涅槃耶？”
    二比丘白佛：“如是，世尊。”
    佛告二比丘：“汝知我所说修多罗，乃至优波提舍。汝愚痴人，应共诤论谁多谁胜耶？”
    时二比丘前礼佛足，重白佛言：“悔过，世尊！悔过，善逝！我愚我痴，不善不辨，而共诤论。”
    佛告二比丘：“汝实知罪悔过，愚痴不善不辨而共诤论。今已自知罪，自见罪，知见悔过，于未来世律仪戒生。我今受汝，怜愍故，令汝善法增长，终不退减。所以者何？若有自知罪，自见罪，知见悔过，于未来世律仪戒生，终不退减。”
    时二比丘闻佛所说，欢喜随喜，作礼而去。

（一一三九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者摩诃迦叶住舍卫国东园鹿子母讲堂，晡时从禅觉，诣世尊所，稽首礼足，退坐一面。
    佛告迦叶：“汝当教授教诫诸比丘，为诸比丘说法、教诫教授。所以者何？我常为诸比丘说法、教诫教授，汝亦应尔。”
    尊者摩诃迦叶白佛言：“世尊，今诸比丘难可为说法，若说法者，当有比丘不忍、不喜。”
    佛告迦叶：“汝见何等因缘而作是说？”
    摩诃迦叶白佛言：“世尊，若有比丘于诸善法无信敬心，若闻说法，彼则退没。若恶智人，于诸善法无精进、惭愧、智慧，闻说法者，彼则退没。若人贪欲、瞋恚、睡眠、掉悔、疑惑、身行骜暴、忿恨、失念、不定、无智，闻说法者，彼则退没。世尊，如是比丘、诸恶人者，尚不能令心住善法，况复增进？当知是辈，随其日夜，善法退减，不能增长。世尊，若有士夫于诸善法信心清净，是则不退；于诸善法精进、惭愧、智慧，是则不退；不贪、不恚、睡眠、掉悔、疑惑，是则不退；身不弊暴，心不染污，不忿、不恨、定心、正念、智慧，是则不退。如是人者，于诸善法日夜增长，况复心住。此人日夜常求胜进，终不退减。”
    佛告迦叶：“如是如是，于诸善法无信心者，是则退减。”亦如迦叶次第广说。
    时尊者摩诃迦叶闻佛所说，欢喜随喜，从座起，作礼而去。

（一一四○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者摩诃迦叶住舍卫国东园鹿子母讲堂，晡时从禅觉，来诣佛所，稽首佛足，退坐一面。
    尔时世尊告摩诃迦叶：“汝当为诸比丘说法、教诫教授。所以者何？我常为诸比丘说法、教诫教授，汝亦应尔。”
    尊者摩诃迦叶白佛言：“世尊，今诸比丘难可为说法、教诫教授。有诸比丘闻所说法，不忍、不喜。”
    佛告摩诃迦叶：“汝何因缘作如是说？”
    摩诃迦叶白佛言：“世尊是法根、法眼、法依，唯愿世尊为诸比丘说法。诸比丘闻已，当受奉行。”
    佛告迦叶：“谛听善思，当为汝说。”
    佛告迦叶：“昔日阿练若比丘，于阿练若比丘所，叹说阿练若法；于乞食比丘所，叹说乞食功德；于粪扫衣比丘所，叹说粪扫衣功德；若少欲知足、修行远离、精勤方便、正念正定、智慧漏尽身作证比丘所，随其所行，赞叹称说。迦叶！若于阿练若所，叹说阿练若法，乃至漏尽比丘所，叹说漏尽身作证。若见其人，悉共语言，随宜慰劳善来者：‘汝名何等？为谁弟子？’让座令坐，叹其贤善，如其法像类，有沙门义，有沙门欲。如是赞叹时，若彼同住同游者，则便决定随顺彼行，不久亦当同其所见，同其所欲。”
    佛告迦叶：“若是年少比丘，见彼阿练若比丘来赞叹阿练若法，乃至漏尽身作证。彼年少比丘应起出迎，恭敬礼拜问讯，乃至彼同住者，不久当得自义饶益。如是恭敬者，长夜当得安乐饶益。”
    佛告迦叶：“今日比丘，见彼来者知见大德，能感财利、衣被、饮食、床卧、汤药者，与共言语，恭敬问讯，叹言：‘善来！何某名字？为谁弟子？’叹其福德，能感大利、衣被、饮食、卧具、汤药；若与尊者相习近者，亦当丰足衣被、饮食、卧具、汤药。若复年少比丘，见彼来者大智大德，能感财利、衣被、饮食、卧具、汤药者，疾起出迎，恭敬问讯，叹言：‘善来！大智大德，能感大利、衣被、饮食、卧具、汤药。’迦叶，如是年少比丘，长夜当得非义不饶益苦。如是迦叶，斯等比丘，为沙门患，为梵行溺，为大映障，恶不善法，烦恼之患，重受诸有，炽然生死，未来苦报，生老病死，忧悲苦恼。
    “是故迦叶，当如是学：为阿练若，于阿练若所，称誉赞叹；粪扫衣、乞食、少欲知足、修行远离、精勤方便、正念正定、正智漏尽身作证者，称誉赞叹，当如是学！”
    佛说此经已，尊者摩诃迦叶闻佛所说，欢喜随喜，作礼而去。

（一一四一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者摩诃迦叶住舍卫国东园鹿子母讲堂，晡时从禅觉，诣世尊所，稽首礼足，退坐一面。
    尔时世尊告摩诃迦叶言：“汝今已老，年耆根熟。粪扫衣重，我衣轻好，汝今可住僧中，着居士坏色轻衣。”
    叶迦白佛言：“世尊，我已长夜习阿练若，赞叹阿练若、粪扫衣、乞食。”
    佛告迦叶：“汝观几种义，习阿练若，赞叹阿练若；粪扫衣、乞食，赞叹粪扫衣、乞食法？”
    迦叶白佛言：“世尊，我观二种义：现法得安乐住义，复为未来众生而作大明。未来世众生当如是念：‘过去上座六神通，出家日久，梵行纯熟，为世尊所叹，智慧梵行者之所奉事。彼于长夜习阿练若，赞叹阿练若；粪扫衣、乞食，赞叹粪扫衣、乞食法。’诸有闻者，净心随喜，长夜皆得安乐饶益。”
    佛告迦叶：“善哉善哉！迦叶，汝则长夜多所饶益，安乐众生，哀愍世间，安乐天人。”
    佛告迦叶：“若有毁訾头陀法者，则毁于我。若有称叹头陀法者，则称叹我。所以者何？头陀法者，我所长夜称誉赞叹。是故迦叶！阿练若者，当称叹阿练若；粪扫衣、乞食者，当称叹粪扫衣、乞食法。”
    佛说此经已，摩诃迦叶闻佛所说，欢喜随喜，作礼而去。

（一一四二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者摩诃迦叶久住舍卫国阿练若床坐处，长须发，着弊衲衣，来诣佛所。
    尔时世尊，无数大众围绕说法。
    时诸比丘见摩诃迦叶从远而来，见已于尊者摩诃迦叶所，起轻慢心，言：“此何等比丘，衣服粗陋，无有仪容而来，衣服彷徉而来！”
    尔时世尊知诸比丘心之所念，告摩诃迦叶：“善来迦叶！于此半座。我今竟知谁先出家，汝耶？我耶？”
    彼诸比丘心生恐怖，身毛皆竖，并相谓言：“奇哉尊者！彼尊者摩诃迦叶，大德大力，大师弟子，请以半座。”
    尔时尊者摩诃迦叶合掌白佛言：“世尊，佛是我师，我是弟子。”
    佛告迦叶：“如是如是，我为大师，汝是弟子。汝今且坐，随其所安。”
    尊者摩诃迦叶稽首佛足，退坐一面。
    尔时世尊复欲警悟诸比丘，复以尊者摩诃迦叶同己所得殊胜广大功德，为现众故告诸比丘：“我离欲恶不善法，有觉有观，初禅具足住，若日、若夜、若日夜；摩诃迦叶亦复如我，离欲恶不善法，乃至初禅具足住，若日、若夜、若日夜。我欲第二、第三、第四禅具足住，若日、若夜、若日夜；彼摩诃迦叶亦复如是，乃至第四禅具足住，若日、若夜、若日夜。我随所欲，慈、悲、喜、舍、空入处、识入处、无所有入处、非想非非想入处、神通境界、天耳、他心智、宿命智、生死智、漏尽智具足住，若日、若夜、若日夜；彼迦叶比丘亦复如是，乃至漏尽智具足住，若日、若夜、若日夜。”
    尔时世尊于无量大众中称叹摩诃迦叶同己广大胜妙功德已，诸比丘闻佛所说，欢喜奉行。

（一一四三）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尊者摩诃迦叶、尊者阿难，住耆阇崛山。
    时尊者阿难诣尊者摩诃迦叶所，语尊者摩诃迦叶言：“今可共出耆阇崛山，入王舍城乞食。”尊者摩诃迦叶默然而许。
    时尊者摩诃迦叶、尊者阿难，着衣持钵，入王舍城乞食。尊者阿难语尊者摩诃迦叶：“日时太早，可共暂过比丘尼精舍。”即便往过。
    时诸比丘尼遥见尊者摩诃迦叶、尊者阿难从远而来，疾敷床座，请令就坐。时诸比丘尼礼尊者摩诃迦叶、阿难足已，退坐一面。
    尊者摩诃迦叶为诸比丘尼种种说法，示教照喜。示教照喜已，时偷罗难陀比丘尼不喜悦，说如是恶言：“云何阿梨摩诃迦叶，于阿梨阿难鞞提诃牟尼前为比丘尼说法？譬如贩针儿，于针师家卖。阿梨摩诃迦叶亦复如是，于阿梨阿难鞞提诃牟尼前，为诸比丘尼说法。”
    尊者摩诃迦叶闻偷罗难陀比丘尼心不喜悦，口说恶言，闻已语尊者阿难：“汝看是偷罗难陀比丘尼，心不喜悦，口说恶言。云何阿难，我是贩针儿，汝是针师，于汝前卖耶？”
    尊者阿难语尊者摩诃迦叶：“且止，当忍。此愚痴老妪，智慧薄少，不曾修习故。”
    “阿难，汝岂不闻世尊、如来、应、等正觉所知所见，于大众中说《月譬经》，教诫教授比丘：当如月譬住，常如新学，如是广说。为说阿难如月譬住，常如新学耶？”
    阿难答言：“不也，尊者摩诃迦叶。”
    “阿难，汝闻世尊、如来、应、等正觉所知所见说言：比丘，当如月譬住，常如新学，其唯摩诃迦叶比丘。”
    阿难答言：“如是，尊者摩诃迦叶。”
    “阿难，汝曾为世尊、如来、应、等正觉所知所见，于无量大众中，请汝来坐耶？又复世尊以同己广大之德，称叹汝阿难离欲恶不善法，乃至漏尽通称叹耶？”
    阿难答言：“不也，尊者摩诃迦叶。”
    “如是阿难，世尊、如来、应、等正觉于无量大众中，口自说言：‘善来摩诃迦叶，请汝半座。’复于大众中以同己广大功德，离欲恶不善法，乃至漏尽通，称叹摩诃迦叶耶？”
    阿难答言：“如是，尊者摩诃迦叶。”
    时摩诃迦叶于比丘尼众中，狮子吼已而去。

（一一四四）

    如是我闻。一时尊者摩诃迦叶、尊者阿难，住王舍城耆阇崛山中。世尊涅槃未久，时世饥馑，乞食难得。
    时尊者阿难，与众多年少比丘俱，不能善摄诸根，食不知量，不能初夜、后夜精勤禅思，乐著睡眠，常求世利，人间游行，至南天竺，有三十年少弟子舍戒还俗，余多童子。
    时尊者阿难于南山国土游行，以少徒众，还王舍城。时尊者阿难举衣钵，洗足已，至尊者摩诃迦叶所，稽首礼足，退坐一面。
    时尊者摩诃迦叶问尊者阿难：“汝从何来，徒众鲜少？”
    阿难答言：“从南山国土人间游行，年少比丘三十人舍戒还俗，徒众损减，又今在者多是童子。”
    尊者摩诃迦叶语阿难言：“有几福利，如来、应、等正觉所知所见，听三人已上，制群食戒？”
    阿难答言：“为二事故。何等为二？一者为贫小家，二者多诸恶人以为伴党，相破坏故。莫令恶人于僧中住，而受众名，映障大众，别为二部，互相嫌诤。”
    尊者迦叶语阿难言：“汝知此义，如何于饥馑时，与众多年少弟子，南山国土游行，令三十人舍戒还俗，徒众损减，余者多是童子？如阿难，汝徒众消减，汝是童子，不知筹量！”
    阿难答言：“云何尊者摩诃迦叶，我已头发二色，犹言童子？”
    尊者摩诃迦叶言：“汝于饥馑世，与诸年少弟子人间游行，致令三十弟子舍戒还俗，其余在者复是童子，徒众消减。不知筹量，而言宿士众坏。阿难，众极坏。阿难，汝是童子，不筹量故。”
    时低舍比丘尼，闻尊者摩诃迦叶以童子责尊者阿难毗提诃牟尼，闻已不欢喜，作是恶言：“云何阿梨摩诃迦叶，本外道门，而以童子呵责阿梨阿难毗提诃牟尼，令童子名流行？”
    尊者摩诃迦叶以天耳闻低舍比丘尼心不欢喜，口出恶言，闻已语尊者阿难：“汝看是低舍比丘尼，心不欢喜，口说恶语，言：‘摩诃迦叶本门外道，而责阿梨阿难毗提诃牟尼，令童子名流行。’”
    尊者阿难答言：“且止，尊者摩诃迦叶。忍之，尊者摩诃迦叶。此愚痴老妪，无自性智。”
    尊者摩诃迦叶语阿难言：“我自出家，都不知有异师，唯如来、应、等正觉。我未出家时，常念生老病死、忧悲恼苦，知在家荒务，多诸烦恼。出家空闲，难可俗人，处于非家，一向鲜洁，尽其形寿，纯一满净，梵行清白。当剃须发，着袈裟衣，正信非家，出家学道，以百千金贵价之衣，段段割截为僧伽梨。若世间阿罗汉者，闻从出家。我出家已，于王舍城那罗聚落中间多子塔所，遇值世尊，正身端坐，相好奇特，诸根寂静，第一息灭，犹如金山。我时见已，作是念：‘此是我师，此是世尊，此是罗汉，此是等正觉！’我时一心合掌敬礼，白佛言：‘是我大师，我是弟子！’
    “佛告我言：‘如是迦叶，我是汝师，汝是弟子。迦叶，汝今成就如是真实净心，所恭敬者不知言知、不见言见、实非罗汉而言罗汉、非等正觉言等正觉者，应当自然身碎七分。迦叶，我今知故言知，见故言见，真阿罗汉言阿罗汉，真等正觉言等正觉。迦叶，我今有因缘故为声闻说法，非无因缘故；依非无依；有神力非无神力。是故迦叶，若欲闻法，应如是学。若欲闻法，以义饶益，当一其心，恭敬尊重，专心侧听，而作是念：我当正观五阴生灭，六触入处集起灭没，于四念处正念乐住，修七觉分、八解脱身作证。常念其身，未尝断绝，离无惭愧，于大师所，及大德梵行，常住惭愧，如是应当学。’
    “尔时世尊为我说法，示教照喜，示教照喜已，从座起去。我亦随去，向于住处，我以百千价直衣割截僧伽梨四摄为座。尔时世尊知我至心，处处下道。我即敷衣，以为坐具，请佛令坐。世尊即坐，以手摩衣，叹言：‘迦叶！此衣轻细，此衣柔软。’我时白言：‘如是世尊，此衣轻细，此衣柔软，唯愿世尊受我此衣。’佛告迦叶：‘汝当受我粪扫衣，我当受汝僧伽梨。’佛即自手授我粪扫纳衣，我即奉佛僧伽梨。如是渐渐教授，我八日之中，以学法受于乞食。至第九日，起于无学。
    “阿难，若有正问：‘谁是世尊法子，从佛口生，从法化生，付以法财，诸禅、解脱、三昧、正受？’应答我是，是则正说。譬如转轮圣王第一长子，当以灌顶住于王位，受王五欲，不苦方便，自然而得。我亦如是，为佛法子，从佛口生，从法化生，得法余财，诸禅、解脱、三昧、正受，不苦方便，自然而得。譬如转轮圣王宝象，高七八肘，一多罗叶能映障者，如是我所成就六神通智则可映障。若有于神通境界智证，有疑惑者，我悉能为分别记说。天耳、他心通、宿命智、生死智、漏尽作证智通，有疑惑者，我悉能为分别记说，令得决定。”
    尊者阿难语尊者摩诃迦叶：“如是如是，摩诃迦叶！如转轮圣王宝象，高七八肘，欲以一多罗叶能映障者，如是尊者摩诃迦叶六神通智则可映障。若有于神通境界作证智，乃至漏尽作证智有疑惑者，尊者摩诃迦叶能为记说，令其决定。我于长夜敬信尊重尊者摩诃迦叶，以有如是大德神力故！”
    尊者摩诃迦叶说是语时，尊者阿难闻其所说，欢喜受持。


杂阿含经卷第四十二

（一一四五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时波斯匿王来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，应施何等人？”
    佛言：“大王，随心所乐处。”
    波斯匿王复白佛言：“应施何处，得大果报？”
    佛言：“大王，此是异问。所问应施何处，此问则异。复问施何处应得大果，此问复异。我今问汝，随意答我。大王，譬如此国临阵战斗，集诸战士。而有一婆罗门子，从东方来，年少幼稚，柔弱端正，肤白发黑，不习武艺，不学术策，恐怖退弱，不能自安，不忍敌观，若刺若射，无有方便，不能伤彼。云何大王，如此士夫，王当赏不？”
    王白佛言：“不赏，世尊。”
    “如是大王，有刹利童子从南方来，鞞舍童子从西方来，首陀罗童子从北方来，无有伎术，皆如东方婆罗门子，王当赏不？”
    王白佛言：“不赏，世尊。”
    佛告大王：“此国集军，临战斗时，有婆罗门童子从东方来，年少端正，肤白发黑，善学武艺，知斗术法，勇健无畏，苦战不退，安住谛观，运戈能伤，能破巨敌。云何大王，如此战士，加重赏不？”
    王白佛言：“重赏，世尊。”
    “如是刹利童子从南方来，鞞舍童子从西方来，首陀罗童子从北方来，年少端正，善诸术艺，勇健堪能，苦战却敌，皆如东方婆罗门子。如是战士，王当赏不？”
    王白佛言：“重赏，世尊。”
    佛言：“大王，如是沙门、婆罗门，远离五支，成就五支，建立福田。施此田者，得大福利，得大果报。何等为舍离五支？所谓贪欲盖，瞋恚、睡眠、掉悔、疑盖，已断已知，是名舍离五支。何等为成就五支？谓无学戒身成就，无学定身、慧身、解脱身、解脱知见身，是名成就五支。大王，如是舍离五支，成就五支，建立福田。施此田者，得大果报。”
    尔时世尊复说偈言：

“运戈猛战斗，堪能勇士夫，
为其战斗故，随功重加赏，
不赏名族胄，怯劣无勇者。
忍辱修贤良，见谛建福田，
贤圣律仪备，成就深妙智，
族胄虽卑微，堪为施福田。
衣食钱财宝，床卧等众具，
悉应以敬施，为持净戒故。
人表林野际，穿井给行人，
溪涧施桥梁，迥路造房舍，
戒德多闻众，行路得止息。
譬如重云起，雷电声振耀，
普雨于壤土，百卉悉扶疏，
禽兽皆欢喜，田夫并欣乐。
如是净信心，闻慧舍悭垢，
钱财丰饮食，常施良福田，
高唱增欢受，如雷雨良田，
功德注流泽，沾洽施主心，
财富名称流，及涅槃大果。”

    佛说此经已，波斯匿王闻佛所说，欢喜随喜，作礼而去。

（一一四六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时波斯匿王来诣佛所，稽首佛足，退坐一面，白佛言：“云何世尊，为婆罗门死，还生自姓婆罗门家，刹利、鞞舍、首陀罗家耶？”
    佛言：“大王，何得如是？大王当知，有四种人，何等为四？有一种人，从冥入冥；有一种人，从冥入明；有一种人，从明入冥；有一种人，从明入明。
    “大王，云何为一种人从冥入冥？谓有人生卑姓家，若生旃陀罗家、鱼猎家、竹作家、车师家，及余种种下贱工巧业家，贫穷活命，形体憔悴，而复修行卑贱之业，亦复为人下贱作使，是名为冥。处斯冥中，复行身恶行，行口恶行，行意恶行，以是因缘，身坏命终，当生恶趣，堕泥梨中。犹如有人从暗入暗，从厕入厕，以血洗血，舍恶受恶。从冥入冥者，亦复如是，是故名为从冥入冥。
    “云何名为从冥入明？谓有世人生卑姓家，乃至为人作诸鄙业，是名为冥。然其彼人于此冥中，行身善行，行口善行，行意善行，以是因缘，身坏命终，生于善趣，受天化生。譬如有人登床跨马，从马升象。从冥入明，亦复如是，是名有人从冥入明。
    “云何有人从明入冥？谓有世人生富乐家，若刹利大姓、婆罗门大姓家、长者大姓家，及余种种富乐家生，多诸钱财、奴婢、客使，广集知识，受身端正，聪明黠慧，是名为明。于此明中，行身恶行，行口恶行，行意恶行，以是因缘，身坏命终，生于恶趣，堕泥梨中。譬如有人从高楼下乘于大象，下象乘马，下马乘舆，下舆坐床，下床堕地，从地落坑。从明入冥者，亦复如是。
    “云何有人从明入明？谓有世人生富乐家，乃至形相端严，是名为明。于此明中，行身善行，行口善行，行意善行，以是因缘，身坏命终，生于善趣，受天化生。譬如有人从楼观至楼观，如是乃至从床至床。从明入明者，亦复如是，是名有人从明入明。”
    尔时世尊复说偈言：

“贫穷困苦者，不信增瞋恨，
悭贪恶邪想，痴惑不恭敬，
见沙门道士，持戒多闻者，
毁訾而不誉，障他施及受，
如斯等士夫，从此至他世，
当堕泥梨中，从冥入于冥。
若有贫穷人，信心少瞋恨，
常生惭愧心，惠施离悭垢，
见沙门梵志，持戒多闻者，
谦虚而问讯，随宜善供给，
劝人令施与，叹施及受者，
如是修善人，从此至他世，
善趣上生天，从冥而入明。
有富乐士夫，不信多瞋恨，
悭贪嫉恶想，邪惑不恭敬，
见沙门梵志，毁訾而不誉，
障他人施惠，亦断受施者，
如是恶士夫，从此至他世，
当生苦地狱，从明入冥中。
若有富士夫，信心不瞋恨，
常起惭愧心，惠施离瞋妒，
见沙门梵志，持戒多闻者，
先奉迎问讯，随宜给所须，
劝人令供养，叹施及受者，
如是等士夫，从此至他世，
生三十三天，从明而入明。”

    佛说此经已，波斯匿王闻佛所说，欢喜随喜，作礼而去。

（一一四七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时波斯匿王，日日身蒙尘土，来诣佛所，稽首佛足，退坐一面。
    佛言：“大王从何所来？”
    波斯匿王白佛言：“世尊，彼灌顶王法，人中自在，精勤方便，王领大地，统理王事，周行观察，而来至此。”
    佛告大王：“今问大王，随意答我。譬如有人从东方来，有信有缘，未曾虚妄，而白王言：‘我东方来，见一石山，极方广大，不穿不坏，亦无缺坏，磨地而来，一切众生、草木之类，悉磨令碎。’南、西、北方亦有人来，有信有缘，亦不虚妄，而白王言：‘我见石山，方广高大，不断不坏，亦不缺坏，磨地而来，一切众生、草木悉皆磨碎。’大王，于意云何？如是像貌大恐怖事，险恶相杀，众生运尽，人道难得，当作何计？”
    王白佛言：“若如是者，更无余计，唯当修善，于佛法律，专心方便。”
    佛告大王：“何故说言险恶恐怖于世卒起，众生运尽，人身难得，唯当行法、行义、行福，于佛法教专精方便？何以不言灌顶王位为众人首，堪能自在，王于大地，事务、众人当须营理耶？”
    王白佛言：“世尊，为复闲时，言灌顶王位为众人首，王于大地，多所经营，以言斗言，以财斗财，以象斗象，以车斗车，以步斗步。当于尔时，无有自在，若胜若伏，是故我说险恶恐怖卒起之时，众生运尽，人身难得，无有余计，唯有行义、行法、行福，于佛法教，专心归依。”
    佛告大王：“如是如是！经常磨迮，谓恶劫、老、病、死，磨迮众生，当作何计？正当修义、修法、修福、修善、修慈，于佛法中精勤方便。”
    尔时世尊而说偈言：

“如有大石山，高广无缺坏，
周遍四方来，磨迮此大地，
非兵马咒术，力所能防御。
恶劫老病死，常磨迮众生，
四种大族姓，栴陀罗猎师，
在家及出家，持戒犯戒者，
一切皆磨迮，无能救护者。
是故慧士夫，观察自己利，
建立清净信，信佛法僧宝，
身口心清净，随顺于正法，
现世名称流，终则生天上。”

    佛说此经已，波斯匿王闻佛所说，欢喜随喜，作礼而去。

（一一四八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时波斯匿王来诣佛所，稽首佛足，退坐一面。
    时有尼乾子七人，阇祇罗七人，一舍罗七人，身皆粗大，彷徉行住祇洹门外。
    时波斯匿王遥见斯等彷徉门外，即从座起，往至其前，合掌问讯，三自称名，言：“我是波斯匿王、拘萨罗王。”
    尔时世尊告波斯匿王：“汝今何故恭敬斯等，三称姓名，合掌问讯？”
    王白佛言：“我作是念：世间若有阿罗汉者，斯等则是。”
    佛告波斯匿王：“汝今且止，汝亦不知是阿罗汉、非阿罗汉，不得他心智故。且当亲近，观其戒行，久而可知，勿速自决。审谛观察，勿但洛莫，当用智慧，不以不智。经诸苦难，堪能自辩，交契计校，真伪则分。见说知明，久而则知，非可卒识，当须思惟，智慧观察。”
    王白佛言：“奇哉世尊！善说斯理，言久相习，观其戒行，乃至见说知明。我有家人，亦复出家，作斯等形相，周流他国，而复来还，舍其被服，还受五欲。是故当知世尊善说，应与同止，观其戒行，乃至言说，如有智慧。”
    尔时世尊而说偈言：

“不以见形相，知人之善恶，
不应暂相见，而与同心志。
有现身口密，俗心不敛摄，
犹如鍮石铜，涂以真金色。
内怀鄙杂心，外现圣威仪，
游行诸国土，欺诳于世人。”

    佛说此经已，波斯匿王闻佛所说，欢喜随喜，作礼而去。

（一一四九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时波斯匿王为首，并七国王，及诸大臣，悉共集会，作如是论议：“五欲之中，何者第一？”
    有一人言：“色最第一。”又复有称声、香、味、触为第一者。中有人言：“我等人人各说第一，竟无定判，当诣世尊，问如此义。如世尊说，当共忆持。”
    尔时波斯匿王为首，与七国王、大臣、眷属来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我等七王与诸大臣如是论议：‘五欲功德，何者为胜？’其中有言色胜，有言声胜，有言香胜，有言味胜，有言触胜，竟无决定。来问世尊，竟何者胜？”
    佛告诸王：“各随意适我，悉有余说。以是因缘，我说五欲功德，然自有人于色适意，止爱一色，满其志愿，正使过上有诸胜色，非其所爱，不触不视，言己所爱最为第一，无过其上。如爱色者，声、香、味、触亦皆如是，当其所爱，辄言最胜，欢喜乐著，虽更有胜过其上者，非其所欲，不触不视，唯我爱者最胜最妙，无比无上。”
    尔时座中有一优婆塞，名曰栴檀，从座起，整衣服，偏袒右肩，合掌白佛：“善说，世尊！善说，善逝！”
    佛告优婆塞：“善说，栴檀！快说，栴檀！”
    时栴檀优婆塞即说偈言：

“央伽族姓王，服珠璎珞铠，
摩竭众庆集，如来出其国。
名闻普流布，犹如雪山王，
如净水莲花，清净无瑕秽。
随日光开敷，芬香熏其国，
央耆国明显，犹如空中日。
观如来慧力，如夜燃炬火，
为眼为大明，来者为决疑。”

    时诸国王叹言：“善说，栴檀优婆塞！”尔时七王脱七宝上衣，奉优婆塞。
    时彼七王闻佛所说，欢喜随喜，从座起去。
    尔时栴檀优婆塞知诸王去已，从座起，整衣服，偏袒右肩，合掌白佛：“今七国王遗我七领上衣，唯愿世尊受此七衣，以哀愍故！”
    尔时世尊为哀愍故，受其七衣。
    栴檀优婆塞欢喜随喜，作礼而去。

（一一五○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时波斯匿王其体肥大，举体流汗，来诣佛所，稽首佛足，退坐一面，气息长喘。
    尔时世尊告波斯匿王：“大王身体极肥盛。”
    大王白佛言：“如是，世尊。患身肥大，常以此身极肥大故，惭耻厌苦。”
    尔时世尊即说偈言：

“人当自系念，每食知节量，
是则诸受薄，安消而保寿。”

    时有一年少，名郁多罗，于会中坐。时波斯匿王告郁多罗：“汝能从世尊受向所说偈，每至食时，为我诵不？若能尔者，赐金钱十万，亦常与食。”
    郁多罗白王：“奉教当诵。”
    时波斯匿王闻佛所说，欢喜随喜，作礼而去。
    时郁多罗知王去已，至世尊前，受所说偈。于王食时，食食为诵，白言：“大王，如佛、世尊、如来、应、等正觉所知所见，而说斯偈：

“人当自系念，每食知节量，
是则诸受薄，安消而保寿。”

    如是波斯匿王渐至后时，身体傭细，容貌端正，处楼阁上，向佛住处合掌恭敬，右膝着地，三说是言：“南无敬礼世尊、如来、应、等正觉！南无敬礼世尊、如来、应、等正觉！与我现法利益，后世利益，现法后世利益，以其饭食知节量故。”

（一一五一）

    如是我闻。一时佛住舍卫国。
    时有年少阿修罗来诣佛所，于佛面前粗恶不善语，瞋骂呵责。
    尔时世尊即说偈言：

“不怒胜瞋恚，不善以善伏，
惠施伏悭贪，真言坏妄语。
不骂亦不虐，常住贤圣心，
恶人住瞋恨，不动如山石。
起瞋恚能持，胜制狂马车，
我说善御士，非彼摄绳者。”

    时年少阿修罗白佛言：“瞿昙！我今悔过，如愚如痴，不辩不善，于瞿昙面前诃骂毁辱。”
    如是忏悔已，时阿修罗闻佛所说，欢喜随喜，作礼而去。

（一一五二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有年少宾耆迦婆罗门来诣佛所，于世尊面前作粗恶不善语，瞋骂呵责。
    尔时世尊告年少宾耆迦：“若于一时吉星之日，汝当会诸宗亲眷属耶？”
    宾耆白佛：“如是，瞿昙。”
    佛告宾耆：“若汝宗亲不受食者，当如之何？”
    宾耆白佛：“不受食者，食还属我。”
    佛告宾耆：“汝亦如是，如来面前作粗恶不善语，骂辱呵责，我竟不受，如此骂者，应当属谁？”
    宾耆白佛：“如是瞿昙，彼虽不受，且以相赠，则便是与。”
    佛告宾耆：“如是不名更相赠遗，何得便为相与？”
    宾耆白佛：“云何名为更相赠遗，名为相与？云何名不受相赠遗，不名相与？”
    佛告宾耆：“若当如是骂则报骂，瞋则报瞋，打则报打，斗则报斗，名相赠遗，名为相与。若复宾耆，骂不报骂，瞋不报瞋，打不报打，斗不报斗，若如是者，非相赠遗，不名相与。”
    宾耆白佛：“瞿昙，我闻古昔婆罗门长老宿重行道大师所说：‘如来、应、等正觉，面前骂辱瞋恚诃责，不瞋不怒。’而今瞿昙有瞋恚耶？”
    尔时世尊即说偈言：

“无瞋何有瞋，正命以调伏，
正智心解脱，慧者无有瞋。
以瞋报瞋者，是则为恶人，
不以瞋报瞋，临敌伏难伏。”
不瞋胜于瞋，三偈如前说。

    尔时年少宾耆白佛言：“悔过，瞿昙！如愚如痴，不辩不善，而于沙门瞿昙面前，粗恶不善语，瞋骂呵责。”
    闻佛所说，欢喜随喜，作礼而去。

（一一五三）

    如是我闻。一时佛住舍卫国东园鹿子母讲堂。
    尔时世尊晡时从禅觉，诣讲堂东荫荫中，露地经行。
    时有健骂婆罗豆婆遮婆罗门来诣佛所，世尊面前作粗恶不善语，骂詈呵责。世尊经行，彼随世尊后行。世尊经行已竟，住于一处。彼婆罗门言：“瞿昙伏耶？”
    尔时世尊而说偈言：

“胜者更增怨，伏者卧不安，
胜伏二俱舍，是得安隐眠。”

    婆罗门白言：“瞿昙！我今悔过，如愚如痴，不辩不善，何于瞿昙面前作粗恶不善语，骂詈呵责！”
    时婆罗门闻佛所说，欢喜随喜，复道而去。

（一一五四）

    如是我闻。一时佛住舍卫国东园鹿子母讲堂。
    世尊晨朝着衣持钵，入舍卫城乞食。
    时健骂婆罗豆婆遮婆罗门遥见世尊，作粗恶不善语，瞋骂呵责，把土坌佛，时有逆风，还吹其土，反自坌身。
    尔时世尊即说偈言：

“若人无瞋恨，骂辱以加者，
清净无结垢，彼恶还归己，
犹如土坌彼，逆风还自污。”

    时彼婆罗门白佛言：“悔过，瞿昙！如愚如痴，不善不辩，何于瞿昙面前粗恶不善语，瞋骂呵责！”
    时婆罗门闻佛所说，欢喜随喜，复道而去。

（一一五五）

    如是我闻。一时佛在拘萨罗人间游行，至舍卫国祇树给孤独园。
    时有婆罗门名曰违义，闻沙门瞿昙从拘萨罗国人间游行，至舍卫国祇树给孤独园，闻已作是念：“我当往诣沙门瞿昙所，闻所说法，当反其义。”作是念已，往诣精舍，至世尊所。
    尔时世尊，无量眷属围绕说法。世尊遥见违义婆罗门来，即默然住。
    违义婆罗门白佛言：“瞿昙说法，乐欲闻之！”
    尔时世尊即说偈言：

“违义婆罗门，未能解深义，
内怀嫉恚心，欲为法留难。
调伏违反心，诸不信乐意，
息诸障碍垢，则解深妙说。”

    时违义婆罗门作是念：“沙门瞿昙已知我心。”闻佛所说，欢喜随喜，从座起而去。

（一一五六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    世尊晨朝着衣持钵，入舍卫城乞食。
    时有不害婆罗门来诣佛所，白佛言：“世尊，我名不害，为称实不？”
    佛告婆罗门：“如是称实者，若身不害，若口不害，若心不害，则为称实。”
    尔时世尊即说偈言：

“若心不杀害，口意亦俱然，
是则为离害，不恐怖众生。”

    佛说此经已，不害婆罗门闻佛所说，欢喜随喜，复道而去。

（一一五七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    世尊晨朝着衣持钵，入王舍城乞食，次第行乞，至火与婆罗门舍。
    火与婆罗门遥见佛来，即具众美饭食，满钵与之。
    如是二日、三日，乞食复至其舍。
    火与婆罗门遥见佛来，作是念：“秃头沙门何故数来，贪美食耶？”
    尔时世尊知火与婆罗门心念已，即说偈言：

“上天日日雨，田夫日夜耕，
数数植种子，是田数收谷。
如人数怀妊，乳牛数怀犊，
数数有求者，则能数惠施，
数数惠施故，常得大名称。
数数弃死尸，数数哭悲恋，
数数生数死，数数忧悲苦，
数数以火烧，数数诸虫食。
若得贤圣道，不数受诸有，
亦不数生死，不数忧悲苦，
不数数火烧，不数诸虫食。”

    时火与婆罗门闻佛说偈，还得信心，复以种种饮食满钵与之。
    世尊不受，以因说偈而施故，复说偈言：

“因为说偈法，不应受饮食，
当观察自法，说法不受食，
婆罗门当知，斯则净命活。
应以余供养，纯净大仙人，
已尽诸有漏，秽法悉已断。
供养以饮食，于其良福田，
欲求福德者，则我田为良。”

    火与婆罗门白佛：“今以此食，应着何所？”
    佛告婆罗门：“我不见诸天、魔、梵、沙门、婆罗门、天神、世人，有能食此信施，令身安乐。汝持是食去，弃于无虫水中，及少生草地。”
    时婆罗门即以此食，持着无虫水中，水即烟出，沸声啾啾。譬如铁丸，烧令火色，掷着水中，水即烟起，沸声啾啾，亦复如是。婆罗门持此饮食着水中，水即烟出，沸声啾啾。
    于时火与婆罗门叹言：“甚奇瞿昙！大德大力，能令此食而作神变。”
    时火与婆罗门因此饭食神变，得信敬心，稽首佛足，退住一面，白佛言：“世尊，我今可得于正法中出家，受具足，修梵行不？”
    佛告婆罗门：“汝今可得于正法中出家、受具足。”
    彼即出家已，作是思惟，所以族姓子剃除须发，着袈裟衣，正信非家，出家学道。乃至得阿罗汉，心善解脱。

（一一五八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时舍卫国中婆肆吒婆罗门女，信佛、法、僧，归佛、归法、归比丘僧。于佛、法、僧已离狐疑，于苦、集、尽、道亦离疑惑，见谛得果，得无间慧。其夫是婆罗豆婆遮种姓婆罗门。
    每至左右所为作时，有小得失，即称南无佛，向如来所住方面，随方合掌，三说是言：“南无多陀阿伽度、阿罗诃、三藐三佛陀！身纯金色，圆光一寻，方身圆满，如尼拘律树，善说妙法，牟尼之尊，仙人上首，是我大师。”
    时夫婆罗门闻之，瞋恚不喜，语其妇言：“为鬼着耶？无有此义！舍诸三明大德婆罗门，而称叹彼秃头沙门。黑暗之分，世所不称。我今当往，共汝大师论议，足知胜如。”
    妇语夫言：“不见诸天、魔、梵、沙门、婆罗门、诸神、世人，能共世尊、如来、应、等正觉，金色之身，圆光一寻，如尼拘律树圆满之身，言说微妙，仙人上首，我之大师，共论议者。然今婆罗门且往，自可知之！”
    时婆罗门即往诣佛所，面相问讯慰劳已，退坐一面，而说偈言：

“为杀于何等，而得安隐眠？
为杀于何等，令心得无忧？
为杀于何等，瞿昙所称叹？”

    尔时世尊知婆罗门心之所念，而说偈言：

“杀于瞋恨者，而得安隐眠。
杀于瞋恚者，而心得无忧。
瞋恚为毒本，能害甘种子，
能害于彼者，贤圣所称叹，
若能害彼者，其心得无忧。”

    时婆罗豆婆遮婆罗门闻佛所说，示教照喜，次第说法，谓说施，说戒，说生天法，说欲味著为灾患，烦恼清净，出要远离，随顺福利清净，分别广说。譬如清净白氎易为染色，如是婆罗豆婆遮婆罗门，即于座上，于四圣谛得无碍等，所谓苦、集、灭、道。是婆罗门见法、得法、知法、入法，度诸疑惑，不由他度，于正法律得无所畏。即从座起，偏露右肩，合掌白佛：“已度，世尊！已度，善逝！我今归佛、归法、归比丘僧已，尽其寿命为优婆塞，证知我！”
    时婆罗豆婆遮婆罗门闻佛所说，欢喜随喜，作礼而去，还归自家。
    其妇优婆夷遥见夫来，见已白言：“已与如来、应、等正觉，纯金色身，圆光一寻，如尼拘律树圆满之身，妙说之上，仙人之首，大牟尼尊，为我大师，共论议耶？”
    其夫答言：“我未尝见诸天、魔、梵、沙门、婆罗门、诸神、世人，有能与如来、应、等正觉，真金色身，圆光一寻，如尼拘律树圆满之身，妙说之上，诸仙之首，牟尼之尊，汝之大师，共论议也。汝今与我作好法衣，我持至世尊所，出家学道。”
    时妇悉以鲜洁白氎，令作法衣。时婆罗门持衣往诣世尊所，稽首礼足，退住一面，白言：“世尊，我今可得于世尊法中出家学道，修梵行不？”
    佛告婆罗门：“汝今可得于此法律出家学道，修诸梵行！”
    即出家已，独静思惟，所以善男子剃除须发，着袈裟衣，出家学道。乃至得阿罗汉，心善解脱。

（一一五九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有魔瞿婆罗门来诣佛所，与世尊面相问讯慰劳已，退坐一面，白佛言：“瞿昙，我于家中常行布施。若一人来，施于一人。若二人、三人，乃至百千，悉皆施与。我如是施，得多福不？”
    佛告婆罗门：“汝如是施，实得大福。所以者何？以于家中常行布施，一人来乞，即施一人；二人、三人，乃至百千，悉皆施与故，即得大福。”
    时魔瞿婆罗门即说偈言：

“在家所为作，布施复大会，
因此惠施故，欲求大功德。
今问于牟尼，我之所应知，
同梵天所见，为我分别说。
云何为解脱，胜妙之善趣？
云何修方便，得生于梵世？
云何随乐施，生明胜梵天？”

    尔时世尊说偈答言：

“施者设大会，随彼爱乐施，
欢喜净信心，攀缘善功德。
以其所建立，求离诸过恶，
远离于贪欲，其心善解脱。
修习于慈心，其功德无量，
况复加至诚，广施设大会。
若于其中间，所得诸善心，
正向善解脱，或余纯善趣，
如是胜因缘，得生于梵世。
如是之惠施，其心平等故，
得生于梵世，其寿命延长。”

    时魔瞿婆罗门闻佛所说，欢喜随喜，从座起而去。

（一一六○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有持华盖、着舍勒、导从婆罗门，来诣佛所，与世尊面相问讯慰劳已，退坐一面，而说偈言：

“无非婆罗门，所行为清净，
刹利修苦行，于净亦复乖。
三典婆罗门，是则为清净，
如是清净者，不在余众生。”

    尔时世尊说偈答言：

“不知清净道，及诸无上净，
于余求净者，至竟无净时。”

    婆罗门白佛：“瞿昙说清净道及无上清净耶？何等为清净道？何等为无上清净？”
    佛告婆罗门：“正见者为清净道。正见修习多修习，断贪欲、断瞋恚、断愚痴，若婆罗门贪欲永断，瞋恚、愚痴永断，一切烦恼永断，是名无上清净。正志、正语、正业、正命、正方便、正念、正定，是名清净道。正定修习多修习已，断贪欲、断瞋恚、断愚痴，若婆罗门贪欲永断，瞋恚、愚痴永断，一切烦恼永断，是名无上清净。”
    婆罗门白佛言：“瞿昙说清净道、无上清净耶！瞿昙，世务多事，今且辞还。”
    佛告婆罗门：“宜知是时。”
    持华盖、着舍勒、导从婆罗门，闻佛所说，欢喜随喜，从座起去。

（一一六一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时有异婆罗门来诣佛所，与世尊面相问讯慰劳已，退坐一面，而说偈言：

“云何为尸罗？云何正威仪？
云何为功德？云何名为业？
成就何等法，罗汉婆罗门？”

    尔时世尊说偈答言：

“宿命忆念智，见生天恶趣，
得诸受生尽，牟尼明决定。
知心善解脱，解脱一切贪，
具足于三明，三明婆罗门。”

    佛说此经已，异婆罗门闻佛所说，欢喜随喜，从座起而去。

（一一六二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊晨朝着衣持钵，入舍卫城乞食，尊者阿难从世尊后。
    时有二老男女，是其夫妇，年耆根熟，伛背如钩，诣里巷头，烧粪扫处，俱蹲向火。
    世尊见彼二老夫妇，年耆愚老，伛背如钩，俱蹲向火，犹如老鹄，欲心相视。见已告尊者阿难：“汝见彼夫妇二人，年耆愚老，背伛如钩，俱蹲向火，犹如老鹄，欲心相视不？”
    阿难白佛：“如是，世尊。”
    佛告阿难：“此二老夫妇，于年少时盛壮之身，勤求财物者，亦可得为舍卫城中第一富长者。若复剃除须发，着袈裟衣，正信非家，出家学道，精勤修习者，亦可得阿罗汉第一上果。于第二分盛壮之身，勤求财物，亦可得为舍卫城中第二富者。若复剃除须发，着袈裟衣，正信非家，出家学道者，亦可得阿那含果证。若于第三分中年之身，勤求财物，亦可得为舍卫城中第三富者。若剃须发，着袈裟衣，正信非家，出家学道者，亦可得斯陀含果证。若于第四分老年之身，勤求财物，亦可得为舍卫城中第四富者。若剃须发，着袈裟衣，正信非家，出家学道者，亦可得为须陀洹果证。彼于今日，年耆根熟，无有钱财，无有方便，无所堪能，不复堪能苦觅钱财，亦不能得胜过人法。”
    尔时世尊复说偈言：

“不行梵行故，不得年少财，
思惟古昔事，眠地如曲弓。
不修于梵行，不得年少财，
犹如老鹄鸟，守死于空池。”

    佛说此经已，尊者阿难陀闻佛所说，欢喜奉行。

（一一六三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    如上说，差别者，唯说异偈言：

“老死之所坏，身及所受灭，
唯有惠施福，为随己资粮。
依于善摄护，及修禅功德，
随力而行施，钱财及饮食，
于群则眠觉，非为空自活。”

    佛说此经已，彼婆罗门闻佛所说，欢喜随喜，作礼而去。


杂阿含经卷第四十三

（一一六四）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    时有众多比丘集于讲堂，作如是论：“诸尊，如世尊说波罗延低舍弥德勒所问：

‘若知二边者，于中永无著，
说名大丈夫，不顾于五欲，
无有烦恼锁，超出缝紩忧。’

    “诸尊，此有何义？云何边？云何二边？云何为中？云何为缝紩？云何思以智知，以了了，智所知，了所了，作苦边，脱于苦？”
    有一答言：“六内入处是一边，六外入处是二边，受是其中，爱为缝紩。习于受者，得彼彼因身，渐转增长出生。于此即法，以智知，以了了，智所知，了所了，作苦边，脱于苦。”
    复有说言：“过去世是一边，未来世是二边，现在世名为中，爱为缝紩。习近此爱，彼彼所因身，渐触增长出生，乃至脱苦。”
    复有说言：“乐受者是一边，苦受者是二边，不苦不乐是其中，爱为缝紩。习近此爱，彼彼所得自身，渐触增长出生，乃至脱苦。”
    复有说言：“有者是一边，集是二边，受是其中，爱为缝紩。如是广说，乃至脱苦。”
    复有说言：“身者是一边，身集是二边，爱为缝紩。如是广说，乃至脱苦。”
    复有说言：“我等一切所说不同，所谓向来种种异说，要不望知，云何世尊有余之说，波罗延低舍弥德勒所问经？我等应往具问世尊，如世尊所说，我等奉持。”
    尔时众多比丘诣世尊所，稽首礼足，退坐一面，白佛言：“世尊，向诸比丘集于讲堂，作如是言：‘于世尊所说波罗延低舍弥德勒所问经，所谓二边，乃至脱苦。’有人说言：‘内六入处是说一边，外六入处是说二边，受是其中，爱为缝紩。’如前广说，悉不决定，今日故来请问世尊，具问斯义。我等所说，谁得其义？”
    佛告诸比丘：“汝等所说，皆是善说。我今当为汝等说有余经。我为波罗延低舍弥德勒有余经说，谓触是一边，触集是二边，受是其中，爱为缝紩。习近爱已，彼彼所得身，缘触增长出生。于此法，以智知，以了了，智所知，了所了，作苦边，脱于苦。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一六五）

    如是我闻。一时尊者宾头卢住拘睒弥国瞿师罗园。
    时有婆蹉国王名优陀延那，诣尊者宾头卢所，共相问讯，问讯已退坐一面。
    婆蹉王优陀延那白尊者宾头卢言：“欲有所问，宁有闲暇见答与不？”
    尊者宾头卢答言：“大王！大王且问，知者当答。”
    婆蹉王优陀延那问尊者宾头卢：“何因何缘，新学年少比丘于此法律出家未久，极安乐住，诸根欣悦，颜貌清净，肤色鲜白，乐静少动，任他而活，野兽其心，堪能尽寿修持梵行，纯一清净？”
    尊者宾头卢答言：“如佛所说，如来、应、等正觉所知所见，为比丘说：‘汝诸比丘，若见宿人，当作母想。见中年者，作姊妹想。见幼稚者，当作女想。’以是因缘，年少比丘于此法律出家未久，安隐乐住，诸根敷悦，颜貌清净，肤色鲜白，乐静少动，任他而活，野兽其心，堪能尽寿修持梵行，纯一清净。”
    婆蹉王优陀延那语尊者宾头卢言：“今诸世间贪求之心，若见宿人而作母想，见中年者作姊妹想，见幼稚者而作女想，当于尔时，心亦随起贪欲烧燃、瞋恚烧燃、愚痴烧燃。要当更有胜因缘不？”
    尊者宾头卢语婆蹉王优陀延那：“更有因缘，如世尊说，如来、应、等正觉所知所见，为比丘说：‘此身从足至顶，骨干肉涂，覆以薄皮，种种不净充满其中。周遍观察，发、毛、爪、齿、尘垢、流唌、皮、肉、白骨、筋、脉、心、肝、肺、脾、肾、肠、肚、生脏、熟脏、胞、泪、汗、涕、沫、肪、脂、髓、痰癊、脓、血、脑汁、屎、尿。’大王，此因此缘故，年少比丘于此法律出家未久，安隐乐住，乃至纯一满净。”
    婆蹉王优陀延那语尊者宾头卢：“人心飘疾，若观不净，随净想现。颇更有因缘，令年少比丘于此法律出家未久，安隐乐住，乃至纯一满净不？”
    尊者宾头卢言：“大王，有因有缘，如世尊说，如来、应、等正觉所知所见，告诸比丘：‘汝等应当守护根门，善摄其心。若眼见色时，莫取色相，莫取随形好，增上执持。若于眼根不摄敛住，则世间贪忧、恶不善法，则漏其心，是故汝等当受持眼律仪。耳声、鼻香、舌味、身触、意法，亦复如是，乃至受持意律仪。’”
    尔时婆蹉王优陀延那语尊者宾头卢：“善哉！善说法，乃至受持诸根律仪。尊者宾头卢，我亦如是，有时不守护身，不持诸根律仪，不一其念，入于宫中，其心极生贪欲炽燃、愚痴烧燃。正使闲房独处，亦复三毒烧燃其心，况复宫中。又我有时善护其身，善摄诸根，专一其念，入于宫中，贪欲、恚、痴不起烧燃其心。于内宫中尚不烧身，亦不烧心，况复闲独。以是之故，此因此缘，能令年少比丘于此法律出家未久，安隐乐住，乃至纯一满净。”
    时婆蹉王优陀延那闻尊者宾头卢所说，欢喜随喜，从座起去。

（一一六六）

    如是我闻。一时佛住拘睒弥国瞿师罗园。
    尔时世尊告诸比丘：“有手故知有取舍，有足故知有往来，有关节故知有屈伸，有腹故知有饥渴。如是比丘，有眼故眼触因缘生受，内觉若苦、若乐、不苦不乐。耳、鼻、舌、身、意，亦复如是。
    “诸比丘，若无手则不知取舍，若无足则不知往来，若无关节则不知有屈伸，若无腹则不知有饥渴。如是诸比丘，若无眼则无眼触因缘生受，内觉若苦、若乐、不苦不乐。耳、鼻、舌、身、意，亦复如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一六七）

    如是我闻。一时佛住拘睒弥国瞿师罗园。
    尔时世尊告诸比丘：“过去世时，有河中草，有龟于中住止。时有野干饥行觅食，遥见龟虫，疾来捉取。龟虫见来，即便藏六。野干守伺，冀出头足，欲取食之。久守龟虫，永不出头，亦不出足，野干饥乏，瞋恚而去。
    “诸比丘，汝等今日亦复如是，知魔波旬常伺汝便，冀汝眼著于色、耳闻声、鼻嗅香、舌尝味、身觉触、意念法，欲令出生染著六境。是故比丘，汝等今日常当执持眼律仪住，执持眼根律仪住，恶魔波旬不得其便，随出随缘。耳、鼻、舌、身、意，亦复如是。于其六根若出若缘，不得其便，犹如龟虫，野干不得其便。”
    尔时世尊即说偈言：

“龟虫畏野干，藏六于壳内，
比丘善摄心，密藏诸觉想，
不依不怖彼，覆心勿言说。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一六八）

    如是我闻。一时佛住拘睒弥国瞿师罗园。
    尔时世尊告诸比丘：“譬如[麦+广]麦，着四衢道头，有六壮夫执杖共打，须臾尘碎，有第七人执杖重打。诸比丘，于意云何？如[麦+广]麦聚，六人共打，七人重打，当极碎不？”
    诸比丘白佛言：“如是，世尊。”
    佛告诸比丘：“如是愚痴士夫，六触入处之所捶打。何等为六？谓眼触入处常所捶打，耳、鼻、舌、身、意触入处常所捶打。彼愚痴士夫为六触入处之所捶打，犹复念求当来世有，如第七人重打令碎。比丘，若言是我，是则动摇；言是我所，是则动摇；未来当有，是则动摇；未来当无，是则动摇；当复有色，是则动摇；当复无色，是则动摇；当复有想，是则动摇；当复无想，是则动摇；当复非有想非无想，是则动摇。动摇故病，动摇故痈，动摇故刺，动摇故著。正观察动摇故苦者，得不动摇心，多修习住，系念正知。如动摇，如是思量、虚诳、有行。因爱言我，是则为爱；言我所，是则为爱；言当来有，是则为爱；言当来无，是则为爱；当有色，是则为爱；当无色，是则为爱；当有想，是则为爱；当无想，是则为爱；当非想非非想，是则为爱。爱故为病，爱故为痈，爱故为刺。若善思观察爱生苦者，当多住离爱心，正念正知。
    “诸比丘，过去世时，阿修罗兴军与帝释斗。时天帝释告三十三天：‘今日诸天、阿修罗共战，若诸天胜，阿修罗不如者，当生执阿修罗，缚以五系，送还天宫。’阿修罗语其众言：‘今阿修罗军与诸天战，若阿修罗胜，诸天不如者，当生执帝释，缚以五系，还归阿修罗宫。’当其战诤，诸天得胜，阿修罗不如。时三十三天生执毗摩质多罗阿修罗王，缚以五系，还归天宫。
    “尔时毗摩质多罗阿修罗王，身被五系，置于正法殿上，以种种天五欲乐而娱乐之。毗摩质多罗阿修罗王作是念：‘唯阿修罗贤善聪慧，诸天虽善，我今且当还归阿修罗宫。’作是念时，即自见身被五系缚，诸天五欲自然化没。毗摩质多罗阿修罗王复作是念：‘诸天贤善，智慧明彻，诸阿修罗虽善，我今且当住此天宫。’作是念时，即自见身五缚得解，诸天五欲自然还出。
    “毗摩质多罗阿修罗王乃至有如是微细之缚。魔波旬缚，转细于是。心动摇时，魔即随缚。心不动摇，魔即随解。是故诸比丘，多住不动摇心，正念正知，应当学！”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一六九）

    如是我闻。一时佛住拘睒弥国瞿师罗园。
    尔时世尊告诸比丘：“若有比丘、比丘尼，眼、色、识因缘生，若欲、若贪、若昵、若念、若决定著处，于彼诸心善自防护。所以者何？此等皆是恐畏之道，有碍有难，此恶人所依，非善人所依，是故应自防护。耳、鼻、舌、身、意，亦复如是。譬如田夫，有好田苗，其守田者懒惰放逸，栏牛啖食。愚痴凡夫亦复如是，六触入处，乃至放逸，亦复如是。若好田苗，其守田者心不放逸，栏牛不食，设复入田，尽驱令出。所谓若心、若意、若识，多闻圣弟子于五欲功德善自摄护，尽心令灭。若好田苗，其守护田者不自放逸，栏牛入境，左手牵鼻，右手执杖，遍身捶打，驱出其田。诸比丘，于意云何？彼牛遭苦痛已，从村至宅，从宅至村，复当如前过食田苗不？”
    答言：“不也，世尊。所以者何？忆先入田遭捶杖苦故。”
    “如是比丘，若心、若意、若识，多闻圣弟子于六触入处，极生厌离、恐怖，内心安住，制令一意。
    “诸比丘，过去世时，有王闻未曾有好弹琴声，极生爱乐，耽湎染著，问诸大臣：‘此何等声，甚可爱乐？’大臣答言：‘此是琴声。’王语大臣：‘取彼声来。’大臣受教，即往取琴来，白言：‘大王，此是琴作好声者。’王语大臣：‘我不用琴，取其先闻可爱乐声来。’大臣答言：‘如此之琴，有众多种具，谓有柄、有槽、有丽、有弦、有技巧方便人弹之，得众具因缘，乃成音声，非不得众具而有音声。前所闻声，久已过去，转亦尽灭，不可持来。’尔时大王作如是言：‘咄！何用此虚伪物为？世间琴者是虚伪物，而令世人耽湎染著。汝今持去，片片析破，弃于十方！’大臣受教，析为百分，弃于处处。
    “如是比丘，若色、受、想、思、欲，知此诸法无常、有为、心因缘生，而便说言：‘是我、我所，彼于异时一切悉无。’诸比丘，应作如是平等正智，如实观察。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一七○）

    如是我闻。一时佛住拘睒弥国瞿师罗园。
    尔时世尊告诸比丘：“如癞病人，四体疮坏，入茅荻中，为诸刺叶针刺所伤，倍增苦痛。如是愚痴凡夫，六触入处受诸苦痛，亦复如是。如彼癞人为草叶针刺所伤，脓血流出。如是愚痴凡夫，其性弊暴，六触入处所触，则起瞋恚，恶声流出，如彼癞人。所以者何？愚痴无闻凡夫，心如癞疮。
    “我今当说律仪、不律仪。云何律仪？云何不律仪？愚痴无闻凡夫眼见色已，于可念色而起贪著，不可念色而起瞋恚，于彼次第随生众多觉想相续，不见过患；复见过患，不能除灭。耳、鼻、舌、身、意，亦复如是。比丘，是名不律仪。云何律仪？多闻圣弟子若眼见色，于可念色不起欲想，不可念色不起恚想，次第不起众多觉想相续住，见色过患；见过患已，能舍离。耳、鼻、舌、身、意，亦复如是。是名律仪。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一七一）

    如是我闻。一时佛住拘睒弥国瞿师罗园。
    尔时世尊告诸比丘：“譬如士夫游空宅中，得六种众生：一者得狗，即执其狗，系着一处；次得其鸟，次得毒蛇，次得野干，次得失收摩罗，次得猕猴，得斯众生，悉缚一处。其狗者乐欲入村，其鸟者常欲飞空，其蛇者常欲入穴，其野干者乐向冢间，失收摩罗者长欲入海，猕猴者欲入山林。此六众生悉系一处，所乐不同，各各嗜欲到所安处，各各不相乐于他处，而系缚故，各用其力向所乐方，而不能脱。
    “如是六根种种境界，各各自求所乐境界，不乐余境界。眼根常求可爱之色，不可意色则生其厌。耳根常求可意之声，不可意声则生其厌。鼻根常求可意之香，不可意香则生其厌。舌根常求可意之味，不可意味则生其厌。身根常求可意之触，不可意触则生其厌。意根常求可意之法，不可意法则生其厌。此六种根，种种行处，种种境界，各各不求异根境界。此六种根，其有力者，堪能自在随觉境界。如彼士夫系六众生于其坚柱，正出用力，随意而去，往反疲极，以绳系故，终依于柱。
    “诸比丘，我说此譬，欲为汝等显示其义。六众生者，譬犹六根。坚柱者，譬身念处。若善修习身念处，有念、不念色，见可爱色则不生著，不可爱色则不生厌。耳声、鼻香、舌味、身触、意法，于可意法则不求欲，不可意法则不生厌。是故比丘，当勤修习，多住身念处。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一七二）

    如是我闻。一时佛住拘睒弥国瞿师罗园。
    尔时世尊告诸比丘：“譬如有四蚖蛇，凶恶毒虐，盛一箧中。时有士夫聪明不愚，有智慧，求乐厌苦，求生厌死。时有一士夫语向士夫言：‘汝今取此箧盛毒蛇，摩拭洗浴，恩亲养食，出内以时。若四毒蛇脱有恼者，或能杀汝，或令近死，汝当防护。’尔时士夫恐怖驰走，忽有五怨，拔刀随逐，要求欲杀，汝当防护。尔时士夫畏四毒蛇及五拔刀怨，驱驰而走。人复语言：‘士夫，内有六贼，随逐伺汝，得便当杀，汝当防护。’尔时士夫畏四毒蛇、五拔刀怨及内六贼，恐怖驰走，还入空村。见彼空舍，危朽腐毁，有诸恶物，捉皆危脆，无有坚固。人复语言：‘士夫，是空聚落当有群贼来，必掩害汝。’尔时士夫畏四毒蛇、五拔刀贼、内六恶贼、空村群贼，而复驰走。忽尔道路临一大河，其水浚急，但见此岸有诸怖畏，而见彼岸安隐快乐，清凉无畏。无桥船可渡得至彼岸，作是思惟：‘我取诸草木，缚束成筏，手足方便，渡至彼岸。’作是念已，即拾草木，依于岸傍，缚束成筏，手足方便，截流横渡。如是士夫免四毒蛇、五拔刀怨、六内恶贼，复得脱于空村群贼，渡于浚流，离于此岸种种怖畏，得至彼岸，安隐快乐。
    “我说此譬，当解其义。比丘！箧者，譬此身色粗四大、四大所造精血之体，秽食长养，沐浴衣服，无常变坏危脆之法。毒蛇者，譬四大，地界、水界、火界、风界。地界若诤，能令身死，及以近死。水、火、风诤，亦复如是。五拔刀怨者，譬五受阴。六内贼者，譬六爱喜。空村者，譬六内入。善男子观察眼入处，是无常变坏；执持眼者，亦是无常虚伪之法。耳、鼻、舌、身、意入处，亦复如是。空村群贼者，譬外六入处。眼为可意、不可意色所害，耳声、鼻香、舌味、身触、意为可意、不可意法所害。浚流者，譬四流，欲流、有流、见流、无明流。河者，譬三爱，欲爱、色爱、无色爱。此岸多恐怖者，譬有身。彼岸清凉安乐者，譬无余涅槃。筏者，譬八正道。手足方便截流渡者，譬精进勇猛。到彼岸婆罗门住处者，譬如来、应、等正觉。
    “如是比丘，大师慈悲安慰弟子，为其所作，我今已作。汝今亦当作其所作，于空闲树下，房舍清净，敷草为座，露地冢间，远离边坐，精勤禅思，慎莫放逸，令后悔恨！此则是我教授之法。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一七三）

    如是我闻。一时佛住拘睒弥国瞿师罗园。
    尔时世尊告诸比丘：“多闻圣弟子于一切苦法，集、灭、味、患、离如实知见，见五欲犹如火坑。如是观察五欲已，于五欲贪、欲爱、欲念、欲著，不永覆心。知其欲心行处、住处，而自防闭。行处、住处逆防闭已，随其行处、住处，世间贪忧、恶不善法，不漏其心。
    “云何名为多闻圣弟子于一切苦法，集、灭、味、患、离如实知见？多闻圣弟子于此苦圣谛如实知，此苦集、此苦灭、此苦灭道迹圣谛如实知，是名多闻圣弟子于一切苦法，集、灭、味、患、离如实知见。
    “云何多闻圣弟子见五欲如火坑，乃至世间贪忧、恶不善法，不永覆心？譬如近一聚落，边有深坑，满中盛火，无有烟焰。时有士夫不愚不痴，聪明黠慧，乐乐厌苦，乐生恶死。彼作是念：‘此有火坑，满中盛火，我若堕中，必死无疑。’于彼生远、思远、欲远。如是多闻圣弟子见五欲如火坑，乃至世间贪忧、恶不善法，不永覆心。若行处、住处，逆防逆知，乃至世间贪忧、恶不善法，不漏其心。
    “譬如聚落边有柰林，多诸棘刺。时有士夫入于林中，有所营作，入林中已，前后、左右、上下尽有棘刺。尔时士夫正念而行，正念来去，正念明目，正念端视，正念屈身。所以者何？莫令利刺伤坏身故。多闻圣弟子亦复如是，若依聚落城邑而住，晨朝着衣持钵，入村乞食，善护其身，善执其心，正念安住，正念而行，正念明目，正念观察。所以者何？莫令利刺伤圣法律。云何利刺伤圣法律？谓可意爱念之色，是名利刺伤圣法律。云何是可意爱念之色伤圣法律？谓五欲功德，眼识色，生爱念，长养欲乐；耳识声，鼻识香，舌识味，身识触，生爱念，长养欲乐，是名可爱念色伤圣法律。是名多闻圣弟子所行处、所住处，逆防逆知，乃至不令世间贪忧、不善法，以漏其心。或时多闻圣弟子失于正念，生恶不善觉，长养欲，长养恚，长养痴。是钝根多闻圣弟子虽起集灭，以欲覆心，譬如铁丸烧令极热，以少水洒，寻即干消，如是多闻圣弟子钝根生念，寻灭如是。
    “多闻圣弟子如是行，如是住。若王、大臣、若亲，往诣其所，请以俸禄，语言：‘男子，何用剃发，执持瓦器，身着袈裟，家家乞食为？不如安慰，服五欲乐，行施作福。’云何比丘，多闻圣弟子，国王、大臣、诸亲檀越请以俸禄，彼当还戒退减以不？”
    答曰：“不也。所以者何？多闻圣弟子于一切苦法，集、灭、味、患、离如实知见故，见火坑譬五欲，乃至世间贪忧、恶不善法不永覆心，行处、住处逆防逆知，乃至世间贪忧、恶不善法不漏其心。若复为国王、大臣、亲族请以俸禄，还戒退减，无有是处。”
    佛告诸比丘：“善哉善哉！彼多闻圣弟子，其心长夜临趣、流注、浚输，向于远离，向于离欲，而于涅槃寂静舍离，乐于涅槃，于有漏处，寂灭清凉。若为国王、长者、亲族所请，还戒退减者，无有是处，余得大苦。譬如恒河，长夜临趣、流注、浚输东方，多众断截，欲令临趣、流注、浚输西方，宁能得不？”
    答言：“不能，世尊。所以者何？恒水长夜流注东方，欲令西流，未而可得，彼诸大众徒辛苦耳。”
    “如是多闻圣弟子，长夜临趣、流注、浚输，向于远离，乃至欲令退减，无有是处，徒辛苦耳。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一七四）

    如是我闻。一时佛住阿毗阇恒水边。
    时有比丘来诣佛所，稽首佛足，退住一面，白佛言：“善哉世尊！为我说法。我闻法已，独一静处，专精思惟，不放逸住。所以族姓子剃除须发，正信非家，出家学道，于上增修梵行，见法自知作证：我生已尽，梵行已立，所作已作，自知不受后有。”
    尔时世尊观察恒水，见恒水中有一大树随流而下，语彼比丘：“汝见此恒水中大树流不？”
    答言：“已见，世尊。”
    佛告比丘：“此大树不着此岸，不着彼岸，不沉水底，不阂洲渚，不入洄澓，人亦不取，非人不取，又不腐败，当随水流顺趣、流注、浚输，至大海不？”
    比丘白佛：“如是，世尊。”
    佛言：“比丘亦复如是，亦不着此岸，不着彼岸，不沉水底，不阂洲渚，不入洄澓，人亦不取，非人不取，又不腐败，当随水流临趣、流注、浚输涅槃。”
    比丘白佛：“云何此岸？云何彼岸？云何沉没？云何洲渚？云何洄澓？云何人取？云何非人取？云何腐败？善哉世尊！为我广说。我闻法已，当独一静处，专精思惟，不放逸住，乃至自知不受后有。”
    佛告比丘：“此岸者，谓内六入处。彼岸者，谓六外入处。人取者，犹如有一习近俗人及出家者，若喜、若忧、若苦、若乐，彼彼所作，悉与共同，始终相随，是名人取。非人取者，犹如有人愿修梵行，我今持戒苦行，修诸梵行，当生在处在处天上，是非人取。洄澓者，犹如有一还戒退转。腐败者，犯戒行恶不善法，腐败寡闻，犹莠稗、吹贝之声，非沙门为沙门像，非梵行为梵行像。如是比丘，是名不着此彼岸，乃至浚输涅槃。”
    时彼比丘闻佛所说，欢喜随喜，作礼而去。时彼比丘独一静处，思惟佛所说水流大树经教，乃至自知不受后有，得阿罗汉。
    时有牧牛人名难屠，去佛不远，执杖牧牛。比丘去已，诣世尊所，稽首礼足，于一面住，白佛言：“世尊，我今堪能不着此岸，不着彼岸，不沉没，不阂洲渚，非人所取，不非人取，不入洄澓，亦不腐败，我得于世尊正法律中出家修梵行不？”
    佛告牧牛者：“汝送牛还主不？”
    牧牛者言：“诸牛中悉有犊牛，自能还归，不须送也，但当听我出家学道。”
    佛告牧牛者：“牛虽能还家，汝今已受人衣食，要当还报其家主。”
    时牧牛者闻佛教已，欢喜随喜，作礼而去。
    时尊者舍利弗在此会中，牧牛者去不久，白佛言：“世尊，难屠牧牛者求欲出家，世尊何故遣还归家？”
    佛告舍利弗：“难屠牧牛者若还住家受五欲者，无有是处。牛付主人已，辄自当还，于此法律出家学道，净修梵行，乃至自知不受后有，得阿罗汉。”
    时难屠牧牛者以牛付主人已，还至佛所，稽首礼足，退住一面，白佛言：“世尊，牛已付主，听我于正法律出家学道！”
    佛告难屠牧牛者：“汝得于此法律出家、受具足，得比丘分。”
    出家已，思惟所以族姓子剃除须发，着袈裟衣，正信非家，出家学道，增修梵行，乃至自知不受后有，成阿罗汉。

（一一七五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘独处坐禅，作是思惟：“比丘云何知、云何见，得见清净？”作是念已，诣诸比丘，语诸比丘言：“诸尊！比丘云何知、云何见，令见清净？”
    比丘答言：“尊者，于六触入处集、灭、味、患、离如实正知，比丘作如是知、如是见者，得见清净。”
    是比丘闻彼比丘记说，心不欢喜。复诣余比丘所，问彼比丘言：“诸尊！比丘云何知、云何见，得见清净？”
    彼比丘答言：“于六界集、灭、味、患、离如实正知，如是比丘如是知、如是见，得见清净。”
    时比丘闻其记说，心亦不喜。复诣余比丘，作是问言：“比丘云何知、云何见，得见清净？”
    彼比丘答言：“于五受阴观察，如病、如痈、如刺、如杀，无常、苦、空、非我，作如是知、如是见，得见清净。”
    是比丘闻诸比丘记说，心亦不喜，往诣佛所，稽首礼足，退坐一面，白佛言：“世尊，我独静思惟：‘比丘云何知、云何见，得见清净？’作是念已，诣诸比丘，三处所说，具白世尊。我闻彼说，心不欢喜，来诣世尊，故以此义请问世尊：比丘云何知、云何见，得见清净？”
    佛告比丘：“过去世时，有一士夫，未曾见紧兽。往诣曾见紧兽者，问曾见紧兽士夫言：‘汝知紧兽不？’答言：‘知。’复问：‘其状云何？’答言：‘其色黑如火烧柱。’当彼见时，紧兽黑色如火烧柱。时彼士夫闻紧兽黑色如火烧柱，不大欢喜，复更诣一曾见紧兽士夫，复问彼言：‘汝知紧兽不？’彼答言：‘知。’复问：‘其状云何？’彼曾见紧兽士夫答言：‘其色赤而开敷，状似肉段。’彼人见时，紧兽开敷，实似肉段。是士夫闻彼所说，犹复不喜，复更诣余曾见紧兽士夫，问：‘汝知紧兽不？’答言：‘知。’复问：‘其状云何？’答言：‘毶毶下垂，如尸利沙果。’是人闻已，心复不喜，复行问余知紧兽者，问：‘汝知紧兽不？’彼答言：‘知。’又问：‘其状云何？’彼复答言：‘其叶青，其叶滑，其叶长广，如尼拘娄陀树。’如彼士夫问其紧兽，闻则不喜，处处更求，而彼诸人见紧兽者，随时所见，而为记说，是故不同。如是诸比丘，若于独处，专精思惟，不放逸住，所因思惟法不起诸漏，心得解脱，随彼所见而为记说。
    “汝今复听我说譬，其智者以譬喻得解。譬如有边国王，善治城壁，门下坚固，交道平正。于四城门，置四守护，悉皆聪慧，知其来去。当其城中，有四交道，安置床榻，城主坐上。若东方使来，问守门者：‘城主何在？’彼即答言：‘主在城中四交道头，床上而坐。’彼使闻已，往诣城主，受其教令，复道而还。南、西、北方远使来人，问守门者：‘城主何在？’彼亦答言：‘在其城中四交道头。’彼使闻已，悉诣城主，受其教令，各还本处。”
    佛告比丘：“我说斯譬，今当说义。所谓城者，以譬人身粗色，如《箧毒蛇譬经》说。善治城壁者，谓之正见。交道平正者，谓内六入处。四门者，谓四识住。四守门者，谓四念处。城主者，谓识受阴。使者，谓正观。如实言者，谓四真谛。复道还者，以八圣道。”
    佛告比丘：“若大师为弟子所作，我今已作，以哀愍故。”如《箧毒蛇譬经》说。
    尔时比丘闻佛说已，专精思惟，不放逸住，增修梵行，乃至不受后有，成阿罗汉。

（一一七六）

    如是我闻。一时世尊释氏人间游行，至迦毗罗卫国，住尼拘娄陀园。
    尔时迦毗罗卫释氏作新讲堂，未有诸沙门、婆罗门、释迦年少及诸人民在中住者。闻世尊来至释氏迦毗罗卫人间游行，住尼拘娄陀园，论苦乐义。“此堂新成，未有住者，可请世尊与诸大众于中供养，得功德福报，长夜安隐，然后我等当随受用。”作是议已，悉共出城，诣世尊所，稽首礼足，退坐一面。
    尔时世尊为诸释氏演说要法，示教照喜已，默然而住。
    时诸释氏从座起，整衣服，为佛作礼，右膝着地，合掌白佛言：“世尊，我等释氏新作讲堂，未有住者，今请世尊及诸大众于中供养，得功德福利，长夜安隐，然后我等当随受用。”
    尔时世尊默然受请。
    时诸释氏知世尊受请已，稽首佛足，各还其所。即以其日，以车舆经纪，运其众具，庄严新堂，敷置床座，软草布地，备香油灯。众事办已，往诣佛所，稽首白佛言：“众事办已，唯圣知时！”
    尔时世尊与诸大众前后围绕，至新堂外，洗足已，然后上堂，于中柱下，东向而坐。时诸比丘亦洗足已，随入讲堂，于世尊后，西面东向，次第而坐。时诸释氏即于东面，西向而坐。
    尔时世尊为诸释氏广说法要，示教照喜已，语诸释氏：“瞿昙！初夜已过，于时可还迦毗罗越。”
    时诸释氏闻佛所说，欢喜随喜，作礼而去。
    尔时世尊知释氏去已，告大目揵连：“汝当为诸比丘说法，我今背疾，当自消息。”
    时大目揵连默然受教。
    尔时世尊，四亵郁多罗僧安置胁下，卷襞僧伽梨，置于头下，右胁而卧，屈膝累足，系念明相，作起想思惟。
    尔时大目揵连语诸比丘：“佛所说法，初、中、后善，善义善味，纯一满净，清白梵行。我今当说漏、不漏法，汝等谛听。
    “云何为漏法？愚痴无闻凡夫，眼见色已，于可念色而起乐著，不可念色而起憎恶，不住身念处，于心解脱、慧解脱无少分智，而起种种恶不善法，不无余灭，不无余永尽。耳、鼻、舌、身、意，亦复如是。比丘如是者，天魔波旬往诣其所，伺其虚短，于其眼色，即得其阙；耳声、鼻香、舌味、身触、意法，亦复如是，即得其阙。譬如枯干草积，四方火起，寻时即烧。如是比丘于其眼色，天魔波旬即得其阙，如是比丘不胜于色。于耳声、鼻香、舌味、身触、意法，受制于法，不能胜法。不胜色，不胜声、香、味、触、法，亦复不胜恶不善法、诸烦恼炽然苦报，及未来世生老病死。诸尊！我从世尊亲受于此诸有漏法，是名《有漏法经》。
    “云何《无漏法经》？多闻圣弟子眼见色，于可念色不起乐著，不可念色不起憎恶，系念而住，无量心解脱、慧解脱如实知，于彼已起恶不善法无余灭尽。耳、鼻、舌、身、意，亦复如是。如是像类比丘，弊魔波旬往诣其所，于其眼色伺求其短，不得其短；于耳声、鼻香、舌味、身触、意法伺求其短，不得其短。譬如楼阁，墙壁牢固，窗户重闭，泥涂厚密，四方火起，不能烧燃。斯等比丘亦复如是，弊魔波旬往诣其所，伺求其短，不得其短。如是比丘能胜彼色，不为彼色之所胜也。胜于声、香、味、触、法，不为彼法之所胜也。若胜于色，胜于声、香、味、触、法已，亦复胜于恶不善法、烦恼炽然苦报，及未来世生老病死。我亲从世尊面受此法，是名《无漏法经》。”
    尔时世尊知大目揵连说法竟，起正身坐，系念在前，告大目揵连：“善哉善哉！目揵连，为人说此经法，多所饶益，多所过度，长夜安乐诸天世人。”
    尔时世尊告诸比丘：“汝当受持《漏无漏法经》，广为人说。所以者何？义具足故，法具足故，梵行具足故，开发神通，正向涅槃。乃至信心善男子，在家出家，当受持读诵，广为人说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一一七七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“譬如灰河，南岸极热，多诸利刺，在于暗处。众多罪人在于河中，随流漂没。中有一人，不愚不痴，聪明黠慧，乐乐厌苦，乐生厌死，作如是念：‘我今何缘在此灰河，南岸极热，又多利刺，在暗冥处，随流漂没？我当以手足方便，逆流而上。’渐见小明，其人默念：‘今已疾殆，见此小明！’复运手足，勤加方便，遂见平地。即住于彼，观察四方，见大石山，不断不坏，亦不穿穴，即登而上。复见清凉八分之水，所谓冷、美、轻、软、香、净、饮时不噎、咽中不碍，饮已安身，即入其中，若浴若饮，离诸恼热。然后复进登大山，上见七种花，谓优钵罗花、钵昙摩花、拘牟头花、分陀利花、修揵提花、弥离头揵提花、阿提目多花。闻花香已，复上石山，见四层阶堂，即坐其上。见五柱帐，即入其中，敛身正坐，种种枕褥，散花遍布，庄严妙好，而于其中自恣坐卧，凉风四凑，令身安隐。坐高临下，高声唱言：‘灰河众生，诸贤正士！如彼灰河，南岸极热，多诸利刺，其处暗冥，求出于彼！’河中有闻声者，寻声问言：‘何方得出？从何处出？’其中有言：‘汝何须问何处得出？彼唤声者亦自不知不见从何而出，彼亦当复在此灰河，南岸极热，多诸利刺，于暗冥中随流来下，用问彼为？’
    “如是比丘，我说此譬，今当说义。灰者，谓三恶不善觉。云何三？欲觉、恚觉、害觉。河者，谓三爱，欲爱、色爱、无色爱。南岸极热者，谓内、外六入处。多诸利刺者，谓五欲功德。暗冥处者，谓无明障闭慧眼。众多人者，谓愚痴凡夫。流，谓生死河。中有一人不愚不痴者，谓菩萨摩诃萨。手足方便，逆流上者，谓精勤修学。微见小明者，谓得法忍。得平地者，谓持戒。观四方者，谓见四真谛。大石山者，谓正见。八分水者，谓八圣道。七种花者，谓七觉分。四层堂者，谓四如意足。五柱帐者，谓信等五根。正身坐者，谓无余涅槃。散花遍布者，谓诸禅、解脱、三昧、正受。自恣坐卧者，谓如来、应、等正觉。四方风吹者，谓四增心见法安乐住。举声唱唤者，谓转法轮。彼有人问诸贤正士何处去、何处出者，谓舍利弗、目揵连等诸贤圣比丘。于中有言：‘汝何所问，彼亦不知不见有所出处，彼亦当复于此灰河，南岸极热，多诸利刺，于暗冥处随流来下’者，谓六师等诸邪见辈，所谓富兰那迦叶、末伽梨瞿舍梨子、散阇耶毗罗胝子、阿耆多枳舍钦婆罗、伽拘罗迦毡延、尼揵连陀阇提弗多罗，及余邪见辈。如是比丘，大师为诸声闻所作，我今已作。汝今当作所作，如前《箧毒蛇》说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。


杂阿含经卷第四十四

（一一七八）

    如是我闻。一时佛住弥絺罗国庵罗园中。
    时有婆四吒婆罗门尼，有六子相续命终，念子发狂，裸形被发，随路而走，至弥絺罗庵罗园中。
    尔时世尊无量大众围绕说法。婆四吒婆罗门尼遥见世尊，见已即得本心，惭愧羞耻，敛身蹲坐。
    尔时世尊告尊者阿难：“取汝郁多罗僧，与彼婆四吒婆罗门尼，令着听法。”
    尊者阿难即受佛教，取衣令着。时婆罗门尼得衣着已，至于佛前，稽首礼佛，退坐一面。
    尔时世尊为其说法，示教照喜已，如佛常法，说法次第，乃至信心清净，受三自归。闻佛所说，欢喜随喜，作礼而去。
    彼婆四吒优婆夷，于后时第七子忽复命终，彼优婆夷都不啼哭、忧悲恼苦。
    时婆四吒优婆夷夫说偈，而告婆四吒优婆夷言：

“先诸子命终，念子生忧苦，
昼夜不饮食，乃至发狂乱。
今丧第七子，而不生忧苦？”

    婆四吒优婆夷即复说偈，答其夫言：

“儿孙有千数，因缘和合生，
长夜迁过去，我与君亦然。
子孙及宗族，其数无限量，
彼彼所生处，更互相残食。
若知生恶者，何足生忧苦！
我已知出离，生死存亡相，
不复生忧苦，入佛正教故。”

    时婆四吒优婆夷夫说偈叹曰：

“未曾所闻法，而今闻汝说，
何处闻说法，不念子忧悲？”

    婆四吒优婆夷说偈答言：

“今日等正觉，在弥絺罗国，
庵罗树园中，永离一切苦。
演说一切苦，苦集苦寂灭，
贤圣八正道，安隐趣涅槃。
则是我大师，深乐其正教，
我已知正法，能开子忧苦。”

    其夫婆罗门复说偈言：

“我今亦当往，弥絺庵罗园，
彼世尊亦当，开我子忧苦。”

    优婆夷复说偈言：

“当观等正觉，柔软金色身，
不调者能调，广度海流人。”

    尔时婆罗门即严驾，乘于马车，诣弥絺罗庵罗园，遥见世尊，转增信乐，诣大师前。
    彼时大师即为说偈，开其法眼，苦、集、灭、道，正向涅槃。
    彼即见法，成无间等。既知法已，请求出家。时婆罗门即得出家，独静思惟，乃至得阿罗汉。世尊记说，于第三夜逮得三明。得三明已，佛即告之，命遣御者，乘车还家，告婆四吒优婆夷，令发随喜，语言：“婆罗门往见世尊，得净信心，奉事大师，即为说法，为开法眼，见苦圣谛、苦集、苦灭、贤圣八道，安趣涅槃，成无间等。既知法已，即求出家。世尊记说，于第三夜，具足三明。”
    时彼御者奉教疾还。时婆四吒优婆夷遥见御者空车而还，即遥问言：“婆罗门为见佛不？佛为说法，开示法眼，见圣谛不？”
    御者白言：“婆罗门已见世尊，得净信心，奉事大师，为开法眼，说四圣谛，成无间等。既知法已，即求出家，专精思惟。世尊记说，于第三夜，具足三明。”
    时优婆夷心即随喜，语御者言：“车马属汝，加复赐汝金钱一千。以汝传信，言婆罗门宿阇谛，已得三明，令我欢喜故。”
    御者白言：“我今何用车马、金钱为？车马、金钱还优婆夷，我今当还婆罗门所，随彼出家。”
    优婆夷言：“汝意如此，便可速还。不久亦当如彼所得，具足三明，随后出家。”
    御者白言：“如是优婆夷，如彼出家，我亦当然。”
    优婆夷言：“汝父出家，汝随出家，我今不久亦当随去。如空野大龙，乘虚而游，其余诸龙、龙子、龙女，悉皆随去。我亦如是，执持衣钵，易养易满。”
    御者白言：“优婆夷，若如是者，所愿必果。不久当见优婆夷少欲知足，执持衣钵，人所弃者，乞受而食，剃发染衣，于阴、界、入断除爱欲，离贪系缚，尽诸有漏。”
    彼婆罗门及其御者、婆四吒优婆夷、优婆夷女孙陀槃梨，悉皆出家，究竟苦边。

（一一七九）

    如是我闻。一时佛住毗舍离国大林精舍。
    时有毗梨耶婆罗豆婆遮婆罗门，晨朝买牛，未偿其价，即日失牛，六日不见。时婆罗门为觅牛故，至大林精舍，遥见世尊坐一树下，仪容挺特，诸根清净，其心寂默，成就止观，其身金色，光明焰照。见已即诣其前，而说偈言：

“云何无所求，空寂在于此，
独一处空闲，而得心所乐？”

    尔时世尊说偈答言：

“若失若复得，于我心不乱。
婆罗门当知，莫谓彼如我，
心计于得失，其心不自在。”

    时婆罗门复说偈言：

“最胜梵志处，如比丘所说，
我今当自说，真实语谛听。
沙门今定非，晨朝失牛者，
六日求不得，是故安乐住。
沙门今定非，种植胡麻田，
虑其草荒没，是故安乐住。
沙门今定非，种稻田乏水，
畏叶枯便死，是故安乐住。
沙门今定无，寡女有七人，
悉养孤遗子，是故安乐住。
沙门今定无，七不爱念子，
放逸多负债，是故安乐住。
沙门今定无，债主守其门，
求索长息财，是故安乐住。
沙门今定无，七领重卧具，
忧勤择诸虫，是故安乐住。
沙门今定无，赤眼黄发妇，
昼夜闻恶声，是故安乐住。
沙门今定无，空仓群鼠戏，
常忧其羸乏，是故安乐住。”

    尔时世尊说偈答言：

“我今日定不，晨朝失其牛，
六日求不得，是故安乐住。
我今日定无，种植胡麻田，
常恐其荒没，是故安乐住。
我今日定无，种稻田乏水，
畏叶便枯死，是故安乐住。
我今日定无，寡女有七人，
悉养孤遗子，是故安乐住。
我今日定无，七不爱念子，
放逸多负债，是故安乐住。
我今日定无，债主守其门，
求索长息财，是故安乐住。
我今日定无，七领重卧具，
忧勤择诸虫，是故安乐住。
我今日定无，黄头赤眼妇，
昼夜闻恶声，是故安乐住。
我今日定无，空仓群鼠戏，
常忧其羸乏，是故安乐住。
不舍念不念，众生安乐住，
断欲离恩爱，而得安乐住。”

    尔时世尊为精进婆罗豆婆遮婆罗门种种说法，示教照喜，如佛常法，次第说法，布施、持戒。乃至于正法中，心得无畏，即从座起，合掌白佛：“我今得于正法律出家学道，成比丘分，修梵行不？”
    佛告婆罗门：“汝今可得于正法律出家、受具足，修诸梵行。”乃至得阿罗汉，心善解脱。
    尔时精进婆罗豆婆遮婆罗门得阿罗汉，缘自觉知，得解脱乐，而说偈言：

“我今甚欣乐，大仙法之上，
得离贪欲乐，不空见于佛。”

（一一八○）

    如是我闻。一时佛住娑罗树林婆罗门聚落。
    尔时世尊晨朝着衣持钵，入娑罗林婆罗门聚落乞食，有非时云起。尔时世尊作是念：“我今当往婆罗门聚落，婆罗门长者大会堂中。”作是念已，即往向彼大会堂所。
    时婆罗门长者悉集堂上，遥见世尊，共相谓言：“彼剃头沙门，竟知何法？”
    尔时世尊告彼婆罗门聚落婆罗门长者言：“诸婆罗门有知法者，有不知者。刹利长者亦有知法者，有不知法者。”
    尔时世尊即说偈言：

“非朋欲胜朋，王不伏难伏，
妻不求胜夫，无子不恭父。
无会无智者，无智不法言；
贪恚痴悉断，是则名智者。”

    时彼婆罗门长者白佛言：“善士，瞿昙！善士夫可入此堂，就座而坐。”世尊坐已，即白佛言：“瞿昙说法，我等乐听！”
    尔时世尊为彼大会婆罗门长者种种说法，示教照喜已，复说偈言：

“愚智群聚会，非说孰知明？
能说寂静道，因说智则辩。
说者显正法，建立大仙幢，
善说为仙幢，法为罗汉幢。”

    尔时世尊为婆罗门聚落婆罗门长者，建立正法，示教照喜。示教照喜已，从座起而去。

（一一八一）

    如是我闻。一时佛在拘萨罗人间游行，至浮梨聚落，住天作婆罗门庵罗园中。尊者优波摩为侍者。
    尔时世尊患背痛，告尊者优波摩：“汝举衣钵已，往至天作婆罗门舍。”
    时天作婆罗门处于中堂，令梳头者理剃须发，见尊者优波摩于门外住，见已即说偈言：

“何等剃须发，身着僧迦梨，
住于彼门外，为欲何所求？”

    尊者优波摩说偈答言：

“罗汉世善逝，所患背风疾，
颇有安乐水，疗牟尼疾不？”

    时天作婆罗门以满钵酥、一瓶油、一瓶石蜜，使人担持，并持暖水，随尊者优波摩，诣世尊所，以涂其体，暖水洗之，酥蜜作饮，世尊背疾即得安隐。
    时天作婆罗门晨朝早起，往诣佛所，稽首礼足，退坐一面，而说偈言：

“何言婆罗门？施何得大果？
何等为时施？云何净福田？”

    尔时世尊说偈答言：

“若得宿命智，见天定趣生，
得尽诸有漏，牟尼起三明，
善知心解脱，解脱一切贪，
说名婆罗门，施彼得大果，
施彼为时施，随所欲福田。”

    时天作婆罗门闻佛所说，欢喜随喜，作礼而去。

（一一八二）

    如是我闻。一时佛在拘萨罗人间游行，于一夜时，住止娑罗林中。
    时有一婆罗门，去娑罗林不远，营作田业。晨朝起作，至娑罗林中，遥见世尊坐一树下，仪容端正，诸根清净，其心寂定，具足成就第一止观，其身金色，光明彻照。见已往诣其所，白言：“瞿昙，我近在此经营事业，故乐此林。瞿昙于此有何事业，乐此林中？”
    复说偈言：

“比丘于此林，为何事业故，
独一守空闲，乐于此林中？”

    尔时世尊说偈答曰：

“无事于此林，林根久已断，
于林离林脱，禅思不乐断。”

    时彼婆罗门闻佛所说，欢喜随喜，作礼而去。

（一一八三）

    如是我闻。一时佛在拘萨罗人间游行，夜宿一娑罗林中。
    时有一婆罗门，近彼林侧，与五百年少婆罗门共。彼婆罗门常称叹钦想：“欲见世尊，何时游于此林，我因得见，过问所疑，颇有闲暇为我记说！”
    时彼婆罗门年少弟子为采薪故，入于林中，遥见世尊坐一树下，仪容端正，诸根寂静，其心寂定，形若金山，光明彻照。见已作是念：“我和上婆罗门常称叹钦仰，欲见瞿昙，问其所疑。今此沙门瞿昙到此林中，我当疾往白和上令知。”即持薪束，疾还学堂，舍薪束已，诣和上所，白言：“和上当知，和上由来常所称叹钦仰，欲见沙门瞿昙，脱到此林，当问所疑。今日瞿昙已到此林，和上知时！”
    时婆罗门即诣世尊所，面相问讯慰劳已，退坐一面，而说偈言：

“独入此恐怖，深邃丛林中，
坚住不倾动，善修正勤法。
无歌舞音乐，寂默住空闲，
我所未曾见，独乐深林者。
欲求于世间，自在增上主？
为三十三天，天上自在乐？
何故深林中，苦行自枯槁？”

    尔时世尊说偈答言：

“若欲种种求，诸界多种著，
彼一切皆是，愚痴之根本。
如是一切求，我久悉已吐，
不求不谄伪，一切无所触。
于一切诸法，唯一清净观，
得无上菩提，禅思修正乐。”

    婆罗门复说偈言：

“我今敬礼汝，大寂牟尼尊！
禅思之妙王，觉无边大觉。
如来天人救，巍巍若金山，
解脱于丛林，于林永不著。
已拔深利刺，清净无余迹，
论师之上首，言说最胜辩。
人中雄狮子，震吼于深林，
显现苦圣谛，集灭八正道，
能尽众苦聚，乘出净无垢。
自脱一切苦，济彼苦众生，
安乐众生故，演说于正法。
已断于恩爱，远离于欲网，
断除于一切，有爱之结缚。
如水生莲花，尘水不染著，
如日停虚空，清净无云翳。
善哉我今日，至拘萨罗林，
得见于大师，两足之胜尊！
大林大精进，得第一广度，
调御师之首，敬礼无所畏！”

    时婆罗门广说斯偈，赞叹佛已，闻佛所说，欢喜随喜，作礼而去。

（一一八四）

    如是我闻。一时佛在拘萨罗人间游行，宿于孙陀利河侧。
    尔时世尊剃发未久，于后夜时，结跏趺坐，正身思惟，系念在前，以衣覆头。
    时孙陀利河侧有婆罗门住止，夜起持祠，余食不尽，持至河边，欲求大德婆罗门以奉之。
    尔时世尊闻河边婆罗门行声，闻已謦咳作声，却衣现头。
    时孙陀利河侧婆罗门见佛已，作是念：“是剃头沙门，非婆罗门。”欲持食还去。彼婆罗门复作是念：“非独沙门是剃头者，婆罗门中亦有剃头，应往至彼，问其所生。”
    时孙陀利河侧婆罗门诣世尊所，而问之言：“为何姓生？”
    尔时世尊即说偈言：

“汝莫问所生，但当问所行，
刻木为钻燧，亦能生于火，
下贱种姓中，生坚固牟尼。
智慧有惭愧，精进善调伏，
究竟大明际，清净修梵行，
而今正是时，应奉施余食。”

    时孙陀利河侧婆罗门复说偈言：

“我今吉良日，求福修供养，
遇得见大士，三时最胜尊，
若不见佛者，当更施余人。”

    尔时孙陀利河侧婆罗门转得信心，即持余食以奉世尊。世尊不受，以说偈得故。如上因说偈而得食广说。
    孙陀利河侧婆罗门白佛言：“世尊，今此施食当置何所？”
    佛告婆罗门：“我不见诸天、魔、梵、沙门、婆罗门、天神、世人，有能食此食，令身安隐者。汝持此食，去着无虫水中，及少生草地。”
    时婆罗门即持此食着无虫水中，水即烟起涌沸，啾啾作声。如烧铁丸投之冷水，烟起涌沸，啾啾作声。如是彼食着无虫水中，烟起涌沸，啾啾作声。
    孙陀利河侧婆罗门心欲恐怖，身毛皆竖，谓为灾变，驰走上岸，集聚干木，供养祠火，令息灾怪。
    世尊见彼集聚干木，供养祠火，望息灾怪，见已即说偈言：

“婆罗门祠火，焚烧干草木，
莫呼是净道，能却诸灾患。
此则恶供养，而谓为黠慧，
作如是因缘，外道取修净。
汝今弃薪火，起内火炽然，
常修不放逸，常当于供养。
处处兴净信，广施设大会，
心意为束薪，瞋恚黑烟起，
妄语为尘味，口舌为木杓，
胸怀燃火处，欲火常炽然，
当善自调伏，消灭士夫火。
正信为大河，净戒为度济，
澄净清流水，智者之所叹。
人中净天德，当于中洗浴，
涉水不着身，安乐度彼岸。
正法为深渊，福德为下济，
澄净水充满，智者所赞叹。
人中天净德，当于中洗浴，
涉水不着身，安乐度彼岸。
真谛善调御，摄护修梵行，
慈悲为苦行，真实心清净，
沐浴以正法，智者所称叹。”

    尔时孙陀利河侧婆罗门闻佛所说，欢喜随喜，复道而去。

（一一八五）

    如是我闻。一时佛在拘萨罗人间游行，住孙陀利河侧丛林中。
    时有孙陀利河侧住止婆罗门，来诣佛所，面相问讯慰劳已，退坐一面，问佛言：“瞿昙，至孙陀利河中洗浴不？”
    佛告婆罗门：“何用于孙陀利河中洗浴为？”
    婆罗门白佛：“瞿昙，孙陀利河是济度之数，是吉祥之数，是清净之数，若有于中洗浴者，悉能除人一切诸恶。”
    尔时世尊即说偈言：

“非孙陀利河，亦非婆休多，
非伽耶萨罗，如是诸河等，
作诸恶不善，能令其清净。
恒河婆休多，孙陀利河等，
愚者常居中，不能除众恶。
其清净之人，何用洗浴为？
其清净之人，何用布萨为？
净业以自净，是生于受持，
不杀亦不盗，不淫不妄语，
信施除悭垢，于斯而洗浴，
于一切众生，常起慈悲心。
井水以洗浴，用伽耶等为？
内心自清净，不待洗于外。
下贱田舍儿，身体多污垢，
以水洗尘秽，不能净其内。”

    尔时孙陀利河侧婆罗门闻佛所说，欢喜随喜，从座起而去。

（一一八六）

    如是我闻。一时佛住迦毗罗卫国尼拘律园中。
    时有萦髻婆罗豆婆遮婆罗门，本俗人时，为佛善知识。来诣佛所，面相问讯慰劳已，退坐一面，而说偈言：

“外身萦髻者，是但名萦髻；
内心萦髻者，是结缚众生。
今请问瞿昙，云何解萦髻？”

    尔时世尊说偈答言：

“受持于净戒，内心修正觉，
专精勤方便，是则解萦髻。”

    时萦髻婆罗门闻佛所说，欢喜随喜，从座起而去。

（一一八七）

    如是我闻。一时佛住迦毗罗卫国尼拘律园中。
    时有萦髻婆罗豆婆遮婆罗门，来诣佛所，面前问讯，相慰劳已，退坐一面，而说偈言：

“身外萦髻者，是但名萦髻；
内心萦髻者，是结缚众生。
我今问瞿昙，如此萦髻者，
云何作方便，于何断萦髻？”

    尔时世尊说偈答言：

“眼耳及与鼻，舌身意入处，
于彼名及色，灭尽令无余，
诸识永灭者，于彼断萦髻。”

    佛说此经已，萦髻婆罗豆婆遮婆罗门闻佛所说，欢喜随喜，从座起而去。

（一一八八）

    如是我闻。一时佛住郁毗罗聚落尼连禅河侧菩提树下，成佛未久。
    尔时世尊独静思惟，作是念：“不恭敬者，则为大苦。无有次序、无他自在可畏惧者，则于大义有所退减。有所恭敬、有次序、有他自在者，得安乐住。有所恭敬、有次序、有他自在，大义满足。颇有诸天、魔、梵、沙门、婆罗门、天神、世人中，能于我所，具足戒胜、三昧胜、智慧胜、解脱胜、解脱知见胜，令我恭敬宗重、奉事供养、依彼而住？”
    复作是念：“无有诸天、魔、梵、沙门、婆罗门、天神、世人，能于我所，戒具足胜、三昧胜、智慧胜、解脱胜、解脱知见胜，令我恭敬宗重、奉事供养、依彼而住者。唯有正法，令我自觉成三藐三佛陀者，我当于彼恭敬宗重、奉事供养、依彼而住。所以者何？过去如来、应、等正觉，亦于正法恭敬宗重、奉事供养、依彼而住。诸当来世如来、应、等正觉，亦于正法恭敬宗重、奉事供养、依彼而住。”
    尔时娑婆世界主梵天王，知世尊心念已，如力士屈伸臂顷，从梵天没，住于佛前，叹言：“善哉！如是，世尊！如是，善逝！懈怠不恭敬者，甚为大苦；广说乃至大义满足。其实无有诸天、魔、梵、沙门、婆罗门、天神、世人，于世尊所，戒具足胜、三昧胜、智慧胜、解脱胜、解脱知见胜，令世尊恭敬宗重、奉事供养、依彼而住者。唯有正法，如来自悟成等正觉，则是如来所应恭敬宗重、奉事供养、依彼而住者。所以者何？过去诸如来、应、等正觉，亦于正法恭敬宗重、奉事供养、依彼而住。诸未来如来、应、等正觉，亦当于正法恭敬宗重、奉事供养、依彼而住。世尊亦当于彼正法恭敬宗重、奉事供养、依彼而住。”
    时梵天王复说偈言：

“过去等正觉，及未来诸佛，
现在佛世尊，能除众生忧，
一切恭敬法，依正法而住，
如是恭敬者，是则诸佛法。”

    时梵天王闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一一八九）

    如是我闻。一时佛住郁毗罗聚落尼连禅河侧菩提树下，成佛未久。
    尔时世尊独静思惟，作是念：“有一乘道，能净众生，度诸忧悲，灭除苦恼，得真如法，谓四念处。何等为四？身身观念处，受、心、法法观念处。若有人不乐四念处者，则不乐如圣法；不乐如圣法者，则不乐如圣道；不乐如圣道者，则不乐甘露法；不乐甘露法者，则不解脱生老病死、忧悲恼苦。若乐修四念处者，则乐修如圣法；乐修如圣法者，则乐如圣道；乐如圣道者，则乐甘露法；乐甘露法者，得解脱生老病死、忧悲恼苦。”
    尔时娑婆世界主梵天王，知佛心念已，譬如力士屈伸臂顷，于梵天没，住于佛前，作是叹言：“如是，世尊！如是，善逝！有一乘道，能净众生，谓四念处。乃至解脱生老病死、忧悲恼苦。”
    时梵天王复说偈言：

“谓有一乘道，见生诸有边，
演说于正法，安慰苦众生。
过去诸世尊，以乘斯道度；
当来诸世尊，亦乘度斯道；
现在尊正觉，乘此度海流，
究竟生死际，调伏心清净。
于生死轮转，悉已永消尽，
知种种诸界，慧眼显正道。
譬若恒水流，悉归趣大海，
激流浚漂远，正道亦如是，
广智善显示，逮得甘露法。
殊胜正法轮，本所未曾闻，
哀愍众生故，而为众生转。
覆护天人众，令度有彼岸，
是故诸众生，咸皆稽首礼。”

    尔时梵天王闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一一九○）

    如是我闻。一时佛住郁毗罗聚落尼连禅河侧菩提树下，成佛未久。
    尔时娑婆世界主梵天王，绝妙色身，于后夜时，来诣佛所，稽首佛足，退坐一面，而说偈言：

“于诸种姓中，刹利两足尊，
明行具足者，天人中最胜。”

    佛告梵天王：“如是，梵天！如是，梵天！

“于诸种姓中，刹利两足尊，
明行具足者，天人中最胜。”

    佛说是经已，娑婆世界主梵天王闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一一九一）

    如是我闻。一时佛在拘萨罗人间游行，住止空闲无聚落处，与比丘众夜宿其中。
    尔时世尊为诸比丘说随顺阿练若法。
    时娑婆世界主梵天王作是念：“今者世尊在拘萨罗人间游行，住一空闲无聚落处，与诸大众止宿空野。尔时世尊为诸大众说随顺空法，我今当往随顺赞叹。”譬如力士屈伸臂顷，于梵天没，住于佛前，稽首佛足，退坐一面，而说偈言：

“习近边床坐，断除诸烦恼，
若不乐空闲，入众自摄护。
自调伏其心，家家行乞食，
摄持于诸根，专精系心念。
然后习空闲，阿练若床坐，
远离诸恐怖，无畏安隐住。
若彼诸凶险，恶蛇众毒害，
黑云大暗冥，震雷曜电光，
离诸烦恼故，昼夜安隐住。
如我所闻法，乃至不究竟，
独一修梵行，不畏千死魔，
若修于觉道，不畏于万数。
一切须陀洹，或得斯陀含，
及阿那含者，其数亦无量，
不能定其数，恐怖于妄说。”

    时娑婆世界主梵天王闻佛所说，欢喜随喜已，为佛作礼，即没不现。

（一一九二）

    如是我闻。一时佛住迦毗罗卫迦毗罗卫林中，与五百比丘俱，皆是阿罗汉，诸漏已尽，所作已作，离诸重担，逮得己利，尽诸有结，正智心善解脱。
    尔时世尊为诸大众说涅槃相应法。
    时有十方世界大众威力诸天，皆悉来会，供养世尊及比丘僧。
    复有诸梵天王，住于梵世，作是念：“今日佛住迦毗罗卫国，如上广说，乃至供养世尊及诸大众。我今当往，各各赞叹。”作是念已，譬如力士屈伸臂顷，从梵天没，住于佛前。
    第一梵天即说偈言：

“于此大林中，大众普云集，
十方诸天众，皆悉来恭敬，
故我远来礼，最胜难伏僧。”

    第二梵天复说偈言：

“是诸比丘僧，真实心精进，
于此大林中，摄诸根求度。”

    第三梵天次说偈言：

“善方便消融，恩爱深利刺，
坚固不倾动，如因陀罗幢。
度深堑水流，清净不求欲，
善度之导师，诸调伏大龙。”

    第四梵天次说偈言：

“归依于佛者，终不堕恶趣，
能断人中身，得天身受乐。”

    各说偈已，四梵天身即没不现。

（一一九三）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有娑婆世界主梵天王，日日精勤，往诣佛所，尊重供养。
    时娑婆世界主作是念：“今旦太早而来见佛，正值世尊入火三昧。我等且当入提婆达多伴党，瞿迦梨比丘房中。”作是念已，即入彼房，至房户中，以指扣户，口说是言：“瞿迦梨！瞿迦梨！于舍利弗、目连所，起净信心。汝莫长夜得不饶益苦！”
    瞿迦梨言：“汝是谁？”
    梵天答言：“娑婆世界主梵天王。”
    瞿迦梨言：“世尊不记汝得阿那含耶？”
    梵天王言：“如是比丘。”
    瞿迦梨言：“汝何故来？”
    娑婆世界主梵天王答言：“此不可治。”即说偈言：

“于无量处所，生心欲筹量，
何有黠慧者，而生此妄想？
无量而欲量，是阴盖凡夫。”

    时娑婆世界主梵天王往诣佛所，稽首礼足，退坐一面，白佛言：“世尊，我常日日勤到佛所，亲觐供养。我作是念：‘今旦太早来见世尊，正值世尊入火三昧，我且当入提婆达多伴党瞿迦梨比丘房中。’即住户中，徐徐扣户，口说是言：‘瞿迦梨，瞿迦梨！当于舍利弗、目揵连贤善智慧者所，起净信心。莫长夜得不饶益苦！’瞿迦梨言：‘汝是谁？’我即答言：‘是娑婆世界主梵天王。’瞿迦梨言：‘世尊不记汝得阿那含耶？’我即答言：‘如是。’瞿迦梨复言：‘汝何故来？’我作是念：‘此不可治。’即说偈言：

“于不可量处，发心欲筹量，
不可量欲量，是阴盖凡夫。”

    佛语梵王：“如是如是，梵王！

“于不可量处，而发心欲量，
何有智慧人，而生此妄想？
不可量欲量，是阴盖凡夫。”

    佛说此经已，娑婆世界主梵天王闻佛所说，欢喜随喜，从座起，为佛作礼，即没不现。

（一一九四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时大梵天王，及余别梵天、善臂别梵天，日日方便，往见供养世尊。
    时有婆句梵天，见别梵天、善臂梵天精勤方便，而问言：“汝欲何之？”
    彼即答言：“欲见世尊，恭敬供养。”
    时婆句梵天即说偈言：

“彼有四鹄鸟，三种金色宫，
五百七十二，修行禅思者。
炽焰金色身，普照梵天宫，
汝且观我身，何用至彼为？”

    尔时善梵王、别梵王、善臂别梵王，复说偈言：

“虽有金色身，普照梵天宫，
其有智慧者，知色有烦恼，
智者不乐色，于其心解脱。”

    时彼善梵天、别梵天、善臂别梵天，往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我今方便欲来见世尊，恭敬供养。有婆句梵天，见我方便，而问我言：‘汝今方便，欲何所之？’我即答言：‘欲往见世尊，礼事供养。’婆句梵天即说偈言：

‘有四种鹄鸟，三种金色宫，
五百七十二，于中而禅思。
观我身金色，普照梵天宫，
汝且观我身，何用至彼为？’

    “我即说偈而答彼言：

“虽有金色身，普照梵天宫，
当知真金色，是则烦恼事，
智者解脱色，于色不复乐。”

    佛告梵天：“如是，梵天。如是，梵天。

“虽有真金色，普照梵天宫，
当知真金色，则是烦恼事，
智者解脱色，于色不复乐。”

    时彼梵天为迦吒务陀低沙比丘故说偈言：

“士夫生世间，利斧在口中，
还自斩其身，斯由恶言故。
应毁者称誉，应誉而反毁，
恶口增其过，所生无安乐。
博弈酒丧财，其过失甚少，
恶心向善逝，是则为大过。
地狱有百千，名尼罗浮陀，
三千有六百，及五阿浮陀，
斯皆谤圣狱，口意恶愿故。”

    佛说此经已，彼诸梵天闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一一九五）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有婆句梵天住梵天上，起如是恶邪见，言：“此处常恒，非变易法，纯一出离之处。”
    尔时世尊知婆句梵天心念已，入于三昧，如其正受，于王舍城没，住梵天上。
    婆句梵天遥见世尊，而说偈言：

“梵天七十二，造作诸福业，
自在而常住，生老死已过。
我于诸明论，修习已究竟，
彼诸天众等，唯谓我长存。”

    尔时世尊说偈答言：

“此则极短寿，非是长存者，
而婆句梵天，自谓为长寿。
尼罗浮多狱，其寿百千数，
我悉忆念知，汝自谓长存。”

    婆句梵天复说偈言：

“佛世尊所见，其劫数无边，
生老死忧悲，皆悉已过去。
唯愿说知我，过去曾所更，
受持何戒业，而得生于此？”

    尔时世尊说偈答言：

“过去久远劫，于大旷野中，
有诸大众行，多贤圣梵行，
饥乏无资粮，汝救之令度，
慈救心相续，经劫而不失；
是则汝过去，所受持功德，
我悉忆念知，久近如眠觉。
过去有村邑，为贼所抄掠，
汝时悉皆救，令其得解脱；
是则过去世，所受持福业，
我忆此因缘，久近如眠觉。
过去有人众，乘船恒水中，
恶龙持彼船，欲尽害其命，
汝时以神力，救令得解脱；
是则汝过去，所受持福业，
我忆是因缘，久近如眠觉。”

    婆句梵天复说偈言：

“决定悉知我，古今寿命事，
亦知余一切，是则为正觉。
是故所受身，金光炎普照，
其身住于此，光明遍世间。”

    尔时世尊为婆句梵天种种说法，示教照喜已，如其正受，从梵天没，还王舍城。

（一一九六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一梵天住梵天上，起如是邪见，言：“此处常恒不变易，纯一出离。未曾见有来至此处，况复有过此上者！”
    尔时世尊知彼梵天心之所念，即入三昧，如其正受，于舍卫国没，现梵天宫，当彼梵天顶上，于虚空中结跏趺坐，正身系念。
    尔时尊者阿若俱邻作是念：“今日世尊为在何所？”即以天眼净过人间眼，观见世尊在梵天上。见已即入三昧，如其正受，于舍卫国没，现彼梵世，在于东方，西面向佛，结跏趺坐，端身系念，在佛座下，梵天座上。
    尔时尊者摩诃迦叶作是念：“今日世尊为在何所？”即以天眼净过于人眼，见世尊在梵天上。见已即入三昧，如其正受，于舍卫国没，现梵天上，在于南方，北面向佛，结跏趺坐，端身系念，在佛座下，梵天座上。
    时尊者舍利弗作是念：“世尊今者为在何所？”即以天眼净过于人眼，见世尊在梵天上。见已即入三昧，如其正受，于舍卫国没，住梵天上，在于西方，东面向佛，结跏趺坐，端身系念，在佛座下，梵天座上。
    尔时尊者大目揵连即作是念：“今日世尊为在何所？”以天眼净过于人眼，遥见世尊在梵天上。见已即入三昧，如其正受，于舍卫国没，住梵天上，在于北方，南面向佛，结跏趺坐，端身系念，在佛座下，梵天座上。
    尔时世尊告梵天曰：“汝今复起是见：从本已来，未曾见有过我上者不？”
    梵天白佛：“我今不敢复言我未曾见有过我上者，唯见梵天光明被障。”
    尔时世尊为彼梵天种种说法，示教照喜已，即入三昧，如其正受，于梵天上没，还舍卫国。尊者阿若俱邻、摩诃迦叶、舍利弗，为彼梵天种种说法，示教照喜已，即入三昧，如其正受，于梵天没，还舍卫国。唯尊者大目揵连，仍于彼住。
    时彼梵天问尊者大目揵连：“世尊诸余弟子，悉有如是大德大力不？”
    时尊者大目揵连即说偈言：

“大德具三明，通达观他心，
漏尽诸罗汉，其数无有量。”

    时尊者大目揵连为彼梵天种种说法，示教照喜已，即入三昧，如其正受，于梵天没，还舍卫国。

（一一九七）

    如是我闻。一时佛住俱尸那竭国力士生地坚固双树林。
    尔时世尊临般涅槃，告尊者阿难：“汝于坚固双树间，敷绳床北首，如来今日中夜于无余涅槃而般涅槃。”
    时尊者阿难奉世尊教，于双坚固树间，为世尊敷绳床北首已，还世尊所，稽首礼足，白言：“世尊！已为如来于双坚固树间敷绳床，令北首。”
    于是世尊往就绳床，右胁着地，北首而卧，足足相累，系念明相。尔时世尊即于中夜，于无余涅槃而般涅槃。
    般涅槃已，双坚固树寻即生花，周匝垂下，供养世尊。
    时有异比丘即说偈言：

“善好坚固树，枝条垂礼佛，
妙花以供养，大师般涅槃。”

    寻时释提桓因说偈：

“一切行无常，斯皆生灭法，
虽生寻以灭，斯寂灭为乐。”

    寻时娑婆世界主梵天王次复说偈言：

“世间一切生，立者皆当舍，
如是圣大师，世间无有比。
逮得如来力，普为世间眼，
终归会磨灭，入无余涅槃。”

    尊者阿那律陀次复说偈言：

“出息入息住，立心善摄护，
从所依而来，世间般涅槃。
大恐怖相生，令人身毛竖，
一切行力具，大师般涅槃。
其心不懈怠，亦不住诸爱，
心法渐解脱，如薪尽火灭。”

    如来涅槃后七日，尊者阿难往支提所，而说偈言：

“导师此宝身，往诣梵天上，
如是大神力，内火还烧身，
五百氎缠身，悉烧令磨灭。
千领细氎衣，以衣如来身，
唯二领不烧，最上及衬身。”

    尊者阿难说是偈已，时诸比丘默然悲喜。


杂阿含经卷第四十五

（一一九八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有阿腊毗比丘尼，住舍卫国王园精舍比丘尼众中。时阿腊毗比丘尼，晨朝着衣持钵，入舍卫城乞食。食已还精舍，举衣钵，洗足，持尼师坛着右肩上，入安陀林坐禅。
    时魔波旬作是念：“今沙门瞿昙住舍卫国祇树给孤独园。有弟子阿腊毗比丘尼，住舍卫国王园精舍比丘尼众中，晨朝着衣持钵，入舍卫城乞食，食已还精舍，举衣钵，洗足已，持尼师坛着右肩上，入安陀林坐禅。我今当往，为作留难。”即化作年少，容貌端正，往诣彼比丘尼所，语比丘尼言：“阿姨，欲何处去？”
    比丘尼答言：“贤者，到远离处去。”
    时魔波旬即说偈言：

“世间无有出，用求远离为？
还服食五欲，勿令后变悔。”

    时阿腊毗比丘尼作是念：“是谁欲恐怖我，为是人耶？为非人耶？奸狡人耶？”心即念言：“此必恶魔欲乱我耳。”觉知已，而说偈言：

“世间有出要，我自知所得，
鄙下之恶魔，汝不知其道。
譬如利刀害，五欲亦如是，
譬如斩肉形，苦受阴亦然。
如汝向所说，服乐五欲者，
是则不可乐，大恐怖之处。
离一切喜乐，舍诸大暗冥，
以灭尽作证，安住离诸漏。
觉知汝恶魔，寻即自灭去！”

    时魔波旬作是念：“彼阿腊毗比丘尼已知我心。”愁忧不乐，即没不现。

（一一九九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有苏摩比丘尼，住舍卫国王园精舍比丘尼众中，晨朝着衣持钵，入舍卫城乞食。食已还精舍，举衣钵，洗足毕，持尼师坛着右肩上，至安陀林坐禅。
    时魔波旬作是念：“今沙门瞿昙住舍卫国祇树给孤独园。有苏摩比丘尼，住舍卫国王园精舍比丘尼众中，晨朝着衣持钵，入舍卫城乞食，食已还精舍，举衣钵，洗足毕，持尼师坛着右肩上，入安陀林坐禅。我今当往，为作留难。”即化作年少，容貌端正，往至苏摩比丘尼所，问言：“阿姨，欲至何所？”
    答言：“贤者，欲至远离处去。”
    时魔波旬即说偈言：

“仙人所住处，是处甚难得，
非彼二指智，能得到彼处。”

    时苏摩比丘尼作是念：“此是何等欲恐怖我，为人、为非人、为奸狡人？”作此思惟已，决定智生，知是恶魔来欲娆乱，即说偈言：

“心入于正受，女形复何为？
智或若生已，逮得无上法。
若于男女想，心不得俱离，
彼即随魔说，汝应往语彼。
离于一切苦，舍一切暗冥，
逮得灭尽证，安住诸漏尽。
觉知汝恶魔，即自磨灭去！”

    时魔波旬作是念：“苏摩比丘尼已知我心。”内怀忧悔，即没不现。

（一二○○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有吉离舍瞿昙弥比丘尼，住舍卫国王园精舍比丘尼众中，晨朝着衣持钵，至舍卫城乞食。食已还精舍，举衣钵，洗足毕，持尼师坛着肩上，入安陀林，于一树下结跏趺坐，入昼正受。
    时魔波旬作是念：“今沙门瞿昙住舍卫国祇树给孤独园。时吉离舍瞿昙弥比丘尼，住舍卫国王园精舍比丘尼众中，晨朝着衣持钵，入舍卫城乞食，食已还精舍，举衣钵，洗足毕，持尼师坛着肩上，入安陀林，于一树下结跏趺坐，入昼正受。我今当往，为作留难。”即化作年少，容貌端正，往至吉离舍瞿昙弥比丘尼所，而说偈言：

“汝何丧其子，涕泣忧愁貌？
独坐于树下，何求于男子？”

    时吉离舍瞿昙弥比丘尼作是念：“为谁恐怖我，为人、为非人、为奸狡者？”如是思惟，生决定智，恶魔波旬来娆我耳。即说偈言：

“无边际诸子，一切皆亡失，
此则男子边，已度男子表。
不恼不忧愁，佛教作已作，
一切离忧苦，舍一切暗冥，
已灭尽作证，安隐尽诸漏。
已知汝弊魔，于此自灭去！”

    时魔波旬作是念：“吉离舍瞿昙弥比丘尼已知我心。”愁忧苦恼，即没不现。

（一二○一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有优钵罗色比丘尼，住舍卫国王园比丘尼众中，晨朝着衣持钵，入舍卫城乞食。食已还精舍，举衣钵，洗足毕，持尼师坛着肩上，入安陀林，坐一树下，入昼正受。
    时魔波旬作是念：“今沙门瞿昙住舍卫国祇树给孤独园。优钵罗色比丘尼住舍卫国王园比丘尼众中，晨朝着衣持钵，入舍卫城乞食，食已还精舍，举衣钵，洗足毕，持尼师坛着肩上，入安陀林，坐一树下，入昼正受。我今当往，为作留难。”即化作年少，容貌端正，至优钵罗色比丘尼所，而说偈言：

“妙花坚固树，依止其树下，
独一无等侣，不畏恶人耶？”

    时优钵罗色比丘尼作是念：“为何等人欲恐怖我，为是人、为非人、为奸狡人？”如是思惟，即得觉知，必是恶魔波旬欲乱我耳。即说偈言：

“设使有百千，皆是奸狡人，
如汝等恶魔，来至我所者，
不能动毛发，不畏汝恶魔。”

    魔复说偈言：

“我今入汝腹，住于内脏中，
或住两眉间，汝不能见我。”

    时优钵罗色比丘尼复说偈言：

“我心有大力，善修习神通，
大缚已解脱，不畏汝恶魔。
我已吐三垢，恐怖之根本，
住于不恐地，不畏于魔军。
于一切爱喜，离一切暗冥，
已证于寂灭，安住诸漏尽。
觉知汝恶魔，自当消灭去！”

    时魔波旬作是念：“优钵罗色比丘尼已知我心。”内怀忧愁，即没不现。

（一二○二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时尸罗比丘尼，住舍卫国王园比丘尼众中，晨朝着衣持钵，入舍卫城乞食。食已还精舍，举衣钵，洗足毕，持尼师坛着肩上，入安陀林，坐一树下，入昼正受。
    时魔波旬作是念：“今沙门瞿昙住舍卫国祇树给孤独园。尸罗比丘尼住舍卫国王园精舍比丘尼众中，晨朝着衣持钵，入舍卫城乞食，食已还精舍，举衣钵，洗足毕，持尼师坛着肩上，入安陀林，坐一树下，入昼正受。我今当往，为作留难。”即化作年少，容貌端正，往到尸罗比丘尼前而说偈言：

“众生云何生？谁为其作者？
众生何处起？去复至何所？”

    尸罗比丘尼作是念：“此是何人欲恐怖我，为人、为非人、为奸狡人？”作是思惟已，即生知觉，此是恶魔欲作留难。即说偈言：

“汝谓有众生，此则恶魔见，
唯有空阴聚，无是众生者。
如和合众材，世名之为车，
诸阴因缘合，假名为众生。
其生则苦生，住亦即苦住，
无余法生苦，苦生苦自灭。
于一切忧苦，离一切暗冥，
已证于寂灭，安住诸漏尽。
已知汝恶魔，则自消灭去！”

    时魔波旬作是念：“尸罗比丘尼已知我心。”内怀忧戚，即没不现。

（一二○三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时毗罗比丘尼，住舍卫国王园比丘尼众中，晨朝着衣持钵，入舍卫城乞食。食已还精舍，举衣钵，洗足毕，持尼师坛着肩上，入安陀林，坐一树下，入昼正受。
    时魔波旬作是念：“今沙门瞿昙住舍卫国祇树给孤独园。毗罗比丘尼住舍卫国王园比丘尼众中，晨朝着衣持钵，入舍卫城乞食，食已还精舍，举衣钵，洗足毕，持尼师坛着肩上，入安陀林，坐一树下，入昼正受。我当往彼，为作留难。”即化作年少，容貌端正，至毗罗比丘尼所，而说偈言：

“云何作此形？谁为其作者？
此形何处起？形去至何所？”

    毗罗比丘尼作是念：“是何人来恐怖我，为人、为非人、为奸狡人？”如是思惟，即得知觉，恶魔波旬欲作娆乱。即说偈言：

“此形不自造，亦非他所作，
因缘会而生，缘散即磨灭。
如世诸种子，因大地而生，
因地水火风，阴界入亦然，
因缘和合生，缘离则磨灭。
舍一切忧苦，离一切暗冥，
已证于寂灭，安住诸漏尽。
恶魔以知汝，即自磨灭去！”

    时魔波旬作是念：“毗罗比丘尼已知我心。”生大忧戚，即没不现。

（一二○四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有毗阇耶比丘尼，住舍卫国王园比丘尼众中，晨朝着衣持钵，入舍卫城乞食。食已还精舍，举衣钵，洗足毕，持尼师坛着肩上，入安陀林，坐一树下，入昼正受。
    时魔波旬作是念：“此沙门瞿昙住舍卫国祇树给孤独园。弟子毗阇耶比丘尼住舍卫国王园比丘尼众中，晨朝着衣持钵，入舍卫城乞食，食已还精舍，举衣钵，洗足毕，持尼师坛着肩上，入安陀林，坐一树下，入昼正受。我今当往，为作留难。”即化作年少，容貌端正，往至其前而说偈言：

“汝今年幼少，我亦是年少，
当共于此处，作五种音乐，
而共相娱乐，用是禅思为？”

    时毗阇耶比丘尼作是念：“此何等人欲恐怖我，为是人耶？为非人耶？为奸狡人耶？”如是思惟已，即得知觉，是魔波旬欲作娆乱。即说偈言：

“歌舞作众伎，种种相娱乐，
今悉已惠汝，非我之所须。
若寂灭正受，及天人五欲，
一切持相与，亦非我所须。
舍一切喜乐，离一切暗冥，
寂灭以作证，安住诸漏尽。
已知汝恶魔，当自消灭去！”

    时魔波旬作是念：“是毗阇耶比丘尼已知我心。”内怀忧戚，即没不现。

（一二○五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时遮罗比丘尼，住舍卫国王园比丘尼众中，晨朝着衣持钵，入舍卫城乞食。食已还精舍，举衣钵，洗足毕，持尼师坛着肩上，至安陀林，坐一树下，入昼正受。
    时魔波旬作是念：“今沙门瞿昙在舍卫国祇树给孤独园。遮罗比丘尼亦住舍卫国王园比丘尼众中，晨朝着衣持钵，入舍卫城乞食，食已还精舍，洗足毕，举衣钵，持尼师坛着肩上，入安陀林，坐一树下，入昼正受。我今当往，为作留难。”即化作年少，容貌端正，至遮罗比丘尼前而说偈言：

“觉受生为乐，生服受五欲，
为谁教授汝，令厌离于生？”

    时遮罗比丘尼作是念：“此是何人欲作恐怖，为人、为非人、为奸狡人，而来至此欲作娆乱？”即说偈言：

“生者必有死，生则受诸苦，
鞭打诸恼苦，一切缘生有。
当断一切苦，超越一切生，
慧眼观圣谛，牟尼所说法。
苦苦及苦集，灭尽离诸苦，
修习八正道，安隐趣涅槃。
大师平等法，我欣乐彼法，
我知彼法故，不复乐受生。
一切离爱喜，舍一切暗冥，
寂灭以作证，安住诸漏尽。
觉知汝恶魔，自当消灭去！”

    时魔波旬作是念：“遮罗比丘尼已知我心。”内怀忧戚，即没不现。

（一二○六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时优波遮罗比丘尼，亦住舍卫国王园比丘尼众中，晨朝着衣持钵，入舍卫城乞食。食已还精舍，举衣钵，洗足毕，持尼师坛着肩上，入安陀林，坐一树下，入昼正受。
    时魔波旬作是念：“今沙门瞿昙住舍卫国祇树给孤独园。优波遮罗比丘尼亦住舍卫国王园比丘尼众中，晨朝着衣持钵，入舍卫城乞食，食已还精舍，举衣钵，洗足毕，持尼师坛着肩上，入安陀林，坐一树下，入昼正受。我今当往，为作留难。”即化作年少，容貌端正，至优波遮罗比丘尼所，而说偈言：

“三十三天上，炎摩兜率陀，
化乐他自在，发愿得往生。”

    优波遮罗比丘尼作是念：“此何等人欲恐怖我，为人、为非人、为是奸狡人？”自思觉悟，必是恶魔欲作娆乱。而说偈言：

“三十三天上，炎摩兜率陀，
化乐他自在，斯等诸天上，
不离有为行，故随魔自在。
一切诸世间，悉是众行聚，
一切诸世间，悉皆动摇法。
一切诸世间，苦火常炽然，
一切诸世间，悉皆烟尘起。
不动亦不摇，不习近凡夫，
不随于魔趣，于是处娱乐。
离一切忧苦，舍一切暗冥，
寂灭以作证，安住诸漏尽。
已觉汝恶魔，则自磨灭去！”

    时魔波旬作是念：“优波遮罗比丘尼已知我心。”内怀忧戚，即没不现。

（一二○七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时尸利沙遮罗比丘尼，亦住舍卫国王园比丘尼众中，晨朝着衣持钵，入舍卫城乞食。食已还精舍，举衣钵，洗足毕，持尼师坛着肩上，入安陀林，坐一树下，入昼正受。
    时魔波旬作是念：“今沙门瞿昙住舍卫国祇树给孤独园。时尸利沙遮罗比丘尼亦住舍卫国王园比丘尼众中，晨朝着衣持钵，入舍卫城乞食，食已还精舍，举衣钵，洗足毕，持尼师坛着肩上，入安陀林，坐一树下，入昼正受。我当往彼，为作留难。”即化作年少，容貌端正，往到尸利沙遮罗比丘尼所，而作是言：“阿姨，汝乐何等诸道？”
    比丘尼答言：“我都无所乐。”
    时魔波旬即说偈言：

“汝何所咨受，剃头作沙门，
身着袈裟衣，而作出家相，
不乐于诸道，而守愚痴住？”

    时尸利沙遮罗比丘尼作是念：“此何等人欲恐怖我，为人、为非人、为奸狡人？”如是思惟已，即自知觉，恶魔波旬欲作娆乱。即说偈言：

“此法外诸道，诸见所缠缚，
缚于诸见已，常随魔自在。
若生释种家，禀无比大师，
能伏诸魔怨，不为彼所伏。
清净一切脱，道眼普观察，
一切智悉知，最胜离诸漏。
彼则我大师，我唯乐彼法，
我入彼法已，得远离寂灭。
离一切爱喜，舍一切暗冥，
寂灭以作证，安住诸漏尽。
已知汝恶魔，如是自灭去！”

    时魔波旬作是念：“尸利沙遮罗比丘尼已知我心。”内怀忧戚，即没不现。

（一二○八）

    如是我闻。一时佛住瞻婆国揭伽池侧。
    尔时世尊，月十五日布萨时，于大众前坐。
    月初出时，时有尊者婆耆舍，于大众中作是念：“我今欲于佛前，叹《月譬偈》。”作是念已，即从座起，整衣服，为佛作礼，合掌白佛言：“世尊，欲有所说！善逝，欲有所说！”
    佛告婆耆舍：“欲说者便说。”
    时尊者婆耆舍即于佛前而说偈言：

“如月停虚空，明净无云翳，
光焰明晖曜，普照于十方。
如来亦如是，慧光照世间，
功德善名称，周遍满十方。”

    尊者婆耆舍说是偈时，诸比丘闻其所说，皆大欢喜。

（一二○九）

    如是我闻。一时佛住瞻婆国揭伽池侧。
    尔时尊者阿若憍陈如，久住空闲阿练若处，来诣佛所，稽首佛足，以面掩佛足上，而说是言：“久不见世尊！久不见善逝！”
    尔时尊者婆耆舍在于会中，作是念：“我今当于尊者阿若憍陈如面前，以《上座譬》而赞叹之。”作此念已，即从座起，整衣服，为佛作礼，合掌白佛：“世尊，欲有所说！善逝，欲有所说！”
    佛告婆耆舍：“欲说时便说。”
    时尊者婆耆舍即说偈言：

“上座之上座，尊者憍陈如，
已度已超越，得安乐正受。
于阿练若处，常乐于远离，
声闻之所应，大师正法教，
一切悉皆陈，正受不放逸，
大德力三明，他心智明了。
上座憍陈如，护持佛法财，
增上恭敬心，头面礼佛足。”

    尊者婆耆舍说是语时，诸比丘闻其所说，皆大欢喜。

（一二一○）

    如是我闻。一时佛住瞻婆国揭伽池侧。
    时尊者舍利弗在供养堂，有众多比丘集会而为说法，句味满足，辩才简净，易解乐闻，不碍不断，深义显现。彼诸比丘专至乐听，尊重忆念，一心侧听。
    时尊者婆耆舍在于会中，作是念：“我当于尊者舍利弗面前，说偈赞叹。”作是念已，即起合掌，白尊者舍利弗：“我欲有所说。”
    舍利弗告言：“随所乐说。”
    尊者婆耆舍即说偈言：

“善能略说法，令众广开解，
贤优婆提舍，于大众宣畅。
当所说法时，咽喉出美声，
悦乐爱念声，调和渐进声，
闻声皆欣乐，专念不移转。”

    尊者婆耆舍说此语时，诸比丘闻其所说，皆大欢喜。

（一二一一）

    如是我闻。一时佛住王舍城那伽山侧，五百比丘俱，皆是阿罗汉，诸漏已尽，所作已作，离诸重担，逮得己利，断诸有结，正智心善解脱。
    尊者大目揵连，观大众心，一切皆悉解脱贪欲。
    时尊者婆耆舍于大众中，作是念：“我今当于世尊及比丘僧面前，说偈赞叹。”作是念已，即从座起，整衣服，合掌白佛言：“世尊，欲有所说！善逝，欲有所说！”
    佛告婆耆舍：“随所乐说。”
    时尊者婆耆舍即说偈言：

“导师无上士，住那伽山侧，
五百比丘众，亲奉于大师。
尊者大目连，神通谛明了，
观彼大众心，悉皆离贪欲。
如是具足度，牟尼度彼岸，
持此最后身，我今稽首礼。”

    尊者婆耆舍说是语时，诸比丘闻其所说，皆大欢喜。

（一二一二）

    如是我闻。一时佛住王舍城迦兰陀竹园夏安居，与大比丘众五百人俱，皆是阿罗汉，诸漏已尽，所作已作，离诸重担，断除有结，正智心善解脱。除一比丘，谓尊者阿难，世尊记说彼现法当得无知证。
    尔时世尊临十五日，月食受时，于大众前敷座而坐，坐已告诸比丘：“我为婆罗门，得般涅槃，持后边身，为大医师，拔诸剑刺。我为婆罗门，得般涅槃，持此后边身，无上医师，能拔剑刺。汝等为子，从我口生，从法化生，得法余财。当怀受我，莫令我若身、若口、若心，有可嫌责事。”
    尔时尊者舍利弗在众会中，从座起，整衣服，为佛作礼，合掌白佛：“世尊向者作如是言：‘我为婆罗门，得般涅槃，持最后身，无上大医，能拔剑刺。汝为我子，从佛口生，从法化生，得法余财。诸比丘，当怀受我，莫令我身、口、心，有可嫌责。’我等不见世尊身、口、心，有可嫌责事。所以者何？世尊不调伏者能令调伏，不寂静者能令寂静，不苏息者能令苏息，不般涅槃者能令般涅槃。如来知道，如来说道，如来向道，然后声闻成就随道、宗道、奉受师教，如其教授，正向欣乐真如善法。我于世尊，都不见有可嫌责身、口、心行。我今于世尊所，乞愿怀受，见、闻、疑罪，若身、口、心有嫌责事。”
    佛告舍利弗：“我不见汝有见、闻、疑，身、口、心可嫌责事。所以者何？汝舍利弗持戒多闻，少欲知足，修行远离，精勤方便，正念正受；捷疾智慧，明利智慧，出要智慧，厌离智慧，大智慧，广智慧，深智慧，无比智慧，智宝成就；示教照喜，亦常赞叹示教照喜，为众说法，未曾疲倦。譬如转轮圣王第一长子，应受灌顶而未灌顶，已住灌顶仪法，如父之法，所可转者亦当随转。汝今如是，为我长子，邻受灌顶而未灌顶，住于仪法，我所应转法轮，汝亦随转，得无所起，尽诸有漏，心善解脱。如是舍利弗，我于汝所，都无见、闻、疑，身、口、心可嫌责事。”
    舍利弗白佛言：“世尊，若我无有见、闻、疑，身、口、心可嫌责事。此五百诸比丘，得无有见、闻、疑，身、口、心可嫌责事耶？”
    佛告舍利弗：“我于此五百比丘，亦不见有见、闻、疑，身、口、心可嫌责事。所以者何？此五百比丘皆是阿罗汉，诸漏已尽，所作已作，已舍重担，断诸有结，正智心善解脱。除一比丘，谓尊者阿难，我记说彼于现法中得无知证。是故诸五百比丘，我不见其有身、口、心，见、闻、疑罪可嫌责者。”
    舍利弗白佛言：“世尊，此五百比丘既无有见、闻、疑，身、口、心可嫌责事，然此中几比丘得三明？几比丘俱解脱？几比丘慧解脱？”
    佛告舍利弗：“此五百比丘中，九十比丘得三明，九十比丘得俱解脱，余者慧解脱。舍利弗，此诸比丘离诸飘转，无有皮肤，真实坚固。”
    时尊者婆耆舍在众会中，作是念：“我今当于世尊及大众面前，叹说《怀受偈》。”作是念已，即从座起，整衣服，为佛作礼，右膝着地，合掌白佛：“世尊，欲有所说！善逝，欲有所说！”
    佛告婆耆舍：“随所乐说。”
    时婆耆舍即说偈言：

“十五清净日，其众五百人，
断除一切结，有尽大仙人。
清净相习近，清净广解脱，
不更受诸有，生死已永绝。
所作者已作，得一切漏尽，
五盖已云除，拔刺根本爱。
狮子无所畏，离一切有余，
害诸有怨结，超越有余境，
诸有漏怨敌，皆悉已潜伏。
犹如转轮王，怀受诸眷属，
慈心广宣化，海内悉奉用。
能伏魔怨敌，为无上导师，
信敬心奉事，三明老死灭。
为法之真子，无有飘转患，
拔诸烦恼刺，敬礼日种胤！”

    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（一二一三）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者尼拘律想，住于旷野禽兽住处。
    尊者婆耆舍出家未久，有如是威仪，依聚落城邑住。晨朝着衣持钵，于彼聚落城邑乞食，善护其身，守诸根门，摄心系念。食已还住处，举衣钵，洗足毕，入室坐禅。速从禅觉，不著乞食，而彼无有随时教授。无有教诫者，心不安乐，周圆隐覆，如是深住。
    时尊者婆耆舍作是念：“我不得利，难得非易得，我不随时得教授教诫，不得欣乐，周圆隐覆心住。我今当赞叹《自厌之偈》。”即说偈言：

“当舍乐不乐，及一切贪觉，
于邻无所作，离染名比丘。
于六觉心想，驰骋于世间，
恶不善隐覆，不能去皮肤。
秽污乐于心，是不名比丘，
有余缚所缚，见闻觉识俱。
于欲觉悟者，彼处不复染，
如是不染者，是则为牟尼。
大地及虚空，世间诸色像，
斯皆磨灭法，寂然自决定。
法器久修习，而得三摩提，
不触不谄伪，其心极专至，
彼圣久涅槃，系念待时灭。”

    时尊者婆耆舍说《自厌离偈》，心自开觉，于不乐等开觉已，欣乐心住。

（一二一四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者阿难陀，晨朝着衣持钵，入舍卫城乞食，以尊者婆耆舍为伴。
    时尊者婆耆舍，见女人有上妙色，见已贪欲心起。
    时尊者婆耆舍作是念：“我今得不利，得苦非得乐。我今见年少女人有妙绝之色，贪欲心生。今为生厌离故，而说偈言：

“贪欲所覆故，炽然烧我心。
今尊者阿难，为我灭贪火，
慈心哀愍故，方便为我说！”

    尊者阿难说偈答言：

“以彼颠倒想，炽然烧其心，
远离于净想，长养贪欲者，
当修不净观，常一心正受，
速灭贪欲火，莫令烧其心。
谛观察诸行，苦空非有我，
系念正观身，多修习厌离，
修习于无相，灭除骄慢使，
得慢无间等，究竟于苦边。”

    尊者阿难说是语时，尊者婆耆舍闻其所说，欢喜奉行。

（一二一五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一长者，请佛及僧，就其舍食。入其舍已，尊者婆耆舍直日住守，请其食分。
    时有众多长者妇女从聚落出，往诣精舍。时尊者婆耆舍见年少女人容色端正，贪欲心起。
    时尊者婆耆舍作是念：“我今不利不得利，得苦不得乐，见他女人容色端正，贪欲心生。我今当说《厌离偈》。”念已而说偈言：

“我已得出离，非家而出家，
贪欲随逐我，如牛念他苗。
当如大将子，大力执强弓，
能破彼重阵，一人摧伏千。
今于日种胤，面前闻所说，
正趣涅槃道，决定心乐住。
如是不放逸，寂灭正受住，
无能于我心，幻惑欺诳者。
决定善观察，安住于正法，
正使无量数，欲来欺惑我，
如是等恶魔，莫能见于我！”

    时尊者婆耆舍说是偈已，心得安住。

（一二一六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时尊者婆耆舍，自以智慧堪能善说，于彼聪明梵行所，生骄慢心。即自心念：“我不利不得利，得苦不得乐，我自以智慧，轻慢于彼聪明梵行者。我今当说《能生厌离偈》。”即说偈言：

“瞿昙莫生慢，断慢令无余，
莫起慢觉想，莫退生变悔，
莫隐覆于他，泥犁杀慢堕。
正受能除忧，见道住正道，
其心得喜乐，见道自摄持。
是故无碍辩，清净离诸盖，
断一切诸慢，起一切明处，
正念于三明，神足他心智。”

    时尊者婆耆舍说此《生厌离偈》已，心得清净。

（一二一七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时尊者婆耆舍，住舍卫国东园鹿子母讲堂，独一思惟，不放逸住，专修自业，逮得三明身作证。
    时尊者婆耆舍作是念：“我独一静处思惟，不放逸住，专修自业，起于三明身作证。今当说偈，赞叹三明。”即说偈言：

“本欲心狂惑，聚落及家家，
游行遇见佛，授我殊胜法。
瞿昙哀愍故，为我说正法，
闻法得净信，舍非家出家。
闻彼说法已，正住于法教，
勤方便系念，坚固常堪能，
逮得于三明，于佛教已作。
世尊善显示，日种苗胤说，
为生盲众生，开其出要门。
苦苦及苦因，苦灭尽作证，
八圣离苦道，安乐趣涅槃。
善义善句味，梵行无过上，
世尊善显示，涅槃济众生。”

（一二一八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“我今当说四法句，谛听善思，当为汝说。何等为四？

“贤圣善说法，是则为最上；
爱说非不爱，是则为第二；
谛说非虚妄，是则第三说；
法说不异言，是则为第四。

    “诸比丘，是名说四法句。”
    尔时尊者婆耆舍于众会中，作是念：“世尊于四众中说四法句，我当以四种赞叹称誉随喜。”即从座起，整衣服，为佛作礼，合掌白佛言：“世尊，欲有所说！善逝，欲有所说！”
    佛告婆耆舍：“随所乐说。”
    时尊者婆耆舍即说偈言：

“若善说法者，于己不恼迫，
亦不恐怖他，是则为善说。
所说爱说者，说令彼欢喜，
不令彼为恶，是则为爱说。
谛说知甘露，谛说知无上，
谛义说法说，正士建立处。
如佛所说法，安隐涅槃道，
灭除一切苦，是名善说法。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二一九）

    如是我闻。一时佛住王舍城那伽山侧，与千比丘俱，皆是阿罗汉，尽诸有漏，所作已作，离诸重担，逮得己利，尽诸有结，正智心善解脱。
    尔时尊者婆耆舍住王舍城寒林中丘冢间，作是念：“今世尊住王舍城那伽山侧，与千比丘俱，皆是阿罗汉，诸漏已尽，所作已作，离诸重担，逮得己利，尽诸有结，正智心善解脱。我今当往，各别赞叹世尊及比丘僧。”作是念已，即往诣佛所，稽首礼足，退住一面，而说偈言：

“无上之导师，住那伽山侧，
千比丘眷属，奉事于如来。
大师广说法，清凉涅槃道，
专听清白法，正觉之所说。
正觉尊所敬，处于大众中，
德阴之大龙，仙人之上首，
兴功德密云，普雨声闻众。
起于昼正受，来奉觐大师，
弟子婆耆舍，稽首而顶礼！

    “世尊，欲有所说！唯然善逝，欲有所说！”
    佛告婆耆舍：“随汝所说，莫先思惟。”
    时婆耆舍即说偈言：

“波旬起微恶，潜制令速灭，
能掩障诸魔，令自觉知过。
观察解结缚，分别清白法，
明照如日月，为诸异道王。
超出智作证，演说第一法，
出烦恼诸流，说道无量种。
建立于甘露，见谛真实法，
如是随顺道，如是师难得，
建立甘露道，见谛崇远离。
世尊善说法，能除人阴盖，
明见于诸法，为调伏随学。”

    尊者婆耆舍说是偈已，诸比丘闻其所说，皆大欢喜。

（一二二○）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊为比丘众说四圣谛相应法，谓此苦圣谛、此苦集圣谛、此苦灭圣谛、此苦灭道迹圣谛。
    时尊者婆耆舍在会中，作是念：“我今当于世尊面前，赞叹《拔箭之譬》。”如是念已，即从座起，整衣服，合掌白佛言：“唯然世尊，欲有所说！唯然善逝，欲有所说！”
    佛告婆耆舍：“随所乐说。”
    时尊者婆耆舍即说偈言：

“我今敬礼佛，哀愍诸众生，
第一拔利箭，善解治众病。
迦露医投药，波睺罗治药，
及彼瞻婆耆，耆婆医疗病，
或有病小瘥，名为善治病，
后时病还发，抱病遂至死。
正觉大医王，善投众生药，
究竟除众苦，不复受诸有。
乃至百千种，那由他病数，
佛悉为疗治，究竟于苦边。
诸医来会者，我今悉告汝，
得甘露法药，随所乐而服。
第一拔利箭，善觉知众病，
治中之最上，故稽首瞿昙！”

    尊者婆耆舍说是语时，诸比丘闻其所说，皆大欢喜。

（一二二一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有尊者尼拘律想，住于旷野禽兽之处，疾病委笃。尊者婆耆舍为看病人，瞻视供养。彼尊者尼拘律想以疾病故，遂般涅槃。
    时尊者婆耆舍作是念：“我和尚为有余涅槃？无余涅槃？我今当求其相。”
    尔时尊者婆耆舍，供养尊者尼拘律想舍利已，持衣钵，向王舍城。次第到王舍城，举衣钵，洗足已，诣佛所，稽首礼足，退住一面，而说偈言：

“我今礼大师，等正觉无减，
于此现法中，一切疑网断。
旷野住比丘，命终般涅槃，
威仪摄诸根，大德称于世，
世尊为制名，名尼拘律想。
我今问世尊，彼不动解脱，
精进勤方便，功德为我说。
我为释迦种，世尊法弟子，
及余皆欲知，圆道眼所说，
我等住于此，一切皆欲闻。
世尊为大师，无上救世间，
断疑大牟尼，智慧已具备，
圆照神道眼，光明显四众，
犹如天帝释，曜三十三天。
诸贪欲疑惑，皆从无明起，
若得遇如来，断灭悉无余。
世尊神道眼，世间为最上，
灭除众生过，如风飘游尘。
一切诸世间，烦恼覆隐没，
诸余悉无有，明目如佛者。
慧光照一切，令同大精进，
唯愿大智尊，当为众记说。
言出微妙声，我等专心听，
柔软音演说，诸世间普闻。
犹如热渴逼，求索清凉水，
如佛无减知，我等亦求知。”

    尊者婆耆舍复说偈言：

“今闻无上士，记说其功德，
不空修梵行，我闻大欢喜。
如说随说得，顺牟尼弟子，
灭生死长縻，虚伪幻化缚。
以见世尊故，能断除诸爱，
度生死彼岸，不复受诸有。”

    佛说此经已，尊者婆耆舍闻佛所说，欢喜随喜，作礼而去。


杂阿含经卷第四十六

（一二二二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过去世时，天、阿修罗对阵斗战，阿修罗胜，诸天不如。时天帝释，军坏退散，极生恐怖，乘车北驰，还归天宫。须弥山下，道径丛林，林下有金翅鸟巢，多有金翅鸟子。尔时帝释恐车马过，践杀鸟子，告御者言：‘可回车还，勿杀鸟子。’御者白王：‘阿修罗军后来逐人，若回还者，为彼所困。’帝释告言：‘宁当回还，为阿修罗杀，不以军众蹈杀众生于道。’御者转乘南向。阿修罗军遥见帝释转乘而还，谓为战策，即还退走，众大恐怖，坏阵流散，归阿修罗宫。”
    佛告诸比丘：“彼天帝释于三十三天为自在王，以慈心故，威力摧伏阿修罗军，亦常赞叹慈心功德。汝等比丘，正信非家，出家学道，当修慈心，亦应赞叹慈心功德。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二二三）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时王舍城中有一士夫，贫穷辛苦，而于佛、法、僧受持禁戒，多闻广学，力行惠施，正见成就。彼身坏命终，得生天上，生三十三天，有三事胜于余三十三天。何等为三？一者天寿，二者天色，三者天名称。
    诸三十三天见是天子三事特胜，天寿、天色、天名称，胜余诸天。见已往诣天帝释所，作如是言：“憍尸迦当知，有一天子始生此天，于先诸天三事特胜，天寿、天色及天名称。”
    时天帝释告彼天子：“诸仁者，我见此人于王舍城作一士夫，贫穷辛苦，于如来法律得信向心，乃至正见成就。身坏命终，来生此天，于诸三十三天三事特胜，天寿、天色及天名称。”
    时天帝释即说偈言：

“正信于如来，决定不倾动，
受持真实戒，圣戒无厌者。
于佛心清净，成就于正见，
当知非贫苦，不空而自活。
故于佛法僧，当生清净信，
智慧力增明，思念佛正教。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二二四）

    如是我闻。一时佛住王舍城耆阇崛山中。
    尔时王舍城人普设大会，悉为请种种异道。有事遮罗迦外道者作是念：“我今请遮罗迦外道天先作福田。”或有事外道出家者，有事尼乾子道者，有事老弟子者，有事火弟子者。有事佛弟子僧者，咸作是念：“今当令佛面前僧先作福田。”
    时天帝释作是念：“莫令王舍城诸人，舍佛面前僧，而奉事余道，求索福田。我当疾往，为王舍城人建立福田。”即化作大婆罗门，仪容严整，乘白马车，诸年少婆罗门众前后导从，持金斗伞盖，至王舍城，诣诸处处大众会中。诸王舍城一切士女咸作是念：“但当观望此大婆罗门所奉事处，我当从彼而先供养，为良福田。”
    时天帝释知王舍城一切士女心之所念，驾乘导从，径诣耆阇崛山，至于门外，除去五饰，往诣佛所，稽首佛足，退坐一面，而说偈言：

“善分别显示，一切法彼岸，
悉度诸恐怖，故稽首瞿昙！
诸人普设会，欲求大功德，
各各设大施，常愿有余果。
愿为说福田，令斯施果成。”
帝释大自在，天王之所问，
于耆阇崛山，大师为记说：
“诸人普设会，欲求大功德，
各各设大施，常愿有余果。
今当说福田，施得大果处：
正向者有四，四圣住于果，
是名僧福田，明行定具足。
僧福田增广，无量逾大海，
调人师弟子，照明显正法，
斯等善供养，施僧良福田。
于僧良福田，佛说得大果，
以僧离五盖，清净应赞叹。
施彼最上田，少施收大利，
是故诸人者，当施僧福田。
增得胜妙法，明行定相应，
供此珍宝僧，施主心欢喜，
起于三种心，施衣服饮食，
离尘垢剑刺，超度诸恶趣。
躬自行启请，自手平等与，
自利亦利他，是施获大利。
慧者如是施，净信心解脱，
无罪安乐施，乘智往生彼。”

    时天帝释闻佛所说，欢喜随喜，为佛作礼，即没不现。
    尔时王舍城诸人民，即从座起，整衣服，为佛作礼，合掌白佛言：“世尊，唯愿世尊与诸大众，受我供养。”
    尔时世尊默然受请。
    是王舍城人民知世尊默然受其请已，作礼而归。到诸大会处，具饮食，布置床座，晨朝遣使，白佛：“时到，唯愿知时。”
    尔时世尊与诸大众，着衣持钵，至大会所，于大众前敷座而坐。王舍城人知佛坐定，自行种种丰美饮食。食讫，洗钵澡漱毕，还复本座，听佛说法。
    尔时世尊为王舍城人种种说法，示教照喜已，从座起而去。

（一二二五）

    如是我闻。一时佛住王舍城耆阇崛山中。
    广说如上说，差别者：时天帝释说异偈，而问佛言：

“今请问瞿昙，微密深妙慧，
世尊之所体，无障碍知见。”

    “众人普设会”偈，如上广说。
    乃至为王舍城诸设会者，说种种法，示教照喜已，从座起去。

（一二二六）

    如是我闻。一时佛在拘萨罗人间游行，至舍卫国祇树给孤独园。
    时波斯匿王，闻世尊拘萨罗人间游行，至舍卫国祇树给孤独园。闻已往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我闻世尊自记说成阿耨多罗三藐三菩提。诸人传者，得非虚妄过长说耶？为如说说、如法说、随顺法说耶？非是他人损同法者，于其问答生厌薄处耶？”
    佛告大王：“彼如是说，是真谛说，非为虚妄。如说说、如法说、随顺法说，非是他人损同法者，于其问答生厌薄处。所以者何？大王，我今实得阿耨多罗三藐三菩提故。”
    波斯匿王白佛言：“虽复世尊作如是说，我犹故不信。所以者何？此间有诸宿重沙门、婆罗门，所谓富兰那迦叶、末迦利瞿舍梨子、删阇耶毗罗胝子、阿耆多枳舍钦婆罗、迦罗拘陀迦栴延、尼乾陀若提子，彼等不自说言得阿耨多罗三藐三菩提。何得世尊幼小年少，出家未久，而便自证得阿耨多罗三藐三菩提？”
    佛告大王：“有四种虽小而不可轻。何等为四？刹利王子年少幼小而不可轻，龙子年少幼小而不可轻，小火虽微而不可轻，比丘幼小而不可轻。”
    尔时世尊即说偈言：

“刹利形相具，贵族发名称，
虽复年幼稚，智者所不轻，
此必居王位，顾念生怨害，
是故难可轻，应生大恭敬；
善求自护者，自护如护命，
以平等自护，而等护于命。
聚落及空处，见彼幼龙者，
莫以小蛇故，而生轻慢想，
杂色小龙形，亦应令安乐，
轻蛇无士女，悉为毒所害；
是故自护者，当如护己命，
以斯善护己，而等护于彼。
猛火之所食，虽小食无限，
小烛亦能烧，足薪则弥广，
从微渐进烧，尽聚落城邑；
是故自护者，当如护己命，
以斯善护己，而等护于彼。
盛火之所焚，百卉荡烧尽，
灭已不盈缩，戒火还复生。
若轻毁比丘，受持净戒火，
烧身及子孙，众灾流百世，
如烧多罗树，无有生长期；
是故当自护，如自护己命，
以斯善自护，而等护于彼。
刹利形相具，幼龙及小火，
比丘具净戒，不应起轻想；
是故当自护，如自护己命，
以斯善自护，而等护于彼。”

    佛说此经已，波斯匿王闻佛所说，欢喜随喜，作礼而去。

（一二二七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时波斯匿王有祖母，极所敬重，忽尔命终。出城阇维，供养舍利毕，弊衣乱发，来诣佛所，稽首佛足，退坐一面。
    尔时世尊告波斯匿王：“大王！从何所来，弊衣乱发？”
    波斯匿王白佛：“世尊，我亡祖母，极所敬重，舍我命终。出城于外阇维供养毕，来诣世尊。”
    佛告大王：“极爱重敬念祖亲耶？”
    波斯匿王白佛：“世尊，极敬重爱恋。世尊，若国土所有象马七宝，乃至国位，悉持与人，能救祖母命者，悉当与之。既不能救，生死长辞，悲恋忧苦，不自堪胜！曾闻世尊所说，一切众生、一切虫、一切神，生者皆死，无不穷尽，无有出生而不死者。今日乃知世尊善说。”
    佛言：“大王，如是如是，一切众生、一切虫、一切神，生者辄死，终归穷尽，无有一生而不死者。”
    佛告大王：“正使婆罗门大姓、刹利大姓、长者大姓，生者皆死，无不死者。正使刹利大王，灌顶居位，王四天下，得力自在，于诸敌国无不降伏，终归有极，无不死者。若复大王，生长寿天，王于天宫，自在快乐，终亦归尽，无不死者。若复大王，阿罗汉比丘诸漏已尽，离诸重担，所作已作，逮得己利，尽诸有结，正智心善解脱，彼亦归尽，舍身涅槃。若复缘觉，善调善寂，尽此身命，终归涅槃。诸佛世尊，十力具足，四无所畏，胜狮子吼，终亦舍身，取般涅槃。以如是比，大王当知，一切众生、一切虫、一切神，有生辄死，终归磨灭，无不死者。”
    尔时世尊复说偈言：

“一切众生类，有命终归死，
各随业所趣，善恶果自受。
恶业堕地狱，为善上升天，
修习胜妙道，漏尽般涅槃。
如来及缘觉，佛声闻弟子，
会当舍身命，何况俗凡夫。”

    佛说此经已，波斯匿王闻佛所说，欢喜随喜，作礼而去。

（一二二八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时波斯匿王独一静处，禅思思惟，作是念：“云何为自念？云何为不自念？”
    复作是念：“若有行身恶行、行口恶行、行意恶行者，当知斯等为不自念。若复行身善行、行口善行、行意善行者，当知斯等则为自念。”
    从禅觉已，往诣佛所，稽首佛足，退住一面，白佛言：“世尊，我于静处独一思惟，作是念：云何为自念？云何为不自念？复作是念：若有行身恶行、行口恶行、行意恶行者，当知斯等为不自念。若复行身善行、行口善行、行意善行者，当知斯等则为自念。”
    佛告大王：“如是大王，如是大王。若有行身恶行、行口恶行、行意恶行者，当知斯等为不自念。彼虽自谓为自爱念，而实非自念。所以者何？无有恶知识所作恶，不念者所不念，不爱者所不爱所作，如其自为自己所作者，是故斯等为不自念。若复大王，行身善行、行口善行、行意善行者，当知斯等则为自念。斯等自谓不自爱惜己身，然其斯等实为自念。所以者何？无有善友于善友所作，念者念作，爱者爱作，如自为己所作者，是故斯等则为自念。”
    尔时世尊复说偈言：

“谓为自念者，不应造恶行，
终不因恶行，令己得安乐。
谓为自念者，终不造恶行，
造诸善业者，令己得安乐。
若自爱念者，善护而自护，
如善护国王，外防边境城。
若自爱念者，极善自宝藏，
如善守之王，内防边境城。
如是自宝藏，刹那无间缺，
刹那缺致忧，恶道长受苦。”

    佛说此经已，波斯匿王闻佛所说，欢喜随喜，作礼而去。

（一二二九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时波斯匿王独静思惟，作如是念：“云何自护？云何不自护？”
    复作是念：“若有行身恶行、行口恶行、行意恶行者，当知斯等为不自护。若复行身善行、行口善行、行意善行者，当知斯等则为自护。”
    从禅觉已，往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我独静思惟，而作是念：云何为自护？云何为不自护？复作是念：若有行身恶行、行口恶行、行意恶行者，当知斯等为不自护。若复行身善行、行口善行、行意善行者，当知斯等则为自护。”
    佛告大王：“如是大王，如是大王。若有行身恶行、行口恶行、行意恶行者，当知斯等为不自护，而彼自谓能自防护。象军、马军、车军、步军，以自防护，虽谓自护，实非自护。所以者何？虽护于外，不护于内，是故大王，名不自护。大王，若复有行身善行、行口善行、行意善行者，当知斯等则为自护。彼虽不以象、马、车、步四军自防，而实自护。所以者何？护其内者，名善自护，非谓防外。”
    尔时世尊复说偈言：

“善护于身口，及意一切业，
惭愧而自防，是名善守护。”

    时波斯匿王闻佛所说，欢喜随喜，作礼而去。

（一二三○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时波斯匿王独静思惟，作是念：“世少有人得胜妙财利，能不放逸，能不贪著，能于众生不起恶行。世多有人得胜妙财利，起于放逸，增其贪著，起诸邪行。”作是念已，往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我独静思惟，作是念：世间少有人得胜妙财，能于财利不起放逸，不起贪著，不作邪行。世多有人得胜妙财，而起放逸，生于贪著，多起邪行。”
    佛告波斯匿王：“如是大王，如是大王。世少有人得胜妙财利，能不贪著，不起放逸，不起邪行。世多有人得胜妙财利，于财放逸，而起贪著，起诸邪行。大王当知，彼诸世人得胜财利，于财放逸，而起贪著，作邪行者，是愚痴人长夜当得不饶益苦。大王，譬如猎师、猎师弟子，空野林中，张网施罥，多杀禽兽，困苦众生，恶业增广。如是世人得胜妙财利，于财放逸，而起贪著，造诸邪行，亦复如是，是愚痴人长夜当得不饶益苦。”
    尔时世尊复说偈言：

“贪欲于胜财，为贪所迷醉，
狂乱不自觉，犹如捕猎者，
缘斯放逸故，当受大苦报。”

    佛说此经已，波斯匿王闻佛所说，欢喜随喜，作礼而去。

（一二三一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时波斯匿王，于正殿上，自观察王事，见胜刹利大姓，见胜婆罗门大姓，见胜长者大姓，因贪欲故，欺诈妄语。即作是念：“止此断事，息此断事，我更不复亲临断事！我有贤子，当令断事。云何自见此胜刹利大姓、婆罗门大姓、长者大姓，为贪欲故，欺诈妄语！”
    时波斯匿王作是念已，往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我于殿上自断王事，见诸胜刹利大姓、婆罗门大姓、长者大姓，为贪利故，欺诈妄语。世尊，我见是事已，作是念：我从今日，止此断事，息此断事。我有贤子，当令其断，不亲自见此胜刹利大姓、婆罗门大姓、长者大姓，缘贪利故，欺诈妄语。”
    佛告波斯匿王：“如是大王，如是大王。彼胜刹利大姓、婆罗门大姓、长者大姓，因贪利故，欺诈妄语，彼愚痴人长夜当得不饶益苦。大王当知，譬如渔师、渔师弟子，于河溪谷，截流张网，残杀众生，令遭大苦。如是大王，彼胜刹利大姓、婆罗门大姓、长者大姓，因贪利故，欺诈妄语，长夜当得不饶益苦。”
    尔时世尊复说偈言：

“于财起贪欲，贪欲所迷醉，
狂乱不自觉，犹如渔捕者，
缘斯恶业故，当受剧苦报。”

    佛说此经已，波斯匿王闻佛所说，欢喜随喜，作礼而去。

（一二三二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时波斯匿王来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，此舍卫国有长者名摩诃男，多财巨富，藏积真金至百千亿，况复余财。世尊，摩诃男长者如是巨富，作如是食用：食粗碎米，食豆羹，食腐败姜，着粗布衣，单皮革屣，乘羸败车，戴树叶盖。未曾闻其供养施与沙门、婆罗门，给恤贫苦、行路顿乏、诸乞丐者。闭门而食，莫令沙门、婆罗门、贫穷、行路、诸乞丐者见之。”
    佛告波斯匿王：“此非正士，得胜财利，不自受用，不知供养父母，供给妻子、宗亲、眷属，恤诸仆使，施与知识。不知随时供诸沙门、婆罗门，种胜福田，崇向胜处，长受安乐，未来生天。得胜财物，不知广用，收其大利。大王，譬如旷野，湖池聚水，无有受用、洗浴、饮者，即于泽中，煎熬消尽。如是不善士夫得胜财物，乃至不广受用，收其大利，如彼池水。
    “大王，有善男子得胜财利，快乐受用，供养父母，供给妻子、宗亲、眷属，给恤仆使，施诸知识，时时供养沙门、婆罗门，种胜福田，崇向胜处，未来生天。得胜钱财，能广受用，倍收大利。譬如大王，聚落城郭边有池水，澄净清凉，树林荫覆，令人受乐，多众受用，乃至禽兽。如是善男子得胜妙财，自供快乐，供养父母，乃至种胜福田，广收大利。”
    尔时世尊复说偈言：

“旷野湖池水，清凉极鲜净，
无有受用者，即于彼消尽。
如是胜妙财，恶士夫所得，
不能自受用，亦不供恤彼，
徒自苦积聚，聚已而自丧。
慧者得胜财，能自乐受用，
广施作功德，及与亲眷属，
随所应给与，如牛王领众。
施与及受用，不失所应者，
乘理而寿终，生天受福乐。”

    佛说此经已，波斯匿王闻佛所说，欢喜随喜，作礼而去。

（一二三三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时舍卫国有长者名摩诃男，命终无有儿息。
    波斯匿王以无子无亲属之财，悉入王家。
    波斯匿王日日校阅财物，身蒙尘土，来诣佛所，稽首佛足，退坐一面。
    尔时世尊告波斯匿王：“大王从何所来，身蒙尘土，似有疲倦？”
    波斯匿王白佛：“世尊，此国长者摩诃男命终，有无子之财，悉入王家。瞻视料理，致令疲劳，尘土坌身，从其舍来。”
    佛问波斯匿王：“彼摩诃男长者，大富多财耶？”
    波斯匿王白佛：“大富，世尊。钱财甚多，百千巨亿金银宝物，况复余财！世尊，彼摩诃男在世之时，粗衣恶食。”如上广说。
    佛告波斯匿王：“彼摩诃男过去世时，遇多迦罗尸弃辟支佛，施一饭食，非净信心，不恭敬与，不自手与，施后变悔，言：‘此饮食自可供给我诸仆使，无辜持用施于沙门。’由是施福，七反往生三十三天，七反生此舍卫国中最胜族姓，最富钱财。以彼施辟支佛时，不净信心，不手自与，不恭敬与，施后随悔故，在所生处，虽得财富，犹故受用粗衣粗食、粗弊卧具、屋舍、车乘，初不尝得上妙色、声、香、味、触，以自安身。
    “复次大王，时彼摩诃男长者，杀其异母兄，取其财物，缘斯罪故，经百千岁堕地狱中。彼余罪报生舍卫国，七反受身，常以无子财，没入王家。大王，摩诃男长者今此寿终，过去施报尽于此身。以彼悭贪，于财放逸，因造过恶，于此命终，已堕地狱，受极苦恼。”
    波斯匿王白佛言：“世尊，摩诃男长者命终，已入地狱受苦痛耶？”
    佛言：“如是大王，已入地狱。”
    时波斯匿王念彼垂泣，以衣拭泪，而说偈言：

“财物真金宝，象马庄严具，
奴仆诸僮使，及诸田宅等，
一切皆遗弃，裸神独游往，
福运数已穷，永舍于人身。
彼今何所有，何所持而去？
于何事不舍，如影之随形？”

    尔时世尊说偈答言：

“唯有罪福业，若人已作者，
是则己之有，彼则常持去，
生死未曾舍，如影之随形。
如人少资粮，涉远遭苦难，
不修功德者，必经恶道苦。
如人丰资粮，安乐以远游，
修德淳厚者，善趣长受乐。
如人远游行，岁久安隐归，
宗亲善知识，欢乐欣集会。
善修功德者，此没生他世，
彼诸亲眷属，见则心欢喜。
是故当修福，积集期永久，
福德能为人，建立他世乐。
福德天所叹，等修正行故，
现世人不毁，终则生天上。”

    佛说此经已，波斯匿王闻佛所说，欢喜随喜，作礼而去。

（一二三四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时波斯匿王普设大会，为大会故，以千特牛行列系柱，集众供具，远集一切诸异外道，悉来聚集波斯匿王大会之处。
    时有众多比丘，亦晨朝着衣持钵，入舍卫城乞食，闻波斯匿王普设大会，如上广说，乃至种种外道皆悉来集。闻已，乞食毕，还精舍，举衣钵，洗足已，往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我等今日众多比丘，晨朝着衣持钵，入舍卫城乞食，闻波斯匿王普设大会，如上广说，乃至种种异道集于会所。”
    尔时世尊即说偈言：

“日日设大会，乃至百千数，
不如正信佛，十六分之一。
如是信法僧，慈念于众生，
彼大会之福，十六不及一。
若人于世间，亿年设福业，
于真心敬礼，四分不及一。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二三五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时波斯匿王，忿诸国人，多所囚执。若刹利、若婆罗门、若鞞舍、若首陀罗、若旃陀罗，持戒、犯戒、在家、出家，悉皆被录，或锁、或杻械、或以绳缚。
    时有众多比丘，晨朝着衣持钵，入舍卫城乞食，闻波斯匿王多所摄录，乃至或锁、或缚。乞食毕，还精舍，举衣钵，洗足已，往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我等今日众多比丘入城乞食，闻波斯匿王多所收录，乃至锁缚。”
    尔时世尊即说偈言：

“非绳锁杻械，名曰坚固缚；
染污心顾念，钱财宝妻子，
是缚长且固，虽缓难可脱。
慧者不顾念，世间五欲乐，
是则断诸缚，安隐永超出。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二三六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时波斯匿王、摩竭提国阿阇世王韦提希子，共相违背。摩竭提王阿阇世韦提希子起四种军，象军、马军、车军、步军，来至拘萨罗国。波斯匿王闻阿阇世王韦提希子四种军至，亦集四种军，象军、马军、车军、步军，出共斗战。阿阇世王四军得胜，波斯匿王四军不如，退败星散，单车驰走，还舍卫城。
    时有众多比丘，晨朝着衣持钵，入舍卫城乞食，闻摩竭提王阿阇世韦提希子起四种军，来至拘萨罗国。波斯匿王起四种军出共斗战，波斯匿王四军不如，退败星散，波斯匿王恐怖狼狈，单车驰走，还舍卫城。闻已，乞食毕，还精舍，举衣钵，洗足已，往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我等今日众多比丘入城乞食，闻摩竭提王阿阇世王韦提希子起四种军，如是广说，乃至单车驰走，还舍卫城。”
    尔时世尊即说偈言：

“战胜增怨敌，败苦卧不安，
胜败二俱舍，卧觉寂静乐。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二三七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时波斯匿王与摩竭提王阿阇世韦提希子共相违背。摩竭提王阿阇世韦提希子起四种军，来至拘萨罗国。波斯匿王倍兴四军，出共斗战。波斯匿王四种军胜，阿阇世王四种军退，摧伏星散。波斯匿王悉皆虏掠阿阇世王象、马、车乘、钱财、宝物，生擒阿阇世王身，载以同车，俱诣佛所，稽首佛足，退坐一面。
    波斯匿王白佛言：“世尊，此是阿阇世王韦提希子，长夜于我无怨恨人而生怨结，于好人所而作不好。然其是我善友之子，当放令还国。”
    佛告波斯匿王：“善哉大王！放其令去，令汝长夜安乐饶益。”
    尔时世尊即说偈言：

“乃至力自在，能广虏掠彼，
助怨在力增，倍收己他利。”

    佛说此经已，波斯匿王及阿阇世王韦提希子闻佛所说，欢喜随喜，作礼而去。

（一二三八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时波斯匿王独静思惟，作是念：“世尊正法，现法离诸炽然，不待时节，通达现见，自觉证知。此法是善知识、善伴党，非是恶知识、恶伴党。”作是念已，往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我独静思惟，作是念：世尊正法，现法离诸炽然，不待时节，通达现见，自觉证知，是则善知识、善伴党，非恶知识、恶伴党。”
    佛告波斯匿王：“如是大王，如是大王。世尊正法律，现法离诸炽然，不待时节，通达现见，缘自觉知，是则善知识、善伴党，非恶知识、恶伴党。所以者何？我为善知识，众生有生法者，解脱于生。众生有老、病、死、忧悲恼苦者，悉令解脱。
    “大王，我于一时，住王舍城山谷精舍。时阿难陀比丘独静思惟，作是念：‘半梵行者是善知识、善伴党，非恶知识、恶伴党。’作是念已，来诣我所，稽首我足，退坐一面，白我言：‘世尊，我独静思惟，作是念：半梵行者是善知识、善伴党，非恶知识、恶伴党。’
    “我时告言：‘阿难，莫作是语，半梵行者是善知识、善伴党，非恶知识、恶伴党。所以者何？纯一满净，梵行清白，谓善知识、善伴党，非恶知识、恶伴党。所以者何？我常为诸众生作善知识，其诸众生有生故，当知世尊正法，现法令脱于生；有老、病、死、忧悲恼苦者，离诸炽然，不待时节，现令脱恼苦，见通达，自觉证知，是则善知识、善伴党，非恶知识、恶伴党。”
    尔时世尊即说偈言：

“赞叹不放逸，是则佛正教，
修禅不放逸，逮得证诸漏。”

    佛说此经已，波斯匿王闻佛所说，欢喜随喜，作礼而去。

（一二三九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时波斯匿王独静思惟，作是念：“颇有一法修习多修习，得现法愿满足，后世愿满足，现法、后世愿满足不？”作是念已，往诣佛所，稽首佛足，退坐一面，白佛言：“世尊，我独静思惟，作是念：颇有一法修习多修习，得现法愿满足、后世愿满足、现法后世愿满足不？”
    佛告波斯匿王：“如是大王，如是大王，有一法修习多修习，得现法愿满足，得后世愿满足，得现法、后世愿满足，谓不放逸善法。不放逸善法，修习多修习，得现法愿满足，得后世愿满足，得现法、后世愿满足。大王，譬如世间所作粗业，彼一切皆依于地而得建立。不放逸善法，亦复如是，修习多修习，得现法愿满足，得后世愿满足，得现法、后法愿满足。如力，如是种子、根、坚、陆、水、足行、狮子、舍宅，亦如是说。
    “是故大王，当住不放逸，当依不放逸。住不放逸、依不放逸已，夫人当作是念：‘大王住不放逸、依不放逸，我今亦当如是住不放逸、依不放逸。’如是夫人，如是大臣、太子、猛将亦如是。国土人民应当念：‘大王住不放逸、依不放逸，夫人、太子、大臣、猛将住不放逸、依不放逸，我等亦应如是住不放逸、依不放逸。’大王，若住不放逸、依不放逸者，则能自护夫人、婇女，亦能自保库藏财宝，增长丰实。”
    尔时世尊即说偈言：

“称誉不放逸，毁訾放逸者，
帝释不放逸，能主忉利天。
称誉不放逸，毁訾放逸者，
不放逸具足，摄持于二义，
一者现法利，二后世亦然，
是名无间等，甚深智慧者。”

    佛说此经已，波斯匿王闻佛所说，欢喜随喜，作礼而去。

（一二四○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时波斯匿王独静思惟，作是念：“此有三法，一切世间所不爱念。何等为三？谓老、病、死。如是三法，一切世间所不爱念。若无此三法，世间所不爱者，诸佛世尊不出于世，世间亦不知有诸佛如来所觉知法，为人广说。以有此三法，世间所不爱念，谓老、病、死故，诸佛如来出兴于世，世间知有诸佛如来所觉知法，广宣说者。”波斯匿王作是念已，来诣佛所，稽首佛足，退坐一面，以其所念，广白世尊。
    佛告波斯匿王：“如是大王，如是大王。此有三法，世间所不爱念，谓老、病、死。乃至世间知有如来所觉知法，为人广说。”
    尔时世尊复说偈言：

“王所乘宝车，终归有朽坏，
此身亦复然，迁移会归老。
唯如来正法，无有衰老相，
禀斯正法者，永到安隐处。
恒凡鄙衰老，丑弊恶形类，
衰老来践蹈，迷魅愚夫心。
若人寿百岁，常虑死随至，
老病竞追逐，伺便辄加害。”

    佛说此经已，波斯匿王闻佛所说，欢喜随喜，作礼而去。


杂阿含经卷第四十七

（一二四一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时给孤独长者来诣佛所，稽首佛足，退坐一面，白佛言：“世尊，若有人在我舍者，皆得净信。诸在我舍而命终者，皆得生天。”
    佛言：“善哉善哉！长者，是深妙说，是一向受，于大众中作狮子吼言：‘在我舍者，皆得净信；及其命终，皆生天上。’有何大德神力比丘为汝说言，凡在汝舍命终者，皆生天上耶？”
    长者白佛：“不也，世尊。”
    复问：“云何为比丘尼、为诸天、为从我所面前闻说？”
    长者白佛：“不也，世尊。”
    “云何长者，汝缘自知见，知在我舍命终者，皆生天上耶？”
    长者白佛：“不也，世尊。”
    佛告长者：“汝既不从大德神力比丘所闻，非比丘尼，非诸天，又不从我面前闻说，复不缘自见知，若有诸人于我舍命终者，皆生天上。汝今何由能作如是甚深妙说，作一向受，于大众中作狮子吼，而作是言：有人于我舍命终者，皆生天上。”
    长者白佛：“无有比丘大德神力而来告我，如上广说，乃至悉皆生天。世尊，然我见众生主怀妊之时，我即教彼为其子故，归佛、归法、归比丘僧；及其生已，复教三归；及生知见，复教持戒。设复婢使、下贱客人怀妊及生，亦如是教。若人卖奴婢者，我辄往彼语言：‘贤者，我欲买人。汝当归佛、归法、归比丘僧，受持禁戒。’随我教者，辄授五戒，然后随价而买；不随我教，则所不取。若复止客、若佣作人，亦复先要受三归五戒，然后受之。若复有来求为弟子，若复乞贷举息，我悉要以三归五戒，然后受之。又复我舍供养佛及比丘僧时，称父母名，兄弟、妻子、宗亲、知识、国王、大臣、诸天、龙神，若存若亡，沙门、婆罗门，内外眷属，下至仆使，皆称其名，而为咒愿。又从世尊闻称名咒愿因缘，皆得生天。或因园田布施，或因房舍，或因床卧具，或因常施，或施行路，下至一抟施与众生，此诸因缘皆生天上。”
    佛言：“善哉善哉！长者，汝以信心，故能作是说。如来于彼有无上知见，审知汝舍有人命终，皆悉生天。”
    尔时给孤独长者闻佛所说，欢喜随喜，作礼而去。

（一二四二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“当恭敬住，常当系心，常当畏慎，随他自在诸修梵行上中下座。所以者何？若有比丘不恭敬住，不系心，不畏慎，不随他自在诸修梵行上中下座，而欲令威仪足者，无有是处。不备威仪，欲令学法满者，无有是处。学法不满，欲令戒身、定身、慧身、解脱身、解脱知见身具足者，无有是处。解脱知见不满足，欲令得无余涅槃者，无有是处。
    “如是比丘，当勤恭敬、系心、畏慎，随他德力诸修梵行上中下座，而威仪具足者，斯有是处。威仪具足已，而学法具足者，斯有是处。学法备足已，而戒身、定身、慧身、解脱身、解脱知见身具足者，斯有是处。解脱知见身具足已，得无余涅槃者，斯有是处。是故比丘，当勤恭敬、系心、畏慎，随他德力诸修梵行上中下座，威仪满足，乃至无余涅槃，当如是学！”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二四三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有二净法，能护世间。何等为二？所谓惭、愧。假使世间无此二净法者，世间亦不知有父母、兄弟、姊妹、妻子、宗亲、师长尊卑之序，颠倒浑乱，如畜生趣。以有二种净法，所谓惭、愧，是故世间知有父母，乃至师长尊卑之序，则不浑乱，如畜生趣。”
    尔时世尊即说偈言：

“世间若无有，惭愧二法者，
违越清净道，向生老病死。
世间若成就，惭愧二法者，
增长清净道，永闭生死门。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二四四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“有烧燃法、不烧燃法，谛听善思，当为汝说。
    “云何烧燃法？若男若女犯戒，行恶不善法，身恶行成就，口、意恶行成就。若彼后时疾病困苦，沉顿床褥，受诸苦毒，当于尔时，先所行恶，悉皆忆念。譬如大山，日西影覆。如是众生先所行恶，身、口、意业诸不善法，临终悉现，心乃追悔：‘咄哉！咄哉！先不修善，但行众恶，当堕恶趣，受诸苦毒！’忆念是已，心生烧燃，心生变悔。心生悔已，不得善心命终，后世亦不善心相续生，是名烧燃法。
    “云何不烧燃？若男子、女人受持净戒，修真实法，身善业成就，口、意善业成就。临寿终时，身遭苦患，沉顿床褥，众苦触身。彼心忆念先修善法，身善行、口、意善行成就，当于尔时攀缘善法：‘我作如是身、口、意善，不为众恶，当生善趣，不堕恶趣。’心不变悔。不变悔故，善心命终，后世续善，是名不烧燃法。”
    尔时世尊即说偈言：

“已种烧燃业，依于非法活，
乘斯恶业行，必生地狱中。
等活及黑绳，众合二叫呼，
烧燃极烧燃，无择大地狱，
是八大地狱，极苦难可过。
恶业种种故，各别十六处，
四周开四门，中间量悉等。
铁为四周板，四门扇亦铁，
铁地盛火燃，其焰普周遍，
纵广百由旬，焰焰无间息。
调伏非诸行，考治强梁者，
长夜加楚毒，其苦难可见，
见者生恐怖，悚栗身毛竖，
堕彼地狱时，足上头向下。
正圣柔和心，修行梵行者，
于此贤圣所，轻心起非义，
及杀害众生，堕斯热地狱。
宛转于火中，犹如火炙鱼，
苦痛号叫呼，如群战象声，
大火自然生，斯由自业故。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二四五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“舍身恶行者，能得身恶行断。不得身恶行断者，我不说彼舍身恶行。以彼能得身恶行断故，是故我说彼舍身恶行。身恶行者，不以义饶益安乐众生。离身恶行，以义饶益得安乐故，是故我说舍身恶行。口、意恶行，亦如是说。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二四六）

    如是我闻。一时佛住王舍城金师住处。
    尔时世尊告诸比丘：“如铸金者，积聚沙土，置于槽中，然后以水灌之，粗上烦恼刚石坚块随水而去，犹有粗沙缠结。复以水灌，粗沙随水流出，然后生金，犹为细沙、黑土之所缠结。复以水灌，细沙黑土随水流出，然后真金纯净无杂，犹有似金微垢。然后金师置于炉中，增火鼓韛，令其融液，垢秽悉除。然其生金犹故不轻不软，光明不发，屈伸则断。彼炼金师、炼金弟子，复置炉中，增火鼓韛，转侧铸炼，然后生金轻软光泽，屈伸不断，随意所作钗、铛、镮、钏诸庄严具。
    “如是净心进向比丘，粗烦恼缠、恶不善业、诸恶邪见，渐断令灭，如彼生金淘去刚石坚块。复次净心进向比丘，次除粗垢，欲觉、恚觉、害觉，如彼生金除粗沙砾。复次净心进向比丘，次除细垢，谓亲里觉、人众觉、生天觉，思惟除灭，如彼生金除去尘垢、细沙、黑土。复次净心进向比丘，有善法觉，思惟除灭，令心清净，犹如生金除去金色相似之垢，令其纯净。复次比丘于诸三昧有行所持，犹如池水周匝岸持，为法所持，不得寂静胜妙，不得息乐，尽诸有漏。如彼金师、金师弟子，铸炼生金，除诸垢秽，不轻不软，不发光泽，屈伸断绝，不得随意成庄严具。复次比丘得诸三昧，不为有行所持，得寂静胜妙，得息乐道，一心一意，尽诸有漏。如炼金师、炼金师弟子，铸炼生金，令其轻软、不断、光泽，屈伸随意。复次比丘离诸觉观，乃至得第二、第三、第四禅，如是正受，纯一清净，离诸烦恼，柔软真实不动。于彼彼入处，欲求作证，悉能得证。如彼金师，铸炼生金，极令轻软、光泽、不断，任作何器，随意所欲。如是比丘三昧正受，乃至于诸入处，悉能得证。”
    佛说此经已，时诸比丘闻佛所说，欢喜奉行。

（一二四七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“应当专心方便，随时思惟三相。云何为三？随时思惟止相、随时思惟举相、随时思惟舍相。若比丘一向思惟止相，则于是处其心下劣。若复一向思惟举相，则于是处掉乱心起。若复一向思惟舍相，则于是处不得正定，尽诸有漏。以彼比丘随时思惟止相、随时思惟举相、随时思惟舍相故，心则正定，尽诸有漏。如巧金师、金师弟子，以生金着于炉中增火，随时扇韛，随时水洒，随时俱舍。若一向鼓韛者，即于是处生金焦尽。一向水洒，则于是处生金坚强。若一向俱舍，则于是处生金不熟，则无所用。是故巧金师、金师弟子，于彼生金随时鼓韛、随时水洒、随时两舍，如是生金得等调适，随事所用。如是比丘专心方便，时时思惟忆念三相，乃至漏尽。”
    佛说是经已，诸比丘闻佛所说，欢喜奉行。

（一二四八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“过去世时，摩竭提国有牧牛者，愚痴无慧。夏末秋初，不善观察恒水此岸，亦不善观恒水彼岸，而驱群牛峻岸而下，峻岸而上，中间洄澓，多起患难。诸比丘，过去世时，摩竭提国有牧牛人，不愚不痴者，有方便慧。夏末秋初，能善观察恒水此岸，亦善观察恒水彼岸，善渡其牛，至平博山谷，好水草处。彼初渡时，先渡大牛能领群者，断其急流。次驱第二多力少牛，随后而渡。然后第三驱羸小者，随逐下流，悉皆次第安隐得渡。新生犊子爱恋其母，亦随其后，得渡彼岸。
    “如是比丘，我说斯譬，当知其义。彼摩竭提牧牛者，愚痴无慧。彼诸六师，富兰那等，亦复如是，习诸邪见，向于邪道。如彼牧牛人愚痴无慧，夏末秋初，不善观察此岸、彼岸，高峻山险，从峻岸下，峻岸而上，中间洄澓，多生患难。如是六师，富兰那等，愚痴无慧，不观此岸，谓于此世；不观彼岸，谓于他世；中间洄澓，谓境诸魔，自遭苦难。彼诸见者，习其所学，亦遭患难。
    “彼摩竭提善牧牛者，不愚不痴，有方便慧，谓如来、应、等正觉。如牧牛者善观此岸，善观彼岸，善渡其牛，于平博山谷，先渡大牛能领群者，横截急流，安渡彼岸。如是我声闻能尽诸漏，乃至自知不受后有，横截恶魔世间贪流，安隐得渡生死彼岸。如摩竭提国善牧牛者，次渡第二多力少牛，截流横渡。如是我诸声闻断五下分结，得阿那含，于彼受生，不还此世，亦复断截恶魔贪流，安隐得渡生死彼岸。如摩竭提国善牧牛者，驱其第三羸小少牛，随其下流，安隐得渡。如是我声闻断三结，贪、恚、痴薄，得斯陀含，一来此世，究竟苦边，横截于彼恶魔贪流，安隐得渡生死彼岸。如摩竭提国善牧牛者，新生犊子爱恋其母，亦随得渡。如是我声闻断三结，得须陀洹，不堕恶趣，决定正向三菩提，七有天人往生，究竟苦边，断截恶魔贪流，安隐得渡生死彼岸。”
    尔时世尊即说偈言：

“此世及他世，明智善显现，
诸魔得未得，乃至于死魔，
一切悉知者，三藐三佛智，
断截诸魔流，破坏令消亡。
开示甘露门，显现正真道，
心常多欣悦，逮得安隐处。”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二四九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“若牧牛人成就十一法者，不能令牛增长，亦不能拥护大群牛，令等安乐。何等为十一？谓不知色、不知相、不去虫、不能覆护其疮、不能起烟、不知择路、不知择处、不知渡处、不知食处、尽搆其乳、不善料理能领群者，是名十一法成就，不能掌护大群牛。
    “如是比丘成就十一法者，不能自安，亦不安他。何等为十一？谓不知色；不知相；不能除其害虫；不覆其疮；不能起烟；不知正路；不知止处；不知渡处；不知食处；尽搆其乳；若有上座多闻耆旧久修梵行，大师所叹，不向诸明智修梵行者，称誉其德，悉令宗敬奉事供养。
    “云何名不知色？诸所有色，彼一切四大及四大造，是名为色不如实知。
    “云何不知相？事业是过相，事业是慧相，是不如实知，是名不知相。
    “云何名不知去虫？所起欲觉，能安不离，不觉不灭；所起瞋恚、害觉，能安不离，不觉不灭，是名不去虫。
    “云何不覆疮？谓眼见色，随取形相，不守眼根，世间贪忧、恶不善法，心随生漏，不能防护；耳、鼻、舌、身、意根，亦复如是，是名不覆其疮。
    “云何不起烟？如所闻，如所受法，不能为人分别显示，是名不起烟。
    “云何不知道？八正道及圣法律，是名为道，彼不如实知，是名不知道。
    “云何不知止处？谓于如来所知法，不得欢喜、悦乐、胜妙、出离饶益，是名不知止处。
    “云何不知渡处？谓彼不知修多罗、毗尼、阿毗昙，不随时往到其所，咨问请受：‘云何为善？云何不善？云何有罪？云何无罪？作何等法为胜非恶？’于隐密法不能开发，于显露法不能广问，于甚深句义自所知者不能广宣显示，是名不知渡处。
    “云何不知放牧处？谓四念处及贤圣法律，是名放牧处，于此不如实知，是名不知放牧处。
    “云何为尽搆其乳？彼刹利、婆罗门长者，自在施与衣被、饮食、床卧、医药、资生众具，彼比丘受者，不知限量，是名尽搆其乳。
    “云何为上座大德多闻耆旧，乃至不向诸胜智梵行者所，称其功德，令其宗重承事供养，令得悦乐？谓比丘不称彼上座，乃至令诸智慧梵行者往诣其所，以随顺身、口、意业，承望奉事，是名不于上座多闻耆旧，乃至令智慧梵行往诣其所，承望奉事，令得悦乐。
    “彼牧牛者成就十一法，堪能令彼群牛增长，拥护群牛，令其悦乐。何等为十一？谓知色、知相，如上清净分说，乃至能领群者，随时料理，令得安乐。是名牧牛者十一事成就，能令群牛增长拥护，令得安乐。
    “如是比丘成就十一法者，能自安乐，亦能安他。何等十一？谓知色、知相，乃至十一，如清净分广说。是名比丘十一事成就，自安安他。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二五○）

    如是我闻。一时佛在拘萨罗人间游行，至一奢能伽罗聚落，住一奢能伽罗林中。
    时有尊者那提迦，旧住一奢能伽罗聚落。
    一奢能伽罗聚落沙门、婆罗门，闻沙门瞿昙，拘萨罗国人间游行，至一奢能伽罗聚落，住一奢能伽罗林中。闻已各办一釜食，着门边，作是念：“我先供养世尊，我先供养善逝。”各各高声大声，作如是唱。
    尔时世尊闻园林内有多人众，高声大声，语尊者那提迦：“何因何缘，园林内有众多人，高声大声，唱说之声？”
    尊者那提迦白佛言：“世尊，此一奢能伽罗聚落，诸刹利、婆罗门长者，闻世尊住此林中，各作一釜食，置园林内，各自唱言：‘我先供养世尊！我先供养善逝！’以是故，于此林中，多人高声大声，唱说之声。唯愿世尊，当受彼食。”
    佛告那提迦：“莫以利我，我不求利。莫以称我，我不求称。那提迦，若于如来，如是便得出要、远离、寂灭、等正觉乐者，则于彼彼所起利乐，若味若求。那提迦，唯我于此像类，得出要、远离、寂灭、等正觉乐，不求而得，不苦而得。于何彼彼所起利乐，若味若求？那提迦，汝等于如此像类色，不得出要、远离、寂灭、等正觉乐故，不得不求之乐、不苦之乐。那提迦，天亦不得如是像类出要、远离、寂灭、等正觉乐、不求之乐、不苦之乐。唯有我得如是像类出要、远离、寂灭、等正觉乐、不求之乐、不苦之乐。于何彼彼所起利乐，若味若求？”
    那提迦白佛言：“世尊，我今欲说譬。”
    佛告那提迦：“宜知是时。”
    那提迦白佛言：“世尊，譬如天雨，水流顺下。随其彼彼世尊住处，于彼彼处，刹利、婆罗门长者，信敬奉事，以世尊戒德清净，正见真直。是故我今作如是说：唯愿世尊，哀受彼请！”
    佛告那提迦：“莫以利我，我不求利。乃至云何于彼彼所起利乐，有味有求？那提迦，我见比丘食好食已，仰腹而卧，急喘长息。我见已作是思惟：‘如此长老，不得出要、远离、寂灭、等正觉乐、不求之乐、不苦之乐。’复次那提迦，我见此有二比丘，食好食已，饱腹喘息，偃阐而行。我作是念：‘非彼长老能得出要、远离、寂灭、等正觉之乐、不求之乐、不苦之乐。’那提迦，我见众多比丘食好食已，从园至园，从房至房，从人至人，从群聚至群聚。我见是已，而作是念：‘非彼长老如是能得出要、远离、寂灭、等正觉乐、不求之乐、不苦之乐。我得如是像类出要、远离、寂灭、等正觉乐、不求之乐、不苦之乐。’
    “复次那提迦，我于一时随道行，见有比丘于前远去，复有比丘于后来亦远。我于尔时，闲静无为，亦无有便利之劳。所以者何？依于食饮，乐著滋味，故有便利，此则为依。观五受阴生灭，而厌离住，此则为依。于六触入处观察集灭，厌离而住，此则为依。于群聚之乐，勤习群聚，厌于远离，是则为依。乐修远离，则勤于远离，厌离群聚，是则为依。是故那提迦，当如是学：于五受阴观察生灭，于六触入处观察集灭，乐于远离，精勤远离，当如是学。”
    佛说此经已，尊者那提迦闻佛所说，欢喜随喜，作礼而去。

（一二五一）

    如是我闻。一时佛在拘萨罗人间游行，至那楞伽罗聚落。
    如上广说，乃至彼彼所起求利。
    佛告那提迦：“我见聚落边有精舍，有比丘坐禅。我见已作如是念：‘今此尊者，聚落人此或沙弥，来往声响作乱，障其禅思，觉其正受，于不到欲到、不获欲获、不证欲证，而作留难。’那提迦，我不喜彼比丘住聚落精舍。
    “那提迦，我见比丘住空闲处，仰卧吁咄。我见是已而作是念：‘今彼比丘，觉寤睡眠，思空闲想。’那提迦，我亦不喜如是比丘住空闲处。
    “那提迦，我复见比丘住空闲处，摇身坐睡。见已作是念：‘今此比丘于睡觉寤，不定得定，定心者得解脱。’是故那提迦，我不喜如是比丘住空闲处。
    “那提迦，我复见比丘住空闲处，端坐正受。我见已作是念：‘今此比丘不解脱者，疾得解脱。已解脱者，令自防护，使不退失。’那提迦，我喜如是比丘住空闲处。
    “那提迦，我复见比丘住空闲处，彼于后时远离空处，集舍床卧具，还入聚落受床卧具。那提迦，我亦不喜如是比丘还入聚落。
    “复次那提迦，我见比丘住聚落精舍，名闻大德，能感财利、衣被、饮食、汤药、众具。彼于后时集舍利养、聚落床座，至于空闲，床卧安止。那提迦，我喜如是比丘，集舍利养、聚落床卧，住于空闲。那提迦，比丘当如是学！”
    佛说此经已，那提迦比丘欢喜随喜，作礼而去。

（一二五二）

    如是我闻。一时佛住鞞舍离国猕猴池侧重阁讲堂。
    尔时世尊告诸比丘：“诸离车子，常枕木枕，手足龟坼，疑畏莫令摩竭陀王阿阇世毗提希子，得其间便，是故常自儆策，不放逸住。以彼不放逸住故，摩竭陀王阿阇世毗提希子，不能伺求得其间便。于未来世不久，诸离车子恣乐无事，手足柔软，缯纩为枕，四体安卧，日出不起，放逸而住。以放逸住故，摩竭陀王阿阇世毗提希子，得其间便。
    “如是比丘精勤方便，坚固堪能，不舍善法，肌肤损瘦，筋连骨立。精勤方便，不舍善法，乃至未得所应得者，不舍精进，常摄其心，不放逸住。以不放逸住故，魔王波旬不得其便。当来之世，有诸比丘恣乐无事，手足柔软，缯纩为枕，四体安卧，日出不起，放逸而住。以放逸住故，恶魔波旬伺得其便。是故比丘，当如是学，精勤方便，乃至不得未得，不舍方便。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二五三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“譬如士夫，晨朝以三百釜食，惠施众生，日中、日暮亦复如是。第二士夫，时节须臾，于一切众生修习慈心，乃至如搆牛乳顷，比先士夫惠施功德所不能及，百分、千分、巨亿万分、算数譬类不得为比。是故比丘，当作是学，时节须臾，于一切众生修习慈心，下至如搆牛乳顷。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二五四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“譬如人家，多女人，少男子，当知是家易为盗贼之所劫夺。如是善男子、善女人，不能数数下至如搆牛乳顷，于一切众生修习慈心，当知是人易为诸恶鬼神所欺。
    “譬如人家，多男子，少女人，不为盗贼数数劫夺。如是善男子，数数下至如搆牛乳顷，于一切众生修习慈心，不为诸恶鬼神所欺。是故诸比丘，常当随时数数下至如搆牛乳顷，修习慈心。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二五五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“譬如有人有匕首剑，其刃广利。有健士夫言：‘我能以手以拳，捶打汝剑，令其摧碎。’诸比丘，彼健士夫当能以手以拳，捶打彼剑，令摧碎不？”
    比丘白佛：“不能，世尊。彼匕首剑，其刃广利，非彼士夫能以手以拳捶打碎折，正足自困。”
    “如是比丘，若沙门、婆罗门下至如搆牛乳顷，于一切众生修习慈心，若有诸恶鬼神欲往伺求其短，不能得其间便，正可反自伤耳。是故诸比丘，当如是学，数数下至如搆牛乳顷，修习慈心。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二五六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊以爪抄土，告诸比丘：“于意云何？我爪上土多，为大地土多？”
    比丘白佛：“世尊爪上土甚少少耳，其大地土无量无数，不可为比。”
    佛告诸比丘：“如是众生能数数下至弹指顷，于一切众生修习慈心者，如甲上土耳。其诸众生不能数数下至如弹指顷，于一切众生修习慈心者，如大地土。是故诸比丘，常当数数于一切众生修习慈心。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二五七）

    如是我闻。一时佛住鞞舍离国猕猴池侧重阁讲堂。
    尔时世尊告诸比丘：“一切行无常，不恒不安，是变易法。诸比丘，常当观察一切诸行，修习厌离、不乐、解脱。”
    时有异比丘从座起，整衣服，为佛作礼，右膝着地，合掌白佛：“寿命迁灭，迟速如何？”
    佛告比丘：“我则能说，但汝欲知者难。”
    比丘白佛：“可说譬不？”
    佛言：“可说。”
    佛告比丘：“有四士夫，手执强弓，一时放发，俱射四方。有一士夫，及箭未落，接取四箭。云何比丘，如是士夫为捷疾不？”
    比丘白佛：“捷疾，世尊。”
    佛告比丘：“此接箭士夫虽复捷疾，有地神天子倍疾于彼，虚空神天倍疾地神，四王天子来去倍疾于虚空神天，日月天子复倍捷疾于四王天，导日月神复倍捷疾于日月天子。诸比丘，命行迁变倍疾于彼导日月神。是故诸比丘，当勤方便，观察命行无常迅速如是。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二五八）

    如是我闻。一时佛住波罗奈国仙人住处鹿野苑中。
    尔时世尊告诸比丘：“过去世时，有一人名陀舍罗诃。彼陀舍罗诃有鼓名阿能诃，好声、美声、深声，彻四十里。彼鼓既久，处处裂坏。尔时鼓士裁割牛皮，周匝缠缚，虽复缠缚，鼓犹无复高声、美声、深声。彼于后时，转复朽坏，皮大剥落，唯有聚木。
    “如是比丘修身、修戒、修心、修慧，以彼修身、修戒、修心、修慧故，于如来所说修多罗，甚深明照，难见难觉，不可思量，微密决定，明智所知，彼则顿受、周备受，闻其所说，欢喜崇习，出离饶益。
    “当来比丘不修身、不修戒、不修心、不修慧，闻如来所说修多罗，甚深明照，空相应随顺缘起法，彼不顿受持，不至到受。闻彼说者，不欢喜崇习，而于世间众杂异论、文辞绮饰、世俗杂句，专心顶受，闻彼说者，欢喜崇习，不得出离饶益。于彼如来所说，甚深明照，空相要法，随顺缘起者，于此则灭。犹如彼鼓，朽故坏裂，唯有聚木。
    “是故诸比丘，当勤方便修身、修戒、修心、修慧，于如来所说甚深明照，空相要法，随顺缘起，顿受、遍受。闻彼说者，欢喜崇习，出离饶益。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二五九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“譬如铁丸，投着火中，与火同色，盛着劫贝绵中。云何比丘，当速燃不？”
    比丘白佛：“如是，世尊。”
    佛告比丘：“愚痴之人，依聚落住，晨朝着衣持钵，入村乞食，不善护身，不守根门，心不系念。若见年少女人，不正思惟，取其色相，起贪欲心，欲烧其心，欲烧其身，身心烧已，舍戒退减，是愚痴人长夜当得非义饶益。是故比丘，当如是学：善护其身，守护根门，系念入村乞食，当如是学！”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二六○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过去世时，有一猫狸，饥渴羸瘦，于孔穴中伺求鼠子，若鼠子出，当取食之。有时鼠子出穴游戏，时彼猫狸疾取吞之。鼠子身小，生入腹中，入腹中已，食其内脏。食内脏时，猫狸迷闷，东西狂走，空宅冢间，不知何止，遂至于死。
    “如是比丘，有愚痴人依聚落住，晨朝着衣持钵，入村乞食，不善护身，不守根门，心不系念。见诸女人，起不正思惟，而取色相，发贪欲心，贪欲发已，欲火炽燃，烧其身心。烧身心已，驰心狂逸，不乐精舍，不乐空闲，不乐树下，为恶不善心侵食内法，舍戒退减，此愚痴人长夜常得不饶益苦。是故比丘，当如是学：善护其身，守诸根门，系心正念，入村乞食，当如是学！”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二六一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“譬如木杵，常用不止，日夜消减。如是比丘，若沙门、婆罗门，从本以来，不闭根门，食不知量，初夜、后夜不勤觉悟，修习善法，当知是辈终日损减，不增善法，如彼木杵。
    “诸比丘，譬如优钵罗、钵昙摩、拘牟头、分陀利，生于水中，长于水中，随水增长。如是沙门、婆罗门，善闭根门，饮食知量，初夜、后夜精勤觉悟，当知是等善根功德日夜增长，终不退减。当如是学：善闭根门，饮食知量，初夜、后夜精勤觉悟，功德善法日夜增长，当如是学。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二六二）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊于后夜时，闻野狐鸣。
    尔时世尊夜过天明，于大众前敷座而坐，告诸比丘：“汝等后夜时，闻野狐鸣不？”
    诸比丘白佛：“如是，世尊。”
    佛告诸比丘：“有一愚痴人，作如是念：‘令我受身，得如是形类，作如是声。’此愚痴人，欲求如是像类处所受生，何足不得！是故比丘，汝等但当精勤方便，求断诸有，莫作方便增长诸有，当如是学！”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二六三）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊告诸比丘：“我不赞叹受少有身，况复多受。所以者何？受有者苦。譬如粪屎，少亦臭秽，何况于多。如是诸有，少亦不叹，乃至刹那，况复于多。所以者何？有者苦故。是故比丘，当如是学，断除诸有，莫增长有，当如是学！”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二六四）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时世尊夜后分时，闻野狐鸣。是夜过已，于大众前敷座而坐，告诸比丘：“汝等于夜后分，闻野狐鸣不？”
    比丘白佛：“如是，世尊。”
    佛告比丘：“彼野狐者，疥疮所困，是故鸣唤。若能有人为彼野狐治疥疮者，野狐必当知恩报恩。而今有一愚痴之人，无有知恩报恩。是故诸比丘，当如是学，知恩报恩。其有小恩尚报，终不忘失，况复大恩！”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二六五）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时有尊者跋迦梨，住王舍城金师精舍，疾病困苦。尊者富邻尼瞻视供养。
    时跋迦梨语富邻尼：“汝可诣世尊所，为我稽首礼世尊足，问讯世尊，少病少恼，起居轻利，安乐住不？言：跋迦梨住金师精舍，疾病困笃，委积床褥，愿见世尊。疾病困苦，气力羸惙，无由奉诣，唯愿世尊降此金师精舍，以哀愍故！”
    时富邻尼受跋迦梨语已，诣世尊所，稽首礼足，退住一面，白佛言：“世尊，尊者跋迦梨稽首世尊足，问讯世尊，少病少恼，起居轻利，安乐住不？”
    世尊答言：“令彼安乐。”
    富邻尼白佛言：“世尊，尊者跋迦梨住金师精舍，疾病困笃，委在床褥，愿见世尊，无有身力来诣世尊。善哉世尊，诣金师精舍，以哀愍故！”
    尔时世尊默然听许。
    时富邻尼知世尊听许已，礼足而去。
    尔时世尊晡时从禅觉，往诣金师精舍，至跋迦梨住房。
    跋迦梨比丘遥见世尊，从床欲起。
    佛告跋迦梨：“且止，勿起！”
    世尊即坐异床，语跋迦梨：“汝心堪忍此病苦不？汝身所患，为增为损？”
    跋迦梨白佛：如前《叉摩比丘修多罗》广说。“世尊，我身苦痛，极难堪忍，欲求刀自杀，不乐苦生。”
    佛告跋迦梨：“我今问汝，随意答我。云何跋迦梨，色是常耶，为非常耶？”
    跋迦梨答言：“无常，世尊。”
    复问：“若无常，是苦耶？”
    答言：“是苦，世尊。”
    复问跋迦梨：“若无常、苦者，是变易法，于中宁有可贪、可欲不？”
    跋迦梨白佛：“不也，世尊。”
    受、想、行、识，亦如是说。
    佛告跋迦梨：“若于彼身无可贪、可欲者，是则善终，后世亦善。”
    尔时世尊为跋迦梨种种说法，示教照喜已，从座起去。
    即于彼夜，尊者跋迦梨思惟解脱，欲执刀自杀，不乐久生。
    时有二天，身极端正，于后夜时，诣世尊所，稽首礼足，退住一面，白佛言：“世尊！尊者跋迦梨疾病困苦，思惟解脱，欲执刀自杀，不乐久生。”第二天言：“彼尊者跋迦梨，已于善解脱而得解脱。”说此语已，俱礼佛足，即没不现。
    尔时世尊夜过晨朝，于大众前敷座而坐，告诸比丘：“昨夜有二天子，形体端正，来诣我所，稽首作礼，退住一面，而作是言：‘尊者跋迦梨住金师精舍，疾病困苦，思惟解脱，欲执刀自杀，不乐久生。’第二天言：‘尊者跋迦梨已于善解脱而得解脱。’说此语已，稽首作礼，即没不现。”
    尔时世尊告一比丘：“汝当往诣尊者跋迦梨比丘所，语跋迦梨言：昨夜有二天来诣我所，稽首作礼，退住一面，语我言：‘尊者跋迦梨疾病困笃，思惟解脱，欲执刀自杀，不乐久生。’第二天言：‘尊者跋迦梨于善解脱而得解脱。’说此语已，即没不现。此是天语。佛复记汝：汝于此身不起贪欲，是则善终，后世亦善。”
    时彼比丘受世尊教已，诣金师精舍跋迦梨房。
    尔时跋迦梨语侍病者：“汝等持绳床，共舁我身，着精舍外，我欲执刀自杀，不乐久生。”
    时有众多比丘出房舍，露地经行。受使比丘诣众多比丘所，问众多比丘言：“诸尊，跋迦梨比丘住在何所？”
    诸比丘答言：“跋迦梨比丘告侍病者，令舁绳床，出精舍外，欲执刀自杀，不乐久生。”
    受使比丘即诣跋迦梨所。跋迦梨比丘遥见使比丘来，语侍病者：“下绳床着地，彼比丘疾来，似世尊使。”彼侍病者即下绳床着地。
    时彼使比丘语跋迦梨：“世尊有教，及天有所说。”
    时跋迦梨语侍病者：“扶我着地，不可于床上受世尊教，及天所说。”时侍病者即扶跋迦梨，下置于地。
    时跋迦梨言：“汝可宣示世尊告敕，及天所说。”
    使比丘言：“跋迦梨，大师告汝：昨夜有二天来白我言：‘跋迦梨比丘疾病困笃，思惟解脱，欲执刀自杀，不乐久生。’第二天言：‘跋迦梨比丘已于善解脱而得解脱。’说此语已，即没不现。世尊复记说汝：善于命终，后世亦善。”
    跋迦梨言：“尊者！大师善知所知，善见所见。彼二天者，亦善知所知，善见所见。然我今日于色无常，决定无疑。无常者是苦，决定无疑。若无常、苦者，是变易法，于彼无有可贪、可欲，决定无疑。受、想、行、识，亦复如是。然我今日疾病苦痛，犹故随身，欲刀自杀，不乐久生。”即执刀自杀。
    时使比丘供养跋迦梨死身已，还诣佛所，稽首礼足，退坐一面，白佛言：“世尊，我以世尊所敕，具告尊者跋迦梨。彼作是言：‘大师善知所知，善见所见。彼二天者，亦善知所知，善见所见。’广说乃至执刀自杀。”
    尔时世尊告诸比丘：“共诣金师精舍，跋迦梨尸所。”见跋迦梨死身，有远离之色。见已语诸比丘：“汝等见是跋迦梨比丘死身在地，有远离之色不？”
    诸比丘白佛：“已见，世尊。”
    复告诸比丘：“绕跋迦梨身，四面周匝有暗冥之相，围绕身不？”
    诸比丘白佛：“已见，世尊。”
    佛告诸比丘：“此是恶魔之像，周匝求觅跋迦梨善男子识神，当生何处。”
    佛告诸比丘：“跋迦梨善男子，不住识神，以刀自杀。”
    尔时世尊为彼跋迦梨说第一记。
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二六六）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有尊者阐陀，住那罗聚落好衣庵罗林中，疾病困笃。
    时尊者舍利弗，闻尊者阐陀在那罗聚落好衣庵罗林中，疾病困笃。闻已语尊者摩诃拘絺罗：“尊者知不？阐陀比丘在那罗聚落好衣庵罗林中疾病困笃，当往共看。”摩诃拘絺罗默然许之。
    时尊者舍利弗，与尊者摩诃拘絺罗，共诣那罗聚落好衣庵罗林中，至尊者阐陀住房。
    尊者阐陀遥见尊者舍利弗、尊者摩诃拘絺罗，凭床欲起。
    尊者舍利弗语尊者阐陀：“汝且莫起！”
    尊者舍利弗、尊者摩诃拘絺罗坐于异床，问尊者阐陀：“云何尊者阐陀，所患为可堪忍不？为增为损？”如前《叉摩修多罗》广说。
    尊者阐陀言：“我今身病，极患苦痛，难可堪忍。所起之病，但增无损，唯欲执刀自杀，不乐苦活。”
    尊者舍利弗言：“尊者阐陀，汝当努力，莫自伤害！若汝在世，我当与汝来往周旋。汝若有乏，我当给汝如法汤药。汝若无看病人，我当看汝，必令适意，非不适意。”
    阐陀答言：“我有供养，那罗聚落诸婆罗门长者悉见看视，衣被、饮食、卧具、汤药无所乏少。自有弟子修梵行者，随意瞻病，非不适意。但我疾病苦痛逼身，难可堪忍，唯欲自杀，不乐苦生。”
    舍利弗言：“我今问汝，随意答我。阐陀，眼及眼识、眼所识色，彼宁是我、异我、相在不？”
    阐陀答言：“不也，尊者舍利弗。”
    复问：“阐陀，耳、鼻、舌、身、意及意识、意识所识法，彼宁是我、异我、相在不？”
    阐陀答言：“不也，尊者舍利弗。”
    复问：“阐陀，汝于眼、眼识及色，为何所见、何所识、何所知故，言眼、眼识及色，非我、不异我、不相在？”
    阐陀答言：“我于眼、眼识及色，见灭、知灭故，见眼、眼识及色，非我、不异我、不相在。”
    复问：“阐陀，汝于耳、鼻、舌、身、意、意识及法，何所见、何所知故，于意、意识及法，见非我、不异我、不相在？”
    阐陀答言：“尊者舍利弗，我于意、意识及法，见灭、知灭故，于意、意识及法，见非我、不异我、不相在。尊者舍利弗，然我今日身病苦痛，不能堪忍，欲以刀自杀，不乐苦生。”
    时尊者摩诃拘絺罗语尊者阐陀：“汝今当于大师修习正念，如所说句：‘有所依者则为动摇，动摇者有所趣向，趣向者为不休息，不休息者则随趣往来，随趣往来者则有未来生死，有未来生死故有未来出没，有未来出没故则有生老病死、忧悲苦恼，如是纯大苦聚集。’如所说句：‘无所依者则不动摇，不动摇者得无趣向，无趣向者则有止息，有止息故则不随趣往来，不随趣往来则无未来出没，无未来出没者则无生老病死、忧悲恼苦，如是纯大苦聚灭。”
    阐陀言：“尊者摩诃拘絺罗，我供养世尊，事于今毕矣；随顺善逝，今已毕矣，适意非不适意。弟子所作，于今已作。若复有余弟子所作供养师者，亦当如是供养大师，适意非不适意。然我今日身病苦痛，难可堪忍，唯欲以刀自杀，不乐苦生。”
    尔时尊者阐陀，即于那罗聚落好衣庵罗林中，以刀自杀。
    时尊者舍利弗供养尊者阐陀舍利已，往诣佛所，稽首礼足，退住一面，白佛言：“世尊！尊者阐陀于那罗聚落好衣庵罗林中，以刀自杀。云何世尊，彼尊者阐陀当至何趣？云何受生？后世云何？”
    佛告尊者舍利弗：“彼不自记说言：尊者摩诃拘絺罗，我供养世尊，于今已毕；随顺善逝，于今已毕，适意非不适意。若复有余供养大师者，当如是作，适意非不适意耶？”
    尔时尊者舍利弗复问世尊：“彼尊者阐陀，先于镇珍尼婆罗门聚落，有供养家、极亲厚家、善言语家。”
    佛告舍利弗：“如是舍利弗，正智、正善解脱善男子，有供养家、亲厚家、善言语家。舍利弗，我不说彼有大过。若有舍此身，余身相续者，我说彼等则有大过。若有舍此身已，余身不相续者，我不说彼有大过也。无大过故，于那罗聚落好衣庵罗林中，以刀自杀。”
    如是世尊为彼尊者阐陀说第一记。
    佛说此经已，尊者舍利弗欢喜，作礼而去。


杂阿含经卷第四十八

（一二六七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子白佛言：“世尊！比丘比丘，度驶流耶？”
    佛言：“如是，天子。”
    天子复问：“无所攀缘，亦无所住，度驶流耶？”
    佛言：“如是，天子。”
    天子复问：“无所攀缘，亦无所住，而度驶流，其义云何？”
    佛言：“天子，我如是如是抱，如是如是直进，则不为水之所漂。如是如是不抱，如是如是不直进，则为水所漂。如是天子，名为无所攀缘，亦无所住，而度驶流。”
    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二六八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子白佛言：“比丘！知一切众生所著、所集，决定解脱、广解脱、极广解脱耶？”
    佛告天子：“我悉知一切众生所著、所集，决定解脱、广解脱、极广解脱。”
    天子白佛：“比丘！云何知一切众生所著、所集，决定解脱、广解脱、极广解脱？”
    佛告天子：“爱喜灭尽，我心解脱。心解脱已，故知一切众生所著、所集，决定解脱、广解脱、极广解脱。”
    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二六九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“谁度于诸流，昼夜勤精进，
不攀亦不住，何染而不著？”

    尔时世尊说偈答言：

“一切戒具足，智慧善正受，
内思惟系念，度难度诸流。
不乐于欲想，超越于色结，
不系亦不住，于染亦不著。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二七○）

    如是我闻。一时佛住王舍城山谷精舍。
    时有拘迦尼，是光明天女，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照山谷。
    时拘迦尼天女而说偈言：

“其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。”

    佛告天女：“如是如是。

“其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。”

    时拘迦尼天女闻佛所说，欢喜随喜，稽首佛足，即没不现。
    尔时世尊夜过晨朝，入于僧中，敷尼师坛，于大众前坐，告诸比丘：“昨日后夜，有拘迦尼天女，容色绝妙，来诣我所，稽首我足，退坐一面而说偈言：

‘其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。’

    “我即答言：‘如是，天女！如是，天女！

‘其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。’

    “说是语时，拘迦尼天女闻我所说，欢喜随喜，稽首我足，即没不现。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二七一）

    如是我闻。一时佛住王舍城山谷精舍。
    尔时尊者阿难告诸比丘：“我今当说《四句法经》，谛听善思，当为汝说。何等为《四句法经》？”
    尔时尊者阿难即说偈言：

“其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。

    “诸比丘，是名《四句法经》。”
    尔时有一异婆罗门，去尊者阿难不远，为诸年少婆罗门受诵经。时彼婆罗门作是念：“若沙门阿难所说偈，于我所说经，便是非人所说。”
    时彼婆罗门即往诣佛所，与世尊面相问讯慰劳已，退坐一面，白佛言：“瞿昙！沙门阿难所说偈言：

‘其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。’

    “如是等所说，则是非人语，非为人语。”
    佛告婆罗门：“如是如是，婆罗门，是非人语，非为人语也。时有拘迦尼天女来诣我所，稽首我足，退坐一面而说偈言：

‘其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。’

    “我时答言：‘如是如是，如天女所言。

‘其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。’

    “是故婆罗门，当知此所说偈，是非人所说，非是人所说也。”
    佛说此经已，彼婆罗门闻佛所说，欢喜随喜，礼佛足而去。

（一二七二）

    如是我闻。一时佛住王舍城山谷精舍。
    时有拘迦那娑天女，是光明天女，起大电光炽然，归佛、归法、归比丘僧，来诣佛所，稽首佛足，退坐一面。其身光明，普照山谷。
    即于佛前而说偈言：

“其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。”

    尔时世尊告天女言：“如是如是，天女，如汝所说：

“其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。”

    尔时拘迦那娑天女闻佛所说，欢喜随喜，稽首佛足，即没不现。
    尔时世尊夜过晨朝，入僧中敷尼师坛，于大众前坐，告诸比丘：“于昨后夜，拘迦那娑天女，光明之天女，来诣我所，稽首我足，退坐一面，而说偈言：

‘其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。’

    “我时答言：‘如是天女，如是天女，如汝所说。

‘其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。
拘迦那天女，电光炎炽然，
敬礼佛法僧，说偈义饶益。’”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二七三）

    如是我闻。一时佛住王舍城山谷精舍。
    时有拘迦那娑天女，光明之天女，放电光明，焰照炽然，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，普照山谷。
    即于佛前而说偈言：

“我能广分别，如来正法律，
今且但略说，足以表其心。
其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。”

    佛告天女：“如是，天女！如是，天女！如汝所说。

“其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。”

    时拘迦那娑天女闻佛所说，欢喜稽首，即没不现。
    尔时世尊夜过晨朝，入于僧前，于大众中敷座而坐，告诸比丘：“昨后夜时，拘迦那娑天女来诣我所，恭敬作礼，退坐一面而说偈言：

‘我能广分别，如来正法律，
今且但略说，足已表我心。
其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。’

    “我时答言：‘如是，天女，如汝所说。

‘其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。’

    “时彼天女闻我所说，欢喜随喜，稽首我足，即没不现。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二七四）

    如是我闻。一时佛住毗舍离猕猴池侧重阁讲堂。
    时有拘迦那娑天女、朱卢陀天女，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照一切猕猴池侧。
    时朱卢陀天女说偈白佛：

“大师等正觉，住毗舍离国，
拘迦那朱卢，稽首恭敬礼。
我昔未曾闻，牟尼正法律，
今乃得亲见，现前说正法。
若于圣法律，恶慧生厌恶，
必当堕恶道，长夜受诸苦。
若于圣法律，正念律仪备，
彼则生天上，长夜受安乐。”

    拘迦那娑天女复说偈言：

“其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。”

    佛告天女：“如是如是，如汝所说。

“其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。”

    时彼天女闻佛所说，欢喜随喜，即没不现。
    尔时世尊夜过晨朝，入僧中敷座而坐，告诸比丘：“昨后夜时，有二天女，容色绝妙，来诣我所，为我作礼，退坐一面。
    “朱卢陀天女而说偈言：

‘大师等正觉，住毗舍离国，
我拘迦那娑，及以朱卢陀，
如是二天女，稽首礼佛足。
我昔未曾闻，牟尼正法律，
今乃见正觉，演说微妙法。
若于正法律，厌恶住恶慧，
必堕于恶道，长夜受大苦。
若于正法律，正念律仪备，
生善趣天上，长夜受安乐。’

    “拘迦那娑天女复说偈言：

‘其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。’

    “我时答言：‘如是如是，如汝所说。

‘其心不为恶，及身口世间，
五欲悉虚空，正智正系念，
不习近众苦，非义和合者。’”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二七五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“无触不报触，触则以触报，
以触报触故，不瞋不招瞋。”

    尔时世尊说偈答言：

“不于不瞋人，而加之以瞋，
清净之正士，离诸烦恼结。
于彼起恶心，恶心还自中，
如逆风扬尘，还自坌其身。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二七六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“愚痴人所行，不合于黠慧，
自所行恶行，为自恶知识，
所造众恶行，终获苦果报。”

    尔时世尊说偈答言：

“既作不善业，终则受诸恼，
造业虽欢喜，啼泣受其报。
造诸善业者，终则不热恼，
欢喜而造业，安乐受其报。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二七七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“不可常言说，亦不一向听，
而得于道迹，坚固正超度，
思惟善寂灭，解脱诸魔缚。
能行说之可，不行不应说，
不行而说者，智者则知非。
不行己所应，不作而言作，
是则同贼非，名为不善业。”

    尔时世尊告天子言：“汝今有所嫌责耶？”
    天子白佛：“悔过，世尊！悔过，善逝！”
    尔时世尊熙怡微笑。
    时彼天子复说偈言：

“我今悔其过，世尊不纳受，
内怀于恶心，抱怨而不舍。”

    尔时世尊说偈答言：

“言说悔过辞，内不息其心，
云何得息怨，何名为修善？”

    时彼天子复说偈言：

“谁不有其过，何人无有罪？
谁复无愚痴，孰能常坚固？”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二七八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有瞿迦梨比丘，是提婆达多伴党，来诣佛所，稽首佛足，退坐一面。
    尔时世尊告瞿迦梨比丘：“瞿迦梨！汝何故于舍利弗、目揵连清净梵行所，起不清净心，长夜当得不饶益苦。”
    瞿迦梨比丘白佛言：“世尊，我今信世尊语，所说无异。但舍利弗、大目揵连，心有恶欲。”
    如是第二、第三说。
    瞿迦梨比丘，提婆达多伴党，于世尊所，再三说中，违反不受，从座起去。去已，其身周遍生诸疱疮，皆如栗，渐渐增长，皆如桃李。
    时瞿迦梨比丘患苦痛，口说是言：“极烧！极烧！”脓血流出，身坏命终，生大钵昙摩地狱。
    时有三天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。
    时一天子白佛言：“瞿迦梨比丘，提婆达多伴党，今已命终。”
    时第二天子作是言：“诸尊当知，瞿迦梨比丘命终堕地狱中。”
    第三天子即说偈言：

“士夫生世间，斧在口中生，
还自斩其身，斯由其恶言。
应毁便称誉，应誉而便毁，
其罪生于口，死堕恶道中。
博弈亡失财，是非为大咎，
毁佛及声闻，是则为大过。”

    彼三天子说是偈已，即没不现。
    尔时世尊夜过晨朝，来入僧中，于大众前敷座而坐，告诸比丘：“昨后夜时，有三天子来诣我所，稽首我足，退坐一面。第一天子语我言：‘世尊，瞿迦梨比丘，提婆达多伴党，今已命终。’第二天子语余天子言：‘瞿迦梨比丘命终堕地狱中。’第三天子即说偈言：

‘士夫生世间，斧在口中生，
还自斩其身，斯由其恶言。
应毁便称誉，应誉而便毁，
其罪口中生，死则堕恶道。’

    “说是偈已，即没不现。
    “诸比丘，汝等欲闻生阿浮陀地狱众生，其寿齐限不？”
    诸比丘白佛：“今正是时，唯愿世尊为诸大众说阿浮陀地狱众生寿命齐限。诸比丘闻已，当受奉行。”
    佛告比丘：“谛听善思，当为汝说。譬如拘萨罗国，四斗为一阿罗，四阿罗为一独笼那，十六独笼那为一阇摩那，十六阇摩那为一摩尼，二十摩尼为一佉梨，二十佉梨为一仓，满中芥子。若使有人百年、百年取一芥子，如是乃至满仓芥子都尽，阿浮陀地狱众生寿命犹故不尽。如是二十阿浮陀地狱众生寿，等一尼罗浮陀地狱众生寿。二十尼罗浮陀地狱众生寿，等一阿吒吒地狱众生寿。二十阿吒吒地狱众生寿，等一阿波波地狱众生寿。二十阿波波地狱众生寿，等一阿休休地狱众生寿。二十阿休休地狱众生寿，等一优钵罗地狱众生寿。二十优钵罗地狱众生寿，等一钵昙摩地狱众生寿。二十钵昙摩地狱众生寿，等一摩诃钵昙摩地狱众生寿。
    “比丘，彼瞿迦梨比丘命终，堕摩诃钵昙摩地狱中，以彼于尊者舍利弗、大目揵连比丘，生恶心诽谤故。是故诸比丘，当作是学，于彼烧燋柱所，尚不欲毁坏，况毁坏有识众生！”
    佛告诸比丘：“当如是学！”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二七九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“退落堕负处，云何而得知？
唯愿世尊说，云何负处门？”

    尔时世尊说偈答言：

“胜处易得知，负处知亦易，
乐法为胜处，毁法为负处。
爱乐恶知识，不爱善知识，
善友生怨结，是名堕负门。
爱乐不善人，善人反憎恶，
欲恶不欲善，是名负处门。
斗秤以欺人，是名堕负门。
博弈耽嗜酒，游轻著女色，
费丧于财物，是名堕负门。
女人不自守，舍主随他行，
男子心放荡，舍妻随外色，
如是为家者，斯皆堕负门。
老妇得少夫，心常怀嫉妒，
怀嫉卧不安，是则堕负门，
老夫得少妇，堕负处亦然。
常乐著睡眠，知识同游戏，
怠惰好瞋恨，斯皆堕负门。
多财结朋友，酒食奢不节，
多费丧财物，斯皆堕负门。
少财多贪爱，生于刹利家，
常求为王者，是则堕负门。
求珠珰璎珞，革屣履伞盖，
庄严自悭惜，是则堕负门。
受他丰美食，自悭惜其财，
食他不反报，是则堕负门。
沙门婆罗门，屈请入其舍，
悭惜不时施，是则堕负门。
沙门婆罗门，次第行乞食，
呵责不欲施，是则堕负门。
若父母年老，不及时奉养，
有财而不施，是则堕负门。
于父母兄弟，捶打而骂辱，
无有尊卑序，是则堕负门。
佛及弟子众，在家与出家，
毁訾不恭敬，是则堕负门。
实非阿罗汉，罗汉过自称，
是则世间贼，堕于负处门。
此世间负处，我知见故说，
犹如险怖道，慧者当远避。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二八○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“谁屈下随下？谁高举随举？
云何童子戏，如童块相掷？”

    尔时世尊说偈答言：

“爱下则随下，爱举则随举，
爱戏于愚夫，如童块相掷。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二八一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“决定以遮遮，意妄想而来，
若人遮一切，不令其逼迫。”

    尔时世尊说偈答言：

“决定以遮遮，意妄想而来，
不必一切遮，但遮其恶业，
遮彼彼恶已，不令其逼迫。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二八二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“云何得名称？云何得大财？
云何德流闻？云何得善友？”

    尔时世尊说偈答言：

“持戒得名称，布施得大财，
真实德流闻，息恶得善友。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二八三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。其身光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“云何人所作，智慧以求财？
等摄受于财，若胜若复劣？”

    尔时世尊说偈答言：

“始学功巧业，方便集财物，
得彼财物已，当应作四分。
一分自食用，二分营生业，
余一分藏密，以拟于贫乏。
营生之业者，田种行商贾，
牧牛羊蕃息，邸舍以求利，
造屋舍床卧，六种资生具，
方便修众具，安乐以存世。
如是善修业，黠慧以求财，
财宝随顺生，如众流归海。
如是财饶益，如蜂集众味，
昼夜财增长，犹如蚁积堆。
不付老子财，不寄边境民，
不信奸狡人，及诸悭吝者。
亲附成事者，远离不成事，
能成事士夫，犹如火炽燃。
善友贵重人，敏密循良者，
同气亲兄弟，善能相摄受。
居亲眷属中，标显若牛王，
各随其所应，分财施饮食，
寿尽而命终，当生天受乐。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二八四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时世尊告诸比丘：“过去世时，拘萨罗国有弹琴人，名曰粗牛，于拘萨罗国人间游行，止息野中。时有六广大天宫天女，来至憍萨罗国粗牛弹琴人所，语粗牛弹琴人言：‘阿舅！阿舅！为我弹琴，我当歌舞。’粗牛弹琴者言：‘如是姊妹，我当为汝弹琴。汝当语我，汝是何人，何由生此？’天女答言：‘阿舅且弹琴，我当歌舞，于歌颂中，自说所以生此因缘。’彼拘萨罗国粗牛弹琴人即便弹琴，彼六天女即便歌舞。
    “第一天女说偈歌言：

‘若男子女人，胜妙衣惠施，
施衣因缘故，所生得殊胜，
施所爱念物，生天随所欲。
见我居宫殿，乘虚而游行，
天身如金聚，天女百中胜，
观察斯福德，回向中之最。’

    “第二天女复说偈言：

‘若男子女人，胜妙香惠施，
爱念可意施，生天随所欲。
见我处宫殿，乘虚而游行，
天身若金聚，天女百中胜，
观察斯福德，回向中之最。’

    “第三天女复说偈言：

‘若男子女人，以食而惠施，
可意爱念施，生天随所欲。
见我居宫殿，乘虚而游行，
天身如金聚，天女百中胜，
观察斯福德，回向中之最。’

    “第四天女复说偈言：

‘忆念余生时，曾为人婢使，
不盗不贪嗜，勤修不懈怠，
量腹自节身，分餐救贫人。
今见居宫殿，乘虚而游行，
天身如金聚，天女百中胜，
观察斯福德，供养中为最。’

    “第五天女复说偈言：

‘忆念余生时，为人作子妇，
嫜姑性狂暴，常加粗涩言，
执节修妇礼，卑逊而奉顺。
今见处宫殿，乘虚而游行，
天身如金聚，天女百中胜，
观察斯福德，供养中为最。’

    “第六天女复说偈言：

‘昔曾见行路，比丘比丘尼，
从其闻正法，一宿受斋戒。
今见处天宫，乘虚而游行，
天身如金聚，天女百中胜，
观察斯福德，回向中之最。’

    “尔时拘萨罗国粗牛弹琴人而说偈言：

‘我今善来此，拘萨罗林中，
得见此天女，具足妙天身。
既见又闻说，当增修善业，
缘今修功德，亦当生天上。’

    “说是语已，时诸天女即没不现。”
    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一二八五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“何法起应灭？何生应防护？
何法应当离？等观何得乐？”

    尔时世尊说偈答言：

“瞋恚起应灭，贪生逆防护，
无明应舍离，等观真谛乐。
欲生诸烦恼，欲为生苦本，
调伏烦恼者，众苦则调伏，
调伏众苦者，烦恼亦调伏。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    于是天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二八六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“若人行放逸，愚痴离恶慧，
禅思不放逸，疾得尽诸漏。”

    尔时世尊说偈答言：

“非世间众事，是则之为欲，
心法驰觉想，是名士夫欲。
世间种种事，常在于世间，
智慧修禅思，爱欲永潜伏。
信为士夫伴，不信则不度，
信增其名称，命终得生天。
于身虚空想，名色不坚固，
不著名色者，远离于积聚。
观此真实义，如解脱哀愍，
由斯智慧故，世称叹供养。
能断众杂相，超绝生死流，
超度诸流已，是名为比丘。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    于是天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二八七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。其身光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“与何人同处，复与谁共事？
知何等人法，名为胜非恶？”

    尔时世尊说偈答言：

“与正士同游，正士同其事，
解知正士法，是则胜非恶。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二八八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“悭吝生于心，不能行布施；
明智求福者，乃能行其惠。”

    尔时世尊说偈答言：

“怖畏不行施，常得不施怖，
怖畏于饥渴，悭吝从怖生。
此世及他世，常痴饥渴畏，
死则不随无，独往无资粮。
少财能施者，多财难亦舍，
难舍而能舍，是则为难施。
无知者不觉，慧者知难知，
以法养妻子，少财净心施。
百千邪盛会，所获其福利，
比前如法施，十六不及一。
打缚恼众生，所得诸财物，
惠施安国土，是名有罪施，
方之平等施，称量所不及。
如法不行非，所得财物施，
难施而行施，是应贤圣施，
所住常获福，寿终上生天。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    时彼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二八九）

    如是我闻。一时佛住王舍城金婆罗山金婆罗鬼神住处石室中。
    尔时世尊金枪刺足，未经几时，起身苦痛。能得舍心，正智正念，堪忍自安，无退减想。
    彼有山神天子八人，作是念：“今日世尊住王舍城金婆罗山金婆罗鬼神住处石室中，金枪刺足，起身苦痛，而能舍心，正念正智，堪忍自安，无所退减。我等当往，面前赞叹。”作是念已，往诣佛所，稽首礼足，退住一面。
    第一天神说偈叹言：

“沙门瞿昙，人中狮子，
身遭苦痛，堪忍自安，
正智正念，无所退减。”

    第二天子复赞叹言：

“大士之大龙，大士之牛王，
大士夫勇力，大士夫良马，
大士夫上首，大士夫之胜。”

    第三天子复赞叹言：

“此沙门瞿昙，士夫分陀利，
身生诸苦痛，而能行舍心，
正智正念住，堪忍以自安，
而无所退减。”

    第四天子复赞叹言：“若有于沙门瞿昙，士夫分陀利所说，违反嫌责，当知斯等长夜当得不饶益苦，唯除不知真实者。”
    第五天子复说偈言：

“观彼三昧定，善住于正受，
解脱离诸尘，不踊亦不没，
其心安隐住，而得心解脱。”

    第六天子复说偈言：

“经历五百岁，诵婆罗门典，
精勤修苦行，不解脱离尘，
是则卑下类，不得度彼岸。”

    第七天子复说偈言：

“为欲之所迫，持戒之所缚，
勇捍行苦行，经历于百年，
其心不解脱，不离于尘垢，
是则卑下类，不度于彼岸。”

    第八天子复说偈言：

“心居骄慢欲，不能自调伏，
不得三昧定，牟尼之正受。
独一居山林，其心常放逸，
于彼死魔军，不得度彼岸。”

    时彼山神天子八人，各各赞叹已，稽首佛足，即没不现。

（一二九○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子而说偈言：

“广无过于地，深无逾于海，
高无过须弥，大士无毗纽。”

    尔时世尊说偈答言：

“广无过于爱，深无逾于腹，
高莫过骄慢，大士无胜佛。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    于是天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二九一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“何物不能烧？何风不能吹？
水灾坏天地，何物不流散？
恶王及盗贼，强劫人财物，
何男子女人，不为其所夺？
云何珍宝藏，终竟不亡失？”

    尔时世尊说偈答言：

“福火不能烧，福风不能吹，
水灾坏天地，福水不流散。
恶王及盗贼，强夺人财宝，
若男子女人，福不被劫夺。
乐报之宝藏，终竟不亡失。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    于是天子闻佛所说，欢喜随喜，即没不现。

（一二九二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“谁当持资粮？何物贼不劫？
何人劫而遮？何人劫不遮？
何人常来诣，智慧者喜乐？”

    尔时世尊说偈答言：

“信者持资粮，福德劫不夺；
贼劫夺则遮，沙门夺欢喜；
沙门常来诣，智慧者欣乐。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    于是天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二九三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有一天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“一切相映障，知一切世间，
乐安慰一切，唯愿世尊说，
云何是世间，最为难得者？”

    是时世尊说偈答言：

“为主而行忍，无财而欲施，
遭难而行法，富贵修远离，
如是四法者，是则为最难。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    于是天子闻佛所说，欢喜随喜，稽首佛足，即没不现。


杂阿含经卷第四十九

（一二九四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“大力自在乐，所求无不得，
何复胜于彼，一切所欲备？”

    尔时世尊说偈答言：

“大力自在乐，彼则无所求，
若有求欲者，是苦非为乐，
于求已过去，是则乐于彼。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    于是天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二九五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“车从何处起？谁能转于车？
车转至何所？何故坏磨灭？”

    尔时世尊说偈答言：

“车从诸业起，心识转于车，
随因而转至，因坏车则亡。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    于是天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二九六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子白佛言：“世尊！拘屡陀王女修波罗提沙，今日生子。”
    佛告天子：“此则不善，非是善。”
    时彼天子即说偈言：

“人生子为乐，世间有子欢，
父母年老衰，子则能奉养。
瞿昙何故说，生子为不善？”

    尔时世尊说偈答言：

“当知恒无常，纯空阴非子，
生子常得苦，愚者说言乐，
是故我说言，生子非为善。
非善为善像，念像不可念，
实苦貌似乐，放逸所践蹈。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    于是天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二九七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“云何数所数？云何数不隐？
云何数中数？云何说言说？”

    尔时世尊说偈答言：

“佛法难测量，二流不显现，
若彼名及色，灭尽悉无余。
是名数所数，彼数不隐藏，
是彼数中数，是则说名数。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    于是天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二九八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“何物重于地？何物高于空？
何物疾于风？何物多于草？”

    尔时世尊说偈答言：

“戒德重于地，慢高于虚空，
忆念疾于风，思想多于草。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    于是天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一二九九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时彼天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“何戒何威仪，何得何为业，
慧者云何住，云何往生天？”

    尔时世尊说偈答言：

“远离于杀生，持戒自防乐，
害心不加生，是则生天路。
远离不与取，与取心欣乐，
断除贼盗心，是则生天路。
不行他所受，远离于邪淫，
自受知止足，是则生天路。
自为己及他，为财及戏笑，
妄语而不为，是则生天路。
断除于两舌，不离他亲友，
常念和彼此，是则生天路。
远离不爱言，软语不伤人，
常说淳美言，是则生天路。
不为不诚说，无义不饶益，
常顺于法言，是则生天路。
聚落若空地，见利言我有，
不行此贪想，是则生天路。
慈心无害想，不害于众生，
心常无怨结，是则生天路。
苦业及果报，二俱生净信，
受持于正见，是则生天路。
如是诸善法，十种净业迹，
等受坚固持，是则生天路。”

    时彼天子复说偈言：

“久见婆罗门，逮得般涅槃，
一切怖已过，永超世恩爱。”

    于是天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三○○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时释提桓因于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时释提桓因说偈问佛：

“何法命不知？何法命不觉？
何法锁于命？何法为命缚？”

    尔时世尊说偈答言：

“色者命不知，诸行命不觉，
身锁于其命，爱缚于命者。”

    释提桓因复说偈言：

“色者非为命，诸佛之所说，
云何而得熟，于彼甚深藏？
云何段肉住？云何知命身？”

    尔时世尊说偈答言：

“歌罗逻为初，歌罗逻生胞，
胞生于肉段，肉段生坚厚，
坚厚生肢节，及诸毛发等。
色等诸情根，渐次成形体，
因母饮食等，长养彼胎身。”

    尔时释提桓因闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三○一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有长胜天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼长胜天子而说偈言：

“善学微妙说，习近诸沙门，
独一无等侣，正思惟静默。”

    尔时世尊说偈答言：

“善学微妙说，习近诸沙门，
独一无等侣，寂默静诸根。”

    时长胜天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三○二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有尸毗天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼尸毗天子说偈问佛：

“何人应同止，何等人共事？
应知何等法，是转胜非恶？”

    尔时世尊说偈答言：

“与正士同止，正士共其事，
应知正士法，是转胜非恶。”

    时彼尸毗天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三○三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有月自在天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼月自在天子而说偈言：

“彼当至究竟，如蚊依从草，
若得正系念，一心善正受。”

    尔时世尊说偈答言：

“彼当到彼岸，如鱼决其网，
禅定具足住，心常致喜乐。”

    时彼月自在天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三○四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有毗瘦纽天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼毗瘦纽天子而说偈言：

“供养于如来，欢喜常增长，
欣乐正法律，不放逸随学。”

    尔时世尊说偈答言：

“善如是说法，防护不放逸，
以不放逸故，不随魔自在。”

    于是毗瘦纽天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三○五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有般阇罗揵椎天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时般阇罗揵椎天子而说偈言：

“愦乱之处所，黠慧者能觉，
禅思觉所觉，牟尼思惟力。”

    尔时世尊说偈答言：

“了知愦乱法，正觉得涅槃，
若得正系念，一心善正受。”

    时般阇罗揵椎天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三○六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有须深天子，与五百眷属，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    尔时世尊告尊者阿难：“汝阿难于尊者舍利弗善说法，心喜乐不？”
    阿难白佛：“如是，世尊。何等人不愚、不痴、有智慧，于尊者舍利弗善说法中，心不欣乐？所以者何？彼尊者舍利弗，持戒多闻，少欲知足，精勤远离，正念坚住，智慧正受。捷疾智慧、利智慧、出离智慧、决定智慧、大智慧、广智慧、深智慧、无等智慧，智宝成就。善能教化，示教照喜，亦常赞叹示教照喜，常为四众说法不倦。”
    佛告阿难：“如是如是，如汝所说。阿难，为何等人不愚、不痴、有智慧，闻尊者舍利弗善说诸法而不欢喜？所以者何？舍利弗比丘持戒多闻，少欲知足，精勤正念，智慧正受。超智、捷智、利智、出智、决定智、大智、广智、深智、无等智，智宝成就。善能教化，示教照喜，亦常赞叹示教照喜，常为四众说法不倦。”
    世尊如是如是向尊者阿难，如是如是称叹舍利弗所说。如是如是须深天子眷属，内心欢喜，身光增明，清净照耀。
    尔时须深天子内怀欢喜，发身净光照耀已，而说偈言：

“舍利弗多闻，明智平等慧，
持戒善调伏，得不起涅槃，
持此后边身，降伏于魔军。”

    时彼须深天子及五百眷属闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三○七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有赤马天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼赤马天子白佛言：“世尊，颇有能行过世界边，至不生、不老、不死处不？”
    佛告赤马：“无有能过世界边，至不生、不老、不死处者。”
    赤马天子白佛言：“奇哉世尊！善说斯义。如世尊说言，无过世界边，至不生、不老、不死处者。所以者何？世尊，我自忆宿命，名曰赤马，作外道仙人，得神通，离诸爱欲。我时作是念：‘我有如是捷疾神足，如健士夫以利箭横射过多罗树影之顷，能登一须弥至一须弥，足蹑东海超至西海。’我时作是念：‘我今成就如是捷疾神力，今日宁可求世界边。’作是念已，即便发行，唯除食息、便利，减节睡眠，常行百岁，于彼命终，竟不能得过世界边，至不生、不老、不死之处。”
    佛告赤马：“我今但以一寻之身，说于世界、世界集、世界灭、世界灭道迹。赤马天子，何等为世间？谓五受阴。何等为五？色受阴、受受阴、想受阴、行受阴、识受阴，是名世间。何等为色集？谓当来有爱，贪喜俱，彼彼染著，是名世间集。云何为世间灭？若彼当来有爱，贪喜俱，彼彼染著，无余断、舍、离、尽、无欲、灭、息、没，是名世间灭。何等为世间灭道迹？谓八圣道，正见、正志、正语、正业、正命、正方便、正念、正定，是名世间灭道迹。赤马，了知世间苦，断世间苦；了知世间集，断世间集；了知世间灭，证世间灭；了知世间灭道迹，修彼道迹。赤马，若比丘于世间苦若知、若断，世间集若知、若断，世间灭若知、若证，世间灭道迹若知、若修。赤马，是名得世界边，度世间爱。”
    尔时世尊重说偈言：

“未曾远游行，而得世界边，
无得世界边，终不尽苦边。
以是故牟尼，能知世界边，
善解世界边，诸梵行已立。
于彼世界边，平等觉知者，
是名贤圣行，度世间彼岸。”

    是时赤马天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三○八）

    如是我闻。一时佛住王舍城毗富罗山侧。
    有六天子，本为外道出家，一名阿毗浮，二名增上阿毗浮，三名能求，四名毗蓝婆，五名阿俱吒，六名迦蓝，来诣佛所。
    阿毗浮天子即说偈言：

“比丘专至心，常修行厌离，
于初夜后夜，思惟善自摄，
见闻其所说，不堕于地狱。”

    增上阿毗浮天子复说偈言：

“厌离于黑暗，心常自摄护，
永离于世间，言语诤论法。
从如来大师，禀受沙门法，
善摄护世间，不令造众恶。”

    能求天子复说偈言：

“断截捶打杀，供养施迦叶，
不见其为恶，亦不见为福。”

    毗蓝婆天子复说偈言：

“我说彼尼乾，外道若提子，
出家行学道，长夜修难行，
于大师徒众，远离于妄语，
我说如是人，不远于罗汉。”

    尔时世尊说偈答言：

“死瘦之野狐，常共狮子游，
终日小羸劣，不能为狮子。
尼乾大师众，虚妄自称叹，
是恶心妄语，去罗汉甚远。”

    尔时天魔波旬，着阿俱吒天子而说偈言：

“精勤弃暗冥，常守护远离，
染著微妙色，贪乐于梵世，
我教化斯等，令得生梵天。”

    尔时世尊作是念：“若此阿俱吒天子所说偈，此是天魔波旬加其力故，非彼阿俱吒天子自心所说，作是说言：

‘精勤弃暗冥，守护于远离，
染著微妙色，贪乐于梵世，
当教化斯等，令得生梵天。’”

    尔时世尊复说偈言：

“若诸所有色，于此及与彼，
或复虚空中，各别光照耀，
当知彼一切，不离魔魔缚，
犹如垂钓饵，钩钓于游鱼。”

    时彼天子咸各念言：“今日阿俱吒天子所说偈，沙门瞿昙言是魔所说。何故沙门瞿昙言是魔说？”
    尔时世尊知诸天子心中所念，而告之言：“今阿俱吒天子所说偈，非彼天子自心所说，是魔波旬加其力故，作是说言：

‘精勤弃暗冥，守护于远离，
染著微妙色，贪乐于梵世，
当教化斯等，令得生梵天。’

    “是故我说偈：

‘若诸所有色，于此及与彼，
或复虚空中，各别光照耀，
当知彼一切，不离魔魔缚，
犹如垂钓饵，钩钓于游鱼。’”

    时诸天子复作是念：“奇哉！沙门瞿昙，神力大德，能见天魔波旬，而我等不见。我等当复各各说偈，赞叹沙门瞿昙。”即说偈言：

“断除于一切，有身爱贪想，
令此善护者，除一切妄语，
若欲断欲爱，应供养大师。
断除三有爱，破坏于妄语，
已断于见贪，应供养大师。
王舍城第一，名毗富罗山，
雪山诸山最，金翅鸟中名。
八方及上下，一切众生界，
于诸天人中，等正觉最上。”

    时诸天子说偈赞佛已，闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三○九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有摩伽天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时有摩伽天子说偈问佛：

“杀何得安眠？杀何得喜乐？
为杀何等人，瞿昙所赞叹？”

    尔时世尊说偈答言：

“若杀于瞋恚，而得安隐眠，
杀于瞋恚者，令人得欢喜。
瞋恚为毒本，杀者我所叹，
杀彼瞋恚已，长夜无忧患。”

    尔时摩伽天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三一○）

    如是我闻。一时佛在舍卫国祇树给孤独园。
    尔时有弥耆迦天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时弥耆迦天子说偈问佛：

“明照有几种，能照明世间？
唯愿世尊说，何等明最上？”

    尔时世尊说偈答言：

“有三种光明，能照耀世间，
昼以日为照，月以照其夜，
灯火昼夜照，照彼彼色像。
上下及诸方，众生悉蒙照，
人天光明中，佛光明为上。”

    佛说此经已，弥耆迦天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三一一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有陀摩尼天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。身诸光明，遍照祇树给孤独园。
    时彼陀摩尼天子而说偈言：

“为婆罗门事，学断莫疲倦，
断除诸爱欲，不求受后身。”

    尔时世尊说偈答言：

“婆罗门无事，所作事已作，
乃至不得岸，昼夜常勤跪，
已到彼岸住，于岸复何跪？
此是婆罗门，专精漏尽禅，
一切诸忧恼，炽然永已断，
是则到彼岸，涅槃无所求。”

    时陀摩尼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三一二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有多罗揵陀天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“断几舍几法，几法上增修，
超越几积聚，名比丘度流？”

    尔时世尊说偈答言：

“断五舍于五，五法上增修，
超五种积聚，名比丘度流。”

    时彼陀摩尼天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三一三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有迦摩天子，容色绝妙，于后夜时，来诣佛所，稽首佛足。身诸光明，遍照祇树给孤独园。
    时迦摩天子白佛言：“甚难，世尊！甚难，善逝！”
    尔时世尊说偈答言：

“所学为甚难，具足戒三昧，
远离于非家，闲居寂静乐。”

    迦摩天子白佛言：“世尊，静默甚难得。”
    尔时世尊说偈答言：

“得所难得学，具足戒三昧，
昼夜常专精，修习意所乐。”

    迦摩天子白佛言：“世尊，正受心难得。”
    尔时世尊说偈答言：

“难住正受住，诸根心决定，
能断死魔縻，圣者随欲进。”

    迦摩天子复白佛言：“世尊，险道甚难行。”
    尔时世尊说偈答言：

“难涉之险道，当行安乐进。
非圣堕于彼，足上头向下；
贤圣乘正直，险路自然平。”

    佛说此经已，迦摩天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三一四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有迦摩天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼迦摩天子说偈问佛：

“贪恚何所因？不乐身毛竖，
恐怖从何起？觉想由何生？
犹如鸠摩罗，依倚于乳母。”

    尔时世尊说偈答言：

“爱生自身长，如尼拘律树，
处处随所著，如榛绵丛林。
若知彼因者，发悟令开觉，
度生死海流，不复更受有。”

    时迦摩天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三一五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有栴檀天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼栴檀天子说偈问佛：

“闻瞿昙大智，无障碍知见，
何所住何学，不遭他世恶？”

    尔时世尊说偈答曰：

“摄持身口意，不造三恶法，
处在于居家，广集于群宾，
信惠财法施，以法立一切，
住彼学彼法，则无他世畏。”

    佛说是经已，栴檀天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三一六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有栴檀天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼天子说偈问佛：

“谁度于诸流，昼夜勤不懈？
不攀无住处，云何不没溺？”

    尔时世尊说偈答言：

“一切戒具足，智慧善正受，
内思惟正念，能度难度流。
不染此欲想，超度彼色爱，
贪喜悉已尽，不入于难测。”

    时彼栴檀天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三一七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有迦叶天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼迦叶天子白佛言：“世尊，我今当说比丘及比丘功德。”
    佛告天子：“随汝所说。”
    时迦叶天子而说偈言：

“比丘修正念，其身善解脱，
昼夜常勤求，坏有诸功德。
了知于世间，灭除一切有，
比丘得无忧，心无所染著。

    “世尊，是名比丘，是名比丘功德。”
    佛告迦叶：“善哉善哉！如汝所说。”
    迦叶天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三一八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有迦叶天子，容色绝妙，于后夜时，来诣佛所，稽首佛足，退坐一面。其身光明，遍照祇树给孤独园。
    时彼迦叶天子白佛言：“世尊，我今当说比丘及比丘所说。”
    佛告迦叶天子：“随所乐说。”
    时彼迦叶天子而说偈言：

“比丘守正念，其心善解脱，
昼夜常勤求，逮得离尘垢。
晓了知世间，于尘离尘垢，
比丘无忧患，心无所染著。

    “世尊，是名比丘，是名比丘所说。”
    佛告迦叶：“如是如是，如汝所说。”
    迦叶天子闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三一九）

    如是我闻。一时佛在摩竭提国人间游行，日暮与五百比丘于屈摩夜叉鬼住处宿。
    时屈摩夜叉鬼来诣佛所，稽首佛足，退坐一面。时屈摩夜叉鬼白佛言：“世尊！今请世尊与诸大众于此夜宿。”
    尔时世尊默然受请。
    是时屈摩夜叉鬼知世尊默然受请已，化作五百重阁、房舍、卧床、坐床、踞床，俱摄褥枕各五百具，悉皆化成。化作五百灯明，无诸烟炎。悉化现已，往诣佛所，稽首佛足，劝请世尊，令入其舍，令诸比丘次受房舍及诸卧具。周遍受已，还至佛所，稽首佛足，退坐一面，而说偈言：

“贤德有正念，贤德常正念，
正念安隐眠，此世及他世。
贤德有正念，贤德常正念，
正念安隐眠，其心常寂止。
贤德有正念，贤德常正念，
正念安隐眠，舍降伏他军。
贤德有正念，贤德常正念，
不杀不教杀，不伏不教伏，
慈心于一切，心不怀怨结。”

    尔时世尊告屈摩夜叉鬼：“如是如是，如汝所说。”
    时屈摩夜叉鬼闻佛所说，欢喜随喜，稽首佛足，还自所住处。

（一三二○）

    如是我闻。一时佛住摩鸠罗山，尊者那伽波罗为亲侍者。
    尔时世尊于夜暗时，天小微雨，电光睒现，出于房外，露地经行。
    是时天帝释作是念：“今日世尊住摩鸠罗山，尊者那伽波罗亲侍供养。其夜暗冥，天时微雨，电光睒现。世尊出房，露地经行。我当化作毗琉璃重阁，执持重阁，随佛经行。”作是念已，即便化作毗琉璃重阁，持诣佛所，稽首佛足，随佛经行。
    尔时摩竭提国人，若男若女，夜啼之时，以摩鸠罗鬼恐之即止。亲侍供养弟子之法，侍师禅觉，然后乃眠。尔时世尊为天帝释，夜经行久。尔时尊者那伽波罗作是念：“世尊今夜经行至久，我今当作摩鸠罗鬼形而恐怖之。”时那伽波罗比丘即反被俱执，长毛在外，往住世尊经行道头，白佛言：“摩鸠罗鬼来！摩鸠罗鬼来！”
    尔时世尊告那伽波罗比丘：“汝那伽波罗愚痴人，以摩鸠罗鬼神像恐怖佛耶？不能动如来、应、等正觉一毛发也。如来、应、等正觉，久离恐怖。”
    尔时天帝释白佛言：“世尊，世尊正法律中，亦复有此人耶？”
    佛言：“憍尸迦，瞿昙家中极大广阔，斯等于未来世，亦当使得清净之法。”
    尔时世尊即说偈言：

“若复婆罗门，于自所得法，
得到于彼岸，若一毗舍遮，
及与摩鸠罗，皆悉超过去。
若复婆罗门，于自所行法，
一切诸受觉，观察皆已灭。
若复婆罗门，自法度彼岸，
一切诸因缘，皆悉已灭尽。
若复婆罗门，自法度彼岸，
一切诸人我，皆悉已灭尽。
若复婆罗门，自法度彼岸，
于生老病死，皆悉已超过。”

    佛说此经已，释提桓因闻佛所说，欢喜随喜，稽首佛足，即没不现。

（一三二一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时尊者阿那律陀，于摩竭提国人间游行，到毕陵伽鬼子母住处宿。时尊者阿那律陀夜后分时，端身正坐，诵优陀那、波罗延那、见真谛诸上座所说偈、比丘尼所说偈、尸路偈、义品、牟尼偈、修多罗，悉皆广诵。
    尔时毕陵伽鬼子夜啼，毕陵伽鬼子母为其子说偈呵止言：

“毕陵伽鬼子，汝今莫复啼，
当听彼比丘，诵习法句偈。
若知法句者，能自护持戒，
远离于杀生，实言不妄语，
能自舍非义，解脱鬼神道。”

    毕陵伽鬼子母说是偈时，毕陵伽鬼子啼声即止。

（一三二二）

    如是我闻。一时佛在摩竭提国人间游行，与大众俱，到富那婆薮鬼子母住处宿。
    尔时世尊为诸比丘说四圣谛相应法，所谓苦圣谛、苦集圣谛、苦灭圣谛、苦灭道迹圣谛。
    尔时富那婆薮鬼母儿富那婆薮，及鬼女郁多罗，二鬼小儿夜啼。时富那婆薮鬼母，教其男女故，而说偈言：

“汝富那婆薮，郁多罗莫啼，
令我得听闻，如来所说法。
非父母能令，其子解脱苦，
闻如来说法，其苦得解脱。
世人随爱欲，为众苦所迫，
如来为说法，令破坏生死。
我今欲闻法，汝等当默然。”
时富那婆薮，鬼女郁多罗，
悉受其母语，默然而静听，
语母言：“善哉！我亦乐闻法，
此正觉世尊，于摩竭胜山，
为诸众生类，演说脱苦法。
说苦及苦因，苦灭灭苦道，
从此四圣谛，安隐趣涅槃。
母今但善听，世尊所说法。”

    时富那婆薮鬼母即说偈言：

“奇哉智慧子，善能随我心，
汝富那婆薮，善叹佛导师。
汝富那婆薮，及女郁多罗，
当生随喜心，我已见圣谛。”

    时富那婆薮鬼母说是偈时，鬼子男女随喜默然。

（一三二三）

    如是我闻。一时佛在摩竭提国人间游行，与诸大众至摩尼遮罗鬼住处夜宿。
    尔时摩尼遮罗鬼，会诸鬼神，集在一处。
    时有一女人，持香花鬘饰、饮食，至彼摩尼遮罗鬼神住处。彼女人遥见世尊在摩尼遮罗鬼神住处坐，见已作是念：“我今现见摩尼遮罗鬼神。”即说偈言：

“善哉摩尼遮，住摩伽陀国，
摩伽陀国人，所求悉如愿。
云何于此世，常得安乐住？
后世复云何，而得生天乐？”

    尔时世尊说偈答言：

“莫放逸慢恣，用摩尼鬼为？
若自修所作，能得生天乐。”

    时彼女人作是念：“此非摩尼遮罗鬼，是沙门瞿昙。”如是知已，即以香花鬘饰供养世尊，稽首礼足，退坐一面，而说偈言：

“何道趣安乐，当修何等行，
此世常安隐，后世生天乐？”

    尔时世尊说偈答言：

“布施善调心，乐执护诸根，
正见修贤行，亲近于沙门，
以正命自活，他世生天乐。
何用三十三，诸天之苦网？
但当一其心，断除于爱欲。
我当说离垢，甘露法善听！”

    时彼女人闻世尊说法，示教照喜，如佛常法，谓布施、持戒、生天之福，欲味、欲患、烦恼清净、出要远离、功德福利，次第演说清净佛法。
    譬如鲜净白氎，易染其色。时彼女人亦复如是，即于座上于四圣谛得平等观苦、集、灭、道。时彼女人见法、得法、知法、入法，度诸疑惑，不由于他，于正法律得无所畏。即从座起，整衣服，合掌白佛：“已度，世尊！已度，善逝！我从今日，尽寿命，归佛、归法、归比丘僧。”
    时彼女人闻佛所说，欢喜随喜，礼佛而去。

（一三二四）

    如是我闻。一时佛在摩竭提国人间游行，到针毛鬼住处夜宿。
    尔时针毛鬼会诸鬼神，集在一处。
    时有焰鬼，见世尊在针毛鬼住处夜宿，见已往诣针毛鬼所，语针毛鬼言：“聚落主，汝今大得善利！今如来、应、等正觉，于汝室宿。”
    针毛鬼言：“今当试看，为是如来为非？”
    时针毛鬼与诸鬼神集会已，还归自舍，束身冲佛。尔时世尊却身避之。如是再三，束身冲佛，佛亦再三却身避之。
    尔时针毛鬼言：“沙门怖耶？”
    佛言：“聚落主，我不怖也，但汝触恶。”
    针毛鬼言：“今有所问，当为我说。能令我喜者善，不能令我喜者，当坏汝心，裂汝胸，令汝热血从其面出，捉汝两手掷恒水彼岸！”
    佛告针毛鬼：“聚落主，我不见诸天、魔、梵、沙门、婆罗门、天神、世人，能坏如来、应、等正觉心者，能裂其胸者，能令热血从面出者，执其两臂掷着恒水彼岸者。汝今但问，当为汝说，令汝欢喜。”
    时针毛鬼说偈问佛：

“一切贪恚心，以何为其因？
不乐身毛竖，恐怖从何起？
意念诸觉想，为从何所起，
犹如新生儿，依倚于乳母？”

    尔时世尊说偈答言：

“爱生自身长，如尼拘律树，
展转相拘引，如藤绵丛林。
若知彼所因，当令鬼觉悟，
度生死海流，不复重增有。”

    尔时针毛鬼闻世尊说偈，心得欢喜，向佛悔过，受持三归。
    佛说此经已，针毛鬼闻佛所说，欢喜奉行。


杂阿含经卷第五十

（一三二五）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有优婆夷子，受八支斋，寻即犯戒，即为鬼神所持。
    尔时优婆夷即说偈言：

“十四十五日，及月分八日，
神通瑞应月，八支善正受。
受持于斋戒，不为鬼所持，
我昔数咨问，世尊作是说。”

    尔时彼鬼即说偈言：

“十四十五日，及月分八日，
神足瑞应月，八支修正受。
斋肃清净住，戒德善守护，
不为鬼戏弄，善哉从佛闻！
汝当说言放，我当放汝子。
诸有慢缓业，染污行苦行，
梵行不清净，终不得大果。
譬如拔菅草，执缓则伤手，
沙门行恶触，当堕地狱中。
譬如拔菅草，急捉不伤手，
沙门善摄持，则到般涅槃。”

    时彼鬼神即放优婆夷子。
    尔时优婆夷说偈告子言：

“子汝今听我，说彼鬼神说，
若有慢缓业，秽污修苦行，
不清净梵行，彼不得大果。
譬如拔菅草，执缓则伤手，
沙门起恶触，当堕地狱中。
如急执菅草，则不伤其手，
沙门善执护，逮得般涅槃。”

    时彼优婆夷子如是觉悟已，剃除须发，着袈裟衣，正信非家，出家学道。心不得乐，还归自家。
    母遥见子，而说偈言：

“迈世而出家，何为还聚落？
烧舍急出财，岂还投火中？”

    其子比丘说偈答言：

“但念母命终，存亡不相见，
故来还瞻视，何见子不欢？”

    时母优婆夷说偈答言：

“舍欲而出家，还欲服食之，
是故我忧悲，恐随魔自在。”

    是时优婆夷如是如是发悟其子，如是其子还空闲处，精勤思惟，断除一切烦恼结缚，得阿罗汉果证。

（一三二六）

    如是我闻。一时佛在摩竭提国人间游行，到阿腊鬼住处夜宿。
    时阿腊鬼，集会诸鬼神。
    时有竭昙鬼，见世尊在阿腊鬼住处夜宿，见已至阿腊鬼所，语阿腊鬼言：“聚落主，汝获大利！如来宿汝住处。”
    阿腊鬼言：“生人今日在我舍住耶？今当令知，为是如来，为非如来？”
    时阿腊鬼，诸鬼神聚会毕，还归自家，语世尊曰：“出去，沙门！”
    尔时世尊以他家故，即出其舍。
    阿腊鬼复言：“沙门，来入！”
    佛即还入，以灭慢故。如是再三。
    时阿腊鬼第四复语世尊言：“沙门，出去！”
    尔时世尊语阿腊鬼言：“聚落主！已三见请，今不复出。”
    阿腊鬼言：“今问沙门，沙门答我。能令我喜者善，不能令我喜者，我当坏其心，裂其胸，亦令热血从其面出，执持两手掷着恒水彼岸！”
    世尊告言：“聚落主，我不见诸天、魔、梵、沙门、婆罗门、天神、世人，有能坏我心，裂我胸，令我热血从面而出，执持两手掷着恒水彼岸者。然聚落主，汝今但问，当为汝说，令汝心喜。”
    时阿腊鬼说偈问佛：

“说何等名为，胜士夫事物？
行于何等法，得安乐果报？
何等为美味？云何寿中胜？”

    尔时世尊说偈答言：

“净信为最胜，士夫之事物。
行法得乐果，解脱味中上。
智慧除老死，是为寿中胜。”

    时阿腊鬼复说偈言：

“云何得名称”，如上所说偈。

    尔时世尊说偈答言：

“持戒名称流”，如上所说偈。

    时阿腊鬼复说偈言：

“几法起世间，几法相顺可？
世几法取受，世几法损减？”

    尔时世尊以偈答言：

“世六法等起，六法相顺可，
世六法取受，世六法损减。”

    阿腊鬼复说偈问佛：

“谁能度诸流，昼夜勤方便？
无攀无住处，孰能不沉没？”

    尔时世尊说偈答言：

“一切戒具足，智慧善正受，
正念内思惟，能度难度流。
不乐于五欲，亦超度色爱，
无攀无住处，是能不没溺。”

    时阿腊鬼复说偈问佛：

“以何法度流？以何度大海？
以何舍离苦？以何得清净？”

    尔时世尊说偈答言：

“以信度河流，不放逸度海，
精进能断苦，以慧得清净。
汝当更问余，沙门梵志法，
其法无有过，真谛施调伏。”

    时阿腊鬼复说偈问佛：

“何烦更问余，沙门梵志法，
即曰最胜士，以显大法炬。
于彼竭昙摩，常当报其恩，
告我等正觉，无上导御师。
我即日当行，从村而至村，
亲侍等正觉，听受所说法。”

    佛说此经已，阿腊鬼欢喜随喜，作礼而去。

（一三二七）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有叔迦罗比丘尼，住王园比丘尼众中，为王舍城诸人恭敬供养，如阿罗汉。又于一时，王舍城人于一吉星日，欢集大会。即于是日，阙不供养。
    有一鬼神敬重彼比丘尼故，至王舍城里巷之中，家家说偈：

“王舍城人民，醉酒惛睡卧，
不勤供养彼，叔迦比丘尼。
善修诸根故，名曰叔迦罗，
善说离垢法，涅槃清凉处。
随顺听所说，终日乐无厌，
乘听法智慧，得度生死流，
犹如海商人，依附力马王。”

    时一优婆塞以衣布施叔迦罗比丘尼，复有优婆塞以食供养。
    时彼鬼神即说偈言：

“智慧优婆塞，获福利丰多，
施叔迦罗衣，离诸烦恼故。
智慧优婆塞，获福利丰多，
施叔迦罗食，离诸积聚故。”

    时彼鬼神说斯偈已，即没不现。

（一三二八）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时毗罗比丘尼，住王舍城王园比丘尼众中。
    为王舍城诸人民，于吉星日，集聚大会。当斯之日，毗罗比丘尼无人供养。
    时有鬼神敬重毗罗比丘尼，即入王舍城，处处里巷，四衢道头而说偈言：

“王舍城人民，醉酒惛睡卧，
毗罗比丘尼，无人供养者。
毗罗比丘尼，勇猛修诸根，
善说离垢尘，涅槃清凉法。
皆随顺所说，终日乐无厌，
乘听法智慧，得度生死流。”

    时有一优婆塞持衣布施毗罗比丘尼，复有一优婆塞以食供养。
    时彼鬼神而说偈言：

“智慧优婆塞，今获多福利，
以衣施断缚，毗罗比丘尼。
智慧优婆塞，今获多福利，
食施毗罗尼，离诸和合故。”

    时彼鬼神说偈已，即没不现。

（一三二九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有娑多耆利天神、醯魔波低天神，共作约誓：“若其宫中有宝物出者，必当相语。不相语者，得违约罪。”
    时醯魔波低天神宫中，有未曾有宝波昙摩花出，花有千叶，大如车轮，金色宝茎。
    时醯魔波低天神遣使告语娑多耆利：“聚落主，今我宫中忽生未曾有宝波昙摩花，花有千叶，大如车轮，金色宝茎，可来观看！”
    娑多耆利天神遣使诣醯魔波低舍，告言：“聚落主，用是波昙摩百千为？今我宫中有未曾有宝大波昙摩出，所谓如来、应、等正觉、明行足、善逝、世间解、无上士、调御丈夫、天人师、佛、世尊。汝便可来奉事供养！”
    时醯魔波低天神，即与五百眷属，往诣娑多耆利天神所，说偈问言：

“十五日良时，天夜遇欢会，
当说受何斋，从何罗汉受？”

    时娑多耆利说偈答言：

“今日佛世尊，在摩竭胜国，
住于王舍城，迦兰陀竹园，
演说微妙法，灭除众生苦。
苦苦及苦集，苦灭尽作证，
八圣出苦道，安隐趣涅槃。
当往设供养，我罗汉世尊！”

    醯魔波低说偈问言：

“彼妙心愿乐，慈济众生不？
彼于受不受，心想平等不？”

    娑多耆利说偈答言：

“彼妙愿慈心，度一切众生；
于诸受不受，心想常平等。”

    时醯魔波低说偈问言：

“为具足明达，已行成就不？
诸漏永灭尽，不受后有耶？”

    娑多耆利说偈答言：

“明达善具足，正行已成就；
诸漏永已尽，不复受后有。”

    醯摩波低说偈问言：

“牟尼意行满，及身口业耶？
明行悉具足，以法赞叹耶？”

    娑多耆利说偈答言：

“具足牟尼心，及业身口满；
明行悉具足，以法而赞叹。”

    醯摩波低说偈问言：

“远离于害生，不与不取不？
为远于放荡，不离禅思不？”

    娑多耆利复说偈言：

“常不害众生，不与不妄取；
远离于放荡，日夜常思禅。”

    醯魔波低复说偈问言：

“为不乐五欲，心不浊乱不？
有清净法眼，灭尽愚痴不？”

    娑多耆利说偈答言：

“心常不乐欲，亦无浊乱心；
佛法眼清净，愚痴尽无余。”

    醯魔波低复说偈问言：

“至诚不妄语，粗涩言无有？
得无别离说，无不诚说不？”

    娑多耆利说偈答言：

“至诚不妄语，亦无粗涩言；
不离他亲厚，常说如法言。”

    醯摩波低复说偈问言：

“为持清净戒，正念寂灭不？
具足等解脱，如来大智不？”

    娑多耆利说偈答言：

“净戒悉具足，正念常寂静；
等解脱成就，得如来大智。”

    醯魔波低复说偈问言：

“明达悉具足，正行已清净？
所有诸漏尽，不复受后有？”

    娑多耆利说偈答言：

“明达悉具足，正行已清净；
一切诸漏尽，无复后生有。”

    醯魔波低复说偈言：

“牟尼善心具，及身口业迹，
明行悉成就，故赞叹其法？”

    娑多耆利说偈答言：

“牟尼善心具，及身口业迹，
明行悉成就，赞叹于其法。”

    醯魔波低复说偈言：

“伊尼延鹿腨，仙人之胜相，
少食舍身贪，牟尼处林禅。
汝今当共行，敬礼彼瞿昙！”

    时有百千鬼神眷属围绕，娑多耆利、醯魔波低速至佛所，礼拜供养，整衣服，偏袒右肩，合掌敬礼，而说偈言：

“伊尼延鹿腨，仙人之胜相，
少食无贪嗜，牟尼乐林禅。
我等今故来，请问于瞿昙，
狮子独游步，天龙无恐畏，
今故来请问，牟尼愿决疑！
云何得出苦？云何苦解脱？
唯愿说解脱，苦于何所灭？”

    尔时世尊说偈答言：

“世五欲功德，及说第六意，
于彼欲无贪，解脱一切苦。
如是从苦出，如是解脱苦，
今答汝所问，苦从此而灭。”

    娑多耆利、醯魔波低复说偈问佛：

“泉从何转还？恶道何不转？
世间诸苦乐，于何而灭尽？”

    尔时世尊说偈答言：

“眼耳鼻舌身，及以意入处，
于彼名及色，永灭尽无余。
于彼泉转还，于彼道不转，
于彼苦及乐，得无余灭尽。”

    娑多耆利、醯魔波低复说偈问佛：

“世间几法起？几法世和合？
几法取受世？几法令世灭？”

    尔时世尊说偈答言：

“六法起世间，六法世和合，
六法取受世，六法世损减。”

    娑多耆利、醯魔波低复说偈问佛：

“云何度诸流，日夜勤方便？
无攀无住处，而不溺深渊？”

    尔时世尊说偈答言：

“一切戒具足，智慧善正受，
如思惟系念，是能度深渊。
不乐诸欲想，亦超色诸结，
无攀无住处，不溺于深渊。”

    娑多耆利、醯魔波低复说偈问佛：

“何法度诸流？以何度大海？
云何舍离苦？云何得清净？”

    尔时世尊说偈答言：

“正信度河流，不放逸度海，
精进能断苦，智慧得清净。”

    尔时世尊复说偈言：

“汝可更问余，沙门梵志法，
真实施调伏，除此更无法。”

    醯魔波低复说偈言：

“更余何所问，沙门梵志法，
大精进今日，已具善开导。
我今当报彼，娑多耆利恩，
能以导御师，告语于我等。
我当诣村村，家家而随佛，
承事礼供养，从佛闻正法。
此百千鬼神，悉合掌恭敬，
一切归依佛，牟尼之大师！
得无上之名，必见真实义，
成就大智慧，于欲不染著。
慧者当观察，救护世间者，
得贤圣道迹，是则大仙人。”

    佛说是经已，娑多耆利、醯魔波低及诸眷属五百鬼神，闻佛所说，皆大欢喜随喜，礼佛而去。

（一三三○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者舍利弗、尊者大目揵连，住耆阇崛山中。
    时尊者舍利弗新剃须发。
    时有伽吒，及优波伽吒鬼。优波伽吒鬼见尊者舍利弗新剃须发，语伽吒鬼言：“我今当往，打彼沙门头！”
    伽吒鬼言：“汝优波伽吒，莫作是语！此沙门大德大力，汝莫长夜得大不饶益苦。”如是再三说。
    时优波伽吒鬼再三不随伽吒鬼语，即以手打尊者舍利弗头，打已寻自唤言：“烧我，伽吒！煮我，伽吒！”再三唤已，陷入地中，堕阿毗地狱。
    尊者大目揵连闻尊者舍利弗为鬼所打声已，即往诣尊者舍利弗所，问尊者舍利弗言：“云何尊者，苦痛可忍不？”
    尊者舍利弗答言：“尊者大目揵连，虽复苦痛，意能堪忍，不至大苦。”
    尊者大目揵连语尊者舍利弗言：“奇哉！尊者舍利弗，真为大德大力。此鬼若以手打耆阇崛山者，能令碎如糠糟，况复打人而不苦痛！”
    尔时尊者舍利弗语尊者大目揵连：“我实不大苦痛。”
    时尊者舍利弗、大目揵连共相慰劳。
    时世尊以天耳闻其语声，闻已即说偈言：

“其心如刚石，坚住不倾动，
染著心已离，瞋者不反报，
若如此修心，何有苦痛处！”

    佛说此经已，诸比丘闻佛所说，欢喜奉行。

（一三三一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有众多比丘于拘萨罗国人间游行，住一林中夏安居。
    彼林中有天神住，知十五日诸比丘受岁，极生忧戚。
    有余天神语彼天神言：“汝何卒生愁忧苦恼？汝当欢喜，诸比丘持戒清净，今日受岁。”
    林中天神答言：“我知比丘今日受岁，不同无羞外道受岁。然精进比丘受岁，持衣钵明日至余处去，此林当空！”
    比丘去后，林中天神而说偈言：

“今我心不乐，但见空林树。
清净心说法，多闻诸比丘，
瞿昙之弟子，今悉何处去？”

    时有异天子而说偈言：

“有至摩伽陀，有至拘萨罗，
亦至金刚地，处处修远离，
犹如野禽兽，随所乐而游。”

（一三三二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时有异比丘在拘萨罗国人间，止住一林中，入昼正受，身体疲极，夜则睡眠。
    时彼林中止住天神作是念：“此非比丘法，于空林中入昼正受，夜著睡眠。我今当往觉悟之。”
    尔时天神往至比丘前，而说偈言：

“比丘汝起起，何以著睡眠！
睡眠有何利，病时何不眠？
利刺刺身时，云何得睡眠？
汝本舍非家，出家之所欲，
当如本所欲，日夜求增进，
莫得堕睡眠，令心不自在。
无常不恒欲，迷醉于愚夫，
余人悉被缚，汝今已解脱，
正信而出家，何以著睡眠？
已调伏贪欲，其心得解脱，
具足胜妙智，出家何故眠？
勤精进正受，常修坚固力，
专求般涅槃，云何而睡眠？
起明断无明，灭尽诸有漏，
调彼后边身，云何著睡眠？”

    时彼天神说是偈时，彼比丘闻其所说，专精思惟，得阿罗汉。

（一三三三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘在拘萨罗，住林中，入昼正受，心起不善觉，依于恶贪。
    时彼林中住止天神作是念：“此非比丘法，止住林中，入昼正受，心生不善觉，依于恶贪。我今当往开悟之。”
    时彼天神即说偈言：

“其心欲远离，止于空闲林，
放心随外缘，乱想而流驰。
调伏乐世心，常乐心解脱，
当舍不乐心，执受安乐住。
思非于正念，莫著我我所，
如以尘头染，是著极难遣，
莫令染乐著，欲心所浊乱。
如释君驰象，奋迅去尘秽，
比丘于自身，正念除尘垢。
尘者谓贪欲，非世间尘土，
黠慧明智者，当悟彼诸尘，
于如来法律，持心莫放逸。
尘垢谓瞋恚，非世间尘土，
黠慧明智者，当悟彼诸尘，
于如来法律，持心莫放逸。
尘垢谓愚痴，非世间尘土，
明智黠慧者，当舍彼诸尘，
于如来法律，持心莫放逸。”

    时彼天神说是偈已，彼比丘闻其所说，专精思惟，断诸烦恼，得阿罗汉。

（一三三四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘在拘萨罗人间，住一林中，入昼正受，起不正思惟。
    时彼林中止住天神作是念：“此非比丘法，止住林中，入昼正受，而起不正思惟。我今当往方便善觉悟之。”
    时彼天神而说偈言：

“何不正思惟，觉观所寝食？
当舍不正念，专修于正受。
尊崇佛法僧，及自持净戒，
常生随喜心，喜乐转胜进，
以心欢喜故，速究竟苦边。”

    时彼天神说偈劝发已，彼比丘专精思惟，尽诸烦恼，得阿罗汉。

（一三三五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘，于拘萨罗人间，住一林中，入昼正受。
    时彼比丘日中时，不乐心生，而说偈言：

“于此日中时，众鸟悉静默，
空野忽有声，令我心恐怖。”

    时彼林中住止天神而说偈言：

“于今日中时，众鸟悉寂静，
空野忽有声，应汝不乐心。
汝当舍不乐，专乐修正受！”

    时彼天子说偈觉悟彼比丘已，时彼比丘专精思惟，舍除烦恼，得阿罗汉。

（一三三六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    尔时尊者阿那律陀，在拘萨罗人间，住一林中。
    时有天神名阇邻尼，是尊者阿那律陀本善知识，往诣尊者阿那律陀所。到阿那律所，而说偈言：

“汝今可发愿，愿还生本处，
三十三天上，五欲乐悉备，
百种诸音乐，常以自欢娱。
每至睡眠时，音乐以觉悟，
诸天玉女众，昼夜侍左右。”

    尊者阿那律说偈答言：

“诸天玉女众，此皆大苦聚，
以彼颠倒想，系著有身见，
诸求生彼者，斯亦是大苦。
阇邻尼当知，我不愿生彼，
生死已永尽，不受后有故。”

    尊者阿那律说是语时，阇邻尼天子闻尊者阿那律所说，欢喜随喜，即没不现。

（一三三七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有比丘在拘萨罗人间，林中止住，勤诵经，勤讲说，精勤思惟。得阿罗汉果证已，不复精勤诵说。
    时有天神止彼林中者，而说偈言：

“比丘汝先时，昼夜勤诵习，
常为诸比丘，共论决定义。
汝今于法句，寂然无所说，
不与诸比丘，共论决定义。”

    时彼比丘说偈答言：

“本未应离欲，心常乐法句，
既离欲相应，诵说事已毕。
先知道已备，用闻见道为？
世间诸闻见，无如悉放舍。”

    时彼天神闻比丘所说，欢喜随喜，即没不现。

（一三三八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘在拘萨罗人间，止一林中。
    时彼比丘有眼患，受师教，应嗅钵昙摩花。时彼比丘受师教已，往至钵昙摩池侧，于池岸边迎风而坐，随风嗅香。
    时有天神主此池者，语比丘言：“何以盗花？汝今便是盗香贼也。”
    尔时比丘说偈答言：

“不坏亦不夺，远住随嗅香，
汝今何故言，我是盗香贼？”

    尔时天神复说偈言：

“不求而不舍，世间名为贼。
汝今人不与，而自一向取，
是则名世间，真实盗香贼。”

    时有一士夫取彼藕根，重负而去。
    尔时比丘为彼天神而说偈言：

“如今彼士夫，断截分陀利，
拔根重负去，便是奸狡人。
汝何故不遮，而言我盗香？”

    时彼天神说偈答言：

“狂乱奸狡人，犹如乳母衣，
何足加其言，且堪与汝语。
袈裟污不现，黑衣墨不污，
奸狡凶恶人，世间不与语。
蝇脚污素帛，明者小过现，
如墨点珂贝，虽小悉皆现。
常从彼求净，无结离烦恼，
如毛发之恶，人见如泰山。”

    时彼比丘复说偈言：

“善哉善哉说，以义安慰我，
汝可常为我，数数说斯偈。”

    时彼天神复说偈言：

“我非汝买奴，亦非人与汝，
何为常随汝，数数相告语？
汝今自当知，彼彼饶益事。”

    时彼天子说是偈已，彼比丘闻其所说，欢喜随喜，从座起去。独一静处，专精思惟，断诸烦恼，得阿罗汉。

（一三三九）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    尔时尊者十力迦叶，住王舍城仙人窟中。时有猎师名曰尺只，去十力迦叶不远，张网捕鹿。
    尔时十力迦叶为彼猎师哀愍说法，时彼猎师不解所说。时十力迦叶即以神力，指端火燃，彼犹不悟。
    尔时仙人窟中住止天神而说偈言：

“深山中猎师，少智盲无目，
何为非时说，薄德无辩慧。
所闻亦不解，明中亦无见，
于诸善胜法，愚痴莫能了。
正使烧十指，彼终不见谛。”

    时彼天神说是偈已，尊者十力迦叶即默然住。

（一三四○）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有尊者金刚子，住巴连弗邑，一处林中。
    时巴连弗邑人民，夏四月过，作憍牟尼大会。
    时尊者金刚子闻世间大会，生不乐心，而说偈言：

“独一处空林，犹如弃枯木，
夏时四月满，世间乐庄严，
普观诸世间，甚苦无过我。”

    尔时林中住止天神即说偈言：

“独一处空林，犹如弃枯木，
为三十三天，心常所愿乐，
犹如地狱中，仰思生人道。”

    时金刚子为彼天神所劝发已，专精思惟，断诸烦恼，得阿罗汉。

（一三四一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘在拘萨罗人间，住一林中，唯好乐持戒，不能增长上进功德。
    时彼林中止住天神作是念：“此非比丘法，住于林中，唯乐持戒，不能增修上进功德。今我当作方便而发悟之。”
    即说偈言：

“非一向持戒，及修习多闻，
独静禅三昧，闲居修远离。
比丘偏猗息，终不得漏尽，
平等正觉乐，远非凡夫辈。”

    时彼比丘为天神劝进已，专精思惟，断诸烦恼，得阿罗汉。

（一三四二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    有尊者那迦达多，在拘萨罗人间，住一林中，有在家、出家，常相亲近。
    时彼林中止住天神作是念：“此非比丘法，住于林中，与诸在家、出家周旋亲数。我今当往方便发悟。”
    而说偈言：

“比丘旦早出，迫暮而还林，
道俗相习近，苦乐必同安，
恐起家放逸，而随魔自在。”

    时那迦达多比丘，为彼天神如是如是开觉已，如是如是专精思惟，断诸烦恼，得阿罗汉。

（一三四三）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有众多比丘，在拘萨罗人间，住一林中，言语嬉戏，终日散乱，心不得定，纵诸根门，驰骋六境。
    时彼林中止住天神，见是比丘不摄威仪，心不欣悦，而说偈言：

“此先有瞿昙，正命弟子众，
无常心乞食，无常受床卧，
观世无常故，得究竟苦边。
今有难养众，沙门所居止，
处处求饮食，遍游于他家，
望财而出家，无真沙门欲，
垂着僧伽梨，如老牛曳尾。”

    尔时比丘语天神言：“汝欲厌我耶？”
    时彼天神复说偈言：

“不指其名姓，不非称其人，
而总向彼众，说其不善者。
疏漏相现者，方便说其过，
勤修精进者，归依恭敬礼。”

    彼诸比丘为天神劝发已，专精思惟，断诸烦恼，得阿罗汉。

（一三四四）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘在拘萨罗人间，住一林中。时彼比丘与长者妇女嬉戏，起恶名声。
    时彼比丘作是念：“我今不类，共他妇女起恶名声。我今欲于此林中自杀。”
    时彼林中止住天神作是思念：“不善不类！此比丘不坏无过，而于林中欲自杀身。我今当往方便开悟。”
    时彼天神化作长者女身，语比丘言：“于诸巷路四衢道中，世间诸人为我及汝起恶名声，言我与汝共相习近，作不正事。已有恶名，今可还俗，共相娱乐。”
    比丘答言：“以彼里巷四衢道中，为我与汝起恶名声，共相习近，为不正事。我今且自杀身。”
    时彼天神还复天身，而说偈言：

“虽闻多恶名，苦行者忍之，
不应苦自害，亦不应起恼。
闻声恐怖者，是则林中兽，
是轻躁众生，不成出家法。
仁者当堪耐，不中住恶声，
执心坚住者，是则出家法。
不由他人语，令汝成劫贼，
亦不由他语，令汝得罗汉。
如汝自知已，诸天亦复知。”

    尔时比丘为彼天神所开悟已，专精思惟，断除烦恼，得阿罗汉。

（一三四五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有尊者见多比丘，在拘萨罗人间，住一林中，着粪扫衣。
    时梵天王与七百梵天，乘其宫殿，来诣尊者见多比丘所，恭敬礼事。
    时有天神住彼林中者，而说偈言：

“观彼寂诸根，能感善供养，
具足三明达，得不倾动法，
度一切方便，少事粪扫衣。
七百梵天子，乘宫来奉诣，
见生死有边，今礼度有岸。”

    时彼天神说偈赞叹见多比丘已，即没不现。

（一三四六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘在拘萨罗人间，住一林中。时彼比丘身体疲极，夜著睡眠。
    时有天神住彼林中者，而觉悟之，即说偈言：

“可起起比丘，何故著睡眠！
睡眠有何义，修禅莫睡眠。”

    时彼比丘说偈答言：

“不肯当云何，懈怠少方便，
缘尽四体羸，夜则著睡眠。”

    时彼天神复说偈言：

“且汝当执守，勿声而大呼，
汝已得修闲，莫令其退没。”

    时彼比丘说偈答言：

“我当用汝语，精勤修方便，
不为彼睡眠，数数覆其心。”

    时彼天神如是如是觉悟彼比丘，时彼比丘专精方便，断诸烦恼，得阿罗汉。
    时彼天神复说偈言：

“汝岂能自起，专精勤方便，
不为众魔军，厌汝令睡眠？”

    时彼比丘说偈答言：

“从今当七夜，常坐正思惟，
其身生喜乐，无一处不满。
初夜观宿命，中夜天眼净，
后夜除无明，见众生苦乐。
上中下形类，善色及恶色，
知何业因缘，而受斯果报。
若士夫所作，所作还自见，
善者见其善，恶者自见恶。”

    时彼天神复说偈言：

“我知先一切，比丘十四人，
皆是须陀洹，悉得禅正受，
来到此林中，当得阿罗汉。
见汝一懈怠，仰卧著睡眠，
莫令住凡夫，故方便觉悟。”

    尔时比丘复说偈言：

“善哉汝天神，以义安慰我，
至诚见开觉，令我尽诸漏。”

    时彼天神复说偈言：

“比丘应如是，信非家出家，
抱愚而出家，逮得见清净。
我今摄受法，当尽寿命思，
若汝疾病时，我当与良药。”

    时彼天神说是偈已，即没不现。

（一三四七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时尊者舍利弗，在拘萨罗人间，依一聚落，止住田侧。时尊者舍利弗，于晨朝时着衣持钵，入村乞食。
    时有一尼揵子，饮酒狂醉，持一瓶酒从聚落出，见尊者舍利弗，而说偈言：

“米膏熏我身，持米膏一瓶，
山地草树木，视之一金色。”

    尔时尊者舍利弗作是念：“作此恶声，是恶邪物而说是偈，我岂不能以偈答之！”
    时尊者舍利弗即说偈言：

“无想味所熏，持空三昧瓶，
山地草树木，视之如涕唾。”

（一三四八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘在拘萨罗人间，住一林中，得他心智，烦恼有余。
    去林下不远有井，有饮野干，罐拘钩颈。时彼野干，作诸方便求脱，而自念言：“天遂欲明，田夫或出，当恐怖我。汝汲水罐，怖我已久，可令我脱！”
    时彼比丘知彼野干心之所念，而说偈言：

“如来慧日出，离林说空法，
心久恐怖我，今可放令去。”

    时彼比丘自教授已，一切结尽，得阿罗汉。

（一三四九）

    如是我闻。一时佛在拘萨罗国人间游行，住一林中。
    时有天神依彼林者，见佛行迹，低头谛观，修于佛念。
    时有优楼鸟，住于道中，行欲蹈佛足迹。
    尔时天神即说偈言：

“汝今优楼鸟，团目栖树间，
莫乱如来迹，坏我念佛境。”

    时彼天神说此偈已，默然念佛。

（一三五○）

    如是我闻。一时佛在拘萨罗人间，住一林中，依波吒利树下住止。
    时有天神依彼林中住，即说偈言：

“今日风卒起，吹波吒利树，
落波吒利花，供养于如来。”

    时彼天神说偈已，默然而住。

（一三五一）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有众多比丘住支提山侧，皆是阿练若比丘，着粪扫衣，常行乞食。
    时山神依彼山住者，而说偈言：

“孔雀文绣身，处鞞提醯山，
随时出妙声，觉乞食比丘。
孔雀文绣身，处鞞提醯山，
随时出妙声，觉粪扫衣者。
孔雀文绣身，处鞞提醯山，
随时出妙声，觉依树坐者。”

    时彼天神说此偈已，即默然住。

（一三五二）

    如是我闻。一时佛住王舍城迦兰陀竹园。
    时有众多比丘住支提山，一切皆修阿兰若行，着粪扫衣，常行乞食。
    尔时那娑佉多河岸崩，杀三营事比丘。
    时支提山住天神而说偈言：

“乞食阿兰若，慎莫营造立，
不见佉多河，傍岸卒崩倒，
压杀彼造立，营事三比丘。
粪扫衣比丘，慎莫营造立，
不见佉多河，傍岸卒崩倒，
压杀彼造立，营事三比丘。
依树下比丘，慎莫营造立，
不见佉多河，傍岸卒崩倒，
压杀彼造立，营事三比丘。”

    时彼天神说此偈已，即默然住。

（一三五三）

    如是我闻。一时佛住迦兰陀竹园。
    时有异比丘，住频陀山。
    尔时山林大火卒起，举山洞燃。时有俗人而说偈言：

“今此频陀山，大火洞炽燃，
焚烧彼竹林，亦烧竹花实。”

    时彼比丘作是念：“今彼俗人能说此偈，我今何不说偈答之？”
    即说偈言：

“一切有炽燃，无慧能救灭，
焚烧诸受欲，亦烧不作苦。”

    时彼比丘说此偈已，默然而住。

（一三五四）

    如是我闻。一时佛住迦兰陀竹园。
    时有异比丘在恒河侧，住一林中。
    时有一族姓女，常为舅姑所责，至恒水岸边，而说偈言：

“恒水我今欲，随流徐入海，
不复令舅姑，数数见嫌责。”

    时彼比丘见族姓女，闻其说偈，作是念：“彼族姓女尚能说偈，我今何为不说偈答耶？”
    即说偈言：

“净信我今欲，随彼八圣水，
徐流入涅槃，不见魔自在。”

    时彼比丘说此偈已，默然而住。

（一三五五）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘在拘萨罗人间，住一林中。
    去林不远，有种瓜田。时有盗者夜偷其瓜，见月欲出，而说偈言：

“明月汝莫出，待我断其瓜，
我持瓜去已，任汝现不现。”

    时彼比丘作是念：“彼盗瓜者尚能说偈，我岂不能说偈答耶？”
    即说偈言：

“恶魔汝莫出，待我断烦恼，
断彼烦恼已，任汝出不出。”

    时彼比丘说此偈已，默然而住。

（一三五六）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘在拘萨罗人间，住一林中。
    时有沙弥而说偈言：

“云何名为常？乞食则为常。
云何为无常？僧食为无常。
云何名为直？唯因陀罗幢。
云何名为曲？曲者唯见钩。”

    时彼比丘作是念：“此沙弥能说斯偈，我今何不说偈而答？”
    即说偈言：

“云何名为常？常者唯涅槃。
云何为无常？谓诸有为法。
云何名为直？谓圣八正道。
云何名为曲？曲者唯恶径。”

    时彼比丘说此偈已，默然而住。

（一三五七）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有舍利弗弟子，服药已，寻即食粥。
    时尊者舍利弗到瓦师舍，从乞瓦瓯。
    时彼瓦师即说偈言：

“云何得名胜，而不施一钱？
云何胜实德，于财无所减？”

    尔时舍利弗说偈答言：

“若不食肉者，而施彼以肉；
诸修梵行者，施之以女色；
不坐高床者，施以高广床；
于彼临行者，施以息止处。
如是等施与，于财不损减，
是则有名誉，而不舍一钱。
实德名称流，于财无所减。”

    时彼瓦师复说偈言：

“汝今舍利弗，所说实为善，
今施汝百瓯，非余亦不得。”

    尊者舍利弗说偈答言：

“彼三十三天，炎摩兜率陀，
化乐诸天人，及他化自在，
瓦钵信以得，而汝不生信。”

    尊者舍利弗说此偈已，于瓦师舍默然出去。

（一三五八）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘在拘萨罗人间，住一林中。
    时有贫士夫在于林侧，作如是希望思惟，而说偈言：

“若得猪一头，美酒满一瓶，
盛持瓯一枚，人数数持与，
若得如是者，当复何所忧！”

    时彼比丘作是念：“此贫士夫尚能说偈，我今何以不说？”
    即说偈言：

“若得佛法僧，比丘善说法，
我不病常闻，不畏众魔怨。”

    时彼比丘说此偈已，默然而住。

（一三五九）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘在拘萨罗人间，住一林中。时彼比丘作如是思惟：“若得好劫贝，长七肘，广二肘，作衣已，乐修善法。”
    时有天神依彼林者，作是念：“此非比丘法，住于林中，作是思惟希望好衣。”
    时天神化作全身骨锁，于彼比丘前舞，而说偈言：

“比丘思劫贝，七肘广六尺，
昼则如是想，知夜何所思？”

    时彼比丘即生恐怖，其身战悚，而说偈言：

“止止不须氎，今着粪扫衣，
昼见骨锁舞，知夜复何见！”

    时彼比丘心惊怖已，即正思惟，专精修习，断诸烦恼，得阿罗汉。

（一三六○）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘在拘萨罗人间，住一林中，得阿罗汉，诸漏已尽，所作已作，已舍重担，断诸有结，正智心善解脱。
    时有一女人，于夜暗中，天时微雨，电光睒照，于林中过，欲诣他男子。倒深泥中，环钏断坏，花璎散落。
    时彼女人而说偈言：

“头发悉散解，花璎落深泥，
镮钏悉破坏，丈夫何所着？”

    时彼比丘作是念：“女人尚能说偈，我岂不能说偈答之？

“烦恼悉断坏，度生死淤泥，
着缠悉散落，十方尊见我。”

    时彼比丘说偈已，即默然而住。

（一三六一）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘在拘萨罗人间，住于河侧一林树间。
    时有丈夫与妇相随，度河住于岸边，弹琴嬉戏，而说偈言：

“爱念而放逸，逍遥青树间，
流水流且清，琴声极和美，
春气调适游，快乐何过是！”

    时彼比丘作是念：“彼士夫尚能说偈，我岂不能说偈答之？

“受持清净戒，爱念等正觉，
沐浴三解脱，善以极清凉，
入道具庄严，快乐岂过是！”

    时彼比丘说此偈已，即默然而住。

（一三六二）

    如是我闻。一时佛住舍卫国祇树给孤独园。
    时有异比丘在拘萨罗人间，住一林中。
    时有天神见诸鸽鸟，而说偈言：

“鸽鸟当积聚，胡麻米粟等，
于山顶树上，高显作巢窟，
若当天雨时，安极饮食宿。”

    时彼比丘作是念：“彼亦觉悟我。”
    即说偈言：

“凡夫积善法，恭敬于三宝，
身坏命终时，资神心安乐。”

    时彼比丘说此偈已，以即觉悟，专精思惟，除诸烦恼，得阿罗汉。


校勘记

《杂阿含经》校勘记

    在《四阿含》中，《杂阿含经》是僧团中用于传授禅修方法的一部重要典籍。“阿含”，译作“教”、“无比法”、“法归”，是全面汇集佛陀言教的圣典。“杂”，是分门别类纂集之意。本经以禅修理论和方法为核心，以出世解脱为归趣，真实记录佛陀及其圣弟子的日常言行，由一千多篇经文纂集而成。其时间跨度自佛陀在尼连禅河侧菩提树下降魔成道起，至双树林间灭度后不久为止。此外还有对后世阿育王护持正法，及未来佛法灭尽的预言。
    此经梵本由东晋时法显法师在师子国求得，刘宋元嘉年间由天竺三藏法师求那跋陀罗译出，宝云传译，慧观笔受。由于一些未知的原因，现存的《杂阿含经》品名不全，各卷前后次序也有一些不顺。全经共五十卷，主要内容为：
    1、五阴诵：包括卷一、卷二、卷三、卷五、卷六、卷七、卷十，共七卷，阐明色、受、想、行、识五阴，无常、苦、空、非我的本质，以破除凡夫爱染执著。
    2、六入处诵：包括卷八、卷九、卷十一、卷十三、卷四十三，共五卷，从内六入、外六尘及六识、六触、六受、六想、六思、六爱等各方面，反复阐明无常、苦、空、非我，破除爱见。
    3、杂因诵：包括卷十二、卷十四、卷十五、卷十六、卷十七，共五卷，阐述四圣谛、十二因缘、十八界、三受等法要。
    4、弟子所说诵：包括卷十八、卷十九、卷二十、卷二十一，共四卷，记述佛陀大弟子舍利弗、大目揵连、阿那律、摩诃迦旃延、阿难等的言教，及在家弟子质多罗长者护法言行。
    5、道品诵：包括卷二十四、卷二十六、卷二十七、卷二十八、卷二十九、卷三十，共六卷，阐述四念处、四正断、四如意足、五根、五力、七觉支、八圣道等三十七道品法，及安那般那念、三学、四不坏净等法要。
    6、如来所说诵：包括卷三十一、卷三十二、卷三十三、卷三十四、卷三十五、卷三十七、卷四十一、卷四十七，共八卷，记述佛陀阐释修行要义、修证品位、轮回可畏、人天因果，以及赞扬摩诃迦叶头陀行、教化训诫诸外道、瞻视患病比丘及在家弟子等事。
    7、八众诵：包括卷四、卷二十二、卷三十六、卷三十八、卷三十九、卷四十、卷四十二、卷四十四、卷四十五、卷四十六、卷四十八、卷四十九、卷五十，共十三卷，记述佛陀以偈颂概述法义、破斥魔波旬留难、称赞帝释善行、为波斯匿王说法、教化诸婆罗门、答天人所问、教化诸鬼神，以及梵天护持佛法、诗僧婆耆舍的诗章、诸比丘尼破斥波旬留难、林中比丘与护法神应答等事。
    8、悬记：卷二十三、卷二十五，记述佛陀对后世阿育王护持正法，及未来佛法灭尽的预言。
    在《杂阿含经》各卷中，佛陀从五阴、六入处、十八界等各个层面，对众生感知周围世界的心理过程作了清晰的描述，揭示出正是由于对种种外境的贪爱迷执，使得众生对真、妄、苦、乐的判断产生错觉，从而无力自拔，不断作出错误取舍，导致个体生命长久陷入相续轮回的痛苦深渊。如第九三七至九五六经所述，众生自无始以来一直长夜轮转于生死之中，所流身血、泪水，所饮母乳，多于四大海水；即使是一劫之中的白骨，积聚在一起也将如一座毗富罗山，这是多么令人痛憾的事实！只有归依佛法，悟明生命本质，趣入解脱正道，专注修持，才能于一切境界不生爱染执著，永脱轮回，得到彻底的清净自在。
    此外，佛陀还应在家弟子的请求，广泛论及世间生活所应遵循的准则，如行孝、持家、布施、息瞋等等，显示了人天导师的智慧与悲心，这些都散见于各卷之中。
    今天的我们离佛陀入灭已经很久了，对于那个时候的记忆也越来越模糊。在这个物欲横流的喧嚣世界中，重温我们的本师——伟大的佛陀在僧团中的榜样和清净教诲，对于我们这些末世弟子，无疑意义重大。人类已经步入二十一世纪，在这个人们曾经憧憬的新世纪里，似乎并没有多少新的福音，而恐怖、战争、疾疫与巨大的自然灾害却接踵而至。由于背离了圣者的教诲，人类的思想与生活正卷入更大的混乱之中，严重的杀生、淫佚与环境污染，必然导致更为猛烈的疾疫和灾害。地球的资源日趋枯竭，必将走向物质繁荣的尽头。透过科学进步的外表，人们仍旧为自私和贪欲所驱使，不可避免地面对着衰老、疾病、死亡、六道轮回，生与死仍是人类社会生活的主旋律，也是每个人心中永远的痛楚。
    翻开经卷，伟大的佛陀对人类的忠告，清晰而庄重。那充满睿智的言教，如云散月出，清凉真实，是一切时代众生生命的甘泉。他向我们阐明了宇宙的本质、自性的庄严、众生的归宿，令人明因识果，改过迁善，求生净土。释迦如来在十方诸佛中以勇猛著称，其普度众生的悲愿历时长新，永不磨灭。
    本经校勘历时数月，以《大正藏》电子本与《乾隆大藏经》PDF文件逐字对校，在印顺法师《杂阿含经论会编》校本的基础上，做了进一步的文字订正、详细标点与分段，使经文更适于阅读。虽然本经现存原本卷次编排不顺，但经反复斟酌，此校本仍按原典卷次不变。《大正藏》本所列各经序数，虽然有些不够严谨，也未再加以改动。各卷文字勘正情况，为避免繁琐不再列出。其全经内容结构、品名章次，读者可认真参阅本文所列的全经内容提要，详细请查阅印顺法师《杂阿含经论会编》。
    本经虽属小乘经藏，却不啻一付清心剂和清醒剂，是那些深染世俗而以大乘自居者的对症良药。反复校阅，不禁尘念顿止，每日拜佛念佛又恳切了许多。

净业学人张景岗 谨记
2005年11月于北京清凉书屋